Help

What would you like to learn about?

getting started...

  • Quick Start Guide
  • Creating an Index
  • Searching an Index

a closer look...

  • Features
  • Examples
  • API Documentation

about...

  • Release Notes
  • License Keys
  • Upgrading From Prior Versions
  • Online Support Forum
  • Online KB

Please use the table of contents on the left to explore even more about SearchUnit.


SearchUnit Documentation: Terms & Conditions

Terms & Conditions

If you do not agree to these terms and conditions then you may not install, use, or distribute SearchUnit.
1. License and Ownership. SearchUnit is a licensed software product. SearchUnit, including its accompanying files and documentation, is owned and copyrighted by Keyoti Inc., © Copyright 2005-2016, all rights reserved. Keyoti Inc. grants the user in possession of an official receipt of purchase a nonexclusive license to download and use the software, for any lawful commercial or noncommercial purposes provided the terms of this agreement are met.
2. Development and Distribution.
If you purchased an Enterprise License Version of Search for ASP.NET, then you may provide copies of the SearchUnit distribution file (.zip/.msi) to anyone employed by your company. These individuals then have license rights and responsibilities equivalent to the One Developer License Version.
If you purchased a One Developer License Version then you may copy and use the SearchUnit distribution file (.zip) on any systems you use but for your development use only. If you purchased a multi developer license version then the number of developers specified in the license type are afforded the rights of a One Developer License. Development use is defined as one person having the ability to read or copy any of the files originally contained in the SearchUnit distribution file including (but not limited to) the .dll, .csc, .html, .gif, .jpg, .bat, and .txt files. You must take appropriate safeguards to protect this product from unauthorized access by others. If you purchased a Site License Version of SearchUnit, then you may provide copies of the SearchUnit distribution file (.zip) to anyone employed by your company whose primary work address is within a 100 mile (160 km) radius of your primary work address. These individuals then have license rights and responsibilities equivalent to the Developer License Version. In all cases the copies of the SearchUnit distribution file (.zip/.msi) must be unaltered and complete, including this license agreement and all copyright notices.
The evaluation version must not be re-distributed in any form. You may not reverse engineer, disassemble, decompile, or modify this software or its accompanying documentation in any way. You may reproduce and redistribute a copy of the dll files as part of any .NET based software developed and licensed by you that itself uses SearchUnit provided
a) your software is installed on no more web-site domains or servers than specified by the license type purchased,
b) your software has clearly distinct and added functionality,
c) you are responsible for all technical support,
d) the SearchUnit application programming interfaces are not documented, exposed, or otherwise made available by your software,
e) attribution is given to Keyoti Inc. (http://www.keyoti.com) in any documentation or screen displays where other credits appear,
f) you do not allow recipients of your software to reverse engineer, disassemble, decompile, or copy portions from your software allowing them to gain separate access to SearchUnit or any parts of it.
The source code samples included with this package and in the SearchUnit documentation may be freely used, modified, incorporated, and distributed without restriction as part of any software that uses SearchUnit itself,
g) your software is not used by software or web developers as part of their application, and
h) your software is not a software component, 'Web Control' or 'Server Control'.
3. Warranty Disclaimer and Limitation of Liability. Search for ASP.NET is licensed to the user on an "AS IS" basis. Keyoti Inc. MAKES NO WARRANTIES, EITHER EXPRESSED OR IMPLIED, WITH RESPECT TO THIS SOFTWARE AND ITS ASSOCIATED FILES AND DOCUMENTATION, INCLUDING BUT NOT LIMITED TO ANY WARRANTY OF MERCHANTABILITY OR FITNESS FOR ANY PARTICULAR PURPOSE. KEYOTI INC. DOES NOT WARRANT THAT THE OPERATION OF THIS SOFTWARE WILL BE UNINTERRUPTED OR ERROR FREE, OR THAT DEFECTS WILL BE CORRECTED. You the user are solely responsible for determining the appropriateness of this software for your use and accept full responsibility for all risks associated with its use. Keyoti Inc. is not and will not be liable for any direct, indirect, special or incidental damages in any amount including loss of profits or interruption of business however caused, even if Keyoti Inc. has been advised of the possibility of such damages. Keyoti Inc. retains the right to, in its sole discretion, refund the purchase price of this software as a complete and final resolution to any dispute.
SPECIFIC DISCLAIMER FOR HIGH-RISK ACTIVITIES. The SOFTWARE is not designed or intended for use in high-risk activities including, without restricting the generality of the foregoing, on-line control of aircraft, air traffic, aircraft navigation or aircraft communications; or in the design, construction, operation or maintenance of any nuclear facility. Keyoti Inc. and its suppliers specifically disclaim any express or implied warranty of fitness for such purposes or any other purposes.
NO LIABILITY FOR CONSEQUENTIAL DAMAGES. To the maximum extent permitted by applicable laws, in no event shall Keyoti Inc. or its suppliers be liable for any damages whatsoever (including without limitation, damages for loss of business profits, business interruption, loss of information, or other pecuniary loss) arising out of the use of or inability to use this Keyoti Inc. product, even if Keyoti Inc. has been advised of the possibility of such damages. Because some states and jurisdictions do not allow the exclusion or limitation of liability for consequential or incidental damages, the above limitation may not apply to you.
4. Support and Source Code Licensing. Keyoti Inc. does provide informal customer support for SearchUnit. We make every effort to ensure the quality of our products, and questions, bug reports, and feature requests are encouraged, please use email. Due to resource limitations, it may not be possible to resolve all issues and no assurances can be given as to when or if problems will be addressed. Customers incorporating SearchUnit into software for deployment or sale are encouraged to purchase the Source Code License Version of SearchUnit which will enable self-support, debugging, and modifications or extensions to the base functionality (but not distribution of the source code itself).


SearchUnit Documentation: Introduction

Thank you for purchasing SearchUnit, please keep up to date through our website keyoti.com and feel invited to post feedback. We also ask that you register your purchase so that we may offer you support and free upgrades from time to time, at http://keyoti.com/care/register

Separate assemblies are provided for CLR2 (.NET 2, .NET 3 and .NET 3.5) and CLR4 (.NET4, .NET 4.5), they can be found under the installation directory.

Overview

SearchUnit provides an index based search control to add search functionality to web applications of any platform (ASP.NET, MVC, Razor, AJAX, HTML, ASP etc). It supports international web-sites and documents. There are no programming skills required to use SearchUnit, making it accessible to page designers as well as programmers. Its UI design is fully customizable through its use of templates. It is easy to deploy, requiring only that it's DLLs, client side files and index files to be moved to the server.

For users it provides high-speed search capabilities, with powerful search expression support and a smooth AJAX interface;

  • Multiple document format indexing -
    • HTML (.aspx, .asp .jsp, .htm, .html, etc)
    • PDF
    • TXT
    • RTF
    • CSV
    • MS Office (.doc, .xls, .ppt, .msg)
    • OOXML / MS Office 2007+ (.docx, .xlsx, .pptx)
    • ODF (.odt, .ods)
    • XML
    • ZIP
  • Simple but powerful expressions
    • Phrase matching
    • NOT, OR and AND operators
    • Wildcards (partial matching)
    • Groups and nested groups
    • Word stemming
  • Implementation is as easy as;
    • Drag SearchBox and SearchResult controls onto pages
    • Configure directory to store index files
    • Crawl and index web-site through integrated index management tool
  • Extensible API gives developers broad usage scope;
    • Plug-in architecture
    • Custom document parsers
    • Custom ranking algorithms
    • Programmatic crawling, indexing and searching
    • Logging of user's search activities

Requirements

The components were built to .NET CLR 2 (2.0, 3.0, 3.5) and CLR 4 (4.0+) specification and are compatible with Visual Studio 2005, 2008, 2010, 2012, and 2013 (implicit 2015 support is expected).


SearchUnit Documentation: Editions; Community, Lite and Pro (switching etc)

Editions: Community, Lite and Pro (switching etc)

SearchUnit is available in 3 editions, Community, Lite and Pro. The Community installer is a separate MSI, whereas the Pro and Lite editions share the same installer, and during installation you can select which edition to install.

Pricing and edition differences

Please visit our licensing page for a run down of current features available to each edition.

In addition to the feature differences, the installed product behaves differently if a license key is set or not (eg trial version mode).

License key present? | Community | Lite and Pro
no (trial mode) | n/a, always full mode | searches run on localhost only, everything else full
time trial license | n/a, always full mode | searches run on any server for a limited number of days
yes | n/a, always full mode | searches run on registered domains/servers
yes OEM/Unlimited | n/a, always full mode | searches run on any domain/server

Switching editions

SearchUnit detects whether it should be running as Community, Lite or Pro based on its Keyoti4.SearchEngine.License.dll. The installer places a different copy of this DLL depending on the edition choice. It's possible to see the installed version of that DLL by right clicking "Keyoti4.SearchEngine.License.dll" -> Properties -> Details (tab) -> Product Name (field).

A known issue with switching editions is that the ASP.NET Temporary Files folder can cache the previously installed copy of the license DLL, which causes the engine to detect the wrong edition. Besides manually clearing the temporary folder manually, it is possible to specify the edition you want to run by adding an appsetting to the web.config, eg. set the value to Community, Lite or Pro

    <configuration>
        <system.web>
            ...
        </system.web>
        <appSettings>
                <add key="Keyoti-SearchEngine-Edition" value="Community"/>
        </appSettings>
        ...
    </configuration>

Note: if an index is created with the Lite or Pro edition, that index will not be searchable with the Community edition. Community indexes however can be searched from the Lite or Pro edition.


SearchUnit Documentation: Features

Features

The following is a quick starting point to explore features in "SearchUnit".

Under the hood

  • Plug-ins
    Allows developers to customize all aspects of the Search engines behavior using a simple 'plug-in' system.
  • Document Security Groups (ACLs) (Pro only)
    Used to restrict results to only documents that the user has permission to see.
  • Categorization (Pro only)
    Documents can be categorized based on their location or other logic, and searches can be restricted to certain categories.
  • Windows Service (Pro only)
    Rebuilds the index automatically, keeping it fully up to date with any changes to documents and URLs.
  • Programmatic Indexing and Searching
    Use the SearchAgent API to programmatically import sources and search documents.
  • Index Management Tool
    Manage all aspects of the index directly from one tool.
  • Administration Web Application (Pro only)
    Manage the index using the web-based administration application.
  • Custom Data
    Store extra meta data with each document such as dates, product codes, forum reply tallies etc.
  • Multilingual
    Indexing/searching support for most languages and scripts. Spelling, stemming/lemma and stop-lists included for popular languages.
  • Extensive File Type Support
    Many files types can be indexed including .aspx, .asp .jsp, .htm, .html, .pdf, .txt, .rtf, .csv, .doc, .xls, .ppt, .msg, .docx, .xlsx, .pptx, .odt, .ods, .xml, .zip

End user UI

Javascript based usage
  • Multi platform
    Supports MVC, Web Forms, AJAX, HTML, ASP etc.
  • Filters & Sorting
    Custom Data fielded data can be used as a source for filtering and sorting.
  • Auto-Complete
    Search query suggestions are shown in a combo box as the user types.
  • Result Previewer
    Result document text can be quickly previewed using DHTML expander.
  • Spelling Suggestions (Pro only)
    Spell check search queries. Includes custom dictionary support for organization acronyms, jargon and names.
  • Customizable Layout
    Modify the layout and how appearance of the result control using the templates.
  • Search Cloud
    Provide users with a word cloud of popular search keywords.
  • Hit Highlighting
    Highlight terms in HTML based result pages.
Web Control based usage
  • Auto-Complete
    Search query suggestions are shown in a combo box as the user types.
  • Result Previewer
    Result document text can be quickly previewed using DHTML expander.
  • Spelling Suggestions (Pro only)
    Spell check search queries. Includes custom dictionary support for organization acronyms, jargon and names.
  • Featured Results
    Promote important pages based on the keywords searched using the Featured Results control.
  • Customizable Layout
    Modify the layout and how appearance of the result control using the templates.
And more - please see the help table of contents for other smaller features, or email support@keyoti.com to ask how you achieve what you need to do.


SearchUnit Documentation: Release Notes

SearchUnit Release Notes

-Fix bug in lemma generator that would create incorrect lemmas under certain conditions.

This product was previously known as "Search for ASP.NET", and has been renamed to "SearchUnit". The name change is purely superficial. The previous release was "Search for ASP.NET 2012", this release is "SearchUnit v6".

6.1.0

Breaking Changes
-Documents are now added to the index with the URL provided in the server's response, which may be different from the requested URL. Previously requested URLs where stored in the index.
Improvements:
-The SearchUnit.js Javascript file now contains no lines over 3000 characters long (this is to help certain other developer tools that might not handle long lines)
-Fix bug with highlighter when keywords start with a symbol.
-Fix incorrect link generation during crawling when FriendlyURLs is enabled.
-Improve redirected URL handling.
-DocumentText class now includes Uri property.
-Fix Windows Service timing being affected by manually triggered Service runs.
-Fix bug in autocomplete when keyotiSearchAutocomplete.options.sew_runSearchOnSelect = false
-Improve support for PDF's using a specific filter stream.
-Improve handling of redirected pages.

6.0.0

Breaking Changes
.NET 1.1 support has ended, .NET 1 DLLs have been removed. No breaking changes from v2012.2 or v2012.3. If you are upgrading from a version older than 2012.2, please see the 2012.2 breaking changes below.
Improvements:
-Add new AJAX based user interface, and support MVC, Razor, AJAX etc.
-Add custom data filter controls and sorting.
-Add search cloud control.
-Minor bug fixes.

2012.3.0

Breaking Changes
If you are upgrading from a version other than 2012.2, please see the 2012.2 breaking changes below.
Improvements:
-Fix issue with xslx parsing.
-PDF title selection improvements.
-Diacritic (accented characters) ignoring for queries (eg. café matches cafe and vice-versa).
-When reimporting 'All' indexable sources do not stop because one source had too many server errors.
-Add more central events (plug-ins).
-Minor bug fixes and API improvements (from customer feedback).

2012.2.0

Breaking Changes
-The underscore '_' character is now treated as NON word breaking, this means that if it appears inside a word (eg. this_variable) then it will not break the word apart (ie into 'this' and 'variable'). This is useful for emails for example, in order to be able to search for my_email@host.com. To revert to old behavior, edit the configuration setting WordNonBreakingCharacters, and remove _ from the character list, and then add it to the WordBreakingCharacters list. Requires reindex to have effect.
-Hyphen '-', forward slash '/' and back slash '\' are now considered word breaking, this means that if they appear inside a word, then they will break the word apart (eg. "\program files\myapp" would be findable with the query "myapp" but not with "\program files\myapp"). Hyphens are treated specially and will match whether they are breaking or non-breaking. To revert to old behavior, edit the configuration setting WordBreakingCharacters, and remove /\- from the character list, and then add it to the WordNonBreakingCharacters list. Requires reindex to have effect.
Improvements:
-Allow keywords to match parts of filenames that are split by hyphens or underscores. Eg. match "key1" to "my-key1-file.pdf".
-Change "_all" queries (which return all documents authorized for user) to only return documents within specified location and content categories.
-Minor bug fixes and API improvements (from customer feedback).

2012.1.0

Breaking Changes
-Support has been added for the 'robots' meta tag - the indexer will now obey these meta tags, to change this behavior set RespectsRobotsMetaTags to false in Configuration.
Improvements:
-Update an indexed document URL when a server redirects to a new URL.
-BoostFactorTagName in Configuration can be used to change the boost factor tag name that the indexer looks for.
-Added login URL parameter (under More Options in the import form) for file-system based imports. This URL is hit before a filesystem import is started, allowing for the search user to be logged in (see the authentication section of the help for more information on log ins).
-Smaller bug fixes.

2012.0.1

Improvements:
-Fix bug in lemmas when certain digit based queries are used.
-Fix bug in index management tool so that security, content and location category changes are effective immediately instead of when the index is next closed (eg closing the tool or indexing a source).

2012.0.0 (v5)

Breaking Changes:
-The index format for 2012 is different to 2010 and earlier. To convert a 2010 index to 2012 format, open the index with the Index Management Tool and it will be converted for you. v3 or older indexes cannot be converted and should be generated from scratch.
-The Configuration.URLCaseSensitive property's default value has been changed from true to false (because it is appropriate to majority of users) - however this does have the side effect that URLs will be stored in all lowercase, therefore if you are doing any URL comparison (comparing your own strings against our stored URLs) check that your string is also lowercase before comparison. Eg. doing something like this resultURL.Contains("News") will ALWAYS be false if Configuration.URLCaseSensitive==false, and should be changed to resultURL.Contains("news")
Improvements:
-Addition of document security groups to allow user to see only results that they have access to
-Search speed improvements for multiple keywords
-New, more powerful index management tool UI
-Popular search auto-complete added (to existing lexicon based auto-complete)
-SearchBox watermark added
-New (plug-in) central events added
-Indexing of ZIP files added
-Added "ImpliedLogicOperator" to configuration to enable changing default search operator from AND to OR
-Now possible to see all documents (that user has permission to see), use query: _all to get all documents, or programmatically searchAgent.Search(searchAgent.AllDocumentReturnQuery, 1, 10);
-Auto-complete suggestions can be easily customized using a plug-in, or in Javascript on the client
-Result preview text can be easily customized using a plug-in, or in Javascript on the client
-Stemming/Lemma support increased to 9 languages
-Added AsynchronousQueue class (.NET 2+) to support asynchronous adding of documents to the index
-Windows Service can now email logs of its actions
-Numerous smaller API enhancements
-New publishing feature in index manager with ability to auto rebuild indexes and deploy with FTP or file copy (ideal for shared hosting users)

2010.1.0

Breaking Changes:
-To speed up searching, some result data is not loaded until a later stage. This only affects developers with custom 'filter' code (i.e. an override of the AddResultItemToResults method). To revert to the old behavior, set the FilterLoadLevel property in SearchResult to Keyoti.SearchEngine.Search.FilterLoadLevel.DocIdUrlCategories

-Web Admin & Windows Service and Plugins: We have improved these by including separate installers for .NET versions 1, 2 (3, 3.5) and 4. In previous versions a single .NET 1 based installer was used, with the side effect that any plug-in DLLs used had to be compiled against our .NET 1 main DLLs. Therefore, if you use a plug-in DLL and choose to install the admin MSI for .NET 2 (3, 3.5) or 4, you will need to also change the plug-in to reference our corresponding main DLLs for that .NET version. Please see the help section on plug-ins for more information or email support.

-.NET 4 users: In ASP.NET 4, the HtmlEncode and UrlEncode methods of the HttpUtility and HttpServerUtility classes have been updated to encode the single quotation mark character (') as &#39; and %27 respectively. Due to this, there is a possibility that an index created with .NET 2 will not be fully compatible with .NET 4 (if URLs have ' chars in them). The safest thing to do is recreate the index from scratch. If uncertain if this affects you, please email support at keyoti.com.
Improvements:
-Inclusion of .NET 4 DLLs and VS 2010 demos
-Inclusion of Web Admin / Windows Service versions for .NET 1, 2 (3, 3.5) and 4 (see breaking changes above)
-Faster searching (with larger indexes)
-Configuration.ImpliedLogicOperator can now be used to change the default operator that is assumed between query words from AND to OR
-Insertion of "..." in the result summary when more than one snippet of text is used. "..." can be changed in Configuration.SummaryTextSplitter
Bug Fixes:
-HTML tags in titles were not escaped
-Some ignore regions were not always correctly ignored
-Fix a highlighting issue with complex queries

2010.0.0 (v4)

Improvements:
-Vastly improved indexing performance, especially with larger indexes (50K docs up)
-Faster searching
-New indexing methodology
-Stop lists
-API improvements
-SearchBox options generates option controls automatically
-Web admin application now uses AJAX based updates on the import/optimize form
-Additional Configuration settings added (Eg. DbConnectionTimeout)

Please see the upgrade section for more details on changes.
Compatibility:

-Not backwards compatible with earlier versions, please see the upgrade section.

3.1.1

Improvements:
-Substantial improvement in PDF indexing performance (CPU and memory usage)
-Fixed bugs relating to image based search buttons
Compatibility:

-Backwards compatible with 3.1.0, please see compatibility notes for 3.1.0 as well.

3.1.0

Improvements:
-Improved HTML output standards compliance.
-Configuration.MaxDocumentSizeToIndex has been added to allow very large documents to be skipped during indexing. By default it is set to 30MB which means that files larger than this will not be indexed.
Compatibility:

-By customer demand, the controls: SearchResults, SearchBoxOptions, and FeaturedResults are wrapped by "DIV" tags, instead of "SPAN" tags. The SearchBox control is still wrapped by "SPAN" tags, but does not use a table for layout. The templates are not wrapped by any tag. These changes have been made to make the rendered output standards compliant, however it is _possible_ that it will effect appearance under your application - therefore it is recommended that the appearance is checked after upgrading.

-Due to potential performance impacts incurred by Authenticode signing assemblies (see http://blogs.msdn.com/shawnfa/archive/2005/12/13/502779.aspx), the product DLLs are no longer Authenticode signed by default. If you prefer to use the Authenticode signed versions, please obtain them here http://keyoti.com/downloads/Search_ASP.NET-Setup-3-1-0-AuthenticodeSignedDLLs.zip

3.0.0

Improvements:
-Added wildcard search support, eg. "excel*" or "*ment" or "*read*".
-File-system based document importing
-Plug-in architecture added
-Simplified index configuration
-New international spelling dictionaries
-Improved search performance
-Improved performance when indexing large numbers of documents (over 10,000)
-Simpler customizability (event based)
-Support for multiple simultaneous indexes
-Autocomplete and result preview AJAX functionality for Controls
-Support for more document types (added .xls, .ppt, ODF, OOXML)
-Improved robustness
-Chinese / Japanese / Korean language support
-Easier single page search/results support
-Meta tag based location/category assignment
-Plug-in DLL based location/category assignment
-Added option for spelling suggestions to be taken from search lexicon, giving better suggestions. See SearchSuggestions.SpellingSuggestionSource
-Added FoundSpellingError event to SearchSuggestions to enable API user to add-to/alter prescribed suggestions.
Compatibility:

Is NOT backwards compatible with v2, please see the upgrade section

Search Pro History

2.2.0b

Improvements:
-Fixed issue with some PDF document encoding of accented chars.
-Added option for spelling suggestions to be taken from search lexicon, giving better suggestions. See SearchSuggestions.SpellingSuggestionSource
-Added FoundSpellingError event to SearchSuggestions to enable API user to add-to/alter prescribed suggestions.
-Added multilingual spelling dictionary
Compatibility:

Is backwards compatible with 2.1.0

2.1.0

Improvements:
-PDF document titles now read from PDF meta data
-Optimized build process memory usage to a scalable flat profile (lower overall usage)
-Optimized search speed in large (>1000000 occurrence) indexes
Search Lite History

2.0.0

Improvements:
-New FeaturedResults control added.
-Crawl/build log window added showing web-site errors.
-Build index operation memory reduced.
-Crawl depth setting added.
-Unhyphenated word forms also searched. (eg. "web-site" now yields results containing "web site").
Compatibility:
Is backwards compatible with 1.3.0

1.3.0

Improvements:
-Ignore region properties added (IgnoreBlockBeginPattern/IgnoreBlockEndPattern), enabling menus etc to be omitted from the index.
-When content encoding not returned by server, encoding is now read from meta tags.
-Documents are now not *reindexed* if 'modified date' is older than the index (also see IgnoreLastModifiedDate).
-Support for (and example of) merging disparate result DataSets added.
-Visual Studio 2005 support added.
-Search speed improvements.
-Http compressed page support added (gzip/deflate).
-Summary word highlighting HTML element property added.
-ReaderExceptionOccurredEvent added to enable detection of broken web-site links.
Fixes:
-Fixed SearchResultURL redirection when result page URL already contains a query string.
Compatibility:
Due to the addition of a new index file in the index directory, it is advisable that you rebuild your indexes before deploying this version. If you do not rebuild the indexes the file will be created automatically (however this may fail if the ASPNET process has insufficient permissions in the index directory). Please see this KB article for details; http://keyoti.com/kb/Default.aspx?ToDo=view&questId=102&catId=54

1.2.0

Improvements:
-Added support for user pressing 'Enter' key inside search box.
-Added properties to control next/prev page link texts.
-SearchResult ItemCreated events added.
-Frames web-site support added (crawling and indexing).
-Added PathMatchesToBeIncluded to allow only URLs with matching substrings to be indexed.
-Property added to handle error page redirects.
-Crawl start URL is persisted by Index Management tool for added convenience.
Compatibility:
Is backwards compatibly with 1.1.0

1.1.0

Improvements:
-Forms Authentication support, enabling the crawler and indexer to work with web applications that require a user to logon - please see Help documentation.
-Windows Integrated Authentication support - enabling the crawler and indexer to crawl web applications where Integrated Authentication is enabled under IIS.
-Crawler now warns users if the start URL is invalid or cannot be read (404 etc).
-Support for international encodings in addition to Unicode/UTF-8.
-Additional API exposure allows subclasses of SearchAgent to be used.
-Support for non English search expression operators (eg. "UND" and "ODER" for "AND" and "OR").
Fixes:
-Issue fixed in crawler making success rate higher.
Compatibility:
Is backwards compatibly with 1.0.0

1.0.0

-Initial release.


SearchUnit Documentation: Quick Start

Quick Start

Please follow these simple steps to quickly setup SearchUnit in a web application. If you have any questions at all please contact us at support@keyoti.com

For MVC usage please see this tutorial

Step 1 (Setup)
Step 2
Step 3
Step 4
Step 5
Step 6
Step 7
Step 8 (Search)

Step 1. Load/Create a project and add a page or webform.

Next

Step 2. Create a new folder to store the index files;

  1. Open the project folder in File Explorer
  2. Create a new folder called 'Keyoti_Search_Index'

Next

Step 3. Open the Index Manager Tool from the Start Menu and enter the path to your index directory.

The Index Manager Tool can be found under the Start Menu;

Start Menu -> All Programs -> SearchUnit -> Index Manager Tool

Next

Step 4. Select 'Import New Source', enter the start URL & click 'Import'.

If an error reports the page cannot be read, please check the URL or consult the user guide for help.

Once the import is complete close the Import window, select 'Optimize' and click 'Start Optimize'.

Next

Step 5. Copy the SearchUnit scripts folder to your project;

  1. Open the SearchUnit install folder (via Start Menu or File Explorer).
  2. Copy the 'Keyoti_SearchEngine_Web_Common' folder.
  3. Paste to your application's Solution Explorer.

    4. Next

Step 6. Add the SearchUnit JS and CSS tags to the head of your page.

To automatically add the tags, drag SearchUnit.js and SearchUnit.css from the Solution Explorer on to the page source. Alternatively copy and paste the tags as below to the head of your page.

<script src="Keyoti_SearchEngine_Web_Common/SearchUnit.js"></script>
<link href="Keyoti_SearchEngine_Web_Common/SearchUnit.css" rel="stylesheet" />

.NET 2 users must also add the following to all pages using SearchUnit (or set the variable from a common JS file).

<script type="text/javascript">keyotiSearch.useWCFService=false;</script>

Next

Step 7. Add the SearchUnit divs to your page.

<div id="sew_searchBoxControl"></div>
<div id="sew_searchResultControl"></div>

sew_searchBoxControl is the search text box and button.

sew_searchResultControl is the search result control.

Next

Step 8. Run the web application (hit F5) and try a search!

Here a search was done for 'themselves'.

Go further!

Now you're ready to explore more features in SearchUnit, please take a look at the 'Features' page in the help for more information on all that SearchUnit can do.


How An Indexed Search Engine Works


SearchUnit Documentation: Upgrading from Prior Versions

Upgrading from versions 1, 2 or 3.

Keyoti SearchUnit 2012 (and 2010) incorporates some significant changes in methodology and the degree of work required to upgrade will be proportional to the proximity of your projects to the older version API. Eg. for a simple case of indexing a web-site through the supplied tools and searching via the SearchResult control - there may be only a few changes to make. However in a case where extensive use of our API has been made, there will be several places where code needs to change (usually property name changes or change to a new method) and possibly attention paid to how configuration settings are stored.

The most fundamental change is the indexing format and methodology. New version indexes are not compatible with older indexes, and must be generated again - however they are also much faster to generate now, so index recreation shouldn't be too large a task.
Further, new indexes are 'built' as documents are added (eg. via importing). The entire 'Build' operation has been removed. This makes all operations more efficient and incremental indexing much quicker.

Step 1 - Creating the new index files

Porting Index Settings And Sources

If you have a v3 index directory that you wish to convert to new format, you can create a new folder for the new index, and copy all XML files from the v3 index directory to the new directory. Doing this will preserve configuration settings, location/content category setups, and imported sources (their import parameters, not the actual documents).
  • If the index is critical, it's recommended that a backup of the original index files is kept until the new index is verified

Step 2 - Changing references

Change the project references from the old version DLLs to the version 4 DLLs.

Step 3 - Upgrading web.config

Check the web.config for any mention of our DLLs with specific version numbers. You should change the version number to that of the actual DLL versions. You can find the version of a DLL through Windows Explorer -> Properties -> Version (tab)

Step 4 - Upgrading classes

If you have used our API from your code, you will need to make some changes.
  • As a result of the immediate indexing (see above), the DocumentImporter class has been merged with DocumentIndex. This means that any calls you may have to the DocumentImporter should be moved to DocumentIndex. Eg. the old routine of
    DocumentImporter imp = new DocumentImporter(config);
imp.Open();
imp.Import(...);
imp.Close();

DocumentIndex idx = new DocumentIndex(config);
idx.Open();
idx.Build();
idx.Close();
    can be changed to just
    DocumentIndex idx = new DocumentIndex(config);
idx.Import(...);
idx.Close();

//Note: the Open() method is now called automatically in the DocumentIndex constructor.
  • There are now convenience methods for common imports, eg. ImportWebsite, etc. which are easier to use than "Import(...)".
  • Optimization. The new index format achieves greater efficiency during indexing, in part by minimizing the amount of redundant optimization performed. In v3 the index was always optimized for searching; whereas in new versions, the index should be optimized after batch operations have been performed (eg. after imports, adds and deletes). Optimization usually takes seconds to minutes, depending on the index size. The UI's have an Optimize button now, or to optimize programmatically, call DocumentIndex.Optimize(), eg.
    DocumentIndex idx = new DocumentIndex(config);
idx.Import(...);
idx.Optimize();
idx.Close();
    or
    DocumentIndex idx = new DocumentIndex(config);
idx.Optimize();
idx.Close();
    Optimization can improve search performance by a factor of ~5 and has no effect on future indexing performance.
  • In order to obtain speed improvements we have removed the ability to search in a case sensitive manner. All searches are case insensitive.
  • We have implemented 'stop words', which are common words that are not indexed. This results in speed improvements during indexing and searching. The stop list can be modified by editing the file 'stoplist.txt' which is found in the index directory when the directory is first initialized (i.e. before actually importing something). The contents of the file may be deleted if you wish to deactivate stop lists, or the contents may be switched with a stop list for another language (which we will provide in the install dir). Also, calling Configuration.StopWords.Clear() immediately after constructing a DocumentIndex or SearchAgent object will clear the stop list.

    It is recommended that the following ASPX code is added to the HeaderTemplate and NoResultsTemplate (in the SearchResults control) to inform the user of which search words were ignored.

<%# Container.IgnoredWordsMessage %>
  • You will probably find a few compilation errors, but please read them carefully as they should include information on the API change (i.e. new method to use instead). Some changes made are just vanity, eg. name changes and many are just minor argument changes.
  • If you use the Central Event System to handle ActionName.ResultItemsFinalized type Action events, then note that the Data property no longer returns type ArrayList, but Keyoti.SearchEngine.Utils.ResultItemList. eg.
    if(e.ActionData.Name== ActionName.ResultItemsFinalized)
{
    ArrayList results = e.ActionData.Data as ArrayList;

should be changed to

if(e.ActionData.Name== ActionName.ResultItemsFinalized)
{
    ResultItemList results = e.ActionData.Data as ResultItemList;
  • Configuration.CacheCrawlLinks: due to a change in the way documents are crawled and indexed (now simultaneously) it is recommended that Configuration.CacheCrawlLinks is set false (default in new indexes), existing index configurations should be changed. Excessive memory may be consumed otherwise.

Compilation

Typically the best way to see what code needs to change is to compile it with the new DLLs. There are numerous cases where a minor change has been made to a member name (to bring it inline with the .NET naming conventions) and cases where members have been made obsolete. In all cases the compiler error should include a suggestion of an alternative to use.

Pro Version Upgrades

In addition to everything described in this document, it's necessary to uninstall the Windows Service and Web Admin (using the administration MSI, located under the start menu) and then after installation of the main installer, install the new administration MSI.

General breaking changes

  • SearchBoxOptions, by default, will automatically create a location drop down menu and content category check boxes for the user. If you are using this control you may prefer to set AutoGenerateLocationDropDown and AutoGenerateContentCheckBoxes to false, to make it revert to older, manual, behavior.
  • IDataAccess interface has been removed, please declare variables as XmlDataAccess instead. It is preferred that you work with DocumentIndex rather than XmlDataAccess when possible.


SearchUnit Documentation: General Installation

General Installation

To use SearchUnit, you must add the following files (where N is your .NET version number) to your project;
  • KeyotiN.SearchEngine.Web.dll
  • KeyotiN.SearchEngine.Core.dll
  • KeyotiN.SearchEngine.License.dll
  • KeyotiN.Text.MSOffice.dll
  • KeyotiN.Text.LemmaGenerator.dll
Optionally for Pro version features;
  • KeyotiN.SearchEnginePro.Web.dll
  • KeyotiN.SearchEngine.Suggestions.dll
  • KeyotiN.SearchEngine.SuggestionsDictionary.dll

and reference KeyotiN.SearchEngine.Web.dll in your web pages that use the Web Controls (not required if using Javascript controls). The assemblies should be listed under "Extensions" in the Visual Studio add reference dialog, or can be browsed to under the install directory, eg C:\Program Files (x86)\Keyoti Inc\SearchUnit 2012\NETCLR_v4_BIN (use NETCLR_v2_BIN for .NET2).

The index directory will need to grant permission to the ASP.NET/IIS user that accesses it, see "Setup" in the index directory topic.

Installation, For Javascript Usage

Client side files

Copy Keyoti_SearchEngine_Web_Common folder from the SearchUnit install folder to your project.

The Javascript usage mode uses AJAX to communicate with the server over either WCF (for .NET 4 up) or ASP.NET Web Services (for .NET 2 up). When possible use WCF, as ASP.NET Web Services are now considered legacy by Microsoft.

WCF (default, .NET 4+)

By default WCF is used, via the SearchService.svc file in the Keyoti_SearchEngine_Web_Common folder. No extra configuration should be necessary.

Troubleshooting:

  • If 404 errors are shown for the SearchService.svc URL when running search;
    • Ensure the app pool is actually using .NET 4 or up.
    • You may need to add a mapping for the SVC extension to ASP.NET. One way to do this is to run ServiceModelReg.exe -i from C:\Windows\Microsoft.NET\Framework\v3.0\Windows Communication Foundation.

Web Services (.NET 2+)

In the search page that uses the Javascript files, call (after the SearchUnit.js import) keyotiSearch.useWCFService = false;

Installation, for ASP.NET Web Control Based Usage & Javascript Usage

 In order to use the AutoComplete feature and ResultPreview feature it may be necessary to perform extra setup in the project that is using the controls.

.NET 4

IIS 6

Add inside the system.web section.
<httpHandlers>
       <add verb="*" path="Keyoti.SearchEngine.Web.CallBackHandler.ashx"
         type="Keyoti.SearchEngine.Web.CallBackHandler,Keyoti4.SearchEngine.Web,
            Version=2015.?.?.?, Culture=neutral, PublicKeyToken=58d9fd2e9ec4dc0e"/>
</httpHandlers>
where 2015.?.?.? should be replaced with the version number of the Keyoti4.SearchEngine.Web DLL.

IIS 7+

Add inside the system.webServer section.
<staticContent>
    <mimeMap mimeType="text/html" fileExtension=".ashx"/>
</staticContent>
<handlers>
    <add name="Keyoti_SearchEngine_Web_CallBackHandler_ashx" verb="*" preCondition="integratedMode"
    path="Keyoti.SearchEngine.Web.CallBackHandler.ashx"
    type="Keyoti.SearchEngine.Web.CallBackHandler, Keyoti4.SearchEngine.Web,
    Version=2015.?.?.?, Culture=neutral, PublicKeyToken=58d9fd2e9ec4dc0e"/>
</handlers>
where 2015.?.?.? should be replaced with the version number of the Keyoti4.SearchEngine.Web DLL.

.NET 2, 3, 3.5

To enable the previewer, set the ResultPreviewerEnabled property of the SearchResult control to True.

Usually performed automatically: If the controls are opened in the VS designer, then the web.config will be amended with the required code. If this doesn't occur, then the web.config must be opened and the following changes made:

IIS 6

Add inside the system.web section.
<httpHandlers>
       <add verb="*" path="Keyoti.SearchEngine.Web.CallBackHandler.ashx"
         type="Keyoti.SearchEngine.Web.CallBackHandler,Keyoti2.SearchEngine.Web,
            Version=2015.?.?.?, Culture=neutral, PublicKeyToken=58d9fd2e9ec4dc0e"/>
</httpHandlers>
where 2015.?.?.? should be replaced with the version number of the Keyoti2.SearchEngine.Web DLL.

IIS 7+

Add inside the system.webServer section.
<staticContent>
    <mimeMap mimeType="text/html" fileExtension=".ashx"/>
</staticContent>
<handlers>
    <add name="Keyoti_SearchEngine_Web_CallBackHandler_ashx" verb="*" preCondition="integratedMode"
    path="Keyoti.SearchEngine.Web.CallBackHandler.ashx"
    type="Keyoti.SearchEngine.Web.CallBackHandler, Keyoti2.SearchEngine.Web,
    Version=2015.?.?.?, Culture=neutral, PublicKeyToken=58d9fd2e9ec4dc0e"/>
</handlers>
where 2015.?.?.? should be replaced with the version number of the Keyoti2.SearchEngine.Web DLL.

.NET 1.1

web.config

The web.config must be opened and the following added inside the system.web section.
    <httpHandlers>
       <add verb="*" path="Keyoti.SearchEngine.Web.CallBackHandler.ashx"
        type="Keyoti.SearchEngine.Web.CallBackHandler,Keyoti.SearchEngine.Web,
            Version=2015.?.?.?, Culture=neutral, PublicKeyToken=58d9fd2e9ec4dc0e"/>
    </httpHandlers>
where 2015.?.?.? should be replaced with the version number of the Keyoti.SearchEngine.Web DLL.

For IIS (without using Visual Studio)

  1. Copy all Keyoti Search DLLs into the bin directory off your application root.

  2. Add

    <%@ Register TagPrefix="searchengine" Namespace="Keyoti.SearchEngine.Web" Assembly="Keyoti.SearchEngine.Web" %>
    to the top of the aspx page where you will use the SearchUnit Control (not required if using Javascript based usage).

Client side files

The installer automatically registers a virtual directory called Keyoti_SearchEngine_Web_Common which holds the necessary scripts. This is used by the AJAX features and needs to be present on the development and deployment machines.

Server farms

To do this, specify the IP (or server name) of every server in the farm in the web.config, using an appSetting named Keyoti-SearchEngine-ServerFarmSynchronizationIPs, its value should be a comma-delimited list. It is also necessary to specify an appSetting named Keyoti-SearchEngine-ServerFarmSynchronizationAppPath with a value indicating the relative URL of the app. Eg.

<appSettings>
    <add key="Keyoti-SearchEngine-ServerFarmSynchronizationIPs" value="10.0.0.1,10.0.0.2,10.0.0.3"/>
    <add key="Keyoti-SearchEngine-ServerFarmSynchronizationAppPath" value="/myapp/"/>
</appSettings>

Doing so will allow each server to communicate with each other every 5 minutes with changes in search keyword data.


SearchUnit Documentation: License Keys

License Keys

Upon purchase, an 'activation key' is provided by email.

If you purchased a Site Wide/Unlimited/OEM license you should use your 'activation key' as described below to obtain an unlimited deployment key. Otherwise, your license to use SearchUnit is restricted to x developers/servers/web-sites where x depends on the size of the license purchased.

About Deployment Keys

In order to use SearchUnit outside of a development environment you need to create a deployment license key(s) for the web-site server (domain) name and the IP address(es) of the servers it will run on. A development environment is defined as viewing the web-site on the same machine as the web server, or running the site under 'localhost' (or 127.0.0.1).

If you are using a multi-server development environment (eg. dev-server -> test-server -> production-server) please see the 'Advanced' section of the Help documentation for license key handling strategy.

You can create production and pre-production (QA, test, dev) deployment license keys on our web-site at http://www.keyoti.com/KeyMaker/main.aspx - to access this system you will need the 'activation key' emailed to you when you purchased the product.

Deployment keys are generated for domain name/server ip combinations, each deployment key corresponds to one domain name and at least one server IP.

We recommend that you generate keys only after the domain name and server IP are known for definite, as a key can only be automatically generated once.

Deployment Key Usage

Once you have generated deployment keys at http://www.keyoti.com/KeyMaker/main.aspx you should set it in the web.config. If the deployment keys are not correct then attempts to use the controls on the server will result in alert messages.

After generating a deployment key ensure it is set in web.config

Eg. web.config;

<appSettings>
        <add key="Keyoti-SearchEngine-LicenseKey" value="your key here"/>
</appSettings>

If you have more than one domain/servername (and therefore deployment key) for the app. you can easily specify up to 4 additional keys by adding a key called;

  • "Keyoti-SearchEngine-LicenseKey2".
  • "Keyoti-SearchEngine-LicenseKey3".
  • "Keyoti-SearchEngine-LicenseKey4".
  • "Keyoti-SearchEngine-LicenseKey5".


SearchUnit Documentation: Indexing: ...in Visual Studio

In Visual Studio

The following only applies if the Control based usage has been adopted, for Javascript based usage please use the Index Management Tool from the Windows Start menu. For details on installing the controls, please see the 'Installation' section of the Help documentation.

1.
Create a folder within your project that will hold the index files.
Set the IndexDirectory property of the SearchResult control to the path of the folder that will store the index files.
View

2.
Start the Index Wizard (right click SearchResult control select Index Wizard)
View

You can specify a different Index Directory to work with, otherwise click next to use the current one.

View

3.
Click 'Import New Source'
a. 'Type of source' should be set to 'Website'.
b. Enter the Start URL of the site you would like to import.
c. Click 'Import' to begin crawling and indexing new links.
View

Once the import has completed or 'Stop' has been selected, click the 'Server Error Log' button to show the Reader Error Log which has details of URLs that couldn't be requested. This is provided for information only and may not effect the search.

Searches can now be performed from any page containing the SearchBox.


SearchUnit Documentation: Indexing: ...in the Web Administration app

In The Web Administration Application - Pro version only

For details on installing the Web Administration Application, please see the 'Administration App. & Windows Service' section of the Help documentation.

1.
Load the Web Admin application, http://localhost/KeyotiSearchAdministration
The default Index Directory to work with is located within the Keyoti-Search-Admin folder. To specify a different Index Directory to work with, enter the path to the Index Directory and select Change to switch to the new index.
View

2.
Click 'Import Documents/Records'
a. 'Type of source' should be set to 'Website'.
b. Enter the Start URL that you want to import.
c. Click 'Import' to begin crawling and indexing new links.
View

Once the import has completed or 'Stop' has been selected, you can view the Web-Site error log to see details of any URL's that contained errors, such as page not found. This is provided for information only and may not effect the search.

Searches can now be performed from any page containing the SearchBox.


SearchUnit Documentation: Indexing: ...programmatically

Show language: C# VB.NET Both

Programmatically

Full Import

Also see this page for other programmatic import/indexing options.

This Windows Forms example is intended to demonstrate a basic programmatic implementation. From the button click event, the website source is imported and the index fully built ready for searching.

Reference these DLL's in your project, KeyotiX.SearchEngine.Core, KeyotiX.SearchEngine.License, KeyotiX.Text.LemmaGenerator.dll, KeyotiX.Text.MSOffice.dll - where X is 2 for .NET 2 and 4 for .NET 4

C#
using System;
using System.Collections.Generic;
using System.ComponentModel;
using System.Data;
using System.Drawing;
using System.Text;
using System.Windows.Forms;
using Keyoti.SearchEngine;
using Keyoti.SearchEngine.Index;
using Keyoti.SearchEngine.DataAccess.IndexableSourceRecords;
using Keyoti.SearchEngine.Search;

namespace WindowsApplication
{
    public partial class Form1 : Form
    {
        public Form1()
        {
            InitializeComponent();

        }

        private void button1_Click(object sender, EventArgs e)
        {
            Configuration configuration = new Configuration();
            configuration.IndexDirectory = "C:/YourSite/IndexDirectory";

            //---Import pages from website.
            DocumentIndex documentIndex = new DocumentIndex(configuration);
            try{
                documentIndex.ImportWebsite("http://www.yoursite.com");
            } finally {
                documentIndex.Close();
            }

            //---Search Index
            SearchAgent sa = new SearchAgent("EnterLicenseKeyHere", configuration);
            SearchResult res = sa.Search("search terms", 1, 10); //res now holds a collection of ResultItem objects

        }
    }
}
VB.NET
Imports System
Imports System.Collections.Generic
Imports System.ComponentModel
Imports System.Data
Imports System.Drawing
Imports System.Text
Imports System.Windows.Forms
Imports Keyoti.SearchEngine
Imports Keyoti.SearchEngine.Index
Imports Keyoti.SearchEngine.DataAccess.IndexableSourceRecords
Imports Keyoti.SearchEngine.Search

Public Class Form1

    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click

        Dim configuration As Keyoti.SearchEngine.Configuration = New Configuration
        configuration.IndexDirectory = "C:/YourSite/IndexDirectory"

'---Import pages from website.
        Dim documentIndex As DocumentIndex = New DocumentIndex(configuration)
        Try
            documentIndex.ImportWebsite("http://www.yoursite.com")
        Finally
            documentIndex.Close()
        End Try

'---Search Index
        Dim sa As SearchAgent = New SearchAgent("EnterLicenseKeyHere", configuration)
        Dim res As SearchResult = sa.Search("search terms", 1, 10) 'res now holds a collection of ResultItem objects

        End Sub
End Class

The try-finally constructs ensure that the index is closed even if an exception occurs.


SearchUnit Documentation: How do I...: ...ignore documents & pages

Ignoring Pages & Documents

Using Index Manager Tool

To exclude or ignore certain pages on the web-site, before importing a new source, select 'More Options' and set 'Path matches to be ignored' to a part of the path that should be ignored.

If for example a support forum on the site has numerous duplicate pages with different URLs (reply links, reply with quote links) then it is desirable to exclude the duplicates from the index at the crawling stage.

Suppose that the links are as follows:

http://localhost/forum.aspx?action=reply&mesgid=1

http://localhost/forum.aspx?action=view&mesgid=1

http://localhost/forum.aspx?action=reply&mesgid=2

http://localhost/forum.aspx?action=view&mesgid=2

and that the 'reply' pages contain the same text as the 'view' pages. To prevent the 'reply' pages from being added to the index at the crawl stage we can add an element to the 'Path matches to be ignored' collection; "forum.aspx?action=reply" - which will prevent any URLs that contain that text from being added. It is a collection and can contain multiple URL segments to be ignored.

Note, if an index has already been created, setting this will have no effect on documents already in the index, so if necessary, delete the index and recrawl.

Robots Meta Tag

The de facto standard 'robots meta tag' can be used to control whether links are read (nofollow), or content is indexed (noindex), for a page.
<meta name="ROBOTS" CONTENT="NOINDEX, NOFOLLOW"/>

To ignore the robots meta tag, set RespectsRobotsMetaTags to false in the configuration.

Programmatically

Specifying pages not to index can be handled programmatically during import by passing an ArrayList of strings;
C#
   DocumentIndex imp = new DocumentIndex(Configuration);
   urlStrings = imp.Import(new WebsiteBasedIndexableSourceRecord(startUrlString,
                pathMatchesToBeIgnoredList, pathMatchesToBeIncludedList));
   imp.Close();

(pathMatchesToBeIgnoredList and pathMatchesToBeIncludedList can be null/Nothing)


SearchUnit Documentation: How do I...: ...ignore menus & other page sections

Menus & Other Regions Not To Index

Certain regions of documents/pages are ideally not indexed for searching, for example, a web-site menu may contain the names of all products on the web-site, clearly if every page contains this menu, then a search for any product name will yield all pages. To prevent this, these regions should be identified before indexing the pages commences. A page can contain any number of regions to ignore.

eg. ignore sections of HTML using these comments

<!--keyoti_search_ignore_begin-->
...region to ignore
<!--keyoti_search_ignore_end-->
Changing Ignore Region Tags

Before building an index, set the IgnoreBlockBeginPattern and IgnoreBlockEndPattern properties in the Configuration, see the Configuration section for more information.

eg.

IgnoreBlockBeginPattern ="<!--start menu-->"

IgnoreBlockEndPattern ="<!--end menu-->"


SearchUnit Documentation: How do I...: ...index Windows Authentication apps

Show language: C# VB.NET Both

Windows Authentication

This section is for crawling and indexing applications that use "Windows Authentication" (as configured under IIS). For ASP.NET controller authentication, please see Forms Authentication Apps & Sites.htm

NTLM Integrated

For this type of integration, no special setup is required. The indexer automatically uses the credentials of the current user who is running the import. (For ASP.NET apps that are importing, this user may be Network Service or 'ASPNET').

Basic or Digest

Open the configuration editor (using one of our UIs) and find the WebsiteCredentials entry. This is where the any username and password is configured. Specify the path that the user/password combination apply to, in the path property. Eg. http://host/dir1/. The 'UserPass' field should be set with the username and password, separated by a space, eg. user1 password1. Specify as many user and path combinations as is needed.


SearchUnit Documentation: How do I..: ...index Forms Authentication apps

Show language: C# VB.NET Both

Forms Authentication Apps./Sites

Crawling and indexing applications that use "Forms Authentication" (.NET 1+), "ASP.NET Membership" (.NET 2+), or any type of custom login mechanism is possible, however a little preparation is required to make it work.

ASP.NET Membership (.NET 2+)

In this example we'll have one page called 'login.aspx' which shows the user the login form, and validates their input to log them in. Typically the validation logic for ASP.NET Membership is inside the "Login" control, however it can be performed externally in one of two ways;

Use of the Login.Authenticate event

    protected void Login1_Authenticate(object sender, AuthenticateEventArgs e)
    {
        e.Authenticated = myCustomLogic();
    }

Call to Membership.ValidateUser

   if (Membership.ValidateUser(user, pass))
                FormsAuthentication.RedirectFromLoginPage(user, false);

The latter code does 2 things, it authenticates the username and password, and then it redirects the user to the desired page. During redirection the user is logged in (via a cookie).

To allow the crawler/indexer to login we need to modify the code to accept the username and password from GET request parameters, not just from the textboxes (since the crawler/indexer is unable to fill in the textboxes itself). To do this we simply change the code to try authenticating from the form parameters as well.

C#
    protected void Page_Load(object sender, EventArgs e)
    {
        string user = Page.Request.Params["searchusername"];
        string pass = Page.Request.Params["searchpassword"];

        //if it wasn't a postback and we do have a username, then login the user
        if (!IsPostBack && user != null && pass != null)
        {
            if (Membership.ValidateUser(user, pass))
                FormsAuthentication.RedirectFromLoginPage(user, false);

        } else if (!IsPostBack && Membership.GetUser() !=null && Request.Params["ReturnUrl"] !=null){
            //not a postback and we didn't get any user info,
            //so if the user is already logged in, redirect them as usual
            FormsAuthentication.RedirectFromLoginPage(Membership.GetUser().UserName, false);
        }

    }
VB.NET
    Protected Sub Page_Load(ByVal sender As Object, ByVal e As EventArgs) Handles Me.Load
        'get any supplied username for the search engine
        Dim user As String = Page.Request.Params("searchusername")
        Dim pass As String = Page.Request.Params("searchpassword")

        'if it wasn't a postback and we do have a username, then login the user
        If (Not IsPostBack _
                    AndAlso ((Not (user) Is Nothing) _
                    AndAlso (Not (pass) Is Nothing))) Then

            If Membership.ValidateUser(user, pass) Then
                FormsAuthentication.RedirectFromLoginPage(user, False)
            End If

        ElseIf Not IsPostBack _
                    AndAlso Not Membership.GetUser() Is Nothing And Not Request.Params("ReturnUrl") Is Nothing Then

            'not a postback and we didn't get any user info,
            'so if the user is already logged in, redirect them as usual
            FormsAuthentication.RedirectFromLoginPage(Membership.GetUser().UserName, False)
        End If
    End Sub

Importing

In the Index Management tool, the import is configured to start from the login page, using the username and password required. For a website import the start URL is set, or for a filesystem import use the 'More Options' button to set the login URL.

Eg. the URL is set to

http://localhost/login.aspx?searchusername=myUserName&searchpassword=myPassword

[optionally you may also want to specify "&ReturnUrl=someURL.aspx" to make the crawler visit 'someURL.aspx' after logging in.]

Security note: by using the parameters named searchusername and searchpassword, the search engine will automatically remove the username and password from the result URL.

If you have difficulty (i.e. the crawler finds only 1 link) then it is of course useful to debug the login process. This can be performed as usual, just start the web application like normal, set a break point on the login method (leave the browser open), and start the crawler. If you treat the crawler like any other browser you will find it easy to debug. When the crawler visits the first page you'll see the break point hit.

It is advisable not to let the application's 'logout' page logout the search engine user, as this may be visited during the crawl operation.

Forms Authentication (.NET 1+)

    void ProcessLogin(object sender, EventArgs e){

        if (FormsAuthentication.Authenticate(txtUser.Text, txtPassword.Text)) {

            FormsAuthentication.RedirectFromLoginPage(txtUser.Text, chkPersistLogin.Checked);

        } else {

            ErrorMessage.InnerHtml = "<b>Invalid username/password combination.</b>";

        }
    }

This code is called by the login button.

<asp:Button Id="cmdLogin" OnClick="ProcessLogin" Text="Login" runat="server" />

The code does 2 things, it authenticates the username and password, and then it redirects the user to the desired page. During redirection the user is logged in (via a cookie).

To allow the crawler/indexer to login we need to modify the code to accept the username and password from GET request parameters, not just from the textboxes (since the crawler/indexer is unable to fill in the textboxes itself). To do this we simply change the code to try authenticating from the form parameters as well.

void ProcessLogin(object sender, EventArgs e){
        string username = txtUser.Text;
        string password = txtPassword.Text;
        if (Request.Params["searchusername"] != null) {//we got a searchusername through the GET request
            username = Request.Params["searchusername"];
            password = Request.Params["searchpassword"];
        }
    if (FormsAuthentication.Authenticate(username, password)) {
        FormsAuthentication.RedirectFromLoginPage(username,
    chkPersistLogin.Checked);
    } else {
        ErrorMessage.InnerHtml = "<b>Invalid username/password combination.</b>";
    }

and then call this method if we receive the GET parameter, from the page load, eg;

private void Page_Load(object sender, System.EventArgs e)
{
        // Put user code to initialize the page here
        if (Request.Params["searchusername"] != null) ProcessLogin(null, null);
}

Then, in the Index Management tool, the crawler is configured to start from this page, using the username and password required. Eg. the crawl import URL is set to

http://localhost/login.aspx?searchusername=myUserName&searchpassword=myPassword

[optionally you may also want to specify "&ReturnUrl=someURL.aspx" to make the crawler visit 'someURL.aspx' after logging in.]

Security note: by using the parameters named searchusername and searchpassword, the search engine will automatically remove the username and password from the result URL.

If you have difficulty (i.e. the crawler finds only 1 link) then it is of course useful to debug the login process. This can be performed as usual, just start the web application like normal, set a break point on the login method (leave the browser open), and start the crawler. If you treat the crawler like any other browser you will find it easy to debug. When the crawler visits the first page you'll see the break point hit.

It is advisable not to let the application's 'logout' page logout the search engine user, as this may be visited during the crawl operation.

Example Code With Modified Authentication Method

<%@ Page language="c#" Codebehind="WebForm4.aspx.cs" %>
<%@Import Namespace="System.Web.Security" %>
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" >

<script language="C#" runat="server">
private void Page_Load(object sender, System.EventArgs e)
{
    // Put user code to initialize the page here
    if (Request.Params["searchusername"] != null) ProcessLogin(null, null);
}

void ProcessLogin(object sender, EventArgs e){
    string username = txtUser.Text;
    string password = txtPassword.Text;
    if (Request.Params["searchusername"] != null) {

//we got a searchusername through the GET request
            username = Request.Params["searchusername"];
            password = Request.Params["searchpassword"];
        }
    if (FormsAuthentication.Authenticate(username, password)) {
        FormsAuthentication.RedirectFromLoginPage(username,
chkPersistLogin.Checked);
    } else {
        ErrorMessage.InnerHtml = "<b>Invalid username/password combination.</b>";
    }

}
</script>
<html>
<head>
<title>Standard Forms Authentication Login Form</title>
</head>
<body >
<form runat="server" ID="Form1">
<table width="400" border="0" cellspacing="0" cellpadding="0">
    <tr>
        <td width="80">Username : </td>
        <td><asp:TextBox Id="txtUser" width="150" runat="server"/></td>
    </tr>
    <tr>
        <td>Password : </td>
        <td><asp:TextBox Id="txtPassword" width="150" TextMode="searchpassword"
runat="server"/></td>
    </tr>
    <tr>
    <tr>
        <td></td>
        <td><asp:CheckBox id="chkPersistLogin" runat="server" />Remember my
credentials<br>
        </td>
    </tr>
    <tr>
        <td> </td>
        <td><asp:Button Id="cmdLogin" OnClick="ProcessLogin" Text="Login"
runat="server" /></td>
    </tr>
</table>
<br><div id="ErrorMessage" runat="server" />
</form>
</body>
</html>


SearchUnit Documentation: How do I...: ...make Plug-ins (site mapper)

Show language: C# VB.NET Both

Writing a Plug-in (Site Map)

See the overview of the Central Event System in general

The following is intended to be viewed side-by-side with the "Plug-in_SiteMap" demo projects available under the install directory. The purpose of the code is to produce a simple map (list of pages and what they link to) of any web-site as it is being imported (crawled).

Step 1. Create a new project

Create a new class library project (to produce a DLL), it can be named anything that is valid to Visual Studio.

Alternatively a blank plug-in project can be created from the Index Management Tool. Select the Plug-in form, enter the folder to create the project in, choose the required language and click Create Project.

Step 2. Add references

Add references to Keyoti.SearchEngine.Core.DLL, Keyoti.SearchEngine.License.DLL, Keyoti.Text.MSOffice.DLL, Keyoti.Text.LemmaGenerator.DLL (note that you must use the Keyoti2... versions if you use those assemblies in your toolbox - see the notes section 'References To Search DLLs').

Step 3. Add a new class

Create a new class named 'ExternalEventHandler', and make it in a namespace called 'Keyoti.SearchEngine'. Note, that for VB.NET projects, you will need to edit the project properties and delete the 'Root namespace' setting, in order for the code to work as presented.

C#
using System;
using System.Collections;
using System.Text;
using System.IO;
using Keyoti.SearchEngine.Events;
using Keyoti.SearchEngine.Documents;
using Keyoti.SearchEngine.DataAccess;
using Keyoti.SearchEngine;

namespace Keyoti.SearchEngine
{
    ///
    /// Creates a site-map when a web-site is crawled.
    ///
    public class ExternalEventHandler
    {

        IEventDispatcher dispatcher;
        Configuration conf;
        public ExternalEventHandler(IEventDispatcher dispatcher, Configuration conf)
        {

        }

        public void DetachHandlers()
        {

        }

    }
}
VB.NET
Imports Keyoti.SearchEngine.Events
Imports Keyoti.SearchEngine.Documents
Imports Keyoti.SearchEngine.DataAccess
Imports Keyoti.SearchEngine
Imports System.Collections
Imports System.IO

Namespace Keyoti.SearchEngine
    '''
    ''' Creates a site-map when a web-site is crawled.
    '''
    Public Class ExternalEventHandler

        Private dispatcher As IEventDispatcher
        Private conf As Configuration

        Public Sub New(ByRef dispatcher As IEventDispatcher, ByRef conf As Configuration)

        End Sub

        Public Sub DetachHandlers()

        End Sub

    End Class
End Namespace

This is now an empty plug-in, it will compile and the search engine can attach to it, however it will not do anything.

Step 4. Attach/detach event handlers

In order to do something, the class needs to attach event handlers in the constructor, and detach those handlers when asked.

C#
        public ExternalEventHandler(IEventDispatcher dispatcher, Configuration conf)
        {
            Keyoti.SearchEngine.DataAccess.Log.WriteLogEntry("SiteMapper", "Initialized", conf);
            dispatcher.Action += new ActionEventHandler(dispatcher_Action);
            dispatcher.NeedObject += new NeedObjectEventHandler(dispatcher_NeedObject);
            this.dispatcher = dispatcher;
            this.conf = conf;

            ...
        }

        public void DetachHandlers()
        {
            if (dispatcher != null)
            {
                dispatcher.Action -= new ActionEventHandler(dispatcher_Action);
                dispatcher.NeedObject -= new NeedObjectEventHandler(dispatcher_NeedObject);
            }
           ...
        }
VB.NET
        Public Sub New(ByRef dispatcher As IEventDispatcher, ByRef conf As Configuration)
            MyBase.New()
            Log.WriteLogEntry("SiteMapper", "Initialized", conf)
            AddHandler dispatcher.Action, AddressOf Me.dispatcher_Action
            AddHandler dispatcher.NeedObject, AddressOf Me.dispatcher_NeedObject
            Me.dispatcher = dispatcher
            Me.conf = conf
            ...
        End Sub

        Public Sub DetachHandlers()
            If (Not (dispatcher) Is Nothing) Then
                RemoveHandler dispatcher.Action, AddressOf Me.dispatcher_Action
                RemoveHandler dispatcher.NeedObject, AddressOf Me.dispatcher_NeedObject

            End If
            ...
        End Sub

The code also writes to a custom log file, named "SiteMapper.txt" (if Logging is enabled in Configuration) and keeps a reference to the configuration (conf) and event dispatcher (dispatcher).

Step 5. Add event handler methods

Event handler methods are added, and the constructor/detach methods are completed with calls to create/close a StreamWriter.

C#
using System;
using System.Collections;
using System.Text;
using System.IO;
using Keyoti.SearchEngine.Events;
using Keyoti.SearchEngine.Documents;
using Keyoti.SearchEngine.DataAccess;
using Keyoti.SearchEngine;

namespace Keyoti.SearchEngine
{
    ///
    /// Creates a site-map when a web-site is crawled.
    ///
    public class ExternalEventHandler
    {
        StreamWriter sw;

        IEventDispatcher dispatcher;
        Configuration conf;
        public ExternalEventHandler(IEventDispatcher dispatcher, Configuration conf)
        {
            Keyoti.SearchEngine.DataAccess.Log.WriteLogEntry("SiteMapper", "Initialized", conf);
            dispatcher.Action += new ActionEventHandler(dispatcher_Action);
            dispatcher.NeedObject += new NeedObjectEventHandler(dispatcher_NeedObject);
            this.dispatcher = dispatcher;
            this.conf = conf;

            sw = new StreamWriter(Path.Combine(conf.IndexDirectory, "sitemap.txt"), false);
        }

        public void DetachHandlers()
        {
            if (dispatcher != null)
            {
                dispatcher.Action -= new ActionEventHandler(dispatcher_Action);
                dispatcher.NeedObject -= new NeedObjectEventHandler(dispatcher_NeedObject);
            }
            sw.Close();

        }

        public void dispatcher_Action(object sender, ActionEventArgs e)
        {
            Keyoti.SearchEngine.DataAccess.Log.WriteLogEntry("CustomAssembly", e.ActionData.Name.ToString(), conf);
            if (e.ActionData.Name == ActionName.DocumentBeingCrawled)
            {
                Document document = (e.ActionData.Data as object[])[0] as Document;
                ArrayList links = (e.ActionData.Data as object[])[1] as ArrayList;

                sw.WriteLine("##################################################################");
                sw.WriteLine(document.Uri.AbsoluteUri);
                sw.WriteLine("------------------------------------------------------------------");
                foreach (Uri link in links)
                    sw.WriteLine(link.AbsoluteUri);

                sw.Flush();
            }
        }

        public void dispatcher_NeedObject(object sender, NeedObjectEventArgs e)
        {

        }
    }
}
VB.NET
Imports Keyoti.SearchEngine.Events
Imports Keyoti.SearchEngine.Documents
Imports Keyoti.SearchEngine.DataAccess
Imports Keyoti.SearchEngine
Imports System.Collections
Imports System.IO

Namespace Keyoti.SearchEngine
    '''
    ''' Creates a site-map when a web-site is crawled.
    '''
    Public Class ExternalEventHandler

        Private sw As StreamWriter

        Private dispatcher As IEventDispatcher

        Private conf As Configuration

        Public Sub New(ByRef dispatcher As IEventDispatcher, ByRef conf As Configuration)
            MyBase.New()
            Log.WriteLogEntry("SiteMapper", "Initialized", conf)
            AddHandler dispatcher.Action, AddressOf Me.dispatcher_Action
            AddHandler dispatcher.NeedObject, AddressOf Me.dispatcher_NeedObject
            Me.dispatcher = dispatcher
            Me.conf = conf
            sw = New StreamWriter(Path.Combine(conf.IndexDirectory, "sitemap.txt"), False)
        End Sub

        Public Sub DetachHandlers()
            If (Not (dispatcher) Is Nothing) Then
                RemoveHandler dispatcher.Action, AddressOf Me.dispatcher_Action
                RemoveHandler dispatcher.NeedObject, AddressOf Me.dispatcher_NeedObject

            End If
            sw.Close()
        End Sub

        Public Sub dispatcher_Action(ByVal sender As Object, ByVal e As ActionEventArgs)
            Log.WriteLogEntry("CustomAssembly", e.ActionData.Name.ToString, conf)
            If (e.ActionData.Name = ActionName.DocumentBeingCrawled) Then
                Dim document As document = CType(CType(e.ActionData.Data, Object())(0), document)
                Dim links As ArrayList = CType(CType(e.ActionData.Data, Object())(1), ArrayList)
                sw.WriteLine("##################################################################")
                sw.WriteLine(document.Uri.AbsoluteUri)
                sw.WriteLine("------------------------------------------------------------------")
                For Each link As Uri In links
                    sw.WriteLine(link.AbsoluteUri)
                Next
                sw.Flush()
            End If
        End Sub

        Public Sub dispatcher_NeedObject(ByVal sender As Object, ByVal e As NeedObjectEventArgs)

        End Sub
    End Class
End Namespace

The site-mapper is only interested in the Action event and in particular actions with name DocumentBeingCrawled (for interest, the example will write all actions received to the log file CustomAssembly.txt if Logging is enabled). When an action named DocumentBeingCrawled occurs, the ActionData.Data object is used to access the document in question and it's links (information about action names and associated data is in the API documentation 'Namespaces'). The document Uri and link list is written to the text file by a StreamWriter.

Step 6. Using the plug-in DLL

Now the project is complete, it can be compiled and used. For development and testing, the easiest way to use the plug-in is to create an Index Directory with a configuration setting linking to the DLL. In the demo project this is already done, there is a folder named IndexDirectory under the project which contains only a configuration.xml file. The Configuration.EventHandlerAssemblyPath property is set to the path of the DLL, relative to the index directory (eg. ..\bin\Plug-in_SiteMap_vb.dll). Since any search process working on this Index Directory will use the plug-in DLL, it can be tested very simply;

  1. Open the Windows based Index Manager Tool - be sure to select the CLR version that matches the references in the plug-in project
  2. Set the Index Directory path to the absolute path of the IndexDirectory folder under the project
  3. Open the Plug-in form from the tool, enter the file path to the plug-in dll and Save. If desired enable logging from the Configuration form.
  4. Click the Indexed Sources form and Import a source
  5. The file 'sitemap.txt' should contain information about the web-site imported

Debugging Notes

Due to the nature of DLL loading, there are some handy tips;

  • Attach the plug-in project's Visual Studio debugger to the process currently working with the Index Directory; This will enable break-points to be set
  • Avoid using the plug-in with a web project until the plug-in is complete, as the application will need to be stopped in order to update the DLL
  • If nothing is happening; Enable logging, try again, then check the CentralEventDispatcher.txt log file - this should contain information about what happened. If it mentions failure to load the assembly, then try to a) minimize the constructor code, to ensure that the plug-in can at least be loaded without failing. b) ensure the references match (see the notes section 'References To Search DLLs')


SearchUnit Documentation: How do I...: ...programmatically import

Show language: C# VB.NET Both

Programmatic Importing & Indexing

This page describes 3 methods of indexing, importing an entire source, adding 1 document at a time (incremental indexing), and adding data directly to the index as strings

Importing An Entire Source

'Importing' a website/file-system folder/database/DataSet means that the indexer will scan for all available documents/pages/data and index everything that matches the import criteria. Reimporting will cause the indexer to rescan the source for changes (where possible, otherwise reindex everything). To import programmatically, use the appropriate Import method in DocumentIndex;

Also see here for a complete code example (Form)

More information on import parameters.

C#
DocumentIndex documentIndex = new DocumentIndex(configuration);
//import a website
documentIndex.ImportWebsite( startURL );
//or like this
documentIndex.Import(new WebsiteBasedIndexableSourceRecord( startURL, pathMatchesToBeIgnored, pathMatchesToBeIncluded));

//or import a file system folder
documentIndex.ImportFileSystemFolder(localFolderPath, virtualPath, targetMatchList, ignoreMatchList, recurseSubFolders);

//or import a database
documentIndex.ImportDatabase(sourceType, connectionString, sqlQuery, uniqueColumnName, resultUrlFormat);

//or import a DataSet (from an assembly)
documentIndex.ImportCustomDataSet(assemblyFilePath, fullClassName, uniqueColumnName, resultUrlFormat);

documentIndex.Close();
VB.NET
Dim documentIndex As New DocumentIndex(configuration)
'import a website
documentIndex.ImportWebsite( startURL )
'or like this
documentIndex.Import(new WebsiteBasedIndexableSourceRecord( startURL, pathMatchesToBeIgnored, pathMatchesToBeIncluded))

'or import a file system folder
documentIndex.ImportFileSystemFolder(localFolderPath, virtualPath, targetMatchList, ignoreMatchList, recurseSubFolders)
'or import a database
documentIndex.ImportDatabase(sourceType, connectionString, sqlQuery, uniqueColumnName, resultUrlFormat)
'or import a DataSet (from an assembly)
documentIndex.ImportCustomDataSet(assemblyFilePath, fullClassName, uniqueColumnName, resultUrlFormat)
documentIndex.Close()

Adding One Document

Instead of importing an entire source, it is possible to add documents/data to the index incrementally. This is ideal for updating the index as documents are created/uploaded.

C#
DocumentIndex documentIndex = new DocumentIndex(configuration);
try{
    documentIndex.AddDocument(new Document("http://some/URL/document", configuration));
} finally {
    documentIndex.Close();
}
VB.NET
Dim documentIndex As DocumentIndex = New DocumentIndex(configuration)
Try
    documentIndex.AddDocument(new Document("http://some/URL/document", configuration))
Finally
    documentIndex.Close()
End Try

Note that "AddDocument" may or may not complete in a trivial amount of time (the actual amount of time depends on many factors including machine load, document size/type, index size, whether the index is due optimization etc), therefore it is not advisable for use in web applications (as the web page doing the indexing will not return to the user until AddDocument has finished).

Asynchronous Adding (.NET 2 up)

Adding to the index asynchronously allows your code to return immediately (e.g. for a web application's upload document page to return immediately), while the document is queued up to be added to the index as soon as possible in the background. To do this use the AsynchronousQueue class (in namespace Keyoti.SearchEngine.Index) - which will queue up AddDocument operations and call them in their original order. AsynchronousQueue uses it's own instance of DocumentIndex, and will create and close that instance as necessary (therefore it is important not to have another instance of DocumentIndex open on the same index directory while there are items in the queue).

C#
//...this code could be called in a button event handler in a web page for example

EventHandler finished = delegate(object sender, EventArgs e)
{
    //at this point the index directory is unlocked and there are no more items pending adding to the index.
};

AsynchronousQueue.QueueForIndexing(new Document("http://someURL/somepage.aspx", Configuration), finished);
AsynchronousQueue.QueueForIndexing(new Document("http://someURL/somepage2.aspx", Configuration), finished);
VB.NET
Private Sub MyFunc()
    '...this code could be called in a button event handler in a web page for example
    Dim finished As EventHandler = AddressOf Me.OnFinished
    AsynchronousQueue.QueueForIndexing(New Document("http://someURL/somepage.aspx", Configuration), finished)
    AsynchronousQueue.QueueForIndexing(New Document("http://someURL/somepage2.aspx", Configuration), finished)
End Sub

Private Sub OnFinished(ByVal sender As Object, ByVal e As EventArgs)
    'at this point the index directory is unlocked and there are no more items pending adding to the index.
End Sub

Removing One Document

Use the RemoveDocument method in DocumentIndex to remove a document from the index. It's important that the document URL matches exactly with the URL already in the index. Please pay attention to trailing slashes (e.g. http://localhost/) and ensure any spaces are encoded as %20.

Asynchronous Remove (.NET 2 up)

Removing from the index asynchronously allows your code to return immediately (e.g. for a web application's deleete document page to return immediately), while the document is queued up to be removed from the index as soon as possible in the background. To do this use the AsynchronousQueue class (in namespace Keyoti.SearchEngine.Index) - which will queue up RemoveDocument operations and call them in their original order. AsynchronousQueue uses it's own instance of DocumentIndex, and will create and close that instance as necessary (therefore it is important not to have another instance of DocumentIndex open on the same index directory while there are items in the queue).

This is the same queue as the asynchronous adding example uses and both add and remove operations can be mixed.

C#
//...this code could be called in a button event handler in a web page for example

EventHandler finished = delegate(object sender, EventArgs e)
{
    //at this point the index directory is unlocked and there are no more items pending adding to the index.
};

AsynchronousQueue.QueueForRemoval(new Document("http://someURL/somepage.aspx", Configuration), finished);
AsynchronousQueue.QueueForRemoval(new Document("http://someURL/somepage2.aspx", Configuration), finished);
VB.NET
Private Sub MyFunc()
    '...this code could be called in a button event handler in a web page for example
    Dim finished As EventHandler = AddressOf Me.OnFinished
    AsynchronousQueue.QueueForRemoval(New Document("http://someURL/somepage.aspx", Configuration), finished)
    AsynchronousQueue.QueueForRemoval(New Document("http://someURL/somepage2.aspx", Configuration), finished)
End Sub

Private Sub OnFinished(ByVal sender As Object, ByVal e As EventArgs)
    'at this point the index directory is unlocked and there are no more items pending adding to the index.
End Sub

Removing a 'document' that originated in a DB

When a row is imported from a DB, we create our own URI for it. To delete that row/document, you need to recreate the URI.

C#
IndexableSourceUri uri = new IndexableSourceUri(1, "d4", "col1");
//where 1 is the IndexableSource ID (see below)
//"d4" is the value in the unique field, that identifies the row to delete
//"col1" is the name of the unique field

documentIndex.RemoveDocument(new Document(uri.UriInstance.AbsoluteUri, Configuration));
In the above, the data was originally imported from a query like this
col1	data
-------------
a1	blah
b2	some
c3	empty
d4	more
so the code will remove that last row from the index. The indexable source ID, can be obtained with code like this
C#
ArrayList recs = documentIndex.GetIndexableSourceRecords();
(recs[0] as IndexableSourceRecord).ID;
assuming that the first record is the one you need. Otherwise you can iterate through 'recs' and look at the Query or Location properties to find the one you need.

Adding Data Directly As Strings

It is possible to add 'documents' to the index that are defined by strings only. In other words, it is possible to index data without the data having to actually reside in a document/page/database etc. This can be useful in the following scenarios for example;

  • Searchable content doesn't match actual content (e.g. extra description or meta info)
  • Indexing database content in a 'push' fashion (unlike Importing which is 'pull') - useful for incremental DB indexing
  • Indexing content from a custom parser
  • Indexing meta info for audio/video files
  • Whenever it's desirable to have full control of what is indexed, when.

To do this, use the PreloadedDocument class, which is a simple class where you pass the 'URI' that will identify the indexed data/document, and specify it’s title, text and custom data - all as strings.

C#
documentIndex.AddDocument(new PreloadedDocument(new Uri(uri), title, text, summary, null, null, null, customData, configuration));
VB.NET
documentIndex.AddDocument(new PreloadedDocument(new Uri(uri), title, text, summary, Nothing, Nothing, Nothing, customData, configuration))

Where;
-'uri' is the real or fictitious Uri of the 'document' - this can point to an actual document or just be used as an arbitrary identifier for the indexed data
-'title' is string title of the document, searchable by the user
-'text' is the text body, this is searchable by the user
-'summary' is used for the result summary if a 'static' summary type is selected in the configuration (otherwise the result summary is generated from the text content based on hits)
-The 3 null/nothings are respectively; content category list, location category name and security group list (please see the API docs)
-'customData' is any CustomData to be added to the document record
-'configuration' is the usual configuration object, as was used to create DocumentIndex

Removing A PreloadedDocument

To remove a 'document' added with PreloadedDocument, use documentIndex.RemoveDocument, passing in the same Uri that the document was created with.


SearchUnit Documentation: How do I...: ...modify identified character encoding in TXT files

Show language: C# VB.NET Both

TXT File Character Encoding

In the event that the encoding of a document or documents is not identified correctly, the Central Event System can be used to modify the encoding used. For example, .TXT files do not contain any header information about the encoding that they are saved in (except for BOMs when present). If the encoding is not returned by the server (which is unlikely) then UTF-8 is assumed. This may cause trouble with non English language files. As the search engine does not have enough information to properly read the file, the Central Event System can be used to provide that information. Please see the Central Event System section for general information on it.

Note: The encoding of HTML files is read either from the server response or from a standard meta tag containing the charset identifier (if present).

The following Action event handler will wait for a document with URL "http://host/myfile.txt" and set it's encoding to "Windows-1250". This can easily be modified to set encodings for any range of files as desired.

C#
private void CentralEventDispatcher_Action(object sender, Keyoti.SearchEngine.Events.ActionEventArgs e)

{

    if(e.ActionData.Name==Keyoti.SearchEngine.Events.ActionName.UseDocumentEncoding)

    {

        if( (e.ActionData.Data as Document).Uri.AbsoluteUri == "http://host/myfile.txt")

        {

                (e.ActionData.Data as Document).Encoding = System.Text.Encoding.GetEncoding("Windows-1250");

        }

     }

}
VB.NET
Private Sub CentralEventDispatcher_Action(ByVal sender As Object, ByVal e As Keyoti.SearchEngine.Events.ActionEventArgs)

        If (e.ActionData.Name = Keyoti.SearchEngine.Events.ActionName.UseDocumentEncoding) Then

            If (CType(e.ActionData.Data,Document).Uri.AbsoluteUri = "http://host/myfile.txt") Then

                CType(e.ActionData.Data,Document).Encoding = System.Text.Encoding.GetEncoding("Windows-1250")

            End If

        End If

    End Sub


SearchUnit Documentation: How do I...: ...add custom or new document parsers

Customized Or New Document Parsers

Using the Central Event System, additional or replacement document parsers can be added for use by the indexer.

There are 2 ways to use the event system, either directly or via a plug-in. When programmatic code is creating an index (i.e. direct use of the search API), then the event handlers below can be attached to the configuration object (as below). If a UI is creating an index (i.e. Index Manager Tool, Web Admin or Windows Service) then the event handlers must be attached via a plug-in (see the plug-in section for more info).

The following assumes that indexing will be programmatic, and an object named "configuration" exists and was used to create the DocumentIndex, eg.

Keyoti.SearchEngine.Configuration configuration = new Keyoti.SearchEngine.Configuration();
configuration.IndexDirectory = "...some path...";
DocumentIndex documentIndex = new DocumentIndex(configuration);

Step 1.

Attach to the NeedObject event from the Central Event System.

configuration.CentralEventDispatcher.NeedObject+=
                new Keyoti.SearchEngine.Events.NeedObjectEventHandler(CentralEventDispatcher_NeedObject);
Step 2.

Handle the event and return a custom subclass of ParserProvider

void CentralEventDispatcher_NeedObject(object sender, Keyoti.SearchEngine.Events.NeedObjectEventArgs e)
{
    if (e.RequiredObject is Keyoti.SearchEngine.Documents.ParserProvider)
    {
        e.RequiredObject = new ExtendedParserProvider(e.Configuration);
    }
}
Step 3.

Write the class, ExtendedParserProvider, which will return the custom parser when the appropriate MIME type is encountered

public class ExtendedParserProvider : ParserProvider
{

    public ExtendedParserProvider(Configuration c) : base(c){}

    public override Parser GetParser(string mimeType)
    {
        if(mimeType=="application/my.file.type")
        {
            return new QQQDocumentParser(Configuration);
        } else
            return base.GetParser (mimeType);
    }
}
Step 4.

If the mime type is not known by the search engine, associate it with the file extension.

For example, if handling a previously unhandled file type with a file extension .qqq, add it to the FileTypeSettings property in the Configuration

eg. programmatically (the same can be achieved in the visual configuration editors, or in the Configuration.xml file in the index directory)

configuration.FileTypesSettings.Add("QQQ", "application/my.file.type");

this associates the new mimetype application/my.file.type with any files with the extension .qqq (note that the extension must be added in uppercase).

Step 5.

Add the QQQDocumentParser class - which overrides the Read method. The method below takes the string content (which it is up to the user to provide) and processes it in base.Read to return the necessary "DocumentText" object.

eg.

public class QQQDocumentParser : Keyoti.SearchEngine.Documents.TxtDocumentParser
{

    public QQQDocumentParser(Configuration c) : base(c) { }

    public override Keyoti.SearchEngine.Documents.DocumentText Read(System.IO.Stream stream, Uri uri, System.Text.Encoding encoding)
    {
        //stream is the document as a stream (i.e. as it is returned from the server)
        //uri is the document's Uri
        //e is the response encoding from the server
        //the stream should be read, and plain text from it added to a string and set in the "documentBody" variable
        string documentBody = "this is test content, real content comes from user created parser.";
        return base.Read(documentBody, uri, encoding);
    }
}


SearchUnit Documentation: How do I...: ...assign location & content categories

Show language: C# VB.NET Both

Assigning Location & Content Categories

Pro only

This example demonstrates how to assign new documents added during import to a specific content category (testcon) and existing documents to be added when 'Auto Assign' is clicked from the Index Manager window. It is intended to provide you with a general guide for creating your own custom assembly for the Central Event System.

Please see the Central Event System overview.

C#
using Keyoti.SearchEngine;
using Keyoti.SearchEngine.Events;

namespace Keyoti.SearchEngine
{
    public class ExternalEventHandler
    {

        private IEventDispatcher dispatcher;

        private Configuration conf;

        public ExternalEventHandler(IEventDispatcher dispatcher, Configuration conf)
        {
            Keyoti.SearchEngine.DataAccess.Log.WriteLogEntry("CustomAssembly", "SUCCESS", conf);
            dispatcher.Action += new ActionEventHandler(dispatcher_Action);
            this.dispatcher = dispatcher;
            this.conf = conf;
        }

        public void DetachHandlers()
        {
            dispatcher.Action -= new ActionEventHandler(dispatcher_Action);

        }

        public void dispatcher_Action(object sender, Keyoti.SearchEngine.Events.ActionEventArgs e)
        {
            // here we pay attention to the auto assign event, and add every document to "testcon"
            if ((e.ActionData.Name == ActionName.AutoAssignContent))
            {
                Keyoti.SearchEngine.DataAccess.DocumentRecord rec;
                Keyoti.SearchEngine.DataAccess.XmlDataAccess da;
                rec = ((Keyoti.SearchEngine.DataAccess.DocumentRecord)(e.ActionData.Data));
                da = ((Keyoti.SearchEngine.DataAccess.XmlDataAccess)(sender));
                rec.ContentCategories.Add(da.GetContentCategoryRecord("testcon"));
            }
        }
    }
}
VB.NET
Imports Keyoti.SearchEngine
Imports Keyoti.SearchEngine.Events

Public Class ExternalEventHandler

    Dim dispatcher As IEventDispatcher
    Dim conf As Configuration

    Public Sub New(ByVal dispatcher As IEventDispatcher, ByVal conf As Configuration)

        Keyoti.SearchEngine.DataAccess.Log.WriteLogEntry("CustomAssembly", "SUCCESS", conf)
        AddHandler dispatcher.Action, New ActionEventHandler(AddressOf dispatcher_Action)

        Me.dispatcher = dispatcher
        Me.conf = conf
    End Sub

    Public Sub DetachHandlers()

        RemoveHandler dispatcher.Action, New ActionEventHandler(AddressOf dispatcher_Action)
    End Sub

    Public Sub dispatcher_Action(ByVal sender As Object, ByVal e As Keyoti.SearchEngine.Events.ActionEventArgs)

        'here we pay attention to the auto assign event, and add every document to "testcon"

        If e.ActionData.Name = ActionName.AutoAssignContent Then

            Dim rec As Keyoti.SearchEngine.DataAccess.DocumentRecord
            Dim da As Keyoti.SearchEngine.DataAccess.XmlDataAccess
            rec = CType(e.ActionData.Data, Keyoti.SearchEngine.DataAccess.DocumentRecord)
            da = CType(sender, Keyoti.SearchEngine.DataAccess.XmlDataAccess)
            'now we have the document being assigned, lets give it a preset category
            'for this to work a category called "testcon" must already exist
            rec.ContentCategories.Add(da.GetContentCategoryRecord("testcon"))

        End If
    End Sub

End Class


SearchUnit Documentation: Result Generation: How do I...: ...add CustomData to a document

Show language: C# VB.NET Both

Custom Data

Custom data, containing specific information about a document, can be assigned to a document at the indexing stage and then recalled during a search. The data's origin, type and relevance are determined by the developer and can be presented to the end user (as extra fields or an image for example) or processed to affect the search results in some way (such as result order).

Source Of Custom Data

The origin of the data is open to the developer, if for example the document represents an item from a database, then the data could be specially selected database columns (such as dates, ownership or other meta data). The data could also consist of the result of an analysis of the document, or data that was originally used in the creation of the document (such as product names, related page URLs or thumbnail images).

Types of Custom Data

The custom data is held as a string, however it can consist of simple or complex types (through the use of delimiters for example) and can be used to store any kind of data (from simple strings through to UUEncoded binary).

Custom date data used for sorting and additional user info.

Adding Custom Data To A Document

This can be achieved either through meta tags in HTML based documents, or through the Central Event System. The indexer will read the data and store it with the document record.

Meta-tags

By adding the following meta tag to a document

<meta name="Keyoti_Search_Custom_Data" content="..." />

The content attribute holds the custom data that should be stored with the document. Technically there is no limit to the length of the data, however large amounts of data (kilobytes) will make reading the document table slower, and thus affect most operations to some degree. If the document is dynamically generated then the custom data can be inserted at run-time, otherwise the data will be static.

Central Event System

By subscribing to the Action event and processing ActionName.ReadText. The associated ActionData.Data is of type DocumentText which has a property called MetaCustomData, which can be set to the data that should be stored. See the Central Event System section for more information on handling actions.

C#
private void CentralEventDispatcher_Action(object sender, Keyoti.SearchEngine.Events.ActionEventArgs e)

{

    if(e.ActionData.Name== ActionName.ReadText)

    {

        string documentUri = (sender as Document).Uri.AbsoluteUri;

        (e.ActionData.Data as DocumentText).MetaCustomData = "my custom data";

    }

}
VB.NET
Private Sub CentralEventDispatcher_Action(ByVal sender As Object, ByVal e As Keyoti.SearchEngine.Events.ActionEventArgs)

        If (e.ActionData.Name = ActionName.ReadText) Then

            Dim documentUri As String = CType(sender,Document).Uri.AbsoluteUri

            CType(e.ActionData.Data,DocumentText).MetaCustomData = "my custom data"

        End If

    End Sub

In this example every document will have it's custom data set to the string "my custom data". The documentUri variable could be used to determine what custom data should be set for the document, for example the document's URI could be used to lookup data in a database, or find a related image.

PDF Meta Data

PDF file meta data can be accessed through the DocumentText.MetaData Hashtable. For example to set CustomData to the PDF creation date, use (e.ActionData.Data as DocumentText).MetaCustomData = (e.ActionData.Data as DocumentText).MetaData["CreateDate"], note however that meta data is not guaranteed to exist. Other keys in the meta data hashtable are CreateDate, CreatorTool, ModifyDate, Producer, Title, and Format.

Using CustomData in a search

Please see the how-to in the 'Searching an Index' section: ...use CustomData for date sorting


SearchUnit Documentation: The Index Manager

The Index Manager

The index manager is designed to be the central tool for crawling web-sites and building indexes for searching. The tool is launched from the Windows Start menu, under SearchUnit, (or if using the ASP.NET Conrols bydropping the SearchResult control onto a form, and then right clicking it to choose the 'Index Manager' option).

Initially an 'Index Directory' must be set, this mirrors the property of the same name in the SearchResult control, and indicates where on the development machine the index files will be written.

Indexed Sources
The document sources that have been indexed - allows documents to be added/removed/viewed.

Configuration
Form for changing index/search settings for the current index directory.

Locations, Contents and Security Groups
Displays a list of documents allowing you to manually add/remove documents from the index.

Plug-in
Allows developers to control engine behavior.

Search
Can be used to check the index has been built correctly without having to leave the Index Management Tool.

Optimize
Defragments and merges Index Directory files. Should be used after managing the index to increase performance.

Publish
Copy the index directory to another folder or FTP it to a server.

Windows Service
Control the Windows Service for automated reindexing.

Logs
View/delete the log files created during importing and indexing. The log files can aid in understanding what operations are doing. Please see the 'Logging' section of the Help documentation for details.

Index Directory field
Change the Index Directory to work with.


SearchUnit Documentation: The Index Manager : Location, Content and Security Group Editors

The Index Manager : Location, Content and Security Group Editors

For full details please see the Assigning Content And Location Categories and Security Groups sections of the Pro addendum Help documentation.

Category/Group List

Adding new items

  1. Click the Name field on the new row (marked by *) and type the name for the category or group you would like to create.
  2. (Optional) Click the 'Auto Assign Path' column and enter a string that will be used to identify matching paths - see 'Auto-assigning documents' below for details.

Deleting items

  1. Select the row you wish to delete.
  2. Right click the row and select 'Delete Item'.

When deleting a category or group that has documents assigned to it you will be asked whether to unassign them. Clicking OK will unassign them from the category or group, if the document doesn't belong to any other category or group it will be assigned to default.

Document List View

Assigning/unassigning documents

Documents can be assigned/unassigned manually to each category or group from the Document List View.

    Assigning

  1. Locate and select the document(s) to be assigned.
  2. From the drop down box select the category/group name to which documents should be assigned.
  3. Select 'Assign Selected Documents'.

    4. Documents that have already been assigned can be assigned to additional Content categories or Security Groups by locating selecting the category/group name containing the documents and following the steps above.

    Unassigning

  1. Locate and select the document(s) to be unassigned.
  2. Click 'Unassign Selected Documents from ...'

Auto-assigning documents

By adding an Auto Assign Path to a category or group, documents can be automatically matched based on their path.

  1. Enter the name of the category or group you would like to create.
  2. In the Auto Assign Path column, enter the string that will be used to identify matching paths.
  3. To automatically assign pages that have already been imported, click 'Auto Assign Documents'.
    Note: To reassign documents that have been assigned to a different category or group select 'Auto Reassign All Documents' by clicking the arrow on the right hand side of the button.

Any documents imported in the future that meet the Auto Assign Path criteria will be automatically assigned for you.


SearchUnit Documentation: The Index Manager : Indexed Sources

The Index Manager : Indexed Sources

Indexed Sources List

The Indexed Sources screen displays a list of imported sources and allows new sources to be added, re-imported, removed and the source parameters to be changed.

Importing a new source

'Import New Source' is used to discover and index links from different sources, such as a Website, Database or using the file system . Please see the Import section of the Help documentation for details.

  1. Click 'Import New Source'
    To setup source parameters such as Path Matches to be Ignored, select 'More Options' before importing.
  2. Choose 'Type of Source' you wish to import - 'Website' for example.
  3. Click 'Import' to begin crawling and indexing new documents.
  • Once the import has completed or 'Stop' has been selected, the source is ready to be searched.

Re-import a source

Used to discover and index new links and re-index documents that have changed. Please see the Document Reindexing Logic section of the documentation for further details.

  1. Click 'Re-import Source' or right click an existing source and select.
  2. Click 'Import' to re-crawl and index documents.
  • To change source parameters ('More Options') you will need to select 'Edit Source Parameters' from the Indexed Sources screen.

Add new documents to 'Unassigned Documents'

'Unassigned Documents' contains all documents that have been manually added to the index. These may be documents that are not linked within your website or documents of special interest that need to be searchable.

  1. Click 'Add New Document' or right click on 'Unassigned Documents' and select.
  2. Enter the document URL to index.
  3. Click 'Add to Index'.
  • Once complete the document will be found within the Unassigned Documents source and will be ready to be searched.

Document List View

The document list view section of the Indexed Sources page displays a summary of the indexed documents including; URI, Page Title, Description, Custom Data as well as the Security Groups, Location & Content category names assigned to the documents. All documents within specific sources can be viewed by clicking on the relevant source in the Indexed Sources section.

Filter

Use the filter box to view only those documents that match a specific string. The filtered results will include matches within the URI and the indexed document text.

More information

Further details about a document such as the Last Modified Date and its indexed text can be seen by right clicking a row and selecting 'More Information'.

Deleting documents from the index

To remove specific documents from the index;

  1. Select the source that contains the document from the Indexed Sources List.
  2. From the Document List View select the row(s) for each document to be removed.
  3. Right click over the selection and click 'Remove document(s) from the index'.
  • All indexed text associated with the document(s) will be deleted and will no longer be searchable.

To remove an imported source (all documents within a source and the source parameters);

  1. Select the source from the Indexed Sources List.
  2. Select 'Delete Source' from menu or right click and select from the context menu.


SearchUnit Documentation: The Index Manager : Plug-in

The Index Manager : Plug-in

By specifying your own custom logic in an assembly (plug-in) the search engine can be further customized and/or extended.

Full details and examples can be found in the Central Event System (Plug-ins) section of the Help documentation.

Specifying a Plug-in DLL

Select the Plug-in tab from the Index Management Tool. Click "Change Plug-in Path" and select your plug-in dll. A message confirming whether the plug-in initialized correctly or failed to initialize will be shown.

Creating a Plug-in VS Project

A blank plug-in project can be created for you, ready to customize and extend the search engine as required. Enter the path of a folder to create the project in. If the folder does not exist it will be created automatically.


SearchUnit Documentation: The Index Manager : Publish

The Index Manager : Publish

The publish form provides a convenient way of copying the index directory over the file-system to another folder or by uploading it to a remote folder via FTP. A scheduled task can also be created to periodically update the index locally and then republish it.

Publish settings

Enter the local folder or FTP details where the index files should be copied to;
  • The file-system
    Enter the path to the target folder or click Browse to locate it.
  • FTP
    Enter your FTP server details, a remote folder that exists on the server and FTP login credentials.

Select Publish Now to copy the index directory contents to the new location. It will minimize search interruption by toggling the search to the new index only when the content has been copied across.

Automatically Update and Republish Index

A scheduled task can be created to periodically update the index locally and then republish it using the publish settings outlined above.

Additionally, an email log containing the results of the republish can be sent once the operation is complete. Enable the Send Email Log check box and complete your email server Smtp credentials. Please note that emails may go to your spam folder - add the 'from email' as a trusted sender in the email client.

To begin setting up the new task click Create Task and specify when the task should run and frequency of repetition;

  • Start Date
    The date on which the scheduled task should first run.
  • Start Time
    The time of day that the scheduled task should first run.
  • Days
    The number of days to wait between runs (use 0 only if Hours > 0). To run without repetition use -1 days.
  • Hours
    The number of hours to wait between runs (use 0 only if Days > 0).


SearchUnit Documentation: The Index Manager : Windows Service

The Index Manager : Windows Service

Full details can be found in the Windows Service section of the Help documentation

Index Directories

This setting is global to the entire machine, not just the current index directory. Specify all index directories that the service should work with, one per line.

Settings

There are two settings in the Windows Service screen that affect the service index timing;
  • Rebuild frequency - Sets how many hours should pass since the last index operation before reindexing is performed.
  • Start indexing hour - The hour of the day at which the first indexing operation will happen.

    • For example, to set the service to index;

    • Every night at 1am; set Start indexing hour to 1, and set Rebuild frequency to 24
    • Every other day at 6pm; set Start indexing hour to 18, and set Rebuild frequency to 48
    • Every 6 hours starting at midnight; set Start indexing hour to 0, and set Rebuild frequency to 6
By default the Windows Service will optimize the index once it has completed importing the sources to maintain performance. To deactivate automatic optimization uncheck 'Service Will Optimize Index'.

Note

The Windows Service will not be able to import documents while the Index Manager Tool is open on the same index directory at the same time. Please ensure the Index Manager Tool is not open at the time of the next indexing operation.


SearchUnit Documentation: The Index Directory

The Index Directory

The index directory

Purpose

The index directory is the place where all index and configuration files are stored. It is in read/write mode during the import and modify processes and read mode during search. When in read/write mode, the import/build operations work on temporary files to allow concurrent search operations to continue unaffected.

Location

The index directory can reside in any location (provided the user process has permission to access it, see below). The index configuration itself has no absolute paths, so it is portable. The index directory has references to other resources, (such as database files, dictionaries, plug-in DLLs and folder paths) which can be set with paths relative to the index directory, using relative paths allows the index and the resources to be moved easily to other locations as a unit.

The only resources linked from an index that must be absolute, are document URLs - see the "Typical Development & Deployment Scenarios" section under "Examples" if the index contains links to 'localhost'.

Setup

Of course, for read/write operations (import/build/modify) the user process that the application runs under must have read/write access, and for read operations (search) the user must at least have read access.

The user names under which the process runs are typically;

  • Index Manager Tool (also under Visual Studio) - current logged in user
  • ASP.NET applications - "ASPNET" for IIS 5 and "NetworkService" for IIS 6, "IIS_IUSRS" for IIS7+ (if you use impersonation it could be a different user)
  • Programmatic - typically as above - depends on the type of application
  • Windows Service - "LocalService"

Index Configuration

The index configuration is stored in the "configuration.xml file in the index directory - please see the Configuration section for more information.


SearchUnit Documentation: Configuration

Show language: C# VB.NET Both

Configuration

Associated with every Index Directory is a configuration.xml file, which holds the settings associated with the index. The configuration.xml file resides inside the Index Directory.

Whenever an index is worked with (import or search) a configuration object must be loaded. If the operation is programmatic then a Configuration object (holding the settings) must be passed to the various components. If the operation is part of the provided tools (Index Manager Tool, Visual Studio designer, Web Admin* or Windows Service*) then the configuration is loaded from the configuration.xml file.

Changing Settings

The configuration can be modified in a few ways;
  • Through the Configuration form in the Index Manager Tool
  • Through the Configuration page under the Admin web application*
  • Programmatically through the ConfigurationManager class
  • Manually - not recommended

Programmatically Changing Configuration

The Configuration class holds the settings for index operations, but is transient (settings are not automatically persisted). To persist the settings to the index, use the ConfigurationManager class.

Eg. to save a configuration instance

C#
//Create a new instance, with default settings
Configuration conf = new Configuration();
//Make some changes
conf.CaseSensitivity = CaseSensitivity.Capitalization;
conf.WebsiteCredentials.Add("keyoti.com", new ResourceCredentials("user", "pass"));

//Write this configuration to an index directory "myIndexDir"
ConfigurationManager cm = new ConfigurationManager( @"c:\inetpub\wwwroot\myIndexDir");
cm.SaveSettings(conf);
VB.NET
'Create a new instance, with default settings
Dim conf As Configuration = New Configuration
'Make some changes
conf.CaseSensitivity = CaseSensitivity.Capitalization
conf.WebsiteCredentials.Add("keyoti.com", New ResourceCredentials("user", "pass"))

'Write this configuration to an index directory "myIndexDir"
Dim cm As ConfigurationManager = New ConfigurationManager("c:\inetpub\wwwroot\myIndexDir")
cm.SaveSettings(conf)

Eg. to load a configuration instance

C#

//Create a new instance, with default settings
Configuration conf = new Configuration();

//Load this configuration instance with settings from index directory "myIndexDir"
ConfigurationManager cm = new ConfigurationManager( @"c:\inetpub\wwwroot\myIndexDir");
cm.RetrieveConfiguration(conf);
VB.NET
'Create a new instance, with default settings
Dim conf As Configuration = New Configuration

'Load this configuration instance with settings from index directory "myIndexDir"
Dim cm As ConfigurationManager = New ConfigurationManager("c:\inetpub\wwwroot\myIndexDir")
cm.RetrieveConfiguration(conf)

The conf object can then be passed in the constructor of any object you create that requires the configuration.

IndexDirectory Property

The Configuration object has an IndexDirectory property which can be set to the absolute file path of the Index Directory.
-If the Configuration object is not loaded via ConfigurationManager then the IndexDirectory property will need to be set before it can be used.
-If the Configuration object is loaded via ConfigurationManager, then the IndexDirectory property will be set automatically to the path where the configuration file is (i.e. the index directory).

*Pro level only


SearchUnit Documentation: Importing

Importing

The importing operation is the process of finding document URLs and adding them to the index. There are a few different types of 'Indexable Sources' that the engine can import documents from;

[For programmatic importation, please see the programmatic example in the examples section.]

Website

Imports documents/pages from a web-site by crawling through the links found. This works well with most web-sites and in particular is the only way to import sites that use session state and/or HTTP GET requests to load content. The important thing to understand about the crawler is that it sees your web-site like a browser without Javascript capabilities - this means that it is able to preserve session, cookies and GET parameters, however it cannot do ASP.NET postbacks (when a postback is required to reach another page, consider embedding a hidden link to the page, eg. <!-- href="otherpage.aspx" -->

Please see the 'How to Index a Web-Site' example

Since each page must be read on the web-site, through a HTTP request, the crawl process can take a considerable amount of time for very large sites (the amount of time is dependent on network speed, machine speed and number of pages - but could be in the order of hours) - see File-system Document Store for a faster alternative.

Parameters

Start URL
The page at which crawling should start. This page must include links to other pages.

Path matches to be ignored (More Options)
List of strings which specify path matches to be ignored - if a string in this list matches the URL about to be crawled, the URL will be ignored. Eg. if this list contains "/dir1/" then the URL "http://localhost/dir1/file.aspx" will not be crawled.

Path matches to be included (More Options)
List of strings which specify path matches to be exclusively included - only if a string in this list matches the URL about to be crawled, will the URL crawled. Eg. if this list contains "/dir1/" then the URL "http://localhost/dir1/file.aspx" will be crawled but "http://localhost/file.aspx" will not.

Website importing does not work well if documents do not have links to them, for example if there is a repository of PDF and Word documents, that aren't directly linked, the crawler will not find them. In this case it's advisable to supplement the import with "File-system Document Store" (below).

File-system Document Store

Imports documents from a local file path by recursively reading the files under a folder. This is useful when a set of documents/files exist under a web-site but aren't linked to (i.e. crawling fails to find them).

The local folder path should be set to a path which corresponds to a virtual folder (eg. c:\inetpub\wwwroot\mydocs) and the virtual folder path should be set to the URL that the local path corresponds to (eg. http://servername/mydocs). In this way any documents found under c:\inetpub\wwwroot\mydocs are automatically mapped to http://servername/mydocs. The local folder path can be relative to the index directory.

Since this process uses the local file system, it is generally much much faster than crawling a web-site.

Parameters

Local folder path
Is the file path of the folder (eg. c:\ or a UNC share - is relative to the index directory, or absolute)

Virtual folder path
Is the URL of the folder - this is used for search results so that the user can access the documents

Target match list
Is a list of strings that specify the documents that will be imported - this can be set to ".doc" and ".pdf" for example to only import Word and PDF files. To specify strings that must match at the end of the filename, use a $ character, eg. ".aspx$" will match "default.aspx" but not "default.aspx.cs"

Recurse sub-folders
Specifies whether to look in subdirectories as well

No recurse folder match list
Is a list of strings that specify which subfolders will not be looked inside - eg. "windows" would prevent the "c:\windows" directory from being scanned for files

Database (MSSQL, OLE, Oracle)

Imports rows from a database. By specifying the DB connection string and a SQL query, the engine can import rows from the database. The SQL query should specify the columns that should be imported. The import will merge all columns into one text string which will be indexed. At present the individual fields are not separately searchable.

Parameters

Connection string
Specify the connection string normally used by your applications to connect to the database, eg.
Standard Security:
1. 'Data Source=Your_Server_Name;Initial Catalog=Your_Database_Name;UserId=Your_Username;Password=Your_Password;'
2. 'Server=Your_Server_Name;Database=Your_Database_Name;UserID=Your_Username;Password=Your_Password;Trusted_Connection=False'
Trusted connection:
1. 'Data Source=Your_Server_Name;Initial Catalog=Your_Database_Name;Integrated Security=SSPI;'
2. 'Server=Your_Server_Name;Database=Your_Database_Name;Trusted_Connection=True;'
If the DB is file based, a relative path can be specified (relative to the Index Directory).

SQL query
Specify the SELECT query that will provide data to the indexer. Eg. SELECT * FROM mytable
The Reader class will by default use the first column as the result title and the second column (if it exists) as the static description.
If the data set will be very large, then it is possible to specify a query that uses paging to retrieve the data. Any instances of {0}, {1} and/or {2} in a query will be replaced with the "start row#", "end row #", and "number of rows requested" respectively. In this way the engine will query for 500 rows at a time (The Configuration property, DbImportPageSize, specifies the number of rows that will be requested.).

Eg. if the result set has a unique number based field;
SELECT * FROM Table1 where id>={0} AND id<{1}
will cause the request to be made with SELECT * FROM Table1 where id>=0 AND id<500 and then again with 500 and 1000, and so on until no more data is returned from the DB.

Eg. if the result set does NOT have a unique number based field;
SELECT * FROM( SELECT top {2} * FROM ( SELECT top {2} * FROM ( SELECT top {1} * FROM Table1 ORDER BY id ASC) a ORDER BY id DESC ) b ) d ORDER BY id ASC
will achieve the same thing.

Unique field
Specify the name of the column that holds unique, record identifying data (eg. the primary key). This column will added to the ResultURL so that your record viewer can present the record.

Result URL format
This format string defines how the result URLs will be created. When the user searches, the result links will be created based on this format. {0} is converted to the unique field value and {1} is converted to the unique field name. This allows your record viewer to identify which record result the user clicked on.

Custom DataSet Provider

Imports rows from a DataSet object, provided by a dynamically loaded 3rd party assembly. Is similar to database importing, except that the DataSet is returned by a user assembly. This is of use when importing data from any kind of unsupported source, or from a database where the data retrieval needs to be specially handled (i.e. not by the database importer). All data in the first DataTable in the DataSet is indexed, where each row corresponds to a searchable 'result'.

Parameters

Assembly path
You can create an assembly that will provide a DataSet for indexing. Specify the full file path of your assembly here. Eg. c:\myapp\my.dll

Full class name
Specify the full class name (including namespace) of the class that will provide the DataSet - eg. mynamespace.myclass

Unique field
Specify the name of the DataSet column that holds unique, record identifying data (eg. the primary key). This column will added to the ResultURL so that your record viewer can present the record.

Result URL format
This format string defines how the result URLs will be created. When the user searches, the result links will be created based on this format. {0} is converted to the unique field value and {1} is converted to the unique field name. This allows your record viewer to identify which record result the user clicked on.

The class specified in "Full class name" must contain at least one method, named GetDataSet with signature

//C#
public DataSet GetDataSet(int firstRow, int numberOfRows);

'VB.NET
Public Function GetDataSet(ByVal firstRow As Integer, ByVal numberOfRows As Integer) As DataSet

This method must return a DataSet with the data from row number 'firstRow' up to a maximum of 'firstRow' + 'numberOfRows'. If no data is available then null/Nothing must be returned. The Configuration property, DbImportPageSize, specifies the 'numberOfRows' that will be requested.

Tips

CAS (security permission) issues:

If accessing an external assembly (ie. CustomDataSetProvider or ExternalEventHandler) in anything below Full Trust, the external assembly must be located under the application directory.

External Assembly Location Tip:

When working with a plug-in DLL and the Admin Web App., place the plug-in DLL in the application BIN directory. This will make the DLL automatically updatable, without stopping the IIS service or killing the ASP.NET worker process.
If the plug-in is outside the application and it's subdirectories, ensure the ASPNET (IIS 5) or NetworkService (IIS 6) user can access the DLL, eg. run from command prompt

cacls "path to plug-in DLL" /E /G ASPNET:R

Relative Paths

Paths to files for Database, CustomDataSetProvider and EventHandlerAssemblyPath imports can be relative to the IndexDirectory making projects easier to move around and share.

For example, the connection string for an Access database may be;

Provider=Microsoft.Jet.OLEDB.4.0; Data Source=C:\Inetpub\wwwroot\tempTestFiles\test.mdb;

If the Access database is in the parent of the index dir, you can instead use;

Provider=Microsoft.Jet.OLEDB.4.0; Data Source=..\test.mdb;


SearchUnit Documentation: Keeping The Index Up To Date

Keeping Up To Date (Automatic Reindexing)

There are various strategies that can be used to keep the index up to date.

Windows Service

Pro version users have the option of installing the Windows Service, and configuring it to reimport sources on any given index directory at specified intervals. More information on the administration installer and Windows Service

Automatic Republishing (Scheduled Task)

Through the Windows Index Management tool's Publish form, it is possible to setup a scheduled task to reimport sources and deploy the result via xcopy or ftp. This approach is ideal when a service cannot be installed, and it facilitates updating the index from a development or staging machine. More information on 'publishing'

Incremental Index Updates (Programmatic)

If there is application code running when changes are made to content that should be indexed (eg. an ASPX page runs when a document is uploaded, or deleted), then it is possible to immediately update the index using the SearchUnit API. This approach is ideal when it's possible to implement, as it results in a fresher index (no waiting for periodic updates) and is more efficient than the other approaches (since it does not require scanning files/folders). More information on incremental updates


SearchUnit Documentation: Logging

Logging

To enable logging and aid in understanding what operations are doing, set the Logging property under Configuration to true/checked (See the Configuration section for more information). This will write *.txt files into the index directory during all operations. These files can be viewed directly or via the log file viewers in the Index Manager Tool or the Web based Administration Tool.

Please note that logging does slow operations down and is recommended when performance is not critical.


SearchUnit Documentation: Stop Lists

Stop Lists

A file called stoplist.txt is automatically created in the index directory when the Index Manager is launched. The stop list contains common words that will be ignored while indexing and searching allowing for greater performance, particularly with larger indexes.

Editing Stop Lists

Words that are common or unique to your site can be added or removed from the stop list file using a text editor (Notepad, EditPlus etc). The file must be;

  • saved in UTF8 encoding
  • in alphabetical order
  • one word per line
  • have a " " (space) on the first line
  • every entry must be lowercase

Note: Any changes to the file will necessitate deletion and recreation of the index.
Note: When using the Auto-Complete PopularSearches setting, offensive words should not be added to the stop list as those words could appear as suggestions if another user searches for them.

Deactivating

To deactivate the use of the stop list file, and allow all words to be indexed and searched, open stoplist.txt as explained above and delete all words.

Clear Programmatically

The stop list can be cleared programmatically by calling
Configuration.StopWords.Clear();
after every DocumentIndex or SearchAgent instantiation.

Non-English Stop Lists

Stop lists for non-English languages can be found in the product installation folder under 'Stop-Lists'. Locate the stop list for your language and copy the file to your Index Directory before creating the index.

Procedure for Creating and Modifying Stop Lists

  1. Launch the Index Manager - stoplist.txt will be automatically created in the Index Directory
  2. Load stoplist.txt in a text editor such as Notepad or Visual Studio
  3. a. To remove a word - delete the word and ensure remaining words are listed one per line.
    b. To add a word - insert the word in alphabetical order, on it's own line and in lowercase.
    c. To add words in bulk - insert the words, one per line and in lowercase. Use the Sort function to arrange the words in alphabetical order.
  4. Ensure the first line has a " " (space) and then save as UTF8 encoding.


SearchUnit Documentation: About location/content categories

About Location/Content Categories

Pro only

The engine supports two types of document categorization - the choice of which (or both) to use should be made based on the features of each.

Location Categories

  • Documents can belong to only one location
  • Users can search inside only one location at a time
  • Location categories are associated to a 'root path', which makes them easily mapped to new documents based on the document's URL (see below)
  • Location categories can also be assigned to documents using the GUI, metatags, programmatically or via a plug-in (see below).

Content Categories

  • Documents can belong to up to ten content categories by default
  • Users can search inside any number of content categories
  • Content categories are not associated to a 'root path' like Location categories are
  • Content categories can also be assigned to documents using the GUI, metatags, programmatically or via a plug-in (see below).

Auto Assign Location Categories

Using Index Management Tool

You can automatically assign pages to specific Location categories directly from your Visual Studio project. Select Manage Index from the SearchResult control and click 'Locations'.

1. Enter the name of the Location category you would like to create.
2. In the Auto Assign Path column, enter the string that will be used to identify matching pages.
3. To automatically assign pages that have already been imported, click 'Auto Assign Documents'.
Note: To reassign documents that have already been assigned to a category select 'Auto Reassign All Documents'.

Any future imported documents that meet the location criteria will be automatically assigned for you.

Using Web Administration Tool

To automatically assign documents to Location categories you will need to;

1. Select 'Manage Location Categories'.
2. Enter the name of the Location category you would like to create.
3. In the Location Root Path field, enter the string that will be used to identify matching pages.
4. Click 'Add'.
5. To automatically assign pages that have already been imported, click 'Auto Assign'.
Note: Select 'All Documents' and click 'Auto Assign' to reassign documents that have already been assigned to a category.

Any future imported documents that meet the location criteria will be automatically assigned for you.

Assigning Content And Location Categories Through Meta Tags

HTML producing pages (.html, .aspx, .asp etc) can be assigned to categories via meta tags. Simply add either or both of the following tags to the HEAD section of the HTML document before building the Index.

<meta name='Keyoti_Search_Location_Category' content='locationName1'  />
<meta name="Keyoti_Search_Content_Categories" content="contentName1, contentName2, ...." />

Note that;

- Whatever Content/Location category is set using meta tags will completely override any other category assignments made each time the index is built.
- A document can belong to only one location category, but can belong to any number of content categories
- Content category names should be separated by commas
- If the specified location or content category does not already exist, it will be created (this means that care must be made not to enter typo's)

You can reset a document back to the default category using the following tags;

<meta name='Keyoti_Search_Location_Category' content='default'  />
<meta name="Keyoti_Search_Content_Categories" content="default" />

Assigning Content And Location Categories Through Central Event System

Please see this example


SearchUnit Documentation: Security groups

Show language: C# VB.NET Both

About Security Groups

Pro only

Security Groups define which groups of users can see which documents. By setting user permissions (see below) only those documents within a specific group can be searched. A document can be associated with multiple Security Groups. Any documents that are not associated with a security group remain in "default" and are available for all users to search.

Example:

Requirement: Only those users within the Sales department should be able to search documents intended for the Sales department. Only those users within the Accounts department should have access to Accounts documents.

  1. First we create a Security Group for 'Sales' and another Security Group for 'Accounts'.
  2. We then associate documents to their respective security groups (Sales or Accounts).
  3. In the code-behind of the SearchResult page we then restrict the search to certain groups based on the logged in user (see below)
A document's Security Group can be specified by;
  1. HTML meta tags
  2. Your plug-in
  3. Matching the auto-assign path, or
  4. Manually using the Index Management Tool or Web Administration Tool.

Assigning Security Groups using HTML meta tags

Security Groups can be assigned to documents using HTML meta tags like this;

<meta name="keyoti_search_security_groups" content="admin,sales">

Note: If the Security Group names specified within the meta tags do not match those setup in the Index Directory, then a new Security Group will be created with that name.

Using your plug-in

Security Groups can be assigned using your own plug-in. Please see the 'Central Event System - Plug-ins' section of this Help for details on setting up your plug-in.

Note: If the Security Group names specified within your plug-in do not match those setup in the Index Directory, then a new Security Group will be created with that name.

Auto Assign Security Groups

By adding an Auto Assign Path to a Security Group, documents can be matched to each group based on their path.

Using Index Management Tool

  1. Enter the name of the Security Group you would like to create.
  2. In the Auto Assign Path column, enter the string that will be used to identify matching paths.
  3. To automatically assign pages that have already been imported, click 'Auto Assign Documents'.
    Note: To reassign documents that have already been assigned to a group select 'Auto Reassign All Documents' by clicking the arrow on the right hand side of the button.

Any documents imported in the future that meet the Auto Assign Path criteria will be automatically assigned for you.

Using Web Administration Tool

To automatically assign security groups to documents using the Web Administration Tool;

1. Select 'Manage Security Groups'.
2. Enter the name of the Security Group you would like to create.
3. In the Security Root Path field, enter the string that will be used to identify matching paths.
4. Click 'Add'.
5. To automatically assign pages that have already been imported, click 'Auto Assign'.
Note: Select 'All Documents' and click 'Auto Assign' to reassign documents that have already been assigned to a security group.

Any documents imported in the future that meet the Auto Assign Path criteria will be automatically assigned for you.

Restricting search based on logged in user

The application developer can restrict the search to certain groups based on the logged in user like this;

C# (ASP.NET Control based usage)

SearchResult1.SearchOptions.SecurityGroupNames = new string[] { "admin" };

VB.NET (ASP.NET Control based usage)

SearchResult1.SearchOptions.SecurityGroupNames = New String() {"admin"}
Javascript (Javascript based usage, called in an .aspx page)
<script type="text/javascript">
    keyotiSearch.securityGroups = ["<%= Keyoti.SearchEngine.SecurityGroup.Encrypt("admin") %>"];
</script>
Javascript (Javascript based usage, called in a Razor page)
<script type="text/javascript">
    keyotiSearch.securityGroups = ["@Keyoti.SearchEngine.SecurityGroup.Encrypt("admin")"];
</script>

In the Javascript based usage examples the "admin" group name is encrypted on the server before it is written to the HTML rendering on the page. This ensures that users cannot fake the Security Group that they belong to, however it also requires that server side code is used to encrypt the name. In other words, <%= ... %> (ASP.NET) and @... (Razor) type code will only work in ASP.NET and Razor pages, not plain HTML.

If the user does not have special document access privilege, then the security group name specified in the array above should be "default". If no security group names are specified, or if SearchOptions is null, then only documents from "default" will be returned.

For increased security it is possible to specify a custom encryption key used to encrypt the security group name, this is done in the web.config appSettings. The key only needs to be random text.

web.config
<configuration>
  ...
  <appSettings>
    <add key="Keyoti-SearchEngine-EncryptionKey" value="<some random text>"/>
  </appSettings>


SearchUnit Documentation: Optimization

Optimization

Defragmentation Of The Index

The index format achieves greater efficiency during indexing, in part by minimizing the amount of redundant optimization performed. In v3 the index was always optimized for searching; whereas in v2010 up, the index should be optimized after batch operations have been performed (eg. after imports, adds and deletes). Optimization usually takes seconds to minutes, depending on the index size. The UI's have an Optimize form, or to optimize programmatically, call DocumentIndex.Optimize(), eg.

DocumentIndex idx = new DocumentIndex(config);
idx.Import(...);
idx.Optimize();
idx.Close();
or
DocumentIndex idx = new DocumentIndex(config);
idx.Optimize();
idx.Close();

Optimization can improve search performance by a factor of ~5 and has no effect on future indexing performance.

Windows Explorer

Due to the way Windows Explorer works, and the fact that the search engine writes/deletes lots of files during indexation, it is advisable to close all instances of Windows Explorer. If an instance of Explorer has been used to view the index directory and then is pointed to a different directory, it can still have a substantial negative impact on indexing speed.

Minimizing Unnecessary Indexing

To ensure optimum search results and performance you should index only those files that you wish to be searchable.

For example, if you have a very large repository of observational data (e.g. text files filled with records from flight, weather data etc that have many different 'word' strings) then indexing it may cause slow downs for certain searches (wildcards) and any index change operations (adding/removing etc). Although Search can handle this type of data, any unnecessary indexing should be avoided if possible.
Hint - the Configuration.IndexNumbers property can also be set false to not index/search for numbers.

This also applies to binary files - although binary file types are ignored by default, this only happens if the server sends the correct mime-type with the response. Eg. if the server response for a .wmv file is "text/plain" then the binary content will be parsed as text, which will mostly be garbage and fill the index unnecessarily. The indexer deliberately includes everything it finds (except for a specific stop-list) because it is dangerous to use heuristics to identify words which would 'never be searched' and therefore shouldn't be indexed. Eg. company/product names with symbols in them shouldn't be ignored.

Forward Index

By default Search will create a Forward Index which allows for result summary generation and result preview features. To speed up indexing, especially with large indexes, you can set Config.CreateForwardIndex=false. This will mean you can't use Config.ResultSummaryType=Dynamic or SearchAgent.GetDocumentText (ResultPreview). StaticBodyStart will be automatically used for ResultSummaryType and can be changed to StaticMetaDescription manually.

Note: Any change to CreateForwardIndex will require the index to be deleted and recreated.


SearchUnit Documentation: Multilingual

Multilingual Support

International indexing/searching is available for most scripts/languages (Western, Middle Eastern and Eastern languages)- but this can be further enhanced using a 'Language Pack'. If no language pack is used, there are no special configuration settings required, the engine will automatically index/search most languages.

Please download the language packs here.

To install a language, unzip the ZIP file, find the appropriate language folder and copy the contents into the index directory that should use the language.

  1. Edit the configuration file and set LemmaLanguage accordingly
  2. For any use of the SearchSuggestions control, change the Language property accordingly

Diacritics/Accented Characters

By default diacritics are handled like their ASCII counterpart, for example 'é' is treated the same as 'e'. To have diacritics be treated distinctly, set Configuration.IgnoreDiacritics = false.


SearchUnit Documentation: Robots

Robots.txt

By default any robots.txt file present on the server is ignored - this is because it's expected that robots.txt would be relevant only to external 'bots'. To have robots.txt not be ignored, set Configuration.RespectsRobotsTXT to true (see section on configuration for more).

The robots.txt must be in the root of the web-site (eg. domain.com/robots.txt), per the 'robots standard'. The engine looks first for instructions specific to User-agent: Keyoti_Search, and then to any wildcard User-agent instructions.


SearchUnit Documentation: About the Javascript mode usage

About the Javascript mode usage

Where possible Keyoti recommends using the newer Javascript mode of usage, rather than the ASP.NET Web Controls, for the following reasons:

  • Automatically supports any HTML platform, such as Web Forms, MVC, Razor, AJAX, ASP, HTML etc etc. All HTML platforms allow the use of Javascript.
  • Faster AJAX based user experience
  • Additional features such as custom data filters and sorting

Even if Javascript development is not a developer strength, usage is straightforward enough that it should not be a problem - plus it's a good way to learn!


SearchUnit Documentation: Javascript Usage: How do I...: ...search with a simple form

Single Page Setup

Assuming that the SearchUnit scripts are located in a sub folder named Keyoti_SearchEngine_Web_Common, and the index is in a sub folder named Keyoti_Search_Index. The following page will create a search box control inside the DIV with id sew_searchBoxControl, and a search result viewer inside the DIV with id sew_searchResultControl.

Javascript / HTML
<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml">
    <head>
        <title></title>
        <link href="Keyoti_SearchEngine_Web_Common/SearchUnit.css" rel="stylesheet" />
        <script src="Keyoti_SearchEngine_Web_Common/SearchUnit.js"></script>
    </head>
    <body>
        <div id="sew_searchBoxControl"></div>
        <div id="sew_searchResultControl"></div>
    </body>
</html>

If you are using .NET 2, you must also call

Javascript
    keyotiSearch.useWCFService=false;

Note: If you get this error "Request format is unrecognized for URL unexpectedly ending in ..." then you may need to add the HttpPost protocol to the webservices section of web.config, eg.

<configuration>
    <system.web>
    <webServices>
        <protocols>
            <add name="HttpGet"/>
            <add name="HttpPost"/>
        </protocols>
    </webServices>
    </system.web>
</configuration>

Example output after a query has been entered.

If the script folder is not the default Keyoti_SearchEngine_Web_Common then it is necessary to point to the folder;

Javascript / HTML
    ...
        <link href="/myscriptfolder/SearchUnit.css" rel="stylesheet" />
        <script src="/myscriptfolder/SearchUnit.js"></script>
        <script type="text/javascript">
            keyotiSearch.commonFolderUrl = "/myscriptfolder";
        </script>
    ...

If the index directory is not the default Keyoti_Search_Index then it is necessary to point to the folder (use the tilda ~ notation to point to the application root, or use an absolute file path);

Javascript / HTML
    ...
        <script type="text/javascript">
            keyotiSearch.indexDirectory = "~/myindexdirectory";
        </script>
    ...

Two Page Setup

Building on the Single Page Setup example above, it is possible to initiate the search from another page.

Javascript / HTML : search.html
<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml">
    <head>
        <title></title>
        <link href="Keyoti_SearchEngine_Web_Common/SearchUnit.css" rel="stylesheet" />
        <script src="Keyoti_SearchEngine_Web_Common/SearchUnit.js"></script>
    </head>
    <body>
        <div id="sew_searchBoxControl"></div>
        <div id="sew_searchResultControl"></div>
    </body>
</html>
Javascript / HTML : index.html
<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml">
    <head>
        <title></title>
        <link href="Keyoti_SearchEngine_Web_Common/SearchUnit.css" rel="stylesheet" />
        <script src="Keyoti_SearchEngine_Web_Common/SearchUnit.js"></script>
        <script type="text/javascript">
            keyotiSearchBox.resultURL = "search.html";
        </script>
    </head>
    <body>
        <div id="sew_searchBoxControl"></div>
    </body>
</html>

If you are using .NET 2, you must also call

Javascript
    keyotiSearch.useWCFService=false;

Templating The Controls

SearchBox

The sew_searchBoxControl can be laid out in anyway, provided it has at least an <input type="text" id="sew_searchBox" /> element (extra attributes such as class and style can be added too) and an element with id sew_searchButton.

Link for a button

HTML
    <div id="sew_searchBoxControl">
        <input type="text" id="sew_searchBox" style="border: 2px solid black; font-size:20px;"/>
        <a href="#stayhere" onclick="keyotiSearchBox.doSearch()" id="sew_searchButton">Search</a>
    </div>

Image for a button

HTML
    <div id="sew_searchBoxControl">
        <input type="text" id="sew_searchBox" />
        <a href="#stayhere" onclick="keyotiSearchBox.doSearch()" id="sew_searchButton"><img src="...." /></a>
    </div>

Image roll-over effects can be achieved using conventional techniques such as CSS sprites or Javascript mouseovers.

SearchResult

The sew_searchResultControl has a template mechanism to define it's layout and elements (such as custom data). There are 3 component DIVs to the sew_searchResultControl, which may be optionally specified; div class='sew_ajax_loader_backer' (which holds the loading animation, defined in CSS), div class='sew_ajax_error' (which holds any error messages) and div id='sew_resultView' (which displays search results).

sew_resultView contains 3 DIV components, which are the header (id='sew_resultHeader'), result list (id='sew_resultList') and footer (id='sew_resultFooter').

HTML
    <div id="sew_searchResultControl">
        <div class="sew_ajax_loader_backer"><div class="sew_ajax_loader"></div></div>
        <div class="sew_ajax_error">
            <span class='sew_errorTitle'>Error</span>
            <p class='sew_errorBody'></p>
            <div class="sew_ajax_error_footer">
                <input type="button" value="OK" id="sew_errorOKButton" />
            </div>
        </div>
        <div id="sew_resultView">
            <div id="sew_resultHeader">
            </div>
            <div id="sew_resultList">
            </div>
            <div id="sew_resultFooter"></div>
        </div>
    </div>

Elements can be arranged as desired and templates defined by the developer can control the layout and content of the header, result list and footer.

Header template

For example;

HTML
    ...
    <div id="sew_resultHeader">
        <div id="sew_headerTEMPLATE" class="sew_header">
            Showing result page <b>${PageNumber}</b>.
            There are <b>${NumberOfResults}</b> results for <b>&#8220;${Query}&#8221;</b>.
            <span id="sew_ignoredWords">The following common words were ignored: ${IgnoredWords}</span>
            <div id="sew_didYouMean">Did you mean: <a href="#stayhere"
                    onclick="keyotiSearch.search('${SuggestedSearchExpressionEscaped}', 1)">${SuggestedSearchExpression}</a></div>
        </div>
    </div>
    ...

The dynamic elements are: ${PageNumber} (the result page being shown), ${NumberOfResults} (the number of results in total), ${Query} (the search query that the results are for) and ${IgnoredWords} (list of any common words that were ignored, the stop words). It is also possible to place other controls, such as the sort control inside the header, this is discussed in the custom data filters section.

Note that it is important to wrap the 'ignored words' section with an element with id sew_ignoredWords, because this element is automatically made invisible if there are no ignored words.

Note that it is important to wrap the 'did you mean' section with an element with id sew_didYouMean, because this element is automatically made invisible if there are no misspelled words.

Footer template

For example;

HTML
    ...
    <div id="sew_resultFooter">
        <div id="sew_footerTEMPLATE" class="sew_footer">
            <span id="previousPageLink">${PreviousPageLink}</span>
            <span id="pageLinksBlock">${PageLinksBlock}</span>
            <span id="nextPageLink">${NextPageLink}</span>
        </div>
    </div>
    ...

The dynamic elements are: ${PreviousPageLink} (link text to the previous page), ${PageLinksBlock} (links to each page number), and ${NextPageLink} (link text to the next page).

Result list template

For example;

HTML
    ...
    <div id="sew_resultList">

        <div id="sew_resultItemTEMPLATE" class="sew_resultItem">
                <span class="sew_resultItemLink"><a href="${UriStringWithKeywords}">${Title}</a></span>
                <span class="sew_resultItemSummary">${Summary}</span>
                <span class="sew_previewResultWrapper"><img alt="Click to preview the document text" src="/Keyoti_SearchEngine_Web_Common/ResultPreview_Expander_Closed.png"
                    onclick="keyotiSearchResultPreviewer.toggleResultPreview(this,
                    '${UriStringAsStored}',
                    '/Keyoti_SearchEngine_Web_Common/ResultPreview_Expander_Closed.png',
                    '/Keyoti_SearchEngine_Web_Common/ResultPreview_Expander_Opened.png')"/>
                <span class="sew_previewResultContent">Loading document...</span></span>
                <div style="clear:both; height:1px;"></div>
                <span class="sew_resultItemURL">${UriString}</span>
                <span class="sew_keywordHitMap">${KeywordHitMap}</span>
                <span class="sew_location">${Location}</span>
                <span class="sew_location">${Content}</span>

                <!--Example Custom data elements-->
                <img data-src="${CustomDataDictionary.img}" />
                <span class="${CustomDataDictionary.dateDisplayClass}">Publish date: ${CustomDataDictionary.date}</span>
            </div>

    </div>
    ...

There are no requirements for layout, element types or data elements to show - the above is just an example that uses what is available.

The dynamic elements are: ${UriString} (the URL for the result), ${Title} (the document/page title), ${Summary} (the result summary, this can be set to be dynamic or statically generated, see configuration), ${UriStringAsStored} (the document URI as it is contained in the index, this can be different to ${UriString}, typically for database results), ${KeywordHitMap} (a breakdown of number of hits within each document for each keyword), ${Location} (the document's location category), ${Content} (the document's content categories) and ${CustomDataDictionary.*} (custom data fields).

Custom data dictionary fields
 Please first see How to add CustomData to a document

If the document contains custom data, stored in URL encoded GET parameter style (eg. fieldName1=data1&fieldName2=data2) then that data is made available to the template through the CustomDataDictionary object. In the above example, the 'img' and 'date' fields from the document's custom data are displayed.

Custom Data Dictionary formatting:

  • Fields must be URL encoded, eg. "img=/1%262.jpg" (%26 = &)
  • Multiple fields are delimited by & "img=/1%262.jpg&date=2014-04-30"
  • Dates MUST be formatted yyyy-mm-dd (as ISO 8601)

Note that the img tag set "data-src" instead of "src", this is only because if the "src" attribute is set to ${CustomDataDictionary.img}, the browser will attempt (and fail) to download the image from the URL http://.../${CustomDataDictionary.img}. By using data-src this is avoided since the "src" attribute is only set when the template is used for result generation.

Hiding elements when a document doesn't contain a custom data field

In order to hide the custom data field and its surrounding text, the dynamically generated CSS class ${CustomDataDictionary.dateDisplayClass} is used. Each field has a dynamically generated class ${CustomDataDictionary.fieldNameDisplayClass}. When there is no text in the custom data field, the class name will be fieldNameNoContent, and when there is content it will be fieldNameContent. For example;

HTML
     ...
    <span class="${CustomDataDictionary.authorDisplayClass}">Author: ${CustomDataDictionary.author}</span>
    ...

If the 'author' custom data field contains no data, the generated HTML will be;

HTML
     ...
    <span class="authorNoContent">Author: </span>
    ...

Therefore adding a style rule to hide the span will make the "Author" text invisible if there is no author information.

CSS
    .authorNoContent{
        display:none;
    }
Formatting or changing custom data field text

The text output from ${CustomDataDictionary.fieldName} is directly from the custom data field in the index, however it can be modified with a Javascript function at search time. For example, specify a function for keyotiTemplateUtility.formatCustomData;

Javascript
    keyotiTemplateUtility.formatCustomData = function (customDataDictionaryItemName, value) {
        if (customDataDictionaryItemName == 'publishDate' && value != null && value.length == 10) {
            //format date to user's locale
            var date = new Date(value.substring(0, 4), value.substring(5, 7) - 1, value.substring(8, 10));
            return date.toLocaleDateString();
        }

        //default provide as-is.
        return value;
    };

This code (which should be called after the Keyoti scripts have been imported) will convert the date format for the 'publishDate' field from yyyy-mm-dd to the user's locale format (eg. mm/dd/yyyy in the US).


SearchUnit Documentation: Programmatic Use: How do I...: ...programmatically search

Show language: C# VB.NET Both

Programmatic Searching

To run programmatic searches is fairly straight forward, it involves setting the Configuration to the correct Index Directory and using SearchAgent to run the actual search.

Example Searcher

C#
using System;
using Keyoti.SearchEngine;
using Keyoti.SearchEngine.Search;

public class MyClass
{
    public static void Main()
    {

        // Put user code to initialize the page here
        Configuration configuration = new Configuration();
        configuration.IndexDirectory =
        @"C:\...path to your index directory...";

        //this SearchUnit Pro license key will expire December 2012, evaluators should email support
        //for a key
        string licensekey =
        "5A556A61675D69626B5C6D6C644854263C3E41433B41413E44404645474A454B4D503D0";

        //run a search for "the"
        SearchAgent sa = new SearchAgent(licensekey, configuration);

        //retrieve results 1 through 10
        SearchResult results = sa.Search("the", 1, 10);

        //the number of results there actually are in total
        int totalNumberOfResults = results.NumberOfResults;

        foreach(ResultItem i in results)
        {
            //the summary from the document
            string summary = i.Summary;

            //the title of the document
            string title = i.Title;

            //the document URL
            string url = i.UriString;

            //the weight of the document in the results
            int weight = i.Weight;
            Console.WriteLine(url);
        }
    }
}
VB.NET
Imports System
Imports Keyoti.SearchEngine
Imports Keyoti.SearchEngine.Search

Public Class MyClass1

    Public Shared Sub Main()
        ' Put user code to initialize the page here
        Dim configuration As Configuration = New Configuration
        configuration.IndexDirectory = "C:\...path to your index directory..."
        'this SearchUnit Pro license key will expire December 2012, evaluators should email support
        'for a key
        Dim licensekey As String = "5A556A61675D69626B5C6D6C644854263C3E41433B41413E44404645474A454B4D503D0"
        'run a search for "the"
        Dim sa As SearchAgent = New SearchAgent(licensekey, configuration)

        'retrieve results 1 through 10
        Dim results As SearchResult = sa.Search("the", 1, 10)
        'the number of results there actually are in total
        Dim totalNumberOfResults As Integer = results.NumberOfResults
        For Each i As ResultItem In results
            'the summary from the document
            Dim summary As String = i.Summary
            'the title of the document
            Dim title As String = i.Title
            'the document URL
            Dim url As String = i.UriString
            'the weight of the document in the results
            Dim weight As Integer = i.Weight
            Console.WriteLine(url)
        Next
    End Sub
End Class


SearchUnit Documentation: Javascript Usage: How do I...: ...provide filters to the user (CustomData)

Custom Data Filters

Custom data that is stored in URL GET encoded format can be used as a filter data source, for search results. For example if documents in the index have a custom data field named 'publishDate', which holds yyyy-mm-dd formatted data, then it is possible to filter out documents that do not match a filter's date range.

Filter types

There are several types of underlying filter that can be used:

  • 'date' - yyyy-mm-dd formatted date strings, supports 'before date A', 'after date B' or 'between dates A and B'
  • 'stringor' - documents with a field matching (case-insensitive) any of a list options will pass the filter, for example:

    2 documents (A and B) have a custom data field 'author'. For document A, author="Andrew" and for document B, author="Brenda".

    If the filter is set to "Andrew" then document A will pass and B will not. If the filter is set to "Andrew OR Brenda" (typically meaning Andrew and Brenda options were checked) then both documents will pass.

  • 'stringlistor' - documents with a field containing a list of data items, where any of those items match (case-insensitive) any of a list of options, will pass the filter, for example:

    2 documents (A and B) have a custom data field 'authors'. For document A, authors="Andrew,Brenda,Nick" and for document B, author="Brenda".

    If the filter is set to "Brenda" then document A and B will pass. If the filter is set to "Andrew OR Brenda" (typically meaning Andrew and Brenda options were checked) then both documents will pass also.

  • 'stringlistand' - documents with a field containing a list of data items, where any of those items match (case-insensitive) ALL of a list of options, will pass the filter, for example:

    2 documents (A and B) have a custom data field 'authors'. For document A, authors="Andrew,Brenda,Nick" and for document B, author="Brenda".

    If the filter is set to "Brenda" then document A and B will pass. If the filter is set to "Andrew AND Brenda" (typically meaning Andrew and Brenda options were checked) then document A will pass also.

  • 'int' - documents with a field containing an integer data item, where the integer matches the filter range (or exact match), will pass the filter.

Filter Control types

The underlying filters described above can be presented to the user with a variety of Controls (where it makes sense to do so). For example an 'int' filter might be presented to the user with 2 text boxes (allowing entry of an integer range), or the 'int' filter might be presented to the user with a dropdown menu, or a group of checkboxes.

  • 'calendar' - shows 2 date pickers allowing the user specify start and end dates. If the start date is not set, then all times up to the end date are allowed. If the end date is not set, then all times after the start date are allowed.
  • 'checkboxes' - shows a group of checkboxes with labels. Compatible with stringor, stringlistor, stringlistand, and int filters.
  • 'checkboxesIntRange' - shows a group of checkboxes with integer ranges defined in their labels. Suitable for int filters.
  • 'dropdown' - shows a SELECT element with dropdown options.
  • 'textboxesIntRange' - shows 2 text boxes (allowing entry of an integer range).

Adding and defining filter controls

To add a filter control to the page, add a DIV with class 'sew_filterControl' (remember it is possible to have multiple CSS classes apply to an element, just separate with a space).

HTML
        <div class="dateFilter sew_filterControl">
            <!--{   "FieldName":    "publishDate",
                    "ControlType":  "calendar",
                    "Label":        "Recipe date:",
                    "Type":         "date",
                    "Options":      []}-->
        </div>

Inside of the DIV is a comment containing JSON formatted meta data. JSON formatting uses the same simple object notation used by Javascript, essentially; "[]" means an array, "{}" means an object, and inside of the braces appear "property name: "value".

Filter definition (properties and options)

The properties set inside of the JSON meta data control what data field the filter works with, how the Control appears and how it operates, the table below shows possible values for each property.

Use care not to make syntax errors when writing JSON meta data, there are various online JSON validators available

 | FieldName | ControlType | Type | Label | Options | OptionLabelFormat | GetLiveDataFromServer
 | Name of the CustomData field | Control type to use | Underlying filter type | User friendly label | Options specific to the control | For labels that are based on option values | Whether to show filter options based on search result data
Calendar/date-pickers | * | "calendar" | "date" | text shown to the left of the date pickers | [] - if no options specified ["yyyy-mm-dd"] - to specify the earliest possible date available ["yyyy-mm-dd", "yyyy-mm-dd"] - to specify the selectable date range | n/a | "true"** or "false"
Checkboxes | * | "checkboxes" | "int" "stringor" "stringand" "stringlistand" "stringlistor" | text shown to the left of the checkboxes | [{ "value": "option1" }, { "value": "option2" }, ...] - a checkbox is shown for each array element, with the checkbox label and filter selection set to the "value" specified. | n/a | "true"** or "false"
Integer range checkboxes | * | "checkboxesIntRange" | "int" | text shown to the left of the checkboxes | [{ "value":"0-2000" }, { "value":"2000-5000"}, ...] - a checkbox is shown for each array element, with the checkbox label set to the "value" specified according to the OptionLabelFormat. The values specified should be in the format of low-high. | "${0} - ${1}" - where ${0} is replaced with the low-end option and ${1} is replaced with the high-end option. | "true"** or "false"
Drop down menu | * | "dropdown" | "int" "stringor" "stringand" "stringlistor" "stringlistand" | text shown to the left of the SELECT | [{ "value": "option1" }, { "value": "option2" }, ...] - an OPTION is added for each array element, with the text set to the "value" specified. | n/a | "true"** or "false"
Integer range textboxes | * | "textboxesIntRange" | "int" | text shown to the left of the first textbox | n/a | n/a | n/a (no options shown to user)

* - specify the field's name (that the filter should operate on) as it appears in the CustomData.

** - use with caution, this can cause extra work on the server (sampling and sorting data), extra data transmission to client (up to 500 unique data items). It is suggested that if there are thousands of different data values assigned to custom data, or many tens of thousands of possible results that this option not be used.

Some example filter definitions.

HTML

    <div class="sew_dateFilter sew_filterControl">
        <!-- {"FieldName":"manufacturedDate", "ControlType":"calendar",
                "Label":"Manufacture date:", "Type":"date", "Options":["2000-01-01"]}-->
    </div>

    <div class="sew_stringOrFilter sew_filterControl">
        <!-- {"FieldName":"make", "ControlType":"checkboxes",
                "Label":"Manufacturer:", "Type":"stringor", "Options":[{ "value": "Ford" },
                    { "value": "Toyota"  }, { "value": "Volkswagon"  }],
                "GetLiveDataFromServer": "true"}-->
    </div>

    <div class="sew_intListFilter sew_filterControl">
        <!-- {"FieldName":"modelYear", "ControlType":"dropdown",
                "Label":"Model year:", "Type":"int", "Options":[{ "value": "1979" }, { "value": "1980" },
                        { "value": "1987" }, { "value": "2010" }, { "value": "2013" },
                        { "value": "2014" }], "GetLiveDataFromServer": "true"} -->
    </div>

    <div class="sew_intRangeFilter sew_filterControl">
        <!-- {"FieldName":"price", "ControlType":"checkboxesIntRange","Label":"Price:",
                    "Type":"int", "OptionLabelFormat":"${0} - ${1}",
                    "Options":[{  "value":"0-2000" }, {  "value":"2000-5000" }, {  "value":"5000-10000" },
                    { "value":"10000-20000" }, { "value":"20000-50000" }],
                    "GetLiveDataFromServer": "true"} -->
    </div>

    <div class="sew_intRangeFilter sew_filterControl">
        <!-- {"FieldName":"price", "ControlType":"textboxesIntRange","Label":"Price:", "Type":"int",
                    "Options":[], "GetLiveDataFromServer": "false"} -->
    </div>

    <div class="sew_stringOrFilter sew_filterControl">
        <!-- {"FieldName":"options", "ControlType":"checkboxes","Label":"Options:", "Type":"stringlistand",
                    "Options":[{ "value": "Auto" }, { "value": "Electric windows"  }, { "value": "Manual"  },
                    { "value": "Hatchback"  }, { "value": "AC"  }], "GetLiveDataFromServer": "true"}-->
    </div>

A complete example page with 3 filters.

HTML
<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml">
    <head>
        <title></title>
        <link href="/Keyoti_SearchEngine_Web_Common/SearchUnit.css" rel="stylesheet" />
        <script src="/Keyoti_SearchEngine_Web_Common/SearchUnit.js"></script>
    </head>
    <body>
        <div id="sew_searchBoxControl"></div>

        <div id="sew_filterControls">

                <div class="sew_filterControl">
                    <!--{
                        "FieldName":    "manufacturedDate",
                        "ControlType":  "calendar",
                        "Label":        "Manufacture date:",
                        "Type":         "date",
                        "Options":      ["2000-01-01"]}-->
                </div>

                <div class="sew_filterControl">
                    <!--{
                        "FieldName":    "make",
                        "ControlType":  "checkboxes",
                        "Label":        "Manufacturer:",
                        "Type":         "stringor",
                        "Options":      [   { "value": "Ford" },
                                            { "value": "Toyota"  },
                                            { "value": "Volkswagon"  }],
                        "GetLiveDataFromServer":    "true"}-->
                </div>

                <div class="sew_filterControl">
                    <!-- {
                        "FieldName":    "modelYear",
                        "ControlType":  "dropdown",
                        "Label":        "Model year:",
                        "Type":         "int",
                        "Options":      [   { "value": "1979" },
                                            { "value": "1980" },
                                            { "value": "1987" },
                                            { "value": "2010" },
                                            { "value": "2013" },
                                            { "value": "2014" }],
                        "GetLiveDataFromServer":    "true"} -->
                </div>

        </div>

        <div id="sew_searchResultControl"></div>
    </body>
</html>

Updating results based on filter selection changes

By default, when the user changes a selection the results will automatically update (a new search is initiated to do this). This may not be ideal user experience if searches are slower than a second or two (due to large index or busy server), or if it is preferable to let the user update all of their choices before refreshing the results. To use a button to update results use the following code:

Javascript / HTML
    ...
        <script type="text/javascript">
            keyotiSearch.updateOnOptionChange = false;
        </script>
    ...
        <input type="button" onclick="keyotiSearch.showPage(1, true)" value="Update results" />


SearchUnit Documentation: Javascript Usage: How do I...: ...provide sort by controls

CustomData Sorting

Custom data that is stored in URL GET encoded format can be used to sort search results. For example if documents in the index have a custom data field named 'publishDate', which holds yyyy-mm-dd formatted data, then it is possible to sort documents by oldest/newest. Other numerical (and alphanumerical) fields such as price can also be sorted.

Adding and defining a sort control

To add a sort control to the page, add a DIV with class 'sew_filterControl'.

HTML
        <div id="sew_sortControl" style="display: inline-block">
            <!-- {"RelevanceText": "Most relevant", "Options":[
                    {"Label":"Preparation time (ascending)", "Field":"preparationTime",
                                                            "Direction":"ASC", "Type":"int"},

                    {"Label":"Preparation time (descending)", "Field":"preparationTime",
                                                            "Direction":"DES", "Type":"int"},

                    {"Label":"Recipe date (newest first)", "Field":"publishDate",
                                                            "Direction":"DES", "Type":"date"},

                    {"Label":"Recipe date (oldest first)", "Field":"publishDate",
                                                            "Direction":"ASC", "Type":"date"}
                ]}-->
        </div>

Inside of the DIV is a comment containing JSON formatted meta data. JSON formatting uses the same simple object notation used by Javascript, essentially; "[]" means an array, "{}" means an object, and inside of the braces appear "property name: "value".

Sort definition (properties and options)

The properties set inside of the JSON meta data control what data field the sort works and how it operates. The 'RelevanceText' property is optional and sets the text used for the default sort order (hit ranking). The table below shows possible values for each property of the Options array.

Use care not to make syntax errors when writing JSON meta data, there are various online JSON validators available

Label | Field | Direction | Type
Option text in the dropdown | The custom data field to sort results by | Which direction to sort in | Type of field data (case insensitive)
* | * | "ASC" - ascending (eg. a->z, 0->9, 1999-01-01->2014-12-31) "DES" | "int" "decimal" "date" "string"

Example adding a sort control inside the header of the search results.

HTML
<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml">
    <head>
        <title></title>
        <link href="/Keyoti_SearchEngine_Web_Common/SearchUnit.css" rel="stylesheet" />
        <script src="/Keyoti_SearchEngine_Web_Common/SearchUnit.js"></script>
    </head>
    <body>
        <div id="sew_searchBoxControl"></div>
        <div id="sew_searchResultControl">
            <div id="sew_resultView">

                <div id="sew_resultHeader">
                    <div id="sew_headerTEMPLATE" class="sew_header">
                        Showing result page <b>${PageNumber}</b>. There are
                        <b>${NumberOfResults}</b> results for <b>&#8220;${Query}&#8221;</b>.
                        <span id="sew_ignoredWords">The following common words were ignored: ${IgnoredWords}</span>

                        <div id="sew_sortControl">
                            <!--
                                {"Options":[
                                    {"Label":"Price (Ascending)", "Field":"price", "Direction":"ASC", "Type":"int"},
                                    {"Label":"Price (Descending)", "Field":"price", "Direction":"DES", "Type":"int"}
                                ]}
                            -->
                        </div>

                   </div>
                </div>

                <div id="sew_resultList"></div>
                <div id="sew_resultFooter"></div>
            </div>
        </div>
    </body>
</html>

In this example the default header template is appended to with the sew_sortControl DIV.

Updating results based on sort by selection changes

By default, when the user changes a selection the results will automatically update (a new search is initiated to do this). This may not be ideal user experience if searches are slower than a second or two (due to large index or busy server), or if it is preferable to let the user update all of their choices before refreshing the results. To use a button to update results use the following code:

Javascript / HTML
    ...
        <script type="text/javascript">
            keyotiSearch.updateOnOptionChange = false;
        </script>
    ...
        <input type="button" onclick="keyotiSearch.showPage(1, true)" value="Update results" />


SearchUnit Documentation: Javascript Usage: How do I...: ...provide location or content category choosers

Adding Location and/or Content Category Options (Pro version only)

Pro version users can setup location and content categorization. To provide the user with control over which categories to search add DIVs with ID's sew_locationChooserControl and/or sew_contentChooserControl. At runtime these will hold location radio button controls and content checkbox controls, be default.

Javascript / HTML
<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml">
    <head>
        <title></title>
        <link href="Keyoti_SearchEngine_Web_Common/SearchUnit.css" rel="stylesheet" />
        <script src="Keyoti_SearchEngine_Web_Common/SearchUnit.js"></script>
    </head>
    <body>
        <div id="sew_searchBoxControl"></div>

       <div id="sew_locationChooserControl"></div>
       <div id="sew_contentChooserControl"></div>
        <div id="sew_searchResultControl"></div>
    </body>
</html>

Updating results based on category selection changes

By default, when the user changes a selection the results will automatically update (a new search is initiated to do this). This may not be ideal user experience if searches are slower than a second or two (due to large index or busy server), or if it is preferable to let the user update all of their choices before refreshing the results. To use a button to update results use the following code:

Javascript / HTML
    ...
        <script type="text/javascript">
            keyotiSearch.updateOnOptionChange = false;
        </script>
    ...
        <input type="button" onclick="keyotiSearch.showPage(1, true)" value="Update results" />

Setting the default Location or Content Category to search inside, with or without a control

To set the location or content category to search within, call the code below. Note that it works with or without the sew_locationChooserControl or sew_contentChooserControl DIVs on the page.

Javascript / HTML
    ...
        <script type="text/javascript">
            keyotiCategoryChoosers.setSelectedLocation("locationName");  //set the default location to search inside
            keyotiCategoryChoosers.setSelectedContents(["contentName1", "contentName2"]);  //set the default contents to search inside
        </script>
    ...

Templating the Controls

For example, to use a SELECT control in the location chooser;

HTML
    ...
    <span id="sew_locationChooserControl">
        <select id="sew_locationOptionTEMPLATE" class="sew_locationOption">
            <option class="sew_locationOptionItem" value="${Value}">${Value}</option>
        </select>
    </span>
    ...

The dynamic elements are: ${Value} (the location name text) and ${Id} which is a unique integer for the location option.

In the above example, the template is defined in a SELECT element. The templating engine will put location items inside the SELECT as OPTION elements - in other words, the content of the SELECT element is repeated for each location item.

Remember that the search engine can only search one location category at a time (it can search multiple content categories), therefore it could be confusing to the user if the control used allows multiple selections.

The default templates for location and content choosers are;

HTML
    ...
    <div id="sew_locationChooserControl">
        <div id="sew_locationOptionTEMPLATE" class="sew_locationOption">
            <label>
                <input type="radio" name="sew_locationOption" class="sew_locationOptionItem" value="${Value}"/>${Value}
            </label>
        </div>
    </div>

    <div id="sew_contentChooserControl">
        <div id="sew_contentOptionTEMPLATE" class="sew_contentOption">
            <label>
                <input type="checkbox" class="sew_contentOptionItem" value="${Value}"/>${Value}
            </label>
        </div>
    </div>
    ...

Modifying the Display Text Used for a Location or Content Category

By default the category name as contained in the index (backend) is displayed to the user (frontend), but it is possible to modify that. To do that override keyotiCategoryChoosers.convertLocationBackendNameToFrontEndName and/or keyotiCategoryChoosers.convertContentBackendNameToFrontEndName.

For example there is a default location named "All", to change it to "Everything" use;

Javascript
     ...
    keyotiCategoryChoosers.convertLocationBackendNameToFrontEndName = function (locationName, convertBack) {
        if (!convertBack) {
            if (locationName == "All") return "Everything";
        } else {
            if (locationName == "Everything") return "All";
        }
        return locationName;
    }
    ...

The 'convertBack' parameter indicates that the reverse conversion is required.

Similarly to convert a content category named "Forum" to "ABC".

Javascript
     ...
    keyotiCategoryChoosers.convertContentBackendNameToFrontEndName = function (contentName, convertBack) {
        if (!convertBack) {
            if (contentName == "Forum") return "ABC";
        } else {
            if (contentName == "ABC") return "Forum";
        }
        return contentName;
    }
    ...


SearchUnit Documentation: Javascript Usage: How do I...: ...provide a search cloud

Search/Keyword Cloud

A search (tag or word) cloud is a collection of common search terms that users of the site have searched for. It enables other users to see popular search terms (note that only words that are in the search lexicon will be shown in the cloud, preventing inappropriate searches being shown). To add a search cloud to the page add a DIV with id='sew_searchCloudControl'.

HTML
<div id="sew_searchCloudControl"></div>

Item template, properties and styling

By default the items inside of the cloud control can be styled with CSS, the elements are written like this:

HTML
    <div id="sew_searchCloudControl" style="visibility: visible;">
        <span class="sew_searchCloud">
            <span class="sew_searchCloudItem" style="font-size: 0.85em;"><a onclick="keyotiSearchBox.doSearch('car', 1)" href="#stayhere">car</a></span>
            <span class="sew_searchCloudItem" style="font-size: 0.8em;"><a onclick="keyotiSearchBox.doSearch('truck', 1)" href="#stayhere">truck</a></span>
        </span>
    </div>

Properties

  • keyotiSearchCloud.fontSizeUnits - maximum and minimum font sizes are defined in Javascript (CSS font units, eg. 'em')
  • keyotiSearchCloud.minimumFontSize - smallest size possible for text in the cloud (least popular terms)
  • keyotiSearchCloud.maximumFontSize - largest size possible for text in the cloud (most popular terms)
  • keyotiSearchCloud.numberOfQueriesToGet - number of query terms to show in the cloud
To further control the appearance of items in the cloud, specify a template (add the following to the page outside of the sew_searchCloudControl DIV:
HTML
<!-- It is important that this template be specified outside of the sew_searchCloudControl DIV -->
<span id="sew_searchCloudItemTEMPLATE" >
    <a href="#stayhere" onclick="keyotiSearch.search('${QueryEscaped}', 1)">${Query}</a>
</span>

If the index directory is not the default Keyoti_Search_Index then it is necessary to point to the folder (use the tilda ~ notation to point to the application root, or use an absolute file path);

Javascript / HTML
    ...
        <script type="text/javascript">
            keyotiSearch.indexDirectory = "~/myindexdirectory";
        </script>
    ...

Settings

Javascript / HTML : search.html
<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml">
    <head>
        <title></title>
        <link href="Keyoti_SearchEngine_Web_Common/SearchUnit.css" rel="stylesheet" />
        <script src="Keyoti_SearchEngine_Web_Common/SearchUnit.js"></script>
    </head>
    <body>
        <div id="sew_searchBoxControl"></div>
        <div id="sew_searchResultControl"></div>
    </body>
</html>
Javascript / HTML : index.html
<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml">
    <head>
        <title></title>
        <link href="Keyoti_SearchEngine_Web_Common/SearchUnit.css" rel="stylesheet" />
        <script src="Keyoti_SearchEngine_Web_Common/SearchUnit.js"></script>
        <script type="text/javascript">
            keyotiSearchBox.resultURL = "search.html";
        </script>
    </head>
    <body>
        <div id="sew_searchBoxControl"></div>
    </body>
</html>


SearchUnit Documentation: Javascript Usage: How do I...: ...provide spelling suggestions (did you mean?)

Spelling Suggestions ("Did you mean?") - Pro version

The default result header template will display spelling suggestions for misspelled search queries.

HTML
    ...
    <div id="sew_resultHeader">
        <div id="sew_headerTEMPLATE" class="sew_header">
            Showing result page <b>${PageNumber}</b>.
            There are <b>${NumberOfResults}</b> results for <b>&#8220;${Query}&#8221;</b>.
            <span id="sew_ignoredWords">The following common words were ignored: ${IgnoredWords}</span>
            <div id="sew_didYouMean">Did you mean: <a href="#stayhere"
                    onclick="keyotiSearch.search(\'${SuggestedSearchExpressionEscaped}\', 1)">${SuggestedSearchExpression}</a></div>
        </div>
    </div>
    ...

It is important to wrap the 'did you mean' section with an element with id sew_didYouMean, because this element is automatically made invisible if there are no misspelled words.

${SuggestedSearchExpressionEscaped} is a Javascript safe string (ie. escaped quotes) containing the corrected search query.

${SuggestedSearchExpression} is the corrected search query.

Language

Installation of Additional Language Dictionaries

Download and unzip the .dict file(s) required and place it in a folder under the Index Directory called "Dictionaries" (creating if need be). For example - myApp\IndexDirectory\Dictionaries\DICT-DE-DE-German_SE.dict. The dictionary files must not be renamed, as their language is determined from the filename.

Multiple global dictionaries are available for free download, once installed a language can be selected using the keyotiSearch.language property.

HTML
    keyotiSearch.language = "EnglishUS";

Valid language strings are as the values defined in the enum Keyoti.SearchEngine.Suggestions.LanguageType: Danish, Dutch, English, EnglishAustralia, EnglishCanada, EnglishMedical, EnglishUK, EnglishUS, French, German, Italian, Norwegian, Polish, Portuguese, Spanish, SpanishLatinAmerica, Swedish, Russian, Custom

When set to "Custom" the spell checker will attempt to load a dictionary file under the Dictionaries folder named DICT-X-X-Custom_SE.dict

Custom Dictionary Wordlists

It is common for web-sites and users to use words that are not in the standard dictionary, typically this includes organizational names, acronyms and jargon. To avoid having these terms queried to the user on searches, add them to a text file (eg. "custom_dictionary.txt") and place that file on the server. Set keyotiSearch.customDictionaryPath to point to 'custom_dictionary.txt' (this is relative to the indexDirectory\Dictionaries\ folder). The terms used in the text file will supplement the dictionary, both for known words and for suggestions. It is recommended that all legal forms of the word are added, and added in lowercase, eg;

keyoti

keyoti's

rapidspell

Spell Suggestion Source

Where the spelling suggestions will be sourced, options are defined in the Keyoti.SearchEngine.Suggestions.SpellingSuggestionSource enum (eg. PresetDictionary, SearchLexicon, PresetDictionaryAndOptionalSearchLexicon, PresetDictionaryAndSearchLexicon). Care should be taken with lexicon based options as large lexicons can cause slow downs.

HTML
    keyotiSearch.spellingSuggestionSource = "PresetDictionary";


SearchUnit Documentation: Search & Result Controls: How do I...: ...customize the AutoComplete

Show language: C# VB.NET Both

AutoComplete Customization

The AutoComplete feature of SearchBox can be customized through the use of a plug-in, or with Javascript on the client side.

Plug-in (Server Side)

AutoComplete Settings

For maximum efficiency plug-in DLLs are not loaded unless keyotiSearchAutocomplete.options.sew_autoCompleteQueryLoadPlugin is set "true". Set this property in the Javascript, in order to be able to modify the autocomplete suggestions.

Creating The Plug-in

A Plug-in project can quickly be generated from the 'Plug-ins' tab in the Index Management Tool, in the project you will find code which handles the AutoCompleteSuggestionsGenerated event. For more information on plug-ins, see the overview of the Central Event System in general.

A plug-in class will subscribe to the Action event and process ActionName.AutoCompleteSuggestionsGenerated. The associated ActionData.Data is of type ArrayList, and contains a list of SearchBoxAutoCompleteHelper.SuggestionResultPair objects. The original text entered by the user is accessible through 'sender' (see below)

C#
private void CentralEventDispatcher_Action(object sender, Keyoti.SearchEngine.Events.ActionEventArgs e)
{
    if(e.ActionData.Name== ActionName.AutoCompleteSuggestionsGenerated)
    {
        ArrayList suggestionPairs = e.ActionData.Data as ArrayList;
        Keyoti.SearchEngine.Web.SearchBoxAutoCompleteHelper helper =
            sender as Keyoti.SearchEngine.Web.SearchBoxAutoCompleteHelper;
        string textEnteredByUser = helper.Query;
        string[] wordsInText = helper.Segments;
        suggestionPairs.Add(new
            Keyoti.SearchEngine.Web.SearchBoxAutoCompleteHelper.SuggestionResultPair("testQuery", 99));
    }
}
VB.NET
Private Sub CentralEventDispatcher_Action(ByVal sender As Object,_
                    ByVal e As Keyoti.SearchEngine.Events.ActionEventArgs)
    If (e.ActionData.Name = ActionName.AutoCompleteSuggestionsGenerated) Then
         Dim suggestionPairs As ArrayList = CType(e.ActionData.Data,ArrayList)
         Dim helper As Keyoti.SearchEngine.Web.SearchBoxAutoCompleteHelper = _
            CType(sender,Keyoti.SearchEngine.Web.SearchBoxAutoCompleteHelper)
         Dim textEnteredByUser As String = helper.Query
         Dim wordsInText() As String = helper.Segments
         suggestionPairs.Add(New _
            Keyoti.SearchEngine.Web.SearchBoxAutoCompleteHelper.SuggestionResultPair("testQuery", 99))
     End If
End Sub

In this example the suggestionPairs list is modified with a new suggestion 'testQuery' added to the end. The list can be cleared, or items removed too. Use 'textEnteredByUser' or 'wordsInText' to determine what the user has typed.

Javascript (Client Side)

On the page with the SearchBox, specify a function called keyotiSearchAutocomplete.sew_OnAutoCompleteSuggestionsGenerated, this will be automatically called by the autocomplete engine when suggestions are generated, allowing for modification of the suggestion list or items in the list.

Javascript
keyotiSearchAutocomplete.sew_OnAutoCompleteSuggestionsGenerated = function (query, suggestions) {

    //how to iterate the generated suggestions
    for (var i = 0; i < suggestions.length; i++) {
        var suggestionText = suggestions[i][0];
        //# of results, will be -1 if AutoCompleteQueryShowNumberOfResults==false
        var suggestionNumberOfResults = suggestions[i][1];

        //modify the text?
        suggestions[i][0] = suggestions[i][0] + "*"; //turn each suggestion into a wildcard
    }
    //add a bonus suggestion, with '10' predicted results
    suggestions[suggestions.length] = ["bonus", 10];
}


SearchUnit Documentation: Search & Result Controls: How do I...: ...customize ResultPreview

Show language: C# VB.NET Both

ResultPreview Customization

The ResultPreview feature of SearchResult can be customized through the use of a plug-in, or with Javascript on the client side.

Plug-in (Server Side)

ResultPreview Settings

For maximum efficiency plug-in DLLs are not loaded unless keyotiSearchResultPreviewer.previewLoadPlugin is set "true". Set this property in Javascript, in order to be able to modify the preview text.

Creating The Plug-in

A Plug-in project can quickly be generated from the 'Plug-ins' tab in the Index Management Tool, in the project you will find code which handles the ResultPreviewTextLoaded event. For more information on plug-ins, see the overview of the Central Event System in general.

A plug-in class will subscribe to the Action event and process ActionName.ResultPreviewTextLoaded. The associated ActionData.Data is of type StringBuilder, and contains the document text, which may be modified. The document Uri is accessible through 'sender' (see below)

C#
private void CentralEventDispatcher_Action(object sender, Keyoti.SearchEngine.Events.ActionEventArgs e)
{
    if(e.ActionData.Name== ActionName.ResultPreviewTextLoaded)
    {
        StringBuilder documentPreviewText = e.ActionData.Data as StringBuilder;
        string uri = (sender as Keyoti.SearchEngine.Web.SearchResultPreviewHelper).Uri;
        //Change the document text, to put the Uri at the start of the text.
        //Remember that if you reassign documentPreviewText to a new object,
        //it will not be used by the previewer.
        documentPreviewText.Insert(0, "Document URL::" + uri + "\r\n\r\n");
    }
}
VB.NET
Private Sub CentralEventDispatcher_Action(ByVal sender As Object,_
                    ByVal e As Keyoti.SearchEngine.Events.ActionEventArgs)
    If (e.ActionData.Name = ActionName.ResultPreviewTextLoaded) Then
        Dim documentPreviewText As StringBuilder = CType(e.ActionData.Data,StringBuilder)
        Dim uri As String = CType(sender,Keyoti.SearchEngine.Web.SearchResultPreviewHelper).Uri
        'Change the document text, to put the Uri at the start of the text.
        'Remember that if you reassign documentPreviewText to a new object,
        'it will not be used by the previewer.
        documentPreviewText.Insert(0, ("Document URL::"  + (uri + ""& vbCrLf& vbCrLf)))
    End If
End Sub

In this example the document text is modified to include the Uri at the start. The documentPreviewText is a StringBuilder and can be modified with any of its methods.

Javascript (Client Side)

On the page with the SearchResult control, add a function called sew_OnResultPreviewTextLoaded, this will be automatically called by the result preview engine when the text is about to be shown, allowing for modification of the text.

Javascript
keyotiSearchResultPreviewer.sew_OnResultPreviewTextLoaded = function (url, text, button, closedImgURL, openedImgURL) {
    //url - document URL
    //text - document text to be shown to user
    //button - instance of the HTML element that the user clicked (could be an img)
    //closedImgURL, openedImgURL - the URLs specified for the button states

    //Let's put the doc URL at the end of the text
    return text + "\r\n\r\n" + url;
}

Note that the modified text is returned, rather than set in the 'text' variable.


SearchUnit Documentation: Result Generation: How do I...: ...boost page & section weight

Show language: C# VB.NET Both

Boosting Page & Section Weight

HTML (ASPX etc)

Whole (or sections of) HTML pages may be boosted in weight using HTML comments, this means that the words will be treated as more important and push the page higher in the search results. Place a HTML comment immediately before the section (or entire page) that you want boosted in weight.

<!--keyoti_search_weight_boost_factor="2.8"-->
<p>all words from here to the end of the page will be weighted by 2.8x more than usual....

To reset the weight to normal, just set the boost factor to "1".

<!--keyoti_search_weight_boost_factor="3"-->
<p>all words in this section will be weighted by 3x more than usual.</p>
<!--keyoti_search_weight_boost_factor="1"-->
<p>all words in this section, to the end of the page will be weighted as usual.</p>

Note that the boost factor is converted to a single precision decimal, and should be greater than 0. Sections with a weight factor of "0" will not be ignored, but instead will result in the document being last in the results. To ignore a region, see this section.

All Document Types

Alternatively, word weighting can be modified in any document with a plug-in. Create a plug-in project using the index manager tool, and in the template find the code for the CalculateWordRelevancies event.

C#
private void CentralEventDispatcher_Action(object sender, Keyoti.SearchEngine.Events.ActionEventArgs e)
{
    if(e.ActionData.Name== ActionName.CalculateWordRelevancies)
    {

    System.Collections.ArrayList words = e.ActionData.Data as System.Collections.ArrayList;
    Document document = sender as Document;
    if (document.Uri.AbsolutePath.Contains("/important/"))
    {
        foreach (Word word2 in words)
        {
            word2.Weight *= 2; //boost the weight of all words by 2, if they're in the /important/ subdir.
        }
    }
}
VB.NET
Private Sub CentralEventDispatcher_Action(ByVal sender As Object,_
                    ByVal e As Keyoti.SearchEngine.Events.ActionEventArgs)
    If (e.ActionData.Name = ActionName.CalculateWordRelevancies) Then

        Dim words As System.Collections.ArrayList = CType(e.ActionData.Data,System.Collections.ArrayList)
        Dim document As Document
        document = CType(sender,Document)
        If document.Uri.AbsolutePath.Contains("/important/") Then
         For Each word2 As Word In words
             word2.Weight = (word2.Weight * 2)
             'boost the weight of all words by 2, if they're in the /important/ subdir.
         Next
        End If

    End If
End Sub

This code will boost all words by 2x that are in documents under the '/important' folder - but any criteria can be used, and specific words in the 'words' collection can be modified in weight.


SearchUnit Documentation: Authentication: How do I...: ...secure document access to specific groups of users

Securing Document Access (Security Groups etc)

Overview

In systems and applications where search users may be restricted in the documents that they can view, it is desirable to limit results so as to not include restricted documents. There are various approaches that can be taken to achieve this and the best approach depends on the situation, and must be decided by the creator of the index.

'Early Binding'

This type of access control involves identifying and storing which users (groups) can access which documents as the index is being prepared. This could mean that the document access control is specified in meta-tags, by a plug-in, derived from the document's location or set manually.

The advantage of 'early binding' is performance, because the results are generated based on access control logic at a deeper level in the engine than with 'late binding'. There are 2 models of 'early binding' outlined below:

-Security Groups Pro only

Security Groups are built into this product, and are ideal in nearly all cases, except when 'separate index directories' are required.

  • 255 different security groups (or privilege levels) may be specified per index
  • 8 (default) security groups may be assigned to each document
  • Results are restricted based on the security group (privilege) that the logged in user belongs to
More information on Security Groups
-Separate Index Directories Per User Group

If your application generates different content based on the logged-in user's privilege level (eg. default.aspx has different content for different user groups) then 'Security Groups' will not work, because there is no way for the index to differentiate between the same URL for different user groups.

The suggested solution is to create a different index directory for each privilege level.

Eg. if application users can be either; public, members or premium members then 3 index directories should be created, named;

  • c:\...\index_dir_public
  • c:\...\index_dir_members
  • c:\...\index_dir_premium_members

The web-site should then be crawled 3 times, once for each index directory, and using the appropriate log-in, to show the indexer the content for that user group (public, members, premium members).

Then at search time the SearchResult control can be pointed to the correct index directory for the current user by setting the SearchResult.IndexDirectory property.

'Late Binding'

Possibly the simplest approach, 'late binding' requires only the creation of a filter which will filter documents based on what the current user can see. The disadvantage of this is lower performance and availability of data to decide which documents are accessible. Please see the section on filtering to understand how to write a filter.

  • The filter must be able to efficiently (ie. ideally not by hitting a DB) decide which documents the current user can see, at search time (this could be based on URL, or using Custom Data)
  • No logic need to be applied during indexing (unless Custom Data is used, in which case it must be stored during indexing)

Please email support@keyoti.com if it is not clear which type of approach to use.


SearchUnit Documentation: Result Generation: How do I...: ...modify stemming (lemmas)

Show language: C# VB.NET Both

Stemming And Lemmas

Stemming (finding lemmas) is used to search for word variations. Eg. if the user searches for "tables", they will receive results that include "table" (note that this is more powerful than simple wildcard searching, because it can match shorter as well as longer forms).

The LemmaWeightFactor property in the Configuration is set to 0.5 by default, and this controls by how much lemma matches are weighted in the results. If the user searched for "tables", then occurrences of "table" will weigh half as much as occurrences of "tables", this ranking helps prevent the top results being cluttered with inexact matches to the searched terms.

Languages

You can choose the language to use for stemming in the LemmaLanguage property in the Configuration. Note that stemming algorithms are language specific and so the supported languages may be less numerous than the spelling dictionaries that are also available for the SearchSuggestions control.

English and German lemmas are built-in to the product DLLs, other languages can be downloaded from this page. Unzipped files should be placed in the index directory, and the LemmaLanguage property in Configuration should be set accordingly.

Customization

The Central Event System includes an Action event called "GetWordVariations" which is fired when the search engine needs lemmas. By hooking into this event the lemmas provided by the default generator can be completely overwritten or modified. Note that variations don't necessarily have to be lemmas (shared stems) but can be any words that should be searched for at the same time, such as synonyms and substitutes. For example a company with a furniture polish product named "Shine-O", may like to include "Shine-O" as a variation for "polish".

Hook into the Central Event System
C#
protected void Page_Load(object sender, EventArgs e)

{

    Sr1.Configuration.CentralEventDispatcher.Action += new Keyoti.SearchEngine.Events.ActionEventHandler(CentralEventDispatcher_Action);

}
VB.NET
Protected Sub Page_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles Me.Load

    AddHandler (Sr1.Configuration.CentralEventDispatcher.Action), AddressOf CentralEventDispatcher_Action

End Sub
Handle the desired event
C#
void CentralEventDispatcher_Action(object sender, Keyoti.SearchEngine.Events.ActionEventArgs e)

{

    if (e.ActionData.Name == Keyoti.SearchEngine.Events.ActionName.GetWordVariations)

    {

        Keyoti.SearchEngine.DataAccess.Word theWord = ((object[])e.ActionData.Data)[0] as Keyoti.SearchEngine.DataAccess.Word;

        ArrayList variations = (e.ActionData.Data as object[])[1] as ArrayList;

        if (theWord.WordContent == "polish")

        {

            string firstVariation = variations[0].ToString();

            variations.Insert(0, "Shine-O");//insert a word we also want to search for

        }

    }

}
VB.NET
Private Sub CentralEventDispatcher_Action(ByVal sender As Object, ByVal e As Keyoti.SearchEngine.Events.ActionEventArgs)

        If (e.ActionData.Name = Keyoti.SearchEngine.Events.ActionName.GetWordVariations) Then

            Dim theWord As Keyoti.SearchEngine.DataAccess.Word = CType(CType(e.ActionData.Data, Object())(0), Keyoti.SearchEngine.DataAccess.Word)

            Dim variations As ArrayList = CType(CType(e.ActionData.Data, Object())(1), ArrayList)

            If (theWord.WordContent = "polish") Then

                Dim firstVariation As String = variations(0).ToString

                variations.Insert(0, "Shine-O")

                'insert a word we also want to search for

            End If

        End If

    End Sub


SearchUnit Documentation: Javascript Usage: How do I...: ...get query term analytics with Google Analytics

Setup Site Search for Google Analytics

Overview

'Site Search' can be setup witin Google Analytics to track your user's search activity while using SearchUnit. You should already have the Analtyics tracking code installed on all relevant pages before following this guide.

You can also view our online tutorial (including video) or follow the simple steps below.

Standard two page setup

If you are using a two page setup for SearchUnit, whereby you use a separate page to display the search results, follow these steps;

  • Enable 'Site Search'
    Navigate to the Admin section of your Analytics account. Then click on View Settings option for the View you wish to setup Site Search tracking on and enable 'Site Search Tracking'.

  • Add the query parameter
    A typical URL for the SearchUnit search results page will look like this;
    http://keyoti.com/searchresults.aspx?query=test

    In order that Google Analytics can determine the search term used we just need to set the Query Parameter field to query.

  • Optional category parameters
    For Google Analytics to register the categories used to refine your site's search results, under Site Search Categories enter 'location' and 'contents'.

Once you have finished setting up your parameters click Save.

One page (AJAX) setup

If you are displaying search results within the same page as the search box - so for instance you are using the AJAX method of displaying search results within the same page, follow these steps

  • Virtual pageview
    When using a one page AJAX setup you won't have the opportunity to use the query parameter in the URL to register the search term so you will need to register a virtual pageview with Google Analytics instead. To do this, simply add the following function to your search button's onclick event;

    ga('send', 'pageview', '/mysite/?query='+ keyotiSearchBox.getQuery());


SearchUnit Documentation: Custom Data filters & sorting

Custom Data Filters & Sorting

Custom Data (fielded data added to document records in the index) can be used as filter sources, with various controls created to facilitate user selection of filters.

Custom Data can also be used as a source for search result sorting.


SearchUnit Documentation: Auto Complete

Auto Complete

The search box control can provide an AJAX based autocomplete as the user types a query, by default (the suggestions are customizable).

Some AutoComplete Members

Access to the autocomplete Javascript object, is through the 'keyotiSearchAutocomplete' namespace.

keyotiSearchAutocomplete.filterFilenames
Whether to filter out filenames from the suggestions.

keyotiSearchAutocomplete.sew_failSilent
Whether to show warning messages about errors - advised to set to false for development.

keyotiSearchAutocomplete.options.sew_queryTextBoxID
The ID of the text box where autocomplete suggestions will be shown.

keyotiSearchAutocomplete.options.sew_searchButtonID
The ID of the search button.

keyotiSearchAutocomplete.options.sew_numberOfSuggestions
The maximum number of suggestions to show.

keyotiSearchAutocomplete.options.sew_runSearchOnSelect
Whether to run search when an autocomplete suggestion is selected.

keyotiSearchAutocomplete.options.sew_showNumberOfResults
Whether to show the estimated number of results for each suggestion.

keyotiSearchAutocomplete.options.sew_autoCompleteQueryLoadPlugin
Whether to load any plugin DLL (as specified by Configuration.ExternalEventHandler) - this allows customization of the auto complete suggestions.

keyotiSearchAutocomplete.options.sew_hideNoResulters
Hide suggestions with no (estimated) results.

Query Suggestion Source

The source of data for auto-complete suggestions can be set using the keyotiSearchAutocomplete.options.sew_source property.

IndexLexicon
Uses the lexicon from the index directory as set under AutoCompleteQueryIndexDirectory, for auto-complete suggestions.

PopularSearches
Previous search terms are used to provide auto-complete suggestions in order of popularity. The algorithm uses an attenuating window to keep new queries important and prevent the popular-search list becoming too large over time.
Note: The AutoCompleteQueryIndexDirectory must still be set.
Note: To prevent inappropriate suggestions and/or hijacking of suggestions by certain users, only words which are in the index lexicon will be offered as suggestions.

Note: Offensive words should not be added to the stop list as those words could appear as a suggestion if another user searches for them.

PopularSearchesAndLexicon (default)
A mix of the above where popular searches are favored, and if there are not enough suggestions from that source then additional suggestions are found from the lexicon.

Server farm synchronization

The popular search auto-complete source must synchronize all servers in a farm in order to function accurately (otherwise different servers will offer different suggestions).

To do this, specify the IP (or server name) of every server in the farm in the web.config, using an appSetting named Keyoti-SearchEngine-ServerFarmSynchronizationIPs, its value should be a comma-delimited list. It is also necessary to specify an appSetting named Keyoti-SearchEngine-ServerFarmSynchronizationAppPath with a value indicating the relative URL of the app. Eg.

<appSettings>
    <add key="Keyoti-SearchEngine-ServerFarmSynchronizationIPs" value="10.0.0.1,10.0.0.2,10.0.0.3"/>
    <add key="Keyoti-SearchEngine-ServerFarmSynchronizationAppPath" value="/myapp/"/>
</appSettings>

The web.config also needs to have a HttpHandler registered, please see the HTTP handler install section.

Doing so will allow servers to communicate with each other every 5 minutes with changes in search keyword data.


SearchUnit Documentation: Result Previewer

Result Previewer

The SearchResult control can provide an AJAX based preview of a result document without the user having to leave the results page (the preview text is customizable). To remove the result preview button, edit the result item template and remove the sew_previewResultWrapper span and its content.


SearchUnit Documentation: Spelling suggestions

Spelling Suggestions ("Did you mean?") - Pro version

The header template can display a link with corrected spelling in the event that the user misspells part of a query.

A custom dictionary can be specified with a list of words that should be ignored (eg. company terms, names etc), in addition to many non English dictionaries. More information in the example.


SearchUnit Documentation: Hit highlighting in result pages

Hit Highlighting in Result Pages

HTML based documents (ASPX etc) clicked on from the result list will have the search keywords highlighted if either the SearchUnit.js or SearchUnit_Highlighter.js scripts are imported on the page.

Import the SearchUnit_Highlighter.js script only if SearchUnit.js is not being used, the SearchUnit_Highlighter.js script is smaller than SearchUnit.js.

<script src="Keyoti_SearchEngine_Web_Common/SearchUnit_Highlighter.js"></script>

Disable Highlighting

To disable highlighting, call keyotiSearch.highlightKeywordsInResultDocument = false;

Change Highlighting Style

Specify a rule for the class keyoti_highlight on the page or .css file.

    <style>
        .keyoti_highlight
        {
            background-color: red;
        }
    </style>


SearchUnit Documentation: Javascript Usage: Server Security

Server Security

Error Messages

Error messages are intended to be used for debugging purposes, however they can include sensitive information (such as file paths). For security, error details are only shown if either of the following are true:

  • The application was accessed through localhost
  • The web.config contains an appSetting named Keyoti-SearchEngine-ShowDetailedErrors, with value="true".
    web.config
        <configuration>
        <system.web>
            ...
        </system.web>
        <appSettings>
            <add key="Keyoti-SearchEngine-ShowDetailedErrors" value="true"/>
        </appSettings>

If errors are arising outside of localhost, temporarily enable show detailed errors to obtain more information.


SearchUnit Documentation: Typical Development/Deployment Scenarios

Typical Development/Deployment Scenarios

Considering that the index is typically generated based on one server's URLs (e.g. localhost) and the IndexDirectory is a path that may be specific to a server, the question naturally arises, how should the index files be deployed? The solution to these two issues is straightforward and depends on the method of development and deployment used - this section may appear long, however it is best to understand the principles before making the two minor settings.

Regarding the search engine, there are two distinct methods of development and deployment to look at.

a) development is performed on a server (e.g. localhost) and deployment is made to a live server, because the live server contains an up to date copy of the web-site to be searched the search index is built against the live server (by importing the current live site), as a result the search result URLs will be correct and the only issue regarding deployment is that of the IndexDirectoy property (see 1. below).

b) development is performed on a server (e.g. localhost) and deployment is made to a live server, because the live server DOES NOT contain an up to date copy of the web-site to be searched the search index is built against the development server, as a result the search result URLs will be incorrect when the index files are deployed to the live server, so they must be mapped from development to deployment (see 1. and 2. below).

1. How to configure the IndexDirectory path

The IndexDirectory property is a file path on the server where the control can read the index files. The property in SearchResult can be overridden by values appearing in the web.config, under the name "Keyoti- SearchEngine-IndexDirectory". This means that the web.config for the deployment server can contain information specific to it, for example;

<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="Off"/>
    </system.web>

    <appSettings>
        <add key="Keyoti-SearchEngine-IndexDirectory" value="d:\web\app1\Indexes"/>
        <add key="Keyoti-SearchEngine-LicenseKey" value="257375237C7B79.....53"/>
    </appSettings>

If these settings are present in the web.config on the production server for example, it will read the index from "d:\web\app1\Indexes" regardless of the settings in the IndexDirectory property in the code. This means that it is safe and convenient to keep a development machine specific IndexDirectory set in code.

Alternatively, with .NET 2 up, it is possible to specify the IndexDirectory as a relative URL, eg. ~/IndexDirectory, if the IndexDirectory is located under the application root. Provided the IndexDirectory is in the same position under development and on the server, there should be no changes necessary.

2. How to map development machine URLs to deployment machine URLs

When an index is built against a machine, for example "localhost" the document URLs stored in the index will be specific to that machine and since those URLs are linked to result items, they will be invalid. Eg. if an index is built on localhost the document URLs will likely be "http://localhost/app1/default.aspx" etc (this is actually dependent on the URLs entered in the web-site spider and indexer list - it is totally possible to index a currently live site from localhost, in which case this part is unnecessary).

Mapping from the URLs gained from the development server (eg localhost) to the deployment server is simple, the SearchResult control has a property "From URIPattern" which is used to specify the URL part specific to the development server, and a property "ToURIPattern" which is used to specify the URL part specific to the deployment server, at run-time the search result URLs are mapped according to these two properties.

Eg 1. A developer builds a web-site on http://localhost/internalApp/ and builds the search index - the search works fine on localhost, however when moving the app. to the live server the search results are linked to localhost. To correct this the developer maps the localhost URLs to the real server's, by setting:

FromURIPattern = "localhost/internalApp"
ToURIPattern = "ourcompanysinternalserver"

This causes URLs like
http://localhost/internalApp/products/product1.aspx
to be mapped to
http://ourcompanysinternalserver/products/product1.aspx

Eg 2. A developer builds a web-site on http://staging.ourdomain.com/ and builds the search index - the search works fine on the staging server, however when moving the app. to the live server the search results are linked to staging.ourdomain.com. To correct this the developer maps the staging.ourdomain.com URLs to the real server's, by setting:

FromURIPattern = "staging.ourdomain.com"
ToURIPattern = "www.ourdomain.com"

This causes URLs like
http://staging.ourdomain.com/default.aspx
to be mapped to
http://www.ourdomain.com/default.aspx

The properties FromURIPattern and ToURIPattern can also be overridden in the web.config, by adding "Keyoti-SearchEngine-FromURIPattern" and "Keyoti-SearchEngine-ToURIPattern" in the same manner as the IndexDirectory property.


SearchUnit Documentation: Search & Result Controls: How do I...: ...search with a simple form

Simplest

Below are some example use scenarios of the control, please refer to the API documentation for additional detail.

This example shows how to use the controls on a page, with no customization at all.

Example from "Example1_Simple", page with SearchBox

<%@ Page language="c#" AutoEventWireup="false" %>
<%@ Register TagPrefix="searchengine" Namespace="Keyoti.SearchEngine.Web"
Assembly="Keyoti2.SearchEngine.Web" %>
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" >
<HTML>

    <HEAD>
    </HEAD>
    <body MS_POSITIONING="GridLayout">
        <form id="Form1" method="post" runat="server">

            <SEARCHENGINE:SEARCHBOX id="SearchBox1"
                runat="server" ResultPageURL="SearchResults.aspx">
            </SEARCHENGINE:SEARCHBOX>
           </form>
    </body>
</HTML>

This simply holds the SearchBox page, it references the SearchResult page through it's ResultPageURL property.

Example from "Example1_Simple", page with SearchResult

<%@ Register TagPrefix="searchengine" Namespace="Keyoti.SearchEngine.Web"
Assembly="Keyoti2.SearchEngine.Web" %>
<%@ Page language="c#" AutoEventWireup="false" %>
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" >
<HTML>
    <body>
        <form id="Form1" method="post" runat="server">

            <searchengine:searchresult id="SearchResult1"
                runat="server" IndexDirectory="~/IndexDirectory">
            </searchengine:searchresult>

           </form>
    </body>
</HTML>

The SearchResult control will display the results for the query entered in the SearchBox page, the only configuration necessary is the IndexDirectory property - this property can be set in code behind, via the Server.MapPath property if desired. Of course, the index must be built before searches can be performed.


SearchUnit Documentation: Search & Result Controls: How do I...: ...customize layout (template usage)

Customizing Layout (Template Usage)

Total control over the appearance of the search results is provided through the template mechanism. SearchResult is a templated control, similar to "DataGrid" or "Repeater", it has a set of templates which can be defined to control layout and style.

HeaderTemplate

The block of Html before the search results can be defined in the header template, it's properties, which are accessed in standard fashion;

<%# Container.QueryExpression %>

NextPageLink
Link to the next page of results to be shown, typical usage is:
<%# Container.NextPageLink %>
Which will result in an anchor tag being shown on the page if not currently showing last page of results.

PreviousPageLink
As above, except for the previous page of results unless on first page.

NumberOfResults
The number of results found.

NumberOfResultsPerPage
The number of results per page, typically used in calculations, eg:
Showing results <%# ((Container.ResultsPage - 1)* Container.NumberOfResultsPerPage + 1) %> to <%# ((Container.ResultsPage - 1)* Container.NumberOfResultsPerPage) + Container.ResultsOnPage%>

QueryExpression
The expression that was search for.

ResultsOnPage
The number of results on the current page.

ResultsPage
The current page of results being shown.

IgnoredWordsMessage
The common words that were ignored.

FooterTemplate

The block of Html after the search results;

NextPageLink
Link to the next page of results to be shown, typical usage is: <%# Container.NextPageLink %> which will result in an anchor tag being shown on the page if not currently showing last page of results.

PreviousPageLink
As above, except for the previous page of results unless on first page.

NumberOfResults
The number of results found.

NumberOfResultsPerPage
The number of results per page, typically used in calculations, eg:
Showing results <%# ((Container.ResultsPage - 1)* Container.NumberOfResultsPerPage + 1) %> to <%# ((Container.ResultsPage - 1)* Container.NumberOfResultsPerPage) + Container.ResultsOnPage%>

QueryExpression
The expression that was search for.

ResultsPage
The current page of results being shown.

PageLinksBlock
A block of page number links, enabling the user to move directly to a result page.

ResultItemTemplate

Repeated for each result found, this is where the layout of the results can be defined.

Summary
The summary of the result document.

Title
The title of the result document.

Uri
The Uri/URL of the result document.

ResultPreview_Expander_ClosedUrl, ResultPreview_Expander_OpenedUrl, and UriAsStored
Used by the result previewer client side code, which is part of the default template.

CustomData
See the 'How To Work With Custom Data' section of the Help documentation.

NoResultsTemplate

Shown alone when there were no results found.

QueryExpression
The expression that was searched for.

IgnoredWordsMessage
The common words that were ignored.

ErrorMessageTemplate

Shown when there was a search error (from invalid user input).

Message
User friendly error message.

ExceptionMessage
The actual exception that occurred.

NoQueryTemplate

Shown alone when there was no QueryExpression.

SearchBox
Displayed when the page containing the SearchResult control is accessed directly without a search query.

Example From "Example2_CustomLayout"

...
<searchengine:searchresult id="SearchResult1" runat="server" HighlightQueryWordsInSummary="False" Width="915px"
    IndexDirectory="C:\inetpub\wwwroot\KeyotiSearchDemo_CSharp\IndexDirectory" SummaryWordLength="100">

    <ResultItemTemplate>
        <A href="<%# Container.Uri %>">
            <div onmouseover="highlight(this)" onmouseout="unhighlight(this)" class='SEResultItem'
                style="cursor: hand;" style='font-family: sans-serif,
Verdana, Arial, Helvetica; font-size:9pt; background-color:#E4FCE4; borderleft:
3px solid #15BD15;padding:6px;border-bottom:1px solid
#15BD15;padding:6px;'>
                <span class='SEResultItemLink' style='font-family:sansserif,
Verdana, Arial, Helvetica; font-size:11pt; font-weight:bold; '>
                    <%# Container.Title %>
                </span>
                <br>
                <span class='SEResultItemURL' style='font-family:sansserif,
Verdana, Arial, Helvetica; font-size:8pt; color: blue; paddingleft:
14px;'>
                    <%# Container.Uri %>
                </span>
                <br>
                <span class='SEResultItemSummary' style='fontfamily:
sans-serif, Verdana, Arial, Helvetica; font-size:10pt;margin-left:14px;'>
                    <%# Container.Summary%>
                </span>
                <br>
            </div>
        </A>
    </ResultItemTemplate>

    <HeaderTemplate>
        <div class='SEHeader' style='font-family: sans-serif, Verdana, Arial, Helvetica; font-size:12pt; background-color:#C2F8C2; border-top: 1px solid
#15BD15; border-left:3px solid #15BD15;border-right: 1px solid #15BD15;
padding:6px;border-bottom:1px solid #15BD15;padding:6px;'>
            You searched for '<%# Container.QueryExpression %>', there are
            <%# Container.NumberOfResults %>
            results. Showing results <%# ((Container.ResultsPage - 1)*
Container.NumberOfResultsPerPage + 1) %> to
            <%# ((Container.ResultsPage - 1)*
Container.NumberOfResultsPerPage) + Container.ResultsOnPage%>
        </div>
    </HeaderTemplate>

    <FooterTemplate>
        <div class='SEFooter' style='font-family: sans-serif, Verdana, Arial,
Helvetica; font-size:9pt; background-color:#C2F8C2; border-left:3px solid
#15BD15;border-right: 1px solid #15BD15; padding:6px;border-bottom:1px solid
#15BD15;padding:6px;'>
            <table border="0" cellpadding="0" cellspacing="3">
                <tr>
                    <td style='font-family: sans-serif, Verdana, Arial,
Helvetica; font-size:9pt;'>Results
                            Page:
                    </td>
                    <td style='font-family: sans-serif, Verdana, Arial,
Helvetica; font-size:9pt;'><%# Container.PreviousPageLink %></td>
                    <td style='font-family: sans-serif, Verdana, Arial,
Helvetica; font-size:9pt;'><%# Container.PageLinksBlock %></td>
                    <td style='font-family: sans-serif, Verdana, Arial,
Helvetica; font-size:9pt;'><%# Container.NextPageLink %></td>
                </tr>
            </table>
        </div>
    </FooterTemplate>

    <NoResultsTemplate>
        <div class='SENoResults' style='font-family: sans-serif, Verdana,
Arial, Helvetica; font-size:9pt; padding:4px;'>Sorry, no results were found for the query "<%#
Container.QueryExpression %>".</div>
    </NoResultsTemplate>

</searchengine:searchresult>

In this example the default error message will be used, as it has not been specified.


SearchUnit Documentation: Result Generation: How do I...: ...filter results

Show language: C# VB.NET Both

Filtering Results

Search results can be filtered by custom criteria (URL, custom data, title, filetype, etc) programmatically, via a simple event handler, or subclass.

Filtering With A Central Event Handler

By directly hooking into the Configuration.CentralEventDispatcher.Action event we can easily obtain the preliminary results of a search, which we can then filter, reorder etc.

The code below handles the "Action" event in the central event system. It processes "ResultItemsFinalized" notifications, and uses the event argument to access the preliminary results.

With The SearchResult Control

Eg. to filter any results that include the word "News" in the title, the following code is used in the code-behind of the form holding the SearchResult control.

C#
    protected void Page_Load(object sender, EventArgs e)
    {
        SearchResult1.FilterLoadLevel = Keyoti.SearchEngine.Search.FilterLoadLevel.Everything;
        SearchResult1.Configuration.CentralEventDispatcher.Action += new
        Keyoti.SearchEngine.Events.ActionEventHandler(CentralEventDispatcher_Action);
    }

    void CentralEventDispatcher_Action(object sender, Keyoti.SearchEngine.Events.ActionEventArgs e)
    {
        if (e.ActionData.Name == Keyoti.SearchEngine.Events.ActionName.ResultItemsFinalized)
        {
            Keyoti.SearchEngine.Utils.ResultItemList results =
                    e.ActionData.Data as Keyoti.SearchEngine.Utils.ResultItemList;
            for (int i = 0; i < results.Count; i++)
            {
                if (results[i].Title.Contains("News"))
                {
                    results.RemoveAt(i);
                    i--;//need to rerun over this element number.
                }
            }
        }
    }
VB
    Protected Sub Page_Load(ByVal sender As Object, ByVal e As EventArgs)

        SearchResult1.FilterLoadLevel = Keyoti.SearchEngine.Search.FilterLoadLevel.Everything
        AddHandler SearchResult1.Configuration.CentralEventDispatcher.Action, _
                            AddressOf Me.CentralEventDispatcher_Action

    End Sub

    Private Sub CentralEventDispatcher_Action(ByVal sender As Object, _
                            ByVal e As Keyoti.SearchEngine.Events.ActionEventArgs)

        If (e.ActionData.Name = Keyoti.SearchEngine.Events.ActionName.ResultItemsFinalized) Then

            Dim results As Keyoti.SearchEngine.Utils.ResultItemList = _
                CType(e.ActionData.Data,Keyoti.SearchEngine.Utils.ResultItemList)
            Dim i As Integer = 0

            Do While (i < results.Count)
                If results(i).Title.Contains("News") Then
                    results.RemoveAt(i)
                    i = (i - 1)
                    'need to rerun over this element number.
                End If
                i = (i + 1)
            Loop

        End If

    End Sub

With The SearchAgent Class

Eg. to filter any results that include the word "News" in the title, the following code is used in the class that uses SearchAgent

C#
    {
        ...
        SearchAgent agent = new SearchAgent(....);

        agent.FilterLoadLevel = Keyoti.SearchEngine.Search.FilterLoadLevel.Everything;
        agent.Configuration.CentralEventDispatcher.Action += new
        Keyoti.SearchEngine.Events.ActionEventHandler(CentralEventDispatcher_Action);
        ...
        agent.Search(....);
    }

    void CentralEventDispatcher_Action(object sender, Keyoti.SearchEngine.Events.ActionEventArgs e)
    {
        ...same as the example above for the SearchResult control...
    }
VB
    Sub ...

        ...
        Dim agent As New SearchAgent(....)
        agent.FilterLoadLevel = Keyoti.SearchEngine.Search.FilterLoadLevel.Everything
        AddHandler agent.Configuration.CentralEventDispatcher.Action, _
                            AddressOf Me.CentralEventDispatcher_Action

    End Sub

    Private Sub CentralEventDispatcher_Action(ByVal sender As Object, _
                            ByVal e As Keyoti.SearchEngine.Events.ActionEventArgs)

        ...same as the example above for the SearchResult control...
    End Sub

Notes

  • Due to the above code accessing the "Title" property of the result item, it was necessary to set:

        SearchResult1.FilterLoadLevel = Keyoti.SearchEngine.Search.FilterLoadLevel.Everything

    The FilterLoadLevel property specifies what amount of data will be loaded for the ResultItemsFinalized stage. It is important to note that the default setting of DocId is the fastest, since it minimizes what may be redundant data loading (assuming that most results are never seen by a user). If the Title was not used, but instead the Uri, or category properties, then the setting of DocIdUrlCategories could be used instead of Everything (which is more optimal).

  • The above code filters on the Title, but the Uri, or other properties can easily be used, for example the condition

         if (results[i].UriString.ToLower().EndsWith(".pdf"))

    filters PDF files.


SearchUnit Documentation: Search & Result Controls: How do I...: ...add FeaturedResults

Featured Results

Use the FeaturedResults control to easily promote important pages. The FeaturedResults control is independent in behavior from SearchResults, so any keywords can be hard-wired to featured documents. The control is templated, allowing complete customization of layout, see below.

Example Code

<SearchEngine:FeaturedResults id="FeaturedResults1" runat="server"
FeaturedDocuments="http://www.amazon.com/gp/product/0451527747|Buy Alice's
Adventures In Wonderland|Get this classic book now from Amazon|alice, adventure,
wonderland||http://www.amazon.com/gp/product/0141439491|Buy Gulliver's
Travels|The classic, Gulliver's Travels|gulliver, travels, adventure||http://
www.keyoti.com/support|Support Forum|Visit the Keyoti support forum|support,
help, question">
    <FeaturedHeaderTemplate>
        <div style='font-weight: bold;font-family: sans-serif, Verdana,
Arial, Helvetica; font-size:12pt; border-bottom: 1px solid #EEEEEE;
padding:3px;'>Featured results:</div>
        <br>
    </FeaturedHeaderTemplate>
    <FeaturedResultTemplate>
        <div><table border="0"> <tr>
            <td style='font-family:sans-serif, Verdana, Arial, Helvetica;
font-size:12pt;'>
        <A style='font-family:sans-serif, Verdana, Arial, Helvetica; fontsize:
12pt;' href="<%# Container.Uri %>" target="newWin"><%# Container.Title %></A>
            </td>
        </tr>
        <tr>
        <td style='font-family:sans-serif, Verdana, Arial, Helvetica; fontsize:
9pt; '><%# Container.Summary%></td>
        </tr>
    </table>
    </div>
    <br>
    </FeaturedResultTemplate>
    </SearchEngine:FeaturedResults>

In this example two templates are specified for the header and each result item (if they are not specified, default templates are used). The FeaturedDocuments property is easiest set through the Visual Studio property editor, and is persisted as; URL|Title|Summary|Keywords||URL2|.....


SearchUnit Documentation: Search & Result Controls: How do I...: ...use AutoComplete or ResultPreview

Auto-Complete & Result Preview

Auto-Complete

Example from "Example1_Simple", page with SearchBox

<%@ Reference Page="~/default.aspx" %>
<%@ Register TagPrefix="searchengine" Namespace="Keyoti.SearchEngine.Web" Assembly="Keyoti2.SearchEngine.Web" %>
<%@ Page language="c#" %>
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" >
<html>
    <head>
    </head>
    <body>
        <form id="Form1" method="post" runat="server">

            <searchengine:searchbox id="SearchBox1" runat="server" ResultPageURL="SearchResults.aspx"
            AutoCompleteQuery="true" AutoCompleteQueryShowNumberOfResults="false"
            AutoCompleteIndexDirectory="~/IndexDirectory">

            </searchengine:searchbox>

        </form>

    </body>
</html>

AutoCompleteQuery is set to true, allowing available search terms to be shown as the user types in the SearchBox, The AutoCompleteIndexDirectory property is set to the path (relative URL or absolute file path) of the index directory.

Example on customizing the suggestions

Result Preview

Example from "Example1_Simple", page with SearchResult

The 'preview' icon/expander part of the template is highlighted in blue.

<%@ Register TagPrefix="searchengine" Namespace="Keyoti.SearchEngine.Web" Assembly="Keyoti2.SearchEngine.Web" %>
<%@ Page language="c#" %>
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" >
<html>
    <head>
    </head>
    <body>
        <form id="Form1" method="post" runat="server">
            <searchengine:searchresult id="SearchResult1" runat="server"
                Width="913px" HighlightQueryWordsInSummary="True" IndexDirectory="~/IndexDirectory"
                ResultPreviewerEnabled="True">

                <ResultItemTemplate>
                    <div class='SEResultItem'>
                        <table border="0">
                            <tr>
                                <td class='SEResultItemLink' style='font-family: sans-serif, Verdana, Arial, Helvetica;
                                    font-size: 10pt;'>
                                    <a href="<%# Container.Uri %>">
                                        <%# Container.Title %>
                                    </a>
                                </td>
                            </tr>
                            <tr>
                                <td class='SEResultItemSummary' style='font-family: sans-serif, Verdana, Arial, Helvetica;
                                    font-size: 9pt;'>
                                    <%# Container.Summary%>
                                    <span class='sew_previewResultWrapper'>...<img alt="Click to preview the document text"
                                        onclick="sew_toggleResultPreview(this, '<%# Container.UriAsStored %>',
                    '<%# Container.ResultPreview_Expander_ClosedUrl %>', '<%# Container.ResultPreview_Expander_OpenedUrl %>')"
                                        src="<%# Container.ResultPreview_Expander_ClosedUrl %>" /><span class='sew_previewResultContent'>Loading
                                            document...</span></span></td>
                            </tr>
                            <tr>
                                <td class='SEResultItemURL' style='font-family: sans-serif, Verdana, Arial, Helvetica;
                                    font-size: 8pt; color: green;'>
                                    <%# Container.Uri %>
                                </td>
                            </tr>
                            <tr>
                                <td class='SELocation' style='font-family: sans-serif, Verdana, Arial, Helvetica;
                                    font-size: 8pt; color: gray;'>
                                    <%# Container.Location %>
                                </td>
                            </tr>
                            <tr>
                                <td class='SEContent' style='font-family: sans-serif, Verdana, Arial, Helvetica;
                                    font-size: 8pt; color: gray;'>
                                    <%# Container.Content %>
                                </td>
                            </tr>
                        </table>
                    </div>
                    <br>
                </ResultItemTemplate>

            </searchengine:searchresult>

            </form>
    </body>
</html>

ResultPreviewerEnabled is set to true, allowing the user to see preview of a search result without having to leave the results page.

Example on customizing the previewed text


SearchUnit Documentation: How do I...: ...provide spelling suggestions (did you mean?)

Show language: C# VB.NET Both

Below are some example use scenarios of the controls, please refer to the API documentation for additional detail.

SearchSuggestions (Did you mean?)

Pro only

This example shows how to use the multi-lingual spelling control on the page holding the SearchResult control. In the code below, the Text property controls the MessageLabel text, the CustomDictionaryPath is an optional way to specify the text file to be used as a custom word list (see below), the SuggestedLink is a Hyperlink control (with all the same available properties as a Hyperlink control) and the MessageLabel is a Label control (again, all properties of Label are available).

Obtaining Non English Dictionaries

By default a US & UK English dictionary is used for spelling suggestions, however alternative dictionaries can be used by setting the Language property in the SearchSuggestions control. The Language property may be set to values in the Keyoti.SearchEngine.Suggestions.LanguageType enum (eg. Danish, Dutch, English, EnglishAustralia, EnglishCanada, EnglishMedical , EnglishUK, EnglishUS, French, German, Italian, Norwegian, Polish, Portuguese, Spanish, SpanishLatinAmerica, Swedish, Russian).

Download and unzip the .dict file(s) required and place it in a folder under the Index Directory called "Dictionaries" (creating if need be). For example - myApp\IndexDirectory\Dictionaries\DICT-DE-DE-German_SE.dict. The dictionary files must not be renamed, as their language is determined from the filename.

Please download the language pack here.
Example Code (Must Be Used On A Page Containing The SearchResult Control)
<SearchEngine:SearchSuggestions id=SearchSuggestions1 runat="server" Language="German" >
    <SuggestedLink Font-Italic="True">suggestedExpression</SuggestedLink>
    <MessageLabel Font-Bold="True"></MessageLabel>
</SearchEngine:SearchSuggestions>

Custom Dictionary Wordlists

It is common for web-sites and users to use words that are not in the standard dictionary, typically this includes organizational names, acronyms and jargon. To avoid having these terms queried to the user on searches, add them to a text file (eg. "custom_dictionary.txt" in the above) and place that file on the server. When CustomDictionaryPath specifies a valid file (relative paths are not relative to the app. dir unless MapPath is used) the terms used in the text file will supplement the dictionary, both for known words and for suggestions. It is recommended that all legal forms of the word are added and added in lowercase, eg;

keyoti

keyoti's

rapidspell

Example Code (Must Be Used On A Page Containing The SearchResult Control)
<SearchEngine:SearchSuggestions id=SearchSuggestions1 runat="server"
CustomDictionaryPath='<%# MapPath("custom_dictionary.txt") %>' Text="Did you mean? ">
    <SuggestedLink Font-Italic="True">suggestedExpression</SuggestedLink>
    <MessageLabel Font-Bold="True"></MessageLabel>
</SearchEngine:SearchSuggestions>

How To Customize The Suggestions

To customize the spelling suggestions provided by the SearchSuggestions control, we handle the OnFoundSpellingError event:

<SearchEnginePro:SearchSuggestions ID="SS" runat="server" SpellingSuggestionSource="PresetDictionary" OnFoundSpellingError="SS_FoundSpellingError" />

and in the code behind we work with the event arguments to customize the suggestions as we choose;

C#
protected void SS_FoundSpellingError(object sender, Keyoti.SearchEngine.Web.FoundSpellingErrorEventArgs e)

{

    //Obtain the misspelled word if we need it.

    string badWord = e.Word;

    //Obtain the suggestions provided by the control

    ArrayList spellingSuggestions = e.Suggestions;

    //Use whatever logic we choose to change the top suggestion. In this case it's always "CUSTOM"

    spellingSuggestions.Insert(0, "CUSTOM");

}
VB.NET
Protected Sub SS_FoundSpellingError(ByVal sender As Object, ByVal e As Keyoti.SearchEngine.Web.FoundSpellingErrorEventArgs)

    'Obtain the misspelled word if we need it.

    Dim badWord As String = e.Word

    'Obtain the suggestions provided by the control

    Dim spellingSuggestions As ArrayList = e.Suggestions

    'Use whatever logic we choose to change the top suggestion. In this case it's always "CUSTOM"

    spellingSuggestions.Insert(0, "CUSTOM")

End Sub

Programmatically Getting Spelling Corrections

To obtain a spelling corrected search expression programmatically, use the following code, and ensure that the following DLLs are referenced (in addition to the usual)

Keyoti2.SearchEngine.Suggestions.dll
Keyoti2.SearchEngine.SuggestionsDictionary.dll
Keyoti2.SearchEnginePro.Web.dll

Example Code

string originalQueryString = "testt query";  //put the query here

Keyoti.SearchEngine.Configuration conf = new Keyoti.SearchEngine.Configuration();

Keyoti.SearchEngine.Search.GroupElement testGroup = new Keyoti.SearchEngine.Search.GroupElement(originalQueryString, conf);

Keyoti.SearchEngine.Suggestions.SearchSuggestionsModel model = new Keyoti.SearchEngine.Suggestions.SearchSuggestionsModel();

//to use a different .dict file (e.g. for non English languages) pass the path in the first argument instead of 'null'.

string suggestedQuery = model.BuildSuggestedExpression(null, null, Keyoti.SearchEngine.Suggestions.LanguageType.English, Keyoti.SearchEngine.Suggestions.SpellingSuggestionSource.PresetDictionary, conf, 0, testGroup, originalQueryString);


SearchUnit Documentation: How do I...: ...provide location or content category choosers (Simple Usage)

SearchBoxOptions (Simple Usage)

Pro only

The SearchBoxOptions control provides a readily useable (although less flexible than the following example) way to add content and/or location category search options to the page. This control is designed to be used on the same page as the SearchBox control, however for an example showing result page switching of categories, please see the demo projects.

Example Code

<SearchEngine:SearchBoxOptions id="Searchboxoptions1" runat="server"
    SearchBoxId="SearchBox1"
    Contents="Books,Stationary,Messages"
    Locations="All,Community">
    <ContentCheckBoxes ForeColor="Gray">
        <CheckBoxesFont Size="10pt" Overline="False" Underline="False" Italic="False" Name="Arial" Bold="False" Strikeout="False"></CheckBoxesFont>
    </ContentCheckBoxes>
    <LocationDropDownList Font-Bold="True"></LocationDropDownList>

</SearchEngine:SearchBoxOptions>

The SearchBoxId property points to the ID of the SearchBox control (which must be on the page), through this the options are attached to the request. The ContentCheckBoxes control is similar to the CheckBoxList control and allows style to be specified for the content category checkboxes. The LocationDropDownList property is a DropDownList control, and again allows appearance to be specified. It is not necessary to specify both content and locations, if either are omitted, the corresponding control is not shown.

Automatic Setup

By default any Location and Content categories setup for the Index Directory will automatically be used to create the search options.

AutoGenerateFromIndexDirectory should be set to the Index Directory to be used to create the category options. AutoGenerateContentCheckBoxes and AutoGenerateLocationDropDown can each be set True or False depending on which options to display.

Manual Setup

To setup the search options manually, set AutoGenerateContentCheckBoxes and/or AutoGenerateLocationDropDown properties to False and add the options to be used to the Contents and Locations properties. These are comma delimited lists of available content and location categories and must match the names stored in the index exactly..


SearchUnit Documentation: How do I...: ...provide location or content category choosers (flexible)

Content & Location User Control (Flexible Usage)

Pro only

SearchBoxOptions is simple to use, but there are many ways that these options can be presented, and many possible requirements for operational logic that can be applied. The following is a User Control (presented in both languages in the demo project) that shows the necessary requirements for integration with the SearchBox control (basically the only requirement is that SearchOptions property in SearchBox is set when the User Control loads).

Example Code (ASCX)

<%@ Control Language="c#" AutoEventWireup="false"
Codebehind="SearchOptionsUC.ascx.cs" Inherits="Test.SearchOptionsUC"
TargetSchema="http://schemas.microsoft.com/intellisense/ie5" %>

<asp:Label id="Label1" runat="server" Font-Bold="True">Search which location?</
asp:Label>

<asp:radiobuttonlist id="RadioButtonList1" runat="server"
RepeatDirection="Horizontal">
    <asp:ListItem Value="All" Selected="True">All</asp:ListItem>
    <asp:ListItem Value="Community">Community</asp:ListItem>
</asp:radiobuttonlist>

<asp:Label id="Label2" runat="server" Font-Bold="True">In which categories?</
asp:Label>

<asp:checkboxlist id="CheckBoxList1" runat="server">
    <asp:ListItem Value="Books" Selected="True">Books</asp:ListItem>
    <asp:ListItem Value="Fiction">Fiction</asp:ListItem>
    <asp:ListItem Value="Nonfiction">Nonfiction</asp:ListItem>
    <asp:ListItem Value="Stationary" Selected="True">Stationary</asp:ListItem>
    <asp:ListItem Value="Messages">Messages</asp:ListItem>
</asp:checkboxlist>

This code simply presents the user with options for choosing location and content categories; note that names of existing content and location categories from the index have been used.

Example Code (ASCX Codebehind)

namespace Test
{
    using System;
    using System.Data;
    using System.Drawing;
    using System.Web;
    using System.Web.UI.WebControls;
    using System.Web.UI.HtmlControls;
    using System.Collections;
    using System.ComponentModel;
    using System.Web.UI;
    using Keyoti.SearchEngine.Search;
    using Keyoti.SearchEngine.Web;
    public class SearchOptionsUC : System.Web.UI.UserControl
    {
        string location;
        string[] contents;

        protected System.Web.UI.WebControls.RadioButtonList RadioButtonList1;
        protected System.Web.UI.WebControls.Label Label1;
        protected System.Web.UI.WebControls.Label Label2;
        protected System.Web.UI.WebControls.CheckBoxList CheckBoxList1;

        private void Page_Load(object sender, System.EventArgs e)
        {

            //find the SearchBox control
            Control c = FindRecursive( Page.Controls );
            //if we couldn't find one, throw exception
            if( c==null )
                throw new Exception("A SearchBox Control "+
                "could not be found on the Form, please add one.");
            else
            {
                //if SearchBox found, set its SearchOptions
                //accordingly with the location/content from
                //the controls
                location = RadioButtonList1.SelectedItem.ToString();

                  //need to pass an array of strings to SearchBox
                //for the content options.
                //So find selected contents and convert to an array
                  ArrayList temporary = new ArrayList();
                  foreach( ListItem item in CheckBoxList1.Items)
                      if( item.Selected )
                        temporary.Add(item.Value);

                  contents = (string[]) temporary.ToArray(typeof
(System.String));

                  //finally set SearchOption property in SearchBox
                ((SearchBox)c).SearchOptions = new
SearchOptions(location, contents);
                  }
            }

        /// <summary>
        /// Finds a SearchBox control in controlsToFindIn
       /// </summary>
        Control FindRecursive(ControlCollection controlsToFindIn)
        {
            Control found = null;
            foreach(Control crt in controlsToFindIn)
            {
                if (found==null)
                {
                    if(crt is Keyoti.SearchEngine.Web.SearchBox)
                        found = crt;
                    else found = FindRecursive(crt.Controls);
                }
            }
            return found;
        }

        #region Web Form Designer generated code
        override protected void OnInit(EventArgs e)
        {
            //
            // CODEGEN: This call is required by the ASP.NET Web Form Designer.
            //
            InitializeComponent();
            base.OnInit(e);
        }

        /// <summary>
        /// Required method for Designer support - do not modify
        /// the contents of this method with the code editor.
        /// </summary>
        private void InitializeComponent()
        {
            this.Load += new System.EventHandler(this.Page_Load);
        }
        #endregion
    }
}

The Page_Load method of the User Control is where the required action is performed; The SearchBox.SearchOptions property is set with the exact names of content and location categories as specified in the index.


SearchUnit Documentation: Search & Result Controls: How do I...: ...customize the AutoComplete

Show language: C# VB.NET Both

AutoComplete Customization

The AutoComplete feature of SearchBox can be customized through the use of a plug-in, or with Javascript on the client side.

Plug-in (Server Side)

AutoComplete Settings

For maximum efficiency plug-in DLLs are not loaded unless SearchBox.AutoCompleteQueryLoadPlugin is set "true". Set this property in the ASPX or codebehind for the page which uses SearchBox, in order to be able to modify the autocomplete suggestions.

Creating The Plug-in

A Plug-in project can quickly be generated from the 'Plug-ins' tab in the Index Management Tool, in the project you will find code which handles the AutoCompleteSuggestionsGenerated event. For more information on plug-ins, see the overview of the Central Event System in general.

A plug-in class will subscribe to the Action event and process ActionName.AutoCompleteSuggestionsGenerated. The associated ActionData.Data is of type ArrayList, and contains a list of SearchBoxAutoCompleteHelper.SuggestionResultPair objects. The original text entered by the user is accessible through 'sender' (see below)

C#
private void CentralEventDispatcher_Action(object sender, Keyoti.SearchEngine.Events.ActionEventArgs e)
{
    if(e.ActionData.Name== ActionName.AutoCompleteSuggestionsGenerated)
    {
        ArrayList suggestionPairs = e.ActionData.Data as ArrayList;
        Keyoti.SearchEngine.Web.SearchBoxAutoCompleteHelper helper =
            sender as Keyoti.SearchEngine.Web.SearchBoxAutoCompleteHelper;
        string textEnteredByUser = helper.Query;
        string[] wordsInText = helper.Segments;
        suggestionPairs.Add(new
            Keyoti.SearchEngine.Web.SearchBoxAutoCompleteHelper.SuggestionResultPair("testQuery", 99));
    }
}
VB.NET
Private Sub CentralEventDispatcher_Action(ByVal sender As Object,_
                    ByVal e As Keyoti.SearchEngine.Events.ActionEventArgs)
    If (e.ActionData.Name = ActionName.AutoCompleteSuggestionsGenerated) Then
         Dim suggestionPairs As ArrayList = CType(e.ActionData.Data,ArrayList)
         Dim helper As Keyoti.SearchEngine.Web.SearchBoxAutoCompleteHelper = _
            CType(sender,Keyoti.SearchEngine.Web.SearchBoxAutoCompleteHelper)
         Dim textEnteredByUser As String = helper.Query
         Dim wordsInText() As String = helper.Segments
         suggestionPairs.Add(New _
            Keyoti.SearchEngine.Web.SearchBoxAutoCompleteHelper.SuggestionResultPair("testQuery", 99))
     End If
End Sub

In this example the suggestionPairs list is modified with a new suggestion 'testQuery' added to the end. The list can be cleared, or items removed too. Use 'textEnteredByUser' or 'wordsInText' to determine what the user has typed.

Javascript (Client Side)

On the page with the SearchBox, add a function called sew_OnAutoCompleteSuggestionsGenerated, this will be automatically called by the autocomplete engine when suggestions are generated, allowing for modification of the suggestion list or items in the list.

Javascript
function sew_OnAutoCompleteSuggestionsGenerated(query, suggestions) {

    //how to iterate the generated suggestions
    for (var i = 0; i < suggestions.length; i++) {
        var suggestionText = suggestions[i][0];
        //# of results, will be -1 if AutoCompleteQueryShowNumberOfResults==false
        var suggestionNumberOfResults = suggestions[i][1];

        //modify the text?
        suggestions[i][0] = suggestions[i][0] + "*"; //turn each suggestion into a wildcard
    }
    //add a bonus suggestion, with '10' predicted results
    suggestions[suggestions.length]=["bonus", 10];
}


SearchUnit Documentation: Search & Result Controls: How do I...: ...customize ResultPreview

Show language: C# VB.NET Both

ResultPreview Customization

The ResultPreview feature of SearchResult can be customized through the use of a plug-in, or with Javascript on the client side.

Plug-in (Server Side)

ResultPreview Settings

For maximum efficiency plug-in DLLs are not loaded unless SearchResult.ResultPreviewerLoadPlugin is set "true". Set this property in the ASPX or codebehind for the page which uses SearchResult, in order to be able to modify the preview text.

Creating The Plug-in

A Plug-in project can quickly be generated from the 'Plug-ins' tab in the Index Management Tool, in the project you will find code which handles the ResultPreviewTextLoaded event. For more information on plug-ins, see the overview of the Central Event System in general.

A plug-in class will subscribe to the Action event and process ActionName.ResultPreviewTextLoaded. The associated ActionData.Data is of type StringBuilder, and contains the document text, which may be modified. The document Uri is accessible through 'sender' (see below)

C#
private void CentralEventDispatcher_Action(object sender, Keyoti.SearchEngine.Events.ActionEventArgs e)
{
    if(e.ActionData.Name== ActionName.ResultPreviewTextLoaded)
    {
        StringBuilder documentPreviewText = e.ActionData.Data as StringBuilder;
        string uri = (sender as Keyoti.SearchEngine.Web.SearchResultPreviewHelper).Uri;
        //Change the document text, to put the Uri at the start of the text.
        //Remember that if you reassign documentPreviewText to a new object,
        //it will not be used by the previewer.
        documentPreviewText.Insert(0, "Document URL::" + uri + "\r\n\r\n");
    }
}
VB.NET
Private Sub CentralEventDispatcher_Action(ByVal sender As Object,_
                    ByVal e As Keyoti.SearchEngine.Events.ActionEventArgs)
    If (e.ActionData.Name = ActionName.ResultPreviewTextLoaded) Then
        Dim documentPreviewText As StringBuilder = CType(e.ActionData.Data,StringBuilder)
        Dim uri As String = CType(sender,Keyoti.SearchEngine.Web.SearchResultPreviewHelper).Uri
        'Change the document text, to put the Uri at the start of the text.
        'Remember that if you reassign documentPreviewText to a new object,
        'it will not be used by the previewer.
        documentPreviewText.Insert(0, ("Document URL::"  + (uri + ""& vbCrLf& vbCrLf)))
    End If
End Sub

In this example the document text is modified to include the Uri at the start. The documentPreviewText is a StringBuilder and can be modified with any of its methods.

Javascript (Client Side)

On the page with the SearchResult control, add a function called sew_OnResultPreviewTextLoaded, this will be automatically called by the result preview engine when the text is about to be shown, allowing for modification of the text.

Javascript
function sew_OnResultPreviewTextLoaded(url, text, button, closedImgURL, openedImgURL) {
    //url - document URL
    //text - document text to be shown to user
    //button - instance of the HTML element that the user clicked (could be an img)
    //closedImgURL, openedImgURL - the URLs specified for the button states

    //Let's put the doc URL at the end of the text
    return text + "\r\n\r\n" + url;
}

Note that the modified text is returned, rather than set in the 'text' variable.


SearchUnit Documentation: Result Generation: How do I...: ...use CustomData for date sorting

Show language: C# VB.NET Both

Adding CustomData to a Document

Please first see How to add CustomData to a document

Processing CustomData In A Search

The custom data can be presented to the user easily through;

-Web Controls: Keyoti.SearchEngine.Web.ResultItem.CustomData or <%# Container.CustomData %> in the ResultItem template

-SearchAgent: Keyoti.SearchEngine.Search.ResultItem.DocumentRecord.CustomData for programmatic searches

For example, in the ResultItem template, to show the custom data as-is.

<ResultItemTemplate>

...other elements such as the title...

<%# Container.CustomData %>

...

</ResultItemTemplate>

Furthermore, to perform processing on the data before presenting it to the user, in a Web context with the SearchResult control, the ItemCreated event can be handled

For example, if CustomData holds a date string, it can be processed like this;

C#
protected void Sr1_ItemCreated(object sender, Keyoti.SearchEngine.Web.SearchResultItemEventArgs e)

{

    if (e.Item is Keyoti.SearchEngine.Web.ResultItem){

        Label dateLabel = e.Item.FindControl("dateLabel") as Label;

        if (dateLabel != null){

            try {

                DateTime docDate = DateTime.Parse((e.Data as Keyoti.SearchEngine.Search.ResultItem).DocumentRecord.CustomData);

                dateLabel.Text = docDate.ToLongDateString();

            }

            catch (FormatException){

                //wasn't a date

            }

        }

    }

}
VB.NET
Protected Sub Sr1_ItemCreated(ByVal sender As Object, ByVal e As Keyoti.SearchEngine.Web.SearchResultItemEventArgs) Handles SearchResult1.ItemCreated

        If (TypeOf e.Item Is Keyoti.SearchEngine.Web.ResultItem) Then
            Dim dateLabel As Label = CType(e.Item.FindControl("dateLabel"), Label)
            If (Not (dateLabel) Is Nothing) Then
                Try
                    Dim docDate As DateTime = DateTime.Parse(CType(e.Data, Keyoti.SearchEngine.Search.ResultItem).DocumentRecord.CustomData)
                    dateLabel.Text = docDate.ToLongDateString
                Catch ex As FormatException
                    'wasn't a date
                End Try
            End If
        End If
    End Sub

Which will look for a Label control with the ID "dateLabel" (which should be added to the ResultItem template) and set it's Text to a formatted date.

Adding Result Sorting

Custom data (and use of dates for example) leads to the question of custom sorting, since it may be desirable to sort the results according to the additional data held. This is relatively simple through the Central Event System.

In this example it is assumed that the CustomData is either a date string (yyyy/mm/dd) or an empty string (which means that documents with dates will be handled as well as documents without). Two buttons will be added to allow the user to sort by date ascending or descending, instead of the standard keyword relevance sorting.

1. Two buttons are added to the HeaderTemplate

<asp:Button ID="sortDownBT" runat="server" OnClick="sortDownBT_Click" Text="Sort By Date (Newest)" />

<asp:Button ID="sortUpBT" runat="server" OnClick="sortUpBT_Click" Text="Sort By Date (Oldest)" />

2. Variables are added to the code-behind for the sorting

C#
bool sortByDate = false;

SortDirection sortDirection = SortDirection.Descending;
VB.NET
Dim sortByDate As Boolean = False

Dim sortDirection As SortDirection = SortDirection.Descending

3. The button Click handlers are added to the code-behind, which set the sort variables and also tell the SearchResult control ("Sr1") to regenerate it's search results after the post-back

C#
protected void sortDownBT_Click(object sender, EventArgs e)

{

    sortByDate = true;

    sortDirection = SortDirection.Descending;

    Sr1.InvalidateChildControlHierarchy();

}

protected void sortUpBT_Click(object sender, EventArgs e)

{

    sortByDate = true;

    sortDirection = SortDirection.Ascending ;

    Sr1.InvalidateChildControlHierarchy();

}
VB.NET
Protected Sub sortDownBT_Click(ByVal sender As Object, ByVal e As System.EventArgs)

        sortByDate = True

        sortDirection = sortDirection.Descending

        Sr1.InvalidateChildControlHierarchy()

End Sub

Protected Sub sortUpBT_Click(ByVal sender As Object, ByVal e As EventArgs)

        sortByDate = True

        sortDirection = sortDirection.Ascending

        Sr1.InvalidateChildControlHierarchy()

End Sub

4. In the Page_Load handler, the Central Event System's "Action" event is hooked up, and filter load level set to include custom data.

C#
protected void Page_Load(object sender, EventArgs e)
{
    Sr1.FilterLoadLevel = Keyoti.SearchEngine.Search.FilterLoadLevel.Everything;
    Sr1.Configuration.CentralEventDispatcher.Action += new Keyoti.SearchEngine.Events.ActionEventHandler(CentralEventDispatcher_Action);

}
VB.NET
Protected Sub Page_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles Me.Load

    Sr1.FilterLoadLevel = Keyoti.SearchEngine.Search.FilterLoadLevel.Everything
    AddHandler (Sr1.Configuration.CentralEventDispatcher.Action), AddressOf CentralEventDispatcher_Action

End Sub

5. And CentralEventDispatcher_Action is added, which will call for the sorting to be done at the appropriate time

C#
void CentralEventDispatcher_Action(object sender, Keyoti.SearchEngine.Events.ActionEventArgs e)

{

    if (sortByDate && e.ActionData.Name == Keyoti.SearchEngine.Events.ActionName.ResultItemsFinalized)

    {

        Keyoti.SearchEngine.Utils.ResultItemList resultItems = e.ActionData.Data as Keyoti.SearchEngine.Utils.ResultItemList;

        resultItems.Sort(new DocumentDateComparer(sortDirection));

    }

}
VB.NET
Private Sub CentralEventDispatcher_Action(ByVal sender As Object, ByVal e As Keyoti.SearchEngine.Events.ActionEventArgs)

        If (sortByDate _

                    AndAlso (e.ActionData.Name = Keyoti.SearchEngine.Events.ActionName.ResultItemsFinalized)) Then

            Dim resultItems As Keyoti.SearchEngine.Utils.ResultItemList = CType(e.ActionData.Data, Keyoti.SearchEngine.Utils.ResultItemList)

            resultItems.Sort(New DocumentDateComparer(sortDirection))

        End If

End Sub

The 'if' is satisfied when date sorting is enabled and the engine signals that the results are finalized. At this point the results are sorted by relevance, so the DocumentDateComparer is used to re-sort the results by date. The comparer class is fairly long because it handles documents with and without dates, as well as any formatting errors in the date strings.

C#
class DocumentDateComparer : IComparer<Keyoti.SearchEngine.Search.ResultItem>
//NOTE: .NET1 users, the above line should be "class DocumentDateComparer : IComparer"
{

    SortDirection sortDirection;

    public DocumentDateComparer(SortDirection sortDirection)

    {

        this.sortDirection = sortDirection;

    }

    public int Compare(Keyoti.SearchEngine.Search.ResultItem x, Keyoti.SearchEngine.Search.ResultItem y)
//NOTE: .NET1 users, the above line should be "public int Compare(object x, object y)"
    {

        string xData = (x as Keyoti.SearchEngine.Search.ResultItem).DocumentRecord.CustomData;

        string yData = (y as Keyoti.SearchEngine.Search.ResultItem).DocumentRecord.CustomData;

        if(xData.Length==0 && yData.Length>0) return 1;

        if(yData.Length==0 && xData.Length>0) return -1;

        if(xData.Length==0 && yData.Length==0)return 0;

        DateTime xDate, yDate;

        try

        {

            xDate = DateTime.Parse(xData);

        }

        catch (FormatException)

        {

            //not a date, so make it historic so that it ends up lower in the sort order

            xDate = DateTime.MinValue;

        }

        try

        {

            yDate = DateTime.Parse(yData);

        }

        catch (FormatException)

        {

            //not a date, so make it historic so that it ends up lower in the sort order

            yDate = DateTime.MinValue;

        }

        if(sortDirection == SortDirection.Descending)

            return yDate.CompareTo(xDate);

        else

            return xDate.CompareTo(yDate);

        }

}
VB.NET
Class DocumentDateComparer
    Implements IComparer(Of Keyoti.SearchEngine.Search.ResultItem)
     'NOTE: .NET1 users, above line should be "Implements IComparer"

    Private sortDirection As SortDirection

    Public Sub New(ByVal sortDirection As SortDirection)

        MyBase.New()

        Me.sortDirection = sortDirection

    End Sub

    Public Function Compare(x As Keyoti.SearchEngine.Search.ResultItem, y As Keyoti.SearchEngine.Search.ResultItem) _
        As Integer Implements IComparer(of Keyoti.SearchEngine.Search.ResultItem).Compare
     'NOTE: .NET1 users, above line should be Public Function Compare(ByVal x As Object, ByVal y As Object) _
      '		As Integer Implements IComparer.Compare"
        Dim xData As String = CType(x, Keyoti.SearchEngine.Search.ResultItem).DocumentRecord.CustomData

        Dim yData As String = CType(y, Keyoti.SearchEngine.Search.ResultItem).DocumentRecord.CustomData

        If ((xData.Length = 0) _

                    AndAlso (yData.Length > 0)) Then

            Return 1

        End If

        If ((yData.Length = 0) _

                    AndAlso (xData.Length > 0)) Then

            Return -1

        End If

        If ((xData.Length = 0) _

                    AndAlso (yData.Length = 0)) Then

            Return 0

        End If

        Dim yDate As DateTime

        Dim xDate As DateTime

        Try

            xDate = DateTime.Parse(xData)

        Catch ex As FormatException

            'not a date, so make it historic so that it ends up lower in the sort order

            xDate = DateTime.MinValue

        End Try

        Try

            yDate = DateTime.Parse(yData)

        Catch ex As FormatException

            'not a date, so make it historic so that it ends up lower in the sort order

            yDate = DateTime.MinValue

        End Try

        If (sortDirection = sortDirection.Descending) Then

            Return yDate.CompareTo(xDate)

        Else

            Return xDate.CompareTo(yDate)

        End If

    End Function

End Class


SearchUnit Documentation: How do I...: ...create a SharePoint Web Part

How to Add SearchUnit to SharePoint

This example shows the simplest steps required to add SearchUnit to your SharePoint site using Visual Studio 2010.

Currently there is a known issue with the design time support when creating a Visual Web Part project for SharePoint however working with the ASPX directly, as explained below, is very straightforward.

1. Create a SharePoint Visual Web Part project.
  1. From Visual Studio select New Project > SharePoint > Visual Web Part project, enter the project name and click OK. Select the instance of SharePoint to use for debugging and click Finish.

  2. Open your project's .ascx page designer and drag the SearchResult control to the page.

    (If the SearchUnit controls are not in the ToolBox already, they can be added by manually navigating to the product DLL and dragging 'Keyoti2.SearchEngine.Web.dll' to the toolbox).

  3. Create a folder to store the Index Directory files. This folder will need to be accessible to all SharePoint users that have access to the page containing the search control. e.g. C:\inetpub\wwwroot\wss\VirtualDirectories\7803\IndexDirectory

  4. Set the IndexDirectory property of the SearchResult control, to the path of the IndexDirectory created above. This will need to be set in code;

2. Creating your Index
  1. Navigate to your 'SearchUnit' installation folder

    (Typically under C:\Program Files (x86)\Keyoti Inc\SearchUnit)

    Open the folder containing the DLL's for your .Net Framework version and open 'Keyoti Search Index Manager Tool Launcher'.

  2. Enter the path to your Index Directory folder and click Open.

    e.g. C:\inetpub\wwwroot\wss\VirtualDirectories\7803\IndexDirectory

    The Configuration file for your Index Directory will need to be changed to allow the crawler to access a SharePoint site using IIS authentication. Click the Configuration tab and find the 'WebsiteCredentials' section.

    Enter the path to your SharePoint site followed by the username and password for a user that has access to the parts of the site you want to be searchable (Administrator for example).

  3. To begin importing your SharePoint site select the Indexed Sources tab and click 'Import New Source'. Set the Start URL to the path of your SharePoint site e.g. http://win-bqdrfp492op:7803/int/default.aspx

    Under 'More Options' you can specify path matches that should be ignored during the import (admin only sections for example) and/or set only those path matches to be included in the import. E.g. "/_" was ignored so all paths containing "/_" will not be indexed.

    Once you have the desired settings close the form and click 'Import' to begin indexing your SharePoint site.

3. Deploying your Visual Web Part project.
  1. In your Visual Web Part project select 'Build' and 'Deploy Solution'.

  2. Navigate to your SharePoint site and select 'Edit Page' then 'Add a Web Part'. Under Categories select your project and click 'Add'.

Try a test search. Should you have any trouble please email support at keyoti.com

AJAX Features (AutoComplete & ResultPreviewer)

When enabling the Auto Complete or Result Previewer features you will need to add a httphandler in IIS;

  1. Open IIS 7 and select the SharePoint site
  2. Open Handler mappings
  3. Click Add Managed Handler
  4. For 'Request Path' enter; Keyoti.SearchEngine.Web.CallBackHandler.ashx
  5. For 'Type' enter; Keyoti.SearchEngine.Web.CallBackHandler, Keyoti2.SearchEngine.Web, Version=2012.?.?.?, Culture=neutral, PublicKeyToken=58d9fd2e9ec4dc0e
    (where 2012.?.?.? should be replaced with the version number of the Keyotix.SearchEngine.Web DLL)
  6. For 'Name' enter; Keyoti AJAX
  7. Restart IIS


SearchUnit Documentation: How do I...: ...get query term analytics with Google Analytics

Setup Site Search for Google Analytics

Overview

'Site Search' can be setup witin Google Analytics to track your user's search activity while using SearchUnit. You should already have the Analtyics tracking code installed on all relevant pages before following this guide.

You can also view our online tutorial (including video) or follow the simple steps below.

Standard two page setup

If you are using a two page setup for SearchUnit, whereby you use a separate page to display the search results, follow these steps;

  • Enable 'Site Search'
    Navigate to the Admin section of your Analytics account. Then click on View Settings option for the View you wish to setup Site Search tracking on and enable 'Site Search Tracking'.

  • Add the query parameter
    A typical URL for the SearchUnit search results page will look like this;
    http://keyoti.com/searchresults.aspx?query=test

    In order that Google Analytics can determine the search term used we just need to set the Query Parameter field to QueryExpr.

  • Optional category parameters
    For Google Analytics to register the categories used to refine your site's search results, under Site Search Categories enter 'loc' and 'cats'.

Once you have finished setting up your parameters click Save.


SearchUnit Documentation: The Controls Common To Search Lite & Pro

The Controls Common To Search Lite & Pro

SearchBox and SearchResult

SearchBox Control

SearchResult Control

The two controls, SearchBox and SearchResult form the basis of SearchUnit, SearchBox receives the user's search query and redirects it to the page containing SearchResult. At runtime SearchResult performs the search and displays the results, at designtime it supplies tools for building and managing the document index.

To be able to perform searches on a web-site the SearchResult control should be added to a webform, this page will be called on to show the results. The SearchBox control is added to a web-form and it's ResultPageURL property is set to the URL of the page holding SearchResult. This links the two together. The SearchResult control uses a directory to store it's index files. The index files are what enables the search to be so fast, even over millions of words in hundreds of documents. The index files directory is specified in the SearchResult.IndexDirectory property (this should be readable by the ASP.NET process).

With the controls set up and configured the web-site can be crawled by the spider and indexed, using the Index Management tool, accessible from the SearchResult control at design-time.

SearchResult Members of Note

HeaderTemplate, FooterTemplate, ResultItemTemplate, NoResultsTemplate, ErrorMessageTemplate and NoQueryTemplate
Used to specify appearance of the results

IndexDirectory
Where the index files will be stored

HighlightQueryWordsInSummary
Whether to highlight query words in the result summaries

NumberOfResultsPerPage
The number of results to show per page

Featured Results

The FeaturedResults control provides a simple way to add a 'featured results' section to the search results header. Typically, featured results are pages which are most important and should be hard-wired to be shown on certain keyword matches, they usually are product pages, purchase pages, help pages etc.


SearchUnit Documentation: Auto Complete

Auto Complete

The SearchBox control can provide an AJAX based autocomplete as the user types a query (the suggestions are customizable). Please also see the code example

.NET 2, 3, 4

Set the AutoCompleteQuery property of the SearchResult control to True and AutoCompleteQueryIndexDirectory to the index directory to be used.

You should optimize the index after removing documents from the index to ensure AutoComplete suggestions are up-to-date.

Usually performed automatically: If the controls are opened in the VS designer, then the web.config will be amended with the required code. If this doesn't occur, then the web.config must be opened and the following changes made:

View Configuration Information For .NET 4

IIS 6

Add inside the system.web section.
<httpHandlers>
       <add verb="*" path="Keyoti.SearchEngine.Web.CallBackHandler.ashx"
         type="Keyoti.SearchEngine.Web.CallBackHandler,Keyoti4.SearchEngine.Web,
            Version=2012.?.?.?, Culture=neutral, PublicKeyToken=58d9fd2e9ec4dc0e"/>
</httpHandlers>
where 2012.?.?.? should be replaced with the version number of the Keyoti4.SearchEngine.Web DLL.

IIS 7

Add inside the system.webServer section.
<staticContent>
    <mimeMap mimeType="text/html" fileExtension=".ashx"/>
</staticContent>
<handlers>
    <add name="Keyoti_SearchEngine_Web_CallBackHandler_ashx" verb="*" preCondition="integratedMode"
    path="Keyoti.SearchEngine.Web.CallBackHandler.ashx"
    type="Keyoti.SearchEngine.Web.CallBackHandler, Keyoti4.SearchEngine.Web,
    Version=2012.?.?.?, Culture=neutral, PublicKeyToken=58d9fd2e9ec4dc0e"/>
</handlers>
where 2012.?.?.? should be replaced with the version number of the Keyoti4.SearchEngine.Web DLL.

View Configuration Information For .NET 2 & 3

IIS 6

Add inside the system.web section.
<httpHandlers>
       <add verb="*" path="Keyoti.SearchEngine.Web.CallBackHandler.ashx"
         type="Keyoti.SearchEngine.Web.CallBackHandler,Keyoti2.SearchEngine.Web,
            Version=2012.?.?.?, Culture=neutral, PublicKeyToken=58d9fd2e9ec4dc0e"/>
</httpHandlers>
where 2012.?.?.? should be replaced with the version number of the Keyoti2.SearchEngine.Web DLL.

IIS 7

Add inside the system.webServer section.
<staticContent>
    <mimeMap mimeType="text/html" fileExtension=".ashx"/>
</staticContent>
<handlers>
    <add name="Keyoti_SearchEngine_Web_CallBackHandler_ashx" verb="*" preCondition="integratedMode"
    path="Keyoti.SearchEngine.Web.CallBackHandler.ashx"
    type="Keyoti.SearchEngine.Web.CallBackHandler, Keyoti2.SearchEngine.Web,
    Version=2012.?.?.?, Culture=neutral, PublicKeyToken=58d9fd2e9ec4dc0e"/>
</handlers>
where 2012.?.?.? should be replaced with the version number of the Keyoti2.SearchEngine.Web DLL.

.NET 1.1

Set the AutoCompleteQuery property of the SearchResult control to True and AutoCompleteQueryIndexDirectory to the index directory to be used.

You should optimize the index after removing documents from the index to ensure AutoComplete suggestions are up-to-date.

Popular search suggestions are not available in .NET 1.1.

View Configuration Information For .NET 1.1

IIS 6

Add inside the system.web section.
    <httpHandlers>
       <add verb="*" path="Keyoti.SearchEngine.Web.CallBackHandler.ashx"
        type="Keyoti.SearchEngine.Web.CallBackHandler,Keyoti.SearchEngine.Web,
            Version=2012.?.?.?, Culture=neutral, PublicKeyToken=58d9fd2e9ec4dc0e"/>
    </httpHandlers>
where 2012.?.?.? should be replaced with the version number of the Keyoti.SearchEngine.Web DLL.

IIS 7

Add inside the system.webServer section.
<staticContent>
    <mimeMap mimeType="text/html" fileExtension=".ashx"/>
</staticContent>
<handlers>
    <add name="Keyoti_SearchEngine_Web_CallBackHandler_ashx" verb="*" preCondition="integratedMode"
    path="Keyoti.SearchEngine.Web.CallBackHandler.ashx"
    type="Keyoti.SearchEngine.Web.CallBackHandler, Keyoti.SearchEngine.Web,
    Version=2012.?.?.?, Culture=neutral, PublicKeyToken=58d9fd2e9ec4dc0e"/>
</handlers>
where 2012.?.?.? should be replaced with the version number of the Keyoti.SearchEngine.Web DLL.
Client side files
The installer automatically registers a virtual directory called Keyoti_SearchEngine_Web_Common which holds the necessary scripts. This is used by the AJAX features and needs to be present on the development and deployment machines.

Some AutoComplete Members

AutoCompleteQuery
Whether to provide auto-complete suggestions to the user as they type in the query text box.

AutoCompleteQueryFailSilent
Whether to show warning messages about errors - advised to set to false for development.

AutoCompleteQueryIndexDirectory
Location of the Index Directory to use for auto complete. Default is '~/IndexDirectory'.

AutoCompleteQueryMaxSuggestions
The maximum number of auto complete suggestions to make.

AutoCompleteQueryRunSearchOnSelect
Whether to automatically run the search when the user selects an auto complete item from the list.

AutoCompleteQueryShowNumberofResults
Whether to list the predicted number of results for each auto complete suggestion - adds server load when true.

AutoCompleteLoadPlugin
Whether to load any plugin DLL (as specified by Configuration.ExternalEventHandler) - this allows customization of the auto complete suggestions.

AutoCompleteQuerySuggestionSource
The source of data for auto-complete suggestions.

Query Suggestion Source

The source of data for auto-complete suggestions can be set using the AutoCompleteQuerySuggestionSource property.

IndexLexicon
Uses the lexicon from the index directory as set under AutoCompleteQueryIndexDirectory, for auto-complete suggestions.

PopularSearches
Previous search terms are used to provide auto-complete suggestions in order of popularity. The algorithm uses an attenuating window to keep new queries important and prevent the popular-search list becoming too large over time.
Note: The AutoCompleteQueryIndexDirectory must still be set.
Note: To prevent inappropriate suggestions and/or hijacking of suggestions by certain users, only words which are in the index lexicon will be offered as suggestions.

Note: Offensive words should not be added to the stop list as those words could appear as a suggestion if another user searches for them.

PopularSearchesAndLexicon (default)
A mix of the above where popular searches are favored, and if there are not enough suggestions from that source then additional suggestions are found from the lexicon.

Server farm synchronization

The popular search auto-complete source must synchronize all servers in a farm in order to function accurately (otherwise different servers will offer different suggestions). To do this, specify the IP (or server name) of every server in the farm in the SearchBox.ServerFarmSynchronizationIPs property, as a comma-delimited list. Eg. ServerFarmSynchronizationIPs="10.0.0.1,10.0.0.2,10.0.0.3". Doing so will allow servers to communicate with each other every 5 minutes with changes in search keyword data.

It is important the AutoCompleteQueryIndexDirectory is identical on each server, as this is used to identify the data being synchronized.


SearchUnit Documentation: Result Previewer

Result Previewer

The SearchResult control can provide an AJAX based preview of a search result without the user having to leave the results page (the preview text is customizable). Please also see the code example.

.NET 4

To enable the previewer, set the ResultPreviewerEnabled property of the SearchResult control to True.

Usually performed automatically: If the controls are opened in the VS designer, then the web.config will be amended with the required code. If this doesn't occur, then the web.config must be opened and the following changes made:

IIS 6

Add inside the system.web section.
<httpHandlers>
       <add verb="*" path="Keyoti.SearchEngine.Web.CallBackHandler.ashx"
         type="Keyoti.SearchEngine.Web.CallBackHandler,Keyoti4.SearchEngine.Web,
            Version=2010.?.?.?, Culture=neutral, PublicKeyToken=58d9fd2e9ec4dc0e"/>
</httpHandlers>
where 2010.?.?.? should be replaced with the version number of the Keyoti4.SearchEngine.Web DLL.

IIS 7

Add inside the system.webServer section.
<staticContent>
    <mimeMap mimeType="text/html" fileExtension=".ashx"/>
</staticContent>
<handlers>
    <add name="Keyoti_SearchEngine_Web_CallBackHandler_ashx" verb="*" preCondition="integratedMode"
    path="Keyoti.SearchEngine.Web.CallBackHandler.ashx"
    type="Keyoti.SearchEngine.Web.CallBackHandler, Keyoti4.SearchEngine.Web,
    Version=2010.?.?.?, Culture=neutral, PublicKeyToken=58d9fd2e9ec4dc0e"/>
</handlers>
where 2010.?.?.? should be replaced with the version number of the Keyoti4.SearchEngine.Web DLL.

.NET 2, 3, 3.5

To enable the previewer, set the ResultPreviewerEnabled property of the SearchResult control to True.

Usually performed automatically: If the controls are opened in the VS designer, then the web.config will be amended with the required code. If this doesn't occur, then the web.config must be opened and the following changes made:

IIS 6

Add inside the system.web section.
<httpHandlers>
       <add verb="*" path="Keyoti.SearchEngine.Web.CallBackHandler.ashx"
         type="Keyoti.SearchEngine.Web.CallBackHandler,Keyoti2.SearchEngine.Web,
            Version=2010.?.?.?, Culture=neutral, PublicKeyToken=58d9fd2e9ec4dc0e"/>
</httpHandlers>
where 2010.?.?.? should be replaced with the version number of the Keyoti2.SearchEngine.Web DLL.

IIS 7

Add inside the system.webServer section.
<staticContent>
    <mimeMap mimeType="text/html" fileExtension=".ashx"/>
</staticContent>
<handlers>
    <add name="Keyoti_SearchEngine_Web_CallBackHandler_ashx" verb="*" preCondition="integratedMode"
    path="Keyoti.SearchEngine.Web.CallBackHandler.ashx"
    type="Keyoti.SearchEngine.Web.CallBackHandler, Keyoti2.SearchEngine.Web,
    Version=2010.?.?.?, Culture=neutral, PublicKeyToken=58d9fd2e9ec4dc0e"/>
</handlers>
where 2010.?.?.? should be replaced with the version number of the Keyoti2.SearchEngine.Web DLL.

.NET 1.1

Set the ResultPreviewerEnabled property of the SearchResult control to True. The web.config must be opened and the following added inside the system.web section - ensure the "add verb" element is all on one line when you paste.

IIS 6

Add inside the system.web section.
    <httpHandlers>
       <add verb="*" path="Keyoti.SearchEngine.Web.CallBackHandler.ashx"
        type="Keyoti.SearchEngine.Web.CallBackHandler,Keyoti.SearchEngine.Web,
            Version=2010.?.?.?, Culture=neutral, PublicKeyToken=58d9fd2e9ec4dc0e"/>
    </httpHandlers>
where 2010.?.?.? should be replaced with the version number of the Keyoti.SearchEngine.Web DLL.

IIS 7

Add inside the system.webServer section.
<staticContent>
    <mimeMap mimeType="text/html" fileExtension=".ashx"/>
</staticContent>
<handlers>
    <add name="Keyoti_SearchEngine_Web_CallBackHandler_ashx" verb="*" preCondition="integratedMode"
    path="Keyoti.SearchEngine.Web.CallBackHandler.ashx"
    type="Keyoti.SearchEngine.Web.CallBackHandler, Keyoti.SearchEngine.Web,
    Version=2010.?.?.?, Culture=neutral, PublicKeyToken=58d9fd2e9ec4dc0e"/>
</handlers>
where 2010.?.?.? should be replaced with the version number of the Keyoti.SearchEngine.Web DLL.
Client side files
The installer automatically registers a virtual directory called Keyoti_SearchEngine_Web_Common which holds the necessary scripts. This is used by the AJAX features and needs to be present on the development and deployment machines.


SearchUnit Documentation: SearchSuggestions & SearchBoxOptions

SearchSuggestions (Pro only)

This control provides spelling suggestions for search queries. It can be placed anywhere on a page with the SearchResult control (including inside SearchResult's templates). The control displays a link which performs a search with the corrected spelling.

A custom dictionary can be specified with a list of words that should be ignored (eg. company terms, names etc).

By default a US & UK English dictionary is used for spelling suggestions, however alternative dictionaries can be used by setting the Language property in the SearchSuggestions control. The extra dictionaries are available for download at http://keyoti.com/products/search/dotnetweb/dictionaries. You should download and unzip the .dict file(s) of your choice and place it in a folder under the Index Directory called "Dictionaries" (which you can create if need be).

For example - myApp\IndexDirectory\Dictionaries\DICT-DE-DE-German_SE.dict. The dictionary files must not be renamed, as their language is determined from the filename.
Members of note

SearchResultId
The ID of the SearchResult control to work with

CustomDictionaryPath
Path of the custom dictionary text file

MessageLabel
The label control used for the 'did you mean?' message

SuggestedLink
The hyperlink control used for the corrected spelling

SpellingSuggestionSource Property

FromEventOnly
Fastest source (from internal perspective) - suggestions are only taken from the FoundSpellingErrorEventArgs.

PresetDictionary
Second fastest - suggestions are obtained from the internal dictionary (as specified by Language property).

SearchLexicon
Third fastest - suggestions are obtained from the current list of words which have been indexed. Speed varies greatly depending on size of lexicon (eg. roughly 1 second for 100,000 words).

PresetDictionaryAndOptionalSearchLexicon
Optimal (default) - uses the dictionary always, and the SearchLexicon only when no search results have been found.

PresetDictionaryAndSearchLexicon
Slowest - uses the preset-dictionary and the search-lexicon always.

SearchBoxOptions (Pro only)

Displays content and location category options to the user on the page with the SearchBox control. This simple control is intended to be a quick way to add options to the search page. See later for a more flexible User Control based solution.

For setup instructions please see the SearchBoxOptions (Simple Usage) Example.

Members of note

LocationDropDownList
Drop down list control showing available locations

ContentCheckBoxes
Check box list control showing available contents

SearchBoxId
SearchBox control to work with

Locations
List of available location names

Contents
List of available content names

Layout
How to layout the child controls

AutoGenerateFromIndexDirectory
The Index Directory where Location and Content Categories will be automatically generated from.

AutoGenerateContentCheckBoxes
Whether to automatically generate the content category checkboxes. AutoGenerateFromIndexDirectory must be set to the index directory, when this is set true.

AutoGenerateLocationDropDown
Whether to automatically generate the content location category drop down menu. AutoGenerateFromIndexDirectory must be set to the index directory, when this is set true.


SearchUnit Documentation: Search Types

Search Types

Different search types can be used to refine and improve the search results. Below is a list of examples showing which operators can be used.

Operator Example | Finds documents containing...
office computer | the word office and the word computer
desktop OR notebook | either the word desktop or the word notebook
desktop OR notebook AND office | the word office and either desktop or notebook
"comedy game show" | the exact phrase comedy game show
connection -speed | the word connection but NOT the word speed. (Single -not query is not allowed)
wel* | words beginning with wel such as welcome, well and welfare
*come | words ending with come such as become, welcome and income
*ie* | words containing ie such as review, theories and friends
(w1 w2 w3) OR (w4 w5) | a combination of either w1, w2 and w3 OR w4 and w5
((w1 w2 w3) OR (w4 w5)) AND "w6 w7" | a combination of either w1, w2 and w3 OR w4 and w5 AND the phrase w6 w7
_all | all documents in the index that this user is allowed to see

By default, when no operator (AND or OR) is specified between words, AND is assumed. To change this to OR, see the ImpliedLogicOperator property in the Configuration.


Tutorials

Loading...


SearchUnit Documentation: Deployment

Deployment

Please see the section "Typical Development/Deployment Scenarios" in the "Examples" part of this Help documentation for information on deploying index files.

Using The Product MSI Installer

If possible, run the MSI installer that was initially used to install the controls on the development machine. This will perform the steps below automatically.

Manually

Manual deployment is fairly simple;
1. Copy the "Keyoti_SearchEngine_Web_Common" directory from the development machine (underneath where Search was installed) to the wwwroot folder on the server. This should result in URLs like http://servername/Keyoti_SearchEngine_Web_Common/ mapping to this directory. You can set it up elsewhere as a virtual directory if you prefer.
2. Either install the SearchUnit assemblies into the GAC using gacutil, or you can deploy these DLLs with your project's bin directory. The assemblies are located under the install dir in a folder named NETCLR_vX_BIN, be sure to pick the same version as those DLLs referenced in your project. If installing in the GAC please see Note below.

Note

As with any assemblies in the GAC, your aspx pages must register the assembly using a full reference. This means the register tag in your aspx pages should contain the correct version, culture and public key.
Eg;

<%@ Register TagPrefix="searchengine" Namespace="Keyoti.SearchEngine.Web" Assembly="Keyoti4.SearchEngine.Web, Version=2015.6.?.?, Culture=neutral, PublicKeyToken=58d9fd2e9ec4dc0e" %>
(where ? should be replaced with correct release version numbers)

otherwise the ASP.NET runtime will not be able to find the assembly in the GAC, and they will need to be in the project's bin dir.


SearchUnit Documentation: Central Event System (Plug-ins)

Central Event System (Plug-ins)

Overview

Central Event System Diagram

The behavior of the search engine components can be customized and/or extended through standard sub-classing, or through the Central Event System. By specifying your own custom logic in an assembly you can, for example, filter documents, override file contents, assign documents to location or content categories (see Example) etc.

Please see the Plug-in Quick Start section for the steps required to setup your plug-in project. .

The Central Event System is relatively simple, and consists of 2 parts; events fired from the search engine code and code that will handle some or all of the events (usually a custom built DLL). Essentially, a simple custom DLL can be created and pointed to in the search configuration - it will then be loaded and initialized by the search engine.

The events are typically

  • Notification that an object is being created
  • Notification that something is being processed (eg. the result list was made, or a document was read)
  • Notification that a decision is being made (eg. whether to index a document, or crawl a page)
Each event provides objects that can be changed - eg. result list can be resorted, or words can be taken out of a newly read document, etc etc.

Writing And Using A Plug-in

Examples:

  • Assigning Location & Content Categories
  • Site Map Creator
  • Adding Document Parsers
  • Modify Identified Character Encoding

Directly Accessing Central Events Without Using A Plug-in

Available Events


SearchUnit: Quick Start

Quick Start

Step 1
Step 2
Step 3
Further Details

Step 1. Create a new Class Library project.

Using the Index Management Tool:

  1. Select the Plug-in tab
  2. Enter the folder to create the project in
  3. Choose the required language and click Create Project.

The project will be created for you. Click Yes to open the project in Visual Studio.

Next

Step 2. Build the project.

From Visual Studio, select Build Solution to produce the plug-in DLL.

Next

Step 3. Set the path to your plug-in DLL.

Using the Index Management Tool:

  • Select the Plug-in tab
  • Enter the path to your plug-in DLL
  • Click Save Plug-in Path

The status box will confirm whether the plug-in was correctly initialized.

Next

Further Details

The plug-in's event handlers can now be modified as required, please see the extensive examples that are already part of the template.

Further details and plug-in examples can be found in the Central Event System (Plug-ins) section of the Help documentation.


SearchUnit Documentation: Writing A Plug-in Event Handler

Central Event System (Plug-ins)

Writing A Plug-in Event Handler

A plug-in template project can be created from the Index Management Tool. Select the Plug-in form, enter the folder to create the project in, choose the required language and click Create Project.

For a detailed example of writing a plug-in, please see the Site Map Plug-in example. The essential aspects are;

The Plug-in Assembly

You create a DLL which contains the class "Keyoti.SearchEngine.ExternalEventHandler" and any additional classes required to perform the custom tasks. It can reference whatever other assemblies are necessary.

Class Structure

The class (ExternalEventHandler) can be written in any .NET language, but must adhere to the following requirements;

Namespace: Class must be in Keyoti.SearchEngine
Class name: ExternalEventHandler
Constructor: Must take parameters of type IEventDispatcher, and Configuration
Methods: at least 1 method called DetachHandlers with no parameters.

Following these requirements allows the search engine to use the class. The constructor should attach handlers to the events from IEventDispatcher and the DetachHandlers should detach the handlers (this is called when the EventHandlerAssemblyPath property changes).

Example

Assign Location And Content Categories

Debugging A Plug-in

By attaching the Visual Studio debugger to a running Index Management Tool, it's easy to debug a plug-in.

  1. Start the index management tool.
  2. From the plug-in project, attach the Visual Studio debugger to the index management tool (Debug->Attach to process)
  3. Place a breakpoint as desired in the plug-in code.
  4. Start indexing in the index management tool - Visual Studio should stop the process at the break point.
If the break point is marked as invalid check that the .PDB file for your plug-in DLL is in the same folder as the live plug-in DLL.

Using A Plug-in

Configuration Settings

Once you have created your assembly, you will need to setup your Search application to communicate with the new logic. To do this, set the EventHandlerAssemblyPath property in the configuration settings, to the path of your project's output DLL (the path can be either, absolute or relative to the Index Directory). The configuration file can be edited by either;

Index Management Tool: Select the Configuration or Plug-in form.
Search Admin App: Select Manage Configuration from the main window.
Programmatically: Set the Configuration. EventHandlerAssemblyPath property.
Other: The configuration.xml file can be edited directly, this is located within your Index Directory folder.

Plug-in Location & References

Any assemblies which are referenced by the plug-in assembly will need to either be in the same folder or in the GAC (the search assemblies are installed in the GAC). It is suggested that the after development, the plug-in DLL is stored in location under the Index Directory - because the Index Directory is a portable unit, locating the plug-in under it will ensure they are not separated. The EventHandlerAssemblyPath can be set relative to the Index Directory.

Log Files

To check your extension plug-in is working as expected you can view the log file CentralEventDispatcher.txt under your Index Directory, which will be updated as soon as anything is attempted using the configuration (eg. edit settings, start a tool). You will need to ensure Logging has been enabled in the configuration settings before using your plug-in.

Example of successful entry;
08/14/2008 10:51 Success, initialized external event handler assembly @ C:\Inetpub\wwwroot\Search_Extension_Plugin\bin\SearchExtensionPlugin.dll

Notes

CAS (security permission) issues:

If accessing an external assembly (ie. CustomDataSetProvider or ExternalEventHandler) in anything below Full Trust, the external assembly must be located under the application directory.

External Assembly Location Tip:

When working with a plug-in DLL and the Admin Web App., place the plug-in DLL in the application BIN directory. This will make the DLL automatically updatable, without stopping the IIS service or killing the ASP.NET worker process.
If the plug-in is outside the application and it's subdirectories, ensure the ASPNET (IIS 5) or NetworkService (IIS 6) user can access the DLL, eg. run from command prompt

cacls "path to plug-in DLL" /E /G ASPNET:R

References To Search DLLs:

It is fine to reference the search DLLs, but attention must be paid to;
  • The plug-in assembly may only reference the exact same assemblies as those being used by the search applications - specifically if your applications are using Keyoti.SearchEngine.Core.DLL, then the plug-in will fail if it is referencing Keyoti2.SearchEngine.Core.DLL (reason being that the identical class names will not be compatible). Note: the Search Admin web application (under Pro) uses a specific CLR version of the assemblies, which depends on what the developer has installed - therefore any plug-ins used must also reference the same CLR assemblies as the version of the admin MSI installed. For example, if the admin MSI for CLR 4 is installed, any plugin MUST reference the CLR 4 assemblies.
  • Like any assembly, the versions of the reference during compilation must match the version of the assembly located at run-time. Specifically, this means that when upgrading from one version of Search to another, any plug-in DLLs will need to be recompiled against the new version assemblies.


SearchUnit Documentation: Handling Central Events Directly (Without A Plug-in)

Show language: C# VB.NET Both

Central Event System (Plug-ins)

Handling Central Events Directly (Without A Plug-in)

Events that are routed through the Central Event System can be handled without an external plug-in assembly. This is more convenient when all operations are performed programmatically - but has the limitation that, obviously, events are not handled when they occur in other processes (eg. the Windows Service, Visual Studio design time, Admin web app.). To access the central events, simply attach to them via the object Configuration.CentralEventDispatcher (where Configuration is the instance of the Configuration being used).

In the following example the Action event is handled at search time, by attaching to the Configuration.CentralEventDispatcher associated with the SearchResult control. Notice that the event handler will only be called during search operations (of course, because that's the context within which the handler is running - the context being the code-behind of the search result page).

C#
protected void Page_Load(object sender, EventArgs e)
{
    SearchResult1.Configuration.CentralEventDispatcher.Action += new
        Keyoti.SearchEngine.Events.ActionEventHandler(CentralEventDispatcher_Action);
}
VB.NET
Protected Sub Page_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles Me.Load

    AddHandler (SearchResult1.Configuration.CentralEventDispatcher.Action, AddressOf CentralEventDispatcher_Action)

End Sub


SearchUnit Documentation: Available Events

Central Event System (Plug-ins)

Available Events

There are 2 events fired by the Central Event System; Action and NeedObject. The Action event fires when an action is performed by the code (eg. result sorting, document reading etc). The NeedObject event fires when certain objects are created, this event allows the object type to be overridden with a subclass.

Action Event

The event arguments for an Action event are of type ActionEventArgs which has a property Name. The Name specifies what action has occurred, see below for a list of names, their description and what object can be found in the ActionEventArgs.Data property.

(Please also see the Keyoti.SearchEngine.Events.ActionName type under the API documentation ('Namespaces') for a complete up to date list.)

ActionEventArgs.Name | Description
AutoAssignContent | The content category for a document was auto assigned, Data contains the DocumentRecord object.
AutoAssignLocation | The location category for a document was auto assigned, Data contains the DocumentRecord object.
AutoAssignSecurityGroup, | The security group a document was auto assigned, Data contains the DocumentRecord object.
AutoCompleteSuggestionsGenerated | The autocomplete suggestions have been generated, Data contains an ArrayList of SuggestionResultPair objects, the sender of this event is SearchBoxAutoCompleteHelper and it has properties 'Query' and 'Segments' which may be of use - NOTE that this event is only fired when SearchBox.AutoCompleteQueryLoadPlugin is true.
CalculateWordRelevancies | The words have been read from a document that is being indexed and each word has been assigned a weight, Data contains the WordCollection from Document.CalculateWordRelevancies method argument.
DocumentBeingCrawled | The crawl-able links in a document are being processed, Data contains a 2 element object array - the 1st element is the Document object being crawled, and the 2nd element is an ArrayList of Uri objects found as links in the Document.
DocumentImporterAddingDocument | A document is about to be imported from an indexable source, Data contains AddDocumentEventArgs object, which has a Cancel property to enable canceling of this action.
DocumentIndexed | A document has been indexed, Data is the Document object.
DiscoveredLinkedURLs | New URLs have been found by reading document links, Data contains an ArrayList of string objects (the link URLs), which can be modified.
GetIndexableSourceRecords | The data-access layer is returning a list of IndexableSourceRecords. Note that changing the list may make the search engine unstable - as any CRUD operations on the indexable source record table may not reflect changes made during this event, handle NeedObject for XmlIndexableSourceRecordTable instead.
GetWordVariations | Variations (typically lemmas via stemming) of a word are required. Data contains a 2 element object array; first element is a Word object for the word that variations are needed for, and the second element is an ArrayList of strings holding the variations. The second element can be modified as desired.
ImportStarted | An import operation has started, Data contains the IndexableSourceRecord instance that is being imported.
ImportFinished | An import operation has ended, Data contains either an ArrayList of Uri objects that were imported, or if an exception occurred, it contains an Exception object.
IsDocumentToBeCrawled | The document has been checked to see if it will be crawled, Data contains IsDocumentToBeCrawledEventData and the WillCrawl property may be changed.
IsDocumentToBeIndexed | The document has been checked to see if it will be crawled, Data contains IsDocumentToBeIndexedEventData and WillIndex property may be changed.
IsFileSystemDocumentToBeIndexed | A document, found during a file system import is about to be indexed, Data contains IsFileSystemDocumentToBeIndexedEventData and WillIndex property may be changed.
ReadLinks | The links in a document have been read, Data contains ArrayList of URL strings.
ReadingText | The text in a document has been parsed and is about to be weighted, use this event to modify the document text before it's weighted, Data contains DocumentText object.
ReadText | The text in a document has been read, Data contains DocumentText object.
RequestingUri | A HttpWebRequest object has been created and is about to be sent for a response from the server, Data contains the HttpWebRequest which can be modified.
ResponseFromServerReceived | A HttpWebResponse object has been created from a response from the server, Data contains the HttpWebResponse.
ResultItemsFinalized | The search result items have been found and sorted, Data contains an ArrayList of ResultItem objects - the order and content of which may be changed.
ResultPreviewTextLoaded | The result preview text has been loaded, Data contains a StringBuilder containing the document text, the StringBuilder is modifiable when handling this event, use (sender as SearchResultPreviewHelper).Uri to get the document Uri.
UseDocumentEncoding | The Encoding of a document is about to be used, Data contains the Document - the Encoding property may be read and/or set to the required value.

NeedObject Event

The event arguments for a NeedObject event are of type NeedObjectEventArgs, which has properties;
RequiredObject: holding an object of the type needed - the instance set in RequiredObject will be used by the engine, and so this can be modified or reset with a new instance (of a sub-class for example).
Configuration: holding the current Configuration instance

Handling the NeedObject event allows sub-classes of standard types to be injected into the code. Below is a list of classes for which a NeedObject is raised.

Class | Typical Timing
Document | When a new Document instance is created, eg. during import and indexing.
Reader | When a document is about to be read, eg. during import and indexing.
ParserProvider | When a document is about to be parsed into words. Provides the provider for the file type.
XmlContentTable | When the data access layer creates the object which manages CRUD for content category records.
XmlLocationTable | When the data access layer creates the object which manages CRUD for location category records.
XmlSecurityGroupTable | When the data access layer creates the object which manages CRUD for security group records.
XmlIndexableSourceRecordTable | When the data access layer creates the object which manages CRUD for indexable source records.

The list of available events will expand with subsequent versions - if you need a specific event, please email support@keyoti.com for inclusion.


SearchUnit Documentation: About the Javascript mode usage API

About the Javascript mode usage API

The Javascript API documentation here is relevant to Javascript mode usage and not the ASP.NET Control based usage.


JSDoc: Namespace: keyotiCategoryChoosers

Namespace: keyotiCategoryChoosers

keyotiCategoryChoosers

Singleton that helps with location and content category chooser Controls

Members

(static) contentChooserItemTransform :Object

The transform to use to generate the content chooser control items
Type:
  • Object

(static) contentChooserTransform :Object

The transform to use to generate the content chooser control
Type:
  • Object

(static) locationChooserItemTransform :Object

The transform to use to generate the location chooser control items
Type:
  • Object

(static) locationChooserTransform :Object

The transform to use to generate the location chooser control
Type:
  • Object

(static) selectedContents :Array

The selected content categories
Type:
  • Array

(static) selectedLocation :String

The selected location
Type:
  • String

Methods

(static) convertContentBackendNameToFrontEndName()

Converts the content 'backend' name to a 'frontend' name, the backend name is that used in the index, and the frontend name is that used in the UI. By default they are the same.

(static) convertLocationBackendNameToFrontEndName()

Converts the location 'backend' name to a 'frontend' name, the backend name is that used in the index, and the frontend name is that used in the UI. By default they are the same.

(static) createChildControls()

Creates location and content controls

(static) createContentControls()

Creates content chooser controls

(static) createLocationControls()

Creates location chooser controls

(static) getSelectedContents()

Gets the selected content category name. This returns the content 'backend' name, the name used in the index, and not any converted 'frontend' name.

(static) getSelectedLocation()

Gets the selected location category name. This returns the location 'backend' name, the name used in the index, and not any converted 'frontend' name.

(static) init()

Initialize

(static) setSelectedContents()

Sets the selected content category names. This expects the content 'frontend' names, which is returned by convertContentBackendNameToFrontEndName.

(static) setSelectedLocation()

Sets the selected location category name. This expects the location 'frontend' name, which is returned by convertLocationBackendNameToFrontEndName.

Classes

  • KeyotiCheckboxesFilterControl
  • KeyotiCheckboxesIntRangeFilterControl
  • KeyotiDateFilter
  • KeyotiDropdownFilterControl
  • KeyotiIntFilter
  • KeyotiStringFilter
  • KeyotiStringListFilter
  • KeyotiTextboxesIntRangeFilterControl

Namespaces

  • keyotiCategoryChoosers
  • keyotiCustomDataFilters
  • keyotiCustomDataSort
  • keyotiResultViewer
  • keyotiSearch
  • keyotiSearchAutocomplete
  • keyotiSearchBox
  • keyotiSearchCloud
  • keyotiSearchResultPreviewer
  • keyotiTemplateUtility

Global

  • filterTransform
  • getRequestFilter
  • isFilterUsed
  • setSelectedValues
  • updateWithLiveData


JSDoc: Namespace: keyotiCustomDataFilters

Namespace: keyotiCustomDataFilters

keyotiCustomDataFilters

Singleton that manages the Custom Data filters.

Members

(static) activeFilters :Array

Array of filter controls in use on the page
Type:
  • Array

Methods

(static) createFilter()

Creates an underlying filter object based on the filterDefinition.

(static) getFilterControl(fieldName)

Gets the filter control being used for the Custom Data field
Parameters:
Name | Type | Description
fieldName | The Custom Data field name

(static) getRequestFilterCollection()

Gets a collection of request filter definitions from all filter Controls

(static) init()

Initialize, look for sew_filterControl DIVs and read their definitions.

(static) resetFilterCollection()

Resets all filters to no selection

(static) setFilterCollection()

Sets the current filter collection

(static) updateWithLiveDataSamples()

Updates all filter Controls with live data samples.

Classes

  • KeyotiCheckboxesFilterControl
  • KeyotiCheckboxesIntRangeFilterControl
  • KeyotiDateFilter
  • KeyotiDropdownFilterControl
  • KeyotiIntFilter
  • KeyotiStringFilter
  • KeyotiStringListFilter
  • KeyotiTextboxesIntRangeFilterControl

Namespaces

  • keyotiCategoryChoosers
  • keyotiCustomDataFilters
  • keyotiCustomDataSort
  • keyotiResultViewer
  • keyotiSearch
  • keyotiSearchAutocomplete
  • keyotiSearchBox
  • keyotiSearchCloud
  • keyotiSearchResultPreviewer
  • keyotiTemplateUtility

Global

  • filterTransform
  • getRequestFilter
  • isFilterUsed
  • setSelectedValues
  • updateWithLiveData


JSDoc: Namespace: keyotiCustomDataSort

Namespace: keyotiCustomDataSort

keyotiCustomDataSort

Handles result sorting based on Custom Data.

Members

(static) meta :Object

Meta information read from definition comment in the HTML
Type:
  • Object

(static) relevanceText :String

The text to use for 'relevance' sort by option
Type:
  • String

(static) selectedSortBy :String

The selected sort by option
Type:
  • String

Methods

(static) createChildControls()

Create child controls (SELECT element)

(static) getSortBy()

Gets the selected value from the SELECT element.

(static) init()

Read meta data about data sort control from JSON comment.

(static) setSortBy()

Sets the selected value of the SELECT element.

Classes

  • KeyotiCheckboxesFilterControl
  • KeyotiCheckboxesIntRangeFilterControl
  • KeyotiDateFilter
  • KeyotiDropdownFilterControl
  • KeyotiIntFilter
  • KeyotiStringFilter
  • KeyotiStringListFilter
  • KeyotiTextboxesIntRangeFilterControl

Namespaces

  • keyotiCategoryChoosers
  • keyotiCustomDataFilters
  • keyotiCustomDataSort
  • keyotiResultViewer
  • keyotiSearch
  • keyotiSearchAutocomplete
  • keyotiSearchBox
  • keyotiSearchCloud
  • keyotiSearchResultPreviewer
  • keyotiTemplateUtility

Global

  • filterTransform
  • getRequestFilter
  • isFilterUsed
  • setSelectedValues
  • updateWithLiveData


JSDoc: Namespace: keyotiResultViewer

Namespace: keyotiResultViewer

keyotiResultViewer

Singleton manager of header/list/footer style Control

Members

(static) resultControlPanel :Object

The result panel element
Type:
  • Object

(static) resultControlPanelAnimationTime :Number

Milliseconds to animate the result panel animation over (default=300)
Type:
  • Number

(static) resultControlPanelInitialHeight :Number

Internal use
Type:
  • Number

(static) resultControlPanelInitialWidth :Number

Internal use
Type:
  • Number

(static) resultFooterPanel :Object

The result footer panel element
Type:
  • Object

(static) resultFooterTransform :Object

The footer transform
Type:
  • Object

(static) resultHeaderPanel :Object

The result header panel element
Type:
  • Object

(static) resultHeaderTransform :Object

The header transform
Type:
  • Object

(static) resultItemTransform :Object

The result item transform
Type:
  • Object

(static) resultListPanel :Object

The results list panel element
Type:
  • Object

(static) resultObject :Object

The results from the server
Type:
  • Object

(static) resultsPanelIsOpen :Boolean

Whether the results panel is open
Type:
  • Boolean

(static) resultViewPanel :Object

The result view panel element
Type:
  • Object

(static) showResultsLoadingAnimPause :Number

Milliseconds to wait before showing the loading animation (default=10)
Type:
  • Number

(static) showResultsLoadingAnimTimeout :Object

The timeout reference for the loading animation
Type:
  • Object

Methods

(static) clearLoadingAnimTimeout()

Clears the loading animation timeout, usually because the results have been loaded

(static) closeResultsControlPanel(instantly)

Closes the results panel so that it is invisible
Parameters:
Name | Type | Description
instantly | Whether to close the panel immediately or animate it

(static) ensureChildControls()

Creates child controls if necessary

(static) expandResultControlPanel(extraHeight)

Expands the result panel to fit the result content inside of it
Parameters:
Name | Type | Description
extraHeight | Any additional height to add to the content height

(static) getResultControlPanel()

Returns the id=sew_searchResultControl element - which holds the entire search result control

(static) getResultFooterPanel()

Returns the footer panel element

(static) getResultHeaderPanel()

Returns the header panel element

(static) getResultListPanel()

Returns the element holding the 'result list' section of the control (ie between the header or footer)

(static) getResultViewPanel()

Returns the element holding the results section of the control, this is separate to the error and loading DIVs, and contains the sew_resultList element

(static) hideResultsLoadingAnim()

Hides the loading animation

(static) hideSearchResults()

Closes the results panel so that it is invisible and empties the child control content

(static) hideServerError()

Hides the server error message

(static) init()

Initialize

(static) onError()

Called when a server error occurs, and shows the error

(static) onErrorOKButton_Click()

Handles the error OK button click

(static) openResultsControlPanel(instantly)

Opens the results panel so that it is visible
Parameters:
Name | Type | Description
instantly | Whether to open the panel immediately or animate it

(static) scrollTop()

Scroll to the the top of the page if topOfPage is true, otherwise to the result header location

(static) showResultsLoadingAnim()

Shows the result loading animation after 'wait' millisconds, unless the results load first

(static) showSearchResults()

Show the search results, opening the result panel if necessary

(static) showServerError(exception)

Displays error information to the user
Parameters:
Name | Type | Description
exception | Object with Message and StackTrace properties

(static) shrinkResultControlPanel(extraHeight)

Shrinks the result panel by extraHeight
Parameters:
Name | Type | Description
extraHeight | The amount of height to remove

Classes

  • KeyotiCheckboxesFilterControl
  • KeyotiCheckboxesIntRangeFilterControl
  • KeyotiDateFilter
  • KeyotiDropdownFilterControl
  • KeyotiIntFilter
  • KeyotiStringFilter
  • KeyotiStringListFilter
  • KeyotiTextboxesIntRangeFilterControl

Namespaces

  • keyotiCategoryChoosers
  • keyotiCustomDataFilters
  • keyotiCustomDataSort
  • keyotiResultViewer
  • keyotiSearch
  • keyotiSearchAutocomplete
  • keyotiSearchBox
  • keyotiSearchCloud
  • keyotiSearchResultPreviewer
  • keyotiTemplateUtility

Global

  • filterTransform
  • getRequestFilter
  • isFilterUsed
  • setSelectedValues
  • updateWithLiveData


JSDoc: Namespace: keyotiTemplateUtility

Namespace: keyotiTemplateUtility

keyotiTemplateUtility

Singleton that helps with templating.

Members

(static) convertDataAttributeInTemplate :Boolean

Whether to convert data-* style attributes in template elements to *
Type:
  • Boolean

Methods

(static) formatCustomData()

When overridden can be used to format how CustomData value's appear in the search results. This function implementation only returns 'value'.

(static) getDisplayClass()

Returns a string equal to customDataDictionaryItemName+"NoContent" if 'value' has zero length, otherwise returns customDataDictionaryItemName+"Content". This can be overridden with custom logic to return CSS class names based on Custom Data field content

(static) readTemplate()

Reads the inner HTML template that may be specified for templatable Controls.

Classes

  • KeyotiCheckboxesFilterControl
  • KeyotiCheckboxesIntRangeFilterControl
  • KeyotiDateFilter
  • KeyotiDropdownFilterControl
  • KeyotiIntFilter
  • KeyotiStringFilter
  • KeyotiStringListFilter
  • KeyotiTextboxesIntRangeFilterControl

Namespaces

  • keyotiCategoryChoosers
  • keyotiCustomDataFilters
  • keyotiCustomDataSort
  • keyotiResultViewer
  • keyotiSearch
  • keyotiSearchAutocomplete
  • keyotiSearchBox
  • keyotiSearchCloud
  • keyotiSearchResultPreviewer
  • keyotiTemplateUtility

Global

  • filterTransform
  • getRequestFilter
  • isFilterUsed
  • setSelectedValues
  • updateWithLiveData


JSDoc: Namespace: keyotiSearch

Namespace: keyotiSearch

keyotiSearch

Singleton that runs searches and display results

Members

(static) abortedSearchAttempts :Number

The number of times the search had to be aborted because another search operation was still loading
Type:
  • Number

(static) commonFolderUrl :String

The URL to the folder where search engine scripts (eg. SearchUnit.js) are kept (no trailing slash required)
Type:
  • String

(static) customDictionaryPath :String

Path to a custom dictionary, this is relative to the indexDirectory\Dictionaries\ folder (ie specify a filename here and put a text file with that name in the Dictionaries folder under the index directory)
Type:
  • String

(static) highlightKeywordsInResultDocument :Boolean

Whether to highlight exact keyword matches in the result document, works with HTML based documents that have imported the SearchUnit_Highlighter.js script.
Type:
  • Boolean

(static) indexDirectory :String

The index directory to search
Type:
  • String

(static) keywordHighlightPattern :String

HTML to use to highlight keyword highlights, default is <span class='sew_resultHighlight'>{0}</span>
Type:
  • String

(static) language :String

The language of the text that is being searched, this affects spell checking: Danish, Dutch, English, EnglishAustralia, EnglishCanada, EnglishMedical, EnglishUK, EnglishUS, French, German, Italian, Norwegian, Polish, Portuguese, Spanish, SpanishLatinAmerica, Swedish, Russian, Custom.
Type:
  • String

(static) pageNumber :Number

The current result page number
Type:
  • Number

(static) query :String

The current search query, may be null
Type:
  • String

(static) queryKeywords :Array

String array of individual keywords in the query
Type:
  • Array

(static) resultKeywordParameterName :String

The query string parameter name to use when linking to results, this is for the highlighter functionality (default=searchunitkeywords).
Type:
  • String

(static) resultsPerPage :Number

Number of results to show per page
Type:
  • Number

(static) securityGroups :Array

Array of encrypted security group names that the user can search with-in, see the Help topic on Security Groups for information
Type:
  • Array

(static) serviceProxy

Handles AJAX service calls

(static) spellingSuggestionSource :String

Where the spelling suggestions will be sourced, options are defined in the Keyoti.SearchEngine.Suggestions.SpellingSuggestionSource enum (eg. FromEventOnly, PresetDictionary, SearchLexicon, PresetDictionaryAndOptionalSearchLexicon, PresetDictionaryAndSearchLexicon). Care should be taken with lexicon based options as large lexicons can cause slow downs.
Type:
  • String

(static) updateOnOptionChange :Boolean

Whether to update search results as soon as any search options (categories, filters, sort-by) are changed, if this is false it is necessary to call keyotiSearch.showPage(1, true) to trigger a refresh
Type:
  • Boolean

(static) useWCFService :Boolean

Whether to use WCF to communicate with the server, this is only usable if the application is running under .NET 4+ on the server
Type:
  • Boolean

Methods

(static) _doSearch()

(static) _getQueryStringParameters()

(static) _onDocumentReady()

(static) _parseQueryStringParameters()

(static) createCustomDataSortControl()

Creates the Custom Data sort control

(static) getFooterJSON()

Gets an object containing footer information, so that it can be used with a template

(static) getHeaderJSON()

Gets an object containing header information, so that it can be used with a template

(static) getPagingLinksBlock()

Gets a block of HTML with links to result pages

(static) getSecurityGroups()

Returns the security groups set by the developer

(static) highlightResultItems()

Adds highlight tags around keyword hits

(static) highlightText()

Adds a highlight to text and returns it, the highlight is set in keyotiSearch.keywordHighlightPattern if the highlightPattern argument is not set.

(static) htmlEscape()

Escapes HTML entities

(static) load()

Load the controls with data from 'jsonObject'

(static) makeQueryStringForSearchParameters()

Returns the query string based on search parameters

(static) nextPage()

Shows the next page of results

(static) onCategoryControlsCreated()

Empty function, called when category controls are created, intended to be overridden by user code.

(static) onContentChange()

Called when the chosen content categories changes

(static) onFilterChange()

Called when a filter changes

(static) onLocationChange()

Called when the chosen location category changes

(static) onSortChange()

Called when the sort order changes

(static) presentResults()

Shows the search results from keyotiSearch.resultObject

(static) previousPage()

Shows the previous page of results

(static) search(query, pageNumber, _blockPushStateToHistory)

Runs the search and shows the results
Parameters:
Name | Type | Description
query | The search query
pageNumber | The result page to show
_blockPushStateToHistory | Whether to prevent this search being logged in the browser's history

(static) showPage(pageNumber, blockScroll)

Shows a result page specified by 'pageNumber'
Parameters:
Name | Type | Description
pageNumber | The page to show
blockScroll | Whether to prevent the page scrolling back to the top as the new page of results is shown

(static) updateSearchCloud()

Calls the server to obtain search cloud terms, and displays them using createChildControls function

Classes

  • KeyotiCheckboxesFilterControl
  • KeyotiCheckboxesIntRangeFilterControl
  • KeyotiDateFilter
  • KeyotiDropdownFilterControl
  • KeyotiIntFilter
  • KeyotiStringFilter
  • KeyotiStringListFilter
  • KeyotiTextboxesIntRangeFilterControl

Namespaces

  • keyotiCategoryChoosers
  • keyotiCustomDataFilters
  • keyotiCustomDataSort
  • keyotiResultViewer
  • keyotiSearch
  • keyotiSearchAutocomplete
  • keyotiSearchBox
  • keyotiSearchCloud
  • keyotiSearchResultPreviewer
  • keyotiTemplateUtility

Global

  • filterTransform
  • getRequestFilter
  • isFilterUsed
  • setSelectedValues
  • updateWithLiveData


JSDoc: Namespace: keyotiSearchAutocomplete

Namespace: keyotiSearchAutocomplete

keyotiSearchAutocomplete

Singleton handling query auto-complete

Members

(static) filterFilenames :Boolean

Whether to filter out filenames from the suggestions
Type:
  • Boolean

(static) options :Object

Behavior options
Type:
  • Object

(static) sew_failSilent :Boolean

Whether to hide any failure messages
Type:
  • Boolean

(static) sew_menuShiftX :Number

Autocomplete suggestion drop down X position shift
Type:
  • Number

(static) sew_menuShiftY :Number

Autocomplete suggestion drop down Y position shift
Type:
  • Number

Methods

(static) dataReceived()

(static) init()

(static) sew_formatItem()

(static) sew_item_selected()

Classes

  • KeyotiCheckboxesFilterControl
  • KeyotiCheckboxesIntRangeFilterControl
  • KeyotiDateFilter
  • KeyotiDropdownFilterControl
  • KeyotiIntFilter
  • KeyotiStringFilter
  • KeyotiStringListFilter
  • KeyotiTextboxesIntRangeFilterControl

Namespaces

  • keyotiCategoryChoosers
  • keyotiCustomDataFilters
  • keyotiCustomDataSort
  • keyotiResultViewer
  • keyotiSearch
  • keyotiSearchAutocomplete
  • keyotiSearchBox
  • keyotiSearchCloud
  • keyotiSearchResultPreviewer
  • keyotiTemplateUtility

Global

  • filterTransform
  • getRequestFilter
  • isFilterUsed
  • setSelectedValues
  • updateWithLiveData


JSDoc: Namespace: keyotiSearchBox

Namespace: keyotiSearchBox

keyotiSearchBox

Manages the search box Control where the user can enter their query

Members

(static) buttonText :String

The button text
Type:
  • String

(static) resultURL :String

Optional - when set, searches are sent to the URL set here. Setting this enables 2 page style searching, otherwise the search results are shown on the same page
Type:
  • String

(static) searchBox :Object

The textbox element
Type:
  • Object

(static) searchBoxControl :Object

The sew_searchBoxControl element
Type:
  • Object

(static) searchButton :Object

The search button element
Type:
  • Object

(static) searchOnEnter :Boolean

Whether to run the search when the user presses ENTER in the query textbox (default true).
Type:
  • Boolean

(static) watermarkText :String

The watermark text
Type:
  • String

(static) watermarkVisible :Boolean

Whether to show the 'Search' placeholder ('watermark')
Type:
  • Boolean

Methods

(static) doSearch()

Runs a search with either 'optionalQuery' or if not specified the query in the textbox

(static) ensureSearchBoxChildControls()

Create textbox and button controls if not already present, within an element with id='sew_searchBox'

(static) getQuery()

Returns the query in the textbox

(static) init()

Initialize

(static) setQuery()

Sets the query shown in the textbox

Classes

  • KeyotiCheckboxesFilterControl
  • KeyotiCheckboxesIntRangeFilterControl
  • KeyotiDateFilter
  • KeyotiDropdownFilterControl
  • KeyotiIntFilter
  • KeyotiStringFilter
  • KeyotiStringListFilter
  • KeyotiTextboxesIntRangeFilterControl

Namespaces

  • keyotiCategoryChoosers
  • keyotiCustomDataFilters
  • keyotiCustomDataSort
  • keyotiResultViewer
  • keyotiSearch
  • keyotiSearchAutocomplete
  • keyotiSearchBox
  • keyotiSearchCloud
  • keyotiSearchResultPreviewer
  • keyotiTemplateUtility

Global

  • filterTransform
  • getRequestFilter
  • isFilterUsed
  • setSelectedValues
  • updateWithLiveData


JSDoc: Namespace: keyotiSearchCloud

Namespace: keyotiSearchCloud

keyotiSearchCloud

Singleton that handles the search cloud Control.

Members

(static) fontSizeUnits :String

The font size units to use, per CSS
Type:
  • String

(static) itemTransform :Object

Transform to use to generate cloud query links
Type:
  • Object

(static) maximumFontSize :Number

The largest font size for the most search query
Type:
  • Number

(static) minimumFontSize :Number

The smallest font size for least searched query
Type:
  • Number

(static) numberOfQueriesToGet :Number

The maximum number of cloud queries to retrieve from the server
Type:
  • Number

(static) transform :Object

Transform to use to generate cloud box
Type:
  • Object

Methods

(static) createChildControls()

Create cloud items based on server data

(static) createControl()

Create content.

(static) init()

Initialize the control.

Classes

  • KeyotiCheckboxesFilterControl
  • KeyotiCheckboxesIntRangeFilterControl
  • KeyotiDateFilter
  • KeyotiDropdownFilterControl
  • KeyotiIntFilter
  • KeyotiStringFilter
  • KeyotiStringListFilter
  • KeyotiTextboxesIntRangeFilterControl

Namespaces

  • keyotiCategoryChoosers
  • keyotiCustomDataFilters
  • keyotiCustomDataSort
  • keyotiResultViewer
  • keyotiSearch
  • keyotiSearchAutocomplete
  • keyotiSearchBox
  • keyotiSearchCloud
  • keyotiSearchResultPreviewer
  • keyotiTemplateUtility

Global

  • filterTransform
  • getRequestFilter
  • isFilterUsed
  • setSelectedValues
  • updateWithLiveData


JSDoc: Namespace: keyotiSearchResultPreviewer

Namespace: keyotiSearchResultPreviewer

keyotiSearchResultPreviewer

Singleton manage the result preview widget

Members

(static) currentPreviewDIV :Object

The DIV element that will hold previews
Type:
  • Object

(static) indexDirectory :String

The index directory to work with
Type:
  • String

(static) keyword_highlightPattern :String

HTML to use to format hits within the preview pane, default is <span class='sew_previewHighlight'>{0}</span>
Type:
  • String

(static) maxCharLength :Number

Maximum number of characters to retrieve for the previewed document text
Type:
  • Number

(static) previewLoadPlugin :Boolean

Whether to load the plugin for the previewer request, this allows the plugin to modify the text to be previewed
Type:
  • Boolean

Methods

(static) toggleResultPreview()

Classes

  • KeyotiCheckboxesFilterControl
  • KeyotiCheckboxesIntRangeFilterControl
  • KeyotiDateFilter
  • KeyotiDropdownFilterControl
  • KeyotiIntFilter
  • KeyotiStringFilter
  • KeyotiStringListFilter
  • KeyotiTextboxesIntRangeFilterControl

Namespaces

  • keyotiCategoryChoosers
  • keyotiCustomDataFilters
  • keyotiCustomDataSort
  • keyotiResultViewer
  • keyotiSearch
  • keyotiSearchAutocomplete
  • keyotiSearchBox
  • keyotiSearchCloud
  • keyotiSearchResultPreviewer
  • keyotiTemplateUtility

Global

  • filterTransform
  • getRequestFilter
  • isFilterUsed
  • setSelectedValues
  • updateWithLiveData


JSDoc: Class: KeyotiCalendarRangeFilterControl

Class: KeyotiCalendarRangeFilterControl

KeyotiCalendarRangeFilterControl

Constructor

new KeyotiCalendarRangeFilterControl(ksqControlElement, filter)

This:
  • {KeyotiCalendarRangeFilterControl}
Parameters:
Name | Type | Description
ksqControlElement | KSQ element that will hold this Control
filter | The underlying filter object, eg. KeyotiIntFilter

Classes

  • KeyotiCalendarRangeFilterControl
  • KeyotiCheckboxesFilterControl
  • KeyotiCheckboxesIntRangeFilterControl
  • KeyotiDateFilter
  • KeyotiDropdownFilterControl
  • KeyotiIntFilter
  • KeyotiStringFilter
  • KeyotiStringListFilter
  • KeyotiTextboxesIntRangeFilterControl

Namespaces

  • keyotiCategoryChoosers
  • keyotiCustomDataFilters
  • keyotiCustomDataSort
  • keyotiResultViewer
  • keyotiSearch
  • keyotiSearchAutocomplete
  • keyotiSearchBox
  • keyotiSearchCloud
  • keyotiSearchResultPreviewer
  • keyotiTemplateUtility


JSDoc: Class: KeyotiCheckboxesFilterControl

Class: KeyotiCheckboxesFilterControl

KeyotiCheckboxesFilterControl

Constructor

new KeyotiCheckboxesFilterControl(ksqControlElement, filter)

Checkbox filter control
This:
  • {KeyotiCheckboxesFilterControl}
Parameters:
Name | Type | Description
ksqControlElement | KSQ element that will hold this Control
filter | The underlying filter object, eg. KeyotiIntFilter

Classes

  • KeyotiCheckboxesFilterControl
  • KeyotiCheckboxesIntRangeFilterControl
  • KeyotiDateFilter
  • KeyotiDropdownFilterControl
  • KeyotiIntFilter
  • KeyotiStringFilter
  • KeyotiStringListFilter
  • KeyotiTextboxesIntRangeFilterControl

Namespaces

  • keyotiCategoryChoosers
  • keyotiCustomDataFilters
  • keyotiCustomDataSort
  • keyotiResultViewer
  • keyotiSearch
  • keyotiSearchAutocomplete
  • keyotiSearchBox
  • keyotiSearchCloud
  • keyotiSearchResultPreviewer
  • keyotiTemplateUtility

Global

  • filterTransform
  • getRequestFilter
  • isFilterUsed
  • setSelectedValues
  • updateWithLiveData


JSDoc: Class: KeyotiCheckboxesIntRangeFilterControl

Class: KeyotiCheckboxesIntRangeFilterControl

KeyotiCheckboxesIntRangeFilterControl

Constructor

new KeyotiCheckboxesIntRangeFilterControl(ksqControlElement, filter)

Checkbox integer range filter control
This:
  • {KeyotiCheckboxesIntRangeFilterControl}
Parameters:
Name | Type | Description
ksqControlElement | KSQ element that will hold this Control
filter | The underlying filter object, eg. KeyotiIntFilter

Classes

  • KeyotiCheckboxesFilterControl
  • KeyotiCheckboxesIntRangeFilterControl
  • KeyotiDateFilter
  • KeyotiDropdownFilterControl
  • KeyotiIntFilter
  • KeyotiStringFilter
  • KeyotiStringListFilter
  • KeyotiTextboxesIntRangeFilterControl

Namespaces

  • keyotiCategoryChoosers
  • keyotiCustomDataFilters
  • keyotiCustomDataSort
  • keyotiResultViewer
  • keyotiSearch
  • keyotiSearchAutocomplete
  • keyotiSearchBox
  • keyotiSearchCloud
  • keyotiSearchResultPreviewer
  • keyotiTemplateUtility

Global

  • filterTransform
  • getRequestFilter
  • isFilterUsed
  • setSelectedValues
  • updateWithLiveData


JSDoc: Class: KeyotiDateFilter

Class: KeyotiDateFilter

KeyotiDateFilter

Constructor

new KeyotiDateFilter(definition)

The underlying filter that represents the type of filter the related Control will work on.
This:
  • {KeyotiDateFilter}
Parameters:
Name | Type | Description
definition | The definition (eg from server) defining the filter control to show and for which custom data field

Classes

  • KeyotiCheckboxesFilterControl
  • KeyotiCheckboxesIntRangeFilterControl
  • KeyotiDateFilter
  • KeyotiDropdownFilterControl
  • KeyotiIntFilter
  • KeyotiStringFilter
  • KeyotiStringListFilter
  • KeyotiTextboxesIntRangeFilterControl

Namespaces

  • keyotiCategoryChoosers
  • keyotiCustomDataFilters
  • keyotiCustomDataSort
  • keyotiResultViewer
  • keyotiSearch
  • keyotiSearchAutocomplete
  • keyotiSearchBox
  • keyotiSearchCloud
  • keyotiSearchResultPreviewer
  • keyotiTemplateUtility

Global

  • filterTransform
  • getRequestFilter
  • isFilterUsed
  • setSelectedValues
  • updateWithLiveData


JSDoc: Class: KeyotiDropdownFilterControl

Class: KeyotiDropdownFilterControl

KeyotiDropdownFilterControl

Constructor

new KeyotiDropdownFilterControl(ksqControlElement, filter)

Dropdown filter control, uses a SELECT element
This:
  • {KeyotiDropdownFilterControl}
Parameters:
Name | Type | Description
ksqControlElement | KSQ element that will hold this Control
filter | The underlying filter object, eg. KeyotiIntFilter

Classes

  • KeyotiCheckboxesFilterControl
  • KeyotiCheckboxesIntRangeFilterControl
  • KeyotiDateFilter
  • KeyotiDropdownFilterControl
  • KeyotiIntFilter
  • KeyotiStringFilter
  • KeyotiStringListFilter
  • KeyotiTextboxesIntRangeFilterControl

Namespaces

  • keyotiCategoryChoosers
  • keyotiCustomDataFilters
  • keyotiCustomDataSort
  • keyotiResultViewer
  • keyotiSearch
  • keyotiSearchAutocomplete
  • keyotiSearchBox
  • keyotiSearchCloud
  • keyotiSearchResultPreviewer
  • keyotiTemplateUtility

Global

  • filterTransform
  • getRequestFilter
  • isFilterUsed
  • setSelectedValues
  • updateWithLiveData


JSDoc: Class: KeyotiIntFilter

Class: KeyotiIntFilter

KeyotiIntFilter

Constructor

new KeyotiIntFilter(definition)

The underlying filter that represents the type of filter the related Control will work on.
This:
  • {KeyotiIntFilter}
Parameters:
Name | Type | Description
definition | The definition (eg from server) defining the filter control to show and for which custom data field

Classes

  • KeyotiCheckboxesFilterControl
  • KeyotiCheckboxesIntRangeFilterControl
  • KeyotiDateFilter
  • KeyotiDropdownFilterControl
  • KeyotiIntFilter
  • KeyotiStringFilter
  • KeyotiStringListFilter
  • KeyotiTextboxesIntRangeFilterControl

Namespaces

  • keyotiCategoryChoosers
  • keyotiCustomDataFilters
  • keyotiCustomDataSort
  • keyotiResultViewer
  • keyotiSearch
  • keyotiSearchAutocomplete
  • keyotiSearchBox
  • keyotiSearchCloud
  • keyotiSearchResultPreviewer
  • keyotiTemplateUtility

Global

  • filterTransform
  • getRequestFilter
  • isFilterUsed
  • setSelectedValues
  • updateWithLiveData


JSDoc: Class: KeyotiStringFilter

Class: KeyotiStringFilter

KeyotiStringFilter

Constructor

new KeyotiStringFilter(definition)

The underlying filter that represents the type of filter the related Control will work on.
This:
  • {KeyotiStringFilter}
Parameters:
Name | Type | Description
definition | The definition (eg from server) defining the filter control to show and for which custom data field

Classes

  • KeyotiCheckboxesFilterControl
  • KeyotiCheckboxesIntRangeFilterControl
  • KeyotiDateFilter
  • KeyotiDropdownFilterControl
  • KeyotiIntFilter
  • KeyotiStringFilter
  • KeyotiStringListFilter
  • KeyotiTextboxesIntRangeFilterControl

Namespaces

  • keyotiCategoryChoosers
  • keyotiCustomDataFilters
  • keyotiCustomDataSort
  • keyotiResultViewer
  • keyotiSearch
  • keyotiSearchAutocomplete
  • keyotiSearchBox
  • keyotiSearchCloud
  • keyotiSearchResultPreviewer
  • keyotiTemplateUtility

Global

  • filterTransform
  • getRequestFilter
  • isFilterUsed
  • setSelectedValues
  • updateWithLiveData


JSDoc: Class: KeyotiStringListFilter

Class: KeyotiStringListFilter

KeyotiStringListFilter

Constructor

new KeyotiStringListFilter(definition)

The underlying filter that represents the type of filter the related Control will work on.
This:
  • {KeyotiStringListFilter}
Parameters:
Name | Type | Description
definition | The definition (eg from server) defining the filter control to show and for which custom data field

Classes

  • KeyotiCheckboxesFilterControl
  • KeyotiCheckboxesIntRangeFilterControl
  • KeyotiDateFilter
  • KeyotiDropdownFilterControl
  • KeyotiIntFilter
  • KeyotiStringFilter
  • KeyotiStringListFilter
  • KeyotiTextboxesIntRangeFilterControl

Namespaces

  • keyotiCategoryChoosers
  • keyotiCustomDataFilters
  • keyotiCustomDataSort
  • keyotiResultViewer
  • keyotiSearch
  • keyotiSearchAutocomplete
  • keyotiSearchBox
  • keyotiSearchCloud
  • keyotiSearchResultPreviewer
  • keyotiTemplateUtility

Global

  • filterTransform
  • getRequestFilter
  • isFilterUsed
  • setSelectedValues
  • updateWithLiveData


JSDoc: Class: KeyotiTextboxesIntRangeFilterControl

Class: KeyotiTextboxesIntRangeFilterControl

KeyotiTextboxesIntRangeFilterControl

Constructor

new KeyotiTextboxesIntRangeFilterControl(ksqControlElement, filter)

2 Textbox integer range filter control
This:
  • {KeyotiTextboxesIntRangeFilterControl}
Parameters:
Name | Type | Description
ksqControlElement | KSQ element that will hold this Control
filter | The underlying filter object, eg. KeyotiIntFilter

Classes

  • KeyotiCheckboxesFilterControl
  • KeyotiCheckboxesIntRangeFilterControl
  • KeyotiDateFilter
  • KeyotiDropdownFilterControl
  • KeyotiIntFilter
  • KeyotiStringFilter
  • KeyotiStringListFilter
  • KeyotiTextboxesIntRangeFilterControl

Namespaces

  • keyotiCategoryChoosers
  • keyotiCustomDataFilters
  • keyotiCustomDataSort
  • keyotiResultViewer
  • keyotiSearch
  • keyotiSearchAutocomplete
  • keyotiSearchBox
  • keyotiSearchCloud
  • keyotiSearchResultPreviewer
  • keyotiTemplateUtility

Global

  • filterTransform
  • getRequestFilter
  • isFilterUsed
  • setSelectedValues
  • updateWithLiveData


SearchUnit Documentation: Administration and Service

The Utility Components

Besides the user interface controls, SearchUnit Pro includes utilities for administering and managing indexes.

Administration Web Application

Not installed by default (although included in the demo projects), this ASP.NET application provides a username/password protected UI for all index management operations.
Manage Content & Location categories
Manage document URLs to be indexed
Crawl web-sites
Build index
Manage configuration of crawl/build and the Windows Service

Please see the 'Administration App. & Windows Service' section of the Help documentation for installation instructions.

Windows Service (Auto Rebuilds)

Not installed by default, the Windows Service automatically rebuilds search indexes (and optionally recrawls the web-site) at specified intervals, from specified start times (eg. every 72 hours starting at 1am, or every 8 hours starting at midnight). Once installed, the Windows Service can be controlled from the Index Management Tool.

Please see the 'Administration App. & Windows Service' section of the Help documentation for installation instructions.


SearchUnit Documentation: Scenarios - Company Intranet

Scenarios: Company Intranet

In this scenario we explore how Search can be integrated with various aspects of a company's intranet site. It is intended that the "Company_Intranet_Scenario" demo project is viewed along-side these pages.

Example 1 Company Intranet - how to index an intranet consisting of web-site pages and a document repository.

Example 2 Categories - how to implement location and content categories.

Example3 ASP.NET Membership - how to index a password protected portion of a site.


SearchUnit Documentation: Scenarios - Example1 Company Intranet

Example1 Company Intranet

This example shows how to index a site containing various documents located on the web server and file-system. This demonstrates usage when a web-site has document folders without HTML links to each document.

We will;
1. Import ASPX and HTML pages from the web server
2. Import PDF and Word documents stored on the file-system
3. Configure the Windows Service to update the index once a week
4. Deploy new documents

1. Import pages from web server

From the page containing the SearchResult control (Example1_CompanyIntranet/SearchResults.aspx in our example), access the Index Management Tool and select Import New Source.

To begin importing enter the start URL for the site and click Import. In this example;
http://localhost:49094/Company_Intranet/IntranetDemoSite/Notices.aspx

The spider will then proceed to read the site and add new links. Once complete you can see these links from the Indexed Sources form.

2. Import documents from file-system

In our demo site we have a folder that contains documents we want indexed for searching but are not linked to from any pages on the site (IntranetDemoSite/Policies/). The easiest way to add these to the index is to use a file-system import.

From the Import section of the Index Management Tool, select FileSystemDocumentStore from the Type of Source drop down list.

Enter the Local Folder Path, in this example;
..\..\IntranetDemoSite\Policies\ which contains the documents on the file-system required to be indexed for searching. The local folder path can be relative to the index directory.

Next enter the Virtual Folder Path, in this example;
http://localhost:49094/Company_Intranet/IntranetDemoSite/Policies/ any documents found under the local folder path are automatically mapped to the Virtual Folder path.

Before Importing we need to set the document types to be included in the Import. Click More Options and under Target Match List add the document types, in this example '.doc' and '.pdf'. Only these document types will be Imported.

Note: To specify strings that must match at the end of the filename, use a $ character, eg. ".aspx$" will match "default.aspx" but not "default.aspx.cs".

Additionally these options can also be set;
No recurse folder match list - is a list of strings that specify which subfolders will not be looked inside.
Recurse sub-folders - specifies whether to look in subdirectories as well.

Click Import to add the documents to the index. Once complete you can see these links from the Indexed Sources form

3. Configure the Windows Service

In our example we want to update the index with any new documents, automatically, once each week. This is achieved by using the Windows Service. For details on installing the Windows Service please see the Administration App. & Windows Service section of the Help Help documentation.

The configuration.xml file under the Index Directory needs to be setup with the details required by the Windows Service. To edit the configuration, from the SearchResult control select Manage Index to open the Index Management Tool and select the Windows Service form from the menu.

The following settings should be configured;

ServiceRebuildFrequency - how many hours should pass since the last indexing operation. In this example it is set to 168. (24hrs x 7 days).

ServiceRebuildHour - the hour of the day at which the first indexing operation will happen. In this example it is set to 13. The first indexing operation will therefore start at 1:00pm.

ServiceWillOptimizeIndex - whether the Windows Service will optimize the index after it has reimported sources.

Click Save Changes. After any changes are made to the Windows Service settings you must restart the service for any changes to take effect. This can be done from the Windows Service section of the Index Management Tool or by loading the service (Control Panel > Administrative Tools > Services) open Keyoti_Search_Index_Service and restart.

4. Deploy new documents

New documents which have been added and are linked to by the site will be added during the next re-indexing operation.

File-system

Any new documents added to the local folder can be deployed by copying them to the Virtual Folder. The new documents will be added during the next re-indexing operation.

Introduction


SearchUnit Documentation: Scenarios - Example2 Categories

Example2 Categories

This example shows how to assign documents in the index to Content and Location categories

For details on Content and Location categories, please see the"Assigning Content And Location Categories" section of the Help documentation.

We will;
1. Create Content/Location categories
2. Automatically assign Location categories
3. Configure SearchBoxOptions control

1. Create Content/Location categories

From the page containing the SearchResult control (Example2_Categories/SearchResults.aspx in our example), access the Index Management Tool and select the Location/Content form.

In the Name field, enter the title for the Content/Location category and select the Add Content/Location button.

URLs can then be manually assigned by dragging them from the default category to the Content/Location categories as required.

2. Automatically assign Location categories

Existing and newly imported URLs can be automatically assigned to Location categories. Using the Index Management Tool select the Location form. Select an existing Location category, or create a new category, and in the Location Root field enter string used to identify document URLs which will be automatically added to this category (such as the a folder name).

To assign existing URLs select the Location category and click Assign Locations.

Any future imported documents that meet the location criteria will be automatically assigned for you.

For example, we have set the Location Root for the Policies category to /Policies/. Allowing the user to only search documents located within that category.

3. Configure SearchBoxOptions control

To display the Content and Location category options to the user the SearchBoxOptions control should be added to the page containing the SearchBox control. Set the SearchBoxId property to the ID of the SearchBox control.

Under the Content/Location property of the SearchBoxOptions control, enter the category names previously created. Note: These must match the exact titles specified when you created the categories, otherwise, as default, all categories will be searched.

Introduction


SearchUnit Documentation: Scenarios - Example3 ASP.NETMembership

Example3 ASP.NETMembership

This example shows how to index a site that uses ASP.NET Membership (.NET2+) authentication.

For details on .NET1+ Forms Authentication and complete C# & VB.NET code, please see the "Forms Authentication Apps & Site" section of the Help documentation.

Our example contains a folder only accessible by logging in as Admin (Example3_ASPNETMembership/Secure). As we want to include the contents of the folder in our index we need to configure the spider to login and visit the first page to be crawled.

We will;
1. Add code to accept username and password
2. Configure Import start page
3. Import documents

1. Add code to accept username and password

To allow the crawler/indexer to login we need to modify the login page code to accept the username and password from GET request parameters. To do this we simply change the code to try authenticating from the form parameters as well;

Protected Sub Page_Load(ByVal sender As Object, ByVal e As EventArgs) Handles Me.Load
        'get any supplied username for the search engine
        Dim user As String = Page.Request.Params("searchusername")
        Dim pass As String = Page.Request.Params("searchpassword")

        'if it wasn't a postback and we do have a username, then login the user
        If (Not IsPostBack _
                    AndAlso ((Not (user) Is Nothing) _
                    AndAlso (Not (pass) Is Nothing))) Then

            If Membership.ValidateUser(user, pass) Then
                FormsAuthentication.RedirectFromLoginPage(user, False)
            End If

        ElseIf Not IsPostBack _
                    AndAlso Not Membership.GetUser() Is Nothing And Not Request.Params("ReturnUrl") Is Nothing Then
            'not a postback and we didn't get any user info,
            'so if the user is already logged in, redirect them as usual
            FormsAuthentication.RedirectFromLoginPage(Membership.GetUser().UserName, False)
        End If
    End Sub

2. Configure Import start page

Then, in the Index Management tool, the Website Import start page is configured to start from the login page, using the username and password required.

Eg. Import start URL is set to;
http://localhost/login.aspx?searchusername=myUserName&searchpassword=myPassword

In our example we also need to specify the URL to visit after logging in. This is done by adding "&ReturnUrl=someURL.aspx" to make the spider visit 'someURL.aspx'.

And so our start URL is set to; http://localhost:49094/Company_Intranet/Example3_ASPNETMembership/login.aspx?searchusername=admin&searchpassword=admin1@&ReturnUrl=%2fCompany_Intranet%2fExample3_ASPNETMembership%2fSecure%2fAccounts.aspx

The spider/indexer will login with Username: admin Password: admin1@ and visit our Accounts.aspx page first.

By using the GET parameters, searchusername and searchpassword we allow the engine to strip the username and password from search results.

3. Import documents

Once the start URL has been configured, click Import to being importing and indexing the documents.

Introduction


SearchUnit Documentation: License Keys In Multi Server Development Environments

License Keys In Multi Server Development Environments

It is common practice to use multiple servers in the development of web applications, for example, an application may go through a lifecycle;
developer machines ("localhost") -> single development test server ("devServer") -> QA server ("qaServer") -> production server ("prodServer")

The current licensing system requires keys for "devServer", "qaServer" and "prodServer" if they are accessed through non local browsers (note; 'devServer' and 'qaServer' keys will be provided free), this poses a problem since it is not acceptable to change the "LicenseKey" property in source code for each server.

The solution is reasonably simple and it uses a mechanism that is likely to be used already, the "web.config" file. Since each server should have a unique web.config file, storing the license keys in there makes sense.

Store the license key in the web.config in the <appSettings> section (if it doesn't exist, create it after the system.web section).

Eg;

<?xml version="1.0" encoding="utf-8" ?>
<configuration>
    <system.web>
        ...........
    </system.web>
    <appSettings>
        <add key="Keyoti-SearchEngine-LicenseKey" value="123456789"/>
    </appSettings>
</configuration>

Now set each server's web.config accordingly, remember web.config files should not be deployed to a server with an application (because they are unique).


SearchUnit Documentation: Crawling Strategy; How To Ensure High Success Rates

Crawling Strategy; How To Ensure High Success Rates

Like all search engine spiders the success rate for crawling is not always 100% - in other words, when crawling web-sites it is not always possible for the spider to find every page automatically, this section includes tips for improving the success rate. It is also worth pointing out that pages can always be added manually through the 'Edit Document List' button in the Index Management tool, or programmatically through the DocumentIndex class.

#1. Think of the spider like a Javascript disabled browser - the spider 'sees' your web-site like a browser, it cannot see pages that are not linked to. It has no access to your directory structure.

#2. Most links written from Javascript are unreadable, because the spider is not a Javascript engine, it doesn't know that your popup menu exists. See #3.

#3. Provide commented out links, or a 'site map' to help the spider. Eg. if your web-site does have a popup menu that uses Javascript, add hidden links like

<!--

href="page1.aspx"

href="page2.aspx"

-->

this won't affect users, but will match one of the spiders regex patterns. These hidden links can be generated by your code at runtime and added to the page.

#4. If the spider reports a problem such as 404 Not Found, or 401 Not Authorized then you should check the URL in a browser (for 404's), and also consult the Forms Authentication section (for 401's).

#5. If need be, by pass the spider and add documents directly using the DocumentIndex class's AddDocument method or manually with the Index Management tool.


SearchUnit Documentation: Document Reindexing Logic (Modified Dates)

Document Reindexing Logic (Modified Dates)

To prevent documents being reindexed needlessly, the engine determines if a document has changed, and will only re-index it if it has.

Note, in Search Lite, re-indexing is not automatic, you must run the indexer either through the SearchResult control or programmatically.

Whether a document has changed is determined by it's modified date, and it's content-size.

Modified Date

Any documents whose 'modified date' is older than the date the document was last indexed, will not be re-indexed. To prevent this default behavior, set IgnoreLastModifiedDate in the configuration to true.

Content Size

Ideally the last-modified date of a document would always be used to identify if it has changed, however web-servers do not always return this information. Further, dynamic pages do not have 'last-modified' dates, since they are dynamic.

The byte size of a document can however be used to identify change with reasonable accuracy. If a document has a different file size, then it has definitely changed. Of course, it is also possible for a document to change, but have the same size (exactly the same number of letters are deleted as added, for example), so this is not 100% accurate.

Despite not having 100% accuracy, it may be desirable to forgo accuracy for performance, by having UseFileSizeToIdentifyChange set to true in the configuration.

Indexing Interval

Further control over re-indexing can be asserted through the IndexingInterval configuration setting, which specifies the number of days that must pass before a document will be reindexed (regardless of whether it was modified), the diagrams below explain the relationship between document modified dates, Indexing Interval and when a document will be indexed.

Reindexing Conditions

In order for a document to be indexed, all of the following conditions must be met;

a) the number of days from today, to the date the document was last indexed, must be equal to or greater than IndexingInterval (eg. this condition is ALWAYS met if IndexingInterval=0).

b) IgnoreLastModifiedDate must be true OR the document's "modified date" must not be older than the document's last index date (if they're equal, it will be indexed) (eg. the document must have changed since it was last indexed).

c) UseFileSizeToIdentifyChange must be false OR the document's "content size" must not different to the document's size when it was last indexed.

Note: if the server fails to supply the indexer with a last modified date in the response, then today will be used.


SearchUnit Documentation: Error Page Redirects

Error Page Redirects

When a web application that is being indexed uses redirects to a custom error page for web-site errors (eg missing pages 404 or server errors 500), then it's important that the search engine can identify the redirect. Otherwise the engine will process the content of the error page as if it were a standard redirect, and not an error.

By default ASP.NET error redirects include "aspxerrorpath=" in the redirect URL and this is used to identify an error. This string may be customized by the application developer however, and in this case it's important to change the ErrorPageRedir property in the search Configuration to match.


SearchUnit Documentation: Conclusion

Conclusion

Thank you for using the SearchUnit component, we hope that you experience much success with it. Keyoti is committed to improving all of it's products and truly values customer feedback of any kind. If you would like to contact us about any of our products please do so through our web site.

http://www.keyoti.com/contact.html

We thrive on suggestions for components, if you have a component wish please don't hesitate to get in touch, it may be the next thing we develop!


SearchUnit Documentation: Administration App. & Windows Service Features

Administration App. & Windows Service

This Help documentation is aimed solely at the Search Administration and Windows Service applications that are part of SearchUnit Pro for ASP.NET

Features

-Web based importing, categorization and configuration
-Service based re-importing

Requirements

IIS5+
ASP.NET 1.1+
Search Controls must be installed first


SearchUnit Documentation: Administration App. & Windows Service Installation

Windows Service & Web Admin Installation

Prerequisites

The installer requires;

  • The full IIS (not IIS Express), versions 5 up.
  • "IIS Management Console" be installed (this is available from 'Turn Windows features on or off'->Internet Information Services->Web Management Tools->IIS Management Console.
  • The main SearchUnit product MSI must be installed.

It is possible to install the MSI without ASP.NET installed, however the Web Administration app will not function (the Service will though).

Installation

To setup the KeyotiSearchAdministration web application under IIS, and to install the Windows Service:
  • The installer can be launched;
    • from the Index Management Tool select Windows Service. Under the Service Status section click Install Service, or
    • by locating KeyotiSearchAdministration-NETX-Setup.exe under the product install folder, or
    • under the Windows Start menu, find the Keyoti Search program group, and choose the ".NET X Administration application installer.exe" shortcut for the .NET CLR version you wish to install.
Note: the Admin app. is available at http://localhost/KeyotiSearchAdministration

Note: by default the Windows Service will start automatically on machine startup..

Note: customers should uninstall their previous Search Administration installation before upgrading.

Please see the Common Tasks section of the Help documentation for further details on Windows Service and Web Admin


SearchUnit Documentation: Administration Web Application

Administration Web Application

To log-in to the Web Application, please visit http://localhost/KeyotiSearchAdministration. The app. presents options for

Manage Content Categories
Configures the available content categories

Manage Location Categories
Configures the available location categories

Manage Configuration
Configures most operations

Import A Website
Crawls a web-site on the net and adds it's pages to the index

Manage Indexed Documents
Lists all known documents and their settings

Delete Index
Completely removes all index documents

Change default Index Directory

The default Index Directory the web app. works with can be changed using the following line in the web.config;

Note
This can be an application relative URL (eg ~/IndexDirectory) or an absolute file path (eg. c:\inetpub), however it must already exist and the ASP.NET user (either ASPNET, NetworkService or an impersonated user) must have permission to write to it.

<add key = "keyoti-search-admin-default-directory" value="~/IndexDirectory" />

Hide Index Directory Selection Option

The option to change the Index Directory the web app. works with can be removed by adding the following line to the web.config;

<add key = "keyoti-search-admin-allow-select-directory" value="false" />

Save Index Directory Path

You can save Index Directory paths to a drop down list by entering the Index Directory you would like to work with and selecting Save.

Note
1. A file must exist called IndexDirectoryPathStore.txt in the application directory.
2. The ASP.NET user (either ASPNET, NetworkService or an impersonated user) must have permission to read/write to the file.

How to use the index directory from the Search Controls

Operations performed through the web app. affect the index directory specified on the Manage Configuration page. To use this index directory for searches, copy the location of the index directory from the Manage Configuration page to the IndexDirectory property in the SearchResult control.

How to install on production servers

To install on other servers, follow the standard installation procedure - install the controls, and then install the app.

How to setup username and password

By default, no username or password is required. To specify one, open web.config and add the appSettings section below;

<?xml version="1.0" encoding="utf-8" ?>
<configuration>
    <appSettings>
        <add key = "keyoti-search-admin-username" value = "JoeBloggs" />
        <add key = "keyoti-search-admin-password" value = "joespass" />
    </appSettings>
</configuration>


SearchUnit Documentation: Windows Service

Windows Service

The Windows Service, "Keyoti_Search_Index_Service_201x" is installed and by default its start-up type is 'automatic'.

Starting/Stopping

Start/Stop can be performed through the Windows Service form of the Index Management Tool, or via the regular Services control panel under Windows.

Note, after changing the configuration timing the windows service should be restarted for changes to take effect.

Specifying Index Directories To Work With

The Windows Service form of the Index Management Tool allows the user to specify which Index Directory paths to work with. Each Index Directory specified is treated separately and will run on it's own schedule.

Configuring Timing

There are two settings in the Configuration page (Admin app) and class (programmatic) which affect the service index timing;

Start indexing hour | - The hour of the day at which the first indexing operation will happen.
Rebuild frequency | - Sets how many hours should pass since the last index operation before reindexing is performed.

For example, to set the service to index;

Every night at 1am; set Start indexing hour to 1, and set Rebuild frequency to 24

Every other day at 6pm; set Start indexing hour to 18, and set Rebuild frequency to 48

Every 6 hours starting at midnight; set Start indexing hour to 0, and set Rebuild frequency to 6

Monitoring Service Activity

To log service activity (start, stop, indexing, crawling) go to the Configuration page under the Index Management Tool or Admin web-app. and enable Logging. A file named KEYOTI_WINDOWS_SERVICE.txt will be written to the index directory the next time the service performs an action (restart the service to get an immediate response).

Note

The Windows Service will not be able to import documents while the Index Manager Tool is open on the same index directory at the same time. Please ensure the Index Manager Tool is not open at the time of the next indexing operation.


SearchUnit Documentation: Administration App. & Windows Service Architecture

Architecture

Although not necessary for regular use, the following is given as an aid to understanding exactly what the Admin and Service require.

Default installation directory

The Admin Web App. is installed in the virtual directory "KeyotiSearchAdministration" under IIS.

Default index directory

Upon installation, the default index directory is a directory called "IndexDirectory" located under "KeyotiSearchAdministration"; eg. C:\Inetpub\wwwroot\KeyotiSearchAdministration\IndexDirectory

This can be changed from the Configuration page.

Location of Configuration.xml

Settings made in the Admin web app. are stored in a file named "Configuration.xml" which is located in the Index Directory.

External files

The location of Index Directories to work with is stored in an XML file named ServiceConfiguration.xml, which is located in the CommonApplicationData folder (eg. c:\ProgramData\Keyoti_Search_6.0.0).


Knowledge Base

Loading...


Support Forum

Loading...


Case Studies

Loading...


API Documentation

Keyoti SearchUnit API Docs
API Documentation
API Documentation
Keyoti SearchUnit v6
SearchUnit Control
Namespaces
Namespace | Description
Keyoti.SearchEngine | The core namespace for the search engine. Search engine namespaces
Keyoti.SearchEngine.DataAccess | Data layer classes. Core data access classes
Keyoti.SearchEngine.DataAccess.IndexableSourceRecords | Indexable source records
Keyoti.SearchEngine.Documents | Classes related to document reading and parsing. Imported documents
Keyoti.SearchEngine.Documents.IFilter | IFilter based parsers
Keyoti.SearchEngine.Events | Central events
Keyoti.SearchEngine.Index | Classes for building the index. Main indexing classes
Keyoti.SearchEngine.Index.IndexableSources | Types of indexable source
Keyoti.SearchEngine.Search | Classes for searching the document index. Search classes
Keyoti.SearchEngine.Suggestions | Spelling suggestions
Keyoti.SearchEngine.Utils | Utilities
Keyoti.SearchEngine.Web | Classes for the Web controls.
Keyoti.SearchEngine.Web.AjaxService |
Keyoti.SearchEngine.Web.AjaxService.WCF |
Keyoti.SearchEngine.Web.Templates | Default templates for SearchResult control.
Keyoti.SearchEngine.WindowsService | Windows Service classes
Keyoti.Text.LemmaGenerator |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.


Keyoti.SearchEngine Namespace

Keyoti.SearchEngine Namespace
API Documentation ► Keyoti.SearchEngine
Keyoti SearchUnit v6
The core namespace for the search engine.

Search engine namespaces

Types
All Types Classes Enumerations
Icon | Type | Description
 | Configuration | Crawling, indexing and search parameters.
 | ConfigurationManager | Retrieves settings from Configuration.xml file and fills a Configuration instance.
 | ConfigurationPropertyAttribute | Property member attribute used to declare which properties of the Configuration class are used as search operation (spider, index, search) settings.
 | ConfigurationPropertyAttribute..::..DataType | Types of property
 | FolderBrowserDialog | Component wrapping access to the Browse For Folder common dialog box. Call the ShowDialog() method to bring the dialog box up.
 | FolderBrowserDialog..::..FolderID | Enum of CSIDLs identifying standard shell folders.
 | KeyotiFatalException | An exception thrown when crawling/building/searching cannot proceed.
 | LicenseLevel |
 | LicenseType |
 | NET4 |
 | SecurityGroup | Utility class for security group encryption.


Configuration Class

Configuration Class
API Documentation ► Keyoti.SearchEngine ► Configuration
Keyoti SearchUnit v6
Crawling, indexing and search parameters.
Declaration Syntax
C# Visual Basic
public class Configuration : INotifyPropertyChanged
Public Class Configuration
    Implements INotifyPropertyChanged
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Configuration()()()() |
 | BoostFactorTagName | The boost factor tag name.
 | CacheCrawlLinks | Whether to store links found on a page before that page is crawled. Set false to conserve memory.
 | CaseSensitivity | Obsolete. The case sensitivity setting for building and searching.
 | CentralEventDispatcher | The centralized event dispatcher that will fire all central events.
 | CrawlSubdomains | Whether to let the crawler crawl [other] subdomains that it finds links to, otherwise the crawler will stay on the exact hostname that it started on.
 | CreateForwardIndex | Whether to create a 'forward index' which allows for result summary generation and result preview features.
 | credentials | Obsolete. Map of web-site domain-names/server-names to usernames and passwords.
 | CurrentIndexVersion | The index version that this build works with.
 | CurrentMajorVersion | The major version of this build.
 | CustomDataFilterLiveDataMaximum | The maximum amount of live data to report with results to the client, for AJAX custom data filters.
 | DataAccessExceptionsThreshold | Obsolete. Number of exceptions that will be tolerated in the data access layer.
 | DbCommandTimeout | The number of seconds to set CommandTimeout to for MSSQL commands.
 | DbImportPageSize | The number of records to read in each database import paging operation.
 | DbType | The storage method for the document index - possible values "sql" or "xml"
 | DefaultPageNames | List of strings with default page names, these pages are synonomous with a URL ending in a directory.
 | DocumentWorkTimeout | The length of time, in milliseconds, until the document work times out
 | Equals(Object) | (Inherited from Object.)
 | ErrorPageRedir | Error page URL pattern
 | EventHandlerAssemblyPath | The absolute file path of an external assembly that will be automatically registered to handle operational events.
 | exceptionThresholds | Obsolete. Contains exception thresholds.
 | ExpressionOperatorsCollection | Collection of logic operators, containing the default pair (AND,OR)
 | FileTypesSettings | Maps mime-type strings to file extensions.
 | Finalize()()()() | (Inherited from Object.)
 | ForceGCollectOnDocRead | Whether to force a garbage collect before and after reading a document. ONLY set true when debugging memory issues.
 | GetApplicationDataFolderPath()()()() | Returns the folder under LocalApplicationData where install info is stored.
 | GetHashCode()()()() | (Inherited from Object.)
 | GetMimeFromFileExtension(String) | Returns the mime-type for a particular file extension, as per settings in fileTypesSettings
 | GetType()()()() | (Inherited from Object.)
 | IgnoreBlockBeginPattern | Pattern that marks the start of a block that should be ignored in the search process
 | IgnoreBlockEndPattern | Pattern that marks the end of a block that should be ignored in the search process
 | IgnoreCommonResourceTypes | Whether to ignore links to common resource types, eg. .jpg, .gif, .js.
 | IgnoreDiacritics | Whether to ignore diacritic marks, eg. treat 'é' in a word the same as 'e', so 'sake' will find 'saké' (default is true).
 | IgnoreLastModifiedDate | Whether to ignore the 'last modified date' returned from the server, during build operations.
 | IgnoreSSLErrors | Whether to ignore SSL issues on the website being imported - eg. expired certificate.
 | ImpliedLogicOperator | The implied logic operator between query expression words.
 | IndexDirectory | The path to the index directory - eg "c:\documentIndex"
 | IndexedDocumentBufferSize | The number of documents to index to the memory buffer before writing to disk.
 | IndexingInterval | The length of time in days that must pass before the document is re-indexed.
 | IndexNumbers | Whether to index numbers.
 | LemmaLanguage | The language to look for lemmas in.
 | LemmaSearchEnabled | Whether to look for variations of query words, eg plural forms, see LemmaWeightFactor and LemmaLanguage also.
 | LemmaWeightFactor | Factor to adjust weight of lemma (word variations) matches.
 | LogFileMaxSize | The size in bytes at which log files are refreshed.
 | Logging | Whether to log activity and errors to files stored in the index directory.
 | MaxDocumentSizeToIndex | Documents smaller than this number of kilobytes will be indexed, and documents larger than this will be skipped.
 | MaximumCrawlDepth | Specifies the maximum 'link depth' that should be crawled.
 | MaxResponseHeaderLength | The length in kilobytes of the response headers. A value of -1 means no limit will be imposed on the response headers
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnNotifyPropertyChanged(String) | Fires the PropertyChanged event.
 | ParseMSWordDocUsingIFilter | Whether to parse MS Word .doc files using the Windows IFilter (COM interop), if false the pure .NET parser is used (default false).
 | ParseRTFDocUsingIFilter | Whether to use the built-in Windows IFilter to parse RTF files. Default is true.
 | PdfDocumentTitleSource | Where the title of a Pdf document is obtained from.
 | PropertyChanged | Fired when a property value changes.
 | ProxyAddress | The address of a proxy server to use to make outbound connections during indexing. Leave empty to not use a proxy.
 | ProxyPort | The port to connect to the proxy server on (if a proxy is used).
 | ReadDocumentInNewThread | The number of documents to index to the memory buffer before writing to disk.
 | ReaderExceptionsThreshold | Number of exceptions that will be tolerated in the reader layer.
 | ReadGlobalConfigKey(String) | Reads a value from the global install config (located under the user's application data folder).
 | RequestThrottle | The length of time, in milliseconds, that the application will wait before each request is made, in order to limit the server load.
 | RequestTimeout | The length of time, in milliseconds, until the request times out
 | RespectsRobotsMetaTags | Whether to consider the robots meta tags (noindex, nofollow).
 | RespectsRobotsTXT | Whether to consider the robots.txt specifications
 | ResultSummaryType | The type of summary that will be shown.
 | ServiceRebuildFrequency | Indexing interval (hours)
 | ServiceRebuildHour | The hour when the reindexing will start (int hour, 0-23)
 | ServiceWillOptimizeIndex | Whether the service should automatically optimize the index for searching.
 | ServiceWillSendEmailLog | Whether the service should send an email log after it has run.
 | SmtpEmailFrom | The email from address that the log will be sent 'from'.
 | SmtpEmailTo | The email from address that the log will be sent to.
 | SmtpMailServer | The email server to use to send email with service run logs.
 | SmtpPassword | The email server password if required. Password will be encrypted and the unencrypted form is not available from configuration files or API.
 | SmtpServerPort | The email server port number to use to send email with service run logs.
 | SmtpUsername | The email server username if required.
 | StopWords | List of 'common' words which are not searchable.
 | SummaryTextSplitter | The string used to split apart summary text from different parts of the result document, default is '...'.
 | SummaryWordLength | Number of words to show in result summaries.
 | ToString()()()() | (Inherited from Object.)
 | URLCaseSensitive | Whether, during indexing, to compare URLs in a case sensitive manner (default is false) - some web servers are case sensitive, IIS is not.
 | UseFileSizeToIdentifyChange | Whether to use the file size of a document to identify if it has been changed or not since it was last indexed (also see IgnoreLastModifiedDate).
 | UserAgent | The user agent that the search engine identifies itself to the server as.
 | WebProxy | Proxy object to use for connections. Setting can speed up access to external servers.
 | WebProxySet | Whether a proxy has been set.
 | WebsiteCredentials | Map of web-site domain-names/server-names to usernames and passwords.
 | WordBreakingCharacters | Characters that will not be considered parts of 'words' and will break a string apart. Any space characters will be ignored.
 | WordNonBreakingCharacters | Characters that will be considered parts of 'words' and not break a string apart. Eg. To be able to search for strings like my_email@blah.com - ensure that @ . and _ are in this list of characters. Any space characters will be ignored.
 | WordsAroundNumber | Number of words to show around non-continguous summary occurrences.
 | WordWeightFactorBody | The weighting factor given to words in the document body - increase to make words in the body text more important.
 | WordWeightFactorTitle | The weighting factor given to words in the document title - increase to make words in the title text more important.
 | WordWeightFactorUrl | The weighting factor given to words in the document title - increase to make words in the URL more important.
 | xmlLocation | Obsolete. The path to the XML document index directory - eg "c:\documentIndex"
Inheritance Hierarchy
Object
Configuration

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Core (Module: Keyoti4.SearchEngine.Core.dll) Version: 2015.6.15.120


Configuration Constructor

Configuration Constructor
API Documentation ► Keyoti.SearchEngine ► Configuration ► Configuration()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public Configuration()
Public Sub New

Send comments on this topic to support@keyoti.com


BoostFactorTagName Property

BoostFactorTagName Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► BoostFactorTagName
Keyoti SearchUnit v6
The boost factor tag name.
Declaration Syntax
C# Visual Basic
public string BoostFactorTagName { get; set; }
Public Property BoostFactorTagName As String
    Get
    Set
Property Value
String
Remarks
Default is keyoti_search_weight_boost_factor.


CacheCrawlLinks Property

CacheCrawlLinks Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► CacheCrawlLinks
Keyoti SearchUnit v6
Whether to store links found on a page before that page is crawled. Set false to conserve memory.
Declaration Syntax
C# Visual Basic
public bool CacheCrawlLinks { get; set; }
Public Property CacheCrawlLinks As Boolean
    Get
    Set
Property Value
Boolean
Remarks
Having this set true will reduce number of connections made to the server by half, and under normal conditions have minimal impact on memory. In cases where thousands of links occur on a page, this may cause higher memory consumption (order of hundred megabytes).


CaseSensitivity Property

CaseSensitivity Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► CaseSensitivity
Keyoti SearchUnit v6
The case sensitivity setting for building and searching.
Declaration Syntax
C# Visual Basic
[ObsoleteAttribute("All searches are case insensitive in v4.", true)]
public CaseSensitivity CaseSensitivity { get; set; }
<ObsoleteAttribute("All searches are case insensitive in v4.", true)>
Public Property CaseSensitivity As CaseSensitivity
    Get
    Set
Property Value
CaseSensitivity

Send comments on this topic to support@keyoti.com


CentralEventDispatcher Property

CentralEventDispatcher Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► CentralEventDispatcher
Keyoti SearchUnit v6
The centralized event dispatcher that will fire all central events.
Declaration Syntax
C# Visual Basic
public virtual CentralEventDispatcher CentralEventDispatcher { get; }
Public Overridable ReadOnly Property CentralEventDispatcher As CentralEventDispatcher
    Get
Property Value
CentralEventDispatcher
Remarks
Handle events from this object directly or through the EventHandlerAssemblyPath property.


CrawlSubdomains Property

CrawlSubdomains Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► CrawlSubdomains
Keyoti SearchUnit v6
Whether to let the crawler crawl [other] subdomains that it finds links to, otherwise the crawler will stay on the exact hostname that it started on.
Declaration Syntax
C# Visual Basic
public bool CrawlSubdomains { get; set; }
Public Property CrawlSubdomains As Boolean
    Get
    Set
Property Value
Boolean

Send comments on this topic to support@keyoti.com


CreateForwardIndex Property

CreateForwardIndex Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► CreateForwardIndex
Keyoti SearchUnit v6
Whether to create a 'forward index' which allows for result summary generation and result preview features.
Declaration Syntax
C# Visual Basic
public bool CreateForwardIndex { get; set; }
Public Property CreateForwardIndex As Boolean
    Get
    Set
Property Value
Boolean
Remarks
A 'forward index' is a list of words in a document. It allows the engine to recreate complete document texts or summary extracts. Setting this to false will mean faster indexing and searching, however the Configuration.ResultSummaryType must be set to a "Static" option, and cannot be "Dynamic". See the Help for more.


credentials Property

credentials Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► credentials
Keyoti SearchUnit v6
Map of web-site domain-names/server-names to usernames and passwords.
Declaration Syntax
C# Visual Basic
[ObsoleteAttribute("Use WebsiteCredentials instead - note different value type.",
    true)]
public Hashtable credentials { get; set; }
<ObsoleteAttribute("Use WebsiteCredentials instead - note different value type.",
    true)>
Public Property credentials As Hashtable
    Get
    Set
Property Value
Hashtable
Remarks
Key = domain-name/server-name.
            Value = 2 element string array, first element = username, second element = password.
            eg. credentials["ourdomain.com"] = new string[]{"username", "password"};


CurrentIndexVersion Field

CurrentIndexVersion Field
API Documentation ► Keyoti.SearchEngine ► Configuration ► CurrentIndexVersion
Keyoti SearchUnit v6
The index version that this build works with.
Declaration Syntax
C# Visual Basic
public const short CurrentIndexVersion
Public Const CurrentIndexVersion As Short
Field Value
Int16

Send comments on this topic to support@keyoti.com


CurrentMajorVersion Field

CurrentMajorVersion Field
API Documentation ► Keyoti.SearchEngine ► Configuration ► CurrentMajorVersion
Keyoti SearchUnit v6
The major version of this build.
Declaration Syntax
C# Visual Basic
public const short CurrentMajorVersion
Public Const CurrentMajorVersion As Short
Field Value
Int16

Send comments on this topic to support@keyoti.com


CustomDataFilterLiveDataMaximum Property

CustomDataFilterLiveDataMaximum Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► CustomDataFilterLiveDataMaximum
Keyoti SearchUnit v6
The maximum amount of live data to report with results to the client, for AJAX custom data filters.
Declaration Syntax
C# Visual Basic
public int CustomDataFilterLiveDataMaximum { get; set; }
Public Property CustomDataFilterLiveDataMaximum As Integer
    Get
    Set
Property Value
Int32

Send comments on this topic to support@keyoti.com


DataAccessExceptionsThreshold Property

DataAccessExceptionsThreshold Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► DataAccessExceptionsThreshold
Keyoti SearchUnit v6
Number of exceptions that will be tolerated in the data access layer.
Declaration Syntax
C# Visual Basic
[ObsoleteAttribute("Not relevant to the current version.", true)]
public int DataAccessExceptionsThreshold { get; set; }
<ObsoleteAttribute("Not relevant to the current version.", true)>
Public Property DataAccessExceptionsThreshold As Integer
    Get
    Set
Property Value
Int32

Send comments on this topic to support@keyoti.com


DbCommandTimeout Property

DbCommandTimeout Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► DbCommandTimeout
Keyoti SearchUnit v6
The number of seconds to set CommandTimeout to for MSSQL commands.
Declaration Syntax
C# Visual Basic
public int DbCommandTimeout { get; set; }
Public Property DbCommandTimeout As Integer
    Get
    Set
Property Value
Int32

Send comments on this topic to support@keyoti.com


DbImportPageSize Property

DbImportPageSize Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► DbImportPageSize
Keyoti SearchUnit v6
The number of records to read in each database import paging operation.
Declaration Syntax
C# Visual Basic
public int DbImportPageSize { get; set; }
Public Property DbImportPageSize As Integer
    Get
    Set
Property Value
Int32
Remarks
When the database import utility (DocumentImporter) is provided with an SQL query that returns 'pages' of results, this number will determine how many rows/records are pulled from the DB in each 'page'.


DbType Property

DbType Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► DbType
Keyoti SearchUnit v6
The storage method for the document index - possible values "sql" or "xml"
Declaration Syntax
C# Visual Basic
public string DbType { get; set; }
Public Property DbType As String
    Get
    Set
Property Value
String
Remarks
Currently, only xml is available.


DefaultPageNames Property

DefaultPageNames Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► DefaultPageNames
Keyoti SearchUnit v6
List of strings with default page names, these pages are synonomous with a URL ending in a directory.
Declaration Syntax
C# Visual Basic
public ArrayList DefaultPageNames { get; set; }
Public Property DefaultPageNames As ArrayList
    Get
    Set
Property Value
ArrayList
Remarks
If this list contains "default.aspx" for example, then http://localhost/default.aspx will be treated as equal to http://localhost/


DocumentWorkTimeout Property

DocumentWorkTimeout Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► DocumentWorkTimeout
Keyoti SearchUnit v6
The length of time, in milliseconds, until the document work times out
Declaration Syntax
C# Visual Basic
public int DocumentWorkTimeout { get; set; }
Public Property DocumentWorkTimeout As Integer
    Get
    Set
Property Value
Int32
Remarks
Since the search engine operates in a wild environment, where a web server can return potentially corrupt data, there is the possibility that the document parser will malfunction. To avoid processing a document for very long periods of time a default 10 minute timeout is applied. If the parser does not finish within the timeout period, it is stopped and the next document in the queue is processed. When logging is enabled, a message is written in the Document.txt file stating that the parser gave up.


ErrorPageRedir Property

ErrorPageRedir Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► ErrorPageRedir
Keyoti SearchUnit v6
Error page URL pattern
Declaration Syntax
C# Visual Basic
public string ErrorPageRedir { get; set; }
Public Property ErrorPageRedir As String
    Get
    Set
Property Value
String
Remarks
When a URL contains this string, it is considered to be an error page redirection (ie. as setup by the web.config) - this is important since it allows the crawler to know that the content is not to be indexed.


EventHandlerAssemblyPath Property

EventHandlerAssemblyPath Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► EventHandlerAssemblyPath
Keyoti SearchUnit v6
The absolute file path of an external assembly that will be automatically registered to handle operational events.
Declaration Syntax
C# Visual Basic
public string EventHandlerAssemblyPath { get; set; }
Public Property EventHandlerAssemblyPath As String
    Get
    Set
Property Value
String
Remarks
This provides a simple but powerful way to customize operational behavior coming from any part of the search system. See user guide for more info.


exceptionThresholds Property

exceptionThresholds Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► exceptionThresholds
Keyoti SearchUnit v6
Contains exception thresholds.
Declaration Syntax
C# Visual Basic
[ObsoleteAttribute("Please use Configuration.DataAccessExceptionsThreshold and Configuration.ReaderExceptionsThreshold instead.",
    true)]
public NameValueCollection exceptionThresholds { get; set; }
<ObsoleteAttribute("Please use Configuration.DataAccessExceptionsThreshold and Configuration.ReaderExceptionsThreshold instead.",
    true)>
Public Property exceptionThresholds As NameValueCollection
    Get
    Set
Property Value
NameValueCollection
Remarks
Possible names are; "dataAccessExceptionsThreshold" specifies the number of data access related exceptions that will be tolerated during crawling/indexing. "readerExceptionsThreshold" specifies the number of 'reader' related exceptions (ie WebExceptions) that will be tolerated during crawling/indexing. Values are Int32 objects.


ExpressionOperatorsCollection Property

ExpressionOperatorsCollection Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► ExpressionOperatorsCollection
Keyoti SearchUnit v6
Collection of logic operators, containing the default pair (AND,OR)
Declaration Syntax
C# Visual Basic
public ArrayList ExpressionOperatorsCollection { get; set; }
Public Property ExpressionOperatorsCollection As ArrayList
    Get
    Set
Property Value
ArrayList

Send comments on this topic to support@keyoti.com


FileTypesSettings Property

FileTypesSettings Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► FileTypesSettings
Keyoti SearchUnit v6
Maps mime-type strings to file extensions.
Declaration Syntax
C# Visual Basic
public StringDictionary FileTypesSettings { get; set; }
Public Property FileTypesSettings As StringDictionary
    Get
    Set
Property Value
StringDictionary
Remarks
The name is the extension (without "."), the value is the mime-type. Eg. FileTypesSettings.Add("HTML", "text/html")


ForceGCollectOnDocRead Field

ForceGCollectOnDocRead Field
API Documentation ► Keyoti.SearchEngine ► Configuration ► ForceGCollectOnDocRead
Keyoti SearchUnit v6
Whether to force a garbage collect before and after reading a document. ONLY set true when debugging memory issues.
Declaration Syntax
C# Visual Basic
public bool ForceGCollectOnDocRead
Public ForceGCollectOnDocRead As Boolean
Field Value
Boolean

Send comments on this topic to support@keyoti.com


GetApplicationDataFolderPath Method

GetApplicationDataFolderPath Method
API Documentation ► Keyoti.SearchEngine ► Configuration ► GetApplicationDataFolderPath()()()()
Keyoti SearchUnit v6
Returns the folder under LocalApplicationData where install info is stored.
Declaration Syntax
C# Visual Basic
public static string GetApplicationDataFolderPath()
Public Shared Function GetApplicationDataFolderPath As String
Return Value
String

Send comments on this topic to support@keyoti.com


GetMimeFromFileExtension Method (fileExtension)

GetMimeFromFileExtension Method (fileExtension)
API Documentation ► Keyoti.SearchEngine ► Configuration ► GetMimeFromFileExtension(String)
Keyoti SearchUnit v6
Returns the mime-type for a particular file extension, as per settings in fileTypesSettings
Declaration Syntax
C# Visual Basic
public virtual string GetMimeFromFileExtension(
    string fileExtension
)
Public Overridable Function GetMimeFromFileExtension (
    fileExtension As String
) As String
Parameters
fileExtension (String)
File extension without '.' char, eg. "html"
Return Value
String

Send comments on this topic to support@keyoti.com


IgnoreBlockBeginPattern Property

IgnoreBlockBeginPattern Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► IgnoreBlockBeginPattern
Keyoti SearchUnit v6
Pattern that marks the start of a block that should be ignored in the search process
Declaration Syntax
C# Visual Basic
public string IgnoreBlockBeginPattern { get; set; }
Public Property IgnoreBlockBeginPattern As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


IgnoreBlockEndPattern Property

IgnoreBlockEndPattern Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► IgnoreBlockEndPattern
Keyoti SearchUnit v6
Pattern that marks the end of a block that should be ignored in the search process
Declaration Syntax
C# Visual Basic
public string IgnoreBlockEndPattern { get; set; }
Public Property IgnoreBlockEndPattern As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


IgnoreCommonResourceTypes Property

IgnoreCommonResourceTypes Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► IgnoreCommonResourceTypes
Keyoti SearchUnit v6
Whether to ignore links to common resource types, eg. .jpg, .gif, .js.
Declaration Syntax
C# Visual Basic
public bool IgnoreCommonResourceTypes { get; set; }
Public Property IgnoreCommonResourceTypes As Boolean
    Get
    Set
Property Value
Boolean
Remarks
Setting this true (default) improves crawl speed but opens the possibility for false hits and the chance that pages will be ignored if URL rewriting is used (for example). Setting to false is safest but incurrs a speed penalty in the crawler.


IgnoreDiacritics Property

IgnoreDiacritics Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► IgnoreDiacritics
Keyoti SearchUnit v6
Whether to ignore diacritic marks, eg. treat 'é' in a word the same as 'e', so 'sake' will find 'saké' (default is true).
Declaration Syntax
C# Visual Basic
public bool IgnoreDiacritics { get; set; }
Public Property IgnoreDiacritics As Boolean
    Get
    Set
Property Value
Boolean

Send comments on this topic to support@keyoti.com


IgnoreLastModifiedDate Property

IgnoreLastModifiedDate Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► IgnoreLastModifiedDate
Keyoti SearchUnit v6
Whether to ignore the 'last modified date' returned from the server, during build operations.
Declaration Syntax
C# Visual Basic
public bool IgnoreLastModifiedDate { get; set; }
Public Property IgnoreLastModifiedDate As Boolean
    Get
    Set
Property Value
Boolean
Remarks
If this is false then files will not be indexed again if they have not changed since the last time they were indexed. It is recommended to set this to false, as this will prevent redundent reindexing. Setting true is useful after changing configuration settings as it will mean any document will be reindexed regardless of whether it changed according to the date - also see UseFileSizeToIdentifyChange.


IgnoreSSLErrors Property

IgnoreSSLErrors Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► IgnoreSSLErrors
Keyoti SearchUnit v6
Whether to ignore SSL issues on the website being imported - eg. expired certificate.
Declaration Syntax
C# Visual Basic
public bool IgnoreSSLErrors { get; set; }
Public Property IgnoreSSLErrors As Boolean
    Get
    Set
Property Value
Boolean
Remarks
If this is false then HTTPS websites with an expired certificate (for example) will not be importable.


ImpliedLogicOperator Property

ImpliedLogicOperator Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► ImpliedLogicOperator
Keyoti SearchUnit v6
The implied logic operator between query expression words.
Declaration Syntax
C# Visual Basic
public ImpliedLogicOperator ImpliedLogicOperator { get; set; }
Public Property ImpliedLogicOperator As ImpliedLogicOperator
    Get
    Set
Property Value
ImpliedLogicOperator
Remarks
When a query contains consecutive words without an explicit operator (eg. AND or OR) then this operator is assumed.


IndexDirectory Property

IndexDirectory Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► IndexDirectory
Keyoti SearchUnit v6
The path to the index directory - eg "c:\documentIndex"
Declaration Syntax
C# Visual Basic
public string IndexDirectory { get; set; }
Public Property IndexDirectory As String
    Get
    Set
Property Value
String
Remarks
The path to the folder that the index files should be stored in. This folder must already exist, and have write permission granted to the ASPNET user.


IndexedDocumentBufferSize Property

IndexedDocumentBufferSize Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► IndexedDocumentBufferSize
Keyoti SearchUnit v6
The number of documents to index to the memory buffer before writing to disk.
Declaration Syntax
C# Visual Basic
public int IndexedDocumentBufferSize { get; set; }
Public Property IndexedDocumentBufferSize As Integer
    Get
    Set
Property Value
Int32
Remarks
Default is 250.


IndexingInterval Property

IndexingInterval Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► IndexingInterval
Keyoti SearchUnit v6
The length of time in days that must pass before the document is re-indexed.
Declaration Syntax
C# Visual Basic
public int IndexingInterval { get; set; }
Public Property IndexingInterval As Integer
    Get
    Set
Property Value
Int32
Remarks
The minimum number of days that must pass before a document can be indexed again. This can be useful for sites with ASPX pages, that will always return last-modified-date today, regardless of whether the content has changed - settings this to 2 for example will mean that the page will not be reindexed unless 2 days have passed.


IndexNumbers Property

IndexNumbers Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► IndexNumbers
Keyoti SearchUnit v6
Whether to index numbers.
Declaration Syntax
C# Visual Basic
public bool IndexNumbers { get; set; }
Public Property IndexNumbers As Boolean
    Get
    Set
Property Value
Boolean
Remarks
Setting this true (default) means that number strings are indexed/searchable. Every unique number increases the lexicon size by one, therefore many unique numbers can decrease index performance - set to false if indexing files with lots of number strings.


LemmaLanguage Property

LemmaLanguage Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► LemmaLanguage
Keyoti SearchUnit v6
The language to look for lemmas in.
Declaration Syntax
C# Visual Basic
public Lemmas..::..StemmerLanguage LemmaLanguage { get; set; }
Public Property LemmaLanguage As Lemmas..::..StemmerLanguage
    Get
    Set
Property Value
Lemmas..::..StemmerLanguage

Send comments on this topic to support@keyoti.com


LemmaSearchEnabled Property

LemmaSearchEnabled Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► LemmaSearchEnabled
Keyoti SearchUnit v6
Whether to look for variations of query words, eg plural forms, see LemmaWeightFactor and LemmaLanguage also.
Declaration Syntax
C# Visual Basic
public bool LemmaSearchEnabled { get; set; }
Public Property LemmaSearchEnabled As Boolean
    Get
    Set
Property Value
Boolean

Send comments on this topic to support@keyoti.com


LemmaWeightFactor Property

LemmaWeightFactor Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► LemmaWeightFactor
Keyoti SearchUnit v6
Factor to adjust weight of lemma (word variations) matches.
Declaration Syntax
C# Visual Basic
public double LemmaWeightFactor { get; set; }
Public Property LemmaWeightFactor As Double
    Get
    Set
Property Value
Double
Remarks
Eg. if query = "table" then results with "table" will score higher than results with "tables".


LogFileMaxSize Property

LogFileMaxSize Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► LogFileMaxSize
Keyoti SearchUnit v6
The size in bytes at which log files are refreshed.
Declaration Syntax
C# Visual Basic
public int LogFileMaxSize { get; set; }
Public Property LogFileMaxSize As Integer
    Get
    Set
Property Value
Int32

Send comments on this topic to support@keyoti.com


Logging Property

Logging Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► Logging
Keyoti SearchUnit v6
Whether to log activity and errors to files stored in the index directory.
Declaration Syntax
C# Visual Basic
public bool Logging { get; set; }
Public Property Logging As Boolean
    Get
    Set
Property Value
Boolean

Send comments on this topic to support@keyoti.com


MaxDocumentSizeToIndex Property

MaxDocumentSizeToIndex Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► MaxDocumentSizeToIndex
Keyoti SearchUnit v6
Documents smaller than this number of kilobytes will be indexed, and documents larger than this will be skipped.
Declaration Syntax
C# Visual Basic
public int MaxDocumentSizeToIndex { get; set; }
Public Property MaxDocumentSizeToIndex As Integer
    Get
    Set
Property Value
Int32

Send comments on this topic to support@keyoti.com


MaximumCrawlDepth Property

MaximumCrawlDepth Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► MaximumCrawlDepth
Keyoti SearchUnit v6
Specifies the maximum 'link depth' that should be crawled.
Declaration Syntax
C# Visual Basic
public int MaximumCrawlDepth { get; set; }
Public Property MaximumCrawlDepth As Integer
    Get
    Set
Property Value
Int32
Remarks
This is useful for limiting the number of pages which will be crawled. Eg. if this is set to 2, then the crawler will only crawl the links found on the start page, and the links found on those linked pages.


MaxResponseHeaderLength Property

MaxResponseHeaderLength Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► MaxResponseHeaderLength
Keyoti SearchUnit v6
The length in kilobytes of the response headers. A value of -1 means no limit will be imposed on the response headers
Declaration Syntax
C# Visual Basic
public int MaxResponseHeaderLength { get; set; }
Public Property MaxResponseHeaderLength As Integer
    Get
    Set
Property Value
Int32

Send comments on this topic to support@keyoti.com


OnNotifyPropertyChanged Method (info)

OnNotifyPropertyChanged Method (info)
API Documentation ► Keyoti.SearchEngine ► Configuration ► OnNotifyPropertyChanged(String)
Keyoti SearchUnit v6
Fires the PropertyChanged event.
Declaration Syntax
C# Visual Basic
protected virtual void OnNotifyPropertyChanged(
    string info
)
Protected Overridable Sub OnNotifyPropertyChanged (
    info As String
)
Parameters
info (String)
The name of the property that changed.


ParseMSWordDocUsingIFilter Property

ParseMSWordDocUsingIFilter Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► ParseMSWordDocUsingIFilter
Keyoti SearchUnit v6
Whether to parse MS Word .doc files using the Windows IFilter (COM interop), if false the pure .NET parser is used (default false).
Declaration Syntax
C# Visual Basic
public bool ParseMSWordDocUsingIFilter { get; set; }
Public Property ParseMSWordDocUsingIFilter As Boolean
    Get
    Set
Property Value
Boolean
Remarks
If the default parser cannot parse certain Word documents, set this to true.


ParseRTFDocUsingIFilter Property

ParseRTFDocUsingIFilter Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► ParseRTFDocUsingIFilter
Keyoti SearchUnit v6
Whether to use the built-in Windows IFilter to parse RTF files. Default is true.
Declaration Syntax
C# Visual Basic
public bool ParseRTFDocUsingIFilter { get; set; }
Public Property ParseRTFDocUsingIFilter As Boolean
    Get
    Set
Property Value
Boolean
Remarks
When set false, the built-in 100% managed RTF parser is used to parse RTF files, this parser may have trouble with right to left files..


PdfDocumentTitleSource Property

PdfDocumentTitleSource Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► PdfDocumentTitleSource
Keyoti SearchUnit v6
Where the title of a Pdf document is obtained from.
Declaration Syntax
C# Visual Basic
public PdfDocumentTitleSource PdfDocumentTitleSource { get; set; }
Public Property PdfDocumentTitleSource As PdfDocumentTitleSource
    Get
    Set
Property Value
PdfDocumentTitleSource
Remarks
Some Pdf documents have valid /Title tags in them, holding a useful title, however many do not. Use this to set whether the internal title field is used or the filename.


PropertyChanged Event

PropertyChanged Event
API Documentation ► Keyoti.SearchEngine ► Configuration ► PropertyChanged
Keyoti SearchUnit v6
Fired when a property value changes.
Declaration Syntax
C# Visual Basic
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler
Value
PropertyChangedEventHandler

Send comments on this topic to support@keyoti.com


ProxyAddress Property

ProxyAddress Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► ProxyAddress
Keyoti SearchUnit v6
The address of a proxy server to use to make outbound connections during indexing. Leave empty to not use a proxy.
Declaration Syntax
C# Visual Basic
public string ProxyAddress { get; set; }
Public Property ProxyAddress As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


ProxyPort Property

ProxyPort Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► ProxyPort
Keyoti SearchUnit v6
The port to connect to the proxy server on (if a proxy is used).
Declaration Syntax
C# Visual Basic
public int ProxyPort { get; set; }
Public Property ProxyPort As Integer
    Get
    Set
Property Value
Int32

Send comments on this topic to support@keyoti.com


ReadDocumentInNewThread Property

ReadDocumentInNewThread Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► ReadDocumentInNewThread
Keyoti SearchUnit v6
The number of documents to index to the memory buffer before writing to disk.
Declaration Syntax
C# Visual Basic
public bool ReadDocumentInNewThread { get; set; }
Public Property ReadDocumentInNewThread As Boolean
    Get
    Set
Property Value
Boolean
Remarks
Default is true.


ReaderExceptionsThreshold Property

ReaderExceptionsThreshold Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► ReaderExceptionsThreshold
Keyoti SearchUnit v6
Number of exceptions that will be tolerated in the reader layer.
Declaration Syntax
C# Visual Basic
public int ReaderExceptionsThreshold { get; set; }
Public Property ReaderExceptionsThreshold As Integer
    Get
    Set
Property Value
Int32

Send comments on this topic to support@keyoti.com


ReadGlobalConfigKey Method (key)

ReadGlobalConfigKey Method (key)
API Documentation ► Keyoti.SearchEngine ► Configuration ► ReadGlobalConfigKey(String)
Keyoti SearchUnit v6
Reads a value from the global install config (located under the user's application data folder).
Declaration Syntax
C# Visual Basic
public static string ReadGlobalConfigKey(
    string key
)
Public Shared Function ReadGlobalConfigKey (
    key As String
) As String
Parameters
key (String)
Return Value
String

Send comments on this topic to support@keyoti.com


RequestThrottle Property

RequestThrottle Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► RequestThrottle
Keyoti SearchUnit v6
The length of time, in milliseconds, that the application will wait before each request is made, in order to limit the server load.
Declaration Syntax
C# Visual Basic
public int RequestThrottle { get; set; }
Public Property RequestThrottle As Integer
    Get
    Set
Property Value
Int32
Remarks
By default this is zero, which is for fastest operation. If the import or index operation is placing too much load on the target server, then increasing this value should lower the load. Higher numbers result in slower import and indexing operations, but do not effect search.


RequestTimeout Property

RequestTimeout Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► RequestTimeout
Keyoti SearchUnit v6
The length of time, in milliseconds, until the request times out
Declaration Syntax
C# Visual Basic
public int RequestTimeout { get; set; }
Public Property RequestTimeout As Integer
    Get
    Set
Property Value
Int32
Remarks
The number of milliseconds to wait for a response from the web-server being crawled/indexed. Typically this is best around 30000 milliseconds.


RespectsRobotsMetaTags Property

RespectsRobotsMetaTags Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► RespectsRobotsMetaTags
Keyoti SearchUnit v6
Whether to consider the robots meta tags (noindex, nofollow).
Declaration Syntax
C# Visual Basic
public bool RespectsRobotsMetaTags { get; set; }
Public Property RespectsRobotsMetaTags As Boolean
    Get
    Set
Property Value
Boolean

Send comments on this topic to support@keyoti.com


RespectsRobotsTXT Property

RespectsRobotsTXT Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► RespectsRobotsTXT
Keyoti SearchUnit v6
Whether to consider the robots.txt specifications
Declaration Syntax
C# Visual Basic
public bool RespectsRobotsTXT { get; set; }
Public Property RespectsRobotsTXT As Boolean
    Get
    Set
Property Value
Boolean

Send comments on this topic to support@keyoti.com


ResultSummaryType Property

ResultSummaryType Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► ResultSummaryType
Keyoti SearchUnit v6
The type of summary that will be shown.
Declaration Syntax
C# Visual Basic
public ResultSummaryType ResultSummaryType { get; set; }
Public Property ResultSummaryType As ResultSummaryType
    Get
    Set
Property Value
ResultSummaryType

Send comments on this topic to support@keyoti.com


ServiceRebuildFrequency Property

ServiceRebuildFrequency Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► ServiceRebuildFrequency
Keyoti SearchUnit v6
Indexing interval (hours)
Declaration Syntax
C# Visual Basic
public int ServiceRebuildFrequency { get; set; }
Public Property ServiceRebuildFrequency As Integer
    Get
    Set
Property Value
Int32
Remarks
Sets how many hours should pass since the last index operation before reindexing is performed. Eg. if indexing is first started at 1am, and this is set to 24, then indexing will be performed every morning at 1am. If this were set to 72, then indexing would happen every 3 days.


ServiceRebuildHour Property

ServiceRebuildHour Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► ServiceRebuildHour
Keyoti SearchUnit v6
The hour when the reindexing will start (int hour, 0-23)
Declaration Syntax
C# Visual Basic
public int ServiceRebuildHour { get; set; }
Public Property ServiceRebuildHour As Integer
    Get
    Set
Property Value
Int32
Remarks
The hour of the day at which the first indexing operation will happen. Eg. if this is set to 1, then the index will be built at 1am - further, if the frequency is set to 6, then indexing will start at 1am, and be performed at 7am, 1pm, 7pm and again at 1am and so on.


ServiceWillOptimizeIndex Property

ServiceWillOptimizeIndex Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► ServiceWillOptimizeIndex
Keyoti SearchUnit v6
Whether the service should automatically optimize the index for searching.
Declaration Syntax
C# Visual Basic
public bool ServiceWillOptimizeIndex { get; set; }
Public Property ServiceWillOptimizeIndex As Boolean
    Get
    Set
Property Value
Boolean

Send comments on this topic to support@keyoti.com


ServiceWillSendEmailLog Property

ServiceWillSendEmailLog Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► ServiceWillSendEmailLog
Keyoti SearchUnit v6
Whether the service should send an email log after it has run.
Declaration Syntax
C# Visual Basic
public bool ServiceWillSendEmailLog { get; set; }
Public Property ServiceWillSendEmailLog As Boolean
    Get
    Set
Property Value
Boolean

Send comments on this topic to support@keyoti.com


SmtpEmailFrom Property

SmtpEmailFrom Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► SmtpEmailFrom
Keyoti SearchUnit v6
The email from address that the log will be sent 'from'.
Declaration Syntax
C# Visual Basic
public string SmtpEmailFrom { get; set; }
Public Property SmtpEmailFrom As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


SmtpEmailTo Property

SmtpEmailTo Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► SmtpEmailTo
Keyoti SearchUnit v6
The email from address that the log will be sent to.
Declaration Syntax
C# Visual Basic
public string SmtpEmailTo { get; set; }
Public Property SmtpEmailTo As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


SmtpMailServer Property

SmtpMailServer Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► SmtpMailServer
Keyoti SearchUnit v6
The email server to use to send email with service run logs.
Declaration Syntax
C# Visual Basic
public string SmtpMailServer { get; set; }
Public Property SmtpMailServer As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


SmtpPassword Property

SmtpPassword Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► SmtpPassword
Keyoti SearchUnit v6
The email server password if required. Password will be encrypted and the unencrypted form is not available from configuration files or API.
Declaration Syntax
C# Visual Basic
public string SmtpPassword { get; set; }
Public Property SmtpPassword As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


SmtpServerPort Property

SmtpServerPort Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► SmtpServerPort
Keyoti SearchUnit v6
The email server port number to use to send email with service run logs.
Declaration Syntax
C# Visual Basic
public int SmtpServerPort { get; set; }
Public Property SmtpServerPort As Integer
    Get
    Set
Property Value
Int32

Send comments on this topic to support@keyoti.com


SmtpUsername Property

SmtpUsername Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► SmtpUsername
Keyoti SearchUnit v6
The email server username if required.
Declaration Syntax
C# Visual Basic
public string SmtpUsername { get; set; }
Public Property SmtpUsername As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


StopWords Property

StopWords Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► StopWords
Keyoti SearchUnit v6
List of 'common' words which are not searchable.
Declaration Syntax
C# Visual Basic
public StringList StopWords { get; }
Public ReadOnly Property StopWords As StringList
    Get
Property Value
StringList

Send comments on this topic to support@keyoti.com


SummaryTextSplitter Property

SummaryTextSplitter Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► SummaryTextSplitter
Keyoti SearchUnit v6
The string used to split apart summary text from different parts of the result document, default is '...'.
Declaration Syntax
C# Visual Basic
public string SummaryTextSplitter { get; set; }
Public Property SummaryTextSplitter As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


SummaryWordLength Property

SummaryWordLength Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► SummaryWordLength
Keyoti SearchUnit v6
Number of words to show in result summaries.
Declaration Syntax
C# Visual Basic
public int SummaryWordLength { get; set; }
Public Property SummaryWordLength As Integer
    Get
    Set
Property Value
Int32

Send comments on this topic to support@keyoti.com


URLCaseSensitive Property

URLCaseSensitive Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► URLCaseSensitive
Keyoti SearchUnit v6
Whether, during indexing, to compare URLs in a case sensitive manner (default is false) - some web servers are case sensitive, IIS is not.
Declaration Syntax
C# Visual Basic
public bool URLCaseSensitive { get; set; }
Public Property URLCaseSensitive As Boolean
    Get
    Set
Property Value
Boolean

Send comments on this topic to support@keyoti.com


UseFileSizeToIdentifyChange Property

UseFileSizeToIdentifyChange Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► UseFileSizeToIdentifyChange
Keyoti SearchUnit v6
Whether to use the file size of a document to identify if it has been changed or not since it was last indexed (also see IgnoreLastModifiedDate).
Declaration Syntax
C# Visual Basic
public bool UseFileSizeToIdentifyChange { get; set; }
Public Property UseFileSizeToIdentifyChange As Boolean
    Get
    Set
Property Value
Boolean
Remarks
Ideally the last-modified date of a document would always be used to identify if it has changed (see IgnoreLastModifiedDate property), however web-servers do not always return this information. Further, dynamic pages do not have 'last-modified' dates, since they are dynamic.

The byte size of a document can however be used to identify change with reasonable accuracy. If a document has a different file size, then it has definitely changed. Of course, it is also possible for a document to change, but have the same size (exactly the same number of letters are deleted as added, for example), so this is not 100% accurate.

Despite not having 100% accuracy, it may be desirable to forgo accuracy for performance, by setting this to true.


UserAgent Property

UserAgent Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► UserAgent
Keyoti SearchUnit v6
The user agent that the search engine identifies itself to the server as.
Declaration Syntax
C# Visual Basic
public string UserAgent { get; set; }
Public Property UserAgent As String
    Get
    Set
Property Value
String
Remarks
Warning - changing this can alter the way that ASP.NET renders pages.


WebProxy Property

WebProxy Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► WebProxy
Keyoti SearchUnit v6
Proxy object to use for connections. Setting can speed up access to external servers.
Declaration Syntax
C# Visual Basic
public IWebProxy WebProxy { get; set; }
Public Property WebProxy As IWebProxy
    Get
    Set
Property Value
IWebProxy

Send comments on this topic to support@keyoti.com


WebProxySet Property

WebProxySet Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► WebProxySet
Keyoti SearchUnit v6
Whether a proxy has been set.
Declaration Syntax
C# Visual Basic
public bool WebProxySet { get; }
Public ReadOnly Property WebProxySet As Boolean
    Get
Property Value
Boolean

Send comments on this topic to support@keyoti.com


WebsiteCredentials Property

WebsiteCredentials Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► WebsiteCredentials
Keyoti SearchUnit v6
Map of web-site domain-names/server-names to usernames and passwords.
Declaration Syntax
C# Visual Basic
public Hashtable WebsiteCredentials { get; set; }
Public Property WebsiteCredentials As Hashtable
    Get
    Set
Property Value
Hashtable
Remarks
Key = domain-name/server-name.
            Value = instance of ResourceCredentials.
            eg. Credentials["ourdomain.com"] = new ResourceCredentials("username", "password");


WordBreakingCharacters Property

WordBreakingCharacters Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► WordBreakingCharacters
Keyoti SearchUnit v6
Characters that will not be considered parts of 'words' and will break a string apart. Any space characters will be ignored.
Declaration Syntax
C# Visual Basic
public string WordBreakingCharacters { get; set; }
Public Property WordBreakingCharacters As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


WordNonBreakingCharacters Property

WordNonBreakingCharacters Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► WordNonBreakingCharacters
Keyoti SearchUnit v6
Characters that will be considered parts of 'words' and not break a string apart. Eg. To be able to search for strings like my_email@blah.com - ensure that @ . and _ are in this list of characters. Any space characters will be ignored.
Declaration Syntax
C# Visual Basic
public string WordNonBreakingCharacters { get; set; }
Public Property WordNonBreakingCharacters As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


WordsAroundNumber Property

WordsAroundNumber Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► WordsAroundNumber
Keyoti SearchUnit v6
Number of words to show around non-continguous summary occurrences.
Declaration Syntax
C# Visual Basic
public int WordsAroundNumber { get; set; }
Public Property WordsAroundNumber As Integer
    Get
    Set
Property Value
Int32

Send comments on this topic to support@keyoti.com


WordWeightFactorBody Property

WordWeightFactorBody Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► WordWeightFactorBody
Keyoti SearchUnit v6
The weighting factor given to words in the document body - increase to make words in the body text more important.
Declaration Syntax
C# Visual Basic
public int WordWeightFactorBody { get; set; }
Public Property WordWeightFactorBody As Integer
    Get
    Set
Property Value
Int32

Send comments on this topic to support@keyoti.com


WordWeightFactorTitle Property

WordWeightFactorTitle Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► WordWeightFactorTitle
Keyoti SearchUnit v6
The weighting factor given to words in the document title - increase to make words in the title text more important.
Declaration Syntax
C# Visual Basic
public int WordWeightFactorTitle { get; set; }
Public Property WordWeightFactorTitle As Integer
    Get
    Set
Property Value
Int32

Send comments on this topic to support@keyoti.com


WordWeightFactorUrl Property

WordWeightFactorUrl Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► WordWeightFactorUrl
Keyoti SearchUnit v6
The weighting factor given to words in the document title - increase to make words in the URL more important.
Declaration Syntax
C# Visual Basic
public int WordWeightFactorUrl { get; set; }
Public Property WordWeightFactorUrl As Integer
    Get
    Set
Property Value
Int32

Send comments on this topic to support@keyoti.com


xmlLocation Property

xmlLocation Property
API Documentation ► Keyoti.SearchEngine ► Configuration ► xmlLocation
Keyoti SearchUnit v6
The path to the XML document index directory - eg "c:\documentIndex"
Declaration Syntax
C# Visual Basic
[ObsoleteAttribute("Use IndexDirectory property instead - it is equivalent.",
    true)]
public string xmlLocation { get; set; }
<ObsoleteAttribute("Use IndexDirectory property instead - it is equivalent.",
    true)>
Public Property xmlLocation As String
    Get
    Set
Property Value
String
Remarks
The path to the folder that the index files should be stored in. This folder must already exist, and have write permission granted to the ASPNET user.


ConfigurationManager Class

ConfigurationManager Class
API Documentation ► Keyoti.SearchEngine ► ConfigurationManager
Keyoti SearchUnit v6
Retrieves settings from Configuration.xml file and fills a Configuration instance.
Declaration Syntax
C# Visual Basic
public class ConfigurationManager
Public Class ConfigurationManager
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ConfigurationManager(String) | Creates a new instance.
 | CleanCollections(Configuration, Boolean, Configuration) | Clears all config collections
 | CreateConfigurationXmlWithDefaultSettings(String) | Creates Configuration.xml file, if it doesn't exist. Write in default settings
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetConfigurationProperties()()()() | Returns a hashtable of configuration properties in their corresponding category
 | GetDataAccess(Configuration) | The data-access layer, the type returned depends on the setting of Configuration.DbType.
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | RetrieveConfiguration()()()() | Obsolete. Loads the configuration settings in Configuration.xml into the Configuration instance
 | RetrieveConfiguration(Configuration) | Loads the configuration settings in Configuration.xml into the Configuration instance
 | RetrieveConfiguration(Configuration, Boolean) | Loads the configuration settings in Configuration.xml into the Configuration instance
 | SaveSettings(Configuration) | Saves the new edited settings (from Configuration object) to configuration.xml
 | ToString()()()() | (Inherited from Object.)
 | ValidateConfiguration(Configuration) | Checks whether the minimum configuration settings are valid.
Remarks
Provides a simple way to persist and retrieve Configuration settings.
Examples
Load configuration from XML file.
Copy image Copy
ConfigurationManager cm = new ConfigurationManager( Server.MapPath("config.xml") );
Configuration configuration = cm.RetrieveConfiguration();
Examples
Save configuration properties set in the Configuration class to config.xml
Copy image Copy
ConfigurationManager cm = new ConfigurationManager( Server.MapPath("config.xml") );
            cm.SaveSettings(configuration);
- Note the config.xml file must have write permission for ASPNET user in web environments.
Inheritance Hierarchy
Object
ConfigurationManager

Send comments on this topic to support@keyoti.com


ConfigurationManager Constructor (indexDirectoryPath)

ConfigurationManager Constructor (indexDirectoryPath)
API Documentation ► Keyoti.SearchEngine ► ConfigurationManager ► ConfigurationManager(String)
Keyoti SearchUnit v6
Creates a new instance.
Declaration Syntax
C# Visual Basic
public ConfigurationManager(
    string indexDirectoryPath
)
Public Sub New (
    indexDirectoryPath As String
)
Parameters
indexDirectoryPath (String)
The index directory path
Remarks
If a configuration.xml file isn't found, it is created with default settings.


CleanCollections Method (configuration, overwrite, defaultInstance)

CleanCollections Method (configuration, overwrite, defaultInstance)
API Documentation ► Keyoti.SearchEngine ► ConfigurationManager ► CleanCollections(Configuration, Boolean, Configuration)
Keyoti SearchUnit v6
Clears all config collections
Declaration Syntax
C# Visual Basic
public void CleanCollections(
    Configuration configuration,
    bool overwrite,
    Configuration defaultInstance
)
Public Sub CleanCollections (
    configuration As Configuration,
    overwrite As Boolean,
    defaultInstance As Configuration
)
Parameters
configuration (Configuration)
overwrite (Boolean)
defaultInstance (Configuration)


CreateConfigurationXmlWithDefaultSettings Method (indexDir)

CreateConfigurationXmlWithDefaultSettings Method (indexDir)
API Documentation ► Keyoti.SearchEngine ► ConfigurationManager ► CreateConfigurationXmlWithDefaultSettings(String)
Keyoti SearchUnit v6
Creates Configuration.xml file, if it doesn't exist. Write in default settings
Declaration Syntax
C# Visual Basic
public void CreateConfigurationXmlWithDefaultSettings(
    string indexDir
)
Public Sub CreateConfigurationXmlWithDefaultSettings (
    indexDir As String
)
Parameters
indexDir (String)


GetConfigurationProperties Method

GetConfigurationProperties Method
API Documentation ► Keyoti.SearchEngine ► ConfigurationManager ► GetConfigurationProperties()()()()
Keyoti SearchUnit v6
Returns a hashtable of configuration properties in their corresponding category
Declaration Syntax
C# Visual Basic
public static Hashtable GetConfigurationProperties()
Public Shared Function GetConfigurationProperties As Hashtable
Return Value
Hashtable
Key = "Category" Value = ArrayList of PropertyInfo objs in that category


GetDataAccess Method (c)

GetDataAccess Method (c)
API Documentation ► Keyoti.SearchEngine ► ConfigurationManager ► GetDataAccess(Configuration)
Keyoti SearchUnit v6
The data-access layer, the type returned depends on the setting of Configuration.DbType.
Declaration Syntax
C# Visual Basic
public virtual XmlDataAccess GetDataAccess(
    Configuration c
)
Public Overridable Function GetDataAccess (
    c As Configuration
) As XmlDataAccess
Parameters
c (Configuration)
Return Value
XmlDataAccess

Send comments on this topic to support@keyoti.com


RetrieveConfiguration Method

RetrieveConfiguration Method
API Documentation ► Keyoti.SearchEngine ► ConfigurationManager ► RetrieveConfiguration()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | RetrieveConfiguration()()()() | Obsolete. Loads the configuration settings in Configuration.xml into the Configuration instance
 | RetrieveConfiguration(Configuration) | Loads the configuration settings in Configuration.xml into the Configuration instance
 | RetrieveConfiguration(Configuration, Boolean) | Loads the configuration settings in Configuration.xml into the Configuration instance


RetrieveConfiguration Method

RetrieveConfiguration Method
API Documentation ► Keyoti.SearchEngine ► ConfigurationManager ► RetrieveConfiguration()()()()
Keyoti SearchUnit v6
Loads the configuration settings in Configuration.xml into the Configuration instance
Declaration Syntax
C# Visual Basic
[ObsoleteAttribute("Use RetrieveConfiguration(Configuration) overload instead.",
    false)]
public Configuration RetrieveConfiguration()
<ObsoleteAttribute("Use RetrieveConfiguration(Configuration) overload instead.",
    false)>
Public Function RetrieveConfiguration As Configuration
Return Value
Configuration
The instance of the Configuration class that holds the settings to be used.


RetrieveConfiguration Method (configuration)

RetrieveConfiguration Method (configuration)
API Documentation ► Keyoti.SearchEngine ► ConfigurationManager ► RetrieveConfiguration(Configuration)
Keyoti SearchUnit v6
Loads the configuration settings in Configuration.xml into the Configuration instance
Declaration Syntax
C# Visual Basic
public void RetrieveConfiguration(
    Configuration configuration
)
Public Sub RetrieveConfiguration (
    configuration As Configuration
)
Parameters
configuration (Configuration)
The Configuration instance to load the settings into.
Return Value

The instance of the Configuration class that holds the settings to be used.


RetrieveConfiguration Method (configuration, overwriteNonDefaultSettings)

RetrieveConfiguration Method (configuration, overwriteNonDefaultSettings)
API Documentation ► Keyoti.SearchEngine ► ConfigurationManager ► RetrieveConfiguration(Configuration, Boolean)
Keyoti SearchUnit v6
Loads the configuration settings in Configuration.xml into the Configuration instance
Declaration Syntax
C# Visual Basic
public void RetrieveConfiguration(
    Configuration configuration,
    bool overwriteNonDefaultSettings
)
Public Sub RetrieveConfiguration (
    configuration As Configuration,
    overwriteNonDefaultSettings As Boolean
)
Parameters
configuration (Configuration)
The Configuration instance to load the settings into.
overwriteNonDefaultSettings (Boolean)
Whether to overwrite any property settings that are not equal to default values - setting this arg to false means that any properties that you have changed will be preserved and not use the value from the configuration.xml file.
Return Value

The instance of the Configuration class that holds the settings to be used.


SaveSettings Method (configuration)

SaveSettings Method (configuration)
API Documentation ► Keyoti.SearchEngine ► ConfigurationManager ► SaveSettings(Configuration)
Keyoti SearchUnit v6
Saves the new edited settings (from Configuration object) to configuration.xml
Declaration Syntax
C# Visual Basic
public void SaveSettings(
    Configuration configuration
)
Public Sub SaveSettings (
    configuration As Configuration
)
Parameters
configuration (Configuration)


ValidateConfiguration Method (Configuration)

ValidateConfiguration Method (Configuration)
API Documentation ► Keyoti.SearchEngine ► ConfigurationManager ► ValidateConfiguration(Configuration)
Keyoti SearchUnit v6
Checks whether the minimum configuration settings are valid.
Declaration Syntax
C# Visual Basic
public bool ValidateConfiguration(
    Configuration Configuration
)
Public Function ValidateConfiguration (
    Configuration As Configuration
) As Boolean
Parameters
Configuration (Configuration)
Return Value
Boolean

Send comments on this topic to support@keyoti.com


ConfigurationPropertyAttribute Class

ConfigurationPropertyAttribute Class
API Documentation ► Keyoti.SearchEngine ► ConfigurationPropertyAttribute
Keyoti SearchUnit v6
Property member attribute used to declare which properties of the Configuration class are used as search operation (spider, index, search) settings.
Declaration Syntax
C# Visual Basic
public class ConfigurationPropertyAttribute : Attribute
Public Class ConfigurationPropertyAttribute
    Inherits Attribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigurationPropertyAttribute(String, String, String) | Creates an instance
 | ConfigurationPropertyAttribute(String, String, String, Boolean) | Creates an instance
 | ConfigurationPropertyAttribute(String, String, String, Boolean, Boolean) | Creates an instance
 | ConfigurationPropertyAttribute(String, String, String, ConfigurationPropertyAttribute..::..DataType, String, String, String, Boolean) | Creates an instance
 | ConfigurationPropertyAttribute(String, String, String, ConfigurationPropertyAttribute..::..DataType, String, String, String) | Creates an instance
 | ConfigurationPropertyAttribute(String, String, String, ConfigurationPropertyAttribute..::..DataType, String, String, String, Type) | Creates an instance
 | ConfigurationPropertyAttribute(String, String, String, ConfigurationPropertyAttribute..::..DataType, String, String, String, Type, Boolean) | Creates an instance
 | Category | The property category.
 | ChangeAffectsIndexState | Whether a change to this property affects the index state.
 | ChildElementName | The name of the child element for a collection
 | ChildType | The type child object.
 | Equals(Object) | (Inherited from Attribute.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Attribute.)
 | GetType()()()() | (Inherited from Object.)
 | HelpText | Any text that can be given to the user as help for this property.
 | IsDefaultAttribute()()()() | (Inherited from Attribute.)
 | IsPassword | Whether this property is a password that should be protected.
 | KeyAttributeName | The name of the attribute holding the collection key
 | Match(Object) | (Inherited from Attribute.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Note | Any note about setting this property - eg. requires recrawl.
 | PropertyDataType | The type of property
 | ToString()()()() | (Inherited from Object.)
 | TypeId | (Inherited from Attribute.)
 | ValueAttributeName | The name of the attribute holding the collection value
Inheritance Hierarchy
Object
 | Attribute
 |  | ConfigurationPropertyAttribute


ConfigurationPropertyAttribute Constructor

ConfigurationPropertyAttribute Constructor
API Documentation ► Keyoti.SearchEngine ► ConfigurationPropertyAttribute ► ConfigurationPropertyAttribute()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | ConfigurationPropertyAttribute(String, String, String) | Creates an instance
 | ConfigurationPropertyAttribute(String, String, String, Boolean) | Creates an instance
 | ConfigurationPropertyAttribute(String, String, String, Boolean, Boolean) | Creates an instance
 | ConfigurationPropertyAttribute(String, String, String, ConfigurationPropertyAttribute..::..DataType, String, String, String, Boolean) | Creates an instance
 | ConfigurationPropertyAttribute(String, String, String, ConfigurationPropertyAttribute..::..DataType, String, String, String) | Creates an instance
 | ConfigurationPropertyAttribute(String, String, String, ConfigurationPropertyAttribute..::..DataType, String, String, String, Type) | Creates an instance
 | ConfigurationPropertyAttribute(String, String, String, ConfigurationPropertyAttribute..::..DataType, String, String, String, Type, Boolean) | Creates an instance


ConfigurationPropertyAttribute Constructor (category, helpText, note)

ConfigurationPropertyAttribute Constructor (category, helpText, note)
API Documentation ► Keyoti.SearchEngine ► ConfigurationPropertyAttribute ► ConfigurationPropertyAttribute(String, String, String)
Keyoti SearchUnit v6
Creates an instance
Declaration Syntax
C# Visual Basic
public ConfigurationPropertyAttribute(
    string category,
    string helpText,
    string note
)
Public Sub New (
    category As String,
    helpText As String,
    note As String
)
Parameters
category (String)
The category of the configuration property
helpText (String)
Any text that can be given to the user as help for this property.
note (String)
Note for the end user

Send comments on this topic to support@keyoti.com


ConfigurationPropertyAttribute Constructor (category, helpText, note, type, keyAttributeName, valueAttributeName, childElementName)

ConfigurationPropertyAttribute Constructor (category, helpText, note, type, keyAttributeName, valueAttributeName, childElementName)
API Documentation ► Keyoti.SearchEngine ► ConfigurationPropertyAttribute ► ConfigurationPropertyAttribute(String, String, String, ConfigurationPropertyAttribute..::..DataType, String, String, String)
Keyoti SearchUnit v6
Creates an instance
Declaration Syntax
C# Visual Basic
public ConfigurationPropertyAttribute(
    string category,
    string helpText,
    string note,
    ConfigurationPropertyAttribute..::..DataType type,
    string keyAttributeName,
    string valueAttributeName,
    string childElementName
)
Public Sub New (
    category As String,
    helpText As String,
    note As String,
    type As ConfigurationPropertyAttribute..::..DataType,
    keyAttributeName As String,
    valueAttributeName As String,
    childElementName As String
)
Parameters
category (String)
The category of the configuration property
helpText (String)
Any text that can be given to the user as help for this property.
note (String)
Note for the end user
type (ConfigurationPropertyAttribute..::..DataType)
The type of child element
keyAttributeName (String)
The attribute specifying the key
valueAttributeName (String)
The attribute holding the value
childElementName (String)
The name of the child element in the Xml file


ConfigurationPropertyAttribute Constructor (category, helpText, note, type, keyAttributeName, valueAttributeName, childElementName, changeAffectsIndexState)

ConfigurationPropertyAttribute Constructor (category, helpText, note, type, keyAttributeName, valueAttributeName, childElementName, changeAffectsIndexState)
API Documentation ► Keyoti.SearchEngine ► ConfigurationPropertyAttribute ► ConfigurationPropertyAttribute(String, String, String, ConfigurationPropertyAttribute..::..DataType, String, String, String, Boolean)
Keyoti SearchUnit v6
Creates an instance
Declaration Syntax
C# Visual Basic
public ConfigurationPropertyAttribute(
    string category,
    string helpText,
    string note,
    ConfigurationPropertyAttribute..::..DataType type,
    string keyAttributeName,
    string valueAttributeName,
    string childElementName,
    bool changeAffectsIndexState
)
Public Sub New (
    category As String,
    helpText As String,
    note As String,
    type As ConfigurationPropertyAttribute..::..DataType,
    keyAttributeName As String,
    valueAttributeName As String,
    childElementName As String,
    changeAffectsIndexState As Boolean
)
Parameters
category (String)
The category of the configuration property
helpText (String)
Any text that can be given to the user as help for this property.
note (String)
Note for the end user
type (ConfigurationPropertyAttribute..::..DataType)
The type of child element
keyAttributeName (String)
The attribute specifying the key
valueAttributeName (String)
The attribute holding the value
childElementName (String)
The name of the child element in the Xml file
changeAffectsIndexState (Boolean)
Whether the index needs to be rebuilt after changing this property


ConfigurationPropertyAttribute Constructor (category, helpText, note, type, keyAttributeName, valueAttributeName, childElementName, childType)

ConfigurationPropertyAttribute Constructor (category, helpText, note, type, keyAttributeName, valueAttributeName, childElementName, childType)
API Documentation ► Keyoti.SearchEngine ► ConfigurationPropertyAttribute ► ConfigurationPropertyAttribute(String, String, String, ConfigurationPropertyAttribute..::..DataType, String, String, String, Type)
Keyoti SearchUnit v6
Creates an instance
Declaration Syntax
C# Visual Basic
public ConfigurationPropertyAttribute(
    string category,
    string helpText,
    string note,
    ConfigurationPropertyAttribute..::..DataType type,
    string keyAttributeName,
    string valueAttributeName,
    string childElementName,
    Type childType
)
Public Sub New (
    category As String,
    helpText As String,
    note As String,
    type As ConfigurationPropertyAttribute..::..DataType,
    keyAttributeName As String,
    valueAttributeName As String,
    childElementName As String,
    childType As Type
)
Parameters
category (String)
The category of the configuration property
helpText (String)
Any text that can be given to the user as help for this property.
note (String)
Note for the end user
type (ConfigurationPropertyAttribute..::..DataType)
The type of the element
keyAttributeName (String)
The attribute specifying the key
valueAttributeName (String)
The name of the attribute used to hold the value of the child element
childElementName (String)
The name of the child element in the Xml file
childType (Type)
The type of child elements

Send comments on this topic to support@keyoti.com


ConfigurationPropertyAttribute Constructor (category, helpText, note, type, keyAttributeName, valueAttributeName, childElementName, childType, changeAffectsIndexState)

ConfigurationPropertyAttribute Constructor (category, helpText, note, type, keyAttributeName, valueAttributeName, childElementName, childType, changeAffectsIndexState)
API Documentation ► Keyoti.SearchEngine ► ConfigurationPropertyAttribute ► ConfigurationPropertyAttribute(String, String, String, ConfigurationPropertyAttribute..::..DataType, String, String, String, Type, Boolean)
Keyoti SearchUnit v6
Creates an instance
Declaration Syntax
C# Visual Basic
public ConfigurationPropertyAttribute(
    string category,
    string helpText,
    string note,
    ConfigurationPropertyAttribute..::..DataType type,
    string keyAttributeName,
    string valueAttributeName,
    string childElementName,
    Type childType,
    bool changeAffectsIndexState
)
Public Sub New (
    category As String,
    helpText As String,
    note As String,
    type As ConfigurationPropertyAttribute..::..DataType,
    keyAttributeName As String,
    valueAttributeName As String,
    childElementName As String,
    childType As Type,
    changeAffectsIndexState As Boolean
)
Parameters
category (String)
The category of the configuration property
helpText (String)
Any text that can be given to the user as help for this property.
note (String)
Note for the end user
type (ConfigurationPropertyAttribute..::..DataType)
The type of child element
keyAttributeName (String)
The attribute specifying the key
valueAttributeName (String)
The name of the attribute used to hold the value of the child element
childElementName (String)
The name of the child element in the Xml file
childType (Type)
The type of child elements
changeAffectsIndexState (Boolean)
Whether changing this property affects the index state.


ConfigurationPropertyAttribute Constructor (category, helpText, note, changeAffectsIndexState)

ConfigurationPropertyAttribute Constructor (category, helpText, note, changeAffectsIndexState)
API Documentation ► Keyoti.SearchEngine ► ConfigurationPropertyAttribute ► ConfigurationPropertyAttribute(String, String, String, Boolean)
Keyoti SearchUnit v6
Creates an instance
Declaration Syntax
C# Visual Basic
public ConfigurationPropertyAttribute(
    string category,
    string helpText,
    string note,
    bool changeAffectsIndexState
)
Public Sub New (
    category As String,
    helpText As String,
    note As String,
    changeAffectsIndexState As Boolean
)
Parameters
category (String)
The category of the configuration property
helpText (String)
Any text that can be given to the user as help for this property.
note (String)
Note for the end user
changeAffectsIndexState (Boolean)
Whether the index needs to be rebuilt after changing this property


ConfigurationPropertyAttribute Constructor (category, helpText, note, changeAffectsIndexState, isPassword)

ConfigurationPropertyAttribute Constructor (category, helpText, note, changeAffectsIndexState, isPassword)
API Documentation ► Keyoti.SearchEngine ► ConfigurationPropertyAttribute ► ConfigurationPropertyAttribute(String, String, String, Boolean, Boolean)
Keyoti SearchUnit v6
Creates an instance
Declaration Syntax
C# Visual Basic
public ConfigurationPropertyAttribute(
    string category,
    string helpText,
    string note,
    bool changeAffectsIndexState,
    bool isPassword
)
Public Sub New (
    category As String,
    helpText As String,
    note As String,
    changeAffectsIndexState As Boolean,
    isPassword As Boolean
)
Parameters
category (String)
The category of the configuration property
helpText (String)
Any text that can be given to the user as help for this property.
note (String)
Note for the end user
changeAffectsIndexState (Boolean)
Whether the index needs to be rebuilt after changing this property
isPassword (Boolean)


Category Property

Category Property
API Documentation ► Keyoti.SearchEngine ► ConfigurationPropertyAttribute ► Category
Keyoti SearchUnit v6
The property category.
Declaration Syntax
C# Visual Basic
public string Category { get; }
Public ReadOnly Property Category As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


ChangeAffectsIndexState Property

ChangeAffectsIndexState Property
API Documentation ► Keyoti.SearchEngine ► ConfigurationPropertyAttribute ► ChangeAffectsIndexState
Keyoti SearchUnit v6
Whether a change to this property affects the index state.
Declaration Syntax
C# Visual Basic
public bool ChangeAffectsIndexState { get; }
Public ReadOnly Property ChangeAffectsIndexState As Boolean
    Get
Property Value
Boolean

Send comments on this topic to support@keyoti.com


ChildElementName Property

ChildElementName Property
API Documentation ► Keyoti.SearchEngine ► ConfigurationPropertyAttribute ► ChildElementName
Keyoti SearchUnit v6
The name of the child element for a collection
Declaration Syntax
C# Visual Basic
public string ChildElementName { get; }
Public ReadOnly Property ChildElementName As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


ChildType Property

ChildType Property
API Documentation ► Keyoti.SearchEngine ► ConfigurationPropertyAttribute ► ChildType
Keyoti SearchUnit v6
The type child object.
Declaration Syntax
C# Visual Basic
public Type ChildType { get; }
Public ReadOnly Property ChildType As Type
    Get
Property Value
Type

Send comments on this topic to support@keyoti.com


HelpText Property

HelpText Property
API Documentation ► Keyoti.SearchEngine ► ConfigurationPropertyAttribute ► HelpText
Keyoti SearchUnit v6
Any text that can be given to the user as help for this property.
Declaration Syntax
C# Visual Basic
public string HelpText { get; }
Public ReadOnly Property HelpText As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


IsPassword Property

IsPassword Property
API Documentation ► Keyoti.SearchEngine ► ConfigurationPropertyAttribute ► IsPassword
Keyoti SearchUnit v6
Whether this property is a password that should be protected.
Declaration Syntax
C# Visual Basic
public bool IsPassword { get; }
Public ReadOnly Property IsPassword As Boolean
    Get
Property Value
Boolean

Send comments on this topic to support@keyoti.com


KeyAttributeName Property

KeyAttributeName Property
API Documentation ► Keyoti.SearchEngine ► ConfigurationPropertyAttribute ► KeyAttributeName
Keyoti SearchUnit v6
The name of the attribute holding the collection key
Declaration Syntax
C# Visual Basic
public string KeyAttributeName { get; }
Public ReadOnly Property KeyAttributeName As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


Note Property

Note Property
API Documentation ► Keyoti.SearchEngine ► ConfigurationPropertyAttribute ► Note
Keyoti SearchUnit v6
Any note about setting this property - eg. requires recrawl.
Declaration Syntax
C# Visual Basic
public string Note { get; }
Public ReadOnly Property Note As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


PropertyDataType Property

PropertyDataType Property
API Documentation ► Keyoti.SearchEngine ► ConfigurationPropertyAttribute ► PropertyDataType
Keyoti SearchUnit v6
The type of property
Declaration Syntax
C# Visual Basic
public ConfigurationPropertyAttribute..::..DataType PropertyDataType { get; }
Public ReadOnly Property PropertyDataType As ConfigurationPropertyAttribute..::..DataType
    Get
Property Value
ConfigurationPropertyAttribute..::..DataType


ValueAttributeName Property

ValueAttributeName Property
API Documentation ► Keyoti.SearchEngine ► ConfigurationPropertyAttribute ► ValueAttributeName
Keyoti SearchUnit v6
The name of the attribute holding the collection value
Declaration Syntax
C# Visual Basic
public string ValueAttributeName { get; }
Public ReadOnly Property ValueAttributeName As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


ConfigurationPropertyAttribute.DataType Enumeration

ConfigurationPropertyAttribute..::..DataType Enumeration
API Documentation ► Keyoti.SearchEngine ► ConfigurationPropertyAttribute ► ConfigurationPropertyAttribute..::..DataType
Keyoti SearchUnit v6
Types of property
Declaration Syntax
C# Visual Basic
public enum DataType
Public Enumeration DataType
Members
Member | Description
Simple | A 'simple' class capable of being serialized as one string
NameValueCollection | A name value collection
List | A list of simple types
Hashtable | A hashtable
StringDictionary | A string dictionary


FolderBrowserDialog Class

FolderBrowserDialog Class
API Documentation ► Keyoti.SearchEngine ► FolderBrowserDialog
Keyoti SearchUnit v6
Component wrapping access to the Browse For Folder common dialog box. Call the ShowDialog() method to bring the dialog box up.
Declaration Syntax
C# Visual Basic
public sealed class FolderBrowserDialog : Component
Public NotInheritable Class FolderBrowserDialog
    Inherits Component
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FolderBrowserDialog()()()() |
 | Container | (Inherited from Component.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DirectoryPath | Full path to the folder selected by the user.
 | Dispose()()()() | (Inherited from Component.)
 | Disposed | (Inherited from Component.)
 | Equals(Object) | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | OnlyFilesystem | Only return file system directories. If the user selects folders that are not part of the file system, the OK button is unavailable.
 | SelectedPath |
 | ShowDialog()()()() | Shows the folder browser dialog box.
 | ShowDialog(IWin32Window) | Shows the folder browser dialog box with the specified owner window.
 | Site | (Inherited from Component.)
 | StartLocation | Location of the root folder from which to start browsing. Only the specified folder and any folders beneath it in the namespace hierarchy appear in the dialog box.
 | ToString()()()() | (Inherited from Component.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | FolderBrowserDialog

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FolderBrowserDialog Constructor

FolderBrowserDialog Constructor
API Documentation ► Keyoti.SearchEngine ► FolderBrowserDialog ► FolderBrowserDialog()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public FolderBrowserDialog()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


DirectoryPath Property

DirectoryPath Property
API Documentation ► Keyoti.SearchEngine ► FolderBrowserDialog ► DirectoryPath
Keyoti SearchUnit v6
Full path to the folder selected by the user.
Declaration Syntax
C# Visual Basic
public string DirectoryPath { get; }
Public ReadOnly Property DirectoryPath As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


OnlyFilesystem Property

OnlyFilesystem Property
API Documentation ► Keyoti.SearchEngine ► FolderBrowserDialog ► OnlyFilesystem
Keyoti SearchUnit v6
Only return file system directories. If the user selects folders that are not part of the file system, the OK button is unavailable.
Declaration Syntax
C# Visual Basic
public bool OnlyFilesystem { get; set; }
Public Property OnlyFilesystem As Boolean
    Get
    Set
Property Value
Boolean

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SelectedPath Property

SelectedPath Property
API Documentation ► Keyoti.SearchEngine ► FolderBrowserDialog ► SelectedPath
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public string SelectedPath { get; }
Public ReadOnly Property SelectedPath As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ShowDialog Method

ShowDialog Method
API Documentation ► Keyoti.SearchEngine ► FolderBrowserDialog ► ShowDialog()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | ShowDialog()()()() | Shows the folder browser dialog box.
 | ShowDialog(IWin32Window) | Shows the folder browser dialog box with the specified owner window.

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ShowDialog Method

ShowDialog Method
API Documentation ► Keyoti.SearchEngine ► FolderBrowserDialog ► ShowDialog()()()()
Keyoti SearchUnit v6
Shows the folder browser dialog box.
Declaration Syntax
C# Visual Basic
public DialogResult ShowDialog()
Public Function ShowDialog As DialogResult
Return Value
DialogResult

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ShowDialog Method (owner)

ShowDialog Method (owner)
API Documentation ► Keyoti.SearchEngine ► FolderBrowserDialog ► ShowDialog(IWin32Window)
Keyoti SearchUnit v6
Shows the folder browser dialog box with the specified owner window.
Declaration Syntax
C# Visual Basic
public DialogResult ShowDialog(
    IWin32Window owner
)
Public Function ShowDialog (
    owner As IWin32Window
) As DialogResult
Parameters
owner (IWin32Window)
Return Value
DialogResult

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


StartLocation Property

StartLocation Property
API Documentation ► Keyoti.SearchEngine ► FolderBrowserDialog ► StartLocation
Keyoti SearchUnit v6
Location of the root folder from which to start browsing. Only the specified folder and any folders beneath it in the namespace hierarchy appear in the dialog box.
Declaration Syntax
C# Visual Basic
public FolderBrowserDialog..::..FolderID StartLocation { get; set; }
Public Property StartLocation As FolderBrowserDialog..::..FolderID
    Get
    Set
Property Value
FolderBrowserDialog..::..FolderID

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FolderBrowserDialog.FolderID Enumeration

FolderBrowserDialog..::..FolderID Enumeration
API Documentation ► Keyoti.SearchEngine ► FolderBrowserDialog ► FolderBrowserDialog..::..FolderID
Keyoti SearchUnit v6
Enum of CSIDLs identifying standard shell folders.
Declaration Syntax
C# Visual Basic
public enum FolderID
Public Enumeration FolderID
Members
Member | Description
Desktop |
Printers |
MyDocuments |
Favorites |
Recent |
SendTo |
StartMenu |
MyComputer |
NetworkNeighborhood |
Templates |
MyPictures |
NetAndDialUpConnections |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


KeyotiFatalException Class

KeyotiFatalException Class
API Documentation ► Keyoti.SearchEngine ► KeyotiFatalException
Keyoti SearchUnit v6
An exception thrown when crawling/building/searching cannot proceed.
Declaration Syntax
C# Visual Basic
public class KeyotiFatalException : ApplicationException
Public Class KeyotiFatalException
    Inherits ApplicationException
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | KeyotiFatalException(Exception) | Creates a new fatal exception
 | KeyotiFatalException(String, Exception) | Creates a new fatal exception
 | CausedByThresholdDBPassed | Whether the dataaccess threshold caused the exception
 | CausedByThresholdReaderPassed | Whether the reader threshold caused the exception
 | Data | (Inherited from Exception.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetBaseException()()()() | (Inherited from Exception.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | (Inherited from Exception.)
 | GetType()()()() | (Inherited from Exception.)
 | HelpLink | (Inherited from Exception.)
 | HResult | (Inherited from Exception.)
 | InnerException | (Inherited from Exception.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | The message (Overrides Exception.Message.)
 | Source | (Inherited from Exception.)
 | StackTrace | (Inherited from Exception.)
 | TargetSite | (Inherited from Exception.)
 | ToString()()()() | (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | ApplicationException
 |  |  | KeyotiFatalException


KeyotiFatalException Constructor

KeyotiFatalException Constructor
API Documentation ► Keyoti.SearchEngine ► KeyotiFatalException ► KeyotiFatalException()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | KeyotiFatalException(Exception) | Creates a new fatal exception
 | KeyotiFatalException(String, Exception) | Creates a new fatal exception


KeyotiFatalException Constructor (innerException)

KeyotiFatalException Constructor (innerException)
API Documentation ► Keyoti.SearchEngine ► KeyotiFatalException ► KeyotiFatalException(Exception)
Keyoti SearchUnit v6
Creates a new fatal exception
Declaration Syntax
C# Visual Basic
public KeyotiFatalException(
    Exception innerException
)
Public Sub New (
    innerException As Exception
)
Parameters
innerException (Exception)


KeyotiFatalException Constructor (message, innerException)

KeyotiFatalException Constructor (message, innerException)
API Documentation ► Keyoti.SearchEngine ► KeyotiFatalException ► KeyotiFatalException(String, Exception)
Keyoti SearchUnit v6
Creates a new fatal exception
Declaration Syntax
C# Visual Basic
public KeyotiFatalException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)
Parameters
message (String)
innerException (Exception)


CausedByThresholdDBPassed Field

CausedByThresholdDBPassed Field
API Documentation ► Keyoti.SearchEngine ► KeyotiFatalException ► CausedByThresholdDBPassed
Keyoti SearchUnit v6
Whether the dataaccess threshold caused the exception
Declaration Syntax
C# Visual Basic
public bool CausedByThresholdDBPassed
Public CausedByThresholdDBPassed As Boolean
Field Value
Boolean

Send comments on this topic to support@keyoti.com


CausedByThresholdReaderPassed Field

CausedByThresholdReaderPassed Field
API Documentation ► Keyoti.SearchEngine ► KeyotiFatalException ► CausedByThresholdReaderPassed
Keyoti SearchUnit v6
Whether the reader threshold caused the exception
Declaration Syntax
C# Visual Basic
public bool CausedByThresholdReaderPassed
Public CausedByThresholdReaderPassed As Boolean
Field Value
Boolean

Send comments on this topic to support@keyoti.com


Message Property

Message Property
API Documentation ► Keyoti.SearchEngine ► KeyotiFatalException ► Message
Keyoti SearchUnit v6
The message
Declaration Syntax
C# Visual Basic
public override string Message { get; }
Public Overrides ReadOnly Property Message As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


LicenseLevel Class

LicenseLevel Class
API Documentation ► Keyoti.SearchEngine ► LicenseLevel
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public class LicenseLevel
Public Class LicenseLevel
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LicenseLevel()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Level |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
LicenseLevel

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.License (Module: Keyoti4.SearchEngine.License.dll) Version: 1.0.0.0


LicenseLevel Constructor

LicenseLevel Constructor
API Documentation ► Keyoti.SearchEngine ► LicenseLevel ► LicenseLevel()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public LicenseLevel()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.License (Module: Keyoti4.SearchEngine.License.dll) Version: 1.0.0.0


Level Field

Level Field
API Documentation ► Keyoti.SearchEngine ► LicenseLevel ► Level
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public readonly LicenseType Level
Public ReadOnly Level As LicenseType
Field Value
LicenseType

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.License (Module: Keyoti4.SearchEngine.License.dll) Version: 1.0.0.0


LicenseType Enumeration

LicenseType Enumeration
API Documentation ► Keyoti.SearchEngine ► LicenseType
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public enum LicenseType
Public Enumeration LicenseType
Members
Member | Description
Lite |
Pro |
Undefined |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.License (Module: Keyoti4.SearchEngine.License.dll) Version: 1.0.0.0


NET4 Class

NET4 Class
API Documentation ► Keyoti.SearchEngine ► NET4
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public class NET4
Public Class NET4
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | NET4()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
NET4

Send comments on this topic to support@keyoti.com


NET4 Constructor

NET4 Constructor
API Documentation ► Keyoti.SearchEngine ► NET4 ► NET4()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public NET4()
Public Sub New

Send comments on this topic to support@keyoti.com


SecurityGroup Class

SecurityGroup Class
API Documentation ► Keyoti.SearchEngine ► SecurityGroup
Keyoti SearchUnit v6
Utility class for security group encryption.
Declaration Syntax
C# Visual Basic
public class SecurityGroup
Public Class SecurityGroup
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SecurityGroup()()()() |
 | Encrypt(String) | Encrypts a security group name
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
SecurityGroup

Send comments on this topic to support@keyoti.com


SecurityGroup Constructor

SecurityGroup Constructor
API Documentation ► Keyoti.SearchEngine ► SecurityGroup ► SecurityGroup()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public SecurityGroup()
Public Sub New

Send comments on this topic to support@keyoti.com


Encrypt Method (securityGroupName)

Encrypt Method (securityGroupName)
API Documentation ► Keyoti.SearchEngine ► SecurityGroup ► Encrypt(String)
Keyoti SearchUnit v6
Encrypts a security group name
Declaration Syntax
C# Visual Basic
public static string Encrypt(
    string securityGroupName
)
Public Shared Function Encrypt (
    securityGroupName As String
) As String
Parameters
securityGroupName (String)
The name to be encrypted, so that it can be passed back to the server.
Return Value
String
Encrypted version.


Keyoti.SearchEngine.DataAccess Namespace

Keyoti.SearchEngine.DataAccess Namespace
API Documentation ► Keyoti.SearchEngine.DataAccess
Keyoti SearchUnit v6
Data layer classes.

Core data access classes

Types
All Types Classes Enumerations
Icon | Type | Description
 | CASE_SENSITIVITY | Obsolete. Used for case sensitivity settings.
 | CaseSensitivity | Used for case sensitivity settings.
 | ContentCategoryRecord | Describes the category for the content of a document.
 | DataAccessException | An exception that originated in the DataAccess layer.
 | DocumentOccurrenceIndexTable | An index of document starting and ending occurrence IDs
 | DocumentRecord | Represents a document stored in the 'database'.
 | FatalDataAccessException | A data-access layer exception that is fatal.
 | IndexConvertor | Converts index format to the current version.
 | IndexState | The state of the index.
 | LexiconMatch | Represents lexicon matches for a query
 | LexiconMatchCollection | Collection of matches.
 | LexiconQuery | Specified a query for lexicon entry searches.
 | LexiconQueryCollection | Collection of query objects
 | LexiconSegmentMatchType | A type of word segment match (i.e. wildcard type).
 | LocationCategoryRecord | Represents a document location type.
 | Log | Writes log messages into the log file
 | OccurrenceMapIWordPositions | Represents the occurrences of words within documents.
 | SecurityGroupRecord | Security group record.
 | StateTable | Represents state table.
 | Word | Incapsulates a word entity
 | WordCollection | Word list wrapper.
 | WordIDPositions | Holds the position of word ids in the occurrence table
 | XmlContentTable | Implements content categories table in an XML file.
 | XmlDataAccess | Provides access to the data stored as XML files
 | XmlIndexableSourceRecordTable | Table holding indexable source records.
 | XmlLocationTable | Represents location category table.
 | XmlSecurityGroupTable | Represents security group table.
 | XmlTable | Abstract class with core functionality.


CASE_SENSITIVITY Enumeration

CASE_SENSITIVITY Enumeration
API Documentation ► Keyoti.SearchEngine.DataAccess ► CASE_SENSITIVITY
Keyoti SearchUnit v6
Used for case sensitivity settings.
Declaration Syntax
C# Visual Basic
[ObsoleteAttribute("Please use CaseSensitivity enum instead, which is identical except with corrected naming convention.",
    true)]
public enum CASE_SENSITIVITY
<ObsoleteAttribute("Please use CaseSensitivity enum instead, which is identical except with corrected naming convention.",
    true)>
Public Enumeration CASE_SENSITIVITY
Members
Member | Description
CASE_SENSITIVE | The case of indexed words matters.
CASE_INSENSITIVE | The case of indexed words doesn't matter.
CAPITALIZATION | The capitalization of the word matters, if the query is in lower case then matches will be made with words in any case, however if the query is capitalized (eg. 'Query') then it will only match words that are capitalized.


CaseSensitivity Enumeration

CaseSensitivity Enumeration
API Documentation ► Keyoti.SearchEngine.DataAccess ► CaseSensitivity
Keyoti SearchUnit v6
Used for case sensitivity settings.
Declaration Syntax
C# Visual Basic
public enum CaseSensitivity
Public Enumeration CaseSensitivity
Members
Member | Description
CaseSensitive | The case of indexed words matters.
CaseInsensitive | The case of indexed words doesn't matter.
Capitalization | The capitalization of the word matters, if the query is in lower case then matches will be made with words in any case, however if the query is capitalized (eg. 'Query') then it will only match words that are capitalized.


ContentCategoryRecord Class

ContentCategoryRecord Class
API Documentation ► Keyoti.SearchEngine.DataAccess ► ContentCategoryRecord
Keyoti SearchUnit v6
Describes the category for the content of a document.
Declaration Syntax
C# Visual Basic
public class ContentCategoryRecord
Public Class ContentCategoryRecord
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ContentCategoryRecord(Int32, String) | Obsolete. Creates a new content category
 | CreateContentCategoryRecord(String) | Creates a new instance.
 | CreateDefaultContentCategoryRecord()()()() | Creates the default ContentCategory object
 | Equals(Object) | Determines if the 2 objects are equal (Overrides Object.Equals(Object).)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | Gets the hashcode based on the content name. (Overrides Object.GetHashCode()()()().)
 | GetType()()()() | (Inherited from Object.)
 | ID | Data access ID
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name | Content name.
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
ContentCategoryRecord

Send comments on this topic to support@keyoti.com


ContentCategoryRecord Constructor (contentID, contentName)

ContentCategoryRecord Constructor (contentID, contentName)
API Documentation ► Keyoti.SearchEngine.DataAccess ► ContentCategoryRecord ► ContentCategoryRecord(Int32, String)
Keyoti SearchUnit v6
Creates a new content category
Declaration Syntax
C# Visual Basic
[ObsoleteAttribute("Use CreateContentCategoryRecord instead, to create new instances.",
    true)]
public ContentCategoryRecord(
    int contentID,
    string contentName
)
<ObsoleteAttribute("Use CreateContentCategoryRecord instead, to create new instances.",
    true)>
Public Sub New (
    contentID As Integer,
    contentName As String
)
Parameters
contentID (Int32)
contentName (String)


CreateContentCategoryRecord Method (contentName)

CreateContentCategoryRecord Method (contentName)
API Documentation ► Keyoti.SearchEngine.DataAccess ► ContentCategoryRecord ► CreateContentCategoryRecord(String)
Keyoti SearchUnit v6
Creates a new instance.
Declaration Syntax
C# Visual Basic
public static ContentCategoryRecord CreateContentCategoryRecord(
    string contentName
)
Public Shared Function CreateContentCategoryRecord (
    contentName As String
) As ContentCategoryRecord
Parameters
contentName (String)
The name of the location
Return Value
ContentCategoryRecord

Send comments on this topic to support@keyoti.com


CreateDefaultContentCategoryRecord Method

CreateDefaultContentCategoryRecord Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► ContentCategoryRecord ► CreateDefaultContentCategoryRecord()()()()
Keyoti SearchUnit v6
Creates the default ContentCategory object
Declaration Syntax
C# Visual Basic
public static ContentCategoryRecord CreateDefaultContentCategoryRecord()
Public Shared Function CreateDefaultContentCategoryRecord As ContentCategoryRecord
Return Value
ContentCategoryRecord

Send comments on this topic to support@keyoti.com


Equals Method (obj)

Equals Method (obj)
API Documentation ► Keyoti.SearchEngine.DataAccess ► ContentCategoryRecord ► Equals(Object)
Keyoti SearchUnit v6
Determines if the 2 objects are equal
Declaration Syntax
C# Visual Basic
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Parameters
obj (Object)
Return Value
Boolean

Send comments on this topic to support@keyoti.com


GetHashCode Method

GetHashCode Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► ContentCategoryRecord ► GetHashCode()()()()
Keyoti SearchUnit v6
Gets the hashcode based on the content name.
Declaration Syntax
C# Visual Basic
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Return Value
Int32

Send comments on this topic to support@keyoti.com


ID Property

ID Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► ContentCategoryRecord ► ID
Keyoti SearchUnit v6
Data access ID
Declaration Syntax
C# Visual Basic
public virtual int ID { get; }
Public Overridable ReadOnly Property ID As Integer
    Get
Property Value
Int32

Send comments on this topic to support@keyoti.com


Name Property

Name Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► ContentCategoryRecord ► Name
Keyoti SearchUnit v6
Content name.
Declaration Syntax
C# Visual Basic
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


DataAccessException Class

DataAccessException Class
API Documentation ► Keyoti.SearchEngine.DataAccess ► DataAccessException
Keyoti SearchUnit v6
An exception that originated in the DataAccess layer.
Declaration Syntax
C# Visual Basic
public class DataAccessException : ApplicationException
Public Class DataAccessException
    Inherits ApplicationException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataAccessException(Exception) | Create a data access exception.
 | Data | (Inherited from Exception.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetBaseException()()()() | (Inherited from Exception.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | (Inherited from Exception.)
 | GetType()()()() | (Inherited from Exception.)
 | HelpLink | (Inherited from Exception.)
 | HResult | (Inherited from Exception.)
 | InnerException | (Inherited from Exception.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | The exception message (Overrides Exception.Message.)
 | Source | (Inherited from Exception.)
 | StackTrace | (Inherited from Exception.)
 | TargetSite | (Inherited from Exception.)
 | ToString()()()() | (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | ApplicationException
 |  |  | DataAccessException


DataAccessException Constructor (innerException)

DataAccessException Constructor (innerException)
API Documentation ► Keyoti.SearchEngine.DataAccess ► DataAccessException ► DataAccessException(Exception)
Keyoti SearchUnit v6
Create a data access exception.
Declaration Syntax
C# Visual Basic
public DataAccessException(
    Exception innerException
)
Public Sub New (
    innerException As Exception
)
Parameters
innerException (Exception)


Message Property

Message Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► DataAccessException ► Message
Keyoti SearchUnit v6
The exception message
Declaration Syntax
C# Visual Basic
public override string Message { get; }
Public Overrides ReadOnly Property Message As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


DocumentOccurrenceIndexTable Class

DocumentOccurrenceIndexTable Class
API Documentation ► Keyoti.SearchEngine.DataAccess ► DocumentOccurrenceIndexTable
Keyoti SearchUnit v6
An index of document starting and ending occurrence IDs
Declaration Syntax
C# Visual Basic
public class DocumentOccurrenceIndexTable
Public Class DocumentOccurrenceIndexTable
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DocumentOccurrenceIndexTable(Configuration) | New instance
 | AddEntry(Int32, Int32, Int32) | Adds a new entry
 | Close()()()() | Closes the file
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FindDocumentOccurranceBoundaries(Int32) | Returns 1st and last occurrenceID belonging to the document
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Open(Boolean) | Opens the file
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
DocumentOccurrenceIndexTable

Send comments on this topic to support@keyoti.com


DocumentOccurrenceIndexTable Constructor (configuration)

DocumentOccurrenceIndexTable Constructor (configuration)
API Documentation ► Keyoti.SearchEngine.DataAccess ► DocumentOccurrenceIndexTable ► DocumentOccurrenceIndexTable(Configuration)
Keyoti SearchUnit v6
New instance
Declaration Syntax
C# Visual Basic
public DocumentOccurrenceIndexTable(
    Configuration configuration
)
Public Sub New (
    configuration As Configuration
)
Parameters
configuration (Configuration)


AddEntry Method (currentDocID, currentDocStartingOccID, currentDocEndingOccID)

AddEntry Method (currentDocID, currentDocStartingOccID, currentDocEndingOccID)
API Documentation ► Keyoti.SearchEngine.DataAccess ► DocumentOccurrenceIndexTable ► AddEntry(Int32, Int32, Int32)
Keyoti SearchUnit v6
Adds a new entry
Declaration Syntax
C# Visual Basic
public void AddEntry(
    int currentDocID,
    int currentDocStartingOccID,
    int currentDocEndingOccID
)
Public Sub AddEntry (
    currentDocID As Integer,
    currentDocStartingOccID As Integer,
    currentDocEndingOccID As Integer
)
Parameters
currentDocID (Int32)
currentDocStartingOccID (Int32)
currentDocEndingOccID (Int32)


Close Method

Close Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► DocumentOccurrenceIndexTable ► Close()()()()
Keyoti SearchUnit v6
Closes the file
Declaration Syntax
C# Visual Basic
public void Close()
Public Sub Close

Send comments on this topic to support@keyoti.com


FindDocumentOccurranceBoundaries Method (documentID)

FindDocumentOccurranceBoundaries Method (documentID)
API Documentation ► Keyoti.SearchEngine.DataAccess ► DocumentOccurrenceIndexTable ► FindDocumentOccurranceBoundaries(Int32)
Keyoti SearchUnit v6
Returns 1st and last occurrenceID belonging to the document
Declaration Syntax
C# Visual Basic
public int[] FindDocumentOccurranceBoundaries(
    int documentID
)
Public Function FindDocumentOccurranceBoundaries (
    documentID As Integer
) As Integer()
Parameters
documentID (Int32)
Document of interest
Return Value
array< Int32 >[]()[][]
Occurrence IDs of start and end of document


Open Method (write)

Open Method (write)
API Documentation ► Keyoti.SearchEngine.DataAccess ► DocumentOccurrenceIndexTable ► Open(Boolean)
Keyoti SearchUnit v6
Opens the file
Declaration Syntax
C# Visual Basic
public void Open(
    bool write
)
Public Sub Open (
    write As Boolean
)
Parameters
write (Boolean)


DocumentRecord Class

DocumentRecord Class
API Documentation ► Keyoti.SearchEngine.DataAccess ► DocumentRecord
Keyoti SearchUnit v6
Represents a document stored in the 'database'.
Declaration Syntax
C# Visual Basic
public class DocumentRecord
Public Class DocumentRecord
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DocumentRecord(Uri) | Creates a new DocumentRecord with the specified Uri and default properties.
 | DocumentRecord(String) | Creates a new DocumentRecord with the specified Uri and default properties.
 | DocumentRecord(Uri, Boolean) | Creates a new DocumentRecord with the specified Uri and default properties.
 | ContentCategories | The content categories of type ContentCategoryRecord that this document belongs to.
 | ContentLength | The length of the file (bytes), or -1 if not available.
 | CustomData | Any custom data that should be stored for the document.
 | Description | Description of the document, if specified.
 | DocumentId | The ID of the document in the 'database'.
 | DontIndex | Whether to ignore the document during index creation.
 | Equals(Object) | Returns true if the objects are equal including all properties. (Overrides Object.Equals(Object).)
 | FileType | The mime-type for the document.
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | Gets the hashcode based on the Uri. (Overrides Object.GetHashCode()()()().)
 | GetType()()()() | (Inherited from Object.)
 | IndexableSourceId | The ID of the indexable source this belongs to, or -1 if none.
 | LastDateIndexed | The date and time the document was last indexed.
 | LocationCategory | The location category that this document belongs to.
 | LoginPage | Needed for FormAuthentication
 | MatchesFilter(String) | Whether this document contains a field which contains filter.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SecurityGroups | The security groups that this document belongs to.
 | Title | The document's title.
 | ToString()()()() | (Inherited from Object.)
 | Uri | The Uri of the doc.
Inheritance Hierarchy
Object
DocumentRecord

Send comments on this topic to support@keyoti.com


DocumentRecord Constructor

DocumentRecord Constructor
API Documentation ► Keyoti.SearchEngine.DataAccess ► DocumentRecord ► DocumentRecord()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | DocumentRecord(Uri) | Creates a new DocumentRecord with the specified Uri and default properties.
 | DocumentRecord(String) | Creates a new DocumentRecord with the specified Uri and default properties.
 | DocumentRecord(Uri, Boolean) | Creates a new DocumentRecord with the specified Uri and default properties.


DocumentRecord Constructor (uriString)

DocumentRecord Constructor (uriString)
API Documentation ► Keyoti.SearchEngine.DataAccess ► DocumentRecord ► DocumentRecord(String)
Keyoti SearchUnit v6
Creates a new DocumentRecord with the specified Uri and default properties.
Declaration Syntax
C# Visual Basic
public DocumentRecord(
    string uriString
)
Public Sub New (
    uriString As String
)
Parameters
uriString (String)
Remarks
The Uri passed as a string will be converted to a Uri object the first time the Uri property is called.


DocumentRecord Constructor (uri)

DocumentRecord Constructor (uri)
API Documentation ► Keyoti.SearchEngine.DataAccess ► DocumentRecord ► DocumentRecord(Uri)
Keyoti SearchUnit v6
Creates a new DocumentRecord with the specified Uri and default properties.
Declaration Syntax
C# Visual Basic
public DocumentRecord(
    Uri uri
)
Public Sub New (
    uri As Uri
)
Parameters
uri (Uri)


DocumentRecord Constructor (uri, loginPage)

DocumentRecord Constructor (uri, loginPage)
API Documentation ► Keyoti.SearchEngine.DataAccess ► DocumentRecord ► DocumentRecord(Uri, Boolean)
Keyoti SearchUnit v6
Creates a new DocumentRecord with the specified Uri and default properties.
Declaration Syntax
C# Visual Basic
public DocumentRecord(
    Uri uri,
    bool loginPage
)
Public Sub New (
    uri As Uri,
    loginPage As Boolean
)
Parameters
uri (Uri)
loginPage (Boolean)


ContentCategories Property

ContentCategories Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► DocumentRecord ► ContentCategories
Keyoti SearchUnit v6
The content categories of type ContentCategoryRecord that this document belongs to.
Declaration Syntax
C# Visual Basic
public virtual ArrayList ContentCategories { get; }
Public Overridable ReadOnly Property ContentCategories As ArrayList
    Get
Property Value
ArrayList

Send comments on this topic to support@keyoti.com


ContentLength Property

ContentLength Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► DocumentRecord ► ContentLength
Keyoti SearchUnit v6
The length of the file (bytes), or -1 if not available.
Declaration Syntax
C# Visual Basic
public long ContentLength { get; set; }
Public Property ContentLength As Long
    Get
    Set
Property Value
Int64

Send comments on this topic to support@keyoti.com


CustomData Property

CustomData Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► DocumentRecord ► CustomData
Keyoti SearchUnit v6
Any custom data that should be stored for the document.
Declaration Syntax
C# Visual Basic
public virtual string CustomData { get; set; }
Public Overridable Property CustomData As String
    Get
    Set
Property Value
String
Remarks
This may be useful for users of the SDK who need to store extra data about a document, such as meta-data, dates, ownership etc. Through this, additional data can be presented to the user or results can be filtered or sorted, etc (see help for more info). If this is set null, an empty string is stored.


Description Property

Description Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► DocumentRecord ► Description
Keyoti SearchUnit v6
Description of the document, if specified.
Declaration Syntax
C# Visual Basic
public virtual string Description { get; set; }
Public Overridable Property Description As String
    Get
    Set
Property Value
String
Remarks
If this is set null, an empty string is stored.


DocumentId Property

DocumentId Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► DocumentRecord ► DocumentId
Keyoti SearchUnit v6
The ID of the document in the 'database'.
Declaration Syntax
C# Visual Basic
public virtual int DocumentId { get; set; }
Public Overridable Property DocumentId As Integer
    Get
    Set
Property Value
Int32

Send comments on this topic to support@keyoti.com


DontIndex Property

DontIndex Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► DocumentRecord ► DontIndex
Keyoti SearchUnit v6
Whether to ignore the document during index creation.
Declaration Syntax
C# Visual Basic
public virtual bool DontIndex { get; set; }
Public Overridable Property DontIndex As Boolean
    Get
    Set
Property Value
Boolean

Send comments on this topic to support@keyoti.com


Equals Method (obj)

Equals Method (obj)
API Documentation ► Keyoti.SearchEngine.DataAccess ► DocumentRecord ► Equals(Object)
Keyoti SearchUnit v6
Returns true if the objects are equal including all properties.
Declaration Syntax
C# Visual Basic
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Parameters
obj (Object)
Return Value
Boolean

Send comments on this topic to support@keyoti.com


FileType Property

FileType Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► DocumentRecord ► FileType
Keyoti SearchUnit v6
The mime-type for the document.
Declaration Syntax
C# Visual Basic
public virtual string FileType { get; set; }
Public Overridable Property FileType As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


GetHashCode Method

GetHashCode Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► DocumentRecord ► GetHashCode()()()()
Keyoti SearchUnit v6
Gets the hashcode based on the Uri.
Declaration Syntax
C# Visual Basic
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Return Value
Int32

Send comments on this topic to support@keyoti.com


IndexableSourceId Property

IndexableSourceId Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► DocumentRecord ► IndexableSourceId
Keyoti SearchUnit v6
The ID of the indexable source this belongs to, or -1 if none.
Declaration Syntax
C# Visual Basic
public int IndexableSourceId { get; set; }
Public Property IndexableSourceId As Integer
    Get
    Set
Property Value
Int32

Send comments on this topic to support@keyoti.com


LastDateIndexed Property

LastDateIndexed Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► DocumentRecord ► LastDateIndexed
Keyoti SearchUnit v6
The date and time the document was last indexed.
Declaration Syntax
C# Visual Basic
public virtual DateTime LastDateIndexed { get; set; }
Public Overridable Property LastDateIndexed As DateTime
    Get
    Set
Property Value
DateTime

Send comments on this topic to support@keyoti.com


LocationCategory Property

LocationCategory Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► DocumentRecord ► LocationCategory
Keyoti SearchUnit v6
The location category that this document belongs to.
Declaration Syntax
C# Visual Basic
public virtual LocationCategoryRecord LocationCategory { get; set; }
Public Overridable Property LocationCategory As LocationCategoryRecord
    Get
    Set
Property Value
LocationCategoryRecord

Send comments on this topic to support@keyoti.com


LoginPage Property

LoginPage Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► DocumentRecord ► LoginPage
Keyoti SearchUnit v6
Needed for FormAuthentication
Declaration Syntax
C# Visual Basic
public virtual bool LoginPage { get; set; }
Public Overridable Property LoginPage As Boolean
    Get
    Set
Property Value
Boolean

Send comments on this topic to support@keyoti.com


MatchesFilter Method (filter)

MatchesFilter Method (filter)
API Documentation ► Keyoti.SearchEngine.DataAccess ► DocumentRecord ► MatchesFilter(String)
Keyoti SearchUnit v6
Whether this document contains a field which contains filter.
Declaration Syntax
C# Visual Basic
public bool MatchesFilter(
    string filter
)
Public Function MatchesFilter (
    filter As String
) As Boolean
Parameters
filter (String)
Return Value
Boolean

Send comments on this topic to support@keyoti.com


SecurityGroups Property

SecurityGroups Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► DocumentRecord ► SecurityGroups
Keyoti SearchUnit v6
The security groups that this document belongs to.
Declaration Syntax
C# Visual Basic
public virtual SecurityGroupRecordList SecurityGroups { get; set; }
Public Overridable Property SecurityGroups As SecurityGroupRecordList
    Get
    Set
Property Value
SecurityGroupRecordList

Send comments on this topic to support@keyoti.com


Title Property

Title Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► DocumentRecord ► Title
Keyoti SearchUnit v6
The document's title.
Declaration Syntax
C# Visual Basic
public virtual string Title { get; set; }
Public Overridable Property Title As String
    Get
    Set
Property Value
String
Remarks
If this is set null, an empty string is stored.


Uri Property

Uri Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► DocumentRecord ► Uri
Keyoti SearchUnit v6
The Uri of the doc.
Declaration Syntax
C# Visual Basic
public virtual Uri Uri { get; set; }
Public Overridable Property Uri As Uri
    Get
    Set
Property Value
Uri

Send comments on this topic to support@keyoti.com


FatalDataAccessException Class

FatalDataAccessException Class
API Documentation ► Keyoti.SearchEngine.DataAccess ► FatalDataAccessException
Keyoti SearchUnit v6
A data-access layer exception that is fatal.
Declaration Syntax
C# Visual Basic
public class FatalDataAccessException : ApplicationException
Public Class FatalDataAccessException
    Inherits ApplicationException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FatalDataAccessException(Exception) | Creates a new fatal exception
 | Data | (Inherited from Exception.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetBaseException()()()() | (Inherited from Exception.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | (Inherited from Exception.)
 | GetType()()()() | (Inherited from Exception.)
 | HelpLink | (Inherited from Exception.)
 | HResult | (Inherited from Exception.)
 | InnerException | (Inherited from Exception.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | The message (Overrides Exception.Message.)
 | Source | (Inherited from Exception.)
 | StackTrace | (Inherited from Exception.)
 | TargetSite | (Inherited from Exception.)
 | ToString()()()() | (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | ApplicationException
 |  |  | FatalDataAccessException


FatalDataAccessException Constructor (innerException)

FatalDataAccessException Constructor (innerException)
API Documentation ► Keyoti.SearchEngine.DataAccess ► FatalDataAccessException ► FatalDataAccessException(Exception)
Keyoti SearchUnit v6
Creates a new fatal exception
Declaration Syntax
C# Visual Basic
public FatalDataAccessException(
    Exception innerException
)
Public Sub New (
    innerException As Exception
)
Parameters
innerException (Exception)


Message Property

Message Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► FatalDataAccessException ► Message
Keyoti SearchUnit v6
The message
Declaration Syntax
C# Visual Basic
public override string Message { get; }
Public Overrides ReadOnly Property Message As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


IndexConvertor Class

IndexConvertor Class
API Documentation ► Keyoti.SearchEngine.DataAccess ► IndexConvertor
Keyoti SearchUnit v6
Converts index format to the current version.
Declaration Syntax
C# Visual Basic
public class IndexConvertor
Public Class IndexConvertor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | IndexConvertor()()()() |
 | Convertv2010(String) | Convert a v2010 index to the current version.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IsIndexFormatCurrent(String) | Whether the specified index is current
 | Isv2010IndexFormat(String) | Whether the specified index is v2010.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
IndexConvertor

Send comments on this topic to support@keyoti.com


IndexConvertor Constructor

IndexConvertor Constructor
API Documentation ► Keyoti.SearchEngine.DataAccess ► IndexConvertor ► IndexConvertor()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public IndexConvertor()
Public Sub New

Send comments on this topic to support@keyoti.com


Convertv2010 Method (indexDirectory)

Convertv2010 Method (indexDirectory)
API Documentation ► Keyoti.SearchEngine.DataAccess ► IndexConvertor ► Convertv2010(String)
Keyoti SearchUnit v6
Convert a v2010 index to the current version.
Declaration Syntax
C# Visual Basic
public static void Convertv2010(
    string indexDirectory
)
Public Shared Sub Convertv2010 (
    indexDirectory As String
)
Parameters
indexDirectory (String)


IsIndexFormatCurrent Method (indexDirectory)

IsIndexFormatCurrent Method (indexDirectory)
API Documentation ► Keyoti.SearchEngine.DataAccess ► IndexConvertor ► IsIndexFormatCurrent(String)
Keyoti SearchUnit v6
Whether the specified index is current
Declaration Syntax
C# Visual Basic
public static bool IsIndexFormatCurrent(
    string indexDirectory
)
Public Shared Function IsIndexFormatCurrent (
    indexDirectory As String
) As Boolean
Parameters
indexDirectory (String)
Return Value
Boolean

Send comments on this topic to support@keyoti.com


Isv2010IndexFormat Method (indexDirectory)

Isv2010IndexFormat Method (indexDirectory)
API Documentation ► Keyoti.SearchEngine.DataAccess ► IndexConvertor ► Isv2010IndexFormat(String)
Keyoti SearchUnit v6
Whether the specified index is v2010.
Declaration Syntax
C# Visual Basic
public static bool Isv2010IndexFormat(
    string indexDirectory
)
Public Shared Function Isv2010IndexFormat (
    indexDirectory As String
) As Boolean
Parameters
indexDirectory (String)
Return Value
Boolean

Send comments on this topic to support@keyoti.com


IndexState Class

IndexState Class
API Documentation ► Keyoti.SearchEngine.DataAccess ► IndexState
Keyoti SearchUnit v6
The state of the index.
Declaration Syntax
C# Visual Basic
public class IndexState
Public Class IndexState
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IndexState()()()() |
 | Equals(Object) | Whether the two objects are equal (Overrides Object.Equals(Object).)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | The hashcode (Overrides Object.GetHashCode()()()().)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NextBuildFull | Whether the next index build operation needs to include all documents.
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
IndexState

Send comments on this topic to support@keyoti.com


IndexState Constructor

IndexState Constructor
API Documentation ► Keyoti.SearchEngine.DataAccess ► IndexState ► IndexState()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public IndexState()
Public Sub New

Send comments on this topic to support@keyoti.com


Equals Method (obj)

Equals Method (obj)
API Documentation ► Keyoti.SearchEngine.DataAccess ► IndexState ► Equals(Object)
Keyoti SearchUnit v6
Whether the two objects are equal
Declaration Syntax
C# Visual Basic
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Parameters
obj (Object)
Return Value
Boolean

Send comments on this topic to support@keyoti.com


GetHashCode Method

GetHashCode Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► IndexState ► GetHashCode()()()()
Keyoti SearchUnit v6
The hashcode
Declaration Syntax
C# Visual Basic
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Return Value
Int32

Send comments on this topic to support@keyoti.com


NextBuildFull Property

NextBuildFull Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► IndexState ► NextBuildFull
Keyoti SearchUnit v6
Whether the next index build operation needs to include all documents.
Declaration Syntax
C# Visual Basic
public bool NextBuildFull { get; set; }
Public Property NextBuildFull As Boolean
    Get
    Set
Property Value
Boolean

Send comments on this topic to support@keyoti.com


LexiconMatch Class

LexiconMatch Class
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconMatch
Keyoti SearchUnit v6
Represents lexicon matches for a query
Declaration Syntax
C# Visual Basic
public class LexiconMatch
Public Class LexiconMatch
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LexiconMatch(Boolean, LexiconQuery) | New instance
 | LexiconMatch(Boolean, ArrayList, Boolean, LexiconQuery) | New instance
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IsStopWord | Whether the query that created this match was for a stop word.
 | LexiconEntries | Where in the occurrence file the word occurrs.
 | MatchedStrings | Any words that matched the query
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OriginatingQuery | The query that made this match.
 | TargetWordIndexInTerms | The ID of the original word.
 | TermIsTarget(Int32) | Whether the matched term was the original target
 | Terms | List of matching terms
 | ToString()()()() | (Inherited from Object.)
 | WordIDs | Matching word Ids.
Inheritance Hierarchy
Object
LexiconMatch

Send comments on this topic to support@keyoti.com


LexiconMatch Constructor

LexiconMatch Constructor
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconMatch ► LexiconMatch()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | LexiconMatch(Boolean, LexiconQuery) | New instance
 | LexiconMatch(Boolean, ArrayList, Boolean, LexiconQuery) | New instance


LexiconMatch Constructor (isStopWord, query)

LexiconMatch Constructor (isStopWord, query)
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconMatch ► LexiconMatch(Boolean, LexiconQuery)
Keyoti SearchUnit v6
New instance
Declaration Syntax
C# Visual Basic
public LexiconMatch(
    bool isStopWord,
    LexiconQuery query
)
Public Sub New (
    isStopWord As Boolean,
    query As LexiconQuery
)
Parameters
isStopWord (Boolean)
query (LexiconQuery)


LexiconMatch Constructor (needIDsPositions, matchedStrings, isStopWord, query)

LexiconMatch Constructor (needIDsPositions, matchedStrings, isStopWord, query)
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconMatch ► LexiconMatch(Boolean, ArrayList, Boolean, LexiconQuery)
Keyoti SearchUnit v6
New instance
Declaration Syntax
C# Visual Basic
public LexiconMatch(
    bool needIDsPositions,
    ArrayList matchedStrings,
    bool isStopWord,
    LexiconQuery query
)
Public Sub New (
    needIDsPositions As Boolean,
    matchedStrings As ArrayList,
    isStopWord As Boolean,
    query As LexiconQuery
)
Parameters
needIDsPositions (Boolean)
matchedStrings (ArrayList)
isStopWord (Boolean)
query (LexiconQuery)


IsStopWord Property

IsStopWord Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconMatch ► IsStopWord
Keyoti SearchUnit v6
Whether the query that created this match was for a stop word.
Declaration Syntax
C# Visual Basic
public bool IsStopWord { get; }
Public ReadOnly Property IsStopWord As Boolean
    Get
Property Value
Boolean

Send comments on this topic to support@keyoti.com


LexiconEntries Property

LexiconEntries Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconMatch ► LexiconEntries
Keyoti SearchUnit v6
Where in the occurrence file the word occurrs.
Declaration Syntax
C# Visual Basic
public ArrayList LexiconEntries { get; }
Public ReadOnly Property LexiconEntries As ArrayList
    Get
Property Value
ArrayList

Send comments on this topic to support@keyoti.com


MatchedStrings Property

MatchedStrings Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconMatch ► MatchedStrings
Keyoti SearchUnit v6
Any words that matched the query
Declaration Syntax
C# Visual Basic
public ArrayList MatchedStrings { get; set; }
Public Property MatchedStrings As ArrayList
    Get
    Set
Property Value
ArrayList

Send comments on this topic to support@keyoti.com


OriginatingQuery Property

OriginatingQuery Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconMatch ► OriginatingQuery
Keyoti SearchUnit v6
The query that made this match.
Declaration Syntax
C# Visual Basic
public LexiconQuery OriginatingQuery { get; }
Public ReadOnly Property OriginatingQuery As LexiconQuery
    Get
Property Value
LexiconQuery

Send comments on this topic to support@keyoti.com


TargetWordIndexInTerms Property

TargetWordIndexInTerms Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconMatch ► TargetWordIndexInTerms
Keyoti SearchUnit v6
The ID of the original word.
Declaration Syntax
C# Visual Basic
public int TargetWordIndexInTerms { get; set; }
Public Property TargetWordIndexInTerms As Integer
    Get
    Set
Property Value
Int32

Send comments on this topic to support@keyoti.com


TermIsTarget Method (termIndex)

TermIsTarget Method (termIndex)
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconMatch ► TermIsTarget(Int32)
Keyoti SearchUnit v6
Whether the matched term was the original target
Declaration Syntax
C# Visual Basic
public bool TermIsTarget(
    int termIndex
)
Public Function TermIsTarget (
    termIndex As Integer
) As Boolean
Parameters
termIndex (Int32)
Return Value
Boolean

Send comments on this topic to support@keyoti.com


Terms Property

Terms Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconMatch ► Terms
Keyoti SearchUnit v6
List of matching terms
Declaration Syntax
C# Visual Basic
public ArrayList Terms { get; set; }
Public Property Terms As ArrayList
    Get
    Set
Property Value
ArrayList

Send comments on this topic to support@keyoti.com


WordIDs Property

WordIDs Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconMatch ► WordIDs
Keyoti SearchUnit v6
Matching word Ids.
Declaration Syntax
C# Visual Basic
public ArrayList WordIDs { get; }
Public ReadOnly Property WordIDs As ArrayList
    Get
Property Value
ArrayList

Send comments on this topic to support@keyoti.com


LexiconMatchCollection Class

LexiconMatchCollection Class
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconMatchCollection
Keyoti SearchUnit v6
Collection of matches.
Declaration Syntax
C# Visual Basic
public class LexiconMatchCollection : ArrayList
Public Class LexiconMatchCollection
    Inherits ArrayList
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LexiconMatchCollection()()()() |
 | Add(Object) | (Inherited from ArrayList.)
 | AddRange(ICollection) | (Inherited from ArrayList.)
 | BinarySearch(Int32, Int32, Object, IComparer) | (Inherited from ArrayList.)
 | BinarySearch(Object) | (Inherited from ArrayList.)
 | BinarySearch(Object, IComparer) | (Inherited from ArrayList.)
 | Capacity | (Inherited from ArrayList.)
 | Clear()()()() | (Inherited from ArrayList.)
 | Clone()()()() | (Inherited from ArrayList.)
 | Contains(Object) | (Inherited from ArrayList.)
 | CopyTo(Array) | (Inherited from ArrayList.)
 | CopyTo(Array, Int32) | (Inherited from ArrayList.)
 | CopyTo(Int32, Array, Int32, Int32) | (Inherited from ArrayList.)
 | Count | (Inherited from ArrayList.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from ArrayList.)
 | GetEnumerator(Int32, Int32) | (Inherited from ArrayList.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetRange(Int32, Int32) | (Inherited from ArrayList.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(Object) | (Inherited from ArrayList.)
 | IndexOf(Object, Int32) | (Inherited from ArrayList.)
 | IndexOf(Object, Int32, Int32) | (Inherited from ArrayList.)
 | Insert(Int32, Object) | (Inherited from ArrayList.)
 | InsertRange(Int32, ICollection) | (Inherited from ArrayList.)
 | IsFixedSize | (Inherited from ArrayList.)
 | IsReadOnly | (Inherited from ArrayList.)
 | IsSynchronized | (Inherited from ArrayList.)
 | Item[([( Int32])]) | Indexer
 | LastIndexOf(Object) | (Inherited from ArrayList.)
 | LastIndexOf(Object, Int32) | (Inherited from ArrayList.)
 | LastIndexOf(Object, Int32, Int32) | (Inherited from ArrayList.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Remove(Object) | (Inherited from ArrayList.)
 | RemoveAt(Int32) | (Inherited from ArrayList.)
 | RemoveRange(Int32, Int32) | (Inherited from ArrayList.)
 | Reverse()()()() | (Inherited from ArrayList.)
 | Reverse(Int32, Int32) | (Inherited from ArrayList.)
 | SetRange(Int32, ICollection) | (Inherited from ArrayList.)
 | Sort()()()() | (Inherited from ArrayList.)
 | Sort(IComparer) | (Inherited from ArrayList.)
 | Sort(Int32, Int32, IComparer) | (Inherited from ArrayList.)
 | SyncRoot | (Inherited from ArrayList.)
 | ToArray()()()() | (Inherited from ArrayList.)
 | ToArray(Type) | (Inherited from ArrayList.)
 | ToString()()()() | (Inherited from Object.)
 | TrimToSize()()()() | (Inherited from ArrayList.)
Inheritance Hierarchy
Object
 | ArrayList
 |  | LexiconMatchCollection


LexiconMatchCollection Constructor

LexiconMatchCollection Constructor
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconMatchCollection ► LexiconMatchCollection()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public LexiconMatchCollection()
Public Sub New

Send comments on this topic to support@keyoti.com


Item Property (item)

Item Property (item)
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconMatchCollection ► Item[([( Int32])])
Keyoti SearchUnit v6
Indexer
Declaration Syntax
C# Visual Basic
public LexiconMatch this[
    int item
] { get; set; }
Public Default Property Item (
    item As Integer
) As LexiconMatch
    Get
    Set
Parameters
item (Int32)
Property Value
LexiconMatch

Send comments on this topic to support@keyoti.com


LexiconQuery Class

LexiconQuery Class
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconQuery
Keyoti SearchUnit v6
Specified a query for lexicon entry searches.
Declaration Syntax
C# Visual Basic
public class LexiconQuery
Public Class LexiconQuery
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LexiconQuery(String, ArrayList, LexiconSegmentMatchType, Configuration) | New instance
 | LexiconQuery(String, ArrayList, LexiconSegmentMatchType, Configuration, Int32, Boolean, ArrayList) | New instance
 | CaseSensitivity | Case sensitivity of matches
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IsMatch(String, CultureInfo) | Whether candidate is a suitable match for this query.
 | IsStopWord | Whether this query is a stop word as defined in the stop list.
 | LexiconMatch | The matches to this query.
 | LexiconSegmentMatchType | The type of segment match being looked for
 | MaximumNumberOfPartialMatchesToFind | The maximum number of partial matches to find
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Run()()()() | When no matches found, call to indicate that the lexicon is exhausted
 | Segment | Segment to look for
 | ToString()()()() | (Inherited from Object.)
 | Variations | The original word (first element) and all variations that were searched for.
Remarks
Used to define what words in the lexicon to return.
Inheritance Hierarchy
Object
LexiconQuery

Send comments on this topic to support@keyoti.com


LexiconQuery Constructor

LexiconQuery Constructor
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconQuery ► LexiconQuery()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | LexiconQuery(String, ArrayList, LexiconSegmentMatchType, Configuration) | New instance
 | LexiconQuery(String, ArrayList, LexiconSegmentMatchType, Configuration, Int32, Boolean, ArrayList) | New instance


LexiconQuery Constructor (segment, variations, type, configuration)

LexiconQuery Constructor (segment, variations, type, configuration)
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconQuery ► LexiconQuery(String, ArrayList, LexiconSegmentMatchType, Configuration)
Keyoti SearchUnit v6
New instance
Declaration Syntax
C# Visual Basic
public LexiconQuery(
    string segment,
    ArrayList variations,
    LexiconSegmentMatchType type,
    Configuration configuration
)
Public Sub New (
    segment As String,
    variations As ArrayList,
    type As LexiconSegmentMatchType,
    configuration As Configuration
)
Parameters
segment (String)
variations (ArrayList)
type (LexiconSegmentMatchType)
configuration (Configuration)


LexiconQuery Constructor (segment, variations, type, configuration, maximumNumberOfPartialMatchesToFind, needIDsPositions, matchedStrings)

LexiconQuery Constructor (segment, variations, type, configuration, maximumNumberOfPartialMatchesToFind, needIDsPositions, matchedStrings)
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconQuery ► LexiconQuery(String, ArrayList, LexiconSegmentMatchType, Configuration, Int32, Boolean, ArrayList)
Keyoti SearchUnit v6
New instance
Declaration Syntax
C# Visual Basic
public LexiconQuery(
    string segment,
    ArrayList variations,
    LexiconSegmentMatchType type,
    Configuration configuration,
    int maximumNumberOfPartialMatchesToFind,
    bool needIDsPositions,
    ArrayList matchedStrings
)
Public Sub New (
    segment As String,
    variations As ArrayList,
    type As LexiconSegmentMatchType,
    configuration As Configuration,
    maximumNumberOfPartialMatchesToFind As Integer,
    needIDsPositions As Boolean,
    matchedStrings As ArrayList
)
Parameters
segment (String)
variations (ArrayList)
type (LexiconSegmentMatchType)
configuration (Configuration)
maximumNumberOfPartialMatchesToFind (Int32)
needIDsPositions (Boolean)
matchedStrings (ArrayList)


CaseSensitivity Property

CaseSensitivity Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconQuery ► CaseSensitivity
Keyoti SearchUnit v6
Case sensitivity of matches
Declaration Syntax
C# Visual Basic
public CaseSensitivity CaseSensitivity { get; }
Public ReadOnly Property CaseSensitivity As CaseSensitivity
    Get
Property Value
CaseSensitivity

Send comments on this topic to support@keyoti.com


IsMatch Method (candidate, compareCulture)

IsMatch Method (candidate, compareCulture)
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconQuery ► IsMatch(String, CultureInfo)
Keyoti SearchUnit v6
Whether candidate is a suitable match for this query.
Declaration Syntax
C# Visual Basic
public virtual int IsMatch(
    string candidate,
    CultureInfo compareCulture
)
Public Overridable Function IsMatch (
    candidate As String,
    compareCulture As CultureInfo
) As Integer
Parameters
candidate (String)
compareCulture (CultureInfo)
Return Value
Int32
The element index in Variations of the match. -1 if no match found.


IsStopWord Property

IsStopWord Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconQuery ► IsStopWord
Keyoti SearchUnit v6
Whether this query is a stop word as defined in the stop list.
Declaration Syntax
C# Visual Basic
public bool IsStopWord { get; }
Public ReadOnly Property IsStopWord As Boolean
    Get
Property Value
Boolean

Send comments on this topic to support@keyoti.com


LexiconMatch Property

LexiconMatch Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconQuery ► LexiconMatch
Keyoti SearchUnit v6
The matches to this query.
Declaration Syntax
C# Visual Basic
public LexiconMatch LexiconMatch { get; }
Public ReadOnly Property LexiconMatch As LexiconMatch
    Get
Property Value
LexiconMatch
Remarks
Must be called only after the query has been Run


LexiconSegmentMatchType Property

LexiconSegmentMatchType Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconQuery ► LexiconSegmentMatchType
Keyoti SearchUnit v6
The type of segment match being looked for
Declaration Syntax
C# Visual Basic
public LexiconSegmentMatchType LexiconSegmentMatchType { get; }
Public ReadOnly Property LexiconSegmentMatchType As LexiconSegmentMatchType
    Get
Property Value
LexiconSegmentMatchType

Send comments on this topic to support@keyoti.com


MaximumNumberOfPartialMatchesToFind Property

MaximumNumberOfPartialMatchesToFind Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconQuery ► MaximumNumberOfPartialMatchesToFind
Keyoti SearchUnit v6
The maximum number of partial matches to find
Declaration Syntax
C# Visual Basic
public int MaximumNumberOfPartialMatchesToFind { get; }
Public ReadOnly Property MaximumNumberOfPartialMatchesToFind As Integer
    Get
Property Value
Int32

Send comments on this topic to support@keyoti.com


Run Method

Run Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconQuery ► Run()()()()
Keyoti SearchUnit v6
When no matches found, call to indicate that the lexicon is exhausted
Declaration Syntax
C# Visual Basic
public void Run()
Public Sub Run

Send comments on this topic to support@keyoti.com


Segment Property

Segment Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconQuery ► Segment
Keyoti SearchUnit v6
Segment to look for
Declaration Syntax
C# Visual Basic
public string Segment { get; }
Public ReadOnly Property Segment As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


Variations Property

Variations Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconQuery ► Variations
Keyoti SearchUnit v6
The original word (first element) and all variations that were searched for.
Declaration Syntax
C# Visual Basic
public virtual string[] Variations { get; }
Public Overridable ReadOnly Property Variations As String()
    Get
Property Value
array< String >[]()[][]


LexiconQueryCollection Class

LexiconQueryCollection Class
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconQueryCollection
Keyoti SearchUnit v6
Collection of query objects
Declaration Syntax
C# Visual Basic
public class LexiconQueryCollection : ArrayList
Public Class LexiconQueryCollection
    Inherits ArrayList
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LexiconQueryCollection()()()() |
 | Add(Object) | (Inherited from ArrayList.)
 | AddRange(ICollection) | (Inherited from ArrayList.)
 | BinarySearch(Int32, Int32, Object, IComparer) | (Inherited from ArrayList.)
 | BinarySearch(Object) | (Inherited from ArrayList.)
 | BinarySearch(Object, IComparer) | (Inherited from ArrayList.)
 | Capacity | (Inherited from ArrayList.)
 | Clear()()()() | (Inherited from ArrayList.)
 | Clone()()()() | (Inherited from ArrayList.)
 | Contains(Object) | (Inherited from ArrayList.)
 | CopyTo(Array) | (Inherited from ArrayList.)
 | CopyTo(Array, Int32) | (Inherited from ArrayList.)
 | CopyTo(Int32, Array, Int32, Int32) | (Inherited from ArrayList.)
 | Count | (Inherited from ArrayList.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from ArrayList.)
 | GetEnumerator(Int32, Int32) | (Inherited from ArrayList.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetRange(Int32, Int32) | (Inherited from ArrayList.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(Object) | (Inherited from ArrayList.)
 | IndexOf(Object, Int32) | (Inherited from ArrayList.)
 | IndexOf(Object, Int32, Int32) | (Inherited from ArrayList.)
 | Insert(Int32, Object) | (Inherited from ArrayList.)
 | InsertRange(Int32, ICollection) | (Inherited from ArrayList.)
 | IsFixedSize | (Inherited from ArrayList.)
 | IsReadOnly | (Inherited from ArrayList.)
 | IsSynchronized | (Inherited from ArrayList.)
 | Item[([( Int32])]) | Indexer
 | LastIndexOf(Object) | (Inherited from ArrayList.)
 | LastIndexOf(Object, Int32) | (Inherited from ArrayList.)
 | LastIndexOf(Object, Int32, Int32) | (Inherited from ArrayList.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Remove(Object) | (Inherited from ArrayList.)
 | RemoveAt(Int32) | (Inherited from ArrayList.)
 | RemoveRange(Int32, Int32) | (Inherited from ArrayList.)
 | Reverse()()()() | (Inherited from ArrayList.)
 | Reverse(Int32, Int32) | (Inherited from ArrayList.)
 | SetRange(Int32, ICollection) | (Inherited from ArrayList.)
 | Sort()()()() | (Inherited from ArrayList.)
 | Sort(IComparer) | (Inherited from ArrayList.)
 | Sort(Int32, Int32, IComparer) | (Inherited from ArrayList.)
 | SyncRoot | (Inherited from ArrayList.)
 | ToArray()()()() | (Inherited from ArrayList.)
 | ToArray(Type) | (Inherited from ArrayList.)
 | ToString()()()() | (Inherited from Object.)
 | TrimToSize()()()() | (Inherited from ArrayList.)
Inheritance Hierarchy
Object
 | ArrayList
 |  | LexiconQueryCollection


LexiconQueryCollection Constructor

LexiconQueryCollection Constructor
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconQueryCollection ► LexiconQueryCollection()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public LexiconQueryCollection()
Public Sub New

Send comments on this topic to support@keyoti.com


Item Property (item)

Item Property (item)
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconQueryCollection ► Item[([( Int32])])
Keyoti SearchUnit v6
Indexer
Declaration Syntax
C# Visual Basic
public LexiconQuery this[
    int item
] { get; set; }
Public Default Property Item (
    item As Integer
) As LexiconQuery
    Get
    Set
Parameters
item (Int32)
Property Value
LexiconQuery

Send comments on this topic to support@keyoti.com


LexiconSegmentMatchType Enumeration

LexiconSegmentMatchType Enumeration
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconSegmentMatchType
Keyoti SearchUnit v6
A type of word segment match (i.e. wildcard type).
Declaration Syntax
C# Visual Basic
public enum LexiconSegmentMatchType
Public Enumeration LexiconSegmentMatchType
Members
Member | Description
StartsWith | Will match any word that starts with the segment.
EndsWith | Will match any word that ends with the segment.
Contains | Will match any word that contains the segment.
Is | Will match any word that is equal to the segment.


LocationCategoryRecord Class

LocationCategoryRecord Class
API Documentation ► Keyoti.SearchEngine.DataAccess ► LocationCategoryRecord
Keyoti SearchUnit v6
Represents a document location type.
Declaration Syntax
C# Visual Basic
public class LocationCategoryRecord
Public Class LocationCategoryRecord
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LocationCategoryRecord()()()() | Obsolete. Creates a new default location.
 | LocationCategoryRecord(Int32, String, String) | Obsolete. Creates a new location.
 | LocationCategoryRecord(Int32, String, String, Boolean) | Creates a new location.
 | CreateDefaultLocationCategoryRecord()()()() | Creates the 'default' location record.
 | CreateLocationCategoryRecord(String, String) | Creates a new instance.
 | DeriveLocation(Uri, XmlDataAccess) | Returns the LocationCategory object which uri is within, if no specific matches, returns default location.
 | Equals(Object) | Determines if the 2 objects are equal (Overrides Object.Equals(Object).)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | Gets the hashcode based on the location name. (Overrides Object.GetHashCode()()()().)
 | GetType()()()() | (Inherited from Object.)
 | ID | The database ID of this location.
 | IsUriUnderRoot(Uri) | Whether uri is within this location.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name | The name of this location.
 | Root | The URL 'root' of this location, see remarks.
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | LocationCategoryRecord
 |  | SecurityGroupRecord


LocationCategoryRecord Constructor

LocationCategoryRecord Constructor
API Documentation ► Keyoti.SearchEngine.DataAccess ► LocationCategoryRecord ► LocationCategoryRecord()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | LocationCategoryRecord()()()() | Obsolete. Creates a new default location.
 | LocationCategoryRecord(Int32, String, String) | Obsolete. Creates a new location.
 | LocationCategoryRecord(Int32, String, String, Boolean) | Creates a new location.


LocationCategoryRecord Constructor

LocationCategoryRecord Constructor
API Documentation ► Keyoti.SearchEngine.DataAccess ► LocationCategoryRecord ► LocationCategoryRecord()()()()
Keyoti SearchUnit v6
Creates a new default location.
Declaration Syntax
C# Visual Basic
[ObsoleteAttribute("Use CreateDefaultLocationCategoryRecord or CreateLocationCategoryRecord instead, to create new instances.",
    true)]
public LocationCategoryRecord()
<ObsoleteAttribute("Use CreateDefaultLocationCategoryRecord or CreateLocationCategoryRecord instead, to create new instances.",
    true)>
Public Sub New

Send comments on this topic to support@keyoti.com


LocationCategoryRecord Constructor (locationID, locationName, locationRoot)

LocationCategoryRecord Constructor (locationID, locationName, locationRoot)
API Documentation ► Keyoti.SearchEngine.DataAccess ► LocationCategoryRecord ► LocationCategoryRecord(Int32, String, String)
Keyoti SearchUnit v6
Creates a new location.
Declaration Syntax
C# Visual Basic
[ObsoleteAttribute("Use CreateDefaultLocationCategoryRecord or CreateLocationCategoryRecord instead, to create new instances.",
    true)]
public LocationCategoryRecord(
    int locationID,
    string locationName,
    string locationRoot
)
<ObsoleteAttribute("Use CreateDefaultLocationCategoryRecord or CreateLocationCategoryRecord instead, to create new instances.",
    true)>
Public Sub New (
    locationID As Integer,
    locationName As String,
    locationRoot As String
)
Parameters
locationID (Int32)
The DB ID of the location
locationName (String)
The name of the location
locationRoot (String)
The location root

Send comments on this topic to support@keyoti.com


LocationCategoryRecord Constructor (locationID, locationName, locationRoot, internalUse)

LocationCategoryRecord Constructor (locationID, locationName, locationRoot, internalUse)
API Documentation ► Keyoti.SearchEngine.DataAccess ► LocationCategoryRecord ► LocationCategoryRecord(Int32, String, String, Boolean)
Keyoti SearchUnit v6
Creates a new location.
Declaration Syntax
C# Visual Basic
protected LocationCategoryRecord(
    int locationID,
    string locationName,
    string locationRoot,
    bool internalUse
)
Protected Sub New (
    locationID As Integer,
    locationName As String,
    locationRoot As String,
    internalUse As Boolean
)
Parameters
locationID (Int32)
The DB ID of the location
locationName (String)
The name of the location
locationRoot (String)
The location root
internalUse (Boolean)
Unused except to add an internal overload


CreateDefaultLocationCategoryRecord Method

CreateDefaultLocationCategoryRecord Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► LocationCategoryRecord ► CreateDefaultLocationCategoryRecord()()()()
Keyoti SearchUnit v6
Creates the 'default' location record.
Declaration Syntax
C# Visual Basic
public static LocationCategoryRecord CreateDefaultLocationCategoryRecord()
Public Shared Function CreateDefaultLocationCategoryRecord As LocationCategoryRecord
Return Value
LocationCategoryRecord

Send comments on this topic to support@keyoti.com


CreateLocationCategoryRecord Method (locationName, locationRoot)

CreateLocationCategoryRecord Method (locationName, locationRoot)
API Documentation ► Keyoti.SearchEngine.DataAccess ► LocationCategoryRecord ► CreateLocationCategoryRecord(String, String)
Keyoti SearchUnit v6
Creates a new instance.
Declaration Syntax
C# Visual Basic
public static LocationCategoryRecord CreateLocationCategoryRecord(
    string locationName,
    string locationRoot
)
Public Shared Function CreateLocationCategoryRecord (
    locationName As String,
    locationRoot As String
) As LocationCategoryRecord
Parameters
locationName (String)
The name of the location
locationRoot (String)
The 'root' path of the location
Return Value
LocationCategoryRecord

Send comments on this topic to support@keyoti.com


DeriveLocation Method (uri, dataAccess)

DeriveLocation Method (uri, dataAccess)
API Documentation ► Keyoti.SearchEngine.DataAccess ► LocationCategoryRecord ► DeriveLocation(Uri, XmlDataAccess)
Keyoti SearchUnit v6
Returns the LocationCategory object which uri is within, if no specific matches, returns default location.
Declaration Syntax
C# Visual Basic
public static LocationCategoryRecord DeriveLocation(
    Uri uri,
    XmlDataAccess dataAccess
)
Public Shared Function DeriveLocation (
    uri As Uri,
    dataAccess As XmlDataAccess
) As LocationCategoryRecord
Parameters
uri (Uri)
The Uri of the page to identify the location of
dataAccess (XmlDataAccess)
Data access layer object to use to read locations from.
Return Value
LocationCategoryRecord

Send comments on this topic to support@keyoti.com


Equals Method (obj)

Equals Method (obj)
API Documentation ► Keyoti.SearchEngine.DataAccess ► LocationCategoryRecord ► Equals(Object)
Keyoti SearchUnit v6
Determines if the 2 objects are equal
Declaration Syntax
C# Visual Basic
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Parameters
obj (Object)
Return Value
Boolean

Send comments on this topic to support@keyoti.com


GetHashCode Method

GetHashCode Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► LocationCategoryRecord ► GetHashCode()()()()
Keyoti SearchUnit v6
Gets the hashcode based on the location name.
Declaration Syntax
C# Visual Basic
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Return Value
Int32

Send comments on this topic to support@keyoti.com


ID Property

ID Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► LocationCategoryRecord ► ID
Keyoti SearchUnit v6
The database ID of this location.
Declaration Syntax
C# Visual Basic
public virtual int ID { get; }
Public Overridable ReadOnly Property ID As Integer
    Get
Property Value
Int32

Send comments on this topic to support@keyoti.com


IsUriUnderRoot Method (uri)

IsUriUnderRoot Method (uri)
API Documentation ► Keyoti.SearchEngine.DataAccess ► LocationCategoryRecord ► IsUriUnderRoot(Uri)
Keyoti SearchUnit v6
Whether uri is within this location.
Declaration Syntax
C# Visual Basic
public virtual bool IsUriUnderRoot(
    Uri uri
)
Public Overridable Function IsUriUnderRoot (
    uri As Uri
) As Boolean
Parameters
uri (Uri)
Return Value
Boolean

Send comments on this topic to support@keyoti.com


Name Property

Name Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► LocationCategoryRecord ► Name
Keyoti SearchUnit v6
The name of this location.
Declaration Syntax
C# Visual Basic
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


Root Property

Root Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► LocationCategoryRecord ► Root
Keyoti SearchUnit v6
The URL 'root' of this location, see remarks.
Declaration Syntax
C# Visual Basic
public virtual string Root { get; set; }
Public Overridable Property Root As String
    Get
    Set
Property Value
String
Remarks
Eg 1. Root = "http://www1.domain.com/", means that every page under http://www1.domain.com/ will automatically be assigned to this location. Eg 2. Root = "http://www1.domain.com/dir1/", means that every page under http://www1.domain.com/dir1/ will automatically be assigned to this location.


Log Class

Log Class
API Documentation ► Keyoti.SearchEngine.DataAccess ► Log
Keyoti SearchUnit v6
Writes log messages into the log file
Declaration Syntax
C# Visual Basic
public class Log
Public Class Log
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Log()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | WriteLogEntry(String, String, Configuration) | Writes a log entry
 | WriteLogEntry(String, String, String, Int32) |
Inheritance Hierarchy
Object
Log

Send comments on this topic to support@keyoti.com


Log Constructor

Log Constructor
API Documentation ► Keyoti.SearchEngine.DataAccess ► Log ► Log()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public Log()
Public Sub New

Send comments on this topic to support@keyoti.com


WriteLogEntry Method

WriteLogEntry Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► Log ► WriteLogEntry()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | WriteLogEntry(String, String, Configuration) | Writes a log entry
 | WriteLogEntry(String, String, String, Int32) |


WriteLogEntry Method (moduleName, logEntry, Configuration)

WriteLogEntry Method (moduleName, logEntry, Configuration)
API Documentation ► Keyoti.SearchEngine.DataAccess ► Log ► WriteLogEntry(String, String, Configuration)
Keyoti SearchUnit v6
Writes a log entry
Declaration Syntax
C# Visual Basic
public static void WriteLogEntry(
    string moduleName,
    string logEntry,
    Configuration Configuration
)
Public Shared Sub WriteLogEntry (
    moduleName As String,
    logEntry As String,
    Configuration As Configuration
)
Parameters
moduleName (String)
Used to identify which module wrote the entry.
logEntry (String)
Text for the log entry.
Configuration (Configuration)
The instance of the Configuration class that holds the settings to be used.


WriteLogEntry Method (moduleName, logEntry, indexDirectory, logFileMaxSize)

WriteLogEntry Method (moduleName, logEntry, indexDirectory, logFileMaxSize)
API Documentation ► Keyoti.SearchEngine.DataAccess ► Log ► WriteLogEntry(String, String, String, Int32)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public static void WriteLogEntry(
    string moduleName,
    string logEntry,
    string indexDirectory,
    int logFileMaxSize
)
Public Shared Sub WriteLogEntry (
    moduleName As String,
    logEntry As String,
    indexDirectory As String,
    logFileMaxSize As Integer
)
Parameters
moduleName (String)
logEntry (String)
indexDirectory (String)
logFileMaxSize (Int32)


OccurrenceMapIWordPositions Class

OccurrenceMapIWordPositions Class
API Documentation ► Keyoti.SearchEngine.DataAccess ► OccurrenceMapIWordPositions
Keyoti SearchUnit v6
Represents the occurrences of words within documents.
Declaration Syntax
C# Visual Basic
public class OccurrenceMapIWordPositions
Public Class OccurrenceMapIWordPositions
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OccurrenceMapIWordPositions(LexiconMatch) | Creates a new occurrence map.
 | AddDocumentID(Int32) | Allocates space for document with ID docID.
 | Contains(Int32) | Whether the document with ID docID is contained in this map.
 | ContainsKey(Int32) | Whether the map contains key
 | DocumentIDs | All document IDs in this map.
 | DocumentIDsCopyList | All document IDs in this map.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Match | The match.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
The indexer for this class is a document ID, the list returned contains occurrence IDs within that document.
Inheritance Hierarchy
Object
OccurrenceMapIWordPositions

Send comments on this topic to support@keyoti.com


OccurrenceMapIWordPositions Constructor (match)

OccurrenceMapIWordPositions Constructor (match)
API Documentation ► Keyoti.SearchEngine.DataAccess ► OccurrenceMapIWordPositions ► OccurrenceMapIWordPositions(LexiconMatch)
Keyoti SearchUnit v6
Creates a new occurrence map.
Declaration Syntax
C# Visual Basic
public OccurrenceMapIWordPositions(
    LexiconMatch match
)
Public Sub New (
    match As LexiconMatch
)
Parameters
match (LexiconMatch)


AddDocumentID Method (docID)

AddDocumentID Method (docID)
API Documentation ► Keyoti.SearchEngine.DataAccess ► OccurrenceMapIWordPositions ► AddDocumentID(Int32)
Keyoti SearchUnit v6
Allocates space for document with ID docID.
Declaration Syntax
C# Visual Basic
public virtual void AddDocumentID(
    int docID
)
Public Overridable Sub AddDocumentID (
    docID As Integer
)
Parameters
docID (Int32)


Contains Method (v)

Contains Method (v)
API Documentation ► Keyoti.SearchEngine.DataAccess ► OccurrenceMapIWordPositions ► Contains(Int32)
Keyoti SearchUnit v6
Whether the document with ID docID is contained in this map.
Declaration Syntax
C# Visual Basic
public virtual bool Contains(
    int v
)
Public Overridable Function Contains (
    v As Integer
) As Boolean
Parameters
v (Int32)
Return Value
Boolean

Send comments on this topic to support@keyoti.com


ContainsKey Method (key)

ContainsKey Method (key)
API Documentation ► Keyoti.SearchEngine.DataAccess ► OccurrenceMapIWordPositions ► ContainsKey(Int32)
Keyoti SearchUnit v6
Whether the map contains key
Declaration Syntax
C# Visual Basic
public bool ContainsKey(
    int key
)
Public Function ContainsKey (
    key As Integer
) As Boolean
Parameters
key (Int32)
Return Value
Boolean

Send comments on this topic to support@keyoti.com


DocumentIDs Property

DocumentIDs Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► OccurrenceMapIWordPositions ► DocumentIDs
Keyoti SearchUnit v6
All document IDs in this map.
Declaration Syntax
C# Visual Basic
public virtual IntList DocumentIDs { get; }
Public Overridable ReadOnly Property DocumentIDs As IntList
    Get
Property Value
IntList

Send comments on this topic to support@keyoti.com


DocumentIDsCopyList Property

DocumentIDsCopyList Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► OccurrenceMapIWordPositions ► DocumentIDsCopyList
Keyoti SearchUnit v6
All document IDs in this map.
Declaration Syntax
C# Visual Basic
public virtual IntList DocumentIDsCopyList { get; }
Public Overridable ReadOnly Property DocumentIDsCopyList As IntList
    Get
Property Value
IntList

Send comments on this topic to support@keyoti.com


Match Property

Match Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► OccurrenceMapIWordPositions ► Match
Keyoti SearchUnit v6
The match.
Declaration Syntax
C# Visual Basic
public LexiconMatch Match { get; }
Public ReadOnly Property Match As LexiconMatch
    Get
Property Value
LexiconMatch

Send comments on this topic to support@keyoti.com


SecurityGroupRecord Class

SecurityGroupRecord Class
API Documentation ► Keyoti.SearchEngine.DataAccess ► SecurityGroupRecord
Keyoti SearchUnit v6
Security group record.
Declaration Syntax
C# Visual Basic
public class SecurityGroupRecord : LocationCategoryRecord
Public Class SecurityGroupRecord
    Inherits LocationCategoryRecord
Members
All Members | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CreateDefaultSecurityGroupRecord()()()() | Creates a new default.
 | CreateSecurityGroupRecord(String, String) | Creates a new instance.
 | defaultGroupRecordName | The name for the default security group.
 | DeriveSecurityGroups(Uri, XmlDataAccess) | Returns the security group records which uri is within, if no specific matches, returns default group.
 | Equals(Object) | Determines if the 2 objects are equal (Inherited from LocationCategoryRecord.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | Gets the hashcode based on the location name. (Inherited from LocationCategoryRecord.)
 | GetType()()()() | (Inherited from Object.)
 | ID | The database ID of this location. (Inherited from LocationCategoryRecord.)
 | IsUriUnderRoot(Uri) | Whether uri is within this location. (Inherited from LocationCategoryRecord.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name | The name of this location. (Inherited from LocationCategoryRecord.)
 | Root | The URL 'root' of this location, see remarks. (Inherited from LocationCategoryRecord.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | LocationCategoryRecord
 |  | SecurityGroupRecord


CreateDefaultSecurityGroupRecord Method

CreateDefaultSecurityGroupRecord Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► SecurityGroupRecord ► CreateDefaultSecurityGroupRecord()()()()
Keyoti SearchUnit v6
Creates a new default.
Declaration Syntax
C# Visual Basic
public static SecurityGroupRecord CreateDefaultSecurityGroupRecord()
Public Shared Function CreateDefaultSecurityGroupRecord As SecurityGroupRecord
Return Value
SecurityGroupRecord

Send comments on this topic to support@keyoti.com


CreateSecurityGroupRecord Method (name, root)

CreateSecurityGroupRecord Method (name, root)
API Documentation ► Keyoti.SearchEngine.DataAccess ► SecurityGroupRecord ► CreateSecurityGroupRecord(String, String)
Keyoti SearchUnit v6
Creates a new instance.
Declaration Syntax
C# Visual Basic
public static SecurityGroupRecord CreateSecurityGroupRecord(
    string name,
    string root
)
Public Shared Function CreateSecurityGroupRecord (
    name As String,
    root As String
) As SecurityGroupRecord
Parameters
name (String)
The name of the location
root (String)
The 'root' path of the location
Return Value
SecurityGroupRecord

Send comments on this topic to support@keyoti.com


defaultGroupRecordName Field

defaultGroupRecordName Field
API Documentation ► Keyoti.SearchEngine.DataAccess ► SecurityGroupRecord ► defaultGroupRecordName
Keyoti SearchUnit v6
The name for the default security group.
Declaration Syntax
C# Visual Basic
public const string defaultGroupRecordName
Public Const defaultGroupRecordName As String
Field Value
String

Send comments on this topic to support@keyoti.com


DeriveSecurityGroups Method (uri, dataAccess)

DeriveSecurityGroups Method (uri, dataAccess)
API Documentation ► Keyoti.SearchEngine.DataAccess ► SecurityGroupRecord ► DeriveSecurityGroups(Uri, XmlDataAccess)
Keyoti SearchUnit v6
Returns the security group records which uri is within, if no specific matches, returns default group.
Declaration Syntax
C# Visual Basic
public static SecurityGroupRecordList DeriveSecurityGroups(
    Uri uri,
    XmlDataAccess dataAccess
)
Public Shared Function DeriveSecurityGroups (
    uri As Uri,
    dataAccess As XmlDataAccess
) As SecurityGroupRecordList
Parameters
uri (Uri)
The Uri of the page to identify the location of
dataAccess (XmlDataAccess)
Data access layer object to use to read locations from.
Return Value
SecurityGroupRecordList

Send comments on this topic to support@keyoti.com


StateTable Class

StateTable Class
API Documentation ► Keyoti.SearchEngine.DataAccess ► StateTable
Keyoti SearchUnit v6
Represents state table.
Declaration Syntax
C# Visual Basic
public class StateTable : XmlTable
Public Class StateTable
    Inherits XmlTable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StateTable(Configuration) | Creates a new instance.
 | changedTable | Flag indicating whether the table has changed. (Inherited from XmlTable.)
 | CheckWriteDefaultFile(String, Configuration) | Creates a default file if one doesn't exist
 | Configuration | The instance of the Configuration class that holds the settings to be used. (Inherited from XmlTable.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetState()()()() | Gets an IndexState object representing the state of the index.
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ReadTable(String) | Load an XmlDocument with the content of the xml file (Inherited from XmlTable.)
 | RemoveNode(String) | Removes from xml file the node selected by the queryString received from the derived class (Inherited from XmlTable.)
 | SetState(IndexState) | Updates the state in the database
 | ToString()()()() | (Inherited from Object.)
 | WriteTable()()()() | Writes content to the file
 | xmlDoc | The xml document. (Inherited from XmlTable.)
 | xmlEscape(String) | Escapes any quotes in val. (Inherited from XmlTable.)
 | xmlUnescape(String) | Unescapes any quotes in val. (Inherited from XmlTable.)
Inheritance Hierarchy
Object
 | XmlTable
 |  | StateTable


StateTable Constructor (configuration)

StateTable Constructor (configuration)
API Documentation ► Keyoti.SearchEngine.DataAccess ► StateTable ► StateTable(Configuration)
Keyoti SearchUnit v6
Creates a new instance.
Declaration Syntax
C# Visual Basic
public StateTable(
    Configuration configuration
)
Public Sub New (
    configuration As Configuration
)
Parameters
configuration (Configuration)
The instance of the Configuration class that holds the settings to be used.


CheckWriteDefaultFile Method (folderPath, configuration)

CheckWriteDefaultFile Method (folderPath, configuration)
API Documentation ► Keyoti.SearchEngine.DataAccess ► StateTable ► CheckWriteDefaultFile(String, Configuration)
Keyoti SearchUnit v6
Creates a default file if one doesn't exist
Declaration Syntax
C# Visual Basic
public static void CheckWriteDefaultFile(
    string folderPath,
    Configuration configuration
)
Public Shared Sub CheckWriteDefaultFile (
    folderPath As String,
    configuration As Configuration
)
Parameters
folderPath (String)
configuration (Configuration)


GetState Method

GetState Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► StateTable ► GetState()()()()
Keyoti SearchUnit v6
Gets an IndexState object representing the state of the index.
Declaration Syntax
C# Visual Basic
public virtual IndexState GetState()
Public Overridable Function GetState As IndexState
Return Value
IndexState

Send comments on this topic to support@keyoti.com


SetState Method (state)

SetState Method (state)
API Documentation ► Keyoti.SearchEngine.DataAccess ► StateTable ► SetState(IndexState)
Keyoti SearchUnit v6
Updates the state in the database
Declaration Syntax
C# Visual Basic
public virtual void SetState(
    IndexState state
)
Public Overridable Sub SetState (
    state As IndexState
)
Parameters
state (IndexState)


WriteTable Method

WriteTable Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► StateTable ► WriteTable()()()()
Keyoti SearchUnit v6
Writes content to the file
Declaration Syntax
C# Visual Basic
public virtual bool WriteTable()
Public Overridable Function WriteTable As Boolean
Return Value
Boolean

Send comments on this topic to support@keyoti.com


Word Class

Word Class
API Documentation ► Keyoti.SearchEngine.DataAccess ► Word
Keyoti SearchUnit v6
Incapsulates a word entity
Declaration Syntax
C# Visual Basic
public class Word
Public Class Word
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Word(String, Int32, Int32, Int32, Int32, Int32, Int32) | New instance.
 | Word(String) | New instance.
 | BoostFactor | The boost factor for this word
 | CompareTo(Word) | Compare to another instance.
 | EndPosition | End position
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InBody | How many occurrences of the word are in the body.
 | InTitle | How many occurrences of the word are in the title.
 | InURL | How many occurrences of the word are in the URL.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | StartPosition | Start position
 | ToString()()()() | (Inherited from Object.)
 | Weight | The weight assigned to this word.
 | WordContent | The actual word.
Inheritance Hierarchy
Object
Word

Send comments on this topic to support@keyoti.com


Word Constructor

Word Constructor
API Documentation ► Keyoti.SearchEngine.DataAccess ► Word ► Word()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Word(String, Int32, Int32, Int32, Int32, Int32, Int32) | New instance.
 | Word(String) | New instance.


Word Constructor (content)

Word Constructor (content)
API Documentation ► Keyoti.SearchEngine.DataAccess ► Word ► Word(String)
Keyoti SearchUnit v6
New instance.
Declaration Syntax
C# Visual Basic
public Word(
    string content
)
Public Sub New (
    content As String
)
Parameters
content (String)
The word as a string

Send comments on this topic to support@keyoti.com


Word Constructor (content, weight, inTitle, inURL, inBody, startPosition, endPosition)

Word Constructor (content, weight, inTitle, inURL, inBody, startPosition, endPosition)
API Documentation ► Keyoti.SearchEngine.DataAccess ► Word ► Word(String, Int32, Int32, Int32, Int32, Int32, Int32)
Keyoti SearchUnit v6
New instance.
Declaration Syntax
C# Visual Basic
public Word(
    string content,
    int weight,
    int inTitle,
    int inURL,
    int inBody,
    int startPosition,
    int endPosition
)
Public Sub New (
    content As String,
    weight As Integer,
    inTitle As Integer,
    inURL As Integer,
    inBody As Integer,
    startPosition As Integer,
    endPosition As Integer
)
Parameters
content (String)
The word as a string
weight (Int32)
The ranking weight of the word in the document
inTitle (Int32)
How many times this word is in the title
inURL (Int32)
How many times this word is in the URL
inBody (Int32)
How many times this word is in the body
startPosition (Int32)
Start of the word
endPosition (Int32)
End of the word

Send comments on this topic to support@keyoti.com


BoostFactor Property

BoostFactor Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► Word ► BoostFactor
Keyoti SearchUnit v6
The boost factor for this word
Declaration Syntax
C# Visual Basic
public float BoostFactor { get; set; }
Public Property BoostFactor As Single
    Get
    Set
Property Value
Single

Send comments on this topic to support@keyoti.com


CompareTo Method (other)

CompareTo Method (other)
API Documentation ► Keyoti.SearchEngine.DataAccess ► Word ► CompareTo(Word)
Keyoti SearchUnit v6
Compare to another instance.
Declaration Syntax
C# Visual Basic
public int CompareTo(
    Word other
)
Public Function CompareTo (
    other As Word
) As Integer
Parameters
other (Word)
Return Value
Int32

Send comments on this topic to support@keyoti.com


EndPosition Property

EndPosition Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► Word ► EndPosition
Keyoti SearchUnit v6
End position
Declaration Syntax
C# Visual Basic
public virtual int EndPosition { get; set; }
Public Overridable Property EndPosition As Integer
    Get
    Set
Property Value
Int32

Send comments on this topic to support@keyoti.com


InBody Property

InBody Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► Word ► InBody
Keyoti SearchUnit v6
How many occurrences of the word are in the body.
Declaration Syntax
C# Visual Basic
public virtual int InBody { get; set; }
Public Overridable Property InBody As Integer
    Get
    Set
Property Value
Int32

Send comments on this topic to support@keyoti.com


InTitle Property

InTitle Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► Word ► InTitle
Keyoti SearchUnit v6
How many occurrences of the word are in the title.
Declaration Syntax
C# Visual Basic
public virtual int InTitle { get; set; }
Public Overridable Property InTitle As Integer
    Get
    Set
Property Value
Int32

Send comments on this topic to support@keyoti.com


InURL Property

InURL Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► Word ► InURL
Keyoti SearchUnit v6
How many occurrences of the word are in the URL.
Declaration Syntax
C# Visual Basic
public virtual int InURL { get; set; }
Public Overridable Property InURL As Integer
    Get
    Set
Property Value
Int32

Send comments on this topic to support@keyoti.com


StartPosition Property

StartPosition Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► Word ► StartPosition
Keyoti SearchUnit v6
Start position
Declaration Syntax
C# Visual Basic
public virtual int StartPosition { get; set; }
Public Overridable Property StartPosition As Integer
    Get
    Set
Property Value
Int32

Send comments on this topic to support@keyoti.com


Weight Property

Weight Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► Word ► Weight
Keyoti SearchUnit v6
The weight assigned to this word.
Declaration Syntax
C# Visual Basic
public virtual int Weight { get; set; }
Public Overridable Property Weight As Integer
    Get
    Set
Property Value
Int32

Send comments on this topic to support@keyoti.com


WordContent Property

WordContent Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► Word ► WordContent
Keyoti SearchUnit v6
The actual word.
Declaration Syntax
C# Visual Basic
public virtual string WordContent { get; set; }
Public Overridable Property WordContent As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


WordCollection Class

WordCollection Class
API Documentation ► Keyoti.SearchEngine.DataAccess ► WordCollection
Keyoti SearchUnit v6
Word list wrapper.
Declaration Syntax
C# Visual Basic
public class WordCollection : List<Word>
Public Class WordCollection
    Inherits List(Of Word)
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WordCollection(ICollection) | New
 | WordCollection()()()() | New
 | WordCollection(Int32) | New
 | Add(T) | (Inherited from List <(Of <(<' Word >)>)>.)
 | AddRange(IEnumerable<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Word >)>)>.)
 | AsReadOnly()()()() | (Inherited from List <(Of <(<' Word >)>)>.)
 | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Word >)>)>.)
 | BinarySearch(T) | (Inherited from List <(Of <(<' Word >)>)>.)
 | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Word >)>)>.)
 | Capacity | (Inherited from List <(Of <(<' Word >)>)>.)
 | Clear()()()() | (Inherited from List <(Of <(<' Word >)>)>.)
 | Contains(T) | (Inherited from List <(Of <(<' Word >)>)>.)
 | ConvertAll<(Of <<'(TOutput>)>>)(Converter<(Of <<'(T, TOutput>)>>)) | (Inherited from List <(Of <(<' Word >)>)>.)
 | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' Word >)>)>.)
 | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' Word >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' Word >)>)>.)
 | Count | (Inherited from List <(Of <(<' Word >)>)>.)
 | Equals(Object) | (Inherited from Object.)
 | Exists(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Word >)>)>.)
 | Finalize()()()() | (Inherited from Object.)
 | Find(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Word >)>)>.)
 | FindAll(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Word >)>)>.)
 | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Word >)>)>.)
 | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Word >)>)>.)
 | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Word >)>)>.)
 | FindLast(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Word >)>)>.)
 | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Word >)>)>.)
 | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Word >)>)>.)
 | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Word >)>)>.)
 | ForEach(Action<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Word >)>)>.)
 | GetEnumerator()()()() | (Inherited from List <(Of <(<' Word >)>)>.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetRange(Int32, Int32) | (Inherited from List <(Of <(<' Word >)>)>.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(T) | (Inherited from List <(Of <(<' Word >)>)>.)
 | IndexOf(T, Int32) | (Inherited from List <(Of <(<' Word >)>)>.)
 | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Word >)>)>.)
 | Insert(Int32, T) | (Inherited from List <(Of <(<' Word >)>)>.)
 | InsertRange(Int32, IEnumerable<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Word >)>)>.)
 | Item[([( Int32])]) | (Inherited from List <(Of <(<' Word >)>)>.)
 | LastIndexOf(T) | (Inherited from List <(Of <(<' Word >)>)>.)
 | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' Word >)>)>.)
 | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Word >)>)>.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Remove(T) | (Inherited from List <(Of <(<' Word >)>)>.)
 | RemoveAll(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Word >)>)>.)
 | RemoveAt(Int32) | (Inherited from List <(Of <(<' Word >)>)>.)
 | RemoveRange(Int32, Int32) | (Inherited from List <(Of <(<' Word >)>)>.)
 | Reverse()()()() | (Inherited from List <(Of <(<' Word >)>)>.)
 | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' Word >)>)>.)
 | Sort()()()() | (Inherited from List <(Of <(<' Word >)>)>.)
 | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Word >)>)>.)
 | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Word >)>)>.)
 | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Word >)>)>.)
 | ToArray()()()() | (Inherited from List <(Of <(<' Word >)>)>.)
 | ToString()()()() | (Inherited from Object.)
 | TrimExcess()()()() | (Inherited from List <(Of <(<' Word >)>)>.)
 | TrueForAll(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Word >)>)>.)
Inheritance Hierarchy
Object
 | List <(Of <(<' Word >)>)>
 |  | WordCollection


WordCollection Constructor

WordCollection Constructor
API Documentation ► Keyoti.SearchEngine.DataAccess ► WordCollection ► WordCollection()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | WordCollection(ICollection) | New
 | WordCollection()()()() | New
 | WordCollection(Int32) | New


WordCollection Constructor

WordCollection Constructor
API Documentation ► Keyoti.SearchEngine.DataAccess ► WordCollection ► WordCollection()()()()
Keyoti SearchUnit v6
New
Declaration Syntax
C# Visual Basic
public WordCollection()
Public Sub New

Send comments on this topic to support@keyoti.com


WordCollection Constructor (col)

WordCollection Constructor (col)
API Documentation ► Keyoti.SearchEngine.DataAccess ► WordCollection ► WordCollection(ICollection)
Keyoti SearchUnit v6
New
Declaration Syntax
C# Visual Basic
public WordCollection(
    ICollection col
)
Public Sub New (
    col As ICollection
)
Parameters
col (ICollection)
Starting collection

Send comments on this topic to support@keyoti.com


WordCollection Constructor (c)

WordCollection Constructor (c)
API Documentation ► Keyoti.SearchEngine.DataAccess ► WordCollection ► WordCollection(Int32)
Keyoti SearchUnit v6
New
Declaration Syntax
C# Visual Basic
public WordCollection(
    int c
)
Public Sub New (
    c As Integer
)
Parameters
c (Int32)
Initial capacity

Send comments on this topic to support@keyoti.com


WordIDPositions Class

WordIDPositions Class
API Documentation ► Keyoti.SearchEngine.DataAccess ► WordIDPositions
Keyoti SearchUnit v6
Holds the position of word ids in the occurrence table
Declaration Syntax
C# Visual Basic
public class WordIDPositions : Hashtable
Public Class WordIDPositions
    Inherits Hashtable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WordIDPositions()()()() | New instance
 | Add(Object, Object) | (Inherited from Hashtable.)
 | Clear()()()() | (Inherited from Hashtable.)
 | Clone()()()() | (Inherited from Hashtable.)
 | comparer | Obsolete. (Inherited from Hashtable.)
 | Contains(Object) | (Inherited from Hashtable.)
 | ContainsKey(Object) | (Inherited from Hashtable.)
 | ContainsValue(Object) | (Inherited from Hashtable.)
 | CopyTo(Array, Int32) | (Inherited from Hashtable.)
 | Count | (Inherited from Hashtable.)
 | EqualityComparer | (Inherited from Hashtable.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from Hashtable.)
 | GetHash(Object) | (Inherited from Hashtable.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | (Inherited from Hashtable.)
 | GetType()()()() | (Inherited from Object.)
 | hcp | Obsolete. (Inherited from Hashtable.)
 | IsFixedSize | (Inherited from Hashtable.)
 | IsReadOnly | (Inherited from Hashtable.)
 | IsSynchronized | (Inherited from Hashtable.)
 | Item[([( Object])]) | (Inherited from Hashtable.)
 | KeyEquals(Object, Object) | (Inherited from Hashtable.)
 | Keys | (Inherited from Hashtable.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnDeserialization(Object) | (Inherited from Hashtable.)
 | Remove(Object) | (Inherited from Hashtable.)
 | SyncRoot | (Inherited from Hashtable.)
 | ToString()()()() | (Inherited from Object.)
 | Values | (Inherited from Hashtable.)
Inheritance Hierarchy
Object
 | Hashtable
 |  | WordIDPositions


WordIDPositions Constructor

WordIDPositions Constructor
API Documentation ► Keyoti.SearchEngine.DataAccess ► WordIDPositions ► WordIDPositions()()()()
Keyoti SearchUnit v6
New instance
Declaration Syntax
C# Visual Basic
public WordIDPositions()
Public Sub New

Send comments on this topic to support@keyoti.com


XmlContentTable Class

XmlContentTable Class
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlContentTable
Keyoti SearchUnit v6
Implements content categories table in an XML file.
Declaration Syntax
C# Visual Basic
public class XmlContentTable : XmlTable
Public Class XmlContentTable
    Inherits XmlTable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | XmlContentTable(Configuration) | Creates a new instance of the XmlContentTable.
 | Add(String) | Obsolete. Adds data from a content object to the table
 | Add(ContentCategoryRecord) | Adds data from a content object to the table
 | changedTable | Flag indicating whether the table has changed. (Inherited from XmlTable.)
 | Configuration | The instance of the Configuration class that holds the settings to be used. (Inherited from XmlTable.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetContentCategories()()()() | Returns list of contents known in the 'database'.
 | GetContentCategoryRecordFromID(Int32) | Gets ContentCategoryRecord for a content ID.
 | GetContentID(String) | Gets the ID for the specified contentCategory
 | GetHashCode()()()() | (Inherited from Object.)
 | GetIDs(String) | Gets ContentCategory ID for the specified ContentCategoryName (in addition, returns the LastUsedID)`
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ReadTable(String) | Load an XmlDocument with the content of the xml file (Inherited from XmlTable.)
 | Remove(String) | Builds the xpathQuery string for removing a ContentCategory node from xml file
 | RemoveNode(String) | Removes from xml file the node selected by the queryString received from the derived class (Inherited from XmlTable.)
 | ToString()()()() | (Inherited from Object.)
 | UpdateContentCategory(ContentCategoryRecord) | Updates a ContentCategory record (does not check for duplicates)
 | WriteTable()()()() | Writes modified content to the file
 | xmlDoc | The xml document. (Inherited from XmlTable.)
 | xmlEscape(String) | Escapes any quotes in val. (Inherited from XmlTable.)
 | xmlUnescape(String) | Unescapes any quotes in val. (Inherited from XmlTable.)
Inheritance Hierarchy
Object
 | XmlTable
 |  | XmlContentTable


XmlContentTable Constructor (configuration)

XmlContentTable Constructor (configuration)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlContentTable ► XmlContentTable(Configuration)
Keyoti SearchUnit v6
Creates a new instance of the XmlContentTable.
Declaration Syntax
C# Visual Basic
public XmlContentTable(
    Configuration configuration
)
Public Sub New (
    configuration As Configuration
)
Parameters
configuration (Configuration)
The instance of the Configuration class that holds the settings to be used.


Add Method

Add Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlContentTable ► Add()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Add(String) | Obsolete. Adds data from a content object to the table
 | Add(ContentCategoryRecord) | Adds data from a content object to the table


Add Method (content)

Add Method (content)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlContentTable ► Add(ContentCategoryRecord)
Keyoti SearchUnit v6
Adds data from a content object to the table
Declaration Syntax
C# Visual Basic
public virtual void Add(
    ContentCategoryRecord content
)
Public Overridable Sub Add (
    content As ContentCategoryRecord
)
Parameters
content (ContentCategoryRecord)


Add Method (content)

Add Method (content)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlContentTable ► Add(String)
Keyoti SearchUnit v6
Adds data from a content object to the table
Declaration Syntax
C# Visual Basic
[ObsoleteAttribute("Use Add(ContentCategoryRecord) instead.", true)]
public virtual void Add(
    string content
)
<ObsoleteAttribute("Use Add(ContentCategoryRecord) instead.", true)>
Public Overridable Sub Add (
    content As String
)
Parameters
content (String)


GetContentCategories Method

GetContentCategories Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlContentTable ► GetContentCategories()()()()
Keyoti SearchUnit v6
Returns list of contents known in the 'database'.
Declaration Syntax
C# Visual Basic
public virtual ArrayList GetContentCategories()
Public Overridable Function GetContentCategories As ArrayList
Return Value
ArrayList
ArrayList of ContentCategoryRecord objects


GetContentCategoryRecordFromID Method (contentID)

GetContentCategoryRecordFromID Method (contentID)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlContentTable ► GetContentCategoryRecordFromID(Int32)
Keyoti SearchUnit v6
Gets ContentCategoryRecord for a content ID.
Declaration Syntax
C# Visual Basic
public virtual ContentCategoryRecord GetContentCategoryRecordFromID(
    int contentID
)
Public Overridable Function GetContentCategoryRecordFromID (
    contentID As Integer
) As ContentCategoryRecord
Parameters
contentID (Int32)
ID of the content category.
Return Value
ContentCategoryRecord
ContentCategoryRecord object or null if not found


GetContentID Method (contentName)

GetContentID Method (contentName)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlContentTable ► GetContentID(String)
Keyoti SearchUnit v6
Gets the ID for the specified contentCategory
Declaration Syntax
C# Visual Basic
public virtual int GetContentID(
    string contentName
)
Public Overridable Function GetContentID (
    contentName As String
) As Integer
Parameters
contentName (String)
string contentCategory
Return Value
Int32
Content ID

Send comments on this topic to support@keyoti.com


GetIDs Method (content)

GetIDs Method (content)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlContentTable ► GetIDs(String)
Keyoti SearchUnit v6
Gets ContentCategory ID for the specified ContentCategoryName (in addition, returns the LastUsedID)`
Declaration Syntax
C# Visual Basic
public virtual int[] GetIDs(
    string content
)
Public Overridable Function GetIDs (
    content As String
) As Integer()
Parameters
content (String)
Return Value
array< Int32 >[]()[][]
2 dim. array of ints - document ID, and last ID used in the documents file


Remove Method (content)

Remove Method (content)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlContentTable ► Remove(String)
Keyoti SearchUnit v6
Builds the xpathQuery string for removing a ContentCategory node from xml file
Declaration Syntax
C# Visual Basic
public virtual void Remove(
    string content
)
Public Overridable Sub Remove (
    content As String
)
Parameters
content (String)
string, contentCategory


UpdateContentCategory Method (conRecord)

UpdateContentCategory Method (conRecord)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlContentTable ► UpdateContentCategory(ContentCategoryRecord)
Keyoti SearchUnit v6
Updates a ContentCategory record (does not check for duplicates)
Declaration Syntax
C# Visual Basic
public virtual void UpdateContentCategory(
    ContentCategoryRecord conRecord
)
Public Overridable Sub UpdateContentCategory (
    conRecord As ContentCategoryRecord
)
Parameters
conRecord (ContentCategoryRecord)
ContentCategoryRecord object

Send comments on this topic to support@keyoti.com


WriteTable Method

WriteTable Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlContentTable ► WriteTable()()()()
Keyoti SearchUnit v6
Writes modified content to the file
Declaration Syntax
C# Visual Basic
public virtual bool WriteTable()
Public Overridable Function WriteTable As Boolean
Return Value
Boolean

Send comments on this topic to support@keyoti.com


XmlDataAccess Class

XmlDataAccess Class
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess
Keyoti SearchUnit v6
Provides access to the data stored as XML files
Declaration Syntax
C# Visual Basic
public class XmlDataAccess
Public Class XmlDataAccess
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | XmlDataAccess(Configuration) | The facade for the entire data access layer.
 | AddContent(String) | Obsolete. Adds a content type to the index.
 | AddContent(ContentCategoryRecord) | Adds a content type to the index.
 | AddIndexableSourceRecord(IndexableSourceRecord) | Adds an indexable source record to the index.
 | AddLocation(LocationCategoryRecord) | Adds a new location to the index.
 | AddSecurityGroup(SecurityGroupRecord) | Adds a new security group to the index.
 | AutoAssignContentCategory(DocumentRecord, Boolean) | Automatically assigns the content category.
 | AutoAssignLocationCategory(DocumentRecord, Boolean) | Automatically assigns the location category.
 | AutoAssignSecurityGroup(DocumentRecord, Boolean) | Automatically assigns the security group.
 | Close()()()() | Updates the files with any modifications made since Open was called.
 | Configuration | Gets the instance of the Configuration class that holds the settings to be used.
 | EnsureDataStore()()()() | Creates files if some of them don't exist
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetContentCategories()()()() | Returns list of contents known in the index.
 | GetContentCategoryRecord(Int32) | Gets a ContentCategoryRecord based on the id of the content record.
 | GetContentCategoryRecord(String) | Gets a ContentCategoryRecord based on the name of the content record.
 | GetContentID(String) | Get's the ID corresponding to a content category name.
 | GetDocumentID(Uri) | Obsolete. Returns the document ID of the document specified by uri
 | GetHashCode()()()() | (Inherited from Object.)
 | GetIndexableSourceRecords()()()() | Gets list of IndexableSourceRecords contained in the index.
 | GetIndexState()()()() | Gets the index state
 | GetLastIndexDate()()()() | Returns the date when the last indexing was performed
 | GetLocationCategories()()()() | Returns list of locations known in the index.
 | GetLocationCategoryRecord(String) | Gets a LocationCategoryRecord based on the locationName.
 | GetLocationCategoryRecord(Int32) | Gets a LocationCategoryRecord based on the locationID.
 | GetLocationID(String) | Get's the ID corresponding to a location category name.
 | GetMatchingDocumentsAndOccurrencesForWord(String, ArrayList, Hashtable, SearchOptions, Boolean) | Obsolete. Gets an OccurrenceMap for a word.
 | GetMatchingDocumentsAndOccurrencesForWord(LexiconMatch, Hashtable, SearchOptions) | Obsolete. Obsolete
 | GetMatchingDocumentsAndOccurrencesWord(LexiconMatch, Hashtable, SearchOptions) | Obsolete. Gets an OccurrenceMap for a word.
 | GetSecurityGroupRecord(String) | Gets a SecurityGroupRecord based on the securityGroupName.
 | GetSecurityGroupRecord(Int32) | Gets a SecurityGroupRecord based on the locationID.
 | GetSecurityGroups()()()() | Returns list of security groups known in the index.
 | GetType()()()() | (Inherited from Object.)
 | GetWordVariations(Word) | Obsolete. Returns list of string objects with variations (lemmas) for a word, empty list if none found.
 | IsContentUsed(String) | Obsolete. Returns true if contentName is used by at least one document
 | IsIndexValid()()()() | Returns whether the current document index is complete.
 | IsLocationUsed(String) | Obsolete. Returns true if locationName is used by at least one document
 | IsOpen | Whether this is open.
 | LockMarkDateTime()()()() | Determines when the index is marked locked. If it isn't locked then DateTime.MinValue is returned.
 | MarkIndexLocked(Boolean) | Marks the index directory as locked/unlocked
 | MarkIndexValid(Boolean) | Marks the current document index as valid or not.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Open()()()() | Opens the data access layer by ensuring that necessary files exist.
 | RemoveContent(String) | Obsolete. Removes a content type from the index.
 | RemoveIndexableSourceRecord(IndexableSourceRecord) | Removes an indexable source record to the index.
 | RemoveLocation(String) | Obsolete. Removes a location from the index.
 | SetIndexState(IndexState) | Sets the index state
 | StateTable | Table holding the index state
 | ToString()()()() | (Inherited from Object.)
 | UpdateContentCategory(ContentCategoryRecord) | Updates a ContentCategory record, except the case when updated content's name is a duplicate (which is not allowed)
 | UpdateIndexableSourceRecord(IndexableSourceRecord) | Updates an indexable source record to the index.
 | UpdateLocationCategory(LocationCategoryRecord) | Updates a locationCategory record, except the case when updated location's name is a duplicate (which is not allowed)
 | UpdateSecurityGroup(SecurityGroupRecord) | Updates a securityGroup record, except the case when updated location's name is a duplicate (which is not allowed)
 | XmlContentTable | Gets the XmlContentTable.
 | XmlIndexableSourceRecordTable | Holds indexable source records
 | XmlLocationTable | Gets the XmlLocationTable.
 | XmlSecurityGroupTable | Gets the XmlSecurityGroupTable.
Inheritance Hierarchy
Object
XmlDataAccess

Send comments on this topic to support@keyoti.com


XmlDataAccess Constructor (configuration)

XmlDataAccess Constructor (configuration)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► XmlDataAccess(Configuration)
Keyoti SearchUnit v6
The facade for the entire data access layer.
Declaration Syntax
C# Visual Basic
public XmlDataAccess(
    Configuration configuration
)
Public Sub New (
    configuration As Configuration
)
Parameters
configuration (Configuration)
Configuration to use.


AddContent Method

AddContent Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► AddContent()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | AddContent(String) | Obsolete. Adds a content type to the index.
 | AddContent(ContentCategoryRecord) | Adds a content type to the index.


AddContent Method (content)

AddContent Method (content)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► AddContent(ContentCategoryRecord)
Keyoti SearchUnit v6
Adds a content type to the index.
Declaration Syntax
C# Visual Basic
public virtual void AddContent(
    ContentCategoryRecord content
)
Public Overridable Sub AddContent (
    content As ContentCategoryRecord
)
Parameters
content (ContentCategoryRecord)
The content category

Send comments on this topic to support@keyoti.com


AddContent Method (content)

AddContent Method (content)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► AddContent(String)
Keyoti SearchUnit v6
Adds a content type to the index.
Declaration Syntax
C# Visual Basic
[ObsoleteAttribute("Use AddContent(ContentCategoryRecord) instead.",
    true)]
public virtual void AddContent(
    string content
)
<ObsoleteAttribute("Use AddContent(ContentCategoryRecord) instead.",
    true)>
Public Overridable Sub AddContent (
    content As String
)
Parameters
content (String)
The content name

Send comments on this topic to support@keyoti.com


AddIndexableSourceRecord Method (indexableSourceRecord)

AddIndexableSourceRecord Method (indexableSourceRecord)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► AddIndexableSourceRecord(IndexableSourceRecord)
Keyoti SearchUnit v6
Adds an indexable source record to the index.
Declaration Syntax
C# Visual Basic
public int AddIndexableSourceRecord(
    IndexableSourceRecord indexableSourceRecord
)
Public Function AddIndexableSourceRecord (
    indexableSourceRecord As IndexableSourceRecord
) As Integer
Parameters
indexableSourceRecord (IndexableSourceRecord)
Return Value
Int32

Send comments on this topic to support@keyoti.com


AddLocation Method (locationCategory)

AddLocation Method (locationCategory)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► AddLocation(LocationCategoryRecord)
Keyoti SearchUnit v6
Adds a new location to the index.
Declaration Syntax
C# Visual Basic
public virtual void AddLocation(
    LocationCategoryRecord locationCategory
)
Public Overridable Sub AddLocation (
    locationCategory As LocationCategoryRecord
)
Parameters
locationCategory (LocationCategoryRecord)


AddSecurityGroup Method (securityGroup)

AddSecurityGroup Method (securityGroup)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► AddSecurityGroup(SecurityGroupRecord)
Keyoti SearchUnit v6
Adds a new security group to the index.
Declaration Syntax
C# Visual Basic
public virtual void AddSecurityGroup(
    SecurityGroupRecord securityGroup
)
Public Overridable Sub AddSecurityGroup (
    securityGroup As SecurityGroupRecord
)
Parameters
securityGroup (SecurityGroupRecord)


AutoAssignContentCategory Method (document, onlyUnassigned)

AutoAssignContentCategory Method (document, onlyUnassigned)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► AutoAssignContentCategory(DocumentRecord, Boolean)
Keyoti SearchUnit v6
Automatically assigns the content category.
Declaration Syntax
C# Visual Basic
public virtual void AutoAssignContentCategory(
    DocumentRecord document,
    bool onlyUnassigned
)
Public Overridable Sub AutoAssignContentCategory (
    document As DocumentRecord,
    onlyUnassigned As Boolean
)
Parameters
document (DocumentRecord)
The DocumentRecord to be assigned to categories.
onlyUnassigned (Boolean)
If true, only assigns a category when one (other than default) is not already set.


AutoAssignLocationCategory Method (document, onlyUnassigned)

AutoAssignLocationCategory Method (document, onlyUnassigned)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► AutoAssignLocationCategory(DocumentRecord, Boolean)
Keyoti SearchUnit v6
Automatically assigns the location category.
Declaration Syntax
C# Visual Basic
public virtual void AutoAssignLocationCategory(
    DocumentRecord document,
    bool onlyUnassigned
)
Public Overridable Sub AutoAssignLocationCategory (
    document As DocumentRecord,
    onlyUnassigned As Boolean
)
Parameters
document (DocumentRecord)
The DocumentRecord to be assigned to categories.
onlyUnassigned (Boolean)
If true, only assigns a category when one (other than default) is not already set.


AutoAssignSecurityGroup Method (document, onlyUnassigned)

AutoAssignSecurityGroup Method (document, onlyUnassigned)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► AutoAssignSecurityGroup(DocumentRecord, Boolean)
Keyoti SearchUnit v6
Automatically assigns the security group.
Declaration Syntax
C# Visual Basic
public virtual void AutoAssignSecurityGroup(
    DocumentRecord document,
    bool onlyUnassigned
)
Public Overridable Sub AutoAssignSecurityGroup (
    document As DocumentRecord,
    onlyUnassigned As Boolean
)
Parameters
document (DocumentRecord)
The DocumentRecord to be assigned a security group.
onlyUnassigned (Boolean)
If true, only assigns a security group when one (other than default) is not already set.


Close Method

Close Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► Close()()()()
Keyoti SearchUnit v6
Updates the files with any modifications made since Open was called.
Declaration Syntax
C# Visual Basic
public virtual void Close()
Public Overridable Sub Close

Send comments on this topic to support@keyoti.com


Configuration Property

Configuration Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► Configuration
Keyoti SearchUnit v6
Gets the instance of the Configuration class that holds the settings to be used.
Declaration Syntax
C# Visual Basic
public Configuration Configuration { get; }
Public ReadOnly Property Configuration As Configuration
    Get
Property Value
Configuration

Send comments on this topic to support@keyoti.com


EnsureDataStore Method

EnsureDataStore Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► EnsureDataStore()()()()
Keyoti SearchUnit v6
Creates files if some of them don't exist
Declaration Syntax
C# Visual Basic
protected virtual void EnsureDataStore()
Protected Overridable Sub EnsureDataStore


GetContentCategories Method

GetContentCategories Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► GetContentCategories()()()()
Keyoti SearchUnit v6
Returns list of contents known in the index.
Declaration Syntax
C# Visual Basic
public virtual ArrayList GetContentCategories()
Public Overridable Function GetContentCategories As ArrayList
Return Value
ArrayList
ArrayList of ContentCategoryRecord objects


GetContentCategoryRecord Method

GetContentCategoryRecord Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► GetContentCategoryRecord()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GetContentCategoryRecord(Int32) | Gets a ContentCategoryRecord based on the id of the content record.
 | GetContentCategoryRecord(String) | Gets a ContentCategoryRecord based on the name of the content record.


GetContentCategoryRecord Method (contentID)

GetContentCategoryRecord Method (contentID)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► GetContentCategoryRecord(Int32)
Keyoti SearchUnit v6
Gets a ContentCategoryRecord based on the id of the content record.
Declaration Syntax
C# Visual Basic
public virtual ContentCategoryRecord GetContentCategoryRecord(
    int contentID
)
Public Overridable Function GetContentCategoryRecord (
    contentID As Integer
) As ContentCategoryRecord
Parameters
contentID (Int32)
The id of an existing content category record.
Return Value
ContentCategoryRecord
The corresponding ContentCategoryRecord or null if none found.


GetContentCategoryRecord Method (contentName)

GetContentCategoryRecord Method (contentName)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► GetContentCategoryRecord(String)
Keyoti SearchUnit v6
Gets a ContentCategoryRecord based on the name of the content record.
Declaration Syntax
C# Visual Basic
public virtual ContentCategoryRecord GetContentCategoryRecord(
    string contentName
)
Public Overridable Function GetContentCategoryRecord (
    contentName As String
) As ContentCategoryRecord
Parameters
contentName (String)
The name of an existing content category record.
Return Value
ContentCategoryRecord
The corresponding ContentCategoryRecord or null if none found.


GetContentID Method (contentName)

GetContentID Method (contentName)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► GetContentID(String)
Keyoti SearchUnit v6
Get's the ID corresponding to a content category name.
Declaration Syntax
C# Visual Basic
public virtual int GetContentID(
    string contentName
)
Public Overridable Function GetContentID (
    contentName As String
) As Integer
Parameters
contentName (String)
Return Value
Int32

Send comments on this topic to support@keyoti.com


GetDocumentID Method (uri)

GetDocumentID Method (uri)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► GetDocumentID(Uri)
Keyoti SearchUnit v6
Returns the document ID of the document specified by uri
Declaration Syntax
C# Visual Basic
[ObsoleteAttribute("Method moved to DocumentIndex class.", true)]
public virtual int GetDocumentID(
    Uri uri
)
<ObsoleteAttribute("Method moved to DocumentIndex class.", true)>
Public Overridable Function GetDocumentID (
    uri As Uri
) As Integer
Parameters
uri (Uri)
Return Value
Int32

Send comments on this topic to support@keyoti.com


GetIndexableSourceRecords Method

GetIndexableSourceRecords Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► GetIndexableSourceRecords()()()()
Keyoti SearchUnit v6
Gets list of IndexableSourceRecords contained in the index.
Declaration Syntax
C# Visual Basic
public ArrayList GetIndexableSourceRecords()
Public Function GetIndexableSourceRecords As ArrayList
Return Value
ArrayList

Send comments on this topic to support@keyoti.com


GetIndexState Method

GetIndexState Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► GetIndexState()()()()
Keyoti SearchUnit v6
Gets the index state
Declaration Syntax
C# Visual Basic
public virtual IndexState GetIndexState()
Public Overridable Function GetIndexState As IndexState
Return Value
IndexState

Send comments on this topic to support@keyoti.com


GetLastIndexDate Method

GetLastIndexDate Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► GetLastIndexDate()()()()
Keyoti SearchUnit v6
Returns the date when the last indexing was performed
Declaration Syntax
C# Visual Basic
public virtual DateTime GetLastIndexDate()
Public Overridable Function GetLastIndexDate As DateTime
Return Value
DateTime
Date of the last indexing

Send comments on this topic to support@keyoti.com


GetLocationCategories Method

GetLocationCategories Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► GetLocationCategories()()()()
Keyoti SearchUnit v6
Returns list of locations known in the index.
Declaration Syntax
C# Visual Basic
public virtual ArrayList GetLocationCategories()
Public Overridable Function GetLocationCategories As ArrayList
Return Value
ArrayList
ArrayList of LocationCategoryRecord objects


GetLocationCategoryRecord Method

GetLocationCategoryRecord Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► GetLocationCategoryRecord()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GetLocationCategoryRecord(String) | Gets a LocationCategoryRecord based on the locationName.
 | GetLocationCategoryRecord(Int32) | Gets a LocationCategoryRecord based on the locationID.


GetLocationCategoryRecord Method (locationID)

GetLocationCategoryRecord Method (locationID)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► GetLocationCategoryRecord(Int32)
Keyoti SearchUnit v6
Gets a LocationCategoryRecord based on the locationID.
Declaration Syntax
C# Visual Basic
public virtual LocationCategoryRecord GetLocationCategoryRecord(
    int locationID
)
Public Overridable Function GetLocationCategoryRecord (
    locationID As Integer
) As LocationCategoryRecord
Parameters
locationID (Int32)
The id of an existing location category record.
Return Value
LocationCategoryRecord
The corresponding LocationCategoryRecord or null if none found.


GetLocationCategoryRecord Method (locationName)

GetLocationCategoryRecord Method (locationName)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► GetLocationCategoryRecord(String)
Keyoti SearchUnit v6
Gets a LocationCategoryRecord based on the locationName.
Declaration Syntax
C# Visual Basic
public virtual LocationCategoryRecord GetLocationCategoryRecord(
    string locationName
)
Public Overridable Function GetLocationCategoryRecord (
    locationName As String
) As LocationCategoryRecord
Parameters
locationName (String)
The name of an existing location category record.
Return Value
LocationCategoryRecord
The corresponding LocationCategoryRecord or null if none found.


GetLocationID Method (locationName)

GetLocationID Method (locationName)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► GetLocationID(String)
Keyoti SearchUnit v6
Get's the ID corresponding to a location category name.
Declaration Syntax
C# Visual Basic
public virtual int GetLocationID(
    string locationName
)
Public Overridable Function GetLocationID (
    locationName As String
) As Integer
Parameters
locationName (String)
Return Value
Int32

Send comments on this topic to support@keyoti.com


GetMatchingDocumentsAndOccurrencesForWord Method

GetMatchingDocumentsAndOccurrencesForWord Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► GetMatchingDocumentsAndOccurrencesForWord()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GetMatchingDocumentsAndOccurrencesForWord(String, ArrayList, Hashtable, SearchOptions, Boolean) | Obsolete. Gets an OccurrenceMap for a word.
 | GetMatchingDocumentsAndOccurrencesForWord(LexiconMatch, Hashtable, SearchOptions) | Obsolete. Obsolete


GetMatchingDocumentsAndOccurrencesForWord Method (word, cumulativeWeights, searchOptions)

GetMatchingDocumentsAndOccurrencesForWord Method (word, cumulativeWeights, searchOptions)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► GetMatchingDocumentsAndOccurrencesForWord(LexiconMatch, Hashtable, SearchOptions)
Keyoti SearchUnit v6
Obsolete
Declaration Syntax
C# Visual Basic
[ObsoleteAttribute("Use GetMatchingDocumentsForWord", true)]
public OccurrenceMapIWordPositions GetMatchingDocumentsAndOccurrencesForWord(
    LexiconMatch word,
    Hashtable cumulativeWeights,
    SearchOptions searchOptions
)
<ObsoleteAttribute("Use GetMatchingDocumentsForWord", true)>
Public Function GetMatchingDocumentsAndOccurrencesForWord (
    word As LexiconMatch,
    cumulativeWeights As Hashtable,
    searchOptions As SearchOptions
) As OccurrenceMapIWordPositions
Parameters
word (LexiconMatch)
cumulativeWeights (Hashtable)
searchOptions (SearchOptions)
Return Value
OccurrenceMapIWordPositions

Send comments on this topic to support@keyoti.com


GetMatchingDocumentsAndOccurrencesForWord Method (word, variations, cumulativeWeights, searchOptions, loadOccurrenceData)

GetMatchingDocumentsAndOccurrencesForWord Method (word, variations, cumulativeWeights, searchOptions, loadOccurrenceData)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► GetMatchingDocumentsAndOccurrencesForWord(String, ArrayList, Hashtable, SearchOptions, Boolean)
Keyoti SearchUnit v6
Gets an OccurrenceMap for a word.
Declaration Syntax
C# Visual Basic
[ObsoleteAttribute("Please use new method OccurrenceMap GetMatchingDocumentsAndOccurrencesForWord(LexiconQuery word, WordCollection variations, Hashtable cumulativeWeights, SearchOptions searchOptions,  bool loadOccurrenceData) instead.",
    true)]
public virtual OccurrenceMapIWordPositions GetMatchingDocumentsAndOccurrencesForWord(
    string word,
    ArrayList variations,
    Hashtable cumulativeWeights,
    SearchOptions searchOptions,
    bool loadOccurrenceData
)
<ObsoleteAttribute("Please use new method OccurrenceMap GetMatchingDocumentsAndOccurrencesForWord(LexiconQuery word, WordCollection variations, Hashtable cumulativeWeights, SearchOptions searchOptions,  bool loadOccurrenceData) instead.",
    true)>
Public Overridable Function GetMatchingDocumentsAndOccurrencesForWord (
    word As String,
    variations As ArrayList,
    cumulativeWeights As Hashtable,
    searchOptions As SearchOptions,
    loadOccurrenceData As Boolean
) As OccurrenceMapIWordPositions
Parameters
word (String)
Word to find occurrences of.
variations (ArrayList)
List of variations (lemmas) for the word.
cumulativeWeights (Hashtable)
Table of weights for occurrences (key=docID, value=word's weight in that doc).
searchOptions (SearchOptions)
Search options.
loadOccurrenceData (Boolean)
Whether to load occurrence data
Return Value
OccurrenceMapIWordPositions
All occurrences of word (or words in variations) that match.


GetMatchingDocumentsAndOccurrencesWord Method (word, cumulativeWeights, searchOptions)

GetMatchingDocumentsAndOccurrencesWord Method (word, cumulativeWeights, searchOptions)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► GetMatchingDocumentsAndOccurrencesWord(LexiconMatch, Hashtable, SearchOptions)
Keyoti SearchUnit v6
Gets an OccurrenceMap for a word.
Declaration Syntax
C# Visual Basic
[ObsoleteAttribute("Use GetMatchingDocumentsForWord", true)]
public virtual OccurrenceMapIWordPositions GetMatchingDocumentsAndOccurrencesWord(
    LexiconMatch word,
    Hashtable cumulativeWeights,
    SearchOptions searchOptions
)
<ObsoleteAttribute("Use GetMatchingDocumentsForWord", true)>
Public Overridable Function GetMatchingDocumentsAndOccurrencesWord (
    word As LexiconMatch,
    cumulativeWeights As Hashtable,
    searchOptions As SearchOptions
) As OccurrenceMapIWordPositions
Parameters
word (LexiconMatch)
Word to find occurrences of.
cumulativeWeights (Hashtable)
Table of weights for occurrences (key=docID, value=word's weight in that doc).
searchOptions (SearchOptions)
Search options.
Return Value
OccurrenceMapIWordPositions
All occurrences of word (or words in variations) that match.


GetSecurityGroupRecord Method

GetSecurityGroupRecord Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► GetSecurityGroupRecord()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GetSecurityGroupRecord(String) | Gets a SecurityGroupRecord based on the securityGroupName.
 | GetSecurityGroupRecord(Int32) | Gets a SecurityGroupRecord based on the locationID.


GetSecurityGroupRecord Method (locationID)

GetSecurityGroupRecord Method (locationID)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► GetSecurityGroupRecord(Int32)
Keyoti SearchUnit v6
Gets a SecurityGroupRecord based on the locationID.
Declaration Syntax
C# Visual Basic
public virtual SecurityGroupRecord GetSecurityGroupRecord(
    int locationID
)
Public Overridable Function GetSecurityGroupRecord (
    locationID As Integer
) As SecurityGroupRecord
Parameters
locationID (Int32)
The id of an existing location category record.
Return Value
SecurityGroupRecord
The corresponding SecurityGroupRecord or null if none found.


GetSecurityGroupRecord Method (securityGroupName)

GetSecurityGroupRecord Method (securityGroupName)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► GetSecurityGroupRecord(String)
Keyoti SearchUnit v6
Gets a SecurityGroupRecord based on the securityGroupName.
Declaration Syntax
C# Visual Basic
public virtual SecurityGroupRecord GetSecurityGroupRecord(
    string securityGroupName
)
Public Overridable Function GetSecurityGroupRecord (
    securityGroupName As String
) As SecurityGroupRecord
Parameters
securityGroupName (String)
The name of an existing group record.
Return Value
SecurityGroupRecord
The corresponding SecurityGroupRecord or null if none found.


GetSecurityGroups Method

GetSecurityGroups Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► GetSecurityGroups()()()()
Keyoti SearchUnit v6
Returns list of security groups known in the index.
Declaration Syntax
C# Visual Basic
public virtual SecurityGroupRecordList GetSecurityGroups()
Public Overridable Function GetSecurityGroups As SecurityGroupRecordList
Return Value
SecurityGroupRecordList
SecurityGroupRecordList of LocationCategoryRecord objects


GetWordVariations Method (word)

GetWordVariations Method (word)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► GetWordVariations(Word)
Keyoti SearchUnit v6
Returns list of string objects with variations (lemmas) for a word, empty list if none found.
Declaration Syntax
C# Visual Basic
[ObsoleteAttribute("Use DocumentIndex.GetWordVariations instead.", false)]
public virtual ArrayList GetWordVariations(
    Word word
)
<ObsoleteAttribute("Use DocumentIndex.GetWordVariations instead.", false)>
Public Overridable Function GetWordVariations (
    word As Word
) As ArrayList
Parameters
word (Word)
Return Value
ArrayList

Send comments on this topic to support@keyoti.com


IsContentUsed Method (contentName)

IsContentUsed Method (contentName)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► IsContentUsed(String)
Keyoti SearchUnit v6
Returns true if contentName is used by at least one document
Declaration Syntax
C# Visual Basic
[ObsoleteAttribute("Method moved to DocumentIndex class.", true)]
public virtual bool IsContentUsed(
    string contentName
)
<ObsoleteAttribute("Method moved to DocumentIndex class.", true)>
Public Overridable Function IsContentUsed (
    contentName As String
) As Boolean
Parameters
contentName (String)
Return Value
Boolean

Send comments on this topic to support@keyoti.com


IsIndexValid Method

IsIndexValid Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► IsIndexValid()()()()
Keyoti SearchUnit v6
Returns whether the current document index is complete.
Declaration Syntax
C# Visual Basic
public virtual bool IsIndexValid()
Public Overridable Function IsIndexValid As Boolean
Return Value
Boolean
Remarks
This will typically return false if the previous build was cancelled.


IsLocationUsed Method (locationName)

IsLocationUsed Method (locationName)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► IsLocationUsed(String)
Keyoti SearchUnit v6
Returns true if locationName is used by at least one document
Declaration Syntax
C# Visual Basic
[ObsoleteAttribute("Method moved to DocumentIndex class.", true)]
public virtual bool IsLocationUsed(
    string locationName
)
<ObsoleteAttribute("Method moved to DocumentIndex class.", true)>
Public Overridable Function IsLocationUsed (
    locationName As String
) As Boolean
Parameters
locationName (String)
Return Value
Boolean

Send comments on this topic to support@keyoti.com


IsOpen Property

IsOpen Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► IsOpen
Keyoti SearchUnit v6
Whether this is open.
Declaration Syntax
C# Visual Basic
public bool IsOpen { get; }
Public ReadOnly Property IsOpen As Boolean
    Get
Property Value
Boolean

Send comments on this topic to support@keyoti.com


LockMarkDateTime Method

LockMarkDateTime Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► LockMarkDateTime()()()()
Keyoti SearchUnit v6
Determines when the index is marked locked. If it isn't locked then DateTime.MinValue is returned.
Declaration Syntax
C# Visual Basic
public virtual DateTime LockMarkDateTime()
Public Overridable Function LockMarkDateTime As DateTime
Return Value
DateTime

Send comments on this topic to support@keyoti.com


MarkIndexLocked Method (locked)

MarkIndexLocked Method (locked)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► MarkIndexLocked(Boolean)
Keyoti SearchUnit v6
Marks the index directory as locked/unlocked
Declaration Syntax
C# Visual Basic
public virtual void MarkIndexLocked(
    bool locked
)
Public Overridable Sub MarkIndexLocked (
    locked As Boolean
)
Parameters
locked (Boolean)


MarkIndexValid Method (valid)

MarkIndexValid Method (valid)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► MarkIndexValid(Boolean)
Keyoti SearchUnit v6
Marks the current document index as valid or not.
Declaration Syntax
C# Visual Basic
public virtual void MarkIndexValid(
    bool valid
)
Public Overridable Sub MarkIndexValid (
    valid As Boolean
)
Parameters
valid (Boolean)
Whether the index is valid

Send comments on this topic to support@keyoti.com


Open Method

Open Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► Open()()()()
Keyoti SearchUnit v6
Opens the data access layer by ensuring that necessary files exist.
Declaration Syntax
C# Visual Basic
public virtual void Open()
Public Overridable Sub Open

Send comments on this topic to support@keyoti.com


RemoveContent Method (content)

RemoveContent Method (content)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► RemoveContent(String)
Keyoti SearchUnit v6
Removes a content type from the index.
Declaration Syntax
C# Visual Basic
[ObsoleteAttribute("Use DocumentIndex.RemoveContent instead - for safety it will first check if the content is used.",
    true)]
public virtual void RemoveContent(
    string content
)
<ObsoleteAttribute("Use DocumentIndex.RemoveContent instead - for safety it will first check if the content is used.",
    true)>
Public Overridable Sub RemoveContent (
    content As String
)
Parameters
content (String)
The content name

Send comments on this topic to support@keyoti.com


RemoveIndexableSourceRecord Method (indexableSourceRecord)

RemoveIndexableSourceRecord Method (indexableSourceRecord)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► RemoveIndexableSourceRecord(IndexableSourceRecord)
Keyoti SearchUnit v6
Removes an indexable source record to the index.
Declaration Syntax
C# Visual Basic
public void RemoveIndexableSourceRecord(
    IndexableSourceRecord indexableSourceRecord
)
Public Sub RemoveIndexableSourceRecord (
    indexableSourceRecord As IndexableSourceRecord
)
Parameters
indexableSourceRecord (IndexableSourceRecord)


RemoveLocation Method (locationName)

RemoveLocation Method (locationName)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► RemoveLocation(String)
Keyoti SearchUnit v6
Removes a location from the index.
Declaration Syntax
C# Visual Basic
[ObsoleteAttribute("Use DocumentIndex.RemoveLocation instead - for safety it will first check if the location is used.",
    true)]
public virtual void RemoveLocation(
    string locationName
)
<ObsoleteAttribute("Use DocumentIndex.RemoveLocation instead - for safety it will first check if the location is used.",
    true)>
Public Overridable Sub RemoveLocation (
    locationName As String
)
Parameters
locationName (String)


SetIndexState Method (state)

SetIndexState Method (state)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► SetIndexState(IndexState)
Keyoti SearchUnit v6
Sets the index state
Declaration Syntax
C# Visual Basic
public virtual void SetIndexState(
    IndexState state
)
Public Overridable Sub SetIndexState (
    state As IndexState
)
Parameters
state (IndexState)


StateTable Property

StateTable Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► StateTable
Keyoti SearchUnit v6
Table holding the index state
Declaration Syntax
C# Visual Basic
public virtual StateTable StateTable { get; }
Public Overridable ReadOnly Property StateTable As StateTable
    Get
Property Value
StateTable

Send comments on this topic to support@keyoti.com


UpdateContentCategory Method (conRecord)

UpdateContentCategory Method (conRecord)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► UpdateContentCategory(ContentCategoryRecord)
Keyoti SearchUnit v6
Updates a ContentCategory record, except the case when updated content's name is a duplicate (which is not allowed)
Declaration Syntax
C# Visual Basic
public virtual bool UpdateContentCategory(
    ContentCategoryRecord conRecord
)
Public Overridable Function UpdateContentCategory (
    conRecord As ContentCategoryRecord
) As Boolean
Parameters
conRecord (ContentCategoryRecord)
ContentCategoryRecord object
Return Value
Boolean
true - if update was performed, false otherwise.


UpdateIndexableSourceRecord Method (indexableSourceRecord)

UpdateIndexableSourceRecord Method (indexableSourceRecord)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► UpdateIndexableSourceRecord(IndexableSourceRecord)
Keyoti SearchUnit v6
Updates an indexable source record to the index.
Declaration Syntax
C# Visual Basic
public void UpdateIndexableSourceRecord(
    IndexableSourceRecord indexableSourceRecord
)
Public Sub UpdateIndexableSourceRecord (
    indexableSourceRecord As IndexableSourceRecord
)
Parameters
indexableSourceRecord (IndexableSourceRecord)


UpdateLocationCategory Method (locRecord)

UpdateLocationCategory Method (locRecord)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► UpdateLocationCategory(LocationCategoryRecord)
Keyoti SearchUnit v6
Updates a locationCategory record, except the case when updated location's name is a duplicate (which is not allowed)
Declaration Syntax
C# Visual Basic
public virtual bool UpdateLocationCategory(
    LocationCategoryRecord locRecord
)
Public Overridable Function UpdateLocationCategory (
    locRecord As LocationCategoryRecord
) As Boolean
Parameters
locRecord (LocationCategoryRecord)
LocationCategoryRecord object
Return Value
Boolean
true - if update was performed, false otherwise.


UpdateSecurityGroup Method (locRecord)

UpdateSecurityGroup Method (locRecord)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► UpdateSecurityGroup(SecurityGroupRecord)
Keyoti SearchUnit v6
Updates a securityGroup record, except the case when updated location's name is a duplicate (which is not allowed)
Declaration Syntax
C# Visual Basic
public virtual bool UpdateSecurityGroup(
    SecurityGroupRecord locRecord
)
Public Overridable Function UpdateSecurityGroup (
    locRecord As SecurityGroupRecord
) As Boolean
Parameters
locRecord (SecurityGroupRecord)
SecurityGroupRecord object
Return Value
Boolean
true - if update was performed, false otherwise.


XmlContentTable Property

XmlContentTable Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► XmlContentTable
Keyoti SearchUnit v6
Gets the XmlContentTable.
Declaration Syntax
C# Visual Basic
public virtual XmlContentTable XmlContentTable { get; }
Public Overridable ReadOnly Property XmlContentTable As XmlContentTable
    Get
Property Value
XmlContentTable

Send comments on this topic to support@keyoti.com


XmlIndexableSourceRecordTable Property

XmlIndexableSourceRecordTable Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► XmlIndexableSourceRecordTable
Keyoti SearchUnit v6
Holds indexable source records
Declaration Syntax
C# Visual Basic
public virtual XmlIndexableSourceRecordTable XmlIndexableSourceRecordTable { get; }
Public Overridable ReadOnly Property XmlIndexableSourceRecordTable As XmlIndexableSourceRecordTable
    Get
Property Value
XmlIndexableSourceRecordTable

Send comments on this topic to support@keyoti.com


XmlLocationTable Property

XmlLocationTable Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► XmlLocationTable
Keyoti SearchUnit v6
Gets the XmlLocationTable.
Declaration Syntax
C# Visual Basic
public virtual XmlLocationTable XmlLocationTable { get; }
Public Overridable ReadOnly Property XmlLocationTable As XmlLocationTable
    Get
Property Value
XmlLocationTable

Send comments on this topic to support@keyoti.com


XmlSecurityGroupTable Property

XmlSecurityGroupTable Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlDataAccess ► XmlSecurityGroupTable
Keyoti SearchUnit v6
Gets the XmlSecurityGroupTable.
Declaration Syntax
C# Visual Basic
public virtual XmlSecurityGroupTable XmlSecurityGroupTable { get; }
Public Overridable ReadOnly Property XmlSecurityGroupTable As XmlSecurityGroupTable
    Get
Property Value
XmlSecurityGroupTable

Send comments on this topic to support@keyoti.com


XmlIndexableSourceRecordTable Class

XmlIndexableSourceRecordTable Class
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlIndexableSourceRecordTable
Keyoti SearchUnit v6
Table holding indexable source records.
Declaration Syntax
C# Visual Basic
public class XmlIndexableSourceRecordTable : XmlTable
Public Class XmlIndexableSourceRecordTable
    Inherits XmlTable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | XmlIndexableSourceRecordTable(Configuration) | New instance
 | Add(IndexableSourceRecord) | Adds a record
 | changedTable | Flag indicating whether the table has changed. (Inherited from XmlTable.)
 | Configuration | The instance of the Configuration class that holds the settings to be used. (Inherited from XmlTable.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetIDs(String, String) | Gets the ID of the record matching location/query
 | GetIndexableSourceRecords()()()() | Gets all records
 | GetIndexedDataSources()()()() | Builds the XmlDocument DOM for DataSourceRecords
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ReadTable(String) | Load an XmlDocument with the content of the xml file (Inherited from XmlTable.)
 | Remove(IndexableSourceRecord) | Removes a record
 | RemoveNode(String) | Removes from xml file the node selected by the queryString received from the derived class (Inherited from XmlTable.)
 | ToString()()()() | (Inherited from Object.)
 | Update(IndexableSourceRecord) | Updates a record of the same ID as indexableSourceRecord
 | WriteTable()()()() | Writes the table
 | xmlDoc | The xml document. (Inherited from XmlTable.)
 | xmlEscape(String) | Escapes any quotes in val. (Inherited from XmlTable.)
 | xmlUnescape(String) | Unescapes any quotes in val. (Inherited from XmlTable.)
Inheritance Hierarchy
Object
 | XmlTable
 |  | XmlIndexableSourceRecordTable


XmlIndexableSourceRecordTable Constructor (configuration)

XmlIndexableSourceRecordTable Constructor (configuration)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlIndexableSourceRecordTable ► XmlIndexableSourceRecordTable(Configuration)
Keyoti SearchUnit v6
New instance
Declaration Syntax
C# Visual Basic
public XmlIndexableSourceRecordTable(
    Configuration configuration
)
Public Sub New (
    configuration As Configuration
)
Parameters
configuration (Configuration)
The configuration to use.


Add Method (indexableSourceRecord)

Add Method (indexableSourceRecord)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlIndexableSourceRecordTable ► Add(IndexableSourceRecord)
Keyoti SearchUnit v6
Adds a record
Declaration Syntax
C# Visual Basic
public virtual int Add(
    IndexableSourceRecord indexableSourceRecord
)
Public Overridable Function Add (
    indexableSourceRecord As IndexableSourceRecord
) As Integer
Parameters
indexableSourceRecord (IndexableSourceRecord)
Return Value
Int32

Send comments on this topic to support@keyoti.com


GetIDs Method (location, query)

GetIDs Method (location, query)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlIndexableSourceRecordTable ► GetIDs(String, String)
Keyoti SearchUnit v6
Gets the ID of the record matching location/query
Declaration Syntax
C# Visual Basic
public virtual int[] GetIDs(
    string location,
    string query
)
Public Overridable Function GetIDs (
    location As String,
    query As String
) As Integer()
Parameters
location (String)
Record 'location' field
query (String)
Record 'query' field
Return Value
array< Int32 >[]()[][]
2 element array. 1st element is ID of the record (or 0 if not found) and 2nd element is the last used ID in the table.


GetIndexableSourceRecords Method

GetIndexableSourceRecords Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlIndexableSourceRecordTable ► GetIndexableSourceRecords()()()()
Keyoti SearchUnit v6
Gets all records
Declaration Syntax
C# Visual Basic
public virtual ArrayList GetIndexableSourceRecords()
Public Overridable Function GetIndexableSourceRecords As ArrayList
Return Value
ArrayList

Send comments on this topic to support@keyoti.com


GetIndexedDataSources Method

GetIndexedDataSources Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlIndexableSourceRecordTable ► GetIndexedDataSources()()()()
Keyoti SearchUnit v6
Builds the XmlDocument DOM for DataSourceRecords
Declaration Syntax
C# Visual Basic
public virtual XmlDocument GetIndexedDataSources()
Public Overridable Function GetIndexedDataSources As XmlDocument
Return Value
XmlDocument

Send comments on this topic to support@keyoti.com


Remove Method (indexableSourceRecord)

Remove Method (indexableSourceRecord)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlIndexableSourceRecordTable ► Remove(IndexableSourceRecord)
Keyoti SearchUnit v6
Removes a record
Declaration Syntax
C# Visual Basic
public virtual void Remove(
    IndexableSourceRecord indexableSourceRecord
)
Public Overridable Sub Remove (
    indexableSourceRecord As IndexableSourceRecord
)
Parameters
indexableSourceRecord (IndexableSourceRecord)


Update Method (indexableSourceRecord)

Update Method (indexableSourceRecord)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlIndexableSourceRecordTable ► Update(IndexableSourceRecord)
Keyoti SearchUnit v6
Updates a record of the same ID as indexableSourceRecord
Declaration Syntax
C# Visual Basic
public virtual void Update(
    IndexableSourceRecord indexableSourceRecord
)
Public Overridable Sub Update (
    indexableSourceRecord As IndexableSourceRecord
)
Parameters
indexableSourceRecord (IndexableSourceRecord)
The record to update

Send comments on this topic to support@keyoti.com


WriteTable Method

WriteTable Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlIndexableSourceRecordTable ► WriteTable()()()()
Keyoti SearchUnit v6
Writes the table
Declaration Syntax
C# Visual Basic
public virtual bool WriteTable()
Public Overridable Function WriteTable As Boolean
Return Value
Boolean
Whether the table had changed before it was written


XmlLocationTable Class

XmlLocationTable Class
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlLocationTable
Keyoti SearchUnit v6
Represents location category table.
Declaration Syntax
C# Visual Basic
public class XmlLocationTable : XmlTable
Public Class XmlLocationTable
    Inherits XmlTable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | XmlLocationTable(Configuration) | Creates a new instance of the XmlLocationTable.
 | Add(LocationCategoryRecord) | Adds a location
 | BuildImportTimeLocationsCache | Creates a cache.
 | changedTable | Flag indicating whether the table has changed. (Inherited from XmlTable.)
 | Configuration | The instance of the Configuration class that holds the settings to be used. (Inherited from XmlTable.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetIDs(String) | Gets locationCategoryID for the specified location category name (in addition, returns the last used ID)`
 | GetLocationCategories()()()() | Returns list of locations known in the 'database'.
 | GetLocationCategoryRecordFromID(Int32) | Returns a LocationCategory, corresponding to locationID passed as in parameter
 | GetLocationID(String) | Returns a location ID for the specified location name.
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ReadTable(String) | Load an XmlDocument with the content of the xml file (Inherited from XmlTable.)
 | Remove(String) | Removes a location from the database.
 | RemoveNode(String) | Removes from xml file the node selected by the queryString received from the derived class (Inherited from XmlTable.)
 | ToString()()()() | (Inherited from Object.)
 | UpdateLocationCategory(LocationCategoryRecord) | Updates the location record in the database
 | WriteTable()()()() | Writes content to the location file
 | xmlDoc | The xml document. (Inherited from XmlTable.)
 | xmlEscape(String) | Escapes any quotes in val. (Inherited from XmlTable.)
 | xmlUnescape(String) | Unescapes any quotes in val. (Inherited from XmlTable.)
Inheritance Hierarchy
Object
 | XmlTable
 |  | XmlLocationTable
 |  |  | XmlSecurityGroupTable


XmlLocationTable Constructor (configuration)

XmlLocationTable Constructor (configuration)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlLocationTable ► XmlLocationTable(Configuration)
Keyoti SearchUnit v6
Creates a new instance of the XmlLocationTable.
Declaration Syntax
C# Visual Basic
public XmlLocationTable(
    Configuration configuration
)
Public Sub New (
    configuration As Configuration
)
Parameters
configuration (Configuration)
The instance of the Configuration class that holds the settings to be used.


Add Method (obj)

Add Method (obj)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlLocationTable ► Add(LocationCategoryRecord)
Keyoti SearchUnit v6
Adds a location
Declaration Syntax
C# Visual Basic
public virtual void Add(
    LocationCategoryRecord obj
)
Public Overridable Sub Add (
    obj As LocationCategoryRecord
)
Parameters
obj (LocationCategoryRecord)


BuildImportTimeLocationsCache Property

BuildImportTimeLocationsCache Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlLocationTable ► BuildImportTimeLocationsCache
Keyoti SearchUnit v6
Creates a cache.
Declaration Syntax
C# Visual Basic
protected ArrayList BuildImportTimeLocationsCache { get; }
Protected ReadOnly Property BuildImportTimeLocationsCache As ArrayList
    Get
Property Value
ArrayList

Send comments on this topic to support@keyoti.com


GetIDs Method (locationName)

GetIDs Method (locationName)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlLocationTable ► GetIDs(String)
Keyoti SearchUnit v6
Gets locationCategoryID for the specified location category name (in addition, returns the last used ID)`
Declaration Syntax
C# Visual Basic
public virtual int[] GetIDs(
    string locationName
)
Public Overridable Function GetIDs (
    locationName As String
) As Integer()
Parameters
locationName (String)
Return Value
array< Int32 >[]()[][]
2 dim. array of ints - document ID, and last ID used


GetLocationCategories Method

GetLocationCategories Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlLocationTable ► GetLocationCategories()()()()
Keyoti SearchUnit v6
Returns list of locations known in the 'database'.
Declaration Syntax
C# Visual Basic
public virtual ArrayList GetLocationCategories()
Public Overridable Function GetLocationCategories As ArrayList
Return Value
ArrayList
ArrayList of LocationCategoryRecord objects


GetLocationCategoryRecordFromID Method (locationID)

GetLocationCategoryRecordFromID Method (locationID)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlLocationTable ► GetLocationCategoryRecordFromID(Int32)
Keyoti SearchUnit v6
Returns a LocationCategory, corresponding to locationID passed as in parameter
Declaration Syntax
C# Visual Basic
public virtual LocationCategoryRecord GetLocationCategoryRecordFromID(
    int locationID
)
Public Overridable Function GetLocationCategoryRecordFromID (
    locationID As Integer
) As LocationCategoryRecord
Parameters
locationID (Int32)
ID for the object to be retrieved
Return Value
LocationCategoryRecord
LocationCategory object or null if not found


GetLocationID Method (locationName)

GetLocationID Method (locationName)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlLocationTable ► GetLocationID(String)
Keyoti SearchUnit v6
Returns a location ID for the specified location name.
Declaration Syntax
C# Visual Basic
public virtual int GetLocationID(
    string locationName
)
Public Overridable Function GetLocationID (
    locationName As String
) As Integer
Parameters
locationName (String)
Return Value
Int32

Send comments on this topic to support@keyoti.com


Remove Method (locationName)

Remove Method (locationName)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlLocationTable ► Remove(String)
Keyoti SearchUnit v6
Removes a location from the database.
Declaration Syntax
C# Visual Basic
public virtual void Remove(
    string locationName
)
Public Overridable Sub Remove (
    locationName As String
)
Parameters
locationName (String)
ContentCatgory to be removed

Send comments on this topic to support@keyoti.com


UpdateLocationCategory Method (locRecord)

UpdateLocationCategory Method (locRecord)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlLocationTable ► UpdateLocationCategory(LocationCategoryRecord)
Keyoti SearchUnit v6
Updates the location record in the database
Declaration Syntax
C# Visual Basic
public virtual void UpdateLocationCategory(
    LocationCategoryRecord locRecord
)
Public Overridable Sub UpdateLocationCategory (
    locRecord As LocationCategoryRecord
)
Parameters
locRecord (LocationCategoryRecord)
LocationRecord object containing data for the location to be updated.


WriteTable Method

WriteTable Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlLocationTable ► WriteTable()()()()
Keyoti SearchUnit v6
Writes content to the location file
Declaration Syntax
C# Visual Basic
public virtual bool WriteTable()
Public Overridable Function WriteTable As Boolean
Return Value
Boolean

Send comments on this topic to support@keyoti.com


XmlSecurityGroupTable Class

XmlSecurityGroupTable Class
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlSecurityGroupTable
Keyoti SearchUnit v6
Represents security group table.
Declaration Syntax
C# Visual Basic
public class XmlSecurityGroupTable : XmlLocationTable
Public Class XmlSecurityGroupTable
    Inherits XmlLocationTable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | XmlSecurityGroupTable(Configuration) | Creates a new instance.
 | Add(LocationCategoryRecord) | Adds a location (Inherited from XmlLocationTable.)
 | BuildImportTimeLocationsCache | Creates a cache. (Inherited from XmlLocationTable.)
 | changedTable | Flag indicating whether the table has changed. (Inherited from XmlTable.)
 | Configuration | The instance of the Configuration class that holds the settings to be used. (Inherited from XmlTable.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetIDs(String) | Gets locationCategoryID for the specified location category name (in addition, returns the last used ID)` (Inherited from XmlLocationTable.)
 | GetLocationCategories()()()() | Returns list of locations known in the 'database'. (Inherited from XmlLocationTable.)
 | GetLocationCategoryRecordFromID(Int32) | Returns a LocationCategory, corresponding to locationID passed as in parameter (Inherited from XmlLocationTable.)
 | GetLocationID(String) | Returns a location ID for the specified location name. (Inherited from XmlLocationTable.)
 | GetNumberOfSecurityGroups()()()() | Gets the number of security groups.
 | GetSecurityGroupID(String) | Returns a location ID for the specified name.
 | GetSecurityGroupRecordFromID(Int32) | Gets the record based on it's ID.
 | GetSecurityGroups()()()() | Returns list of locations known in the index.
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ReadTable(String) | Load an XmlDocument with the content of the xml file (Inherited from XmlTable.)
 | Remove(String) | Removes a location from the database. (Inherited from XmlLocationTable.)
 | RemoveNode(String) | Removes from xml file the node selected by the queryString received from the derived class (Inherited from XmlTable.)
 | ToString()()()() | (Inherited from Object.)
 | UpdateLocationCategory(LocationCategoryRecord) | Updates the location record in the database (Inherited from XmlLocationTable.)
 | WriteTable()()()() | Writes content to the location file (Inherited from XmlLocationTable.)
 | xmlDoc | The xml document. (Inherited from XmlTable.)
 | xmlEscape(String) | Escapes any quotes in val. (Inherited from XmlTable.)
 | xmlUnescape(String) | Unescapes any quotes in val. (Inherited from XmlTable.)
Inheritance Hierarchy
Object
 | XmlTable
 |  | XmlLocationTable
 |  |  | XmlSecurityGroupTable


XmlSecurityGroupTable Constructor (configuration)

XmlSecurityGroupTable Constructor (configuration)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlSecurityGroupTable ► XmlSecurityGroupTable(Configuration)
Keyoti SearchUnit v6
Creates a new instance.
Declaration Syntax
C# Visual Basic
public XmlSecurityGroupTable(
    Configuration configuration
)
Public Sub New (
    configuration As Configuration
)
Parameters
configuration (Configuration)
The instance of the Configuration class that holds the settings to be used.


GetNumberOfSecurityGroups Method

GetNumberOfSecurityGroups Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlSecurityGroupTable ► GetNumberOfSecurityGroups()()()()
Keyoti SearchUnit v6
Gets the number of security groups.
Declaration Syntax
C# Visual Basic
public virtual int GetNumberOfSecurityGroups()
Public Overridable Function GetNumberOfSecurityGroups As Integer
Return Value
Int32

Send comments on this topic to support@keyoti.com


GetSecurityGroupID Method (name)

GetSecurityGroupID Method (name)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlSecurityGroupTable ► GetSecurityGroupID(String)
Keyoti SearchUnit v6
Returns a location ID for the specified name.
Declaration Syntax
C# Visual Basic
public virtual int GetSecurityGroupID(
    string name
)
Public Overridable Function GetSecurityGroupID (
    name As String
) As Integer
Parameters
name (String)
Return Value
Int32

Send comments on this topic to support@keyoti.com


GetSecurityGroupRecordFromID Method (id)

GetSecurityGroupRecordFromID Method (id)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlSecurityGroupTable ► GetSecurityGroupRecordFromID(Int32)
Keyoti SearchUnit v6
Gets the record based on it's ID.
Declaration Syntax
C# Visual Basic
public SecurityGroupRecord GetSecurityGroupRecordFromID(
    int id
)
Public Function GetSecurityGroupRecordFromID (
    id As Integer
) As SecurityGroupRecord
Parameters
id (Int32)
Return Value
SecurityGroupRecord

Send comments on this topic to support@keyoti.com


GetSecurityGroups Method

GetSecurityGroups Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlSecurityGroupTable ► GetSecurityGroups()()()()
Keyoti SearchUnit v6
Returns list of locations known in the index.
Declaration Syntax
C# Visual Basic
public virtual SecurityGroupRecordList GetSecurityGroups()
Public Overridable Function GetSecurityGroups As SecurityGroupRecordList
Return Value
SecurityGroupRecordList
ArrayList of SecurityGroupRecord objects

Send comments on this topic to support@keyoti.com


XmlTable Class

XmlTable Class
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlTable
Keyoti SearchUnit v6
Abstract class with core functionality.
Declaration Syntax
C# Visual Basic
public abstract class XmlTable
Public MustInherit Class XmlTable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | XmlTable(Configuration) | Constructor
 | changedTable | Flag indicating whether the table has changed.
 | Configuration | The instance of the Configuration class that holds the settings to be used.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GenerateConcatForXPath(String) | Generates a safe xpath query regardless of quotes.
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ReadTable(String) | Load an XmlDocument with the content of the xml file
 | RemoveNode(String) | Removes from xml file the node selected by the queryString received from the derived class
 | ToString()()()() | (Inherited from Object.)
 | WriteRootElement(String, String, Configuration) | Helper method for EnsureDataStore()
 | xmlDoc | The xml document.
 | xmlEscape(String) | Escapes any quotes in val.
 | xmlUnescape(String) | Unescapes any quotes in val.
Inheritance Hierarchy
Object
 | XmlTable
 |  | StateTable
 |  | XmlContentTable
 |  | XmlIndexableSourceRecordTable
 |  | XmlLocationTable


XmlTable Constructor (configuration)

XmlTable Constructor (configuration)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlTable ► XmlTable(Configuration)
Keyoti SearchUnit v6
Constructor
Declaration Syntax
C# Visual Basic
public XmlTable(
    Configuration configuration
)
Public Sub New (
    configuration As Configuration
)
Parameters
configuration (Configuration)
The instance of the Configuration class that holds the settings to be used.


changedTable Field

changedTable Field
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlTable ► changedTable
Keyoti SearchUnit v6
Flag indicating whether the table has changed.
Declaration Syntax
C# Visual Basic
protected bool changedTable
Protected changedTable As Boolean
Field Value
Boolean

Send comments on this topic to support@keyoti.com


Configuration Property

Configuration Property
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlTable ► Configuration
Keyoti SearchUnit v6
The instance of the Configuration class that holds the settings to be used.
Declaration Syntax
C# Visual Basic
public Configuration Configuration { get; }
Public ReadOnly Property Configuration As Configuration
    Get
Property Value
Configuration

Send comments on this topic to support@keyoti.com


GenerateConcatForXPath Method (a_xPathQueryString)

GenerateConcatForXPath Method (a_xPathQueryString)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlTable ► GenerateConcatForXPath(String)
Keyoti SearchUnit v6
Generates a safe xpath query regardless of quotes.
Declaration Syntax
C# Visual Basic
public static string GenerateConcatForXPath(
    string a_xPathQueryString
)
Public Shared Function GenerateConcatForXPath (
    a_xPathQueryString As String
) As String
Parameters
a_xPathQueryString (String)
Return Value
String

Send comments on this topic to support@keyoti.com


ReadTable Method (objectType)

ReadTable Method (objectType)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlTable ► ReadTable(String)
Keyoti SearchUnit v6
Load an XmlDocument with the content of the xml file
Declaration Syntax
C# Visual Basic
protected virtual XmlDocument ReadTable(
    string objectType
)
Protected Overridable Function ReadTable (
    objectType As String
) As XmlDocument
Parameters
objectType (String)
the type of the invoking class
Return Value
XmlDocument
XmlDocument loaded with data from the file


RemoveNode Method (xpathQuery)

RemoveNode Method (xpathQuery)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlTable ► RemoveNode(String)
Keyoti SearchUnit v6
Removes from xml file the node selected by the queryString received from the derived class
Declaration Syntax
C# Visual Basic
protected virtual void RemoveNode(
    string xpathQuery
)
Protected Overridable Sub RemoveNode (
    xpathQuery As String
)
Parameters
xpathQuery (String)


WriteRootElement Method (fileName, rootElement, Configuration)

WriteRootElement Method (fileName, rootElement, Configuration)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlTable ► WriteRootElement(String, String, Configuration)
Keyoti SearchUnit v6
Helper method for EnsureDataStore()
Declaration Syntax
C# Visual Basic
public static void WriteRootElement(
    string fileName,
    string rootElement,
    Configuration Configuration
)
Public Shared Sub WriteRootElement (
    fileName As String,
    rootElement As String,
    Configuration As Configuration
)
Parameters
fileName (String)
string, name of the file
rootElement (String)
the name of the root element to be inserted
Configuration (Configuration)
the configuration to use


xmlDoc Field

xmlDoc Field
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlTable ► xmlDoc
Keyoti SearchUnit v6
The xml document.
Declaration Syntax
C# Visual Basic
protected XmlDocument xmlDoc
Protected xmlDoc As XmlDocument
Field Value
XmlDocument

Send comments on this topic to support@keyoti.com


xmlEscape Method (val)

xmlEscape Method (val)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlTable ► xmlEscape(String)
Keyoti SearchUnit v6
Escapes any quotes in val.
Declaration Syntax
C# Visual Basic
protected virtual string xmlEscape(
    string val
)
Protected Overridable Function xmlEscape (
    val As String
) As String
Parameters
val (String)
Return Value
String

Send comments on this topic to support@keyoti.com


xmlUnescape Method (val)

xmlUnescape Method (val)
API Documentation ► Keyoti.SearchEngine.DataAccess ► XmlTable ► xmlUnescape(String)
Keyoti SearchUnit v6
Unescapes any quotes in val.
Declaration Syntax
C# Visual Basic
public virtual string xmlUnescape(
    string val
)
Public Overridable Function xmlUnescape (
    val As String
) As String
Parameters
val (String)
Return Value
String

Send comments on this topic to support@keyoti.com


Keyoti.SearchEngine.DataAccess.IndexableSourceRecords Namespace

Keyoti.SearchEngine.DataAccess.IndexableSourceRecords Namespace
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords
Keyoti SearchUnit v6
Indexable source records
Types
All Types Classes
Icon | Type | Description
 | AllIndexableSourceRecords | Points to all IndexableSourceRecords.
 | CustomDataSetBasedIndexableSourceRecord | Assembly (Custom) source specific subclass for indexable source records.
 | DatabaseBasedIndexableSourceRecord | Database source specific subclass for indexable source records.
 | FileSystemFolderBasedSourceRecord | File-system source specific subclass for indexable source records.
 | IndexableSourceRecord | Base for all IndexableSourceRecord types.
 | IndexableSourceRecordFactory | Creates IndexableSourceRecord subclassed objects of type based on SourceType.
 | UnassignedDocuments | Points to documents not currently assigned to any IndexableSourceRecord.
 | WebsiteBasedIndexableSourceRecord | Website source specific subclass for indexable source records.


AllIndexableSourceRecords Class

AllIndexableSourceRecords Class
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► AllIndexableSourceRecords
Keyoti SearchUnit v6
Points to all IndexableSourceRecords.
Declaration Syntax
C# Visual Basic
public class AllIndexableSourceRecords : IndexableSourceRecord
Public Class AllIndexableSourceRecords
    Inherits IndexableSourceRecord
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AllIndexableSourceRecords()()()() | New
 | CopyFrom(IndexableSourceRecord) | Sets the values of this record to those of 'record'. (Inherited from IndexableSourceRecord.)
 | DelimitList(ArrayList, Char) | Delimits an ArrayList of strings (Inherited from IndexableSourceRecord.)
 | Equals(Object) | Whether 2 source records are equal (Inherited from IndexableSourceRecord.)
 | ExtensionData | Any extra data that subclasses need to store. (Inherited from IndexableSourceRecord.)
 | Finalize()()()() | (Inherited from Object.)
 | GetExtensionData()()()() | Gets the extension data in the form of a hastable, key=friendly property name, value=property or null. (Inherited from IndexableSourceRecord.)
 | GetHashCode()()()() | The hashcode for this record (Inherited from IndexableSourceRecord.)
 | GetType()()()() | (Inherited from Object.)
 | ID | The ID of the resource (Inherited from IndexableSourceRecord.)
 | Location | The location of the resource (Inherited from IndexableSourceRecord.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Query | A query used on the source, if there is one. (Inherited from IndexableSourceRecord.)
 | ResultURL | The result URL format string, which converts a record ID to a result. (Inherited from IndexableSourceRecord.)
 | SetExtensionData(Hashtable) | Sets the extension data in the form of a hastable, key=friendly property name, value=property (Inherited from IndexableSourceRecord.)
 | SourceType | The type of source this record represents (Inherited from IndexableSourceRecord.)
 | ToString()()()() | Returns the record as a string (Inherited from IndexableSourceRecord.)
 | UniqueColumn | The unique column in the data returned if there is one. (Inherited from IndexableSourceRecord.)
Inheritance Hierarchy
Object
 | IndexableSourceRecord
 |  | AllIndexableSourceRecords


AllIndexableSourceRecords Constructor

AllIndexableSourceRecords Constructor
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► AllIndexableSourceRecords ► AllIndexableSourceRecords()()()()
Keyoti SearchUnit v6
New
Declaration Syntax
C# Visual Basic
public AllIndexableSourceRecords()
Public Sub New

Send comments on this topic to support@keyoti.com


CustomDataSetBasedIndexableSourceRecord Class

CustomDataSetBasedIndexableSourceRecord Class
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► CustomDataSetBasedIndexableSourceRecord
Keyoti SearchUnit v6
Assembly (Custom) source specific subclass for indexable source records.
Declaration Syntax
C# Visual Basic
public class CustomDataSetBasedIndexableSourceRecord : IndexableSourceRecord
Public Class CustomDataSetBasedIndexableSourceRecord
    Inherits IndexableSourceRecord
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CustomDataSetBasedIndexableSourceRecord(String, String, String, String) | Creates a new instance and assigns SourceType
 | CopyFrom(IndexableSourceRecord) | Sets the values of this record to those of 'record'. (Inherited from IndexableSourceRecord.)
 | DelimitList(ArrayList, Char) | Delimits an ArrayList of strings (Inherited from IndexableSourceRecord.)
 | Equals(Object) | Whether 2 source records are equal (Inherited from IndexableSourceRecord.)
 | ExtensionData | Any extra data that subclasses need to store. (Inherited from IndexableSourceRecord.)
 | Finalize()()()() | (Inherited from Object.)
 | GetAssemblyFilePath()()()() | Gets the import parameter.
 | GetExtensionData()()()() | Gets the extension data in the form of a hastable, key=friendly property name, value=property or null. (Inherited from IndexableSourceRecord.)
 | GetFullClassName()()()() | Gets the import parameter.
 | GetHashCode()()()() | The hashcode for this record (Inherited from IndexableSourceRecord.)
 | GetResultUrlFormat()()()() | Gets the import parameter.
 | GetType()()()() | (Inherited from Object.)
 | GetUniqueColumnName()()()() | Gets the import parameter.
 | ID | The ID of the resource (Inherited from IndexableSourceRecord.)
 | Location | The location of the resource (Inherited from IndexableSourceRecord.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Query | A query used on the source, if there is one. (Inherited from IndexableSourceRecord.)
 | ResultURL | The result URL format string, which converts a record ID to a result. (Inherited from IndexableSourceRecord.)
 | SetExtensionData(Hashtable) | Sets the extension data in the form of a hastable, key=friendly property name, value=property (Inherited from IndexableSourceRecord.)
 | SetImportParameters(String, String, String, String) | Sets the data required to perform an import.
 | SourceType | The type of source this record represents (Inherited from IndexableSourceRecord.)
 | ToString()()()() | Returns the record as a string (Inherited from IndexableSourceRecord.)
 | UniqueColumn | The unique column in the data returned if there is one. (Inherited from IndexableSourceRecord.)
Remarks
Provides specific helper methods for data retreival and setting.
Inheritance Hierarchy
Object
 | IndexableSourceRecord
 |  | CustomDataSetBasedIndexableSourceRecord


CustomDataSetBasedIndexableSourceRecord Constructor (assemblyFilePath, fullClassName, uniqueColumnName, resultUrlFormat)

CustomDataSetBasedIndexableSourceRecord Constructor (assemblyFilePath, fullClassName, uniqueColumnName, resultUrlFormat)
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► CustomDataSetBasedIndexableSourceRecord ► CustomDataSetBasedIndexableSourceRecord(String, String, String, String)
Keyoti SearchUnit v6
Creates a new instance and assigns SourceType
Declaration Syntax
C# Visual Basic
public CustomDataSetBasedIndexableSourceRecord(
    string assemblyFilePath,
    string fullClassName,
    string uniqueColumnName,
    string resultUrlFormat
)
Public Sub New (
    assemblyFilePath As String,
    fullClassName As String,
    uniqueColumnName As String,
    resultUrlFormat As String
)
Parameters
assemblyFilePath (String)
fullClassName (String)
uniqueColumnName (String)
resultUrlFormat (String)


GetAssemblyFilePath Method

GetAssemblyFilePath Method
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► CustomDataSetBasedIndexableSourceRecord ► GetAssemblyFilePath()()()()
Keyoti SearchUnit v6
Gets the import parameter.
Declaration Syntax
C# Visual Basic
public string GetAssemblyFilePath()
Public Function GetAssemblyFilePath As String
Return Value
String

Send comments on this topic to support@keyoti.com


GetFullClassName Method

GetFullClassName Method
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► CustomDataSetBasedIndexableSourceRecord ► GetFullClassName()()()()
Keyoti SearchUnit v6
Gets the import parameter.
Declaration Syntax
C# Visual Basic
public string GetFullClassName()
Public Function GetFullClassName As String
Return Value
String

Send comments on this topic to support@keyoti.com


GetResultUrlFormat Method

GetResultUrlFormat Method
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► CustomDataSetBasedIndexableSourceRecord ► GetResultUrlFormat()()()()
Keyoti SearchUnit v6
Gets the import parameter.
Declaration Syntax
C# Visual Basic
public string GetResultUrlFormat()
Public Function GetResultUrlFormat As String
Return Value
String

Send comments on this topic to support@keyoti.com


GetUniqueColumnName Method

GetUniqueColumnName Method
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► CustomDataSetBasedIndexableSourceRecord ► GetUniqueColumnName()()()()
Keyoti SearchUnit v6
Gets the import parameter.
Declaration Syntax
C# Visual Basic
public string GetUniqueColumnName()
Public Function GetUniqueColumnName As String
Return Value
String

Send comments on this topic to support@keyoti.com


SetImportParameters Method (assemblyFilePath, fullClassName, uniqueColumnName, resultUrlFormat)

SetImportParameters Method (assemblyFilePath, fullClassName, uniqueColumnName, resultUrlFormat)
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► CustomDataSetBasedIndexableSourceRecord ► SetImportParameters(String, String, String, String)
Keyoti SearchUnit v6
Sets the data required to perform an import.
Declaration Syntax
C# Visual Basic
public void SetImportParameters(
    string assemblyFilePath,
    string fullClassName,
    string uniqueColumnName,
    string resultUrlFormat
)
Public Sub SetImportParameters (
    assemblyFilePath As String,
    fullClassName As String,
    uniqueColumnName As String,
    resultUrlFormat As String
)
Parameters
assemblyFilePath (String)
fullClassName (String)
uniqueColumnName (String)
resultUrlFormat (String)


DatabaseBasedIndexableSourceRecord Class

DatabaseBasedIndexableSourceRecord Class
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► DatabaseBasedIndexableSourceRecord
Keyoti SearchUnit v6
Database source specific subclass for indexable source records.
Declaration Syntax
C# Visual Basic
public class DatabaseBasedIndexableSourceRecord : IndexableSourceRecord
Public Class DatabaseBasedIndexableSourceRecord
    Inherits IndexableSourceRecord
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DatabaseBasedIndexableSourceRecord(SourceType, String, String, String, String) | Creates a new instance and assign SourceType to sourceType
 | CopyFrom(IndexableSourceRecord) | Sets the values of this record to those of 'record'. (Inherited from IndexableSourceRecord.)
 | DelimitList(ArrayList, Char) | Delimits an ArrayList of strings (Inherited from IndexableSourceRecord.)
 | Equals(Object) | Whether 2 source records are equal (Inherited from IndexableSourceRecord.)
 | ExtensionData | Any extra data that subclasses need to store. (Inherited from IndexableSourceRecord.)
 | Finalize()()()() | (Inherited from Object.)
 | GetConnectionString()()()() | Gets the import parameter.
 | GetDbType()()()() | Gets the import parameter.
 | GetExtensionData()()()() | Gets the extension data in the form of a hastable, key=friendly property name, value=property or null. (Inherited from IndexableSourceRecord.)
 | GetHashCode()()()() | The hashcode for this record (Inherited from IndexableSourceRecord.)
 | GetResultUrlFormat()()()() | Gets the import parameter.
 | GetSqlQuery()()()() | Gets the import parameter.
 | GetType()()()() | (Inherited from Object.)
 | GetUniqueColumnName()()()() | Gets the import parameter.
 | ID | The ID of the resource (Inherited from IndexableSourceRecord.)
 | Location | The location of the resource (Inherited from IndexableSourceRecord.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Query | A query used on the source, if there is one. (Inherited from IndexableSourceRecord.)
 | ResultURL | The result URL format string, which converts a record ID to a result. (Inherited from IndexableSourceRecord.)
 | SetExtensionData(Hashtable) | Sets the extension data in the form of a hastable, key=friendly property name, value=property (Inherited from IndexableSourceRecord.)
 | SetImportParameters(String, String, String, String, SourceType) | Sets the data required to perform an import.
 | SourceType | The type of source this record represents (Inherited from IndexableSourceRecord.)
 | ToString()()()() | Returns the record as a string (Inherited from IndexableSourceRecord.)
 | UniqueColumn | The unique column in the data returned if there is one. (Inherited from IndexableSourceRecord.)
Remarks
Provides specific helper methods for data retreival and setting.
Inheritance Hierarchy
Object
 | IndexableSourceRecord
 |  | DatabaseBasedIndexableSourceRecord


DatabaseBasedIndexableSourceRecord Constructor (sourceType, connectionString, sqlQuery, uniqueColumnName, resultUrlFormat)

DatabaseBasedIndexableSourceRecord Constructor (sourceType, connectionString, sqlQuery, uniqueColumnName, resultUrlFormat)
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► DatabaseBasedIndexableSourceRecord ► DatabaseBasedIndexableSourceRecord(SourceType, String, String, String, String)
Keyoti SearchUnit v6
Creates a new instance and assign SourceType to sourceType
Declaration Syntax
C# Visual Basic
public DatabaseBasedIndexableSourceRecord(
    SourceType sourceType,
    string connectionString,
    string sqlQuery,
    string uniqueColumnName,
    string resultUrlFormat
)
Public Sub New (
    sourceType As SourceType,
    connectionString As String,
    sqlQuery As String,
    uniqueColumnName As String,
    resultUrlFormat As String
)
Parameters
sourceType (SourceType)
connectionString (String)
sqlQuery (String)
uniqueColumnName (String)
resultUrlFormat (String)


GetConnectionString Method

GetConnectionString Method
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► DatabaseBasedIndexableSourceRecord ► GetConnectionString()()()()
Keyoti SearchUnit v6
Gets the import parameter.
Declaration Syntax
C# Visual Basic
public string GetConnectionString()
Public Function GetConnectionString As String
Return Value
String

Send comments on this topic to support@keyoti.com


GetDbType Method

GetDbType Method
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► DatabaseBasedIndexableSourceRecord ► GetDbType()()()()
Keyoti SearchUnit v6
Gets the import parameter.
Declaration Syntax
C# Visual Basic
public SourceType GetDbType()
Public Function GetDbType As SourceType
Return Value
SourceType

Send comments on this topic to support@keyoti.com


GetResultUrlFormat Method

GetResultUrlFormat Method
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► DatabaseBasedIndexableSourceRecord ► GetResultUrlFormat()()()()
Keyoti SearchUnit v6
Gets the import parameter.
Declaration Syntax
C# Visual Basic
public string GetResultUrlFormat()
Public Function GetResultUrlFormat As String
Return Value
String

Send comments on this topic to support@keyoti.com


GetSqlQuery Method

GetSqlQuery Method
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► DatabaseBasedIndexableSourceRecord ► GetSqlQuery()()()()
Keyoti SearchUnit v6
Gets the import parameter.
Declaration Syntax
C# Visual Basic
public string GetSqlQuery()
Public Function GetSqlQuery As String
Return Value
String

Send comments on this topic to support@keyoti.com


GetUniqueColumnName Method

GetUniqueColumnName Method
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► DatabaseBasedIndexableSourceRecord ► GetUniqueColumnName()()()()
Keyoti SearchUnit v6
Gets the import parameter.
Declaration Syntax
C# Visual Basic
public string GetUniqueColumnName()
Public Function GetUniqueColumnName As String
Return Value
String

Send comments on this topic to support@keyoti.com


SetImportParameters Method (connectionString, sqlQuery, uniqueColumnName, resultUrlFormat, dbType)

SetImportParameters Method (connectionString, sqlQuery, uniqueColumnName, resultUrlFormat, dbType)
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► DatabaseBasedIndexableSourceRecord ► SetImportParameters(String, String, String, String, SourceType)
Keyoti SearchUnit v6
Sets the data required to perform an import.
Declaration Syntax
C# Visual Basic
public void SetImportParameters(
    string connectionString,
    string sqlQuery,
    string uniqueColumnName,
    string resultUrlFormat,
    SourceType dbType
)
Public Sub SetImportParameters (
    connectionString As String,
    sqlQuery As String,
    uniqueColumnName As String,
    resultUrlFormat As String,
    dbType As SourceType
)
Parameters
connectionString (String)
sqlQuery (String)
uniqueColumnName (String)
resultUrlFormat (String)
dbType (SourceType)


FileSystemFolderBasedSourceRecord Class

FileSystemFolderBasedSourceRecord Class
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► FileSystemFolderBasedSourceRecord
Keyoti SearchUnit v6
File-system source specific subclass for indexable source records.
Declaration Syntax
C# Visual Basic
public class FileSystemFolderBasedSourceRecord : IndexableSourceRecord
Public Class FileSystemFolderBasedSourceRecord
    Inherits IndexableSourceRecord
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FileSystemFolderBasedSourceRecord(String, String, String) | Creates a new instance and assigns SourceType
 | FileSystemFolderBasedSourceRecord(String, String, ArrayList, ArrayList, Boolean) | Creates a new instance and assigns SourceType
 | FileSystemFolderBasedSourceRecord(String, String, ArrayList, ArrayList, Boolean, String) | Creates a new instance and assigns SourceType
 | CopyFrom(IndexableSourceRecord) | Sets the values of this record to those of 'record'. (Inherited from IndexableSourceRecord.)
 | DelimitList(ArrayList, Char) | Delimits an ArrayList of strings (Inherited from IndexableSourceRecord.)
 | Equals(Object) | Whether 2 source records are equal (Inherited from IndexableSourceRecord.)
 | ExtensionData | Any extra data that subclasses need to store. (Inherited from IndexableSourceRecord.)
 | Finalize()()()() | (Inherited from Object.)
 | GetExtensionData()()()() | Gets the extension data in the form of a hastable, key=friendly property name, value=property (Overrides IndexableSourceRecord.GetExtensionData()()()().)
 | GetHashCode()()()() | The hashcode for this record (Inherited from IndexableSourceRecord.)
 | GetIgnoreMatchList()()()() | Gets the import parameter.
 | GetLocalFolderPath()()()() | Gets the import parameter.
 | GetLoginUrl()()()() | Gets the login URL, if set.
 | GetRecurseSubFolders()()()() | Gets the import parameter.
 | GetTargetMatchList()()()() | Gets the import parameter.
 | GetType()()()() | (Inherited from Object.)
 | GetVirtualPath()()()() | Gets the import parameter.
 | ID | The ID of the resource (Inherited from IndexableSourceRecord.)
 | Location | The location of the resource (Inherited from IndexableSourceRecord.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Query | A query used on the source, if there is one. (Inherited from IndexableSourceRecord.)
 | ResultURL | The result URL format string, which converts a record ID to a result. (Inherited from IndexableSourceRecord.)
 | SetExtensionData(Hashtable) | Sets the extension data in the form of a hastable, key=friendly property name, value=property (Overrides IndexableSourceRecord.SetExtensionData(Hashtable).)
 | SetImportParameters(String, String, ArrayList, ArrayList, Boolean, String) | Sets the data required to perform an import.
 | SourceType | The type of source this record represents (Inherited from IndexableSourceRecord.)
 | ToString()()()() | Returns the record as a string (Inherited from IndexableSourceRecord.)
 | UniqueColumn | The unique column in the data returned if there is one. (Inherited from IndexableSourceRecord.)
Remarks
Provides specific helper methods for data retrieval and setting.
Inheritance Hierarchy
Object
 | IndexableSourceRecord
 |  | FileSystemFolderBasedSourceRecord


FileSystemFolderBasedSourceRecord Constructor

FileSystemFolderBasedSourceRecord Constructor
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► FileSystemFolderBasedSourceRecord ► FileSystemFolderBasedSourceRecord()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FileSystemFolderBasedSourceRecord(String, String, String) | Creates a new instance and assigns SourceType
 | FileSystemFolderBasedSourceRecord(String, String, ArrayList, ArrayList, Boolean) | Creates a new instance and assigns SourceType
 | FileSystemFolderBasedSourceRecord(String, String, ArrayList, ArrayList, Boolean, String) | Creates a new instance and assigns SourceType


FileSystemFolderBasedSourceRecord Constructor (localFolderPath, virtualPath, targetMatchList, ignoreMatchList, recurseSubFolders)

FileSystemFolderBasedSourceRecord Constructor (localFolderPath, virtualPath, targetMatchList, ignoreMatchList, recurseSubFolders)
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► FileSystemFolderBasedSourceRecord ► FileSystemFolderBasedSourceRecord(String, String, ArrayList, ArrayList, Boolean)
Keyoti SearchUnit v6
Creates a new instance and assigns SourceType
Declaration Syntax
C# Visual Basic
public FileSystemFolderBasedSourceRecord(
    string localFolderPath,
    string virtualPath,
    ArrayList targetMatchList,
    ArrayList ignoreMatchList,
    bool recurseSubFolders
)
Public Sub New (
    localFolderPath As String,
    virtualPath As String,
    targetMatchList As ArrayList,
    ignoreMatchList As ArrayList,
    recurseSubFolders As Boolean
)
Parameters
localFolderPath (String)
The path of the folder which will be scanned for documents - may be absolute or relative to the index directory.
virtualPath (String)
The virtual path corresponding to localFolderPath that will enable the document to be read via HTTP
targetMatchList (ArrayList)
Files with matching paths to the contents of this list will be imported (eg. ".doc", ".pdf")
ignoreMatchList (ArrayList)
Any folders with matching paths will to the contents of this list, will not be recursed
recurseSubFolders (Boolean)
Whether to recurse into subfolders

Send comments on this topic to support@keyoti.com


FileSystemFolderBasedSourceRecord Constructor (localFolderPath, virtualPath, targetMatchList, ignoreMatchList, recurseSubFolders, loginUrl)

FileSystemFolderBasedSourceRecord Constructor (localFolderPath, virtualPath, targetMatchList, ignoreMatchList, recurseSubFolders, loginUrl)
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► FileSystemFolderBasedSourceRecord ► FileSystemFolderBasedSourceRecord(String, String, ArrayList, ArrayList, Boolean, String)
Keyoti SearchUnit v6
Creates a new instance and assigns SourceType
Declaration Syntax
C# Visual Basic
public FileSystemFolderBasedSourceRecord(
    string localFolderPath,
    string virtualPath,
    ArrayList targetMatchList,
    ArrayList ignoreMatchList,
    bool recurseSubFolders,
    string loginUrl
)
Public Sub New (
    localFolderPath As String,
    virtualPath As String,
    targetMatchList As ArrayList,
    ignoreMatchList As ArrayList,
    recurseSubFolders As Boolean,
    loginUrl As String
)
Parameters
localFolderPath (String)
The path of the folder which will be scanned for documents - may be absolute or relative to the index directory.
virtualPath (String)
The virtual path corresponding to localFolderPath that will enable the document to be read via HTTP
targetMatchList (ArrayList)
Files with matching paths to the contents of this list will be imported (eg. ".doc", ".pdf")
ignoreMatchList (ArrayList)
Any folders with matching paths will to the contents of this list, will not be recursed
recurseSubFolders (Boolean)
Whether to recurse into subfolders
loginUrl (String)
The URL to visit before importing any documents, to log the indexer in to the web-site. Null/Nothing if not needed.


FileSystemFolderBasedSourceRecord Constructor (localFolderPath, virtualPath, extensionData)

FileSystemFolderBasedSourceRecord Constructor (localFolderPath, virtualPath, extensionData)
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► FileSystemFolderBasedSourceRecord ► FileSystemFolderBasedSourceRecord(String, String, String)
Keyoti SearchUnit v6
Creates a new instance and assigns SourceType
Declaration Syntax
C# Visual Basic
public FileSystemFolderBasedSourceRecord(
    string localFolderPath,
    string virtualPath,
    string extensionData
)
Public Sub New (
    localFolderPath As String,
    virtualPath As String,
    extensionData As String
)
Parameters
localFolderPath (String)
The path of the folder which will be scanned for documents - may be absolute or relative to the index directory.
virtualPath (String)
The virtual path corresponding to localFolderPath that will enable the document to be read via HTTP
extensionData (String)
Used internally

Send comments on this topic to support@keyoti.com


GetExtensionData Method

GetExtensionData Method
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► FileSystemFolderBasedSourceRecord ► GetExtensionData()()()()
Keyoti SearchUnit v6
Gets the extension data in the form of a hastable, key=friendly property name, value=property
Declaration Syntax
C# Visual Basic
public override Hashtable GetExtensionData()
Public Overrides Function GetExtensionData As Hashtable
Return Value
Hashtable

Send comments on this topic to support@keyoti.com


GetIgnoreMatchList Method

GetIgnoreMatchList Method
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► FileSystemFolderBasedSourceRecord ► GetIgnoreMatchList()()()()
Keyoti SearchUnit v6
Gets the import parameter.
Declaration Syntax
C# Visual Basic
public ArrayList GetIgnoreMatchList()
Public Function GetIgnoreMatchList As ArrayList
Return Value
ArrayList

Send comments on this topic to support@keyoti.com


GetLocalFolderPath Method

GetLocalFolderPath Method
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► FileSystemFolderBasedSourceRecord ► GetLocalFolderPath()()()()
Keyoti SearchUnit v6
Gets the import parameter.
Declaration Syntax
C# Visual Basic
public string GetLocalFolderPath()
Public Function GetLocalFolderPath As String
Return Value
String

Send comments on this topic to support@keyoti.com


GetLoginUrl Method

GetLoginUrl Method
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► FileSystemFolderBasedSourceRecord ► GetLoginUrl()()()()
Keyoti SearchUnit v6
Gets the login URL, if set.
Declaration Syntax
C# Visual Basic
public string GetLoginUrl()
Public Function GetLoginUrl As String
Return Value
String

Send comments on this topic to support@keyoti.com


GetRecurseSubFolders Method

GetRecurseSubFolders Method
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► FileSystemFolderBasedSourceRecord ► GetRecurseSubFolders()()()()
Keyoti SearchUnit v6
Gets the import parameter.
Declaration Syntax
C# Visual Basic
public bool GetRecurseSubFolders()
Public Function GetRecurseSubFolders As Boolean
Return Value
Boolean

Send comments on this topic to support@keyoti.com


GetTargetMatchList Method

GetTargetMatchList Method
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► FileSystemFolderBasedSourceRecord ► GetTargetMatchList()()()()
Keyoti SearchUnit v6
Gets the import parameter.
Declaration Syntax
C# Visual Basic
public ArrayList GetTargetMatchList()
Public Function GetTargetMatchList As ArrayList
Return Value
ArrayList

Send comments on this topic to support@keyoti.com


GetVirtualPath Method

GetVirtualPath Method
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► FileSystemFolderBasedSourceRecord ► GetVirtualPath()()()()
Keyoti SearchUnit v6
Gets the import parameter.
Declaration Syntax
C# Visual Basic
public string GetVirtualPath()
Public Function GetVirtualPath As String
Return Value
String

Send comments on this topic to support@keyoti.com


SetExtensionData Method (data)

SetExtensionData Method (data)
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► FileSystemFolderBasedSourceRecord ► SetExtensionData(Hashtable)
Keyoti SearchUnit v6
Sets the extension data in the form of a hastable, key=friendly property name, value=property
Declaration Syntax
C# Visual Basic
public override void SetExtensionData(
    Hashtable data
)
Public Overrides Sub SetExtensionData (
    data As Hashtable
)
Parameters
data (Hashtable)


SetImportParameters Method (localFolderPath, virtualPath, targetMatchList, ignoreMatchList, recurseSubFolders, loginUrl)

SetImportParameters Method (localFolderPath, virtualPath, targetMatchList, ignoreMatchList, recurseSubFolders, loginUrl)
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► FileSystemFolderBasedSourceRecord ► SetImportParameters(String, String, ArrayList, ArrayList, Boolean, String)
Keyoti SearchUnit v6
Sets the data required to perform an import.
Declaration Syntax
C# Visual Basic
public void SetImportParameters(
    string localFolderPath,
    string virtualPath,
    ArrayList targetMatchList,
    ArrayList ignoreMatchList,
    bool recurseSubFolders,
    string loginUrl
)
Public Sub SetImportParameters (
    localFolderPath As String,
    virtualPath As String,
    targetMatchList As ArrayList,
    ignoreMatchList As ArrayList,
    recurseSubFolders As Boolean,
    loginUrl As String
)
Parameters
localFolderPath (String)
The path of the folder which will be scanned for documents - may be absolute or relative to the index directory.
virtualPath (String)
The virtual path corresponding to localFolderPath that will enable the document to be read via HTTP
targetMatchList (ArrayList)
Files with matching paths to the contents of this list will be imported (eg. ".doc", ".pdf")
ignoreMatchList (ArrayList)
Any folders with matching paths will to the contents of this list, will not be recursed
recurseSubFolders (Boolean)
Whether to recurse into subfolders
loginUrl (String)


IndexableSourceRecord Class

IndexableSourceRecord Class
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► IndexableSourceRecord
Keyoti SearchUnit v6
Base for all IndexableSourceRecord types.
Declaration Syntax
C# Visual Basic
public class IndexableSourceRecord
Public Class IndexableSourceRecord
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CopyFrom(IndexableSourceRecord) | Sets the values of this record to those of 'record'.
 | DelimitList(ArrayList, Char) | Delimits an ArrayList of strings
 | Equals(Object) | Whether 2 source records are equal (Overrides Object.Equals(Object).)
 | ExtensionData | Any extra data that subclasses need to store.
 | Finalize()()()() | (Inherited from Object.)
 | GetExtensionData()()()() | Gets the extension data in the form of a hastable, key=friendly property name, value=property or null.
 | GetHashCode()()()() | The hashcode for this record (Overrides Object.GetHashCode()()()().)
 | GetType()()()() | (Inherited from Object.)
 | ID | The ID of the resource
 | Location | The location of the resource
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Query | A query used on the source, if there is one.
 | ResultURL | The result URL format string, which converts a record ID to a result.
 | SetExtensionData(Hashtable) | Sets the extension data in the form of a hastable, key=friendly property name, value=property
 | SourceType | The type of source this record represents
 | ToString()()()() | Returns the record as a string (Overrides Object.ToString()()()().)
 | UniqueColumn | The unique column in the data returned if there is one.
Inheritance Hierarchy
Object
 | IndexableSourceRecord
 |  | AllIndexableSourceRecords
 |  | CustomDataSetBasedIndexableSourceRecord
 |  | DatabaseBasedIndexableSourceRecord
 |  | FileSystemFolderBasedSourceRecord
 |  | UnassignedDocuments
 |  | WebsiteBasedIndexableSourceRecord


CopyFrom Method (record)

CopyFrom Method (record)
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► IndexableSourceRecord ► CopyFrom(IndexableSourceRecord)
Keyoti SearchUnit v6
Sets the values of this record to those of 'record'.
Declaration Syntax
C# Visual Basic
public void CopyFrom(
    IndexableSourceRecord record
)
Public Sub CopyFrom (
    record As IndexableSourceRecord
)
Parameters
record (IndexableSourceRecord)


DelimitList Method (l, delimiter)

DelimitList Method (l, delimiter)
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► IndexableSourceRecord ► DelimitList(ArrayList, Char)
Keyoti SearchUnit v6
Delimits an ArrayList of strings
Declaration Syntax
C# Visual Basic
protected string DelimitList(
    ArrayList l,
    char delimiter
)
Protected Function DelimitList (
    l As ArrayList,
    delimiter As Char
) As String
Parameters
l (ArrayList)
List of strings
delimiter (Char)
Delimiter character
Return Value
String

Send comments on this topic to support@keyoti.com


Equals Method (obj)

Equals Method (obj)
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► IndexableSourceRecord ► Equals(Object)
Keyoti SearchUnit v6
Whether 2 source records are equal
Declaration Syntax
C# Visual Basic
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Parameters
obj (Object)
Return Value
Boolean

Send comments on this topic to support@keyoti.com


ExtensionData Property

ExtensionData Property
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► IndexableSourceRecord ► ExtensionData
Keyoti SearchUnit v6
Any extra data that subclasses need to store.
Declaration Syntax
C# Visual Basic
public string ExtensionData { get; set; }
Public Property ExtensionData As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


GetExtensionData Method

GetExtensionData Method
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► IndexableSourceRecord ► GetExtensionData()()()()
Keyoti SearchUnit v6
Gets the extension data in the form of a hastable, key=friendly property name, value=property or null.
Declaration Syntax
C# Visual Basic
public virtual Hashtable GetExtensionData()
Public Overridable Function GetExtensionData As Hashtable
Return Value
Hashtable

Send comments on this topic to support@keyoti.com


GetHashCode Method

GetHashCode Method
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► IndexableSourceRecord ► GetHashCode()()()()
Keyoti SearchUnit v6
The hashcode for this record
Declaration Syntax
C# Visual Basic
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Return Value
Int32

Send comments on this topic to support@keyoti.com


ID Property

ID Property
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► IndexableSourceRecord ► ID
Keyoti SearchUnit v6
The ID of the resource
Declaration Syntax
C# Visual Basic
public int ID { get; set; }
Public Property ID As Integer
    Get
    Set
Property Value
Int32

Send comments on this topic to support@keyoti.com


Location Property

Location Property
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► IndexableSourceRecord ► Location
Keyoti SearchUnit v6
The location of the resource
Declaration Syntax
C# Visual Basic
public string Location { get; set; }
Public Property Location As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


Query Property

Query Property
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► IndexableSourceRecord ► Query
Keyoti SearchUnit v6
A query used on the source, if there is one.
Declaration Syntax
C# Visual Basic
public string Query { get; set; }
Public Property Query As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


ResultURL Property

ResultURL Property
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► IndexableSourceRecord ► ResultURL
Keyoti SearchUnit v6
The result URL format string, which converts a record ID to a result.
Declaration Syntax
C# Visual Basic
public string ResultURL { get; set; }
Public Property ResultURL As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


SetExtensionData Method (data)

SetExtensionData Method (data)
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► IndexableSourceRecord ► SetExtensionData(Hashtable)
Keyoti SearchUnit v6
Sets the extension data in the form of a hastable, key=friendly property name, value=property
Declaration Syntax
C# Visual Basic
public virtual void SetExtensionData(
    Hashtable data
)
Public Overridable Sub SetExtensionData (
    data As Hashtable
)
Parameters
data (Hashtable)


SourceType Property

SourceType Property
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► IndexableSourceRecord ► SourceType
Keyoti SearchUnit v6
The type of source this record represents
Declaration Syntax
C# Visual Basic
public SourceType SourceType { get; set; }
Public Property SourceType As SourceType
    Get
    Set
Property Value
SourceType

Send comments on this topic to support@keyoti.com


ToString Method

ToString Method
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► IndexableSourceRecord ► ToString()()()()
Keyoti SearchUnit v6
Returns the record as a string
Declaration Syntax
C# Visual Basic
public override string ToString()
Public Overrides Function ToString As String
Return Value
String

Send comments on this topic to support@keyoti.com


UniqueColumn Property

UniqueColumn Property
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► IndexableSourceRecord ► UniqueColumn
Keyoti SearchUnit v6
The unique column in the data returned if there is one.
Declaration Syntax
C# Visual Basic
public string UniqueColumn { get; set; }
Public Property UniqueColumn As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


IndexableSourceRecordFactory Class

IndexableSourceRecordFactory Class
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► IndexableSourceRecordFactory
Keyoti SearchUnit v6
Creates IndexableSourceRecord subclassed objects of type based on SourceType.
Declaration Syntax
C# Visual Basic
public class IndexableSourceRecordFactory
Public Class IndexableSourceRecordFactory
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | IndexableSourceRecordFactory()()()() |
 | CreateRecord(SourceType) | Factory method to create subclass of this class specific to the sourceType
 | CreateRecord(SourceType, String, String, String, String, String) | Factory method to create subclass of this class specific to the sourceType
 | CreateRecord(SourceType, String, String, String, String) | Factory method to create subclass of this class specific to the sourceType
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
IndexableSourceRecordFactory

Send comments on this topic to support@keyoti.com


IndexableSourceRecordFactory Constructor

IndexableSourceRecordFactory Constructor
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► IndexableSourceRecordFactory ► IndexableSourceRecordFactory()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public IndexableSourceRecordFactory()
Public Sub New

Send comments on this topic to support@keyoti.com


CreateRecord Method

CreateRecord Method
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► IndexableSourceRecordFactory ► CreateRecord()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | CreateRecord(SourceType) | Factory method to create subclass of this class specific to the sourceType
 | CreateRecord(SourceType, String, String, String, String, String) | Factory method to create subclass of this class specific to the sourceType
 | CreateRecord(SourceType, String, String, String, String) | Factory method to create subclass of this class specific to the sourceType


CreateRecord Method (sourceType)

CreateRecord Method (sourceType)
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► IndexableSourceRecordFactory ► CreateRecord(SourceType)
Keyoti SearchUnit v6
Factory method to create subclass of this class specific to the sourceType
Declaration Syntax
C# Visual Basic
public static IndexableSourceRecord CreateRecord(
    SourceType sourceType
)
Public Shared Function CreateRecord (
    sourceType As SourceType
) As IndexableSourceRecord
Parameters
sourceType (SourceType)
The type of record to create
Return Value
IndexableSourceRecord

Send comments on this topic to support@keyoti.com


CreateRecord Method (sourceType, location, query, uniqueColumn, resultURL)

CreateRecord Method (sourceType, location, query, uniqueColumn, resultURL)
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► IndexableSourceRecordFactory ► CreateRecord(SourceType, String, String, String, String)
Keyoti SearchUnit v6
Factory method to create subclass of this class specific to the sourceType
Declaration Syntax
C# Visual Basic
public static IndexableSourceRecord CreateRecord(
    SourceType sourceType,
    string location,
    string query,
    string uniqueColumn,
    string resultURL
)
Public Shared Function CreateRecord (
    sourceType As SourceType,
    location As String,
    query As String,
    uniqueColumn As String,
    resultURL As String
) As IndexableSourceRecord
Parameters
sourceType (SourceType)
location (String)
query (String)
uniqueColumn (String)
resultURL (String)
Return Value
IndexableSourceRecord

Send comments on this topic to support@keyoti.com


CreateRecord Method (sourceType, location, query, uniqueColumn, resultURL, extensionData)

CreateRecord Method (sourceType, location, query, uniqueColumn, resultURL, extensionData)
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► IndexableSourceRecordFactory ► CreateRecord(SourceType, String, String, String, String, String)
Keyoti SearchUnit v6
Factory method to create subclass of this class specific to the sourceType
Declaration Syntax
C# Visual Basic
public static IndexableSourceRecord CreateRecord(
    SourceType sourceType,
    string location,
    string query,
    string uniqueColumn,
    string resultURL,
    string extensionData
)
Public Shared Function CreateRecord (
    sourceType As SourceType,
    location As String,
    query As String,
    uniqueColumn As String,
    resultURL As String,
    extensionData As String
) As IndexableSourceRecord
Parameters
sourceType (SourceType)
location (String)
query (String)
uniqueColumn (String)
resultURL (String)
extensionData (String)
Return Value
IndexableSourceRecord

Send comments on this topic to support@keyoti.com


UnassignedDocuments Class

UnassignedDocuments Class
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► UnassignedDocuments
Keyoti SearchUnit v6
Points to documents not currently assigned to any IndexableSourceRecord.
Declaration Syntax
C# Visual Basic
public class UnassignedDocuments : IndexableSourceRecord
Public Class UnassignedDocuments
    Inherits IndexableSourceRecord
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UnassignedDocuments()()()() | New
 | CopyFrom(IndexableSourceRecord) | Sets the values of this record to those of 'record'. (Inherited from IndexableSourceRecord.)
 | DefaultLocationName | Unassigned document name.
 | DelimitList(ArrayList, Char) | Delimits an ArrayList of strings (Inherited from IndexableSourceRecord.)
 | Equals(Object) | Whether 2 source records are equal (Inherited from IndexableSourceRecord.)
 | ExtensionData | Any extra data that subclasses need to store. (Inherited from IndexableSourceRecord.)
 | Finalize()()()() | (Inherited from Object.)
 | GetExtensionData()()()() | Gets the extension data in the form of a hastable, key=friendly property name, value=property or null. (Inherited from IndexableSourceRecord.)
 | GetHashCode()()()() | The hashcode for this record (Inherited from IndexableSourceRecord.)
 | GetType()()()() | (Inherited from Object.)
 | ID | The ID of the resource (Inherited from IndexableSourceRecord.)
 | Location | The location of the resource (Inherited from IndexableSourceRecord.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Query | A query used on the source, if there is one. (Inherited from IndexableSourceRecord.)
 | ResultURL | The result URL format string, which converts a record ID to a result. (Inherited from IndexableSourceRecord.)
 | SetExtensionData(Hashtable) | Sets the extension data in the form of a hastable, key=friendly property name, value=property (Inherited from IndexableSourceRecord.)
 | SourceType | The type of source this record represents (Inherited from IndexableSourceRecord.)
 | ToString()()()() | Returns the record as a string (Inherited from IndexableSourceRecord.)
 | UniqueColumn | The unique column in the data returned if there is one. (Inherited from IndexableSourceRecord.)
Inheritance Hierarchy
Object
 | IndexableSourceRecord
 |  | UnassignedDocuments


UnassignedDocuments Constructor

UnassignedDocuments Constructor
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► UnassignedDocuments ► UnassignedDocuments()()()()
Keyoti SearchUnit v6
New
Declaration Syntax
C# Visual Basic
public UnassignedDocuments()
Public Sub New

Send comments on this topic to support@keyoti.com


DefaultLocationName Field

DefaultLocationName Field
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► UnassignedDocuments ► DefaultLocationName
Keyoti SearchUnit v6
Unassigned document name.
Declaration Syntax
C# Visual Basic
public static string DefaultLocationName
Public Shared DefaultLocationName As String
Field Value
String

Send comments on this topic to support@keyoti.com


WebsiteBasedIndexableSourceRecord Class

WebsiteBasedIndexableSourceRecord Class
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► WebsiteBasedIndexableSourceRecord
Keyoti SearchUnit v6
Website source specific subclass for indexable source records.
Declaration Syntax
C# Visual Basic
public class WebsiteBasedIndexableSourceRecord : IndexableSourceRecord
Public Class WebsiteBasedIndexableSourceRecord
    Inherits IndexableSourceRecord
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WebsiteBasedIndexableSourceRecord(String) | Creates a new instance and assigns SourceType
 | WebsiteBasedIndexableSourceRecord(String, String) | Creates a new instance and assigns SourceType
 | WebsiteBasedIndexableSourceRecord(String, ArrayList, ArrayList) | Creates a new instance and assigns SourceType
 | CopyFrom(IndexableSourceRecord) | Sets the values of this record to those of 'record'. (Inherited from IndexableSourceRecord.)
 | DelimitList(ArrayList, Char) | Delimits an ArrayList of strings (Inherited from IndexableSourceRecord.)
 | Equals(Object) | Whether 2 source records are equal (Inherited from IndexableSourceRecord.)
 | ExtensionData | Any extra data that subclasses need to store. (Inherited from IndexableSourceRecord.)
 | Finalize()()()() | (Inherited from Object.)
 | GetExtensionData()()()() | Gets the extension data in the form of a hastable, key=friendly property name, value=property (Overrides IndexableSourceRecord.GetExtensionData()()()().)
 | GetHashCode()()()() | The hashcode for this record (Inherited from IndexableSourceRecord.)
 | GetPathMatchesToBeIgnored()()()() | List of strings which specify path matches to be ignored, see remarks.
 | GetPathMatchesToBeIncluded()()()() | List of strings which specify path matches to be exclusively included, see remarks.
 | GetType()()()() | (Inherited from Object.)
 | GetWebsiteStartUrl()()()() | Gets the import parameter.
 | ID | The ID of the resource (Inherited from IndexableSourceRecord.)
 | Location | The location of the resource (Inherited from IndexableSourceRecord.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Query | A query used on the source, if there is one. (Inherited from IndexableSourceRecord.)
 | ResultURL | The result URL format string, which converts a record ID to a result. (Inherited from IndexableSourceRecord.)
 | SetExtensionData(Hashtable) | Sets the extension data in the form of a hastable, key=friendly property name, value=property (Overrides IndexableSourceRecord.SetExtensionData(Hashtable).)
 | SetImportParameters(String, ArrayList, ArrayList) | Sets the data required to perform an import.
 | SourceType | The type of source this record represents (Inherited from IndexableSourceRecord.)
 | ToString()()()() | Returns the record as a string (Inherited from IndexableSourceRecord.)
 | UniqueColumn | The unique column in the data returned if there is one. (Inherited from IndexableSourceRecord.)
Remarks
Provides specific helper methods for data retreival and setting.
Inheritance Hierarchy
Object
 | IndexableSourceRecord
 |  | WebsiteBasedIndexableSourceRecord


WebsiteBasedIndexableSourceRecord Constructor

WebsiteBasedIndexableSourceRecord Constructor
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► WebsiteBasedIndexableSourceRecord ► WebsiteBasedIndexableSourceRecord()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | WebsiteBasedIndexableSourceRecord(String) | Creates a new instance and assigns SourceType
 | WebsiteBasedIndexableSourceRecord(String, String) | Creates a new instance and assigns SourceType
 | WebsiteBasedIndexableSourceRecord(String, ArrayList, ArrayList) | Creates a new instance and assigns SourceType


WebsiteBasedIndexableSourceRecord Constructor (webSiteStartUrl)

WebsiteBasedIndexableSourceRecord Constructor (webSiteStartUrl)
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► WebsiteBasedIndexableSourceRecord ► WebsiteBasedIndexableSourceRecord(String)
Keyoti SearchUnit v6
Creates a new instance and assigns SourceType
Declaration Syntax
C# Visual Basic
public WebsiteBasedIndexableSourceRecord(
    string webSiteStartUrl
)
Public Sub New (
    webSiteStartUrl As String
)
Parameters
webSiteStartUrl (String)


WebsiteBasedIndexableSourceRecord Constructor (webSiteStartUrl, pathMatchesToBeIgnoredList, pathMatchesToBeIncludedList)

WebsiteBasedIndexableSourceRecord Constructor (webSiteStartUrl, pathMatchesToBeIgnoredList, pathMatchesToBeIncludedList)
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► WebsiteBasedIndexableSourceRecord ► WebsiteBasedIndexableSourceRecord(String, ArrayList, ArrayList)
Keyoti SearchUnit v6
Creates a new instance and assigns SourceType
Declaration Syntax
C# Visual Basic
public WebsiteBasedIndexableSourceRecord(
    string webSiteStartUrl,
    ArrayList pathMatchesToBeIgnoredList,
    ArrayList pathMatchesToBeIncludedList
)
Public Sub New (
    webSiteStartUrl As String,
    pathMatchesToBeIgnoredList As ArrayList,
    pathMatchesToBeIncludedList As ArrayList
)
Parameters
webSiteStartUrl (String)
pathMatchesToBeIgnoredList (ArrayList)
pathMatchesToBeIncludedList (ArrayList)


WebsiteBasedIndexableSourceRecord Constructor (webSiteStartUrl, extensionData)

WebsiteBasedIndexableSourceRecord Constructor (webSiteStartUrl, extensionData)
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► WebsiteBasedIndexableSourceRecord ► WebsiteBasedIndexableSourceRecord(String, String)
Keyoti SearchUnit v6
Creates a new instance and assigns SourceType
Declaration Syntax
C# Visual Basic
public WebsiteBasedIndexableSourceRecord(
    string webSiteStartUrl,
    string extensionData
)
Public Sub New (
    webSiteStartUrl As String,
    extensionData As String
)
Parameters
webSiteStartUrl (String)
extensionData (String)


GetExtensionData Method

GetExtensionData Method
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► WebsiteBasedIndexableSourceRecord ► GetExtensionData()()()()
Keyoti SearchUnit v6
Gets the extension data in the form of a hastable, key=friendly property name, value=property
Declaration Syntax
C# Visual Basic
public override Hashtable GetExtensionData()
Public Overrides Function GetExtensionData As Hashtable
Return Value
Hashtable

Send comments on this topic to support@keyoti.com


GetPathMatchesToBeIgnored Method

GetPathMatchesToBeIgnored Method
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► WebsiteBasedIndexableSourceRecord ► GetPathMatchesToBeIgnored()()()()
Keyoti SearchUnit v6
List of strings which specify path matches to be ignored, see remarks.
Declaration Syntax
C# Visual Basic
public ArrayList GetPathMatchesToBeIgnored()
Public Function GetPathMatchesToBeIgnored As ArrayList
Return Value
ArrayList
Remarks
If a string in this list matches the URL about to be crawled, the URL will be ignored. Eg. if this list contains "/dir1/" then the URL "http://localhost/dir1/file.aspx" will not be crawled.


GetPathMatchesToBeIncluded Method

GetPathMatchesToBeIncluded Method
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► WebsiteBasedIndexableSourceRecord ► GetPathMatchesToBeIncluded()()()()
Keyoti SearchUnit v6
List of strings which specify path matches to be exclusively included, see remarks.
Declaration Syntax
C# Visual Basic
public ArrayList GetPathMatchesToBeIncluded()
Public Function GetPathMatchesToBeIncluded As ArrayList
Return Value
ArrayList
Remarks
Only if a string in this list matches the URL about to be crawled, the URL will be included to crawl Eg. if this list contains "/dir1/" then the URL "http://localhost/dir1/file.aspx" will be crawled, but "http://localhost/file.aspx" will not.


GetWebsiteStartUrl Method

GetWebsiteStartUrl Method
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► WebsiteBasedIndexableSourceRecord ► GetWebsiteStartUrl()()()()
Keyoti SearchUnit v6
Gets the import parameter.
Declaration Syntax
C# Visual Basic
public string GetWebsiteStartUrl()
Public Function GetWebsiteStartUrl As String
Return Value
String

Send comments on this topic to support@keyoti.com


SetExtensionData Method (data)

SetExtensionData Method (data)
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► WebsiteBasedIndexableSourceRecord ► SetExtensionData(Hashtable)
Keyoti SearchUnit v6
Sets the extension data in the form of a hastable, key=friendly property name, value=property
Declaration Syntax
C# Visual Basic
public override void SetExtensionData(
    Hashtable data
)
Public Overrides Sub SetExtensionData (
    data As Hashtable
)
Parameters
data (Hashtable)


SetImportParameters Method (webStartStartUrl, pathMatchesToBeIgnoredList, pathMatchesToBeIncludedList)

SetImportParameters Method (webStartStartUrl, pathMatchesToBeIgnoredList, pathMatchesToBeIncludedList)
API Documentation ► Keyoti.SearchEngine.DataAccess.IndexableSourceRecords ► WebsiteBasedIndexableSourceRecord ► SetImportParameters(String, ArrayList, ArrayList)
Keyoti SearchUnit v6
Sets the data required to perform an import.
Declaration Syntax
C# Visual Basic
public void SetImportParameters(
    string webStartStartUrl,
    ArrayList pathMatchesToBeIgnoredList,
    ArrayList pathMatchesToBeIncludedList
)
Public Sub SetImportParameters (
    webStartStartUrl As String,
    pathMatchesToBeIgnoredList As ArrayList,
    pathMatchesToBeIncludedList As ArrayList
)
Parameters
webStartStartUrl (String)
pathMatchesToBeIgnoredList (ArrayList)
pathMatchesToBeIncludedList (ArrayList)


Keyoti.SearchEngine.Documents Namespace

Keyoti.SearchEngine.Documents Namespace
API Documentation ► Keyoti.SearchEngine.Documents
Keyoti SearchUnit v6
Classes related to document reading and parsing.

Imported documents

Types
All Types Classes Structures Enumerations
Icon | Type | Description
 | Parser..::..BoostPoint | A point in the plain text where weighting is affected.
 | DataSetRecordParser | Parser of XML representation of record from a DataSet based source.
 | Document | Represents an indexed document.
 | DocumentText | Represents the text in a document, including title and static summary.
 | DocxParser | Summary description for DocxParser.
 | FatalReaderException | A Reader exception that is fatal.
 | GenericIFilterParser | A generic, IFilter based document parser, which can read text from any document for which an IFilter is installed on the system.
 | HtmlDocumentParser | Parses Html documents for words and links.
 | HtmlStringParser | Converts HTML to plain text
 | LastModifiedDateNotAvailableException | Signifies that a Last-Modified HTTP header wasn't provided in the HTTP response.
 | OdsDocumentParser | Parses Open Document Format (ODF) spreadsheet files (.ods).
 | OdtDocumentParser | Parses Open Document Format (ODF) word processor files (.odt).
 | Parser | Abstract base class for document parsers.
 | ParserProvider | Provides a parser for different document types.
 | PdfDocumentParser | Pdf Parser
 | PdfDocumentTitleSource | Where the title of a Pdf document is obtained from.
 | PptxParser | Parses PPTX (PowerPoint) files.
 | PreloadedDocument | A document with preset text.
 | Reader | Reads files from the filesystem and pages from servers via HTTP.
 | ReaderException | An exception that originated in the Reader.
 | ReaderExceptionOccurredEventArgs | Holds data about the WebException that caused an exception in the Reader class.
 | RtfDocumentParser | Rtf document parser
 | TxtDocumentParser | Parser for .txt documents.
 | Word2002Parser | Parses v97-2003 binary format documents.
 | WordDocumentParser | Master parser for Word documents, this class applies RTF or Word2002 Parsers according to actual structure of .doc files.
 | XlsxParser | .xlsx (MS Excel) document parser.
 | XmlDocumentParser | Reads plain text from an Xml document stream.
 | ZipFileParser | Parses ZIP files - and indexes any files inside that the engine can index.


DataSetRecordParser Class

DataSetRecordParser Class
API Documentation ► Keyoti.SearchEngine.Documents ► DataSetRecordParser
Keyoti SearchUnit v6
Parser of XML representation of record from a DataSet based source.
Declaration Syntax
C# Visual Basic
public class DataSetRecordParser : HtmlDocumentParser
Public Class DataSetRecordParser
    Inherits HtmlDocumentParser
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataSetRecordParser(Configuration) | New instance
 | Configuration | Gets the instance of the Configuration class that holds the settings to be used. (Inherited from Parser.)
 | CopyStream(Stream) | (Inherited from Parser.)
 | DeriveEncoding(Stream) | Tries to find the encoding of a HTML file from the Content-type meta tag. (Inherited from HtmlDocumentParser.)
 | DeriveTitleFromDocument(String) | Attempts to returns the title of the document, based on the documentBody (Inherited from HtmlDocumentParser.)
 | Encoding | The character encoding used in the document Stream, if applicable. (Inherited from Parser.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FindIgnoreRegions(String) | Finds all ignore regions in documentBody. (Inherited from HtmlDocumentParser.)
 | GetFilenameFooter(Uri) | Creates a footer with filename info from the Uri (Inherited from Parser.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetNextWord(String) | Returns the next 'word' in rawBody, is iterative, so subsequent calls move to consecutive words. (Inherited from HtmlDocumentParser.)
 | GetType()()()() | (Inherited from Object.)
 | GetWordsInUri(Uri) | Returns list of words as strings in an ArrayList, that are in the Uri (Inherited from Parser.)
 | IsCurrentWordInTitle()()()() | Whether word last returned by GetNextWord is in title. (Inherited from HtmlDocumentParser.)
 | IsInIgnoredRegion(ArrayList) | Determines whether current word (at wordStart) is in an ignored region. (Inherited from Parser.)
 | IsStreamNeeded()()()() | Obsolete. Whether the parser would need a stream to be passed to it in order to perform a ReadText or ReadLinks operation. (Inherited from Parser.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ParseWords(String, ArrayList, WordCollection, StringBuilder, ArrayList) | Parses rawBody into descrete Word objects and places them in readDocumentWords. (Inherited from Parser.)
 | PreprocessBreakChunk(String) | Applies any required processing to a chunk of text that typically forms either a word or whitespace block. (Inherited from Parser.)
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean) | Processes the list of all words found in the document and returns a list that should be index. (Inherited from Parser.)
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean, ArrayList) | Processes the list of all words found in the document and returns a list that should be index. (Inherited from Parser.)
 | Read(Stream, Uri, Encoding) | Reads a document and returns an object holding it's text and any links. (Overrides HtmlDocumentParser.Read(Stream, Uri, Encoding).)
 | ReadDocumentContent(Stream, Encoding) | Returns string read from 'stream'. (Inherited from HtmlDocumentParser.)
 | ReadLinks(Stream, Encoding) | Obsolete. Reads links to other pages. (Inherited from Parser.)
 | ReadMetaTable(String) | Reads the meta tags for a document. (Inherited from HtmlDocumentParser.)
 | ReadText(Stream, Uri, Encoding) | Obsolete. Reads text and returns list of words and title (Inherited from Parser.)
 | ResetWordPointers()()()() | Resets the current word being processed. (Inherited from Parser.)
 | ToString()()()() | (Inherited from Object.)
 | TruncateWordWithRepeatedChar(String) | Removes repeated non-letters from word. (Inherited from Parser.)
 | WordEnd | The current word's end. (Inherited from Parser.)
 | WordStart | The current word's start. (Inherited from Parser.)
Inheritance Hierarchy
Object
 | Parser
 |  | HtmlDocumentParser
 |  |  | DataSetRecordParser


DataSetRecordParser Constructor (configuration)

DataSetRecordParser Constructor (configuration)
API Documentation ► Keyoti.SearchEngine.Documents ► DataSetRecordParser ► DataSetRecordParser(Configuration)
Keyoti SearchUnit v6
New instance
Declaration Syntax
C# Visual Basic
public DataSetRecordParser(
    Configuration configuration
)
Public Sub New (
    configuration As Configuration
)
Parameters
configuration (Configuration)


Read Method (stream, uri, encoding)

Read Method (stream, uri, encoding)
API Documentation ► Keyoti.SearchEngine.Documents ► DataSetRecordParser ► Read(Stream, Uri, Encoding)
Keyoti SearchUnit v6
Reads a document and returns an object holding it's text and any links.
Declaration Syntax
C# Visual Basic
public override DocumentText Read(
    Stream stream,
    Uri uri,
    Encoding encoding
)
Public Overrides Function Read (
    stream As Stream,
    uri As Uri,
    encoding As Encoding
) As DocumentText
Parameters
stream (Stream)
The document stream to read from.
uri (Uri)
The document URI, used only for weighting words found in the document.
encoding (Encoding)
The document encoding if applicable/available.
Return Value
DocumentText
The DocumentText for the document.


Document Class

Document Class
API Documentation ► Keyoti.SearchEngine.Documents ► Document
Keyoti SearchUnit v6
Represents an indexed document.
Declaration Syntax
C# Visual Basic
public class Document
Public Class Document
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Document(DocumentRecord, Configuration) | Creates a new Document.
 | Document(String, Configuration) | Creates a new Document.
 | CalculateWordRelevancies(WordCollection) | Calculate the weight field value for the words in the list.
 | CalculateWordsRelevancy(ArrayList) | Obsolete. Calculate the weight field value for the words in the list.
 | Configuration | The instance of the Configuration class that holds the settings to be used.
 | ContentCategories | The content categories of type ContentCategoryRecord that this document belongs to.
 | CustomData | Any custom data that should be stored for the document.
 | Description | Description of the document, if specified.
 | Dispose()()()() | Removes all references held by this object.
 | DocumentId | The ID of the document in the data layer.
 | DocumentRecord | The DocumentRecord instance that stores the data.
 | DontIndex | Whether to ignore the document during index creation.
 | Encoding | The document's character encoding.
 | Equals(Object) | Determines if documents are equal (Overrides Object.Equals(Object).)
 | FileType | Obsolete. The mime-type for the document.
 | Finalize()()()() | (Inherited from Object.)
 | GetFileType()()()() | The mime-type for the document.
 | GetHashCode()()()() | Gets the hashcode for the document, based on it's DocumentRecord. (Overrides Object.GetHashCode()()()().)
 | GetType()()()() | (Inherited from Object.)
 | InBodyCoefficient | Coefficient used for weighting words found in the document body.
 | IndexableSourceId | The ID of the indexable source this belongs to, or -1 if none.
 | InTitleCoefficient | Coefficient used for weighting words found in the document title.
 | InUrlCoefficient | Coefficient used for weighting words found in the document Uri.
 | IsDocumentChanged()()()() | Whether the document can be identified to have changed between the last time it was indexed and when LoadResponseStream was called.
 | IsIndexed()()()() | Whether this document has been indexed.
 | LastDateIndexed | The date the document was last indexed.
 | LastModifiedDate | The LastModifiedDate for the document.
 | LastResponseStatusCode | The URI provided with the last server response, HttpStatusCode.Unused if not available.
 | LastResponseUri | The URI provided with the last server response, null if not available.
 | LocationCategory | The location category that this document belongs to.
 | LoginPage | Whether this page is a 'login page' (for Forms Authentication).
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Parser | The Parser instance used to parse words from the remote document.
 | ParserProvider | The ParserProvider to use to obtain the correct parser to parse the document.
 | Reader | The Reader instance used to read the document and links from the remote document.
 | ReadLinks()()()() | Retrieves a list of links, calling ReadLinks() from the Parser property
 | ReadText()()()() | Retrieves the document's words as an ArrayList, and title if available.
 | SecurityGroups | The securityGroup category that this document belongs to.
 | stream | The document stream.
 | Title | The title of the document.
 | ToString()()()() | (Inherited from Object.)
 | Uri | The document's Uri (URL).
Inheritance Hierarchy
Object
 | Document
 |  | PreloadedDocument


Document Constructor

Document Constructor
API Documentation ► Keyoti.SearchEngine.Documents ► Document ► Document()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Document(DocumentRecord, Configuration) | Creates a new Document.
 | Document(String, Configuration) | Creates a new Document.


Document Constructor (documentRecord, configuration)

Document Constructor (documentRecord, configuration)
API Documentation ► Keyoti.SearchEngine.Documents ► Document ► Document(DocumentRecord, Configuration)
Keyoti SearchUnit v6
Creates a new Document.
Declaration Syntax
C# Visual Basic
public Document(
    DocumentRecord documentRecord,
    Configuration configuration
)
Public Sub New (
    documentRecord As DocumentRecord,
    configuration As Configuration
)
Parameters
documentRecord (DocumentRecord)
The data layer DocumentRecord that holds the data.
configuration (Configuration)
The instance of the Configuration class that holds the settings to be used.


Document Constructor (uri, configuration)

Document Constructor (uri, configuration)
API Documentation ► Keyoti.SearchEngine.Documents ► Document ► Document(String, Configuration)
Keyoti SearchUnit v6
Creates a new Document.
Declaration Syntax
C# Visual Basic
public Document(
    string uri,
    Configuration configuration
)
Public Sub New (
    uri As String,
    configuration As Configuration
)
Parameters
uri (String)
The URI of the document
configuration (Configuration)
The instance of the Configuration class that holds the settings to be used.


CalculateWordRelevancies Method (wordsList)

CalculateWordRelevancies Method (wordsList)
API Documentation ► Keyoti.SearchEngine.Documents ► Document ► CalculateWordRelevancies(WordCollection)
Keyoti SearchUnit v6
Calculate the weight field value for the words in the list.
Declaration Syntax
C# Visual Basic
protected virtual void CalculateWordRelevancies(
    WordCollection wordsList
)
Protected Overridable Sub CalculateWordRelevancies (
    wordsList As WordCollection
)
Parameters
wordsList (WordCollection)
WordCollection of Word objects, with inBody, in Title, inURL fields filled
Remarks
This method defines the relationship between the occurrences (hits) in the document and the weight of the words in the document. Eg. A document contains 4 words; "this", "is", "this", "example". The document's title is; "example" The document's URL is; http://localhost/example.html If phrase matching is enabled, when the build is performed the wordsList parameter will contain Word objects with the following data:
Copy image Copy
wordsList[0] = "this", inUri=0, inTitle=0, inBody=1
wordsList[1] = "is",   inUri=0, inTitle=0, inBody=1
wordsList[2] = "this", inUri=0, inTitle=0, inBody=1
wordsList[3] = "example", inUri=1, inTitle=1, inBody=1
If phrase matching is disabled, when the build is performed the wordsList parameter will contain Word objects with the following data:
Copy image Copy
wordsList[0] = "this", inUri=0, inTitle=0, inBody=2
wordsList[1] = "is",   inUri=0, inTitle=0, inBody=1
wordsList[2] = "example", inUri=1, inTitle=1, inBody=1
This method is then called to calculate the Weight property in the Word objects (by default it uses the weight coefficients). This method can therefore be overridden with custom rules for weighting.


CalculateWordsRelevancy Method (wordsList)

CalculateWordsRelevancy Method (wordsList)
API Documentation ► Keyoti.SearchEngine.Documents ► Document ► CalculateWordsRelevancy(ArrayList)
Keyoti SearchUnit v6
Calculate the weight field value for the words in the list.
Declaration Syntax
C# Visual Basic
[ObsoleteAttribute("Renamed, use CalculateWordRelevancies", true)]
protected virtual void CalculateWordsRelevancy(
    ArrayList wordsList
)
<ObsoleteAttribute("Renamed, use CalculateWordRelevancies", true)>
Protected Overridable Sub CalculateWordsRelevancy (
    wordsList As ArrayList
)
Parameters
wordsList (ArrayList)
ArrayList of Word objects, with inBody, in Title, inURL fields filled
Remarks
This method defines the relationship between the occurrences (hits) in the document and the weight of the words in the document. Eg. A document contains 4 words; "this", "is", "this", "example". The document's title is; "example" The document's URL is; http://localhost/example.html If phrase matching is enabled, when the build is performed the wordsList parameter will contain Word objects with the following data:
Copy image Copy
wordsList[0] = "this", inUri=0, inTitle=0, inBody=1
wordsList[1] = "is",   inUri=0, inTitle=0, inBody=1
wordsList[2] = "this", inUri=0, inTitle=0, inBody=1
wordsList[3] = "example", inUri=1, inTitle=1, inBody=1
If phrase matching is disabled, when the build is performed the wordsList parameter will contain Word objects with the following data:
Copy image Copy
wordsList[0] = "this", inUri=0, inTitle=0, inBody=2
wordsList[1] = "is",   inUri=0, inTitle=0, inBody=1
wordsList[2] = "example", inUri=1, inTitle=1, inBody=1
This method is then called to calculate the Weight property in the Word objects (by default it uses the weight coefficients). This method can therefore be overridden with custom rules for weighting.


Configuration Property

Configuration Property
API Documentation ► Keyoti.SearchEngine.Documents ► Document ► Configuration
Keyoti SearchUnit v6
The instance of the Configuration class that holds the settings to be used.
Declaration Syntax
C# Visual Basic
public Configuration Configuration { get; }
Public ReadOnly Property Configuration As Configuration
    Get
Property Value
Configuration

Send comments on this topic to support@keyoti.com


ContentCategories Property

ContentCategories Property
API Documentation ► Keyoti.SearchEngine.Documents ► Document ► ContentCategories
Keyoti SearchUnit v6
The content categories of type ContentCategoryRecord that this document belongs to.
Declaration Syntax
C# Visual Basic
public virtual ArrayList ContentCategories { get; }
Public Overridable ReadOnly Property ContentCategories As ArrayList
    Get
Property Value
ArrayList

Send comments on this topic to support@keyoti.com


CustomData Property

CustomData Property
API Documentation ► Keyoti.SearchEngine.Documents ► Document ► CustomData
Keyoti SearchUnit v6
Any custom data that should be stored for the document.
Declaration Syntax
C# Visual Basic
public virtual string CustomData { get; set; }
Public Overridable Property CustomData As String
    Get
    Set
Property Value
String
Remarks
This may be useful for users of the SDK who need to store extra data about a document, such as meta-data, dates, ownership etc. Through this, additional data can be presented to the user or results can be filtered or sorted, etc (see help for more info). If this is set null, an empty string is stored.


Description Property

Description Property
API Documentation ► Keyoti.SearchEngine.Documents ► Document ► Description
Keyoti SearchUnit v6
Description of the document, if specified.
Declaration Syntax
C# Visual Basic
public virtual string Description { get; set; }
Public Overridable Property Description As String
    Get
    Set
Property Value
String
Remarks
This is only specified when enablePhraseMatching is false.


Dispose Method

Dispose Method
API Documentation ► Keyoti.SearchEngine.Documents ► Document ► Dispose()()()()
Keyoti SearchUnit v6
Removes all references held by this object.
Declaration Syntax
C# Visual Basic
public virtual void Dispose()
Public Overridable Sub Dispose

Send comments on this topic to support@keyoti.com


DocumentId Property

DocumentId Property
API Documentation ► Keyoti.SearchEngine.Documents ► Document ► DocumentId
Keyoti SearchUnit v6
The ID of the document in the data layer.
Declaration Syntax
C# Visual Basic
public virtual int DocumentId { get; set; }
Public Overridable Property DocumentId As Integer
    Get
    Set
Property Value
Int32

Send comments on this topic to support@keyoti.com


DocumentRecord Property

DocumentRecord Property
API Documentation ► Keyoti.SearchEngine.Documents ► Document ► DocumentRecord
Keyoti SearchUnit v6
The DocumentRecord instance that stores the data.
Declaration Syntax
C# Visual Basic
public virtual DocumentRecord DocumentRecord { get; set; }
Public Overridable Property DocumentRecord As DocumentRecord
    Get
    Set
Property Value
DocumentRecord

Send comments on this topic to support@keyoti.com


DontIndex Property

DontIndex Property
API Documentation ► Keyoti.SearchEngine.Documents ► Document ► DontIndex
Keyoti SearchUnit v6
Whether to ignore the document during index creation.
Declaration Syntax
C# Visual Basic
public virtual bool DontIndex { get; set; }
Public Overridable Property DontIndex As Boolean
    Get
    Set
Property Value
Boolean

Send comments on this topic to support@keyoti.com


Encoding Property

Encoding Property
API Documentation ► Keyoti.SearchEngine.Documents ► Document ► Encoding
Keyoti SearchUnit v6
The document's character encoding.
Declaration Syntax
C# Visual Basic
public virtual Encoding Encoding { get; set; }
Public Overridable Property Encoding As Encoding
    Get
    Set
Property Value
Encoding
Remarks
Only has a valid value if set externally or if ReadText or ReadLinks has been called.


Equals Method (obj)

Equals Method (obj)
API Documentation ► Keyoti.SearchEngine.Documents ► Document ► Equals(Object)
Keyoti SearchUnit v6
Determines if documents are equal
Declaration Syntax
C# Visual Basic
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Parameters
obj (Object)
The document to compare
Return Value
Boolean

Send comments on this topic to support@keyoti.com


FileType Property

FileType Property
API Documentation ► Keyoti.SearchEngine.Documents ► Document ► FileType
Keyoti SearchUnit v6
The mime-type for the document.
Declaration Syntax
C# Visual Basic
[ObsoleteAttribute("Use GetFileType instead.", true)]
public virtual string FileType { get; set; }
<ObsoleteAttribute("Use GetFileType instead.", true)>
Public Overridable Property FileType As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


GetFileType Method

GetFileType Method
API Documentation ► Keyoti.SearchEngine.Documents ► Document ► GetFileType()()()()
Keyoti SearchUnit v6
The mime-type for the document.
Declaration Syntax
C# Visual Basic
public virtual string GetFileType()
Public Overridable Function GetFileType As String
Return Value
String

Send comments on this topic to support@keyoti.com


GetHashCode Method

GetHashCode Method
API Documentation ► Keyoti.SearchEngine.Documents ► Document ► GetHashCode()()()()
Keyoti SearchUnit v6
Gets the hashcode for the document, based on it's DocumentRecord.
Declaration Syntax
C# Visual Basic
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Return Value
Int32

Send comments on this topic to support@keyoti.com


InBodyCoefficient Property

InBodyCoefficient Property
API Documentation ► Keyoti.SearchEngine.Documents ► Document ► InBodyCoefficient
Keyoti SearchUnit v6
Coefficient used for weighting words found in the document body.
Declaration Syntax
C# Visual Basic
public int InBodyCoefficient { get; set; }
Public Property InBodyCoefficient As Integer
    Get
    Set
Property Value
Int32
Remarks
Increasing this number makes documents with query words in the body rank higher. This number is only used during index building, after that it is not used, so this number should be changed as part of a custom build program.


IndexableSourceId Property

IndexableSourceId Property
API Documentation ► Keyoti.SearchEngine.Documents ► Document ► IndexableSourceId
Keyoti SearchUnit v6
The ID of the indexable source this belongs to, or -1 if none.
Declaration Syntax
C# Visual Basic
public virtual int IndexableSourceId { get; set; }
Public Overridable Property IndexableSourceId As Integer
    Get
    Set
Property Value
Int32

Send comments on this topic to support@keyoti.com


InTitleCoefficient Property

InTitleCoefficient Property
API Documentation ► Keyoti.SearchEngine.Documents ► Document ► InTitleCoefficient
Keyoti SearchUnit v6
Coefficient used for weighting words found in the document title.
Declaration Syntax
C# Visual Basic
public int InTitleCoefficient { get; set; }
Public Property InTitleCoefficient As Integer
    Get
    Set
Property Value
Int32
Remarks
Increasing this number makes documents with query words in the title rank higher. This number is only used during index building, after that it is not used, so this number should be changed as part of a custom build program.


InUrlCoefficient Property

InUrlCoefficient Property
API Documentation ► Keyoti.SearchEngine.Documents ► Document ► InUrlCoefficient
Keyoti SearchUnit v6
Coefficient used for weighting words found in the document Uri.
Declaration Syntax
C# Visual Basic
public int InUrlCoefficient { get; set; }
Public Property InUrlCoefficient As Integer
    Get
    Set
Property Value
Int32
Remarks
Increasing this number makes documents with query words in the Uri rank higher. This number is only used during index building, after that it is not used, so this number should be changed as part of a custom build program.


IsDocumentChanged Method

IsDocumentChanged Method
API Documentation ► Keyoti.SearchEngine.Documents ► Document ► IsDocumentChanged()()()()
Keyoti SearchUnit v6
Whether the document can be identified to have changed between the last time it was indexed and when LoadResponseStream was called.
Declaration Syntax
C# Visual Basic
public bool IsDocumentChanged()
Public Function IsDocumentChanged As Boolean
Return Value
Boolean
Remarks
Change is detected through the Document's last-modified date and through it's file-size. Either of these mechanisms may be unusable to detect change, since they both rely on data from the document's source (e.g. web-server). Further, both mechanisms can be overridden through Configuration properties.


IsIndexed Method

IsIndexed Method
API Documentation ► Keyoti.SearchEngine.Documents ► Document ► IsIndexed()()()()
Keyoti SearchUnit v6
Whether this document has been indexed.
Declaration Syntax
C# Visual Basic
public virtual bool IsIndexed()
Public Overridable Function IsIndexed As Boolean
Return Value
Boolean

Send comments on this topic to support@keyoti.com


LastDateIndexed Property

LastDateIndexed Property
API Documentation ► Keyoti.SearchEngine.Documents ► Document ► LastDateIndexed
Keyoti SearchUnit v6
The date the document was last indexed.
Declaration Syntax
C# Visual Basic
public virtual DateTime LastDateIndexed { get; set; }
Public Overridable Property LastDateIndexed As DateTime
    Get
    Set
Property Value
DateTime

Send comments on this topic to support@keyoti.com


LastModifiedDate Property

LastModifiedDate Property
API Documentation ► Keyoti.SearchEngine.Documents ► Document ► LastModifiedDate
Keyoti SearchUnit v6
The LastModifiedDate for the document.
Declaration Syntax
C# Visual Basic
public virtual DateTime LastModifiedDate { get; set; }
Public Overridable Property LastModifiedDate As DateTime
    Get
    Set
Property Value
DateTime

Send comments on this topic to support@keyoti.com


LastResponseStatusCode Property

LastResponseStatusCode Property
API Documentation ► Keyoti.SearchEngine.Documents ► Document ► LastResponseStatusCode
Keyoti SearchUnit v6
The URI provided with the last server response, HttpStatusCode.Unused if not available.
Declaration Syntax
C# Visual Basic
public HttpStatusCode LastResponseStatusCode { get; }
Public ReadOnly Property LastResponseStatusCode As HttpStatusCode
    Get
Property Value
HttpStatusCode

Send comments on this topic to support@keyoti.com


LastResponseUri Property

LastResponseUri Property
API Documentation ► Keyoti.SearchEngine.Documents ► Document ► LastResponseUri
Keyoti SearchUnit v6
The URI provided with the last server response, null if not available.
Declaration Syntax
C# Visual Basic
public Uri LastResponseUri { get; }
Public ReadOnly Property LastResponseUri As Uri
    Get
Property Value
Uri

Send comments on this topic to support@keyoti.com


LocationCategory Property

LocationCategory Property
API Documentation ► Keyoti.SearchEngine.Documents ► Document ► LocationCategory
Keyoti SearchUnit v6
The location category that this document belongs to.
Declaration Syntax
C# Visual Basic
public virtual LocationCategoryRecord LocationCategory { get; set; }
Public Overridable Property LocationCategory As LocationCategoryRecord
    Get
    Set
Property Value
LocationCategoryRecord

Send comments on this topic to support@keyoti.com


LoginPage Property

LoginPage Property
API Documentation ► Keyoti.SearchEngine.Documents ► Document ► LoginPage
Keyoti SearchUnit v6
Whether this page is a 'login page' (for Forms Authentication).
Declaration Syntax
C# Visual Basic
public virtual bool LoginPage { get; set; }
Public Overridable Property LoginPage As Boolean
    Get
    Set
Property Value
Boolean
Remarks
Pages marked as a login page called prior to building the index so that the indexer is logged in to the web-site. See user guide for details on using indexer with web-sites using Forms Authentication.


Parser Property

Parser Property
API Documentation ► Keyoti.SearchEngine.Documents ► Document ► Parser
Keyoti SearchUnit v6
The Parser instance used to parse words from the remote document.
Declaration Syntax
C# Visual Basic
public virtual Parser Parser { get; set; }
Public Overridable Property Parser As Parser
    Get
    Set
Property Value
Parser
Remarks
If this property isn't set before the first use of this property, a default is assigned from the ParserProvider property.


ParserProvider Property

ParserProvider Property
API Documentation ► Keyoti.SearchEngine.Documents ► Document ► ParserProvider
Keyoti SearchUnit v6
The ParserProvider to use to obtain the correct parser to parse the document.
Declaration Syntax
C# Visual Basic
public virtual ParserProvider ParserProvider { get; set; }
Public Overridable Property ParserProvider As ParserProvider
    Get
    Set
Property Value
ParserProvider
Remarks
If this property isn't set before the first use of this property, a default is assigned.


Reader Property

Reader Property
API Documentation ► Keyoti.SearchEngine.Documents ► Document ► Reader
Keyoti SearchUnit v6
The Reader instance used to read the document and links from the remote document.
Declaration Syntax
C# Visual Basic
public virtual Reader Reader { get; set; }
Public Overridable Property Reader As Reader
    Get
    Set
Property Value
Reader
Remarks
If this property isn't set before the first use of this property, a default is assigned.


ReadLinks Method

ReadLinks Method
API Documentation ► Keyoti.SearchEngine.Documents ► Document ► ReadLinks()()()()
Keyoti SearchUnit v6
Retrieves a list of links, calling ReadLinks() from the Parser property
Declaration Syntax
C# Visual Basic
public virtual ArrayList ReadLinks()
Public Overridable Function ReadLinks As ArrayList
Return Value
ArrayList
ArrayList of strings with URLs from this document's links.


ReadText Method

ReadText Method
API Documentation ► Keyoti.SearchEngine.Documents ► Document ► ReadText()()()()
Keyoti SearchUnit v6
Retrieves the document's words as an ArrayList, and title if available.
Declaration Syntax
C# Visual Basic
public virtual DocumentText ReadText()
Public Overridable Function ReadText As DocumentText
Return Value
DocumentText
DocumentText object representing the words, title and summary of this document.


SecurityGroups Property

SecurityGroups Property
API Documentation ► Keyoti.SearchEngine.Documents ► Document ► SecurityGroups
Keyoti SearchUnit v6
The securityGroup category that this document belongs to.
Declaration Syntax
C# Visual Basic
public virtual SecurityGroupRecordList SecurityGroups { get; set; }
Public Overridable Property SecurityGroups As SecurityGroupRecordList
    Get
    Set
Property Value
SecurityGroupRecordList

Send comments on this topic to support@keyoti.com


stream Field

stream Field
API Documentation ► Keyoti.SearchEngine.Documents ► Document ► stream
Keyoti SearchUnit v6
The document stream.
Declaration Syntax
C# Visual Basic
protected Stream stream
Protected stream As Stream
Field Value
Stream

Send comments on this topic to support@keyoti.com


Title Property

Title Property
API Documentation ► Keyoti.SearchEngine.Documents ► Document ► Title
Keyoti SearchUnit v6
The title of the document.
Declaration Syntax
C# Visual Basic
public virtual string Title { get; set; }
Public Overridable Property Title As String
    Get
    Set
Property Value
String
Remarks
Typically for Html documents this is obtained from the <title> tag.


Uri Property

Uri Property
API Documentation ► Keyoti.SearchEngine.Documents ► Document ► Uri
Keyoti SearchUnit v6
The document's Uri (URL).
Declaration Syntax
C# Visual Basic
public virtual Uri Uri { get; set; }
Public Overridable Property Uri As Uri
    Get
    Set
Property Value
Uri

Send comments on this topic to support@keyoti.com


DocumentText Class

DocumentText Class
API Documentation ► Keyoti.SearchEngine.Documents ► DocumentText
Keyoti SearchUnit v6
Represents the text in a document, including title and static summary.
Declaration Syntax
C# Visual Basic
public class DocumentText
Public Class DocumentText
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DocumentText(String, String, WordCollection, String, array<String>[]()[][], String, StringList, array<String>[]()[][], Hashtable) | Create a new instance
 | DocumentText(String, String, WordCollection, String, array<String>[]()[][], String, StringList, array<String>[]()[][]) | Create a new instance
 | AddWord(String, Int32, Boolean) | Convenience method to add a word to the indexed document text.
 | AppendText(String, Configuration) | Appends words in 'text' to the main document.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Links | List of link URLs to other documents contained in this document.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Merge(DocumentText) | Merges the words in 'text' with this object.
 | MetaContentNames | Content category names from meta tag.
 | MetaCustomData | Custom data from meta tag.
 | MetaData | Meta data if it exists (if it doesn't, null/nothing).
 | MetaLocationName | Location category names from meta tag.
 | MetaSecurityGroupNames | Security category names from meta tag.
 | PrependText(String, Configuration) | Prepends words in 'text' to the start of the main document.
 | Summary | Summary or excerpt of the document.
 | Title | The document title.
 | ToString()()()() | (Inherited from Object.)
 | Words | List of Word objects from the document.
Inheritance Hierarchy
Object
DocumentText

Send comments on this topic to support@keyoti.com


DocumentText Constructor

DocumentText Constructor
API Documentation ► Keyoti.SearchEngine.Documents ► DocumentText ► DocumentText()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | DocumentText(String, String, WordCollection, String, array<String>[]()[][], String, StringList, array<String>[]()[][], Hashtable) | Create a new instance
 | DocumentText(String, String, WordCollection, String, array<String>[]()[][], String, StringList, array<String>[]()[][]) | Create a new instance


DocumentText Constructor (title, summary, words, metaTagLocationName, metaTagContentNames, metaCustomData, links, metaSecurityGroupNames)

DocumentText Constructor (title, summary, words, metaTagLocationName, metaTagContentNames, metaCustomData, links, metaSecurityGroupNames)
API Documentation ► Keyoti.SearchEngine.Documents ► DocumentText ► DocumentText(String, String, WordCollection, String, array<String>[]()[][], String, StringList, array<String>[]()[][])
Keyoti SearchUnit v6
Create a new instance
Declaration Syntax
C# Visual Basic
public DocumentText(
    string title,
    string summary,
    WordCollection words,
    string metaTagLocationName,
    string[] metaTagContentNames,
    string metaCustomData,
    StringList links,
    string[] metaSecurityGroupNames
)
Public Sub New (
    title As String,
    summary As String,
    words As WordCollection,
    metaTagLocationName As String,
    metaTagContentNames As String(),
    metaCustomData As String,
    links As StringList,
    metaSecurityGroupNames As String()
)
Parameters
title (String)
The title of the document
summary (String)
A summary of the document (usually the first N words)
words (WordCollection)
WordCollection holding all words in the document
metaTagLocationName (String)
Any 'location' category name specified in meta data
metaTagContentNames (array< String >[]()[][])
Any 'content' category names specified in meta data
metaCustomData (String)
Any custom data specified in meta data
links (StringList)
List of link URLs to other documents contained in this document.
metaSecurityGroupNames (array< String >[]()[][])
Any names of security groups specified in the meta data.


DocumentText Constructor (title, summary, words, metaTagLocationName, metaTagContentNames, metaCustomData, links, metaSecurityGroupNames, metaData)

DocumentText Constructor (title, summary, words, metaTagLocationName, metaTagContentNames, metaCustomData, links, metaSecurityGroupNames, metaData)
API Documentation ► Keyoti.SearchEngine.Documents ► DocumentText ► DocumentText(String, String, WordCollection, String, array<String>[]()[][], String, StringList, array<String>[]()[][], Hashtable)
Keyoti SearchUnit v6
Create a new instance
Declaration Syntax
C# Visual Basic
public DocumentText(
    string title,
    string summary,
    WordCollection words,
    string metaTagLocationName,
    string[] metaTagContentNames,
    string metaCustomData,
    StringList links,
    string[] metaSecurityGroupNames,
    Hashtable metaData
)
Public Sub New (
    title As String,
    summary As String,
    words As WordCollection,
    metaTagLocationName As String,
    metaTagContentNames As String(),
    metaCustomData As String,
    links As StringList,
    metaSecurityGroupNames As String(),
    metaData As Hashtable
)
Parameters
title (String)
The title of the document
summary (String)
A summary of the document (usually the first N words)
words (WordCollection)
WordCollection holding all words in the document
metaTagLocationName (String)
Any 'location' category name specified in meta data
metaTagContentNames (array< String >[]()[][])
Any 'content' category names specified in meta data
metaCustomData (String)
Any custom data specified in meta data
links (StringList)
List of link URLs to other documents contained in this document.
metaSecurityGroupNames (array< String >[]()[][])
Any names of security groups specified in the meta data.
metaData (Hashtable)
Hashtable of meta data, keys and values are strings.


AddWord Method (word, weight, trimWhiteSpace)

AddWord Method (word, weight, trimWhiteSpace)
API Documentation ► Keyoti.SearchEngine.Documents ► DocumentText ► AddWord(String, Int32, Boolean)
Keyoti SearchUnit v6
Convenience method to add a word to the indexed document text.
Declaration Syntax
C# Visual Basic
public void AddWord(
    string word,
    int weight,
    bool trimWhiteSpace
)
Public Sub AddWord (
    word As String,
    weight As Integer,
    trimWhiteSpace As Boolean
)
Parameters
word (String)
weight (Int32)
trimWhiteSpace (Boolean)
Remarks
Any words added will be indexed with the document content and will be searchable. These words may also be shown in the result summary.


AppendText Method (text, configuration)

AppendText Method (text, configuration)
API Documentation ► Keyoti.SearchEngine.Documents ► DocumentText ► AppendText(String, Configuration)
Keyoti SearchUnit v6
Appends words in 'text' to the main document.
Declaration Syntax
C# Visual Basic
public void AppendText(
    string text,
    Configuration configuration
)
Public Sub AppendText (
    text As String,
    configuration As Configuration
)
Parameters
text (String)
The plain text that should be appended to the existing document text and indexed.
configuration (Configuration)
The existing configuration to use.


Links Property

Links Property
API Documentation ► Keyoti.SearchEngine.Documents ► DocumentText ► Links
Keyoti SearchUnit v6
List of link URLs to other documents contained in this document.
Declaration Syntax
C# Visual Basic
public StringList Links { get; }
Public ReadOnly Property Links As StringList
    Get
Property Value
StringList

Send comments on this topic to support@keyoti.com


Merge Method (text)

Merge Method (text)
API Documentation ► Keyoti.SearchEngine.Documents ► DocumentText ► Merge(DocumentText)
Keyoti SearchUnit v6
Merges the words in 'text' with this object.
Declaration Syntax
C# Visual Basic
public void Merge(
    DocumentText text
)
Public Sub Merge (
    text As DocumentText
)
Parameters
text (DocumentText)


MetaContentNames Property

MetaContentNames Property
API Documentation ► Keyoti.SearchEngine.Documents ► DocumentText ► MetaContentNames
Keyoti SearchUnit v6
Content category names from meta tag.
Declaration Syntax
C# Visual Basic
public string[] MetaContentNames { get; set; }
Public Property MetaContentNames As String()
    Get
    Set
Property Value
array< String >[]()[][]


MetaCustomData Property

MetaCustomData Property
API Documentation ► Keyoti.SearchEngine.Documents ► DocumentText ► MetaCustomData
Keyoti SearchUnit v6
Custom data from meta tag.
Declaration Syntax
C# Visual Basic
public string MetaCustomData { get; set; }
Public Property MetaCustomData As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


MetaData Property

MetaData Property
API Documentation ► Keyoti.SearchEngine.Documents ► DocumentText ► MetaData
Keyoti SearchUnit v6
Meta data if it exists (if it doesn't, null/nothing).
Declaration Syntax
C# Visual Basic
public Hashtable MetaData { get; set; }
Public Property MetaData As Hashtable
    Get
    Set
Property Value
Hashtable

Send comments on this topic to support@keyoti.com


MetaLocationName Property

MetaLocationName Property
API Documentation ► Keyoti.SearchEngine.Documents ► DocumentText ► MetaLocationName
Keyoti SearchUnit v6
Location category names from meta tag.
Declaration Syntax
C# Visual Basic
public string MetaLocationName { get; set; }
Public Property MetaLocationName As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


MetaSecurityGroupNames Property

MetaSecurityGroupNames Property
API Documentation ► Keyoti.SearchEngine.Documents ► DocumentText ► MetaSecurityGroupNames
Keyoti SearchUnit v6
Security category names from meta tag.
Declaration Syntax
C# Visual Basic
public string[] MetaSecurityGroupNames { get; set; }
Public Property MetaSecurityGroupNames As String()
    Get
    Set
Property Value
array< String >[]()[][]


PrependText Method (text, configuration)

PrependText Method (text, configuration)
API Documentation ► Keyoti.SearchEngine.Documents ► DocumentText ► PrependText(String, Configuration)
Keyoti SearchUnit v6
Prepends words in 'text' to the start of the main document.
Declaration Syntax
C# Visual Basic
public void PrependText(
    string text,
    Configuration configuration
)
Public Sub PrependText (
    text As String,
    configuration As Configuration
)
Parameters
text (String)
The plain text that should be prepended to the beginning of the existing document text and indexed.
configuration (Configuration)
The existing configuration to use.


Summary Property

Summary Property
API Documentation ► Keyoti.SearchEngine.Documents ► DocumentText ► Summary
Keyoti SearchUnit v6
Summary or excerpt of the document.
Declaration Syntax
C# Visual Basic
public string Summary { get; set; }
Public Property Summary As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


Title Property

Title Property
API Documentation ► Keyoti.SearchEngine.Documents ► DocumentText ► Title
Keyoti SearchUnit v6
The document title.
Declaration Syntax
C# Visual Basic
public string Title { get; set; }
Public Property Title As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


Words Property

Words Property
API Documentation ► Keyoti.SearchEngine.Documents ► DocumentText ► Words
Keyoti SearchUnit v6
List of Word objects from the document.
Declaration Syntax
C# Visual Basic
public WordCollection Words { get; }
Public ReadOnly Property Words As WordCollection
    Get
Property Value
WordCollection

Send comments on this topic to support@keyoti.com


DocxParser Class

DocxParser Class
API Documentation ► Keyoti.SearchEngine.Documents ► DocxParser
Keyoti SearchUnit v6
Summary description for DocxParser.
Declaration Syntax
C# Visual Basic
public class DocxParser : XmlDocumentParser
Public Class DocxParser
    Inherits XmlDocumentParser
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DocxParser(Configuration) | New instance
 | Configuration | Gets the instance of the Configuration class that holds the settings to be used. (Inherited from Parser.)
 | CopyStream(Stream) | (Inherited from Parser.)
 | Encoding | The character encoding used in the document Stream, if applicable. (Inherited from Parser.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetFilenameFooter(Uri) | Creates a footer with filename info from the Uri (Inherited from Parser.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetNextWord(String) | Returns the next 'word' in rawBody, is iterative, so subsequent calls move to consecutive words. (Inherited from Parser.)
 | GetType()()()() | (Inherited from Object.)
 | GetWordsInUri(Uri) | Returns list of words as strings in an ArrayList, that are in the Uri (Inherited from Parser.)
 | IsCurrentWordInTitle()()()() | Returns whether the word last returned by GetNextWord is part of the title. (Inherited from Parser.)
 | IsInIgnoredRegion(ArrayList) | Determines whether current word (at wordStart) is in an ignored region. (Inherited from Parser.)
 | IsStreamNeeded()()()() | Obsolete. Whether the parser would need a stream to be passed to it in order to perform a ReadText or ReadLinks operation. (Inherited from Parser.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ParseWords(String, ArrayList, WordCollection, StringBuilder, ArrayList) | Parses rawBody into descrete Word objects and places them in readDocumentWords. (Inherited from Parser.)
 | PreprocessBreakChunk(String) | Applies any required processing to a chunk of text that typically forms either a word or whitespace block. (Inherited from Parser.)
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean) | Processes the list of all words found in the document and returns a list that should be index. (Inherited from Parser.)
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean, ArrayList) | Processes the list of all words found in the document and returns a list that should be index. (Inherited from Parser.)
 | Read(Stream, Uri, Encoding) | Reads a document and returns an object holding it's text and any links. (Overrides XmlDocumentParser.Read(Stream, Uri, Encoding).)
 | Read(String, Uri, Encoding) | Read the document (Inherited from TxtDocumentParser.)
 | ReadLinks(Stream, Encoding) | Obsolete. Reads links to other pages. (Inherited from Parser.)
 | ReadText(Stream, Uri, Encoding) | Obsolete. Reads text and returns list of words and title (Inherited from Parser.)
 | ResetWordPointers()()()() | Resets the current word being processed. (Inherited from Parser.)
 | ToString()()()() | (Inherited from Object.)
 | TruncateWordWithRepeatedChar(String) | Removes repeated non-letters from word. (Inherited from Parser.)
 | WordEnd | The current word's end. (Inherited from Parser.)
 | WordStart | The current word's start. (Inherited from Parser.)
Inheritance Hierarchy
Object
 | Parser
 |  | TxtDocumentParser
 |  |  | XmlDocumentParser
 |  |  |  | DocxParser


DocxParser Constructor (configuration)

DocxParser Constructor (configuration)
API Documentation ► Keyoti.SearchEngine.Documents ► DocxParser ► DocxParser(Configuration)
Keyoti SearchUnit v6
New instance
Declaration Syntax
C# Visual Basic
public DocxParser(
    Configuration configuration
)
Public Sub New (
    configuration As Configuration
)
Parameters
configuration (Configuration)
The configuration to use.


Read Method (stream, uri, encoding)

Read Method (stream, uri, encoding)
API Documentation ► Keyoti.SearchEngine.Documents ► DocxParser ► Read(Stream, Uri, Encoding)
Keyoti SearchUnit v6
Reads a document and returns an object holding it's text and any links.
Declaration Syntax
C# Visual Basic
public override DocumentText Read(
    Stream stream,
    Uri uri,
    Encoding encoding
)
Public Overrides Function Read (
    stream As Stream,
    uri As Uri,
    encoding As Encoding
) As DocumentText
Parameters
stream (Stream)
The document stream to read from.
uri (Uri)
The document URI, used only for weighting words found in the document.
encoding (Encoding)
The document encoding if applicable/available.
Return Value
DocumentText
The DocumentText for the document.


FatalReaderException Class

FatalReaderException Class
API Documentation ► Keyoti.SearchEngine.Documents ► FatalReaderException
Keyoti SearchUnit v6
A Reader exception that is fatal.
Declaration Syntax
C# Visual Basic
public class FatalReaderException : Exception
Public Class FatalReaderException
    Inherits Exception
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FatalReaderException(Exception) | Creates a new fatal exception
 | Data | (Inherited from Exception.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetBaseException()()()() | (Inherited from Exception.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | (Inherited from Exception.)
 | GetType()()()() | (Inherited from Exception.)
 | HelpLink | (Inherited from Exception.)
 | HResult | (Inherited from Exception.)
 | InnerException | (Inherited from Exception.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | The message (Overrides Exception.Message.)
 | Source | (Inherited from Exception.)
 | StackTrace | (Inherited from Exception.)
 | TargetSite | (Inherited from Exception.)
 | ToString()()()() | (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | FatalReaderException


FatalReaderException Constructor (innerException)

FatalReaderException Constructor (innerException)
API Documentation ► Keyoti.SearchEngine.Documents ► FatalReaderException ► FatalReaderException(Exception)
Keyoti SearchUnit v6
Creates a new fatal exception
Declaration Syntax
C# Visual Basic
public FatalReaderException(
    Exception innerException
)
Public Sub New (
    innerException As Exception
)
Parameters
innerException (Exception)


Message Property

Message Property
API Documentation ► Keyoti.SearchEngine.Documents ► FatalReaderException ► Message
Keyoti SearchUnit v6
The message
Declaration Syntax
C# Visual Basic
public override string Message { get; }
Public Overrides ReadOnly Property Message As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


GenericIFilterParser Class

GenericIFilterParser Class
API Documentation ► Keyoti.SearchEngine.Documents ► GenericIFilterParser
Keyoti SearchUnit v6
A generic, IFilter based document parser, which can read text from any document for which an IFilter is installed on the system.
Declaration Syntax
C# Visual Basic
public class GenericIFilterParser : TxtDocumentParser
Public Class GenericIFilterParser
    Inherits TxtDocumentParser
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GenericIFilterParser(Configuration, String) | New instance
 | Configuration | Gets the instance of the Configuration class that holds the settings to be used. (Inherited from Parser.)
 | CopyStream(Stream) | (Inherited from Parser.)
 | Encoding | The character encoding used in the document Stream, if applicable. (Inherited from Parser.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetFilenameFooter(Uri) | Creates a footer with filename info from the Uri (Inherited from Parser.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetNextWord(String) | Returns the next 'word' in rawBody, is iterative, so subsequent calls move to consecutive words. (Inherited from Parser.)
 | GetType()()()() | (Inherited from Object.)
 | GetWordsInUri(Uri) | Returns list of words as strings in an ArrayList, that are in the Uri (Inherited from Parser.)
 | IsCurrentWordInTitle()()()() | Returns whether the word last returned by GetNextWord is part of the title. (Inherited from Parser.)
 | IsInIgnoredRegion(ArrayList) | Determines whether current word (at wordStart) is in an ignored region. (Inherited from Parser.)
 | IsStreamNeeded()()()() | Obsolete. Whether the parser would need a stream to be passed to it in order to perform a ReadText or ReadLinks operation. (Inherited from Parser.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ParseWords(String, ArrayList, WordCollection, StringBuilder, ArrayList) | Parses rawBody into descrete Word objects and places them in readDocumentWords. (Inherited from Parser.)
 | PreprocessBreakChunk(String) | Applies any required processing to a chunk of text that typically forms either a word or whitespace block. (Inherited from Parser.)
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean) | Processes the list of all words found in the document and returns a list that should be index. (Inherited from Parser.)
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean, ArrayList) | Processes the list of all words found in the document and returns a list that should be index. (Inherited from Parser.)
 | Read(Stream, Uri, Encoding) | Reads a document and returns an object holding it's text and any links. (Overrides TxtDocumentParser.Read(Stream, Uri, Encoding).)
 | Read(String, Uri, Encoding) | Read the document (Inherited from TxtDocumentParser.)
 | ReadLinks(Stream, Encoding) | Obsolete. Reads links to other pages. (Inherited from Parser.)
 | ReadText(Stream, Uri, Encoding) | Obsolete. Reads text and returns list of words and title (Inherited from Parser.)
 | ResetWordPointers()()()() | Resets the current word being processed. (Inherited from Parser.)
 | ToString()()()() | (Inherited from Object.)
 | TruncateWordWithRepeatedChar(String) | Removes repeated non-letters from word. (Inherited from Parser.)
 | WordEnd | The current word's end. (Inherited from Parser.)
 | WordStart | The current word's start. (Inherited from Parser.)
Remarks
Used for .XLS (Excel) and .PPT (Powerpoint) files.
Inheritance Hierarchy
Object
 | Parser
 |  | TxtDocumentParser
 |  |  | GenericIFilterParser


GenericIFilterParser Constructor (configuration, mimeType)

GenericIFilterParser Constructor (configuration, mimeType)
API Documentation ► Keyoti.SearchEngine.Documents ► GenericIFilterParser ► GenericIFilterParser(Configuration, String)
Keyoti SearchUnit v6
New instance
Declaration Syntax
C# Visual Basic
public GenericIFilterParser(
    Configuration configuration,
    string mimeType
)
Public Sub New (
    configuration As Configuration,
    mimeType As String
)
Parameters
configuration (Configuration)
The configuration to use
mimeType (String)
The mimetype for the content

Send comments on this topic to support@keyoti.com


Read Method (stream, uri, encoding)

Read Method (stream, uri, encoding)
API Documentation ► Keyoti.SearchEngine.Documents ► GenericIFilterParser ► Read(Stream, Uri, Encoding)
Keyoti SearchUnit v6
Reads a document and returns an object holding it's text and any links.
Declaration Syntax
C# Visual Basic
public override DocumentText Read(
    Stream stream,
    Uri uri,
    Encoding encoding
)
Public Overrides Function Read (
    stream As Stream,
    uri As Uri,
    encoding As Encoding
) As DocumentText
Parameters
stream (Stream)
The document stream to read from.
uri (Uri)
The document URI, used only for weighting words found in the document.
encoding (Encoding)
The document encoding if applicable/available.
Return Value
DocumentText
The DocumentText for the document.


HtmlDocumentParser Class

HtmlDocumentParser Class
API Documentation ► Keyoti.SearchEngine.Documents ► HtmlDocumentParser
Keyoti SearchUnit v6
Parses Html documents for words and links.
Declaration Syntax
C# Visual Basic
public class HtmlDocumentParser : Parser
Public Class HtmlDocumentParser
    Inherits Parser
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HtmlDocumentParser(Configuration) | Creates a new instance of HtmlDocumentParser.
 | Configuration | Gets the instance of the Configuration class that holds the settings to be used. (Inherited from Parser.)
 | CopyStream(Stream) | (Inherited from Parser.)
 | DeriveEncoding(Stream) | Tries to find the encoding of a HTML file from the Content-type meta tag.
 | DeriveTitleFromDocument(String) | Attempts to returns the title of the document, based on the documentBody
 | Encoding | The character encoding used in the document Stream, if applicable. (Inherited from Parser.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FindIgnoreRegions(String) | Finds all ignore regions in documentBody.
 | GetFilenameFooter(Uri) | Creates a footer with filename info from the Uri (Inherited from Parser.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetNextWord(String) | Returns the next 'word' in rawBody, is iterative, so subsequent calls move to consecutive words. (Overrides Parser.GetNextWord(String).)
 | GetType()()()() | (Inherited from Object.)
 | GetWordsInUri(Uri) | Returns list of words as strings in an ArrayList, that are in the Uri (Inherited from Parser.)
 | IsCurrentWordInTitle()()()() | Whether word last returned by GetNextWord is in title. (Overrides Parser.IsCurrentWordInTitle()()()().)
 | IsInIgnoredRegion(ArrayList) | Determines whether current word (at wordStart) is in an ignored region. (Inherited from Parser.)
 | IsStreamNeeded()()()() | Obsolete. Whether the parser would need a stream to be passed to it in order to perform a ReadText or ReadLinks operation. (Inherited from Parser.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ParseWords(String, ArrayList, WordCollection, StringBuilder, ArrayList) | Parses rawBody into descrete Word objects and places them in readDocumentWords. (Inherited from Parser.)
 | PreprocessBreakChunk(String) | Applies any required processing to a chunk of text that typically forms either a word or whitespace block. (Inherited from Parser.)
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean) | Processes the list of all words found in the document and returns a list that should be index. (Inherited from Parser.)
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean, ArrayList) | Processes the list of all words found in the document and returns a list that should be index. (Inherited from Parser.)
 | Read(Stream, Uri, Encoding) | Reads a document and returns an object holding it's text and any links. (Overrides Parser.Read(Stream, Uri, Encoding).)
 | ReadDocumentContent(Stream, Encoding) | Returns string read from 'stream'.
 | ReadLinks(Stream, Encoding) | Obsolete. Reads links to other pages. (Inherited from Parser.)
 | ReadMetaTable(String) | Reads the meta tags for a document.
 | ReadText(Stream, Uri, Encoding) | Obsolete. Reads text and returns list of words and title (Inherited from Parser.)
 | ResetWordPointers()()()() | Resets the current word being processed. (Inherited from Parser.)
 | ToString()()()() | (Inherited from Object.)
 | TruncateWordWithRepeatedChar(String) | Removes repeated non-letters from word. (Inherited from Parser.)
 | WordEnd | The current word's end. (Inherited from Parser.)
 | WordStart | The current word's start. (Inherited from Parser.)
Inheritance Hierarchy
Object
 | Parser
 |  | HtmlDocumentParser
 |  |  | DataSetRecordParser


HtmlDocumentParser Constructor (configuration)

HtmlDocumentParser Constructor (configuration)
API Documentation ► Keyoti.SearchEngine.Documents ► HtmlDocumentParser ► HtmlDocumentParser(Configuration)
Keyoti SearchUnit v6
Creates a new instance of HtmlDocumentParser.
Declaration Syntax
C# Visual Basic
public HtmlDocumentParser(
    Configuration configuration
)
Public Sub New (
    configuration As Configuration
)
Parameters
configuration (Configuration)
The instance of the Configuration class that holds the settings to be used.


DeriveEncoding Method (stream)

DeriveEncoding Method (stream)
API Documentation ► Keyoti.SearchEngine.Documents ► HtmlDocumentParser ► DeriveEncoding(Stream)
Keyoti SearchUnit v6
Tries to find the encoding of a HTML file from the Content-type meta tag.
Declaration Syntax
C# Visual Basic
protected virtual Encoding DeriveEncoding(
    Stream stream
)
Protected Overridable Function DeriveEncoding (
    stream As Stream
) As Encoding
Parameters
stream (Stream)
Return Value
Encoding

Send comments on this topic to support@keyoti.com


DeriveTitleFromDocument Method (documentBody)

DeriveTitleFromDocument Method (documentBody)
API Documentation ► Keyoti.SearchEngine.Documents ► HtmlDocumentParser ► DeriveTitleFromDocument(String)
Keyoti SearchUnit v6
Attempts to returns the title of the document, based on the documentBody
Declaration Syntax
C# Visual Basic
protected virtual string DeriveTitleFromDocument(
    string documentBody
)
Protected Overridable Function DeriveTitleFromDocument (
    documentBody As String
) As String
Parameters
documentBody (String)
The raw text of the document
Return Value
String
Null if a title couldn't be found, otherwise the title that should be used.


FindIgnoreRegions Method (documentBody)

FindIgnoreRegions Method (documentBody)
API Documentation ► Keyoti.SearchEngine.Documents ► HtmlDocumentParser ► FindIgnoreRegions(String)
Keyoti SearchUnit v6
Finds all ignore regions in documentBody.
Declaration Syntax
C# Visual Basic
protected virtual ArrayList FindIgnoreRegions(
    string documentBody
)
Protected Overridable Function FindIgnoreRegions (
    documentBody As String
) As ArrayList
Parameters
documentBody (String)
The text that may have regions to ignore
Return Value
ArrayList
List of int[2] objects containing the start and end of each region to ignore.


GetNextWord Method (rawBody)

GetNextWord Method (rawBody)
API Documentation ► Keyoti.SearchEngine.Documents ► HtmlDocumentParser ► GetNextWord(String)
Keyoti SearchUnit v6
Returns the next 'word' in rawBody, is iterative, so subsequent calls move to consecutive words.
Declaration Syntax
C# Visual Basic
protected override string GetNextWord(
    string rawBody
)
Protected Overrides Function GetNextWord (
    rawBody As String
) As String
Parameters
rawBody (String)
The text to pull words from.
Return Value
String
String, the next word.
Remarks
Also returns whitespace between words and null when the end of the text is reached.


IsCurrentWordInTitle Method

IsCurrentWordInTitle Method
API Documentation ► Keyoti.SearchEngine.Documents ► HtmlDocumentParser ► IsCurrentWordInTitle()()()()
Keyoti SearchUnit v6
Whether word last returned by GetNextWord is in title.
Declaration Syntax
C# Visual Basic
protected override bool IsCurrentWordInTitle()
Protected Overrides Function IsCurrentWordInTitle As Boolean
Return Value
Boolean

Send comments on this topic to support@keyoti.com


Read Method (stream, uri, encoding)

Read Method (stream, uri, encoding)
API Documentation ► Keyoti.SearchEngine.Documents ► HtmlDocumentParser ► Read(Stream, Uri, Encoding)
Keyoti SearchUnit v6
Reads a document and returns an object holding it's text and any links.
Declaration Syntax
C# Visual Basic
public override DocumentText Read(
    Stream stream,
    Uri uri,
    Encoding encoding
)
Public Overrides Function Read (
    stream As Stream,
    uri As Uri,
    encoding As Encoding
) As DocumentText
Parameters
stream (Stream)
The document stream to read from.
uri (Uri)
The document URI, used only for weighting words found in the document.
encoding (Encoding)
The document encoding if applicable/available.
Return Value
DocumentText
The DocumentText for the document.


ReadDocumentContent Method (stream, encoding)

ReadDocumentContent Method (stream, encoding)
API Documentation ► Keyoti.SearchEngine.Documents ► HtmlDocumentParser ► ReadDocumentContent(Stream, Encoding)
Keyoti SearchUnit v6
Returns string read from 'stream'.
Declaration Syntax
C# Visual Basic
protected virtual string ReadDocumentContent(
    Stream stream,
    Encoding encoding
)
Protected Overridable Function ReadDocumentContent (
    stream As Stream,
    encoding As Encoding
) As String
Parameters
stream (Stream)
encoding (Encoding)
Return Value
String

Send comments on this topic to support@keyoti.com


ReadMetaTable Method (documentBody)

ReadMetaTable Method (documentBody)
API Documentation ► Keyoti.SearchEngine.Documents ► HtmlDocumentParser ► ReadMetaTable(String)
Keyoti SearchUnit v6
Reads the meta tags for a document.
Declaration Syntax
C# Visual Basic
protected virtual void ReadMetaTable(
    string documentBody
)
Protected Overridable Sub ReadMetaTable (
    documentBody As String
)
Parameters
documentBody (String)


HtmlStringParser Class

HtmlStringParser Class
API Documentation ► Keyoti.SearchEngine.Documents ► HtmlStringParser
Keyoti SearchUnit v6
Converts HTML to plain text
Declaration Syntax
C# Visual Basic
public class HtmlStringParser
Public Class HtmlStringParser
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HtmlStringParser(String, ArrayList, Configuration) | New instance of HTML string parser.
 | BoostPoints | Points in the extracted text where weight boosting is changed (by tags).
 | Equals(Object) | (Inherited from Object.)
 | Extract()()()() | Gets the plain text from a HTML document.
 | Finalize()()()() | (Inherited from Object.)
 | FoundTitleEnd | Position where title ends.
 | FoundTitleStart | Position where title starts.
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SetBody(String) | Sets the html body to work with.
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
HtmlStringParser

Send comments on this topic to support@keyoti.com


HtmlStringParser Constructor (rawBody, ignoreRegions, config)

HtmlStringParser Constructor (rawBody, ignoreRegions, config)
API Documentation ► Keyoti.SearchEngine.Documents ► HtmlStringParser ► HtmlStringParser(String, ArrayList, Configuration)
Keyoti SearchUnit v6
New instance of HTML string parser.
Declaration Syntax
C# Visual Basic
public HtmlStringParser(
    string rawBody,
    ArrayList ignoreRegions,
    Configuration config
)
Public Sub New (
    rawBody As String,
    ignoreRegions As ArrayList,
    config As Configuration
)
Parameters
rawBody (String)
ignoreRegions (ArrayList)
config (Configuration)


BoostPoints Property

BoostPoints Property
API Documentation ► Keyoti.SearchEngine.Documents ► HtmlStringParser ► BoostPoints
Keyoti SearchUnit v6
Points in the extracted text where weight boosting is changed (by tags).
Declaration Syntax
C# Visual Basic
public ArrayList BoostPoints { get; }
Public ReadOnly Property BoostPoints As ArrayList
    Get
Property Value
ArrayList

Send comments on this topic to support@keyoti.com


Extract Method

Extract Method
API Documentation ► Keyoti.SearchEngine.Documents ► HtmlStringParser ► Extract()()()()
Keyoti SearchUnit v6
Gets the plain text from a HTML document.
Declaration Syntax
C# Visual Basic
public string Extract()
Public Function Extract As String
Return Value
String

Send comments on this topic to support@keyoti.com


FoundTitleEnd Property

FoundTitleEnd Property
API Documentation ► Keyoti.SearchEngine.Documents ► HtmlStringParser ► FoundTitleEnd
Keyoti SearchUnit v6
Position where title ends.
Declaration Syntax
C# Visual Basic
public int FoundTitleEnd { get; }
Public ReadOnly Property FoundTitleEnd As Integer
    Get
Property Value
Int32

Send comments on this topic to support@keyoti.com


FoundTitleStart Property

FoundTitleStart Property
API Documentation ► Keyoti.SearchEngine.Documents ► HtmlStringParser ► FoundTitleStart
Keyoti SearchUnit v6
Position where title starts.
Declaration Syntax
C# Visual Basic
public int FoundTitleStart { get; }
Public ReadOnly Property FoundTitleStart As Integer
    Get
Property Value
Int32

Send comments on this topic to support@keyoti.com


SetBody Method (rawBody)

SetBody Method (rawBody)
API Documentation ► Keyoti.SearchEngine.Documents ► HtmlStringParser ► SetBody(String)
Keyoti SearchUnit v6
Sets the html body to work with.
Declaration Syntax
C# Visual Basic
public void SetBody(
    string rawBody
)
Public Sub SetBody (
    rawBody As String
)
Parameters
rawBody (String)


LastModifiedDateNotAvailableException Class

LastModifiedDateNotAvailableException Class
API Documentation ► Keyoti.SearchEngine.Documents ► LastModifiedDateNotAvailableException
Keyoti SearchUnit v6
Signifies that a Last-Modified HTTP header wasn't provided in the HTTP response.
Declaration Syntax
C# Visual Basic
public class LastModifiedDateNotAvailableException : Exception
Public Class LastModifiedDateNotAvailableException
    Inherits Exception
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LastModifiedDateNotAvailableException()()()() |
 | Data | (Inherited from Exception.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetBaseException()()()() | (Inherited from Exception.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | (Inherited from Exception.)
 | GetType()()()() | (Inherited from Exception.)
 | HelpLink | (Inherited from Exception.)
 | HResult | (Inherited from Exception.)
 | InnerException | (Inherited from Exception.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from Exception.)
 | Source | (Inherited from Exception.)
 | StackTrace | (Inherited from Exception.)
 | TargetSite | (Inherited from Exception.)
 | ToString()()()() | (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | LastModifiedDateNotAvailableException


LastModifiedDateNotAvailableException Constructor

LastModifiedDateNotAvailableException Constructor
API Documentation ► Keyoti.SearchEngine.Documents ► LastModifiedDateNotAvailableException ► LastModifiedDateNotAvailableException()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public LastModifiedDateNotAvailableException()
Public Sub New

Send comments on this topic to support@keyoti.com


OdsDocumentParser Class

OdsDocumentParser Class
API Documentation ► Keyoti.SearchEngine.Documents ► OdsDocumentParser
Keyoti SearchUnit v6
Parses Open Document Format (ODF) spreadsheet files (.ods).
Declaration Syntax
C# Visual Basic
public class OdsDocumentParser : XmlDocumentParser
Public Class OdsDocumentParser
    Inherits XmlDocumentParser
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OdsDocumentParser(Configuration) | New collection
 | Configuration | Gets the instance of the Configuration class that holds the settings to be used. (Inherited from Parser.)
 | CopyStream(Stream) | (Inherited from Parser.)
 | Encoding | The character encoding used in the document Stream, if applicable. (Inherited from Parser.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetFilenameFooter(Uri) | Creates a footer with filename info from the Uri (Inherited from Parser.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetNextWord(String) | Returns the next 'word' in rawBody, is iterative, so subsequent calls move to consecutive words. (Inherited from Parser.)
 | GetType()()()() | (Inherited from Object.)
 | GetWordsInUri(Uri) | Returns list of words as strings in an ArrayList, that are in the Uri (Inherited from Parser.)
 | IsCurrentWordInTitle()()()() | Returns whether the word last returned by GetNextWord is part of the title. (Inherited from Parser.)
 | IsInIgnoredRegion(ArrayList) | Determines whether current word (at wordStart) is in an ignored region. (Inherited from Parser.)
 | IsStreamNeeded()()()() | Obsolete. Whether the parser would need a stream to be passed to it in order to perform a ReadText or ReadLinks operation. (Inherited from Parser.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ParseWords(String, ArrayList, WordCollection, StringBuilder, ArrayList) | Parses rawBody into descrete Word objects and places them in readDocumentWords. (Inherited from Parser.)
 | PreprocessBreakChunk(String) | Applies any required processing to a chunk of text that typically forms either a word or whitespace block. (Inherited from Parser.)
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean) | Processes the list of all words found in the document and returns a list that should be index. (Inherited from Parser.)
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean, ArrayList) | Processes the list of all words found in the document and returns a list that should be index. (Inherited from Parser.)
 | Read(Stream, Uri, Encoding) | Reads a document and returns an object holding it's text and any links. (Overrides XmlDocumentParser.Read(Stream, Uri, Encoding).)
 | Read(String, Uri, Encoding) | Read the document (Inherited from TxtDocumentParser.)
 | ReadLinks(Stream, Encoding) | Obsolete. Reads links to other pages. (Inherited from Parser.)
 | ReadText(Stream, Uri, Encoding) | Obsolete. Reads text and returns list of words and title (Inherited from Parser.)
 | ResetWordPointers()()()() | Resets the current word being processed. (Inherited from Parser.)
 | ToString()()()() | (Inherited from Object.)
 | TruncateWordWithRepeatedChar(String) | Removes repeated non-letters from word. (Inherited from Parser.)
 | WordEnd | The current word's end. (Inherited from Parser.)
 | WordStart | The current word's start. (Inherited from Parser.)
Inheritance Hierarchy
Object
 | Parser
 |  | TxtDocumentParser
 |  |  | XmlDocumentParser
 |  |  |  | OdsDocumentParser


OdsDocumentParser Constructor (c)

OdsDocumentParser Constructor (c)
API Documentation ► Keyoti.SearchEngine.Documents ► OdsDocumentParser ► OdsDocumentParser(Configuration)
Keyoti SearchUnit v6
New collection
Declaration Syntax
C# Visual Basic
public OdsDocumentParser(
    Configuration c
)
Public Sub New (
    c As Configuration
)
Parameters
c (Configuration)


Read Method (stream, uri, encoding)

Read Method (stream, uri, encoding)
API Documentation ► Keyoti.SearchEngine.Documents ► OdsDocumentParser ► Read(Stream, Uri, Encoding)
Keyoti SearchUnit v6
Reads a document and returns an object holding it's text and any links.
Declaration Syntax
C# Visual Basic
public override DocumentText Read(
    Stream stream,
    Uri uri,
    Encoding encoding
)
Public Overrides Function Read (
    stream As Stream,
    uri As Uri,
    encoding As Encoding
) As DocumentText
Parameters
stream (Stream)
The document stream to read from.
uri (Uri)
The document URI, used only for weighting words found in the document.
encoding (Encoding)
The document encoding if applicable/available.
Return Value
DocumentText
The DocumentText for the document.


OdtDocumentParser Class

OdtDocumentParser Class
API Documentation ► Keyoti.SearchEngine.Documents ► OdtDocumentParser
Keyoti SearchUnit v6
Parses Open Document Format (ODF) word processor files (.odt).
Declaration Syntax
C# Visual Basic
public class OdtDocumentParser : XmlDocumentParser
Public Class OdtDocumentParser
    Inherits XmlDocumentParser
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OdtDocumentParser(Configuration) | New collection
 | Configuration | Gets the instance of the Configuration class that holds the settings to be used. (Inherited from Parser.)
 | CopyStream(Stream) | (Inherited from Parser.)
 | Encoding | The character encoding used in the document Stream, if applicable. (Inherited from Parser.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetFilenameFooter(Uri) | Creates a footer with filename info from the Uri (Inherited from Parser.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetNextWord(String) | Returns the next 'word' in rawBody, is iterative, so subsequent calls move to consecutive words. (Inherited from Parser.)
 | GetType()()()() | (Inherited from Object.)
 | GetWordsInUri(Uri) | Returns list of words as strings in an ArrayList, that are in the Uri (Inherited from Parser.)
 | IsCurrentWordInTitle()()()() | Returns whether the word last returned by GetNextWord is part of the title. (Inherited from Parser.)
 | IsInIgnoredRegion(ArrayList) | Determines whether current word (at wordStart) is in an ignored region. (Inherited from Parser.)
 | IsStreamNeeded()()()() | Obsolete. Whether the parser would need a stream to be passed to it in order to perform a ReadText or ReadLinks operation. (Inherited from Parser.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ParseWords(String, ArrayList, WordCollection, StringBuilder, ArrayList) | Parses rawBody into descrete Word objects and places them in readDocumentWords. (Inherited from Parser.)
 | PreprocessBreakChunk(String) | Applies any required processing to a chunk of text that typically forms either a word or whitespace block. (Inherited from Parser.)
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean) | Processes the list of all words found in the document and returns a list that should be index. (Inherited from Parser.)
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean, ArrayList) | Processes the list of all words found in the document and returns a list that should be index. (Inherited from Parser.)
 | Read(Stream, Uri, Encoding) | Reads a document and returns an object holding it's text and any links. (Overrides XmlDocumentParser.Read(Stream, Uri, Encoding).)
 | Read(String, Uri, Encoding) | Read the document (Inherited from TxtDocumentParser.)
 | ReadLinks(Stream, Encoding) | Obsolete. Reads links to other pages. (Inherited from Parser.)
 | ReadText(Stream, Uri, Encoding) | Obsolete. Reads text and returns list of words and title (Inherited from Parser.)
 | ResetWordPointers()()()() | Resets the current word being processed. (Inherited from Parser.)
 | ToString()()()() | (Inherited from Object.)
 | TruncateWordWithRepeatedChar(String) | Removes repeated non-letters from word. (Inherited from Parser.)
 | WordEnd | The current word's end. (Inherited from Parser.)
 | WordStart | The current word's start. (Inherited from Parser.)
Inheritance Hierarchy
Object
 | Parser
 |  | TxtDocumentParser
 |  |  | XmlDocumentParser
 |  |  |  | OdtDocumentParser


OdtDocumentParser Constructor (c)

OdtDocumentParser Constructor (c)
API Documentation ► Keyoti.SearchEngine.Documents ► OdtDocumentParser ► OdtDocumentParser(Configuration)
Keyoti SearchUnit v6
New collection
Declaration Syntax
C# Visual Basic
public OdtDocumentParser(
    Configuration c
)
Public Sub New (
    c As Configuration
)
Parameters
c (Configuration)


Read Method (stream, uri, encoding)

Read Method (stream, uri, encoding)
API Documentation ► Keyoti.SearchEngine.Documents ► OdtDocumentParser ► Read(Stream, Uri, Encoding)
Keyoti SearchUnit v6
Reads a document and returns an object holding it's text and any links.
Declaration Syntax
C# Visual Basic
public override DocumentText Read(
    Stream stream,
    Uri uri,
    Encoding encoding
)
Public Overrides Function Read (
    stream As Stream,
    uri As Uri,
    encoding As Encoding
) As DocumentText
Parameters
stream (Stream)
The document stream to read from.
uri (Uri)
The document URI, used only for weighting words found in the document.
encoding (Encoding)
The document encoding if applicable/available.
Return Value
DocumentText
The DocumentText for the document.


Parser Class

Parser Class
API Documentation ► Keyoti.SearchEngine.Documents ► Parser
Keyoti SearchUnit v6
Abstract base class for document parsers.
Declaration Syntax
C# Visual Basic
public abstract class Parser
Public MustInherit Class Parser
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Parser(Configuration) |
 | Configuration | Gets the instance of the Configuration class that holds the settings to be used.
 | CopyStream(Stream) |
 | Encoding | The character encoding used in the document Stream, if applicable.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetFilenameFooter(Uri) | Creates a footer with filename info from the Uri
 | GetHashCode()()()() | (Inherited from Object.)
 | GetNextWord(String) | Returns the next 'word' in rawBody, is iterative, so subsequent calls move to consecutive words.
 | GetType()()()() | (Inherited from Object.)
 | GetWordsInUri(Uri) | Returns list of words as strings in an ArrayList, that are in the Uri
 | IsCurrentWordInTitle()()()() | Returns whether the word last returned by GetNextWord is part of the title.
 | IsInIgnoredRegion(ArrayList) | Determines whether current word (at wordStart) is in an ignored region.
 | IsStreamNeeded()()()() | Obsolete. Whether the parser would need a stream to be passed to it in order to perform a ReadText or ReadLinks operation.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ParseWords(String, ArrayList, WordCollection, StringBuilder, ArrayList) | Parses rawBody into descrete Word objects and places them in readDocumentWords.
 | PreprocessBreakChunk(String) | Applies any required processing to a chunk of text that typically forms either a word or whitespace block.
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean) | Processes the list of all words found in the document and returns a list that should be index.
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean, ArrayList) | Processes the list of all words found in the document and returns a list that should be index.
 | Read(Stream, Uri, Encoding) | Reads a document and returns an object holding it's text and any links.
 | ReadLinks(Stream, Encoding) | Obsolete. Reads links to other pages.
 | ReadText(Stream, Uri, Encoding) | Obsolete. Reads text and returns list of words and title
 | ResetWordPointers()()()() | Resets the current word being processed.
 | ToString()()()() | (Inherited from Object.)
 | TruncateWordWithRepeatedChar(String) | Removes repeated non-letters from word.
 | WordEnd | The current word's end.
 | WordStart | The current word's start.
Inheritance Hierarchy
Object
 | Parser
 |  | HtmlDocumentParser
 |  | PdfDocumentParser
 |  | RtfDocumentParser
 |  | TxtDocumentParser
 |  | Word2002Parser
 |  | WordDocumentParser
 |  | ZipFileParser


Parser Constructor (configuration)

Parser Constructor (configuration)
API Documentation ► Keyoti.SearchEngine.Documents ► Parser ► Parser(Configuration)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
protected Parser(
    Configuration configuration
)
Protected Sub New (
    configuration As Configuration
)
Parameters
configuration (Configuration)


Configuration Property

Configuration Property
API Documentation ► Keyoti.SearchEngine.Documents ► Parser ► Configuration
Keyoti SearchUnit v6
Gets the instance of the Configuration class that holds the settings to be used.
Declaration Syntax
C# Visual Basic
protected Configuration Configuration { get; }
Protected ReadOnly Property Configuration As Configuration
    Get
Property Value
Configuration

Send comments on this topic to support@keyoti.com


CopyStream Method (stream)

CopyStream Method (stream)
API Documentation ► Keyoti.SearchEngine.Documents ► Parser ► CopyStream(Stream)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
protected MemoryStream CopyStream(
    Stream stream
)
Protected Function CopyStream (
    stream As Stream
) As MemoryStream
Parameters
stream (Stream)
Return Value
MemoryStream

Send comments on this topic to support@keyoti.com


Encoding Property

Encoding Property
API Documentation ► Keyoti.SearchEngine.Documents ► Parser ► Encoding
Keyoti SearchUnit v6
The character encoding used in the document Stream, if applicable.
Declaration Syntax
C# Visual Basic
protected Encoding Encoding { get; set; }
Protected Property Encoding As Encoding
    Get
    Set
Property Value
Encoding

Send comments on this topic to support@keyoti.com


GetFilenameFooter Method (uri)

GetFilenameFooter Method (uri)
API Documentation ► Keyoti.SearchEngine.Documents ► Parser ► GetFilenameFooter(Uri)
Keyoti SearchUnit v6
Creates a footer with filename info from the Uri
Declaration Syntax
C# Visual Basic
protected virtual string GetFilenameFooter(
    Uri uri
)
Protected Overridable Function GetFilenameFooter (
    uri As Uri
) As String
Parameters
uri (Uri)
Return Value
String

Send comments on this topic to support@keyoti.com


GetNextWord Method (rawBody)

GetNextWord Method (rawBody)
API Documentation ► Keyoti.SearchEngine.Documents ► Parser ► GetNextWord(String)
Keyoti SearchUnit v6
Returns the next 'word' in rawBody, is iterative, so subsequent calls move to consecutive words.
Declaration Syntax
C# Visual Basic
protected virtual string GetNextWord(
    string rawBody
)
Protected Overridable Function GetNextWord (
    rawBody As String
) As String
Parameters
rawBody (String)
The text to pull words from.
Return Value
String
Remarks
Also returns whitespace between words and null when the end of the text is reached.


GetWordsInUri Method (uriToInspect)

GetWordsInUri Method (uriToInspect)
API Documentation ► Keyoti.SearchEngine.Documents ► Parser ► GetWordsInUri(Uri)
Keyoti SearchUnit v6
Returns list of words as strings in an ArrayList, that are in the Uri
Declaration Syntax
C# Visual Basic
protected virtual ArrayList GetWordsInUri(
    Uri uriToInspect
)
Protected Overridable Function GetWordsInUri (
    uriToInspect As Uri
) As ArrayList
Parameters
uriToInspect (Uri)
Return Value
ArrayList

Send comments on this topic to support@keyoti.com


IsCurrentWordInTitle Method

IsCurrentWordInTitle Method
API Documentation ► Keyoti.SearchEngine.Documents ► Parser ► IsCurrentWordInTitle()()()()
Keyoti SearchUnit v6
Returns whether the word last returned by GetNextWord is part of the title.
Declaration Syntax
C# Visual Basic
protected virtual bool IsCurrentWordInTitle()
Protected Overridable Function IsCurrentWordInTitle As Boolean
Return Value
Boolean
True if the word is part of the title

Send comments on this topic to support@keyoti.com


IsInIgnoredRegion Method (allIgnoreRegions)

IsInIgnoredRegion Method (allIgnoreRegions)
API Documentation ► Keyoti.SearchEngine.Documents ► Parser ► IsInIgnoredRegion(ArrayList)
Keyoti SearchUnit v6
Determines whether current word (at wordStart) is in an ignored region.
Declaration Syntax
C# Visual Basic
protected bool IsInIgnoredRegion(
    ArrayList allIgnoreRegions
)
Protected Function IsInIgnoredRegion (
    allIgnoreRegions As ArrayList
) As Boolean
Parameters
allIgnoreRegions (ArrayList)
Collection of 2 dim int arrays indicating the start and end of ignore regions
Return Value
Boolean
True if is in ignore region.


IsStreamNeeded Method

IsStreamNeeded Method
API Documentation ► Keyoti.SearchEngine.Documents ► Parser ► IsStreamNeeded()()()()
Keyoti SearchUnit v6
Whether the parser would need a stream to be passed to it in order to perform a ReadText or ReadLinks operation.
Declaration Syntax
C# Visual Basic
[ObsoleteAttribute("Unnecessary due to refactored Read method.", true)]
public virtual bool IsStreamNeeded()
<ObsoleteAttribute("Unnecessary due to refactored Read method.", true)>
Public Overridable Function IsStreamNeeded As Boolean
Return Value
Boolean

Send comments on this topic to support@keyoti.com


ParseWords Method (rawBody, allIgnoreRegions, readDocumentWords, description, wordsInUri)

ParseWords Method (rawBody, allIgnoreRegions, readDocumentWords, description, wordsInUri)
API Documentation ► Keyoti.SearchEngine.Documents ► Parser ► ParseWords(String, ArrayList, WordCollection, StringBuilder, ArrayList)
Keyoti SearchUnit v6
Parses rawBody into descrete Word objects and places them in readDocumentWords.
Declaration Syntax
C# Visual Basic
public virtual void ParseWords(
    string rawBody,
    ArrayList allIgnoreRegions,
    WordCollection readDocumentWords,
    StringBuilder description,
    ArrayList wordsInUri
)
Public Overridable Sub ParseWords (
    rawBody As String,
    allIgnoreRegions As ArrayList,
    readDocumentWords As WordCollection,
    description As StringBuilder,
    wordsInUri As ArrayList
)
Parameters
rawBody (String)
The text to parse
allIgnoreRegions (ArrayList)
List of int[2] instances containing start and end of ignore regions (if no ignore regions, just pass empty ArrayList)
readDocumentWords (WordCollection)
List that this method will add Word objects to
description (StringBuilder)
StringBuilder that this method will append the start of the document to (if not required just pass blank instance of StringBuilder).
wordsInUri (ArrayList)
List of words from the Uri text (this affects weighting, if not available just pass empty ArrayList).


PreprocessBreakChunk Method (chunk)

PreprocessBreakChunk Method (chunk)
API Documentation ► Keyoti.SearchEngine.Documents ► Parser ► PreprocessBreakChunk(String)
Keyoti SearchUnit v6
Applies any required processing to a chunk of text that typically forms either a word or whitespace block.
Declaration Syntax
C# Visual Basic
protected virtual string PreprocessBreakChunk(
    string chunk
)
Protected Overridable Function PreprocessBreakChunk (
    chunk As String
) As String
Parameters
chunk (String)
The chunk
Return Value
String
The chunk after processing

Send comments on this topic to support@keyoti.com


ProcessWordsToFinalIndexedList Method

ProcessWordsToFinalIndexedList Method
API Documentation ► Keyoti.SearchEngine.Documents ► Parser ► ProcessWordsToFinalIndexedList()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean) | Processes the list of all words found in the document and returns a list that should be index.
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean, ArrayList) | Processes the list of all words found in the document and returns a list that should be index.


ProcessWordsToFinalIndexedList Method (wordsIncludingDuplicates, phraseMatching)

ProcessWordsToFinalIndexedList Method (wordsIncludingDuplicates, phraseMatching)
API Documentation ► Keyoti.SearchEngine.Documents ► Parser ► ProcessWordsToFinalIndexedList(WordCollection, Boolean)
Keyoti SearchUnit v6
Processes the list of all words found in the document and returns a list that should be index.
Declaration Syntax
C# Visual Basic
public WordCollection ProcessWordsToFinalIndexedList(
    WordCollection wordsIncludingDuplicates,
    bool phraseMatching
)
Public Function ProcessWordsToFinalIndexedList (
    wordsIncludingDuplicates As WordCollection,
    phraseMatching As Boolean
) As WordCollection
Parameters
wordsIncludingDuplicates (WordCollection)
The list of words in the document
phraseMatching (Boolean)
Whether we're indexing for phrase matching
Return Value
WordCollection
List of Word objects for indexing

Send comments on this topic to support@keyoti.com


ProcessWordsToFinalIndexedList Method (wordsIncludingDuplicates, phraseMatching, boostPoints)

ProcessWordsToFinalIndexedList Method (wordsIncludingDuplicates, phraseMatching, boostPoints)
API Documentation ► Keyoti.SearchEngine.Documents ► Parser ► ProcessWordsToFinalIndexedList(WordCollection, Boolean, ArrayList)
Keyoti SearchUnit v6
Processes the list of all words found in the document and returns a list that should be index.
Declaration Syntax
C# Visual Basic
public virtual WordCollection ProcessWordsToFinalIndexedList(
    WordCollection wordsIncludingDuplicates,
    bool phraseMatching,
    ArrayList boostPoints
)
Public Overridable Function ProcessWordsToFinalIndexedList (
    wordsIncludingDuplicates As WordCollection,
    phraseMatching As Boolean,
    boostPoints As ArrayList
) As WordCollection
Parameters
wordsIncludingDuplicates (WordCollection)
The list of words in the document
phraseMatching (Boolean)
Whether we're indexing for phrase matching
boostPoints (ArrayList)
List of BoostPoint objects indicated where weighting is changed by document tags.
Return Value
WordCollection
List of Word objects for indexing

Send comments on this topic to support@keyoti.com


Read Method (stream, uri, encoding)

Read Method (stream, uri, encoding)
API Documentation ► Keyoti.SearchEngine.Documents ► Parser ► Read(Stream, Uri, Encoding)
Keyoti SearchUnit v6
Reads a document and returns an object holding it's text and any links.
Declaration Syntax
C# Visual Basic
public abstract DocumentText Read(
    Stream stream,
    Uri uri,
    Encoding encoding
)
Public MustOverride Function Read (
    stream As Stream,
    uri As Uri,
    encoding As Encoding
) As DocumentText
Parameters
stream (Stream)
The document stream to read from.
uri (Uri)
The document URI, used only for weighting words found in the document.
encoding (Encoding)
The document encoding if applicable/available.
Return Value
DocumentText
The DocumentText for the document.


ReadLinks Method (stream, encoding)

ReadLinks Method (stream, encoding)
API Documentation ► Keyoti.SearchEngine.Documents ► Parser ► ReadLinks(Stream, Encoding)
Keyoti SearchUnit v6
Reads links to other pages.
Declaration Syntax
C# Visual Basic
[ObsoleteAttribute("Use Read method instead.", true)]
public ArrayList ReadLinks(
    Stream stream,
    Encoding encoding
)
<ObsoleteAttribute("Use Read method instead.", true)>
Public Function ReadLinks (
    stream As Stream,
    encoding As Encoding
) As ArrayList
Parameters
stream (Stream)
Document as a stream
encoding (Encoding)
The character encoding used in the stream, typically this is obtained from the ContentType header from the server.
Return Value
ArrayList
List of strings with link Uris (note these maybe relative to current page).


ReadText Method (stream, uri, encoding)

ReadText Method (stream, uri, encoding)
API Documentation ► Keyoti.SearchEngine.Documents ► Parser ► ReadText(Stream, Uri, Encoding)
Keyoti SearchUnit v6
Reads text and returns list of words and title
Declaration Syntax
C# Visual Basic
[ObsoleteAttribute("Use Read method instead.", true)]
public Object[] ReadText(
    Stream stream,
    Uri uri,
    Encoding encoding
)
<ObsoleteAttribute("Use Read method instead.", true)>
Public Function ReadText (
    stream As Stream,
    uri As Uri,
    encoding As Encoding
) As Object()
Parameters
stream (Stream)
Stream Object
uri (Uri)
Uri object
encoding (Encoding)
Encoding object
Return Value
array< Object >[]()[][]
Remarks
Eg. A document contains 4 words; "this", "is", "this", "example". The document's title is; "example" The document's URL is; http://localhost/example.html If phrase matching is enabled, returns the following data:
Copy image Copy
wordsList[0] = "this", inUri=0, inTitle=0, inBody=1
wordsList[1] = "is",   inUri=0, inTitle=0, inBody=1
wordsList[2] = "this", inUri=0, inTitle=0, inBody=1
wordsList[3] = "example", inUri=1, inTitle=1, inBody=1
If phrase matching is disabled, returns the following data:
Copy image Copy
wordsList[0] = "this", inUri=0, inTitle=0, inBody=2
wordsList[1] = "is",   inUri=0, inTitle=0, inBody=1
wordsList[2] = "example", inUri=1, inTitle=1, inBody=1


ResetWordPointers Method

ResetWordPointers Method
API Documentation ► Keyoti.SearchEngine.Documents ► Parser ► ResetWordPointers()()()()
Keyoti SearchUnit v6
Resets the current word being processed.
Declaration Syntax
C# Visual Basic
protected void ResetWordPointers()
Protected Sub ResetWordPointers

Send comments on this topic to support@keyoti.com


TruncateWordWithRepeatedChar Method (word)

TruncateWordWithRepeatedChar Method (word)
API Documentation ► Keyoti.SearchEngine.Documents ► Parser ► TruncateWordWithRepeatedChar(String)
Keyoti SearchUnit v6
Removes repeated non-letters from word.
Declaration Syntax
C# Visual Basic
protected virtual string TruncateWordWithRepeatedChar(
    string word
)
Protected Overridable Function TruncateWordWithRepeatedChar (
    word As String
) As String
Parameters
word (String)
Return Value
String
word without repeated whitespace
Remarks
This is required because although whitespace must be indexed, long repeated chunks are not useful.


WordEnd Property

WordEnd Property
API Documentation ► Keyoti.SearchEngine.Documents ► Parser ► WordEnd
Keyoti SearchUnit v6
The current word's end.
Declaration Syntax
C# Visual Basic
protected int WordEnd { get; }
Protected ReadOnly Property WordEnd As Integer
    Get
Property Value
Int32

Send comments on this topic to support@keyoti.com


WordStart Property

WordStart Property
API Documentation ► Keyoti.SearchEngine.Documents ► Parser ► WordStart
Keyoti SearchUnit v6
The current word's start.
Declaration Syntax
C# Visual Basic
protected int WordStart { get; }
Protected ReadOnly Property WordStart As Integer
    Get
Property Value
Int32

Send comments on this topic to support@keyoti.com


Parser.BoostPoint Structure

Parser..::..BoostPoint Structure
API Documentation ► Keyoti.SearchEngine.Documents ► Parser ► Parser..::..BoostPoint
Keyoti SearchUnit v6
A point in the plain text where weighting is affected.
Declaration Syntax
C# Visual Basic
public struct BoostPoint
Public Structure BoostPoint
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Parser..::..BoostPoint(Int32, Single) | New
 | boostFactor | Weighting factor (1 to reset to normal)
 | boostStart | Start
 | Equals(Object) | (Inherited from ValueType.)
 | GetHashCode()()()() | (Inherited from ValueType.)
 | GetType()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from ValueType.)


Parser.BoostPoint Constructor (start, factor)

Parser..::..BoostPoint Constructor (start, factor)
API Documentation ► Keyoti.SearchEngine.Documents ► Parser..::..BoostPoint ► Parser..::..BoostPoint(Int32, Single)
Keyoti SearchUnit v6
New
Declaration Syntax
C# Visual Basic
public BoostPoint(
    int start,
    float factor
)
Public Sub New (
    start As Integer,
    factor As Single
)
Parameters
start (Int32)
factor (Single)


boostFactor Field

boostFactor Field
API Documentation ► Keyoti.SearchEngine.Documents ► Parser..::..BoostPoint ► boostFactor
Keyoti SearchUnit v6
Weighting factor (1 to reset to normal)
Declaration Syntax
C# Visual Basic
public float boostFactor
Public boostFactor As Single
Field Value
Single

Send comments on this topic to support@keyoti.com


boostStart Field

boostStart Field
API Documentation ► Keyoti.SearchEngine.Documents ► Parser..::..BoostPoint ► boostStart
Keyoti SearchUnit v6
Start
Declaration Syntax
C# Visual Basic
public int boostStart
Public boostStart As Integer
Field Value
Int32

Send comments on this topic to support@keyoti.com


ParserProvider Class

ParserProvider Class
API Documentation ► Keyoti.SearchEngine.Documents ► ParserProvider
Keyoti SearchUnit v6
Provides a parser for different document types.
Declaration Syntax
C# Visual Basic
public class ParserProvider
Public Class ParserProvider
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ParserProvider(Configuration) | Creates an instance of the ParserProvider class.
 | Configuration | Gets the instance of the Configuration class that holds the settings to be used.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetParser(String) | Gets a new parser object for the specified mimeType.
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
GetParser is used to return a Parser subclass for the specified mimeType. The mimeType is initially identified for a document based on the Response.ContentType returned from the server or from Configuration.fileTypesSettings for documents read using the file-system. Subclassing this class is necessary when adding new document parsers to the build system.
Examples
Suppose a new parser is written for your organizations XML files - called XMLDocumentParser. Of course this parser must now be used for these files, to do this ParserProvider is subclassed - called CustomParserProvider. To make the Document class use the new CustomParserProvider one way would be to subclass DocumentIndex and override CreateNewDocument method to return a new Document object with a preset ParserProvider property. This causes CustomParserProvider to be instantiated and passed to each Document object as it is indexed. In CustomParserProvider the GetParser is overridden to return the XMLDocumentParser for the XML mime type.
Inheritance Hierarchy
Object
ParserProvider

Send comments on this topic to support@keyoti.com


ParserProvider Constructor (configuration)

ParserProvider Constructor (configuration)
API Documentation ► Keyoti.SearchEngine.Documents ► ParserProvider ► ParserProvider(Configuration)
Keyoti SearchUnit v6
Creates an instance of the ParserProvider class.
Declaration Syntax
C# Visual Basic
public ParserProvider(
    Configuration configuration
)
Public Sub New (
    configuration As Configuration
)
Parameters
configuration (Configuration)
The instance of the Configuration class that holds the settings to be used.


Configuration Property

Configuration Property
API Documentation ► Keyoti.SearchEngine.Documents ► ParserProvider ► Configuration
Keyoti SearchUnit v6
Gets the instance of the Configuration class that holds the settings to be used.
Declaration Syntax
C# Visual Basic
public Configuration Configuration { get; }
Public ReadOnly Property Configuration As Configuration
    Get
Property Value
Configuration

Send comments on this topic to support@keyoti.com


GetParser Method (mimeType)

GetParser Method (mimeType)
API Documentation ► Keyoti.SearchEngine.Documents ► ParserProvider ► GetParser(String)
Keyoti SearchUnit v6
Gets a new parser object for the specified mimeType.
Declaration Syntax
C# Visual Basic
public virtual Parser GetParser(
    string mimeType
)
Public Overridable Function GetParser (
    mimeType As String
) As Parser
Parameters
mimeType (String)
The mime-type for which the parser is required.
Return Value
Parser
Parser sub-class, or null if no suitable parser found.


PdfDocumentParser Class

PdfDocumentParser Class
API Documentation ► Keyoti.SearchEngine.Documents ► PdfDocumentParser
Keyoti SearchUnit v6
Pdf Parser
Declaration Syntax
C# Visual Basic
public class PdfDocumentParser : Parser
Public Class PdfDocumentParser
    Inherits Parser
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PdfDocumentParser(Configuration) | Creates an instance of the PdfDocumentParser class.
 | Configuration | Gets the instance of the Configuration class that holds the settings to be used. (Inherited from Parser.)
 | CopyStream(Stream) | (Inherited from Parser.)
 | Encoding | The character encoding used in the document Stream, if applicable. (Inherited from Parser.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetFilenameFooter(Uri) | Creates a footer with filename info from the Uri (Inherited from Parser.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetNextWord(String) | Returns the next 'word' in rawBody, is iterative, so subsequent calls move to consecutive words. (Inherited from Parser.)
 | GetTitle(String) | Reads the document title meta data from an ascii representation of the file
 | GetType()()()() | (Inherited from Object.)
 | GetWordsInUri(Uri) | Returns list of words as strings in an ArrayList, that are in the Uri (Inherited from Parser.)
 | IsCurrentWordInTitle()()()() | Returns whether the word last returned by GetNextWord is part of the title. (Inherited from Parser.)
 | IsInIgnoredRegion(ArrayList) | Determines whether current word (at wordStart) is in an ignored region. (Inherited from Parser.)
 | IsStreamNeeded()()()() | Obsolete. Whether the parser would need a stream to be passed to it in order to perform a ReadText or ReadLinks operation. (Inherited from Parser.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ParseWords(String, ArrayList, WordCollection, StringBuilder, ArrayList) | Parses rawBody into descrete Word objects and places them in readDocumentWords. (Inherited from Parser.)
 | PreprocessBreakChunk(String) | Applies any required processing to a chunk of text that typically forms either a word or whitespace block. (Inherited from Parser.)
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean) | Processes the list of all words found in the document and returns a list that should be index. (Inherited from Parser.)
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean, ArrayList) | Processes the list of all words found in the document and returns a list that should be index. (Inherited from Parser.)
 | Read(Stream, Uri, Encoding) | Reads a document and returns an object holding it's text and any links. (Overrides Parser.Read(Stream, Uri, Encoding).)
 | ReadLinks(Stream, Encoding) | Obsolete. Reads links to other pages. (Inherited from Parser.)
 | ReadText(Stream, Uri, Encoding) | Obsolete. Reads text and returns list of words and title (Inherited from Parser.)
 | ResetWordPointers()()()() | Resets the current word being processed. (Inherited from Parser.)
 | ToString()()()() | (Inherited from Object.)
 | TruncateWordWithRepeatedChar(String) | Removes repeated non-letters from word. (Inherited from Parser.)
 | WordEnd | The current word's end. (Inherited from Parser.)
 | WordStart | The current word's start. (Inherited from Parser.)
Inheritance Hierarchy
Object
 | Parser
 |  | PdfDocumentParser


PdfDocumentParser Constructor (configuration)

PdfDocumentParser Constructor (configuration)
API Documentation ► Keyoti.SearchEngine.Documents ► PdfDocumentParser ► PdfDocumentParser(Configuration)
Keyoti SearchUnit v6
Creates an instance of the PdfDocumentParser class.
Declaration Syntax
C# Visual Basic
public PdfDocumentParser(
    Configuration configuration
)
Public Sub New (
    configuration As Configuration
)
Parameters
configuration (Configuration)
The instance of the Configuration class that holds the settings to be used.


GetTitle Method (textFromPdf)

GetTitle Method (textFromPdf)
API Documentation ► Keyoti.SearchEngine.Documents ► PdfDocumentParser ► GetTitle(String)
Keyoti SearchUnit v6
Reads the document title meta data from an ascii representation of the file
Declaration Syntax
C# Visual Basic
protected virtual string GetTitle(
    string textFromPdf
)
Protected Overridable Function GetTitle (
    textFromPdf As String
) As String
Parameters
textFromPdf (String)
Return Value
String

Send comments on this topic to support@keyoti.com


Read Method (stream, uri, encoding)

Read Method (stream, uri, encoding)
API Documentation ► Keyoti.SearchEngine.Documents ► PdfDocumentParser ► Read(Stream, Uri, Encoding)
Keyoti SearchUnit v6
Reads a document and returns an object holding it's text and any links.
Declaration Syntax
C# Visual Basic
public override DocumentText Read(
    Stream stream,
    Uri uri,
    Encoding encoding
)
Public Overrides Function Read (
    stream As Stream,
    uri As Uri,
    encoding As Encoding
) As DocumentText
Parameters
stream (Stream)
The document stream to read from.
uri (Uri)
The document URI, used only for weighting words found in the document.
encoding (Encoding)
The document encoding if applicable/available.
Return Value
DocumentText
The DocumentText for the document.


PdfDocumentTitleSource Enumeration

PdfDocumentTitleSource Enumeration
API Documentation ► Keyoti.SearchEngine.Documents ► PdfDocumentTitleSource
Keyoti SearchUnit v6
Where the title of a Pdf document is obtained from.
Declaration Syntax
C# Visual Basic
public enum PdfDocumentTitleSource
Public Enumeration PdfDocumentTitleSource
Members
Member | Description
DocumentTitleField | The title assigned to the document by the writer (uses dc:title for source if available).
DocumentTitleFieldPreferNonDC | The title assigned to the document by the writer (uses older /Title tags instead of dc:title for source if available).
Filename | The filename of the PDF


PptxParser Class

PptxParser Class
API Documentation ► Keyoti.SearchEngine.Documents ► PptxParser
Keyoti SearchUnit v6
Parses PPTX (PowerPoint) files.
Declaration Syntax
C# Visual Basic
public class PptxParser : XmlDocumentParser
Public Class PptxParser
    Inherits XmlDocumentParser
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PptxParser(Configuration) | New instance
 | Configuration | Gets the instance of the Configuration class that holds the settings to be used. (Inherited from Parser.)
 | CopyStream(Stream) | (Inherited from Parser.)
 | Encoding | The character encoding used in the document Stream, if applicable. (Inherited from Parser.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetFilenameFooter(Uri) | Creates a footer with filename info from the Uri (Inherited from Parser.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetNextWord(String) | Returns the next 'word' in rawBody, is iterative, so subsequent calls move to consecutive words. (Inherited from Parser.)
 | GetType()()()() | (Inherited from Object.)
 | GetWordsInUri(Uri) | Returns list of words as strings in an ArrayList, that are in the Uri (Inherited from Parser.)
 | IsCurrentWordInTitle()()()() | Returns whether the word last returned by GetNextWord is part of the title. (Inherited from Parser.)
 | IsInIgnoredRegion(ArrayList) | Determines whether current word (at wordStart) is in an ignored region. (Inherited from Parser.)
 | IsStreamNeeded()()()() | Obsolete. Whether the parser would need a stream to be passed to it in order to perform a ReadText or ReadLinks operation. (Inherited from Parser.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ParseWords(String, ArrayList, WordCollection, StringBuilder, ArrayList) | Parses rawBody into descrete Word objects and places them in readDocumentWords. (Inherited from Parser.)
 | PreprocessBreakChunk(String) | Applies any required processing to a chunk of text that typically forms either a word or whitespace block. (Inherited from Parser.)
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean) | Processes the list of all words found in the document and returns a list that should be index. (Inherited from Parser.)
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean, ArrayList) | Processes the list of all words found in the document and returns a list that should be index. (Inherited from Parser.)
 | Read(Stream, Uri, Encoding) | Reads a document and returns an object holding it's text and any links. (Overrides XmlDocumentParser.Read(Stream, Uri, Encoding).)
 | Read(String, Uri, Encoding) | Read the document (Inherited from TxtDocumentParser.)
 | ReadLinks(Stream, Encoding) | Obsolete. Reads links to other pages. (Inherited from Parser.)
 | ReadText(Stream, Uri, Encoding) | Obsolete. Reads text and returns list of words and title (Inherited from Parser.)
 | ResetWordPointers()()()() | Resets the current word being processed. (Inherited from Parser.)
 | ToString()()()() | (Inherited from Object.)
 | TruncateWordWithRepeatedChar(String) | Removes repeated non-letters from word. (Inherited from Parser.)
 | WordEnd | The current word's end. (Inherited from Parser.)
 | WordStart | The current word's start. (Inherited from Parser.)
Inheritance Hierarchy
Object
 | Parser
 |  | TxtDocumentParser
 |  |  | XmlDocumentParser
 |  |  |  | PptxParser


PptxParser Constructor (configuration)

PptxParser Constructor (configuration)
API Documentation ► Keyoti.SearchEngine.Documents ► PptxParser ► PptxParser(Configuration)
Keyoti SearchUnit v6
New instance
Declaration Syntax
C# Visual Basic
public PptxParser(
    Configuration configuration
)
Public Sub New (
    configuration As Configuration
)
Parameters
configuration (Configuration)


Read Method (stream, uri, encoding)

Read Method (stream, uri, encoding)
API Documentation ► Keyoti.SearchEngine.Documents ► PptxParser ► Read(Stream, Uri, Encoding)
Keyoti SearchUnit v6
Reads a document and returns an object holding it's text and any links.
Declaration Syntax
C# Visual Basic
public override DocumentText Read(
    Stream stream,
    Uri uri,
    Encoding encoding
)
Public Overrides Function Read (
    stream As Stream,
    uri As Uri,
    encoding As Encoding
) As DocumentText
Parameters
stream (Stream)
The document stream to read from.
uri (Uri)
The document URI, used only for weighting words found in the document.
encoding (Encoding)
The document encoding if applicable/available.
Return Value
DocumentText
The DocumentText for the document.


PreloadedDocument Class

PreloadedDocument Class
API Documentation ► Keyoti.SearchEngine.Documents ► PreloadedDocument
Keyoti SearchUnit v6
A document with preset text.
Declaration Syntax
C# Visual Basic
public class PreloadedDocument : Document
Public Class PreloadedDocument
    Inherits Document
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PreloadedDocument(Uri, String, String, String, ArrayList, LocationCategoryRecord, SecurityGroupRecordList, String, Configuration) | Creates a new instance
 | PreloadedDocument(Uri, String, String, Configuration) | Creates a new instance
 | CalculateWordRelevancies(WordCollection) | Calculate the weight field value for the words in the list. (Inherited from Document.)
 | CalculateWordsRelevancy(ArrayList) | Obsolete. Calculate the weight field value for the words in the list. (Inherited from Document.)
 | Configuration | The instance of the Configuration class that holds the settings to be used. (Inherited from Document.)
 | ContentCategories | The content categories of type ContentCategoryRecord that this document belongs to. (Inherited from Document.)
 | CustomData | Any custom data that should be stored for the document. (Inherited from Document.)
 | Description | Description of the document, if specified. (Inherited from Document.)
 | Dispose()()()() | Removes all references held by this object. (Inherited from Document.)
 | DocumentId | The ID of the document in the data layer. (Inherited from Document.)
 | DocumentRecord | The DocumentRecord instance that stores the data. (Inherited from Document.)
 | DontIndex | Whether to ignore the document during index creation. (Inherited from Document.)
 | Encoding | The document's character encoding. (Inherited from Document.)
 | Equals(Object) | Determines if documents are equal (Inherited from Document.)
 | FileType | Obsolete. The mime-type for the document. (Inherited from Document.)
 | Finalize()()()() | (Inherited from Object.)
 | GetFileType()()()() | The mime-type for the document. (Inherited from Document.)
 | GetHashCode()()()() | Gets the hashcode for the document, based on it's DocumentRecord. (Inherited from Document.)
 | GetType()()()() | (Inherited from Object.)
 | InBodyCoefficient | Coefficient used for weighting words found in the document body. (Inherited from Document.)
 | IndexableSourceId | The ID of the indexable source this belongs to, or -1 if none. (Inherited from Document.)
 | InTitleCoefficient | Coefficient used for weighting words found in the document title. (Inherited from Document.)
 | InUrlCoefficient | Coefficient used for weighting words found in the document Uri. (Inherited from Document.)
 | IsDocumentChanged()()()() | Whether the document can be identified to have changed between the last time it was indexed and when LoadResponseStream was called. (Inherited from Document.)
 | IsIndexed()()()() | Whether this document has been indexed. (Inherited from Document.)
 | LastDateIndexed | The date the document was last indexed. (Inherited from Document.)
 | LastModifiedDate | The LastModifiedDate for the document. (Inherited from Document.)
 | LastResponseStatusCode | The URI provided with the last server response, HttpStatusCode.Unused if not available. (Inherited from Document.)
 | LastResponseUri | The URI provided with the last server response, null if not available. (Inherited from Document.)
 | LocationCategory | The location category that this document belongs to. (Inherited from Document.)
 | LoginPage | Whether this page is a 'login page' (for Forms Authentication). (Inherited from Document.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Parser | The Parser instance used to parse words from the remote document. (Inherited from Document.)
 | ParserProvider | The ParserProvider to use to obtain the correct parser to parse the document. (Inherited from Document.)
 | Reader | The Reader instance used to read the document and links from the remote document. (Inherited from Document.)
 | ReadLinks()()()() | Returns an empty ArrayList. (Overrides Document.ReadLinks()()()().)
 | ReadText()()()() | Reads the text in the document. (Overrides Document.ReadText()()()().)
 | SecurityGroups | The securityGroup category that this document belongs to. (Inherited from Document.)
 | stream | The document stream. (Inherited from Document.)
 | Title | The title of the document. (Inherited from Document.)
 | ToString()()()() | (Inherited from Object.)
 | Uri | The document's Uri (URL). (Inherited from Document.)
Remarks
During indexing, the data passed in the constructor is used, rather than loaded from the document's URI. The document's URI is used in the search results to identify the document.
Inheritance Hierarchy
Object
 | Document
 |  | PreloadedDocument


PreloadedDocument Constructor

PreloadedDocument Constructor
API Documentation ► Keyoti.SearchEngine.Documents ► PreloadedDocument ► PreloadedDocument()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | PreloadedDocument(Uri, String, String, String, ArrayList, LocationCategoryRecord, SecurityGroupRecordList, String, Configuration) | Creates a new instance
 | PreloadedDocument(Uri, String, String, Configuration) | Creates a new instance


PreloadedDocument Constructor (documentUri, title, text, configuration)

PreloadedDocument Constructor (documentUri, title, text, configuration)
API Documentation ► Keyoti.SearchEngine.Documents ► PreloadedDocument ► PreloadedDocument(Uri, String, String, Configuration)
Keyoti SearchUnit v6
Creates a new instance
Declaration Syntax
C# Visual Basic
public PreloadedDocument(
    Uri documentUri,
    string title,
    string text,
    Configuration configuration
)
Public Sub New (
    documentUri As Uri,
    title As String,
    text As String,
    configuration As Configuration
)
Parameters
documentUri (Uri)
The URI used to identify the document, does not have to be a 'real' URI.
title (String)
Title of the document.
text (String)
Body of the document text.
configuration (Configuration)
The Configuration.


PreloadedDocument Constructor (documentUri, title, text, summary, contentCategories, locationCategory, securityGroups, customData, configuration)

PreloadedDocument Constructor (documentUri, title, text, summary, contentCategories, locationCategory, securityGroups, customData, configuration)
API Documentation ► Keyoti.SearchEngine.Documents ► PreloadedDocument ► PreloadedDocument(Uri, String, String, String, ArrayList, LocationCategoryRecord, SecurityGroupRecordList, String, Configuration)
Keyoti SearchUnit v6
Creates a new instance
Declaration Syntax
C# Visual Basic
public PreloadedDocument(
    Uri documentUri,
    string title,
    string text,
    string summary,
    ArrayList contentCategories,
    LocationCategoryRecord locationCategory,
    SecurityGroupRecordList securityGroups,
    string customData,
    Configuration configuration
)
Public Sub New (
    documentUri As Uri,
    title As String,
    text As String,
    summary As String,
    contentCategories As ArrayList,
    locationCategory As LocationCategoryRecord,
    securityGroups As SecurityGroupRecordList,
    customData As String,
    configuration As Configuration
)
Parameters
documentUri (Uri)
The URI used to identify the document, does not have to be a 'real' URI.
title (String)
Title of the document.
text (String)
Body of the document text.
summary (String)
Summary of document, which may be used as a result summary (see Configuration).
contentCategories (ArrayList)
Content categories this document belongs to or null - must be of type ContentCategoryRecord.
locationCategory (LocationCategoryRecord)
Location category this document belongs to or null.
securityGroups (SecurityGroupRecordList)
Security groups this document belongs to or null.
customData (String)
'Custom data' for the document.
configuration (Configuration)
The Configuration.


ReadLinks Method

ReadLinks Method
API Documentation ► Keyoti.SearchEngine.Documents ► PreloadedDocument ► ReadLinks()()()()
Keyoti SearchUnit v6
Returns an empty ArrayList.
Declaration Syntax
C# Visual Basic
public override ArrayList ReadLinks()
Public Overrides Function ReadLinks As ArrayList
Return Value
ArrayList

Send comments on this topic to support@keyoti.com


ReadText Method

ReadText Method
API Documentation ► Keyoti.SearchEngine.Documents ► PreloadedDocument ► ReadText()()()()
Keyoti SearchUnit v6
Reads the text in the document.
Declaration Syntax
C# Visual Basic
public override DocumentText ReadText()
Public Overrides Function ReadText As DocumentText
Return Value
DocumentText

Send comments on this topic to support@keyoti.com


Reader Class

Reader Class
API Documentation ► Keyoti.SearchEngine.Documents ► Reader
Keyoti SearchUnit v6
Reads files from the filesystem and pages from servers via HTTP.
Declaration Syntax
C# Visual Basic
public class Reader
Public Class Reader
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Reader(Configuration) | Constructs a new Reader instance.
 | CheckRedirection(WebRequest, WebResponse) | Checks if a redirection occurred - and returns true if it was to the error page specified in Configuration.ErrorPageRedir
 | Configuration | Gets the instance of the Configuration class that holds the settings to be used.
 | DecompressStream(String, Stream) | Decompresses the response stream if compressed with 'deflate' or 'gzip', if not compressed with either then the original stream is returned.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetFileType(Uri) | Retrieves the mime-type for the specified Uri
 | GetHashCode()()()() | (Inherited from Object.)
 | GetLastModifiedDate(Uri) | Gets the date the file was last modified
 | GetStream(Uri) | Returns the document at uri as a stream.
 | GetType()()()() | (Inherited from Object.)
 | LastContentDispositionFilename | If not null/Nothing, is the last filename specified by Content-Disposition header.
 | LastResponseContentLength | The length of the content in the response, or -1 if no information available.
 | LastResponseEncoding | The name of the encoding used with the most recent response. This may be empty or null.
 | LastResponseFileType | The mimetype returned in the last reponse obtained.
 | LastResponseLastModifiedDate | The last-modified-date returned in the last reponse obtained.
 | LastResponseStatusCode | The status code from the last server response.
 | LastResponseUri | The Uri given in the response from the server.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Request(Uri) | Creates a request to Uri and returns the response from the server.
 | TestUri(Uri, Configuration) | Tests a Uri, returning the WebException that occurred, or null/nothing if there wasn't one.
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
Reader

Send comments on this topic to support@keyoti.com


Reader Constructor (configuration)

Reader Constructor (configuration)
API Documentation ► Keyoti.SearchEngine.Documents ► Reader ► Reader(Configuration)
Keyoti SearchUnit v6
Constructs a new Reader instance.
Declaration Syntax
C# Visual Basic
public Reader(
    Configuration configuration
)
Public Sub New (
    configuration As Configuration
)
Parameters
configuration (Configuration)
The instance of the Configuration class that holds the settings to be used.


CheckRedirection Method (request, response)

CheckRedirection Method (request, response)
API Documentation ► Keyoti.SearchEngine.Documents ► Reader ► CheckRedirection(WebRequest, WebResponse)
Keyoti SearchUnit v6
Checks if a redirection occurred - and returns true if it was to the error page specified in Configuration.ErrorPageRedir
Declaration Syntax
C# Visual Basic
public virtual bool CheckRedirection(
    WebRequest request,
    WebResponse response
)
Public Overridable Function CheckRedirection (
    request As WebRequest,
    response As WebResponse
) As Boolean
Parameters
request (WebRequest)
response (WebResponse)
Return Value
Boolean

Send comments on this topic to support@keyoti.com


Configuration Property

Configuration Property
API Documentation ► Keyoti.SearchEngine.Documents ► Reader ► Configuration
Keyoti SearchUnit v6
Gets the instance of the Configuration class that holds the settings to be used.
Declaration Syntax
C# Visual Basic
public Configuration Configuration { get; }
Public ReadOnly Property Configuration As Configuration
    Get
Property Value
Configuration

Send comments on this topic to support@keyoti.com


DecompressStream Method (contentEncoding, inStream)

DecompressStream Method (contentEncoding, inStream)
API Documentation ► Keyoti.SearchEngine.Documents ► Reader ► DecompressStream(String, Stream)
Keyoti SearchUnit v6
Decompresses the response stream if compressed with 'deflate' or 'gzip', if not compressed with either then the original stream is returned.
Declaration Syntax
C# Visual Basic
protected virtual Stream DecompressStream(
    string contentEncoding,
    Stream inStream
)
Protected Overridable Function DecompressStream (
    contentEncoding As String,
    inStream As Stream
) As Stream
Parameters
contentEncoding (String)
deflate | gzip
inStream (Stream)
Stream to decompress
Return Value
Stream
A decompressed stream.


GetFileType Method (uri)

GetFileType Method (uri)
API Documentation ► Keyoti.SearchEngine.Documents ► Reader ► GetFileType(Uri)
Keyoti SearchUnit v6
Retrieves the mime-type for the specified Uri
Declaration Syntax
C# Visual Basic
public virtual string GetFileType(
    Uri uri
)
Public Overridable Function GetFileType (
    uri As Uri
) As String
Parameters
uri (Uri)
The document Uri
Return Value
String
Mimetypes as per the server's settings. Eg. a html document would return "text/html".


GetLastModifiedDate Method (uri)

GetLastModifiedDate Method (uri)
API Documentation ► Keyoti.SearchEngine.Documents ► Reader ► GetLastModifiedDate(Uri)
Keyoti SearchUnit v6
Gets the date the file was last modified
Declaration Syntax
C# Visual Basic
public virtual DateTime GetLastModifiedDate(
    Uri uri
)
Public Overridable Function GetLastModifiedDate (
    uri As Uri
) As DateTime
Parameters
uri (Uri)
The file to retrieve the date for
Return Value
DateTime
Remarks
If the server fails to return a Last Modified Date, this will return today.
Remarks
For dynamic pages (aspx etc) this will return today.
Exceptions
Exception | Condition
LastModifiedDateNotAvailableException | Thrown when a HTTP server does not provide a Last-Modified header.


GetStream Method (uri)

GetStream Method (uri)
API Documentation ► Keyoti.SearchEngine.Documents ► Reader ► GetStream(Uri)
Keyoti SearchUnit v6
Returns the document at uri as a stream.
Declaration Syntax
C# Visual Basic
public virtual Stream GetStream(
    Uri uri
)
Public Overridable Function GetStream (
    uri As Uri
) As Stream
Parameters
uri (Uri)
Return Value
Stream
Remarks
If the response from the server is compressed with deflate or gzip, it is decompressed first.


LastContentDispositionFilename Property

LastContentDispositionFilename Property
API Documentation ► Keyoti.SearchEngine.Documents ► Reader ► LastContentDispositionFilename
Keyoti SearchUnit v6
If not null/Nothing, is the last filename specified by Content-Disposition header.
Declaration Syntax
C# Visual Basic
public string LastContentDispositionFilename { get; }
Public ReadOnly Property LastContentDispositionFilename As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


LastResponseContentLength Property

LastResponseContentLength Property
API Documentation ► Keyoti.SearchEngine.Documents ► Reader ► LastResponseContentLength
Keyoti SearchUnit v6
The length of the content in the response, or -1 if no information available.
Declaration Syntax
C# Visual Basic
public long LastResponseContentLength { get; }
Public ReadOnly Property LastResponseContentLength As Long
    Get
Property Value
Int64

Send comments on this topic to support@keyoti.com


LastResponseEncoding Property

LastResponseEncoding Property
API Documentation ► Keyoti.SearchEngine.Documents ► Reader ► LastResponseEncoding
Keyoti SearchUnit v6
The name of the encoding used with the most recent response. This may be empty or null.
Declaration Syntax
C# Visual Basic
public string LastResponseEncoding { get; }
Public ReadOnly Property LastResponseEncoding As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


LastResponseFileType Property

LastResponseFileType Property
API Documentation ► Keyoti.SearchEngine.Documents ► Reader ► LastResponseFileType
Keyoti SearchUnit v6
The mimetype returned in the last reponse obtained.
Declaration Syntax
C# Visual Basic
public string LastResponseFileType { get; }
Public ReadOnly Property LastResponseFileType As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


LastResponseLastModifiedDate Property

LastResponseLastModifiedDate Property
API Documentation ► Keyoti.SearchEngine.Documents ► Reader ► LastResponseLastModifiedDate
Keyoti SearchUnit v6
The last-modified-date returned in the last reponse obtained.
Declaration Syntax
C# Visual Basic
public DateTime LastResponseLastModifiedDate { get; }
Public ReadOnly Property LastResponseLastModifiedDate As DateTime
    Get
Property Value
DateTime

Send comments on this topic to support@keyoti.com


LastResponseStatusCode Property

LastResponseStatusCode Property
API Documentation ► Keyoti.SearchEngine.Documents ► Reader ► LastResponseStatusCode
Keyoti SearchUnit v6
The status code from the last server response.
Declaration Syntax
C# Visual Basic
public HttpStatusCode LastResponseStatusCode { get; }
Public ReadOnly Property LastResponseStatusCode As HttpStatusCode
    Get
Property Value
HttpStatusCode

Send comments on this topic to support@keyoti.com


LastResponseUri Property

LastResponseUri Property
API Documentation ► Keyoti.SearchEngine.Documents ► Reader ► LastResponseUri
Keyoti SearchUnit v6
The Uri given in the response from the server.
Declaration Syntax
C# Visual Basic
public Uri LastResponseUri { get; }
Public ReadOnly Property LastResponseUri As Uri
    Get
Property Value
Uri

Send comments on this topic to support@keyoti.com


Request Method (uri)

Request Method (uri)
API Documentation ► Keyoti.SearchEngine.Documents ► Reader ► Request(Uri)
Keyoti SearchUnit v6
Creates a request to Uri and returns the response from the server.
Declaration Syntax
C# Visual Basic
protected virtual HttpWebResponse Request(
    Uri uri
)
Protected Overridable Function Request (
    uri As Uri
) As HttpWebResponse
Parameters
uri (Uri)
Return Value
HttpWebResponse
Remarks
Uses authentication settings from Configuration. Sets the FileType for this file.
Exceptions
Exception | Condition
 | ProtocolViolationException if Uri protocol is invalid
 | WebException if a web exception occurs, or if redirection to error page occurs


TestUri Method (uri, configuration)

TestUri Method (uri, configuration)
API Documentation ► Keyoti.SearchEngine.Documents ► Reader ► TestUri(Uri, Configuration)
Keyoti SearchUnit v6
Tests a Uri, returning the WebException that occurred, or null/nothing if there wasn't one.
Declaration Syntax
C# Visual Basic
public static WebException TestUri(
    Uri uri,
    Configuration configuration
)
Public Shared Function TestUri (
    uri As Uri,
    configuration As Configuration
) As WebException
Parameters
uri (Uri)
configuration (Configuration)
Return Value
WebException
A WebException that occurs during the connection


ReaderException Class

ReaderException Class
API Documentation ► Keyoti.SearchEngine.Documents ► ReaderException
Keyoti SearchUnit v6
An exception that originated in the Reader.
Declaration Syntax
C# Visual Basic
public class ReaderException : Exception
Public Class ReaderException
    Inherits Exception
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReaderException(Exception) | Create a reader exception.
 | ReaderException(String, Exception) | New
 | Data | (Inherited from Exception.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetBaseException()()()() | (Inherited from Exception.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | (Inherited from Exception.)
 | GetType()()()() | (Inherited from Exception.)
 | HelpLink | (Inherited from Exception.)
 | HResult | (Inherited from Exception.)
 | InnerException | (Inherited from Exception.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | The exception message (Overrides Exception.Message.)
 | Source | (Inherited from Exception.)
 | StackTrace | (Inherited from Exception.)
 | TargetSite | (Inherited from Exception.)
 | ToString()()()() | (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | ReaderException


ReaderException Constructor

ReaderException Constructor
API Documentation ► Keyoti.SearchEngine.Documents ► ReaderException ► ReaderException()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | ReaderException(Exception) | Create a reader exception.
 | ReaderException(String, Exception) | New


ReaderException Constructor (innerException)

ReaderException Constructor (innerException)
API Documentation ► Keyoti.SearchEngine.Documents ► ReaderException ► ReaderException(Exception)
Keyoti SearchUnit v6
Create a reader exception.
Declaration Syntax
C# Visual Basic
public ReaderException(
    Exception innerException
)
Public Sub New (
    innerException As Exception
)
Parameters
innerException (Exception)


ReaderException Constructor (message, innerException)

ReaderException Constructor (message, innerException)
API Documentation ► Keyoti.SearchEngine.Documents ► ReaderException ► ReaderException(String, Exception)
Keyoti SearchUnit v6
New
Declaration Syntax
C# Visual Basic
public ReaderException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)
Parameters
message (String)
innerException (Exception)


Message Property

Message Property
API Documentation ► Keyoti.SearchEngine.Documents ► ReaderException ► Message
Keyoti SearchUnit v6
The exception message
Declaration Syntax
C# Visual Basic
public override string Message { get; }
Public Overrides ReadOnly Property Message As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


ReaderExceptionOccurredEventArgs Class

ReaderExceptionOccurredEventArgs Class
API Documentation ► Keyoti.SearchEngine.Documents ► ReaderExceptionOccurredEventArgs
Keyoti SearchUnit v6
Holds data about the WebException that caused an exception in the Reader class.
Declaration Syntax
C# Visual Basic
public class ReaderExceptionOccurredEventArgs : EventArgs
Public Class ReaderExceptionOccurredEventArgs
    Inherits EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReaderExceptionOccurredEventArgs(WebException, Uri) | Constructor
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | Uri | The Uri of the document being read.
 | WebException | The exception that occured while reading a document.
Inheritance Hierarchy
Object
 | EventArgs
 |  | ReaderExceptionOccurredEventArgs


ReaderExceptionOccurredEventArgs Constructor (we, uri)

ReaderExceptionOccurredEventArgs Constructor (we, uri)
API Documentation ► Keyoti.SearchEngine.Documents ► ReaderExceptionOccurredEventArgs ► ReaderExceptionOccurredEventArgs(WebException, Uri)
Keyoti SearchUnit v6
Constructor
Declaration Syntax
C# Visual Basic
public ReaderExceptionOccurredEventArgs(
    WebException we,
    Uri uri
)
Public Sub New (
    we As WebException,
    uri As Uri
)
Parameters
we (WebException)
uri (Uri)


Uri Property

Uri Property
API Documentation ► Keyoti.SearchEngine.Documents ► ReaderExceptionOccurredEventArgs ► Uri
Keyoti SearchUnit v6
The Uri of the document being read.
Declaration Syntax
C# Visual Basic
public Uri Uri { get; set; }
Public Property Uri As Uri
    Get
    Set
Property Value
Uri

Send comments on this topic to support@keyoti.com


WebException Property

WebException Property
API Documentation ► Keyoti.SearchEngine.Documents ► ReaderExceptionOccurredEventArgs ► WebException
Keyoti SearchUnit v6
The exception that occured while reading a document.
Declaration Syntax
C# Visual Basic
public WebException WebException { get; set; }
Public Property WebException As WebException
    Get
    Set
Property Value
WebException

Send comments on this topic to support@keyoti.com


RtfDocumentParser Class

RtfDocumentParser Class
API Documentation ► Keyoti.SearchEngine.Documents ► RtfDocumentParser
Keyoti SearchUnit v6
Rtf document parser
Declaration Syntax
C# Visual Basic
public class RtfDocumentParser : Parser
Public Class RtfDocumentParser
    Inherits Parser
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RtfDocumentParser(Configuration) | Creates a new parser.
 | Configuration | Gets the instance of the Configuration class that holds the settings to be used. (Inherited from Parser.)
 | CopyStream(Stream) | (Inherited from Parser.)
 | Encoding | The character encoding used in the document Stream, if applicable. (Inherited from Parser.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetFilenameFooter(Uri) | Creates a footer with filename info from the Uri (Inherited from Parser.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetNextWord(String) | Returns the next 'word' in rawBody, is iterative, so subsequent calls move to consecutive words. (Inherited from Parser.)
 | GetType()()()() | (Inherited from Object.)
 | GetWordsInUri(Uri) | Returns list of words as strings in an ArrayList, that are in the Uri (Inherited from Parser.)
 | IsCurrentWordInTitle()()()() | Returns whether the word last returned by GetNextWord is part of the title. (Inherited from Parser.)
 | IsInIgnoredRegion(ArrayList) | Determines whether current word (at wordStart) is in an ignored region. (Inherited from Parser.)
 | IsStreamNeeded()()()() | Obsolete. Whether the parser would need a stream to be passed to it in order to perform a ReadText or ReadLinks operation. (Inherited from Parser.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ParseWords(String, ArrayList, WordCollection, StringBuilder, ArrayList) | Parses rawBody into descrete Word objects and places them in readDocumentWords. (Inherited from Parser.)
 | PreprocessBreakChunk(String) | Applies any required processing to a chunk of text that typically forms either a word or whitespace block. (Inherited from Parser.)
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean) | Processes the list of all words found in the document and returns a list that should be index. (Inherited from Parser.)
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean, ArrayList) | Processes the list of all words found in the document and returns a list that should be index. (Inherited from Parser.)
 | Read(Stream, Uri, Encoding) | Reads a document and returns an object holding it's text and any links. (Overrides Parser.Read(Stream, Uri, Encoding).)
 | ReadLinks(Stream, Encoding) | Obsolete. Reads links to other pages. (Inherited from Parser.)
 | ReadText(Stream, Uri, Encoding) | Obsolete. Reads text and returns list of words and title (Inherited from Parser.)
 | ResetWordPointers()()()() | Resets the current word being processed. (Inherited from Parser.)
 | ToString()()()() | (Inherited from Object.)
 | TruncateWordWithRepeatedChar(String) | Removes repeated non-letters from word. (Inherited from Parser.)
 | WordEnd | The current word's end. (Inherited from Parser.)
 | WordStart | The current word's start. (Inherited from Parser.)
Inheritance Hierarchy
Object
 | Parser
 |  | RtfDocumentParser


RtfDocumentParser Constructor (configuration)

RtfDocumentParser Constructor (configuration)
API Documentation ► Keyoti.SearchEngine.Documents ► RtfDocumentParser ► RtfDocumentParser(Configuration)
Keyoti SearchUnit v6
Creates a new parser.
Declaration Syntax
C# Visual Basic
public RtfDocumentParser(
    Configuration configuration
)
Public Sub New (
    configuration As Configuration
)
Parameters
configuration (Configuration)
The instance of the Configuration class that holds the settings to be used.


Read Method (stream, uri, encoding)

Read Method (stream, uri, encoding)
API Documentation ► Keyoti.SearchEngine.Documents ► RtfDocumentParser ► Read(Stream, Uri, Encoding)
Keyoti SearchUnit v6
Reads a document and returns an object holding it's text and any links.
Declaration Syntax
C# Visual Basic
public override DocumentText Read(
    Stream stream,
    Uri uri,
    Encoding encoding
)
Public Overrides Function Read (
    stream As Stream,
    uri As Uri,
    encoding As Encoding
) As DocumentText
Parameters
stream (Stream)
The document stream to read from.
uri (Uri)
The document URI, used only for weighting words found in the document.
encoding (Encoding)
The document encoding if applicable/available.
Return Value
DocumentText
The DocumentText for the document.


TxtDocumentParser Class

TxtDocumentParser Class
API Documentation ► Keyoti.SearchEngine.Documents ► TxtDocumentParser
Keyoti SearchUnit v6
Parser for .txt documents.
Declaration Syntax
C# Visual Basic
public class TxtDocumentParser : Parser
Public Class TxtDocumentParser
    Inherits Parser
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TxtDocumentParser(Configuration) | Creates an instance of TxtDocumentParser class.
 | Configuration | Gets the instance of the Configuration class that holds the settings to be used. (Inherited from Parser.)
 | CopyStream(Stream) | (Inherited from Parser.)
 | Encoding | The character encoding used in the document Stream, if applicable. (Inherited from Parser.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetFilenameFooter(Uri) | Creates a footer with filename info from the Uri (Inherited from Parser.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetNextWord(String) | Returns the next 'word' in rawBody, is iterative, so subsequent calls move to consecutive words. (Inherited from Parser.)
 | GetType()()()() | (Inherited from Object.)
 | GetWordsInUri(Uri) | Returns list of words as strings in an ArrayList, that are in the Uri (Inherited from Parser.)
 | IsCurrentWordInTitle()()()() | Returns whether the word last returned by GetNextWord is part of the title. (Inherited from Parser.)
 | IsInIgnoredRegion(ArrayList) | Determines whether current word (at wordStart) is in an ignored region. (Inherited from Parser.)
 | IsStreamNeeded()()()() | Obsolete. Whether the parser would need a stream to be passed to it in order to perform a ReadText or ReadLinks operation. (Inherited from Parser.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ParseWords(String, ArrayList, WordCollection, StringBuilder, ArrayList) | Parses rawBody into descrete Word objects and places them in readDocumentWords. (Inherited from Parser.)
 | PreprocessBreakChunk(String) | Applies any required processing to a chunk of text that typically forms either a word or whitespace block. (Inherited from Parser.)
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean) | Processes the list of all words found in the document and returns a list that should be index. (Inherited from Parser.)
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean, ArrayList) | Processes the list of all words found in the document and returns a list that should be index. (Inherited from Parser.)
 | Read(Stream, Uri, Encoding) | Reads a document and returns an object holding it's text and any links. (Overrides Parser.Read(Stream, Uri, Encoding).)
 | Read(String, Uri, Encoding) | Read the document
 | ReadLinks(Stream, Encoding) | Obsolete. Reads links to other pages. (Inherited from Parser.)
 | ReadText(Stream, Uri, Encoding) | Obsolete. Reads text and returns list of words and title (Inherited from Parser.)
 | ResetWordPointers()()()() | Resets the current word being processed. (Inherited from Parser.)
 | ToString()()()() | (Inherited from Object.)
 | TruncateWordWithRepeatedChar(String) | Removes repeated non-letters from word. (Inherited from Parser.)
 | WordEnd | The current word's end. (Inherited from Parser.)
 | WordStart | The current word's start. (Inherited from Parser.)
Inheritance Hierarchy
Object
 | Parser
 |  | TxtDocumentParser
 |  |  | GenericIFilterParser
 |  |  | XmlDocumentParser


TxtDocumentParser Constructor (configuration)

TxtDocumentParser Constructor (configuration)
API Documentation ► Keyoti.SearchEngine.Documents ► TxtDocumentParser ► TxtDocumentParser(Configuration)
Keyoti SearchUnit v6
Creates an instance of TxtDocumentParser class.
Declaration Syntax
C# Visual Basic
public TxtDocumentParser(
    Configuration configuration
)
Public Sub New (
    configuration As Configuration
)
Parameters
configuration (Configuration)
The instance of the Configuration class that holds the settings to be used.


Read Method

Read Method
API Documentation ► Keyoti.SearchEngine.Documents ► TxtDocumentParser ► Read()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Read(Stream, Uri, Encoding) | Reads a document and returns an object holding it's text and any links. (Overrides Parser.Read(Stream, Uri, Encoding).)
 | Read(String, Uri, Encoding) | Read the document


Read Method (stream, uri, encoding)

Read Method (stream, uri, encoding)
API Documentation ► Keyoti.SearchEngine.Documents ► TxtDocumentParser ► Read(Stream, Uri, Encoding)
Keyoti SearchUnit v6
Reads a document and returns an object holding it's text and any links.
Declaration Syntax
C# Visual Basic
public override DocumentText Read(
    Stream stream,
    Uri uri,
    Encoding encoding
)
Public Overrides Function Read (
    stream As Stream,
    uri As Uri,
    encoding As Encoding
) As DocumentText
Parameters
stream (Stream)
The document stream to read from.
uri (Uri)
The document URI, used only for weighting words found in the document.
encoding (Encoding)
The document encoding if applicable/available.
Return Value
DocumentText
The DocumentText for the document.


Read Method (rawBody, uri, encoding)

Read Method (rawBody, uri, encoding)
API Documentation ► Keyoti.SearchEngine.Documents ► TxtDocumentParser ► Read(String, Uri, Encoding)
Keyoti SearchUnit v6
Read the document
Declaration Syntax
C# Visual Basic
public DocumentText Read(
    string rawBody,
    Uri uri,
    Encoding encoding
)
Public Function Read (
    rawBody As String,
    uri As Uri,
    encoding As Encoding
) As DocumentText
Parameters
rawBody (String)
uri (Uri)
encoding (Encoding)
Return Value
DocumentText

Send comments on this topic to support@keyoti.com


Word2002Parser Class

Word2002Parser Class
API Documentation ► Keyoti.SearchEngine.Documents ► Word2002Parser
Keyoti SearchUnit v6
Parses v97-2003 binary format documents.
Declaration Syntax
C# Visual Basic
public class Word2002Parser : Parser
Public Class Word2002Parser
    Inherits Parser
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Word2002Parser(Configuration) | Creates an instance of Word2002Parser class.
 | Configuration | Gets the instance of the Configuration class that holds the settings to be used. (Inherited from Parser.)
 | CopyStream(Stream) | (Inherited from Parser.)
 | Encoding | The character encoding used in the document Stream, if applicable. (Inherited from Parser.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetFilenameFooter(Uri) | Creates a footer with filename info from the Uri (Inherited from Parser.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetNextWord(String) | Returns the next 'word' in rawBody, is iterative, so subsequent calls move to consecutive words. (Inherited from Parser.)
 | GetType()()()() | (Inherited from Object.)
 | GetWordsInUri(Uri) | Returns list of words as strings in an ArrayList, that are in the Uri (Inherited from Parser.)
 | IsCurrentWordInTitle()()()() | Returns whether the word last returned by GetNextWord is part of the title. (Inherited from Parser.)
 | IsInIgnoredRegion(ArrayList) | Determines whether current word (at wordStart) is in an ignored region. (Inherited from Parser.)
 | IsStreamNeeded()()()() | Obsolete. Whether the parser would need a stream to be passed to it in order to perform a ReadText or ReadLinks operation. (Inherited from Parser.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ParseWords(String, ArrayList, WordCollection, StringBuilder, ArrayList) | Parses rawBody into descrete Word objects and places them in readDocumentWords. (Inherited from Parser.)
 | PreprocessBreakChunk(String) | Applies any required processing to a chunk of text that typically forms either a word or whitespace block. (Inherited from Parser.)
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean) | Processes the list of all words found in the document and returns a list that should be index. (Inherited from Parser.)
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean, ArrayList) | Processes the list of all words found in the document and returns a list that should be index. (Inherited from Parser.)
 | Read(Stream, Uri, Encoding) | Reads a document and returns an object holding it's text and any links. (Overrides Parser.Read(Stream, Uri, Encoding).)
 | ReadLinks(Stream, Encoding) | Obsolete. Reads links to other pages. (Inherited from Parser.)
 | ReadText(Stream, Uri, Encoding) | Obsolete. Reads text and returns list of words and title (Inherited from Parser.)
 | ResetWordPointers()()()() | Resets the current word being processed. (Inherited from Parser.)
 | ToString()()()() | (Inherited from Object.)
 | TruncateWordWithRepeatedChar(String) | Removes repeated non-letters from word. (Inherited from Parser.)
 | WordEnd | The current word's end. (Inherited from Parser.)
 | WordStart | The current word's start. (Inherited from Parser.)
Inheritance Hierarchy
Object
 | Parser
 |  | Word2002Parser


Word2002Parser Constructor (configuration)

Word2002Parser Constructor (configuration)
API Documentation ► Keyoti.SearchEngine.Documents ► Word2002Parser ► Word2002Parser(Configuration)
Keyoti SearchUnit v6
Creates an instance of Word2002Parser class.
Declaration Syntax
C# Visual Basic
public Word2002Parser(
    Configuration configuration
)
Public Sub New (
    configuration As Configuration
)
Parameters
configuration (Configuration)
The instance of the Configuration class that holds the settings to be used.


Read Method (stream, uri, encoding)

Read Method (stream, uri, encoding)
API Documentation ► Keyoti.SearchEngine.Documents ► Word2002Parser ► Read(Stream, Uri, Encoding)
Keyoti SearchUnit v6
Reads a document and returns an object holding it's text and any links.
Declaration Syntax
C# Visual Basic
public override DocumentText Read(
    Stream stream,
    Uri uri,
    Encoding encoding
)
Public Overrides Function Read (
    stream As Stream,
    uri As Uri,
    encoding As Encoding
) As DocumentText
Parameters
stream (Stream)
The document stream to read from.
uri (Uri)
The document URI, used only for weighting words found in the document.
encoding (Encoding)
The document encoding if applicable/available.
Return Value
DocumentText
The DocumentText for the document.


WordDocumentParser Class

WordDocumentParser Class
API Documentation ► Keyoti.SearchEngine.Documents ► WordDocumentParser
Keyoti SearchUnit v6
Master parser for Word documents, this class applies RTF or Word2002 Parsers according to actual structure of .doc files.
Declaration Syntax
C# Visual Basic
public class WordDocumentParser : Parser
Public Class WordDocumentParser
    Inherits Parser
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WordDocumentParser(Configuration) | Creates an instance of WordDocumentParser class.
 | Configuration | Gets the instance of the Configuration class that holds the settings to be used. (Inherited from Parser.)
 | CopyStream(Stream) | (Inherited from Parser.)
 | Encoding | The character encoding used in the document Stream, if applicable. (Inherited from Parser.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetFilenameFooter(Uri) | Creates a footer with filename info from the Uri (Inherited from Parser.)
 | GetFormatParser(Stream) | Returns parser specific to actual type of .doc file.
 | GetHashCode()()()() | (Inherited from Object.)
 | GetNextWord(String) | Returns the next 'word' in rawBody, is iterative, so subsequent calls move to consecutive words. (Inherited from Parser.)
 | GetType()()()() | (Inherited from Object.)
 | GetWordsInUri(Uri) | Returns list of words as strings in an ArrayList, that are in the Uri (Inherited from Parser.)
 | IsCurrentWordInTitle()()()() | Returns whether the word last returned by GetNextWord is part of the title. (Inherited from Parser.)
 | IsInIgnoredRegion(ArrayList) | Determines whether current word (at wordStart) is in an ignored region. (Inherited from Parser.)
 | IsStreamNeeded()()()() | Obsolete. Whether the parser would need a stream to be passed to it in order to perform a ReadText or ReadLinks operation. (Inherited from Parser.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ParseWords(String, ArrayList, WordCollection, StringBuilder, ArrayList) | Parses rawBody into descrete Word objects and places them in readDocumentWords. (Inherited from Parser.)
 | PreprocessBreakChunk(String) | Applies any required processing to a chunk of text that typically forms either a word or whitespace block. (Inherited from Parser.)
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean) | Processes the list of all words found in the document and returns a list that should be index. (Inherited from Parser.)
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean, ArrayList) | Processes the list of all words found in the document and returns a list that should be index. (Inherited from Parser.)
 | Read(Stream, Uri, Encoding) | Reads a document and returns an object holding it's text and any links. (Overrides Parser.Read(Stream, Uri, Encoding).)
 | ReadLinks(Stream, Encoding) | Obsolete. Reads links to other pages. (Inherited from Parser.)
 | ReadText(Stream, Uri, Encoding) | Obsolete. Reads text and returns list of words and title (Inherited from Parser.)
 | ResetWordPointers()()()() | Resets the current word being processed. (Inherited from Parser.)
 | ToString()()()() | (Inherited from Object.)
 | TruncateWordWithRepeatedChar(String) | Removes repeated non-letters from word. (Inherited from Parser.)
 | WordEnd | The current word's end. (Inherited from Parser.)
 | WordStart | The current word's start. (Inherited from Parser.)
Inheritance Hierarchy
Object
 | Parser
 |  | WordDocumentParser


WordDocumentParser Constructor (configuration)

WordDocumentParser Constructor (configuration)
API Documentation ► Keyoti.SearchEngine.Documents ► WordDocumentParser ► WordDocumentParser(Configuration)
Keyoti SearchUnit v6
Creates an instance of WordDocumentParser class.
Declaration Syntax
C# Visual Basic
public WordDocumentParser(
    Configuration configuration
)
Public Sub New (
    configuration As Configuration
)
Parameters
configuration (Configuration)
The instance of the Configuration class that holds the settings to be used.


GetFormatParser Method (stream)

GetFormatParser Method (stream)
API Documentation ► Keyoti.SearchEngine.Documents ► WordDocumentParser ► GetFormatParser(Stream)
Keyoti SearchUnit v6
Returns parser specific to actual type of .doc file.
Declaration Syntax
C# Visual Basic
protected virtual Parser GetFormatParser(
    Stream stream
)
Protected Overridable Function GetFormatParser (
    stream As Stream
) As Parser
Parameters
stream (Stream)
The document as a stream
Return Value
Parser
The appropriate parser.


Read Method (stream, uri, encoding)

Read Method (stream, uri, encoding)
API Documentation ► Keyoti.SearchEngine.Documents ► WordDocumentParser ► Read(Stream, Uri, Encoding)
Keyoti SearchUnit v6
Reads a document and returns an object holding it's text and any links.
Declaration Syntax
C# Visual Basic
public override DocumentText Read(
    Stream stream,
    Uri uri,
    Encoding encoding
)
Public Overrides Function Read (
    stream As Stream,
    uri As Uri,
    encoding As Encoding
) As DocumentText
Parameters
stream (Stream)
The document stream to read from.
uri (Uri)
The document URI, used only for weighting words found in the document.
encoding (Encoding)
The document encoding if applicable/available.
Return Value
DocumentText
The DocumentText for the document.


XlsxParser Class

XlsxParser Class
API Documentation ► Keyoti.SearchEngine.Documents ► XlsxParser
Keyoti SearchUnit v6
.xlsx (MS Excel) document parser.
Declaration Syntax
C# Visual Basic
public class XlsxParser : XmlDocumentParser
Public Class XlsxParser
    Inherits XmlDocumentParser
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | XlsxParser(Configuration) | New instance
 | Configuration | Gets the instance of the Configuration class that holds the settings to be used. (Inherited from Parser.)
 | CopyStream(Stream) | (Inherited from Parser.)
 | Encoding | The character encoding used in the document Stream, if applicable. (Inherited from Parser.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetFilenameFooter(Uri) | Creates a footer with filename info from the Uri (Inherited from Parser.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetNextWord(String) | Returns the next 'word' in rawBody, is iterative, so subsequent calls move to consecutive words. (Inherited from Parser.)
 | GetType()()()() | (Inherited from Object.)
 | GetWordsInUri(Uri) | Returns list of words as strings in an ArrayList, that are in the Uri (Inherited from Parser.)
 | IsCurrentWordInTitle()()()() | Returns whether the word last returned by GetNextWord is part of the title. (Inherited from Parser.)
 | IsInIgnoredRegion(ArrayList) | Determines whether current word (at wordStart) is in an ignored region. (Inherited from Parser.)
 | IsStreamNeeded()()()() | Obsolete. Whether the parser would need a stream to be passed to it in order to perform a ReadText or ReadLinks operation. (Inherited from Parser.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ParseWords(String, ArrayList, WordCollection, StringBuilder, ArrayList) | Parses rawBody into descrete Word objects and places them in readDocumentWords. (Inherited from Parser.)
 | PreprocessBreakChunk(String) | Applies any required processing to a chunk of text that typically forms either a word or whitespace block. (Inherited from Parser.)
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean) | Processes the list of all words found in the document and returns a list that should be index. (Inherited from Parser.)
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean, ArrayList) | Processes the list of all words found in the document and returns a list that should be index. (Inherited from Parser.)
 | Read(Stream, Uri, Encoding) | Reads a document and returns an object holding it's text and any links. (Overrides XmlDocumentParser.Read(Stream, Uri, Encoding).)
 | Read(String, Uri, Encoding) | Read the document (Inherited from TxtDocumentParser.)
 | ReadLinks(Stream, Encoding) | Obsolete. Reads links to other pages. (Inherited from Parser.)
 | ReadText(Stream, Uri, Encoding) | Obsolete. Reads text and returns list of words and title (Inherited from Parser.)
 | ResetWordPointers()()()() | Resets the current word being processed. (Inherited from Parser.)
 | ToString()()()() | (Inherited from Object.)
 | TruncateWordWithRepeatedChar(String) | Removes repeated non-letters from word. (Inherited from Parser.)
 | WordEnd | The current word's end. (Inherited from Parser.)
 | WordStart | The current word's start. (Inherited from Parser.)
Inheritance Hierarchy
Object
 | Parser
 |  | TxtDocumentParser
 |  |  | XmlDocumentParser
 |  |  |  | XlsxParser


XlsxParser Constructor (configuration)

XlsxParser Constructor (configuration)
API Documentation ► Keyoti.SearchEngine.Documents ► XlsxParser ► XlsxParser(Configuration)
Keyoti SearchUnit v6
New instance
Declaration Syntax
C# Visual Basic
public XlsxParser(
    Configuration configuration
)
Public Sub New (
    configuration As Configuration
)
Parameters
configuration (Configuration)
The configuration to use

Send comments on this topic to support@keyoti.com


Read Method (stream, uri, encoding)

Read Method (stream, uri, encoding)
API Documentation ► Keyoti.SearchEngine.Documents ► XlsxParser ► Read(Stream, Uri, Encoding)
Keyoti SearchUnit v6
Reads a document and returns an object holding it's text and any links.
Declaration Syntax
C# Visual Basic
public override DocumentText Read(
    Stream stream,
    Uri uri,
    Encoding encoding
)
Public Overrides Function Read (
    stream As Stream,
    uri As Uri,
    encoding As Encoding
) As DocumentText
Parameters
stream (Stream)
The document stream to read from.
uri (Uri)
The document URI, used only for weighting words found in the document.
encoding (Encoding)
The document encoding if applicable/available.
Return Value
DocumentText
The DocumentText for the document.


XmlDocumentParser Class

XmlDocumentParser Class
API Documentation ► Keyoti.SearchEngine.Documents ► XmlDocumentParser
Keyoti SearchUnit v6
Reads plain text from an Xml document stream.
Declaration Syntax
C# Visual Basic
public class XmlDocumentParser : TxtDocumentParser
Public Class XmlDocumentParser
    Inherits TxtDocumentParser
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | XmlDocumentParser(Configuration) | New instance
 | Configuration | Gets the instance of the Configuration class that holds the settings to be used. (Inherited from Parser.)
 | CopyStream(Stream) | (Inherited from Parser.)
 | Encoding | The character encoding used in the document Stream, if applicable. (Inherited from Parser.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetFilenameFooter(Uri) | Creates a footer with filename info from the Uri (Inherited from Parser.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetNextWord(String) | Returns the next 'word' in rawBody, is iterative, so subsequent calls move to consecutive words. (Inherited from Parser.)
 | GetType()()()() | (Inherited from Object.)
 | GetWordsInUri(Uri) | Returns list of words as strings in an ArrayList, that are in the Uri (Inherited from Parser.)
 | IsCurrentWordInTitle()()()() | Returns whether the word last returned by GetNextWord is part of the title. (Inherited from Parser.)
 | IsInIgnoredRegion(ArrayList) | Determines whether current word (at wordStart) is in an ignored region. (Inherited from Parser.)
 | IsStreamNeeded()()()() | Obsolete. Whether the parser would need a stream to be passed to it in order to perform a ReadText or ReadLinks operation. (Inherited from Parser.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ParseWords(String, ArrayList, WordCollection, StringBuilder, ArrayList) | Parses rawBody into descrete Word objects and places them in readDocumentWords. (Inherited from Parser.)
 | PreprocessBreakChunk(String) | Applies any required processing to a chunk of text that typically forms either a word or whitespace block. (Inherited from Parser.)
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean) | Processes the list of all words found in the document and returns a list that should be index. (Inherited from Parser.)
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean, ArrayList) | Processes the list of all words found in the document and returns a list that should be index. (Inherited from Parser.)
 | Read(Stream, Uri, Encoding) | Reads a document and returns an object holding it's text and any links. (Overrides TxtDocumentParser.Read(Stream, Uri, Encoding).)
 | Read(String, Uri, Encoding) | Read the document (Inherited from TxtDocumentParser.)
 | ReadLinks(Stream, Encoding) | Obsolete. Reads links to other pages. (Inherited from Parser.)
 | ReadText(Stream, Uri, Encoding) | Obsolete. Reads text and returns list of words and title (Inherited from Parser.)
 | ResetWordPointers()()()() | Resets the current word being processed. (Inherited from Parser.)
 | ToString()()()() | (Inherited from Object.)
 | TruncateWordWithRepeatedChar(String) | Removes repeated non-letters from word. (Inherited from Parser.)
 | WordEnd | The current word's end. (Inherited from Parser.)
 | WordStart | The current word's start. (Inherited from Parser.)
Inheritance Hierarchy
Object
 | Parser
 |  | TxtDocumentParser
 |  |  | XmlDocumentParser
 |  |  |  | DocxParser
 |  |  |  | OdsDocumentParser
 |  |  |  | OdtDocumentParser
 |  |  |  | PptxParser
 |  |  |  | XlsxParser


XmlDocumentParser Constructor (c)

XmlDocumentParser Constructor (c)
API Documentation ► Keyoti.SearchEngine.Documents ► XmlDocumentParser ► XmlDocumentParser(Configuration)
Keyoti SearchUnit v6
New instance
Declaration Syntax
C# Visual Basic
public XmlDocumentParser(
    Configuration c
)
Public Sub New (
    c As Configuration
)
Parameters
c (Configuration)
The configuration

Send comments on this topic to support@keyoti.com


Read Method (stream, uri, encoding)

Read Method (stream, uri, encoding)
API Documentation ► Keyoti.SearchEngine.Documents ► XmlDocumentParser ► Read(Stream, Uri, Encoding)
Keyoti SearchUnit v6
Reads a document and returns an object holding it's text and any links.
Declaration Syntax
C# Visual Basic
public override DocumentText Read(
    Stream stream,
    Uri uri,
    Encoding encoding
)
Public Overrides Function Read (
    stream As Stream,
    uri As Uri,
    encoding As Encoding
) As DocumentText
Parameters
stream (Stream)
The document stream to read from.
uri (Uri)
The document URI, used only for weighting words found in the document.
encoding (Encoding)
The document encoding if applicable/available.
Return Value
DocumentText
The DocumentText for the document.


ZipFileParser Class

ZipFileParser Class
API Documentation ► Keyoti.SearchEngine.Documents ► ZipFileParser
Keyoti SearchUnit v6
Parses ZIP files - and indexes any files inside that the engine can index.
Declaration Syntax
C# Visual Basic
public class ZipFileParser : Parser
Public Class ZipFileParser
    Inherits Parser
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZipFileParser(Configuration) |
 | Configuration | Gets the instance of the Configuration class that holds the settings to be used. (Inherited from Parser.)
 | CopyStream(Stream) | (Inherited from Parser.)
 | Encoding | The character encoding used in the document Stream, if applicable. (Inherited from Parser.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetFilenameFooter(Uri) | Creates a footer with filename info from the Uri (Inherited from Parser.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetNextWord(String) | Returns the next 'word' in rawBody, is iterative, so subsequent calls move to consecutive words. (Inherited from Parser.)
 | GetType()()()() | (Inherited from Object.)
 | GetWordsInUri(Uri) | Returns list of words as strings in an ArrayList, that are in the Uri (Inherited from Parser.)
 | IsCurrentWordInTitle()()()() | Returns whether the word last returned by GetNextWord is part of the title. (Inherited from Parser.)
 | IsInIgnoredRegion(ArrayList) | Determines whether current word (at wordStart) is in an ignored region. (Inherited from Parser.)
 | IsStreamNeeded()()()() | Obsolete. Whether the parser would need a stream to be passed to it in order to perform a ReadText or ReadLinks operation. (Inherited from Parser.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ParseWords(String, ArrayList, WordCollection, StringBuilder, ArrayList) | Parses rawBody into descrete Word objects and places them in readDocumentWords. (Inherited from Parser.)
 | PreprocessBreakChunk(String) | Applies any required processing to a chunk of text that typically forms either a word or whitespace block. (Inherited from Parser.)
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean) | Processes the list of all words found in the document and returns a list that should be index. (Inherited from Parser.)
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean, ArrayList) | Processes the list of all words found in the document and returns a list that should be index. (Inherited from Parser.)
 | Read(Stream, Uri, Encoding) | (Overrides Parser.Read(Stream, Uri, Encoding).)
 | ReadLinks(Stream, Encoding) | Obsolete. Reads links to other pages. (Inherited from Parser.)
 | ReadText(Stream, Uri, Encoding) | Obsolete. Reads text and returns list of words and title (Inherited from Parser.)
 | ResetWordPointers()()()() | Resets the current word being processed. (Inherited from Parser.)
 | ToString()()()() | (Inherited from Object.)
 | TruncateWordWithRepeatedChar(String) | Removes repeated non-letters from word. (Inherited from Parser.)
 | WordEnd | The current word's end. (Inherited from Parser.)
 | WordStart | The current word's start. (Inherited from Parser.)
Inheritance Hierarchy
Object
 | Parser
 |  | ZipFileParser


ZipFileParser Constructor (configuration)

ZipFileParser Constructor (configuration)
API Documentation ► Keyoti.SearchEngine.Documents ► ZipFileParser ► ZipFileParser(Configuration)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public ZipFileParser(
    Configuration configuration
)
Public Sub New (
    configuration As Configuration
)
Parameters
configuration (Configuration)


Read Method (stream, uri, encoding)

Read Method (stream, uri, encoding)
API Documentation ► Keyoti.SearchEngine.Documents ► ZipFileParser ► Read(Stream, Uri, Encoding)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public override DocumentText Read(
    Stream stream,
    Uri uri,
    Encoding encoding
)
Public Overrides Function Read (
    stream As Stream,
    uri As Uri,
    encoding As Encoding
) As DocumentText
Parameters
stream (Stream)
uri (Uri)
encoding (Encoding)
Return Value
DocumentText

Send comments on this topic to support@keyoti.com


Keyoti.SearchEngine.Documents.IFilter Namespace

Keyoti.SearchEngine.Documents.IFilter Namespace
API Documentation ► Keyoti.SearchEngine.Documents.IFilter
Keyoti SearchUnit v6
IFilter based parsers
Types
All Types Classes
Icon | Type | Description
 | Reader | Reads text from a file using an installed IFilter if available.


Reader Class

Reader Class
API Documentation ► Keyoti.SearchEngine.Documents.IFilter ► Reader
Keyoti SearchUnit v6
Reads text from a file using an installed IFilter if available.
Declaration Syntax
C# Visual Basic
public class Reader
Public Class Reader
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Reader()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IsReadable(String) | Whether the file can be read.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Read(String) | Returns the text in the document, if it can be read via an installed IFilter.
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
Reader

Send comments on this topic to support@keyoti.com


Reader Constructor

Reader Constructor
API Documentation ► Keyoti.SearchEngine.Documents.IFilter ► Reader ► Reader()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public Reader()
Public Sub New

Send comments on this topic to support@keyoti.com


IsReadable Method (filename)

IsReadable Method (filename)
API Documentation ► Keyoti.SearchEngine.Documents.IFilter ► Reader ► IsReadable(String)
Keyoti SearchUnit v6
Whether the file can be read.
Declaration Syntax
C# Visual Basic
public static bool IsReadable(
    string filename
)
Public Shared Function IsReadable (
    filename As String
) As Boolean
Parameters
filename (String)
Return Value
Boolean

Send comments on this topic to support@keyoti.com


Read Method (filename)

Read Method (filename)
API Documentation ► Keyoti.SearchEngine.Documents.IFilter ► Reader ► Read(String)
Keyoti SearchUnit v6
Returns the text in the document, if it can be read via an installed IFilter.
Declaration Syntax
C# Visual Basic
public static string Read(
    string filename
)
Public Shared Function Read (
    filename As String
) As String
Parameters
filename (String)
Return Value
String

Send comments on this topic to support@keyoti.com


Keyoti.SearchEngine.Events Namespace

Keyoti.SearchEngine.Events Namespace
API Documentation ► Keyoti.SearchEngine.Events
Keyoti SearchUnit v6
Central events
Types
All Types Classes Interfaces Enumerations Delegates
Icon | Type | Description
 | ActionData | Data relevant to an action event
 | ActionEventArgs | Event argument for the Action event.
 | ActionEventHandler | Handler signature for action events
 | ActionName | The name of the action which caused the event.
 | CentralEventDispatcher | Dispatches events from various source classes to direct handlers and plug-in DLLs (Configuration.EventHandlerAssemblyPath).
 | CentralizedInternalEventNotifier | Used by INotifyAction and INotifyNeedObject objects to fire Action and NeedObject events.
 | IEventDispatcher | A dispatcher of central events
 | IsDocumentToBeCrawledEventData | Data for the IsDocumentToBeCrawled event.
 | IsDocumentToBeIndexedEventData | Data for the IsDocumentToBeIndexed event.
 | IsFileSystemDocumentToBeIndexedEventData | Data for the IsFileSystemDocumentToBeIndexed event.
 | NeedObjectEventArgs | Event argument for the NeedObject event.
 | NeedObjectEventHandler | Handler signature for need object events
 | SearchParameters |


ActionData Class

ActionData Class
API Documentation ► Keyoti.SearchEngine.Events ► ActionData
Keyoti SearchUnit v6
Data relevant to an action event
Declaration Syntax
C# Visual Basic
public class ActionData
Public Class ActionData
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ActionData(Object, ActionName) | New instance
 | Data | Related data, see ActionName enumeration for information.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name | The name of the action.
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
ActionData

Send comments on this topic to support@keyoti.com


ActionData Constructor (data, name)

ActionData Constructor (data, name)
API Documentation ► Keyoti.SearchEngine.Events ► ActionData ► ActionData(Object, ActionName)
Keyoti SearchUnit v6
New instance
Declaration Syntax
C# Visual Basic
public ActionData(
    Object data,
    ActionName name
)
Public Sub New (
    data As Object,
    name As ActionName
)
Parameters
data (Object)
name (ActionName)


Data Property

Data Property
API Documentation ► Keyoti.SearchEngine.Events ► ActionData ► Data
Keyoti SearchUnit v6
Related data, see ActionName enumeration for information.
Declaration Syntax
C# Visual Basic
public Object Data { get; }
Public ReadOnly Property Data As Object
    Get
Property Value
Object

Send comments on this topic to support@keyoti.com


Name Property

Name Property
API Documentation ► Keyoti.SearchEngine.Events ► ActionData ► Name
Keyoti SearchUnit v6
The name of the action.
Declaration Syntax
C# Visual Basic
public ActionName Name { get; }
Public ReadOnly Property Name As ActionName
    Get
Property Value
ActionName

Send comments on this topic to support@keyoti.com


ActionEventArgs Class

ActionEventArgs Class
API Documentation ► Keyoti.SearchEngine.Events ► ActionEventArgs
Keyoti SearchUnit v6
Event argument for the Action event.
Declaration Syntax
C# Visual Basic
public class ActionEventArgs : EventArgs
Public Class ActionEventArgs
    Inherits EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ActionEventArgs(ActionData, Configuration) | New instance
 | ActionData | Data relevant to the action
 | Configuration | The configuration in use.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
ActionData contains data relevant to the action, which can be used or modified.
Inheritance Hierarchy
Object
 | EventArgs
 |  | ActionEventArgs


ActionEventArgs Constructor (actionData, currentConfiguration)

ActionEventArgs Constructor (actionData, currentConfiguration)
API Documentation ► Keyoti.SearchEngine.Events ► ActionEventArgs ► ActionEventArgs(ActionData, Configuration)
Keyoti SearchUnit v6
New instance
Declaration Syntax
C# Visual Basic
public ActionEventArgs(
    ActionData actionData,
    Configuration currentConfiguration
)
Public Sub New (
    actionData As ActionData,
    currentConfiguration As Configuration
)
Parameters
actionData (ActionData)
Relevant data
currentConfiguration (Configuration)
The configuration to use.


ActionData Property

ActionData Property
API Documentation ► Keyoti.SearchEngine.Events ► ActionEventArgs ► ActionData
Keyoti SearchUnit v6
Data relevant to the action
Declaration Syntax
C# Visual Basic
public ActionData ActionData { get; set; }
Public Property ActionData As ActionData
    Get
    Set
Property Value
ActionData

Send comments on this topic to support@keyoti.com


Configuration Property

Configuration Property
API Documentation ► Keyoti.SearchEngine.Events ► ActionEventArgs ► Configuration
Keyoti SearchUnit v6
The configuration in use.
Declaration Syntax
C# Visual Basic
public Configuration Configuration { get; }
Public ReadOnly Property Configuration As Configuration
    Get
Property Value
Configuration

Send comments on this topic to support@keyoti.com


ActionEventHandler Delegate

ActionEventHandler Delegate
API Documentation ► Keyoti.SearchEngine.Events ► ActionEventHandler
Keyoti SearchUnit v6
Handler signature for action events
Declaration Syntax
C# Visual Basic
public delegate void ActionEventHandler(
    Object sender,
    ActionEventArgs e
)
Public Delegate Sub ActionEventHandler (
    sender As Object,
    e As ActionEventArgs
)
Parameters
sender (Object)
e (ActionEventArgs)


ActionName Enumeration

ActionName Enumeration
API Documentation ► Keyoti.SearchEngine.Events ► ActionName
Keyoti SearchUnit v6
The name of the action which caused the event.
Declaration Syntax
C# Visual Basic
public enum ActionName
Public Enumeration ActionName
Members
Member | Description
AutoAssignContent | The content category for a document was auto assigned, Data contains DocumentRecord object.
AutoAssignLocation | The location category for a document was auto assigned, Data contains DocumentRecord object.
AutoAssignSecurityGroup | The security group a document was auto assigned to, Data contains DocumentRecord object.
AutoCompleteSuggestionsGenerated | The autocomplete suggestions have been generated, Data contains an ArrayList of SuggestionResultPair objects, the sender of this event is SearchBoxAutoCompleteHelper and it has properties 'Query' and 'Segments' which may be of use - NOTE that this event is only fired when SearchBox.AutoCompleteQueryLoadPlugin is true.
CalculateWordRelevancies | The words have been read from a document that is being indexed and each word has been assigned a weight, Data contains WordCollection from Document.CalculateWordRelevancies method argument.
DocumentBeingCrawled | The crawlable links in a document are being processed, Data contains a 2 element object array - the 1st element is the Document object being crawled, and the 2nd element is an ArrayList of Uri objects found as links in the Document.
DocumentImporterAddedDocument | A document has been imported to an indexable source, Data contains AddDocumentEventArgs object.
DocumentImporterAddingDocument | A document is about to be imported from an indexable source, Data contains AddDocumentEventArgs object, which has a Cancel property to enable canceling of this action.
DocumentIndexBuild | The index has been built, Data is null/nothing.
DocumentIndexed | A document has been indexed, Data is the Document object.
DiscoveredLinkedURLs | New URLs have been found by reading document links, Data contains an ArrayList of string objects (the link URLs), which may not be changed.
DiscoverLinkedURLs | New URLs have been found by reading document links, Data contains an ArrayList of string objects (the link URLs).
GetIndexableSourceRecords | The data-access layer is returning a list of IndexableSourceRecords. Note that changing the list may make the search engine unstable - as any CRUD operations on the indexable source record table may not reflect changes made during this event, handle NeedObject for XmlIndexableSourceRecordTable instead.
GetWordVariations | Variations (typically lemmas via stemming) of a word are required. Data contains a 2 element object array; first element is a Word object for the word that variations are needed for, and the second element is an ArrayList of strings holding the variations. The second element can be modified as desired.
ImportStarted | An import operation has started, Data contains the IndexableSourceRecord instance that is being imported.
ImportFinished | An import operation has ended, Data contains either an ArrayList of Uri objects that were imported, or if an exception occurred, it contains an Exception object.
IsDocumentToBeCrawled | The document has been checked to see if it will be crawled, Data contains IsDocumentToBeCrawledEventData and the WillCrawl property may be changed.
IsDocumentToBeIndexed | The document has been checked to see if it will be crawled, Data contains IsDocumentToBeIndexedEventData and WillIndex property may be changed.
IsFileSystemDocumentToBeIndexed | A document, found during a file system import is about to be indexed, Data contains IsFileSystemDocumentToBeIndexedEventData and WillIndex property may be changed.
IsResultCustomDataFilteredThrough | Whether a ResultItem should be included in the search results, Data contains CustomDataFilterActionData and its IsFilteredThrough property may be changed.
QueryExpressionGroupCreated | The raw query text has been parsed in to a GroupElement object, Data contains the GroupElement object which may be changed.
ReadLinks | The links in a document have been read, Data contains ArrayList of URL strings.
ReadingText | The text in a document has been parsed and is about to be weighted, use this event to modify the document text before it's weighted, Data contains DocumentText object.
ReadText | The text in a document has been read and weighted, Data contains DocumentText object.
RequestingUri | A HttpWebRequest object has been created and is about to be sent for a response from the server, Data contains the HttpWebRequest which can be modified.
ResponseFromServerReceived | A HttpWebResponse object has been created from a response from the server, Data contains the HttpWebResponse.
ResultItemsFinalized | The search result items have been found and sorted, Data contains an ResultItemList of ResultItem objects - the order and content of which may be changed. Ideal for result filtering.
ResultPreviewTextLoaded | The result preview text has been loaded, Data contains a StringBuilder containing the document text, the StringBuilder is modifiable when handling this event, use (sender as SearchResultPreviewHelper).Uri to get the document Uri.
SearchBegin | A search is beginning, the parameters are known and may be modified, Data contains the SearchParameters object with the query etc.
UseDocumentEncoding | The Encoding of a document is about to be used, Data contains the Document - the Encoding property may be read and/or set to the required value.


CentralEventDispatcher Class

CentralEventDispatcher Class
API Documentation ► Keyoti.SearchEngine.Events ► CentralEventDispatcher
Keyoti SearchUnit v6
Dispatches events from various source classes to direct handlers and plug-in DLLs (Configuration.EventHandlerAssemblyPath).
Declaration Syntax
C# Visual Basic
public class CentralEventDispatcher : IEventDispatcher
Public Class CentralEventDispatcher
    Implements IEventDispatcher
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CentralEventDispatcher(Configuration) | New instance
 | Action | Event fired when an action is being performed.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InitializationProblems | User friendly message explaining any problems during initialization.
 | Initialized | Whether the plug-in DLL initialized without a problem.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NeedObject | Event fired when the search engine needs a new object.
 | RaiseAction(Object, ActionEventArgs) | Raises the Action event
 | RaiseNeedObject(Object, NeedObjectEventArgs) | Raises the need object event for an event source
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
CentralEventDispatcher

Send comments on this topic to support@keyoti.com


CentralEventDispatcher Constructor (configuration)

CentralEventDispatcher Constructor (configuration)
API Documentation ► Keyoti.SearchEngine.Events ► CentralEventDispatcher ► CentralEventDispatcher(Configuration)
Keyoti SearchUnit v6
New instance
Declaration Syntax
C# Visual Basic
public CentralEventDispatcher(
    Configuration configuration
)
Public Sub New (
    configuration As Configuration
)
Parameters
configuration (Configuration)
The configuration to use.


Action Event

Action Event
API Documentation ► Keyoti.SearchEngine.Events ► CentralEventDispatcher ► Action
Keyoti SearchUnit v6
Event fired when an action is being performed.
Declaration Syntax
C# Visual Basic
public event ActionEventHandler Action
Public Event Action As ActionEventHandler
Value
ActionEventHandler
Remarks
Provides a mechanism to customize behavior and data


InitializationProblems Property

InitializationProblems Property
API Documentation ► Keyoti.SearchEngine.Events ► CentralEventDispatcher ► InitializationProblems
Keyoti SearchUnit v6
User friendly message explaining any problems during initialization.
Declaration Syntax
C# Visual Basic
public string InitializationProblems { get; }
Public ReadOnly Property InitializationProblems As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


Initialized Property

Initialized Property
API Documentation ► Keyoti.SearchEngine.Events ► CentralEventDispatcher ► Initialized
Keyoti SearchUnit v6
Whether the plug-in DLL initialized without a problem.
Declaration Syntax
C# Visual Basic
public bool Initialized { get; }
Public ReadOnly Property Initialized As Boolean
    Get
Property Value
Boolean

Send comments on this topic to support@keyoti.com


NeedObject Event

NeedObject Event
API Documentation ► Keyoti.SearchEngine.Events ► CentralEventDispatcher ► NeedObject
Keyoti SearchUnit v6
Event fired when the search engine needs a new object.
Declaration Syntax
C# Visual Basic
public event NeedObjectEventHandler NeedObject
Public Event NeedObject As NeedObjectEventHandler
Value
NeedObjectEventHandler
Remarks
Provides a mechanism by which subclasses can be injected


RaiseAction Method (sender, args)

RaiseAction Method (sender, args)
API Documentation ► Keyoti.SearchEngine.Events ► CentralEventDispatcher ► RaiseAction(Object, ActionEventArgs)
Keyoti SearchUnit v6
Raises the Action event
Declaration Syntax
C# Visual Basic
public virtual void RaiseAction(
    Object sender,
    ActionEventArgs args
)
Public Overridable Sub RaiseAction (
    sender As Object,
    args As ActionEventArgs
)
Parameters
sender (Object)
args (ActionEventArgs)


RaiseNeedObject Method (sender, args)

RaiseNeedObject Method (sender, args)
API Documentation ► Keyoti.SearchEngine.Events ► CentralEventDispatcher ► RaiseNeedObject(Object, NeedObjectEventArgs)
Keyoti SearchUnit v6
Raises the need object event for an event source
Declaration Syntax
C# Visual Basic
public virtual Object RaiseNeedObject(
    Object sender,
    NeedObjectEventArgs args
)
Public Overridable Function RaiseNeedObject (
    sender As Object,
    args As NeedObjectEventArgs
) As Object
Parameters
sender (Object)
args (NeedObjectEventArgs)
Return Value
Object

Send comments on this topic to support@keyoti.com


CentralizedInternalEventNotifier Class

CentralizedInternalEventNotifier Class
API Documentation ► Keyoti.SearchEngine.Events ► CentralizedInternalEventNotifier
Keyoti SearchUnit v6
Used by INotifyAction and INotifyNeedObject objects to fire Action and NeedObject events.
Declaration Syntax
C# Visual Basic
public class CentralizedInternalEventNotifier
Public Class CentralizedInternalEventNotifier
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CentralizedInternalEventNotifier()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnAction(Object, ActionEventArgs) | Raises the Action event
 | OnNeedObject(Object, NeedObjectEventArgs) | Raises the NeedObject event
 | Register(CentralEventDispatcher) | Registers the dispatcher.
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
CentralizedInternalEventNotifier

Send comments on this topic to support@keyoti.com


CentralizedInternalEventNotifier Constructor

CentralizedInternalEventNotifier Constructor
API Documentation ► Keyoti.SearchEngine.Events ► CentralizedInternalEventNotifier ► CentralizedInternalEventNotifier()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public CentralizedInternalEventNotifier()
Public Sub New

Send comments on this topic to support@keyoti.com


OnAction Method (sender, args)

OnAction Method (sender, args)
API Documentation ► Keyoti.SearchEngine.Events ► CentralizedInternalEventNotifier ► OnAction(Object, ActionEventArgs)
Keyoti SearchUnit v6
Raises the Action event
Declaration Syntax
C# Visual Basic
public virtual void OnAction(
    Object sender,
    ActionEventArgs args
)
Public Overridable Sub OnAction (
    sender As Object,
    args As ActionEventArgs
)
Parameters
sender (Object)
args (ActionEventArgs)


OnNeedObject Method (sender, args)

OnNeedObject Method (sender, args)
API Documentation ► Keyoti.SearchEngine.Events ► CentralizedInternalEventNotifier ► OnNeedObject(Object, NeedObjectEventArgs)
Keyoti SearchUnit v6
Raises the NeedObject event
Declaration Syntax
C# Visual Basic
public virtual Object OnNeedObject(
    Object sender,
    NeedObjectEventArgs args
)
Public Overridable Function OnNeedObject (
    sender As Object,
    args As NeedObjectEventArgs
) As Object
Parameters
sender (Object)
args (NeedObjectEventArgs)
Return Value
Object
The object set in RequiredObject property of the event args.


Register Method (dispatcher)

Register Method (dispatcher)
API Documentation ► Keyoti.SearchEngine.Events ► CentralizedInternalEventNotifier ► Register(CentralEventDispatcher)
Keyoti SearchUnit v6
Registers the dispatcher.
Declaration Syntax
C# Visual Basic
public void Register(
    CentralEventDispatcher dispatcher
)
Public Sub Register (
    dispatcher As CentralEventDispatcher
)
Parameters
dispatcher (CentralEventDispatcher)


IEventDispatcher Interface

IEventDispatcher Interface
API Documentation ► Keyoti.SearchEngine.Events ► IEventDispatcher
Keyoti SearchUnit v6
A dispatcher of central events
Declaration Syntax
C# Visual Basic
public interface IEventDispatcher
Public Interface IEventDispatcher
Members
All Members | Events
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Action | Event fired when an action is being performed.
 | NeedObject | Event fired when the search engine needs a new object.


Action Event

Action Event
API Documentation ► Keyoti.SearchEngine.Events ► IEventDispatcher ► Action
Keyoti SearchUnit v6
Event fired when an action is being performed.
Declaration Syntax
C# Visual Basic
event ActionEventHandler Action
Event Action As ActionEventHandler
Value
ActionEventHandler
Remarks
Provides a mechanism to customize behavior and data


NeedObject Event

NeedObject Event
API Documentation ► Keyoti.SearchEngine.Events ► IEventDispatcher ► NeedObject
Keyoti SearchUnit v6
Event fired when the search engine needs a new object.
Declaration Syntax
C# Visual Basic
event NeedObjectEventHandler NeedObject
Event NeedObject As NeedObjectEventHandler
Value
NeedObjectEventHandler
Remarks
Provides a mechanism by which subclasses can be injected


IsDocumentToBeCrawledEventData Class

IsDocumentToBeCrawledEventData Class
API Documentation ► Keyoti.SearchEngine.Events ► IsDocumentToBeCrawledEventData
Keyoti SearchUnit v6
Data for the IsDocumentToBeCrawled event.
Declaration Syntax
C# Visual Basic
public class IsDocumentToBeCrawledEventData
Public Class IsDocumentToBeCrawledEventData
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IsDocumentToBeCrawledEventData(Boolean, Document, ArrayList, ArrayList, String) | Creates a new instance
 | Document | The document.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ParentUri | The Uri of the document that had the link to this document.
 | PathMatchesToBeIgnored | Path matches that the user has requested be ignored
 | PathMatchesToBeIncluded | Path matches that the user has requested be exclusively included
 | ToString()()()() | (Inherited from Object.)
 | WillCrawl | Whether the document will be crawled
Inheritance Hierarchy
Object
IsDocumentToBeCrawledEventData

Send comments on this topic to support@keyoti.com


IsDocumentToBeCrawledEventData Constructor (isDocumentToBeCrawled, document, pathMatchesToBeIgnored, pathMatchesToBeIncluded, parentUri)

IsDocumentToBeCrawledEventData Constructor (isDocumentToBeCrawled, document, pathMatchesToBeIgnored, pathMatchesToBeIncluded, parentUri)
API Documentation ► Keyoti.SearchEngine.Events ► IsDocumentToBeCrawledEventData ► IsDocumentToBeCrawledEventData(Boolean, Document, ArrayList, ArrayList, String)
Keyoti SearchUnit v6
Creates a new instance
Declaration Syntax
C# Visual Basic
public IsDocumentToBeCrawledEventData(
    bool isDocumentToBeCrawled,
    Document document,
    ArrayList pathMatchesToBeIgnored,
    ArrayList pathMatchesToBeIncluded,
    string parentUri
)
Public Sub New (
    isDocumentToBeCrawled As Boolean,
    document As Document,
    pathMatchesToBeIgnored As ArrayList,
    pathMatchesToBeIncluded As ArrayList,
    parentUri As String
)
Parameters
isDocumentToBeCrawled (Boolean)
document (Document)
pathMatchesToBeIgnored (ArrayList)
pathMatchesToBeIncluded (ArrayList)
parentUri (String)


Document Property

Document Property
API Documentation ► Keyoti.SearchEngine.Events ► IsDocumentToBeCrawledEventData ► Document
Keyoti SearchUnit v6
The document.
Declaration Syntax
C# Visual Basic
public Document Document { get; }
Public ReadOnly Property Document As Document
    Get
Property Value
Document

Send comments on this topic to support@keyoti.com


ParentUri Property

ParentUri Property
API Documentation ► Keyoti.SearchEngine.Events ► IsDocumentToBeCrawledEventData ► ParentUri
Keyoti SearchUnit v6
The Uri of the document that had the link to this document.
Declaration Syntax
C# Visual Basic
public string ParentUri { get; }
Public ReadOnly Property ParentUri As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


PathMatchesToBeIgnored Property

PathMatchesToBeIgnored Property
API Documentation ► Keyoti.SearchEngine.Events ► IsDocumentToBeCrawledEventData ► PathMatchesToBeIgnored
Keyoti SearchUnit v6
Path matches that the user has requested be ignored
Declaration Syntax
C# Visual Basic
public ArrayList PathMatchesToBeIgnored { get; }
Public ReadOnly Property PathMatchesToBeIgnored As ArrayList
    Get
Property Value
ArrayList

Send comments on this topic to support@keyoti.com


PathMatchesToBeIncluded Property

PathMatchesToBeIncluded Property
API Documentation ► Keyoti.SearchEngine.Events ► IsDocumentToBeCrawledEventData ► PathMatchesToBeIncluded
Keyoti SearchUnit v6
Path matches that the user has requested be exclusively included
Declaration Syntax
C# Visual Basic
public ArrayList PathMatchesToBeIncluded { get; }
Public ReadOnly Property PathMatchesToBeIncluded As ArrayList
    Get
Property Value
ArrayList

Send comments on this topic to support@keyoti.com


WillCrawl Property

WillCrawl Property
API Documentation ► Keyoti.SearchEngine.Events ► IsDocumentToBeCrawledEventData ► WillCrawl
Keyoti SearchUnit v6
Whether the document will be crawled
Declaration Syntax
C# Visual Basic
public bool WillCrawl { get; set; }
Public Property WillCrawl As Boolean
    Get
    Set
Property Value
Boolean

Send comments on this topic to support@keyoti.com


IsDocumentToBeIndexedEventData Class

IsDocumentToBeIndexedEventData Class
API Documentation ► Keyoti.SearchEngine.Events ► IsDocumentToBeIndexedEventData
Keyoti SearchUnit v6
Data for the IsDocumentToBeIndexed event.
Declaration Syntax
C# Visual Basic
public class IsDocumentToBeIndexedEventData
Public Class IsDocumentToBeIndexedEventData
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IsDocumentToBeIndexedEventData(Boolean, Document) | New instance
 | Document | The document in question
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | WillIndex | Whether the document will be indexed
Inheritance Hierarchy
Object
IsDocumentToBeIndexedEventData

Send comments on this topic to support@keyoti.com


IsDocumentToBeIndexedEventData Constructor (willIndex, document)

IsDocumentToBeIndexedEventData Constructor (willIndex, document)
API Documentation ► Keyoti.SearchEngine.Events ► IsDocumentToBeIndexedEventData ► IsDocumentToBeIndexedEventData(Boolean, Document)
Keyoti SearchUnit v6
New instance
Declaration Syntax
C# Visual Basic
public IsDocumentToBeIndexedEventData(
    bool willIndex,
    Document document
)
Public Sub New (
    willIndex As Boolean,
    document As Document
)
Parameters
willIndex (Boolean)
document (Document)


Document Property

Document Property
API Documentation ► Keyoti.SearchEngine.Events ► IsDocumentToBeIndexedEventData ► Document
Keyoti SearchUnit v6
The document in question
Declaration Syntax
C# Visual Basic
public Document Document { get; }
Public ReadOnly Property Document As Document
    Get
Property Value
Document

Send comments on this topic to support@keyoti.com


WillIndex Property

WillIndex Property
API Documentation ► Keyoti.SearchEngine.Events ► IsDocumentToBeIndexedEventData ► WillIndex
Keyoti SearchUnit v6
Whether the document will be indexed
Declaration Syntax
C# Visual Basic
public bool WillIndex { get; set; }
Public Property WillIndex As Boolean
    Get
    Set
Property Value
Boolean

Send comments on this topic to support@keyoti.com


IsFileSystemDocumentToBeIndexedEventData Class

IsFileSystemDocumentToBeIndexedEventData Class
API Documentation ► Keyoti.SearchEngine.Events ► IsFileSystemDocumentToBeIndexedEventData
Keyoti SearchUnit v6
Data for the IsFileSystemDocumentToBeIndexed event.
Declaration Syntax
C# Visual Basic
public class IsFileSystemDocumentToBeIndexedEventData
Public Class IsFileSystemDocumentToBeIndexedEventData
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IsFileSystemDocumentToBeIndexedEventData(Boolean, String, String) | New instance
 | Equals(Object) | (Inherited from Object.)
 | FileSystemPath | The URL of the document in question
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | Url | The URL of the document in question
 | WillIndex | Whether the document will be indexed
Inheritance Hierarchy
Object
IsFileSystemDocumentToBeIndexedEventData

Send comments on this topic to support@keyoti.com


IsFileSystemDocumentToBeIndexedEventData Constructor (willIndex, fileSystemPath, url)

IsFileSystemDocumentToBeIndexedEventData Constructor (willIndex, fileSystemPath, url)
API Documentation ► Keyoti.SearchEngine.Events ► IsFileSystemDocumentToBeIndexedEventData ► IsFileSystemDocumentToBeIndexedEventData(Boolean, String, String)
Keyoti SearchUnit v6
New instance
Declaration Syntax
C# Visual Basic
public IsFileSystemDocumentToBeIndexedEventData(
    bool willIndex,
    string fileSystemPath,
    string url
)
Public Sub New (
    willIndex As Boolean,
    fileSystemPath As String,
    url As String
)
Parameters
willIndex (Boolean)
Whether to index the document.
fileSystemPath (String)
The file system based path to the document.The URL of the document.
url (String)


FileSystemPath Property

FileSystemPath Property
API Documentation ► Keyoti.SearchEngine.Events ► IsFileSystemDocumentToBeIndexedEventData ► FileSystemPath
Keyoti SearchUnit v6
The URL of the document in question
Declaration Syntax
C# Visual Basic
public string FileSystemPath { get; }
Public ReadOnly Property FileSystemPath As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


Url Property

Url Property
API Documentation ► Keyoti.SearchEngine.Events ► IsFileSystemDocumentToBeIndexedEventData ► Url
Keyoti SearchUnit v6
The URL of the document in question
Declaration Syntax
C# Visual Basic
public string Url { get; }
Public ReadOnly Property Url As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


WillIndex Property

WillIndex Property
API Documentation ► Keyoti.SearchEngine.Events ► IsFileSystemDocumentToBeIndexedEventData ► WillIndex
Keyoti SearchUnit v6
Whether the document will be indexed
Declaration Syntax
C# Visual Basic
public bool WillIndex { get; set; }
Public Property WillIndex As Boolean
    Get
    Set
Property Value
Boolean

Send comments on this topic to support@keyoti.com


NeedObjectEventArgs Class

NeedObjectEventArgs Class
API Documentation ► Keyoti.SearchEngine.Events ► NeedObjectEventArgs
Keyoti SearchUnit v6
Event argument for the NeedObject event.
Declaration Syntax
C# Visual Basic
public class NeedObjectEventArgs : EventArgs
Public Class NeedObjectEventArgs
    Inherits EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NeedObjectEventArgs(Object, Configuration) | New instance.
 | Configuration | The configuration being used.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | RequiredObject | Holds an object of the type that is needed.
 | ToString()()()() | (Inherited from Object.)
Remarks
RequiredObject holds an object of the type that is needed. Whatever object is set in RequiredObject will be used. This means that the RequiredObject can be left-alone, modified or replaced with a new instance (subclass for example).
Inheritance Hierarchy
Object
 | EventArgs
 |  | NeedObjectEventArgs


NeedObjectEventArgs Constructor (requiredObject, currentConfiguration)

NeedObjectEventArgs Constructor (requiredObject, currentConfiguration)
API Documentation ► Keyoti.SearchEngine.Events ► NeedObjectEventArgs ► NeedObjectEventArgs(Object, Configuration)
Keyoti SearchUnit v6
New instance.
Declaration Syntax
C# Visual Basic
public NeedObjectEventArgs(
    Object requiredObject,
    Configuration currentConfiguration
)
Public Sub New (
    requiredObject As Object,
    currentConfiguration As Configuration
)
Parameters
requiredObject (Object)
currentConfiguration (Configuration)


Configuration Property

Configuration Property
API Documentation ► Keyoti.SearchEngine.Events ► NeedObjectEventArgs ► Configuration
Keyoti SearchUnit v6
The configuration being used.
Declaration Syntax
C# Visual Basic
public Configuration Configuration { get; }
Public ReadOnly Property Configuration As Configuration
    Get
Property Value
Configuration

Send comments on this topic to support@keyoti.com


RequiredObject Property

RequiredObject Property
API Documentation ► Keyoti.SearchEngine.Events ► NeedObjectEventArgs ► RequiredObject
Keyoti SearchUnit v6
Holds an object of the type that is needed.
Declaration Syntax
C# Visual Basic
public Object RequiredObject { get; set; }
Public Property RequiredObject As Object
    Get
    Set
Property Value
Object

Send comments on this topic to support@keyoti.com


NeedObjectEventHandler Delegate

NeedObjectEventHandler Delegate
API Documentation ► Keyoti.SearchEngine.Events ► NeedObjectEventHandler
Keyoti SearchUnit v6
Handler signature for need object events
Declaration Syntax
C# Visual Basic
public delegate void NeedObjectEventHandler(
    Object sender,
    NeedObjectEventArgs e
)
Public Delegate Sub NeedObjectEventHandler (
    sender As Object,
    e As NeedObjectEventArgs
)
Parameters
sender (Object)
e (NeedObjectEventArgs)


SearchParameters Class

SearchParameters Class
API Documentation ► Keyoti.SearchEngine.Events ► SearchParameters
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public class SearchParameters
Public Class SearchParameters
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SearchParameters(String, SearchOptions, Int32, Int32) | New
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HighRange | The highest result number to return (1 based)
 | LowRange | The lowest result number to return (1 based)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | QueryExpression | The expression to search for
 | SearchOptions | Search options
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
SearchParameters

Send comments on this topic to support@keyoti.com


SearchParameters Constructor (queryExpression, searchOptions, lowRange, highRange)

SearchParameters Constructor (queryExpression, searchOptions, lowRange, highRange)
API Documentation ► Keyoti.SearchEngine.Events ► SearchParameters ► SearchParameters(String, SearchOptions, Int32, Int32)
Keyoti SearchUnit v6
New
Declaration Syntax
C# Visual Basic
public SearchParameters(
    string queryExpression,
    SearchOptions searchOptions,
    int lowRange,
    int highRange
)
Public Sub New (
    queryExpression As String,
    searchOptions As SearchOptions,
    lowRange As Integer,
    highRange As Integer
)
Parameters
queryExpression (String)
The expression to search for
searchOptions (SearchOptions)
Search options
lowRange (Int32)
The lowest result number to return (1 based)
highRange (Int32)
The highest result number to return (1 based)


HighRange Property

HighRange Property
API Documentation ► Keyoti.SearchEngine.Events ► SearchParameters ► HighRange
Keyoti SearchUnit v6
The highest result number to return (1 based)
Declaration Syntax
C# Visual Basic
public int HighRange { get; set; }
Public Property HighRange As Integer
    Get
    Set
Property Value
Int32

Send comments on this topic to support@keyoti.com


LowRange Property

LowRange Property
API Documentation ► Keyoti.SearchEngine.Events ► SearchParameters ► LowRange
Keyoti SearchUnit v6
The lowest result number to return (1 based)
Declaration Syntax
C# Visual Basic
public int LowRange { get; set; }
Public Property LowRange As Integer
    Get
    Set
Property Value
Int32

Send comments on this topic to support@keyoti.com


QueryExpression Property

QueryExpression Property
API Documentation ► Keyoti.SearchEngine.Events ► SearchParameters ► QueryExpression
Keyoti SearchUnit v6
The expression to search for
Declaration Syntax
C# Visual Basic
public string QueryExpression { get; set; }
Public Property QueryExpression As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


SearchOptions Property

SearchOptions Property
API Documentation ► Keyoti.SearchEngine.Events ► SearchParameters ► SearchOptions
Keyoti SearchUnit v6
Search options
Declaration Syntax
C# Visual Basic
public SearchOptions SearchOptions { get; set; }
Public Property SearchOptions As SearchOptions
    Get
    Set
Property Value
SearchOptions

Send comments on this topic to support@keyoti.com


Keyoti.SearchEngine.Index Namespace

Keyoti.SearchEngine.Index Namespace
API Documentation ► Keyoti.SearchEngine.Index
Keyoti SearchUnit v6
Classes for building the index.

Main indexing classes

Types
All Types Classes Delegates
Icon | Type | Description
 | AsynchronousQueue | Queues and runs operations such as AddDocument asynchronously, use the static methods, not a constructor.
 | DocumentIndex | Represents the document index, and provides functionality for building the index, and adding/removing documents.
 | IndexLockedException | Exception indicating that the index is locked.
 | ReaderExceptionOccurredEventHandler | Specifies a method that handles ReaderExceptionOccured events
 | StartUrlCannotBeReadException | Thrown by crawler when the start URL cannot be read, typically because of a network exception.
 | State | The state of the index.


AsynchronousQueue Class

AsynchronousQueue Class
API Documentation ► Keyoti.SearchEngine.Index ► AsynchronousQueue
Keyoti SearchUnit v6
Queues and runs operations such as AddDocument asynchronously, use the static methods, not a constructor.
Declaration Syntax
C# Visual Basic
public class AsynchronousQueue
Public Class AsynchronousQueue
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | QueueForIndexing(Document, EventHandler) | Adds the document to the queue for adding to the index - the document will be indexed asynchronously as soon as possible.
 | QueueSize | Current queue size (remaining items).
 | ToString()()()() | (Inherited from Object.)
Remarks
This class will create and close a DocumentIndex instance as required, it is important therefore that no other DocumentIndex instance is open on the same index directory while the queue has items.

Typical usage is to call AsynchronousQueue.QueueForIndexing with the document and an EventHandler delegate, please see the Help example on programmatic importing.

Inheritance Hierarchy
Object
AsynchronousQueue

Send comments on this topic to support@keyoti.com


QueueForIndexing Method (document, queueEmpty)

QueueForIndexing Method (document, queueEmpty)
API Documentation ► Keyoti.SearchEngine.Index ► AsynchronousQueue ► QueueForIndexing(Document, EventHandler)
Keyoti SearchUnit v6
Adds the document to the queue for adding to the index - the document will be indexed asynchronously as soon as possible.
Declaration Syntax
C# Visual Basic
public static void QueueForIndexing(
    Document document,
    EventHandler queueEmpty
)
Public Shared Sub QueueForIndexing (
    document As Document,
    queueEmpty As EventHandler
)
Parameters
document (Document)
The document.
queueEmpty (EventHandler)
Delegate called when the queue has been emptied, and the index directory unlocked.


QueueSize Property

QueueSize Property
API Documentation ► Keyoti.SearchEngine.Index ► AsynchronousQueue ► QueueSize
Keyoti SearchUnit v6
Current queue size (remaining items).
Declaration Syntax
C# Visual Basic
public int QueueSize { get; }
Public ReadOnly Property QueueSize As Integer
    Get
Property Value
Int32

Send comments on this topic to support@keyoti.com


DocumentIndex Class

DocumentIndex Class
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex
Keyoti SearchUnit v6
Represents the document index, and provides functionality for building the index, and adding/removing documents.
Declaration Syntax
C# Visual Basic
public class DocumentIndex
Public Class DocumentIndex
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DocumentIndex(Configuration) | Creates a new instance of the DocumentIndex class.
 | AddContent(ContentCategoryRecord) | Adds a content type to the index.
 | AddDocument(Document) | Adds the specified document to the index (synchronously).
 | AddedDocument | Fired when a document has been added to the index, providing an opportunity to cancel.
 | AddingDocument | Fired when a document is about to be added to the index, providing an opportunity to cancel.
 | AddLocation(LocationCategoryRecord) | Adds a new location to the index.
 | AddSecurityGroup(SecurityGroupRecord) | Add a new security group to the index.
 | AutoAssignDocumentContent(Boolean) | Automatically assigns the content category to documents.
 | AutoAssignDocumentLocation(Boolean) | Automatically assigns the location category to documents.
 | AutoAssignDocumentSecurityGroup(Boolean) | Automatically assigns the security groups to documents.
 | Cancel()()()() | When called, will stop the import.
 | Cancelled | Whether the build has been cancelled.
 | Close()()()() | Closes the index layer.
 | Closed | Fired when the document index is closed.
 | Configuration | The configuration
 | CreateNewDocument(DocumentRecord) | Called whenever a Document object is created, override this method to use Document subclasses.
 | CurrentAddingDocumentUrl | The Url of the document being added to the index.
 | DataAccess | The data-access layer, the type returned depends on the setting of Configuration.DbType.
 | DeleteDocument(String) | Convenience, calls RemoveDocument method. See remarks.
 | DeleteIndex(Boolean) | Deletes the contents of the index, by deleting the index files.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | Flush()()()() | Flushes any buffered operations out to the disk.
 | GetContentCategoryRecords()()()() | Gets all content category records from the index.
 | GetDocument(Uri) | Gets a Document from the data-access that has a URI equal to documentUri.
 | GetDocumentID(Uri) | Returns the document ID of the document specified by uri
 | GetDocumentsFromIndexableSource(IndexableSourceRecord) | Get's an ArrayList of Document objects belonging to (imported from) an IndexableSource.
 | GetHashCode()()()() | (Inherited from Object.)
 | GetImportSample(IndexableSourceRecord, DataSet, Int32, LinkBasedImportSampler..::..InvokeMethod) | Produces a sample DataTable of data that will be imported from the indexableSourceRecord using dataSource and places it in the DataSet ds as the first item.
 | GetIndexableSourceForRecord(IndexableSourceRecord) | Creates the IIndexableSource object (eg. DataSetBasedSource) for the specified indexableSourceRecord.
 | GetIndexableSourceRecord(SourceType, String, String) | Gets an IndexableSourceRecord from the index that matches the type, location and query.
 | GetIndexableSourceRecords()()()() | Gets a collection of indexable sources
 | GetIndexedDocuments()()()() | Gets all the indexed documents from the document table, as an ArrayList of Document objects
 | GetLastIndexDate()()()() | Obsolete. Return the date when last index was performed
 | GetLocationCategoryRecords()()()() | Gets all location category records from the index.
 | GetNumberOfDocumentsFromIndexableSource(IndexableSourceRecord) | Gets the number of documents that have been imported from the source
 | GetSecurityGroupRecord(String) | Gets all security group records from the index.
 | GetSecurityGroupRecords()()()() | Gets all security group records from the index.
 | GetState()()()() | Gets the state of the index.
 | GetType()()()() | (Inherited from Object.)
 | GetWordVariations(Word, Configuration) | Returns list of string objects with variations (lemmas) for a word, empty list if none found.
 | Import(IndexableSourceRecord) | Imports the documents from an indexable source into the document index and returns a collection of imported Uri objects.
 | Import(IndexableSourceRecord, IIndexableSource) | Imports the documents from an indexable source into the document index and returns a collection of imported Uri objects
 | ImportCustomDataSet(String, String, String, String) | Convenience method to import data from a DLL using the Import method.
 | ImportDatabase(SourceType, String, String, String, String) | Convenience method to import data from a database using the Import method.
 | ImportFileSystemFolder(String, String, ArrayList, ArrayList, Boolean) | Convenience method to import documents from a virtual folder using the Import method.
 | ImportSampleDataTableColumnsFinalized | Fired when the DataTable used for the import sample has it's columns finalized.
 | ImportWebsite(String) | Convenience method to crawl and import a website using the Import method.
 | IsClosed | Whether this object has been closed.
 | IsContentUsed(String) | Returns true if contentName is used by at least one document
 | IsDocumentToBeIndexed(Document) | Determines if a document should be indexed.
 | IsLocationUsed(String) | Returns true if locationName is used by at least one document
 | IsLocked()()()() | Whether the current index is locked (preventing operations other than search).
 | IsPaused | Whether the import is paused.
 | IsSecurityGroupUsed(String) | Returns true if the named security group is used by at least one document.
 | ItemsImported | The number of items (documents, records, files, etc) that have been imported since the last call to Import.
 | ItemsToImportTotal | If available, the total number of items (documents, records, files, etc) that will be imported, otherwise returns -1.
 | MarkIndexValid(Boolean) | Marks the current document index as valid or not.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OccurrenceCount | The number of occurrences indexed during the build.
 | OnImportSampleDataTableColumnsFinalized(EventArgs) | Called whenever a readerException is caught
 | OnReaderExceptionOccurred(ReaderExceptionOccurredEventArgs) | Called whenever a readerException is caught
 | Open()()()() | Obsolete. Opens the index for use.
 | Optimize()()()() | Reorganizes index files for optimal search speed.
 | OptimizeProgress | The current percent progress of the optimize operation. (0-100)
 | Pause()()()() | Pauses the import.
 | PercentItemsDeleted | The percentage of items (documents, records, files, etc) that have been delete since the last call to RemoveSource.
 | ReaderExceptionOccurred | Fired whenever the (web) reader encounters a network exception, eg. 404 (this can be useful for identifying dead links)
 | RegisterDataSetBasedSource(Int32, DataSetBasedSource) | Registers a DataSetBasedSource for use by the document reader.
 | ReimportIndexableSources()()()() | Reimports all indexed sources.
 | RemoveContent(String, Boolean) | Removes a content type from the index if the type is unused, otherwise throws an exception.
 | RemoveContent(String) | Removes a content type from the index if the type is unused, otherwise throws an exception.
 | RemoveDocument(Document) | Removes the document specified from the database. See remarks.
 | RemoveDocument(String) | Removes the document specified by its Uri from the database
 | RemoveLocation(String, Boolean) | Removes a location from the index if the location is unused, otherwise throws an exception.
 | RemoveLocation(String) | Removes a location from the index if the location is unused, otherwise throws an exception.
 | RemoveSecurityGroup(String) | Removes a security group from the index if the group is unused, otherwise throws an exception.
 | RemoveSecurityGroup(String, Boolean) | Removes a security group from the index if the group is unused, otherwise throws an exception.
 | RemoveSource(IndexableSourceRecord) | Removes the indexable data source passed as argument from database, and all of it's documents.
 | Resume()()()() | Resumes a paused import.
 | ToString()()()() | (Inherited from Object.)
 | UnlockIndexDirectory(String) | Forcefully unlocks the index directory specified. Only use if certain that other processes are not using the index.
 | UpdateDocument(DocumentRecord) | Obsolete. Updates the content/location categories stored for a document in the index
 | UpdateDocumentCategories(Document) | Updates location/content categories assigned in DocumentRecord to the index.
 | UpdateDocumentSecurityGroups(Document) | Updates the security group assigned in DocumentRecord to the index.
 | UpdateIndexableSourceRecord(IndexableSourceRecord) | Updates the IndexableSourceRecord in the index, the ID property must be set.
Remarks
This class imports records from any IndexableSource, represented by an IndexableSourceRecord. An IndexableSource can be a source of data such as;
  • Web-site - WebSiteBasedSourceRecord
  • MSSQL, Oracle, or OLE database - DatabaseBasedIndexableSourceRecord
  • File-system directory - FileSystemFolderBasedSourceRecord
  • Custom DataSet - CustomDataSetBasedIndexableSourceRecord
This class is typically used as;
Copy image Copy
documentIndex = new DocumentIndex(configuration)
documentIndex.Import(...)
documentIndex.Close()
The Import method can be used to either, import a new set of documents, or to update an existing set. For example, Import can be used first to import a web-site (which will be crawled). When it does this it saves the IndexableSourceRecord into the index. The IndexableSourceRecord can be passed to Import later and will cause the method to update the source (adding new documents and removing now missing documents).
Inheritance Hierarchy
Object
DocumentIndex

Send comments on this topic to support@keyoti.com


DocumentIndex Constructor (configuration)

DocumentIndex Constructor (configuration)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► DocumentIndex(Configuration)
Keyoti SearchUnit v6
Creates a new instance of the DocumentIndex class.
Declaration Syntax
C# Visual Basic
public DocumentIndex(
    Configuration configuration
)
Public Sub New (
    configuration As Configuration
)
Parameters
configuration (Configuration)
The instance of the Configuration class that holds the settings to be used.


AddContent Method (content)

AddContent Method (content)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► AddContent(ContentCategoryRecord)
Keyoti SearchUnit v6
Adds a content type to the index.
Declaration Syntax
C# Visual Basic
public virtual void AddContent(
    ContentCategoryRecord content
)
Public Overridable Sub AddContent (
    content As ContentCategoryRecord
)
Parameters
content (ContentCategoryRecord)
The content category

Send comments on this topic to support@keyoti.com


AddDocument Method (document)

AddDocument Method (document)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► AddDocument(Document)
Keyoti SearchUnit v6
Adds the specified document to the index (synchronously).
Declaration Syntax
C# Visual Basic
public virtual void AddDocument(
    Document document
)
Public Overridable Sub AddDocument (
    document As Document
)
Parameters
document (Document)


AddedDocument Event

AddedDocument Event
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► AddedDocument
Keyoti SearchUnit v6
Fired when a document has been added to the index, providing an opportunity to cancel.
Declaration Syntax
C# Visual Basic
public event AddDocumentEventHandler AddedDocument
Public Event AddedDocument As AddDocumentEventHandler
Value
AddDocumentEventHandler

Send comments on this topic to support@keyoti.com


AddingDocument Event

AddingDocument Event
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► AddingDocument
Keyoti SearchUnit v6
Fired when a document is about to be added to the index, providing an opportunity to cancel.
Declaration Syntax
C# Visual Basic
public event AddDocumentEventHandler AddingDocument
Public Event AddingDocument As AddDocumentEventHandler
Value
AddDocumentEventHandler

Send comments on this topic to support@keyoti.com


AddLocation Method (locationCategory)

AddLocation Method (locationCategory)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► AddLocation(LocationCategoryRecord)
Keyoti SearchUnit v6
Adds a new location to the index.
Declaration Syntax
C# Visual Basic
public virtual void AddLocation(
    LocationCategoryRecord locationCategory
)
Public Overridable Sub AddLocation (
    locationCategory As LocationCategoryRecord
)
Parameters
locationCategory (LocationCategoryRecord)


AddSecurityGroup Method (record)

AddSecurityGroup Method (record)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► AddSecurityGroup(SecurityGroupRecord)
Keyoti SearchUnit v6
Add a new security group to the index.
Declaration Syntax
C# Visual Basic
public void AddSecurityGroup(
    SecurityGroupRecord record
)
Public Sub AddSecurityGroup (
    record As SecurityGroupRecord
)
Parameters
record (SecurityGroupRecord)


AutoAssignDocumentContent Method (onlyUnassigned)

AutoAssignDocumentContent Method (onlyUnassigned)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► AutoAssignDocumentContent(Boolean)
Keyoti SearchUnit v6
Automatically assigns the content category to documents.
Declaration Syntax
C# Visual Basic
public virtual void AutoAssignDocumentContent(
    bool onlyUnassigned
)
Public Overridable Sub AutoAssignDocumentContent (
    onlyUnassigned As Boolean
)
Parameters
onlyUnassigned (Boolean)
If true, only assigns a category when one (other than default) is not already set.
Remarks
Uses any plug-in assembly.


AutoAssignDocumentLocation Method (onlyUnassigned)

AutoAssignDocumentLocation Method (onlyUnassigned)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► AutoAssignDocumentLocation(Boolean)
Keyoti SearchUnit v6
Automatically assigns the location category to documents.
Declaration Syntax
C# Visual Basic
public virtual void AutoAssignDocumentLocation(
    bool onlyUnassigned
)
Public Overridable Sub AutoAssignDocumentLocation (
    onlyUnassigned As Boolean
)
Parameters
onlyUnassigned (Boolean)
If true, only assigns a category when one (other than default) is not already set.
Remarks
Uses the Location category root and any plug-in assembly.


AutoAssignDocumentSecurityGroup Method (onlyUnassigned)

AutoAssignDocumentSecurityGroup Method (onlyUnassigned)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► AutoAssignDocumentSecurityGroup(Boolean)
Keyoti SearchUnit v6
Automatically assigns the security groups to documents.
Declaration Syntax
C# Visual Basic
public void AutoAssignDocumentSecurityGroup(
    bool onlyUnassigned
)
Public Sub AutoAssignDocumentSecurityGroup (
    onlyUnassigned As Boolean
)
Parameters
onlyUnassigned (Boolean)
If true, only assigns when one (other than default) is not already set.
Remarks
Uses the security group root and any plug-in assembly.


Cancel Method

Cancel Method
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► Cancel()()()()
Keyoti SearchUnit v6
When called, will stop the import.
Declaration Syntax
C# Visual Basic
public void Cancel()
Public Sub Cancel

Send comments on this topic to support@keyoti.com


Cancelled Property

Cancelled Property
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► Cancelled
Keyoti SearchUnit v6
Whether the build has been cancelled.
Declaration Syntax
C# Visual Basic
public bool Cancelled { get; }
Public ReadOnly Property Cancelled As Boolean
    Get
Property Value
Boolean

Send comments on this topic to support@keyoti.com


Close Method

Close Method
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► Close()()()()
Keyoti SearchUnit v6
Closes the index layer.
Declaration Syntax
C# Visual Basic
public virtual void Close()
Public Overridable Sub Close

Send comments on this topic to support@keyoti.com


Closed Event

Closed Event
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► Closed
Keyoti SearchUnit v6
Fired when the document index is closed.
Declaration Syntax
C# Visual Basic
public event EventHandler Closed
Public Event Closed As EventHandler
Value
EventHandler

Send comments on this topic to support@keyoti.com


Configuration Property

Configuration Property
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► Configuration
Keyoti SearchUnit v6
The configuration
Declaration Syntax
C# Visual Basic
public Configuration Configuration { get; }
Public ReadOnly Property Configuration As Configuration
    Get
Property Value
Configuration

Send comments on this topic to support@keyoti.com


CreateNewDocument Method (documentRecord)

CreateNewDocument Method (documentRecord)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► CreateNewDocument(DocumentRecord)
Keyoti SearchUnit v6
Called whenever a Document object is created, override this method to use Document subclasses.
Declaration Syntax
C# Visual Basic
protected virtual Document CreateNewDocument(
    DocumentRecord documentRecord
)
Protected Overridable Function CreateNewDocument (
    documentRecord As DocumentRecord
) As Document
Parameters
documentRecord (DocumentRecord)
The data-access layer document record.
Return Value
Document
A new Document (or subclass of)


CurrentAddingDocumentUrl Property

CurrentAddingDocumentUrl Property
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► CurrentAddingDocumentUrl
Keyoti SearchUnit v6
The Url of the document being added to the index.
Declaration Syntax
C# Visual Basic
public string CurrentAddingDocumentUrl { get; }
Public ReadOnly Property CurrentAddingDocumentUrl As String
    Get
Property Value
String
Remarks
Updated before AddingDocument event.


DataAccess Property

DataAccess Property
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► DataAccess
Keyoti SearchUnit v6
The data-access layer, the type returned depends on the setting of Configuration.DbType.
Declaration Syntax
C# Visual Basic
public virtual XmlDataAccess DataAccess { get; set; }
Public Overridable Property DataAccess As XmlDataAccess
    Get
    Set
Property Value
XmlDataAccess

Send comments on this topic to support@keyoti.com


DeleteDocument Method (documentUri)

DeleteDocument Method (documentUri)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► DeleteDocument(String)
Keyoti SearchUnit v6
Convenience, calls RemoveDocument method. See remarks.
Declaration Syntax
C# Visual Basic
public void DeleteDocument(
    string documentUri
)
Public Sub DeleteDocument (
    documentUri As String
)
Parameters
documentUri (String)
Remarks
It's important that the document URL matches exactly with the URL already in the index. Please pay attention to trailing slashes (eg. http://localhost/) and ensure any spaces are encoded as %20.


DeleteIndex Method (deleteConfiguration)

DeleteIndex Method (deleteConfiguration)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► DeleteIndex(Boolean)
Keyoti SearchUnit v6
Deletes the contents of the index, by deleting the index files.
Declaration Syntax
C# Visual Basic
public void DeleteIndex(
    bool deleteConfiguration
)
Public Sub DeleteIndex (
    deleteConfiguration As Boolean
)
Parameters
deleteConfiguration (Boolean)
Whether to delete the configuration files as well as the indexed data.


Flush Method

Flush Method
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► Flush()()()()
Keyoti SearchUnit v6
Flushes any buffered operations out to the disk.
Declaration Syntax
C# Visual Basic
public virtual void Flush()
Public Overridable Sub Flush

Send comments on this topic to support@keyoti.com


GetContentCategoryRecords Method

GetContentCategoryRecords Method
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► GetContentCategoryRecords()()()()
Keyoti SearchUnit v6
Gets all content category records from the index.
Declaration Syntax
C# Visual Basic
public virtual ContentCategoryRecord[] GetContentCategoryRecords()
Public Overridable Function GetContentCategoryRecords As ContentCategoryRecord()
Return Value
array< ContentCategoryRecord >[]()[][]


GetDocument Method (documentUri)

GetDocument Method (documentUri)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► GetDocument(Uri)
Keyoti SearchUnit v6
Gets a Document from the data-access that has a URI equal to documentUri.
Declaration Syntax
C# Visual Basic
public virtual Document GetDocument(
    Uri documentUri
)
Public Overridable Function GetDocument (
    documentUri As Uri
) As Document
Parameters
documentUri (Uri)
The Uri of the document.
Return Value
Document
The matching Document if found, otherwise null/nothing.


GetDocumentID Method (uri)

GetDocumentID Method (uri)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► GetDocumentID(Uri)
Keyoti SearchUnit v6
Returns the document ID of the document specified by uri
Declaration Syntax
C# Visual Basic
public virtual int GetDocumentID(
    Uri uri
)
Public Overridable Function GetDocumentID (
    uri As Uri
) As Integer
Parameters
uri (Uri)
Return Value
Int32

Send comments on this topic to support@keyoti.com


GetDocumentsFromIndexableSource Method (indexableSourceRecord)

GetDocumentsFromIndexableSource Method (indexableSourceRecord)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► GetDocumentsFromIndexableSource(IndexableSourceRecord)
Keyoti SearchUnit v6
Get's an ArrayList of Document objects belonging to (imported from) an IndexableSource.
Declaration Syntax
C# Visual Basic
public virtual ArrayList GetDocumentsFromIndexableSource(
    IndexableSourceRecord indexableSourceRecord
)
Public Overridable Function GetDocumentsFromIndexableSource (
    indexableSourceRecord As IndexableSourceRecord
) As ArrayList
Parameters
indexableSourceRecord (IndexableSourceRecord)
Return Value
ArrayList

Send comments on this topic to support@keyoti.com


GetImportSample Method (indexableSourceRecord, dataSet, sampleSize, invoker)

GetImportSample Method (indexableSourceRecord, dataSet, sampleSize, invoker)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► GetImportSample(IndexableSourceRecord, DataSet, Int32, LinkBasedImportSampler..::..InvokeMethod)
Keyoti SearchUnit v6
Produces a sample DataTable of data that will be imported from the indexableSourceRecord using dataSource and places it in the DataSet ds as the first item.
Declaration Syntax
C# Visual Basic
public virtual void GetImportSample(
    IndexableSourceRecord indexableSourceRecord,
    DataSet dataSet,
    int sampleSize,
    LinkBasedImportSampler..::..InvokeMethod invoker
)
Public Overridable Sub GetImportSample (
    indexableSourceRecord As IndexableSourceRecord,
    dataSet As DataSet,
    sampleSize As Integer,
    invoker As LinkBasedImportSampler..::..InvokeMethod
)
Parameters
indexableSourceRecord (IndexableSourceRecord)
The instance of the source record which will be used to import documents/records.
dataSet (DataSet)
The DataSet to which the DataTable is added.
sampleSize (Int32)
The number of records to retrieve.
invoker (LinkBasedImportSampler..::..InvokeMethod)
A UI control with an Invoke method, which can be used to invoke a method on the UI thread. Can only be null when operating outside of Windows Forms.
Remarks
Can be used to test import parameters and produce example of result from Import method.


GetIndexableSourceForRecord Method (indexableSourceRecord)

GetIndexableSourceForRecord Method (indexableSourceRecord)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► GetIndexableSourceForRecord(IndexableSourceRecord)
Keyoti SearchUnit v6
Creates the IIndexableSource object (eg. DataSetBasedSource) for the specified indexableSourceRecord.
Declaration Syntax
C# Visual Basic
public virtual IIndexableSource GetIndexableSourceForRecord(
    IndexableSourceRecord indexableSourceRecord
)
Public Overridable Function GetIndexableSourceForRecord (
    indexableSourceRecord As IndexableSourceRecord
) As IIndexableSource
Parameters
indexableSourceRecord (IndexableSourceRecord)
Return Value
IIndexableSource

Send comments on this topic to support@keyoti.com


GetIndexableSourceRecord Method (sourceType, location, query)

GetIndexableSourceRecord Method (sourceType, location, query)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► GetIndexableSourceRecord(SourceType, String, String)
Keyoti SearchUnit v6
Gets an IndexableSourceRecord from the index that matches the type, location and query.
Declaration Syntax
C# Visual Basic
public IndexableSourceRecord GetIndexableSourceRecord(
    SourceType sourceType,
    string location,
    string query
)
Public Function GetIndexableSourceRecord (
    sourceType As SourceType,
    location As String,
    query As String
) As IndexableSourceRecord
Parameters
sourceType (SourceType)
The type of the source, eg. website
location (String)
The location specified when the source was imported
query (String)
May be null for certain import types (eg. website) - the query specified during import (eg. the SQL statement)
Return Value
IndexableSourceRecord
The record or null if none found that matched.


GetIndexableSourceRecords Method

GetIndexableSourceRecords Method
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► GetIndexableSourceRecords()()()()
Keyoti SearchUnit v6
Gets a collection of indexable sources
Declaration Syntax
C# Visual Basic
public virtual ArrayList GetIndexableSourceRecords()
Public Overridable Function GetIndexableSourceRecords As ArrayList
Return Value
ArrayList

Send comments on this topic to support@keyoti.com


GetIndexedDocuments Method

GetIndexedDocuments Method
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► GetIndexedDocuments()()()()
Keyoti SearchUnit v6
Gets all the indexed documents from the document table, as an ArrayList of Document objects
Declaration Syntax
C# Visual Basic
public virtual ArrayList GetIndexedDocuments()
Public Overridable Function GetIndexedDocuments As ArrayList
Return Value
ArrayList
ArrayList of Document objects

Send comments on this topic to support@keyoti.com


GetLastIndexDate Method

GetLastIndexDate Method
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► GetLastIndexDate()()()()
Keyoti SearchUnit v6
Return the date when last index was performed
Declaration Syntax
C# Visual Basic
[ObsoleteAttribute("Use GetStatus, to find the last index date.", true)]
public DateTime GetLastIndexDate()
<ObsoleteAttribute("Use GetStatus, to find the last index date.", true)>
Public Function GetLastIndexDate As DateTime
Return Value
DateTime

Send comments on this topic to support@keyoti.com


GetLocationCategoryRecords Method

GetLocationCategoryRecords Method
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► GetLocationCategoryRecords()()()()
Keyoti SearchUnit v6
Gets all location category records from the index.
Declaration Syntax
C# Visual Basic
public virtual LocationCategoryRecord[] GetLocationCategoryRecords()
Public Overridable Function GetLocationCategoryRecords As LocationCategoryRecord()
Return Value
array< LocationCategoryRecord >[]()[][]


GetNumberOfDocumentsFromIndexableSource Method (selectedSource)

GetNumberOfDocumentsFromIndexableSource Method (selectedSource)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► GetNumberOfDocumentsFromIndexableSource(IndexableSourceRecord)
Keyoti SearchUnit v6
Gets the number of documents that have been imported from the source
Declaration Syntax
C# Visual Basic
public virtual int GetNumberOfDocumentsFromIndexableSource(
    IndexableSourceRecord selectedSource
)
Public Overridable Function GetNumberOfDocumentsFromIndexableSource (
    selectedSource As IndexableSourceRecord
) As Integer
Parameters
selectedSource (IndexableSourceRecord)
The source to look at
Return Value
Int32

Send comments on this topic to support@keyoti.com


GetSecurityGroupRecord Method (name)

GetSecurityGroupRecord Method (name)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► GetSecurityGroupRecord(String)
Keyoti SearchUnit v6
Gets all security group records from the index.
Declaration Syntax
C# Visual Basic
public virtual SecurityGroupRecord GetSecurityGroupRecord(
    string name
)
Public Overridable Function GetSecurityGroupRecord (
    name As String
) As SecurityGroupRecord
Parameters
name (String)
Return Value
SecurityGroupRecord

Send comments on this topic to support@keyoti.com


GetSecurityGroupRecords Method

GetSecurityGroupRecords Method
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► GetSecurityGroupRecords()()()()
Keyoti SearchUnit v6
Gets all security group records from the index.
Declaration Syntax
C# Visual Basic
public virtual SecurityGroupRecordList GetSecurityGroupRecords()
Public Overridable Function GetSecurityGroupRecords As SecurityGroupRecordList
Return Value
SecurityGroupRecordList

Send comments on this topic to support@keyoti.com


GetState Method

GetState Method
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► GetState()()()()
Keyoti SearchUnit v6
Gets the state of the index.
Declaration Syntax
C# Visual Basic
public virtual State GetState()
Public Overridable Function GetState As State
Return Value
State

Send comments on this topic to support@keyoti.com


GetWordVariations Method (word, configuration)

GetWordVariations Method (word, configuration)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► GetWordVariations(Word, Configuration)
Keyoti SearchUnit v6
Returns list of string objects with variations (lemmas) for a word, empty list if none found.
Declaration Syntax
C# Visual Basic
public static ArrayList GetWordVariations(
    Word word,
    Configuration configuration
)
Public Shared Function GetWordVariations (
    word As Word,
    configuration As Configuration
) As ArrayList
Parameters
word (Word)
configuration (Configuration)
Return Value
ArrayList
Remarks
The configuration object is used for it's LemmaLanguage property.


Import Method

Import Method
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► Import()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Import(IndexableSourceRecord) | Imports the documents from an indexable source into the document index and returns a collection of imported Uri objects.
 | Import(IndexableSourceRecord, IIndexableSource) | Imports the documents from an indexable source into the document index and returns a collection of imported Uri objects


Import Method (indexableSourceRecord)

Import Method (indexableSourceRecord)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► Import(IndexableSourceRecord)
Keyoti SearchUnit v6
Imports the documents from an indexable source into the document index and returns a collection of imported Uri objects.
Declaration Syntax
C# Visual Basic
public ArrayList Import(
    IndexableSourceRecord indexableSourceRecord
)
Public Function Import (
    indexableSourceRecord As IndexableSourceRecord
) As ArrayList
Parameters
indexableSourceRecord (IndexableSourceRecord)
The indexable source's record which provides connection information and an ID.
Return Value
ArrayList
Remarks
The IIndexableSource object related to the IndexableSourceRecord is created automatically. To pass a custom instance, use the appropriate overload of this method.


Import Method (indexableSourceRecord, dataSource)

Import Method (indexableSourceRecord, dataSource)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► Import(IndexableSourceRecord, IIndexableSource)
Keyoti SearchUnit v6
Imports the documents from an indexable source into the document index and returns a collection of imported Uri objects
Declaration Syntax
C# Visual Basic
public virtual ArrayList Import(
    IndexableSourceRecord indexableSourceRecord,
    IIndexableSource dataSource
)
Public Overridable Function Import (
    indexableSourceRecord As IndexableSourceRecord,
    dataSource As IIndexableSource
) As ArrayList
Parameters
indexableSourceRecord (IndexableSourceRecord)
The indexable source's record which provides connection information.
dataSource (IIndexableSource)
The instance of the source which will be used to import documents/records.
Return Value
ArrayList
Returns list of Uri objects newly imported
Remarks
Will persist indexableSourceRecord to the data-access layer, unless it is of type SourceType.PresetDataSetProvider.


ImportCustomDataSet Method (assemblyFilePath, fullClassName, uniqueColumnName, resultUrlFormat)

ImportCustomDataSet Method (assemblyFilePath, fullClassName, uniqueColumnName, resultUrlFormat)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► ImportCustomDataSet(String, String, String, String)
Keyoti SearchUnit v6
Convenience method to import data from a DLL using the Import method.
Declaration Syntax
C# Visual Basic
public ArrayList ImportCustomDataSet(
    string assemblyFilePath,
    string fullClassName,
    string uniqueColumnName,
    string resultUrlFormat
)
Public Function ImportCustomDataSet (
    assemblyFilePath As String,
    fullClassName As String,
    uniqueColumnName As String,
    resultUrlFormat As String
) As ArrayList
Parameters
assemblyFilePath (String)
Full path to the DLL, including filename - can be relative to IndexDirectory - see help.
fullClassName (String)
The fully qualified class name that contains the data.
uniqueColumnName (String)
The name of the column which uniquely identifies a row (eg. primary key)
resultUrlFormat (String)
The format string for the result URLs.
Return Value
ArrayList
Returns list of Uri objects newly imported
Remarks
The Help has much more information in the importing section, regarding custom dataset imports.


ImportDatabase Method (sourceType, connectionString, sqlQuery, uniqueColumnName, resultUrlFormat)

ImportDatabase Method (sourceType, connectionString, sqlQuery, uniqueColumnName, resultUrlFormat)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► ImportDatabase(SourceType, String, String, String, String)
Keyoti SearchUnit v6
Convenience method to import data from a database using the Import method.
Declaration Syntax
C# Visual Basic
public ArrayList ImportDatabase(
    SourceType sourceType,
    string connectionString,
    string sqlQuery,
    string uniqueColumnName,
    string resultUrlFormat
)
Public Function ImportDatabase (
    sourceType As SourceType,
    connectionString As String,
    sqlQuery As String,
    uniqueColumnName As String,
    resultUrlFormat As String
) As ArrayList
Parameters
sourceType (SourceType)
The SourceType specifying the database type
connectionString (String)
Connection string for DB
sqlQuery (String)
The SQL query returning the data to index
uniqueColumnName (String)
The name of the column which uniquely identifies a row (eg. primary key)
resultUrlFormat (String)
The format string for the result URLs.
Return Value
ArrayList
Returns list of Uri objects newly imported
Remarks
The Help has much more information in the importing section, regarding databases imports.


ImportFileSystemFolder Method (localFolderPath, virtualPath, targetMatchList, ignoreMatchList, recurseSubFolders)

ImportFileSystemFolder Method (localFolderPath, virtualPath, targetMatchList, ignoreMatchList, recurseSubFolders)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► ImportFileSystemFolder(String, String, ArrayList, ArrayList, Boolean)
Keyoti SearchUnit v6
Convenience method to import documents from a virtual folder using the Import method.
Declaration Syntax
C# Visual Basic
public ArrayList ImportFileSystemFolder(
    string localFolderPath,
    string virtualPath,
    ArrayList targetMatchList,
    ArrayList ignoreMatchList,
    bool recurseSubFolders
)
Public Function ImportFileSystemFolder (
    localFolderPath As String,
    virtualPath As String,
    targetMatchList As ArrayList,
    ignoreMatchList As ArrayList,
    recurseSubFolders As Boolean
) As ArrayList
Parameters
localFolderPath (String)
Filepath of the virtual folder (or subfolder) to import documents from.
virtualPath (String)
URL corresponding to localFolderPath.
targetMatchList (ArrayList)
ArrayList of strings - if specified then only document paths matching one of these strings will be imported (useful for specifying filetypes, eg ".doc$" means file names ending with .doc). May be null/Nothing
ignoreMatchList (ArrayList)
ArrayList of strings - any document paths which match one of these strings will be ignored. May be null/Nothing
recurseSubFolders (Boolean)
Whether to recurse into subfolders looking for documents
Return Value
ArrayList
Returns list of Uri objects newly imported
Examples
If there is a virtual folder ("mywebsite") located at c:\inetpub\wwwroot\mywebsite, which is accessible via http://localhost/mywebsite and all PDF documents should be imported from that folder, then the import is done as.
Copy image Copy
match = new ArrayList();
match.Add(".pdf");
ImportFileSystemFolder(@"c:\inetpub\wwwroot\mywebsite", "http://localhost/mywebsite/", match, null, true);
Examples
If there is a virtual folder ("mywebsite") located at c:\inetpub\wwwroot\mywebsite, which is accessible via http://localhost/mywebsite and all documents should be imported from a folder at c:\inetpub\wwwroot\mywebsite\docs, then the import is done as.
Copy image Copy
ImportFileSystemFolder(@"c:\inetpub\wwwroot\mywebsite\docs", "http://localhost/mywebsite/docs/", null, null, true);


ImportSampleDataTableColumnsFinalized Event

ImportSampleDataTableColumnsFinalized Event
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► ImportSampleDataTableColumnsFinalized
Keyoti SearchUnit v6
Fired when the DataTable used for the import sample has it's columns finalized.
Declaration Syntax
C# Visual Basic
public event EventHandler ImportSampleDataTableColumnsFinalized
Public Event ImportSampleDataTableColumnsFinalized As EventHandler
Value
EventHandler

Send comments on this topic to support@keyoti.com


ImportWebsite Method (url)

ImportWebsite Method (url)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► ImportWebsite(String)
Keyoti SearchUnit v6
Convenience method to crawl and import a website using the Import method.
Declaration Syntax
C# Visual Basic
public ArrayList ImportWebsite(
    string url
)
Public Function ImportWebsite (
    url As String
) As ArrayList
Parameters
url (String)
Starting URL of web-site to crawl.
Return Value
ArrayList
Returns list of Uri objects newly imported


IsClosed Property

IsClosed Property
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► IsClosed
Keyoti SearchUnit v6
Whether this object has been closed.
Declaration Syntax
C# Visual Basic
public bool IsClosed { get; }
Public ReadOnly Property IsClosed As Boolean
    Get
Property Value
Boolean

Send comments on this topic to support@keyoti.com


IsContentUsed Method (contentName)

IsContentUsed Method (contentName)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► IsContentUsed(String)
Keyoti SearchUnit v6
Returns true if contentName is used by at least one document
Declaration Syntax
C# Visual Basic
public virtual bool IsContentUsed(
    string contentName
)
Public Overridable Function IsContentUsed (
    contentName As String
) As Boolean
Parameters
contentName (String)
Return Value
Boolean

Send comments on this topic to support@keyoti.com


IsDocumentToBeIndexed Method (document)

IsDocumentToBeIndexed Method (document)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► IsDocumentToBeIndexed(Document)
Keyoti SearchUnit v6
Determines if a document should be indexed.
Declaration Syntax
C# Visual Basic
protected internal virtual bool IsDocumentToBeIndexed(
    Document document
)
Protected Friend Overridable Function IsDocumentToBeIndexed (
    document As Document
) As Boolean
Parameters
document (Document)
Return Value
Boolean

Send comments on this topic to support@keyoti.com


IsLocationUsed Method (locationName)

IsLocationUsed Method (locationName)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► IsLocationUsed(String)
Keyoti SearchUnit v6
Returns true if locationName is used by at least one document
Declaration Syntax
C# Visual Basic
public virtual bool IsLocationUsed(
    string locationName
)
Public Overridable Function IsLocationUsed (
    locationName As String
) As Boolean
Parameters
locationName (String)
Return Value
Boolean

Send comments on this topic to support@keyoti.com


IsLocked Method

IsLocked Method
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► IsLocked()()()()
Keyoti SearchUnit v6
Whether the current index is locked (preventing operations other than search).
Declaration Syntax
C# Visual Basic
public virtual bool IsLocked()
Public Overridable Function IsLocked As Boolean
Return Value
Boolean
Remarks
If the index is locked then attempts to create a new instance will cause an IndexLockedException. An index is locked when some other process is already working on it.


IsPaused Property

IsPaused Property
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► IsPaused
Keyoti SearchUnit v6
Whether the import is paused.
Declaration Syntax
C# Visual Basic
public bool IsPaused { get; }
Public ReadOnly Property IsPaused As Boolean
    Get
Property Value
Boolean

Send comments on this topic to support@keyoti.com


IsSecurityGroupUsed Method (name)

IsSecurityGroupUsed Method (name)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► IsSecurityGroupUsed(String)
Keyoti SearchUnit v6
Returns true if the named security group is used by at least one document.
Declaration Syntax
C# Visual Basic
public bool IsSecurityGroupUsed(
    string name
)
Public Function IsSecurityGroupUsed (
    name As String
) As Boolean
Parameters
name (String)
Return Value
Boolean

Send comments on this topic to support@keyoti.com


ItemsImported Property

ItemsImported Property
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► ItemsImported
Keyoti SearchUnit v6
The number of items (documents, records, files, etc) that have been imported since the last call to Import.
Declaration Syntax
C# Visual Basic
public virtual int ItemsImported { get; }
Public Overridable ReadOnly Property ItemsImported As Integer
    Get
Property Value
Int32
Remarks
Access this property from a different thread to track import progress.


ItemsToImportTotal Property

ItemsToImportTotal Property
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► ItemsToImportTotal
Keyoti SearchUnit v6
If available, the total number of items (documents, records, files, etc) that will be imported, otherwise returns -1.
Declaration Syntax
C# Visual Basic
public virtual int ItemsToImportTotal { get; }
Public Overridable ReadOnly Property ItemsToImportTotal As Integer
    Get
Property Value
Int32
Remarks
Access this property from a different thread to track import progress.


MarkIndexValid Method (valid)

MarkIndexValid Method (valid)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► MarkIndexValid(Boolean)
Keyoti SearchUnit v6
Marks the current document index as valid or not.
Declaration Syntax
C# Visual Basic
public virtual void MarkIndexValid(
    bool valid
)
Public Overridable Sub MarkIndexValid (
    valid As Boolean
)
Parameters
valid (Boolean)
Wether the index is valid

Send comments on this topic to support@keyoti.com


OccurrenceCount Property

OccurrenceCount Property
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► OccurrenceCount
Keyoti SearchUnit v6
The number of occurrences indexed during the build.
Declaration Syntax
C# Visual Basic
public virtual int OccurrenceCount { get; }
Public Overridable ReadOnly Property OccurrenceCount As Integer
    Get
Property Value
Int32

Send comments on this topic to support@keyoti.com


OnImportSampleDataTableColumnsFinalized Method (evArgs)

OnImportSampleDataTableColumnsFinalized Method (evArgs)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► OnImportSampleDataTableColumnsFinalized(EventArgs)
Keyoti SearchUnit v6
Called whenever a readerException is caught
Declaration Syntax
C# Visual Basic
protected virtual void OnImportSampleDataTableColumnsFinalized(
    EventArgs evArgs
)
Protected Overridable Sub OnImportSampleDataTableColumnsFinalized (
    evArgs As EventArgs
)
Parameters
evArgs (EventArgs)


OnReaderExceptionOccurred Method (evArgs)

OnReaderExceptionOccurred Method (evArgs)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► OnReaderExceptionOccurred(ReaderExceptionOccurredEventArgs)
Keyoti SearchUnit v6
Called whenever a readerException is caught
Declaration Syntax
C# Visual Basic
protected virtual void OnReaderExceptionOccurred(
    ReaderExceptionOccurredEventArgs evArgs
)
Protected Overridable Sub OnReaderExceptionOccurred (
    evArgs As ReaderExceptionOccurredEventArgs
)
Parameters
evArgs (ReaderExceptionOccurredEventArgs)


Open Method

Open Method
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► Open()()()()
Keyoti SearchUnit v6
Opens the index for use.
Declaration Syntax
C# Visual Basic
[ObsoleteAttribute("Open method not needed, automatically opened in the constructor now.",
    false)]
public virtual void Open()
<ObsoleteAttribute("Open method not needed, automatically opened in the constructor now.",
    false)>
Public Overridable Sub Open
Remarks
Will not reopen the DataAccess layer if it is already opened.


Optimize Method

Optimize Method
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► Optimize()()()()
Keyoti SearchUnit v6
Reorganizes index files for optimal search speed.
Declaration Syntax
C# Visual Basic
public void Optimize()
Public Sub Optimize
Remarks
Adding/deleting documents from the index causes the index to become fragmented, therefore calling Optimize after batch operations will speed up searching.


OptimizeProgress Property

OptimizeProgress Property
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► OptimizeProgress
Keyoti SearchUnit v6
The current percent progress of the optimize operation. (0-100)
Declaration Syntax
C# Visual Basic
public int OptimizeProgress { get; }
Public ReadOnly Property OptimizeProgress As Integer
    Get
Property Value
Int32

Send comments on this topic to support@keyoti.com


Pause Method

Pause Method
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► Pause()()()()
Keyoti SearchUnit v6
Pauses the import.
Declaration Syntax
C# Visual Basic
public virtual void Pause()
Public Overridable Sub Pause

Send comments on this topic to support@keyoti.com


PercentItemsDeleted Property

PercentItemsDeleted Property
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► PercentItemsDeleted
Keyoti SearchUnit v6
The percentage of items (documents, records, files, etc) that have been delete since the last call to RemoveSource.
Declaration Syntax
C# Visual Basic
public virtual int PercentItemsDeleted { get; }
Public Overridable ReadOnly Property PercentItemsDeleted As Integer
    Get
Property Value
Int32
Remarks
Access this property from a different thread to track delete progress.


ReaderExceptionOccurred Event

ReaderExceptionOccurred Event
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► ReaderExceptionOccurred
Keyoti SearchUnit v6
Fired whenever the (web) reader encounters a network exception, eg. 404 (this can be useful for identifying dead links)
Declaration Syntax
C# Visual Basic
public event ReaderExceptionOccurredEventHandler ReaderExceptionOccurred
Public Event ReaderExceptionOccurred As ReaderExceptionOccurredEventHandler
Value
ReaderExceptionOccurredEventHandler

Send comments on this topic to support@keyoti.com


RegisterDataSetBasedSource Method (id, dataSetBasedSource)

RegisterDataSetBasedSource Method (id, dataSetBasedSource)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► RegisterDataSetBasedSource(Int32, DataSetBasedSource)
Keyoti SearchUnit v6
Registers a DataSetBasedSource for use by the document reader.
Declaration Syntax
C# Visual Basic
public virtual void RegisterDataSetBasedSource(
    int id,
    DataSetBasedSource dataSetBasedSource
)
Public Overridable Sub RegisterDataSetBasedSource (
    id As Integer,
    dataSetBasedSource As DataSetBasedSource
)
Parameters
id (Int32)
dataSetBasedSource (DataSetBasedSource)


ReimportIndexableSources Method

ReimportIndexableSources Method
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► ReimportIndexableSources()()()()
Keyoti SearchUnit v6
Reimports all indexed sources.
Declaration Syntax
C# Visual Basic
public virtual void ReimportIndexableSources()
Public Overridable Sub ReimportIndexableSources


RemoveContent Method

RemoveContent Method
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► RemoveContent()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | RemoveContent(String, Boolean) | Removes a content type from the index if the type is unused, otherwise throws an exception.
 | RemoveContent(String) | Removes a content type from the index if the type is unused, otherwise throws an exception.


RemoveContent Method (content)

RemoveContent Method (content)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► RemoveContent(String)
Keyoti SearchUnit v6
Removes a content type from the index if the type is unused, otherwise throws an exception.
Declaration Syntax
C# Visual Basic
public void RemoveContent(
    string content
)
Public Sub RemoveContent (
    content As String
)
Parameters
content (String)
The content name
Remarks
Throws an InvalidOperationException if the category is currently assigned to a document.


RemoveContent Method (content, checkIfContentCategoryIsUsed)

RemoveContent Method (content, checkIfContentCategoryIsUsed)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► RemoveContent(String, Boolean)
Keyoti SearchUnit v6
Removes a content type from the index if the type is unused, otherwise throws an exception.
Declaration Syntax
C# Visual Basic
public virtual void RemoveContent(
    string content,
    bool checkIfContentCategoryIsUsed
)
Public Overridable Sub RemoveContent (
    content As String,
    checkIfContentCategoryIsUsed As Boolean
)
Parameters
content (String)
The content name
checkIfContentCategoryIsUsed (Boolean)
Whether to check (and warn with an InvalidOperationException) if the content category is used.
Remarks
Throws an InvalidOperationException if the category is currently assigned to a document and checkIfContentCategoryIsUsed==true.


RemoveDocument Method

RemoveDocument Method
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► RemoveDocument()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | RemoveDocument(Document) | Removes the document specified from the database. See remarks.
 | RemoveDocument(String) | Removes the document specified by its Uri from the database


RemoveDocument Method (document)

RemoveDocument Method (document)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► RemoveDocument(Document)
Keyoti SearchUnit v6
Removes the document specified from the database. See remarks.
Declaration Syntax
C# Visual Basic
public void RemoveDocument(
    Document document
)
Public Sub RemoveDocument (
    document As Document
)
Parameters
document (Document)
Remarks
It's important that the document URL matches exactly with the URL already in the index. Please pay attention to trailing slashes (eg. http://localhost/) and ensure any spaces are encoded as %20.


RemoveDocument Method (documentUri)

RemoveDocument Method (documentUri)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► RemoveDocument(String)
Keyoti SearchUnit v6
Removes the document specified by its Uri from the database
Declaration Syntax
C# Visual Basic
public virtual void RemoveDocument(
    string documentUri
)
Public Overridable Sub RemoveDocument (
    documentUri As String
)
Parameters
documentUri (String)


RemoveLocation Method

RemoveLocation Method
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► RemoveLocation()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | RemoveLocation(String, Boolean) | Removes a location from the index if the location is unused, otherwise throws an exception.
 | RemoveLocation(String) | Removes a location from the index if the location is unused, otherwise throws an exception.


RemoveLocation Method (locationName)

RemoveLocation Method (locationName)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► RemoveLocation(String)
Keyoti SearchUnit v6
Removes a location from the index if the location is unused, otherwise throws an exception.
Declaration Syntax
C# Visual Basic
public void RemoveLocation(
    string locationName
)
Public Sub RemoveLocation (
    locationName As String
)
Parameters
locationName (String)
Remarks
Throws an InvalidOperationException if the location is currently assigned to a document.


RemoveLocation Method (locationName, checkIfLocationCategoryIsUsed)

RemoveLocation Method (locationName, checkIfLocationCategoryIsUsed)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► RemoveLocation(String, Boolean)
Keyoti SearchUnit v6
Removes a location from the index if the location is unused, otherwise throws an exception.
Declaration Syntax
C# Visual Basic
public virtual void RemoveLocation(
    string locationName,
    bool checkIfLocationCategoryIsUsed
)
Public Overridable Sub RemoveLocation (
    locationName As String,
    checkIfLocationCategoryIsUsed As Boolean
)
Parameters
locationName (String)
checkIfLocationCategoryIsUsed (Boolean)
Remarks
Throws an InvalidOperationException if the location is currently assigned to a document.


RemoveSecurityGroup Method

RemoveSecurityGroup Method
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► RemoveSecurityGroup()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | RemoveSecurityGroup(String) | Removes a security group from the index if the group is unused, otherwise throws an exception.
 | RemoveSecurityGroup(String, Boolean) | Removes a security group from the index if the group is unused, otherwise throws an exception.


RemoveSecurityGroup Method (name)

RemoveSecurityGroup Method (name)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► RemoveSecurityGroup(String)
Keyoti SearchUnit v6
Removes a security group from the index if the group is unused, otherwise throws an exception.
Declaration Syntax
C# Visual Basic
public void RemoveSecurityGroup(
    string name
)
Public Sub RemoveSecurityGroup (
    name As String
)
Parameters
name (String)
Remarks
Throws an InvalidOperationException if the location is currently assigned to a document.


RemoveSecurityGroup Method (name, checkIfGroupIsUsed)

RemoveSecurityGroup Method (name, checkIfGroupIsUsed)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► RemoveSecurityGroup(String, Boolean)
Keyoti SearchUnit v6
Removes a security group from the index if the group is unused, otherwise throws an exception.
Declaration Syntax
C# Visual Basic
public virtual void RemoveSecurityGroup(
    string name,
    bool checkIfGroupIsUsed
)
Public Overridable Sub RemoveSecurityGroup (
    name As String,
    checkIfGroupIsUsed As Boolean
)
Parameters
name (String)
checkIfGroupIsUsed (Boolean)
Remarks
Throws an InvalidOperationException if the location is currently assigned to a document.


RemoveSource Method (sourceRecord)

RemoveSource Method (sourceRecord)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► RemoveSource(IndexableSourceRecord)
Keyoti SearchUnit v6
Removes the indexable data source passed as argument from database, and all of it's documents.
Declaration Syntax
C# Visual Basic
public virtual void RemoveSource(
    IndexableSourceRecord sourceRecord
)
Public Overridable Sub RemoveSource (
    sourceRecord As IndexableSourceRecord
)
Parameters
sourceRecord (IndexableSourceRecord)
The source to remove

Send comments on this topic to support@keyoti.com


Resume Method

Resume Method
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► Resume()()()()
Keyoti SearchUnit v6
Resumes a paused import.
Declaration Syntax
C# Visual Basic
public virtual void Resume()
Public Overridable Sub Resume

Send comments on this topic to support@keyoti.com


UnlockIndexDirectory Method (indexDirectory)

UnlockIndexDirectory Method (indexDirectory)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► UnlockIndexDirectory(String)
Keyoti SearchUnit v6
Forcefully unlocks the index directory specified. Only use if certain that other processes are not using the index.
Declaration Syntax
C# Visual Basic
public static void UnlockIndexDirectory(
    string indexDirectory
)
Public Shared Sub UnlockIndexDirectory (
    indexDirectory As String
)
Parameters
indexDirectory (String)
Path to the index directory.


UpdateDocument Method (docRecord)

UpdateDocument Method (docRecord)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► UpdateDocument(DocumentRecord)
Keyoti SearchUnit v6
Updates the content/location categories stored for a document in the index
Declaration Syntax
C# Visual Basic
[ObsoleteAttribute("Use UpdateDocumentCategories instead - note that only the content/location categories assigned to the document are updated in the index, to update other data, delete the document and reindex.",
    true)]
public void UpdateDocument(
    DocumentRecord docRecord
)
<ObsoleteAttribute("Use UpdateDocumentCategories instead - note that only the content/location categories assigned to the document are updated in the index, to update other data, delete the document and reindex.",
    true)>
Public Sub UpdateDocument (
    docRecord As DocumentRecord
)
Parameters
docRecord (DocumentRecord)
The new DocumentRecord.


UpdateDocumentCategories Method (document)

UpdateDocumentCategories Method (document)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► UpdateDocumentCategories(Document)
Keyoti SearchUnit v6
Updates location/content categories assigned in DocumentRecord to the index.
Declaration Syntax
C# Visual Basic
public void UpdateDocumentCategories(
    Document document
)
Public Sub UpdateDocumentCategories (
    document As Document
)
Parameters
document (Document)


UpdateDocumentSecurityGroups Method (document)

UpdateDocumentSecurityGroups Method (document)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► UpdateDocumentSecurityGroups(Document)
Keyoti SearchUnit v6
Updates the security group assigned in DocumentRecord to the index.
Declaration Syntax
C# Visual Basic
public void UpdateDocumentSecurityGroups(
    Document document
)
Public Sub UpdateDocumentSecurityGroups (
    document As Document
)
Parameters
document (Document)


UpdateIndexableSourceRecord Method (updatedSource)

UpdateIndexableSourceRecord Method (updatedSource)
API Documentation ► Keyoti.SearchEngine.Index ► DocumentIndex ► UpdateIndexableSourceRecord(IndexableSourceRecord)
Keyoti SearchUnit v6
Updates the IndexableSourceRecord in the index, the ID property must be set.
Declaration Syntax
C# Visual Basic
public void UpdateIndexableSourceRecord(
    IndexableSourceRecord updatedSource
)
Public Sub UpdateIndexableSourceRecord (
    updatedSource As IndexableSourceRecord
)
Parameters
updatedSource (IndexableSourceRecord)


IndexLockedException Class

IndexLockedException Class
API Documentation ► Keyoti.SearchEngine.Index ► IndexLockedException
Keyoti SearchUnit v6
Exception indicating that the index is locked.
Declaration Syntax
C# Visual Basic
public class IndexLockedException : InvalidOperationException
Public Class IndexLockedException
    Inherits InvalidOperationException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IndexLockedException(String) | New.
 | Data | (Inherited from Exception.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetBaseException()()()() | (Inherited from Exception.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | (Inherited from Exception.)
 | GetType()()()() | (Inherited from Exception.)
 | HelpLink | (Inherited from Exception.)
 | HResult | (Inherited from Exception.)
 | InnerException | (Inherited from Exception.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from Exception.)
 | Source | (Inherited from Exception.)
 | StackTrace | (Inherited from Exception.)
 | TargetSite | (Inherited from Exception.)
 | ToString()()()() | (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SystemException
 |  |  | InvalidOperationException
 |  |  |  | IndexLockedException


IndexLockedException Constructor (mesg)

IndexLockedException Constructor (mesg)
API Documentation ► Keyoti.SearchEngine.Index ► IndexLockedException ► IndexLockedException(String)
Keyoti SearchUnit v6
New.
Declaration Syntax
C# Visual Basic
public IndexLockedException(
    string mesg
)
Public Sub New (
    mesg As String
)
Parameters
mesg (String)


ReaderExceptionOccurredEventHandler Delegate

ReaderExceptionOccurredEventHandler Delegate
API Documentation ► Keyoti.SearchEngine.Index ► ReaderExceptionOccurredEventHandler
Keyoti SearchUnit v6
Specifies a method that handles ReaderExceptionOccured events
Declaration Syntax
C# Visual Basic
public delegate void ReaderExceptionOccurredEventHandler(
    Object sender,
    ReaderExceptionOccurredEventArgs e
)
Public Delegate Sub ReaderExceptionOccurredEventHandler (
    sender As Object,
    e As ReaderExceptionOccurredEventArgs
)
Parameters
sender (Object)
e (ReaderExceptionOccurredEventArgs)


StartUrlCannotBeReadException Class

StartUrlCannotBeReadException Class
API Documentation ► Keyoti.SearchEngine.Index ► StartUrlCannotBeReadException
Keyoti SearchUnit v6
Thrown by crawler when the start URL cannot be read, typically because of a network exception.
Declaration Syntax
C# Visual Basic
public class StartUrlCannotBeReadException : Exception
Public Class StartUrlCannotBeReadException
    Inherits Exception
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StartUrlCannotBeReadException(Exception) | Creates a new instance
 | Data | (Inherited from Exception.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetBaseException()()()() | (Inherited from Exception.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | (Inherited from Exception.)
 | GetType()()()() | (Inherited from Exception.)
 | HelpLink | (Inherited from Exception.)
 | HResult | (Inherited from Exception.)
 | InnerException | (Inherited from Exception.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | Description of the exception (Overrides Exception.Message.)
 | Source | (Inherited from Exception.)
 | StackTrace | (Inherited from Exception.)
 | TargetSite | (Inherited from Exception.)
 | ToString()()()() | (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | StartUrlCannotBeReadException


StartUrlCannotBeReadException Constructor (innerException)

StartUrlCannotBeReadException Constructor (innerException)
API Documentation ► Keyoti.SearchEngine.Index ► StartUrlCannotBeReadException ► StartUrlCannotBeReadException(Exception)
Keyoti SearchUnit v6
Creates a new instance
Declaration Syntax
C# Visual Basic
public StartUrlCannotBeReadException(
    Exception innerException
)
Public Sub New (
    innerException As Exception
)
Parameters
innerException (Exception)


Message Property

Message Property
API Documentation ► Keyoti.SearchEngine.Index ► StartUrlCannotBeReadException ► Message
Keyoti SearchUnit v6
Description of the exception
Declaration Syntax
C# Visual Basic
public override string Message { get; }
Public Overrides ReadOnly Property Message As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


State Class

State Class
API Documentation ► Keyoti.SearchEngine.Index ► State
Keyoti SearchUnit v6
The state of the index.
Declaration Syntax
C# Visual Basic
public class State
Public Class State
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | State(Int32, Int32, Boolean, DateTime, IndexState) | Creates an instance
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetInformationMessage()()()() | Gets an English message detailing the state of the index, with recommendations.
 | GetType()()()() | (Inherited from Object.)
 | LastIndexBuildDate | The date the index was last built.
 | Locked | Whether the index is currently locked.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NumberOfDocuments | The number of documents in the index.
 | NumberOfUnindexedDocuments | The number of documents which have not been 'indexed' and are unsearchable.
 | OperationalState | The operational state of the index, such as whether it needs fully reindexing because a setting has changed.
 | ToString()()()() | (Inherited from Object.)
 | ValidForSearching | Whether the index can be searched.
Inheritance Hierarchy
Object
State

Send comments on this topic to support@keyoti.com


State Constructor (numberOfUnindexedDocuments, numberOfDocuments, validForSearching, lastIndexedDate, indexState)

State Constructor (numberOfUnindexedDocuments, numberOfDocuments, validForSearching, lastIndexedDate, indexState)
API Documentation ► Keyoti.SearchEngine.Index ► State ► State(Int32, Int32, Boolean, DateTime, IndexState)
Keyoti SearchUnit v6
Creates an instance
Declaration Syntax
C# Visual Basic
public State(
    int numberOfUnindexedDocuments,
    int numberOfDocuments,
    bool validForSearching,
    DateTime lastIndexedDate,
    IndexState indexState
)
Public Sub New (
    numberOfUnindexedDocuments As Integer,
    numberOfDocuments As Integer,
    validForSearching As Boolean,
    lastIndexedDate As DateTime,
    indexState As IndexState
)
Parameters
numberOfUnindexedDocuments (Int32)
numberOfDocuments (Int32)
validForSearching (Boolean)
lastIndexedDate (DateTime)
indexState (IndexState)


GetInformationMessage Method

GetInformationMessage Method
API Documentation ► Keyoti.SearchEngine.Index ► State ► GetInformationMessage()()()()
Keyoti SearchUnit v6
Gets an English message detailing the state of the index, with recommendations.
Declaration Syntax
C# Visual Basic
public virtual string GetInformationMessage()
Public Overridable Function GetInformationMessage As String
Return Value
String

Send comments on this topic to support@keyoti.com


LastIndexBuildDate Property

LastIndexBuildDate Property
API Documentation ► Keyoti.SearchEngine.Index ► State ► LastIndexBuildDate
Keyoti SearchUnit v6
The date the index was last built.
Declaration Syntax
C# Visual Basic
public DateTime LastIndexBuildDate { get; }
Public ReadOnly Property LastIndexBuildDate As DateTime
    Get
Property Value
DateTime

Send comments on this topic to support@keyoti.com


Locked Property

Locked Property
API Documentation ► Keyoti.SearchEngine.Index ► State ► Locked
Keyoti SearchUnit v6
Whether the index is currently locked.
Declaration Syntax
C# Visual Basic
public bool Locked { get; }
Public ReadOnly Property Locked As Boolean
    Get
Property Value
Boolean

Send comments on this topic to support@keyoti.com


NumberOfDocuments Property

NumberOfDocuments Property
API Documentation ► Keyoti.SearchEngine.Index ► State ► NumberOfDocuments
Keyoti SearchUnit v6
The number of documents in the index.
Declaration Syntax
C# Visual Basic
public int NumberOfDocuments { get; }
Public ReadOnly Property NumberOfDocuments As Integer
    Get
Property Value
Int32

Send comments on this topic to support@keyoti.com


NumberOfUnindexedDocuments Property

NumberOfUnindexedDocuments Property
API Documentation ► Keyoti.SearchEngine.Index ► State ► NumberOfUnindexedDocuments
Keyoti SearchUnit v6
The number of documents which have not been 'indexed' and are unsearchable.
Declaration Syntax
C# Visual Basic
public int NumberOfUnindexedDocuments { get; }
Public ReadOnly Property NumberOfUnindexedDocuments As Integer
    Get
Property Value
Int32

Send comments on this topic to support@keyoti.com


OperationalState Property

OperationalState Property
API Documentation ► Keyoti.SearchEngine.Index ► State ► OperationalState
Keyoti SearchUnit v6
The operational state of the index, such as whether it needs fully reindexing because a setting has changed.
Declaration Syntax
C# Visual Basic
public IndexState OperationalState { get; }
Public ReadOnly Property OperationalState As IndexState
    Get
Property Value
IndexState

Send comments on this topic to support@keyoti.com


ValidForSearching Property

ValidForSearching Property
API Documentation ► Keyoti.SearchEngine.Index ► State ► ValidForSearching
Keyoti SearchUnit v6
Whether the index can be searched.
Declaration Syntax
C# Visual Basic
public bool ValidForSearching { get; }
Public ReadOnly Property ValidForSearching As Boolean
    Get
Property Value
Boolean

Send comments on this topic to support@keyoti.com


Keyoti.SearchEngine.Index.IndexableSources Namespace

Keyoti.SearchEngine.Index.IndexableSources Namespace
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources
Keyoti SearchUnit v6
Types of indexable source
Types
All Types Classes Interfaces Enumerations Delegates
Icon | Type | Description
 | AddDocumentEventArgs | Arguments for AddDocument event which provides the opportunity to cancel a document from being added
 | AddDocumentEventHandler | Event handler
 | LinkBasedImportSampler..::..AddRowDelegate | The "AddRow" method to call, on the grid.
 | LinkBasedImportSampler..::..BeginInvokeMethod | A "BeginInvoke" method, used to invoke on the UI thread.
 | CustomDataSetProviderAdapter | Obtains DataSet data from a user provided assembly.
 | DataSetBasedSource | A dataset based source
 | WebSiteSpider..::..DiscoveredDocumentHandler | Delegate which is called as documents are found.
 | FileSysDocumentStore | Imports documents found in a directory
 | FileSystemFolderBasedSource | Represents a file system directory as a source of documents.
 | IDataSetAdapter | A dataset adapter
 | IIndexableSource | An indexable source
 | LinkBasedImportSampler..::..ImportRowDelegate | The "ImportRow" method to call, on the grid.
 | IndexableSource | Base abstract class for indexable source types.
 | IndexableSourceFactory | Creates instances of IndexableSource sub-classes.
 | IndexableSourceFieldHelpAttribute | Source field help text.
 | IndexableSourceFieldsAttribute | Source field descriptions.
 | IndexableSourceRecordPersistenceAttribute | Information about whether a SourceType type of indexable source record is persisted
 | IndexableSourceUri | A Uri from an indexable source
 | LinkBasedImportSampler..::..InvokeMethod | An "Invoke" method, used to invoke on the UI thread.
 | LinkBasedImportSampler | Gets a sample import from a link providing source.
 | MSSQLAdapter | Adapter for MSSQL indexable sources
 | OLEAdapter | Adapter for OLE database indexable sources
 | OracleAdapter | Oracle database adapter
 | PresetDataSetAdapter | An adapter used to provide a predefined DataSet to DocumentImporter and DocumentIndex.
 | LinkBasedImportSampler..::..SampleMethod | The method the produces the sample
 | SourceType | Describes the type of information source that should be indexed.
 | WebSiteBasedSource | Represents a web-site that will be crawled.
 | WebSiteSpider | Crawls web-sites to find new links.


AddDocumentEventArgs Class

AddDocumentEventArgs Class
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► AddDocumentEventArgs
Keyoti SearchUnit v6
Arguments for AddDocument event which provides the opportunity to cancel a document from being added
Declaration Syntax
C# Visual Basic
public class AddDocumentEventArgs : EventArgs
Public Class AddDocumentEventArgs
    Inherits EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddDocumentEventArgs(Document, XmlDataAccess) | Constructor
 | Cancel | Set to true to cancel the document being added
 | Cancelable | Whether the event is cancelable - this is generally false for "Added" events and true for "Adding" events.
 | DataAccess | The current DataAccess.
 | Document | The Document that is about to be added
 | DocumentUri | The uri of the document that is about to be added
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | AddDocumentEventArgs


AddDocumentEventArgs Constructor (document, dataAccess)

AddDocumentEventArgs Constructor (document, dataAccess)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► AddDocumentEventArgs ► AddDocumentEventArgs(Document, XmlDataAccess)
Keyoti SearchUnit v6
Constructor
Declaration Syntax
C# Visual Basic
public AddDocumentEventArgs(
    Document document,
    XmlDataAccess dataAccess
)
Public Sub New (
    document As Document,
    dataAccess As XmlDataAccess
)
Parameters
document (Document)
dataAccess (XmlDataAccess)


Cancel Property

Cancel Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► AddDocumentEventArgs ► Cancel
Keyoti SearchUnit v6
Set to true to cancel the document being added
Declaration Syntax
C# Visual Basic
public bool Cancel { get; set; }
Public Property Cancel As Boolean
    Get
    Set
Property Value
Boolean

Send comments on this topic to support@keyoti.com


Cancelable Property

Cancelable Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► AddDocumentEventArgs ► Cancelable
Keyoti SearchUnit v6
Whether the event is cancelable - this is generally false for "Added" events and true for "Adding" events.
Declaration Syntax
C# Visual Basic
public bool Cancelable { get; set; }
Public Property Cancelable As Boolean
    Get
    Set
Property Value
Boolean

Send comments on this topic to support@keyoti.com


DataAccess Property

DataAccess Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► AddDocumentEventArgs ► DataAccess
Keyoti SearchUnit v6
The current DataAccess.
Declaration Syntax
C# Visual Basic
public XmlDataAccess DataAccess { get; set; }
Public Property DataAccess As XmlDataAccess
    Get
    Set
Property Value
XmlDataAccess

Send comments on this topic to support@keyoti.com


Document Property

Document Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► AddDocumentEventArgs ► Document
Keyoti SearchUnit v6
The Document that is about to be added
Declaration Syntax
C# Visual Basic
public Document Document { get; set; }
Public Property Document As Document
    Get
    Set
Property Value
Document

Send comments on this topic to support@keyoti.com


DocumentUri Property

DocumentUri Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► AddDocumentEventArgs ► DocumentUri
Keyoti SearchUnit v6
The uri of the document that is about to be added
Declaration Syntax
C# Visual Basic
public string DocumentUri { get; set; }
Public Property DocumentUri As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


AddDocumentEventHandler Delegate

AddDocumentEventHandler Delegate
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► AddDocumentEventHandler
Keyoti SearchUnit v6
Event handler
Declaration Syntax
C# Visual Basic
public delegate void AddDocumentEventHandler(
    Object sender,
    AddDocumentEventArgs e
)
Public Delegate Sub AddDocumentEventHandler (
    sender As Object,
    e As AddDocumentEventArgs
)
Parameters
sender (Object)
e (AddDocumentEventArgs)


CustomDataSetProviderAdapter Class

CustomDataSetProviderAdapter Class
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► CustomDataSetProviderAdapter
Keyoti SearchUnit v6
Obtains DataSet data from a user provided assembly.
Declaration Syntax
C# Visual Basic
public class CustomDataSetProviderAdapter : IDataSetAdapter
Public Class CustomDataSetProviderAdapter
    Implements IDataSetAdapter
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CustomDataSetProviderAdapter(String, String, Configuration) | New instance
 | Configuration | The index configuration
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetDataSet(Int32, Int32) | Gets the next set of data
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Location | The location of the assembly providing the data - should be a file path that is either absolute or relative to the index directory
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Query | The name of the class to call
 | ToString()()()() | (Inherited from Object.)
Remarks
DataSet should contain only one table, containing records from firstRow to firstRow+numberOfRows.
Inheritance Hierarchy
Object
CustomDataSetProviderAdapter

Send comments on this topic to support@keyoti.com


CustomDataSetProviderAdapter Constructor (assemblyPath, className, configuration)

CustomDataSetProviderAdapter Constructor (assemblyPath, className, configuration)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► CustomDataSetProviderAdapter ► CustomDataSetProviderAdapter(String, String, Configuration)
Keyoti SearchUnit v6
New instance
Declaration Syntax
C# Visual Basic
public CustomDataSetProviderAdapter(
    string assemblyPath,
    string className,
    Configuration configuration
)
Public Sub New (
    assemblyPath As String,
    className As String,
    configuration As Configuration
)
Parameters
assemblyPath (String)
The location of the assembly
className (String)
The class to call
configuration (Configuration)
Index configuration

Send comments on this topic to support@keyoti.com


Configuration Property

Configuration Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► CustomDataSetProviderAdapter ► Configuration
Keyoti SearchUnit v6
The index configuration
Declaration Syntax
C# Visual Basic
public Configuration Configuration { get; }
Public ReadOnly Property Configuration As Configuration
    Get
Property Value
Configuration

Send comments on this topic to support@keyoti.com


GetDataSet Method (firstRow, numberOfRows)

GetDataSet Method (firstRow, numberOfRows)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► CustomDataSetProviderAdapter ► GetDataSet(Int32, Int32)
Keyoti SearchUnit v6
Gets the next set of data
Declaration Syntax
C# Visual Basic
public virtual DataSet GetDataSet(
    int firstRow,
    int numberOfRows
)
Public Overridable Function GetDataSet (
    firstRow As Integer,
    numberOfRows As Integer
) As DataSet
Parameters
firstRow (Int32)
numberOfRows (Int32)
Return Value
DataSet

Send comments on this topic to support@keyoti.com


Location Property

Location Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► CustomDataSetProviderAdapter ► Location
Keyoti SearchUnit v6
The location of the assembly providing the data - should be a file path that is either absolute or relative to the index directory
Declaration Syntax
C# Visual Basic
public string Location { get; }
Public ReadOnly Property Location As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


Query Property

Query Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► CustomDataSetProviderAdapter ► Query
Keyoti SearchUnit v6
The name of the class to call
Declaration Syntax
C# Visual Basic
public string Query { get; }
Public ReadOnly Property Query As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


DataSetBasedSource Class

DataSetBasedSource Class
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► DataSetBasedSource
Keyoti SearchUnit v6
A dataset based source
Declaration Syntax
C# Visual Basic
public class DataSetBasedSource : IndexableSource
Public Class DataSetBasedSource
    Inherits IndexableSource
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataSetBasedSource(Configuration, IndexableSourceRecord, IDataSetAdapter) | Instantiates a dataSet based indexable source
 | AddedDocument | Fired when a document has been added to the index. (Inherited from IndexableSource.)
 | AddingDocument | Fired when a document is about to be added (Inherited from IndexableSource.)
 | Cancel()()()() | Cancel the import (Inherited from IndexableSource.)
 | Cancelled | Whether the import was cancelled. (Inherited from IndexableSource.)
 | Close()()()() | Closes the data access (Inherited from IndexableSource.)
 | Configuration | The configuration. (Inherited from IndexableSource.)
 | DataAccess | The data-access layer. (Inherited from IndexableSource.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FindDataRow(String, String) | Looks through the current and subsequent pages of DataSets for a DataRow whose primary key value is primaryKeyValue
 | GetHashCode()()()() | (Inherited from Object.)
 | GetImportSample(DataSet, Int32, LinkBasedImportSampler..::..InvokeMethod) | Gets a sample of the import data that Import will retrieve. (Overrides IndexableSource.GetImportSample(DataSet, Int32, LinkBasedImportSampler..::..InvokeMethod).)
 | GetNextDataSet()()()() | Gets the next DataSet chunk from the data source.
 | GetType()()()() | (Inherited from Object.)
 | Import()()()() | Imports the records for an indexable source (Overrides IndexableSource.Import()()()().)
 | ImportSampleDataTableColumnsFinalized | Fired when the DataTable used for the import sample has it's columns finalized. (Inherited from IndexableSource.)
 | IndexableSourceRecord | The record representing this source, in the data-access (Inherited from IndexableSource.)
 | ItemsImported | The number of rows that have been imported since the last call to Import. (Overrides IndexableSource.ItemsImported.)
 | ItemsToImportTotal | If available. The total number of items (documents, records, files, etc) that will be imported. (Inherited from IndexableSource.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnAddedDocument(AddDocumentEventArgs) | Fires the AddedDocument event. (Inherited from IndexableSource.)
 | OnAddingDocument(AddDocumentEventArgs) | Fires the AddingDocument event. (Inherited from IndexableSource.)
 | OnImportSampleDataTableColumnsFinalized(EventArgs) | Raises ImportSampleDataTableColumnsFinalized (Inherited from IndexableSource.)
 | OnReaderExceptionOccurred(ReaderExceptionOccurredEventArgs) | Called whenever a readerException is caught (Inherited from IndexableSource.)
 | Open()()()() | Opens the data access (Inherited from IndexableSource.)
 | PageSize | The number of records to read in each paging operation.
 | ReaderExceptionOccurred | Fired whenever the (web) reader encounters a network exception, eg. 404 (this can be useful for identifying dead links) (Inherited from IndexableSource.)
 | Reset()()()() | Resets the iterator to the start of the DataSet
 | SetIndexableSourceRecord(IndexableSourceRecord) | Sets record representing this source, in the data-access (Inherited from IndexableSource.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | IndexableSource
 |  | DataSetBasedSource


DataSetBasedSource Constructor (configuration, indexableSourceRecord, dataSetAdapter)

DataSetBasedSource Constructor (configuration, indexableSourceRecord, dataSetAdapter)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► DataSetBasedSource ► DataSetBasedSource(Configuration, IndexableSourceRecord, IDataSetAdapter)
Keyoti SearchUnit v6
Instantiates a dataSet based indexable source
Declaration Syntax
C# Visual Basic
public DataSetBasedSource(
    Configuration configuration,
    IndexableSourceRecord indexableSourceRecord,
    IDataSetAdapter dataSetAdapter
)
Public Sub New (
    configuration As Configuration,
    indexableSourceRecord As IndexableSourceRecord,
    dataSetAdapter As IDataSetAdapter
)
Parameters
configuration (Configuration)
indexableSourceRecord (IndexableSourceRecord)
dataSetAdapter (IDataSetAdapter)


FindDataRow Method (primaryKeyValue, uniqueColumn)

FindDataRow Method (primaryKeyValue, uniqueColumn)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► DataSetBasedSource ► FindDataRow(String, String)
Keyoti SearchUnit v6
Looks through the current and subsequent pages of DataSets for a DataRow whose primary key value is primaryKeyValue
Declaration Syntax
C# Visual Basic
public virtual DataRow FindDataRow(
    string primaryKeyValue,
    string uniqueColumn
)
Public Overridable Function FindDataRow (
    primaryKeyValue As String,
    uniqueColumn As String
) As DataRow
Parameters
primaryKeyValue (String)
The value of the primary key identifying the row
uniqueColumn (String)
The name of the primary key column
Return Value
DataRow

Send comments on this topic to support@keyoti.com


GetImportSample Method (dataSet, sampleSize, invoker)

GetImportSample Method (dataSet, sampleSize, invoker)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► DataSetBasedSource ► GetImportSample(DataSet, Int32, LinkBasedImportSampler..::..InvokeMethod)
Keyoti SearchUnit v6
Gets a sample of the import data that Import will retrieve.
Declaration Syntax
C# Visual Basic
public override void GetImportSample(
    DataSet dataSet,
    int sampleSize,
    LinkBasedImportSampler..::..InvokeMethod invoker
)
Public Overrides Sub GetImportSample (
    dataSet As DataSet,
    sampleSize As Integer,
    invoker As LinkBasedImportSampler..::..InvokeMethod
)
Parameters
dataSet (DataSet)
The DataSet where a DataTable containing the data will be added.
sampleSize (Int32)
The number of records to retrieve.
invoker (LinkBasedImportSampler..::..InvokeMethod)
A UI control with an Invoke method, which can be used to invoke a method on the UI thread. Can only be null when operating outside of Windows Forms.


GetNextDataSet Method

GetNextDataSet Method
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► DataSetBasedSource ► GetNextDataSet()()()()
Keyoti SearchUnit v6
Gets the next DataSet chunk from the data source.
Declaration Syntax
C# Visual Basic
public virtual DataSet GetNextDataSet()
Public Overridable Function GetNextDataSet As DataSet
Return Value
DataSet
A data set containing the next PageSize records, or null/Nothing if no more records exist.


Import Method

Import Method
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► DataSetBasedSource ► Import()()()()
Keyoti SearchUnit v6
Imports the records for an indexable source
Declaration Syntax
C# Visual Basic
public override ArrayList Import()
Public Overrides Function Import As ArrayList
Return Value
ArrayList
ArrayList of Uri objects of all records found in source.


ItemsImported Property

ItemsImported Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► DataSetBasedSource ► ItemsImported
Keyoti SearchUnit v6
The number of rows that have been imported since the last call to Import.
Declaration Syntax
C# Visual Basic
public override int ItemsImported { get; }
Public Overrides ReadOnly Property ItemsImported As Integer
    Get
Property Value
Int32
Remarks
Access this property from a different thread to track import progress.


PageSize Property

PageSize Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► DataSetBasedSource ► PageSize
Keyoti SearchUnit v6
The number of records to read in each paging operation.
Declaration Syntax
C# Visual Basic
public int PageSize { get; }
Public ReadOnly Property PageSize As Integer
    Get
Property Value
Int32
Remarks
Set to zero to obtain all records in one go.


Reset Method

Reset Method
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► DataSetBasedSource ► Reset()()()()
Keyoti SearchUnit v6
Resets the iterator to the start of the DataSet
Declaration Syntax
C# Visual Basic
public void Reset()
Public Sub Reset

Send comments on this topic to support@keyoti.com


FileSysDocumentStore Class

FileSysDocumentStore Class
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► FileSysDocumentStore
Keyoti SearchUnit v6
Imports documents found in a directory
Declaration Syntax
C# Visual Basic
public class FileSysDocumentStore
Public Class FileSysDocumentStore
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FileSysDocumentStore(DirectoryInfo, Uri, Configuration) | Constructor
 | AddedDocument | Fired when a document has been added to the index.
 | AddingDocument | Fired when a document is about to be added. Can be canceled.
 | Cancel()()()() | Cancels the import
 | Close()()()() | Closes the index for use
 | Configuration | Gets the instance of the Configuration class that holds the settings to be used.
 | ConvertFilePathToUrl(String) | Converts the file's path, to a url based on the virtual folder.
 | DataAccess | The data-access layer.
 | DiscoverFiles(Boolean, ArrayList, ArrayList, String, ArrayList, ArrayList) | Retrieves all the eligable files
 | Equals(Object) | (Inherited from Object.)
 | Exceptions | List of exceptions that occurred during the operation.
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Import(Boolean, ArrayList, ArrayList, String) | Finds new files belonging to specified categories from under root (subdirectories optional) to the document list
 | Import(Boolean, ArrayList, ArrayList, String, IndexableSourceRecord) | Finds new files belonging to specified categories from under root (subdirectories optional) to the document list
 | ImportedFiles | Number of files so far imported
 | ItemsToImportTotal | If available, the total number of items (documents, records, files, etc) that will be imported, otherwise returns -1.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Open()()()() | Opens the index for use
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
FileSysDocumentStore

Send comments on this topic to support@keyoti.com


FileSysDocumentStore Constructor (rootPath, rootVirtualPath, configuration)

FileSysDocumentStore Constructor (rootPath, rootVirtualPath, configuration)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► FileSysDocumentStore ► FileSysDocumentStore(DirectoryInfo, Uri, Configuration)
Keyoti SearchUnit v6
Constructor
Declaration Syntax
C# Visual Basic
public FileSysDocumentStore(
    DirectoryInfo rootPath,
    Uri rootVirtualPath,
    Configuration configuration
)
Public Sub New (
    rootPath As DirectoryInfo,
    rootVirtualPath As Uri,
    configuration As Configuration
)
Parameters
rootPath (DirectoryInfo)
Folder specification for importing files (absolute path)
rootVirtualPath (Uri)
The virtual path.
configuration (Configuration)
The instance of the Configuration class that holds the settings to be used.


AddedDocument Event

AddedDocument Event
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► FileSysDocumentStore ► AddedDocument
Keyoti SearchUnit v6
Fired when a document has been added to the index.
Declaration Syntax
C# Visual Basic
public event AddDocumentEventHandler AddedDocument
Public Event AddedDocument As AddDocumentEventHandler
Value
AddDocumentEventHandler

Send comments on this topic to support@keyoti.com


AddingDocument Event

AddingDocument Event
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► FileSysDocumentStore ► AddingDocument
Keyoti SearchUnit v6
Fired when a document is about to be added. Can be canceled.
Declaration Syntax
C# Visual Basic
public event AddDocumentEventHandler AddingDocument
Public Event AddingDocument As AddDocumentEventHandler
Value
AddDocumentEventHandler

Send comments on this topic to support@keyoti.com


Cancel Method

Cancel Method
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► FileSysDocumentStore ► Cancel()()()()
Keyoti SearchUnit v6
Cancels the import
Declaration Syntax
C# Visual Basic
public void Cancel()
Public Sub Cancel

Send comments on this topic to support@keyoti.com


Close Method

Close Method
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► FileSysDocumentStore ► Close()()()()
Keyoti SearchUnit v6
Closes the index for use
Declaration Syntax
C# Visual Basic
public virtual void Close()
Public Overridable Sub Close

Send comments on this topic to support@keyoti.com


Configuration Property

Configuration Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► FileSysDocumentStore ► Configuration
Keyoti SearchUnit v6
Gets the instance of the Configuration class that holds the settings to be used.
Declaration Syntax
C# Visual Basic
public Configuration Configuration { get; }
Public ReadOnly Property Configuration As Configuration
    Get
Property Value
Configuration

Send comments on this topic to support@keyoti.com


ConvertFilePathToUrl Method (filepath)

ConvertFilePathToUrl Method (filepath)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► FileSysDocumentStore ► ConvertFilePathToUrl(String)
Keyoti SearchUnit v6
Converts the file's path, to a url based on the virtual folder.
Declaration Syntax
C# Visual Basic
protected virtual string ConvertFilePathToUrl(
    string filepath
)
Protected Overridable Function ConvertFilePathToUrl (
    filepath As String
) As String
Parameters
filepath (String)
Return Value
String

Send comments on this topic to support@keyoti.com


DataAccess Property

DataAccess Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► FileSysDocumentStore ► DataAccess
Keyoti SearchUnit v6
The data-access layer.
Declaration Syntax
C# Visual Basic
public virtual XmlDataAccess DataAccess { get; set; }
Public Overridable Property DataAccess As XmlDataAccess
    Get
    Set
Property Value
XmlDataAccess

Send comments on this topic to support@keyoti.com


DiscoverFiles Method (isRecursive, targetMatches, noRecurseMatches, loginURL, theFoundItems, foundFileUrls)

DiscoverFiles Method (isRecursive, targetMatches, noRecurseMatches, loginURL, theFoundItems, foundFileUrls)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► FileSysDocumentStore ► DiscoverFiles(Boolean, ArrayList, ArrayList, String, ArrayList, ArrayList)
Keyoti SearchUnit v6
Retrieves all the eligable files
Declaration Syntax
C# Visual Basic
public ArrayList DiscoverFiles(
    bool isRecursive,
    ArrayList targetMatches,
    ArrayList noRecurseMatches,
    string loginURL,
    ArrayList theFoundItems,
    ArrayList foundFileUrls
)
Public Function DiscoverFiles (
    isRecursive As Boolean,
    targetMatches As ArrayList,
    noRecurseMatches As ArrayList,
    loginURL As String,
    theFoundItems As ArrayList,
    foundFileUrls As ArrayList
) As ArrayList
Parameters
isRecursive (Boolean)
If subdirectories will be browsed
targetMatches (ArrayList)
Pattern specification for including files
noRecurseMatches (ArrayList)
Pattern specification for ignoring files
loginURL (String)
theFoundItems (ArrayList)
List of found files
foundFileUrls (ArrayList)
Url strings of found documents
Return Value
ArrayList
List of string file paths

Send comments on this topic to support@keyoti.com


Exceptions Property

Exceptions Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► FileSysDocumentStore ► Exceptions
Keyoti SearchUnit v6
List of exceptions that occurred during the operation.
Declaration Syntax
C# Visual Basic
public ArrayList Exceptions { get; }
Public ReadOnly Property Exceptions As ArrayList
    Get
Property Value
ArrayList

Send comments on this topic to support@keyoti.com


Import Method

Import Method
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► FileSysDocumentStore ► Import()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Import(Boolean, ArrayList, ArrayList, String) | Finds new files belonging to specified categories from under root (subdirectories optional) to the document list
 | Import(Boolean, ArrayList, ArrayList, String, IndexableSourceRecord) | Finds new files belonging to specified categories from under root (subdirectories optional) to the document list


Import Method (isRecursive, targetMatches, noRecurseMatches, loginURL)

Import Method (isRecursive, targetMatches, noRecurseMatches, loginURL)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► FileSysDocumentStore ► Import(Boolean, ArrayList, ArrayList, String)
Keyoti SearchUnit v6
Finds new files belonging to specified categories from under root (subdirectories optional) to the document list
Declaration Syntax
C# Visual Basic
public ArrayList Import(
    bool isRecursive,
    ArrayList targetMatches,
    ArrayList noRecurseMatches,
    string loginURL
)
Public Function Import (
    isRecursive As Boolean,
    targetMatches As ArrayList,
    noRecurseMatches As ArrayList,
    loginURL As String
) As ArrayList
Parameters
isRecursive (Boolean)
Subdirectories will be recursively browsed too
targetMatches (ArrayList)
Pattern specification for including files
noRecurseMatches (ArrayList)
Pattern specification for ignoring files
loginURL (String)
Return Value
ArrayList
Collection of strings of imported Urls

Send comments on this topic to support@keyoti.com


Import Method (isRecursive, targetMatches, noRecurseMatches, loginURL, record)

Import Method (isRecursive, targetMatches, noRecurseMatches, loginURL, record)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► FileSysDocumentStore ► Import(Boolean, ArrayList, ArrayList, String, IndexableSourceRecord)
Keyoti SearchUnit v6
Finds new files belonging to specified categories from under root (subdirectories optional) to the document list
Declaration Syntax
C# Visual Basic
public virtual ArrayList Import(
    bool isRecursive,
    ArrayList targetMatches,
    ArrayList noRecurseMatches,
    string loginURL,
    IndexableSourceRecord record
)
Public Overridable Function Import (
    isRecursive As Boolean,
    targetMatches As ArrayList,
    noRecurseMatches As ArrayList,
    loginURL As String,
    record As IndexableSourceRecord
) As ArrayList
Parameters
isRecursive (Boolean)
Subdirectories will be recursively browsed too
targetMatches (ArrayList)
Pattern specification for including files
noRecurseMatches (ArrayList)
Pattern specification for ignoring files
loginURL (String)
The URL to login with before indexing.
record (IndexableSourceRecord)
The IndexableSourceRecord that the documents shall be assigned to - can be null.
Return Value
ArrayList
Collection of strings of imported Urls

Send comments on this topic to support@keyoti.com


ImportedFiles Property

ImportedFiles Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► FileSysDocumentStore ► ImportedFiles
Keyoti SearchUnit v6
Number of files so far imported
Declaration Syntax
C# Visual Basic
public int ImportedFiles { get; }
Public ReadOnly Property ImportedFiles As Integer
    Get
Property Value
Int32

Send comments on this topic to support@keyoti.com


ItemsToImportTotal Property

ItemsToImportTotal Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► FileSysDocumentStore ► ItemsToImportTotal
Keyoti SearchUnit v6
If available, the total number of items (documents, records, files, etc) that will be imported, otherwise returns -1.
Declaration Syntax
C# Visual Basic
public int ItemsToImportTotal { get; }
Public ReadOnly Property ItemsToImportTotal As Integer
    Get
Property Value
Int32
Remarks
Access this property from a different thread to track import progress.


Open Method

Open Method
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► FileSysDocumentStore ► Open()()()()
Keyoti SearchUnit v6
Opens the index for use
Declaration Syntax
C# Visual Basic
public virtual void Open()
Public Overridable Sub Open

Send comments on this topic to support@keyoti.com


FileSystemFolderBasedSource Class

FileSystemFolderBasedSource Class
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► FileSystemFolderBasedSource
Keyoti SearchUnit v6
Represents a file system directory as a source of documents.
Declaration Syntax
C# Visual Basic
public class FileSystemFolderBasedSource : IndexableSource
Public Class FileSystemFolderBasedSource
    Inherits IndexableSource
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FileSystemFolderBasedSource(Configuration, FileSystemFolderBasedSourceRecord) | Instantiates a website based indexable source
 | AddedDocument | Fired when a document has been added to the index. (Inherited from IndexableSource.)
 | AddingDocument | Fired when a document is about to be added (Inherited from IndexableSource.)
 | Cancel()()()() | Cancel importing files (Overrides IndexableSource.Cancel()()()().)
 | Cancelled | Whether the import was cancelled. (Inherited from IndexableSource.)
 | Close()()()() | Closes the data access (Inherited from IndexableSource.)
 | Configuration | The configuration. (Inherited from IndexableSource.)
 | DataAccess | The data-access layer. (Inherited from IndexableSource.)
 | DiscoverFiles(ArrayList) | Uses FileSysDocumentStore.DiscoverLinkURLs to find documents under the directory specified in IndexableSourceRecord.Location
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetImportSample(DataSet, Int32, LinkBasedImportSampler..::..InvokeMethod) | Gets a sample of the import data that Import will retrieve. (Overrides IndexableSource.GetImportSample(DataSet, Int32, LinkBasedImportSampler..::..InvokeMethod).)
 | GetType()()()() | (Inherited from Object.)
 | Import()()()() | Imports files from the specified source. (Overrides IndexableSource.Import()()()().)
 | ImportSampleDataTableColumnsFinalized | Fired when the DataTable used for the import sample has it's columns finalized. (Inherited from IndexableSource.)
 | IndexableSourceRecord | The record representing this source, in the data-access (Inherited from IndexableSource.)
 | ItemsImported | Number of files that have been imported (Overrides IndexableSource.ItemsImported.)
 | ItemsToImportTotal | If available, the total number of items (documents, records, files, etc) that will be imported, otherwise returns -1. (Overrides IndexableSource.ItemsToImportTotal.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnAddedDocument(AddDocumentEventArgs) | Fires the AddedDocument event. (Inherited from IndexableSource.)
 | OnAddingDocument(AddDocumentEventArgs) | Fires the AddingDocument event. (Inherited from IndexableSource.)
 | OnImportSampleDataTableColumnsFinalized(EventArgs) | Raises ImportSampleDataTableColumnsFinalized (Inherited from IndexableSource.)
 | OnReaderExceptionOccurred(ReaderExceptionOccurredEventArgs) | Called whenever a readerException is caught (Inherited from IndexableSource.)
 | Open()()()() | Opens the data access (Inherited from IndexableSource.)
 | ReaderExceptionOccurred | Fired whenever the (web) reader encounters a network exception, eg. 404 (this can be useful for identifying dead links) (Inherited from IndexableSource.)
 | SetIndexableSourceRecord(IndexableSourceRecord) | Sets record representing this source, in the data-access (Inherited from IndexableSource.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | IndexableSource
 |  | FileSystemFolderBasedSource


FileSystemFolderBasedSource Constructor (configuration, indexableSourceRecord)

FileSystemFolderBasedSource Constructor (configuration, indexableSourceRecord)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► FileSystemFolderBasedSource ► FileSystemFolderBasedSource(Configuration, FileSystemFolderBasedSourceRecord)
Keyoti SearchUnit v6
Instantiates a website based indexable source
Declaration Syntax
C# Visual Basic
public FileSystemFolderBasedSource(
    Configuration configuration,
    FileSystemFolderBasedSourceRecord indexableSourceRecord
)
Public Sub New (
    configuration As Configuration,
    indexableSourceRecord As FileSystemFolderBasedSourceRecord
)
Parameters
configuration (Configuration)
indexableSourceRecord (FileSystemFolderBasedSourceRecord)


Cancel Method

Cancel Method
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► FileSystemFolderBasedSource ► Cancel()()()()
Keyoti SearchUnit v6
Cancel importing files
Declaration Syntax
C# Visual Basic
public override void Cancel()
Public Overrides Sub Cancel

Send comments on this topic to support@keyoti.com


DiscoverFiles Method (newLinks)

DiscoverFiles Method (newLinks)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► FileSystemFolderBasedSource ► DiscoverFiles(ArrayList)
Keyoti SearchUnit v6
Uses FileSysDocumentStore.DiscoverLinkURLs to find documents under the directory specified in IndexableSourceRecord.Location
Declaration Syntax
C# Visual Basic
public void DiscoverFiles(
    ArrayList newLinks
)
Public Sub DiscoverFiles (
    newLinks As ArrayList
)
Parameters
newLinks (ArrayList)
List that found link URL strings are added to.


GetImportSample Method (dataSet, sampleSize, invoker)

GetImportSample Method (dataSet, sampleSize, invoker)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► FileSystemFolderBasedSource ► GetImportSample(DataSet, Int32, LinkBasedImportSampler..::..InvokeMethod)
Keyoti SearchUnit v6
Gets a sample of the import data that Import will retrieve.
Declaration Syntax
C# Visual Basic
public override void GetImportSample(
    DataSet dataSet,
    int sampleSize,
    LinkBasedImportSampler..::..InvokeMethod invoker
)
Public Overrides Sub GetImportSample (
    dataSet As DataSet,
    sampleSize As Integer,
    invoker As LinkBasedImportSampler..::..InvokeMethod
)
Parameters
dataSet (DataSet)
The DataSet where a DataTable containing the data will be added.
sampleSize (Int32)
The number of records to retrieve.
invoker (LinkBasedImportSampler..::..InvokeMethod)
A UI control with an Invoke method, which can be used to invoke a method on the UI thread. Can only be null when operating outside of Windows Forms.


Import Method

Import Method
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► FileSystemFolderBasedSource ► Import()()()()
Keyoti SearchUnit v6
Imports files from the specified source.
Declaration Syntax
C# Visual Basic
public override ArrayList Import()
Public Overrides Function Import As ArrayList
Return Value
ArrayList
List of Uri objects for imported documents.


ItemsImported Property

ItemsImported Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► FileSystemFolderBasedSource ► ItemsImported
Keyoti SearchUnit v6
Number of files that have been imported
Declaration Syntax
C# Visual Basic
public override int ItemsImported { get; }
Public Overrides ReadOnly Property ItemsImported As Integer
    Get
Property Value
Int32

Send comments on this topic to support@keyoti.com


ItemsToImportTotal Property

ItemsToImportTotal Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► FileSystemFolderBasedSource ► ItemsToImportTotal
Keyoti SearchUnit v6
If available, the total number of items (documents, records, files, etc) that will be imported, otherwise returns -1.
Declaration Syntax
C# Visual Basic
public override int ItemsToImportTotal { get; }
Public Overrides ReadOnly Property ItemsToImportTotal As Integer
    Get
Property Value
Int32
Remarks
Access this property from a different thread to track import progress.


IDataSetAdapter Interface

IDataSetAdapter Interface
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IDataSetAdapter
Keyoti SearchUnit v6
A dataset adapter
Declaration Syntax
C# Visual Basic
public interface IDataSetAdapter
Public Interface IDataSetAdapter
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetDataSet(Int32, Int32) | Gets the page of data
 | Location | Generic location identified
 | Query | Generic query


GetDataSet Method (firstRow, numberOfRows)

GetDataSet Method (firstRow, numberOfRows)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IDataSetAdapter ► GetDataSet(Int32, Int32)
Keyoti SearchUnit v6
Gets the page of data
Declaration Syntax
C# Visual Basic
DataSet GetDataSet(
    int firstRow,
    int numberOfRows
)
Function GetDataSet (
    firstRow As Integer,
    numberOfRows As Integer
) As DataSet
Parameters
firstRow (Int32)
The first row of data to get
numberOfRows (Int32)
The number of rows to get
Return Value
DataSet
A DataSet holding only the requested data in a DataTable.


Location Property

Location Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IDataSetAdapter ► Location
Keyoti SearchUnit v6
Generic location identified
Declaration Syntax
C# Visual Basic
string Location { get; }
ReadOnly Property Location As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


Query Property

Query Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IDataSetAdapter ► Query
Keyoti SearchUnit v6
Generic query
Declaration Syntax
C# Visual Basic
string Query { get; }
ReadOnly Property Query As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


IIndexableSource Interface

IIndexableSource Interface
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IIndexableSource
Keyoti SearchUnit v6
An indexable source
Declaration Syntax
C# Visual Basic
public interface IIndexableSource
Public Interface IIndexableSource
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddedDocument | Fired when a document has been added
 | AddingDocument | Fired when a document is about to be added
 | Cancel()()()() | Cancel the import
 | Cancelled | Whether the import was cancelled.
 | Close()()()() | Closes the data access
 | Configuration | The configuration
 | DataAccess | The data-access facade
 | GetImportSample(DataSet, Int32, LinkBasedImportSampler..::..InvokeMethod) | Gets a sample of the import data that Import will retrieve.
 | Import()()()() | Adds new files imported from the source
 | ImportSampleDataTableColumnsFinalized | Fired when the DataTable used for the import sample has it's columns finalized.
 | IndexableSourceRecord | The record representing this source, in the data-access
 | ItemsImported | The number of items (documents, records, files etc.) that have been imported since the last call to Import.
 | ItemsToImportTotal | If available. The total number of items (documents, records, files, etc) that will be imported.
 | Open()()()() | Opens the data access
 | ReaderExceptionOccurred | Fired when a reader exception occurs


AddedDocument Event

AddedDocument Event
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IIndexableSource ► AddedDocument
Keyoti SearchUnit v6
Fired when a document has been added
Declaration Syntax
C# Visual Basic
event AddDocumentEventHandler AddedDocument
Event AddedDocument As AddDocumentEventHandler
Value
AddDocumentEventHandler

Send comments on this topic to support@keyoti.com


AddingDocument Event

AddingDocument Event
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IIndexableSource ► AddingDocument
Keyoti SearchUnit v6
Fired when a document is about to be added
Declaration Syntax
C# Visual Basic
event AddDocumentEventHandler AddingDocument
Event AddingDocument As AddDocumentEventHandler
Value
AddDocumentEventHandler

Send comments on this topic to support@keyoti.com


Cancel Method

Cancel Method
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IIndexableSource ► Cancel()()()()
Keyoti SearchUnit v6
Cancel the import
Declaration Syntax
C# Visual Basic
void Cancel()
Sub Cancel

Send comments on this topic to support@keyoti.com


Cancelled Property

Cancelled Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IIndexableSource ► Cancelled
Keyoti SearchUnit v6
Whether the import was cancelled.
Declaration Syntax
C# Visual Basic
bool Cancelled { get; }
ReadOnly Property Cancelled As Boolean
    Get
Property Value
Boolean

Send comments on this topic to support@keyoti.com


Close Method

Close Method
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IIndexableSource ► Close()()()()
Keyoti SearchUnit v6
Closes the data access
Declaration Syntax
C# Visual Basic
void Close()
Sub Close

Send comments on this topic to support@keyoti.com


Configuration Property

Configuration Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IIndexableSource ► Configuration
Keyoti SearchUnit v6
The configuration
Declaration Syntax
C# Visual Basic
Configuration Configuration { get; }
ReadOnly Property Configuration As Configuration
    Get
Property Value
Configuration

Send comments on this topic to support@keyoti.com


DataAccess Property

DataAccess Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IIndexableSource ► DataAccess
Keyoti SearchUnit v6
The data-access facade
Declaration Syntax
C# Visual Basic
XmlDataAccess DataAccess { get; set; }
Property DataAccess As XmlDataAccess
    Get
    Set
Property Value
XmlDataAccess

Send comments on this topic to support@keyoti.com


GetImportSample Method (dataSet, sampleSize, invoker)

GetImportSample Method (dataSet, sampleSize, invoker)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IIndexableSource ► GetImportSample(DataSet, Int32, LinkBasedImportSampler..::..InvokeMethod)
Keyoti SearchUnit v6
Gets a sample of the import data that Import will retrieve.
Declaration Syntax
C# Visual Basic
void GetImportSample(
    DataSet dataSet,
    int sampleSize,
    LinkBasedImportSampler..::..InvokeMethod invoker
)
Sub GetImportSample (
    dataSet As DataSet,
    sampleSize As Integer,
    invoker As LinkBasedImportSampler..::..InvokeMethod
)
Parameters
dataSet (DataSet)
The DataSet where a DataTable containing the data will be added.
sampleSize (Int32)
The number of records to retrieve.
invoker (LinkBasedImportSampler..::..InvokeMethod)
A UI control with an Invoke method, which can be used to invoke a method on the UI thread. Can only be null when operating outside of Windows Forms.


Import Method

Import Method
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IIndexableSource ► Import()()()()
Keyoti SearchUnit v6
Adds new files imported from the source
Declaration Syntax
C# Visual Basic
ArrayList Import()
Function Import As ArrayList
Return Value
ArrayList
Collection of strings of imported Urls

Send comments on this topic to support@keyoti.com


ImportSampleDataTableColumnsFinalized Event

ImportSampleDataTableColumnsFinalized Event
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IIndexableSource ► ImportSampleDataTableColumnsFinalized
Keyoti SearchUnit v6
Fired when the DataTable used for the import sample has it's columns finalized.
Declaration Syntax
C# Visual Basic
event EventHandler ImportSampleDataTableColumnsFinalized
Event ImportSampleDataTableColumnsFinalized As EventHandler
Value
EventHandler

Send comments on this topic to support@keyoti.com


IndexableSourceRecord Property

IndexableSourceRecord Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IIndexableSource ► IndexableSourceRecord
Keyoti SearchUnit v6
The record representing this source, in the data-access
Declaration Syntax
C# Visual Basic
IndexableSourceRecord IndexableSourceRecord { get; }
ReadOnly Property IndexableSourceRecord As IndexableSourceRecord
    Get
Property Value
IndexableSourceRecord

Send comments on this topic to support@keyoti.com


ItemsImported Property

ItemsImported Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IIndexableSource ► ItemsImported
Keyoti SearchUnit v6
The number of items (documents, records, files etc.) that have been imported since the last call to Import.
Declaration Syntax
C# Visual Basic
int ItemsImported { get; }
ReadOnly Property ItemsImported As Integer
    Get
Property Value
Int32
Remarks
Access this property from a different thread to track import progress.


ItemsToImportTotal Property

ItemsToImportTotal Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IIndexableSource ► ItemsToImportTotal
Keyoti SearchUnit v6
If available. The total number of items (documents, records, files, etc) that will be imported.
Declaration Syntax
C# Visual Basic
int ItemsToImportTotal { get; }
ReadOnly Property ItemsToImportTotal As Integer
    Get
Property Value
Int32
Remarks
Access this property from a different thread to track import progress.


Open Method

Open Method
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IIndexableSource ► Open()()()()
Keyoti SearchUnit v6
Opens the data access
Declaration Syntax
C# Visual Basic
void Open()
Sub Open

Send comments on this topic to support@keyoti.com


ReaderExceptionOccurred Event

ReaderExceptionOccurred Event
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IIndexableSource ► ReaderExceptionOccurred
Keyoti SearchUnit v6
Fired when a reader exception occurs
Declaration Syntax
C# Visual Basic
event ReaderExceptionOccurredEventHandler ReaderExceptionOccurred
Event ReaderExceptionOccurred As ReaderExceptionOccurredEventHandler
Value
ReaderExceptionOccurredEventHandler

Send comments on this topic to support@keyoti.com


IndexableSource Class

IndexableSource Class
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSource
Keyoti SearchUnit v6
Base abstract class for indexable source types.
Declaration Syntax
C# Visual Basic
public abstract class IndexableSource : IIndexableSource
Public MustInherit Class IndexableSource
    Implements IIndexableSource
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IndexableSource()()()() |
 | AddedDocument | Fired when a document has been added to the index.
 | AddingDocument | Fired when a document is about to be added
 | Cancel()()()() | Cancel the import
 | Cancelled | Whether the import was cancelled.
 | Close()()()() | Closes the data access
 | Configuration | The configuration.
 | DataAccess | The data-access layer.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetDocuments(DocumentIndex, IndexableSourceRecord, Configuration) | Gets a collection of Document objects belonging to an indexable source
 | GetHashCode()()()() | (Inherited from Object.)
 | GetImportSample(DataSet, Int32, LinkBasedImportSampler..::..InvokeMethod) | Gets a sample of the import data that Import will retrieve.
 | GetType()()()() | (Inherited from Object.)
 | Import()()()() | Adds new files imported from the source
 | ImportSampleDataTableColumnsFinalized | Fired when the DataTable used for the import sample has it's columns finalized.
 | IndexableSourceRecord | The record representing this source, in the data-access
 | ItemsImported | The number of items that have been imported since the last call to Import.
 | ItemsToImportTotal | If available. The total number of items (documents, records, files, etc) that will be imported.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnAddedDocument(AddDocumentEventArgs) | Fires the AddedDocument event.
 | OnAddingDocument(AddDocumentEventArgs) | Fires the AddingDocument event.
 | OnImportSampleDataTableColumnsFinalized(EventArgs) | Raises ImportSampleDataTableColumnsFinalized
 | OnReaderExceptionOccurred(ReaderExceptionOccurredEventArgs) | Called whenever a readerException is caught
 | Open()()()() | Opens the data access
 | ReaderExceptionOccurred | Fired whenever the (web) reader encounters a network exception, eg. 404 (this can be useful for identifying dead links)
 | SetIndexableSourceRecord(IndexableSourceRecord) | Sets record representing this source, in the data-access
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | IndexableSource
 |  | DataSetBasedSource
 |  | FileSystemFolderBasedSource
 |  | WebSiteBasedSource


IndexableSource Constructor

IndexableSource Constructor
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSource ► IndexableSource()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
protected IndexableSource()
Protected Sub New

Send comments on this topic to support@keyoti.com


AddedDocument Event

AddedDocument Event
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSource ► AddedDocument
Keyoti SearchUnit v6
Fired when a document has been added to the index.
Declaration Syntax
C# Visual Basic
public event AddDocumentEventHandler AddedDocument
Public Event AddedDocument As AddDocumentEventHandler
Value
AddDocumentEventHandler

Send comments on this topic to support@keyoti.com


AddingDocument Event

AddingDocument Event
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSource ► AddingDocument
Keyoti SearchUnit v6
Fired when a document is about to be added
Declaration Syntax
C# Visual Basic
public event AddDocumentEventHandler AddingDocument
Public Event AddingDocument As AddDocumentEventHandler
Value
AddDocumentEventHandler

Send comments on this topic to support@keyoti.com


Cancel Method

Cancel Method
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSource ► Cancel()()()()
Keyoti SearchUnit v6
Cancel the import
Declaration Syntax
C# Visual Basic
public virtual void Cancel()
Public Overridable Sub Cancel

Send comments on this topic to support@keyoti.com


Cancelled Property

Cancelled Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSource ► Cancelled
Keyoti SearchUnit v6
Whether the import was cancelled.
Declaration Syntax
C# Visual Basic
public virtual bool Cancelled { get; }
Public Overridable ReadOnly Property Cancelled As Boolean
    Get
Property Value
Boolean

Send comments on this topic to support@keyoti.com


Close Method

Close Method
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSource ► Close()()()()
Keyoti SearchUnit v6
Closes the data access
Declaration Syntax
C# Visual Basic
public virtual void Close()
Public Overridable Sub Close

Send comments on this topic to support@keyoti.com


Configuration Property

Configuration Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSource ► Configuration
Keyoti SearchUnit v6
The configuration.
Declaration Syntax
C# Visual Basic
public virtual Configuration Configuration { get; set; }
Public Overridable Property Configuration As Configuration
    Get
    Set
Property Value
Configuration

Send comments on this topic to support@keyoti.com


DataAccess Property

DataAccess Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSource ► DataAccess
Keyoti SearchUnit v6
The data-access layer.
Declaration Syntax
C# Visual Basic
public virtual XmlDataAccess DataAccess { get; set; }
Public Overridable Property DataAccess As XmlDataAccess
    Get
    Set
Property Value
XmlDataAccess

Send comments on this topic to support@keyoti.com


GetDocuments Method (di, indexableSourceRecord, configuration)

GetDocuments Method (di, indexableSourceRecord, configuration)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSource ► GetDocuments(DocumentIndex, IndexableSourceRecord, Configuration)
Keyoti SearchUnit v6
Gets a collection of Document objects belonging to an indexable source
Declaration Syntax
C# Visual Basic
public static ArrayList GetDocuments(
    DocumentIndex di,
    IndexableSourceRecord indexableSourceRecord,
    Configuration configuration
)
Public Shared Function GetDocuments (
    di As DocumentIndex,
    indexableSourceRecord As IndexableSourceRecord,
    configuration As Configuration
) As ArrayList
Parameters
di (DocumentIndex)
indexableSourceRecord (IndexableSourceRecord)
configuration (Configuration)
Return Value
ArrayList
ArrayList of Document objects

Send comments on this topic to support@keyoti.com


GetImportSample Method (dataSet, sampleSize, invoker)

GetImportSample Method (dataSet, sampleSize, invoker)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSource ► GetImportSample(DataSet, Int32, LinkBasedImportSampler..::..InvokeMethod)
Keyoti SearchUnit v6
Gets a sample of the import data that Import will retrieve.
Declaration Syntax
C# Visual Basic
public abstract void GetImportSample(
    DataSet dataSet,
    int sampleSize,
    LinkBasedImportSampler..::..InvokeMethod invoker
)
Public MustOverride Sub GetImportSample (
    dataSet As DataSet,
    sampleSize As Integer,
    invoker As LinkBasedImportSampler..::..InvokeMethod
)
Parameters
dataSet (DataSet)
The DataSet where a DataTable containing the data will be added.
sampleSize (Int32)
The number of records to retrieve.
invoker (LinkBasedImportSampler..::..InvokeMethod)
A UI control with an Invoke method, which can be used to invoke a method on the UI thread. Can only be null when operating outside of Windows Forms.


Import Method

Import Method
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSource ► Import()()()()
Keyoti SearchUnit v6
Adds new files imported from the source
Declaration Syntax
C# Visual Basic
public abstract ArrayList Import()
Public MustOverride Function Import As ArrayList
Return Value
ArrayList
Collection of strings of imported Urls

Send comments on this topic to support@keyoti.com


ImportSampleDataTableColumnsFinalized Event

ImportSampleDataTableColumnsFinalized Event
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSource ► ImportSampleDataTableColumnsFinalized
Keyoti SearchUnit v6
Fired when the DataTable used for the import sample has it's columns finalized.
Declaration Syntax
C# Visual Basic
public event EventHandler ImportSampleDataTableColumnsFinalized
Public Event ImportSampleDataTableColumnsFinalized As EventHandler
Value
EventHandler

Send comments on this topic to support@keyoti.com


IndexableSourceRecord Property

IndexableSourceRecord Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSource ► IndexableSourceRecord
Keyoti SearchUnit v6
The record representing this source, in the data-access
Declaration Syntax
C# Visual Basic
public virtual IndexableSourceRecord IndexableSourceRecord { get; }
Public Overridable ReadOnly Property IndexableSourceRecord As IndexableSourceRecord
    Get
Property Value
IndexableSourceRecord

Send comments on this topic to support@keyoti.com


ItemsImported Property

ItemsImported Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSource ► ItemsImported
Keyoti SearchUnit v6
The number of items that have been imported since the last call to Import.
Declaration Syntax
C# Visual Basic
public abstract int ItemsImported { get; }
Public MustOverride ReadOnly Property ItemsImported As Integer
    Get
Property Value
Int32
Remarks
Access this property from a different thread to track import progress.


ItemsToImportTotal Property

ItemsToImportTotal Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSource ► ItemsToImportTotal
Keyoti SearchUnit v6
If available. The total number of items (documents, records, files, etc) that will be imported.
Declaration Syntax
C# Visual Basic
public virtual int ItemsToImportTotal { get; }
Public Overridable ReadOnly Property ItemsToImportTotal As Integer
    Get
Property Value
Int32
Remarks
Access this property from a different thread to track import progress.


OnAddedDocument Method (e)

OnAddedDocument Method (e)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSource ► OnAddedDocument(AddDocumentEventArgs)
Keyoti SearchUnit v6
Fires the AddedDocument event.
Declaration Syntax
C# Visual Basic
protected virtual void OnAddedDocument(
    AddDocumentEventArgs e
)
Protected Overridable Sub OnAddedDocument (
    e As AddDocumentEventArgs
)
Parameters
e (AddDocumentEventArgs)


OnAddingDocument Method (e)

OnAddingDocument Method (e)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSource ► OnAddingDocument(AddDocumentEventArgs)
Keyoti SearchUnit v6
Fires the AddingDocument event.
Declaration Syntax
C# Visual Basic
protected virtual void OnAddingDocument(
    AddDocumentEventArgs e
)
Protected Overridable Sub OnAddingDocument (
    e As AddDocumentEventArgs
)
Parameters
e (AddDocumentEventArgs)


OnImportSampleDataTableColumnsFinalized Method (e)

OnImportSampleDataTableColumnsFinalized Method (e)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSource ► OnImportSampleDataTableColumnsFinalized(EventArgs)
Keyoti SearchUnit v6
Raises ImportSampleDataTableColumnsFinalized
Declaration Syntax
C# Visual Basic
protected void OnImportSampleDataTableColumnsFinalized(
    EventArgs e
)
Protected Sub OnImportSampleDataTableColumnsFinalized (
    e As EventArgs
)
Parameters
e (EventArgs)


OnReaderExceptionOccurred Method (evArgs)

OnReaderExceptionOccurred Method (evArgs)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSource ► OnReaderExceptionOccurred(ReaderExceptionOccurredEventArgs)
Keyoti SearchUnit v6
Called whenever a readerException is caught
Declaration Syntax
C# Visual Basic
protected virtual void OnReaderExceptionOccurred(
    ReaderExceptionOccurredEventArgs evArgs
)
Protected Overridable Sub OnReaderExceptionOccurred (
    evArgs As ReaderExceptionOccurredEventArgs
)
Parameters
evArgs (ReaderExceptionOccurredEventArgs)


Open Method

Open Method
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSource ► Open()()()()
Keyoti SearchUnit v6
Opens the data access
Declaration Syntax
C# Visual Basic
public virtual void Open()
Public Overridable Sub Open

Send comments on this topic to support@keyoti.com


ReaderExceptionOccurred Event

ReaderExceptionOccurred Event
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSource ► ReaderExceptionOccurred
Keyoti SearchUnit v6
Fired whenever the (web) reader encounters a network exception, eg. 404 (this can be useful for identifying dead links)
Declaration Syntax
C# Visual Basic
public event ReaderExceptionOccurredEventHandler ReaderExceptionOccurred
Public Event ReaderExceptionOccurred As ReaderExceptionOccurredEventHandler
Value
ReaderExceptionOccurredEventHandler

Send comments on this topic to support@keyoti.com


SetIndexableSourceRecord Method (value)

SetIndexableSourceRecord Method (value)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSource ► SetIndexableSourceRecord(IndexableSourceRecord)
Keyoti SearchUnit v6
Sets record representing this source, in the data-access
Declaration Syntax
C# Visual Basic
protected void SetIndexableSourceRecord(
    IndexableSourceRecord value
)
Protected Sub SetIndexableSourceRecord (
    value As IndexableSourceRecord
)
Parameters
value (IndexableSourceRecord)


IndexableSourceFactory Class

IndexableSourceFactory Class
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSourceFactory
Keyoti SearchUnit v6
Creates instances of IndexableSource sub-classes.
Declaration Syntax
C# Visual Basic
public class IndexableSourceFactory
Public Class IndexableSourceFactory
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | IndexableSourceFactory()()()() |
 | CreateIndexableSource(Configuration, IndexableSourceRecord) | Creates instances of IndexableSource sub-classes.
 | CreateIndexableSource(Configuration, IndexableSourceRecord, IDataSetAdapter) | Creates an instance of DataSetBasedSource with the IDataSetAdapter.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
IndexableSourceFactory

Send comments on this topic to support@keyoti.com


IndexableSourceFactory Constructor

IndexableSourceFactory Constructor
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSourceFactory ► IndexableSourceFactory()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public IndexableSourceFactory()
Public Sub New

Send comments on this topic to support@keyoti.com


CreateIndexableSource Method

CreateIndexableSource Method
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSourceFactory ► CreateIndexableSource()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | CreateIndexableSource(Configuration, IndexableSourceRecord) | Creates instances of IndexableSource sub-classes.
 | CreateIndexableSource(Configuration, IndexableSourceRecord, IDataSetAdapter) | Creates an instance of DataSetBasedSource with the IDataSetAdapter.


CreateIndexableSource Method (configuration, indexableSourceRecord)

CreateIndexableSource Method (configuration, indexableSourceRecord)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSourceFactory ► CreateIndexableSource(Configuration, IndexableSourceRecord)
Keyoti SearchUnit v6
Creates instances of IndexableSource sub-classes.
Declaration Syntax
C# Visual Basic
public virtual IIndexableSource CreateIndexableSource(
    Configuration configuration,
    IndexableSourceRecord indexableSourceRecord
)
Public Overridable Function CreateIndexableSource (
    configuration As Configuration,
    indexableSourceRecord As IndexableSourceRecord
) As IIndexableSource
Parameters
configuration (Configuration)
indexableSourceRecord (IndexableSourceRecord)
Return Value
IIndexableSource

Send comments on this topic to support@keyoti.com


CreateIndexableSource Method (configuration, indexableSourceRecord, dataSetAdapter)

CreateIndexableSource Method (configuration, indexableSourceRecord, dataSetAdapter)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSourceFactory ► CreateIndexableSource(Configuration, IndexableSourceRecord, IDataSetAdapter)
Keyoti SearchUnit v6
Creates an instance of DataSetBasedSource with the IDataSetAdapter.
Declaration Syntax
C# Visual Basic
public virtual IIndexableSource CreateIndexableSource(
    Configuration configuration,
    IndexableSourceRecord indexableSourceRecord,
    IDataSetAdapter dataSetAdapter
)
Public Overridable Function CreateIndexableSource (
    configuration As Configuration,
    indexableSourceRecord As IndexableSourceRecord,
    dataSetAdapter As IDataSetAdapter
) As IIndexableSource
Parameters
configuration (Configuration)
indexableSourceRecord (IndexableSourceRecord)
dataSetAdapter (IDataSetAdapter)
Return Value
IIndexableSource

Send comments on this topic to support@keyoti.com


IndexableSourceFieldHelpAttribute Class

IndexableSourceFieldHelpAttribute Class
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSourceFieldHelpAttribute
Keyoti SearchUnit v6
Source field help text.
Declaration Syntax
C# Visual Basic
public class IndexableSourceFieldHelpAttribute : Attribute
Public Class IndexableSourceFieldHelpAttribute
    Inherits Attribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IndexableSourceFieldHelpAttribute(String, String, String, String) | Creates an instance
 | Equals(Object) | (Inherited from Attribute.)
 | Finalize()()()() | (Inherited from Object.)
 | GetAttribute(SourceType) | Retrieves the attribute of this type from the enum member.
 | GetHashCode()()()() | (Inherited from Attribute.)
 | GetType()()()() | (Inherited from Object.)
 | IsDefaultAttribute()()()() | (Inherited from Attribute.)
 | LocationHelp | Help text.
 | Match(Object) | (Inherited from Attribute.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | QueryHelp | Help text.
 | ResultURLHelp | Help text.
 | ToString()()()() | (Inherited from Object.)
 | TypeId | (Inherited from Attribute.)
 | UniqueHelp | Help text.
Inheritance Hierarchy
Object
 | Attribute
 |  | IndexableSourceFieldHelpAttribute


IndexableSourceFieldHelpAttribute Constructor (locationHelp, queryHelp, uniqueHelp, resultURLHelp)

IndexableSourceFieldHelpAttribute Constructor (locationHelp, queryHelp, uniqueHelp, resultURLHelp)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSourceFieldHelpAttribute ► IndexableSourceFieldHelpAttribute(String, String, String, String)
Keyoti SearchUnit v6
Creates an instance
Declaration Syntax
C# Visual Basic
public IndexableSourceFieldHelpAttribute(
    string locationHelp,
    string queryHelp,
    string uniqueHelp,
    string resultURLHelp
)
Public Sub New (
    locationHelp As String,
    queryHelp As String,
    uniqueHelp As String,
    resultURLHelp As String
)
Parameters
locationHelp (String)
queryHelp (String)
uniqueHelp (String)
resultURLHelp (String)


GetAttribute Method (type)

GetAttribute Method (type)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSourceFieldHelpAttribute ► GetAttribute(SourceType)
Keyoti SearchUnit v6
Retrieves the attribute of this type from the enum member.
Declaration Syntax
C# Visual Basic
public static IndexableSourceFieldHelpAttribute GetAttribute(
    SourceType type
)
Public Shared Function GetAttribute (
    type As SourceType
) As IndexableSourceFieldHelpAttribute
Parameters
type (SourceType)
Return Value
IndexableSourceFieldHelpAttribute

Send comments on this topic to support@keyoti.com


LocationHelp Property

LocationHelp Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSourceFieldHelpAttribute ► LocationHelp
Keyoti SearchUnit v6
Help text.
Declaration Syntax
C# Visual Basic
public string LocationHelp { get; }
Public ReadOnly Property LocationHelp As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


QueryHelp Property

QueryHelp Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSourceFieldHelpAttribute ► QueryHelp
Keyoti SearchUnit v6
Help text.
Declaration Syntax
C# Visual Basic
public string QueryHelp { get; }
Public ReadOnly Property QueryHelp As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


ResultURLHelp Property

ResultURLHelp Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSourceFieldHelpAttribute ► ResultURLHelp
Keyoti SearchUnit v6
Help text.
Declaration Syntax
C# Visual Basic
public string ResultURLHelp { get; }
Public ReadOnly Property ResultURLHelp As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


UniqueHelp Property

UniqueHelp Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSourceFieldHelpAttribute ► UniqueHelp
Keyoti SearchUnit v6
Help text.
Declaration Syntax
C# Visual Basic
public string UniqueHelp { get; }
Public ReadOnly Property UniqueHelp As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


IndexableSourceFieldsAttribute Class

IndexableSourceFieldsAttribute Class
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSourceFieldsAttribute
Keyoti SearchUnit v6
Source field descriptions.
Declaration Syntax
C# Visual Basic
public class IndexableSourceFieldsAttribute : Attribute
Public Class IndexableSourceFieldsAttribute
    Inherits Attribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IndexableSourceFieldsAttribute(String, String, String, String) | Creates an instance
 | IndexableSourceFieldsAttribute(String, String, String, String, Boolean, String) | Creates an instance
 | Equals(Object) | (Inherited from Attribute.)
 | Finalize()()()() | (Inherited from Object.)
 | GetAttribute(SourceType) | Retrieves the attribute of this type from the enum member.
 | GetHashCode()()()() | (Inherited from Attribute.)
 | GetType()()()() | (Inherited from Object.)
 | IsDefaultAttribute()()()() | (Inherited from Attribute.)
 | LocationDefaultValue | Default value for the location field
 | LocationText | Field text.
 | Match(Object) | (Inherited from Attribute.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MoreOptions | Whether there are more options.
 | QueryText | Field text.
 | ResultURLText | Field text.
 | ToString()()()() | (Inherited from Object.)
 | TypeId | (Inherited from Attribute.)
 | UniqueText | Field text.
Inheritance Hierarchy
Object
 | Attribute
 |  | IndexableSourceFieldsAttribute


IndexableSourceFieldsAttribute Constructor

IndexableSourceFieldsAttribute Constructor
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSourceFieldsAttribute ► IndexableSourceFieldsAttribute()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | IndexableSourceFieldsAttribute(String, String, String, String) | Creates an instance
 | IndexableSourceFieldsAttribute(String, String, String, String, Boolean, String) | Creates an instance


IndexableSourceFieldsAttribute Constructor (locationText, queryText, uniqueText, resultURLText)

IndexableSourceFieldsAttribute Constructor (locationText, queryText, uniqueText, resultURLText)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSourceFieldsAttribute ► IndexableSourceFieldsAttribute(String, String, String, String)
Keyoti SearchUnit v6
Creates an instance
Declaration Syntax
C# Visual Basic
public IndexableSourceFieldsAttribute(
    string locationText,
    string queryText,
    string uniqueText,
    string resultURLText
)
Public Sub New (
    locationText As String,
    queryText As String,
    uniqueText As String,
    resultURLText As String
)
Parameters
locationText (String)
queryText (String)
uniqueText (String)
resultURLText (String)


IndexableSourceFieldsAttribute Constructor (locationText, queryText, uniqueText, resultURLText, moreOptions, locationDefaultValue)

IndexableSourceFieldsAttribute Constructor (locationText, queryText, uniqueText, resultURLText, moreOptions, locationDefaultValue)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSourceFieldsAttribute ► IndexableSourceFieldsAttribute(String, String, String, String, Boolean, String)
Keyoti SearchUnit v6
Creates an instance
Declaration Syntax
C# Visual Basic
public IndexableSourceFieldsAttribute(
    string locationText,
    string queryText,
    string uniqueText,
    string resultURLText,
    bool moreOptions,
    string locationDefaultValue
)
Public Sub New (
    locationText As String,
    queryText As String,
    uniqueText As String,
    resultURLText As String,
    moreOptions As Boolean,
    locationDefaultValue As String
)
Parameters
locationText (String)
queryText (String)
uniqueText (String)
resultURLText (String)
moreOptions (Boolean)
locationDefaultValue (String)


GetAttribute Method (type)

GetAttribute Method (type)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSourceFieldsAttribute ► GetAttribute(SourceType)
Keyoti SearchUnit v6
Retrieves the attribute of this type from the enum member.
Declaration Syntax
C# Visual Basic
public static IndexableSourceFieldsAttribute GetAttribute(
    SourceType type
)
Public Shared Function GetAttribute (
    type As SourceType
) As IndexableSourceFieldsAttribute
Parameters
type (SourceType)
Return Value
IndexableSourceFieldsAttribute

Send comments on this topic to support@keyoti.com


LocationDefaultValue Property

LocationDefaultValue Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSourceFieldsAttribute ► LocationDefaultValue
Keyoti SearchUnit v6
Default value for the location field
Declaration Syntax
C# Visual Basic
public string LocationDefaultValue { get; }
Public ReadOnly Property LocationDefaultValue As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


LocationText Property

LocationText Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSourceFieldsAttribute ► LocationText
Keyoti SearchUnit v6
Field text.
Declaration Syntax
C# Visual Basic
public string LocationText { get; }
Public ReadOnly Property LocationText As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


MoreOptions Property

MoreOptions Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSourceFieldsAttribute ► MoreOptions
Keyoti SearchUnit v6
Whether there are more options.
Declaration Syntax
C# Visual Basic
public bool MoreOptions { get; }
Public ReadOnly Property MoreOptions As Boolean
    Get
Property Value
Boolean

Send comments on this topic to support@keyoti.com


QueryText Property

QueryText Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSourceFieldsAttribute ► QueryText
Keyoti SearchUnit v6
Field text.
Declaration Syntax
C# Visual Basic
public string QueryText { get; }
Public ReadOnly Property QueryText As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


ResultURLText Property

ResultURLText Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSourceFieldsAttribute ► ResultURLText
Keyoti SearchUnit v6
Field text.
Declaration Syntax
C# Visual Basic
public string ResultURLText { get; }
Public ReadOnly Property ResultURLText As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


UniqueText Property

UniqueText Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSourceFieldsAttribute ► UniqueText
Keyoti SearchUnit v6
Field text.
Declaration Syntax
C# Visual Basic
public string UniqueText { get; }
Public ReadOnly Property UniqueText As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


IndexableSourceRecordPersistenceAttribute Class

IndexableSourceRecordPersistenceAttribute Class
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSourceRecordPersistenceAttribute
Keyoti SearchUnit v6
Information about whether a SourceType type of indexable source record is persisted
Declaration Syntax
C# Visual Basic
public class IndexableSourceRecordPersistenceAttribute : Attribute
Public Class IndexableSourceRecordPersistenceAttribute
    Inherits Attribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IndexableSourceRecordPersistenceAttribute(Boolean) | Creates an instance
 | Equals(Object) | (Inherited from Attribute.)
 | Finalize()()()() | (Inherited from Object.)
 | GetAttribute(SourceType) | Retrieves the attribute of this type from the enum member.
 | GetHashCode()()()() | (Inherited from Attribute.)
 | GetType()()()() | (Inherited from Object.)
 | IsDefaultAttribute()()()() | (Inherited from Attribute.)
 | IsPersisted | Whether the type is persisted.
 | Match(Object) | (Inherited from Attribute.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | TypeId | (Inherited from Attribute.)
Inheritance Hierarchy
Object
 | Attribute
 |  | IndexableSourceRecordPersistenceAttribute


IndexableSourceRecordPersistenceAttribute Constructor (isPersisted)

IndexableSourceRecordPersistenceAttribute Constructor (isPersisted)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSourceRecordPersistenceAttribute ► IndexableSourceRecordPersistenceAttribute(Boolean)
Keyoti SearchUnit v6
Creates an instance
Declaration Syntax
C# Visual Basic
public IndexableSourceRecordPersistenceAttribute(
    bool isPersisted
)
Public Sub New (
    isPersisted As Boolean
)
Parameters
isPersisted (Boolean)
Whether the field this is related to is persisted.


GetAttribute Method (type)

GetAttribute Method (type)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSourceRecordPersistenceAttribute ► GetAttribute(SourceType)
Keyoti SearchUnit v6
Retrieves the attribute of this type from the enum member.
Declaration Syntax
C# Visual Basic
public static IndexableSourceRecordPersistenceAttribute GetAttribute(
    SourceType type
)
Public Shared Function GetAttribute (
    type As SourceType
) As IndexableSourceRecordPersistenceAttribute
Parameters
type (SourceType)
Return Value
IndexableSourceRecordPersistenceAttribute


IsPersisted Property

IsPersisted Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSourceRecordPersistenceAttribute ► IsPersisted
Keyoti SearchUnit v6
Whether the type is persisted.
Declaration Syntax
C# Visual Basic
public bool IsPersisted { get; }
Public ReadOnly Property IsPersisted As Boolean
    Get
Property Value
Boolean

Send comments on this topic to support@keyoti.com


IndexableSourceUri Class

IndexableSourceUri Class
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSourceUri
Keyoti SearchUnit v6
A Uri from an indexable source
Declaration Syntax
C# Visual Basic
public class IndexableSourceUri
Public Class IndexableSourceUri
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IndexableSourceUri(Int32, String, String) | New instance
 | IndexableSourceUri(Uri) | New instance
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSourceID(Uri) | Gets the Id of the indexable source record
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PkValue | The value of the row in the UniqueColumn field in the source data
 | SourceID | The Id of the indexable source record
 | ToString()()()() | (Inherited from Object.)
 | UniqueColumn | The unique column that produced the record
 | UriInstance | The wrapped Uri
 | UriIsIndexableSource(Uri) | Whether the Uri is from an indexable source
 | UriIsIndexableSource(String) | Whether the Uri is from an indexable source
Inheritance Hierarchy
Object
IndexableSourceUri

Send comments on this topic to support@keyoti.com


IndexableSourceUri Constructor

IndexableSourceUri Constructor
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSourceUri ► IndexableSourceUri()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | IndexableSourceUri(Int32, String, String) | New instance
 | IndexableSourceUri(Uri) | New instance


IndexableSourceUri Constructor (id, primaryKey, primaryKeyFieldName)

IndexableSourceUri Constructor (id, primaryKey, primaryKeyFieldName)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSourceUri ► IndexableSourceUri(Int32, String, String)
Keyoti SearchUnit v6
New instance
Declaration Syntax
C# Visual Basic
public IndexableSourceUri(
    int id,
    string primaryKey,
    string primaryKeyFieldName
)
Public Sub New (
    id As Integer,
    primaryKey As String,
    primaryKeyFieldName As String
)
Parameters
id (Int32)
primaryKey (String)
primaryKeyFieldName (String)


IndexableSourceUri Constructor (uri)

IndexableSourceUri Constructor (uri)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSourceUri ► IndexableSourceUri(Uri)
Keyoti SearchUnit v6
New instance
Declaration Syntax
C# Visual Basic
public IndexableSourceUri(
    Uri uri
)
Public Sub New (
    uri As Uri
)
Parameters
uri (Uri)


GetSourceID Method (u)

GetSourceID Method (u)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSourceUri ► GetSourceID(Uri)
Keyoti SearchUnit v6
Gets the Id of the indexable source record
Declaration Syntax
C# Visual Basic
public static int GetSourceID(
    Uri u
)
Public Shared Function GetSourceID (
    u As Uri
) As Integer
Parameters
u (Uri)
Return Value
Int32

Send comments on this topic to support@keyoti.com


PkValue Property

PkValue Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSourceUri ► PkValue
Keyoti SearchUnit v6
The value of the row in the UniqueColumn field in the source data
Declaration Syntax
C# Visual Basic
public string PkValue { get; }
Public ReadOnly Property PkValue As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


SourceID Property

SourceID Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSourceUri ► SourceID
Keyoti SearchUnit v6
The Id of the indexable source record
Declaration Syntax
C# Visual Basic
public int SourceID { get; }
Public ReadOnly Property SourceID As Integer
    Get
Property Value
Int32

Send comments on this topic to support@keyoti.com


UniqueColumn Property

UniqueColumn Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSourceUri ► UniqueColumn
Keyoti SearchUnit v6
The unique column that produced the record
Declaration Syntax
C# Visual Basic
public string UniqueColumn { get; }
Public ReadOnly Property UniqueColumn As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


UriInstance Property

UriInstance Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSourceUri ► UriInstance
Keyoti SearchUnit v6
The wrapped Uri
Declaration Syntax
C# Visual Basic
public Uri UriInstance { get; }
Public ReadOnly Property UriInstance As Uri
    Get
Property Value
Uri

Send comments on this topic to support@keyoti.com


UriIsIndexableSource Method

UriIsIndexableSource Method
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSourceUri ► UriIsIndexableSource()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | UriIsIndexableSource(Uri) | Whether the Uri is from an indexable source
 | UriIsIndexableSource(String) | Whether the Uri is from an indexable source


UriIsIndexableSource Method (u)

UriIsIndexableSource Method (u)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSourceUri ► UriIsIndexableSource(String)
Keyoti SearchUnit v6
Whether the Uri is from an indexable source
Declaration Syntax
C# Visual Basic
public static bool UriIsIndexableSource(
    string u
)
Public Shared Function UriIsIndexableSource (
    u As String
) As Boolean
Parameters
u (String)
Return Value
Boolean

Send comments on this topic to support@keyoti.com


UriIsIndexableSource Method (u)

UriIsIndexableSource Method (u)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► IndexableSourceUri ► UriIsIndexableSource(Uri)
Keyoti SearchUnit v6
Whether the Uri is from an indexable source
Declaration Syntax
C# Visual Basic
public static bool UriIsIndexableSource(
    Uri u
)
Public Shared Function UriIsIndexableSource (
    u As Uri
) As Boolean
Parameters
u (Uri)
Return Value
Boolean

Send comments on this topic to support@keyoti.com


LinkBasedImportSampler Class

LinkBasedImportSampler Class
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► LinkBasedImportSampler
Keyoti SearchUnit v6
Gets a sample import from a link providing source.
Declaration Syntax
C# Visual Basic
public class LinkBasedImportSampler
Public Class LinkBasedImportSampler
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | LinkBasedImportSampler(IIndexableSource, LinkBasedImportSampler..::..InvokeMethod, DataSet) | New instance
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetImportSample(Int32, LinkBasedImportSampler..::..SampleMethod) | Starts getting the sample
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
LinkBasedImportSampler

Send comments on this topic to support@keyoti.com


LinkBasedImportSampler Constructor (source, invoker, dataSet)

LinkBasedImportSampler Constructor (source, invoker, dataSet)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► LinkBasedImportSampler ► LinkBasedImportSampler(IIndexableSource, LinkBasedImportSampler..::..InvokeMethod, DataSet)
Keyoti SearchUnit v6
New instance
Declaration Syntax
C# Visual Basic
public LinkBasedImportSampler(
    IIndexableSource source,
    LinkBasedImportSampler..::..InvokeMethod invoker,
    DataSet dataSet
)
Public Sub New (
    source As IIndexableSource,
    invoker As LinkBasedImportSampler..::..InvokeMethod,
    dataSet As DataSet
)
Parameters
source (IIndexableSource)
Source to sample
invoker (LinkBasedImportSampler..::..InvokeMethod)
UI thread invoker to use if Windows Forms, null otherwise
dataSet (DataSet)
DataSet to add sample data to

Send comments on this topic to support@keyoti.com


GetImportSample Method (sampleSize, method)

GetImportSample Method (sampleSize, method)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► LinkBasedImportSampler ► GetImportSample(Int32, LinkBasedImportSampler..::..SampleMethod)
Keyoti SearchUnit v6
Starts getting the sample
Declaration Syntax
C# Visual Basic
public void GetImportSample(
    int sampleSize,
    LinkBasedImportSampler..::..SampleMethod method
)
Public Sub GetImportSample (
    sampleSize As Integer,
    method As LinkBasedImportSampler..::..SampleMethod
)
Parameters
sampleSize (Int32)
Size of the sample
method (LinkBasedImportSampler..::..SampleMethod)
Method to call to get a sample

Send comments on this topic to support@keyoti.com


LinkBasedImportSampler.AddRowDelegate Delegate

LinkBasedImportSampler..::..AddRowDelegate Delegate
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► LinkBasedImportSampler ► LinkBasedImportSampler..::..AddRowDelegate
Keyoti SearchUnit v6
The "AddRow" method to call, on the grid.
Declaration Syntax
C# Visual Basic
public delegate void AddRowDelegate(
    Object[] items
)
Public Delegate Sub AddRowDelegate (
    items As Object()
)
Parameters
items (array< Object >[]()[][])


LinkBasedImportSampler.BeginInvokeMethod Delegate

LinkBasedImportSampler..::..BeginInvokeMethod Delegate
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► LinkBasedImportSampler ► LinkBasedImportSampler..::..BeginInvokeMethod
Keyoti SearchUnit v6
A "BeginInvoke" method, used to invoke on the UI thread.
Declaration Syntax
C# Visual Basic
public delegate IAsyncResult BeginInvokeMethod(
    Delegate method,
    Object[] args
)
Public Delegate Function BeginInvokeMethod (
    method As Delegate,
    args As Object()
) As IAsyncResult
Parameters
method (Delegate)
args (array< Object >[]()[][])
Return Value
IAsyncResult

Send comments on this topic to support@keyoti.com


LinkBasedImportSampler.ImportRowDelegate Delegate

LinkBasedImportSampler..::..ImportRowDelegate Delegate
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► LinkBasedImportSampler ► LinkBasedImportSampler..::..ImportRowDelegate
Keyoti SearchUnit v6
The "ImportRow" method to call, on the grid.
Declaration Syntax
C# Visual Basic
public delegate void ImportRowDelegate(
    DataRow row
)
Public Delegate Sub ImportRowDelegate (
    row As DataRow
)
Parameters
row (DataRow)


LinkBasedImportSampler.InvokeMethod Delegate

LinkBasedImportSampler..::..InvokeMethod Delegate
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► LinkBasedImportSampler ► LinkBasedImportSampler..::..InvokeMethod
Keyoti SearchUnit v6
An "Invoke" method, used to invoke on the UI thread.
Declaration Syntax
C# Visual Basic
public delegate Object InvokeMethod(
    Delegate method,
    Object[] args
)
Public Delegate Function InvokeMethod (
    method As Delegate,
    args As Object()
) As Object
Parameters
method (Delegate)
args (array< Object >[]()[][])
Return Value
Object

Send comments on this topic to support@keyoti.com


LinkBasedImportSampler.SampleMethod Delegate

LinkBasedImportSampler..::..SampleMethod Delegate
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► LinkBasedImportSampler ► LinkBasedImportSampler..::..SampleMethod
Keyoti SearchUnit v6
The method the produces the sample
Declaration Syntax
C# Visual Basic
public delegate void SampleMethod(
    ArrayList links
)
Public Delegate Sub SampleMethod (
    links As ArrayList
)
Parameters
links (ArrayList)


MSSQLAdapter Class

MSSQLAdapter Class
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► MSSQLAdapter
Keyoti SearchUnit v6
Adapter for MSSQL indexable sources
Declaration Syntax
C# Visual Basic
public class MSSQLAdapter : IDataSetAdapter
Public Class MSSQLAdapter
    Implements IDataSetAdapter
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MSSQLAdapter(String, String, Configuration) | New instance
 | Configuration | The index configuration
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetDataSet(Int32, Int32) | Gets the next data set
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Location | Connection string
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Query | SQL statement to retrieve data
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
MSSQLAdapter

Send comments on this topic to support@keyoti.com


MSSQLAdapter Constructor (locationString, queryString, configuration)

MSSQLAdapter Constructor (locationString, queryString, configuration)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► MSSQLAdapter ► MSSQLAdapter(String, String, Configuration)
Keyoti SearchUnit v6
New instance
Declaration Syntax
C# Visual Basic
public MSSQLAdapter(
    string locationString,
    string queryString,
    Configuration configuration
)
Public Sub New (
    locationString As String,
    queryString As String,
    configuration As Configuration
)
Parameters
locationString (String)
Connection string
queryString (String)
SQL statement
configuration (Configuration)
Configuration

Send comments on this topic to support@keyoti.com


Configuration Property

Configuration Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► MSSQLAdapter ► Configuration
Keyoti SearchUnit v6
The index configuration
Declaration Syntax
C# Visual Basic
public Configuration Configuration { get; }
Public ReadOnly Property Configuration As Configuration
    Get
Property Value
Configuration

Send comments on this topic to support@keyoti.com


GetDataSet Method (firstRow, numberOfRows)

GetDataSet Method (firstRow, numberOfRows)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► MSSQLAdapter ► GetDataSet(Int32, Int32)
Keyoti SearchUnit v6
Gets the next data set
Declaration Syntax
C# Visual Basic
public virtual DataSet GetDataSet(
    int firstRow,
    int numberOfRows
)
Public Overridable Function GetDataSet (
    firstRow As Integer,
    numberOfRows As Integer
) As DataSet
Parameters
firstRow (Int32)
numberOfRows (Int32)
Return Value
DataSet

Send comments on this topic to support@keyoti.com


Location Property

Location Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► MSSQLAdapter ► Location
Keyoti SearchUnit v6
Connection string
Declaration Syntax
C# Visual Basic
public string Location { get; }
Public ReadOnly Property Location As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


Query Property

Query Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► MSSQLAdapter ► Query
Keyoti SearchUnit v6
SQL statement to retrieve data
Declaration Syntax
C# Visual Basic
public string Query { get; }
Public ReadOnly Property Query As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


OLEAdapter Class

OLEAdapter Class
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► OLEAdapter
Keyoti SearchUnit v6
Adapter for OLE database indexable sources
Declaration Syntax
C# Visual Basic
public class OLEAdapter : IDataSetAdapter
Public Class OLEAdapter
    Implements IDataSetAdapter
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OLEAdapter(String, String, Configuration) | New instance
 | Configuration | The index configuration
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetDataSet(Int32, Int32) | Gets the next data set
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Location | Connection string
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Query | SQL query
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
OLEAdapter

Send comments on this topic to support@keyoti.com


OLEAdapter Constructor (location, queryString, configuration)

OLEAdapter Constructor (location, queryString, configuration)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► OLEAdapter ► OLEAdapter(String, String, Configuration)
Keyoti SearchUnit v6
New instance
Declaration Syntax
C# Visual Basic
public OLEAdapter(
    string location,
    string queryString,
    Configuration configuration
)
Public Sub New (
    location As String,
    queryString As String,
    configuration As Configuration
)
Parameters
location (String)
The OLEDB connection string
queryString (String)
The SQL query
configuration (Configuration)
The configuration of the index

Send comments on this topic to support@keyoti.com


Configuration Property

Configuration Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► OLEAdapter ► Configuration
Keyoti SearchUnit v6
The index configuration
Declaration Syntax
C# Visual Basic
public Configuration Configuration { get; }
Public ReadOnly Property Configuration As Configuration
    Get
Property Value
Configuration

Send comments on this topic to support@keyoti.com


GetDataSet Method (firstRow, numberOfRows)

GetDataSet Method (firstRow, numberOfRows)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► OLEAdapter ► GetDataSet(Int32, Int32)
Keyoti SearchUnit v6
Gets the next data set
Declaration Syntax
C# Visual Basic
public virtual DataSet GetDataSet(
    int firstRow,
    int numberOfRows
)
Public Overridable Function GetDataSet (
    firstRow As Integer,
    numberOfRows As Integer
) As DataSet
Parameters
firstRow (Int32)
numberOfRows (Int32)
Return Value
DataSet

Send comments on this topic to support@keyoti.com


Location Property

Location Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► OLEAdapter ► Location
Keyoti SearchUnit v6
Connection string
Declaration Syntax
C# Visual Basic
public string Location { get; }
Public ReadOnly Property Location As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


Query Property

Query Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► OLEAdapter ► Query
Keyoti SearchUnit v6
SQL query
Declaration Syntax
C# Visual Basic
public string Query { get; }
Public ReadOnly Property Query As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


OracleAdapter Class

OracleAdapter Class
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► OracleAdapter
Keyoti SearchUnit v6
Oracle database adapter
Declaration Syntax
C# Visual Basic
public class OracleAdapter : IDataSetAdapter
Public Class OracleAdapter
    Implements IDataSetAdapter
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OracleAdapter(String, String, Configuration) | New instance
 | Configuration | Index configuration
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetDataSet(Int32, Int32) | Gets the next set of data
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Location | Connection string
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Query | SQL to retrieve data
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
OracleAdapter

Send comments on this topic to support@keyoti.com


OracleAdapter Constructor (locationString, queryString, configuration)

OracleAdapter Constructor (locationString, queryString, configuration)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► OracleAdapter ► OracleAdapter(String, String, Configuration)
Keyoti SearchUnit v6
New instance
Declaration Syntax
C# Visual Basic
public OracleAdapter(
    string locationString,
    string queryString,
    Configuration configuration
)
Public Sub New (
    locationString As String,
    queryString As String,
    configuration As Configuration
)
Parameters
locationString (String)
queryString (String)
configuration (Configuration)


Configuration Property

Configuration Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► OracleAdapter ► Configuration
Keyoti SearchUnit v6
Index configuration
Declaration Syntax
C# Visual Basic
public Configuration Configuration { get; }
Public ReadOnly Property Configuration As Configuration
    Get
Property Value
Configuration

Send comments on this topic to support@keyoti.com


GetDataSet Method (firstRow, numberOfRows)

GetDataSet Method (firstRow, numberOfRows)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► OracleAdapter ► GetDataSet(Int32, Int32)
Keyoti SearchUnit v6
Gets the next set of data
Declaration Syntax
C# Visual Basic
public virtual DataSet GetDataSet(
    int firstRow,
    int numberOfRows
)
Public Overridable Function GetDataSet (
    firstRow As Integer,
    numberOfRows As Integer
) As DataSet
Parameters
firstRow (Int32)
numberOfRows (Int32)
Return Value
DataSet

Send comments on this topic to support@keyoti.com


Location Property

Location Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► OracleAdapter ► Location
Keyoti SearchUnit v6
Connection string
Declaration Syntax
C# Visual Basic
public string Location { get; }
Public ReadOnly Property Location As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


Query Property

Query Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► OracleAdapter ► Query
Keyoti SearchUnit v6
SQL to retrieve data
Declaration Syntax
C# Visual Basic
public string Query { get; }
Public ReadOnly Property Query As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


PresetDataSetAdapter Class

PresetDataSetAdapter Class
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► PresetDataSetAdapter
Keyoti SearchUnit v6
An adapter used to provide a predefined DataSet to DocumentImporter and DocumentIndex.
Declaration Syntax
C# Visual Basic
public class PresetDataSetAdapter : IDataSetAdapter
Public Class PresetDataSetAdapter
    Implements IDataSetAdapter
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PresetDataSetAdapter(DataSet) | New instance
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetDataSet(Int32, Int32) | Retreives the next page of data
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Location | Unused
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Query | Unused
 | ToString()()()() | (Inherited from Object.)
Remarks
Note: Only the data in Tables[0] (the first table in the set) is indexed.
Examples
In this example a DataSet is created, indexed and then searched.  The fictional r.aspx could be created to present
                    relevant information to the user, such as the 'body' field.

                    DataSet CreateTestData()
                    {
                        DataSet ds = new DataSet();
                        DataTable tab =new DataTable("testTable");
                        ds.Tables.Add(tab);

                        //The first column in the set is used as the result title
                        tab.Columns.Add("title");
                        tab.Columns.Add("oid");
                        tab.Columns.Add("body");

                        tab.Rows.Add(new object[]{"object1", 1, "this is the body for object1"});
                        tab.Rows.Add(new object[]{"object2", 2, "something about this object - its #2"});
                        tab.Rows.Add(new object[]{"object3", 3, "more stuff and this is number 3, has this more than once"});
                        tab.Rows.Add(new object[]{"object4", 4, "object4 has something else"});

                        return ds;
                    }

                    public void IndexDataSet()
                    {
                        //Specify where to store the index
                        Configuration configuration = new Configuration();
                        configuration.IndexDirectory = "c:/IndexDirectory";

                        //Create an indexable source record, defining:
                        IndexableSourceRecord indexableSourceRecord = new IndexableSourceRecord(
                            SourceType.PresetDataSetProvider,				//this is a preset DataSet
                            null,											//not applicable
                            null,											//not applicable
                            "oid",											//the 'primary key'/'identifying' field name
                            "http://localhost/r.aspx?key={0}&keyField={1}"	//the format to use for the result URLs
                        );

                        //Assign any number not currently assigned to an existing source
                        indexableSourceRecord.ID = 900001;

                        //Create the adapter around any DataSet
                        PresetDataSetAdapter presetDataSetAdapter = new PresetDataSetAdapter(CreateTestData());

                        //Create the IndexableSource around the adapter
                        DataSetBasedSource dataSetBasedSource = new DataSetBasedSource(configuration, indexableSourceRecord, presetDataSetAdapter);

                        //Create the importer
                        DocumentIndex documentIndex = new DocumentIndex(configuration);
                        documentIndex.RegisterDataSetBasedSource(indexableSourceRecord.ID, dataSetBasedSource);

                        //Import from the IndexableSource
                        documentIndex.Import( indexableSourceRecord, dataSetBasedSource );
                        documentIndex.Close();

                        //Run a test search
                        string searchQuery = "this";
                        SearchAgent searchAgent = new SearchAgent(searchQuery, licKey, configuration);

                        //Register the IndexableSource for URL mapping
                        searchAgent.RegisterDataSetBasedSource(indexableSourceRecord.ID, dataSetBasedSource);

                        SearchResult result = searchAgent.Search(1, 10);

                        //Expected results
                        System.Diagnostics.Debug.Assert(3 == result.Count);
                        System.Diagnostics.Debug.Assert("http://localhost/r.aspx?key=3&keyField=oid" == (result[0] as ResultItem).UriString);
                        System.Diagnostics.Debug.Assert("object3" == (result[0] as ResultItem).Title);

                    }
Inheritance Hierarchy
Object
PresetDataSetAdapter

Send comments on this topic to support@keyoti.com


PresetDataSetAdapter Constructor (sourceDataSet)

PresetDataSetAdapter Constructor (sourceDataSet)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► PresetDataSetAdapter ► PresetDataSetAdapter(DataSet)
Keyoti SearchUnit v6
New instance
Declaration Syntax
C# Visual Basic
public PresetDataSetAdapter(
    DataSet sourceDataSet
)
Public Sub New (
    sourceDataSet As DataSet
)
Parameters
sourceDataSet (DataSet)
Source dataset which will be indexed

Send comments on this topic to support@keyoti.com


GetDataSet Method (firstRow, numberOfRows)

GetDataSet Method (firstRow, numberOfRows)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► PresetDataSetAdapter ► GetDataSet(Int32, Int32)
Keyoti SearchUnit v6
Retreives the next page of data
Declaration Syntax
C# Visual Basic
public DataSet GetDataSet(
    int firstRow,
    int numberOfRows
)
Public Function GetDataSet (
    firstRow As Integer,
    numberOfRows As Integer
) As DataSet
Parameters
firstRow (Int32)
First row of data required
numberOfRows (Int32)
Number of rows required
Return Value
DataSet
DataSet of data

Send comments on this topic to support@keyoti.com


Location Property

Location Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► PresetDataSetAdapter ► Location
Keyoti SearchUnit v6
Unused
Declaration Syntax
C# Visual Basic
public string Location { get; set; }
Public Property Location As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


Query Property

Query Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► PresetDataSetAdapter ► Query
Keyoti SearchUnit v6
Unused
Declaration Syntax
C# Visual Basic
public string Query { get; set; }
Public Property Query As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


SourceType Enumeration

SourceType Enumeration
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► SourceType
Keyoti SearchUnit v6
Describes the type of information source that should be indexed.
Declaration Syntax
C# Visual Basic
public enum SourceType
Public Enumeration SourceType
Members
Member | Description
Website | A crawled web-site
MSSQL | MS-SQL server
OLE | OLE based source
Oracle | Oracle server
CustomDataSetProvider | A custom assembly that will provide a DataSet
FileSystemDocumentStore | An imported virtual directory
PresetDataSetProvider | A user created DataSet will be provided via a PresetDataSetAdapter (see API docs)


WebSiteBasedSource Class

WebSiteBasedSource Class
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► WebSiteBasedSource
Keyoti SearchUnit v6
Represents a web-site that will be crawled.
Declaration Syntax
C# Visual Basic
public class WebSiteBasedSource : IndexableSource
Public Class WebSiteBasedSource
    Inherits IndexableSource
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WebSiteBasedSource(Configuration, WebsiteBasedIndexableSourceRecord) | Instantiates a website based indexable source
 | AddedDocument | Fired when a document has been added to the index. (Inherited from IndexableSource.)
 | AddingDocument | Fired when a document is about to be added (Inherited from IndexableSource.)
 | Cancel()()()() | Cancels the crawl (Overrides IndexableSource.Cancel()()()().)
 | Cancelled | Whether the import was cancelled. (Inherited from IndexableSource.)
 | Close()()()() | Closes the data access (Inherited from IndexableSource.)
 | Configuration | The configuration. (Inherited from IndexableSource.)
 | DataAccess | The data-access layer. (Inherited from IndexableSource.)
 | DiscoverLinkedURLs(ArrayList) | Uses WebSiteSpider.DiscoverLinkURLs to find pages linked to the IndexableSourceRecord.Location
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetImportSample(DataSet, Int32, LinkBasedImportSampler..::..InvokeMethod) | Gets a sample of the import data that Import will retrieve. (Overrides IndexableSource.GetImportSample(DataSet, Int32, LinkBasedImportSampler..::..InvokeMethod).)
 | GetType()()()() | (Inherited from Object.)
 | Import()()()() | Imports the records for website based indexable source (Overrides IndexableSource.Import()()()().)
 | ImportSampleDataTableColumnsFinalized | Fired when the DataTable used for the import sample has it's columns finalized. (Inherited from IndexableSource.)
 | IndexableSourceRecord | The record representing this source, in the data-access (Inherited from IndexableSource.)
 | ItemsImported | The number of web-pages that have been imported since the last call to Import. (Overrides IndexableSource.ItemsImported.)
 | ItemsToImportTotal | If available. The total number of items (documents, records, files, etc) that will be imported. (Inherited from IndexableSource.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnAddedDocument(AddDocumentEventArgs) | Fires the AddedDocument event. (Inherited from IndexableSource.)
 | OnAddingDocument(AddDocumentEventArgs) | Fires the AddingDocument event. (Inherited from IndexableSource.)
 | OnImportSampleDataTableColumnsFinalized(EventArgs) | Raises ImportSampleDataTableColumnsFinalized (Inherited from IndexableSource.)
 | OnReaderExceptionOccurred(ReaderExceptionOccurredEventArgs) | Called whenever a readerException is caught (Inherited from IndexableSource.)
 | Open()()()() | Opens the data access (Inherited from IndexableSource.)
 | ReaderExceptionOccurred | Fired whenever the (web) reader encounters a network exception, eg. 404 (this can be useful for identifying dead links) (Inherited from IndexableSource.)
 | SetIndexableSourceRecord(IndexableSourceRecord) | Sets record representing this source, in the data-access (Inherited from IndexableSource.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | IndexableSource
 |  | WebSiteBasedSource


WebSiteBasedSource Constructor (configuration, indexableSourceRecord)

WebSiteBasedSource Constructor (configuration, indexableSourceRecord)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► WebSiteBasedSource ► WebSiteBasedSource(Configuration, WebsiteBasedIndexableSourceRecord)
Keyoti SearchUnit v6
Instantiates a website based indexable source
Declaration Syntax
C# Visual Basic
public WebSiteBasedSource(
    Configuration configuration,
    WebsiteBasedIndexableSourceRecord indexableSourceRecord
)
Public Sub New (
    configuration As Configuration,
    indexableSourceRecord As WebsiteBasedIndexableSourceRecord
)
Parameters
configuration (Configuration)
The configuration
indexableSourceRecord (WebsiteBasedIndexableSourceRecord)
IndexableSourceRecord identifying the web-site


Cancel Method

Cancel Method
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► WebSiteBasedSource ► Cancel()()()()
Keyoti SearchUnit v6
Cancels the crawl
Declaration Syntax
C# Visual Basic
public override void Cancel()
Public Overrides Sub Cancel

Send comments on this topic to support@keyoti.com


DiscoverLinkedURLs Method (newLinks)

DiscoverLinkedURLs Method (newLinks)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► WebSiteBasedSource ► DiscoverLinkedURLs(ArrayList)
Keyoti SearchUnit v6
Uses WebSiteSpider.DiscoverLinkURLs to find pages linked to the IndexableSourceRecord.Location
Declaration Syntax
C# Visual Basic
public void DiscoverLinkedURLs(
    ArrayList newLinks
)
Public Sub DiscoverLinkedURLs (
    newLinks As ArrayList
)
Parameters
newLinks (ArrayList)
List that found link URL strings are added to.


GetImportSample Method (dataSet, sampleSize, invoker)

GetImportSample Method (dataSet, sampleSize, invoker)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► WebSiteBasedSource ► GetImportSample(DataSet, Int32, LinkBasedImportSampler..::..InvokeMethod)
Keyoti SearchUnit v6
Gets a sample of the import data that Import will retrieve.
Declaration Syntax
C# Visual Basic
public override void GetImportSample(
    DataSet dataSet,
    int sampleSize,
    LinkBasedImportSampler..::..InvokeMethod invoker
)
Public Overrides Sub GetImportSample (
    dataSet As DataSet,
    sampleSize As Integer,
    invoker As LinkBasedImportSampler..::..InvokeMethod
)
Parameters
dataSet (DataSet)
The DataSet where a DataTable containing the data will be added.
sampleSize (Int32)
The number of records to retrieve.
invoker (LinkBasedImportSampler..::..InvokeMethod)
A UI control with an Invoke method, which can be used to invoke a method on the UI thread. Can only be null when operating outside of Windows Forms.


Import Method

Import Method
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► WebSiteBasedSource ► Import()()()()
Keyoti SearchUnit v6
Imports the records for website based indexable source
Declaration Syntax
C# Visual Basic
public override ArrayList Import()
Public Overrides Function Import As ArrayList
Return Value
ArrayList
List of Uri objects for imported documents.


ItemsImported Property

ItemsImported Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► WebSiteBasedSource ► ItemsImported
Keyoti SearchUnit v6
The number of web-pages that have been imported since the last call to Import.
Declaration Syntax
C# Visual Basic
public override int ItemsImported { get; }
Public Overrides ReadOnly Property ItemsImported As Integer
    Get
Property Value
Int32
Remarks
Access this property from a different thread to track import progress.


WebSiteSpider Class

WebSiteSpider Class
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► WebSiteSpider
Keyoti SearchUnit v6
Crawls web-sites to find new links.
Declaration Syntax
C# Visual Basic
public class WebSiteSpider
Public Class WebSiteSpider
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WebSiteSpider(Configuration) | Creates a new instance.
 | AddedDocument | Fired when a document has been added to the index.
 | AddingDocument | Fired when a document is about to be added to the index.
 | CancelCrawl()()()() | Cancels the crawl.
 | Close()()()() | Closes the index for use
 | Configuration | Gets the instance of the Configuration class that holds the settings to be used.
 | Crawl()()()() | Obsolete. Starts the spidering process, which will recrawl all the existing documents for new links.
 | Crawl(String, Boolean) | Obsolete. Starts the spidering process, which will recrawl all the existing documents for new links.
 | Crawl(String, Boolean, WebsiteBasedIndexableSourceRecord) | Obsolete. Starts the spidering process, which will recrawl all the existing documents for new links.
 | Crawl(ArrayList) | Obsolete. Crawls all URL strings in urlList, adds new document URLs (including those from urlList) to the 'database' and returns list of newly found URLs.
 | Crawl(ArrayList, ArrayList) | Obsolete. Crawls all URL strings in urlList, adds new document URLs (including those from urlList) to the 'database' and returns list of newly found URLs.
 | Crawl(ArrayList, ArrayList, WebsiteBasedIndexableSourceRecord) | Obsolete. Crawls all URL strings in urlList, adds new document URLs (including those from urlList) to the 'database' and returns list of newly found URLs.
 | CreateNewDocument(DocumentRecord) | Called whenever a Document object is created, override this method to use Document subclasses.
 | DataAccess | The data-access layer.
 | DiscoverLinkedURLs(ArrayList, ArrayList, ArrayList) | Crawls all URLs in urlList, and returns list of all newly found URLs (whether they are known to the document index or not, and not including urls in urlList)
 | DiscoverLinkedURLs(ArrayList, ArrayList, ArrayList, ArrayList) | Crawls all URLs in urlList, and adds found URLs to discoveredURLs list (whether they are known to the document index or not, and not including urls in urlList)
 | DiscoverLinkedURLs(ArrayList, ArrayList, ArrayList, ArrayList, ArrayList, Boolean, ArrayList, WebSiteSpider..::..DiscoveredDocumentHandler) | Crawls all URLs in urlList, and adds found URLs to discoveredURLs list (whether they are known to the document index or not, and not including urls in urlList)
 | DocumentShouldBeCrawled(Document) | Obsolete. Method called from Crawl - checks if the current document type is specified as to be crawled in config file, returning true - if so (files types from config file are stored in class member when the object is instantiated)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetIndexedDocuments()()()() | Obsolete. Gets all the indexed documents from the document table, as an ArrayList of Document objects
 | GetType()()()() | (Inherited from Object.)
 | IsDocumentToBeCrawled(Document, Boolean, Boolean, String, ArrayList, ArrayList) | Method called during crawl - checks if the current document type is specified as to be crawled in config file, returning true - if so (files types from config file are stored in class member when the object is instantiated)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NewLinkNo | Number of new links found so far.
 | OnReaderExceptionOccurred(ReaderException, Uri) | Called whenever a readerException is caught
 | Open()()()() | Opens the index for use.
 | PrefilterDocumentToCrawl(Document) | Called during crawl to identify if the document might be crawled. Will return false if the document won't be crawled based on it's URL.
 | ProcessedLinkNo | The number of processed links.
 | ReaderExceptionOccurred | Fired whenever the (web) reader encounters a network exception, eg. 404 (this can be useful for identifying dead links)
 | ToString()()()() | (Inherited from Object.)
Remarks
Before any operations (Crawl, GetIndexedDocuments) can be performed the index must be opened with Open (otherwise a KeyotiFatalException is thrown) - and should be closed afterwards with Close.
Inheritance Hierarchy
Object
WebSiteSpider

Send comments on this topic to support@keyoti.com


WebSiteSpider Constructor (configuration)

WebSiteSpider Constructor (configuration)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► WebSiteSpider ► WebSiteSpider(Configuration)
Keyoti SearchUnit v6
Creates a new instance.
Declaration Syntax
C# Visual Basic
public WebSiteSpider(
    Configuration configuration
)
Public Sub New (
    configuration As Configuration
)
Parameters
configuration (Configuration)
The instance of the Configuration class that holds the settings to be used.


AddedDocument Event

AddedDocument Event
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► WebSiteSpider ► AddedDocument
Keyoti SearchUnit v6
Fired when a document has been added to the index.
Declaration Syntax
C# Visual Basic
public event AddDocumentEventHandler AddedDocument
Public Event AddedDocument As AddDocumentEventHandler
Value
AddDocumentEventHandler

Send comments on this topic to support@keyoti.com


AddingDocument Event

AddingDocument Event
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► WebSiteSpider ► AddingDocument
Keyoti SearchUnit v6
Fired when a document is about to be added to the index.
Declaration Syntax
C# Visual Basic
public event AddDocumentEventHandler AddingDocument
Public Event AddingDocument As AddDocumentEventHandler
Value
AddDocumentEventHandler

Send comments on this topic to support@keyoti.com


CancelCrawl Method

CancelCrawl Method
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► WebSiteSpider ► CancelCrawl()()()()
Keyoti SearchUnit v6
Cancels the crawl.
Declaration Syntax
C# Visual Basic
public virtual void CancelCrawl()
Public Overridable Sub CancelCrawl

Send comments on this topic to support@keyoti.com


Close Method

Close Method
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► WebSiteSpider ► Close()()()()
Keyoti SearchUnit v6
Closes the index for use
Declaration Syntax
C# Visual Basic
public virtual void Close()
Public Overridable Sub Close

Send comments on this topic to support@keyoti.com


Configuration Property

Configuration Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► WebSiteSpider ► Configuration
Keyoti SearchUnit v6
Gets the instance of the Configuration class that holds the settings to be used.
Declaration Syntax
C# Visual Basic
public Configuration Configuration { get; }
Public ReadOnly Property Configuration As Configuration
    Get
Property Value
Configuration

Send comments on this topic to support@keyoti.com


Crawl Method

Crawl Method
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► WebSiteSpider ► Crawl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Crawl()()()() | Obsolete. Starts the spidering process, which will recrawl all the existing documents for new links.
 | Crawl(String, Boolean) | Obsolete. Starts the spidering process, which will recrawl all the existing documents for new links.
 | Crawl(String, Boolean, WebsiteBasedIndexableSourceRecord) | Obsolete. Starts the spidering process, which will recrawl all the existing documents for new links.
 | Crawl(ArrayList) | Obsolete. Crawls all URL strings in urlList, adds new document URLs (including those from urlList) to the 'database' and returns list of newly found URLs.
 | Crawl(ArrayList, ArrayList) | Obsolete. Crawls all URL strings in urlList, adds new document URLs (including those from urlList) to the 'database' and returns list of newly found URLs.
 | Crawl(ArrayList, ArrayList, WebsiteBasedIndexableSourceRecord) | Obsolete. Crawls all URL strings in urlList, adds new document URLs (including those from urlList) to the 'database' and returns list of newly found URLs.


Crawl Method

Crawl Method
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► WebSiteSpider ► Crawl()()()()
Keyoti SearchUnit v6
Starts the spidering process, which will recrawl all the existing documents for new links.
Declaration Syntax
C# Visual Basic
[ObsoleteAttribute("Use DocumentIndex.ImportWebsite instead.", true)]
public virtual ArrayList Crawl()
<ObsoleteAttribute("Use DocumentIndex.ImportWebsite instead.", true)>
Public Overridable Function Crawl As ArrayList
Return Value
ArrayList
ArrayList of Uri objects with URLs that weren't already in the index
Exceptions
Exception | Condition
InvalidOperationException | If Configuration.IsLock is true (a lock has been applied).


Crawl Method (urlList)

Crawl Method (urlList)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► WebSiteSpider ► Crawl(ArrayList)
Keyoti SearchUnit v6
Crawls all URL strings in urlList, adds new document URLs (including those from urlList) to the 'database' and returns list of newly found URLs.
Declaration Syntax
C# Visual Basic
[ObsoleteAttribute("Use DocumentIndex.ImportWebsite instead.", true)]
public virtual ArrayList Crawl(
    ArrayList urlList
)
<ObsoleteAttribute("Use DocumentIndex.ImportWebsite instead.", true)>
Public Overridable Function Crawl (
    urlList As ArrayList
) As ArrayList
Parameters
urlList (ArrayList)
List of string objects specifying URLs to be crawled
Return Value
ArrayList
ArrayList of Uri objects with new URLs added to 'database'.
Remarks
Crawling will read each page and then each page (within the same host) linked from that page, until it finds no new pages.
Exceptions
Exception | Condition
InvalidOperationException | If Configuration.IsLock is true (a lock has been applied).


Crawl Method (urlList, isLoginPage)

Crawl Method (urlList, isLoginPage)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► WebSiteSpider ► Crawl(ArrayList, ArrayList)
Keyoti SearchUnit v6
Crawls all URL strings in urlList, adds new document URLs (including those from urlList) to the 'database' and returns list of newly found URLs.
Declaration Syntax
C# Visual Basic
[ObsoleteAttribute("Use DocumentIndex.ImportWebsite instead.", true)]
public virtual ArrayList Crawl(
    ArrayList urlList,
    ArrayList isLoginPage
)
<ObsoleteAttribute("Use DocumentIndex.ImportWebsite instead.", true)>
Public Overridable Function Crawl (
    urlList As ArrayList,
    isLoginPage As ArrayList
) As ArrayList
Parameters
urlList (ArrayList)
List of string objects specifying URLs to be crawled
isLoginPage (ArrayList)
List of booleans indicating whether URL at corresponding index in urlList is a 'login page' for Forms Authentication - see user guide section on Forms Authentication for more.
Return Value
ArrayList
ArrayList of Uri objects with new URLs added to 'database'.
Remarks
Crawling will read each page and then each page (within the same host) linked from that page, until it finds no new pages.
Exceptions
Exception | Condition
InvalidOperationException | If Configuration.IsLock is true (a lock has been applied).


Crawl Method (urlList, isLoginPage, indexableSourceRecord)

Crawl Method (urlList, isLoginPage, indexableSourceRecord)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► WebSiteSpider ► Crawl(ArrayList, ArrayList, WebsiteBasedIndexableSourceRecord)
Keyoti SearchUnit v6
Crawls all URL strings in urlList, adds new document URLs (including those from urlList) to the 'database' and returns list of newly found URLs.
Declaration Syntax
C# Visual Basic
[ObsoleteAttribute("Use DocumentIndex.ImportWebsite instead.", true)]
public virtual ArrayList Crawl(
    ArrayList urlList,
    ArrayList isLoginPage,
    WebsiteBasedIndexableSourceRecord indexableSourceRecord
)
<ObsoleteAttribute("Use DocumentIndex.ImportWebsite instead.", true)>
Public Overridable Function Crawl (
    urlList As ArrayList,
    isLoginPage As ArrayList,
    indexableSourceRecord As WebsiteBasedIndexableSourceRecord
) As ArrayList
Parameters
urlList (ArrayList)
List of string objects specifying URLs to be crawled
isLoginPage (ArrayList)
List of booleans indicating whether URL at corresponding index in urlList is a 'login page' for Forms Authentication - see user guide section on Forms Authentication for more.
indexableSourceRecord (WebsiteBasedIndexableSourceRecord)
The IndexableSourceRecord that this document is assigned to, may be null.
Return Value
ArrayList
ArrayList of Uri objects with URLs added to 'database'.
Remarks
Crawling will read each page and then each page (within the same host) linked from that page, until it finds no new pages. Note that the return list includes newly found URLs and pre-existing URLs (from prior crawls, etc).
Exceptions
Exception | Condition
InvalidOperationException | If Configuration.IsLock is true (a lock has been applied).


Crawl Method (startURL, isLoginPage)

Crawl Method (startURL, isLoginPage)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► WebSiteSpider ► Crawl(String, Boolean)
Keyoti SearchUnit v6
Starts the spidering process, which will recrawl all the existing documents for new links.
Declaration Syntax
C# Visual Basic
[ObsoleteAttribute("Use DocumentIndex.ImportWebsite instead.", true)]
public virtual ArrayList Crawl(
    string startURL,
    bool isLoginPage
)
<ObsoleteAttribute("Use DocumentIndex.ImportWebsite instead.", true)>
Public Overridable Function Crawl (
    startURL As String,
    isLoginPage As Boolean
) As ArrayList
Parameters
startURL (String)
The URL to start crawling a web-site from.
isLoginPage (Boolean)
Whether this start URL is the login form for the site
Return Value
ArrayList
ArrayList of Uri objects with URLs that weren't already in the index
Exceptions
Exception | Condition
InvalidOperationException | If Configuration.IsLock is true (a lock has been applied).


Crawl Method (startURL, isLoginPage, indexableSourceRecord)

Crawl Method (startURL, isLoginPage, indexableSourceRecord)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► WebSiteSpider ► Crawl(String, Boolean, WebsiteBasedIndexableSourceRecord)
Keyoti SearchUnit v6
Starts the spidering process, which will recrawl all the existing documents for new links.
Declaration Syntax
C# Visual Basic
[ObsoleteAttribute("Use DocumentIndex.ImportWebsite instead.", true)]
public virtual ArrayList Crawl(
    string startURL,
    bool isLoginPage,
    WebsiteBasedIndexableSourceRecord indexableSourceRecord
)
<ObsoleteAttribute("Use DocumentIndex.ImportWebsite instead.", true)>
Public Overridable Function Crawl (
    startURL As String,
    isLoginPage As Boolean,
    indexableSourceRecord As WebsiteBasedIndexableSourceRecord
) As ArrayList
Parameters
startURL (String)
The URL to start crawling a web-site from.
isLoginPage (Boolean)
Whether this start URL is the login form for the site
indexableSourceRecord (WebsiteBasedIndexableSourceRecord)
The indexable source record representing a web-site to crawl
Return Value
ArrayList
ArrayList of Uri objects with URLs that weren't already in the index
Exceptions
Exception | Condition
InvalidOperationException | If Configuration.IsLock is true (a lock has been applied).


CreateNewDocument Method (docRec)

CreateNewDocument Method (docRec)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► WebSiteSpider ► CreateNewDocument(DocumentRecord)
Keyoti SearchUnit v6
Called whenever a Document object is created, override this method to use Document subclasses.
Declaration Syntax
C# Visual Basic
protected virtual Document CreateNewDocument(
    DocumentRecord docRec
)
Protected Overridable Function CreateNewDocument (
    docRec As DocumentRecord
) As Document
Parameters
docRec (DocumentRecord)
The data-access layer document record.
Return Value
Document
A new Document (or subclass of)


DataAccess Property

DataAccess Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► WebSiteSpider ► DataAccess
Keyoti SearchUnit v6
The data-access layer.
Declaration Syntax
C# Visual Basic
public virtual XmlDataAccess DataAccess { get; set; }
Public Overridable Property DataAccess As XmlDataAccess
    Get
    Set
Property Value
XmlDataAccess

Send comments on this topic to support@keyoti.com


DiscoverLinkedURLs Method

DiscoverLinkedURLs Method
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► WebSiteSpider ► DiscoverLinkedURLs()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | DiscoverLinkedURLs(ArrayList, ArrayList, ArrayList) | Crawls all URLs in urlList, and returns list of all newly found URLs (whether they are known to the document index or not, and not including urls in urlList)
 | DiscoverLinkedURLs(ArrayList, ArrayList, ArrayList, ArrayList) | Crawls all URLs in urlList, and adds found URLs to discoveredURLs list (whether they are known to the document index or not, and not including urls in urlList)
 | DiscoverLinkedURLs(ArrayList, ArrayList, ArrayList, ArrayList, ArrayList, Boolean, ArrayList, WebSiteSpider..::..DiscoveredDocumentHandler) | Crawls all URLs in urlList, and adds found URLs to discoveredURLs list (whether they are known to the document index or not, and not including urls in urlList)


DiscoverLinkedURLs Method (crawlUriList, pathMatchesToBeIgnored, pathMatchesToBeIncluded)

DiscoverLinkedURLs Method (crawlUriList, pathMatchesToBeIgnored, pathMatchesToBeIncluded)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► WebSiteSpider ► DiscoverLinkedURLs(ArrayList, ArrayList, ArrayList)
Keyoti SearchUnit v6
Crawls all URLs in urlList, and returns list of all newly found URLs (whether they are known to the document index or not, and not including urls in urlList)
Declaration Syntax
C# Visual Basic
public ArrayList DiscoverLinkedURLs(
    ArrayList crawlUriList,
    ArrayList pathMatchesToBeIgnored,
    ArrayList pathMatchesToBeIncluded
)
Public Function DiscoverLinkedURLs (
    crawlUriList As ArrayList,
    pathMatchesToBeIgnored As ArrayList,
    pathMatchesToBeIncluded As ArrayList
) As ArrayList
Parameters
crawlUriList (ArrayList)
List of string objects specifying Uris to be crawled.
pathMatchesToBeIgnored (ArrayList)
List of strings which specify path matches to be ignored, can be null.
pathMatchesToBeIncluded (ArrayList)
List of strings which specify path matches to be included, can be null.
Return Value
ArrayList
ArrayList of string objects with new URLs found through crawling
Remarks
Unlike Crawl, this method doesn't add new URLs to the 'database'. Crawl uses this method, overriding this method will affect Crawl.


DiscoverLinkedURLs Method (crawlUriList, discoveredURLs, pathMatchesToBeIgnored, pathMatchesToBeIncluded)

DiscoverLinkedURLs Method (crawlUriList, discoveredURLs, pathMatchesToBeIgnored, pathMatchesToBeIncluded)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► WebSiteSpider ► DiscoverLinkedURLs(ArrayList, ArrayList, ArrayList, ArrayList)
Keyoti SearchUnit v6
Crawls all URLs in urlList, and adds found URLs to discoveredURLs list (whether they are known to the document index or not, and not including urls in urlList)
Declaration Syntax
C# Visual Basic
public void DiscoverLinkedURLs(
    ArrayList crawlUriList,
    ArrayList discoveredURLs,
    ArrayList pathMatchesToBeIgnored,
    ArrayList pathMatchesToBeIncluded
)
Public Sub DiscoverLinkedURLs (
    crawlUriList As ArrayList,
    discoveredURLs As ArrayList,
    pathMatchesToBeIgnored As ArrayList,
    pathMatchesToBeIncluded As ArrayList
)
Parameters
crawlUriList (ArrayList)
List of string objects specifying Uris to be crawled
discoveredURLs (ArrayList)
ArrayList of string objects with new URLs found through crawling
pathMatchesToBeIgnored (ArrayList)
Any strings which will be used to determine if a file should be ignored based on its Url path.
pathMatchesToBeIncluded (ArrayList)
Any strings which will be used to determine if a file should exclusively be included based on its Url path.
Remarks
Unlike Crawl, this method doesn't add new URLs to the 'database'. Crawl uses this method, overriding this method will affect Crawl. This override is most suitable for polling discoveredURLs from another thread, to track progress.


DiscoverLinkedURLs Method (crawlUriList, discoveredURLs, pathMatchesToBeIgnored, pathMatchesToBeIncluded, existingDocumentURLs, indexNow, addedURLs, discoveredDocumentHandler)

DiscoverLinkedURLs Method (crawlUriList, discoveredURLs, pathMatchesToBeIgnored, pathMatchesToBeIncluded, existingDocumentURLs, indexNow, addedURLs, discoveredDocumentHandler)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► WebSiteSpider ► DiscoverLinkedURLs(ArrayList, ArrayList, ArrayList, ArrayList, ArrayList, Boolean, ArrayList, WebSiteSpider..::..DiscoveredDocumentHandler)
Keyoti SearchUnit v6
Crawls all URLs in urlList, and adds found URLs to discoveredURLs list (whether they are known to the document index or not, and not including urls in urlList)
Declaration Syntax
C# Visual Basic
public virtual void DiscoverLinkedURLs(
    ArrayList crawlUriList,
    ArrayList discoveredURLs,
    ArrayList pathMatchesToBeIgnored,
    ArrayList pathMatchesToBeIncluded,
    ArrayList existingDocumentURLs,
    bool indexNow,
    ArrayList addedURLs,
    WebSiteSpider..::..DiscoveredDocumentHandler discoveredDocumentHandler
)
Public Overridable Sub DiscoverLinkedURLs (
    crawlUriList As ArrayList,
    discoveredURLs As ArrayList,
    pathMatchesToBeIgnored As ArrayList,
    pathMatchesToBeIncluded As ArrayList,
    existingDocumentURLs As ArrayList,
    indexNow As Boolean,
    addedURLs As ArrayList,
    discoveredDocumentHandler As WebSiteSpider..::..DiscoveredDocumentHandler
)
Parameters
crawlUriList (ArrayList)
List of string objects specifying Uris to be crawled
discoveredURLs (ArrayList)
ArrayList of string objects with new URLs found through crawling
pathMatchesToBeIgnored (ArrayList)
Any strings which will be used to determine if a file should be ignored based on its Url path.
pathMatchesToBeIncluded (ArrayList)
Any strings which will be used to determine if a file should exclusively be included based on its Url path.
existingDocumentURLs (ArrayList)
List of URLs of existing documents in the index
indexNow (Boolean)
Whether to index these documents now.
addedURLs (ArrayList)
ArrayList in which added URLs will be added
discoveredDocumentHandler (WebSiteSpider..::..DiscoveredDocumentHandler)
Delegate to be informed as documents are found
Remarks
Unlike Crawl, this method doesn't add new URLs to the 'database'. Crawl uses this method, overriding this method will affect Crawl. This override is most suitable for polling discoveredURLs from another thread, to track progress.


DocumentShouldBeCrawled Method (doc)

DocumentShouldBeCrawled Method (doc)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► WebSiteSpider ► DocumentShouldBeCrawled(Document)
Keyoti SearchUnit v6
Method called from Crawl - checks if the current document type is specified as to be crawled in config file, returning true - if so (files types from config file are stored in class member when the object is instantiated)
Declaration Syntax
C# Visual Basic
[ObsoleteAttribute("Use IsDocumentToBeCrawled instead", true)]
protected virtual bool DocumentShouldBeCrawled(
    Document doc
)
<ObsoleteAttribute("Use IsDocumentToBeCrawled instead", true)>
Protected Overridable Function DocumentShouldBeCrawled (
    doc As Document
) As Boolean
Parameters
doc (Document)
Return Value
Boolean

Send comments on this topic to support@keyoti.com


GetIndexedDocuments Method

GetIndexedDocuments Method
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► WebSiteSpider ► GetIndexedDocuments()()()()
Keyoti SearchUnit v6
Gets all the indexed documents from the document table, as an ArrayList of Document objects
Declaration Syntax
C# Visual Basic
[ObsoleteAttribute("Use DocumentIndex.GetIndexedDocuments instead.",
    true)]
public virtual ArrayList GetIndexedDocuments()
<ObsoleteAttribute("Use DocumentIndex.GetIndexedDocuments instead.",
    true)>
Public Overridable Function GetIndexedDocuments As ArrayList
Return Value
ArrayList
ArrayList of Document objects

Send comments on this topic to support@keyoti.com


IsDocumentToBeCrawled Method (document, documentHasIgnorePathHit, documentHasIncludePathMiss, parentUri, pathMatchesToBeIgnored, pathMatchesToBeIncluded)

IsDocumentToBeCrawled Method (document, documentHasIgnorePathHit, documentHasIncludePathMiss, parentUri, pathMatchesToBeIgnored, pathMatchesToBeIncluded)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► WebSiteSpider ► IsDocumentToBeCrawled(Document, Boolean, Boolean, String, ArrayList, ArrayList)
Keyoti SearchUnit v6
Method called during crawl - checks if the current document type is specified as to be crawled in config file, returning true - if so (files types from config file are stored in class member when the object is instantiated)
Declaration Syntax
C# Visual Basic
protected virtual bool IsDocumentToBeCrawled(
    Document document,
    bool documentHasIgnorePathHit,
    bool documentHasIncludePathMiss,
    string parentUri,
    ArrayList pathMatchesToBeIgnored,
    ArrayList pathMatchesToBeIncluded
)
Protected Overridable Function IsDocumentToBeCrawled (
    document As Document,
    documentHasIgnorePathHit As Boolean,
    documentHasIncludePathMiss As Boolean,
    parentUri As String,
    pathMatchesToBeIgnored As ArrayList,
    pathMatchesToBeIncluded As ArrayList
) As Boolean
Parameters
document (Document)
documentHasIgnorePathHit (Boolean)
documentHasIncludePathMiss (Boolean)
parentUri (String)
pathMatchesToBeIgnored (ArrayList)
pathMatchesToBeIncluded (ArrayList)
Return Value
Boolean

Send comments on this topic to support@keyoti.com


NewLinkNo Property

NewLinkNo Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► WebSiteSpider ► NewLinkNo
Keyoti SearchUnit v6
Number of new links found so far.
Declaration Syntax
C# Visual Basic
public virtual int NewLinkNo { get; set; }
Public Overridable Property NewLinkNo As Integer
    Get
    Set
Property Value
Int32

Send comments on this topic to support@keyoti.com


OnReaderExceptionOccurred Method (ex, uri)

OnReaderExceptionOccurred Method (ex, uri)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► WebSiteSpider ► OnReaderExceptionOccurred(ReaderException, Uri)
Keyoti SearchUnit v6
Called whenever a readerException is caught
Declaration Syntax
C# Visual Basic
protected virtual void OnReaderExceptionOccurred(
    ReaderException ex,
    Uri uri
)
Protected Overridable Sub OnReaderExceptionOccurred (
    ex As ReaderException,
    uri As Uri
)
Parameters
ex (ReaderException)
uri (Uri)


Open Method

Open Method
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► WebSiteSpider ► Open()()()()
Keyoti SearchUnit v6
Opens the index for use.
Declaration Syntax
C# Visual Basic
public virtual void Open()
Public Overridable Sub Open
Remarks
Will not reopen the DataAccess layer if it is already opened.


PrefilterDocumentToCrawl Method (document)

PrefilterDocumentToCrawl Method (document)
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► WebSiteSpider ► PrefilterDocumentToCrawl(Document)
Keyoti SearchUnit v6
Called during crawl to identify if the document might be crawled. Will return false if the document won't be crawled based on it's URL.
Declaration Syntax
C# Visual Basic
protected virtual bool PrefilterDocumentToCrawl(
    Document document
)
Protected Overridable Function PrefilterDocumentToCrawl (
    document As Document
) As Boolean
Parameters
document (Document)
Return Value
Boolean

Send comments on this topic to support@keyoti.com


ProcessedLinkNo Property

ProcessedLinkNo Property
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► WebSiteSpider ► ProcessedLinkNo
Keyoti SearchUnit v6
The number of processed links.
Declaration Syntax
C# Visual Basic
public virtual int ProcessedLinkNo { get; }
Public Overridable ReadOnly Property ProcessedLinkNo As Integer
    Get
Property Value
Int32

Send comments on this topic to support@keyoti.com


ReaderExceptionOccurred Event

ReaderExceptionOccurred Event
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► WebSiteSpider ► ReaderExceptionOccurred
Keyoti SearchUnit v6
Fired whenever the (web) reader encounters a network exception, eg. 404 (this can be useful for identifying dead links)
Declaration Syntax
C# Visual Basic
public event ReaderExceptionOccurredEventHandler ReaderExceptionOccurred
Public Event ReaderExceptionOccurred As ReaderExceptionOccurredEventHandler
Value
ReaderExceptionOccurredEventHandler

Send comments on this topic to support@keyoti.com


WebSiteSpider.DiscoveredDocumentHandler Delegate

WebSiteSpider..::..DiscoveredDocumentHandler Delegate
API Documentation ► Keyoti.SearchEngine.Index.IndexableSources ► WebSiteSpider ► WebSiteSpider..::..DiscoveredDocumentHandler
Keyoti SearchUnit v6
Delegate which is called as documents are found.
Declaration Syntax
C# Visual Basic
public delegate bool DiscoveredDocumentHandler(
    Document newDocument
)
Public Delegate Function DiscoveredDocumentHandler (
    newDocument As Document
) As Boolean
Parameters
newDocument (Document)
Return Value
Boolean

Send comments on this topic to support@keyoti.com


Keyoti.SearchEngine.Search Namespace

Keyoti.SearchEngine.Search Namespace
API Documentation ► Keyoti.SearchEngine.Search
Keyoti SearchUnit v6
Classes for searching the document index.

Search classes

Types
All Types Classes Interfaces Enumerations Delegates
Icon | Type | Description
 | AsianWordElement | Represents an Asian language word element in the query.
 | CustomDataFilter |
 | CustomDataFilterActionData |
 | CustomDataFilterEngineFactory |
 | SearchResult..::..DataRowEventArgs | Event args for DataRow event(s).
 | SearchResult..::..DataRowEventHandler | Handler delegate
 | SearchResult..::..DataTableEventArgs | Event args for DataTable event(s).
 | SearchResult..::..DataTableEventHandler | Handler delegate
 | CustomDataFilterEngineFactory..::..DateEngine |
 | Element | Base class for all query elements, see remarks.
 | CustomDataFilterEngineFactory..::..EngineBase |
 | ExpressionOperators | A pair of strings used as logic operator (AND, OR) names
 | SortBy..::..FieldDataType | Types of fields that can be sorted.
 | FilterCollection |
 | FilterLoadLevel | Specifies what amount of data to load for any filtering by an AddResultItemToResults override.
 | GroupElement | Implements a group for a search expression; group entity has elements (words, not-words, phrases and other nested groups) connected through a unique logic operator (AND is assumed for 'space')
 | ICustomDataFilterEngine |
 | ImpliedLogicOperator | Implied logic operator options.
 | CustomDataFilterEngineFactory..::..IntEngine |
 | InvalidExpressionReason | Specifies the reason for search expression exceptions.
 | InvalidSearchExpressionException | Thrown when a search expression is invalid.
 | LiveDataCollection |
 | LiveDataSample |
 | LOGIC_OPERATOR | Obsolete. Logic operators
 | LogicOperator | Logic operators
 | NotWordElement | Represents a 'not word', appearing in queries as -word
 | OperatorElement | Represents an operator element in a query.
 | PhraseElement | Represents a phrase in the query (eg. "this phrase").
 | QueryExpressionParser | Parses raw query strings entered by users.
 | Range<(Of <(<'T>)>)> |
 | REASON | Obsolete. Specifies the reason for search expression exceptions.
 | ResultItem | Represents a result item from a search.
 | ResultSummaryType | Describes types of result summaries.
 | SearchAgent | Performs searches with user defined queries.
 | SearcherIO | Internal use, handles search IO operations.
 | SearchLogic | Applies query logic to search results
 | SearchOptions | Contains content and location options (note these are only applicable in Search PRO).
 | SearchResult |
 | SortBy | Sort by definition.
 | CustomDataFilterEngineFactory..::..StringListEngine |
 | CustomDataFilterEngineFactory..::..StringOREngine |
 | WildcardWordElement | Represents a word element in the query which contains a wildcard.
 | WordElement | Represents a word element in the query.


AsianWordElement Class

AsianWordElement Class
API Documentation ► Keyoti.SearchEngine.Search ► AsianWordElement
Keyoti SearchUnit v6
Represents an Asian language word element in the query.
Declaration Syntax
C# Visual Basic
public class AsianWordElement : WildcardWordElement
Public Class AsianWordElement
    Inherits WildcardWordElement
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AsianWordElement(String, Configuration) | Creates a new AsianWordElement
 | Configuration | The instance of the Configuration class that holds the settings to be used. (Inherited from Element.)
 | Content | Returns a string representing the content of the element, this should typically be; WordElement.Content => theWord NotWordElement.Content => -theWord GroupElement.Content => null PhraseElement.Content => thePhrase (no quotes) (Inherited from WordElement.)
 | CreateLexiconQueries(SearcherIO) | Creates the lexicon query(s) needed for this element (Inherited from WildcardWordElement.)
 | elementQueryCollection | The lexicon queries used for the element (Inherited from Element.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetIgnoredWords()()()() | Returns the stop words from the original query that were ignored. (Inherited from WordElement.)
 | GetMatchingDocumentIDs(SearcherIO, IntHashtable, SearchOptions, Hashtable) | Gets all document IDs matching this element. (Inherited from WildcardWordElement.)
 | GetType()()()() | (Inherited from Object.)
 | IsAsianWord(String) | Determines whether word contains Asian languages characters.
 | IsStopWord()()()() | Whether is stop word, only Word elements can be stop words. (Inherited from WordElement.)
 | maximumWildMatchesToFind | Maximum wildcard matches to find (Inherited from WildcardWordElement.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | theWildCardType | The type of wildcard. (Inherited from WildcardWordElement.)
 | ToString()()()() | (Inherited from Object.)
 | WildCardToken | The string that will be taken to be wild. Default = "*" (Inherited from WildcardWordElement.)
 | WildCardType | The type of wildcard specified. (Inherited from WildcardWordElement.)
Remarks
Asian languages are treated differently to Western languages.
Inheritance Hierarchy
Object
 | Element
 |  | WordElement
 |  |  | WildcardWordElement
 |  |  |  | AsianWordElement


AsianWordElement Constructor (word, configuration)

AsianWordElement Constructor (word, configuration)
API Documentation ► Keyoti.SearchEngine.Search ► AsianWordElement ► AsianWordElement(String, Configuration)
Keyoti SearchUnit v6
Creates a new AsianWordElement
Declaration Syntax
C# Visual Basic
public AsianWordElement(
    string word,
    Configuration configuration
)
Public Sub New (
    word As String,
    configuration As Configuration
)
Parameters
word (String)
The word containing Asian characters.
configuration (Configuration)
The instance of the Configuration class that holds the settings to be used.


IsAsianWord Method (word)

IsAsianWord Method (word)
API Documentation ► Keyoti.SearchEngine.Search ► AsianWordElement ► IsAsianWord(String)
Keyoti SearchUnit v6
Determines whether word contains Asian languages characters.
Declaration Syntax
C# Visual Basic
public static bool IsAsianWord(
    string word
)
Public Shared Function IsAsianWord (
    word As String
) As Boolean
Parameters
word (String)
The word which may contain Asian chars.
Return Value
Boolean
True if from an Asian language.
Remarks
Does not determine if word is a legal word in any Asian language.


CustomDataFilter Class

CustomDataFilter Class
API Documentation ► Keyoti.SearchEngine.Search ► CustomDataFilter
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public class CustomDataFilter
Public Class CustomDataFilter
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | FieldName | The field name that this filter is for.
 | Filter | Collection of filters and their limits.
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NeedLiveData | Whether to get live data for this filter's field. Allows relevant filter options to be displayed.
 | ToString()()()() | (Inherited from Object.)
 | Type | The filter type.
Inheritance Hierarchy
Object
CustomDataFilter

Send comments on this topic to support@keyoti.com


FieldName Property

FieldName Property
API Documentation ► Keyoti.SearchEngine.Search ► CustomDataFilter ► FieldName
Keyoti SearchUnit v6
The field name that this filter is for.
Declaration Syntax
C# Visual Basic
public string FieldName { get; set; }
Public Property FieldName As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


Filter Property

Filter Property
API Documentation ► Keyoti.SearchEngine.Search ► CustomDataFilter ► Filter
Keyoti SearchUnit v6
Collection of filters and their limits.
Declaration Syntax
C# Visual Basic
public string[][] Filter { get; set; }
Public Property Filter As String()()
    Get
    Set
Property Value
array<array< String >[]()[][]>[]()[][]


NeedLiveData Property

NeedLiveData Property
API Documentation ► Keyoti.SearchEngine.Search ► CustomDataFilter ► NeedLiveData
Keyoti SearchUnit v6
Whether to get live data for this filter's field. Allows relevant filter options to be displayed.
Declaration Syntax
C# Visual Basic
public bool NeedLiveData { get; set; }
Public Property NeedLiveData As Boolean
    Get
    Set
Property Value
Boolean

Send comments on this topic to support@keyoti.com


Type Property

Type Property
API Documentation ► Keyoti.SearchEngine.Search ► CustomDataFilter ► Type
Keyoti SearchUnit v6
The filter type.
Declaration Syntax
C# Visual Basic
public string Type { get; set; }
Public Property Type As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


CustomDataFilterActionData Class

CustomDataFilterActionData Class
API Documentation ► Keyoti.SearchEngine.Search ► CustomDataFilterActionData
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public class CustomDataFilterActionData
Public Class CustomDataFilterActionData
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CustomDataFilterActionData(ResultItem, CustomDataFilter, ICustomDataFilterEngine) |
 | Engine |
 | Equals(Object) | (Inherited from Object.)
 | Filter |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IsFilteredThrough |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ResultItem |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
CustomDataFilterActionData

Send comments on this topic to support@keyoti.com


CustomDataFilterActionData Constructor (item, filter, engine)

CustomDataFilterActionData Constructor (item, filter, engine)
API Documentation ► Keyoti.SearchEngine.Search ► CustomDataFilterActionData ► CustomDataFilterActionData(ResultItem, CustomDataFilter, ICustomDataFilterEngine)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public CustomDataFilterActionData(
    ResultItem item,
    CustomDataFilter filter,
    ICustomDataFilterEngine engine
)
Public Sub New (
    item As ResultItem,
    filter As CustomDataFilter,
    engine As ICustomDataFilterEngine
)
Parameters
item (ResultItem)
filter (CustomDataFilter)
engine (ICustomDataFilterEngine)


Engine Property

Engine Property
API Documentation ► Keyoti.SearchEngine.Search ► CustomDataFilterActionData ► Engine
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public ICustomDataFilterEngine Engine { get; }
Public ReadOnly Property Engine As ICustomDataFilterEngine
    Get
Property Value
ICustomDataFilterEngine

Send comments on this topic to support@keyoti.com


Filter Property

Filter Property
API Documentation ► Keyoti.SearchEngine.Search ► CustomDataFilterActionData ► Filter
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public CustomDataFilter Filter { get; }
Public ReadOnly Property Filter As CustomDataFilter
    Get
Property Value
CustomDataFilter

Send comments on this topic to support@keyoti.com


IsFilteredThrough Property

IsFilteredThrough Property
API Documentation ► Keyoti.SearchEngine.Search ► CustomDataFilterActionData ► IsFilteredThrough
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public bool IsFilteredThrough { get; set; }
Public Property IsFilteredThrough As Boolean
    Get
    Set
Property Value
Boolean

Send comments on this topic to support@keyoti.com


ResultItem Property

ResultItem Property
API Documentation ► Keyoti.SearchEngine.Search ► CustomDataFilterActionData ► ResultItem
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public ResultItem ResultItem { get; }
Public ReadOnly Property ResultItem As ResultItem
    Get
Property Value
ResultItem

Send comments on this topic to support@keyoti.com


CustomDataFilterEngineFactory Class

CustomDataFilterEngineFactory Class
API Documentation ► Keyoti.SearchEngine.Search ► CustomDataFilterEngineFactory
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public class CustomDataFilterEngineFactory
Public Class CustomDataFilterEngineFactory
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CustomDataFilterEngineFactory()()()() |
 | CreateEngine(String, array<array<String>[]()[][]>[]()[][], Configuration) |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
CustomDataFilterEngineFactory

Send comments on this topic to support@keyoti.com


CustomDataFilterEngineFactory Constructor

CustomDataFilterEngineFactory Constructor
API Documentation ► Keyoti.SearchEngine.Search ► CustomDataFilterEngineFactory ► CustomDataFilterEngineFactory()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public CustomDataFilterEngineFactory()
Public Sub New

Send comments on this topic to support@keyoti.com


CreateEngine Method (format, filter, configuration)

CreateEngine Method (format, filter, configuration)
API Documentation ► Keyoti.SearchEngine.Search ► CustomDataFilterEngineFactory ► CreateEngine(String, array<array<String>[]()[][]>[]()[][], Configuration)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public static ICustomDataFilterEngine CreateEngine(
    string format,
    string[][] filter,
    Configuration configuration
)
Public Shared Function CreateEngine (
    format As String,
    filter As String()(),
    configuration As Configuration
) As ICustomDataFilterEngine
Parameters
format (String)
filter (array<array< String >[]()[][]>[]()[][])
configuration (Configuration)
Return Value
ICustomDataFilterEngine

Send comments on this topic to support@keyoti.com


CustomDataFilterEngineFactory.DateEngine Class

CustomDataFilterEngineFactory..::..DateEngine Class
API Documentation ► Keyoti.SearchEngine.Search ► CustomDataFilterEngineFactory ► CustomDataFilterEngineFactory..::..DateEngine
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public class DateEngine : CustomDataFilterEngineFactory..::..EngineBase, ICustomDataFilterEngine
Public Class DateEngine
    Inherits CustomDataFilterEngineFactory..::..EngineBase
    Implements ICustomDataFilterEngine
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CustomDataFilterEngineFactory..::..DateEngine(array<String>[]()[][], Configuration) |
 | configuration | (Inherited from CustomDataFilterEngineFactory..::..EngineBase.)
 | DefaultFilterThroughNoCustomData | (Inherited from CustomDataFilterEngineFactory..::..EngineBase.)
 | DefaultFilterThroughParserError | (Inherited from CustomDataFilterEngineFactory..::..EngineBase.)
 | disabled | (Inherited from CustomDataFilterEngineFactory..::..EngineBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | formatOK | (Inherited from CustomDataFilterEngineFactory..::..EngineBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IsFilteredThrough(String) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CustomDataFilterEngineFactory..::..EngineBase
 |  | CustomDataFilterEngineFactory..::..DateEngine


CustomDataFilterEngineFactory.DateEngine Constructor (filter, configuration)

CustomDataFilterEngineFactory..::..DateEngine Constructor (filter, configuration)
API Documentation ► Keyoti.SearchEngine.Search ► CustomDataFilterEngineFactory..::..DateEngine ► CustomDataFilterEngineFactory..::..DateEngine(array<String>[]()[][], Configuration)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public DateEngine(
    string[] filter,
    Configuration configuration
)
Public Sub New (
    filter As String(),
    configuration As Configuration
)
Parameters
filter (array< String >[]()[][])
configuration (Configuration)


IsFilteredThrough Method (customDataEntry)

IsFilteredThrough Method (customDataEntry)
API Documentation ► Keyoti.SearchEngine.Search ► CustomDataFilterEngineFactory..::..DateEngine ► IsFilteredThrough(String)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public bool IsFilteredThrough(
    string customDataEntry
)
Public Function IsFilteredThrough (
    customDataEntry As String
) As Boolean
Parameters
customDataEntry (String)
Return Value
Boolean

Send comments on this topic to support@keyoti.com


CustomDataFilterEngineFactory.EngineBase Class

CustomDataFilterEngineFactory..::..EngineBase Class
API Documentation ► Keyoti.SearchEngine.Search ► CustomDataFilterEngineFactory ► CustomDataFilterEngineFactory..::..EngineBase
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public abstract class EngineBase
Public MustInherit Class EngineBase
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CustomDataFilterEngineFactory..::..EngineBase()()()() |
 | configuration |
 | DefaultFilterThroughNoCustomData |
 | DefaultFilterThroughParserError |
 | disabled |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | formatOK |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CustomDataFilterEngineFactory..::..EngineBase
 |  | CustomDataFilterEngineFactory..::..DateEngine
 |  | CustomDataFilterEngineFactory..::..IntEngine
 |  | CustomDataFilterEngineFactory..::..StringListEngine
 |  | CustomDataFilterEngineFactory..::..StringOREngine


CustomDataFilterEngineFactory.EngineBase Constructor

CustomDataFilterEngineFactory..::..EngineBase Constructor
API Documentation ► Keyoti.SearchEngine.Search ► CustomDataFilterEngineFactory..::..EngineBase ► CustomDataFilterEngineFactory..::..EngineBase()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
protected EngineBase()
Protected Sub New

Send comments on this topic to support@keyoti.com


configuration Field

configuration Field
API Documentation ► Keyoti.SearchEngine.Search ► CustomDataFilterEngineFactory..::..EngineBase ► configuration
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
protected Configuration configuration
Protected configuration As Configuration
Field Value
Configuration

Send comments on this topic to support@keyoti.com


DefaultFilterThroughNoCustomData Field

DefaultFilterThroughNoCustomData Field
API Documentation ► Keyoti.SearchEngine.Search ► CustomDataFilterEngineFactory..::..EngineBase ► DefaultFilterThroughNoCustomData
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
protected bool DefaultFilterThroughNoCustomData
Protected DefaultFilterThroughNoCustomData As Boolean
Field Value
Boolean

Send comments on this topic to support@keyoti.com


DefaultFilterThroughParserError Field

DefaultFilterThroughParserError Field
API Documentation ► Keyoti.SearchEngine.Search ► CustomDataFilterEngineFactory..::..EngineBase ► DefaultFilterThroughParserError
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
protected bool DefaultFilterThroughParserError
Protected DefaultFilterThroughParserError As Boolean
Field Value
Boolean

Send comments on this topic to support@keyoti.com


disabled Field

disabled Field
API Documentation ► Keyoti.SearchEngine.Search ► CustomDataFilterEngineFactory..::..EngineBase ► disabled
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
protected bool disabled
Protected disabled As Boolean
Field Value
Boolean

Send comments on this topic to support@keyoti.com


formatOK Field

formatOK Field
API Documentation ► Keyoti.SearchEngine.Search ► CustomDataFilterEngineFactory..::..EngineBase ► formatOK
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
protected bool formatOK
Protected formatOK As Boolean
Field Value
Boolean

Send comments on this topic to support@keyoti.com


CustomDataFilterEngineFactory.IntEngine Class

CustomDataFilterEngineFactory..::..IntEngine Class
API Documentation ► Keyoti.SearchEngine.Search ► CustomDataFilterEngineFactory ► CustomDataFilterEngineFactory..::..IntEngine
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public class IntEngine : CustomDataFilterEngineFactory..::..EngineBase, ICustomDataFilterEngine
Public Class IntEngine
    Inherits CustomDataFilterEngineFactory..::..EngineBase
    Implements ICustomDataFilterEngine
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CustomDataFilterEngineFactory..::..IntEngine(array<array<String>[]()[][]>[]()[][], Configuration) |
 | configuration | (Inherited from CustomDataFilterEngineFactory..::..EngineBase.)
 | DefaultFilterThroughNoCustomData | (Inherited from CustomDataFilterEngineFactory..::..EngineBase.)
 | DefaultFilterThroughParserError | (Inherited from CustomDataFilterEngineFactory..::..EngineBase.)
 | disabled | (Inherited from CustomDataFilterEngineFactory..::..EngineBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | formatOK | (Inherited from CustomDataFilterEngineFactory..::..EngineBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IsFilteredThrough(String) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CustomDataFilterEngineFactory..::..EngineBase
 |  | CustomDataFilterEngineFactory..::..IntEngine


CustomDataFilterEngineFactory.IntEngine Constructor (filters, configuration)

CustomDataFilterEngineFactory..::..IntEngine Constructor (filters, configuration)
API Documentation ► Keyoti.SearchEngine.Search ► CustomDataFilterEngineFactory..::..IntEngine ► CustomDataFilterEngineFactory..::..IntEngine(array<array<String>[]()[][]>[]()[][], Configuration)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public IntEngine(
    string[][] filters,
    Configuration configuration
)
Public Sub New (
    filters As String()(),
    configuration As Configuration
)
Parameters
filters (array<array< String >[]()[][]>[]()[][])
configuration (Configuration)


IsFilteredThrough Method (customDataEntry)

IsFilteredThrough Method (customDataEntry)
API Documentation ► Keyoti.SearchEngine.Search ► CustomDataFilterEngineFactory..::..IntEngine ► IsFilteredThrough(String)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public bool IsFilteredThrough(
    string customDataEntry
)
Public Function IsFilteredThrough (
    customDataEntry As String
) As Boolean
Parameters
customDataEntry (String)
Return Value
Boolean

Send comments on this topic to support@keyoti.com


CustomDataFilterEngineFactory.StringListEngine Class

CustomDataFilterEngineFactory..::..StringListEngine Class
API Documentation ► Keyoti.SearchEngine.Search ► CustomDataFilterEngineFactory ► CustomDataFilterEngineFactory..::..StringListEngine
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public class StringListEngine : CustomDataFilterEngineFactory..::..EngineBase,
    ICustomDataFilterEngine
Public Class StringListEngine
    Inherits CustomDataFilterEngineFactory..::..EngineBase
    Implements ICustomDataFilterEngine
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CustomDataFilterEngineFactory..::..StringListEngine(array<array<String>[]()[][]>[]()[][], Configuration, String) |
 | configuration | (Inherited from CustomDataFilterEngineFactory..::..EngineBase.)
 | DefaultFilterThroughNoCustomData | (Inherited from CustomDataFilterEngineFactory..::..EngineBase.)
 | DefaultFilterThroughParserError | (Inherited from CustomDataFilterEngineFactory..::..EngineBase.)
 | disabled | (Inherited from CustomDataFilterEngineFactory..::..EngineBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | formatOK | (Inherited from CustomDataFilterEngineFactory..::..EngineBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IsFilteredThrough(String) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CustomDataFilterEngineFactory..::..EngineBase
 |  | CustomDataFilterEngineFactory..::..StringListEngine


CustomDataFilterEngineFactory.StringListEngine Constructor (filter, configuration, operatorType)

CustomDataFilterEngineFactory..::..StringListEngine Constructor (filter, configuration, operatorType)
API Documentation ► Keyoti.SearchEngine.Search ► CustomDataFilterEngineFactory..::..StringListEngine ► CustomDataFilterEngineFactory..::..StringListEngine(array<array<String>[]()[][]>[]()[][], Configuration, String)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public StringListEngine(
    string[][] filter,
    Configuration configuration,
    string operatorType
)
Public Sub New (
    filter As String()(),
    configuration As Configuration,
    operatorType As String
)
Parameters
filter (array<array< String >[]()[][]>[]()[][])
configuration (Configuration)
operatorType (String)


IsFilteredThrough Method (customDataEntry)

IsFilteredThrough Method (customDataEntry)
API Documentation ► Keyoti.SearchEngine.Search ► CustomDataFilterEngineFactory..::..StringListEngine ► IsFilteredThrough(String)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public bool IsFilteredThrough(
    string customDataEntry
)
Public Function IsFilteredThrough (
    customDataEntry As String
) As Boolean
Parameters
customDataEntry (String)
Return Value
Boolean

Send comments on this topic to support@keyoti.com


CustomDataFilterEngineFactory.StringOREngine Class

CustomDataFilterEngineFactory..::..StringOREngine Class
API Documentation ► Keyoti.SearchEngine.Search ► CustomDataFilterEngineFactory ► CustomDataFilterEngineFactory..::..StringOREngine
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public class StringOREngine : CustomDataFilterEngineFactory..::..EngineBase,
    ICustomDataFilterEngine
Public Class StringOREngine
    Inherits CustomDataFilterEngineFactory..::..EngineBase
    Implements ICustomDataFilterEngine
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CustomDataFilterEngineFactory..::..StringOREngine(array<array<String>[]()[][]>[]()[][], Configuration) |
 | configuration | (Inherited from CustomDataFilterEngineFactory..::..EngineBase.)
 | DefaultFilterThroughNoCustomData | (Inherited from CustomDataFilterEngineFactory..::..EngineBase.)
 | DefaultFilterThroughParserError | (Inherited from CustomDataFilterEngineFactory..::..EngineBase.)
 | disabled | (Inherited from CustomDataFilterEngineFactory..::..EngineBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | formatOK | (Inherited from CustomDataFilterEngineFactory..::..EngineBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IsFilteredThrough(String) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CustomDataFilterEngineFactory..::..EngineBase
 |  | CustomDataFilterEngineFactory..::..StringOREngine


CustomDataFilterEngineFactory.StringOREngine Constructor (filter, configuration)

CustomDataFilterEngineFactory..::..StringOREngine Constructor (filter, configuration)
API Documentation ► Keyoti.SearchEngine.Search ► CustomDataFilterEngineFactory..::..StringOREngine ► CustomDataFilterEngineFactory..::..StringOREngine(array<array<String>[]()[][]>[]()[][], Configuration)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public StringOREngine(
    string[][] filter,
    Configuration configuration
)
Public Sub New (
    filter As String()(),
    configuration As Configuration
)
Parameters
filter (array<array< String >[]()[][]>[]()[][])
configuration (Configuration)


IsFilteredThrough Method (customDataEntry)

IsFilteredThrough Method (customDataEntry)
API Documentation ► Keyoti.SearchEngine.Search ► CustomDataFilterEngineFactory..::..StringOREngine ► IsFilteredThrough(String)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public bool IsFilteredThrough(
    string customDataEntry
)
Public Function IsFilteredThrough (
    customDataEntry As String
) As Boolean
Parameters
customDataEntry (String)
Return Value
Boolean

Send comments on this topic to support@keyoti.com


Element Class

Element Class
API Documentation ► Keyoti.SearchEngine.Search ► Element
Keyoti SearchUnit v6
Base class for all query elements, see remarks.
Declaration Syntax
C# Visual Basic
public abstract class Element
Public MustInherit Class Element
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Element(Configuration) | Creates an instance of Element class.
 | Configuration | The instance of the Configuration class that holds the settings to be used.
 | Content | Returns a string representing the content of the element, this should typically be; WordElement.Content => theWord NotWordElement.Content => -theWord GroupElement.Content => null PhraseElement.Content => thePhrase (no quotes)
 | CreateLexiconQueries(SearcherIO) | Creates the LexiconQuery objects for this element.
 | elementQueryCollection | The lexicon queries used for the element
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetIgnoredWords()()()() | Returns the stop words from the original query that were ignored.
 | GetMatchingDocumentIDs(SearcherIO, IntHashtable, SearchOptions, Hashtable) | Gets all document IDs matching this element.
 | GetType()()()() | (Inherited from Object.)
 | IsStopWord()()()() | Whether is stop word.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
A search query contains one or more 'elements' - these are identified as follows.
  • PhraseElement - a part of a query between quotes, eg. "this phrase"
  • GroupElement - a part of a query between brackets, eg. (this group). Typically holds other elements within it.
  • NotWordElement - a word in the query marked with a minus sign, eg. -excludeMe
  • WordElement - a word in the query, eg. this
Inheritance Hierarchy
Object
 | Element
 |  | GroupElement
 |  | NotWordElement
 |  | OperatorElement
 |  | PhraseElement
 |  | WordElement


Element Constructor (configuration)

Element Constructor (configuration)
API Documentation ► Keyoti.SearchEngine.Search ► Element ► Element(Configuration)
Keyoti SearchUnit v6
Creates an instance of Element class.
Declaration Syntax
C# Visual Basic
public Element(
    Configuration configuration
)
Public Sub New (
    configuration As Configuration
)
Parameters
configuration (Configuration)
The instance of the Configuration class that holds the settings to be used.


Configuration Property

Configuration Property
API Documentation ► Keyoti.SearchEngine.Search ► Element ► Configuration
Keyoti SearchUnit v6
The instance of the Configuration class that holds the settings to be used.
Declaration Syntax
C# Visual Basic
public Configuration Configuration { get; }
Public ReadOnly Property Configuration As Configuration
    Get
Property Value
Configuration

Send comments on this topic to support@keyoti.com


Content Property

Content Property
API Documentation ► Keyoti.SearchEngine.Search ► Element ► Content
Keyoti SearchUnit v6
Returns a string representing the content of the element, this should typically be;
WordElement.Content => theWord
NotWordElement.Content => -theWord
GroupElement.Content => null
PhraseElement.Content => thePhrase (no quotes)
Declaration Syntax
C# Visual Basic
public abstract string Content { get; }
Public MustOverride ReadOnly Property Content As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


CreateLexiconQueries Method (dataAccess)

CreateLexiconQueries Method (dataAccess)
API Documentation ► Keyoti.SearchEngine.Search ► Element ► CreateLexiconQueries(SearcherIO)
Keyoti SearchUnit v6
Creates the LexiconQuery objects for this element.
Declaration Syntax
C# Visual Basic
public abstract LexiconQueryCollection CreateLexiconQueries(
    SearcherIO dataAccess
)
Public MustOverride Function CreateLexiconQueries (
    dataAccess As SearcherIO
) As LexiconQueryCollection
Parameters
dataAccess (SearcherIO)
Return Value
LexiconQueryCollection

Send comments on this topic to support@keyoti.com


elementQueryCollection Field

elementQueryCollection Field
API Documentation ► Keyoti.SearchEngine.Search ► Element ► elementQueryCollection
Keyoti SearchUnit v6
The lexicon queries used for the element
Declaration Syntax
C# Visual Basic
protected LexiconQueryCollection elementQueryCollection
Protected elementQueryCollection As LexiconQueryCollection
Field Value
LexiconQueryCollection

Send comments on this topic to support@keyoti.com


GetIgnoredWords Method

GetIgnoredWords Method
API Documentation ► Keyoti.SearchEngine.Search ► Element ► GetIgnoredWords()()()()
Keyoti SearchUnit v6
Returns the stop words from the original query that were ignored.
Declaration Syntax
C# Visual Basic
protected internal virtual StringList GetIgnoredWords()
Protected Friend Overridable Function GetIgnoredWords As StringList
Return Value
StringList

Send comments on this topic to support@keyoti.com


GetMatchingDocumentIDs Method (dataAccess, cumulativeWeights, searchOptions, objDocOc)

GetMatchingDocumentIDs Method (dataAccess, cumulativeWeights, searchOptions, objDocOc)
API Documentation ► Keyoti.SearchEngine.Search ► Element ► GetMatchingDocumentIDs(SearcherIO, IntHashtable, SearchOptions, Hashtable)
Keyoti SearchUnit v6
Gets all document IDs matching this element.
Declaration Syntax
C# Visual Basic
public abstract IntList GetMatchingDocumentIDs(
    SearcherIO dataAccess,
    IntHashtable cumulativeWeights,
    SearchOptions searchOptions,
    Hashtable objDocOc
)
Public MustOverride Function GetMatchingDocumentIDs (
    dataAccess As SearcherIO,
    cumulativeWeights As IntHashtable,
    searchOptions As SearchOptions,
    objDocOc As Hashtable
) As IntList
Parameters
dataAccess (SearcherIO)
The data-access layer with the index.
cumulativeWeights (IntHashtable)
Hashtable passed to this method containing table of weights for occurrences (key=docID, value=word's weight in that doc).
searchOptions (SearchOptions)
Search options.
objDocOc (Hashtable)
Table of documents and their occurrence maps, this method adds the OccurrenceMap for this element to the table. key = this element, value = OccurrenceMap
Return Value
IntList
IntList of int document IDs

Send comments on this topic to support@keyoti.com


IsStopWord Method

IsStopWord Method
API Documentation ► Keyoti.SearchEngine.Search ► Element ► IsStopWord()()()()
Keyoti SearchUnit v6
Whether is stop word.
Declaration Syntax
C# Visual Basic
protected internal virtual bool IsStopWord()
Protected Friend Overridable Function IsStopWord As Boolean
Return Value
Boolean

Send comments on this topic to support@keyoti.com


ExpressionOperators Class

ExpressionOperators Class
API Documentation ► Keyoti.SearchEngine.Search ► ExpressionOperators
Keyoti SearchUnit v6
A pair of strings used as logic operator (AND, OR) names
Declaration Syntax
C# Visual Basic
public class ExpressionOperators
Public Class ExpressionOperators
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExpressionOperators(String, String) | Creates an instance of ExpressionOperators that receieves two strings (AND, OR operators) as parameters
 | AND | Define the AND logic operator
 | Equals(Object) | Equal (Overrides Object.Equals(Object).)
 | Finalize()()()() | (Inherited from Object.)
 | FromString(String) | Creates an instance based on the serialization of this object through a call to ToString.
 | GetHashCode()()()() | hash (Overrides Object.GetHashCode()()()().)
 | GetSerializationPattern()()()() | Returns the serialization pattern - which dictates how strings are converted to objects in FromString.
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OR | Define the OR logic operator
 | ToString()()()() | Overriden, as to return operators definition data (AND=<and>,OR=<or>) (Overrides Object.ToString()()()().)
Inheritance Hierarchy
Object
ExpressionOperators

Send comments on this topic to support@keyoti.com


ExpressionOperators Constructor (andOperator, orOperator)

ExpressionOperators Constructor (andOperator, orOperator)
API Documentation ► Keyoti.SearchEngine.Search ► ExpressionOperators ► ExpressionOperators(String, String)
Keyoti SearchUnit v6
Creates an instance of ExpressionOperators that receieves two strings (AND, OR operators) as parameters
Declaration Syntax
C# Visual Basic
public ExpressionOperators(
    string andOperator,
    string orOperator
)
Public Sub New (
    andOperator As String,
    orOperator As String
)
Parameters
andOperator (String)
String used as AND operator
orOperator (String)
String used as OR operator

Send comments on this topic to support@keyoti.com


AND Property

AND Property
API Documentation ► Keyoti.SearchEngine.Search ► ExpressionOperators ► AND
Keyoti SearchUnit v6
Define the AND logic operator
Declaration Syntax
C# Visual Basic
public string AND { get; set; }
Public Property AND As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


Equals Method (obj)

Equals Method (obj)
API Documentation ► Keyoti.SearchEngine.Search ► ExpressionOperators ► Equals(Object)
Keyoti SearchUnit v6
Equal
Declaration Syntax
C# Visual Basic
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Parameters
obj (Object)
Return Value
Boolean

Send comments on this topic to support@keyoti.com


FromString Method (serializedString)

FromString Method (serializedString)
API Documentation ► Keyoti.SearchEngine.Search ► ExpressionOperators ► FromString(String)
Keyoti SearchUnit v6
Creates an instance based on the serialization of this object through a call to ToString.
Declaration Syntax
C# Visual Basic
public static ExpressionOperators FromString(
    string serializedString
)
Public Shared Function FromString (
    serializedString As String
) As ExpressionOperators
Parameters
serializedString (String)
Output of ToString.
Return Value
ExpressionOperators
Remarks
i.e. ExpressionOperators.FromString( obj.ToString() ) creates an instance the same as obj.


GetHashCode Method

GetHashCode Method
API Documentation ► Keyoti.SearchEngine.Search ► ExpressionOperators ► GetHashCode()()()()
Keyoti SearchUnit v6
hash
Declaration Syntax
C# Visual Basic
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Return Value
Int32

Send comments on this topic to support@keyoti.com


GetSerializationPattern Method

GetSerializationPattern Method
API Documentation ► Keyoti.SearchEngine.Search ► ExpressionOperators ► GetSerializationPattern()()()()
Keyoti SearchUnit v6
Returns the serialization pattern - which dictates how strings are converted to objects in FromString.
Declaration Syntax
C# Visual Basic
public static string GetSerializationPattern()
Public Shared Function GetSerializationPattern As String
Return Value
String

Send comments on this topic to support@keyoti.com


OR Property

OR Property
API Documentation ► Keyoti.SearchEngine.Search ► ExpressionOperators ► OR
Keyoti SearchUnit v6
Define the OR logic operator
Declaration Syntax
C# Visual Basic
public string OR { get; set; }
Public Property OR As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


ToString Method

ToString Method
API Documentation ► Keyoti.SearchEngine.Search ► ExpressionOperators ► ToString()()()()
Keyoti SearchUnit v6
Overriden, as to return operators definition data (AND=<and>,OR=<or>)
Declaration Syntax
C# Visual Basic
public override string ToString()
Public Overrides Function ToString As String
Return Value
String
String representation

Send comments on this topic to support@keyoti.com


FilterCollection Class

FilterCollection Class
API Documentation ► Keyoti.SearchEngine.Search ► FilterCollection
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public class FilterCollection : List<CustomDataFilter>
Public Class FilterCollection
    Inherits List(Of CustomDataFilter)
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FilterCollection(Int32) | New
 | Add(T) | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | AddRange(IEnumerable<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | AppendLiveData(ResultItem) |
 | AsReadOnly()()()() | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | BinarySearch(T) | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | Capacity | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | Clear()()()() | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | Contains(T) | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | ConvertAll<(Of <<'(TOutput>)>>)(Converter<(Of <<'(T, TOutput>)>>)) | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | Count | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | Equals(Object) | (Inherited from Object.)
 | Exists(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | Finalize()()()() | (Inherited from Object.)
 | Find(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | FindAll(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | FindLast(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | ForEach(Action<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | GetEnumerator()()()() | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetLiveDataCollection(Configuration) |
 | GetRange(Int32, Int32) | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(T) | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | IndexOf(T, Int32) | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | Insert(Int32, T) | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | InsertRange(Int32, IEnumerable<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | IsFilteredThrough(ResultItem, CentralizedInternalEventNotifier, Configuration) |
 | IsFilterNeedingLiveData |
 | Item[([( Int32])]) | Gets a result.
 | LastIndexOf(T) | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Remove(T) | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | RemoveAll(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | RemoveAt(Int32) | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | RemoveRange(Int32, Int32) | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | Reverse()()()() | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | Sort()()()() | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | ToArray()()()() | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | ToString()()()() | (Inherited from Object.)
 | TrimExcess()()()() | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
 | TrueForAll(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' CustomDataFilter >)>)>.)
Inheritance Hierarchy
Object
 | List <(Of <(<' CustomDataFilter >)>)>
 |  | FilterCollection


FilterCollection Constructor (capacity)

FilterCollection Constructor (capacity)
API Documentation ► Keyoti.SearchEngine.Search ► FilterCollection ► FilterCollection(Int32)
Keyoti SearchUnit v6
New
Declaration Syntax
C# Visual Basic
public FilterCollection(
    int capacity
)
Public Sub New (
    capacity As Integer
)
Parameters
capacity (Int32)


AppendLiveData Method (r)

AppendLiveData Method (r)
API Documentation ► Keyoti.SearchEngine.Search ► FilterCollection ► AppendLiveData(ResultItem)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public void AppendLiveData(
    ResultItem r
)
Public Sub AppendLiveData (
    r As ResultItem
)
Parameters
r (ResultItem)


GetLiveDataCollection Method (configuration)

GetLiveDataCollection Method (configuration)
API Documentation ► Keyoti.SearchEngine.Search ► FilterCollection ► GetLiveDataCollection(Configuration)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public LiveDataCollection GetLiveDataCollection(
    Configuration configuration
)
Public Function GetLiveDataCollection (
    configuration As Configuration
) As LiveDataCollection
Parameters
configuration (Configuration)
Return Value
LiveDataCollection

Send comments on this topic to support@keyoti.com


IsFilteredThrough Method (result, _CentralizedInternalEventNotifier, configuration)

IsFilteredThrough Method (result, _CentralizedInternalEventNotifier, configuration)
API Documentation ► Keyoti.SearchEngine.Search ► FilterCollection ► IsFilteredThrough(ResultItem, CentralizedInternalEventNotifier, Configuration)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public bool IsFilteredThrough(
    ResultItem result,
    CentralizedInternalEventNotifier _CentralizedInternalEventNotifier,
    Configuration configuration
)
Public Function IsFilteredThrough (
    result As ResultItem,
    _CentralizedInternalEventNotifier As CentralizedInternalEventNotifier,
    configuration As Configuration
) As Boolean
Parameters
result (ResultItem)
_CentralizedInternalEventNotifier (CentralizedInternalEventNotifier)
configuration (Configuration)
Return Value
Boolean

Send comments on this topic to support@keyoti.com


IsFilterNeedingLiveData Property

IsFilterNeedingLiveData Property
API Documentation ► Keyoti.SearchEngine.Search ► FilterCollection ► IsFilterNeedingLiveData
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public bool IsFilterNeedingLiveData { get; }
Public ReadOnly Property IsFilterNeedingLiveData As Boolean
    Get
Property Value
Boolean

Send comments on this topic to support@keyoti.com


Item Property (index)

Item Property (index)
API Documentation ► Keyoti.SearchEngine.Search ► FilterCollection ► Item[([( Int32])])
Keyoti SearchUnit v6
Gets a result.
Declaration Syntax
C# Visual Basic
public CustomDataFilter this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As CustomDataFilter
    Get
    Set
Parameters
index (Int32)
The result number, 0 based.
Property Value
CustomDataFilter

Send comments on this topic to support@keyoti.com


FilterLoadLevel Enumeration

FilterLoadLevel Enumeration
API Documentation ► Keyoti.SearchEngine.Search ► FilterLoadLevel
Keyoti SearchUnit v6
Specifies what amount of data to load for any filtering by an AddResultItemToResults override.
Declaration Syntax
C# Visual Basic
public enum FilterLoadLevel
Public Enumeration FilterLoadLevel
Members
Member | Description
DocId | Only the document's ID - fastest.
DocIdUrlCategories | The document's ID, Url and any content/location categories, plus security group - normal.
Everything | Every document field. The document's ID, Url and any content/location categories, filetype, custom data, etc. - slower.


GroupElement Class

GroupElement Class
API Documentation ► Keyoti.SearchEngine.Search ► GroupElement
Keyoti SearchUnit v6
Implements a group for a search expression; group entity has elements (words, not-words, phrases and other nested groups) connected through a unique logic operator (AND is assumed for 'space')
Declaration Syntax
C# Visual Basic
public class GroupElement : Element
Public Class GroupElement
    Inherits Element
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GroupElement(Configuration) | Creates an empty group.
 | GroupElement(String, Configuration) | Creates a group containing the expression
 | AddMissingOperators()()()() | Add implied operators where the operator is missing between entities (eg. by default space is assumed to be AND)
 | AddMissingOperatorsAsAnd()()()() | Obsolete. Obsolete - Renamed to AddMissingOperators, please use new name.
 | ChildElements | Returns a list of Element objects, representing the sub elements of the query.
 | Configuration | The instance of the Configuration class that holds the settings to be used. (Inherited from Element.)
 | Content | Returns a string representing the content of the element, this should typically be; WordElement.Content => theWord NotWordElement.Content => -theWord GroupElement.Content => null PhraseElement.Content => thePhrase (no quotes) (Overrides Element.Content.)
 | CreateLexiconQueries(SearcherIO) | Creates the LexiconQuery for this element. (Overrides Element.CreateLexiconQueries(SearcherIO).)
 | CreateWordSubgroup(String) | Creates an Element based on the parameter.
 | elementQueryCollection | The lexicon queries used for the element (Inherited from Element.)
 | elements | The Element objects within the group.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetChildElementContents()()()() | Returns ArrayList of all child element .Content properties
 | GetHashCode()()()() | (Inherited from Object.)
 | GetIgnoredWords()()()() | Returns the stop words from the original query that were ignored. (Overrides Element.GetIgnoredWords()()()().)
 | GetMatchingDocumentIDs(SearcherIO, IntHashtable, SearchOptions, Hashtable) | Gets all document IDs matching this group. (Overrides Element.GetMatchingDocumentIDs(SearcherIO, IntHashtable, SearchOptions, Hashtable).)
 | GetType()()()() | (Inherited from Object.)
 | GroupOperator | The logic operator that all elements in the group are bound with (AND or OR).
 | IsStopWord()()()() | Whether is stop word. (Inherited from Element.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ParseExpression(String) | Loads the elements field with elements (words, phrases, groups, logic operators) in expression.
 | RemoveOperatorAmbiguities()()()() | Removes operators ambiguities (if there are both "AND" and "OR" operators in a group, re-adjust groups like: (x OR y) AND z)
 | RunLexiconQueries(SearcherIO) | Runs lexicon queries for every element in the group, allowing occurrence lookups to occur.
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | Element
 |  | GroupElement


GroupElement Constructor

GroupElement Constructor
API Documentation ► Keyoti.SearchEngine.Search ► GroupElement ► GroupElement()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GroupElement(Configuration) | Creates an empty group.
 | GroupElement(String, Configuration) | Creates a group containing the expression


GroupElement Constructor (configuration)

GroupElement Constructor (configuration)
API Documentation ► Keyoti.SearchEngine.Search ► GroupElement ► GroupElement(Configuration)
Keyoti SearchUnit v6
Creates an empty group.
Declaration Syntax
C# Visual Basic
public GroupElement(
    Configuration configuration
)
Public Sub New (
    configuration As Configuration
)
Parameters
configuration (Configuration)
The instance of the Configuration class that holds the settings to be used.


GroupElement Constructor (expression, configuration)

GroupElement Constructor (expression, configuration)
API Documentation ► Keyoti.SearchEngine.Search ► GroupElement ► GroupElement(String, Configuration)
Keyoti SearchUnit v6
Creates a group containing the expression
Declaration Syntax
C# Visual Basic
public GroupElement(
    string expression,
    Configuration configuration
)
Public Sub New (
    expression As String,
    configuration As Configuration
)
Parameters
expression (String)
The search query within the group.
configuration (Configuration)
The instance of the Configuration class that holds the settings to be used.


AddMissingOperators Method

AddMissingOperators Method
API Documentation ► Keyoti.SearchEngine.Search ► GroupElement ► AddMissingOperators()()()()
Keyoti SearchUnit v6
Add implied operators where the operator is missing between entities (eg. by default space is assumed to be AND)
Declaration Syntax
C# Visual Basic
protected virtual void AddMissingOperators()
Protected Overridable Sub AddMissingOperators
Remarks
The operator used is defined by Configuration.ImpliedLogicOperator (default is AND)


AddMissingOperatorsAsAnd Method

AddMissingOperatorsAsAnd Method
API Documentation ► Keyoti.SearchEngine.Search ► GroupElement ► AddMissingOperatorsAsAnd()()()()
Keyoti SearchUnit v6
Obsolete - Renamed to AddMissingOperators, please use new name.
Declaration Syntax
C# Visual Basic
[ObsoleteAttribute("Renamed to AddMissingOperators, please use new name.",
    true)]
protected virtual void AddMissingOperatorsAsAnd()
<ObsoleteAttribute("Renamed to AddMissingOperators, please use new name.",
    true)>
Protected Overridable Sub AddMissingOperatorsAsAnd


ChildElements Property

ChildElements Property
API Documentation ► Keyoti.SearchEngine.Search ► GroupElement ► ChildElements
Keyoti SearchUnit v6
Returns a list of Element objects, representing the sub elements of the query.
Declaration Syntax
C# Visual Basic
public ArrayList ChildElements { get; }
Public ReadOnly Property ChildElements As ArrayList
    Get
Property Value
ArrayList

Send comments on this topic to support@keyoti.com


Content Property

Content Property
API Documentation ► Keyoti.SearchEngine.Search ► GroupElement ► Content
Keyoti SearchUnit v6
Returns a string representing the content of the element, this should typically be;
WordElement.Content => theWord
NotWordElement.Content => -theWord
GroupElement.Content => null
PhraseElement.Content => thePhrase (no quotes)
Declaration Syntax
C# Visual Basic
public override string Content { get; }
Public Overrides ReadOnly Property Content As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


CreateLexiconQueries Method (dataAccess)

CreateLexiconQueries Method (dataAccess)
API Documentation ► Keyoti.SearchEngine.Search ► GroupElement ► CreateLexiconQueries(SearcherIO)
Keyoti SearchUnit v6
Creates the LexiconQuery for this element.
Declaration Syntax
C# Visual Basic
public override LexiconQueryCollection CreateLexiconQueries(
    SearcherIO dataAccess
)
Public Overrides Function CreateLexiconQueries (
    dataAccess As SearcherIO
) As LexiconQueryCollection
Parameters
dataAccess (SearcherIO)
Return Value
LexiconQueryCollection

Send comments on this topic to support@keyoti.com


CreateWordSubgroup Method (word)

CreateWordSubgroup Method (word)
API Documentation ► Keyoti.SearchEngine.Search ► GroupElement ► CreateWordSubgroup(String)
Keyoti SearchUnit v6
Creates an Element based on the parameter.
Declaration Syntax
C# Visual Basic
protected virtual Element CreateWordSubgroup(
    string word
)
Protected Overridable Function CreateWordSubgroup (
    word As String
) As Element
Parameters
word (String)
The word to create an Element for
Return Value
Element
Element object based on the word
Remarks

If the word is hyphenated it returns a GroupElement containing the word and the word in a PhraseElement without hyphens.

If the word is not hyphenated it returns a WordElement, or a WildcardWordElement if the word contains a wildcard.


elements Field

elements Field
API Documentation ► Keyoti.SearchEngine.Search ► GroupElement ► elements
Keyoti SearchUnit v6
The Element objects within the group.
Declaration Syntax
C# Visual Basic
protected ArrayList elements
Protected elements As ArrayList
Field Value
ArrayList

Send comments on this topic to support@keyoti.com


GetChildElementContents Method

GetChildElementContents Method
API Documentation ► Keyoti.SearchEngine.Search ► GroupElement ► GetChildElementContents()()()()
Keyoti SearchUnit v6
Returns ArrayList of all child element .Content properties
Declaration Syntax
C# Visual Basic
public virtual ArrayList GetChildElementContents()
Public Overridable Function GetChildElementContents As ArrayList
Return Value
ArrayList

Send comments on this topic to support@keyoti.com


GetIgnoredWords Method

GetIgnoredWords Method
API Documentation ► Keyoti.SearchEngine.Search ► GroupElement ► GetIgnoredWords()()()()
Keyoti SearchUnit v6
Returns the stop words from the original query that were ignored.
Declaration Syntax
C# Visual Basic
protected internal override StringList GetIgnoredWords()
Protected Friend Overrides Function GetIgnoredWords As StringList
Return Value
StringList

Send comments on this topic to support@keyoti.com


GetMatchingDocumentIDs Method (dataAccess, cumulativeWeights, searchOptions, objDocOc)

GetMatchingDocumentIDs Method (dataAccess, cumulativeWeights, searchOptions, objDocOc)
API Documentation ► Keyoti.SearchEngine.Search ► GroupElement ► GetMatchingDocumentIDs(SearcherIO, IntHashtable, SearchOptions, Hashtable)
Keyoti SearchUnit v6
Gets all document IDs matching this group.
Declaration Syntax
C# Visual Basic
public override IntList GetMatchingDocumentIDs(
    SearcherIO dataAccess,
    IntHashtable cumulativeWeights,
    SearchOptions searchOptions,
    Hashtable objDocOc
)
Public Overrides Function GetMatchingDocumentIDs (
    dataAccess As SearcherIO,
    cumulativeWeights As IntHashtable,
    searchOptions As SearchOptions,
    objDocOc As Hashtable
) As IntList
Parameters
dataAccess (SearcherIO)
The data-access layer with the index.
cumulativeWeights (IntHashtable)
Hashtable passed to this method containing table of weights for occurrences (key=docID, value=word's weight in that doc).
searchOptions (SearchOptions)
Search options.
objDocOc (Hashtable)
Table of documents and their occurrence maps, this method adds the OccurrenceMap for this element to the table. key = this element, value = OccurrenceMap
Return Value
IntList
IntList of int document IDs

Send comments on this topic to support@keyoti.com


GroupOperator Property

GroupOperator Property
API Documentation ► Keyoti.SearchEngine.Search ► GroupElement ► GroupOperator
Keyoti SearchUnit v6
The logic operator that all elements in the group are bound with (AND or OR).
Declaration Syntax
C# Visual Basic
public LogicOperator GroupOperator { get; set; }
Public Property GroupOperator As LogicOperator
    Get
    Set
Property Value
LogicOperator

Send comments on this topic to support@keyoti.com


ParseExpression Method (expression)

ParseExpression Method (expression)
API Documentation ► Keyoti.SearchEngine.Search ► GroupElement ► ParseExpression(String)
Keyoti SearchUnit v6
Loads the elements field with elements (words, phrases, groups, logic operators) in expression.
Declaration Syntax
C# Visual Basic
protected virtual void ParseExpression(
    string expression
)
Protected Overridable Sub ParseExpression (
    expression As String
)
Parameters
expression (String)
Remarks
Note: at this stage spaces are not yet replaced with "AND" operators, this is resolved internally later.
Examples
If expression = "one two three", then elements will be loaded with 3 WordElement objects. If expression = "one OR two three", then elements will be loaded with 3 WordElement objects and one OperatorElement (for the OR).


RemoveOperatorAmbiguities Method

RemoveOperatorAmbiguities Method
API Documentation ► Keyoti.SearchEngine.Search ► GroupElement ► RemoveOperatorAmbiguities()()()()
Keyoti SearchUnit v6
Removes operators ambiguities (if there are both "AND" and "OR" operators in a group, re-adjust groups like: (x OR y) AND z)
Declaration Syntax
C# Visual Basic
protected virtual void RemoveOperatorAmbiguities()
Protected Overridable Sub RemoveOperatorAmbiguities


RunLexiconQueries Method (dataAccess)

RunLexiconQueries Method (dataAccess)
API Documentation ► Keyoti.SearchEngine.Search ► GroupElement ► RunLexiconQueries(SearcherIO)
Keyoti SearchUnit v6
Runs lexicon queries for every element in the group, allowing occurrence lookups to occur.
Declaration Syntax
C# Visual Basic
public void RunLexiconQueries(
    SearcherIO dataAccess
)
Public Sub RunLexiconQueries (
    dataAccess As SearcherIO
)
Parameters
dataAccess (SearcherIO)


ICustomDataFilterEngine Interface

ICustomDataFilterEngine Interface
API Documentation ► Keyoti.SearchEngine.Search ► ICustomDataFilterEngine
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public interface ICustomDataFilterEngine
Public Interface ICustomDataFilterEngine
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | IsFilteredThrough(String) |


IsFilteredThrough Method (customDataEntry)

IsFilteredThrough Method (customDataEntry)
API Documentation ► Keyoti.SearchEngine.Search ► ICustomDataFilterEngine ► IsFilteredThrough(String)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
bool IsFilteredThrough(
    string customDataEntry
)
Function IsFilteredThrough (
    customDataEntry As String
) As Boolean
Parameters
customDataEntry (String)
Return Value
Boolean

Send comments on this topic to support@keyoti.com


ImpliedLogicOperator Enumeration

ImpliedLogicOperator Enumeration
API Documentation ► Keyoti.SearchEngine.Search ► ImpliedLogicOperator
Keyoti SearchUnit v6
Implied logic operator options.
Declaration Syntax
C# Visual Basic
public enum ImpliedLogicOperator
Public Enumeration ImpliedLogicOperator
Members
Member | Description
And | AND is implied between words in an expression.
Or | OR is implied between words in an expression.
Remarks
To change the implied logic operator for queries, see Configuration.


InvalidExpressionReason Enumeration

InvalidExpressionReason Enumeration
API Documentation ► Keyoti.SearchEngine.Search ► InvalidExpressionReason
Keyoti SearchUnit v6
Specifies the reason for search expression exceptions.
Declaration Syntax
C# Visual Basic
public enum InvalidExpressionReason
Public Enumeration InvalidExpressionReason
Members
Member | Description
NotWordWithOrOperator | A not word was grouped with another element using an OR operator.
UniqueNotWord | A not word appeared in a group by itself.
DifferentOperatorsWithinGroup | A group contained more than one type of operator (and ambiguities could not be resolved).
QuotesAndPhraseDisabled | The group contained a phrase element (""), however phrase matching was not enabled for the last index build.
InvalidWilcardToken | Invalid use of the Wildcard token - typically this means a "*" appeared by itself and not next to a word.


InvalidSearchExpressionException Class

InvalidSearchExpressionException Class
API Documentation ► Keyoti.SearchEngine.Search ► InvalidSearchExpressionException
Keyoti SearchUnit v6
Thrown when a search expression is invalid.
Declaration Syntax
C# Visual Basic
public class InvalidSearchExpressionException : ApplicationException
Public Class InvalidSearchExpressionException
    Inherits ApplicationException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InvalidSearchExpressionException(InvalidExpressionReason) | Creates a new exception with the specified reason
 | Data | (Inherited from Exception.)
 | Equals(Object) | (Inherited from Object.)
 | excepMessage | Gets the exception technical message.
 | Finalize()()()() | (Inherited from Object.)
 | GetBaseException()()()() | (Inherited from Exception.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | (Inherited from Exception.)
 | GetType()()()() | (Inherited from Exception.)
 | HelpLink | (Inherited from Exception.)
 | HResult | (Inherited from Exception.)
 | InnerException | (Inherited from Exception.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | Gets the message related to the exception (Overrides Exception.Message.)
 | Source | (Inherited from Exception.)
 | StackTrace | (Inherited from Exception.)
 | TargetSite | (Inherited from Exception.)
 | ToString()()()() | (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | ApplicationException
 |  |  | InvalidSearchExpressionException


InvalidSearchExpressionException Constructor (reason)

InvalidSearchExpressionException Constructor (reason)
API Documentation ► Keyoti.SearchEngine.Search ► InvalidSearchExpressionException ► InvalidSearchExpressionException(InvalidExpressionReason)
Keyoti SearchUnit v6
Creates a new exception with the specified reason
Declaration Syntax
C# Visual Basic
public InvalidSearchExpressionException(
    InvalidExpressionReason reason
)
Public Sub New (
    reason As InvalidExpressionReason
)
Parameters
reason (InvalidExpressionReason)
The reason for the search expression exception.


excepMessage Property

excepMessage Property
API Documentation ► Keyoti.SearchEngine.Search ► InvalidSearchExpressionException ► excepMessage
Keyoti SearchUnit v6
Gets the exception technical message.
Declaration Syntax
C# Visual Basic
public string excepMessage { get; }
Public ReadOnly Property excepMessage As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


Message Property

Message Property
API Documentation ► Keyoti.SearchEngine.Search ► InvalidSearchExpressionException ► Message
Keyoti SearchUnit v6
Gets the message related to the exception
Declaration Syntax
C# Visual Basic
public override string Message { get; }
Public Overrides ReadOnly Property Message As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


LiveDataCollection Class

LiveDataCollection Class
API Documentation ► Keyoti.SearchEngine.Search ► LiveDataCollection
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public class LiveDataCollection : List<LiveDataSample>
Public Class LiveDataCollection
    Inherits List(Of LiveDataSample)
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LiveDataCollection(Int32) |
 | Add(T) | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | AddRange(IEnumerable<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | AsReadOnly()()()() | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | BinarySearch(T) | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | Capacity | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | Clear()()()() | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | Contains(T) | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | ConvertAll<(Of <<'(TOutput>)>>)(Converter<(Of <<'(T, TOutput>)>>)) | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | Count | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | Equals(Object) | (Inherited from Object.)
 | Exists(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | Finalize()()()() | (Inherited from Object.)
 | Find(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | FindAll(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | FindLast(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | ForEach(Action<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | GetEnumerator()()()() | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetRange(Int32, Int32) | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(T) | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | IndexOf(T, Int32) | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | Insert(Int32, T) | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | InsertRange(Int32, IEnumerable<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | Item[([( Int32])]) | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | LastIndexOf(T) | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Remove(T) | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | RemoveAll(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | RemoveAt(Int32) | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | RemoveRange(Int32, Int32) | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | Reverse()()()() | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | Sort()()()() | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | ToArray()()()() | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | ToString()()()() | (Inherited from Object.)
 | TrimExcess()()()() | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
 | TrueForAll(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' LiveDataSample >)>)>.)
Inheritance Hierarchy
Object
 | List <(Of <(<' LiveDataSample >)>)>
 |  | LiveDataCollection


LiveDataCollection Constructor (capacity)

LiveDataCollection Constructor (capacity)
API Documentation ► Keyoti.SearchEngine.Search ► LiveDataCollection ► LiveDataCollection(Int32)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public LiveDataCollection(
    int capacity
)
Public Sub New (
    capacity As Integer
)
Parameters
capacity (Int32)


LiveDataSample Class

LiveDataSample Class
API Documentation ► Keyoti.SearchEngine.Search ► LiveDataSample
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public class LiveDataSample
Public Class LiveDataSample
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DataSample |
 | Equals(Object) | (Inherited from Object.)
 | FieldName |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
LiveDataSample

Send comments on this topic to support@keyoti.com


DataSample Property

DataSample Property
API Documentation ► Keyoti.SearchEngine.Search ► LiveDataSample ► DataSample
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public string[] DataSample { get; set; }
Public Property DataSample As String()
    Get
    Set
Property Value
array< String >[]()[][]


FieldName Property

FieldName Property
API Documentation ► Keyoti.SearchEngine.Search ► LiveDataSample ► FieldName
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public string FieldName { get; set; }
Public Property FieldName As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


LOGIC_OPERATOR Enumeration

LOGIC_OPERATOR Enumeration
API Documentation ► Keyoti.SearchEngine.Search ► LOGIC_OPERATOR
Keyoti SearchUnit v6
Logic operators
Declaration Syntax
C# Visual Basic
[ObsoleteAttribute("Please use equivalent enum, named 'LogicOperator' instead.",
    true)]
public enum LOGIC_OPERATOR
<ObsoleteAttribute("Please use equivalent enum, named 'LogicOperator' instead.",
    true)>
Public Enumeration LOGIC_OPERATOR
Members
Member | Description
AND_OPERATOR | AND logic operator
OR_OPERATOR | OR logic operator
NOT_OPERATOR | NOT logic operator


LogicOperator Enumeration

LogicOperator Enumeration
API Documentation ► Keyoti.SearchEngine.Search ► LogicOperator
Keyoti SearchUnit v6
Logic operators
Declaration Syntax
C# Visual Basic
public enum LogicOperator
Public Enumeration LogicOperator
Members
Member | Description
And | AND logic operator
Or | OR logic operator
Not | NOT logic operator


NotWordElement Class

NotWordElement Class
API Documentation ► Keyoti.SearchEngine.Search ► NotWordElement
Keyoti SearchUnit v6
Represents a 'not word', appearing in queries as -word
Declaration Syntax
C# Visual Basic
public class NotWordElement : Element
Public Class NotWordElement
    Inherits Element
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NotWordElement(String, Configuration) | Creates a new NotWordElement.
 | Configuration | The instance of the Configuration class that holds the settings to be used. (Inherited from Element.)
 | Content | Returns a string representing the content of the element, this should typically be; WordElement.Content => theWord NotWordElement.Content => -theWord GroupElement.Content => null PhraseElement.Content => thePhrase (no quotes) (Overrides Element.Content.)
 | CreateLexiconQueries(SearcherIO) | Creates the LexiconQuery for this element. (Overrides Element.CreateLexiconQueries(SearcherIO).)
 | elementQueryCollection | The lexicon queries used for the element (Inherited from Element.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetIgnoredWords()()()() | Returns the stop words from the original query that were ignored. (Overrides Element.GetIgnoredWords()()()().)
 | GetMatchingDocumentIDs(SearcherIO, IntHashtable, SearchOptions, Hashtable) | Gets all document IDs matching this element (not containing the notword). (Overrides Element.GetMatchingDocumentIDs(SearcherIO, IntHashtable, SearchOptions, Hashtable).)
 | GetType()()()() | (Inherited from Object.)
 | IsStopWord()()()() | Whether is stop word, only Word elements can be stop words. (Overrides Element.IsStopWord()()()().)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Examples
Copy image Copy
query = "this -notthis";
"this" will be a WordELement. "notthis" will be a NotWordElement.
Inheritance Hierarchy
Object
 | Element
 |  | NotWordElement


NotWordElement Constructor (notword, configuration)

NotWordElement Constructor (notword, configuration)
API Documentation ► Keyoti.SearchEngine.Search ► NotWordElement ► NotWordElement(String, Configuration)
Keyoti SearchUnit v6
Creates a new NotWordElement.
Declaration Syntax
C# Visual Basic
public NotWordElement(
    string notword,
    Configuration configuration
)
Public Sub New (
    notword As String,
    configuration As Configuration
)
Parameters
notword (String)
The word that is NOTTED, without the minus operator.
configuration (Configuration)
The instance of the Configuration class that holds the settings to be used.


Content Property

Content Property
API Documentation ► Keyoti.SearchEngine.Search ► NotWordElement ► Content
Keyoti SearchUnit v6
Returns a string representing the content of the element, this should typically be;
WordElement.Content => theWord
NotWordElement.Content => -theWord
GroupElement.Content => null
PhraseElement.Content => thePhrase (no quotes)
Declaration Syntax
C# Visual Basic
public override string Content { get; }
Public Overrides ReadOnly Property Content As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


CreateLexiconQueries Method (dataAccess)

CreateLexiconQueries Method (dataAccess)
API Documentation ► Keyoti.SearchEngine.Search ► NotWordElement ► CreateLexiconQueries(SearcherIO)
Keyoti SearchUnit v6
Creates the LexiconQuery for this element.
Declaration Syntax
C# Visual Basic
public override LexiconQueryCollection CreateLexiconQueries(
    SearcherIO dataAccess
)
Public Overrides Function CreateLexiconQueries (
    dataAccess As SearcherIO
) As LexiconQueryCollection
Parameters
dataAccess (SearcherIO)
Return Value
LexiconQueryCollection

Send comments on this topic to support@keyoti.com


GetIgnoredWords Method

GetIgnoredWords Method
API Documentation ► Keyoti.SearchEngine.Search ► NotWordElement ► GetIgnoredWords()()()()
Keyoti SearchUnit v6
Returns the stop words from the original query that were ignored.
Declaration Syntax
C# Visual Basic
protected internal override StringList GetIgnoredWords()
Protected Friend Overrides Function GetIgnoredWords As StringList
Return Value
StringList

Send comments on this topic to support@keyoti.com


GetMatchingDocumentIDs Method (dataAccess, cumulativeWeights, searchOptions, objDocOc)

GetMatchingDocumentIDs Method (dataAccess, cumulativeWeights, searchOptions, objDocOc)
API Documentation ► Keyoti.SearchEngine.Search ► NotWordElement ► GetMatchingDocumentIDs(SearcherIO, IntHashtable, SearchOptions, Hashtable)
Keyoti SearchUnit v6
Gets all document IDs matching this element (not containing the notword).
Declaration Syntax
C# Visual Basic
public override IntList GetMatchingDocumentIDs(
    SearcherIO dataAccess,
    IntHashtable cumulativeWeights,
    SearchOptions searchOptions,
    Hashtable objDocOc
)
Public Overrides Function GetMatchingDocumentIDs (
    dataAccess As SearcherIO,
    cumulativeWeights As IntHashtable,
    searchOptions As SearchOptions,
    objDocOc As Hashtable
) As IntList
Parameters
dataAccess (SearcherIO)
The data-access layer with the index.
cumulativeWeights (IntHashtable)
Hashtable passed to this method containing table of weights for occurrences (key=docID, value=word's weight in that doc).
searchOptions (SearchOptions)
Search options.
objDocOc (Hashtable)
Table of documents and their occurrence maps, this method adds the OccurrenceMap for this element to the table. key = this element, value = OccurrenceMap
Return Value
IntList
IntList of int document IDs

Send comments on this topic to support@keyoti.com


IsStopWord Method

IsStopWord Method
API Documentation ► Keyoti.SearchEngine.Search ► NotWordElement ► IsStopWord()()()()
Keyoti SearchUnit v6
Whether is stop word, only Word elements can be stop words.
Declaration Syntax
C# Visual Basic
protected internal override bool IsStopWord()
Protected Friend Overrides Function IsStopWord As Boolean
Return Value
Boolean

Send comments on this topic to support@keyoti.com


OperatorElement Class

OperatorElement Class
API Documentation ► Keyoti.SearchEngine.Search ► OperatorElement
Keyoti SearchUnit v6
Represents an operator element in a query.
Declaration Syntax
C# Visual Basic
public class OperatorElement : Element
Public Class OperatorElement
    Inherits Element
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OperatorElement(LogicOperator, Configuration) | Creates a new operator element based on logicOperator.
 | Configuration | The instance of the Configuration class that holds the settings to be used. (Inherited from Element.)
 | Content | Returns a string representing the content of the element, this should typically be; WordElement.Content => theWord NotWordElement.Content => -theWord GroupElement.Content => null PhraseElement.Content => thePhrase (no quotes) (Overrides Element.Content.)
 | CreateLexiconQueries(SearcherIO) | Creates the LexiconQuery for this element. (Overrides Element.CreateLexiconQueries(SearcherIO).)
 | elementQueryCollection | The lexicon queries used for the element (Inherited from Element.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetIgnoredWords()()()() | Returns the stop words from the original query that were ignored. (Inherited from Element.)
 | GetMatchingDocumentIDs(SearcherIO, IntHashtable, SearchOptions, Hashtable) | Unused - imposed by Element's inheritance (Overrides Element.GetMatchingDocumentIDs(SearcherIO, IntHashtable, SearchOptions, Hashtable).)
 | GetType()()()() | (Inherited from Object.)
 | IsStopWord()()()() | Whether is stop word. (Inherited from Element.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | Element
 |  | OperatorElement


OperatorElement Constructor (logicOperator, configuration)

OperatorElement Constructor (logicOperator, configuration)
API Documentation ► Keyoti.SearchEngine.Search ► OperatorElement ► OperatorElement(LogicOperator, Configuration)
Keyoti SearchUnit v6
Creates a new operator element based on logicOperator.
Declaration Syntax
C# Visual Basic
public OperatorElement(
    LogicOperator logicOperator,
    Configuration configuration
)
Public Sub New (
    logicOperator As LogicOperator,
    configuration As Configuration
)
Parameters
logicOperator (LogicOperator)
The logic operator, either AND or OR
configuration (Configuration)
The instance of the Configuration class that holds the settings to be used.


Content Property

Content Property
API Documentation ► Keyoti.SearchEngine.Search ► OperatorElement ► Content
Keyoti SearchUnit v6
Returns a string representing the content of the element, this should typically be;
WordElement.Content => theWord
NotWordElement.Content => -theWord
GroupElement.Content => null
PhraseElement.Content => thePhrase (no quotes)
Declaration Syntax
C# Visual Basic
public override string Content { get; }
Public Overrides ReadOnly Property Content As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


CreateLexiconQueries Method (dataAccess)

CreateLexiconQueries Method (dataAccess)
API Documentation ► Keyoti.SearchEngine.Search ► OperatorElement ► CreateLexiconQueries(SearcherIO)
Keyoti SearchUnit v6
Creates the LexiconQuery for this element.
Declaration Syntax
C# Visual Basic
public override LexiconQueryCollection CreateLexiconQueries(
    SearcherIO dataAccess
)
Public Overrides Function CreateLexiconQueries (
    dataAccess As SearcherIO
) As LexiconQueryCollection
Parameters
dataAccess (SearcherIO)
Return Value
LexiconQueryCollection

Send comments on this topic to support@keyoti.com


GetMatchingDocumentIDs Method (dataAccess, cumulativeWeights, searchOptions, objDocOc)

GetMatchingDocumentIDs Method (dataAccess, cumulativeWeights, searchOptions, objDocOc)
API Documentation ► Keyoti.SearchEngine.Search ► OperatorElement ► GetMatchingDocumentIDs(SearcherIO, IntHashtable, SearchOptions, Hashtable)
Keyoti SearchUnit v6
Unused - imposed by Element's inheritance
Declaration Syntax
C# Visual Basic
public override IntList GetMatchingDocumentIDs(
    SearcherIO dataAccess,
    IntHashtable cumulativeWeights,
    SearchOptions searchOptions,
    Hashtable objDocOc
)
Public Overrides Function GetMatchingDocumentIDs (
    dataAccess As SearcherIO,
    cumulativeWeights As IntHashtable,
    searchOptions As SearchOptions,
    objDocOc As Hashtable
) As IntList
Parameters
dataAccess (SearcherIO)
cumulativeWeights (IntHashtable)
searchOptions (SearchOptions)
objDocOc (Hashtable)
Return Value
IntList
null/nothing


PhraseElement Class

PhraseElement Class
API Documentation ► Keyoti.SearchEngine.Search ► PhraseElement
Keyoti SearchUnit v6
Represents a phrase in the query (eg. "this phrase").
Declaration Syntax
C# Visual Basic
public class PhraseElement : Element
Public Class PhraseElement
    Inherits Element
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PhraseElement(String, Configuration) | Creates a phrase element based on phrase
 | Configuration | The instance of the Configuration class that holds the settings to be used. (Inherited from Element.)
 | Content | Returns a string representing the content of the element, this should typically be; WordElement.Content => theWord NotWordElement.Content => -theWord GroupElement.Content => null PhraseElement.Content => thePhrase (no quotes) (Overrides Element.Content.)
 | CreateLexiconQueries(SearcherIO) | Creates the LexiconQuery for this element. (Overrides Element.CreateLexiconQueries(SearcherIO).)
 | elementQueryCollection | The lexicon queries used for the element (Inherited from Element.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetIgnoredWords()()()() | Returns the stop words from the original query that were ignored. (Overrides Element.GetIgnoredWords()()()().)
 | GetMatchingDocumentIDs(SearcherIO, IntHashtable, SearchOptions, Hashtable) | Gets all document IDs matching this phrase. (Overrides Element.GetMatchingDocumentIDs(SearcherIO, IntHashtable, SearchOptions, Hashtable).)
 | GetType()()()() | (Inherited from Object.)
 | IsStopWord()()()() | Whether is stop word. (Inherited from Element.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | Element
 |  | PhraseElement


PhraseElement Constructor (phrase, configuration)

PhraseElement Constructor (phrase, configuration)
API Documentation ► Keyoti.SearchEngine.Search ► PhraseElement ► PhraseElement(String, Configuration)
Keyoti SearchUnit v6
Creates a phrase element based on phrase
Declaration Syntax
C# Visual Basic
public PhraseElement(
    string phrase,
    Configuration configuration
)
Public Sub New (
    phrase As String,
    configuration As Configuration
)
Parameters
phrase (String)
The phrase, WITHOUT quotes.
configuration (Configuration)
The instance of the Configuration class that holds the settings to be used.


Content Property

Content Property
API Documentation ► Keyoti.SearchEngine.Search ► PhraseElement ► Content
Keyoti SearchUnit v6
Returns a string representing the content of the element, this should typically be;
WordElement.Content => theWord
NotWordElement.Content => -theWord
GroupElement.Content => null
PhraseElement.Content => thePhrase (no quotes)
Declaration Syntax
C# Visual Basic
public override string Content { get; }
Public Overrides ReadOnly Property Content As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


CreateLexiconQueries Method (dataAccess)

CreateLexiconQueries Method (dataAccess)
API Documentation ► Keyoti.SearchEngine.Search ► PhraseElement ► CreateLexiconQueries(SearcherIO)
Keyoti SearchUnit v6
Creates the LexiconQuery for this element.
Declaration Syntax
C# Visual Basic
public override LexiconQueryCollection CreateLexiconQueries(
    SearcherIO dataAccess
)
Public Overrides Function CreateLexiconQueries (
    dataAccess As SearcherIO
) As LexiconQueryCollection
Parameters
dataAccess (SearcherIO)
Return Value
LexiconQueryCollection

Send comments on this topic to support@keyoti.com


GetIgnoredWords Method

GetIgnoredWords Method
API Documentation ► Keyoti.SearchEngine.Search ► PhraseElement ► GetIgnoredWords()()()()
Keyoti SearchUnit v6
Returns the stop words from the original query that were ignored.
Declaration Syntax
C# Visual Basic
protected internal override StringList GetIgnoredWords()
Protected Friend Overrides Function GetIgnoredWords As StringList
Return Value
StringList

Send comments on this topic to support@keyoti.com


GetMatchingDocumentIDs Method (dataAccess, cumulativeWeights, searchOptions, objDocOc)

GetMatchingDocumentIDs Method (dataAccess, cumulativeWeights, searchOptions, objDocOc)
API Documentation ► Keyoti.SearchEngine.Search ► PhraseElement ► GetMatchingDocumentIDs(SearcherIO, IntHashtable, SearchOptions, Hashtable)
Keyoti SearchUnit v6
Gets all document IDs matching this phrase.
Declaration Syntax
C# Visual Basic
public override IntList GetMatchingDocumentIDs(
    SearcherIO dataAccess,
    IntHashtable cumulativeWeights,
    SearchOptions searchOptions,
    Hashtable objDocOc
)
Public Overrides Function GetMatchingDocumentIDs (
    dataAccess As SearcherIO,
    cumulativeWeights As IntHashtable,
    searchOptions As SearchOptions,
    objDocOc As Hashtable
) As IntList
Parameters
dataAccess (SearcherIO)
The data-access layer with the index.
cumulativeWeights (IntHashtable)
Hashtable passed to this method containing table of weights for occurrences (key=docID, value=word's weight in that doc).
searchOptions (SearchOptions)
Search options.
objDocOc (Hashtable)
Table of documents and their occurrence maps, this method adds the OccurrenceMap for this element to the table. key = this element, value = OccurrenceMap
Return Value
IntList
IntList of int document IDs

Send comments on this topic to support@keyoti.com


QueryExpressionParser Class

QueryExpressionParser Class
API Documentation ► Keyoti.SearchEngine.Search ► QueryExpressionParser
Keyoti SearchUnit v6
Parses raw query strings entered by users.
Declaration Syntax
C# Visual Basic
public class QueryExpressionParser
Public Class QueryExpressionParser
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | QueryExpressionParser(String, Configuration) | Creates a new instance.
 | Configuration | Gets the instance of the Configuration class that holds the settings to be used.
 | CreateExpressionGroup()()()() | Creates a GroupElement based on the query set in the .ctor.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PreparseExpression()()()() | Cleans up the query expression from the user.
 | queryString | The query string being worked with.
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
QueryExpressionParser

Send comments on this topic to support@keyoti.com


QueryExpressionParser Constructor (queryString, configuration)

QueryExpressionParser Constructor (queryString, configuration)
API Documentation ► Keyoti.SearchEngine.Search ► QueryExpressionParser ► QueryExpressionParser(String, Configuration)
Keyoti SearchUnit v6
Creates a new instance.
Declaration Syntax
C# Visual Basic
public QueryExpressionParser(
    string queryString,
    Configuration configuration
)
Public Sub New (
    queryString As String,
    configuration As Configuration
)
Parameters
queryString (String)
The raw query expression.
configuration (Configuration)
The instance of the Configuration class that holds the settings to be used.


Configuration Property

Configuration Property
API Documentation ► Keyoti.SearchEngine.Search ► QueryExpressionParser ► Configuration
Keyoti SearchUnit v6
Gets the instance of the Configuration class that holds the settings to be used.
Declaration Syntax
C# Visual Basic
public Configuration Configuration { get; }
Public ReadOnly Property Configuration As Configuration
    Get
Property Value
Configuration

Send comments on this topic to support@keyoti.com


CreateExpressionGroup Method

CreateExpressionGroup Method
API Documentation ► Keyoti.SearchEngine.Search ► QueryExpressionParser ► CreateExpressionGroup()()()()
Keyoti SearchUnit v6
Creates a GroupElement based on the query set in the .ctor.
Declaration Syntax
C# Visual Basic
public virtual GroupElement CreateExpressionGroup()
Public Overridable Function CreateExpressionGroup As GroupElement
Return Value
GroupElement
Remarks
If PreparseExpression hasn't been called, this will call it automatically.


PreparseExpression Method

PreparseExpression Method
API Documentation ► Keyoti.SearchEngine.Search ► QueryExpressionParser ► PreparseExpression()()()()
Keyoti SearchUnit v6
Cleans up the query expression from the user.
Declaration Syntax
C# Visual Basic
public virtual void PreparseExpression()
Public Overridable Sub PreparseExpression
Remarks
Removes duplicate spaces, beginning/end spaces, adds missing close brackets at the end of the query. This method is called automatically if not called before CreateExpressionGroup.


queryString Field

queryString Field
API Documentation ► Keyoti.SearchEngine.Search ► QueryExpressionParser ► queryString
Keyoti SearchUnit v6
The query string being worked with.
Declaration Syntax
C# Visual Basic
protected string queryString
Protected queryString As String
Field Value
String

Send comments on this topic to support@keyoti.com


Range(T) Class

Range<(Of <(<'T>)>)> Class
API Documentation ► Keyoti.SearchEngine.Search ► Range<(Of <(<'T>)>)>
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public class Range<T>
where T : Object, IComparable<T>

Public Class Range(Of T As {Object, IComparable(Of T)})
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "T:Keyoti.SearchEngine.Search.Range`1"]

Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Range<(Of <(<'T>)>)>()()()() |
 | ContainsRange(Range<(Of <<'(T>)>>)) | Determines if another range is inside the bounds of this range
 | ContainsValue(T) | Determines if the provided value is inside the range
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IsInsideRange(Range<(Of <<'(T>)>>)) | Determines if this Range is inside the bounds of another range
 | IsValid()()()() | Determines if the range is valid
 | Maximum | Maximum value of the range
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Minimum | Minimum value of the range
 | ToString()()()() | Presents the Range in readable format (Overrides Object.ToString()()()().)
Inheritance Hierarchy
Object
Range<(Of <(<'T>)>)>

Send comments on this topic to support@keyoti.com


Range(T) Constructor

Range<(Of <(<'T>)>)> Constructor
API Documentation ► Keyoti.SearchEngine.Search ► Range<(Of <(<'T>)>)> ► Range<(Of <(<'T>)>)>()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public Range()
Public Sub New

Send comments on this topic to support@keyoti.com


ContainsRange Method (Range)

ContainsRange Method (Range)
API Documentation ► Keyoti.SearchEngine.Search ► Range<(Of <(<'T>)>)> ► ContainsRange(Range<(Of <<'(T>)>>))
Keyoti SearchUnit v6
Determines if another range is inside the bounds of this range
Declaration Syntax
C# Visual Basic
public bool ContainsRange(
    Range<T> Range
)
Public Function ContainsRange (
    Range As Range(Of T)
) As Boolean
Parameters
Range (Range <(Of <(<' T >)>)>)
The child range to test
Return Value
Boolean
True if range is inside, else false

Send comments on this topic to support@keyoti.com


ContainsValue Method (value)

ContainsValue Method (value)
API Documentation ► Keyoti.SearchEngine.Search ► Range<(Of <(<'T>)>)> ► ContainsValue(T)
Keyoti SearchUnit v6
Determines if the provided value is inside the range
Declaration Syntax
C# Visual Basic
public bool ContainsValue(
    T value
)
Public Function ContainsValue (
    value As T
) As Boolean
Parameters
value (T)
The value to test
Return Value
Boolean
True if the value is inside Range, else false


IsInsideRange Method (Range)

IsInsideRange Method (Range)
API Documentation ► Keyoti.SearchEngine.Search ► Range<(Of <(<'T>)>)> ► IsInsideRange(Range<(Of <<'(T>)>>))
Keyoti SearchUnit v6
Determines if this Range is inside the bounds of another range
Declaration Syntax
C# Visual Basic
public bool IsInsideRange(
    Range<T> Range
)
Public Function IsInsideRange (
    Range As Range(Of T)
) As Boolean
Parameters
Range (Range <(Of <(<' T >)>)>)
The parent range to test on
Return Value
Boolean
True if range is inclusive, else false

Send comments on this topic to support@keyoti.com


IsValid Method

IsValid Method
API Documentation ► Keyoti.SearchEngine.Search ► Range<(Of <(<'T>)>)> ► IsValid()()()()
Keyoti SearchUnit v6
Determines if the range is valid
Declaration Syntax
C# Visual Basic
public bool IsValid()
Public Function IsValid As Boolean
Return Value
Boolean
True if range is valid, else false

Send comments on this topic to support@keyoti.com


Maximum Property

Maximum Property
API Documentation ► Keyoti.SearchEngine.Search ► Range<(Of <(<'T>)>)> ► Maximum
Keyoti SearchUnit v6
Maximum value of the range
Declaration Syntax
C# Visual Basic
public T Maximum { get; set; }
Public Property Maximum As T
    Get
    Set
Property Value
T

Send comments on this topic to support@keyoti.com


Minimum Property

Minimum Property
API Documentation ► Keyoti.SearchEngine.Search ► Range<(Of <(<'T>)>)> ► Minimum
Keyoti SearchUnit v6
Minimum value of the range
Declaration Syntax
C# Visual Basic
public T Minimum { get; set; }
Public Property Minimum As T
    Get
    Set
Property Value
T

Send comments on this topic to support@keyoti.com


ToString Method

ToString Method
API Documentation ► Keyoti.SearchEngine.Search ► Range<(Of <(<'T>)>)> ► ToString()()()()
Keyoti SearchUnit v6
Presents the Range in readable format
Declaration Syntax
C# Visual Basic
public override string ToString()
Public Overrides Function ToString As String
Return Value
String
String representation of the Range

Send comments on this topic to support@keyoti.com


REASON Enumeration

REASON Enumeration
API Documentation ► Keyoti.SearchEngine.Search ► REASON
Keyoti SearchUnit v6
Specifies the reason for search expression exceptions.
Declaration Syntax
C# Visual Basic
[ObsoleteAttribute("Please use equivalent 'InvalidExpressionReason'.",
    true)]
public enum REASON
<ObsoleteAttribute("Please use equivalent 'InvalidExpressionReason'.",
    true)>
Public Enumeration REASON
Members
Member | Description
NOT_WORD_OR_OPER | A not word was grouped with another element using an OR operator.
UNIQUE_NOT_WORD | A not word appeared in a group by itself.
DIFFERENT_OPERATORS_WITHIN_GROUP | A group contained more than one type of operator (and ambiguities could not be resolved).
QUOTES_AND_PHRASE_DISABLED | The group contained a phrase element (""), however phrase matching was not enabled for the last index build.


ResultItem Class

ResultItem Class
API Documentation ► Keyoti.SearchEngine.Search ► ResultItem
Keyoti SearchUnit v6
Represents a result item from a search.
Declaration Syntax
C# Visual Basic
public class ResultItem
Public Class ResultItem
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ResultItem(String, String, String, String, String, Int32, String, SecurityGroupRecordList) | Creates a new result item.
 | Content | Searched contents for this result
 | CustomData | Any custom data that should be stored for the document.
 | CustomDataDictionary | List holding names and values of custom data, when custom data is formatted as a URL query string (eg. name1=value1&name2=value2)
 | DocumentRecord | The underlying DocumentRecord that this result is for.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetContentString(DocumentRecord) | Returns a string representing the content categories that docRec belongs to.
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityGroupsString(DocumentRecord) | Returns a string representing the content categories that docRec belongs to.
 | GetType()()()() | (Inherited from Object.)
 | KeywordHitMap | Map of keywords and number of hits within this document of each keyword.
 | Location | Searched location for this result
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SecurityGroups | Searched security groups for this result
 | Summary | A summary for the result.
 | Title | The title of the result item.
 | ToString()()()() | (Inherited from Object.)
 | UriString | The result document's URL, as a string.
 | UriStringAsStored | The URL of the document as it is stored in the data-access.
 | Weight | The relative weight of this result.
Inheritance Hierarchy
Object
ResultItem

Send comments on this topic to support@keyoti.com


ResultItem Constructor (uriString, documentUriString, content, location, summary, weight, title, securityGroups)

ResultItem Constructor (uriString, documentUriString, content, location, summary, weight, title, securityGroups)
API Documentation ► Keyoti.SearchEngine.Search ► ResultItem ► ResultItem(String, String, String, String, String, Int32, String, SecurityGroupRecordList)
Keyoti SearchUnit v6
Creates a new result item.
Declaration Syntax
C# Visual Basic
public ResultItem(
    string uriString,
    string documentUriString,
    string content,
    string location,
    string summary,
    int weight,
    string title,
    SecurityGroupRecordList securityGroups
)
Public Sub New (
    uriString As String,
    documentUriString As String,
    content As String,
    location As String,
    summary As String,
    weight As Integer,
    title As String,
    securityGroups As SecurityGroupRecordList
)
Parameters
uriString (String)
The Uri related to the result.
documentUriString (String)
The Uri of the document as stored in the data-access
content (String)
String holding the content categories
location (String)
String holding the location category
summary (String)
Summary of the result
weight (Int32)
Result weight
title (String)
Result title
securityGroups (SecurityGroupRecordList)
Security groups identified with the result item


Content Property

Content Property
API Documentation ► Keyoti.SearchEngine.Search ► ResultItem ► Content
Keyoti SearchUnit v6
Searched contents for this result
Declaration Syntax
C# Visual Basic
public virtual string Content { get; set; }
Public Overridable Property Content As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


CustomData Property

CustomData Property
API Documentation ► Keyoti.SearchEngine.Search ► ResultItem ► CustomData
Keyoti SearchUnit v6
Any custom data that should be stored for the document.
Declaration Syntax
C# Visual Basic
public virtual string CustomData { get; set; }
Public Overridable Property CustomData As String
    Get
    Set
Property Value
String
Remarks
This may be useful for users of the SDK who need to store extra data about a document, such as meta-data, dates, ownership etc. Through this, additional data can be presented to the user or results can be filtered or sorted, etc (see help for more info). If this is set null, an empty string is stored.


CustomDataDictionary Property

CustomDataDictionary Property
API Documentation ► Keyoti.SearchEngine.Search ► ResultItem ► CustomDataDictionary
Keyoti SearchUnit v6
List holding names and values of custom data, when custom data is formatted as a URL query string (eg. name1=value1&name2=value2)
Declaration Syntax
C# Visual Basic
public virtual NameValueList CustomDataDictionary { get; }
Public Overridable ReadOnly Property CustomDataDictionary As NameValueList
    Get
Property Value
NameValueList

Send comments on this topic to support@keyoti.com


DocumentRecord Property

DocumentRecord Property
API Documentation ► Keyoti.SearchEngine.Search ► ResultItem ► DocumentRecord
Keyoti SearchUnit v6
The underlying DocumentRecord that this result is for.
Declaration Syntax
C# Visual Basic
public virtual DocumentRecord DocumentRecord { get; }
Public Overridable ReadOnly Property DocumentRecord As DocumentRecord
    Get
Property Value
DocumentRecord

Send comments on this topic to support@keyoti.com


GetContentString Method (docRec)

GetContentString Method (docRec)
API Documentation ► Keyoti.SearchEngine.Search ► ResultItem ► GetContentString(DocumentRecord)
Keyoti SearchUnit v6
Returns a string representing the content categories that docRec belongs to.
Declaration Syntax
C# Visual Basic
public static string GetContentString(
    DocumentRecord docRec
)
Public Shared Function GetContentString (
    docRec As DocumentRecord
) As String
Parameters
docRec (DocumentRecord)
Return Value
String

Send comments on this topic to support@keyoti.com


GetSecurityGroupsString Method (docRec)

GetSecurityGroupsString Method (docRec)
API Documentation ► Keyoti.SearchEngine.Search ► ResultItem ► GetSecurityGroupsString(DocumentRecord)
Keyoti SearchUnit v6
Returns a string representing the content categories that docRec belongs to.
Declaration Syntax
C# Visual Basic
public static string GetSecurityGroupsString(
    DocumentRecord docRec
)
Public Shared Function GetSecurityGroupsString (
    docRec As DocumentRecord
) As String
Parameters
docRec (DocumentRecord)
Return Value
String

Send comments on this topic to support@keyoti.com


KeywordHitMap Property

KeywordHitMap Property
API Documentation ► Keyoti.SearchEngine.Search ► ResultItem ► KeywordHitMap
Keyoti SearchUnit v6
Map of keywords and number of hits within this document of each keyword.
Declaration Syntax
C# Visual Basic
public virtual KeywordHitMapDictionary KeywordHitMap { get; }
Public Overridable ReadOnly Property KeywordHitMap As KeywordHitMapDictionary
    Get
Property Value
KeywordHitMapDictionary

Send comments on this topic to support@keyoti.com


Location Property

Location Property
API Documentation ► Keyoti.SearchEngine.Search ► ResultItem ► Location
Keyoti SearchUnit v6
Searched location for this result
Declaration Syntax
C# Visual Basic
public virtual string Location { get; set; }
Public Overridable Property Location As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


SecurityGroups Property

SecurityGroups Property
API Documentation ► Keyoti.SearchEngine.Search ► ResultItem ► SecurityGroups
Keyoti SearchUnit v6
Searched security groups for this result
Declaration Syntax
C# Visual Basic
public virtual SecurityGroupRecordList SecurityGroups { get; set; }
Public Overridable Property SecurityGroups As SecurityGroupRecordList
    Get
    Set
Property Value
SecurityGroupRecordList

Send comments on this topic to support@keyoti.com


Summary Property

Summary Property
API Documentation ► Keyoti.SearchEngine.Search ► ResultItem ► Summary
Keyoti SearchUnit v6
A summary for the result.
Declaration Syntax
C# Visual Basic
public virtual string Summary { get; set; }
Public Overridable Property Summary As String
    Get
    Set
Property Value
String
Remarks
When phrase matching is enabled this is an extract of the document text containing the original query terms, otherwise this is text from the start of the document.


Title Property

Title Property
API Documentation ► Keyoti.SearchEngine.Search ► ResultItem ► Title
Keyoti SearchUnit v6
The title of the result item.
Declaration Syntax
C# Visual Basic
public virtual string Title { get; set; }
Public Overridable Property Title As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


UriString Property

UriString Property
API Documentation ► Keyoti.SearchEngine.Search ► ResultItem ► UriString
Keyoti SearchUnit v6
The result document's URL, as a string.
Declaration Syntax
C# Visual Basic
public virtual string UriString { get; set; }
Public Overridable Property UriString As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


UriStringAsStored Property

UriStringAsStored Property
API Documentation ► Keyoti.SearchEngine.Search ► ResultItem ► UriStringAsStored
Keyoti SearchUnit v6
The URL of the document as it is stored in the data-access.
Declaration Syntax
C# Visual Basic
public virtual string UriStringAsStored { get; set; }
Public Overridable Property UriStringAsStored As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


Weight Property

Weight Property
API Documentation ► Keyoti.SearchEngine.Search ► ResultItem ► Weight
Keyoti SearchUnit v6
The relative weight of this result.
Declaration Syntax
C# Visual Basic
public virtual int Weight { get; set; }
Public Overridable Property Weight As Integer
    Get
    Set
Property Value
Int32

Send comments on this topic to support@keyoti.com


ResultSummaryType Enumeration

ResultSummaryType Enumeration
API Documentation ► Keyoti.SearchEngine.Search ► ResultSummaryType
Keyoti SearchUnit v6
Describes types of result summaries.
Declaration Syntax
C# Visual Basic
public enum ResultSummaryType
Public Enumeration ResultSummaryType
Members
Member | Description
StaticMetaDescription | Where possible, takes the summary from the HTML meta tag - otherwise StaticBodyStart is used.
StaticBodyStart | Takes the summary from as the first X number of words in the document.
Dynamic | Generates the summary based on the keywords searched for.


SearchAgent Class

SearchAgent Class
API Documentation ► Keyoti.SearchEngine.Search ► SearchAgent
Keyoti SearchUnit v6
Performs searches with user defined queries.
Declaration Syntax
C# Visual Basic
public class SearchAgent
Public Class SearchAgent
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SearchAgent(String, Configuration) | Creates a new instance with no query specified.
 | SearchAgent(String, String, Configuration) | Obsolete. Creates a new instance.
 | AddResultItemToResults(ResultItem, ResultItemList) | Add a ResultItem object to the collection
 | AllDocumentReturnQuery | The query that the user can use to retrieve a list of all documents
 | Configuration | Configuration of the index
 | CreateQueryExpressionParser(String) | Creates an instance of QueryExpressionParser.
 | CreateWholeExpressionGroup(String) | Creates a GroupElement representing the search expression.
 | DataAccess | The data-access layer.
 | Equals(Object) | (Inherited from Object.)
 | FilterLoadLevel | Specifies what amount of data to load for any filtering by an AddResultItemToResults override.
 | Finalize()()()() | (Inherited from Object.)
 | GetContentCategoryRecords()()()() | Gets all content category records from the index.
 | GetDocumentText(String) | Returns a document's text.
 | GetHashCode()()()() | (Inherited from Object.)
 | GetLocationCategoryRecords()()()() | Gets all location category records from the index.
 | GetNumberOfResults(ArrayList) | Returns number of results for a each query in queryExpressions collection
 | GetSearchQuerySuggestions(String, Int32) | Returns a list of words that may be suggestions for segment using the search lexicon only.
 | GetType()()()() | (Inherited from Object.)
 | LicenseKey | The license key.
 | LookUpWordInLexicon(String, Boolean) | Returns whether word is in the lexicon
 | MemberwiseClone()()()() | (Inherited from Object.)
 | QueryGroup | A GroupElement based on the entire search query.
 | QueryString | Search query
 | RegisterDataSetBasedSource(Int32, DataSetBasedSource) | Registers a DataSetBasedSource for use in result URL mapping.
 | Search(String, Int32, Int32) | Runs the search and returns results between lowRange (inclusive and 1 based) and highRange (inclusive and 1 based), ensure the QueryString property is set before calling this.
 | Search(String, SearchOptions, Int32, Int32) | Runs the search and returns results between lowRange (inclusive) and highRange (inclusive), ensure the QueryString property is set before calling this.
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
SearchAgent

Send comments on this topic to support@keyoti.com


SearchAgent Constructor

SearchAgent Constructor
API Documentation ► Keyoti.SearchEngine.Search ► SearchAgent ► SearchAgent()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | SearchAgent(String, Configuration) | Creates a new instance with no query specified.
 | SearchAgent(String, String, Configuration) | Obsolete. Creates a new instance.


SearchAgent Constructor (licenseKey, configuration)

SearchAgent Constructor (licenseKey, configuration)
API Documentation ► Keyoti.SearchEngine.Search ► SearchAgent ► SearchAgent(String, Configuration)
Keyoti SearchUnit v6
Creates a new instance with no query specified.
Declaration Syntax
C# Visual Basic
public SearchAgent(
    string licenseKey,
    Configuration configuration
)
Public Sub New (
    licenseKey As String,
    configuration As Configuration
)
Parameters
licenseKey (String)
A deployment license key, either generated through the Keyoti web-site or provided for trial purposes.
configuration (Configuration)
The instance of the Configuration class that holds the settings to be used.


SearchAgent Constructor (queryString, licenseKey, configuration)

SearchAgent Constructor (queryString, licenseKey, configuration)
API Documentation ► Keyoti.SearchEngine.Search ► SearchAgent ► SearchAgent(String, String, Configuration)
Keyoti SearchUnit v6
Creates a new instance.
Declaration Syntax
C# Visual Basic
[ObsoleteAttribute("Please use alternative constructor and pass query expression as parameter in Search method",
    true)]
public SearchAgent(
    string queryString,
    string licenseKey,
    Configuration configuration
)
<ObsoleteAttribute("Please use alternative constructor and pass query expression as parameter in Search method",
    true)>
Public Sub New (
    queryString As String,
    licenseKey As String,
    configuration As Configuration
)
Parameters
queryString (String)
Expression defining the search to be performed
licenseKey (String)
A deployment license key, either generated through the Keyoti web-site or provided for trial purposes.
configuration (Configuration)
The instance of the Configuration class that holds the settings to be used.


AddResultItemToResults Method (result, results)

AddResultItemToResults Method (result, results)
API Documentation ► Keyoti.SearchEngine.Search ► SearchAgent ► AddResultItemToResults(ResultItem, ResultItemList)
Keyoti SearchUnit v6
Add a ResultItem object to the collection
Declaration Syntax
C# Visual Basic
protected virtual void AddResultItemToResults(
    ResultItem result,
    ResultItemList results
)
Protected Overridable Sub AddResultItemToResults (
    result As ResultItem,
    results As ResultItemList
)
Parameters
result (ResultItem)
results (ResultItemList)


AllDocumentReturnQuery Property

AllDocumentReturnQuery Property
API Documentation ► Keyoti.SearchEngine.Search ► SearchAgent ► AllDocumentReturnQuery
Keyoti SearchUnit v6
The query that the user can use to retrieve a list of all documents
Declaration Syntax
C# Visual Basic
public string AllDocumentReturnQuery { get; set; }
Public Property AllDocumentReturnQuery As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


Configuration Property

Configuration Property
API Documentation ► Keyoti.SearchEngine.Search ► SearchAgent ► Configuration
Keyoti SearchUnit v6
Configuration of the index
Declaration Syntax
C# Visual Basic
public Configuration Configuration { get; }
Public ReadOnly Property Configuration As Configuration
    Get
Property Value
Configuration

Send comments on this topic to support@keyoti.com


CreateQueryExpressionParser Method (queryString)

CreateQueryExpressionParser Method (queryString)
API Documentation ► Keyoti.SearchEngine.Search ► SearchAgent ► CreateQueryExpressionParser(String)
Keyoti SearchUnit v6
Creates an instance of QueryExpressionParser.
Declaration Syntax
C# Visual Basic
protected virtual QueryExpressionParser CreateQueryExpressionParser(
    string queryString
)
Protected Overridable Function CreateQueryExpressionParser (
    queryString As String
) As QueryExpressionParser
Parameters
queryString (String)
Return Value
QueryExpressionParser
Remarks
Can be overridden to return subclass of QueryExpressionParser.


CreateWholeExpressionGroup Method (queryString)

CreateWholeExpressionGroup Method (queryString)
API Documentation ► Keyoti.SearchEngine.Search ► SearchAgent ► CreateWholeExpressionGroup(String)
Keyoti SearchUnit v6
Creates a GroupElement representing the search expression.
Declaration Syntax
C# Visual Basic
public virtual GroupElement CreateWholeExpressionGroup(
    string queryString
)
Public Overridable Function CreateWholeExpressionGroup (
    queryString As String
) As GroupElement
Parameters
queryString (String)
The search query.
Return Value
GroupElement

Send comments on this topic to support@keyoti.com


DataAccess Property

DataAccess Property
API Documentation ► Keyoti.SearchEngine.Search ► SearchAgent ► DataAccess
Keyoti SearchUnit v6
The data-access layer.
Declaration Syntax
C# Visual Basic
public virtual XmlDataAccess DataAccess { get; set; }
Public Overridable Property DataAccess As XmlDataAccess
    Get
    Set
Property Value
XmlDataAccess

Send comments on this topic to support@keyoti.com


FilterLoadLevel Property

FilterLoadLevel Property
API Documentation ► Keyoti.SearchEngine.Search ► SearchAgent ► FilterLoadLevel
Keyoti SearchUnit v6
Specifies what amount of data to load for any filtering by an AddResultItemToResults override.
Declaration Syntax
C# Visual Basic
public FilterLoadLevel FilterLoadLevel { get; set; }
Public Property FilterLoadLevel As FilterLoadLevel
    Get
    Set
Property Value
FilterLoadLevel
Remarks

The AddResultItemToResults method can be overridden to enable result filtering, but since that method is called early in the search process, it will include many results that will not actually be shown to the user (i.e. results on page 2 onwards). Therefore, it is preferable to load as little data for each document at this stage (since the document may not be presented as a result).

If no filtering is required, set this to DocId, for optimal search speed.


GetContentCategoryRecords Method

GetContentCategoryRecords Method
API Documentation ► Keyoti.SearchEngine.Search ► SearchAgent ► GetContentCategoryRecords()()()()
Keyoti SearchUnit v6
Gets all content category records from the index.
Declaration Syntax
C# Visual Basic
public virtual ContentCategoryRecord[] GetContentCategoryRecords()
Public Overridable Function GetContentCategoryRecords As ContentCategoryRecord()
Return Value
array< ContentCategoryRecord >[]()[][]


GetDocumentText Method (uri)

GetDocumentText Method (uri)
API Documentation ► Keyoti.SearchEngine.Search ► SearchAgent ► GetDocumentText(String)
Keyoti SearchUnit v6
Returns a document's text.
Declaration Syntax
C# Visual Basic
public virtual string GetDocumentText(
    string uri
)
Public Overridable Function GetDocumentText (
    uri As String
) As String
Parameters
uri (String)
string uri
Return Value
String
String representing the document's content; null if the document is not found


GetLocationCategoryRecords Method

GetLocationCategoryRecords Method
API Documentation ► Keyoti.SearchEngine.Search ► SearchAgent ► GetLocationCategoryRecords()()()()
Keyoti SearchUnit v6
Gets all location category records from the index.
Declaration Syntax
C# Visual Basic
public virtual LocationCategoryRecord[] GetLocationCategoryRecords()
Public Overridable Function GetLocationCategoryRecords As LocationCategoryRecord()
Return Value
array< LocationCategoryRecord >[]()[][]


GetNumberOfResults Method (queryExpressions)

GetNumberOfResults Method (queryExpressions)
API Documentation ► Keyoti.SearchEngine.Search ► SearchAgent ► GetNumberOfResults(ArrayList)
Keyoti SearchUnit v6
Returns number of results for a each query in queryExpressions collection
Declaration Syntax
C# Visual Basic
public virtual ArrayList GetNumberOfResults(
    ArrayList queryExpressions
)
Public Overridable Function GetNumberOfResults (
    queryExpressions As ArrayList
) As ArrayList
Parameters
queryExpressions (ArrayList)
List of query strings
Return Value
ArrayList
List of integers holding the number of results for the corresponding query in queryExpressions


GetSearchQuerySuggestions Method (segment, numberOfSuggestionQueriesToFind)

GetSearchQuerySuggestions Method (segment, numberOfSuggestionQueriesToFind)
API Documentation ► Keyoti.SearchEngine.Search ► SearchAgent ► GetSearchQuerySuggestions(String, Int32)
Keyoti SearchUnit v6
Returns a list of words that may be suggestions for segment using the search lexicon only.
Declaration Syntax
C# Visual Basic
public ArrayList GetSearchQuerySuggestions(
    string segment,
    int numberOfSuggestionQueriesToFind
)
Public Function GetSearchQuerySuggestions (
    segment As String,
    numberOfSuggestionQueriesToFind As Integer
) As ArrayList
Parameters
segment (String)
The start of a word.
numberOfSuggestionQueriesToFind (Int32)
The maximum number of query suggestion strings to find.
Return Value
ArrayList
List of words in the search lexicon that start with segment


LicenseKey Property

LicenseKey Property
API Documentation ► Keyoti.SearchEngine.Search ► SearchAgent ► LicenseKey
Keyoti SearchUnit v6
The license key.
Declaration Syntax
C# Visual Basic
public string LicenseKey { get; set; }
Public Property LicenseKey As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


LookUpWordInLexicon Method (word, includeStopList)

LookUpWordInLexicon Method (word, includeStopList)
API Documentation ► Keyoti.SearchEngine.Search ► SearchAgent ► LookUpWordInLexicon(String, Boolean)
Keyoti SearchUnit v6
Returns whether word is in the lexicon
Declaration Syntax
C# Visual Basic
public bool LookUpWordInLexicon(
    string word,
    bool includeStopList
)
Public Function LookUpWordInLexicon (
    word As String,
    includeStopList As Boolean
) As Boolean
Parameters
word (String)
includeStopList (Boolean)
Return Value
Boolean

Send comments on this topic to support@keyoti.com


QueryGroup Property

QueryGroup Property
API Documentation ► Keyoti.SearchEngine.Search ► SearchAgent ► QueryGroup
Keyoti SearchUnit v6
A GroupElement based on the entire search query.
Declaration Syntax
C# Visual Basic
public virtual GroupElement QueryGroup { get; }
Public Overridable ReadOnly Property QueryGroup As GroupElement
    Get
Property Value
GroupElement
Remarks
Inner expression elements can be obtained from this.


QueryString Property

QueryString Property
API Documentation ► Keyoti.SearchEngine.Search ► SearchAgent ► QueryString
Keyoti SearchUnit v6
Search query
Declaration Syntax
C# Visual Basic
public string QueryString { get; }
Public ReadOnly Property QueryString As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


RegisterDataSetBasedSource Method (indexableSourceRecordId, dataSetBasedSource)

RegisterDataSetBasedSource Method (indexableSourceRecordId, dataSetBasedSource)
API Documentation ► Keyoti.SearchEngine.Search ► SearchAgent ► RegisterDataSetBasedSource(Int32, DataSetBasedSource)
Keyoti SearchUnit v6
Registers a DataSetBasedSource for use in result URL mapping.
Declaration Syntax
C# Visual Basic
public virtual void RegisterDataSetBasedSource(
    int indexableSourceRecordId,
    DataSetBasedSource dataSetBasedSource
)
Public Overridable Sub RegisterDataSetBasedSource (
    indexableSourceRecordId As Integer,
    dataSetBasedSource As DataSetBasedSource
)
Parameters
indexableSourceRecordId (Int32)
dataSetBasedSource (DataSetBasedSource)


Search Method

Search Method
API Documentation ► Keyoti.SearchEngine.Search ► SearchAgent ► Search()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Search(String, Int32, Int32) | Runs the search and returns results between lowRange (inclusive and 1 based) and highRange (inclusive and 1 based), ensure the QueryString property is set before calling this.
 | Search(String, SearchOptions, Int32, Int32) | Runs the search and returns results between lowRange (inclusive) and highRange (inclusive), ensure the QueryString property is set before calling this.


Search Method (queryExpression, searchOptions, lowRange, highRange)

Search Method (queryExpression, searchOptions, lowRange, highRange)
API Documentation ► Keyoti.SearchEngine.Search ► SearchAgent ► Search(String, SearchOptions, Int32, Int32)
Keyoti SearchUnit v6
Runs the search and returns results between lowRange (inclusive) and highRange (inclusive), ensure the QueryString property is set before calling this.
Declaration Syntax
C# Visual Basic
public virtual SearchResult Search(
    string queryExpression,
    SearchOptions searchOptions,
    int lowRange,
    int highRange
)
Public Overridable Function Search (
    queryExpression As String,
    searchOptions As SearchOptions,
    lowRange As Integer,
    highRange As Integer
) As SearchResult
Parameters
queryExpression (String)
The expression to search for
searchOptions (SearchOptions)
Search options.
lowRange (Int32)
The lowest result number to return (1 based)
highRange (Int32)
The highest result number to return (1 based)
Return Value
SearchResult
A SearchResult instance with results found
Remarks
The returned SearchResult object will include results between lowRange and highRange. Eg. if lowRange = 10 and highRange = 19 the results returned will be items 10 through 19.
Exceptions
Exception | Condition
InvalidSearchExpressionException | If queryString is not valid for searches.
LicenseException | If a valid license key has not been specified.


Search Method (queryExpression, lowRange, highRange)

Search Method (queryExpression, lowRange, highRange)
API Documentation ► Keyoti.SearchEngine.Search ► SearchAgent ► Search(String, Int32, Int32)
Keyoti SearchUnit v6
Runs the search and returns results between lowRange (inclusive and 1 based) and highRange (inclusive and 1 based), ensure the QueryString property is set before calling this.
Declaration Syntax
C# Visual Basic
public virtual SearchResult Search(
    string queryExpression,
    int lowRange,
    int highRange
)
Public Overridable Function Search (
    queryExpression As String,
    lowRange As Integer,
    highRange As Integer
) As SearchResult
Parameters
queryExpression (String)
The expression to search for
lowRange (Int32)
The lowest result number to return (1 based)
highRange (Int32)
The highest result number to return (1 based)
Return Value
SearchResult
A SearchResult instance with results found
Remarks
The returned SearchResult object will include results between lowRange and highRange. Eg. if lowRange = 10 and highRange = 19 the results returned will be items 10 through 19.


SearcherIO Class

SearcherIO Class
API Documentation ► Keyoti.SearchEngine.Search ► SearcherIO
Keyoti SearchUnit v6
Internal use, handles search IO operations.
Declaration Syntax
C# Visual Basic
public class SearcherIO
Public Class SearcherIO
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SearcherIO(Configuration, XmlLocationTable, XmlContentTable, XmlSecurityGroupTable) | New.
 | SearcherIO(Configuration) | New, using default instances of XML tables.
 | CancelGetMatchingIndexedDocuments()()()() | Cancels the GetMatchingIndexedDocuments process.
 | Close()()()() | Close
 | Configuration | Gets the instance of the Configuration class that holds the settings to be used.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetAllLexiconEntries()()()() | Gets a list of all entries in the lexicon
 | GetDocumentsNotContainingTheWord(LexiconMatch, IntHashtable, SearchOptions) | Gets an ArrayList of document IDs which don't contain notWord.
 | GetHashCode()()()() | (Inherited from Object.)
 | GetIndexedDocumentIds()()()() | Gets a list of all DocumentRecord object IDs in the index.
 | GetIndexedDocumentIds(Int32, Int32, Int32, String, Boolean, Int32%, array<Int32>[]()[][]) | Obsolete. Gets a list of DocumentRecord object IDs in the index within the specified limit.
 | GetIndexedDocumentIds(Int32, Int32, Int32, String, Boolean, Int32%, array<Int32>[]()[][], array<Int32>[]()[][], Int32) | Gets a list of DocumentRecord object IDs in the index within the specified limit.
 | GetMatchingDocumentsForPhrase(array<LexiconMatch>[]()[][], IntHashtable, SearchOptions, Boolean, Hashtable, PhraseElement, StringList) | Finds documents that match a phrase
 | GetMatchingDocumentsForWord(LexiconMatch, IntHashtable, SearchOptions, Boolean) | Gets an OccurrenceMap for a word.
 | GetMatchingIndexedDocuments(Int32, Int32, IndexableSourceRecord, String, Boolean, Int32%) | Gets a list of DocumentRecord objects in the index within the specified limit.
 | GetMatchingIndexedDocuments(Int32, Int32, SecurityGroupRecord, String, Boolean, Int32%) | Gets a list of DocumentRecord objects in the index within the specified limit.
 | GetMatchingIndexedDocuments(Int32, Int32, ContentCategoryRecord, String, Boolean, Int32%) | Gets a list of DocumentRecord objects in the index within the specified limit.
 | GetMatchingIndexedDocuments(Int32, Int32, LocationCategoryRecord, String, Boolean, Int32%) | Gets a list of DocumentRecord objects in the index within the specified limit.
 | GetNumberOfResults(ArrayList) | Gets the number of results for a collection of queryExpressions (words AND conected)
 | GetType()()()() | (Inherited from Object.)
 | GetWordVariations(Word) | Returns list of string objects with variations (lemmas) for a word, empty list if none found.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | RunLexiconQueries(LexiconQueryCollection) | Runs the specified queries.
 | ToString()()()() | (Inherited from Object.)
 | XmlContentTable | Gets the XmlContentTable.
 | XmlLocationTable | Gets the XmlLocationTable.
 | XmlSecurityGroupTable | Gets the XmlSecurityGroupTable.
Inheritance Hierarchy
Object
SearcherIO

Send comments on this topic to support@keyoti.com


SearcherIO Constructor

SearcherIO Constructor
API Documentation ► Keyoti.SearchEngine.Search ► SearcherIO ► SearcherIO()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | SearcherIO(Configuration, XmlLocationTable, XmlContentTable, XmlSecurityGroupTable) | New.
 | SearcherIO(Configuration) | New, using default instances of XML tables.


SearcherIO Constructor (conf)

SearcherIO Constructor (conf)
API Documentation ► Keyoti.SearchEngine.Search ► SearcherIO ► SearcherIO(Configuration)
Keyoti SearchUnit v6
New, using default instances of XML tables.
Declaration Syntax
C# Visual Basic
public SearcherIO(
    Configuration conf
)
Public Sub New (
    conf As Configuration
)
Parameters
conf (Configuration)


SearcherIO Constructor (conf, xmlLocationTable, xmlContentTable, xmlSecurityGroupTable)

SearcherIO Constructor (conf, xmlLocationTable, xmlContentTable, xmlSecurityGroupTable)
API Documentation ► Keyoti.SearchEngine.Search ► SearcherIO ► SearcherIO(Configuration, XmlLocationTable, XmlContentTable, XmlSecurityGroupTable)
Keyoti SearchUnit v6
New.
Declaration Syntax
C# Visual Basic
public SearcherIO(
    Configuration conf,
    XmlLocationTable xmlLocationTable,
    XmlContentTable xmlContentTable,
    XmlSecurityGroupTable xmlSecurityGroupTable
)
Public Sub New (
    conf As Configuration,
    xmlLocationTable As XmlLocationTable,
    xmlContentTable As XmlContentTable,
    xmlSecurityGroupTable As XmlSecurityGroupTable
)
Parameters
conf (Configuration)
xmlLocationTable (XmlLocationTable)
xmlContentTable (XmlContentTable)
xmlSecurityGroupTable (XmlSecurityGroupTable)


CancelGetMatchingIndexedDocuments Method

CancelGetMatchingIndexedDocuments Method
API Documentation ► Keyoti.SearchEngine.Search ► SearcherIO ► CancelGetMatchingIndexedDocuments()()()()
Keyoti SearchUnit v6
Cancels the GetMatchingIndexedDocuments process.
Declaration Syntax
C# Visual Basic
public void CancelGetMatchingIndexedDocuments()
Public Sub CancelGetMatchingIndexedDocuments


Close Method

Close Method
API Documentation ► Keyoti.SearchEngine.Search ► SearcherIO ► Close()()()()
Keyoti SearchUnit v6
Close
Declaration Syntax
C# Visual Basic
public void Close()
Public Sub Close

Send comments on this topic to support@keyoti.com


Configuration Property

Configuration Property
API Documentation ► Keyoti.SearchEngine.Search ► SearcherIO ► Configuration
Keyoti SearchUnit v6
Gets the instance of the Configuration class that holds the settings to be used.
Declaration Syntax
C# Visual Basic
public Configuration Configuration { get; }
Public ReadOnly Property Configuration As Configuration
    Get
Property Value
Configuration

Send comments on this topic to support@keyoti.com


GetAllLexiconEntries Method

GetAllLexiconEntries Method
API Documentation ► Keyoti.SearchEngine.Search ► SearcherIO ► GetAllLexiconEntries()()()()
Keyoti SearchUnit v6
Gets a list of all entries in the lexicon
Declaration Syntax
C# Visual Basic
public ArrayList GetAllLexiconEntries()
Public Function GetAllLexiconEntries As ArrayList
Return Value
ArrayList

Send comments on this topic to support@keyoti.com


GetDocumentsNotContainingTheWord Method (match, cumulativeWeights, searchOptions)

GetDocumentsNotContainingTheWord Method (match, cumulativeWeights, searchOptions)
API Documentation ► Keyoti.SearchEngine.Search ► SearcherIO ► GetDocumentsNotContainingTheWord(LexiconMatch, IntHashtable, SearchOptions)
Keyoti SearchUnit v6
Gets an ArrayList of document IDs which don't contain notWord.
Declaration Syntax
C# Visual Basic
public virtual IntList GetDocumentsNotContainingTheWord(
    LexiconMatch match,
    IntHashtable cumulativeWeights,
    SearchOptions searchOptions
)
Public Overridable Function GetDocumentsNotContainingTheWord (
    match As LexiconMatch,
    cumulativeWeights As IntHashtable,
    searchOptions As SearchOptions
) As IntList
Parameters
match (LexiconMatch)
The word that mustn't appear in the documents.
cumulativeWeights (IntHashtable)
Hashtable holding word weights.
searchOptions (SearchOptions)
Search options.
Return Value
IntList
List of document IDs that don't contain the word.


GetIndexedDocumentIds Method

GetIndexedDocumentIds Method
API Documentation ► Keyoti.SearchEngine.Search ► SearcherIO ► GetIndexedDocumentIds()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GetIndexedDocumentIds()()()() | Gets a list of all DocumentRecord object IDs in the index.
 | GetIndexedDocumentIds(Int32, Int32, Int32, String, Boolean, Int32%, array<Int32>[]()[][]) | Obsolete. Gets a list of DocumentRecord object IDs in the index within the specified limit.
 | GetIndexedDocumentIds(Int32, Int32, Int32, String, Boolean, Int32%, array<Int32>[]()[][], array<Int32>[]()[][], Int32) | Gets a list of DocumentRecord object IDs in the index within the specified limit.


GetIndexedDocumentIds Method

GetIndexedDocumentIds Method
API Documentation ► Keyoti.SearchEngine.Search ► SearcherIO ► GetIndexedDocumentIds()()()()
Keyoti SearchUnit v6
Gets a list of all DocumentRecord object IDs in the index.
Declaration Syntax
C# Visual Basic
public virtual IntList GetIndexedDocumentIds()
Public Overridable Function GetIndexedDocumentIds As IntList
Return Value
IntList
ArrayList of DocumentRecord objects

Send comments on this topic to support@keyoti.com


GetIndexedDocumentIds Method (from, to, sourceID, filter, getCount, totalCount, securityGroupID)

GetIndexedDocumentIds Method (from, to, sourceID, filter, getCount, totalCount, securityGroupID)
API Documentation ► Keyoti.SearchEngine.Search ► SearcherIO ► GetIndexedDocumentIds(Int32, Int32, Int32, String, Boolean, Int32%, array<Int32>[]()[][])
Keyoti SearchUnit v6
Gets a list of DocumentRecord object IDs in the index within the specified limit.
Declaration Syntax
C# Visual Basic
[ObsoleteAttribute("Please use new version of this method with content and location arguments added.",
    true)]
public virtual IntList GetIndexedDocumentIds(
    int from,
    int to,
    int sourceID,
    string filter,
    bool getCount,
    out int totalCount,
    int[] securityGroupID
)
<ObsoleteAttribute("Please use new version of this method with content and location arguments added.",
    true)>
Public Overridable Function GetIndexedDocumentIds (
    from As Integer,
    to As Integer,
    sourceID As Integer,
    filter As String,
    getCount As Boolean,
    <OutAttribute> ByRef totalCount As Integer,
    securityGroupID As Integer()
) As IntList
Parameters
from (Int32)
Document from which to start
to (Int32)
Document at which to end
sourceID (Int32)
If !=-1 then document must be in this indexed source, if -1 then all.
filter (String)
Substring the must be in any document field in order to add
getCount (Boolean)
Whether to get a count of all documents that are in source (requires extra work).
totalCount (Int32 %)
Output param holding the total count if getCount is true.
securityGroupID (array< Int32 >[]()[][])
Security group IDs that documents must belong to, eg. 1 for default, -1 for all
Return Value
IntList
ArrayList of DocumentRecord objects

Send comments on this topic to support@keyoti.com


GetIndexedDocumentIds Method (from, to, sourceID, filter, getCount, totalCount, securityGroupID, contentCategoryIDs, locationCategoryID)

GetIndexedDocumentIds Method (from, to, sourceID, filter, getCount, totalCount, securityGroupID, contentCategoryIDs, locationCategoryID)
API Documentation ► Keyoti.SearchEngine.Search ► SearcherIO ► GetIndexedDocumentIds(Int32, Int32, Int32, String, Boolean, Int32%, array<Int32>[]()[][], array<Int32>[]()[][], Int32)
Keyoti SearchUnit v6
Gets a list of DocumentRecord object IDs in the index within the specified limit.
Declaration Syntax
C# Visual Basic
public virtual IntList GetIndexedDocumentIds(
    int from,
    int to,
    int sourceID,
    string filter,
    bool getCount,
    out int totalCount,
    int[] securityGroupID,
    int[] contentCategoryIDs,
    int locationCategoryID
)
Public Overridable Function GetIndexedDocumentIds (
    from As Integer,
    to As Integer,
    sourceID As Integer,
    filter As String,
    getCount As Boolean,
    <OutAttribute> ByRef totalCount As Integer,
    securityGroupID As Integer(),
    contentCategoryIDs As Integer(),
    locationCategoryID As Integer
) As IntList
Parameters
from (Int32)
Document from which to start
to (Int32)
Document at which to end
sourceID (Int32)
If !=-1 then document must be in this indexed source, if -1 then all.
filter (String)
Substring the must be in any document field in order to add
getCount (Boolean)
Whether to get a count of all documents that are in source (requires extra work).
totalCount (Int32 %)
Output param holding the total count if getCount is true.
securityGroupID (array< Int32 >[]()[][])
Security group IDs that documents must belong to, eg. 1 for default, -1 for all
contentCategoryIDs (array< Int32 >[]()[][])
Content category group IDs that document must belong to, eg. 0 for all
locationCategoryID (Int32)
Location category group ID that document must belong to, eg. -1 for all
Return Value
IntList
ArrayList of DocumentRecord objects

Send comments on this topic to support@keyoti.com


GetMatchingDocumentsForPhrase Method (words, cumulativeWeights, searchOptions, loadOccurrenceData, objDocOc, phrase, ignoredWords)

GetMatchingDocumentsForPhrase Method (words, cumulativeWeights, searchOptions, loadOccurrenceData, objDocOc, phrase, ignoredWords)
API Documentation ► Keyoti.SearchEngine.Search ► SearcherIO ► GetMatchingDocumentsForPhrase(array<LexiconMatch>[]()[][], IntHashtable, SearchOptions, Boolean, Hashtable, PhraseElement, StringList)
Keyoti SearchUnit v6
Finds documents that match a phrase
Declaration Syntax
C# Visual Basic
public virtual IntList GetMatchingDocumentsForPhrase(
    LexiconMatch[] words,
    IntHashtable cumulativeWeights,
    SearchOptions searchOptions,
    bool loadOccurrenceData,
    Hashtable objDocOc,
    PhraseElement phrase,
    StringList ignoredWords
)
Public Overridable Function GetMatchingDocumentsForPhrase (
    words As LexiconMatch(),
    cumulativeWeights As IntHashtable,
    searchOptions As SearchOptions,
    loadOccurrenceData As Boolean,
    objDocOc As Hashtable,
    phrase As PhraseElement,
    ignoredWords As StringList
) As IntList
Parameters
words (array< LexiconMatch >[]()[][])
Array of words in the phrase
cumulativeWeights (IntHashtable)
Weights of the matched terms
searchOptions (SearchOptions)
Options to restrict the search
loadOccurrenceData (Boolean)
Whether to load occurrence data
objDocOc (Hashtable)
Store of occurrence data
phrase (PhraseElement)
The phrase
ignoredWords (StringList)
List of words which have been ignored as stop words
Return Value
IntList
Matching document IDs.


GetMatchingDocumentsForWord Method (word, cumulativeWeights, searchOptions, loadOccurrenceData)

GetMatchingDocumentsForWord Method (word, cumulativeWeights, searchOptions, loadOccurrenceData)
API Documentation ► Keyoti.SearchEngine.Search ► SearcherIO ► GetMatchingDocumentsForWord(LexiconMatch, IntHashtable, SearchOptions, Boolean)
Keyoti SearchUnit v6
Gets an OccurrenceMap for a word.
Declaration Syntax
C# Visual Basic
public virtual OccurrenceMapIWordPositions GetMatchingDocumentsForWord(
    LexiconMatch word,
    IntHashtable cumulativeWeights,
    SearchOptions searchOptions,
    bool loadOccurrenceData
)
Public Overridable Function GetMatchingDocumentsForWord (
    word As LexiconMatch,
    cumulativeWeights As IntHashtable,
    searchOptions As SearchOptions,
    loadOccurrenceData As Boolean
) As OccurrenceMapIWordPositions
Parameters
word (LexiconMatch)
Word to find occurrences of.
cumulativeWeights (IntHashtable)
Table of weights for occurrences (key=docID, value=word's weight in that doc).
searchOptions (SearchOptions)
Search options.
loadOccurrenceData (Boolean)
Whether to load occurrence data into the match
Return Value
OccurrenceMapIWordPositions
All occurrences of word (or words in variations) that match.


GetMatchingIndexedDocuments Method

GetMatchingIndexedDocuments Method
API Documentation ► Keyoti.SearchEngine.Search ► SearcherIO ► GetMatchingIndexedDocuments()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GetMatchingIndexedDocuments(Int32, Int32, IndexableSourceRecord, String, Boolean, Int32%) | Gets a list of DocumentRecord objects in the index within the specified limit.
 | GetMatchingIndexedDocuments(Int32, Int32, SecurityGroupRecord, String, Boolean, Int32%) | Gets a list of DocumentRecord objects in the index within the specified limit.
 | GetMatchingIndexedDocuments(Int32, Int32, ContentCategoryRecord, String, Boolean, Int32%) | Gets a list of DocumentRecord objects in the index within the specified limit.
 | GetMatchingIndexedDocuments(Int32, Int32, LocationCategoryRecord, String, Boolean, Int32%) | Gets a list of DocumentRecord objects in the index within the specified limit.


GetMatchingIndexedDocuments Method (from, to, source, filter, getCount, totalCount)

GetMatchingIndexedDocuments Method (from, to, source, filter, getCount, totalCount)
API Documentation ► Keyoti.SearchEngine.Search ► SearcherIO ► GetMatchingIndexedDocuments(Int32, Int32, ContentCategoryRecord, String, Boolean, Int32%)
Keyoti SearchUnit v6
Gets a list of DocumentRecord objects in the index within the specified limit.
Declaration Syntax
C# Visual Basic
public virtual ArrayList GetMatchingIndexedDocuments(
    int from,
    int to,
    ContentCategoryRecord source,
    string filter,
    bool getCount,
    out int totalCount
)
Public Overridable Function GetMatchingIndexedDocuments (
    from As Integer,
    to As Integer,
    source As ContentCategoryRecord,
    filter As String,
    getCount As Boolean,
    <OutAttribute> ByRef totalCount As Integer
) As ArrayList
Parameters
from (Int32)
Document from which to start
to (Int32)
Document at which to end
source (ContentCategoryRecord)
The content category to look within.
filter (String)
Substring that must be in any document field in order to add
getCount (Boolean)
Whether to get a count of all documents that are in source (requires extra work).
totalCount (Int32 %)
Output param holding the total count if getCount is true.
Return Value
ArrayList
ArrayList of DocumentRecord objects

Send comments on this topic to support@keyoti.com


GetMatchingIndexedDocuments Method (from, to, source, filter, getCount, totalCount)

GetMatchingIndexedDocuments Method (from, to, source, filter, getCount, totalCount)
API Documentation ► Keyoti.SearchEngine.Search ► SearcherIO ► GetMatchingIndexedDocuments(Int32, Int32, IndexableSourceRecord, String, Boolean, Int32%)
Keyoti SearchUnit v6
Gets a list of DocumentRecord objects in the index within the specified limit.
Declaration Syntax
C# Visual Basic
public virtual ArrayList GetMatchingIndexedDocuments(
    int from,
    int to,
    IndexableSourceRecord source,
    string filter,
    bool getCount,
    out int totalCount
)
Public Overridable Function GetMatchingIndexedDocuments (
    from As Integer,
    to As Integer,
    source As IndexableSourceRecord,
    filter As String,
    getCount As Boolean,
    <OutAttribute> ByRef totalCount As Integer
) As ArrayList
Parameters
from (Int32)
Document from which to start
to (Int32)
Document at which to end
source (IndexableSourceRecord)
The indexable source to look within
filter (String)
Substring that must be in any document field in order to add
getCount (Boolean)
Whether to get a count of all documents that are in source (requires extra work).
totalCount (Int32 %)
Output param holding the total count if getCount is true.
Return Value
ArrayList
ArrayList of DocumentRecord objects

Send comments on this topic to support@keyoti.com


GetMatchingIndexedDocuments Method (from, to, source, filter, getCount, totalCount)

GetMatchingIndexedDocuments Method (from, to, source, filter, getCount, totalCount)
API Documentation ► Keyoti.SearchEngine.Search ► SearcherIO ► GetMatchingIndexedDocuments(Int32, Int32, LocationCategoryRecord, String, Boolean, Int32%)
Keyoti SearchUnit v6
Gets a list of DocumentRecord objects in the index within the specified limit.
Declaration Syntax
C# Visual Basic
public virtual ArrayList GetMatchingIndexedDocuments(
    int from,
    int to,
    LocationCategoryRecord source,
    string filter,
    bool getCount,
    out int totalCount
)
Public Overridable Function GetMatchingIndexedDocuments (
    from As Integer,
    to As Integer,
    source As LocationCategoryRecord,
    filter As String,
    getCount As Boolean,
    <OutAttribute> ByRef totalCount As Integer
) As ArrayList
Parameters
from (Int32)
Document from which to start
to (Int32)
Document at which to end
source (LocationCategoryRecord)
The location category that the documents will belong to
filter (String)
Substring that must be in any document field in order to add
getCount (Boolean)
Whether to get a count of all documents that are in source (requires extra work).
totalCount (Int32 %)
Output param holding the total count if getCount is true.
Return Value
ArrayList
ArrayList of DocumentRecord objects

Send comments on this topic to support@keyoti.com


GetMatchingIndexedDocuments Method (from, to, source, filter, getCount, totalCount)

GetMatchingIndexedDocuments Method (from, to, source, filter, getCount, totalCount)
API Documentation ► Keyoti.SearchEngine.Search ► SearcherIO ► GetMatchingIndexedDocuments(Int32, Int32, SecurityGroupRecord, String, Boolean, Int32%)
Keyoti SearchUnit v6
Gets a list of DocumentRecord objects in the index within the specified limit.
Declaration Syntax
C# Visual Basic
public virtual ArrayList GetMatchingIndexedDocuments(
    int from,
    int to,
    SecurityGroupRecord source,
    string filter,
    bool getCount,
    out int totalCount
)
Public Overridable Function GetMatchingIndexedDocuments (
    from As Integer,
    to As Integer,
    source As SecurityGroupRecord,
    filter As String,
    getCount As Boolean,
    <OutAttribute> ByRef totalCount As Integer
) As ArrayList
Parameters
from (Int32)
Document from which to start
to (Int32)
Document at which to end
source (SecurityGroupRecord)
The security group to find documents within
filter (String)
Substring that must be in any document field in order to add
getCount (Boolean)
Whether to get a count of all documents that are in source (requires extra work).
totalCount (Int32 %)
Output param holding the total count if getCount is true.
Return Value
ArrayList
ArrayList of DocumentRecord objects

Send comments on this topic to support@keyoti.com


GetNumberOfResults Method (queryExpressions)

GetNumberOfResults Method (queryExpressions)
API Documentation ► Keyoti.SearchEngine.Search ► SearcherIO ► GetNumberOfResults(ArrayList)
Keyoti SearchUnit v6
Gets the number of results for a collection of queryExpressions (words AND conected)
Declaration Syntax
C# Visual Basic
public ArrayList GetNumberOfResults(
    ArrayList queryExpressions
)
Public Function GetNumberOfResults (
    queryExpressions As ArrayList
) As ArrayList
Parameters
queryExpressions (ArrayList)
Query strings collection
Return Value
ArrayList
Int (number of results per query) collection


GetWordVariations Method (word)

GetWordVariations Method (word)
API Documentation ► Keyoti.SearchEngine.Search ► SearcherIO ► GetWordVariations(Word)
Keyoti SearchUnit v6
Returns list of string objects with variations (lemmas) for a word, empty list if none found.
Declaration Syntax
C# Visual Basic
public virtual ArrayList GetWordVariations(
    Word word
)
Public Overridable Function GetWordVariations (
    word As Word
) As ArrayList
Parameters
word (Word)
Return Value
ArrayList

Send comments on this topic to support@keyoti.com


RunLexiconQueries Method (queries)

RunLexiconQueries Method (queries)
API Documentation ► Keyoti.SearchEngine.Search ► SearcherIO ► RunLexiconQueries(LexiconQueryCollection)
Keyoti SearchUnit v6
Runs the specified queries.
Declaration Syntax
C# Visual Basic
public virtual void RunLexiconQueries(
    LexiconQueryCollection queries
)
Public Overridable Sub RunLexiconQueries (
    queries As LexiconQueryCollection
)
Parameters
queries (LexiconQueryCollection)


XmlContentTable Property

XmlContentTable Property
API Documentation ► Keyoti.SearchEngine.Search ► SearcherIO ► XmlContentTable
Keyoti SearchUnit v6
Gets the XmlContentTable.
Declaration Syntax
C# Visual Basic
public virtual XmlContentTable XmlContentTable { get; }
Public Overridable ReadOnly Property XmlContentTable As XmlContentTable
    Get
Property Value
XmlContentTable

Send comments on this topic to support@keyoti.com


XmlLocationTable Property

XmlLocationTable Property
API Documentation ► Keyoti.SearchEngine.Search ► SearcherIO ► XmlLocationTable
Keyoti SearchUnit v6
Gets the XmlLocationTable.
Declaration Syntax
C# Visual Basic
public virtual XmlLocationTable XmlLocationTable { get; }
Public Overridable ReadOnly Property XmlLocationTable As XmlLocationTable
    Get
Property Value
XmlLocationTable

Send comments on this topic to support@keyoti.com


XmlSecurityGroupTable Property

XmlSecurityGroupTable Property
API Documentation ► Keyoti.SearchEngine.Search ► SearcherIO ► XmlSecurityGroupTable
Keyoti SearchUnit v6
Gets the XmlSecurityGroupTable.
Declaration Syntax
C# Visual Basic
public virtual XmlSecurityGroupTable XmlSecurityGroupTable { get; }
Public Overridable ReadOnly Property XmlSecurityGroupTable As XmlSecurityGroupTable
    Get
Property Value
XmlSecurityGroupTable

Send comments on this topic to support@keyoti.com


SearchLogic Class

SearchLogic Class
API Documentation ► Keyoti.SearchEngine.Search ► SearchLogic
Keyoti SearchUnit v6
Applies query logic to search results
Declaration Syntax
C# Visual Basic
public class SearchLogic
Public Class SearchLogic
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SearchLogic()()()() | Creates an instance
 | ApplyANDLogic(IntListList, Configuration) | Receives an IntListList of IntList objects, each IntList contains the document IDs matching each Element in the query, and applies logic to the list.
 | ApplyORLogic(IntListList, Configuration) | Receives an IntListList of IntList objects, each IntList contains the document IDs matching each Element in the query, and applies logic to the list.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
SearchLogic

Send comments on this topic to support@keyoti.com


SearchLogic Constructor

SearchLogic Constructor
API Documentation ► Keyoti.SearchEngine.Search ► SearchLogic ► SearchLogic()()()()
Keyoti SearchUnit v6
Creates an instance
Declaration Syntax
C# Visual Basic
public SearchLogic()
Public Sub New

Send comments on this topic to support@keyoti.com


ApplyANDLogic Method (allDocumentsList, Configuration)

ApplyANDLogic Method (allDocumentsList, Configuration)
API Documentation ► Keyoti.SearchEngine.Search ► SearchLogic ► ApplyANDLogic(IntListList, Configuration)
Keyoti SearchUnit v6
Receives an IntListList of IntList objects, each IntList contains the document IDs matching each Element in the query, and applies logic to the list.
Declaration Syntax
C# Visual Basic
public static IntList ApplyANDLogic(
    IntListList allDocumentsList,
    Configuration Configuration
)
Public Shared Function ApplyANDLogic (
    allDocumentsList As IntListList,
    Configuration As Configuration
) As IntList
Parameters
allDocumentsList (IntListList)
Document IDs to apply the AND logic to
Configuration (Configuration)
The instance of the Configuration class that holds the settings to be used.
Return Value
IntList
IntList of Document IDs satisfying the AND logic
Remarks
Eg. if a query = "one two" then two Elements are created, one WordElement for "one" and one for "two". The query specifies AND logic between those elements, thus this method receives an ArrayList with elements as follows; allDocumentsList[0] = {1, 3, 5} where 1, 3 and 5 are document IDs with "one" in them. allDocumentsList[1] = {3, 5, 8, 10} where 3, 5, 8, 10 are document IDs with "two" in them. This method will then return an IntList of ints with {3, 5} in it.


ApplyORLogic Method (allDocumentsList, Configuration)

ApplyORLogic Method (allDocumentsList, Configuration)
API Documentation ► Keyoti.SearchEngine.Search ► SearchLogic ► ApplyORLogic(IntListList, Configuration)
Keyoti SearchUnit v6
Receives an IntListList of IntList objects, each IntList contains the document IDs matching each Element in the query, and applies logic to the list.
Declaration Syntax
C# Visual Basic
public static IntList ApplyORLogic(
    IntListList allDocumentsList,
    Configuration Configuration
)
Public Shared Function ApplyORLogic (
    allDocumentsList As IntListList,
    Configuration As Configuration
) As IntList
Parameters
allDocumentsList (IntListList)
Document IDs to apply the OR logic to
Configuration (Configuration)
The instance of the Configuration class that holds the settings to be used.
Return Value
IntList
IntList of Document IDs satisfying the OR logic
Remarks
Eg. if a query = "one OR two" then two WordElements are created, one WordElement for "one" and one for "two". The query specifies OR logic between those elements, thus this method receives an ArrayList with elements as follows; allDocumentsList[0] = {1, 3, 5} where 1, 3 and 5 are document IDs with "one" in them. allDocumentsList[1] = {3, 5, 8, 10} where 3, 5, 8, 10 are document IDs with "two" in them. This method will then return an IntList of ints with {1, 3, 5, 8, 10} in it.


SearchOptions Class

SearchOptions Class
API Documentation ► Keyoti.SearchEngine.Search ► SearchOptions
Keyoti SearchUnit v6
Contains content and location options (note these are only applicable in Search PRO).
Declaration Syntax
C# Visual Basic
[SerializableAttribute]
public class SearchOptions
<SerializableAttribute>
Public Class SearchOptions
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SearchOptions()()()() | Constructs a new instance.
 | SearchOptions(String, array<String>[]()[][]) | Constructs a new instance.
 | SearchOptions(String, array<String>[]()[][], array<String>[]()[][]) | Constructs a new instance.
 | SearchOptions(String, array<String>[]()[][], array<String>[]()[][], FilterCollection, SortBy) | Constructs a new instance.
 | ContentCategoryNames | Array of content names to search within.
 | CustomDataFilters | Any filters to apply to results.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | LocationCategoryName | Location name to search within.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnNotifyPropertyChanged(String) | Fires the property changed event
 | PropertyChanged | Fired when a property value changes.
 | SecurityGroupNames | Array of security group names to search within.
 | SortBy | How to sort results.
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
SearchOptions

Send comments on this topic to support@keyoti.com


SearchOptions Constructor

SearchOptions Constructor
API Documentation ► Keyoti.SearchEngine.Search ► SearchOptions ► SearchOptions()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | SearchOptions()()()() | Constructs a new instance.
 | SearchOptions(String, array<String>[]()[][]) | Constructs a new instance.
 | SearchOptions(String, array<String>[]()[][], array<String>[]()[][]) | Constructs a new instance.
 | SearchOptions(String, array<String>[]()[][], array<String>[]()[][], FilterCollection, SortBy) | Constructs a new instance.


SearchOptions Constructor

SearchOptions Constructor
API Documentation ► Keyoti.SearchEngine.Search ► SearchOptions ► SearchOptions()()()()
Keyoti SearchUnit v6
Constructs a new instance.
Declaration Syntax
C# Visual Basic
public SearchOptions()
Public Sub New

Send comments on this topic to support@keyoti.com


SearchOptions Constructor (locationCategoryName, contentCategoryNames)

SearchOptions Constructor (locationCategoryName, contentCategoryNames)
API Documentation ► Keyoti.SearchEngine.Search ► SearchOptions ► SearchOptions(String, array<String>[]()[][])
Keyoti SearchUnit v6
Constructs a new instance.
Declaration Syntax
C# Visual Basic
public SearchOptions(
    string locationCategoryName,
    string[] contentCategoryNames
)
Public Sub New (
    locationCategoryName As String,
    contentCategoryNames As String()
)
Parameters
locationCategoryName (String)
Location name to search within.
contentCategoryNames (array< String >[]()[][])
Array of content names to search within.


SearchOptions Constructor (locationCategoryName, contentCategoryNames, securityGroupNames)

SearchOptions Constructor (locationCategoryName, contentCategoryNames, securityGroupNames)
API Documentation ► Keyoti.SearchEngine.Search ► SearchOptions ► SearchOptions(String, array<String>[]()[][], array<String>[]()[][])
Keyoti SearchUnit v6
Constructs a new instance.
Declaration Syntax
C# Visual Basic
public SearchOptions(
    string locationCategoryName,
    string[] contentCategoryNames,
    string[] securityGroupNames
)
Public Sub New (
    locationCategoryName As String,
    contentCategoryNames As String(),
    securityGroupNames As String()
)
Parameters
locationCategoryName (String)
Location name to search within.
contentCategoryNames (array< String >[]()[][])
Array of content names to search within.
securityGroupNames (array< String >[]()[][])
Security group names to search within

Send comments on this topic to support@keyoti.com


SearchOptions Constructor (locationCategoryName, contentCategoryNames, securityGroupNames, customDataFilters, sortBy)

SearchOptions Constructor (locationCategoryName, contentCategoryNames, securityGroupNames, customDataFilters, sortBy)
API Documentation ► Keyoti.SearchEngine.Search ► SearchOptions ► SearchOptions(String, array<String>[]()[][], array<String>[]()[][], FilterCollection, SortBy)
Keyoti SearchUnit v6
Constructs a new instance.
Declaration Syntax
C# Visual Basic
public SearchOptions(
    string locationCategoryName,
    string[] contentCategoryNames,
    string[] securityGroupNames,
    FilterCollection customDataFilters,
    SortBy sortBy
)
Public Sub New (
    locationCategoryName As String,
    contentCategoryNames As String(),
    securityGroupNames As String(),
    customDataFilters As FilterCollection,
    sortBy As SortBy
)
Parameters
locationCategoryName (String)
Location name to search within.
contentCategoryNames (array< String >[]()[][])
Array of content names to search within.
securityGroupNames (array< String >[]()[][])
Security group names to search within
customDataFilters (FilterCollection)
Any custom data filters that should be applied to the search
sortBy (SortBy)


ContentCategoryNames Property

ContentCategoryNames Property
API Documentation ► Keyoti.SearchEngine.Search ► SearchOptions ► ContentCategoryNames
Keyoti SearchUnit v6
Array of content names to search within.
Declaration Syntax
C# Visual Basic
public string[] ContentCategoryNames { get; set; }
Public Property ContentCategoryNames As String()
    Get
    Set
Property Value
array< String >[]()[][]


CustomDataFilters Property

CustomDataFilters Property
API Documentation ► Keyoti.SearchEngine.Search ► SearchOptions ► CustomDataFilters
Keyoti SearchUnit v6
Any filters to apply to results.
Declaration Syntax
C# Visual Basic
public FilterCollection CustomDataFilters { get; set; }
Public Property CustomDataFilters As FilterCollection
    Get
    Set
Property Value
FilterCollection

Send comments on this topic to support@keyoti.com


LocationCategoryName Property

LocationCategoryName Property
API Documentation ► Keyoti.SearchEngine.Search ► SearchOptions ► LocationCategoryName
Keyoti SearchUnit v6
Location name to search within.
Declaration Syntax
C# Visual Basic
public string LocationCategoryName { get; set; }
Public Property LocationCategoryName As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


OnNotifyPropertyChanged Method (info)

OnNotifyPropertyChanged Method (info)
API Documentation ► Keyoti.SearchEngine.Search ► SearchOptions ► OnNotifyPropertyChanged(String)
Keyoti SearchUnit v6
Fires the property changed event
Declaration Syntax
C# Visual Basic
protected virtual void OnNotifyPropertyChanged(
    string info
)
Protected Overridable Sub OnNotifyPropertyChanged (
    info As String
)
Parameters
info (String)
Name of the property

Send comments on this topic to support@keyoti.com


PropertyChanged Event

PropertyChanged Event
API Documentation ► Keyoti.SearchEngine.Search ► SearchOptions ► PropertyChanged
Keyoti SearchUnit v6
Fired when a property value changes.
Declaration Syntax
C# Visual Basic
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler
Value
PropertyChangedEventHandler

Send comments on this topic to support@keyoti.com


SecurityGroupNames Property

SecurityGroupNames Property
API Documentation ► Keyoti.SearchEngine.Search ► SearchOptions ► SecurityGroupNames
Keyoti SearchUnit v6
Array of security group names to search within.
Declaration Syntax
C# Visual Basic
public string[] SecurityGroupNames { get; set; }
Public Property SecurityGroupNames As String()
    Get
    Set
Property Value
array< String >[]()[][]


SortBy Property

SortBy Property
API Documentation ► Keyoti.SearchEngine.Search ► SearchOptions ► SortBy
Keyoti SearchUnit v6
How to sort results.
Declaration Syntax
C# Visual Basic
public SortBy SortBy { get; set; }
Public Property SortBy As SortBy
    Get
    Set
Property Value
SortBy

Send comments on this topic to support@keyoti.com


SearchResult Class

SearchResult Class
API Documentation ► Keyoti.SearchEngine.Search ► SearchResult
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public class SearchResult : List<ResultItem>
Public Class SearchResult
    Inherits List(Of ResultItem)
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SearchResult()()()() |
 | Add(T) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | AddRange(IEnumerable<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | AsReadOnly()()()() | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | BeforeDataRowAdd | Event fired just before data row is added to data table during initialization of DataSet property.
 | BeforeDataTableAdd | Event fired just before data table is added to data set during initialization of DataSet property.
 | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | BinarySearch(T) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | Capacity | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | Clear()()()() | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | Contains(T) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | ConvertAll<(Of <<'(TOutput>)>>)(Converter<(Of <<'(T, TOutput>)>>)) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | Count | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | DataSet | Converts the search results to a DataSet (see remarks).
 | Equals(Object) | (Inherited from Object.)
 | Exists(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | Finalize()()()() | (Inherited from Object.)
 | Find(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | FindAll(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | FindLast(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | ForEach(Action<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | GetEnumerator()()()() | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetRange(Int32, Int32) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | GetType()()()() | (Inherited from Object.)
 | IgnoredWords | Any words in the query which were ignored, usually because they're on the index's stop list.
 | IndexOf(T) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | IndexOf(T, Int32) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | Insert(Int32, T) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | InsertRange(Int32, IEnumerable<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | Item[([( Int32])]) | Gets a result.
 | LastIndexOf(T) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | LiveDataSamples |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NumberOfResults | The number of results found.
 | Remove(T) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | RemoveAll(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | RemoveAt(Int32) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | RemoveRange(Int32, Int32) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | Reverse()()()() | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | Sort()()()() | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | ToArray()()()() | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | ToString()()()() | (Inherited from Object.)
 | TrimExcess()()()() | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | TrueForAll(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
Inheritance Hierarchy
Object
 | List <(Of <(<' ResultItem >)>)>
 |  | SearchResult


SearchResult Constructor

SearchResult Constructor
API Documentation ► Keyoti.SearchEngine.Search ► SearchResult ► SearchResult()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public SearchResult()
Public Sub New

Send comments on this topic to support@keyoti.com


BeforeDataRowAdd Event

BeforeDataRowAdd Event
API Documentation ► Keyoti.SearchEngine.Search ► SearchResult ► BeforeDataRowAdd
Keyoti SearchUnit v6
Event fired just before data row is added to data table during initialization of DataSet property.
Declaration Syntax
C# Visual Basic
public event SearchResult..::..DataRowEventHandler BeforeDataRowAdd
Public Event BeforeDataRowAdd As SearchResult..::..DataRowEventHandler
Value
SearchResult..::..DataRowEventHandler
Remarks
Only happens if DataSet property is used.


BeforeDataTableAdd Event

BeforeDataTableAdd Event
API Documentation ► Keyoti.SearchEngine.Search ► SearchResult ► BeforeDataTableAdd
Keyoti SearchUnit v6
Event fired just before data table is added to data set during initialization of DataSet property.
Declaration Syntax
C# Visual Basic
public event SearchResult..::..DataTableEventHandler BeforeDataTableAdd
Public Event BeforeDataTableAdd As SearchResult..::..DataTableEventHandler
Value
SearchResult..::..DataTableEventHandler
Remarks
Only happens if DataSet property is used.


DataSet Property

DataSet Property
API Documentation ► Keyoti.SearchEngine.Search ► SearchResult ► DataSet
Keyoti SearchUnit v6
Converts the search results to a DataSet (see remarks).
Declaration Syntax
C# Visual Basic
public virtual DataSet DataSet { get; }
Public Overridable ReadOnly Property DataSet As DataSet
    Get
Property Value
DataSet
Remarks
This creates a DataSet containing one table, with columns "UriString", "Title", "Summary", "Weight" which hold the data from the properties of the Keyoti.SearchEngine.Search.ResultItem class. Each row represents one result. This property is cached, so that the operation only occurs once.


IgnoredWords Property

IgnoredWords Property
API Documentation ► Keyoti.SearchEngine.Search ► SearchResult ► IgnoredWords
Keyoti SearchUnit v6
Any words in the query which were ignored, usually because they're on the index's stop list.
Declaration Syntax
C# Visual Basic
public StringList IgnoredWords { get; set; }
Public Property IgnoredWords As StringList
    Get
    Set
Property Value
StringList

Send comments on this topic to support@keyoti.com


Item Property (index)

Item Property (index)
API Documentation ► Keyoti.SearchEngine.Search ► SearchResult ► Item[([( Int32])])
Keyoti SearchUnit v6
Gets a result.
Declaration Syntax
C# Visual Basic
public ResultItem this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As ResultItem
    Get
    Set
Parameters
index (Int32)
The result number, 0 based.
Property Value
ResultItem

Send comments on this topic to support@keyoti.com


LiveDataSamples Property

LiveDataSamples Property
API Documentation ► Keyoti.SearchEngine.Search ► SearchResult ► LiveDataSamples
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public LiveDataCollection LiveDataSamples { get; }
Public ReadOnly Property LiveDataSamples As LiveDataCollection
    Get
Property Value
LiveDataCollection

Send comments on this topic to support@keyoti.com


NumberOfResults Property

NumberOfResults Property
API Documentation ► Keyoti.SearchEngine.Search ► SearchResult ► NumberOfResults
Keyoti SearchUnit v6
The number of results found.
Declaration Syntax
C# Visual Basic
public virtual int NumberOfResults { get; set; }
Public Overridable Property NumberOfResults As Integer
    Get
    Set
Property Value
Int32

Send comments on this topic to support@keyoti.com


SearchResult.DataRowEventArgs Class

SearchResult..::..DataRowEventArgs Class
API Documentation ► Keyoti.SearchEngine.Search ► SearchResult ► SearchResult..::..DataRowEventArgs
Keyoti SearchUnit v6
Event args for DataRow event(s).
Declaration Syntax
C# Visual Basic
public class DataRowEventArgs : EventArgs
Public Class DataRowEventArgs
    Inherits EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SearchResult..::..DataRowEventArgs(DataRow) | New instance
 | DataRow | The row
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | SearchResult..::..DataRowEventArgs


SearchResult.DataRowEventArgs Constructor (row)

SearchResult..::..DataRowEventArgs Constructor (row)
API Documentation ► Keyoti.SearchEngine.Search ► SearchResult..::..DataRowEventArgs ► SearchResult..::..DataRowEventArgs(DataRow)
Keyoti SearchUnit v6
New instance
Declaration Syntax
C# Visual Basic
public DataRowEventArgs(
    DataRow row
)
Public Sub New (
    row As DataRow
)
Parameters
row (DataRow)


DataRow Property

DataRow Property
API Documentation ► Keyoti.SearchEngine.Search ► SearchResult..::..DataRowEventArgs ► DataRow
Keyoti SearchUnit v6
The row
Declaration Syntax
C# Visual Basic
public DataRow DataRow { get; }
Public ReadOnly Property DataRow As DataRow
    Get
Property Value
DataRow

Send comments on this topic to support@keyoti.com


SearchResult.DataRowEventHandler Delegate

SearchResult..::..DataRowEventHandler Delegate
API Documentation ► Keyoti.SearchEngine.Search ► SearchResult ► SearchResult..::..DataRowEventHandler
Keyoti SearchUnit v6
Handler delegate
Declaration Syntax
C# Visual Basic
public delegate void DataRowEventHandler(
    Object sender,
    SearchResult..::..DataRowEventArgs e
)
Public Delegate Sub DataRowEventHandler (
    sender As Object,
    e As SearchResult..::..DataRowEventArgs
)
Parameters
sender (Object)
e (SearchResult..::..DataRowEventArgs)


SearchResult.DataTableEventArgs Class

SearchResult..::..DataTableEventArgs Class
API Documentation ► Keyoti.SearchEngine.Search ► SearchResult ► SearchResult..::..DataTableEventArgs
Keyoti SearchUnit v6
Event args for DataTable event(s).
Declaration Syntax
C# Visual Basic
public class DataTableEventArgs : EventArgs
Public Class DataTableEventArgs
    Inherits EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SearchResult..::..DataTableEventArgs(DataTable) | New instance
 | DataTable | The table
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | SearchResult..::..DataTableEventArgs


SearchResult.DataTableEventArgs Constructor (table)

SearchResult..::..DataTableEventArgs Constructor (table)
API Documentation ► Keyoti.SearchEngine.Search ► SearchResult..::..DataTableEventArgs ► SearchResult..::..DataTableEventArgs(DataTable)
Keyoti SearchUnit v6
New instance
Declaration Syntax
C# Visual Basic
public DataTableEventArgs(
    DataTable table
)
Public Sub New (
    table As DataTable
)
Parameters
table (DataTable)


DataTable Property

DataTable Property
API Documentation ► Keyoti.SearchEngine.Search ► SearchResult..::..DataTableEventArgs ► DataTable
Keyoti SearchUnit v6
The table
Declaration Syntax
C# Visual Basic
public DataTable DataTable { get; }
Public ReadOnly Property DataTable As DataTable
    Get
Property Value
DataTable

Send comments on this topic to support@keyoti.com


SearchResult.DataTableEventHandler Delegate

SearchResult..::..DataTableEventHandler Delegate
API Documentation ► Keyoti.SearchEngine.Search ► SearchResult ► SearchResult..::..DataTableEventHandler
Keyoti SearchUnit v6
Handler delegate
Declaration Syntax
C# Visual Basic
public delegate void DataTableEventHandler(
    Object sender,
    SearchResult..::..DataTableEventArgs e
)
Public Delegate Sub DataTableEventHandler (
    sender As Object,
    e As SearchResult..::..DataTableEventArgs
)
Parameters
sender (Object)
e (SearchResult..::..DataTableEventArgs)


SortBy Class

SortBy Class
API Documentation ► Keyoti.SearchEngine.Search ► SortBy
Keyoti SearchUnit v6
Sort by definition.
Declaration Syntax
C# Visual Basic
public class SortBy
Public Class SortBy
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SortBy(String, ListSortDirection, SortBy..::..FieldDataType) | New
 | Direction | The sort direction, ascending means 0, 1, 2, 3.
 | Equals(Object) | (Inherited from Object.)
 | Field | The field to sort by, null for relevance.
 | FieldType | The field type, int, string, date
 | Finalize()()()() | (Inherited from Object.)
 | FromString(String) | Create an instance based on shorthand 'sortByString' (used by AJAX client).
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
SortBy

Send comments on this topic to support@keyoti.com


SortBy Constructor (field, direction, fieldType)

SortBy Constructor (field, direction, fieldType)
API Documentation ► Keyoti.SearchEngine.Search ► SortBy ► SortBy(String, ListSortDirection, SortBy..::..FieldDataType)
Keyoti SearchUnit v6
New
Declaration Syntax
C# Visual Basic
public SortBy(
    string field,
    ListSortDirection direction,
    SortBy..::..FieldDataType fieldType
)
Public Sub New (
    field As String,
    direction As ListSortDirection,
    fieldType As SortBy..::..FieldDataType
)
Parameters
field (String)
direction (ListSortDirection)
fieldType (SortBy..::..FieldDataType)


Direction Property

Direction Property
API Documentation ► Keyoti.SearchEngine.Search ► SortBy ► Direction
Keyoti SearchUnit v6
The sort direction, ascending means 0, 1, 2, 3.
Declaration Syntax
C# Visual Basic
public ListSortDirection Direction { get; set; }
Public Property Direction As ListSortDirection
    Get
    Set
Property Value
ListSortDirection

Send comments on this topic to support@keyoti.com


Field Property

Field Property
API Documentation ► Keyoti.SearchEngine.Search ► SortBy ► Field
Keyoti SearchUnit v6
The field to sort by, null for relevance.
Declaration Syntax
C# Visual Basic
public string Field { get; set; }
Public Property Field As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


FieldType Property

FieldType Property
API Documentation ► Keyoti.SearchEngine.Search ► SortBy ► FieldType
Keyoti SearchUnit v6
The field type, int, string, date
Declaration Syntax
C# Visual Basic
public SortBy..::..FieldDataType FieldType { get; set; }
Public Property FieldType As SortBy..::..FieldDataType
    Get
    Set
Property Value
SortBy..::..FieldDataType

Send comments on this topic to support@keyoti.com


FromString Method (sortByString)

FromString Method (sortByString)
API Documentation ► Keyoti.SearchEngine.Search ► SortBy ► FromString(String)
Keyoti SearchUnit v6
Create an instance based on shorthand 'sortByString' (used by AJAX client).
Declaration Syntax
C# Visual Basic
public static SortBy FromString(
    string sortByString
)
Public Shared Function FromString (
    sortByString As String
) As SortBy
Parameters
sortByString (String)
Eg. ASCfieldname => Field=fieldname, Direction=Ascending
Return Value
SortBy

Send comments on this topic to support@keyoti.com


SortBy.FieldDataType Enumeration

SortBy..::..FieldDataType Enumeration
API Documentation ► Keyoti.SearchEngine.Search ► SortBy ► SortBy..::..FieldDataType
Keyoti SearchUnit v6
Types of fields that can be sorted.
Declaration Syntax
C# Visual Basic
public enum FieldDataType
Public Enumeration FieldDataType
Members
Member | Description
Int | Integers
Decimal | Decimals
String | Strings
Date | Dates


WildcardWordElement Class

WildcardWordElement Class
API Documentation ► Keyoti.SearchEngine.Search ► WildcardWordElement
Keyoti SearchUnit v6
Represents a word element in the query which contains a wildcard.
Declaration Syntax
C# Visual Basic
public class WildcardWordElement : WordElement
Public Class WildcardWordElement
    Inherits WordElement
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WildcardWordElement(String, Configuration) | Creates a new WildcardWordElement
 | Configuration | The instance of the Configuration class that holds the settings to be used. (Inherited from Element.)
 | Content | Returns a string representing the content of the element, this should typically be; WordElement.Content => theWord NotWordElement.Content => -theWord GroupElement.Content => null PhraseElement.Content => thePhrase (no quotes) (Inherited from WordElement.)
 | CreateLexiconQueries(SearcherIO) | Creates the lexicon query(s) needed for this element (Overrides WordElement.CreateLexiconQueries(SearcherIO).)
 | elementQueryCollection | The lexicon queries used for the element (Inherited from Element.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetIgnoredWords()()()() | Returns the stop words from the original query that were ignored. (Inherited from WordElement.)
 | GetMatchingDocumentIDs(SearcherIO, IntHashtable, SearchOptions, Hashtable) | Gets all document IDs matching this element. (Overrides WordElement.GetMatchingDocumentIDs(SearcherIO, IntHashtable, SearchOptions, Hashtable).)
 | GetType()()()() | (Inherited from Object.)
 | IsStopWord()()()() | Whether is stop word, only Word elements can be stop words. (Inherited from WordElement.)
 | maximumWildMatchesToFind | Maximum wildcard matches to find
 | MemberwiseClone()()()() | (Inherited from Object.)
 | StringContainsWildCardToken(String, Configuration) | Determines if text contains the WildCardToken.
 | theWildCardType | The type of wildcard.
 | ToString()()()() | (Inherited from Object.)
 | WildCardToken | The string that will be taken to be wild. Default = "*"
 | WildCardType | The type of wildcard specified.
Inheritance Hierarchy
Object
 | Element
 |  | WordElement
 |  |  | WildcardWordElement
 |  |  |  | AsianWordElement


WildcardWordElement Constructor (word, configuration)

WildcardWordElement Constructor (word, configuration)
API Documentation ► Keyoti.SearchEngine.Search ► WildcardWordElement ► WildcardWordElement(String, Configuration)
Keyoti SearchUnit v6
Creates a new WildcardWordElement
Declaration Syntax
C# Visual Basic
public WildcardWordElement(
    string word,
    Configuration configuration
)
Public Sub New (
    word As String,
    configuration As Configuration
)
Parameters
word (String)
The word, including wildcard character(s)
configuration (Configuration)
The instance of the Configuration class that holds the settings to be used.
Remarks
If no WildCardToken is found in the string then the WildCardType is defaulted to contains.


CreateLexiconQueries Method (dataAccess)

CreateLexiconQueries Method (dataAccess)
API Documentation ► Keyoti.SearchEngine.Search ► WildcardWordElement ► CreateLexiconQueries(SearcherIO)
Keyoti SearchUnit v6
Creates the lexicon query(s) needed for this element
Declaration Syntax
C# Visual Basic
public override LexiconQueryCollection CreateLexiconQueries(
    SearcherIO dataAccess
)
Public Overrides Function CreateLexiconQueries (
    dataAccess As SearcherIO
) As LexiconQueryCollection
Parameters
dataAccess (SearcherIO)
The data access layer
Return Value
LexiconQueryCollection
A collection of queries needed

Send comments on this topic to support@keyoti.com


GetMatchingDocumentIDs Method (dataAccess, cumulativeWeights, searchOptions, objDocOc)

GetMatchingDocumentIDs Method (dataAccess, cumulativeWeights, searchOptions, objDocOc)
API Documentation ► Keyoti.SearchEngine.Search ► WildcardWordElement ► GetMatchingDocumentIDs(SearcherIO, IntHashtable, SearchOptions, Hashtable)
Keyoti SearchUnit v6
Gets all document IDs matching this element.
Declaration Syntax
C# Visual Basic
public override IntList GetMatchingDocumentIDs(
    SearcherIO dataAccess,
    IntHashtable cumulativeWeights,
    SearchOptions searchOptions,
    Hashtable objDocOc
)
Public Overrides Function GetMatchingDocumentIDs (
    dataAccess As SearcherIO,
    cumulativeWeights As IntHashtable,
    searchOptions As SearchOptions,
    objDocOc As Hashtable
) As IntList
Parameters
dataAccess (SearcherIO)
The data-access layer with the index.
cumulativeWeights (IntHashtable)
Hashtable passed to this method containing table of weights for occurrences (key=docID, value=word's weight in that doc).
searchOptions (SearchOptions)
Search options.
objDocOc (Hashtable)
Table of documents and their occurrence maps, this method adds the OccurrenceMap for this element to the table. key = this element, value = OccurrenceMap
Return Value
IntList
ArrayList of int document IDs

Send comments on this topic to support@keyoti.com


maximumWildMatchesToFind Field

maximumWildMatchesToFind Field
API Documentation ► Keyoti.SearchEngine.Search ► WildcardWordElement ► maximumWildMatchesToFind
Keyoti SearchUnit v6
Maximum wildcard matches to find
Declaration Syntax
C# Visual Basic
protected int maximumWildMatchesToFind
Protected maximumWildMatchesToFind As Integer
Field Value
Int32

Send comments on this topic to support@keyoti.com


StringContainsWildCardToken Method (text, configuration)

StringContainsWildCardToken Method (text, configuration)
API Documentation ► Keyoti.SearchEngine.Search ► WildcardWordElement ► StringContainsWildCardToken(String, Configuration)
Keyoti SearchUnit v6
Determines if text contains the WildCardToken.
Declaration Syntax
C# Visual Basic
public static bool StringContainsWildCardToken(
    string text,
    Configuration configuration
)
Public Shared Function StringContainsWildCardToken (
    text As String,
    configuration As Configuration
) As Boolean
Parameters
text (String)
configuration (Configuration)
Return Value
Boolean

Send comments on this topic to support@keyoti.com


theWildCardType Field

theWildCardType Field
API Documentation ► Keyoti.SearchEngine.Search ► WildcardWordElement ► theWildCardType
Keyoti SearchUnit v6
The type of wildcard.
Declaration Syntax
C# Visual Basic
protected LexiconSegmentMatchType theWildCardType
Protected theWildCardType As LexiconSegmentMatchType
Field Value
LexiconSegmentMatchType

Send comments on this topic to support@keyoti.com


WildCardToken Property

WildCardToken Property
API Documentation ► Keyoti.SearchEngine.Search ► WildcardWordElement ► WildCardToken
Keyoti SearchUnit v6
The string that will be taken to be wild. Default = "*"
Declaration Syntax
C# Visual Basic
public virtual string WildCardToken { get; set; }
Public Overridable Property WildCardToken As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


WildCardType Property

WildCardType Property
API Documentation ► Keyoti.SearchEngine.Search ► WildcardWordElement ► WildCardType
Keyoti SearchUnit v6
The type of wildcard specified.
Declaration Syntax
C# Visual Basic
public virtual LexiconSegmentMatchType WildCardType { get; }
Public Overridable ReadOnly Property WildCardType As LexiconSegmentMatchType
    Get
Property Value
LexiconSegmentMatchType

Send comments on this topic to support@keyoti.com


WordElement Class

WordElement Class
API Documentation ► Keyoti.SearchEngine.Search ► WordElement
Keyoti SearchUnit v6
Represents a word element in the query.
Declaration Syntax
C# Visual Basic
public class WordElement : Element
Public Class WordElement
    Inherits Element
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WordElement(String, Configuration) | Creates a new WordElement
 | Configuration | The instance of the Configuration class that holds the settings to be used. (Inherited from Element.)
 | Content | Returns a string representing the content of the element, this should typically be; WordElement.Content => theWord NotWordElement.Content => -theWord GroupElement.Content => null PhraseElement.Content => thePhrase (no quotes) (Overrides Element.Content.)
 | CreateLexiconQueries(SearcherIO) | Creates the LexiconQuery for this element. (Overrides Element.CreateLexiconQueries(SearcherIO).)
 | elementQueryCollection | The lexicon queries used for the element (Inherited from Element.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetIgnoredWords()()()() | Returns the stop words from the original query that were ignored. (Overrides Element.GetIgnoredWords()()()().)
 | GetMatchingDocumentIDs(SearcherIO, IntHashtable, SearchOptions, Hashtable) | Gets all document IDs matching this element. (Overrides Element.GetMatchingDocumentIDs(SearcherIO, IntHashtable, SearchOptions, Hashtable).)
 | GetType()()()() | (Inherited from Object.)
 | IsStopWord()()()() | Whether is stop word, only Word elements can be stop words. (Overrides Element.IsStopWord()()()().)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | Element
 |  | WordElement
 |  |  | WildcardWordElement


WordElement Constructor (word, configuration)

WordElement Constructor (word, configuration)
API Documentation ► Keyoti.SearchEngine.Search ► WordElement ► WordElement(String, Configuration)
Keyoti SearchUnit v6
Creates a new WordElement
Declaration Syntax
C# Visual Basic
public WordElement(
    string word,
    Configuration configuration
)
Public Sub New (
    word As String,
    configuration As Configuration
)
Parameters
word (String)
The word
configuration (Configuration)
The instance of the Configuration class that holds the settings to be used.


Content Property

Content Property
API Documentation ► Keyoti.SearchEngine.Search ► WordElement ► Content
Keyoti SearchUnit v6
Returns a string representing the content of the element, this should typically be;
WordElement.Content => theWord
NotWordElement.Content => -theWord
GroupElement.Content => null
PhraseElement.Content => thePhrase (no quotes)
Declaration Syntax
C# Visual Basic
public override string Content { get; }
Public Overrides ReadOnly Property Content As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


CreateLexiconQueries Method (dataAccess)

CreateLexiconQueries Method (dataAccess)
API Documentation ► Keyoti.SearchEngine.Search ► WordElement ► CreateLexiconQueries(SearcherIO)
Keyoti SearchUnit v6
Creates the LexiconQuery for this element.
Declaration Syntax
C# Visual Basic
public override LexiconQueryCollection CreateLexiconQueries(
    SearcherIO dataAccess
)
Public Overrides Function CreateLexiconQueries (
    dataAccess As SearcherIO
) As LexiconQueryCollection
Parameters
dataAccess (SearcherIO)
Return Value
LexiconQueryCollection

Send comments on this topic to support@keyoti.com


GetIgnoredWords Method

GetIgnoredWords Method
API Documentation ► Keyoti.SearchEngine.Search ► WordElement ► GetIgnoredWords()()()()
Keyoti SearchUnit v6
Returns the stop words from the original query that were ignored.
Declaration Syntax
C# Visual Basic
protected internal override StringList GetIgnoredWords()
Protected Friend Overrides Function GetIgnoredWords As StringList
Return Value
StringList

Send comments on this topic to support@keyoti.com


GetMatchingDocumentIDs Method (dataAccess, cumulativeWeights, searchOptions, objDocOc)

GetMatchingDocumentIDs Method (dataAccess, cumulativeWeights, searchOptions, objDocOc)
API Documentation ► Keyoti.SearchEngine.Search ► WordElement ► GetMatchingDocumentIDs(SearcherIO, IntHashtable, SearchOptions, Hashtable)
Keyoti SearchUnit v6
Gets all document IDs matching this element.
Declaration Syntax
C# Visual Basic
public override IntList GetMatchingDocumentIDs(
    SearcherIO dataAccess,
    IntHashtable cumulativeWeights,
    SearchOptions searchOptions,
    Hashtable objDocOc
)
Public Overrides Function GetMatchingDocumentIDs (
    dataAccess As SearcherIO,
    cumulativeWeights As IntHashtable,
    searchOptions As SearchOptions,
    objDocOc As Hashtable
) As IntList
Parameters
dataAccess (SearcherIO)
The data-access layer with the index.
cumulativeWeights (IntHashtable)
Hashtable passed to this method containing table of weights for occurrences (key=docID, value=word's weight in that doc).
searchOptions (SearchOptions)
Search options.
objDocOc (Hashtable)
Table of documents and their occurrence maps, this method adds the OccurrenceMap for this element to the table. key = this element, value = OccurrenceMap
Return Value
IntList
ArrayList of int document IDs

Send comments on this topic to support@keyoti.com


IsStopWord Method

IsStopWord Method
API Documentation ► Keyoti.SearchEngine.Search ► WordElement ► IsStopWord()()()()
Keyoti SearchUnit v6
Whether is stop word, only Word elements can be stop words.
Declaration Syntax
C# Visual Basic
protected internal override bool IsStopWord()
Protected Friend Overrides Function IsStopWord As Boolean
Return Value
Boolean

Send comments on this topic to support@keyoti.com


Keyoti.SearchEngine.Suggestions Namespace

Keyoti.SearchEngine.Suggestions Namespace
API Documentation ► Keyoti.SearchEngine.Suggestions
Keyoti SearchUnit v6
Spelling suggestions
Types
All Types Classes Enumerations Delegates
Icon | Type | Description
 | FoundSpellingErrorEventArgs | Event arguments for FoundSpellingError event.
 | FoundSpellingErrorEventHandler | Handler for FoundSpellingErrorEventArgs type.
 | SearchSuggestionsModel | Model layer class backing the SearchSuggestion Control.
 | SpellingSuggestionSource | Where to look for spelling suggestions for erroneous words.


FoundSpellingErrorEventArgs Class

FoundSpellingErrorEventArgs Class
API Documentation ► Keyoti.SearchEngine.Suggestions ► FoundSpellingErrorEventArgs
Keyoti SearchUnit v6
Event arguments for FoundSpellingError event.
Declaration Syntax
C# Visual Basic
public class FoundSpellingErrorEventArgs : EventArgs
Public Class FoundSpellingErrorEventArgs
    Inherits EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FoundSpellingErrorEventArgs(String, ArrayList) | Constructor
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Suggestions | A list of string suggestions for the word. The string in the first element will be used to provide the user's suggestion.
 | ToString()()()() | (Inherited from Object.)
 | Word | The word in the query expression that was misspelt.
Inheritance Hierarchy
Object
 | EventArgs
 |  | FoundSpellingErrorEventArgs

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FoundSpellingErrorEventArgs Constructor (misspelling, suggestions)

FoundSpellingErrorEventArgs Constructor (misspelling, suggestions)
API Documentation ► Keyoti.SearchEngine.Suggestions ► FoundSpellingErrorEventArgs ► FoundSpellingErrorEventArgs(String, ArrayList)
Keyoti SearchUnit v6
Constructor
Declaration Syntax
C# Visual Basic
public FoundSpellingErrorEventArgs(
    string misspelling,
    ArrayList suggestions
)
Public Sub New (
    misspelling As String,
    suggestions As ArrayList
)
Parameters
misspelling (String)
suggestions (ArrayList)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Suggestions Property

Suggestions Property
API Documentation ► Keyoti.SearchEngine.Suggestions ► FoundSpellingErrorEventArgs ► Suggestions
Keyoti SearchUnit v6
A list of string suggestions for the word. The string in the first element will be used to provide the user's suggestion.
Declaration Syntax
C# Visual Basic
public ArrayList Suggestions { get; }
Public ReadOnly Property Suggestions As ArrayList
    Get
Property Value
ArrayList
Remarks
Handlers of this event may modify this property inorder to customize the suggestions provided to the user.

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Word Property

Word Property
API Documentation ► Keyoti.SearchEngine.Suggestions ► FoundSpellingErrorEventArgs ► Word
Keyoti SearchUnit v6
The word in the query expression that was misspelt.
Declaration Syntax
C# Visual Basic
public string Word { get; }
Public ReadOnly Property Word As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FoundSpellingErrorEventHandler Delegate

FoundSpellingErrorEventHandler Delegate
API Documentation ► Keyoti.SearchEngine.Suggestions ► FoundSpellingErrorEventHandler
Keyoti SearchUnit v6
Handler for FoundSpellingErrorEventArgs type.
Declaration Syntax
C# Visual Basic
public delegate void FoundSpellingErrorEventHandler(
    Object sender,
    FoundSpellingErrorEventArgs e
)
Public Delegate Sub FoundSpellingErrorEventHandler (
    sender As Object,
    e As FoundSpellingErrorEventArgs
)
Parameters
sender (Object)
e (FoundSpellingErrorEventArgs)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SearchSuggestionsModel Class

SearchSuggestionsModel Class
API Documentation ► Keyoti.SearchEngine.Suggestions ► SearchSuggestionsModel
Keyoti SearchUnit v6
Model layer class backing the SearchSuggestion Control.
Declaration Syntax
C# Visual Basic
public class SearchSuggestionsModel
Public Class SearchSuggestionsModel
Members
All Members | Constructors | Methods | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SearchSuggestionsModel()()()() |
 | BuildSuggestedExpression(String, String, LanguageType, SpellingSuggestionSource, Configuration, Int32, GroupElement, String) |
 | CreateSuggestions(String) | Creates list of suggestions to be passed as argument to FoundSpellingError event, for finalization.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FoundSpellingError | Called when a spelling error is found - provides opportunity to adjust the suggestions.
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NeedSuggestionForWord(String) | Determines whether the word in the search query should be flagged and suggestions found for it.
 | numberOfSearchResults | The number of search results that the SearchResult control found.
 | OnFoundSpellingError(FoundSpellingErrorEventArgs) | Called when a misspelled word is found, raises the FoundSpellingError event.
 | ToString()()()() | (Inherited from Object.)
Remarks
Can be sub-classed to override default behavior.
Inheritance Hierarchy
Object
SearchSuggestionsModel

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SearchSuggestionsModel Constructor

SearchSuggestionsModel Constructor
API Documentation ► Keyoti.SearchEngine.Suggestions ► SearchSuggestionsModel ► SearchSuggestionsModel()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public SearchSuggestionsModel()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


BuildSuggestedExpression Method (mainDictionaryPath, customDictionaryPath, language, suggestionsSource, configuration, numberOfResults, group, query)

BuildSuggestedExpression Method (mainDictionaryPath, customDictionaryPath, language, suggestionsSource, configuration, numberOfResults, group, query)
API Documentation ► Keyoti.SearchEngine.Suggestions ► SearchSuggestionsModel ► BuildSuggestedExpression(String, String, LanguageType, SpellingSuggestionSource, Configuration, Int32, GroupElement, String)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public virtual string BuildSuggestedExpression(
    string mainDictionaryPath,
    string customDictionaryPath,
    LanguageType language,
    SpellingSuggestionSource suggestionsSource,
    Configuration configuration,
    int numberOfResults,
    GroupElement group,
    string query
)
Public Overridable Function BuildSuggestedExpression (
    mainDictionaryPath As String,
    customDictionaryPath As String,
    language As LanguageType,
    suggestionsSource As SpellingSuggestionSource,
    configuration As Configuration,
    numberOfResults As Integer,
    group As GroupElement,
    query As String
) As String
Parameters
mainDictionaryPath (String)
customDictionaryPath (String)
language (LanguageType)
suggestionsSource (SpellingSuggestionSource)
configuration (Configuration)
numberOfResults (Int32)
group (GroupElement)
query (String)
Return Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


CreateSuggestions Method (word)

CreateSuggestions Method (word)
API Documentation ► Keyoti.SearchEngine.Suggestions ► SearchSuggestionsModel ► CreateSuggestions(String)
Keyoti SearchUnit v6
Creates list of suggestions to be passed as argument to FoundSpellingError event, for finalization.
Declaration Syntax
C# Visual Basic
protected virtual ArrayList CreateSuggestions(
    string word
)
Protected Overridable Function CreateSuggestions (
    word As String
) As ArrayList
Parameters
word (String)
Word that suggestions are being found for.
Return Value
ArrayList
List of strings.

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FoundSpellingError Event

FoundSpellingError Event
API Documentation ► Keyoti.SearchEngine.Suggestions ► SearchSuggestionsModel ► FoundSpellingError
Keyoti SearchUnit v6
Called when a spelling error is found - provides opportunity to adjust the suggestions.
Declaration Syntax
C# Visual Basic
public event FoundSpellingErrorEventHandler FoundSpellingError
Public Event FoundSpellingError As FoundSpellingErrorEventHandler
Value
FoundSpellingErrorEventHandler

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


NeedSuggestionForWord Method (word)

NeedSuggestionForWord Method (word)
API Documentation ► Keyoti.SearchEngine.Suggestions ► SearchSuggestionsModel ► NeedSuggestionForWord(String)
Keyoti SearchUnit v6
Determines whether the word in the search query should be flagged and suggestions found for it.
Declaration Syntax
C# Visual Basic
protected virtual bool NeedSuggestionForWord(
    string word
)
Protected Overridable Function NeedSuggestionForWord (
    word As String
) As Boolean
Parameters
word (String)
A word in the search query.
Return Value
Boolean
True if the word should be flagged for suggestions.

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


numberOfSearchResults Field

numberOfSearchResults Field
API Documentation ► Keyoti.SearchEngine.Suggestions ► SearchSuggestionsModel ► numberOfSearchResults
Keyoti SearchUnit v6
The number of search results that the SearchResult control found.
Declaration Syntax
C# Visual Basic
protected int numberOfSearchResults
Protected numberOfSearchResults As Integer
Field Value
Int32

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


OnFoundSpellingError Method (eArgs)

OnFoundSpellingError Method (eArgs)
API Documentation ► Keyoti.SearchEngine.Suggestions ► SearchSuggestionsModel ► OnFoundSpellingError(FoundSpellingErrorEventArgs)
Keyoti SearchUnit v6
Called when a misspelled word is found, raises the FoundSpellingError event.
Declaration Syntax
C# Visual Basic
protected virtual void OnFoundSpellingError(
    FoundSpellingErrorEventArgs eArgs
)
Protected Overridable Sub OnFoundSpellingError (
    eArgs As FoundSpellingErrorEventArgs
)
Parameters
eArgs (FoundSpellingErrorEventArgs)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SpellingSuggestionSource Enumeration

SpellingSuggestionSource Enumeration
API Documentation ► Keyoti.SearchEngine.Suggestions ► SpellingSuggestionSource
Keyoti SearchUnit v6
Where to look for spelling suggestions for erroneous words.
Declaration Syntax
C# Visual Basic
public enum SpellingSuggestionSource
Public Enumeration SpellingSuggestionSource
Members
Member | Description
FromEventOnly | Fastest source (from internal perspective) - suggestions are only taken from the FoundSpellingErrorEventArgs.
PresetDictionary | Second fastest - suggestions are obtained from the internal dictionary (as specified by Language property).
SearchLexicon | Third fastest - suggestions are obtained from the current list of words which have been indexed. Speed varies greatly depending on size of lexicon (eg. roughly 1 second for 100,000 words).
PresetDictionaryAndOptionalSearchLexicon | Optimal (default) - uses the dictionary always, and the SearchLexicon only when no search results have been found.
PresetDictionaryAndSearchLexicon | Slowest - uses the preset-dictionary and the search-lexicon always.
Remarks
Care should be taken when using any option with "SearchLexicon" as this can become slow when the lexicon becomes very large (>100,000 entries).

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Keyoti.SearchEngine.Utils Namespace

Keyoti.SearchEngine.Utils Namespace
API Documentation ► Keyoti.SearchEngine.Utils
Keyoti SearchUnit v6
Utilities
Types
All Types Classes Delegates
Icon | Type | Description
 | BoolHashtable | Bool key/value hashtable
 | BoolList | Bool list wrapper.
 | CannotAddToListException | Thrown when a list is full.
 | ExternalAssemblyClass | Represents a class in an external assembly
 | ZipExtractor..::..ExtractedFileListener | Called when a file is extracted.
 | ZipExtractor..::..FileChooser | Returns true when the caller wants filename
 | HtmlHelper | Contains helper utilities for HTML.
 | IntArraysList | Int list wrapper.
 | IntHashtable | Int key/value hashtable
 | IntList | Int list wrapper.
 | IntListList | Int based list.
 | IsolatedStoreHandler | Handles isolated storage based on this assembly.
 | KeywordHitMapDictionary | Holds a map of query keywords and the number of matches inside a result document.
 | KeywordHits | Maps a keyword to number of matches inside of a result document for that keyword.
 | NameValueList | Holds a map of names and string values.
 | NameValuePair | Maps a keyword to number of matches inside of a result document for that keyword.
 | ResourceCredentials | Credentials used to log in to a web-site for example.
 | ResultItemList | ResultItem list wrapper.
 | SecurityGroupRecordList | SecurityGroupRecord list wrapper.
 | SSTCryptographer | String encrypter
 | StringList | String list wrapper.
 | UriComparer | Compares Uri objects
 | UriTools | Tools for URLs
 | ZipExtractor | Extracts file streams from ZIP archives.


BoolHashtable Class

BoolHashtable Class
API Documentation ► Keyoti.SearchEngine.Utils ► BoolHashtable
Keyoti SearchUnit v6
Bool key/value hashtable
Declaration Syntax
C# Visual Basic
public class BoolHashtable
Public Class BoolHashtable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BoolHashtable()()()() | Creates a new occurrence map.
 | Add(Int32, Boolean) | Add an item
 | Clear()()()() | Clear the list
 | ContainsKey(Int32) | Whether the table contains a key
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Item[([( Int32])]) | List occurrence IDs (bool) for document with specified ID.
 | Keys | All document IDs in this map.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
BoolHashtable

Send comments on this topic to support@keyoti.com


BoolHashtable Constructor

BoolHashtable Constructor
API Documentation ► Keyoti.SearchEngine.Utils ► BoolHashtable ► BoolHashtable()()()()
Keyoti SearchUnit v6
Creates a new occurrence map.
Declaration Syntax
C# Visual Basic
public BoolHashtable()
Public Sub New

Send comments on this topic to support@keyoti.com


Add Method (key, value)

Add Method (key, value)
API Documentation ► Keyoti.SearchEngine.Utils ► BoolHashtable ► Add(Int32, Boolean)
Keyoti SearchUnit v6
Add an item
Declaration Syntax
C# Visual Basic
public virtual void Add(
    int key,
    bool value
)
Public Overridable Sub Add (
    key As Integer,
    value As Boolean
)
Parameters
key (Int32)
value (Boolean)


Clear Method

Clear Method
API Documentation ► Keyoti.SearchEngine.Utils ► BoolHashtable ► Clear()()()()
Keyoti SearchUnit v6
Clear the list
Declaration Syntax
C# Visual Basic
public void Clear()
Public Sub Clear

Send comments on this topic to support@keyoti.com


ContainsKey Method (key)

ContainsKey Method (key)
API Documentation ► Keyoti.SearchEngine.Utils ► BoolHashtable ► ContainsKey(Int32)
Keyoti SearchUnit v6
Whether the table contains a key
Declaration Syntax
C# Visual Basic
public bool ContainsKey(
    int key
)
Public Function ContainsKey (
    key As Integer
) As Boolean
Parameters
key (Int32)
Return Value
Boolean

Send comments on this topic to support@keyoti.com


Item Property (docID)

Item Property (docID)
API Documentation ► Keyoti.SearchEngine.Utils ► BoolHashtable ► Item[([( Int32])])
Keyoti SearchUnit v6
List occurrence IDs (bool) for document with specified ID.
Declaration Syntax
C# Visual Basic
public virtual bool this[
    int docID
] { get; set; }
Public Overridable Default Property Item (
    docID As Integer
) As Boolean
    Get
    Set
Parameters
docID (Int32)
Property Value
Boolean

Send comments on this topic to support@keyoti.com


Keys Property

Keys Property
API Documentation ► Keyoti.SearchEngine.Utils ► BoolHashtable ► Keys
Keyoti SearchUnit v6
All document IDs in this map.
Declaration Syntax
C# Visual Basic
public virtual IntList Keys { get; }
Public Overridable ReadOnly Property Keys As IntList
    Get
Property Value
IntList

Send comments on this topic to support@keyoti.com


BoolList Class

BoolList Class
API Documentation ► Keyoti.SearchEngine.Utils ► BoolList
Keyoti SearchUnit v6
Bool list wrapper.
Declaration Syntax
C# Visual Basic
public class BoolList : List<bool>
Public Class BoolList
    Inherits List(Of Boolean)
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BoolList()()()() | New
 | BoolList(Int32) | New
 | Add(T) | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | AddRange(IEnumerable<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | AsReadOnly()()()() | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | BinarySearch(T) | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | Capacity | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | Clear()()()() | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | Contains(T) | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | ConvertAll<(Of <<'(TOutput>)>>)(Converter<(Of <<'(T, TOutput>)>>)) | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | Count | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | Equals(Object) | (Inherited from Object.)
 | Exists(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | Finalize()()()() | (Inherited from Object.)
 | Find(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | FindAll(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | FindLast(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | ForEach(Action<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | GetEnumerator()()()() | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetRange(Int32, Int32) | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(T) | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | IndexOf(T, Int32) | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | Insert(Int32, T) | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | InsertRange(Int32, IEnumerable<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | Item[([( Int32])]) | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | LastIndexOf(T) | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Remove(T) | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | RemoveAll(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | RemoveAt(Int32) | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | RemoveRange(Int32, Int32) | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | Reverse()()()() | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | Sort()()()() | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | ToArray()()()() | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | ToCommaDelimitedBool()()()() | Generates a comma delimited string representation for human consumption.
 | ToString()()()() | (Inherited from Object.)
 | TrimExcess()()()() | (Inherited from List <(Of <(<' Boolean >)>)>.)
 | TrueForAll(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Boolean >)>)>.)
Inheritance Hierarchy
Object
 | List <(Of <(<' Boolean >)>)>
 |  | BoolList


BoolList Constructor

BoolList Constructor
API Documentation ► Keyoti.SearchEngine.Utils ► BoolList ► BoolList()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | BoolList()()()() | New
 | BoolList(Int32) | New


BoolList Constructor

BoolList Constructor
API Documentation ► Keyoti.SearchEngine.Utils ► BoolList ► BoolList()()()()
Keyoti SearchUnit v6
New
Declaration Syntax
C# Visual Basic
public BoolList()
Public Sub New

Send comments on this topic to support@keyoti.com


BoolList Constructor (c)

BoolList Constructor (c)
API Documentation ► Keyoti.SearchEngine.Utils ► BoolList ► BoolList(Int32)
Keyoti SearchUnit v6
New
Declaration Syntax
C# Visual Basic
public BoolList(
    int c
)
Public Sub New (
    c As Integer
)
Parameters
c (Int32)
Initial capacity

Send comments on this topic to support@keyoti.com


ToCommaDelimitedBool Method

ToCommaDelimitedBool Method
API Documentation ► Keyoti.SearchEngine.Utils ► BoolList ► ToCommaDelimitedBool()()()()
Keyoti SearchUnit v6
Generates a comma delimited string representation for human consumption.
Declaration Syntax
C# Visual Basic
public string ToCommaDelimitedBool()
Public Function ToCommaDelimitedBool As String
Return Value
String

Send comments on this topic to support@keyoti.com


CannotAddToListException Class

CannotAddToListException Class
API Documentation ► Keyoti.SearchEngine.Utils ► CannotAddToListException
Keyoti SearchUnit v6
Thrown when a list is full.
Declaration Syntax
C# Visual Basic
public class CannotAddToListException : ApplicationException
Public Class CannotAddToListException
    Inherits ApplicationException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CannotAddToListException(String) | New instance.
 | Data | (Inherited from Exception.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetBaseException()()()() | (Inherited from Exception.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | (Inherited from Exception.)
 | GetType()()()() | (Inherited from Exception.)
 | HelpLink | (Inherited from Exception.)
 | HResult | (Inherited from Exception.)
 | InnerException | (Inherited from Exception.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from Exception.)
 | Source | (Inherited from Exception.)
 | StackTrace | (Inherited from Exception.)
 | TargetSite | (Inherited from Exception.)
 | ToString()()()() | (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | ApplicationException
 |  |  | CannotAddToListException


CannotAddToListException Constructor (message)

CannotAddToListException Constructor (message)
API Documentation ► Keyoti.SearchEngine.Utils ► CannotAddToListException ► CannotAddToListException(String)
Keyoti SearchUnit v6
New instance.
Declaration Syntax
C# Visual Basic
public CannotAddToListException(
    string message
)
Public Sub New (
    message As String
)
Parameters
message (String)


ExternalAssemblyClass Class

ExternalAssemblyClass Class
API Documentation ► Keyoti.SearchEngine.Utils ► ExternalAssemblyClass
Keyoti SearchUnit v6
Represents a class in an external assembly
Declaration Syntax
C# Visual Basic
public class ExternalAssemblyClass
Public Class ExternalAssemblyClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExternalAssemblyClass(String, String) | New instance
 | AssemblyPath | Path to the assembly
 | ClassName | Name of the class
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
ExternalAssemblyClass

Send comments on this topic to support@keyoti.com


ExternalAssemblyClass Constructor (assemblyPath, className)

ExternalAssemblyClass Constructor (assemblyPath, className)
API Documentation ► Keyoti.SearchEngine.Utils ► ExternalAssemblyClass ► ExternalAssemblyClass(String, String)
Keyoti SearchUnit v6
New instance
Declaration Syntax
C# Visual Basic
public ExternalAssemblyClass(
    string assemblyPath,
    string className
)
Public Sub New (
    assemblyPath As String,
    className As String
)
Parameters
assemblyPath (String)
The path to the assembly
className (String)
The name of the class

Send comments on this topic to support@keyoti.com


AssemblyPath Property

AssemblyPath Property
API Documentation ► Keyoti.SearchEngine.Utils ► ExternalAssemblyClass ► AssemblyPath
Keyoti SearchUnit v6
Path to the assembly
Declaration Syntax
C# Visual Basic
public string AssemblyPath { get; }
Public ReadOnly Property AssemblyPath As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


ClassName Property

ClassName Property
API Documentation ► Keyoti.SearchEngine.Utils ► ExternalAssemblyClass ► ClassName
Keyoti SearchUnit v6
Name of the class
Declaration Syntax
C# Visual Basic
public string ClassName { get; }
Public ReadOnly Property ClassName As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com


HtmlHelper Class

HtmlHelper Class
API Documentation ► Keyoti.SearchEngine.Utils ► HtmlHelper
Keyoti SearchUnit v6
Contains helper utilities for HTML.
Declaration Syntax
C# Visual Basic
public class HtmlHelper
Public Class HtmlHelper
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | HtmlHelper()()()() |
 | ConvertEntity(String) | Converts a HTML entity to a character
 | ConvertEntity(String, Boolean, Int32, Int32) | End pos is the char after the trailing ';'
 | convertHtmlEntities(String) | Converts HTML entity codes to their Unicode characters
 | convertHtmlEntities(String, Boolean) | Converts HTML entity codes to their Unicode characters
 | Equals(Object) | (Inherited from Object.)
 | ExtractPlainText(String, Configuration) | Extracts plain text from html
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
HtmlHelper

Send comments on this topic to support@keyoti.com


HtmlHelper Constructor

HtmlHelper Constructor
API Documentation ► Keyoti.SearchEngine.Utils ► HtmlHelper ► HtmlHelper()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public HtmlHelper()
Public Sub New

Send comments on this topic to support@keyoti.com


ConvertEntity Method

ConvertEntity Method
API Documentation ► Keyoti.SearchEngine.Utils ► HtmlHelper ► ConvertEntity()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | ConvertEntity(String) | Converts a HTML entity to a character
 | ConvertEntity(String, Boolean, Int32, Int32) | End pos is the char after the trailing ';'


ConvertEntity Method (text)

ConvertEntity Method (text)
API Documentation ► Keyoti.SearchEngine.Utils ► HtmlHelper ► ConvertEntity(String)
Keyoti SearchUnit v6
Converts a HTML entity to a character
Declaration Syntax
C# Visual Basic
public static string ConvertEntity(
    string text
)
Public Shared Function ConvertEntity (
    text As String
) As String
Parameters
text (String)
Return Value
String

Send comments on this topic to support@keyoti.com


ConvertEntity Method (text, convertAMP, startPos, endPos)

ConvertEntity Method (text, convertAMP, startPos, endPos)
API Documentation ► Keyoti.SearchEngine.Utils ► HtmlHelper ► ConvertEntity(String, Boolean, Int32, Int32)
Keyoti SearchUnit v6
End pos is the char after the trailing ';'
Declaration Syntax
C# Visual Basic
public static string ConvertEntity(
    string text,
    bool convertAMP,
    int startPos,
    int endPos
)
Public Shared Function ConvertEntity (
    text As String,
    convertAMP As Boolean,
    startPos As Integer,
    endPos As Integer
) As String
Parameters
text (String)
convertAMP (Boolean)
startPos (Int32)
endPos (Int32)
Return Value
String

Send comments on this topic to support@keyoti.com


convertHtmlEntities Method

convertHtmlEntities Method
API Documentation ► Keyoti.SearchEngine.Utils ► HtmlHelper ► convertHtmlEntities()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | convertHtmlEntities(String) | Converts HTML entity codes to their Unicode characters
 | convertHtmlEntities(String, Boolean) | Converts HTML entity codes to their Unicode characters


convertHtmlEntities Method (text)

convertHtmlEntities Method (text)
API Documentation ► Keyoti.SearchEngine.Utils ► HtmlHelper ► convertHtmlEntities(String)
Keyoti SearchUnit v6
Converts HTML entity codes to their Unicode characters
Declaration Syntax
C# Visual Basic
public static string convertHtmlEntities(
    string text
)
Public Shared Function convertHtmlEntities (
    text As String
) As String
Parameters
text (String)
Return Value
String

Send comments on this topic to support@keyoti.com


convertHtmlEntities Method (text, convertAMP)

convertHtmlEntities Method (text, convertAMP)
API Documentation ► Keyoti.SearchEngine.Utils ► HtmlHelper ► convertHtmlEntities(String, Boolean)
Keyoti SearchUnit v6
Converts HTML entity codes to their Unicode characters
Declaration Syntax
C# Visual Basic
public static string convertHtmlEntities(
    string text,
    bool convertAMP
)
Public Shared Function convertHtmlEntities (
    text As String,
    convertAMP As Boolean
) As String
Parameters
text (String)
The text containing the entities to convert.
convertAMP (Boolean)
Whether to convert &amp; entities to &
Return Value
String

Send comments on this topic to support@keyoti.com


ExtractPlainText Method (html, config)

ExtractPlainText Method (html, config)
API Documentation ► Keyoti.SearchEngine.Utils ► HtmlHelper ► ExtractPlainText(String, Configuration)
Keyoti SearchUnit v6
Extracts plain text from html
Declaration Syntax
C# Visual Basic
public static string ExtractPlainText(
    string html,
    Configuration config
)
Public Shared Function ExtractPlainText (
    html As String,
    config As Configuration
) As String
Parameters
html (String)
config (Configuration)
Return Value
String

Send comments on this topic to support@keyoti.com


IntArraysList Class

IntArraysList Class
API Documentation ► Keyoti.SearchEngine.Utils ► IntArraysList
Keyoti SearchUnit v6
Int list wrapper.
Declaration Syntax
C# Visual Basic
public class IntArraysList : List<int[]>
Public Class IntArraysList
    Inherits List(Of Integer())
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IntArraysList()()()() | New
 | IntArraysList(Int32) | New
 | Add(T) | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | AddRange(IEnumerable<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | AsReadOnly()()()() | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | BinarySearch(T) | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | Capacity | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | Clear()()()() | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | Contains(T) | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | ConvertAll<(Of <<'(TOutput>)>>)(Converter<(Of <<'(T, TOutput>)>>)) | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | Count | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | Equals(Object) | (Inherited from Object.)
 | Exists(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | Finalize()()()() | (Inherited from Object.)
 | Find(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | FindAll(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | FindLast(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | ForEach(Action<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | GetEnumerator()()()() | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetRange(Int32, Int32) | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(T) | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | IndexOf(T, Int32) | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | Insert(Int32, T) | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | InsertRange(Int32, IEnumerable<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | Item[([( Int32])]) | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | LastIndexOf(T) | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Remove(T) | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | RemoveAll(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | RemoveAt(Int32) | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | RemoveRange(Int32, Int32) | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | Reverse()()()() | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | Reverse(Int32, Int32) | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | Sort()()()() | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | ToArray()()()() | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | ToString()()()() | (Inherited from Object.)
 | TrimExcess()()()() | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
 | TrueForAll(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<'array< Int32 >[]()[][]>)>)>.)
Inheritance Hierarchy
Object
 | List <(Of <(<'array< Int32 >[]()[][]>)>)>
 |  | IntArraysList


IntArraysList Constructor

IntArraysList Constructor
API Documentation ► Keyoti.SearchEngine.Utils ► IntArraysList ► IntArraysList()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | IntArraysList()()()() | New
 | IntArraysList(Int32) | New


IntArraysList Constructor

IntArraysList Constructor
API Documentation ► Keyoti.SearchEngine.Utils ► IntArraysList ► IntArraysList()()()()
Keyoti SearchUnit v6
New
Declaration Syntax
C# Visual Basic
public IntArraysList()
Public Sub New

Send comments on this topic to support@keyoti.com


IntArraysList Constructor (c)

IntArraysList Constructor (c)
API Documentation ► Keyoti.SearchEngine.Utils ► IntArraysList ► IntArraysList(Int32)
Keyoti SearchUnit v6
New
Declaration Syntax
C# Visual Basic
public IntArraysList(
    int c
)
Public Sub New (
    c As Integer
)
Parameters
c (Int32)
Initial capacity

Send comments on this topic to support@keyoti.com


IntHashtable Class

IntHashtable Class
API Documentation ► Keyoti.SearchEngine.Utils ► IntHashtable
Keyoti SearchUnit v6
Int key/value hashtable
Declaration Syntax
C# Visual Basic
public class IntHashtable
Public Class IntHashtable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IntHashtable()()()() | Creates a new occurrence map.
 | Add(Int32, Int32) | Add an item
 | Clear()()()() | Clear the list
 | Contains(Int32) | Whether the document with ID docID is contained in this map.
 | ContainsKey(Int32) | Whether the table contains a key
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Item[([( Int32])]) | List occurrence IDs (int) for document with specified ID.
 | Keys | All document IDs in this map.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
IntHashtable

Send comments on this topic to support@keyoti.com


IntHashtable Constructor

IntHashtable Constructor
API Documentation ► Keyoti.SearchEngine.Utils ► IntHashtable ► IntHashtable()()()()
Keyoti SearchUnit v6
Creates a new occurrence map.
Declaration Syntax
C# Visual Basic
public IntHashtable()
Public Sub New

Send comments on this topic to support@keyoti.com


Add Method (key, value)

Add Method (key, value)
API Documentation ► Keyoti.SearchEngine.Utils ► IntHashtable ► Add(Int32, Int32)
Keyoti SearchUnit v6
Add an item
Declaration Syntax
C# Visual Basic
public virtual void Add(
    int key,
    int value
)
Public Overridable Sub Add (
    key As Integer,
    value As Integer
)
Parameters
key (Int32)
value (Int32)


Clear Method

Clear Method
API Documentation ► Keyoti.SearchEngine.Utils ► IntHashtable ► Clear()()()()
Keyoti SearchUnit v6
Clear the list
Declaration Syntax
C# Visual Basic
public void Clear()
Public Sub Clear

Send comments on this topic to support@keyoti.com


Contains Method (v)

Contains Method (v)
API Documentation ► Keyoti.SearchEngine.Utils ► IntHashtable ► Contains(Int32)
Keyoti SearchUnit v6
Whether the document with ID docID is contained in this map.
Declaration Syntax
C# Visual Basic
public virtual bool Contains(
    int v
)
Public Overridable Function Contains (
    v As Integer
) As Boolean
Parameters
v (Int32)
Return Value
Boolean

Send comments on this topic to support@keyoti.com


ContainsKey Method (key)

ContainsKey Method (key)
API Documentation ► Keyoti.SearchEngine.Utils ► IntHashtable ► ContainsKey(Int32)
Keyoti SearchUnit v6
Whether the table contains a key
Declaration Syntax
C# Visual Basic
public bool ContainsKey(
    int key
)
Public Function ContainsKey (
    key As Integer
) As Boolean
Parameters
key (Int32)
Return Value
Boolean

Send comments on this topic to support@keyoti.com


Item Property (docID)

Item Property (docID)
API Documentation ► Keyoti.SearchEngine.Utils ► IntHashtable ► Item[([( Int32])])
Keyoti SearchUnit v6
List occurrence IDs (int) for document with specified ID.
Declaration Syntax
C# Visual Basic
public virtual int this[
    int docID
] { get; set; }
Public Overridable Default Property Item (
    docID As Integer
) As Integer
    Get
    Set
Parameters
docID (Int32)
Property Value
Int32

Send comments on this topic to support@keyoti.com


Keys Property

Keys Property
API Documentation ► Keyoti.SearchEngine.Utils ► IntHashtable ► Keys
Keyoti SearchUnit v6
All document IDs in this map.
Declaration Syntax
C# Visual Basic
public virtual IntList Keys { get; }
Public Overridable ReadOnly Property Keys As IntList
    Get
Property Value
IntList

Send comments on this topic to support@keyoti.com


IntList Class

IntList Class
API Documentation ► Keyoti.SearchEngine.Utils ► IntList
Keyoti SearchUnit v6
Int list wrapper.
Declaration Syntax
C# Visual Basic
public class IntList : List<int>
Public Class IntList
    Inherits List(Of Integer)
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IntList()()()() | New
 | IntList(Int32) | New
 | Add(T) | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | AddRange(IEnumerable<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | AsReadOnly()()()() | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | BinarySearch(T) | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | Capacity | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | Clear()()()() | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | Contains(T) | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | ConvertAll<(Of <<'(TOutput>)>>)(Converter<(Of <<'(T, TOutput>)>>)) | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | Count | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | Equals(Object) | (Inherited from Object.)
 | Exists(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | Finalize()()()() | (Inherited from Object.)
 | Find(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | FindAll(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | FindLast(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | ForEach(Action<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | GetEnumerator()()()() | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetRange(Int32, Int32) | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(T) | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | IndexOf(T, Int32) | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | Insert(Int32, T) | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | InsertRange(Int32, IEnumerable<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | Item[([( Int32])]) | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | LastIndexOf(T) | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Remove(T) | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | RemoveAll(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | RemoveAt(Int32) | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | RemoveRange(Int32, Int32) | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | Reverse()()()() | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | Sort()()()() | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | ToArray()()()() | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | ToCommaDelimitedInt()()()() | Generates a comma delimited string representation for human consumption.
 | ToString()()()() | (Inherited from Object.)
 | TrimExcess()()()() | (Inherited from List <(Of <(<' Int32 >)>)>.)
 | TrueForAll(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' Int32 >)>)>.)
Inheritance Hierarchy
Object
 | List <(Of <(<' Int32 >)>)>
 |  | IntList


IntList Constructor

IntList Constructor
API Documentation ► Keyoti.SearchEngine.Utils ► IntList ► IntList()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | IntList()()()() | New
 | IntList(Int32) | New


IntList Constructor

IntList Constructor
API Documentation ► Keyoti.SearchEngine.Utils ► IntList ► IntList()()()()
Keyoti SearchUnit v6
New
Declaration Syntax
C# Visual Basic
public IntList()
Public Sub New

Send comments on this topic to support@keyoti.com


IntList Constructor (c)

IntList Constructor (c)
API Documentation ► Keyoti.SearchEngine.Utils ► IntList ► IntList(Int32)
Keyoti SearchUnit v6
New
Declaration Syntax
C# Visual Basic
public IntList(
    int c
)
Public Sub New (
    c As Integer
)
Parameters
c (Int32)
Initial capacity

Send comments on this topic to support@keyoti.com


ToCommaDelimitedInt Method

ToCommaDelimitedInt Method
API Documentation ► Keyoti.SearchEngine.Utils ► IntList ► ToCommaDelimitedInt()()()()
Keyoti SearchUnit v6
Generates a comma delimited string representation for human consumption.
Declaration Syntax
C# Visual Basic
public string ToCommaDelimitedInt()
Public Function ToCommaDelimitedInt As String
Return Value
String

Send comments on this topic to support@keyoti.com


IntListList Class

IntListList Class
API Documentation ► Keyoti.SearchEngine.Utils ► IntListList
Keyoti SearchUnit v6
Int based list.
Declaration Syntax
C# Visual Basic
public class IntListList : ArrayList
Public Class IntListList
    Inherits ArrayList
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IntListList()()()() | New
 | IntListList(Int32) | New
 | Add(Object) | (Inherited from ArrayList.)
 | AddRange(ICollection) | (Inherited from ArrayList.)
 | BinarySearch(Int32, Int32, Object, IComparer) | (Inherited from ArrayList.)
 | BinarySearch(Object) | (Inherited from ArrayList.)
 | BinarySearch(Object, IComparer) | (Inherited from ArrayList.)
 | Capacity | (Inherited from ArrayList.)
 | Clear()()()() | (Inherited from ArrayList.)
 | Clone()()()() | (Inherited from ArrayList.)
 | Contains(Object) | (Inherited from ArrayList.)
 | CopyTo(Array) | (Inherited from ArrayList.)
 | CopyTo(Array, Int32) | (Inherited from ArrayList.)
 | CopyTo(Int32, Array, Int32, Int32) | (Inherited from ArrayList.)
 | Count | (Inherited from ArrayList.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from ArrayList.)
 | GetEnumerator(Int32, Int32) | (Inherited from ArrayList.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetRange(Int32, Int32) | (Inherited from ArrayList.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(Object) | (Inherited from ArrayList.)
 | IndexOf(Object, Int32) | (Inherited from ArrayList.)
 | IndexOf(Object, Int32, Int32) | (Inherited from ArrayList.)
 | Insert(Int32, Object) | (Inherited from ArrayList.)
 | InsertRange(Int32, ICollection) | (Inherited from ArrayList.)
 | IsFixedSize | (Inherited from ArrayList.)
 | IsReadOnly | (Inherited from ArrayList.)
 | IsSynchronized | (Inherited from ArrayList.)
 | Item[([( Int32])]) | Item from the collection
 | LastIndexOf(Object) | (Inherited from ArrayList.)
 | LastIndexOf(Object, Int32) | (Inherited from ArrayList.)
 | LastIndexOf(Object, Int32, Int32) | (Inherited from ArrayList.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Remove(Object) | (Inherited from ArrayList.)
 | RemoveAt(Int32) | (Inherited from ArrayList.)
 | RemoveRange(Int32, Int32) | (Inherited from ArrayList.)
 | Reverse()()()() | (Inherited from ArrayList.)
 | Reverse(Int32, Int32) | (Inherited from ArrayList.)
 | SetRange(Int32, ICollection) | (Inherited from ArrayList.)
 | Sort()()()() | (Inherited from ArrayList.)
 | Sort(IComparer) | (Inherited from ArrayList.)
 | Sort(Int32, Int32, IComparer) | (Inherited from ArrayList.)
 | SyncRoot | (Inherited from ArrayList.)
 | ToArray()()()() | (Inherited from ArrayList.)
 | ToArray(Type) | (Inherited from ArrayList.)
 | ToString()()()() | (Inherited from Object.)
 | TrimToSize()()()() | (Inherited from ArrayList.)
Inheritance Hierarchy
Object
 | ArrayList
 |  | IntListList


IntListList Constructor

IntListList Constructor
API Documentation ► Keyoti.SearchEngine.Utils ► IntListList ► IntListList()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | IntListList()()()() | New
 | IntListList(Int32) | New


IntListList Constructor

IntListList Constructor
API Documentation ► Keyoti.SearchEngine.Utils ► IntListList ► IntListList()()()()
Keyoti SearchUnit v6
New
Declaration Syntax
C# Visual Basic
public IntListList()
Public Sub New

Send comments on this topic to support@keyoti.com


IntListList Constructor (c)

IntListList Constructor (c)
API Documentation ► Keyoti.SearchEngine.Utils ► IntListList ► IntListList(Int32)
Keyoti SearchUnit v6
New
Declaration Syntax
C# Visual Basic
public IntListList(
    int c
)
Public Sub New (
    c As Integer
)
Parameters
c (Int32)
Initial capacity

Send comments on this topic to support@keyoti.com


Item Property (i)

Item Property (i)
API Documentation ► Keyoti.SearchEngine.Utils ► IntListList ► Item[([( Int32])])
Keyoti SearchUnit v6
Item from the collection
Declaration Syntax
C# Visual Basic
public IntList this[
    int i
] { get; set; }
Public Default Property Item (
    i As Integer
) As IntList
    Get
    Set
Parameters
i (Int32)
Property Value
IntList

Send comments on this topic to support@keyoti.com


IsolatedStoreHandler Class

IsolatedStoreHandler Class
API Documentation ► Keyoti.SearchEngine.Utils ► IsolatedStoreHandler
Keyoti SearchUnit v6
Handles isolated storage based on this assembly.
Declaration Syntax
C# Visual Basic
public class IsolatedStoreHandler
Public Class IsolatedStoreHandler
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | IsolatedStoreHandler()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetMachineStoreForAssembly()()()() | Gets the machine store
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
IsolatedStoreHandler

Send comments on this topic to support@keyoti.com


IsolatedStoreHandler Constructor

IsolatedStoreHandler Constructor
API Documentation ► Keyoti.SearchEngine.Utils ► IsolatedStoreHandler ► IsolatedStoreHandler()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public IsolatedStoreHandler()
Public Sub New

Send comments on this topic to support@keyoti.com


GetMachineStoreForAssembly Method

GetMachineStoreForAssembly Method
API Documentation ► Keyoti.SearchEngine.Utils ► IsolatedStoreHandler ► GetMachineStoreForAssembly()()()()
Keyoti SearchUnit v6
Gets the machine store
Declaration Syntax
C# Visual Basic
public static IsolatedStorageFile GetMachineStoreForAssembly()
Public Shared Function GetMachineStoreForAssembly As IsolatedStorageFile
Return Value
IsolatedStorageFile

Send comments on this topic to support@keyoti.com


KeywordHitMapDictionary Class

KeywordHitMapDictionary Class
API Documentation ► Keyoti.SearchEngine.Utils ► KeywordHitMapDictionary
Keyoti SearchUnit v6
Holds a map of query keywords and the number of matches inside a result document.
Declaration Syntax
C# Visual Basic
public class KeywordHitMapDictionary : List<KeywordHits>
Public Class KeywordHitMapDictionary
    Inherits List(Of KeywordHits)
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | KeywordHitMapDictionary(Int32) | New
 | Add(T) | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | AddRange(IEnumerable<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | AsReadOnly()()()() | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | BinarySearch(T) | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | Capacity | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | Clear()()()() | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | Contains(T) | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | ConvertAll<(Of <<'(TOutput>)>>)(Converter<(Of <<'(T, TOutput>)>>)) | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | Count | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | Equals(Object) | (Inherited from Object.)
 | Exists(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | Finalize()()()() | (Inherited from Object.)
 | Find(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | FindAll(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | FindLast(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | ForEach(Action<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | GetEnumerator()()()() | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetRange(Int32, Int32) | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(T) | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | IndexOf(T, Int32) | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | Insert(Int32, T) | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | InsertRange(Int32, IEnumerable<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | Item[([( Int32])]) | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | LastIndexOf(T) | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Remove(T) | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | RemoveAll(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | RemoveAt(Int32) | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | RemoveRange(Int32, Int32) | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | Reverse()()()() | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | Sort()()()() | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | ToArray()()()() | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | ToString()()()() | Returns a user friendly string representation. (Overrides Object.ToString()()()().)
 | TrimExcess()()()() | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
 | TrueForAll(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' KeywordHits >)>)>.)
Inheritance Hierarchy
Object
 | List <(Of <(<' KeywordHits >)>)>
 |  | KeywordHitMapDictionary


KeywordHitMapDictionary Constructor (capacity)

KeywordHitMapDictionary Constructor (capacity)
API Documentation ► Keyoti.SearchEngine.Utils ► KeywordHitMapDictionary ► KeywordHitMapDictionary(Int32)
Keyoti SearchUnit v6
New
Declaration Syntax
C# Visual Basic
public KeywordHitMapDictionary(
    int capacity
)
Public Sub New (
    capacity As Integer
)
Parameters
capacity (Int32)


ToString Method

ToString Method
API Documentation ► Keyoti.SearchEngine.Utils ► KeywordHitMapDictionary ► ToString()()()()
Keyoti SearchUnit v6
Returns a user friendly string representation.
Declaration Syntax
C# Visual Basic
public override string ToString()
Public Overrides Function ToString As String
Return Value
String

Send comments on this topic to support@keyoti.com


KeywordHits Class

KeywordHits Class
API Documentation ► Keyoti.SearchEngine.Utils ► KeywordHits
Keyoti SearchUnit v6
Maps a keyword to number of matches inside of a result document for that keyword.
Declaration Syntax
C# Visual Basic
public class KeywordHits
Public Class KeywordHits
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | KeywordHits(String, Int32) | New
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Hits | Number of hits of the keyword in the document.
 | Keyword | The keyword.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
KeywordHits

Send comments on this topic to support@keyoti.com


KeywordHits Constructor (keyword, hits)

KeywordHits Constructor (keyword, hits)
API Documentation ► Keyoti.SearchEngine.Utils ► KeywordHits ► KeywordHits(String, Int32)
Keyoti SearchUnit v6
New
Declaration Syntax
C# Visual Basic
public KeywordHits(
    string keyword,
    int hits
)
Public Sub New (
    keyword As String,
    hits As Integer
)
Parameters
keyword (String)
hits (Int32)


Hits Property

Hits Property
API Documentation ► Keyoti.SearchEngine.Utils ► KeywordHits ► Hits
Keyoti SearchUnit v6
Number of hits of the keyword in the document.
Declaration Syntax
C# Visual Basic
public int Hits { get; set; }
Public Property Hits As Integer
    Get
    Set
Property Value
Int32

Send comments on this topic to support@keyoti.com


Keyword Property

Keyword Property
API Documentation ► Keyoti.SearchEngine.Utils ► KeywordHits ► Keyword
Keyoti SearchUnit v6
The keyword.
Declaration Syntax
C# Visual Basic
public string Keyword { get; set; }
Public Property Keyword As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


NameValueList Class

NameValueList Class
API Documentation ► Keyoti.SearchEngine.Utils ► NameValueList
Keyoti SearchUnit v6
Holds a map of names and string values.
Declaration Syntax
C# Visual Basic
public class NameValueList : List<NameValuePair>
Public Class NameValueList
    Inherits List(Of NameValuePair)
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NameValueList(Int32) | New
 | Add(T) | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | AddRange(IEnumerable<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | AsReadOnly()()()() | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | BinarySearch(T) | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | Capacity | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | Clear()()()() | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | Contains(T) | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | ConvertAll<(Of <<'(TOutput>)>>)(Converter<(Of <<'(T, TOutput>)>>)) | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | Count | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | Equals(Object) | (Inherited from Object.)
 | Exists(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | Finalize()()()() | (Inherited from Object.)
 | Find(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | FindAll(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | FindLast(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | ForEach(Action<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | GetEnumerator()()()() | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetRange(Int32, Int32) | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(T) | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | IndexOf(T, Int32) | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | Insert(Int32, T) | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | InsertRange(Int32, IEnumerable<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | Item[([( Int32])]) | Gets an entry.
 | Item[([( String])]) | Gets an entry.
 | LastIndexOf(T) | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Remove(T) | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | RemoveAll(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | RemoveAt(Int32) | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | RemoveRange(Int32, Int32) | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | Reverse()()()() | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | Sort()()()() | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | ToArray()()()() | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | ToString()()()() | Returns a user friendly string representation. (Overrides Object.ToString()()()().)
 | TrimExcess()()()() | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
 | TrueForAll(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' NameValuePair >)>)>.)
Inheritance Hierarchy
Object
 | List <(Of <(<' NameValuePair >)>)>
 |  | NameValueList


NameValueList Constructor (capacity)

NameValueList Constructor (capacity)
API Documentation ► Keyoti.SearchEngine.Utils ► NameValueList ► NameValueList(Int32)
Keyoti SearchUnit v6
New
Declaration Syntax
C# Visual Basic
public NameValueList(
    int capacity
)
Public Sub New (
    capacity As Integer
)
Parameters
capacity (Int32)


Item Property

Item Property
API Documentation ► Keyoti.SearchEngine.Utils ► NameValueList ► Item
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Item[([( Int32])]) | Gets an entry.
 | Item[([( String])]) | Gets an entry.


Item Property (index)

Item Property (index)
API Documentation ► Keyoti.SearchEngine.Utils ► NameValueList ► Item[([( Int32])])
Keyoti SearchUnit v6
Gets an entry.
Declaration Syntax
C# Visual Basic
public NameValuePair this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As NameValuePair
    Get
    Set
Parameters
index (Int32)
The result number, 0 based.
Property Value
NameValuePair

Send comments on this topic to support@keyoti.com


Item Property (name)

Item Property (name)
API Documentation ► Keyoti.SearchEngine.Utils ► NameValueList ► Item[([( String])])
Keyoti SearchUnit v6
Gets an entry.
Declaration Syntax
C# Visual Basic
public string this[
    string name
] { get; }
Public ReadOnly Default Property Item (
    name As String
) As String
    Get
Parameters
name (String)
Property Value
String

Send comments on this topic to support@keyoti.com


ToString Method

ToString Method
API Documentation ► Keyoti.SearchEngine.Utils ► NameValueList ► ToString()()()()
Keyoti SearchUnit v6
Returns a user friendly string representation.
Declaration Syntax
C# Visual Basic
public override string ToString()
Public Overrides Function ToString As String
Return Value
String

Send comments on this topic to support@keyoti.com


NameValuePair Class

NameValuePair Class
API Documentation ► Keyoti.SearchEngine.Utils ► NameValuePair
Keyoti SearchUnit v6
Maps a keyword to number of matches inside of a result document for that keyword.
Declaration Syntax
C# Visual Basic
public class NameValuePair
Public Class NameValuePair
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NameValuePair(String, String) | New
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name | The name.
 | ToString()()()() | (Inherited from Object.)
 | Value | The value.
Inheritance Hierarchy
Object
NameValuePair

Send comments on this topic to support@keyoti.com


NameValuePair Constructor (name, value)

NameValuePair Constructor (name, value)
API Documentation ► Keyoti.SearchEngine.Utils ► NameValuePair ► NameValuePair(String, String)
Keyoti SearchUnit v6
New
Declaration Syntax
C# Visual Basic
public NameValuePair(
    string name,
    string value
)
Public Sub New (
    name As String,
    value As String
)
Parameters
name (String)
value (String)


Name Property

Name Property
API Documentation ► Keyoti.SearchEngine.Utils ► NameValuePair ► Name
Keyoti SearchUnit v6
The name.
Declaration Syntax
C# Visual Basic
public string Name { get; set; }
Public Property Name As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


Value Property

Value Property
API Documentation ► Keyoti.SearchEngine.Utils ► NameValuePair ► Value
Keyoti SearchUnit v6
The value.
Declaration Syntax
C# Visual Basic
public string Value { get; set; }
Public Property Value As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


ResourceCredentials Class

ResourceCredentials Class
API Documentation ► Keyoti.SearchEngine.Utils ► ResourceCredentials
Keyoti SearchUnit v6
Credentials used to log in to a web-site for example.
Declaration Syntax
C# Visual Basic
public class ResourceCredentials
Public Class ResourceCredentials
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ResourceCredentials(String, String) | New instance
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FromString(String) | Creates an instance based on the serialization of this object through a call to ToString.
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSerializationPattern()()()() | Returns the serialization pattern - which dictates how strings are converted to objects in FromString.
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Password | The password
 | ToString()()()() | Serializes this instance in string form (Overrides Object.ToString()()()().)
 | Username | The username
Inheritance Hierarchy
Object
ResourceCredentials

Send comments on this topic to support@keyoti.com


ResourceCredentials Constructor (username, password)

ResourceCredentials Constructor (username, password)
API Documentation ► Keyoti.SearchEngine.Utils ► ResourceCredentials ► ResourceCredentials(String, String)
Keyoti SearchUnit v6
New instance
Declaration Syntax
C# Visual Basic
public ResourceCredentials(
    string username,
    string password
)
Public Sub New (
    username As String,
    password As String
)
Parameters
username (String)
Username for the website
password (String)
Password for the website

Send comments on this topic to support@keyoti.com


FromString Method (serializedString)

FromString Method (serializedString)
API Documentation ► Keyoti.SearchEngine.Utils ► ResourceCredentials ► FromString(String)
Keyoti SearchUnit v6
Creates an instance based on the serialization of this object through a call to ToString.
Declaration Syntax
C# Visual Basic
public static ResourceCredentials FromString(
    string serializedString
)
Public Shared Function FromString (
    serializedString As String
) As ResourceCredentials
Parameters
serializedString (String)
Output of ToString.
Return Value
ResourceCredentials
Remarks
i.e. ResourceCredentials.FromString( obj.ToString() ) creates an instance the same as obj.


GetSerializationPattern Method

GetSerializationPattern Method
API Documentation ► Keyoti.SearchEngine.Utils ► ResourceCredentials ► GetSerializationPattern()()()()
Keyoti SearchUnit v6
Returns the serialization pattern - which dictates how strings are converted to objects in FromString.
Declaration Syntax
C# Visual Basic
public static string GetSerializationPattern()
Public Shared Function GetSerializationPattern As String
Return Value
String

Send comments on this topic to support@keyoti.com


Password Property

Password Property
API Documentation ► Keyoti.SearchEngine.Utils ► ResourceCredentials ► Password
Keyoti SearchUnit v6
The password
Declaration Syntax
C# Visual Basic
public string Password { get; set; }
Public Property Password As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


ToString Method

ToString Method
API Documentation ► Keyoti.SearchEngine.Utils ► ResourceCredentials ► ToString()()()()
Keyoti SearchUnit v6
Serializes this instance in string form
Declaration Syntax
C# Visual Basic
public override string ToString()
Public Overrides Function ToString As String
Return Value
String

Send comments on this topic to support@keyoti.com


Username Property

Username Property
API Documentation ► Keyoti.SearchEngine.Utils ► ResourceCredentials ► Username
Keyoti SearchUnit v6
The username
Declaration Syntax
C# Visual Basic
public string Username { get; set; }
Public Property Username As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


ResultItemList Class

ResultItemList Class
API Documentation ► Keyoti.SearchEngine.Utils ► ResultItemList
Keyoti SearchUnit v6
ResultItem list wrapper.
Declaration Syntax
C# Visual Basic
public class ResultItemList : List<ResultItem>
Public Class ResultItemList
    Inherits List(Of ResultItem)
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ResultItemList()()()() | New
 | ResultItemList(Int32) | New
 | Add(T) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | AddRange(IEnumerable<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | AsReadOnly()()()() | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | BinarySearch(T) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | Capacity | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | Clear()()()() | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | Contains(T) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | ConvertAll<(Of <<'(TOutput>)>>)(Converter<(Of <<'(T, TOutput>)>>)) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | Count | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | Equals(Object) | (Inherited from Object.)
 | Exists(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | Finalize()()()() | (Inherited from Object.)
 | Find(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | FindAll(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | FindLast(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | ForEach(Action<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | GetEnumerator()()()() | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetRange(Int32, Int32) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(T) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | IndexOf(T, Int32) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | Insert(Int32, T) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | InsertRange(Int32, IEnumerable<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | Item[([( Int32])]) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | LastIndexOf(T) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Remove(T) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | RemoveAll(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | RemoveAt(Int32) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | RemoveRange(Int32, Int32) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | Reverse()()()() | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | Sort()()()() | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | ToArray()()()() | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | ToString()()()() | (Inherited from Object.)
 | TrimExcess()()()() | (Inherited from List <(Of <(<' ResultItem >)>)>.)
 | TrueForAll(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' ResultItem >)>)>.)
Inheritance Hierarchy
Object
 | List <(Of <(<' ResultItem >)>)>
 |  | ResultItemList


ResultItemList Constructor

ResultItemList Constructor
API Documentation ► Keyoti.SearchEngine.Utils ► ResultItemList ► ResultItemList()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | ResultItemList()()()() | New
 | ResultItemList(Int32) | New


ResultItemList Constructor

ResultItemList Constructor
API Documentation ► Keyoti.SearchEngine.Utils ► ResultItemList ► ResultItemList()()()()
Keyoti SearchUnit v6
New
Declaration Syntax
C# Visual Basic
public ResultItemList()
Public Sub New

Send comments on this topic to support@keyoti.com


ResultItemList Constructor (c)

ResultItemList Constructor (c)
API Documentation ► Keyoti.SearchEngine.Utils ► ResultItemList ► ResultItemList(Int32)
Keyoti SearchUnit v6
New
Declaration Syntax
C# Visual Basic
public ResultItemList(
    int c
)
Public Sub New (
    c As Integer
)
Parameters
c (Int32)
Initial capacity

Send comments on this topic to support@keyoti.com


SecurityGroupRecordList Class

SecurityGroupRecordList Class
API Documentation ► Keyoti.SearchEngine.Utils ► SecurityGroupRecordList
Keyoti SearchUnit v6
SecurityGroupRecord list wrapper.
Declaration Syntax
C# Visual Basic
[SerializableAttribute]
public class SecurityGroupRecordList : IList<SecurityGroupRecord>,
    ICollection
<SerializableAttribute>
Public Class SecurityGroupRecordList
    Implements IList(Of SecurityGroupRecord), ICollection
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SecurityGroupRecordList()()()() | New
 | SecurityGroupRecordList(Int32) | New
 | Add(SecurityGroupRecord) | Add a record.
 | Add(SecurityGroupRecord, Boolean) | Add a record.
 | AddRange(SecurityGroupRecordList) | Add a record range.
 | AddRange(SecurityGroupRecordList, Boolean) | Add a record range.
 | Clear()()()() | Clear the list
 | Contains(SecurityGroupRecord) | Whether the list contains the record.
 | ContainsGroupWithId(array<Int32>[]()[][]) | Whether a group in the list has Id = securityGroupId
 | CopyTo(array<SecurityGroupRecord>[]()[][], Int32) | Copies the list.
 | CopyTo(Array, Int32) | Copies to an array.
 | Count | Number of items in list.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | Gets an enumerator
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(SecurityGroupRecord) | Index of a record
 | Insert(Int32, SecurityGroupRecord) | Inserts a record
 | IsReadOnly | Whether the list is read only.
 | IsSynchronized | Whether the list is synchornized.
 | Item[([( Int32])]) | Item indexer
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Remove(SecurityGroupRecord) | Removes an item
 | RemoveAt(Int32) | Removes a record at the index specified.
 | Sort()()()() | Sort.
 | SyncRoot | The sync root.
 | ToCommaDelimitedSecurityGroupRecord()()()() | Generates a comma delimited SecurityGroupRecord representation for human consumption.
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
SecurityGroupRecordList

Send comments on this topic to support@keyoti.com


SecurityGroupRecordList Constructor

SecurityGroupRecordList Constructor
API Documentation ► Keyoti.SearchEngine.Utils ► SecurityGroupRecordList ► SecurityGroupRecordList()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | SecurityGroupRecordList()()()() | New
 | SecurityGroupRecordList(Int32) | New


SecurityGroupRecordList Constructor

SecurityGroupRecordList Constructor
API Documentation ► Keyoti.SearchEngine.Utils ► SecurityGroupRecordList ► SecurityGroupRecordList()()()()
Keyoti SearchUnit v6
New
Declaration Syntax
C# Visual Basic
public SecurityGroupRecordList()
Public Sub New

Send comments on this topic to support@keyoti.com


SecurityGroupRecordList Constructor (c)

SecurityGroupRecordList Constructor (c)
API Documentation ► Keyoti.SearchEngine.Utils ► SecurityGroupRecordList ► SecurityGroupRecordList(Int32)
Keyoti SearchUnit v6
New
Declaration Syntax
C# Visual Basic
public SecurityGroupRecordList(
    int c
)
Public Sub New (
    c As Integer
)
Parameters
c (Int32)
Initial capacity

Send comments on this topic to support@keyoti.com


Add Method

Add Method
API Documentation ► Keyoti.SearchEngine.Utils ► SecurityGroupRecordList ► Add()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Add(SecurityGroupRecord) | Add a record.
 | Add(SecurityGroupRecord, Boolean) | Add a record.


Add Method (record)

Add Method (record)
API Documentation ► Keyoti.SearchEngine.Utils ► SecurityGroupRecordList ► Add(SecurityGroupRecord)
Keyoti SearchUnit v6
Add a record.
Declaration Syntax
C# Visual Basic
public void Add(
    SecurityGroupRecord record
)
Public Sub Add (
    record As SecurityGroupRecord
)
Parameters
record (SecurityGroupRecord)


Add Method (record, removeExistingDefaultAssignment)

Add Method (record, removeExistingDefaultAssignment)
API Documentation ► Keyoti.SearchEngine.Utils ► SecurityGroupRecordList ► Add(SecurityGroupRecord, Boolean)
Keyoti SearchUnit v6
Add a record.
Declaration Syntax
C# Visual Basic
public void Add(
    SecurityGroupRecord record,
    bool removeExistingDefaultAssignment
)
Public Sub Add (
    record As SecurityGroupRecord,
    removeExistingDefaultAssignment As Boolean
)
Parameters
record (SecurityGroupRecord)
removeExistingDefaultAssignment (Boolean)


AddRange Method

AddRange Method
API Documentation ► Keyoti.SearchEngine.Utils ► SecurityGroupRecordList ► AddRange()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | AddRange(SecurityGroupRecordList) | Add a record range.
 | AddRange(SecurityGroupRecordList, Boolean) | Add a record range.


AddRange Method (list)

AddRange Method (list)
API Documentation ► Keyoti.SearchEngine.Utils ► SecurityGroupRecordList ► AddRange(SecurityGroupRecordList)
Keyoti SearchUnit v6
Add a record range.
Declaration Syntax
C# Visual Basic
public void AddRange(
    SecurityGroupRecordList list
)
Public Sub AddRange (
    list As SecurityGroupRecordList
)
Parameters
list (SecurityGroupRecordList)


AddRange Method (list, removeExistingDefaultAssignment)

AddRange Method (list, removeExistingDefaultAssignment)
API Documentation ► Keyoti.SearchEngine.Utils ► SecurityGroupRecordList ► AddRange(SecurityGroupRecordList, Boolean)
Keyoti SearchUnit v6
Add a record range.
Declaration Syntax
C# Visual Basic
public void AddRange(
    SecurityGroupRecordList list,
    bool removeExistingDefaultAssignment
)
Public Sub AddRange (
    list As SecurityGroupRecordList,
    removeExistingDefaultAssignment As Boolean
)
Parameters
list (SecurityGroupRecordList)
removeExistingDefaultAssignment (Boolean)


Clear Method

Clear Method
API Documentation ► Keyoti.SearchEngine.Utils ► SecurityGroupRecordList ► Clear()()()()
Keyoti SearchUnit v6
Clear the list
Declaration Syntax
C# Visual Basic
public void Clear()
Public Sub Clear

Send comments on this topic to support@keyoti.com


Contains Method (item)

Contains Method (item)
API Documentation ► Keyoti.SearchEngine.Utils ► SecurityGroupRecordList ► Contains(SecurityGroupRecord)
Keyoti SearchUnit v6
Whether the list contains the record.
Declaration Syntax
C# Visual Basic
public bool Contains(
    SecurityGroupRecord item
)
Public Function Contains (
    item As SecurityGroupRecord
) As Boolean
Parameters
item (SecurityGroupRecord)
Return Value
Boolean

Send comments on this topic to support@keyoti.com


ContainsGroupWithId Method (securityGroupId)

ContainsGroupWithId Method (securityGroupId)
API Documentation ► Keyoti.SearchEngine.Utils ► SecurityGroupRecordList ► ContainsGroupWithId(array<Int32>[]()[][])
Keyoti SearchUnit v6
Whether a group in the list has Id = securityGroupId
Declaration Syntax
C# Visual Basic
public bool ContainsGroupWithId(
    int[] securityGroupId
)
Public Function ContainsGroupWithId (
    securityGroupId As Integer()
) As Boolean
Parameters
securityGroupId (array< Int32 >[]()[][])
Return Value
Boolean

Send comments on this topic to support@keyoti.com


CopyTo Method

CopyTo Method
API Documentation ► Keyoti.SearchEngine.Utils ► SecurityGroupRecordList ► CopyTo()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | CopyTo(array<SecurityGroupRecord>[]()[][], Int32) | Copies the list.
 | CopyTo(Array, Int32) | Copies to an array.


CopyTo Method (array, arrayIndex)

CopyTo Method (array, arrayIndex)
API Documentation ► Keyoti.SearchEngine.Utils ► SecurityGroupRecordList ► CopyTo(array<SecurityGroupRecord>[]()[][], Int32)
Keyoti SearchUnit v6
Copies the list.
Declaration Syntax
C# Visual Basic
public void CopyTo(
    SecurityGroupRecord[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As SecurityGroupRecord(),
    arrayIndex As Integer
)
Parameters
array (array< SecurityGroupRecord >[]()[][])
arrayIndex (Int32)


CopyTo Method (array, index)

CopyTo Method (array, index)
API Documentation ► Keyoti.SearchEngine.Utils ► SecurityGroupRecordList ► CopyTo(Array, Int32)
Keyoti SearchUnit v6
Copies to an array.
Declaration Syntax
C# Visual Basic
public void CopyTo(
    Array array,
    int index
)
Public Sub CopyTo (
    array As Array,
    index As Integer
)
Parameters
array (Array)
index (Int32)


Count Property

Count Property
API Documentation ► Keyoti.SearchEngine.Utils ► SecurityGroupRecordList ► Count
Keyoti SearchUnit v6
Number of items in list.
Declaration Syntax
C# Visual Basic
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
Property Value
Int32

Send comments on this topic to support@keyoti.com


GetEnumerator Method

GetEnumerator Method
API Documentation ► Keyoti.SearchEngine.Utils ► SecurityGroupRecordList ► GetEnumerator()()()()
Keyoti SearchUnit v6
Gets an enumerator
Declaration Syntax
C# Visual Basic
public IEnumerator<SecurityGroupRecord> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of SecurityGroupRecord)
Return Value
IEnumerator <(Of <(<' SecurityGroupRecord >)>)>


IndexOf Method (item)

IndexOf Method (item)
API Documentation ► Keyoti.SearchEngine.Utils ► SecurityGroupRecordList ► IndexOf(SecurityGroupRecord)
Keyoti SearchUnit v6
Index of a record
Declaration Syntax
C# Visual Basic
public int IndexOf(
    SecurityGroupRecord item
)
Public Function IndexOf (
    item As SecurityGroupRecord
) As Integer
Parameters
item (SecurityGroupRecord)
Return Value
Int32

Send comments on this topic to support@keyoti.com


Insert Method (index, item)

Insert Method (index, item)
API Documentation ► Keyoti.SearchEngine.Utils ► SecurityGroupRecordList ► Insert(Int32, SecurityGroupRecord)
Keyoti SearchUnit v6
Inserts a record
Declaration Syntax
C# Visual Basic
public void Insert(
    int index,
    SecurityGroupRecord item
)
Public Sub Insert (
    index As Integer,
    item As SecurityGroupRecord
)
Parameters
index (Int32)
item (SecurityGroupRecord)


IsReadOnly Property

IsReadOnly Property
API Documentation ► Keyoti.SearchEngine.Utils ► SecurityGroupRecordList ► IsReadOnly
Keyoti SearchUnit v6
Whether the list is read only.
Declaration Syntax
C# Visual Basic
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
Property Value
Boolean

Send comments on this topic to support@keyoti.com


IsSynchronized Property

IsSynchronized Property
API Documentation ► Keyoti.SearchEngine.Utils ► SecurityGroupRecordList ► IsSynchronized
Keyoti SearchUnit v6
Whether the list is synchornized.
Declaration Syntax
C# Visual Basic
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
Property Value
Boolean

Send comments on this topic to support@keyoti.com


Item Property (index)

Item Property (index)
API Documentation ► Keyoti.SearchEngine.Utils ► SecurityGroupRecordList ► Item[([( Int32])])
Keyoti SearchUnit v6
Item indexer
Declaration Syntax
C# Visual Basic
public SecurityGroupRecord this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As SecurityGroupRecord
    Get
    Set
Parameters
index (Int32)
Property Value
SecurityGroupRecord

Send comments on this topic to support@keyoti.com


Remove Method (item)

Remove Method (item)
API Documentation ► Keyoti.SearchEngine.Utils ► SecurityGroupRecordList ► Remove(SecurityGroupRecord)
Keyoti SearchUnit v6
Removes an item
Declaration Syntax
C# Visual Basic
public bool Remove(
    SecurityGroupRecord item
)
Public Function Remove (
    item As SecurityGroupRecord
) As Boolean
Parameters
item (SecurityGroupRecord)
Return Value
Boolean

Send comments on this topic to support@keyoti.com


RemoveAt Method (index)

RemoveAt Method (index)
API Documentation ► Keyoti.SearchEngine.Utils ► SecurityGroupRecordList ► RemoveAt(Int32)
Keyoti SearchUnit v6
Removes a record at the index specified.
Declaration Syntax
C# Visual Basic
public void RemoveAt(
    int index
)
Public Sub RemoveAt (
    index As Integer
)
Parameters
index (Int32)


Sort Method

Sort Method
API Documentation ► Keyoti.SearchEngine.Utils ► SecurityGroupRecordList ► Sort()()()()
Keyoti SearchUnit v6
Sort.
Declaration Syntax
C# Visual Basic
public void Sort()
Public Sub Sort

Send comments on this topic to support@keyoti.com


SyncRoot Property

SyncRoot Property
API Documentation ► Keyoti.SearchEngine.Utils ► SecurityGroupRecordList ► SyncRoot
Keyoti SearchUnit v6
The sync root.
Declaration Syntax
C# Visual Basic
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
Property Value
Object

Send comments on this topic to support@keyoti.com


ToCommaDelimitedSecurityGroupRecord Method

ToCommaDelimitedSecurityGroupRecord Method
API Documentation ► Keyoti.SearchEngine.Utils ► SecurityGroupRecordList ► ToCommaDelimitedSecurityGroupRecord()()()()
Keyoti SearchUnit v6
Generates a comma delimited SecurityGroupRecord representation for human consumption.
Declaration Syntax
C# Visual Basic
public string ToCommaDelimitedSecurityGroupRecord()
Public Function ToCommaDelimitedSecurityGroupRecord As String
Return Value
String

Send comments on this topic to support@keyoti.com


SSTCryptographer Class

SSTCryptographer Class
API Documentation ► Keyoti.SearchEngine.Utils ► SSTCryptographer
Keyoti SearchUnit v6
String encrypter
Declaration Syntax
C# Visual Basic
public class SSTCryptographer
Public Class SSTCryptographer
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SSTCryptographer()()()() |
 | Decrypt(String) | Decrypt the given string using the default key.
 | Decrypt(String, String) | Decrypt the given string using the specified key.
 | Encrypt(String) | Encrypt the given string using the default key.
 | Encrypt(String, String) | Encrypt the given string using the specified key.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
SSTCryptographer

Send comments on this topic to support@keyoti.com


SSTCryptographer Constructor

SSTCryptographer Constructor
API Documentation ► Keyoti.SearchEngine.Utils ► SSTCryptographer ► SSTCryptographer()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public SSTCryptographer()
Public Sub New

Send comments on this topic to support@keyoti.com


Decrypt Method

Decrypt Method
API Documentation ► Keyoti.SearchEngine.Utils ► SSTCryptographer ► Decrypt()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Decrypt(String) | Decrypt the given string using the default key.
 | Decrypt(String, String) | Decrypt the given string using the specified key.


Decrypt Method (strEncrypted)

Decrypt Method (strEncrypted)
API Documentation ► Keyoti.SearchEngine.Utils ► SSTCryptographer ► Decrypt(String)
Keyoti SearchUnit v6
Decrypt the given string using the default key.
Declaration Syntax
C# Visual Basic
public static string Decrypt(
    string strEncrypted
)
Public Shared Function Decrypt (
    strEncrypted As String
) As String
Parameters
strEncrypted (String)
The string to be decrypted.
Return Value
String
The decrypted string.


Decrypt Method (strEncrypted, strKey)

Decrypt Method (strEncrypted, strKey)
API Documentation ► Keyoti.SearchEngine.Utils ► SSTCryptographer ► Decrypt(String, String)
Keyoti SearchUnit v6
Decrypt the given string using the specified key.
Declaration Syntax
C# Visual Basic
public static string Decrypt(
    string strEncrypted,
    string strKey
)
Public Shared Function Decrypt (
    strEncrypted As String,
    strKey As String
) As String
Parameters
strEncrypted (String)
The string to be decrypted.
strKey (String)
The decryption key.
Return Value
String
The decrypted string.


Encrypt Method

Encrypt Method
API Documentation ► Keyoti.SearchEngine.Utils ► SSTCryptographer ► Encrypt()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Encrypt(String) | Encrypt the given string using the default key.
 | Encrypt(String, String) | Encrypt the given string using the specified key.


Encrypt Method (strToEncrypt)

Encrypt Method (strToEncrypt)
API Documentation ► Keyoti.SearchEngine.Utils ► SSTCryptographer ► Encrypt(String)
Keyoti SearchUnit v6
Encrypt the given string using the default key.
Declaration Syntax
C# Visual Basic
public static string Encrypt(
    string strToEncrypt
)
Public Shared Function Encrypt (
    strToEncrypt As String
) As String
Parameters
strToEncrypt (String)
The string to be encrypted.
Return Value
String
The encrypted string.


Encrypt Method (strToEncrypt, strKey)

Encrypt Method (strToEncrypt, strKey)
API Documentation ► Keyoti.SearchEngine.Utils ► SSTCryptographer ► Encrypt(String, String)
Keyoti SearchUnit v6
Encrypt the given string using the specified key.
Declaration Syntax
C# Visual Basic
public static string Encrypt(
    string strToEncrypt,
    string strKey
)
Public Shared Function Encrypt (
    strToEncrypt As String,
    strKey As String
) As String
Parameters
strToEncrypt (String)
The string to be encrypted.
strKey (String)
The encryption key.
Return Value
String
The encrypted string.


StringList Class

StringList Class
API Documentation ► Keyoti.SearchEngine.Utils ► StringList
Keyoti SearchUnit v6
String list wrapper.
Declaration Syntax
C# Visual Basic
public class StringList : List<string>
Public Class StringList
    Inherits List(Of String)
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StringList()()()() | New
 | StringList(Int32) | New
 | Add(T) | (Inherited from List <(Of <(<' String >)>)>.)
 | AddRange(IEnumerable<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
 | AsReadOnly()()()() | (Inherited from List <(Of <(<' String >)>)>.)
 | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
 | BinarySearch(T) | (Inherited from List <(Of <(<' String >)>)>.)
 | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
 | Capacity | (Inherited from List <(Of <(<' String >)>)>.)
 | Clear()()()() | (Inherited from List <(Of <(<' String >)>)>.)
 | Contains(T) | (Inherited from List <(Of <(<' String >)>)>.)
 | ConvertAll<(Of <<'(TOutput>)>>)(Converter<(Of <<'(T, TOutput>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
 | CopyTo(array<T>[]()[][]) | (Inherited from List <(Of <(<' String >)>)>.)
 | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | (Inherited from List <(Of <(<' String >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | (Inherited from List <(Of <(<' String >)>)>.)
 | Count | (Inherited from List <(Of <(<' String >)>)>.)
 | Equals(Object) | (Inherited from Object.)
 | Exists(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
 | Finalize()()()() | (Inherited from Object.)
 | Find(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
 | FindAll(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
 | FindIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
 | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
 | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
 | FindLast(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
 | FindLastIndex(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
 | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
 | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
 | ForEach(Action<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
 | GetEnumerator()()()() | (Inherited from List <(Of <(<' String >)>)>.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetRange(Int32, Int32) | (Inherited from List <(Of <(<' String >)>)>.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(T) | (Inherited from List <(Of <(<' String >)>)>.)
 | IndexOf(T, Int32) | (Inherited from List <(Of <(<' String >)>)>.)
 | IndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' String >)>)>.)
 | Insert(Int32, T) | (Inherited from List <(Of <(<' String >)>)>.)
 | InsertRange(Int32, IEnumerable<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
 | Item[([( Int32])]) | (Inherited from List <(Of <(<' String >)>)>.)
 | LastIndexOf(T) | (Inherited from List <(Of <(<' String >)>)>.)
 | LastIndexOf(T, Int32) | (Inherited from List <(Of <(<' String >)>)>.)
 | LastIndexOf(T, Int32, Int32) | (Inherited from List <(Of <(<' String >)>)>.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Remove(T) | (Inherited from List <(Of <(<' String >)>)>.)
 | RemoveAll(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
 | RemoveAt(Int32) | (Inherited from List <(Of <(<' String >)>)>.)
 | RemoveRange(Int32, Int32) | (Inherited from List <(Of <(<' String >)>)>.)
 | Reverse()()()() | (Inherited from List <(Of <(<' String >)>)>.)
 | Reverse(Int32, Int32) | (Inherited from List <(Of <(<' String >)>)>.)
 | Sort()()()() | (Inherited from List <(Of <(<' String >)>)>.)
 | Sort(IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
 | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
 | Sort(Comparison<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
 | ToArray()()()() | (Inherited from List <(Of <(<' String >)>)>.)
 | ToCommaDelimitedString()()()() | Generates a comma delimited string representation for human consumption.
 | ToString()()()() | (Inherited from Object.)
 | TrimExcess()()()() | (Inherited from List <(Of <(<' String >)>)>.)
 | TrueForAll(Predicate<(Of <<'(T>)>>)) | (Inherited from List <(Of <(<' String >)>)>.)
Inheritance Hierarchy
Object
 | List <(Of <(<' String >)>)>
 |  | StringList


StringList Constructor

StringList Constructor
API Documentation ► Keyoti.SearchEngine.Utils ► StringList ► StringList()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | StringList()()()() | New
 | StringList(Int32) | New


StringList Constructor

StringList Constructor
API Documentation ► Keyoti.SearchEngine.Utils ► StringList ► StringList()()()()
Keyoti SearchUnit v6
New
Declaration Syntax
C# Visual Basic
public StringList()
Public Sub New

Send comments on this topic to support@keyoti.com


StringList Constructor (c)

StringList Constructor (c)
API Documentation ► Keyoti.SearchEngine.Utils ► StringList ► StringList(Int32)
Keyoti SearchUnit v6
New
Declaration Syntax
C# Visual Basic
public StringList(
    int c
)
Public Sub New (
    c As Integer
)
Parameters
c (Int32)
Initial capacity

Send comments on this topic to support@keyoti.com


ToCommaDelimitedString Method

ToCommaDelimitedString Method
API Documentation ► Keyoti.SearchEngine.Utils ► StringList ► ToCommaDelimitedString()()()()
Keyoti SearchUnit v6
Generates a comma delimited string representation for human consumption.
Declaration Syntax
C# Visual Basic
public string ToCommaDelimitedString()
Public Function ToCommaDelimitedString As String
Return Value
String

Send comments on this topic to support@keyoti.com


UriComparer Class

UriComparer Class
API Documentation ► Keyoti.SearchEngine.Utils ► UriComparer
Keyoti SearchUnit v6
Compares Uri objects
Declaration Syntax
C# Visual Basic
public class UriComparer : IComparer
Public Class UriComparer
    Implements IComparer
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | UriComparer()()()() | New instance
 | Compare(Object, Object) | Compare 2 Uris
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
UriComparer

Send comments on this topic to support@keyoti.com


UriComparer Constructor

UriComparer Constructor
API Documentation ► Keyoti.SearchEngine.Utils ► UriComparer ► UriComparer()()()()
Keyoti SearchUnit v6
New instance
Declaration Syntax
C# Visual Basic
public UriComparer()
Public Sub New

Send comments on this topic to support@keyoti.com


Compare Method (x, y)

Compare Method (x, y)
API Documentation ► Keyoti.SearchEngine.Utils ► UriComparer ► Compare(Object, Object)
Keyoti SearchUnit v6
Compare 2 Uris
Declaration Syntax
C# Visual Basic
public int Compare(
    Object x,
    Object y
)
Public Function Compare (
    x As Object,
    y As Object
) As Integer
Parameters
x (Object)
y (Object)
Return Value
Int32
Remarks
For speed, does not check type of x and y


UriTools Class

UriTools Class
API Documentation ► Keyoti.SearchEngine.Utils ► UriTools
Keyoti SearchUnit v6
Tools for URLs
Declaration Syntax
C# Visual Basic
public class UriTools
Public Class UriTools
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | UriTools()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetAttributeValue(String, String) | Gets an attribute from a tag.
 | GetCaseAdjustedAbsoluteURIString(Uri, Boolean) |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | RemoveQueryParameters(String, array<String>[]()[][]) | Removes query string parameters from Uris.
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
UriTools

Send comments on this topic to support@keyoti.com


UriTools Constructor

UriTools Constructor
API Documentation ► Keyoti.SearchEngine.Utils ► UriTools ► UriTools()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public UriTools()
Public Sub New

Send comments on this topic to support@keyoti.com


GetAttributeValue Method (tag, attributeName)

GetAttributeValue Method (tag, attributeName)
API Documentation ► Keyoti.SearchEngine.Utils ► UriTools ► GetAttributeValue(String, String)
Keyoti SearchUnit v6
Gets an attribute from a tag.
Declaration Syntax
C# Visual Basic
public static string GetAttributeValue(
    string tag,
    string attributeName
)
Public Shared Function GetAttributeValue (
    tag As String,
    attributeName As String
) As String
Parameters
tag (String)
attributeName (String)
Return Value
String

Send comments on this topic to support@keyoti.com


GetCaseAdjustedAbsoluteURIString Method (uri, indexIsCaseSensitive)

GetCaseAdjustedAbsoluteURIString Method (uri, indexIsCaseSensitive)
API Documentation ► Keyoti.SearchEngine.Utils ► UriTools ► GetCaseAdjustedAbsoluteURIString(Uri, Boolean)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public static string GetCaseAdjustedAbsoluteURIString(
    Uri uri,
    bool indexIsCaseSensitive
)
Public Shared Function GetCaseAdjustedAbsoluteURIString (
    uri As Uri,
    indexIsCaseSensitive As Boolean
) As String
Parameters
uri (Uri)
indexIsCaseSensitive (Boolean)
Return Value
String

Send comments on this topic to support@keyoti.com


RemoveQueryParameters Method (uriString, cleanParams)

RemoveQueryParameters Method (uriString, cleanParams)
API Documentation ► Keyoti.SearchEngine.Utils ► UriTools ► RemoveQueryParameters(String, array<String>[]()[][])
Keyoti SearchUnit v6
Removes query string parameters from Uris.
Declaration Syntax
C# Visual Basic
public static string RemoveQueryParameters(
    string uriString,
    string[] cleanParams
)
Public Shared Function RemoveQueryParameters (
    uriString As String,
    cleanParams As String()
) As String
Parameters
uriString (String)
cleanParams (array< String >[]()[][])
Return Value
String

Send comments on this topic to support@keyoti.com


ZipExtractor Class

ZipExtractor Class
API Documentation ► Keyoti.SearchEngine.Utils ► ZipExtractor
Keyoti SearchUnit v6
Extracts file streams from ZIP archives.
Declaration Syntax
C# Visual Basic
public class ZipExtractor
Public Class ZipExtractor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ZipExtractor(Stream) | New instance
 | Equals(Object) | (Inherited from Object.)
 | ExtractFiles(ZipExtractor..::..FileChooser, ArrayList) | Extracts desired files from the stream according to the delegate.
 | ExtractFiles(ZipExtractor..::..FileChooser, ArrayList, ArrayList) | Extracts desired files from the stream according to the delegate.
 | ExtractIndividualFiles(ZipExtractor..::..FileChooser, ZipExtractor..::..ExtractedFileListener) | Extracts desired files from the stream according to the delegate.
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
ZipExtractor

Send comments on this topic to support@keyoti.com


ZipExtractor Constructor (stream)

ZipExtractor Constructor (stream)
API Documentation ► Keyoti.SearchEngine.Utils ► ZipExtractor ► ZipExtractor(Stream)
Keyoti SearchUnit v6
New instance
Declaration Syntax
C# Visual Basic
public ZipExtractor(
    Stream stream
)
Public Sub New (
    stream As Stream
)
Parameters
stream (Stream)
The zip archive stream.


ExtractFiles Method

ExtractFiles Method
API Documentation ► Keyoti.SearchEngine.Utils ► ZipExtractor ► ExtractFiles()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | ExtractFiles(ZipExtractor..::..FileChooser, ArrayList) | Extracts desired files from the stream according to the delegate.
 | ExtractFiles(ZipExtractor..::..FileChooser, ArrayList, ArrayList) | Extracts desired files from the stream according to the delegate.


ExtractFiles Method (fileChooser, chosenFilePositions)

ExtractFiles Method (fileChooser, chosenFilePositions)
API Documentation ► Keyoti.SearchEngine.Utils ► ZipExtractor ► ExtractFiles(ZipExtractor..::..FileChooser, ArrayList)
Keyoti SearchUnit v6
Extracts desired files from the stream according to the delegate.
Declaration Syntax
C# Visual Basic
public Stream ExtractFiles(
    ZipExtractor..::..FileChooser fileChooser,
    ArrayList chosenFilePositions
)
Public Function ExtractFiles (
    fileChooser As ZipExtractor..::..FileChooser,
    chosenFilePositions As ArrayList
) As Stream
Parameters
fileChooser (ZipExtractor..::..FileChooser)
FileChooser delegate that determines if a file should be extracted
chosenFilePositions (ArrayList)
Empty ArrayList into which 2 element Int64 (long) arrays will be added, each holding the start (first element) and end (second element) positions of the files in the expanded stream.
Return Value
Stream
The files as in a concatenated stream.


ExtractFiles Method (fileChooser, chosenFilePositions, filenames)

ExtractFiles Method (fileChooser, chosenFilePositions, filenames)
API Documentation ► Keyoti.SearchEngine.Utils ► ZipExtractor ► ExtractFiles(ZipExtractor..::..FileChooser, ArrayList, ArrayList)
Keyoti SearchUnit v6
Extracts desired files from the stream according to the delegate.
Declaration Syntax
C# Visual Basic
public Stream ExtractFiles(
    ZipExtractor..::..FileChooser fileChooser,
    ArrayList chosenFilePositions,
    ArrayList filenames
)
Public Function ExtractFiles (
    fileChooser As ZipExtractor..::..FileChooser,
    chosenFilePositions As ArrayList,
    filenames As ArrayList
) As Stream
Parameters
fileChooser (ZipExtractor..::..FileChooser)
FileChooser delegate that determines if a file should be extracted
chosenFilePositions (ArrayList)
Empty ArrayList into which 2 element Int64 (long) arrays will be added, each holding the start (first element) and end (second element) positions of the files in the expanded stream.
filenames (ArrayList)
List of filesnames found
Return Value
Stream
The files as in a concatenated stream.


ExtractIndividualFiles Method (fileChooser, extractedFile)

ExtractIndividualFiles Method (fileChooser, extractedFile)
API Documentation ► Keyoti.SearchEngine.Utils ► ZipExtractor ► ExtractIndividualFiles(ZipExtractor..::..FileChooser, ZipExtractor..::..ExtractedFileListener)
Keyoti SearchUnit v6
Extracts desired files from the stream according to the delegate.
Declaration Syntax
C# Visual Basic
public void ExtractIndividualFiles(
    ZipExtractor..::..FileChooser fileChooser,
    ZipExtractor..::..ExtractedFileListener extractedFile
)
Public Sub ExtractIndividualFiles (
    fileChooser As ZipExtractor..::..FileChooser,
    extractedFile As ZipExtractor..::..ExtractedFileListener
)
Parameters
fileChooser (ZipExtractor..::..FileChooser)
FileChooser delegate that determines if a file should be extracted
extractedFile (ZipExtractor..::..ExtractedFileListener)
Delegate called when a file has been extracted, passing the file as a stream


ZipExtractor.ExtractedFileListener Delegate

ZipExtractor..::..ExtractedFileListener Delegate
API Documentation ► Keyoti.SearchEngine.Utils ► ZipExtractor ► ZipExtractor..::..ExtractedFileListener
Keyoti SearchUnit v6
Called when a file is extracted.
Declaration Syntax
C# Visual Basic
public delegate void ExtractedFileListener(
    Stream file,
    string fileName
)
Public Delegate Sub ExtractedFileListener (
    file As Stream,
    fileName As String
)
Parameters
file (Stream)
Stream containing the file
fileName (String)


ZipExtractor.FileChooser Delegate

ZipExtractor..::..FileChooser Delegate
API Documentation ► Keyoti.SearchEngine.Utils ► ZipExtractor ► ZipExtractor..::..FileChooser
Keyoti SearchUnit v6
Returns true when the caller wants filename
Declaration Syntax
C# Visual Basic
public delegate bool FileChooser(
    string filename
)
Public Delegate Function FileChooser (
    filename As String
) As Boolean
Parameters
filename (String)
Return Value
Boolean

Send comments on this topic to support@keyoti.com


Keyoti.SearchEngine.Web Namespace

Keyoti.SearchEngine.Web Namespace
API Documentation ► Keyoti.SearchEngine.Web
Keyoti SearchUnit v6
Classes for the Web controls.
Types
All Types Classes Interfaces Enumerations Delegates
Icon | Type | Description
 | AutoCompletePopularSearchHelper |
 | SearchBox..::..AutoCompleteSuggestionSource | Identifies source of autocomplete suggestions.
 | CallBackHandler | Handles AJAX call backs
 | ClientFilesLocation | Where the client files should be obtained from.
 | SearchBoxAutoCompleteHelper..::..SuggestionResultPair..::..Comparer | Comparer
 | ErrorMessage | Used to display an error message.
 | ExpressionOperatorsCollection | Collection of ExpressionOperators objects (that contains the strings used for AND/OR operators)
 | FeaturedDocument | Represents a featured document, when a search matches criteria specified here, a featured result is created.
 | FeaturedDocuments | Collection of FeaturedDocument objects
 | FeaturedDocumentsConverter | Type converter for FeaturedDocuments collection.
 | FeaturedResults | Server Control which presents featured results to the user.
 | FileTypeCollection | Maps mime-type strings to file extensions.
 | FileTypeItem | A file type item which maps a file extension to a mime type.
 | FlexiFilePath | File path specifiable through a relative URL or a absolute file path.
 | Footer | The footer shown below the search results.
 | Header | The header shown before the search results.
 | ICache |
 | KButton | RapidSpell button
 | KCheckBox | Keyoti CheckBox control
 | KDropDownList | Keyoti DropDownList control
 | KFont | Keyoti Font class
 | KLabel | Keyoti Label Control
 | KTextBox | RapidSpell button
 | SearchResult..::..Mode | The possible viewing modes that this control can be in.
 | NET4 |
 | NoQuery | Shown when there is no search query
 | NoResults | Shown when there are no results
 | PopularAutoCompleteRegister |
 | AutoCompletePopularSearchHelper..::..QueryTally | Represents a query and its hit tally.
 | ResultItem | A result item, shown between the header and footer.
 | ResultsPageClickEventArgs | The event arguments for a results page link click.
 | SearchResult..::..ResultsPageClickEventHandler | Defines a handler for PageXClicked event.
 | SearchBox | Web control giving the user a texbox to enter a search query, and submit button to run the search.
 | SearchBoxAutoCompleteHelper | Handles auto complete AJAX requests
 | SearchBoxOptions | Web control allowing the user to select location and content options that will be used by search
 | SearchBoxOptionsLayout | The layout style for this control.
 | SearchContentOptions | Web control exposing a collection of check boxes, that will allow a content categories selection
 | SearchResult | Web control performing search and showing results to the user.
 | SearchResultControlSummaryOptions | Options for the result summaries.
 | SearchResultItemEventArgs | Holds information about the SearchResult item event.
 | SearchResult..::..SearchResultItemEventHandler | Event handler for the ItemCreated event.
 | SearchResultPreviewHelper | Handles search result preview requests
 | SearchSuggestions | Web Control that spell checks query expressions used for the searches, and displays suggestions if necessary/possible.
 | SearchBoxAutoCompleteHelper..::..SuggestionResultPair | An autocomplete suggestion - this includes the suggested search 'query' and (if requested) the approximate number of results for the query.
 | SystemWebCachingCache |
 | Utils | Various utilities.


AutoCompletePopularSearchHelper Class

AutoCompletePopularSearchHelper Class
API Documentation ► Keyoti.SearchEngine.Web ► AutoCompletePopularSearchHelper
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public class AutoCompletePopularSearchHelper
Public Class AutoCompletePopularSearchHelper
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AutoCompletePopularSearchHelper(ICache, String) |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
AutoCompletePopularSearchHelper

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


AutoCompletePopularSearchHelper Constructor (cache, indexDirectory)

AutoCompletePopularSearchHelper Constructor (cache, indexDirectory)
API Documentation ► Keyoti.SearchEngine.Web ► AutoCompletePopularSearchHelper ► AutoCompletePopularSearchHelper(ICache, String)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public AutoCompletePopularSearchHelper(
    ICache cache,
    string indexDirectory
)
Public Sub New (
    cache As ICache,
    indexDirectory As String
)
Parameters
cache (ICache)
indexDirectory (String)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


AutoCompletePopularSearchHelper.QueryTally Class

AutoCompletePopularSearchHelper..::..QueryTally Class
API Documentation ► Keyoti.SearchEngine.Web ► AutoCompletePopularSearchHelper ► AutoCompletePopularSearchHelper..::..QueryTally
Keyoti SearchUnit v6
Represents a query and its hit tally.
Declaration Syntax
C# Visual Basic
public class QueryTally
Public Class QueryTally
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AutoCompletePopularSearchHelper..::..QueryTally()()()() | New.
 | AutoCompletePopularSearchHelper..::..QueryTally(String) | New
 | AutoCompletePopularSearchHelper..::..QueryTally(String, Int32) | New
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IncTally(Int32, Boolean) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Query | The query
 | Tally | The tally
 | TallyDelta | The change in tally since last synch.
 | ToString()()()() | (Overrides Object.ToString()()()().)
Inheritance Hierarchy
Object
AutoCompletePopularSearchHelper..::..QueryTally

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


AutoCompletePopularSearchHelper.QueryTally Constructor

AutoCompletePopularSearchHelper..::..QueryTally Constructor
API Documentation ► Keyoti.SearchEngine.Web ► AutoCompletePopularSearchHelper..::..QueryTally ► AutoCompletePopularSearchHelper..::..QueryTally()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | AutoCompletePopularSearchHelper..::..QueryTally()()()() | New.
 | AutoCompletePopularSearchHelper..::..QueryTally(String) | New
 | AutoCompletePopularSearchHelper..::..QueryTally(String, Int32) | New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


AutoCompletePopularSearchHelper.QueryTally Constructor

AutoCompletePopularSearchHelper..::..QueryTally Constructor
API Documentation ► Keyoti.SearchEngine.Web ► AutoCompletePopularSearchHelper..::..QueryTally ► AutoCompletePopularSearchHelper..::..QueryTally()()()()
Keyoti SearchUnit v6
New.
Declaration Syntax
C# Visual Basic
public QueryTally()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


AutoCompletePopularSearchHelper.QueryTally Constructor (formattedString)

AutoCompletePopularSearchHelper..::..QueryTally Constructor (formattedString)
API Documentation ► Keyoti.SearchEngine.Web ► AutoCompletePopularSearchHelper..::..QueryTally ► AutoCompletePopularSearchHelper..::..QueryTally(String)
Keyoti SearchUnit v6
New
Declaration Syntax
C# Visual Basic
public QueryTally(
    string formattedString
)
Public Sub New (
    formattedString As String
)
Parameters
formattedString (String)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


AutoCompletePopularSearchHelper.QueryTally Constructor (_query, _tally)

AutoCompletePopularSearchHelper..::..QueryTally Constructor (_query, _tally)
API Documentation ► Keyoti.SearchEngine.Web ► AutoCompletePopularSearchHelper..::..QueryTally ► AutoCompletePopularSearchHelper..::..QueryTally(String, Int32)
Keyoti SearchUnit v6
New
Declaration Syntax
C# Visual Basic
public QueryTally(
    string _query,
    int _tally
)
Public Sub New (
    _query As String,
    _tally As Integer
)
Parameters
_query (String)
_tally (Int32)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


IncTally Method (amount, incrementTallyDelta)

IncTally Method (amount, incrementTallyDelta)
API Documentation ► Keyoti.SearchEngine.Web ► AutoCompletePopularSearchHelper..::..QueryTally ► IncTally(Int32, Boolean)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public void IncTally(
    int amount,
    bool incrementTallyDelta
)
Public Sub IncTally (
    amount As Integer,
    incrementTallyDelta As Boolean
)
Parameters
amount (Int32)
incrementTallyDelta (Boolean)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Query Property

Query Property
API Documentation ► Keyoti.SearchEngine.Web ► AutoCompletePopularSearchHelper..::..QueryTally ► Query
Keyoti SearchUnit v6
The query
Declaration Syntax
C# Visual Basic
public string Query { get; }
Public ReadOnly Property Query As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Tally Property

Tally Property
API Documentation ► Keyoti.SearchEngine.Web ► AutoCompletePopularSearchHelper..::..QueryTally ► Tally
Keyoti SearchUnit v6
The tally
Declaration Syntax
C# Visual Basic
public int Tally { get; }
Public ReadOnly Property Tally As Integer
    Get
Property Value
Int32

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


TallyDelta Property

TallyDelta Property
API Documentation ► Keyoti.SearchEngine.Web ► AutoCompletePopularSearchHelper..::..QueryTally ► TallyDelta
Keyoti SearchUnit v6
The change in tally since last synch.
Declaration Syntax
C# Visual Basic
public int TallyDelta { get; }
Public ReadOnly Property TallyDelta As Integer
    Get
Property Value
Int32

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ToString Method

ToString Method
API Documentation ► Keyoti.SearchEngine.Web ► AutoCompletePopularSearchHelper..::..QueryTally ► ToString()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public override string ToString()
Public Overrides Function ToString As String
Return Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


CallBackHandler Class

CallBackHandler Class
API Documentation ► Keyoti.SearchEngine.Web ► CallBackHandler
Keyoti SearchUnit v6
Handles AJAX call backs
Declaration Syntax
C# Visual Basic
public class CallBackHandler : IHttpHandler
Public Class CallBackHandler
    Implements IHttpHandler
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CallBackHandler()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IsReusable | Returns true
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ProcessRequest(HttpContext) | Processes the ajax request
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
CallBackHandler

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


CallBackHandler Constructor

CallBackHandler Constructor
API Documentation ► Keyoti.SearchEngine.Web ► CallBackHandler ► CallBackHandler()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public CallBackHandler()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


IsReusable Property

IsReusable Property
API Documentation ► Keyoti.SearchEngine.Web ► CallBackHandler ► IsReusable
Keyoti SearchUnit v6
Returns true
Declaration Syntax
C# Visual Basic
public bool IsReusable { get; }
Public ReadOnly Property IsReusable As Boolean
    Get
Property Value
Boolean

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ProcessRequest Method (ctx)

ProcessRequest Method (ctx)
API Documentation ► Keyoti.SearchEngine.Web ► CallBackHandler ► ProcessRequest(HttpContext)
Keyoti SearchUnit v6
Processes the ajax request
Declaration Syntax
C# Visual Basic
public void ProcessRequest(
    HttpContext ctx
)
Public Sub ProcessRequest (
    ctx As HttpContext
)
Parameters
ctx (HttpContext)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ClientFilesLocation Enumeration

ClientFilesLocation Enumeration
API Documentation ► Keyoti.SearchEngine.Web ► ClientFilesLocation
Keyoti SearchUnit v6
Where the client files should be obtained from.
Declaration Syntax
C# Visual Basic
public enum ClientFilesLocation
Public Enumeration ClientFilesLocation
Members
Member | Description
Internal | Stored in the control DLL (.NET 2 only).
External | Stored at URL specified by ClientFilesFolder property.

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ErrorMessage Class

ErrorMessage Class
API Documentation ► Keyoti.SearchEngine.Web ► ErrorMessage
Keyoti SearchUnit v6
Used to display an error message.
Declaration Syntax
C# Visual Basic
public class ErrorMessage : WebControl,
    INamingContainer
Public Class ErrorMessage
    Inherits WebControl
    Implements INamingContainer
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ErrorMessage(String, String) | Creates a new instance.
 | ErrorMessage()()()() | Creates a new instance.
 | AccessKey | (Inherited from WebControl.)
 | Adapter | (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | (Inherited from Control.)
 | AddParsedSubObject(Object) | (Inherited from Control.)
 | ApplyStyle(Style) | (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | (Inherited from Control.)
 | Attributes | (Inherited from WebControl.)
 | BackColor | (Inherited from WebControl.)
 | BeginRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | BindingContainer | (Inherited from Control.)
 | BorderColor | (Inherited from WebControl.)
 | BorderStyle | (Inherited from WebControl.)
 | BorderWidth | (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | (Inherited from Control.)
 | ChildControlsCreated | (Inherited from Control.)
 | ClearCachedClientID()()()() | (Inherited from Control.)
 | ClearChildControlState()()()() | (Inherited from Control.)
 | ClearChildState()()()() | (Inherited from Control.)
 | ClearChildViewState()()()() | (Inherited from Control.)
 | ClearEffectiveClientIDMode()()()() | (Inherited from Control.)
 | ClientID | (Inherited from Control.)
 | ClientIDMode | (Inherited from Control.)
 | ClientIDSeparator | (Inherited from Control.)
 | Context | (Inherited from Control.)
 | Controls | (Inherited from Control.)
 | ControlStyle | (Inherited from WebControl.)
 | ControlStyleCreated | (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | (Inherited from WebControl.)
 | CreateChildControls()()()() | (Inherited from Control.)
 | CreateControlCollection()()()() | (Inherited from Control.)
 | CreateControlStyle()()()() | (Inherited from WebControl.)
 | CssClass | (Inherited from WebControl.)
 | DataBind()()()() | (Inherited from Control.)
 | DataBind(Boolean) | (Inherited from Control.)
 | DataBindChildren()()()() | (Inherited from Control.)
 | DataBinding | (Inherited from Control.)
 | DataItemContainer | (Inherited from Control.)
 | DataKeysContainer | (Inherited from Control.)
 | DesignMode | (Inherited from Control.)
 | Dispose()()()() | (Inherited from Control.)
 | Disposed | (Inherited from Control.)
 | Enabled | (Inherited from WebControl.)
 | EnableTheming | (Inherited from WebControl.)
 | EnableViewState | (Inherited from Control.)
 | EndRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | EnsureChildControls()()()() | (Inherited from Control.)
 | EnsureID()()()() | (Inherited from Control.)
 | Equals(Object) | (Inherited from Object.)
 | Events | (Inherited from Control.)
 | ExceptionMessage | The exception message.
 | Finalize()()()() | (Inherited from Object.)
 | FindControl(String) | (Inherited from Control.)
 | FindControl(String, Int32) | (Inherited from Control.)
 | Focus()()()() | (Inherited from Control.)
 | Font | (Inherited from WebControl.)
 | ForeColor | (Inherited from WebControl.)
 | GetDesignModeState()()()() | (Inherited from Control.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetRouteUrl(Object) | (Inherited from Control.)
 | GetRouteUrl(String, Object) | (Inherited from Control.)
 | GetRouteUrl(RouteValueDictionary) | (Inherited from Control.)
 | GetRouteUrl(String, RouteValueDictionary) | (Inherited from Control.)
 | GetType()()()() | (Inherited from Object.)
 | GetUniqueIDRelativeTo(Control) | (Inherited from Control.)
 | HasAttributes | (Inherited from WebControl.)
 | HasChildViewState | (Inherited from Control.)
 | HasControls()()()() | (Inherited from Control.)
 | HasEvents()()()() | (Inherited from Control.)
 | Height | (Inherited from WebControl.)
 | ID | (Inherited from Control.)
 | IdSeparator | (Inherited from Control.)
 | Init | (Inherited from Control.)
 | IsChildControlStateCleared | (Inherited from Control.)
 | IsEnabled | (Inherited from WebControl.)
 | IsLiteralContent()()()() | (Inherited from Control.)
 | IsTrackingViewState | (Inherited from Control.)
 | IsViewStateEnabled | (Inherited from Control.)
 | Load | (Inherited from Control.)
 | LoadControlState(Object) | (Inherited from Control.)
 | LoadViewState(Object) | (Inherited from WebControl.)
 | LoadViewStateByID | (Inherited from Control.)
 | MapPathSecure(String) | (Inherited from Control.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle(Style) | (Inherited from WebControl.)
 | Message | The user friendly error message.
 | NamingContainer | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | (Inherited from Control.)
 | OnDataBinding(EventArgs) | (Inherited from Control.)
 | OnInit(EventArgs) | (Inherited from Control.)
 | OnLoad(EventArgs) | (Inherited from Control.)
 | OnPreRender(EventArgs) | (Inherited from Control.)
 | OnUnload(EventArgs) | (Inherited from Control.)
 | OpenFile(String) | (Inherited from Control.)
 | Page | (Inherited from Control.)
 | Parent | (Inherited from Control.)
 | PreRender | (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | (Inherited from Control.)
 | RemovedControl(Control) | (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingCompatibility | (Inherited from Control.)
 | ResolveAdapter()()()() | (Inherited from Control.)
 | ResolveClientUrl(String) | (Inherited from Control.)
 | ResolveUrl(String) | (Inherited from Control.)
 | SaveControlState()()()() | (Inherited from Control.)
 | SaveViewState()()()() | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | (Inherited from Control.)
 | SetTraceData(Object, Object) | (Inherited from Control.)
 | SetTraceData(Object, Object, Object) | (Inherited from Control.)
 | Site | (Inherited from Control.)
 | SkinID | (Inherited from WebControl.)
 | Style | (Inherited from WebControl.)
 | SupportsDisabledAttribute | (Inherited from WebControl.)
 | TabIndex | (Inherited from WebControl.)
 | TagKey | (Inherited from WebControl.)
 | TagName | (Inherited from WebControl.)
 | TemplateControl | (Inherited from Control.)
 | TemplateSourceDirectory | (Inherited from Control.)
 | ToolTip | (Inherited from WebControl.)
 | ToString()()()() | (Inherited from Object.)
 | TrackViewState()()()() | (Inherited from WebControl.)
 | UniqueID | (Inherited from Control.)
 | Unload | (Inherited from Control.)
 | ValidateRequestMode | (Inherited from Control.)
 | ViewState | (Inherited from Control.)
 | ViewStateIgnoresCase | (Inherited from Control.)
 | ViewStateMode | (Inherited from Control.)
 | Visible | (Inherited from Control.)
 | Width | (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | ErrorMessage

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ErrorMessage Constructor

ErrorMessage Constructor
API Documentation ► Keyoti.SearchEngine.Web ► ErrorMessage ► ErrorMessage()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | ErrorMessage(String, String) | Creates a new instance.
 | ErrorMessage()()()() | Creates a new instance.

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ErrorMessage Constructor

ErrorMessage Constructor
API Documentation ► Keyoti.SearchEngine.Web ► ErrorMessage ► ErrorMessage()()()()
Keyoti SearchUnit v6
Creates a new instance.
Declaration Syntax
C# Visual Basic
public ErrorMessage()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ErrorMessage Constructor (reasonMessage, exceptionMessage)

ErrorMessage Constructor (reasonMessage, exceptionMessage)
API Documentation ► Keyoti.SearchEngine.Web ► ErrorMessage ► ErrorMessage(String, String)
Keyoti SearchUnit v6
Creates a new instance.
Declaration Syntax
C# Visual Basic
public ErrorMessage(
    string reasonMessage,
    string exceptionMessage
)
Public Sub New (
    reasonMessage As String,
    exceptionMessage As String
)
Parameters
reasonMessage (String)
exceptionMessage (String)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ExceptionMessage Property

ExceptionMessage Property
API Documentation ► Keyoti.SearchEngine.Web ► ErrorMessage ► ExceptionMessage
Keyoti SearchUnit v6
The exception message.
Declaration Syntax
C# Visual Basic
public string ExceptionMessage { get; set; }
Public Property ExceptionMessage As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Message Property

Message Property
API Documentation ► Keyoti.SearchEngine.Web ► ErrorMessage ► Message
Keyoti SearchUnit v6
The user friendly error message.
Declaration Syntax
C# Visual Basic
public string Message { get; set; }
Public Property Message As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ExpressionOperatorsCollection Class

ExpressionOperatorsCollection Class
API Documentation ► Keyoti.SearchEngine.Web ► ExpressionOperatorsCollection
Keyoti SearchUnit v6
Collection of ExpressionOperators objects (that contains the strings used for AND/OR operators)
Declaration Syntax
C# Visual Basic
public class ExpressionOperatorsCollection : CollectionBase
Public Class ExpressionOperatorsCollection
    Inherits CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExpressionOperatorsCollection()()()() | Creates a new instance of the collection
 | ExpressionOperatorsCollection(String) |
 | Add(ExpressionOperators) | Add a new item to the collection
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InnerList | (Inherited from CollectionBase.)
 | Item[([( Int32])]) | Collection's indexer
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ExpressionOperators) | Removes an item from the collections
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | ToString()()()() | (Overrides Object.ToString()()()().)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ExpressionOperatorsCollection

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ExpressionOperatorsCollection Constructor

ExpressionOperatorsCollection Constructor
API Documentation ► Keyoti.SearchEngine.Web ► ExpressionOperatorsCollection ► ExpressionOperatorsCollection()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | ExpressionOperatorsCollection()()()() | Creates a new instance of the collection
 | ExpressionOperatorsCollection(String) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ExpressionOperatorsCollection Constructor

ExpressionOperatorsCollection Constructor
API Documentation ► Keyoti.SearchEngine.Web ► ExpressionOperatorsCollection ► ExpressionOperatorsCollection()()()()
Keyoti SearchUnit v6
Creates a new instance of the collection
Declaration Syntax
C# Visual Basic
public ExpressionOperatorsCollection()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ExpressionOperatorsCollection Constructor (itemsString)

ExpressionOperatorsCollection Constructor (itemsString)
API Documentation ► Keyoti.SearchEngine.Web ► ExpressionOperatorsCollection ► ExpressionOperatorsCollection(String)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public ExpressionOperatorsCollection(
    string itemsString
)
Public Sub New (
    itemsString As String
)
Parameters
itemsString (String)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Add Method (item)

Add Method (item)
API Documentation ► Keyoti.SearchEngine.Web ► ExpressionOperatorsCollection ► Add(ExpressionOperators)
Keyoti SearchUnit v6
Add a new item to the collection
Declaration Syntax
C# Visual Basic
public void Add(
    ExpressionOperators item
)
Public Sub Add (
    item As ExpressionOperators
)
Parameters
item (ExpressionOperators)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Item Property (index)

Item Property (index)
API Documentation ► Keyoti.SearchEngine.Web ► ExpressionOperatorsCollection ► Item[([( Int32])])
Keyoti SearchUnit v6
Collection's indexer
Declaration Syntax
C# Visual Basic
public ExpressionOperators this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As ExpressionOperators
    Get
Parameters
index (Int32)
Property Value
ExpressionOperators

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Remove Method (item)

Remove Method (item)
API Documentation ► Keyoti.SearchEngine.Web ► ExpressionOperatorsCollection ► Remove(ExpressionOperators)
Keyoti SearchUnit v6
Removes an item from the collections
Declaration Syntax
C# Visual Basic
public void Remove(
    ExpressionOperators item
)
Public Sub Remove (
    item As ExpressionOperators
)
Parameters
item (ExpressionOperators)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ToString Method

ToString Method
API Documentation ► Keyoti.SearchEngine.Web ► ExpressionOperatorsCollection ► ToString()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public override string ToString()
Public Overrides Function ToString As String
Return Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FeaturedDocument Class

FeaturedDocument Class
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedDocument
Keyoti SearchUnit v6
Represents a featured document, when a search matches criteria specified here, a featured result is created.
Declaration Syntax
C# Visual Basic
public class FeaturedDocument
Public Class FeaturedDocument
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FeaturedDocument()()()() | Creates a new instance.
 | FeaturedDocument(String, String, String, String) | Creates a new instance.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Keywords | Keywords which will trigger this to be shown as a result.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Summary | The summary to display in the featured result.
 | Title | The title to display in the featured result.
 | ToString()()()() | Returns this object as a pipe delimited string. (Overrides Object.ToString()()()().)
 | Uri | The URI the featured result should link to.
Inheritance Hierarchy
Object
FeaturedDocument

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FeaturedDocument Constructor

FeaturedDocument Constructor
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedDocument ► FeaturedDocument()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FeaturedDocument()()()() | Creates a new instance.
 | FeaturedDocument(String, String, String, String) | Creates a new instance.

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FeaturedDocument Constructor

FeaturedDocument Constructor
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedDocument ► FeaturedDocument()()()()
Keyoti SearchUnit v6
Creates a new instance.
Declaration Syntax
C# Visual Basic
public FeaturedDocument()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FeaturedDocument Constructor (uri, title, summary, keywords)

FeaturedDocument Constructor (uri, title, summary, keywords)
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedDocument ► FeaturedDocument(String, String, String, String)
Keyoti SearchUnit v6
Creates a new instance.
Declaration Syntax
C# Visual Basic
public FeaturedDocument(
    string uri,
    string title,
    string summary,
    string keywords
)
Public Sub New (
    uri As String,
    title As String,
    summary As String,
    keywords As String
)
Parameters
uri (String)
title (String)
summary (String)
keywords (String)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Keywords Property

Keywords Property
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedDocument ► Keywords
Keyoti SearchUnit v6
Keywords which will trigger this to be shown as a result.
Declaration Syntax
C# Visual Basic
public string Keywords { get; set; }
Public Property Keywords As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Summary Property

Summary Property
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedDocument ► Summary
Keyoti SearchUnit v6
The summary to display in the featured result.
Declaration Syntax
C# Visual Basic
public string Summary { get; set; }
Public Property Summary As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Title Property

Title Property
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedDocument ► Title
Keyoti SearchUnit v6
The title to display in the featured result.
Declaration Syntax
C# Visual Basic
public string Title { get; set; }
Public Property Title As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ToString Method

ToString Method
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedDocument ► ToString()()()()
Keyoti SearchUnit v6
Returns this object as a pipe delimited string.
Declaration Syntax
C# Visual Basic
public override string ToString()
Public Overrides Function ToString As String
Return Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Uri Property

Uri Property
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedDocument ► Uri
Keyoti SearchUnit v6
The URI the featured result should link to.
Declaration Syntax
C# Visual Basic
public string Uri { get; set; }
Public Property Uri As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FeaturedDocuments Class

FeaturedDocuments Class
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedDocuments
Keyoti SearchUnit v6
Collection of FeaturedDocument objects
Declaration Syntax
C# Visual Basic
[TypeConverterAttribute(typeof(FeaturedDocumentsConverter))]
public class FeaturedDocuments : CollectionBase
<TypeConverterAttribute(GetType(FeaturedDocumentsConverter))>
Public Class FeaturedDocuments
    Inherits CollectionBase
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FeaturedDocuments()()()() | Creates a new instance.
 | FeaturedDocuments(String) | Creates a new instance, from the data in itemsString.
 | Add(FeaturedDocument) | Adds a FeaturedDocument to the collection.
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InnerList | (Inherited from CollectionBase.)
 | Item[([( Int32])]) | Indexer access to a FeaturedDocument in the collection.
 | List | (Inherited from CollectionBase.)
 | ListChanged |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Overrides CollectionBase.OnInsert(Int32, Object).)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Overrides CollectionBase.OnRemoveComplete(Int32, Object).)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Overrides CollectionBase.OnSetComplete(Int32, Object, Object).)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(FeaturedDocument) | Removes a FeaturedDocument from the collection.
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | ToString()()()() | Returns this collection of FeaturedDocument objects as a double-pipe delimited string. (Overrides Object.ToString()()()().)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | FeaturedDocuments

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FeaturedDocuments Constructor

FeaturedDocuments Constructor
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedDocuments ► FeaturedDocuments()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FeaturedDocuments()()()() | Creates a new instance.
 | FeaturedDocuments(String) | Creates a new instance, from the data in itemsString.

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FeaturedDocuments Constructor

FeaturedDocuments Constructor
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedDocuments ► FeaturedDocuments()()()()
Keyoti SearchUnit v6
Creates a new instance.
Declaration Syntax
C# Visual Basic
public FeaturedDocuments()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FeaturedDocuments Constructor (itemsString)

FeaturedDocuments Constructor (itemsString)
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedDocuments ► FeaturedDocuments(String)
Keyoti SearchUnit v6
Creates a new instance, from the data in itemsString.
Declaration Syntax
C# Visual Basic
public FeaturedDocuments(
    string itemsString
)
Public Sub New (
    itemsString As String
)
Parameters
itemsString (String)
Remarks
itemsString is formatted as fDoc1Uri|fDoc1Title|fDoc1Summary|fDoc1Keywords||fDoc2Uri|fDoc2Title|fDoc2Summary|fDoc2Keywords ...

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Add Method (item)

Add Method (item)
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedDocuments ► Add(FeaturedDocument)
Keyoti SearchUnit v6
Adds a FeaturedDocument to the collection.
Declaration Syntax
C# Visual Basic
public void Add(
    FeaturedDocument item
)
Public Sub Add (
    item As FeaturedDocument
)
Parameters
item (FeaturedDocument)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Item Property (index)

Item Property (index)
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedDocuments ► Item[([( Int32])])
Keyoti SearchUnit v6
Indexer access to a FeaturedDocument in the collection.
Declaration Syntax
C# Visual Basic
public FeaturedDocument this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As FeaturedDocument
    Get
Parameters
index (Int32)
Property Value
FeaturedDocument

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ListChanged Event

ListChanged Event
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedDocuments ► ListChanged
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public event ListChangedEventHandler ListChanged
Public Event ListChanged As ListChangedEventHandler
Value
ListChangedEventHandler

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


OnInsert Method (index, value)

OnInsert Method (index, value)
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedDocuments ► OnInsert(Int32, Object)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
protected override void OnInsert(
    int index,
    Object value
)
Protected Overrides Sub OnInsert (
    index As Integer,
    value As Object
)
Parameters
index (Int32)
value (Object)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


OnRemoveComplete Method (index, value)

OnRemoveComplete Method (index, value)
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedDocuments ► OnRemoveComplete(Int32, Object)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
protected override void OnRemoveComplete(
    int index,
    Object value
)
Protected Overrides Sub OnRemoveComplete (
    index As Integer,
    value As Object
)
Parameters
index (Int32)
value (Object)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


OnSetComplete Method (index, oldValue, newValue)

OnSetComplete Method (index, oldValue, newValue)
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedDocuments ► OnSetComplete(Int32, Object, Object)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
protected override void OnSetComplete(
    int index,
    Object oldValue,
    Object newValue
)
Protected Overrides Sub OnSetComplete (
    index As Integer,
    oldValue As Object,
    newValue As Object
)
Parameters
index (Int32)
oldValue (Object)
newValue (Object)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Remove Method (item)

Remove Method (item)
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedDocuments ► Remove(FeaturedDocument)
Keyoti SearchUnit v6
Removes a FeaturedDocument from the collection.
Declaration Syntax
C# Visual Basic
public void Remove(
    FeaturedDocument item
)
Public Sub Remove (
    item As FeaturedDocument
)
Parameters
item (FeaturedDocument)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ToString Method

ToString Method
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedDocuments ► ToString()()()()
Keyoti SearchUnit v6
Returns this collection of FeaturedDocument objects as a double-pipe delimited string.
Declaration Syntax
C# Visual Basic
public override string ToString()
Public Overrides Function ToString As String
Return Value
String
featuredDocument1.ToString() + "||" + featuredDocument2.ToString() + ....

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FeaturedDocumentsConverter Class

FeaturedDocumentsConverter Class
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedDocumentsConverter
Keyoti SearchUnit v6
Type converter for FeaturedDocuments collection.
Declaration Syntax
C# Visual Basic
public class FeaturedDocumentsConverter : TypeConverter
Public Class FeaturedDocumentsConverter
    Inherits TypeConverter
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | FeaturedDocumentsConverter()()()() | Creates a new instance
 | CanConvertFrom(ITypeDescriptorContext, Type) | Whether the converter can convert from sourceType. (Overrides TypeConverter.CanConvertFrom(ITypeDescriptorContext, Type).)
 | CanConvertFrom(Type) | (Inherited from TypeConverter.)
 | CanConvertTo(ITypeDescriptorContext, Type) | Whether the converter can convert to targetType. (Overrides TypeConverter.CanConvertTo(ITypeDescriptorContext, Type).)
 | CanConvertTo(Type) | (Inherited from TypeConverter.)
 | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts strings to collection (Overrides TypeConverter.ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
 | ConvertFrom(Object) | (Inherited from TypeConverter.)
 | ConvertFromInvariantString(String) | (Inherited from TypeConverter.)
 | ConvertFromInvariantString(ITypeDescriptorContext, String) | (Inherited from TypeConverter.)
 | ConvertFromString(String) | (Inherited from TypeConverter.)
 | ConvertFromString(ITypeDescriptorContext, String) | (Inherited from TypeConverter.)
 | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | (Inherited from TypeConverter.)
 | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Convert to string (Overrides TypeConverter.ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
 | ConvertTo(Object, Type) | (Inherited from TypeConverter.)
 | ConvertToInvariantString(Object) | (Inherited from TypeConverter.)
 | ConvertToInvariantString(ITypeDescriptorContext, Object) | (Inherited from TypeConverter.)
 | ConvertToString(Object) | (Inherited from TypeConverter.)
 | ConvertToString(ITypeDescriptorContext, Object) | (Inherited from TypeConverter.)
 | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | (Inherited from TypeConverter.)
 | CreateInstance(IDictionary) | (Inherited from TypeConverter.)
 | CreateInstance(ITypeDescriptorContext, IDictionary) | (Inherited from TypeConverter.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetConvertFromException(Object) | (Inherited from TypeConverter.)
 | GetConvertToException(Object, Type) | (Inherited from TypeConverter.)
 | GetCreateInstanceSupported()()()() | (Inherited from TypeConverter.)
 | GetCreateInstanceSupported(ITypeDescriptorContext) | (Inherited from TypeConverter.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetProperties(Object) | (Inherited from TypeConverter.)
 | GetProperties(ITypeDescriptorContext, Object) | (Inherited from TypeConverter.)
 | GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[][]) | (Inherited from TypeConverter.)
 | GetPropertiesSupported()()()() | (Inherited from TypeConverter.)
 | GetPropertiesSupported(ITypeDescriptorContext) | (Inherited from TypeConverter.)
 | GetStandardValues()()()() | (Inherited from TypeConverter.)
 | GetStandardValues(ITypeDescriptorContext) | (Inherited from TypeConverter.)
 | GetStandardValuesExclusive(ITypeDescriptorContext) | (Overrides TypeConverter.GetStandardValuesExclusive(ITypeDescriptorContext).)
 | GetStandardValuesExclusive()()()() | (Inherited from TypeConverter.)
 | GetStandardValuesSupported(ITypeDescriptorContext) | (Overrides TypeConverter.GetStandardValuesSupported(ITypeDescriptorContext).)
 | GetStandardValuesSupported()()()() | (Inherited from TypeConverter.)
 | GetType()()()() | (Inherited from Object.)
 | IsValid(Object) | (Inherited from TypeConverter.)
 | IsValid(ITypeDescriptorContext, Object) | (Inherited from TypeConverter.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SortProperties(PropertyDescriptorCollection, array<String>[]()[][]) | (Inherited from TypeConverter.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | TypeConverter
 |  | FeaturedDocumentsConverter

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FeaturedDocumentsConverter Constructor

FeaturedDocumentsConverter Constructor
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedDocumentsConverter ► FeaturedDocumentsConverter()()()()
Keyoti SearchUnit v6
Creates a new instance
Declaration Syntax
C# Visual Basic
public FeaturedDocumentsConverter()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


CanConvertFrom Method (context, sourceType)

CanConvertFrom Method (context, sourceType)
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedDocumentsConverter ► CanConvertFrom(ITypeDescriptorContext, Type)
Keyoti SearchUnit v6
Whether the converter can convert from sourceType.
Declaration Syntax
C# Visual Basic
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Public Overrides Function CanConvertFrom (
    context As ITypeDescriptorContext,
    sourceType As Type
) As Boolean
Parameters
context (ITypeDescriptorContext)
sourceType (Type)
Return Value
Boolean

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


CanConvertTo Method (context, targetType)

CanConvertTo Method (context, targetType)
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedDocumentsConverter ► CanConvertTo(ITypeDescriptorContext, Type)
Keyoti SearchUnit v6
Whether the converter can convert to targetType.
Declaration Syntax
C# Visual Basic
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type targetType
)
Public Overrides Function CanConvertTo (
    context As ITypeDescriptorContext,
    targetType As Type
) As Boolean
Parameters
context (ITypeDescriptorContext)
targetType (Type)
Return Value
Boolean

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ConvertFrom Method (context, culture, value)

ConvertFrom Method (context, culture, value)
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedDocumentsConverter ► ConvertFrom(ITypeDescriptorContext, CultureInfo, Object)
Keyoti SearchUnit v6
Converts strings to collection
Declaration Syntax
C# Visual Basic
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Public Overrides Function ConvertFrom (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object
) As Object
Parameters
context (ITypeDescriptorContext)
culture (CultureInfo)
value (Object)
Return Value
Object

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ConvertTo Method (context, culture, value, targetType)

ConvertTo Method (context, culture, value, targetType)
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedDocumentsConverter ► ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type)
Keyoti SearchUnit v6
Convert to string
Declaration Syntax
C# Visual Basic
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type targetType
)
Public Overrides Function ConvertTo (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object,
    targetType As Type
) As Object
Parameters
context (ITypeDescriptorContext)
culture (CultureInfo)
value (Object)
targetType (Type)
Return Value
Object

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


GetStandardValuesExclusive Method (context)

GetStandardValuesExclusive Method (context)
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedDocumentsConverter ► GetStandardValuesExclusive(ITypeDescriptorContext)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public override bool GetStandardValuesExclusive(
    ITypeDescriptorContext context
)
Public Overrides Function GetStandardValuesExclusive (
    context As ITypeDescriptorContext
) As Boolean
Parameters
context (ITypeDescriptorContext)
Return Value
Boolean

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


GetStandardValuesSupported Method (context)

GetStandardValuesSupported Method (context)
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedDocumentsConverter ► GetStandardValuesSupported(ITypeDescriptorContext)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public override bool GetStandardValuesSupported(
    ITypeDescriptorContext context
)
Public Overrides Function GetStandardValuesSupported (
    context As ITypeDescriptorContext
) As Boolean
Parameters
context (ITypeDescriptorContext)
Return Value
Boolean

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FeaturedResults Class

FeaturedResults Class
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedResults
Keyoti SearchUnit v6
Server Control which presents featured results to the user.
Declaration Syntax
C# Visual Basic
public class FeaturedResults : WebControl,
    INamingContainer
Public Class FeaturedResults
    Inherits WebControl
    Implements INamingContainer
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FeaturedResults()()()() |
 | AccessKey | (Inherited from WebControl.)
 | Adapter | (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | (Inherited from Control.)
 | AddParsedSubObject(Object) | (Inherited from Control.)
 | ApplyStyle(Style) | (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | (Inherited from Control.)
 | Attributes | (Inherited from WebControl.)
 | BackColor | (Inherited from WebControl.)
 | BeginRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | BindingContainer | (Inherited from Control.)
 | BorderColor | (Inherited from WebControl.)
 | BorderStyle | (Inherited from WebControl.)
 | BorderWidth | (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | (Inherited from Control.)
 | ChildControlsCreated | (Inherited from Control.)
 | ClearCachedClientID()()()() | (Inherited from Control.)
 | ClearChildControlState()()()() | (Inherited from Control.)
 | ClearChildState()()()() | (Inherited from Control.)
 | ClearChildViewState()()()() | (Inherited from Control.)
 | ClearEffectiveClientIDMode()()()() | (Inherited from Control.)
 | ClientID | (Inherited from Control.)
 | ClientIDMode | (Inherited from Control.)
 | ClientIDSeparator | (Inherited from Control.)
 | Context | (Inherited from Control.)
 | Controls | (Inherited from Control.)
 | ControlStyle | (Inherited from WebControl.)
 | ControlStyleCreated | (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | (Inherited from WebControl.)
 | CreateChildControls()()()() | Creates the child controls and performs the search based on featured documents (Overrides Control.CreateChildControls()()()().)
 | CreateControlCollection()()()() | (Inherited from Control.)
 | CreateControlStyle()()()() | (Inherited from WebControl.)
 | CssClass | (Inherited from WebControl.)
 | DataBind()()()() | (Inherited from Control.)
 | DataBind(Boolean) | (Inherited from Control.)
 | DataBindChildren()()()() | (Inherited from Control.)
 | DataBinding | (Inherited from Control.)
 | DataItemContainer | (Inherited from Control.)
 | DataKeysContainer | (Inherited from Control.)
 | DesignMode | (Inherited from Control.)
 | Dispose()()()() | (Inherited from Control.)
 | Disposed | (Inherited from Control.)
 | Enabled | (Inherited from WebControl.)
 | EnableTheming | (Inherited from WebControl.)
 | EnableViewState | (Inherited from Control.)
 | EndRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | EnsureChildControls()()()() | (Inherited from Control.)
 | EnsureID()()()() | (Inherited from Control.)
 | Equals(Object) | (Inherited from Object.)
 | Events | (Inherited from Control.)
 | FeaturedDocuments | Collection of documents that will be also searched for the query expression, persisted in HTML as FeaturedDoc1Uri|FeaturedDoc1Title|FeaturedDoc1Summary|FeaturedDoc1Keywords||FeaturedDoc2Uri.... (Documents delimited by ||, entities within document delimited by |, keywords is a list of words delimited by comma)
 | FeaturedHeaderTemplate | The header template shown above the featured search results.
 | FeaturedResultTemplate | Template for a search result, based on featured documents
 | Finalize()()()() | (Inherited from Object.)
 | FindControl(String) | (Inherited from Control.)
 | FindControl(String, Int32) | (Inherited from Control.)
 | Focus()()()() | (Inherited from Control.)
 | Font | (Inherited from WebControl.)
 | ForeColor | (Inherited from WebControl.)
 | GetDesignModeState()()()() | (Inherited from Control.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetRouteUrl(Object) | (Inherited from Control.)
 | GetRouteUrl(String, Object) | (Inherited from Control.)
 | GetRouteUrl(RouteValueDictionary) | (Inherited from Control.)
 | GetRouteUrl(String, RouteValueDictionary) | (Inherited from Control.)
 | GetType()()()() | (Inherited from Object.)
 | GetUniqueIDRelativeTo(Control) | (Inherited from Control.)
 | HasAttributes | (Inherited from WebControl.)
 | HasChildViewState | (Inherited from Control.)
 | HasControls()()()() | (Inherited from Control.)
 | HasEvents()()()() | (Inherited from Control.)
 | Height | (Inherited from WebControl.)
 | ID | (Inherited from Control.)
 | IdSeparator | (Inherited from Control.)
 | Init | (Inherited from Control.)
 | IsChildControlStateCleared | (Inherited from Control.)
 | IsEnabled | (Inherited from WebControl.)
 | IsLiteralContent()()()() | (Inherited from Control.)
 | IsTrackingViewState | (Inherited from Control.)
 | IsViewStateEnabled | (Inherited from Control.)
 | Load | (Inherited from Control.)
 | LoadControlState(Object) | (Inherited from Control.)
 | LoadViewState(Object) | (Inherited from WebControl.)
 | LoadViewStateByID | (Inherited from Control.)
 | MapPathSecure(String) | (Inherited from Control.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle(Style) | (Inherited from WebControl.)
 | NamingContainer | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | (Inherited from Control.)
 | OnDataBinding(EventArgs) | (Inherited from Control.)
 | OnInit(EventArgs) | (Inherited from Control.)
 | OnLoad(EventArgs) | (Inherited from Control.)
 | OnPreRender(EventArgs) | (Inherited from Control.)
 | OnUnload(EventArgs) | (Inherited from Control.)
 | OpenFile(String) | (Inherited from Control.)
 | Page | (Inherited from Control.)
 | Parent | (Inherited from Control.)
 | PreRender | (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | (Inherited from Control.)
 | RemovedControl(Control) | (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the control. (Overrides WebControl.RenderContents(HtmlTextWriter).)
 | RenderControl(HtmlTextWriter) | (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingCompatibility | (Inherited from Control.)
 | ResolveAdapter()()()() | (Inherited from Control.)
 | ResolveClientUrl(String) | (Inherited from Control.)
 | ResolveUrl(String) | (Inherited from Control.)
 | SaveControlState()()()() | (Inherited from Control.)
 | SaveViewState()()()() | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | (Inherited from Control.)
 | SetTraceData(Object, Object) | (Inherited from Control.)
 | SetTraceData(Object, Object, Object) | (Inherited from Control.)
 | Site | (Inherited from Control.)
 | SkinID | (Inherited from WebControl.)
 | Style | (Inherited from WebControl.)
 | SupportsDisabledAttribute | (Inherited from WebControl.)
 | TabIndex | (Inherited from WebControl.)
 | TagKey | See base. (Overrides WebControl.TagKey.)
 | TagName | (Inherited from WebControl.)
 | TemplateControl | (Inherited from Control.)
 | TemplateSourceDirectory | (Inherited from Control.)
 | ToolTip | (Inherited from WebControl.)
 | ToString()()()() | (Inherited from Object.)
 | TrackViewState()()()() | (Inherited from WebControl.)
 | UniqueID | (Inherited from Control.)
 | Unload | (Inherited from Control.)
 | ValidateRequestMode | (Inherited from Control.)
 | ViewState | (Inherited from Control.)
 | ViewStateIgnoresCase | (Inherited from Control.)
 | ViewStateMode | (Inherited from Control.)
 | Visible | (Inherited from Control.)
 | Width | (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | FeaturedResults

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FeaturedResults Constructor

FeaturedResults Constructor
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedResults ► FeaturedResults()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public FeaturedResults()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


CreateChildControls Method

CreateChildControls Method
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedResults ► CreateChildControls()()()()
Keyoti SearchUnit v6
Creates the child controls and performs the search based on featured documents
Declaration Syntax
C# Visual Basic
protected override void CreateChildControls()
Protected Overrides Sub CreateChildControls

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FeaturedDocuments Property

FeaturedDocuments Property
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedResults ► FeaturedDocuments
Keyoti SearchUnit v6
Collection of documents that will be also searched for the query expression, persisted in HTML as FeaturedDoc1Uri|FeaturedDoc1Title|FeaturedDoc1Summary|FeaturedDoc1Keywords||FeaturedDoc2Uri.... (Documents delimited by ||, entities within document delimited by |, keywords is a list of words delimited by comma)
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public virtual FeaturedDocuments FeaturedDocuments { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overridable Property FeaturedDocuments As FeaturedDocuments
    Get
    Set
Property Value
FeaturedDocuments

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FeaturedHeaderTemplate Property

FeaturedHeaderTemplate Property
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedResults ► FeaturedHeaderTemplate
Keyoti SearchUnit v6
The header template shown above the featured search results.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public virtual ITemplate FeaturedHeaderTemplate { get; set; }
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public Overridable Property FeaturedHeaderTemplate As ITemplate
    Get
    Set
Property Value
ITemplate

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FeaturedResultTemplate Property

FeaturedResultTemplate Property
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedResults ► FeaturedResultTemplate
Keyoti SearchUnit v6
Template for a search result, based on featured documents
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public virtual ITemplate FeaturedResultTemplate { get; set; }
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public Overridable Property FeaturedResultTemplate As ITemplate
    Get
    Set
Property Value
ITemplate

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


RenderContents Method (writer)

RenderContents Method (writer)
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedResults ► RenderContents(HtmlTextWriter)
Keyoti SearchUnit v6
Renders the control.
Declaration Syntax
C# Visual Basic
protected override void RenderContents(
    HtmlTextWriter writer
)
Protected Overrides Sub RenderContents (
    writer As HtmlTextWriter
)
Parameters
writer (HtmlTextWriter)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


TagKey Property

TagKey Property
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedResults ► TagKey
Keyoti SearchUnit v6
See base.
Declaration Syntax
C# Visual Basic
protected override HtmlTextWriterTag TagKey { get; }
Protected Overrides ReadOnly Property TagKey As HtmlTextWriterTag
    Get
Property Value
HtmlTextWriterTag

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FileTypeCollection Class

FileTypeCollection Class
API Documentation ► Keyoti.SearchEngine.Web ► FileTypeCollection
Keyoti SearchUnit v6
Maps mime-type strings to file extensions.
Declaration Syntax
C# Visual Basic
public class FileTypeCollection : CollectionBase
Public Class FileTypeCollection
    Inherits CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FileTypeCollection()()()() | Creates an empty collection
 | FileTypeCollection(String) | Creates a new collection using the items in itemsString as elements.
 | Add(FileTypeItem) | Adds a FileTypeItem
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InnerList | (Inherited from CollectionBase.)
 | Item[([( Int32])]) | Indexer for a file type item.
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(FileTypeItem) | Removes a FileTypeItem
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | ToString()()()() | Returns the collection as a delimeted string (Overrides Object.ToString()()()().)
Remarks
The name is the extension (without "."), the value is the mime-type.
Inheritance Hierarchy
Object
 | CollectionBase
 |  | FileTypeCollection

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FileTypeCollection Constructor

FileTypeCollection Constructor
API Documentation ► Keyoti.SearchEngine.Web ► FileTypeCollection ► FileTypeCollection()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FileTypeCollection()()()() | Creates an empty collection
 | FileTypeCollection(String) | Creates a new collection using the items in itemsString as elements.

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FileTypeCollection Constructor

FileTypeCollection Constructor
API Documentation ► Keyoti.SearchEngine.Web ► FileTypeCollection ► FileTypeCollection()()()()
Keyoti SearchUnit v6
Creates an empty collection
Declaration Syntax
C# Visual Basic
public FileTypeCollection()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FileTypeCollection Constructor (itemsString)

FileTypeCollection Constructor (itemsString)
API Documentation ► Keyoti.SearchEngine.Web ► FileTypeCollection ► FileTypeCollection(String)
Keyoti SearchUnit v6
Creates a new collection using the items in itemsString as elements.
Declaration Syntax
C# Visual Basic
public FileTypeCollection(
    string itemsString
)
Public Sub New (
    itemsString As String
)
Parameters
itemsString (String)
String formatted as; item1EXTENSION-item1MIME,item2EXTENSION-item2MIME

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Add Method (item)

Add Method (item)
API Documentation ► Keyoti.SearchEngine.Web ► FileTypeCollection ► Add(FileTypeItem)
Keyoti SearchUnit v6
Adds a FileTypeItem
Declaration Syntax
C# Visual Basic
public void Add(
    FileTypeItem item
)
Public Sub Add (
    item As FileTypeItem
)
Parameters
item (FileTypeItem)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Item Property (index)

Item Property (index)
API Documentation ► Keyoti.SearchEngine.Web ► FileTypeCollection ► Item[([( Int32])])
Keyoti SearchUnit v6
Indexer for a file type item.
Declaration Syntax
C# Visual Basic
public FileTypeItem this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As FileTypeItem
    Get
Parameters
index (Int32)
Property Value
FileTypeItem

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Remove Method (item)

Remove Method (item)
API Documentation ► Keyoti.SearchEngine.Web ► FileTypeCollection ► Remove(FileTypeItem)
Keyoti SearchUnit v6
Removes a FileTypeItem
Declaration Syntax
C# Visual Basic
public void Remove(
    FileTypeItem item
)
Public Sub Remove (
    item As FileTypeItem
)
Parameters
item (FileTypeItem)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ToString Method

ToString Method
API Documentation ► Keyoti.SearchEngine.Web ► FileTypeCollection ► ToString()()()()
Keyoti SearchUnit v6
Returns the collection as a delimeted string
Declaration Syntax
C# Visual Basic
public override string ToString()
Public Overrides Function ToString As String
Return Value
String
String formatted as; item1EXTENSION-item1MIME,item2EXTENSION-item2MIME

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FileTypeItem Class

FileTypeItem Class
API Documentation ► Keyoti.SearchEngine.Web ► FileTypeItem
Keyoti SearchUnit v6
A file type item which maps a file extension to a mime type.
Declaration Syntax
C# Visual Basic
public class FileTypeItem
Public Class FileTypeItem
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FileTypeItem()()()() | Create a new instance
 | FileTypeItem(String, String) | Create a new instance mapping an extension to a mime
 | Equals(Object) | (Inherited from Object.)
 | Extension | The file extension
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MimeType | The mime type
 | ToString()()()() | Returns a friendly representation of the mapping. (Overrides Object.ToString()()()().)
Inheritance Hierarchy
Object
FileTypeItem

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FileTypeItem Constructor

FileTypeItem Constructor
API Documentation ► Keyoti.SearchEngine.Web ► FileTypeItem ► FileTypeItem()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FileTypeItem()()()() | Create a new instance
 | FileTypeItem(String, String) | Create a new instance mapping an extension to a mime

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FileTypeItem Constructor

FileTypeItem Constructor
API Documentation ► Keyoti.SearchEngine.Web ► FileTypeItem ► FileTypeItem()()()()
Keyoti SearchUnit v6
Create a new instance
Declaration Syntax
C# Visual Basic
public FileTypeItem()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FileTypeItem Constructor (ext, mime)

FileTypeItem Constructor (ext, mime)
API Documentation ► Keyoti.SearchEngine.Web ► FileTypeItem ► FileTypeItem(String, String)
Keyoti SearchUnit v6
Create a new instance mapping an extension to a mime
Declaration Syntax
C# Visual Basic
public FileTypeItem(
    string ext,
    string mime
)
Public Sub New (
    ext As String,
    mime As String
)
Parameters
ext (String)
The file extension to map from
mime (String)
The mime-type associated to the extension

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Extension Property

Extension Property
API Documentation ► Keyoti.SearchEngine.Web ► FileTypeItem ► Extension
Keyoti SearchUnit v6
The file extension
Declaration Syntax
C# Visual Basic
public string Extension { get; set; }
Public Property Extension As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


MimeType Property

MimeType Property
API Documentation ► Keyoti.SearchEngine.Web ► FileTypeItem ► MimeType
Keyoti SearchUnit v6
The mime type
Declaration Syntax
C# Visual Basic
public string MimeType { get; set; }
Public Property MimeType As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ToString Method

ToString Method
API Documentation ► Keyoti.SearchEngine.Web ► FileTypeItem ► ToString()()()()
Keyoti SearchUnit v6
Returns a friendly representation of the mapping.
Declaration Syntax
C# Visual Basic
public override string ToString()
Public Overrides Function ToString As String
Return Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FlexiFilePath Class

FlexiFilePath Class
API Documentation ► Keyoti.SearchEngine.Web ► FlexiFilePath
Keyoti SearchUnit v6
File path specifiable through a relative URL or a absolute file path.
Declaration Syntax
C# Visual Basic
public class FlexiFilePath
Public Class FlexiFilePath
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FlexiFilePath(String, Page) | .Ctor
 | FlexiFilePath(String, HttpRequest) | .Ctor - ONLY USE THIS .CTOR WHEN PAGE IS NOT AVAILABLE
 | FlexiFilePath(String) | .Ctor - ONLY USE THIS .CTOR WHEN NOT USING RELATIVE PATHS
 | FlexiFilePath(String, ISite) | .Ctor - ONLY USE THIS .CTOR AT DESIGNTIME
 | AbsoluteFilePath | Resolves the flexipath into an absolute filepath and returns it.
 | Clone()()()() | Makes a copy of this object
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FlexiPath | Gets the flexipath
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SetFlexiPath(String) | Set's the flexi path
 | ToString()()()() | Returns the flexipath (Overrides Object.ToString()()()().)
 | UpdateResolver(Page) | When the original page instance used for resolving has gone, this method can be used to provide a new instance.
 | UpdateResolver(HttpRequest) | When the original request instance used for resolving has gone, this method can be used to provide a new instance.
 | UpdateResolver(ISite) | When the original ISite instance used for resolving has gone, this method can be used to provide a new instance.
Inheritance Hierarchy
Object
FlexiFilePath

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FlexiFilePath Constructor

FlexiFilePath Constructor
API Documentation ► Keyoti.SearchEngine.Web ► FlexiFilePath ► FlexiFilePath()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FlexiFilePath(String, Page) | .Ctor
 | FlexiFilePath(String, HttpRequest) | .Ctor - ONLY USE THIS .CTOR WHEN PAGE IS NOT AVAILABLE
 | FlexiFilePath(String) | .Ctor - ONLY USE THIS .CTOR WHEN NOT USING RELATIVE PATHS
 | FlexiFilePath(String, ISite) | .Ctor - ONLY USE THIS .CTOR AT DESIGNTIME

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FlexiFilePath Constructor (flexiPath)

FlexiFilePath Constructor (flexiPath)
API Documentation ► Keyoti.SearchEngine.Web ► FlexiFilePath ► FlexiFilePath(String)
Keyoti SearchUnit v6
.Ctor - ONLY USE THIS .CTOR WHEN NOT USING RELATIVE PATHS
Declaration Syntax
C# Visual Basic
public FlexiFilePath(
    string flexiPath
)
Public Sub New (
    flexiPath As String
)
Parameters
flexiPath (String)
Either a URL or a file path

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FlexiFilePath Constructor (flexiPath, site)

FlexiFilePath Constructor (flexiPath, site)
API Documentation ► Keyoti.SearchEngine.Web ► FlexiFilePath ► FlexiFilePath(String, ISite)
Keyoti SearchUnit v6
.Ctor - ONLY USE THIS .CTOR AT DESIGNTIME
Declaration Syntax
C# Visual Basic
public FlexiFilePath(
    string flexiPath,
    ISite site
)
Public Sub New (
    flexiPath As String,
    site As ISite
)
Parameters
flexiPath (String)
Either a URL or a file path
site (ISite)
Designer Site

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FlexiFilePath Constructor (flexiPath, req)

FlexiFilePath Constructor (flexiPath, req)
API Documentation ► Keyoti.SearchEngine.Web ► FlexiFilePath ► FlexiFilePath(String, HttpRequest)
Keyoti SearchUnit v6
.Ctor - ONLY USE THIS .CTOR WHEN PAGE IS NOT AVAILABLE
Declaration Syntax
C# Visual Basic
public FlexiFilePath(
    string flexiPath,
    HttpRequest req
)
Public Sub New (
    flexiPath As String,
    req As HttpRequest
)
Parameters
flexiPath (String)
Either a URL or a file path
req (HttpRequest)
The request which a URL is relative to

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FlexiFilePath Constructor (flexiPath, page)

FlexiFilePath Constructor (flexiPath, page)
API Documentation ► Keyoti.SearchEngine.Web ► FlexiFilePath ► FlexiFilePath(String, Page)
Keyoti SearchUnit v6
.Ctor
Declaration Syntax
C# Visual Basic
public FlexiFilePath(
    string flexiPath,
    Page page
)
Public Sub New (
    flexiPath As String,
    page As Page
)
Parameters
flexiPath (String)
Either a URL or a file path
page (Page)
The page holding the request which a URL is relative to

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


AbsoluteFilePath Property

AbsoluteFilePath Property
API Documentation ► Keyoti.SearchEngine.Web ► FlexiFilePath ► AbsoluteFilePath
Keyoti SearchUnit v6
Resolves the flexipath into an absolute filepath and returns it.
Declaration Syntax
C# Visual Basic
public string AbsoluteFilePath { get; }
Public ReadOnly Property AbsoluteFilePath As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Clone Method

Clone Method
API Documentation ► Keyoti.SearchEngine.Web ► FlexiFilePath ► Clone()()()()
Keyoti SearchUnit v6
Makes a copy of this object
Declaration Syntax
C# Visual Basic
public FlexiFilePath Clone()
Public Function Clone As FlexiFilePath
Return Value
FlexiFilePath

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FlexiPath Property

FlexiPath Property
API Documentation ► Keyoti.SearchEngine.Web ► FlexiFilePath ► FlexiPath
Keyoti SearchUnit v6
Gets the flexipath
Declaration Syntax
C# Visual Basic
public string FlexiPath { get; }
Public ReadOnly Property FlexiPath As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SetFlexiPath Method (newPath)

SetFlexiPath Method (newPath)
API Documentation ► Keyoti.SearchEngine.Web ► FlexiFilePath ► SetFlexiPath(String)
Keyoti SearchUnit v6
Set's the flexi path
Declaration Syntax
C# Visual Basic
public void SetFlexiPath(
    string newPath
)
Public Sub SetFlexiPath (
    newPath As String
)
Parameters
newPath (String)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ToString Method

ToString Method
API Documentation ► Keyoti.SearchEngine.Web ► FlexiFilePath ► ToString()()()()
Keyoti SearchUnit v6
Returns the flexipath
Declaration Syntax
C# Visual Basic
public override string ToString()
Public Overrides Function ToString As String
Return Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


UpdateResolver Method

UpdateResolver Method
API Documentation ► Keyoti.SearchEngine.Web ► FlexiFilePath ► UpdateResolver()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | UpdateResolver(Page) | When the original page instance used for resolving has gone, this method can be used to provide a new instance.
 | UpdateResolver(HttpRequest) | When the original request instance used for resolving has gone, this method can be used to provide a new instance.
 | UpdateResolver(ISite) | When the original ISite instance used for resolving has gone, this method can be used to provide a new instance.

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


UpdateResolver Method (resolver)

UpdateResolver Method (resolver)
API Documentation ► Keyoti.SearchEngine.Web ► FlexiFilePath ► UpdateResolver(ISite)
Keyoti SearchUnit v6
When the original ISite instance used for resolving has gone, this method can be used to provide a new instance.
Declaration Syntax
C# Visual Basic
public void UpdateResolver(
    ISite resolver
)
Public Sub UpdateResolver (
    resolver As ISite
)
Parameters
resolver (ISite)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


UpdateResolver Method (resolver)

UpdateResolver Method (resolver)
API Documentation ► Keyoti.SearchEngine.Web ► FlexiFilePath ► UpdateResolver(HttpRequest)
Keyoti SearchUnit v6
When the original request instance used for resolving has gone, this method can be used to provide a new instance.
Declaration Syntax
C# Visual Basic
public void UpdateResolver(
    HttpRequest resolver
)
Public Sub UpdateResolver (
    resolver As HttpRequest
)
Parameters
resolver (HttpRequest)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


UpdateResolver Method (resolver)

UpdateResolver Method (resolver)
API Documentation ► Keyoti.SearchEngine.Web ► FlexiFilePath ► UpdateResolver(Page)
Keyoti SearchUnit v6
When the original page instance used for resolving has gone, this method can be used to provide a new instance.
Declaration Syntax
C# Visual Basic
public void UpdateResolver(
    Page resolver
)
Public Sub UpdateResolver (
    resolver As Page
)
Parameters
resolver (Page)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Footer Class

Footer Class
API Documentation ► Keyoti.SearchEngine.Web ► Footer
Keyoti SearchUnit v6
The footer shown below the search results.
Declaration Syntax
C# Visual Basic
public class Footer : WebControl, INamingContainer
Public Class Footer
    Inherits WebControl
    Implements INamingContainer
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Footer()()()() | Creates a new instance with no member values.
 | Footer(String, Int32, Int32, Int32, String, String, Page, Control, String) | Creates a new instance and sets all properties.
 | AccessKey | (Inherited from WebControl.)
 | Adapter | (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | (Inherited from Control.)
 | AddParsedSubObject(Object) | (Inherited from Control.)
 | ApplyStyle(Style) | (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | (Inherited from Control.)
 | Attributes | (Inherited from WebControl.)
 | BackColor | (Inherited from WebControl.)
 | BeginRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | BindingContainer | (Inherited from Control.)
 | BorderColor | (Inherited from WebControl.)
 | BorderStyle | (Inherited from WebControl.)
 | BorderWidth | (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | (Inherited from Control.)
 | ChildControlsCreated | (Inherited from Control.)
 | ClearCachedClientID()()()() | (Inherited from Control.)
 | ClearChildControlState()()()() | (Inherited from Control.)
 | ClearChildState()()()() | (Inherited from Control.)
 | ClearChildViewState()()()() | (Inherited from Control.)
 | ClearEffectiveClientIDMode()()()() | (Inherited from Control.)
 | ClientID | (Inherited from Control.)
 | ClientIDMode | (Inherited from Control.)
 | ClientIDSeparator | (Inherited from Control.)
 | Context | (Inherited from Control.)
 | Controls | (Inherited from Control.)
 | ControlStyle | (Inherited from WebControl.)
 | ControlStyleCreated | (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | (Inherited from WebControl.)
 | CreateChildControls()()()() | (Inherited from Control.)
 | CreateControlCollection()()()() | (Inherited from Control.)
 | CreateControlStyle()()()() | (Inherited from WebControl.)
 | CssClass | (Inherited from WebControl.)
 | DataBind()()()() | (Inherited from Control.)
 | DataBind(Boolean) | (Inherited from Control.)
 | DataBindChildren()()()() | (Inherited from Control.)
 | DataBinding | (Inherited from Control.)
 | DataItemContainer | (Inherited from Control.)
 | DataKeysContainer | (Inherited from Control.)
 | DesignMode | (Inherited from Control.)
 | Dispose()()()() | (Inherited from Control.)
 | Disposed | (Inherited from Control.)
 | Enabled | (Inherited from WebControl.)
 | EnableTheming | (Inherited from WebControl.)
 | EnableViewState | (Inherited from Control.)
 | EndRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | EnsureChildControls()()()() | (Inherited from Control.)
 | EnsureID()()()() | (Inherited from Control.)
 | Equals(Object) | (Inherited from Object.)
 | Events | (Inherited from Control.)
 | Finalize()()()() | (Inherited from Object.)
 | FindControl(String) | (Inherited from Control.)
 | FindControl(String, Int32) | (Inherited from Control.)
 | Focus()()()() | (Inherited from Control.)
 | Font | (Inherited from WebControl.)
 | ForeColor | (Inherited from WebControl.)
 | GetDesignModeState()()()() | (Inherited from Control.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetRouteUrl(Object) | (Inherited from Control.)
 | GetRouteUrl(String, Object) | (Inherited from Control.)
 | GetRouteUrl(RouteValueDictionary) | (Inherited from Control.)
 | GetRouteUrl(String, RouteValueDictionary) | (Inherited from Control.)
 | GetType()()()() | (Inherited from Object.)
 | GetUniqueIDRelativeTo(Control) | (Inherited from Control.)
 | HasAttributes | (Inherited from WebControl.)
 | HasChildViewState | (Inherited from Control.)
 | HasControls()()()() | (Inherited from Control.)
 | HasEvents()()()() | (Inherited from Control.)
 | Height | (Inherited from WebControl.)
 | ID | (Inherited from Control.)
 | IdSeparator | (Inherited from Control.)
 | IgnoredWords | Comma delimited list of words which were not searched for (stop-list).
 | IgnoredWordsMessage | User friendly, English message, reporting ignored words (stop-list).
 | Init | (Inherited from Control.)
 | IsChildControlStateCleared | (Inherited from Control.)
 | IsEnabled | (Inherited from WebControl.)
 | IsLiteralContent()()()() | (Inherited from Control.)
 | IsTrackingViewState | (Inherited from Control.)
 | IsViewStateEnabled | (Inherited from Control.)
 | Load | (Inherited from Control.)
 | LoadControlState(Object) | (Inherited from Control.)
 | LoadViewState(Object) | (Inherited from WebControl.)
 | LoadViewStateByID | (Inherited from Control.)
 | MapPathSecure(String) | (Inherited from Control.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle(Style) | (Inherited from WebControl.)
 | NamingContainer | (Inherited from Control.)
 | NextPageLink | Link to the next page of results.
 | NumberOfResults | The number of results found.
 | NumberOfResultsPerPage | The number of results being shown per page.
 | OnBubbleEvent(Object, EventArgs) | (Inherited from Control.)
 | OnDataBinding(EventArgs) | (Inherited from Control.)
 | OnInit(EventArgs) | (Inherited from Control.)
 | OnLoad(EventArgs) | (Inherited from Control.)
 | OnPreRender(EventArgs) | (Inherited from Control.)
 | OnUnload(EventArgs) | (Inherited from Control.)
 | OpenFile(String) | (Inherited from Control.)
 | Page | (Inherited from Control.)
 | PageLinksBlock | Block of links to nearby pages.
 | Parent | (Inherited from Control.)
 | PreRender | (Inherited from Control.)
 | PreviousPageLink | Link to the previous page of results.
 | QueryExpression | The search query entered by the user.
 | RaiseBubbleEvent(Object, EventArgs) | (Inherited from Control.)
 | RemovedControl(Control) | (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | See base (Overrides WebControl.RenderBeginTag(HtmlTextWriter).)
 | RenderChildren(HtmlTextWriter) | (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | See base (Overrides WebControl.RenderEndTag(HtmlTextWriter).)
 | RenderingCompatibility | (Inherited from Control.)
 | ResolveAdapter()()()() | (Inherited from Control.)
 | ResolveClientUrl(String) | (Inherited from Control.)
 | ResolveUrl(String) | (Inherited from Control.)
 | ResultsPage | The current results page number.
 | SaveControlState()()()() | (Inherited from Control.)
 | SaveViewState()()()() | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | (Inherited from Control.)
 | SetTraceData(Object, Object) | (Inherited from Control.)
 | SetTraceData(Object, Object, Object) | (Inherited from Control.)
 | Site | (Inherited from Control.)
 | SkinID | (Inherited from WebControl.)
 | Style | (Inherited from WebControl.)
 | SupportsDisabledAttribute | (Inherited from WebControl.)
 | TabIndex | (Inherited from WebControl.)
 | TagKey | (Inherited from WebControl.)
 | TagName | (Inherited from WebControl.)
 | TemplateControl | (Inherited from Control.)
 | TemplateSourceDirectory | (Inherited from Control.)
 | ToolTip | (Inherited from WebControl.)
 | ToString()()()() | (Inherited from Object.)
 | TrackViewState()()()() | (Inherited from WebControl.)
 | UniqueID | (Inherited from Control.)
 | Unload | (Inherited from Control.)
 | ValidateRequestMode | (Inherited from Control.)
 | ViewState | (Inherited from Control.)
 | ViewStateIgnoresCase | (Inherited from Control.)
 | ViewStateMode | (Inherited from Control.)
 | Visible | (Inherited from Control.)
 | Width | (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | Footer

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Footer Constructor

Footer Constructor
API Documentation ► Keyoti.SearchEngine.Web ► Footer ► Footer()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Footer()()()() | Creates a new instance with no member values.
 | Footer(String, Int32, Int32, Int32, String, String, Page, Control, String) | Creates a new instance and sets all properties.

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Footer Constructor

Footer Constructor
API Documentation ► Keyoti.SearchEngine.Web ► Footer ► Footer()()()()
Keyoti SearchUnit v6
Creates a new instance with no member values.
Declaration Syntax
C# Visual Basic
public Footer()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Footer Constructor (QueryExpression, NumberOfResults, ResultsPage, NumberOfResultsPerPage, previousPageLinkText, nextPageLinkText, page, parent, ignoredWords)

Footer Constructor (QueryExpression, NumberOfResults, ResultsPage, NumberOfResultsPerPage, previousPageLinkText, nextPageLinkText, page, parent, ignoredWords)
API Documentation ► Keyoti.SearchEngine.Web ► Footer ► Footer(String, Int32, Int32, Int32, String, String, Page, Control, String)
Keyoti SearchUnit v6
Creates a new instance and sets all properties.
Declaration Syntax
C# Visual Basic
public Footer(
    string QueryExpression,
    int NumberOfResults,
    int ResultsPage,
    int NumberOfResultsPerPage,
    string previousPageLinkText,
    string nextPageLinkText,
    Page page,
    Control parent,
    string ignoredWords
)
Public Sub New (
    QueryExpression As String,
    NumberOfResults As Integer,
    ResultsPage As Integer,
    NumberOfResultsPerPage As Integer,
    previousPageLinkText As String,
    nextPageLinkText As String,
    page As Page,
    parent As Control,
    ignoredWords As String
)
Parameters
QueryExpression (String)
NumberOfResults (Int32)
ResultsPage (Int32)
NumberOfResultsPerPage (Int32)
previousPageLinkText (String)
nextPageLinkText (String)
page (Page)
parent (Control)
ignoredWords (String)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


IgnoredWords Property

IgnoredWords Property
API Documentation ► Keyoti.SearchEngine.Web ► Footer ► IgnoredWords
Keyoti SearchUnit v6
Comma delimited list of words which were not searched for (stop-list).
Declaration Syntax
C# Visual Basic
public string IgnoredWords { get; }
Public ReadOnly Property IgnoredWords As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


IgnoredWordsMessage Property

IgnoredWordsMessage Property
API Documentation ► Keyoti.SearchEngine.Web ► Footer ► IgnoredWordsMessage
Keyoti SearchUnit v6
User friendly, English message, reporting ignored words (stop-list).
Declaration Syntax
C# Visual Basic
public string IgnoredWordsMessage { get; }
Public ReadOnly Property IgnoredWordsMessage As String
    Get
Property Value
String
Remarks
For other languages, please construct a user friendly message in the template using the IgnoredWords property.

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


NextPageLink Property

NextPageLink Property
API Documentation ► Keyoti.SearchEngine.Web ► Footer ► NextPageLink
Keyoti SearchUnit v6
Link to the next page of results.
Declaration Syntax
C# Visual Basic
public string NextPageLink { get; }
Public ReadOnly Property NextPageLink As String
    Get
Property Value
String
Remarks
Note this is an empty string if the current page is the last page.

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


NumberOfResults Property

NumberOfResults Property
API Documentation ► Keyoti.SearchEngine.Web ► Footer ► NumberOfResults
Keyoti SearchUnit v6
The number of results found.
Declaration Syntax
C# Visual Basic
public int NumberOfResults { get; }
Public ReadOnly Property NumberOfResults As Integer
    Get
Property Value
Int32

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


NumberOfResultsPerPage Property

NumberOfResultsPerPage Property
API Documentation ► Keyoti.SearchEngine.Web ► Footer ► NumberOfResultsPerPage
Keyoti SearchUnit v6
The number of results being shown per page.
Declaration Syntax
C# Visual Basic
public int NumberOfResultsPerPage { get; }
Public ReadOnly Property NumberOfResultsPerPage As Integer
    Get
Property Value
Int32

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


PageLinksBlock Property

PageLinksBlock Property
API Documentation ► Keyoti.SearchEngine.Web ► Footer ► PageLinksBlock
Keyoti SearchUnit v6
Block of links to nearby pages.
Declaration Syntax
C# Visual Basic
public string PageLinksBlock { get; }
Public ReadOnly Property PageLinksBlock As String
    Get
Property Value
String
Remarks
Note this is an empty string if there is only one page.

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


PreviousPageLink Property

PreviousPageLink Property
API Documentation ► Keyoti.SearchEngine.Web ► Footer ► PreviousPageLink
Keyoti SearchUnit v6
Link to the previous page of results.
Declaration Syntax
C# Visual Basic
public string PreviousPageLink { get; }
Public ReadOnly Property PreviousPageLink As String
    Get
Property Value
String
Remarks
Note this is an empty string if the current page is #1.

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


QueryExpression Property

QueryExpression Property
API Documentation ► Keyoti.SearchEngine.Web ► Footer ► QueryExpression
Keyoti SearchUnit v6
The search query entered by the user.
Declaration Syntax
C# Visual Basic
public string QueryExpression { get; set; }
Public Property QueryExpression As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


RenderBeginTag Method (writer)

RenderBeginTag Method (writer)
API Documentation ► Keyoti.SearchEngine.Web ► Footer ► RenderBeginTag(HtmlTextWriter)
Keyoti SearchUnit v6
See base
Declaration Syntax
C# Visual Basic
public override void RenderBeginTag(
    HtmlTextWriter writer
)
Public Overrides Sub RenderBeginTag (
    writer As HtmlTextWriter
)
Parameters
writer (HtmlTextWriter)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


RenderEndTag Method (writer)

RenderEndTag Method (writer)
API Documentation ► Keyoti.SearchEngine.Web ► Footer ► RenderEndTag(HtmlTextWriter)
Keyoti SearchUnit v6
See base
Declaration Syntax
C# Visual Basic
public override void RenderEndTag(
    HtmlTextWriter writer
)
Public Overrides Sub RenderEndTag (
    writer As HtmlTextWriter
)
Parameters
writer (HtmlTextWriter)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ResultsPage Property

ResultsPage Property
API Documentation ► Keyoti.SearchEngine.Web ► Footer ► ResultsPage
Keyoti SearchUnit v6
The current results page number.
Declaration Syntax
C# Visual Basic
public int ResultsPage { get; }
Public ReadOnly Property ResultsPage As Integer
    Get
Property Value
Int32

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Header Class

Header Class
API Documentation ► Keyoti.SearchEngine.Web ► Header
Keyoti SearchUnit v6
The header shown before the search results.
Declaration Syntax
C# Visual Basic
public class Header : WebControl, INamingContainer
Public Class Header
    Inherits WebControl
    Implements INamingContainer
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Header()()()() | Creates an instance with no members set
 | Header(String, Int32, Int32, Int32, String, String, Page, Control, String) | Creates a new instance and sets all properties.
 | AccessKey | (Inherited from WebControl.)
 | Adapter | (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | (Inherited from Control.)
 | AddParsedSubObject(Object) | (Inherited from Control.)
 | ApplyStyle(Style) | (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | (Inherited from Control.)
 | Attributes | (Inherited from WebControl.)
 | BackColor | (Inherited from WebControl.)
 | BeginRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | BindingContainer | (Inherited from Control.)
 | BorderColor | (Inherited from WebControl.)
 | BorderStyle | (Inherited from WebControl.)
 | BorderWidth | (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | (Inherited from Control.)
 | ChildControlsCreated | (Inherited from Control.)
 | ClearCachedClientID()()()() | (Inherited from Control.)
 | ClearChildControlState()()()() | (Inherited from Control.)
 | ClearChildState()()()() | (Inherited from Control.)
 | ClearChildViewState()()()() | (Inherited from Control.)
 | ClearEffectiveClientIDMode()()()() | (Inherited from Control.)
 | ClientID | (Inherited from Control.)
 | ClientIDMode | (Inherited from Control.)
 | ClientIDSeparator | (Inherited from Control.)
 | Context | (Inherited from Control.)
 | Controls | (Inherited from Control.)
 | ControlStyle | (Inherited from WebControl.)
 | ControlStyleCreated | (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | (Inherited from WebControl.)
 | CreateChildControls()()()() | (Inherited from Control.)
 | CreateControlCollection()()()() | (Inherited from Control.)
 | CreateControlStyle()()()() | (Inherited from WebControl.)
 | CssClass | (Inherited from WebControl.)
 | DataBind()()()() | (Inherited from Control.)
 | DataBind(Boolean) | (Inherited from Control.)
 | DataBindChildren()()()() | (Inherited from Control.)
 | DataBinding | (Inherited from Control.)
 | DataItemContainer | (Inherited from Control.)
 | DataKeysContainer | (Inherited from Control.)
 | DesignMode | (Inherited from Control.)
 | Dispose()()()() | (Inherited from Control.)
 | Disposed | (Inherited from Control.)
 | Enabled | (Inherited from WebControl.)
 | EnableTheming | (Inherited from WebControl.)
 | EnableViewState | (Inherited from Control.)
 | EndRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | EnsureChildControls()()()() | (Inherited from Control.)
 | EnsureID()()()() | (Inherited from Control.)
 | Equals(Object) | (Inherited from Object.)
 | Events | (Inherited from Control.)
 | Finalize()()()() | (Inherited from Object.)
 | FindControl(String) | (Inherited from Control.)
 | FindControl(String, Int32) | (Inherited from Control.)
 | Focus()()()() | (Inherited from Control.)
 | Font | (Inherited from WebControl.)
 | ForeColor | (Inherited from WebControl.)
 | GetDesignModeState()()()() | (Inherited from Control.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetRouteUrl(Object) | (Inherited from Control.)
 | GetRouteUrl(String, Object) | (Inherited from Control.)
 | GetRouteUrl(RouteValueDictionary) | (Inherited from Control.)
 | GetRouteUrl(String, RouteValueDictionary) | (Inherited from Control.)
 | GetType()()()() | (Inherited from Object.)
 | GetUniqueIDRelativeTo(Control) | (Inherited from Control.)
 | HasAttributes | (Inherited from WebControl.)
 | HasChildViewState | (Inherited from Control.)
 | HasControls()()()() | (Inherited from Control.)
 | HasEvents()()()() | (Inherited from Control.)
 | Height | (Inherited from WebControl.)
 | ID | (Inherited from Control.)
 | IdSeparator | (Inherited from Control.)
 | IgnoredWords | Comma delimited list of words which were not searched for (stop-list).
 | IgnoredWordsMessage | User friendly, English message, reporting ignored words (stop-list).
 | Init | (Inherited from Control.)
 | IsChildControlStateCleared | (Inherited from Control.)
 | IsEnabled | (Inherited from WebControl.)
 | IsLiteralContent()()()() | (Inherited from Control.)
 | IsTrackingViewState | (Inherited from Control.)
 | IsViewStateEnabled | (Inherited from Control.)
 | Load | (Inherited from Control.)
 | LoadControlState(Object) | (Inherited from Control.)
 | LoadViewState(Object) | (Inherited from WebControl.)
 | LoadViewStateByID | (Inherited from Control.)
 | MapPathSecure(String) | (Inherited from Control.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle(Style) | (Inherited from WebControl.)
 | NamingContainer | (Inherited from Control.)
 | NextPageLink | Link to the next page of results.
 | NumberOfResults | The number of results found
 | NumberOfResultsPerPage | The number of results being shown per page.
 | OnBubbleEvent(Object, EventArgs) | (Inherited from Control.)
 | OnDataBinding(EventArgs) | (Inherited from Control.)
 | OnInit(EventArgs) | (Inherited from Control.)
 | OnLoad(EventArgs) | (Inherited from Control.)
 | OnPreRender(EventArgs) | (Inherited from Control.)
 | OnUnload(EventArgs) | (Inherited from Control.)
 | OpenFile(String) | (Inherited from Control.)
 | Page | (Inherited from Control.)
 | PageLinksBlock | Block of links to nearby pages.
 | Parent | (Inherited from Control.)
 | PreRender | (Inherited from Control.)
 | PreviousPageLink | Link to the previous page of results.
 | QueryExpression | The user's search query
 | RaiseBubbleEvent(Object, EventArgs) | (Inherited from Control.)
 | RemovedControl(Control) | (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | See base (Overrides WebControl.RenderBeginTag(HtmlTextWriter).)
 | RenderChildren(HtmlTextWriter) | (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | See base (Overrides WebControl.RenderEndTag(HtmlTextWriter).)
 | RenderingCompatibility | (Inherited from Control.)
 | ResolveAdapter()()()() | (Inherited from Control.)
 | ResolveClientUrl(String) | (Inherited from Control.)
 | ResolveUrl(String) | (Inherited from Control.)
 | ResultsOnPage | The number of results shown on the page
 | ResultsPage | The current results page number.
 | SaveControlState()()()() | (Inherited from Control.)
 | SaveViewState()()()() | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | (Inherited from Control.)
 | SetTraceData(Object, Object) | (Inherited from Control.)
 | SetTraceData(Object, Object, Object) | (Inherited from Control.)
 | Site | (Inherited from Control.)
 | SkinID | (Inherited from WebControl.)
 | Style | (Inherited from WebControl.)
 | SupportsDisabledAttribute | (Inherited from WebControl.)
 | TabIndex | (Inherited from WebControl.)
 | TagKey | (Inherited from WebControl.)
 | TagName | (Inherited from WebControl.)
 | TemplateControl | (Inherited from Control.)
 | TemplateSourceDirectory | (Inherited from Control.)
 | ToolTip | (Inherited from WebControl.)
 | ToString()()()() | (Inherited from Object.)
 | TrackViewState()()()() | (Inherited from WebControl.)
 | UniqueID | (Inherited from Control.)
 | Unload | (Inherited from Control.)
 | ValidateRequestMode | (Inherited from Control.)
 | ViewState | (Inherited from Control.)
 | ViewStateIgnoresCase | (Inherited from Control.)
 | ViewStateMode | (Inherited from Control.)
 | Visible | (Inherited from Control.)
 | Width | (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | Header

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Header Constructor

Header Constructor
API Documentation ► Keyoti.SearchEngine.Web ► Header ► Header()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Header()()()() | Creates an instance with no members set
 | Header(String, Int32, Int32, Int32, String, String, Page, Control, String) | Creates a new instance and sets all properties.

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Header Constructor

Header Constructor
API Documentation ► Keyoti.SearchEngine.Web ► Header ► Header()()()()
Keyoti SearchUnit v6
Creates an instance with no members set
Declaration Syntax
C# Visual Basic
public Header()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Header Constructor (QueryExpression, NumberOfResults, resultsPage, NumberOfResultsPerPage, previousPageLinkText, nextPageLinkText, page, parent, ignoredWords)

Header Constructor (QueryExpression, NumberOfResults, resultsPage, NumberOfResultsPerPage, previousPageLinkText, nextPageLinkText, page, parent, ignoredWords)
API Documentation ► Keyoti.SearchEngine.Web ► Header ► Header(String, Int32, Int32, Int32, String, String, Page, Control, String)
Keyoti SearchUnit v6
Creates a new instance and sets all properties.
Declaration Syntax
C# Visual Basic
public Header(
    string QueryExpression,
    int NumberOfResults,
    int resultsPage,
    int NumberOfResultsPerPage,
    string previousPageLinkText,
    string nextPageLinkText,
    Page page,
    Control parent,
    string ignoredWords
)
Public Sub New (
    QueryExpression As String,
    NumberOfResults As Integer,
    resultsPage As Integer,
    NumberOfResultsPerPage As Integer,
    previousPageLinkText As String,
    nextPageLinkText As String,
    page As Page,
    parent As Control,
    ignoredWords As String
)
Parameters
QueryExpression (String)
NumberOfResults (Int32)
resultsPage (Int32)
NumberOfResultsPerPage (Int32)
previousPageLinkText (String)
nextPageLinkText (String)
page (Page)
parent (Control)
ignoredWords (String)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


IgnoredWords Property

IgnoredWords Property
API Documentation ► Keyoti.SearchEngine.Web ► Header ► IgnoredWords
Keyoti SearchUnit v6
Comma delimited list of words which were not searched for (stop-list).
Declaration Syntax
C# Visual Basic
public string IgnoredWords { get; }
Public ReadOnly Property IgnoredWords As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


IgnoredWordsMessage Property

IgnoredWordsMessage Property
API Documentation ► Keyoti.SearchEngine.Web ► Header ► IgnoredWordsMessage
Keyoti SearchUnit v6
User friendly, English message, reporting ignored words (stop-list).
Declaration Syntax
C# Visual Basic
public string IgnoredWordsMessage { get; }
Public ReadOnly Property IgnoredWordsMessage As String
    Get
Property Value
String
Remarks
For other languages, please construct a user friendly message in the template using the IgnoredWords property.

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


NextPageLink Property

NextPageLink Property
API Documentation ► Keyoti.SearchEngine.Web ► Header ► NextPageLink
Keyoti SearchUnit v6
Link to the next page of results.
Declaration Syntax
C# Visual Basic
public string NextPageLink { get; }
Public ReadOnly Property NextPageLink As String
    Get
Property Value
String
Remarks
Note this is an empty string if the current page is the last page.

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


NumberOfResults Property

NumberOfResults Property
API Documentation ► Keyoti.SearchEngine.Web ► Header ► NumberOfResults
Keyoti SearchUnit v6
The number of results found
Declaration Syntax
C# Visual Basic
public int NumberOfResults { get; }
Public ReadOnly Property NumberOfResults As Integer
    Get
Property Value
Int32

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


NumberOfResultsPerPage Property

NumberOfResultsPerPage Property
API Documentation ► Keyoti.SearchEngine.Web ► Header ► NumberOfResultsPerPage
Keyoti SearchUnit v6
The number of results being shown per page.
Declaration Syntax
C# Visual Basic
public int NumberOfResultsPerPage { get; }
Public ReadOnly Property NumberOfResultsPerPage As Integer
    Get
Property Value
Int32

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


PageLinksBlock Property

PageLinksBlock Property
API Documentation ► Keyoti.SearchEngine.Web ► Header ► PageLinksBlock
Keyoti SearchUnit v6
Block of links to nearby pages.
Declaration Syntax
C# Visual Basic
public string PageLinksBlock { get; }
Public ReadOnly Property PageLinksBlock As String
    Get
Property Value
String
Remarks
Note this is an empty string if there is only one page.

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


PreviousPageLink Property

PreviousPageLink Property
API Documentation ► Keyoti.SearchEngine.Web ► Header ► PreviousPageLink
Keyoti SearchUnit v6
Link to the previous page of results.
Declaration Syntax
C# Visual Basic
public string PreviousPageLink { get; }
Public ReadOnly Property PreviousPageLink As String
    Get
Property Value
String
Remarks
Note this is an empty string if the current page is #1.

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


QueryExpression Property

QueryExpression Property
API Documentation ► Keyoti.SearchEngine.Web ► Header ► QueryExpression
Keyoti SearchUnit v6
The user's search query
Declaration Syntax
C# Visual Basic
public string QueryExpression { get; }
Public ReadOnly Property QueryExpression As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


RenderBeginTag Method (writer)

RenderBeginTag Method (writer)
API Documentation ► Keyoti.SearchEngine.Web ► Header ► RenderBeginTag(HtmlTextWriter)
Keyoti SearchUnit v6
See base
Declaration Syntax
C# Visual Basic
public override void RenderBeginTag(
    HtmlTextWriter writer
)
Public Overrides Sub RenderBeginTag (
    writer As HtmlTextWriter
)
Parameters
writer (HtmlTextWriter)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


RenderEndTag Method (writer)

RenderEndTag Method (writer)
API Documentation ► Keyoti.SearchEngine.Web ► Header ► RenderEndTag(HtmlTextWriter)
Keyoti SearchUnit v6
See base
Declaration Syntax
C# Visual Basic
public override void RenderEndTag(
    HtmlTextWriter writer
)
Public Overrides Sub RenderEndTag (
    writer As HtmlTextWriter
)
Parameters
writer (HtmlTextWriter)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ResultsOnPage Property

ResultsOnPage Property
API Documentation ► Keyoti.SearchEngine.Web ► Header ► ResultsOnPage
Keyoti SearchUnit v6
The number of results shown on the page
Declaration Syntax
C# Visual Basic
public int ResultsOnPage { get; }
Public ReadOnly Property ResultsOnPage As Integer
    Get
Property Value
Int32

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ResultsPage Property

ResultsPage Property
API Documentation ► Keyoti.SearchEngine.Web ► Header ► ResultsPage
Keyoti SearchUnit v6
The current results page number.
Declaration Syntax
C# Visual Basic
public int ResultsPage { get; }
Public ReadOnly Property ResultsPage As Integer
    Get
Property Value
Int32

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ICache Interface

ICache Interface
API Documentation ► Keyoti.SearchEngine.Web ► ICache
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public interface ICache
Public Interface ICache
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddItem(String, Object, String, DateTime, TimeSpan, CacheItemPriority, CacheItemRemovedCallback) |
 | AddItem(String, Object, String, TimeSpan) |
 | AddItem(String, Object) |
 | GetItem(String) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


AddItem Method

AddItem Method
API Documentation ► Keyoti.SearchEngine.Web ► ICache ► AddItem()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | AddItem(String, Object, String, DateTime, TimeSpan, CacheItemPriority, CacheItemRemovedCallback) |
 | AddItem(String, Object, String, TimeSpan) |
 | AddItem(String, Object) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


AddItem Method (key, item)

AddItem Method (key, item)
API Documentation ► Keyoti.SearchEngine.Web ► ICache ► AddItem(String, Object)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
void AddItem(
    string key,
    Object item
)
Sub AddItem (
    key As String,
    item As Object
)
Parameters
key (String)
item (Object)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


AddItem Method (key, item, dependencyFile, absoluteExpiry, expiration, priority, callBack)

AddItem Method (key, item, dependencyFile, absoluteExpiry, expiration, priority, callBack)
API Documentation ► Keyoti.SearchEngine.Web ► ICache ► AddItem(String, Object, String, DateTime, TimeSpan, CacheItemPriority, CacheItemRemovedCallback)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
void AddItem(
    string key,
    Object item,
    string dependencyFile,
    DateTime absoluteExpiry,
    TimeSpan expiration,
    CacheItemPriority priority,
    CacheItemRemovedCallback callBack
)
Sub AddItem (
    key As String,
    item As Object,
    dependencyFile As String,
    absoluteExpiry As DateTime,
    expiration As TimeSpan,
    priority As CacheItemPriority,
    callBack As CacheItemRemovedCallback
)
Parameters
key (String)
item (Object)
dependencyFile (String)
absoluteExpiry (DateTime)
expiration (TimeSpan)
priority (CacheItemPriority)
callBack (CacheItemRemovedCallback)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


AddItem Method (key, item, dependencyFile, expiration)

AddItem Method (key, item, dependencyFile, expiration)
API Documentation ► Keyoti.SearchEngine.Web ► ICache ► AddItem(String, Object, String, TimeSpan)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
void AddItem(
    string key,
    Object item,
    string dependencyFile,
    TimeSpan expiration
)
Sub AddItem (
    key As String,
    item As Object,
    dependencyFile As String,
    expiration As TimeSpan
)
Parameters
key (String)
item (Object)
dependencyFile (String)
expiration (TimeSpan)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


GetItem Method (key)

GetItem Method (key)
API Documentation ► Keyoti.SearchEngine.Web ► ICache ► GetItem(String)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
Object GetItem(
    string key
)
Function GetItem (
    key As String
) As Object
Parameters
key (String)
Return Value
Object

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


KButton Class

KButton Class
API Documentation ► Keyoti.SearchEngine.Web ► KButton
Keyoti SearchUnit v6
RapidSpell button
Declaration Syntax
C# Visual Basic
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public class KButton : Control
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Class KButton
    Inherits Control
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | KButton(String) | Initializes a new instance of the RSButton class using the specified button type
 | KButton()()()() | Initializes a new instance of the RSButton class using the specified button type
 | Adapter | (Inherited from Control.)
 | AddedControl(Control, Int32) | (Inherited from Control.)
 | AddParsedSubObject(Object) | (Inherited from Control.)
 | ApplyStyleSheetSkin(Page) | (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | (Inherited from Control.)
 | Attributes | The runtime attributes.
 | BackColor | Gets or sets the background color of the Web server control.
 | BeginRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | BindingContainer | (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web server control.
 | BorderStyle | Gets or sets the border style of the Web server control.
 | BorderWidth | Gets or sets the border width of the Web server control.
 | BuildProfileTree(String, Boolean) | (Inherited from Control.)
 | ChildControlsCreated | (Inherited from Control.)
 | ClearCachedClientID()()()() | (Inherited from Control.)
 | ClearChildControlState()()()() | (Inherited from Control.)
 | ClearChildState()()()() | (Inherited from Control.)
 | ClearChildViewState()()()() | (Inherited from Control.)
 | ClearEffectiveClientIDMode()()()() | (Inherited from Control.)
 | ClientID | (Inherited from Control.)
 | ClientIDMode | (Inherited from Control.)
 | ClientIDSeparator | (Inherited from Control.)
 | Context | (Inherited from Control.)
 | Controls | (Inherited from Control.)
 | CreateChildControls()()()() | (Inherited from Control.)
 | CreateControlCollection()()()() | (Inherited from Control.)
 | CssClass | The CssClass of this control.
 | DataBind()()()() | (Inherited from Control.)
 | DataBind(Boolean) | (Inherited from Control.)
 | DataBindChildren()()()() | (Inherited from Control.)
 | DataBinding | (Inherited from Control.)
 | DataItemContainer | (Inherited from Control.)
 | DataKeysContainer | (Inherited from Control.)
 | DesignMode | (Inherited from Control.)
 | Dispose()()()() | (Inherited from Control.)
 | Disposed | (Inherited from Control.)
 | EnableTheming | (Inherited from Control.)
 | EnableViewState | (Inherited from Control.)
 | EndRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | EnsureChildControls()()()() | (Inherited from Control.)
 | EnsureID()()()() | (Inherited from Control.)
 | Equals(Object) | (Inherited from Object.)
 | Events | (Inherited from Control.)
 | Finalize()()()() | (Inherited from Object.)
 | FindControl(String) | (Inherited from Control.)
 | FindControl(String, Int32) | (Inherited from Control.)
 | Focus()()()() | (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control.
 | ForeColor | Gets or sets the foreground color of the Web server control.
 | GetDesignModeState()()()() | (Inherited from Control.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetRouteUrl(Object) | (Inherited from Control.)
 | GetRouteUrl(String, Object) | (Inherited from Control.)
 | GetRouteUrl(RouteValueDictionary) | (Inherited from Control.)
 | GetRouteUrl(String, RouteValueDictionary) | (Inherited from Control.)
 | GetType()()()() | (Inherited from Object.)
 | GetUniqueIDRelativeTo(Control) | (Inherited from Control.)
 | HasChildViewState | (Inherited from Control.)
 | HasControls()()()() | (Inherited from Control.)
 | HasEvents()()()() | (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control.
 | ID | The ID of the control (Overrides Control.ID.)
 | IdSeparator | (Inherited from Control.)
 | ImageAltText | The button image alt attribute text
 | ImageMouseDown | The button image URL. This is for mouse down and is optional.
 | ImageMouseOut | The button image URL. This is for mouse out (ie. not mouse over) and is optional.
 | ImageMouseOver | The button image URL. This is for mouse over and is optional.
 | ImageTitleText | The button image title attribute text
 | Init | (Inherited from Control.)
 | IsChildControlStateCleared | (Inherited from Control.)
 | IsLiteralContent()()()() | (Inherited from Control.)
 | IsTrackingViewState | (Inherited from Control.)
 | IsViewStateEnabled | (Inherited from Control.)
 | Load | (Inherited from Control.)
 | LoadControlState(Object) | (Inherited from Control.)
 | LoadViewState(Object) | (Inherited from Control.)
 | LoadViewStateByID | (Inherited from Control.)
 | MapPathSecure(String) | (Inherited from Control.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name | The button text.
 | NamingContainer | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | (Inherited from Control.)
 | onclick | The button client-side onclick handler.
 | OnDataBinding(EventArgs) | (Inherited from Control.)
 | OnInit(EventArgs) | (Inherited from Control.)
 | OnLoad(EventArgs) | (Inherited from Control.)
 | OnPreRender(EventArgs) | (Inherited from Control.)
 | OnUnload(EventArgs) | (Inherited from Control.)
 | OpenFile(String) | (Inherited from Control.)
 | Page | (Inherited from Control.)
 | Parent | (Inherited from Control.)
 | PreRender | (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | (Inherited from Control.)
 | RemovedControl(Control) | (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control. (Overrides Control.Render(HtmlTextWriter).)
 | RenderAttributes(HtmlTextWriter) | Internal use.
 | RenderChildren(HtmlTextWriter) | (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | (Inherited from Control.)
 | RenderingCompatibility | (Inherited from Control.)
 | ResolveAdapter()()()() | (Inherited from Control.)
 | ResolveClientUrl(String) | (Inherited from Control.)
 | ResolveUrl(String) | (Inherited from Control.)
 | runat | Internal use.
 | SaveControlState()()()() | (Inherited from Control.)
 | SaveViewState()()()() | (Inherited from Control.)
 | SetDesignModeState(IDictionary) | (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | (Inherited from Control.)
 | SetTraceData(Object, Object) | (Inherited from Control.)
 | SetTraceData(Object, Object, Object) | (Inherited from Control.)
 | Site | (Inherited from Control.)
 | SkinID | (Inherited from Control.)
 | style | The button client-side style handler.
 | TabIndex | The button tab index.
 | TemplateControl | (Inherited from Control.)
 | TemplateSourceDirectory | (Inherited from Control.)
 | ToString()()()() | (Inherited from Object.)
 | TrackViewState()()()() | (Inherited from Control.)
 | type | The button text.
 | UniqueID | (Inherited from Control.)
 | Unload | (Inherited from Control.)
 | ValidateRequestMode | (Inherited from Control.)
 | Value | The button text.
 | ViewState | (Inherited from Control.)
 | ViewStateIgnoresCase | (Inherited from Control.)
 | ViewStateMode | (Inherited from Control.)
 | Visible | Whether to render this control (Overrides Control.Visible.)
 | Width | Gets or sets the width of the Web server control.
Inheritance Hierarchy
Object
 | Control
 |  | KButton

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


KButton Constructor

KButton Constructor
API Documentation ► Keyoti.SearchEngine.Web ► KButton ► KButton()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | KButton(String) | Initializes a new instance of the RSButton class using the specified button type
 | KButton()()()() | Initializes a new instance of the RSButton class using the specified button type

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


KButton Constructor

KButton Constructor
API Documentation ► Keyoti.SearchEngine.Web ► KButton ► KButton()()()()
Keyoti SearchUnit v6
Initializes a new instance of the RSButton class using the specified button type
Declaration Syntax
C# Visual Basic
public KButton()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


KButton Constructor (type)

KButton Constructor (type)
API Documentation ► Keyoti.SearchEngine.Web ► KButton ► KButton(String)
Keyoti SearchUnit v6
Initializes a new instance of the RSButton class using the specified button type
Declaration Syntax
C# Visual Basic
public KButton(
    string type
)
Public Sub New (
    type As String
)
Parameters
type (String)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Attributes Property

Attributes Property
API Documentation ► Keyoti.SearchEngine.Web ► KButton ► Attributes
Keyoti SearchUnit v6
The runtime attributes.
Declaration Syntax
C# Visual Basic
public AttributeCollection Attributes { get; }
Public ReadOnly Property Attributes As AttributeCollection
    Get
Property Value
AttributeCollection

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


BackColor Property

BackColor Property
API Documentation ► Keyoti.SearchEngine.Web ► KButton ► BackColor
Keyoti SearchUnit v6
Gets or sets the background color of the Web server control.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public Color BackColor { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property BackColor As Color
    Get
    Set
Property Value
Color

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


BorderColor Property

BorderColor Property
API Documentation ► Keyoti.SearchEngine.Web ► KButton ► BorderColor
Keyoti SearchUnit v6
Gets or sets the border color of the Web server control.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public Color BorderColor { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property BorderColor As Color
    Get
    Set
Property Value
Color

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


BorderStyle Property

BorderStyle Property
API Documentation ► Keyoti.SearchEngine.Web ► KButton ► BorderStyle
Keyoti SearchUnit v6
Gets or sets the border style of the Web server control.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public BorderStyle BorderStyle { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property BorderStyle As BorderStyle
    Get
    Set
Property Value
BorderStyle

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


BorderWidth Property

BorderWidth Property
API Documentation ► Keyoti.SearchEngine.Web ► KButton ► BorderWidth
Keyoti SearchUnit v6
Gets or sets the border width of the Web server control.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public Unit BorderWidth { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property BorderWidth As Unit
    Get
    Set
Property Value
Unit

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


CssClass Property

CssClass Property
API Documentation ► Keyoti.SearchEngine.Web ► KButton ► CssClass
Keyoti SearchUnit v6
The CssClass of this control.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string CssClass { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property CssClass As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Font Property

Font Property
API Documentation ► Keyoti.SearchEngine.Web ► KButton ► Font
Keyoti SearchUnit v6
Gets the font properties associated with the Web server control.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public FontInfo Font { get; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public ReadOnly Property Font As FontInfo
    Get
Property Value
FontInfo

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ForeColor Property

ForeColor Property
API Documentation ► Keyoti.SearchEngine.Web ► KButton ► ForeColor
Keyoti SearchUnit v6
Gets or sets the foreground color of the Web server control.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public Color ForeColor { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ForeColor As Color
    Get
    Set
Property Value
Color

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Height Property

Height Property
API Documentation ► Keyoti.SearchEngine.Web ► KButton ► Height
Keyoti SearchUnit v6
Gets or sets the height of the Web server control.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public Unit Height { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property Height As Unit
    Get
    Set
Property Value
Unit

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ID Property

ID Property
API Documentation ► Keyoti.SearchEngine.Web ► KButton ► ID
Keyoti SearchUnit v6
The ID of the control
Declaration Syntax
C# Visual Basic
public override string ID { get; set; }
Public Overrides Property ID As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ImageAltText Property

ImageAltText Property
API Documentation ► Keyoti.SearchEngine.Web ► KButton ► ImageAltText
Keyoti SearchUnit v6
The button image alt attribute text
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string ImageAltText { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ImageAltText As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ImageMouseDown Property

ImageMouseDown Property
API Documentation ► Keyoti.SearchEngine.Web ► KButton ► ImageMouseDown
Keyoti SearchUnit v6
The button image URL. This is for mouse down and is optional.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string ImageMouseDown { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ImageMouseDown As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ImageMouseOut Property

ImageMouseOut Property
API Documentation ► Keyoti.SearchEngine.Web ► KButton ► ImageMouseOut
Keyoti SearchUnit v6
The button image URL. This is for mouse out (ie. not mouse over) and is optional.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string ImageMouseOut { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ImageMouseOut As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ImageMouseOver Property

ImageMouseOver Property
API Documentation ► Keyoti.SearchEngine.Web ► KButton ► ImageMouseOver
Keyoti SearchUnit v6
The button image URL. This is for mouse over and is optional.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string ImageMouseOver { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ImageMouseOver As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ImageTitleText Property

ImageTitleText Property
API Documentation ► Keyoti.SearchEngine.Web ► KButton ► ImageTitleText
Keyoti SearchUnit v6
The button image title attribute text
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string ImageTitleText { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ImageTitleText As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Name Property

Name Property
API Documentation ► Keyoti.SearchEngine.Web ► KButton ► Name
Keyoti SearchUnit v6
The button text.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string Name { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property Name As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


onclick Property

onclick Property
API Documentation ► Keyoti.SearchEngine.Web ► KButton ► onclick
Keyoti SearchUnit v6
The button client-side onclick handler.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string onclick { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property onclick As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Render Method (output)

Render Method (output)
API Documentation ► Keyoti.SearchEngine.Web ► KButton ► Render(HtmlTextWriter)
Keyoti SearchUnit v6
Renders the control.
Declaration Syntax
C# Visual Basic
protected override void Render(
    HtmlTextWriter output
)
Protected Overrides Sub Render (
    output As HtmlTextWriter
)
Parameters
output (HtmlTextWriter)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


RenderAttributes Method (writer)

RenderAttributes Method (writer)
API Documentation ► Keyoti.SearchEngine.Web ► KButton ► RenderAttributes(HtmlTextWriter)
Keyoti SearchUnit v6
Internal use.
Declaration Syntax
C# Visual Basic
protected virtual void RenderAttributes(
    HtmlTextWriter writer
)
Protected Overridable Sub RenderAttributes (
    writer As HtmlTextWriter
)
Parameters
writer (HtmlTextWriter)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


runat Property

runat Property
API Documentation ► Keyoti.SearchEngine.Web ► KButton ► runat
Keyoti SearchUnit v6
Internal use.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string runat { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property runat As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


style Property

style Property
API Documentation ► Keyoti.SearchEngine.Web ► KButton ► style
Keyoti SearchUnit v6
The button client-side style handler.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string style { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property style As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


TabIndex Property

TabIndex Property
API Documentation ► Keyoti.SearchEngine.Web ► KButton ► TabIndex
Keyoti SearchUnit v6
The button tab index.
Declaration Syntax
C# Visual Basic
public short TabIndex { get; set; }
Public Property TabIndex As Short
    Get
    Set
Property Value
Int16

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


type Property

type Property
API Documentation ► Keyoti.SearchEngine.Web ► KButton ► type
Keyoti SearchUnit v6
The button text.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string type { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property type As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Value Property

Value Property
API Documentation ► Keyoti.SearchEngine.Web ► KButton ► Value
Keyoti SearchUnit v6
The button text.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string Value { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property Value As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Visible Property

Visible Property
API Documentation ► Keyoti.SearchEngine.Web ► KButton ► Visible
Keyoti SearchUnit v6
Whether to render this control
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public override bool Visible { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overrides Property Visible As Boolean
    Get
    Set
Property Value
Boolean

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Width Property

Width Property
API Documentation ► Keyoti.SearchEngine.Web ► KButton ► Width
Keyoti SearchUnit v6
Gets or sets the width of the Web server control.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public Unit Width { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property Width As Unit
    Get
    Set
Property Value
Unit

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


KCheckBox Class

KCheckBox Class
API Documentation ► Keyoti.SearchEngine.Web ► KCheckBox
Keyoti SearchUnit v6
Keyoti CheckBox control
Declaration Syntax
C# Visual Basic
public class KCheckBox : CheckBox
Public Class KCheckBox
    Inherits CheckBox
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | KCheckBox()()()() |
 | AccessKey | (Inherited from WebControl.)
 | Adapter | (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | (Inherited from CheckBox.)
 | AddedControl(Control, Int32) | (Inherited from Control.)
 | AddParsedSubObject(Object) | (Inherited from Control.)
 | ApplyStyle(Style) | (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | (Inherited from Control.)
 | Attributes | (Inherited from WebControl.)
 | AutoPostBack | (Inherited from CheckBox.)
 | BackColor | (Inherited from WebControl.)
 | BeginRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | BindingContainer | (Inherited from Control.)
 | BorderColor | (Inherited from WebControl.)
 | BorderStyle | (Inherited from WebControl.)
 | BorderWidth | (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | (Inherited from Control.)
 | CausesValidation | (Inherited from CheckBox.)
 | Checked | (Inherited from CheckBox.)
 | CheckedChanged | (Inherited from CheckBox.)
 | ChildControlsCreated | (Inherited from Control.)
 | ClearCachedClientID()()()() | (Inherited from Control.)
 | ClearChildControlState()()()() | (Inherited from Control.)
 | ClearChildState()()()() | (Inherited from Control.)
 | ClearChildViewState()()()() | (Inherited from Control.)
 | ClearEffectiveClientIDMode()()()() | (Inherited from Control.)
 | ClientID | (Inherited from Control.)
 | ClientIDMode | (Inherited from Control.)
 | ClientIDSeparator | (Inherited from Control.)
 | Context | (Inherited from Control.)
 | Controls | (Inherited from Control.)
 | ControlStyle | (Inherited from WebControl.)
 | ControlStyleCreated | (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | (Inherited from WebControl.)
 | CreateChildControls()()()() | (Inherited from Control.)
 | CreateControlCollection()()()() | (Inherited from Control.)
 | CreateControlStyle()()()() | (Inherited from WebControl.)
 | CssClass | (Inherited from WebControl.)
 | DataBind()()()() | (Inherited from Control.)
 | DataBind(Boolean) | (Inherited from Control.)
 | DataBindChildren()()()() | (Inherited from Control.)
 | DataBinding | (Inherited from Control.)
 | DataItemContainer | (Inherited from Control.)
 | DataKeysContainer | (Inherited from Control.)
 | DesignMode | (Inherited from Control.)
 | Dispose()()()() | (Inherited from Control.)
 | Disposed | (Inherited from Control.)
 | Enabled | (Inherited from WebControl.)
 | EnableTheming | (Inherited from WebControl.)
 | EnableViewState | (Inherited from Control.)
 | EndRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | EnsureChildControls()()()() | (Inherited from Control.)
 | EnsureID()()()() | (Inherited from Control.)
 | Equals(Object) | (Inherited from Object.)
 | Events | (Inherited from Control.)
 | Finalize()()()() | (Inherited from Object.)
 | FindControl(String) | (Inherited from Control.)
 | FindControl(String, Int32) | (Inherited from Control.)
 | Focus()()()() | (Inherited from Control.)
 | Font | (Overrides WebControl.Font.)
 | ForeColor | (Inherited from WebControl.)
 | GetDesignModeState()()()() | (Inherited from Control.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetRouteUrl(Object) | (Inherited from Control.)
 | GetRouteUrl(String, Object) | (Inherited from Control.)
 | GetRouteUrl(RouteValueDictionary) | (Inherited from Control.)
 | GetRouteUrl(String, RouteValueDictionary) | (Inherited from Control.)
 | GetType()()()() | (Inherited from Object.)
 | GetUniqueIDRelativeTo(Control) | (Inherited from Control.)
 | HasAttributes | (Inherited from WebControl.)
 | HasChildViewState | (Inherited from Control.)
 | HasControls()()()() | (Inherited from Control.)
 | HasEvents()()()() | (Inherited from Control.)
 | Height | (Inherited from WebControl.)
 | ID | (Inherited from Control.)
 | IdSeparator | (Inherited from Control.)
 | Init | (Inherited from Control.)
 | InputAttributes | (Inherited from CheckBox.)
 | IsChildControlStateCleared | (Inherited from Control.)
 | IsEnabled | (Inherited from WebControl.)
 | IsLiteralContent()()()() | (Inherited from Control.)
 | IsTrackingViewState | (Inherited from Control.)
 | IsViewStateEnabled | (Inherited from Control.)
 | LabelAttributes | (Inherited from CheckBox.)
 | Load | (Inherited from Control.)
 | LoadControlState(Object) | (Inherited from Control.)
 | LoadPostData(String, NameValueCollection) | (Inherited from CheckBox.)
 | LoadViewState(Object) | (Inherited from CheckBox.)
 | LoadViewStateByID | (Inherited from Control.)
 | MapPathSecure(String) | (Inherited from Control.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle(Style) | (Inherited from WebControl.)
 | NamingContainer | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | (Inherited from Control.)
 | OnCheckedChanged(EventArgs) | (Inherited from CheckBox.)
 | OnDataBinding(EventArgs) | (Inherited from Control.)
 | OnInit(EventArgs) | (Inherited from Control.)
 | OnLoad(EventArgs) | (Inherited from Control.)
 | OnPreRender(EventArgs) | (Inherited from CheckBox.)
 | OnUnload(EventArgs) | (Inherited from Control.)
 | OpenFile(String) | (Inherited from Control.)
 | Page | (Inherited from Control.)
 | Parent | (Inherited from Control.)
 | PreRender | (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | (Inherited from Control.)
 | RaisePostDataChangedEvent()()()() | (Inherited from CheckBox.)
 | RemovedControl(Control) | (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from CheckBox.)
 | RenderBeginTag(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingCompatibility | (Inherited from Control.)
 | ResolveAdapter()()()() | (Inherited from Control.)
 | ResolveClientUrl(String) | (Inherited from Control.)
 | ResolveUrl(String) | (Inherited from Control.)
 | SaveControlState()()()() | (Inherited from Control.)
 | SaveViewState()()()() | (Inherited from CheckBox.)
 | SetDesignModeState(IDictionary) | (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | (Inherited from Control.)
 | SetTraceData(Object, Object) | (Inherited from Control.)
 | SetTraceData(Object, Object, Object) | (Inherited from Control.)
 | Site | (Inherited from Control.)
 | SkinID | (Inherited from WebControl.)
 | Style | (Inherited from WebControl.)
 | SupportsDisabledAttribute | (Inherited from WebControl.)
 | TabIndex | (Inherited from WebControl.)
 | TagKey | (Inherited from WebControl.)
 | TagName | (Inherited from WebControl.)
 | TemplateControl | (Inherited from Control.)
 | TemplateSourceDirectory | (Inherited from Control.)
 | Text | (Inherited from CheckBox.)
 | TextAlign | (Inherited from CheckBox.)
 | ToolTip | (Inherited from WebControl.)
 | ToString()()()() | (Inherited from Object.)
 | TrackViewState()()()() | (Inherited from CheckBox.)
 | UniqueID | (Inherited from Control.)
 | Unload | (Inherited from Control.)
 | ValidateRequestMode | (Inherited from Control.)
 | ValidationGroup | (Inherited from CheckBox.)
 | ViewState | (Inherited from Control.)
 | ViewStateIgnoresCase | (Inherited from Control.)
 | ViewStateMode | (Inherited from Control.)
 | Visible | (Inherited from Control.)
 | Width | (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | CheckBox
 |  |  |  | KCheckBox

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


KCheckBox Constructor

KCheckBox Constructor
API Documentation ► Keyoti.SearchEngine.Web ► KCheckBox ► KCheckBox()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public KCheckBox()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


Font Property

Font Property
API Documentation ► Keyoti.SearchEngine.Web ► KCheckBox ► Font
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public override FontInfo Font { get; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overrides ReadOnly Property Font As FontInfo
    Get
Property Value
FontInfo

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


KDropDownList Class

KDropDownList Class
API Documentation ► Keyoti.SearchEngine.Web ► KDropDownList
Keyoti SearchUnit v6
Keyoti DropDownList control
Declaration Syntax
C# Visual Basic
public class KDropDownList : DropDownList
Public Class KDropDownList
    Inherits DropDownList
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | KDropDownList()()()() |
 | AccessKey | (Inherited from WebControl.)
 | Adapter | (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | (Inherited from DropDownList.)
 | AddedControl(Control, Int32) | (Inherited from Control.)
 | AddParsedSubObject(Object) | (Inherited from Control.)
 | AppendDataBoundItems | (Inherited from ListControl.)
 | ApplyStyle(Style) | (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | (Inherited from Control.)
 | Attributes | (Inherited from WebControl.)
 | AutoPostBack | (Inherited from ListControl.)
 | BackColor | (Overrides WebControl.BackColor.)
 | BeginRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | BindingContainer | (Inherited from Control.)
 | BorderColor | (Inherited from DropDownList.)
 | BorderStyle | (Inherited from DropDownList.)
 | BorderWidth | (Inherited from DropDownList.)
 | BuildProfileTree(String, Boolean) | (Inherited from Control.)
 | CallingDataMethods | (Inherited from DataBoundControl.)
 | CausesValidation | (Inherited from ListControl.)
 | ChildControlsCreated | (Inherited from Control.)
 | ClearCachedClientID()()()() | (Inherited from Control.)
 | ClearChildControlState()()()() | (Inherited from Control.)
 | ClearChildState()()()() | (Inherited from Control.)
 | ClearChildViewState()()()() | (Inherited from Control.)
 | ClearEffectiveClientIDMode()()()() | (Inherited from Control.)
 | ClearSelection()()()() | (Inherited from ListControl.)
 | ClientID | (Inherited from Control.)
 | ClientIDMode | (Inherited from Control.)
 | ClientIDSeparator | (Inherited from Control.)
 | ConfirmInitState()()()() | (Inherited from BaseDataBoundControl.)
 | Context | (Inherited from Control.)
 | Controls | (Inherited from Control.)
 | ControlStyle | (Inherited from WebControl.)
 | ControlStyleCreated | (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | (Inherited from WebControl.)
 | CreateChildControls()()()() | (Inherited from Control.)
 | CreateControlCollection()()()() | (Inherited from DropDownList.)
 | CreateControlStyle()()()() | (Inherited from WebControl.)
 | CreateDataSourceSelectArguments()()()() | (Inherited from DataBoundControl.)
 | CreatingModelDataSource | (Inherited from DataBoundControl.)
 | CssClass | (Overrides WebControl.CssClass.)
 | DataBind()()()() | (Inherited from BaseDataBoundControl.)
 | DataBind(Boolean) | (Inherited from Control.)
 | DataBindChildren()()()() | (Inherited from Control.)
 | DataBinding | (Inherited from Control.)
 | DataBound | (Inherited from BaseDataBoundControl.)
 | DataItemContainer | (Inherited from Control.)
 | DataKeysContainer | (Inherited from Control.)
 | DataMember | (Inherited from DataBoundControl.)
 | DataSource | (Inherited from BaseDataBoundControl.)
 | DataSourceID | (Inherited from DataBoundControl.)
 | DataSourceObject | (Inherited from DataBoundControl.)
 | DataTextField | (Inherited from ListControl.)
 | DataTextFormatString | (Inherited from ListControl.)
 | DataValueField | (Inherited from ListControl.)
 | DesignMode | (Inherited from Control.)
 | Dispose()()()() | (Inherited from Control.)
 | Disposed | (Inherited from Control.)
 | Enabled | (Inherited from WebControl.)
 | EnableTheming | (Inherited from WebControl.)
 | EnableViewState | (Inherited from Control.)
 | EndRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | EnsureChildControls()()()() | (Inherited from Control.)
 | EnsureDataBound()()()() | (Inherited from BaseDataBoundControl.)
 | EnsureID()()()() | (Inherited from Control.)
 | Equals(Object) | (Inherited from Object.)
 | Events | (Inherited from Control.)
 | Finalize()()()() | (Inherited from Object.)
 | FindControl(String) | (Inherited from Control.)
 | FindControl(String, Int32) | (Inherited from Control.)
 | Focus()()()() | (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Overrides WebControl.Font.)
 | ForeColor | (Overrides WebControl.ForeColor.)
 | GetData()()()() | (Inherited from DataBoundControl.)
 | GetDataSource()()()() | (Inherited from DataBoundControl.)
 | GetDesignModeState()()()() | (Inherited from Control.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetRouteUrl(Object) | (Inherited from Control.)
 | GetRouteUrl(String, Object) | (Inherited from Control.)
 | GetRouteUrl(RouteValueDictionary) | (Inherited from Control.)
 | GetRouteUrl(String, RouteValueDictionary) | (Inherited from Control.)
 | GetType()()()() | (Inherited from Object.)
 | GetUniqueIDRelativeTo(Control) | (Inherited from Control.)
 | HasAttributes | (Inherited from WebControl.)
 | HasChildViewState | (Inherited from Control.)
 | HasControls()()()() | (Inherited from Control.)
 | HasEvents()()()() | (Inherited from Control.)
 | Height | (Overrides WebControl.Height.)
 | ID | (Inherited from Control.)
 | IdSeparator | (Inherited from Control.)
 | Init | (Inherited from Control.)
 | Initialized | (Inherited from BaseDataBoundControl.)
 | IsBoundUsingDataSourceID | (Inherited from BaseDataBoundControl.)
 | IsChildControlStateCleared | (Inherited from Control.)
 | IsDataBindingAutomatic | (Inherited from BaseDataBoundControl.)
 | IsEnabled | (Inherited from WebControl.)
 | IsLiteralContent()()()() | (Inherited from Control.)
 | IsTrackingViewState | (Inherited from Control.)
 | IsUsingModelBinders | (Inherited from DataBoundControl.)
 | IsViewStateEnabled | (Inherited from Control.)
 | Items | (Overrides ListControl.Items.)
 | ItemType | (Inherited from DataBoundControl.)
 | Load | (Inherited from Control.)
 | LoadControlState(Object) | (Inherited from Control.)
 | LoadPostData(String, NameValueCollection) | (Inherited from DropDownList.)
 | LoadViewState(Object) | (Inherited from ListControl.)
 | LoadViewStateByID | (Inherited from Control.)
 | MapPathSecure(String) | (Inherited from Control.)
 | MarkAsDataBound()()()() | (Inherited from DataBoundControl.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle(Style) | (Inherited from WebControl.)
 | NamingContainer | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | (Inherited from Control.)
 | OnCreatingModelDataSource(CreatingModelDataSourceEventArgs) | (Inherited from DataBoundControl.)
 | OnDataBinding(EventArgs) | (Inherited from ListControl.)
 | OnDataBound(EventArgs) | (Inherited from BaseDataBoundControl.)
 | OnDataPropertyChanged()()()() | (Inherited from DataBoundControl.)
 | OnDataSourceViewChanged(Object, EventArgs) | (Inherited from DataBoundControl.)
 | OnInit(EventArgs) | (Inherited from BaseDataBoundControl.)
 | OnLoad(EventArgs) | (Inherited from DataBoundControl.)
 | OnPagePreLoad(Object, EventArgs) | (Inherited from DataBoundControl.)
 | OnPreRender(EventArgs) | (Inherited from ListControl.)
 | OnSelectedIndexChanged(EventArgs) | (Inherited from ListControl.)
 | OnTextChanged(EventArgs) | (Inherited from ListControl.)
 | OnUnload(EventArgs) | (Inherited from Control.)
 | OpenFile(String) | (Inherited from Control.)
 | Page | (Inherited from Control.)
 | Parent | (Inherited from Control.)
 | PerformDataBinding(IEnumerable) | (Inherited from ListControl.)
 | PerformSelect()()()() | (Inherited from ListControl.)
 | PreRender | (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | (Inherited from Control.)
 | RaisePostDataChangedEvent()()()() | (Inherited from DropDownList.)
 | RemovedControl(Control) | (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | (Inherited from ListControl.)
 | RenderControl(HtmlTextWriter) | (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingCompatibility | (Inherited from Control.)
 | RequiresDataBinding | (Inherited from BaseDataBoundControl.)
 | ResolveAdapter()()()() | (Inherited from Control.)
 | ResolveClientUrl(String) | (Inherited from Control.)
 | ResolveUrl(String) | (Inherited from Control.)
 | SaveControlState()()()() | (Inherited from Control.)
 | SaveViewState()()()() | (Inherited from ListControl.)
 | SelectArguments | (Inherited from DataBoundControl.)
 | SelectedIndex | (Inherited from DropDownList.)
 | SelectedIndexChanged | (Inherited from ListControl.)
 | SelectedItem | (Inherited from ListControl.)
 | SelectedValue | (Inherited from ListControl.)
 | SelectMethod | (Inherited from DataBoundControl.)
 | SetDesignModeState(IDictionary) | (Inherited from Control.)
 | SetPostDataSelection(Int32) | (Inherited from ListControl.)
 | SetRenderMethodDelegate(RenderMethod) | (Inherited from Control.)
 | SetTraceData(Object, Object) | (Inherited from Control.)
 | SetTraceData(Object, Object, Object) | (Inherited from Control.)
 | Site | (Inherited from Control.)
 | SkinID | (Inherited from WebControl.)
 | Style | (Inherited from WebControl.)
 | SupportsDisabledAttribute | (Inherited from DropDownList.)
 | TabIndex | (Inherited from WebControl.)
 | TagKey | (Inherited from ListControl.)
 | TagName | (Inherited from WebControl.)
 | TemplateControl | (Inherited from Control.)
 | TemplateSourceDirectory | (Inherited from Control.)
 | Text | (Inherited from ListControl.)
 | TextChanged | (Inherited from ListControl.)
 | ToolTip | (Inherited from WebControl.)
 | ToString()()()() | (Inherited from Object.)
 | TrackViewState()()()() | (Inherited from ListControl.)
 | UniqueID | (Inherited from Control.)
 | Unload | (Inherited from Control.)
 | ValidateDataSource(Object) | (Inherited from DataBoundControl.)
 | ValidateRequestMode | (Inherited from Control.)
 | ValidationGroup | (Inherited from ListControl.)
 | VerifyMultiSelect()()()() | (Inherited from DropDownList.)
 | ViewState | (Inherited from Control.)
 | ViewStateIgnoresCase | (Inherited from Control.)
 | ViewStateMode | (Inherited from Control.)
 | Visible | (Inherited from Control.)
 | Width | (Overrides WebControl.Width.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | BaseDataBoundControl
 |  |  |  | DataBoundControl
 |  |  |  |  | ListControl
 |  |  |  |  |  | DropDownList
 |  |  |  |  |  |  | KDropDownList

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


KDropDownList Constructor

KDropDownList Constructor
API Documentation ► Keyoti.SearchEngine.Web ► KDropDownList ► KDropDownList()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public KDropDownList()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


BackColor Property

BackColor Property
API Documentation ► Keyoti.SearchEngine.Web ► KDropDownList ► BackColor
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public override Color BackColor { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overrides Property BackColor As Color
    Get
    Set
Property Value
Color

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


CssClass Property

CssClass Property
API Documentation ► Keyoti.SearchEngine.Web ► KDropDownList ► CssClass
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public override string CssClass { get; set; }
Public Overrides Property CssClass As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


Font Property

Font Property
API Documentation ► Keyoti.SearchEngine.Web ► KDropDownList ► Font
Keyoti SearchUnit v6
Gets the font properties associated with the Web server control.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public override FontInfo Font { get; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overrides ReadOnly Property Font As FontInfo
    Get
Property Value
FontInfo

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


ForeColor Property

ForeColor Property
API Documentation ► Keyoti.SearchEngine.Web ► KDropDownList ► ForeColor
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public override Color ForeColor { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overrides Property ForeColor As Color
    Get
    Set
Property Value
Color

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


Height Property

Height Property
API Documentation ► Keyoti.SearchEngine.Web ► KDropDownList ► Height
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public override Unit Height { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overrides Property Height As Unit
    Get
    Set
Property Value
Unit

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


Items Property

Items Property
API Documentation ► Keyoti.SearchEngine.Web ► KDropDownList ► Items
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public override ListItemCollection Items { get; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overrides ReadOnly Property Items As ListItemCollection
    Get
Property Value
ListItemCollection

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


Width Property

Width Property
API Documentation ► Keyoti.SearchEngine.Web ► KDropDownList ► Width
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public override Unit Width { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overrides Property Width As Unit
    Get
    Set
Property Value
Unit

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


KFont Class

KFont Class
API Documentation ► Keyoti.SearchEngine.Web ► KFont
Keyoti SearchUnit v6
Keyoti Font class
Declaration Syntax
C# Visual Basic
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public class KFont
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Class KFont
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | KFont()()()() |
 | Bold |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Italic |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name |
 | Names |
 | Overline |
 | Size |
 | Strikeout |
 | ToString()()()() | (Inherited from Object.)
 | Underline |
Inheritance Hierarchy
Object
KFont

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


KFont Constructor

KFont Constructor
API Documentation ► Keyoti.SearchEngine.Web ► KFont ► KFont()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public KFont()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


Bold Property

Bold Property
API Documentation ► Keyoti.SearchEngine.Web ► KFont ► Bold
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool Bold { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property Bold As Boolean
    Get
    Set
Property Value
Boolean

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


Italic Property

Italic Property
API Documentation ► Keyoti.SearchEngine.Web ► KFont ► Italic
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool Italic { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property Italic As Boolean
    Get
    Set
Property Value
Boolean

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


Name Property

Name Property
API Documentation ► Keyoti.SearchEngine.Web ► KFont ► Name
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string Name { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property Name As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


Names Property

Names Property
API Documentation ► Keyoti.SearchEngine.Web ► KFont ► Names
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
[TypeConverterAttribute(typeof(FontNamesConverter))]
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string[] Names { get; set; }
<TypeConverterAttribute(GetType(FontNamesConverter))>
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property Names As String()
    Get
    Set
Property Value
array< String >[]()[][]

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


Overline Property

Overline Property
API Documentation ► Keyoti.SearchEngine.Web ► KFont ► Overline
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool Overline { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property Overline As Boolean
    Get
    Set
Property Value
Boolean

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


Size Property

Size Property
API Documentation ► Keyoti.SearchEngine.Web ► KFont ► Size
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public FontUnit Size { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property Size As FontUnit
    Get
    Set
Property Value
FontUnit

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


Strikeout Property

Strikeout Property
API Documentation ► Keyoti.SearchEngine.Web ► KFont ► Strikeout
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool Strikeout { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property Strikeout As Boolean
    Get
    Set
Property Value
Boolean

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


Underline Property

Underline Property
API Documentation ► Keyoti.SearchEngine.Web ► KFont ► Underline
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool Underline { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property Underline As Boolean
    Get
    Set
Property Value
Boolean

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


KLabel Class

KLabel Class
API Documentation ► Keyoti.SearchEngine.Web ► KLabel
Keyoti SearchUnit v6
Keyoti Label Control
Declaration Syntax
C# Visual Basic
public class KLabel : Label
Public Class KLabel
    Inherits Label
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | KLabel()()()() |
 | AccessKey | (Inherited from WebControl.)
 | Adapter | (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | (Inherited from Label.)
 | AddedControl(Control, Int32) | (Inherited from Control.)
 | AddParsedSubObject(Object) | (Inherited from Label.)
 | ApplyStyle(Style) | (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | (Inherited from Control.)
 | AssociatedControlID | (Inherited from Label.)
 | Attributes | (Inherited from WebControl.)
 | BackColor | (Inherited from WebControl.)
 | BeginRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | BindingContainer | (Inherited from Control.)
 | BorderColor | (Inherited from WebControl.)
 | BorderStyle | (Inherited from WebControl.)
 | BorderWidth | (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | (Inherited from Control.)
 | ChildControlsCreated | (Inherited from Control.)
 | ClearCachedClientID()()()() | (Inherited from Control.)
 | ClearChildControlState()()()() | (Inherited from Control.)
 | ClearChildState()()()() | (Inherited from Control.)
 | ClearChildViewState()()()() | (Inherited from Control.)
 | ClearEffectiveClientIDMode()()()() | (Inherited from Control.)
 | ClientID | (Inherited from Control.)
 | ClientIDMode | (Inherited from Control.)
 | ClientIDSeparator | (Inherited from Control.)
 | Context | (Inherited from Control.)
 | Controls | (Inherited from Control.)
 | ControlStyle | (Inherited from WebControl.)
 | ControlStyleCreated | (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | (Inherited from WebControl.)
 | CreateChildControls()()()() | (Inherited from Control.)
 | CreateControlCollection()()()() | (Inherited from Control.)
 | CreateControlStyle()()()() | (Inherited from WebControl.)
 | CssClass | (Inherited from WebControl.)
 | DataBind()()()() | (Inherited from Control.)
 | DataBind(Boolean) | (Inherited from Control.)
 | DataBindChildren()()()() | (Inherited from Control.)
 | DataBinding | (Inherited from Control.)
 | DataItemContainer | (Inherited from Control.)
 | DataKeysContainer | (Inherited from Control.)
 | DesignMode | (Inherited from Control.)
 | Dispose()()()() | (Inherited from Control.)
 | Disposed | (Inherited from Control.)
 | Enabled | (Inherited from WebControl.)
 | EnableTheming | (Inherited from WebControl.)
 | EnableViewState | (Inherited from Control.)
 | EndRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | EnsureChildControls()()()() | (Inherited from Control.)
 | EnsureID()()()() | (Inherited from Control.)
 | Equals(Object) | (Inherited from Object.)
 | Events | (Inherited from Control.)
 | Finalize()()()() | (Inherited from Object.)
 | FindControl(String) | (Inherited from Control.)
 | FindControl(String, Int32) | (Inherited from Control.)
 | Focus()()()() | (Inherited from Control.)
 | Font | (Inherited from WebControl.)
 | ForeColor | (Inherited from WebControl.)
 | GetDesignModeState()()()() | (Inherited from Control.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetRouteUrl(Object) | (Inherited from Control.)
 | GetRouteUrl(String, Object) | (Inherited from Control.)
 | GetRouteUrl(RouteValueDictionary) | (Inherited from Control.)
 | GetRouteUrl(String, RouteValueDictionary) | (Inherited from Control.)
 | GetType()()()() | (Inherited from Object.)
 | GetUniqueIDRelativeTo(Control) | (Inherited from Control.)
 | HasAttributes | (Inherited from WebControl.)
 | HasChildViewState | (Inherited from Control.)
 | HasControls()()()() | (Inherited from Control.)
 | HasEvents()()()() | (Inherited from Control.)
 | Height | (Inherited from WebControl.)
 | ID | (Inherited from Control.)
 | IdSeparator | (Inherited from Control.)
 | Init | (Inherited from Control.)
 | IsChildControlStateCleared | (Inherited from Control.)
 | IsEnabled | (Inherited from WebControl.)
 | IsLiteralContent()()()() | (Inherited from Control.)
 | IsTrackingViewState | (Inherited from Control.)
 | IsViewStateEnabled | (Inherited from Control.)
 | Load | (Inherited from Control.)
 | LoadControlState(Object) | (Inherited from Control.)
 | LoadViewState(Object) | (Inherited from Label.)
 | LoadViewStateByID | (Inherited from Control.)
 | MapPathSecure(String) | (Inherited from Control.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle(Style) | (Inherited from WebControl.)
 | NamingContainer | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | (Inherited from Control.)
 | OnDataBinding(EventArgs) | (Inherited from Control.)
 | OnInit(EventArgs) | (Inherited from Control.)
 | OnLoad(EventArgs) | (Inherited from Control.)
 | OnPreRender(EventArgs) | (Inherited from Control.)
 | OnUnload(EventArgs) | (Inherited from Control.)
 | OpenFile(String) | (Inherited from Control.)
 | Page | (Inherited from Control.)
 | Parent | (Inherited from Control.)
 | PreRender | (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | (Inherited from Control.)
 | RemovedControl(Control) | (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | (Inherited from Label.)
 | RenderControl(HtmlTextWriter) | (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingCompatibility | (Inherited from Control.)
 | ResolveAdapter()()()() | (Inherited from Control.)
 | ResolveClientUrl(String) | (Inherited from Control.)
 | ResolveUrl(String) | (Inherited from Control.)
 | SaveControlState()()()() | (Inherited from Control.)
 | SaveViewState()()()() | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | (Inherited from Control.)
 | SetTraceData(Object, Object) | (Inherited from Control.)
 | SetTraceData(Object, Object, Object) | (Inherited from Control.)
 | Site | (Inherited from Control.)
 | SkinID | (Inherited from WebControl.)
 | Style | (Inherited from WebControl.)
 | SupportsDisabledAttribute | (Inherited from Label.)
 | TabIndex | (Inherited from WebControl.)
 | TagKey | (Inherited from Label.)
 | TagName | (Inherited from WebControl.)
 | TemplateControl | (Inherited from Control.)
 | TemplateSourceDirectory | (Inherited from Control.)
 | Text | (Overrides Label.Text.)
 | ToolTip | (Inherited from WebControl.)
 | ToString()()()() | (Inherited from Object.)
 | TrackViewState()()()() | (Inherited from WebControl.)
 | UniqueID | (Inherited from Control.)
 | Unload | (Inherited from Control.)
 | ValidateRequestMode | (Inherited from Control.)
 | ViewState | (Inherited from Control.)
 | ViewStateIgnoresCase | (Inherited from Control.)
 | ViewStateMode | (Inherited from Control.)
 | Visible | (Inherited from Control.)
 | Width | (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | Label
 |  |  |  | KLabel

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


KLabel Constructor

KLabel Constructor
API Documentation ► Keyoti.SearchEngine.Web ► KLabel ► KLabel()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public KLabel()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


Text Property

Text Property
API Documentation ► Keyoti.SearchEngine.Web ► KLabel ► Text
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public override string Text { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overrides Property Text As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


KTextBox Class

KTextBox Class
API Documentation ► Keyoti.SearchEngine.Web ► KTextBox
Keyoti SearchUnit v6
RapidSpell button
Declaration Syntax
C# Visual Basic
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public class KTextBox : Control
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Class KTextBox
    Inherits Control
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | KTextBox()()()() | Initializes a new instance of the RSButton class using the specified button type
 | Adapter | (Inherited from Control.)
 | AddedControl(Control, Int32) | (Inherited from Control.)
 | AddParsedSubObject(Object) | (Inherited from Control.)
 | ApplyStyleSheetSkin(Page) | (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | (Inherited from Control.)
 | Attributes | The runtime attributes.
 | BackColor | Gets or sets the background color of the Web server control.
 | BeginRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | BindingContainer | (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web server control.
 | BorderStyle | Gets or sets the border style of the Web server control.
 | BorderWidth | Gets or sets the border width of the Web server control.
 | BuildProfileTree(String, Boolean) | (Inherited from Control.)
 | ChildControlsCreated | (Inherited from Control.)
 | ClearCachedClientID()()()() | (Inherited from Control.)
 | ClearChildControlState()()()() | (Inherited from Control.)
 | ClearChildState()()()() | (Inherited from Control.)
 | ClearChildViewState()()()() | (Inherited from Control.)
 | ClearEffectiveClientIDMode()()()() | (Inherited from Control.)
 | ClientID | (Inherited from Control.)
 | ClientIDMode | (Inherited from Control.)
 | ClientIDSeparator | (Inherited from Control.)
 | Context | (Inherited from Control.)
 | Controls | (Inherited from Control.)
 | CreateChildControls()()()() | (Inherited from Control.)
 | CreateControlCollection()()()() | (Inherited from Control.)
 | CssClass | The CssClass of this control.
 | DataBind()()()() | (Inherited from Control.)
 | DataBind(Boolean) | (Inherited from Control.)
 | DataBindChildren()()()() | (Inherited from Control.)
 | DataBinding | (Inherited from Control.)
 | DataItemContainer | (Inherited from Control.)
 | DataKeysContainer | (Inherited from Control.)
 | DesignMode | (Inherited from Control.)
 | Dispose()()()() | (Inherited from Control.)
 | Disposed | (Inherited from Control.)
 | EnableTheming | (Inherited from Control.)
 | EnableViewState | (Inherited from Control.)
 | EndRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | EnsureChildControls()()()() | (Inherited from Control.)
 | EnsureID()()()() | (Inherited from Control.)
 | Equals(Object) | (Inherited from Object.)
 | Events | (Inherited from Control.)
 | Finalize()()()() | (Inherited from Object.)
 | FindControl(String) | (Inherited from Control.)
 | FindControl(String, Int32) | (Inherited from Control.)
 | Focus()()()() | (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control.
 | ForeColor | Gets or sets the foreground color of the Web server control.
 | GetDesignModeState()()()() | (Inherited from Control.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetRouteUrl(Object) | (Inherited from Control.)
 | GetRouteUrl(String, Object) | (Inherited from Control.)
 | GetRouteUrl(RouteValueDictionary) | (Inherited from Control.)
 | GetRouteUrl(String, RouteValueDictionary) | (Inherited from Control.)
 | GetType()()()() | (Inherited from Object.)
 | GetUniqueIDRelativeTo(Control) | (Inherited from Control.)
 | HasChildViewState | (Inherited from Control.)
 | HasControls()()()() | (Inherited from Control.)
 | HasEvents()()()() | (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control.
 | ID | The ID of the control (Overrides Control.ID.)
 | IdSeparator | (Inherited from Control.)
 | Init | (Inherited from Control.)
 | IsChildControlStateCleared | (Inherited from Control.)
 | IsLiteralContent()()()() | (Inherited from Control.)
 | IsTrackingViewState | (Inherited from Control.)
 | IsViewStateEnabled | (Inherited from Control.)
 | Load | (Inherited from Control.)
 | LoadControlState(Object) | (Inherited from Control.)
 | LoadViewState(Object) | (Inherited from Control.)
 | LoadViewStateByID | (Inherited from Control.)
 | MapPathSecure(String) | (Inherited from Control.)
 | MaxLength | The maxlength.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name | The button text.
 | NamingContainer | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | (Inherited from Control.)
 | onclick | The button client-side onclick handler.
 | OnDataBinding(EventArgs) | (Inherited from Control.)
 | OnInit(EventArgs) | (Inherited from Control.)
 | onKeyPress | The text box client-side onclick handler.
 | OnLoad(EventArgs) | (Inherited from Control.)
 | OnPreRender(EventArgs) | (Overrides Control.OnPreRender(EventArgs).)
 | OnUnload(EventArgs) | (Inherited from Control.)
 | OpenFile(String) | (Inherited from Control.)
 | Page | (Inherited from Control.)
 | Parent | (Inherited from Control.)
 | PreRender | (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | (Inherited from Control.)
 | RemovedControl(Control) | (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control. (Overrides Control.Render(HtmlTextWriter).)
 | RenderAttributes(HtmlTextWriter) | Internal use.
 | RenderChildren(HtmlTextWriter) | (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | (Inherited from Control.)
 | RenderingCompatibility | (Inherited from Control.)
 | ResolveAdapter()()()() | (Inherited from Control.)
 | ResolveClientUrl(String) | (Inherited from Control.)
 | ResolveUrl(String) | (Inherited from Control.)
 | runat | Internal use.
 | SaveControlState()()()() | (Inherited from Control.)
 | SaveViewState()()()() | (Inherited from Control.)
 | SetDesignModeState(IDictionary) | (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | (Inherited from Control.)
 | SetTraceData(Object, Object) | (Inherited from Control.)
 | SetTraceData(Object, Object, Object) | (Inherited from Control.)
 | Site | (Inherited from Control.)
 | SkinID | (Inherited from Control.)
 | style | The button client-side style handler.
 | TabIndex | The tab index.
 | TemplateControl | (Inherited from Control.)
 | TemplateSourceDirectory | (Inherited from Control.)
 | ToString()()()() | (Inherited from Object.)
 | TrackViewState()()()() | (Inherited from Control.)
 | type | The button text.
 | UniqueID | (Inherited from Control.)
 | Unload | (Inherited from Control.)
 | ValidateRequestMode | (Inherited from Control.)
 | Value | The button text.
 | ViewState | (Inherited from Control.)
 | ViewStateIgnoresCase | (Inherited from Control.)
 | ViewStateMode | (Inherited from Control.)
 | Visible | Whether to render this control (Overrides Control.Visible.)
 | WatermarkColor | Watermark text.
 | WatermarkText | Watermark text.
 | WatermarkVisible | Watermark text.
 | Width | Gets or sets the width of the Web server control.
Inheritance Hierarchy
Object
 | Control
 |  | KTextBox

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


KTextBox Constructor

KTextBox Constructor
API Documentation ► Keyoti.SearchEngine.Web ► KTextBox ► KTextBox()()()()
Keyoti SearchUnit v6
Initializes a new instance of the RSButton class using the specified button type
Declaration Syntax
C# Visual Basic
public KTextBox()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Attributes Property

Attributes Property
API Documentation ► Keyoti.SearchEngine.Web ► KTextBox ► Attributes
Keyoti SearchUnit v6
The runtime attributes.
Declaration Syntax
C# Visual Basic
public AttributeCollection Attributes { get; }
Public ReadOnly Property Attributes As AttributeCollection
    Get
Property Value
AttributeCollection

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


BackColor Property

BackColor Property
API Documentation ► Keyoti.SearchEngine.Web ► KTextBox ► BackColor
Keyoti SearchUnit v6
Gets or sets the background color of the Web server control.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public Color BackColor { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property BackColor As Color
    Get
    Set
Property Value
Color

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


BorderColor Property

BorderColor Property
API Documentation ► Keyoti.SearchEngine.Web ► KTextBox ► BorderColor
Keyoti SearchUnit v6
Gets or sets the border color of the Web server control.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public Color BorderColor { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property BorderColor As Color
    Get
    Set
Property Value
Color

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


BorderStyle Property

BorderStyle Property
API Documentation ► Keyoti.SearchEngine.Web ► KTextBox ► BorderStyle
Keyoti SearchUnit v6
Gets or sets the border style of the Web server control.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public BorderStyle BorderStyle { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property BorderStyle As BorderStyle
    Get
    Set
Property Value
BorderStyle

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


BorderWidth Property

BorderWidth Property
API Documentation ► Keyoti.SearchEngine.Web ► KTextBox ► BorderWidth
Keyoti SearchUnit v6
Gets or sets the border width of the Web server control.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public Unit BorderWidth { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property BorderWidth As Unit
    Get
    Set
Property Value
Unit

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


CssClass Property

CssClass Property
API Documentation ► Keyoti.SearchEngine.Web ► KTextBox ► CssClass
Keyoti SearchUnit v6
The CssClass of this control.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string CssClass { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property CssClass As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Font Property

Font Property
API Documentation ► Keyoti.SearchEngine.Web ► KTextBox ► Font
Keyoti SearchUnit v6
Gets the font properties associated with the Web server control.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public FontInfo Font { get; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public ReadOnly Property Font As FontInfo
    Get
Property Value
FontInfo

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ForeColor Property

ForeColor Property
API Documentation ► Keyoti.SearchEngine.Web ► KTextBox ► ForeColor
Keyoti SearchUnit v6
Gets or sets the foreground color of the Web server control.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public Color ForeColor { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ForeColor As Color
    Get
    Set
Property Value
Color

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Height Property

Height Property
API Documentation ► Keyoti.SearchEngine.Web ► KTextBox ► Height
Keyoti SearchUnit v6
Gets or sets the height of the Web server control.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public Unit Height { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property Height As Unit
    Get
    Set
Property Value
Unit

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ID Property

ID Property
API Documentation ► Keyoti.SearchEngine.Web ► KTextBox ► ID
Keyoti SearchUnit v6
The ID of the control
Declaration Syntax
C# Visual Basic
public override string ID { get; set; }
Public Overrides Property ID As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


MaxLength Property

MaxLength Property
API Documentation ► Keyoti.SearchEngine.Web ► KTextBox ► MaxLength
Keyoti SearchUnit v6
The maxlength.
Declaration Syntax
C# Visual Basic
public short MaxLength { get; set; }
Public Property MaxLength As Short
    Get
    Set
Property Value
Int16

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Name Property

Name Property
API Documentation ► Keyoti.SearchEngine.Web ► KTextBox ► Name
Keyoti SearchUnit v6
The button text.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string Name { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property Name As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


onclick Property

onclick Property
API Documentation ► Keyoti.SearchEngine.Web ► KTextBox ► onclick
Keyoti SearchUnit v6
The button client-side onclick handler.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string onclick { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property onclick As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


onKeyPress Property

onKeyPress Property
API Documentation ► Keyoti.SearchEngine.Web ► KTextBox ► onKeyPress
Keyoti SearchUnit v6
The text box client-side onclick handler.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string onKeyPress { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property onKeyPress As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


OnPreRender Method (e)

OnPreRender Method (e)
API Documentation ► Keyoti.SearchEngine.Web ► KTextBox ► OnPreRender(EventArgs)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
protected override void OnPreRender(
    EventArgs e
)
Protected Overrides Sub OnPreRender (
    e As EventArgs
)
Parameters
e (EventArgs)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Render Method (output)

Render Method (output)
API Documentation ► Keyoti.SearchEngine.Web ► KTextBox ► Render(HtmlTextWriter)
Keyoti SearchUnit v6
Renders the control.
Declaration Syntax
C# Visual Basic
protected override void Render(
    HtmlTextWriter output
)
Protected Overrides Sub Render (
    output As HtmlTextWriter
)
Parameters
output (HtmlTextWriter)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


RenderAttributes Method (writer)

RenderAttributes Method (writer)
API Documentation ► Keyoti.SearchEngine.Web ► KTextBox ► RenderAttributes(HtmlTextWriter)
Keyoti SearchUnit v6
Internal use.
Declaration Syntax
C# Visual Basic
protected virtual void RenderAttributes(
    HtmlTextWriter writer
)
Protected Overridable Sub RenderAttributes (
    writer As HtmlTextWriter
)
Parameters
writer (HtmlTextWriter)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


runat Property

runat Property
API Documentation ► Keyoti.SearchEngine.Web ► KTextBox ► runat
Keyoti SearchUnit v6
Internal use.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string runat { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property runat As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


style Property

style Property
API Documentation ► Keyoti.SearchEngine.Web ► KTextBox ► style
Keyoti SearchUnit v6
The button client-side style handler.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string style { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property style As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


TabIndex Property

TabIndex Property
API Documentation ► Keyoti.SearchEngine.Web ► KTextBox ► TabIndex
Keyoti SearchUnit v6
The tab index.
Declaration Syntax
C# Visual Basic
public short TabIndex { get; set; }
Public Property TabIndex As Short
    Get
    Set
Property Value
Int16

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


type Property

type Property
API Documentation ► Keyoti.SearchEngine.Web ► KTextBox ► type
Keyoti SearchUnit v6
The button text.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string type { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property type As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Value Property

Value Property
API Documentation ► Keyoti.SearchEngine.Web ► KTextBox ► Value
Keyoti SearchUnit v6
The button text.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string Value { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property Value As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Visible Property

Visible Property
API Documentation ► Keyoti.SearchEngine.Web ► KTextBox ► Visible
Keyoti SearchUnit v6
Whether to render this control
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public override bool Visible { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overrides Property Visible As Boolean
    Get
    Set
Property Value
Boolean

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


WatermarkColor Property

WatermarkColor Property
API Documentation ► Keyoti.SearchEngine.Web ► KTextBox ► WatermarkColor
Keyoti SearchUnit v6
Watermark text.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public Color WatermarkColor { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property WatermarkColor As Color
    Get
    Set
Property Value
Color

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


WatermarkText Property

WatermarkText Property
API Documentation ► Keyoti.SearchEngine.Web ► KTextBox ► WatermarkText
Keyoti SearchUnit v6
Watermark text.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string WatermarkText { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property WatermarkText As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


WatermarkVisible Property

WatermarkVisible Property
API Documentation ► Keyoti.SearchEngine.Web ► KTextBox ► WatermarkVisible
Keyoti SearchUnit v6
Watermark text.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool WatermarkVisible { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property WatermarkVisible As Boolean
    Get
    Set
Property Value
Boolean

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Width Property

Width Property
API Documentation ► Keyoti.SearchEngine.Web ► KTextBox ► Width
Keyoti SearchUnit v6
Gets or sets the width of the Web server control.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public Unit Width { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property Width As Unit
    Get
    Set
Property Value
Unit

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


NET4 Class

NET4 Class
API Documentation ► Keyoti.SearchEngine.Web ► NET4
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public class NET4
Public Class NET4
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | NET4()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
NET4

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


NET4 Constructor

NET4 Constructor
API Documentation ► Keyoti.SearchEngine.Web ► NET4 ► NET4()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public NET4()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


NoQuery Class

NoQuery Class
API Documentation ► Keyoti.SearchEngine.Web ► NoQuery
Keyoti SearchUnit v6
Shown when there is no search query
Declaration Syntax
C# Visual Basic
public class NoQuery : WebControl, INamingContainer
Public Class NoQuery
    Inherits WebControl
    Implements INamingContainer
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NoQuery()()()() |
 | AccessKey | (Inherited from WebControl.)
 | Adapter | (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | (Inherited from Control.)
 | AddParsedSubObject(Object) | (Inherited from Control.)
 | ApplyStyle(Style) | (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | (Inherited from Control.)
 | Attributes | (Inherited from WebControl.)
 | BackColor | (Inherited from WebControl.)
 | BeginRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | BindingContainer | (Inherited from Control.)
 | BorderColor | (Inherited from WebControl.)
 | BorderStyle | (Inherited from WebControl.)
 | BorderWidth | (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | (Inherited from Control.)
 | ChildControlsCreated | (Inherited from Control.)
 | ClearCachedClientID()()()() | (Inherited from Control.)
 | ClearChildControlState()()()() | (Inherited from Control.)
 | ClearChildState()()()() | (Inherited from Control.)
 | ClearChildViewState()()()() | (Inherited from Control.)
 | ClearEffectiveClientIDMode()()()() | (Inherited from Control.)
 | ClientID | (Inherited from Control.)
 | ClientIDMode | (Inherited from Control.)
 | ClientIDSeparator | (Inherited from Control.)
 | Context | (Inherited from Control.)
 | Controls | (Inherited from Control.)
 | ControlStyle | (Inherited from WebControl.)
 | ControlStyleCreated | (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | (Inherited from WebControl.)
 | CreateChildControls()()()() | (Inherited from Control.)
 | CreateControlCollection()()()() | (Inherited from Control.)
 | CreateControlStyle()()()() | (Inherited from WebControl.)
 | CssClass | (Inherited from WebControl.)
 | DataBind()()()() | (Inherited from Control.)
 | DataBind(Boolean) | (Inherited from Control.)
 | DataBindChildren()()()() | (Inherited from Control.)
 | DataBinding | (Inherited from Control.)
 | DataItemContainer | (Inherited from Control.)
 | DataKeysContainer | (Inherited from Control.)
 | DesignMode | (Inherited from Control.)
 | Dispose()()()() | (Inherited from Control.)
 | Disposed | (Inherited from Control.)
 | Enabled | (Inherited from WebControl.)
 | EnableTheming | (Inherited from WebControl.)
 | EnableViewState | (Inherited from Control.)
 | EndRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | EnsureChildControls()()()() | (Inherited from Control.)
 | EnsureID()()()() | (Inherited from Control.)
 | Equals(Object) | (Inherited from Object.)
 | Events | (Inherited from Control.)
 | Finalize()()()() | (Inherited from Object.)
 | FindControl(String) | (Inherited from Control.)
 | FindControl(String, Int32) | (Inherited from Control.)
 | Focus()()()() | (Inherited from Control.)
 | Font | (Inherited from WebControl.)
 | ForeColor | (Inherited from WebControl.)
 | GetDesignModeState()()()() | (Inherited from Control.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetRouteUrl(Object) | (Inherited from Control.)
 | GetRouteUrl(String, Object) | (Inherited from Control.)
 | GetRouteUrl(RouteValueDictionary) | (Inherited from Control.)
 | GetRouteUrl(String, RouteValueDictionary) | (Inherited from Control.)
 | GetType()()()() | (Inherited from Object.)
 | GetUniqueIDRelativeTo(Control) | (Inherited from Control.)
 | HasAttributes | (Inherited from WebControl.)
 | HasChildViewState | (Inherited from Control.)
 | HasControls()()()() | (Inherited from Control.)
 | HasEvents()()()() | (Inherited from Control.)
 | Height | (Inherited from WebControl.)
 | ID | (Inherited from Control.)
 | IdSeparator | (Inherited from Control.)
 | Init | (Inherited from Control.)
 | IsChildControlStateCleared | (Inherited from Control.)
 | IsEnabled | (Inherited from WebControl.)
 | IsLiteralContent()()()() | (Inherited from Control.)
 | IsTrackingViewState | (Inherited from Control.)
 | IsViewStateEnabled | (Inherited from Control.)
 | Load | (Inherited from Control.)
 | LoadControlState(Object) | (Inherited from Control.)
 | LoadViewState(Object) | (Inherited from WebControl.)
 | LoadViewStateByID | (Inherited from Control.)
 | MapPathSecure(String) | (Inherited from Control.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle(Style) | (Inherited from WebControl.)
 | NamingContainer | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | (Inherited from Control.)
 | OnDataBinding(EventArgs) | (Inherited from Control.)
 | OnInit(EventArgs) | (Inherited from Control.)
 | OnLoad(EventArgs) | (Inherited from Control.)
 | OnPreRender(EventArgs) | (Inherited from Control.)
 | OnUnload(EventArgs) | (Inherited from Control.)
 | OpenFile(String) | (Inherited from Control.)
 | Page | (Inherited from Control.)
 | Parent | (Inherited from Control.)
 | PreRender | (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | (Inherited from Control.)
 | RemovedControl(Control) | (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | See base (Overrides WebControl.RenderBeginTag(HtmlTextWriter).)
 | RenderChildren(HtmlTextWriter) | (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | See base (Overrides WebControl.RenderEndTag(HtmlTextWriter).)
 | RenderingCompatibility | (Inherited from Control.)
 | ResolveAdapter()()()() | (Inherited from Control.)
 | ResolveClientUrl(String) | (Inherited from Control.)
 | ResolveUrl(String) | (Inherited from Control.)
 | SaveControlState()()()() | (Inherited from Control.)
 | SaveViewState()()()() | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | (Inherited from Control.)
 | SetTraceData(Object, Object) | (Inherited from Control.)
 | SetTraceData(Object, Object, Object) | (Inherited from Control.)
 | Site | (Inherited from Control.)
 | SkinID | (Inherited from WebControl.)
 | Style | (Inherited from WebControl.)
 | SupportsDisabledAttribute | (Inherited from WebControl.)
 | TabIndex | (Inherited from WebControl.)
 | TagKey | (Inherited from WebControl.)
 | TagName | (Inherited from WebControl.)
 | TemplateControl | (Inherited from Control.)
 | TemplateSourceDirectory | (Inherited from Control.)
 | ToolTip | (Inherited from WebControl.)
 | ToString()()()() | (Inherited from Object.)
 | TrackViewState()()()() | (Inherited from WebControl.)
 | UniqueID | (Inherited from Control.)
 | Unload | (Inherited from Control.)
 | ValidateRequestMode | (Inherited from Control.)
 | ViewState | (Inherited from Control.)
 | ViewStateIgnoresCase | (Inherited from Control.)
 | ViewStateMode | (Inherited from Control.)
 | Visible | (Inherited from Control.)
 | Width | (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | NoQuery

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


NoQuery Constructor

NoQuery Constructor
API Documentation ► Keyoti.SearchEngine.Web ► NoQuery ► NoQuery()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public NoQuery()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


RenderBeginTag Method (writer)

RenderBeginTag Method (writer)
API Documentation ► Keyoti.SearchEngine.Web ► NoQuery ► RenderBeginTag(HtmlTextWriter)
Keyoti SearchUnit v6
See base
Declaration Syntax
C# Visual Basic
public override void RenderBeginTag(
    HtmlTextWriter writer
)
Public Overrides Sub RenderBeginTag (
    writer As HtmlTextWriter
)
Parameters
writer (HtmlTextWriter)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


RenderEndTag Method (writer)

RenderEndTag Method (writer)
API Documentation ► Keyoti.SearchEngine.Web ► NoQuery ► RenderEndTag(HtmlTextWriter)
Keyoti SearchUnit v6
See base
Declaration Syntax
C# Visual Basic
public override void RenderEndTag(
    HtmlTextWriter writer
)
Public Overrides Sub RenderEndTag (
    writer As HtmlTextWriter
)
Parameters
writer (HtmlTextWriter)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


NoResults Class

NoResults Class
API Documentation ► Keyoti.SearchEngine.Web ► NoResults
Keyoti SearchUnit v6
Shown when there are no results
Declaration Syntax
C# Visual Basic
public class NoResults : WebControl, INamingContainer
Public Class NoResults
    Inherits WebControl
    Implements INamingContainer
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NoResults(String, String) |
 | AccessKey | (Inherited from WebControl.)
 | Adapter | (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | (Inherited from Control.)
 | AddParsedSubObject(Object) | (Inherited from Control.)
 | ApplyStyle(Style) | (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | (Inherited from Control.)
 | Attributes | (Inherited from WebControl.)
 | BackColor | (Inherited from WebControl.)
 | BeginRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | BindingContainer | (Inherited from Control.)
 | BorderColor | (Inherited from WebControl.)
 | BorderStyle | (Inherited from WebControl.)
 | BorderWidth | (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | (Inherited from Control.)
 | ChildControlsCreated | (Inherited from Control.)
 | ClearCachedClientID()()()() | (Inherited from Control.)
 | ClearChildControlState()()()() | (Inherited from Control.)
 | ClearChildState()()()() | (Inherited from Control.)
 | ClearChildViewState()()()() | (Inherited from Control.)
 | ClearEffectiveClientIDMode()()()() | (Inherited from Control.)
 | ClientID | (Inherited from Control.)
 | ClientIDMode | (Inherited from Control.)
 | ClientIDSeparator | (Inherited from Control.)
 | Context | (Inherited from Control.)
 | Controls | (Inherited from Control.)
 | ControlStyle | (Inherited from WebControl.)
 | ControlStyleCreated | (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | (Inherited from WebControl.)
 | CreateChildControls()()()() | (Inherited from Control.)
 | CreateControlCollection()()()() | (Inherited from Control.)
 | CreateControlStyle()()()() | (Inherited from WebControl.)
 | CssClass | (Inherited from WebControl.)
 | DataBind()()()() | (Inherited from Control.)
 | DataBind(Boolean) | (Inherited from Control.)
 | DataBindChildren()()()() | (Inherited from Control.)
 | DataBinding | (Inherited from Control.)
 | DataItemContainer | (Inherited from Control.)
 | DataKeysContainer | (Inherited from Control.)
 | DesignMode | (Inherited from Control.)
 | Dispose()()()() | (Inherited from Control.)
 | Disposed | (Inherited from Control.)
 | Enabled | (Inherited from WebControl.)
 | EnableTheming | (Inherited from WebControl.)
 | EnableViewState | (Inherited from Control.)
 | EndRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | EnsureChildControls()()()() | (Inherited from Control.)
 | EnsureID()()()() | (Inherited from Control.)
 | Equals(Object) | (Inherited from Object.)
 | Events | (Inherited from Control.)
 | Finalize()()()() | (Inherited from Object.)
 | FindControl(String) | (Inherited from Control.)
 | FindControl(String, Int32) | (Inherited from Control.)
 | Focus()()()() | (Inherited from Control.)
 | Font | (Inherited from WebControl.)
 | ForeColor | (Inherited from WebControl.)
 | GetDesignModeState()()()() | (Inherited from Control.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetRouteUrl(Object) | (Inherited from Control.)
 | GetRouteUrl(String, Object) | (Inherited from Control.)
 | GetRouteUrl(RouteValueDictionary) | (Inherited from Control.)
 | GetRouteUrl(String, RouteValueDictionary) | (Inherited from Control.)
 | GetType()()()() | (Inherited from Object.)
 | GetUniqueIDRelativeTo(Control) | (Inherited from Control.)
 | HasAttributes | (Inherited from WebControl.)
 | HasChildViewState | (Inherited from Control.)
 | HasControls()()()() | (Inherited from Control.)
 | HasEvents()()()() | (Inherited from Control.)
 | Height | (Inherited from WebControl.)
 | ID | (Inherited from Control.)
 | IdSeparator | (Inherited from Control.)
 | IgnoredWords | Comma delimited list of words which were not searched for (stop-list).
 | IgnoredWordsMessage | User friendly, English message, reporting ignored words (stop-list).
 | Init | (Inherited from Control.)
 | IsChildControlStateCleared | (Inherited from Control.)
 | IsEnabled | (Inherited from WebControl.)
 | IsLiteralContent()()()() | (Inherited from Control.)
 | IsTrackingViewState | (Inherited from Control.)
 | IsViewStateEnabled | (Inherited from Control.)
 | Load | (Inherited from Control.)
 | LoadControlState(Object) | (Inherited from Control.)
 | LoadViewState(Object) | (Inherited from WebControl.)
 | LoadViewStateByID | (Inherited from Control.)
 | MapPathSecure(String) | (Inherited from Control.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle(Style) | (Inherited from WebControl.)
 | NamingContainer | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | (Inherited from Control.)
 | OnDataBinding(EventArgs) | (Inherited from Control.)
 | OnInit(EventArgs) | (Inherited from Control.)
 | OnLoad(EventArgs) | (Inherited from Control.)
 | OnPreRender(EventArgs) | (Inherited from Control.)
 | OnUnload(EventArgs) | (Inherited from Control.)
 | OpenFile(String) | (Inherited from Control.)
 | Page | (Inherited from Control.)
 | Parent | (Inherited from Control.)
 | PreRender | (Inherited from Control.)
 | QueryExpression | The search query used.
 | RaiseBubbleEvent(Object, EventArgs) | (Inherited from Control.)
 | RemovedControl(Control) | (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | See base (Overrides WebControl.RenderBeginTag(HtmlTextWriter).)
 | RenderChildren(HtmlTextWriter) | (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | See base (Overrides WebControl.RenderEndTag(HtmlTextWriter).)
 | RenderingCompatibility | (Inherited from Control.)
 | ResolveAdapter()()()() | (Inherited from Control.)
 | ResolveClientUrl(String) | (Inherited from Control.)
 | ResolveUrl(String) | (Inherited from Control.)
 | SaveControlState()()()() | (Inherited from Control.)
 | SaveViewState()()()() | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | (Inherited from Control.)
 | SetTraceData(Object, Object) | (Inherited from Control.)
 | SetTraceData(Object, Object, Object) | (Inherited from Control.)
 | Site | (Inherited from Control.)
 | SkinID | (Inherited from WebControl.)
 | Style | (Inherited from WebControl.)
 | SupportsDisabledAttribute | (Inherited from WebControl.)
 | TabIndex | (Inherited from WebControl.)
 | TagKey | (Inherited from WebControl.)
 | TagName | (Inherited from WebControl.)
 | TemplateControl | (Inherited from Control.)
 | TemplateSourceDirectory | (Inherited from Control.)
 | ToolTip | (Inherited from WebControl.)
 | ToString()()()() | (Inherited from Object.)
 | TrackViewState()()()() | (Inherited from WebControl.)
 | UniqueID | (Inherited from Control.)
 | Unload | (Inherited from Control.)
 | ValidateRequestMode | (Inherited from Control.)
 | ViewState | (Inherited from Control.)
 | ViewStateIgnoresCase | (Inherited from Control.)
 | ViewStateMode | (Inherited from Control.)
 | Visible | (Inherited from Control.)
 | Width | (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | NoResults

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


NoResults Constructor (query, ignoredWords)

NoResults Constructor (query, ignoredWords)
API Documentation ► Keyoti.SearchEngine.Web ► NoResults ► NoResults(String, String)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public NoResults(
    string query,
    string ignoredWords
)
Public Sub New (
    query As String,
    ignoredWords As String
)
Parameters
query (String)
ignoredWords (String)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


IgnoredWords Property

IgnoredWords Property
API Documentation ► Keyoti.SearchEngine.Web ► NoResults ► IgnoredWords
Keyoti SearchUnit v6
Comma delimited list of words which were not searched for (stop-list).
Declaration Syntax
C# Visual Basic
public string IgnoredWords { get; }
Public ReadOnly Property IgnoredWords As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


IgnoredWordsMessage Property

IgnoredWordsMessage Property
API Documentation ► Keyoti.SearchEngine.Web ► NoResults ► IgnoredWordsMessage
Keyoti SearchUnit v6
User friendly, English message, reporting ignored words (stop-list).
Declaration Syntax
C# Visual Basic
public string IgnoredWordsMessage { get; }
Public ReadOnly Property IgnoredWordsMessage As String
    Get
Property Value
String
Remarks
For other languages, please construct a user friendly message in the template using the IgnoredWords property.

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


QueryExpression Property

QueryExpression Property
API Documentation ► Keyoti.SearchEngine.Web ► NoResults ► QueryExpression
Keyoti SearchUnit v6
The search query used.
Declaration Syntax
C# Visual Basic
public string QueryExpression { get; }
Public ReadOnly Property QueryExpression As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


RenderBeginTag Method (writer)

RenderBeginTag Method (writer)
API Documentation ► Keyoti.SearchEngine.Web ► NoResults ► RenderBeginTag(HtmlTextWriter)
Keyoti SearchUnit v6
See base
Declaration Syntax
C# Visual Basic
public override void RenderBeginTag(
    HtmlTextWriter writer
)
Public Overrides Sub RenderBeginTag (
    writer As HtmlTextWriter
)
Parameters
writer (HtmlTextWriter)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


RenderEndTag Method (writer)

RenderEndTag Method (writer)
API Documentation ► Keyoti.SearchEngine.Web ► NoResults ► RenderEndTag(HtmlTextWriter)
Keyoti SearchUnit v6
See base
Declaration Syntax
C# Visual Basic
public override void RenderEndTag(
    HtmlTextWriter writer
)
Public Overrides Sub RenderEndTag (
    writer As HtmlTextWriter
)
Parameters
writer (HtmlTextWriter)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


PopularAutoCompleteRegister Class

PopularAutoCompleteRegister Class
API Documentation ► Keyoti.SearchEngine.Web ► PopularAutoCompleteRegister
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public class PopularAutoCompleteRegister
Public Class PopularAutoCompleteRegister
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PopularAutoCompleteRegister(ICache, String) |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetMostPopularSearches(Int32) |
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | RegisterSearch(String, String, ICache, String, array<String>[]()[][]) | Register a user search, so that it can be tallied and considered by the popular search query autocompleter.
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
PopularAutoCompleteRegister

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


PopularAutoCompleteRegister Constructor (cache, indexDirectory)

PopularAutoCompleteRegister Constructor (cache, indexDirectory)
API Documentation ► Keyoti.SearchEngine.Web ► PopularAutoCompleteRegister ► PopularAutoCompleteRegister(ICache, String)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public PopularAutoCompleteRegister(
    ICache cache,
    string indexDirectory
)
Public Sub New (
    cache As ICache,
    indexDirectory As String
)
Parameters
cache (ICache)
indexDirectory (String)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


GetMostPopularSearches Method (numberOfQueriesToGet)

GetMostPopularSearches Method (numberOfQueriesToGet)
API Documentation ► Keyoti.SearchEngine.Web ► PopularAutoCompleteRegister ► GetMostPopularSearches(Int32)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public List<AutoCompletePopularSearchHelper..::..QueryTally> GetMostPopularSearches(
    int numberOfQueriesToGet
)
Public Function GetMostPopularSearches (
    numberOfQueriesToGet As Integer
) As List(Of AutoCompletePopularSearchHelper..::..QueryTally)
Parameters
numberOfQueriesToGet (Int32)
Return Value
List <(Of <(<' AutoCompletePopularSearchHelper..::..QueryTally >)>)>

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


RegisterSearch Method (query, indexDirectory, cache, appPath, synchIPs)

RegisterSearch Method (query, indexDirectory, cache, appPath, synchIPs)
API Documentation ► Keyoti.SearchEngine.Web ► PopularAutoCompleteRegister ► RegisterSearch(String, String, ICache, String, array<String>[]()[][])
Keyoti SearchUnit v6
Register a user search, so that it can be tallied and considered by the popular search query autocompleter.
Declaration Syntax
C# Visual Basic
public static void RegisterSearch(
    string query,
    string indexDirectory,
    ICache cache,
    string appPath,
    string[] synchIPs
)
Public Shared Sub RegisterSearch (
    query As String,
    indexDirectory As String,
    cache As ICache,
    appPath As String,
    synchIPs As String()
)
Parameters
query (String)
The search query
indexDirectory (String)
The index directory (absolute file path - NOT a virtual path like "~/Index") that was searched.
cache (ICache)
appPath (String)
synchIPs (array< String >[]()[][])

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ResultItem Class

ResultItem Class
API Documentation ► Keyoti.SearchEngine.Web ► ResultItem
Keyoti SearchUnit v6
A result item, shown between the header and footer.
Declaration Syntax
C# Visual Basic
public class ResultItem : WebControl, INamingContainer
Public Class ResultItem
    Inherits WebControl
    Implements INamingContainer
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ResultItem()()()() |
 | AccessKey | (Inherited from WebControl.)
 | Adapter | (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | (Inherited from Control.)
 | AddParsedSubObject(Object) | (Inherited from Control.)
 | ApplyStyle(Style) | (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | (Inherited from Control.)
 | Attributes | (Inherited from WebControl.)
 | BackColor | (Inherited from WebControl.)
 | BeginRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | BindingContainer | (Inherited from Control.)
 | BorderColor | (Inherited from WebControl.)
 | BorderStyle | (Inherited from WebControl.)
 | BorderWidth | (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | (Inherited from Control.)
 | ChildControlsCreated | (Inherited from Control.)
 | ClearCachedClientID()()()() | (Inherited from Control.)
 | ClearChildControlState()()()() | (Inherited from Control.)
 | ClearChildState()()()() | (Inherited from Control.)
 | ClearChildViewState()()()() | (Inherited from Control.)
 | ClearEffectiveClientIDMode()()()() | (Inherited from Control.)
 | ClientID | (Inherited from Control.)
 | ClientIDMode | (Inherited from Control.)
 | ClientIDSeparator | (Inherited from Control.)
 | Content | Content specified for search
 | Context | (Inherited from Control.)
 | Controls | (Inherited from Control.)
 | ControlStyle | (Inherited from WebControl.)
 | ControlStyleCreated | (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | (Inherited from WebControl.)
 | CreateChildControls()()()() | (Inherited from Control.)
 | CreateControlCollection()()()() | (Inherited from Control.)
 | CreateControlStyle()()()() | (Inherited from WebControl.)
 | CssClass | (Inherited from WebControl.)
 | CustomData | The custom data
 | DataBind()()()() | (Inherited from Control.)
 | DataBind(Boolean) | (Inherited from Control.)
 | DataBindChildren()()()() | (Inherited from Control.)
 | DataBinding | (Inherited from Control.)
 | DataItemContainer | (Inherited from Control.)
 | DataKeysContainer | (Inherited from Control.)
 | DesignMode | (Inherited from Control.)
 | Dispose()()()() | (Inherited from Control.)
 | Disposed | (Inherited from Control.)
 | Enabled | (Inherited from WebControl.)
 | EnableTheming | (Inherited from WebControl.)
 | EnableViewState | (Inherited from Control.)
 | EndRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | EnsureChildControls()()()() | (Inherited from Control.)
 | EnsureID()()()() | (Inherited from Control.)
 | Equals(Object) | (Inherited from Object.)
 | Events | (Inherited from Control.)
 | Finalize()()()() | (Inherited from Object.)
 | FindControl(String) | (Inherited from Control.)
 | FindControl(String, Int32) | (Inherited from Control.)
 | Focus()()()() | (Inherited from Control.)
 | Font | (Inherited from WebControl.)
 | ForeColor | (Inherited from WebControl.)
 | GetDesignModeState()()()() | (Inherited from Control.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetRouteUrl(Object) | (Inherited from Control.)
 | GetRouteUrl(String, Object) | (Inherited from Control.)
 | GetRouteUrl(RouteValueDictionary) | (Inherited from Control.)
 | GetRouteUrl(String, RouteValueDictionary) | (Inherited from Control.)
 | GetType()()()() | (Inherited from Object.)
 | GetUniqueIDRelativeTo(Control) | (Inherited from Control.)
 | HasAttributes | (Inherited from WebControl.)
 | HasChildViewState | (Inherited from Control.)
 | HasControls()()()() | (Inherited from Control.)
 | HasEvents()()()() | (Inherited from Control.)
 | Height | (Inherited from WebControl.)
 | HighlightQueryWordsInSummary(ArrayList, String) | Highlights 'words' in Summary
 | ID | (Inherited from Control.)
 | IdSeparator | (Inherited from Control.)
 | Init | (Inherited from Control.)
 | IsChildControlStateCleared | (Inherited from Control.)
 | IsEnabled | (Inherited from WebControl.)
 | IsLiteralContent()()()() | (Inherited from Control.)
 | IsTrackingViewState | (Inherited from Control.)
 | IsViewStateEnabled | (Inherited from Control.)
 | KeywordHitMap | Map of keywords and number of hits within this document of each keyword.
 | Load | (Inherited from Control.)
 | LoadControlState(Object) | (Inherited from Control.)
 | LoadViewState(Object) | (Inherited from WebControl.)
 | LoadViewStateByID | (Inherited from Control.)
 | Location | Location specified for search
 | MapPathSecure(String) | (Inherited from Control.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle(Style) | (Inherited from WebControl.)
 | NamingContainer | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | (Inherited from Control.)
 | OnDataBinding(EventArgs) | (Inherited from Control.)
 | OnInit(EventArgs) | (Inherited from Control.)
 | OnLoad(EventArgs) | (Inherited from Control.)
 | OnPreRender(EventArgs) | (Inherited from Control.)
 | OnUnload(EventArgs) | (Inherited from Control.)
 | OpenFile(String) | (Inherited from Control.)
 | Page | (Inherited from Control.)
 | Parent | (Inherited from Control.)
 | PreRender | (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | (Inherited from Control.)
 | RemovedControl(Control) | (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | See base (Overrides WebControl.RenderBeginTag(HtmlTextWriter).)
 | RenderChildren(HtmlTextWriter) | (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | See base (Overrides WebControl.RenderEndTag(HtmlTextWriter).)
 | RenderingCompatibility | (Inherited from Control.)
 | ResolveAdapter()()()() | (Inherited from Control.)
 | ResolveClientUrl(String) | (Inherited from Control.)
 | ResolveUrl(String) | (Inherited from Control.)
 | ResultPreview_Expander_ClosedUrl |
 | ResultPreview_Expander_OpenedUrl |
 | SaveControlState()()()() | (Inherited from Control.)
 | SaveViewState()()()() | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | (Inherited from Control.)
 | SetTraceData(Object, Object) | (Inherited from Control.)
 | SetTraceData(Object, Object, Object) | (Inherited from Control.)
 | Site | (Inherited from Control.)
 | SkinID | (Inherited from WebControl.)
 | Style | (Inherited from WebControl.)
 | Summary | The result summary
 | SupportsDisabledAttribute | (Inherited from WebControl.)
 | TabIndex | (Inherited from WebControl.)
 | TagKey | (Inherited from WebControl.)
 | TagName | (Inherited from WebControl.)
 | TemplateControl | (Inherited from Control.)
 | TemplateSourceDirectory | (Inherited from Control.)
 | Title | The result title
 | ToolTip | (Inherited from WebControl.)
 | ToString()()()() | (Inherited from Object.)
 | TrackViewState()()()() | (Inherited from WebControl.)
 | UniqueID | (Inherited from Control.)
 | Unload | (Inherited from Control.)
 | Uri | The URI of the result document
 | UriAsStored | The URI of the result document as it appears in the document index
 | ValidateRequestMode | (Inherited from Control.)
 | ViewState | (Inherited from Control.)
 | ViewStateIgnoresCase | (Inherited from Control.)
 | ViewStateMode | (Inherited from Control.)
 | Visible | (Inherited from Control.)
 | Width | (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | ResultItem

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ResultItem Constructor

ResultItem Constructor
API Documentation ► Keyoti.SearchEngine.Web ► ResultItem ► ResultItem()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public ResultItem()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Content Property

Content Property
API Documentation ► Keyoti.SearchEngine.Web ► ResultItem ► Content
Keyoti SearchUnit v6
Content specified for search
Declaration Syntax
C# Visual Basic
public virtual string Content { get; set; }
Public Overridable Property Content As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


CustomData Property

CustomData Property
API Documentation ► Keyoti.SearchEngine.Web ► ResultItem ► CustomData
Keyoti SearchUnit v6
The custom data
Declaration Syntax
C# Visual Basic
public virtual string CustomData { get; set; }
Public Overridable Property CustomData As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


HighlightQueryWordsInSummary Method (elements, highlightQueryWordsInSummaryHTML)

HighlightQueryWordsInSummary Method (elements, highlightQueryWordsInSummaryHTML)
API Documentation ► Keyoti.SearchEngine.Web ► ResultItem ► HighlightQueryWordsInSummary(ArrayList, String)
Keyoti SearchUnit v6
Highlights 'words' in Summary
Declaration Syntax
C# Visual Basic
public virtual IntArraysList HighlightQueryWordsInSummary(
    ArrayList elements,
    string highlightQueryWordsInSummaryHTML
)
Public Overridable Function HighlightQueryWordsInSummary (
    elements As ArrayList,
    highlightQueryWordsInSummaryHTML As String
) As IntArraysList
Parameters
elements (ArrayList)
ArrayList of Element objects, some elements can be null.
highlightQueryWordsInSummaryHTML (String)
The HTML used to highlight (must contain {0} formatting)
Return Value
IntArraysList
List of character positions (in the new summary) that were inserted by this method.

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


KeywordHitMap Property

KeywordHitMap Property
API Documentation ► Keyoti.SearchEngine.Web ► ResultItem ► KeywordHitMap
Keyoti SearchUnit v6
Map of keywords and number of hits within this document of each keyword.
Declaration Syntax
C# Visual Basic
public virtual KeywordHitMapDictionary KeywordHitMap { get; }
Public Overridable ReadOnly Property KeywordHitMap As KeywordHitMapDictionary
    Get
Property Value
KeywordHitMapDictionary

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Location Property

Location Property
API Documentation ► Keyoti.SearchEngine.Web ► ResultItem ► Location
Keyoti SearchUnit v6
Location specified for search
Declaration Syntax
C# Visual Basic
public virtual string Location { get; set; }
Public Overridable Property Location As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


RenderBeginTag Method (writer)

RenderBeginTag Method (writer)
API Documentation ► Keyoti.SearchEngine.Web ► ResultItem ► RenderBeginTag(HtmlTextWriter)
Keyoti SearchUnit v6
See base
Declaration Syntax
C# Visual Basic
public override void RenderBeginTag(
    HtmlTextWriter writer
)
Public Overrides Sub RenderBeginTag (
    writer As HtmlTextWriter
)
Parameters
writer (HtmlTextWriter)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


RenderEndTag Method (writer)

RenderEndTag Method (writer)
API Documentation ► Keyoti.SearchEngine.Web ► ResultItem ► RenderEndTag(HtmlTextWriter)
Keyoti SearchUnit v6
See base
Declaration Syntax
C# Visual Basic
public override void RenderEndTag(
    HtmlTextWriter writer
)
Public Overrides Sub RenderEndTag (
    writer As HtmlTextWriter
)
Parameters
writer (HtmlTextWriter)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ResultPreview_Expander_ClosedUrl Property

ResultPreview_Expander_ClosedUrl Property
API Documentation ► Keyoti.SearchEngine.Web ► ResultItem ► ResultPreview_Expander_ClosedUrl
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public virtual string ResultPreview_Expander_ClosedUrl { get; }
Public Overridable ReadOnly Property ResultPreview_Expander_ClosedUrl As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ResultPreview_Expander_OpenedUrl Property

ResultPreview_Expander_OpenedUrl Property
API Documentation ► Keyoti.SearchEngine.Web ► ResultItem ► ResultPreview_Expander_OpenedUrl
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public virtual string ResultPreview_Expander_OpenedUrl { get; }
Public Overridable ReadOnly Property ResultPreview_Expander_OpenedUrl As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Summary Property

Summary Property
API Documentation ► Keyoti.SearchEngine.Web ► ResultItem ► Summary
Keyoti SearchUnit v6
The result summary
Declaration Syntax
C# Visual Basic
public virtual string Summary { get; set; }
Public Overridable Property Summary As String
    Get
    Set
Property Value
String
Remarks
When phrase matching is enabled, this summary is an extract of the document that includes the search words, otherwise it is text from the beginning of the document.

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Title Property

Title Property
API Documentation ► Keyoti.SearchEngine.Web ► ResultItem ► Title
Keyoti SearchUnit v6
The result title
Declaration Syntax
C# Visual Basic
public virtual string Title { get; set; }
Public Overridable Property Title As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Uri Property

Uri Property
API Documentation ► Keyoti.SearchEngine.Web ► ResultItem ► Uri
Keyoti SearchUnit v6
The URI of the result document
Declaration Syntax
C# Visual Basic
public virtual string Uri { get; set; }
Public Overridable Property Uri As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


UriAsStored Property

UriAsStored Property
API Documentation ► Keyoti.SearchEngine.Web ► ResultItem ► UriAsStored
Keyoti SearchUnit v6
The URI of the result document as it appears in the document index
Declaration Syntax
C# Visual Basic
public virtual string UriAsStored { get; set; }
Public Overridable Property UriAsStored As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ResultsPageClickEventArgs Class

ResultsPageClickEventArgs Class
API Documentation ► Keyoti.SearchEngine.Web ► ResultsPageClickEventArgs
Keyoti SearchUnit v6
The event arguments for a results page link click.
Declaration Syntax
C# Visual Basic
public class ResultsPageClickEventArgs : EventArgs
Public Class ResultsPageClickEventArgs
    Inherits EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ResultsPageClickEventArgs(Int32) | Creates a new instance
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PageNo | The page number requested in the link.
 | ToString()()()() | (Inherited from Object.)
Remarks
This is related to the links bar containing links to page numbers.
Inheritance Hierarchy
Object
 | EventArgs
 |  | ResultsPageClickEventArgs

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ResultsPageClickEventArgs Constructor (pageNo)

ResultsPageClickEventArgs Constructor (pageNo)
API Documentation ► Keyoti.SearchEngine.Web ► ResultsPageClickEventArgs ► ResultsPageClickEventArgs(Int32)
Keyoti SearchUnit v6
Creates a new instance
Declaration Syntax
C# Visual Basic
public ResultsPageClickEventArgs(
    int pageNo
)
Public Sub New (
    pageNo As Integer
)
Parameters
pageNo (Int32)
The page number requested in the link.

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


PageNo Property

PageNo Property
API Documentation ► Keyoti.SearchEngine.Web ► ResultsPageClickEventArgs ► PageNo
Keyoti SearchUnit v6
The page number requested in the link.
Declaration Syntax
C# Visual Basic
public virtual int PageNo { get; }
Public Overridable ReadOnly Property PageNo As Integer
    Get
Property Value
Int32

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SearchBox Class

SearchBox Class
API Documentation ► Keyoti.SearchEngine.Web ► SearchBox
Keyoti SearchUnit v6
Web control giving the user a texbox to enter a search query, and submit button to run the search.
Declaration Syntax
C# Visual Basic
public class SearchBox : WebControl, IPostBackEventHandler,
    INamingContainer
Public Class SearchBox
    Inherits WebControl
    Implements IPostBackEventHandler, INamingContainer
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SearchBox()()()() | Creates a new instance.
 | AccessKey | (Inherited from WebControl.)
 | Adapter | (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | (Inherited from Control.)
 | AddParsedSubObject(Object) | (Inherited from Control.)
 | ApplyStyle(Style) | (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | (Inherited from Control.)
 | Attributes | (Inherited from WebControl.)
 | AutoCompleteQuery | Whether to provide auto-complete suggestions to the user as they type in the query text box (see remarks).
 | AutoCompleteQueryFailSilent | Whether to show warning messages about errors - advised to set to false for development.
 | AutoCompleteQueryHideNoResultSuggestions | Whether to hide suggestions that would yield no results - this puts more load on the server as it requires additional work.
 | AutoCompleteQueryIndexDirectory | The index directory to be used to find auto-complete suggestions.
 | AutoCompleteQueryLoadPlugin | Whether to load any plugin assembly from the configuration.
 | AutoCompleteQueryMaxSuggestions | The maximum number of auto complete suggestions to make.
 | AutoCompleteQueryRunSearchOnSelect | Whether to automatically run the search when the user selects an auto-complete item from the list.
 | AutoCompleteQueryShowNumberOfResults | Whether to list the predicated number of results for each auto-complete suggestion - adds server load when true.
 | AutoCompleteQuerySuggestionSource | The source of data for auto-complete suggestions.
 | BackColor | (Inherited from WebControl.)
 | BeginRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | BindingContainer | (Inherited from Control.)
 | BorderColor | (Inherited from WebControl.)
 | BorderStyle | (Inherited from WebControl.)
 | BorderWidth | (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | (Inherited from Control.)
 | ChildControlsCreated | (Inherited from Control.)
 | ClearCachedClientID()()()() | (Inherited from Control.)
 | ClearChildControlState()()()() | (Inherited from Control.)
 | ClearChildState()()()() | (Inherited from Control.)
 | ClearChildViewState()()()() | (Inherited from Control.)
 | ClearEffectiveClientIDMode()()()() | (Inherited from Control.)
 | ClientFilesLocation | Whether to use the internal client files, or external files (for customization).
 | ClientID | (Inherited from Control.)
 | ClientIDMode | (Inherited from Control.)
 | ClientIDSeparator | (Inherited from Control.)
 | Context | (Inherited from Control.)
 | Controls | (Inherited from Control.)
 | ControlStyle | (Inherited from WebControl.)
 | ControlStyleCreated | (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | (Inherited from WebControl.)
 | CreateChildControls()()()() | Creates and adds child controls. (Overrides Control.CreateChildControls()()()().)
 | CreateControlCollection()()()() | (Inherited from Control.)
 | CreateControlStyle()()()() | (Inherited from WebControl.)
 | CssClass | (Inherited from WebControl.)
 | DataBind()()()() | (Inherited from Control.)
 | DataBind(Boolean) | (Inherited from Control.)
 | DataBindChildren()()()() | (Inherited from Control.)
 | DataBinding | (Inherited from Control.)
 | DataItemContainer | (Inherited from Control.)
 | DataKeysContainer | (Inherited from Control.)
 | DesignMode | (Inherited from Control.)
 | Dispose()()()() | (Inherited from Control.)
 | Disposed | (Inherited from Control.)
 | Enabled | (Inherited from WebControl.)
 | EnableTheming | (Inherited from WebControl.)
 | EnableViewState | (Inherited from Control.)
 | EndRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | EnsureChildControls()()()() | (Inherited from Control.)
 | EnsureID()()()() | (Inherited from Control.)
 | EnterSubmitsSearch | Whether to submit the search when the user presses enter and focus is in the search text box (default=true).
 | Equals(Object) | (Inherited from Object.)
 | Events | (Inherited from Control.)
 | Finalize()()()() | (Inherited from Object.)
 | FindControl(String) | (Inherited from Control.)
 | FindControl(String, Int32) | (Inherited from Control.)
 | Focus()()()() | (Inherited from Control.)
 | Font | (Overrides WebControl.Font.)
 | ForeColor | (Overrides WebControl.ForeColor.)
 | GetDesignModeState()()()() | (Inherited from Control.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetRouteUrl(Object) | (Inherited from Control.)
 | GetRouteUrl(String, Object) | (Inherited from Control.)
 | GetRouteUrl(RouteValueDictionary) | (Inherited from Control.)
 | GetRouteUrl(String, RouteValueDictionary) | (Inherited from Control.)
 | GetType()()()() | (Inherited from Object.)
 | GetUniqueIDRelativeTo(Control) | (Inherited from Control.)
 | HasAttributes | (Inherited from WebControl.)
 | HasChildViewState | (Inherited from Control.)
 | HasControls()()()() | (Inherited from Control.)
 | HasEvents()()()() | (Inherited from Control.)
 | Height | (Inherited from WebControl.)
 | ID | (Inherited from Control.)
 | IdSeparator | (Inherited from Control.)
 | Init | (Inherited from Control.)
 | IsChildControlStateCleared | (Inherited from Control.)
 | IsEnabled | (Inherited from WebControl.)
 | IsLiteralContent()()()() | (Inherited from Control.)
 | IsTrackingViewState | (Inherited from Control.)
 | IsViewStateEnabled | (Inherited from Control.)
 | Load | (Inherited from Control.)
 | LoadControlState(Object) | (Inherited from Control.)
 | LoadViewState(Object) | (Inherited from WebControl.)
 | LoadViewStateByID | (Inherited from Control.)
 | MapPathSecure(String) | (Inherited from Control.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle(Style) | (Inherited from WebControl.)
 | NamingContainer | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | (Inherited from Control.)
 | OnDataBinding(EventArgs) | (Inherited from Control.)
 | OnInit(EventArgs) | (Inherited from Control.)
 | OnLoad(EventArgs) | (Inherited from Control.)
 | OnPreRender(EventArgs) | Called at the PreRender stage. (Overrides Control.OnPreRender(EventArgs).)
 | OnSearch(EventArgs) | Called after the Search button is pressed.
 | OnUnload(EventArgs) | (Inherited from Control.)
 | OpenFile(String) | (Inherited from Control.)
 | Page | (Inherited from Control.)
 | Parent | (Inherited from Control.)
 | PreRender | (Inherited from Control.)
 | QueryTextBox | The query text box.
 | RaiseBubbleEvent(Object, EventArgs) | (Inherited from Control.)
 | RaisePostBackEvent(String) | Called on postbacks related to this control
 | RedirectToSearchResults()()()() | Forces a redirect to 'ResultPageURL' with the query entered in the query text box.
 | RegisterSearch(String, String, ICache, String, array<String>[]()[][]) | Register a user search, so that it can be tallied and considered by the popular search query autocompleter.
 | RememberQuery | Whether to remember the user's query and reshow it next time the control renders (default=true).
 | RemovedControl(Control) | (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Render this control to the output parameter specified. (Overrides WebControl.RenderContents(HtmlTextWriter).)
 | RenderControl(HtmlTextWriter) | (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingCompatibility | (Inherited from Control.)
 | ResolveAdapter()()()() | (Inherited from Control.)
 | ResolveClientUrl(String) | (Inherited from Control.)
 | ResolveUrl(String) | (Inherited from Control.)
 | ResultPageURL | The URL of the page holding the SearchResult control.
 | SaveControlState()()()() | (Inherited from Control.)
 | SaveViewState()()()() | (Inherited from WebControl.)
 | Search | Fired when Search button is pressed.
 | SearchButton | The button that starts the search.
 | SearchOptions |
 | ServerFarmSynchronizationIPs | Comma delimited list of IP addresses (or server names) of other servers that need to be synchronized with popular query based autocomplete.
 | SetDesignModeState(IDictionary) | (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | (Inherited from Control.)
 | SetTraceData(Object, Object) | (Inherited from Control.)
 | SetTraceData(Object, Object, Object) | (Inherited from Control.)
 | Site | (Inherited from Control.)
 | SkinID | (Inherited from WebControl.)
 | Style | (Inherited from WebControl.)
 | SupportsDisabledAttribute | (Inherited from WebControl.)
 | TabIndex | (Inherited from WebControl.)
 | TagKey | (Inherited from WebControl.)
 | TagName | (Inherited from WebControl.)
 | TemplateControl | (Inherited from Control.)
 | TemplateSourceDirectory | (Inherited from Control.)
 | Text | The text to show in the textbox when it renders - is overridden by RememberQuery.
 | ToolTip | (Inherited from WebControl.)
 | ToString()()()() | (Inherited from Object.)
 | TrackViewState()()()() | (Inherited from WebControl.)
 | UniqueID | (Inherited from Control.)
 | Unload | (Inherited from Control.)
 | ValidateRequestMode | (Inherited from Control.)
 | ViewState | (Inherited from Control.)
 | ViewStateIgnoresCase | (Inherited from Control.)
 | ViewStateMode | (Inherited from Control.)
 | Visible | (Inherited from Control.)
 | WatermarkColor | Watermark color.
 | WatermarkText | Text to use as the watermark.
 | WatermarkVisible | Whether to show a 'Search' watermark in the textbox.
 | Width | (Inherited from WebControl.)
Remarks
This control is used to launch the search, which it does by redirecting the request to the page containing the SearchResult control.
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | SearchBox

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SearchBox Constructor

SearchBox Constructor
API Documentation ► Keyoti.SearchEngine.Web ► SearchBox ► SearchBox()()()()
Keyoti SearchUnit v6
Creates a new instance.
Declaration Syntax
C# Visual Basic
public SearchBox()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


AutoCompleteQuery Property

AutoCompleteQuery Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchBox ► AutoCompleteQuery
Keyoti SearchUnit v6
Whether to provide auto-complete suggestions to the user as they type in the query text box (see remarks).
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public virtual bool AutoCompleteQuery { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overridable Property AutoCompleteQuery As Boolean
    Get
    Set
Property Value
Boolean
Remarks
This feature requires; i) The web.config file must be edited to add the following HttpHandler
Copy image Copy
<httpHandlers>
        <add verb="*" path="Keyoti.SearchEngine.Web.CallBackHandler.aspx" type="Keyoti.SearchEngine.Web.CallBackHandler,Keyoti.SearchEngine.Web.ASP.NETv2"/>
        </httpHandlers>
ii) The AutoCompleteQueryIndexDirectory property must be set to the index directory that the search will be performed on, or the Keyoti-SearchEngine-IndexDirectory web.config appSetting must be set.

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


AutoCompleteQueryFailSilent Property

AutoCompleteQueryFailSilent Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchBox ► AutoCompleteQueryFailSilent
Keyoti SearchUnit v6
Whether to show warning messages about errors - advised to set to false for development.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public virtual bool AutoCompleteQueryFailSilent { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overridable Property AutoCompleteQueryFailSilent As Boolean
    Get
    Set
Property Value
Boolean

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


AutoCompleteQueryHideNoResultSuggestions Property

AutoCompleteQueryHideNoResultSuggestions Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchBox ► AutoCompleteQueryHideNoResultSuggestions
Keyoti SearchUnit v6
Whether to hide suggestions that would yield no results - this puts more load on the server as it requires additional work.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public virtual bool AutoCompleteQueryHideNoResultSuggestions { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overridable Property AutoCompleteQueryHideNoResultSuggestions As Boolean
    Get
    Set
Property Value
Boolean

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


AutoCompleteQueryIndexDirectory Property

AutoCompleteQueryIndexDirectory Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchBox ► AutoCompleteQueryIndexDirectory
Keyoti SearchUnit v6
The index directory to be used to find auto-complete suggestions.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public virtual string AutoCompleteQueryIndexDirectory { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overridable Property AutoCompleteQueryIndexDirectory As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


AutoCompleteQueryLoadPlugin Property

AutoCompleteQueryLoadPlugin Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchBox ► AutoCompleteQueryLoadPlugin
Keyoti SearchUnit v6
Whether to load any plugin assembly from the configuration.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public virtual bool AutoCompleteQueryLoadPlugin { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overridable Property AutoCompleteQueryLoadPlugin As Boolean
    Get
    Set
Property Value
Boolean

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


AutoCompleteQueryMaxSuggestions Property

AutoCompleteQueryMaxSuggestions Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchBox ► AutoCompleteQueryMaxSuggestions
Keyoti SearchUnit v6
The maximum number of auto complete suggestions to make.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public virtual int AutoCompleteQueryMaxSuggestions { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overridable Property AutoCompleteQueryMaxSuggestions As Integer
    Get
    Set
Property Value
Int32

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


AutoCompleteQueryRunSearchOnSelect Property

AutoCompleteQueryRunSearchOnSelect Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchBox ► AutoCompleteQueryRunSearchOnSelect
Keyoti SearchUnit v6
Whether to automatically run the search when the user selects an auto-complete item from the list.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public virtual bool AutoCompleteQueryRunSearchOnSelect { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overridable Property AutoCompleteQueryRunSearchOnSelect As Boolean
    Get
    Set
Property Value
Boolean

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


AutoCompleteQueryShowNumberOfResults Property

AutoCompleteQueryShowNumberOfResults Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchBox ► AutoCompleteQueryShowNumberOfResults
Keyoti SearchUnit v6
Whether to list the predicated number of results for each auto-complete suggestion - adds server load when true.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public virtual bool AutoCompleteQueryShowNumberOfResults { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overridable Property AutoCompleteQueryShowNumberOfResults As Boolean
    Get
    Set
Property Value
Boolean

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


AutoCompleteQuerySuggestionSource Property

AutoCompleteQuerySuggestionSource Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchBox ► AutoCompleteQuerySuggestionSource
Keyoti SearchUnit v6
The source of data for auto-complete suggestions.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public virtual SearchBox..::..AutoCompleteSuggestionSource AutoCompleteQuerySuggestionSource { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overridable Property AutoCompleteQuerySuggestionSource As SearchBox..::..AutoCompleteSuggestionSource
    Get
    Set
Property Value
SearchBox..::..AutoCompleteSuggestionSource

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ClientFilesLocation Property

ClientFilesLocation Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchBox ► ClientFilesLocation
Keyoti SearchUnit v6
Whether to use the internal client files, or external files (for customization).
Declaration Syntax
C# Visual Basic
public ClientFilesLocation ClientFilesLocation { get; set; }
Public Property ClientFilesLocation As ClientFilesLocation
    Get
    Set
Property Value
ClientFilesLocation
Remarks
Default = Internal

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


CreateChildControls Method

CreateChildControls Method
API Documentation ► Keyoti.SearchEngine.Web ► SearchBox ► CreateChildControls()()()()
Keyoti SearchUnit v6
Creates and adds child controls.
Declaration Syntax
C# Visual Basic
protected override void CreateChildControls()
Protected Overrides Sub CreateChildControls

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


EnterSubmitsSearch Property

EnterSubmitsSearch Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchBox ► EnterSubmitsSearch
Keyoti SearchUnit v6
Whether to submit the search when the user presses enter and focus is in the search text box (default=true).
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public virtual bool EnterSubmitsSearch { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overridable Property EnterSubmitsSearch As Boolean
    Get
    Set
Property Value
Boolean

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Font Property

Font Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchBox ► Font
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public override FontInfo Font { get; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overrides ReadOnly Property Font As FontInfo
    Get
Property Value
FontInfo

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ForeColor Property

ForeColor Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchBox ► ForeColor
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public override Color ForeColor { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overrides Property ForeColor As Color
    Get
    Set
Property Value
Color

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


OnPreRender Method (e)

OnPreRender Method (e)
API Documentation ► Keyoti.SearchEngine.Web ► SearchBox ► OnPreRender(EventArgs)
Keyoti SearchUnit v6
Called at the PreRender stage.
Declaration Syntax
C# Visual Basic
protected override void OnPreRender(
    EventArgs e
)
Protected Overrides Sub OnPreRender (
    e As EventArgs
)
Parameters
e (EventArgs)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


OnSearch Method (e)

OnSearch Method (e)
API Documentation ► Keyoti.SearchEngine.Web ► SearchBox ► OnSearch(EventArgs)
Keyoti SearchUnit v6
Called after the Search button is pressed.
Declaration Syntax
C# Visual Basic
protected virtual void OnSearch(
    EventArgs e
)
Protected Overridable Sub OnSearch (
    e As EventArgs
)
Parameters
e (EventArgs)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


QueryTextBox Property

QueryTextBox Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchBox ► QueryTextBox
Keyoti SearchUnit v6
The query text box.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public virtual KTextBox QueryTextBox { get; }
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public Overridable ReadOnly Property QueryTextBox As KTextBox
    Get
Property Value
KTextBox

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


RaisePostBackEvent Method (eventArgument)

RaisePostBackEvent Method (eventArgument)
API Documentation ► Keyoti.SearchEngine.Web ► SearchBox ► RaisePostBackEvent(String)
Keyoti SearchUnit v6
Called on postbacks related to this control
Declaration Syntax
C# Visual Basic
public virtual void RaisePostBackEvent(
    string eventArgument
)
Public Overridable Sub RaisePostBackEvent (
    eventArgument As String
)
Parameters
eventArgument (String)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


RedirectToSearchResults Method

RedirectToSearchResults Method
API Documentation ► Keyoti.SearchEngine.Web ► SearchBox ► RedirectToSearchResults()()()()
Keyoti SearchUnit v6
Forces a redirect to 'ResultPageURL' with the query entered in the query text box.
Declaration Syntax
C# Visual Basic
public virtual void RedirectToSearchResults()
Public Overridable Sub RedirectToSearchResults

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


RegisterSearch Method (query, indexDirectory, cache, appPath, synchIPs)

RegisterSearch Method (query, indexDirectory, cache, appPath, synchIPs)
API Documentation ► Keyoti.SearchEngine.Web ► SearchBox ► RegisterSearch(String, String, ICache, String, array<String>[]()[][])
Keyoti SearchUnit v6
Register a user search, so that it can be tallied and considered by the popular search query autocompleter.
Declaration Syntax
C# Visual Basic
public static void RegisterSearch(
    string query,
    string indexDirectory,
    ICache cache,
    string appPath,
    string[] synchIPs
)
Public Shared Sub RegisterSearch (
    query As String,
    indexDirectory As String,
    cache As ICache,
    appPath As String,
    synchIPs As String()
)
Parameters
query (String)
The search query
indexDirectory (String)
The index directory (absolute file path - NOT a virtual path like "~/Index") that was searched.
cache (ICache)
The application wide cache (Page.Cache)
appPath (String)
The virtual application path, eg. /myapp/, can be empty if app is the root of the domain (eg http://host/)
synchIPs (array< String >[]()[][])
Any IPs or server names that the popular autocomplete list should be synched up with (eg. other servers in a farm), or null/nothing.

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


RememberQuery Property

RememberQuery Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchBox ► RememberQuery
Keyoti SearchUnit v6
Whether to remember the user's query and reshow it next time the control renders (default=true).
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public virtual bool RememberQuery { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overridable Property RememberQuery As Boolean
    Get
    Set
Property Value
Boolean

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


RenderContents Method (output)

RenderContents Method (output)
API Documentation ► Keyoti.SearchEngine.Web ► SearchBox ► RenderContents(HtmlTextWriter)
Keyoti SearchUnit v6
Render this control to the output parameter specified.
Declaration Syntax
C# Visual Basic
protected override void RenderContents(
    HtmlTextWriter output
)
Protected Overrides Sub RenderContents (
    output As HtmlTextWriter
)
Parameters
output (HtmlTextWriter)
The HTML writer to write out to

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ResultPageURL Property

ResultPageURL Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchBox ► ResultPageURL
Keyoti SearchUnit v6
The URL of the page holding the SearchResult control.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public virtual string ResultPageURL { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overridable Property ResultPageURL As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Search Event

Search Event
API Documentation ► Keyoti.SearchEngine.Web ► SearchBox ► Search
Keyoti SearchUnit v6
Fired when Search button is pressed.
Declaration Syntax
C# Visual Basic
public event EventHandler Search
Public Event Search As EventHandler
Value
EventHandler

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SearchButton Property

SearchButton Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchBox ► SearchButton
Keyoti SearchUnit v6
The button that starts the search.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public virtual KButton SearchButton { get; }
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public Overridable ReadOnly Property SearchButton As KButton
    Get
Property Value
KButton

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SearchOptions Property

SearchOptions Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchBox ► SearchOptions
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public virtual SearchOptions SearchOptions { get; set; }
Public Overridable Property SearchOptions As SearchOptions
    Get
    Set
Property Value
SearchOptions

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ServerFarmSynchronizationIPs Property

ServerFarmSynchronizationIPs Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchBox ► ServerFarmSynchronizationIPs
Keyoti SearchUnit v6
Comma delimited list of IP addresses (or server names) of other servers that need to be synchronized with popular query based autocomplete.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string ServerFarmSynchronizationIPs { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ServerFarmSynchronizationIPs As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Text Property

Text Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchBox ► Text
Keyoti SearchUnit v6
The text to show in the textbox when it renders - is overridden by RememberQuery.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public virtual string Text { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overridable Property Text As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


WatermarkColor Property

WatermarkColor Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchBox ► WatermarkColor
Keyoti SearchUnit v6
Watermark color.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public virtual Color WatermarkColor { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overridable Property WatermarkColor As Color
    Get
    Set
Property Value
Color

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


WatermarkText Property

WatermarkText Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchBox ► WatermarkText
Keyoti SearchUnit v6
Text to use as the watermark.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public virtual string WatermarkText { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overridable Property WatermarkText As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


WatermarkVisible Property

WatermarkVisible Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchBox ► WatermarkVisible
Keyoti SearchUnit v6
Whether to show a 'Search' watermark in the textbox.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public virtual bool WatermarkVisible { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overridable Property WatermarkVisible As Boolean
    Get
    Set
Property Value
Boolean

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SearchBox.AutoCompleteSuggestionSource Enumeration

SearchBox..::..AutoCompleteSuggestionSource Enumeration
API Documentation ► Keyoti.SearchEngine.Web ► SearchBox ► SearchBox..::..AutoCompleteSuggestionSource
Keyoti SearchUnit v6
Identifies source of autocomplete suggestions.
Declaration Syntax
C# Visual Basic
public enum AutoCompleteSuggestionSource
Public Enumeration AutoCompleteSuggestionSource
Members
Member | Description
IndexLexicon | Get suggestions from the words contained in the index.
PopularSearches | Get suggestions from a list of popular searches.
PopularSearchesAndLexicon | Get suggestions from a list of popular searches and if need be (not enough suggestions) supplement with terms from the lexicon.

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SearchBoxAutoCompleteHelper Class

SearchBoxAutoCompleteHelper Class
API Documentation ► Keyoti.SearchEngine.Web ► SearchBoxAutoCompleteHelper
Keyoti SearchUnit v6
Handles auto complete AJAX requests
Declaration Syntax
C# Visual Basic
public class SearchBoxAutoCompleteHelper
Public Class SearchBoxAutoCompleteHelper
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SearchBoxAutoCompleteHelper()()()() | New
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSuggestions(String, String, Boolean, Byte, String, ICache, SearchBox..::..AutoCompleteSuggestionSource, Boolean) | Get's the suggestions
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ProcessRequest(HttpContext) | Processes the AJAX request
 | Query | The query entered by the user.
 | Segments | The words in the query.
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
SearchBoxAutoCompleteHelper

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SearchBoxAutoCompleteHelper Constructor

SearchBoxAutoCompleteHelper Constructor
API Documentation ► Keyoti.SearchEngine.Web ► SearchBoxAutoCompleteHelper ► SearchBoxAutoCompleteHelper()()()()
Keyoti SearchUnit v6
New
Declaration Syntax
C# Visual Basic
public SearchBoxAutoCompleteHelper()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


GetSuggestions Method (text, indexDir, calculateNumberOfResults, numberOfSuggestionQueriesToFind, plugin, cache, source, hideNoResulters)

GetSuggestions Method (text, indexDir, calculateNumberOfResults, numberOfSuggestionQueriesToFind, plugin, cache, source, hideNoResulters)
API Documentation ► Keyoti.SearchEngine.Web ► SearchBoxAutoCompleteHelper ► GetSuggestions(String, String, Boolean, Byte, String, ICache, SearchBox..::..AutoCompleteSuggestionSource, Boolean)
Keyoti SearchUnit v6
Get's the suggestions
Declaration Syntax
C# Visual Basic
public virtual ArrayList GetSuggestions(
    string text,
    string indexDir,
    bool calculateNumberOfResults,
    byte numberOfSuggestionQueriesToFind,
    string plugin,
    ICache cache,
    SearchBox..::..AutoCompleteSuggestionSource source,
    bool hideNoResulters
)
Public Overridable Function GetSuggestions (
    text As String,
    indexDir As String,
    calculateNumberOfResults As Boolean,
    numberOfSuggestionQueriesToFind As Byte,
    plugin As String,
    cache As ICache,
    source As SearchBox..::..AutoCompleteSuggestionSource,
    hideNoResulters As Boolean
) As ArrayList
Parameters
text (String)
indexDir (String)
calculateNumberOfResults (Boolean)
numberOfSuggestionQueriesToFind (Byte)
plugin (String)
cache (ICache)
source (SearchBox..::..AutoCompleteSuggestionSource)
hideNoResulters (Boolean)
Return Value
ArrayList

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ProcessRequest Method (ctx)

ProcessRequest Method (ctx)
API Documentation ► Keyoti.SearchEngine.Web ► SearchBoxAutoCompleteHelper ► ProcessRequest(HttpContext)
Keyoti SearchUnit v6
Processes the AJAX request
Declaration Syntax
C# Visual Basic
public void ProcessRequest(
    HttpContext ctx
)
Public Sub ProcessRequest (
    ctx As HttpContext
)
Parameters
ctx (HttpContext)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Query Property

Query Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchBoxAutoCompleteHelper ► Query
Keyoti SearchUnit v6
The query entered by the user.
Declaration Syntax
C# Visual Basic
public string Query { get; }
Public ReadOnly Property Query As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Segments Property

Segments Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchBoxAutoCompleteHelper ► Segments
Keyoti SearchUnit v6
The words in the query.
Declaration Syntax
C# Visual Basic
public string[] Segments { get; }
Public ReadOnly Property Segments As String()
    Get
Property Value
array< String >[]()[][]

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SearchBoxAutoCompleteHelper.SuggestionResultPair Class

SearchBoxAutoCompleteHelper..::..SuggestionResultPair Class
API Documentation ► Keyoti.SearchEngine.Web ► SearchBoxAutoCompleteHelper ► SearchBoxAutoCompleteHelper..::..SuggestionResultPair
Keyoti SearchUnit v6
An autocomplete suggestion - this includes the suggested search 'query' and (if requested) the approximate number of results for the query.
Declaration Syntax
C# Visual Basic
public class SuggestionResultPair
Public Class SuggestionResultPair
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SearchBoxAutoCompleteHelper..::..SuggestionResultPair(String, Int32) | New
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NumberOfResults | Approximate number of results for the query.
 | Query | Suggested search query that will appear in the combo box
 | ToString()()()() | Converts to a string (Overrides Object.ToString()()()().)
Inheritance Hierarchy
Object
SearchBoxAutoCompleteHelper..::..SuggestionResultPair

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SearchBoxAutoCompleteHelper.SuggestionResultPair Constructor (query, numberOfResults)

SearchBoxAutoCompleteHelper..::..SuggestionResultPair Constructor (query, numberOfResults)
API Documentation ► Keyoti.SearchEngine.Web ► SearchBoxAutoCompleteHelper..::..SuggestionResultPair ► SearchBoxAutoCompleteHelper..::..SuggestionResultPair(String, Int32)
Keyoti SearchUnit v6
New
Declaration Syntax
C# Visual Basic
public SuggestionResultPair(
    string query,
    int numberOfResults
)
Public Sub New (
    query As String,
    numberOfResults As Integer
)
Parameters
query (String)
numberOfResults (Int32)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


NumberOfResults Property

NumberOfResults Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchBoxAutoCompleteHelper..::..SuggestionResultPair ► NumberOfResults
Keyoti SearchUnit v6
Approximate number of results for the query.
Declaration Syntax
C# Visual Basic
public int NumberOfResults { get; }
Public ReadOnly Property NumberOfResults As Integer
    Get
Property Value
Int32

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Query Property

Query Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchBoxAutoCompleteHelper..::..SuggestionResultPair ► Query
Keyoti SearchUnit v6
Suggested search query that will appear in the combo box
Declaration Syntax
C# Visual Basic
public string Query { get; }
Public ReadOnly Property Query As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ToString Method

ToString Method
API Documentation ► Keyoti.SearchEngine.Web ► SearchBoxAutoCompleteHelper..::..SuggestionResultPair ► ToString()()()()
Keyoti SearchUnit v6
Converts to a string
Declaration Syntax
C# Visual Basic
public override string ToString()
Public Overrides Function ToString As String
Return Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SearchBoxAutoCompleteHelper.SuggestionResultPair.Comparer Class

SearchBoxAutoCompleteHelper..::..SuggestionResultPair..::..Comparer Class
API Documentation ► Keyoti.SearchEngine.Web ► SearchBoxAutoCompleteHelper..::..SuggestionResultPair ► SearchBoxAutoCompleteHelper..::..SuggestionResultPair..::..Comparer
Keyoti SearchUnit v6
Comparer
Declaration Syntax
C# Visual Basic
public class Comparer : IComparer
Public Class Comparer
    Implements IComparer
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SearchBoxAutoCompleteHelper..::..SuggestionResultPair..::..Comparer()()()() |
 | Compare(Object, Object) | Used for sorting
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
SearchBoxAutoCompleteHelper..::..SuggestionResultPair..::..Comparer

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SearchBoxAutoCompleteHelper.SuggestionResultPair.Comparer Constructor

SearchBoxAutoCompleteHelper..::..SuggestionResultPair..::..Comparer Constructor
API Documentation ► Keyoti.SearchEngine.Web ► SearchBoxAutoCompleteHelper..::..SuggestionResultPair..::..Comparer ► SearchBoxAutoCompleteHelper..::..SuggestionResultPair..::..Comparer()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public Comparer()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Compare Method (x, y)

Compare Method (x, y)
API Documentation ► Keyoti.SearchEngine.Web ► SearchBoxAutoCompleteHelper..::..SuggestionResultPair..::..Comparer ► Compare(Object, Object)
Keyoti SearchUnit v6
Used for sorting
Declaration Syntax
C# Visual Basic
public int Compare(
    Object x,
    Object y
)
Public Function Compare (
    x As Object,
    y As Object
) As Integer
Parameters
x (Object)
y (Object)
Return Value
Int32

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SearchBoxOptions Class

SearchBoxOptions Class
API Documentation ► Keyoti.SearchEngine.Web ► SearchBoxOptions
Keyoti SearchUnit v6
Web control allowing the user to select location and content options that will be used by search
Declaration Syntax
C# Visual Basic
public class SearchBoxOptions : WebControl,
    INamingContainer
Public Class SearchBoxOptions
    Inherits WebControl
    Implements INamingContainer
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SearchBoxOptions()()()() | Constructor
 | AccessKey | (Inherited from WebControl.)
 | Adapter | (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | (Inherited from Control.)
 | AddParsedSubObject(Object) | (Inherited from Control.)
 | ApplyStyle(Style) | (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | (Inherited from Control.)
 | Attributes | (Inherited from WebControl.)
 | AutoGenerateContentCheckBoxes | Whether to automatically generate the content category checkboxes.
 | AutoGenerateFromIndexDirectory | The Index Directory, where index files are stored, this must already exist, and can be specified as an absolute file path, or a relative URL.
 | AutoGenerateLocationAllOptionText | The text to use for the "All" locations option.
 | AutoGenerateLocationDropDown | Whether to automatically generate the location category drop down menu.
 | BackColor | (Inherited from WebControl.)
 | BeginRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | BindingContainer | (Inherited from Control.)
 | BorderColor | (Inherited from WebControl.)
 | BorderStyle | (Inherited from WebControl.)
 | BorderWidth | (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | (Inherited from Control.)
 | ChildControlsCreated | (Inherited from Control.)
 | ClearCachedClientID()()()() | (Inherited from Control.)
 | ClearChildControlState()()()() | (Inherited from Control.)
 | ClearChildState()()()() | (Inherited from Control.)
 | ClearChildViewState()()()() | (Inherited from Control.)
 | ClearEffectiveClientIDMode()()()() | (Inherited from Control.)
 | ClientID | (Inherited from Control.)
 | ClientIDMode | (Inherited from Control.)
 | ClientIDSeparator | (Inherited from Control.)
 | ContentCheckBoxes | Control containing a set of content check boxes, offering the user a possibility to select one or more content categories
 | Contents | Content categories collection
 | Context | (Inherited from Control.)
 | Controls | (Inherited from Control.)
 | ControlStyle | (Inherited from WebControl.)
 | ControlStyleCreated | (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | (Inherited from WebControl.)
 | CreateChildControls()()()() | (Overrides Control.CreateChildControls()()()().)
 | CreateControlCollection()()()() | (Inherited from Control.)
 | CreateControlStyle()()()() | (Inherited from WebControl.)
 | CssClass | (Inherited from WebControl.)
 | DataBind()()()() | (Inherited from Control.)
 | DataBind(Boolean) | (Inherited from Control.)
 | DataBindChildren()()()() | (Inherited from Control.)
 | DataBinding | (Inherited from Control.)
 | DataItemContainer | (Inherited from Control.)
 | DataKeysContainer | (Inherited from Control.)
 | DesignMode | (Inherited from Control.)
 | Dispose()()()() | (Inherited from Control.)
 | Disposed | (Inherited from Control.)
 | Enabled | (Inherited from WebControl.)
 | EnableTheming | (Inherited from WebControl.)
 | EnableViewState | (Inherited from Control.)
 | EndRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | EnsureChildControls()()()() | (Inherited from Control.)
 | EnsureID()()()() | (Inherited from Control.)
 | Equals(Object) | (Inherited from Object.)
 | Events | (Inherited from Control.)
 | Finalize()()()() | (Inherited from Object.)
 | FindControl(String) | (Inherited from Control.)
 | FindControl(String, Int32) | (Inherited from Control.)
 | Focus()()()() | (Inherited from Control.)
 | Font | (Overrides WebControl.Font.)
 | ForeColor | (Overrides WebControl.ForeColor.)
 | GetDesignModeState()()()() | (Inherited from Control.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetRouteUrl(Object) | (Inherited from Control.)
 | GetRouteUrl(String, Object) | (Inherited from Control.)
 | GetRouteUrl(RouteValueDictionary) | (Inherited from Control.)
 | GetRouteUrl(String, RouteValueDictionary) | (Inherited from Control.)
 | GetType()()()() | (Inherited from Object.)
 | GetUniqueIDRelativeTo(Control) | (Inherited from Control.)
 | HasAttributes | (Inherited from WebControl.)
 | HasChildViewState | (Inherited from Control.)
 | HasControls()()()() | (Inherited from Control.)
 | HasEvents()()()() | (Inherited from Control.)
 | Height | (Inherited from WebControl.)
 | ID | (Inherited from Control.)
 | IdSeparator | (Inherited from Control.)
 | Init | (Inherited from Control.)
 | IsChildControlStateCleared | (Inherited from Control.)
 | IsEnabled | (Inherited from WebControl.)
 | IsLiteralContent()()()() | (Inherited from Control.)
 | IsTrackingViewState | (Inherited from Control.)
 | IsViewStateEnabled | (Inherited from Control.)
 | Layout | Whether to layout the controls horizontally or vertically
 | Load | (Inherited from Control.)
 | LoadControlState(Object) | (Inherited from Control.)
 | LoadViewState(Object) | (Inherited from WebControl.)
 | LoadViewStateByID | (Inherited from Control.)
 | LocationDropDownList | DropDown list populated with location names, offering the user the possibility to select a location category
 | Locations | Location categories collection
 | MapPathSecure(String) | (Inherited from Control.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle(Style) | (Inherited from WebControl.)
 | NamingContainer | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | (Inherited from Control.)
 | OnDataBinding(EventArgs) | (Inherited from Control.)
 | OnInit(EventArgs) | (Inherited from Control.)
 | OnLoad(EventArgs) | Sets selected location/contents (accesible here, as view state is restored) in the SearchBox (Overrides Control.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | (Inherited from Control.)
 | OnUnload(EventArgs) | (Inherited from Control.)
 | OpenFile(String) | (Inherited from Control.)
 | Page | (Inherited from Control.)
 | Parent | (Inherited from Control.)
 | PreRender | (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | (Inherited from Control.)
 | RemovedControl(Control) | (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Render this control to the output parameter specified. (Overrides WebControl.RenderContents(HtmlTextWriter).)
 | RenderControl(HtmlTextWriter) | (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingCompatibility | (Inherited from Control.)
 | ResolveAdapter()()()() | (Inherited from Control.)
 | ResolveClientUrl(String) | (Inherited from Control.)
 | ResolveUrl(String) | (Inherited from Control.)
 | SaveControlState()()()() | (Inherited from Control.)
 | SaveViewState()()()() | (Inherited from WebControl.)
 | SearchBoxId | ID for the SearchBox control in the page that will use for search the selected location/contents options
 | SetDesignModeState(IDictionary) | (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | (Inherited from Control.)
 | SetTraceData(Object, Object) | (Inherited from Control.)
 | SetTraceData(Object, Object, Object) | (Inherited from Control.)
 | Site | (Inherited from Control.)
 | SkinID | (Inherited from WebControl.)
 | Style | (Inherited from WebControl.)
 | SupportsDisabledAttribute | (Inherited from WebControl.)
 | TabIndex | (Inherited from WebControl.)
 | TagKey | See base. (Overrides WebControl.TagKey.)
 | TagName | (Inherited from WebControl.)
 | TemplateControl | (Inherited from Control.)
 | TemplateSourceDirectory | (Inherited from Control.)
 | ToolTip | (Inherited from WebControl.)
 | ToString()()()() | (Inherited from Object.)
 | TrackViewState()()()() | (Inherited from WebControl.)
 | UniqueID | (Inherited from Control.)
 | Unload | (Inherited from Control.)
 | ValidateRequestMode | (Inherited from Control.)
 | ViewState | (Inherited from Control.)
 | ViewStateIgnoresCase | (Inherited from Control.)
 | ViewStateMode | (Inherited from Control.)
 | Visible | (Inherited from Control.)
 | Width | (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | SearchBoxOptions

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


SearchBoxOptions Constructor

SearchBoxOptions Constructor
API Documentation ► Keyoti.SearchEngine.Web ► SearchBoxOptions ► SearchBoxOptions()()()()
Keyoti SearchUnit v6
Constructor
Declaration Syntax
C# Visual Basic
public SearchBoxOptions()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


AutoGenerateContentCheckBoxes Property

AutoGenerateContentCheckBoxes Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchBoxOptions ► AutoGenerateContentCheckBoxes
Keyoti SearchUnit v6
Whether to automatically generate the content category checkboxes.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool AutoGenerateContentCheckBoxes { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property AutoGenerateContentCheckBoxes As Boolean
    Get
    Set
Property Value
Boolean
Remarks
AutoGenerateFromIndexDirectory must be set to the index directory, when this is set true.

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


AutoGenerateFromIndexDirectory Property

AutoGenerateFromIndexDirectory Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchBoxOptions ► AutoGenerateFromIndexDirectory
Keyoti SearchUnit v6
The Index Directory, where index files are stored, this must already exist, and can be specified as an absolute file path, or a relative URL.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public virtual string AutoGenerateFromIndexDirectory { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overridable Property AutoGenerateFromIndexDirectory As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


AutoGenerateLocationAllOptionText Property

AutoGenerateLocationAllOptionText Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchBoxOptions ► AutoGenerateLocationAllOptionText
Keyoti SearchUnit v6
The text to use for the "All" locations option.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string AutoGenerateLocationAllOptionText { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property AutoGenerateLocationAllOptionText As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


AutoGenerateLocationDropDown Property

AutoGenerateLocationDropDown Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchBoxOptions ► AutoGenerateLocationDropDown
Keyoti SearchUnit v6
Whether to automatically generate the location category drop down menu.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool AutoGenerateLocationDropDown { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property AutoGenerateLocationDropDown As Boolean
    Get
    Set
Property Value
Boolean

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


ContentCheckBoxes Property

ContentCheckBoxes Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchBoxOptions ► ContentCheckBoxes
Keyoti SearchUnit v6
Control containing a set of content check boxes, offering the user a possibility to select one or more content categories
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public SearchContentOptions ContentCheckBoxes { get; }
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property ContentCheckBoxes As SearchContentOptions
    Get
Property Value
SearchContentOptions

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


Contents Property

Contents Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchBoxOptions ► Contents
Keyoti SearchUnit v6
Content categories collection
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public virtual StringCollection Contents { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overridable Property Contents As StringCollection
    Get
    Set
Property Value
StringCollection

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


CreateChildControls Method

CreateChildControls Method
API Documentation ► Keyoti.SearchEngine.Web ► SearchBoxOptions ► CreateChildControls()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
protected override void CreateChildControls()
Protected Overrides Sub CreateChildControls

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


Font Property

Font Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchBoxOptions ► Font
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public override FontInfo Font { get; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overrides ReadOnly Property Font As FontInfo
    Get
Property Value
FontInfo

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


ForeColor Property

ForeColor Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchBoxOptions ► ForeColor
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public override Color ForeColor { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overrides Property ForeColor As Color
    Get
    Set
Property Value
Color

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


Layout Property

Layout Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchBoxOptions ► Layout
Keyoti SearchUnit v6
Whether to layout the controls horizontally or vertically
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public SearchBoxOptionsLayout Layout { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property Layout As SearchBoxOptionsLayout
    Get
    Set
Property Value
SearchBoxOptionsLayout

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


LocationDropDownList Property

LocationDropDownList Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchBoxOptions ► LocationDropDownList
Keyoti SearchUnit v6
DropDown list populated with location names, offering the user the possibility to select a location category
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public virtual KDropDownList LocationDropDownList { get; }
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public Overridable ReadOnly Property LocationDropDownList As KDropDownList
    Get
Property Value
KDropDownList

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


Locations Property

Locations Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchBoxOptions ► Locations
Keyoti SearchUnit v6
Location categories collection
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public virtual StringCollection Locations { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overridable Property Locations As StringCollection
    Get
    Set
Property Value
StringCollection

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


OnLoad Method (e)

OnLoad Method (e)
API Documentation ► Keyoti.SearchEngine.Web ► SearchBoxOptions ► OnLoad(EventArgs)
Keyoti SearchUnit v6
Sets selected location/contents (accesible here, as view state is restored) in the SearchBox
Declaration Syntax
C# Visual Basic
protected override void OnLoad(
    EventArgs e
)
Protected Overrides Sub OnLoad (
    e As EventArgs
)
Parameters
e (EventArgs)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


RenderContents Method (output)

RenderContents Method (output)
API Documentation ► Keyoti.SearchEngine.Web ► SearchBoxOptions ► RenderContents(HtmlTextWriter)
Keyoti SearchUnit v6
Render this control to the output parameter specified.
Declaration Syntax
C# Visual Basic
protected override void RenderContents(
    HtmlTextWriter output
)
Protected Overrides Sub RenderContents (
    output As HtmlTextWriter
)
Parameters
output (HtmlTextWriter)
The HTML writer to write out to

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


SearchBoxId Property

SearchBoxId Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchBoxOptions ► SearchBoxId
Keyoti SearchUnit v6
ID for the SearchBox control in the page that will use for search the selected location/contents options
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public virtual string SearchBoxId { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overridable Property SearchBoxId As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


TagKey Property

TagKey Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchBoxOptions ► TagKey
Keyoti SearchUnit v6
See base.
Declaration Syntax
C# Visual Basic
protected override HtmlTextWriterTag TagKey { get; }
Protected Overrides ReadOnly Property TagKey As HtmlTextWriterTag
    Get
Property Value
HtmlTextWriterTag

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


SearchBoxOptionsLayout Enumeration

SearchBoxOptionsLayout Enumeration
API Documentation ► Keyoti.SearchEngine.Web ► SearchBoxOptionsLayout
Keyoti SearchUnit v6
The layout style for this control.
Declaration Syntax
C# Visual Basic
public enum SearchBoxOptionsLayout
Public Enumeration SearchBoxOptionsLayout
Members
Member | Description
HORIZONTAL | Position controls horizontally
VERTICAL | Position controls vertically

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


SearchContentOptions Class

SearchContentOptions Class
API Documentation ► Keyoti.SearchEngine.Web ► SearchContentOptions
Keyoti SearchUnit v6
Web control exposing a collection of check boxes, that will allow a content categories selection
Declaration Syntax
C# Visual Basic
public class SearchContentOptions : WebControl
Public Class SearchContentOptions
    Inherits WebControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SearchContentOptions()()()() | Constructor
 | AccessKey | (Inherited from WebControl.)
 | Adapter | (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | (Inherited from Control.)
 | AddParsedSubObject(Object) | (Inherited from Control.)
 | ApplyStyle(Style) | (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | (Inherited from Control.)
 | Attributes | (Inherited from WebControl.)
 | BackColor | (Overrides WebControl.BackColor.)
 | BeginRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | BindingContainer | (Inherited from Control.)
 | BorderColor | (Inherited from WebControl.)
 | BorderStyle | (Inherited from WebControl.)
 | BorderWidth | (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | (Inherited from Control.)
 | CheckBoxesFont |
 | ChildControlsCreated | (Inherited from Control.)
 | ClearCachedClientID()()()() | (Inherited from Control.)
 | ClearChildControlState()()()() | (Inherited from Control.)
 | ClearChildState()()()() | (Inherited from Control.)
 | ClearChildViewState()()()() | (Inherited from Control.)
 | ClearEffectiveClientIDMode()()()() | (Inherited from Control.)
 | ClientID | (Inherited from Control.)
 | ClientIDMode | (Inherited from Control.)
 | ClientIDSeparator | (Inherited from Control.)
 | Context | (Inherited from Control.)
 | Controls | (Inherited from Control.)
 | ControlStyle | (Inherited from WebControl.)
 | ControlStyleCreated | (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | (Inherited from WebControl.)
 | CreateCheckBoxes(StringCollection) | Creates a checkBox instance for every content category in the collection
 | CreateChildControls()()()() | (Inherited from Control.)
 | CreateControlCollection()()()() | (Inherited from Control.)
 | CreateControlStyle()()()() | (Inherited from WebControl.)
 | CssClass | (Inherited from WebControl.)
 | DataBind()()()() | (Inherited from Control.)
 | DataBind(Boolean) | (Inherited from Control.)
 | DataBindChildren()()()() | (Inherited from Control.)
 | DataBinding | (Inherited from Control.)
 | DataItemContainer | (Inherited from Control.)
 | DataKeysContainer | (Inherited from Control.)
 | DesignMode | (Inherited from Control.)
 | Dispose()()()() | (Inherited from Control.)
 | Disposed | (Inherited from Control.)
 | Enabled | (Inherited from WebControl.)
 | EnableTheming | (Inherited from WebControl.)
 | EnableViewState | (Inherited from Control.)
 | EndRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | EnsureChildControls()()()() | (Inherited from Control.)
 | EnsureID()()()() | (Inherited from Control.)
 | Equals(Object) | (Inherited from Object.)
 | Events | (Inherited from Control.)
 | Finalize()()()() | (Inherited from Object.)
 | FindControl(String) | (Inherited from Control.)
 | FindControl(String, Int32) | (Inherited from Control.)
 | Focus()()()() | (Inherited from Control.)
 | Font | (Overrides WebControl.Font.)
 | ForeColor | (Overrides WebControl.ForeColor.)
 | GetDesignModeState()()()() | (Inherited from Control.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetRouteUrl(Object) | (Inherited from Control.)
 | GetRouteUrl(String, Object) | (Inherited from Control.)
 | GetRouteUrl(RouteValueDictionary) | (Inherited from Control.)
 | GetRouteUrl(String, RouteValueDictionary) | (Inherited from Control.)
 | GetType()()()() | (Inherited from Object.)
 | GetUniqueIDRelativeTo(Control) | (Inherited from Control.)
 | HasAttributes | (Inherited from WebControl.)
 | HasChildViewState | (Inherited from Control.)
 | HasControls()()()() | (Inherited from Control.)
 | HasEvents()()()() | (Inherited from Control.)
 | Height | (Overrides WebControl.Height.)
 | ID | (Inherited from Control.)
 | IdSeparator | (Inherited from Control.)
 | Init | (Inherited from Control.)
 | IsChildControlStateCleared | (Inherited from Control.)
 | IsEnabled | (Inherited from WebControl.)
 | IsLiteralContent()()()() | (Inherited from Control.)
 | IsTrackingViewState | (Inherited from Control.)
 | IsViewStateEnabled | (Inherited from Control.)
 | Layout |
 | Load | (Inherited from Control.)
 | LoadControlState(Object) | (Inherited from Control.)
 | LoadViewState(Object) | (Inherited from WebControl.)
 | LoadViewStateByID | (Inherited from Control.)
 | MapPathSecure(String) | (Inherited from Control.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle(Style) | (Inherited from WebControl.)
 | NamingContainer | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | (Inherited from Control.)
 | OnDataBinding(EventArgs) | (Inherited from Control.)
 | OnInit(EventArgs) | (Inherited from Control.)
 | OnLoad(EventArgs) | (Inherited from Control.)
 | OnPreRender(EventArgs) | (Inherited from Control.)
 | OnUnload(EventArgs) | (Inherited from Control.)
 | OpenFile(String) | (Inherited from Control.)
 | Page | (Inherited from Control.)
 | Parent | (Inherited from Control.)
 | PreRender | (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | (Inherited from Control.)
 | RefreshCheckBoxProperties()()()() | Refreshes the children CheckBoxes properties
 | RemovedControl(Control) | (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Render this control to the output parameter specified. (Overrides WebControl.RenderContents(HtmlTextWriter).)
 | RenderControl(HtmlTextWriter) | (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingCompatibility | (Inherited from Control.)
 | ResolveAdapter()()()() | (Inherited from Control.)
 | ResolveClientUrl(String) | (Inherited from Control.)
 | ResolveUrl(String) | (Inherited from Control.)
 | SaveControlState()()()() | (Inherited from Control.)
 | SaveViewState()()()() | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | (Inherited from Control.)
 | SetTraceData(Object, Object) | (Inherited from Control.)
 | SetTraceData(Object, Object, Object) | (Inherited from Control.)
 | Site | (Inherited from Control.)
 | SkinID | (Inherited from WebControl.)
 | Style | (Inherited from WebControl.)
 | SupportsDisabledAttribute | (Inherited from WebControl.)
 | TabIndex | (Inherited from WebControl.)
 | TagKey | (Inherited from WebControl.)
 | TagName | (Inherited from WebControl.)
 | TemplateControl | (Inherited from Control.)
 | TemplateSourceDirectory | (Inherited from Control.)
 | ToolTip | (Inherited from WebControl.)
 | ToString()()()() | (Inherited from Object.)
 | TrackViewState()()()() | (Inherited from WebControl.)
 | UniqueID | (Inherited from Control.)
 | Unload | (Inherited from Control.)
 | ValidateRequestMode | (Inherited from Control.)
 | ViewState | (Inherited from Control.)
 | ViewStateIgnoresCase | (Inherited from Control.)
 | ViewStateMode | (Inherited from Control.)
 | Visible | (Inherited from Control.)
 | Width | (Overrides WebControl.Width.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | SearchContentOptions

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


SearchContentOptions Constructor

SearchContentOptions Constructor
API Documentation ► Keyoti.SearchEngine.Web ► SearchContentOptions ► SearchContentOptions()()()()
Keyoti SearchUnit v6
Constructor
Declaration Syntax
C# Visual Basic
public SearchContentOptions()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


BackColor Property

BackColor Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchContentOptions ► BackColor
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public override Color BackColor { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overrides Property BackColor As Color
    Get
    Set
Property Value
Color

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


CheckBoxesFont Property

CheckBoxesFont Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchContentOptions ► CheckBoxesFont
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public KFont CheckBoxesFont { get; }
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property CheckBoxesFont As KFont
    Get
Property Value
KFont

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


CreateCheckBoxes Method (contents)

CreateCheckBoxes Method (contents)
API Documentation ► Keyoti.SearchEngine.Web ► SearchContentOptions ► CreateCheckBoxes(StringCollection)
Keyoti SearchUnit v6
Creates a checkBox instance for every content category in the collection
Declaration Syntax
C# Visual Basic
public void CreateCheckBoxes(
    StringCollection contents
)
Public Sub CreateCheckBoxes (
    contents As StringCollection
)
Parameters
contents (StringCollection)
content collection

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


Font Property

Font Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchContentOptions ► Font
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public override FontInfo Font { get; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overrides ReadOnly Property Font As FontInfo
    Get
Property Value
FontInfo

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


ForeColor Property

ForeColor Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchContentOptions ► ForeColor
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public override Color ForeColor { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overrides Property ForeColor As Color
    Get
    Set
Property Value
Color

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


Height Property

Height Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchContentOptions ► Height
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public override Unit Height { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overrides Property Height As Unit
    Get
    Set
Property Value
Unit

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


Layout Field

Layout Field
API Documentation ► Keyoti.SearchEngine.Web ► SearchContentOptions ► Layout
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public SearchBoxOptionsLayout Layout
Public Layout As SearchBoxOptionsLayout
Field Value
SearchBoxOptionsLayout

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


RefreshCheckBoxProperties Method

RefreshCheckBoxProperties Method
API Documentation ► Keyoti.SearchEngine.Web ► SearchContentOptions ► RefreshCheckBoxProperties()()()()
Keyoti SearchUnit v6
Refreshes the children CheckBoxes properties
Declaration Syntax
C# Visual Basic
public void RefreshCheckBoxProperties()
Public Sub RefreshCheckBoxProperties

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


RenderContents Method (output)

RenderContents Method (output)
API Documentation ► Keyoti.SearchEngine.Web ► SearchContentOptions ► RenderContents(HtmlTextWriter)
Keyoti SearchUnit v6
Render this control to the output parameter specified.
Declaration Syntax
C# Visual Basic
protected override void RenderContents(
    HtmlTextWriter output
)
Protected Overrides Sub RenderContents (
    output As HtmlTextWriter
)
Parameters
output (HtmlTextWriter)
The HTML writer to write out to

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


Width Property

Width Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchContentOptions ► Width
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public override Unit Width { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overrides Property Width As Unit
    Get
    Set
Property Value
Unit

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


SearchResult Class

SearchResult Class
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult
Keyoti SearchUnit v6
Web control performing search and showing results to the user.
Declaration Syntax
C# Visual Basic
public class SearchResult : WebControl,
    IPostBackEventHandler, INamingContainer
Public Class SearchResult
    Inherits WebControl
    Implements IPostBackEventHandler, INamingContainer
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SearchResult()()()() | Creates a new instance of the control.
 | AccessKey | (Inherited from WebControl.)
 | Adapter | (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | (Inherited from Control.)
 | AddParsedSubObject(Object) | (Inherited from Control.)
 | ApplyStyle(Style) | (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | (Inherited from Control.)
 | Attributes | (Inherited from WebControl.)
 | BackColor | (Inherited from WebControl.)
 | BeginRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | BindingContainer | (Inherited from Control.)
 | BorderColor | (Inherited from WebControl.)
 | BorderStyle | (Inherited from WebControl.)
 | BorderWidth | (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | (Inherited from Control.)
 | ChildControlsCreated | (Inherited from Control.)
 | ClearCachedClientID()()()() | (Inherited from Control.)
 | ClearChildControlState()()()() | (Inherited from Control.)
 | ClearChildState()()()() | (Inherited from Control.)
 | ClearChildViewState()()()() | (Inherited from Control.)
 | ClearEffectiveClientIDMode()()()() | (Inherited from Control.)
 | ClientFilesLocation | Whether to use the internal client files, or external files (for customization).
 | ClientID | (Inherited from Control.)
 | ClientIDMode | (Inherited from Control.)
 | ClientIDSeparator | (Inherited from Control.)
 | Configuration | The instance of the Configuration class that holds the settings to be used.
 | Context | (Inherited from Control.)
 | Controls | (Inherited from Control.)
 | ControlStyle | (Inherited from WebControl.)
 | ControlStyleCreated | (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | (Inherited from WebControl.)
 | CreateChildControls()()()() | Creates the child controls, and performs the search. (Overrides Control.CreateChildControls()()()().)
 | CreateControlCollection()()()() | (Inherited from Control.)
 | CreateControlStyle()()()() | (Inherited from WebControl.)
 | CreateDefaultErrorMessageTemplate()()()() | Creates a DefaultErrorMessageTemplate instance with default layout for the error message.
 | CreateDefaultFooterTemplate()()()() | Creates a DefaultHeaderTemplate instance with default layout for the footer.
 | CreateDefaultHeaderTemplate()()()() | Creates a DefaultHeaderTemplate instance with default layout for the header.
 | CreateDefaultNoQueryTemplate()()()() | Creates a DefaultNoQueryTemplate instance with default layout for the no query item.
 | CreateDefaultNoResultsTemplate()()()() | Creates a DefaultNoResultsTemplate instance with default layout for the no results message.
 | CreateDefaultResultItemTemplate()()()() | Creates a DefaultResultItemTemplate instance with default layout for the result item.
 | CssClass | (Inherited from WebControl.)
 | DataBind()()()() | (Inherited from Control.)
 | DataBind(Boolean) | (Inherited from Control.)
 | DataBindChildren()()()() | (Inherited from Control.)
 | DataBinding | (Inherited from Control.)
 | DataItemContainer | (Inherited from Control.)
 | DataKeysContainer | (Inherited from Control.)
 | DataSource | An optional DataSet instance that will be used as the source of the search results (see remarks).
 | DesignMode | (Inherited from Control.)
 | Dispose()()()() | (Inherited from Control.)
 | Disposed | (Inherited from Control.)
 | Enabled | (Inherited from WebControl.)
 | EnableTheming | (Inherited from WebControl.)
 | EnableViewState | (Inherited from Control.)
 | EndRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | EnsureChildControls()()()() | (Inherited from Control.)
 | EnsureID()()()() | (Inherited from Control.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorMessageTemplate | The error message template shown when an error occurrs.
 | Events | (Inherited from Control.)
 | FilterLoadLevel | Specifies what amount of data to load for any filtering by a ResultItemsFinalized event handler or by an AddResultItemToResults override.
 | Finalize()()()() | (Inherited from Object.)
 | FindControl(String) | (Inherited from Control.)
 | FindControl(String, Int32) | (Inherited from Control.)
 | Focus()()()() | (Inherited from Control.)
 | Font | (Inherited from WebControl.)
 | FooterTemplate | The footer template shown below the search results.
 | ForeColor | (Inherited from WebControl.)
 | FromURIPattern | If necessary URLs in the results can be mapped to other domains/paths, specify the from match here, eg. http://localhost
 | GenerateDefaultTemplatesIfNeeded()()()() | Creates the default templates if the specified ones are null.
 | GetDesignModeState()()()() | (Inherited from Control.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetRouteUrl(Object) | (Inherited from Control.)
 | GetRouteUrl(String, Object) | (Inherited from Control.)
 | GetRouteUrl(RouteValueDictionary) | (Inherited from Control.)
 | GetRouteUrl(String, RouteValueDictionary) | (Inherited from Control.)
 | GetSearchResults(SearchOptions) | Returns the results used to create ResultItems, this can be either a DataSet or a SearchResult.
 | GetType()()()() | (Inherited from Object.)
 | GetUniqueIDRelativeTo(Control) | (Inherited from Control.)
 | HasAttributes | (Inherited from WebControl.)
 | HasChildViewState | (Inherited from Control.)
 | HasControls()()()() | (Inherited from Control.)
 | HasEvents()()()() | (Inherited from Control.)
 | HeaderTemplate | The header template shown above the search results.
 | Height | (Inherited from WebControl.)
 | HighlightQueryWordsInSummary | Whether to highlight the query words in the summary.
 | HighlightQueryWordsInSummaryHTML | How to highlight the query words in the summary. Eg. <b>{0}</b>
 | ID | (Inherited from Control.)
 | IdSeparator | (Inherited from Control.)
 | IgnoredWords | Comma delimited list of words which were not searched for (stop-list).
 | IndexDirectory | The directory where the document index files should be stored, this must already exist, and can be specified as an absolute file path, or a relative URL.
 | Init | (Inherited from Control.)
 | InvalidateChildControlHierarchy()()()() | Invalidates child controls to force recreation of result items. Call when results should be regenerated after a postback.
 | IsChildControlStateCleared | (Inherited from Control.)
 | IsEnabled | (Inherited from WebControl.)
 | IsLiteralContent()()()() | (Inherited from Control.)
 | IsTrackingViewState | (Inherited from Control.)
 | IsViewStateEnabled | (Inherited from Control.)
 | ItemCreated | Fired when a search result item control is created.
 | LicenseKey | The license key for the control, see remarks.
 | Load | (Inherited from Control.)
 | LoadConfiguration(String) | Load configuration object values from the Configuration.xml file.
 | LoadControlState(Object) | (Inherited from Control.)
 | LoadViewState(Object) | (Inherited from WebControl.)
 | LoadViewStateByID | (Inherited from Control.)
 | MapPathSecure(String) | (Inherited from Control.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle(Style) | (Inherited from WebControl.)
 | NamingContainer | (Inherited from Control.)
 | NextPageClicked | Fired when 'next page' link is clicked.
 | NextPageLink | Link to the next page of results, is empty string if on last page.
 | NextPageLinkText | Link text to the next page of results
 | NoQueryTemplate | The template shown when there is no search query present when the page loads.
 | NoResultsTemplate | The template shown when there are no results.
 | NumberOfResults | The number of results found.
 | NumberOfResultsFinalized | Fired when the number of results is known and the NumberOfResults property is set.
 | NumberOfResultsPerPage | The number of results per page to show.
 | OnBubbleEvent(Object, EventArgs) | (Inherited from Control.)
 | OnDataBinding(EventArgs) | (Inherited from Control.)
 | OnInit(EventArgs) | Called during the Init lifecycle stage (Overrides Control.OnInit(EventArgs).)
 | OnItemCreated(Control, Object) | Raises the ItemCreated event.
 | OnLoad(EventArgs) | (Inherited from Control.)
 | OnNextPageClicked(EventArgs) | Called when 'next page' link is clicked.
 | OnNumberOfResultsFinalized(EventArgs) | Called when 'next page' link is clicked.
 | OnPageXClicked(ResultsPageClickEventArgs) | Called when one of the specific page links in the bar is clicked.
 | OnPreRender(EventArgs) | (Overrides Control.OnPreRender(EventArgs).)
 | OnPrevPageClicked(EventArgs) | Called when 'previous page' link is clicked.
 | OnUnload(EventArgs) | (Inherited from Control.)
 | OpenFile(String) | (Inherited from Control.)
 | Page | (Inherited from Control.)
 | PageXClicked | Fired when one of the specific page links in the bar is clicked.
 | Parent | (Inherited from Control.)
 | PreRender | (Inherited from Control.)
 | PreviousPageLink | Link to the previous page of results, is empty string if on first page.
 | PreviousPageLinkText | Link text to the previous page of results
 | PrevPageClicked | Fired when 'previous page' link is clicked.
 | QueryExpression | The query used in the search.
 | RaiseBubbleEvent(Object, EventArgs) | (Inherited from Control.)
 | RaisePostBackEvent(String) | Called when a post back occurrs related to this control.
 | RemovedControl(Control) | (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders this control. (Overrides WebControl.RenderContents(HtmlTextWriter).)
 | RenderControl(HtmlTextWriter) | (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingCompatibility | (Inherited from Control.)
 | ResolveAdapter()()()() | (Inherited from Control.)
 | ResolveClientUrl(String) | (Inherited from Control.)
 | ResolveUrl(String) | (Inherited from Control.)
 | ResultItemTemplate | The template for result items.
 | ResultPreviewerCharacterLimit | Maximum number of characters to show in the result preview text (limits the amount of text sent to the browser).
 | ResultPreviewerEnabled | Whether to allow the user to see an AJAX based preview of a result.
 | ResultPreviewerHighlightHTML | HTML code used to highlight hits in the result preview, {0} represents the hit.
 | ResultPreviewerLoadPlugin | Whether to load any plugin during an AJAX based preview of a result - this allows for serverside modification of the preview text.
 | ResultsPage | The results page number shown to the user.
 | ResultSummaryType | What type of result summary to show
 | SaveControlState()()()() | (Inherited from Control.)
 | SaveViewState()()()() | (Inherited from WebControl.)
 | SearchAgent | SearchAgent instance that will be used to search the index.
 | SearchOptions | The SearchOptions object controlling the search parameters.
 | SearchResults | Specifies the
 | SetDesignModeState(IDictionary) | (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | (Inherited from Control.)
 | SetTraceData(Object, Object) | (Inherited from Control.)
 | SetTraceData(Object, Object, Object) | (Inherited from Control.)
 | Site | (Inherited from Control.)
 | SkinID | (Inherited from WebControl.)
 | Style | (Inherited from WebControl.)
 | SupportsDisabledAttribute | (Inherited from WebControl.)
 | TabIndex | (Inherited from WebControl.)
 | TagKey | See base. (Overrides WebControl.TagKey.)
 | TagName | (Inherited from WebControl.)
 | TemplateControl | (Inherited from Control.)
 | TemplateSourceDirectory | (Inherited from Control.)
 | ToolTip | (Inherited from WebControl.)
 | ToString()()()() | (Inherited from Object.)
 | ToURIPattern | If necessary URLs in the results can be mapped to other domains/paths, specify the to match here, eg. http://www.domain.com
 | TrackViewState()()()() | (Inherited from WebControl.)
 | UniqueID | (Inherited from Control.)
 | Unload | (Inherited from Control.)
 | ValidateRequestMode | (Inherited from Control.)
 | ViewMode | The mode that the control is currently in.
 | ViewState | (Inherited from Control.)
 | ViewStateIgnoresCase | (Inherited from Control.)
 | ViewStateMode | (Inherited from Control.)
 | Visible | (Inherited from Control.)
 | Width | (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | SearchResult

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SearchResult Constructor

SearchResult Constructor
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► SearchResult()()()()
Keyoti SearchUnit v6
Creates a new instance of the control.
Declaration Syntax
C# Visual Basic
public SearchResult()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ClientFilesLocation Property

ClientFilesLocation Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► ClientFilesLocation
Keyoti SearchUnit v6
Whether to use the internal client files, or external files (for customization).
Declaration Syntax
C# Visual Basic
public ClientFilesLocation ClientFilesLocation { get; set; }
Public Property ClientFilesLocation As ClientFilesLocation
    Get
    Set
Property Value
ClientFilesLocation
Remarks
Default = Internal

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Configuration Property

Configuration Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► Configuration
Keyoti SearchUnit v6
The instance of the Configuration class that holds the settings to be used.
Declaration Syntax
C# Visual Basic
public Configuration Configuration { get; set; }
Public Property Configuration As Configuration
    Get
    Set
Property Value
Configuration

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


CreateChildControls Method

CreateChildControls Method
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► CreateChildControls()()()()
Keyoti SearchUnit v6
Creates the child controls, and performs the search.
Declaration Syntax
C# Visual Basic
protected override void CreateChildControls()
Protected Overrides Sub CreateChildControls

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


CreateDefaultErrorMessageTemplate Method

CreateDefaultErrorMessageTemplate Method
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► CreateDefaultErrorMessageTemplate()()()()
Keyoti SearchUnit v6
Creates a DefaultErrorMessageTemplate instance with default layout for the error message.
Declaration Syntax
C# Visual Basic
protected ITemplate CreateDefaultErrorMessageTemplate()
Protected Function CreateDefaultErrorMessageTemplate As ITemplate
Return Value
ITemplate

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


CreateDefaultFooterTemplate Method

CreateDefaultFooterTemplate Method
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► CreateDefaultFooterTemplate()()()()
Keyoti SearchUnit v6
Creates a DefaultHeaderTemplate instance with default layout for the footer.
Declaration Syntax
C# Visual Basic
protected ITemplate CreateDefaultFooterTemplate()
Protected Function CreateDefaultFooterTemplate As ITemplate
Return Value
ITemplate

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


CreateDefaultHeaderTemplate Method

CreateDefaultHeaderTemplate Method
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► CreateDefaultHeaderTemplate()()()()
Keyoti SearchUnit v6
Creates a DefaultHeaderTemplate instance with default layout for the header.
Declaration Syntax
C# Visual Basic
protected ITemplate CreateDefaultHeaderTemplate()
Protected Function CreateDefaultHeaderTemplate As ITemplate
Return Value
ITemplate

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


CreateDefaultNoQueryTemplate Method

CreateDefaultNoQueryTemplate Method
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► CreateDefaultNoQueryTemplate()()()()
Keyoti SearchUnit v6
Creates a DefaultNoQueryTemplate instance with default layout for the no query item.
Declaration Syntax
C# Visual Basic
protected ITemplate CreateDefaultNoQueryTemplate()
Protected Function CreateDefaultNoQueryTemplate As ITemplate
Return Value
ITemplate

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


CreateDefaultNoResultsTemplate Method

CreateDefaultNoResultsTemplate Method
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► CreateDefaultNoResultsTemplate()()()()
Keyoti SearchUnit v6
Creates a DefaultNoResultsTemplate instance with default layout for the no results message.
Declaration Syntax
C# Visual Basic
protected ITemplate CreateDefaultNoResultsTemplate()
Protected Function CreateDefaultNoResultsTemplate As ITemplate
Return Value
ITemplate

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


CreateDefaultResultItemTemplate Method

CreateDefaultResultItemTemplate Method
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► CreateDefaultResultItemTemplate()()()()
Keyoti SearchUnit v6
Creates a DefaultResultItemTemplate instance with default layout for the result item.
Declaration Syntax
C# Visual Basic
protected ITemplate CreateDefaultResultItemTemplate()
Protected Function CreateDefaultResultItemTemplate As ITemplate
Return Value
ITemplate

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


DataSource Property

DataSource Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► DataSource
Keyoti SearchUnit v6
An optional DataSet instance that will be used as the source of the search results (see remarks).
Declaration Syntax
C# Visual Basic
public virtual DataSet DataSource { get; set; }
Public Overridable Property DataSource As DataSet
    Get
    Set
Property Value
DataSet
Remarks
When this property is set to anything other than a null instance, the DataSet specified will be used as the search results, INSTEAD of the search results found internally. This is useful when merging different result sets. The DataSet's first table will be used for results, with each row corresponding to a result. The table must contain AT LEAST the following columns for correct operation;
  • URIString
  • Summary
  • Title
Where each is a string, corresponding in meaning to the properties of the same name in the ResultItem control. Additional columns may exist, and these can be accessed via the ItemCreated of this control, whose event arguments provide access to the current DataRow. Please see the demo projects for an example.

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ErrorMessageTemplate Property

ErrorMessageTemplate Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► ErrorMessageTemplate
Keyoti SearchUnit v6
The error message template shown when an error occurrs.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public virtual ITemplate ErrorMessageTemplate { get; set; }
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public Overridable Property ErrorMessageTemplate As ITemplate
    Get
    Set
Property Value
ITemplate

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FilterLoadLevel Property

FilterLoadLevel Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► FilterLoadLevel
Keyoti SearchUnit v6
Specifies what amount of data to load for any filtering by a ResultItemsFinalized event handler or by an AddResultItemToResults override.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public FilterLoadLevel FilterLoadLevel { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property FilterLoadLevel As FilterLoadLevel
    Get
    Set
Property Value
FilterLoadLevel
Remarks

The ResultItemsFinalized *central event* can be handled, or SearchAgent.AddResultItemToResults method can be overridden to enable result filtering, but since that method is called early in the search process, it will include many results that will not actually be shown to the user (i.e. results on page 2 onwards). Therefore, it is preferable to load as little data for each document at this stage (since the document may not be presented as a result).

If no filtering is required, set this to DocId, for optimal search speed.

See the Central Event System section of the help for info on handling central events.

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FooterTemplate Property

FooterTemplate Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► FooterTemplate
Keyoti SearchUnit v6
The footer template shown below the search results.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public virtual ITemplate FooterTemplate { get; set; }
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public Overridable Property FooterTemplate As ITemplate
    Get
    Set
Property Value
ITemplate

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FromURIPattern Property

FromURIPattern Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► FromURIPattern
Keyoti SearchUnit v6
If necessary URLs in the results can be mapped to other domains/paths, specify the from match here, eg. http://localhost
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public virtual string FromURIPattern { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overridable Property FromURIPattern As String
    Get
    Set
Property Value
String
Remarks
If an index is built against a web-site on localhost (or some other dev/staging server) for example then the URLs given in the search results will be incorrect when running in a production/live server environment. This simple mechanism allows results to be mapped from one URL to another.
Examples

Eg 1. A developer builds a web-site on http://localhost/internalApp/ and builds the search index - the search works fine on localhost, however when moving the app. to the live server the search results are linked to localhost. To correct this the developer maps the localhost URLs to the real server's, by setting:

Copy image Copy
FromURIPattern = "localhost/internalApp"
ToURIPattern = "ourcompanysinternalserver"
This causes URLs like http://localhost/internalApp/products/product1.aspx to be mapped to http://ourcompanysinternalserver/products/product1.aspx

Examples

Eg 2. A developer builds a web-site on http://staging.ourdomain.com/ and builds the search index - the search works fine on the staging server, however when moving the app. to the live server the search results are linked to staging.ourdomain.com. To correct this the developer maps the staging.ourdomain.com URLs to the real server's, by setting:

Copy image Copy
FromURIPattern = "staging.ourdomain.com"
ToURIPattern = "www.ourdomain.com"
This causes URLs like http://staging.ourdomain.com/default.aspx to be mapped to http://www.ourdomain.com/default.aspx

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


GenerateDefaultTemplatesIfNeeded Method

GenerateDefaultTemplatesIfNeeded Method
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► GenerateDefaultTemplatesIfNeeded()()()()
Keyoti SearchUnit v6
Creates the default templates if the specified ones are null.
Declaration Syntax
C# Visual Basic
protected internal void GenerateDefaultTemplatesIfNeeded()
Protected Friend Sub GenerateDefaultTemplatesIfNeeded

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


GetSearchResults Method (searchOptions)

GetSearchResults Method (searchOptions)
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► GetSearchResults(SearchOptions)
Keyoti SearchUnit v6
Returns the results used to create ResultItems, this can be either a DataSet or a SearchResult.
Declaration Syntax
C# Visual Basic
protected virtual Object GetSearchResults(
    SearchOptions searchOptions
)
Protected Overridable Function GetSearchResults (
    searchOptions As SearchOptions
) As Object
Parameters
searchOptions (SearchOptions)
Return Value
Object

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


HeaderTemplate Property

HeaderTemplate Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► HeaderTemplate
Keyoti SearchUnit v6
The header template shown above the search results.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public virtual ITemplate HeaderTemplate { get; set; }
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public Overridable Property HeaderTemplate As ITemplate
    Get
    Set
Property Value
ITemplate

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


HighlightQueryWordsInSummary Property

HighlightQueryWordsInSummary Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► HighlightQueryWordsInSummary
Keyoti SearchUnit v6
Whether to highlight the query words in the summary.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public virtual bool HighlightQueryWordsInSummary { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overridable Property HighlightQueryWordsInSummary As Boolean
    Get
    Set
Property Value
Boolean

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


HighlightQueryWordsInSummaryHTML Property

HighlightQueryWordsInSummaryHTML Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► HighlightQueryWordsInSummaryHTML
Keyoti SearchUnit v6
How to highlight the query words in the summary. Eg. <b>{0}</b>
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public virtual string HighlightQueryWordsInSummaryHTML { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overridable Property HighlightQueryWordsInSummaryHTML As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


IgnoredWords Property

IgnoredWords Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► IgnoredWords
Keyoti SearchUnit v6
Comma delimited list of words which were not searched for (stop-list).
Declaration Syntax
C# Visual Basic
public string IgnoredWords { get; set; }
Public Property IgnoredWords As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


IndexDirectory Property

IndexDirectory Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► IndexDirectory
Keyoti SearchUnit v6
The directory where the document index files should be stored, this must already exist, and can be specified as an absolute file path, or a relative URL.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public virtual string IndexDirectory { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overridable Property IndexDirectory As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


InvalidateChildControlHierarchy Method

InvalidateChildControlHierarchy Method
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► InvalidateChildControlHierarchy()()()()
Keyoti SearchUnit v6
Invalidates child controls to force recreation of result items. Call when results should be regenerated after a postback.
Declaration Syntax
C# Visual Basic
public void InvalidateChildControlHierarchy()
Public Sub InvalidateChildControlHierarchy

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ItemCreated Event

ItemCreated Event
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► ItemCreated
Keyoti SearchUnit v6
Fired when a search result item control is created.
Declaration Syntax
C# Visual Basic
public event SearchResult..::..SearchResultItemEventHandler ItemCreated
Public Event ItemCreated As SearchResult..::..SearchResultItemEventHandler
Value
SearchResult..::..SearchResultItemEventHandler

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


LicenseKey Property

LicenseKey Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► LicenseKey
Keyoti SearchUnit v6
The license key for the control, see remarks.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public virtual string LicenseKey { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overridable Property LicenseKey As String
    Get
    Set
Property Value
String
Remarks
If an application setting in the web config file called "Keyoti-SearchEngine-LicenseKey" exists, it's value will OVERRIDE this property.

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


LoadConfiguration Method (theIndexDirectory)

LoadConfiguration Method (theIndexDirectory)
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► LoadConfiguration(String)
Keyoti SearchUnit v6
Load configuration object values from the Configuration.xml file.
Declaration Syntax
C# Visual Basic
public virtual void LoadConfiguration(
    string theIndexDirectory
)
Public Overridable Sub LoadConfiguration (
    theIndexDirectory As String
)
Parameters
theIndexDirectory (String)
Remarks
This should be called before any code makes changes to the Configuration property, as this will overwrite any existing settings.

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


NextPageClicked Event

NextPageClicked Event
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► NextPageClicked
Keyoti SearchUnit v6
Fired when 'next page' link is clicked.
Declaration Syntax
C# Visual Basic
public event EventHandler NextPageClicked
Public Event NextPageClicked As EventHandler
Value
EventHandler

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


NextPageLink Property

NextPageLink Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► NextPageLink
Keyoti SearchUnit v6
Link to the next page of results, is empty string if on last page.
Declaration Syntax
C# Visual Basic
public virtual string NextPageLink { get; set; }
Public Overridable Property NextPageLink As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


NextPageLinkText Property

NextPageLinkText Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► NextPageLinkText
Keyoti SearchUnit v6
Link text to the next page of results
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public virtual string NextPageLinkText { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overridable Property NextPageLinkText As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


NoQueryTemplate Property

NoQueryTemplate Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► NoQueryTemplate
Keyoti SearchUnit v6
The template shown when there is no search query present when the page loads.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public virtual ITemplate NoQueryTemplate { get; set; }
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public Overridable Property NoQueryTemplate As ITemplate
    Get
    Set
Property Value
ITemplate

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


NoResultsTemplate Property

NoResultsTemplate Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► NoResultsTemplate
Keyoti SearchUnit v6
The template shown when there are no results.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public virtual ITemplate NoResultsTemplate { get; set; }
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public Overridable Property NoResultsTemplate As ITemplate
    Get
    Set
Property Value
ITemplate

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


NumberOfResults Property

NumberOfResults Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► NumberOfResults
Keyoti SearchUnit v6
The number of results found.
Declaration Syntax
C# Visual Basic
public virtual int NumberOfResults { get; }
Public Overridable ReadOnly Property NumberOfResults As Integer
    Get
Property Value
Int32
Remarks
This is not known until the NumberOfResultsFinalized event is fired

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


NumberOfResultsFinalized Event

NumberOfResultsFinalized Event
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► NumberOfResultsFinalized
Keyoti SearchUnit v6
Fired when the number of results is known and the NumberOfResults property is set.
Declaration Syntax
C# Visual Basic
public event EventHandler NumberOfResultsFinalized
Public Event NumberOfResultsFinalized As EventHandler
Value
EventHandler
Remarks
Only after this event can the NumberOfResults property be used.

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


NumberOfResultsPerPage Property

NumberOfResultsPerPage Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► NumberOfResultsPerPage
Keyoti SearchUnit v6
The number of results per page to show.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public virtual int NumberOfResultsPerPage { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overridable Property NumberOfResultsPerPage As Integer
    Get
    Set
Property Value
Int32

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


OnInit Method (e)

OnInit Method (e)
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► OnInit(EventArgs)
Keyoti SearchUnit v6
Called during the Init lifecycle stage
Declaration Syntax
C# Visual Basic
protected override void OnInit(
    EventArgs e
)
Protected Overrides Sub OnInit (
    e As EventArgs
)
Parameters
e (EventArgs)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


OnItemCreated Method (item, data)

OnItemCreated Method (item, data)
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► OnItemCreated(Control, Object)
Keyoti SearchUnit v6
Raises the ItemCreated event.
Declaration Syntax
C# Visual Basic
protected virtual void OnItemCreated(
    Control item,
    Object data
)
Protected Overridable Sub OnItemCreated (
    item As Control,
    data As Object
)
Parameters
item (Control)
The item that was created.
data (Object)
The data associated with the item, for a ResultItem this is likely to be either a Keyoti.SearchEngine.Search.ResultItem object, or a DataRow object (when a DataSource is set).

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


OnNextPageClicked Method (e)

OnNextPageClicked Method (e)
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► OnNextPageClicked(EventArgs)
Keyoti SearchUnit v6
Called when 'next page' link is clicked.
Declaration Syntax
C# Visual Basic
protected virtual void OnNextPageClicked(
    EventArgs e
)
Protected Overridable Sub OnNextPageClicked (
    e As EventArgs
)
Parameters
e (EventArgs)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


OnNumberOfResultsFinalized Method (e)

OnNumberOfResultsFinalized Method (e)
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► OnNumberOfResultsFinalized(EventArgs)
Keyoti SearchUnit v6
Called when 'next page' link is clicked.
Declaration Syntax
C# Visual Basic
protected virtual void OnNumberOfResultsFinalized(
    EventArgs e
)
Protected Overridable Sub OnNumberOfResultsFinalized (
    e As EventArgs
)
Parameters
e (EventArgs)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


OnPageXClicked Method (e)

OnPageXClicked Method (e)
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► OnPageXClicked(ResultsPageClickEventArgs)
Keyoti SearchUnit v6
Called when one of the specific page links in the bar is clicked.
Declaration Syntax
C# Visual Basic
protected virtual void OnPageXClicked(
    ResultsPageClickEventArgs e
)
Protected Overridable Sub OnPageXClicked (
    e As ResultsPageClickEventArgs
)
Parameters
e (ResultsPageClickEventArgs)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


OnPreRender Method (e)

OnPreRender Method (e)
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► OnPreRender(EventArgs)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
protected override void OnPreRender(
    EventArgs e
)
Protected Overrides Sub OnPreRender (
    e As EventArgs
)
Parameters
e (EventArgs)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


OnPrevPageClicked Method (e)

OnPrevPageClicked Method (e)
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► OnPrevPageClicked(EventArgs)
Keyoti SearchUnit v6
Called when 'previous page' link is clicked.
Declaration Syntax
C# Visual Basic
protected virtual void OnPrevPageClicked(
    EventArgs e
)
Protected Overridable Sub OnPrevPageClicked (
    e As EventArgs
)
Parameters
e (EventArgs)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


PageXClicked Event

PageXClicked Event
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► PageXClicked
Keyoti SearchUnit v6
Fired when one of the specific page links in the bar is clicked.
Declaration Syntax
C# Visual Basic
public event SearchResult..::..ResultsPageClickEventHandler PageXClicked
Public Event PageXClicked As SearchResult..::..ResultsPageClickEventHandler
Value
SearchResult..::..ResultsPageClickEventHandler

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


PreviousPageLink Property

PreviousPageLink Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► PreviousPageLink
Keyoti SearchUnit v6
Link to the previous page of results, is empty string if on first page.
Declaration Syntax
C# Visual Basic
public string PreviousPageLink { get; set; }
Public Property PreviousPageLink As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


PreviousPageLinkText Property

PreviousPageLinkText Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► PreviousPageLinkText
Keyoti SearchUnit v6
Link text to the previous page of results
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string PreviousPageLinkText { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property PreviousPageLinkText As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


PrevPageClicked Event

PrevPageClicked Event
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► PrevPageClicked
Keyoti SearchUnit v6
Fired when 'previous page' link is clicked.
Declaration Syntax
C# Visual Basic
public event EventHandler PrevPageClicked
Public Event PrevPageClicked As EventHandler
Value
EventHandler

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


QueryExpression Property

QueryExpression Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► QueryExpression
Keyoti SearchUnit v6
The query used in the search.
Declaration Syntax
C# Visual Basic
public virtual string QueryExpression { get; set; }
Public Overridable Property QueryExpression As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


RaisePostBackEvent Method (eventArgument)

RaisePostBackEvent Method (eventArgument)
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► RaisePostBackEvent(String)
Keyoti SearchUnit v6
Called when a post back occurrs related to this control.
Declaration Syntax
C# Visual Basic
public virtual void RaisePostBackEvent(
    string eventArgument
)
Public Overridable Sub RaisePostBackEvent (
    eventArgument As String
)
Parameters
eventArgument (String)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


RenderContents Method (output)

RenderContents Method (output)
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► RenderContents(HtmlTextWriter)
Keyoti SearchUnit v6
Renders this control.
Declaration Syntax
C# Visual Basic
protected override void RenderContents(
    HtmlTextWriter output
)
Protected Overrides Sub RenderContents (
    output As HtmlTextWriter
)
Parameters
output (HtmlTextWriter)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ResultItemTemplate Property

ResultItemTemplate Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► ResultItemTemplate
Keyoti SearchUnit v6
The template for result items.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public virtual ITemplate ResultItemTemplate { get; set; }
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public Overridable Property ResultItemTemplate As ITemplate
    Get
    Set
Property Value
ITemplate

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ResultPreviewerCharacterLimit Property

ResultPreviewerCharacterLimit Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► ResultPreviewerCharacterLimit
Keyoti SearchUnit v6
Maximum number of characters to show in the result preview text (limits the amount of text sent to the browser).
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public virtual int ResultPreviewerCharacterLimit { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overridable Property ResultPreviewerCharacterLimit As Integer
    Get
    Set
Property Value
Int32

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ResultPreviewerEnabled Property

ResultPreviewerEnabled Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► ResultPreviewerEnabled
Keyoti SearchUnit v6
Whether to allow the user to see an AJAX based preview of a result.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public virtual bool ResultPreviewerEnabled { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overridable Property ResultPreviewerEnabled As Boolean
    Get
    Set
Property Value
Boolean

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ResultPreviewerHighlightHTML Property

ResultPreviewerHighlightHTML Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► ResultPreviewerHighlightHTML
Keyoti SearchUnit v6
HTML code used to highlight hits in the result preview, {0} represents the hit.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public virtual string ResultPreviewerHighlightHTML { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overridable Property ResultPreviewerHighlightHTML As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ResultPreviewerLoadPlugin Property

ResultPreviewerLoadPlugin Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► ResultPreviewerLoadPlugin
Keyoti SearchUnit v6
Whether to load any plugin during an AJAX based preview of a result - this allows for serverside modification of the preview text.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public virtual bool ResultPreviewerLoadPlugin { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overridable Property ResultPreviewerLoadPlugin As Boolean
    Get
    Set
Property Value
Boolean

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ResultsPage Property

ResultsPage Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► ResultsPage
Keyoti SearchUnit v6
The results page number shown to the user.
Declaration Syntax
C# Visual Basic
public virtual int ResultsPage { get; set; }
Public Overridable Property ResultsPage As Integer
    Get
    Set
Property Value
Int32

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ResultSummaryType Property

ResultSummaryType Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► ResultSummaryType
Keyoti SearchUnit v6
What type of result summary to show
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public SearchResultControlSummaryOptions ResultSummaryType { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ResultSummaryType As SearchResultControlSummaryOptions
    Get
    Set
Property Value
SearchResultControlSummaryOptions

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SearchAgent Property

SearchAgent Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► SearchAgent
Keyoti SearchUnit v6
SearchAgent instance that will be used to search the index.
Declaration Syntax
C# Visual Basic
public virtual SearchAgent SearchAgent { get; set; }
Public Overridable Property SearchAgent As SearchAgent
    Get
    Set
Property Value
SearchAgent

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SearchOptions Property

SearchOptions Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► SearchOptions
Keyoti SearchUnit v6
The SearchOptions object controlling the search parameters.
Declaration Syntax
C# Visual Basic
public virtual SearchOptions SearchOptions { get; set; }
Public Overridable Property SearchOptions As SearchOptions
    Get
    Set
Property Value
SearchOptions
Remarks
Access this property in code-behind to force results from a particular location or content category, for example.

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SearchResults Property

SearchResults Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► SearchResults
Keyoti SearchUnit v6
Specifies the
Declaration Syntax
C# Visual Basic
public SearchResult SearchResults { set; }
Public WriteOnly Property SearchResults As SearchResult
    Set
Property Value
SearchResult

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


TagKey Property

TagKey Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► TagKey
Keyoti SearchUnit v6
See base.
Declaration Syntax
C# Visual Basic
protected override HtmlTextWriterTag TagKey { get; }
Protected Overrides ReadOnly Property TagKey As HtmlTextWriterTag
    Get
Property Value
HtmlTextWriterTag

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ToURIPattern Property

ToURIPattern Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► ToURIPattern
Keyoti SearchUnit v6
If necessary URLs in the results can be mapped to other domains/paths, specify the to match here, eg. http://www.domain.com
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public virtual string ToURIPattern { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overridable Property ToURIPattern As String
    Get
    Set
Property Value
String
Remarks
If an index is built against a web-site on localhost (or some other dev/staging server) for example then the URLs given in the search results will be incorrect when running in a production/live server environment. This simple mechanism allows results to be mapped from one URL to another.
Examples

Eg 1. A developer builds a web-site on http://localhost/internalApp/ and builds the search index - the search works fine on localhost, however when moving the app. to the live server the search results are linked to localhost. To correct this the developer maps the localhost URLs to the real server's, by setting:

Copy image Copy
FromURIPattern = "localhost/internalApp"
ToURIPattern = "ourcompanysinternalserver"
This causes URLs like http://localhost/internalApp/products/product1.aspx to be mapped to http://ourcompanysinternalserver/products/product1.aspx

Examples

Eg 2. A developer builds a web-site on http://staging.ourdomain.com/ and builds the search index - the search works fine on the staging server, however when moving the app. to the live server the search results are linked to staging.ourdomain.com. To correct this the developer maps the staging.ourdomain.com URLs to the real server's, by setting:

Copy image Copy
FromURIPattern = "staging.ourdomain.com"
ToURIPattern = "www.ourdomain.com"
This causes URLs like http://staging.ourdomain.com/default.aspx to be mapped to http://www.ourdomain.com/default.aspx

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ViewMode Property

ViewMode Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► ViewMode
Keyoti SearchUnit v6
The mode that the control is currently in.
Declaration Syntax
C# Visual Basic
public SearchResult..::..Mode ViewMode { get; set; }
Public Property ViewMode As SearchResult..::..Mode
    Get
    Set
Property Value
SearchResult..::..Mode

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SearchResult.Mode Enumeration

SearchResult..::..Mode Enumeration
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► SearchResult..::..Mode
Keyoti SearchUnit v6
The possible viewing modes that this control can be in.
Declaration Syntax
C# Visual Basic
public enum Mode
Public Enumeration Mode
Members
Member | Description
NoQuery |
Results |
InvalidSearch |
Unset |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SearchResult.ResultsPageClickEventHandler Delegate

SearchResult..::..ResultsPageClickEventHandler Delegate
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► SearchResult..::..ResultsPageClickEventHandler
Keyoti SearchUnit v6
Defines a handler for PageXClicked event.
Declaration Syntax
C# Visual Basic
public delegate void ResultsPageClickEventHandler(
    Object sender,
    ResultsPageClickEventArgs eventArgs
)
Public Delegate Sub ResultsPageClickEventHandler (
    sender As Object,
    eventArgs As ResultsPageClickEventArgs
)
Parameters
sender (Object)
eventArgs (ResultsPageClickEventArgs)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SearchResult.SearchResultItemEventHandler Delegate

SearchResult..::..SearchResultItemEventHandler Delegate
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► SearchResult..::..SearchResultItemEventHandler
Keyoti SearchUnit v6
Event handler for the ItemCreated event.
Declaration Syntax
C# Visual Basic
public delegate void SearchResultItemEventHandler(
    Object sender,
    SearchResultItemEventArgs e
)
Public Delegate Sub SearchResultItemEventHandler (
    sender As Object,
    e As SearchResultItemEventArgs
)
Parameters
sender (Object)
e (SearchResultItemEventArgs)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SearchResultControlSummaryOptions Enumeration

SearchResultControlSummaryOptions Enumeration
API Documentation ► Keyoti.SearchEngine.Web ► SearchResultControlSummaryOptions
Keyoti SearchUnit v6
Options for the result summaries.
Declaration Syntax
C# Visual Basic
public enum SearchResultControlSummaryOptions
Public Enumeration SearchResultControlSummaryOptions
Members
Member | Description
AsSetInConfiguration | Use the configuration file setting.
StaticMetaDescription | Where possible, takes the summary from the HTML meta tag - otherwise StaticBodyStart is used.
StaticBodyStart | Takes the summary from as the first X number of words in the document.
Dynamic | Generates the summary based on the keywords searched for.

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SearchResultItemEventArgs Class

SearchResultItemEventArgs Class
API Documentation ► Keyoti.SearchEngine.Web ► SearchResultItemEventArgs
Keyoti SearchUnit v6
Holds information about the SearchResult item event.
Declaration Syntax
C# Visual Basic
public class SearchResultItemEventArgs : EventArgs
Public Class SearchResultItemEventArgs
    Inherits EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SearchResultItemEventArgs(Control) | New instance.
 | SearchResultItemEventArgs(Control, Object) | New instance.
 | Data | The data associated with the item, if any (see remarks).
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Item | The item involved in the event, this is a ResultItem, Header, Footer, ErrorMessage or NoResults instance.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | SearchResultItemEventArgs

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SearchResultItemEventArgs Constructor

SearchResultItemEventArgs Constructor
API Documentation ► Keyoti.SearchEngine.Web ► SearchResultItemEventArgs ► SearchResultItemEventArgs()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | SearchResultItemEventArgs(Control) | New instance.
 | SearchResultItemEventArgs(Control, Object) | New instance.

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SearchResultItemEventArgs Constructor (item)

SearchResultItemEventArgs Constructor (item)
API Documentation ► Keyoti.SearchEngine.Web ► SearchResultItemEventArgs ► SearchResultItemEventArgs(Control)
Keyoti SearchUnit v6
New instance.
Declaration Syntax
C# Visual Basic
public SearchResultItemEventArgs(
    Control item
)
Public Sub New (
    item As Control
)
Parameters
item (Control)
The item that the event concerns.

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SearchResultItemEventArgs Constructor (item, dataRow)

SearchResultItemEventArgs Constructor (item, dataRow)
API Documentation ► Keyoti.SearchEngine.Web ► SearchResultItemEventArgs ► SearchResultItemEventArgs(Control, Object)
Keyoti SearchUnit v6
New instance.
Declaration Syntax
C# Visual Basic
public SearchResultItemEventArgs(
    Control item,
    Object dataRow
)
Public Sub New (
    item As Control,
    dataRow As Object
)
Parameters
item (Control)
The item that the event concerns.
dataRow (Object)
Any data that is associated with the item.

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Data Property

Data Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchResultItemEventArgs ► Data
Keyoti SearchUnit v6
The data associated with the item, if any (see remarks).
Declaration Syntax
C# Visual Basic
public virtual Object Data { get; }
Public Overridable ReadOnly Property Data As Object
    Get
Property Value
Object
Remarks
Typically this is useful when the ResultItem is created, this property will contain the data associated with the item, for a ResultItem this is likely to be either a Keyoti.SearchEngine.Search.ResultItem object, or a DataRow object (when a DataSource is set).

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Item Property

Item Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchResultItemEventArgs ► Item
Keyoti SearchUnit v6
The item involved in the event, this is a ResultItem, Header, Footer, ErrorMessage or NoResults instance.
Declaration Syntax
C# Visual Basic
public virtual Control Item { get; }
Public Overridable ReadOnly Property Item As Control
    Get
Property Value
Control

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SearchResultPreviewHelper Class

SearchResultPreviewHelper Class
API Documentation ► Keyoti.SearchEngine.Web ► SearchResultPreviewHelper
Keyoti SearchUnit v6
Handles search result preview requests
Declaration Syntax
C# Visual Basic
public class SearchResultPreviewHelper
Public Class SearchResultPreviewHelper
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SearchResultPreviewHelper()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetCachedConfig(ICache, String) |
 | GetDocumentText(Boolean, Int32, Configuration, String) | Gets the document text
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ProcessRequest(HttpContext) | Processes the request.
 | ToString()()()() | (Inherited from Object.)
 | Uri | The Uri of the document that was requested.
Inheritance Hierarchy
Object
SearchResultPreviewHelper

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SearchResultPreviewHelper Constructor

SearchResultPreviewHelper Constructor
API Documentation ► Keyoti.SearchEngine.Web ► SearchResultPreviewHelper ► SearchResultPreviewHelper()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public SearchResultPreviewHelper()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


GetCachedConfig Method (cache, indexDir)

GetCachedConfig Method (cache, indexDir)
API Documentation ► Keyoti.SearchEngine.Web ► SearchResultPreviewHelper ► GetCachedConfig(ICache, String)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public static Configuration GetCachedConfig(
    ICache cache,
    string indexDir
)
Public Shared Function GetCachedConfig (
    cache As ICache,
    indexDir As String
) As Configuration
Parameters
cache (ICache)
indexDir (String)
Return Value
Configuration

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


GetDocumentText Method (plugin, maxCharLength, config, uri)

GetDocumentText Method (plugin, maxCharLength, config, uri)
API Documentation ► Keyoti.SearchEngine.Web ► SearchResultPreviewHelper ► GetDocumentText(Boolean, Int32, Configuration, String)
Keyoti SearchUnit v6
Gets the document text
Declaration Syntax
C# Visual Basic
public string GetDocumentText(
    bool plugin,
    int maxCharLength,
    Configuration config,
    string uri
)
Public Function GetDocumentText (
    plugin As Boolean,
    maxCharLength As Integer,
    config As Configuration,
    uri As String
) As String
Parameters
plugin (Boolean)
Whether to load a plug-in
maxCharLength (Int32)
Maximum number of document chars to retrieve
config (Configuration)
The configuration
uri (String)
Return Value
String
Document plain text.

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ProcessRequest Method (ctx)

ProcessRequest Method (ctx)
API Documentation ► Keyoti.SearchEngine.Web ► SearchResultPreviewHelper ► ProcessRequest(HttpContext)
Keyoti SearchUnit v6
Processes the request.
Declaration Syntax
C# Visual Basic
public void ProcessRequest(
    HttpContext ctx
)
Public Sub ProcessRequest (
    ctx As HttpContext
)
Parameters
ctx (HttpContext)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Uri Property

Uri Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchResultPreviewHelper ► Uri
Keyoti SearchUnit v6
The Uri of the document that was requested.
Declaration Syntax
C# Visual Basic
public string Uri { get; }
Public ReadOnly Property Uri As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SearchSuggestions Class

SearchSuggestions Class
API Documentation ► Keyoti.SearchEngine.Web ► SearchSuggestions
Keyoti SearchUnit v6
Web Control that spell checks query expressions used for the searches, and displays suggestions if necessary/possible.
Declaration Syntax
C# Visual Basic
public class SearchSuggestions : WebControl,
    INamingContainer
Public Class SearchSuggestions
    Inherits WebControl
    Implements INamingContainer
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SearchSuggestions()()()() | Constructor
 | AccessKey | (Inherited from WebControl.)
 | Adapter | (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | (Inherited from Control.)
 | AddParsedSubObject(Object) | (Inherited from Control.)
 | ApplyStyle(Style) | (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | (Inherited from Control.)
 | Attributes | (Inherited from WebControl.)
 | BackColor | (Inherited from WebControl.)
 | BeginRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | BindingContainer | (Inherited from Control.)
 | BorderColor | (Inherited from WebControl.)
 | BorderStyle | (Inherited from WebControl.)
 | BorderWidth | (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | (Inherited from Control.)
 | ChildControlsCreated | (Inherited from Control.)
 | ClearCachedClientID()()()() | (Inherited from Control.)
 | ClearChildControlState()()()() | (Inherited from Control.)
 | ClearChildState()()()() | (Inherited from Control.)
 | ClearChildViewState()()()() | (Inherited from Control.)
 | ClearEffectiveClientIDMode()()()() | (Inherited from Control.)
 | ClientID | (Inherited from Control.)
 | ClientIDMode | (Inherited from Control.)
 | ClientIDSeparator | (Inherited from Control.)
 | Context | (Inherited from Control.)
 | Controls | (Inherited from Control.)
 | ControlStyle | (Inherited from WebControl.)
 | ControlStyleCreated | (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | (Inherited from WebControl.)
 | CreateChildControls()()()() | (Inherited from Control.)
 | CreateControlCollection()()()() | (Inherited from Control.)
 | CreateControlStyle()()()() | (Inherited from WebControl.)
 | CssClass | (Inherited from WebControl.)
 | CustomDictionaryPath | Path on the server where a custom dictionary is located.
 | DataBind()()()() | (Inherited from Control.)
 | DataBind(Boolean) | (Inherited from Control.)
 | DataBindChildren()()()() | (Inherited from Control.)
 | DataBinding | (Inherited from Control.)
 | DataItemContainer | (Inherited from Control.)
 | DataKeysContainer | (Inherited from Control.)
 | DesignMode | (Inherited from Control.)
 | Dispose()()()() | (Inherited from Control.)
 | Disposed | (Inherited from Control.)
 | Enabled | (Inherited from WebControl.)
 | EnableTheming | (Inherited from WebControl.)
 | EnableViewState | (Inherited from Control.)
 | EndRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | EnsureChildControls()()()() | (Inherited from Control.)
 | EnsureID()()()() | (Inherited from Control.)
 | Equals(Object) | (Inherited from Object.)
 | Events | (Inherited from Control.)
 | Finalize()()()() | (Inherited from Object.)
 | FindControl(String) | (Inherited from Control.)
 | FindControl(String, Int32) | (Inherited from Control.)
 | Focus()()()() | (Inherited from Control.)
 | Font | (Inherited from WebControl.)
 | ForeColor | (Inherited from WebControl.)
 | FoundSpellingError | Called when a spelling error is found - provides opportunity to adjust the suggestions.
 | GetDesignModeState()()()() | (Inherited from Control.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetRouteUrl(Object) | (Inherited from Control.)
 | GetRouteUrl(String, Object) | (Inherited from Control.)
 | GetRouteUrl(RouteValueDictionary) | (Inherited from Control.)
 | GetRouteUrl(String, RouteValueDictionary) | (Inherited from Control.)
 | GetType()()()() | (Inherited from Object.)
 | GetUniqueIDRelativeTo(Control) | (Inherited from Control.)
 | HasAttributes | (Inherited from WebControl.)
 | HasChildViewState | (Inherited from Control.)
 | HasControls()()()() | (Inherited from Control.)
 | HasEvents()()()() | (Inherited from Control.)
 | Height | (Inherited from WebControl.)
 | ID | (Inherited from Control.)
 | IdSeparator | (Inherited from Control.)
 | Init | (Inherited from Control.)
 | IsChildControlStateCleared | (Inherited from Control.)
 | IsEnabled | (Inherited from WebControl.)
 | IsLiteralContent()()()() | (Inherited from Control.)
 | IsTrackingViewState | (Inherited from Control.)
 | IsViewStateEnabled | (Inherited from Control.)
 | Language | The language to spell check in. Note for non-English, the extended version of Keyoti.SearchEngine.SuggestionsDictionary.dll must be used.
 | Load | (Inherited from Control.)
 | LoadControlState(Object) | (Inherited from Control.)
 | LoadViewState(Object) | (Inherited from WebControl.)
 | LoadViewStateByID | (Inherited from Control.)
 | MapPathSecure(String) | (Inherited from Control.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle(Style) | (Inherited from WebControl.)
 | MessageLabel | The message to be displayed before suggestions for a potentially mispelled word
 | Model |
 | NamingContainer | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | (Inherited from Control.)
 | OnDataBinding(EventArgs) | (Inherited from Control.)
 | OnFoundSpellingError(FoundSpellingErrorEventArgs) | Called when a misspelled word is found, raises the FoundSpellingError event.
 | OnInit(EventArgs) | (Inherited from Control.)
 | OnLoad(EventArgs) | Called when control loads. (Overrides Control.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | (Inherited from Control.)
 | OnSuggestedSearchExpressionCreated(EventArgs) | Called when the suggested query has been created by the control.
 | OnUnload(EventArgs) | (Inherited from Control.)
 | OpenFile(String) | (Inherited from Control.)
 | Page | (Inherited from Control.)
 | Parent | (Inherited from Control.)
 | PreRender | (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | (Inherited from Control.)
 | RemovedControl(Control) | (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control into the specified writer (Overrides WebControl.RenderContents(HtmlTextWriter).)
 | RenderControl(HtmlTextWriter) | (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingCompatibility | (Inherited from Control.)
 | ResolveAdapter()()()() | (Inherited from Control.)
 | ResolveClientUrl(String) | (Inherited from Control.)
 | ResolveUrl(String) | (Inherited from Control.)
 | SaveControlState()()()() | (Inherited from Control.)
 | SaveViewState()()()() | (Inherited from WebControl.)
 | SearchResultId | ID for the SearchResult control for which the query expression will be checked
 | SearchResults_PreRender(Object, EventArgs) | Called when SearchResult control is pre-rendering
 | SetDesignModeState(IDictionary) | (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | (Inherited from Control.)
 | SetTraceData(Object, Object) | (Inherited from Control.)
 | SetTraceData(Object, Object, Object) | (Inherited from Control.)
 | Site | (Inherited from Control.)
 | SkinID | (Inherited from WebControl.)
 | SpellingSuggestionSource | Where to look for spelling suggestions for erroneous words.
 | Style | (Inherited from WebControl.)
 | SuggestedLink | The link that will cause redirection to result page, with a different query expression, based on suggested query elements
 | SuggestedSearchExpression | The search expression that will be suggested to the user.
 | SuggestedSearchExpressionCreated | Fired when the suggested query expression has been created
 | SupportsDisabledAttribute | (Inherited from WebControl.)
 | TabIndex | (Inherited from WebControl.)
 | TagKey | (Inherited from WebControl.)
 | TagName | (Inherited from WebControl.)
 | TemplateControl | (Inherited from Control.)
 | TemplateSourceDirectory | (Inherited from Control.)
 | Text | Text that will be displayed before suggestions
 | ToolTip | (Inherited from WebControl.)
 | ToString()()()() | (Inherited from Object.)
 | TrackViewState()()()() | (Inherited from WebControl.)
 | UniqueID | (Inherited from Control.)
 | Unload | (Inherited from Control.)
 | ValidateRequestMode | (Inherited from Control.)
 | ViewState | (Inherited from Control.)
 | ViewStateIgnoresCase | (Inherited from Control.)
 | ViewStateMode | (Inherited from Control.)
 | Visible | (Inherited from Control.)
 | Width | (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | SearchSuggestions

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


SearchSuggestions Constructor

SearchSuggestions Constructor
API Documentation ► Keyoti.SearchEngine.Web ► SearchSuggestions ► SearchSuggestions()()()()
Keyoti SearchUnit v6
Constructor
Declaration Syntax
C# Visual Basic
public SearchSuggestions()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


CustomDictionaryPath Property

CustomDictionaryPath Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchSuggestions ► CustomDictionaryPath
Keyoti SearchUnit v6
Path on the server where a custom dictionary is located.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public virtual string CustomDictionaryPath { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overridable Property CustomDictionaryPath As String
    Get
    Set
Property Value
String
Remarks
A custom is a text file with a list of words, one per line. The words contained in it are used as acceptable spellings, and suggestions.

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


FoundSpellingError Event

FoundSpellingError Event
API Documentation ► Keyoti.SearchEngine.Web ► SearchSuggestions ► FoundSpellingError
Keyoti SearchUnit v6
Called when a spelling error is found - provides opportunity to adjust the suggestions.
Declaration Syntax
C# Visual Basic
public event FoundSpellingErrorEventHandler FoundSpellingError
Public Event FoundSpellingError As FoundSpellingErrorEventHandler
Value
FoundSpellingErrorEventHandler

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


Language Property

Language Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchSuggestions ► Language
Keyoti SearchUnit v6
The language to spell check in. Note for non-English, the extended version of Keyoti.SearchEngine.SuggestionsDictionary.dll must be used.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public LanguageType Language { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property Language As LanguageType
    Get
    Set
Property Value
LanguageType

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


MessageLabel Property

MessageLabel Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchSuggestions ► MessageLabel
Keyoti SearchUnit v6
The message to be displayed before suggestions for a potentially mispelled word
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public virtual KLabel MessageLabel { get; }
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public Overridable ReadOnly Property MessageLabel As KLabel
    Get
Property Value
KLabel

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


Model Property

Model Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchSuggestions ► Model
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public SearchSuggestionsModel Model { get; set; }
Public Property Model As SearchSuggestionsModel
    Get
    Set
Property Value
SearchSuggestionsModel

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


OnFoundSpellingError Method (eArgs)

OnFoundSpellingError Method (eArgs)
API Documentation ► Keyoti.SearchEngine.Web ► SearchSuggestions ► OnFoundSpellingError(FoundSpellingErrorEventArgs)
Keyoti SearchUnit v6
Called when a misspelled word is found, raises the FoundSpellingError event.
Declaration Syntax
C# Visual Basic
protected virtual void OnFoundSpellingError(
    FoundSpellingErrorEventArgs eArgs
)
Protected Overridable Sub OnFoundSpellingError (
    eArgs As FoundSpellingErrorEventArgs
)
Parameters
eArgs (FoundSpellingErrorEventArgs)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


OnLoad Method (e)

OnLoad Method (e)
API Documentation ► Keyoti.SearchEngine.Web ► SearchSuggestions ► OnLoad(EventArgs)
Keyoti SearchUnit v6
Called when control loads.
Declaration Syntax
C# Visual Basic
protected override void OnLoad(
    EventArgs e
)
Protected Overrides Sub OnLoad (
    e As EventArgs
)
Parameters
e (EventArgs)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


OnSuggestedSearchExpressionCreated Method (e)

OnSuggestedSearchExpressionCreated Method (e)
API Documentation ► Keyoti.SearchEngine.Web ► SearchSuggestions ► OnSuggestedSearchExpressionCreated(EventArgs)
Keyoti SearchUnit v6
Called when the suggested query has been created by the control.
Declaration Syntax
C# Visual Basic
protected virtual void OnSuggestedSearchExpressionCreated(
    EventArgs e
)
Protected Overridable Sub OnSuggestedSearchExpressionCreated (
    e As EventArgs
)
Parameters
e (EventArgs)
Remarks
SuggestedSearchExpression property will now contain the suggestion.

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


RenderContents Method (output)

RenderContents Method (output)
API Documentation ► Keyoti.SearchEngine.Web ► SearchSuggestions ► RenderContents(HtmlTextWriter)
Keyoti SearchUnit v6
Renders the contents of the control into the specified writer
Declaration Syntax
C# Visual Basic
protected override void RenderContents(
    HtmlTextWriter output
)
Protected Overrides Sub RenderContents (
    output As HtmlTextWriter
)
Parameters
output (HtmlTextWriter)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


SearchResultId Property

SearchResultId Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchSuggestions ► SearchResultId
Keyoti SearchUnit v6
ID for the SearchResult control for which the query expression will be checked
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public virtual string SearchResultId { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overridable Property SearchResultId As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


SearchResults_PreRender Method (sender, e)

SearchResults_PreRender Method (sender, e)
API Documentation ► Keyoti.SearchEngine.Web ► SearchSuggestions ► SearchResults_PreRender(Object, EventArgs)
Keyoti SearchUnit v6
Called when SearchResult control is pre-rendering
Declaration Syntax
C# Visual Basic
protected virtual void SearchResults_PreRender(
    Object sender,
    EventArgs e
)
Protected Overridable Sub SearchResults_PreRender (
    sender As Object,
    e As EventArgs
)
Parameters
sender (Object)
The SearchResult control
e (EventArgs)
EventArgs

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


SpellingSuggestionSource Property

SpellingSuggestionSource Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchSuggestions ► SpellingSuggestionSource
Keyoti SearchUnit v6
Where to look for spelling suggestions for erroneous words.
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public SpellingSuggestionSource SpellingSuggestionSource { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property SpellingSuggestionSource As SpellingSuggestionSource
    Get
    Set
Property Value
SpellingSuggestionSource
Remarks
Care should be taken when using any option with "SearchLexicon" as this can become slow when the lexicon becomes very large (>100,000 entries).

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


SuggestedLink Property

SuggestedLink Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchSuggestions ► SuggestedLink
Keyoti SearchUnit v6
The link that will cause redirection to result page, with a different query expression, based on suggested query elements
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public virtual HyperLink SuggestedLink { get; }
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public Overridable ReadOnly Property SuggestedLink As HyperLink
    Get
Property Value
HyperLink

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


SuggestedSearchExpression Property

SuggestedSearchExpression Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchSuggestions ► SuggestedSearchExpression
Keyoti SearchUnit v6
The search expression that will be suggested to the user.
Declaration Syntax
C# Visual Basic
public virtual string SuggestedSearchExpression { get; set; }
Public Overridable Property SuggestedSearchExpression As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


SuggestedSearchExpressionCreated Event

SuggestedSearchExpressionCreated Event
API Documentation ► Keyoti.SearchEngine.Web ► SearchSuggestions ► SuggestedSearchExpressionCreated
Keyoti SearchUnit v6
Fired when the suggested query expression has been created
Declaration Syntax
C# Visual Basic
public event EventHandler SuggestedSearchExpressionCreated
Public Event SuggestedSearchExpressionCreated As EventHandler
Value
EventHandler

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


Text Property

Text Property
API Documentation ► Keyoti.SearchEngine.Web ► SearchSuggestions ► Text
Keyoti SearchUnit v6
Text that will be displayed before suggestions
Declaration Syntax
C# Visual Basic
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public virtual string Text { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overridable Property Text As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


SystemWebCachingCache Class

SystemWebCachingCache Class
API Documentation ► Keyoti.SearchEngine.Web ► SystemWebCachingCache
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public class SystemWebCachingCache : ICache
Public Class SystemWebCachingCache
    Implements ICache
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SystemWebCachingCache(Cache) |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
SystemWebCachingCache

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SystemWebCachingCache Constructor (cache)

SystemWebCachingCache Constructor (cache)
API Documentation ► Keyoti.SearchEngine.Web ► SystemWebCachingCache ► SystemWebCachingCache(Cache)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public SystemWebCachingCache(
    Cache cache
)
Public Sub New (
    cache As Cache
)
Parameters
cache (Cache)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Utils Class

Utils Class
API Documentation ► Keyoti.SearchEngine.Web ► Utils
Keyoti SearchUnit v6
Various utilities.
Declaration Syntax
C# Visual Basic
public class Utils
Public Class Utils
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Utils()()()() |
 | AppSetting(String) | Reads a web.config setting.
 | Equals(Object) | (Inherited from Object.)
 | EscapeAMPsInResourceURL(String) | Changes & to &amp; in resource URLs
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetPostBackEventReference(Page, Control, String) | Gets a post back reference from the page
 | GetPostBackEventReference(Page, Control) | Gets a post back reference from the page
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
Utils

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Utils Constructor

Utils Constructor
API Documentation ► Keyoti.SearchEngine.Web ► Utils ► Utils()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public Utils()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


AppSetting Method (key)

AppSetting Method (key)
API Documentation ► Keyoti.SearchEngine.Web ► Utils ► AppSetting(String)
Keyoti SearchUnit v6
Reads a web.config setting.
Declaration Syntax
C# Visual Basic
public static string AppSetting(
    string key
)
Public Shared Function AppSetting (
    key As String
) As String
Parameters
key (String)
Settng key
Return Value
String
Setting value

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


EscapeAMPsInResourceURL Method (url)

EscapeAMPsInResourceURL Method (url)
API Documentation ► Keyoti.SearchEngine.Web ► Utils ► EscapeAMPsInResourceURL(String)
Keyoti SearchUnit v6
Changes & to &amp; in resource URLs
Declaration Syntax
C# Visual Basic
public static string EscapeAMPsInResourceURL(
    string url
)
Public Shared Function EscapeAMPsInResourceURL (
    url As String
) As String
Parameters
url (String)
Return Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


GetPostBackEventReference Method

GetPostBackEventReference Method
API Documentation ► Keyoti.SearchEngine.Web ► Utils ► GetPostBackEventReference()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GetPostBackEventReference(Page, Control, String) | Gets a post back reference from the page
 | GetPostBackEventReference(Page, Control) | Gets a post back reference from the page

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


GetPostBackEventReference Method (page, parent)

GetPostBackEventReference Method (page, parent)
API Documentation ► Keyoti.SearchEngine.Web ► Utils ► GetPostBackEventReference(Page, Control)
Keyoti SearchUnit v6
Gets a post back reference from the page
Declaration Syntax
C# Visual Basic
public static string GetPostBackEventReference(
    Page page,
    Control parent
)
Public Shared Function GetPostBackEventReference (
    page As Page,
    parent As Control
) As String
Parameters
page (Page)
parent (Control)
Return Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


GetPostBackEventReference Method (page, parent, argument)

GetPostBackEventReference Method (page, parent, argument)
API Documentation ► Keyoti.SearchEngine.Web ► Utils ► GetPostBackEventReference(Page, Control, String)
Keyoti SearchUnit v6
Gets a post back reference from the page
Declaration Syntax
C# Visual Basic
public static string GetPostBackEventReference(
    Page page,
    Control parent,
    string argument
)
Public Shared Function GetPostBackEventReference (
    page As Page,
    parent As Control,
    argument As String
) As String
Parameters
page (Page)
parent (Control)
argument (String)
Return Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Keyoti.SearchEngine.Web.AjaxService Namespace

Keyoti.SearchEngine.Web.AjaxService Namespace
API Documentation ► Keyoti.SearchEngine.Web.AjaxService
Keyoti SearchUnit v6
Types
All Types Classes
Icon | Type | Description
 | CategoryListWrapper |
 | SearchCloudWrapper |
 | SearchResultWrapper |
 | StringAndIDWrapper |
 | StringWrapper |
 | SuggestionPairListWrapper |


CategoryListWrapper Class

CategoryListWrapper Class
API Documentation ► Keyoti.SearchEngine.Web.AjaxService ► CategoryListWrapper
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public class CategoryListWrapper
Public Class CategoryListWrapper
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CategoryListWrapper()()()() |
 | CategoriesEnabled |
 | ContentCategories |
 | Equals(Object) | (Inherited from Object.)
 | Exception |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | LocationCategories |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
CategoryListWrapper

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


CategoryListWrapper Constructor

CategoryListWrapper Constructor
API Documentation ► Keyoti.SearchEngine.Web.AjaxService ► CategoryListWrapper ► CategoryListWrapper()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public CategoryListWrapper()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


CategoriesEnabled Property

CategoriesEnabled Property
API Documentation ► Keyoti.SearchEngine.Web.AjaxService ► CategoryListWrapper ► CategoriesEnabled
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public bool CategoriesEnabled { get; set; }
Public Property CategoriesEnabled As Boolean
    Get
    Set
Property Value
Boolean

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ContentCategories Property

ContentCategories Property
API Documentation ► Keyoti.SearchEngine.Web.AjaxService ► CategoryListWrapper ► ContentCategories
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public List<StringAndIDWrapper> ContentCategories { get; set; }
Public Property ContentCategories As List(Of StringAndIDWrapper)
    Get
    Set
Property Value
List <(Of <(<' StringAndIDWrapper >)>)>

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Exception Property

Exception Property
API Documentation ► Keyoti.SearchEngine.Web.AjaxService ► CategoryListWrapper ► Exception
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public string Exception { get; set; }
Public Property Exception As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


LocationCategories Property

LocationCategories Property
API Documentation ► Keyoti.SearchEngine.Web.AjaxService ► CategoryListWrapper ► LocationCategories
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public List<StringAndIDWrapper> LocationCategories { get; set; }
Public Property LocationCategories As List(Of StringAndIDWrapper)
    Get
    Set
Property Value
List <(Of <(<' StringAndIDWrapper >)>)>

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SearchCloudWrapper Class

SearchCloudWrapper Class
API Documentation ► Keyoti.SearchEngine.Web.AjaxService ► SearchCloudWrapper
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public class SearchCloudWrapper
Public Class SearchCloudWrapper
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SearchCloudWrapper()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Exception |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Items |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
SearchCloudWrapper

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SearchCloudWrapper Constructor

SearchCloudWrapper Constructor
API Documentation ► Keyoti.SearchEngine.Web.AjaxService ► SearchCloudWrapper ► SearchCloudWrapper()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public SearchCloudWrapper()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Exception Property

Exception Property
API Documentation ► Keyoti.SearchEngine.Web.AjaxService ► SearchCloudWrapper ► Exception
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public string Exception { get; set; }
Public Property Exception As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Items Property

Items Property
API Documentation ► Keyoti.SearchEngine.Web.AjaxService ► SearchCloudWrapper ► Items
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public List<AutoCompletePopularSearchHelper..::..QueryTally> Items { get; set; }
Public Property Items As List(Of AutoCompletePopularSearchHelper..::..QueryTally)
    Get
    Set
Property Value
List <(Of <(<' AutoCompletePopularSearchHelper..::..QueryTally >)>)>

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SearchResultWrapper Class

SearchResultWrapper Class
API Documentation ► Keyoti.SearchEngine.Web.AjaxService ► SearchResultWrapper
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public class SearchResultWrapper
Public Class SearchResultWrapper
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SearchResultWrapper()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Exception |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IgnoredWords |
 | LiveDataSamples |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NumberOfResults |
 | QueryKeywords |
 | Results |
 | SuggestedSearchExpression |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
SearchResultWrapper

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SearchResultWrapper Constructor

SearchResultWrapper Constructor
API Documentation ► Keyoti.SearchEngine.Web.AjaxService ► SearchResultWrapper ► SearchResultWrapper()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public SearchResultWrapper()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Exception Property

Exception Property
API Documentation ► Keyoti.SearchEngine.Web.AjaxService ► SearchResultWrapper ► Exception
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public string Exception { get; set; }
Public Property Exception As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


IgnoredWords Property

IgnoredWords Property
API Documentation ► Keyoti.SearchEngine.Web.AjaxService ► SearchResultWrapper ► IgnoredWords
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public StringList IgnoredWords { get; set; }
Public Property IgnoredWords As StringList
    Get
    Set
Property Value
StringList

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


LiveDataSamples Property

LiveDataSamples Property
API Documentation ► Keyoti.SearchEngine.Web.AjaxService ► SearchResultWrapper ► LiveDataSamples
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public LiveDataSample[] LiveDataSamples { get; set; }
Public Property LiveDataSamples As LiveDataSample()
    Get
    Set
Property Value
array< LiveDataSample >[]()[][]

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


NumberOfResults Property

NumberOfResults Property
API Documentation ► Keyoti.SearchEngine.Web.AjaxService ► SearchResultWrapper ► NumberOfResults
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public int NumberOfResults { get; set; }
Public Property NumberOfResults As Integer
    Get
    Set
Property Value
Int32

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


QueryKeywords Property

QueryKeywords Property
API Documentation ► Keyoti.SearchEngine.Web.AjaxService ► SearchResultWrapper ► QueryKeywords
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public string[] QueryKeywords { get; set; }
Public Property QueryKeywords As String()
    Get
    Set
Property Value
array< String >[]()[][]

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Results Property

Results Property
API Documentation ► Keyoti.SearchEngine.Web.AjaxService ► SearchResultWrapper ► Results
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public SearchResult Results { get; set; }
Public Property Results As SearchResult
    Get
    Set
Property Value
SearchResult

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SuggestedSearchExpression Property

SuggestedSearchExpression Property
API Documentation ► Keyoti.SearchEngine.Web.AjaxService ► SearchResultWrapper ► SuggestedSearchExpression
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public string SuggestedSearchExpression { get; set; }
Public Property SuggestedSearchExpression As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


StringAndIDWrapper Class

StringAndIDWrapper Class
API Documentation ► Keyoti.SearchEngine.Web.AjaxService ► StringAndIDWrapper
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public class StringAndIDWrapper
Public Class StringAndIDWrapper
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StringAndIDWrapper()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Exception |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Id |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | Value |
Inheritance Hierarchy
Object
StringAndIDWrapper

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


StringAndIDWrapper Constructor

StringAndIDWrapper Constructor
API Documentation ► Keyoti.SearchEngine.Web.AjaxService ► StringAndIDWrapper ► StringAndIDWrapper()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public StringAndIDWrapper()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Exception Property

Exception Property
API Documentation ► Keyoti.SearchEngine.Web.AjaxService ► StringAndIDWrapper ► Exception
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public string Exception { get; set; }
Public Property Exception As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Id Property

Id Property
API Documentation ► Keyoti.SearchEngine.Web.AjaxService ► StringAndIDWrapper ► Id
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public int Id { get; set; }
Public Property Id As Integer
    Get
    Set
Property Value
Int32

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Value Property

Value Property
API Documentation ► Keyoti.SearchEngine.Web.AjaxService ► StringAndIDWrapper ► Value
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public string Value { get; set; }
Public Property Value As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


StringWrapper Class

StringWrapper Class
API Documentation ► Keyoti.SearchEngine.Web.AjaxService ► StringWrapper
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public class StringWrapper
Public Class StringWrapper
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StringWrapper()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Exception |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | Value |
Inheritance Hierarchy
Object
StringWrapper

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


StringWrapper Constructor

StringWrapper Constructor
API Documentation ► Keyoti.SearchEngine.Web.AjaxService ► StringWrapper ► StringWrapper()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public StringWrapper()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Exception Property

Exception Property
API Documentation ► Keyoti.SearchEngine.Web.AjaxService ► StringWrapper ► Exception
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public string Exception { get; set; }
Public Property Exception As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Value Property

Value Property
API Documentation ► Keyoti.SearchEngine.Web.AjaxService ► StringWrapper ► Value
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public string Value { get; set; }
Public Property Value As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SuggestionPairListWrapper Class

SuggestionPairListWrapper Class
API Documentation ► Keyoti.SearchEngine.Web.AjaxService ► SuggestionPairListWrapper
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public class SuggestionPairListWrapper
Public Class SuggestionPairListWrapper
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SuggestionPairListWrapper()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Exception |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Items |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
SuggestionPairListWrapper

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SuggestionPairListWrapper Constructor

SuggestionPairListWrapper Constructor
API Documentation ► Keyoti.SearchEngine.Web.AjaxService ► SuggestionPairListWrapper ► SuggestionPairListWrapper()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public SuggestionPairListWrapper()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Exception Property

Exception Property
API Documentation ► Keyoti.SearchEngine.Web.AjaxService ► SuggestionPairListWrapper ► Exception
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public string Exception { get; set; }
Public Property Exception As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Items Property

Items Property
API Documentation ► Keyoti.SearchEngine.Web.AjaxService ► SuggestionPairListWrapper ► Items
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public List<SearchBoxAutoCompleteHelper..::..SuggestionResultPair> Items { get; set; }
Public Property Items As List(Of SearchBoxAutoCompleteHelper..::..SuggestionResultPair)
    Get
    Set
Property Value
List <(Of <(<' SearchBoxAutoCompleteHelper..::..SuggestionResultPair >)>)>

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Keyoti.SearchEngine.Web.AjaxService.WCF Namespace

Keyoti.SearchEngine.Web.AjaxService.WCF Namespace
API Documentation ► Keyoti.SearchEngine.Web.AjaxService.WCF
Keyoti SearchUnit v6
Types
All Types Classes Interfaces
Icon | Type | Description
 | ISearch |
 | MemoryCacheBasedCache |
 | SearchService |


ISearch Interface

ISearch Interface
API Documentation ► Keyoti.SearchEngine.Web.AjaxService.WCF ► ISearch
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public interface ISearch
Public Interface ISearch
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetAutoComplete(Boolean, String, String, String, String, String, Boolean) |
 | GetLocationAndContentCategories(String) |
 | GetPreviewText(String, String, Int32, Int32) |
 | GetResults(String, String, Int32, Int32, String, array<String>[]()[][], FilterCollection, array<String>[]()[][], String, String, String, String) |
 | GetSearchCloud(String, Int32) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


GetAutoComplete Method (hd, id, n, p, q, s, tl)

GetAutoComplete Method (hd, id, n, p, q, s, tl)
API Documentation ► Keyoti.SearchEngine.Web.AjaxService.WCF ► ISearch ► GetAutoComplete(Boolean, String, String, String, String, String, Boolean)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
SuggestionPairListWrapper GetAutoComplete(
    bool hd,
    string id,
    string n,
    string p,
    string q,
    string s,
    bool tl
)
Function GetAutoComplete (
    hd As Boolean,
    id As String,
    n As String,
    p As String,
    q As String,
    s As String,
    tl As Boolean
) As SuggestionPairListWrapper
Parameters
hd (Boolean)
id (String)
n (String)
p (String)
q (String)
s (String)
tl (Boolean)
Return Value
SuggestionPairListWrapper

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


GetLocationAndContentCategories Method (indexDirectory)

GetLocationAndContentCategories Method (indexDirectory)
API Documentation ► Keyoti.SearchEngine.Web.AjaxService.WCF ► ISearch ► GetLocationAndContentCategories(String)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
CategoryListWrapper GetLocationAndContentCategories(
    string indexDirectory
)
Function GetLocationAndContentCategories (
    indexDirectory As String
) As CategoryListWrapper
Parameters
indexDirectory (String)
Return Value
CategoryListWrapper

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


GetPreviewText Method (indexDirectory, u, p, mx)

GetPreviewText Method (indexDirectory, u, p, mx)
API Documentation ► Keyoti.SearchEngine.Web.AjaxService.WCF ► ISearch ► GetPreviewText(String, String, Int32, Int32)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
StringWrapper GetPreviewText(
    string indexDirectory,
    string u,
    int p,
    int mx
)
Function GetPreviewText (
    indexDirectory As String,
    u As String,
    p As Integer,
    mx As Integer
) As StringWrapper
Parameters
indexDirectory (String)
u (String)
p (Int32)
mx (Int32)
Return Value
StringWrapper

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


GetResults Method (indexDirectory, query, resultPage, resultsPerPage, locationName, contentNames, filterCollection, securityGroupNames, sortBy, language, customDictionaryPath, spellingSuggestionSource)

GetResults Method (indexDirectory, query, resultPage, resultsPerPage, locationName, contentNames, filterCollection, securityGroupNames, sortBy, language, customDictionaryPath, spellingSuggestionSource)
API Documentation ► Keyoti.SearchEngine.Web.AjaxService.WCF ► ISearch ► GetResults(String, String, Int32, Int32, String, array<String>[]()[][], FilterCollection, array<String>[]()[][], String, String, String, String)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
SearchResultWrapper GetResults(
    string indexDirectory,
    string query,
    int resultPage,
    int resultsPerPage,
    string locationName,
    string[] contentNames,
    FilterCollection filterCollection,
    string[] securityGroupNames,
    string sortBy,
    string language,
    string customDictionaryPath,
    string spellingSuggestionSource
)
Function GetResults (
    indexDirectory As String,
    query As String,
    resultPage As Integer,
    resultsPerPage As Integer,
    locationName As String,
    contentNames As String(),
    filterCollection As FilterCollection,
    securityGroupNames As String(),
    sortBy As String,
    language As String,
    customDictionaryPath As String,
    spellingSuggestionSource As String
) As SearchResultWrapper
Parameters
indexDirectory (String)
query (String)
resultPage (Int32)
resultsPerPage (Int32)
locationName (String)
contentNames (array< String >[]()[][])
filterCollection (FilterCollection)
securityGroupNames (array< String >[]()[][])
sortBy (String)
language (String)
customDictionaryPath (String)
spellingSuggestionSource (String)
Return Value
SearchResultWrapper

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


GetSearchCloud Method (indexDirectory, numberOfQueries)

GetSearchCloud Method (indexDirectory, numberOfQueries)
API Documentation ► Keyoti.SearchEngine.Web.AjaxService.WCF ► ISearch ► GetSearchCloud(String, Int32)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
SearchCloudWrapper GetSearchCloud(
    string indexDirectory,
    int numberOfQueries
)
Function GetSearchCloud (
    indexDirectory As String,
    numberOfQueries As Integer
) As SearchCloudWrapper
Parameters
indexDirectory (String)
numberOfQueries (Int32)
Return Value
SearchCloudWrapper

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


MemoryCacheBasedCache Class

MemoryCacheBasedCache Class
API Documentation ► Keyoti.SearchEngine.Web.AjaxService.WCF ► MemoryCacheBasedCache
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public class MemoryCacheBasedCache : ICache
Public Class MemoryCacheBasedCache
    Implements ICache
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | MemoryCacheBasedCache(MemoryCache) |
 | AddItem(String, Object, String, TimeSpan) |
 | AddItem(String, Object) |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetItem(String) |
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
MemoryCacheBasedCache

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


MemoryCacheBasedCache Constructor (memoryCache)

MemoryCacheBasedCache Constructor (memoryCache)
API Documentation ► Keyoti.SearchEngine.Web.AjaxService.WCF ► MemoryCacheBasedCache ► MemoryCacheBasedCache(MemoryCache)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public MemoryCacheBasedCache(
    MemoryCache memoryCache
)
Public Sub New (
    memoryCache As MemoryCache
)
Parameters
memoryCache (MemoryCache)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


AddItem Method

AddItem Method
API Documentation ► Keyoti.SearchEngine.Web.AjaxService.WCF ► MemoryCacheBasedCache ► AddItem()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | AddItem(String, Object, String, TimeSpan) |
 | AddItem(String, Object) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


AddItem Method (key, item)

AddItem Method (key, item)
API Documentation ► Keyoti.SearchEngine.Web.AjaxService.WCF ► MemoryCacheBasedCache ► AddItem(String, Object)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public void AddItem(
    string key,
    Object item
)
Public Sub AddItem (
    key As String,
    item As Object
)
Parameters
key (String)
item (Object)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


AddItem Method (key, item, dependency, expiration)

AddItem Method (key, item, dependency, expiration)
API Documentation ► Keyoti.SearchEngine.Web.AjaxService.WCF ► MemoryCacheBasedCache ► AddItem(String, Object, String, TimeSpan)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public void AddItem(
    string key,
    Object item,
    string dependency,
    TimeSpan expiration
)
Public Sub AddItem (
    key As String,
    item As Object,
    dependency As String,
    expiration As TimeSpan
)
Parameters
key (String)
item (Object)
dependency (String)
expiration (TimeSpan)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


GetItem Method (key)

GetItem Method (key)
API Documentation ► Keyoti.SearchEngine.Web.AjaxService.WCF ► MemoryCacheBasedCache ► GetItem(String)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public Object GetItem(
    string key
)
Public Function GetItem (
    key As String
) As Object
Parameters
key (String)
Return Value
Object

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SearchService Class

SearchService Class
API Documentation ► Keyoti.SearchEngine.Web.AjaxService.WCF ► SearchService
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public class SearchService : ISearch
Public Class SearchService
    Implements ISearch
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SearchService()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetAutoComplete(Boolean, String, String, String, String, String, Boolean) |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetLocationAndContentCategories(String) |
 | GetPreviewText(String, String, Int32, Int32) |
 | GetResults(String, String, Int32, Int32, String, array<String>[]()[][], FilterCollection, array<String>[]()[][], String, String, String, String) |
 | GetSearchCloud(String, Int32) |
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ServerAddress |
 | ServerName |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
SearchService

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SearchService Constructor

SearchService Constructor
API Documentation ► Keyoti.SearchEngine.Web.AjaxService.WCF ► SearchService ► SearchService()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public SearchService()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


GetAutoComplete Method (hd, id, n, p, q, s, tl)

GetAutoComplete Method (hd, id, n, p, q, s, tl)
API Documentation ► Keyoti.SearchEngine.Web.AjaxService.WCF ► SearchService ► GetAutoComplete(Boolean, String, String, String, String, String, Boolean)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public SuggestionPairListWrapper GetAutoComplete(
    bool hd,
    string id,
    string n,
    string p,
    string q,
    string s,
    bool tl
)
Public Function GetAutoComplete (
    hd As Boolean,
    id As String,
    n As String,
    p As String,
    q As String,
    s As String,
    tl As Boolean
) As SuggestionPairListWrapper
Parameters
hd (Boolean)
id (String)
n (String)
p (String)
q (String)
s (String)
tl (Boolean)
Return Value
SuggestionPairListWrapper

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


GetLocationAndContentCategories Method (indexDirectory)

GetLocationAndContentCategories Method (indexDirectory)
API Documentation ► Keyoti.SearchEngine.Web.AjaxService.WCF ► SearchService ► GetLocationAndContentCategories(String)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public CategoryListWrapper GetLocationAndContentCategories(
    string indexDirectory
)
Public Function GetLocationAndContentCategories (
    indexDirectory As String
) As CategoryListWrapper
Parameters
indexDirectory (String)
Return Value
CategoryListWrapper

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


GetPreviewText Method (indexDirectory, u, p, mx)

GetPreviewText Method (indexDirectory, u, p, mx)
API Documentation ► Keyoti.SearchEngine.Web.AjaxService.WCF ► SearchService ► GetPreviewText(String, String, Int32, Int32)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public StringWrapper GetPreviewText(
    string indexDirectory,
    string u,
    int p,
    int mx
)
Public Function GetPreviewText (
    indexDirectory As String,
    u As String,
    p As Integer,
    mx As Integer
) As StringWrapper
Parameters
indexDirectory (String)
u (String)
p (Int32)
mx (Int32)
Return Value
StringWrapper

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


GetResults Method (indexDirectory, query, resultPage, resultsPerPage, locationName, contentNames, filterCollection, securityGroupNames, sortBy, language, customDictionaryPath, spellingSuggestionSource)

GetResults Method (indexDirectory, query, resultPage, resultsPerPage, locationName, contentNames, filterCollection, securityGroupNames, sortBy, language, customDictionaryPath, spellingSuggestionSource)
API Documentation ► Keyoti.SearchEngine.Web.AjaxService.WCF ► SearchService ► GetResults(String, String, Int32, Int32, String, array<String>[]()[][], FilterCollection, array<String>[]()[][], String, String, String, String)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public SearchResultWrapper GetResults(
    string indexDirectory,
    string query,
    int resultPage,
    int resultsPerPage,
    string locationName,
    string[] contentNames,
    FilterCollection filterCollection,
    string[] securityGroupNames,
    string sortBy,
    string language,
    string customDictionaryPath,
    string spellingSuggestionSource
)
Public Function GetResults (
    indexDirectory As String,
    query As String,
    resultPage As Integer,
    resultsPerPage As Integer,
    locationName As String,
    contentNames As String(),
    filterCollection As FilterCollection,
    securityGroupNames As String(),
    sortBy As String,
    language As String,
    customDictionaryPath As String,
    spellingSuggestionSource As String
) As SearchResultWrapper
Parameters
indexDirectory (String)
query (String)
resultPage (Int32)
resultsPerPage (Int32)
locationName (String)
contentNames (array< String >[]()[][])
filterCollection (FilterCollection)
securityGroupNames (array< String >[]()[][])
sortBy (String)
language (String)
customDictionaryPath (String)
spellingSuggestionSource (String)
Return Value
SearchResultWrapper

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


GetSearchCloud Method (indexDirectory, numberOfQueries)

GetSearchCloud Method (indexDirectory, numberOfQueries)
API Documentation ► Keyoti.SearchEngine.Web.AjaxService.WCF ► SearchService ► GetSearchCloud(String, Int32)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public SearchCloudWrapper GetSearchCloud(
    string indexDirectory,
    int numberOfQueries
)
Public Function GetSearchCloud (
    indexDirectory As String,
    numberOfQueries As Integer
) As SearchCloudWrapper
Parameters
indexDirectory (String)
numberOfQueries (Int32)
Return Value
SearchCloudWrapper

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ServerAddress Property

ServerAddress Property
API Documentation ► Keyoti.SearchEngine.Web.AjaxService.WCF ► SearchService ► ServerAddress
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public string ServerAddress { get; }
Public ReadOnly Property ServerAddress As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ServerName Property

ServerName Property
API Documentation ► Keyoti.SearchEngine.Web.AjaxService.WCF ► SearchService ► ServerName
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public string ServerName { get; }
Public ReadOnly Property ServerName As String
    Get
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Keyoti.SearchEngine.Web.Templates Namespace

Keyoti.SearchEngine.Web.Templates Namespace
API Documentation ► Keyoti.SearchEngine.Web.Templates
Keyoti SearchUnit v6
Default templates for SearchResult control.
Types
All Types Classes
Icon | Type | Description
 | DefaultErrorMessageTemplate | The default template used for the error message.
 | DefaultFeaturedResultItemTemplate | The default template used for the featuredResult item.
 | DefaultFeaturedResultsHeaderTemplate | The default template used for the featured results header.
 | DefaultFooterTemplate | The default template used for the footer.
 | DefaultHeaderTemplate | The default template used for the header.
 | DefaultNoQueryTemplate | The default template used for the no query item.
 | DefaultNoResultsTemplate | The default template used for the no results message.
 | DefaultResultItemTemplate | The default template used for the result item.
 | FeaturedHeader | Featured result header
 | FeaturedResultItem | A featured result item


DefaultErrorMessageTemplate Class

DefaultErrorMessageTemplate Class
API Documentation ► Keyoti.SearchEngine.Web.Templates ► DefaultErrorMessageTemplate
Keyoti SearchUnit v6
The default template used for the error message.
Declaration Syntax
C# Visual Basic
public class DefaultErrorMessageTemplate : TemplateBuilder
Public Class DefaultErrorMessageTemplate
    Inherits TemplateBuilder
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DefaultErrorMessageTemplate()()()() |
 | AllowWhitespaceLiterals()()()() | (Inherited from ControlBuilder.)
 | AppendLiteralString(String) | (Inherited from ControlBuilder.)
 | AppendSubBuilder(ControlBuilder) | (Inherited from ControlBuilder.)
 | BindingContainerBuilder | (Inherited from ControlBuilder.)
 | BindingContainerType | (Inherited from ControlBuilder.)
 | BuildObject()()()() | (Inherited from TemplateBuilder.)
 | CloseControl()()()() | (Inherited from TemplateBuilder.)
 | ComplexPropertyEntries | (Inherited from ControlBuilder.)
 | ControlType | (Inherited from ControlBuilder.)
 | CurrentFilterResolutionService | (Inherited from ControlBuilder.)
 | DeclareType | (Inherited from ControlBuilder.)
 | DesignTime | Whether the rendering is being done at design time.
 | Equals(Object) | (Inherited from Object.)
 | FChildrenAsProperties | (Inherited from ControlBuilder.)
 | Finalize()()()() | (Inherited from Object.)
 | FIsNonParserAccessor | (Inherited from ControlBuilder.)
 | GetChildControlType(String, IDictionary) | (Inherited from ControlBuilder.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetObjectPersistData()()()() | (Inherited from ControlBuilder.)
 | GetResourceKey()()()() | (Inherited from ControlBuilder.)
 | GetType()()()() | (Inherited from Object.)
 | HasAspCode | (Inherited from ControlBuilder.)
 | HasBody()()()() | (Inherited from ControlBuilder.)
 | HtmlDecodeLiterals()()()() | (Inherited from ControlBuilder.)
 | ID | (Inherited from ControlBuilder.)
 | InDesigner | (Inherited from ControlBuilder.)
 | Init(TemplateParser, ControlBuilder, Type, String, String, IDictionary) | (Inherited from TemplateBuilder.)
 | InPageTheme | (Inherited from ControlBuilder.)
 | InstantiateIn(Control) | Instantiate control in template (Overrides TemplateBuilder.InstantiateIn(Control).)
 | ItemType | (Inherited from ControlBuilder.)
 | Localize | (Inherited from ControlBuilder.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NamingContainerType | (Inherited from ControlBuilder.)
 | NeedsTagInnerText()()()() | (Inherited from TemplateBuilder.)
 | OnAppendToParentBuilder(ControlBuilder) | (Inherited from ControlBuilder.)
 | PageVirtualPath | (Inherited from ControlBuilder.)
 | Parser | (Inherited from ControlBuilder.)
 | ProcessGeneratedCode(CodeCompileUnit, CodeTypeDeclaration, CodeTypeDeclaration, CodeMemberMethod, CodeMemberMethod) | (Inherited from ControlBuilder.)
 | ServiceProvider | (Inherited from ControlBuilder.)
 | SetResourceKey(String) | (Inherited from ControlBuilder.)
 | SetServiceProvider(IServiceProvider) | (Inherited from ControlBuilder.)
 | SetTagInnerText(String) | (Inherited from TemplateBuilder.)
 | SubBuilders | (Inherited from ControlBuilder.)
 | TagName | (Inherited from ControlBuilder.)
 | TemplatePropertyEntries | (Inherited from ControlBuilder.)
 | Text | Template text (Overrides TemplateBuilder.Text.)
 | ThemeResolutionService | (Inherited from ControlBuilder.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | ControlBuilder
 |  | TemplateBuilder
 |  |  | DefaultErrorMessageTemplate

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


DefaultErrorMessageTemplate Constructor

DefaultErrorMessageTemplate Constructor
API Documentation ► Keyoti.SearchEngine.Web.Templates ► DefaultErrorMessageTemplate ► DefaultErrorMessageTemplate()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public DefaultErrorMessageTemplate()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


DesignTime Field

DesignTime Field
API Documentation ► Keyoti.SearchEngine.Web.Templates ► DefaultErrorMessageTemplate ► DesignTime
Keyoti SearchUnit v6
Whether the rendering is being done at design time.
Declaration Syntax
C# Visual Basic
public bool DesignTime
Public DesignTime As Boolean
Field Value
Boolean

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


InstantiateIn Method (container)

InstantiateIn Method (container)
API Documentation ► Keyoti.SearchEngine.Web.Templates ► DefaultErrorMessageTemplate ► InstantiateIn(Control)
Keyoti SearchUnit v6
Instantiate control in template
Declaration Syntax
C# Visual Basic
public override void InstantiateIn(
    Control container
)
Public Overrides Sub InstantiateIn (
    container As Control
)
Parameters
container (Control)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Text Property

Text Property
API Documentation ► Keyoti.SearchEngine.Web.Templates ► DefaultErrorMessageTemplate ► Text
Keyoti SearchUnit v6
Template text
Declaration Syntax
C# Visual Basic
public override string Text { get; set; }
Public Overrides Property Text As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


DefaultFeaturedResultItemTemplate Class

DefaultFeaturedResultItemTemplate Class
API Documentation ► Keyoti.SearchEngine.Web.Templates ► DefaultFeaturedResultItemTemplate
Keyoti SearchUnit v6
The default template used for the featuredResult item.
Declaration Syntax
C# Visual Basic
public class DefaultFeaturedResultItemTemplate : TemplateBuilder
Public Class DefaultFeaturedResultItemTemplate
    Inherits TemplateBuilder
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DefaultFeaturedResultItemTemplate()()()() |
 | AllowWhitespaceLiterals()()()() | (Inherited from ControlBuilder.)
 | AppendLiteralString(String) | (Inherited from ControlBuilder.)
 | AppendSubBuilder(ControlBuilder) | (Inherited from ControlBuilder.)
 | BindingContainerBuilder | (Inherited from ControlBuilder.)
 | BindingContainerType | (Inherited from ControlBuilder.)
 | BuildObject()()()() | (Inherited from TemplateBuilder.)
 | CloseControl()()()() | (Inherited from TemplateBuilder.)
 | ComplexPropertyEntries | (Inherited from ControlBuilder.)
 | ControlType | (Inherited from ControlBuilder.)
 | CurrentFilterResolutionService | (Inherited from ControlBuilder.)
 | DeclareType | (Inherited from ControlBuilder.)
 | DesignTime |
 | Equals(Object) | (Inherited from Object.)
 | FChildrenAsProperties | (Inherited from ControlBuilder.)
 | Finalize()()()() | (Inherited from Object.)
 | FIsNonParserAccessor | (Inherited from ControlBuilder.)
 | GetChildControlType(String, IDictionary) | (Inherited from ControlBuilder.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetObjectPersistData()()()() | (Inherited from ControlBuilder.)
 | GetResourceKey()()()() | (Inherited from ControlBuilder.)
 | GetType()()()() | (Inherited from Object.)
 | HasAspCode | (Inherited from ControlBuilder.)
 | HasBody()()()() | (Inherited from ControlBuilder.)
 | HtmlDecodeLiterals()()()() | (Inherited from ControlBuilder.)
 | ID | (Inherited from ControlBuilder.)
 | InDesigner | (Inherited from ControlBuilder.)
 | Init(TemplateParser, ControlBuilder, Type, String, String, IDictionary) | (Inherited from TemplateBuilder.)
 | InPageTheme | (Inherited from ControlBuilder.)
 | InstantiateIn(Control) | (Overrides TemplateBuilder.InstantiateIn(Control).)
 | ItemType | (Inherited from ControlBuilder.)
 | Localize | (Inherited from ControlBuilder.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NamingContainerType | (Inherited from ControlBuilder.)
 | NeedsTagInnerText()()()() | (Inherited from TemplateBuilder.)
 | OnAppendToParentBuilder(ControlBuilder) | (Inherited from ControlBuilder.)
 | PageVirtualPath | (Inherited from ControlBuilder.)
 | Parser | (Inherited from ControlBuilder.)
 | ProcessGeneratedCode(CodeCompileUnit, CodeTypeDeclaration, CodeTypeDeclaration, CodeMemberMethod, CodeMemberMethod) | (Inherited from ControlBuilder.)
 | ServiceProvider | (Inherited from ControlBuilder.)
 | SetResourceKey(String) | (Inherited from ControlBuilder.)
 | SetServiceProvider(IServiceProvider) | (Inherited from ControlBuilder.)
 | SetTagInnerText(String) | (Inherited from TemplateBuilder.)
 | SubBuilders | (Inherited from ControlBuilder.)
 | TagName | (Inherited from ControlBuilder.)
 | TemplatePropertyEntries | (Inherited from ControlBuilder.)
 | Text | (Overrides TemplateBuilder.Text.)
 | ThemeResolutionService | (Inherited from ControlBuilder.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | ControlBuilder
 |  | TemplateBuilder
 |  |  | DefaultFeaturedResultItemTemplate

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


DefaultFeaturedResultItemTemplate Constructor

DefaultFeaturedResultItemTemplate Constructor
API Documentation ► Keyoti.SearchEngine.Web.Templates ► DefaultFeaturedResultItemTemplate ► DefaultFeaturedResultItemTemplate()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public DefaultFeaturedResultItemTemplate()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


DesignTime Field

DesignTime Field
API Documentation ► Keyoti.SearchEngine.Web.Templates ► DefaultFeaturedResultItemTemplate ► DesignTime
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public bool DesignTime
Public DesignTime As Boolean
Field Value
Boolean

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


InstantiateIn Method (container)

InstantiateIn Method (container)
API Documentation ► Keyoti.SearchEngine.Web.Templates ► DefaultFeaturedResultItemTemplate ► InstantiateIn(Control)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public override void InstantiateIn(
    Control container
)
Public Overrides Sub InstantiateIn (
    container As Control
)
Parameters
container (Control)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Text Property

Text Property
API Documentation ► Keyoti.SearchEngine.Web.Templates ► DefaultFeaturedResultItemTemplate ► Text
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public override string Text { get; set; }
Public Overrides Property Text As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


DefaultFeaturedResultsHeaderTemplate Class

DefaultFeaturedResultsHeaderTemplate Class
API Documentation ► Keyoti.SearchEngine.Web.Templates ► DefaultFeaturedResultsHeaderTemplate
Keyoti SearchUnit v6
The default template used for the featured results header.
Declaration Syntax
C# Visual Basic
public class DefaultFeaturedResultsHeaderTemplate : TemplateBuilder
Public Class DefaultFeaturedResultsHeaderTemplate
    Inherits TemplateBuilder
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DefaultFeaturedResultsHeaderTemplate()()()() |
 | AllowWhitespaceLiterals()()()() | (Inherited from ControlBuilder.)
 | AppendLiteralString(String) | (Inherited from ControlBuilder.)
 | AppendSubBuilder(ControlBuilder) | (Inherited from ControlBuilder.)
 | BindingContainerBuilder | (Inherited from ControlBuilder.)
 | BindingContainerType | (Inherited from ControlBuilder.)
 | BuildObject()()()() | (Inherited from TemplateBuilder.)
 | CloseControl()()()() | (Inherited from TemplateBuilder.)
 | ComplexPropertyEntries | (Inherited from ControlBuilder.)
 | ControlType | (Inherited from ControlBuilder.)
 | CurrentFilterResolutionService | (Inherited from ControlBuilder.)
 | DeclareType | (Inherited from ControlBuilder.)
 | Equals(Object) | (Inherited from Object.)
 | FChildrenAsProperties | (Inherited from ControlBuilder.)
 | Finalize()()()() | (Inherited from Object.)
 | FIsNonParserAccessor | (Inherited from ControlBuilder.)
 | GetChildControlType(String, IDictionary) | (Inherited from ControlBuilder.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetObjectPersistData()()()() | (Inherited from ControlBuilder.)
 | GetResourceKey()()()() | (Inherited from ControlBuilder.)
 | GetType()()()() | (Inherited from Object.)
 | HasAspCode | (Inherited from ControlBuilder.)
 | HasBody()()()() | (Inherited from ControlBuilder.)
 | HtmlDecodeLiterals()()()() | (Inherited from ControlBuilder.)
 | ID | (Inherited from ControlBuilder.)
 | InDesigner | (Inherited from ControlBuilder.)
 | Init(TemplateParser, ControlBuilder, Type, String, String, IDictionary) | (Inherited from TemplateBuilder.)
 | InPageTheme | (Inherited from ControlBuilder.)
 | InstantiateIn(Control) | (Overrides TemplateBuilder.InstantiateIn(Control).)
 | ItemType | (Inherited from ControlBuilder.)
 | Localize | (Inherited from ControlBuilder.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NamingContainerType | (Inherited from ControlBuilder.)
 | NeedsTagInnerText()()()() | (Inherited from TemplateBuilder.)
 | OnAppendToParentBuilder(ControlBuilder) | (Inherited from ControlBuilder.)
 | PageVirtualPath | (Inherited from ControlBuilder.)
 | Parser | (Inherited from ControlBuilder.)
 | ProcessGeneratedCode(CodeCompileUnit, CodeTypeDeclaration, CodeTypeDeclaration, CodeMemberMethod, CodeMemberMethod) | (Inherited from ControlBuilder.)
 | ServiceProvider | (Inherited from ControlBuilder.)
 | SetResourceKey(String) | (Inherited from ControlBuilder.)
 | SetServiceProvider(IServiceProvider) | (Inherited from ControlBuilder.)
 | SetTagInnerText(String) | (Inherited from TemplateBuilder.)
 | SubBuilders | (Inherited from ControlBuilder.)
 | TagName | (Inherited from ControlBuilder.)
 | TemplatePropertyEntries | (Inherited from ControlBuilder.)
 | Text | (Overrides TemplateBuilder.Text.)
 | ThemeResolutionService | (Inherited from ControlBuilder.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | ControlBuilder
 |  | TemplateBuilder
 |  |  | DefaultFeaturedResultsHeaderTemplate

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


DefaultFeaturedResultsHeaderTemplate Constructor

DefaultFeaturedResultsHeaderTemplate Constructor
API Documentation ► Keyoti.SearchEngine.Web.Templates ► DefaultFeaturedResultsHeaderTemplate ► DefaultFeaturedResultsHeaderTemplate()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public DefaultFeaturedResultsHeaderTemplate()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


InstantiateIn Method (container)

InstantiateIn Method (container)
API Documentation ► Keyoti.SearchEngine.Web.Templates ► DefaultFeaturedResultsHeaderTemplate ► InstantiateIn(Control)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public override void InstantiateIn(
    Control container
)
Public Overrides Sub InstantiateIn (
    container As Control
)
Parameters
container (Control)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Text Property

Text Property
API Documentation ► Keyoti.SearchEngine.Web.Templates ► DefaultFeaturedResultsHeaderTemplate ► Text
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public override string Text { get; set; }
Public Overrides Property Text As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


DefaultFooterTemplate Class

DefaultFooterTemplate Class
API Documentation ► Keyoti.SearchEngine.Web.Templates ► DefaultFooterTemplate
Keyoti SearchUnit v6
The default template used for the footer.
Declaration Syntax
C# Visual Basic
public class DefaultFooterTemplate : TemplateBuilder
Public Class DefaultFooterTemplate
    Inherits TemplateBuilder
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DefaultFooterTemplate()()()() |
 | AllowWhitespaceLiterals()()()() | (Inherited from ControlBuilder.)
 | AppendLiteralString(String) | (Inherited from ControlBuilder.)
 | AppendSubBuilder(ControlBuilder) | (Inherited from ControlBuilder.)
 | BindingContainerBuilder | (Inherited from ControlBuilder.)
 | BindingContainerType | (Inherited from ControlBuilder.)
 | BuildObject()()()() | (Inherited from TemplateBuilder.)
 | CloseControl()()()() | (Inherited from TemplateBuilder.)
 | ComplexPropertyEntries | (Inherited from ControlBuilder.)
 | ControlType | (Inherited from ControlBuilder.)
 | CurrentFilterResolutionService | (Inherited from ControlBuilder.)
 | DeclareType | (Inherited from ControlBuilder.)
 | DesignTime | Whether the rendering is being done at design time.
 | Equals(Object) | (Inherited from Object.)
 | FChildrenAsProperties | (Inherited from ControlBuilder.)
 | Finalize()()()() | (Inherited from Object.)
 | FIsNonParserAccessor | (Inherited from ControlBuilder.)
 | GetChildControlType(String, IDictionary) | (Inherited from ControlBuilder.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetObjectPersistData()()()() | (Inherited from ControlBuilder.)
 | GetResourceKey()()()() | (Inherited from ControlBuilder.)
 | GetType()()()() | (Inherited from Object.)
 | HasAspCode | (Inherited from ControlBuilder.)
 | HasBody()()()() | (Inherited from ControlBuilder.)
 | HtmlDecodeLiterals()()()() | (Inherited from ControlBuilder.)
 | ID | (Inherited from ControlBuilder.)
 | InDesigner | (Inherited from ControlBuilder.)
 | Init(TemplateParser, ControlBuilder, Type, String, String, IDictionary) | (Inherited from TemplateBuilder.)
 | InPageTheme | (Inherited from ControlBuilder.)
 | InstantiateIn(Control) | Instantiate control in template (Overrides TemplateBuilder.InstantiateIn(Control).)
 | ItemType | (Inherited from ControlBuilder.)
 | Localize | (Inherited from ControlBuilder.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NamingContainerType | (Inherited from ControlBuilder.)
 | NeedsTagInnerText()()()() | (Inherited from TemplateBuilder.)
 | OnAppendToParentBuilder(ControlBuilder) | (Inherited from ControlBuilder.)
 | PageVirtualPath | (Inherited from ControlBuilder.)
 | Parser | (Inherited from ControlBuilder.)
 | ProcessGeneratedCode(CodeCompileUnit, CodeTypeDeclaration, CodeTypeDeclaration, CodeMemberMethod, CodeMemberMethod) | (Inherited from ControlBuilder.)
 | ServiceProvider | (Inherited from ControlBuilder.)
 | SetResourceKey(String) | (Inherited from ControlBuilder.)
 | SetServiceProvider(IServiceProvider) | (Inherited from ControlBuilder.)
 | SetTagInnerText(String) | (Inherited from TemplateBuilder.)
 | SubBuilders | (Inherited from ControlBuilder.)
 | TagName | (Inherited from ControlBuilder.)
 | TemplatePropertyEntries | (Inherited from ControlBuilder.)
 | Text | Template text (Overrides TemplateBuilder.Text.)
 | ThemeResolutionService | (Inherited from ControlBuilder.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | ControlBuilder
 |  | TemplateBuilder
 |  |  | DefaultFooterTemplate

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


DefaultFooterTemplate Constructor

DefaultFooterTemplate Constructor
API Documentation ► Keyoti.SearchEngine.Web.Templates ► DefaultFooterTemplate ► DefaultFooterTemplate()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public DefaultFooterTemplate()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


DesignTime Field

DesignTime Field
API Documentation ► Keyoti.SearchEngine.Web.Templates ► DefaultFooterTemplate ► DesignTime
Keyoti SearchUnit v6
Whether the rendering is being done at design time.
Declaration Syntax
C# Visual Basic
public bool DesignTime
Public DesignTime As Boolean
Field Value
Boolean

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


InstantiateIn Method (container)

InstantiateIn Method (container)
API Documentation ► Keyoti.SearchEngine.Web.Templates ► DefaultFooterTemplate ► InstantiateIn(Control)
Keyoti SearchUnit v6
Instantiate control in template
Declaration Syntax
C# Visual Basic
public override void InstantiateIn(
    Control container
)
Public Overrides Sub InstantiateIn (
    container As Control
)
Parameters
container (Control)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Text Property

Text Property
API Documentation ► Keyoti.SearchEngine.Web.Templates ► DefaultFooterTemplate ► Text
Keyoti SearchUnit v6
Template text
Declaration Syntax
C# Visual Basic
public override string Text { get; set; }
Public Overrides Property Text As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


DefaultHeaderTemplate Class

DefaultHeaderTemplate Class
API Documentation ► Keyoti.SearchEngine.Web.Templates ► DefaultHeaderTemplate
Keyoti SearchUnit v6
The default template used for the header.
Declaration Syntax
C# Visual Basic
public class DefaultHeaderTemplate : TemplateBuilder
Public Class DefaultHeaderTemplate
    Inherits TemplateBuilder
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DefaultHeaderTemplate()()()() |
 | AllowWhitespaceLiterals()()()() | (Inherited from ControlBuilder.)
 | AppendLiteralString(String) | (Inherited from ControlBuilder.)
 | AppendSubBuilder(ControlBuilder) | (Inherited from ControlBuilder.)
 | BindingContainerBuilder | (Inherited from ControlBuilder.)
 | BindingContainerType | (Inherited from ControlBuilder.)
 | BuildObject()()()() | (Inherited from TemplateBuilder.)
 | CloseControl()()()() | (Inherited from TemplateBuilder.)
 | ComplexPropertyEntries | (Inherited from ControlBuilder.)
 | ControlType | (Inherited from ControlBuilder.)
 | CurrentFilterResolutionService | (Inherited from ControlBuilder.)
 | DeclareType | (Inherited from ControlBuilder.)
 | DesignTime | Whether the rendering is being done at design time.
 | Equals(Object) | (Inherited from Object.)
 | FChildrenAsProperties | (Inherited from ControlBuilder.)
 | Finalize()()()() | (Inherited from Object.)
 | FIsNonParserAccessor | (Inherited from ControlBuilder.)
 | GetChildControlType(String, IDictionary) | (Inherited from ControlBuilder.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetObjectPersistData()()()() | (Inherited from ControlBuilder.)
 | GetResourceKey()()()() | (Inherited from ControlBuilder.)
 | GetType()()()() | (Inherited from Object.)
 | HasAspCode | (Inherited from ControlBuilder.)
 | HasBody()()()() | (Inherited from ControlBuilder.)
 | HtmlDecodeLiterals()()()() | (Inherited from ControlBuilder.)
 | ID | (Inherited from ControlBuilder.)
 | InDesigner | (Inherited from ControlBuilder.)
 | Init(TemplateParser, ControlBuilder, Type, String, String, IDictionary) | (Inherited from TemplateBuilder.)
 | InPageTheme | (Inherited from ControlBuilder.)
 | InstantiateIn(Control) | Instantiate control in template (Overrides TemplateBuilder.InstantiateIn(Control).)
 | ItemType | (Inherited from ControlBuilder.)
 | Localize | (Inherited from ControlBuilder.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NamingContainerType | (Inherited from ControlBuilder.)
 | NeedsTagInnerText()()()() | (Inherited from TemplateBuilder.)
 | OnAppendToParentBuilder(ControlBuilder) | (Inherited from ControlBuilder.)
 | PageVirtualPath | (Inherited from ControlBuilder.)
 | Parser | (Inherited from ControlBuilder.)
 | ProcessGeneratedCode(CodeCompileUnit, CodeTypeDeclaration, CodeTypeDeclaration, CodeMemberMethod, CodeMemberMethod) | (Inherited from ControlBuilder.)
 | ServiceProvider | (Inherited from ControlBuilder.)
 | SetResourceKey(String) | (Inherited from ControlBuilder.)
 | SetServiceProvider(IServiceProvider) | (Inherited from ControlBuilder.)
 | SetTagInnerText(String) | (Inherited from TemplateBuilder.)
 | SubBuilders | (Inherited from ControlBuilder.)
 | TagName | (Inherited from ControlBuilder.)
 | TemplatePropertyEntries | (Inherited from ControlBuilder.)
 | Text | Template text (Overrides TemplateBuilder.Text.)
 | ThemeResolutionService | (Inherited from ControlBuilder.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | ControlBuilder
 |  | TemplateBuilder
 |  |  | DefaultHeaderTemplate

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


DefaultHeaderTemplate Constructor

DefaultHeaderTemplate Constructor
API Documentation ► Keyoti.SearchEngine.Web.Templates ► DefaultHeaderTemplate ► DefaultHeaderTemplate()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public DefaultHeaderTemplate()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


DesignTime Field

DesignTime Field
API Documentation ► Keyoti.SearchEngine.Web.Templates ► DefaultHeaderTemplate ► DesignTime
Keyoti SearchUnit v6
Whether the rendering is being done at design time.
Declaration Syntax
C# Visual Basic
public bool DesignTime
Public DesignTime As Boolean
Field Value
Boolean

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


InstantiateIn Method (container)

InstantiateIn Method (container)
API Documentation ► Keyoti.SearchEngine.Web.Templates ► DefaultHeaderTemplate ► InstantiateIn(Control)
Keyoti SearchUnit v6
Instantiate control in template
Declaration Syntax
C# Visual Basic
public override void InstantiateIn(
    Control container
)
Public Overrides Sub InstantiateIn (
    container As Control
)
Parameters
container (Control)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Text Property

Text Property
API Documentation ► Keyoti.SearchEngine.Web.Templates ► DefaultHeaderTemplate ► Text
Keyoti SearchUnit v6
Template text
Declaration Syntax
C# Visual Basic
public override string Text { get; set; }
Public Overrides Property Text As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


DefaultNoQueryTemplate Class

DefaultNoQueryTemplate Class
API Documentation ► Keyoti.SearchEngine.Web.Templates ► DefaultNoQueryTemplate
Keyoti SearchUnit v6
The default template used for the no query item.
Declaration Syntax
C# Visual Basic
public class DefaultNoQueryTemplate : TemplateBuilder
Public Class DefaultNoQueryTemplate
    Inherits TemplateBuilder
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DefaultNoQueryTemplate()()()() |
 | AllowWhitespaceLiterals()()()() | (Inherited from ControlBuilder.)
 | AppendLiteralString(String) | (Inherited from ControlBuilder.)
 | AppendSubBuilder(ControlBuilder) | (Inherited from ControlBuilder.)
 | BindingContainerBuilder | (Inherited from ControlBuilder.)
 | BindingContainerType | (Inherited from ControlBuilder.)
 | BuildObject()()()() | (Inherited from TemplateBuilder.)
 | CloseControl()()()() | (Inherited from TemplateBuilder.)
 | ComplexPropertyEntries | (Inherited from ControlBuilder.)
 | ControlType | (Inherited from ControlBuilder.)
 | CurrentFilterResolutionService | (Inherited from ControlBuilder.)
 | DeclareType | (Inherited from ControlBuilder.)
 | DesignTime | Whether the rendering is being done at design time.
 | Equals(Object) | (Inherited from Object.)
 | FChildrenAsProperties | (Inherited from ControlBuilder.)
 | Finalize()()()() | (Inherited from Object.)
 | FIsNonParserAccessor | (Inherited from ControlBuilder.)
 | GetChildControlType(String, IDictionary) | (Inherited from ControlBuilder.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetObjectPersistData()()()() | (Inherited from ControlBuilder.)
 | GetResourceKey()()()() | (Inherited from ControlBuilder.)
 | GetType()()()() | (Inherited from Object.)
 | HasAspCode | (Inherited from ControlBuilder.)
 | HasBody()()()() | (Inherited from ControlBuilder.)
 | HtmlDecodeLiterals()()()() | (Inherited from ControlBuilder.)
 | ID | (Inherited from ControlBuilder.)
 | InDesigner | (Inherited from ControlBuilder.)
 | Init(TemplateParser, ControlBuilder, Type, String, String, IDictionary) | (Inherited from TemplateBuilder.)
 | InPageTheme | (Inherited from ControlBuilder.)
 | InstantiateIn(Control) | Instantiate control in template (Overrides TemplateBuilder.InstantiateIn(Control).)
 | ItemType | (Inherited from ControlBuilder.)
 | Localize | (Inherited from ControlBuilder.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NamingContainerType | (Inherited from ControlBuilder.)
 | NeedsTagInnerText()()()() | (Inherited from TemplateBuilder.)
 | OnAppendToParentBuilder(ControlBuilder) | (Inherited from ControlBuilder.)
 | PageVirtualPath | (Inherited from ControlBuilder.)
 | Parser | (Inherited from ControlBuilder.)
 | ProcessGeneratedCode(CodeCompileUnit, CodeTypeDeclaration, CodeTypeDeclaration, CodeMemberMethod, CodeMemberMethod) | (Inherited from ControlBuilder.)
 | ServiceProvider | (Inherited from ControlBuilder.)
 | SetResourceKey(String) | (Inherited from ControlBuilder.)
 | SetServiceProvider(IServiceProvider) | (Inherited from ControlBuilder.)
 | SetTagInnerText(String) | (Inherited from TemplateBuilder.)
 | SubBuilders | (Inherited from ControlBuilder.)
 | TagName | (Inherited from ControlBuilder.)
 | TemplatePropertyEntries | (Inherited from ControlBuilder.)
 | Text | Template text (Overrides TemplateBuilder.Text.)
 | ThemeResolutionService | (Inherited from ControlBuilder.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | ControlBuilder
 |  | TemplateBuilder
 |  |  | DefaultNoQueryTemplate

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


DefaultNoQueryTemplate Constructor

DefaultNoQueryTemplate Constructor
API Documentation ► Keyoti.SearchEngine.Web.Templates ► DefaultNoQueryTemplate ► DefaultNoQueryTemplate()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public DefaultNoQueryTemplate()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


DesignTime Field

DesignTime Field
API Documentation ► Keyoti.SearchEngine.Web.Templates ► DefaultNoQueryTemplate ► DesignTime
Keyoti SearchUnit v6
Whether the rendering is being done at design time.
Declaration Syntax
C# Visual Basic
public bool DesignTime
Public DesignTime As Boolean
Field Value
Boolean

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


InstantiateIn Method (container)

InstantiateIn Method (container)
API Documentation ► Keyoti.SearchEngine.Web.Templates ► DefaultNoQueryTemplate ► InstantiateIn(Control)
Keyoti SearchUnit v6
Instantiate control in template
Declaration Syntax
C# Visual Basic
public override void InstantiateIn(
    Control container
)
Public Overrides Sub InstantiateIn (
    container As Control
)
Parameters
container (Control)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Text Property

Text Property
API Documentation ► Keyoti.SearchEngine.Web.Templates ► DefaultNoQueryTemplate ► Text
Keyoti SearchUnit v6
Template text
Declaration Syntax
C# Visual Basic
public override string Text { get; set; }
Public Overrides Property Text As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


DefaultNoResultsTemplate Class

DefaultNoResultsTemplate Class
API Documentation ► Keyoti.SearchEngine.Web.Templates ► DefaultNoResultsTemplate
Keyoti SearchUnit v6
The default template used for the no results message.
Declaration Syntax
C# Visual Basic
public class DefaultNoResultsTemplate : TemplateBuilder
Public Class DefaultNoResultsTemplate
    Inherits TemplateBuilder
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DefaultNoResultsTemplate()()()() |
 | AllowWhitespaceLiterals()()()() | (Inherited from ControlBuilder.)
 | AppendLiteralString(String) | (Inherited from ControlBuilder.)
 | AppendSubBuilder(ControlBuilder) | (Inherited from ControlBuilder.)
 | BindingContainerBuilder | (Inherited from ControlBuilder.)
 | BindingContainerType | (Inherited from ControlBuilder.)
 | BuildObject()()()() | (Inherited from TemplateBuilder.)
 | CloseControl()()()() | (Inherited from TemplateBuilder.)
 | ComplexPropertyEntries | (Inherited from ControlBuilder.)
 | ControlType | (Inherited from ControlBuilder.)
 | CurrentFilterResolutionService | (Inherited from ControlBuilder.)
 | DeclareType | (Inherited from ControlBuilder.)
 | DesignTime | Whether the rendering is being done at design time.
 | Equals(Object) | (Inherited from Object.)
 | FChildrenAsProperties | (Inherited from ControlBuilder.)
 | Finalize()()()() | (Inherited from Object.)
 | FIsNonParserAccessor | (Inherited from ControlBuilder.)
 | GetChildControlType(String, IDictionary) | (Inherited from ControlBuilder.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetObjectPersistData()()()() | (Inherited from ControlBuilder.)
 | GetResourceKey()()()() | (Inherited from ControlBuilder.)
 | GetType()()()() | (Inherited from Object.)
 | HasAspCode | (Inherited from ControlBuilder.)
 | HasBody()()()() | (Inherited from ControlBuilder.)
 | HtmlDecodeLiterals()()()() | (Inherited from ControlBuilder.)
 | ID | (Inherited from ControlBuilder.)
 | InDesigner | (Inherited from ControlBuilder.)
 | Init(TemplateParser, ControlBuilder, Type, String, String, IDictionary) | (Inherited from TemplateBuilder.)
 | InPageTheme | (Inherited from ControlBuilder.)
 | InstantiateIn(Control) | Instantiate control in template (Overrides TemplateBuilder.InstantiateIn(Control).)
 | ItemType | (Inherited from ControlBuilder.)
 | Localize | (Inherited from ControlBuilder.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NamingContainerType | (Inherited from ControlBuilder.)
 | NeedsTagInnerText()()()() | (Inherited from TemplateBuilder.)
 | OnAppendToParentBuilder(ControlBuilder) | (Inherited from ControlBuilder.)
 | PageVirtualPath | (Inherited from ControlBuilder.)
 | Parser | (Inherited from ControlBuilder.)
 | ProcessGeneratedCode(CodeCompileUnit, CodeTypeDeclaration, CodeTypeDeclaration, CodeMemberMethod, CodeMemberMethod) | (Inherited from ControlBuilder.)
 | ServiceProvider | (Inherited from ControlBuilder.)
 | SetResourceKey(String) | (Inherited from ControlBuilder.)
 | SetServiceProvider(IServiceProvider) | (Inherited from ControlBuilder.)
 | SetTagInnerText(String) | (Inherited from TemplateBuilder.)
 | SubBuilders | (Inherited from ControlBuilder.)
 | TagName | (Inherited from ControlBuilder.)
 | TemplatePropertyEntries | (Inherited from ControlBuilder.)
 | Text | Template text (Overrides TemplateBuilder.Text.)
 | ThemeResolutionService | (Inherited from ControlBuilder.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | ControlBuilder
 |  | TemplateBuilder
 |  |  | DefaultNoResultsTemplate

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


DefaultNoResultsTemplate Constructor

DefaultNoResultsTemplate Constructor
API Documentation ► Keyoti.SearchEngine.Web.Templates ► DefaultNoResultsTemplate ► DefaultNoResultsTemplate()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public DefaultNoResultsTemplate()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


DesignTime Field

DesignTime Field
API Documentation ► Keyoti.SearchEngine.Web.Templates ► DefaultNoResultsTemplate ► DesignTime
Keyoti SearchUnit v6
Whether the rendering is being done at design time.
Declaration Syntax
C# Visual Basic
public bool DesignTime
Public DesignTime As Boolean
Field Value
Boolean

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


InstantiateIn Method (container)

InstantiateIn Method (container)
API Documentation ► Keyoti.SearchEngine.Web.Templates ► DefaultNoResultsTemplate ► InstantiateIn(Control)
Keyoti SearchUnit v6
Instantiate control in template
Declaration Syntax
C# Visual Basic
public override void InstantiateIn(
    Control container
)
Public Overrides Sub InstantiateIn (
    container As Control
)
Parameters
container (Control)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Text Property

Text Property
API Documentation ► Keyoti.SearchEngine.Web.Templates ► DefaultNoResultsTemplate ► Text
Keyoti SearchUnit v6
Template text
Declaration Syntax
C# Visual Basic
public override string Text { get; set; }
Public Overrides Property Text As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


DefaultResultItemTemplate Class

DefaultResultItemTemplate Class
API Documentation ► Keyoti.SearchEngine.Web.Templates ► DefaultResultItemTemplate
Keyoti SearchUnit v6
The default template used for the result item.
Declaration Syntax
C# Visual Basic
public class DefaultResultItemTemplate : TemplateBuilder
Public Class DefaultResultItemTemplate
    Inherits TemplateBuilder
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DefaultResultItemTemplate(Page) | Constructor
 | AllowWhitespaceLiterals()()()() | (Inherited from ControlBuilder.)
 | AppendLiteralString(String) | (Inherited from ControlBuilder.)
 | AppendSubBuilder(ControlBuilder) | (Inherited from ControlBuilder.)
 | BindingContainerBuilder | (Inherited from ControlBuilder.)
 | BindingContainerType | (Inherited from ControlBuilder.)
 | BuildObject()()()() | (Inherited from TemplateBuilder.)
 | CloseControl()()()() | (Inherited from TemplateBuilder.)
 | ComplexPropertyEntries | (Inherited from ControlBuilder.)
 | ControlType | (Inherited from ControlBuilder.)
 | CurrentFilterResolutionService | (Inherited from ControlBuilder.)
 | DeclareType | (Inherited from ControlBuilder.)
 | DesignTime | Whether the rendering is being done at design time.
 | Equals(Object) | (Inherited from Object.)
 | FChildrenAsProperties | (Inherited from ControlBuilder.)
 | Finalize()()()() | (Inherited from Object.)
 | FIsNonParserAccessor | (Inherited from ControlBuilder.)
 | GetChildControlType(String, IDictionary) | (Inherited from ControlBuilder.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetObjectPersistData()()()() | (Inherited from ControlBuilder.)
 | GetResourceKey()()()() | (Inherited from ControlBuilder.)
 | GetType()()()() | (Inherited from Object.)
 | HasAspCode | (Inherited from ControlBuilder.)
 | HasBody()()()() | (Inherited from ControlBuilder.)
 | HtmlDecodeLiterals()()()() | (Inherited from ControlBuilder.)
 | ID | (Inherited from ControlBuilder.)
 | InDesigner | (Inherited from ControlBuilder.)
 | Init(TemplateParser, ControlBuilder, Type, String, String, IDictionary) | (Inherited from TemplateBuilder.)
 | InPageTheme | (Inherited from ControlBuilder.)
 | InstantiateIn(Control) | Instantiate control in template (Overrides TemplateBuilder.InstantiateIn(Control).)
 | ItemType | (Inherited from ControlBuilder.)
 | Localize | (Inherited from ControlBuilder.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NamingContainerType | (Inherited from ControlBuilder.)
 | NeedsTagInnerText()()()() | (Inherited from TemplateBuilder.)
 | OnAppendToParentBuilder(ControlBuilder) | (Inherited from ControlBuilder.)
 | PageVirtualPath | (Inherited from ControlBuilder.)
 | Parser | (Inherited from ControlBuilder.)
 | ProcessGeneratedCode(CodeCompileUnit, CodeTypeDeclaration, CodeTypeDeclaration, CodeMemberMethod, CodeMemberMethod) | (Inherited from ControlBuilder.)
 | ServiceProvider | (Inherited from ControlBuilder.)
 | SetResourceKey(String) | (Inherited from ControlBuilder.)
 | SetServiceProvider(IServiceProvider) | (Inherited from ControlBuilder.)
 | SetTagInnerText(String) | (Inherited from TemplateBuilder.)
 | SubBuilders | (Inherited from ControlBuilder.)
 | TagName | (Inherited from ControlBuilder.)
 | TemplatePropertyEntries | (Inherited from ControlBuilder.)
 | Text | Template text (Overrides TemplateBuilder.Text.)
 | ThemeResolutionService | (Inherited from ControlBuilder.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | ControlBuilder
 |  | TemplateBuilder
 |  |  | DefaultResultItemTemplate

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


DefaultResultItemTemplate Constructor (page)

DefaultResultItemTemplate Constructor (page)
API Documentation ► Keyoti.SearchEngine.Web.Templates ► DefaultResultItemTemplate ► DefaultResultItemTemplate(Page)
Keyoti SearchUnit v6
Constructor
Declaration Syntax
C# Visual Basic
public DefaultResultItemTemplate(
    Page page
)
Public Sub New (
    page As Page
)
Parameters
page (Page)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


DesignTime Field

DesignTime Field
API Documentation ► Keyoti.SearchEngine.Web.Templates ► DefaultResultItemTemplate ► DesignTime
Keyoti SearchUnit v6
Whether the rendering is being done at design time.
Declaration Syntax
C# Visual Basic
public bool DesignTime
Public DesignTime As Boolean
Field Value
Boolean

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


InstantiateIn Method (container)

InstantiateIn Method (container)
API Documentation ► Keyoti.SearchEngine.Web.Templates ► DefaultResultItemTemplate ► InstantiateIn(Control)
Keyoti SearchUnit v6
Instantiate control in template
Declaration Syntax
C# Visual Basic
public override void InstantiateIn(
    Control container
)
Public Overrides Sub InstantiateIn (
    container As Control
)
Parameters
container (Control)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Text Property

Text Property
API Documentation ► Keyoti.SearchEngine.Web.Templates ► DefaultResultItemTemplate ► Text
Keyoti SearchUnit v6
Template text
Declaration Syntax
C# Visual Basic
public override string Text { get; set; }
Public Overrides Property Text As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FeaturedHeader Class

FeaturedHeader Class
API Documentation ► Keyoti.SearchEngine.Web.Templates ► FeaturedHeader
Keyoti SearchUnit v6
Featured result header
Declaration Syntax
C# Visual Basic
public class FeaturedHeader : WebControl,
    INamingContainer
Public Class FeaturedHeader
    Inherits WebControl
    Implements INamingContainer
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FeaturedHeader()()()() |
 | AccessKey | (Inherited from WebControl.)
 | Adapter | (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | (Inherited from Control.)
 | AddParsedSubObject(Object) | (Inherited from Control.)
 | ApplyStyle(Style) | (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | (Inherited from Control.)
 | Attributes | (Inherited from WebControl.)
 | BackColor | (Inherited from WebControl.)
 | BeginRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | BindingContainer | (Inherited from Control.)
 | BorderColor | (Inherited from WebControl.)
 | BorderStyle | (Inherited from WebControl.)
 | BorderWidth | (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | (Inherited from Control.)
 | ChildControlsCreated | (Inherited from Control.)
 | ClearCachedClientID()()()() | (Inherited from Control.)
 | ClearChildControlState()()()() | (Inherited from Control.)
 | ClearChildState()()()() | (Inherited from Control.)
 | ClearChildViewState()()()() | (Inherited from Control.)
 | ClearEffectiveClientIDMode()()()() | (Inherited from Control.)
 | ClientID | (Inherited from Control.)
 | ClientIDMode | (Inherited from Control.)
 | ClientIDSeparator | (Inherited from Control.)
 | Context | (Inherited from Control.)
 | Controls | (Inherited from Control.)
 | ControlStyle | (Inherited from WebControl.)
 | ControlStyleCreated | (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | (Inherited from WebControl.)
 | CreateChildControls()()()() | (Inherited from Control.)
 | CreateControlCollection()()()() | (Inherited from Control.)
 | CreateControlStyle()()()() | (Inherited from WebControl.)
 | CssClass | (Inherited from WebControl.)
 | DataBind()()()() | (Inherited from Control.)
 | DataBind(Boolean) | (Inherited from Control.)
 | DataBindChildren()()()() | (Inherited from Control.)
 | DataBinding | (Inherited from Control.)
 | DataItemContainer | (Inherited from Control.)
 | DataKeysContainer | (Inherited from Control.)
 | DesignMode | (Inherited from Control.)
 | Dispose()()()() | (Inherited from Control.)
 | Disposed | (Inherited from Control.)
 | Enabled | (Inherited from WebControl.)
 | EnableTheming | (Inherited from WebControl.)
 | EnableViewState | (Inherited from Control.)
 | EndRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | EnsureChildControls()()()() | (Inherited from Control.)
 | EnsureID()()()() | (Inherited from Control.)
 | Equals(Object) | (Inherited from Object.)
 | Events | (Inherited from Control.)
 | Finalize()()()() | (Inherited from Object.)
 | FindControl(String) | (Inherited from Control.)
 | FindControl(String, Int32) | (Inherited from Control.)
 | Focus()()()() | (Inherited from Control.)
 | Font | (Inherited from WebControl.)
 | ForeColor | (Inherited from WebControl.)
 | GetDesignModeState()()()() | (Inherited from Control.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetRouteUrl(Object) | (Inherited from Control.)
 | GetRouteUrl(String, Object) | (Inherited from Control.)
 | GetRouteUrl(RouteValueDictionary) | (Inherited from Control.)
 | GetRouteUrl(String, RouteValueDictionary) | (Inherited from Control.)
 | GetType()()()() | (Inherited from Object.)
 | GetUniqueIDRelativeTo(Control) | (Inherited from Control.)
 | HasAttributes | (Inherited from WebControl.)
 | HasChildViewState | (Inherited from Control.)
 | HasControls()()()() | (Inherited from Control.)
 | HasEvents()()()() | (Inherited from Control.)
 | Height | (Inherited from WebControl.)
 | ID | (Inherited from Control.)
 | IdSeparator | (Inherited from Control.)
 | Init | (Inherited from Control.)
 | IsChildControlStateCleared | (Inherited from Control.)
 | IsEnabled | (Inherited from WebControl.)
 | IsLiteralContent()()()() | (Inherited from Control.)
 | IsTrackingViewState | (Inherited from Control.)
 | IsViewStateEnabled | (Inherited from Control.)
 | Load | (Inherited from Control.)
 | LoadControlState(Object) | (Inherited from Control.)
 | LoadViewState(Object) | (Inherited from WebControl.)
 | LoadViewStateByID | (Inherited from Control.)
 | MapPathSecure(String) | (Inherited from Control.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle(Style) | (Inherited from WebControl.)
 | NamingContainer | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | (Inherited from Control.)
 | OnDataBinding(EventArgs) | (Inherited from Control.)
 | OnInit(EventArgs) | (Inherited from Control.)
 | OnLoad(EventArgs) | (Inherited from Control.)
 | OnPreRender(EventArgs) | (Inherited from Control.)
 | OnUnload(EventArgs) | (Inherited from Control.)
 | OpenFile(String) | (Inherited from Control.)
 | Page | (Inherited from Control.)
 | Parent | (Inherited from Control.)
 | PreRender | (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | (Inherited from Control.)
 | RemovedControl(Control) | (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | See base (Overrides WebControl.RenderBeginTag(HtmlTextWriter).)
 | RenderChildren(HtmlTextWriter) | (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | See base (Overrides WebControl.RenderEndTag(HtmlTextWriter).)
 | RenderingCompatibility | (Inherited from Control.)
 | ResolveAdapter()()()() | (Inherited from Control.)
 | ResolveClientUrl(String) | (Inherited from Control.)
 | ResolveUrl(String) | (Inherited from Control.)
 | SaveControlState()()()() | (Inherited from Control.)
 | SaveViewState()()()() | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | (Inherited from Control.)
 | SetTraceData(Object, Object) | (Inherited from Control.)
 | SetTraceData(Object, Object, Object) | (Inherited from Control.)
 | Site | (Inherited from Control.)
 | SkinID | (Inherited from WebControl.)
 | Style | (Inherited from WebControl.)
 | SupportsDisabledAttribute | (Inherited from WebControl.)
 | TabIndex | (Inherited from WebControl.)
 | TagKey | (Inherited from WebControl.)
 | TagName | (Inherited from WebControl.)
 | TemplateControl | (Inherited from Control.)
 | TemplateSourceDirectory | (Inherited from Control.)
 | ToolTip | (Inherited from WebControl.)
 | ToString()()()() | (Inherited from Object.)
 | TrackViewState()()()() | (Inherited from WebControl.)
 | UniqueID | (Inherited from Control.)
 | Unload | (Inherited from Control.)
 | ValidateRequestMode | (Inherited from Control.)
 | ViewState | (Inherited from Control.)
 | ViewStateIgnoresCase | (Inherited from Control.)
 | ViewStateMode | (Inherited from Control.)
 | Visible | (Inherited from Control.)
 | Width | (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | FeaturedHeader

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FeaturedHeader Constructor

FeaturedHeader Constructor
API Documentation ► Keyoti.SearchEngine.Web.Templates ► FeaturedHeader ► FeaturedHeader()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public FeaturedHeader()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


RenderBeginTag Method (writer)

RenderBeginTag Method (writer)
API Documentation ► Keyoti.SearchEngine.Web.Templates ► FeaturedHeader ► RenderBeginTag(HtmlTextWriter)
Keyoti SearchUnit v6
See base
Declaration Syntax
C# Visual Basic
public override void RenderBeginTag(
    HtmlTextWriter writer
)
Public Overrides Sub RenderBeginTag (
    writer As HtmlTextWriter
)
Parameters
writer (HtmlTextWriter)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


RenderEndTag Method (writer)

RenderEndTag Method (writer)
API Documentation ► Keyoti.SearchEngine.Web.Templates ► FeaturedHeader ► RenderEndTag(HtmlTextWriter)
Keyoti SearchUnit v6
See base
Declaration Syntax
C# Visual Basic
public override void RenderEndTag(
    HtmlTextWriter writer
)
Public Overrides Sub RenderEndTag (
    writer As HtmlTextWriter
)
Parameters
writer (HtmlTextWriter)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FeaturedResultItem Class

FeaturedResultItem Class
API Documentation ► Keyoti.SearchEngine.Web.Templates ► FeaturedResultItem
Keyoti SearchUnit v6
A featured result item
Declaration Syntax
C# Visual Basic
public class FeaturedResultItem : WebControl,
    INamingContainer
Public Class FeaturedResultItem
    Inherits WebControl
    Implements INamingContainer
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FeaturedResultItem()()()() |
 | FeaturedResultItem(String, String, String) |
 | AccessKey | (Inherited from WebControl.)
 | Adapter | (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | (Inherited from Control.)
 | AddParsedSubObject(Object) | (Inherited from Control.)
 | ApplyStyle(Style) | (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | (Inherited from Control.)
 | Attributes | (Inherited from WebControl.)
 | BackColor | (Inherited from WebControl.)
 | BeginRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | BindingContainer | (Inherited from Control.)
 | BorderColor | (Inherited from WebControl.)
 | BorderStyle | (Inherited from WebControl.)
 | BorderWidth | (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | (Inherited from Control.)
 | ChildControlsCreated | (Inherited from Control.)
 | ClearCachedClientID()()()() | (Inherited from Control.)
 | ClearChildControlState()()()() | (Inherited from Control.)
 | ClearChildState()()()() | (Inherited from Control.)
 | ClearChildViewState()()()() | (Inherited from Control.)
 | ClearEffectiveClientIDMode()()()() | (Inherited from Control.)
 | ClientID | (Inherited from Control.)
 | ClientIDMode | (Inherited from Control.)
 | ClientIDSeparator | (Inherited from Control.)
 | Context | (Inherited from Control.)
 | Controls | (Inherited from Control.)
 | ControlStyle | (Inherited from WebControl.)
 | ControlStyleCreated | (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | (Inherited from WebControl.)
 | CreateChildControls()()()() | (Inherited from Control.)
 | CreateControlCollection()()()() | (Inherited from Control.)
 | CreateControlStyle()()()() | (Inherited from WebControl.)
 | CssClass | (Inherited from WebControl.)
 | DataBind()()()() | (Inherited from Control.)
 | DataBind(Boolean) | (Inherited from Control.)
 | DataBindChildren()()()() | (Inherited from Control.)
 | DataBinding | (Inherited from Control.)
 | DataItemContainer | (Inherited from Control.)
 | DataKeysContainer | (Inherited from Control.)
 | DesignMode | (Inherited from Control.)
 | Dispose()()()() | (Inherited from Control.)
 | Disposed | (Inherited from Control.)
 | Enabled | (Inherited from WebControl.)
 | EnableTheming | (Inherited from WebControl.)
 | EnableViewState | (Inherited from Control.)
 | EndRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | EnsureChildControls()()()() | (Inherited from Control.)
 | EnsureID()()()() | (Inherited from Control.)
 | Equals(Object) | (Inherited from Object.)
 | Events | (Inherited from Control.)
 | Finalize()()()() | (Inherited from Object.)
 | FindControl(String) | (Inherited from Control.)
 | FindControl(String, Int32) | (Inherited from Control.)
 | Focus()()()() | (Inherited from Control.)
 | Font | (Inherited from WebControl.)
 | ForeColor | (Inherited from WebControl.)
 | GetDesignModeState()()()() | (Inherited from Control.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetRouteUrl(Object) | (Inherited from Control.)
 | GetRouteUrl(String, Object) | (Inherited from Control.)
 | GetRouteUrl(RouteValueDictionary) | (Inherited from Control.)
 | GetRouteUrl(String, RouteValueDictionary) | (Inherited from Control.)
 | GetType()()()() | (Inherited from Object.)
 | GetUniqueIDRelativeTo(Control) | (Inherited from Control.)
 | HasAttributes | (Inherited from WebControl.)
 | HasChildViewState | (Inherited from Control.)
 | HasControls()()()() | (Inherited from Control.)
 | HasEvents()()()() | (Inherited from Control.)
 | Height | (Inherited from WebControl.)
 | ID | (Inherited from Control.)
 | IdSeparator | (Inherited from Control.)
 | Init | (Inherited from Control.)
 | IsChildControlStateCleared | (Inherited from Control.)
 | IsEnabled | (Inherited from WebControl.)
 | IsLiteralContent()()()() | (Inherited from Control.)
 | IsTrackingViewState | (Inherited from Control.)
 | IsViewStateEnabled | (Inherited from Control.)
 | Load | (Inherited from Control.)
 | LoadControlState(Object) | (Inherited from Control.)
 | LoadViewState(Object) | (Inherited from WebControl.)
 | LoadViewStateByID | (Inherited from Control.)
 | MapPathSecure(String) | (Inherited from Control.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle(Style) | (Inherited from WebControl.)
 | NamingContainer | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | (Inherited from Control.)
 | OnDataBinding(EventArgs) | (Inherited from Control.)
 | OnInit(EventArgs) | (Inherited from Control.)
 | OnLoad(EventArgs) | (Inherited from Control.)
 | OnPreRender(EventArgs) | (Inherited from Control.)
 | OnUnload(EventArgs) | (Inherited from Control.)
 | OpenFile(String) | (Inherited from Control.)
 | Page | (Inherited from Control.)
 | Parent | (Inherited from Control.)
 | PreRender | (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | (Inherited from Control.)
 | RemovedControl(Control) | (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | See base (Overrides WebControl.RenderBeginTag(HtmlTextWriter).)
 | RenderChildren(HtmlTextWriter) | (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | See base (Overrides WebControl.RenderEndTag(HtmlTextWriter).)
 | RenderingCompatibility | (Inherited from Control.)
 | ResolveAdapter()()()() | (Inherited from Control.)
 | ResolveClientUrl(String) | (Inherited from Control.)
 | ResolveUrl(String) | (Inherited from Control.)
 | SaveControlState()()()() | (Inherited from Control.)
 | SaveViewState()()()() | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | (Inherited from Control.)
 | SetTraceData(Object, Object) | (Inherited from Control.)
 | SetTraceData(Object, Object, Object) | (Inherited from Control.)
 | Site | (Inherited from Control.)
 | SkinID | (Inherited from WebControl.)
 | Style | (Inherited from WebControl.)
 | Summary |
 | SupportsDisabledAttribute | (Inherited from WebControl.)
 | TabIndex | (Inherited from WebControl.)
 | TagKey | (Inherited from WebControl.)
 | TagName | (Inherited from WebControl.)
 | TemplateControl | (Inherited from Control.)
 | TemplateSourceDirectory | (Inherited from Control.)
 | Title |
 | ToolTip | (Inherited from WebControl.)
 | ToString()()()() | (Inherited from Object.)
 | TrackViewState()()()() | (Inherited from WebControl.)
 | UniqueID | (Inherited from Control.)
 | Unload | (Inherited from Control.)
 | Uri |
 | ValidateRequestMode | (Inherited from Control.)
 | ViewState | (Inherited from Control.)
 | ViewStateIgnoresCase | (Inherited from Control.)
 | ViewStateMode | (Inherited from Control.)
 | Visible | (Inherited from Control.)
 | Width | (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | FeaturedResultItem

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FeaturedResultItem Constructor

FeaturedResultItem Constructor
API Documentation ► Keyoti.SearchEngine.Web.Templates ► FeaturedResultItem ► FeaturedResultItem()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FeaturedResultItem()()()() |
 | FeaturedResultItem(String, String, String) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FeaturedResultItem Constructor

FeaturedResultItem Constructor
API Documentation ► Keyoti.SearchEngine.Web.Templates ► FeaturedResultItem ► FeaturedResultItem()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public FeaturedResultItem()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FeaturedResultItem Constructor (uri, title, summary)

FeaturedResultItem Constructor (uri, title, summary)
API Documentation ► Keyoti.SearchEngine.Web.Templates ► FeaturedResultItem ► FeaturedResultItem(String, String, String)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public FeaturedResultItem(
    string uri,
    string title,
    string summary
)
Public Sub New (
    uri As String,
    title As String,
    summary As String
)
Parameters
uri (String)
title (String)
summary (String)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


RenderBeginTag Method (writer)

RenderBeginTag Method (writer)
API Documentation ► Keyoti.SearchEngine.Web.Templates ► FeaturedResultItem ► RenderBeginTag(HtmlTextWriter)
Keyoti SearchUnit v6
See base
Declaration Syntax
C# Visual Basic
public override void RenderBeginTag(
    HtmlTextWriter writer
)
Public Overrides Sub RenderBeginTag (
    writer As HtmlTextWriter
)
Parameters
writer (HtmlTextWriter)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


RenderEndTag Method (writer)

RenderEndTag Method (writer)
API Documentation ► Keyoti.SearchEngine.Web.Templates ► FeaturedResultItem ► RenderEndTag(HtmlTextWriter)
Keyoti SearchUnit v6
See base
Declaration Syntax
C# Visual Basic
public override void RenderEndTag(
    HtmlTextWriter writer
)
Public Overrides Sub RenderEndTag (
    writer As HtmlTextWriter
)
Parameters
writer (HtmlTextWriter)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Summary Property

Summary Property
API Documentation ► Keyoti.SearchEngine.Web.Templates ► FeaturedResultItem ► Summary
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public virtual string Summary { get; set; }
Public Overridable Property Summary As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Title Property

Title Property
API Documentation ► Keyoti.SearchEngine.Web.Templates ► FeaturedResultItem ► Title
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public virtual string Title { get; set; }
Public Overridable Property Title As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Uri Property

Uri Property
API Documentation ► Keyoti.SearchEngine.Web.Templates ► FeaturedResultItem ► Uri
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public virtual string Uri { get; set; }
Public Overridable Property Uri As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Keyoti.SearchEngine.WindowsService Namespace

Keyoti.SearchEngine.WindowsService Namespace
API Documentation ► Keyoti.SearchEngine.WindowsService
Keyoti SearchUnit v6
Windows Service classes
Types
All Types Classes Delegates
Icon | Type | Description
 | Configuration | Stores settings for the service.
 | ServiceConfiguration..::..IndexDirectoriesDataTable |
 | ServiceConfiguration..::..IndexDirectoriesRow |
 | ServiceConfiguration..::..IndexDirectoriesRowChangeEvent |
 | ServiceConfiguration..::..IndexDirectoriesRowChangeEventHandler |
 | ServiceConfiguration..::..IndexDirectoryDataTable |
 | ServiceConfiguration..::..IndexDirectoryRow |
 | ServiceConfiguration..::..IndexDirectoryRowChangeEvent |
 | ServiceConfiguration..::..IndexDirectoryRowChangeEventHandler |
 | ServiceConfiguration |
 | Task | Represents a task that the windows service will perform on an index directory.


Configuration Class

Configuration Class
API Documentation ► Keyoti.SearchEngine.WindowsService ► Configuration
Keyoti SearchUnit v6
Stores settings for the service.
Declaration Syntax
C# Visual Basic
public class Configuration
Public Class Configuration
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Configuration()()()() | New instance
 | Configuration(String) | New instance
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetIndexDirectories()()()() | Gets the index directories
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SetIndexDirectories(array<String>[]()[][]) | Sets the index directories
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
Configuration

Send comments on this topic to support@keyoti.com


Configuration Constructor

Configuration Constructor
API Documentation ► Keyoti.SearchEngine.WindowsService ► Configuration ► Configuration()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Configuration()()()() | New instance
 | Configuration(String) | New instance


Configuration Constructor

Configuration Constructor
API Documentation ► Keyoti.SearchEngine.WindowsService ► Configuration ► Configuration()()()()
Keyoti SearchUnit v6
New instance
Declaration Syntax
C# Visual Basic
public Configuration()
Public Sub New

Send comments on this topic to support@keyoti.com


Configuration Constructor (root)

Configuration Constructor (root)
API Documentation ► Keyoti.SearchEngine.WindowsService ► Configuration ► Configuration(String)
Keyoti SearchUnit v6
New instance
Declaration Syntax
C# Visual Basic
public Configuration(
    string root
)
Public Sub New (
    root As String
)
Parameters
root (String)


GetIndexDirectories Method

GetIndexDirectories Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► Configuration ► GetIndexDirectories()()()()
Keyoti SearchUnit v6
Gets the index directories
Declaration Syntax
C# Visual Basic
public string[] GetIndexDirectories()
Public Function GetIndexDirectories As String()
Return Value
array< String >[]()[][]


SetIndexDirectories Method (indexDirectories)

SetIndexDirectories Method (indexDirectories)
API Documentation ► Keyoti.SearchEngine.WindowsService ► Configuration ► SetIndexDirectories(array<String>[]()[][])
Keyoti SearchUnit v6
Sets the index directories
Declaration Syntax
C# Visual Basic
public void SetIndexDirectories(
    string[] indexDirectories
)
Public Sub SetIndexDirectories (
    indexDirectories As String()
)
Parameters
indexDirectories (array< String >[]()[][])


ServiceConfiguration Class

ServiceConfiguration Class
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
[SerializableAttribute]
public class ServiceConfiguration : DataSet
<SerializableAttribute>
Public Class ServiceConfiguration
    Inherits DataSet
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ServiceConfiguration()()()() |
 | ServiceConfiguration(SerializationInfo, StreamingContext) |
 | AcceptChanges()()()() | (Inherited from DataSet.)
 | BeginInit()()()() | (Inherited from DataSet.)
 | CaseSensitive | (Inherited from DataSet.)
 | Clear()()()() | (Inherited from DataSet.)
 | Clone()()()() | (Overrides DataSet.Clone()()()().)
 | Container | (Inherited from MarshalByValueComponent.)
 | Copy()()()() | (Inherited from DataSet.)
 | CreateDataReader()()()() | (Inherited from DataSet.)
 | CreateDataReader(array<DataTable>[]()[][]) | (Inherited from DataSet.)
 | DataSetName | (Inherited from DataSet.)
 | DefaultViewManager | (Inherited from DataSet.)
 | DesignMode | (Inherited from MarshalByValueComponent.)
 | DetermineSchemaSerializationMode(SerializationInfo, StreamingContext) | (Inherited from DataSet.)
 | DetermineSchemaSerializationMode(XmlReader) | (Inherited from DataSet.)
 | Dispose()()()() | (Inherited from MarshalByValueComponent.)
 | Dispose(Boolean) | (Inherited from MarshalByValueComponent.)
 | Disposed | (Inherited from MarshalByValueComponent.)
 | EndInit()()()() | (Inherited from DataSet.)
 | EnforceConstraints | (Inherited from DataSet.)
 | Equals(Object) | (Inherited from Object.)
 | Events | (Inherited from MarshalByValueComponent.)
 | ExtendedProperties | (Inherited from DataSet.)
 | Finalize()()()() | (Inherited from MarshalByValueComponent.)
 | GetChanges()()()() | (Inherited from DataSet.)
 | GetChanges(DataRowState) | (Inherited from DataSet.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | (Inherited from DataSet.)
 | GetSchemaSerializable()()()() | (Overrides DataSet.GetSchemaSerializable()()()().)
 | GetSerializationData(SerializationInfo, StreamingContext) | (Inherited from DataSet.)
 | GetService(Type) | (Inherited from MarshalByValueComponent.)
 | GetType()()()() | (Inherited from Object.)
 | GetXml()()()() | (Inherited from DataSet.)
 | GetXmlSchema()()()() | (Inherited from DataSet.)
 | HasChanges()()()() | (Inherited from DataSet.)
 | HasChanges(DataRowState) | (Inherited from DataSet.)
 | HasErrors | (Inherited from DataSet.)
 | IndexDirectories |
 | IndexDirectory |
 | InferXmlSchema(XmlReader, array<String>[]()[][]) | (Inherited from DataSet.)
 | InferXmlSchema(Stream, array<String>[]()[][]) | (Inherited from DataSet.)
 | InferXmlSchema(TextReader, array<String>[]()[][]) | (Inherited from DataSet.)
 | InferXmlSchema(String, array<String>[]()[][]) | (Inherited from DataSet.)
 | Initialized | (Inherited from DataSet.)
 | InitializeDerivedDataSet()()()() | (Inherited from DataSet.)
 | IsBinarySerialized(SerializationInfo, StreamingContext) | (Inherited from DataSet.)
 | IsInitialized | (Inherited from DataSet.)
 | Load(IDataReader, LoadOption, FillErrorEventHandler, array<DataTable>[]()[][]) | (Inherited from DataSet.)
 | Load(IDataReader, LoadOption, array<DataTable>[]()[][]) | (Inherited from DataSet.)
 | Load(IDataReader, LoadOption, array<String>[]()[][]) | (Inherited from DataSet.)
 | Locale | (Inherited from DataSet.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Merge(DataSet) | (Inherited from DataSet.)
 | Merge(DataSet, Boolean) | (Inherited from DataSet.)
 | Merge(DataSet, Boolean, MissingSchemaAction) | (Inherited from DataSet.)
 | Merge(DataTable) | (Inherited from DataSet.)
 | Merge(DataTable, Boolean, MissingSchemaAction) | (Inherited from DataSet.)
 | Merge(array<DataRow>[]()[][]) | (Inherited from DataSet.)
 | Merge(array<DataRow>[]()[][], Boolean, MissingSchemaAction) | (Inherited from DataSet.)
 | MergeFailed | (Inherited from DataSet.)
 | Namespace | (Inherited from DataSet.)
 | OnPropertyChanging(PropertyChangedEventArgs) | (Inherited from DataSet.)
 | OnRemoveRelation(DataRelation) | (Inherited from DataSet.)
 | OnRemoveTable(DataTable) | (Inherited from DataSet.)
 | Prefix | (Inherited from DataSet.)
 | RaisePropertyChanging(String) | (Inherited from DataSet.)
 | ReadXml(XmlReader) | (Inherited from DataSet.)
 | ReadXml(Stream) | (Inherited from DataSet.)
 | ReadXml(TextReader) | (Inherited from DataSet.)
 | ReadXml(String) | (Inherited from DataSet.)
 | ReadXml(XmlReader, XmlReadMode) | (Inherited from DataSet.)
 | ReadXml(Stream, XmlReadMode) | (Inherited from DataSet.)
 | ReadXml(TextReader, XmlReadMode) | (Inherited from DataSet.)
 | ReadXml(String, XmlReadMode) | (Inherited from DataSet.)
 | ReadXmlSchema(XmlReader) | (Inherited from DataSet.)
 | ReadXmlSchema(Stream) | (Inherited from DataSet.)
 | ReadXmlSchema(TextReader) | (Inherited from DataSet.)
 | ReadXmlSchema(String) | (Inherited from DataSet.)
 | ReadXmlSerializable(XmlReader) | (Overrides DataSet.ReadXmlSerializable(XmlReader).)
 | RejectChanges()()()() | (Inherited from DataSet.)
 | Relations | (Inherited from DataSet.)
 | RemotingFormat | (Inherited from DataSet.)
 | Reset()()()() | (Inherited from DataSet.)
 | SchemaSerializationMode | (Inherited from DataSet.)
 | ShouldSerializeRelations()()()() | (Overrides DataSet.ShouldSerializeRelations()()()().)
 | ShouldSerializeTables()()()() | (Overrides DataSet.ShouldSerializeTables()()()().)
 | Site | (Inherited from DataSet.)
 | Tables | (Inherited from DataSet.)
 | ToString()()()() | (Inherited from MarshalByValueComponent.)
 | WriteXml(Stream) | (Inherited from DataSet.)
 | WriteXml(TextWriter) | (Inherited from DataSet.)
 | WriteXml(XmlWriter) | (Inherited from DataSet.)
 | WriteXml(String) | (Inherited from DataSet.)
 | WriteXml(Stream, XmlWriteMode) | (Inherited from DataSet.)
 | WriteXml(TextWriter, XmlWriteMode) | (Inherited from DataSet.)
 | WriteXml(XmlWriter, XmlWriteMode) | (Inherited from DataSet.)
 | WriteXml(String, XmlWriteMode) | (Inherited from DataSet.)
 | WriteXmlSchema(Stream) | (Inherited from DataSet.)
 | WriteXmlSchema(Stream, Converter<(Of <<'(Type, String>)>>)) | (Inherited from DataSet.)
 | WriteXmlSchema(String) | (Inherited from DataSet.)
 | WriteXmlSchema(String, Converter<(Of <<'(Type, String>)>>)) | (Inherited from DataSet.)
 | WriteXmlSchema(TextWriter) | (Inherited from DataSet.)
 | WriteXmlSchema(TextWriter, Converter<(Of <<'(Type, String>)>>)) | (Inherited from DataSet.)
 | WriteXmlSchema(XmlWriter) | (Inherited from DataSet.)
 | WriteXmlSchema(XmlWriter, Converter<(Of <<'(Type, String>)>>)) | (Inherited from DataSet.)
Inheritance Hierarchy
Object
 | MarshalByValueComponent
 |  | DataSet
 |  |  | ServiceConfiguration


ServiceConfiguration Constructor

ServiceConfiguration Constructor
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration ► ServiceConfiguration()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | ServiceConfiguration()()()() |
 | ServiceConfiguration(SerializationInfo, StreamingContext) |


ServiceConfiguration Constructor

ServiceConfiguration Constructor
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration ► ServiceConfiguration()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public ServiceConfiguration()
Public Sub New

Send comments on this topic to support@keyoti.com


ServiceConfiguration Constructor (info, context)

ServiceConfiguration Constructor (info, context)
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration ► ServiceConfiguration(SerializationInfo, StreamingContext)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
protected ServiceConfiguration(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Parameters
info (SerializationInfo)
context (StreamingContext)


Clone Method

Clone Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration ► Clone()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public override DataSet Clone()
Public Overrides Function Clone As DataSet
Return Value
DataSet

Send comments on this topic to support@keyoti.com


GetSchemaSerializable Method

GetSchemaSerializable Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration ► GetSchemaSerializable()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
protected override XmlSchema GetSchemaSerializable()
Protected Overrides Function GetSchemaSerializable As XmlSchema
Return Value
XmlSchema

Send comments on this topic to support@keyoti.com


IndexDirectories Property

IndexDirectories Property
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration ► IndexDirectories
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public ServiceConfiguration..::..IndexDirectoriesDataTable IndexDirectories { get; }
Public ReadOnly Property IndexDirectories As ServiceConfiguration..::..IndexDirectoriesDataTable
    Get
Property Value
ServiceConfiguration..::..IndexDirectoriesDataTable


IndexDirectory Property

IndexDirectory Property
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration ► IndexDirectory
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public ServiceConfiguration..::..IndexDirectoryDataTable IndexDirectory { get; }
Public ReadOnly Property IndexDirectory As ServiceConfiguration..::..IndexDirectoryDataTable
    Get
Property Value
ServiceConfiguration..::..IndexDirectoryDataTable


ReadXmlSerializable Method (reader)

ReadXmlSerializable Method (reader)
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration ► ReadXmlSerializable(XmlReader)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
protected override void ReadXmlSerializable(
    XmlReader reader
)
Protected Overrides Sub ReadXmlSerializable (
    reader As XmlReader
)
Parameters
reader (XmlReader)


ShouldSerializeRelations Method

ShouldSerializeRelations Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration ► ShouldSerializeRelations()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
protected override bool ShouldSerializeRelations()
Protected Overrides Function ShouldSerializeRelations As Boolean
Return Value
Boolean

Send comments on this topic to support@keyoti.com


ShouldSerializeTables Method

ShouldSerializeTables Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration ► ShouldSerializeTables()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
protected override bool ShouldSerializeTables()
Protected Overrides Function ShouldSerializeTables As Boolean
Return Value
Boolean

Send comments on this topic to support@keyoti.com


ServiceConfiguration.IndexDirectoriesDataTable Class

ServiceConfiguration..::..IndexDirectoriesDataTable Class
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration ► ServiceConfiguration..::..IndexDirectoriesDataTable
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public class IndexDirectoriesDataTable : DataTable,
    IEnumerable
Public Class IndexDirectoriesDataTable
    Inherits DataTable
    Implements IEnumerable
Members
All Members | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AcceptChanges()()()() | (Inherited from DataTable.)
 | AddIndexDirectoriesRow(ServiceConfiguration..::..IndexDirectoriesRow) |
 | AddIndexDirectoriesRow()()()() |
 | BeginInit()()()() | (Inherited from DataTable.)
 | BeginLoadData()()()() | (Inherited from DataTable.)
 | CaseSensitive | (Inherited from DataTable.)
 | ChildRelations | (Inherited from DataTable.)
 | Clear()()()() | (Inherited from DataTable.)
 | Clone()()()() | (Overrides DataTable.Clone()()()().)
 | ColumnChanged | (Inherited from DataTable.)
 | ColumnChanging | (Inherited from DataTable.)
 | Columns | (Inherited from DataTable.)
 | Compute(String, String) | (Inherited from DataTable.)
 | Constraints | (Inherited from DataTable.)
 | Container | (Inherited from MarshalByValueComponent.)
 | Copy()()()() | (Inherited from DataTable.)
 | Count |
 | CreateDataReader()()()() | (Inherited from DataTable.)
 | CreateInstance()()()() | (Overrides DataTable.CreateInstance()()()().)
 | DataSet | (Inherited from DataTable.)
 | DefaultView | (Inherited from DataTable.)
 | DesignMode | (Inherited from MarshalByValueComponent.)
 | DisplayExpression | (Inherited from DataTable.)
 | Dispose()()()() | (Inherited from MarshalByValueComponent.)
 | Dispose(Boolean) | (Inherited from MarshalByValueComponent.)
 | Disposed | (Inherited from MarshalByValueComponent.)
 | EndInit()()()() | (Inherited from DataTable.)
 | EndLoadData()()()() | (Inherited from DataTable.)
 | Equals(Object) | (Inherited from Object.)
 | Events | (Inherited from MarshalByValueComponent.)
 | ExtendedProperties | (Inherited from DataTable.)
 | Finalize()()()() | (Inherited from MarshalByValueComponent.)
 | fInitInProgress | (Inherited from DataTable.)
 | GetChanges()()()() | (Inherited from DataTable.)
 | GetChanges(DataRowState) | (Inherited from DataTable.)
 | GetEnumerator()()()() |
 | GetErrors()()()() | (Inherited from DataTable.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | (Inherited from DataTable.)
 | GetRowType()()()() | (Overrides DataTable.GetRowType()()()().)
 | GetSchema()()()() | (Inherited from DataTable.)
 | GetService(Type) | (Inherited from MarshalByValueComponent.)
 | GetType()()()() | (Inherited from Object.)
 | HasErrors | (Inherited from DataTable.)
 | ImportRow(DataRow) | (Inherited from DataTable.)
 | IndexDirectoriesRowChanged |
 | IndexDirectoriesRowChanging |
 | IndexDirectoriesRowDeleted |
 | IndexDirectoriesRowDeleting |
 | Initialized | (Inherited from DataTable.)
 | IsInitialized | (Inherited from DataTable.)
 | Item[([( Int32])]) |
 | Load(IDataReader) | (Inherited from DataTable.)
 | Load(IDataReader, LoadOption) | (Inherited from DataTable.)
 | Load(IDataReader, LoadOption, FillErrorEventHandler) | (Inherited from DataTable.)
 | LoadDataRow(array<Object>[]()[][], Boolean) | (Inherited from DataTable.)
 | LoadDataRow(array<Object>[]()[][], LoadOption) | (Inherited from DataTable.)
 | Locale | (Inherited from DataTable.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Merge(DataTable) | (Inherited from DataTable.)
 | Merge(DataTable, Boolean) | (Inherited from DataTable.)
 | Merge(DataTable, Boolean, MissingSchemaAction) | (Inherited from DataTable.)
 | MinimumCapacity | (Inherited from DataTable.)
 | Namespace | (Inherited from DataTable.)
 | NewIndexDirectoriesRow()()()() |
 | NewRow()()()() | (Inherited from DataTable.)
 | NewRowArray(Int32) | (Inherited from DataTable.)
 | NewRowFromBuilder(DataRowBuilder) | (Overrides DataTable.NewRowFromBuilder(DataRowBuilder).)
 | OnColumnChanged(DataColumnChangeEventArgs) | (Inherited from DataTable.)
 | OnColumnChanging(DataColumnChangeEventArgs) | (Inherited from DataTable.)
 | OnPropertyChanging(PropertyChangedEventArgs) | (Inherited from DataTable.)
 | OnRemoveColumn(DataColumn) | (Inherited from DataTable.)
 | OnRowChanged(DataRowChangeEventArgs) | (Overrides DataTable.OnRowChanged(DataRowChangeEventArgs).)
 | OnRowChanging(DataRowChangeEventArgs) | (Overrides DataTable.OnRowChanging(DataRowChangeEventArgs).)
 | OnRowDeleted(DataRowChangeEventArgs) | (Overrides DataTable.OnRowDeleted(DataRowChangeEventArgs).)
 | OnRowDeleting(DataRowChangeEventArgs) | (Overrides DataTable.OnRowDeleting(DataRowChangeEventArgs).)
 | OnTableCleared(DataTableClearEventArgs) | (Inherited from DataTable.)
 | OnTableClearing(DataTableClearEventArgs) | (Inherited from DataTable.)
 | OnTableNewRow(DataTableNewRowEventArgs) | (Inherited from DataTable.)
 | ParentRelations | (Inherited from DataTable.)
 | Prefix | (Inherited from DataTable.)
 | PrimaryKey | (Inherited from DataTable.)
 | ReadXml(Stream) | (Inherited from DataTable.)
 | ReadXml(TextReader) | (Inherited from DataTable.)
 | ReadXml(String) | (Inherited from DataTable.)
 | ReadXml(XmlReader) | (Inherited from DataTable.)
 | ReadXmlSchema(Stream) | (Inherited from DataTable.)
 | ReadXmlSchema(TextReader) | (Inherited from DataTable.)
 | ReadXmlSchema(String) | (Inherited from DataTable.)
 | ReadXmlSchema(XmlReader) | (Inherited from DataTable.)
 | ReadXmlSerializable(XmlReader) | (Inherited from DataTable.)
 | RejectChanges()()()() | (Inherited from DataTable.)
 | RemotingFormat | (Inherited from DataTable.)
 | RemoveIndexDirectoriesRow(ServiceConfiguration..::..IndexDirectoriesRow) |
 | Reset()()()() | (Inherited from DataTable.)
 | RowChanged | (Inherited from DataTable.)
 | RowChanging | (Inherited from DataTable.)
 | RowDeleted | (Inherited from DataTable.)
 | RowDeleting | (Inherited from DataTable.)
 | Rows | (Inherited from DataTable.)
 | Select()()()() | (Inherited from DataTable.)
 | Select(String) | (Inherited from DataTable.)
 | Select(String, String) | (Inherited from DataTable.)
 | Select(String, String, DataViewRowState) | (Inherited from DataTable.)
 | Site | (Inherited from DataTable.)
 | TableCleared | (Inherited from DataTable.)
 | TableClearing | (Inherited from DataTable.)
 | TableName | (Inherited from DataTable.)
 | TableNewRow | (Inherited from DataTable.)
 | ToString()()()() | (Inherited from DataTable.)
 | WriteXml(Stream) | (Inherited from DataTable.)
 | WriteXml(Stream, Boolean) | (Inherited from DataTable.)
 | WriteXml(TextWriter) | (Inherited from DataTable.)
 | WriteXml(TextWriter, Boolean) | (Inherited from DataTable.)
 | WriteXml(XmlWriter) | (Inherited from DataTable.)
 | WriteXml(XmlWriter, Boolean) | (Inherited from DataTable.)
 | WriteXml(String) | (Inherited from DataTable.)
 | WriteXml(String, Boolean) | (Inherited from DataTable.)
 | WriteXml(Stream, XmlWriteMode) | (Inherited from DataTable.)
 | WriteXml(Stream, XmlWriteMode, Boolean) | (Inherited from DataTable.)
 | WriteXml(TextWriter, XmlWriteMode) | (Inherited from DataTable.)
 | WriteXml(TextWriter, XmlWriteMode, Boolean) | (Inherited from DataTable.)
 | WriteXml(XmlWriter, XmlWriteMode) | (Inherited from DataTable.)
 | WriteXml(XmlWriter, XmlWriteMode, Boolean) | (Inherited from DataTable.)
 | WriteXml(String, XmlWriteMode) | (Inherited from DataTable.)
 | WriteXml(String, XmlWriteMode, Boolean) | (Inherited from DataTable.)
 | WriteXmlSchema(Stream) | (Inherited from DataTable.)
 | WriteXmlSchema(Stream, Boolean) | (Inherited from DataTable.)
 | WriteXmlSchema(TextWriter) | (Inherited from DataTable.)
 | WriteXmlSchema(TextWriter, Boolean) | (Inherited from DataTable.)
 | WriteXmlSchema(XmlWriter) | (Inherited from DataTable.)
 | WriteXmlSchema(XmlWriter, Boolean) | (Inherited from DataTable.)
 | WriteXmlSchema(String) | (Inherited from DataTable.)
 | WriteXmlSchema(String, Boolean) | (Inherited from DataTable.)
Inheritance Hierarchy
Object
 | MarshalByValueComponent
 |  | DataTable
 |  |  | ServiceConfiguration..::..IndexDirectoriesDataTable


AddIndexDirectoriesRow Method

AddIndexDirectoriesRow Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoriesDataTable ► AddIndexDirectoriesRow()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | AddIndexDirectoriesRow(ServiceConfiguration..::..IndexDirectoriesRow) |
 | AddIndexDirectoriesRow()()()() |


AddIndexDirectoriesRow Method

AddIndexDirectoriesRow Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoriesDataTable ► AddIndexDirectoriesRow()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public ServiceConfiguration..::..IndexDirectoriesRow AddIndexDirectoriesRow()
Public Function AddIndexDirectoriesRow As ServiceConfiguration..::..IndexDirectoriesRow
Return Value
ServiceConfiguration..::..IndexDirectoriesRow


AddIndexDirectoriesRow Method (row)

AddIndexDirectoriesRow Method (row)
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoriesDataTable ► AddIndexDirectoriesRow(ServiceConfiguration..::..IndexDirectoriesRow)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public void AddIndexDirectoriesRow(
    ServiceConfiguration..::..IndexDirectoriesRow row
)
Public Sub AddIndexDirectoriesRow (
    row As ServiceConfiguration..::..IndexDirectoriesRow
)
Parameters
row (ServiceConfiguration..::..IndexDirectoriesRow)


Clone Method

Clone Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoriesDataTable ► Clone()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public override DataTable Clone()
Public Overrides Function Clone As DataTable
Return Value
DataTable

Send comments on this topic to support@keyoti.com


Count Property

Count Property
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoriesDataTable ► Count
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
Property Value
Int32

Send comments on this topic to support@keyoti.com


CreateInstance Method

CreateInstance Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoriesDataTable ► CreateInstance()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
protected override DataTable CreateInstance()
Protected Overrides Function CreateInstance As DataTable
Return Value
DataTable

Send comments on this topic to support@keyoti.com


GetEnumerator Method

GetEnumerator Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoriesDataTable ► GetEnumerator()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
Return Value
IEnumerator

Send comments on this topic to support@keyoti.com


GetRowType Method

GetRowType Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoriesDataTable ► GetRowType()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
protected override Type GetRowType()
Protected Overrides Function GetRowType As Type
Return Value
Type

Send comments on this topic to support@keyoti.com


IndexDirectoriesRowChanged Event

IndexDirectoriesRowChanged Event
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoriesDataTable ► IndexDirectoriesRowChanged
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public event ServiceConfiguration..::..IndexDirectoriesRowChangeEventHandler IndexDirectoriesRowChanged
Public Event IndexDirectoriesRowChanged As ServiceConfiguration..::..IndexDirectoriesRowChangeEventHandler
Value
ServiceConfiguration..::..IndexDirectoriesRowChangeEventHandler


IndexDirectoriesRowChanging Event

IndexDirectoriesRowChanging Event
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoriesDataTable ► IndexDirectoriesRowChanging
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public event ServiceConfiguration..::..IndexDirectoriesRowChangeEventHandler IndexDirectoriesRowChanging
Public Event IndexDirectoriesRowChanging As ServiceConfiguration..::..IndexDirectoriesRowChangeEventHandler
Value
ServiceConfiguration..::..IndexDirectoriesRowChangeEventHandler


IndexDirectoriesRowDeleted Event

IndexDirectoriesRowDeleted Event
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoriesDataTable ► IndexDirectoriesRowDeleted
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public event ServiceConfiguration..::..IndexDirectoriesRowChangeEventHandler IndexDirectoriesRowDeleted
Public Event IndexDirectoriesRowDeleted As ServiceConfiguration..::..IndexDirectoriesRowChangeEventHandler
Value
ServiceConfiguration..::..IndexDirectoriesRowChangeEventHandler


IndexDirectoriesRowDeleting Event

IndexDirectoriesRowDeleting Event
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoriesDataTable ► IndexDirectoriesRowDeleting
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public event ServiceConfiguration..::..IndexDirectoriesRowChangeEventHandler IndexDirectoriesRowDeleting
Public Event IndexDirectoriesRowDeleting As ServiceConfiguration..::..IndexDirectoriesRowChangeEventHandler
Value
ServiceConfiguration..::..IndexDirectoriesRowChangeEventHandler


Item Property (index)

Item Property (index)
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoriesDataTable ► Item[([( Int32])])
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public ServiceConfiguration..::..IndexDirectoriesRow this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As ServiceConfiguration..::..IndexDirectoriesRow
    Get
Parameters
index (Int32)
Property Value
ServiceConfiguration..::..IndexDirectoriesRow


NewIndexDirectoriesRow Method

NewIndexDirectoriesRow Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoriesDataTable ► NewIndexDirectoriesRow()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public ServiceConfiguration..::..IndexDirectoriesRow NewIndexDirectoriesRow()
Public Function NewIndexDirectoriesRow As ServiceConfiguration..::..IndexDirectoriesRow
Return Value
ServiceConfiguration..::..IndexDirectoriesRow


NewRowFromBuilder Method (builder)

NewRowFromBuilder Method (builder)
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoriesDataTable ► NewRowFromBuilder(DataRowBuilder)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
protected override DataRow NewRowFromBuilder(
    DataRowBuilder builder
)
Protected Overrides Function NewRowFromBuilder (
    builder As DataRowBuilder
) As DataRow
Parameters
builder (DataRowBuilder)
Return Value
DataRow

Send comments on this topic to support@keyoti.com


OnRowChanged Method (e)

OnRowChanged Method (e)
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoriesDataTable ► OnRowChanged(DataRowChangeEventArgs)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
protected override void OnRowChanged(
    DataRowChangeEventArgs e
)
Protected Overrides Sub OnRowChanged (
    e As DataRowChangeEventArgs
)
Parameters
e (DataRowChangeEventArgs)


OnRowChanging Method (e)

OnRowChanging Method (e)
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoriesDataTable ► OnRowChanging(DataRowChangeEventArgs)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
protected override void OnRowChanging(
    DataRowChangeEventArgs e
)
Protected Overrides Sub OnRowChanging (
    e As DataRowChangeEventArgs
)
Parameters
e (DataRowChangeEventArgs)


OnRowDeleted Method (e)

OnRowDeleted Method (e)
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoriesDataTable ► OnRowDeleted(DataRowChangeEventArgs)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
protected override void OnRowDeleted(
    DataRowChangeEventArgs e
)
Protected Overrides Sub OnRowDeleted (
    e As DataRowChangeEventArgs
)
Parameters
e (DataRowChangeEventArgs)


OnRowDeleting Method (e)

OnRowDeleting Method (e)
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoriesDataTable ► OnRowDeleting(DataRowChangeEventArgs)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
protected override void OnRowDeleting(
    DataRowChangeEventArgs e
)
Protected Overrides Sub OnRowDeleting (
    e As DataRowChangeEventArgs
)
Parameters
e (DataRowChangeEventArgs)


RemoveIndexDirectoriesRow Method (row)

RemoveIndexDirectoriesRow Method (row)
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoriesDataTable ► RemoveIndexDirectoriesRow(ServiceConfiguration..::..IndexDirectoriesRow)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public void RemoveIndexDirectoriesRow(
    ServiceConfiguration..::..IndexDirectoriesRow row
)
Public Sub RemoveIndexDirectoriesRow (
    row As ServiceConfiguration..::..IndexDirectoriesRow
)
Parameters
row (ServiceConfiguration..::..IndexDirectoriesRow)


ServiceConfiguration.IndexDirectoriesRow Class

ServiceConfiguration..::..IndexDirectoriesRow Class
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration ► ServiceConfiguration..::..IndexDirectoriesRow
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public class IndexDirectoriesRow : DataRow
Public Class IndexDirectoriesRow
    Inherits DataRow
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AcceptChanges()()()() | (Inherited from DataRow.)
 | BeginEdit()()()() | (Inherited from DataRow.)
 | CancelEdit()()()() | (Inherited from DataRow.)
 | ClearErrors()()()() | (Inherited from DataRow.)
 | Delete()()()() | (Inherited from DataRow.)
 | EndEdit()()()() | (Inherited from DataRow.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetChildRows(String) | (Inherited from DataRow.)
 | GetChildRows(String, DataRowVersion) | (Inherited from DataRow.)
 | GetChildRows(DataRelation) | (Inherited from DataRow.)
 | GetChildRows(DataRelation, DataRowVersion) | (Inherited from DataRow.)
 | GetColumnError(Int32) | (Inherited from DataRow.)
 | GetColumnError(String) | (Inherited from DataRow.)
 | GetColumnError(DataColumn) | (Inherited from DataRow.)
 | GetColumnsInError()()()() | (Inherited from DataRow.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetIndexDirectoryRows()()()() |
 | GetParentRow(String) | (Inherited from DataRow.)
 | GetParentRow(String, DataRowVersion) | (Inherited from DataRow.)
 | GetParentRow(DataRelation) | (Inherited from DataRow.)
 | GetParentRow(DataRelation, DataRowVersion) | (Inherited from DataRow.)
 | GetParentRows(String) | (Inherited from DataRow.)
 | GetParentRows(String, DataRowVersion) | (Inherited from DataRow.)
 | GetParentRows(DataRelation) | (Inherited from DataRow.)
 | GetParentRows(DataRelation, DataRowVersion) | (Inherited from DataRow.)
 | GetType()()()() | (Inherited from Object.)
 | HasErrors | (Inherited from DataRow.)
 | HasVersion(DataRowVersion) | (Inherited from DataRow.)
 | IsNull(Int32) | (Inherited from DataRow.)
 | IsNull(String) | (Inherited from DataRow.)
 | IsNull(DataColumn) | (Inherited from DataRow.)
 | IsNull(DataColumn, DataRowVersion) | (Inherited from DataRow.)
 | Item[([( Int32])]) | (Inherited from DataRow.)
 | Item[([( String])]) | (Inherited from DataRow.)
 | Item[([( DataColumn])]) | (Inherited from DataRow.)
 | Item[([( Int32, DataRowVersion])]) | (Inherited from DataRow.)
 | Item[([( String, DataRowVersion])]) | (Inherited from DataRow.)
 | Item[([( DataColumn, DataRowVersion])]) | (Inherited from DataRow.)
 | ItemArray | (Inherited from DataRow.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | RejectChanges()()()() | (Inherited from DataRow.)
 | RowError | (Inherited from DataRow.)
 | RowState | (Inherited from DataRow.)
 | SetAdded()()()() | (Inherited from DataRow.)
 | SetColumnError(Int32, String) | (Inherited from DataRow.)
 | SetColumnError(String, String) | (Inherited from DataRow.)
 | SetColumnError(DataColumn, String) | (Inherited from DataRow.)
 | SetModified()()()() | (Inherited from DataRow.)
 | SetNull(DataColumn) | (Inherited from DataRow.)
 | SetParentRow(DataRow) | (Inherited from DataRow.)
 | SetParentRow(DataRow, DataRelation) | (Inherited from DataRow.)
 | Table | (Inherited from DataRow.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | DataRow
 |  | ServiceConfiguration..::..IndexDirectoriesRow


GetIndexDirectoryRows Method

GetIndexDirectoryRows Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoriesRow ► GetIndexDirectoryRows()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public ServiceConfiguration..::..IndexDirectoryRow[] GetIndexDirectoryRows()
Public Function GetIndexDirectoryRows As ServiceConfiguration..::..IndexDirectoryRow()
Return Value
array< ServiceConfiguration..::..IndexDirectoryRow >[]()[][]


ServiceConfiguration.IndexDirectoriesRowChangeEvent Class

ServiceConfiguration..::..IndexDirectoriesRowChangeEvent Class
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration ► ServiceConfiguration..::..IndexDirectoriesRowChangeEvent
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public class IndexDirectoriesRowChangeEvent : EventArgs
Public Class IndexDirectoriesRowChangeEvent
    Inherits EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ServiceConfiguration..::..IndexDirectoriesRowChangeEvent(ServiceConfiguration..::..IndexDirectoriesRow, DataRowAction) |
 | Action |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Row |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | ServiceConfiguration..::..IndexDirectoriesRowChangeEvent


ServiceConfiguration.IndexDirectoriesRowChangeEvent Constructor (row, action)

ServiceConfiguration..::..IndexDirectoriesRowChangeEvent Constructor (row, action)
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoriesRowChangeEvent ► ServiceConfiguration..::..IndexDirectoriesRowChangeEvent(ServiceConfiguration..::..IndexDirectoriesRow, DataRowAction)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public IndexDirectoriesRowChangeEvent(
    ServiceConfiguration..::..IndexDirectoriesRow row,
    DataRowAction action
)
Public Sub New (
    row As ServiceConfiguration..::..IndexDirectoriesRow,
    action As DataRowAction
)
Parameters
row (ServiceConfiguration..::..IndexDirectoriesRow)
action (DataRowAction)


Action Property

Action Property
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoriesRowChangeEvent ► Action
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public DataRowAction Action { get; }
Public ReadOnly Property Action As DataRowAction
    Get
Property Value
DataRowAction

Send comments on this topic to support@keyoti.com


Row Property

Row Property
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoriesRowChangeEvent ► Row
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public ServiceConfiguration..::..IndexDirectoriesRow Row { get; }
Public ReadOnly Property Row As ServiceConfiguration..::..IndexDirectoriesRow
    Get
Property Value
ServiceConfiguration..::..IndexDirectoriesRow


ServiceConfiguration.IndexDirectoriesRowChangeEventHandler Delegate

ServiceConfiguration..::..IndexDirectoriesRowChangeEventHandler Delegate
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration ► ServiceConfiguration..::..IndexDirectoriesRowChangeEventHandler
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public delegate void IndexDirectoriesRowChangeEventHandler(
    Object sender,
    ServiceConfiguration..::..IndexDirectoriesRowChangeEvent e
)
Public Delegate Sub IndexDirectoriesRowChangeEventHandler (
    sender As Object,
    e As ServiceConfiguration..::..IndexDirectoriesRowChangeEvent
)
Parameters
sender (Object)
e (ServiceConfiguration..::..IndexDirectoriesRowChangeEvent)


ServiceConfiguration.IndexDirectoryDataTable Class

ServiceConfiguration..::..IndexDirectoryDataTable Class
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration ► ServiceConfiguration..::..IndexDirectoryDataTable
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public class IndexDirectoryDataTable : DataTable,
    IEnumerable
Public Class IndexDirectoryDataTable
    Inherits DataTable
    Implements IEnumerable
Members
All Members | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AcceptChanges()()()() | (Inherited from DataTable.)
 | AddIndexDirectoryRow(ServiceConfiguration..::..IndexDirectoryRow) |
 | AddIndexDirectoryRow(String, ServiceConfiguration..::..IndexDirectoriesRow) |
 | BeginInit()()()() | (Inherited from DataTable.)
 | BeginLoadData()()()() | (Inherited from DataTable.)
 | CaseSensitive | (Inherited from DataTable.)
 | ChildRelations | (Inherited from DataTable.)
 | Clear()()()() | (Inherited from DataTable.)
 | Clone()()()() | (Overrides DataTable.Clone()()()().)
 | ColumnChanged | (Inherited from DataTable.)
 | ColumnChanging | (Inherited from DataTable.)
 | Columns | (Inherited from DataTable.)
 | Compute(String, String) | (Inherited from DataTable.)
 | Constraints | (Inherited from DataTable.)
 | Container | (Inherited from MarshalByValueComponent.)
 | Copy()()()() | (Inherited from DataTable.)
 | Count |
 | CreateDataReader()()()() | (Inherited from DataTable.)
 | CreateInstance()()()() | (Overrides DataTable.CreateInstance()()()().)
 | DataSet | (Inherited from DataTable.)
 | DefaultView | (Inherited from DataTable.)
 | DesignMode | (Inherited from MarshalByValueComponent.)
 | DisplayExpression | (Inherited from DataTable.)
 | Dispose()()()() | (Inherited from MarshalByValueComponent.)
 | Dispose(Boolean) | (Inherited from MarshalByValueComponent.)
 | Disposed | (Inherited from MarshalByValueComponent.)
 | EndInit()()()() | (Inherited from DataTable.)
 | EndLoadData()()()() | (Inherited from DataTable.)
 | Equals(Object) | (Inherited from Object.)
 | Events | (Inherited from MarshalByValueComponent.)
 | ExtendedProperties | (Inherited from DataTable.)
 | Finalize()()()() | (Inherited from MarshalByValueComponent.)
 | fInitInProgress | (Inherited from DataTable.)
 | GetChanges()()()() | (Inherited from DataTable.)
 | GetChanges(DataRowState) | (Inherited from DataTable.)
 | GetEnumerator()()()() |
 | GetErrors()()()() | (Inherited from DataTable.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | (Inherited from DataTable.)
 | GetRowType()()()() | (Overrides DataTable.GetRowType()()()().)
 | GetSchema()()()() | (Inherited from DataTable.)
 | GetService(Type) | (Inherited from MarshalByValueComponent.)
 | GetType()()()() | (Inherited from Object.)
 | HasErrors | (Inherited from DataTable.)
 | ImportRow(DataRow) | (Inherited from DataTable.)
 | IndexDirectoryRowChanged |
 | IndexDirectoryRowChanging |
 | IndexDirectoryRowDeleted |
 | IndexDirectoryRowDeleting |
 | Initialized | (Inherited from DataTable.)
 | IsInitialized | (Inherited from DataTable.)
 | Item[([( Int32])]) |
 | Load(IDataReader) | (Inherited from DataTable.)
 | Load(IDataReader, LoadOption) | (Inherited from DataTable.)
 | Load(IDataReader, LoadOption, FillErrorEventHandler) | (Inherited from DataTable.)
 | LoadDataRow(array<Object>[]()[][], Boolean) | (Inherited from DataTable.)
 | LoadDataRow(array<Object>[]()[][], LoadOption) | (Inherited from DataTable.)
 | Locale | (Inherited from DataTable.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Merge(DataTable) | (Inherited from DataTable.)
 | Merge(DataTable, Boolean) | (Inherited from DataTable.)
 | Merge(DataTable, Boolean, MissingSchemaAction) | (Inherited from DataTable.)
 | MinimumCapacity | (Inherited from DataTable.)
 | Namespace | (Inherited from DataTable.)
 | NewIndexDirectoryRow()()()() |
 | NewRow()()()() | (Inherited from DataTable.)
 | NewRowArray(Int32) | (Inherited from DataTable.)
 | NewRowFromBuilder(DataRowBuilder) | (Overrides DataTable.NewRowFromBuilder(DataRowBuilder).)
 | OnColumnChanged(DataColumnChangeEventArgs) | (Inherited from DataTable.)
 | OnColumnChanging(DataColumnChangeEventArgs) | (Inherited from DataTable.)
 | OnPropertyChanging(PropertyChangedEventArgs) | (Inherited from DataTable.)
 | OnRemoveColumn(DataColumn) | (Inherited from DataTable.)
 | OnRowChanged(DataRowChangeEventArgs) | (Overrides DataTable.OnRowChanged(DataRowChangeEventArgs).)
 | OnRowChanging(DataRowChangeEventArgs) | (Overrides DataTable.OnRowChanging(DataRowChangeEventArgs).)
 | OnRowDeleted(DataRowChangeEventArgs) | (Overrides DataTable.OnRowDeleted(DataRowChangeEventArgs).)
 | OnRowDeleting(DataRowChangeEventArgs) | (Overrides DataTable.OnRowDeleting(DataRowChangeEventArgs).)
 | OnTableCleared(DataTableClearEventArgs) | (Inherited from DataTable.)
 | OnTableClearing(DataTableClearEventArgs) | (Inherited from DataTable.)
 | OnTableNewRow(DataTableNewRowEventArgs) | (Inherited from DataTable.)
 | ParentRelations | (Inherited from DataTable.)
 | Prefix | (Inherited from DataTable.)
 | PrimaryKey | (Inherited from DataTable.)
 | ReadXml(Stream) | (Inherited from DataTable.)
 | ReadXml(TextReader) | (Inherited from DataTable.)
 | ReadXml(String) | (Inherited from DataTable.)
 | ReadXml(XmlReader) | (Inherited from DataTable.)
 | ReadXmlSchema(Stream) | (Inherited from DataTable.)
 | ReadXmlSchema(TextReader) | (Inherited from DataTable.)
 | ReadXmlSchema(String) | (Inherited from DataTable.)
 | ReadXmlSchema(XmlReader) | (Inherited from DataTable.)
 | ReadXmlSerializable(XmlReader) | (Inherited from DataTable.)
 | RejectChanges()()()() | (Inherited from DataTable.)
 | RemotingFormat | (Inherited from DataTable.)
 | RemoveIndexDirectoryRow(ServiceConfiguration..::..IndexDirectoryRow) |
 | Reset()()()() | (Inherited from DataTable.)
 | RowChanged | (Inherited from DataTable.)
 | RowChanging | (Inherited from DataTable.)
 | RowDeleted | (Inherited from DataTable.)
 | RowDeleting | (Inherited from DataTable.)
 | Rows | (Inherited from DataTable.)
 | Select()()()() | (Inherited from DataTable.)
 | Select(String) | (Inherited from DataTable.)
 | Select(String, String) | (Inherited from DataTable.)
 | Select(String, String, DataViewRowState) | (Inherited from DataTable.)
 | Site | (Inherited from DataTable.)
 | TableCleared | (Inherited from DataTable.)
 | TableClearing | (Inherited from DataTable.)
 | TableName | (Inherited from DataTable.)
 | TableNewRow | (Inherited from DataTable.)
 | ToString()()()() | (Inherited from DataTable.)
 | WriteXml(Stream) | (Inherited from DataTable.)
 | WriteXml(Stream, Boolean) | (Inherited from DataTable.)
 | WriteXml(TextWriter) | (Inherited from DataTable.)
 | WriteXml(TextWriter, Boolean) | (Inherited from DataTable.)
 | WriteXml(XmlWriter) | (Inherited from DataTable.)
 | WriteXml(XmlWriter, Boolean) | (Inherited from DataTable.)
 | WriteXml(String) | (Inherited from DataTable.)
 | WriteXml(String, Boolean) | (Inherited from DataTable.)
 | WriteXml(Stream, XmlWriteMode) | (Inherited from DataTable.)
 | WriteXml(Stream, XmlWriteMode, Boolean) | (Inherited from DataTable.)
 | WriteXml(TextWriter, XmlWriteMode) | (Inherited from DataTable.)
 | WriteXml(TextWriter, XmlWriteMode, Boolean) | (Inherited from DataTable.)
 | WriteXml(XmlWriter, XmlWriteMode) | (Inherited from DataTable.)
 | WriteXml(XmlWriter, XmlWriteMode, Boolean) | (Inherited from DataTable.)
 | WriteXml(String, XmlWriteMode) | (Inherited from DataTable.)
 | WriteXml(String, XmlWriteMode, Boolean) | (Inherited from DataTable.)
 | WriteXmlSchema(Stream) | (Inherited from DataTable.)
 | WriteXmlSchema(Stream, Boolean) | (Inherited from DataTable.)
 | WriteXmlSchema(TextWriter) | (Inherited from DataTable.)
 | WriteXmlSchema(TextWriter, Boolean) | (Inherited from DataTable.)
 | WriteXmlSchema(XmlWriter) | (Inherited from DataTable.)
 | WriteXmlSchema(XmlWriter, Boolean) | (Inherited from DataTable.)
 | WriteXmlSchema(String) | (Inherited from DataTable.)
 | WriteXmlSchema(String, Boolean) | (Inherited from DataTable.)
Inheritance Hierarchy
Object
 | MarshalByValueComponent
 |  | DataTable
 |  |  | ServiceConfiguration..::..IndexDirectoryDataTable


AddIndexDirectoryRow Method

AddIndexDirectoryRow Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoryDataTable ► AddIndexDirectoryRow()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | AddIndexDirectoryRow(ServiceConfiguration..::..IndexDirectoryRow) |
 | AddIndexDirectoryRow(String, ServiceConfiguration..::..IndexDirectoriesRow) |


AddIndexDirectoryRow Method (row)

AddIndexDirectoryRow Method (row)
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoryDataTable ► AddIndexDirectoryRow(ServiceConfiguration..::..IndexDirectoryRow)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public void AddIndexDirectoryRow(
    ServiceConfiguration..::..IndexDirectoryRow row
)
Public Sub AddIndexDirectoryRow (
    row As ServiceConfiguration..::..IndexDirectoryRow
)
Parameters
row (ServiceConfiguration..::..IndexDirectoryRow)


AddIndexDirectoryRow Method (IndexDirectory_Text, parentIndexDirectoriesRowByIndexDirectories_IndexDirectory)

AddIndexDirectoryRow Method (IndexDirectory_Text, parentIndexDirectoriesRowByIndexDirectories_IndexDirectory)
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoryDataTable ► AddIndexDirectoryRow(String, ServiceConfiguration..::..IndexDirectoriesRow)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public ServiceConfiguration..::..IndexDirectoryRow AddIndexDirectoryRow(
    string IndexDirectory_Text,
    ServiceConfiguration..::..IndexDirectoriesRow parentIndexDirectoriesRowByIndexDirectories_IndexDirectory
)
Public Function AddIndexDirectoryRow (
    IndexDirectory_Text As String,
    parentIndexDirectoriesRowByIndexDirectories_IndexDirectory As ServiceConfiguration..::..IndexDirectoriesRow
) As ServiceConfiguration..::..IndexDirectoryRow
Parameters
IndexDirectory_Text (String)
parentIndexDirectoriesRowByIndexDirectories_IndexDirectory (ServiceConfiguration..::..IndexDirectoriesRow)
Return Value
ServiceConfiguration..::..IndexDirectoryRow


Clone Method

Clone Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoryDataTable ► Clone()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public override DataTable Clone()
Public Overrides Function Clone As DataTable
Return Value
DataTable

Send comments on this topic to support@keyoti.com


Count Property

Count Property
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoryDataTable ► Count
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
Property Value
Int32

Send comments on this topic to support@keyoti.com


CreateInstance Method

CreateInstance Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoryDataTable ► CreateInstance()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
protected override DataTable CreateInstance()
Protected Overrides Function CreateInstance As DataTable
Return Value
DataTable

Send comments on this topic to support@keyoti.com


GetEnumerator Method

GetEnumerator Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoryDataTable ► GetEnumerator()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
Return Value
IEnumerator

Send comments on this topic to support@keyoti.com


GetRowType Method

GetRowType Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoryDataTable ► GetRowType()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
protected override Type GetRowType()
Protected Overrides Function GetRowType As Type
Return Value
Type

Send comments on this topic to support@keyoti.com


IndexDirectoryRowChanged Event

IndexDirectoryRowChanged Event
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoryDataTable ► IndexDirectoryRowChanged
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public event ServiceConfiguration..::..IndexDirectoryRowChangeEventHandler IndexDirectoryRowChanged
Public Event IndexDirectoryRowChanged As ServiceConfiguration..::..IndexDirectoryRowChangeEventHandler
Value
ServiceConfiguration..::..IndexDirectoryRowChangeEventHandler


IndexDirectoryRowChanging Event

IndexDirectoryRowChanging Event
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoryDataTable ► IndexDirectoryRowChanging
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public event ServiceConfiguration..::..IndexDirectoryRowChangeEventHandler IndexDirectoryRowChanging
Public Event IndexDirectoryRowChanging As ServiceConfiguration..::..IndexDirectoryRowChangeEventHandler
Value
ServiceConfiguration..::..IndexDirectoryRowChangeEventHandler


IndexDirectoryRowDeleted Event

IndexDirectoryRowDeleted Event
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoryDataTable ► IndexDirectoryRowDeleted
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public event ServiceConfiguration..::..IndexDirectoryRowChangeEventHandler IndexDirectoryRowDeleted
Public Event IndexDirectoryRowDeleted As ServiceConfiguration..::..IndexDirectoryRowChangeEventHandler
Value
ServiceConfiguration..::..IndexDirectoryRowChangeEventHandler


IndexDirectoryRowDeleting Event

IndexDirectoryRowDeleting Event
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoryDataTable ► IndexDirectoryRowDeleting
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public event ServiceConfiguration..::..IndexDirectoryRowChangeEventHandler IndexDirectoryRowDeleting
Public Event IndexDirectoryRowDeleting As ServiceConfiguration..::..IndexDirectoryRowChangeEventHandler
Value
ServiceConfiguration..::..IndexDirectoryRowChangeEventHandler


Item Property (index)

Item Property (index)
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoryDataTable ► Item[([( Int32])])
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public ServiceConfiguration..::..IndexDirectoryRow this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As ServiceConfiguration..::..IndexDirectoryRow
    Get
Parameters
index (Int32)
Property Value
ServiceConfiguration..::..IndexDirectoryRow


NewIndexDirectoryRow Method

NewIndexDirectoryRow Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoryDataTable ► NewIndexDirectoryRow()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public ServiceConfiguration..::..IndexDirectoryRow NewIndexDirectoryRow()
Public Function NewIndexDirectoryRow As ServiceConfiguration..::..IndexDirectoryRow
Return Value
ServiceConfiguration..::..IndexDirectoryRow


NewRowFromBuilder Method (builder)

NewRowFromBuilder Method (builder)
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoryDataTable ► NewRowFromBuilder(DataRowBuilder)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
protected override DataRow NewRowFromBuilder(
    DataRowBuilder builder
)
Protected Overrides Function NewRowFromBuilder (
    builder As DataRowBuilder
) As DataRow
Parameters
builder (DataRowBuilder)
Return Value
DataRow

Send comments on this topic to support@keyoti.com


OnRowChanged Method (e)

OnRowChanged Method (e)
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoryDataTable ► OnRowChanged(DataRowChangeEventArgs)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
protected override void OnRowChanged(
    DataRowChangeEventArgs e
)
Protected Overrides Sub OnRowChanged (
    e As DataRowChangeEventArgs
)
Parameters
e (DataRowChangeEventArgs)


OnRowChanging Method (e)

OnRowChanging Method (e)
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoryDataTable ► OnRowChanging(DataRowChangeEventArgs)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
protected override void OnRowChanging(
    DataRowChangeEventArgs e
)
Protected Overrides Sub OnRowChanging (
    e As DataRowChangeEventArgs
)
Parameters
e (DataRowChangeEventArgs)


OnRowDeleted Method (e)

OnRowDeleted Method (e)
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoryDataTable ► OnRowDeleted(DataRowChangeEventArgs)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
protected override void OnRowDeleted(
    DataRowChangeEventArgs e
)
Protected Overrides Sub OnRowDeleted (
    e As DataRowChangeEventArgs
)
Parameters
e (DataRowChangeEventArgs)


OnRowDeleting Method (e)

OnRowDeleting Method (e)
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoryDataTable ► OnRowDeleting(DataRowChangeEventArgs)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
protected override void OnRowDeleting(
    DataRowChangeEventArgs e
)
Protected Overrides Sub OnRowDeleting (
    e As DataRowChangeEventArgs
)
Parameters
e (DataRowChangeEventArgs)


RemoveIndexDirectoryRow Method (row)

RemoveIndexDirectoryRow Method (row)
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoryDataTable ► RemoveIndexDirectoryRow(ServiceConfiguration..::..IndexDirectoryRow)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public void RemoveIndexDirectoryRow(
    ServiceConfiguration..::..IndexDirectoryRow row
)
Public Sub RemoveIndexDirectoryRow (
    row As ServiceConfiguration..::..IndexDirectoryRow
)
Parameters
row (ServiceConfiguration..::..IndexDirectoryRow)


ServiceConfiguration.IndexDirectoryRow Class

ServiceConfiguration..::..IndexDirectoryRow Class
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration ► ServiceConfiguration..::..IndexDirectoryRow
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public class IndexDirectoryRow : DataRow
Public Class IndexDirectoryRow
    Inherits DataRow
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AcceptChanges()()()() | (Inherited from DataRow.)
 | BeginEdit()()()() | (Inherited from DataRow.)
 | CancelEdit()()()() | (Inherited from DataRow.)
 | ClearErrors()()()() | (Inherited from DataRow.)
 | Delete()()()() | (Inherited from DataRow.)
 | EndEdit()()()() | (Inherited from DataRow.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetChildRows(String) | (Inherited from DataRow.)
 | GetChildRows(String, DataRowVersion) | (Inherited from DataRow.)
 | GetChildRows(DataRelation) | (Inherited from DataRow.)
 | GetChildRows(DataRelation, DataRowVersion) | (Inherited from DataRow.)
 | GetColumnError(Int32) | (Inherited from DataRow.)
 | GetColumnError(String) | (Inherited from DataRow.)
 | GetColumnError(DataColumn) | (Inherited from DataRow.)
 | GetColumnsInError()()()() | (Inherited from DataRow.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetParentRow(String) | (Inherited from DataRow.)
 | GetParentRow(String, DataRowVersion) | (Inherited from DataRow.)
 | GetParentRow(DataRelation) | (Inherited from DataRow.)
 | GetParentRow(DataRelation, DataRowVersion) | (Inherited from DataRow.)
 | GetParentRows(String) | (Inherited from DataRow.)
 | GetParentRows(String, DataRowVersion) | (Inherited from DataRow.)
 | GetParentRows(DataRelation) | (Inherited from DataRow.)
 | GetParentRows(DataRelation, DataRowVersion) | (Inherited from DataRow.)
 | GetType()()()() | (Inherited from Object.)
 | HasErrors | (Inherited from DataRow.)
 | HasVersion(DataRowVersion) | (Inherited from DataRow.)
 | IndexDirectoriesRow |
 | IndexDirectory_Text |
 | IsIndexDirectory_TextNull()()()() |
 | IsNull(Int32) | (Inherited from DataRow.)
 | IsNull(String) | (Inherited from DataRow.)
 | IsNull(DataColumn) | (Inherited from DataRow.)
 | IsNull(DataColumn, DataRowVersion) | (Inherited from DataRow.)
 | Item[([( Int32])]) | (Inherited from DataRow.)
 | Item[([( String])]) | (Inherited from DataRow.)
 | Item[([( DataColumn])]) | (Inherited from DataRow.)
 | Item[([( Int32, DataRowVersion])]) | (Inherited from DataRow.)
 | Item[([( String, DataRowVersion])]) | (Inherited from DataRow.)
 | Item[([( DataColumn, DataRowVersion])]) | (Inherited from DataRow.)
 | ItemArray | (Inherited from DataRow.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | RejectChanges()()()() | (Inherited from DataRow.)
 | RowError | (Inherited from DataRow.)
 | RowState | (Inherited from DataRow.)
 | SetAdded()()()() | (Inherited from DataRow.)
 | SetColumnError(Int32, String) | (Inherited from DataRow.)
 | SetColumnError(String, String) | (Inherited from DataRow.)
 | SetColumnError(DataColumn, String) | (Inherited from DataRow.)
 | SetIndexDirectory_TextNull()()()() |
 | SetModified()()()() | (Inherited from DataRow.)
 | SetNull(DataColumn) | (Inherited from DataRow.)
 | SetParentRow(DataRow) | (Inherited from DataRow.)
 | SetParentRow(DataRow, DataRelation) | (Inherited from DataRow.)
 | Table | (Inherited from DataRow.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | DataRow
 |  | ServiceConfiguration..::..IndexDirectoryRow


IndexDirectoriesRow Property

IndexDirectoriesRow Property
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoryRow ► IndexDirectoriesRow
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public ServiceConfiguration..::..IndexDirectoriesRow IndexDirectoriesRow { get; set; }
Public Property IndexDirectoriesRow As ServiceConfiguration..::..IndexDirectoriesRow
    Get
    Set
Property Value
ServiceConfiguration..::..IndexDirectoriesRow


IndexDirectory_Text Property

IndexDirectory_Text Property
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoryRow ► IndexDirectory_Text
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public string IndexDirectory_Text { get; set; }
Public Property IndexDirectory_Text As String
    Get
    Set
Property Value
String

Send comments on this topic to support@keyoti.com


IsIndexDirectory_TextNull Method

IsIndexDirectory_TextNull Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoryRow ► IsIndexDirectory_TextNull()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public bool IsIndexDirectory_TextNull()
Public Function IsIndexDirectory_TextNull As Boolean
Return Value
Boolean

Send comments on this topic to support@keyoti.com


SetIndexDirectory_TextNull Method

SetIndexDirectory_TextNull Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoryRow ► SetIndexDirectory_TextNull()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public void SetIndexDirectory_TextNull()
Public Sub SetIndexDirectory_TextNull

Send comments on this topic to support@keyoti.com


ServiceConfiguration.IndexDirectoryRowChangeEvent Class

ServiceConfiguration..::..IndexDirectoryRowChangeEvent Class
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration ► ServiceConfiguration..::..IndexDirectoryRowChangeEvent
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public class IndexDirectoryRowChangeEvent : EventArgs
Public Class IndexDirectoryRowChangeEvent
    Inherits EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ServiceConfiguration..::..IndexDirectoryRowChangeEvent(ServiceConfiguration..::..IndexDirectoryRow, DataRowAction) |
 | Action |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Row |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | ServiceConfiguration..::..IndexDirectoryRowChangeEvent


ServiceConfiguration.IndexDirectoryRowChangeEvent Constructor (row, action)

ServiceConfiguration..::..IndexDirectoryRowChangeEvent Constructor (row, action)
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoryRowChangeEvent ► ServiceConfiguration..::..IndexDirectoryRowChangeEvent(ServiceConfiguration..::..IndexDirectoryRow, DataRowAction)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public IndexDirectoryRowChangeEvent(
    ServiceConfiguration..::..IndexDirectoryRow row,
    DataRowAction action
)
Public Sub New (
    row As ServiceConfiguration..::..IndexDirectoryRow,
    action As DataRowAction
)
Parameters
row (ServiceConfiguration..::..IndexDirectoryRow)
action (DataRowAction)


Action Property

Action Property
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoryRowChangeEvent ► Action
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public DataRowAction Action { get; }
Public ReadOnly Property Action As DataRowAction
    Get
Property Value
DataRowAction

Send comments on this topic to support@keyoti.com


Row Property

Row Property
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoryRowChangeEvent ► Row
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public ServiceConfiguration..::..IndexDirectoryRow Row { get; }
Public ReadOnly Property Row As ServiceConfiguration..::..IndexDirectoryRow
    Get
Property Value
ServiceConfiguration..::..IndexDirectoryRow


ServiceConfiguration.IndexDirectoryRowChangeEventHandler Delegate

ServiceConfiguration..::..IndexDirectoryRowChangeEventHandler Delegate
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration ► ServiceConfiguration..::..IndexDirectoryRowChangeEventHandler
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public delegate void IndexDirectoryRowChangeEventHandler(
    Object sender,
    ServiceConfiguration..::..IndexDirectoryRowChangeEvent e
)
Public Delegate Sub IndexDirectoryRowChangeEventHandler (
    sender As Object,
    e As ServiceConfiguration..::..IndexDirectoryRowChangeEvent
)
Parameters
sender (Object)
e (ServiceConfiguration..::..IndexDirectoryRowChangeEvent)


Task Class

Task Class
API Documentation ► Keyoti.SearchEngine.WindowsService ► Task
Keyoti SearchUnit v6
Represents a task that the windows service will perform on an index directory.
Declaration Syntax
C# Visual Basic
public class Task
Public Class Task
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Task(String, Int32) | New instance
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SendEmail(String, String, Configuration, Int32) | Sends an email using the properties in configuration
 | Start()()()() | Starts the task timers
 | Stop()()()() | Stops the task from reoccuring
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
Task

Send comments on this topic to support@keyoti.com


Task Constructor (indexDirectory, id)

Task Constructor (indexDirectory, id)
API Documentation ► Keyoti.SearchEngine.WindowsService ► Task ► Task(String, Int32)
Keyoti SearchUnit v6
New instance
Declaration Syntax
C# Visual Basic
public Task(
    string indexDirectory,
    int id
)
Public Sub New (
    indexDirectory As String,
    id As Integer
)
Parameters
indexDirectory (String)
id (Int32)


SendEmail Method (subject, body, Configuration, id)

SendEmail Method (subject, body, Configuration, id)
API Documentation ► Keyoti.SearchEngine.WindowsService ► Task ► SendEmail(String, String, Configuration, Int32)
Keyoti SearchUnit v6
Sends an email using the properties in configuration
Declaration Syntax
C# Visual Basic
public static void SendEmail(
    string subject,
    string body,
    Configuration Configuration,
    int id
)
Public Shared Sub SendEmail (
    subject As String,
    body As String,
    Configuration As Configuration,
    id As Integer
)
Parameters
subject (String)
body (String)
Configuration (Configuration)
id (Int32)


Start Method

Start Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► Task ► Start()()()()
Keyoti SearchUnit v6
Starts the task timers
Declaration Syntax
C# Visual Basic
public void Start()
Public Sub Start

Send comments on this topic to support@keyoti.com


Stop Method

Stop Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► Task ► Stop()()()()
Keyoti SearchUnit v6
Stops the task from reoccuring
Declaration Syntax
C# Visual Basic
public void Stop()
Public Sub Stop

Send comments on this topic to support@keyoti.com


Keyoti.Text.LemmaGenerator Namespace

Keyoti.Text.LemmaGenerator Namespace
API Documentation ► Keyoti.Text.LemmaGenerator
Keyoti SearchUnit v6
Types
All Types Classes Interfaces Enumerations
Icon | Type | Description
 | DE2Stemmer |
 | Lemmas |
 | PorterStemmer |
 | StemmerInterface |
 | Lemmas..::..StemmerLanguage |


DE2Stemmer Class

DE2Stemmer Class
API Documentation ► Keyoti.Text.LemmaGenerator ► DE2Stemmer
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public class DE2Stemmer : StemmerInterface
Public Class DE2Stemmer
    Implements StemmerInterface
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DE2Stemmer()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | stemTerm(String) |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
DE2Stemmer

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.Text.LemmaGenerator (Module: Keyoti4.Text.LemmaGenerator.dll) Version: 5.0.12.314


DE2Stemmer Constructor

DE2Stemmer Constructor
API Documentation ► Keyoti.Text.LemmaGenerator ► DE2Stemmer ► DE2Stemmer()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public DE2Stemmer()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.Text.LemmaGenerator (Module: Keyoti4.Text.LemmaGenerator.dll) Version: 5.0.12.314


stemTerm Method (term)

stemTerm Method (term)
API Documentation ► Keyoti.Text.LemmaGenerator ► DE2Stemmer ► stemTerm(String)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public string stemTerm(
    string term
)
Public Function stemTerm (
    term As String
) As String
Parameters
term (String)
Return Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.Text.LemmaGenerator (Module: Keyoti4.Text.LemmaGenerator.dll) Version: 5.0.12.314


Lemmas Class

Lemmas Class
API Documentation ► Keyoti.Text.LemmaGenerator ► Lemmas
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public class Lemmas
Public Class Lemmas
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Lemmas(String) |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetLemmas(String) |
 | GetType()()()() | (Inherited from Object.)
 | Language |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
Lemmas

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.Text.LemmaGenerator (Module: Keyoti4.Text.LemmaGenerator.dll) Version: 5.0.12.314


Lemmas Constructor (extensionFilesBaseFolder)

Lemmas Constructor (extensionFilesBaseFolder)
API Documentation ► Keyoti.Text.LemmaGenerator ► Lemmas ► Lemmas(String)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public Lemmas(
    string extensionFilesBaseFolder
)
Public Sub New (
    extensionFilesBaseFolder As String
)
Parameters
extensionFilesBaseFolder (String)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.Text.LemmaGenerator (Module: Keyoti4.Text.LemmaGenerator.dll) Version: 5.0.12.314


GetLemmas Method (word)

GetLemmas Method (word)
API Documentation ► Keyoti.Text.LemmaGenerator ► Lemmas ► GetLemmas(String)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public string[] GetLemmas(
    string word
)
Public Function GetLemmas (
    word As String
) As String()
Parameters
word (String)
Return Value
array< String >[]()[][]

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.Text.LemmaGenerator (Module: Keyoti4.Text.LemmaGenerator.dll) Version: 5.0.12.314


Language Property

Language Property
API Documentation ► Keyoti.Text.LemmaGenerator ► Lemmas ► Language
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public Lemmas..::..StemmerLanguage Language { get; set; }
Public Property Language As Lemmas..::..StemmerLanguage
    Get
    Set
Property Value
Lemmas..::..StemmerLanguage

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.Text.LemmaGenerator (Module: Keyoti4.Text.LemmaGenerator.dll) Version: 5.0.12.314


Lemmas.StemmerLanguage Enumeration

Lemmas..::..StemmerLanguage Enumeration
API Documentation ► Keyoti.Text.LemmaGenerator ► Lemmas ► Lemmas..::..StemmerLanguage
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public enum StemmerLanguage
Public Enumeration StemmerLanguage
Members
Member | Description
English |
German |
Russian |
Spanish |
French |
Italian |
Dutch |
Portuguese |
Swedish |
Danish |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.Text.LemmaGenerator (Module: Keyoti4.Text.LemmaGenerator.dll) Version: 5.0.12.314


PorterStemmer Class

PorterStemmer Class
API Documentation ► Keyoti.Text.LemmaGenerator ► PorterStemmer
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public class PorterStemmer : StemmerInterface
Public Class PorterStemmer
    Implements StemmerInterface
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PorterStemmer()()()() |
 | add(Char) |
 | add(array<Char>[]()[][], Int32) |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | getResultBuffer()()()() |
 | getResultLength()()()() |
 | getTerm()()()() |
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | stem()()()() |
 | stemTerm(String) |
 | ToString()()()() | (Overrides Object.ToString()()()().)
Inheritance Hierarchy
Object
PorterStemmer

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.Text.LemmaGenerator (Module: Keyoti4.Text.LemmaGenerator.dll) Version: 5.0.12.314


PorterStemmer Constructor

PorterStemmer Constructor
API Documentation ► Keyoti.Text.LemmaGenerator ► PorterStemmer ► PorterStemmer()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public PorterStemmer()
Public Sub New

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.Text.LemmaGenerator (Module: Keyoti4.Text.LemmaGenerator.dll) Version: 5.0.12.314


add Method

add Method
API Documentation ► Keyoti.Text.LemmaGenerator ► PorterStemmer ► add()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | add(Char) |
 | add(array<Char>[]()[][], Int32) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.Text.LemmaGenerator (Module: Keyoti4.Text.LemmaGenerator.dll) Version: 5.0.12.314


add Method (ch)

add Method (ch)
API Documentation ► Keyoti.Text.LemmaGenerator ► PorterStemmer ► add(Char)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public void add(
    char ch
)
Public Sub add (
    ch As Char
)
Parameters
ch (Char)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.Text.LemmaGenerator (Module: Keyoti4.Text.LemmaGenerator.dll) Version: 5.0.12.314


add Method (w, wLen)

add Method (w, wLen)
API Documentation ► Keyoti.Text.LemmaGenerator ► PorterStemmer ► add(array<Char>[]()[][], Int32)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public void add(
    char[] w,
    int wLen
)
Public Sub add (
    w As Char(),
    wLen As Integer
)
Parameters
w (array< Char >[]()[][])
wLen (Int32)

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.Text.LemmaGenerator (Module: Keyoti4.Text.LemmaGenerator.dll) Version: 5.0.12.314


getResultBuffer Method

getResultBuffer Method
API Documentation ► Keyoti.Text.LemmaGenerator ► PorterStemmer ► getResultBuffer()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public char[] getResultBuffer()
Public Function getResultBuffer As Char()
Return Value
array< Char >[]()[][]

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.Text.LemmaGenerator (Module: Keyoti4.Text.LemmaGenerator.dll) Version: 5.0.12.314


getResultLength Method

getResultLength Method
API Documentation ► Keyoti.Text.LemmaGenerator ► PorterStemmer ► getResultLength()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public int getResultLength()
Public Function getResultLength As Integer
Return Value
Int32

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.Text.LemmaGenerator (Module: Keyoti4.Text.LemmaGenerator.dll) Version: 5.0.12.314


getTerm Method

getTerm Method
API Documentation ► Keyoti.Text.LemmaGenerator ► PorterStemmer ► getTerm()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public string getTerm()
Public Function getTerm As String
Return Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.Text.LemmaGenerator (Module: Keyoti4.Text.LemmaGenerator.dll) Version: 5.0.12.314


stem Method

stem Method
API Documentation ► Keyoti.Text.LemmaGenerator ► PorterStemmer ► stem()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public void stem()
Public Sub stem

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.Text.LemmaGenerator (Module: Keyoti4.Text.LemmaGenerator.dll) Version: 5.0.12.314


stemTerm Method (s)

stemTerm Method (s)
API Documentation ► Keyoti.Text.LemmaGenerator ► PorterStemmer ► stemTerm(String)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public string stemTerm(
    string s
)
Public Function stemTerm (
    s As String
) As String
Parameters
s (String)
Return Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.Text.LemmaGenerator (Module: Keyoti4.Text.LemmaGenerator.dll) Version: 5.0.12.314


ToString Method

ToString Method
API Documentation ► Keyoti.Text.LemmaGenerator ► PorterStemmer ► ToString()()()()
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public override string ToString()
Public Overrides Function ToString As String
Return Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.Text.LemmaGenerator (Module: Keyoti4.Text.LemmaGenerator.dll) Version: 5.0.12.314


StemmerInterface Interface

StemmerInterface Interface
API Documentation ► Keyoti.Text.LemmaGenerator ► StemmerInterface
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
public interface StemmerInterface
Public Interface StemmerInterface
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | stemTerm(String) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.Text.LemmaGenerator (Module: Keyoti4.Text.LemmaGenerator.dll) Version: 5.0.12.314


stemTerm Method (s)

stemTerm Method (s)
API Documentation ► Keyoti.Text.LemmaGenerator ► StemmerInterface ► stemTerm(String)
Keyoti SearchUnit v6
Declaration Syntax
C# Visual Basic
string stemTerm(
    string s
)
Function stemTerm (
    s As String
) As String
Parameters
s (String)
Return Value
String

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.Text.LemmaGenerator (Module: Keyoti4.Text.LemmaGenerator.dll) Version: 5.0.12.314


IsNull Method

IsNull Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoriesRow ► IsNull()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | IsNull(Int32) |
 | IsNull(String) |
 | IsNull(DataColumn) |
 | IsNull(DataColumn, DataRowVersion) |


Select Method

Select Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoryDataTable ► Select()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Select()()()() |
 | Select(String) |
 | Select(String, String) |
 | Select(String, String, DataViewRowState) |


FindControl Method

FindControl Method
API Documentation ► Keyoti.SearchEngine.Web ► KLabel ► FindControl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FindControl(String) |
 | FindControl(String, Int32) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


RenderControl Method

RenderControl Method
API Documentation ► Keyoti.SearchEngine.Web ► KLabel ► RenderControl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) |
 | RenderControl(HtmlTextWriter, ControlAdapter) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


GetCreateInstanceSupported Method

GetCreateInstanceSupported Method
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedDocumentsConverter ► GetCreateInstanceSupported()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GetCreateInstanceSupported()()()() |
 | GetCreateInstanceSupported(ITypeDescriptorContext) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FindLastIndex Method

FindLastIndex Method
API Documentation ► Keyoti.SearchEngine.Utils ► StringList ► FindLastIndex()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FindLastIndex(Predicate<(Of <<'(T>)>>)) |
 | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) |
 | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) |


FindControl Method

FindControl Method
API Documentation ► Keyoti.SearchEngine.Web ► SearchBoxOptions ► FindControl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FindControl(String) |
 | FindControl(String, Int32) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


GetParentRow Method

GetParentRow Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoryRow ► GetParentRow()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GetParentRow(String) |
 | GetParentRow(String, DataRowVersion) |
 | GetParentRow(DataRelation) |
 | GetParentRow(DataRelation, DataRowVersion) |


FindControl Method

FindControl Method
API Documentation ► Keyoti.SearchEngine.Web ► KCheckBox ► FindControl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FindControl(String) |
 | FindControl(String, Int32) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


Reverse Method

Reverse Method
API Documentation ► Keyoti.SearchEngine.Search ► LiveDataCollection ► Reverse()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Reverse()()()() |
 | Reverse(Int32, Int32) |


FindControl Method

FindControl Method
API Documentation ► Keyoti.SearchEngine.Web ► Header ► FindControl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FindControl(String) |
 | FindControl(String, Int32) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


DataBind Method

DataBind Method
API Documentation ► Keyoti.SearchEngine.Web ► SearchBox ► DataBind()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | DataBind()()()() |
 | DataBind(Boolean) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


RenderControl Method

RenderControl Method
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► RenderControl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) |
 | RenderControl(HtmlTextWriter, ControlAdapter) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FindLastIndex Method

FindLastIndex Method
API Documentation ► Keyoti.SearchEngine.Search ► FilterCollection ► FindLastIndex()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FindLastIndex(Predicate<(Of <<'(T>)>>)) |
 | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) |
 | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) |


CanConvertTo Method

CanConvertTo Method
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedDocumentsConverter ► CanConvertTo()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | CanConvertTo(ITypeDescriptorContext, Type) | Whether the converter can convert to targetType. (Overrides TypeConverter.CanConvertTo(ITypeDescriptorContext, Type).)
 | CanConvertTo(Type) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


IndexOf Method

IndexOf Method
API Documentation ► Keyoti.SearchEngine.Utils ► NameValueList ► IndexOf()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | IndexOf(T) |
 | IndexOf(T, Int32) |
 | IndexOf(T, Int32, Int32) |


FindIndex Method

FindIndex Method
API Documentation ► Keyoti.SearchEngine.Search ► LiveDataCollection ► FindIndex()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FindIndex(Predicate<(Of <<'(T>)>>)) |
 | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) |
 | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) |


SetTraceData Method

SetTraceData Method
API Documentation ► Keyoti.SearchEngine.Web ► NoResults ► SetTraceData()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | SetTraceData(Object, Object) |
 | SetTraceData(Object, Object, Object) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ToArray Method

ToArray Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconMatchCollection ► ToArray()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | ToArray()()()() |
 | ToArray(Type) |


DataBind Method

DataBind Method
API Documentation ► Keyoti.SearchEngine.Web ► ErrorMessage ► DataBind()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | DataBind()()()() |
 | DataBind(Boolean) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SetTraceData Method

SetTraceData Method
API Documentation ► Keyoti.SearchEngine.Web.Templates ► FeaturedResultItem ► SetTraceData()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | SetTraceData(Object, Object) |
 | SetTraceData(Object, Object, Object) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SetTraceData Method

SetTraceData Method
API Documentation ► Keyoti.SearchEngine.Web ► ErrorMessage ► SetTraceData()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | SetTraceData(Object, Object) |
 | SetTraceData(Object, Object, Object) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


GetRouteUrl Method

GetRouteUrl Method
API Documentation ► Keyoti.SearchEngine.Web ► KCheckBox ► GetRouteUrl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GetRouteUrl(Object) |
 | GetRouteUrl(String, Object) |
 | GetRouteUrl(RouteValueDictionary) |
 | GetRouteUrl(String, RouteValueDictionary) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


RenderControl Method

RenderControl Method
API Documentation ► Keyoti.SearchEngine.Web ► KDropDownList ► RenderControl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) |
 | RenderControl(HtmlTextWriter, ControlAdapter) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


DataBind Method

DataBind Method
API Documentation ► Keyoti.SearchEngine.Web ► SearchContentOptions ► DataBind()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | DataBind()()()() |
 | DataBind(Boolean) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


Sort Method

Sort Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► WordCollection ► Sort()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Sort()()()() |
 | Sort(IComparer<(Of <<'(T>)>>)) |
 | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) |
 | Sort(Comparison<(Of <<'(T>)>>)) |


LoadDataRow Method

LoadDataRow Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoryDataTable ► LoadDataRow()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | LoadDataRow(array<Object>[]()[][], Boolean) |
 | LoadDataRow(array<Object>[]()[][], LoadOption) |


DataBind Method

DataBind Method
API Documentation ► Keyoti.SearchEngine.Web ► NoQuery ► DataBind()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | DataBind()()()() |
 | DataBind(Boolean) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


DataBind Method

DataBind Method
API Documentation ► Keyoti.SearchEngine.Web ► Header ► DataBind()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | DataBind()()()() |
 | DataBind(Boolean) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FindLastIndex Method

FindLastIndex Method
API Documentation ► Keyoti.SearchEngine.Search ► LiveDataCollection ► FindLastIndex()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FindLastIndex(Predicate<(Of <<'(T>)>>)) |
 | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) |
 | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) |


Sort Method

Sort Method
API Documentation ► Keyoti.SearchEngine.Search ► LiveDataCollection ► Sort()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Sort()()()() |
 | Sort(IComparer<(Of <<'(T>)>>)) |
 | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) |
 | Sort(Comparison<(Of <<'(T>)>>)) |


LoadDataRow Method

LoadDataRow Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoriesDataTable ► LoadDataRow()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | LoadDataRow(array<Object>[]()[][], Boolean) |
 | LoadDataRow(array<Object>[]()[][], LoadOption) |


ConvertToInvariantString Method

ConvertToInvariantString Method
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedDocumentsConverter ► ConvertToInvariantString()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | ConvertToInvariantString(Object) |
 | ConvertToInvariantString(ITypeDescriptorContext, Object) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FindControl Method

FindControl Method
API Documentation ► Keyoti.SearchEngine.Web ► Footer ► FindControl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FindControl(String) |
 | FindControl(String, Int32) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


GetRouteUrl Method

GetRouteUrl Method
API Documentation ► Keyoti.SearchEngine.Web.Templates ► FeaturedHeader ► GetRouteUrl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GetRouteUrl(Object) |
 | GetRouteUrl(String, Object) |
 | GetRouteUrl(RouteValueDictionary) |
 | GetRouteUrl(String, RouteValueDictionary) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


CopyTo Method

CopyTo Method
API Documentation ► Keyoti.SearchEngine.Utils ► IntList ► CopyTo()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | CopyTo(array<T>[]()[][]) |
 | CopyTo(Int32, array<T>[]()[][], Int32, Int32) |
 | CopyTo(array<T>[]()[][], Int32) |


SetTraceData Method

SetTraceData Method
API Documentation ► Keyoti.SearchEngine.Web ► SearchSuggestions ► SetTraceData()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | SetTraceData(Object, Object) |
 | SetTraceData(Object, Object, Object) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


ReadXml Method

ReadXml Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoriesDataTable ► ReadXml()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | ReadXml(Stream) |
 | ReadXml(TextReader) |
 | ReadXml(String) |
 | ReadXml(XmlReader) |


Read Method

Read Method
API Documentation ► Keyoti.SearchEngine.Documents ► PptxParser ► Read()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Read(Stream, Uri, Encoding) | Reads a document and returns an object holding it's text and any links. (Overrides XmlDocumentParser.Read(Stream, Uri, Encoding).)
 | Read(String, Uri, Encoding) | Read the document


BinarySearch Method

BinarySearch Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconMatchCollection ► BinarySearch()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | BinarySearch(Int32, Int32, Object, IComparer) |
 | BinarySearch(Object) |
 | BinarySearch(Object, IComparer) |


ReadXml Method

ReadXml Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoryDataTable ► ReadXml()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | ReadXml(Stream) |
 | ReadXml(TextReader) |
 | ReadXml(String) |
 | ReadXml(XmlReader) |


Reverse Method

Reverse Method
API Documentation ► Keyoti.SearchEngine.Utils ► NameValueList ► Reverse()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Reverse()()()() |
 | Reverse(Int32, Int32) |


RenderControl Method

RenderControl Method
API Documentation ► Keyoti.SearchEngine.Web ► KButton ► RenderControl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) |
 | RenderControl(HtmlTextWriter, ControlAdapter) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


GetColumnError Method

GetColumnError Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoryRow ► GetColumnError()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GetColumnError(Int32) |
 | GetColumnError(String) |
 | GetColumnError(DataColumn) |


FindControl Method

FindControl Method
API Documentation ► Keyoti.SearchEngine.Web ► KTextBox ► FindControl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FindControl(String) |
 | FindControl(String, Int32) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


CopyTo Method

CopyTo Method
API Documentation ► Keyoti.SearchEngine.Utils ► IntListList ► CopyTo()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | CopyTo(Array) |
 | CopyTo(Array, Int32) |
 | CopyTo(Int32, Array, Int32, Int32) |


DataBind Method

DataBind Method
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► DataBind()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | DataBind()()()() |
 | DataBind(Boolean) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


GetProperties Method

GetProperties Method
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedDocumentsConverter ► GetProperties()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GetProperties(Object) |
 | GetProperties(ITypeDescriptorContext, Object) |
 | GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[][]) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


GetRouteUrl Method

GetRouteUrl Method
API Documentation ► Keyoti.SearchEngine.Web.Templates ► FeaturedResultItem ► GetRouteUrl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GetRouteUrl(Object) |
 | GetRouteUrl(String, Object) |
 | GetRouteUrl(RouteValueDictionary) |
 | GetRouteUrl(String, RouteValueDictionary) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


CopyTo Method

CopyTo Method
API Documentation ► Keyoti.SearchEngine.Utils ► KeywordHitMapDictionary ► CopyTo()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | CopyTo(array<T>[]()[][]) |
 | CopyTo(Int32, array<T>[]()[][], Int32, Int32) |
 | CopyTo(array<T>[]()[][], Int32) |


ProcessWordsToFinalIndexedList Method

ProcessWordsToFinalIndexedList Method
API Documentation ► Keyoti.SearchEngine.Documents ► DocxParser ► ProcessWordsToFinalIndexedList()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean) | Processes the list of all words found in the document and returns a list that should be index.
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean, ArrayList) | Processes the list of all words found in the document and returns a list that should be index.


FindControl Method

FindControl Method
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedResults ► FindControl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FindControl(String) |
 | FindControl(String, Int32) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SetTraceData Method

SetTraceData Method
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedResults ► SetTraceData()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | SetTraceData(Object, Object) |
 | SetTraceData(Object, Object, Object) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Sort Method

Sort Method
API Documentation ► Keyoti.SearchEngine.Utils ► NameValueList ► Sort()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Sort()()()() |
 | Sort(IComparer<(Of <<'(T>)>>)) |
 | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) |
 | Sort(Comparison<(Of <<'(T>)>>)) |


CopyTo Method

CopyTo Method
API Documentation ► Keyoti.SearchEngine.Utils ► IntArraysList ► CopyTo()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | CopyTo(array<T>[]()[][]) |
 | CopyTo(Int32, array<T>[]()[][], Int32, Int32) |
 | CopyTo(array<T>[]()[][], Int32) |


LastIndexOf Method

LastIndexOf Method
API Documentation ► Keyoti.SearchEngine.Search ► SearchResult ► LastIndexOf()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | LastIndexOf(T) |
 | LastIndexOf(T, Int32) |
 | LastIndexOf(T, Int32, Int32) |


BinarySearch Method

BinarySearch Method
API Documentation ► Keyoti.SearchEngine.Utils ► StringList ► BinarySearch()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) |
 | BinarySearch(T) |
 | BinarySearch(T, IComparer<(Of <<'(T>)>>)) |


WriteXmlSchema Method

WriteXmlSchema Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoriesDataTable ► WriteXmlSchema()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | WriteXmlSchema(Stream) |
 | WriteXmlSchema(Stream, Boolean) |
 | WriteXmlSchema(TextWriter) |
 | WriteXmlSchema(TextWriter, Boolean) |
 | WriteXmlSchema(XmlWriter) |
 | WriteXmlSchema(XmlWriter, Boolean) |
 | WriteXmlSchema(String) |
 | WriteXmlSchema(String, Boolean) |


IndexOf Method

IndexOf Method
API Documentation ► Keyoti.SearchEngine.Search ► SearchResult ► IndexOf()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | IndexOf(T) |
 | IndexOf(T, Int32) |
 | IndexOf(T, Int32, Int32) |


SetTraceData Method

SetTraceData Method
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► SetTraceData()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | SetTraceData(Object, Object) |
 | SetTraceData(Object, Object, Object) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


RenderControl Method

RenderControl Method
API Documentation ► Keyoti.SearchEngine.Web.Templates ► FeaturedHeader ► RenderControl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) |
 | RenderControl(HtmlTextWriter, ControlAdapter) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FindControl Method

FindControl Method
API Documentation ► Keyoti.SearchEngine.Web.Templates ► FeaturedResultItem ► FindControl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FindControl(String) |
 | FindControl(String, Int32) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SetColumnError Method

SetColumnError Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoryRow ► SetColumnError()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | SetColumnError(Int32, String) |
 | SetColumnError(String, String) |
 | SetColumnError(DataColumn, String) |


GetEnumerator Method

GetEnumerator Method
API Documentation ► Keyoti.SearchEngine.Utils ► IntListList ► GetEnumerator()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GetEnumerator()()()() |
 | GetEnumerator(Int32, Int32) |


Load Method

Load Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoriesDataTable ► Load()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Load(IDataReader) |
 | Load(IDataReader, LoadOption) |
 | Load(IDataReader, LoadOption, FillErrorEventHandler) |


FindIndex Method

FindIndex Method
API Documentation ► Keyoti.SearchEngine.Utils ► IntArraysList ► FindIndex()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FindIndex(Predicate<(Of <<'(T>)>>)) |
 | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) |
 | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) |


ProcessWordsToFinalIndexedList Method

ProcessWordsToFinalIndexedList Method
API Documentation ► Keyoti.SearchEngine.Documents ► PptxParser ► ProcessWordsToFinalIndexedList()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean) | Processes the list of all words found in the document and returns a list that should be index.
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean, ArrayList) | Processes the list of all words found in the document and returns a list that should be index.


SetTraceData Method

SetTraceData Method
API Documentation ► Keyoti.SearchEngine.Web ► NoQuery ► SetTraceData()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | SetTraceData(Object, Object) |
 | SetTraceData(Object, Object, Object) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FindIndex Method

FindIndex Method
API Documentation ► Keyoti.SearchEngine.Search ► FilterCollection ► FindIndex()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FindIndex(Predicate<(Of <<'(T>)>>)) |
 | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) |
 | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) |


RenderControl Method

RenderControl Method
API Documentation ► Keyoti.SearchEngine.Web ► Header ► RenderControl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) |
 | RenderControl(HtmlTextWriter, ControlAdapter) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Sort Method

Sort Method
API Documentation ► Keyoti.SearchEngine.Utils ► BoolList ► Sort()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Sort()()()() |
 | Sort(IComparer<(Of <<'(T>)>>)) |
 | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) |
 | Sort(Comparison<(Of <<'(T>)>>)) |


GetRouteUrl Method

GetRouteUrl Method
API Documentation ► Keyoti.SearchEngine.Web ► SearchSuggestions ► GetRouteUrl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GetRouteUrl(Object) |
 | GetRouteUrl(String, Object) |
 | GetRouteUrl(RouteValueDictionary) |
 | GetRouteUrl(String, RouteValueDictionary) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


LastIndexOf Method

LastIndexOf Method
API Documentation ► Keyoti.SearchEngine.Utils ► IntListList ► LastIndexOf()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | LastIndexOf(Object) |
 | LastIndexOf(Object, Int32) |
 | LastIndexOf(Object, Int32, Int32) |


ProcessWordsToFinalIndexedList Method

ProcessWordsToFinalIndexedList Method
API Documentation ► Keyoti.SearchEngine.Documents ► GenericIFilterParser ► ProcessWordsToFinalIndexedList()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean) | Processes the list of all words found in the document and returns a list that should be index.
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean, ArrayList) | Processes the list of all words found in the document and returns a list that should be index.


Reverse Method

Reverse Method
API Documentation ► Keyoti.SearchEngine.Search ► SearchResult ► Reverse()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Reverse()()()() |
 | Reverse(Int32, Int32) |


DataBind Method

DataBind Method
API Documentation ► Keyoti.SearchEngine.Web ► Footer ► DataBind()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | DataBind()()()() |
 | DataBind(Boolean) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


BinarySearch Method

BinarySearch Method
API Documentation ► Keyoti.SearchEngine.Search ► SearchResult ► BinarySearch()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) |
 | BinarySearch(T) |
 | BinarySearch(T, IComparer<(Of <<'(T>)>>)) |


Sort Method

Sort Method
API Documentation ► Keyoti.SearchEngine.Utils ► ResultItemList ► Sort()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Sort()()()() |
 | Sort(IComparer<(Of <<'(T>)>>)) |
 | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) |
 | Sort(Comparison<(Of <<'(T>)>>)) |


WriteXml Method

WriteXml Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoryDataTable ► WriteXml()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | WriteXml(Stream) |
 | WriteXml(Stream, Boolean) |
 | WriteXml(TextWriter) |
 | WriteXml(TextWriter, Boolean) |
 | WriteXml(XmlWriter) |
 | WriteXml(XmlWriter, Boolean) |
 | WriteXml(String) |
 | WriteXml(String, Boolean) |
 | WriteXml(Stream, XmlWriteMode) |
 | WriteXml(Stream, XmlWriteMode, Boolean) |
 | WriteXml(TextWriter, XmlWriteMode) |
 | WriteXml(TextWriter, XmlWriteMode, Boolean) |
 | WriteXml(XmlWriter, XmlWriteMode) |
 | WriteXml(XmlWriter, XmlWriteMode, Boolean) |
 | WriteXml(String, XmlWriteMode) |
 | WriteXml(String, XmlWriteMode, Boolean) |


GetRouteUrl Method

GetRouteUrl Method
API Documentation ► Keyoti.SearchEngine.Web ► SearchBoxOptions ► GetRouteUrl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GetRouteUrl(Object) |
 | GetRouteUrl(String, Object) |
 | GetRouteUrl(RouteValueDictionary) |
 | GetRouteUrl(String, RouteValueDictionary) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


Load Method

Load Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration ► Load()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Load(IDataReader, LoadOption, FillErrorEventHandler, array<DataTable>[]()[][]) |
 | Load(IDataReader, LoadOption, array<DataTable>[]()[][]) |
 | Load(IDataReader, LoadOption, array<String>[]()[][]) |


BinarySearch Method

BinarySearch Method
API Documentation ► Keyoti.SearchEngine.Utils ► IntListList ► BinarySearch()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | BinarySearch(Int32, Int32, Object, IComparer) |
 | BinarySearch(Object) |
 | BinarySearch(Object, IComparer) |


BinarySearch Method

BinarySearch Method
API Documentation ► Keyoti.SearchEngine.Utils ► NameValueList ► BinarySearch()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) |
 | BinarySearch(T) |
 | BinarySearch(T, IComparer<(Of <<'(T>)>>)) |


RenderControl Method

RenderControl Method
API Documentation ► Keyoti.SearchEngine.Web ► NoResults ► RenderControl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) |
 | RenderControl(HtmlTextWriter, ControlAdapter) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


CopyTo Method

CopyTo Method
API Documentation ► Keyoti.SearchEngine.Search ► LiveDataCollection ► CopyTo()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | CopyTo(array<T>[]()[][]) |
 | CopyTo(Int32, array<T>[]()[][], Int32, Int32) |
 | CopyTo(array<T>[]()[][], Int32) |


GetRouteUrl Method

GetRouteUrl Method
API Documentation ► Keyoti.SearchEngine.Web ► SearchContentOptions ► GetRouteUrl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GetRouteUrl(Object) |
 | GetRouteUrl(String, Object) |
 | GetRouteUrl(RouteValueDictionary) |
 | GetRouteUrl(String, RouteValueDictionary) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


RenderControl Method

RenderControl Method
API Documentation ► Keyoti.SearchEngine.Web ► ResultItem ► RenderControl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) |
 | RenderControl(HtmlTextWriter, ControlAdapter) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Reverse Method

Reverse Method
API Documentation ► Keyoti.SearchEngine.Utils ► IntListList ► Reverse()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Reverse()()()() |
 | Reverse(Int32, Int32) |


Dispose Method

Dispose Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoryDataTable ► Dispose()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Dispose()()()() |
 | Dispose(Boolean) |


LastIndexOf Method

LastIndexOf Method
API Documentation ► Keyoti.SearchEngine.Utils ► IntList ► LastIndexOf()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | LastIndexOf(T) |
 | LastIndexOf(T, Int32) |
 | LastIndexOf(T, Int32, Int32) |


FindIndex Method

FindIndex Method
API Documentation ► Keyoti.SearchEngine.Utils ► KeywordHitMapDictionary ► FindIndex()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FindIndex(Predicate<(Of <<'(T>)>>)) |
 | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) |
 | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) |


LastIndexOf Method

LastIndexOf Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconQueryCollection ► LastIndexOf()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | LastIndexOf(Object) |
 | LastIndexOf(Object, Int32) |
 | LastIndexOf(Object, Int32, Int32) |


Merge Method

Merge Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoryDataTable ► Merge()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Merge(DataTable) |
 | Merge(DataTable, Boolean) |
 | Merge(DataTable, Boolean, MissingSchemaAction) |


GetRouteUrl Method

GetRouteUrl Method
API Documentation ► Keyoti.SearchEngine.Web ► NoQuery ► GetRouteUrl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GetRouteUrl(Object) |
 | GetRouteUrl(String, Object) |
 | GetRouteUrl(RouteValueDictionary) |
 | GetRouteUrl(String, RouteValueDictionary) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FindControl Method

FindControl Method
API Documentation ► Keyoti.SearchEngine.Web ► ErrorMessage ► FindControl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FindControl(String) |
 | FindControl(String, Int32) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


RenderControl Method

RenderControl Method
API Documentation ► Keyoti.SearchEngine.Web ► ErrorMessage ► RenderControl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) |
 | RenderControl(HtmlTextWriter, ControlAdapter) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SetParentRow Method

SetParentRow Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoryRow ► SetParentRow()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | SetParentRow(DataRow) |
 | SetParentRow(DataRow, DataRelation) |


FindControl Method

FindControl Method
API Documentation ► Keyoti.SearchEngine.Web ► ResultItem ► FindControl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FindControl(String) |
 | FindControl(String, Int32) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


CopyTo Method

CopyTo Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconQueryCollection ► CopyTo()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | CopyTo(Array) |
 | CopyTo(Array, Int32) |
 | CopyTo(Int32, Array, Int32, Int32) |


RenderControl Method

RenderControl Method
API Documentation ► Keyoti.SearchEngine.Web ► KCheckBox ► RenderControl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) |
 | RenderControl(HtmlTextWriter, ControlAdapter) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


DataBind Method

DataBind Method
API Documentation ► Keyoti.SearchEngine.Web ► KTextBox ► DataBind()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | DataBind()()()() |
 | DataBind(Boolean) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FindLastIndex Method

FindLastIndex Method
API Documentation ► Keyoti.SearchEngine.Utils ► KeywordHitMapDictionary ► FindLastIndex()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FindLastIndex(Predicate<(Of <<'(T>)>>)) |
 | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) |
 | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) |


IndexOf Method

IndexOf Method
API Documentation ► Keyoti.SearchEngine.Utils ► StringList ► IndexOf()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | IndexOf(T) |
 | IndexOf(T, Int32) |
 | IndexOf(T, Int32, Int32) |


LastIndexOf Method

LastIndexOf Method
API Documentation ► Keyoti.SearchEngine.Search ► LiveDataCollection ► LastIndexOf()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | LastIndexOf(T) |
 | LastIndexOf(T, Int32) |
 | LastIndexOf(T, Int32, Int32) |


SetTraceData Method

SetTraceData Method
API Documentation ► Keyoti.SearchEngine.Web ► KTextBox ► SetTraceData()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | SetTraceData(Object, Object) |
 | SetTraceData(Object, Object, Object) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


RenderControl Method

RenderControl Method
API Documentation ► Keyoti.SearchEngine.Web ► SearchSuggestions ► RenderControl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) |
 | RenderControl(HtmlTextWriter, ControlAdapter) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


IndexOf Method

IndexOf Method
API Documentation ► Keyoti.SearchEngine.Search ► LiveDataCollection ► IndexOf()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | IndexOf(T) |
 | IndexOf(T, Int32) |
 | IndexOf(T, Int32, Int32) |


GetChildRows Method

GetChildRows Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoryRow ► GetChildRows()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GetChildRows(String) |
 | GetChildRows(String, DataRowVersion) |
 | GetChildRows(DataRelation) |
 | GetChildRows(DataRelation, DataRowVersion) |


GetRouteUrl Method

GetRouteUrl Method
API Documentation ► Keyoti.SearchEngine.Web ► Header ► GetRouteUrl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GetRouteUrl(Object) |
 | GetRouteUrl(String, Object) |
 | GetRouteUrl(RouteValueDictionary) |
 | GetRouteUrl(String, RouteValueDictionary) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


RenderControl Method

RenderControl Method
API Documentation ► Keyoti.SearchEngine.Web ► Footer ► RenderControl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) |
 | RenderControl(HtmlTextWriter, ControlAdapter) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


IsValid Method

IsValid Method
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedDocumentsConverter ► IsValid()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | IsValid(Object) |
 | IsValid(ITypeDescriptorContext, Object) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Dispose Method

Dispose Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration ► Dispose()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Dispose()()()() |
 | Dispose(Boolean) |


IndexOf Method

IndexOf Method
API Documentation ► Keyoti.SearchEngine.Utils ► KeywordHitMapDictionary ► IndexOf()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | IndexOf(T) |
 | IndexOf(T, Int32) |
 | IndexOf(T, Int32, Int32) |


FindLastIndex Method

FindLastIndex Method
API Documentation ► Keyoti.SearchEngine.Utils ► IntList ► FindLastIndex()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FindLastIndex(Predicate<(Of <<'(T>)>>)) |
 | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) |
 | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) |


GetEnumerator Method

GetEnumerator Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconQueryCollection ► GetEnumerator()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GetEnumerator()()()() |
 | GetEnumerator(Int32, Int32) |


GetRouteUrl Method

GetRouteUrl Method
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedResults ► GetRouteUrl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GetRouteUrl(Object) |
 | GetRouteUrl(String, Object) |
 | GetRouteUrl(RouteValueDictionary) |
 | GetRouteUrl(String, RouteValueDictionary) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SetTraceData Method

SetTraceData Method
API Documentation ► Keyoti.SearchEngine.Web ► ResultItem ► SetTraceData()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | SetTraceData(Object, Object) |
 | SetTraceData(Object, Object, Object) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Merge Method

Merge Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoriesDataTable ► Merge()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Merge(DataTable) |
 | Merge(DataTable, Boolean) |
 | Merge(DataTable, Boolean, MissingSchemaAction) |


IndexOf Method

IndexOf Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► WordCollection ► IndexOf()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | IndexOf(T) |
 | IndexOf(T, Int32) |
 | IndexOf(T, Int32, Int32) |


HasChanges Method

HasChanges Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration ► HasChanges()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | HasChanges()()()() |
 | HasChanges(DataRowState) |


SetTraceData Method

SetTraceData Method
API Documentation ► Keyoti.SearchEngine.Web ► Header ► SetTraceData()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | SetTraceData(Object, Object) |
 | SetTraceData(Object, Object, Object) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SetTraceData Method

SetTraceData Method
API Documentation ► Keyoti.SearchEngine.Web ► SearchBox ► SetTraceData()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | SetTraceData(Object, Object) |
 | SetTraceData(Object, Object, Object) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FindIndex Method

FindIndex Method
API Documentation ► Keyoti.SearchEngine.Utils ► ResultItemList ► FindIndex()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FindIndex(Predicate<(Of <<'(T>)>>)) |
 | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) |
 | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) |


RenderControl Method

RenderControl Method
API Documentation ► Keyoti.SearchEngine.Web ► SearchBox ► RenderControl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) |
 | RenderControl(HtmlTextWriter, ControlAdapter) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Sort Method

Sort Method
API Documentation ► Keyoti.SearchEngine.Search ► SearchResult ► Sort()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Sort()()()() |
 | Sort(IComparer<(Of <<'(T>)>>)) |
 | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) |
 | Sort(Comparison<(Of <<'(T>)>>)) |


RenderControl Method

RenderControl Method
API Documentation ► Keyoti.SearchEngine.Web ► KTextBox ► RenderControl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) |
 | RenderControl(HtmlTextWriter, ControlAdapter) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


GetParentRow Method

GetParentRow Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoriesRow ► GetParentRow()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GetParentRow(String) |
 | GetParentRow(String, DataRowVersion) |
 | GetParentRow(DataRelation) |
 | GetParentRow(DataRelation, DataRowVersion) |


Sort Method

Sort Method
API Documentation ► Keyoti.SearchEngine.Utils ► IntArraysList ► Sort()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Sort()()()() |
 | Sort(IComparer<(Of <<'(T>)>>)) |
 | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) |
 | Sort(Comparison<(Of <<'(T>)>>)) |


IndexOf Method

IndexOf Method
API Documentation ► Keyoti.SearchEngine.Utils ► IntListList ► IndexOf()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | IndexOf(Object) |
 | IndexOf(Object, Int32) |
 | IndexOf(Object, Int32, Int32) |


RenderControl Method

RenderControl Method
API Documentation ► Keyoti.SearchEngine.Web ► NoQuery ► RenderControl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) |
 | RenderControl(HtmlTextWriter, ControlAdapter) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


IndexOf Method

IndexOf Method
API Documentation ► Keyoti.SearchEngine.Search ► FilterCollection ► IndexOf()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | IndexOf(T) |
 | IndexOf(T, Int32) |
 | IndexOf(T, Int32, Int32) |


FindControl Method

FindControl Method
API Documentation ► Keyoti.SearchEngine.Web ► NoResults ► FindControl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FindControl(String) |
 | FindControl(String, Int32) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


CopyTo Method

CopyTo Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconMatchCollection ► CopyTo()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | CopyTo(Array) |
 | CopyTo(Array, Int32) |
 | CopyTo(Int32, Array, Int32, Int32) |


LastIndexOf Method

LastIndexOf Method
API Documentation ► Keyoti.SearchEngine.Utils ► StringList ► LastIndexOf()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | LastIndexOf(T) |
 | LastIndexOf(T, Int32) |
 | LastIndexOf(T, Int32, Int32) |


RenderControl Method

RenderControl Method
API Documentation ► Keyoti.SearchEngine.Web.Templates ► FeaturedResultItem ► RenderControl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) |
 | RenderControl(HtmlTextWriter, ControlAdapter) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ProcessWordsToFinalIndexedList Method

ProcessWordsToFinalIndexedList Method
API Documentation ► Keyoti.SearchEngine.Documents ► RtfDocumentParser ► ProcessWordsToFinalIndexedList()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean) | Processes the list of all words found in the document and returns a list that should be index.
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean, ArrayList) | Processes the list of all words found in the document and returns a list that should be index.


ProcessWordsToFinalIndexedList Method

ProcessWordsToFinalIndexedList Method
API Documentation ► Keyoti.SearchEngine.Documents ► PdfDocumentParser ► ProcessWordsToFinalIndexedList()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean) | Processes the list of all words found in the document and returns a list that should be index.
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean, ArrayList) | Processes the list of all words found in the document and returns a list that should be index.


ToArray Method

ToArray Method
API Documentation ► Keyoti.SearchEngine.Utils ► IntListList ► ToArray()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | ToArray()()()() |
 | ToArray(Type) |


LastIndexOf Method

LastIndexOf Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconMatchCollection ► LastIndexOf()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | LastIndexOf(Object) |
 | LastIndexOf(Object, Int32) |
 | LastIndexOf(Object, Int32, Int32) |


Read Method

Read Method
API Documentation ► Keyoti.SearchEngine.Documents ► OdtDocumentParser ► Read()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Read(Stream, Uri, Encoding) | Reads a document and returns an object holding it's text and any links. (Overrides XmlDocumentParser.Read(Stream, Uri, Encoding).)
 | Read(String, Uri, Encoding) | Read the document


FindIndex Method

FindIndex Method
API Documentation ► Keyoti.SearchEngine.Utils ► IntList ► FindIndex()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FindIndex(Predicate<(Of <<'(T>)>>)) |
 | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) |
 | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) |


GetChanges Method

GetChanges Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration ► GetChanges()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GetChanges()()()() |
 | GetChanges(DataRowState) |


Reverse Method

Reverse Method
API Documentation ► Keyoti.SearchEngine.Search ► FilterCollection ► Reverse()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Reverse()()()() |
 | Reverse(Int32, Int32) |


BinarySearch Method

BinarySearch Method
API Documentation ► Keyoti.SearchEngine.Utils ► IntList ► BinarySearch()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) |
 | BinarySearch(T) |
 | BinarySearch(T, IComparer<(Of <<'(T>)>>)) |


BinarySearch Method

BinarySearch Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► WordCollection ► BinarySearch()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) |
 | BinarySearch(T) |
 | BinarySearch(T, IComparer<(Of <<'(T>)>>)) |


Dispose Method

Dispose Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoriesDataTable ► Dispose()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Dispose()()()() |
 | Dispose(Boolean) |


Select Method

Select Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoriesDataTable ► Select()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Select()()()() |
 | Select(String) |
 | Select(String, String) |
 | Select(String, String, DataViewRowState) |


WriteXmlSchema Method

WriteXmlSchema Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoryDataTable ► WriteXmlSchema()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | WriteXmlSchema(Stream) |
 | WriteXmlSchema(Stream, Boolean) |
 | WriteXmlSchema(TextWriter) |
 | WriteXmlSchema(TextWriter, Boolean) |
 | WriteXmlSchema(XmlWriter) |
 | WriteXmlSchema(XmlWriter, Boolean) |
 | WriteXmlSchema(String) |
 | WriteXmlSchema(String, Boolean) |


ProcessWordsToFinalIndexedList Method

ProcessWordsToFinalIndexedList Method
API Documentation ► Keyoti.SearchEngine.Documents ► HtmlDocumentParser ► ProcessWordsToFinalIndexedList()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean) | Processes the list of all words found in the document and returns a list that should be index.
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean, ArrayList) | Processes the list of all words found in the document and returns a list that should be index.


GetRouteUrl Method

GetRouteUrl Method
API Documentation ► Keyoti.SearchEngine.Web ► Footer ► GetRouteUrl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GetRouteUrl(Object) |
 | GetRouteUrl(String, Object) |
 | GetRouteUrl(RouteValueDictionary) |
 | GetRouteUrl(String, RouteValueDictionary) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ProcessWordsToFinalIndexedList Method

ProcessWordsToFinalIndexedList Method
API Documentation ► Keyoti.SearchEngine.Documents ► TxtDocumentParser ► ProcessWordsToFinalIndexedList()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean) | Processes the list of all words found in the document and returns a list that should be index.
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean, ArrayList) | Processes the list of all words found in the document and returns a list that should be index.


Item Property

Item Property
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoryRow ► Item
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | Item[([( String])]) |
 | Item[([( DataColumn])]) |
 | Item[([( Int32, DataRowVersion])]) |
 | Item[([( String, DataRowVersion])]) |
 | Item[([( DataColumn, DataRowVersion])]) |


CopyTo Method

CopyTo Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► WordCollection ► CopyTo()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | CopyTo(array<T>[]()[][]) |
 | CopyTo(Int32, array<T>[]()[][], Int32, Int32) |
 | CopyTo(array<T>[]()[][], Int32) |


Reverse Method

Reverse Method
API Documentation ► Keyoti.SearchEngine.Utils ► KeywordHitMapDictionary ► Reverse()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Reverse()()()() |
 | Reverse(Int32, Int32) |


GetPropertiesSupported Method

GetPropertiesSupported Method
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedDocumentsConverter ► GetPropertiesSupported()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GetPropertiesSupported()()()() |
 | GetPropertiesSupported(ITypeDescriptorContext) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SetTraceData Method

SetTraceData Method
API Documentation ► Keyoti.SearchEngine.Web ► KButton ► SetTraceData()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | SetTraceData(Object, Object) |
 | SetTraceData(Object, Object, Object) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


LastIndexOf Method

LastIndexOf Method
API Documentation ► Keyoti.SearchEngine.Utils ► KeywordHitMapDictionary ► LastIndexOf()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | LastIndexOf(T) |
 | LastIndexOf(T, Int32) |
 | LastIndexOf(T, Int32, Int32) |


CopyTo Method

CopyTo Method
API Documentation ► Keyoti.SearchEngine.Utils ► StringList ► CopyTo()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | CopyTo(array<T>[]()[][]) |
 | CopyTo(Int32, array<T>[]()[][], Int32, Int32) |
 | CopyTo(array<T>[]()[][], Int32) |


IndexOf Method

IndexOf Method
API Documentation ► Keyoti.SearchEngine.Utils ► IntList ► IndexOf()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | IndexOf(T) |
 | IndexOf(T, Int32) |
 | IndexOf(T, Int32, Int32) |


Reverse Method

Reverse Method
API Documentation ► Keyoti.SearchEngine.Utils ► StringList ► Reverse()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Reverse()()()() |
 | Reverse(Int32, Int32) |


SetTraceData Method

SetTraceData Method
API Documentation ► Keyoti.SearchEngine.Web ► Footer ► SetTraceData()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | SetTraceData(Object, Object) |
 | SetTraceData(Object, Object, Object) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FindControl Method

FindControl Method
API Documentation ► Keyoti.SearchEngine.Web ► NoQuery ► FindControl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FindControl(String) |
 | FindControl(String, Int32) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FindLastIndex Method

FindLastIndex Method
API Documentation ► Keyoti.SearchEngine.Utils ► BoolList ► FindLastIndex()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FindLastIndex(Predicate<(Of <<'(T>)>>)) |
 | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) |
 | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) |


Sort Method

Sort Method
API Documentation ► Keyoti.SearchEngine.Utils ► IntList ► Sort()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Sort()()()() |
 | Sort(IComparer<(Of <<'(T>)>>)) |
 | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) |
 | Sort(Comparison<(Of <<'(T>)>>)) |


GetParentRows Method

GetParentRows Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoriesRow ► GetParentRows()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GetParentRows(String) |
 | GetParentRows(String, DataRowVersion) |
 | GetParentRows(DataRelation) |
 | GetParentRows(DataRelation, DataRowVersion) |


SetColumnError Method

SetColumnError Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoriesRow ► SetColumnError()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | SetColumnError(Int32, String) |
 | SetColumnError(String, String) |
 | SetColumnError(DataColumn, String) |


SetTraceData Method

SetTraceData Method
API Documentation ► Keyoti.SearchEngine.Web ► SearchBoxOptions ► SetTraceData()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | SetTraceData(Object, Object) |
 | SetTraceData(Object, Object, Object) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


BinarySearch Method

BinarySearch Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconQueryCollection ► BinarySearch()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | BinarySearch(Int32, Int32, Object, IComparer) |
 | BinarySearch(Object) |
 | BinarySearch(Object, IComparer) |


RenderControl Method

RenderControl Method
API Documentation ► Keyoti.SearchEngine.Web ► SearchContentOptions ► RenderControl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) |
 | RenderControl(HtmlTextWriter, ControlAdapter) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


LastIndexOf Method

LastIndexOf Method
API Documentation ► Keyoti.SearchEngine.Search ► FilterCollection ► LastIndexOf()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | LastIndexOf(T) |
 | LastIndexOf(T, Int32) |
 | LastIndexOf(T, Int32, Int32) |


CopyTo Method

CopyTo Method
API Documentation ► Keyoti.SearchEngine.Search ► SearchResult ► CopyTo()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | CopyTo(array<T>[]()[][]) |
 | CopyTo(Int32, array<T>[]()[][], Int32, Int32) |
 | CopyTo(array<T>[]()[][], Int32) |


SetTraceData Method

SetTraceData Method
API Documentation ► Keyoti.SearchEngine.Web ► KDropDownList ► SetTraceData()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | SetTraceData(Object, Object) |
 | SetTraceData(Object, Object, Object) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


DataBind Method

DataBind Method
API Documentation ► Keyoti.SearchEngine.Web ► KCheckBox ► DataBind()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | DataBind()()()() |
 | DataBind(Boolean) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


FindControl Method

FindControl Method
API Documentation ► Keyoti.SearchEngine.Web ► SearchBox ► FindControl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FindControl(String) |
 | FindControl(String, Int32) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FindControl Method

FindControl Method
API Documentation ► Keyoti.SearchEngine.Web ► SearchContentOptions ► FindControl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FindControl(String) |
 | FindControl(String, Int32) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


GetRouteUrl Method

GetRouteUrl Method
API Documentation ► Keyoti.SearchEngine.Web ► ErrorMessage ► GetRouteUrl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GetRouteUrl(Object) |
 | GetRouteUrl(String, Object) |
 | GetRouteUrl(RouteValueDictionary) |
 | GetRouteUrl(String, RouteValueDictionary) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


GetChanges Method

GetChanges Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoryDataTable ► GetChanges()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GetChanges()()()() |
 | GetChanges(DataRowState) |


GetRouteUrl Method

GetRouteUrl Method
API Documentation ► Keyoti.SearchEngine.Web ► SearchBox ► GetRouteUrl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GetRouteUrl(Object) |
 | GetRouteUrl(String, Object) |
 | GetRouteUrl(RouteValueDictionary) |
 | GetRouteUrl(String, RouteValueDictionary) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


LastIndexOf Method

LastIndexOf Method
API Documentation ► Keyoti.SearchEngine.Utils ► ResultItemList ► LastIndexOf()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | LastIndexOf(T) |
 | LastIndexOf(T, Int32) |
 | LastIndexOf(T, Int32, Int32) |


FindControl Method

FindControl Method
API Documentation ► Keyoti.SearchEngine.Web ► SearchSuggestions ► FindControl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FindControl(String) |
 | FindControl(String, Int32) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


FindControl Method

FindControl Method
API Documentation ► Keyoti.SearchEngine.Web ► KButton ► FindControl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FindControl(String) |
 | FindControl(String, Int32) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FindLastIndex Method

FindLastIndex Method
API Documentation ► Keyoti.SearchEngine.Search ► SearchResult ► FindLastIndex()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FindLastIndex(Predicate<(Of <<'(T>)>>)) |
 | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) |
 | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) |


BinarySearch Method

BinarySearch Method
API Documentation ► Keyoti.SearchEngine.Utils ► KeywordHitMapDictionary ► BinarySearch()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) |
 | BinarySearch(T) |
 | BinarySearch(T, IComparer<(Of <<'(T>)>>)) |


BinarySearch Method

BinarySearch Method
API Documentation ► Keyoti.SearchEngine.Utils ► ResultItemList ► BinarySearch()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) |
 | BinarySearch(T) |
 | BinarySearch(T, IComparer<(Of <<'(T>)>>)) |


SetParentRow Method

SetParentRow Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoriesRow ► SetParentRow()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | SetParentRow(DataRow) |
 | SetParentRow(DataRow, DataRelation) |


ConvertFrom Method

ConvertFrom Method
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedDocumentsConverter ► ConvertFrom()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts strings to collection (Overrides TypeConverter.ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
 | ConvertFrom(Object) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


GetChanges Method

GetChanges Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoriesDataTable ► GetChanges()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GetChanges()()()() |
 | GetChanges(DataRowState) |


ConvertFromInvariantString Method

ConvertFromInvariantString Method
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedDocumentsConverter ► ConvertFromInvariantString()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | ConvertFromInvariantString(String) |
 | ConvertFromInvariantString(ITypeDescriptorContext, String) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


WriteXmlSchema Method

WriteXmlSchema Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration ► WriteXmlSchema()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | WriteXmlSchema(Stream) |
 | WriteXmlSchema(Stream, Converter<(Of <<'(Type, String>)>>)) |
 | WriteXmlSchema(String) |
 | WriteXmlSchema(String, Converter<(Of <<'(Type, String>)>>)) |
 | WriteXmlSchema(TextWriter) |
 | WriteXmlSchema(TextWriter, Converter<(Of <<'(Type, String>)>>)) |
 | WriteXmlSchema(XmlWriter) |
 | WriteXmlSchema(XmlWriter, Converter<(Of <<'(Type, String>)>>)) |


CopyTo Method

CopyTo Method
API Documentation ► Keyoti.SearchEngine.Utils ► BoolList ► CopyTo()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | CopyTo(array<T>[]()[][]) |
 | CopyTo(Int32, array<T>[]()[][], Int32, Int32) |
 | CopyTo(array<T>[]()[][], Int32) |


ProcessWordsToFinalIndexedList Method

ProcessWordsToFinalIndexedList Method
API Documentation ► Keyoti.SearchEngine.Documents ► Word2002Parser ► ProcessWordsToFinalIndexedList()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean) | Processes the list of all words found in the document and returns a list that should be index.
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean, ArrayList) | Processes the list of all words found in the document and returns a list that should be index.


BinarySearch Method

BinarySearch Method
API Documentation ► Keyoti.SearchEngine.Search ► FilterCollection ► BinarySearch()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) |
 | BinarySearch(T) |
 | BinarySearch(T, IComparer<(Of <<'(T>)>>)) |


Reverse Method

Reverse Method
API Documentation ► Keyoti.SearchEngine.Utils ► IntArraysList ► Reverse()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Reverse()()()() |
 | Reverse(Int32, Int32) |


BinarySearch Method

BinarySearch Method
API Documentation ► Keyoti.SearchEngine.Utils ► IntArraysList ► BinarySearch()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) |
 | BinarySearch(T) |
 | BinarySearch(T, IComparer<(Of <<'(T>)>>)) |


Sort Method

Sort Method
API Documentation ► Keyoti.SearchEngine.Utils ► KeywordHitMapDictionary ► Sort()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Sort()()()() |
 | Sort(IComparer<(Of <<'(T>)>>)) |
 | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) |
 | Sort(Comparison<(Of <<'(T>)>>)) |


IndexOf Method

IndexOf Method
API Documentation ► Keyoti.SearchEngine.Utils ► ResultItemList ► IndexOf()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | IndexOf(T) |
 | IndexOf(T, Int32) |
 | IndexOf(T, Int32, Int32) |


ConvertToString Method

ConvertToString Method
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedDocumentsConverter ► ConvertToString()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | ConvertToString(Object) |
 | ConvertToString(ITypeDescriptorContext, Object) |
 | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FindIndex Method

FindIndex Method
API Documentation ► Keyoti.SearchEngine.Utils ► BoolList ► FindIndex()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FindIndex(Predicate<(Of <<'(T>)>>)) |
 | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) |
 | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) |


FindControl Method

FindControl Method
API Documentation ► Keyoti.SearchEngine.Web ► KDropDownList ► FindControl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FindControl(String) |
 | FindControl(String, Int32) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


ReadXml Method

ReadXml Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration ► ReadXml()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | ReadXml(XmlReader) |
 | ReadXml(Stream) |
 | ReadXml(TextReader) |
 | ReadXml(String) |
 | ReadXml(XmlReader, XmlReadMode) |
 | ReadXml(Stream, XmlReadMode) |
 | ReadXml(TextReader, XmlReadMode) |
 | ReadXml(String, XmlReadMode) |


Sort Method

Sort Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconMatchCollection ► Sort()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Sort()()()() |
 | Sort(IComparer) |
 | Sort(Int32, Int32, IComparer) |


Reverse Method

Reverse Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconMatchCollection ► Reverse()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Reverse()()()() |
 | Reverse(Int32, Int32) |


FindLastIndex Method

FindLastIndex Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► WordCollection ► FindLastIndex()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FindLastIndex(Predicate<(Of <<'(T>)>>)) |
 | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) |
 | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) |


Sort Method

Sort Method
API Documentation ► Keyoti.SearchEngine.Utils ► StringList ► Sort()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Sort()()()() |
 | Sort(IComparer<(Of <<'(T>)>>)) |
 | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) |
 | Sort(Comparison<(Of <<'(T>)>>)) |


GetParentRows Method

GetParentRows Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoryRow ► GetParentRows()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GetParentRows(String) |
 | GetParentRows(String, DataRowVersion) |
 | GetParentRows(DataRelation) |
 | GetParentRows(DataRelation, DataRowVersion) |


FindControl Method

FindControl Method
API Documentation ► Keyoti.SearchEngine.Web.Templates ► FeaturedHeader ► FindControl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FindControl(String) |
 | FindControl(String, Int32) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


WriteXml Method

WriteXml Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration ► WriteXml()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | WriteXml(Stream) |
 | WriteXml(TextWriter) |
 | WriteXml(XmlWriter) |
 | WriteXml(String) |
 | WriteXml(Stream, XmlWriteMode) |
 | WriteXml(TextWriter, XmlWriteMode) |
 | WriteXml(XmlWriter, XmlWriteMode) |
 | WriteXml(String, XmlWriteMode) |


DetermineSchemaSerializationMode Method

DetermineSchemaSerializationMode Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration ► DetermineSchemaSerializationMode()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | DetermineSchemaSerializationMode(SerializationInfo, StreamingContext) |
 | DetermineSchemaSerializationMode(XmlReader) |


GetRouteUrl Method

GetRouteUrl Method
API Documentation ► Keyoti.SearchEngine.Web ► NoResults ► GetRouteUrl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GetRouteUrl(Object) |
 | GetRouteUrl(String, Object) |
 | GetRouteUrl(RouteValueDictionary) |
 | GetRouteUrl(String, RouteValueDictionary) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ProcessWordsToFinalIndexedList Method

ProcessWordsToFinalIndexedList Method
API Documentation ► Keyoti.SearchEngine.Documents ► XmlDocumentParser ► ProcessWordsToFinalIndexedList()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean) | Processes the list of all words found in the document and returns a list that should be index.
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean, ArrayList) | Processes the list of all words found in the document and returns a list that should be index.


FindLastIndex Method

FindLastIndex Method
API Documentation ► Keyoti.SearchEngine.Utils ► ResultItemList ► FindLastIndex()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FindLastIndex(Predicate<(Of <<'(T>)>>)) |
 | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) |
 | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) |


DataBind Method

DataBind Method
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedResults ► DataBind()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | DataBind()()()() |
 | DataBind(Boolean) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


DataBind Method

DataBind Method
API Documentation ► Keyoti.SearchEngine.Web ► KLabel ► DataBind()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | DataBind()()()() |
 | DataBind(Boolean) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


IndexOf Method

IndexOf Method
API Documentation ► Keyoti.SearchEngine.Utils ► BoolList ► IndexOf()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | IndexOf(T) |
 | IndexOf(T, Int32) |
 | IndexOf(T, Int32, Int32) |


ReadXmlSchema Method

ReadXmlSchema Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoriesDataTable ► ReadXmlSchema()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | ReadXmlSchema(Stream) |
 | ReadXmlSchema(TextReader) |
 | ReadXmlSchema(String) |
 | ReadXmlSchema(XmlReader) |


Read Method

Read Method
API Documentation ► Keyoti.SearchEngine.Documents ► OdsDocumentParser ► Read()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Read(Stream, Uri, Encoding) | Reads a document and returns an object holding it's text and any links. (Overrides XmlDocumentParser.Read(Stream, Uri, Encoding).)
 | Read(String, Uri, Encoding) | Read the document


LastIndexOf Method

LastIndexOf Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► WordCollection ► LastIndexOf()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | LastIndexOf(T) |
 | LastIndexOf(T, Int32) |
 | LastIndexOf(T, Int32, Int32) |


Read Method

Read Method
API Documentation ► Keyoti.SearchEngine.Documents ► XmlDocumentParser ► Read()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Read(Stream, Uri, Encoding) | Reads a document and returns an object holding it's text and any links. (Overrides TxtDocumentParser.Read(Stream, Uri, Encoding).)
 | Read(String, Uri, Encoding) | Read the document


GetStandardValuesExclusive Method

GetStandardValuesExclusive Method
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedDocumentsConverter ► GetStandardValuesExclusive()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GetStandardValuesExclusive(ITypeDescriptorContext) | (Overrides TypeConverter.GetStandardValuesExclusive(ITypeDescriptorContext).)
 | GetStandardValuesExclusive()()()() |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Load Method

Load Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoryDataTable ► Load()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Load(IDataReader) |
 | Load(IDataReader, LoadOption) |
 | Load(IDataReader, LoadOption, FillErrorEventHandler) |


FindIndex Method

FindIndex Method
API Documentation ► Keyoti.SearchEngine.Search ► SearchResult ► FindIndex()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FindIndex(Predicate<(Of <<'(T>)>>)) |
 | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) |
 | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) |


FindLastIndex Method

FindLastIndex Method
API Documentation ► Keyoti.SearchEngine.Utils ► IntArraysList ► FindLastIndex()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FindLastIndex(Predicate<(Of <<'(T>)>>)) |
 | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) |
 | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) |


DataBind Method

DataBind Method
API Documentation ► Keyoti.SearchEngine.Web ► KButton ► DataBind()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | DataBind()()()() |
 | DataBind(Boolean) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ProcessWordsToFinalIndexedList Method

ProcessWordsToFinalIndexedList Method
API Documentation ► Keyoti.SearchEngine.Documents ► WordDocumentParser ► ProcessWordsToFinalIndexedList()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean) | Processes the list of all words found in the document and returns a list that should be index.
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean, ArrayList) | Processes the list of all words found in the document and returns a list that should be index.


ConvertFromString Method

ConvertFromString Method
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedDocumentsConverter ► ConvertFromString()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | ConvertFromString(String) |
 | ConvertFromString(ITypeDescriptorContext, String) |
 | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


DataBind Method

DataBind Method
API Documentation ► Keyoti.SearchEngine.Web ► KDropDownList ► DataBind()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | DataBind()()()() | (Overrides Control.DataBind()()()().)
 | DataBind(Boolean) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


SetTraceData Method

SetTraceData Method
API Documentation ► Keyoti.SearchEngine.Web ► KLabel ► SetTraceData()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | SetTraceData(Object, Object) |
 | SetTraceData(Object, Object, Object) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


IndexOf Method

IndexOf Method
API Documentation ► Keyoti.SearchEngine.Utils ► IntArraysList ► IndexOf()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | IndexOf(T) |
 | IndexOf(T, Int32) |
 | IndexOf(T, Int32, Int32) |


LastIndexOf Method

LastIndexOf Method
API Documentation ► Keyoti.SearchEngine.Utils ► IntArraysList ► LastIndexOf()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | LastIndexOf(T) |
 | LastIndexOf(T, Int32) |
 | LastIndexOf(T, Int32, Int32) |


Sort Method

Sort Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconQueryCollection ► Sort()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Sort()()()() |
 | Sort(IComparer) |
 | Sort(Int32, Int32, IComparer) |


IndexOf Method

IndexOf Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconMatchCollection ► IndexOf()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | IndexOf(Object) |
 | IndexOf(Object, Int32) |
 | IndexOf(Object, Int32, Int32) |


GetStandardValues Method

GetStandardValues Method
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedDocumentsConverter ► GetStandardValues()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GetStandardValues()()()() |
 | GetStandardValues(ITypeDescriptorContext) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


SetTraceData Method

SetTraceData Method
API Documentation ► Keyoti.SearchEngine.Web ► KCheckBox ► SetTraceData()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | SetTraceData(Object, Object) |
 | SetTraceData(Object, Object, Object) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


GetColumnError Method

GetColumnError Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoriesRow ► GetColumnError()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GetColumnError(Int32) |
 | GetColumnError(String) |
 | GetColumnError(DataColumn) |


Reverse Method

Reverse Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconQueryCollection ► Reverse()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Reverse()()()() |
 | Reverse(Int32, Int32) |


SetTraceData Method

SetTraceData Method
API Documentation ► Keyoti.SearchEngine.Web ► SearchContentOptions ► SetTraceData()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | SetTraceData(Object, Object) |
 | SetTraceData(Object, Object, Object) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


DataBind Method

DataBind Method
API Documentation ► Keyoti.SearchEngine.Web ► SearchBoxOptions ► DataBind()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | DataBind()()()() |
 | DataBind(Boolean) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


GetRouteUrl Method

GetRouteUrl Method
API Documentation ► Keyoti.SearchEngine.Web ► ResultItem ► GetRouteUrl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GetRouteUrl(Object) |
 | GetRouteUrl(String, Object) |
 | GetRouteUrl(RouteValueDictionary) |
 | GetRouteUrl(String, RouteValueDictionary) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FindControl Method

FindControl Method
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► FindControl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FindControl(String) |
 | FindControl(String, Int32) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


GetChildRows Method

GetChildRows Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoriesRow ► GetChildRows()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GetChildRows(String) |
 | GetChildRows(String, DataRowVersion) |
 | GetChildRows(DataRelation) |
 | GetChildRows(DataRelation, DataRowVersion) |


ProcessWordsToFinalIndexedList Method

ProcessWordsToFinalIndexedList Method
API Documentation ► Keyoti.SearchEngine.Documents ► OdsDocumentParser ► ProcessWordsToFinalIndexedList()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean) | Processes the list of all words found in the document and returns a list that should be index.
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean, ArrayList) | Processes the list of all words found in the document and returns a list that should be index.


Read Method

Read Method
API Documentation ► Keyoti.SearchEngine.Documents ► GenericIFilterParser ► Read()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Read(Stream, Uri, Encoding) | Reads a document and returns an object holding it's text and any links. (Overrides TxtDocumentParser.Read(Stream, Uri, Encoding).)
 | Read(String, Uri, Encoding) | Read the document


FindIndex Method

FindIndex Method
API Documentation ► Keyoti.SearchEngine.Utils ► StringList ► FindIndex()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FindIndex(Predicate<(Of <<'(T>)>>)) |
 | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) |
 | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) |


DataBind Method

DataBind Method
API Documentation ► Keyoti.SearchEngine.Web ► ResultItem ► DataBind()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | DataBind()()()() |
 | DataBind(Boolean) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


ToArray Method

ToArray Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconQueryCollection ► ToArray()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | ToArray()()()() |
 | ToArray(Type) |


Read Method

Read Method
API Documentation ► Keyoti.SearchEngine.Documents ► DocxParser ► Read()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Read(Stream, Uri, Encoding) | Reads a document and returns an object holding it's text and any links. (Overrides XmlDocumentParser.Read(Stream, Uri, Encoding).)
 | Read(String, Uri, Encoding) | Read the document


LastIndexOf Method

LastIndexOf Method
API Documentation ► Keyoti.SearchEngine.Utils ► NameValueList ► LastIndexOf()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | LastIndexOf(T) |
 | LastIndexOf(T, Int32) |
 | LastIndexOf(T, Int32, Int32) |


GetRouteUrl Method

GetRouteUrl Method
API Documentation ► Keyoti.SearchEngine.Web ► KLabel ► GetRouteUrl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GetRouteUrl(Object) |
 | GetRouteUrl(String, Object) |
 | GetRouteUrl(RouteValueDictionary) |
 | GetRouteUrl(String, RouteValueDictionary) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


RenderControl Method

RenderControl Method
API Documentation ► Keyoti.SearchEngine.Web ► SearchBoxOptions ► RenderControl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) |
 | RenderControl(HtmlTextWriter, ControlAdapter) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


InferXmlSchema Method

InferXmlSchema Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration ► InferXmlSchema()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | InferXmlSchema(XmlReader, array<String>[]()[][]) |
 | InferXmlSchema(Stream, array<String>[]()[][]) |
 | InferXmlSchema(TextReader, array<String>[]()[][]) |
 | InferXmlSchema(String, array<String>[]()[][]) |


ReadXmlSchema Method

ReadXmlSchema Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration ► ReadXmlSchema()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | ReadXmlSchema(XmlReader) |
 | ReadXmlSchema(Stream) |
 | ReadXmlSchema(TextReader) |
 | ReadXmlSchema(String) |


Sort Method

Sort Method
API Documentation ► Keyoti.SearchEngine.Search ► FilterCollection ► Sort()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Sort()()()() |
 | Sort(IComparer<(Of <<'(T>)>>)) |
 | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) |
 | Sort(Comparison<(Of <<'(T>)>>)) |


LastIndexOf Method

LastIndexOf Method
API Documentation ► Keyoti.SearchEngine.Utils ► BoolList ► LastIndexOf()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | LastIndexOf(T) |
 | LastIndexOf(T, Int32) |
 | LastIndexOf(T, Int32, Int32) |


ProcessWordsToFinalIndexedList Method

ProcessWordsToFinalIndexedList Method
API Documentation ► Keyoti.SearchEngine.Documents ► ZipFileParser ► ProcessWordsToFinalIndexedList()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean) | Processes the list of all words found in the document and returns a list that should be index.
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean, ArrayList) | Processes the list of all words found in the document and returns a list that should be index.


ProcessWordsToFinalIndexedList Method

ProcessWordsToFinalIndexedList Method
API Documentation ► Keyoti.SearchEngine.Documents ► OdtDocumentParser ► ProcessWordsToFinalIndexedList()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean) | Processes the list of all words found in the document and returns a list that should be index.
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean, ArrayList) | Processes the list of all words found in the document and returns a list that should be index.


GetStandardValuesSupported Method

GetStandardValuesSupported Method
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedDocumentsConverter ► GetStandardValuesSupported()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GetStandardValuesSupported(ITypeDescriptorContext) | (Overrides TypeConverter.GetStandardValuesSupported(ITypeDescriptorContext).)
 | GetStandardValuesSupported()()()() |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


BinarySearch Method

BinarySearch Method
API Documentation ► Keyoti.SearchEngine.Utils ► BoolList ► BinarySearch()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) |
 | BinarySearch(T) |
 | BinarySearch(T, IComparer<(Of <<'(T>)>>)) |


GetRouteUrl Method

GetRouteUrl Method
API Documentation ► Keyoti.SearchEngine.Web ► SearchResult ► GetRouteUrl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GetRouteUrl(Object) |
 | GetRouteUrl(String, Object) |
 | GetRouteUrl(RouteValueDictionary) |
 | GetRouteUrl(String, RouteValueDictionary) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


GetRouteUrl Method

GetRouteUrl Method
API Documentation ► Keyoti.SearchEngine.Web ► KButton ► GetRouteUrl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GetRouteUrl(Object) |
 | GetRouteUrl(String, Object) |
 | GetRouteUrl(RouteValueDictionary) |
 | GetRouteUrl(String, RouteValueDictionary) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


DataBind Method

DataBind Method
API Documentation ► Keyoti.SearchEngine.Web ► NoResults ► DataBind()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | DataBind()()()() |
 | DataBind(Boolean) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


IsNull Method

IsNull Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoryRow ► IsNull()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | IsNull(Int32) |
 | IsNull(String) |
 | IsNull(DataColumn) |
 | IsNull(DataColumn, DataRowVersion) |


ProcessWordsToFinalIndexedList Method

ProcessWordsToFinalIndexedList Method
API Documentation ► Keyoti.SearchEngine.Documents ► XlsxParser ► ProcessWordsToFinalIndexedList()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean) | Processes the list of all words found in the document and returns a list that should be index.
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean, ArrayList) | Processes the list of all words found in the document and returns a list that should be index.


ReadXmlSchema Method

ReadXmlSchema Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoryDataTable ► ReadXmlSchema()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | ReadXmlSchema(Stream) |
 | ReadXmlSchema(TextReader) |
 | ReadXmlSchema(String) |
 | ReadXmlSchema(XmlReader) |


GetRouteUrl Method

GetRouteUrl Method
API Documentation ► Keyoti.SearchEngine.Web ► KTextBox ► GetRouteUrl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GetRouteUrl(Object) |
 | GetRouteUrl(String, Object) |
 | GetRouteUrl(RouteValueDictionary) |
 | GetRouteUrl(String, RouteValueDictionary) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Reverse Method

Reverse Method
API Documentation ► Keyoti.SearchEngine.Utils ► BoolList ► Reverse()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Reverse()()()() |
 | Reverse(Int32, Int32) |


Sort Method

Sort Method
API Documentation ► Keyoti.SearchEngine.Utils ► IntListList ► Sort()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Sort()()()() |
 | Sort(IComparer) |
 | Sort(Int32, Int32, IComparer) |


SetTraceData Method

SetTraceData Method
API Documentation ► Keyoti.SearchEngine.Web.Templates ► FeaturedHeader ► SetTraceData()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | SetTraceData(Object, Object) |
 | SetTraceData(Object, Object, Object) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


CopyTo Method

CopyTo Method
API Documentation ► Keyoti.SearchEngine.Search ► FilterCollection ► CopyTo()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | CopyTo(array<T>[]()[][]) |
 | CopyTo(Int32, array<T>[]()[][], Int32, Int32) |
 | CopyTo(array<T>[]()[][], Int32) |


CopyTo Method

CopyTo Method
API Documentation ► Keyoti.SearchEngine.Utils ► NameValueList ► CopyTo()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | CopyTo(array<T>[]()[][]) |
 | CopyTo(Int32, array<T>[]()[][], Int32, Int32) |
 | CopyTo(array<T>[]()[][], Int32) |


DataBind Method

DataBind Method
API Documentation ► Keyoti.SearchEngine.Web.Templates ► FeaturedResultItem ► DataBind()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | DataBind()()()() |
 | DataBind(Boolean) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


RenderControl Method

RenderControl Method
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedResults ► RenderControl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) |
 | RenderControl(HtmlTextWriter, ControlAdapter) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Reverse Method

Reverse Method
API Documentation ► Keyoti.SearchEngine.Utils ► IntList ► Reverse()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Reverse()()()() |
 | Reverse(Int32, Int32) |


Reverse Method

Reverse Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► WordCollection ► Reverse()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Reverse()()()() |
 | Reverse(Int32, Int32) |


ProcessWordsToFinalIndexedList Method

ProcessWordsToFinalIndexedList Method
API Documentation ► Keyoti.SearchEngine.Documents ► DataSetRecordParser ► ProcessWordsToFinalIndexedList()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean) | Processes the list of all words found in the document and returns a list that should be index.
 | ProcessWordsToFinalIndexedList(WordCollection, Boolean, ArrayList) | Processes the list of all words found in the document and returns a list that should be index.


BinarySearch Method

BinarySearch Method
API Documentation ► Keyoti.SearchEngine.Search ► LiveDataCollection ► BinarySearch()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) |
 | BinarySearch(T) |
 | BinarySearch(T, IComparer<(Of <<'(T>)>>)) |


FindIndex Method

FindIndex Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► WordCollection ► FindIndex()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FindIndex(Predicate<(Of <<'(T>)>>)) |
 | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) |
 | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) |


CreateDataReader Method

CreateDataReader Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration ► CreateDataReader()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | CreateDataReader()()()() |
 | CreateDataReader(array<DataTable>[]()[][]) |


DataBind Method

DataBind Method
API Documentation ► Keyoti.SearchEngine.Web ► SearchSuggestions ► DataBind()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | DataBind()()()() |
 | DataBind(Boolean) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


ConvertTo Method

ConvertTo Method
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedDocumentsConverter ► ConvertTo()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Convert to string (Overrides TypeConverter.ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
 | ConvertTo(Object, Type) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


Read Method

Read Method
API Documentation ► Keyoti.SearchEngine.Documents ► XlsxParser ► Read()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Read(Stream, Uri, Encoding) | Reads a document and returns an object holding it's text and any links. (Overrides XmlDocumentParser.Read(Stream, Uri, Encoding).)
 | Read(String, Uri, Encoding) | Read the document


CopyTo Method

CopyTo Method
API Documentation ► Keyoti.SearchEngine.Utils ► ResultItemList ► CopyTo()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | CopyTo(array<T>[]()[][]) |
 | CopyTo(Int32, array<T>[]()[][], Int32, Int32) |
 | CopyTo(array<T>[]()[][], Int32) |


Reverse Method

Reverse Method
API Documentation ► Keyoti.SearchEngine.Utils ► ResultItemList ► Reverse()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Reverse()()()() |
 | Reverse(Int32, Int32) |


WriteXml Method

WriteXml Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoriesDataTable ► WriteXml()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | WriteXml(Stream) |
 | WriteXml(Stream, Boolean) |
 | WriteXml(TextWriter) |
 | WriteXml(TextWriter, Boolean) |
 | WriteXml(XmlWriter) |
 | WriteXml(XmlWriter, Boolean) |
 | WriteXml(String) |
 | WriteXml(String, Boolean) |
 | WriteXml(Stream, XmlWriteMode) |
 | WriteXml(Stream, XmlWriteMode, Boolean) |
 | WriteXml(TextWriter, XmlWriteMode) |
 | WriteXml(TextWriter, XmlWriteMode, Boolean) |
 | WriteXml(XmlWriter, XmlWriteMode) |
 | WriteXml(XmlWriter, XmlWriteMode, Boolean) |
 | WriteXml(String, XmlWriteMode) |
 | WriteXml(String, XmlWriteMode, Boolean) |


Merge Method

Merge Method
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration ► Merge()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Merge(DataSet) |
 | Merge(DataSet, Boolean) |
 | Merge(DataSet, Boolean, MissingSchemaAction) |
 | Merge(DataTable) |
 | Merge(DataTable, Boolean, MissingSchemaAction) |
 | Merge(array<DataRow>[]()[][]) |
 | Merge(array<DataRow>[]()[][], Boolean, MissingSchemaAction) |


GetEnumerator Method

GetEnumerator Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconMatchCollection ► GetEnumerator()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GetEnumerator()()()() |
 | GetEnumerator(Int32, Int32) |


IndexOf Method

IndexOf Method
API Documentation ► Keyoti.SearchEngine.DataAccess ► LexiconQueryCollection ► IndexOf()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | IndexOf(Object) |
 | IndexOf(Object, Int32) |
 | IndexOf(Object, Int32, Int32) |


CanConvertFrom Method

CanConvertFrom Method
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedDocumentsConverter ► CanConvertFrom()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | CanConvertFrom(ITypeDescriptorContext, Type) | Whether the converter can convert from sourceType. (Overrides TypeConverter.CanConvertFrom(ITypeDescriptorContext, Type).)
 | CanConvertFrom(Type) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


DataBind Method

DataBind Method
API Documentation ► Keyoti.SearchEngine.Web.Templates ► FeaturedHeader ► DataBind()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | DataBind()()()() |
 | DataBind(Boolean) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FindIndex Method

FindIndex Method
API Documentation ► Keyoti.SearchEngine.Utils ► NameValueList ► FindIndex()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FindIndex(Predicate<(Of <<'(T>)>>)) |
 | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) |
 | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) |


CreateInstance Method

CreateInstance Method
API Documentation ► Keyoti.SearchEngine.Web ► FeaturedDocumentsConverter ► CreateInstance()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | CreateInstance(IDictionary) |
 | CreateInstance(ITypeDescriptorContext, IDictionary) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEngine.Web (Module: Keyoti4.SearchEngine.Web.dll) Version: 2015.6.15.120


FindLastIndex Method

FindLastIndex Method
API Documentation ► Keyoti.SearchEngine.Utils ► NameValueList ► FindLastIndex()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | FindLastIndex(Predicate<(Of <<'(T>)>>)) |
 | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) |
 | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) |


Item Property

Item Property
API Documentation ► Keyoti.SearchEngine.WindowsService ► ServiceConfiguration..::..IndexDirectoriesRow ► Item
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | Item[([( String])]) |
 | Item[([( DataColumn])]) |
 | Item[([( Int32, DataRowVersion])]) |
 | Item[([( String, DataRowVersion])]) |
 | Item[([( DataColumn, DataRowVersion])]) |


GetRouteUrl Method

GetRouteUrl Method
API Documentation ► Keyoti.SearchEngine.Web ► KDropDownList ► GetRouteUrl()()()()
Keyoti SearchUnit v6
Members
Icon | Member | Description
 | GetRouteUrl(Object) |
 | GetRouteUrl(String, Object) |
 | GetRouteUrl(RouteValueDictionary) |
 | GetRouteUrl(String, RouteValueDictionary) |

Send comments on this topic to support@keyoti.com

2005-2016 Keyoti Inc.

Assembly: Keyoti4.SearchEnginePro.Web (Module: Keyoti4.SearchEnginePro.Web.dll) Version: 2015.6.15.120


SearchUnit Documentation: Installation

Installation

To use SearchUnit Pro for ASP.NET specific controls, you must add the following files to your project;
  • KeyotiX.SearchEnginePro.Web.dll,
  • KeyotiX.SearchEngine.Web.dll,
  • KeyotiX.SearchEngine.Core.dll,
  • KeyotiX.Text.MSOffice.dll,
  • KeyotiX.SearchEngine.Suggestions.dll, and
  • KeyotiX.SearchEngine.SuggestionsDictionary.dll, and
  • KeyotiX.Text.LemmaGenerator.dll

and reference the following DLLs in your web pages that use these controls.

  • KeyotiX.SearchEngine.Web.dll, and
  • KeyotiX.SearchEnginePro.Web.dll

(Where X corresponds to the .NET CLR version in use).

For Visual Studio

Simply add the SearchUnit assemblies to your Toolbox

  1. Select the "Components" tab in the Toolbox slider.
  2. Right click in the Toolbox area and click "Add/Remove Items" or "Customize Toolbox...".
  3. Select the ".NET Framework Components" tab.
  4. Find the SearchBox, FeaturedResults, and SearchResult controls under the Keyoti.SearchEngine.Web assembly.
  5. Find the SearchSuggestions and SearchBoxOptions controls under the Keyoti.SearchEnginePro.Web assembly.
  6. Click OK.

The controls have been added to your Toolbox and can be dragged onto forms.

For IIS (without using Visual Studio)

  1. Copy the following files into the bin directory off your application root;
    • KeyotiX.SearchEnginePro.Web.dll,
    • KeyotiX.SearchEngine.Web.dll,
    • KeyotiX.SearchEngine.Core.dll,
    • KeyotiX.Text.MSOffice.dll,
    • KeyotiX.SearchEngine.Suggestions.dll,
    • KeyotiX.SearchEngine.SuggestionsDictionary.dll, and
    • KeyotiX.Text.LemmaGenerator.dll

  2. Add

    <%@ Register TagPrefix="searchengine" Namespace="Keyoti.SearchEnginePro.Web" Assembly="KeyotiX.SearchEngine.Web" %>

    to the top of the aspx page where you will use the SearchUnit Pro for ASP.NET Controls.

    (Where X corresponds to the .NET CLR version in use).


SearchUnit Documentation: Introduction

SearchUnit

This Help documentation is aimed at the Pro level controls ONLY found in SearchUnit Pro, please see the general Search Help documentation for information on common controls.

Thank you for purchasing SearchUnit for ASP.NET, please keep up to date through our website keyoti.com and feel invited to post feedback. We also ask that you register your purchase so that we may offer you support and free upgrades from time to time, at http://keyoti.com/care/register

SearchUnit Pro Unique Features

Beyond the base level functionality of SearchUnit Lite, SearchUnit Pro also adds;

-Content & Location categories for documents
-'Did you mean?' style suggestions for spelling errors
-Index administration web application
-Windows Service based re-indexing/re-crawling

Requirements

The components were built to .NET CLR 1, 2 & 4 specification and are compatible with Visual Studio 2003, 2005, 2008, 2010, 2012, 2013.


SearchUnit Documentation: The Components

The Components

As well as the user interface controls, SearchUnit includes component classes that can be used to crawl web-sites, build indexes and search. Presented here is an overview of the key classes, it is recommended that the API docs are also consulted.

DocumentIndex

Inside the Keyoti.SearchEngine.Index namespace, this class provides methods for managing the indexed documents and to import sources (crawl web-sites, import folder contents, import databases & datasets).

Key Members

GetIndexedDocuments()
Returns all the Document objects in the index.

AddDocument()
Adds a Document object to the index.

RemoveDocument()
Removes a Document from the index.

Import(IndexableSourceRecord) and also convenience methods (ImportWebsite, ImportFileSystemFolder, ImportDatabase, and ImportCustomDataSet)
Imports the documents from an indexable source into the document index and returns a collection of imported Uri objects.

GetDocumentsFromIndexableSource(IndexableSourceRecord)
Returns all documents previously imported from a source.

SearchAgent

Inside the Keyoti.SearchEngine.Search namespace, this class provides methods for searching the index, it is located in Keyoti.SearchEngine.Search.

Key Members

Search()
Searches the index for the specified query.

GetDocumentText(string)
Retrieves the text of an indexed document, without formatting.


when changing these properties you will need to;

change files to ignore => delete index, recrawl and rebuild

change 'ignore last modified date' => rebuild index

change 'ignore regions' => rebuild index

change 'enable phrase matching => rebuild index

are there others? cant remember


SearchUnit Documentation: Examples

Examples

  • Authentication
    • How do I...: ...secure document access to specific groups of users
  • Examples
  • How do I...
    • ...add custom or new document parsers
    • ...create a SharePoint Web Part
    • ...ignore documents & pages
    • ...ignore menus & other page sections
    • ...index Windows Authentication apps
    • ...make Plug-ins (site mapper)
    • ...modify identified character encoding in TXT files
    • ...programmatically import
  • How do I..
    • ...index Forms Authentication apps
  • Indexing
    • ...in the Web Administration app
    • ...in Visual Studio
    • ...programmatically
  • Javascript Usage
    • How do I...: ...provide a search cloud
    • How do I...: ...provide filters to the user (CustomData)
    • How do I...: ...provide location or content category choosers
    • How do I...: ...provide sort by controls
    • How do I...: ...provide spelling suggestions (did you mean?)
    • How do I...: ...search with a simple form
    • Server Security
  • Programmatic Use
    • How do I...: ...programmatically search
  • Result Generation
    • How do I...: ...add CustomData to a document
    • How do I...: ...boost page & section weight
    • How do I...: ...filter results
    • How do I...: ...modify stemming (lemmas)
    • How do I...: ...secure document access to specific groups of users
    • How do I...: ...use CustomData for date sorting
  • Search & Result Controls
    • How do I...: ...add FeaturedResults
    • How do I...: ...customize layout (template usage)
    • How do I...: ...customize ResultPreview
    • How do I...: ...customize ResultPreview
    • How do I...: ...customize the AutoComplete
    • How do I...: ...customize the AutoComplete
    • How do I...: ...search with a simple form
    • How do I...: ...use AutoComplete or ResultPreview
  • Typical Development/Deployment Scenarios


Indexing A Website

Please choose the type of example;

In Visual Studio / Index Manager Tool

In Web Admin Application

Programmatically


SearchUnit Documentation: Result Generation: How do I...: ...secure document access to specific groups of users

Show language: C# VB.NET Both

Stemming And Lemmas

Stemming (finding lemmas) is used to search for word variations. Eg. if the user searches for "tables", they will receive results that include "table" (note that this is more powerful than simple wildcard searching, because it can match shorter as well as longer forms).

The LemmaWeightFactor property in the Configuration is set to 0.5 by default, and this controls by how much lemma matches are weighted in the results. If the user searched for "tables", then occurrences of "table" will weigh half as much as occurrences of "tables", this ranking helps prevent the top results being cluttered with inexact matches to the searched terms.

Languages

You can choose the language to use for stemming in the LemmaLanguage property in the Configuration. Note that stemming algorithms are language specific and so the supported languages may be less numerous than the spelling dictionaries that are also available for the SearchSuggestions control.

English and German lemmas are built-in to the product DLLs, other languages can be downloaded from this page. Unzipped files should be placed in the index directory, and the LemmaLanguage property in Configuration should be set accordingly.

Customization

The Central Event System includes an Action event called "GetWordVariations" which is fired when the search engine needs lemmas. By hooking into this event the lemmas provided by the default generator can be completely overwritten or modified. Note that variations don't necessarily have to be lemmas (shared stems) but can be any words that should be searched for at the same time, such as synonyms and substitutes. For example a company with a furniture polish product named "Shine-O", may like to include "Shine-O" as a variation for "polish".

Create a plug-in project
If a plug-in project does not already exist, create one with the Plug-in Quick Start.
Handle the desired event

Within the plug-in project, handle the Action event, and specifically the GetWordVariations Action.

C#
void CentralEventDispatcher_Action(object sender, Keyoti.SearchEngine.Events.ActionEventArgs e)
{

    if (e.ActionData.Name == Keyoti.SearchEngine.Events.ActionName.GetWordVariations)
    {

        Keyoti.SearchEngine.DataAccess.Word theWord = ((object[])e.ActionData.Data)[0] as Keyoti.SearchEngine.DataAccess.Word;

        ArrayList variations = (e.ActionData.Data as object[])[1] as ArrayList;

        if (theWord.WordContent == "polish")
        {

            string firstVariation = variations[0].ToString();

            variations.Insert(0, "Shine-O");//insert a word we also want to search for

        }
    }
}
VB.NET
Private Sub CentralEventDispatcher_Action(ByVal sender As Object, ByVal e As Keyoti.SearchEngine.Events.ActionEventArgs)

        If (e.ActionData.Name = Keyoti.SearchEngine.Events.ActionName.GetWordVariations) Then

            Dim theWord As Keyoti.SearchEngine.DataAccess.Word = CType(CType(e.ActionData.Data, Object())(0), Keyoti.SearchEngine.DataAccess.Word)

            Dim variations As ArrayList = CType(CType(e.ActionData.Data, Object())(1), ArrayList)

            If (theWord.WordContent = "polish") Then

                Dim firstVariation As String = variations(0).ToString

                variations.Insert(0, "Shine-O")

                'insert a word we also want to search for

            End If

        End If

    End Sub


JSDoc: Home

Home

Classes

  • KeyotiCheckboxesFilterControl
  • KeyotiCheckboxesIntRangeFilterControl
  • KeyotiDateFilter
  • KeyotiDropdownFilterControl
  • KeyotiIntFilter
  • KeyotiStringFilter
  • KeyotiStringListFilter
  • KeyotiTextboxesIntRangeFilterControl

Namespaces

  • keyotiCategoryChoosers
  • keyotiCustomDataFilters
  • keyotiCustomDataSort
  • keyotiResultViewer
  • keyotiSearch
  • keyotiSearchAutocomplete
  • keyotiSearchBox
  • keyotiSearchCloud
  • keyotiSearchResultPreviewer
  • keyotiTemplateUtility

Global

  • filterTransform
  • getRequestFilter
  • isFilterUsed
  • setSelectedValues
  • updateWithLiveData


                                 Apache License
                           Version 2.0, January 2004
                        http://www.apache.org/licenses/

   TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION

   1. Definitions.

      "License" shall mean the terms and conditions for use, reproduction,
      and distribution as defined by Sections 1 through 9 of this document.

      "Licensor" shall mean the copyright owner or entity authorized by
      the copyright owner that is granting the License.

      "Legal Entity" shall mean the union of the acting entity and all
      other entities that control, are controlled by, or are under common
      control with that entity. For the purposes of this definition,
      "control" means (i) the power, direct or indirect, to cause the
      direction or management of such entity, whether by contract or
      otherwise, or (ii) ownership of fifty percent (50%) or more of the
      outstanding shares, or (iii) beneficial ownership of such entity.

      "You" (or "Your") shall mean an individual or Legal Entity
      exercising permissions granted by this License.

      "Source" form shall mean the preferred form for making modifications,
      including but not limited to software source code, documentation
      source, and configuration files.

      "Object" form shall mean any form resulting from mechanical
      transformation or translation of a Source form, including but
      not limited to compiled object code, generated documentation,
      and conversions to other media types.

      "Work" shall mean the work of authorship, whether in Source or
      Object form, made available under the License, as indicated by a
      copyright notice that is included in or attached to the work
      (an example is provided in the Appendix below).

      "Derivative Works" shall mean any work, whether in Source or Object
      form, that is based on (or derived from) the Work and for which the
      editorial revisions, annotations, elaborations, or other modifications
      represent, as a whole, an original work of authorship. For the purposes
      of this License, Derivative Works shall not include works that remain
      separable from, or merely link (or bind by name) to the interfaces of,
      the Work and Derivative Works thereof.

      "Contribution" shall mean any work of authorship, including
      the original version of the Work and any modifications or additions
      to that Work or Derivative Works thereof, that is intentionally
      submitted to Licensor for inclusion in the Work by the copyright owner
      or by an individual or Legal Entity authorized to submit on behalf of
      the copyright owner. For the purposes of this definition, "submitted"
      means any form of electronic, verbal, or written communication sent
      to the Licensor or its representatives, including but not limited to
      communication on electronic mailing lists, source code control systems,
      and issue tracking systems that are managed by, or on behalf of, the
      Licensor for the purpose of discussing and improving the Work, but
      excluding communication that is conspicuously marked or otherwise
      designated in writing by the copyright owner as "Not a Contribution."

      "Contributor" shall mean Licensor and any individual or Legal Entity
      on behalf of whom a Contribution has been received by Licensor and
      subsequently incorporated within the Work.

   2. Grant of Copyright License. Subject to the terms and conditions of
      this License, each Contributor hereby grants to You a perpetual,
      worldwide, non-exclusive, no-charge, royalty-free, irrevocable
      copyright license to reproduce, prepare Derivative Works of,
      publicly display, publicly perform, sublicense, and distribute the
      Work and such Derivative Works in Source or Object form.

   3. Grant of Patent License. Subject to the terms and conditions of
      this License, each Contributor hereby grants to You a perpetual,
      worldwide, non-exclusive, no-charge, royalty-free, irrevocable
      (except as stated in this section) patent license to make, have made,
      use, offer to sell, sell, import, and otherwise transfer the Work,
      where such license applies only to those patent claims licensable
      by such Contributor that are necessarily infringed by their
      Contribution(s) alone or by combination of their Contribution(s)
      with the Work to which such Contribution(s) was submitted. If You
      institute patent litigation against any entity (including a
      cross-claim or counterclaim in a lawsuit) alleging that the Work
      or a Contribution incorporated within the Work constitutes direct
      or contributory patent infringement, then any patent licenses
      granted to You under this License for that Work shall terminate
      as of the date such litigation is filed.

   4. Redistribution. You may reproduce and distribute copies of the
      Work or Derivative Works thereof in any medium, with or without
      modifications, and in Source or Object form, provided that You
      meet the following conditions:

      (a) You must give any other recipients of the Work or
          Derivative Works a copy of this License; and

      (b) You must cause any modified files to carry prominent notices
          stating that You changed the files; and

      (c) You must retain, in the Source form of any Derivative Works
          that You distribute, all copyright, patent, trademark, and
          attribution notices from the Source form of the Work,
          excluding those notices that do not pertain to any part of
          the Derivative Works; and

      (d) If the Work includes a "NOTICE" text file as part of its
          distribution, then any Derivative Works that You distribute must
          include a readable copy of the attribution notices contained
          within such NOTICE file, excluding those notices that do not
          pertain to any part of the Derivative Works, in at least one
          of the following places: within a NOTICE text file distributed
          as part of the Derivative Works; within the Source form or
          documentation, if provided along with the Derivative Works; or,
          within a display generated by the Derivative Works, if and
          wherever such third-party notices normally appear. The contents
          of the NOTICE file are for informational purposes only and
          do not modify the License. You may add Your own attribution
          notices within Derivative Works that You distribute, alongside
          or as an addendum to the NOTICE text from the Work, provided
          that such additional attribution notices cannot be construed
          as modifying the License.

      You may add Your own copyright statement to Your modifications and
      may provide additional or different license terms and conditions
      for use, reproduction, or distribution of Your modifications, or
      for any such Derivative Works as a whole, provided Your use,
      reproduction, and distribution of the Work otherwise complies with
      the conditions stated in this License.

   5. Submission of Contributions. Unless You explicitly state otherwise,
      any Contribution intentionally submitted for inclusion in the Work
      by You to the Licensor shall be under the terms and conditions of
      this License, without any additional terms or conditions.
      Notwithstanding the above, nothing herein shall supersede or modify
      the terms of any separate license agreement you may have executed
      with Licensor regarding such Contributions.

   6. Trademarks. This License does not grant permission to use the trade
      names, trademarks, service marks, or product names of the Licensor,
      except as required for reasonable and customary use in describing the
      origin of the Work and reproducing the content of the NOTICE file.

   7. Disclaimer of Warranty. Unless required by applicable law or
      agreed to in writing, Licensor provides the Work (and each
      Contributor provides its Contributions) on an "AS IS" BASIS,
      WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
      implied, including, without limitation, any warranties or conditions
      of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
      PARTICULAR PURPOSE. You are solely responsible for determining the
      appropriateness of using or redistributing the Work and assume any
      risks associated with Your exercise of permissions under this License.

   8. Limitation of Liability. In no event and under no legal theory,
      whether in tort (including negligence), contract, or otherwise,
      unless required by applicable law (such as deliberate and grossly
      negligent acts) or agreed to in writing, shall any Contributor be
      liable to You for damages, including any direct, indirect, special,
      incidental, or consequential damages of any character arising as a
      result of this License or out of the use or inability to use the
      Work (including but not limited to damages for loss of goodwill,
      work stoppage, computer failure or malfunction, or any and all
      other commercial damages or losses), even if such Contributor
      has been advised of the possibility of such damages.

   9. Accepting Warranty or Additional Liability. While redistributing
      the Work or Derivative Works thereof, You may choose to offer,
      and charge a fee for, acceptance of support, warranty, indemnity,
      or other liability obligations and/or rights consistent with this
      License. However, in accepting such obligations, You may act only
      on Your own behalf and on Your sole responsibility, not on behalf
      of any other Contributor, and only if You agree to indemnify,
      defend, and hold each Contributor harmless for any liability
      incurred by, or claims asserted against, such Contributor by reason
      of your accepting any such warranty or additional liability.

   END OF TERMS AND CONDITIONS

   APPENDIX: How to apply the Apache License to your work.

      To apply the Apache License to your work, attach the following
      boilerplate notice, with the fields enclosed by brackets "[]"
      replaced with your own identifying information. (Don't include
      the brackets!)  The text should be enclosed in the appropriate
      comment syntax for the file format. We also recommend that a
      file or class name and description of purpose be included on the
      same "printed page" as the copyright notice for easier
      identification within third-party archives.

   Copyright [yyyy] [name of copyright owner]

   Licensed under the Apache License, Version 2.0 (the "License");
   you may not use this file except in compliance with the License.
   You may obtain a copy of the License at

       http://www.apache.org/licenses/LICENSE-2.0

   Unless required by applicable law or agreed to in writing, software
   distributed under the License is distributed on an "AS IS" BASIS,
   WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
   See the License for the specific language governing permissions and
   limitations under the License.