RapidSpell Desktop .NET Documentation: Terms & Conditions

Terms & Conditions

If you do not agree to these terms and conditions then you may not install, use, or distribute RapidSpell Desktop.
1. License and Ownership. RapidSpell Desktop is a licensed software product. RapidSpell Desktop, including its accompanying files and documentation, is owned and copyrighted by Keyoti Inc., © Copyright 2002-2017, all rights reserved. Keyoti Inc. grants the user in possession of an official receipt of purchase a nonexclusive license to download and use the software, for any lawful commercial or noncommercial purposes provided the terms of this agreement are met.
2. Distribution. If you purchased an Individual License Version of RapidSpell Desktop, you may copy and use the RapidSpell Desktop distribution file (.zip) on any systems you use but for your individual use only. Individual use is defined as one person having the ability to read or copy any of the files originally contained in the RapidSpell Desktop distribution file including (but not limited to) the .dll, .cs, .vb, .html, .gif, .jpg, .bat, and .txt files. You must take appropriate safeguards to protect this product from unauthorized access by others.
If you purchased a Site License Version of RapidSpell Desktop, then you may provide copies of the RapidSpell Desktop distribution file (.zip) to anyone employed by your company whose primary work address is within a 100 mile (160 km) radius of your primary work address. These individuals then have license rights and responsibilities equivalent to the Individual License Version. In all cases the copies of the RapidSpell Desktop distribution file (.zip) must be unaltered and complete, including this license agreement and all copyright notices. You may not reverse engineer, disassemble, decompile, or modify this software or its accompanying documentation in any way.
You may reproduce and redistribute a copy of the dll files as part of any .NET based software developed and licensed by you that itself uses RapidSpell Desktop provided
a) your software has clearly distinct and added functionality,
b) you are responsible for all technical support,
c) the RapidSpell Desktop application programming interfaces are not documented, exposed, or otherwise made available by your software,
d) attribution is given to Keyoti Inc. (http://www.keyoti.com) in any documentation or screen displays where other credits appear,
e) you do not allow recipients of your software to reverse engineer, disassemble, decompile, or copy portions from your software allowing them to gain separate access to RapidSpell Desktop or any parts of it,
f) your software is not used by software developers as part of their application, and
g) your software is not a software component or 'Control'.
The source code samples included with this package and in the RapidSpell Desktop documentation may be freely used, modified, incorporated, and distributed without restriction as part of any software that uses RapidSpell Desktop itself.
3. Warranty Disclaimer and Limitation of Liability. RapidSpell Desktop is licensed to the user on an "AS IS" basis. Keyoti Inc. MAKES NO WARRANTIES, EITHER EXPRESSED OR IMPLIED, WITH RESPECT TO THIS SOFTWARE AND ITS ASSOCIATED FILES AND DOCUMENTATION, INCLUDING BUT NOT LIMITED TO ANY WARRANTY OF MERCHANTABILITY OR FITNESS FOR ANY PARTICULAR PURPOSE. KEYOTI Inc. DOES NOT WARRANT THAT THE OPERATION OF THIS SOFTWARE WILL BE UNINTERRUPTED OR ERROR FREE, OR THAT DEFECTS WILL BE CORRECTED. You the user are solely responsible for determining the appropriateness of this software for your use and accept full responsibility for all risks associated with its use. Keyoti Inc. is not and will not be liable for any direct, indirect, special or incidental damages in any amount including loss of profits or interruption of business however caused, even if Keyoti Inc. has been advised of the possibility of such damages. Keyoti Inc. retains the right to, in its sole discretion, refund the purchase price of this software as a complete and final resolution to any dispute.
SPECIFIC DISCLAIMER FOR HIGH-RISK ACTIVITIES.
The SOFTWARE is not designed or intended for use in high-risk activities including, without restricting the generality of the foregoing, online control of aircraft, air traffic, aircraft navigation or aircraft communications; or in the design, construction, operation or maintenance of any nuclear facility. Keyoti Inc. and its suppliers specifically disclaim any express or implied warranty of fitness for such purposes or any other purposes.
NO LIABILITY FOR CONSEQUENTIAL DAMAGES.
To the maximum extent permitted by applicable laws, in no event shall Keyoti Inc. or its suppliers be liable for any damages whatsoever (including without limitation, damages for loss of business profits, business interruption, loss of information, or other pecuniary loss) arising out of the use of or inability to use this Keyoti Inc. product, even if Keyoti Inc. has been advised of the possibility of such damages. Because some states and jurisdictions do not allow the exclusion or limitation of liability for consequential or incidental damages, the above limitation may not apply to you.
4. Support and Source Code Licensing. Keyoti Inc. does provide formal customer support for RapidSpell Desktop for a fee. We also make every effort to ensure the quality of our products, and questions, bug reports, and feature requests are encouraged, please use email. Due to resource limitations, it may not be possible to resolve all issues and no assurances can be given as to when or if problems will be addressed. Customers incorporating RapidSpell Desktop into software for deployment or sale are encouraged to purchase the Source Code License Version of RapidSpell Desktop which will enable self-support, debugging, and modifications or extensions to the base functionality (but not distribution of the source code itself).


RapidSpell Desktop .NET Documentation: Introduction

RapidSpell Desktop .NET

Thank you for purchasing RapidSpell, please keep up to date through our website keyoti.com and feel invited to post feedback. We also ask that you register your purchase so that we may offer you support and free upgrades from time to time, at http://keyoti.com/care/register

Overview

RapidSpell consists of 3 spelling components (GUI and non-GUI) which provide for rapid integration within your application. Keyoti has developed these highly granular components with simplicity of application development in mind.

The assembly holds a graphical user interface component, which can be implemented with 2 lines of code to supply complete spell checker functionality (dialog or as-you-type) to any Windows Forms based application and a non-GUI class which provides a clean API for model (business/logic) level integration. Simplicity of use has been a major guiding force in the component design, however user customization has not been spared, the GUI can be easily customized and extended to provide UI customization and the non-GUI component provides access to core spell checking functionality.

Main spell check features:

  • Sentence capitalization correction
  • Autocorrect
  • Duplicate word detection
  • User (custom) dictionary and UI editor
  • Options editor
  • Customizable, compressed main dictionaries
  • Multilingual
  • Various ignore options (capitalization, words with digits, URLs/Emails, custom regex patterns etc)
  • Undo

Common Uses

Spell checking;
  • Strings programmatically
  • Windows Forms text editors (RichTextBox, TextBox)
  • 3rd Party text editors (TX Text Control, DevExpress, Janus etc.)

Requirements

The components were built to .NET CLR 2, 4.x and .NET Core 3.x specification and work with all SDKs from 2.0 up.

Reminder: .NET SDK v3 and v3.5 are actually CLR 2.


RapidSpell Desktop .NET Documentation: Release Notes

RapidSpell Desktop .NET Release Notes

General Upgrade Notes: As you move from one version to the next it is likely that your licenses.licx file becomes incompatible with the current version. The simplest way to fix this is to edit the licenses.licx file and on each line related to our controls, remove the text after the assembly name, eg.

Keyoti.RapidSpell.RapidSpellChecker, Keyoti.RapidSpell.NET4, Version=6.0.17.1105, Culture=neutral, PublicKeyToken=58d9fd2e9ec4dc0e
can be changed to
Keyoti.RapidSpell.RapidSpellChecker, Keyoti.RapidSpell.NET4

which will allow the licenses.licx file to be used with any version.

6.1.0

Backwards Compatibility
  • Please see v6.0.0 notes.
Improvements
  • Added .NET Core 3 support - reference Keyoti.RapidSpell.NETCore.dll in your .NET Core 3+ projects and license by calling Keyoti.RapidSpell.CoreLicensing.SetLicenseKey("<license key>");
  • ComboBox support added, please use the new AYTComboBox control for as you type spell checking in a ComboBox, you will need to add it to RapidSpellAsYouType the same way you do other textboxes (AddTextComponent method)
  • Updated English dictionaries

6.0.0

Backwards Compatibility
  • Please be aware that we have added support for multiple user dictionaries. This means that the end user can click the "Options..." button and then "User Dictionaries" and proceed to add new text files to be used as user dictionaries. The user is NOT permitted to remove the user dictionary assigned via code. To prevent the user adding/removing their own dictionaries, set ShowOptionForMultipleUserDictionaries=false in RapidSpellDialog or OptionsPresenter.
  • If you have a custom Options editor form (ie you are handling the event 'rapidSpellDialog1.CreateDialogViewOptions') then you will need to update the form that implements IDialogViewOptions. Open it and add an event SelectUserDictionary:
         public event EventHandler SelectUserDictionary;
    In the "User Dictionary" button click handler (eg. void userDictionaryBT_Click(object sender, EventArgs e)) change the code to call the new SelectUserDictionary event, eg.
            void userDictionaryBT_Click(object sender, EventArgs e)
        {
            if (SelectUserDictionary != null) SelectUserDictionary(this, e);
        }
Improvements
  • Add user dictionary file manager, so the user can add/remove additional text files to be used as user dictionaries (not available with TX Text Control at present).
  • Update Dict Manager
  • Improve user dictionary performance
  • Add DevExpress RichEdit support

5.4.0

Backwards Compatibility
  • As 5.3.0
Improvements
  • Fix German compound words longer than 10 chars.
  • The DataGridView_AYT_Manager control now includes both ShowErrorGlyph and ShowErrorUnderline properties to allow switching from underlines to a simple 'e' error icon in each cell with spelling errors.
  • Fix user options in case of concurrency.
  • Fix modal dialog.
  • Includes TX support DLLs to version 24.

5.3.0

Backwards Compatibility
  • As 5.2.0
Improvements
  • English dictionary updates.
  • Small bug fixes.
  • Includes TX support DLLs to version 22.

5.2.0

Backwards Compatibility
  • As 5.1.0
Improvements
  • Fix DataGridView underline rendering with non singleline mode usage.
  • Small bug fixes.
  • Includes TX support DLLs to version 21.

5.1.1

Backwards Compatibility
  • As 5.1.0
Improvements
  • Added RapidSpellAsYouType.RemoveAllTextComponents.
  • Added TX18 support DLL.
  • Corrected parsing of symbols.

5.1.0

Backwards Compatibility
  • All loaded main dictionaries are now cached and shared between (all instances of) RapidSpellAsYouType and RapidSpellDialog. This also improves performance when using the compressed .2.dict files (the default dictionary is compressed). The ShareDictionary property in the controls has been deprecated and now has no effect.
    The cache can be controlled through static methods

    DictionaryCache.RemoveDictionary
    DictionaryCache.RemoveAllDictionaries
Improvements
  • Improved RapidSpellAsYouType startup time using asynchronous dictionary loading (this means that forms load faster but there may be a very short delay before the underlines are shown for the first time, if this is unacceptable please use a non-compressed .dict file).
  • Users may now press ALT-<NUMBER> in RapidSpellDialog as a shortcut to change the misspelled word to item number <NUMBER> in the suggestion list. Also see NumberSuggestionList property in RapidSpellDialog to show list numbers.
  • Added WordChanging event to RapidSpellDialog.
  • Several small bug fixes..

5.0.0

Backwards Compatibility
  • The Keyoti.RapidSpellMDict.DLL dictionary is no longer used, by default a compressed US English dictionary is used - to use a different language you can embed the corresponding Dict File (.dict) into your project, please see the dictionaries section of the help for more info.
  • Lowercase i is no longer ignored by default (when LanguageParser==English), to preserve the old behaviour set IgnoreInEnglishLowerCaseI in the controls to true. It is also autocorrected.
  • The context menu now includes an "Ignore" option, therefore GetSuggestionsToolStripItems will also include an Ignore menu option, if you are using this method check that the extra ignore menu item will not harm your code.
  • WPF support has been dropped as we have since released RapidSpell WPF which includes new as-you-type support.
Improvements
  • Sentence capitalization correction (auto or manual).
  • Ignore Once added to 'as you type'.
  • Easier to use custom context menus from 3rd party control kits (use GetSuggestionContextMenuInformation, ChangeWordMenuItem_Click, IgnoreOnceMenuItem_Click, IgnoreAllMenuItem_Click, AddMenuItem_Click methods in RapidSpellAsYouType).
  • RapidSpellDialog support for DataGridView added (as you type already exists, see Help).
  • Compressed dictionaries
  • Many small bug fixes and improvements in behavior.

4.7.0

Backwards Compatibility
  • Backwards compatible with v4.6.x.
Improvements
  • Inclusion of .NET 4 built DLLs.

4.6.1

Backwards Compatibility
  • Backwards compatible with v4.6.
Improvements
  • WordDeleted event added to RapidSpellDialog for indication of user's removal of word from user dictionary.
  • Inclusion of TX Text Control v15.1 support DLL.
Fixes
  • Minor bug fixes

4.6.0

Backwards Compatibility
  • Backwards compatible with v4.5, please see v4.5 notes below for info on older versions.
Improvements
  • As you type support for regular .NET textboxes, RichTextBox and TextBox without subclassing. See TextBoxBase property and AddTextBoxBase method in RapidSpellAsYouType.
Fixes
  • Designtime issue with dictionary path properties
  • Options form fixed under non default DPIs
  • Minor TX Text Control integration bugs fixed, including; Support non standard screen resolutions, Ignore read-only hyperlinks, ApplicationFields
  • Minor bug fixes

4.5.0

This release is skipping some version numbers due to the magnitude of the change for our TX Text Control users.
Improvements

  • Various Form properties in RapidSpellDialog implemented for Win Form user's convenience (no need to use CreateDialogView event).
  • Overhaul of TX Text Control interaction.
Backwards Compatibility Issues For TX Text Control Users
As a result of unsolvable issues with the underlining mechanism used in prior versions we have adopted a new painting technique, which solves these issues but does introduce it's own differences/compromises (which we feel are greatly out weighed by the improvements). It's suggested that you review the new demo projects and help pages for TX.

Usage differences
  • Only one TXTextControlAdapter control is now used with RapidSpellAsYouType and/or RapidSpellDialog. For example, this means that the 'Helper' class from our examples should not be used anymore.
  • The TXTextControlAdapter control will automatically handle headers/footers/frames etc.
  • Although it is possible to use the red wavy underline style, we recommend that the dashed or single underline style is used (via the RapidSpellAsYouType.UnderlineStyle property).

End user experience differences
  • Undo functionality is no longer affected by running the spell checker.
  • Only the currently focused 'element' (header/footer/body/frame) is spell checked, with either the as-you-type or dialog control.
  • Slight flicker may be present in the underlines at certain times, this is because the painting is supplemental to the TX painting.

4.0.0

Backwards Compatibility

There are some API changes which are 'breaking', they will prevent some applications being compiled without code changes. Modifications to code should be simple in all cases except that of customized RapidSpellGUI (custom UI).

  • v3 license keys are not compatible with v4, please purchase an upgrade
  • Minor property renaming and movement of some methods to properties - in all cases, follow the compiler error message for suggested change.
  • RapidSpellGUI / IUserInterfaceForm - this class / interface has split into two; IDialogView and IUserInterfaceFormPresenter (implemented by RapidSpellGUIPresenter which replaces RapidSpellGUI). The BuildGUI method has been removed and now UI customizations are made by implementing the lightweight IDialogView interface (see demo projects and user guide for detail). Most other method overrides in RapidSpellGUI will still apply to RapidSpellGUIPresenter, except to note that the UI elements are now accessible through the DialogView property.
  • As part of the RapidSpellGUI change, IUserInterfaceFormProvider has been removed, it's functionality (customizing UI) has been replaced by RapidSpellDialog.CreateDialogView event.
  • IUserInterfaceFormPresenter has no Windows Forms specific properties due to support for WPF (eg. ControlBox). Instead, these can be accessed by casting DialogView.
  • RapidSpellAsYouType and RapidSpellGUIPresenter/Dialog event handler delegates moved to Keyoti.RapidSpell.Event namespace - import this namespace if not already.
  • Some user options, such as "Check spelling as you type" will override the properties in the controls (eg. RapidSpellAsYouType.CheckAsYouType). To avoid this, you can disable user options by setting RapidSpellAsYouType.OptionsEnabled=false and/or RapidSpellDialog.OptionsEnabled=false
  • RapidSpellAsYouType.TextComponents no longer has a "getter". Instead, rework your code to either use only the "setter", or use the new AddTextComponent/RemoveTextComponent methods.

It's possible that no compiler errors will occur after upgrading.

None of our default DLLs are Authenticode signed, if you need signed versions please download http://keyoti.com/downloads/RSDT.NET-4-0-0-Authenticode_signed_DLLs.zip

Improvements

  • User options form added, with user dictionary editor
  • Autocorrect (English / customizable) added to RapidSpellAsYouType
  • Undo function added to RapidSpellDialog
  • Dynamic add/remove of text boxes to spell checker controls
  • WPF support for RapidSpellDialog
  • Simpler and more flexible UI customization
  • Global change all/ignore all
  • Ignore once implementation for coupled RapidSpellDialog & RapidSpellAsYouType
  • Tighter integration between RapidSpellDialog & RapidSpellAsYouType
  • Improved handling of programmatic text changes
  • Duplicate word detection in RapidSpellAsYouType added (already present in Dialog)
  • Sentence context shown in dialog checker

Version History

3.8.0

Backwards Compatibility

-Backwards compatible with all v3 - except that Dict File file-names have been changed to a more consistent format. Please update the DictFilePath property of controls that directly access Dict Files from our installation directory.
**Note that if a Dict File cannot be located (wrong path) the DLL dictionary is used by default.

-All of our DLLs are now Authenticode signed.

Improvements

-July 2007 dictionary update included, adds 40,000 more words and word form variations.
-TX TextControl 14 support added.
-VS 2008 toolbox support and demo projects added.
-Aspose Editor support added.
-TX TextControl support behavior improved.

Fixes
-Various minor bug fixes

3.7.0b

Backwards Compatibility

-The installation directory layout and specifically, the DLL locations, has changed (to include .NET2/3 DLLs). This _may_ cause the references to become broken in your project (depending on how they were referenced). If your reference becomes broken, please re-add the reference to the DLL.

-If your code assigns a ContextMenu to AYTRichTextBox or AYTTextBox you must now assign that ContextMenu to the ContextMenuDefault property in order to have it shown properly when the user requests the ContextMenu away from a spelling error. In previous versions the control copied any design-time assigned ContextMenus and showed them when the user clicked away from a spelling error. However there were reliability issues and because of this, the behavior has changed.

-If your code assigns a ContextMenu to TXTextControl and you use RapidSpellAsYouType to check TXTextcontrol, then you must now assign that the ContextMenu to the TXTextControlAdapter.ContextMenuDefault property only.

-For CLR2 (.NET2), the new .NET2 assembly should be referenced, and in the licenses.licx any line referencing Keyoti.RapidSpell must be changed to "Keyoti.RapidSpell.RapidSpellChecker, Keyoti.RapidSpell.NET2"

-DataGridAYTTextBoxColumn.ShowErrorGlyph property is used to indicate whether a red 'e' is shown in a cell holding a spelling error. This property is now false by default and the new ShowErrorUnderline property is true, indicating that underlines will now be shown.

Improvements

-Replacement Dictionary DLLs support lower than Full Trust
-(ClickOnce) Other non Full Trust issues ironed out, RapidSpellDialog can be used under Internet security Context
-New .NET2 assembly version included, with ContextMenuStrip and DataGridView support added
-Added ContextMenuDefault property to AYT text boxes to make assigning default context menus easier
-DataGrid noneditmode display improvement (now shows underlines, optional).
-DevExpress support integrated into main DLL and source code provided to make support for DevExpress controls version independent
-Updated demos

Fixes
-Various minor bug fixes

3.6.0

Backwards Compatibility
-No compatibility issues to 3.5.2.
Improvements
-Visual Studio 2005 support
-ShowSuggestionsWhenTextIsSelected added to RapidSpellAsYouType, allowing default behavior override
-TX TextControl v12 support (see http://keyoti.com/kb/attachments/RSDT.NET_TX_TextControl_Comprehensive_How_To/article.html)
Fixes
-Fixed issue with suggestions when IgnoreWordsWithDigits is set false, default value is true.

3.5.2

Backwards Compatibility
-No compatibility issues to 3.5.1.
Improvements
-Ignore HTML/XML support added to RapidSpellAsYouType
Fixes
-Fixed issue with suggestions when IgnoreWordsWithDigits is set false, default value is true.

3.5.1

Backwards Compatibility
-No compatibility issues to 3.5.0.
Improvements
-Support for Infragistics 5.2 added (5.1 and 4.3 still included)
Fixes
-Fixed issue causing slowdown with very long 'words' (>150 chars)
-Dictionary update including case corrections for i.e. and e.g.
-Fixed issue that could occur when launching the spell checker on multiple text boxes before previous check was complete

3.5.0

BACKWARD INCOMPATIBILITY

Some changes have affected compatibility/expected-behavior between this version and previous versions:

Licensing; with the implementation of a new licensing system, simply swapping old version for new version DLLs will NOT WORK. It is imperative that licensing instructions in the user-guide PDF are followed.

GUI Changes; pressing the Escape key now closes the dialog based spell checker, various keyboard shortcuts "&" are now defined by default for RapidSpellGUI buttons.

Improvements
-Grids: As-you-type support added for DataGrid, Janus GridEX and Infragistics UltraGrid
-Full support added for Janus EditBox
-Improved suggestions for 2-3 character words
-Additional properties of RapidSpellGUI/Form exposed through RapidSpellDialog for additional convenience
-RapidSpellAsYouType painting in TX TextControl improved
-Work-around used to prevent modal flickering during dispose, modal forms can now be made to not be disposed of automatically, use ModalAutoDispose to set behavior
-RapidSpellAsYouType.AutoCheckAllTextComponentsUnder now looks for nested text components
-Added AllowAnyCase property
Fixes
-"Smart apostrophes" from MS Word are now handled correctly
-IgnoreURLsAndEmailAddresses toggling behavior fixed
-Tab order and default focus in RapidSpellGUI
-Fixed bug with AYTRichTextBox and Apps key firing suggestions context menu

3.4.0

Improvements
-Enhanced word parser allows sophisticated custom pattern ignoring and built-in URL and email ignoring, please see V2Parser and IgnoreURLsAndEmailAddresses properties and AddIgnorePattern(regex) method.
-In RapidSpellDialog, double clicking on a suggestion now automatically changes the text to that suggestion.
-Portuguese UI texts added, for new Portuguese dictionaries.
-New AutoCheckAllTextComponentsUnder method provides shortcut to as-you-type check all compatible text boxes on the Form.
-Support for new version of Infragistics controls (3.2).
-New property AllowMixedCase sets whether words of mixed case will be reported as errors if they are not in dictionary with matching case.
Fixes
-Duplicate word errors are now highlighted in a manner consistent with spelling errors. Also fixes highlighting errors related to duplicate words.
-TXTextControl in page view, doesn't scroll properly to make error word visible, this has been fixed.
-When focus leaves the text box, all unchecked words are now spell checked, in RapidSpellAsYouType.

3.3.0

Improvements
-The RapidSpellAsYouType context menu displayed when the user right clicks on an underlined word can now be shown as part of a custom context menu. See SpellContextMenuRequest event.
-RapidSpellDialog forms can now be closed through RapidSpellDialog.Close() - multi-form applications should listen for Form.Closing event to close RapidSpellDialog object when necessary.
-Customized GUI classes can now be used in RapidSpellDialog, allowing for easier use, especially in multiple text box environments.
-Dictionary updates.
Fixes
-TXTextControl adapter is now usable with RapidSpellAsYouType in the design environment without needing to code the adapter around the TextControl manually, it can be performed visually.
-Duplicate numbers are no longer reported as an error.
Backwards Compatibility
-No compatibility issues to 3.2.0.

3.2.1

Improvements
-Dialog icon now settable.
Fixes
-Minor duplicate word detection fix.
Backwards Compatibility
-No compatibility issues to 3.2.0.

3.2.0

Improvements
-Spell check now detects duplicate words.
-AYTRichTextBox & AYTTextBox Controls now have optional Cut/Copy/Paste menu.
-TX TextControl support with RapidSpellDialog has been improved with the addition of an 'adapter' control TXTextControlAdapter; integration is now custom code-less.
-Addition of new RapidSpellAYTDialogCoupler control creates cohesive as-you-type and dialog checking.
-QueryTextBoxMultiline property added, so that 'not in dictionary' text box can be set to single line.
-Developer set context menu's are now shown when a user right clicks off a misspelt word.
-ShowSuggestionsContextMenu property added to RapidSpellAsYouType, enabling suggestions to be disabled.
-Dialog box is not shown (by default) if there are no errors.
-Addition of Location property in RapidSpellDialog, for setting dialog location.
-All UI text properties are now set-able.
-Addition of MinimizeBox, TopLevel, MdiParent, Parent and TopMost properties.
-New events for; ignore, change and add actions in RapidSpellDialog and RapidSpellAsYouType.
-New Infragistics UltraTextEditor adapter Control makes integration easy and code-less.
-CheckerEngine property now available in RapidSpellDialog.
Fixes
-Suggestions now preserve case of mis-spelt word.
-Anything starting with a digit was ignored, now anything containing a digit will be ignored by default unless IgnoreWordsWithDigits = false.
Backwards Compatibility
-Checking is performed (in Dialog) prior to opening dialog, on slow machines this may cause a delay before a message box or the dialog is shown, set AlwaysShowDialog=true for old behavior.
-Customers using TX TextControl and RapidSpellDialog should use the new adapter control TXTextControlAdapter or add a ScrollToCaret method to their interface.

3.1.2

Improvements
SpellCheckFinished event argument now has 'Cancelled' property, the property is true when the spell check was cancelled (either by clicking cancel or by closing the dialog box).
Fixes
When running any of the spell checker Controls on systems whose culture is not invariant, or English based, certain words in the dictionary are ignored and reported as misspelled, the top suggestion is shown to be that word.

Compiling projects on systems without TX TextControl would cause a non-critical warning to be produced by the compiler. This has been fixed and TXTextControl dependency (for developers working with that tool) has been moved to a separate DLL (Keyoti.RapidSpell.TXSupport.dll).

3.1.0

Improvements
As You Type support for TX Text Control, added.
As You Type Fixes
Changing text in a text box using the .Text property could cause the underline to appear in the wrong place

3.0.3

Improvements
'Add' context menu option in RapidSpellAsYouType is now hidable (use ShowAddMenuOption=false)
As You Type Fixes
Text control resizing - now repaints underlines automatically
Hyphens causing word breaks across lines - underlines now drawn on both lines

3.0.1

Fixes
Mouse wheel scrolling repaint fix.

Improvements Over v2

As-you-type checking with full in-document highlighting
Smooth multiple text box checking for dialog and as-you-type
Backwards Compatibility
v3 is backwards compatible apart from the following issues;

Namespace in v2 was Com.Keyoti.RapidSpell (Java convention), it is now Keyoti.RapidSpell, this was changed to avoid confusion with COM, which RapidSpell has no connection with.

RapidSpellGUI internal lifetime control has been changed, if you are using RapidSpellGUI and are concerned, please contact support@keyoti.com.

Known Issues

Flickering With As-You-Type; due to the limitations in the .NET implementation of the text box controls it is not possible to rigorously control painting of the text box - double buffering, a common anti-flicker technique is impossible. In tests we have found that the amount of flicker is dependent on the age of the users graphics card. More modern, powerful cards have much less flicker, due to their higher update rates. We will continue to look at ways of minimizing the flicker in the future.


RapidSpell Desktop .NET Documentation: Installation

Installation

Running the MSI installer is all that is required to install the controls for development. Initially the controls will be licensed on a time-limited trial basis until a license key is registered through the evaluation splash page.

After installation, the DLLs are made available to the list of assemblies in Visual Studio, from here the controls can be added to the VS toolbar by right clicking in the Toolbox and choosing "Add/Remove items..." and from there selecting the controls in the dialog list.

Referencing Keyoti Assemblies (DLLs)

The installer includes current version DLLs for .NET CLR 1, 2 and 4. These can be found in the subfolders under the install directory. It is important to understand which set of DLLs you are referencing. For example if you reference the .NET 4 DLLs, then the licenses.licx line should correspond to that, see below.

The exact DLLs that you reference will depend on what you are doing;

Standard:
.NET Core 3 - reference Keyoti.RapidSpell.NETCore.DLL (from the .NETCore_DLLs folder)
.NET 2, 3 or 3.5 - reference Keyoti.RapidSpell.NET2.DLL (from the .NET2_DLLs folder)
.NET 4 - reference Keyoti.RapidSpell.NET4.DLL (from the .NET4_DLLs folder)

TX Text Control support:
Reference Keyoti.RapidSpell.NET2.TXSupportv1x.DLL (from the 3rd Party DLLs folder) (from the .NET2_DLLs folder)

Infragistics support:
Reference Keyoti.RapidSpell.InfUTEditorSupport2.vX.Y.DLL (from the 3rd Party DLLs folder), and Keyoti.RapidSpell.NET2.DLL (from the .NET2_DLLs folder)

Other 3rd Party controls:
As 'Standard' above with any support classes we prescribe.

Licensing

With .NET Core

.NET Core 3 does not currently support licenses.licx or lc.exe. Therefore to license the DLL please call:

Keyoti.RapidSpell.CoreLicensing.SetLicenseKey("<license key>");

With regular .NET Framework

The controls, components and classes are licensed using the .NET licensing framework. Fundamental to this is the requirement that a file "licenses.licx" is compiled with the project. The licenses.licx files specifies class names and their assemblies, that need referencing. It is important that the assembly name (see below) matches the name of the assembly that the project references. Eg. if referencing Keyoti.RapidSpell.NET2.DLL then the assembly name in the licenses.licx must be "Keyoti.RapidSpell.NET2".

Registering The License Key

Either click "Register" in the blue licensing dialog shown when running an unlicensed application, or run the registration application (Control-Register.exe) located under the '.NETx_DLLs' folder (choose the same folder as the DLLs you are referencing). Any applications using RapidSpell must subsequently be fully rebuilt (Rebuild Solution) to embed the key properly.

TFS and other build server users: When using TFS, the build server needs the key registered under the TFSSERVICE user. To do that, use Control-Register.exe from under \Program Files\Keyoti Inc\RapidSpell Desktop .Net\.Net4_DLLs\
This requires Keyoti.RapidSpell.NET4.dll to be in the same folder when run.
The simplest way to do this is to install RapidSpell on the server, but it's not required, the EXE and DLL can be copied over. Then use "Run As..." on Control-Register and choose TFSSERVICE.

Information for build servers running under the system account
If you find you’re unable to use “Run As…” for the local system account then please follow these instructions;

Download PSTools (from SysInternals, owned by Microsoft) and extract PSexec.exe to a folder on the machine.

Download from TechNet

Download from Keyoti

Open the CMD prompt using “Run as Administrator” and open the directory containing PSexec.exe

Type;

psexec -i -s cmd.exe

(-i is for interactive, -s is to run as system)

Then launch Control-Register.exe from the new CMD window, or launch it from the Psexec command instead of CMD.

Visual Studio

A licenses.licx file is created (or appended to) when any licensed control is dragged onto the design surface. (The licenses.licx file must be in the project that makes the executable.) However, if the controls are used directly in code, or if the RapidSpellChecker class is used directly then Visual Studio will not create/ append the licenses.licx file. In this case create or open one in the project directory (using Notepad for example - make sure it is called "licenses.licx" and not "licenses.licx.txt"). In the licenses.licx file add one of these lines:

If referencing our .NET 2 DLL
Keyoti.RapidSpell.RapidSpellChecker, Keyoti.RapidSpell.NET2

If referencing our .NET 4 DLL
Keyoti.RapidSpell.RapidSpellChecker, Keyoti.RapidSpell.NET4

which follows the standard format

<Class name>, <Assembly name>

If the class exists in a different assembly, such as the Keyoti.RapidSpell.TXSupportv12.DLL, then modify the assembly name, and if the control used is RapidSpellDialog for example then modify the class name, eg.

Keyoti.RapidSpell.RapidSpellDialog, Keyoti.RapidSpell.TXSupportv12

After modifying the licenses.licx file it is important to rebuild the solution. The licenses.licx file can contain multiple lines specifying different classes and assemblies.

Note: if a licenses.licx file is copied into the project directory, it must also be added to the VS project.

Note: the licenses.licx file must be in the project that creates the executable, if RapidSpell is used in a usercontrol, the licenses.licx file must still be added to the exe project that uses the usercontrol.

Command-line compiler

lc.exe is used to compile a text file (like licenses.licx) into a resource, from there the resource can be compiled into the final executable, please see the .NET documentation and Non Visual Studio examples for help.

lc /target:Form.exe /complist:licenses.licx /i:Keyoti.RapidSpell.DLL

csc /res:Form1.exe.licenses /target:exe /reference:Keyoti.RapidSpell.DLL Form1.cs

Deployment

RapidSpell Desktop complies with the "XCopy deployment" standard which means that deployment is simply a matter of ensuring that the RapidSpell Desktop DLLs used are deployed with the executable or installed into the GAC. The DLLs that you choose to deploy is dependent on which controls you have used, typically only Keyoti.RapidSpell(.NETX).DLL need to be deployed.

Special considerations are:

-Some 3rd party support controls reside in other assemblies, if these assemblies are referred to in your project, then they must be deployed also.

-Any ".dict" files used (eg. via the DictFilePath properties) must be deployed also, unless they are embedded resources (see the dictionaries section).

-The .NET licensing mechanism does NOT allow the name of the executable to be changed after it has been compiled - doing so will invalidate all licenses.


Quick Start - As You Type Usage

Quick Start - AsYouType

Step 1
Step 2
Step 3
Step 4
Step 5
Change Dictionary

Step 1. Get your project ready (load or create it).

Step 2

Step 2. Add the RapidSpell Controls to your ToolBox

(if you have older versions listed, please remove them).

Note:
.NET 4 users should only add controls from, and reference Keyoti.RapidSpell.NET4.dll
.NET 2 & 3 users should only add controls from, and reference Keyoti.RapidSpell.NET2.dll
.NET 1.x users should use Keyoti.RapidSpell.dll instead

Step 3

Step 3. Drag the rapidSpellAsYouType Control onto your Form and add a TextBox.

Step 4

Step 4. Set the TextBoxBase property in rapidSpellAsYouType1 to your TextBox.

Step 5

Step 5. Run!

Note:

- By default a US English dictionary is used, to switch it to another dictionary (eg. UK) please click here.

- To offer an "Add" function to the user, set the UserDictionaryFile property to the file path where the dictionary should be stored (eg. "user-dictionary.txt").

Changing the main dictionary

Included are 5 dictionaries assemblies, AU, CA, UK and US English and a combined UK and US dictionary. These are located in the Dictionaries folder under the install folder.

To change the dictionary being used;

  1. Add the Dict File of your choice to your project -
    a. Copy the Dict File from the install folder, typically C:\Program Files (x86)\Keyoti Inc\RapidSpell Desktop .NET\Dictionaries
    (files with .2 in them are compressed)
    b. Paste the Dict File to your project folder
    c. Open your Visual Studio project, right click within the Solution Explorer select 'Add Existing Item' and locate the Dict File (you may need to change the File Types to 'All Files')

  2. In the properties pane for the Dict File, set it as an Embedded Resource

  3. Set the DictFilePath in the spell check controls to the name of the Dict File
    (in the screen-shot that would be 'DICT-EN-UK-UKEnglish.2.dict')

Note: By default, when a Dict File is not specified, the built-in US English dictionary is used.


Quick Start - Dialog Mode Usage

Quick Start - Dialog mode

Step 1
Step 2
Step 3
Step 4
Step 5
Step 6
Change Dictionary

Step 1. Get your project ready (load or create it).

Next

Step 2. Add the RapidSpell Controls to your ToolBox

(if you have older versions listed, please remove them).

Note:
.NET 4 users should only add controls from, and reference Keyoti.RapidSpell.NET4.dll
.NET 2 & 3 users should only add controls from, and reference Keyoti.RapidSpell.NET2.dll
.NET 1.x users should use Keyoti.RapidSpell.dll instead

Next

Step 3. Drag the rapidSpellDialog Control onto your Form and add a TextBox.

Next

Step 4. Set the TextBoxBaseToCheck property of rapidSpellDialog1 to the text box ID.

Next

Step 5. Add a button to the form and call Check() in the click event.

Next

Step 6. Run!

Note:

- By default a US English dictionary is used, to switch it to another dictionary (eg. UK) please click here.

- To offer an "Add" function to the user, set the UserDictionaryFile property to the file path where the dictionary should be stored (eg. "user-dictionary.txt").

Users can edit the word being checked using the dialog form and replace it with their own.

Changing the main dictionary

Included are 5 dictionaries assemblies, AU, CA, UK and US English and a combined UK and US dictionary. These are located in the Dictionaries folder under the install folder.

To change the dictionary being used;

  1. Add the Dict File of your choice to your project -
    a. Copy the Dict File from the install folder, typically C:\Program Files (x86)\Keyoti Inc\RapidSpell Desktop .NET\Dictionaries
    (files with .2 in them are compressed)
    b. Paste the Dict File to your project folder
    c. Open your Visual Studio project, right click within the Solution Explorer select 'Add Existing Item' and locate the Dict File (you may need to change the File Types to 'All Files')

  2. In the properties pane for the Dict File, set it as an Embedded Resource

  3. Set the DictFilePath in the spell check controls to the name of the Dict File
    (in the screen-shot that would be 'DICT-EN-UK-UKEnglish.2.dict')

Note: By default, when a Dict File is not specified, the built-in US English dictionary is used.


RapidSpell Desktop .NET Documentation: RapidSpellDialog

RapidSpellDialog

The RapidSpellDialog control conveniently wraps access to the RapidSpellGUIPresenter class providing dialog spell checking functionality for Windows Forms or WPF with single or multiple text boxes. This control is of particular use to developers who use an IDE such as Microsoft's Visual Studio or Borland's C# Builder.

This control mirrors most properties and methods available in RapidSpellGUIPresenter. Some members of note are (please consult API docs for more info):

Properties
Options | - the users options
TextBoxBaseToCheck | - the TextBoxBase to be checked
TextBoxBasesToCheck | - an array of TextBoxBases to be checked
ThirdPartyTextComponentToCheck | - a 3rd party component to be checked
ThirdPartyTextComponentsToCheck | - an array of 3rd party components to be checked
Modal | - whether to spell check modally
SuggestSplitWords | - whether to suggest split words (eg. thistime -> this time)
SuggestionsMethod | - the suggestions method in use (hashing or phonetic)
GUILanguage | - the text language used in the GUI
IgnoreXML | - whether to ignore XML or HTML tags
ShowFinishedBoxAtEnd | - whether to show a spell check finished box at end
IgnoreCapitalizedWords | - whether to ignore capitalized words
IncludeUserDictionaryInSuggestions | - whether to include user dictionary words in suggestions
LookIntoHyphenatedText | - whether to consider hyphenated parts as individual words
UserInterfaceFormProvider | - allows customized user interfaces to be used
Methods
Check() - runs the spell checker dialog
Events
SpellCheckStarted | - fired when checking starts
SpellCheckStartedTextBox | - fired when spell check starts on a text box (used in multiple text box checking situations)
SpellCheckFinished | - fired when checked ends
SpellCheckFinishedTextBox | - fired when spell check starts on a text box (used in multiple text box checking situations)
WordAdded | - fired when word added to user dictionary
WordChanged | - fired when word changed
WordIgnored | - fired when word ignored
CreateDialogView | - allows customization of the UI by replacing the form used in the dialog
CreateDialogViewOptions | - allows customization of the UI by replacing the form used in the dialog
CreateDialogViewUserDictionaryEdit | - allows customization of the UI by replacing the form used in the dialog
RecheckDocumentRequest | - user has requested the document be rechecked


RapidSpell Desktop .NET Documentation: RapidSpellAsYouType

RapidSpellAsYouType

The RapidSpellAsYouType control provides "as-you-type" spell checking and autocorrect functionality for System.Windows.Forms.TextBox and RichTextBox and also for derived controls (eg. Keyoti.RapidSpell.AYTTextBox and Keyoti.RapidSpell.AYTRichTextBox) and implementors of the IAYTTextBox interface. Only one RapidSpellAsYouType control is required to check multiple text boxes per form.

Some members of note are (please consult API docs for more info):

Properties
CheckAsYouType | - whether to spell check words as the user types/modifies text.
CheckCompoundWords | - whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
ConsiderationRange | - sets the factor for words to consider for suggestions, lower values are faster but consider less words for suggestions. Default is 80. If w <= 1 this method won't do anything.
DictFilePath | - optional file path to the main dictionary .dict file to use.
GUILanguage | - the language to show the UI in.
IgnoreCapitalizedWords | - whether to ignore words with capital letters.
IncludeUserDictionaryInSuggestions | - whether the user dictionary should be used in finding suggestions for misspelt words.
LanguageParser | - the type of language parsing to use.
LookIntoHyphenatedText | - whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
Options | - the users options.
SeparateHyphenWords | - whether to treat hyphenated (-) words as separate words, default is false.
SuggestionsMethod | - the suggestions method to use.
SuggestSplitWords | - whether to look for connected words in suggestions.
TextBoxBase | - the TextBox or RichTextBox to check as the user types/ modifies text.
TextComponent | - the IAYTTextBox text box to check as the user types/ modifies text.
TextComponents | - the IAYTTextBox text boxes to check as the user types/ modifies text (legacy, use AddTextComponent).
UnderlineColor | - the underline color to use with mis-spelt words.
UserDictionaryFile | - the user dictionary file, if this file doesn't exist it will be created.
Methods
AddTextBoxBase | - adds a text component to the list being checked.
AddTextComponent | - adds a text component to the list being checked.
AutoCheckAllTextComponentsUnder | - adds all eligible text components found inside a control.
ForceCheckAll | - forces a check of the whole document.
RepaintUnderlines | - repaints the underlines, this should be called if any changes are made to layout, such as changes to font sizes, etc.
Events
SpellCheckFinished | - fired when checking finishes.
SpellCheckStarted | - fired when checking starts
SpellContextMenuRequest | - fired when context menu should be shown, allows customization of spelling context menu
WordAdded | - fired when word added to user dictionary
WordChanged | - fired when word changed
WordsEntered | - fired when words are entered by the user
WordIgnored | - fired when word ignored

AYTRichTextBox

The AYTRichTextBox control is a sub-class of RichTextBox, this means that it can be used as a direct replacement for RichTextBox. This control has optional additional functionality for RapidSpellAsYouType.

AYTTextBox

The AYTTextBox control is a sub-class of TextBox, this means that it can be used as a direct replacement for TextBox. This control has optional additional functionality for RapidSpellAsYouType.

AYTInkEdit

As you type enabled subclass of the InkEdit (from the Tablet SDK). Available in the "Tablet Ink SDK Support" sub folder - requires the Tablet SDK be installed.

Implementation

Please see the 'Examples' section of this manual.


RapidSpell Desktop .NET Documentation: RapidSpellAYTDialogCoupler

RapidSpellAYTDialogCoupler

Quickly and simply couples RapidSpellAsYouType and RapidSpellDialog to provide a cohesive end user experience (i.e. Ignore All in RapidSpellDialog will Ignore All in RapidSpellAsYouType). Design time use is easy, drop the RapidSpellAYTDialogCoupler component onto the design surface and set the RapidSpellAsYouType and RapidSpellDialog properties to the RapidSpellAsYouType and RapidSpellDialog controls already on the form.


RapidSpell Desktop .NET Documentation: Main DLLs

Main DLLs

.NET1.x

Keyoti.RapidSpell.dll contains the main controls for .NET 1.x use. This DLL can be used with .NET 2+ if desired, however it does not contain .NET 2+ features such as ContextMenuStrip or DataGridView.

.NET 2 & 3 (CLR2)

Keyoti.RapidSpell.NET2.dll contains the main controls for CLR2 (.NET2 and .NET3) use. References to Keyoti.RapidSpell.DLL in this document and Keyoti KB articles can generally be interchanged with Keyoti.RapidSpell.NET2.DLL.

.NET 4 (CLR4)

Keyoti.RapidSpell.NET4.dll contains the main controls for CLR4 (.NET4) use. References to Keyoti.RapidSpell.DLL in this document and Keyoti KB articles can generally be interchanged with Keyoti.RapidSpell.NET4.DLL.


RapidSpell Desktop .NET Documentation: 3rd Party Control Support

3rd Party Control Support

3rd party control support is offered through support DLLs, support class source code and knowledge base articles (http://keyoti.com/kb), as appropriate. The Visual Studio demos accompanying this product demonstrate support with a selection of controls - please consult the demos folder for what is currently available.

TX Text Control 16 and higher

To use RapidSpell with TX Text Control it is necessary to reference Keyoti.RapidSpell.NET2.TXSupportv1X.DLL instead of Keyoti.RapidSpell.NET2.DLL. It is important to choose the correct version of Keyoti.RapidSpell.NET2.TXSupportv1X.DLL as it references a particular version of TX TextControl.

Do NOT use RapidSpellAsYouType (as-you-type checking is now handled by RapidSpellDialog) or the TXTextControlAdapter classes. Use only RapidSpellDialog and it's AddTextComponent to assign a TextControl to be spell checked (dialog and as you type).

Basic Setup
  1. Open/create a project which uses TX Text Control
  2. Open the form holding TX Text Control, and drag on RapidSpellDialog.
  3. Configure the "Text Control" property in RapidSpellDialog.
  4. Add a button or menu item and start RapidSpellDialog in it's click handler, calling RapidSpellDialog.Check()

At this stage the spell check should work, however a few changes are needed for optimal integration.

ContextMenuStrip

RapidSpellDialog will need to control the ContextMenuStrip for the Text Control. Therefore, unset the TextControl.ContextMenuStrip property in the designer, to null/Nothing/none. Then set RapidSpellDialog's ContextMenuStripDefault property to the ContextMenuStrip to use when the user clicks away from a spelling error.

In the regular TX Text Control examples, there is a MouseDown event handler, which is used to show the regular 'text context menu'. This should be commented out, so that the context menu strip is not manually shown on the MouseDown event - RapidSpell will take care of this.

In the regular TX Text Control examples, there is a TextFrameRightClicked event handler, which shows the context menu for textframes when the user right clicks on a frame edge. Modify textControl1_TextFrameRightClicked, by adding

//C#
if (rapidSpellDialog1.GetSuggestionsToolStripItems() == null)
{
...
}

'VB.NET
If RapidSpellDialog1.GetSuggestionsToolStripItems() Is Nothing Then
...
End If
around it's contents, so that the menu logic isn't performed when there are spelling suggestions.

Resetting Ignored Words (When Creating/Opening New Documents)

To reset the words that have been ignored for a document, call

rapidSpellDialog1.ResetIgnoredWords()

TX Text Control 15.1 and lower

To use RapidSpell with TX Text Control it is necessary to reference Keyoti.RapidSpell.NET2.TXSupportv1X.DLL instead of Keyoti.RapidSpell.NET2.DLL. It is important to choose the correct version of Keyoti.RapidSpell.NET2.TXSupportv1X.DLL as it references a particular version of TX TextControl.

For a detailed how to, please see http://keyoti.com/kb/Default.aspx?ToDo=view&questId=97&catId=44 or the demos under the TX TextControl subfolder inside the Examples folder.

DevExpress XtraGrid, MemoEdit, MemoExEdit, TextEdit

Support for DevExpress controls is provided through the class RapidSpell_DevExpressAdapter_Glue which is supplied in source code form with the DevExpress Visual Studio demo projects. This class includes (in the case of the text editors) subclasses of the DevExpress controls which can be used in place. This class also includes column editor repository classes for grid spell checking. The demo projects and 'Use Case' section show usage. Support for DevExpress is version agnostic, which means it is safe to upgrade regularly without needing updates for RapidSpell support.

Janus GridEX, EditBox

Support for Janus controls is provided through subclasses of Janus control classes for the text editors and through grid events. The demo projects and 'Use Case' section show usage. Support for is version agnostic, which means it is safe to upgrade regularly without needing updates for RapidSpell support.

Infragistics

Support DLLs for certain versions are provided, these enable use of RapidSpell with Infragistics' UltraTextEditor and UltraGrid. These are provided for legacy users - please email support@keyoti.com if help is needed with these controls.


RapidSpell Desktop .NET Documentation: Dictionaries

Dictionaries

RapidSpell can use 2 different types of dictionary at once; the "main dictionary" and a "user dictionary".

Main Dictionary

Included are 5 dictionaries assemblies, AU, CA, UK and US English dictionaries, each containing ~110K words, a combined UK and US dictionary containing ~115K words. These are located in the Dictionaries folder under the install folder.

Keyoti offer a number of non-English dictionaries. Further details and evaluation versions are available at;

http://keyoti.com/products/rapidspell/dotNet/dictionaries.html

Choosing The Main Dictionary

  • RapidSpell uses it's own proprietary compressed/uncompressed dictionary format, these dictionaries are called Dict Files.
  • By default, when a Dict File is not specified, the built-in US English dictionary is used.
  • To use a Dict File set the DictFilePath property (of any spell check control) to the path of the Dict File to be used.
  • Files with '.2.dict' in their name are compressed. Due to decompression they do load slightly slower than the uncompressed versions.
As An Embedded Resource

Embedding the Dict File as a resource is the cleanest way to distribute the dictionary, the dictionary is included in your DLL or EXE, and does not have to be packaged separately. The only disadvantage is that the dictionary cannot be changed (using Dict Manager) without recompiling the application.

  1. Add the Dict File of your choice to your project (it can be the project that uses RapidSpell or a satellite assembly (provided the assembly is loaded into the App Domain (i.e. it's used) before spell checking starts).
  2. In the properties pane for the Dict File, set it as an Embedded Resource
  3. Set the DictFilePath in the spell check controls or RapidSpellChecker to the name of the Dict File (in the screen-shot that would be 'DICT-EN-UK-UKEnglish.2.dict')

Notes:

.NET 1 users must use uncompressed .dict files - which do not have ".2" in their file-name.

The spell checker will search for any resource in any loaded assembly containing the string in the DictFilePath property, therefore it's not necessary to specify the namespace or folder in which the resource is stored.

To reload the default dictionary use the name 'DICT-EN-US-USEnglish.2.default.dict' (.NET1 users should use 'DICT-EN-US-USEnglish.default.dict').
As An External File

With this style of usage you deploy the Dict File with your application as a separate file. You are in total control of how and where the Dict File is deployed, and must set the DictFilePath property of the controls to point to that location, ideally this should be done before the Check method is called (with RapidSpellDialog), to prevent redundant dictionary loading.

The DictFilePath property can be set as a relative path (relative to the EXE) or an absolute file path.

Dictionary Customization

It is possible to customize the dictionaries and create new ones using the convenient Dict Manager tool included in RapidSpell Desktop, please load the tool and consult the help system provided in it for more details.

The Dict Manager tool included in RapidSpell Desktop

User (Custom) Dictionaries / Add Button

To offer an "Add" function to the user, set the UserDictionaryFile property in either spell checking control to the file path where the dictionary should be stored (eg. "user-dictionary.txt"). If the file path specified is valid, the Add option will be enabled. If the file does not exist (but the path is valid) then the file will be created. The user dictionary is a simple UTF-8 text file with words listed one per line (it is not a .dict file and isn't created by 'Dict Manager'). The user dictionary is suited best to relatively short lists added to by the user. If a large list (order of thousands) of custom words needs to be added, it is suggested that they are added to the main dictionary using Dict Manager.

The Options form (via the 'Options...' button in the dialog spell check) allows the user to edit the user dictionary and also add/remove additional user dictionary files (except with TX Text Control). To prevent this, set ShowOptionForMultipleUserDictionaries=false in RapidSpellDialog or OptionsPresenter.

A Note About Main Dictionary Size

Understandably, many developers look to dictionary size as a metric for how good a spell checker is. However, the relationship is not that simple. There are many many words that can be grouped as part of the English language, especially when consideration is made for the history of English, how it has changed and been influenced by other languages (eg. French). If a spell checker dictionary is very large (ie hundreds of thousands of words) then it will include archaic and unusual spellings, scientific terms etc. which may be problematic during spell checking; a common misspelling may be accepted because it matches an unusual spelling or word. For example, consider "wonned", it is accepted by Merrium Webster as an archaic spelling for the past tense of "win". Clearly "wonned" is generally not acceptable in modern English, and it should be corrected as "won" - but a very large dictionary would accept it.


Dict Manager: Introduction

Dict Manager

Windows GUI

Dict Manager is a free tool provided by Keyoti for the manipulation of RapidSpell Dict (dictionary) files.

This tool can be used to create and modify Dict files, making it easy for developers to create new or custom word lists.

Automation

If you would like to use Dict Manager's simple API to programatically modify Dict files then please reference the Dict Manager EXE from your project (EXE's can be referenced as well as DLL's, when you browse for the assembly, just change the file type to *.exe in the open dialog).

The DictManagerModel class is used to manage dict files programmatically. Usage is fairly simple.

  • CreateDict
  • LoadDict
  • AddWord
  • MergeDictFile
  • MergeTextFile
  • RemoveWord
  • LookUp
  • SaveDict
  • Creates a new dict file
  • Loads an existing dict file
  • Adds a word to current open dict file
  • Merges an existing dict file with the open dict file
  • Merges an existing text file with the open dict file
  • Removes a word from the dict file
  • Checks if a word is in the dict file
  • Saves the currently open dict file

Typical usages should be in the following order;

  • create or load
  • modifying operations
  • save

Need help? Please email support@keyoti.com


Dict Manager: General Usage

General Usage

To customize a Dict file click on the "Open" button, this will show a file dialog with a *.dict filter. Choose the Dict file to customize and click OK. This loads the Dict file and the main text box shows the details of the dictionary.

If you attempt to open a file from a location that Dict Manager does not have permission to write to, you'll receive a 'read only' warning - please restart Dict Manager with Admin privilege.

New Dict files can be created using File->New.

Words can be added or removed one at a time to a Dict file through the lower text field. Words can also be added by merging *.txt or *.dict files, to do this drag and drop the file with the word list on to the main text box.

Saving Dict files requires some processing which may take a few minutes, depending on it's size and disorder.


Dict Manager: Dict File

Dict Files

Dict files are *.dict files that contain the main dictionary used by RapidSpell (Web & Desktop editions). They are in a proprietary format that optimizes the speed of RapidSpell. RapidSpell allows developers to switch between Dict files at run time.

Files with ".2.dict" in their names were originally compressed and Dict Manager will recompress when saving.


Dict Manager: Adding/Removing Words

Adding/Removing Words

The lower text field allows words to be added/removed, words should not contain spaces.

To add/remove a word, enter the word in the text field and click "Add" or "Remove". An error will be reported if an attempt to remove a word that is not in the dictionary is made.

The "Look Up" button can be used to report if a word is in the dictionary.

Any duplication of words occuring from adding will be removed when the Dict is saved.


Dict Manager: Merging Dict Files

Merging Dict Files

Dict files can be merged with other Dict files or with simple text files. To merge a text file or Dict file, drag it on to the main text field, this will take all words from the file dropped and add them to the open Dict file. "Tools->Add Words From File" opens a file dialog, and has the same effect as dragging and dropping.

Simple text files can be of Plain Text, UTF-8 or Unicode encoding and must contain one word per line, eg;

word1
word2
....

Any duplication of words occuring from merging will be removed when the Dict is saved.


RapidSpell Desktop .NET Documentation: User Options

User Options

The options form (in RapidSpellDialog or invoked programmatically) allows the user to store their own spell check preferences and also edit their user dictionary.

By default, user options are enabled and stored under .NET's IsolatedStorage. It's important to remember that user options (if enabled) will override the properties set in the spell checker controls (eg. RapidSpellAsYouType.CheckAsYouType = true will have no effect if the user has disabled check as you type).

Ensure that any of the settings specified below are made in both RapidSpellDialog and RapidSpellAsYouType as one will override the other if used with RapidSpellAYTDialogCoupler.

Disabling User Options

Set OptionsEnabled in the RapidSpellDialog and/or RapidSpellAsYouType control.

Programmatically Setting User Options

Call SetUserOptions on the options object and pass the values that should be used. Then call Save to write the changes. In this example we use the existing values (so no changes are made).
Dim o As Options.UserOptions = rapidSpellDialog1.Options
rapidSpellDialog1.Options.SetUserOptions(o.CheckAsYouType, o.IncludeUserDictionaryInSuggestions, _
    o.IgnoreWordsWithDigits, o.IgnoreURLsAndEmailAddresses, o.IgnoreCapitalizedWords, _
    o.AllowMixedCase, o.AllowAnyCase, o.FindSuggestions, False)
rapidSpellDialog1.Options.Save()
Eg. To change the "Check as you type" option, replace o.CheckAsYouType with either true or false.

Changing Storage Location

Set OptionsStorageLocation to either IsolatedStorage (default), FileSystem or Stream see below.

Maintaining Separate Options Profiles

Set OptionsFileName in the RapidSpellDialog and/or RapidSpellAsYouType control to a unique name for each separate set of options to use.

Resetting / Deleting Options

Call UserOptions.Delete() to empty the file and allow the default options to be recreated. Eg. RapidSpellDialog.Options.Delete()

Launching Options Editor Programmatically

  1. Create an instance of Keyoti.RapidSpell.Options.OptionsPresenter
  2. Call it's Show method with the UserOptions instance (from either the RapidSpellAsYouType or RapidSpellDialog control)
  3. If Show returns true, then save the UserOptions object
  4. If the UserOptions instance hasn't been loaded (eg before the Check method is called in RapidSpellDialog), then set the UserDictionary property in UserOptions to a new instance of the UserDictionary class, otherwise the edit user dictionary button will not be shown.
  5. To prevent the user from adding multiple user dictionaries, set optionsPresenter.ShowOptionForMultipleUserDictionaries = false
  6. To prevent the user from editing user dictionaries at all, set optionsPresenter.ShowUserDictionaryButton = false

Eg.
            OptionsPresenter optionsPresenter = rapidSpellAsYouType1.OptionsPresenter;
            if (optionsPresenter.Show(this, rapidSpellAsYouType1.Options))
            {
                rapidSpellAsYouType1.Options.Save();
            }

How To Use A Custom Stream For Storage

Events are available which can be used to determine when to prepare a stream to read/write to.

For example, to use a custom stream to write to an XML file;

.........
       Public Sub New()
        MyBase.New
        InitializeComponent
        rapidSpellAsYouType1.OptionsStorageLocation = Keyoti.RapidSpell.Options.UserOptions.StorageType.Stream
        rapidSpellDialog1.OptionsStorageLocation = Keyoti.RapidSpell.Options.UserOptions.StorageType.Stream
        Dim options As Keyoti.RapidSpell.Options.UserOptions = New Keyoti.RapidSpell.Options.UserOptions
        options.StorageLocation = Keyoti.RapidSpell.Options.UserOptions.StorageType.Stream
        AddHandler options.NeedCustomStreamForSaving, AddressOf Me.NeedSaveStream
        AddHandler options.NeedCustomStreamForLoading, AddressOf Me.NeedLoadStream
        AddHandler options.OptionsSaved, AddressOf Me.options_OptionsSaved
        options.Load
        rapidSpellAsYouType1.Options = options
        rapidSpellDialog1.Options = options
        rapidSpellAsYouType1.TextBoxBase = Me.aytTextBox1
    End Sub

    Private Sub options_OptionsSaved(ByVal sender As Object, ByVal e As Keyoti.RapidSpell.Event.OptionsSavedEventArgs)
        'update the DB?
    End Sub

    Private Sub NeedSaveStream(ByVal sender As Object, ByVal e As Keyoti.RapidSpell.Options.NeedStreamEventArgs)
        e.RequiredStream = New System.IO.FileStream("c:\useropt.xml", System.IO.FileMode.Truncate, System.IO.FileAccess.Write)
    End Sub

    Private Sub NeedLoadStream(ByVal sender As Object, ByVal e As Keyoti.RapidSpell.Options.NeedStreamEventArgs)
        e.RequiredStream = New System.IO.FileStream("c:\useropt.xml", System.IO.FileMode.OpenOrCreate)
    End Sub
.........
NOTE:

1. RapidSpellAsYouType.TextComponent or .TextBoxBase must be set AFTER options.Load. This is because otherwise the options are loaded from the default location as soon as the textbox is set.

2. You can use the OptionsSaved event to write the stream's contents to a DB instead.


RapidSpell Desktop .NET Documentation: RapidSpellGUIPresenter

RapidSpellGUIPresenter

The RapidSpellGUIPresenter has a 100% customizable UI (IDialogView), provides user dictionary functionality, is multi-threaded and is extremely simple to use. The interface has a familiar layout and functionality.

RapidSpellGUIPresenter will interactively check any TextBoxBase derived class, this includes TextBox, RichTextBox and their sub-classes. When invoked in an application the component will query the user on each misspelled word allowing the following functions;

Ignore
Ignore All occurrences of misspelt word
Add to user dictionary if provided
Change misspelt word to suggestion or user amended text
Change All occurrences of misspelt word
Undo last action
Options editor with user dictionary edit
Cancel

The GUI checks selections (querying to continue when finished), wraps from current caret position back to current caret position and handles the user editing the text in your application while checking is in progress.

Please see later sections for details on customizing the UI and the API documentation for member information.


RapidSpell Desktop .NET Documentation: RapidSpellChecker

RapidSpellChecker

Provides a model (business/logic) level spell checker API which can be used in a client-server environment and any applications where a client GUI does not exist. User dictionaries can optionally be used, allowing words to be added. This component can be used in 2 different ways, in an iterative fashion or on a query by query basis. Please see the API docs for code level details.

Using RapidSpellChecker in an iterative manner provides complete textual correction of strings similar to a GUI based spell checker. A string is loaded into RapidSpellChecker and then successive calls to the NextBadWord() method move through the string allowing FindSuggestions() and ChangeBadWord(replacement) to be called to find spelling suggestions and optionally correct the misspelt words in the text, finally GetAmendedText() returns the corrected text.

Alternatively RapidSpellChecker may be used in a simple query by query basis, calls to LookUp(word) and FindSuggestions(word) methods allow bare bones spell checking functionality.

Key API Points

Methods
RapidSpellChecker() | - argumentless constructor
Check(text [, startPosition]) | - begins checking text
FindSuggestions(word) | - finds suggestions for word
LookUp(word) | - checks if word is in either main or user dictionaries
SetUserDictionary(file) | - allows you to define which file will be used as a user dictionary
IgnoreAll(word) | - ignores all future occurrences of word
AddWord(word) | - adds word to the user dictionary if it exists
NextBadWord() | - finds the next misspelt word in the text
ChangeBadWord(newWord) | - changes the misspelt word last identified by NextBadWord()
GetAmendedText() | - returns the corrected text
FindCompoundWords(text, list) | - adds compound words in text string
FindAnagrams(word, list) | - adds anagrams of word to list
Properties
DictFilePath | - the path to a .dict dictionary file.
LanguageParser | - the language parser to be used (LanguageType.ENGLISH, LanguageType.FRENCH....)
IgnoreXML | - whether to ignore XML tags
ModalMode | - whether to operate modally
SuggestSplitWords | - whether to suggest split words, eg. "myhouse" -> "my house"
CheckCompoundWords/font> | - whether to check unknown words for compound forms
LookIntoHyphenatedText | - whether to treat hyphens as word separators

Query by Query Usage Sequence Diagram

Iterative Usage Sequence Diagram

See Examples section for details.


RapidSpell Desktop .NET Documentation: Simple GUI Text Editor With Dialog Checking

Note to VB.NET Users

To conserve space we have shown most code examples in only C#, however VB.NET examples are available in the example source folders.

Simple GUI Text Editor With Dialog Checking

To use the GUI dialog spell checker control (RapidSpellDialog) as an integral part of your application simply instantiate it, set the text component you wish this GUI to spell check and call Check(), which will bring up this component in a new Form allowing the user to correct their document in the TextBoxBase derived class.

Example, note this code is highly simplistic for demonstration purposes.

Code Example

using System;
using System.Collections;
using System.Drawing;
using System.Windows.Forms;
using Keyoti.RapidSpell;

public class GUIExample : Form{
    RapidSpellDialog rs;
    TextBox tb = new TextBox();

    MainMenu mainMenu1;
    MenuItem menuItem1, menuItem2;

    public GUIExample() : base() {
        //set up the text box
        tb.Size = new Size(500,352);
        tb.Multiline = true;
        Controls.Add(tb);

        //config menu
        mainMenu1 = new MainMenu();
        menuItem1 = new MenuItem();
        menuItem2 = new MenuItem();
        mainMenu1.MenuItems.AddRange(new MenuItem[] { menuItem1 });
        menuItem1.Index = 0;
        menuItem1.MenuItems.AddRange(new MenuItem[] {menuItem2 } );
        menuItem1.Text = "Tools";
        menuItem2.Index = 0;
        menuItem2.Text = "Check Spelling";
        //listen to clicks
        menuItem2.Click += new EventHandler(StartRS);
        Menu = mainMenu1;

        //set form size
        Size = new Size(510,400);

        //configure spell checker
        rs = new RapidSpellDialog();
        rs.TextBoxBaseToCheck = tb;
    }

    //run spell check when the menu is clicked
    private void StartRS(object sender, EventArgs args){
        rs.Check();
    }

    public static void Main(String[] args) {
        Application.Run( new GUIExample() );
    }
}


RapidSpell Desktop .NET Documentation: Custom RapidSpellDialog User Interface

Custom RapidSpellDialog User Interface

Layout/Style

It is easy to customize the UI used by the RapidSpellDialog control. The example projects include full source code for the default UIs, which can be modified by hand or in the Visual Studio designer. It's also possible to implement the lightweight IDialogView interface from scratch and use any class as a UI (eg. built on 3rd party forms).

Assuming IDialogView has been implemented already (see demos), the class is used by handling the CreateDialogView event in RapidSpellDialog, and setting an instance of the class (which implements IDialogView) in the event argument's NewView property.

C#

    private void rapidSpellDialog1_CreateDialogView(object sender, Keyoti.RapidSpell.Event.CreateDialogViewEventArgs e)
    {
         e.NewView = new CustomGUIView();
    }

VB.NET

    Sub rapidSpellDialog1_CreateDialogView(ByVal sender As System.Object, _
        ByVal e As Keyoti.RapidSpell.Event.CreateDialogViewEventArgs) Handles rapidSpellDialog1.CreateDialogView
        e.NewView = New CustomGUIView
    End Sub

The above assumes that CustomGUIView is a class implementing IDialogView.

Options And User Dictionary Editor

Similarly, the CreateDialogViewOptions, CreateDialogViewUserDictionarySelect and CreateDialogViewUserDictionaryEdit events allow substitution of the default UIs for option and user dictionary editing. Please see the demo projects for full source.

Behavior

It is easy to customize the UI behavior used by the RapidSpellDialog control. This is done by subclassing "RapidSpellGUIPresenter" which is the logic behind the RapidSpellDialog user interface. RapidSpellGUIPresenter has methods which react to user input and also controls the Form, which it holds in it's "DialogView" property (this is actually the instance returned via the "CreateDialogView" event, see above).

To use a subclass of RapidSpellGUIPresenter, handle the RapidSpellDialog.CreateUserInterfaceFormPresenter event.

C#

    private void rapidSpellDialog1_CreateUserInterfaceFormPresenter(object sender, Keyoti.RapidSpell.Event.CreateUserInterfaceFormPresenterEventArgs e)
    {
       e.NewPresenter = new CRapidSpellGUIPresenter();
    }

VB.NET

    Sub rapidSpellDialog1_CreateUserInterfaceFormPresenter(ByVal sender As System.Object, _
        ByVal e As Keyoti.RapidSpell.Event.CreateUserInterfaceFormPresenterEventArgs) Handles rapidSpellDialog1.CreateUserInterfaceFormPresenter
        e.NewPresenter = new CRapidSpellGUIPresenter()
    End Sub

This sets the instance of the RapidSpellGUIPresenter subclass "CRapidSpellGUIPresenter" in the event property.

Consult the API docs (under namespaces) for details of the various methods which can be overridden. As an example, consider the case where the "change" buttons should be disabled when there are no suggestions. The CRapidSpellGUIPresenter class would look like this.

C#

    public class CRapidSpellGUIPresenter : RapidSpellGUIPresenter
    {

        protected override void Resume()
        {
            base.Resume();
            System.Collections.ArrayList suggs;
            suggs = CheckerEngine.FindSuggestions();

            DialogView.ChangeAllButtonEnabled = suggs.Count > 0;
            DialogView.ChangeButtonEnabled = suggs.Count > 0;

        }
    }

The Resume method is called every time a word is shown as an error to the user, and the opportunity is taken to look at how many suggestions there are (using the CheckerEngine property). When there are no suggestions the change buttons are disabled (note how they are accessed via the DialogView property, which returns the IDialogView instance in use).


RapidSpell Desktop .NET Documentation: Using RapidSpell With 3rd Party Controls

Using RapidSpell With 3rd Party Controls

RapidSpell Desktop supports 3rd party text box controls, such as "TX Text Control" by The Imaging Source, EditBox by Janus and DevExpress grids and editors. "Adapter" controls are included for some 3rd party vendors, and KB articles are also provided. To facilitate functionality with other 3rd party components an interface is defined, ISpellCheckableTextComponent which requires properties to exist or be mapped to, these properties relate to the text in the text control and the user's selection, please see the API docs for more information.

TX Text Control

To use RapidSpell with TX Text Control it is necessary to reference the Keyoti.RapidSpell.NET2.TXSupportv1X.DLL instead of Keyoti.RapidSpell.NET2 .DLL.

For TX v15.1 and down - please see an in depth article on FULL integration with TX we have prepared:

http://keyoti.com/kb/Default.aspx?ToDo=view&questId=97&catId=44

For TX v16 and up - please see this page

Also, the included Visual Studio demos include TX specific examples.

Other Controls

To use RapidSpell Desktop with an indirectly supported 3rd party control should be a simple process, it is only necessary to extend (inherit from) the 3rd party control class and implement the ISpellCheckableTextComponent interface.

For example, if the 3rd party control's class (the class that actually sits on the Windows form) is named "3rdPartyControl", then a new class could be written called "SpellCheckableControl" which would implement the ISpellCheckableTextComponent interface, see diagram above. In code this could be as simple as

Code Example C# 3rd Party Control

using Keyoti.RapidSpell;
public class SpellCheckableControl : 3rdPartyControl,ISpellCheckableTextComponent
{
        public RSTextControl() : base() {}

        .........
        .........
        any required method implementations
        .........
}

Code Example VB.NET 3rd Party Control

Imports Keyoti.RapidSpell
Public Class SpellCheckableControl
        Inherits 3rdPartyControl
        Implements ISpellCheckableTextComponent

    Public Sub New()
        MyBase.New()
    End Sub

            .........
            .........
            any required method implementations
            .........

End Class

In the above example the actual method implementations were left out because they are specific to the 3rd party control being used, in fact if the 3rd party control extends TextBoxBase or shares the same interface as TextBoxBase there is no need to implement any methods.


RapidSpell Desktop .NET Documentation: As-You-Type Checking (RapidSpellAsYouType)

As-You-Type Checking (RapidSpellAsYouType)

To use the as-you-type checker, RapidSpellAsYouType with one or many text boxes should be fairly simple. RapidSpellAsYouType can work with any TextBoxBase derived text box (e.g. standard .NET textboxes) and any class which implements IAYTTextBox.

Example Code (AsYouTypeExample.cs)

Minimal requirements for as-you-type checking with RichTextBox.

using System;
using System.Drawing;
using System.Windows.Forms;
using Keyoti.RapidSpell;

public class AsYouTypeExample : Form{

    RapidSpellAsYouType rs =new RapidSpellAsYouType();
    RichTextBox tb = new RichTextBox();

    public AsYouTypeExample() : base() {
        Size = new Size(508,380);

        tb.Size = new Size(500,352);
        tb.Multiline = true;
        tb.WordWrap = true;
        Controls.Add(tb);

        rs.AddTextBoxBase(tb);
    }

    public static void Main(String[] args) {
        Application.Run( new AsYouTypeExample() );
    }
}

Use the AddTextBoxBase (or AddTextComponent) method to add additional textboxes to check.

Spell checking a ComboBox

The AYTComboBox control can be hooked up to RapidSpellAsYouType to enable spell checking in a ComboBox. AYTComboBox is a subclass of the .NET class ComboBox, and can be used as a direct replacement (it is safe to manually change the designer file to use AYTComboBox).

this.comboBox1 = new AYTComboBox();
...
rapidSpellAsYouType1.AddTextComponent(comboBox1);

Using RapidSpellAsYouType With TX Text Control

To use RapidSpell with TX Text Control it is necessary to reference the Keyoti.RapidSpell.NET2.TXSupportv1X.DLL instead of Keyoti.RapidSpell.NET2 .DLL.

For TX v15.1 and down - please see an in depth article on FULL integration with TX we have prepared:

http://keyoti.com/kb/Default.aspx?ToDo=view&questId=97&catId=44

For TX v16 and up - please see this page

Also, the included Visual Studio demos include TX specific examples.

DevExpress XtraGrid & MemoExEdit

DevExpress support is provided via a "Glue" class RapidSpell_DevExpressAdapter_Glue which is provided in source form in the included Visual Studio demo projects. Use with DevExpress is DLL version agnostic, and no extra support DLL is required. Please see the following KB articles

http://keyoti.com/kb/Default.aspx?ToDo=view&questId=139&catId=44

http://keyoti.com/kb/Default.aspx?ToDo=view&questId=140&catId=44

As-You-Type With Other 3rd Party Controls

RapidSpellAsYouType currently also works with: Infragistics UltraGrid, Janus GridEX and Janus EditBox.

If a 3rd party control conforms, or can be made to conform to the requirements of the IAYTTextBox interface, then it should be as-you-type checkable. This is a simple benefit of object orientation, however in practice this interface may be hard to implement and some tweaking may be necessary for proper results.


RapidSpell Desktop .NET Documentation: As You Type ContextMenuStrip Customization

As You Type ContextMenuStrip Customization

To use the spell checker's suggestion items in an externally provided ContextMenu(Strip)

  1. Set RapidSpellAsYouType.ShowSuggestionsContextMenu = false
  2. Set RapidSpellAsYouType.ShowCutCopyPasteOnTextBoxBase = false (if working with a .NET TextBox)
  3. Add a ContextMenuStrip to the form and assign it to the text editor and handle it's Opening event
  4. In the event handler, use GetSuggestionsToolStripItems to obtain spelling suggestions and construct the menu.
            private void contextMenuStrip1_Opening(object sender, CancelEventArgs e)
        {
            //clear any old suggestions, leaving the first two menu items which we don't want to clear
            if (contextMenuStrip1.Items.Count > 2)
                while (contextMenuStrip1.Items.Count > 2)
                    contextMenuStrip1.Items.RemoveAt(2);

            //grab the suggestions from the spell checker
            ToolStripItem[] suggestions = rapidSpellAsYouType1.GetSuggestionsToolStripItems();

            //if there are suggestions (ie if the click was on an error), show them
            if (suggestions != null)
            {
                contextMenuStrip1.Items.Add(new ToolStripSeparator());
                contextMenuStrip1.Items.AddRange(suggestions);
            }
        }

To use a ContextMenu(Strip) when user clicks away from an error

  1. Set RapidSpellAsYouType.ShowSuggestionsContextMenu = true
  2. Use the AYTTextBox or AYTRichTextBox control for the textbox, instead of the standard .NET textboxes
  3. Add a ContextMenuStrip to the form, if not already present
  4. Set ContextMenuStripDefault in AYTTextBox or AYTRichTextBox to the ContextMenuStrip to be shown when the user right clicks away from an error


RapidSpell Desktop .NET Documentation: Spell Checking in Grids

Spell Checking in Grids

RapidSpellDialog

DataGridView

The DataGridView example in the demo projects give a code example.

1. Add the RapidSpellDialog control to the form

2. Set IgnoreIncorrectSentenceCapitalization = true

3. Add this method to the form with the DataGridView

    void RefreshSpell()
        {
            rsd.ClearTextComponents();

            //create text components for all cells of interest
            foreach (DataGridViewRow r in dataGridView1.Rows)
            {
                rsd.AddTextComponent(new SpellCheckableDataGridViewCell(r.Cells[0]));
                rsd.AddTextComponent(new SpellCheckableDataGridViewCell(r.Cells[1]));
            }
        }

The loop should be changed to call AddTextComponent with every cell that should be spell checked in the row.

4. Launch the spell check by calling

    RefreshSpell();
    rsd.Check();

RapidSpellAsYouType

Supports various grid controls.

DataGridView

The DataGridView example in the demo projects give a code example.

1. Add Keyoti.RapidSpell.Grid.DataGridView_AYT_Manager control to the form

2. Set it's DataGridView property to the instance of the DataGridView to work with.

3. Set it's RapidSpellAsYouType property to the instance of RapidSpellAsYouType to work with

4. In the designer, right click on the grid and choose Edit Columns.

5. Select columns to be spell checked and set each column's ColumnType to "AYTDataGridViewTextBoxColumn" - if it is not available in the list, ensure that Keyoti.RapidSpell.NETX.DLL is referenced and the project has been built.

DataGrid

The DataGrid example in the demo projects give a code example - in particular refer to the method AddCustomDataTableStyle(). This method performs the following;

1. Create an instance of DataGridTableStyle.

2. Create a DataGridAYTTextBoxColumn, and give it a RapidSpellAsYouType instance.

3. Add the DataGridAYTTextBoxColumn to the DataGridTableStyle with the MappingName set to ensure the column editor will be used to edit the desired column.

4. Add the DataGridTableStyle to the DataGrid's TableStyles property.

DevExpress XtraGrid

Please consult the VS demos and http://keyoti.com/kb/Default.aspx?ToDo=view&questId=139 for an up to date KB article.

Janus GridEX

Please consult the VS demos and http://keyoti.com/kb/Default.aspx?ToDo=view&questId=58 for an up to date KB article.


RapidSpell Desktop .NET Documentation: Autocorrect Customization And International Support

Autocorrect Customization And International Support

RapidSpellAsYouType includes an autocorrector (which can be disabled by setting RapidSpellAsYouType.AutoCorrectEnabled=false) for English.

The RapidSpellAsYouType.AutoCorrectionMap is a Hashtable linking user entries to substitutions. This can be modified as desired when the form is created.

Eg.

rapidSpellAsYouType1.AutoCorrectionMap["vb"] = "Visual Basic";
will cause the text "vb" to be changed to "Visual Basic" when the user enters it.

In this way, auto correction lists for any language can be used.


RapidSpell Desktop .NET Documentation: RapidSpellDialog + RapidSpellAsYouType

RapidSpellDialog + RapidSpellAsYouType

To provide a coherent user experience when both RapidSpellDialog and RapidSpellAsYouType check the same text box, it is necessary to use the RapidSpellAYTDialogCoupler component. This component (which can be added to the IDE tool box) is a simple way to connect the 2 types of spell checkers, ensuring that modifications made in one, are reflected in the other. For example, if the user clicks "Ignore All" in the as-you-type spell checker, then that word should also be ignored in the dialog checker.

Example code

//c#
rapidSpellAYTDialogCoupler1 = new RapidSpellAYTDialogCoupler();
rapidSpellAYTDialogCoupler1.RapidSpellDialog = rapidSpellDialog1;
rapidSpellAYTDialogCoupler1.RapidSpellAsYouType = rapidSpellAsYouType1;

'VB.NET
rapidSpellAYTDialogCoupler1 = New RapidSpellAYTDialogCoupler()
rapidSpellAYTDialogCoupler1.RapidSpellDialog = rapidSpellDialog1
rapidSpellAYTDialogCoupler1.RapidSpellAsYouType = rapidSpellAsYouType1


WPF Support

Please see the RapidSpell WPF product for current WPF support.


RapidSpell Desktop .NET Documentation: ClickOnce & CAS

ClickOnce & CAS

RapidSpellDialog may be used in partial trust applications (Internet, and Intranet zone for example) provided it is licensed in the manner described below. RapidSpellAsYouType cannot be used in partial trust applications because it requires full trust for screen drawing.

Required Code Changes

The only requirement for using RapidSpellDialog under partial trust is that the control is licensed by calling these lines of code BEFORE the RapidSpellDialog control is instantiated, eg. the first line of the Form constructor.

//C#
Keyoti.RapidSpell.ComClientInteropSupport c = new
Keyoti.RapidSpell.ComClientInteropSupport();
c.Key = "<...place your license key here...>";

'VB
Dim c As New Keyoti.RapidSpell.ComClientInteropSupport()
c.Key = "<...place your license key here...>"


RapidSpell Desktop .NET Documentation: Non-GUI Spell Checker

Non-GUI Spell Checker

The RapidSpellChecker component is of particular use in non-GUI scenarios. Below is a very simple excerpt of how this component can be used.

Code Example

.........
    RapidSpellChecker c = new RapidSpellChecker();
    BadWord badWord;
    ArrayList suggestions;

    //check some text.
    c.Check("This is sume text.");

    //iterate through all bad words in the text.
    while((badWord = c.NextBadWord())!=null){

        Console.WriteLine(badWord.GetWord() +
            "- is not spelt correctly. Suggestions:");

        try{
            //get suggestions for the current bad word.
            suggestions = c.FindSuggestions();

            //display all suggestions.
            for(int i=0; i<suggestions.Count; i++){
                Console.WriteLine(suggestions[i]);
            }

            //change the bad word in the text with "replacement".
            c.ChangeBadWord("replacement");
        } catch (NoCurrentBadWordException e){
            Console.WriteLine(e);
        }
    }
    Console.WriteLine(c.GetAmendedText());
.........


RapidSpell Desktop .NET Documentation: Ignore Pattern Customization

Ignore Pattern Customization & Email/URL Addresses

The IgnoreURLsAndEmailAddresses property/option can be used to make the spell checker ignore these types of strings. A built in regex does this matching, however for performance reasons it does not match every known top level domain (eg. .no), and also will not match custom domains.

The AddIgnorePattern method allows customization of the patterns that are ignored, this can be applied to most strings, not just domains.

Eg. to also ignore .no and .ro domains, call this

C#
string pattern = @"[a-zA-Z0-9]+(?:[a-zA-Z0-9\-\.]+)?\.(?:no|ro){1,2}";

(rapidSpellDialog.CheckerEngine as RapidSpellChecker).AddIgnorePattern(pattern);
rapidSpellAsYouType.RapidSpellChecker.AddIgnorePattern(pattern);
VB.NET
Dim pattern As String = "[a-zA-Z0-9]+(?:[a-zA-Z0-9\-\.]+)?\.(?:no|ro){1,2}"
CType(rapidSpellDialog.CheckerEngine,RapidSpellChecker).AddIgnorePattern(pattern)
rapidSpellAsYouType.RapidSpellChecker.AddIgnorePattern(pattern)


RapidSpell Desktop .NET Documentation: Suggestions Algorithm

Suggestions Algorithm

It is possible to choose (programmatically) the algorithm used to find suggestions for spelling errors, there are two algorithms on offer, 'hashing' (default) and 'phonetic'. Each algorithm has it's own advantages and disadvantages;

Hashing (default): Very fast, roughly 40 times faster than the phonetic algorithm, works best on typographic errors and common spelling mistakes. Similar to most spell checker suggestions.

Phonetic (Sounds like, English only): Slower, works well with genuine attempts to spell correctly, works poorly with typographic errors. Can appear to produce wild results, although results do sound like the word in question. Does not work with non English languages. Unusual.

It is recommended that you choose the suggestions algorithm in line with your target audience. The phonetic algorithm, although appearing worse overall, is more suited for people who have not spoken English for very long, e.g. non native English speakers and children.


RapidSpell Desktop .NET Documentation: Consideration Range

Consideration Range

The hashing suggestion algorithm is very fast because it accurately cuts down the list of words to look at as possible suggestions. The factory default consideration range is 80, which provides optimal speed with a loss of only a fraction of possible suggestions. It is possible to set the consideration range through the RapidSpellDialog, RapidSpellAsYouType, RapidSpellGUI and RapidSpellChecker classes. The relationship between speed, number of suggestions and consideration range is shown below.


RapidSpell Desktop .NET Documentation: Conclusion

Conclusion

Thank you for using the RapidSpell component, we hope that you experience much success with it. Keyoti is committed to improving all of it's products and truly values customer feedback of any kind. If you would like to contact us about any of our products please do so through our web site.

http://www.keyoti.com/contact.html

We thrive on suggestions for components and feature requests, if you have a component wish please don't hesitate to get in touch, it may be the next thing we develop!


Knowledge Base

Open in a new window


Support Forum

Open in a new window


API

Keyoti RapidSpell Desktop .NET API Docs
API
API
Keyoti RapidSpell Desktop .NET
RapidSpell Desktop .NET Control
Namespaces
Namespace | Description
Keyoti.RapidSpell | The core namespace for RapidSpell. Main namespace
Keyoti.RapidSpell.Compression |
Keyoti.RapidSpell.DialogViews | Dialog's view class namespace
Keyoti.RapidSpell.Event | The namespace for events. Events and delegates
Keyoti.RapidSpell.FrameWorkSpecific | The namespace for RapidSpell Desktop .NET specific classes. Misc
Keyoti.RapidSpell.Grid | The namespace for grid classes. Classes for grid support
Keyoti.RapidSpell.Options | User options related classes
Keyoti.RapidSpell.ThirdParty.DevExpress6 | 3rd party support

Send comments on this topic to support@keyoti.com

2005-2017 Keyoti Inc.


Keyoti.RapidSpell Namespace

Keyoti RapidSpell Desktop .NET API Docs
Keyoti.RapidSpell Namespace
API ► Keyoti.RapidSpell
Keyoti RapidSpell Desktop .NET
The core namespace for RapidSpell.

Main namespace

Types
All Types Classes Interfaces Enumerations Delegates
Icon | Type | Description
 | AYTComboBox | As-You-Type enabled TextBox.
 | AYTRichTextBox | As-You-Type enabled RichTextBox.
 | AYTTextBox | As-You-Type enabled TextBox.
 | BadWord | Represents a mis-spelt word in the text.
 | CheckerEngineAdapter | Abstract base implementation of ICheckerEngine, override chosen members for desired functionality.
 | ComClientInteropSupport | This class supports users who access RapidSpell controls from COM code.
 | ContextMenuInformation | Describes the context menu that should be shown to the user for a particular error.
 | CutCopyPasteContextMenuMaker | Create a Cut/Copy/Paste ContextMenu
 | CutCopyPasteContextMenuStripMaker | Creates a Cut/Copy/Paste ContextMenuStrip
 | DialogTexts | Contains all texts in RapidSpellDialog and user options.
 | DictionaryCache | Cache of loaded dictionaries.
 | IAYTTextBox | Interface requirements for an "as-you-type" text box, if an object implements this interface then it is compatible with the RapidSpellAYT control.
 | ICheckerEngine | Defines the interface required for a class to be used as a checker engine
 | ISpellCheckableTextComponent | Defines the interface required for a text component to be spell checkable using the RapidSpellDialog control (or RapidSpellGUI class)
 | ISpellCheckableTextComponent2 | Defines the interface required for a text component to be spell checkable using the RapidSpellDialog control (or RapidSpellGUI class)
 | IUserInterfaceFormPresenter | Interface requirements for a dialog based UI form.
 | KLicenseProvider | Summary description for KLicenseProvider.
 | LanguageType | Enumeration of language types.
 | UserDictionary..::..ListChangedEventArgs | Event args for ListChanged event
 | UserDictionary..::..ListChangedEventHandler | Event handler
 | UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation | Types of operation
 | MultiFileUserDictionary | Represents multiple file based user dictionaries.
 | NeedRapidSpellAsYouTypeAgentEventArgs | Event args for NeedRapidSpellAsYouTypeAgent event. Specify a NewAgent to override default behaviour.
 | NeedRapidSpellAsYouTypeAgentEventHandler | Event delegate.
 | NoCurrentBadWordException | Thrown if NextBadWord has not been run first and found a mis-spelled word.
 | NoTextComponentException | Thrown if a valid text component hasn't been set to be checked (by the GUI for example).
 | UndoableOperation..::..Operation | Types of operation
 | OperationScope | The scope of an operation.
 | OptionsSavedEventArgs | Args for the options saved event.
 | OptionsSavedEventHandler | Handler
 | RapidSpellAsYouType | RapidSpell Desktop As-You-Type Control, spell checks text boxes as the user types.
 | RapidSpellAsYouTypeAgent | Agent class that handles as-you-type for one text box.
 | RapidSpellAYTDialogCoupler | RapidSpell Desktop AYT-Dialog Coupler Control, this lightweight convenience control is used to couple RapidSpellAsYouType and RapidSpellDialog.
 | RapidSpellChecker | Spell checker engine, checks a text string for spelling errors and makes suggested corrections.
 | RapidSpellDialog | RapidSpell Desktop Dialog Control, this convenience control provides design time support for RapidSpellGUI and multiple text box support.
 | RapidSpellGUIPresenter | Controls the UI logic used for RapidSpellDialog forms.
 | RegisterForm | Internally used for registering license keys.
 | RichTextBoxIAYTAdapter | Internal wrapper for RichTextBox
 | TextBoxUtilityAdapter..::..RightClickEventHandler | Handles right clicks.
 | RapidSpellDialog..::..SpellCheckEventHandler | Spell check event handler delegate.
 | RapidSpellGUIPresenter..::..SpellCheckEventHandler | Spell check event handler delegate.
 | SpellContextMenuRequestEventHandler | Handler delegate
 | SpellingDictionary | Helper
 | RapidSpellChecker..::..State | State of the spell checker
 | UserDictionary..::..StorageLocation | Location options for storage
 | Suggestion | Represents a suggestion.
 | SuggestionsMethodType | Suggestions algorithm identifiers.
 | TextBoxBaseIAYTAdapter | Internal wrapper for TextBoxBase
 | RapidSpellDialog..::..TextBoxSpellCheckEventHandler | Handler delegate
 | TextBoxUtilityAdapter | Handles painting on AYTTextBox and AYTRichTextbox
 | TextChangeHint | Hints the change scanner as to where the change could be, if any, on user input.
 | Underline | Represents an underline
 | UnderlineEventArgs | Event arguments for underline events
 | UnderlineEventHandler | Underline event handler
 | UnderlineStyle | Mis-spelling underline style for RapidSpellAYT control.
 | UndoableOperation | An operation which can be undone
 | UndoableStateEventArgs | Args for the events fired when words are ignored.
 | UndoEventArgs | Undo event args
 | UndoEventHandler | Event handler delegate
 | UndoManager | Manages the undoable operation stack.
 | UserDictionary | Represents the UserDictionary
 | WordAddedEventArgs | Args for the events fired when words are added to the user dictionary.
 | WordAddedEventHandler | Handler delegate
 | WordChangedEventArgs | Args for the events fired when words are changed.
 | WordChangedEventHandler | Handler delegate
 | WordIgnoredEventArgs | Args for the events fired when words are ignored.
 | WordIgnoredEventHandler | Handler delegate
 | WordOccurrence | Represents a word in the text.
 | WordRemovedEventArgs | Args for the events fired when words are removed from the user dictionary.
 | WordRemovedEventHandler | Handler delegate


AYTComboBox Class

Keyoti RapidSpell Desktop .NET API Docs
AYTComboBox Class
API ► Keyoti.RapidSpell ► AYTComboBox
Keyoti RapidSpell Desktop .NET
As-You-Type enabled TextBox.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class AYTComboBox : ComboBox,
    IAYTTextBox
public class AYTComboBox : ComboBox,
    IAYTTextBox
Public Class AYTComboBox
    Inherits ComboBox
    Implements IAYTTextBox
Public Class AYTComboBox
    Inherits ComboBox
    Implements IAYTTextBox
public ref class AYTComboBox : public ComboBox,
    IAYTTextBox
public ref class AYTComboBox : public ComboBox,
    IAYTTextBox
type AYTComboBox =
    class
        inherit ComboBox
        interface IAYTTextBox
    end
type AYTComboBox =
    class
        inherit ComboBox
        interface IAYTTextBox
    end
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AYTComboBox()()()() | Creates a new TextBox with "as-you-type" facility.
 | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
 | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
 | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
 | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
 | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
 | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
 | AddItemsCore(array<Object>[]()[][]) | Obsolete. Adds the specified items to the combo box. (Inherited from ComboBox.)
 | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
 | AllowSelection | Gets a value indicating whether the list enables selection of list items. (Inherited from ListControl.)
 | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
 | AutoCompleteCustomSource | Gets or sets a custom StringCollection to use when the AutoCompleteSource property is set to CustomSource. (Inherited from ComboBox.)
 | AutoCompleteMode | Gets or sets an option that controls how automatic completion works for the ComboBox. (Inherited from ComboBox.)
 | AutoCompleteSource | Gets or sets a value specifying the source of complete strings used for automatic completion. (Inherited from ComboBox.)
 | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
 | AutoSize | This property is not relevant for this class. (Inherited from Control.)
 | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
 | BackColor | (Inherited from ComboBox.)
 | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
 | BackgroundImage | This property is not relevant to this class. (Inherited from ComboBox.)
 | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from ComboBox.)
 | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from ComboBox.)
 | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from ComboBox.)
 | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
 | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
 | BeginUpdate()()()() | Maintains performance when items are added to the ComboBox one at a time. (Inherited from ComboBox.)
 | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
 | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
 | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
 | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
 | BringToFront()()()() | Brings the control to the front of the z-order. (Inherited from Control.)
 | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
 | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
 | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
 | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
 | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
 | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
 | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
 | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
 | Click | Occurs when the control is clicked. (Inherited from Control.)
 | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
 | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
 | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
 | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | Contains(Control) | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
 | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
 | ContextMenu | (Overrides Control.ContextMenu.)
 | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
 | ContextMenuDefault | The context menu that will be shown when the right click is not on a misspelled word.
 | ContextMenuStrip | The context menu that will be shown when the right click is not on a misspelled word. (Overrides Control.ContextMenuStrip.)
 | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
 | ContextMenuStripDefault | The context menu that will be shown when the right click is not on a misspelled word.
 | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
 | ControlBackgroundPaint | Event fired when Windows level background repaint occurs.
 | ControlPaint | Event fired when Windows level repaint occurs.
 | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
 | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
 | CreateAccessibilityInstance()()()() | (Inherited from ComboBox.)
 | CreateControl()()()() | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
 | CreateControlsInstance()()()() | Creates a new instance of the control collection for the control. (Inherited from Control.)
 | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
 | CreateGraphics()()()() | Creates the Graphics for the control. (Inherited from Control.)
 | CreateHandle()()()() | Creates a handle for the control. (Inherited from ComboBox.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from ComboBox.)
 | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
 | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
 | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
 | DataManager | Gets the CurrencyManager associated with this control. (Inherited from ListControl.)
 | DataSource | Gets or sets the data source for this ComboBox. (Inherited from ComboBox.)
 | DataSourceChanged | Occurs when the DataSource changes. (Inherited from ListControl.)
 | DefaultContextMenu | The context menu that will be shown when the right click is not on a misspelled word.
 | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
 | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
 | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
 | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
 | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
 | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
 | DefaultSize | (Inherited from ComboBox.)
 | DefWndProc(Message%) | Sends the specified message to the default window procedure. (Inherited from Control.)
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | DestroyHandle()()()() | Destroys the handle associated with the control. (Inherited from Control.)
 | DeviceDpi()()()() | (Inherited from Control.)
 | DisplayMember | Gets or sets the property to display for this ListControl. (Inherited from ListControl.)
 | DisplayMemberChanged | Occurs when the DisplayMember property changes. (Inherited from ListControl.)
 | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
 | Dispose(Boolean) | Releases the unmanaged resources used by the ComboBox and optionally releases the managed resources. (Inherited from ComboBox.)
 | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
 | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
 | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
 | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
 | DoDragDrop(Object, DragDropEffects) | Begins a drag-and-drop operation. (Inherited from Control.)
 | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
 | DoubleClick | This event is not relevant for this class. (Inherited from ComboBox.)
 | DpiChangedAfterParent()()()() | (Inherited from Control.)
 | DpiChangedBeforeParent()()()() | (Inherited from Control.)
 | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
 | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
 | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
 | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
 | DrawItem | Occurs when a visual aspect of an owner-drawn ComboBox changes. (Inherited from ComboBox.)
 | DrawMode | Gets or sets a value indicating whether your code or the operating system will handle drawing of elements in the list. (Inherited from ComboBox.)
 | DrawToBitmap(Bitmap, Rectangle) | Supports rendering to the specified bitmap. (Inherited from Control.)
 | DropDown | Occurs when the drop-down portion of a ComboBox is shown. (Inherited from ComboBox.)
 | DropDownClosed | Occurs when the drop-down portion of the ComboBox is no longer visible. (Inherited from ComboBox.)
 | DropDownHeight | Gets or sets the height in pixels of the drop-down portion of the ComboBox. (Inherited from ComboBox.)
 | DropDownStyle | Gets or sets a value specifying the style of the combo box. (Inherited from ComboBox.)
 | DropDownStyleChanged | Occurs when the DropDownStyle property has changed. (Inherited from ComboBox.)
 | DropDownWidth | Gets or sets the width of the of the drop-down portion of a combo box. (Inherited from ComboBox.)
 | DroppedDown | Gets or sets a value indicating whether the combo box is displaying its drop-down portion. (Inherited from ComboBox.)
 | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
 | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
 | EndInvoke(IAsyncResult) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
 | EndUpdate()()()() | Resumes painting the ComboBox control after painting is suspended by the BeginUpdate()()()() method. (Inherited from ComboBox.)
 | Enter | Occurs when the control is entered. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | FilterItemOnProperty(Object) | Retrieves the current value of the ListControl item, if it is a property of an object, given the item. (Inherited from ListControl.)
 | FilterItemOnProperty(Object, String) | Returns the current value of the ListControl item, if it is a property of an object given the item and the property name. (Inherited from ListControl.)
 | Finalize()()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | FindForm()()()() | Retrieves the form that the control is on. (Inherited from Control.)
 | FindString(String) | Returns the index of the first item in the ComboBox that starts with the specified string. (Inherited from ComboBox.)
 | FindString(String, Int32) | Returns the index of the first item in the ComboBox beyond the specified index that contains the specified string. The search is not case sensitive. (Inherited from ComboBox.)
 | FindStringExact(String) | Finds the first item in the combo box that matches the specified string. (Inherited from ComboBox.)
 | FindStringExact(String, Int32) | Finds the first item after the specified index that matches the specified string. (Inherited from ComboBox.)
 | FlatStyle | Gets or sets the appearance of the ComboBox. (Inherited from ComboBox.)
 | Focus()()()() | Sets input focus to the control. (Inherited from Control.)
 | Focused | Gets a value indicating whether the ComboBox has focus. (Inherited from ComboBox.)
 | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
 | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
 | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
 | ForeColor | (Inherited from ComboBox.)
 | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
 | Format | Occurs when the control is bound to a data value. (Inherited from ListControl.)
 | FormatChanged | Event fired when formatting changes (such as font change).
 | FormatInfo | Gets or sets the IFormatProvider that provides custom formatting behavior. (Inherited from ListControl.)
 | FormatInfoChanged | Occurs when the value of the FormatInfo property changes. (Inherited from ListControl.)
 | FormatString | Gets or sets the format-specifier characters that indicate how a value is to be displayed. (Inherited from ListControl.)
 | FormatStringChanged | Occurs when value of the FormatString property changes (Inherited from ListControl.)
 | FormattingEnabled | Gets or sets a value indicating whether formatting is applied to the DisplayMember property of the ListControl. (Inherited from ListControl.)
 | FormattingEnabledChanged | Occurs when the value of the FormattingEnabled property changes. (Inherited from ListControl.)
 | GetAccessibilityObjectById(Int32) | Retrieves the specified AccessibleObject. (Inherited from Control.)
 | GetAutoSizeMode()()()() | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
 | GetBaselineOffsetAtCharIndex(Int32) | Gets the baseline offset for a character at index i
 | GetCharIndexFromPos(Point) | gets the char index from a position point.
 | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
 | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
 | GetContainerControl()()()() | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
 | GetFirstVisibleCharIndex()()()() | Gets the character index of the first visible character in the window, this is for optimization and can just return 0 if unavailable.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItemHeight(Int32) | Returns the height of an item in the ComboBox. (Inherited from ComboBox.)
 | GetItemText(Object) | Returns the text representation of the specified item. (Inherited from ListControl.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetLineFromCharIndex(Int32) | Gets the line number that char index is on
 | GetNextControl(Control, Boolean) | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
 | GetPosFromCharIndex(Int32) | Gets the position point from the char index
 | GetPreferredSize(Size) | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
 | GetScaledBounds(Rectangle, SizeF, BoundsSpecified) | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetStyle(ControlStyles) | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
 | GetTBU()()()() | Interface requirement
 | GetTopLevel()()()() | Determines if the control is a top-level control. (Inherited from Control.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
 | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
 | Handle |
 | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
 | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
 | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the control. (Inherited from Control.)
 | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
 | Hide()()()() | Conceals the control from the user. (Inherited from Control.)
 | HScrolled | Event fired when horizontal scroll changed (by anything).
 | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
 | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
 | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | InitLayout()()()() | Called after the control has been added to another container. (Inherited from Control.)
 | IntegralHeight | Gets or sets a value indicating whether the control should resize to avoid showing partial items. (Inherited from ComboBox.)
 | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
 | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
 | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
 | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
 | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
 | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
 | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
 | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
 | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
 | InvokeGotFocus(Control, EventArgs) | Raises the GotFocus event for the specified control. (Inherited from Control.)
 | InvokeLostFocus(Control, EventArgs) | Raises the LostFocus event for the specified control. (Inherited from Control.)
 | InvokeOnClick(Control, EventArgs) | Raises the Click event for the specified control. (Inherited from Control.)
 | InvokePaint(Control, PaintEventArgs) | Raises the Paint event for the specified control. (Inherited from Control.)
 | InvokePaintBackground(Control, PaintEventArgs) | Raises the PaintBackground event for the specified control. (Inherited from Control.)
 | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
 | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
 | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
 | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
 | IsInputChar(Char) | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
 | IsInputKey(Keys) | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from ComboBox.)
 | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
 | ItemHeight | Gets or sets the height of an item in the combo box. (Inherited from ComboBox.)
 | Items | Gets an object representing the collection of the items contained in this ComboBox. (Inherited from ComboBox.)
 | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
 | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
 | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
 | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
 | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
 | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
 | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
 | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
 | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
 | LogicalToDeviceUnits(Int32) | (Inherited from Control.)
 | LogicalToDeviceUnits(Size) | (Inherited from Control.)
 | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
 | Margin | Gets or sets the space between controls. (Inherited from Control.)
 | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
 | MaxDropDownItems | Gets or sets the maximum number of items to be shown in the drop-down portion of the ComboBox. (Inherited from ComboBox.)
 | MaximumSize | (Inherited from ComboBox.)
 | MaxLength | Gets or sets the number of characters a user can type into the ComboBox. (Inherited from ComboBox.)
 | MeasureItem | Occurs each time an owner-drawn ComboBox item needs to be drawn and when the sizes of the list items are determined. (Inherited from ComboBox.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinimumSize | (Inherited from ComboBox.)
 | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
 | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
 | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
 | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
 | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
 | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
 | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
 | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
 | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
 | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
 | Move | Occurs when the control is moved. (Inherited from Control.)
 | Name | Gets or sets the name of the control. (Inherited from Control.)
 | NotifyInvalidate(Rectangle) | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
 | OnAutoSizeChanged(EventArgs) | Raises the AutoSizeChanged event. (Inherited from Control.)
 | OnBackColorChanged(EventArgs) | (Inherited from ComboBox.)
 | OnBackgroundImageChanged(EventArgs) | Raises the BackgroundImageChanged event. (Inherited from Control.)
 | OnBackgroundImageLayoutChanged(EventArgs) | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
 | OnBindingContextChanged(EventArgs) | (Inherited from ListControl.)
 | OnCausesValidationChanged(EventArgs) | Raises the CausesValidationChanged event. (Inherited from Control.)
 | OnChangeUICues(UICuesEventArgs) | Raises the ChangeUICues event. (Inherited from Control.)
 | OnClick(EventArgs) | Raises the Click event. (Inherited from Control.)
 | OnClientSizeChanged(EventArgs) | Raises the ClientSizeChanged event. (Inherited from Control.)
 | OnContextMenuChanged(EventArgs) | Raises the ContextMenuChanged event. (Inherited from Control.)
 | OnContextMenuStripChanged(EventArgs) | Raises the ContextMenuStripChanged event. (Inherited from Control.)
 | OnControlAdded(ControlEventArgs) | Raises the ControlAdded event. (Inherited from Control.)
 | OnControlRemoved(ControlEventArgs) | Raises the ControlRemoved event. (Inherited from Control.)
 | OnCreateControl()()()() | Raises the CreateControl()()()() method. (Inherited from Control.)
 | OnCursorChanged(EventArgs) | Raises the CursorChanged event. (Inherited from Control.)
 | OnDataSourceChanged(EventArgs) | (Inherited from ComboBox.)
 | OnDisplayMemberChanged(EventArgs) | (Inherited from ComboBox.)
 | OnDockChanged(EventArgs) | Raises the DockChanged event. (Inherited from Control.)
 | OnDoubleClick(EventArgs) | Raises the DoubleClick event. (Inherited from Control.)
 | OnDpiChangedAfterParent(EventArgs) | (Inherited from Control.)
 | OnDpiChangedBeforeParent(EventArgs) | (Inherited from Control.)
 | OnDragDrop(DragEventArgs) | Raises the DragDrop event. (Inherited from Control.)
 | OnDragEnter(DragEventArgs) | Raises the DragEnter event. (Inherited from Control.)
 | OnDragLeave(EventArgs) | Raises the DragLeave event. (Inherited from Control.)
 | OnDragOver(DragEventArgs) | Raises the DragOver event. (Inherited from Control.)
 | OnDrawItem(DrawItemEventArgs) | Raises the DrawItem event. (Inherited from ComboBox.)
 | OnDropDown(EventArgs) | Raises the DropDown event. (Inherited from ComboBox.)
 | OnDropDownClosed(EventArgs) | Raises the DropDownClosed event. (Inherited from ComboBox.)
 | OnDropDownStyleChanged(EventArgs) | Raises the DropDownStyleChanged event. (Inherited from ComboBox.)
 | OnEnabledChanged(EventArgs) | Raises the EnabledChanged event. (Inherited from Control.)
 | OnEnter(EventArgs) | Raises the Enter event. (Inherited from Control.)
 | OnFontChanged(EventArgs) | (Inherited from ComboBox.)
 | OnForeColorChanged(EventArgs) | (Inherited from ComboBox.)
 | OnFormat(ListControlConvertEventArgs) | Raises the Format event. (Inherited from ListControl.)
 | OnFormatInfoChanged(EventArgs) | Raises the FormatInfoChanged event. (Inherited from ListControl.)
 | OnFormatStringChanged(EventArgs) | Raises the FormatStringChanged event. (Inherited from ListControl.)
 | OnFormattingEnabledChanged(EventArgs) | Raises the FormattingEnabledChanged event. (Inherited from ListControl.)
 | OnGiveFeedback(GiveFeedbackEventArgs) | Raises the GiveFeedback event. (Inherited from Control.)
 | OnGotFocus(EventArgs) | Raises the GotFocus event. (Inherited from ComboBox.)
 | OnHandleCreated(EventArgs) | Raises the HandleCreated event. (Inherited from ComboBox.)
 | OnHandleDestroyed(EventArgs) | Raises the HandleDestroyed event. (Inherited from ComboBox.)
 | OnHelpRequested(HelpEventArgs) | Raises the HelpRequested event. (Inherited from Control.)
 | OnImeModeChanged(EventArgs) | Raises the ImeModeChanged event. (Inherited from Control.)
 | OnInvalidated(InvalidateEventArgs) | Raises the Invalidated event. (Inherited from Control.)
 | OnKeyDown(KeyEventArgs) | Raises the KeyDown event. (Inherited from ComboBox.)
 | OnKeyPress(KeyPressEventArgs) | Raises the KeyPress event. (Inherited from ComboBox.)
 | OnKeyUp(KeyEventArgs) | Raises the KeyUp event. (Inherited from Control.)
 | OnLayout(LayoutEventArgs) | Raises the Layout event. (Inherited from Control.)
 | OnLeave(EventArgs) | Raises the Leave event. (Inherited from Control.)
 | OnLocationChanged(EventArgs) | Raises the LocationChanged event. (Inherited from Control.)
 | OnLostFocus(EventArgs) | Raises the LostFocus event. (Inherited from ComboBox.)
 | OnMarginChanged(EventArgs) | Raises the MarginChanged event. (Inherited from Control.)
 | OnMeasureItem(MeasureItemEventArgs) | Raises the MeasureItem event. (Inherited from ComboBox.)
 | OnMouseCaptureChanged(EventArgs) | Raises the MouseCaptureChanged event. (Inherited from Control.)
 | OnMouseClick(MouseEventArgs) | Raises the MouseClick event. (Inherited from Control.)
 | OnMouseDoubleClick(MouseEventArgs) | Raises the MouseDoubleClick event. (Inherited from Control.)
 | OnMouseDown(MouseEventArgs) | Raises the MouseDown event. (Inherited from Control.)
 | OnMouseEnter(EventArgs) | Raises the MouseEnter event. (Inherited from ComboBox.)
 | OnMouseHover(EventArgs) | Raises the MouseHover event. (Inherited from Control.)
 | OnMouseLeave(EventArgs) | Raises the MouseLeave event. (Inherited from ComboBox.)
 | OnMouseMove(MouseEventArgs) | Raises the MouseMove event. (Inherited from Control.)
 | OnMouseUp(MouseEventArgs) | Raises the MouseUp event. (Inherited from Control.)
 | OnMouseWheel(MouseEventArgs) | Raises the MouseWheel event. (Inherited from Control.)
 | OnMove(EventArgs) | Raises the Move event. (Inherited from Control.)
 | OnNotifyMessage(Message) | Notifies the control of Windows messages. (Inherited from Control.)
 | OnPaddingChanged(EventArgs) | Raises the PaddingChanged event. (Inherited from Control.)
 | OnPaint(PaintEventArgs) | Raises the Paint event. (Inherited from Control.)
 | OnPaintBackground(PaintEventArgs) | Paints the background of the control. (Inherited from Control.)
 | OnParentBackColorChanged(EventArgs) | Raises the BackColorChanged event. (Inherited from ComboBox.)
 | OnParentBackgroundImageChanged(EventArgs) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
 | OnParentBindingContextChanged(EventArgs) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
 | OnParentChanged(EventArgs) | Raises the ParentChanged event. (Inherited from Control.)
 | OnParentCursorChanged(EventArgs) | Raises the CursorChanged event. (Inherited from Control.)
 | OnParentEnabledChanged(EventArgs) | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
 | OnParentFontChanged(EventArgs) | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
 | OnParentForeColorChanged(EventArgs) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
 | OnParentRightToLeftChanged(EventArgs) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
 | OnParentVisibleChanged(EventArgs) | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
 | OnPreviewKeyDown(PreviewKeyDownEventArgs) | Raises the PreviewKeyDown event. (Inherited from Control.)
 | OnPrint(PaintEventArgs) | Raises the Paint event. (Inherited from Control.)
 | OnQueryContinueDrag(QueryContinueDragEventArgs) | Raises the QueryContinueDrag event. (Inherited from Control.)
 | OnRegionChanged(EventArgs) | Raises the RegionChanged event. (Inherited from Control.)
 | OnResize(EventArgs) | Raises the Resize event. (Inherited from ComboBox.)
 | OnRightToLeftChanged(EventArgs) | Raises the RightToLeftChanged event. (Inherited from Control.)
 | OnSelectedIndexChanged(EventArgs) | Raises the SelectedIndexChanged event. (Inherited from ComboBox.)
 | OnSelectedItemChanged(EventArgs) | Raises the SelectedItemChanged event. (Inherited from ComboBox.)
 | OnSelectedValueChanged(EventArgs) | Raises the SelectedValueChanged event. (Inherited from ComboBox.)
 | OnSelectionChangeCommitted(EventArgs) | Raises the SelectionChangeCommitted event. (Inherited from ComboBox.)
 | OnSizeChanged(EventArgs) | Raises the SizeChanged event. (Inherited from Control.)
 | OnStyleChanged(EventArgs) | Raises the StyleChanged event. (Inherited from Control.)
 | OnSystemColorsChanged(EventArgs) | Raises the SystemColorsChanged event. (Inherited from Control.)
 | OnTabIndexChanged(EventArgs) | Raises the TabIndexChanged event. (Inherited from Control.)
 | OnTabStopChanged(EventArgs) | Raises the TabStopChanged event. (Inherited from Control.)
 | OnTextChanged(EventArgs) | Raises the TextChanged event. (Inherited from ComboBox.)
 | OnTextUpdate(EventArgs) | Raises the TextUpdate event. (Inherited from ComboBox.)
 | OnValidated(EventArgs) | Raises the Validated event. (Inherited from Control.)
 | OnValidating(CancelEventArgs) | Raises the Validating event. (Inherited from ComboBox.)
 | OnValueMemberChanged(EventArgs) | Raises the ValueMemberChanged event. (Inherited from ListControl.)
 | OnVisibleChanged(EventArgs) | Raises the VisibleChanged event. (Inherited from Control.)
 | Padding | This property is not relevant for this class. (Inherited from ComboBox.)
 | PaddingChanged | This event is not relevant to this class. (Inherited from ComboBox.)
 | Paint | Occurs when the ComboBox control is redrawn. (Inherited from ComboBox.)
 | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
 | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
 | Pasting | Occurs when text is about to be pasted.
 | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
 | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
 | PointToClient(Point) | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
 | PointToScreen(Point) | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
 | PreferredHeight | Gets the preferred height of the ComboBox. (Inherited from ComboBox.)
 | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
 | PreProcessControlMessage(Message%) | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
 | PreProcessMessage(Message%) | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
 | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
 | ProcessCmdKey(Message%, Keys) | Processes a command key. (Inherited from Control.)
 | ProcessDialogChar(Char) | Processes a dialog character. (Inherited from Control.)
 | ProcessDialogKey(Keys) | Processes a dialog key. (Inherited from Control.)
 | ProcessKeyEventArgs(Message%) | (Inherited from ComboBox.)
 | ProcessKeyMessage(Message%) | Processes a keyboard message. (Inherited from Control.)
 | ProcessKeyPreview(Message%) | Previews a keyboard message. (Inherited from Control.)
 | ProcessMnemonic(Char) | Processes a mnemonic character. (Inherited from Control.)
 | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
 | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
 | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
 | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
 | RaiseDragEvent(Object, DragEventArgs) | Raises the appropriate drag event. (Inherited from Control.)
 | RaiseKeyEvent(Object, KeyEventArgs) | Raises the appropriate key event. (Inherited from Control.)
 | RaiseMouseEvent(Object, MouseEventArgs) | Raises the appropriate mouse event. (Inherited from Control.)
 | RaisePaintEvent(Object, PaintEventArgs) | Raises the appropriate paint event. (Inherited from Control.)
 | ReadOnly |
 | RecreateHandle()()()() | Forces the re-creation of the handle for the control. (Inherited from Control.)
 | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
 | RectangleToClient(Rectangle) | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
 | RectangleToScreen(Rectangle) | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
 | Refresh()()()() | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
 | RefreshItem(Int32) | Refreshes the item contained at the specified location. (Inherited from ComboBox.)
 | RefreshItems()()()() | Refreshes all ComboBox items. (Inherited from ComboBox.)
 | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
 | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
 | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
 | RescaleConstantsForDpi(Int32, Int32) | (Inherited from Control.)
 | ResetBackColor()()()() | Resets the BackColor property to its default value. (Inherited from Control.)
 | ResetBindings()()()() | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
 | ResetCursor()()()() | Resets the Cursor property to its default value. (Inherited from Control.)
 | ResetFont()()()() | Resets the Font property to its default value. (Inherited from Control.)
 | ResetForeColor()()()() | Resets the ForeColor property to its default value. (Inherited from Control.)
 | ResetImeMode()()()() | Resets the ImeMode property to its default value. (Inherited from Control.)
 | ResetMouseEventArgs()()()() | Resets the control to handle the MouseLeave event. (Inherited from Control.)
 | ResetRightToLeft()()()() | Resets the RightToLeft property to its default value. (Inherited from Control.)
 | ResetText()()()() | (Inherited from ComboBox.)
 | Resize | Occurs when the control is resized. (Inherited from Control.)
 | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
 | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
 | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
 | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
 | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
 | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
 | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateContent(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateHorizontal(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateLeftRight(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
 | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
 | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
 | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
 | ScaleBitmapLogicalToDevice(Bitmap%) | (Inherited from Control.)
 | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
 | ScaleControl(SizeF, BoundsSpecified) | (Inherited from ComboBox.)
 | ScaleCore(Single, Single) | This method is not relevant for this class. (Inherited from Control.)
 | ScrollCaret | Occurs when the text box is scrolled to the caret.
 | Select(Int32, Int32) | Selects a range of text in the editable portion of the ComboBox. (Inherited from ComboBox.)
 | Select()()()() | Activates the control. (Inherited from Control.)
 | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
 | SelectAll()()()() | Selects all the text in the editable portion of the ComboBox. (Inherited from ComboBox.)
 | SelectedIndex | Gets or sets the index specifying the currently selected item. (Inherited from ComboBox.)
 | SelectedIndexChanged | Occurs when the SelectedIndex property has changed. (Inherited from ComboBox.)
 | SelectedItem | Gets or sets currently selected item in the ComboBox. (Inherited from ComboBox.)
 | SelectedText | Gets or sets the text that is selected in the editable portion of a ComboBox. (Inherited from ComboBox.)
 | SelectedValue | Gets or sets the value of the member property specified by the ValueMember property. (Inherited from ListControl.)
 | SelectedValueChanged | Occurs when the SelectedValue property changes. (Inherited from ListControl.)
 | SelectionChangeCommitted | Occurs when the selected item has changed and that change is displayed in the ComboBox. (Inherited from ComboBox.)
 | SelectionChanged | Occurs when the selection of text within the control has changed.
 | SelectionLength | This member overrides TextBox.SelectionLength.
 | SelectionStart | Gets or sets the starting point of text selected in the text box.
 | SelectNextControl(Control, Boolean, Boolean, Boolean, Boolean) | Activates the next control. (Inherited from Control.)
 | SendToBack()()()() | Sends the control to the back of the z-order. (Inherited from Control.)
 | SetAutoSizeMode(AutoSizeMode) | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
 | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
 | SetBoundsCore(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the size and location of the ComboBox. (Inherited from ComboBox.)
 | SetClientSizeCore(Int32, Int32) | Sets the size of the client area of the control. (Inherited from Control.)
 | SetItemCore(Int32, Object) | When overridden in a derived class, sets the object with the specified index in the derived class. (Inherited from ComboBox.)
 | SetItemsCore(IList) | When overridden in a derived class, sets the specified array of objects in a collection in the derived class. (Inherited from ComboBox.)
 | SetStyle(ControlStyles, Boolean) | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
 | SetTopLevel(Boolean) | Sets the control as the top-level control. (Inherited from Control.)
 | SetVisibleCore(Boolean) | Sets the control to the specified visible state. (Inherited from Control.)
 | Show()()()() | Displays the control to the user. (Inherited from Control.)
 | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
 | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
 | Site | Gets or sets the site of the control. (Inherited from Control.)
 | Size | Gets or sets the height and width of the control. (Inherited from Control.)
 | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
 | SizeFromClientSize(Size) | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
 | Sorted | Gets or sets a value indicating whether the items in the combo box are sorted. (Inherited from ComboBox.)
 | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
 | SuspendLayout()()()() | Temporarily suspends the layout logic for the control. (Inherited from Control.)
 | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
 | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
 | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
 | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
 | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
 | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
 | Text | Gets or sets the text associated with this control. (Inherited from ComboBox.)
 | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
 | TextLength |
 | TextUpdate | Occurs when the control has formatted the text, but before the text is displayed. (Inherited from ComboBox.)
 | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
 | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
 | ToString()()()() | Returns a string that represents the ComboBox control. (Inherited from ComboBox.)
 | Update()()()() | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
 | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
 | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
 | UpdateStyles()()()() | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
 | UpdateZOrder()()()() | Updates the control in its parent's z-order. (Inherited from Control.)
 | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
 | Validated | Occurs when the control is finished validating. (Inherited from Control.)
 | Validating | Occurs when the control is validating. (Inherited from Control.)
 | ValueMember | Gets or sets the property to use as the actual value for the items in the ListControl. (Inherited from ListControl.)
 | ValueMemberChanged | Occurs when the ValueMember property changes. (Inherited from ListControl.)
 | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
 | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
 | VScrolled | Event fired when vertical scroll changed (by anything).
 | VScrollEnd | Event fired when vertical scroll ends.
 | Width | Gets or sets the width of the control. (Inherited from Control.)
 | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
 | WndProc(Message%) | Handles WndProc events and dispatches new events. (Overrides ComboBox.WndProc(Message%).)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | Control
 |  |  |  | ListControl
 |  |  |  |  | ComboBox
 |  |  |  |  |  | AYTComboBox

Send comments on this topic to support@keyoti.com

2005-2017 Keyoti Inc.

Assembly: Keyoti.RapidSpell.NET4 (Module: Keyoti.RapidSpell.NET4.dll) Version: 6.0.19.705


AYTComboBox Constructor

Keyoti RapidSpell Desktop .NET API Docs
AYTComboBox Constructor
API ► Keyoti.RapidSpell ► AYTComboBox ► AYTComboBox()()()()
Keyoti RapidSpell Desktop .NET
Creates a new TextBox with "as-you-type" facility.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public AYTComboBox()
public AYTComboBox()
Public Sub New
Public Sub New
public:
AYTComboBox()
public:
AYTComboBox()
new : unit -> AYTComboBox
new : unit -> AYTComboBox


ContextMenu Property

Keyoti RapidSpell Desktop .NET API Docs
ContextMenu Property
API ► Keyoti.RapidSpell ► AYTComboBox ► ContextMenu
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override ContextMenu ContextMenu { set; }
public override ContextMenu ContextMenu { set; }
Public Overrides WriteOnly Property ContextMenu As ContextMenu
    Set
Public Overrides WriteOnly Property ContextMenu As ContextMenu
    Set
public:
virtual property ContextMenu^ ContextMenu {
    void set (ContextMenu^ value) override;
}
public:
virtual property ContextMenu^ ContextMenu {
    void set (ContextMenu^ value) override;
}
abstract ContextMenu : ContextMenu with set
override ContextMenu : ContextMenu with set
abstract ContextMenu : ContextMenu with set
override ContextMenu : ContextMenu with set
Property Value
ContextMenu


ContextMenuDefault Property

Keyoti RapidSpell Desktop .NET API Docs
ContextMenuDefault Property
API ► Keyoti.RapidSpell ► AYTComboBox ► ContextMenuDefault
Keyoti RapidSpell Desktop .NET
The context menu that will be shown when the right click is not on a misspelled word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ContextMenu ContextMenuDefault { get; }
public ContextMenu ContextMenuDefault { get; }
Public ReadOnly Property ContextMenuDefault As ContextMenu
    Get
Public ReadOnly Property ContextMenuDefault As ContextMenu
    Get
public:
virtual property ContextMenu^ ContextMenuDefault {
    ContextMenu^ get () sealed;
}
public:
virtual property ContextMenu^ ContextMenuDefault {
    ContextMenu^ get () sealed;
}
abstract ContextMenuDefault : ContextMenu with get
override ContextMenuDefault : ContextMenu with get
abstract ContextMenuDefault : ContextMenu with get
override ContextMenuDefault : ContextMenu with get
Property Value
ContextMenu
Remarks
This is the context menu originally set in the ContextMenu property.


ContextMenuStrip Property

Keyoti RapidSpell Desktop .NET API Docs
ContextMenuStrip Property
API ► Keyoti.RapidSpell ► AYTComboBox ► ContextMenuStrip
Keyoti RapidSpell Desktop .NET
The context menu that will be shown when the right click is not on a misspelled word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override ContextMenuStrip ContextMenuStrip { get; set; }
public override ContextMenuStrip ContextMenuStrip { get; set; }
Public Overrides Property ContextMenuStrip As ContextMenuStrip
    Get
    Set
Public Overrides Property ContextMenuStrip As ContextMenuStrip
    Get
    Set
public:
virtual property ContextMenuStrip^ ContextMenuStrip {
    ContextMenuStrip^ get () override;
    void set (ContextMenuStrip^ value) override;
}
public:
virtual property ContextMenuStrip^ ContextMenuStrip {
    ContextMenuStrip^ get () override;
    void set (ContextMenuStrip^ value) override;
}
abstract ContextMenuStrip : ContextMenuStrip with get, set
override ContextMenuStrip : ContextMenuStrip with get, set
abstract ContextMenuStrip : ContextMenuStrip with get, set
override ContextMenuStrip : ContextMenuStrip with get, set
Property Value
ContextMenuStrip


ContextMenuStripDefault Property

Keyoti RapidSpell Desktop .NET API Docs
ContextMenuStripDefault Property
API ► Keyoti.RapidSpell ► AYTComboBox ► ContextMenuStripDefault
Keyoti RapidSpell Desktop .NET
The context menu that will be shown when the right click is not on a misspelled word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ContextMenuStrip ContextMenuStripDefault { get; set; }
public ContextMenuStrip ContextMenuStripDefault { get; set; }
Public Property ContextMenuStripDefault As ContextMenuStrip
    Get
    Set
Public Property ContextMenuStripDefault As ContextMenuStrip
    Get
    Set
public:
virtual property ContextMenuStrip^ ContextMenuStripDefault {
    ContextMenuStrip^ get () sealed;
    void set (ContextMenuStrip^ value) sealed;
}
public:
virtual property ContextMenuStrip^ ContextMenuStripDefault {
    ContextMenuStrip^ get () sealed;
    void set (ContextMenuStrip^ value) sealed;
}
abstract ContextMenuStripDefault : ContextMenuStrip with get, set
override ContextMenuStripDefault : ContextMenuStrip with get, set
abstract ContextMenuStripDefault : ContextMenuStrip with get, set
override ContextMenuStripDefault : ContextMenuStrip with get, set
Property Value
ContextMenuStrip
Remarks
This is the context menu originally set in the ContextMenuStrip property.


ControlBackgroundPaint Event

Keyoti RapidSpell Desktop .NET API Docs
ControlBackgroundPaint Event
API ► Keyoti.RapidSpell ► AYTComboBox ► ControlBackgroundPaint
Keyoti RapidSpell Desktop .NET
Event fired when Windows level background repaint occurs.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler ControlBackgroundPaint
public event EventHandler ControlBackgroundPaint
Public Event ControlBackgroundPaint As EventHandler
Public Event ControlBackgroundPaint As EventHandler
public:
 event EventHandler^ ControlBackgroundPaint {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
 event EventHandler^ ControlBackgroundPaint {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member ControlBackgroundPaint : IEvent<EventHandler,
    EventArgs>

member ControlBackgroundPaint : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


ControlPaint Event

Keyoti RapidSpell Desktop .NET API Docs
ControlPaint Event
API ► Keyoti.RapidSpell ► AYTComboBox ► ControlPaint
Keyoti RapidSpell Desktop .NET
Event fired when Windows level repaint occurs.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler ControlPaint
public event EventHandler ControlPaint
Public Event ControlPaint As EventHandler
Public Event ControlPaint As EventHandler
public:
virtual  event EventHandler^ ControlPaint {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ ControlPaint {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ControlPaint : IEvent<EventHandler,
    EventArgs>
override ControlPaint : IEvent<EventHandler,
    EventArgs>
abstract ControlPaint : IEvent<EventHandler,
    EventArgs>
override ControlPaint : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


DefaultContextMenu Property

Keyoti RapidSpell Desktop .NET API Docs
DefaultContextMenu Property
API ► Keyoti.RapidSpell ► AYTComboBox ► DefaultContextMenu
Keyoti RapidSpell Desktop .NET
The context menu that will be shown when the right click is not on a misspelled word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ContextMenu DefaultContextMenu { get; }
public ContextMenu DefaultContextMenu { get; }
Public ReadOnly Property DefaultContextMenu As ContextMenu
    Get
Public ReadOnly Property DefaultContextMenu As ContextMenu
    Get
public:
virtual property ContextMenu^ DefaultContextMenu {
    ContextMenu^ get () sealed;
}
public:
virtual property ContextMenu^ DefaultContextMenu {
    ContextMenu^ get () sealed;
}
abstract DefaultContextMenu : ContextMenu with get
override DefaultContextMenu : ContextMenu with get
abstract DefaultContextMenu : ContextMenu with get
override DefaultContextMenu : ContextMenu with get
Property Value
ContextMenu
Remarks
This is the context menu originally set in the ContextMenu property.


FormatChanged Event

Keyoti RapidSpell Desktop .NET API Docs
FormatChanged Event
API ► Keyoti.RapidSpell ► AYTComboBox ► FormatChanged
Keyoti RapidSpell Desktop .NET
Event fired when formatting changes (such as font change).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler FormatChanged
public event EventHandler FormatChanged
Public Event FormatChanged As EventHandler
Public Event FormatChanged As EventHandler
public:
virtual  event EventHandler^ FormatChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ FormatChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract FormatChanged : IEvent<EventHandler,
    EventArgs>
override FormatChanged : IEvent<EventHandler,
    EventArgs>
abstract FormatChanged : IEvent<EventHandler,
    EventArgs>
override FormatChanged : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


GetBaselineOffsetAtCharIndex Method (i)

Keyoti RapidSpell Desktop .NET API Docs
GetBaselineOffsetAtCharIndex Method (i)
API ► Keyoti.RapidSpell ► AYTComboBox ► GetBaselineOffsetAtCharIndex(Int32)
Keyoti RapidSpell Desktop .NET
Gets the baseline offset for a character at index i
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int GetBaselineOffsetAtCharIndex(
    int i
)
public int GetBaselineOffsetAtCharIndex(
    int i
)
Public Function GetBaselineOffsetAtCharIndex (
    i As Integer
) As Integer
Public Function GetBaselineOffsetAtCharIndex (
    i As Integer
) As Integer
public:
virtual int GetBaselineOffsetAtCharIndex(
    int i
) sealed
public:
virtual int GetBaselineOffsetAtCharIndex(
    int i
) sealed
abstract GetBaselineOffsetAtCharIndex :
        i : int -> int
override GetBaselineOffsetAtCharIndex :
        i : int -> int
abstract GetBaselineOffsetAtCharIndex :
        i : int -> int
override GetBaselineOffsetAtCharIndex :
        i : int -> int
Parameters
i (Int32)
Return Value
Int32


GetCharIndexFromPos Method (pos)

Keyoti RapidSpell Desktop .NET API Docs
GetCharIndexFromPos Method (pos)
API ► Keyoti.RapidSpell ► AYTComboBox ► GetCharIndexFromPos(Point)
Keyoti RapidSpell Desktop .NET
gets the char index from a position point.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int GetCharIndexFromPos(
    Point pos
)
public int GetCharIndexFromPos(
    Point pos
)
Public Function GetCharIndexFromPos (
    pos As Point
) As Integer
Public Function GetCharIndexFromPos (
    pos As Point
) As Integer
public:
virtual int GetCharIndexFromPos(
    Point pos
) sealed
public:
virtual int GetCharIndexFromPos(
    Point pos
) sealed
abstract GetCharIndexFromPos :
        pos : Point -> int
override GetCharIndexFromPos :
        pos : Point -> int
abstract GetCharIndexFromPos :
        pos : Point -> int
override GetCharIndexFromPos :
        pos : Point -> int
Parameters
pos (Point)
Return Value
Int32


GetFirstVisibleCharIndex Method

Keyoti RapidSpell Desktop .NET API Docs
GetFirstVisibleCharIndex Method
API ► Keyoti.RapidSpell ► AYTComboBox ► GetFirstVisibleCharIndex()()()()
Keyoti RapidSpell Desktop .NET
Gets the character index of the first visible character in the window, this is for optimization and can just return 0 if unavailable.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int GetFirstVisibleCharIndex()
public int GetFirstVisibleCharIndex()
Public Function GetFirstVisibleCharIndex As Integer
Public Function GetFirstVisibleCharIndex As Integer
public:
virtual int GetFirstVisibleCharIndex() sealed
public:
virtual int GetFirstVisibleCharIndex() sealed
abstract GetFirstVisibleCharIndex : unit -> int
override GetFirstVisibleCharIndex : unit -> int
abstract GetFirstVisibleCharIndex : unit -> int
override GetFirstVisibleCharIndex : unit -> int
Return Value
Int32


GetLineFromCharIndex Method (ind)

Keyoti RapidSpell Desktop .NET API Docs
GetLineFromCharIndex Method (ind)
API ► Keyoti.RapidSpell ► AYTComboBox ► GetLineFromCharIndex(Int32)
Keyoti RapidSpell Desktop .NET
Gets the line number that char index is on
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int GetLineFromCharIndex(
    int ind
)
public int GetLineFromCharIndex(
    int ind
)
Public Function GetLineFromCharIndex (
    ind As Integer
) As Integer
Public Function GetLineFromCharIndex (
    ind As Integer
) As Integer
public:
virtual int GetLineFromCharIndex(
    int ind
) sealed
public:
virtual int GetLineFromCharIndex(
    int ind
) sealed
abstract GetLineFromCharIndex :
        ind : int -> int
override GetLineFromCharIndex :
        ind : int -> int
abstract GetLineFromCharIndex :
        ind : int -> int
override GetLineFromCharIndex :
        ind : int -> int
Parameters
ind (Int32)
Return Value
Int32


GetPosFromCharIndex Method (ind)

Keyoti RapidSpell Desktop .NET API Docs
GetPosFromCharIndex Method (ind)
API ► Keyoti.RapidSpell ► AYTComboBox ► GetPosFromCharIndex(Int32)
Keyoti RapidSpell Desktop .NET
Gets the position point from the char index
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Point GetPosFromCharIndex(
    int ind
)
public Point GetPosFromCharIndex(
    int ind
)
Public Function GetPosFromCharIndex (
    ind As Integer
) As Point
Public Function GetPosFromCharIndex (
    ind As Integer
) As Point
public:
virtual Point GetPosFromCharIndex(
    int ind
) sealed
public:
virtual Point GetPosFromCharIndex(
    int ind
) sealed
abstract GetPosFromCharIndex :
        ind : int -> Point
override GetPosFromCharIndex :
        ind : int -> Point
abstract GetPosFromCharIndex :
        ind : int -> Point
override GetPosFromCharIndex :
        ind : int -> Point
Parameters
ind (Int32)
Return Value
Point


GetTBU Method

Keyoti RapidSpell Desktop .NET API Docs
GetTBU Method
API ► Keyoti.RapidSpell ► AYTComboBox ► GetTBU()()()()
Keyoti RapidSpell Desktop .NET
Interface requirement
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public TextBoxUtilityAdapter GetTBU()
public TextBoxUtilityAdapter GetTBU()
Public Function GetTBU As TextBoxUtilityAdapter
Public Function GetTBU As TextBoxUtilityAdapter
public:
virtual TextBoxUtilityAdapter^ GetTBU() sealed
public:
virtual TextBoxUtilityAdapter^ GetTBU() sealed
abstract GetTBU : unit -> TextBoxUtilityAdapter
override GetTBU : unit -> TextBoxUtilityAdapter
abstract GetTBU : unit -> TextBoxUtilityAdapter
override GetTBU : unit -> TextBoxUtilityAdapter
Return Value
TextBoxUtilityAdapter


Handle Property

Keyoti RapidSpell Desktop .NET API Docs
Handle Property
API ► Keyoti.RapidSpell ► AYTComboBox ► Handle
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public IntPtr Handle { get; }
public IntPtr Handle { get; }
Public ReadOnly Property Handle As IntPtr
    Get
Public ReadOnly Property Handle As IntPtr
    Get
public:
virtual property IntPtr Handle {
    IntPtr get () sealed;
}
public:
virtual property IntPtr Handle {
    IntPtr get () sealed;
}
abstract Handle : IntPtr with get
override Handle : IntPtr with get
abstract Handle : IntPtr with get
override Handle : IntPtr with get
Property Value
IntPtr


HScrolled Event

Keyoti RapidSpell Desktop .NET API Docs
HScrolled Event
API ► Keyoti.RapidSpell ► AYTComboBox ► HScrolled
Keyoti RapidSpell Desktop .NET
Event fired when horizontal scroll changed (by anything).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler HScrolled
public event EventHandler HScrolled
Public Event HScrolled As EventHandler
Public Event HScrolled As EventHandler
public:
virtual  event EventHandler^ HScrolled {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ HScrolled {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract HScrolled : IEvent<EventHandler,
    EventArgs>
override HScrolled : IEvent<EventHandler,
    EventArgs>
abstract HScrolled : IEvent<EventHandler,
    EventArgs>
override HScrolled : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


Pasting Event

Keyoti RapidSpell Desktop .NET API Docs
Pasting Event
API ► Keyoti.RapidSpell ► AYTComboBox ► Pasting
Keyoti RapidSpell Desktop .NET
Occurs when text is about to be pasted.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler Pasting
public event EventHandler Pasting
Public Event Pasting As EventHandler
Public Event Pasting As EventHandler
public:
 event EventHandler^ Pasting {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
 event EventHandler^ Pasting {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member Pasting : IEvent<EventHandler,
    EventArgs>

member Pasting : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


ReadOnly Property

Keyoti RapidSpell Desktop .NET API Docs
ReadOnly Property
API ► Keyoti.RapidSpell ► AYTComboBox ► ReadOnly
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ReadOnly { get; }
public bool ReadOnly { get; }
Public ReadOnly Property ReadOnly As Boolean
    Get
Public ReadOnly Property ReadOnly As Boolean
    Get
public:
virtual property bool ReadOnly {
    bool get () sealed;
}
public:
virtual property bool ReadOnly {
    bool get () sealed;
}
abstract ReadOnly : bool with get
override ReadOnly : bool with get
abstract ReadOnly : bool with get
override ReadOnly : bool with get
Property Value
Boolean


ScrollCaret Event

Keyoti RapidSpell Desktop .NET API Docs
ScrollCaret Event
API ► Keyoti.RapidSpell ► AYTComboBox ► ScrollCaret
Keyoti RapidSpell Desktop .NET
Occurs when the text box is scrolled to the caret.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler ScrollCaret
public event EventHandler ScrollCaret
Public Event ScrollCaret As EventHandler
Public Event ScrollCaret As EventHandler
public:
virtual  event EventHandler^ ScrollCaret {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ ScrollCaret {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ScrollCaret : IEvent<EventHandler,
    EventArgs>
override ScrollCaret : IEvent<EventHandler,
    EventArgs>
abstract ScrollCaret : IEvent<EventHandler,
    EventArgs>
override ScrollCaret : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


SelectionChanged Event

Keyoti RapidSpell Desktop .NET API Docs
SelectionChanged Event
API ► Keyoti.RapidSpell ► AYTComboBox ► SelectionChanged
Keyoti RapidSpell Desktop .NET
Occurs when the selection of text within the control has changed.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler SelectionChanged
public event EventHandler SelectionChanged
Public Event SelectionChanged As EventHandler
Public Event SelectionChanged As EventHandler
public:
 event EventHandler^ SelectionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
 event EventHandler^ SelectionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member SelectionChanged : IEvent<EventHandler,
    EventArgs>

member SelectionChanged : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


SelectionLength Property

Keyoti RapidSpell Desktop .NET API Docs
SelectionLength Property
API ► Keyoti.RapidSpell ► AYTComboBox ► SelectionLength
Keyoti RapidSpell Desktop .NET
This member overrides TextBox.SelectionLength.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int SelectionLength { get; set; }
public int SelectionLength { get; set; }
Public Property SelectionLength As Integer
    Get
    Set
Public Property SelectionLength As Integer
    Get
    Set
public:
virtual property int SelectionLength {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int SelectionLength {
    int get () sealed;
    void set (int value) sealed;
}
abstract SelectionLength : int with get, set
override SelectionLength : int with get, set
abstract SelectionLength : int with get, set
override SelectionLength : int with get, set
Property Value
Int32


SelectionStart Property

Keyoti RapidSpell Desktop .NET API Docs
SelectionStart Property
API ► Keyoti.RapidSpell ► AYTComboBox ► SelectionStart
Keyoti RapidSpell Desktop .NET
Gets or sets the starting point of text selected in the text box.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int SelectionStart { get; set; }
public int SelectionStart { get; set; }
Public Property SelectionStart As Integer
    Get
    Set
Public Property SelectionStart As Integer
    Get
    Set
public:
virtual property int SelectionStart {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int SelectionStart {
    int get () sealed;
    void set (int value) sealed;
}
abstract SelectionStart : int with get, set
override SelectionStart : int with get, set
abstract SelectionStart : int with get, set
override SelectionStart : int with get, set
Property Value
Int32
Remarks
If no text is selected in the control, this property indicates the insertion point for new text. If you set this property to a location beyond the length of the text in the control, the selection start position will be placed after the last character. When text is selected in the text box control, changing this property might decrease the value of the SelectionLength property. If the remaining text in the control after the position indicated by the SelectionStart property is less than the value of the SelectionLength property, the value of the SelectionLength property is automatically decreased. The value of the SelectionStart property never causes an increase in the SelectionLength property. Note You can programmatically move the caret within the text box by setting the SelectionStart to the position within the text box where you want the caret to move to and set the SelectionLength property to a value of zero (0). The text box must have focus in order for the caret to be moved.


TextLength Property

Keyoti RapidSpell Desktop .NET API Docs
TextLength Property
API ► Keyoti.RapidSpell ► AYTComboBox ► TextLength
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int TextLength { get; }
public int TextLength { get; }
Public ReadOnly Property TextLength As Integer
    Get
Public ReadOnly Property TextLength As Integer
    Get
public:
virtual property int TextLength {
    int get () sealed;
}
public:
virtual property int TextLength {
    int get () sealed;
}
abstract TextLength : int with get
override TextLength : int with get
abstract TextLength : int with get
override TextLength : int with get
Property Value
Int32


VScrolled Event

Keyoti RapidSpell Desktop .NET API Docs
VScrolled Event
API ► Keyoti.RapidSpell ► AYTComboBox ► VScrolled
Keyoti RapidSpell Desktop .NET
Event fired when vertical scroll changed (by anything).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler VScrolled
public event EventHandler VScrolled
Public Event VScrolled As EventHandler
Public Event VScrolled As EventHandler
public:
virtual  event EventHandler^ VScrolled {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ VScrolled {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract VScrolled : IEvent<EventHandler,
    EventArgs>
override VScrolled : IEvent<EventHandler,
    EventArgs>
abstract VScrolled : IEvent<EventHandler,
    EventArgs>
override VScrolled : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


VScrollEnd Event

Keyoti RapidSpell Desktop .NET API Docs
VScrollEnd Event
API ► Keyoti.RapidSpell ► AYTComboBox ► VScrollEnd
Keyoti RapidSpell Desktop .NET
Event fired when vertical scroll ends.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler VScrollEnd
public event EventHandler VScrollEnd
Public Event VScrollEnd As EventHandler
Public Event VScrollEnd As EventHandler
public:
virtual  event EventHandler^ VScrollEnd {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ VScrollEnd {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract VScrollEnd : IEvent<EventHandler,
    EventArgs>
override VScrollEnd : IEvent<EventHandler,
    EventArgs>
abstract VScrollEnd : IEvent<EventHandler,
    EventArgs>
override VScrollEnd : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


WndProc Method (m)

Keyoti RapidSpell Desktop .NET API Docs
WndProc Method (m)
API ► Keyoti.RapidSpell ► AYTComboBox ► WndProc(Message%)
Keyoti RapidSpell Desktop .NET
Handles WndProc events and dispatches new events.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override void WndProc(
    ref Message m
)
protected override void WndProc(
    ref Message m
)
Protected Overrides Sub WndProc (
    ByRef m As Message
)
Protected Overrides Sub WndProc (
    ByRef m As Message
)
protected:
virtual void WndProc(
    Message% m
) override
protected:
virtual void WndProc(
    Message% m
) override
abstract WndProc :
        m : Message byref -> unit
override WndProc :
        m : Message byref -> unit
abstract WndProc :
        m : Message byref -> unit
override WndProc :
        m : Message byref -> unit
Parameters
m (Message %)


AYTRichTextBox Class

Keyoti RapidSpell Desktop .NET API Docs
AYTRichTextBox Class
API ► Keyoti.RapidSpell ► AYTRichTextBox
Keyoti RapidSpell Desktop .NET
As-You-Type enabled RichTextBox.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class AYTRichTextBox : RichTextBox,
    IAYTTextBox
public class AYTRichTextBox : RichTextBox,
    IAYTTextBox
Public Class AYTRichTextBox
    Inherits RichTextBox
    Implements IAYTTextBox
Public Class AYTRichTextBox
    Inherits RichTextBox
    Implements IAYTTextBox
public ref class AYTRichTextBox : public RichTextBox,
    IAYTTextBox
public ref class AYTRichTextBox : public RichTextBox,
    IAYTTextBox
type AYTRichTextBox =
    class
        inherit RichTextBox
        interface IAYTTextBox
    end
type AYTRichTextBox =
    class
        inherit RichTextBox
        interface IAYTTextBox
    end
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AYTRichTextBox()()()() | Creates a new RichTextBox with "as-you-type" facility.
 | AcceptsTab | Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order. (Inherited from TextBoxBase.)
 | AcceptsTabChanged | Occurs when the value of the AcceptsTab property has changed. (Inherited from TextBoxBase.)
 | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
 | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
 | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
 | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
 | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
 | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
 | AllowDrop | Gets or sets a value indicating whether the control will enable drag-and-drop operations. (Inherited from RichTextBox.)
 | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
 | AppendText(String) | Appends text to the current text of a text box. (Inherited from TextBoxBase.)
 | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
 | AutoSize | This property is not relevant to this class. (Inherited from RichTextBox.)
 | AutoSizeChanged | This event is not relevant for this class. (Inherited from TextBoxBase.)
 | AutoWordSelection | Gets or sets a value indicating whether automatic word selection is enabled. (Inherited from RichTextBox.)
 | BackColor | Gets or sets the background color of the control. (Inherited from TextBoxBase.)
 | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
 | BackgroundImage | This property is not relevant to this class. (Inherited from RichTextBox.)
 | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from RichTextBox.)
 | BackgroundImageLayout | This property is not relevant to this class. (Inherited from RichTextBox.)
 | BackgroundImageLayoutChanged | Occurs when the value of the BackgroundImageLayout property changes. (Inherited from RichTextBox.)
 | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
 | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
 | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
 | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
 | BorderStyle | Gets or sets the border type of the text box control. (Inherited from TextBoxBase.)
 | BorderStyleChanged | Occurs when the value of the BorderStyle property has changed. (Inherited from TextBoxBase.)
 | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
 | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
 | BringToFront()()()() | Brings the control to the front of the z-order. (Inherited from Control.)
 | BulletIndent | Gets or sets the indentation used in the RichTextBox control when the bullet style is applied to the text. (Inherited from RichTextBox.)
 | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from TextBoxBase.)
 | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
 | CanPaste(DataFormats..::..Format) | Determines whether you can paste information from the Clipboard in the specified data format. (Inherited from RichTextBox.)
 | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
 | CanRedo | Gets a value indicating whether there are actions that have occurred within the RichTextBox that can be reapplied. (Inherited from RichTextBox.)
 | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
 | CanUndo | Gets a value indicating whether the user can undo the previous operation in a text box control. (Inherited from TextBoxBase.)
 | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
 | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
 | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
 | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
 | Clear()()()() | Clears all text from the text box control. (Inherited from TextBoxBase.)
 | ClearUndo()()()() | Clears information about the most recent operation from the undo buffer of the text box. (Inherited from TextBoxBase.)
 | Click | Occurs when the text box is clicked. (Inherited from TextBoxBase.)
 | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
 | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
 | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
 | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | Contains(Control) | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
 | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
 | ContentsResized | Occurs when contents within the control are resized. (Inherited from RichTextBox.)
 | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
 | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
 | ContextMenuDefault | The context menu that will be shown when the right click is not on a misspelled word.
 | ContextMenuStrip | The context menu that will be shown when the right click is not on a misspelled word. (Overrides Control.ContextMenuStrip.)
 | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
 | ContextMenuStripDefault | The context menu that will be shown when the right click is not on a misspelled word.
 | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
 | ControlBackgroundPaint | Event fired when Windows level background repaint occurs.
 | ControlPaint | Event fired when Windows level repaint occurs.
 | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
 | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
 | Copy()()()() | Copies the current selection in the text box to the Clipboard. (Inherited from TextBoxBase.)
 | CreateAccessibilityInstance()()()() | Creates a new accessibility object for the control. (Inherited from Control.)
 | CreateControl()()()() | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
 | CreateControlsInstance()()()() | Creates a new instance of the control collection for the control. (Inherited from Control.)
 | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
 | CreateGraphics()()()() | Creates the Graphics for the control. (Inherited from Control.)
 | CreateHandle()()()() | (Inherited from TextBoxBase.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateParams | (Inherited from RichTextBox.)
 | CreateRichEditOleCallback()()()() | Creates an IRichEditOleCallback-compatible object for handling rich-edit callback operations. (Inherited from RichTextBox.)
 | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
 | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
 | Cut()()()() | Moves the current selection in the text box to the Clipboard. (Inherited from TextBoxBase.)
 | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
 | DefaultContextMenu | Obsolete. Obsolete - Use ContextMenuDefault instead.
 | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from TextBoxBase.)
 | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
 | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
 | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
 | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
 | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
 | DefaultSize | Gets the default size of the control. (Inherited from RichTextBox.)
 | DefWndProc(Message%) | Sends the specified message to the default window procedure. (Inherited from Control.)
 | DeselectAll()()()() | Specifies that the value of the SelectionLength property is zero so that no characters are selected in the control. (Inherited from TextBoxBase.)
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | DestroyHandle()()()() | Destroys the handle associated with the control. (Inherited from Control.)
 | DetectUrls | Gets or sets a value indicating whether or not the RichTextBox will automatically format a Uniform Resource Locator (URL) when it is typed into the control. (Inherited from RichTextBox.)
 | DeviceDpi()()()() | (Inherited from Control.)
 | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
 | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
 | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
 | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
 | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
 | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
 | DoDragDrop(Object, DragDropEffects) | Begins a drag-and-drop operation. (Inherited from Control.)
 | DoubleBuffered | Gets or sets a value indicating whether control drawing is done in a buffer before the control is displayed. This property is not relevant for this class. (Inherited from TextBoxBase.)
 | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
 | DpiChangedAfterParent()()()() | (Inherited from Control.)
 | DpiChangedBeforeParent()()()() | (Inherited from Control.)
 | DragDrop | Occurs when the user completes a drag-and-drop (Inherited from RichTextBox.)
 | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from RichTextBox.)
 | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from RichTextBox.)
 | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from RichTextBox.)
 | DrawToBitmap(Bitmap, Rectangle) | This method is not relevant for this class. (Inherited from RichTextBox.)
 | EnableAutoDragDrop | Gets or sets a value that enables drag-and-drop operations on text, pictures, and other data. (Inherited from RichTextBox.)
 | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
 | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
 | EndInvoke(IAsyncResult) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
 | Enter | Occurs when the control is entered. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | Finalize()()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | Find(String) | Searches the text in a RichTextBox control for a string. (Inherited from RichTextBox.)
 | Find(String, RichTextBoxFinds) | Searches the text in a RichTextBox control for a string with specific options applied to the search. (Inherited from RichTextBox.)
 | Find(String, Int32, RichTextBoxFinds) | Searches the text in a RichTextBox control for a string at a specific location within the control and with specific options applied to the search. (Inherited from RichTextBox.)
 | Find(String, Int32, Int32, RichTextBoxFinds) | Searches the text in a RichTextBox control for a string within a range of text within the control and with specific options applied to the search. (Inherited from RichTextBox.)
 | Find(array<Char>[]()[][]) | Searches the text of a RichTextBox control for the first instance of a character from a list of characters. (Inherited from RichTextBox.)
 | Find(array<Char>[]()[][], Int32) | Searches the text of a RichTextBox control, at a specific starting point, for the first instance of a character from a list of characters. (Inherited from RichTextBox.)
 | Find(array<Char>[]()[][], Int32, Int32) | Searches a range of text in a RichTextBox control for the first instance of a character from a list of characters. (Inherited from RichTextBox.)
 | FindForm()()()() | Retrieves the form that the control is on. (Inherited from Control.)
 | Focus()()()() | Sets input focus to the control. (Inherited from Control.)
 | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
 | Font | Gets or sets the font used when displaying text in the control. (Inherited from RichTextBox.)
 | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
 | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
 | ForeColor | Gets or sets the font color used when displaying text in the control. (Inherited from RichTextBox.)
 | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
 | FormatChanged | Event fired when formatting changes (such as font change).
 | GetAccessibilityObjectById(Int32) | Retrieves the specified AccessibleObject. (Inherited from Control.)
 | GetAutoSizeMode()()()() | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
 | GetBaselineOffsetAtCharIndex(Int32) | Gets the baseline offset for a character at index i
 | GetCharFromPosition(Point) | Retrieves the character that is closest to the specified location within the control. (Inherited from TextBoxBase.)
 | GetCharIndexFromPos(Point) | gets the char index from a position point.
 | GetCharIndexFromPosition(Point) | Retrieves the index of the character nearest to the specified location. (Inherited from RichTextBox.)
 | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
 | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
 | GetContainerControl()()()() | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
 | GetFirstCharIndexFromLine(Int32) | Retrieves the index of the first character of a given line. (Inherited from TextBoxBase.)
 | GetFirstCharIndexOfCurrentLine()()()() | Retrieves the index of the first character of the current line. (Inherited from TextBoxBase.)
 | GetFirstVisibleCharIndex()()()() | Gets the character index of the first visible character in the window, this is for optimization and can just return 0 if unavailable.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetLineFromCharIndex(Int32) | Retrieves the line number from the specified character position within the text of the RichTextBox control. (Inherited from RichTextBox.)
 | GetNextControl(Control, Boolean) | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
 | GetPosFromCharIndex(Int32) | Gets the position point from the char index
 | GetPositionFromCharIndex(Int32) | Retrieves the location within the control at the specified character index. (Inherited from RichTextBox.)
 | GetPreferredSize(Size) | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
 | GetScaledBounds(Rectangle, SizeF, BoundsSpecified) | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetStyle(ControlStyles) | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
 | GetTBU()()()() | Interface requirement
 | GetTopLevel()()()() | Determines if the control is a top-level control. (Inherited from Control.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GiveFeedback | Occurs during a drag operation. (Inherited from RichTextBox.)
 | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
 | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
 | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
 | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
 | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the control. (Inherited from Control.)
 | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
 | Hide()()()() | Conceals the control from the user. (Inherited from Control.)
 | HideSelection | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus. (Inherited from TextBoxBase.)
 | HideSelectionChanged | Occurs when the value of the HideSelection property has changed. (Inherited from TextBoxBase.)
 | HScroll | Occurs when the user clicks the horizontal scroll bar of the control. (Inherited from RichTextBox.)
 | HScrolled | Event fired when horizontal scroll changed (by anything).
 | ImeChange | Occurs when the user switches input methods on an Asian version of the Windows operating system. (Inherited from RichTextBox.)
 | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
 | ImeModeBase | (Inherited from TextBoxBase.)
 | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | InitLayout()()()() | Called after the control has been added to another container. (Inherited from Control.)
 | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
 | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
 | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
 | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
 | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
 | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
 | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
 | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
 | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
 | InvokeGotFocus(Control, EventArgs) | Raises the GotFocus event for the specified control. (Inherited from Control.)
 | InvokeLostFocus(Control, EventArgs) | Raises the LostFocus event for the specified control. (Inherited from Control.)
 | InvokeOnClick(Control, EventArgs) | Raises the Click event for the specified control. (Inherited from Control.)
 | InvokePaint(Control, PaintEventArgs) | Raises the Paint event for the specified control. (Inherited from Control.)
 | InvokePaintBackground(Control, PaintEventArgs) | Raises the PaintBackground event for the specified control. (Inherited from Control.)
 | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
 | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
 | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
 | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
 | IsInputChar(Char) | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
 | IsInputKey(Keys) | Determines whether the specified key is an input key or a special key that requires preprocessing. (Inherited from TextBoxBase.)
 | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
 | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
 | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
 | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
 | LanguageOption | Gets or sets a value that indicates RichTextBox settings for Input Method Editor (IME) and Asian language support. (Inherited from RichTextBox.)
 | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
 | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
 | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
 | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
 | Lines | Gets or sets the lines of text in a text box control. (Inherited from TextBoxBase.)
 | LinkClicked | Occurs when the user clicks on a link within the text of the control. (Inherited from RichTextBox.)
 | LoadFile(String) | Loads a rich text format (RTF) or standard ASCII text file into the RichTextBox control. (Inherited from RichTextBox.)
 | LoadFile(String, RichTextBoxStreamType) | Loads a specific type of file into the RichTextBox control. (Inherited from RichTextBox.)
 | LoadFile(Stream, RichTextBoxStreamType) | Loads the contents of an existing data stream into the RichTextBox control. (Inherited from RichTextBox.)
 | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
 | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
 | LogicalToDeviceUnits(Int32) | (Inherited from Control.)
 | LogicalToDeviceUnits(Size) | (Inherited from Control.)
 | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
 | Margin | Gets or sets the space between controls. (Inherited from Control.)
 | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
 | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
 | MaxLength | Gets or sets the maximum number of characters the user can type or paste into the rich text box control. (Inherited from RichTextBox.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
 | Modified | Gets or sets a value that indicates that the text box control has been modified by the user since the control was created or its contents were last set. (Inherited from TextBoxBase.)
 | ModifiedChanged | Occurs when the value of the Modified property has changed. (Inherited from TextBoxBase.)
 | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
 | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from TextBoxBase.)
 | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
 | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
 | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
 | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
 | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
 | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
 | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
 | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
 | Move | Occurs when the control is moved. (Inherited from Control.)
 | Multiline | Gets or sets a value indicating whether this is a multiline RichTextBox control. (Inherited from RichTextBox.)
 | MultilineChanged | Occurs when the value of the Multiline property has changed. (Inherited from TextBoxBase.)
 | Name | Gets or sets the name of the control. (Inherited from Control.)
 | NotifyInvalidate(Rectangle) | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
 | OnAcceptsTabChanged(EventArgs) | Raises the AcceptsTabChanged event. (Inherited from TextBoxBase.)
 | OnAutoSizeChanged(EventArgs) | Raises the AutoSizeChanged event. (Inherited from Control.)
 | OnBackColorChanged(EventArgs) | (Inherited from RichTextBox.)
 | OnBackgroundImageChanged(EventArgs) | Raises the BackgroundImageChanged event. (Inherited from Control.)
 | OnBackgroundImageLayoutChanged(EventArgs) | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
 | OnBindingContextChanged(EventArgs) | Raises the BindingContextChanged event. (Inherited from Control.)
 | OnBorderStyleChanged(EventArgs) | Raises the BorderStyleChanged event. (Inherited from TextBoxBase.)
 | OnCausesValidationChanged(EventArgs) | Raises the CausesValidationChanged event. (Inherited from Control.)
 | OnChangeUICues(UICuesEventArgs) | Raises the ChangeUICues event. (Inherited from Control.)
 | OnClick(EventArgs) | Raises the Click event. (Inherited from Control.)
 | OnClientSizeChanged(EventArgs) | Raises the ClientSizeChanged event. (Inherited from Control.)
 | OnContentsResized(ContentsResizedEventArgs) | Raises the ContentsResized event. (Inherited from RichTextBox.)
 | OnContextMenuChanged(EventArgs) | (Inherited from RichTextBox.)
 | OnContextMenuStripChanged(EventArgs) | Raises the ContextMenuStripChanged event. (Inherited from Control.)
 | OnControlAdded(ControlEventArgs) | Raises the ControlAdded event. (Inherited from Control.)
 | OnControlRemoved(ControlEventArgs) | Raises the ControlRemoved event. (Inherited from Control.)
 | OnCreateControl()()()() | Raises the CreateControl()()()() method. (Inherited from Control.)
 | OnCursorChanged(EventArgs) | Raises the CursorChanged event. (Inherited from Control.)
 | OnDockChanged(EventArgs) | Raises the DockChanged event. (Inherited from Control.)
 | OnDoubleClick(EventArgs) | Raises the DoubleClick event. (Inherited from Control.)
 | OnDpiChangedAfterParent(EventArgs) | (Inherited from Control.)
 | OnDpiChangedBeforeParent(EventArgs) | (Inherited from Control.)
 | OnDragDrop(DragEventArgs) | Raises the DragDrop event. (Inherited from Control.)
 | OnDragEnter(DragEventArgs) | Raises the DragEnter event. (Inherited from Control.)
 | OnDragLeave(EventArgs) | Raises the DragLeave event. (Inherited from Control.)
 | OnDragOver(DragEventArgs) | Raises the DragOver event. (Inherited from Control.)
 | OnEnabledChanged(EventArgs) | Raises the EnabledChanged event. (Inherited from Control.)
 | OnEnter(EventArgs) | Raises the Enter event. (Inherited from Control.)
 | OnFontChanged(EventArgs) | (Inherited from TextBoxBase.)
 | OnForeColorChanged(EventArgs) | Raises the ForeColorChanged event. (Inherited from Control.)
 | OnGiveFeedback(GiveFeedbackEventArgs) | Raises the GiveFeedback event. (Inherited from Control.)
 | OnGotFocus(EventArgs) | Raises the GotFocus event. (Inherited from Control.)
 | OnHandleCreated(EventArgs) | (Inherited from RichTextBox.)
 | OnHandleDestroyed(EventArgs) | (Inherited from RichTextBox.)
 | OnHelpRequested(HelpEventArgs) | Raises the HelpRequested event. (Inherited from Control.)
 | OnHideSelectionChanged(EventArgs) | Fired when HideSelection changes (Overrides TextBoxBase.OnHideSelectionChanged(EventArgs).)
 | OnHScroll(EventArgs) | Raises the HScroll event. (Inherited from RichTextBox.)
 | OnImeChange(EventArgs) | Raises the ImeChange event. (Inherited from RichTextBox.)
 | OnImeModeChanged(EventArgs) | Raises the ImeModeChanged event. (Inherited from Control.)
 | OnInvalidated(InvalidateEventArgs) | Raises the Invalidated event. (Inherited from Control.)
 | OnKeyDown(KeyEventArgs) | Raises the KeyDown event. (Inherited from Control.)
 | OnKeyPress(KeyPressEventArgs) | Raises the KeyPress event. (Inherited from Control.)
 | OnKeyUp(KeyEventArgs) | Raises the KeyUp event. (Inherited from Control.)
 | OnLayout(LayoutEventArgs) | Raises the Layout event. (Inherited from Control.)
 | OnLeave(EventArgs) | Raises the Leave event. (Inherited from Control.)
 | OnLinkClicked(LinkClickedEventArgs) | Raises the LinkClicked event. (Inherited from RichTextBox.)
 | OnLocationChanged(EventArgs) | Raises the LocationChanged event. (Inherited from Control.)
 | OnLostFocus(EventArgs) | Raises the LostFocus event. (Inherited from Control.)
 | OnMarginChanged(EventArgs) | Raises the MarginChanged event. (Inherited from Control.)
 | OnModifiedChanged(EventArgs) | Raises the ModifiedChanged event. (Inherited from TextBoxBase.)
 | OnMouseCaptureChanged(EventArgs) | Raises the MouseCaptureChanged event. (Inherited from Control.)
 | OnMouseClick(MouseEventArgs) | Raises the MouseClick event. (Inherited from Control.)
 | OnMouseDoubleClick(MouseEventArgs) | Raises the MouseDoubleClick event. (Inherited from Control.)
 | OnMouseDown(MouseEventArgs) | Raises the MouseDown event. (Inherited from Control.)
 | OnMouseEnter(EventArgs) | Raises the MouseEnter event. (Inherited from Control.)
 | OnMouseHover(EventArgs) | Raises the MouseHover event. (Inherited from Control.)
 | OnMouseLeave(EventArgs) | Raises the MouseLeave event. (Inherited from Control.)
 | OnMouseMove(MouseEventArgs) | Raises the MouseMove event. (Inherited from Control.)
 | OnMouseUp(MouseEventArgs) | (Inherited from TextBoxBase.)
 | OnMouseWheel(MouseEventArgs) | Raises the MouseWheel event. (Inherited from Control.)
 | OnMove(EventArgs) | Raises the Move event. (Inherited from Control.)
 | OnMultilineChanged(EventArgs) | Raises the MultilineChanged event. (Inherited from TextBoxBase.)
 | OnNotifyMessage(Message) | Notifies the control of Windows messages. (Inherited from Control.)
 | OnPaddingChanged(EventArgs) | This method is not relevant for this class. (Inherited from TextBoxBase.)
 | OnPaint(PaintEventArgs) | Raises the Paint event. (Inherited from Control.)
 | OnPaintBackground(PaintEventArgs) | Paints the background of the control. (Inherited from Control.)
 | OnParentBackColorChanged(EventArgs) | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
 | OnParentBackgroundImageChanged(EventArgs) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
 | OnParentBindingContextChanged(EventArgs) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
 | OnParentChanged(EventArgs) | Raises the ParentChanged event. (Inherited from Control.)
 | OnParentCursorChanged(EventArgs) | Raises the CursorChanged event. (Inherited from Control.)
 | OnParentEnabledChanged(EventArgs) | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
 | OnParentFontChanged(EventArgs) | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
 | OnParentForeColorChanged(EventArgs) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
 | OnParentRightToLeftChanged(EventArgs) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
 | OnParentVisibleChanged(EventArgs) | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
 | OnPreviewKeyDown(PreviewKeyDownEventArgs) | Raises the PreviewKeyDown event. (Inherited from Control.)
 | OnPrint(PaintEventArgs) | Raises the Paint event. (Inherited from Control.)
 | OnProtected(EventArgs) | Raises the Protected event. (Inherited from RichTextBox.)
 | OnQueryContinueDrag(QueryContinueDragEventArgs) | Raises the QueryContinueDrag event. (Inherited from Control.)
 | OnReadOnlyChanged(EventArgs) | Raises the ReadOnlyChanged event. (Inherited from TextBoxBase.)
 | OnRegionChanged(EventArgs) | Raises the RegionChanged event. (Inherited from Control.)
 | OnResize(EventArgs) | Raises the Resize event. (Inherited from Control.)
 | OnRightToLeftChanged(EventArgs) | (Inherited from RichTextBox.)
 | OnSelectionChanged(EventArgs) | Raises the SelectionChanged event. (Inherited from RichTextBox.)
 | OnSizeChanged(EventArgs) | Raises the SizeChanged event. (Inherited from Control.)
 | OnStyleChanged(EventArgs) | Raises the StyleChanged event. (Inherited from Control.)
 | OnSystemColorsChanged(EventArgs) | Raises the SystemColorsChanged event. (Inherited from Control.)
 | OnTabIndexChanged(EventArgs) | Raises the TabIndexChanged event. (Inherited from Control.)
 | OnTabStopChanged(EventArgs) | Raises the TabStopChanged event. (Inherited from Control.)
 | OnTextChanged(EventArgs) | (Inherited from TextBoxBase.)
 | OnValidated(EventArgs) | Raises the Validated event. (Inherited from Control.)
 | OnValidating(CancelEventArgs) | Raises the Validating event. (Inherited from Control.)
 | OnVisibleChanged(EventArgs) | Raises the VisibleChanged event. (Inherited from Control.)
 | OnVScroll(EventArgs) | Raises the VScroll event. (Inherited from RichTextBox.)
 | Padding | This property is not relevant for this class. (Inherited from TextBoxBase.)
 | PaddingChanged | This event is not relevant for this class. (Inherited from TextBoxBase.)
 | Paint | Occurs when the control is redrawn. This event is not relevant for this class. (Inherited from TextBoxBase.)
 | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
 | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
 | Paste(DataFormats..::..Format) | Pastes the contents of the Clipboard in the specified Clipboard format. (Inherited from RichTextBox.)
 | Paste()()()() | Replaces the current selection in the text box with the contents of the Clipboard. (Inherited from TextBoxBase.)
 | Pasting | Occurs when text is about to be pasted.
 | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
 | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
 | PointToClient(Point) | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
 | PointToScreen(Point) | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
 | PreferredHeight | Gets the preferred height for a text box. (Inherited from TextBoxBase.)
 | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
 | PreProcessControlMessage(Message%) | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
 | PreProcessMessage(Message%) | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
 | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
 | ProcessCmdKey(Message%, Keys) | (Inherited from RichTextBox.)
 | ProcessDialogChar(Char) | Processes a dialog character. (Inherited from Control.)
 | ProcessDialogKey(Keys) | (Inherited from TextBoxBase.)
 | ProcessKeyEventArgs(Message%) | Processes a key message and generates the appropriate control events. (Inherited from Control.)
 | ProcessKeyMessage(Message%) | Processes a keyboard message. (Inherited from Control.)
 | ProcessKeyPreview(Message%) | Previews a keyboard message. (Inherited from Control.)
 | ProcessMnemonic(Char) | Processes a mnemonic character. (Inherited from Control.)
 | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
 | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
 | Protected | Occurs when the user attempts to modify protected text in the control. (Inherited from RichTextBox.)
 | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
 | QueryContinueDrag | This event is not relevant to this class. (Inherited from RichTextBox.)
 | RaiseDragEvent(Object, DragEventArgs) | Raises the appropriate drag event. (Inherited from Control.)
 | RaiseKeyEvent(Object, KeyEventArgs) | Raises the appropriate key event. (Inherited from Control.)
 | RaiseMouseEvent(Object, MouseEventArgs) | Raises the appropriate mouse event. (Inherited from Control.)
 | RaisePaintEvent(Object, PaintEventArgs) | Raises the appropriate paint event. (Inherited from Control.)
 | ReadOnly | Gets or sets a value indicating whether text in the text box is read-only. (Inherited from TextBoxBase.)
 | ReadOnlyChanged | Occurs when the value of the ReadOnly property has changed. (Inherited from TextBoxBase.)
 | RecreateHandle()()()() | Forces the re-creation of the handle for the control. (Inherited from Control.)
 | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
 | RectangleToClient(Rectangle) | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
 | RectangleToScreen(Rectangle) | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
 | Redo()()()() | Reapplies the last operation that was undone in the control. (Inherited from RichTextBox.)
 | RedoActionName | Gets the name of the action that can be reapplied to the control when the Redo()()()() method is called. (Inherited from RichTextBox.)
 | Refresh()()()() | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
 | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
 | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
 | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
 | RescaleConstantsForDpi(Int32, Int32) | (Inherited from Control.)
 | ResetBackColor()()()() | Resets the BackColor property to its default value. (Inherited from Control.)
 | ResetBindings()()()() | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
 | ResetCursor()()()() | Resets the Cursor property to its default value. (Inherited from Control.)
 | ResetFont()()()() | Resets the Font property to its default value. (Inherited from Control.)
 | ResetForeColor()()()() | Resets the ForeColor property to its default value. (Inherited from Control.)
 | ResetImeMode()()()() | Resets the ImeMode property to its default value. (Inherited from Control.)
 | ResetMouseEventArgs()()()() | Resets the control to handle the MouseLeave event. (Inherited from Control.)
 | ResetRightToLeft()()()() | Resets the RightToLeft property to its default value. (Inherited from Control.)
 | ResetText()()()() | Resets the Text property to its default value. (Inherited from Control.)
 | Resize | Occurs when the control is resized. (Inherited from Control.)
 | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
 | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
 | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
 | RichTextShortcutsEnabled | This property is not relevant for this class. (Inherited from RichTextBox.)
 | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
 | RightMargin | Gets or sets the size of a single line of text within the RichTextBox control. (Inherited from RichTextBox.)
 | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
 | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
 | Rtf | Gets or sets the text of the RichTextBox control, including all rich text format (RTF) codes. (Inherited from RichTextBox.)
 | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateContent(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateHorizontal(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateLeftRight(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
 | SaveFile(String) | Saves the contents of the RichTextBox to a rich text format (RTF) file. (Inherited from RichTextBox.)
 | SaveFile(String, RichTextBoxStreamType) | Saves the contents of the RichTextBox to a specific type of file. (Inherited from RichTextBox.)
 | SaveFile(Stream, RichTextBoxStreamType) | Saves the contents of a RichTextBox control to an open data stream. (Inherited from RichTextBox.)
 | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
 | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
 | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
 | ScaleBitmapLogicalToDevice(Bitmap%) | (Inherited from Control.)
 | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
 | ScaleControl(SizeF, BoundsSpecified) | Scales a control's location, size, padding and margin. (Inherited from Control.)
 | ScaleCore(Single, Single) | This method is not relevant for this class. (Inherited from Control.)
 | ScrollBars | Gets or sets the type of scroll bars to display in the RichTextBox control. (Inherited from RichTextBox.)
 | ScrollCaret | Occurs when the text box is scrolled to the caret.
 | ScrollToCaret()()()() | Scrolls the contents of the control to the current caret position. (Inherited from TextBoxBase.)
 | Select(Int32, Int32) | Selects a range of text in the text box. (Inherited from TextBoxBase.)
 | Select()()()() | Activates the control. (Inherited from Control.)
 | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
 | SelectAll()()()() | Selects all text in the text box. (Inherited from TextBoxBase.)
 | SelectedRtf | Gets or sets the currently selected rich text format (RTF) formatted text in the control. (Inherited from RichTextBox.)
 | SelectedText | Gets or sets the selected text within the RichTextBox. (Inherited from RichTextBox.)
 | SelectionAlignment | Gets or sets the alignment to apply to the current selection or insertion point. (Inherited from RichTextBox.)
 | SelectionBackColor | Gets or sets the color of text when the text is selected in a RichTextBox control. (Inherited from RichTextBox.)
 | SelectionBullet | Gets or sets a value indicating whether the bullet style is applied to the current selection or insertion point. (Inherited from RichTextBox.)
 | SelectionChanged | Occurs when the selection of text within the control has changed. (Inherited from RichTextBox.)
 | SelectionCharOffset | Gets or sets whether text in the control appears on the baseline, as a superscript, or as a subscript below the baseline. (Inherited from RichTextBox.)
 | SelectionColor | Gets or sets the text color of the current text selection or insertion point. (Inherited from RichTextBox.)
 | SelectionFont | Gets or sets the font of the current text selection or insertion point. (Inherited from RichTextBox.)
 | SelectionHangingIndent | Gets or sets the distance between the left edge of the first line of text in the selected paragraph and the left edge of subsequent lines in the same paragraph. (Inherited from RichTextBox.)
 | SelectionIndent | Gets or sets the length, in pixels, of the indentation of the line where the selection starts. (Inherited from RichTextBox.)
 | SelectionLength | Gets or sets the number of characters selected in control. (Inherited from RichTextBox.)
 | SelectionProtected | Gets or sets a value indicating whether the current text selection is protected. (Inherited from RichTextBox.)
 | SelectionRightIndent | The distance (in pixels) between the right edge of the RichTextBox control and the right edge of the text that is selected or added at the current insertion point. (Inherited from RichTextBox.)
 | SelectionStart | Gets or sets the starting point of text selected in the text box. (Inherited from TextBoxBase.)
 | SelectionTabs | Gets or sets the absolute tab stop positions in a RichTextBox control. (Inherited from RichTextBox.)
 | SelectionType | Gets the selection type within the control. (Inherited from RichTextBox.)
 | SelectNextControl(Control, Boolean, Boolean, Boolean, Boolean) | Activates the next control. (Inherited from Control.)
 | SendToBack()()()() | Sends the control to the back of the z-order. (Inherited from Control.)
 | SetAutoSizeMode(AutoSizeMode) | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
 | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
 | SetBoundsCore(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the TextBoxBase control. (Inherited from TextBoxBase.)
 | SetClientSizeCore(Int32, Int32) | Sets the size of the client area of the control. (Inherited from Control.)
 | SetStyle(ControlStyles, Boolean) | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
 | SetTopLevel(Boolean) | Sets the control as the top-level control. (Inherited from Control.)
 | SetVisibleCore(Boolean) | Sets the control to the specified visible state. (Inherited from Control.)
 | ShortcutsEnabled | Gets or sets a value indicating whether the defined shortcuts are enabled. (Inherited from TextBoxBase.)
 | Show()()()() | Displays the control to the user. (Inherited from Control.)
 | ShowCutCopyPasteContextMenu | Whether to show the standard Undo/Cut/Copy/Paste/Delete/Select All context menu.
 | ShowCutCopyPasteContextMenuStrip | Whether to show the standard Undo/Cut/Copy/Paste/Delete/Select All context menu strip.
 | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
 | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
 | ShowSelectionMargin | Gets or sets a value indicating whether a selection margin is displayed in the RichTextBox. (Inherited from RichTextBox.)
 | Site | Gets or sets the site of the control. (Inherited from Control.)
 | Size | Gets or sets the height and width of the control. (Inherited from Control.)
 | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
 | SizeFromClientSize(Size) | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
 | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
 | SuspendLayout()()()() | Temporarily suspends the layout logic for the control. (Inherited from Control.)
 | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
 | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
 | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
 | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
 | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
 | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
 | Text | The plain text in the text box. (Overrides RichTextBox.Text.)
 | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
 | TextLength | The length of plain text in the text box. (Overrides RichTextBox.TextLength.)
 | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
 | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
 | ToString()()()() | Returns a string that represents the TextBoxBase control. (Inherited from TextBoxBase.)
 | UnderlineYOffset | Controls the position of the underline relative to the baseline.
 | Undo()()()() | Undoes the last edit operation in the text box. (Inherited from TextBoxBase.)
 | UndoActionName | Gets the name of the action that can be undone in the control when the Undo()()()() method is called. (Inherited from RichTextBox.)
 | Update()()()() | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
 | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
 | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
 | UpdateStyles()()()() | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
 | UpdateZOrder()()()() | Updates the control in its parent's z-order. (Inherited from Control.)
 | UseAccurateBaselineOffsetMethod | Whether to calculate the baseline offset with the most accurate method (slower).
 | UseUndoCompatibleTextAccess | Whether to use a work around with RichTextBox that prevents undo information from being lost when the Text property is accessed.
 | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
 | Validated | Occurs when the control is finished validating. (Inherited from Control.)
 | Validating | Occurs when the control is validating. (Inherited from Control.)
 | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
 | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
 | VScroll | Occurs when the user clicks the vertical scroll bars of the control. (Inherited from RichTextBox.)
 | VScrolled | Event fired when vertical scroll changed (by anything).
 | VScrollEnd | Event fired when vertical scroll ends.
 | Width | Gets or sets the width of the control. (Inherited from Control.)
 | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
 | WndProc(Message%) | Handles WndProc events and dispatches new events. (Overrides RichTextBox.WndProc(Message%).)
 | WordWrap | Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary. (Inherited from TextBoxBase.)
 | ZoomFactor | Gets or sets the current zoom level of the RichTextBox. (Inherited from RichTextBox.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | Control
 |  |  |  | TextBoxBase
 |  |  |  |  | RichTextBox
 |  |  |  |  |  | AYTRichTextBox


AYTRichTextBox Constructor

Keyoti RapidSpell Desktop .NET API Docs
AYTRichTextBox Constructor
API ► Keyoti.RapidSpell ► AYTRichTextBox ► AYTRichTextBox()()()()
Keyoti RapidSpell Desktop .NET
Creates a new RichTextBox with "as-you-type" facility.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public AYTRichTextBox()
public AYTRichTextBox()
Public Sub New
Public Sub New
public:
AYTRichTextBox()
public:
AYTRichTextBox()
new : unit -> AYTRichTextBox
new : unit -> AYTRichTextBox


ContextMenuDefault Property

Keyoti RapidSpell Desktop .NET API Docs
ContextMenuDefault Property
API ► Keyoti.RapidSpell ► AYTRichTextBox ► ContextMenuDefault
Keyoti RapidSpell Desktop .NET
The context menu that will be shown when the right click is not on a misspelled word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual ContextMenu ContextMenuDefault { get; set; }
public virtual ContextMenu ContextMenuDefault { get; set; }
Public Overridable Property ContextMenuDefault As ContextMenu
    Get
    Set
Public Overridable Property ContextMenuDefault As ContextMenu
    Get
    Set
public:
virtual property ContextMenu^ ContextMenuDefault {
    ContextMenu^ get ();
    void set (ContextMenu^ value);
}
public:
virtual property ContextMenu^ ContextMenuDefault {
    ContextMenu^ get ();
    void set (ContextMenu^ value);
}
abstract ContextMenuDefault : ContextMenu with get, set
override ContextMenuDefault : ContextMenu with get, set
abstract ContextMenuDefault : ContextMenu with get, set
override ContextMenuDefault : ContextMenu with get, set
Property Value
ContextMenu


ContextMenuStrip Property

Keyoti RapidSpell Desktop .NET API Docs
ContextMenuStrip Property
API ► Keyoti.RapidSpell ► AYTRichTextBox ► ContextMenuStrip
Keyoti RapidSpell Desktop .NET
The context menu that will be shown when the right click is not on a misspelled word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override ContextMenuStrip ContextMenuStrip { get; set; }
public override ContextMenuStrip ContextMenuStrip { get; set; }
Public Overrides Property ContextMenuStrip As ContextMenuStrip
    Get
    Set
Public Overrides Property ContextMenuStrip As ContextMenuStrip
    Get
    Set
public:
virtual property ContextMenuStrip^ ContextMenuStrip {
    ContextMenuStrip^ get () override;
    void set (ContextMenuStrip^ value) override;
}
public:
virtual property ContextMenuStrip^ ContextMenuStrip {
    ContextMenuStrip^ get () override;
    void set (ContextMenuStrip^ value) override;
}
abstract ContextMenuStrip : ContextMenuStrip with get, set
override ContextMenuStrip : ContextMenuStrip with get, set
abstract ContextMenuStrip : ContextMenuStrip with get, set
override ContextMenuStrip : ContextMenuStrip with get, set
Property Value
ContextMenuStrip


ContextMenuStripDefault Property

Keyoti RapidSpell Desktop .NET API Docs
ContextMenuStripDefault Property
API ► Keyoti.RapidSpell ► AYTRichTextBox ► ContextMenuStripDefault
Keyoti RapidSpell Desktop .NET
The context menu that will be shown when the right click is not on a misspelled word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ContextMenuStrip ContextMenuStripDefault { get; set; }
public ContextMenuStrip ContextMenuStripDefault { get; set; }
Public Property ContextMenuStripDefault As ContextMenuStrip
    Get
    Set
Public Property ContextMenuStripDefault As ContextMenuStrip
    Get
    Set
public:
virtual property ContextMenuStrip^ ContextMenuStripDefault {
    ContextMenuStrip^ get () sealed;
    void set (ContextMenuStrip^ value) sealed;
}
public:
virtual property ContextMenuStrip^ ContextMenuStripDefault {
    ContextMenuStrip^ get () sealed;
    void set (ContextMenuStrip^ value) sealed;
}
abstract ContextMenuStripDefault : ContextMenuStrip with get, set
override ContextMenuStripDefault : ContextMenuStrip with get, set
abstract ContextMenuStripDefault : ContextMenuStrip with get, set
override ContextMenuStripDefault : ContextMenuStrip with get, set
Property Value
ContextMenuStrip


ControlBackgroundPaint Event

Keyoti RapidSpell Desktop .NET API Docs
ControlBackgroundPaint Event
API ► Keyoti.RapidSpell ► AYTRichTextBox ► ControlBackgroundPaint
Keyoti RapidSpell Desktop .NET
Event fired when Windows level background repaint occurs.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler ControlBackgroundPaint
public event EventHandler ControlBackgroundPaint
Public Event ControlBackgroundPaint As EventHandler
Public Event ControlBackgroundPaint As EventHandler
public:
 event EventHandler^ ControlBackgroundPaint {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
 event EventHandler^ ControlBackgroundPaint {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member ControlBackgroundPaint : IEvent<EventHandler,
    EventArgs>

member ControlBackgroundPaint : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


ControlPaint Event

Keyoti RapidSpell Desktop .NET API Docs
ControlPaint Event
API ► Keyoti.RapidSpell ► AYTRichTextBox ► ControlPaint
Keyoti RapidSpell Desktop .NET
Event fired when Windows level repaint occurs.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler ControlPaint
public event EventHandler ControlPaint
Public Event ControlPaint As EventHandler
Public Event ControlPaint As EventHandler
public:
virtual  event EventHandler^ ControlPaint {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ ControlPaint {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ControlPaint : IEvent<EventHandler,
    EventArgs>
override ControlPaint : IEvent<EventHandler,
    EventArgs>
abstract ControlPaint : IEvent<EventHandler,
    EventArgs>
override ControlPaint : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


DefaultContextMenu Property

Keyoti RapidSpell Desktop .NET API Docs
DefaultContextMenu Property
API ► Keyoti.RapidSpell ► AYTRichTextBox ► DefaultContextMenu
Keyoti RapidSpell Desktop .NET
Obsolete - Use ContextMenuDefault instead.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
[ObsoleteAttribute("Use ContextMenuDefault instead.")]
public virtual ContextMenu DefaultContextMenu { get; set; }
[ObsoleteAttribute("Use ContextMenuDefault instead.")]
public virtual ContextMenu DefaultContextMenu { get; set; }
<ObsoleteAttribute("Use ContextMenuDefault instead.")>
Public Overridable Property DefaultContextMenu As ContextMenu
    Get
    Set
<ObsoleteAttribute("Use ContextMenuDefault instead.")>
Public Overridable Property DefaultContextMenu As ContextMenu
    Get
    Set
public:
[ObsoleteAttribute(L"Use ContextMenuDefault instead.")]
virtual property ContextMenu^ DefaultContextMenu {
    ContextMenu^ get ();
    void set (ContextMenu^ value);
}
public:
[ObsoleteAttribute(L"Use ContextMenuDefault instead.")]
virtual property ContextMenu^ DefaultContextMenu {
    ContextMenu^ get ();
    void set (ContextMenu^ value);
}
[<ObsoleteAttribute("Use ContextMenuDefault instead.")>]
abstract DefaultContextMenu : ContextMenu with get, set
[<ObsoleteAttribute("Use ContextMenuDefault instead.")>]
override DefaultContextMenu : ContextMenu with get, set
[<ObsoleteAttribute("Use ContextMenuDefault instead.")>]
abstract DefaultContextMenu : ContextMenu with get, set
[<ObsoleteAttribute("Use ContextMenuDefault instead.")>]
override DefaultContextMenu : ContextMenu with get, set
Property Value
ContextMenu


FormatChanged Event

Keyoti RapidSpell Desktop .NET API Docs
FormatChanged Event
API ► Keyoti.RapidSpell ► AYTRichTextBox ► FormatChanged
Keyoti RapidSpell Desktop .NET
Event fired when formatting changes (such as font change).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler FormatChanged
public event EventHandler FormatChanged
Public Event FormatChanged As EventHandler
Public Event FormatChanged As EventHandler
public:
virtual  event EventHandler^ FormatChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ FormatChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract FormatChanged : IEvent<EventHandler,
    EventArgs>
override FormatChanged : IEvent<EventHandler,
    EventArgs>
abstract FormatChanged : IEvent<EventHandler,
    EventArgs>
override FormatChanged : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


GetBaselineOffsetAtCharIndex Method (i)

Keyoti RapidSpell Desktop .NET API Docs
GetBaselineOffsetAtCharIndex Method (i)
API ► Keyoti.RapidSpell ► AYTRichTextBox ► GetBaselineOffsetAtCharIndex(Int32)
Keyoti RapidSpell Desktop .NET
Gets the baseline offset for a character at index i
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int GetBaselineOffsetAtCharIndex(
    int i
)
public int GetBaselineOffsetAtCharIndex(
    int i
)
Public Function GetBaselineOffsetAtCharIndex (
    i As Integer
) As Integer
Public Function GetBaselineOffsetAtCharIndex (
    i As Integer
) As Integer
public:
virtual int GetBaselineOffsetAtCharIndex(
    int i
) sealed
public:
virtual int GetBaselineOffsetAtCharIndex(
    int i
) sealed
abstract GetBaselineOffsetAtCharIndex :
        i : int -> int
override GetBaselineOffsetAtCharIndex :
        i : int -> int
abstract GetBaselineOffsetAtCharIndex :
        i : int -> int
override GetBaselineOffsetAtCharIndex :
        i : int -> int
Parameters
i (Int32)
Return Value
Int32


GetCharIndexFromPos Method (pos)

Keyoti RapidSpell Desktop .NET API Docs
GetCharIndexFromPos Method (pos)
API ► Keyoti.RapidSpell ► AYTRichTextBox ► GetCharIndexFromPos(Point)
Keyoti RapidSpell Desktop .NET
gets the char index from a position point.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int GetCharIndexFromPos(
    Point pos
)
public int GetCharIndexFromPos(
    Point pos
)
Public Function GetCharIndexFromPos (
    pos As Point
) As Integer
Public Function GetCharIndexFromPos (
    pos As Point
) As Integer
public:
virtual int GetCharIndexFromPos(
    Point pos
) sealed
public:
virtual int GetCharIndexFromPos(
    Point pos
) sealed
abstract GetCharIndexFromPos :
        pos : Point -> int
override GetCharIndexFromPos :
        pos : Point -> int
abstract GetCharIndexFromPos :
        pos : Point -> int
override GetCharIndexFromPos :
        pos : Point -> int
Parameters
pos (Point)
Return Value
Int32


GetFirstVisibleCharIndex Method

Keyoti RapidSpell Desktop .NET API Docs
GetFirstVisibleCharIndex Method
API ► Keyoti.RapidSpell ► AYTRichTextBox ► GetFirstVisibleCharIndex()()()()
Keyoti RapidSpell Desktop .NET
Gets the character index of the first visible character in the window, this is for optimization and can just return 0 if unavailable.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int GetFirstVisibleCharIndex()
public int GetFirstVisibleCharIndex()
Public Function GetFirstVisibleCharIndex As Integer
Public Function GetFirstVisibleCharIndex As Integer
public:
virtual int GetFirstVisibleCharIndex() sealed
public:
virtual int GetFirstVisibleCharIndex() sealed
abstract GetFirstVisibleCharIndex : unit -> int
override GetFirstVisibleCharIndex : unit -> int
abstract GetFirstVisibleCharIndex : unit -> int
override GetFirstVisibleCharIndex : unit -> int
Return Value
Int32


GetPosFromCharIndex Method (ind)

Keyoti RapidSpell Desktop .NET API Docs
GetPosFromCharIndex Method (ind)
API ► Keyoti.RapidSpell ► AYTRichTextBox ► GetPosFromCharIndex(Int32)
Keyoti RapidSpell Desktop .NET
Gets the position point from the char index
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Point GetPosFromCharIndex(
    int ind
)
public Point GetPosFromCharIndex(
    int ind
)
Public Function GetPosFromCharIndex (
    ind As Integer
) As Point
Public Function GetPosFromCharIndex (
    ind As Integer
) As Point
public:
virtual Point GetPosFromCharIndex(
    int ind
) sealed
public:
virtual Point GetPosFromCharIndex(
    int ind
) sealed
abstract GetPosFromCharIndex :
        ind : int -> Point
override GetPosFromCharIndex :
        ind : int -> Point
abstract GetPosFromCharIndex :
        ind : int -> Point
override GetPosFromCharIndex :
        ind : int -> Point
Parameters
ind (Int32)
Return Value
Point


GetTBU Method

Keyoti RapidSpell Desktop .NET API Docs
GetTBU Method
API ► Keyoti.RapidSpell ► AYTRichTextBox ► GetTBU()()()()
Keyoti RapidSpell Desktop .NET
Interface requirement
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public TextBoxUtilityAdapter GetTBU()
public TextBoxUtilityAdapter GetTBU()
Public Function GetTBU As TextBoxUtilityAdapter
Public Function GetTBU As TextBoxUtilityAdapter
public:
virtual TextBoxUtilityAdapter^ GetTBU() sealed
public:
virtual TextBoxUtilityAdapter^ GetTBU() sealed
abstract GetTBU : unit -> TextBoxUtilityAdapter
override GetTBU : unit -> TextBoxUtilityAdapter
abstract GetTBU : unit -> TextBoxUtilityAdapter
override GetTBU : unit -> TextBoxUtilityAdapter
Return Value
TextBoxUtilityAdapter


HScrolled Event

Keyoti RapidSpell Desktop .NET API Docs
HScrolled Event
API ► Keyoti.RapidSpell ► AYTRichTextBox ► HScrolled
Keyoti RapidSpell Desktop .NET
Event fired when horizontal scroll changed (by anything).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler HScrolled
public event EventHandler HScrolled
Public Event HScrolled As EventHandler
Public Event HScrolled As EventHandler
public:
virtual  event EventHandler^ HScrolled {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ HScrolled {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract HScrolled : IEvent<EventHandler,
    EventArgs>
override HScrolled : IEvent<EventHandler,
    EventArgs>
abstract HScrolled : IEvent<EventHandler,
    EventArgs>
override HScrolled : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


OnHideSelectionChanged Method (e)

Keyoti RapidSpell Desktop .NET API Docs
OnHideSelectionChanged Method (e)
API ► Keyoti.RapidSpell ► AYTRichTextBox ► OnHideSelectionChanged(EventArgs)
Keyoti RapidSpell Desktop .NET
Fired when HideSelection changes
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override void OnHideSelectionChanged(
    EventArgs e
)
protected override void OnHideSelectionChanged(
    EventArgs e
)
Protected Overrides Sub OnHideSelectionChanged (
    e As EventArgs
)
Protected Overrides Sub OnHideSelectionChanged (
    e As EventArgs
)
protected:
virtual void OnHideSelectionChanged(
    EventArgs^ e
) override
protected:
virtual void OnHideSelectionChanged(
    EventArgs^ e
) override
abstract OnHideSelectionChanged :
        e : EventArgs -> unit
override OnHideSelectionChanged :
        e : EventArgs -> unit
abstract OnHideSelectionChanged :
        e : EventArgs -> unit
override OnHideSelectionChanged :
        e : EventArgs -> unit
Parameters
e (EventArgs)


Pasting Event

Keyoti RapidSpell Desktop .NET API Docs
Pasting Event
API ► Keyoti.RapidSpell ► AYTRichTextBox ► Pasting
Keyoti RapidSpell Desktop .NET
Occurs when text is about to be pasted.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler Pasting
public event EventHandler Pasting
Public Event Pasting As EventHandler
Public Event Pasting As EventHandler
public:
 event EventHandler^ Pasting {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
 event EventHandler^ Pasting {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member Pasting : IEvent<EventHandler,
    EventArgs>

member Pasting : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


ScrollCaret Event

Keyoti RapidSpell Desktop .NET API Docs
ScrollCaret Event
API ► Keyoti.RapidSpell ► AYTRichTextBox ► ScrollCaret
Keyoti RapidSpell Desktop .NET
Occurs when the text box is scrolled to the caret.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler ScrollCaret
public event EventHandler ScrollCaret
Public Event ScrollCaret As EventHandler
Public Event ScrollCaret As EventHandler
public:
virtual  event EventHandler^ ScrollCaret {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ ScrollCaret {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ScrollCaret : IEvent<EventHandler,
    EventArgs>
override ScrollCaret : IEvent<EventHandler,
    EventArgs>
abstract ScrollCaret : IEvent<EventHandler,
    EventArgs>
override ScrollCaret : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


ShowCutCopyPasteContextMenu Property

Keyoti RapidSpell Desktop .NET API Docs
ShowCutCopyPasteContextMenu Property
API ► Keyoti.RapidSpell ► AYTRichTextBox ► ShowCutCopyPasteContextMenu
Keyoti RapidSpell Desktop .NET
Whether to show the standard Undo/Cut/Copy/Paste/Delete/Select All context menu.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ShowCutCopyPasteContextMenu { get; set; }
public bool ShowCutCopyPasteContextMenu { get; set; }
Public Property ShowCutCopyPasteContextMenu As Boolean
    Get
    Set
Public Property ShowCutCopyPasteContextMenu As Boolean
    Get
    Set
public:
property bool ShowCutCopyPasteContextMenu {
    bool get ();
    void set (bool value);
}
public:
property bool ShowCutCopyPasteContextMenu {
    bool get ();
    void set (bool value);
}
member ShowCutCopyPasteContextMenu : bool with get, set

member ShowCutCopyPasteContextMenu : bool with get, set
Property Value
Boolean


ShowCutCopyPasteContextMenuStrip Property

Keyoti RapidSpell Desktop .NET API Docs
ShowCutCopyPasteContextMenuStrip Property
API ► Keyoti.RapidSpell ► AYTRichTextBox ► ShowCutCopyPasteContextMenuStrip
Keyoti RapidSpell Desktop .NET
Whether to show the standard Undo/Cut/Copy/Paste/Delete/Select All context menu strip.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool ShowCutCopyPasteContextMenuStrip { get; set; }
public virtual bool ShowCutCopyPasteContextMenuStrip { get; set; }
Public Overridable Property ShowCutCopyPasteContextMenuStrip As Boolean
    Get
    Set
Public Overridable Property ShowCutCopyPasteContextMenuStrip As Boolean
    Get
    Set
public:
virtual property bool ShowCutCopyPasteContextMenuStrip {
    bool get ();
    void set (bool value);
}
public:
virtual property bool ShowCutCopyPasteContextMenuStrip {
    bool get ();
    void set (bool value);
}
abstract ShowCutCopyPasteContextMenuStrip : bool with get, set
override ShowCutCopyPasteContextMenuStrip : bool with get, set
abstract ShowCutCopyPasteContextMenuStrip : bool with get, set
override ShowCutCopyPasteContextMenuStrip : bool with get, set
Property Value
Boolean


Text Property

Keyoti RapidSpell Desktop .NET API Docs
Text Property
API ► Keyoti.RapidSpell ► AYTRichTextBox ► Text
Keyoti RapidSpell Desktop .NET
The plain text in the text box.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override string Text { get; set; }
public override string Text { get; set; }
Public Overrides Property Text As String
    Get
    Set
Public Overrides Property Text As String
    Get
    Set
public:
virtual property String^ Text {
    String^ get () override;
    void set (String^ value) override;
}
public:
virtual property String^ Text {
    String^ get () override;
    void set (String^ value) override;
}
abstract Text : string with get, set
override Text : string with get, set
abstract Text : string with get, set
override Text : string with get, set
Property Value
String


TextLength Property

Keyoti RapidSpell Desktop .NET API Docs
TextLength Property
API ► Keyoti.RapidSpell ► AYTRichTextBox ► TextLength
Keyoti RapidSpell Desktop .NET
The length of plain text in the text box.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override int TextLength { get; }
public override int TextLength { get; }
Public Overrides ReadOnly Property TextLength As Integer
    Get
Public Overrides ReadOnly Property TextLength As Integer
    Get
public:
virtual property int TextLength {
    int get () override;
}
public:
virtual property int TextLength {
    int get () override;
}
abstract TextLength : int with get
override TextLength : int with get
abstract TextLength : int with get
override TextLength : int with get
Property Value
Int32


UnderlineYOffset Property

Keyoti RapidSpell Desktop .NET API Docs
UnderlineYOffset Property
API ► Keyoti.RapidSpell ► AYTRichTextBox ► UnderlineYOffset
Keyoti RapidSpell Desktop .NET
Controls the position of the underline relative to the baseline.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int UnderlineYOffset { get; set; }
public int UnderlineYOffset { get; set; }
Public Property UnderlineYOffset As Integer
    Get
    Set
Public Property UnderlineYOffset As Integer
    Get
    Set
public:
property int UnderlineYOffset {
    int get ();
    void set (int value);
}
public:
property int UnderlineYOffset {
    int get ();
    void set (int value);
}
member UnderlineYOffset : int with get, set

member UnderlineYOffset : int with get, set
Property Value
Int32


UseAccurateBaselineOffsetMethod Property

Keyoti RapidSpell Desktop .NET API Docs
UseAccurateBaselineOffsetMethod Property
API ► Keyoti.RapidSpell ► AYTRichTextBox ► UseAccurateBaselineOffsetMethod
Keyoti RapidSpell Desktop .NET
Whether to calculate the baseline offset with the most accurate method (slower).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool UseAccurateBaselineOffsetMethod { get; set; }
public bool UseAccurateBaselineOffsetMethod { get; set; }
Public Property UseAccurateBaselineOffsetMethod As Boolean
    Get
    Set
Public Property UseAccurateBaselineOffsetMethod As Boolean
    Get
    Set
public:
property bool UseAccurateBaselineOffsetMethod {
    bool get ();
    void set (bool value);
}
public:
property bool UseAccurateBaselineOffsetMethod {
    bool get ();
    void set (bool value);
}
member UseAccurateBaselineOffsetMethod : bool with get, set

member UseAccurateBaselineOffsetMethod : bool with get, set
Property Value
Boolean


UseUndoCompatibleTextAccess Property

Keyoti RapidSpell Desktop .NET API Docs
UseUndoCompatibleTextAccess Property
API ► Keyoti.RapidSpell ► AYTRichTextBox ► UseUndoCompatibleTextAccess
Keyoti RapidSpell Desktop .NET
Whether to use a work around with RichTextBox that prevents undo information from being lost when the Text property is accessed.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool UseUndoCompatibleTextAccess { get; set; }
public bool UseUndoCompatibleTextAccess { get; set; }
Public Property UseUndoCompatibleTextAccess As Boolean
    Get
    Set
Public Property UseUndoCompatibleTextAccess As Boolean
    Get
    Set
public:
property bool UseUndoCompatibleTextAccess {
    bool get ();
    void set (bool value);
}
public:
property bool UseUndoCompatibleTextAccess {
    bool get ();
    void set (bool value);
}
member UseUndoCompatibleTextAccess : bool with get, set

member UseUndoCompatibleTextAccess : bool with get, set
Property Value
Boolean
Remarks
The side effect of using this work around is the .Text property will now return '\r' instead of '\n' (which .Text will return if this property is false) at new-lines. If your code requires \n for newlines, please be careful with this property, setting this to true could break your code.


VScrolled Event

Keyoti RapidSpell Desktop .NET API Docs
VScrolled Event
API ► Keyoti.RapidSpell ► AYTRichTextBox ► VScrolled
Keyoti RapidSpell Desktop .NET
Event fired when vertical scroll changed (by anything).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler VScrolled
public event EventHandler VScrolled
Public Event VScrolled As EventHandler
Public Event VScrolled As EventHandler
public:
virtual  event EventHandler^ VScrolled {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ VScrolled {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract VScrolled : IEvent<EventHandler,
    EventArgs>
override VScrolled : IEvent<EventHandler,
    EventArgs>
abstract VScrolled : IEvent<EventHandler,
    EventArgs>
override VScrolled : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


VScrollEnd Event

Keyoti RapidSpell Desktop .NET API Docs
VScrollEnd Event
API ► Keyoti.RapidSpell ► AYTRichTextBox ► VScrollEnd
Keyoti RapidSpell Desktop .NET
Event fired when vertical scroll ends.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler VScrollEnd
public event EventHandler VScrollEnd
Public Event VScrollEnd As EventHandler
Public Event VScrollEnd As EventHandler
public:
virtual  event EventHandler^ VScrollEnd {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ VScrollEnd {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract VScrollEnd : IEvent<EventHandler,
    EventArgs>
override VScrollEnd : IEvent<EventHandler,
    EventArgs>
abstract VScrollEnd : IEvent<EventHandler,
    EventArgs>
override VScrollEnd : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


WndProc Method (m)

Keyoti RapidSpell Desktop .NET API Docs
WndProc Method (m)
API ► Keyoti.RapidSpell ► AYTRichTextBox ► WndProc(Message%)
Keyoti RapidSpell Desktop .NET
Handles WndProc events and dispatches new events.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override void WndProc(
    ref Message m
)
protected override void WndProc(
    ref Message m
)
Protected Overrides Sub WndProc (
    ByRef m As Message
)
Protected Overrides Sub WndProc (
    ByRef m As Message
)
protected:
virtual void WndProc(
    Message% m
) override
protected:
virtual void WndProc(
    Message% m
) override
abstract WndProc :
        m : Message byref -> unit
override WndProc :
        m : Message byref -> unit
abstract WndProc :
        m : Message byref -> unit
override WndProc :
        m : Message byref -> unit
Parameters
m (Message %)


AYTTextBox Class

Keyoti RapidSpell Desktop .NET API Docs
AYTTextBox Class
API ► Keyoti.RapidSpell ► AYTTextBox
Keyoti RapidSpell Desktop .NET
As-You-Type enabled TextBox.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class AYTTextBox : TextBox, IAYTTextBox
public class AYTTextBox : TextBox, IAYTTextBox
Public Class AYTTextBox
    Inherits TextBox
    Implements IAYTTextBox
Public Class AYTTextBox
    Inherits TextBox
    Implements IAYTTextBox
public ref class AYTTextBox : public TextBox,
    IAYTTextBox
public ref class AYTTextBox : public TextBox,
    IAYTTextBox
type AYTTextBox =
    class
        inherit TextBox
        interface IAYTTextBox
    end
type AYTTextBox =
    class
        inherit TextBox
        interface IAYTTextBox
    end
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AYTTextBox()()()() | Creates a new TextBox with "as-you-type" facility.
 | AcceptsReturn | Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form. (Inherited from TextBox.)
 | AcceptsTab | Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order. (Inherited from TextBoxBase.)
 | AcceptsTabChanged | Occurs when the value of the AcceptsTab property has changed. (Inherited from TextBoxBase.)
 | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
 | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
 | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
 | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
 | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
 | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
 | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
 | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
 | AppendText(String) | Appends text to the current text of a text box. (Inherited from TextBoxBase.)
 | AutoCompleteCustomSource | Gets or sets a custom StringCollection to use when the AutoCompleteSource property is set to CustomSource. (Inherited from TextBox.)
 | AutoCompleteMode | Gets or sets an option that controls how automatic completion works for the TextBox. (Inherited from TextBox.)
 | AutoCompleteSource | Gets or sets a value specifying the source of complete strings used for automatic completion. (Inherited from TextBox.)
 | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
 | AutoSize | Gets or sets a value indicating whether the height of the control automatically adjusts when the font assigned to the control is changed. (Inherited from TextBoxBase.)
 | AutoSizeChanged | This event is not relevant for this class. (Inherited from TextBoxBase.)
 | BackColor | Gets or sets the background color of the control. (Inherited from TextBoxBase.)
 | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
 | BackgroundImage | This property is not relevant for this class. (Inherited from TextBoxBase.)
 | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. This event is not relevant for this class. (Inherited from TextBoxBase.)
 | BackgroundImageLayout | This property is not relevant for this class. (Inherited from TextBoxBase.)
 | BackgroundImageLayoutChanged | Occurs when the value of the BackgroundImageLayout property changes. This event is not relevant for this class. (Inherited from TextBoxBase.)
 | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
 | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
 | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
 | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
 | BorderStyle | Gets or sets the border type of the text box control. (Inherited from TextBoxBase.)
 | BorderStyleChanged | Occurs when the value of the BorderStyle property has changed. (Inherited from TextBoxBase.)
 | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
 | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
 | BringToFront()()()() | Brings the control to the front of the z-order. (Inherited from Control.)
 | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from TextBoxBase.)
 | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
 | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
 | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
 | CanUndo | Gets a value indicating whether the user can undo the previous operation in a text box control. (Inherited from TextBoxBase.)
 | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
 | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
 | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
 | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
 | CharacterCasing | Gets or sets whether the TextBox control modifies the case of characters as they are typed. (Inherited from TextBox.)
 | Clear()()()() | Clears all text from the text box control. (Inherited from TextBoxBase.)
 | ClearUndo()()()() | Clears information about the most recent operation from the undo buffer of the text box. (Inherited from TextBoxBase.)
 | Click | Occurs when the text box is clicked. (Inherited from TextBoxBase.)
 | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
 | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
 | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
 | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | Contains(Control) | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
 | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
 | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
 | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
 | ContextMenuDefault | The context menu that will be shown when the right click is not on a misspelled word.
 | ContextMenuStrip | The context menu that will be shown when the right click is not on a misspelled word. (Overrides Control.ContextMenuStrip.)
 | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
 | ContextMenuStripDefault | The context menu that will be shown when the right click is not on a misspelled word.
 | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
 | ControlBackgroundPaint | Event fired when Windows level background repaint occurs.
 | ControlPaint | Event fired when Windows level repaint occurs.
 | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
 | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
 | Copy()()()() | Copies the current selection in the text box to the Clipboard. (Inherited from TextBoxBase.)
 | CreateAccessibilityInstance()()()() | Creates a new accessibility object for the control. (Inherited from Control.)
 | CreateControl()()()() | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
 | CreateControlsInstance()()()() | Creates a new instance of the control collection for the control. (Inherited from Control.)
 | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
 | CreateGraphics()()()() | Creates the Graphics for the control. (Inherited from Control.)
 | CreateHandle()()()() | (Inherited from TextBoxBase.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateParams | (Inherited from TextBox.)
 | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
 | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
 | Cut()()()() | Moves the current selection in the text box to the Clipboard. (Inherited from TextBoxBase.)
 | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
 | DefaultContextMenu | Obsolete. Obsolete - Use ContextMenuDefault instead.
 | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from TextBoxBase.)
 | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
 | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
 | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
 | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
 | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
 | DefaultSize | (Inherited from TextBoxBase.)
 | DefWndProc(Message%) | Sends the specified message to the default window procedure. (Inherited from Control.)
 | DeselectAll()()()() | Specifies that the value of the SelectionLength property is zero so that no characters are selected in the control. (Inherited from TextBoxBase.)
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | DestroyHandle()()()() | Destroys the handle associated with the control. (Inherited from Control.)
 | DeviceDpi()()()() | (Inherited from Control.)
 | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
 | Dispose(Boolean) | Releases the unmanaged resources used by the TextBox and optionally releases the managed resources. (Inherited from TextBox.)
 | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
 | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
 | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
 | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
 | DoDragDrop(Object, DragDropEffects) | Begins a drag-and-drop operation. (Inherited from Control.)
 | DoubleBuffered | Gets or sets a value indicating whether control drawing is done in a buffer before the control is displayed. This property is not relevant for this class. (Inherited from TextBoxBase.)
 | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
 | DpiChangedAfterParent()()()() | (Inherited from Control.)
 | DpiChangedBeforeParent()()()() | (Inherited from Control.)
 | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
 | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
 | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
 | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
 | DrawToBitmap(Bitmap, Rectangle) | Supports rendering to the specified bitmap. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
 | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
 | EndInvoke(IAsyncResult) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
 | Enter | Occurs when the control is entered. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | Finalize()()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | FindForm()()()() | Retrieves the form that the control is on. (Inherited from Control.)
 | Focus()()()() | Sets input focus to the control. (Inherited from Control.)
 | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
 | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
 | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
 | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color of the control. (Inherited from TextBoxBase.)
 | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
 | FormatChanged | Event fired when formatting changes (such as font change).
 | GetAccessibilityObjectById(Int32) | Retrieves the specified AccessibleObject. (Inherited from Control.)
 | GetAutoSizeMode()()()() | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
 | GetBaselineOffsetAtCharIndex(Int32) | Gets the baseline offset for a character at index i
 | GetCharFromPosition(Point) | Retrieves the character that is closest to the specified location within the control. (Inherited from TextBoxBase.)
 | GetCharIndexFromPos(Point) | gets the char index from a position point.
 | GetCharIndexFromPosition(Point) | Retrieves the index of the character nearest to the specified location. (Inherited from TextBoxBase.)
 | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
 | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
 | GetContainerControl()()()() | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
 | GetFirstCharIndexFromLine(Int32) | Retrieves the index of the first character of a given line. (Inherited from TextBoxBase.)
 | GetFirstCharIndexOfCurrentLine()()()() | Retrieves the index of the first character of the current line. (Inherited from TextBoxBase.)
 | GetFirstVisibleCharIndex()()()() | Gets the character index of the first visible character in the window, this is for optimization and can just return 0 if unavailable.
 | GetFocusOnContextMenu | Whether to get focus when the user activates the context menu.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetLineFromCharIndex(Int32) | Retrieves the line number from the specified character position within the text of the control. (Inherited from TextBoxBase.)
 | GetNextControl(Control, Boolean) | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
 | GetPosFromCharIndex(Int32) | Gets the position point from the char index
 | GetPositionFromCharIndex(Int32) | Retrieves the location within the control at the specified character index. (Inherited from TextBoxBase.)
 | GetPreferredSize(Size) | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
 | GetScaledBounds(Rectangle, SizeF, BoundsSpecified) | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetStyle(ControlStyles) | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
 | GetTBU()()()() | Interface requirement
 | GetTopLevel()()()() | Determines if the control is a top-level control. (Inherited from Control.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
 | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
 | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
 | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
 | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
 | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the control. (Inherited from Control.)
 | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
 | Hide()()()() | Conceals the control from the user. (Inherited from Control.)
 | HideSelection | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus. (Inherited from TextBoxBase.)
 | HideSelectionChanged | Occurs when the value of the HideSelection property has changed. (Inherited from TextBoxBase.)
 | HScrolled | Event fired when horizontal scroll changed (by anything).
 | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
 | ImeModeBase | (Inherited from TextBoxBase.)
 | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | InitLayout()()()() | Called after the control has been added to another container. (Inherited from Control.)
 | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
 | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
 | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
 | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
 | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
 | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
 | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
 | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
 | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
 | InvokeGotFocus(Control, EventArgs) | Raises the GotFocus event for the specified control. (Inherited from Control.)
 | InvokeLostFocus(Control, EventArgs) | Raises the LostFocus event for the specified control. (Inherited from Control.)
 | InvokeOnClick(Control, EventArgs) | Raises the Click event for the specified control. (Inherited from Control.)
 | InvokePaint(Control, PaintEventArgs) | Raises the Paint event for the specified control. (Inherited from Control.)
 | InvokePaintBackground(Control, PaintEventArgs) | Raises the PaintBackground event for the specified control. (Inherited from Control.)
 | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
 | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
 | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
 | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
 | IsInputChar(Char) | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
 | IsInputKey(Keys) | Determines whether the specified key is an input key or a special key that requires preprocessing. (Inherited from TextBox.)
 | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
 | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
 | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
 | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
 | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
 | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
 | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
 | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
 | Lines | Gets or sets the lines of text in a text box control. (Inherited from TextBoxBase.)
 | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
 | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
 | LogicalToDeviceUnits(Int32) | (Inherited from Control.)
 | LogicalToDeviceUnits(Size) | (Inherited from Control.)
 | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
 | Margin | Gets or sets the space between controls. (Inherited from Control.)
 | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
 | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
 | MaxLength | Gets or sets the maximum number of characters the user can type or paste into the text box control. (Inherited from TextBoxBase.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
 | Modified | Gets or sets a value that indicates that the text box control has been modified by the user since the control was created or its contents were last set. (Inherited from TextBoxBase.)
 | ModifiedChanged | Occurs when the value of the Modified property has changed. (Inherited from TextBoxBase.)
 | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
 | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from TextBoxBase.)
 | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
 | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
 | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
 | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
 | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
 | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
 | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
 | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
 | Move | Occurs when the control is moved. (Inherited from Control.)
 | Multiline | Gets or sets a value indicating whether this is a multiline TextBox control. (Inherited from TextBox.)
 | MultilineChanged | Occurs when the value of the Multiline property has changed. (Inherited from TextBoxBase.)
 | Name | Gets or sets the name of the control. (Inherited from Control.)
 | NotifyInvalidate(Rectangle) | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
 | OnAcceptsTabChanged(EventArgs) | Raises the AcceptsTabChanged event. (Inherited from TextBoxBase.)
 | OnAutoSizeChanged(EventArgs) | Raises the AutoSizeChanged event. (Inherited from Control.)
 | OnBackColorChanged(EventArgs) | Raises the BackColorChanged event. (Inherited from TextBox.)
 | OnBackgroundImageChanged(EventArgs) | Raises the BackgroundImageChanged event. (Inherited from Control.)
 | OnBackgroundImageLayoutChanged(EventArgs) | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
 | OnBindingContextChanged(EventArgs) | Raises the BindingContextChanged event. (Inherited from Control.)
 | OnBorderStyleChanged(EventArgs) | Raises the BorderStyleChanged event. (Inherited from TextBoxBase.)
 | OnCausesValidationChanged(EventArgs) | Raises the CausesValidationChanged event. (Inherited from Control.)
 | OnChangeUICues(UICuesEventArgs) | Raises the ChangeUICues event. (Inherited from Control.)
 | OnClick(EventArgs) | Raises the Click event. (Inherited from Control.)
 | OnClientSizeChanged(EventArgs) | Raises the ClientSizeChanged event. (Inherited from Control.)
 | OnContextMenuChanged(EventArgs) | Raises the ContextMenuChanged event. (Inherited from Control.)
 | OnContextMenuStripChanged(EventArgs) | Raises the ContextMenuStripChanged event. (Inherited from Control.)
 | OnControlAdded(ControlEventArgs) | Raises the ControlAdded event. (Inherited from Control.)
 | OnControlRemoved(ControlEventArgs) | Raises the ControlRemoved event. (Inherited from Control.)
 | OnCreateControl()()()() | Raises the CreateControl()()()() method. (Inherited from Control.)
 | OnCursorChanged(EventArgs) | Raises the CursorChanged event. (Inherited from Control.)
 | OnDockChanged(EventArgs) | Raises the DockChanged event. (Inherited from Control.)
 | OnDoubleClick(EventArgs) | Raises the DoubleClick event. (Inherited from Control.)
 | OnDpiChangedAfterParent(EventArgs) | (Inherited from Control.)
 | OnDpiChangedBeforeParent(EventArgs) | (Inherited from Control.)
 | OnDragDrop(DragEventArgs) | Raises the DragDrop event. (Inherited from Control.)
 | OnDragEnter(DragEventArgs) | Raises the DragEnter event. (Inherited from Control.)
 | OnDragLeave(EventArgs) | Raises the DragLeave event. (Inherited from Control.)
 | OnDragOver(DragEventArgs) | Raises the DragOver event. (Inherited from Control.)
 | OnEnabledChanged(EventArgs) | Raises the EnabledChanged event. (Inherited from Control.)
 | OnEnter(EventArgs) | Raises the Enter event. (Inherited from Control.)
 | OnFontChanged(EventArgs) | Raises the FontChanged event. (Inherited from TextBox.)
 | OnForeColorChanged(EventArgs) | Raises the ForeColorChanged event. (Inherited from Control.)
 | OnGiveFeedback(GiveFeedbackEventArgs) | Raises the GiveFeedback event. (Inherited from Control.)
 | OnGotFocus(EventArgs) | Raises the GotFocus event. (Inherited from TextBox.)
 | OnHandleCreated(EventArgs) | (Inherited from TextBox.)
 | OnHandleDestroyed(EventArgs) | Raises the OnHandleDestroyed(EventArgs) event. (Inherited from TextBox.)
 | OnHelpRequested(HelpEventArgs) | Raises the HelpRequested event. (Inherited from Control.)
 | OnHideSelectionChanged(EventArgs) | Raise the HideSelectionChanged event. (Inherited from TextBoxBase.)
 | OnImeModeChanged(EventArgs) | Raises the ImeModeChanged event. (Inherited from Control.)
 | OnInvalidated(InvalidateEventArgs) | Raises the Invalidated event. (Inherited from Control.)
 | OnKeyDown(KeyEventArgs) | Raises the KeyDown event. (Inherited from Control.)
 | OnKeyPress(KeyPressEventArgs) | Raises the KeyPress event. (Inherited from Control.)
 | OnKeyUp(KeyEventArgs) | Raises the KeyUp event. (Inherited from Control.)
 | OnLayout(LayoutEventArgs) | Raises the Layout event. (Inherited from Control.)
 | OnLeave(EventArgs) | Raises the Leave event. (Inherited from Control.)
 | OnLocationChanged(EventArgs) | Raises the LocationChanged event. (Inherited from Control.)
 | OnLostFocus(EventArgs) | Raises the LostFocus event. (Inherited from Control.)
 | OnMarginChanged(EventArgs) | Raises the MarginChanged event. (Inherited from Control.)
 | OnModifiedChanged(EventArgs) | Raises the ModifiedChanged event. (Inherited from TextBoxBase.)
 | OnMouseCaptureChanged(EventArgs) | Raises the MouseCaptureChanged event. (Inherited from Control.)
 | OnMouseClick(MouseEventArgs) | Raises the MouseClick event. (Inherited from Control.)
 | OnMouseDoubleClick(MouseEventArgs) | Raises the MouseDoubleClick event. (Inherited from Control.)
 | OnMouseDown(MouseEventArgs) | Raises the MouseDown event. (Inherited from Control.)
 | OnMouseEnter(EventArgs) | Raises the MouseEnter event. (Inherited from Control.)
 | OnMouseHover(EventArgs) | Raises the MouseHover event. (Inherited from Control.)
 | OnMouseLeave(EventArgs) | Raises the MouseLeave event. (Inherited from Control.)
 | OnMouseMove(MouseEventArgs) | Raises the MouseMove event. (Inherited from Control.)
 | OnMouseUp(MouseEventArgs) | (Inherited from TextBoxBase.)
 | OnMouseWheel(MouseEventArgs) | Raises the MouseWheel event. (Inherited from Control.)
 | OnMove(EventArgs) | Raises the Move event. (Inherited from Control.)
 | OnMultilineChanged(EventArgs) | Raises the MultilineChanged event. (Inherited from TextBoxBase.)
 | OnNotifyMessage(Message) | Notifies the control of Windows messages. (Inherited from Control.)
 | OnPaddingChanged(EventArgs) | This method is not relevant for this class. (Inherited from TextBoxBase.)
 | OnPaint(PaintEventArgs) | Raises the Paint event. (Inherited from Control.)
 | OnPaintBackground(PaintEventArgs) | Paints the background of the control. (Inherited from Control.)
 | OnParentBackColorChanged(EventArgs) | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
 | OnParentBackgroundImageChanged(EventArgs) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
 | OnParentBindingContextChanged(EventArgs) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
 | OnParentChanged(EventArgs) | Raises the ParentChanged event. (Inherited from Control.)
 | OnParentCursorChanged(EventArgs) | Raises the CursorChanged event. (Inherited from Control.)
 | OnParentEnabledChanged(EventArgs) | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
 | OnParentFontChanged(EventArgs) | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
 | OnParentForeColorChanged(EventArgs) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
 | OnParentRightToLeftChanged(EventArgs) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
 | OnParentVisibleChanged(EventArgs) | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
 | OnPreviewKeyDown(PreviewKeyDownEventArgs) | Raises the PreviewKeyDown event. (Inherited from Control.)
 | OnPrint(PaintEventArgs) | Raises the Paint event. (Inherited from Control.)
 | OnQueryContinueDrag(QueryContinueDragEventArgs) | Raises the QueryContinueDrag event. (Inherited from Control.)
 | OnReadOnlyChanged(EventArgs) | Raises the ReadOnlyChanged event. (Inherited from TextBoxBase.)
 | OnRegionChanged(EventArgs) | Raises the RegionChanged event. (Inherited from Control.)
 | OnResize(EventArgs) | Raises the Resize event. (Inherited from Control.)
 | OnRightToLeftChanged(EventArgs) | Raises the RightToLeftChanged event. (Inherited from Control.)
 | OnSizeChanged(EventArgs) | Raises the SizeChanged event. (Inherited from Control.)
 | OnStyleChanged(EventArgs) | Raises the StyleChanged event. (Inherited from Control.)
 | OnSystemColorsChanged(EventArgs) | Raises the SystemColorsChanged event. (Inherited from Control.)
 | OnTabIndexChanged(EventArgs) | Raises the TabIndexChanged event. (Inherited from Control.)
 | OnTabStopChanged(EventArgs) | Raises the TabStopChanged event. (Inherited from Control.)
 | OnTextAlignChanged(EventArgs) | Raises the TextAlignChanged event. (Inherited from TextBox.)
 | OnTextChanged(EventArgs) | (Inherited from TextBoxBase.)
 | OnValidated(EventArgs) | Raises the Validated event. (Inherited from Control.)
 | OnValidating(CancelEventArgs) | Raises the Validating event. (Inherited from Control.)
 | OnVisibleChanged(EventArgs) | Raises the VisibleChanged event. (Inherited from Control.)
 | Padding | This property is not relevant for this class. (Inherited from TextBoxBase.)
 | PaddingChanged | This event is not relevant for this class. (Inherited from TextBoxBase.)
 | Paint | Occurs when the control is redrawn. This event is not relevant for this class. (Inherited from TextBoxBase.)
 | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
 | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
 | PasswordChar | Gets or sets the character used to mask characters of a password in a single-line TextBox control. (Inherited from TextBox.)
 | Paste(String) | Sets the selected text to the specified text without clearing the undo buffer. (Inherited from TextBox.)
 | Paste()()()() | Replaces the current selection in the text box with the contents of the Clipboard. (Inherited from TextBoxBase.)
 | Pasting | Occurs when text is about to be pasted.
 | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
 | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
 | PointToClient(Point) | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
 | PointToScreen(Point) | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
 | PreferredHeight | Gets the preferred height for a text box. (Inherited from TextBoxBase.)
 | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
 | PreProcessControlMessage(Message%) | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
 | PreProcessMessage(Message%) | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
 | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
 | ProcessCmdKey(Message%, Keys) | (Inherited from TextBox.)
 | ProcessDialogChar(Char) | Processes a dialog character. (Inherited from Control.)
 | ProcessDialogKey(Keys) | (Inherited from TextBoxBase.)
 | ProcessKeyEventArgs(Message%) | Processes a key message and generates the appropriate control events. (Inherited from Control.)
 | ProcessKeyMessage(Message%) | Processes a keyboard message. (Inherited from Control.)
 | ProcessKeyPreview(Message%) | Previews a keyboard message. (Inherited from Control.)
 | ProcessMnemonic(Char) | Processes a mnemonic character. (Inherited from Control.)
 | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
 | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
 | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
 | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
 | RaiseDragEvent(Object, DragEventArgs) | Raises the appropriate drag event. (Inherited from Control.)
 | RaiseKeyEvent(Object, KeyEventArgs) | Raises the appropriate key event. (Inherited from Control.)
 | RaiseMouseEvent(Object, MouseEventArgs) | Raises the appropriate mouse event. (Inherited from Control.)
 | RaisePaintEvent(Object, PaintEventArgs) | Raises the appropriate paint event. (Inherited from Control.)
 | ReadOnly | Gets or sets a value indicating whether text in the text box is read-only. (Inherited from TextBoxBase.)
 | ReadOnlyChanged | Occurs when the value of the ReadOnly property has changed. (Inherited from TextBoxBase.)
 | RecreateHandle()()()() | Forces the re-creation of the handle for the control. (Inherited from Control.)
 | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
 | RectangleToClient(Rectangle) | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
 | RectangleToScreen(Rectangle) | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
 | Refresh()()()() | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
 | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
 | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
 | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
 | RescaleConstantsForDpi(Int32, Int32) | (Inherited from Control.)
 | ResetBackColor()()()() | Resets the BackColor property to its default value. (Inherited from Control.)
 | ResetBindings()()()() | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
 | ResetCursor()()()() | Resets the Cursor property to its default value. (Inherited from Control.)
 | ResetFont()()()() | Resets the Font property to its default value. (Inherited from Control.)
 | ResetForeColor()()()() | Resets the ForeColor property to its default value. (Inherited from Control.)
 | ResetImeMode()()()() | Resets the ImeMode property to its default value. (Inherited from Control.)
 | ResetMouseEventArgs()()()() | Resets the control to handle the MouseLeave event. (Inherited from Control.)
 | ResetRightToLeft()()()() | Resets the RightToLeft property to its default value. (Inherited from Control.)
 | ResetText()()()() | Resets the Text property to its default value. (Inherited from Control.)
 | Resize | Occurs when the control is resized. (Inherited from Control.)
 | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
 | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
 | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
 | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
 | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
 | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
 | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateContent(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateHorizontal(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateLeftRight(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
 | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
 | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
 | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
 | ScaleBitmapLogicalToDevice(Bitmap%) | (Inherited from Control.)
 | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
 | ScaleControl(SizeF, BoundsSpecified) | Scales a control's location, size, padding and margin. (Inherited from Control.)
 | ScaleCore(Single, Single) | This method is not relevant for this class. (Inherited from Control.)
 | ScrollBars | Gets or sets which scroll bars should appear in a multiline TextBox control. (Inherited from TextBox.)
 | ScrollCaret | Occurs when the text box is scrolled to the caret.
 | ScrollToCaret()()()() | Scrolls to caret
 | Select(Int32, Int32) | Selects a range of text in the text box. (Inherited from TextBoxBase.)
 | Select()()()() | Activates the control. (Inherited from Control.)
 | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
 | SelectAll()()()() | Selects all text in the text box. (Inherited from TextBoxBase.)
 | SelectedText | Gets or sets a value indicating the currently selected text in the control. (Inherited from TextBoxBase.)
 | SelectionChanged | Occurs when the selection of text within the control has changed.
 | SelectionLength | This member overrides TextBox.SelectionLength. (Overrides TextBoxBase.SelectionLength.)
 | SelectionStart | Gets or sets the starting point of text selected in the text box.
 | SelectNextControl(Control, Boolean, Boolean, Boolean, Boolean) | Activates the next control. (Inherited from Control.)
 | SendToBack()()()() | Sends the control to the back of the z-order. (Inherited from Control.)
 | SetAutoSizeMode(AutoSizeMode) | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
 | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
 | SetBoundsCore(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the TextBoxBase control. (Inherited from TextBoxBase.)
 | SetClientSizeCore(Int32, Int32) | Sets the size of the client area of the control. (Inherited from Control.)
 | SetStyle(ControlStyles, Boolean) | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
 | SetTopLevel(Boolean) | Sets the control as the top-level control. (Inherited from Control.)
 | SetVisibleCore(Boolean) | Sets the control to the specified visible state. (Inherited from Control.)
 | ShortcutsEnabled | Gets or sets a value indicating whether the defined shortcuts are enabled. (Inherited from TextBoxBase.)
 | Show()()()() | Displays the control to the user. (Inherited from Control.)
 | ShowCutCopyPasteContextMenu | Whether to show the standard Undo/Cut/Copy/Paste/Delete/Select All context menu.
 | ShowCutCopyPasteContextMenuStrip | Whether to show the standard Undo/Cut/Copy/Paste/Delete/Select All context menu strip.
 | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
 | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
 | Site | Gets or sets the site of the control. (Inherited from Control.)
 | Size | Gets or sets the height and width of the control. (Inherited from Control.)
 | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
 | SizeFromClientSize(Size) | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
 | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
 | SuspendLayout()()()() | Temporarily suspends the layout logic for the control. (Inherited from Control.)
 | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
 | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
 | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
 | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
 | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
 | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
 | Text | Gets or sets the current text in the TextBox. (Inherited from TextBox.)
 | TextAlign | Gets or sets how text is aligned in a TextBox control. (Inherited from TextBox.)
 | TextAlignChanged | Occurs when the value of the TextAlign property has changed. (Inherited from TextBox.)
 | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
 | TextLength | Gets the length of text in the control. (Inherited from TextBoxBase.)
 | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
 | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
 | ToString()()()() | Returns a string that represents the TextBoxBase control. (Inherited from TextBoxBase.)
 | UnderlineYOffset | Controls the position of the underline relative to the baseline.
 | Undo()()()() | Undoes the last edit operation in the text box. (Inherited from TextBoxBase.)
 | Update()()()() | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
 | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
 | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
 | UpdateStyles()()()() | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
 | UpdateZOrder()()()() | Updates the control in its parent's z-order. (Inherited from Control.)
 | UseSystemPasswordChar | Gets or sets a value indicating whether the text in the TextBox control should appear as the default password character. (Inherited from TextBox.)
 | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
 | Validated | Occurs when the control is finished validating. (Inherited from Control.)
 | Validating | Occurs when the control is validating. (Inherited from Control.)
 | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
 | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
 | VScrolled | Event fired when vertical scroll changed (by anything).
 | VScrollEnd | Event fired when vertical scroll ends.
 | Width | Gets or sets the width of the control. (Inherited from Control.)
 | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
 | WndProc(Message%) | Handles WndProc events and dispatches new events. (Overrides TextBox.WndProc(Message%).)
 | WordWrap | Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary. (Inherited from TextBoxBase.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | Control
 |  |  |  | TextBoxBase
 |  |  |  |  | TextBox
 |  |  |  |  |  | AYTTextBox
 |  |  |  |  |  |  | AYTTextEditingControl


AYTTextBox Constructor

Keyoti RapidSpell Desktop .NET API Docs
AYTTextBox Constructor
API ► Keyoti.RapidSpell ► AYTTextBox ► AYTTextBox()()()()
Keyoti RapidSpell Desktop .NET
Creates a new TextBox with "as-you-type" facility.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public AYTTextBox()
public AYTTextBox()
Public Sub New
Public Sub New
public:
AYTTextBox()
public:
AYTTextBox()
new : unit -> AYTTextBox
new : unit -> AYTTextBox


ContextMenuDefault Property

Keyoti RapidSpell Desktop .NET API Docs
ContextMenuDefault Property
API ► Keyoti.RapidSpell ► AYTTextBox ► ContextMenuDefault
Keyoti RapidSpell Desktop .NET
The context menu that will be shown when the right click is not on a misspelled word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual ContextMenu ContextMenuDefault { get; set; }
public virtual ContextMenu ContextMenuDefault { get; set; }
Public Overridable Property ContextMenuDefault As ContextMenu
    Get
    Set
Public Overridable Property ContextMenuDefault As ContextMenu
    Get
    Set
public:
virtual property ContextMenu^ ContextMenuDefault {
    ContextMenu^ get ();
    void set (ContextMenu^ value);
}
public:
virtual property ContextMenu^ ContextMenuDefault {
    ContextMenu^ get ();
    void set (ContextMenu^ value);
}
abstract ContextMenuDefault : ContextMenu with get, set
override ContextMenuDefault : ContextMenu with get, set
abstract ContextMenuDefault : ContextMenu with get, set
override ContextMenuDefault : ContextMenu with get, set
Property Value
ContextMenu


ContextMenuStrip Property

Keyoti RapidSpell Desktop .NET API Docs
ContextMenuStrip Property
API ► Keyoti.RapidSpell ► AYTTextBox ► ContextMenuStrip
Keyoti RapidSpell Desktop .NET
The context menu that will be shown when the right click is not on a misspelled word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override ContextMenuStrip ContextMenuStrip { get; set; }
public override ContextMenuStrip ContextMenuStrip { get; set; }
Public Overrides Property ContextMenuStrip As ContextMenuStrip
    Get
    Set
Public Overrides Property ContextMenuStrip As ContextMenuStrip
    Get
    Set
public:
virtual property ContextMenuStrip^ ContextMenuStrip {
    ContextMenuStrip^ get () override;
    void set (ContextMenuStrip^ value) override;
}
public:
virtual property ContextMenuStrip^ ContextMenuStrip {
    ContextMenuStrip^ get () override;
    void set (ContextMenuStrip^ value) override;
}
abstract ContextMenuStrip : ContextMenuStrip with get, set
override ContextMenuStrip : ContextMenuStrip with get, set
abstract ContextMenuStrip : ContextMenuStrip with get, set
override ContextMenuStrip : ContextMenuStrip with get, set
Property Value
ContextMenuStrip


ContextMenuStripDefault Property

Keyoti RapidSpell Desktop .NET API Docs
ContextMenuStripDefault Property
API ► Keyoti.RapidSpell ► AYTTextBox ► ContextMenuStripDefault
Keyoti RapidSpell Desktop .NET
The context menu that will be shown when the right click is not on a misspelled word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ContextMenuStrip ContextMenuStripDefault { get; set; }
public ContextMenuStrip ContextMenuStripDefault { get; set; }
Public Property ContextMenuStripDefault As ContextMenuStrip
    Get
    Set
Public Property ContextMenuStripDefault As ContextMenuStrip
    Get
    Set
public:
virtual property ContextMenuStrip^ ContextMenuStripDefault {
    ContextMenuStrip^ get () sealed;
    void set (ContextMenuStrip^ value) sealed;
}
public:
virtual property ContextMenuStrip^ ContextMenuStripDefault {
    ContextMenuStrip^ get () sealed;
    void set (ContextMenuStrip^ value) sealed;
}
abstract ContextMenuStripDefault : ContextMenuStrip with get, set
override ContextMenuStripDefault : ContextMenuStrip with get, set
abstract ContextMenuStripDefault : ContextMenuStrip with get, set
override ContextMenuStripDefault : ContextMenuStrip with get, set
Property Value
ContextMenuStrip
Remarks
This is the context menu originally set in the ContextMenuStrip property.


ControlBackgroundPaint Event

Keyoti RapidSpell Desktop .NET API Docs
ControlBackgroundPaint Event
API ► Keyoti.RapidSpell ► AYTTextBox ► ControlBackgroundPaint
Keyoti RapidSpell Desktop .NET
Event fired when Windows level background repaint occurs.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler ControlBackgroundPaint
public event EventHandler ControlBackgroundPaint
Public Event ControlBackgroundPaint As EventHandler
Public Event ControlBackgroundPaint As EventHandler
public:
 event EventHandler^ ControlBackgroundPaint {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
 event EventHandler^ ControlBackgroundPaint {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member ControlBackgroundPaint : IEvent<EventHandler,
    EventArgs>

member ControlBackgroundPaint : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


ControlPaint Event

Keyoti RapidSpell Desktop .NET API Docs
ControlPaint Event
API ► Keyoti.RapidSpell ► AYTTextBox ► ControlPaint
Keyoti RapidSpell Desktop .NET
Event fired when Windows level repaint occurs.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler ControlPaint
public event EventHandler ControlPaint
Public Event ControlPaint As EventHandler
Public Event ControlPaint As EventHandler
public:
virtual  event EventHandler^ ControlPaint {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ ControlPaint {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ControlPaint : IEvent<EventHandler,
    EventArgs>
override ControlPaint : IEvent<EventHandler,
    EventArgs>
abstract ControlPaint : IEvent<EventHandler,
    EventArgs>
override ControlPaint : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


DefaultContextMenu Property

Keyoti RapidSpell Desktop .NET API Docs
DefaultContextMenu Property
API ► Keyoti.RapidSpell ► AYTTextBox ► DefaultContextMenu
Keyoti RapidSpell Desktop .NET
Obsolete - Use ContextMenuDefault instead.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
[ObsoleteAttribute("Use ContextMenuDefault instead.")]
public virtual ContextMenu DefaultContextMenu { get; set; }
[ObsoleteAttribute("Use ContextMenuDefault instead.")]
public virtual ContextMenu DefaultContextMenu { get; set; }
<ObsoleteAttribute("Use ContextMenuDefault instead.")>
Public Overridable Property DefaultContextMenu As ContextMenu
    Get
    Set
<ObsoleteAttribute("Use ContextMenuDefault instead.")>
Public Overridable Property DefaultContextMenu As ContextMenu
    Get
    Set
public:
[ObsoleteAttribute(L"Use ContextMenuDefault instead.")]
virtual property ContextMenu^ DefaultContextMenu {
    ContextMenu^ get ();
    void set (ContextMenu^ value);
}
public:
[ObsoleteAttribute(L"Use ContextMenuDefault instead.")]
virtual property ContextMenu^ DefaultContextMenu {
    ContextMenu^ get ();
    void set (ContextMenu^ value);
}
[<ObsoleteAttribute("Use ContextMenuDefault instead.")>]
abstract DefaultContextMenu : ContextMenu with get, set
[<ObsoleteAttribute("Use ContextMenuDefault instead.")>]
override DefaultContextMenu : ContextMenu with get, set
[<ObsoleteAttribute("Use ContextMenuDefault instead.")>]
abstract DefaultContextMenu : ContextMenu with get, set
[<ObsoleteAttribute("Use ContextMenuDefault instead.")>]
override DefaultContextMenu : ContextMenu with get, set
Property Value
ContextMenu


FormatChanged Event

Keyoti RapidSpell Desktop .NET API Docs
FormatChanged Event
API ► Keyoti.RapidSpell ► AYTTextBox ► FormatChanged
Keyoti RapidSpell Desktop .NET
Event fired when formatting changes (such as font change).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler FormatChanged
public event EventHandler FormatChanged
Public Event FormatChanged As EventHandler
Public Event FormatChanged As EventHandler
public:
virtual  event EventHandler^ FormatChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ FormatChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract FormatChanged : IEvent<EventHandler,
    EventArgs>
override FormatChanged : IEvent<EventHandler,
    EventArgs>
abstract FormatChanged : IEvent<EventHandler,
    EventArgs>
override FormatChanged : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


GetBaselineOffsetAtCharIndex Method (i)

Keyoti RapidSpell Desktop .NET API Docs
GetBaselineOffsetAtCharIndex Method (i)
API ► Keyoti.RapidSpell ► AYTTextBox ► GetBaselineOffsetAtCharIndex(Int32)
Keyoti RapidSpell Desktop .NET
Gets the baseline offset for a character at index i
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int GetBaselineOffsetAtCharIndex(
    int i
)
public int GetBaselineOffsetAtCharIndex(
    int i
)
Public Function GetBaselineOffsetAtCharIndex (
    i As Integer
) As Integer
Public Function GetBaselineOffsetAtCharIndex (
    i As Integer
) As Integer
public:
virtual int GetBaselineOffsetAtCharIndex(
    int i
) sealed
public:
virtual int GetBaselineOffsetAtCharIndex(
    int i
) sealed
abstract GetBaselineOffsetAtCharIndex :
        i : int -> int
override GetBaselineOffsetAtCharIndex :
        i : int -> int
abstract GetBaselineOffsetAtCharIndex :
        i : int -> int
override GetBaselineOffsetAtCharIndex :
        i : int -> int
Parameters
i (Int32)
Return Value
Int32


GetCharIndexFromPos Method (pos)

Keyoti RapidSpell Desktop .NET API Docs
GetCharIndexFromPos Method (pos)
API ► Keyoti.RapidSpell ► AYTTextBox ► GetCharIndexFromPos(Point)
Keyoti RapidSpell Desktop .NET
gets the char index from a position point.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int GetCharIndexFromPos(
    Point pos
)
public int GetCharIndexFromPos(
    Point pos
)
Public Function GetCharIndexFromPos (
    pos As Point
) As Integer
Public Function GetCharIndexFromPos (
    pos As Point
) As Integer
public:
virtual int GetCharIndexFromPos(
    Point pos
) sealed
public:
virtual int GetCharIndexFromPos(
    Point pos
) sealed
abstract GetCharIndexFromPos :
        pos : Point -> int
override GetCharIndexFromPos :
        pos : Point -> int
abstract GetCharIndexFromPos :
        pos : Point -> int
override GetCharIndexFromPos :
        pos : Point -> int
Parameters
pos (Point)
Return Value
Int32


GetFirstVisibleCharIndex Method

Keyoti RapidSpell Desktop .NET API Docs
GetFirstVisibleCharIndex Method
API ► Keyoti.RapidSpell ► AYTTextBox ► GetFirstVisibleCharIndex()()()()
Keyoti RapidSpell Desktop .NET
Gets the character index of the first visible character in the window, this is for optimization and can just return 0 if unavailable.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int GetFirstVisibleCharIndex()
public int GetFirstVisibleCharIndex()
Public Function GetFirstVisibleCharIndex As Integer
Public Function GetFirstVisibleCharIndex As Integer
public:
virtual int GetFirstVisibleCharIndex() sealed
public:
virtual int GetFirstVisibleCharIndex() sealed
abstract GetFirstVisibleCharIndex : unit -> int
override GetFirstVisibleCharIndex : unit -> int
abstract GetFirstVisibleCharIndex : unit -> int
override GetFirstVisibleCharIndex : unit -> int
Return Value
Int32


GetFocusOnContextMenu Property

Keyoti RapidSpell Desktop .NET API Docs
GetFocusOnContextMenu Property
API ► Keyoti.RapidSpell ► AYTTextBox ► GetFocusOnContextMenu
Keyoti RapidSpell Desktop .NET
Whether to get focus when the user activates the context menu.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool GetFocusOnContextMenu { get; set; }
public virtual bool GetFocusOnContextMenu { get; set; }
Public Overridable Property GetFocusOnContextMenu As Boolean
    Get
    Set
Public Overridable Property GetFocusOnContextMenu As Boolean
    Get
    Set
public:
virtual property bool GetFocusOnContextMenu {
    bool get ();
    void set (bool value);
}
public:
virtual property bool GetFocusOnContextMenu {
    bool get ();
    void set (bool value);
}
abstract GetFocusOnContextMenu : bool with get, set
override GetFocusOnContextMenu : bool with get, set
abstract GetFocusOnContextMenu : bool with get, set
override GetFocusOnContextMenu : bool with get, set
Property Value
Boolean
Remarks
Setting this to true makes the behavior like RichTextBox's


GetPosFromCharIndex Method (ind)

Keyoti RapidSpell Desktop .NET API Docs
GetPosFromCharIndex Method (ind)
API ► Keyoti.RapidSpell ► AYTTextBox ► GetPosFromCharIndex(Int32)
Keyoti RapidSpell Desktop .NET
Gets the position point from the char index
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Point GetPosFromCharIndex(
    int ind
)
public Point GetPosFromCharIndex(
    int ind
)
Public Function GetPosFromCharIndex (
    ind As Integer
) As Point
Public Function GetPosFromCharIndex (
    ind As Integer
) As Point
public:
virtual Point GetPosFromCharIndex(
    int ind
) sealed
public:
virtual Point GetPosFromCharIndex(
    int ind
) sealed
abstract GetPosFromCharIndex :
        ind : int -> Point
override GetPosFromCharIndex :
        ind : int -> Point
abstract GetPosFromCharIndex :
        ind : int -> Point
override GetPosFromCharIndex :
        ind : int -> Point
Parameters
ind (Int32)
Return Value
Point


GetTBU Method

Keyoti RapidSpell Desktop .NET API Docs
GetTBU Method
API ► Keyoti.RapidSpell ► AYTTextBox ► GetTBU()()()()
Keyoti RapidSpell Desktop .NET
Interface requirement
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public TextBoxUtilityAdapter GetTBU()
public TextBoxUtilityAdapter GetTBU()
Public Function GetTBU As TextBoxUtilityAdapter
Public Function GetTBU As TextBoxUtilityAdapter
public:
virtual TextBoxUtilityAdapter^ GetTBU() sealed
public:
virtual TextBoxUtilityAdapter^ GetTBU() sealed
abstract GetTBU : unit -> TextBoxUtilityAdapter
override GetTBU : unit -> TextBoxUtilityAdapter
abstract GetTBU : unit -> TextBoxUtilityAdapter
override GetTBU : unit -> TextBoxUtilityAdapter
Return Value
TextBoxUtilityAdapter


HScrolled Event

Keyoti RapidSpell Desktop .NET API Docs
HScrolled Event
API ► Keyoti.RapidSpell ► AYTTextBox ► HScrolled
Keyoti RapidSpell Desktop .NET
Event fired when horizontal scroll changed (by anything).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler HScrolled
public event EventHandler HScrolled
Public Event HScrolled As EventHandler
Public Event HScrolled As EventHandler
public:
virtual  event EventHandler^ HScrolled {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ HScrolled {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract HScrolled : IEvent<EventHandler,
    EventArgs>
override HScrolled : IEvent<EventHandler,
    EventArgs>
abstract HScrolled : IEvent<EventHandler,
    EventArgs>
override HScrolled : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


Pasting Event

Keyoti RapidSpell Desktop .NET API Docs
Pasting Event
API ► Keyoti.RapidSpell ► AYTTextBox ► Pasting
Keyoti RapidSpell Desktop .NET
Occurs when text is about to be pasted.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler Pasting
public event EventHandler Pasting
Public Event Pasting As EventHandler
Public Event Pasting As EventHandler
public:
 event EventHandler^ Pasting {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
 event EventHandler^ Pasting {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member Pasting : IEvent<EventHandler,
    EventArgs>

member Pasting : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


ScrollCaret Event

Keyoti RapidSpell Desktop .NET API Docs
ScrollCaret Event
API ► Keyoti.RapidSpell ► AYTTextBox ► ScrollCaret
Keyoti RapidSpell Desktop .NET
Occurs when the text box is scrolled to the caret.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler ScrollCaret
public event EventHandler ScrollCaret
Public Event ScrollCaret As EventHandler
Public Event ScrollCaret As EventHandler
public:
virtual  event EventHandler^ ScrollCaret {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ ScrollCaret {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ScrollCaret : IEvent<EventHandler,
    EventArgs>
override ScrollCaret : IEvent<EventHandler,
    EventArgs>
abstract ScrollCaret : IEvent<EventHandler,
    EventArgs>
override ScrollCaret : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


ScrollToCaret Method

Keyoti RapidSpell Desktop .NET API Docs
ScrollToCaret Method
API ► Keyoti.RapidSpell ► AYTTextBox ► ScrollToCaret()()()()
Keyoti RapidSpell Desktop .NET
Scrolls to caret
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void ScrollToCaret()
public void ScrollToCaret()
Public Sub ScrollToCaret
Public Sub ScrollToCaret
public:
void ScrollToCaret()
public:
void ScrollToCaret()
member ScrollToCaret : unit -> unit

member ScrollToCaret : unit -> unit


SelectionChanged Event

Keyoti RapidSpell Desktop .NET API Docs
SelectionChanged Event
API ► Keyoti.RapidSpell ► AYTTextBox ► SelectionChanged
Keyoti RapidSpell Desktop .NET
Occurs when the selection of text within the control has changed.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler SelectionChanged
public event EventHandler SelectionChanged
Public Event SelectionChanged As EventHandler
Public Event SelectionChanged As EventHandler
public:
 event EventHandler^ SelectionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
 event EventHandler^ SelectionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member SelectionChanged : IEvent<EventHandler,
    EventArgs>

member SelectionChanged : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


SelectionLength Property

Keyoti RapidSpell Desktop .NET API Docs
SelectionLength Property
API ► Keyoti.RapidSpell ► AYTTextBox ► SelectionLength
Keyoti RapidSpell Desktop .NET
This member overrides TextBox.SelectionLength.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override int SelectionLength { get; set; }
public override int SelectionLength { get; set; }
Public Overrides Property SelectionLength As Integer
    Get
    Set
Public Overrides Property SelectionLength As Integer
    Get
    Set
public:
virtual property int SelectionLength {
    int get () override;
    void set (int value) override;
}
public:
virtual property int SelectionLength {
    int get () override;
    void set (int value) override;
}
abstract SelectionLength : int with get, set
override SelectionLength : int with get, set
abstract SelectionLength : int with get, set
override SelectionLength : int with get, set
Property Value
Int32


SelectionStart Property

Keyoti RapidSpell Desktop .NET API Docs
SelectionStart Property
API ► Keyoti.RapidSpell ► AYTTextBox ► SelectionStart
Keyoti RapidSpell Desktop .NET
Gets or sets the starting point of text selected in the text box.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int SelectionStart { get; set; }
public int SelectionStart { get; set; }
Public Property SelectionStart As Integer
    Get
    Set
Public Property SelectionStart As Integer
    Get
    Set
public:
virtual property int SelectionStart {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int SelectionStart {
    int get () sealed;
    void set (int value) sealed;
}
abstract SelectionStart : int with get, set
override SelectionStart : int with get, set
abstract SelectionStart : int with get, set
override SelectionStart : int with get, set
Property Value
Int32
Remarks
If no text is selected in the control, this property indicates the insertion point for new text. If you set this property to a location beyond the length of the text in the control, the selection start position will be placed after the last character. When text is selected in the text box control, changing this property might decrease the value of the SelectionLength property. If the remaining text in the control after the position indicated by the SelectionStart property is less than the value of the SelectionLength property, the value of the SelectionLength property is automatically decreased. The value of the SelectionStart property never causes an increase in the SelectionLength property. Note You can programmatically move the caret within the text box by setting the SelectionStart to the position within the text box where you want the caret to move to and set the SelectionLength property to a value of zero (0). The text box must have focus in order for the caret to be moved.


ShowCutCopyPasteContextMenu Property

Keyoti RapidSpell Desktop .NET API Docs
ShowCutCopyPasteContextMenu Property
API ► Keyoti.RapidSpell ► AYTTextBox ► ShowCutCopyPasteContextMenu
Keyoti RapidSpell Desktop .NET
Whether to show the standard Undo/Cut/Copy/Paste/Delete/Select All context menu.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool ShowCutCopyPasteContextMenu { get; set; }
public virtual bool ShowCutCopyPasteContextMenu { get; set; }
Public Overridable Property ShowCutCopyPasteContextMenu As Boolean
    Get
    Set
Public Overridable Property ShowCutCopyPasteContextMenu As Boolean
    Get
    Set
public:
virtual property bool ShowCutCopyPasteContextMenu {
    bool get ();
    void set (bool value);
}
public:
virtual property bool ShowCutCopyPasteContextMenu {
    bool get ();
    void set (bool value);
}
abstract ShowCutCopyPasteContextMenu : bool with get, set
override ShowCutCopyPasteContextMenu : bool with get, set
abstract ShowCutCopyPasteContextMenu : bool with get, set
override ShowCutCopyPasteContextMenu : bool with get, set
Property Value
Boolean


ShowCutCopyPasteContextMenuStrip Property

Keyoti RapidSpell Desktop .NET API Docs
ShowCutCopyPasteContextMenuStrip Property
API ► Keyoti.RapidSpell ► AYTTextBox ► ShowCutCopyPasteContextMenuStrip
Keyoti RapidSpell Desktop .NET
Whether to show the standard Undo/Cut/Copy/Paste/Delete/Select All context menu strip.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool ShowCutCopyPasteContextMenuStrip { get; set; }
public virtual bool ShowCutCopyPasteContextMenuStrip { get; set; }
Public Overridable Property ShowCutCopyPasteContextMenuStrip As Boolean
    Get
    Set
Public Overridable Property ShowCutCopyPasteContextMenuStrip As Boolean
    Get
    Set
public:
virtual property bool ShowCutCopyPasteContextMenuStrip {
    bool get ();
    void set (bool value);
}
public:
virtual property bool ShowCutCopyPasteContextMenuStrip {
    bool get ();
    void set (bool value);
}
abstract ShowCutCopyPasteContextMenuStrip : bool with get, set
override ShowCutCopyPasteContextMenuStrip : bool with get, set
abstract ShowCutCopyPasteContextMenuStrip : bool with get, set
override ShowCutCopyPasteContextMenuStrip : bool with get, set
Property Value
Boolean


UnderlineYOffset Property

Keyoti RapidSpell Desktop .NET API Docs
UnderlineYOffset Property
API ► Keyoti.RapidSpell ► AYTTextBox ► UnderlineYOffset
Keyoti RapidSpell Desktop .NET
Controls the position of the underline relative to the baseline.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int UnderlineYOffset { get; set; }
public int UnderlineYOffset { get; set; }
Public Property UnderlineYOffset As Integer
    Get
    Set
Public Property UnderlineYOffset As Integer
    Get
    Set
public:
property int UnderlineYOffset {
    int get ();
    void set (int value);
}
public:
property int UnderlineYOffset {
    int get ();
    void set (int value);
}
member UnderlineYOffset : int with get, set

member UnderlineYOffset : int with get, set
Property Value
Int32


VScrolled Event

Keyoti RapidSpell Desktop .NET API Docs
VScrolled Event
API ► Keyoti.RapidSpell ► AYTTextBox ► VScrolled
Keyoti RapidSpell Desktop .NET
Event fired when vertical scroll changed (by anything).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler VScrolled
public event EventHandler VScrolled
Public Event VScrolled As EventHandler
Public Event VScrolled As EventHandler
public:
virtual  event EventHandler^ VScrolled {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ VScrolled {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract VScrolled : IEvent<EventHandler,
    EventArgs>
override VScrolled : IEvent<EventHandler,
    EventArgs>
abstract VScrolled : IEvent<EventHandler,
    EventArgs>
override VScrolled : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


VScrollEnd Event

Keyoti RapidSpell Desktop .NET API Docs
VScrollEnd Event
API ► Keyoti.RapidSpell ► AYTTextBox ► VScrollEnd
Keyoti RapidSpell Desktop .NET
Event fired when vertical scroll ends.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler VScrollEnd
public event EventHandler VScrollEnd
Public Event VScrollEnd As EventHandler
Public Event VScrollEnd As EventHandler
public:
virtual  event EventHandler^ VScrollEnd {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ VScrollEnd {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract VScrollEnd : IEvent<EventHandler,
    EventArgs>
override VScrollEnd : IEvent<EventHandler,
    EventArgs>
abstract VScrollEnd : IEvent<EventHandler,
    EventArgs>
override VScrollEnd : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


WndProc Method (m)

Keyoti RapidSpell Desktop .NET API Docs
WndProc Method (m)
API ► Keyoti.RapidSpell ► AYTTextBox ► WndProc(Message%)
Keyoti RapidSpell Desktop .NET
Handles WndProc events and dispatches new events.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override void WndProc(
    ref Message m
)
protected override void WndProc(
    ref Message m
)
Protected Overrides Sub WndProc (
    ByRef m As Message
)
Protected Overrides Sub WndProc (
    ByRef m As Message
)
protected:
virtual void WndProc(
    Message% m
) override
protected:
virtual void WndProc(
    Message% m
) override
abstract WndProc :
        m : Message byref -> unit
override WndProc :
        m : Message byref -> unit
abstract WndProc :
        m : Message byref -> unit
override WndProc :
        m : Message byref -> unit
Parameters
m (Message %)


BadWord Class

Keyoti RapidSpell Desktop .NET API Docs
BadWord Class
API ► Keyoti.RapidSpell ► BadWord
Keyoti RapidSpell Desktop .NET
Represents a mis-spelt word in the text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class BadWord : WordOccurrence
public class BadWord : WordOccurrence
Public Class BadWord
    Inherits WordOccurrence
Public Class BadWord
    Inherits WordOccurrence
public ref class BadWord : public WordOccurrence
public ref class BadWord : public WordOccurrence
type BadWord =
    class
        inherit WordOccurrence
    end
type BadWord =
    class
        inherit WordOccurrence
    end
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BadWord(String, Int32, Int32) | Constructs a BadWord (REASON_SPELLING) instance.
 | BadWord(String, Int32, Int32, Int32) | Constructs a BadWord instance.
 | caretEnd | End of word (Inherited from WordOccurrence.)
 | caretStart | Start of word (Inherited from WordOccurrence.)
 | Clone()()()() | Clones this instance
 | EndPosition | Gets the position of the end of this word in the main text. (Inherited from WordOccurrence.)
 | Equals(Object) | See base. (Overrides Object.Equals(Object).)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetEndPosition()()()() | Gets the position of the end of this word in the main text. (Inherited from WordOccurrence.)
 | GetHashCode()()()() | See base (Overrides Object.GetHashCode()()()().)
 | GetReason()()()() | Gets the reason that this is a bad word.
 | GetStartPosition()()()() | Gets the position of the start of this word in the main text. (Inherited from WordOccurrence.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GetWord()()()() | Gets the String of this bad word. (Inherited from WordOccurrence.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Reason | Gets the reason that this is a bad word.
 | REASON_CAPITALIZATION | BadWord reason, incorrect capitalization.
 | REASON_DUPLICATE | BadWord reason, duplicate word occurrence.
 | REASON_SPELLING | BadWord reason, incorrect spelling.
 | Shift(Int32) | Moves the bad word position by delta
 | StartPosition | Gets the position of the start of this word in the main text. (Inherited from WordOccurrence.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Word | Gets the string of this bad word. (Inherited from WordOccurrence.)
Inheritance Hierarchy
Object
 | WordOccurrence
 |  | BadWord


BadWord Constructor

Keyoti RapidSpell Desktop .NET API Docs
BadWord Constructor
API ► Keyoti.RapidSpell ► BadWord ► BadWord()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | BadWord(String, Int32, Int32) | Constructs a BadWord (REASON_SPELLING) instance.
 | BadWord(String, Int32, Int32, Int32) | Constructs a BadWord instance.


BadWord Constructor (word, caretStart, caretEnd)

Keyoti RapidSpell Desktop .NET API Docs
BadWord Constructor (word, caretStart, caretEnd)
API ► Keyoti.RapidSpell ► BadWord ► BadWord(String, Int32, Int32)
Keyoti RapidSpell Desktop .NET
Constructs a BadWord (REASON_SPELLING) instance.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public BadWord(
    string word,
    int caretStart,
    int caretEnd
)
public BadWord(
    string word,
    int caretStart,
    int caretEnd
)
Public Sub New (
    word As String,
    caretStart As Integer,
    caretEnd As Integer
)
Public Sub New (
    word As String,
    caretStart As Integer,
    caretEnd As Integer
)
public:
BadWord(
    String^ word,
    int caretStart,
    int caretEnd
)
public:
BadWord(
    String^ word,
    int caretStart,
    int caretEnd
)
new :
        word : string *
        caretStart : int *
        caretEnd : int -> BadWord
new :
        word : string *
        caretStart : int *
        caretEnd : int -> BadWord
Parameters
word (String)
the word String that is misspelt
caretStart (Int32)
the position in the original text
caretEnd (Int32)
the end position in the text


BadWord Constructor (word, caretStart, caretEnd, reason)

Keyoti RapidSpell Desktop .NET API Docs
BadWord Constructor (word, caretStart, caretEnd, reason)
API ► Keyoti.RapidSpell ► BadWord ► BadWord(String, Int32, Int32, Int32)
Keyoti RapidSpell Desktop .NET
Constructs a BadWord instance.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public BadWord(
    string word,
    int caretStart,
    int caretEnd,
    int reason
)
public BadWord(
    string word,
    int caretStart,
    int caretEnd,
    int reason
)
Public Sub New (
    word As String,
    caretStart As Integer,
    caretEnd As Integer,
    reason As Integer
)
Public Sub New (
    word As String,
    caretStart As Integer,
    caretEnd As Integer,
    reason As Integer
)
public:
BadWord(
    String^ word,
    int caretStart,
    int caretEnd,
    int reason
)
public:
BadWord(
    String^ word,
    int caretStart,
    int caretEnd,
    int reason
)
new :
        word : string *
        caretStart : int *
        caretEnd : int *
        reason : int -> BadWord
new :
        word : string *
        caretStart : int *
        caretEnd : int *
        reason : int -> BadWord
Parameters
word (String)
the word String that is misspelt
caretStart (Int32)
the position in the original text
caretEnd (Int32)
the end position in the text
reason (Int32)
the reason this is a bad word, either REASON_DUPLICATE or REASON_SPELLING


Clone Method

Keyoti RapidSpell Desktop .NET API Docs
Clone Method
API ► Keyoti.RapidSpell ► BadWord ► Clone()()()()
Keyoti RapidSpell Desktop .NET
Clones this instance
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public BadWord Clone()
public BadWord Clone()
Public Function Clone As BadWord
Public Function Clone As BadWord
public:
BadWord^ Clone()
public:
BadWord^ Clone()
member Clone : unit -> BadWord

member Clone : unit -> BadWord
Return Value
BadWord


Equals Method (obj)

Keyoti RapidSpell Desktop .NET API Docs
Equals Method (obj)
API ► Keyoti.RapidSpell ► BadWord ► Equals(Object)
Keyoti RapidSpell Desktop .NET
See base.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
Parameters
obj (Object)
Return Value
Boolean


GetHashCode Method

Keyoti RapidSpell Desktop .NET API Docs
GetHashCode Method
API ► Keyoti.RapidSpell ► BadWord ► GetHashCode()()()()
Keyoti RapidSpell Desktop .NET
See base
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
Return Value
Int32


GetReason Method

Keyoti RapidSpell Desktop .NET API Docs
GetReason Method
API ► Keyoti.RapidSpell ► BadWord ► GetReason()()()()
Keyoti RapidSpell Desktop .NET
Gets the reason that this is a bad word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int GetReason()
public int GetReason()
Public Function GetReason As Integer
Public Function GetReason As Integer
public:
int GetReason()
public:
int GetReason()
member GetReason : unit -> int

member GetReason : unit -> int
Return Value
Int32


Reason Property

Keyoti RapidSpell Desktop .NET API Docs
Reason Property
API ► Keyoti.RapidSpell ► BadWord ► Reason
Keyoti RapidSpell Desktop .NET
Gets the reason that this is a bad word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int Reason { get; }
public int Reason { get; }
Public ReadOnly Property Reason As Integer
    Get
Public ReadOnly Property Reason As Integer
    Get
public:
property int Reason {
    int get ();
}
public:
property int Reason {
    int get ();
}
member Reason : int with get

member Reason : int with get
Property Value
Int32


REASON_CAPITALIZATION Field

Keyoti RapidSpell Desktop .NET API Docs
REASON_CAPITALIZATION Field
API ► Keyoti.RapidSpell ► BadWord ► REASON_CAPITALIZATION
Keyoti RapidSpell Desktop .NET
BadWord reason, incorrect capitalization.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static int REASON_CAPITALIZATION
public static int REASON_CAPITALIZATION
Public Shared REASON_CAPITALIZATION As Integer
Public Shared REASON_CAPITALIZATION As Integer
public:
static int REASON_CAPITALIZATION
public:
static int REASON_CAPITALIZATION
static val mutable REASON_CAPITALIZATION: int
static val mutable REASON_CAPITALIZATION: int
Field Value
Int32


REASON_DUPLICATE Field

Keyoti RapidSpell Desktop .NET API Docs
REASON_DUPLICATE Field
API ► Keyoti.RapidSpell ► BadWord ► REASON_DUPLICATE
Keyoti RapidSpell Desktop .NET
BadWord reason, duplicate word occurrence.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static int REASON_DUPLICATE
public static int REASON_DUPLICATE
Public Shared REASON_DUPLICATE As Integer
Public Shared REASON_DUPLICATE As Integer
public:
static int REASON_DUPLICATE
public:
static int REASON_DUPLICATE
static val mutable REASON_DUPLICATE: int
static val mutable REASON_DUPLICATE: int
Field Value
Int32


REASON_SPELLING Field

Keyoti RapidSpell Desktop .NET API Docs
REASON_SPELLING Field
API ► Keyoti.RapidSpell ► BadWord ► REASON_SPELLING
Keyoti RapidSpell Desktop .NET
BadWord reason, incorrect spelling.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static int REASON_SPELLING
public static int REASON_SPELLING
Public Shared REASON_SPELLING As Integer
Public Shared REASON_SPELLING As Integer
public:
static int REASON_SPELLING
public:
static int REASON_SPELLING
static val mutable REASON_SPELLING: int
static val mutable REASON_SPELLING: int
Field Value
Int32


Shift Method (delta)

Keyoti RapidSpell Desktop .NET API Docs
Shift Method (delta)
API ► Keyoti.RapidSpell ► BadWord ► Shift(Int32)
Keyoti RapidSpell Desktop .NET
Moves the bad word position by delta
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void Shift(
    int delta
)
public virtual void Shift(
    int delta
)
Public Overridable Sub Shift (
    delta As Integer
)
Public Overridable Sub Shift (
    delta As Integer
)
public:
virtual void Shift(
    int delta
)
public:
virtual void Shift(
    int delta
)
abstract Shift :
        delta : int -> unit
override Shift :
        delta : int -> unit
abstract Shift :
        delta : int -> unit
override Shift :
        delta : int -> unit
Parameters
delta (Int32)


CheckerEngineAdapter Class

Keyoti RapidSpell Desktop .NET API Docs
CheckerEngineAdapter Class
API ► Keyoti.RapidSpell ► CheckerEngineAdapter
Keyoti RapidSpell Desktop .NET
Abstract base implementation of ICheckerEngine, override chosen members for desired functionality.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public abstract class CheckerEngineAdapter : ICheckerEngine
public abstract class CheckerEngineAdapter : ICheckerEngine
Public MustInherit Class CheckerEngineAdapter
    Implements ICheckerEngine
Public MustInherit Class CheckerEngineAdapter
    Implements ICheckerEngine
public ref class CheckerEngineAdapter abstract : ICheckerEngine
public ref class CheckerEngineAdapter abstract : ICheckerEngine
[<AbstractClassAttribute>]
type CheckerEngineAdapter =
    class
        interface ICheckerEngine
    end
[<AbstractClassAttribute>]
type CheckerEngineAdapter =
    class
        interface ICheckerEngine
    end
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CheckerEngineAdapter()()()() |
 | AddWord(String) | Adds a word to the user dictionary, if it exists.
 | AllowAnyCase | Whether to allow words spelt with any case, eg. "africa" instead of "Africa", this is more relaxed than AllowMixedCase.
 | AllowMixedCase | Whether to allow words spelt with mixed case, eg. "MIxEd"
 | ChangeBadWord(String) | Changes the current bad word to newWord in the text.
 | ChangeBadWord(BadWord, String) | Changes badWord to newWord in the text.
 | Check(String) | Checks the text for errors.
 | Check(String, Boolean) | Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.
 | CheckCompoundWords | Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
 | CurrentBadWord | Gets the current bad word (last returned by NextBadWord).
 | DictFilePath | The file to be used as the main dictionary, if this is null then the RapidSpellMDict.DLL satellite assembly is used.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FindCapitalizedSuggestions | Whether to look for capitalized suggestions, note this will slow FindSuggestions down by about 7 times.
 | FindSuggestions()()()() | Returns an ArrayList of Strings that are suitable suggestions for the current bad word (that is, the one last returned by NextBadWord()).
 | FindSuggestions(String) | Returns an ArrayList of Strings that are suitable suggestions for word.
 | GetConsiderationRange()()()() | Gets the factor for words to consider for suggestions.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIgnoreCapitalizedWords()()()() | Gets whether to ignore words that start with capital letters.
 | GetIncludeUserDictionaryInSuggestions()()()() | Gets whether the user dictionary should be used in finding suggestions for misspelt words.
 | GetSuggestionsMethod()()()() | Sets the suggestions method, where method is an integer identifier.
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GetUndoableStatePoint()()()() | Returns null as undo is not supported
 | IgnoreAll(String) | Marks word to be ignored in rest of the text.
 | IgnoreAllCaseInsensitive | Whether Ignore All operations should be considered case insensitive (default false).
 | IgnoreIncorrectSentenceCapitalization | Whether to ignore incorrect sentence capitalization.
 | IgnoreInEnglishLowerCaseI | Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
 | IgnoreList | The words to ignore, note this list is changed by IgnoreAll.
 | IgnorePatternMaximumWordLength | The maximum length of word that will be tested as a regex ignore pattern.
 | IgnoreURLsAndEmailAddresses | Whether to ignore URLs and email addresses (requires V2Parser=true)
 | IgnoreWordsWithDigits | Whether to ignore words with numbers in them (eg. A10 or 7-11).
 | IgnoreXML | Whether to ignore XML tags in the text.
 | LanguageParser | The type of language parsing to use.
 | LookIntoHyphenatedText | Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
 | LookUp(String) | Looks up word in the dictionary, returns true if it is in there.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NextBadWord()()()() | Gets the next bad word in the list that was identified by Check.
 | RevertToUndoableStatePoint(RapidSpellChecker..::..State) | Throws NotImplementedException
 | SetConsiderationRange(Int32) | Sets the breadth of the suggestions search.
 | SetDictFileStream(Stream, String, DateTime) | Passes a Dict file as a stream, to be used for the main dictionary.
 | SetIgnoreCapitalizedWords(Boolean) | Sets whether to ignore capitalized words.
 | SetIncludeUserDictionaryInSuggestions(Boolean) | Sets whether to include the user dictionary in suggestions taken from this engine.
 | SetOptionalContext(String, String) | Provides the engine with any helpful text around the text snippet which will be passed to the Check method. Implementation is not required.
 | SetPosition(Int32) | Sets the pointer position for the NextBadWord iterator.
 | SetSeparateHyphenWords(Boolean) | Sets whether to separate words with hyphens in them into separate words.
 | SetSuggestionsMethod(Int32) | Sets the suggestions method, where method is an integer identifier.
 | SetUserDictionary(UserDictionary) | Sets the UserDictionary object to be used as a user dictionary source.
 | SetUserDictionary(String) | Sets the UserDictionary file path to be used as a user dictionary source.
 | SuggestSplitWords | Whether to look for connected words in suggestions.
 | TextBoundary | The AdvancedTextBoundary class to use to parse words.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | UnloadMainDictionary()()()() | Empties the main dictionary store.
 | userDictionary | The user dictionary, this should be null (C#) or nothing (VB.NET) if no user dictionary is being used.
 | V2Parser | Whether to use parser version 2
 | WarnDuplicates | Whether to treat duplicate words as errors (eg. "this is is an error").
 | WordAdded | Fires when a word is added
Remarks
None of the members contained in this class do anything.
Inheritance Hierarchy
Object
CheckerEngineAdapter


CheckerEngineAdapter Constructor

Keyoti RapidSpell Desktop .NET API Docs
CheckerEngineAdapter Constructor
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► CheckerEngineAdapter()()()()
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected CheckerEngineAdapter()
protected CheckerEngineAdapter()
Protected Sub New
Protected Sub New
protected:
CheckerEngineAdapter()
protected:
CheckerEngineAdapter()
new : unit -> CheckerEngineAdapter
new : unit -> CheckerEngineAdapter


AddWord Method (word)

Keyoti RapidSpell Desktop .NET API Docs
AddWord Method (word)
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► AddWord(String)
Keyoti RapidSpell Desktop .NET
Adds a word to the user dictionary, if it exists.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool AddWord(
    string word
)
public virtual bool AddWord(
    string word
)
Public Overridable Function AddWord (
    word As String
) As Boolean
Public Overridable Function AddWord (
    word As String
) As Boolean
public:
virtual bool AddWord(
    String^ word
)
public:
virtual bool AddWord(
    String^ word
)
abstract AddWord :
        word : string -> bool
override AddWord :
        word : string -> bool
abstract AddWord :
        word : string -> bool
override AddWord :
        word : string -> bool
Parameters
word (String)
Return Value
Boolean
This implementation always returns false.
Remarks
Should return true if the word was added successfully, false otherwise.


AllowAnyCase Property

Keyoti RapidSpell Desktop .NET API Docs
AllowAnyCase Property
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► AllowAnyCase
Keyoti RapidSpell Desktop .NET
Whether to allow words spelt with any case, eg. "africa" instead of "Africa", this is more relaxed than AllowMixedCase.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool AllowAnyCase { get; set; }
public bool AllowAnyCase { get; set; }
Public Property AllowAnyCase As Boolean
    Get
    Set
Public Property AllowAnyCase As Boolean
    Get
    Set
public:
virtual property bool AllowAnyCase {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool AllowAnyCase {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract AllowAnyCase : bool with get, set
override AllowAnyCase : bool with get, set
abstract AllowAnyCase : bool with get, set
override AllowAnyCase : bool with get, set
Property Value
Boolean


AllowMixedCase Property

Keyoti RapidSpell Desktop .NET API Docs
AllowMixedCase Property
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► AllowMixedCase
Keyoti RapidSpell Desktop .NET
Whether to allow words spelt with mixed case, eg. "MIxEd"
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool AllowMixedCase { get; set; }
public virtual bool AllowMixedCase { get; set; }
Public Overridable Property AllowMixedCase As Boolean
    Get
    Set
Public Overridable Property AllowMixedCase As Boolean
    Get
    Set
public:
virtual property bool AllowMixedCase {
    bool get ();
    void set (bool value);
}
public:
virtual property bool AllowMixedCase {
    bool get ();
    void set (bool value);
}
abstract AllowMixedCase : bool with get, set
override AllowMixedCase : bool with get, set
abstract AllowMixedCase : bool with get, set
override AllowMixedCase : bool with get, set
Property Value
Boolean


ChangeBadWord Method

Keyoti RapidSpell Desktop .NET API Docs
ChangeBadWord Method
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► ChangeBadWord()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | ChangeBadWord(String) | Changes the current bad word to newWord in the text.
 | ChangeBadWord(BadWord, String) | Changes badWord to newWord in the text.


ChangeBadWord Method (badWord, newWord)

Keyoti RapidSpell Desktop .NET API Docs
ChangeBadWord Method (badWord, newWord)
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► ChangeBadWord(BadWord, String)
Keyoti RapidSpell Desktop .NET
Changes badWord to newWord in the text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void ChangeBadWord(
    BadWord badWord,
    string newWord
)
public virtual void ChangeBadWord(
    BadWord badWord,
    string newWord
)
Public Overridable Sub ChangeBadWord (
    badWord As BadWord,
    newWord As String
)
Public Overridable Sub ChangeBadWord (
    badWord As BadWord,
    newWord As String
)
public:
virtual void ChangeBadWord(
    BadWord^ badWord,
    String^ newWord
)
public:
virtual void ChangeBadWord(
    BadWord^ badWord,
    String^ newWord
)
abstract ChangeBadWord :
        badWord : BadWord *
        newWord : string -> unit
override ChangeBadWord :
        badWord : BadWord *
        newWord : string -> unit
abstract ChangeBadWord :
        badWord : BadWord *
        newWord : string -> unit
override ChangeBadWord :
        badWord : BadWord *
        newWord : string -> unit
Parameters
badWord (BadWord)
the bad word to replace
newWord (String)
replaces the current misspelt word.
Return Value

void
Exceptions
Exception | Condition
ArgumentNullException | if newWord parameter is null.


ChangeBadWord Method (newWord)

Keyoti RapidSpell Desktop .NET API Docs
ChangeBadWord Method (newWord)
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► ChangeBadWord(String)
Keyoti RapidSpell Desktop .NET
Changes the current bad word to newWord in the text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void ChangeBadWord(
    string newWord
)
public void ChangeBadWord(
    string newWord
)
Public Sub ChangeBadWord (
    newWord As String
)
Public Sub ChangeBadWord (
    newWord As String
)
public:
virtual void ChangeBadWord(
    String^ newWord
) sealed
public:
virtual void ChangeBadWord(
    String^ newWord
) sealed
abstract ChangeBadWord :
        newWord : string -> unit
override ChangeBadWord :
        newWord : string -> unit
abstract ChangeBadWord :
        newWord : string -> unit
override ChangeBadWord :
        newWord : string -> unit
Parameters
newWord (String)
replaces the current misspelt word.
Return Value

void
Exceptions
Exception | Condition
NoCurrentBadWordException | if nextBadWord() hasn't been run first AND found an erroneous word.
ArgumentNullException | if newWord parameter is null.


Check Method

Keyoti RapidSpell Desktop .NET API Docs
Check Method
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► Check()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Check(String) | Checks the text for errors.
 | Check(String, Boolean) | Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.


Check Method (text)

Keyoti RapidSpell Desktop .NET API Docs
Check Method (text)
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► Check(String)
Keyoti RapidSpell Desktop .NET
Checks the text for errors.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void Check(
    string text
)
public virtual void Check(
    string text
)
Public Overridable Sub Check (
    text As String
)
Public Overridable Sub Check (
    text As String
)
public:
virtual void Check(
    String^ text
)
public:
virtual void Check(
    String^ text
)
abstract Check :
        text : string -> unit
override Check :
        text : string -> unit
abstract Check :
        text : string -> unit
override Check :
        text : string -> unit
Parameters
text (String)
Exceptions
Exception | Condition
ArgumentNullException | if text parameter is null.


Check Method (text, isStartOfTextBody)

Keyoti RapidSpell Desktop .NET API Docs
Check Method (text, isStartOfTextBody)
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► Check(String, Boolean)
Keyoti RapidSpell Desktop .NET
Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void Check(
    string text,
    bool isStartOfTextBody
)
public void Check(
    string text,
    bool isStartOfTextBody
)
Public Sub Check (
    text As String,
    isStartOfTextBody As Boolean
)
Public Sub Check (
    text As String,
    isStartOfTextBody As Boolean
)
public:
virtual void Check(
    String^ text,
    bool isStartOfTextBody
) sealed
public:
virtual void Check(
    String^ text,
    bool isStartOfTextBody
) sealed
abstract Check :
        text : string *
        isStartOfTextBody : bool -> unit
override Check :
        text : string *
        isStartOfTextBody : bool -> unit
abstract Check :
        text : string *
        isStartOfTextBody : bool -> unit
override Check :
        text : string *
        isStartOfTextBody : bool -> unit
Parameters
text (String)
to spell check.
isStartOfTextBody (Boolean)
whether the text being spell checked is at the start of the text body (eg. start of text box), this affects sentence capitalization determination.
Return Value

void
Exceptions
Exception | Condition
ArgumentNullException | if text parameter is null.


CheckCompoundWords Property

Keyoti RapidSpell Desktop .NET API Docs
CheckCompoundWords Property
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► CheckCompoundWords
Keyoti RapidSpell Desktop .NET
Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool CheckCompoundWords { get; set; }
public virtual bool CheckCompoundWords { get; set; }
Public Overridable Property CheckCompoundWords As Boolean
    Get
    Set
Public Overridable Property CheckCompoundWords As Boolean
    Get
    Set
public:
virtual property bool CheckCompoundWords {
    bool get ();
    void set (bool value);
}
public:
virtual property bool CheckCompoundWords {
    bool get ();
    void set (bool value);
}
abstract CheckCompoundWords : bool with get, set
override CheckCompoundWords : bool with get, set
abstract CheckCompoundWords : bool with get, set
override CheckCompoundWords : bool with get, set
Property Value
Boolean
Remarks
If this=false then LookUp("thesewordsarejoined") = false

If this=true then LookUp("thesewordsarejoined") = true

If this=false then LookUp("abcdef") = false

If this=true then LookUp("abcdef") = false

Setting this to true will degrade lookup performance


CurrentBadWord Property

Keyoti RapidSpell Desktop .NET API Docs
CurrentBadWord Property
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► CurrentBadWord
Keyoti RapidSpell Desktop .NET
Gets the current bad word (last returned by NextBadWord).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual BadWord CurrentBadWord { get; }
public virtual BadWord CurrentBadWord { get; }
Public Overridable ReadOnly Property CurrentBadWord As BadWord
    Get
Public Overridable ReadOnly Property CurrentBadWord As BadWord
    Get
public:
virtual property BadWord^ CurrentBadWord {
    BadWord^ get ();
}
public:
virtual property BadWord^ CurrentBadWord {
    BadWord^ get ();
}
abstract CurrentBadWord : BadWord with get
override CurrentBadWord : BadWord with get
abstract CurrentBadWord : BadWord with get
override CurrentBadWord : BadWord with get
Property Value
BadWord


DictFilePath Property

Keyoti RapidSpell Desktop .NET API Docs
DictFilePath Property
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► DictFilePath
Keyoti RapidSpell Desktop .NET
The file to be used as the main dictionary, if this is null then the RapidSpellMDict.DLL satellite assembly is used.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual string DictFilePath { get; set; }
public virtual string DictFilePath { get; set; }
Public Overridable Property DictFilePath As String
    Get
    Set
Public Overridable Property DictFilePath As String
    Get
    Set
public:
virtual property String^ DictFilePath {
    String^ get ();
    void set (String^ value);
}
public:
virtual property String^ DictFilePath {
    String^ get ();
    void set (String^ value);
}
abstract DictFilePath : string with get, set
override DictFilePath : string with get, set
abstract DictFilePath : string with get, set
override DictFilePath : string with get, set
Return Value
String
This implementation always returns null.


FindCapitalizedSuggestions Property

Keyoti RapidSpell Desktop .NET API Docs
FindCapitalizedSuggestions Property
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► FindCapitalizedSuggestions
Keyoti RapidSpell Desktop .NET
Whether to look for capitalized suggestions, note this will slow FindSuggestions down by about 7 times.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool FindCapitalizedSuggestions { get; set; }
public bool FindCapitalizedSuggestions { get; set; }
Public Property FindCapitalizedSuggestions As Boolean
    Get
    Set
Public Property FindCapitalizedSuggestions As Boolean
    Get
    Set
public:
virtual property bool FindCapitalizedSuggestions {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool FindCapitalizedSuggestions {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract FindCapitalizedSuggestions : bool with get, set
override FindCapitalizedSuggestions : bool with get, set
abstract FindCapitalizedSuggestions : bool with get, set
override FindCapitalizedSuggestions : bool with get, set
Property Value
Boolean


FindSuggestions Method

Keyoti RapidSpell Desktop .NET API Docs
FindSuggestions Method
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► FindSuggestions()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | FindSuggestions()()()() | Returns an ArrayList of Strings that are suitable suggestions for the current bad word (that is, the one last returned by NextBadWord()).
 | FindSuggestions(String) | Returns an ArrayList of Strings that are suitable suggestions for word.


FindSuggestions Method

Keyoti RapidSpell Desktop .NET API Docs
FindSuggestions Method
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► FindSuggestions()()()()
Keyoti RapidSpell Desktop .NET
Returns an ArrayList of Strings that are suitable suggestions for the current bad word (that is, the one last returned by NextBadWord()).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual ArrayList FindSuggestions()
public virtual ArrayList FindSuggestions()
Public Overridable Function FindSuggestions As ArrayList
Public Overridable Function FindSuggestions As ArrayList
public:
virtual ArrayList^ FindSuggestions()
public:
virtual ArrayList^ FindSuggestions()
abstract FindSuggestions : unit -> ArrayList
override FindSuggestions : unit -> ArrayList
abstract FindSuggestions : unit -> ArrayList
override FindSuggestions : unit -> ArrayList
Return Value
ArrayList
An empty ArrayList
Remarks
If no suggestions can be found, this should return an empty ArrayList. This method should be thread safe if operating with RapidSpell Desktop.
Exceptions
Exception | Condition
NoCurrentBadWordException | If NextBadWord() hasn't been run first AND found an erroneous word.


FindSuggestions Method (word)

Keyoti RapidSpell Desktop .NET API Docs
FindSuggestions Method (word)
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► FindSuggestions(String)
Keyoti RapidSpell Desktop .NET
Returns an ArrayList of Strings that are suitable suggestions for word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual ArrayList FindSuggestions(
    string word
)
public virtual ArrayList FindSuggestions(
    string word
)
Public Overridable Function FindSuggestions (
    word As String
) As ArrayList
Public Overridable Function FindSuggestions (
    word As String
) As ArrayList
public:
virtual ArrayList^ FindSuggestions(
    String^ word
)
public:
virtual ArrayList^ FindSuggestions(
    String^ word
)
abstract FindSuggestions :
        word : string -> ArrayList
override FindSuggestions :
        word : string -> ArrayList
abstract FindSuggestions :
        word : string -> ArrayList
override FindSuggestions :
        word : string -> ArrayList
Parameters
word (String)
Return Value
ArrayList
An empty ArrayList
Remarks
If no suggestions can be found, this should return an empty ArrayList. This method should be thread safe if operating with RapidSpell Desktop.


GetConsiderationRange Method

Keyoti RapidSpell Desktop .NET API Docs
GetConsiderationRange Method
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► GetConsiderationRange()()()()
Keyoti RapidSpell Desktop .NET
Gets the factor for words to consider for suggestions.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual int GetConsiderationRange()
public virtual int GetConsiderationRange()
Public Overridable Function GetConsiderationRange As Integer
Public Overridable Function GetConsiderationRange As Integer
public:
virtual int GetConsiderationRange()
public:
virtual int GetConsiderationRange()
abstract GetConsiderationRange : unit -> int
override GetConsiderationRange : unit -> int
abstract GetConsiderationRange : unit -> int
override GetConsiderationRange : unit -> int
Return Value
Int32
This implementation always returns 0.


GetIgnoreCapitalizedWords Method

Keyoti RapidSpell Desktop .NET API Docs
GetIgnoreCapitalizedWords Method
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► GetIgnoreCapitalizedWords()()()()
Keyoti RapidSpell Desktop .NET
Gets whether to ignore words that start with capital letters.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool GetIgnoreCapitalizedWords()
public virtual bool GetIgnoreCapitalizedWords()
Public Overridable Function GetIgnoreCapitalizedWords As Boolean
Public Overridable Function GetIgnoreCapitalizedWords As Boolean
public:
virtual bool GetIgnoreCapitalizedWords()
public:
virtual bool GetIgnoreCapitalizedWords()
abstract GetIgnoreCapitalizedWords : unit -> bool
override GetIgnoreCapitalizedWords : unit -> bool
abstract GetIgnoreCapitalizedWords : unit -> bool
override GetIgnoreCapitalizedWords : unit -> bool
Return Value
Boolean
This implementation always returns false.


GetIncludeUserDictionaryInSuggestions Method

Keyoti RapidSpell Desktop .NET API Docs
GetIncludeUserDictionaryInSuggestions Method
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► GetIncludeUserDictionaryInSuggestions()()()()
Keyoti RapidSpell Desktop .NET
Gets whether the user dictionary should be used in finding suggestions for misspelt words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool GetIncludeUserDictionaryInSuggestions()
public virtual bool GetIncludeUserDictionaryInSuggestions()
Public Overridable Function GetIncludeUserDictionaryInSuggestions As Boolean
Public Overridable Function GetIncludeUserDictionaryInSuggestions As Boolean
public:
virtual bool GetIncludeUserDictionaryInSuggestions()
public:
virtual bool GetIncludeUserDictionaryInSuggestions()
abstract GetIncludeUserDictionaryInSuggestions : unit -> bool
override GetIncludeUserDictionaryInSuggestions : unit -> bool
abstract GetIncludeUserDictionaryInSuggestions : unit -> bool
override GetIncludeUserDictionaryInSuggestions : unit -> bool
Return Value
Boolean
This implementation always returns false.


GetSuggestionsMethod Method

Keyoti RapidSpell Desktop .NET API Docs
GetSuggestionsMethod Method
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► GetSuggestionsMethod()()()()
Keyoti RapidSpell Desktop .NET
Sets the suggestions method, where method is an integer identifier.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual int GetSuggestionsMethod()
public virtual int GetSuggestionsMethod()
Public Overridable Function GetSuggestionsMethod As Integer
Public Overridable Function GetSuggestionsMethod As Integer
public:
virtual int GetSuggestionsMethod()
public:
virtual int GetSuggestionsMethod()
abstract GetSuggestionsMethod : unit -> int
override GetSuggestionsMethod : unit -> int
abstract GetSuggestionsMethod : unit -> int
override GetSuggestionsMethod : unit -> int
Return Value
Int32


GetUndoableStatePoint Method

Keyoti RapidSpell Desktop .NET API Docs
GetUndoableStatePoint Method
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► GetUndoableStatePoint()()()()
Keyoti RapidSpell Desktop .NET
Returns null as undo is not supported
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual RapidSpellChecker..::..State GetUndoableStatePoint()
public virtual RapidSpellChecker..::..State GetUndoableStatePoint()
Public Overridable Function GetUndoableStatePoint As RapidSpellChecker..::..State
Public Overridable Function GetUndoableStatePoint As RapidSpellChecker..::..State
public:
virtual RapidSpellChecker..::..State^ GetUndoableStatePoint()
public:
virtual RapidSpellChecker..::..State^ GetUndoableStatePoint()
abstract GetUndoableStatePoint : unit -> RapidSpellChecker..::..State
override GetUndoableStatePoint : unit -> RapidSpellChecker..::..State
abstract GetUndoableStatePoint : unit -> RapidSpellChecker..::..State
override GetUndoableStatePoint : unit -> RapidSpellChecker..::..State
Return Value
RapidSpellChecker..::..State
Returns the current state, or null if not supporting undo.


IgnoreAll Method (word)

Keyoti RapidSpell Desktop .NET API Docs
IgnoreAll Method (word)
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► IgnoreAll(String)
Keyoti RapidSpell Desktop .NET
Marks word to be ignored in rest of the text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void IgnoreAll(
    string word
)
public virtual void IgnoreAll(
    string word
)
Public Overridable Sub IgnoreAll (
    word As String
)
Public Overridable Sub IgnoreAll (
    word As String
)
public:
virtual void IgnoreAll(
    String^ word
)
public:
virtual void IgnoreAll(
    String^ word
)
abstract IgnoreAll :
        word : string -> unit
override IgnoreAll :
        word : string -> unit
abstract IgnoreAll :
        word : string -> unit
override IgnoreAll :
        word : string -> unit
Parameters
word (String)
to ignore
Return Value

void
Exceptions
Exception | Condition
ArgumentNullException | if word parameter is null.


IgnoreAllCaseInsensitive Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreAllCaseInsensitive Property
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► IgnoreAllCaseInsensitive
Keyoti RapidSpell Desktop .NET
Whether Ignore All operations should be considered case insensitive (default false).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreAllCaseInsensitive { get; set; }
public bool IgnoreAllCaseInsensitive { get; set; }
Public Property IgnoreAllCaseInsensitive As Boolean
    Get
    Set
Public Property IgnoreAllCaseInsensitive As Boolean
    Get
    Set
public:
virtual property bool IgnoreAllCaseInsensitive {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool IgnoreAllCaseInsensitive {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IgnoreAllCaseInsensitive : bool with get, set
override IgnoreAllCaseInsensitive : bool with get, set
abstract IgnoreAllCaseInsensitive : bool with get, set
override IgnoreAllCaseInsensitive : bool with get, set
Property Value
Boolean


IgnoreIncorrectSentenceCapitalization Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreIncorrectSentenceCapitalization Property
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► IgnoreIncorrectSentenceCapitalization
Keyoti RapidSpell Desktop .NET
Whether to ignore incorrect sentence capitalization.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreIncorrectSentenceCapitalization { get; set; }
public bool IgnoreIncorrectSentenceCapitalization { get; set; }
Public Property IgnoreIncorrectSentenceCapitalization As Boolean
    Get
    Set
Public Property IgnoreIncorrectSentenceCapitalization As Boolean
    Get
    Set
public:
virtual property bool IgnoreIncorrectSentenceCapitalization {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool IgnoreIncorrectSentenceCapitalization {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IgnoreIncorrectSentenceCapitalization : bool with get, set
override IgnoreIncorrectSentenceCapitalization : bool with get, set
abstract IgnoreIncorrectSentenceCapitalization : bool with get, set
override IgnoreIncorrectSentenceCapitalization : bool with get, set
Property Value
Boolean


IgnoreInEnglishLowerCaseI Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreInEnglishLowerCaseI Property
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► IgnoreInEnglishLowerCaseI
Keyoti RapidSpell Desktop .NET
Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreInEnglishLowerCaseI { get; set; }
public bool IgnoreInEnglishLowerCaseI { get; set; }
Public Property IgnoreInEnglishLowerCaseI As Boolean
    Get
    Set
Public Property IgnoreInEnglishLowerCaseI As Boolean
    Get
    Set
public:
virtual property bool IgnoreInEnglishLowerCaseI {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool IgnoreInEnglishLowerCaseI {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IgnoreInEnglishLowerCaseI : bool with get, set
override IgnoreInEnglishLowerCaseI : bool with get, set
abstract IgnoreInEnglishLowerCaseI : bool with get, set
override IgnoreInEnglishLowerCaseI : bool with get, set
Property Value
Boolean


IgnoreList Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreList Property
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► IgnoreList
Keyoti RapidSpell Desktop .NET
The words to ignore, note this list is changed by IgnoreAll.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual ArrayList IgnoreList { get; set; }
public virtual ArrayList IgnoreList { get; set; }
Public Overridable Property IgnoreList As ArrayList
    Get
    Set
Public Overridable Property IgnoreList As ArrayList
    Get
    Set
public:
virtual property ArrayList^ IgnoreList {
    ArrayList^ get ();
    void set (ArrayList^ value);
}
public:
virtual property ArrayList^ IgnoreList {
    ArrayList^ get ();
    void set (ArrayList^ value);
}
abstract IgnoreList : ArrayList with get, set
override IgnoreList : ArrayList with get, set
abstract IgnoreList : ArrayList with get, set
override IgnoreList : ArrayList with get, set
Property Value
ArrayList


IgnorePatternMaximumWordLength Property

Keyoti RapidSpell Desktop .NET API Docs
IgnorePatternMaximumWordLength Property
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► IgnorePatternMaximumWordLength
Keyoti RapidSpell Desktop .NET
The maximum length of word that will be tested as a regex ignore pattern.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int IgnorePatternMaximumWordLength { get; set; }
public int IgnorePatternMaximumWordLength { get; set; }
Public Property IgnorePatternMaximumWordLength As Integer
    Get
    Set
Public Property IgnorePatternMaximumWordLength As Integer
    Get
    Set
public:
virtual property int IgnorePatternMaximumWordLength {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int IgnorePatternMaximumWordLength {
    int get () sealed;
    void set (int value) sealed;
}
abstract IgnorePatternMaximumWordLength : int with get, set
override IgnorePatternMaximumWordLength : int with get, set
abstract IgnorePatternMaximumWordLength : int with get, set
override IgnorePatternMaximumWordLength : int with get, set
Property Value
Int32


IgnoreURLsAndEmailAddresses Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreURLsAndEmailAddresses Property
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► IgnoreURLsAndEmailAddresses
Keyoti RapidSpell Desktop .NET
Whether to ignore URLs and email addresses (requires V2Parser=true)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool IgnoreURLsAndEmailAddresses { get; set; }
public virtual bool IgnoreURLsAndEmailAddresses { get; set; }
Public Overridable Property IgnoreURLsAndEmailAddresses As Boolean
    Get
    Set
Public Overridable Property IgnoreURLsAndEmailAddresses As Boolean
    Get
    Set
public:
virtual property bool IgnoreURLsAndEmailAddresses {
    bool get ();
    void set (bool value);
}
public:
virtual property bool IgnoreURLsAndEmailAddresses {
    bool get ();
    void set (bool value);
}
abstract IgnoreURLsAndEmailAddresses : bool with get, set
override IgnoreURLsAndEmailAddresses : bool with get, set
abstract IgnoreURLsAndEmailAddresses : bool with get, set
override IgnoreURLsAndEmailAddresses : bool with get, set
Property Value
Boolean
Remarks
This will cause the following strings to be accepted as non-spelling errors;
"user@domain.com", "http://www.domain.com", "domain.co.uk" etc.


IgnoreWordsWithDigits Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreWordsWithDigits Property
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► IgnoreWordsWithDigits
Keyoti RapidSpell Desktop .NET
Whether to ignore words with numbers in them (eg. A10 or 7-11).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool IgnoreWordsWithDigits { get; set; }
public virtual bool IgnoreWordsWithDigits { get; set; }
Public Overridable Property IgnoreWordsWithDigits As Boolean
    Get
    Set
Public Overridable Property IgnoreWordsWithDigits As Boolean
    Get
    Set
public:
virtual property bool IgnoreWordsWithDigits {
    bool get ();
    void set (bool value);
}
public:
virtual property bool IgnoreWordsWithDigits {
    bool get ();
    void set (bool value);
}
abstract IgnoreWordsWithDigits : bool with get, set
override IgnoreWordsWithDigits : bool with get, set
abstract IgnoreWordsWithDigits : bool with get, set
override IgnoreWordsWithDigits : bool with get, set
Property Value
Boolean


IgnoreXML Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreXML Property
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► IgnoreXML
Keyoti RapidSpell Desktop .NET
Whether to ignore XML tags in the text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool IgnoreXML { get; set; }
public virtual bool IgnoreXML { get; set; }
Public Overridable Property IgnoreXML As Boolean
    Get
    Set
Public Overridable Property IgnoreXML As Boolean
    Get
    Set
public:
virtual property bool IgnoreXML {
    bool get ();
    void set (bool value);
}
public:
virtual property bool IgnoreXML {
    bool get ();
    void set (bool value);
}
abstract IgnoreXML : bool with get, set
override IgnoreXML : bool with get, set
abstract IgnoreXML : bool with get, set
override IgnoreXML : bool with get, set
Return Value
Boolean
This property is always false.


LanguageParser Property

Keyoti RapidSpell Desktop .NET API Docs
LanguageParser Property
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► LanguageParser
Keyoti RapidSpell Desktop .NET
The type of language parsing to use.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual LanguageType LanguageParser { get; set; }
public virtual LanguageType LanguageParser { get; set; }
Public Overridable Property LanguageParser As LanguageType
    Get
    Set
Public Overridable Property LanguageParser As LanguageType
    Get
    Set
public:
virtual property LanguageType LanguageParser {
    LanguageType get ();
    void set (LanguageType value);
}
public:
virtual property LanguageType LanguageParser {
    LanguageType get ();
    void set (LanguageType value);
}
abstract LanguageParser : LanguageType with get, set
override LanguageParser : LanguageType with get, set
abstract LanguageParser : LanguageType with get, set
override LanguageParser : LanguageType with get, set
Return Value
LanguageType
This implementation always returns RapidSpellChecker.LanguageParserType.ENGLISH.
Remarks
Eg. If the dictionary is set to French, you should use the French parser.


LookIntoHyphenatedText Property

Keyoti RapidSpell Desktop .NET API Docs
LookIntoHyphenatedText Property
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► LookIntoHyphenatedText
Keyoti RapidSpell Desktop .NET
Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool LookIntoHyphenatedText { get; set; }
public virtual bool LookIntoHyphenatedText { get; set; }
Public Overridable Property LookIntoHyphenatedText As Boolean
    Get
    Set
Public Overridable Property LookIntoHyphenatedText As Boolean
    Get
    Set
public:
virtual property bool LookIntoHyphenatedText {
    bool get ();
    void set (bool value);
}
public:
virtual property bool LookIntoHyphenatedText {
    bool get ();
    void set (bool value);
}
abstract LookIntoHyphenatedText : bool with get, set
override LookIntoHyphenatedText : bool with get, set
abstract LookIntoHyphenatedText : bool with get, set
override LookIntoHyphenatedText : bool with get, set
Property Value
Boolean
Remarks
Eg. "socio-economic" will be checked as "socio" and "economic".


LookUp Method (word)

Keyoti RapidSpell Desktop .NET API Docs
LookUp Method (word)
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► LookUp(String)
Keyoti RapidSpell Desktop .NET
Looks up word in the dictionary, returns true if it is in there.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool LookUp(
    string word
)
public virtual bool LookUp(
    string word
)
Public Overridable Function LookUp (
    word As String
) As Boolean
Public Overridable Function LookUp (
    word As String
) As Boolean
public:
virtual bool LookUp(
    String^ word
)
public:
virtual bool LookUp(
    String^ word
)
abstract LookUp :
        word : string -> bool
override LookUp :
        word : string -> bool
abstract LookUp :
        word : string -> bool
override LookUp :
        word : string -> bool
Parameters
word (String)
Return Value
Boolean


NextBadWord Method

Keyoti RapidSpell Desktop .NET API Docs
NextBadWord Method
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► NextBadWord()()()()
Keyoti RapidSpell Desktop .NET
Gets the next bad word in the list that was identified by Check.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual BadWord NextBadWord()
public virtual BadWord NextBadWord()
Public Overridable Function NextBadWord As BadWord
Public Overridable Function NextBadWord As BadWord
public:
virtual BadWord^ NextBadWord()
public:
virtual BadWord^ NextBadWord()
abstract NextBadWord : unit -> BadWord
override NextBadWord : unit -> BadWord
abstract NextBadWord : unit -> BadWord
override NextBadWord : unit -> BadWord
Return Value
BadWord
This implementation always returns null.
Remarks
Check must be called before this method.


RevertToUndoableStatePoint Method (state)

Keyoti RapidSpell Desktop .NET API Docs
RevertToUndoableStatePoint Method (state)
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► RevertToUndoableStatePoint(RapidSpellChecker..::..State)
Keyoti RapidSpell Desktop .NET
Throws NotImplementedException
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void RevertToUndoableStatePoint(
    RapidSpellChecker..::..State state
)
public virtual void RevertToUndoableStatePoint(
    RapidSpellChecker..::..State state
)
Public Overridable Sub RevertToUndoableStatePoint (
    state As RapidSpellChecker..::..State
)
Public Overridable Sub RevertToUndoableStatePoint (
    state As RapidSpellChecker..::..State
)
public:
virtual void RevertToUndoableStatePoint(
    RapidSpellChecker..::..State^ state
)
public:
virtual void RevertToUndoableStatePoint(
    RapidSpellChecker..::..State^ state
)
abstract RevertToUndoableStatePoint :
        state : RapidSpellChecker..::..State -> unit
override RevertToUndoableStatePoint :
        state : RapidSpellChecker..::..State -> unit
abstract RevertToUndoableStatePoint :
        state : RapidSpellChecker..::..State -> unit
override RevertToUndoableStatePoint :
        state : RapidSpellChecker..::..State -> unit
Parameters
state (RapidSpellChecker..::..State)


SetConsiderationRange Method (range)

Keyoti RapidSpell Desktop .NET API Docs
SetConsiderationRange Method (range)
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► SetConsiderationRange(Int32)
Keyoti RapidSpell Desktop .NET
Sets the breadth of the suggestions search.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void SetConsiderationRange(
    int range
)
public virtual void SetConsiderationRange(
    int range
)
Public Overridable Sub SetConsiderationRange (
    range As Integer
)
Public Overridable Sub SetConsiderationRange (
    range As Integer
)
public:
virtual void SetConsiderationRange(
    int range
)
public:
virtual void SetConsiderationRange(
    int range
)
abstract SetConsiderationRange :
        range : int -> unit
override SetConsiderationRange :
        range : int -> unit
abstract SetConsiderationRange :
        range : int -> unit
override SetConsiderationRange :
        range : int -> unit
Parameters
range (Int32)


SetDictFileStream Method (dictFileStream, id, modifiedDate)

Keyoti RapidSpell Desktop .NET API Docs
SetDictFileStream Method (dictFileStream, id, modifiedDate)
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► SetDictFileStream(Stream, String, DateTime)
Keyoti RapidSpell Desktop .NET
Passes a Dict file as a stream, to be used for the main dictionary.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void SetDictFileStream(
    Stream dictFileStream,
    string id,
    DateTime modifiedDate
)
public virtual void SetDictFileStream(
    Stream dictFileStream,
    string id,
    DateTime modifiedDate
)
Public Overridable Sub SetDictFileStream (
    dictFileStream As Stream,
    id As String,
    modifiedDate As DateTime
)
Public Overridable Sub SetDictFileStream (
    dictFileStream As Stream,
    id As String,
    modifiedDate As DateTime
)
public:
virtual void SetDictFileStream(
    Stream^ dictFileStream,
    String^ id,
    DateTime modifiedDate
)
public:
virtual void SetDictFileStream(
    Stream^ dictFileStream,
    String^ id,
    DateTime modifiedDate
)
abstract SetDictFileStream :
        dictFileStream : Stream *
        id : string *
        modifiedDate : DateTime -> unit
override SetDictFileStream :
        dictFileStream : Stream *
        id : string *
        modifiedDate : DateTime -> unit
abstract SetDictFileStream :
        dictFileStream : Stream *
        id : string *
        modifiedDate : DateTime -> unit
override SetDictFileStream :
        dictFileStream : Stream *
        id : string *
        modifiedDate : DateTime -> unit
Parameters
dictFileStream (Stream)
The stream containing the dictionary
id (String)
Any generated identity string which the spell checker can use to cache and identify this dictionary.
modifiedDate (DateTime)
The DateTime when this dictionary was modified, use Now to update the cache.
Remarks
Note this method must be set before Check is called, and the stream position must be at beginning of Dict file. The stream is NOT closed by this method.


SetIgnoreCapitalizedWords Method (ignore)

Keyoti RapidSpell Desktop .NET API Docs
SetIgnoreCapitalizedWords Method (ignore)
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► SetIgnoreCapitalizedWords(Boolean)
Keyoti RapidSpell Desktop .NET
Sets whether to ignore capitalized words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void SetIgnoreCapitalizedWords(
    bool ignore
)
public virtual void SetIgnoreCapitalizedWords(
    bool ignore
)
Public Overridable Sub SetIgnoreCapitalizedWords (
    ignore As Boolean
)
Public Overridable Sub SetIgnoreCapitalizedWords (
    ignore As Boolean
)
public:
virtual void SetIgnoreCapitalizedWords(
    bool ignore
)
public:
virtual void SetIgnoreCapitalizedWords(
    bool ignore
)
abstract SetIgnoreCapitalizedWords :
        ignore : bool -> unit
override SetIgnoreCapitalizedWords :
        ignore : bool -> unit
abstract SetIgnoreCapitalizedWords :
        ignore : bool -> unit
override SetIgnoreCapitalizedWords :
        ignore : bool -> unit
Parameters
ignore (Boolean)


SetIncludeUserDictionaryInSuggestions Method (includeUserDictionaryInSuggestions)

Keyoti RapidSpell Desktop .NET API Docs
SetIncludeUserDictionaryInSuggestions Method (includeUserDictionaryInSuggestions)
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► SetIncludeUserDictionaryInSuggestions(Boolean)
Keyoti RapidSpell Desktop .NET
Sets whether to include the user dictionary in suggestions taken from this engine.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void SetIncludeUserDictionaryInSuggestions(
    bool includeUserDictionaryInSuggestions
)
public virtual void SetIncludeUserDictionaryInSuggestions(
    bool includeUserDictionaryInSuggestions
)
Public Overridable Sub SetIncludeUserDictionaryInSuggestions (
    includeUserDictionaryInSuggestions As Boolean
)
Public Overridable Sub SetIncludeUserDictionaryInSuggestions (
    includeUserDictionaryInSuggestions As Boolean
)
public:
virtual void SetIncludeUserDictionaryInSuggestions(
    bool includeUserDictionaryInSuggestions
)
public:
virtual void SetIncludeUserDictionaryInSuggestions(
    bool includeUserDictionaryInSuggestions
)
abstract SetIncludeUserDictionaryInSuggestions :
        includeUserDictionaryInSuggestions : bool -> unit
override SetIncludeUserDictionaryInSuggestions :
        includeUserDictionaryInSuggestions : bool -> unit
abstract SetIncludeUserDictionaryInSuggestions :
        includeUserDictionaryInSuggestions : bool -> unit
override SetIncludeUserDictionaryInSuggestions :
        includeUserDictionaryInSuggestions : bool -> unit
Parameters
includeUserDictionaryInSuggestions (Boolean)


SetOptionalContext Method (beforeToCheckSnippet, afterToCheckSnippet)

Keyoti RapidSpell Desktop .NET API Docs
SetOptionalContext Method (beforeToCheckSnippet, afterToCheckSnippet)
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► SetOptionalContext(String, String)
Keyoti RapidSpell Desktop .NET
Provides the engine with any helpful text around the text snippet which will be passed to the Check method. Implementation is not required.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void SetOptionalContext(
    string beforeToCheckSnippet,
    string afterToCheckSnippet
)
public virtual void SetOptionalContext(
    string beforeToCheckSnippet,
    string afterToCheckSnippet
)
Public Overridable Sub SetOptionalContext (
    beforeToCheckSnippet As String,
    afterToCheckSnippet As String
)
Public Overridable Sub SetOptionalContext (
    beforeToCheckSnippet As String,
    afterToCheckSnippet As String
)
public:
virtual void SetOptionalContext(
    String^ beforeToCheckSnippet,
    String^ afterToCheckSnippet
)
public:
virtual void SetOptionalContext(
    String^ beforeToCheckSnippet,
    String^ afterToCheckSnippet
)
abstract SetOptionalContext :
        beforeToCheckSnippet : string *
        afterToCheckSnippet : string -> unit
override SetOptionalContext :
        beforeToCheckSnippet : string *
        afterToCheckSnippet : string -> unit
abstract SetOptionalContext :
        beforeToCheckSnippet : string *
        afterToCheckSnippet : string -> unit
override SetOptionalContext :
        beforeToCheckSnippet : string *
        afterToCheckSnippet : string -> unit
Parameters
beforeToCheckSnippet (String)
Any text before the to check snippet
afterToCheckSnippet (String)
Any text after the snippet
Remarks
Eg. if the document contains "This is an an example piece." and Check will be called on "an example piece", then the fact that 'an' is duplicated will not be detected. Therefore, by passing "This is an " to beforeToCheckSnippet the checker will be able to detect that an is duplicated.


SetPosition Method (pos)

Keyoti RapidSpell Desktop .NET API Docs
SetPosition Method (pos)
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► SetPosition(Int32)
Keyoti RapidSpell Desktop .NET
Sets the pointer position for the NextBadWord iterator.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void SetPosition(
    int pos
)
public virtual void SetPosition(
    int pos
)
Public Overridable Sub SetPosition (
    pos As Integer
)
Public Overridable Sub SetPosition (
    pos As Integer
)
public:
virtual void SetPosition(
    int pos
)
public:
virtual void SetPosition(
    int pos
)
abstract SetPosition :
        pos : int -> unit
override SetPosition :
        pos : int -> unit
abstract SetPosition :
        pos : int -> unit
override SetPosition :
        pos : int -> unit
Parameters
pos (Int32)
Remarks
Further calls to NextBadWord will look for the next bad word from position pos. If position > the text length it is set to the text length. If position < 0, it is set to zero.


SetSeparateHyphenWords Method (separate)

Keyoti RapidSpell Desktop .NET API Docs
SetSeparateHyphenWords Method (separate)
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► SetSeparateHyphenWords(Boolean)
Keyoti RapidSpell Desktop .NET
Sets whether to separate words with hyphens in them into separate words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void SetSeparateHyphenWords(
    bool separate
)
public virtual void SetSeparateHyphenWords(
    bool separate
)
Public Overridable Sub SetSeparateHyphenWords (
    separate As Boolean
)
Public Overridable Sub SetSeparateHyphenWords (
    separate As Boolean
)
public:
virtual void SetSeparateHyphenWords(
    bool separate
)
public:
virtual void SetSeparateHyphenWords(
    bool separate
)
abstract SetSeparateHyphenWords :
        separate : bool -> unit
override SetSeparateHyphenWords :
        separate : bool -> unit
abstract SetSeparateHyphenWords :
        separate : bool -> unit
override SetSeparateHyphenWords :
        separate : bool -> unit
Parameters
separate (Boolean)


SetSuggestionsMethod Method (method)

Keyoti RapidSpell Desktop .NET API Docs
SetSuggestionsMethod Method (method)
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► SetSuggestionsMethod(Int32)
Keyoti RapidSpell Desktop .NET
Sets the suggestions method, where method is an integer identifier.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void SetSuggestionsMethod(
    int method
)
public virtual void SetSuggestionsMethod(
    int method
)
Public Overridable Sub SetSuggestionsMethod (
    method As Integer
)
Public Overridable Sub SetSuggestionsMethod (
    method As Integer
)
public:
virtual void SetSuggestionsMethod(
    int method
)
public:
virtual void SetSuggestionsMethod(
    int method
)
abstract SetSuggestionsMethod :
        method : int -> unit
override SetSuggestionsMethod :
        method : int -> unit
abstract SetSuggestionsMethod :
        method : int -> unit
override SetSuggestionsMethod :
        method : int -> unit
Parameters
method (Int32)


SetUserDictionary Method

Keyoti RapidSpell Desktop .NET API Docs
SetUserDictionary Method
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► SetUserDictionary()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | SetUserDictionary(UserDictionary) | Sets the UserDictionary object to be used as a user dictionary source.
 | SetUserDictionary(String) | Sets the UserDictionary file path to be used as a user dictionary source.


SetUserDictionary Method (userDictionary)

Keyoti RapidSpell Desktop .NET API Docs
SetUserDictionary Method (userDictionary)
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► SetUserDictionary(UserDictionary)
Keyoti RapidSpell Desktop .NET
Sets the UserDictionary object to be used as a user dictionary source.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void SetUserDictionary(
    UserDictionary userDictionary
)
public virtual void SetUserDictionary(
    UserDictionary userDictionary
)
Public Overridable Sub SetUserDictionary (
    userDictionary As UserDictionary
)
Public Overridable Sub SetUserDictionary (
    userDictionary As UserDictionary
)
public:
virtual void SetUserDictionary(
    UserDictionary^ userDictionary
)
public:
virtual void SetUserDictionary(
    UserDictionary^ userDictionary
)
abstract SetUserDictionary :
        userDictionary : UserDictionary -> unit
override SetUserDictionary :
        userDictionary : UserDictionary -> unit
abstract SetUserDictionary :
        userDictionary : UserDictionary -> unit
override SetUserDictionary :
        userDictionary : UserDictionary -> unit
Parameters
userDictionary (UserDictionary)


SetUserDictionary Method (userDictionary)

Keyoti RapidSpell Desktop .NET API Docs
SetUserDictionary Method (userDictionary)
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► SetUserDictionary(String)
Keyoti RapidSpell Desktop .NET
Sets the UserDictionary file path to be used as a user dictionary source.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void SetUserDictionary(
    string userDictionary
)
public virtual void SetUserDictionary(
    string userDictionary
)
Public Overridable Sub SetUserDictionary (
    userDictionary As String
)
Public Overridable Sub SetUserDictionary (
    userDictionary As String
)
public:
virtual void SetUserDictionary(
    String^ userDictionary
)
public:
virtual void SetUserDictionary(
    String^ userDictionary
)
abstract SetUserDictionary :
        userDictionary : string -> unit
override SetUserDictionary :
        userDictionary : string -> unit
abstract SetUserDictionary :
        userDictionary : string -> unit
override SetUserDictionary :
        userDictionary : string -> unit
Parameters
userDictionary (String)


SuggestSplitWords Property

Keyoti RapidSpell Desktop .NET API Docs
SuggestSplitWords Property
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► SuggestSplitWords
Keyoti RapidSpell Desktop .NET
Whether to look for connected words in suggestions.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool SuggestSplitWords { get; set; }
public virtual bool SuggestSplitWords { get; set; }
Public Overridable Property SuggestSplitWords As Boolean
    Get
    Set
Public Overridable Property SuggestSplitWords As Boolean
    Get
    Set
public:
virtual property bool SuggestSplitWords {
    bool get ();
    void set (bool value);
}
public:
virtual property bool SuggestSplitWords {
    bool get ();
    void set (bool value);
}
abstract SuggestSplitWords : bool with get, set
override SuggestSplitWords : bool with get, set
abstract SuggestSplitWords : bool with get, set
override SuggestSplitWords : bool with get, set
Property Value
Boolean
Remarks
if this=true then suggestions may include joined words.

Eg; suggestions for "myhouse" will include "my house"


TextBoundary Property

Keyoti RapidSpell Desktop .NET API Docs
TextBoundary Property
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► TextBoundary
Keyoti RapidSpell Desktop .NET
The AdvancedTextBoundary class to use to parse words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public AdvancedTextBoundary TextBoundary { get; set; }
public AdvancedTextBoundary TextBoundary { get; set; }
Public Property TextBoundary As AdvancedTextBoundary
    Get
    Set
Public Property TextBoundary As AdvancedTextBoundary
    Get
    Set
public:
virtual property AdvancedTextBoundary^ TextBoundary {
    AdvancedTextBoundary^ get () sealed;
    void set (AdvancedTextBoundary^ value) sealed;
}
public:
virtual property AdvancedTextBoundary^ TextBoundary {
    AdvancedTextBoundary^ get () sealed;
    void set (AdvancedTextBoundary^ value) sealed;
}
abstract TextBoundary : AdvancedTextBoundary with get, set
override TextBoundary : AdvancedTextBoundary with get, set
abstract TextBoundary : AdvancedTextBoundary with get, set
override TextBoundary : AdvancedTextBoundary with get, set
Property Value
AdvancedTextBoundary


UnloadMainDictionary Method

Keyoti RapidSpell Desktop .NET API Docs
UnloadMainDictionary Method
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► UnloadMainDictionary()()()()
Keyoti RapidSpell Desktop .NET
Empties the main dictionary store.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void UnloadMainDictionary()
public void UnloadMainDictionary()
Public Sub UnloadMainDictionary
Public Sub UnloadMainDictionary
public:
void UnloadMainDictionary()
public:
void UnloadMainDictionary()
member UnloadMainDictionary : unit -> unit

member UnloadMainDictionary : unit -> unit


userDictionary Property

Keyoti RapidSpell Desktop .NET API Docs
userDictionary Property
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► userDictionary
Keyoti RapidSpell Desktop .NET
The user dictionary, this should be null (C#) or nothing (VB.NET) if no user dictionary is being used.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual UserDictionary userDictionary { get; }
public virtual UserDictionary userDictionary { get; }
Public Overridable ReadOnly Property userDictionary As UserDictionary
    Get
Public Overridable ReadOnly Property userDictionary As UserDictionary
    Get
public:
virtual property UserDictionary^ userDictionary {
    UserDictionary^ get ();
}
public:
virtual property UserDictionary^ userDictionary {
    UserDictionary^ get ();
}
abstract userDictionary : UserDictionary with get
override userDictionary : UserDictionary with get
abstract userDictionary : UserDictionary with get
override userDictionary : UserDictionary with get
Return Value
UserDictionary
This implementation always returns null.


V2Parser Property

Keyoti RapidSpell Desktop .NET API Docs
V2Parser Property
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► V2Parser
Keyoti RapidSpell Desktop .NET
Whether to use parser version 2
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool V2Parser { get; set; }
public virtual bool V2Parser { get; set; }
Public Overridable Property V2Parser As Boolean
    Get
    Set
Public Overridable Property V2Parser As Boolean
    Get
    Set
public:
virtual property bool V2Parser {
    bool get ();
    void set (bool value);
}
public:
virtual property bool V2Parser {
    bool get ();
    void set (bool value);
}
abstract V2Parser : bool with get, set
override V2Parser : bool with get, set
abstract V2Parser : bool with get, set
override V2Parser : bool with get, set
Property Value
Boolean


WarnDuplicates Property

Keyoti RapidSpell Desktop .NET API Docs
WarnDuplicates Property
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► WarnDuplicates
Keyoti RapidSpell Desktop .NET
Whether to treat duplicate words as errors (eg. "this is is an error").
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool WarnDuplicates { get; set; }
public virtual bool WarnDuplicates { get; set; }
Public Overridable Property WarnDuplicates As Boolean
    Get
    Set
Public Overridable Property WarnDuplicates As Boolean
    Get
    Set
public:
virtual property bool WarnDuplicates {
    bool get ();
    void set (bool value);
}
public:
virtual property bool WarnDuplicates {
    bool get ();
    void set (bool value);
}
abstract WarnDuplicates : bool with get, set
override WarnDuplicates : bool with get, set
abstract WarnDuplicates : bool with get, set
override WarnDuplicates : bool with get, set
Property Value
Boolean


WordAdded Event

Keyoti RapidSpell Desktop .NET API Docs
WordAdded Event
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► WordAdded
Keyoti RapidSpell Desktop .NET
Fires when a word is added
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event WordAddedEventHandler WordAdded
public event WordAddedEventHandler WordAdded
Public Event WordAdded As WordAddedEventHandler
Public Event WordAdded As WordAddedEventHandler
public:
virtual  event WordAddedEventHandler^ WordAdded {
    void add (WordAddedEventHandler^ value);
    void remove (WordAddedEventHandler^ value);
}
public:
virtual  event WordAddedEventHandler^ WordAdded {
    void add (WordAddedEventHandler^ value);
    void remove (WordAddedEventHandler^ value);
}
abstract WordAdded : IEvent<WordAddedEventHandler,
    WordAddedEventArgs>
override WordAdded : IEvent<WordAddedEventHandler,
    WordAddedEventArgs>
abstract WordAdded : IEvent<WordAddedEventHandler,
    WordAddedEventArgs>
override WordAdded : IEvent<WordAddedEventHandler,
    WordAddedEventArgs>
Value
WordAddedEventHandler


ComClientInteropSupport Class

Keyoti RapidSpell Desktop .NET API Docs
ComClientInteropSupport Class
API ► Keyoti.RapidSpell ► ComClientInteropSupport
Keyoti RapidSpell Desktop .NET
This class supports users who access RapidSpell controls from COM code.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class ComClientInteropSupport
public class ComClientInteropSupport
Public Class ComClientInteropSupport
Public Class ComClientInteropSupport
public ref class ComClientInteropSupport
public ref class ComClientInteropSupport
type ComClientInteropSupport =  class end
type ComClientInteropSupport =  class end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ComClientInteropSupport()()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | Key | The COM support key (email support@keyoti.com for a key).
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Remarks
RapidSpell .NET, although completely written in .NET, can be used from COM, as per MS documented procedure. Please note that according to MS, not all containers are 'supported' http://support.microsoft.com/default.aspx?scid=KB;EN-US;311334
Inheritance Hierarchy
Object
ComClientInteropSupport


ComClientInteropSupport Constructor

Keyoti RapidSpell Desktop .NET API Docs
ComClientInteropSupport Constructor
API ► Keyoti.RapidSpell ► ComClientInteropSupport ► ComClientInteropSupport()()()()
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ComClientInteropSupport()
public ComClientInteropSupport()
Public Sub New
Public Sub New
public:
ComClientInteropSupport()
public:
ComClientInteropSupport()
new : unit -> ComClientInteropSupport
new : unit -> ComClientInteropSupport


Key Property

Keyoti RapidSpell Desktop .NET API Docs
Key Property
API ► Keyoti.RapidSpell ► ComClientInteropSupport ► Key
Keyoti RapidSpell Desktop .NET
The COM support key (email support@keyoti.com for a key).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string Key { set; }
public string Key { set; }
Public WriteOnly Property Key As String
    Set
Public WriteOnly Property Key As String
    Set
public:
property String^ Key {
    void set (String^ value);
}
public:
property String^ Key {
    void set (String^ value);
}
member Key : string with set

member Key : string with set
Property Value
String


ContextMenuInformation Class

Keyoti RapidSpell Desktop .NET API Docs
ContextMenuInformation Class
API ► Keyoti.RapidSpell ► ContextMenuInformation
Keyoti RapidSpell Desktop .NET
Describes the context menu that should be shown to the user for a particular error.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class ContextMenuInformation
public class ContextMenuInformation
Public Class ContextMenuInformation
Public Class ContextMenuInformation
public ref class ContextMenuInformation
public ref class ContextMenuInformation
type ContextMenuInformation =  class end
type ContextMenuInformation =  class end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ContextMenuInformation()()()() |
 | AddMenuValid | Whether the add menu item should be enabled.
 | BadWord | The BadWord that was the menu is for.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MenuHasAdd | Whether the menu has an add word option.
 | MenuHasIgnore | Whether the menu has an ignore option.
 | MenuHasIgnoreAll | Whether the menu has an ignore all option.
 | MenuItems | The menu item objects that can be added to a context menu directly, this is usually of an array of ToolStripItem or MenuItem.
 | Suggestions | List of string suggestions for the error word.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
ContextMenuInformation


ContextMenuInformation Constructor

Keyoti RapidSpell Desktop .NET API Docs
ContextMenuInformation Constructor
API ► Keyoti.RapidSpell ► ContextMenuInformation ► ContextMenuInformation()()()()
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ContextMenuInformation()
public ContextMenuInformation()
Public Sub New
Public Sub New
public:
ContextMenuInformation()
public:
ContextMenuInformation()
new : unit -> ContextMenuInformation
new : unit -> ContextMenuInformation


AddMenuValid Property

Keyoti RapidSpell Desktop .NET API Docs
AddMenuValid Property
API ► Keyoti.RapidSpell ► ContextMenuInformation ► AddMenuValid
Keyoti RapidSpell Desktop .NET
Whether the add menu item should be enabled.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool AddMenuValid { get; }
public bool AddMenuValid { get; }
Public ReadOnly Property AddMenuValid As Boolean
    Get
Public ReadOnly Property AddMenuValid As Boolean
    Get
public:
property bool AddMenuValid {
    bool get ();
}
public:
property bool AddMenuValid {
    bool get ();
}
member AddMenuValid : bool with get

member AddMenuValid : bool with get
Property Value
Boolean


BadWord Property

Keyoti RapidSpell Desktop .NET API Docs
BadWord Property
API ► Keyoti.RapidSpell ► ContextMenuInformation ► BadWord
Keyoti RapidSpell Desktop .NET
The BadWord that was the menu is for.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public BadWord BadWord { get; }
public BadWord BadWord { get; }
Public ReadOnly Property BadWord As BadWord
    Get
Public ReadOnly Property BadWord As BadWord
    Get
public:
property BadWord^ BadWord {
    BadWord^ get ();
}
public:
property BadWord^ BadWord {
    BadWord^ get ();
}
member BadWord : BadWord with get

member BadWord : BadWord with get
Property Value
BadWord


MenuHasAdd Property

Keyoti RapidSpell Desktop .NET API Docs
MenuHasAdd Property
API ► Keyoti.RapidSpell ► ContextMenuInformation ► MenuHasAdd
Keyoti RapidSpell Desktop .NET
Whether the menu has an add word option.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool MenuHasAdd { get; }
public bool MenuHasAdd { get; }
Public ReadOnly Property MenuHasAdd As Boolean
    Get
Public ReadOnly Property MenuHasAdd As Boolean
    Get
public:
property bool MenuHasAdd {
    bool get ();
}
public:
property bool MenuHasAdd {
    bool get ();
}
member MenuHasAdd : bool with get

member MenuHasAdd : bool with get
Property Value
Boolean


MenuHasIgnore Property

Keyoti RapidSpell Desktop .NET API Docs
MenuHasIgnore Property
API ► Keyoti.RapidSpell ► ContextMenuInformation ► MenuHasIgnore
Keyoti RapidSpell Desktop .NET
Whether the menu has an ignore option.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool MenuHasIgnore { get; }
public bool MenuHasIgnore { get; }
Public ReadOnly Property MenuHasIgnore As Boolean
    Get
Public ReadOnly Property MenuHasIgnore As Boolean
    Get
public:
property bool MenuHasIgnore {
    bool get ();
}
public:
property bool MenuHasIgnore {
    bool get ();
}
member MenuHasIgnore : bool with get

member MenuHasIgnore : bool with get
Property Value
Boolean


MenuHasIgnoreAll Property

Keyoti RapidSpell Desktop .NET API Docs
MenuHasIgnoreAll Property
API ► Keyoti.RapidSpell ► ContextMenuInformation ► MenuHasIgnoreAll
Keyoti RapidSpell Desktop .NET
Whether the menu has an ignore all option.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool MenuHasIgnoreAll { get; }
public bool MenuHasIgnoreAll { get; }
Public ReadOnly Property MenuHasIgnoreAll As Boolean
    Get
Public ReadOnly Property MenuHasIgnoreAll As Boolean
    Get
public:
property bool MenuHasIgnoreAll {
    bool get ();
}
public:
property bool MenuHasIgnoreAll {
    bool get ();
}
member MenuHasIgnoreAll : bool with get

member MenuHasIgnoreAll : bool with get
Property Value
Boolean


MenuItems Property

Keyoti RapidSpell Desktop .NET API Docs
MenuItems Property
API ► Keyoti.RapidSpell ► ContextMenuInformation ► MenuItems
Keyoti RapidSpell Desktop .NET
The menu item objects that can be added to a context menu directly, this is usually of an array of ToolStripItem or MenuItem.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Object MenuItems { get; }
public Object MenuItems { get; }
Public ReadOnly Property MenuItems As Object
    Get
Public ReadOnly Property MenuItems As Object
    Get
public:
property Object^ MenuItems {
    Object^ get ();
}
public:
property Object^ MenuItems {
    Object^ get ();
}
member MenuItems : Object with get

member MenuItems : Object with get
Property Value
Object


Suggestions Property

Keyoti RapidSpell Desktop .NET API Docs
Suggestions Property
API ► Keyoti.RapidSpell ► ContextMenuInformation ► Suggestions
Keyoti RapidSpell Desktop .NET
List of string suggestions for the error word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ArrayList Suggestions { get; }
public ArrayList Suggestions { get; }
Public ReadOnly Property Suggestions As ArrayList
    Get
Public ReadOnly Property Suggestions As ArrayList
    Get
public:
property ArrayList^ Suggestions {
    ArrayList^ get ();
}
public:
property ArrayList^ Suggestions {
    ArrayList^ get ();
}
member Suggestions : ArrayList with get

member Suggestions : ArrayList with get
Property Value
ArrayList


CutCopyPasteContextMenuMaker Class

Keyoti RapidSpell Desktop .NET API Docs
CutCopyPasteContextMenuMaker Class
API ► Keyoti.RapidSpell ► CutCopyPasteContextMenuMaker
Keyoti RapidSpell Desktop .NET
Create a Cut/Copy/Paste ContextMenu
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class CutCopyPasteContextMenuMaker
public class CutCopyPasteContextMenuMaker
Public Class CutCopyPasteContextMenuMaker
Public Class CutCopyPasteContextMenuMaker
public ref class CutCopyPasteContextMenuMaker
public ref class CutCopyPasteContextMenuMaker
type CutCopyPasteContextMenuMaker =  class end
type CutCopyPasteContextMenuMaker =  class end
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CutCopyPasteContextMenuMaker(TextBoxBase, Boolean) | New
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMenu()()()() | The context menu
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
CutCopyPasteContextMenuMaker


CutCopyPasteContextMenuMaker Constructor (textBox, showUndo)

Keyoti RapidSpell Desktop .NET API Docs
CutCopyPasteContextMenuMaker Constructor (textBox, showUndo)
API ► Keyoti.RapidSpell ► CutCopyPasteContextMenuMaker ► CutCopyPasteContextMenuMaker(TextBoxBase, Boolean)
Keyoti RapidSpell Desktop .NET
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public CutCopyPasteContextMenuMaker(
    TextBoxBase textBox,
    bool showUndo
)
public CutCopyPasteContextMenuMaker(
    TextBoxBase textBox,
    bool showUndo
)
Public Sub New (
    textBox As TextBoxBase,
    showUndo As Boolean
)
Public Sub New (
    textBox As TextBoxBase,
    showUndo As Boolean
)
public:
CutCopyPasteContextMenuMaker(
    TextBoxBase^ textBox,
    bool showUndo
)
public:
CutCopyPasteContextMenuMaker(
    TextBoxBase^ textBox,
    bool showUndo
)
new :
        textBox : TextBoxBase *
        showUndo : bool -> CutCopyPasteContextMenuMaker
new :
        textBox : TextBoxBase *
        showUndo : bool -> CutCopyPasteContextMenuMaker
Parameters
textBox (TextBoxBase)
showUndo (Boolean)


GetMenu Method

Keyoti RapidSpell Desktop .NET API Docs
GetMenu Method
API ► Keyoti.RapidSpell ► CutCopyPasteContextMenuMaker ► GetMenu()()()()
Keyoti RapidSpell Desktop .NET
The context menu
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ContextMenu GetMenu()
public ContextMenu GetMenu()
Public Function GetMenu As ContextMenu
Public Function GetMenu As ContextMenu
public:
ContextMenu^ GetMenu()
public:
ContextMenu^ GetMenu()
member GetMenu : unit -> ContextMenu

member GetMenu : unit -> ContextMenu
Return Value
ContextMenu


CutCopyPasteContextMenuStripMaker Class

Keyoti RapidSpell Desktop .NET API Docs
CutCopyPasteContextMenuStripMaker Class
API ► Keyoti.RapidSpell ► CutCopyPasteContextMenuStripMaker
Keyoti RapidSpell Desktop .NET
Creates a Cut/Copy/Paste ContextMenuStrip
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class CutCopyPasteContextMenuStripMaker
public class CutCopyPasteContextMenuStripMaker
Public Class CutCopyPasteContextMenuStripMaker
Public Class CutCopyPasteContextMenuStripMaker
public ref class CutCopyPasteContextMenuStripMaker
public ref class CutCopyPasteContextMenuStripMaker
type CutCopyPasteContextMenuStripMaker =  class end
type CutCopyPasteContextMenuStripMaker =  class end
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CutCopyPasteContextMenuStripMaker(TextBoxBase, Boolean) | Makes menu strip.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMenu()()()() | The context menu
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
CutCopyPasteContextMenuStripMaker


CutCopyPasteContextMenuStripMaker Constructor (textBox, showUndo)

Keyoti RapidSpell Desktop .NET API Docs
CutCopyPasteContextMenuStripMaker Constructor (textBox, showUndo)
API ► Keyoti.RapidSpell ► CutCopyPasteContextMenuStripMaker ► CutCopyPasteContextMenuStripMaker(TextBoxBase, Boolean)
Keyoti RapidSpell Desktop .NET
Makes menu strip.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public CutCopyPasteContextMenuStripMaker(
    TextBoxBase textBox,
    bool showUndo
)
public CutCopyPasteContextMenuStripMaker(
    TextBoxBase textBox,
    bool showUndo
)
Public Sub New (
    textBox As TextBoxBase,
    showUndo As Boolean
)
Public Sub New (
    textBox As TextBoxBase,
    showUndo As Boolean
)
public:
CutCopyPasteContextMenuStripMaker(
    TextBoxBase^ textBox,
    bool showUndo
)
public:
CutCopyPasteContextMenuStripMaker(
    TextBoxBase^ textBox,
    bool showUndo
)
new :
        textBox : TextBoxBase *
        showUndo : bool -> CutCopyPasteContextMenuStripMaker
new :
        textBox : TextBoxBase *
        showUndo : bool -> CutCopyPasteContextMenuStripMaker
Parameters
textBox (TextBoxBase)
showUndo (Boolean)


GetMenu Method

Keyoti RapidSpell Desktop .NET API Docs
GetMenu Method
API ► Keyoti.RapidSpell ► CutCopyPasteContextMenuStripMaker ► GetMenu()()()()
Keyoti RapidSpell Desktop .NET
The context menu
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ContextMenuStrip GetMenu()
public ContextMenuStrip GetMenu()
Public Function GetMenu As ContextMenuStrip
Public Function GetMenu As ContextMenuStrip
public:
ContextMenuStrip^ GetMenu()
public:
ContextMenuStrip^ GetMenu()
member GetMenu : unit -> ContextMenuStrip

member GetMenu : unit -> ContextMenuStrip
Return Value
ContextMenuStrip


DialogTexts Class

Keyoti RapidSpell Desktop .NET API Docs
DialogTexts Class
API ► Keyoti.RapidSpell ► DialogTexts
Keyoti RapidSpell Desktop .NET
Contains all texts in RapidSpellDialog and user options.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public class DialogTexts
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public class DialogTexts
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Class DialogTexts
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Class DialogTexts
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public ref class DialogTexts
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public ref class DialogTexts
[<TypeConverterAttribute(typeof(ExpandableObjectConverter))>]
type DialogTexts =  class end
[<TypeConverterAttribute(typeof(ExpandableObjectConverter))>]
type DialogTexts =  class end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DialogTexts()()()() |
 | AddButtonText | Add button text.
 | ApplyLanguage(LanguageType, LanguageType) | Applies text settings
 | ApplyTo(IUserInterfaceFormPresenter) | Applies text settings
 | ApplyTo(IDialogViewUserDictionaryEdit) | Applies text settings
 | ApplyTo(IDialogViewUserDictionarySelect) | Applies text settings
 | ApplyTo(IDialogViewOptions) | Applies text settings
 | CancelButtonText | Cancel button text.
 | ChangeAllButtonText | Change All button text.
 | ChangeButtonText | Change button text.
 | CheckCompletePopUpText | Check complete pop up text
 | CheckCompletePopUpTitle | Check complete pop up title
 | CheckingSpellingText | Checking spelling text
 | DialogTitleText | Dialog title text
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FindingSuggestionsLabelText | Finding suggestions label text.
 | FindSuggestionsLabelText | Find suggestions label text.
 | FinishedCheckingSelectionPopUpText | Finished checking selection dialog text
 | FinishedCheckingSelectionPopUpTitle | Finished checking selection dialog title
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | IgnoreAllButtonText | Ignore All button text.
 | IgnoreButtonText | Ignore button text.
 | InDictionaryLabelText | In dictionary label text
 | LoadingDictionaryText | UI Text
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NoSuggestionsText | No suggestions found text
 | NotInDictionaryLabelText | Not in dictionary label text
 | OptionsButtonText | Options button text.
 | OptionsFormAdvancedSettingsText | UI Text
 | OptionsFormAlwaysSuggestCorrectionsText | UI Text
 | OptionsFormBasicSettingsText | UI Text
 | OptionsFormCancelText | UI Text
 | OptionsFormCheckAsYouTypeText | UI Text
 | OptionsFormIgnoreImproperCaseText | UI Text
 | OptionsFormIgnoreInternetAddressesText | UI Text
 | OptionsFormIgnoreWordsInUppercaseText | UI Text
 | OptionsFormIgnoreWordsWithNumbersText | UI Text
 | OptionsFormOKText | UI Text
 | OptionsFormRecheckTextText | UI Text
 | OptionsFormSuggestFromMainDictionaryOnlyText | UI Text
 | OptionsFormTitleText | UI Text
 | OptionsFormUserDictionaryEditText | UI Text
 | RemoveDuplicateWordText | Remove duplicate word text
 | ResetText | Used at design time to reset UI text.
 | ResumeButtonText | Resume button text
 | SuggestionsLabelText | Suggestions label text
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | UndoButtonText | Undo button text.
 | UserDictionaryFormAddText | UI Text
 | UserDictionaryFormCancelText | UI Text
 | UserDictionaryFormContentsText | UI Text
 | UserDictionaryFormDeleteText | UI Text
 | UserDictionaryFormDictionaryLabelText | UI Text
 | UserDictionaryFormOKText | UI Text
 | UserDictionaryFormTitleText | UI Text
 | UserDictionaryFormWordLabelText | UI Text
 | UserDictionarySelectFormAddFileText |
 | UserDictionarySelectFormCancelText | UI Text
 | UserDictionarySelectFormChangeDefaultText |
 | UserDictionarySelectFormDeleteText | UI Text
 | UserDictionarySelectFormDictionaryLabelText | UI Text
 | UserDictionarySelectFormEditFileText |
 | UserDictionarySelectFormGroupBoxTitleText | UI Text
 | UserDictionarySelectFormNewFileText |
 | UserDictionarySelectFormOKText | UI Text
 | UserDictionarySelectFormRemoveFileText |
 | UserDictionarySelectFormTitleText | UI Text
Inheritance Hierarchy
Object
DialogTexts


DialogTexts Constructor

Keyoti RapidSpell Desktop .NET API Docs
DialogTexts Constructor
API ► Keyoti.RapidSpell ► DialogTexts ► DialogTexts()()()()
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public DialogTexts()
public DialogTexts()
Public Sub New
Public Sub New
public:
DialogTexts()
public:
DialogTexts()
new : unit -> DialogTexts
new : unit -> DialogTexts


AddButtonText Property

Keyoti RapidSpell Desktop .NET API Docs
AddButtonText Property
API ► Keyoti.RapidSpell ► DialogTexts ► AddButtonText
Keyoti RapidSpell Desktop .NET
Add button text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string AddButtonText { get; set; }
public string AddButtonText { get; set; }
Public Property AddButtonText As String
    Get
    Set
Public Property AddButtonText As String
    Get
    Set
public:
property String^ AddButtonText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ AddButtonText {
    String^ get ();
    void set (String^ value);
}
member AddButtonText : string with get, set

member AddButtonText : string with get, set
Property Value
String


ApplyLanguage Method (newlang, oldlang)

Keyoti RapidSpell Desktop .NET API Docs
ApplyLanguage Method (newlang, oldlang)
API ► Keyoti.RapidSpell ► DialogTexts ► ApplyLanguage(LanguageType, LanguageType)
Keyoti RapidSpell Desktop .NET
Applies text settings
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void ApplyLanguage(
    LanguageType newlang,
    LanguageType oldlang
)
public void ApplyLanguage(
    LanguageType newlang,
    LanguageType oldlang
)
Public Sub ApplyLanguage (
    newlang As LanguageType,
    oldlang As LanguageType
)
Public Sub ApplyLanguage (
    newlang As LanguageType,
    oldlang As LanguageType
)
public:
void ApplyLanguage(
    LanguageType newlang,
    LanguageType oldlang
)
public:
void ApplyLanguage(
    LanguageType newlang,
    LanguageType oldlang
)
member ApplyLanguage :
        newlang : LanguageType *
        oldlang : LanguageType -> unit

member ApplyLanguage :
        newlang : LanguageType *
        oldlang : LanguageType -> unit
Parameters
newlang (LanguageType)
oldlang (LanguageType)


ApplyTo Method

Keyoti RapidSpell Desktop .NET API Docs
ApplyTo Method
API ► Keyoti.RapidSpell ► DialogTexts ► ApplyTo()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | ApplyTo(IUserInterfaceFormPresenter) | Applies text settings
 | ApplyTo(IDialogViewUserDictionaryEdit) | Applies text settings
 | ApplyTo(IDialogViewUserDictionarySelect) | Applies text settings
 | ApplyTo(IDialogViewOptions) | Applies text settings


ApplyTo Method (o)

Keyoti RapidSpell Desktop .NET API Docs
ApplyTo Method (o)
API ► Keyoti.RapidSpell ► DialogTexts ► ApplyTo(IDialogViewOptions)
Keyoti RapidSpell Desktop .NET
Applies text settings
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void ApplyTo(
    IDialogViewOptions o
)
public void ApplyTo(
    IDialogViewOptions o
)
Public Sub ApplyTo (
    o As IDialogViewOptions
)
Public Sub ApplyTo (
    o As IDialogViewOptions
)
public:
void ApplyTo(
    IDialogViewOptions^ o
)
public:
void ApplyTo(
    IDialogViewOptions^ o
)
member ApplyTo :
        o : IDialogViewOptions -> unit

member ApplyTo :
        o : IDialogViewOptions -> unit
Parameters
o (IDialogViewOptions)


ApplyTo Method (o)

Keyoti RapidSpell Desktop .NET API Docs
ApplyTo Method (o)
API ► Keyoti.RapidSpell ► DialogTexts ► ApplyTo(IDialogViewUserDictionaryEdit)
Keyoti RapidSpell Desktop .NET
Applies text settings
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void ApplyTo(
    IDialogViewUserDictionaryEdit o
)
public void ApplyTo(
    IDialogViewUserDictionaryEdit o
)
Public Sub ApplyTo (
    o As IDialogViewUserDictionaryEdit
)
Public Sub ApplyTo (
    o As IDialogViewUserDictionaryEdit
)
public:
void ApplyTo(
    IDialogViewUserDictionaryEdit^ o
)
public:
void ApplyTo(
    IDialogViewUserDictionaryEdit^ o
)
member ApplyTo :
        o : IDialogViewUserDictionaryEdit -> unit

member ApplyTo :
        o : IDialogViewUserDictionaryEdit -> unit
Parameters
o (IDialogViewUserDictionaryEdit)


ApplyTo Method (o)

Keyoti RapidSpell Desktop .NET API Docs
ApplyTo Method (o)
API ► Keyoti.RapidSpell ► DialogTexts ► ApplyTo(IDialogViewUserDictionarySelect)
Keyoti RapidSpell Desktop .NET
Applies text settings
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void ApplyTo(
    IDialogViewUserDictionarySelect o
)
public void ApplyTo(
    IDialogViewUserDictionarySelect o
)
Public Sub ApplyTo (
    o As IDialogViewUserDictionarySelect
)
Public Sub ApplyTo (
    o As IDialogViewUserDictionarySelect
)
public:
void ApplyTo(
    IDialogViewUserDictionarySelect^ o
)
public:
void ApplyTo(
    IDialogViewUserDictionarySelect^ o
)
member ApplyTo :
        o : IDialogViewUserDictionarySelect -> unit

member ApplyTo :
        o : IDialogViewUserDictionarySelect -> unit
Parameters
o (IDialogViewUserDictionarySelect)


ApplyTo Method (rs)

Keyoti RapidSpell Desktop .NET API Docs
ApplyTo Method (rs)
API ► Keyoti.RapidSpell ► DialogTexts ► ApplyTo(IUserInterfaceFormPresenter)
Keyoti RapidSpell Desktop .NET
Applies text settings
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void ApplyTo(
    IUserInterfaceFormPresenter rs
)
public void ApplyTo(
    IUserInterfaceFormPresenter rs
)
Public Sub ApplyTo (
    rs As IUserInterfaceFormPresenter
)
Public Sub ApplyTo (
    rs As IUserInterfaceFormPresenter
)
public:
void ApplyTo(
    IUserInterfaceFormPresenter^ rs
)
public:
void ApplyTo(
    IUserInterfaceFormPresenter^ rs
)
member ApplyTo :
        rs : IUserInterfaceFormPresenter -> unit

member ApplyTo :
        rs : IUserInterfaceFormPresenter -> unit
Parameters
rs (IUserInterfaceFormPresenter)


CancelButtonText Property

Keyoti RapidSpell Desktop .NET API Docs
CancelButtonText Property
API ► Keyoti.RapidSpell ► DialogTexts ► CancelButtonText
Keyoti RapidSpell Desktop .NET
Cancel button text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string CancelButtonText { get; set; }
public string CancelButtonText { get; set; }
Public Property CancelButtonText As String
    Get
    Set
Public Property CancelButtonText As String
    Get
    Set
public:
property String^ CancelButtonText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ CancelButtonText {
    String^ get ();
    void set (String^ value);
}
member CancelButtonText : string with get, set

member CancelButtonText : string with get, set
Property Value
String


ChangeAllButtonText Property

Keyoti RapidSpell Desktop .NET API Docs
ChangeAllButtonText Property
API ► Keyoti.RapidSpell ► DialogTexts ► ChangeAllButtonText
Keyoti RapidSpell Desktop .NET
Change All button text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string ChangeAllButtonText { get; set; }
public string ChangeAllButtonText { get; set; }
Public Property ChangeAllButtonText As String
    Get
    Set
Public Property ChangeAllButtonText As String
    Get
    Set
public:
property String^ ChangeAllButtonText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ ChangeAllButtonText {
    String^ get ();
    void set (String^ value);
}
member ChangeAllButtonText : string with get, set

member ChangeAllButtonText : string with get, set
Property Value
String


ChangeButtonText Property

Keyoti RapidSpell Desktop .NET API Docs
ChangeButtonText Property
API ► Keyoti.RapidSpell ► DialogTexts ► ChangeButtonText
Keyoti RapidSpell Desktop .NET
Change button text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string ChangeButtonText { get; set; }
public string ChangeButtonText { get; set; }
Public Property ChangeButtonText As String
    Get
    Set
Public Property ChangeButtonText As String
    Get
    Set
public:
property String^ ChangeButtonText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ ChangeButtonText {
    String^ get ();
    void set (String^ value);
}
member ChangeButtonText : string with get, set

member ChangeButtonText : string with get, set
Property Value
String


CheckCompletePopUpText Property

Keyoti RapidSpell Desktop .NET API Docs
CheckCompletePopUpText Property
API ► Keyoti.RapidSpell ► DialogTexts ► CheckCompletePopUpText
Keyoti RapidSpell Desktop .NET
Check complete pop up text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string CheckCompletePopUpText { get; set; }
public string CheckCompletePopUpText { get; set; }
Public Property CheckCompletePopUpText As String
    Get
    Set
Public Property CheckCompletePopUpText As String
    Get
    Set
public:
property String^ CheckCompletePopUpText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ CheckCompletePopUpText {
    String^ get ();
    void set (String^ value);
}
member CheckCompletePopUpText : string with get, set

member CheckCompletePopUpText : string with get, set
Property Value
String


CheckCompletePopUpTitle Property

Keyoti RapidSpell Desktop .NET API Docs
CheckCompletePopUpTitle Property
API ► Keyoti.RapidSpell ► DialogTexts ► CheckCompletePopUpTitle
Keyoti RapidSpell Desktop .NET
Check complete pop up title
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string CheckCompletePopUpTitle { get; set; }
public string CheckCompletePopUpTitle { get; set; }
Public Property CheckCompletePopUpTitle As String
    Get
    Set
Public Property CheckCompletePopUpTitle As String
    Get
    Set
public:
property String^ CheckCompletePopUpTitle {
    String^ get ();
    void set (String^ value);
}
public:
property String^ CheckCompletePopUpTitle {
    String^ get ();
    void set (String^ value);
}
member CheckCompletePopUpTitle : string with get, set

member CheckCompletePopUpTitle : string with get, set
Property Value
String


CheckingSpellingText Property

Keyoti RapidSpell Desktop .NET API Docs
CheckingSpellingText Property
API ► Keyoti.RapidSpell ► DialogTexts ► CheckingSpellingText
Keyoti RapidSpell Desktop .NET
Checking spelling text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string CheckingSpellingText { get; set; }
public string CheckingSpellingText { get; set; }
Public Property CheckingSpellingText As String
    Get
    Set
Public Property CheckingSpellingText As String
    Get
    Set
public:
property String^ CheckingSpellingText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ CheckingSpellingText {
    String^ get ();
    void set (String^ value);
}
member CheckingSpellingText : string with get, set

member CheckingSpellingText : string with get, set
Property Value
String


DialogTitleText Property

Keyoti RapidSpell Desktop .NET API Docs
DialogTitleText Property
API ► Keyoti.RapidSpell ► DialogTexts ► DialogTitleText
Keyoti RapidSpell Desktop .NET
Dialog title text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string DialogTitleText { get; set; }
public string DialogTitleText { get; set; }
Public Property DialogTitleText As String
    Get
    Set
Public Property DialogTitleText As String
    Get
    Set
public:
property String^ DialogTitleText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ DialogTitleText {
    String^ get ();
    void set (String^ value);
}
member DialogTitleText : string with get, set

member DialogTitleText : string with get, set
Property Value
String


FindingSuggestionsLabelText Property

Keyoti RapidSpell Desktop .NET API Docs
FindingSuggestionsLabelText Property
API ► Keyoti.RapidSpell ► DialogTexts ► FindingSuggestionsLabelText
Keyoti RapidSpell Desktop .NET
Finding suggestions label text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string FindingSuggestionsLabelText { get; set; }
public string FindingSuggestionsLabelText { get; set; }
Public Property FindingSuggestionsLabelText As String
    Get
    Set
Public Property FindingSuggestionsLabelText As String
    Get
    Set
public:
property String^ FindingSuggestionsLabelText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ FindingSuggestionsLabelText {
    String^ get ();
    void set (String^ value);
}
member FindingSuggestionsLabelText : string with get, set

member FindingSuggestionsLabelText : string with get, set
Property Value
String


FindSuggestionsLabelText Property

Keyoti RapidSpell Desktop .NET API Docs
FindSuggestionsLabelText Property
API ► Keyoti.RapidSpell ► DialogTexts ► FindSuggestionsLabelText
Keyoti RapidSpell Desktop .NET
Find suggestions label text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string FindSuggestionsLabelText { get; set; }
public string FindSuggestionsLabelText { get; set; }
Public Property FindSuggestionsLabelText As String
    Get
    Set
Public Property FindSuggestionsLabelText As String
    Get
    Set
public:
property String^ FindSuggestionsLabelText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ FindSuggestionsLabelText {
    String^ get ();
    void set (String^ value);
}
member FindSuggestionsLabelText : string with get, set

member FindSuggestionsLabelText : string with get, set
Property Value
String


FinishedCheckingSelectionPopUpText Property

Keyoti RapidSpell Desktop .NET API Docs
FinishedCheckingSelectionPopUpText Property
API ► Keyoti.RapidSpell ► DialogTexts ► FinishedCheckingSelectionPopUpText
Keyoti RapidSpell Desktop .NET
Finished checking selection dialog text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string FinishedCheckingSelectionPopUpText { get; set; }
public string FinishedCheckingSelectionPopUpText { get; set; }
Public Property FinishedCheckingSelectionPopUpText As String
    Get
    Set
Public Property FinishedCheckingSelectionPopUpText As String
    Get
    Set
public:
property String^ FinishedCheckingSelectionPopUpText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ FinishedCheckingSelectionPopUpText {
    String^ get ();
    void set (String^ value);
}
member FinishedCheckingSelectionPopUpText : string with get, set

member FinishedCheckingSelectionPopUpText : string with get, set
Property Value
String


FinishedCheckingSelectionPopUpTitle Property

Keyoti RapidSpell Desktop .NET API Docs
FinishedCheckingSelectionPopUpTitle Property
API ► Keyoti.RapidSpell ► DialogTexts ► FinishedCheckingSelectionPopUpTitle
Keyoti RapidSpell Desktop .NET
Finished checking selection dialog title
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string FinishedCheckingSelectionPopUpTitle { get; set; }
public string FinishedCheckingSelectionPopUpTitle { get; set; }
Public Property FinishedCheckingSelectionPopUpTitle As String
    Get
    Set
Public Property FinishedCheckingSelectionPopUpTitle As String
    Get
    Set
public:
property String^ FinishedCheckingSelectionPopUpTitle {
    String^ get ();
    void set (String^ value);
}
public:
property String^ FinishedCheckingSelectionPopUpTitle {
    String^ get ();
    void set (String^ value);
}
member FinishedCheckingSelectionPopUpTitle : string with get, set

member FinishedCheckingSelectionPopUpTitle : string with get, set
Property Value
String


IgnoreAllButtonText Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreAllButtonText Property
API ► Keyoti.RapidSpell ► DialogTexts ► IgnoreAllButtonText
Keyoti RapidSpell Desktop .NET
Ignore All button text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string IgnoreAllButtonText { get; set; }
public string IgnoreAllButtonText { get; set; }
Public Property IgnoreAllButtonText As String
    Get
    Set
Public Property IgnoreAllButtonText As String
    Get
    Set
public:
property String^ IgnoreAllButtonText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ IgnoreAllButtonText {
    String^ get ();
    void set (String^ value);
}
member IgnoreAllButtonText : string with get, set

member IgnoreAllButtonText : string with get, set
Property Value
String


IgnoreButtonText Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreButtonText Property
API ► Keyoti.RapidSpell ► DialogTexts ► IgnoreButtonText
Keyoti RapidSpell Desktop .NET
Ignore button text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string IgnoreButtonText { get; set; }
public string IgnoreButtonText { get; set; }
Public Property IgnoreButtonText As String
    Get
    Set
Public Property IgnoreButtonText As String
    Get
    Set
public:
property String^ IgnoreButtonText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ IgnoreButtonText {
    String^ get ();
    void set (String^ value);
}
member IgnoreButtonText : string with get, set

member IgnoreButtonText : string with get, set
Property Value
String


InDictionaryLabelText Property

Keyoti RapidSpell Desktop .NET API Docs
InDictionaryLabelText Property
API ► Keyoti.RapidSpell ► DialogTexts ► InDictionaryLabelText
Keyoti RapidSpell Desktop .NET
In dictionary label text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string InDictionaryLabelText { get; set; }
public string InDictionaryLabelText { get; set; }
Public Property InDictionaryLabelText As String
    Get
    Set
Public Property InDictionaryLabelText As String
    Get
    Set
public:
property String^ InDictionaryLabelText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ InDictionaryLabelText {
    String^ get ();
    void set (String^ value);
}
member InDictionaryLabelText : string with get, set

member InDictionaryLabelText : string with get, set
Property Value
String


LoadingDictionaryText Property

Keyoti RapidSpell Desktop .NET API Docs
LoadingDictionaryText Property
API ► Keyoti.RapidSpell ► DialogTexts ► LoadingDictionaryText
Keyoti RapidSpell Desktop .NET
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string LoadingDictionaryText { get; set; }
public string LoadingDictionaryText { get; set; }
Public Property LoadingDictionaryText As String
    Get
    Set
Public Property LoadingDictionaryText As String
    Get
    Set
public:
property String^ LoadingDictionaryText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ LoadingDictionaryText {
    String^ get ();
    void set (String^ value);
}
member LoadingDictionaryText : string with get, set

member LoadingDictionaryText : string with get, set
Property Value
String


NoSuggestionsText Property

Keyoti RapidSpell Desktop .NET API Docs
NoSuggestionsText Property
API ► Keyoti.RapidSpell ► DialogTexts ► NoSuggestionsText
Keyoti RapidSpell Desktop .NET
No suggestions found text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string NoSuggestionsText { get; set; }
public string NoSuggestionsText { get; set; }
Public Property NoSuggestionsText As String
    Get
    Set
Public Property NoSuggestionsText As String
    Get
    Set
public:
property String^ NoSuggestionsText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ NoSuggestionsText {
    String^ get ();
    void set (String^ value);
}
member NoSuggestionsText : string with get, set

member NoSuggestionsText : string with get, set
Property Value
String


NotInDictionaryLabelText Property

Keyoti RapidSpell Desktop .NET API Docs
NotInDictionaryLabelText Property
API ► Keyoti.RapidSpell ► DialogTexts ► NotInDictionaryLabelText
Keyoti RapidSpell Desktop .NET
Not in dictionary label text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string NotInDictionaryLabelText { get; set; }
public string NotInDictionaryLabelText { get; set; }
Public Property NotInDictionaryLabelText As String
    Get
    Set
Public Property NotInDictionaryLabelText As String
    Get
    Set
public:
property String^ NotInDictionaryLabelText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ NotInDictionaryLabelText {
    String^ get ();
    void set (String^ value);
}
member NotInDictionaryLabelText : string with get, set

member NotInDictionaryLabelText : string with get, set
Property Value
String


OptionsButtonText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsButtonText Property
API ► Keyoti.RapidSpell ► DialogTexts ► OptionsButtonText
Keyoti RapidSpell Desktop .NET
Options button text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsButtonText { get; set; }
public string OptionsButtonText { get; set; }
Public Property OptionsButtonText As String
    Get
    Set
Public Property OptionsButtonText As String
    Get
    Set
public:
property String^ OptionsButtonText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OptionsButtonText {
    String^ get ();
    void set (String^ value);
}
member OptionsButtonText : string with get, set

member OptionsButtonText : string with get, set
Property Value
String


OptionsFormAdvancedSettingsText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsFormAdvancedSettingsText Property
API ► Keyoti.RapidSpell ► DialogTexts ► OptionsFormAdvancedSettingsText
Keyoti RapidSpell Desktop .NET
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsFormAdvancedSettingsText { get; set; }
public string OptionsFormAdvancedSettingsText { get; set; }
Public Property OptionsFormAdvancedSettingsText As String
    Get
    Set
Public Property OptionsFormAdvancedSettingsText As String
    Get
    Set
public:
property String^ OptionsFormAdvancedSettingsText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OptionsFormAdvancedSettingsText {
    String^ get ();
    void set (String^ value);
}
member OptionsFormAdvancedSettingsText : string with get, set

member OptionsFormAdvancedSettingsText : string with get, set
Property Value
String


OptionsFormAlwaysSuggestCorrectionsText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsFormAlwaysSuggestCorrectionsText Property
API ► Keyoti.RapidSpell ► DialogTexts ► OptionsFormAlwaysSuggestCorrectionsText
Keyoti RapidSpell Desktop .NET
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsFormAlwaysSuggestCorrectionsText { get; set; }
public string OptionsFormAlwaysSuggestCorrectionsText { get; set; }
Public Property OptionsFormAlwaysSuggestCorrectionsText As String
    Get
    Set
Public Property OptionsFormAlwaysSuggestCorrectionsText As String
    Get
    Set
public:
property String^ OptionsFormAlwaysSuggestCorrectionsText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OptionsFormAlwaysSuggestCorrectionsText {
    String^ get ();
    void set (String^ value);
}
member OptionsFormAlwaysSuggestCorrectionsText : string with get, set

member OptionsFormAlwaysSuggestCorrectionsText : string with get, set
Property Value
String


OptionsFormBasicSettingsText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsFormBasicSettingsText Property
API ► Keyoti.RapidSpell ► DialogTexts ► OptionsFormBasicSettingsText
Keyoti RapidSpell Desktop .NET
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsFormBasicSettingsText { get; set; }
public string OptionsFormBasicSettingsText { get; set; }
Public Property OptionsFormBasicSettingsText As String
    Get
    Set
Public Property OptionsFormBasicSettingsText As String
    Get
    Set
public:
property String^ OptionsFormBasicSettingsText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OptionsFormBasicSettingsText {
    String^ get ();
    void set (String^ value);
}
member OptionsFormBasicSettingsText : string with get, set

member OptionsFormBasicSettingsText : string with get, set
Property Value
String


OptionsFormCancelText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsFormCancelText Property
API ► Keyoti.RapidSpell ► DialogTexts ► OptionsFormCancelText
Keyoti RapidSpell Desktop .NET
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsFormCancelText { get; set; }
public string OptionsFormCancelText { get; set; }
Public Property OptionsFormCancelText As String
    Get
    Set
Public Property OptionsFormCancelText As String
    Get
    Set
public:
property String^ OptionsFormCancelText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OptionsFormCancelText {
    String^ get ();
    void set (String^ value);
}
member OptionsFormCancelText : string with get, set

member OptionsFormCancelText : string with get, set
Property Value
String


OptionsFormCheckAsYouTypeText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsFormCheckAsYouTypeText Property
API ► Keyoti.RapidSpell ► DialogTexts ► OptionsFormCheckAsYouTypeText
Keyoti RapidSpell Desktop .NET
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsFormCheckAsYouTypeText { get; set; }
public string OptionsFormCheckAsYouTypeText { get; set; }
Public Property OptionsFormCheckAsYouTypeText As String
    Get
    Set
Public Property OptionsFormCheckAsYouTypeText As String
    Get
    Set
public:
property String^ OptionsFormCheckAsYouTypeText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OptionsFormCheckAsYouTypeText {
    String^ get ();
    void set (String^ value);
}
member OptionsFormCheckAsYouTypeText : string with get, set

member OptionsFormCheckAsYouTypeText : string with get, set
Property Value
String


OptionsFormIgnoreImproperCaseText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsFormIgnoreImproperCaseText Property
API ► Keyoti.RapidSpell ► DialogTexts ► OptionsFormIgnoreImproperCaseText
Keyoti RapidSpell Desktop .NET
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsFormIgnoreImproperCaseText { get; set; }
public string OptionsFormIgnoreImproperCaseText { get; set; }
Public Property OptionsFormIgnoreImproperCaseText As String
    Get
    Set
Public Property OptionsFormIgnoreImproperCaseText As String
    Get
    Set
public:
property String^ OptionsFormIgnoreImproperCaseText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OptionsFormIgnoreImproperCaseText {
    String^ get ();
    void set (String^ value);
}
member OptionsFormIgnoreImproperCaseText : string with get, set

member OptionsFormIgnoreImproperCaseText : string with get, set
Property Value
String


OptionsFormIgnoreInternetAddressesText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsFormIgnoreInternetAddressesText Property
API ► Keyoti.RapidSpell ► DialogTexts ► OptionsFormIgnoreInternetAddressesText
Keyoti RapidSpell Desktop .NET
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsFormIgnoreInternetAddressesText { get; set; }
public string OptionsFormIgnoreInternetAddressesText { get; set; }
Public Property OptionsFormIgnoreInternetAddressesText As String
    Get
    Set
Public Property OptionsFormIgnoreInternetAddressesText As String
    Get
    Set
public:
property String^ OptionsFormIgnoreInternetAddressesText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OptionsFormIgnoreInternetAddressesText {
    String^ get ();
    void set (String^ value);
}
member OptionsFormIgnoreInternetAddressesText : string with get, set

member OptionsFormIgnoreInternetAddressesText : string with get, set
Property Value
String


OptionsFormIgnoreWordsInUppercaseText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsFormIgnoreWordsInUppercaseText Property
API ► Keyoti.RapidSpell ► DialogTexts ► OptionsFormIgnoreWordsInUppercaseText
Keyoti RapidSpell Desktop .NET
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsFormIgnoreWordsInUppercaseText { get; set; }
public string OptionsFormIgnoreWordsInUppercaseText { get; set; }
Public Property OptionsFormIgnoreWordsInUppercaseText As String
    Get
    Set
Public Property OptionsFormIgnoreWordsInUppercaseText As String
    Get
    Set
public:
property String^ OptionsFormIgnoreWordsInUppercaseText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OptionsFormIgnoreWordsInUppercaseText {
    String^ get ();
    void set (String^ value);
}
member OptionsFormIgnoreWordsInUppercaseText : string with get, set

member OptionsFormIgnoreWordsInUppercaseText : string with get, set
Property Value
String


OptionsFormIgnoreWordsWithNumbersText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsFormIgnoreWordsWithNumbersText Property
API ► Keyoti.RapidSpell ► DialogTexts ► OptionsFormIgnoreWordsWithNumbersText
Keyoti RapidSpell Desktop .NET
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsFormIgnoreWordsWithNumbersText { get; set; }
public string OptionsFormIgnoreWordsWithNumbersText { get; set; }
Public Property OptionsFormIgnoreWordsWithNumbersText As String
    Get
    Set
Public Property OptionsFormIgnoreWordsWithNumbersText As String
    Get
    Set
public:
property String^ OptionsFormIgnoreWordsWithNumbersText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OptionsFormIgnoreWordsWithNumbersText {
    String^ get ();
    void set (String^ value);
}
member OptionsFormIgnoreWordsWithNumbersText : string with get, set

member OptionsFormIgnoreWordsWithNumbersText : string with get, set
Property Value
String


OptionsFormOKText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsFormOKText Property
API ► Keyoti.RapidSpell ► DialogTexts ► OptionsFormOKText
Keyoti RapidSpell Desktop .NET
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsFormOKText { get; set; }
public string OptionsFormOKText { get; set; }
Public Property OptionsFormOKText As String
    Get
    Set
Public Property OptionsFormOKText As String
    Get
    Set
public:
property String^ OptionsFormOKText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OptionsFormOKText {
    String^ get ();
    void set (String^ value);
}
member OptionsFormOKText : string with get, set

member OptionsFormOKText : string with get, set
Property Value
String


OptionsFormRecheckTextText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsFormRecheckTextText Property
API ► Keyoti.RapidSpell ► DialogTexts ► OptionsFormRecheckTextText
Keyoti RapidSpell Desktop .NET
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsFormRecheckTextText { get; set; }
public string OptionsFormRecheckTextText { get; set; }
Public Property OptionsFormRecheckTextText As String
    Get
    Set
Public Property OptionsFormRecheckTextText As String
    Get
    Set
public:
property String^ OptionsFormRecheckTextText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OptionsFormRecheckTextText {
    String^ get ();
    void set (String^ value);
}
member OptionsFormRecheckTextText : string with get, set

member OptionsFormRecheckTextText : string with get, set
Property Value
String


OptionsFormSuggestFromMainDictionaryOnlyText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsFormSuggestFromMainDictionaryOnlyText Property
API ► Keyoti.RapidSpell ► DialogTexts ► OptionsFormSuggestFromMainDictionaryOnlyText
Keyoti RapidSpell Desktop .NET
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsFormSuggestFromMainDictionaryOnlyText { get; set; }
public string OptionsFormSuggestFromMainDictionaryOnlyText { get; set; }
Public Property OptionsFormSuggestFromMainDictionaryOnlyText As String
    Get
    Set
Public Property OptionsFormSuggestFromMainDictionaryOnlyText As String
    Get
    Set
public:
property String^ OptionsFormSuggestFromMainDictionaryOnlyText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OptionsFormSuggestFromMainDictionaryOnlyText {
    String^ get ();
    void set (String^ value);
}
member OptionsFormSuggestFromMainDictionaryOnlyText : string with get, set

member OptionsFormSuggestFromMainDictionaryOnlyText : string with get, set
Property Value
String


OptionsFormTitleText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsFormTitleText Property
API ► Keyoti.RapidSpell ► DialogTexts ► OptionsFormTitleText
Keyoti RapidSpell Desktop .NET
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsFormTitleText { get; set; }
public string OptionsFormTitleText { get; set; }
Public Property OptionsFormTitleText As String
    Get
    Set
Public Property OptionsFormTitleText As String
    Get
    Set
public:
property String^ OptionsFormTitleText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OptionsFormTitleText {
    String^ get ();
    void set (String^ value);
}
member OptionsFormTitleText : string with get, set

member OptionsFormTitleText : string with get, set
Property Value
String


OptionsFormUserDictionaryEditText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsFormUserDictionaryEditText Property
API ► Keyoti.RapidSpell ► DialogTexts ► OptionsFormUserDictionaryEditText
Keyoti RapidSpell Desktop .NET
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsFormUserDictionaryEditText { get; set; }
public string OptionsFormUserDictionaryEditText { get; set; }
Public Property OptionsFormUserDictionaryEditText As String
    Get
    Set
Public Property OptionsFormUserDictionaryEditText As String
    Get
    Set
public:
property String^ OptionsFormUserDictionaryEditText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OptionsFormUserDictionaryEditText {
    String^ get ();
    void set (String^ value);
}
member OptionsFormUserDictionaryEditText : string with get, set

member OptionsFormUserDictionaryEditText : string with get, set
Property Value
String


RemoveDuplicateWordText Property

Keyoti RapidSpell Desktop .NET API Docs
RemoveDuplicateWordText Property
API ► Keyoti.RapidSpell ► DialogTexts ► RemoveDuplicateWordText
Keyoti RapidSpell Desktop .NET
Remove duplicate word text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string RemoveDuplicateWordText { get; set; }
public string RemoveDuplicateWordText { get; set; }
Public Property RemoveDuplicateWordText As String
    Get
    Set
Public Property RemoveDuplicateWordText As String
    Get
    Set
public:
property String^ RemoveDuplicateWordText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ RemoveDuplicateWordText {
    String^ get ();
    void set (String^ value);
}
member RemoveDuplicateWordText : string with get, set

member RemoveDuplicateWordText : string with get, set
Property Value
String


ResetText Property

Keyoti RapidSpell Desktop .NET API Docs
ResetText Property
API ► Keyoti.RapidSpell ► DialogTexts ► ResetText
Keyoti RapidSpell Desktop .NET
Used at design time to reset UI text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ResetText { get; set; }
public bool ResetText { get; set; }
Public Property ResetText As Boolean
    Get
    Set
Public Property ResetText As Boolean
    Get
    Set
public:
property bool ResetText {
    bool get ();
    void set (bool value);
}
public:
property bool ResetText {
    bool get ();
    void set (bool value);
}
member ResetText : bool with get, set

member ResetText : bool with get, set
Property Value
Boolean


ResumeButtonText Property

Keyoti RapidSpell Desktop .NET API Docs
ResumeButtonText Property
API ► Keyoti.RapidSpell ► DialogTexts ► ResumeButtonText
Keyoti RapidSpell Desktop .NET
Resume button text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string ResumeButtonText { get; set; }
public string ResumeButtonText { get; set; }
Public Property ResumeButtonText As String
    Get
    Set
Public Property ResumeButtonText As String
    Get
    Set
public:
property String^ ResumeButtonText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ ResumeButtonText {
    String^ get ();
    void set (String^ value);
}
member ResumeButtonText : string with get, set

member ResumeButtonText : string with get, set
Property Value
String


SuggestionsLabelText Property

Keyoti RapidSpell Desktop .NET API Docs
SuggestionsLabelText Property
API ► Keyoti.RapidSpell ► DialogTexts ► SuggestionsLabelText
Keyoti RapidSpell Desktop .NET
Suggestions label text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string SuggestionsLabelText { get; set; }
public string SuggestionsLabelText { get; set; }
Public Property SuggestionsLabelText As String
    Get
    Set
Public Property SuggestionsLabelText As String
    Get
    Set
public:
property String^ SuggestionsLabelText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ SuggestionsLabelText {
    String^ get ();
    void set (String^ value);
}
member SuggestionsLabelText : string with get, set

member SuggestionsLabelText : string with get, set
Property Value
String


UndoButtonText Property

Keyoti RapidSpell Desktop .NET API Docs
UndoButtonText Property
API ► Keyoti.RapidSpell ► DialogTexts ► UndoButtonText
Keyoti RapidSpell Desktop .NET
Undo button text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UndoButtonText { get; set; }
public string UndoButtonText { get; set; }
Public Property UndoButtonText As String
    Get
    Set
Public Property UndoButtonText As String
    Get
    Set
public:
property String^ UndoButtonText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UndoButtonText {
    String^ get ();
    void set (String^ value);
}
member UndoButtonText : string with get, set

member UndoButtonText : string with get, set
Property Value
String


UserDictionaryFormAddText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionaryFormAddText Property
API ► Keyoti.RapidSpell ► DialogTexts ► UserDictionaryFormAddText
Keyoti RapidSpell Desktop .NET
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionaryFormAddText { get; set; }
public string UserDictionaryFormAddText { get; set; }
Public Property UserDictionaryFormAddText As String
    Get
    Set
Public Property UserDictionaryFormAddText As String
    Get
    Set
public:
property String^ UserDictionaryFormAddText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserDictionaryFormAddText {
    String^ get ();
    void set (String^ value);
}
member UserDictionaryFormAddText : string with get, set

member UserDictionaryFormAddText : string with get, set
Property Value
String


UserDictionaryFormCancelText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionaryFormCancelText Property
API ► Keyoti.RapidSpell ► DialogTexts ► UserDictionaryFormCancelText
Keyoti RapidSpell Desktop .NET
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionaryFormCancelText { get; set; }
public string UserDictionaryFormCancelText { get; set; }
Public Property UserDictionaryFormCancelText As String
    Get
    Set
Public Property UserDictionaryFormCancelText As String
    Get
    Set
public:
property String^ UserDictionaryFormCancelText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserDictionaryFormCancelText {
    String^ get ();
    void set (String^ value);
}
member UserDictionaryFormCancelText : string with get, set

member UserDictionaryFormCancelText : string with get, set
Property Value
String


UserDictionaryFormContentsText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionaryFormContentsText Property
API ► Keyoti.RapidSpell ► DialogTexts ► UserDictionaryFormContentsText
Keyoti RapidSpell Desktop .NET
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionaryFormContentsText { get; set; }
public string UserDictionaryFormContentsText { get; set; }
Public Property UserDictionaryFormContentsText As String
    Get
    Set
Public Property UserDictionaryFormContentsText As String
    Get
    Set
public:
property String^ UserDictionaryFormContentsText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserDictionaryFormContentsText {
    String^ get ();
    void set (String^ value);
}
member UserDictionaryFormContentsText : string with get, set

member UserDictionaryFormContentsText : string with get, set
Property Value
String


UserDictionaryFormDeleteText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionaryFormDeleteText Property
API ► Keyoti.RapidSpell ► DialogTexts ► UserDictionaryFormDeleteText
Keyoti RapidSpell Desktop .NET
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionaryFormDeleteText { get; set; }
public string UserDictionaryFormDeleteText { get; set; }
Public Property UserDictionaryFormDeleteText As String
    Get
    Set
Public Property UserDictionaryFormDeleteText As String
    Get
    Set
public:
property String^ UserDictionaryFormDeleteText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserDictionaryFormDeleteText {
    String^ get ();
    void set (String^ value);
}
member UserDictionaryFormDeleteText : string with get, set

member UserDictionaryFormDeleteText : string with get, set
Property Value
String


UserDictionaryFormDictionaryLabelText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionaryFormDictionaryLabelText Property
API ► Keyoti.RapidSpell ► DialogTexts ► UserDictionaryFormDictionaryLabelText
Keyoti RapidSpell Desktop .NET
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionaryFormDictionaryLabelText { get; set; }
public string UserDictionaryFormDictionaryLabelText { get; set; }
Public Property UserDictionaryFormDictionaryLabelText As String
    Get
    Set
Public Property UserDictionaryFormDictionaryLabelText As String
    Get
    Set
public:
property String^ UserDictionaryFormDictionaryLabelText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserDictionaryFormDictionaryLabelText {
    String^ get ();
    void set (String^ value);
}
member UserDictionaryFormDictionaryLabelText : string with get, set

member UserDictionaryFormDictionaryLabelText : string with get, set
Property Value
String


UserDictionaryFormOKText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionaryFormOKText Property
API ► Keyoti.RapidSpell ► DialogTexts ► UserDictionaryFormOKText
Keyoti RapidSpell Desktop .NET
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionaryFormOKText { get; set; }
public string UserDictionaryFormOKText { get; set; }
Public Property UserDictionaryFormOKText As String
    Get
    Set
Public Property UserDictionaryFormOKText As String
    Get
    Set
public:
property String^ UserDictionaryFormOKText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserDictionaryFormOKText {
    String^ get ();
    void set (String^ value);
}
member UserDictionaryFormOKText : string with get, set

member UserDictionaryFormOKText : string with get, set
Property Value
String


UserDictionaryFormTitleText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionaryFormTitleText Property
API ► Keyoti.RapidSpell ► DialogTexts ► UserDictionaryFormTitleText
Keyoti RapidSpell Desktop .NET
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionaryFormTitleText { get; set; }
public string UserDictionaryFormTitleText { get; set; }
Public Property UserDictionaryFormTitleText As String
    Get
    Set
Public Property UserDictionaryFormTitleText As String
    Get
    Set
public:
property String^ UserDictionaryFormTitleText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserDictionaryFormTitleText {
    String^ get ();
    void set (String^ value);
}
member UserDictionaryFormTitleText : string with get, set

member UserDictionaryFormTitleText : string with get, set
Property Value
String


UserDictionaryFormWordLabelText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionaryFormWordLabelText Property
API ► Keyoti.RapidSpell ► DialogTexts ► UserDictionaryFormWordLabelText
Keyoti RapidSpell Desktop .NET
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionaryFormWordLabelText { get; set; }
public string UserDictionaryFormWordLabelText { get; set; }
Public Property UserDictionaryFormWordLabelText As String
    Get
    Set
Public Property UserDictionaryFormWordLabelText As String
    Get
    Set
public:
property String^ UserDictionaryFormWordLabelText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserDictionaryFormWordLabelText {
    String^ get ();
    void set (String^ value);
}
member UserDictionaryFormWordLabelText : string with get, set

member UserDictionaryFormWordLabelText : string with get, set
Property Value
String


UserDictionarySelectFormAddFileText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionarySelectFormAddFileText Property
API ► Keyoti.RapidSpell ► DialogTexts ► UserDictionarySelectFormAddFileText
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionarySelectFormAddFileText { get; set; }
public string UserDictionarySelectFormAddFileText { get; set; }
Public Property UserDictionarySelectFormAddFileText As String
    Get
    Set
Public Property UserDictionarySelectFormAddFileText As String
    Get
    Set
public:
property String^ UserDictionarySelectFormAddFileText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserDictionarySelectFormAddFileText {
    String^ get ();
    void set (String^ value);
}
member UserDictionarySelectFormAddFileText : string with get, set

member UserDictionarySelectFormAddFileText : string with get, set
Property Value
String


UserDictionarySelectFormCancelText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionarySelectFormCancelText Property
API ► Keyoti.RapidSpell ► DialogTexts ► UserDictionarySelectFormCancelText
Keyoti RapidSpell Desktop .NET
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionarySelectFormCancelText { get; set; }
public string UserDictionarySelectFormCancelText { get; set; }
Public Property UserDictionarySelectFormCancelText As String
    Get
    Set
Public Property UserDictionarySelectFormCancelText As String
    Get
    Set
public:
property String^ UserDictionarySelectFormCancelText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserDictionarySelectFormCancelText {
    String^ get ();
    void set (String^ value);
}
member UserDictionarySelectFormCancelText : string with get, set

member UserDictionarySelectFormCancelText : string with get, set
Property Value
String


UserDictionarySelectFormChangeDefaultText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionarySelectFormChangeDefaultText Property
API ► Keyoti.RapidSpell ► DialogTexts ► UserDictionarySelectFormChangeDefaultText
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionarySelectFormChangeDefaultText { get; set; }
public string UserDictionarySelectFormChangeDefaultText { get; set; }
Public Property UserDictionarySelectFormChangeDefaultText As String
    Get
    Set
Public Property UserDictionarySelectFormChangeDefaultText As String
    Get
    Set
public:
property String^ UserDictionarySelectFormChangeDefaultText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserDictionarySelectFormChangeDefaultText {
    String^ get ();
    void set (String^ value);
}
member UserDictionarySelectFormChangeDefaultText : string with get, set

member UserDictionarySelectFormChangeDefaultText : string with get, set
Property Value
String


UserDictionarySelectFormDeleteText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionarySelectFormDeleteText Property
API ► Keyoti.RapidSpell ► DialogTexts ► UserDictionarySelectFormDeleteText
Keyoti RapidSpell Desktop .NET
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionarySelectFormDeleteText { get; set; }
public string UserDictionarySelectFormDeleteText { get; set; }
Public Property UserDictionarySelectFormDeleteText As String
    Get
    Set
Public Property UserDictionarySelectFormDeleteText As String
    Get
    Set
public:
property String^ UserDictionarySelectFormDeleteText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserDictionarySelectFormDeleteText {
    String^ get ();
    void set (String^ value);
}
member UserDictionarySelectFormDeleteText : string with get, set

member UserDictionarySelectFormDeleteText : string with get, set
Property Value
String


UserDictionarySelectFormDictionaryLabelText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionarySelectFormDictionaryLabelText Property
API ► Keyoti.RapidSpell ► DialogTexts ► UserDictionarySelectFormDictionaryLabelText
Keyoti RapidSpell Desktop .NET
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionarySelectFormDictionaryLabelText { get; set; }
public string UserDictionarySelectFormDictionaryLabelText { get; set; }
Public Property UserDictionarySelectFormDictionaryLabelText As String
    Get
    Set
Public Property UserDictionarySelectFormDictionaryLabelText As String
    Get
    Set
public:
property String^ UserDictionarySelectFormDictionaryLabelText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserDictionarySelectFormDictionaryLabelText {
    String^ get ();
    void set (String^ value);
}
member UserDictionarySelectFormDictionaryLabelText : string with get, set

member UserDictionarySelectFormDictionaryLabelText : string with get, set
Property Value
String


UserDictionarySelectFormEditFileText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionarySelectFormEditFileText Property
API ► Keyoti.RapidSpell ► DialogTexts ► UserDictionarySelectFormEditFileText
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionarySelectFormEditFileText { get; set; }
public string UserDictionarySelectFormEditFileText { get; set; }
Public Property UserDictionarySelectFormEditFileText As String
    Get
    Set
Public Property UserDictionarySelectFormEditFileText As String
    Get
    Set
public:
property String^ UserDictionarySelectFormEditFileText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserDictionarySelectFormEditFileText {
    String^ get ();
    void set (String^ value);
}
member UserDictionarySelectFormEditFileText : string with get, set

member UserDictionarySelectFormEditFileText : string with get, set
Property Value
String


UserDictionarySelectFormGroupBoxTitleText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionarySelectFormGroupBoxTitleText Property
API ► Keyoti.RapidSpell ► DialogTexts ► UserDictionarySelectFormGroupBoxTitleText
Keyoti RapidSpell Desktop .NET
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionarySelectFormGroupBoxTitleText { get; set; }
public string UserDictionarySelectFormGroupBoxTitleText { get; set; }
Public Property UserDictionarySelectFormGroupBoxTitleText As String
    Get
    Set
Public Property UserDictionarySelectFormGroupBoxTitleText As String
    Get
    Set
public:
property String^ UserDictionarySelectFormGroupBoxTitleText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserDictionarySelectFormGroupBoxTitleText {
    String^ get ();
    void set (String^ value);
}
member UserDictionarySelectFormGroupBoxTitleText : string with get, set

member UserDictionarySelectFormGroupBoxTitleText : string with get, set
Property Value
String


UserDictionarySelectFormNewFileText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionarySelectFormNewFileText Property
API ► Keyoti.RapidSpell ► DialogTexts ► UserDictionarySelectFormNewFileText
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionarySelectFormNewFileText { get; set; }
public string UserDictionarySelectFormNewFileText { get; set; }
Public Property UserDictionarySelectFormNewFileText As String
    Get
    Set
Public Property UserDictionarySelectFormNewFileText As String
    Get
    Set
public:
property String^ UserDictionarySelectFormNewFileText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserDictionarySelectFormNewFileText {
    String^ get ();
    void set (String^ value);
}
member UserDictionarySelectFormNewFileText : string with get, set

member UserDictionarySelectFormNewFileText : string with get, set
Property Value
String


UserDictionarySelectFormOKText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionarySelectFormOKText Property
API ► Keyoti.RapidSpell ► DialogTexts ► UserDictionarySelectFormOKText
Keyoti RapidSpell Desktop .NET
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionarySelectFormOKText { get; set; }
public string UserDictionarySelectFormOKText { get; set; }
Public Property UserDictionarySelectFormOKText As String
    Get
    Set
Public Property UserDictionarySelectFormOKText As String
    Get
    Set
public:
property String^ UserDictionarySelectFormOKText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserDictionarySelectFormOKText {
    String^ get ();
    void set (String^ value);
}
member UserDictionarySelectFormOKText : string with get, set

member UserDictionarySelectFormOKText : string with get, set
Property Value
String


UserDictionarySelectFormRemoveFileText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionarySelectFormRemoveFileText Property
API ► Keyoti.RapidSpell ► DialogTexts ► UserDictionarySelectFormRemoveFileText
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionarySelectFormRemoveFileText { get; set; }
public string UserDictionarySelectFormRemoveFileText { get; set; }
Public Property UserDictionarySelectFormRemoveFileText As String
    Get
    Set
Public Property UserDictionarySelectFormRemoveFileText As String
    Get
    Set
public:
property String^ UserDictionarySelectFormRemoveFileText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserDictionarySelectFormRemoveFileText {
    String^ get ();
    void set (String^ value);
}
member UserDictionarySelectFormRemoveFileText : string with get, set

member UserDictionarySelectFormRemoveFileText : string with get, set
Property Value
String


UserDictionarySelectFormTitleText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionarySelectFormTitleText Property
API ► Keyoti.RapidSpell ► DialogTexts ► UserDictionarySelectFormTitleText
Keyoti RapidSpell Desktop .NET
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionarySelectFormTitleText { get; set; }
public string UserDictionarySelectFormTitleText { get; set; }
Public Property UserDictionarySelectFormTitleText As String
    Get
    Set
Public Property UserDictionarySelectFormTitleText As String
    Get
    Set
public:
property String^ UserDictionarySelectFormTitleText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserDictionarySelectFormTitleText {
    String^ get ();
    void set (String^ value);
}
member UserDictionarySelectFormTitleText : string with get, set

member UserDictionarySelectFormTitleText : string with get, set
Property Value
String


DictionaryCache Class

Keyoti RapidSpell Desktop .NET API Docs
DictionaryCache Class
API ► Keyoti.RapidSpell ► DictionaryCache
Keyoti RapidSpell Desktop .NET
Cache of loaded dictionaries.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class DictionaryCache
public class DictionaryCache
Public Class DictionaryCache
Public Class DictionaryCache
public ref class DictionaryCache
public ref class DictionaryCache
type DictionaryCache =  class end
type DictionaryCache =  class end
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DictionaryCache()()()() |
 | AddDictionary(SpellingDictionary) | Adds a dictionary to the cache.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetDictionary(String, DateTime) | Gets a dictionary from the cache.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RemoveAllDictionaries()()()() | Removes all dictionaries in the cache, they will be reloaded if needed later.
 | RemoveDictionary(String) | Removes a dictionary from the cache based on its filename.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
DictionaryCache


DictionaryCache Constructor

Keyoti RapidSpell Desktop .NET API Docs
DictionaryCache Constructor
API ► Keyoti.RapidSpell ► DictionaryCache ► DictionaryCache()()()()
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public DictionaryCache()
public DictionaryCache()
Public Sub New
Public Sub New
public:
DictionaryCache()
public:
DictionaryCache()
new : unit -> DictionaryCache
new : unit -> DictionaryCache


AddDictionary Method (dictionary)

Keyoti RapidSpell Desktop .NET API Docs
AddDictionary Method (dictionary)
API ► Keyoti.RapidSpell ► DictionaryCache ► AddDictionary(SpellingDictionary)
Keyoti RapidSpell Desktop .NET
Adds a dictionary to the cache.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static void AddDictionary(
    SpellingDictionary dictionary
)
public static void AddDictionary(
    SpellingDictionary dictionary
)
Public Shared Sub AddDictionary (
    dictionary As SpellingDictionary
)
Public Shared Sub AddDictionary (
    dictionary As SpellingDictionary
)
public:
static void AddDictionary(
    SpellingDictionary^ dictionary
)
public:
static void AddDictionary(
    SpellingDictionary^ dictionary
)
static member AddDictionary :
        dictionary : SpellingDictionary -> unit

static member AddDictionary :
        dictionary : SpellingDictionary -> unit
Parameters
dictionary (SpellingDictionary)


GetDictionary Method (path, lastModifiedDate)

Keyoti RapidSpell Desktop .NET API Docs
GetDictionary Method (path, lastModifiedDate)
API ► Keyoti.RapidSpell ► DictionaryCache ► GetDictionary(String, DateTime)
Keyoti RapidSpell Desktop .NET
Gets a dictionary from the cache.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static SpellingDictionary GetDictionary(
    string path,
    DateTime lastModifiedDate
)
public static SpellingDictionary GetDictionary(
    string path,
    DateTime lastModifiedDate
)
Public Shared Function GetDictionary (
    path As String,
    lastModifiedDate As DateTime
) As SpellingDictionary
Public Shared Function GetDictionary (
    path As String,
    lastModifiedDate As DateTime
) As SpellingDictionary
public:
static SpellingDictionary^ GetDictionary(
    String^ path,
    DateTime lastModifiedDate
)
public:
static SpellingDictionary^ GetDictionary(
    String^ path,
    DateTime lastModifiedDate
)
static member GetDictionary :
        path : string *
        lastModifiedDate : DateTime -> SpellingDictionary

static member GetDictionary :
        path : string *
        lastModifiedDate : DateTime -> SpellingDictionary
Parameters
path (String)
lastModifiedDate (DateTime)
Return Value
SpellingDictionary


RemoveAllDictionaries Method

Keyoti RapidSpell Desktop .NET API Docs
RemoveAllDictionaries Method
API ► Keyoti.RapidSpell ► DictionaryCache ► RemoveAllDictionaries()()()()
Keyoti RapidSpell Desktop .NET
Removes all dictionaries in the cache, they will be reloaded if needed later.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static void RemoveAllDictionaries()
public static void RemoveAllDictionaries()
Public Shared Sub RemoveAllDictionaries
Public Shared Sub RemoveAllDictionaries
public:
static void RemoveAllDictionaries()
public:
static void RemoveAllDictionaries()
static member RemoveAllDictionaries : unit -> unit

static member RemoveAllDictionaries : unit -> unit


RemoveDictionary Method (path)

Keyoti RapidSpell Desktop .NET API Docs
RemoveDictionary Method (path)
API ► Keyoti.RapidSpell ► DictionaryCache ► RemoveDictionary(String)
Keyoti RapidSpell Desktop .NET
Removes a dictionary from the cache based on its filename.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static void RemoveDictionary(
    string path
)
public static void RemoveDictionary(
    string path
)
Public Shared Sub RemoveDictionary (
    path As String
)
Public Shared Sub RemoveDictionary (
    path As String
)
public:
static void RemoveDictionary(
    String^ path
)
public:
static void RemoveDictionary(
    String^ path
)
static member RemoveDictionary :
        path : string -> unit

static member RemoveDictionary :
        path : string -> unit
Parameters
path (String)
Path to the dictionary


IAYTTextBox Interface

Keyoti RapidSpell Desktop .NET API Docs
IAYTTextBox Interface
API ► Keyoti.RapidSpell ► IAYTTextBox
Keyoti RapidSpell Desktop .NET
Interface requirements for an "as-you-type" text box, if an object implements this interface then it is compatible with the RapidSpellAYT control.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public interface IAYTTextBox
public interface IAYTTextBox
Public Interface IAYTTextBox
Public Interface IAYTTextBox
public interface class IAYTTextBox
public interface class IAYTTextBox
type IAYTTextBox =  interface end
type IAYTTextBox =  interface end
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BeginInvoke(Delegate) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
 | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
 | ClientSize | Gets or sets the height and width of the client area of the control.
 | ContextMenu | Gets or sets the shortcut menu associated with the control
 | ContextMenuDefault | The context menu that will be shown when the right click is not on a misspelled word.
 | ContextMenuStrip | Gets or sets the shortcut menu associated with the control
 | ContextMenuStripDefault | The context menu strip that will be shown when the right click is not on a misspelled word.
 | ControlPaint | Event fired when Control repaint occurs.
 | DefaultContextMenu | Obsolete. The context menu that will be shown when the right click is not on a misspelled word.
 | Disposed | Event fires when component is Disposed.
 | Disposing | If the control is disposing
 | Enabled | Whether the textbox is enabled
 | Enter | Occurs when the control receives focus.
 | FormatChanged | Occurs when the formatting changes, such as font property value changes.
 | GetBaselineOffsetAtCharIndex(Int32) | Gets the Y offset of the baseline from the position returned by GetPosFromCharIndex for a particular character.
 | GetCharIndexFromPos(Point) | gets the char index from a position point.
 | GetFirstVisibleCharIndex()()()() | Gets the character index of the first visible character in the window, this is for optimization and can just return 0 if unavailable.
 | GetLineFromCharIndex(Int32) | Gets the line number that char index is on
 | GetPosFromCharIndex(Int32) | Gets the position point from the char index.
 | GetTBU()()()() | Returns the TextBoxUtilityAdapter, this is used internally for 3rd Party interface adapters.
 | Handle | Gets the window handle that the control is bound to.
 | Height | Gets or sets the height of the control.
 | HScrolled | Event fired when horizontal scroll changed (by anything).
 | IsDisposed | Gets a value indicating whether the control has been disposed of.
 | IsHandleCreated | Same as Control.IsHandleCreated
 | KeyDown | Occurs when a key is pressed while the control has focus.
 | KeyPress | Occurs when a key is pressed while the control has focus.
 | KeyUp | Occurs when a key is released while the control has focus.
 | Leave | Occurs when the control loses focus.
 | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed.
 | MouseUp | Occurs when the mouse is released on the text box.
 | MouseWheel | Occurs when the mouse wheel is used to scroll.
 | Parent | The parent control
 | ReadOnly | Whether the textbox is readonly
 | RecreatingHandle | If the control is recreating it's handle
 | Refresh()()()() | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
 | Resize | Occurs when the control is resized.
 | ScrollCaret | Occurs when the text box is scrolled to the caret.
 | SelectedText | Gets or sets a value indicating the currently selected text in the control.
 | SelectionLength | Gets or sets the number of characters selected in the text box.
 | SelectionStart | Gets or sets the starting point of text selected in the text box.
 | SuspendLayout()()()() | Suspend layout
 | Text | Gets or sets the current text in the text box.
 | TextChanged | Occurs when the Text property value changes.
 | TextLength | Gets the current text length in the text box.
 | VScrolled | Event fired when vertical scroll changed (by anything).
 | VScrollEnd | Event fired when vertical scroll ends.
 | Width | Gets or sets the width of the control.


BeginInvoke Method

Keyoti RapidSpell Desktop .NET API Docs
BeginInvoke Method
API ► Keyoti.RapidSpell ► IAYTTextBox ► BeginInvoke()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | BeginInvoke(Delegate) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
 | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.


BeginInvoke Method (d)

Keyoti RapidSpell Desktop .NET API Docs
BeginInvoke Method (d)
API ► Keyoti.RapidSpell ► IAYTTextBox ► BeginInvoke(Delegate)
Keyoti RapidSpell Desktop .NET
Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
IAsyncResult BeginInvoke(
    Delegate d
)
IAsyncResult BeginInvoke(
    Delegate d
)
Function BeginInvoke (
    d As Delegate
) As IAsyncResult
Function BeginInvoke (
    d As Delegate
) As IAsyncResult
IAsyncResult^ BeginInvoke(
    Delegate^ d
)
IAsyncResult^ BeginInvoke(
    Delegate^ d
)
abstract BeginInvoke :
        d : Delegate -> IAsyncResult

abstract BeginInvoke :
        d : Delegate -> IAsyncResult
Parameters
d (Delegate)
Return Value
IAsyncResult


BeginInvoke Method (d, parameters)

Keyoti RapidSpell Desktop .NET API Docs
BeginInvoke Method (d, parameters)
API ► Keyoti.RapidSpell ► IAYTTextBox ► BeginInvoke(Delegate, array<Object>[]()[][])
Keyoti RapidSpell Desktop .NET
Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
IAsyncResult BeginInvoke(
    Delegate d,
    Object[] parameters
)
IAsyncResult BeginInvoke(
    Delegate d,
    Object[] parameters
)
Function BeginInvoke (
    d As Delegate,
    parameters As Object()
) As IAsyncResult
Function BeginInvoke (
    d As Delegate,
    parameters As Object()
) As IAsyncResult
IAsyncResult^ BeginInvoke(
    Delegate^ d,
    array<Object^>^ parameters
)
IAsyncResult^ BeginInvoke(
    Delegate^ d,
    array<Object^>^ parameters
)
abstract BeginInvoke :
        d : Delegate *
        parameters : Object[] -> IAsyncResult

abstract BeginInvoke :
        d : Delegate *
        parameters : Object[] -> IAsyncResult
Parameters
d (Delegate)
parameters (array< Object >[]()[][])
Return Value
IAsyncResult


ClientSize Property

Keyoti RapidSpell Desktop .NET API Docs
ClientSize Property
API ► Keyoti.RapidSpell ► IAYTTextBox ► ClientSize
Keyoti RapidSpell Desktop .NET
Gets or sets the height and width of the client area of the control.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
Size ClientSize { get; set; }
Size ClientSize { get; set; }
Property ClientSize As Size
    Get
    Set
Property ClientSize As Size
    Get
    Set
property Size ClientSize {
    Size get ();
    void set (Size value);
}
property Size ClientSize {
    Size get ();
    void set (Size value);
}
abstract ClientSize : Size with get, set

abstract ClientSize : Size with get, set
Property Value
Size


ContextMenu Property

Keyoti RapidSpell Desktop .NET API Docs
ContextMenu Property
API ► Keyoti.RapidSpell ► IAYTTextBox ► ContextMenu
Keyoti RapidSpell Desktop .NET
Gets or sets the shortcut menu associated with the control
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
ContextMenu ContextMenu { get; set; }
ContextMenu ContextMenu { get; set; }
Property ContextMenu As ContextMenu
    Get
    Set
Property ContextMenu As ContextMenu
    Get
    Set
property ContextMenu^ ContextMenu {
    ContextMenu^ get ();
    void set (ContextMenu^ value);
}
property ContextMenu^ ContextMenu {
    ContextMenu^ get ();
    void set (ContextMenu^ value);
}
abstract ContextMenu : ContextMenu with get, set

abstract ContextMenu : ContextMenu with get, set
Property Value
ContextMenu


ContextMenuDefault Property

Keyoti RapidSpell Desktop .NET API Docs
ContextMenuDefault Property
API ► Keyoti.RapidSpell ► IAYTTextBox ► ContextMenuDefault
Keyoti RapidSpell Desktop .NET
The context menu that will be shown when the right click is not on a misspelled word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
ContextMenu ContextMenuDefault { get; }
ContextMenu ContextMenuDefault { get; }
ReadOnly Property ContextMenuDefault As ContextMenu
    Get
ReadOnly Property ContextMenuDefault As ContextMenu
    Get
property ContextMenu^ ContextMenuDefault {
    ContextMenu^ get ();
}
property ContextMenu^ ContextMenuDefault {
    ContextMenu^ get ();
}
abstract ContextMenuDefault : ContextMenu with get

abstract ContextMenuDefault : ContextMenu with get
Property Value
ContextMenu
Remarks
This is the context menu originally set in the ContextMenu property.


ContextMenuStrip Property

Keyoti RapidSpell Desktop .NET API Docs
ContextMenuStrip Property
API ► Keyoti.RapidSpell ► IAYTTextBox ► ContextMenuStrip
Keyoti RapidSpell Desktop .NET
Gets or sets the shortcut menu associated with the control
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
ContextMenuStrip ContextMenuStrip { get; set; }
ContextMenuStrip ContextMenuStrip { get; set; }
Property ContextMenuStrip As ContextMenuStrip
    Get
    Set
Property ContextMenuStrip As ContextMenuStrip
    Get
    Set
property ContextMenuStrip^ ContextMenuStrip {
    ContextMenuStrip^ get ();
    void set (ContextMenuStrip^ value);
}
property ContextMenuStrip^ ContextMenuStrip {
    ContextMenuStrip^ get ();
    void set (ContextMenuStrip^ value);
}
abstract ContextMenuStrip : ContextMenuStrip with get, set

abstract ContextMenuStrip : ContextMenuStrip with get, set
Property Value
ContextMenuStrip


ContextMenuStripDefault Property

Keyoti RapidSpell Desktop .NET API Docs
ContextMenuStripDefault Property
API ► Keyoti.RapidSpell ► IAYTTextBox ► ContextMenuStripDefault
Keyoti RapidSpell Desktop .NET
The context menu strip that will be shown when the right click is not on a misspelled word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
ContextMenuStrip ContextMenuStripDefault { get; }
ContextMenuStrip ContextMenuStripDefault { get; }
ReadOnly Property ContextMenuStripDefault As ContextMenuStrip
    Get
ReadOnly Property ContextMenuStripDefault As ContextMenuStrip
    Get
property ContextMenuStrip^ ContextMenuStripDefault {
    ContextMenuStrip^ get ();
}
property ContextMenuStrip^ ContextMenuStripDefault {
    ContextMenuStrip^ get ();
}
abstract ContextMenuStripDefault : ContextMenuStrip with get

abstract ContextMenuStripDefault : ContextMenuStrip with get
Property Value
ContextMenuStrip
Remarks
This is the context menu strip originally set in the ContextMenuStrip property.


ControlPaint Event

Keyoti RapidSpell Desktop .NET API Docs
ControlPaint Event
API ► Keyoti.RapidSpell ► IAYTTextBox ► ControlPaint
Keyoti RapidSpell Desktop .NET
Event fired when Control repaint occurs.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event EventHandler ControlPaint
event EventHandler ControlPaint
Event ControlPaint As EventHandler
Event ControlPaint As EventHandler
 event EventHandler^ ControlPaint {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
 event EventHandler^ ControlPaint {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ControlPaint : IEvent<EventHandler,
    EventArgs>

abstract ControlPaint : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


DefaultContextMenu Property

Keyoti RapidSpell Desktop .NET API Docs
DefaultContextMenu Property
API ► Keyoti.RapidSpell ► IAYTTextBox ► DefaultContextMenu
Keyoti RapidSpell Desktop .NET
The context menu that will be shown when the right click is not on a misspelled word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
[ObsoleteAttribute("Use ContextMenuDefault instead.")]
ContextMenu DefaultContextMenu { get; }
[ObsoleteAttribute("Use ContextMenuDefault instead.")]
ContextMenu DefaultContextMenu { get; }
<ObsoleteAttribute("Use ContextMenuDefault instead.")>
ReadOnly Property DefaultContextMenu As ContextMenu
    Get
<ObsoleteAttribute("Use ContextMenuDefault instead.")>
ReadOnly Property DefaultContextMenu As ContextMenu
    Get
[ObsoleteAttribute(L"Use ContextMenuDefault instead.")]
property ContextMenu^ DefaultContextMenu {
    ContextMenu^ get ();
}
[ObsoleteAttribute(L"Use ContextMenuDefault instead.")]
property ContextMenu^ DefaultContextMenu {
    ContextMenu^ get ();
}
[<ObsoleteAttribute("Use ContextMenuDefault instead.")>]
abstract DefaultContextMenu : ContextMenu with get

[<ObsoleteAttribute("Use ContextMenuDefault instead.")>]
abstract DefaultContextMenu : ContextMenu with get
Property Value
ContextMenu
Remarks
This is the context menu originally set in the ContextMenu property.


Disposed Event

Keyoti RapidSpell Desktop .NET API Docs
Disposed Event
API ► Keyoti.RapidSpell ► IAYTTextBox ► Disposed
Keyoti RapidSpell Desktop .NET
Event fires when component is Disposed.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event EventHandler Disposed
event EventHandler Disposed
Event Disposed As EventHandler
Event Disposed As EventHandler
 event EventHandler^ Disposed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
 event EventHandler^ Disposed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Disposed : IEvent<EventHandler,
    EventArgs>

abstract Disposed : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


Disposing Property

Keyoti RapidSpell Desktop .NET API Docs
Disposing Property
API ► Keyoti.RapidSpell ► IAYTTextBox ► Disposing
Keyoti RapidSpell Desktop .NET
If the control is disposing
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool Disposing { get; }
bool Disposing { get; }
ReadOnly Property Disposing As Boolean
    Get
ReadOnly Property Disposing As Boolean
    Get
property bool Disposing {
    bool get ();
}
property bool Disposing {
    bool get ();
}
abstract Disposing : bool with get

abstract Disposing : bool with get
Property Value
Boolean


Enabled Property

Keyoti RapidSpell Desktop .NET API Docs
Enabled Property
API ► Keyoti.RapidSpell ► IAYTTextBox ► Enabled
Keyoti RapidSpell Desktop .NET
Whether the textbox is enabled
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool Enabled { get; }
bool Enabled { get; }
ReadOnly Property Enabled As Boolean
    Get
ReadOnly Property Enabled As Boolean
    Get
property bool Enabled {
    bool get ();
}
property bool Enabled {
    bool get ();
}
abstract Enabled : bool with get

abstract Enabled : bool with get
Property Value
Boolean
Remarks
If not supported, return true.


Enter Event

Keyoti RapidSpell Desktop .NET API Docs
Enter Event
API ► Keyoti.RapidSpell ► IAYTTextBox ► Enter
Keyoti RapidSpell Desktop .NET
Occurs when the control receives focus.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event EventHandler Enter
event EventHandler Enter
Event Enter As EventHandler
Event Enter As EventHandler
 event EventHandler^ Enter {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
 event EventHandler^ Enter {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Enter : IEvent<EventHandler,
    EventArgs>

abstract Enter : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


FormatChanged Event

Keyoti RapidSpell Desktop .NET API Docs
FormatChanged Event
API ► Keyoti.RapidSpell ► IAYTTextBox ► FormatChanged
Keyoti RapidSpell Desktop .NET
Occurs when the formatting changes, such as font property value changes.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event EventHandler FormatChanged
event EventHandler FormatChanged
Event FormatChanged As EventHandler
Event FormatChanged As EventHandler
 event EventHandler^ FormatChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
 event EventHandler^ FormatChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract FormatChanged : IEvent<EventHandler,
    EventArgs>

abstract FormatChanged : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


GetBaselineOffsetAtCharIndex Method (index)

Keyoti RapidSpell Desktop .NET API Docs
GetBaselineOffsetAtCharIndex Method (index)
API ► Keyoti.RapidSpell ► IAYTTextBox ► GetBaselineOffsetAtCharIndex(Int32)
Keyoti RapidSpell Desktop .NET
Gets the Y offset of the baseline from the position returned by GetPosFromCharIndex for a particular character.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
int GetBaselineOffsetAtCharIndex(
    int index
)
int GetBaselineOffsetAtCharIndex(
    int index
)
Function GetBaselineOffsetAtCharIndex (
    index As Integer
) As Integer
Function GetBaselineOffsetAtCharIndex (
    index As Integer
) As Integer
int GetBaselineOffsetAtCharIndex(
    int index
)
int GetBaselineOffsetAtCharIndex(
    int index
)
abstract GetBaselineOffsetAtCharIndex :
        index : int -> int

abstract GetBaselineOffsetAtCharIndex :
        index : int -> int
Parameters
index (Int32)
Return Value
Int32
Remarks
For example, with RichTextBox Controls GetPosFromCharIndex returns the top left coord, therefore this method must return the height of the biggest font on the line.


GetCharIndexFromPos Method (pos)

Keyoti RapidSpell Desktop .NET API Docs
GetCharIndexFromPos Method (pos)
API ► Keyoti.RapidSpell ► IAYTTextBox ► GetCharIndexFromPos(Point)
Keyoti RapidSpell Desktop .NET
gets the char index from a position point.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
int GetCharIndexFromPos(
    Point pos
)
int GetCharIndexFromPos(
    Point pos
)
Function GetCharIndexFromPos (
    pos As Point
) As Integer
Function GetCharIndexFromPos (
    pos As Point
) As Integer
int GetCharIndexFromPos(
    Point pos
)
int GetCharIndexFromPos(
    Point pos
)
abstract GetCharIndexFromPos :
        pos : Point -> int

abstract GetCharIndexFromPos :
        pos : Point -> int
Parameters
pos (Point)
Return Value
Int32


GetFirstVisibleCharIndex Method

Keyoti RapidSpell Desktop .NET API Docs
GetFirstVisibleCharIndex Method
API ► Keyoti.RapidSpell ► IAYTTextBox ► GetFirstVisibleCharIndex()()()()
Keyoti RapidSpell Desktop .NET
Gets the character index of the first visible character in the window, this is for optimization and can just return 0 if unavailable.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
int GetFirstVisibleCharIndex()
int GetFirstVisibleCharIndex()
Function GetFirstVisibleCharIndex As Integer
Function GetFirstVisibleCharIndex As Integer
int GetFirstVisibleCharIndex()
int GetFirstVisibleCharIndex()
abstract GetFirstVisibleCharIndex : unit -> int

abstract GetFirstVisibleCharIndex : unit -> int
Return Value
Int32


GetLineFromCharIndex Method (index)

Keyoti RapidSpell Desktop .NET API Docs
GetLineFromCharIndex Method (index)
API ► Keyoti.RapidSpell ► IAYTTextBox ► GetLineFromCharIndex(Int32)
Keyoti RapidSpell Desktop .NET
Gets the line number that char index is on
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
int GetLineFromCharIndex(
    int index
)
int GetLineFromCharIndex(
    int index
)
Function GetLineFromCharIndex (
    index As Integer
) As Integer
Function GetLineFromCharIndex (
    index As Integer
) As Integer
int GetLineFromCharIndex(
    int index
)
int GetLineFromCharIndex(
    int index
)
abstract GetLineFromCharIndex :
        index : int -> int

abstract GetLineFromCharIndex :
        index : int -> int
Parameters
index (Int32)
Return Value
Int32


GetPosFromCharIndex Method (index)

Keyoti RapidSpell Desktop .NET API Docs
GetPosFromCharIndex Method (index)
API ► Keyoti.RapidSpell ► IAYTTextBox ► GetPosFromCharIndex(Int32)
Keyoti RapidSpell Desktop .NET
Gets the position point from the char index.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
Point GetPosFromCharIndex(
    int index
)
Point GetPosFromCharIndex(
    int index
)
Function GetPosFromCharIndex (
    index As Integer
) As Point
Function GetPosFromCharIndex (
    index As Integer
) As Point
Point GetPosFromCharIndex(
    int index
)
Point GetPosFromCharIndex(
    int index
)
abstract GetPosFromCharIndex :
        index : int -> Point

abstract GetPosFromCharIndex :
        index : int -> Point
Parameters
index (Int32)
Return Value
Point


GetTBU Method

Keyoti RapidSpell Desktop .NET API Docs
GetTBU Method
API ► Keyoti.RapidSpell ► IAYTTextBox ► GetTBU()()()()
Keyoti RapidSpell Desktop .NET
Returns the TextBoxUtilityAdapter, this is used internally for 3rd Party interface adapters.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
TextBoxUtilityAdapter GetTBU()
TextBoxUtilityAdapter GetTBU()
Function GetTBU As TextBoxUtilityAdapter
Function GetTBU As TextBoxUtilityAdapter
TextBoxUtilityAdapter^ GetTBU()
TextBoxUtilityAdapter^ GetTBU()
abstract GetTBU : unit -> TextBoxUtilityAdapter

abstract GetTBU : unit -> TextBoxUtilityAdapter
Return Value
TextBoxUtilityAdapter


Handle Property

Keyoti RapidSpell Desktop .NET API Docs
Handle Property
API ► Keyoti.RapidSpell ► IAYTTextBox ► Handle
Keyoti RapidSpell Desktop .NET
Gets the window handle that the control is bound to.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
IntPtr Handle { get; }
IntPtr Handle { get; }
ReadOnly Property Handle As IntPtr
    Get
ReadOnly Property Handle As IntPtr
    Get
property IntPtr Handle {
    IntPtr get ();
}
property IntPtr Handle {
    IntPtr get ();
}
abstract Handle : IntPtr with get

abstract Handle : IntPtr with get
Property Value
IntPtr


Height Property

Keyoti RapidSpell Desktop .NET API Docs
Height Property
API ► Keyoti.RapidSpell ► IAYTTextBox ► Height
Keyoti RapidSpell Desktop .NET
Gets or sets the height of the control.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
int Height { get; set; }
int Height { get; set; }
Property Height As Integer
    Get
    Set
Property Height As Integer
    Get
    Set
property int Height {
    int get ();
    void set (int value);
}
property int Height {
    int get ();
    void set (int value);
}
abstract Height : int with get, set

abstract Height : int with get, set
Property Value
Int32


HScrolled Event

Keyoti RapidSpell Desktop .NET API Docs
HScrolled Event
API ► Keyoti.RapidSpell ► IAYTTextBox ► HScrolled
Keyoti RapidSpell Desktop .NET
Event fired when horizontal scroll changed (by anything).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event EventHandler HScrolled
event EventHandler HScrolled
Event HScrolled As EventHandler
Event HScrolled As EventHandler
 event EventHandler^ HScrolled {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
 event EventHandler^ HScrolled {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract HScrolled : IEvent<EventHandler,
    EventArgs>

abstract HScrolled : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


IsDisposed Property

Keyoti RapidSpell Desktop .NET API Docs
IsDisposed Property
API ► Keyoti.RapidSpell ► IAYTTextBox ► IsDisposed
Keyoti RapidSpell Desktop .NET
Gets a value indicating whether the control has been disposed of.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool IsDisposed { get; }
bool IsDisposed { get; }
ReadOnly Property IsDisposed As Boolean
    Get
ReadOnly Property IsDisposed As Boolean
    Get
property bool IsDisposed {
    bool get ();
}
property bool IsDisposed {
    bool get ();
}
abstract IsDisposed : bool with get

abstract IsDisposed : bool with get
Property Value
Boolean


IsHandleCreated Property

Keyoti RapidSpell Desktop .NET API Docs
IsHandleCreated Property
API ► Keyoti.RapidSpell ► IAYTTextBox ► IsHandleCreated
Keyoti RapidSpell Desktop .NET
Same as Control.IsHandleCreated
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool IsHandleCreated { get; }
bool IsHandleCreated { get; }
ReadOnly Property IsHandleCreated As Boolean
    Get
ReadOnly Property IsHandleCreated As Boolean
    Get
property bool IsHandleCreated {
    bool get ();
}
property bool IsHandleCreated {
    bool get ();
}
abstract IsHandleCreated : bool with get

abstract IsHandleCreated : bool with get
Property Value
Boolean


KeyDown Event

Keyoti RapidSpell Desktop .NET API Docs
KeyDown Event
API ► Keyoti.RapidSpell ► IAYTTextBox ► KeyDown
Keyoti RapidSpell Desktop .NET
Occurs when a key is pressed while the control has focus.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event KeyEventHandler KeyDown
event KeyEventHandler KeyDown
Event KeyDown As KeyEventHandler
Event KeyDown As KeyEventHandler
 event KeyEventHandler^ KeyDown {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}
 event KeyEventHandler^ KeyDown {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}
abstract KeyDown : IEvent<KeyEventHandler,
    KeyEventArgs>

abstract KeyDown : IEvent<KeyEventHandler,
    KeyEventArgs>
Value
KeyEventHandler


KeyPress Event

Keyoti RapidSpell Desktop .NET API Docs
KeyPress Event
API ► Keyoti.RapidSpell ► IAYTTextBox ► KeyPress
Keyoti RapidSpell Desktop .NET
Occurs when a key is pressed while the control has focus.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event KeyPressEventHandler KeyPress
event KeyPressEventHandler KeyPress
Event KeyPress As KeyPressEventHandler
Event KeyPress As KeyPressEventHandler
 event KeyPressEventHandler^ KeyPress {
    void add (KeyPressEventHandler^ value);
    void remove (KeyPressEventHandler^ value);
}
 event KeyPressEventHandler^ KeyPress {
    void add (KeyPressEventHandler^ value);
    void remove (KeyPressEventHandler^ value);
}
abstract KeyPress : IEvent<KeyPressEventHandler,
    KeyPressEventArgs>

abstract KeyPress : IEvent<KeyPressEventHandler,
    KeyPressEventArgs>
Value
KeyPressEventHandler
Remarks
Used by the auto-corrector


KeyUp Event

Keyoti RapidSpell Desktop .NET API Docs
KeyUp Event
API ► Keyoti.RapidSpell ► IAYTTextBox ► KeyUp
Keyoti RapidSpell Desktop .NET
Occurs when a key is released while the control has focus.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event KeyEventHandler KeyUp
event KeyEventHandler KeyUp
Event KeyUp As KeyEventHandler
Event KeyUp As KeyEventHandler
 event KeyEventHandler^ KeyUp {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}
 event KeyEventHandler^ KeyUp {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}
abstract KeyUp : IEvent<KeyEventHandler,
    KeyEventArgs>

abstract KeyUp : IEvent<KeyEventHandler,
    KeyEventArgs>
Value
KeyEventHandler


Leave Event

Keyoti RapidSpell Desktop .NET API Docs
Leave Event
API ► Keyoti.RapidSpell ► IAYTTextBox ► Leave
Keyoti RapidSpell Desktop .NET
Occurs when the control loses focus.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event EventHandler Leave
event EventHandler Leave
Event Leave As EventHandler
Event Leave As EventHandler
 event EventHandler^ Leave {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
 event EventHandler^ Leave {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Leave : IEvent<EventHandler,
    EventArgs>

abstract Leave : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


MouseDown Event

Keyoti RapidSpell Desktop .NET API Docs
MouseDown Event
API ► Keyoti.RapidSpell ► IAYTTextBox ► MouseDown
Keyoti RapidSpell Desktop .NET
Occurs when the mouse pointer is over the control and a mouse button is pressed.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event MouseEventHandler MouseDown
event MouseEventHandler MouseDown
Event MouseDown As MouseEventHandler
Event MouseDown As MouseEventHandler
 event MouseEventHandler^ MouseDown {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}
 event MouseEventHandler^ MouseDown {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}
abstract MouseDown : IEvent<MouseEventHandler,
    MouseEventArgs>

abstract MouseDown : IEvent<MouseEventHandler,
    MouseEventArgs>
Value
MouseEventHandler


MouseUp Event

Keyoti RapidSpell Desktop .NET API Docs
MouseUp Event
API ► Keyoti.RapidSpell ► IAYTTextBox ► MouseUp
Keyoti RapidSpell Desktop .NET
Occurs when the mouse is released on the text box.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event MouseEventHandler MouseUp
event MouseEventHandler MouseUp
Event MouseUp As MouseEventHandler
Event MouseUp As MouseEventHandler
 event MouseEventHandler^ MouseUp {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}
 event MouseEventHandler^ MouseUp {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}
abstract MouseUp : IEvent<MouseEventHandler,
    MouseEventArgs>

abstract MouseUp : IEvent<MouseEventHandler,
    MouseEventArgs>
Value
MouseEventHandler


MouseWheel Event

Keyoti RapidSpell Desktop .NET API Docs
MouseWheel Event
API ► Keyoti.RapidSpell ► IAYTTextBox ► MouseWheel
Keyoti RapidSpell Desktop .NET
Occurs when the mouse wheel is used to scroll.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event MouseEventHandler MouseWheel
event MouseEventHandler MouseWheel
Event MouseWheel As MouseEventHandler
Event MouseWheel As MouseEventHandler
 event MouseEventHandler^ MouseWheel {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}
 event MouseEventHandler^ MouseWheel {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}
abstract MouseWheel : IEvent<MouseEventHandler,
    MouseEventArgs>

abstract MouseWheel : IEvent<MouseEventHandler,
    MouseEventArgs>
Value
MouseEventHandler


Parent Property

Keyoti RapidSpell Desktop .NET API Docs
Parent Property
API ► Keyoti.RapidSpell ► IAYTTextBox ► Parent
Keyoti RapidSpell Desktop .NET
The parent control
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
Control Parent { get; }
Control Parent { get; }
ReadOnly Property Parent As Control
    Get
ReadOnly Property Parent As Control
    Get
property Control^ Parent {
    Control^ get ();
}
property Control^ Parent {
    Control^ get ();
}
abstract Parent : Control with get

abstract Parent : Control with get
Property Value
Control


ReadOnly Property

Keyoti RapidSpell Desktop .NET API Docs
ReadOnly Property
API ► Keyoti.RapidSpell ► IAYTTextBox ► ReadOnly
Keyoti RapidSpell Desktop .NET
Whether the textbox is readonly
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool ReadOnly { get; }
bool ReadOnly { get; }
ReadOnly Property ReadOnly As Boolean
    Get
ReadOnly Property ReadOnly As Boolean
    Get
property bool ReadOnly {
    bool get ();
}
property bool ReadOnly {
    bool get ();
}
abstract ReadOnly : bool with get

abstract ReadOnly : bool with get
Property Value
Boolean
Remarks
If not supported, return false.


RecreatingHandle Property

Keyoti RapidSpell Desktop .NET API Docs
RecreatingHandle Property
API ► Keyoti.RapidSpell ► IAYTTextBox ► RecreatingHandle
Keyoti RapidSpell Desktop .NET
If the control is recreating it's handle
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool RecreatingHandle { get; }
bool RecreatingHandle { get; }
ReadOnly Property RecreatingHandle As Boolean
    Get
ReadOnly Property RecreatingHandle As Boolean
    Get
property bool RecreatingHandle {
    bool get ();
}
property bool RecreatingHandle {
    bool get ();
}
abstract RecreatingHandle : bool with get

abstract RecreatingHandle : bool with get
Property Value
Boolean


Refresh Method

Keyoti RapidSpell Desktop .NET API Docs
Refresh Method
API ► Keyoti.RapidSpell ► IAYTTextBox ► Refresh()()()()
Keyoti RapidSpell Desktop .NET
Forces the control to invalidate its client area and immediately redraw itself and any child controls.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void Refresh()
void Refresh()
Sub Refresh
Sub Refresh
void Refresh()
void Refresh()
abstract Refresh : unit -> unit

abstract Refresh : unit -> unit


Resize Event

Keyoti RapidSpell Desktop .NET API Docs
Resize Event
API ► Keyoti.RapidSpell ► IAYTTextBox ► Resize
Keyoti RapidSpell Desktop .NET
Occurs when the control is resized.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event EventHandler Resize
event EventHandler Resize
Event Resize As EventHandler
Event Resize As EventHandler
 event EventHandler^ Resize {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
 event EventHandler^ Resize {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Resize : IEvent<EventHandler,
    EventArgs>

abstract Resize : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


ScrollCaret Event

Keyoti RapidSpell Desktop .NET API Docs
ScrollCaret Event
API ► Keyoti.RapidSpell ► IAYTTextBox ► ScrollCaret
Keyoti RapidSpell Desktop .NET
Occurs when the text box is scrolled to the caret.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event EventHandler ScrollCaret
event EventHandler ScrollCaret
Event ScrollCaret As EventHandler
Event ScrollCaret As EventHandler
 event EventHandler^ ScrollCaret {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
 event EventHandler^ ScrollCaret {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ScrollCaret : IEvent<EventHandler,
    EventArgs>

abstract ScrollCaret : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


SelectedText Property

Keyoti RapidSpell Desktop .NET API Docs
SelectedText Property
API ► Keyoti.RapidSpell ► IAYTTextBox ► SelectedText
Keyoti RapidSpell Desktop .NET
Gets or sets a value indicating the currently selected text in the control.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string SelectedText { get; set; }
string SelectedText { get; set; }
Property SelectedText As String
    Get
    Set
Property SelectedText As String
    Get
    Set
property String^ SelectedText {
    String^ get ();
    void set (String^ value);
}
property String^ SelectedText {
    String^ get ();
    void set (String^ value);
}
abstract SelectedText : string with get, set

abstract SelectedText : string with get, set
Property Value
String


SelectionLength Property

Keyoti RapidSpell Desktop .NET API Docs
SelectionLength Property
API ► Keyoti.RapidSpell ► IAYTTextBox ► SelectionLength
Keyoti RapidSpell Desktop .NET
Gets or sets the number of characters selected in the text box.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
int SelectionLength { get; set; }
int SelectionLength { get; set; }
Property SelectionLength As Integer
    Get
    Set
Property SelectionLength As Integer
    Get
    Set
property int SelectionLength {
    int get ();
    void set (int value);
}
property int SelectionLength {
    int get ();
    void set (int value);
}
abstract SelectionLength : int with get, set

abstract SelectionLength : int with get, set
Property Value
Int32


SelectionStart Property

Keyoti RapidSpell Desktop .NET API Docs
SelectionStart Property
API ► Keyoti.RapidSpell ► IAYTTextBox ► SelectionStart
Keyoti RapidSpell Desktop .NET
Gets or sets the starting point of text selected in the text box.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
int SelectionStart { get; set; }
int SelectionStart { get; set; }
Property SelectionStart As Integer
    Get
    Set
Property SelectionStart As Integer
    Get
    Set
property int SelectionStart {
    int get ();
    void set (int value);
}
property int SelectionStart {
    int get ();
    void set (int value);
}
abstract SelectionStart : int with get, set

abstract SelectionStart : int with get, set
Property Value
Int32


SuspendLayout Method

Keyoti RapidSpell Desktop .NET API Docs
SuspendLayout Method
API ► Keyoti.RapidSpell ► IAYTTextBox ► SuspendLayout()()()()
Keyoti RapidSpell Desktop .NET
Suspend layout
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void SuspendLayout()
void SuspendLayout()
Sub SuspendLayout
Sub SuspendLayout
void SuspendLayout()
void SuspendLayout()
abstract SuspendLayout : unit -> unit

abstract SuspendLayout : unit -> unit


Text Property

Keyoti RapidSpell Desktop .NET API Docs
Text Property
API ► Keyoti.RapidSpell ► IAYTTextBox ► Text
Keyoti RapidSpell Desktop .NET
Gets or sets the current text in the text box.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string Text { get; set; }
string Text { get; set; }
Property Text As String
    Get
    Set
Property Text As String
    Get
    Set
property String^ Text {
    String^ get ();
    void set (String^ value);
}
property String^ Text {
    String^ get ();
    void set (String^ value);
}
abstract Text : string with get, set

abstract Text : string with get, set
Property Value
String


TextChanged Event

Keyoti RapidSpell Desktop .NET API Docs
TextChanged Event
API ► Keyoti.RapidSpell ► IAYTTextBox ► TextChanged
Keyoti RapidSpell Desktop .NET
Occurs when the Text property value changes.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event EventHandler TextChanged
event EventHandler TextChanged
Event TextChanged As EventHandler
Event TextChanged As EventHandler
 event EventHandler^ TextChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
 event EventHandler^ TextChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract TextChanged : IEvent<EventHandler,
    EventArgs>

abstract TextChanged : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


TextLength Property

Keyoti RapidSpell Desktop .NET API Docs
TextLength Property
API ► Keyoti.RapidSpell ► IAYTTextBox ► TextLength
Keyoti RapidSpell Desktop .NET
Gets the current text length in the text box.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
int TextLength { get; }
int TextLength { get; }
ReadOnly Property TextLength As Integer
    Get
ReadOnly Property TextLength As Integer
    Get
property int TextLength {
    int get ();
}
property int TextLength {
    int get ();
}
abstract TextLength : int with get

abstract TextLength : int with get
Property Value
Int32


VScrolled Event

Keyoti RapidSpell Desktop .NET API Docs
VScrolled Event
API ► Keyoti.RapidSpell ► IAYTTextBox ► VScrolled
Keyoti RapidSpell Desktop .NET
Event fired when vertical scroll changed (by anything).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event EventHandler VScrolled
event EventHandler VScrolled
Event VScrolled As EventHandler
Event VScrolled As EventHandler
 event EventHandler^ VScrolled {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
 event EventHandler^ VScrolled {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract VScrolled : IEvent<EventHandler,
    EventArgs>

abstract VScrolled : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


VScrollEnd Event

Keyoti RapidSpell Desktop .NET API Docs
VScrollEnd Event
API ► Keyoti.RapidSpell ► IAYTTextBox ► VScrollEnd
Keyoti RapidSpell Desktop .NET
Event fired when vertical scroll ends.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event EventHandler VScrollEnd
event EventHandler VScrollEnd
Event VScrollEnd As EventHandler
Event VScrollEnd As EventHandler
 event EventHandler^ VScrollEnd {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
 event EventHandler^ VScrollEnd {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract VScrollEnd : IEvent<EventHandler,
    EventArgs>

abstract VScrollEnd : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


Width Property

Keyoti RapidSpell Desktop .NET API Docs
Width Property
API ► Keyoti.RapidSpell ► IAYTTextBox ► Width
Keyoti RapidSpell Desktop .NET
Gets or sets the width of the control.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
int Width { get; set; }
int Width { get; set; }
Property Width As Integer
    Get
    Set
Property Width As Integer
    Get
    Set
property int Width {
    int get ();
    void set (int value);
}
property int Width {
    int get ();
    void set (int value);
}
abstract Width : int with get, set

abstract Width : int with get, set
Property Value
Int32


ICheckerEngine Interface

Keyoti RapidSpell Desktop .NET API Docs
ICheckerEngine Interface
API ► Keyoti.RapidSpell ► ICheckerEngine
Keyoti RapidSpell Desktop .NET
Defines the interface required for a class to be used as a checker engine
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public interface ICheckerEngine
public interface ICheckerEngine
Public Interface ICheckerEngine
Public Interface ICheckerEngine
public interface class ICheckerEngine
public interface class ICheckerEngine
type ICheckerEngine =  interface end
type ICheckerEngine =  interface end
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddWord(String) | Adds a word to the user dictionary, if it exists.
 | AllowAnyCase | Whether to allow words spelt with any case, eg. "africa" instead of "Africa", this is more relaxed than AllowMixedCase.
 | AllowMixedCase | Whether to allow words spelt with mixed case, eg. "MIxEd"
 | ChangeBadWord(String) | Changes the current bad word to newWord in the text.
 | ChangeBadWord(BadWord, String) | Changes badWord to newWord in the text.
 | Check(String) | Checks the text for errors.
 | Check(String, Boolean) | Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.
 | CheckCompoundWords | Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
 | CurrentBadWord | Gets the current bad word (last returned by NextBadWord).
 | DictFilePath | The file to be used as the main dictionary, if this is null then the RapidSpellMDict.DLL satellite assembly is used.
 | FindCapitalizedSuggestions | Whether to look for capitalized suggestions, note this will slow FindSuggestions down by about 7 times.
 | FindSuggestions()()()() | Returns an ArrayList of Strings that are suitable suggestions for the current bad word (that is, the one last returned by NextBadWord()).
 | FindSuggestions(String) | Returns an ArrayList of Strings that are suitable suggestions for word.
 | GetConsiderationRange()()()() | Gets the factor for words to consider for suggestions.
 | GetIgnoreCapitalizedWords()()()() | Gets whether to ignore words that start with capital letters.
 | GetIncludeUserDictionaryInSuggestions()()()() | Gets whether the user dictionary should be used in finding suggestions for misspelt words.
 | GetSuggestionsMethod()()()() | Gets the suggestions method, where method is an integer identifier.
 | GetUndoableStatePoint()()()() | Gets the state of the current run, which can be stored and used with RevertToUndoableStatePoint(RapidSpellChecker..::..State)
 | IgnoreAll(String) | Marks word to be ignored in rest of the text.
 | IgnoreAllCaseInsensitive | Whether Ignore All operations should be considered case insensitive (default false).
 | IgnoreIncorrectSentenceCapitalization | Whether to ignore incorrect sentence capitalization.
 | IgnoreInEnglishLowerCaseI | Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
 | IgnoreList | The words to ignore, note this list is changed by IgnoreAll.
 | IgnorePatternMaximumWordLength | The maximum length of word that will be tested as a regex ignore pattern.
 | IgnoreURLsAndEmailAddresses | Whether to ignore URLs and email addresses (requires V2Parser=true)
 | IgnoreWordsWithDigits | Whether to ignore words with numbers in them (eg. A10 or 7-11).
 | IgnoreXML | Whether to ignore XML tags in the text.
 | LanguageParser | The type of language parsing to use.
 | LookIntoHyphenatedText | Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
 | LookUp(String) | Looks up word in the dictionary, returns true if it is in there.
 | NextBadWord()()()() | Gets the next bad word in the list that was identified by Check.
 | RevertToUndoableStatePoint(RapidSpellChecker..::..State) | Reverts the state to that it was when GetUndoableStatePoint()()()() was called.
 | SetConsiderationRange(Int32) | Sets the breadth of the suggestions search.
 | SetDictFileStream(Stream, String, DateTime) | Passes a Dict file as a stream, to be used for the main dictionary.
 | SetIgnoreCapitalizedWords(Boolean) | Sets whether to ignore capitalized words.
 | SetIncludeUserDictionaryInSuggestions(Boolean) | Sets whether to include the user dictionary in suggestions taken from this engine.
 | SetOptionalContext(String, String) | Provides the engine with any helpful text around the text snippet which will be passed to the Check method. Implementation is not required.
 | SetPosition(Int32) | Sets the pointer position for the NextBadWord iterator.
 | SetSeparateHyphenWords(Boolean) | Sets whether to separate words with hyphens in them into separate words.
 | SetSuggestionsMethod(Int32) | Sets the suggestions method, where method is an integer identifier.
 | SetUserDictionary(UserDictionary) | Sets the UserDictionary object to be used as a user dictionary source.
 | SetUserDictionary(String) | Sets the UserDictionary file path to be used as a user dictionary source.
 | SuggestSplitWords | Whether to look for connected words in suggestions.
 | TextBoundary | The AdvancedTextBoundary class to use to parse words.
 | userDictionary | The user dictionary, this should be null (C#) or nothing (VB.NET) if no user dictionary is being used.
 | V2Parser | Whether to use parser version 2 (specific to RapidSpellChecker).
 | WarnDuplicates | Whether to treat duplicate words as errors (eg. "this is is an error").
 | WordAdded | Indicates a word has been added
Remarks
This is the interface which any checker engine must have, by implementing this interface any object can be used to parse text and identify 'bad words'. It is not necessary to functionally implement all members, for this reason an abstract empty implementation class is provided (CheckerEngineAdapter) which can be extended and overridden for desired functionality.


AddWord Method (word)

Keyoti RapidSpell Desktop .NET API Docs
AddWord Method (word)
API ► Keyoti.RapidSpell ► ICheckerEngine ► AddWord(String)
Keyoti RapidSpell Desktop .NET
Adds a word to the user dictionary, if it exists.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool AddWord(
    string word
)
bool AddWord(
    string word
)
Function AddWord (
    word As String
) As Boolean
Function AddWord (
    word As String
) As Boolean
bool AddWord(
    String^ word
)
bool AddWord(
    String^ word
)
abstract AddWord :
        word : string -> bool

abstract AddWord :
        word : string -> bool
Parameters
word (String)
Return Value
Boolean
Remarks
Should return true if the word was added successfully, false otherwise.


AllowAnyCase Property

Keyoti RapidSpell Desktop .NET API Docs
AllowAnyCase Property
API ► Keyoti.RapidSpell ► ICheckerEngine ► AllowAnyCase
Keyoti RapidSpell Desktop .NET
Whether to allow words spelt with any case, eg. "africa" instead of "Africa", this is more relaxed than AllowMixedCase.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool AllowAnyCase { get; set; }
bool AllowAnyCase { get; set; }
Property AllowAnyCase As Boolean
    Get
    Set
Property AllowAnyCase As Boolean
    Get
    Set
property bool AllowAnyCase {
    bool get ();
    void set (bool value);
}
property bool AllowAnyCase {
    bool get ();
    void set (bool value);
}
abstract AllowAnyCase : bool with get, set

abstract AllowAnyCase : bool with get, set
Property Value
Boolean


AllowMixedCase Property

Keyoti RapidSpell Desktop .NET API Docs
AllowMixedCase Property
API ► Keyoti.RapidSpell ► ICheckerEngine ► AllowMixedCase
Keyoti RapidSpell Desktop .NET
Whether to allow words spelt with mixed case, eg. "MIxEd"
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool AllowMixedCase { get; set; }
bool AllowMixedCase { get; set; }
Property AllowMixedCase As Boolean
    Get
    Set
Property AllowMixedCase As Boolean
    Get
    Set
property bool AllowMixedCase {
    bool get ();
    void set (bool value);
}
property bool AllowMixedCase {
    bool get ();
    void set (bool value);
}
abstract AllowMixedCase : bool with get, set

abstract AllowMixedCase : bool with get, set
Property Value
Boolean


ChangeBadWord Method

Keyoti RapidSpell Desktop .NET API Docs
ChangeBadWord Method
API ► Keyoti.RapidSpell ► ICheckerEngine ► ChangeBadWord()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | ChangeBadWord(String) | Changes the current bad word to newWord in the text.
 | ChangeBadWord(BadWord, String) | Changes badWord to newWord in the text.


ChangeBadWord Method (badWord, newWord)

Keyoti RapidSpell Desktop .NET API Docs
ChangeBadWord Method (badWord, newWord)
API ► Keyoti.RapidSpell ► ICheckerEngine ► ChangeBadWord(BadWord, String)
Keyoti RapidSpell Desktop .NET
Changes badWord to newWord in the text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void ChangeBadWord(
    BadWord badWord,
    string newWord
)
void ChangeBadWord(
    BadWord badWord,
    string newWord
)
Sub ChangeBadWord (
    badWord As BadWord,
    newWord As String
)
Sub ChangeBadWord (
    badWord As BadWord,
    newWord As String
)
void ChangeBadWord(
    BadWord^ badWord,
    String^ newWord
)
void ChangeBadWord(
    BadWord^ badWord,
    String^ newWord
)
abstract ChangeBadWord :
        badWord : BadWord *
        newWord : string -> unit

abstract ChangeBadWord :
        badWord : BadWord *
        newWord : string -> unit
Parameters
badWord (BadWord)
the word to reaplce
newWord (String)
replaces the current misspelt word.
Return Value

void
Exceptions
Exception | Condition
ArgumentNullException | if newWord parameter is null.


ChangeBadWord Method (newWord)

Keyoti RapidSpell Desktop .NET API Docs
ChangeBadWord Method (newWord)
API ► Keyoti.RapidSpell ► ICheckerEngine ► ChangeBadWord(String)
Keyoti RapidSpell Desktop .NET
Changes the current bad word to newWord in the text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void ChangeBadWord(
    string newWord
)
void ChangeBadWord(
    string newWord
)
Sub ChangeBadWord (
    newWord As String
)
Sub ChangeBadWord (
    newWord As String
)
void ChangeBadWord(
    String^ newWord
)
void ChangeBadWord(
    String^ newWord
)
abstract ChangeBadWord :
        newWord : string -> unit

abstract ChangeBadWord :
        newWord : string -> unit
Parameters
newWord (String)
replaces the current misspelt word.
Return Value

void
Exceptions
Exception | Condition
NoCurrentBadWordException | if nextBadWord() hasn't been run first AND found an erroneous word.
ArgumentNullException | if newWord parameter is null.


Check Method

Keyoti RapidSpell Desktop .NET API Docs
Check Method
API ► Keyoti.RapidSpell ► ICheckerEngine ► Check()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Check(String) | Checks the text for errors.
 | Check(String, Boolean) | Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.


Check Method (text)

Keyoti RapidSpell Desktop .NET API Docs
Check Method (text)
API ► Keyoti.RapidSpell ► ICheckerEngine ► Check(String)
Keyoti RapidSpell Desktop .NET
Checks the text for errors.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void Check(
    string text
)
void Check(
    string text
)
Sub Check (
    text As String
)
Sub Check (
    text As String
)
void Check(
    String^ text
)
void Check(
    String^ text
)
abstract Check :
        text : string -> unit

abstract Check :
        text : string -> unit
Parameters
text (String)
Exceptions
Exception | Condition
ArgumentNullException | if text parameter is null.


Check Method (text, isStartOfTextBody)

Keyoti RapidSpell Desktop .NET API Docs
Check Method (text, isStartOfTextBody)
API ► Keyoti.RapidSpell ► ICheckerEngine ► Check(String, Boolean)
Keyoti RapidSpell Desktop .NET
Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void Check(
    string text,
    bool isStartOfTextBody
)
void Check(
    string text,
    bool isStartOfTextBody
)
Sub Check (
    text As String,
    isStartOfTextBody As Boolean
)
Sub Check (
    text As String,
    isStartOfTextBody As Boolean
)
void Check(
    String^ text,
    bool isStartOfTextBody
)
void Check(
    String^ text,
    bool isStartOfTextBody
)
abstract Check :
        text : string *
        isStartOfTextBody : bool -> unit

abstract Check :
        text : string *
        isStartOfTextBody : bool -> unit
Parameters
text (String)
to spell check.
isStartOfTextBody (Boolean)
whether the text being spell checked is at the start of the text body (eg. start of text box), this affects sentence capitalization determination.
Return Value

void
Exceptions
Exception | Condition
ArgumentNullException | if text parameter is null.


CheckCompoundWords Property

Keyoti RapidSpell Desktop .NET API Docs
CheckCompoundWords Property
API ► Keyoti.RapidSpell ► ICheckerEngine ► CheckCompoundWords
Keyoti RapidSpell Desktop .NET
Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool CheckCompoundWords { get; set; }
bool CheckCompoundWords { get; set; }
Property CheckCompoundWords As Boolean
    Get
    Set
Property CheckCompoundWords As Boolean
    Get
    Set
property bool CheckCompoundWords {
    bool get ();
    void set (bool value);
}
property bool CheckCompoundWords {
    bool get ();
    void set (bool value);
}
abstract CheckCompoundWords : bool with get, set

abstract CheckCompoundWords : bool with get, set
Property Value
Boolean
Remarks
If this=false then LookUp("thesewordsarejoined") = false

If this=true then LookUp("thesewordsarejoined") = true

If this=false then LookUp("abcdef") = false

If this=true then LookUp("abcdef") = false

Setting this to true will degrade lookup performance


CurrentBadWord Property

Keyoti RapidSpell Desktop .NET API Docs
CurrentBadWord Property
API ► Keyoti.RapidSpell ► ICheckerEngine ► CurrentBadWord
Keyoti RapidSpell Desktop .NET
Gets the current bad word (last returned by NextBadWord).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
BadWord CurrentBadWord { get; }
BadWord CurrentBadWord { get; }
ReadOnly Property CurrentBadWord As BadWord
    Get
ReadOnly Property CurrentBadWord As BadWord
    Get
property BadWord^ CurrentBadWord {
    BadWord^ get ();
}
property BadWord^ CurrentBadWord {
    BadWord^ get ();
}
abstract CurrentBadWord : BadWord with get

abstract CurrentBadWord : BadWord with get
Property Value
BadWord


DictFilePath Property

Keyoti RapidSpell Desktop .NET API Docs
DictFilePath Property
API ► Keyoti.RapidSpell ► ICheckerEngine ► DictFilePath
Keyoti RapidSpell Desktop .NET
The file to be used as the main dictionary, if this is null then the RapidSpellMDict.DLL satellite assembly is used.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string DictFilePath { get; set; }
string DictFilePath { get; set; }
Property DictFilePath As String
    Get
    Set
Property DictFilePath As String
    Get
    Set
property String^ DictFilePath {
    String^ get ();
    void set (String^ value);
}
property String^ DictFilePath {
    String^ get ();
    void set (String^ value);
}
abstract DictFilePath : string with get, set

abstract DictFilePath : string with get, set
Property Value
String


FindCapitalizedSuggestions Property

Keyoti RapidSpell Desktop .NET API Docs
FindCapitalizedSuggestions Property
API ► Keyoti.RapidSpell ► ICheckerEngine ► FindCapitalizedSuggestions
Keyoti RapidSpell Desktop .NET
Whether to look for capitalized suggestions, note this will slow FindSuggestions down by about 7 times.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool FindCapitalizedSuggestions { get; set; }
bool FindCapitalizedSuggestions { get; set; }
Property FindCapitalizedSuggestions As Boolean
    Get
    Set
Property FindCapitalizedSuggestions As Boolean
    Get
    Set
property bool FindCapitalizedSuggestions {
    bool get ();
    void set (bool value);
}
property bool FindCapitalizedSuggestions {
    bool get ();
    void set (bool value);
}
abstract FindCapitalizedSuggestions : bool with get, set

abstract FindCapitalizedSuggestions : bool with get, set
Property Value
Boolean


FindSuggestions Method

Keyoti RapidSpell Desktop .NET API Docs
FindSuggestions Method
API ► Keyoti.RapidSpell ► ICheckerEngine ► FindSuggestions()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | FindSuggestions()()()() | Returns an ArrayList of Strings that are suitable suggestions for the current bad word (that is, the one last returned by NextBadWord()).
 | FindSuggestions(String) | Returns an ArrayList of Strings that are suitable suggestions for word.


FindSuggestions Method

Keyoti RapidSpell Desktop .NET API Docs
FindSuggestions Method
API ► Keyoti.RapidSpell ► ICheckerEngine ► FindSuggestions()()()()
Keyoti RapidSpell Desktop .NET
Returns an ArrayList of Strings that are suitable suggestions for the current bad word (that is, the one last returned by NextBadWord()).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
ArrayList FindSuggestions()
ArrayList FindSuggestions()
Function FindSuggestions As ArrayList
Function FindSuggestions As ArrayList
ArrayList^ FindSuggestions()
ArrayList^ FindSuggestions()
abstract FindSuggestions : unit -> ArrayList

abstract FindSuggestions : unit -> ArrayList
Return Value
ArrayList
Remarks
If no suggestions can be found, this should return an empty ArrayList. This method should be thread safe if operating with RapidSpell Desktop.
Exceptions
Exception | Condition
NoCurrentBadWordException | If NextBadWord() hasn't been run first AND found an erroneous word.


FindSuggestions Method (word)

Keyoti RapidSpell Desktop .NET API Docs
FindSuggestions Method (word)
API ► Keyoti.RapidSpell ► ICheckerEngine ► FindSuggestions(String)
Keyoti RapidSpell Desktop .NET
Returns an ArrayList of Strings that are suitable suggestions for word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
ArrayList FindSuggestions(
    string word
)
ArrayList FindSuggestions(
    string word
)
Function FindSuggestions (
    word As String
) As ArrayList
Function FindSuggestions (
    word As String
) As ArrayList
ArrayList^ FindSuggestions(
    String^ word
)
ArrayList^ FindSuggestions(
    String^ word
)
abstract FindSuggestions :
        word : string -> ArrayList

abstract FindSuggestions :
        word : string -> ArrayList
Parameters
word (String)
Return Value
ArrayList
Remarks
If no suggestions can be found, this should return an empty ArrayList. This method should be thread safe if operating with RapidSpell Desktop.


GetConsiderationRange Method

Keyoti RapidSpell Desktop .NET API Docs
GetConsiderationRange Method
API ► Keyoti.RapidSpell ► ICheckerEngine ► GetConsiderationRange()()()()
Keyoti RapidSpell Desktop .NET
Gets the factor for words to consider for suggestions.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
int GetConsiderationRange()
int GetConsiderationRange()
Function GetConsiderationRange As Integer
Function GetConsiderationRange As Integer
int GetConsiderationRange()
int GetConsiderationRange()
abstract GetConsiderationRange : unit -> int

abstract GetConsiderationRange : unit -> int
Return Value
Int32


GetIgnoreCapitalizedWords Method

Keyoti RapidSpell Desktop .NET API Docs
GetIgnoreCapitalizedWords Method
API ► Keyoti.RapidSpell ► ICheckerEngine ► GetIgnoreCapitalizedWords()()()()
Keyoti RapidSpell Desktop .NET
Gets whether to ignore words that start with capital letters.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool GetIgnoreCapitalizedWords()
bool GetIgnoreCapitalizedWords()
Function GetIgnoreCapitalizedWords As Boolean
Function GetIgnoreCapitalizedWords As Boolean
bool GetIgnoreCapitalizedWords()
bool GetIgnoreCapitalizedWords()
abstract GetIgnoreCapitalizedWords : unit -> bool

abstract GetIgnoreCapitalizedWords : unit -> bool
Return Value
Boolean


GetIncludeUserDictionaryInSuggestions Method

Keyoti RapidSpell Desktop .NET API Docs
GetIncludeUserDictionaryInSuggestions Method
API ► Keyoti.RapidSpell ► ICheckerEngine ► GetIncludeUserDictionaryInSuggestions()()()()
Keyoti RapidSpell Desktop .NET
Gets whether the user dictionary should be used in finding suggestions for misspelt words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool GetIncludeUserDictionaryInSuggestions()
bool GetIncludeUserDictionaryInSuggestions()
Function GetIncludeUserDictionaryInSuggestions As Boolean
Function GetIncludeUserDictionaryInSuggestions As Boolean
bool GetIncludeUserDictionaryInSuggestions()
bool GetIncludeUserDictionaryInSuggestions()
abstract GetIncludeUserDictionaryInSuggestions : unit -> bool

abstract GetIncludeUserDictionaryInSuggestions : unit -> bool
Return Value
Boolean


GetSuggestionsMethod Method

Keyoti RapidSpell Desktop .NET API Docs
GetSuggestionsMethod Method
API ► Keyoti.RapidSpell ► ICheckerEngine ► GetSuggestionsMethod()()()()
Keyoti RapidSpell Desktop .NET
Gets the suggestions method, where method is an integer identifier.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
int GetSuggestionsMethod()
int GetSuggestionsMethod()
Function GetSuggestionsMethod As Integer
Function GetSuggestionsMethod As Integer
int GetSuggestionsMethod()
int GetSuggestionsMethod()
abstract GetSuggestionsMethod : unit -> int

abstract GetSuggestionsMethod : unit -> int
Return Value
Int32


GetUndoableStatePoint Method

Keyoti RapidSpell Desktop .NET API Docs
GetUndoableStatePoint Method
API ► Keyoti.RapidSpell ► ICheckerEngine ► GetUndoableStatePoint()()()()
Keyoti RapidSpell Desktop .NET
Gets the state of the current run, which can be stored and used with RevertToUndoableStatePoint(RapidSpellChecker..::..State)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
RapidSpellChecker..::..State GetUndoableStatePoint()
RapidSpellChecker..::..State GetUndoableStatePoint()
Function GetUndoableStatePoint As RapidSpellChecker..::..State
Function GetUndoableStatePoint As RapidSpellChecker..::..State
RapidSpellChecker..::..State^ GetUndoableStatePoint()
RapidSpellChecker..::..State^ GetUndoableStatePoint()
abstract GetUndoableStatePoint : unit -> RapidSpellChecker..::..State

abstract GetUndoableStatePoint : unit -> RapidSpellChecker..::..State
Return Value
RapidSpellChecker..::..State
Returns the current state, or null if not supporting undo.


IgnoreAll Method (word)

Keyoti RapidSpell Desktop .NET API Docs
IgnoreAll Method (word)
API ► Keyoti.RapidSpell ► ICheckerEngine ► IgnoreAll(String)
Keyoti RapidSpell Desktop .NET
Marks word to be ignored in rest of the text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void IgnoreAll(
    string word
)
void IgnoreAll(
    string word
)
Sub IgnoreAll (
    word As String
)
Sub IgnoreAll (
    word As String
)
void IgnoreAll(
    String^ word
)
void IgnoreAll(
    String^ word
)
abstract IgnoreAll :
        word : string -> unit

abstract IgnoreAll :
        word : string -> unit
Parameters
word (String)
to ignore
Return Value

void
Exceptions
Exception | Condition
ArgumentNullException | if word parameter is null.


IgnoreAllCaseInsensitive Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreAllCaseInsensitive Property
API ► Keyoti.RapidSpell ► ICheckerEngine ► IgnoreAllCaseInsensitive
Keyoti RapidSpell Desktop .NET
Whether Ignore All operations should be considered case insensitive (default false).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool IgnoreAllCaseInsensitive { get; set; }
bool IgnoreAllCaseInsensitive { get; set; }
Property IgnoreAllCaseInsensitive As Boolean
    Get
    Set
Property IgnoreAllCaseInsensitive As Boolean
    Get
    Set
property bool IgnoreAllCaseInsensitive {
    bool get ();
    void set (bool value);
}
property bool IgnoreAllCaseInsensitive {
    bool get ();
    void set (bool value);
}
abstract IgnoreAllCaseInsensitive : bool with get, set

abstract IgnoreAllCaseInsensitive : bool with get, set
Property Value
Boolean


IgnoreIncorrectSentenceCapitalization Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreIncorrectSentenceCapitalization Property
API ► Keyoti.RapidSpell ► ICheckerEngine ► IgnoreIncorrectSentenceCapitalization
Keyoti RapidSpell Desktop .NET
Whether to ignore incorrect sentence capitalization.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool IgnoreIncorrectSentenceCapitalization { get; set; }
bool IgnoreIncorrectSentenceCapitalization { get; set; }
Property IgnoreIncorrectSentenceCapitalization As Boolean
    Get
    Set
Property IgnoreIncorrectSentenceCapitalization As Boolean
    Get
    Set
property bool IgnoreIncorrectSentenceCapitalization {
    bool get ();
    void set (bool value);
}
property bool IgnoreIncorrectSentenceCapitalization {
    bool get ();
    void set (bool value);
}
abstract IgnoreIncorrectSentenceCapitalization : bool with get, set

abstract IgnoreIncorrectSentenceCapitalization : bool with get, set
Property Value
Boolean


IgnoreInEnglishLowerCaseI Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreInEnglishLowerCaseI Property
API ► Keyoti.RapidSpell ► ICheckerEngine ► IgnoreInEnglishLowerCaseI
Keyoti RapidSpell Desktop .NET
Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool IgnoreInEnglishLowerCaseI { get; set; }
bool IgnoreInEnglishLowerCaseI { get; set; }
Property IgnoreInEnglishLowerCaseI As Boolean
    Get
    Set
Property IgnoreInEnglishLowerCaseI As Boolean
    Get
    Set
property bool IgnoreInEnglishLowerCaseI {
    bool get ();
    void set (bool value);
}
property bool IgnoreInEnglishLowerCaseI {
    bool get ();
    void set (bool value);
}
abstract IgnoreInEnglishLowerCaseI : bool with get, set

abstract IgnoreInEnglishLowerCaseI : bool with get, set
Property Value
Boolean


IgnoreList Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreList Property
API ► Keyoti.RapidSpell ► ICheckerEngine ► IgnoreList
Keyoti RapidSpell Desktop .NET
The words to ignore, note this list is changed by IgnoreAll.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
ArrayList IgnoreList { get; }
ArrayList IgnoreList { get; }
ReadOnly Property IgnoreList As ArrayList
    Get
ReadOnly Property IgnoreList As ArrayList
    Get
property ArrayList^ IgnoreList {
    ArrayList^ get ();
}
property ArrayList^ IgnoreList {
    ArrayList^ get ();
}
abstract IgnoreList : ArrayList with get

abstract IgnoreList : ArrayList with get
Property Value
ArrayList


IgnorePatternMaximumWordLength Property

Keyoti RapidSpell Desktop .NET API Docs
IgnorePatternMaximumWordLength Property
API ► Keyoti.RapidSpell ► ICheckerEngine ► IgnorePatternMaximumWordLength
Keyoti RapidSpell Desktop .NET
The maximum length of word that will be tested as a regex ignore pattern.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
int IgnorePatternMaximumWordLength { get; set; }
int IgnorePatternMaximumWordLength { get; set; }
Property IgnorePatternMaximumWordLength As Integer
    Get
    Set
Property IgnorePatternMaximumWordLength As Integer
    Get
    Set
property int IgnorePatternMaximumWordLength {
    int get ();
    void set (int value);
}
property int IgnorePatternMaximumWordLength {
    int get ();
    void set (int value);
}
abstract IgnorePatternMaximumWordLength : int with get, set

abstract IgnorePatternMaximumWordLength : int with get, set
Property Value
Int32


IgnoreURLsAndEmailAddresses Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreURLsAndEmailAddresses Property
API ► Keyoti.RapidSpell ► ICheckerEngine ► IgnoreURLsAndEmailAddresses
Keyoti RapidSpell Desktop .NET
Whether to ignore URLs and email addresses (requires V2Parser=true)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool IgnoreURLsAndEmailAddresses { get; set; }
bool IgnoreURLsAndEmailAddresses { get; set; }
Property IgnoreURLsAndEmailAddresses As Boolean
    Get
    Set
Property IgnoreURLsAndEmailAddresses As Boolean
    Get
    Set
property bool IgnoreURLsAndEmailAddresses {
    bool get ();
    void set (bool value);
}
property bool IgnoreURLsAndEmailAddresses {
    bool get ();
    void set (bool value);
}
abstract IgnoreURLsAndEmailAddresses : bool with get, set

abstract IgnoreURLsAndEmailAddresses : bool with get, set
Property Value
Boolean
Remarks
This will cause the following strings to be accepted as non-spelling errors;
"user@domain.com", "http://www.domain.com", "domain.co.uk" etc.


IgnoreWordsWithDigits Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreWordsWithDigits Property
API ► Keyoti.RapidSpell ► ICheckerEngine ► IgnoreWordsWithDigits
Keyoti RapidSpell Desktop .NET
Whether to ignore words with numbers in them (eg. A10 or 7-11).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool IgnoreWordsWithDigits { get; set; }
bool IgnoreWordsWithDigits { get; set; }
Property IgnoreWordsWithDigits As Boolean
    Get
    Set
Property IgnoreWordsWithDigits As Boolean
    Get
    Set
property bool IgnoreWordsWithDigits {
    bool get ();
    void set (bool value);
}
property bool IgnoreWordsWithDigits {
    bool get ();
    void set (bool value);
}
abstract IgnoreWordsWithDigits : bool with get, set

abstract IgnoreWordsWithDigits : bool with get, set
Property Value
Boolean


IgnoreXML Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreXML Property
API ► Keyoti.RapidSpell ► ICheckerEngine ► IgnoreXML
Keyoti RapidSpell Desktop .NET
Whether to ignore XML tags in the text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool IgnoreXML { get; set; }
bool IgnoreXML { get; set; }
Property IgnoreXML As Boolean
    Get
    Set
Property IgnoreXML As Boolean
    Get
    Set
property bool IgnoreXML {
    bool get ();
    void set (bool value);
}
property bool IgnoreXML {
    bool get ();
    void set (bool value);
}
abstract IgnoreXML : bool with get, set

abstract IgnoreXML : bool with get, set
Property Value
Boolean


LanguageParser Property

Keyoti RapidSpell Desktop .NET API Docs
LanguageParser Property
API ► Keyoti.RapidSpell ► ICheckerEngine ► LanguageParser
Keyoti RapidSpell Desktop .NET
The type of language parsing to use.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
LanguageType LanguageParser { get; set; }
LanguageType LanguageParser { get; set; }
Property LanguageParser As LanguageType
    Get
    Set
Property LanguageParser As LanguageType
    Get
    Set
property LanguageType LanguageParser {
    LanguageType get ();
    void set (LanguageType value);
}
property LanguageType LanguageParser {
    LanguageType get ();
    void set (LanguageType value);
}
abstract LanguageParser : LanguageType with get, set

abstract LanguageParser : LanguageType with get, set
Return Value
LanguageType
This implementation always returns ENGLISH.
Remarks
Eg. If the dictionary is set to French, you should use the French parser.


LookIntoHyphenatedText Property

Keyoti RapidSpell Desktop .NET API Docs
LookIntoHyphenatedText Property
API ► Keyoti.RapidSpell ► ICheckerEngine ► LookIntoHyphenatedText
Keyoti RapidSpell Desktop .NET
Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool LookIntoHyphenatedText { get; set; }
bool LookIntoHyphenatedText { get; set; }
Property LookIntoHyphenatedText As Boolean
    Get
    Set
Property LookIntoHyphenatedText As Boolean
    Get
    Set
property bool LookIntoHyphenatedText {
    bool get ();
    void set (bool value);
}
property bool LookIntoHyphenatedText {
    bool get ();
    void set (bool value);
}
abstract LookIntoHyphenatedText : bool with get, set

abstract LookIntoHyphenatedText : bool with get, set
Property Value
Boolean
Remarks
Eg. "socio-economic" will be checked as "socio" and "economic".


LookUp Method (word)

Keyoti RapidSpell Desktop .NET API Docs
LookUp Method (word)
API ► Keyoti.RapidSpell ► ICheckerEngine ► LookUp(String)
Keyoti RapidSpell Desktop .NET
Looks up word in the dictionary, returns true if it is in there.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool LookUp(
    string word
)
bool LookUp(
    string word
)
Function LookUp (
    word As String
) As Boolean
Function LookUp (
    word As String
) As Boolean
bool LookUp(
    String^ word
)
bool LookUp(
    String^ word
)
abstract LookUp :
        word : string -> bool

abstract LookUp :
        word : string -> bool
Parameters
word (String)
Return Value
Boolean


NextBadWord Method

Keyoti RapidSpell Desktop .NET API Docs
NextBadWord Method
API ► Keyoti.RapidSpell ► ICheckerEngine ► NextBadWord()()()()
Keyoti RapidSpell Desktop .NET
Gets the next bad word in the list that was identified by Check.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
BadWord NextBadWord()
BadWord NextBadWord()
Function NextBadWord As BadWord
Function NextBadWord As BadWord
BadWord^ NextBadWord()
BadWord^ NextBadWord()
abstract NextBadWord : unit -> BadWord

abstract NextBadWord : unit -> BadWord
Return Value
BadWord
The next BadWord object from the text, must return null (C#) or nothing (VB.NET) when no more bad words exist.
Remarks
Check must be called before this method.


RevertToUndoableStatePoint Method (state)

Keyoti RapidSpell Desktop .NET API Docs
RevertToUndoableStatePoint Method (state)
API ► Keyoti.RapidSpell ► ICheckerEngine ► RevertToUndoableStatePoint(RapidSpellChecker..::..State)
Keyoti RapidSpell Desktop .NET
Reverts the state to that it was when GetUndoableStatePoint()()()() was called.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void RevertToUndoableStatePoint(
    RapidSpellChecker..::..State state
)
void RevertToUndoableStatePoint(
    RapidSpellChecker..::..State state
)
Sub RevertToUndoableStatePoint (
    state As RapidSpellChecker..::..State
)
Sub RevertToUndoableStatePoint (
    state As RapidSpellChecker..::..State
)
void RevertToUndoableStatePoint(
    RapidSpellChecker..::..State^ state
)
void RevertToUndoableStatePoint(
    RapidSpellChecker..::..State^ state
)
abstract RevertToUndoableStatePoint :
        state : RapidSpellChecker..::..State -> unit

abstract RevertToUndoableStatePoint :
        state : RapidSpellChecker..::..State -> unit
Parameters
state (RapidSpellChecker..::..State)


SetConsiderationRange Method (range)

Keyoti RapidSpell Desktop .NET API Docs
SetConsiderationRange Method (range)
API ► Keyoti.RapidSpell ► ICheckerEngine ► SetConsiderationRange(Int32)
Keyoti RapidSpell Desktop .NET
Sets the breadth of the suggestions search.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void SetConsiderationRange(
    int range
)
void SetConsiderationRange(
    int range
)
Sub SetConsiderationRange (
    range As Integer
)
Sub SetConsiderationRange (
    range As Integer
)
void SetConsiderationRange(
    int range
)
void SetConsiderationRange(
    int range
)
abstract SetConsiderationRange :
        range : int -> unit

abstract SetConsiderationRange :
        range : int -> unit
Parameters
range (Int32)


SetDictFileStream Method (dictFileStream, id, modifiedDate)

Keyoti RapidSpell Desktop .NET API Docs
SetDictFileStream Method (dictFileStream, id, modifiedDate)
API ► Keyoti.RapidSpell ► ICheckerEngine ► SetDictFileStream(Stream, String, DateTime)
Keyoti RapidSpell Desktop .NET
Passes a Dict file as a stream, to be used for the main dictionary.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void SetDictFileStream(
    Stream dictFileStream,
    string id,
    DateTime modifiedDate
)
void SetDictFileStream(
    Stream dictFileStream,
    string id,
    DateTime modifiedDate
)
Sub SetDictFileStream (
    dictFileStream As Stream,
    id As String,
    modifiedDate As DateTime
)
Sub SetDictFileStream (
    dictFileStream As Stream,
    id As String,
    modifiedDate As DateTime
)
void SetDictFileStream(
    Stream^ dictFileStream,
    String^ id,
    DateTime modifiedDate
)
void SetDictFileStream(
    Stream^ dictFileStream,
    String^ id,
    DateTime modifiedDate
)
abstract SetDictFileStream :
        dictFileStream : Stream *
        id : string *
        modifiedDate : DateTime -> unit

abstract SetDictFileStream :
        dictFileStream : Stream *
        id : string *
        modifiedDate : DateTime -> unit
Parameters
dictFileStream (Stream)
The stream containing the dictionary
id (String)
Any generated identity string which the spell checker can use to cache and identify this dictionary.
modifiedDate (DateTime)
When the dictionary was modified, use .Now to update the cache.
Remarks
Note this method must be set before Check is called, and the stream position must be at beginning of Dict file. The stream is NOT closed by this method.


SetIgnoreCapitalizedWords Method (ignore)

Keyoti RapidSpell Desktop .NET API Docs
SetIgnoreCapitalizedWords Method (ignore)
API ► Keyoti.RapidSpell ► ICheckerEngine ► SetIgnoreCapitalizedWords(Boolean)
Keyoti RapidSpell Desktop .NET
Sets whether to ignore capitalized words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void SetIgnoreCapitalizedWords(
    bool ignore
)
void SetIgnoreCapitalizedWords(
    bool ignore
)
Sub SetIgnoreCapitalizedWords (
    ignore As Boolean
)
Sub SetIgnoreCapitalizedWords (
    ignore As Boolean
)
void SetIgnoreCapitalizedWords(
    bool ignore
)
void SetIgnoreCapitalizedWords(
    bool ignore
)
abstract SetIgnoreCapitalizedWords :
        ignore : bool -> unit

abstract SetIgnoreCapitalizedWords :
        ignore : bool -> unit
Parameters
ignore (Boolean)


SetIncludeUserDictionaryInSuggestions Method (includeUserDictionaryInSuggestions)

Keyoti RapidSpell Desktop .NET API Docs
SetIncludeUserDictionaryInSuggestions Method (includeUserDictionaryInSuggestions)
API ► Keyoti.RapidSpell ► ICheckerEngine ► SetIncludeUserDictionaryInSuggestions(Boolean)
Keyoti RapidSpell Desktop .NET
Sets whether to include the user dictionary in suggestions taken from this engine.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void SetIncludeUserDictionaryInSuggestions(
    bool includeUserDictionaryInSuggestions
)
void SetIncludeUserDictionaryInSuggestions(
    bool includeUserDictionaryInSuggestions
)
Sub SetIncludeUserDictionaryInSuggestions (
    includeUserDictionaryInSuggestions As Boolean
)
Sub SetIncludeUserDictionaryInSuggestions (
    includeUserDictionaryInSuggestions As Boolean
)
void SetIncludeUserDictionaryInSuggestions(
    bool includeUserDictionaryInSuggestions
)
void SetIncludeUserDictionaryInSuggestions(
    bool includeUserDictionaryInSuggestions
)
abstract SetIncludeUserDictionaryInSuggestions :
        includeUserDictionaryInSuggestions : bool -> unit

abstract SetIncludeUserDictionaryInSuggestions :
        includeUserDictionaryInSuggestions : bool -> unit
Parameters
includeUserDictionaryInSuggestions (Boolean)


SetOptionalContext Method (beforeToCheckSnippet, afterToCheckSnippet)

Keyoti RapidSpell Desktop .NET API Docs
SetOptionalContext Method (beforeToCheckSnippet, afterToCheckSnippet)
API ► Keyoti.RapidSpell ► ICheckerEngine ► SetOptionalContext(String, String)
Keyoti RapidSpell Desktop .NET
Provides the engine with any helpful text around the text snippet which will be passed to the Check method. Implementation is not required.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void SetOptionalContext(
    string beforeToCheckSnippet,
    string afterToCheckSnippet
)
void SetOptionalContext(
    string beforeToCheckSnippet,
    string afterToCheckSnippet
)
Sub SetOptionalContext (
    beforeToCheckSnippet As String,
    afterToCheckSnippet As String
)
Sub SetOptionalContext (
    beforeToCheckSnippet As String,
    afterToCheckSnippet As String
)
void SetOptionalContext(
    String^ beforeToCheckSnippet,
    String^ afterToCheckSnippet
)
void SetOptionalContext(
    String^ beforeToCheckSnippet,
    String^ afterToCheckSnippet
)
abstract SetOptionalContext :
        beforeToCheckSnippet : string *
        afterToCheckSnippet : string -> unit

abstract SetOptionalContext :
        beforeToCheckSnippet : string *
        afterToCheckSnippet : string -> unit
Parameters
beforeToCheckSnippet (String)
Any text before the to check snippet
afterToCheckSnippet (String)
Any text after the snippet
Remarks
Eg. if the document contains "This is an an example piece." and Check will be called on "an example piece", then the fact that 'an' is duplicated will not be detected. Therefore, by passing "This is an " to beforeToCheckSnippet the checker will be able to detect that an is duplicated.


SetPosition Method (pos)

Keyoti RapidSpell Desktop .NET API Docs
SetPosition Method (pos)
API ► Keyoti.RapidSpell ► ICheckerEngine ► SetPosition(Int32)
Keyoti RapidSpell Desktop .NET
Sets the pointer position for the NextBadWord iterator.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void SetPosition(
    int pos
)
void SetPosition(
    int pos
)
Sub SetPosition (
    pos As Integer
)
Sub SetPosition (
    pos As Integer
)
void SetPosition(
    int pos
)
void SetPosition(
    int pos
)
abstract SetPosition :
        pos : int -> unit

abstract SetPosition :
        pos : int -> unit
Parameters
pos (Int32)
Remarks
Further calls to NextBadWord will look for the next bad word from position pos. If position > the text length it is set to the text length. If position < 0, it is set to zero.


SetSeparateHyphenWords Method (separate)

Keyoti RapidSpell Desktop .NET API Docs
SetSeparateHyphenWords Method (separate)
API ► Keyoti.RapidSpell ► ICheckerEngine ► SetSeparateHyphenWords(Boolean)
Keyoti RapidSpell Desktop .NET
Sets whether to separate words with hyphens in them into separate words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void SetSeparateHyphenWords(
    bool separate
)
void SetSeparateHyphenWords(
    bool separate
)
Sub SetSeparateHyphenWords (
    separate As Boolean
)
Sub SetSeparateHyphenWords (
    separate As Boolean
)
void SetSeparateHyphenWords(
    bool separate
)
void SetSeparateHyphenWords(
    bool separate
)
abstract SetSeparateHyphenWords :
        separate : bool -> unit

abstract SetSeparateHyphenWords :
        separate : bool -> unit
Parameters
separate (Boolean)


SetSuggestionsMethod Method (method)

Keyoti RapidSpell Desktop .NET API Docs
SetSuggestionsMethod Method (method)
API ► Keyoti.RapidSpell ► ICheckerEngine ► SetSuggestionsMethod(Int32)
Keyoti RapidSpell Desktop .NET
Sets the suggestions method, where method is an integer identifier.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void SetSuggestionsMethod(
    int method
)
void SetSuggestionsMethod(
    int method
)
Sub SetSuggestionsMethod (
    method As Integer
)
Sub SetSuggestionsMethod (
    method As Integer
)
void SetSuggestionsMethod(
    int method
)
void SetSuggestionsMethod(
    int method
)
abstract SetSuggestionsMethod :
        method : int -> unit

abstract SetSuggestionsMethod :
        method : int -> unit
Parameters
method (Int32)


SetUserDictionary Method

Keyoti RapidSpell Desktop .NET API Docs
SetUserDictionary Method
API ► Keyoti.RapidSpell ► ICheckerEngine ► SetUserDictionary()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | SetUserDictionary(UserDictionary) | Sets the UserDictionary object to be used as a user dictionary source.
 | SetUserDictionary(String) | Sets the UserDictionary file path to be used as a user dictionary source.


SetUserDictionary Method (userDictionary)

Keyoti RapidSpell Desktop .NET API Docs
SetUserDictionary Method (userDictionary)
API ► Keyoti.RapidSpell ► ICheckerEngine ► SetUserDictionary(UserDictionary)
Keyoti RapidSpell Desktop .NET
Sets the UserDictionary object to be used as a user dictionary source.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void SetUserDictionary(
    UserDictionary userDictionary
)
void SetUserDictionary(
    UserDictionary userDictionary
)
Sub SetUserDictionary (
    userDictionary As UserDictionary
)
Sub SetUserDictionary (
    userDictionary As UserDictionary
)
void SetUserDictionary(
    UserDictionary^ userDictionary
)
void SetUserDictionary(
    UserDictionary^ userDictionary
)
abstract SetUserDictionary :
        userDictionary : UserDictionary -> unit

abstract SetUserDictionary :
        userDictionary : UserDictionary -> unit
Parameters
userDictionary (UserDictionary)


SetUserDictionary Method (userDictionary)

Keyoti RapidSpell Desktop .NET API Docs
SetUserDictionary Method (userDictionary)
API ► Keyoti.RapidSpell ► ICheckerEngine ► SetUserDictionary(String)
Keyoti RapidSpell Desktop .NET
Sets the UserDictionary file path to be used as a user dictionary source.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void SetUserDictionary(
    string userDictionary
)
void SetUserDictionary(
    string userDictionary
)
Sub SetUserDictionary (
    userDictionary As String
)
Sub SetUserDictionary (
    userDictionary As String
)
void SetUserDictionary(
    String^ userDictionary
)
void SetUserDictionary(
    String^ userDictionary
)
abstract SetUserDictionary :
        userDictionary : string -> unit

abstract SetUserDictionary :
        userDictionary : string -> unit
Parameters
userDictionary (String)


SuggestSplitWords Property

Keyoti RapidSpell Desktop .NET API Docs
SuggestSplitWords Property
API ► Keyoti.RapidSpell ► ICheckerEngine ► SuggestSplitWords
Keyoti RapidSpell Desktop .NET
Whether to look for connected words in suggestions.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool SuggestSplitWords { get; set; }
bool SuggestSplitWords { get; set; }
Property SuggestSplitWords As Boolean
    Get
    Set
Property SuggestSplitWords As Boolean
    Get
    Set
property bool SuggestSplitWords {
    bool get ();
    void set (bool value);
}
property bool SuggestSplitWords {
    bool get ();
    void set (bool value);
}
abstract SuggestSplitWords : bool with get, set

abstract SuggestSplitWords : bool with get, set
Property Value
Boolean
Remarks
if this=true then suggestions may include joined words.

Eg; suggestions for "myhouse" will include "my house"


TextBoundary Property

Keyoti RapidSpell Desktop .NET API Docs
TextBoundary Property
API ► Keyoti.RapidSpell ► ICheckerEngine ► TextBoundary
Keyoti RapidSpell Desktop .NET
The AdvancedTextBoundary class to use to parse words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
AdvancedTextBoundary TextBoundary { get; set; }
AdvancedTextBoundary TextBoundary { get; set; }
Property TextBoundary As AdvancedTextBoundary
    Get
    Set
Property TextBoundary As AdvancedTextBoundary
    Get
    Set
property AdvancedTextBoundary^ TextBoundary {
    AdvancedTextBoundary^ get ();
    void set (AdvancedTextBoundary^ value);
}
property AdvancedTextBoundary^ TextBoundary {
    AdvancedTextBoundary^ get ();
    void set (AdvancedTextBoundary^ value);
}
abstract TextBoundary : AdvancedTextBoundary with get, set

abstract TextBoundary : AdvancedTextBoundary with get, set
Property Value
AdvancedTextBoundary


userDictionary Property

Keyoti RapidSpell Desktop .NET API Docs
userDictionary Property
API ► Keyoti.RapidSpell ► ICheckerEngine ► userDictionary
Keyoti RapidSpell Desktop .NET
The user dictionary, this should be null (C#) or nothing (VB.NET) if no user dictionary is being used.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
UserDictionary userDictionary { get; }
UserDictionary userDictionary { get; }
ReadOnly Property userDictionary As UserDictionary
    Get
ReadOnly Property userDictionary As UserDictionary
    Get
property UserDictionary^ userDictionary {
    UserDictionary^ get ();
}
property UserDictionary^ userDictionary {
    UserDictionary^ get ();
}
abstract userDictionary : UserDictionary with get

abstract userDictionary : UserDictionary with get
Property Value
UserDictionary


V2Parser Property

Keyoti RapidSpell Desktop .NET API Docs
V2Parser Property
API ► Keyoti.RapidSpell ► ICheckerEngine ► V2Parser
Keyoti RapidSpell Desktop .NET
Whether to use parser version 2 (specific to RapidSpellChecker).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool V2Parser { get; set; }
bool V2Parser { get; set; }
Property V2Parser As Boolean
    Get
    Set
Property V2Parser As Boolean
    Get
    Set
property bool V2Parser {
    bool get ();
    void set (bool value);
}
property bool V2Parser {
    bool get ();
    void set (bool value);
}
abstract V2Parser : bool with get, set

abstract V2Parser : bool with get, set
Property Value
Boolean


WarnDuplicates Property

Keyoti RapidSpell Desktop .NET API Docs
WarnDuplicates Property
API ► Keyoti.RapidSpell ► ICheckerEngine ► WarnDuplicates
Keyoti RapidSpell Desktop .NET
Whether to treat duplicate words as errors (eg. "this is is an error").
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool WarnDuplicates { get; set; }
bool WarnDuplicates { get; set; }
Property WarnDuplicates As Boolean
    Get
    Set
Property WarnDuplicates As Boolean
    Get
    Set
property bool WarnDuplicates {
    bool get ();
    void set (bool value);
}
property bool WarnDuplicates {
    bool get ();
    void set (bool value);
}
abstract WarnDuplicates : bool with get, set

abstract WarnDuplicates : bool with get, set
Property Value
Boolean


WordAdded Event

Keyoti RapidSpell Desktop .NET API Docs
WordAdded Event
API ► Keyoti.RapidSpell ► ICheckerEngine ► WordAdded
Keyoti RapidSpell Desktop .NET
Indicates a word has been added
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event WordAddedEventHandler WordAdded
event WordAddedEventHandler WordAdded
Event WordAdded As WordAddedEventHandler
Event WordAdded As WordAddedEventHandler
 event WordAddedEventHandler^ WordAdded {
    void add (WordAddedEventHandler^ value);
    void remove (WordAddedEventHandler^ value);
}
 event WordAddedEventHandler^ WordAdded {
    void add (WordAddedEventHandler^ value);
    void remove (WordAddedEventHandler^ value);
}
abstract WordAdded : IEvent<WordAddedEventHandler,
    WordAddedEventArgs>

abstract WordAdded : IEvent<WordAddedEventHandler,
    WordAddedEventArgs>
Value
WordAddedEventHandler


ISpellCheckableTextComponent Interface

Keyoti RapidSpell Desktop .NET API Docs
ISpellCheckableTextComponent Interface
API ► Keyoti.RapidSpell ► ISpellCheckableTextComponent
Keyoti RapidSpell Desktop .NET
Defines the interface required for a text component to be spell checkable using the RapidSpellDialog control (or RapidSpellGUI class)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public interface ISpellCheckableTextComponent
public interface ISpellCheckableTextComponent
Public Interface ISpellCheckableTextComponent
Public Interface ISpellCheckableTextComponent
public interface class ISpellCheckableTextComponent
public interface class ISpellCheckableTextComponent
type ISpellCheckableTextComponent =  interface end
type ISpellCheckableTextComponent =  interface end
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Dispose()()()() | Dispose of resources
 | Disposed | Occurs when the control is disposed of.
 | Enabled | Whether the textbox is enabled
 | GotFocus | Occurs when the control receives focus.
 | HideSelection | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus.
 | ReadOnly | Whether the textbox is readonly
 | ScrollToCaret()()()() | Scrolls the contents of the control to the current caret position.
 | SelectedText | Gets or sets a value indicating the currently selected text in the control.
 | SelectionLength | Gets or sets the number of characters selected in the text box.
 | SelectionStart | Gets or sets the starting point of text selected in the text box.
 | Text | Gets or sets the current text in the text box.
Remarks
This is typically used in conjunction with 3rd party text controls.


Dispose Method

Keyoti RapidSpell Desktop .NET API Docs
Dispose Method
API ► Keyoti.RapidSpell ► ISpellCheckableTextComponent ► Dispose()()()()
Keyoti RapidSpell Desktop .NET
Dispose of resources
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void Dispose()
void Dispose()
Sub Dispose
Sub Dispose
void Dispose()
void Dispose()
abstract Dispose : unit -> unit

abstract Dispose : unit -> unit


Disposed Event

Keyoti RapidSpell Desktop .NET API Docs
Disposed Event
API ► Keyoti.RapidSpell ► ISpellCheckableTextComponent ► Disposed
Keyoti RapidSpell Desktop .NET
Occurs when the control is disposed of.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event EventHandler Disposed
event EventHandler Disposed
Event Disposed As EventHandler
Event Disposed As EventHandler
 event EventHandler^ Disposed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
 event EventHandler^ Disposed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Disposed : IEvent<EventHandler,
    EventArgs>

abstract Disposed : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


Enabled Property

Keyoti RapidSpell Desktop .NET API Docs
Enabled Property
API ► Keyoti.RapidSpell ► ISpellCheckableTextComponent ► Enabled
Keyoti RapidSpell Desktop .NET
Whether the textbox is enabled
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool Enabled { get; }
bool Enabled { get; }
ReadOnly Property Enabled As Boolean
    Get
ReadOnly Property Enabled As Boolean
    Get
property bool Enabled {
    bool get ();
}
property bool Enabled {
    bool get ();
}
abstract Enabled : bool with get

abstract Enabled : bool with get
Property Value
Boolean
Remarks
If not supported, return true.


GotFocus Event

Keyoti RapidSpell Desktop .NET API Docs
GotFocus Event
API ► Keyoti.RapidSpell ► ISpellCheckableTextComponent ► GotFocus
Keyoti RapidSpell Desktop .NET
Occurs when the control receives focus.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event EventHandler GotFocus
event EventHandler GotFocus
Event GotFocus As EventHandler
Event GotFocus As EventHandler
 event EventHandler^ GotFocus {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
 event EventHandler^ GotFocus {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract GotFocus : IEvent<EventHandler,
    EventArgs>

abstract GotFocus : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


HideSelection Property

Keyoti RapidSpell Desktop .NET API Docs
HideSelection Property
API ► Keyoti.RapidSpell ► ISpellCheckableTextComponent ► HideSelection
Keyoti RapidSpell Desktop .NET
Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool HideSelection { get; set; }
bool HideSelection { get; set; }
Property HideSelection As Boolean
    Get
    Set
Property HideSelection As Boolean
    Get
    Set
property bool HideSelection {
    bool get ();
    void set (bool value);
}
property bool HideSelection {
    bool get ();
    void set (bool value);
}
abstract HideSelection : bool with get, set

abstract HideSelection : bool with get, set
Property Value
Boolean


ReadOnly Property

Keyoti RapidSpell Desktop .NET API Docs
ReadOnly Property
API ► Keyoti.RapidSpell ► ISpellCheckableTextComponent ► ReadOnly
Keyoti RapidSpell Desktop .NET
Whether the textbox is readonly
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool ReadOnly { get; }
bool ReadOnly { get; }
ReadOnly Property ReadOnly As Boolean
    Get
ReadOnly Property ReadOnly As Boolean
    Get
property bool ReadOnly {
    bool get ();
}
property bool ReadOnly {
    bool get ();
}
abstract ReadOnly : bool with get

abstract ReadOnly : bool with get
Property Value
Boolean
Remarks
If not supported, return false.


ScrollToCaret Method

Keyoti RapidSpell Desktop .NET API Docs
ScrollToCaret Method
API ► Keyoti.RapidSpell ► ISpellCheckableTextComponent ► ScrollToCaret()()()()
Keyoti RapidSpell Desktop .NET
Scrolls the contents of the control to the current caret position.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void ScrollToCaret()
void ScrollToCaret()
Sub ScrollToCaret
Sub ScrollToCaret
void ScrollToCaret()
void ScrollToCaret()
abstract ScrollToCaret : unit -> unit

abstract ScrollToCaret : unit -> unit


SelectedText Property

Keyoti RapidSpell Desktop .NET API Docs
SelectedText Property
API ► Keyoti.RapidSpell ► ISpellCheckableTextComponent ► SelectedText
Keyoti RapidSpell Desktop .NET
Gets or sets a value indicating the currently selected text in the control.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string SelectedText { get; set; }
string SelectedText { get; set; }
Property SelectedText As String
    Get
    Set
Property SelectedText As String
    Get
    Set
property String^ SelectedText {
    String^ get ();
    void set (String^ value);
}
property String^ SelectedText {
    String^ get ();
    void set (String^ value);
}
abstract SelectedText : string with get, set

abstract SelectedText : string with get, set
Property Value
String


SelectionLength Property

Keyoti RapidSpell Desktop .NET API Docs
SelectionLength Property
API ► Keyoti.RapidSpell ► ISpellCheckableTextComponent ► SelectionLength
Keyoti RapidSpell Desktop .NET
Gets or sets the number of characters selected in the text box.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
int SelectionLength { get; set; }
int SelectionLength { get; set; }
Property SelectionLength As Integer
    Get
    Set
Property SelectionLength As Integer
    Get
    Set
property int SelectionLength {
    int get ();
    void set (int value);
}
property int SelectionLength {
    int get ();
    void set (int value);
}
abstract SelectionLength : int with get, set

abstract SelectionLength : int with get, set
Property Value
Int32


SelectionStart Property

Keyoti RapidSpell Desktop .NET API Docs
SelectionStart Property
API ► Keyoti.RapidSpell ► ISpellCheckableTextComponent ► SelectionStart
Keyoti RapidSpell Desktop .NET
Gets or sets the starting point of text selected in the text box.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
int SelectionStart { get; set; }
int SelectionStart { get; set; }
Property SelectionStart As Integer
    Get
    Set
Property SelectionStart As Integer
    Get
    Set
property int SelectionStart {
    int get ();
    void set (int value);
}
property int SelectionStart {
    int get ();
    void set (int value);
}
abstract SelectionStart : int with get, set

abstract SelectionStart : int with get, set
Property Value
Int32


Text Property

Keyoti RapidSpell Desktop .NET API Docs
Text Property
API ► Keyoti.RapidSpell ► ISpellCheckableTextComponent ► Text
Keyoti RapidSpell Desktop .NET
Gets or sets the current text in the text box.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string Text { get; set; }
string Text { get; set; }
Property Text As String
    Get
    Set
Property Text As String
    Get
    Set
property String^ Text {
    String^ get ();
    void set (String^ value);
}
property String^ Text {
    String^ get ();
    void set (String^ value);
}
abstract Text : string with get, set

abstract Text : string with get, set
Property Value
String


ISpellCheckableTextComponent2 Interface

Keyoti RapidSpell Desktop .NET API Docs
ISpellCheckableTextComponent2 Interface
API ► Keyoti.RapidSpell ► ISpellCheckableTextComponent2
Keyoti RapidSpell Desktop .NET
Defines the interface required for a text component to be spell checkable using the RapidSpellDialog control (or RapidSpellGUI class)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public interface ISpellCheckableTextComponent2 : ISpellCheckableTextComponent
public interface ISpellCheckableTextComponent2 : ISpellCheckableTextComponent
Public Interface ISpellCheckableTextComponent2
    Inherits ISpellCheckableTextComponent
Public Interface ISpellCheckableTextComponent2
    Inherits ISpellCheckableTextComponent
public interface class ISpellCheckableTextComponent2 : ISpellCheckableTextComponent
public interface class ISpellCheckableTextComponent2 : ISpellCheckableTextComponent
type ISpellCheckableTextComponent2 =
    interface
        interface ISpellCheckableTextComponent
    end
type ISpellCheckableTextComponent2 =
    interface
        interface ISpellCheckableTextComponent
    end
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CaretPosition | The caret or selection start position
 | Dispose()()()() | Dispose of resources (Inherited from ISpellCheckableTextComponent.)
 | Disposed | Occurs when the control is disposed of. (Inherited from ISpellCheckableTextComponent.)
 | Enabled | Whether the textbox is enabled (Inherited from ISpellCheckableTextComponent.)
 | GotFocus | Occurs when the control receives focus. (Inherited from ISpellCheckableTextComponent.)
 | HideSelection | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus. (Inherited from ISpellCheckableTextComponent.)
 | ReadOnly | Whether the textbox is readonly (Inherited from ISpellCheckableTextComponent.)
 | ScrollToCaret()()()() | Scrolls the contents of the control to the current caret position. (Inherited from ISpellCheckableTextComponent.)
 | Select(Int32, Int32) | Make a selection
 | SelectedText | Gets or sets a value indicating the currently selected text in the control. (Inherited from ISpellCheckableTextComponent.)
 | SelectionEnd | Gets or sets the starting point of text selected in the text box.
 | SelectionLength | Gets or sets the number of characters selected in the text box. (Inherited from ISpellCheckableTextComponent.)
 | SelectionStart | Gets or sets the starting point of text selected in the text box. (Inherited from ISpellCheckableTextComponent.)
 | Text | Gets or sets the current text in the text box. (Inherited from ISpellCheckableTextComponent.)
Remarks
This is typically used in conjunction with 3rd party text controls.


CaretPosition Property

Keyoti RapidSpell Desktop .NET API Docs
CaretPosition Property
API ► Keyoti.RapidSpell ► ISpellCheckableTextComponent2 ► CaretPosition
Keyoti RapidSpell Desktop .NET
The caret or selection start position
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
int CaretPosition { get; set; }
int CaretPosition { get; set; }
Property CaretPosition As Integer
    Get
    Set
Property CaretPosition As Integer
    Get
    Set
property int CaretPosition {
    int get ();
    void set (int value);
}
property int CaretPosition {
    int get ();
    void set (int value);
}
abstract CaretPosition : int with get, set

abstract CaretPosition : int with get, set
Property Value
Int32


Select Method (from, to)

Keyoti RapidSpell Desktop .NET API Docs
Select Method (from, to)
API ► Keyoti.RapidSpell ► ISpellCheckableTextComponent2 ► Select(Int32, Int32)
Keyoti RapidSpell Desktop .NET
Make a selection
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void Select(
    int from,
    int to
)
void Select(
    int from,
    int to
)
Sub Select (
    from As Integer,
    to As Integer
)
Sub Select (
    from As Integer,
    to As Integer
)
void Select(
    int from,
    int to
)
void Select(
    int from,
    int to
)
abstract Select :
        from : int *
        to : int -> unit

abstract Select :
        from : int *
        to : int -> unit
Parameters
from (Int32)
to (Int32)


SelectionEnd Property

Keyoti RapidSpell Desktop .NET API Docs
SelectionEnd Property
API ► Keyoti.RapidSpell ► ISpellCheckableTextComponent2 ► SelectionEnd
Keyoti RapidSpell Desktop .NET
Gets or sets the starting point of text selected in the text box.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
int SelectionEnd { get; }
int SelectionEnd { get; }
ReadOnly Property SelectionEnd As Integer
    Get
ReadOnly Property SelectionEnd As Integer
    Get
property int SelectionEnd {
    int get ();
}
property int SelectionEnd {
    int get ();
}
abstract SelectionEnd : int with get

abstract SelectionEnd : int with get
Property Value
Int32


IUserInterfaceFormPresenter Interface

Keyoti RapidSpell Desktop .NET API Docs
IUserInterfaceFormPresenter Interface
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter
Keyoti RapidSpell Desktop .NET
Interface requirements for a dialog based UI form.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public interface IUserInterfaceFormPresenter : IDialogViewEventHandler
public interface IUserInterfaceFormPresenter : IDialogViewEventHandler
Public Interface IUserInterfaceFormPresenter
    Inherits IDialogViewEventHandler
Public Interface IUserInterfaceFormPresenter
    Inherits IDialogViewEventHandler
public interface class IUserInterfaceFormPresenter : IDialogViewEventHandler
public interface class IUserInterfaceFormPresenter : IDialogViewEventHandler
type IUserInterfaceFormPresenter =
    interface
        interface IDialogViewEventHandler
    end
type IUserInterfaceFormPresenter =
    interface
        interface IDialogViewEventHandler
    end
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddButtonText | Add button text.
 | AllOperationScope | The scope that ignore-all/change-all should have.
 | CancelButtonText | Cancel button text.
 | Cancelled | Whether the spell check has been cancelled.
 | ChangeAllButtonText | Change All button text.
 | ChangeButtonText | Change button text.
 | Check()()()() | Bring up the spell checker Form and start checking the component set by SetTextComponentToCheck.
 | Check(TextBoxBase) | Bring up the spell checker Form and start checking the TextBoxBase textComponent.
 | Check(ISpellCheckableTextComponent) | Bring up the spell checker Form and start checking the TextBoxBase textComponent.
 | CheckCompletePopUpText | Check complete pop up text
 | CheckCompletePopUpTitle | Check complete pop up title
 | CheckCompoundWords | Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
 | CheckerEngine | The checker engine to use, this object must implement the ICheckerEngine interface, allows customization or replacement of the spell checker.
 | CheckFromStartOfText | Whether to check from the start of the text (true) or whereever the cursor is (false)
 | CheckingSpellingText | Checking spelling text
 | ConsiderationRange | The factor for words to consider for suggestions, lower values are faster but consider less words for suggestions. Default is 80. If w <= 1 this method won't do anything.
 | CreateDialogView | Indicates that a new IDialogView is being created, also provides chance to override the default IDialogView.
 | CreateDialogViewOptions | Indicates that a new IDialogViewOptions is being created, also provides chance to override the default IDialogViewOptions.
 | CreateDialogViewUserDictionaryEdit | Indicates that a new IDialogViewUserDictionaryEdit is being created, also provides chance to override the default IDialogViewUserDictionaryEdit.
 | CreateDialogViewUserDictionarySelect | Indicates that a new IDialogViewUserDictionarySelect is being created, also provides chance to override the default IDialogViewUserDictionarySelect.
 | DialogTitleText | Dialog title text
 | DialogView | The IDialogView to use
 | DialogView_AddButtonClick(Object, EventArgs) | The add button was clicked (Inherited from IDialogViewEventHandler.)
 | DialogView_CancelButtonClick(Object, EventArgs) | The cancel button was clicked (Inherited from IDialogViewEventHandler.)
 | DialogView_ChangeAllButtonClick(Object, EventArgs) | The change-all button was clicked (Inherited from IDialogViewEventHandler.)
 | DialogView_ChangeButtonClick(Object, EventArgs) | The change button was clicked (Inherited from IDialogViewEventHandler.)
 | DialogView_Closing(Object, CancelEventArgs) | The view is closing (Inherited from IDialogViewEventHandler.)
 | DialogView_IgnoreAllButtonClick(Object, EventArgs) | The ignore all button was clicked (Inherited from IDialogViewEventHandler.)
 | DialogView_IgnoreButtonClick(Object, EventArgs) | The ignore button was clicked (Inherited from IDialogViewEventHandler.)
 | DialogView_Load(Object, EventArgs) | The view has loaded (Inherited from IDialogViewEventHandler.)
 | DialogView_OptionsButtonClick(Object, EventArgs) | The options button was clicked (Inherited from IDialogViewEventHandler.)
 | DialogView_QueryTextBoxEnter(Object, EventArgs) | Query textbox has been entered (Inherited from IDialogViewEventHandler.)
 | DialogView_QueryTextBoxTextChanged(Object, EventArgs) | The text in the query textbox changed (Inherited from IDialogViewEventHandler.)
 | DialogView_SuggestionsListDoubleClick(Object, EventArgs) | The user double clicked on a suggested item. Not mandatory to implement. (Inherited from IDialogViewEventHandler.)
 | DialogView_UndoButtonClick(Object, EventArgs) | The undo button was clicked (Inherited from IDialogViewEventHandler.)
 | DialogView_UserNeedsSuggestionsChanged(Object, EventArgs) | User has checked the "Find Suggestions" checkbox (if it exists). (Inherited from IDialogViewEventHandler.)
 | DictFilePath | Optional file path to the main dictionary .dict file to use.
 | Dispose()()()() | Dispose of resources
 | DisposeAtEnd | Whether to dispose of this form when spell check is finished.
 | FindCapitalizedSuggestions | Whether to look for capitalized suggestions, note this will slow FindSuggestions down by about 7 times.
 | FindingSuggestionsLabelText | Finding suggestions label text.
 | FindSuggestionsLabelText | Find suggestions label text.
 | FinishedCheckingSelectionPopUpText | Finished checking selection dialog text
 | FinishedCheckingSelectionPopUpTitle | Finished checking selection dialog title
 | GetIncludeUserDictionaryInSuggestions()()()() | Gets whether the user dictionary should be used in finding suggestions for misspelt words.
 | GetSeparateHyphenWords()()()() | Gets whether to treat hyphenated (-) words as separate words, default is false.
 | GUILanguage | The language to show the UI in.
 | IgnoreAllButtonText | Ignore All button text.
 | IgnoreButtonText | Ignore button text.
 | IgnoreCapitalizedWords | Sets whether to ignore words with capital letters.
 | IgnoreIncorrectSentenceCapitalization | Whether to ignore incorrect sentence capitalization.
 | IgnoreInEnglishLowerCaseI | Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
 | IgnoreWordsWithDigits | Whether to ignore words with numbers in them (eg. A10 or 7-11).
 | IgnoreXML | Whether to ignore XML/HTML tags, false by default.
 | InDictionaryLabelText | In dictionary label text
 | IsDialogViewCreated()()()() | Whether a dialog view has already been created.
 | IsShowFinishedMessageBox()()()() | Returns whether a message box should be opened when the spell check is complete.
 | LanguageParser | The type of language parsing to use.
 | Load | Fired when the DialogView loads.
 | LookIntoHyphenatedText | Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
 | MaximumContextualWords | The maximum number of words to show the user in the sentence around misspelled words.
 | ModalAutoDispose | When running modally, determines if the dialog will be disposed of when spell check finishes.
 | ModalMode | Whether the spell checker will run modally. (Modal operation blocks the parent form)
 | ModalOwner | The owner window when used modally.
 | NoSuggestionsText | No suggestions found text
 | NotInDictionaryLabelText | Not in dictionary label text
 | NumberSuggestionList | Whether to number the items in the suggestion list, for quick user selection.
 | Options | Object responsible for holding, loading and saving the user's spell check options.
 | OptionsButtonText | Options button text
 | OptionsPresenter | Presenter for the user options form (IDialogViewOptions).
 | Ready | Fired when ready to proceed with first query.
 | RecheckDocumentRequest | Fired when the text should be rechecked
 | Remove()()()() | Safely frees up resources.
 | RemoveDuplicateWordText | Remove duplicate word text
 | ResumeButtonText | Resume button text
 | SetIgnoreOnceBadWords(ArrayList) | Provide a list of BadWord objects that have been ignored
 | SetIncludeUserDictionaryInSuggestions(Boolean) | Sets whether the user dictionary should be used in finding suggestions for misspelt words.
 | SetSeparateHyphenWords(Boolean) | Sets whether to treat hyphenated (-) words as separate words, default is false.
 | SetShowFinishedMessageBox(Boolean) | Sets whether a message box should be opened when the spell check is complete.
 | SetTextComponentToCheck(TextBoxBase) | Set the TextBoxBase (eg; TextBox etc) that this GUI will spell check.
 | SetTextComponentToCheck(ISpellCheckableTextComponent) | Sets the ISpellCheckableTextComponent that this GUI will spell check.
 | SetUserDictionary(UserDictionary) | Set the user dictionary object.
 | SetUserDictionaryFile(String) | Set the user dictionary file, if this file doesn't exist it will be created.
 | ShowContextSentence | Whether to show the query in context of it's sentence/line.
 | SpellCheckFinished | Fired when checking finishes
 | SpellCheckStarted | Fired when checking starts
 | SuggestionsLabelText | Suggestions label text
 | SuggestionsMethod | Sets the suggestions method to use. Either PHONETIC_SUGGESTIONS or HASHING_SUGGESTIONS
 | SuggestSplitWords | Whether to look for connected words in suggestions.
 | UndoButtonText | Undo button text
 | Undone | Fired when an Undo occurs
 | UserQuery | Indicates that the user is being queried on a spelling error.
 | WarnDuplicates | Whether to show duplicate words as errors (eg. "this is is an error").
 | WordAdded | Fired when word added to user dictionary
 | WordChanged | Fired when word changed
 | WordChanging | Fired before a word is changed
 | WordIgnored | Fired when word ignored
Remarks
Implement this interface in custom UI objects that you wish to plug-in to RapidSpellDialog.

Note: Sub-classes of RapidSpellGUI implement this interface by inheritance (automatically).


AddButtonText Property

Keyoti RapidSpell Desktop .NET API Docs
AddButtonText Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► AddButtonText
Keyoti RapidSpell Desktop .NET
Add button text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string AddButtonText { get; set; }
string AddButtonText { get; set; }
Property AddButtonText As String
    Get
    Set
Property AddButtonText As String
    Get
    Set
property String^ AddButtonText {
    String^ get ();
    void set (String^ value);
}
property String^ AddButtonText {
    String^ get ();
    void set (String^ value);
}
abstract AddButtonText : string with get, set

abstract AddButtonText : string with get, set
Property Value
String


AllOperationScope Property

Keyoti RapidSpell Desktop .NET API Docs
AllOperationScope Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► AllOperationScope
Keyoti RapidSpell Desktop .NET
The scope that ignore-all/change-all should have.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
OperationScope AllOperationScope { get; set; }
OperationScope AllOperationScope { get; set; }
Property AllOperationScope As OperationScope
    Get
    Set
Property AllOperationScope As OperationScope
    Get
    Set
property OperationScope AllOperationScope {
    OperationScope get ();
    void set (OperationScope value);
}
property OperationScope AllOperationScope {
    OperationScope get ();
    void set (OperationScope value);
}
abstract AllOperationScope : OperationScope with get, set

abstract AllOperationScope : OperationScope with get, set
Property Value
OperationScope


CancelButtonText Property

Keyoti RapidSpell Desktop .NET API Docs
CancelButtonText Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► CancelButtonText
Keyoti RapidSpell Desktop .NET
Cancel button text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string CancelButtonText { get; set; }
string CancelButtonText { get; set; }
Property CancelButtonText As String
    Get
    Set
Property CancelButtonText As String
    Get
    Set
property String^ CancelButtonText {
    String^ get ();
    void set (String^ value);
}
property String^ CancelButtonText {
    String^ get ();
    void set (String^ value);
}
abstract CancelButtonText : string with get, set

abstract CancelButtonText : string with get, set
Property Value
String


Cancelled Property

Keyoti RapidSpell Desktop .NET API Docs
Cancelled Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► Cancelled
Keyoti RapidSpell Desktop .NET
Whether the spell check has been cancelled.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool Cancelled { get; }
bool Cancelled { get; }
ReadOnly Property Cancelled As Boolean
    Get
ReadOnly Property Cancelled As Boolean
    Get
property bool Cancelled {
    bool get ();
}
property bool Cancelled {
    bool get ();
}
abstract Cancelled : bool with get

abstract Cancelled : bool with get
Property Value
Boolean


ChangeAllButtonText Property

Keyoti RapidSpell Desktop .NET API Docs
ChangeAllButtonText Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► ChangeAllButtonText
Keyoti RapidSpell Desktop .NET
Change All button text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string ChangeAllButtonText { get; set; }
string ChangeAllButtonText { get; set; }
Property ChangeAllButtonText As String
    Get
    Set
Property ChangeAllButtonText As String
    Get
    Set
property String^ ChangeAllButtonText {
    String^ get ();
    void set (String^ value);
}
property String^ ChangeAllButtonText {
    String^ get ();
    void set (String^ value);
}
abstract ChangeAllButtonText : string with get, set

abstract ChangeAllButtonText : string with get, set
Property Value
String


ChangeButtonText Property

Keyoti RapidSpell Desktop .NET API Docs
ChangeButtonText Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► ChangeButtonText
Keyoti RapidSpell Desktop .NET
Change button text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string ChangeButtonText { get; set; }
string ChangeButtonText { get; set; }
Property ChangeButtonText As String
    Get
    Set
Property ChangeButtonText As String
    Get
    Set
property String^ ChangeButtonText {
    String^ get ();
    void set (String^ value);
}
property String^ ChangeButtonText {
    String^ get ();
    void set (String^ value);
}
abstract ChangeButtonText : string with get, set

abstract ChangeButtonText : string with get, set
Property Value
String


Check Method

Keyoti RapidSpell Desktop .NET API Docs
Check Method
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► Check()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Check()()()() | Bring up the spell checker Form and start checking the component set by SetTextComponentToCheck.
 | Check(TextBoxBase) | Bring up the spell checker Form and start checking the TextBoxBase textComponent.
 | Check(ISpellCheckableTextComponent) | Bring up the spell checker Form and start checking the TextBoxBase textComponent.


Check Method

Keyoti RapidSpell Desktop .NET API Docs
Check Method
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► Check()()()()
Keyoti RapidSpell Desktop .NET
Bring up the spell checker Form and start checking the component set by SetTextComponentToCheck.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void Check()
void Check()
Sub Check
Sub Check
void Check()
void Check()
abstract Check : unit -> unit

abstract Check : unit -> unit
Exceptions
Exception | Condition
NoTextComponentException | if SetTextComponentToCheck hasn't be called first with a TextBoxBase object.


Check Method (textComponent)

Keyoti RapidSpell Desktop .NET API Docs
Check Method (textComponent)
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► Check(ISpellCheckableTextComponent)
Keyoti RapidSpell Desktop .NET
Bring up the spell checker Form and start checking the TextBoxBase textComponent.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void Check(
    ISpellCheckableTextComponent textComponent
)
void Check(
    ISpellCheckableTextComponent textComponent
)
Sub Check (
    textComponent As ISpellCheckableTextComponent
)
Sub Check (
    textComponent As ISpellCheckableTextComponent
)
void Check(
    ISpellCheckableTextComponent^ textComponent
)
void Check(
    ISpellCheckableTextComponent^ textComponent
)
abstract Check :
        textComponent : ISpellCheckableTextComponent -> unit

abstract Check :
        textComponent : ISpellCheckableTextComponent -> unit
Parameters
textComponent (ISpellCheckableTextComponent)
Exceptions
Exception | Condition
ArgumentNullException | if textComponent parameter is null.


Check Method (textComponent)

Keyoti RapidSpell Desktop .NET API Docs
Check Method (textComponent)
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► Check(TextBoxBase)
Keyoti RapidSpell Desktop .NET
Bring up the spell checker Form and start checking the TextBoxBase textComponent.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void Check(
    TextBoxBase textComponent
)
void Check(
    TextBoxBase textComponent
)
Sub Check (
    textComponent As TextBoxBase
)
Sub Check (
    textComponent As TextBoxBase
)
void Check(
    TextBoxBase^ textComponent
)
void Check(
    TextBoxBase^ textComponent
)
abstract Check :
        textComponent : TextBoxBase -> unit

abstract Check :
        textComponent : TextBoxBase -> unit
Parameters
textComponent (TextBoxBase)
Exceptions
Exception | Condition
ArgumentNullException | if textComponent parameter is null.


CheckCompletePopUpText Property

Keyoti RapidSpell Desktop .NET API Docs
CheckCompletePopUpText Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► CheckCompletePopUpText
Keyoti RapidSpell Desktop .NET
Check complete pop up text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string CheckCompletePopUpText { get; set; }
string CheckCompletePopUpText { get; set; }
Property CheckCompletePopUpText As String
    Get
    Set
Property CheckCompletePopUpText As String
    Get
    Set
property String^ CheckCompletePopUpText {
    String^ get ();
    void set (String^ value);
}
property String^ CheckCompletePopUpText {
    String^ get ();
    void set (String^ value);
}
abstract CheckCompletePopUpText : string with get, set

abstract CheckCompletePopUpText : string with get, set
Property Value
String


CheckCompletePopUpTitle Property

Keyoti RapidSpell Desktop .NET API Docs
CheckCompletePopUpTitle Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► CheckCompletePopUpTitle
Keyoti RapidSpell Desktop .NET
Check complete pop up title
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string CheckCompletePopUpTitle { get; set; }
string CheckCompletePopUpTitle { get; set; }
Property CheckCompletePopUpTitle As String
    Get
    Set
Property CheckCompletePopUpTitle As String
    Get
    Set
property String^ CheckCompletePopUpTitle {
    String^ get ();
    void set (String^ value);
}
property String^ CheckCompletePopUpTitle {
    String^ get ();
    void set (String^ value);
}
abstract CheckCompletePopUpTitle : string with get, set

abstract CheckCompletePopUpTitle : string with get, set
Property Value
String


CheckCompoundWords Property

Keyoti RapidSpell Desktop .NET API Docs
CheckCompoundWords Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► CheckCompoundWords
Keyoti RapidSpell Desktop .NET
Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool CheckCompoundWords { get; set; }
bool CheckCompoundWords { get; set; }
Property CheckCompoundWords As Boolean
    Get
    Set
Property CheckCompoundWords As Boolean
    Get
    Set
property bool CheckCompoundWords {
    bool get ();
    void set (bool value);
}
property bool CheckCompoundWords {
    bool get ();
    void set (bool value);
}
abstract CheckCompoundWords : bool with get, set

abstract CheckCompoundWords : bool with get, set
Property Value
Boolean
Remarks
If this=false then LookUp("thesewordsarejoined") = false

If this=true then LookUp("thesewordsarejoined") = true

If this=false then LookUp("abcdef") = false

If this=true then LookUp("abcdef") = false

Setting this to true will degrade lookup performance


CheckerEngine Property

Keyoti RapidSpell Desktop .NET API Docs
CheckerEngine Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► CheckerEngine
Keyoti RapidSpell Desktop .NET
The checker engine to use, this object must implement the ICheckerEngine interface, allows customization or replacement of the spell checker.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
ICheckerEngine CheckerEngine { get; set; }
ICheckerEngine CheckerEngine { get; set; }
Property CheckerEngine As ICheckerEngine
    Get
    Set
Property CheckerEngine As ICheckerEngine
    Get
    Set
property ICheckerEngine^ CheckerEngine {
    ICheckerEngine^ get ();
    void set (ICheckerEngine^ value);
}
property ICheckerEngine^ CheckerEngine {
    ICheckerEngine^ get ();
    void set (ICheckerEngine^ value);
}
abstract CheckerEngine : ICheckerEngine with get, set

abstract CheckerEngine : ICheckerEngine with get, set
Property Value
ICheckerEngine
Remarks
Use this property to replace the object used to perform checking, it is not necessary to replace this with a spell checker, any type of word parser can be used. For example an abbreviations checker could be written to replace common words with abbreviations. Caveat: Most properties in RapidSpellGUI are mirrors of properties in ICheckerEngine, setting a CheckerEngine AFTER setting properties in RapidSpellGUI will overwrite those property values with the values of CheckerEngine.


CheckFromStartOfText Property

Keyoti RapidSpell Desktop .NET API Docs
CheckFromStartOfText Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► CheckFromStartOfText
Keyoti RapidSpell Desktop .NET
Whether to check from the start of the text (true) or whereever the cursor is (false)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool CheckFromStartOfText { get; set; }
bool CheckFromStartOfText { get; set; }
Property CheckFromStartOfText As Boolean
    Get
    Set
Property CheckFromStartOfText As Boolean
    Get
    Set
property bool CheckFromStartOfText {
    bool get ();
    void set (bool value);
}
property bool CheckFromStartOfText {
    bool get ();
    void set (bool value);
}
abstract CheckFromStartOfText : bool with get, set

abstract CheckFromStartOfText : bool with get, set
Property Value
Boolean


CheckingSpellingText Property

Keyoti RapidSpell Desktop .NET API Docs
CheckingSpellingText Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► CheckingSpellingText
Keyoti RapidSpell Desktop .NET
Checking spelling text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string CheckingSpellingText { get; set; }
string CheckingSpellingText { get; set; }
Property CheckingSpellingText As String
    Get
    Set
Property CheckingSpellingText As String
    Get
    Set
property String^ CheckingSpellingText {
    String^ get ();
    void set (String^ value);
}
property String^ CheckingSpellingText {
    String^ get ();
    void set (String^ value);
}
abstract CheckingSpellingText : string with get, set

abstract CheckingSpellingText : string with get, set
Property Value
String


ConsiderationRange Property

Keyoti RapidSpell Desktop .NET API Docs
ConsiderationRange Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► ConsiderationRange
Keyoti RapidSpell Desktop .NET
The factor for words to consider for suggestions, lower values are faster but consider less words for suggestions. Default is 80. If w <= 1 this method won't do anything.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
int ConsiderationRange { get; set; }
int ConsiderationRange { get; set; }
Property ConsiderationRange As Integer
    Get
    Set
Property ConsiderationRange As Integer
    Get
    Set
property int ConsiderationRange {
    int get ();
    void set (int value);
}
property int ConsiderationRange {
    int get ();
    void set (int value);
}
abstract ConsiderationRange : int with get, set

abstract ConsiderationRange : int with get, set
Property Value
Int32


CreateDialogView Event

Keyoti RapidSpell Desktop .NET API Docs
CreateDialogView Event
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► CreateDialogView
Keyoti RapidSpell Desktop .NET
Indicates that a new IDialogView is being created, also provides chance to override the default IDialogView.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event CreateDialogViewEventHandler CreateDialogView
event CreateDialogViewEventHandler CreateDialogView
Event CreateDialogView As CreateDialogViewEventHandler
Event CreateDialogView As CreateDialogViewEventHandler
 event CreateDialogViewEventHandler^ CreateDialogView {
    void add (CreateDialogViewEventHandler^ value);
    void remove (CreateDialogViewEventHandler^ value);
}
 event CreateDialogViewEventHandler^ CreateDialogView {
    void add (CreateDialogViewEventHandler^ value);
    void remove (CreateDialogViewEventHandler^ value);
}
abstract CreateDialogView : IEvent<CreateDialogViewEventHandler,
    CreateDialogViewEventArgs>

abstract CreateDialogView : IEvent<CreateDialogViewEventHandler,
    CreateDialogViewEventArgs>
Value
CreateDialogViewEventHandler


CreateDialogViewOptions Event

Keyoti RapidSpell Desktop .NET API Docs
CreateDialogViewOptions Event
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► CreateDialogViewOptions
Keyoti RapidSpell Desktop .NET
Indicates that a new IDialogViewOptions is being created, also provides chance to override the default IDialogViewOptions.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event CreateDialogViewOptionsEventHandler CreateDialogViewOptions
event CreateDialogViewOptionsEventHandler CreateDialogViewOptions
Event CreateDialogViewOptions As CreateDialogViewOptionsEventHandler
Event CreateDialogViewOptions As CreateDialogViewOptionsEventHandler
 event CreateDialogViewOptionsEventHandler^ CreateDialogViewOptions {
    void add (CreateDialogViewOptionsEventHandler^ value);
    void remove (CreateDialogViewOptionsEventHandler^ value);
}
 event CreateDialogViewOptionsEventHandler^ CreateDialogViewOptions {
    void add (CreateDialogViewOptionsEventHandler^ value);
    void remove (CreateDialogViewOptionsEventHandler^ value);
}
abstract CreateDialogViewOptions : IEvent<CreateDialogViewOptionsEventHandler,
    CreateDialogViewOptionsEventArgs>

abstract CreateDialogViewOptions : IEvent<CreateDialogViewOptionsEventHandler,
    CreateDialogViewOptionsEventArgs>
Value
CreateDialogViewOptionsEventHandler


CreateDialogViewUserDictionaryEdit Event

Keyoti RapidSpell Desktop .NET API Docs
CreateDialogViewUserDictionaryEdit Event
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► CreateDialogViewUserDictionaryEdit
Keyoti RapidSpell Desktop .NET
Indicates that a new IDialogViewUserDictionaryEdit is being created, also provides chance to override the default IDialogViewUserDictionaryEdit.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event CreateDialogViewUserDictionaryEditEventHandler CreateDialogViewUserDictionaryEdit
event CreateDialogViewUserDictionaryEditEventHandler CreateDialogViewUserDictionaryEdit
Event CreateDialogViewUserDictionaryEdit As CreateDialogViewUserDictionaryEditEventHandler
Event CreateDialogViewUserDictionaryEdit As CreateDialogViewUserDictionaryEditEventHandler
 event CreateDialogViewUserDictionaryEditEventHandler^ CreateDialogViewUserDictionaryEdit {
    void add (CreateDialogViewUserDictionaryEditEventHandler^ value);
    void remove (CreateDialogViewUserDictionaryEditEventHandler^ value);
}
 event CreateDialogViewUserDictionaryEditEventHandler^ CreateDialogViewUserDictionaryEdit {
    void add (CreateDialogViewUserDictionaryEditEventHandler^ value);
    void remove (CreateDialogViewUserDictionaryEditEventHandler^ value);
}
abstract CreateDialogViewUserDictionaryEdit : IEvent<CreateDialogViewUserDictionaryEditEventHandler,
    CreateDialogViewUserDictionaryEditEventArgs>

abstract CreateDialogViewUserDictionaryEdit : IEvent<CreateDialogViewUserDictionaryEditEventHandler,
    CreateDialogViewUserDictionaryEditEventArgs>
Value
CreateDialogViewUserDictionaryEditEventHandler


CreateDialogViewUserDictionarySelect Event

Keyoti RapidSpell Desktop .NET API Docs
CreateDialogViewUserDictionarySelect Event
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► CreateDialogViewUserDictionarySelect
Keyoti RapidSpell Desktop .NET
Indicates that a new IDialogViewUserDictionarySelect is being created, also provides chance to override the default IDialogViewUserDictionarySelect.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event CreateDialogViewUserDictionarySelectEventHandler CreateDialogViewUserDictionarySelect
event CreateDialogViewUserDictionarySelectEventHandler CreateDialogViewUserDictionarySelect
Event CreateDialogViewUserDictionarySelect As CreateDialogViewUserDictionarySelectEventHandler
Event CreateDialogViewUserDictionarySelect As CreateDialogViewUserDictionarySelectEventHandler
 event CreateDialogViewUserDictionarySelectEventHandler^ CreateDialogViewUserDictionarySelect {
    void add (CreateDialogViewUserDictionarySelectEventHandler^ value);
    void remove (CreateDialogViewUserDictionarySelectEventHandler^ value);
}
 event CreateDialogViewUserDictionarySelectEventHandler^ CreateDialogViewUserDictionarySelect {
    void add (CreateDialogViewUserDictionarySelectEventHandler^ value);
    void remove (CreateDialogViewUserDictionarySelectEventHandler^ value);
}
abstract CreateDialogViewUserDictionarySelect : IEvent<CreateDialogViewUserDictionarySelectEventHandler,
    CreateDialogViewUserDictionarySelectEventArgs>

abstract CreateDialogViewUserDictionarySelect : IEvent<CreateDialogViewUserDictionarySelectEventHandler,
    CreateDialogViewUserDictionarySelectEventArgs>
Value
CreateDialogViewUserDictionarySelectEventHandler


DialogTitleText Property

Keyoti RapidSpell Desktop .NET API Docs
DialogTitleText Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► DialogTitleText
Keyoti RapidSpell Desktop .NET
Dialog title text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string DialogTitleText { get; set; }
string DialogTitleText { get; set; }
Property DialogTitleText As String
    Get
    Set
Property DialogTitleText As String
    Get
    Set
property String^ DialogTitleText {
    String^ get ();
    void set (String^ value);
}
property String^ DialogTitleText {
    String^ get ();
    void set (String^ value);
}
abstract DialogTitleText : string with get, set

abstract DialogTitleText : string with get, set
Property Value
String


DialogView Property

Keyoti RapidSpell Desktop .NET API Docs
DialogView Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► DialogView
Keyoti RapidSpell Desktop .NET
The IDialogView to use
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
IDialogView DialogView { get; set; }
IDialogView DialogView { get; set; }
Property DialogView As IDialogView
    Get
    Set
Property DialogView As IDialogView
    Get
    Set
property IDialogView^ DialogView {
    IDialogView^ get ();
    void set (IDialogView^ value);
}
property IDialogView^ DialogView {
    IDialogView^ get ();
    void set (IDialogView^ value);
}
abstract DialogView : IDialogView with get, set

abstract DialogView : IDialogView with get, set
Property Value
IDialogView


DictFilePath Property

Keyoti RapidSpell Desktop .NET API Docs
DictFilePath Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► DictFilePath
Keyoti RapidSpell Desktop .NET
Optional file path to the main dictionary .dict file to use.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string DictFilePath { get; set; }
string DictFilePath { get; set; }
Property DictFilePath As String
    Get
    Set
Property DictFilePath As String
    Get
    Set
property String^ DictFilePath {
    String^ get ();
    void set (String^ value);
}
property String^ DictFilePath {
    String^ get ();
    void set (String^ value);
}
abstract DictFilePath : string with get, set

abstract DictFilePath : string with get, set
Property Value
String


Dispose Method

Keyoti RapidSpell Desktop .NET API Docs
Dispose Method
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► Dispose()()()()
Keyoti RapidSpell Desktop .NET
Dispose of resources
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void Dispose()
void Dispose()
Sub Dispose
Sub Dispose
void Dispose()
void Dispose()
abstract Dispose : unit -> unit

abstract Dispose : unit -> unit


DisposeAtEnd Property

Keyoti RapidSpell Desktop .NET API Docs
DisposeAtEnd Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► DisposeAtEnd
Keyoti RapidSpell Desktop .NET
Whether to dispose of this form when spell check is finished.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool DisposeAtEnd { get; set; }
bool DisposeAtEnd { get; set; }
Property DisposeAtEnd As Boolean
    Get
    Set
Property DisposeAtEnd As Boolean
    Get
    Set
property bool DisposeAtEnd {
    bool get ();
    void set (bool value);
}
property bool DisposeAtEnd {
    bool get ();
    void set (bool value);
}
abstract DisposeAtEnd : bool with get, set

abstract DisposeAtEnd : bool with get, set
Property Value
Boolean


FindCapitalizedSuggestions Property

Keyoti RapidSpell Desktop .NET API Docs
FindCapitalizedSuggestions Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► FindCapitalizedSuggestions
Keyoti RapidSpell Desktop .NET
Whether to look for capitalized suggestions, note this will slow FindSuggestions down by about 7 times.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool FindCapitalizedSuggestions { get; set; }
bool FindCapitalizedSuggestions { get; set; }
Property FindCapitalizedSuggestions As Boolean
    Get
    Set
Property FindCapitalizedSuggestions As Boolean
    Get
    Set
property bool FindCapitalizedSuggestions {
    bool get ();
    void set (bool value);
}
property bool FindCapitalizedSuggestions {
    bool get ();
    void set (bool value);
}
abstract FindCapitalizedSuggestions : bool with get, set

abstract FindCapitalizedSuggestions : bool with get, set
Property Value
Boolean


FindingSuggestionsLabelText Property

Keyoti RapidSpell Desktop .NET API Docs
FindingSuggestionsLabelText Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► FindingSuggestionsLabelText
Keyoti RapidSpell Desktop .NET
Finding suggestions label text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string FindingSuggestionsLabelText { get; set; }
string FindingSuggestionsLabelText { get; set; }
Property FindingSuggestionsLabelText As String
    Get
    Set
Property FindingSuggestionsLabelText As String
    Get
    Set
property String^ FindingSuggestionsLabelText {
    String^ get ();
    void set (String^ value);
}
property String^ FindingSuggestionsLabelText {
    String^ get ();
    void set (String^ value);
}
abstract FindingSuggestionsLabelText : string with get, set

abstract FindingSuggestionsLabelText : string with get, set
Property Value
String


FindSuggestionsLabelText Property

Keyoti RapidSpell Desktop .NET API Docs
FindSuggestionsLabelText Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► FindSuggestionsLabelText
Keyoti RapidSpell Desktop .NET
Find suggestions label text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string FindSuggestionsLabelText { get; set; }
string FindSuggestionsLabelText { get; set; }
Property FindSuggestionsLabelText As String
    Get
    Set
Property FindSuggestionsLabelText As String
    Get
    Set
property String^ FindSuggestionsLabelText {
    String^ get ();
    void set (String^ value);
}
property String^ FindSuggestionsLabelText {
    String^ get ();
    void set (String^ value);
}
abstract FindSuggestionsLabelText : string with get, set

abstract FindSuggestionsLabelText : string with get, set
Property Value
String


FinishedCheckingSelectionPopUpText Property

Keyoti RapidSpell Desktop .NET API Docs
FinishedCheckingSelectionPopUpText Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► FinishedCheckingSelectionPopUpText
Keyoti RapidSpell Desktop .NET
Finished checking selection dialog text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string FinishedCheckingSelectionPopUpText { get; set; }
string FinishedCheckingSelectionPopUpText { get; set; }
Property FinishedCheckingSelectionPopUpText As String
    Get
    Set
Property FinishedCheckingSelectionPopUpText As String
    Get
    Set
property String^ FinishedCheckingSelectionPopUpText {
    String^ get ();
    void set (String^ value);
}
property String^ FinishedCheckingSelectionPopUpText {
    String^ get ();
    void set (String^ value);
}
abstract FinishedCheckingSelectionPopUpText : string with get, set

abstract FinishedCheckingSelectionPopUpText : string with get, set
Property Value
String


FinishedCheckingSelectionPopUpTitle Property

Keyoti RapidSpell Desktop .NET API Docs
FinishedCheckingSelectionPopUpTitle Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► FinishedCheckingSelectionPopUpTitle
Keyoti RapidSpell Desktop .NET
Finished checking selection dialog title
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string FinishedCheckingSelectionPopUpTitle { get; set; }
string FinishedCheckingSelectionPopUpTitle { get; set; }
Property FinishedCheckingSelectionPopUpTitle As String
    Get
    Set
Property FinishedCheckingSelectionPopUpTitle As String
    Get
    Set
property String^ FinishedCheckingSelectionPopUpTitle {
    String^ get ();
    void set (String^ value);
}
property String^ FinishedCheckingSelectionPopUpTitle {
    String^ get ();
    void set (String^ value);
}
abstract FinishedCheckingSelectionPopUpTitle : string with get, set

abstract FinishedCheckingSelectionPopUpTitle : string with get, set
Property Value
String


GetIncludeUserDictionaryInSuggestions Method

Keyoti RapidSpell Desktop .NET API Docs
GetIncludeUserDictionaryInSuggestions Method
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► GetIncludeUserDictionaryInSuggestions()()()()
Keyoti RapidSpell Desktop .NET
Gets whether the user dictionary should be used in finding suggestions for misspelt words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool GetIncludeUserDictionaryInSuggestions()
bool GetIncludeUserDictionaryInSuggestions()
Function GetIncludeUserDictionaryInSuggestions As Boolean
Function GetIncludeUserDictionaryInSuggestions As Boolean
bool GetIncludeUserDictionaryInSuggestions()
bool GetIncludeUserDictionaryInSuggestions()
abstract GetIncludeUserDictionaryInSuggestions : unit -> bool

abstract GetIncludeUserDictionaryInSuggestions : unit -> bool
Return Value
Boolean


GetSeparateHyphenWords Method

Keyoti RapidSpell Desktop .NET API Docs
GetSeparateHyphenWords Method
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► GetSeparateHyphenWords()()()()
Keyoti RapidSpell Desktop .NET
Gets whether to treat hyphenated (-) words as separate words, default is false.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool GetSeparateHyphenWords()
bool GetSeparateHyphenWords()
Function GetSeparateHyphenWords As Boolean
Function GetSeparateHyphenWords As Boolean
bool GetSeparateHyphenWords()
bool GetSeparateHyphenWords()
abstract GetSeparateHyphenWords : unit -> bool

abstract GetSeparateHyphenWords : unit -> bool
Return Value
Boolean
Remarks
For eg. if this is true text like "cheap-deals" will be treated as two words "cheap" and "deals", otherwise this will be treated as one word "cheap-deals".


GUILanguage Property

Keyoti RapidSpell Desktop .NET API Docs
GUILanguage Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► GUILanguage
Keyoti RapidSpell Desktop .NET
The language to show the UI in.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
LanguageType GUILanguage { get; set; }
LanguageType GUILanguage { get; set; }
Property GUILanguage As LanguageType
    Get
    Set
Property GUILanguage As LanguageType
    Get
    Set
property LanguageType GUILanguage {
    LanguageType get ();
    void set (LanguageType value);
}
property LanguageType GUILanguage {
    LanguageType get ();
    void set (LanguageType value);
}
abstract GUILanguage : LanguageType with get, set

abstract GUILanguage : LanguageType with get, set
Property Value
LanguageType


IgnoreAllButtonText Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreAllButtonText Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► IgnoreAllButtonText
Keyoti RapidSpell Desktop .NET
Ignore All button text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string IgnoreAllButtonText { get; set; }
string IgnoreAllButtonText { get; set; }
Property IgnoreAllButtonText As String
    Get
    Set
Property IgnoreAllButtonText As String
    Get
    Set
property String^ IgnoreAllButtonText {
    String^ get ();
    void set (String^ value);
}
property String^ IgnoreAllButtonText {
    String^ get ();
    void set (String^ value);
}
abstract IgnoreAllButtonText : string with get, set

abstract IgnoreAllButtonText : string with get, set
Property Value
String


IgnoreButtonText Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreButtonText Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► IgnoreButtonText
Keyoti RapidSpell Desktop .NET
Ignore button text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string IgnoreButtonText { get; set; }
string IgnoreButtonText { get; set; }
Property IgnoreButtonText As String
    Get
    Set
Property IgnoreButtonText As String
    Get
    Set
property String^ IgnoreButtonText {
    String^ get ();
    void set (String^ value);
}
property String^ IgnoreButtonText {
    String^ get ();
    void set (String^ value);
}
abstract IgnoreButtonText : string with get, set

abstract IgnoreButtonText : string with get, set
Property Value
String


IgnoreCapitalizedWords Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreCapitalizedWords Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► IgnoreCapitalizedWords
Keyoti RapidSpell Desktop .NET
Sets whether to ignore words with capital letters.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool IgnoreCapitalizedWords { get; set; }
bool IgnoreCapitalizedWords { get; set; }
Property IgnoreCapitalizedWords As Boolean
    Get
    Set
Property IgnoreCapitalizedWords As Boolean
    Get
    Set
property bool IgnoreCapitalizedWords {
    bool get ();
    void set (bool value);
}
property bool IgnoreCapitalizedWords {
    bool get ();
    void set (bool value);
}
abstract IgnoreCapitalizedWords : bool with get, set

abstract IgnoreCapitalizedWords : bool with get, set
Property Value
Boolean


IgnoreIncorrectSentenceCapitalization Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreIncorrectSentenceCapitalization Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► IgnoreIncorrectSentenceCapitalization
Keyoti RapidSpell Desktop .NET
Whether to ignore incorrect sentence capitalization.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool IgnoreIncorrectSentenceCapitalization { get; set; }
bool IgnoreIncorrectSentenceCapitalization { get; set; }
Property IgnoreIncorrectSentenceCapitalization As Boolean
    Get
    Set
Property IgnoreIncorrectSentenceCapitalization As Boolean
    Get
    Set
property bool IgnoreIncorrectSentenceCapitalization {
    bool get ();
    void set (bool value);
}
property bool IgnoreIncorrectSentenceCapitalization {
    bool get ();
    void set (bool value);
}
abstract IgnoreIncorrectSentenceCapitalization : bool with get, set

abstract IgnoreIncorrectSentenceCapitalization : bool with get, set
Property Value
Boolean


IgnoreInEnglishLowerCaseI Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreInEnglishLowerCaseI Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► IgnoreInEnglishLowerCaseI
Keyoti RapidSpell Desktop .NET
Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool IgnoreInEnglishLowerCaseI { get; set; }
bool IgnoreInEnglishLowerCaseI { get; set; }
Property IgnoreInEnglishLowerCaseI As Boolean
    Get
    Set
Property IgnoreInEnglishLowerCaseI As Boolean
    Get
    Set
property bool IgnoreInEnglishLowerCaseI {
    bool get ();
    void set (bool value);
}
property bool IgnoreInEnglishLowerCaseI {
    bool get ();
    void set (bool value);
}
abstract IgnoreInEnglishLowerCaseI : bool with get, set

abstract IgnoreInEnglishLowerCaseI : bool with get, set
Property Value
Boolean


IgnoreWordsWithDigits Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreWordsWithDigits Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► IgnoreWordsWithDigits
Keyoti RapidSpell Desktop .NET
Whether to ignore words with numbers in them (eg. A10 or 7-11).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool IgnoreWordsWithDigits { get; set; }
bool IgnoreWordsWithDigits { get; set; }
Property IgnoreWordsWithDigits As Boolean
    Get
    Set
Property IgnoreWordsWithDigits As Boolean
    Get
    Set
property bool IgnoreWordsWithDigits {
    bool get ();
    void set (bool value);
}
property bool IgnoreWordsWithDigits {
    bool get ();
    void set (bool value);
}
abstract IgnoreWordsWithDigits : bool with get, set

abstract IgnoreWordsWithDigits : bool with get, set
Property Value
Boolean


IgnoreXML Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreXML Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► IgnoreXML
Keyoti RapidSpell Desktop .NET
Whether to ignore XML/HTML tags, false by default.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool IgnoreXML { get; set; }
bool IgnoreXML { get; set; }
Property IgnoreXML As Boolean
    Get
    Set
Property IgnoreXML As Boolean
    Get
    Set
property bool IgnoreXML {
    bool get ();
    void set (bool value);
}
property bool IgnoreXML {
    bool get ();
    void set (bool value);
}
abstract IgnoreXML : bool with get, set

abstract IgnoreXML : bool with get, set
Property Value
Boolean
Remarks
This identifies XML tags as anything in between < and > characters, there for it will cause undesirable effects in text such as "the sign for less than is < and the sign for greater than is >". Of course in HTML that should have been written as "the sign for less than is &lt; and the sign for greater than is &gt;" anyway, which would be fine.


InDictionaryLabelText Property

Keyoti RapidSpell Desktop .NET API Docs
InDictionaryLabelText Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► InDictionaryLabelText
Keyoti RapidSpell Desktop .NET
In dictionary label text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string InDictionaryLabelText { get; set; }
string InDictionaryLabelText { get; set; }
Property InDictionaryLabelText As String
    Get
    Set
Property InDictionaryLabelText As String
    Get
    Set
property String^ InDictionaryLabelText {
    String^ get ();
    void set (String^ value);
}
property String^ InDictionaryLabelText {
    String^ get ();
    void set (String^ value);
}
abstract InDictionaryLabelText : string with get, set

abstract InDictionaryLabelText : string with get, set
Property Value
String


IsDialogViewCreated Method

Keyoti RapidSpell Desktop .NET API Docs
IsDialogViewCreated Method
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► IsDialogViewCreated()()()()
Keyoti RapidSpell Desktop .NET
Whether a dialog view has already been created.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool IsDialogViewCreated()
bool IsDialogViewCreated()
Function IsDialogViewCreated As Boolean
Function IsDialogViewCreated As Boolean
bool IsDialogViewCreated()
bool IsDialogViewCreated()
abstract IsDialogViewCreated : unit -> bool

abstract IsDialogViewCreated : unit -> bool
Return Value
Boolean


IsShowFinishedMessageBox Method

Keyoti RapidSpell Desktop .NET API Docs
IsShowFinishedMessageBox Method
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► IsShowFinishedMessageBox()()()()
Keyoti RapidSpell Desktop .NET
Returns whether a message box should be opened when the spell check is complete.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool IsShowFinishedMessageBox()
bool IsShowFinishedMessageBox()
Function IsShowFinishedMessageBox As Boolean
Function IsShowFinishedMessageBox As Boolean
bool IsShowFinishedMessageBox()
bool IsShowFinishedMessageBox()
abstract IsShowFinishedMessageBox : unit -> bool

abstract IsShowFinishedMessageBox : unit -> bool
Return Value
Boolean
true if the message box should be opened, false otherwise.


LanguageParser Property

Keyoti RapidSpell Desktop .NET API Docs
LanguageParser Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► LanguageParser
Keyoti RapidSpell Desktop .NET
The type of language parsing to use.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
LanguageType LanguageParser { get; set; }
LanguageType LanguageParser { get; set; }
Property LanguageParser As LanguageType
    Get
    Set
Property LanguageParser As LanguageType
    Get
    Set
property LanguageType LanguageParser {
    LanguageType get ();
    void set (LanguageType value);
}
property LanguageType LanguageParser {
    LanguageType get ();
    void set (LanguageType value);
}
abstract LanguageParser : LanguageType with get, set

abstract LanguageParser : LanguageType with get, set
Property Value
LanguageType
Remarks
Eg. If the dictionary is set to French, you should use the French parser.


Load Event

Keyoti RapidSpell Desktop .NET API Docs
Load Event
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► Load
Keyoti RapidSpell Desktop .NET
Fired when the DialogView loads.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event EventHandler Load
event EventHandler Load
Event Load As EventHandler
Event Load As EventHandler
 event EventHandler^ Load {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
 event EventHandler^ Load {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Load : IEvent<EventHandler,
    EventArgs>

abstract Load : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


LookIntoHyphenatedText Property

Keyoti RapidSpell Desktop .NET API Docs
LookIntoHyphenatedText Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► LookIntoHyphenatedText
Keyoti RapidSpell Desktop .NET
Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool LookIntoHyphenatedText { get; set; }
bool LookIntoHyphenatedText { get; set; }
Property LookIntoHyphenatedText As Boolean
    Get
    Set
Property LookIntoHyphenatedText As Boolean
    Get
    Set
property bool LookIntoHyphenatedText {
    bool get ();
    void set (bool value);
}
property bool LookIntoHyphenatedText {
    bool get ();
    void set (bool value);
}
abstract LookIntoHyphenatedText : bool with get, set

abstract LookIntoHyphenatedText : bool with get, set
Property Value
Boolean
Remarks
Eg. "socio-economic" will be checked as "socio" and "economic".


MaximumContextualWords Property

Keyoti RapidSpell Desktop .NET API Docs
MaximumContextualWords Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► MaximumContextualWords
Keyoti RapidSpell Desktop .NET
The maximum number of words to show the user in the sentence around misspelled words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
int MaximumContextualWords { get; set; }
int MaximumContextualWords { get; set; }
Property MaximumContextualWords As Integer
    Get
    Set
Property MaximumContextualWords As Integer
    Get
    Set
property int MaximumContextualWords {
    int get ();
    void set (int value);
}
property int MaximumContextualWords {
    int get ();
    void set (int value);
}
abstract MaximumContextualWords : int with get, set

abstract MaximumContextualWords : int with get, set
Property Value
Int32


ModalAutoDispose Property

Keyoti RapidSpell Desktop .NET API Docs
ModalAutoDispose Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► ModalAutoDispose
Keyoti RapidSpell Desktop .NET
When running modally, determines if the dialog will be disposed of when spell check finishes.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool ModalAutoDispose { get; set; }
bool ModalAutoDispose { get; set; }
Property ModalAutoDispose As Boolean
    Get
    Set
Property ModalAutoDispose As Boolean
    Get
    Set
property bool ModalAutoDispose {
    bool get ();
    void set (bool value);
}
property bool ModalAutoDispose {
    bool get ();
    void set (bool value);
}
abstract ModalAutoDispose : bool with get, set

abstract ModalAutoDispose : bool with get, set
Property Value
Boolean
Remarks
If a modal form disposes of itself, there will be slight flickering on the screen, to prevent this, set this property to false and call Dispose() when finished with this control.


ModalMode Property

Keyoti RapidSpell Desktop .NET API Docs
ModalMode Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► ModalMode
Keyoti RapidSpell Desktop .NET
Whether the spell checker will run modally. (Modal operation blocks the parent form)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool ModalMode { get; set; }
bool ModalMode { get; set; }
Property ModalMode As Boolean
    Get
    Set
Property ModalMode As Boolean
    Get
    Set
property bool ModalMode {
    bool get ();
    void set (bool value);
}
property bool ModalMode {
    bool get ();
    void set (bool value);
}
abstract ModalMode : bool with get, set

abstract ModalMode : bool with get, set
Property Value
Boolean


ModalOwner Property

Keyoti RapidSpell Desktop .NET API Docs
ModalOwner Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► ModalOwner
Keyoti RapidSpell Desktop .NET
The owner window when used modally.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
Object ModalOwner { get; set; }
Object ModalOwner { get; set; }
Property ModalOwner As Object
    Get
    Set
Property ModalOwner As Object
    Get
    Set
property Object^ ModalOwner {
    Object^ get ();
    void set (Object^ value);
}
property Object^ ModalOwner {
    Object^ get ();
    void set (Object^ value);
}
abstract ModalOwner : Object with get, set

abstract ModalOwner : Object with get, set
Property Value
Object


NoSuggestionsText Property

Keyoti RapidSpell Desktop .NET API Docs
NoSuggestionsText Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► NoSuggestionsText
Keyoti RapidSpell Desktop .NET
No suggestions found text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string NoSuggestionsText { get; set; }
string NoSuggestionsText { get; set; }
Property NoSuggestionsText As String
    Get
    Set
Property NoSuggestionsText As String
    Get
    Set
property String^ NoSuggestionsText {
    String^ get ();
    void set (String^ value);
}
property String^ NoSuggestionsText {
    String^ get ();
    void set (String^ value);
}
abstract NoSuggestionsText : string with get, set

abstract NoSuggestionsText : string with get, set
Property Value
String


NotInDictionaryLabelText Property

Keyoti RapidSpell Desktop .NET API Docs
NotInDictionaryLabelText Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► NotInDictionaryLabelText
Keyoti RapidSpell Desktop .NET
Not in dictionary label text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string NotInDictionaryLabelText { get; set; }
string NotInDictionaryLabelText { get; set; }
Property NotInDictionaryLabelText As String
    Get
    Set
Property NotInDictionaryLabelText As String
    Get
    Set
property String^ NotInDictionaryLabelText {
    String^ get ();
    void set (String^ value);
}
property String^ NotInDictionaryLabelText {
    String^ get ();
    void set (String^ value);
}
abstract NotInDictionaryLabelText : string with get, set

abstract NotInDictionaryLabelText : string with get, set
Property Value
String


NumberSuggestionList Property

Keyoti RapidSpell Desktop .NET API Docs
NumberSuggestionList Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► NumberSuggestionList
Keyoti RapidSpell Desktop .NET
Whether to number the items in the suggestion list, for quick user selection.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool NumberSuggestionList { get; set; }
bool NumberSuggestionList { get; set; }
Property NumberSuggestionList As Boolean
    Get
    Set
Property NumberSuggestionList As Boolean
    Get
    Set
property bool NumberSuggestionList {
    bool get ();
    void set (bool value);
}
property bool NumberSuggestionList {
    bool get ();
    void set (bool value);
}
abstract NumberSuggestionList : bool with get, set

abstract NumberSuggestionList : bool with get, set
Property Value
Boolean


Options Property

Keyoti RapidSpell Desktop .NET API Docs
Options Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► Options
Keyoti RapidSpell Desktop .NET
Object responsible for holding, loading and saving the user's spell check options.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
UserOptions Options { get; set; }
UserOptions Options { get; set; }
Property Options As UserOptions
    Get
    Set
Property Options As UserOptions
    Get
    Set
property UserOptions^ Options {
    UserOptions^ get ();
    void set (UserOptions^ value);
}
property UserOptions^ Options {
    UserOptions^ get ();
    void set (UserOptions^ value);
}
abstract Options : UserOptions with get, set

abstract Options : UserOptions with get, set
Property Value
UserOptions
Remarks
To customize how the user's options are saved/loaded, subclass UserOptions and set an instance in this property.


OptionsButtonText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsButtonText Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► OptionsButtonText
Keyoti RapidSpell Desktop .NET
Options button text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string OptionsButtonText { get; set; }
string OptionsButtonText { get; set; }
Property OptionsButtonText As String
    Get
    Set
Property OptionsButtonText As String
    Get
    Set
property String^ OptionsButtonText {
    String^ get ();
    void set (String^ value);
}
property String^ OptionsButtonText {
    String^ get ();
    void set (String^ value);
}
abstract OptionsButtonText : string with get, set

abstract OptionsButtonText : string with get, set
Property Value
String


OptionsPresenter Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsPresenter Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► OptionsPresenter
Keyoti RapidSpell Desktop .NET
Presenter for the user options form (IDialogViewOptions).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
OptionsPresenter OptionsPresenter { get; set; }
OptionsPresenter OptionsPresenter { get; set; }
Property OptionsPresenter As OptionsPresenter
    Get
    Set
Property OptionsPresenter As OptionsPresenter
    Get
    Set
property OptionsPresenter^ OptionsPresenter {
    OptionsPresenter^ get ();
    void set (OptionsPresenter^ value);
}
property OptionsPresenter^ OptionsPresenter {
    OptionsPresenter^ get ();
    void set (OptionsPresenter^ value);
}
abstract OptionsPresenter : OptionsPresenter with get, set

abstract OptionsPresenter : OptionsPresenter with get, set
Property Value
OptionsPresenter
Remarks
Set properties in this instance to affect the options shown to the user, or handle CreateDialogViewOptions to create your own IDialogViewOptions form instance.


Ready Event

Keyoti RapidSpell Desktop .NET API Docs
Ready Event
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► Ready
Keyoti RapidSpell Desktop .NET
Fired when ready to proceed with first query.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event EventHandler Ready
event EventHandler Ready
Event Ready As EventHandler
Event Ready As EventHandler
 event EventHandler^ Ready {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
 event EventHandler^ Ready {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Ready : IEvent<EventHandler,
    EventArgs>

abstract Ready : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


RecheckDocumentRequest Event

Keyoti RapidSpell Desktop .NET API Docs
RecheckDocumentRequest Event
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► RecheckDocumentRequest
Keyoti RapidSpell Desktop .NET
Fired when the text should be rechecked
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event EventHandler RecheckDocumentRequest
event EventHandler RecheckDocumentRequest
Event RecheckDocumentRequest As EventHandler
Event RecheckDocumentRequest As EventHandler
 event EventHandler^ RecheckDocumentRequest {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
 event EventHandler^ RecheckDocumentRequest {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract RecheckDocumentRequest : IEvent<EventHandler,
    EventArgs>

abstract RecheckDocumentRequest : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


Remove Method

Keyoti RapidSpell Desktop .NET API Docs
Remove Method
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► Remove()()()()
Keyoti RapidSpell Desktop .NET
Safely frees up resources.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void Remove()
void Remove()
Sub Remove
Sub Remove
void Remove()
void Remove()
abstract Remove : unit -> unit

abstract Remove : unit -> unit


RemoveDuplicateWordText Property

Keyoti RapidSpell Desktop .NET API Docs
RemoveDuplicateWordText Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► RemoveDuplicateWordText
Keyoti RapidSpell Desktop .NET
Remove duplicate word text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string RemoveDuplicateWordText { get; set; }
string RemoveDuplicateWordText { get; set; }
Property RemoveDuplicateWordText As String
    Get
    Set
Property RemoveDuplicateWordText As String
    Get
    Set
property String^ RemoveDuplicateWordText {
    String^ get ();
    void set (String^ value);
}
property String^ RemoveDuplicateWordText {
    String^ get ();
    void set (String^ value);
}
abstract RemoveDuplicateWordText : string with get, set

abstract RemoveDuplicateWordText : string with get, set
Property Value
String


ResumeButtonText Property

Keyoti RapidSpell Desktop .NET API Docs
ResumeButtonText Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► ResumeButtonText
Keyoti RapidSpell Desktop .NET
Resume button text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string ResumeButtonText { get; set; }
string ResumeButtonText { get; set; }
Property ResumeButtonText As String
    Get
    Set
Property ResumeButtonText As String
    Get
    Set
property String^ ResumeButtonText {
    String^ get ();
    void set (String^ value);
}
property String^ ResumeButtonText {
    String^ get ();
    void set (String^ value);
}
abstract ResumeButtonText : string with get, set

abstract ResumeButtonText : string with get, set
Property Value
String


SetIgnoreOnceBadWords Method (ignoreOnceBadWords)

Keyoti RapidSpell Desktop .NET API Docs
SetIgnoreOnceBadWords Method (ignoreOnceBadWords)
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► SetIgnoreOnceBadWords(ArrayList)
Keyoti RapidSpell Desktop .NET
Provide a list of BadWord objects that have been ignored
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void SetIgnoreOnceBadWords(
    ArrayList ignoreOnceBadWords
)
void SetIgnoreOnceBadWords(
    ArrayList ignoreOnceBadWords
)
Sub SetIgnoreOnceBadWords (
    ignoreOnceBadWords As ArrayList
)
Sub SetIgnoreOnceBadWords (
    ignoreOnceBadWords As ArrayList
)
void SetIgnoreOnceBadWords(
    ArrayList^ ignoreOnceBadWords
)
void SetIgnoreOnceBadWords(
    ArrayList^ ignoreOnceBadWords
)
abstract SetIgnoreOnceBadWords :
        ignoreOnceBadWords : ArrayList -> unit

abstract SetIgnoreOnceBadWords :
        ignoreOnceBadWords : ArrayList -> unit
Parameters
ignoreOnceBadWords (ArrayList)


SetIncludeUserDictionaryInSuggestions Method (v)

Keyoti RapidSpell Desktop .NET API Docs
SetIncludeUserDictionaryInSuggestions Method (v)
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► SetIncludeUserDictionaryInSuggestions(Boolean)
Keyoti RapidSpell Desktop .NET
Sets whether the user dictionary should be used in finding suggestions for misspelt words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void SetIncludeUserDictionaryInSuggestions(
    bool v
)
void SetIncludeUserDictionaryInSuggestions(
    bool v
)
Sub SetIncludeUserDictionaryInSuggestions (
    v As Boolean
)
Sub SetIncludeUserDictionaryInSuggestions (
    v As Boolean
)
void SetIncludeUserDictionaryInSuggestions(
    bool v
)
void SetIncludeUserDictionaryInSuggestions(
    bool v
)
abstract SetIncludeUserDictionaryInSuggestions :
        v : bool -> unit

abstract SetIncludeUserDictionaryInSuggestions :
        v : bool -> unit
Parameters
v (Boolean)


SetSeparateHyphenWords Method (f)

Keyoti RapidSpell Desktop .NET API Docs
SetSeparateHyphenWords Method (f)
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► SetSeparateHyphenWords(Boolean)
Keyoti RapidSpell Desktop .NET
Sets whether to treat hyphenated (-) words as separate words, default is false.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void SetSeparateHyphenWords(
    bool f
)
void SetSeparateHyphenWords(
    bool f
)
Sub SetSeparateHyphenWords (
    f As Boolean
)
Sub SetSeparateHyphenWords (
    f As Boolean
)
void SetSeparateHyphenWords(
    bool f
)
void SetSeparateHyphenWords(
    bool f
)
abstract SetSeparateHyphenWords :
        f : bool -> unit

abstract SetSeparateHyphenWords :
        f : bool -> unit
Parameters
f (Boolean)
Remarks
For eg. if this is true text like "cheap-deals" will be treated as two words "cheap" and "deals", otherwise this will be treated as one word "cheap-deals".


SetShowFinishedMessageBox Method (b)

Keyoti RapidSpell Desktop .NET API Docs
SetShowFinishedMessageBox Method (b)
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► SetShowFinishedMessageBox(Boolean)
Keyoti RapidSpell Desktop .NET
Sets whether a message box should be opened when the spell check is complete.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void SetShowFinishedMessageBox(
    bool b
)
void SetShowFinishedMessageBox(
    bool b
)
Sub SetShowFinishedMessageBox (
    b As Boolean
)
Sub SetShowFinishedMessageBox (
    b As Boolean
)
void SetShowFinishedMessageBox(
    bool b
)
void SetShowFinishedMessageBox(
    bool b
)
abstract SetShowFinishedMessageBox :
        b : bool -> unit

abstract SetShowFinishedMessageBox :
        b : bool -> unit
Parameters
b (Boolean)
boolean indicating if the message box should be opened.


SetTextComponentToCheck Method

Keyoti RapidSpell Desktop .NET API Docs
SetTextComponentToCheck Method
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► SetTextComponentToCheck()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | SetTextComponentToCheck(TextBoxBase) | Set the TextBoxBase (eg; TextBox etc) that this GUI will spell check.
 | SetTextComponentToCheck(ISpellCheckableTextComponent) | Sets the ISpellCheckableTextComponent that this GUI will spell check.


SetTextComponentToCheck Method (textComponent)

Keyoti RapidSpell Desktop .NET API Docs
SetTextComponentToCheck Method (textComponent)
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► SetTextComponentToCheck(ISpellCheckableTextComponent)
Keyoti RapidSpell Desktop .NET
Sets the ISpellCheckableTextComponent that this GUI will spell check.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void SetTextComponentToCheck(
    ISpellCheckableTextComponent textComponent
)
void SetTextComponentToCheck(
    ISpellCheckableTextComponent textComponent
)
Sub SetTextComponentToCheck (
    textComponent As ISpellCheckableTextComponent
)
Sub SetTextComponentToCheck (
    textComponent As ISpellCheckableTextComponent
)
void SetTextComponentToCheck(
    ISpellCheckableTextComponent^ textComponent
)
void SetTextComponentToCheck(
    ISpellCheckableTextComponent^ textComponent
)
abstract SetTextComponentToCheck :
        textComponent : ISpellCheckableTextComponent -> unit

abstract SetTextComponentToCheck :
        textComponent : ISpellCheckableTextComponent -> unit
Parameters
textComponent (ISpellCheckableTextComponent)
the ISpellCheckableTextComponent that this will spell check.
Exceptions
Exception | Condition
ArgumentNullException | if textComponent parameter is null.


SetTextComponentToCheck Method (textComponent)

Keyoti RapidSpell Desktop .NET API Docs
SetTextComponentToCheck Method (textComponent)
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► SetTextComponentToCheck(TextBoxBase)
Keyoti RapidSpell Desktop .NET
Set the TextBoxBase (eg; TextBox etc) that this GUI will spell check.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void SetTextComponentToCheck(
    TextBoxBase textComponent
)
void SetTextComponentToCheck(
    TextBoxBase textComponent
)
Sub SetTextComponentToCheck (
    textComponent As TextBoxBase
)
Sub SetTextComponentToCheck (
    textComponent As TextBoxBase
)
void SetTextComponentToCheck(
    TextBoxBase^ textComponent
)
void SetTextComponentToCheck(
    TextBoxBase^ textComponent
)
abstract SetTextComponentToCheck :
        textComponent : TextBoxBase -> unit

abstract SetTextComponentToCheck :
        textComponent : TextBoxBase -> unit
Parameters
textComponent (TextBoxBase)
the TextBoxBase that this will spell check.
Exceptions
Exception | Condition
ArgumentNullException | if textComponent parameter is null.


SetUserDictionary Method (userDictionary)

Keyoti RapidSpell Desktop .NET API Docs
SetUserDictionary Method (userDictionary)
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► SetUserDictionary(UserDictionary)
Keyoti RapidSpell Desktop .NET
Set the user dictionary object.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void SetUserDictionary(
    UserDictionary userDictionary
)
void SetUserDictionary(
    UserDictionary userDictionary
)
Sub SetUserDictionary (
    userDictionary As UserDictionary
)
Sub SetUserDictionary (
    userDictionary As UserDictionary
)
void SetUserDictionary(
    UserDictionary^ userDictionary
)
void SetUserDictionary(
    UserDictionary^ userDictionary
)
abstract SetUserDictionary :
        userDictionary : UserDictionary -> unit

abstract SetUserDictionary :
        userDictionary : UserDictionary -> unit
Parameters
userDictionary (UserDictionary)
the UserDictionary to use as a user dictionary.
Remarks
Use of a user dictionary is optional.
Exceptions
Exception | Condition
ArgumentNullException | if userDictionary parameter is null.


SetUserDictionaryFile Method (userDictionaryFile)

Keyoti RapidSpell Desktop .NET API Docs
SetUserDictionaryFile Method (userDictionaryFile)
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► SetUserDictionaryFile(String)
Keyoti RapidSpell Desktop .NET
Set the user dictionary file, if this file doesn't exist it will be created.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void SetUserDictionaryFile(
    string userDictionaryFile
)
void SetUserDictionaryFile(
    string userDictionaryFile
)
Sub SetUserDictionaryFile (
    userDictionaryFile As String
)
Sub SetUserDictionaryFile (
    userDictionaryFile As String
)
void SetUserDictionaryFile(
    String^ userDictionaryFile
)
void SetUserDictionaryFile(
    String^ userDictionaryFile
)
abstract SetUserDictionaryFile :
        userDictionaryFile : string -> unit

abstract SetUserDictionaryFile :
        userDictionaryFile : string -> unit
Parameters
userDictionaryFile (String)
the File to use as a user dictionary.
Remarks
Use of a user dictionary is optional.
Exceptions
Exception | Condition
ArgumentNullException | if userDictionaryFile parameter is null.


ShowContextSentence Property

Keyoti RapidSpell Desktop .NET API Docs
ShowContextSentence Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► ShowContextSentence
Keyoti RapidSpell Desktop .NET
Whether to show the query in context of it's sentence/line.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool ShowContextSentence { get; set; }
bool ShowContextSentence { get; set; }
Property ShowContextSentence As Boolean
    Get
    Set
Property ShowContextSentence As Boolean
    Get
    Set
property bool ShowContextSentence {
    bool get ();
    void set (bool value);
}
property bool ShowContextSentence {
    bool get ();
    void set (bool value);
}
abstract ShowContextSentence : bool with get, set

abstract ShowContextSentence : bool with get, set
Property Value
Boolean


SpellCheckFinished Event

Keyoti RapidSpell Desktop .NET API Docs
SpellCheckFinished Event
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► SpellCheckFinished
Keyoti RapidSpell Desktop .NET
Fired when checking finishes
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event RapidSpellGUIPresenter..::..SpellCheckEventHandler SpellCheckFinished
event RapidSpellGUIPresenter..::..SpellCheckEventHandler SpellCheckFinished
Event SpellCheckFinished As RapidSpellGUIPresenter..::..SpellCheckEventHandler
Event SpellCheckFinished As RapidSpellGUIPresenter..::..SpellCheckEventHandler
 event RapidSpellGUIPresenter..::..SpellCheckEventHandler^ SpellCheckFinished {
    void add (RapidSpellGUIPresenter..::..SpellCheckEventHandler^ value);
    void remove (RapidSpellGUIPresenter..::..SpellCheckEventHandler^ value);
}
 event RapidSpellGUIPresenter..::..SpellCheckEventHandler^ SpellCheckFinished {
    void add (RapidSpellGUIPresenter..::..SpellCheckEventHandler^ value);
    void remove (RapidSpellGUIPresenter..::..SpellCheckEventHandler^ value);
}
abstract SpellCheckFinished : IEvent<RapidSpellGUIPresenter..::..SpellCheckEventHandler,
    SpellCheckEventArgs>

abstract SpellCheckFinished : IEvent<RapidSpellGUIPresenter..::..SpellCheckEventHandler,
    SpellCheckEventArgs>
Value
RapidSpellGUIPresenter..::..SpellCheckEventHandler


SpellCheckStarted Event

Keyoti RapidSpell Desktop .NET API Docs
SpellCheckStarted Event
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► SpellCheckStarted
Keyoti RapidSpell Desktop .NET
Fired when checking starts
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event RapidSpellGUIPresenter..::..SpellCheckEventHandler SpellCheckStarted
event RapidSpellGUIPresenter..::..SpellCheckEventHandler SpellCheckStarted
Event SpellCheckStarted As RapidSpellGUIPresenter..::..SpellCheckEventHandler
Event SpellCheckStarted As RapidSpellGUIPresenter..::..SpellCheckEventHandler
 event RapidSpellGUIPresenter..::..SpellCheckEventHandler^ SpellCheckStarted {
    void add (RapidSpellGUIPresenter..::..SpellCheckEventHandler^ value);
    void remove (RapidSpellGUIPresenter..::..SpellCheckEventHandler^ value);
}
 event RapidSpellGUIPresenter..::..SpellCheckEventHandler^ SpellCheckStarted {
    void add (RapidSpellGUIPresenter..::..SpellCheckEventHandler^ value);
    void remove (RapidSpellGUIPresenter..::..SpellCheckEventHandler^ value);
}
abstract SpellCheckStarted : IEvent<RapidSpellGUIPresenter..::..SpellCheckEventHandler,
    SpellCheckEventArgs>

abstract SpellCheckStarted : IEvent<RapidSpellGUIPresenter..::..SpellCheckEventHandler,
    SpellCheckEventArgs>
Value
RapidSpellGUIPresenter..::..SpellCheckEventHandler


SuggestionsLabelText Property

Keyoti RapidSpell Desktop .NET API Docs
SuggestionsLabelText Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► SuggestionsLabelText
Keyoti RapidSpell Desktop .NET
Suggestions label text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string SuggestionsLabelText { get; set; }
string SuggestionsLabelText { get; set; }
Property SuggestionsLabelText As String
    Get
    Set
Property SuggestionsLabelText As String
    Get
    Set
property String^ SuggestionsLabelText {
    String^ get ();
    void set (String^ value);
}
property String^ SuggestionsLabelText {
    String^ get ();
    void set (String^ value);
}
abstract SuggestionsLabelText : string with get, set

abstract SuggestionsLabelText : string with get, set
Property Value
String


SuggestionsMethod Property

Keyoti RapidSpell Desktop .NET API Docs
SuggestionsMethod Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► SuggestionsMethod
Keyoti RapidSpell Desktop .NET
Sets the suggestions method to use. Either PHONETIC_SUGGESTIONS or HASHING_SUGGESTIONS
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
SuggestionsMethodType SuggestionsMethod { get; set; }
SuggestionsMethodType SuggestionsMethod { get; set; }
Property SuggestionsMethod As SuggestionsMethodType
    Get
    Set
Property SuggestionsMethod As SuggestionsMethodType
    Get
    Set
property SuggestionsMethodType SuggestionsMethod {
    SuggestionsMethodType get ();
    void set (SuggestionsMethodType value);
}
property SuggestionsMethodType SuggestionsMethod {
    SuggestionsMethodType get ();
    void set (SuggestionsMethodType value);
}
abstract SuggestionsMethod : SuggestionsMethodType with get, set

abstract SuggestionsMethod : SuggestionsMethodType with get, set
Property Value
SuggestionsMethodType


SuggestSplitWords Property

Keyoti RapidSpell Desktop .NET API Docs
SuggestSplitWords Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► SuggestSplitWords
Keyoti RapidSpell Desktop .NET
Whether to look for connected words in suggestions.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool SuggestSplitWords { get; set; }
bool SuggestSplitWords { get; set; }
Property SuggestSplitWords As Boolean
    Get
    Set
Property SuggestSplitWords As Boolean
    Get
    Set
property bool SuggestSplitWords {
    bool get ();
    void set (bool value);
}
property bool SuggestSplitWords {
    bool get ();
    void set (bool value);
}
abstract SuggestSplitWords : bool with get, set

abstract SuggestSplitWords : bool with get, set
Property Value
Boolean
Remarks
if this=true then suggestions may include joined words.

Eg; suggestions for "myhouse" will include "my house"


UndoButtonText Property

Keyoti RapidSpell Desktop .NET API Docs
UndoButtonText Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► UndoButtonText
Keyoti RapidSpell Desktop .NET
Undo button text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string UndoButtonText { get; set; }
string UndoButtonText { get; set; }
Property UndoButtonText As String
    Get
    Set
Property UndoButtonText As String
    Get
    Set
property String^ UndoButtonText {
    String^ get ();
    void set (String^ value);
}
property String^ UndoButtonText {
    String^ get ();
    void set (String^ value);
}
abstract UndoButtonText : string with get, set

abstract UndoButtonText : string with get, set
Property Value
String


Undone Event

Keyoti RapidSpell Desktop .NET API Docs
Undone Event
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► Undone
Keyoti RapidSpell Desktop .NET
Fired when an Undo occurs
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event UndoEventHandler Undone
event UndoEventHandler Undone
Event Undone As UndoEventHandler
Event Undone As UndoEventHandler
 event UndoEventHandler^ Undone {
    void add (UndoEventHandler^ value);
    void remove (UndoEventHandler^ value);
}
 event UndoEventHandler^ Undone {
    void add (UndoEventHandler^ value);
    void remove (UndoEventHandler^ value);
}
abstract Undone : IEvent<UndoEventHandler,
    UndoEventArgs>

abstract Undone : IEvent<UndoEventHandler,
    UndoEventArgs>
Value
UndoEventHandler


UserQuery Event

Keyoti RapidSpell Desktop .NET API Docs
UserQuery Event
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► UserQuery
Keyoti RapidSpell Desktop .NET
Indicates that the user is being queried on a spelling error.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event UserQueryEventHandler UserQuery
event UserQueryEventHandler UserQuery
Event UserQuery As UserQueryEventHandler
Event UserQuery As UserQueryEventHandler
 event UserQueryEventHandler^ UserQuery {
    void add (UserQueryEventHandler^ value);
    void remove (UserQueryEventHandler^ value);
}
 event UserQueryEventHandler^ UserQuery {
    void add (UserQueryEventHandler^ value);
    void remove (UserQueryEventHandler^ value);
}
abstract UserQuery : IEvent<UserQueryEventHandler,
    UserQueryEventArgs>

abstract UserQuery : IEvent<UserQueryEventHandler,
    UserQueryEventArgs>
Value
UserQueryEventHandler


WarnDuplicates Property

Keyoti RapidSpell Desktop .NET API Docs
WarnDuplicates Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► WarnDuplicates
Keyoti RapidSpell Desktop .NET
Whether to show duplicate words as errors (eg. "this is is an error").
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool WarnDuplicates { get; set; }
bool WarnDuplicates { get; set; }
Property WarnDuplicates As Boolean
    Get
    Set
Property WarnDuplicates As Boolean
    Get
    Set
property bool WarnDuplicates {
    bool get ();
    void set (bool value);
}
property bool WarnDuplicates {
    bool get ();
    void set (bool value);
}
abstract WarnDuplicates : bool with get, set

abstract WarnDuplicates : bool with get, set
Property Value
Boolean


WordAdded Event

Keyoti RapidSpell Desktop .NET API Docs
WordAdded Event
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► WordAdded
Keyoti RapidSpell Desktop .NET
Fired when word added to user dictionary
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event WordAddedEventHandler WordAdded
event WordAddedEventHandler WordAdded
Event WordAdded As WordAddedEventHandler
Event WordAdded As WordAddedEventHandler
 event WordAddedEventHandler^ WordAdded {
    void add (WordAddedEventHandler^ value);
    void remove (WordAddedEventHandler^ value);
}
 event WordAddedEventHandler^ WordAdded {
    void add (WordAddedEventHandler^ value);
    void remove (WordAddedEventHandler^ value);
}
abstract WordAdded : IEvent<WordAddedEventHandler,
    WordAddedEventArgs>

abstract WordAdded : IEvent<WordAddedEventHandler,
    WordAddedEventArgs>
Value
WordAddedEventHandler


WordChanged Event

Keyoti RapidSpell Desktop .NET API Docs
WordChanged Event
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► WordChanged
Keyoti RapidSpell Desktop .NET
Fired when word changed
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event WordChangedEventHandler WordChanged
event WordChangedEventHandler WordChanged
Event WordChanged As WordChangedEventHandler
Event WordChanged As WordChangedEventHandler
 event WordChangedEventHandler^ WordChanged {
    void add (WordChangedEventHandler^ value);
    void remove (WordChangedEventHandler^ value);
}
 event WordChangedEventHandler^ WordChanged {
    void add (WordChangedEventHandler^ value);
    void remove (WordChangedEventHandler^ value);
}
abstract WordChanged : IEvent<WordChangedEventHandler,
    WordChangedEventArgs>

abstract WordChanged : IEvent<WordChangedEventHandler,
    WordChangedEventArgs>
Value
WordChangedEventHandler


WordChanging Event

Keyoti RapidSpell Desktop .NET API Docs
WordChanging Event
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► WordChanging
Keyoti RapidSpell Desktop .NET
Fired before a word is changed
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event WordChangedEventHandler WordChanging
event WordChangedEventHandler WordChanging
Event WordChanging As WordChangedEventHandler
Event WordChanging As WordChangedEventHandler
 event WordChangedEventHandler^ WordChanging {
    void add (WordChangedEventHandler^ value);
    void remove (WordChangedEventHandler^ value);
}
 event WordChangedEventHandler^ WordChanging {
    void add (WordChangedEventHandler^ value);
    void remove (WordChangedEventHandler^ value);
}
abstract WordChanging : IEvent<WordChangedEventHandler,
    WordChangedEventArgs>

abstract WordChanging : IEvent<WordChangedEventHandler,
    WordChangedEventArgs>
Value
WordChangedEventHandler


WordIgnored Event

Keyoti RapidSpell Desktop .NET API Docs
WordIgnored Event
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► WordIgnored
Keyoti RapidSpell Desktop .NET
Fired when word ignored
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event WordIgnoredEventHandler WordIgnored
event WordIgnoredEventHandler WordIgnored
Event WordIgnored As WordIgnoredEventHandler
Event WordIgnored As WordIgnoredEventHandler
 event WordIgnoredEventHandler^ WordIgnored {
    void add (WordIgnoredEventHandler^ value);
    void remove (WordIgnoredEventHandler^ value);
}
 event WordIgnoredEventHandler^ WordIgnored {
    void add (WordIgnoredEventHandler^ value);
    void remove (WordIgnoredEventHandler^ value);
}
abstract WordIgnored : IEvent<WordIgnoredEventHandler,
    WordIgnoredEventArgs>

abstract WordIgnored : IEvent<WordIgnoredEventHandler,
    WordIgnoredEventArgs>
Value
WordIgnoredEventHandler


KLicenseProvider Class

Keyoti RapidSpell Desktop .NET API Docs
KLicenseProvider Class
API ► Keyoti.RapidSpell ► KLicenseProvider
Keyoti RapidSpell Desktop .NET
Summary description for KLicenseProvider.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class KLicenseProvider : LicenseProvider
public class KLicenseProvider : LicenseProvider
Public Class KLicenseProvider
    Inherits LicenseProvider
Public Class KLicenseProvider
    Inherits LicenseProvider
public ref class KLicenseProvider : public LicenseProvider
public ref class KLicenseProvider : public LicenseProvider
type KLicenseProvider =
    class
        inherit LicenseProvider
    end
type KLicenseProvider =
    class
        inherit LicenseProvider
    end
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | KLicenseProvider()()()() | New
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLicense(LicenseContext, Type, Object, Boolean) | Retrieves the license. (Overrides LicenseProvider.GetLicense(LicenseContext, Type, Object, Boolean).)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetStoredKey(String) | Store key
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | LicenseProvider
 |  | KLicenseProvider


KLicenseProvider Constructor

Keyoti RapidSpell Desktop .NET API Docs
KLicenseProvider Constructor
API ► Keyoti.RapidSpell ► KLicenseProvider ► KLicenseProvider()()()()
Keyoti RapidSpell Desktop .NET
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public KLicenseProvider()
public KLicenseProvider()
Public Sub New
Public Sub New
public:
KLicenseProvider()
public:
KLicenseProvider()
new : unit -> KLicenseProvider
new : unit -> KLicenseProvider


GetLicense Method (context, type, instance, allowExceptions)

Keyoti RapidSpell Desktop .NET API Docs
GetLicense Method (context, type, instance, allowExceptions)
API ► Keyoti.RapidSpell ► KLicenseProvider ► GetLicense(LicenseContext, Type, Object, Boolean)
Keyoti RapidSpell Desktop .NET
Retrieves the license.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override License GetLicense(
    LicenseContext context,
    Type type,
    Object instance,
    bool allowExceptions
)
public override License GetLicense(
    LicenseContext context,
    Type type,
    Object instance,
    bool allowExceptions
)
Public Overrides Function GetLicense (
    context As LicenseContext,
    type As Type,
    instance As Object,
    allowExceptions As Boolean
) As License
Public Overrides Function GetLicense (
    context As LicenseContext,
    type As Type,
    instance As Object,
    allowExceptions As Boolean
) As License
public:
virtual License^ GetLicense(
    LicenseContext^ context,
    Type^ type,
    Object^ instance,
    bool allowExceptions
) override
public:
virtual License^ GetLicense(
    LicenseContext^ context,
    Type^ type,
    Object^ instance,
    bool allowExceptions
) override
abstract GetLicense :
        context : LicenseContext *
        type : Type *
        instance : Object *
        allowExceptions : bool -> License
override GetLicense :
        context : LicenseContext *
        type : Type *
        instance : Object *
        allowExceptions : bool -> License
abstract GetLicense :
        context : LicenseContext *
        type : Type *
        instance : Object *
        allowExceptions : bool -> License
override GetLicense :
        context : LicenseContext *
        type : Type *
        instance : Object *
        allowExceptions : bool -> License
Parameters
context (LicenseContext)
type (Type)
instance (Object)
allowExceptions (Boolean)
Return Value
License


SetStoredKey Method (key)

Keyoti RapidSpell Desktop .NET API Docs
SetStoredKey Method (key)
API ► Keyoti.RapidSpell ► KLicenseProvider ► SetStoredKey(String)
Keyoti RapidSpell Desktop .NET
Store key
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static string SetStoredKey(
    string key
)
public static string SetStoredKey(
    string key
)
Public Shared Function SetStoredKey (
    key As String
) As String
Public Shared Function SetStoredKey (
    key As String
) As String
public:
static String^ SetStoredKey(
    String^ key
)
public:
static String^ SetStoredKey(
    String^ key
)
static member SetStoredKey :
        key : string -> string

static member SetStoredKey :
        key : string -> string
Parameters
key (String)
Return Value
String


LanguageType Enumeration

Keyoti RapidSpell Desktop .NET API Docs
LanguageType Enumeration
API ► Keyoti.RapidSpell ► LanguageType
Keyoti RapidSpell Desktop .NET
Enumeration of language types.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public enum LanguageType
public enum LanguageType
Public Enumeration LanguageType
Public Enumeration LanguageType
public enum class LanguageType
public enum class LanguageType
type LanguageType
type LanguageType
Members
Member | Description
ENGLISH | English.
DUTCH | Dutch.
FRENCH | French.
GERMAN | German.
ITALIAN | Italian.
PORTUGUESE | Portuguese.
SPANISH | Spanish.
POLISH | Polish.
RUSSIAN | Russian.


MultiFileUserDictionary Class

Keyoti RapidSpell Desktop .NET API Docs
MultiFileUserDictionary Class
API ► Keyoti.RapidSpell ► MultiFileUserDictionary
Keyoti RapidSpell Desktop .NET
Represents multiple file based user dictionaries.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class MultiFileUserDictionary : UserDictionary
public class MultiFileUserDictionary : UserDictionary
Public Class MultiFileUserDictionary
    Inherits UserDictionary
Public Class MultiFileUserDictionary
    Inherits UserDictionary
public ref class MultiFileUserDictionary : public UserDictionary
public ref class MultiFileUserDictionary : public UserDictionary
type MultiFileUserDictionary =
    class
        inherit UserDictionary
    end
type MultiFileUserDictionary =
    class
        inherit UserDictionary
    end
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MultiFileUserDictionary(List<(Of <<'(UserDictionary>)>>)) | New
 | AddFile(String) | Adds a new user dictionary to the collection
 | AddWord(String) | Adds a word to the default dictionary (Overrides UserDictionary.AddWord(String).)
 | dictFile | The file containing the dictionary (Inherited from UserDictionary.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetFileNames()()()() | The file names
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GetUserDictionary(String) | Gets the UserDictionary associated with the specified path.
 | IsValid()()()() | Whether a problem has occurred. (Overrides UserDictionary.IsValid()()()().)
 | ListChanged | Notifies handlers that the word list has changed. (Inherited from UserDictionary.)
 | Location | Where to store the user dictionary (Inherited from UserDictionary.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnListChanged(UserDictionary..::..ListChangedEventArgs) | Raises ListChanged (Inherited from UserDictionary.)
 | OnListChanged(Object, UserDictionary..::..ListChangedEventArgs) | Raises ListChanged (Inherited from UserDictionary.)
 | ReadAll(ArrayList) | Reads all words from all files (Overrides UserDictionary.ReadAll(ArrayList).)
 | ReloadDictionary()()()() | Reload (Overrides UserDictionary.ReloadDictionary()()()().)
 | RemoveFile(String) | Removes a user dictionary from the collection
 | RemoveWord(String) | Removes a word from the default dictionary (Overrides UserDictionary.RemoveWord(String).)
 | SaveList(ArrayList) | Save (Overrides UserDictionary.SaveList(ArrayList).)
 | SetDefaultUserDictionaryFile(String) | Sets the default user dictionary
 | SetFiles(List<(Of <<'(String>)>>)) | Sets user dictionaries in the collection
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | UserDictionary
 |  | MultiFileUserDictionary


MultiFileUserDictionary Constructor (dictionaries)

Keyoti RapidSpell Desktop .NET API Docs
MultiFileUserDictionary Constructor (dictionaries)
API ► Keyoti.RapidSpell ► MultiFileUserDictionary ► MultiFileUserDictionary(List<(Of <<'(UserDictionary>)>>))
Keyoti RapidSpell Desktop .NET
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public MultiFileUserDictionary(
    List<UserDictionary> dictionaries
)
public MultiFileUserDictionary(
    List<UserDictionary> dictionaries
)
Public Sub New (
    dictionaries As List(Of UserDictionary)
)
Public Sub New (
    dictionaries As List(Of UserDictionary)
)
public:
MultiFileUserDictionary(
    List<UserDictionary^>^ dictionaries
)
public:
MultiFileUserDictionary(
    List<UserDictionary^>^ dictionaries
)
new :
        dictionaries : List<UserDictionary> -> MultiFileUserDictionary
new :
        dictionaries : List<UserDictionary> -> MultiFileUserDictionary
Parameters
dictionaries (List <(Of <(<' UserDictionary >)>)>)


AddFile Method (file)

Keyoti RapidSpell Desktop .NET API Docs
AddFile Method (file)
API ► Keyoti.RapidSpell ► MultiFileUserDictionary ► AddFile(String)
Keyoti RapidSpell Desktop .NET
Adds a new user dictionary to the collection
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual UserDictionary AddFile(
    string file
)
public virtual UserDictionary AddFile(
    string file
)
Public Overridable Function AddFile (
    file As String
) As UserDictionary
Public Overridable Function AddFile (
    file As String
) As UserDictionary
public:
virtual UserDictionary^ AddFile(
    String^ file
)
public:
virtual UserDictionary^ AddFile(
    String^ file
)
abstract AddFile :
        file : string -> UserDictionary
override AddFile :
        file : string -> UserDictionary
abstract AddFile :
        file : string -> UserDictionary
override AddFile :
        file : string -> UserDictionary
Parameters
file (String)
File path
Return Value
UserDictionary


AddWord Method (word)

Keyoti RapidSpell Desktop .NET API Docs
AddWord Method (word)
API ► Keyoti.RapidSpell ► MultiFileUserDictionary ► AddWord(String)
Keyoti RapidSpell Desktop .NET
Adds a word to the default dictionary
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override bool AddWord(
    string word
)
public override bool AddWord(
    string word
)
Public Overrides Function AddWord (
    word As String
) As Boolean
Public Overrides Function AddWord (
    word As String
) As Boolean
public:
virtual bool AddWord(
    String^ word
) override
public:
virtual bool AddWord(
    String^ word
) override
abstract AddWord :
        word : string -> bool
override AddWord :
        word : string -> bool
abstract AddWord :
        word : string -> bool
override AddWord :
        word : string -> bool
Parameters
word (String)
Return Value
Boolean


GetFileNames Method

Keyoti RapidSpell Desktop .NET API Docs
GetFileNames Method
API ► Keyoti.RapidSpell ► MultiFileUserDictionary ► GetFileNames()()()()
Keyoti RapidSpell Desktop .NET
The file names
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public List<string> GetFileNames()
public List<string> GetFileNames()
Public Function GetFileNames As List(Of String)
Public Function GetFileNames As List(Of String)
public:
List<String^>^ GetFileNames()
public:
List<String^>^ GetFileNames()
member GetFileNames : unit -> List<string>

member GetFileNames : unit -> List<string>
Return Value
List <(Of <(<' String >)>)>


GetUserDictionary Method (file)

Keyoti RapidSpell Desktop .NET API Docs
GetUserDictionary Method (file)
API ► Keyoti.RapidSpell ► MultiFileUserDictionary ► GetUserDictionary(String)
Keyoti RapidSpell Desktop .NET
Gets the UserDictionary associated with the specified path.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UserDictionary GetUserDictionary(
    string file
)
public UserDictionary GetUserDictionary(
    string file
)
Public Function GetUserDictionary (
    file As String
) As UserDictionary
Public Function GetUserDictionary (
    file As String
) As UserDictionary
public:
UserDictionary^ GetUserDictionary(
    String^ file
)
public:
UserDictionary^ GetUserDictionary(
    String^ file
)
member GetUserDictionary :
        file : string -> UserDictionary

member GetUserDictionary :
        file : string -> UserDictionary
Parameters
file (String)
Return Value
UserDictionary


IsValid Method

Keyoti RapidSpell Desktop .NET API Docs
IsValid Method
API ► Keyoti.RapidSpell ► MultiFileUserDictionary ► IsValid()()()()
Keyoti RapidSpell Desktop .NET
Whether a problem has occurred.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override bool IsValid()
public override bool IsValid()
Public Overrides Function IsValid As Boolean
Public Overrides Function IsValid As Boolean
public:
virtual bool IsValid() override
public:
virtual bool IsValid() override
abstract IsValid : unit -> bool
override IsValid : unit -> bool
abstract IsValid : unit -> bool
override IsValid : unit -> bool
Return Value
Boolean


ReadAll Method (list)

Keyoti RapidSpell Desktop .NET API Docs
ReadAll Method (list)
API ► Keyoti.RapidSpell ► MultiFileUserDictionary ► ReadAll(ArrayList)
Keyoti RapidSpell Desktop .NET
Reads all words from all files
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override int ReadAll(
    ArrayList list
)
public override int ReadAll(
    ArrayList list
)
Public Overrides Function ReadAll (
    list As ArrayList
) As Integer
Public Overrides Function ReadAll (
    list As ArrayList
) As Integer
public:
virtual int ReadAll(
    ArrayList^ list
) override
public:
virtual int ReadAll(
    ArrayList^ list
) override
abstract ReadAll :
        list : ArrayList -> int
override ReadAll :
        list : ArrayList -> int
abstract ReadAll :
        list : ArrayList -> int
override ReadAll :
        list : ArrayList -> int
Parameters
list (ArrayList)
Return Value
Int32


ReloadDictionary Method

Keyoti RapidSpell Desktop .NET API Docs
ReloadDictionary Method
API ► Keyoti.RapidSpell ► MultiFileUserDictionary ► ReloadDictionary()()()()
Keyoti RapidSpell Desktop .NET
Reload
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override bool ReloadDictionary()
public override bool ReloadDictionary()
Public Overrides Function ReloadDictionary As Boolean
Public Overrides Function ReloadDictionary As Boolean
public:
virtual bool ReloadDictionary() override
public:
virtual bool ReloadDictionary() override
abstract ReloadDictionary : unit -> bool
override ReloadDictionary : unit -> bool
abstract ReloadDictionary : unit -> bool
override ReloadDictionary : unit -> bool
Return Value
Boolean


RemoveFile Method (file)

Keyoti RapidSpell Desktop .NET API Docs
RemoveFile Method (file)
API ► Keyoti.RapidSpell ► MultiFileUserDictionary ► RemoveFile(String)
Keyoti RapidSpell Desktop .NET
Removes a user dictionary from the collection
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void RemoveFile(
    string file
)
public virtual void RemoveFile(
    string file
)
Public Overridable Sub RemoveFile (
    file As String
)
Public Overridable Sub RemoveFile (
    file As String
)
public:
virtual void RemoveFile(
    String^ file
)
public:
virtual void RemoveFile(
    String^ file
)
abstract RemoveFile :
        file : string -> unit
override RemoveFile :
        file : string -> unit
abstract RemoveFile :
        file : string -> unit
override RemoveFile :
        file : string -> unit
Parameters
file (String)
Path


RemoveWord Method (word)

Keyoti RapidSpell Desktop .NET API Docs
RemoveWord Method (word)
API ► Keyoti.RapidSpell ► MultiFileUserDictionary ► RemoveWord(String)
Keyoti RapidSpell Desktop .NET
Removes a word from the default dictionary
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override bool RemoveWord(
    string word
)
public override bool RemoveWord(
    string word
)
Public Overrides Function RemoveWord (
    word As String
) As Boolean
Public Overrides Function RemoveWord (
    word As String
) As Boolean
public:
virtual bool RemoveWord(
    String^ word
) override
public:
virtual bool RemoveWord(
    String^ word
) override
abstract RemoveWord :
        word : string -> bool
override RemoveWord :
        word : string -> bool
abstract RemoveWord :
        word : string -> bool
override RemoveWord :
        word : string -> bool
Parameters
word (String)
Return Value
Boolean


SaveList Method (newList)

Keyoti RapidSpell Desktop .NET API Docs
SaveList Method (newList)
API ► Keyoti.RapidSpell ► MultiFileUserDictionary ► SaveList(ArrayList)
Keyoti RapidSpell Desktop .NET
Save
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override void SaveList(
    ArrayList newList
)
public override void SaveList(
    ArrayList newList
)
Public Overrides Sub SaveList (
    newList As ArrayList
)
Public Overrides Sub SaveList (
    newList As ArrayList
)
public:
virtual void SaveList(
    ArrayList^ newList
) override
public:
virtual void SaveList(
    ArrayList^ newList
) override
abstract SaveList :
        newList : ArrayList -> unit
override SaveList :
        newList : ArrayList -> unit
abstract SaveList :
        newList : ArrayList -> unit
override SaveList :
        newList : ArrayList -> unit
Parameters
newList (ArrayList)


SetDefaultUserDictionaryFile Method (defaultUserDictionaryFileName)

Keyoti RapidSpell Desktop .NET API Docs
SetDefaultUserDictionaryFile Method (defaultUserDictionaryFileName)
API ► Keyoti.RapidSpell ► MultiFileUserDictionary ► SetDefaultUserDictionaryFile(String)
Keyoti RapidSpell Desktop .NET
Sets the default user dictionary
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void SetDefaultUserDictionaryFile(
    string defaultUserDictionaryFileName
)
public void SetDefaultUserDictionaryFile(
    string defaultUserDictionaryFileName
)
Public Sub SetDefaultUserDictionaryFile (
    defaultUserDictionaryFileName As String
)
Public Sub SetDefaultUserDictionaryFile (
    defaultUserDictionaryFileName As String
)
public:
void SetDefaultUserDictionaryFile(
    String^ defaultUserDictionaryFileName
)
public:
void SetDefaultUserDictionaryFile(
    String^ defaultUserDictionaryFileName
)
member SetDefaultUserDictionaryFile :
        defaultUserDictionaryFileName : string -> unit

member SetDefaultUserDictionaryFile :
        defaultUserDictionaryFileName : string -> unit
Parameters
defaultUserDictionaryFileName (String)


SetFiles Method (supplementalUserDictionaryFiles)

Keyoti RapidSpell Desktop .NET API Docs
SetFiles Method (supplementalUserDictionaryFiles)
API ► Keyoti.RapidSpell ► MultiFileUserDictionary ► SetFiles(List<(Of <<'(String>)>>))
Keyoti RapidSpell Desktop .NET
Sets user dictionaries in the collection
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void SetFiles(
    List<string> supplementalUserDictionaryFiles
)
public virtual void SetFiles(
    List<string> supplementalUserDictionaryFiles
)
Public Overridable Sub SetFiles (
    supplementalUserDictionaryFiles As List(Of String)
)
Public Overridable Sub SetFiles (
    supplementalUserDictionaryFiles As List(Of String)
)
public:
virtual void SetFiles(
    List<String^>^ supplementalUserDictionaryFiles
)
public:
virtual void SetFiles(
    List<String^>^ supplementalUserDictionaryFiles
)
abstract SetFiles :
        supplementalUserDictionaryFiles : List<string> -> unit
override SetFiles :
        supplementalUserDictionaryFiles : List<string> -> unit
abstract SetFiles :
        supplementalUserDictionaryFiles : List<string> -> unit
override SetFiles :
        supplementalUserDictionaryFiles : List<string> -> unit
Parameters
supplementalUserDictionaryFiles (List <(Of <(<' String >)>)>)


NeedRapidSpellAsYouTypeAgentEventArgs Class

Keyoti RapidSpell Desktop .NET API Docs
NeedRapidSpellAsYouTypeAgentEventArgs Class
API ► Keyoti.RapidSpell ► NeedRapidSpellAsYouTypeAgentEventArgs
Keyoti RapidSpell Desktop .NET
Event args for NeedRapidSpellAsYouTypeAgent event. Specify a NewAgent to override default behaviour.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class NeedRapidSpellAsYouTypeAgentEventArgs : EventArgs
public class NeedRapidSpellAsYouTypeAgentEventArgs : EventArgs
Public Class NeedRapidSpellAsYouTypeAgentEventArgs
    Inherits EventArgs
Public Class NeedRapidSpellAsYouTypeAgentEventArgs
    Inherits EventArgs
public ref class NeedRapidSpellAsYouTypeAgentEventArgs : public EventArgs
public ref class NeedRapidSpellAsYouTypeAgentEventArgs : public EventArgs
type NeedRapidSpellAsYouTypeAgentEventArgs =
    class
        inherit EventArgs
    end
type NeedRapidSpellAsYouTypeAgentEventArgs =
    class
        inherit EventArgs
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NeedRapidSpellAsYouTypeAgentEventArgs()()()() | New
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewAgent | Instance of RapidSpellAsYouTypeAgent or subclass to use.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | NeedRapidSpellAsYouTypeAgentEventArgs


NeedRapidSpellAsYouTypeAgentEventArgs Constructor

Keyoti RapidSpell Desktop .NET API Docs
NeedRapidSpellAsYouTypeAgentEventArgs Constructor
API ► Keyoti.RapidSpell ► NeedRapidSpellAsYouTypeAgentEventArgs ► NeedRapidSpellAsYouTypeAgentEventArgs()()()()
Keyoti RapidSpell Desktop .NET
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public NeedRapidSpellAsYouTypeAgentEventArgs()
public NeedRapidSpellAsYouTypeAgentEventArgs()
Public Sub New
Public Sub New
public:
NeedRapidSpellAsYouTypeAgentEventArgs()
public:
NeedRapidSpellAsYouTypeAgentEventArgs()
new : unit -> NeedRapidSpellAsYouTypeAgentEventArgs
new : unit -> NeedRapidSpellAsYouTypeAgentEventArgs


NewAgent Property

Keyoti RapidSpell Desktop .NET API Docs
NewAgent Property
API ► Keyoti.RapidSpell ► NeedRapidSpellAsYouTypeAgentEventArgs ► NewAgent
Keyoti RapidSpell Desktop .NET
Instance of RapidSpellAsYouTypeAgent or subclass to use.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public RapidSpellAsYouTypeAgent NewAgent { get; set; }
public RapidSpellAsYouTypeAgent NewAgent { get; set; }
Public Property NewAgent As RapidSpellAsYouTypeAgent
    Get
    Set
Public Property NewAgent As RapidSpellAsYouTypeAgent
    Get
    Set
public:
property RapidSpellAsYouTypeAgent^ NewAgent {
    RapidSpellAsYouTypeAgent^ get ();
    void set (RapidSpellAsYouTypeAgent^ value);
}
public:
property RapidSpellAsYouTypeAgent^ NewAgent {
    RapidSpellAsYouTypeAgent^ get ();
    void set (RapidSpellAsYouTypeAgent^ value);
}
member NewAgent : RapidSpellAsYouTypeAgent with get, set

member NewAgent : RapidSpellAsYouTypeAgent with get, set
Property Value
RapidSpellAsYouTypeAgent


NeedRapidSpellAsYouTypeAgentEventHandler Delegate

Keyoti RapidSpell Desktop .NET API Docs
NeedRapidSpellAsYouTypeAgentEventHandler Delegate
API ► Keyoti.RapidSpell ► NeedRapidSpellAsYouTypeAgentEventHandler
Keyoti RapidSpell Desktop .NET
Event delegate.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void NeedRapidSpellAsYouTypeAgentEventHandler(
    Object sender,
    NeedRapidSpellAsYouTypeAgentEventArgs e
)
public delegate void NeedRapidSpellAsYouTypeAgentEventHandler(
    Object sender,
    NeedRapidSpellAsYouTypeAgentEventArgs e
)
Public Delegate Sub NeedRapidSpellAsYouTypeAgentEventHandler (
    sender As Object,
    e As NeedRapidSpellAsYouTypeAgentEventArgs
)
Public Delegate Sub NeedRapidSpellAsYouTypeAgentEventHandler (
    sender As Object,
    e As NeedRapidSpellAsYouTypeAgentEventArgs
)
public delegate void NeedRapidSpellAsYouTypeAgentEventHandler(
    Object^ sender,
    NeedRapidSpellAsYouTypeAgentEventArgs^ e
)
public delegate void NeedRapidSpellAsYouTypeAgentEventHandler(
    Object^ sender,
    NeedRapidSpellAsYouTypeAgentEventArgs^ e
)
type NeedRapidSpellAsYouTypeAgentEventHandler =
    delegate of
        sender : Object *
        e : NeedRapidSpellAsYouTypeAgentEventArgs -> unit
type NeedRapidSpellAsYouTypeAgentEventHandler =
    delegate of
        sender : Object *
        e : NeedRapidSpellAsYouTypeAgentEventArgs -> unit
Parameters
sender (Object)
e (NeedRapidSpellAsYouTypeAgentEventArgs)


NoCurrentBadWordException Class

Keyoti RapidSpell Desktop .NET API Docs
NoCurrentBadWordException Class
API ► Keyoti.RapidSpell ► NoCurrentBadWordException
Keyoti RapidSpell Desktop .NET
Thrown if NextBadWord has not been run first and found a mis-spelled word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
[SerializableAttribute]
public class NoCurrentBadWordException : ApplicationException
[SerializableAttribute]
public class NoCurrentBadWordException : ApplicationException
<SerializableAttribute>
Public Class NoCurrentBadWordException
    Inherits ApplicationException
<SerializableAttribute>
Public Class NoCurrentBadWordException
    Inherits ApplicationException
[SerializableAttribute]
public ref class NoCurrentBadWordException : public ApplicationException
[SerializableAttribute]
public ref class NoCurrentBadWordException : public ApplicationException
[<SerializableAttribute>]
type NoCurrentBadWordException =
    class
        inherit ApplicationException
    end
[<SerializableAttribute>]
type NoCurrentBadWordException =
    class
        inherit ApplicationException
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NoCurrentBadWordException()()()() | Create a new instance with no message.
 | NoCurrentBadWordException(String) | Create a new instance with mesg as a message.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | ApplicationException
 |  |  | NoCurrentBadWordException


NoCurrentBadWordException Constructor

Keyoti RapidSpell Desktop .NET API Docs
NoCurrentBadWordException Constructor
API ► Keyoti.RapidSpell ► NoCurrentBadWordException ► NoCurrentBadWordException()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | NoCurrentBadWordException()()()() | Create a new instance with no message.
 | NoCurrentBadWordException(String) | Create a new instance with mesg as a message.


NoCurrentBadWordException Constructor

Keyoti RapidSpell Desktop .NET API Docs
NoCurrentBadWordException Constructor
API ► Keyoti.RapidSpell ► NoCurrentBadWordException ► NoCurrentBadWordException()()()()
Keyoti RapidSpell Desktop .NET
Create a new instance with no message.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public NoCurrentBadWordException()
public NoCurrentBadWordException()
Public Sub New
Public Sub New
public:
NoCurrentBadWordException()
public:
NoCurrentBadWordException()
new : unit -> NoCurrentBadWordException
new : unit -> NoCurrentBadWordException


NoCurrentBadWordException Constructor (mesg)

Keyoti RapidSpell Desktop .NET API Docs
NoCurrentBadWordException Constructor (mesg)
API ► Keyoti.RapidSpell ► NoCurrentBadWordException ► NoCurrentBadWordException(String)
Keyoti RapidSpell Desktop .NET
Create a new instance with mesg as a message.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public NoCurrentBadWordException(
    string mesg
)
public NoCurrentBadWordException(
    string mesg
)
Public Sub New (
    mesg As String
)
Public Sub New (
    mesg As String
)
public:
NoCurrentBadWordException(
    String^ mesg
)
public:
NoCurrentBadWordException(
    String^ mesg
)
new :
        mesg : string -> NoCurrentBadWordException
new :
        mesg : string -> NoCurrentBadWordException
Parameters
mesg (String)


NoTextComponentException Class

Keyoti RapidSpell Desktop .NET API Docs
NoTextComponentException Class
API ► Keyoti.RapidSpell ► NoTextComponentException
Keyoti RapidSpell Desktop .NET
Thrown if a valid text component hasn't been set to be checked (by the GUI for example).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class NoTextComponentException : Exception
public class NoTextComponentException : Exception
Public Class NoTextComponentException
    Inherits Exception
Public Class NoTextComponentException
    Inherits Exception
public ref class NoTextComponentException : public Exception
public ref class NoTextComponentException : public Exception
type NoTextComponentException =
    class
        inherit Exception
    end
type NoTextComponentException =
    class
        inherit Exception
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NoTextComponentException()()()() | Create a new instance with no message.
 | NoTextComponentException(String) | Create a new instance with mesg as a message.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | NoTextComponentException


NoTextComponentException Constructor

Keyoti RapidSpell Desktop .NET API Docs
NoTextComponentException Constructor
API ► Keyoti.RapidSpell ► NoTextComponentException ► NoTextComponentException()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | NoTextComponentException()()()() | Create a new instance with no message.
 | NoTextComponentException(String) | Create a new instance with mesg as a message.


NoTextComponentException Constructor

Keyoti RapidSpell Desktop .NET API Docs
NoTextComponentException Constructor
API ► Keyoti.RapidSpell ► NoTextComponentException ► NoTextComponentException()()()()
Keyoti RapidSpell Desktop .NET
Create a new instance with no message.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public NoTextComponentException()
public NoTextComponentException()
Public Sub New
Public Sub New
public:
NoTextComponentException()
public:
NoTextComponentException()
new : unit -> NoTextComponentException
new : unit -> NoTextComponentException


NoTextComponentException Constructor (mesg)

Keyoti RapidSpell Desktop .NET API Docs
NoTextComponentException Constructor (mesg)
API ► Keyoti.RapidSpell ► NoTextComponentException ► NoTextComponentException(String)
Keyoti RapidSpell Desktop .NET
Create a new instance with mesg as a message.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public NoTextComponentException(
    string mesg
)
public NoTextComponentException(
    string mesg
)
Public Sub New (
    mesg As String
)
Public Sub New (
    mesg As String
)
public:
NoTextComponentException(
    String^ mesg
)
public:
NoTextComponentException(
    String^ mesg
)
new :
        mesg : string -> NoTextComponentException
new :
        mesg : string -> NoTextComponentException
Parameters
mesg (String)


OperationScope Enumeration

Keyoti RapidSpell Desktop .NET API Docs
OperationScope Enumeration
API ► Keyoti.RapidSpell ► OperationScope
Keyoti RapidSpell Desktop .NET
The scope of an operation.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public enum OperationScope
public enum OperationScope
Public Enumeration OperationScope
Public Enumeration OperationScope
public enum class OperationScope
public enum class OperationScope
type OperationScope
type OperationScope
Members
Member | Description
AllAssignedTextBoxes | Perform operation on all assigned text boxes.
CurrentTextBox | Perform operation on current text box only.


OptionsSavedEventArgs Class

Keyoti RapidSpell Desktop .NET API Docs
OptionsSavedEventArgs Class
API ► Keyoti.RapidSpell ► OptionsSavedEventArgs
Keyoti RapidSpell Desktop .NET
Args for the options saved event.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class OptionsSavedEventArgs : EventArgs
public class OptionsSavedEventArgs : EventArgs
Public Class OptionsSavedEventArgs
    Inherits EventArgs
Public Class OptionsSavedEventArgs
    Inherits EventArgs
public ref class OptionsSavedEventArgs : public EventArgs
public ref class OptionsSavedEventArgs : public EventArgs
type OptionsSavedEventArgs =
    class
        inherit EventArgs
    end
type OptionsSavedEventArgs =
    class
        inherit EventArgs
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OptionsSavedEventArgs(Boolean) | New instance
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TextRecheckRequired | Whether the change in options requires the text to be rechecked.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | OptionsSavedEventArgs


OptionsSavedEventArgs Constructor (textRecheckRequired)

Keyoti RapidSpell Desktop .NET API Docs
OptionsSavedEventArgs Constructor (textRecheckRequired)
API ► Keyoti.RapidSpell ► OptionsSavedEventArgs ► OptionsSavedEventArgs(Boolean)
Keyoti RapidSpell Desktop .NET
New instance
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public OptionsSavedEventArgs(
    bool textRecheckRequired
)
public OptionsSavedEventArgs(
    bool textRecheckRequired
)
Public Sub New (
    textRecheckRequired As Boolean
)
Public Sub New (
    textRecheckRequired As Boolean
)
public:
OptionsSavedEventArgs(
    bool textRecheckRequired
)
public:
OptionsSavedEventArgs(
    bool textRecheckRequired
)
new :
        textRecheckRequired : bool -> OptionsSavedEventArgs
new :
        textRecheckRequired : bool -> OptionsSavedEventArgs
Parameters
textRecheckRequired (Boolean)
Whether the change in options requires the text to be rechecked.


TextRecheckRequired Property

Keyoti RapidSpell Desktop .NET API Docs
TextRecheckRequired Property
API ► Keyoti.RapidSpell ► OptionsSavedEventArgs ► TextRecheckRequired
Keyoti RapidSpell Desktop .NET
Whether the change in options requires the text to be rechecked.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool TextRecheckRequired { get; }
public bool TextRecheckRequired { get; }
Public ReadOnly Property TextRecheckRequired As Boolean
    Get
Public ReadOnly Property TextRecheckRequired As Boolean
    Get
public:
property bool TextRecheckRequired {
    bool get ();
}
public:
property bool TextRecheckRequired {
    bool get ();
}
member TextRecheckRequired : bool with get

member TextRecheckRequired : bool with get
Property Value
Boolean


OptionsSavedEventHandler Delegate

Keyoti RapidSpell Desktop .NET API Docs
OptionsSavedEventHandler Delegate
API ► Keyoti.RapidSpell ► OptionsSavedEventHandler
Keyoti RapidSpell Desktop .NET
Handler
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void OptionsSavedEventHandler(
    Object sender,
    OptionsSavedEventArgs e
)
public delegate void OptionsSavedEventHandler(
    Object sender,
    OptionsSavedEventArgs e
)
Public Delegate Sub OptionsSavedEventHandler (
    sender As Object,
    e As OptionsSavedEventArgs
)
Public Delegate Sub OptionsSavedEventHandler (
    sender As Object,
    e As OptionsSavedEventArgs
)
public delegate void OptionsSavedEventHandler(
    Object^ sender,
    OptionsSavedEventArgs^ e
)
public delegate void OptionsSavedEventHandler(
    Object^ sender,
    OptionsSavedEventArgs^ e
)
type OptionsSavedEventHandler =
    delegate of
        sender : Object *
        e : OptionsSavedEventArgs -> unit
type OptionsSavedEventHandler =
    delegate of
        sender : Object *
        e : OptionsSavedEventArgs -> unit
Parameters
sender (Object)
e (OptionsSavedEventArgs)


RapidSpellAsYouType Class

Keyoti RapidSpell Desktop .NET API Docs
RapidSpellAsYouType Class
API ► Keyoti.RapidSpell ► RapidSpellAsYouType
Keyoti RapidSpell Desktop .NET
RapidSpell Desktop As-You-Type Control, spell checks text boxes as the user types.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class RapidSpellAsYouType : Component
public class RapidSpellAsYouType : Component
Public Class RapidSpellAsYouType
    Inherits Component
Public Class RapidSpellAsYouType
    Inherits Component
public ref class RapidSpellAsYouType : public Component
public ref class RapidSpellAsYouType : public Component
type RapidSpellAsYouType =
    class
        inherit Component
    end
type RapidSpellAsYouType =
    class
        inherit Component
    end
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RapidSpellAsYouType()()()() | Default constructor.
 | RapidSpellAsYouType(IContainer) | Designer constructor.
 | AddMenuItem_Click()()()() | Handles add menu item clicks.
 | AddMenuText | Add button text.
 | AddTextBoxBase(TextBoxBase) | Add a text component to be checked to the collection.
 | AddTextComponent(IAYTTextBox) | Add a text component to be checked to the collection.
 | AllowAnyCase | Whether to allow words spelt with incorrect case, eg. "africa", instead of "Africa", this is more relaxed than AllowMixedCase
 | AllowMixedCase | Whether to allow words spelt with mixed case, eg. "MIxEd"
 | AutoCheckAllTextComponentsUnder(Control) | When set, will check all text boxes under this control. NOTE this overrides the TextComponent(s) property. This method should be called once the form has loaded, otherwise the child controls in textComponentsUnder may not have been set.
 | AutoCorrectEnabled | Whether to auto-correct common spelling/typographical mistakes (default is English errors).
 | AutoCorrectionMap | A map of common errors and their corrections.
 | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
 | ChangeWordMenuItem_Click(String, Boolean) | Handles change word menu clicks
 | CheckAsYouType | Whether to spell check words as the user types/modifies text.
 | CheckCompoundWords | Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
 | CheckDisabledTextBoxes | Whether to spell check textboxes which are disabled.
 | checkFromPosition | Index of of character in text to check from.
 | CheckReadOnlyTextBoxes | Whether to spell check textboxes which are readonly.
 | ClearAllHighlights()()()() | Clears all spell check highlights (underlines) from the whole document.
 | ClearTextComponents()()()() | Removes all text components from being spell checked.
 | ConsiderationRange | Sets the factor for words to consider for suggestions, lower values are faster but consider less words for suggestions. Default is 500. If w <= 1 this method won't do anything.
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | ContextMenuStripEnabled | Whether to show the suggestion context menu through a ContextMenuStrip (true) or a ContextMenu (false).
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | DictFilePath | The file to be used as the main dictionary (either a full file path, or the name of an embedded resource), if this is null then the built-in US English dictionary is used.
 | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | Finalize()()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | FindCapitalizedSuggestions | Whether to look for capitalized suggestions, note this will slow FindSuggestions down by about 7 times.
 | ForceCheckAll()()()() | Forces a check of the whole document.
 | FoundSpellingError | Fired when a spelling error is found.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetNumberOfCurrentSpellingErrors(TextBoxBase) | Returns the number of spelling errors currently in the tb, where tb is a textbox currently being spell checked.
 | GetNumberOfCurrentSpellingErrors(IAYTTextBox) | Returns the number of spelling errors currently in the tb, where tb is a textbox currently being spell checked.
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetSuggestionContextMenuInformation()()()() | Gets information about the context menu that should be shown
 | GetSuggestions()()()() | Returns suggestions menu items for the last right clicked word. Null/Nothing if none.
 | GetSuggestionsToolStripItems()()()() | Returns suggestions menu items as ToolStripItems for the last right clicked word. Null/Nothing if none.
 | GetTextComponents()()()() | Gets the text components being spell checked.
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GUILanguage | The language to show the UI in.
 | IgnoreAllMenuItem_Click()()()() | Handles ignore all menu clicks.
 | IgnoreAllMenuText | Ignore All button text.
 | IgnoreCapitalizedWords | Whether to ignore words with capital letters.
 | IgnoreIncorrectSentenceCapitalization | Whether to ignore incorrect sentence capitalization.
 | IgnoreInEnglishLowerCaseI | Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
 | IgnoreMenuText | Ignore button text.
 | IgnoreOnce(BadWord, IAYTTextBox) | Ignores an instance of a bad word in the the textbox.
 | IgnoreOnce(BadWord, TextBoxBase) | Ignores an instance of a bad word in the the textbox.
 | IgnoreOnceMenuItem_Click()()()() | Handles ignore once menu clicks.
 | IgnoreURLsAndEmailAddresses | Whether to ignore URLs and email addresses (requires V2Parser=true)
 | IgnoreWordsWithDigits | Whether to ignore words with numbers in them (eg. A10 or 7-11).
 | IgnoreXML | Whether to ignore XML/HTML tags, false by default.
 | IncludeUserDictionaryInSuggestions | Whether the user dictionary should be used in finding suggestions for misspelt words.
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | LanguageParser | The type of language parsing to use.
 | LookIntoHyphenatedText | Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NeedRapidSpellAsYouTypeAgent | Fired when a new RapidSpellAsYouTypeAgent object is needed.
 | OnFoundSpellingError(FoundSpellingErrorEventArgs, Boolean) | Raises the FoundSpellingError event
 | OnNeedRapidSpellAsYouTypeAgent(NeedRapidSpellAsYouTypeAgentEventArgs) | Fires NeedRapidSpellAsYouTypeAgent
 | OnSpellContextMenuRequest(SpellContextMenuEventArgs) | Fires event when a context menu is requested
 | OnWordAdded(WordAddedEventArgs) | Fires event when a word is added to the user dictionary
 | OnWordChanged(WordChangedEventArgs) | Fires event when a word is changed
 | OnWordIgnored(WordIgnoredEventArgs) | Fires event when a word is ignored
 | OnWordsEntered(WordsEnteredEventArgs) | Fires event when a word is entered into the textbox
 | Options | Object responsible for holding, loading and saving the user's spell check options.
 | OptionsEnabled | Whether to use user options.
 | OptionsFileName | The file name used to store the settings (by default in IsolatedStorage).
 | OptionsPresenter | Presenter for the user options form (IDialogViewOptions).
 | OptionsStorageLocation | Where the user's options are stored.
 | RapidSpellChecker | The core spell checker object
 | RecheckTextOnPropertyChange | Whether to recheck the text when properties that affect the spell check change.
 | RemoveAllTextComponents()()()() | Removes all text components to be checked from the collection.
 | RemoveDuplicateWordText | Remove duplicate word text
 | RemoveTextBoxBase(TextBoxBase) | Remove a text component to be checked from the collection.
 | RemoveTextComponent(IAYTTextBox) | Remove a text component to be checked from the collection.
 | RepaintUnderlines()()()() | Repaints the underlines, this should be called if any changes are made to layout, such as changes to font sizes, etc.
 | ResetIgnoredWords()()()() | Resets all ignored words, so that the document will be rechecked.
 | SeparateHyphenWords | Whether to treat hyphenated (-) words as separate words, default is false.
 | SetRepaintTimer(Int32) | If set to a value other than 0, the underline painting will not be performed until the timer has elapsed. This has a resolution of 250 milliseconds.
 | ShowAddMenuOption | Whether to show the Add option in the context menu.
 | ShowCutCopyPasteMenuOnTextBoxBase | Whether to show a cut copy paste context menu on TextBoxBase controls being checked.
 | ShowSuggestionsContextMenu | Whether to show a context menu with suggestions when a misspelt word is right clicked, has no effect on developer set context menu.
 | ShowSuggestionsWhenTextIsSelected | Whether to show the spelling context menu regardless of whether text is currently selected.
 | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
 | SpellCheckFinished | Fired when checking finishes
 | SpellCheckStarted | Fired when checking starts
 | SpellContextMenuRequest | Fired when a request is made (usually by a right click on an underlined word) for context menu
 | SuggestionsMethod | The suggestions method to use.
 | SuggestSplitWords | Whether to look for connected words in suggestions.
 | TextBoundary | The AdvancedTextBoundary class to use to parse words.
 | TextBoxBase | The TextBoxBase text box to check as the user types/modifies text. Do NOT set an AYTRichTextBox or AYTTextBox control here, use the TextComponent property instead.
 | TextComponent | The IAYTTextBox text box to check as the user types/modifies text.
 | TextComponents | The IAYTTextBox text boxes to check as the user types/modifies text.
 | ToString()()()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
 | UnderlineColor | The underline color to use with mis-spelt words.
 | UnderlineStyle | The underline style to use with mis-spelt words.
 | UnignoreWord(BadWord, IAYTTextBox) | Unignores an instance of a bad word in the textbox.
 | UnignoreWord(BadWord, TextBoxBase) | Unignores an instance of a bad word in the textbox.
 | UnignoreWord(BadWord) | Unignores an instance of a bad word in all textboxes.
 | UpdateAllTextBoxes | Whether to update all text boxes when ForceCheckAll is called, usually this should be true.
 | UserDictionaryFile | The user dictionary file, if this file doesn't exist it will be created.
 | V2Parser | Whether to use parser version 2 - Set to false for backwards (pre v3.4) compatibility.
 | WarnDuplicates | Whether to show duplicate words as errors (eg. "this is is an error").
 | WordAdded | Fired when word added to user dictionary
 | WordChanged | Fired when word changed
 | WordIgnored | Fired when word ignored
 | WordsEntered | Fired when words have been entered (typed or pasted).
Remarks
This class works with IAYTTextBox interface classes. RichTextBox and TextBox subclasses are included. This class not only checks as the user types, but also follows any text modifying actions, such as; Cut, paste, selection delete etc.
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | RapidSpellAsYouType


RapidSpellAsYouType Constructor

Keyoti RapidSpell Desktop .NET API Docs
RapidSpellAsYouType Constructor
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► RapidSpellAsYouType()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | RapidSpellAsYouType()()()() | Default constructor.
 | RapidSpellAsYouType(IContainer) | Designer constructor.


RapidSpellAsYouType Constructor

Keyoti RapidSpell Desktop .NET API Docs
RapidSpellAsYouType Constructor
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► RapidSpellAsYouType()()()()
Keyoti RapidSpell Desktop .NET
Default constructor.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public RapidSpellAsYouType()
public RapidSpellAsYouType()
Public Sub New
Public Sub New
public:
RapidSpellAsYouType()
public:
RapidSpellAsYouType()
new : unit -> RapidSpellAsYouType
new : unit -> RapidSpellAsYouType


RapidSpellAsYouType Constructor (container)

Keyoti RapidSpell Desktop .NET API Docs
RapidSpellAsYouType Constructor (container)
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► RapidSpellAsYouType(IContainer)
Keyoti RapidSpell Desktop .NET
Designer constructor.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public RapidSpellAsYouType(
    IContainer container
)
public RapidSpellAsYouType(
    IContainer container
)
Public Sub New (
    container As IContainer
)
Public Sub New (
    container As IContainer
)
public:
RapidSpellAsYouType(
    IContainer^ container
)
public:
RapidSpellAsYouType(
    IContainer^ container
)
new :
        container : IContainer -> RapidSpellAsYouType
new :
        container : IContainer -> RapidSpellAsYouType
Parameters
container (IContainer)


AddMenuItem_Click Method

Keyoti RapidSpell Desktop .NET API Docs
AddMenuItem_Click Method
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► AddMenuItem_Click()()()()
Keyoti RapidSpell Desktop .NET
Handles add menu item clicks.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void AddMenuItem_Click()
public void AddMenuItem_Click()
Public Sub AddMenuItem_Click
Public Sub AddMenuItem_Click
public:
void AddMenuItem_Click()
public:
void AddMenuItem_Click()
member AddMenuItem_Click : unit -> unit

member AddMenuItem_Click : unit -> unit


AddMenuText Property

Keyoti RapidSpell Desktop .NET API Docs
AddMenuText Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► AddMenuText
Keyoti RapidSpell Desktop .NET
Add button text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string AddMenuText { get; set; }
public string AddMenuText { get; set; }
Public Property AddMenuText As String
    Get
    Set
Public Property AddMenuText As String
    Get
    Set
public:
property String^ AddMenuText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ AddMenuText {
    String^ get ();
    void set (String^ value);
}
member AddMenuText : string with get, set

member AddMenuText : string with get, set
Property Value
String


AddTextBoxBase Method (textComponent)

Keyoti RapidSpell Desktop .NET API Docs
AddTextBoxBase Method (textComponent)
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► AddTextBoxBase(TextBoxBase)
Keyoti RapidSpell Desktop .NET
Add a text component to be checked to the collection.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void AddTextBoxBase(
    TextBoxBase textComponent
)
public virtual void AddTextBoxBase(
    TextBoxBase textComponent
)
Public Overridable Sub AddTextBoxBase (
    textComponent As TextBoxBase
)
Public Overridable Sub AddTextBoxBase (
    textComponent As TextBoxBase
)
public:
virtual void AddTextBoxBase(
    TextBoxBase^ textComponent
)
public:
virtual void AddTextBoxBase(
    TextBoxBase^ textComponent
)
abstract AddTextBoxBase :
        textComponent : TextBoxBase -> unit
override AddTextBoxBase :
        textComponent : TextBoxBase -> unit
abstract AddTextBoxBase :
        textComponent : TextBoxBase -> unit
override AddTextBoxBase :
        textComponent : TextBoxBase -> unit
Parameters
textComponent (TextBoxBase)
The text box to be spell checked
Remarks
If textboxes are to be dynamically added/removed from the collection of textboxes to check, call this and RemoveTextComponent


AddTextComponent Method (textComponent)

Keyoti RapidSpell Desktop .NET API Docs
AddTextComponent Method (textComponent)
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► AddTextComponent(IAYTTextBox)
Keyoti RapidSpell Desktop .NET
Add a text component to be checked to the collection.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void AddTextComponent(
    IAYTTextBox textComponent
)
public virtual void AddTextComponent(
    IAYTTextBox textComponent
)
Public Overridable Sub AddTextComponent (
    textComponent As IAYTTextBox
)
Public Overridable Sub AddTextComponent (
    textComponent As IAYTTextBox
)
public:
virtual void AddTextComponent(
    IAYTTextBox^ textComponent
)
public:
virtual void AddTextComponent(
    IAYTTextBox^ textComponent
)
abstract AddTextComponent :
        textComponent : IAYTTextBox -> unit
override AddTextComponent :
        textComponent : IAYTTextBox -> unit
abstract AddTextComponent :
        textComponent : IAYTTextBox -> unit
override AddTextComponent :
        textComponent : IAYTTextBox -> unit
Parameters
textComponent (IAYTTextBox)
The text box to be spell checked
Remarks
If textboxes are to be dynamically added/removed from the collection of textboxes to check, call this and RemoveTextComponent


AllowAnyCase Property

Keyoti RapidSpell Desktop .NET API Docs
AllowAnyCase Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► AllowAnyCase
Keyoti RapidSpell Desktop .NET
Whether to allow words spelt with incorrect case, eg. "africa", instead of "Africa", this is more relaxed than AllowMixedCase
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool AllowAnyCase { get; set; }
public bool AllowAnyCase { get; set; }
Public Property AllowAnyCase As Boolean
    Get
    Set
Public Property AllowAnyCase As Boolean
    Get
    Set
public:
property bool AllowAnyCase {
    bool get ();
    void set (bool value);
}
public:
property bool AllowAnyCase {
    bool get ();
    void set (bool value);
}
member AllowAnyCase : bool with get, set

member AllowAnyCase : bool with get, set
Property Value
Boolean


AllowMixedCase Property

Keyoti RapidSpell Desktop .NET API Docs
AllowMixedCase Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► AllowMixedCase
Keyoti RapidSpell Desktop .NET
Whether to allow words spelt with mixed case, eg. "MIxEd"
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool AllowMixedCase { get; set; }
public bool AllowMixedCase { get; set; }
Public Property AllowMixedCase As Boolean
    Get
    Set
Public Property AllowMixedCase As Boolean
    Get
    Set
public:
property bool AllowMixedCase {
    bool get ();
    void set (bool value);
}
public:
property bool AllowMixedCase {
    bool get ();
    void set (bool value);
}
member AllowMixedCase : bool with get, set

member AllowMixedCase : bool with get, set
Property Value
Boolean


AutoCheckAllTextComponentsUnder Method (textComponentsUnder)

Keyoti RapidSpell Desktop .NET API Docs
AutoCheckAllTextComponentsUnder Method (textComponentsUnder)
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► AutoCheckAllTextComponentsUnder(Control)
Keyoti RapidSpell Desktop .NET
When set, will check all text boxes under this control. NOTE this overrides the TextComponent(s) property. This method should be called once the form has loaded, otherwise the child controls in textComponentsUnder may not have been set.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void AutoCheckAllTextComponentsUnder(
    Control textComponentsUnder
)
public void AutoCheckAllTextComponentsUnder(
    Control textComponentsUnder
)
Public Sub AutoCheckAllTextComponentsUnder (
    textComponentsUnder As Control
)
Public Sub AutoCheckAllTextComponentsUnder (
    textComponentsUnder As Control
)
public:
void AutoCheckAllTextComponentsUnder(
    Control^ textComponentsUnder
)
public:
void AutoCheckAllTextComponentsUnder(
    Control^ textComponentsUnder
)
member AutoCheckAllTextComponentsUnder :
        textComponentsUnder : Control -> unit

member AutoCheckAllTextComponentsUnder :
        textComponentsUnder : Control -> unit
Parameters
textComponentsUnder (Control)


AutoCorrectEnabled Property

Keyoti RapidSpell Desktop .NET API Docs
AutoCorrectEnabled Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► AutoCorrectEnabled
Keyoti RapidSpell Desktop .NET
Whether to auto-correct common spelling/typographical mistakes (default is English errors).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool AutoCorrectEnabled { get; set; }
public bool AutoCorrectEnabled { get; set; }
Public Property AutoCorrectEnabled As Boolean
    Get
    Set
Public Property AutoCorrectEnabled As Boolean
    Get
    Set
public:
property bool AutoCorrectEnabled {
    bool get ();
    void set (bool value);
}
public:
property bool AutoCorrectEnabled {
    bool get ();
    void set (bool value);
}
member AutoCorrectEnabled : bool with get, set

member AutoCorrectEnabled : bool with get, set
Property Value
Boolean
Remarks
To set a custom list (eg. other languages see AutoCorrectionMap)


AutoCorrectionMap Property

Keyoti RapidSpell Desktop .NET API Docs
AutoCorrectionMap Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► AutoCorrectionMap
Keyoti RapidSpell Desktop .NET
A map of common errors and their corrections.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual Hashtable AutoCorrectionMap { get; set; }
public virtual Hashtable AutoCorrectionMap { get; set; }
Public Overridable Property AutoCorrectionMap As Hashtable
    Get
    Set
Public Overridable Property AutoCorrectionMap As Hashtable
    Get
    Set
public:
virtual property Hashtable^ AutoCorrectionMap {
    Hashtable^ get ();
    void set (Hashtable^ value);
}
public:
virtual property Hashtable^ AutoCorrectionMap {
    Hashtable^ get ();
    void set (Hashtable^ value);
}
abstract AutoCorrectionMap : Hashtable with get, set
override AutoCorrectionMap : Hashtable with get, set
abstract AutoCorrectionMap : Hashtable with get, set
override AutoCorrectionMap : Hashtable with get, set
Property Value
Hashtable
Remarks
To set a custom list (eg. other languages see AutoCorrectionMap)


ChangeWordMenuItem_Click Method (replacementWord, isRemoveDuplicateItem)

Keyoti RapidSpell Desktop .NET API Docs
ChangeWordMenuItem_Click Method (replacementWord, isRemoveDuplicateItem)
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► ChangeWordMenuItem_Click(String, Boolean)
Keyoti RapidSpell Desktop .NET
Handles change word menu clicks
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void ChangeWordMenuItem_Click(
    string replacementWord,
    bool isRemoveDuplicateItem
)
public void ChangeWordMenuItem_Click(
    string replacementWord,
    bool isRemoveDuplicateItem
)
Public Sub ChangeWordMenuItem_Click (
    replacementWord As String,
    isRemoveDuplicateItem As Boolean
)
Public Sub ChangeWordMenuItem_Click (
    replacementWord As String,
    isRemoveDuplicateItem As Boolean
)
public:
void ChangeWordMenuItem_Click(
    String^ replacementWord,
    bool isRemoveDuplicateItem
)
public:
void ChangeWordMenuItem_Click(
    String^ replacementWord,
    bool isRemoveDuplicateItem
)
member ChangeWordMenuItem_Click :
        replacementWord : string *
        isRemoveDuplicateItem : bool -> unit

member ChangeWordMenuItem_Click :
        replacementWord : string *
        isRemoveDuplicateItem : bool -> unit
Parameters
replacementWord (String)
The new word to replace the current error
isRemoveDuplicateItem (Boolean)
Whether the change is actually to remove duplicate (in which case 'replacementWord' can be null)


CheckAsYouType Property

Keyoti RapidSpell Desktop .NET API Docs
CheckAsYouType Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► CheckAsYouType
Keyoti RapidSpell Desktop .NET
Whether to spell check words as the user types/modifies text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool CheckAsYouType { get; set; }
public bool CheckAsYouType { get; set; }
Public Property CheckAsYouType As Boolean
    Get
    Set
Public Property CheckAsYouType As Boolean
    Get
    Set
public:
property bool CheckAsYouType {
    bool get ();
    void set (bool value);
}
public:
property bool CheckAsYouType {
    bool get ();
    void set (bool value);
}
member CheckAsYouType : bool with get, set

member CheckAsYouType : bool with get, set
Property Value
Boolean
Remarks
True turns spell checking on, false turns it off. If a change of state occurs then either SpellCheckStarted or SpellCheckFinished events are fired.


CheckCompoundWords Property

Keyoti RapidSpell Desktop .NET API Docs
CheckCompoundWords Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► CheckCompoundWords
Keyoti RapidSpell Desktop .NET
Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool CheckCompoundWords { get; set; }
public bool CheckCompoundWords { get; set; }
Public Property CheckCompoundWords As Boolean
    Get
    Set
Public Property CheckCompoundWords As Boolean
    Get
    Set
public:
property bool CheckCompoundWords {
    bool get ();
    void set (bool value);
}
public:
property bool CheckCompoundWords {
    bool get ();
    void set (bool value);
}
member CheckCompoundWords : bool with get, set

member CheckCompoundWords : bool with get, set
Property Value
Boolean
Remarks
If this=false then LookUp("thesewordsarejoined") = false

If this=true then LookUp("thesewordsarejoined") = true

If this=false then LookUp("abcdef") = false

If this=true then LookUp("abcdef") = false

Setting this to true will degrade lookup performance


CheckDisabledTextBoxes Property

Keyoti RapidSpell Desktop .NET API Docs
CheckDisabledTextBoxes Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► CheckDisabledTextBoxes
Keyoti RapidSpell Desktop .NET
Whether to spell check textboxes which are disabled.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool CheckDisabledTextBoxes { get; set; }
public bool CheckDisabledTextBoxes { get; set; }
Public Property CheckDisabledTextBoxes As Boolean
    Get
    Set
Public Property CheckDisabledTextBoxes As Boolean
    Get
    Set
public:
property bool CheckDisabledTextBoxes {
    bool get ();
    void set (bool value);
}
public:
property bool CheckDisabledTextBoxes {
    bool get ();
    void set (bool value);
}
member CheckDisabledTextBoxes : bool with get, set

member CheckDisabledTextBoxes : bool with get, set
Property Value
Boolean


checkFromPosition Field

Keyoti RapidSpell Desktop .NET API Docs
checkFromPosition Field
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► checkFromPosition
Keyoti RapidSpell Desktop .NET
Index of of character in text to check from.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected int checkFromPosition
protected int checkFromPosition
Protected checkFromPosition As Integer
Protected checkFromPosition As Integer
protected:
int checkFromPosition
protected:
int checkFromPosition
val mutable checkFromPosition: int
val mutable checkFromPosition: int
Field Value
Int32


CheckReadOnlyTextBoxes Property

Keyoti RapidSpell Desktop .NET API Docs
CheckReadOnlyTextBoxes Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► CheckReadOnlyTextBoxes
Keyoti RapidSpell Desktop .NET
Whether to spell check textboxes which are readonly.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool CheckReadOnlyTextBoxes { get; set; }
public bool CheckReadOnlyTextBoxes { get; set; }
Public Property CheckReadOnlyTextBoxes As Boolean
    Get
    Set
Public Property CheckReadOnlyTextBoxes As Boolean
    Get
    Set
public:
property bool CheckReadOnlyTextBoxes {
    bool get ();
    void set (bool value);
}
public:
property bool CheckReadOnlyTextBoxes {
    bool get ();
    void set (bool value);
}
member CheckReadOnlyTextBoxes : bool with get, set

member CheckReadOnlyTextBoxes : bool with get, set
Property Value
Boolean


ClearAllHighlights Method

Keyoti RapidSpell Desktop .NET API Docs
ClearAllHighlights Method
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► ClearAllHighlights()()()()
Keyoti RapidSpell Desktop .NET
Clears all spell check highlights (underlines) from the whole document.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void ClearAllHighlights()
public void ClearAllHighlights()
Public Sub ClearAllHighlights
Public Sub ClearAllHighlights
public:
void ClearAllHighlights()
public:
void ClearAllHighlights()
member ClearAllHighlights : unit -> unit

member ClearAllHighlights : unit -> unit


ClearTextComponents Method

Keyoti RapidSpell Desktop .NET API Docs
ClearTextComponents Method
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► ClearTextComponents()()()()
Keyoti RapidSpell Desktop .NET
Removes all text components from being spell checked.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void ClearTextComponents()
public void ClearTextComponents()
Public Sub ClearTextComponents
Public Sub ClearTextComponents
public:
void ClearTextComponents()
public:
void ClearTextComponents()
member ClearTextComponents : unit -> unit

member ClearTextComponents : unit -> unit


ConsiderationRange Property

Keyoti RapidSpell Desktop .NET API Docs
ConsiderationRange Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► ConsiderationRange
Keyoti RapidSpell Desktop .NET
Sets the factor for words to consider for suggestions, lower values are faster but consider less words for suggestions. Default is 500. If w <= 1 this method won't do anything.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int ConsiderationRange { get; set; }
public int ConsiderationRange { get; set; }
Public Property ConsiderationRange As Integer
    Get
    Set
Public Property ConsiderationRange As Integer
    Get
    Set
public:
property int ConsiderationRange {
    int get ();
    void set (int value);
}
public:
property int ConsiderationRange {
    int get ();
    void set (int value);
}
member ConsiderationRange : int with get, set

member ConsiderationRange : int with get, set
Property Value
Int32


ContextMenuStripEnabled Property

Keyoti RapidSpell Desktop .NET API Docs
ContextMenuStripEnabled Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► ContextMenuStripEnabled
Keyoti RapidSpell Desktop .NET
Whether to show the suggestion context menu through a ContextMenuStrip (true) or a ContextMenu (false).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool ContextMenuStripEnabled { get; set; }
public virtual bool ContextMenuStripEnabled { get; set; }
Public Overridable Property ContextMenuStripEnabled As Boolean
    Get
    Set
Public Overridable Property ContextMenuStripEnabled As Boolean
    Get
    Set
public:
virtual property bool ContextMenuStripEnabled {
    bool get ();
    void set (bool value);
}
public:
virtual property bool ContextMenuStripEnabled {
    bool get ();
    void set (bool value);
}
abstract ContextMenuStripEnabled : bool with get, set
override ContextMenuStripEnabled : bool with get, set
abstract ContextMenuStripEnabled : bool with get, set
override ContextMenuStripEnabled : bool with get, set
Property Value
Boolean


DictFilePath Property

Keyoti RapidSpell Desktop .NET API Docs
DictFilePath Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► DictFilePath
Keyoti RapidSpell Desktop .NET
The file to be used as the main dictionary (either a full file path, or the name of an embedded resource), if this is null then the built-in US English dictionary is used.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string DictFilePath { get; set; }
public string DictFilePath { get; set; }
Public Property DictFilePath As String
    Get
    Set
Public Property DictFilePath As String
    Get
    Set
public:
property String^ DictFilePath {
    String^ get ();
    void set (String^ value);
}
public:
property String^ DictFilePath {
    String^ get ();
    void set (String^ value);
}
member DictFilePath : string with get, set

member DictFilePath : string with get, set
Property Value
String


FindCapitalizedSuggestions Property

Keyoti RapidSpell Desktop .NET API Docs
FindCapitalizedSuggestions Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► FindCapitalizedSuggestions
Keyoti RapidSpell Desktop .NET
Whether to look for capitalized suggestions, note this will slow FindSuggestions down by about 7 times.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool FindCapitalizedSuggestions { get; set; }
public bool FindCapitalizedSuggestions { get; set; }
Public Property FindCapitalizedSuggestions As Boolean
    Get
    Set
Public Property FindCapitalizedSuggestions As Boolean
    Get
    Set
public:
property bool FindCapitalizedSuggestions {
    bool get ();
    void set (bool value);
}
public:
property bool FindCapitalizedSuggestions {
    bool get ();
    void set (bool value);
}
member FindCapitalizedSuggestions : bool with get, set

member FindCapitalizedSuggestions : bool with get, set
Property Value
Boolean


ForceCheckAll Method

Keyoti RapidSpell Desktop .NET API Docs
ForceCheckAll Method
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► ForceCheckAll()()()()
Keyoti RapidSpell Desktop .NET
Forces a check of the whole document.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void ForceCheckAll()
public void ForceCheckAll()
Public Sub ForceCheckAll
Public Sub ForceCheckAll
public:
void ForceCheckAll()
public:
void ForceCheckAll()
member ForceCheckAll : unit -> unit

member ForceCheckAll : unit -> unit
Remarks
This method is used internally, but may be of some use.


FoundSpellingError Event

Keyoti RapidSpell Desktop .NET API Docs
FoundSpellingError Event
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► FoundSpellingError
Keyoti RapidSpell Desktop .NET
Fired when a spelling error is found.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event FoundSpellingErrorEventHandler FoundSpellingError
public event FoundSpellingErrorEventHandler FoundSpellingError
Public Event FoundSpellingError As FoundSpellingErrorEventHandler
Public Event FoundSpellingError As FoundSpellingErrorEventHandler
public:
 event FoundSpellingErrorEventHandler^ FoundSpellingError {
    void add (FoundSpellingErrorEventHandler^ value);
    void remove (FoundSpellingErrorEventHandler^ value);
}
public:
 event FoundSpellingErrorEventHandler^ FoundSpellingError {
    void add (FoundSpellingErrorEventHandler^ value);
    void remove (FoundSpellingErrorEventHandler^ value);
}
member FoundSpellingError : IEvent<FoundSpellingErrorEventHandler,
    FoundSpellingErrorEventArgs>

member FoundSpellingError : IEvent<FoundSpellingErrorEventHandler,
    FoundSpellingErrorEventArgs>
Value
FoundSpellingErrorEventHandler


GetNumberOfCurrentSpellingErrors Method

Keyoti RapidSpell Desktop .NET API Docs
GetNumberOfCurrentSpellingErrors Method
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► GetNumberOfCurrentSpellingErrors()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | GetNumberOfCurrentSpellingErrors(TextBoxBase) | Returns the number of spelling errors currently in the tb, where tb is a textbox currently being spell checked.
 | GetNumberOfCurrentSpellingErrors(IAYTTextBox) | Returns the number of spelling errors currently in the tb, where tb is a textbox currently being spell checked.


GetNumberOfCurrentSpellingErrors Method (tb)

Keyoti RapidSpell Desktop .NET API Docs
GetNumberOfCurrentSpellingErrors Method (tb)
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► GetNumberOfCurrentSpellingErrors(IAYTTextBox)
Keyoti RapidSpell Desktop .NET
Returns the number of spelling errors currently in the tb, where tb is a textbox currently being spell checked.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int GetNumberOfCurrentSpellingErrors(
    IAYTTextBox tb
)
public int GetNumberOfCurrentSpellingErrors(
    IAYTTextBox tb
)
Public Function GetNumberOfCurrentSpellingErrors (
    tb As IAYTTextBox
) As Integer
Public Function GetNumberOfCurrentSpellingErrors (
    tb As IAYTTextBox
) As Integer
public:
int GetNumberOfCurrentSpellingErrors(
    IAYTTextBox^ tb
)
public:
int GetNumberOfCurrentSpellingErrors(
    IAYTTextBox^ tb
)
member GetNumberOfCurrentSpellingErrors :
        tb : IAYTTextBox -> int

member GetNumberOfCurrentSpellingErrors :
        tb : IAYTTextBox -> int
Parameters
tb (IAYTTextBox)
Return Value
Int32
Number of errors, or -1 if the text box is not being spell checked.


GetNumberOfCurrentSpellingErrors Method (tb)

Keyoti RapidSpell Desktop .NET API Docs
GetNumberOfCurrentSpellingErrors Method (tb)
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► GetNumberOfCurrentSpellingErrors(TextBoxBase)
Keyoti RapidSpell Desktop .NET
Returns the number of spelling errors currently in the tb, where tb is a textbox currently being spell checked.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int GetNumberOfCurrentSpellingErrors(
    TextBoxBase tb
)
public int GetNumberOfCurrentSpellingErrors(
    TextBoxBase tb
)
Public Function GetNumberOfCurrentSpellingErrors (
    tb As TextBoxBase
) As Integer
Public Function GetNumberOfCurrentSpellingErrors (
    tb As TextBoxBase
) As Integer
public:
int GetNumberOfCurrentSpellingErrors(
    TextBoxBase^ tb
)
public:
int GetNumberOfCurrentSpellingErrors(
    TextBoxBase^ tb
)
member GetNumberOfCurrentSpellingErrors :
        tb : TextBoxBase -> int

member GetNumberOfCurrentSpellingErrors :
        tb : TextBoxBase -> int
Parameters
tb (TextBoxBase)
Return Value
Int32
Number of errors, or -1 if the text box is not being spell checked.


GetSuggestionContextMenuInformation Method

Keyoti RapidSpell Desktop .NET API Docs
GetSuggestionContextMenuInformation Method
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► GetSuggestionContextMenuInformation()()()()
Keyoti RapidSpell Desktop .NET
Gets information about the context menu that should be shown
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ContextMenuInformation GetSuggestionContextMenuInformation()
public ContextMenuInformation GetSuggestionContextMenuInformation()
Public Function GetSuggestionContextMenuInformation As ContextMenuInformation
Public Function GetSuggestionContextMenuInformation As ContextMenuInformation
public:
ContextMenuInformation^ GetSuggestionContextMenuInformation()
public:
ContextMenuInformation^ GetSuggestionContextMenuInformation()
member GetSuggestionContextMenuInformation : unit -> ContextMenuInformation

member GetSuggestionContextMenuInformation : unit -> ContextMenuInformation
Return Value
ContextMenuInformation


GetSuggestions Method

Keyoti RapidSpell Desktop .NET API Docs
GetSuggestions Method
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► GetSuggestions()()()()
Keyoti RapidSpell Desktop .NET
Returns suggestions menu items for the last right clicked word. Null/Nothing if none.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual MenuItem[] GetSuggestions()
public virtual MenuItem[] GetSuggestions()
Public Overridable Function GetSuggestions As MenuItem()
Public Overridable Function GetSuggestions As MenuItem()
public:
virtual array<MenuItem^>^ GetSuggestions()
public:
virtual array<MenuItem^>^ GetSuggestions()
abstract GetSuggestions : unit -> MenuItem[]
override GetSuggestions : unit -> MenuItem[]
abstract GetSuggestions : unit -> MenuItem[]
override GetSuggestions : unit -> MenuItem[]
Return Value
array< MenuItem >[]()[][]
Remarks

See demo projects for an example.

An example usage; retreives suggestions menu items and uses them in a 3rd Party menu control.
Copy image Copy
MenuItem[] suggs;

TD.SandBar.ToolbarItemBase[] sandBarSuggs;

private void contextMenuBarItem1_BeforePopup(object sender, TD.SandBar.MenuPopupEventArgs e)
{

    this.contextMenuBarItem1.Items.Clear();
    suggs = this.rapidSpellAsYouType1.GetSuggestions();
    if(suggs!=null)//then we have suggestions
    {
        sandBarSuggs = new TD.SandBar.ToolbarItemBase[suggs.Length];
        for(int i=0; i<suggs.Length;i++)
            sandBarSuggs[i] = new TD.SandBar.MenuButtonItem(suggs[i].Text, new EventHandler(this.OnCMClick));

        this.contextMenuBarItem1.Items.AddRange(sandBarSuggs);
    }
}

void OnCMClick(object sender, EventArgs e){
    //rapidspellasyoutype.OnPopUpClick expects the sender to be a MenuItem, so need to call
    //method with original item it produced
    for(int i=0;i<sandBarSuggs.Length; i++)    {

        if(sender == sandBarSuggs[i])
        {
            this.rapidSpellAsYouType1.OnPopUpClick(suggs[i], e);
        }
    }
}


GetSuggestionsToolStripItems Method

Keyoti RapidSpell Desktop .NET API Docs
GetSuggestionsToolStripItems Method
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► GetSuggestionsToolStripItems()()()()
Keyoti RapidSpell Desktop .NET
Returns suggestions menu items as ToolStripItems for the last right clicked word. Null/Nothing if none.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual ToolStripItem[] GetSuggestionsToolStripItems()
public virtual ToolStripItem[] GetSuggestionsToolStripItems()
Public Overridable Function GetSuggestionsToolStripItems As ToolStripItem()
Public Overridable Function GetSuggestionsToolStripItems As ToolStripItem()
public:
virtual array<ToolStripItem^>^ GetSuggestionsToolStripItems()
public:
virtual array<ToolStripItem^>^ GetSuggestionsToolStripItems()
abstract GetSuggestionsToolStripItems : unit -> ToolStripItem[]
override GetSuggestionsToolStripItems : unit -> ToolStripItem[]
abstract GetSuggestionsToolStripItems : unit -> ToolStripItem[]
override GetSuggestionsToolStripItems : unit -> ToolStripItem[]
Return Value
array< ToolStripItem >[]()[][]
Remarks
Please see GetSuggestions remarks for general info.


GetTextComponents Method

Keyoti RapidSpell Desktop .NET API Docs
GetTextComponents Method
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► GetTextComponents()()()()
Keyoti RapidSpell Desktop .NET
Gets the text components being spell checked.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public List<IAYTTextBox> GetTextComponents()
public List<IAYTTextBox> GetTextComponents()
Public Function GetTextComponents As List(Of IAYTTextBox)
Public Function GetTextComponents As List(Of IAYTTextBox)
public:
List<IAYTTextBox^>^ GetTextComponents()
public:
List<IAYTTextBox^>^ GetTextComponents()
member GetTextComponents : unit -> List<IAYTTextBox>

member GetTextComponents : unit -> List<IAYTTextBox>
Return Value
List <(Of <(<' IAYTTextBox >)>)>


GUILanguage Property

Keyoti RapidSpell Desktop .NET API Docs
GUILanguage Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► GUILanguage
Keyoti RapidSpell Desktop .NET
The language to show the UI in.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public LanguageType GUILanguage { get; set; }
public LanguageType GUILanguage { get; set; }
Public Property GUILanguage As LanguageType
    Get
    Set
Public Property GUILanguage As LanguageType
    Get
    Set
public:
property LanguageType GUILanguage {
    LanguageType get ();
    void set (LanguageType value);
}
public:
property LanguageType GUILanguage {
    LanguageType get ();
    void set (LanguageType value);
}
member GUILanguage : LanguageType with get, set

member GUILanguage : LanguageType with get, set
Property Value
LanguageType


IgnoreAllMenuItem_Click Method

Keyoti RapidSpell Desktop .NET API Docs
IgnoreAllMenuItem_Click Method
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► IgnoreAllMenuItem_Click()()()()
Keyoti RapidSpell Desktop .NET
Handles ignore all menu clicks.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void IgnoreAllMenuItem_Click()
public void IgnoreAllMenuItem_Click()
Public Sub IgnoreAllMenuItem_Click
Public Sub IgnoreAllMenuItem_Click
public:
void IgnoreAllMenuItem_Click()
public:
void IgnoreAllMenuItem_Click()
member IgnoreAllMenuItem_Click : unit -> unit

member IgnoreAllMenuItem_Click : unit -> unit


IgnoreAllMenuText Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreAllMenuText Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► IgnoreAllMenuText
Keyoti RapidSpell Desktop .NET
Ignore All button text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string IgnoreAllMenuText { get; set; }
public string IgnoreAllMenuText { get; set; }
Public Property IgnoreAllMenuText As String
    Get
    Set
Public Property IgnoreAllMenuText As String
    Get
    Set
public:
property String^ IgnoreAllMenuText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ IgnoreAllMenuText {
    String^ get ();
    void set (String^ value);
}
member IgnoreAllMenuText : string with get, set

member IgnoreAllMenuText : string with get, set
Property Value
String


IgnoreCapitalizedWords Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreCapitalizedWords Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► IgnoreCapitalizedWords
Keyoti RapidSpell Desktop .NET
Whether to ignore words with capital letters.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreCapitalizedWords { get; set; }
public bool IgnoreCapitalizedWords { get; set; }
Public Property IgnoreCapitalizedWords As Boolean
    Get
    Set
Public Property IgnoreCapitalizedWords As Boolean
    Get
    Set
public:
property bool IgnoreCapitalizedWords {
    bool get ();
    void set (bool value);
}
public:
property bool IgnoreCapitalizedWords {
    bool get ();
    void set (bool value);
}
member IgnoreCapitalizedWords : bool with get, set

member IgnoreCapitalizedWords : bool with get, set
Property Value
Boolean


IgnoreIncorrectSentenceCapitalization Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreIncorrectSentenceCapitalization Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► IgnoreIncorrectSentenceCapitalization
Keyoti RapidSpell Desktop .NET
Whether to ignore incorrect sentence capitalization.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreIncorrectSentenceCapitalization { get; set; }
public bool IgnoreIncorrectSentenceCapitalization { get; set; }
Public Property IgnoreIncorrectSentenceCapitalization As Boolean
    Get
    Set
Public Property IgnoreIncorrectSentenceCapitalization As Boolean
    Get
    Set
public:
property bool IgnoreIncorrectSentenceCapitalization {
    bool get ();
    void set (bool value);
}
public:
property bool IgnoreIncorrectSentenceCapitalization {
    bool get ();
    void set (bool value);
}
member IgnoreIncorrectSentenceCapitalization : bool with get, set

member IgnoreIncorrectSentenceCapitalization : bool with get, set
Property Value
Boolean


IgnoreInEnglishLowerCaseI Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreInEnglishLowerCaseI Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► IgnoreInEnglishLowerCaseI
Keyoti RapidSpell Desktop .NET
Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreInEnglishLowerCaseI { get; set; }
public bool IgnoreInEnglishLowerCaseI { get; set; }
Public Property IgnoreInEnglishLowerCaseI As Boolean
    Get
    Set
Public Property IgnoreInEnglishLowerCaseI As Boolean
    Get
    Set
public:
property bool IgnoreInEnglishLowerCaseI {
    bool get ();
    void set (bool value);
}
public:
property bool IgnoreInEnglishLowerCaseI {
    bool get ();
    void set (bool value);
}
member IgnoreInEnglishLowerCaseI : bool with get, set

member IgnoreInEnglishLowerCaseI : bool with get, set
Property Value
Boolean


IgnoreMenuText Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreMenuText Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► IgnoreMenuText
Keyoti RapidSpell Desktop .NET
Ignore button text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string IgnoreMenuText { get; set; }
public string IgnoreMenuText { get; set; }
Public Property IgnoreMenuText As String
    Get
    Set
Public Property IgnoreMenuText As String
    Get
    Set
public:
property String^ IgnoreMenuText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ IgnoreMenuText {
    String^ get ();
    void set (String^ value);
}
member IgnoreMenuText : string with get, set

member IgnoreMenuText : string with get, set
Property Value
String


IgnoreOnce Method

Keyoti RapidSpell Desktop .NET API Docs
IgnoreOnce Method
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► IgnoreOnce()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | IgnoreOnce(BadWord, IAYTTextBox) | Ignores an instance of a bad word in the the textbox.
 | IgnoreOnce(BadWord, TextBoxBase) | Ignores an instance of a bad word in the the textbox.


IgnoreOnce Method (badWord, textBox)

Keyoti RapidSpell Desktop .NET API Docs
IgnoreOnce Method (badWord, textBox)
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► IgnoreOnce(BadWord, IAYTTextBox)
Keyoti RapidSpell Desktop .NET
Ignores an instance of a bad word in the the textbox.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void IgnoreOnce(
    BadWord badWord,
    IAYTTextBox textBox
)
public virtual void IgnoreOnce(
    BadWord badWord,
    IAYTTextBox textBox
)
Public Overridable Sub IgnoreOnce (
    badWord As BadWord,
    textBox As IAYTTextBox
)
Public Overridable Sub IgnoreOnce (
    badWord As BadWord,
    textBox As IAYTTextBox
)
public:
virtual void IgnoreOnce(
    BadWord^ badWord,
    IAYTTextBox^ textBox
)
public:
virtual void IgnoreOnce(
    BadWord^ badWord,
    IAYTTextBox^ textBox
)
abstract IgnoreOnce :
        badWord : BadWord *
        textBox : IAYTTextBox -> unit
override IgnoreOnce :
        badWord : BadWord *
        textBox : IAYTTextBox -> unit
abstract IgnoreOnce :
        badWord : BadWord *
        textBox : IAYTTextBox -> unit
override IgnoreOnce :
        badWord : BadWord *
        textBox : IAYTTextBox -> unit
Parameters
badWord (BadWord)
textBox (IAYTTextBox)


IgnoreOnce Method (badWord, textBox)

Keyoti RapidSpell Desktop .NET API Docs
IgnoreOnce Method (badWord, textBox)
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► IgnoreOnce(BadWord, TextBoxBase)
Keyoti RapidSpell Desktop .NET
Ignores an instance of a bad word in the the textbox.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void IgnoreOnce(
    BadWord badWord,
    TextBoxBase textBox
)
public virtual void IgnoreOnce(
    BadWord badWord,
    TextBoxBase textBox
)
Public Overridable Sub IgnoreOnce (
    badWord As BadWord,
    textBox As TextBoxBase
)
Public Overridable Sub IgnoreOnce (
    badWord As BadWord,
    textBox As TextBoxBase
)
public:
virtual void IgnoreOnce(
    BadWord^ badWord,
    TextBoxBase^ textBox
)
public:
virtual void IgnoreOnce(
    BadWord^ badWord,
    TextBoxBase^ textBox
)
abstract IgnoreOnce :
        badWord : BadWord *
        textBox : TextBoxBase -> unit
override IgnoreOnce :
        badWord : BadWord *
        textBox : TextBoxBase -> unit
abstract IgnoreOnce :
        badWord : BadWord *
        textBox : TextBoxBase -> unit
override IgnoreOnce :
        badWord : BadWord *
        textBox : TextBoxBase -> unit
Parameters
badWord (BadWord)
textBox (TextBoxBase)


IgnoreOnceMenuItem_Click Method

Keyoti RapidSpell Desktop .NET API Docs
IgnoreOnceMenuItem_Click Method
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► IgnoreOnceMenuItem_Click()()()()
Keyoti RapidSpell Desktop .NET
Handles ignore once menu clicks.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void IgnoreOnceMenuItem_Click()
public void IgnoreOnceMenuItem_Click()
Public Sub IgnoreOnceMenuItem_Click
Public Sub IgnoreOnceMenuItem_Click
public:
void IgnoreOnceMenuItem_Click()
public:
void IgnoreOnceMenuItem_Click()
member IgnoreOnceMenuItem_Click : unit -> unit

member IgnoreOnceMenuItem_Click : unit -> unit


IgnoreURLsAndEmailAddresses Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreURLsAndEmailAddresses Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► IgnoreURLsAndEmailAddresses
Keyoti RapidSpell Desktop .NET
Whether to ignore URLs and email addresses (requires V2Parser=true)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreURLsAndEmailAddresses { get; set; }
public bool IgnoreURLsAndEmailAddresses { get; set; }
Public Property IgnoreURLsAndEmailAddresses As Boolean
    Get
    Set
Public Property IgnoreURLsAndEmailAddresses As Boolean
    Get
    Set
public:
property bool IgnoreURLsAndEmailAddresses {
    bool get ();
    void set (bool value);
}
public:
property bool IgnoreURLsAndEmailAddresses {
    bool get ();
    void set (bool value);
}
member IgnoreURLsAndEmailAddresses : bool with get, set

member IgnoreURLsAndEmailAddresses : bool with get, set
Property Value
Boolean
Remarks
This will cause the following strings to be accepted as non-spelling errors;
"user@domain.com", "http://www.domain.com", "domain.co.uk" etc.


IgnoreWordsWithDigits Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreWordsWithDigits Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► IgnoreWordsWithDigits
Keyoti RapidSpell Desktop .NET
Whether to ignore words with numbers in them (eg. A10 or 7-11).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreWordsWithDigits { get; set; }
public bool IgnoreWordsWithDigits { get; set; }
Public Property IgnoreWordsWithDigits As Boolean
    Get
    Set
Public Property IgnoreWordsWithDigits As Boolean
    Get
    Set
public:
property bool IgnoreWordsWithDigits {
    bool get ();
    void set (bool value);
}
public:
property bool IgnoreWordsWithDigits {
    bool get ();
    void set (bool value);
}
member IgnoreWordsWithDigits : bool with get, set

member IgnoreWordsWithDigits : bool with get, set
Property Value
Boolean


IgnoreXML Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreXML Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► IgnoreXML
Keyoti RapidSpell Desktop .NET
Whether to ignore XML/HTML tags, false by default.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreXML { get; set; }
public bool IgnoreXML { get; set; }
Public Property IgnoreXML As Boolean
    Get
    Set
Public Property IgnoreXML As Boolean
    Get
    Set
public:
property bool IgnoreXML {
    bool get ();
    void set (bool value);
}
public:
property bool IgnoreXML {
    bool get ();
    void set (bool value);
}
member IgnoreXML : bool with get, set

member IgnoreXML : bool with get, set
Property Value
Boolean
Remarks
This identifies XML tags as anything in between < and > characters, there for it will cause undesirable effects in text such as "the sign for less than is < and the sign for greater than is >". Of course in HTML that should have been written as "the sign for less than is &lt; and the sign for greater than is &gt;" anyway, which would be fine.


IncludeUserDictionaryInSuggestions Property

Keyoti RapidSpell Desktop .NET API Docs
IncludeUserDictionaryInSuggestions Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► IncludeUserDictionaryInSuggestions
Keyoti RapidSpell Desktop .NET
Whether the user dictionary should be used in finding suggestions for misspelt words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IncludeUserDictionaryInSuggestions { get; set; }
public bool IncludeUserDictionaryInSuggestions { get; set; }
Public Property IncludeUserDictionaryInSuggestions As Boolean
    Get
    Set
Public Property IncludeUserDictionaryInSuggestions As Boolean
    Get
    Set
public:
property bool IncludeUserDictionaryInSuggestions {
    bool get ();
    void set (bool value);
}
public:
property bool IncludeUserDictionaryInSuggestions {
    bool get ();
    void set (bool value);
}
member IncludeUserDictionaryInSuggestions : bool with get, set

member IncludeUserDictionaryInSuggestions : bool with get, set
Property Value
Boolean


LanguageParser Property

Keyoti RapidSpell Desktop .NET API Docs
LanguageParser Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► LanguageParser
Keyoti RapidSpell Desktop .NET
The type of language parsing to use.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public LanguageType LanguageParser { get; set; }
public LanguageType LanguageParser { get; set; }
Public Property LanguageParser As LanguageType
    Get
    Set
Public Property LanguageParser As LanguageType
    Get
    Set
public:
property LanguageType LanguageParser {
    LanguageType get ();
    void set (LanguageType value);
}
public:
property LanguageType LanguageParser {
    LanguageType get ();
    void set (LanguageType value);
}
member LanguageParser : LanguageType with get, set

member LanguageParser : LanguageType with get, set
Property Value
LanguageType
Remarks
Eg. If the dictionary is set to French, you should use the French parser.


LookIntoHyphenatedText Property

Keyoti RapidSpell Desktop .NET API Docs
LookIntoHyphenatedText Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► LookIntoHyphenatedText
Keyoti RapidSpell Desktop .NET
Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool LookIntoHyphenatedText { get; set; }
public bool LookIntoHyphenatedText { get; set; }
Public Property LookIntoHyphenatedText As Boolean
    Get
    Set
Public Property LookIntoHyphenatedText As Boolean
    Get
    Set
public:
property bool LookIntoHyphenatedText {
    bool get ();
    void set (bool value);
}
public:
property bool LookIntoHyphenatedText {
    bool get ();
    void set (bool value);
}
member LookIntoHyphenatedText : bool with get, set

member LookIntoHyphenatedText : bool with get, set
Property Value
Boolean
Remarks
Eg. "socio-economic" will be checked as "socio" and "economic".


NeedRapidSpellAsYouTypeAgent Event

Keyoti RapidSpell Desktop .NET API Docs
NeedRapidSpellAsYouTypeAgent Event
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► NeedRapidSpellAsYouTypeAgent
Keyoti RapidSpell Desktop .NET
Fired when a new RapidSpellAsYouTypeAgent object is needed.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event NeedRapidSpellAsYouTypeAgentEventHandler NeedRapidSpellAsYouTypeAgent
public event NeedRapidSpellAsYouTypeAgentEventHandler NeedRapidSpellAsYouTypeAgent
Public Event NeedRapidSpellAsYouTypeAgent As NeedRapidSpellAsYouTypeAgentEventHandler
Public Event NeedRapidSpellAsYouTypeAgent As NeedRapidSpellAsYouTypeAgentEventHandler
public:
 event NeedRapidSpellAsYouTypeAgentEventHandler^ NeedRapidSpellAsYouTypeAgent {
    void add (NeedRapidSpellAsYouTypeAgentEventHandler^ value);
    void remove (NeedRapidSpellAsYouTypeAgentEventHandler^ value);
}
public:
 event NeedRapidSpellAsYouTypeAgentEventHandler^ NeedRapidSpellAsYouTypeAgent {
    void add (NeedRapidSpellAsYouTypeAgentEventHandler^ value);
    void remove (NeedRapidSpellAsYouTypeAgentEventHandler^ value);
}
member NeedRapidSpellAsYouTypeAgent : IEvent<NeedRapidSpellAsYouTypeAgentEventHandler,
    NeedRapidSpellAsYouTypeAgentEventArgs>

member NeedRapidSpellAsYouTypeAgent : IEvent<NeedRapidSpellAsYouTypeAgentEventHandler,
    NeedRapidSpellAsYouTypeAgentEventArgs>
Value
NeedRapidSpellAsYouTypeAgentEventHandler


OnFoundSpellingError Method (e, useAutoCorrectionMap)

Keyoti RapidSpell Desktop .NET API Docs
OnFoundSpellingError Method (e, useAutoCorrectionMap)
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► OnFoundSpellingError(FoundSpellingErrorEventArgs, Boolean)
Keyoti RapidSpell Desktop .NET
Raises the FoundSpellingError event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected internal void OnFoundSpellingError(
    FoundSpellingErrorEventArgs e,
    bool useAutoCorrectionMap
)
protected internal void OnFoundSpellingError(
    FoundSpellingErrorEventArgs e,
    bool useAutoCorrectionMap
)
Protected Friend Sub OnFoundSpellingError (
    e As FoundSpellingErrorEventArgs,
    useAutoCorrectionMap As Boolean
)
Protected Friend Sub OnFoundSpellingError (
    e As FoundSpellingErrorEventArgs,
    useAutoCorrectionMap As Boolean
)
protected public:
void OnFoundSpellingError(
    FoundSpellingErrorEventArgs^ e,
    bool useAutoCorrectionMap
)
protected public:
void OnFoundSpellingError(
    FoundSpellingErrorEventArgs^ e,
    bool useAutoCorrectionMap
)
member OnFoundSpellingError :
        e : FoundSpellingErrorEventArgs *
        useAutoCorrectionMap : bool -> unit

member OnFoundSpellingError :
        e : FoundSpellingErrorEventArgs *
        useAutoCorrectionMap : bool -> unit
Parameters
e (FoundSpellingErrorEventArgs)
Event arguments
useAutoCorrectionMap (Boolean)
Whether to use the auto correct mappings


OnNeedRapidSpellAsYouTypeAgent Method (e)

Keyoti RapidSpell Desktop .NET API Docs
OnNeedRapidSpellAsYouTypeAgent Method (e)
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► OnNeedRapidSpellAsYouTypeAgent(NeedRapidSpellAsYouTypeAgentEventArgs)
Keyoti RapidSpell Desktop .NET
Fires NeedRapidSpellAsYouTypeAgent
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void OnNeedRapidSpellAsYouTypeAgent(
    NeedRapidSpellAsYouTypeAgentEventArgs e
)
protected virtual void OnNeedRapidSpellAsYouTypeAgent(
    NeedRapidSpellAsYouTypeAgentEventArgs e
)
Protected Overridable Sub OnNeedRapidSpellAsYouTypeAgent (
    e As NeedRapidSpellAsYouTypeAgentEventArgs
)
Protected Overridable Sub OnNeedRapidSpellAsYouTypeAgent (
    e As NeedRapidSpellAsYouTypeAgentEventArgs
)
protected:
virtual void OnNeedRapidSpellAsYouTypeAgent(
    NeedRapidSpellAsYouTypeAgentEventArgs^ e
)
protected:
virtual void OnNeedRapidSpellAsYouTypeAgent(
    NeedRapidSpellAsYouTypeAgentEventArgs^ e
)
abstract OnNeedRapidSpellAsYouTypeAgent :
        e : NeedRapidSpellAsYouTypeAgentEventArgs -> unit
override OnNeedRapidSpellAsYouTypeAgent :
        e : NeedRapidSpellAsYouTypeAgentEventArgs -> unit
abstract OnNeedRapidSpellAsYouTypeAgent :
        e : NeedRapidSpellAsYouTypeAgentEventArgs -> unit
override OnNeedRapidSpellAsYouTypeAgent :
        e : NeedRapidSpellAsYouTypeAgentEventArgs -> unit
Parameters
e (NeedRapidSpellAsYouTypeAgentEventArgs)


OnSpellContextMenuRequest Method (e)

Keyoti RapidSpell Desktop .NET API Docs
OnSpellContextMenuRequest Method (e)
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► OnSpellContextMenuRequest(SpellContextMenuEventArgs)
Keyoti RapidSpell Desktop .NET
Fires event when a context menu is requested
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected internal void OnSpellContextMenuRequest(
    SpellContextMenuEventArgs e
)
protected internal void OnSpellContextMenuRequest(
    SpellContextMenuEventArgs e
)
Protected Friend Sub OnSpellContextMenuRequest (
    e As SpellContextMenuEventArgs
)
Protected Friend Sub OnSpellContextMenuRequest (
    e As SpellContextMenuEventArgs
)
protected public:
void OnSpellContextMenuRequest(
    SpellContextMenuEventArgs^ e
)
protected public:
void OnSpellContextMenuRequest(
    SpellContextMenuEventArgs^ e
)
member OnSpellContextMenuRequest :
        e : SpellContextMenuEventArgs -> unit

member OnSpellContextMenuRequest :
        e : SpellContextMenuEventArgs -> unit
Parameters
e (SpellContextMenuEventArgs)


OnWordAdded Method (e)

Keyoti RapidSpell Desktop .NET API Docs
OnWordAdded Method (e)
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► OnWordAdded(WordAddedEventArgs)
Keyoti RapidSpell Desktop .NET
Fires event when a word is added to the user dictionary
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected internal void OnWordAdded(
    WordAddedEventArgs e
)
protected internal void OnWordAdded(
    WordAddedEventArgs e
)
Protected Friend Sub OnWordAdded (
    e As WordAddedEventArgs
)
Protected Friend Sub OnWordAdded (
    e As WordAddedEventArgs
)
protected public:
void OnWordAdded(
    WordAddedEventArgs^ e
)
protected public:
void OnWordAdded(
    WordAddedEventArgs^ e
)
member OnWordAdded :
        e : WordAddedEventArgs -> unit

member OnWordAdded :
        e : WordAddedEventArgs -> unit
Parameters
e (WordAddedEventArgs)


OnWordChanged Method (e)

Keyoti RapidSpell Desktop .NET API Docs
OnWordChanged Method (e)
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► OnWordChanged(WordChangedEventArgs)
Keyoti RapidSpell Desktop .NET
Fires event when a word is changed
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected internal void OnWordChanged(
    WordChangedEventArgs e
)
protected internal void OnWordChanged(
    WordChangedEventArgs e
)
Protected Friend Sub OnWordChanged (
    e As WordChangedEventArgs
)
Protected Friend Sub OnWordChanged (
    e As WordChangedEventArgs
)
protected public:
void OnWordChanged(
    WordChangedEventArgs^ e
)
protected public:
void OnWordChanged(
    WordChangedEventArgs^ e
)
member OnWordChanged :
        e : WordChangedEventArgs -> unit

member OnWordChanged :
        e : WordChangedEventArgs -> unit
Parameters
e (WordChangedEventArgs)


OnWordIgnored Method (e)

Keyoti RapidSpell Desktop .NET API Docs
OnWordIgnored Method (e)
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► OnWordIgnored(WordIgnoredEventArgs)
Keyoti RapidSpell Desktop .NET
Fires event when a word is ignored
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected internal void OnWordIgnored(
    WordIgnoredEventArgs e
)
protected internal void OnWordIgnored(
    WordIgnoredEventArgs e
)
Protected Friend Sub OnWordIgnored (
    e As WordIgnoredEventArgs
)
Protected Friend Sub OnWordIgnored (
    e As WordIgnoredEventArgs
)
protected public:
void OnWordIgnored(
    WordIgnoredEventArgs^ e
)
protected public:
void OnWordIgnored(
    WordIgnoredEventArgs^ e
)
member OnWordIgnored :
        e : WordIgnoredEventArgs -> unit

member OnWordIgnored :
        e : WordIgnoredEventArgs -> unit
Parameters
e (WordIgnoredEventArgs)


OnWordsEntered Method (e)

Keyoti RapidSpell Desktop .NET API Docs
OnWordsEntered Method (e)
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► OnWordsEntered(WordsEnteredEventArgs)
Keyoti RapidSpell Desktop .NET
Fires event when a word is entered into the textbox
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected internal void OnWordsEntered(
    WordsEnteredEventArgs e
)
protected internal void OnWordsEntered(
    WordsEnteredEventArgs e
)
Protected Friend Sub OnWordsEntered (
    e As WordsEnteredEventArgs
)
Protected Friend Sub OnWordsEntered (
    e As WordsEnteredEventArgs
)
protected public:
void OnWordsEntered(
    WordsEnteredEventArgs^ e
)
protected public:
void OnWordsEntered(
    WordsEnteredEventArgs^ e
)
member OnWordsEntered :
        e : WordsEnteredEventArgs -> unit

member OnWordsEntered :
        e : WordsEnteredEventArgs -> unit
Parameters
e (WordsEnteredEventArgs)


Options Property

Keyoti RapidSpell Desktop .NET API Docs
Options Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► Options
Keyoti RapidSpell Desktop .NET
Object responsible for holding, loading and saving the user's spell check options.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual UserOptions Options { get; set; }
public virtual UserOptions Options { get; set; }
Public Overridable Property Options As UserOptions
    Get
    Set
Public Overridable Property Options As UserOptions
    Get
    Set
public:
virtual property UserOptions^ Options {
    UserOptions^ get ();
    void set (UserOptions^ value);
}
public:
virtual property UserOptions^ Options {
    UserOptions^ get ();
    void set (UserOptions^ value);
}
abstract Options : UserOptions with get, set
override Options : UserOptions with get, set
abstract Options : UserOptions with get, set
override Options : UserOptions with get, set
Property Value
UserOptions
Remarks
To customize how the user's options are saved/loaded, subclass UserOptions and set an instance in this property.


OptionsEnabled Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsEnabled Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► OptionsEnabled
Keyoti RapidSpell Desktop .NET
Whether to use user options.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool OptionsEnabled { get; set; }
public virtual bool OptionsEnabled { get; set; }
Public Overridable Property OptionsEnabled As Boolean
    Get
    Set
Public Overridable Property OptionsEnabled As Boolean
    Get
    Set
public:
virtual property bool OptionsEnabled {
    bool get ();
    void set (bool value);
}
public:
virtual property bool OptionsEnabled {
    bool get ();
    void set (bool value);
}
abstract OptionsEnabled : bool with get, set
override OptionsEnabled : bool with get, set
abstract OptionsEnabled : bool with get, set
override OptionsEnabled : bool with get, set
Property Value
Boolean


OptionsFileName Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsFileName Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► OptionsFileName
Keyoti RapidSpell Desktop .NET
The file name used to store the settings (by default in IsolatedStorage).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsFileName { get; set; }
public string OptionsFileName { get; set; }
Public Property OptionsFileName As String
    Get
    Set
Public Property OptionsFileName As String
    Get
    Set
public:
property String^ OptionsFileName {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OptionsFileName {
    String^ get ();
    void set (String^ value);
}
member OptionsFileName : string with get, set

member OptionsFileName : string with get, set
Property Value
String
Remarks
Changing this can ensure different applications have unique user settings.


OptionsPresenter Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsPresenter Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► OptionsPresenter
Keyoti RapidSpell Desktop .NET
Presenter for the user options form (IDialogViewOptions).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual OptionsPresenter OptionsPresenter { get; set; }
public virtual OptionsPresenter OptionsPresenter { get; set; }
Public Overridable Property OptionsPresenter As OptionsPresenter
    Get
    Set
Public Overridable Property OptionsPresenter As OptionsPresenter
    Get
    Set
public:
virtual property OptionsPresenter^ OptionsPresenter {
    OptionsPresenter^ get ();
    void set (OptionsPresenter^ value);
}
public:
virtual property OptionsPresenter^ OptionsPresenter {
    OptionsPresenter^ get ();
    void set (OptionsPresenter^ value);
}
abstract OptionsPresenter : OptionsPresenter with get, set
override OptionsPresenter : OptionsPresenter with get, set
abstract OptionsPresenter : OptionsPresenter with get, set
override OptionsPresenter : OptionsPresenter with get, set
Property Value
OptionsPresenter
Remarks
Set properties in this instance to affect the options shown to the user, or handle CreateDialogViewOptions to create your own IDialogViewOptions form instance.


OptionsStorageLocation Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsStorageLocation Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► OptionsStorageLocation
Keyoti RapidSpell Desktop .NET
Where the user's options are stored.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UserOptions..::..StorageType OptionsStorageLocation { get; set; }
public UserOptions..::..StorageType OptionsStorageLocation { get; set; }
Public Property OptionsStorageLocation As UserOptions..::..StorageType
    Get
    Set
Public Property OptionsStorageLocation As UserOptions..::..StorageType
    Get
    Set
public:
property UserOptions..::..StorageType OptionsStorageLocation {
    UserOptions..::..StorageType get ();
    void set (UserOptions..::..StorageType value);
}
public:
property UserOptions..::..StorageType OptionsStorageLocation {
    UserOptions..::..StorageType get ();
    void set (UserOptions..::..StorageType value);
}
member OptionsStorageLocation : UserOptions..::..StorageType with get, set

member OptionsStorageLocation : UserOptions..::..StorageType with get, set
Property Value
UserOptions..::..StorageType


RapidSpellChecker Property

Keyoti RapidSpell Desktop .NET API Docs
RapidSpellChecker Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► RapidSpellChecker
Keyoti RapidSpell Desktop .NET
The core spell checker object
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public RapidSpellChecker RapidSpellChecker { get; set; }
public RapidSpellChecker RapidSpellChecker { get; set; }
Public Property RapidSpellChecker As RapidSpellChecker
    Get
    Set
Public Property RapidSpellChecker As RapidSpellChecker
    Get
    Set
public:
property RapidSpellChecker^ RapidSpellChecker {
    RapidSpellChecker^ get ();
    void set (RapidSpellChecker^ value);
}
public:
property RapidSpellChecker^ RapidSpellChecker {
    RapidSpellChecker^ get ();
    void set (RapidSpellChecker^ value);
}
member RapidSpellChecker : RapidSpellChecker with get, set

member RapidSpellChecker : RapidSpellChecker with get, set
Property Value
RapidSpellChecker


RecheckTextOnPropertyChange Property

Keyoti RapidSpell Desktop .NET API Docs
RecheckTextOnPropertyChange Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► RecheckTextOnPropertyChange
Keyoti RapidSpell Desktop .NET
Whether to recheck the text when properties that affect the spell check change.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool RecheckTextOnPropertyChange { get; set; }
public bool RecheckTextOnPropertyChange { get; set; }
Public Property RecheckTextOnPropertyChange As Boolean
    Get
    Set
Public Property RecheckTextOnPropertyChange As Boolean
    Get
    Set
public:
property bool RecheckTextOnPropertyChange {
    bool get ();
    void set (bool value);
}
public:
property bool RecheckTextOnPropertyChange {
    bool get ();
    void set (bool value);
}
member RecheckTextOnPropertyChange : bool with get, set

member RecheckTextOnPropertyChange : bool with get, set
Property Value
Boolean
Remarks
Setting this to false before setting several properties prevents redundant rechecking of text.


RemoveAllTextComponents Method

Keyoti RapidSpell Desktop .NET API Docs
RemoveAllTextComponents Method
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► RemoveAllTextComponents()()()()
Keyoti RapidSpell Desktop .NET
Removes all text components to be checked from the collection.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void RemoveAllTextComponents()
public virtual void RemoveAllTextComponents()
Public Overridable Sub RemoveAllTextComponents
Public Overridable Sub RemoveAllTextComponents
public:
virtual void RemoveAllTextComponents()
public:
virtual void RemoveAllTextComponents()
abstract RemoveAllTextComponents : unit -> unit
override RemoveAllTextComponents : unit -> unit
abstract RemoveAllTextComponents : unit -> unit
override RemoveAllTextComponents : unit -> unit


RemoveDuplicateWordText Property

Keyoti RapidSpell Desktop .NET API Docs
RemoveDuplicateWordText Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► RemoveDuplicateWordText
Keyoti RapidSpell Desktop .NET
Remove duplicate word text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string RemoveDuplicateWordText { get; set; }
public string RemoveDuplicateWordText { get; set; }
Public Property RemoveDuplicateWordText As String
    Get
    Set
Public Property RemoveDuplicateWordText As String
    Get
    Set
public:
property String^ RemoveDuplicateWordText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ RemoveDuplicateWordText {
    String^ get ();
    void set (String^ value);
}
member RemoveDuplicateWordText : string with get, set

member RemoveDuplicateWordText : string with get, set
Property Value
String


RemoveTextBoxBase Method (textComponent)

Keyoti RapidSpell Desktop .NET API Docs
RemoveTextBoxBase Method (textComponent)
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► RemoveTextBoxBase(TextBoxBase)
Keyoti RapidSpell Desktop .NET
Remove a text component to be checked from the collection.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void RemoveTextBoxBase(
    TextBoxBase textComponent
)
public virtual void RemoveTextBoxBase(
    TextBoxBase textComponent
)
Public Overridable Sub RemoveTextBoxBase (
    textComponent As TextBoxBase
)
Public Overridable Sub RemoveTextBoxBase (
    textComponent As TextBoxBase
)
public:
virtual void RemoveTextBoxBase(
    TextBoxBase^ textComponent
)
public:
virtual void RemoveTextBoxBase(
    TextBoxBase^ textComponent
)
abstract RemoveTextBoxBase :
        textComponent : TextBoxBase -> unit
override RemoveTextBoxBase :
        textComponent : TextBoxBase -> unit
abstract RemoveTextBoxBase :
        textComponent : TextBoxBase -> unit
override RemoveTextBoxBase :
        textComponent : TextBoxBase -> unit
Parameters
textComponent (TextBoxBase)
The text box to no longer be spell checked
Remarks
If textboxes are to be dynamically added/removed from the collection of textboxes to check, call this and AddTextComponent


RemoveTextComponent Method (textComponent)

Keyoti RapidSpell Desktop .NET API Docs
RemoveTextComponent Method (textComponent)
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► RemoveTextComponent(IAYTTextBox)
Keyoti RapidSpell Desktop .NET
Remove a text component to be checked from the collection.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void RemoveTextComponent(
    IAYTTextBox textComponent
)
public virtual void RemoveTextComponent(
    IAYTTextBox textComponent
)
Public Overridable Sub RemoveTextComponent (
    textComponent As IAYTTextBox
)
Public Overridable Sub RemoveTextComponent (
    textComponent As IAYTTextBox
)
public:
virtual void RemoveTextComponent(
    IAYTTextBox^ textComponent
)
public:
virtual void RemoveTextComponent(
    IAYTTextBox^ textComponent
)
abstract RemoveTextComponent :
        textComponent : IAYTTextBox -> unit
override RemoveTextComponent :
        textComponent : IAYTTextBox -> unit
abstract RemoveTextComponent :
        textComponent : IAYTTextBox -> unit
override RemoveTextComponent :
        textComponent : IAYTTextBox -> unit
Parameters
textComponent (IAYTTextBox)
The text box to no longer be spell checked
Remarks
If textboxes are to be dynamically added/removed from the collection of textboxes to check, call this and AddTextComponent


RepaintUnderlines Method

Keyoti RapidSpell Desktop .NET API Docs
RepaintUnderlines Method
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► RepaintUnderlines()()()()
Keyoti RapidSpell Desktop .NET
Repaints the underlines, this should be called if any changes are made to layout, such as changes to font sizes, etc.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void RepaintUnderlines()
public void RepaintUnderlines()
Public Sub RepaintUnderlines
Public Sub RepaintUnderlines
public:
void RepaintUnderlines()
public:
void RepaintUnderlines()
member RepaintUnderlines : unit -> unit

member RepaintUnderlines : unit -> unit


ResetIgnoredWords Method

Keyoti RapidSpell Desktop .NET API Docs
ResetIgnoredWords Method
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► ResetIgnoredWords()()()()
Keyoti RapidSpell Desktop .NET
Resets all ignored words, so that the document will be rechecked.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void ResetIgnoredWords()
public virtual void ResetIgnoredWords()
Public Overridable Sub ResetIgnoredWords
Public Overridable Sub ResetIgnoredWords
public:
virtual void ResetIgnoredWords()
public:
virtual void ResetIgnoredWords()
abstract ResetIgnoredWords : unit -> unit
override ResetIgnoredWords : unit -> unit
abstract ResetIgnoredWords : unit -> unit
override ResetIgnoredWords : unit -> unit


SeparateHyphenWords Property

Keyoti RapidSpell Desktop .NET API Docs
SeparateHyphenWords Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► SeparateHyphenWords
Keyoti RapidSpell Desktop .NET
Whether to treat hyphenated (-) words as separate words, default is false.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool SeparateHyphenWords { get; set; }
public bool SeparateHyphenWords { get; set; }
Public Property SeparateHyphenWords As Boolean
    Get
    Set
Public Property SeparateHyphenWords As Boolean
    Get
    Set
public:
property bool SeparateHyphenWords {
    bool get ();
    void set (bool value);
}
public:
property bool SeparateHyphenWords {
    bool get ();
    void set (bool value);
}
member SeparateHyphenWords : bool with get, set

member SeparateHyphenWords : bool with get, set
Property Value
Boolean
Remarks
For eg. if this is true text like "cheap-deals" will be treated as two words "cheap" and "deals", otherwise this will be treated as one word "cheap-deals".


SetRepaintTimer Method (milliseconds)

Keyoti RapidSpell Desktop .NET API Docs
SetRepaintTimer Method (milliseconds)
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► SetRepaintTimer(Int32)
Keyoti RapidSpell Desktop .NET
If set to a value other than 0, the underline painting will not be performed until the timer has elapsed. This has a resolution of 250 milliseconds.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void SetRepaintTimer(
    int milliseconds
)
public void SetRepaintTimer(
    int milliseconds
)
Public Sub SetRepaintTimer (
    milliseconds As Integer
)
Public Sub SetRepaintTimer (
    milliseconds As Integer
)
public:
void SetRepaintTimer(
    int milliseconds
)
public:
void SetRepaintTimer(
    int milliseconds
)
member SetRepaintTimer :
        milliseconds : int -> unit

member SetRepaintTimer :
        milliseconds : int -> unit
Parameters
milliseconds (Int32)


ShowAddMenuOption Property

Keyoti RapidSpell Desktop .NET API Docs
ShowAddMenuOption Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► ShowAddMenuOption
Keyoti RapidSpell Desktop .NET
Whether to show the Add option in the context menu.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ShowAddMenuOption { get; set; }
public bool ShowAddMenuOption { get; set; }
Public Property ShowAddMenuOption As Boolean
    Get
    Set
Public Property ShowAddMenuOption As Boolean
    Get
    Set
public:
property bool ShowAddMenuOption {
    bool get ();
    void set (bool value);
}
public:
property bool ShowAddMenuOption {
    bool get ();
    void set (bool value);
}
member ShowAddMenuOption : bool with get, set

member ShowAddMenuOption : bool with get, set
Property Value
Boolean


ShowCutCopyPasteMenuOnTextBoxBase Property

Keyoti RapidSpell Desktop .NET API Docs
ShowCutCopyPasteMenuOnTextBoxBase Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► ShowCutCopyPasteMenuOnTextBoxBase
Keyoti RapidSpell Desktop .NET
Whether to show a cut copy paste context menu on TextBoxBase controls being checked.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ShowCutCopyPasteMenuOnTextBoxBase { get; set; }
public bool ShowCutCopyPasteMenuOnTextBoxBase { get; set; }
Public Property ShowCutCopyPasteMenuOnTextBoxBase As Boolean
    Get
    Set
Public Property ShowCutCopyPasteMenuOnTextBoxBase As Boolean
    Get
    Set
public:
property bool ShowCutCopyPasteMenuOnTextBoxBase {
    bool get ();
    void set (bool value);
}
public:
property bool ShowCutCopyPasteMenuOnTextBoxBase {
    bool get ();
    void set (bool value);
}
member ShowCutCopyPasteMenuOnTextBoxBase : bool with get, set

member ShowCutCopyPasteMenuOnTextBoxBase : bool with get, set
Property Value
Boolean


ShowSuggestionsContextMenu Property

Keyoti RapidSpell Desktop .NET API Docs
ShowSuggestionsContextMenu Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► ShowSuggestionsContextMenu
Keyoti RapidSpell Desktop .NET
Whether to show a context menu with suggestions when a misspelt word is right clicked, has no effect on developer set context menu.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ShowSuggestionsContextMenu { get; set; }
public bool ShowSuggestionsContextMenu { get; set; }
Public Property ShowSuggestionsContextMenu As Boolean
    Get
    Set
Public Property ShowSuggestionsContextMenu As Boolean
    Get
    Set
public:
property bool ShowSuggestionsContextMenu {
    bool get ();
    void set (bool value);
}
public:
property bool ShowSuggestionsContextMenu {
    bool get ();
    void set (bool value);
}
member ShowSuggestionsContextMenu : bool with get, set

member ShowSuggestionsContextMenu : bool with get, set
Property Value
Boolean
Remarks
When this property is false a context menu with suggestions is NOT shown (any existing developer set context menu is shown). When this property is true a context menu with suggestions is shown when the user's right click is on a misspelt word. A developer set context menu is always shown when a right click is off a misspelt word.


ShowSuggestionsWhenTextIsSelected Property

Keyoti RapidSpell Desktop .NET API Docs
ShowSuggestionsWhenTextIsSelected Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► ShowSuggestionsWhenTextIsSelected
Keyoti RapidSpell Desktop .NET
Whether to show the spelling context menu regardless of whether text is currently selected.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ShowSuggestionsWhenTextIsSelected { get; set; }
public bool ShowSuggestionsWhenTextIsSelected { get; set; }
Public Property ShowSuggestionsWhenTextIsSelected As Boolean
    Get
    Set
Public Property ShowSuggestionsWhenTextIsSelected As Boolean
    Get
    Set
public:
property bool ShowSuggestionsWhenTextIsSelected {
    bool get ();
    void set (bool value);
}
public:
property bool ShowSuggestionsWhenTextIsSelected {
    bool get ();
    void set (bool value);
}
member ShowSuggestionsWhenTextIsSelected : bool with get, set

member ShowSuggestionsWhenTextIsSelected : bool with get, set
Property Value
Boolean


SpellCheckFinished Event

Keyoti RapidSpell Desktop .NET API Docs
SpellCheckFinished Event
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► SpellCheckFinished
Keyoti RapidSpell Desktop .NET
Fired when checking finishes
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event SpellCheckEventHandler SpellCheckFinished
public event SpellCheckEventHandler SpellCheckFinished
Public Event SpellCheckFinished As SpellCheckEventHandler
Public Event SpellCheckFinished As SpellCheckEventHandler
public:
 event SpellCheckEventHandler^ SpellCheckFinished {
    void add (SpellCheckEventHandler^ value);
    void remove (SpellCheckEventHandler^ value);
}
public:
 event SpellCheckEventHandler^ SpellCheckFinished {
    void add (SpellCheckEventHandler^ value);
    void remove (SpellCheckEventHandler^ value);
}
member SpellCheckFinished : IEvent<SpellCheckEventHandler,
    SpellCheckEventArgs>

member SpellCheckFinished : IEvent<SpellCheckEventHandler,
    SpellCheckEventArgs>
Value
SpellCheckEventHandler


SpellCheckStarted Event

Keyoti RapidSpell Desktop .NET API Docs
SpellCheckStarted Event
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► SpellCheckStarted
Keyoti RapidSpell Desktop .NET
Fired when checking starts
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event SpellCheckEventHandler SpellCheckStarted
public event SpellCheckEventHandler SpellCheckStarted
Public Event SpellCheckStarted As SpellCheckEventHandler
Public Event SpellCheckStarted As SpellCheckEventHandler
public:
 event SpellCheckEventHandler^ SpellCheckStarted {
    void add (SpellCheckEventHandler^ value);
    void remove (SpellCheckEventHandler^ value);
}
public:
 event SpellCheckEventHandler^ SpellCheckStarted {
    void add (SpellCheckEventHandler^ value);
    void remove (SpellCheckEventHandler^ value);
}
member SpellCheckStarted : IEvent<SpellCheckEventHandler,
    SpellCheckEventArgs>

member SpellCheckStarted : IEvent<SpellCheckEventHandler,
    SpellCheckEventArgs>
Value
SpellCheckEventHandler


SpellContextMenuRequest Event

Keyoti RapidSpell Desktop .NET API Docs
SpellContextMenuRequest Event
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► SpellContextMenuRequest
Keyoti RapidSpell Desktop .NET
Fired when a request is made (usually by a right click on an underlined word) for context menu
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event SpellContextMenuRequestEventHandler SpellContextMenuRequest
public event SpellContextMenuRequestEventHandler SpellContextMenuRequest
Public Event SpellContextMenuRequest As SpellContextMenuRequestEventHandler
Public Event SpellContextMenuRequest As SpellContextMenuRequestEventHandler
public:
 event SpellContextMenuRequestEventHandler^ SpellContextMenuRequest {
    void add (SpellContextMenuRequestEventHandler^ value);
    void remove (SpellContextMenuRequestEventHandler^ value);
}
public:
 event SpellContextMenuRequestEventHandler^ SpellContextMenuRequest {
    void add (SpellContextMenuRequestEventHandler^ value);
    void remove (SpellContextMenuRequestEventHandler^ value);
}
member SpellContextMenuRequest : IEvent<SpellContextMenuRequestEventHandler,
    SpellContextMenuEventArgs>

member SpellContextMenuRequest : IEvent<SpellContextMenuRequestEventHandler,
    SpellContextMenuEventArgs>
Value
SpellContextMenuRequestEventHandler
Remarks
This event is a good way to display the spelling context menu in a developers own context menu. Setting ShowSuggestionsContextMenu to false will deactivate the automatic context menu that appears when a user right clicks on a spelling error. Listeners to this event are notified when a context menu should be shown with spelling suggestions and options, the event args also include a collection of MenuItem objects with spelling suggestions and Ignore All & Add options; These menu item click events are already hooked into RapidSpellAsYouType and will function as expected, without further programming.
Examples
Handling the context menu in a custom fashion.
Copy image Copy
.....
private Keyoti.RapidSpell.AYTRichTextBox aytRichTextBox1;
private Keyoti.RapidSpell.RapidSpellAsYouType rapidSpellAsYouType1;
.....

private void InitializeComponent(){
    .....
    this.rapidSpellAsYouType1.SpellContextMenuRequest +=
        new RapidSpellAsYouType.SpellContextMenuRequestEventHandler(rapidSpellAsYouType1_SpellContextMenuRequest);
    .....
}

private void rapidSpellAsYouType1_SpellContextMenuRequest(object sender, Keyoti.RapidSpell.Event.SpellContextMenuEventArgs e)
{
    //The MenuItem objects in e.MenuItems can be added to any menu as desired.
    this.aytRichTextBox1.ContextMenu.MenuItems.AddRange((MenuItem[])e.MenuItems);
}
....


SuggestionsMethod Property

Keyoti RapidSpell Desktop .NET API Docs
SuggestionsMethod Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► SuggestionsMethod
Keyoti RapidSpell Desktop .NET
The suggestions method to use.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public SuggestionsMethodType SuggestionsMethod { get; set; }
public SuggestionsMethodType SuggestionsMethod { get; set; }
Public Property SuggestionsMethod As SuggestionsMethodType
    Get
    Set
Public Property SuggestionsMethod As SuggestionsMethodType
    Get
    Set
public:
property SuggestionsMethodType SuggestionsMethod {
    SuggestionsMethodType get ();
    void set (SuggestionsMethodType value);
}
public:
property SuggestionsMethodType SuggestionsMethod {
    SuggestionsMethodType get ();
    void set (SuggestionsMethodType value);
}
member SuggestionsMethod : SuggestionsMethodType with get, set

member SuggestionsMethod : SuggestionsMethodType with get, set
Property Value
SuggestionsMethodType


SuggestSplitWords Property

Keyoti RapidSpell Desktop .NET API Docs
SuggestSplitWords Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► SuggestSplitWords
Keyoti RapidSpell Desktop .NET
Whether to look for connected words in suggestions.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool SuggestSplitWords { get; set; }
public bool SuggestSplitWords { get; set; }
Public Property SuggestSplitWords As Boolean
    Get
    Set
Public Property SuggestSplitWords As Boolean
    Get
    Set
public:
property bool SuggestSplitWords {
    bool get ();
    void set (bool value);
}
public:
property bool SuggestSplitWords {
    bool get ();
    void set (bool value);
}
member SuggestSplitWords : bool with get, set

member SuggestSplitWords : bool with get, set
Property Value
Boolean
Remarks
if this=true then suggestions may include joined words.

Eg; suggestions for "myhouse" will include "my house"


TextBoundary Property

Keyoti RapidSpell Desktop .NET API Docs
TextBoundary Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► TextBoundary
Keyoti RapidSpell Desktop .NET
The AdvancedTextBoundary class to use to parse words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public AdvancedTextBoundary TextBoundary { get; set; }
public AdvancedTextBoundary TextBoundary { get; set; }
Public Property TextBoundary As AdvancedTextBoundary
    Get
    Set
Public Property TextBoundary As AdvancedTextBoundary
    Get
    Set
public:
property AdvancedTextBoundary^ TextBoundary {
    AdvancedTextBoundary^ get ();
    void set (AdvancedTextBoundary^ value);
}
public:
property AdvancedTextBoundary^ TextBoundary {
    AdvancedTextBoundary^ get ();
    void set (AdvancedTextBoundary^ value);
}
member TextBoundary : AdvancedTextBoundary with get, set

member TextBoundary : AdvancedTextBoundary with get, set
Property Value
AdvancedTextBoundary
Remarks
Note, you must set this property in RapidSpellChecker with a different instance of the same class.


TextBoxBase Property

Keyoti RapidSpell Desktop .NET API Docs
TextBoxBase Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► TextBoxBase
Keyoti RapidSpell Desktop .NET
The TextBoxBase text box to check as the user types/modifies text. Do NOT set an AYTRichTextBox or AYTTextBox control here, use the TextComponent property instead.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public TextBoxBase TextBoxBase { get; set; }
public TextBoxBase TextBoxBase { get; set; }
Public Property TextBoxBase As TextBoxBase
    Get
    Set
Public Property TextBoxBase As TextBoxBase
    Get
    Set
public:
property TextBoxBase^ TextBoxBase {
    TextBoxBase^ get ();
    void set (TextBoxBase^ value);
}
public:
property TextBoxBase^ TextBoxBase {
    TextBoxBase^ get ();
    void set (TextBoxBase^ value);
}
member TextBoxBase : TextBoxBase with get, set

member TextBoxBase : TextBoxBase with get, set
Property Value
TextBoxBase


TextComponent Property

Keyoti RapidSpell Desktop .NET API Docs
TextComponent Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► TextComponent
Keyoti RapidSpell Desktop .NET
The IAYTTextBox text box to check as the user types/modifies text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public IAYTTextBox TextComponent { get; set; }
public IAYTTextBox TextComponent { get; set; }
Public Property TextComponent As IAYTTextBox
    Get
    Set
Public Property TextComponent As IAYTTextBox
    Get
    Set
public:
property IAYTTextBox^ TextComponent {
    IAYTTextBox^ get ();
    void set (IAYTTextBox^ value);
}
public:
property IAYTTextBox^ TextComponent {
    IAYTTextBox^ get ();
    void set (IAYTTextBox^ value);
}
member TextComponent : IAYTTextBox with get, set

member TextComponent : IAYTTextBox with get, set
Property Value
IAYTTextBox


TextComponents Property

Keyoti RapidSpell Desktop .NET API Docs
TextComponents Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► TextComponents
Keyoti RapidSpell Desktop .NET
The IAYTTextBox text boxes to check as the user types/modifies text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public IAYTTextBox[] TextComponents { set; }
public IAYTTextBox[] TextComponents { set; }
Public WriteOnly Property TextComponents As IAYTTextBox()
    Set
Public WriteOnly Property TextComponents As IAYTTextBox()
    Set
public:
property array<IAYTTextBox^>^ TextComponents {
    void set (array<IAYTTextBox^>^ value);
}
public:
property array<IAYTTextBox^>^ TextComponents {
    void set (array<IAYTTextBox^>^ value);
}
member TextComponents : IAYTTextBox[] with set

member TextComponents : IAYTTextBox[] with set
Property Value
array< IAYTTextBox >[]()[][]


UnderlineColor Property

Keyoti RapidSpell Desktop .NET API Docs
UnderlineColor Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► UnderlineColor
Keyoti RapidSpell Desktop .NET
The underline color to use with mis-spelt words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Color UnderlineColor { get; set; }
public Color UnderlineColor { get; set; }
Public Property UnderlineColor As Color
    Get
    Set
Public Property UnderlineColor As Color
    Get
    Set
public:
property Color UnderlineColor {
    Color get ();
    void set (Color value);
}
public:
property Color UnderlineColor {
    Color get ();
    void set (Color value);
}
member UnderlineColor : Color with get, set

member UnderlineColor : Color with get, set
Property Value
Color


UnderlineStyle Property

Keyoti RapidSpell Desktop .NET API Docs
UnderlineStyle Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► UnderlineStyle
Keyoti RapidSpell Desktop .NET
The underline style to use with mis-spelt words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UnderlineStyle UnderlineStyle { get; set; }
public UnderlineStyle UnderlineStyle { get; set; }
Public Property UnderlineStyle As UnderlineStyle
    Get
    Set
Public Property UnderlineStyle As UnderlineStyle
    Get
    Set
public:
property UnderlineStyle UnderlineStyle {
    UnderlineStyle get ();
    void set (UnderlineStyle value);
}
public:
property UnderlineStyle UnderlineStyle {
    UnderlineStyle get ();
    void set (UnderlineStyle value);
}
member UnderlineStyle : UnderlineStyle with get, set

member UnderlineStyle : UnderlineStyle with get, set
Property Value
UnderlineStyle


UnignoreWord Method

Keyoti RapidSpell Desktop .NET API Docs
UnignoreWord Method
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► UnignoreWord()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | UnignoreWord(BadWord, IAYTTextBox) | Unignores an instance of a bad word in the textbox.
 | UnignoreWord(BadWord, TextBoxBase) | Unignores an instance of a bad word in the textbox.
 | UnignoreWord(BadWord) | Unignores an instance of a bad word in all textboxes.


UnignoreWord Method (badWord)

Keyoti RapidSpell Desktop .NET API Docs
UnignoreWord Method (badWord)
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► UnignoreWord(BadWord)
Keyoti RapidSpell Desktop .NET
Unignores an instance of a bad word in all textboxes.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void UnignoreWord(
    BadWord badWord
)
public virtual void UnignoreWord(
    BadWord badWord
)
Public Overridable Sub UnignoreWord (
    badWord As BadWord
)
Public Overridable Sub UnignoreWord (
    badWord As BadWord
)
public:
virtual void UnignoreWord(
    BadWord^ badWord
)
public:
virtual void UnignoreWord(
    BadWord^ badWord
)
abstract UnignoreWord :
        badWord : BadWord -> unit
override UnignoreWord :
        badWord : BadWord -> unit
abstract UnignoreWord :
        badWord : BadWord -> unit
override UnignoreWord :
        badWord : BadWord -> unit
Parameters
badWord (BadWord)


UnignoreWord Method (badWord, textBox)

Keyoti RapidSpell Desktop .NET API Docs
UnignoreWord Method (badWord, textBox)
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► UnignoreWord(BadWord, IAYTTextBox)
Keyoti RapidSpell Desktop .NET
Unignores an instance of a bad word in the textbox.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void UnignoreWord(
    BadWord badWord,
    IAYTTextBox textBox
)
public virtual void UnignoreWord(
    BadWord badWord,
    IAYTTextBox textBox
)
Public Overridable Sub UnignoreWord (
    badWord As BadWord,
    textBox As IAYTTextBox
)
Public Overridable Sub UnignoreWord (
    badWord As BadWord,
    textBox As IAYTTextBox
)
public:
virtual void UnignoreWord(
    BadWord^ badWord,
    IAYTTextBox^ textBox
)
public:
virtual void UnignoreWord(
    BadWord^ badWord,
    IAYTTextBox^ textBox
)
abstract UnignoreWord :
        badWord : BadWord *
        textBox : IAYTTextBox -> unit
override UnignoreWord :
        badWord : BadWord *
        textBox : IAYTTextBox -> unit
abstract UnignoreWord :
        badWord : BadWord *
        textBox : IAYTTextBox -> unit
override UnignoreWord :
        badWord : BadWord *
        textBox : IAYTTextBox -> unit
Parameters
badWord (BadWord)
textBox (IAYTTextBox)


UnignoreWord Method (badWord, textBox)

Keyoti RapidSpell Desktop .NET API Docs
UnignoreWord Method (badWord, textBox)
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► UnignoreWord(BadWord, TextBoxBase)
Keyoti RapidSpell Desktop .NET
Unignores an instance of a bad word in the textbox.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void UnignoreWord(
    BadWord badWord,
    TextBoxBase textBox
)
public virtual void UnignoreWord(
    BadWord badWord,
    TextBoxBase textBox
)
Public Overridable Sub UnignoreWord (
    badWord As BadWord,
    textBox As TextBoxBase
)
Public Overridable Sub UnignoreWord (
    badWord As BadWord,
    textBox As TextBoxBase
)
public:
virtual void UnignoreWord(
    BadWord^ badWord,
    TextBoxBase^ textBox
)
public:
virtual void UnignoreWord(
    BadWord^ badWord,
    TextBoxBase^ textBox
)
abstract UnignoreWord :
        badWord : BadWord *
        textBox : TextBoxBase -> unit
override UnignoreWord :
        badWord : BadWord *
        textBox : TextBoxBase -> unit
abstract UnignoreWord :
        badWord : BadWord *
        textBox : TextBoxBase -> unit
override UnignoreWord :
        badWord : BadWord *
        textBox : TextBoxBase -> unit
Parameters
badWord (BadWord)
textBox (TextBoxBase)


UpdateAllTextBoxes Property

Keyoti RapidSpell Desktop .NET API Docs
UpdateAllTextBoxes Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► UpdateAllTextBoxes
Keyoti RapidSpell Desktop .NET
Whether to update all text boxes when ForceCheckAll is called, usually this should be true.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool UpdateAllTextBoxes { get; set; }
public bool UpdateAllTextBoxes { get; set; }
Public Property UpdateAllTextBoxes As Boolean
    Get
    Set
Public Property UpdateAllTextBoxes As Boolean
    Get
    Set
public:
property bool UpdateAllTextBoxes {
    bool get ();
    void set (bool value);
}
public:
property bool UpdateAllTextBoxes {
    bool get ();
    void set (bool value);
}
member UpdateAllTextBoxes : bool with get, set

member UpdateAllTextBoxes : bool with get, set
Property Value
Boolean


UserDictionaryFile Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionaryFile Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► UserDictionaryFile
Keyoti RapidSpell Desktop .NET
The user dictionary file, if this file doesn't exist it will be created.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionaryFile { get; set; }
public string UserDictionaryFile { get; set; }
Public Property UserDictionaryFile As String
    Get
    Set
Public Property UserDictionaryFile As String
    Get
    Set
public:
property String^ UserDictionaryFile {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserDictionaryFile {
    String^ get ();
    void set (String^ value);
}
member UserDictionaryFile : string with get, set

member UserDictionaryFile : string with get, set
Property Value
String
Remarks
Use of a user dictionary is optional.


V2Parser Property

Keyoti RapidSpell Desktop .NET API Docs
V2Parser Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► V2Parser
Keyoti RapidSpell Desktop .NET
Whether to use parser version 2 - Set to false for backwards (pre v3.4) compatibility.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool V2Parser { get; set; }
public bool V2Parser { get; set; }
Public Property V2Parser As Boolean
    Get
    Set
Public Property V2Parser As Boolean
    Get
    Set
public:
property bool V2Parser {
    bool get ();
    void set (bool value);
}
public:
property bool V2Parser {
    bool get ();
    void set (bool value);
}
member V2Parser : bool with get, set

member V2Parser : bool with get, set
Property Value
Boolean


WarnDuplicates Property

Keyoti RapidSpell Desktop .NET API Docs
WarnDuplicates Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► WarnDuplicates
Keyoti RapidSpell Desktop .NET
Whether to show duplicate words as errors (eg. "this is is an error").
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool WarnDuplicates { get; set; }
public bool WarnDuplicates { get; set; }
Public Property WarnDuplicates As Boolean
    Get
    Set
Public Property WarnDuplicates As Boolean
    Get
    Set
public:
property bool WarnDuplicates {
    bool get ();
    void set (bool value);
}
public:
property bool WarnDuplicates {
    bool get ();
    void set (bool value);
}
member WarnDuplicates : bool with get, set

member WarnDuplicates : bool with get, set
Property Value
Boolean


WordAdded Event

Keyoti RapidSpell Desktop .NET API Docs
WordAdded Event
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► WordAdded
Keyoti RapidSpell Desktop .NET
Fired when word added to user dictionary
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event WordAddedEventHandler WordAdded
public event WordAddedEventHandler WordAdded
Public Event WordAdded As WordAddedEventHandler
Public Event WordAdded As WordAddedEventHandler
public:
 event WordAddedEventHandler^ WordAdded {
    void add (WordAddedEventHandler^ value);
    void remove (WordAddedEventHandler^ value);
}
public:
 event WordAddedEventHandler^ WordAdded {
    void add (WordAddedEventHandler^ value);
    void remove (WordAddedEventHandler^ value);
}
member WordAdded : IEvent<WordAddedEventHandler,
    WordAddedEventArgs>

member WordAdded : IEvent<WordAddedEventHandler,
    WordAddedEventArgs>
Value
WordAddedEventHandler


WordChanged Event

Keyoti RapidSpell Desktop .NET API Docs
WordChanged Event
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► WordChanged
Keyoti RapidSpell Desktop .NET
Fired when word changed
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event WordChangedEventHandler WordChanged
public event WordChangedEventHandler WordChanged
Public Event WordChanged As WordChangedEventHandler
Public Event WordChanged As WordChangedEventHandler
public:
 event WordChangedEventHandler^ WordChanged {
    void add (WordChangedEventHandler^ value);
    void remove (WordChangedEventHandler^ value);
}
public:
 event WordChangedEventHandler^ WordChanged {
    void add (WordChangedEventHandler^ value);
    void remove (WordChangedEventHandler^ value);
}
member WordChanged : IEvent<WordChangedEventHandler,
    WordChangedEventArgs>

member WordChanged : IEvent<WordChangedEventHandler,
    WordChangedEventArgs>
Value
WordChangedEventHandler


WordIgnored Event

Keyoti RapidSpell Desktop .NET API Docs
WordIgnored Event
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► WordIgnored
Keyoti RapidSpell Desktop .NET
Fired when word ignored
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event WordIgnoredEventHandler WordIgnored
public event WordIgnoredEventHandler WordIgnored
Public Event WordIgnored As WordIgnoredEventHandler
Public Event WordIgnored As WordIgnoredEventHandler
public:
 event WordIgnoredEventHandler^ WordIgnored {
    void add (WordIgnoredEventHandler^ value);
    void remove (WordIgnoredEventHandler^ value);
}
public:
 event WordIgnoredEventHandler^ WordIgnored {
    void add (WordIgnoredEventHandler^ value);
    void remove (WordIgnoredEventHandler^ value);
}
member WordIgnored : IEvent<WordIgnoredEventHandler,
    WordIgnoredEventArgs>

member WordIgnored : IEvent<WordIgnoredEventHandler,
    WordIgnoredEventArgs>
Value
WordIgnoredEventHandler


WordsEntered Event

Keyoti RapidSpell Desktop .NET API Docs
WordsEntered Event
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► WordsEntered
Keyoti RapidSpell Desktop .NET
Fired when words have been entered (typed or pasted).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event WordsEnteredEventHandler WordsEntered
public event WordsEnteredEventHandler WordsEntered
Public Event WordsEntered As WordsEnteredEventHandler
Public Event WordsEntered As WordsEnteredEventHandler
public:
 event WordsEnteredEventHandler^ WordsEntered {
    void add (WordsEnteredEventHandler^ value);
    void remove (WordsEnteredEventHandler^ value);
}
public:
 event WordsEnteredEventHandler^ WordsEntered {
    void add (WordsEnteredEventHandler^ value);
    void remove (WordsEnteredEventHandler^ value);
}
member WordsEntered : IEvent<WordsEnteredEventHandler,
    WordsEnteredEventArgs>

member WordsEntered : IEvent<WordsEnteredEventHandler,
    WordsEnteredEventArgs>
Value
WordsEnteredEventHandler


RapidSpellAsYouTypeAgent Class

Keyoti RapidSpell Desktop .NET API Docs
RapidSpellAsYouTypeAgent Class
API ► Keyoti.RapidSpell ► RapidSpellAsYouTypeAgent
Keyoti RapidSpell Desktop .NET
Agent class that handles as-you-type for one text box.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class RapidSpellAsYouTypeAgent
public class RapidSpellAsYouTypeAgent
Public Class RapidSpellAsYouTypeAgent
Public Class RapidSpellAsYouTypeAgent
public ref class RapidSpellAsYouTypeAgent
public ref class RapidSpellAsYouTypeAgent
type RapidSpellAsYouTypeAgent =  class end
type RapidSpellAsYouTypeAgent =  class end
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RapidSpellAsYouTypeAgent(RapidSpellAsYouType) | New agent
 | AddMenuItem_Click()()()() | Handles add menu item clicks.
 | ChangeWordMenuItem_Click(String, Boolean) | Handles change word menu clicks
 | CheckAsYouType | Whether to spell check as the user types
 | checkFromPosition | Index of of character in text to check from.
 | checkToPosition | Index of character in text to check to.
 | ClearAllHighlights()()()() | Clears all spell check highlights (underlines) from the whole document (all text boxes).
 | DeHighlightText(BadWord) | Removes a highlight from a bad word in the text component
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | ForceCheckAll()()()() | Forces a check of the whole document.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetNumberOfCurrentSpellingErrors()()()() | Gets the current number of errors.
 | GetSuggestionContextMenuInformation()()()() | Gets information about the context menu that should be shown
 | GetSuggestions()()()() | Returns suggestions menu items for the last right clicked word. Null/Nothing if none.
 | GetSuggestionsToolStripItems()()()() | Returns suggestions menu items as ToolStripItems for the last right clicked word. Null/Nothing if none.
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | HighlightText(BadWord) | Highlights a bad word in the text component
 | IdentifyChange(TextChangeHint) | Returns the start and end indices in the current text of the changed text
 | IgnoreAllMenuItem_Click()()()() | Handles ignore all menu clicks.
 | IgnoreOnce(BadWord) | Ignores a word only once in the text
 | IgnoreOnceMenuItem_Click()()()() | Handles ignore once menu clicks.
 | IsInIgnorePos(Int32) | Whether to ignore words starting at this position.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnFocus(Object, EventArgs) | Called when text box is focused
 | OnKeyDown(Object, KeyEventArgs) | Called when user keys down
 | OnKeyPress(Object, KeyPressEventArgs) | Called when user keys down
 | OnKeyUp(Object, KeyEventArgs) | Called when user keys up
 | OnLeave(Object, EventArgs) | Called when user leaves a text box
 | OnMouseUp(Object, MouseEventArgs) | Called when mouse ups
 | OnPopup(Object, EventArgs) | Called when context menu is popped up.
 | OnPopUpClick(Object, EventArgs) | Called when the context menu is clicked, 'sender' must be the original MenuItem created by GetSuggestions, or by OnPopUp.
 | OnTextChanged(Object, EventArgs) | Called when text in text box changes
 | parent |
 | RepaintUnderlines()()()() | Repaints the underlines, this should be called if any changes are made to layout, such as changes to font sizes, etc.
 | TextBoxBase | Gets the TextBoxBase instance (if applicable) that this object is spell checking.
 | TextComponent | The IAYTTextBox text box to check as the user types/modifies text.
 | theCurrentTextComponent | The current text component being checked (because it's in focus)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | UnignoreWord(BadWord) | Unignores a word.
Inheritance Hierarchy
Object
RapidSpellAsYouTypeAgent


RapidSpellAsYouTypeAgent Constructor (parent)

Keyoti RapidSpell Desktop .NET API Docs
RapidSpellAsYouTypeAgent Constructor (parent)
API ► Keyoti.RapidSpell ► RapidSpellAsYouTypeAgent ► RapidSpellAsYouTypeAgent(RapidSpellAsYouType)
Keyoti RapidSpell Desktop .NET
New agent
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public RapidSpellAsYouTypeAgent(
    RapidSpellAsYouType parent
)
public RapidSpellAsYouTypeAgent(
    RapidSpellAsYouType parent
)
Public Sub New (
    parent As RapidSpellAsYouType
)
Public Sub New (
    parent As RapidSpellAsYouType
)
public:
RapidSpellAsYouTypeAgent(
    RapidSpellAsYouType^ parent
)
public:
RapidSpellAsYouTypeAgent(
    RapidSpellAsYouType^ parent
)
new :
        parent : RapidSpellAsYouType -> RapidSpellAsYouTypeAgent
new :
        parent : RapidSpellAsYouType -> RapidSpellAsYouTypeAgent
Parameters
parent (RapidSpellAsYouType)


AddMenuItem_Click Method

Keyoti RapidSpell Desktop .NET API Docs
AddMenuItem_Click Method
API ► Keyoti.RapidSpell ► RapidSpellAsYouTypeAgent ► AddMenuItem_Click()()()()
Keyoti RapidSpell Desktop .NET
Handles add menu item clicks.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void AddMenuItem_Click()
public virtual void AddMenuItem_Click()
Public Overridable Sub AddMenuItem_Click
Public Overridable Sub AddMenuItem_Click
public:
virtual void AddMenuItem_Click()
public:
virtual void AddMenuItem_Click()
abstract AddMenuItem_Click : unit -> unit
override AddMenuItem_Click : unit -> unit
abstract AddMenuItem_Click : unit -> unit
override AddMenuItem_Click : unit -> unit


ChangeWordMenuItem_Click Method (replacementWord, isRemoveDuplicateItem)

Keyoti RapidSpell Desktop .NET API Docs
ChangeWordMenuItem_Click Method (replacementWord, isRemoveDuplicateItem)
API ► Keyoti.RapidSpell ► RapidSpellAsYouTypeAgent ► ChangeWordMenuItem_Click(String, Boolean)
Keyoti RapidSpell Desktop .NET
Handles change word menu clicks
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void ChangeWordMenuItem_Click(
    string replacementWord,
    bool isRemoveDuplicateItem
)
public virtual void ChangeWordMenuItem_Click(
    string replacementWord,
    bool isRemoveDuplicateItem
)
Public Overridable Sub ChangeWordMenuItem_Click (
    replacementWord As String,
    isRemoveDuplicateItem As Boolean
)
Public Overridable Sub ChangeWordMenuItem_Click (
    replacementWord As String,
    isRemoveDuplicateItem As Boolean
)
public:
virtual void ChangeWordMenuItem_Click(
    String^ replacementWord,
    bool isRemoveDuplicateItem
)
public:
virtual void ChangeWordMenuItem_Click(
    String^ replacementWord,
    bool isRemoveDuplicateItem
)
abstract ChangeWordMenuItem_Click :
        replacementWord : string *
        isRemoveDuplicateItem : bool -> unit
override ChangeWordMenuItem_Click :
        replacementWord : string *
        isRemoveDuplicateItem : bool -> unit
abstract ChangeWordMenuItem_Click :
        replacementWord : string *
        isRemoveDuplicateItem : bool -> unit
override ChangeWordMenuItem_Click :
        replacementWord : string *
        isRemoveDuplicateItem : bool -> unit
Parameters
replacementWord (String)
The new word to replace the current error
isRemoveDuplicateItem (Boolean)
Whether the change is actually to remove duplicate (in which case 'replacementWord' can be null)


CheckAsYouType Property

Keyoti RapidSpell Desktop .NET API Docs
CheckAsYouType Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouTypeAgent ► CheckAsYouType
Keyoti RapidSpell Desktop .NET
Whether to spell check as the user types
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool CheckAsYouType { get; }
public bool CheckAsYouType { get; }
Public ReadOnly Property CheckAsYouType As Boolean
    Get
Public ReadOnly Property CheckAsYouType As Boolean
    Get
public:
property bool CheckAsYouType {
    bool get ();
}
public:
property bool CheckAsYouType {
    bool get ();
}
member CheckAsYouType : bool with get

member CheckAsYouType : bool with get
Property Value
Boolean


checkFromPosition Field

Keyoti RapidSpell Desktop .NET API Docs
checkFromPosition Field
API ► Keyoti.RapidSpell ► RapidSpellAsYouTypeAgent ► checkFromPosition
Keyoti RapidSpell Desktop .NET
Index of of character in text to check from.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected int checkFromPosition
protected int checkFromPosition
Protected checkFromPosition As Integer
Protected checkFromPosition As Integer
protected:
int checkFromPosition
protected:
int checkFromPosition
val mutable checkFromPosition: int
val mutable checkFromPosition: int
Field Value
Int32


checkToPosition Field

Keyoti RapidSpell Desktop .NET API Docs
checkToPosition Field
API ► Keyoti.RapidSpell ► RapidSpellAsYouTypeAgent ► checkToPosition
Keyoti RapidSpell Desktop .NET
Index of character in text to check to.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected int checkToPosition
protected int checkToPosition
Protected checkToPosition As Integer
Protected checkToPosition As Integer
protected:
int checkToPosition
protected:
int checkToPosition
val mutable checkToPosition: int
val mutable checkToPosition: int
Field Value
Int32


ClearAllHighlights Method

Keyoti RapidSpell Desktop .NET API Docs
ClearAllHighlights Method
API ► Keyoti.RapidSpell ► RapidSpellAsYouTypeAgent ► ClearAllHighlights()()()()
Keyoti RapidSpell Desktop .NET
Clears all spell check highlights (underlines) from the whole document (all text boxes).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void ClearAllHighlights()
public void ClearAllHighlights()
Public Sub ClearAllHighlights
Public Sub ClearAllHighlights
public:
void ClearAllHighlights()
public:
void ClearAllHighlights()
member ClearAllHighlights : unit -> unit

member ClearAllHighlights : unit -> unit


DeHighlightText Method (theBadWord)

Keyoti RapidSpell Desktop .NET API Docs
DeHighlightText Method (theBadWord)
API ► Keyoti.RapidSpell ► RapidSpellAsYouTypeAgent ► DeHighlightText(BadWord)
Keyoti RapidSpell Desktop .NET
Removes a highlight from a bad word in the text component
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void DeHighlightText(
    BadWord theBadWord
)
protected virtual void DeHighlightText(
    BadWord theBadWord
)
Protected Overridable Sub DeHighlightText (
    theBadWord As BadWord
)
Protected Overridable Sub DeHighlightText (
    theBadWord As BadWord
)
protected:
virtual void DeHighlightText(
    BadWord^ theBadWord
)
protected:
virtual void DeHighlightText(
    BadWord^ theBadWord
)
abstract DeHighlightText :
        theBadWord : BadWord -> unit
override DeHighlightText :
        theBadWord : BadWord -> unit
abstract DeHighlightText :
        theBadWord : BadWord -> unit
override DeHighlightText :
        theBadWord : BadWord -> unit
Parameters
theBadWord (BadWord)
Remarks
The word specified by theBadWord does not necessarily have to have been identified as "bad", before this method is called. The location of theBadWord must be relative to the checkFromPosition.


ForceCheckAll Method

Keyoti RapidSpell Desktop .NET API Docs
ForceCheckAll Method
API ► Keyoti.RapidSpell ► RapidSpellAsYouTypeAgent ► ForceCheckAll()()()()
Keyoti RapidSpell Desktop .NET
Forces a check of the whole document.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void ForceCheckAll()
public void ForceCheckAll()
Public Sub ForceCheckAll
Public Sub ForceCheckAll
public:
void ForceCheckAll()
public:
void ForceCheckAll()
member ForceCheckAll : unit -> unit

member ForceCheckAll : unit -> unit
Remarks
This method is used internally, but may be of some use.


GetNumberOfCurrentSpellingErrors Method

Keyoti RapidSpell Desktop .NET API Docs
GetNumberOfCurrentSpellingErrors Method
API ► Keyoti.RapidSpell ► RapidSpellAsYouTypeAgent ► GetNumberOfCurrentSpellingErrors()()()()
Keyoti RapidSpell Desktop .NET
Gets the current number of errors.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int GetNumberOfCurrentSpellingErrors()
public int GetNumberOfCurrentSpellingErrors()
Public Function GetNumberOfCurrentSpellingErrors As Integer
Public Function GetNumberOfCurrentSpellingErrors As Integer
public:
int GetNumberOfCurrentSpellingErrors()
public:
int GetNumberOfCurrentSpellingErrors()
member GetNumberOfCurrentSpellingErrors : unit -> int

member GetNumberOfCurrentSpellingErrors : unit -> int
Return Value
Int32


GetSuggestionContextMenuInformation Method

Keyoti RapidSpell Desktop .NET API Docs
GetSuggestionContextMenuInformation Method
API ► Keyoti.RapidSpell ► RapidSpellAsYouTypeAgent ► GetSuggestionContextMenuInformation()()()()
Keyoti RapidSpell Desktop .NET
Gets information about the context menu that should be shown
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ContextMenuInformation GetSuggestionContextMenuInformation()
public ContextMenuInformation GetSuggestionContextMenuInformation()
Public Function GetSuggestionContextMenuInformation As ContextMenuInformation
Public Function GetSuggestionContextMenuInformation As ContextMenuInformation
public:
ContextMenuInformation^ GetSuggestionContextMenuInformation()
public:
ContextMenuInformation^ GetSuggestionContextMenuInformation()
member GetSuggestionContextMenuInformation : unit -> ContextMenuInformation

member GetSuggestionContextMenuInformation : unit -> ContextMenuInformation
Return Value
ContextMenuInformation


GetSuggestions Method

Keyoti RapidSpell Desktop .NET API Docs
GetSuggestions Method
API ► Keyoti.RapidSpell ► RapidSpellAsYouTypeAgent ► GetSuggestions()()()()
Keyoti RapidSpell Desktop .NET
Returns suggestions menu items for the last right clicked word. Null/Nothing if none.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual MenuItem[] GetSuggestions()
public virtual MenuItem[] GetSuggestions()
Public Overridable Function GetSuggestions As MenuItem()
Public Overridable Function GetSuggestions As MenuItem()
public:
virtual array<MenuItem^>^ GetSuggestions()
public:
virtual array<MenuItem^>^ GetSuggestions()
abstract GetSuggestions : unit -> MenuItem[]
override GetSuggestions : unit -> MenuItem[]
abstract GetSuggestions : unit -> MenuItem[]
override GetSuggestions : unit -> MenuItem[]
Return Value
array< MenuItem >[]()[][]
Remarks

See demo projects for an example.

An example usage; retrieves suggestions menu items and uses them in a 3rd Party menu control.
Copy image Copy
MenuItem[] suggs;

TD.SandBar.ToolbarItemBase[] sandBarSuggs;

private void contextMenuBarItem1_BeforePopup(object sender, TD.SandBar.MenuPopupEventArgs e)
{

    this.contextMenuBarItem1.Items.Clear();
    suggs = this.rapidSpellAsYouType1.GetSuggestions();
    if(suggs!=null)//then we have suggestions
    {
        sandBarSuggs = new TD.SandBar.ToolbarItemBase[suggs.Length];
        for(int i=0; i<suggs.Length;i++)
            sandBarSuggs[i] = new TD.SandBar.MenuButtonItem(suggs[i].Text, new EventHandler(this.OnCMClick));

        this.contextMenuBarItem1.Items.AddRange(sandBarSuggs);
    }
}

void OnCMClick(object sender, EventArgs e){
    //rapidspellasyoutype.OnPopUpClick expects the sender to be a MenuItem, so need to call
    //method with original item it produced
    for(int i=0;i<sandBarSuggs.Length; i++)    {

        if(sender == sandBarSuggs[i])
        {
            this.rapidSpellAsYouType1.OnPopUpClick(suggs[i], e);
        }
    }
}


GetSuggestionsToolStripItems Method

Keyoti RapidSpell Desktop .NET API Docs
GetSuggestionsToolStripItems Method
API ► Keyoti.RapidSpell ► RapidSpellAsYouTypeAgent ► GetSuggestionsToolStripItems()()()()
Keyoti RapidSpell Desktop .NET
Returns suggestions menu items as ToolStripItems for the last right clicked word. Null/Nothing if none.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual ToolStripItem[] GetSuggestionsToolStripItems()
public virtual ToolStripItem[] GetSuggestionsToolStripItems()
Public Overridable Function GetSuggestionsToolStripItems As ToolStripItem()
Public Overridable Function GetSuggestionsToolStripItems As ToolStripItem()
public:
virtual array<ToolStripItem^>^ GetSuggestionsToolStripItems()
public:
virtual array<ToolStripItem^>^ GetSuggestionsToolStripItems()
abstract GetSuggestionsToolStripItems : unit -> ToolStripItem[]
override GetSuggestionsToolStripItems : unit -> ToolStripItem[]
abstract GetSuggestionsToolStripItems : unit -> ToolStripItem[]
override GetSuggestionsToolStripItems : unit -> ToolStripItem[]
Return Value
array< ToolStripItem >[]()[][]
Remarks
Please see GetSuggestions remarks for general info.


HighlightText Method (theBadWord)

Keyoti RapidSpell Desktop .NET API Docs
HighlightText Method (theBadWord)
API ► Keyoti.RapidSpell ► RapidSpellAsYouTypeAgent ► HighlightText(BadWord)
Keyoti RapidSpell Desktop .NET
Highlights a bad word in the text component
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void HighlightText(
    BadWord theBadWord
)
protected virtual void HighlightText(
    BadWord theBadWord
)
Protected Overridable Sub HighlightText (
    theBadWord As BadWord
)
Protected Overridable Sub HighlightText (
    theBadWord As BadWord
)
protected:
virtual void HighlightText(
    BadWord^ theBadWord
)
protected:
virtual void HighlightText(
    BadWord^ theBadWord
)
abstract HighlightText :
        theBadWord : BadWord -> unit
override HighlightText :
        theBadWord : BadWord -> unit
abstract HighlightText :
        theBadWord : BadWord -> unit
override HighlightText :
        theBadWord : BadWord -> unit
Parameters
theBadWord (BadWord)
Remarks
The location of theBadWord must be relative to the checkFromPosition.


IdentifyChange Method (hint)

Keyoti RapidSpell Desktop .NET API Docs
IdentifyChange Method (hint)
API ► Keyoti.RapidSpell ► RapidSpellAsYouTypeAgent ► IdentifyChange(TextChangeHint)
Keyoti RapidSpell Desktop .NET
Returns the start and end indices in the current text of the changed text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected int[] IdentifyChange(
    TextChangeHint hint
)
protected int[] IdentifyChange(
    TextChangeHint hint
)
Protected Function IdentifyChange (
    hint As TextChangeHint
) As Integer()
Protected Function IdentifyChange (
    hint As TextChangeHint
) As Integer()
protected:
array<int>^ IdentifyChange(
    TextChangeHint^ hint
)
protected:
array<int>^ IdentifyChange(
    TextChangeHint^ hint
)
member IdentifyChange :
        hint : TextChangeHint -> int[]

member IdentifyChange :
        hint : TextChangeHint -> int[]
Parameters
hint (TextChangeHint)
Return Value
array< Int32 >[]()[][]
Remarks
Note that end index is on right hand side of last character. eg.
Copy image Copy
"cat"
 ^ ^
 0 3


IgnoreAllMenuItem_Click Method

Keyoti RapidSpell Desktop .NET API Docs
IgnoreAllMenuItem_Click Method
API ► Keyoti.RapidSpell ► RapidSpellAsYouTypeAgent ► IgnoreAllMenuItem_Click()()()()
Keyoti RapidSpell Desktop .NET
Handles ignore all menu clicks.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void IgnoreAllMenuItem_Click()
public virtual void IgnoreAllMenuItem_Click()
Public Overridable Sub IgnoreAllMenuItem_Click
Public Overridable Sub IgnoreAllMenuItem_Click
public:
virtual void IgnoreAllMenuItem_Click()
public:
virtual void IgnoreAllMenuItem_Click()
abstract IgnoreAllMenuItem_Click : unit -> unit
override IgnoreAllMenuItem_Click : unit -> unit
abstract IgnoreAllMenuItem_Click : unit -> unit
override IgnoreAllMenuItem_Click : unit -> unit


IgnoreOnce Method (badWord)

Keyoti RapidSpell Desktop .NET API Docs
IgnoreOnce Method (badWord)
API ► Keyoti.RapidSpell ► RapidSpellAsYouTypeAgent ► IgnoreOnce(BadWord)
Keyoti RapidSpell Desktop .NET
Ignores a word only once in the text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void IgnoreOnce(
    BadWord badWord
)
public virtual void IgnoreOnce(
    BadWord badWord
)
Public Overridable Sub IgnoreOnce (
    badWord As BadWord
)
Public Overridable Sub IgnoreOnce (
    badWord As BadWord
)
public:
virtual void IgnoreOnce(
    BadWord^ badWord
)
public:
virtual void IgnoreOnce(
    BadWord^ badWord
)
abstract IgnoreOnce :
        badWord : BadWord -> unit
override IgnoreOnce :
        badWord : BadWord -> unit
abstract IgnoreOnce :
        badWord : BadWord -> unit
override IgnoreOnce :
        badWord : BadWord -> unit
Parameters
badWord (BadWord)


IgnoreOnceMenuItem_Click Method

Keyoti RapidSpell Desktop .NET API Docs
IgnoreOnceMenuItem_Click Method
API ► Keyoti.RapidSpell ► RapidSpellAsYouTypeAgent ► IgnoreOnceMenuItem_Click()()()()
Keyoti RapidSpell Desktop .NET
Handles ignore once menu clicks.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void IgnoreOnceMenuItem_Click()
public virtual void IgnoreOnceMenuItem_Click()
Public Overridable Sub IgnoreOnceMenuItem_Click
Public Overridable Sub IgnoreOnceMenuItem_Click
public:
virtual void IgnoreOnceMenuItem_Click()
public:
virtual void IgnoreOnceMenuItem_Click()
abstract IgnoreOnceMenuItem_Click : unit -> unit
override IgnoreOnceMenuItem_Click : unit -> unit
abstract IgnoreOnceMenuItem_Click : unit -> unit
override IgnoreOnceMenuItem_Click : unit -> unit


IsInIgnorePos Method (pos)

Keyoti RapidSpell Desktop .NET API Docs
IsInIgnorePos Method (pos)
API ► Keyoti.RapidSpell ► RapidSpellAsYouTypeAgent ► IsInIgnorePos(Int32)
Keyoti RapidSpell Desktop .NET
Whether to ignore words starting at this position.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual bool IsInIgnorePos(
    int pos
)
protected virtual bool IsInIgnorePos(
    int pos
)
Protected Overridable Function IsInIgnorePos (
    pos As Integer
) As Boolean
Protected Overridable Function IsInIgnorePos (
    pos As Integer
) As Boolean
protected:
virtual bool IsInIgnorePos(
    int pos
)
protected:
virtual bool IsInIgnorePos(
    int pos
)
abstract IsInIgnorePos :
        pos : int -> bool
override IsInIgnorePos :
        pos : int -> bool
abstract IsInIgnorePos :
        pos : int -> bool
override IsInIgnorePos :
        pos : int -> bool
Parameters
pos (Int32)
The position in the text.
Return Value
Boolean
True/False as to whether the character at pos should be ignored.
Remarks
Override this method to customize which regions of a document are ignored.


OnFocus Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
OnFocus Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellAsYouTypeAgent ► OnFocus(Object, EventArgs)
Keyoti RapidSpell Desktop .NET
Called when text box is focused
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected void OnFocus(
    Object sender,
    EventArgs e
)
protected void OnFocus(
    Object sender,
    EventArgs e
)
Protected Sub OnFocus (
    sender As Object,
    e As EventArgs
)
Protected Sub OnFocus (
    sender As Object,
    e As EventArgs
)
protected:
void OnFocus(
    Object^ sender,
    EventArgs^ e
)
protected:
void OnFocus(
    Object^ sender,
    EventArgs^ e
)
member OnFocus :
        sender : Object *
        e : EventArgs -> unit

member OnFocus :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


OnKeyDown Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
OnKeyDown Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellAsYouTypeAgent ► OnKeyDown(Object, KeyEventArgs)
Keyoti RapidSpell Desktop .NET
Called when user keys down
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void OnKeyDown(
    Object sender,
    KeyEventArgs e
)
protected virtual void OnKeyDown(
    Object sender,
    KeyEventArgs e
)
Protected Overridable Sub OnKeyDown (
    sender As Object,
    e As KeyEventArgs
)
Protected Overridable Sub OnKeyDown (
    sender As Object,
    e As KeyEventArgs
)
protected:
virtual void OnKeyDown(
    Object^ sender,
    KeyEventArgs^ e
)
protected:
virtual void OnKeyDown(
    Object^ sender,
    KeyEventArgs^ e
)
abstract OnKeyDown :
        sender : Object *
        e : KeyEventArgs -> unit
override OnKeyDown :
        sender : Object *
        e : KeyEventArgs -> unit
abstract OnKeyDown :
        sender : Object *
        e : KeyEventArgs -> unit
override OnKeyDown :
        sender : Object *
        e : KeyEventArgs -> unit
Parameters
sender (Object)
e (KeyEventArgs)


OnKeyPress Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
OnKeyPress Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellAsYouTypeAgent ► OnKeyPress(Object, KeyPressEventArgs)
Keyoti RapidSpell Desktop .NET
Called when user keys down
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void OnKeyPress(
    Object sender,
    KeyPressEventArgs e
)
protected virtual void OnKeyPress(
    Object sender,
    KeyPressEventArgs e
)
Protected Overridable Sub OnKeyPress (
    sender As Object,
    e As KeyPressEventArgs
)
Protected Overridable Sub OnKeyPress (
    sender As Object,
    e As KeyPressEventArgs
)
protected:
virtual void OnKeyPress(
    Object^ sender,
    KeyPressEventArgs^ e
)
protected:
virtual void OnKeyPress(
    Object^ sender,
    KeyPressEventArgs^ e
)
abstract OnKeyPress :
        sender : Object *
        e : KeyPressEventArgs -> unit
override OnKeyPress :
        sender : Object *
        e : KeyPressEventArgs -> unit
abstract OnKeyPress :
        sender : Object *
        e : KeyPressEventArgs -> unit
override OnKeyPress :
        sender : Object *
        e : KeyPressEventArgs -> unit
Parameters
sender (Object)
e (KeyPressEventArgs)


OnKeyUp Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
OnKeyUp Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellAsYouTypeAgent ► OnKeyUp(Object, KeyEventArgs)
Keyoti RapidSpell Desktop .NET
Called when user keys up
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void OnKeyUp(
    Object sender,
    KeyEventArgs e
)
protected virtual void OnKeyUp(
    Object sender,
    KeyEventArgs e
)
Protected Overridable Sub OnKeyUp (
    sender As Object,
    e As KeyEventArgs
)
Protected Overridable Sub OnKeyUp (
    sender As Object,
    e As KeyEventArgs
)
protected:
virtual void OnKeyUp(
    Object^ sender,
    KeyEventArgs^ e
)
protected:
virtual void OnKeyUp(
    Object^ sender,
    KeyEventArgs^ e
)
abstract OnKeyUp :
        sender : Object *
        e : KeyEventArgs -> unit
override OnKeyUp :
        sender : Object *
        e : KeyEventArgs -> unit
abstract OnKeyUp :
        sender : Object *
        e : KeyEventArgs -> unit
override OnKeyUp :
        sender : Object *
        e : KeyEventArgs -> unit
Parameters
sender (Object)
e (KeyEventArgs)


OnLeave Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
OnLeave Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellAsYouTypeAgent ► OnLeave(Object, EventArgs)
Keyoti RapidSpell Desktop .NET
Called when user leaves a text box
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected void OnLeave(
    Object sender,
    EventArgs e
)
protected void OnLeave(
    Object sender,
    EventArgs e
)
Protected Sub OnLeave (
    sender As Object,
    e As EventArgs
)
Protected Sub OnLeave (
    sender As Object,
    e As EventArgs
)
protected:
void OnLeave(
    Object^ sender,
    EventArgs^ e
)
protected:
void OnLeave(
    Object^ sender,
    EventArgs^ e
)
member OnLeave :
        sender : Object *
        e : EventArgs -> unit

member OnLeave :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


OnMouseUp Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
OnMouseUp Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellAsYouTypeAgent ► OnMouseUp(Object, MouseEventArgs)
Keyoti RapidSpell Desktop .NET
Called when mouse ups
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected void OnMouseUp(
    Object sender,
    MouseEventArgs e
)
protected void OnMouseUp(
    Object sender,
    MouseEventArgs e
)
Protected Sub OnMouseUp (
    sender As Object,
    e As MouseEventArgs
)
Protected Sub OnMouseUp (
    sender As Object,
    e As MouseEventArgs
)
protected:
void OnMouseUp(
    Object^ sender,
    MouseEventArgs^ e
)
protected:
void OnMouseUp(
    Object^ sender,
    MouseEventArgs^ e
)
member OnMouseUp :
        sender : Object *
        e : MouseEventArgs -> unit

member OnMouseUp :
        sender : Object *
        e : MouseEventArgs -> unit
Parameters
sender (Object)
e (MouseEventArgs)


OnPopup Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
OnPopup Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellAsYouTypeAgent ► OnPopup(Object, EventArgs)
Keyoti RapidSpell Desktop .NET
Called when context menu is popped up.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void OnPopup(
    Object sender,
    EventArgs e
)
public virtual void OnPopup(
    Object sender,
    EventArgs e
)
Public Overridable Sub OnPopup (
    sender As Object,
    e As EventArgs
)
Public Overridable Sub OnPopup (
    sender As Object,
    e As EventArgs
)
public:
virtual void OnPopup(
    Object^ sender,
    EventArgs^ e
)
public:
virtual void OnPopup(
    Object^ sender,
    EventArgs^ e
)
abstract OnPopup :
        sender : Object *
        e : EventArgs -> unit
override OnPopup :
        sender : Object *
        e : EventArgs -> unit
abstract OnPopup :
        sender : Object *
        e : EventArgs -> unit
override OnPopup :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


OnPopUpClick Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
OnPopUpClick Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellAsYouTypeAgent ► OnPopUpClick(Object, EventArgs)
Keyoti RapidSpell Desktop .NET
Called when the context menu is clicked, 'sender' must be the original MenuItem created by GetSuggestions, or by OnPopUp.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void OnPopUpClick(
    Object sender,
    EventArgs e
)
public virtual void OnPopUpClick(
    Object sender,
    EventArgs e
)
Public Overridable Sub OnPopUpClick (
    sender As Object,
    e As EventArgs
)
Public Overridable Sub OnPopUpClick (
    sender As Object,
    e As EventArgs
)
public:
virtual void OnPopUpClick(
    Object^ sender,
    EventArgs^ e
)
public:
virtual void OnPopUpClick(
    Object^ sender,
    EventArgs^ e
)
abstract OnPopUpClick :
        sender : Object *
        e : EventArgs -> unit
override OnPopUpClick :
        sender : Object *
        e : EventArgs -> unit
abstract OnPopUpClick :
        sender : Object *
        e : EventArgs -> unit
override OnPopUpClick :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


OnTextChanged Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
OnTextChanged Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellAsYouTypeAgent ► OnTextChanged(Object, EventArgs)
Keyoti RapidSpell Desktop .NET
Called when text in text box changes
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected void OnTextChanged(
    Object sender,
    EventArgs e
)
protected void OnTextChanged(
    Object sender,
    EventArgs e
)
Protected Sub OnTextChanged (
    sender As Object,
    e As EventArgs
)
Protected Sub OnTextChanged (
    sender As Object,
    e As EventArgs
)
protected:
void OnTextChanged(
    Object^ sender,
    EventArgs^ e
)
protected:
void OnTextChanged(
    Object^ sender,
    EventArgs^ e
)
member OnTextChanged :
        sender : Object *
        e : EventArgs -> unit

member OnTextChanged :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


parent Field

Keyoti RapidSpell Desktop .NET API Docs
parent Field
API ► Keyoti.RapidSpell ► RapidSpellAsYouTypeAgent ► parent
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected RapidSpellAsYouType parent
protected RapidSpellAsYouType parent
Protected parent As RapidSpellAsYouType
Protected parent As RapidSpellAsYouType
protected:
RapidSpellAsYouType^ parent
protected:
RapidSpellAsYouType^ parent
val mutable parent: RapidSpellAsYouType
val mutable parent: RapidSpellAsYouType
Field Value
RapidSpellAsYouType


RepaintUnderlines Method

Keyoti RapidSpell Desktop .NET API Docs
RepaintUnderlines Method
API ► Keyoti.RapidSpell ► RapidSpellAsYouTypeAgent ► RepaintUnderlines()()()()
Keyoti RapidSpell Desktop .NET
Repaints the underlines, this should be called if any changes are made to layout, such as changes to font sizes, etc.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void RepaintUnderlines()
public void RepaintUnderlines()
Public Sub RepaintUnderlines
Public Sub RepaintUnderlines
public:
void RepaintUnderlines()
public:
void RepaintUnderlines()
member RepaintUnderlines : unit -> unit

member RepaintUnderlines : unit -> unit


TextBoxBase Property

Keyoti RapidSpell Desktop .NET API Docs
TextBoxBase Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouTypeAgent ► TextBoxBase
Keyoti RapidSpell Desktop .NET
Gets the TextBoxBase instance (if applicable) that this object is spell checking.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public TextBoxBase TextBoxBase { get; }
public TextBoxBase TextBoxBase { get; }
Public ReadOnly Property TextBoxBase As TextBoxBase
    Get
Public ReadOnly Property TextBoxBase As TextBoxBase
    Get
public:
property TextBoxBase^ TextBoxBase {
    TextBoxBase^ get ();
}
public:
property TextBoxBase^ TextBoxBase {
    TextBoxBase^ get ();
}
member TextBoxBase : TextBoxBase with get

member TextBoxBase : TextBoxBase with get
Property Value
TextBoxBase
Remarks
Returns null if working with an IAYTTextBox that is not derived from TextBoxBase.


TextComponent Property

Keyoti RapidSpell Desktop .NET API Docs
TextComponent Property
API ► Keyoti.RapidSpell ► RapidSpellAsYouTypeAgent ► TextComponent
Keyoti RapidSpell Desktop .NET
The IAYTTextBox text box to check as the user types/modifies text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public IAYTTextBox TextComponent { get; set; }
public IAYTTextBox TextComponent { get; set; }
Public Property TextComponent As IAYTTextBox
    Get
    Set
Public Property TextComponent As IAYTTextBox
    Get
    Set
public:
property IAYTTextBox^ TextComponent {
    IAYTTextBox^ get ();
    void set (IAYTTextBox^ value);
}
public:
property IAYTTextBox^ TextComponent {
    IAYTTextBox^ get ();
    void set (IAYTTextBox^ value);
}
member TextComponent : IAYTTextBox with get, set

member TextComponent : IAYTTextBox with get, set
Property Value
IAYTTextBox


theCurrentTextComponent Field

Keyoti RapidSpell Desktop .NET API Docs
theCurrentTextComponent Field
API ► Keyoti.RapidSpell ► RapidSpellAsYouTypeAgent ► theCurrentTextComponent
Keyoti RapidSpell Desktop .NET
The current text component being checked (because it's in focus)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected internal IAYTTextBox theCurrentTextComponent
protected internal IAYTTextBox theCurrentTextComponent
Protected Friend theCurrentTextComponent As IAYTTextBox
Protected Friend theCurrentTextComponent As IAYTTextBox
protected public:
IAYTTextBox^ theCurrentTextComponent
protected public:
IAYTTextBox^ theCurrentTextComponent
val mutable theCurrentTextComponent: IAYTTextBox
val mutable theCurrentTextComponent: IAYTTextBox
Field Value
IAYTTextBox


UnignoreWord Method (badWord)

Keyoti RapidSpell Desktop .NET API Docs
UnignoreWord Method (badWord)
API ► Keyoti.RapidSpell ► RapidSpellAsYouTypeAgent ► UnignoreWord(BadWord)
Keyoti RapidSpell Desktop .NET
Unignores a word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void UnignoreWord(
    BadWord badWord
)
public virtual void UnignoreWord(
    BadWord badWord
)
Public Overridable Sub UnignoreWord (
    badWord As BadWord
)
Public Overridable Sub UnignoreWord (
    badWord As BadWord
)
public:
virtual void UnignoreWord(
    BadWord^ badWord
)
public:
virtual void UnignoreWord(
    BadWord^ badWord
)
abstract UnignoreWord :
        badWord : BadWord -> unit
override UnignoreWord :
        badWord : BadWord -> unit
abstract UnignoreWord :
        badWord : BadWord -> unit
override UnignoreWord :
        badWord : BadWord -> unit
Parameters
badWord (BadWord)


RapidSpellAYTDialogCoupler Class

Keyoti RapidSpell Desktop .NET API Docs
RapidSpellAYTDialogCoupler Class
API ► Keyoti.RapidSpell ► RapidSpellAYTDialogCoupler
Keyoti RapidSpell Desktop .NET
RapidSpell Desktop AYT-Dialog Coupler Control, this lightweight convenience control is used to couple RapidSpellAsYouType and RapidSpellDialog.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class RapidSpellAYTDialogCoupler : Component
public class RapidSpellAYTDialogCoupler : Component
Public Class RapidSpellAYTDialogCoupler
    Inherits Component
Public Class RapidSpellAYTDialogCoupler
    Inherits Component
public ref class RapidSpellAYTDialogCoupler : public Component
public ref class RapidSpellAYTDialogCoupler : public Component
type RapidSpellAYTDialogCoupler =
    class
        inherit Component
    end
type RapidSpellAYTDialogCoupler =
    class
        inherit Component
    end
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RapidSpellAYTDialogCoupler()()()() | New
 | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | Dispose(Boolean) | Frees up resources. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | Finalize()()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RapidSpellAsYouType | The RapidSpellAsYouType Control.
 | RapidSpellDialog | The RapidSpellDialog Control.
 | RSAWordAdded(Object, WordAddedEventArgs) | Called when a word is added to the dictionary by the as you type.
 | RSAWordIgnored(Object, WordIgnoredEventArgs) | Called when a word is ignore by the as you type.
 | RSDFinished(Object, TextBoxSpellCheckEventArgs) | Called when the dialog finishes.
 | RSDStarted(Object, TextBoxSpellCheckEventArgs) | Called when the dialog starts.
 | RSDWordAdded(Object, WordAddedEventArgs) | Called when a word is added to the dictionary by the dialog.
 | RSDWordChanged(Object, WordChangedEventArgs) | Called when a word is changed by the dialog.
 | RSDWordIgnored(Object, WordIgnoredEventArgs) | Called when a word is ignored by the dialog.
 | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
 | ToString()()()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Remarks
This control provides a coherent end-user experience; for example clicking 'Ignore All' when checking in RapidSpellDialog will also cause the underline (painted by RapidSpellAsYouType) to be removed.
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | RapidSpellAYTDialogCoupler


RapidSpellAYTDialogCoupler Constructor

Keyoti RapidSpell Desktop .NET API Docs
RapidSpellAYTDialogCoupler Constructor
API ► Keyoti.RapidSpell ► RapidSpellAYTDialogCoupler ► RapidSpellAYTDialogCoupler()()()()
Keyoti RapidSpell Desktop .NET
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public RapidSpellAYTDialogCoupler()
public RapidSpellAYTDialogCoupler()
Public Sub New
Public Sub New
public:
RapidSpellAYTDialogCoupler()
public:
RapidSpellAYTDialogCoupler()
new : unit -> RapidSpellAYTDialogCoupler
new : unit -> RapidSpellAYTDialogCoupler


Dispose Method (disposing)

Keyoti RapidSpell Desktop .NET API Docs
Dispose Method (disposing)
API ► Keyoti.RapidSpell ► RapidSpellAYTDialogCoupler ► Dispose(Boolean)
Keyoti RapidSpell Desktop .NET
Frees up resources.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
Parameters
disposing (Boolean)


RapidSpellAsYouType Property

Keyoti RapidSpell Desktop .NET API Docs
RapidSpellAsYouType Property
API ► Keyoti.RapidSpell ► RapidSpellAYTDialogCoupler ► RapidSpellAsYouType
Keyoti RapidSpell Desktop .NET
The RapidSpellAsYouType Control.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public RapidSpellAsYouType RapidSpellAsYouType { get; set; }
public RapidSpellAsYouType RapidSpellAsYouType { get; set; }
Public Property RapidSpellAsYouType As RapidSpellAsYouType
    Get
    Set
Public Property RapidSpellAsYouType As RapidSpellAsYouType
    Get
    Set
public:
property RapidSpellAsYouType^ RapidSpellAsYouType {
    RapidSpellAsYouType^ get ();
    void set (RapidSpellAsYouType^ value);
}
public:
property RapidSpellAsYouType^ RapidSpellAsYouType {
    RapidSpellAsYouType^ get ();
    void set (RapidSpellAsYouType^ value);
}
member RapidSpellAsYouType : RapidSpellAsYouType with get, set

member RapidSpellAsYouType : RapidSpellAsYouType with get, set
Property Value
RapidSpellAsYouType


RapidSpellDialog Property

Keyoti RapidSpell Desktop .NET API Docs
RapidSpellDialog Property
API ► Keyoti.RapidSpell ► RapidSpellAYTDialogCoupler ► RapidSpellDialog
Keyoti RapidSpell Desktop .NET
The RapidSpellDialog Control.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public RapidSpellDialog RapidSpellDialog { get; set; }
public RapidSpellDialog RapidSpellDialog { get; set; }
Public Property RapidSpellDialog As RapidSpellDialog
    Get
    Set
Public Property RapidSpellDialog As RapidSpellDialog
    Get
    Set
public:
property RapidSpellDialog^ RapidSpellDialog {
    RapidSpellDialog^ get ();
    void set (RapidSpellDialog^ value);
}
public:
property RapidSpellDialog^ RapidSpellDialog {
    RapidSpellDialog^ get ();
    void set (RapidSpellDialog^ value);
}
member RapidSpellDialog : RapidSpellDialog with get, set

member RapidSpellDialog : RapidSpellDialog with get, set
Property Value
RapidSpellDialog


RSAWordAdded Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
RSAWordAdded Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellAYTDialogCoupler ► RSAWordAdded(Object, WordAddedEventArgs)
Keyoti RapidSpell Desktop .NET
Called when a word is added to the dictionary by the as you type.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void RSAWordAdded(
    Object sender,
    WordAddedEventArgs e
)
protected virtual void RSAWordAdded(
    Object sender,
    WordAddedEventArgs e
)
Protected Overridable Sub RSAWordAdded (
    sender As Object,
    e As WordAddedEventArgs
)
Protected Overridable Sub RSAWordAdded (
    sender As Object,
    e As WordAddedEventArgs
)
protected:
virtual void RSAWordAdded(
    Object^ sender,
    WordAddedEventArgs^ e
)
protected:
virtual void RSAWordAdded(
    Object^ sender,
    WordAddedEventArgs^ e
)
abstract RSAWordAdded :
        sender : Object *
        e : WordAddedEventArgs -> unit
override RSAWordAdded :
        sender : Object *
        e : WordAddedEventArgs -> unit
abstract RSAWordAdded :
        sender : Object *
        e : WordAddedEventArgs -> unit
override RSAWordAdded :
        sender : Object *
        e : WordAddedEventArgs -> unit
Parameters
sender (Object)
The sender object
e (WordAddedEventArgs)
The event args


RSAWordIgnored Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
RSAWordIgnored Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellAYTDialogCoupler ► RSAWordIgnored(Object, WordIgnoredEventArgs)
Keyoti RapidSpell Desktop .NET
Called when a word is ignore by the as you type.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void RSAWordIgnored(
    Object sender,
    WordIgnoredEventArgs e
)
protected virtual void RSAWordIgnored(
    Object sender,
    WordIgnoredEventArgs e
)
Protected Overridable Sub RSAWordIgnored (
    sender As Object,
    e As WordIgnoredEventArgs
)
Protected Overridable Sub RSAWordIgnored (
    sender As Object,
    e As WordIgnoredEventArgs
)
protected:
virtual void RSAWordIgnored(
    Object^ sender,
    WordIgnoredEventArgs^ e
)
protected:
virtual void RSAWordIgnored(
    Object^ sender,
    WordIgnoredEventArgs^ e
)
abstract RSAWordIgnored :
        sender : Object *
        e : WordIgnoredEventArgs -> unit
override RSAWordIgnored :
        sender : Object *
        e : WordIgnoredEventArgs -> unit
abstract RSAWordIgnored :
        sender : Object *
        e : WordIgnoredEventArgs -> unit
override RSAWordIgnored :
        sender : Object *
        e : WordIgnoredEventArgs -> unit
Parameters
sender (Object)
The sender object
e (WordIgnoredEventArgs)
The event args


RSDFinished Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
RSDFinished Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellAYTDialogCoupler ► RSDFinished(Object, TextBoxSpellCheckEventArgs)
Keyoti RapidSpell Desktop .NET
Called when the dialog finishes.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void RSDFinished(
    Object sender,
    TextBoxSpellCheckEventArgs e
)
protected virtual void RSDFinished(
    Object sender,
    TextBoxSpellCheckEventArgs e
)
Protected Overridable Sub RSDFinished (
    sender As Object,
    e As TextBoxSpellCheckEventArgs
)
Protected Overridable Sub RSDFinished (
    sender As Object,
    e As TextBoxSpellCheckEventArgs
)
protected:
virtual void RSDFinished(
    Object^ sender,
    TextBoxSpellCheckEventArgs^ e
)
protected:
virtual void RSDFinished(
    Object^ sender,
    TextBoxSpellCheckEventArgs^ e
)
abstract RSDFinished :
        sender : Object *
        e : TextBoxSpellCheckEventArgs -> unit
override RSDFinished :
        sender : Object *
        e : TextBoxSpellCheckEventArgs -> unit
abstract RSDFinished :
        sender : Object *
        e : TextBoxSpellCheckEventArgs -> unit
override RSDFinished :
        sender : Object *
        e : TextBoxSpellCheckEventArgs -> unit
Parameters
sender (Object)
The sender object
e (TextBoxSpellCheckEventArgs)
The event args


RSDStarted Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
RSDStarted Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellAYTDialogCoupler ► RSDStarted(Object, TextBoxSpellCheckEventArgs)
Keyoti RapidSpell Desktop .NET
Called when the dialog starts.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void RSDStarted(
    Object sender,
    TextBoxSpellCheckEventArgs e
)
protected virtual void RSDStarted(
    Object sender,
    TextBoxSpellCheckEventArgs e
)
Protected Overridable Sub RSDStarted (
    sender As Object,
    e As TextBoxSpellCheckEventArgs
)
Protected Overridable Sub RSDStarted (
    sender As Object,
    e As TextBoxSpellCheckEventArgs
)
protected:
virtual void RSDStarted(
    Object^ sender,
    TextBoxSpellCheckEventArgs^ e
)
protected:
virtual void RSDStarted(
    Object^ sender,
    TextBoxSpellCheckEventArgs^ e
)
abstract RSDStarted :
        sender : Object *
        e : TextBoxSpellCheckEventArgs -> unit
override RSDStarted :
        sender : Object *
        e : TextBoxSpellCheckEventArgs -> unit
abstract RSDStarted :
        sender : Object *
        e : TextBoxSpellCheckEventArgs -> unit
override RSDStarted :
        sender : Object *
        e : TextBoxSpellCheckEventArgs -> unit
Parameters
sender (Object)
The sender object
e (TextBoxSpellCheckEventArgs)
The event args


RSDWordAdded Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
RSDWordAdded Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellAYTDialogCoupler ► RSDWordAdded(Object, WordAddedEventArgs)
Keyoti RapidSpell Desktop .NET
Called when a word is added to the dictionary by the dialog.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void RSDWordAdded(
    Object sender,
    WordAddedEventArgs e
)
protected virtual void RSDWordAdded(
    Object sender,
    WordAddedEventArgs e
)
Protected Overridable Sub RSDWordAdded (
    sender As Object,
    e As WordAddedEventArgs
)
Protected Overridable Sub RSDWordAdded (
    sender As Object,
    e As WordAddedEventArgs
)
protected:
virtual void RSDWordAdded(
    Object^ sender,
    WordAddedEventArgs^ e
)
protected:
virtual void RSDWordAdded(
    Object^ sender,
    WordAddedEventArgs^ e
)
abstract RSDWordAdded :
        sender : Object *
        e : WordAddedEventArgs -> unit
override RSDWordAdded :
        sender : Object *
        e : WordAddedEventArgs -> unit
abstract RSDWordAdded :
        sender : Object *
        e : WordAddedEventArgs -> unit
override RSDWordAdded :
        sender : Object *
        e : WordAddedEventArgs -> unit
Parameters
sender (Object)
The sender object
e (WordAddedEventArgs)
The event args


RSDWordChanged Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
RSDWordChanged Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellAYTDialogCoupler ► RSDWordChanged(Object, WordChangedEventArgs)
Keyoti RapidSpell Desktop .NET
Called when a word is changed by the dialog.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void RSDWordChanged(
    Object sender,
    WordChangedEventArgs e
)
protected virtual void RSDWordChanged(
    Object sender,
    WordChangedEventArgs e
)
Protected Overridable Sub RSDWordChanged (
    sender As Object,
    e As WordChangedEventArgs
)
Protected Overridable Sub RSDWordChanged (
    sender As Object,
    e As WordChangedEventArgs
)
protected:
virtual void RSDWordChanged(
    Object^ sender,
    WordChangedEventArgs^ e
)
protected:
virtual void RSDWordChanged(
    Object^ sender,
    WordChangedEventArgs^ e
)
abstract RSDWordChanged :
        sender : Object *
        e : WordChangedEventArgs -> unit
override RSDWordChanged :
        sender : Object *
        e : WordChangedEventArgs -> unit
abstract RSDWordChanged :
        sender : Object *
        e : WordChangedEventArgs -> unit
override RSDWordChanged :
        sender : Object *
        e : WordChangedEventArgs -> unit
Parameters
sender (Object)
The sender object
e (WordChangedEventArgs)
The event args


RSDWordIgnored Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
RSDWordIgnored Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellAYTDialogCoupler ► RSDWordIgnored(Object, WordIgnoredEventArgs)
Keyoti RapidSpell Desktop .NET
Called when a word is ignored by the dialog.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void RSDWordIgnored(
    Object sender,
    WordIgnoredEventArgs e
)
protected virtual void RSDWordIgnored(
    Object sender,
    WordIgnoredEventArgs e
)
Protected Overridable Sub RSDWordIgnored (
    sender As Object,
    e As WordIgnoredEventArgs
)
Protected Overridable Sub RSDWordIgnored (
    sender As Object,
    e As WordIgnoredEventArgs
)
protected:
virtual void RSDWordIgnored(
    Object^ sender,
    WordIgnoredEventArgs^ e
)
protected:
virtual void RSDWordIgnored(
    Object^ sender,
    WordIgnoredEventArgs^ e
)
abstract RSDWordIgnored :
        sender : Object *
        e : WordIgnoredEventArgs -> unit
override RSDWordIgnored :
        sender : Object *
        e : WordIgnoredEventArgs -> unit
abstract RSDWordIgnored :
        sender : Object *
        e : WordIgnoredEventArgs -> unit
override RSDWordIgnored :
        sender : Object *
        e : WordIgnoredEventArgs -> unit
Parameters
sender (Object)
The sender object
e (WordIgnoredEventArgs)
The event args


RapidSpellChecker Class

Keyoti RapidSpell Desktop .NET API Docs
RapidSpellChecker Class
API ► Keyoti.RapidSpell ► RapidSpellChecker
Keyoti RapidSpell Desktop .NET
Spell checker engine, checks a text string for spelling errors and makes suggested corrections.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class RapidSpellChecker : ICheckerEngine
public class RapidSpellChecker : ICheckerEngine
Public Class RapidSpellChecker
    Implements ICheckerEngine
Public Class RapidSpellChecker
    Implements ICheckerEngine
public ref class RapidSpellChecker : ICheckerEngine
public ref class RapidSpellChecker : ICheckerEngine
type RapidSpellChecker =
    class
        interface ICheckerEngine
    end
type RapidSpellChecker =
    class
        interface ICheckerEngine
    end
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RapidSpellChecker()()()() | Creates a RapidSpellChecker, with no user dictionary.
 | AddIgnorePattern(String) | Adds a regex pattern to ignore (maximum of 20 can be added - IgnoreURLsAndEmailAddresses=true counts as 1).
 | AddWord(String) | Adds word to the user dictionary (if it has been specified).
 | AllowAnyCase | Whether to allow words spelt with incorrect case, eg. "africa", instead of "Africa", this is more relaxed than AllowMixedCase
 | AllowMixedCase | Whether to allow words spelt with mixed case, eg. "MIxEd" - also see AllowAnyCase.
 | ChangeAll(String) | Changes all instances of the current bad word to newWord in the text.
 | ChangeBadWord(String) | Changes the current bad word to newWord in the text.
 | ChangeBadWord(BadWord, String) | Changes badWord to newWord in the text.
 | Check(String) | Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.
 | Check(String, Boolean) | Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.
 | Check(String, Int32) | Checks text for spelling correctness, from startPosition in text, mis-spelt words can be accessed through NextBadWord.
 | Check(String, Int32, Boolean) | Checks text for spelling correctness, from startPosition in text, mis-spelt words can be accessed through NextBadWord.
 | CheckCompoundWords | Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
 | convertHtmlEntities(String) | Converts HTML entity codes to their Unicode characters
 | convertHtmlEntities(String, Boolean) | Converts HTML entity codes to their Unicode characters
 | CurrentBadWord | Gets the current bad word (last returned by NextBadWord).
 | DictFilePath | The file to be used as the main dictionary (either a full file path, or the name of an embedded resource), if this is null then the built-in US English dictionary is used.
 | Dispose(Boolean) | Disposes of resources.
 | Dispose()()()() | Clean up any resources being used.
 | dontSuggest | Don't suggest words in this array (swear words).
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Frees up resources. (Overrides Object.Finalize()()()().)
 | FindAnagrams(String, IList) | Finds anagrams of word and puts them in anagrams if not already present.
 | FindCapitalizedSuggestions | Whether to look for capitalized suggestions, note this will slow FindSuggestions down by about 7 times.
 | FindCompoundWords(String, IList, Boolean) | Finds the compound words in text and puts them in subwords, set subwords to null/nothing to just find if text has compound word formation.
 | FindSuggestions()()()() | Gets an enumeration of String suggestions for spelling of current bad word.
 | FindSuggestions(String) | Gets an enumeration of String suggestions for word.
 | FindSuggestions(String, Boolean) | Gets an enumeration of String suggestions for word.
 | GetAmendedText()()()() | Returns the original text sent to check() but with any alterations made through change
 | GetConsiderationRange()()()() | Gets the factor for words to consider for suggestions.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIgnoreCapitalizedWords()()()() | Gets whether to ignore words with capital letters.
 | GetIncludeUserDictionaryInSuggestions()()()() | Gets whether the user dictionary should be used in finding suggestions for misspelt words.
 | GetNextWord()()()() | Returns the next word in the text.
 | GetSeparateHyphenWords()()()() | Gets whether to treat hyphenated (-) words as separate words, default is false.
 | GetSuggestionsMethod()()()() | Obsolete. Gets the suggestions method to use. Either PHONETIC_SUGGESTIONS or HASHING_SUGGESTIONS
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GetUndoableStatePoint()()()() | Gets the state of the current run, which can be stored and used with RevertToUndoableStatePoint(RapidSpellChecker..::..State)
 | HASHING_SUGGESTIONS | Indicator for suggestion method (Hashing is default).
 | IgnoreAll(String) | Marks word to be ignored in rest of the text.
 | IgnoreAllCaseInsensitive | Whether Ignore All operations should be considered case insensitive (default false).
 | IgnoreIncorrectSentenceCapitalization | Whether to ignore incorrect sentence capitalization.
 | IgnoreInEnglishLowerCaseI | Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
 | IgnoreList | The words to ignore, note this list is changed by IgnoreAll.
 | IgnorePatternMaximumWordLength | The maximum length of word that will be tested as a regex ignore pattern.
 | IgnoreRtfCodes | Sets whether this should ignore Rtf (or any escaped) codes in the text.
 | IgnoreURLsAndEmailAddresses | Whether to ignore URLs and email addresses (requires V2Parser=true)
 | IgnoreWordsWithDigits | Whether to ignore words with numbers in them (eg. A10 or 7-11).
 | IgnoreXML | Whether to ignore XML/HTML tags, should be set true for RichTextBox support, false by default.
 | IsAllCaps(String) | Whether all chars in s are in upper case
 | IsStartsWithCap(String) | Whether first letter is a capital and rest are lower.
 | IsWord(Int32, Int32) | Whether the word defined by the parameters is a word or whitespace.
 | LanguageParser | The type of language parsing to use.
 | LookForAnagrams | Whether to look for anagrams, if true suggestion performance is slower.
 | LookIntoHyphenatedText | Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
 | LookUp(String) | Checks if query is in the main dictionary or user.
 | LookUpMainDictionary(String) | Checks if query is in the word dictionary. Returns true if doesnt start with a letter or apostrophe
 | LookUpUserDictionary(String) | Look up the query in the user dictionary if it exists.
 | MakeCap(String) | Capitalises first letter of word
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NextBadWord()()()() | Returns the next mis-spelt word in the text, as a BadWord object.
 | PHONETIC_SUGGESTIONS | Indicator for suggestion method (Hashing is default).
 | ReloadUserDictionary()()()() | Reloads the user dictionary.
 | RemoveIgnorePattern(String) | Removes a regex pattern to ignore (maximum of 20 can be added - IgnoreURLsAndEmailAddresses=true counts as 1).
 | RevertToUndoableStatePoint(RapidSpellChecker..::..State) | Reverts the state to what it was when GetUndoableStatePoint()()()() was called.
 | SetConsiderationRange(Int32) | Sets the factor for words to consider for suggestions, lower values are faster but consider less words for suggestions. Default is 80. If w <= 1 this method won't do anything.
 | SetDictFileStream(Stream, String, DateTime) | Passes a Dict file as a stream, to be used for the main dictionary.
 | SetIgnoreCapitalizedWords(Boolean) | Sets whether to ignore words with capital letters.
 | SetIncludeUserDictionaryInSuggestions(Boolean) | Sets whether the user dictionary should be used in finding suggestions for misspelt words.
 | SetOptionalContext(String, String) | Provides the engine with any helpful text around the text snippet which will be passed to the Check method.
 | SetPosition(Int32) | Sets the pointer position for the NextBadWord iterator.
 | SetSeparateHyphenWords(Boolean) | Sets whether to treat hyphenated (-) words as separate words, default is false.
 | SetSuggestionsMethod(Int32) | Obsolete. Sets the suggestions method to use. Either PHONETIC_SUGGESTIONS or HASHING_SUGGESTIONS
 | SetUserDictionary(String) | Set the user dictionary to use.
 | SetUserDictionary(UserDictionary) | Set the user dictionary to use.
 | ShareDictionary | Obsolete. Whether to share the dictionary in memory across all instances of RapidSpellChecker (false by default).
 | SuggestionsMethod | The method used for suggestions, default is Hashing
 | SuggestSplitWords | Whether to look for connected words in suggestions.
 | TextBoundary | The AdvancedTextBoundary class to use to parse words.
 | theCurrentBadWord | The current badword
 | theText | The text being checked.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | UnloadMainDictionary()()()() | Obsolete. Empties the main dictionary store.
 | userDictionary | The UserDictionary being used, may be null if no user dictionary is being used.
 | V2Parser | Whether to use parser version 2 - Set to false for backwards compatibility.
 | WarnDuplicates | Whether to treat duplicate words as errors (eg. "this is is an error").
 | WordAdded | Fired when word added to user dictionary
 | WordChanged | Change word event, fired when a word is changed.
 | wordEnd | The end index of the current word being checked/parsed.
 | WordIgnored | Fired when word ignored
 | wordStart | The start index of the current word being checked/parsed.
Remarks
This is a non-GUI component, suitable for the business/logic layer of your application. You would use this component in web server based applications. This component can be used in 2 different ways. The most common usage, in an iterative fashion is detailed below, but it may also be used on a query by query basis. To use this component in an iterative way you must first call Check to set the text to check and then iterate through NextBadWord() to identify misspelt words. NextBadWord will return a BadWord object and internally locate the the misspelt word in the text, then you can call FindSuggestions which will return a ArrayList of suggestions as String objects. You may also call ChangeBadWord(replacement) to replace that current misspelt word in the text. NextBadWord() will return null when the text has been checked. GetAmendedText returns the current state of the text with corrections. Calling ChangeBadWord or FindSuggestions before NextBadWord has been called and returned a BadWord (i.e. not null) will result in a NoCurrentBadWordException
Remarks

The second way to use this component is simply to query words yourself using LookUp(word) to check if word is in the lexicon/dictionary and FindSuggestions(word) to find spelling suggestions for word.

Examples
Check some text, find suggestions and replace mis-spelt words with "replacement".
Copy image Copy
RapidSpellChecker c = new RapidSpellChecker();
BadWord badWord;
ArrayList suggestions;

 //check some text.
c.Check("This is sume text.");

//iterate through all bad words in the text.
while((badWord = c.NextBadWord())!=null){

    Console.WriteLine(badWord.GetWord() + "- is not spelt correctly. Suggestions:");

    try{
        //get suggestions for the current bad word.
        suggestions = c.FindSuggestions();

        //display all suggestions.
        for(int i=0; i<suggestions.Count; i++){
            Console.WriteLine(suggestions[i]);
        }

        //change the bad word in the text with "replacement".
        c.ChangeBadWord("replacement");

    } catch (NoCurrentBadWordException e){
        Console.WriteLine(e);
    }

}
Console.WriteLine(c.GetAmendedText());
Inheritance Hierarchy
Object
RapidSpellChecker


RapidSpellChecker Constructor

Keyoti RapidSpell Desktop .NET API Docs
RapidSpellChecker Constructor
API ► Keyoti.RapidSpell ► RapidSpellChecker ► RapidSpellChecker()()()()
Keyoti RapidSpell Desktop .NET
Creates a RapidSpellChecker, with no user dictionary.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public RapidSpellChecker()
public RapidSpellChecker()
Public Sub New
Public Sub New
public:
RapidSpellChecker()
public:
RapidSpellChecker()
new : unit -> RapidSpellChecker
new : unit -> RapidSpellChecker
Exceptions
Exception | Condition
ApplicationException | If the dictionary cannot be read.


AddIgnorePattern Method (p)

Keyoti RapidSpell Desktop .NET API Docs
AddIgnorePattern Method (p)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► AddIgnorePattern(String)
Keyoti RapidSpell Desktop .NET
Adds a regex pattern to ignore (maximum of 20 can be added - IgnoreURLsAndEmailAddresses=true counts as 1).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void AddIgnorePattern(
    string p
)
public virtual void AddIgnorePattern(
    string p
)
Public Overridable Sub AddIgnorePattern (
    p As String
)
Public Overridable Sub AddIgnorePattern (
    p As String
)
public:
virtual void AddIgnorePattern(
    String^ p
)
public:
virtual void AddIgnorePattern(
    String^ p
)
abstract AddIgnorePattern :
        p : string -> unit
override AddIgnorePattern :
        p : string -> unit
abstract AddIgnorePattern :
        p : string -> unit
override AddIgnorePattern :
        p : string -> unit
Parameters
p (String)
Remarks
Eg, to ignore email addresses either set IgnoreURLsAndEmailAddresses=true or AddIgnorePattern("^(?:[0-9a-zA-Z](?:[-.\w]*[0-9a-zA-Z])*@(?:[0-9a-zA-Z][-\w]*[0-9a-zA-Z]\.)+[a-zA-Z]{2,9})$").


AddWord Method (word)

Keyoti RapidSpell Desktop .NET API Docs
AddWord Method (word)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► AddWord(String)
Keyoti RapidSpell Desktop .NET
Adds word to the user dictionary (if it has been specified).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool AddWord(
    string word
)
public virtual bool AddWord(
    string word
)
Public Overridable Function AddWord (
    word As String
) As Boolean
Public Overridable Function AddWord (
    word As String
) As Boolean
public:
virtual bool AddWord(
    String^ word
)
public:
virtual bool AddWord(
    String^ word
)
abstract AddWord :
        word : string -> bool
override AddWord :
        word : string -> bool
abstract AddWord :
        word : string -> bool
override AddWord :
        word : string -> bool
Parameters
word (String)
String to add to user dictionary, if it is being used.
Return Value
Boolean
boolean true if the word was is now in the user dictionary, false if the word could not be added to the user dictionary.
Exceptions
Exception | Condition
ArgumentNullException | If word parameter is null.


AllowAnyCase Property

Keyoti RapidSpell Desktop .NET API Docs
AllowAnyCase Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► AllowAnyCase
Keyoti RapidSpell Desktop .NET
Whether to allow words spelt with incorrect case, eg. "africa", instead of "Africa", this is more relaxed than AllowMixedCase
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool AllowAnyCase { get; set; }
public bool AllowAnyCase { get; set; }
Public Property AllowAnyCase As Boolean
    Get
    Set
Public Property AllowAnyCase As Boolean
    Get
    Set
public:
virtual property bool AllowAnyCase {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool AllowAnyCase {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract AllowAnyCase : bool with get, set
override AllowAnyCase : bool with get, set
abstract AllowAnyCase : bool with get, set
override AllowAnyCase : bool with get, set
Property Value
Boolean


AllowMixedCase Property

Keyoti RapidSpell Desktop .NET API Docs
AllowMixedCase Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► AllowMixedCase
Keyoti RapidSpell Desktop .NET
Whether to allow words spelt with mixed case, eg. "MIxEd" - also see AllowAnyCase.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool AllowMixedCase { get; set; }
public bool AllowMixedCase { get; set; }
Public Property AllowMixedCase As Boolean
    Get
    Set
Public Property AllowMixedCase As Boolean
    Get
    Set
public:
virtual property bool AllowMixedCase {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool AllowMixedCase {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract AllowMixedCase : bool with get, set
override AllowMixedCase : bool with get, set
abstract AllowMixedCase : bool with get, set
override AllowMixedCase : bool with get, set
Property Value
Boolean


ChangeAll Method (newWord)

Keyoti RapidSpell Desktop .NET API Docs
ChangeAll Method (newWord)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► ChangeAll(String)
Keyoti RapidSpell Desktop .NET
Changes all instances of the current bad word to newWord in the text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void ChangeAll(
    string newWord
)
public virtual void ChangeAll(
    string newWord
)
Public Overridable Sub ChangeAll (
    newWord As String
)
Public Overridable Sub ChangeAll (
    newWord As String
)
public:
virtual void ChangeAll(
    String^ newWord
)
public:
virtual void ChangeAll(
    String^ newWord
)
abstract ChangeAll :
        newWord : string -> unit
override ChangeAll :
        newWord : string -> unit
abstract ChangeAll :
        newWord : string -> unit
override ChangeAll :
        newWord : string -> unit
Parameters
newWord (String)
Exceptions
Exception | Condition
NoCurrentBadWordException | if nextBadWord() hasn't been run first AND found an erroneous word.
ArgumentNullException | if newWord parameter is null.


ChangeBadWord Method

Keyoti RapidSpell Desktop .NET API Docs
ChangeBadWord Method
API ► Keyoti.RapidSpell ► RapidSpellChecker ► ChangeBadWord()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | ChangeBadWord(String) | Changes the current bad word to newWord in the text.
 | ChangeBadWord(BadWord, String) | Changes badWord to newWord in the text.


ChangeBadWord Method (badWord, newWord)

Keyoti RapidSpell Desktop .NET API Docs
ChangeBadWord Method (badWord, newWord)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► ChangeBadWord(BadWord, String)
Keyoti RapidSpell Desktop .NET
Changes badWord to newWord in the text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void ChangeBadWord(
    BadWord badWord,
    string newWord
)
public virtual void ChangeBadWord(
    BadWord badWord,
    string newWord
)
Public Overridable Sub ChangeBadWord (
    badWord As BadWord,
    newWord As String
)
Public Overridable Sub ChangeBadWord (
    badWord As BadWord,
    newWord As String
)
public:
virtual void ChangeBadWord(
    BadWord^ badWord,
    String^ newWord
)
public:
virtual void ChangeBadWord(
    BadWord^ badWord,
    String^ newWord
)
abstract ChangeBadWord :
        badWord : BadWord *
        newWord : string -> unit
override ChangeBadWord :
        badWord : BadWord *
        newWord : string -> unit
abstract ChangeBadWord :
        badWord : BadWord *
        newWord : string -> unit
override ChangeBadWord :
        badWord : BadWord *
        newWord : string -> unit
Parameters
badWord (BadWord)
word to replace
newWord (String)
replaces the current misspelt word.
Return Value

void
Exceptions
Exception | Condition
ArgumentNullException | if newWord parameter is null.


ChangeBadWord Method (newWord)

Keyoti RapidSpell Desktop .NET API Docs
ChangeBadWord Method (newWord)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► ChangeBadWord(String)
Keyoti RapidSpell Desktop .NET
Changes the current bad word to newWord in the text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void ChangeBadWord(
    string newWord
)
public void ChangeBadWord(
    string newWord
)
Public Sub ChangeBadWord (
    newWord As String
)
Public Sub ChangeBadWord (
    newWord As String
)
public:
virtual void ChangeBadWord(
    String^ newWord
) sealed
public:
virtual void ChangeBadWord(
    String^ newWord
) sealed
abstract ChangeBadWord :
        newWord : string -> unit
override ChangeBadWord :
        newWord : string -> unit
abstract ChangeBadWord :
        newWord : string -> unit
override ChangeBadWord :
        newWord : string -> unit
Parameters
newWord (String)
Replaces the current misspelt word.
Return Value

void
Exceptions
Exception | Condition
NoCurrentBadWordException | if nextBadWord() hasn't been run first AND found an erroneous word.
ArgumentNullException | if newWord parameter is null.


Check Method

Keyoti RapidSpell Desktop .NET API Docs
Check Method
API ► Keyoti.RapidSpell ► RapidSpellChecker ► Check()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Check(String) | Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.
 | Check(String, Boolean) | Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.
 | Check(String, Int32) | Checks text for spelling correctness, from startPosition in text, mis-spelt words can be accessed through NextBadWord.
 | Check(String, Int32, Boolean) | Checks text for spelling correctness, from startPosition in text, mis-spelt words can be accessed through NextBadWord.


Check Method (text)

Keyoti RapidSpell Desktop .NET API Docs
Check Method (text)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► Check(String)
Keyoti RapidSpell Desktop .NET
Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void Check(
    string text
)
public void Check(
    string text
)
Public Sub Check (
    text As String
)
Public Sub Check (
    text As String
)
public:
virtual void Check(
    String^ text
) sealed
public:
virtual void Check(
    String^ text
) sealed
abstract Check :
        text : string -> unit
override Check :
        text : string -> unit
abstract Check :
        text : string -> unit
override Check :
        text : string -> unit
Parameters
text (String)
to spell check.
Return Value

void
Exceptions
Exception | Condition
ArgumentNullException | if text parameter is null.


Check Method (text, isStartOfTextBody)

Keyoti RapidSpell Desktop .NET API Docs
Check Method (text, isStartOfTextBody)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► Check(String, Boolean)
Keyoti RapidSpell Desktop .NET
Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void Check(
    string text,
    bool isStartOfTextBody
)
public void Check(
    string text,
    bool isStartOfTextBody
)
Public Sub Check (
    text As String,
    isStartOfTextBody As Boolean
)
Public Sub Check (
    text As String,
    isStartOfTextBody As Boolean
)
public:
virtual void Check(
    String^ text,
    bool isStartOfTextBody
) sealed
public:
virtual void Check(
    String^ text,
    bool isStartOfTextBody
) sealed
abstract Check :
        text : string *
        isStartOfTextBody : bool -> unit
override Check :
        text : string *
        isStartOfTextBody : bool -> unit
abstract Check :
        text : string *
        isStartOfTextBody : bool -> unit
override Check :
        text : string *
        isStartOfTextBody : bool -> unit
Parameters
text (String)
to spell check.
isStartOfTextBody (Boolean)
whether the text being spell checked is at the start of the text body (eg. start of text box), this affects sentence capitalization determination.
Return Value

void
Exceptions
Exception | Condition
ArgumentNullException | if text parameter is null.


Check Method (text, startPosition)

Keyoti RapidSpell Desktop .NET API Docs
Check Method (text, startPosition)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► Check(String, Int32)
Keyoti RapidSpell Desktop .NET
Checks text for spelling correctness, from startPosition in text, mis-spelt words can be accessed through NextBadWord.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void Check(
    string text,
    int startPosition
)
public void Check(
    string text,
    int startPosition
)
Public Sub Check (
    text As String,
    startPosition As Integer
)
Public Sub Check (
    text As String,
    startPosition As Integer
)
public:
void Check(
    String^ text,
    int startPosition
)
public:
void Check(
    String^ text,
    int startPosition
)
member Check :
        text : string *
        startPosition : int -> unit

member Check :
        text : string *
        startPosition : int -> unit
Parameters
text (String)
the text to be checked
startPosition (Int32)
the position in the text to begin checking from
Return Value

void
Remarks
startPosition should be >=0 but if it is < 0 it is set = 0.
Exceptions
Exception | Condition
ArgumentNullException | if text parameter is null.


Check Method (text, startPosition, isStartOfTextBody)

Keyoti RapidSpell Desktop .NET API Docs
Check Method (text, startPosition, isStartOfTextBody)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► Check(String, Int32, Boolean)
Keyoti RapidSpell Desktop .NET
Checks text for spelling correctness, from startPosition in text, mis-spelt words can be accessed through NextBadWord.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void Check(
    string text,
    int startPosition,
    bool isStartOfTextBody
)
public virtual void Check(
    string text,
    int startPosition,
    bool isStartOfTextBody
)
Public Overridable Sub Check (
    text As String,
    startPosition As Integer,
    isStartOfTextBody As Boolean
)
Public Overridable Sub Check (
    text As String,
    startPosition As Integer,
    isStartOfTextBody As Boolean
)
public:
virtual void Check(
    String^ text,
    int startPosition,
    bool isStartOfTextBody
)
public:
virtual void Check(
    String^ text,
    int startPosition,
    bool isStartOfTextBody
)
abstract Check :
        text : string *
        startPosition : int *
        isStartOfTextBody : bool -> unit
override Check :
        text : string *
        startPosition : int *
        isStartOfTextBody : bool -> unit
abstract Check :
        text : string *
        startPosition : int *
        isStartOfTextBody : bool -> unit
override Check :
        text : string *
        startPosition : int *
        isStartOfTextBody : bool -> unit
Parameters
text (String)
the text to be checked
startPosition (Int32)
the position in the text to begin checking from
isStartOfTextBody (Boolean)
whether the text being spell checked is at the start of the text body (eg. start of text box), this affects sentence capitalization determination.
Return Value

void
Remarks
startPosition should be >=0 but if it is < 0 it is set = 0.
Exceptions
Exception | Condition
ArgumentNullException | if text parameter is null.


CheckCompoundWords Property

Keyoti RapidSpell Desktop .NET API Docs
CheckCompoundWords Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► CheckCompoundWords
Keyoti RapidSpell Desktop .NET
Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool CheckCompoundWords { get; set; }
public bool CheckCompoundWords { get; set; }
Public Property CheckCompoundWords As Boolean
    Get
    Set
Public Property CheckCompoundWords As Boolean
    Get
    Set
public:
virtual property bool CheckCompoundWords {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool CheckCompoundWords {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract CheckCompoundWords : bool with get, set
override CheckCompoundWords : bool with get, set
abstract CheckCompoundWords : bool with get, set
override CheckCompoundWords : bool with get, set
Property Value
Boolean
Remarks
If this=false then LookUp("thesewordsarejoined") = false

If this=true then LookUp("thesewordsarejoined") = true

If this=false then LookUp("abcdef") = false

If this=true then LookUp("abcdef") = false

Setting this to true will degrade lookup performance by a maximum of approx. 100[1-1/n] percent (where n is the number of letters in the word) for misspelt words. There is no preformance degredation for correctly spelt words. On average for texts with mostly correctly spelt words the performance degredation for the Check method is roughly 25%.


convertHtmlEntities Method

Keyoti RapidSpell Desktop .NET API Docs
convertHtmlEntities Method
API ► Keyoti.RapidSpell ► RapidSpellChecker ► convertHtmlEntities()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | convertHtmlEntities(String) | Converts HTML entity codes to their Unicode characters
 | convertHtmlEntities(String, Boolean) | Converts HTML entity codes to their Unicode characters


convertHtmlEntities Method (text)

Keyoti RapidSpell Desktop .NET API Docs
convertHtmlEntities Method (text)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► convertHtmlEntities(String)
Keyoti RapidSpell Desktop .NET
Converts HTML entity codes to their Unicode characters
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static string convertHtmlEntities(
    string text
)
public static string convertHtmlEntities(
    string text
)
Public Shared Function convertHtmlEntities (
    text As String
) As String
Public Shared Function convertHtmlEntities (
    text As String
) As String
public:
static String^ convertHtmlEntities(
    String^ text
)
public:
static String^ convertHtmlEntities(
    String^ text
)
static member convertHtmlEntities :
        text : string -> string

static member convertHtmlEntities :
        text : string -> string
Parameters
text (String)
Return Value
String


convertHtmlEntities Method (text, convertAMP)

Keyoti RapidSpell Desktop .NET API Docs
convertHtmlEntities Method (text, convertAMP)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► convertHtmlEntities(String, Boolean)
Keyoti RapidSpell Desktop .NET
Converts HTML entity codes to their Unicode characters
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static string convertHtmlEntities(
    string text,
    bool convertAMP
)
public static string convertHtmlEntities(
    string text,
    bool convertAMP
)
Public Shared Function convertHtmlEntities (
    text As String,
    convertAMP As Boolean
) As String
Public Shared Function convertHtmlEntities (
    text As String,
    convertAMP As Boolean
) As String
public:
static String^ convertHtmlEntities(
    String^ text,
    bool convertAMP
)
public:
static String^ convertHtmlEntities(
    String^ text,
    bool convertAMP
)
static member convertHtmlEntities :
        text : string *
        convertAMP : bool -> string

static member convertHtmlEntities :
        text : string *
        convertAMP : bool -> string
Parameters
text (String)
The text containing the entities to convert.
convertAMP (Boolean)
Whether to convert &amp; entities to &
Return Value
String


CurrentBadWord Property

Keyoti RapidSpell Desktop .NET API Docs
CurrentBadWord Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► CurrentBadWord
Keyoti RapidSpell Desktop .NET
Gets the current bad word (last returned by NextBadWord).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public BadWord CurrentBadWord { get; }
public BadWord CurrentBadWord { get; }
Public ReadOnly Property CurrentBadWord As BadWord
    Get
Public ReadOnly Property CurrentBadWord As BadWord
    Get
public:
virtual property BadWord^ CurrentBadWord {
    BadWord^ get () sealed;
}
public:
virtual property BadWord^ CurrentBadWord {
    BadWord^ get () sealed;
}
abstract CurrentBadWord : BadWord with get
override CurrentBadWord : BadWord with get
abstract CurrentBadWord : BadWord with get
override CurrentBadWord : BadWord with get
Property Value
BadWord


DictFilePath Property

Keyoti RapidSpell Desktop .NET API Docs
DictFilePath Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► DictFilePath
Keyoti RapidSpell Desktop .NET
The file to be used as the main dictionary (either a full file path, or the name of an embedded resource), if this is null then the built-in US English dictionary is used.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string DictFilePath { get; set; }
public string DictFilePath { get; set; }
Public Property DictFilePath As String
    Get
    Set
Public Property DictFilePath As String
    Get
    Set
public:
virtual property String^ DictFilePath {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ DictFilePath {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract DictFilePath : string with get, set
override DictFilePath : string with get, set
abstract DictFilePath : string with get, set
override DictFilePath : string with get, set
Property Value
String


Dispose Method

Keyoti RapidSpell Desktop .NET API Docs
Dispose Method
API ► Keyoti.RapidSpell ► RapidSpellChecker ► Dispose()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Dispose(Boolean) | Disposes of resources.
 | Dispose()()()() | Clean up any resources being used.


Dispose Method

Keyoti RapidSpell Desktop .NET API Docs
Dispose Method
API ► Keyoti.RapidSpell ► RapidSpellChecker ► Dispose()()()()
Keyoti RapidSpell Desktop .NET
Clean up any resources being used.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void Dispose()
public virtual void Dispose()
Public Overridable Sub Dispose
Public Overridable Sub Dispose
public:
virtual void Dispose()
public:
virtual void Dispose()
abstract Dispose : unit -> unit
override Dispose : unit -> unit
abstract Dispose : unit -> unit
override Dispose : unit -> unit


Dispose Method (disposing)

Keyoti RapidSpell Desktop .NET API Docs
Dispose Method (disposing)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► Dispose(Boolean)
Keyoti RapidSpell Desktop .NET
Disposes of resources.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void Dispose(
    bool disposing
)
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
)
protected:
virtual void Dispose(
    bool disposing
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
Parameters
disposing (Boolean)


dontSuggest Field

Keyoti RapidSpell Desktop .NET API Docs
dontSuggest Field
API ► Keyoti.RapidSpell ► RapidSpellChecker ► dontSuggest
Keyoti RapidSpell Desktop .NET
Don't suggest words in this array (swear words).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected string[] dontSuggest
protected string[] dontSuggest
Protected dontSuggest As String()
Protected dontSuggest As String()
protected:
array<String^>^ dontSuggest
protected:
array<String^>^ dontSuggest
val mutable dontSuggest: string[]
val mutable dontSuggest: string[]
Field Value
array< String >[]()[][]


Finalize Method

Keyoti RapidSpell Desktop .NET API Docs
Finalize Method
API ► Keyoti.RapidSpell ► RapidSpellChecker ► Finalize()()()()
Keyoti RapidSpell Desktop .NET
Frees up resources.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override void Finalize()
protected override void Finalize()
Protected Overrides Sub Finalize
Protected Overrides Sub Finalize
protected:
virtual void Finalize() override
protected:
virtual void Finalize() override
abstract Finalize : unit -> unit
override Finalize : unit -> unit
abstract Finalize : unit -> unit
override Finalize : unit -> unit


FindAnagrams Method (word, anagrams)

Keyoti RapidSpell Desktop .NET API Docs
FindAnagrams Method (word, anagrams)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► FindAnagrams(String, IList)
Keyoti RapidSpell Desktop .NET
Finds anagrams of word and puts them in anagrams if not already present.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void FindAnagrams(
    string word,
    IList anagrams
)
public virtual void FindAnagrams(
    string word,
    IList anagrams
)
Public Overridable Sub FindAnagrams (
    word As String,
    anagrams As IList
)
Public Overridable Sub FindAnagrams (
    word As String,
    anagrams As IList
)
public:
virtual void FindAnagrams(
    String^ word,
    IList^ anagrams
)
public:
virtual void FindAnagrams(
    String^ word,
    IList^ anagrams
)
abstract FindAnagrams :
        word : string *
        anagrams : IList -> unit
override FindAnagrams :
        word : string *
        anagrams : IList -> unit
abstract FindAnagrams :
        word : string *
        anagrams : IList -> unit
override FindAnagrams :
        word : string *
        anagrams : IList -> unit
Parameters
word (String)
The word to find anagrams of
anagrams (IList)
A list that anagrams will be added to.
Remarks
Exceptions
Exception | Condition
ArgumentNullException | if word is null/nothing


FindCapitalizedSuggestions Property

Keyoti RapidSpell Desktop .NET API Docs
FindCapitalizedSuggestions Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► FindCapitalizedSuggestions
Keyoti RapidSpell Desktop .NET
Whether to look for capitalized suggestions, note this will slow FindSuggestions down by about 7 times.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool FindCapitalizedSuggestions { get; set; }
public bool FindCapitalizedSuggestions { get; set; }
Public Property FindCapitalizedSuggestions As Boolean
    Get
    Set
Public Property FindCapitalizedSuggestions As Boolean
    Get
    Set
public:
virtual property bool FindCapitalizedSuggestions {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool FindCapitalizedSuggestions {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract FindCapitalizedSuggestions : bool with get, set
override FindCapitalizedSuggestions : bool with get, set
abstract FindCapitalizedSuggestions : bool with get, set
override FindCapitalizedSuggestions : bool with get, set
Property Value
Boolean


FindCompoundWords Method (text, subwords, lengthLimit)

Keyoti RapidSpell Desktop .NET API Docs
FindCompoundWords Method (text, subwords, lengthLimit)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► FindCompoundWords(String, IList, Boolean)
Keyoti RapidSpell Desktop .NET
Finds the compound words in text and puts them in subwords, set subwords to null/nothing to just find if text has compound word formation.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool FindCompoundWords(
    string text,
    IList subwords,
    bool lengthLimit
)
public virtual bool FindCompoundWords(
    string text,
    IList subwords,
    bool lengthLimit
)
Public Overridable Function FindCompoundWords (
    text As String,
    subwords As IList,
    lengthLimit As Boolean
) As Boolean
Public Overridable Function FindCompoundWords (
    text As String,
    subwords As IList,
    lengthLimit As Boolean
) As Boolean
public:
virtual bool FindCompoundWords(
    String^ text,
    IList^ subwords,
    bool lengthLimit
)
public:
virtual bool FindCompoundWords(
    String^ text,
    IList^ subwords,
    bool lengthLimit
)
abstract FindCompoundWords :
        text : string *
        subwords : IList *
        lengthLimit : bool -> bool
override FindCompoundWords :
        text : string *
        subwords : IList *
        lengthLimit : bool -> bool
abstract FindCompoundWords :
        text : string *
        subwords : IList *
        lengthLimit : bool -> bool
override FindCompoundWords :
        text : string *
        subwords : IList *
        lengthLimit : bool -> bool
Parameters
text (String)
The text to find compound words in
subwords (IList)
A list that formative sub-words will be added to, can be null/nothing.
lengthLimit (Boolean)
Whether to restrict lookups to words under 10 characters long. Looking up compounds for very long words can cause slow downs.
Return Value
Boolean
True if text is entirely formed from compound words, False if not.
Remarks
Only adds words to list if all are valid. In other words, this will not find all words that are part of text, but only the words that all make up text.

Eg. "catchmentarea" has words "catchment" and "area" but not "cat", "me" etc.

The order of the words in the list is the reverse of their order in text.
Exceptions
Exception | Condition
ArgumentNullException | if text is null


FindSuggestions Method

Keyoti RapidSpell Desktop .NET API Docs
FindSuggestions Method
API ► Keyoti.RapidSpell ► RapidSpellChecker ► FindSuggestions()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | FindSuggestions()()()() | Gets an enumeration of String suggestions for spelling of current bad word.
 | FindSuggestions(String) | Gets an enumeration of String suggestions for word.
 | FindSuggestions(String, Boolean) | Gets an enumeration of String suggestions for word.


FindSuggestions Method

Keyoti RapidSpell Desktop .NET API Docs
FindSuggestions Method
API ► Keyoti.RapidSpell ► RapidSpellChecker ► FindSuggestions()()()()
Keyoti RapidSpell Desktop .NET
Gets an enumeration of String suggestions for spelling of current bad word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual ArrayList FindSuggestions()
public virtual ArrayList FindSuggestions()
Public Overridable Function FindSuggestions As ArrayList
Public Overridable Function FindSuggestions As ArrayList
public:
virtual ArrayList^ FindSuggestions()
public:
virtual ArrayList^ FindSuggestions()
abstract FindSuggestions : unit -> ArrayList
override FindSuggestions : unit -> ArrayList
abstract FindSuggestions : unit -> ArrayList
override FindSuggestions : unit -> ArrayList
Return Value
ArrayList
ArrayList of String suggestions for current bad word.
Exceptions
Exception | Condition
NoCurrentBadWordException | If NextBadWord() hasn't been run first AND found an erroneous word.


FindSuggestions Method (word)

Keyoti RapidSpell Desktop .NET API Docs
FindSuggestions Method (word)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► FindSuggestions(String)
Keyoti RapidSpell Desktop .NET
Gets an enumeration of String suggestions for word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual ArrayList FindSuggestions(
    string word
)
public virtual ArrayList FindSuggestions(
    string word
)
Public Overridable Function FindSuggestions (
    word As String
) As ArrayList
Public Overridable Function FindSuggestions (
    word As String
) As ArrayList
public:
virtual ArrayList^ FindSuggestions(
    String^ word
)
public:
virtual ArrayList^ FindSuggestions(
    String^ word
)
abstract FindSuggestions :
        word : string -> ArrayList
override FindSuggestions :
        word : string -> ArrayList
abstract FindSuggestions :
        word : string -> ArrayList
override FindSuggestions :
        word : string -> ArrayList
Parameters
word (String)
the word to check the spelling of.
Return Value
ArrayList
ArrayList of String suggestions for word.
Exceptions
Exception | Condition
ArgumentNullException | if word parameter is null.


FindSuggestions Method (word, searchLowerCase)

Keyoti RapidSpell Desktop .NET API Docs
FindSuggestions Method (word, searchLowerCase)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► FindSuggestions(String, Boolean)
Keyoti RapidSpell Desktop .NET
Gets an enumeration of String suggestions for word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual ArrayList FindSuggestions(
    string word,
    bool searchLowerCase
)
protected virtual ArrayList FindSuggestions(
    string word,
    bool searchLowerCase
)
Protected Overridable Function FindSuggestions (
    word As String,
    searchLowerCase As Boolean
) As ArrayList
Protected Overridable Function FindSuggestions (
    word As String,
    searchLowerCase As Boolean
) As ArrayList
protected:
virtual ArrayList^ FindSuggestions(
    String^ word,
    bool searchLowerCase
)
protected:
virtual ArrayList^ FindSuggestions(
    String^ word,
    bool searchLowerCase
)
abstract FindSuggestions :
        word : string *
        searchLowerCase : bool -> ArrayList
override FindSuggestions :
        word : string *
        searchLowerCase : bool -> ArrayList
abstract FindSuggestions :
        word : string *
        searchLowerCase : bool -> ArrayList
override FindSuggestions :
        word : string *
        searchLowerCase : bool -> ArrayList
Parameters
word (String)
the word to check the spelling of.
searchLowerCase (Boolean)
whether to return suggestions for word in a lower case form (if it's capitalized).
Return Value
ArrayList
ArrayList of String suggestions for word.
Exceptions
Exception | Condition
ArgumentNullException | if word parameter is null.


GetAmendedText Method

Keyoti RapidSpell Desktop .NET API Docs
GetAmendedText Method
API ► Keyoti.RapidSpell ► RapidSpellChecker ► GetAmendedText()()()()
Keyoti RapidSpell Desktop .NET
Returns the original text sent to check() but with any alterations made through change
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual string GetAmendedText()
public virtual string GetAmendedText()
Public Overridable Function GetAmendedText As String
Public Overridable Function GetAmendedText As String
public:
virtual String^ GetAmendedText()
public:
virtual String^ GetAmendedText()
abstract GetAmendedText : unit -> string
override GetAmendedText : unit -> string
abstract GetAmendedText : unit -> string
override GetAmendedText : unit -> string
Return Value
String
String the text after corrections, null if there is no text.


GetConsiderationRange Method

Keyoti RapidSpell Desktop .NET API Docs
GetConsiderationRange Method
API ► Keyoti.RapidSpell ► RapidSpellChecker ► GetConsiderationRange()()()()
Keyoti RapidSpell Desktop .NET
Gets the factor for words to consider for suggestions.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int GetConsiderationRange()
public int GetConsiderationRange()
Public Function GetConsiderationRange As Integer
Public Function GetConsiderationRange As Integer
public:
virtual int GetConsiderationRange() sealed
public:
virtual int GetConsiderationRange() sealed
abstract GetConsiderationRange : unit -> int
override GetConsiderationRange : unit -> int
abstract GetConsiderationRange : unit -> int
override GetConsiderationRange : unit -> int
Return Value
Int32


GetIgnoreCapitalizedWords Method

Keyoti RapidSpell Desktop .NET API Docs
GetIgnoreCapitalizedWords Method
API ► Keyoti.RapidSpell ► RapidSpellChecker ► GetIgnoreCapitalizedWords()()()()
Keyoti RapidSpell Desktop .NET
Gets whether to ignore words with capital letters.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool GetIgnoreCapitalizedWords()
public bool GetIgnoreCapitalizedWords()
Public Function GetIgnoreCapitalizedWords As Boolean
Public Function GetIgnoreCapitalizedWords As Boolean
public:
virtual bool GetIgnoreCapitalizedWords() sealed
public:
virtual bool GetIgnoreCapitalizedWords() sealed
abstract GetIgnoreCapitalizedWords : unit -> bool
override GetIgnoreCapitalizedWords : unit -> bool
abstract GetIgnoreCapitalizedWords : unit -> bool
override GetIgnoreCapitalizedWords : unit -> bool
Return Value
Boolean


GetIncludeUserDictionaryInSuggestions Method

Keyoti RapidSpell Desktop .NET API Docs
GetIncludeUserDictionaryInSuggestions Method
API ► Keyoti.RapidSpell ► RapidSpellChecker ► GetIncludeUserDictionaryInSuggestions()()()()
Keyoti RapidSpell Desktop .NET
Gets whether the user dictionary should be used in finding suggestions for misspelt words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool GetIncludeUserDictionaryInSuggestions()
public bool GetIncludeUserDictionaryInSuggestions()
Public Function GetIncludeUserDictionaryInSuggestions As Boolean
Public Function GetIncludeUserDictionaryInSuggestions As Boolean
public:
virtual bool GetIncludeUserDictionaryInSuggestions() sealed
public:
virtual bool GetIncludeUserDictionaryInSuggestions() sealed
abstract GetIncludeUserDictionaryInSuggestions : unit -> bool
override GetIncludeUserDictionaryInSuggestions : unit -> bool
abstract GetIncludeUserDictionaryInSuggestions : unit -> bool
override GetIncludeUserDictionaryInSuggestions : unit -> bool
Return Value
Boolean


GetNextWord Method

Keyoti RapidSpell Desktop .NET API Docs
GetNextWord Method
API ► Keyoti.RapidSpell ► RapidSpellChecker ► GetNextWord()()()()
Keyoti RapidSpell Desktop .NET
Returns the next word in the text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected internal virtual string GetNextWord()
protected internal virtual string GetNextWord()
Protected Friend Overridable Function GetNextWord As String
Protected Friend Overridable Function GetNextWord As String
protected public:
virtual String^ GetNextWord()
protected public:
virtual String^ GetNextWord()
abstract GetNextWord : unit -> string
override GetNextWord : unit -> string
abstract GetNextWord : unit -> string
override GetNextWord : unit -> string
Return Value
String
String the next word in the text


GetSeparateHyphenWords Method

Keyoti RapidSpell Desktop .NET API Docs
GetSeparateHyphenWords Method
API ► Keyoti.RapidSpell ► RapidSpellChecker ► GetSeparateHyphenWords()()()()
Keyoti RapidSpell Desktop .NET
Gets whether to treat hyphenated (-) words as separate words, default is false.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool GetSeparateHyphenWords()
public bool GetSeparateHyphenWords()
Public Function GetSeparateHyphenWords As Boolean
Public Function GetSeparateHyphenWords As Boolean
public:
bool GetSeparateHyphenWords()
public:
bool GetSeparateHyphenWords()
member GetSeparateHyphenWords : unit -> bool

member GetSeparateHyphenWords : unit -> bool
Return Value
Boolean
Remarks
For eg. if this is true text like "cheap-deals" will be treated as two words "cheap" and "deals", otherwise this will be treated as one word "cheap-deals".


GetSuggestionsMethod Method

Keyoti RapidSpell Desktop .NET API Docs
GetSuggestionsMethod Method
API ► Keyoti.RapidSpell ► RapidSpellChecker ► GetSuggestionsMethod()()()()
Keyoti RapidSpell Desktop .NET
Gets the suggestions method to use. Either PHONETIC_SUGGESTIONS or HASHING_SUGGESTIONS
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
[ObsoleteAttribute("Please use SuggestionsMethod property instead, it can be set with the SuggestionsMethodType enum.",
    false)]
public virtual int GetSuggestionsMethod()
[ObsoleteAttribute("Please use SuggestionsMethod property instead, it can be set with the SuggestionsMethodType enum.",
    false)]
public virtual int GetSuggestionsMethod()
<ObsoleteAttribute("Please use SuggestionsMethod property instead, it can be set with the SuggestionsMethodType enum.",
    false)>
Public Overridable Function GetSuggestionsMethod As Integer
<ObsoleteAttribute("Please use SuggestionsMethod property instead, it can be set with the SuggestionsMethodType enum.",
    false)>
Public Overridable Function GetSuggestionsMethod As Integer
public:
[ObsoleteAttribute(L"Please use SuggestionsMethod property instead, it can be set with the SuggestionsMethodType enum.",
    false)]
virtual int GetSuggestionsMethod()
public:
[ObsoleteAttribute(L"Please use SuggestionsMethod property instead, it can be set with the SuggestionsMethodType enum.",
    false)]
virtual int GetSuggestionsMethod()
[<ObsoleteAttribute("Please use SuggestionsMethod property instead, it can be set with the SuggestionsMethodType enum.",
    false)>]
abstract GetSuggestionsMethod : unit -> int
[<ObsoleteAttribute("Please use SuggestionsMethod property instead, it can be set with the SuggestionsMethodType enum.",
    false)>]
override GetSuggestionsMethod : unit -> int
[<ObsoleteAttribute("Please use SuggestionsMethod property instead, it can be set with the SuggestionsMethodType enum.",
    false)>]
abstract GetSuggestionsMethod : unit -> int
[<ObsoleteAttribute("Please use SuggestionsMethod property instead, it can be set with the SuggestionsMethodType enum.",
    false)>]
override GetSuggestionsMethod : unit -> int
Return Value
Int32


GetUndoableStatePoint Method

Keyoti RapidSpell Desktop .NET API Docs
GetUndoableStatePoint Method
API ► Keyoti.RapidSpell ► RapidSpellChecker ► GetUndoableStatePoint()()()()
Keyoti RapidSpell Desktop .NET
Gets the state of the current run, which can be stored and used with RevertToUndoableStatePoint(RapidSpellChecker..::..State)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual RapidSpellChecker..::..State GetUndoableStatePoint()
public virtual RapidSpellChecker..::..State GetUndoableStatePoint()
Public Overridable Function GetUndoableStatePoint As RapidSpellChecker..::..State
Public Overridable Function GetUndoableStatePoint As RapidSpellChecker..::..State
public:
virtual RapidSpellChecker..::..State^ GetUndoableStatePoint()
public:
virtual RapidSpellChecker..::..State^ GetUndoableStatePoint()
abstract GetUndoableStatePoint : unit -> RapidSpellChecker..::..State
override GetUndoableStatePoint : unit -> RapidSpellChecker..::..State
abstract GetUndoableStatePoint : unit -> RapidSpellChecker..::..State
override GetUndoableStatePoint : unit -> RapidSpellChecker..::..State
Return Value
RapidSpellChecker..::..State
Returns the current state, or null if not supporting undo.


HASHING_SUGGESTIONS Field

Keyoti RapidSpell Desktop .NET API Docs
HASHING_SUGGESTIONS Field
API ► Keyoti.RapidSpell ► RapidSpellChecker ► HASHING_SUGGESTIONS
Keyoti RapidSpell Desktop .NET
Indicator for suggestion method (Hashing is default).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static int HASHING_SUGGESTIONS
public static int HASHING_SUGGESTIONS
Public Shared HASHING_SUGGESTIONS As Integer
Public Shared HASHING_SUGGESTIONS As Integer
public:
static int HASHING_SUGGESTIONS
public:
static int HASHING_SUGGESTIONS
static val mutable HASHING_SUGGESTIONS: int
static val mutable HASHING_SUGGESTIONS: int
Field Value
Int32


IgnoreAll Method (word)

Keyoti RapidSpell Desktop .NET API Docs
IgnoreAll Method (word)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► IgnoreAll(String)
Keyoti RapidSpell Desktop .NET
Marks word to be ignored in rest of the text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void IgnoreAll(
    string word
)
public virtual void IgnoreAll(
    string word
)
Public Overridable Sub IgnoreAll (
    word As String
)
Public Overridable Sub IgnoreAll (
    word As String
)
public:
virtual void IgnoreAll(
    String^ word
)
public:
virtual void IgnoreAll(
    String^ word
)
abstract IgnoreAll :
        word : string -> unit
override IgnoreAll :
        word : string -> unit
abstract IgnoreAll :
        word : string -> unit
override IgnoreAll :
        word : string -> unit
Parameters
word (String)
to ignore
Return Value

void
Exceptions
Exception | Condition
ArgumentNullException | if word parameter is null.


IgnoreAllCaseInsensitive Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreAllCaseInsensitive Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► IgnoreAllCaseInsensitive
Keyoti RapidSpell Desktop .NET
Whether Ignore All operations should be considered case insensitive (default false).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreAllCaseInsensitive { get; set; }
public bool IgnoreAllCaseInsensitive { get; set; }
Public Property IgnoreAllCaseInsensitive As Boolean
    Get
    Set
Public Property IgnoreAllCaseInsensitive As Boolean
    Get
    Set
public:
virtual property bool IgnoreAllCaseInsensitive {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool IgnoreAllCaseInsensitive {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IgnoreAllCaseInsensitive : bool with get, set
override IgnoreAllCaseInsensitive : bool with get, set
abstract IgnoreAllCaseInsensitive : bool with get, set
override IgnoreAllCaseInsensitive : bool with get, set
Property Value
Boolean


IgnoreIncorrectSentenceCapitalization Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreIncorrectSentenceCapitalization Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► IgnoreIncorrectSentenceCapitalization
Keyoti RapidSpell Desktop .NET
Whether to ignore incorrect sentence capitalization.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreIncorrectSentenceCapitalization { get; set; }
public bool IgnoreIncorrectSentenceCapitalization { get; set; }
Public Property IgnoreIncorrectSentenceCapitalization As Boolean
    Get
    Set
Public Property IgnoreIncorrectSentenceCapitalization As Boolean
    Get
    Set
public:
virtual property bool IgnoreIncorrectSentenceCapitalization {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool IgnoreIncorrectSentenceCapitalization {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IgnoreIncorrectSentenceCapitalization : bool with get, set
override IgnoreIncorrectSentenceCapitalization : bool with get, set
abstract IgnoreIncorrectSentenceCapitalization : bool with get, set
override IgnoreIncorrectSentenceCapitalization : bool with get, set
Property Value
Boolean


IgnoreInEnglishLowerCaseI Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreInEnglishLowerCaseI Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► IgnoreInEnglishLowerCaseI
Keyoti RapidSpell Desktop .NET
Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreInEnglishLowerCaseI { get; set; }
public bool IgnoreInEnglishLowerCaseI { get; set; }
Public Property IgnoreInEnglishLowerCaseI As Boolean
    Get
    Set
Public Property IgnoreInEnglishLowerCaseI As Boolean
    Get
    Set
public:
virtual property bool IgnoreInEnglishLowerCaseI {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool IgnoreInEnglishLowerCaseI {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IgnoreInEnglishLowerCaseI : bool with get, set
override IgnoreInEnglishLowerCaseI : bool with get, set
abstract IgnoreInEnglishLowerCaseI : bool with get, set
override IgnoreInEnglishLowerCaseI : bool with get, set
Property Value
Boolean


IgnoreList Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreList Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► IgnoreList
Keyoti RapidSpell Desktop .NET
The words to ignore, note this list is changed by IgnoreAll.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ArrayList IgnoreList { get; }
public ArrayList IgnoreList { get; }
Public ReadOnly Property IgnoreList As ArrayList
    Get
Public ReadOnly Property IgnoreList As ArrayList
    Get
public:
virtual property ArrayList^ IgnoreList {
    ArrayList^ get () sealed;
}
public:
virtual property ArrayList^ IgnoreList {
    ArrayList^ get () sealed;
}
abstract IgnoreList : ArrayList with get
override IgnoreList : ArrayList with get
abstract IgnoreList : ArrayList with get
override IgnoreList : ArrayList with get
Property Value
ArrayList


IgnorePatternMaximumWordLength Property

Keyoti RapidSpell Desktop .NET API Docs
IgnorePatternMaximumWordLength Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► IgnorePatternMaximumWordLength
Keyoti RapidSpell Desktop .NET
The maximum length of word that will be tested as a regex ignore pattern.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int IgnorePatternMaximumWordLength { get; set; }
public int IgnorePatternMaximumWordLength { get; set; }
Public Property IgnorePatternMaximumWordLength As Integer
    Get
    Set
Public Property IgnorePatternMaximumWordLength As Integer
    Get
    Set
public:
virtual property int IgnorePatternMaximumWordLength {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int IgnorePatternMaximumWordLength {
    int get () sealed;
    void set (int value) sealed;
}
abstract IgnorePatternMaximumWordLength : int with get, set
override IgnorePatternMaximumWordLength : int with get, set
abstract IgnorePatternMaximumWordLength : int with get, set
override IgnorePatternMaximumWordLength : int with get, set
Property Value
Int32


IgnoreRtfCodes Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreRtfCodes Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► IgnoreRtfCodes
Keyoti RapidSpell Desktop .NET
Sets whether this should ignore Rtf (or any escaped) codes in the text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreRtfCodes { get; set; }
public bool IgnoreRtfCodes { get; set; }
Public Property IgnoreRtfCodes As Boolean
    Get
    Set
Public Property IgnoreRtfCodes As Boolean
    Get
    Set
public:
property bool IgnoreRtfCodes {
    bool get ();
    void set (bool value);
}
public:
property bool IgnoreRtfCodes {
    bool get ();
    void set (bool value);
}
member IgnoreRtfCodes : bool with get, set

member IgnoreRtfCodes : bool with get, set
Property Value
Boolean


IgnoreURLsAndEmailAddresses Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreURLsAndEmailAddresses Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► IgnoreURLsAndEmailAddresses
Keyoti RapidSpell Desktop .NET
Whether to ignore URLs and email addresses (requires V2Parser=true)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreURLsAndEmailAddresses { get; set; }
public bool IgnoreURLsAndEmailAddresses { get; set; }
Public Property IgnoreURLsAndEmailAddresses As Boolean
    Get
    Set
Public Property IgnoreURLsAndEmailAddresses As Boolean
    Get
    Set
public:
virtual property bool IgnoreURLsAndEmailAddresses {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool IgnoreURLsAndEmailAddresses {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IgnoreURLsAndEmailAddresses : bool with get, set
override IgnoreURLsAndEmailAddresses : bool with get, set
abstract IgnoreURLsAndEmailAddresses : bool with get, set
override IgnoreURLsAndEmailAddresses : bool with get, set
Property Value
Boolean
Remarks
This will cause the following strings to be accepted as non-spelling errors;
"user@domain.com", "http://www.domain.com", "domain.co.uk" etc.


IgnoreWordsWithDigits Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreWordsWithDigits Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► IgnoreWordsWithDigits
Keyoti RapidSpell Desktop .NET
Whether to ignore words with numbers in them (eg. A10 or 7-11).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreWordsWithDigits { get; set; }
public bool IgnoreWordsWithDigits { get; set; }
Public Property IgnoreWordsWithDigits As Boolean
    Get
    Set
Public Property IgnoreWordsWithDigits As Boolean
    Get
    Set
public:
virtual property bool IgnoreWordsWithDigits {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool IgnoreWordsWithDigits {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IgnoreWordsWithDigits : bool with get, set
override IgnoreWordsWithDigits : bool with get, set
abstract IgnoreWordsWithDigits : bool with get, set
override IgnoreWordsWithDigits : bool with get, set
Property Value
Boolean


IgnoreXML Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreXML Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► IgnoreXML
Keyoti RapidSpell Desktop .NET
Whether to ignore XML/HTML tags, should be set true for RichTextBox support, false by default.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreXML { get; set; }
public bool IgnoreXML { get; set; }
Public Property IgnoreXML As Boolean
    Get
    Set
Public Property IgnoreXML As Boolean
    Get
    Set
public:
virtual property bool IgnoreXML {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool IgnoreXML {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IgnoreXML : bool with get, set
override IgnoreXML : bool with get, set
abstract IgnoreXML : bool with get, set
override IgnoreXML : bool with get, set
Property Value
Boolean


IsAllCaps Method (s)

Keyoti RapidSpell Desktop .NET API Docs
IsAllCaps Method (s)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► IsAllCaps(String)
Keyoti RapidSpell Desktop .NET
Whether all chars in s are in upper case
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static bool IsAllCaps(
    string s
)
public static bool IsAllCaps(
    string s
)
Public Shared Function IsAllCaps (
    s As String
) As Boolean
Public Shared Function IsAllCaps (
    s As String
) As Boolean
public:
static bool IsAllCaps(
    String^ s
)
public:
static bool IsAllCaps(
    String^ s
)
static member IsAllCaps :
        s : string -> bool

static member IsAllCaps :
        s : string -> bool
Parameters
s (String)
Return Value
Boolean


IsStartsWithCap Method (word)

Keyoti RapidSpell Desktop .NET API Docs
IsStartsWithCap Method (word)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► IsStartsWithCap(String)
Keyoti RapidSpell Desktop .NET
Whether first letter is a capital and rest are lower.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static bool IsStartsWithCap(
    string word
)
public static bool IsStartsWithCap(
    string word
)
Public Shared Function IsStartsWithCap (
    word As String
) As Boolean
Public Shared Function IsStartsWithCap (
    word As String
) As Boolean
public:
static bool IsStartsWithCap(
    String^ word
)
public:
static bool IsStartsWithCap(
    String^ word
)
static member IsStartsWithCap :
        word : string -> bool

static member IsStartsWithCap :
        word : string -> bool
Parameters
word (String)
Return Value
Boolean


IsWord Method (wordStart, wordEnd)

Keyoti RapidSpell Desktop .NET API Docs
IsWord Method (wordStart, wordEnd)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► IsWord(Int32, Int32)
Keyoti RapidSpell Desktop .NET
Whether the word defined by the parameters is a word or whitespace.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected internal virtual bool IsWord(
    int wordStart,
    int wordEnd
)
protected internal virtual bool IsWord(
    int wordStart,
    int wordEnd
)
Protected Friend Overridable Function IsWord (
    wordStart As Integer,
    wordEnd As Integer
) As Boolean
Protected Friend Overridable Function IsWord (
    wordStart As Integer,
    wordEnd As Integer
) As Boolean
protected public:
virtual bool IsWord(
    int wordStart,
    int wordEnd
)
protected public:
virtual bool IsWord(
    int wordStart,
    int wordEnd
)
abstract IsWord :
        wordStart : int *
        wordEnd : int -> bool
override IsWord :
        wordStart : int *
        wordEnd : int -> bool
abstract IsWord :
        wordStart : int *
        wordEnd : int -> bool
override IsWord :
        wordStart : int *
        wordEnd : int -> bool
Parameters
wordStart (Int32)
wordEnd (Int32)
Return Value
Boolean
True if is a word, false if whitespace.


LanguageParser Property

Keyoti RapidSpell Desktop .NET API Docs
LanguageParser Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► LanguageParser
Keyoti RapidSpell Desktop .NET
The type of language parsing to use.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public LanguageType LanguageParser { get; set; }
public LanguageType LanguageParser { get; set; }
Public Property LanguageParser As LanguageType
    Get
    Set
Public Property LanguageParser As LanguageType
    Get
    Set
public:
virtual property LanguageType LanguageParser {
    LanguageType get () sealed;
    void set (LanguageType value) sealed;
}
public:
virtual property LanguageType LanguageParser {
    LanguageType get () sealed;
    void set (LanguageType value) sealed;
}
abstract LanguageParser : LanguageType with get, set
override LanguageParser : LanguageType with get, set
abstract LanguageParser : LanguageType with get, set
override LanguageParser : LanguageType with get, set
Property Value
LanguageType
Remarks
Eg. If the dictionary is set to French, you should use the French parser.


LookForAnagrams Property

Keyoti RapidSpell Desktop .NET API Docs
LookForAnagrams Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► LookForAnagrams
Keyoti RapidSpell Desktop .NET
Whether to look for anagrams, if true suggestion performance is slower.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool LookForAnagrams { get; set; }
public bool LookForAnagrams { get; set; }
Public Property LookForAnagrams As Boolean
    Get
    Set
Public Property LookForAnagrams As Boolean
    Get
    Set
public:
property bool LookForAnagrams {
    bool get ();
    void set (bool value);
}
public:
property bool LookForAnagrams {
    bool get ();
    void set (bool value);
}
member LookForAnagrams : bool with get, set

member LookForAnagrams : bool with get, set
Property Value
Boolean


LookIntoHyphenatedText Property

Keyoti RapidSpell Desktop .NET API Docs
LookIntoHyphenatedText Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► LookIntoHyphenatedText
Keyoti RapidSpell Desktop .NET
Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool LookIntoHyphenatedText { get; set; }
public bool LookIntoHyphenatedText { get; set; }
Public Property LookIntoHyphenatedText As Boolean
    Get
    Set
Public Property LookIntoHyphenatedText As Boolean
    Get
    Set
public:
virtual property bool LookIntoHyphenatedText {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool LookIntoHyphenatedText {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract LookIntoHyphenatedText : bool with get, set
override LookIntoHyphenatedText : bool with get, set
abstract LookIntoHyphenatedText : bool with get, set
override LookIntoHyphenatedText : bool with get, set
Property Value
Boolean
Remarks
Eg. "socio-economic" will be checked as "socio" and "economic".


LookUp Method (query)

Keyoti RapidSpell Desktop .NET API Docs
LookUp Method (query)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► LookUp(String)
Keyoti RapidSpell Desktop .NET
Checks if query is in the main dictionary or user.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool LookUp(
    string query
)
public virtual bool LookUp(
    string query
)
Public Overridable Function LookUp (
    query As String
) As Boolean
Public Overridable Function LookUp (
    query As String
) As Boolean
public:
virtual bool LookUp(
    String^ query
)
public:
virtual bool LookUp(
    String^ query
)
abstract LookUp :
        query : string -> bool
override LookUp :
        query : string -> bool
abstract LookUp :
        query : string -> bool
override LookUp :
        query : string -> bool
Parameters
query (String)
the word to check spelling of
Return Value
Boolean
true if spelt correctly, false if not in dictionary
Remarks
This method is inconsiderate of the words in IgnoreList.
Exceptions
Exception | Condition
ArgumentNullException | if query parameter is null.


LookUpMainDictionary Method (query)

Keyoti RapidSpell Desktop .NET API Docs
LookUpMainDictionary Method (query)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► LookUpMainDictionary(String)
Keyoti RapidSpell Desktop .NET
Checks if query is in the word dictionary. Returns true if doesnt start with a letter or apostrophe
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual bool LookUpMainDictionary(
    string query
)
protected virtual bool LookUpMainDictionary(
    string query
)
Protected Overridable Function LookUpMainDictionary (
    query As String
) As Boolean
Protected Overridable Function LookUpMainDictionary (
    query As String
) As Boolean
protected:
virtual bool LookUpMainDictionary(
    String^ query
)
protected:
virtual bool LookUpMainDictionary(
    String^ query
)
abstract LookUpMainDictionary :
        query : string -> bool
override LookUpMainDictionary :
        query : string -> bool
abstract LookUpMainDictionary :
        query : string -> bool
override LookUpMainDictionary :
        query : string -> bool
Parameters
query (String)
the word to check spelling of
Return Value
Boolean
boolean true if spelt correctly, false if not in dictionary


LookUpUserDictionary Method (query)

Keyoti RapidSpell Desktop .NET API Docs
LookUpUserDictionary Method (query)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► LookUpUserDictionary(String)
Keyoti RapidSpell Desktop .NET
Look up the query in the user dictionary if it exists.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual bool LookUpUserDictionary(
    string query
)
protected virtual bool LookUpUserDictionary(
    string query
)
Protected Overridable Function LookUpUserDictionary (
    query As String
) As Boolean
Protected Overridable Function LookUpUserDictionary (
    query As String
) As Boolean
protected:
virtual bool LookUpUserDictionary(
    String^ query
)
protected:
virtual bool LookUpUserDictionary(
    String^ query
)
abstract LookUpUserDictionary :
        query : string -> bool
override LookUpUserDictionary :
        query : string -> bool
abstract LookUpUserDictionary :
        query : string -> bool
override LookUpUserDictionary :
        query : string -> bool
Parameters
query (String)
Return Value
Boolean


MakeCap Method (word)

Keyoti RapidSpell Desktop .NET API Docs
MakeCap Method (word)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► MakeCap(String)
Keyoti RapidSpell Desktop .NET
Capitalises first letter of word
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static string MakeCap(
    string word
)
public static string MakeCap(
    string word
)
Public Shared Function MakeCap (
    word As String
) As String
Public Shared Function MakeCap (
    word As String
) As String
public:
static String^ MakeCap(
    String^ word
)
public:
static String^ MakeCap(
    String^ word
)
static member MakeCap :
        word : string -> string

static member MakeCap :
        word : string -> string
Parameters
word (String)
Return Value
String


NextBadWord Method

Keyoti RapidSpell Desktop .NET API Docs
NextBadWord Method
API ► Keyoti.RapidSpell ► RapidSpellChecker ► NextBadWord()()()()
Keyoti RapidSpell Desktop .NET
Returns the next mis-spelt word in the text, as a BadWord object.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual BadWord NextBadWord()
public virtual BadWord NextBadWord()
Public Overridable Function NextBadWord As BadWord
Public Overridable Function NextBadWord As BadWord
public:
virtual BadWord^ NextBadWord()
public:
virtual BadWord^ NextBadWord()
abstract NextBadWord : unit -> BadWord
override NextBadWord : unit -> BadWord
abstract NextBadWord : unit -> BadWord
override NextBadWord : unit -> BadWord
Return Value
BadWord
Keyoti.RapidSpell.BadWord or null if there are no more bad words.


PHONETIC_SUGGESTIONS Field

Keyoti RapidSpell Desktop .NET API Docs
PHONETIC_SUGGESTIONS Field
API ► Keyoti.RapidSpell ► RapidSpellChecker ► PHONETIC_SUGGESTIONS
Keyoti RapidSpell Desktop .NET
Indicator for suggestion method (Hashing is default).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static int PHONETIC_SUGGESTIONS
public static int PHONETIC_SUGGESTIONS
Public Shared PHONETIC_SUGGESTIONS As Integer
Public Shared PHONETIC_SUGGESTIONS As Integer
public:
static int PHONETIC_SUGGESTIONS
public:
static int PHONETIC_SUGGESTIONS
static val mutable PHONETIC_SUGGESTIONS: int
static val mutable PHONETIC_SUGGESTIONS: int
Field Value
Int32


ReloadUserDictionary Method

Keyoti RapidSpell Desktop .NET API Docs
ReloadUserDictionary Method
API ► Keyoti.RapidSpell ► RapidSpellChecker ► ReloadUserDictionary()()()()
Keyoti RapidSpell Desktop .NET
Reloads the user dictionary.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void ReloadUserDictionary()
public virtual void ReloadUserDictionary()
Public Overridable Sub ReloadUserDictionary
Public Overridable Sub ReloadUserDictionary
public:
virtual void ReloadUserDictionary()
public:
virtual void ReloadUserDictionary()
abstract ReloadUserDictionary : unit -> unit
override ReloadUserDictionary : unit -> unit
abstract ReloadUserDictionary : unit -> unit
override ReloadUserDictionary : unit -> unit
Remarks
Call this when the user dictionary is changed externally


RemoveIgnorePattern Method (p)

Keyoti RapidSpell Desktop .NET API Docs
RemoveIgnorePattern Method (p)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► RemoveIgnorePattern(String)
Keyoti RapidSpell Desktop .NET
Removes a regex pattern to ignore (maximum of 20 can be added - IgnoreURLsAndEmailAddresses=true counts as 1).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void RemoveIgnorePattern(
    string p
)
public virtual void RemoveIgnorePattern(
    string p
)
Public Overridable Sub RemoveIgnorePattern (
    p As String
)
Public Overridable Sub RemoveIgnorePattern (
    p As String
)
public:
virtual void RemoveIgnorePattern(
    String^ p
)
public:
virtual void RemoveIgnorePattern(
    String^ p
)
abstract RemoveIgnorePattern :
        p : string -> unit
override RemoveIgnorePattern :
        p : string -> unit
abstract RemoveIgnorePattern :
        p : string -> unit
override RemoveIgnorePattern :
        p : string -> unit
Parameters
p (String)


RevertToUndoableStatePoint Method (state)

Keyoti RapidSpell Desktop .NET API Docs
RevertToUndoableStatePoint Method (state)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► RevertToUndoableStatePoint(RapidSpellChecker..::..State)
Keyoti RapidSpell Desktop .NET
Reverts the state to what it was when GetUndoableStatePoint()()()() was called.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void RevertToUndoableStatePoint(
    RapidSpellChecker..::..State state
)
public virtual void RevertToUndoableStatePoint(
    RapidSpellChecker..::..State state
)
Public Overridable Sub RevertToUndoableStatePoint (
    state As RapidSpellChecker..::..State
)
Public Overridable Sub RevertToUndoableStatePoint (
    state As RapidSpellChecker..::..State
)
public:
virtual void RevertToUndoableStatePoint(
    RapidSpellChecker..::..State^ state
)
public:
virtual void RevertToUndoableStatePoint(
    RapidSpellChecker..::..State^ state
)
abstract RevertToUndoableStatePoint :
        state : RapidSpellChecker..::..State -> unit
override RevertToUndoableStatePoint :
        state : RapidSpellChecker..::..State -> unit
abstract RevertToUndoableStatePoint :
        state : RapidSpellChecker..::..State -> unit
override RevertToUndoableStatePoint :
        state : RapidSpellChecker..::..State -> unit
Parameters
state (RapidSpellChecker..::..State)


SetConsiderationRange Method (w)

Keyoti RapidSpell Desktop .NET API Docs
SetConsiderationRange Method (w)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► SetConsiderationRange(Int32)
Keyoti RapidSpell Desktop .NET
Sets the factor for words to consider for suggestions, lower values are faster but consider less words for suggestions. Default is 80. If w <= 1 this method won't do anything.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void SetConsiderationRange(
    int w
)
public void SetConsiderationRange(
    int w
)
Public Sub SetConsiderationRange (
    w As Integer
)
Public Sub SetConsiderationRange (
    w As Integer
)
public:
virtual void SetConsiderationRange(
    int w
) sealed
public:
virtual void SetConsiderationRange(
    int w
) sealed
abstract SetConsiderationRange :
        w : int -> unit
override SetConsiderationRange :
        w : int -> unit
abstract SetConsiderationRange :
        w : int -> unit
override SetConsiderationRange :
        w : int -> unit
Parameters
w (Int32)


SetDictFileStream Method (dictFileStream, dictionaryID, modifiedDate)

Keyoti RapidSpell Desktop .NET API Docs
SetDictFileStream Method (dictFileStream, dictionaryID, modifiedDate)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► SetDictFileStream(Stream, String, DateTime)
Keyoti RapidSpell Desktop .NET
Passes a Dict file as a stream, to be used for the main dictionary.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void SetDictFileStream(
    Stream dictFileStream,
    string dictionaryID,
    DateTime modifiedDate
)
public virtual void SetDictFileStream(
    Stream dictFileStream,
    string dictionaryID,
    DateTime modifiedDate
)
Public Overridable Sub SetDictFileStream (
    dictFileStream As Stream,
    dictionaryID As String,
    modifiedDate As DateTime
)
Public Overridable Sub SetDictFileStream (
    dictFileStream As Stream,
    dictionaryID As String,
    modifiedDate As DateTime
)
public:
virtual void SetDictFileStream(
    Stream^ dictFileStream,
    String^ dictionaryID,
    DateTime modifiedDate
)
public:
virtual void SetDictFileStream(
    Stream^ dictFileStream,
    String^ dictionaryID,
    DateTime modifiedDate
)
abstract SetDictFileStream :
        dictFileStream : Stream *
        dictionaryID : string *
        modifiedDate : DateTime -> unit
override SetDictFileStream :
        dictFileStream : Stream *
        dictionaryID : string *
        modifiedDate : DateTime -> unit
abstract SetDictFileStream :
        dictFileStream : Stream *
        dictionaryID : string *
        modifiedDate : DateTime -> unit
override SetDictFileStream :
        dictFileStream : Stream *
        dictionaryID : string *
        modifiedDate : DateTime -> unit
Parameters
dictFileStream (Stream)
The stream containing the dictionary
dictionaryID (String)
Any generated identity string which the spell checker can use to cache and identify this dictionary.
modifiedDate (DateTime)
The DateTime when this dictionary was modified, use Now to update the cache.
Remarks
Note this method must be set before Check is called, and the stream position must be at beginning of Dict file. The stream is NOT closed by this method.


SetIgnoreCapitalizedWords Method (v)

Keyoti RapidSpell Desktop .NET API Docs
SetIgnoreCapitalizedWords Method (v)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► SetIgnoreCapitalizedWords(Boolean)
Keyoti RapidSpell Desktop .NET
Sets whether to ignore words with capital letters.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void SetIgnoreCapitalizedWords(
    bool v
)
public void SetIgnoreCapitalizedWords(
    bool v
)
Public Sub SetIgnoreCapitalizedWords (
    v As Boolean
)
Public Sub SetIgnoreCapitalizedWords (
    v As Boolean
)
public:
virtual void SetIgnoreCapitalizedWords(
    bool v
) sealed
public:
virtual void SetIgnoreCapitalizedWords(
    bool v
) sealed
abstract SetIgnoreCapitalizedWords :
        v : bool -> unit
override SetIgnoreCapitalizedWords :
        v : bool -> unit
abstract SetIgnoreCapitalizedWords :
        v : bool -> unit
override SetIgnoreCapitalizedWords :
        v : bool -> unit
Parameters
v (Boolean)


SetIncludeUserDictionaryInSuggestions Method (v)

Keyoti RapidSpell Desktop .NET API Docs
SetIncludeUserDictionaryInSuggestions Method (v)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► SetIncludeUserDictionaryInSuggestions(Boolean)
Keyoti RapidSpell Desktop .NET
Sets whether the user dictionary should be used in finding suggestions for misspelt words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void SetIncludeUserDictionaryInSuggestions(
    bool v
)
public void SetIncludeUserDictionaryInSuggestions(
    bool v
)
Public Sub SetIncludeUserDictionaryInSuggestions (
    v As Boolean
)
Public Sub SetIncludeUserDictionaryInSuggestions (
    v As Boolean
)
public:
virtual void SetIncludeUserDictionaryInSuggestions(
    bool v
) sealed
public:
virtual void SetIncludeUserDictionaryInSuggestions(
    bool v
) sealed
abstract SetIncludeUserDictionaryInSuggestions :
        v : bool -> unit
override SetIncludeUserDictionaryInSuggestions :
        v : bool -> unit
abstract SetIncludeUserDictionaryInSuggestions :
        v : bool -> unit
override SetIncludeUserDictionaryInSuggestions :
        v : bool -> unit
Parameters
v (Boolean)


SetOptionalContext Method (beforeToCheckSnippet, afterToCheckSnippet)

Keyoti RapidSpell Desktop .NET API Docs
SetOptionalContext Method (beforeToCheckSnippet, afterToCheckSnippet)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► SetOptionalContext(String, String)
Keyoti RapidSpell Desktop .NET
Provides the engine with any helpful text around the text snippet which will be passed to the Check method.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void SetOptionalContext(
    string beforeToCheckSnippet,
    string afterToCheckSnippet
)
public virtual void SetOptionalContext(
    string beforeToCheckSnippet,
    string afterToCheckSnippet
)
Public Overridable Sub SetOptionalContext (
    beforeToCheckSnippet As String,
    afterToCheckSnippet As String
)
Public Overridable Sub SetOptionalContext (
    beforeToCheckSnippet As String,
    afterToCheckSnippet As String
)
public:
virtual void SetOptionalContext(
    String^ beforeToCheckSnippet,
    String^ afterToCheckSnippet
)
public:
virtual void SetOptionalContext(
    String^ beforeToCheckSnippet,
    String^ afterToCheckSnippet
)
abstract SetOptionalContext :
        beforeToCheckSnippet : string *
        afterToCheckSnippet : string -> unit
override SetOptionalContext :
        beforeToCheckSnippet : string *
        afterToCheckSnippet : string -> unit
abstract SetOptionalContext :
        beforeToCheckSnippet : string *
        afterToCheckSnippet : string -> unit
override SetOptionalContext :
        beforeToCheckSnippet : string *
        afterToCheckSnippet : string -> unit
Parameters
beforeToCheckSnippet (String)
Any text before the to check snippet
afterToCheckSnippet (String)
Any text after the snippet
Remarks
Eg. if the document contains "This is an an example piece." and Check will be called on "an example piece", then the fact that 'an' is duplicated will not be detected. Therefore, by passing "This is an " to beforeToCheckSnippet the checker will be able to detect that an is duplicated.


SetPosition Method (pos)

Keyoti RapidSpell Desktop .NET API Docs
SetPosition Method (pos)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► SetPosition(Int32)
Keyoti RapidSpell Desktop .NET
Sets the pointer position for the NextBadWord iterator.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void SetPosition(
    int pos
)
public virtual void SetPosition(
    int pos
)
Public Overridable Sub SetPosition (
    pos As Integer
)
Public Overridable Sub SetPosition (
    pos As Integer
)
public:
virtual void SetPosition(
    int pos
)
public:
virtual void SetPosition(
    int pos
)
abstract SetPosition :
        pos : int -> unit
override SetPosition :
        pos : int -> unit
abstract SetPosition :
        pos : int -> unit
override SetPosition :
        pos : int -> unit
Parameters
pos (Int32)
Remarks
Further calls to NextBadWord will look for the next bad word from position pos. If position > the text length it is set to the text length. If position < 0, it is set to zero.


SetSeparateHyphenWords Method (f)

Keyoti RapidSpell Desktop .NET API Docs
SetSeparateHyphenWords Method (f)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► SetSeparateHyphenWords(Boolean)
Keyoti RapidSpell Desktop .NET
Sets whether to treat hyphenated (-) words as separate words, default is false.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void SetSeparateHyphenWords(
    bool f
)
public void SetSeparateHyphenWords(
    bool f
)
Public Sub SetSeparateHyphenWords (
    f As Boolean
)
Public Sub SetSeparateHyphenWords (
    f As Boolean
)
public:
virtual void SetSeparateHyphenWords(
    bool f
) sealed
public:
virtual void SetSeparateHyphenWords(
    bool f
) sealed
abstract SetSeparateHyphenWords :
        f : bool -> unit
override SetSeparateHyphenWords :
        f : bool -> unit
abstract SetSeparateHyphenWords :
        f : bool -> unit
override SetSeparateHyphenWords :
        f : bool -> unit
Parameters
f (Boolean)
Remarks
For eg. if this is true text like "cheap-deals" will be treated as two words "cheap" and "deals", otherwise this will be treated as one word "cheap-deals". Also see LookIntoHyphenatedText.


SetSuggestionsMethod Method (method)

Keyoti RapidSpell Desktop .NET API Docs
SetSuggestionsMethod Method (method)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► SetSuggestionsMethod(Int32)
Keyoti RapidSpell Desktop .NET
Sets the suggestions method to use. Either PHONETIC_SUGGESTIONS or HASHING_SUGGESTIONS
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
[ObsoleteAttribute("Please use SuggestionsMethod property instead, it can be set with the SuggestionsMethodType enum.",
    false)]
public void SetSuggestionsMethod(
    int method
)
[ObsoleteAttribute("Please use SuggestionsMethod property instead, it can be set with the SuggestionsMethodType enum.",
    false)]
public void SetSuggestionsMethod(
    int method
)
<ObsoleteAttribute("Please use SuggestionsMethod property instead, it can be set with the SuggestionsMethodType enum.",
    false)>
Public Sub SetSuggestionsMethod (
    method As Integer
)
<ObsoleteAttribute("Please use SuggestionsMethod property instead, it can be set with the SuggestionsMethodType enum.",
    false)>
Public Sub SetSuggestionsMethod (
    method As Integer
)
public:
[ObsoleteAttribute(L"Please use SuggestionsMethod property instead, it can be set with the SuggestionsMethodType enum.",
    false)]
virtual void SetSuggestionsMethod(
    int method
) sealed
public:
[ObsoleteAttribute(L"Please use SuggestionsMethod property instead, it can be set with the SuggestionsMethodType enum.",
    false)]
virtual void SetSuggestionsMethod(
    int method
) sealed
[<ObsoleteAttribute("Please use SuggestionsMethod property instead, it can be set with the SuggestionsMethodType enum.",
    false)>]
abstract SetSuggestionsMethod :
        method : int -> unit
[<ObsoleteAttribute("Please use SuggestionsMethod property instead, it can be set with the SuggestionsMethodType enum.",
    false)>]
override SetSuggestionsMethod :
        method : int -> unit
[<ObsoleteAttribute("Please use SuggestionsMethod property instead, it can be set with the SuggestionsMethodType enum.",
    false)>]
abstract SetSuggestionsMethod :
        method : int -> unit
[<ObsoleteAttribute("Please use SuggestionsMethod property instead, it can be set with the SuggestionsMethodType enum.",
    false)>]
override SetSuggestionsMethod :
        method : int -> unit
Parameters
method (Int32)


SetUserDictionary Method

Keyoti RapidSpell Desktop .NET API Docs
SetUserDictionary Method
API ► Keyoti.RapidSpell ► RapidSpellChecker ► SetUserDictionary()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | SetUserDictionary(String) | Set the user dictionary to use.
 | SetUserDictionary(UserDictionary) | Set the user dictionary to use.


SetUserDictionary Method (userDictionary)

Keyoti RapidSpell Desktop .NET API Docs
SetUserDictionary Method (userDictionary)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► SetUserDictionary(UserDictionary)
Keyoti RapidSpell Desktop .NET
Set the user dictionary to use.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void SetUserDictionary(
    UserDictionary userDictionary
)
public void SetUserDictionary(
    UserDictionary userDictionary
)
Public Sub SetUserDictionary (
    userDictionary As UserDictionary
)
Public Sub SetUserDictionary (
    userDictionary As UserDictionary
)
public:
virtual void SetUserDictionary(
    UserDictionary^ userDictionary
) sealed
public:
virtual void SetUserDictionary(
    UserDictionary^ userDictionary
) sealed
abstract SetUserDictionary :
        userDictionary : UserDictionary -> unit
override SetUserDictionary :
        userDictionary : UserDictionary -> unit
abstract SetUserDictionary :
        userDictionary : UserDictionary -> unit
override SetUserDictionary :
        userDictionary : UserDictionary -> unit
Parameters
userDictionary (UserDictionary)
a UserDictionary object representing a user dictionary
Remarks
If the userDictionary can not be created/read it will be ignored
Exceptions
Exception | Condition
ArgumentNullException | if userDictionary is null.


SetUserDictionary Method (userDictionaryFile)

Keyoti RapidSpell Desktop .NET API Docs
SetUserDictionary Method (userDictionaryFile)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► SetUserDictionary(String)
Keyoti RapidSpell Desktop .NET
Set the user dictionary to use.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void SetUserDictionary(
    string userDictionaryFile
)
public void SetUserDictionary(
    string userDictionaryFile
)
Public Sub SetUserDictionary (
    userDictionaryFile As String
)
Public Sub SetUserDictionary (
    userDictionaryFile As String
)
public:
virtual void SetUserDictionary(
    String^ userDictionaryFile
) sealed
public:
virtual void SetUserDictionary(
    String^ userDictionaryFile
) sealed
abstract SetUserDictionary :
        userDictionaryFile : string -> unit
override SetUserDictionary :
        userDictionaryFile : string -> unit
abstract SetUserDictionary :
        userDictionaryFile : string -> unit
override SetUserDictionary :
        userDictionaryFile : string -> unit
Parameters
userDictionaryFile (String)
a file to be used as a user dictionary
Remarks
If the userDictionary can not be created/read it will be ignored
Exceptions
Exception | Condition
ArgumentNullException | if userDictionaryFile is null


ShareDictionary Property

Keyoti RapidSpell Desktop .NET API Docs
ShareDictionary Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► ShareDictionary
Keyoti RapidSpell Desktop .NET
Whether to share the dictionary in memory across all instances of RapidSpellChecker (false by default).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
[ObsoleteAttribute("Unnecessary, all dictionaries are cached now in a superior manner.",
    false)]
public bool ShareDictionary { get; set; }
[ObsoleteAttribute("Unnecessary, all dictionaries are cached now in a superior manner.",
    false)]
public bool ShareDictionary { get; set; }
<ObsoleteAttribute("Unnecessary, all dictionaries are cached now in a superior manner.",
    false)>
Public Property ShareDictionary As Boolean
    Get
    Set
<ObsoleteAttribute("Unnecessary, all dictionaries are cached now in a superior manner.",
    false)>
Public Property ShareDictionary As Boolean
    Get
    Set
public:
[ObsoleteAttribute(L"Unnecessary, all dictionaries are cached now in a superior manner.",
    false)]
property bool ShareDictionary {
    bool get ();
    void set (bool value);
}
public:
[ObsoleteAttribute(L"Unnecessary, all dictionaries are cached now in a superior manner.",
    false)]
property bool ShareDictionary {
    bool get ();
    void set (bool value);
}
[<ObsoleteAttribute("Unnecessary, all dictionaries are cached now in a superior manner.",
    false)>]
member ShareDictionary : bool with get, set

[<ObsoleteAttribute("Unnecessary, all dictionaries are cached now in a superior manner.",
    false)>]
member ShareDictionary : bool with get, set
Property Value
Boolean
Remarks
Setting this to true will lower memory usage if multiple instances of RapidSpellChecker are in use at once, but will mean that only one dictionary may be used at one time. This does not affect user dictionaries.

Note that all instances with this set to true should use the same dictionary. This property must be set before any spell checking begins.


SuggestionsMethod Property

Keyoti RapidSpell Desktop .NET API Docs
SuggestionsMethod Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► SuggestionsMethod
Keyoti RapidSpell Desktop .NET
The method used for suggestions, default is Hashing
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public SuggestionsMethodType SuggestionsMethod { get; set; }
public SuggestionsMethodType SuggestionsMethod { get; set; }
Public Property SuggestionsMethod As SuggestionsMethodType
    Get
    Set
Public Property SuggestionsMethod As SuggestionsMethodType
    Get
    Set
public:
property SuggestionsMethodType SuggestionsMethod {
    SuggestionsMethodType get ();
    void set (SuggestionsMethodType value);
}
public:
property SuggestionsMethodType SuggestionsMethod {
    SuggestionsMethodType get ();
    void set (SuggestionsMethodType value);
}
member SuggestionsMethod : SuggestionsMethodType with get, set

member SuggestionsMethod : SuggestionsMethodType with get, set
Property Value
SuggestionsMethodType


SuggestSplitWords Property

Keyoti RapidSpell Desktop .NET API Docs
SuggestSplitWords Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► SuggestSplitWords
Keyoti RapidSpell Desktop .NET
Whether to look for connected words in suggestions.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool SuggestSplitWords { get; set; }
public bool SuggestSplitWords { get; set; }
Public Property SuggestSplitWords As Boolean
    Get
    Set
Public Property SuggestSplitWords As Boolean
    Get
    Set
public:
virtual property bool SuggestSplitWords {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool SuggestSplitWords {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract SuggestSplitWords : bool with get, set
override SuggestSplitWords : bool with get, set
abstract SuggestSplitWords : bool with get, set
override SuggestSplitWords : bool with get, set
Property Value
Boolean
Remarks
if this=true then suggestions may include joined words.

Eg; suggestions for "yourhouse" will include "yourhouse"

Setting this to true (default) has a slight performance impact.


TextBoundary Property

Keyoti RapidSpell Desktop .NET API Docs
TextBoundary Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► TextBoundary
Keyoti RapidSpell Desktop .NET
The AdvancedTextBoundary class to use to parse words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public AdvancedTextBoundary TextBoundary { get; set; }
public AdvancedTextBoundary TextBoundary { get; set; }
Public Property TextBoundary As AdvancedTextBoundary
    Get
    Set
Public Property TextBoundary As AdvancedTextBoundary
    Get
    Set
public:
virtual property AdvancedTextBoundary^ TextBoundary {
    AdvancedTextBoundary^ get () sealed;
    void set (AdvancedTextBoundary^ value) sealed;
}
public:
virtual property AdvancedTextBoundary^ TextBoundary {
    AdvancedTextBoundary^ get () sealed;
    void set (AdvancedTextBoundary^ value) sealed;
}
abstract TextBoundary : AdvancedTextBoundary with get, set
override TextBoundary : AdvancedTextBoundary with get, set
abstract TextBoundary : AdvancedTextBoundary with get, set
override TextBoundary : AdvancedTextBoundary with get, set
Property Value
AdvancedTextBoundary


theCurrentBadWord Field

Keyoti RapidSpell Desktop .NET API Docs
theCurrentBadWord Field
API ► Keyoti.RapidSpell ► RapidSpellChecker ► theCurrentBadWord
Keyoti RapidSpell Desktop .NET
The current badword
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected BadWord theCurrentBadWord
protected BadWord theCurrentBadWord
Protected theCurrentBadWord As BadWord
Protected theCurrentBadWord As BadWord
protected:
BadWord^ theCurrentBadWord
protected:
BadWord^ theCurrentBadWord
val mutable theCurrentBadWord: BadWord
val mutable theCurrentBadWord: BadWord
Field Value
BadWord


theText Field

Keyoti RapidSpell Desktop .NET API Docs
theText Field
API ► Keyoti.RapidSpell ► RapidSpellChecker ► theText
Keyoti RapidSpell Desktop .NET
The text being checked.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected StringBuilder theText
protected StringBuilder theText
Protected theText As StringBuilder
Protected theText As StringBuilder
protected:
StringBuilder^ theText
protected:
StringBuilder^ theText
val mutable theText: StringBuilder
val mutable theText: StringBuilder
Field Value
StringBuilder


UnloadMainDictionary Method

Keyoti RapidSpell Desktop .NET API Docs
UnloadMainDictionary Method
API ► Keyoti.RapidSpell ► RapidSpellChecker ► UnloadMainDictionary()()()()
Keyoti RapidSpell Desktop .NET
Empties the main dictionary store.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
[ObsoleteAttribute("No longer useful because of new dictionary caching.  See release notes.",
    true)]
public void UnloadMainDictionary()
[ObsoleteAttribute("No longer useful because of new dictionary caching.  See release notes.",
    true)]
public void UnloadMainDictionary()
<ObsoleteAttribute("No longer useful because of new dictionary caching.  See release notes.",
    true)>
Public Sub UnloadMainDictionary
<ObsoleteAttribute("No longer useful because of new dictionary caching.  See release notes.",
    true)>
Public Sub UnloadMainDictionary
public:
[ObsoleteAttribute(L"No longer useful because of new dictionary caching.  See release notes.",
    true)]
void UnloadMainDictionary()
public:
[ObsoleteAttribute(L"No longer useful because of new dictionary caching.  See release notes.",
    true)]
void UnloadMainDictionary()
[<ObsoleteAttribute("No longer useful because of new dictionary caching.  See release notes.",
    true)>]
member UnloadMainDictionary : unit -> unit

[<ObsoleteAttribute("No longer useful because of new dictionary caching.  See release notes.",
    true)>]
member UnloadMainDictionary : unit -> unit


userDictionary Property

Keyoti RapidSpell Desktop .NET API Docs
userDictionary Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► userDictionary
Keyoti RapidSpell Desktop .NET
The UserDictionary being used, may be null if no user dictionary is being used.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UserDictionary userDictionary { get; set; }
public UserDictionary userDictionary { get; set; }
Public Property userDictionary As UserDictionary
    Get
    Set
Public Property userDictionary As UserDictionary
    Get
    Set
public:
virtual property UserDictionary^ userDictionary {
    UserDictionary^ get () sealed;
    void set (UserDictionary^ value) sealed;
}
public:
virtual property UserDictionary^ userDictionary {
    UserDictionary^ get () sealed;
    void set (UserDictionary^ value) sealed;
}
abstract userDictionary : UserDictionary with get, set
override userDictionary : UserDictionary with get, set
abstract userDictionary : UserDictionary with get, set
override userDictionary : UserDictionary with get, set
Property Value
UserDictionary


V2Parser Property

Keyoti RapidSpell Desktop .NET API Docs
V2Parser Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► V2Parser
Keyoti RapidSpell Desktop .NET
Whether to use parser version 2 - Set to false for backwards compatibility.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool V2Parser { get; set; }
public bool V2Parser { get; set; }
Public Property V2Parser As Boolean
    Get
    Set
Public Property V2Parser As Boolean
    Get
    Set
public:
virtual property bool V2Parser {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool V2Parser {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract V2Parser : bool with get, set
override V2Parser : bool with get, set
abstract V2Parser : bool with get, set
override V2Parser : bool with get, set
Property Value
Boolean


WarnDuplicates Property

Keyoti RapidSpell Desktop .NET API Docs
WarnDuplicates Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► WarnDuplicates
Keyoti RapidSpell Desktop .NET
Whether to treat duplicate words as errors (eg. "this is is an error").
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool WarnDuplicates { get; set; }
public bool WarnDuplicates { get; set; }
Public Property WarnDuplicates As Boolean
    Get
    Set
Public Property WarnDuplicates As Boolean
    Get
    Set
public:
virtual property bool WarnDuplicates {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool WarnDuplicates {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract WarnDuplicates : bool with get, set
override WarnDuplicates : bool with get, set
abstract WarnDuplicates : bool with get, set
override WarnDuplicates : bool with get, set
Property Value
Boolean


WordAdded Event

Keyoti RapidSpell Desktop .NET API Docs
WordAdded Event
API ► Keyoti.RapidSpell ► RapidSpellChecker ► WordAdded
Keyoti RapidSpell Desktop .NET
Fired when word added to user dictionary
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event WordAddedEventHandler WordAdded
public event WordAddedEventHandler WordAdded
Public Event WordAdded As WordAddedEventHandler
Public Event WordAdded As WordAddedEventHandler
public:
virtual  event WordAddedEventHandler^ WordAdded {
    void add (WordAddedEventHandler^ value);
    void remove (WordAddedEventHandler^ value);
}
public:
virtual  event WordAddedEventHandler^ WordAdded {
    void add (WordAddedEventHandler^ value);
    void remove (WordAddedEventHandler^ value);
}
abstract WordAdded : IEvent<WordAddedEventHandler,
    WordAddedEventArgs>
override WordAdded : IEvent<WordAddedEventHandler,
    WordAddedEventArgs>
abstract WordAdded : IEvent<WordAddedEventHandler,
    WordAddedEventArgs>
override WordAdded : IEvent<WordAddedEventHandler,
    WordAddedEventArgs>
Value
WordAddedEventHandler


WordChanged Event

Keyoti RapidSpell Desktop .NET API Docs
WordChanged Event
API ► Keyoti.RapidSpell ► RapidSpellChecker ► WordChanged
Keyoti RapidSpell Desktop .NET
Change word event, fired when a word is changed.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event WordChangedEventHandler WordChanged
public event WordChangedEventHandler WordChanged
Public Event WordChanged As WordChangedEventHandler
Public Event WordChanged As WordChangedEventHandler
public:
 event WordChangedEventHandler^ WordChanged {
    void add (WordChangedEventHandler^ value);
    void remove (WordChangedEventHandler^ value);
}
public:
 event WordChangedEventHandler^ WordChanged {
    void add (WordChangedEventHandler^ value);
    void remove (WordChangedEventHandler^ value);
}
member WordChanged : IEvent<WordChangedEventHandler,
    WordChangedEventArgs>

member WordChanged : IEvent<WordChangedEventHandler,
    WordChangedEventArgs>
Value
WordChangedEventHandler


wordEnd Field

Keyoti RapidSpell Desktop .NET API Docs
wordEnd Field
API ► Keyoti.RapidSpell ► RapidSpellChecker ► wordEnd
Keyoti RapidSpell Desktop .NET
The end index of the current word being checked/parsed.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected int wordEnd
protected int wordEnd
Protected wordEnd As Integer
Protected wordEnd As Integer
protected:
int wordEnd
protected:
int wordEnd
val mutable wordEnd: int
val mutable wordEnd: int
Field Value
Int32


WordIgnored Event

Keyoti RapidSpell Desktop .NET API Docs
WordIgnored Event
API ► Keyoti.RapidSpell ► RapidSpellChecker ► WordIgnored
Keyoti RapidSpell Desktop .NET
Fired when word ignored
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event WordIgnoredEventHandler WordIgnored
public event WordIgnoredEventHandler WordIgnored
Public Event WordIgnored As WordIgnoredEventHandler
Public Event WordIgnored As WordIgnoredEventHandler
public:
 event WordIgnoredEventHandler^ WordIgnored {
    void add (WordIgnoredEventHandler^ value);
    void remove (WordIgnoredEventHandler^ value);
}
public:
 event WordIgnoredEventHandler^ WordIgnored {
    void add (WordIgnoredEventHandler^ value);
    void remove (WordIgnoredEventHandler^ value);
}
member WordIgnored : IEvent<WordIgnoredEventHandler,
    WordIgnoredEventArgs>

member WordIgnored : IEvent<WordIgnoredEventHandler,
    WordIgnoredEventArgs>
Value
WordIgnoredEventHandler


wordStart Field

Keyoti RapidSpell Desktop .NET API Docs
wordStart Field
API ► Keyoti.RapidSpell ► RapidSpellChecker ► wordStart
Keyoti RapidSpell Desktop .NET
The start index of the current word being checked/parsed.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected int wordStart
protected int wordStart
Protected wordStart As Integer
Protected wordStart As Integer
protected:
int wordStart
protected:
int wordStart
val mutable wordStart: int
val mutable wordStart: int
Field Value
Int32


RapidSpellChecker.State Class

Keyoti RapidSpell Desktop .NET API Docs
RapidSpellChecker..::..State Class
API ► Keyoti.RapidSpell ► RapidSpellChecker ► RapidSpellChecker..::..State
Keyoti RapidSpell Desktop .NET
State of the spell checker
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class State
public class State
Public Class State
Public Class State
public ref class State
public ref class State
type State =  class end
type State =  class end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RapidSpellChecker..::..State(Int32, String, BadWord) | ublic void SetUserDiction New
 | CurrentBadWord | Current misspelling
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Position | Spell checkers position in text
 | PreviousWord | Word before current word
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
RapidSpellChecker..::..State


RapidSpellChecker.State Constructor (position, previousWord, currentBadWord)

Keyoti RapidSpell Desktop .NET API Docs
RapidSpellChecker..::..State Constructor (position, previousWord, currentBadWord)
API ► Keyoti.RapidSpell ► RapidSpellChecker..::..State ► RapidSpellChecker..::..State(Int32, String, BadWord)
Keyoti RapidSpell Desktop .NET
ublic void SetUserDiction New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public State(
    int position,
    string previousWord,
    BadWord currentBadWord
)
public State(
    int position,
    string previousWord,
    BadWord currentBadWord
)
Public Sub New (
    position As Integer,
    previousWord As String,
    currentBadWord As BadWord
)
Public Sub New (
    position As Integer,
    previousWord As String,
    currentBadWord As BadWord
)
public:
State(
    int position,
    String^ previousWord,
    BadWord^ currentBadWord
)
public:
State(
    int position,
    String^ previousWord,
    BadWord^ currentBadWord
)
new :
        position : int *
        previousWord : string *
        currentBadWord : BadWord -> State
new :
        position : int *
        previousWord : string *
        currentBadWord : BadWord -> State
Parameters
position (Int32)
previousWord (String)
currentBadWord (BadWord)


CurrentBadWord Property

Keyoti RapidSpell Desktop .NET API Docs
CurrentBadWord Property
API ► Keyoti.RapidSpell ► RapidSpellChecker..::..State ► CurrentBadWord
Keyoti RapidSpell Desktop .NET
Current misspelling
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public BadWord CurrentBadWord { get; set; }
public BadWord CurrentBadWord { get; set; }
Public Property CurrentBadWord As BadWord
    Get
    Set
Public Property CurrentBadWord As BadWord
    Get
    Set
public:
property BadWord^ CurrentBadWord {
    BadWord^ get ();
    void set (BadWord^ value);
}
public:
property BadWord^ CurrentBadWord {
    BadWord^ get ();
    void set (BadWord^ value);
}
member CurrentBadWord : BadWord with get, set

member CurrentBadWord : BadWord with get, set
Property Value
BadWord


Position Property

Keyoti RapidSpell Desktop .NET API Docs
Position Property
API ► Keyoti.RapidSpell ► RapidSpellChecker..::..State ► Position
Keyoti RapidSpell Desktop .NET
Spell checkers position in text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int Position { get; set; }
public int Position { get; set; }
Public Property Position As Integer
    Get
    Set
Public Property Position As Integer
    Get
    Set
public:
property int Position {
    int get ();
    void set (int value);
}
public:
property int Position {
    int get ();
    void set (int value);
}
member Position : int with get, set

member Position : int with get, set
Property Value
Int32


PreviousWord Property

Keyoti RapidSpell Desktop .NET API Docs
PreviousWord Property
API ► Keyoti.RapidSpell ► RapidSpellChecker..::..State ► PreviousWord
Keyoti RapidSpell Desktop .NET
Word before current word
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string PreviousWord { get; set; }
public string PreviousWord { get; set; }
Public Property PreviousWord As String
    Get
    Set
Public Property PreviousWord As String
    Get
    Set
public:
property String^ PreviousWord {
    String^ get ();
    void set (String^ value);
}
public:
property String^ PreviousWord {
    String^ get ();
    void set (String^ value);
}
member PreviousWord : string with get, set

member PreviousWord : string with get, set
Property Value
String


RapidSpellDialog Class

Keyoti RapidSpell Desktop .NET API Docs
RapidSpellDialog Class
API ► Keyoti.RapidSpell ► RapidSpellDialog
Keyoti RapidSpell Desktop .NET
RapidSpell Desktop Dialog Control, this convenience control provides design time support for RapidSpellGUI and multiple text box support.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class RapidSpellDialog : Component
public class RapidSpellDialog : Component
Public Class RapidSpellDialog
    Inherits Component
Public Class RapidSpellDialog
    Inherits Component
public ref class RapidSpellDialog : public Component
public ref class RapidSpellDialog : public Component
type RapidSpellDialog =
    class
        inherit Component
    end
type RapidSpellDialog =
    class
        inherit Component
    end
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RapidSpellDialog()()()() | Default constructor.
 | RapidSpellDialog(IContainer) | Designer constructor.
 | AddTextComponent(TextBoxBase) | Adds a TextBoxBase (TextBox, RichTextBox and derivatives) to be checked.
 | AddTextComponent(ISpellCheckableTextComponent) | Adds an ISpellCheckableTextComponent to be checked.
 | AllOperationScope | The scope that ignore-all/change-all should have.
 | AllowAnyCase | Whether to allow words spelt with incorrect case, eg. "africa", instead of "Africa", this is more relaxed than AllowMixedCase
 | AllowMixedCase | Whether to allow words spelt with mixed case, eg. "MIxEd"
 | AlwaysShowDialog | Whether to show dialog even when there are no errors in the text box. If set to false causes a spell check before opening the dialog, if there are no errors a message box appears instead of the dialog.
 | BackColor | Gets or sets the background color for the control.
 | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
 | Check()()()() | Bring up the spell checker dialog and start checking the component set to check.
 | CheckCompoundWords | Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
 | CheckDisabledTextBoxes | Whether to spell check textboxes which are disabled.
 | CheckerEngine | The checker engine to use, this object must implement the ICheckerEngine interface, allows customization or replacement of the spell checker.
 | CheckFromStartOfTextOnMultiples | Whether to check each textbox from the start of the text when working with multiple textboxes.
 | CheckReadOnlyTextBoxes | Whether to spell check textboxes which are readonly.
 | ClearTextComponents()()()() | Obsolete. Removes all text components from being spell checked.
 | Close()()()() | Close the spell checker dialog window, if open.
 | ConsiderationRange | Sets the factor for words to consider for suggestions, lower values are faster but consider less words for suggestions. Default is 500. If w <= 1 this method won't do anything.
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | ControlBox | Whether a control box is displayed in the caption bar of the form.
 | CreateDialogView | Fired when an IDialogView is being created. Allows for customization
 | CreateDialogViewOptions | Fired when an IDialogViewOptions is being created. Allows for customization
 | CreateDialogViewUserDictionaryEdit | Indicates that a new IDialogViewUserDictionaryEdit is being created, also provides chance to override the default IDialogViewUserDictionaryEdit.
 | CreateDialogViewUserDictionarySelect | Indicates that a new IDialogViewUserDictionarySelect is being created, also provides chance to override the default IDialogViewUserDictionarySelect.
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateUserInterfaceFormPresenter | Fired when an IUserInterfaceFormPresenter is being created. Allows for customization
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | DictFilePath | The file to be used as the main dictionary (either a full file path, or the name of an embedded resource), if this is null then the built-in US English dictionary is used.
 | Dispose(Boolean) | Disposes of unmanaged resources. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | Finalize()()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | FindCapitalizedSuggestions | Whether to look for capitalized suggestions, note this will slow FindSuggestions down by about 7 times.
 | ForeColor | Gets or sets the foreground color for the control.
 | FormBorderStyle | Specifies the border styles for the dialog form.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GUILanguage | The language to show the UI in.
 | Icon | Gets or sets the icon for the form..
 | IgnoreCapitalizedWords | Whether to ignore words with capital letters.
 | IgnoreIncorrectSentenceCapitalization | Whether to ignore incorrect sentence capitalization.
 | IgnoreInEnglishLowerCaseI | Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
 | IgnoreURLsAndEmailAddresses | Whether to ignore URLs and email addresses (requires V2Parser=true)
 | IgnoreWordsWithDigits | Whether to ignore words with numbers in them (eg. A10 or 7-11).
 | IgnoreXML | Whether to ignore XML/HTML tags, false by default.
 | IncludeUserDictionaryInSuggestions | Whether the user dictionary should be used in finding suggestions for misspelt words.
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | LanguageParser | The type of language parsing to use.
 | Location | Where to position dialog the first time it is opened.
 | LookIntoHyphenatedText | Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
 | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form.
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinimizeBox | Whether the minimize button is displayed in the caption bar of the form.
 | Modal | Whether the spell checker will run modally. (Modal operation blocks the parent form)
 | ModalAutoDispose | When running modally, determines if the dialog will be disposed of when spell check finishes.
 | ModalOwner | The owner of the checker form, when it's viewed modally.
 | NumberSuggestionList | Whether to number the items in the suggestion list, for quick user selection.
 | OnCreateDialogView(CreateDialogViewEventArgs) | Raises event
 | OnCreateDialogViewOptions(CreateDialogViewOptionsEventArgs) | Raises event
 | OnCreateDialogViewUserDictionaryEdit(CreateDialogViewUserDictionaryEditEventArgs) | Fires the CreateDialogViewUserDictionaryEdit event.
 | OnCreateDialogViewUserDictionarySelect(CreateDialogViewUserDictionarySelectEventArgs) | Raises event
 | OnCreateUserInterfaceFormPresenter(CreateUserInterfaceFormPresenterEventArgs) | Raises event
 | OnSpellCheckFinishedTextBox(TextBoxSpellCheckEventArgs) | Raises event
 | OnSpellCheckStartedTextBox(TextBoxSpellCheckEventArgs) | Raises event
 | OnWordAdded(Object, WordAddedEventArgs) | Fires WordAdded event
 | OnWordChanged(Object, WordChangedEventArgs) | Fires WordChanged event
 | OnWordChanging(Object, WordChangedEventArgs) | Fires WordChanging event
 | OnWordIgnored(Object, WordIgnoredEventArgs) | Fires WordIgnored event
 | Options | Object responsible for holding, loading and saving the user's spell check options.
 | OptionsEnabled | Whether to use user options.
 | OptionsFileName | The file name used to store the settings (by default in IsolatedStorage).
 | OptionsPresenter | Presenter for the user options form (IDialogViewOptions).
 | OptionsStorageLocation | Where the user's options are stored.
 | Parent | Gets or sets the parent of the dialog form.
 | QueryTextBoxMultiline | Whether 'not in dictionary' text box is multiline or single line.
 | Ready | Fired when ready to proceed with first query.
 | RecheckDocumentRequest | Fired when the text should be rechecked
 | RemoveAllTextComponents()()()() | Removes all text components from being spell checked.
 | RemoveTextComponent(TextBoxBase) | Removes a TextBoxBase (TextBox, RichTextBox and derivatives) to be checked.
 | RemoveTextComponent(ISpellCheckableTextComponent) | Removes an ISpellCheckableTextComponent to be checked.
 | ResetIgnoredWords()()()() | Resets all ignored words, so that the document will be rechecked.
 | SeparateHyphenWords | Whether to treat hyphenated (-) words as separate words, default is false.
 | ShowContextSentence | Whether to show the query in context of it's sentence/line.
 | ShowFinishedBoxAtEnd | Whether to show the spell check complete dialog box at the end, true by default.
 | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
 | ShowOptionForCheckAsYouType | Whether to show the 'check as you type' option check box in the options form.
 | ShowOptionForMultipleUserDictionaries | Whether to allow the user to add/remove additional user dictionaries in the options form, the user is not permitted to remove the user dictionary assigned via code.
 | ShowOptionsButton | Whether to show the options button.
 | ShowUndoButton | Whether to show the undo button.
 | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
 | SizeGripStyle | Style of the size grip to display in the lower-right corner of the form
 | SpellCheckFinished | Fired when checking finishes
 | SpellCheckFinishedTextBox | Fired when spell check starts on a text box (used in multiple text box checking situations)
 | SpellCheckStarted | Fired when checking starts
 | SpellCheckStartedTextBox | Fired when spell check starts on a text box (used in multiple text box checking situations)
 | StartPosition | Gets or sets the starting position of the form at run time
 | SuggestionsMethod | The suggestions method to use.
 | SuggestSplitWords | Whether to look for connected words in suggestions.
 | TextBoxBasesToCheck | Array of TextBoxBases this GUI will spell check.
 | TextBoxBaseToCheck | The TextBoxBase (eg; TextBox etc) that this GUI will spell check.
 | Texts | The UI texts.
 | ThirdPartyTextComponentsToCheck | Array of ISpellCheckableTextComponent this GUI will spell check.
 | ThirdPartyTextComponentToCheck | The 3rd Party Component that this GUI will spell check.
 | TopLevel | Whether to display the form as a top-level window.
 | TopMost | Whether the form is 'always on top'.
 | ToString()()()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
 | Undone | Fired when an Undo occurs
 | UserDictionaryFile | The user dictionary file, if this file doesn't exist it will be created.
 | UserInterfaceFormPresenter | The presenter (eg. RapidSpellGUIPresenter) currently in use, may be null/Nothing if not created yet.
 | UserQuery | Indicates that the user is being queried on a spelling error.
 | V2Parser | Whether to use parser version 2 - Set to false for backwards (pre v3.4) compatibility.
 | WarnDuplicates | Whether to show duplicate words as errors (eg. "this is is an error").
 | WordAdded | Fired when word added to user dictionary
 | WordChanged | Fired when a word is changed
 | WordChanging | Fired before a word is changed
 | WordIgnored | Fired when word ignored
 | WordRemoved | Fired when a word is removed from user dictionary.
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | RapidSpellDialog


RapidSpellDialog Constructor

Keyoti RapidSpell Desktop .NET API Docs
RapidSpellDialog Constructor
API ► Keyoti.RapidSpell ► RapidSpellDialog ► RapidSpellDialog()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | RapidSpellDialog()()()() | Default constructor.
 | RapidSpellDialog(IContainer) | Designer constructor.


RapidSpellDialog Constructor

Keyoti RapidSpell Desktop .NET API Docs
RapidSpellDialog Constructor
API ► Keyoti.RapidSpell ► RapidSpellDialog ► RapidSpellDialog()()()()
Keyoti RapidSpell Desktop .NET
Default constructor.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public RapidSpellDialog()
public RapidSpellDialog()
Public Sub New
Public Sub New
public:
RapidSpellDialog()
public:
RapidSpellDialog()
new : unit -> RapidSpellDialog
new : unit -> RapidSpellDialog


RapidSpellDialog Constructor (container)

Keyoti RapidSpell Desktop .NET API Docs
RapidSpellDialog Constructor (container)
API ► Keyoti.RapidSpell ► RapidSpellDialog ► RapidSpellDialog(IContainer)
Keyoti RapidSpell Desktop .NET
Designer constructor.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public RapidSpellDialog(
    IContainer container
)
public RapidSpellDialog(
    IContainer container
)
Public Sub New (
    container As IContainer
)
Public Sub New (
    container As IContainer
)
public:
RapidSpellDialog(
    IContainer^ container
)
public:
RapidSpellDialog(
    IContainer^ container
)
new :
        container : IContainer -> RapidSpellDialog
new :
        container : IContainer -> RapidSpellDialog
Parameters
container (IContainer)


AddTextComponent Method

Keyoti RapidSpell Desktop .NET API Docs
AddTextComponent Method
API ► Keyoti.RapidSpell ► RapidSpellDialog ► AddTextComponent()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | AddTextComponent(TextBoxBase) | Adds a TextBoxBase (TextBox, RichTextBox and derivatives) to be checked.
 | AddTextComponent(ISpellCheckableTextComponent) | Adds an ISpellCheckableTextComponent to be checked.


AddTextComponent Method (textComponent)

Keyoti RapidSpell Desktop .NET API Docs
AddTextComponent Method (textComponent)
API ► Keyoti.RapidSpell ► RapidSpellDialog ► AddTextComponent(ISpellCheckableTextComponent)
Keyoti RapidSpell Desktop .NET
Adds an ISpellCheckableTextComponent to be checked.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void AddTextComponent(
    ISpellCheckableTextComponent textComponent
)
public virtual void AddTextComponent(
    ISpellCheckableTextComponent textComponent
)
Public Overridable Sub AddTextComponent (
    textComponent As ISpellCheckableTextComponent
)
Public Overridable Sub AddTextComponent (
    textComponent As ISpellCheckableTextComponent
)
public:
virtual void AddTextComponent(
    ISpellCheckableTextComponent^ textComponent
)
public:
virtual void AddTextComponent(
    ISpellCheckableTextComponent^ textComponent
)
abstract AddTextComponent :
        textComponent : ISpellCheckableTextComponent -> unit
override AddTextComponent :
        textComponent : ISpellCheckableTextComponent -> unit
abstract AddTextComponent :
        textComponent : ISpellCheckableTextComponent -> unit
override AddTextComponent :
        textComponent : ISpellCheckableTextComponent -> unit
Parameters
textComponent (ISpellCheckableTextComponent)


AddTextComponent Method (textBoxBase)

Keyoti RapidSpell Desktop .NET API Docs
AddTextComponent Method (textBoxBase)
API ► Keyoti.RapidSpell ► RapidSpellDialog ► AddTextComponent(TextBoxBase)
Keyoti RapidSpell Desktop .NET
Adds a TextBoxBase (TextBox, RichTextBox and derivatives) to be checked.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void AddTextComponent(
    TextBoxBase textBoxBase
)
public virtual void AddTextComponent(
    TextBoxBase textBoxBase
)
Public Overridable Sub AddTextComponent (
    textBoxBase As TextBoxBase
)
Public Overridable Sub AddTextComponent (
    textBoxBase As TextBoxBase
)
public:
virtual void AddTextComponent(
    TextBoxBase^ textBoxBase
)
public:
virtual void AddTextComponent(
    TextBoxBase^ textBoxBase
)
abstract AddTextComponent :
        textBoxBase : TextBoxBase -> unit
override AddTextComponent :
        textBoxBase : TextBoxBase -> unit
abstract AddTextComponent :
        textBoxBase : TextBoxBase -> unit
override AddTextComponent :
        textBoxBase : TextBoxBase -> unit
Parameters
textBoxBase (TextBoxBase)


AllOperationScope Property

Keyoti RapidSpell Desktop .NET API Docs
AllOperationScope Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► AllOperationScope
Keyoti RapidSpell Desktop .NET
The scope that ignore-all/change-all should have.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public OperationScope AllOperationScope { get; set; }
public OperationScope AllOperationScope { get; set; }
Public Property AllOperationScope As OperationScope
    Get
    Set
Public Property AllOperationScope As OperationScope
    Get
    Set
public:
property OperationScope AllOperationScope {
    OperationScope get ();
    void set (OperationScope value);
}
public:
property OperationScope AllOperationScope {
    OperationScope get ();
    void set (OperationScope value);
}
member AllOperationScope : OperationScope with get, set

member AllOperationScope : OperationScope with get, set
Property Value
OperationScope


AllowAnyCase Property

Keyoti RapidSpell Desktop .NET API Docs
AllowAnyCase Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► AllowAnyCase
Keyoti RapidSpell Desktop .NET
Whether to allow words spelt with incorrect case, eg. "africa", instead of "Africa", this is more relaxed than AllowMixedCase
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool AllowAnyCase { get; set; }
public bool AllowAnyCase { get; set; }
Public Property AllowAnyCase As Boolean
    Get
    Set
Public Property AllowAnyCase As Boolean
    Get
    Set
public:
property bool AllowAnyCase {
    bool get ();
    void set (bool value);
}
public:
property bool AllowAnyCase {
    bool get ();
    void set (bool value);
}
member AllowAnyCase : bool with get, set

member AllowAnyCase : bool with get, set
Property Value
Boolean


AllowMixedCase Property

Keyoti RapidSpell Desktop .NET API Docs
AllowMixedCase Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► AllowMixedCase
Keyoti RapidSpell Desktop .NET
Whether to allow words spelt with mixed case, eg. "MIxEd"
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool AllowMixedCase { get; set; }
public bool AllowMixedCase { get; set; }
Public Property AllowMixedCase As Boolean
    Get
    Set
Public Property AllowMixedCase As Boolean
    Get
    Set
public:
property bool AllowMixedCase {
    bool get ();
    void set (bool value);
}
public:
property bool AllowMixedCase {
    bool get ();
    void set (bool value);
}
member AllowMixedCase : bool with get, set

member AllowMixedCase : bool with get, set
Property Value
Boolean


AlwaysShowDialog Property

Keyoti RapidSpell Desktop .NET API Docs
AlwaysShowDialog Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► AlwaysShowDialog
Keyoti RapidSpell Desktop .NET
Whether to show dialog even when there are no errors in the text box. If set to false causes a spell check before opening the dialog, if there are no errors a message box appears instead of the dialog.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool AlwaysShowDialog { get; set; }
public bool AlwaysShowDialog { get; set; }
Public Property AlwaysShowDialog As Boolean
    Get
    Set
Public Property AlwaysShowDialog As Boolean
    Get
    Set
public:
property bool AlwaysShowDialog {
    bool get ();
    void set (bool value);
}
public:
property bool AlwaysShowDialog {
    bool get ();
    void set (bool value);
}
member AlwaysShowDialog : bool with get, set

member AlwaysShowDialog : bool with get, set
Property Value
Boolean


BackColor Property

Keyoti RapidSpell Desktop .NET API Docs
BackColor Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► BackColor
Keyoti RapidSpell Desktop .NET
Gets or sets the background color for the control.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Color BackColor { get; set; }
public Color BackColor { get; set; }
Public Property BackColor As Color
    Get
    Set
Public Property BackColor As Color
    Get
    Set
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}
member BackColor : Color with get, set

member BackColor : Color with get, set
Property Value
Color


Check Method

Keyoti RapidSpell Desktop .NET API Docs
Check Method
API ► Keyoti.RapidSpell ► RapidSpellDialog ► Check()()()()
Keyoti RapidSpell Desktop .NET
Bring up the spell checker dialog and start checking the component set to check.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void Check()
public void Check()
Public Sub Check
Public Sub Check
public:
void Check()
public:
void Check()
member Check : unit -> unit

member Check : unit -> unit
Exceptions
Exception | Condition
NoTextComponentException | if text component to check hasn't been set first with a TextBoxBase or 3rd Party component.


CheckCompoundWords Property

Keyoti RapidSpell Desktop .NET API Docs
CheckCompoundWords Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► CheckCompoundWords
Keyoti RapidSpell Desktop .NET
Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool CheckCompoundWords { get; set; }
public bool CheckCompoundWords { get; set; }
Public Property CheckCompoundWords As Boolean
    Get
    Set
Public Property CheckCompoundWords As Boolean
    Get
    Set
public:
property bool CheckCompoundWords {
    bool get ();
    void set (bool value);
}
public:
property bool CheckCompoundWords {
    bool get ();
    void set (bool value);
}
member CheckCompoundWords : bool with get, set

member CheckCompoundWords : bool with get, set
Property Value
Boolean
Remarks
If this=false then LookUp("thesewordsarejoined") = false

If this=true then LookUp("thesewordsarejoined") = true

If this=false then LookUp("abcdef") = false

If this=true then LookUp("abcdef") = false

Setting this to true will degrade lookup performance


CheckDisabledTextBoxes Property

Keyoti RapidSpell Desktop .NET API Docs
CheckDisabledTextBoxes Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► CheckDisabledTextBoxes
Keyoti RapidSpell Desktop .NET
Whether to spell check textboxes which are disabled.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool CheckDisabledTextBoxes { get; set; }
public bool CheckDisabledTextBoxes { get; set; }
Public Property CheckDisabledTextBoxes As Boolean
    Get
    Set
Public Property CheckDisabledTextBoxes As Boolean
    Get
    Set
public:
property bool CheckDisabledTextBoxes {
    bool get ();
    void set (bool value);
}
public:
property bool CheckDisabledTextBoxes {
    bool get ();
    void set (bool value);
}
member CheckDisabledTextBoxes : bool with get, set

member CheckDisabledTextBoxes : bool with get, set
Property Value
Boolean


CheckerEngine Property

Keyoti RapidSpell Desktop .NET API Docs
CheckerEngine Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► CheckerEngine
Keyoti RapidSpell Desktop .NET
The checker engine to use, this object must implement the ICheckerEngine interface, allows customization or replacement of the spell checker.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ICheckerEngine CheckerEngine { get; set; }
public ICheckerEngine CheckerEngine { get; set; }
Public Property CheckerEngine As ICheckerEngine
    Get
    Set
Public Property CheckerEngine As ICheckerEngine
    Get
    Set
public:
property ICheckerEngine^ CheckerEngine {
    ICheckerEngine^ get ();
    void set (ICheckerEngine^ value);
}
public:
property ICheckerEngine^ CheckerEngine {
    ICheckerEngine^ get ();
    void set (ICheckerEngine^ value);
}
member CheckerEngine : ICheckerEngine with get, set

member CheckerEngine : ICheckerEngine with get, set
Property Value
ICheckerEngine
Remarks
Use this property to replace the object used to perform checking, it is not necessary to replace this with a spell checker, any type of word parser can be used. For example an abbreviations checker could be written to replace common words with abbreviations. Caveat: Most behavior properties in RapidSpellDialog are mirrors of properties in ICheckerEngine; any values set in ICheckerEngine will be overwritten by values set in RapidSpellDialog.


CheckFromStartOfTextOnMultiples Property

Keyoti RapidSpell Desktop .NET API Docs
CheckFromStartOfTextOnMultiples Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► CheckFromStartOfTextOnMultiples
Keyoti RapidSpell Desktop .NET
Whether to check each textbox from the start of the text when working with multiple textboxes.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool CheckFromStartOfTextOnMultiples { get; set; }
public bool CheckFromStartOfTextOnMultiples { get; set; }
Public Property CheckFromStartOfTextOnMultiples As Boolean
    Get
    Set
Public Property CheckFromStartOfTextOnMultiples As Boolean
    Get
    Set
public:
property bool CheckFromStartOfTextOnMultiples {
    bool get ();
    void set (bool value);
}
public:
property bool CheckFromStartOfTextOnMultiples {
    bool get ();
    void set (bool value);
}
member CheckFromStartOfTextOnMultiples : bool with get, set

member CheckFromStartOfTextOnMultiples : bool with get, set
Property Value
Boolean


CheckReadOnlyTextBoxes Property

Keyoti RapidSpell Desktop .NET API Docs
CheckReadOnlyTextBoxes Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► CheckReadOnlyTextBoxes
Keyoti RapidSpell Desktop .NET
Whether to spell check textboxes which are readonly.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool CheckReadOnlyTextBoxes { get; set; }
public bool CheckReadOnlyTextBoxes { get; set; }
Public Property CheckReadOnlyTextBoxes As Boolean
    Get
    Set
Public Property CheckReadOnlyTextBoxes As Boolean
    Get
    Set
public:
property bool CheckReadOnlyTextBoxes {
    bool get ();
    void set (bool value);
}
public:
property bool CheckReadOnlyTextBoxes {
    bool get ();
    void set (bool value);
}
member CheckReadOnlyTextBoxes : bool with get, set

member CheckReadOnlyTextBoxes : bool with get, set
Property Value
Boolean


ClearTextComponents Method

Keyoti RapidSpell Desktop .NET API Docs
ClearTextComponents Method
API ► Keyoti.RapidSpell ► RapidSpellDialog ► ClearTextComponents()()()()
Keyoti RapidSpell Desktop .NET
Removes all text components from being spell checked.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
[ObsoleteAttribute("This method has been renamed, please call RemoveAllTextComponents() instead.",
    false)]
public void ClearTextComponents()
[ObsoleteAttribute("This method has been renamed, please call RemoveAllTextComponents() instead.",
    false)]
public void ClearTextComponents()
<ObsoleteAttribute("This method has been renamed, please call RemoveAllTextComponents() instead.",
    false)>
Public Sub ClearTextComponents
<ObsoleteAttribute("This method has been renamed, please call RemoveAllTextComponents() instead.",
    false)>
Public Sub ClearTextComponents
public:
[ObsoleteAttribute(L"This method has been renamed, please call RemoveAllTextComponents() instead.",
    false)]
void ClearTextComponents()
public:
[ObsoleteAttribute(L"This method has been renamed, please call RemoveAllTextComponents() instead.",
    false)]
void ClearTextComponents()
[<ObsoleteAttribute("This method has been renamed, please call RemoveAllTextComponents() instead.",
    false)>]
member ClearTextComponents : unit -> unit

[<ObsoleteAttribute("This method has been renamed, please call RemoveAllTextComponents() instead.",
    false)>]
member ClearTextComponents : unit -> unit


Close Method

Keyoti RapidSpell Desktop .NET API Docs
Close Method
API ► Keyoti.RapidSpell ► RapidSpellDialog ► Close()()()()
Keyoti RapidSpell Desktop .NET
Close the spell checker dialog window, if open.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void Close()
public void Close()
Public Sub Close
Public Sub Close
public:
void Close()
public:
void Close()
member Close : unit -> unit

member Close : unit -> unit


ConsiderationRange Property

Keyoti RapidSpell Desktop .NET API Docs
ConsiderationRange Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► ConsiderationRange
Keyoti RapidSpell Desktop .NET
Sets the factor for words to consider for suggestions, lower values are faster but consider less words for suggestions. Default is 500. If w <= 1 this method won't do anything.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int ConsiderationRange { get; set; }
public int ConsiderationRange { get; set; }
Public Property ConsiderationRange As Integer
    Get
    Set
Public Property ConsiderationRange As Integer
    Get
    Set
public:
property int ConsiderationRange {
    int get ();
    void set (int value);
}
public:
property int ConsiderationRange {
    int get ();
    void set (int value);
}
member ConsiderationRange : int with get, set

member ConsiderationRange : int with get, set
Property Value
Int32


ControlBox Property

Keyoti RapidSpell Desktop .NET API Docs
ControlBox Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► ControlBox
Keyoti RapidSpell Desktop .NET
Whether a control box is displayed in the caption bar of the form.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ControlBox { get; set; }
public bool ControlBox { get; set; }
Public Property ControlBox As Boolean
    Get
    Set
Public Property ControlBox As Boolean
    Get
    Set
public:
property bool ControlBox {
    bool get ();
    void set (bool value);
}
public:
property bool ControlBox {
    bool get ();
    void set (bool value);
}
member ControlBox : bool with get, set

member ControlBox : bool with get, set
Property Value
Boolean


CreateDialogView Event

Keyoti RapidSpell Desktop .NET API Docs
CreateDialogView Event
API ► Keyoti.RapidSpell ► RapidSpellDialog ► CreateDialogView
Keyoti RapidSpell Desktop .NET
Fired when an IDialogView is being created. Allows for customization
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event CreateDialogViewEventHandler CreateDialogView
public event CreateDialogViewEventHandler CreateDialogView
Public Event CreateDialogView As CreateDialogViewEventHandler
Public Event CreateDialogView As CreateDialogViewEventHandler
public:
 event CreateDialogViewEventHandler^ CreateDialogView {
    void add (CreateDialogViewEventHandler^ value);
    void remove (CreateDialogViewEventHandler^ value);
}
public:
 event CreateDialogViewEventHandler^ CreateDialogView {
    void add (CreateDialogViewEventHandler^ value);
    void remove (CreateDialogViewEventHandler^ value);
}
member CreateDialogView : IEvent<CreateDialogViewEventHandler,
    CreateDialogViewEventArgs>

member CreateDialogView : IEvent<CreateDialogViewEventHandler,
    CreateDialogViewEventArgs>
Value
CreateDialogViewEventHandler


CreateDialogViewOptions Event

Keyoti RapidSpell Desktop .NET API Docs
CreateDialogViewOptions Event
API ► Keyoti.RapidSpell ► RapidSpellDialog ► CreateDialogViewOptions
Keyoti RapidSpell Desktop .NET
Fired when an IDialogViewOptions is being created. Allows for customization
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event CreateDialogViewOptionsEventHandler CreateDialogViewOptions
public event CreateDialogViewOptionsEventHandler CreateDialogViewOptions
Public Event CreateDialogViewOptions As CreateDialogViewOptionsEventHandler
Public Event CreateDialogViewOptions As CreateDialogViewOptionsEventHandler
public:
 event CreateDialogViewOptionsEventHandler^ CreateDialogViewOptions {
    void add (CreateDialogViewOptionsEventHandler^ value);
    void remove (CreateDialogViewOptionsEventHandler^ value);
}
public:
 event CreateDialogViewOptionsEventHandler^ CreateDialogViewOptions {
    void add (CreateDialogViewOptionsEventHandler^ value);
    void remove (CreateDialogViewOptionsEventHandler^ value);
}
member CreateDialogViewOptions : IEvent<CreateDialogViewOptionsEventHandler,
    CreateDialogViewOptionsEventArgs>

member CreateDialogViewOptions : IEvent<CreateDialogViewOptionsEventHandler,
    CreateDialogViewOptionsEventArgs>
Value
CreateDialogViewOptionsEventHandler


CreateDialogViewUserDictionaryEdit Event

Keyoti RapidSpell Desktop .NET API Docs
CreateDialogViewUserDictionaryEdit Event
API ► Keyoti.RapidSpell ► RapidSpellDialog ► CreateDialogViewUserDictionaryEdit
Keyoti RapidSpell Desktop .NET
Indicates that a new IDialogViewUserDictionaryEdit is being created, also provides chance to override the default IDialogViewUserDictionaryEdit.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event CreateDialogViewUserDictionaryEditEventHandler CreateDialogViewUserDictionaryEdit
public event CreateDialogViewUserDictionaryEditEventHandler CreateDialogViewUserDictionaryEdit
Public Event CreateDialogViewUserDictionaryEdit As CreateDialogViewUserDictionaryEditEventHandler
Public Event CreateDialogViewUserDictionaryEdit As CreateDialogViewUserDictionaryEditEventHandler
public:
 event CreateDialogViewUserDictionaryEditEventHandler^ CreateDialogViewUserDictionaryEdit {
    void add (CreateDialogViewUserDictionaryEditEventHandler^ value);
    void remove (CreateDialogViewUserDictionaryEditEventHandler^ value);
}
public:
 event CreateDialogViewUserDictionaryEditEventHandler^ CreateDialogViewUserDictionaryEdit {
    void add (CreateDialogViewUserDictionaryEditEventHandler^ value);
    void remove (CreateDialogViewUserDictionaryEditEventHandler^ value);
}
member CreateDialogViewUserDictionaryEdit : IEvent<CreateDialogViewUserDictionaryEditEventHandler,
    CreateDialogViewUserDictionaryEditEventArgs>

member CreateDialogViewUserDictionaryEdit : IEvent<CreateDialogViewUserDictionaryEditEventHandler,
    CreateDialogViewUserDictionaryEditEventArgs>
Value
CreateDialogViewUserDictionaryEditEventHandler


CreateDialogViewUserDictionarySelect Event

Keyoti RapidSpell Desktop .NET API Docs
CreateDialogViewUserDictionarySelect Event
API ► Keyoti.RapidSpell ► RapidSpellDialog ► CreateDialogViewUserDictionarySelect
Keyoti RapidSpell Desktop .NET
Indicates that a new IDialogViewUserDictionarySelect is being created, also provides chance to override the default IDialogViewUserDictionarySelect.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event CreateDialogViewUserDictionarySelectEventHandler CreateDialogViewUserDictionarySelect
public event CreateDialogViewUserDictionarySelectEventHandler CreateDialogViewUserDictionarySelect
Public Event CreateDialogViewUserDictionarySelect As CreateDialogViewUserDictionarySelectEventHandler
Public Event CreateDialogViewUserDictionarySelect As CreateDialogViewUserDictionarySelectEventHandler
public:
 event CreateDialogViewUserDictionarySelectEventHandler^ CreateDialogViewUserDictionarySelect {
    void add (CreateDialogViewUserDictionarySelectEventHandler^ value);
    void remove (CreateDialogViewUserDictionarySelectEventHandler^ value);
}
public:
 event CreateDialogViewUserDictionarySelectEventHandler^ CreateDialogViewUserDictionarySelect {
    void add (CreateDialogViewUserDictionarySelectEventHandler^ value);
    void remove (CreateDialogViewUserDictionarySelectEventHandler^ value);
}
member CreateDialogViewUserDictionarySelect : IEvent<CreateDialogViewUserDictionarySelectEventHandler,
    CreateDialogViewUserDictionarySelectEventArgs>

member CreateDialogViewUserDictionarySelect : IEvent<CreateDialogViewUserDictionarySelectEventHandler,
    CreateDialogViewUserDictionarySelectEventArgs>
Value
CreateDialogViewUserDictionarySelectEventHandler


CreateUserInterfaceFormPresenter Event

Keyoti RapidSpell Desktop .NET API Docs
CreateUserInterfaceFormPresenter Event
API ► Keyoti.RapidSpell ► RapidSpellDialog ► CreateUserInterfaceFormPresenter
Keyoti RapidSpell Desktop .NET
Fired when an IUserInterfaceFormPresenter is being created. Allows for customization
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event CreateUserInterfaceFormPresenterEventHandler CreateUserInterfaceFormPresenter
public event CreateUserInterfaceFormPresenterEventHandler CreateUserInterfaceFormPresenter
Public Event CreateUserInterfaceFormPresenter As CreateUserInterfaceFormPresenterEventHandler
Public Event CreateUserInterfaceFormPresenter As CreateUserInterfaceFormPresenterEventHandler
public:
 event CreateUserInterfaceFormPresenterEventHandler^ CreateUserInterfaceFormPresenter {
    void add (CreateUserInterfaceFormPresenterEventHandler^ value);
    void remove (CreateUserInterfaceFormPresenterEventHandler^ value);
}
public:
 event CreateUserInterfaceFormPresenterEventHandler^ CreateUserInterfaceFormPresenter {
    void add (CreateUserInterfaceFormPresenterEventHandler^ value);
    void remove (CreateUserInterfaceFormPresenterEventHandler^ value);
}
member CreateUserInterfaceFormPresenter : IEvent<CreateUserInterfaceFormPresenterEventHandler,
    CreateUserInterfaceFormPresenterEventArgs>

member CreateUserInterfaceFormPresenter : IEvent<CreateUserInterfaceFormPresenterEventHandler,
    CreateUserInterfaceFormPresenterEventArgs>
Value
CreateUserInterfaceFormPresenterEventHandler


DictFilePath Property

Keyoti RapidSpell Desktop .NET API Docs
DictFilePath Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► DictFilePath
Keyoti RapidSpell Desktop .NET
The file to be used as the main dictionary (either a full file path, or the name of an embedded resource), if this is null then the built-in US English dictionary is used.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string DictFilePath { get; set; }
public string DictFilePath { get; set; }
Public Property DictFilePath As String
    Get
    Set
Public Property DictFilePath As String
    Get
    Set
public:
property String^ DictFilePath {
    String^ get ();
    void set (String^ value);
}
public:
property String^ DictFilePath {
    String^ get ();
    void set (String^ value);
}
member DictFilePath : string with get, set

member DictFilePath : string with get, set
Property Value
String


Dispose Method (disposing)

Keyoti RapidSpell Desktop .NET API Docs
Dispose Method (disposing)
API ► Keyoti.RapidSpell ► RapidSpellDialog ► Dispose(Boolean)
Keyoti RapidSpell Desktop .NET
Disposes of unmanaged resources.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
Parameters
disposing (Boolean)


FindCapitalizedSuggestions Property

Keyoti RapidSpell Desktop .NET API Docs
FindCapitalizedSuggestions Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► FindCapitalizedSuggestions
Keyoti RapidSpell Desktop .NET
Whether to look for capitalized suggestions, note this will slow FindSuggestions down by about 7 times.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool FindCapitalizedSuggestions { get; set; }
public bool FindCapitalizedSuggestions { get; set; }
Public Property FindCapitalizedSuggestions As Boolean
    Get
    Set
Public Property FindCapitalizedSuggestions As Boolean
    Get
    Set
public:
property bool FindCapitalizedSuggestions {
    bool get ();
    void set (bool value);
}
public:
property bool FindCapitalizedSuggestions {
    bool get ();
    void set (bool value);
}
member FindCapitalizedSuggestions : bool with get, set

member FindCapitalizedSuggestions : bool with get, set
Property Value
Boolean


ForeColor Property

Keyoti RapidSpell Desktop .NET API Docs
ForeColor Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► ForeColor
Keyoti RapidSpell Desktop .NET
Gets or sets the foreground color for the control.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Color ForeColor { get; set; }
public Color ForeColor { get; set; }
Public Property ForeColor As Color
    Get
    Set
Public Property ForeColor As Color
    Get
    Set
public:
property Color ForeColor {
    Color get ();
    void set (Color value);
}
public:
property Color ForeColor {
    Color get ();
    void set (Color value);
}
member ForeColor : Color with get, set

member ForeColor : Color with get, set
Property Value
Color


FormBorderStyle Property

Keyoti RapidSpell Desktop .NET API Docs
FormBorderStyle Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► FormBorderStyle
Keyoti RapidSpell Desktop .NET
Specifies the border styles for the dialog form.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public FormBorderStyle FormBorderStyle { get; set; }
public FormBorderStyle FormBorderStyle { get; set; }
Public Property FormBorderStyle As FormBorderStyle
    Get
    Set
Public Property FormBorderStyle As FormBorderStyle
    Get
    Set
public:
property FormBorderStyle FormBorderStyle {
    FormBorderStyle get ();
    void set (FormBorderStyle value);
}
public:
property FormBorderStyle FormBorderStyle {
    FormBorderStyle get ();
    void set (FormBorderStyle value);
}
member FormBorderStyle : FormBorderStyle with get, set

member FormBorderStyle : FormBorderStyle with get, set
Property Value
FormBorderStyle


GUILanguage Property

Keyoti RapidSpell Desktop .NET API Docs
GUILanguage Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► GUILanguage
Keyoti RapidSpell Desktop .NET
The language to show the UI in.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public LanguageType GUILanguage { get; set; }
public LanguageType GUILanguage { get; set; }
Public Property GUILanguage As LanguageType
    Get
    Set
Public Property GUILanguage As LanguageType
    Get
    Set
public:
property LanguageType GUILanguage {
    LanguageType get ();
    void set (LanguageType value);
}
public:
property LanguageType GUILanguage {
    LanguageType get ();
    void set (LanguageType value);
}
member GUILanguage : LanguageType with get, set

member GUILanguage : LanguageType with get, set
Property Value
LanguageType


Icon Property

Keyoti RapidSpell Desktop .NET API Docs
Icon Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► Icon
Keyoti RapidSpell Desktop .NET
Gets or sets the icon for the form..
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Icon Icon { get; set; }
public Icon Icon { get; set; }
Public Property Icon As Icon
    Get
    Set
Public Property Icon As Icon
    Get
    Set
public:
property Icon^ Icon {
    Icon^ get ();
    void set (Icon^ value);
}
public:
property Icon^ Icon {
    Icon^ get ();
    void set (Icon^ value);
}
member Icon : Icon with get, set

member Icon : Icon with get, set
Property Value
Icon


IgnoreCapitalizedWords Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreCapitalizedWords Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► IgnoreCapitalizedWords
Keyoti RapidSpell Desktop .NET
Whether to ignore words with capital letters.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreCapitalizedWords { get; set; }
public bool IgnoreCapitalizedWords { get; set; }
Public Property IgnoreCapitalizedWords As Boolean
    Get
    Set
Public Property IgnoreCapitalizedWords As Boolean
    Get
    Set
public:
property bool IgnoreCapitalizedWords {
    bool get ();
    void set (bool value);
}
public:
property bool IgnoreCapitalizedWords {
    bool get ();
    void set (bool value);
}
member IgnoreCapitalizedWords : bool with get, set

member IgnoreCapitalizedWords : bool with get, set
Property Value
Boolean


IgnoreIncorrectSentenceCapitalization Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreIncorrectSentenceCapitalization Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► IgnoreIncorrectSentenceCapitalization
Keyoti RapidSpell Desktop .NET
Whether to ignore incorrect sentence capitalization.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreIncorrectSentenceCapitalization { get; set; }
public bool IgnoreIncorrectSentenceCapitalization { get; set; }
Public Property IgnoreIncorrectSentenceCapitalization As Boolean
    Get
    Set
Public Property IgnoreIncorrectSentenceCapitalization As Boolean
    Get
    Set
public:
property bool IgnoreIncorrectSentenceCapitalization {
    bool get ();
    void set (bool value);
}
public:
property bool IgnoreIncorrectSentenceCapitalization {
    bool get ();
    void set (bool value);
}
member IgnoreIncorrectSentenceCapitalization : bool with get, set

member IgnoreIncorrectSentenceCapitalization : bool with get, set
Property Value
Boolean


IgnoreInEnglishLowerCaseI Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreInEnglishLowerCaseI Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► IgnoreInEnglishLowerCaseI
Keyoti RapidSpell Desktop .NET
Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreInEnglishLowerCaseI { get; set; }
public bool IgnoreInEnglishLowerCaseI { get; set; }
Public Property IgnoreInEnglishLowerCaseI As Boolean
    Get
    Set
Public Property IgnoreInEnglishLowerCaseI As Boolean
    Get
    Set
public:
property bool IgnoreInEnglishLowerCaseI {
    bool get ();
    void set (bool value);
}
public:
property bool IgnoreInEnglishLowerCaseI {
    bool get ();
    void set (bool value);
}
member IgnoreInEnglishLowerCaseI : bool with get, set

member IgnoreInEnglishLowerCaseI : bool with get, set
Property Value
Boolean


IgnoreURLsAndEmailAddresses Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreURLsAndEmailAddresses Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► IgnoreURLsAndEmailAddresses
Keyoti RapidSpell Desktop .NET
Whether to ignore URLs and email addresses (requires V2Parser=true)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreURLsAndEmailAddresses { get; set; }
public bool IgnoreURLsAndEmailAddresses { get; set; }
Public Property IgnoreURLsAndEmailAddresses As Boolean
    Get
    Set
Public Property IgnoreURLsAndEmailAddresses As Boolean
    Get
    Set
public:
property bool IgnoreURLsAndEmailAddresses {
    bool get ();
    void set (bool value);
}
public:
property bool IgnoreURLsAndEmailAddresses {
    bool get ();
    void set (bool value);
}
member IgnoreURLsAndEmailAddresses : bool with get, set

member IgnoreURLsAndEmailAddresses : bool with get, set
Property Value
Boolean
Remarks
This will cause the following strings to be accepted as non-spelling errors;
"user@domain.com", "http://www.domain.com", "domain.co.uk" etc.


IgnoreWordsWithDigits Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreWordsWithDigits Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► IgnoreWordsWithDigits
Keyoti RapidSpell Desktop .NET
Whether to ignore words with numbers in them (eg. A10 or 7-11).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreWordsWithDigits { get; set; }
public bool IgnoreWordsWithDigits { get; set; }
Public Property IgnoreWordsWithDigits As Boolean
    Get
    Set
Public Property IgnoreWordsWithDigits As Boolean
    Get
    Set
public:
property bool IgnoreWordsWithDigits {
    bool get ();
    void set (bool value);
}
public:
property bool IgnoreWordsWithDigits {
    bool get ();
    void set (bool value);
}
member IgnoreWordsWithDigits : bool with get, set

member IgnoreWordsWithDigits : bool with get, set
Property Value
Boolean


IgnoreXML Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreXML Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► IgnoreXML
Keyoti RapidSpell Desktop .NET
Whether to ignore XML/HTML tags, false by default.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreXML { get; set; }
public bool IgnoreXML { get; set; }
Public Property IgnoreXML As Boolean
    Get
    Set
Public Property IgnoreXML As Boolean
    Get
    Set
public:
property bool IgnoreXML {
    bool get ();
    void set (bool value);
}
public:
property bool IgnoreXML {
    bool get ();
    void set (bool value);
}
member IgnoreXML : bool with get, set

member IgnoreXML : bool with get, set
Property Value
Boolean
Remarks
This identifies XML tags as anything in between < and > characters, there for it will cause undesirable effects in text such as "the sign for less than is < and the sign for greater than is >". Of course in HTML that should have been written as "the sign for less than is &lt; and the sign for greater than is &gt;" anyway, which would be fine.


IncludeUserDictionaryInSuggestions Property

Keyoti RapidSpell Desktop .NET API Docs
IncludeUserDictionaryInSuggestions Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► IncludeUserDictionaryInSuggestions
Keyoti RapidSpell Desktop .NET
Whether the user dictionary should be used in finding suggestions for misspelt words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IncludeUserDictionaryInSuggestions { get; set; }
public bool IncludeUserDictionaryInSuggestions { get; set; }
Public Property IncludeUserDictionaryInSuggestions As Boolean
    Get
    Set
Public Property IncludeUserDictionaryInSuggestions As Boolean
    Get
    Set
public:
property bool IncludeUserDictionaryInSuggestions {
    bool get ();
    void set (bool value);
}
public:
property bool IncludeUserDictionaryInSuggestions {
    bool get ();
    void set (bool value);
}
member IncludeUserDictionaryInSuggestions : bool with get, set

member IncludeUserDictionaryInSuggestions : bool with get, set
Property Value
Boolean


LanguageParser Property

Keyoti RapidSpell Desktop .NET API Docs
LanguageParser Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► LanguageParser
Keyoti RapidSpell Desktop .NET
The type of language parsing to use.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public LanguageType LanguageParser { get; set; }
public LanguageType LanguageParser { get; set; }
Public Property LanguageParser As LanguageType
    Get
    Set
Public Property LanguageParser As LanguageType
    Get
    Set
public:
property LanguageType LanguageParser {
    LanguageType get ();
    void set (LanguageType value);
}
public:
property LanguageType LanguageParser {
    LanguageType get ();
    void set (LanguageType value);
}
member LanguageParser : LanguageType with get, set

member LanguageParser : LanguageType with get, set
Property Value
LanguageType
Remarks
Eg. If the dictionary is set to French, you should use the French parser.


Location Property

Keyoti RapidSpell Desktop .NET API Docs
Location Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► Location
Keyoti RapidSpell Desktop .NET
Where to position dialog the first time it is opened.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Point Location { get; set; }
public Point Location { get; set; }
Public Property Location As Point
    Get
    Set
Public Property Location As Point
    Get
    Set
public:
property Point Location {
    Point get ();
    void set (Point value);
}
public:
property Point Location {
    Point get ();
    void set (Point value);
}
member Location : Point with get, set

member Location : Point with get, set
Property Value
Point


LookIntoHyphenatedText Property

Keyoti RapidSpell Desktop .NET API Docs
LookIntoHyphenatedText Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► LookIntoHyphenatedText
Keyoti RapidSpell Desktop .NET
Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool LookIntoHyphenatedText { get; set; }
public bool LookIntoHyphenatedText { get; set; }
Public Property LookIntoHyphenatedText As Boolean
    Get
    Set
Public Property LookIntoHyphenatedText As Boolean
    Get
    Set
public:
property bool LookIntoHyphenatedText {
    bool get ();
    void set (bool value);
}
public:
property bool LookIntoHyphenatedText {
    bool get ();
    void set (bool value);
}
member LookIntoHyphenatedText : bool with get, set

member LookIntoHyphenatedText : bool with get, set
Property Value
Boolean
Remarks
Eg. "socio-economic" will be checked as "socio" and "economic".


MdiParent Property

Keyoti RapidSpell Desktop .NET API Docs
MdiParent Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► MdiParent
Keyoti RapidSpell Desktop .NET
Gets or sets the current multiple document interface (MDI) parent form of this form.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Form MdiParent { get; set; }
public Form MdiParent { get; set; }
Public Property MdiParent As Form
    Get
    Set
Public Property MdiParent As Form
    Get
    Set
public:
property Form^ MdiParent {
    Form^ get ();
    void set (Form^ value);
}
public:
property Form^ MdiParent {
    Form^ get ();
    void set (Form^ value);
}
member MdiParent : Form with get, set

member MdiParent : Form with get, set
Property Value
Form


MinimizeBox Property

Keyoti RapidSpell Desktop .NET API Docs
MinimizeBox Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► MinimizeBox
Keyoti RapidSpell Desktop .NET
Whether the minimize button is displayed in the caption bar of the form.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool MinimizeBox { get; set; }
public bool MinimizeBox { get; set; }
Public Property MinimizeBox As Boolean
    Get
    Set
Public Property MinimizeBox As Boolean
    Get
    Set
public:
property bool MinimizeBox {
    bool get ();
    void set (bool value);
}
public:
property bool MinimizeBox {
    bool get ();
    void set (bool value);
}
member MinimizeBox : bool with get, set

member MinimizeBox : bool with get, set
Property Value
Boolean


Modal Property

Keyoti RapidSpell Desktop .NET API Docs
Modal Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► Modal
Keyoti RapidSpell Desktop .NET
Whether the spell checker will run modally. (Modal operation blocks the parent form)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool Modal { get; set; }
public bool Modal { get; set; }
Public Property Modal As Boolean
    Get
    Set
Public Property Modal As Boolean
    Get
    Set
public:
property bool Modal {
    bool get ();
    void set (bool value);
}
public:
property bool Modal {
    bool get ();
    void set (bool value);
}
member Modal : bool with get, set

member Modal : bool with get, set
Property Value
Boolean


ModalAutoDispose Property

Keyoti RapidSpell Desktop .NET API Docs
ModalAutoDispose Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► ModalAutoDispose
Keyoti RapidSpell Desktop .NET
When running modally, determines if the dialog will be disposed of when spell check finishes.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ModalAutoDispose { get; set; }
public bool ModalAutoDispose { get; set; }
Public Property ModalAutoDispose As Boolean
    Get
    Set
Public Property ModalAutoDispose As Boolean
    Get
    Set
public:
property bool ModalAutoDispose {
    bool get ();
    void set (bool value);
}
public:
property bool ModalAutoDispose {
    bool get ();
    void set (bool value);
}
member ModalAutoDispose : bool with get, set

member ModalAutoDispose : bool with get, set
Property Value
Boolean
Remarks
If a modal form disposes of itself, there will be slight flickering on the screen, to prevent this, set this property to false and call Dispose() when finished with this control.


ModalOwner Property

Keyoti RapidSpell Desktop .NET API Docs
ModalOwner Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► ModalOwner
Keyoti RapidSpell Desktop .NET
The owner of the checker form, when it's viewed modally.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public IWin32Window ModalOwner { get; set; }
public IWin32Window ModalOwner { get; set; }
Public Property ModalOwner As IWin32Window
    Get
    Set
Public Property ModalOwner As IWin32Window
    Get
    Set
public:
property IWin32Window^ ModalOwner {
    IWin32Window^ get ();
    void set (IWin32Window^ value);
}
public:
property IWin32Window^ ModalOwner {
    IWin32Window^ get ();
    void set (IWin32Window^ value);
}
member ModalOwner : IWin32Window with get, set

member ModalOwner : IWin32Window with get, set
Property Value
IWin32Window
Remarks
This is equivalent to owner in ShowDialog(owner), set to null/nothing for no owner to be specified.


NumberSuggestionList Property

Keyoti RapidSpell Desktop .NET API Docs
NumberSuggestionList Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► NumberSuggestionList
Keyoti RapidSpell Desktop .NET
Whether to number the items in the suggestion list, for quick user selection.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool NumberSuggestionList { get; set; }
public bool NumberSuggestionList { get; set; }
Public Property NumberSuggestionList As Boolean
    Get
    Set
Public Property NumberSuggestionList As Boolean
    Get
    Set
public:
property bool NumberSuggestionList {
    bool get ();
    void set (bool value);
}
public:
property bool NumberSuggestionList {
    bool get ();
    void set (bool value);
}
member NumberSuggestionList : bool with get, set

member NumberSuggestionList : bool with get, set
Property Value
Boolean


OnCreateDialogView Method (e)

Keyoti RapidSpell Desktop .NET API Docs
OnCreateDialogView Method (e)
API ► Keyoti.RapidSpell ► RapidSpellDialog ► OnCreateDialogView(CreateDialogViewEventArgs)
Keyoti RapidSpell Desktop .NET
Raises event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void OnCreateDialogView(
    CreateDialogViewEventArgs e
)
protected virtual void OnCreateDialogView(
    CreateDialogViewEventArgs e
)
Protected Overridable Sub OnCreateDialogView (
    e As CreateDialogViewEventArgs
)
Protected Overridable Sub OnCreateDialogView (
    e As CreateDialogViewEventArgs
)
protected:
virtual void OnCreateDialogView(
    CreateDialogViewEventArgs^ e
)
protected:
virtual void OnCreateDialogView(
    CreateDialogViewEventArgs^ e
)
abstract OnCreateDialogView :
        e : CreateDialogViewEventArgs -> unit
override OnCreateDialogView :
        e : CreateDialogViewEventArgs -> unit
abstract OnCreateDialogView :
        e : CreateDialogViewEventArgs -> unit
override OnCreateDialogView :
        e : CreateDialogViewEventArgs -> unit
Parameters
e (CreateDialogViewEventArgs)


OnCreateDialogViewOptions Method (e)

Keyoti RapidSpell Desktop .NET API Docs
OnCreateDialogViewOptions Method (e)
API ► Keyoti.RapidSpell ► RapidSpellDialog ► OnCreateDialogViewOptions(CreateDialogViewOptionsEventArgs)
Keyoti RapidSpell Desktop .NET
Raises event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void OnCreateDialogViewOptions(
    CreateDialogViewOptionsEventArgs e
)
protected virtual void OnCreateDialogViewOptions(
    CreateDialogViewOptionsEventArgs e
)
Protected Overridable Sub OnCreateDialogViewOptions (
    e As CreateDialogViewOptionsEventArgs
)
Protected Overridable Sub OnCreateDialogViewOptions (
    e As CreateDialogViewOptionsEventArgs
)
protected:
virtual void OnCreateDialogViewOptions(
    CreateDialogViewOptionsEventArgs^ e
)
protected:
virtual void OnCreateDialogViewOptions(
    CreateDialogViewOptionsEventArgs^ e
)
abstract OnCreateDialogViewOptions :
        e : CreateDialogViewOptionsEventArgs -> unit
override OnCreateDialogViewOptions :
        e : CreateDialogViewOptionsEventArgs -> unit
abstract OnCreateDialogViewOptions :
        e : CreateDialogViewOptionsEventArgs -> unit
override OnCreateDialogViewOptions :
        e : CreateDialogViewOptionsEventArgs -> unit
Parameters
e (CreateDialogViewOptionsEventArgs)


OnCreateDialogViewUserDictionaryEdit Method (e)

Keyoti RapidSpell Desktop .NET API Docs
OnCreateDialogViewUserDictionaryEdit Method (e)
API ► Keyoti.RapidSpell ► RapidSpellDialog ► OnCreateDialogViewUserDictionaryEdit(CreateDialogViewUserDictionaryEditEventArgs)
Keyoti RapidSpell Desktop .NET
Fires the CreateDialogViewUserDictionaryEdit event.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void OnCreateDialogViewUserDictionaryEdit(
    CreateDialogViewUserDictionaryEditEventArgs e
)
protected virtual void OnCreateDialogViewUserDictionaryEdit(
    CreateDialogViewUserDictionaryEditEventArgs e
)
Protected Overridable Sub OnCreateDialogViewUserDictionaryEdit (
    e As CreateDialogViewUserDictionaryEditEventArgs
)
Protected Overridable Sub OnCreateDialogViewUserDictionaryEdit (
    e As CreateDialogViewUserDictionaryEditEventArgs
)
protected:
virtual void OnCreateDialogViewUserDictionaryEdit(
    CreateDialogViewUserDictionaryEditEventArgs^ e
)
protected:
virtual void OnCreateDialogViewUserDictionaryEdit(
    CreateDialogViewUserDictionaryEditEventArgs^ e
)
abstract OnCreateDialogViewUserDictionaryEdit :
        e : CreateDialogViewUserDictionaryEditEventArgs -> unit
override OnCreateDialogViewUserDictionaryEdit :
        e : CreateDialogViewUserDictionaryEditEventArgs -> unit
abstract OnCreateDialogViewUserDictionaryEdit :
        e : CreateDialogViewUserDictionaryEditEventArgs -> unit
override OnCreateDialogViewUserDictionaryEdit :
        e : CreateDialogViewUserDictionaryEditEventArgs -> unit
Parameters
e (CreateDialogViewUserDictionaryEditEventArgs)


OnCreateDialogViewUserDictionarySelect Method (e)

Keyoti RapidSpell Desktop .NET API Docs
OnCreateDialogViewUserDictionarySelect Method (e)
API ► Keyoti.RapidSpell ► RapidSpellDialog ► OnCreateDialogViewUserDictionarySelect(CreateDialogViewUserDictionarySelectEventArgs)
Keyoti RapidSpell Desktop .NET
Raises event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void OnCreateDialogViewUserDictionarySelect(
    CreateDialogViewUserDictionarySelectEventArgs e
)
protected virtual void OnCreateDialogViewUserDictionarySelect(
    CreateDialogViewUserDictionarySelectEventArgs e
)
Protected Overridable Sub OnCreateDialogViewUserDictionarySelect (
    e As CreateDialogViewUserDictionarySelectEventArgs
)
Protected Overridable Sub OnCreateDialogViewUserDictionarySelect (
    e As CreateDialogViewUserDictionarySelectEventArgs
)
protected:
virtual void OnCreateDialogViewUserDictionarySelect(
    CreateDialogViewUserDictionarySelectEventArgs^ e
)
protected:
virtual void OnCreateDialogViewUserDictionarySelect(
    CreateDialogViewUserDictionarySelectEventArgs^ e
)
abstract OnCreateDialogViewUserDictionarySelect :
        e : CreateDialogViewUserDictionarySelectEventArgs -> unit
override OnCreateDialogViewUserDictionarySelect :
        e : CreateDialogViewUserDictionarySelectEventArgs -> unit
abstract OnCreateDialogViewUserDictionarySelect :
        e : CreateDialogViewUserDictionarySelectEventArgs -> unit
override OnCreateDialogViewUserDictionarySelect :
        e : CreateDialogViewUserDictionarySelectEventArgs -> unit
Parameters
e (CreateDialogViewUserDictionarySelectEventArgs)


OnCreateUserInterfaceFormPresenter Method (e)

Keyoti RapidSpell Desktop .NET API Docs
OnCreateUserInterfaceFormPresenter Method (e)
API ► Keyoti.RapidSpell ► RapidSpellDialog ► OnCreateUserInterfaceFormPresenter(CreateUserInterfaceFormPresenterEventArgs)
Keyoti RapidSpell Desktop .NET
Raises event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void OnCreateUserInterfaceFormPresenter(
    CreateUserInterfaceFormPresenterEventArgs e
)
protected virtual void OnCreateUserInterfaceFormPresenter(
    CreateUserInterfaceFormPresenterEventArgs e
)
Protected Overridable Sub OnCreateUserInterfaceFormPresenter (
    e As CreateUserInterfaceFormPresenterEventArgs
)
Protected Overridable Sub OnCreateUserInterfaceFormPresenter (
    e As CreateUserInterfaceFormPresenterEventArgs
)
protected:
virtual void OnCreateUserInterfaceFormPresenter(
    CreateUserInterfaceFormPresenterEventArgs^ e
)
protected:
virtual void OnCreateUserInterfaceFormPresenter(
    CreateUserInterfaceFormPresenterEventArgs^ e
)
abstract OnCreateUserInterfaceFormPresenter :
        e : CreateUserInterfaceFormPresenterEventArgs -> unit
override OnCreateUserInterfaceFormPresenter :
        e : CreateUserInterfaceFormPresenterEventArgs -> unit
abstract OnCreateUserInterfaceFormPresenter :
        e : CreateUserInterfaceFormPresenterEventArgs -> unit
override OnCreateUserInterfaceFormPresenter :
        e : CreateUserInterfaceFormPresenterEventArgs -> unit
Parameters
e (CreateUserInterfaceFormPresenterEventArgs)


OnSpellCheckFinishedTextBox Method (e)

Keyoti RapidSpell Desktop .NET API Docs
OnSpellCheckFinishedTextBox Method (e)
API ► Keyoti.RapidSpell ► RapidSpellDialog ► OnSpellCheckFinishedTextBox(TextBoxSpellCheckEventArgs)
Keyoti RapidSpell Desktop .NET
Raises event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void OnSpellCheckFinishedTextBox(
    TextBoxSpellCheckEventArgs e
)
protected virtual void OnSpellCheckFinishedTextBox(
    TextBoxSpellCheckEventArgs e
)
Protected Overridable Sub OnSpellCheckFinishedTextBox (
    e As TextBoxSpellCheckEventArgs
)
Protected Overridable Sub OnSpellCheckFinishedTextBox (
    e As TextBoxSpellCheckEventArgs
)
protected:
virtual void OnSpellCheckFinishedTextBox(
    TextBoxSpellCheckEventArgs^ e
)
protected:
virtual void OnSpellCheckFinishedTextBox(
    TextBoxSpellCheckEventArgs^ e
)
abstract OnSpellCheckFinishedTextBox :
        e : TextBoxSpellCheckEventArgs -> unit
override OnSpellCheckFinishedTextBox :
        e : TextBoxSpellCheckEventArgs -> unit
abstract OnSpellCheckFinishedTextBox :
        e : TextBoxSpellCheckEventArgs -> unit
override OnSpellCheckFinishedTextBox :
        e : TextBoxSpellCheckEventArgs -> unit
Parameters
e (TextBoxSpellCheckEventArgs)


OnSpellCheckStartedTextBox Method (e)

Keyoti RapidSpell Desktop .NET API Docs
OnSpellCheckStartedTextBox Method (e)
API ► Keyoti.RapidSpell ► RapidSpellDialog ► OnSpellCheckStartedTextBox(TextBoxSpellCheckEventArgs)
Keyoti RapidSpell Desktop .NET
Raises event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void OnSpellCheckStartedTextBox(
    TextBoxSpellCheckEventArgs e
)
protected virtual void OnSpellCheckStartedTextBox(
    TextBoxSpellCheckEventArgs e
)
Protected Overridable Sub OnSpellCheckStartedTextBox (
    e As TextBoxSpellCheckEventArgs
)
Protected Overridable Sub OnSpellCheckStartedTextBox (
    e As TextBoxSpellCheckEventArgs
)
protected:
virtual void OnSpellCheckStartedTextBox(
    TextBoxSpellCheckEventArgs^ e
)
protected:
virtual void OnSpellCheckStartedTextBox(
    TextBoxSpellCheckEventArgs^ e
)
abstract OnSpellCheckStartedTextBox :
        e : TextBoxSpellCheckEventArgs -> unit
override OnSpellCheckStartedTextBox :
        e : TextBoxSpellCheckEventArgs -> unit
abstract OnSpellCheckStartedTextBox :
        e : TextBoxSpellCheckEventArgs -> unit
override OnSpellCheckStartedTextBox :
        e : TextBoxSpellCheckEventArgs -> unit
Parameters
e (TextBoxSpellCheckEventArgs)


OnWordAdded Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
OnWordAdded Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellDialog ► OnWordAdded(Object, WordAddedEventArgs)
Keyoti RapidSpell Desktop .NET
Fires WordAdded event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected internal void OnWordAdded(
    Object sender,
    WordAddedEventArgs e
)
protected internal void OnWordAdded(
    Object sender,
    WordAddedEventArgs e
)
Protected Friend Sub OnWordAdded (
    sender As Object,
    e As WordAddedEventArgs
)
Protected Friend Sub OnWordAdded (
    sender As Object,
    e As WordAddedEventArgs
)
protected public:
void OnWordAdded(
    Object^ sender,
    WordAddedEventArgs^ e
)
protected public:
void OnWordAdded(
    Object^ sender,
    WordAddedEventArgs^ e
)
member OnWordAdded :
        sender : Object *
        e : WordAddedEventArgs -> unit

member OnWordAdded :
        sender : Object *
        e : WordAddedEventArgs -> unit
Parameters
sender (Object)
e (WordAddedEventArgs)


OnWordChanged Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
OnWordChanged Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellDialog ► OnWordChanged(Object, WordChangedEventArgs)
Keyoti RapidSpell Desktop .NET
Fires WordChanged event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected internal void OnWordChanged(
    Object sender,
    WordChangedEventArgs e
)
protected internal void OnWordChanged(
    Object sender,
    WordChangedEventArgs e
)
Protected Friend Sub OnWordChanged (
    sender As Object,
    e As WordChangedEventArgs
)
Protected Friend Sub OnWordChanged (
    sender As Object,
    e As WordChangedEventArgs
)
protected public:
void OnWordChanged(
    Object^ sender,
    WordChangedEventArgs^ e
)
protected public:
void OnWordChanged(
    Object^ sender,
    WordChangedEventArgs^ e
)
member OnWordChanged :
        sender : Object *
        e : WordChangedEventArgs -> unit

member OnWordChanged :
        sender : Object *
        e : WordChangedEventArgs -> unit
Parameters
sender (Object)
e (WordChangedEventArgs)


OnWordChanging Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
OnWordChanging Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellDialog ► OnWordChanging(Object, WordChangedEventArgs)
Keyoti RapidSpell Desktop .NET
Fires WordChanging event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected internal void OnWordChanging(
    Object sender,
    WordChangedEventArgs e
)
protected internal void OnWordChanging(
    Object sender,
    WordChangedEventArgs e
)
Protected Friend Sub OnWordChanging (
    sender As Object,
    e As WordChangedEventArgs
)
Protected Friend Sub OnWordChanging (
    sender As Object,
    e As WordChangedEventArgs
)
protected public:
void OnWordChanging(
    Object^ sender,
    WordChangedEventArgs^ e
)
protected public:
void OnWordChanging(
    Object^ sender,
    WordChangedEventArgs^ e
)
member OnWordChanging :
        sender : Object *
        e : WordChangedEventArgs -> unit

member OnWordChanging :
        sender : Object *
        e : WordChangedEventArgs -> unit
Parameters
sender (Object)
e (WordChangedEventArgs)


OnWordIgnored Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
OnWordIgnored Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellDialog ► OnWordIgnored(Object, WordIgnoredEventArgs)
Keyoti RapidSpell Desktop .NET
Fires WordIgnored event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected internal void OnWordIgnored(
    Object sender,
    WordIgnoredEventArgs e
)
protected internal void OnWordIgnored(
    Object sender,
    WordIgnoredEventArgs e
)
Protected Friend Sub OnWordIgnored (
    sender As Object,
    e As WordIgnoredEventArgs
)
Protected Friend Sub OnWordIgnored (
    sender As Object,
    e As WordIgnoredEventArgs
)
protected public:
void OnWordIgnored(
    Object^ sender,
    WordIgnoredEventArgs^ e
)
protected public:
void OnWordIgnored(
    Object^ sender,
    WordIgnoredEventArgs^ e
)
member OnWordIgnored :
        sender : Object *
        e : WordIgnoredEventArgs -> unit

member OnWordIgnored :
        sender : Object *
        e : WordIgnoredEventArgs -> unit
Parameters
sender (Object)
e (WordIgnoredEventArgs)


Options Property

Keyoti RapidSpell Desktop .NET API Docs
Options Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► Options
Keyoti RapidSpell Desktop .NET
Object responsible for holding, loading and saving the user's spell check options.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual UserOptions Options { get; set; }
public virtual UserOptions Options { get; set; }
Public Overridable Property Options As UserOptions
    Get
    Set
Public Overridable Property Options As UserOptions
    Get
    Set
public:
virtual property UserOptions^ Options {
    UserOptions^ get ();
    void set (UserOptions^ value);
}
public:
virtual property UserOptions^ Options {
    UserOptions^ get ();
    void set (UserOptions^ value);
}
abstract Options : UserOptions with get, set
override Options : UserOptions with get, set
abstract Options : UserOptions with get, set
override Options : UserOptions with get, set
Property Value
UserOptions
Remarks
To customize how the user's options are saved/loaded, subclass UserOptions and set an instance in this property.


OptionsEnabled Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsEnabled Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► OptionsEnabled
Keyoti RapidSpell Desktop .NET
Whether to use user options.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool OptionsEnabled { get; set; }
public virtual bool OptionsEnabled { get; set; }
Public Overridable Property OptionsEnabled As Boolean
    Get
    Set
Public Overridable Property OptionsEnabled As Boolean
    Get
    Set
public:
virtual property bool OptionsEnabled {
    bool get ();
    void set (bool value);
}
public:
virtual property bool OptionsEnabled {
    bool get ();
    void set (bool value);
}
abstract OptionsEnabled : bool with get, set
override OptionsEnabled : bool with get, set
abstract OptionsEnabled : bool with get, set
override OptionsEnabled : bool with get, set
Property Value
Boolean


OptionsFileName Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsFileName Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► OptionsFileName
Keyoti RapidSpell Desktop .NET
The file name used to store the settings (by default in IsolatedStorage).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsFileName { get; set; }
public string OptionsFileName { get; set; }
Public Property OptionsFileName As String
    Get
    Set
Public Property OptionsFileName As String
    Get
    Set
public:
property String^ OptionsFileName {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OptionsFileName {
    String^ get ();
    void set (String^ value);
}
member OptionsFileName : string with get, set

member OptionsFileName : string with get, set
Property Value
String
Remarks
Changing this can ensure different applications have unique user settings.


OptionsPresenter Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsPresenter Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► OptionsPresenter
Keyoti RapidSpell Desktop .NET
Presenter for the user options form (IDialogViewOptions).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual OptionsPresenter OptionsPresenter { get; set; }
public virtual OptionsPresenter OptionsPresenter { get; set; }
Public Overridable Property OptionsPresenter As OptionsPresenter
    Get
    Set
Public Overridable Property OptionsPresenter As OptionsPresenter
    Get
    Set
public:
virtual property OptionsPresenter^ OptionsPresenter {
    OptionsPresenter^ get ();
    void set (OptionsPresenter^ value);
}
public:
virtual property OptionsPresenter^ OptionsPresenter {
    OptionsPresenter^ get ();
    void set (OptionsPresenter^ value);
}
abstract OptionsPresenter : OptionsPresenter with get, set
override OptionsPresenter : OptionsPresenter with get, set
abstract OptionsPresenter : OptionsPresenter with get, set
override OptionsPresenter : OptionsPresenter with get, set
Property Value
OptionsPresenter
Remarks
Set properties in this instance to affect the options shown to the user, or handle CreateDialogViewOptions to create your own IDialogViewOptions form instance.


OptionsStorageLocation Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsStorageLocation Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► OptionsStorageLocation
Keyoti RapidSpell Desktop .NET
Where the user's options are stored.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UserOptions..::..StorageType OptionsStorageLocation { get; set; }
public UserOptions..::..StorageType OptionsStorageLocation { get; set; }
Public Property OptionsStorageLocation As UserOptions..::..StorageType
    Get
    Set
Public Property OptionsStorageLocation As UserOptions..::..StorageType
    Get
    Set
public:
property UserOptions..::..StorageType OptionsStorageLocation {
    UserOptions..::..StorageType get ();
    void set (UserOptions..::..StorageType value);
}
public:
property UserOptions..::..StorageType OptionsStorageLocation {
    UserOptions..::..StorageType get ();
    void set (UserOptions..::..StorageType value);
}
member OptionsStorageLocation : UserOptions..::..StorageType with get, set

member OptionsStorageLocation : UserOptions..::..StorageType with get, set
Property Value
UserOptions..::..StorageType


Parent Property

Keyoti RapidSpell Desktop .NET API Docs
Parent Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► Parent
Keyoti RapidSpell Desktop .NET
Gets or sets the parent of the dialog form.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Control Parent { get; set; }
public Control Parent { get; set; }
Public Property Parent As Control
    Get
    Set
Public Property Parent As Control
    Get
    Set
public:
property Control^ Parent {
    Control^ get ();
    void set (Control^ value);
}
public:
property Control^ Parent {
    Control^ get ();
    void set (Control^ value);
}
member Parent : Control with get, set

member Parent : Control with get, set
Property Value
Control


QueryTextBoxMultiline Property

Keyoti RapidSpell Desktop .NET API Docs
QueryTextBoxMultiline Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► QueryTextBoxMultiline
Keyoti RapidSpell Desktop .NET
Whether 'not in dictionary' text box is multiline or single line.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool QueryTextBoxMultiline { get; set; }
public bool QueryTextBoxMultiline { get; set; }
Public Property QueryTextBoxMultiline As Boolean
    Get
    Set
Public Property QueryTextBoxMultiline As Boolean
    Get
    Set
public:
property bool QueryTextBoxMultiline {
    bool get ();
    void set (bool value);
}
public:
property bool QueryTextBoxMultiline {
    bool get ();
    void set (bool value);
}
member QueryTextBoxMultiline : bool with get, set

member QueryTextBoxMultiline : bool with get, set
Property Value
Boolean


Ready Event

Keyoti RapidSpell Desktop .NET API Docs
Ready Event
API ► Keyoti.RapidSpell ► RapidSpellDialog ► Ready
Keyoti RapidSpell Desktop .NET
Fired when ready to proceed with first query.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler Ready
public event EventHandler Ready
Public Event Ready As EventHandler
Public Event Ready As EventHandler
public:
 event EventHandler^ Ready {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
 event EventHandler^ Ready {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member Ready : IEvent<EventHandler,
    EventArgs>

member Ready : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


RecheckDocumentRequest Event

Keyoti RapidSpell Desktop .NET API Docs
RecheckDocumentRequest Event
API ► Keyoti.RapidSpell ► RapidSpellDialog ► RecheckDocumentRequest
Keyoti RapidSpell Desktop .NET
Fired when the text should be rechecked
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler RecheckDocumentRequest
public event EventHandler RecheckDocumentRequest
Public Event RecheckDocumentRequest As EventHandler
Public Event RecheckDocumentRequest As EventHandler
public:
 event EventHandler^ RecheckDocumentRequest {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
 event EventHandler^ RecheckDocumentRequest {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member RecheckDocumentRequest : IEvent<EventHandler,
    EventArgs>

member RecheckDocumentRequest : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


RemoveAllTextComponents Method

Keyoti RapidSpell Desktop .NET API Docs
RemoveAllTextComponents Method
API ► Keyoti.RapidSpell ► RapidSpellDialog ► RemoveAllTextComponents()()()()
Keyoti RapidSpell Desktop .NET
Removes all text components from being spell checked.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void RemoveAllTextComponents()
public void RemoveAllTextComponents()
Public Sub RemoveAllTextComponents
Public Sub RemoveAllTextComponents
public:
void RemoveAllTextComponents()
public:
void RemoveAllTextComponents()
member RemoveAllTextComponents : unit -> unit

member RemoveAllTextComponents : unit -> unit


RemoveTextComponent Method

Keyoti RapidSpell Desktop .NET API Docs
RemoveTextComponent Method
API ► Keyoti.RapidSpell ► RapidSpellDialog ► RemoveTextComponent()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | RemoveTextComponent(TextBoxBase) | Removes a TextBoxBase (TextBox, RichTextBox and derivatives) to be checked.
 | RemoveTextComponent(ISpellCheckableTextComponent) | Removes an ISpellCheckableTextComponent to be checked.


RemoveTextComponent Method (textComponent)

Keyoti RapidSpell Desktop .NET API Docs
RemoveTextComponent Method (textComponent)
API ► Keyoti.RapidSpell ► RapidSpellDialog ► RemoveTextComponent(ISpellCheckableTextComponent)
Keyoti RapidSpell Desktop .NET
Removes an ISpellCheckableTextComponent to be checked.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void RemoveTextComponent(
    ISpellCheckableTextComponent textComponent
)
public virtual void RemoveTextComponent(
    ISpellCheckableTextComponent textComponent
)
Public Overridable Sub RemoveTextComponent (
    textComponent As ISpellCheckableTextComponent
)
Public Overridable Sub RemoveTextComponent (
    textComponent As ISpellCheckableTextComponent
)
public:
virtual void RemoveTextComponent(
    ISpellCheckableTextComponent^ textComponent
)
public:
virtual void RemoveTextComponent(
    ISpellCheckableTextComponent^ textComponent
)
abstract RemoveTextComponent :
        textComponent : ISpellCheckableTextComponent -> unit
override RemoveTextComponent :
        textComponent : ISpellCheckableTextComponent -> unit
abstract RemoveTextComponent :
        textComponent : ISpellCheckableTextComponent -> unit
override RemoveTextComponent :
        textComponent : ISpellCheckableTextComponent -> unit
Parameters
textComponent (ISpellCheckableTextComponent)


RemoveTextComponent Method (textBoxBase)

Keyoti RapidSpell Desktop .NET API Docs
RemoveTextComponent Method (textBoxBase)
API ► Keyoti.RapidSpell ► RapidSpellDialog ► RemoveTextComponent(TextBoxBase)
Keyoti RapidSpell Desktop .NET
Removes a TextBoxBase (TextBox, RichTextBox and derivatives) to be checked.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void RemoveTextComponent(
    TextBoxBase textBoxBase
)
public virtual void RemoveTextComponent(
    TextBoxBase textBoxBase
)
Public Overridable Sub RemoveTextComponent (
    textBoxBase As TextBoxBase
)
Public Overridable Sub RemoveTextComponent (
    textBoxBase As TextBoxBase
)
public:
virtual void RemoveTextComponent(
    TextBoxBase^ textBoxBase
)
public:
virtual void RemoveTextComponent(
    TextBoxBase^ textBoxBase
)
abstract RemoveTextComponent :
        textBoxBase : TextBoxBase -> unit
override RemoveTextComponent :
        textBoxBase : TextBoxBase -> unit
abstract RemoveTextComponent :
        textBoxBase : TextBoxBase -> unit
override RemoveTextComponent :
        textBoxBase : TextBoxBase -> unit
Parameters
textBoxBase (TextBoxBase)


ResetIgnoredWords Method

Keyoti RapidSpell Desktop .NET API Docs
ResetIgnoredWords Method
API ► Keyoti.RapidSpell ► RapidSpellDialog ► ResetIgnoredWords()()()()
Keyoti RapidSpell Desktop .NET
Resets all ignored words, so that the document will be rechecked.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void ResetIgnoredWords()
public virtual void ResetIgnoredWords()
Public Overridable Sub ResetIgnoredWords
Public Overridable Sub ResetIgnoredWords
public:
virtual void ResetIgnoredWords()
public:
virtual void ResetIgnoredWords()
abstract ResetIgnoredWords : unit -> unit
override ResetIgnoredWords : unit -> unit
abstract ResetIgnoredWords : unit -> unit
override ResetIgnoredWords : unit -> unit


SeparateHyphenWords Property

Keyoti RapidSpell Desktop .NET API Docs
SeparateHyphenWords Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► SeparateHyphenWords
Keyoti RapidSpell Desktop .NET
Whether to treat hyphenated (-) words as separate words, default is false.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool SeparateHyphenWords { get; set; }
public bool SeparateHyphenWords { get; set; }
Public Property SeparateHyphenWords As Boolean
    Get
    Set
Public Property SeparateHyphenWords As Boolean
    Get
    Set
public:
property bool SeparateHyphenWords {
    bool get ();
    void set (bool value);
}
public:
property bool SeparateHyphenWords {
    bool get ();
    void set (bool value);
}
member SeparateHyphenWords : bool with get, set

member SeparateHyphenWords : bool with get, set
Property Value
Boolean
Remarks
For eg. if this is true text like "cheap-deals" will be treated as two words "cheap" and "deals", otherwise this will be treated as one word "cheap-deals".


ShowContextSentence Property

Keyoti RapidSpell Desktop .NET API Docs
ShowContextSentence Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► ShowContextSentence
Keyoti RapidSpell Desktop .NET
Whether to show the query in context of it's sentence/line.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ShowContextSentence { get; set; }
public bool ShowContextSentence { get; set; }
Public Property ShowContextSentence As Boolean
    Get
    Set
Public Property ShowContextSentence As Boolean
    Get
    Set
public:
property bool ShowContextSentence {
    bool get ();
    void set (bool value);
}
public:
property bool ShowContextSentence {
    bool get ();
    void set (bool value);
}
member ShowContextSentence : bool with get, set

member ShowContextSentence : bool with get, set
Property Value
Boolean


ShowFinishedBoxAtEnd Property

Keyoti RapidSpell Desktop .NET API Docs
ShowFinishedBoxAtEnd Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► ShowFinishedBoxAtEnd
Keyoti RapidSpell Desktop .NET
Whether to show the spell check complete dialog box at the end, true by default.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ShowFinishedBoxAtEnd { get; set; }
public bool ShowFinishedBoxAtEnd { get; set; }
Public Property ShowFinishedBoxAtEnd As Boolean
    Get
    Set
Public Property ShowFinishedBoxAtEnd As Boolean
    Get
    Set
public:
property bool ShowFinishedBoxAtEnd {
    bool get ();
    void set (bool value);
}
public:
property bool ShowFinishedBoxAtEnd {
    bool get ();
    void set (bool value);
}
member ShowFinishedBoxAtEnd : bool with get, set

member ShowFinishedBoxAtEnd : bool with get, set
Property Value
Boolean


ShowInTaskbar Property

Keyoti RapidSpell Desktop .NET API Docs
ShowInTaskbar Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► ShowInTaskbar
Keyoti RapidSpell Desktop .NET
Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ShowInTaskbar { get; set; }
public bool ShowInTaskbar { get; set; }
Public Property ShowInTaskbar As Boolean
    Get
    Set
Public Property ShowInTaskbar As Boolean
    Get
    Set
public:
property bool ShowInTaskbar {
    bool get ();
    void set (bool value);
}
public:
property bool ShowInTaskbar {
    bool get ();
    void set (bool value);
}
member ShowInTaskbar : bool with get, set

member ShowInTaskbar : bool with get, set
Property Value
Boolean


ShowOptionForCheckAsYouType Property

Keyoti RapidSpell Desktop .NET API Docs
ShowOptionForCheckAsYouType Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► ShowOptionForCheckAsYouType
Keyoti RapidSpell Desktop .NET
Whether to show the 'check as you type' option check box in the options form.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ShowOptionForCheckAsYouType { get; set; }
public bool ShowOptionForCheckAsYouType { get; set; }
Public Property ShowOptionForCheckAsYouType As Boolean
    Get
    Set
Public Property ShowOptionForCheckAsYouType As Boolean
    Get
    Set
public:
property bool ShowOptionForCheckAsYouType {
    bool get ();
    void set (bool value);
}
public:
property bool ShowOptionForCheckAsYouType {
    bool get ();
    void set (bool value);
}
member ShowOptionForCheckAsYouType : bool with get, set

member ShowOptionForCheckAsYouType : bool with get, set
Property Value
Boolean


ShowOptionForMultipleUserDictionaries Property

Keyoti RapidSpell Desktop .NET API Docs
ShowOptionForMultipleUserDictionaries Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► ShowOptionForMultipleUserDictionaries
Keyoti RapidSpell Desktop .NET
Whether to allow the user to add/remove additional user dictionaries in the options form, the user is not permitted to remove the user dictionary assigned via code.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ShowOptionForMultipleUserDictionaries { get; set; }
public bool ShowOptionForMultipleUserDictionaries { get; set; }
Public Property ShowOptionForMultipleUserDictionaries As Boolean
    Get
    Set
Public Property ShowOptionForMultipleUserDictionaries As Boolean
    Get
    Set
public:
property bool ShowOptionForMultipleUserDictionaries {
    bool get ();
    void set (bool value);
}
public:
property bool ShowOptionForMultipleUserDictionaries {
    bool get ();
    void set (bool value);
}
member ShowOptionForMultipleUserDictionaries : bool with get, set

member ShowOptionForMultipleUserDictionaries : bool with get, set
Property Value
Boolean


ShowOptionsButton Property

Keyoti RapidSpell Desktop .NET API Docs
ShowOptionsButton Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► ShowOptionsButton
Keyoti RapidSpell Desktop .NET
Whether to show the options button.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ShowOptionsButton { get; set; }
public bool ShowOptionsButton { get; set; }
Public Property ShowOptionsButton As Boolean
    Get
    Set
Public Property ShowOptionsButton As Boolean
    Get
    Set
public:
property bool ShowOptionsButton {
    bool get ();
    void set (bool value);
}
public:
property bool ShowOptionsButton {
    bool get ();
    void set (bool value);
}
member ShowOptionsButton : bool with get, set

member ShowOptionsButton : bool with get, set
Property Value
Boolean


ShowUndoButton Property

Keyoti RapidSpell Desktop .NET API Docs
ShowUndoButton Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► ShowUndoButton
Keyoti RapidSpell Desktop .NET
Whether to show the undo button.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ShowUndoButton { get; set; }
public bool ShowUndoButton { get; set; }
Public Property ShowUndoButton As Boolean
    Get
    Set
Public Property ShowUndoButton As Boolean
    Get
    Set
public:
property bool ShowUndoButton {
    bool get ();
    void set (bool value);
}
public:
property bool ShowUndoButton {
    bool get ();
    void set (bool value);
}
member ShowUndoButton : bool with get, set

member ShowUndoButton : bool with get, set
Property Value
Boolean


SizeGripStyle Property

Keyoti RapidSpell Desktop .NET API Docs
SizeGripStyle Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► SizeGripStyle
Keyoti RapidSpell Desktop .NET
Style of the size grip to display in the lower-right corner of the form
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public SizeGripStyle SizeGripStyle { get; set; }
public SizeGripStyle SizeGripStyle { get; set; }
Public Property SizeGripStyle As SizeGripStyle
    Get
    Set
Public Property SizeGripStyle As SizeGripStyle
    Get
    Set
public:
property SizeGripStyle SizeGripStyle {
    SizeGripStyle get ();
    void set (SizeGripStyle value);
}
public:
property SizeGripStyle SizeGripStyle {
    SizeGripStyle get ();
    void set (SizeGripStyle value);
}
member SizeGripStyle : SizeGripStyle with get, set

member SizeGripStyle : SizeGripStyle with get, set
Property Value
SizeGripStyle


SpellCheckFinished Event

Keyoti RapidSpell Desktop .NET API Docs
SpellCheckFinished Event
API ► Keyoti.RapidSpell ► RapidSpellDialog ► SpellCheckFinished
Keyoti RapidSpell Desktop .NET
Fired when checking finishes
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event RapidSpellDialog..::..SpellCheckEventHandler SpellCheckFinished
public event RapidSpellDialog..::..SpellCheckEventHandler SpellCheckFinished
Public Event SpellCheckFinished As RapidSpellDialog..::..SpellCheckEventHandler
Public Event SpellCheckFinished As RapidSpellDialog..::..SpellCheckEventHandler
public:
 event RapidSpellDialog..::..SpellCheckEventHandler^ SpellCheckFinished {
    void add (RapidSpellDialog..::..SpellCheckEventHandler^ value);
    void remove (RapidSpellDialog..::..SpellCheckEventHandler^ value);
}
public:
 event RapidSpellDialog..::..SpellCheckEventHandler^ SpellCheckFinished {
    void add (RapidSpellDialog..::..SpellCheckEventHandler^ value);
    void remove (RapidSpellDialog..::..SpellCheckEventHandler^ value);
}
member SpellCheckFinished : IEvent<RapidSpellDialog..::..SpellCheckEventHandler,
    SpellCheckEventArgs>

member SpellCheckFinished : IEvent<RapidSpellDialog..::..SpellCheckEventHandler,
    SpellCheckEventArgs>
Value
RapidSpellDialog..::..SpellCheckEventHandler


SpellCheckFinishedTextBox Event

Keyoti RapidSpell Desktop .NET API Docs
SpellCheckFinishedTextBox Event
API ► Keyoti.RapidSpell ► RapidSpellDialog ► SpellCheckFinishedTextBox
Keyoti RapidSpell Desktop .NET
Fired when spell check starts on a text box (used in multiple text box checking situations)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event RapidSpellDialog..::..TextBoxSpellCheckEventHandler SpellCheckFinishedTextBox
public event RapidSpellDialog..::..TextBoxSpellCheckEventHandler SpellCheckFinishedTextBox
Public Event SpellCheckFinishedTextBox As RapidSpellDialog..::..TextBoxSpellCheckEventHandler
Public Event SpellCheckFinishedTextBox As RapidSpellDialog..::..TextBoxSpellCheckEventHandler
public:
 event RapidSpellDialog..::..TextBoxSpellCheckEventHandler^ SpellCheckFinishedTextBox {
    void add (RapidSpellDialog..::..TextBoxSpellCheckEventHandler^ value);
    void remove (RapidSpellDialog..::..TextBoxSpellCheckEventHandler^ value);
}
public:
 event RapidSpellDialog..::..TextBoxSpellCheckEventHandler^ SpellCheckFinishedTextBox {
    void add (RapidSpellDialog..::..TextBoxSpellCheckEventHandler^ value);
    void remove (RapidSpellDialog..::..TextBoxSpellCheckEventHandler^ value);
}
member SpellCheckFinishedTextBox : IEvent<RapidSpellDialog..::..TextBoxSpellCheckEventHandler,
    TextBoxSpellCheckEventArgs>

member SpellCheckFinishedTextBox : IEvent<RapidSpellDialog..::..TextBoxSpellCheckEventHandler,
    TextBoxSpellCheckEventArgs>
Value
RapidSpellDialog..::..TextBoxSpellCheckEventHandler


SpellCheckStarted Event

Keyoti RapidSpell Desktop .NET API Docs
SpellCheckStarted Event
API ► Keyoti.RapidSpell ► RapidSpellDialog ► SpellCheckStarted
Keyoti RapidSpell Desktop .NET
Fired when checking starts
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event RapidSpellDialog..::..SpellCheckEventHandler SpellCheckStarted
public event RapidSpellDialog..::..SpellCheckEventHandler SpellCheckStarted
Public Event SpellCheckStarted As RapidSpellDialog..::..SpellCheckEventHandler
Public Event SpellCheckStarted As RapidSpellDialog..::..SpellCheckEventHandler
public:
 event RapidSpellDialog..::..SpellCheckEventHandler^ SpellCheckStarted {
    void add (RapidSpellDialog..::..SpellCheckEventHandler^ value);
    void remove (RapidSpellDialog..::..SpellCheckEventHandler^ value);
}
public:
 event RapidSpellDialog..::..SpellCheckEventHandler^ SpellCheckStarted {
    void add (RapidSpellDialog..::..SpellCheckEventHandler^ value);
    void remove (RapidSpellDialog..::..SpellCheckEventHandler^ value);
}
member SpellCheckStarted : IEvent<RapidSpellDialog..::..SpellCheckEventHandler,
    SpellCheckEventArgs>

member SpellCheckStarted : IEvent<RapidSpellDialog..::..SpellCheckEventHandler,
    SpellCheckEventArgs>
Value
RapidSpellDialog..::..SpellCheckEventHandler


SpellCheckStartedTextBox Event

Keyoti RapidSpell Desktop .NET API Docs
SpellCheckStartedTextBox Event
API ► Keyoti.RapidSpell ► RapidSpellDialog ► SpellCheckStartedTextBox
Keyoti RapidSpell Desktop .NET
Fired when spell check starts on a text box (used in multiple text box checking situations)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event RapidSpellDialog..::..TextBoxSpellCheckEventHandler SpellCheckStartedTextBox
public event RapidSpellDialog..::..TextBoxSpellCheckEventHandler SpellCheckStartedTextBox
Public Event SpellCheckStartedTextBox As RapidSpellDialog..::..TextBoxSpellCheckEventHandler
Public Event SpellCheckStartedTextBox As RapidSpellDialog..::..TextBoxSpellCheckEventHandler
public:
 event RapidSpellDialog..::..TextBoxSpellCheckEventHandler^ SpellCheckStartedTextBox {
    void add (RapidSpellDialog..::..TextBoxSpellCheckEventHandler^ value);
    void remove (RapidSpellDialog..::..TextBoxSpellCheckEventHandler^ value);
}
public:
 event RapidSpellDialog..::..TextBoxSpellCheckEventHandler^ SpellCheckStartedTextBox {
    void add (RapidSpellDialog..::..TextBoxSpellCheckEventHandler^ value);
    void remove (RapidSpellDialog..::..TextBoxSpellCheckEventHandler^ value);
}
member SpellCheckStartedTextBox : IEvent<RapidSpellDialog..::..TextBoxSpellCheckEventHandler,
    TextBoxSpellCheckEventArgs>

member SpellCheckStartedTextBox : IEvent<RapidSpellDialog..::..TextBoxSpellCheckEventHandler,
    TextBoxSpellCheckEventArgs>
Value
RapidSpellDialog..::..TextBoxSpellCheckEventHandler


StartPosition Property

Keyoti RapidSpell Desktop .NET API Docs
StartPosition Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► StartPosition
Keyoti RapidSpell Desktop .NET
Gets or sets the starting position of the form at run time
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public FormStartPosition StartPosition { get; set; }
public FormStartPosition StartPosition { get; set; }
Public Property StartPosition As FormStartPosition
    Get
    Set
Public Property StartPosition As FormStartPosition
    Get
    Set
public:
property FormStartPosition StartPosition {
    FormStartPosition get ();
    void set (FormStartPosition value);
}
public:
property FormStartPosition StartPosition {
    FormStartPosition get ();
    void set (FormStartPosition value);
}
member StartPosition : FormStartPosition with get, set

member StartPosition : FormStartPosition with get, set
Property Value
FormStartPosition


SuggestionsMethod Property

Keyoti RapidSpell Desktop .NET API Docs
SuggestionsMethod Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► SuggestionsMethod
Keyoti RapidSpell Desktop .NET
The suggestions method to use.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public SuggestionsMethodType SuggestionsMethod { get; set; }
public SuggestionsMethodType SuggestionsMethod { get; set; }
Public Property SuggestionsMethod As SuggestionsMethodType
    Get
    Set
Public Property SuggestionsMethod As SuggestionsMethodType
    Get
    Set
public:
property SuggestionsMethodType SuggestionsMethod {
    SuggestionsMethodType get ();
    void set (SuggestionsMethodType value);
}
public:
property SuggestionsMethodType SuggestionsMethod {
    SuggestionsMethodType get ();
    void set (SuggestionsMethodType value);
}
member SuggestionsMethod : SuggestionsMethodType with get, set

member SuggestionsMethod : SuggestionsMethodType with get, set
Property Value
SuggestionsMethodType


SuggestSplitWords Property

Keyoti RapidSpell Desktop .NET API Docs
SuggestSplitWords Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► SuggestSplitWords
Keyoti RapidSpell Desktop .NET
Whether to look for connected words in suggestions.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool SuggestSplitWords { get; set; }
public bool SuggestSplitWords { get; set; }
Public Property SuggestSplitWords As Boolean
    Get
    Set
Public Property SuggestSplitWords As Boolean
    Get
    Set
public:
property bool SuggestSplitWords {
    bool get ();
    void set (bool value);
}
public:
property bool SuggestSplitWords {
    bool get ();
    void set (bool value);
}
member SuggestSplitWords : bool with get, set

member SuggestSplitWords : bool with get, set
Property Value
Boolean
Remarks
if this=true then suggestions may include joined words.

Eg; suggestions for "myhouse" will include "my house"


TextBoxBasesToCheck Property

Keyoti RapidSpell Desktop .NET API Docs
TextBoxBasesToCheck Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► TextBoxBasesToCheck
Keyoti RapidSpell Desktop .NET
Array of TextBoxBases this GUI will spell check.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public TextBoxBase[] TextBoxBasesToCheck { get; set; }
public TextBoxBase[] TextBoxBasesToCheck { get; set; }
Public Property TextBoxBasesToCheck As TextBoxBase()
    Get
    Set
Public Property TextBoxBasesToCheck As TextBoxBase()
    Get
    Set
public:
property array<TextBoxBase^>^ TextBoxBasesToCheck {
    array<TextBoxBase^>^ get ();
    void set (array<TextBoxBase^>^ value);
}
public:
property array<TextBoxBase^>^ TextBoxBasesToCheck {
    array<TextBoxBase^>^ get ();
    void set (array<TextBoxBase^>^ value);
}
member TextBoxBasesToCheck : TextBoxBase[] with get, set

member TextBoxBasesToCheck : TextBoxBase[] with get, set
Property Value
array< TextBoxBase >[]()[][]


TextBoxBaseToCheck Property

Keyoti RapidSpell Desktop .NET API Docs
TextBoxBaseToCheck Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► TextBoxBaseToCheck
Keyoti RapidSpell Desktop .NET
The TextBoxBase (eg; TextBox etc) that this GUI will spell check.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public TextBoxBase TextBoxBaseToCheck { get; set; }
public TextBoxBase TextBoxBaseToCheck { get; set; }
Public Property TextBoxBaseToCheck As TextBoxBase
    Get
    Set
Public Property TextBoxBaseToCheck As TextBoxBase
    Get
    Set
public:
property TextBoxBase^ TextBoxBaseToCheck {
    TextBoxBase^ get ();
    void set (TextBoxBase^ value);
}
public:
property TextBoxBase^ TextBoxBaseToCheck {
    TextBoxBase^ get ();
    void set (TextBoxBase^ value);
}
member TextBoxBaseToCheck : TextBoxBase with get, set

member TextBoxBaseToCheck : TextBoxBase with get, set
Property Value
TextBoxBase


Texts Property

Keyoti RapidSpell Desktop .NET API Docs
Texts Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► Texts
Keyoti RapidSpell Desktop .NET
The UI texts.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public DialogTexts Texts { get; set; }
public DialogTexts Texts { get; set; }
Public Property Texts As DialogTexts
    Get
    Set
Public Property Texts As DialogTexts
    Get
    Set
public:
property DialogTexts^ Texts {
    DialogTexts^ get ();
    void set (DialogTexts^ value);
}
public:
property DialogTexts^ Texts {
    DialogTexts^ get ();
    void set (DialogTexts^ value);
}
member Texts : DialogTexts with get, set

member Texts : DialogTexts with get, set
Property Value
DialogTexts


ThirdPartyTextComponentsToCheck Property

Keyoti RapidSpell Desktop .NET API Docs
ThirdPartyTextComponentsToCheck Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► ThirdPartyTextComponentsToCheck
Keyoti RapidSpell Desktop .NET
Array of ISpellCheckableTextComponent this GUI will spell check.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ISpellCheckableTextComponent[] ThirdPartyTextComponentsToCheck { get; set; }
public ISpellCheckableTextComponent[] ThirdPartyTextComponentsToCheck { get; set; }
Public Property ThirdPartyTextComponentsToCheck As ISpellCheckableTextComponent()
    Get
    Set
Public Property ThirdPartyTextComponentsToCheck As ISpellCheckableTextComponent()
    Get
    Set
public:
property array<ISpellCheckableTextComponent^>^ ThirdPartyTextComponentsToCheck {
    array<ISpellCheckableTextComponent^>^ get ();
    void set (array<ISpellCheckableTextComponent^>^ value);
}
public:
property array<ISpellCheckableTextComponent^>^ ThirdPartyTextComponentsToCheck {
    array<ISpellCheckableTextComponent^>^ get ();
    void set (array<ISpellCheckableTextComponent^>^ value);
}
member ThirdPartyTextComponentsToCheck : ISpellCheckableTextComponent[] with get, set

member ThirdPartyTextComponentsToCheck : ISpellCheckableTextComponent[] with get, set
Property Value
array< ISpellCheckableTextComponent >[]()[][]


ThirdPartyTextComponentToCheck Property

Keyoti RapidSpell Desktop .NET API Docs
ThirdPartyTextComponentToCheck Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► ThirdPartyTextComponentToCheck
Keyoti RapidSpell Desktop .NET
The 3rd Party Component that this GUI will spell check.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ISpellCheckableTextComponent ThirdPartyTextComponentToCheck { get; set; }
public ISpellCheckableTextComponent ThirdPartyTextComponentToCheck { get; set; }
Public Property ThirdPartyTextComponentToCheck As ISpellCheckableTextComponent
    Get
    Set
Public Property ThirdPartyTextComponentToCheck As ISpellCheckableTextComponent
    Get
    Set
public:
property ISpellCheckableTextComponent^ ThirdPartyTextComponentToCheck {
    ISpellCheckableTextComponent^ get ();
    void set (ISpellCheckableTextComponent^ value);
}
public:
property ISpellCheckableTextComponent^ ThirdPartyTextComponentToCheck {
    ISpellCheckableTextComponent^ get ();
    void set (ISpellCheckableTextComponent^ value);
}
member ThirdPartyTextComponentToCheck : ISpellCheckableTextComponent with get, set

member ThirdPartyTextComponentToCheck : ISpellCheckableTextComponent with get, set
Property Value
ISpellCheckableTextComponent


TopLevel Property

Keyoti RapidSpell Desktop .NET API Docs
TopLevel Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► TopLevel
Keyoti RapidSpell Desktop .NET
Whether to display the form as a top-level window.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool TopLevel { get; set; }
public bool TopLevel { get; set; }
Public Property TopLevel As Boolean
    Get
    Set
Public Property TopLevel As Boolean
    Get
    Set
public:
property bool TopLevel {
    bool get ();
    void set (bool value);
}
public:
property bool TopLevel {
    bool get ();
    void set (bool value);
}
member TopLevel : bool with get, set

member TopLevel : bool with get, set
Property Value
Boolean


TopMost Property

Keyoti RapidSpell Desktop .NET API Docs
TopMost Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► TopMost
Keyoti RapidSpell Desktop .NET
Whether the form is 'always on top'.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool TopMost { get; set; }
public bool TopMost { get; set; }
Public Property TopMost As Boolean
    Get
    Set
Public Property TopMost As Boolean
    Get
    Set
public:
property bool TopMost {
    bool get ();
    void set (bool value);
}
public:
property bool TopMost {
    bool get ();
    void set (bool value);
}
member TopMost : bool with get, set

member TopMost : bool with get, set
Property Value
Boolean


Undone Event

Keyoti RapidSpell Desktop .NET API Docs
Undone Event
API ► Keyoti.RapidSpell ► RapidSpellDialog ► Undone
Keyoti RapidSpell Desktop .NET
Fired when an Undo occurs
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event UndoEventHandler Undone
public event UndoEventHandler Undone
Public Event Undone As UndoEventHandler
Public Event Undone As UndoEventHandler
public:
 event UndoEventHandler^ Undone {
    void add (UndoEventHandler^ value);
    void remove (UndoEventHandler^ value);
}
public:
 event UndoEventHandler^ Undone {
    void add (UndoEventHandler^ value);
    void remove (UndoEventHandler^ value);
}
member Undone : IEvent<UndoEventHandler,
    UndoEventArgs>

member Undone : IEvent<UndoEventHandler,
    UndoEventArgs>
Value
UndoEventHandler


UserDictionaryFile Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionaryFile Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► UserDictionaryFile
Keyoti RapidSpell Desktop .NET
The user dictionary file, if this file doesn't exist it will be created.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionaryFile { get; set; }
public string UserDictionaryFile { get; set; }
Public Property UserDictionaryFile As String
    Get
    Set
Public Property UserDictionaryFile As String
    Get
    Set
public:
property String^ UserDictionaryFile {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserDictionaryFile {
    String^ get ();
    void set (String^ value);
}
member UserDictionaryFile : string with get, set

member UserDictionaryFile : string with get, set
Property Value
String
Remarks
Use of a user dictionary is optional.


UserInterfaceFormPresenter Property

Keyoti RapidSpell Desktop .NET API Docs
UserInterfaceFormPresenter Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► UserInterfaceFormPresenter
Keyoti RapidSpell Desktop .NET
The presenter (eg. RapidSpellGUIPresenter) currently in use, may be null/Nothing if not created yet.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public IUserInterfaceFormPresenter UserInterfaceFormPresenter { get; }
public IUserInterfaceFormPresenter UserInterfaceFormPresenter { get; }
Public ReadOnly Property UserInterfaceFormPresenter As IUserInterfaceFormPresenter
    Get
Public ReadOnly Property UserInterfaceFormPresenter As IUserInterfaceFormPresenter
    Get
public:
property IUserInterfaceFormPresenter^ UserInterfaceFormPresenter {
    IUserInterfaceFormPresenter^ get ();
}
public:
property IUserInterfaceFormPresenter^ UserInterfaceFormPresenter {
    IUserInterfaceFormPresenter^ get ();
}
member UserInterfaceFormPresenter : IUserInterfaceFormPresenter with get

member UserInterfaceFormPresenter : IUserInterfaceFormPresenter with get
Property Value
IUserInterfaceFormPresenter


UserQuery Event

Keyoti RapidSpell Desktop .NET API Docs
UserQuery Event
API ► Keyoti.RapidSpell ► RapidSpellDialog ► UserQuery
Keyoti RapidSpell Desktop .NET
Indicates that the user is being queried on a spelling error.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event UserQueryEventHandler UserQuery
public event UserQueryEventHandler UserQuery
Public Event UserQuery As UserQueryEventHandler
Public Event UserQuery As UserQueryEventHandler
public:
 event UserQueryEventHandler^ UserQuery {
    void add (UserQueryEventHandler^ value);
    void remove (UserQueryEventHandler^ value);
}
public:
 event UserQueryEventHandler^ UserQuery {
    void add (UserQueryEventHandler^ value);
    void remove (UserQueryEventHandler^ value);
}
member UserQuery : IEvent<UserQueryEventHandler,
    UserQueryEventArgs>

member UserQuery : IEvent<UserQueryEventHandler,
    UserQueryEventArgs>
Value
UserQueryEventHandler


V2Parser Property

Keyoti RapidSpell Desktop .NET API Docs
V2Parser Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► V2Parser
Keyoti RapidSpell Desktop .NET
Whether to use parser version 2 - Set to false for backwards (pre v3.4) compatibility.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool V2Parser { get; set; }
public bool V2Parser { get; set; }
Public Property V2Parser As Boolean
    Get
    Set
Public Property V2Parser As Boolean
    Get
    Set
public:
property bool V2Parser {
    bool get ();
    void set (bool value);
}
public:
property bool V2Parser {
    bool get ();
    void set (bool value);
}
member V2Parser : bool with get, set

member V2Parser : bool with get, set
Property Value
Boolean


WarnDuplicates Property

Keyoti RapidSpell Desktop .NET API Docs
WarnDuplicates Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► WarnDuplicates
Keyoti RapidSpell Desktop .NET
Whether to show duplicate words as errors (eg. "this is is an error").
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool WarnDuplicates { get; set; }
public bool WarnDuplicates { get; set; }
Public Property WarnDuplicates As Boolean
    Get
    Set
Public Property WarnDuplicates As Boolean
    Get
    Set
public:
property bool WarnDuplicates {
    bool get ();
    void set (bool value);
}
public:
property bool WarnDuplicates {
    bool get ();
    void set (bool value);
}
member WarnDuplicates : bool with get, set

member WarnDuplicates : bool with get, set
Property Value
Boolean


WordAdded Event

Keyoti RapidSpell Desktop .NET API Docs
WordAdded Event
API ► Keyoti.RapidSpell ► RapidSpellDialog ► WordAdded
Keyoti RapidSpell Desktop .NET
Fired when word added to user dictionary
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event WordAddedEventHandler WordAdded
public event WordAddedEventHandler WordAdded
Public Event WordAdded As WordAddedEventHandler
Public Event WordAdded As WordAddedEventHandler
public:
 event WordAddedEventHandler^ WordAdded {
    void add (WordAddedEventHandler^ value);
    void remove (WordAddedEventHandler^ value);
}
public:
 event WordAddedEventHandler^ WordAdded {
    void add (WordAddedEventHandler^ value);
    void remove (WordAddedEventHandler^ value);
}
member WordAdded : IEvent<WordAddedEventHandler,
    WordAddedEventArgs>

member WordAdded : IEvent<WordAddedEventHandler,
    WordAddedEventArgs>
Value
WordAddedEventHandler


WordChanged Event

Keyoti RapidSpell Desktop .NET API Docs
WordChanged Event
API ► Keyoti.RapidSpell ► RapidSpellDialog ► WordChanged
Keyoti RapidSpell Desktop .NET
Fired when a word is changed
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event WordChangedEventHandler WordChanged
public event WordChangedEventHandler WordChanged
Public Event WordChanged As WordChangedEventHandler
Public Event WordChanged As WordChangedEventHandler
public:
 event WordChangedEventHandler^ WordChanged {
    void add (WordChangedEventHandler^ value);
    void remove (WordChangedEventHandler^ value);
}
public:
 event WordChangedEventHandler^ WordChanged {
    void add (WordChangedEventHandler^ value);
    void remove (WordChangedEventHandler^ value);
}
member WordChanged : IEvent<WordChangedEventHandler,
    WordChangedEventArgs>

member WordChanged : IEvent<WordChangedEventHandler,
    WordChangedEventArgs>
Value
WordChangedEventHandler


WordChanging Event

Keyoti RapidSpell Desktop .NET API Docs
WordChanging Event
API ► Keyoti.RapidSpell ► RapidSpellDialog ► WordChanging
Keyoti RapidSpell Desktop .NET
Fired before a word is changed
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event WordChangedEventHandler WordChanging
public event WordChangedEventHandler WordChanging
Public Event WordChanging As WordChangedEventHandler
Public Event WordChanging As WordChangedEventHandler
public:
 event WordChangedEventHandler^ WordChanging {
    void add (WordChangedEventHandler^ value);
    void remove (WordChangedEventHandler^ value);
}
public:
 event WordChangedEventHandler^ WordChanging {
    void add (WordChangedEventHandler^ value);
    void remove (WordChangedEventHandler^ value);
}
member WordChanging : IEvent<WordChangedEventHandler,
    WordChangedEventArgs>

member WordChanging : IEvent<WordChangedEventHandler,
    WordChangedEventArgs>
Value
WordChangedEventHandler


WordIgnored Event

Keyoti RapidSpell Desktop .NET API Docs
WordIgnored Event
API ► Keyoti.RapidSpell ► RapidSpellDialog ► WordIgnored
Keyoti RapidSpell Desktop .NET
Fired when word ignored
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event WordIgnoredEventHandler WordIgnored
public event WordIgnoredEventHandler WordIgnored
Public Event WordIgnored As WordIgnoredEventHandler
Public Event WordIgnored As WordIgnoredEventHandler
public:
 event WordIgnoredEventHandler^ WordIgnored {
    void add (WordIgnoredEventHandler^ value);
    void remove (WordIgnoredEventHandler^ value);
}
public:
 event WordIgnoredEventHandler^ WordIgnored {
    void add (WordIgnoredEventHandler^ value);
    void remove (WordIgnoredEventHandler^ value);
}
member WordIgnored : IEvent<WordIgnoredEventHandler,
    WordIgnoredEventArgs>

member WordIgnored : IEvent<WordIgnoredEventHandler,
    WordIgnoredEventArgs>
Value
WordIgnoredEventHandler


WordRemoved Event

Keyoti RapidSpell Desktop .NET API Docs
WordRemoved Event
API ► Keyoti.RapidSpell ► RapidSpellDialog ► WordRemoved
Keyoti RapidSpell Desktop .NET
Fired when a word is removed from user dictionary.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event WordRemovedEventHandler WordRemoved
public event WordRemovedEventHandler WordRemoved
Public Event WordRemoved As WordRemovedEventHandler
Public Event WordRemoved As WordRemovedEventHandler
public:
 event WordRemovedEventHandler^ WordRemoved {
    void add (WordRemovedEventHandler^ value);
    void remove (WordRemovedEventHandler^ value);
}
public:
 event WordRemovedEventHandler^ WordRemoved {
    void add (WordRemovedEventHandler^ value);
    void remove (WordRemovedEventHandler^ value);
}
member WordRemoved : IEvent<WordRemovedEventHandler,
    WordRemovedEventArgs>

member WordRemoved : IEvent<WordRemovedEventHandler,
    WordRemovedEventArgs>
Value
WordRemovedEventHandler


RapidSpellDialog.SpellCheckEventHandler Delegate

Keyoti RapidSpell Desktop .NET API Docs
RapidSpellDialog..::..SpellCheckEventHandler Delegate
API ► Keyoti.RapidSpell ► RapidSpellDialog ► RapidSpellDialog..::..SpellCheckEventHandler
Keyoti RapidSpell Desktop .NET
Spell check event handler delegate.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void SpellCheckEventHandler(
    Object sender,
    SpellCheckEventArgs e
)
public delegate void SpellCheckEventHandler(
    Object sender,
    SpellCheckEventArgs e
)
Public Delegate Sub SpellCheckEventHandler (
    sender As Object,
    e As SpellCheckEventArgs
)
Public Delegate Sub SpellCheckEventHandler (
    sender As Object,
    e As SpellCheckEventArgs
)
public delegate void SpellCheckEventHandler(
    Object^ sender,
    SpellCheckEventArgs^ e
)
public delegate void SpellCheckEventHandler(
    Object^ sender,
    SpellCheckEventArgs^ e
)
type SpellCheckEventHandler =
    delegate of
        sender : Object *
        e : SpellCheckEventArgs -> unit
type SpellCheckEventHandler =
    delegate of
        sender : Object *
        e : SpellCheckEventArgs -> unit
Parameters
sender (Object)
e (SpellCheckEventArgs)


RapidSpellDialog.TextBoxSpellCheckEventHandler Delegate

Keyoti RapidSpell Desktop .NET API Docs
RapidSpellDialog..::..TextBoxSpellCheckEventHandler Delegate
API ► Keyoti.RapidSpell ► RapidSpellDialog ► RapidSpellDialog..::..TextBoxSpellCheckEventHandler
Keyoti RapidSpell Desktop .NET
Handler delegate
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void TextBoxSpellCheckEventHandler(
    Object sender,
    TextBoxSpellCheckEventArgs e
)
public delegate void TextBoxSpellCheckEventHandler(
    Object sender,
    TextBoxSpellCheckEventArgs e
)
Public Delegate Sub TextBoxSpellCheckEventHandler (
    sender As Object,
    e As TextBoxSpellCheckEventArgs
)
Public Delegate Sub TextBoxSpellCheckEventHandler (
    sender As Object,
    e As TextBoxSpellCheckEventArgs
)
public delegate void TextBoxSpellCheckEventHandler(
    Object^ sender,
    TextBoxSpellCheckEventArgs^ e
)
public delegate void TextBoxSpellCheckEventHandler(
    Object^ sender,
    TextBoxSpellCheckEventArgs^ e
)
type TextBoxSpellCheckEventHandler =
    delegate of
        sender : Object *
        e : TextBoxSpellCheckEventArgs -> unit
type TextBoxSpellCheckEventHandler =
    delegate of
        sender : Object *
        e : TextBoxSpellCheckEventArgs -> unit
Parameters
sender (Object)
e (TextBoxSpellCheckEventArgs)


RapidSpellGUIPresenter Class

Keyoti RapidSpell Desktop .NET API Docs
RapidSpellGUIPresenter Class
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter
Keyoti RapidSpell Desktop .NET
Controls the UI logic used for RapidSpellDialog forms.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class RapidSpellGUIPresenter : Component,
    IUserInterfaceFormPresenter, IDialogViewEventHandler
public class RapidSpellGUIPresenter : Component,
    IUserInterfaceFormPresenter, IDialogViewEventHandler
Public Class RapidSpellGUIPresenter
    Inherits Component
    Implements IUserInterfaceFormPresenter, IDialogViewEventHandler
Public Class RapidSpellGUIPresenter
    Inherits Component
    Implements IUserInterfaceFormPresenter, IDialogViewEventHandler
public ref class RapidSpellGUIPresenter : public Component,
    IUserInterfaceFormPresenter, IDialogViewEventHandler
public ref class RapidSpellGUIPresenter : public Component,
    IUserInterfaceFormPresenter, IDialogViewEventHandler
type RapidSpellGUIPresenter =
    class
        inherit Component
        interface IUserInterfaceFormPresenter
        interface IDialogViewEventHandler
    end
type RapidSpellGUIPresenter =
    class
        inherit Component
        interface IUserInterfaceFormPresenter
        interface IDialogViewEventHandler
    end
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RapidSpellGUIPresenter()()()() | Construct this GUI component - this will NOT open a new Form, call Check to do that.
 | ActionPerformed(Object, EventArgs) | Obsolete. Listen to GUI events and perform actions depending on the button sending the event.
 | active | The state of this GUI. It can be either active (user is using it) or inactive (user focus is elsewhere).
 | AddButtonText | Add button text.
 | AddWord()()()() | Adds the current bad word to the user dictionary.
 | AllOperationScope | The scope that ignore-all/change-all should have.
 | CancelActionPerformed(Object, CancelEventArgs) | Obsolete. Listen to GUI events and perform actions depending on the button sending the event.
 | CancelButtonText | Cancel button text.
 | Cancelled | Whether the spell check has been cancelled.
 | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
 | ChangeAll()()()() | Called when user wants to change all instances of current bad word to selected word
 | ChangeAllButtonText | Change All button text.
 | ChangeButtonText | Change button text.
 | ChangeWord()()()() | User wants to change current bad word to selected word
 | Check()()()() | Bring up the spell checker Form and start checking the component set by SetTextComponentToCheck.
 | Check(TextBoxBase) | Bring up the spell checker Form and start checking the TextBoxBase textComponent.
 | Check(ISpellCheckableTextComponent) | Bring up the spell checker Form and start checking the TextBoxBase textComponent.
 | CheckCompletePopUpText | Check complete pop up text
 | CheckCompletePopUpTitle | Check complete pop up title
 | CheckCompoundWords | Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
 | CheckerEngine | The checker engine to use, this object must implement the ICheckerEngine interface, allows customization or replacement of the spell checker.
 | CheckFromStartOfText | Whether to check from the start of the text (true) or whereever the cursor is (false)
 | checkingSelection | The state of this GUI. It can be either active (user is using it) or inactive (user focus is elsewhere).
 | CheckingSpellingText | Checking spelling text
 | Close()()()() | Closes the form if open.
 | ConsiderationRange | The factor for words to consider for suggestions, lower values are faster but consider less words for suggestions. Default is 80. If w <= 1 this method won't do anything.
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | CreateDialogView | Indicates that a new IDialogView has been created, also provides chance to override the default IDialogView.
 | CreateDialogViewOptions | Indicates that a new IDialogViewOptions is being created, also provides chance to override the default IDialogViewOptions.
 | CreateDialogViewUserDictionaryEdit | Indicates that a new IDialogViewUserDictionaryEdit is being created, also provides chance to override the default IDialogViewUserDictionaryEdit.
 | CreateDialogViewUserDictionarySelect | Indicates that a new IDialogViewUserDictionarySelect is being created, also provides chance to override the default IDialogViewUserDictionarySelect.
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | DialogTitleText | Dialog title text
 | DialogView | The IDialogView instance to use for the UI.
 | DialogView_AddButtonClick(Object, EventArgs) | Handles IDialogView event
 | DialogView_CancelButtonClick(Object, EventArgs) | Handles IDialogView event
 | DialogView_ChangeAllButtonClick(Object, EventArgs) | Handles IDialogView event
 | DialogView_ChangeButtonClick(Object, EventArgs) | Handles IDialogView event
 | DialogView_Closing(Object, CancelEventArgs) | Handles IDialogView event
 | DialogView_IgnoreAllButtonClick(Object, EventArgs) | Handles IDialogView event
 | DialogView_IgnoreButtonClick(Object, EventArgs) | Handles IDialogView event
 | DialogView_Load(Object, EventArgs) | Handles IDialogView event
 | DialogView_OptionsButtonClick(Object, EventArgs) | Handles IDialogView event
 | DialogView_QueryTextBoxEnter(Object, EventArgs) | Handles IDialogView event
 | DialogView_QueryTextBoxTextChanged(Object, EventArgs) | Handles IDialogView event
 | DialogView_SuggestionsListDoubleClick(Object, EventArgs) | Handles IDialogView event
 | DialogView_UndoButtonClick(Object, EventArgs) | Handles the Undo button click
 | DialogView_UserNeedsSuggestionsChanged(Object, EventArgs) | Handles IDialogView event
 | DialogViewOptionsPresenter_CreateDialogViewOptions(Object, CreateDialogViewOptionsEventArgs) | Handles IDialogView event
 | DialogViewOptionsPresenter_CreateDialogViewUserDictionaryEdit(Object, CreateDialogViewUserDictionaryEditEventArgs) | Handles IDialogView event
 | DialogViewOptionsPresenter_CreateDialogViewUserDictionarySelect(Object, CreateDialogViewUserDictionarySelectEventArgs) | Handles IDialogView event
 | DictFilePath | Optional file path to the main dictionary .dict file to use.
 | Dispose()()()() | Disposes of resources
 | Dispose(Boolean) | Frees up resources (Overrides Component.Dispose(Boolean).)
 | DisposeAtEnd | Whether to dispose of this form when spell check is finished.
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
 | End()()()() | Called when finished checking document, brings up spelling check is complete message.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | Finalize()()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | FindCapitalizedSuggestions | Whether to look for capitalized suggestions, note this will slow FindSuggestions down by about 7 times.
 | FindingSuggestionsLabelText | Finding suggestions label text.
 | findSuggestions | Whether this should look up suggestions for misspelt words or not.
 | FindSuggestionsLabelText | Find suggestions label text.
 | FindWordEnd(Int32) | Returns the end of the word that fromPos is in.
 | FinishedCheckingSelectionPopUpText | Finished checking selection dialog text
 | FinishedCheckingSelectionPopUpTitle | Finished checking selection dialog title
 | FocusGained(Object, EventArgs) | Called when objects whose focus this is listening to gain focus.
 | fromPosition | Where the user wants to check from in the document
 | GenerateSentenceParts(Int32, Int32) | Finds the sentence up to a point and the sentence after a point
 | GetConsiderationRange()()()() | Obsolete. Gets the factor for words to consider for suggestions.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIgnoreCapitalizedWords()()()() | Obsolete. Gets whether to ignore words with capital letters.
 | GetIncludeUserDictionaryInSuggestions()()()() | Obsolete. Gets whether the user dictionary should be used in finding suggestions for misspelt words.
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetSeparateHyphenWords()()()() | Obsolete. Gets whether to treat hyphenated (-) words as separate words, default is false.
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GUILanguage | The language to show the UI in.
 | guiShowing | Whether the gui is currently showing
 | Ignore()()()() | Ignore the current bad word.
 | IgnoreAll()()()() | Ignores all occurrences of this word.
 | IgnoreAllButtonText | Ignore All button text.
 | IgnoreButtonText | Ignore button text.
 | IgnoreCapitalizedWords | Whether to ignore words with capital letters.
 | IgnoreIncorrectSentenceCapitalization | Whether to ignore incorrect sentence capitalization.
 | IgnoreInEnglishLowerCaseI | Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
 | IgnoreWordsWithDigits | Whether to ignore words with numbers in them (eg. A10 or 7-11).
 | IgnoreXML | Whether to ignore XML/HTML tags, false by default.
 | IncludeUserDictionaryInSuggestions | Whether the user dictionary should be used in finding suggestions for misspelt words.
 | InDictionaryLabelText | In dictionary label text
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | IsDialogViewCreated()()()() | Whether a dialog view has already been created.
 | IsDisposed | Whether the IDialogView is disposed of
 | IsShowFinishedMessageBox()()()() | Obsolete. Returns whether a message box should be opened when the spell check is complete.
 | LanguageParser | The type of language parsing to use.
 | Load | Fired when the DialogView loads.
 | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
 | LookIntoHyphenatedText | Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
 | MakeChange()()()() | Changes the current bad word for one selected from the suggestions list or entered in the query pane returns the word used.
 | MakeChange(Boolean) | Changes the current bad word for one selected from the suggestions list or entered in the query pane returns the word used.
 | MakeChange(Boolean, String, Boolean) | Changes the current bad word for one selected from the suggestions list or entered in the query pane returns the word used.
 | MaximumContextualWords | The maximum number of words to show the user in the sentence around misspelled words.
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ModalAutoDispose | When running modally, determines if the dialog will be disposed of when spell check finishes.
 | ModalMode | Whether the spell checker will run modally. (Modal operation blocks the parent form)
 | ModalOwner | The modal dialog owner window.
 | MoveCaretToWordEnd()()()() | Moves the caret to the end of the word the caret is in, or where it is if not on a word.
 | MoveCaretToWordStart()()()() | Moves the caret to the start of the word the caret is in, or where it is if not on a word.
 | NoSuggestionsText | No suggestions found text
 | NotInDictionaryLabelText | Not in dictionary label text
 | NumberSuggestionList | Whether to number the items in the suggestion list, for quick user selection.
 | OnCreateDialogView(CreateDialogViewEventArgs) | Fires the CreateDialogView event.
 | OnSuggestionsDoubleClick(Object, EventArgs) | Called when the user double clicks on a suggestion.
 | OnUndone(UndoEventArgs) | Raises the Undone event
 | OnUserQuery(UserQueryEventArgs) | Fires the user query event
 | Options | Object responsible for holding, loading and saving the user's spell check options.
 | OptionsButtonText | Options button text
 | OptionsPresenter | Presenter for the user options form (IDialogViewOptions).
 | ProceedFromEnd()()()() | Decides what to do once reached end of required text check region
 | QueryTextBoxMultiline | Whether 'not in dictionary' text box is multiline or single line.
 | Ready | Fired when ready to proceed with first query.
 | RecheckDocumentRequest | Fired when document recheck is requested
 | Remove()()()() | Safely frees up resources.
 | RemoveDuplicateWordText | Remove duplicate word text
 | Resume()()()() | Looks for next bad word
 | ResumeButtonText | Resume button text
 | SelectText(BadWord) | Selects a bad word in the text component
 | SeparateHyphenWords | Sets whether to treat hyphenated (-) words as separate words, default is false.
 | SetConsiderationRange(Int32) | Obsolete. Sets the factor for words to consider for suggestions, lower values are faster but consider less words for suggestions. Default is 80. If w <= 1 this method won't do anything.
 | SetDisposeAtEnd(Boolean) | Sets whether this will dispose of self at the end of the spell check.
 | SetFormCancelButton(IButtonControl) | Obsolete. Sets the Form.CancelButton property - this is for VB.NET users who are inheriting from this class.
 | SetIgnoreCapitalizedWords(Boolean) | Obsolete. Sets whether to ignore words with capital letters.
 | SetIgnoreOnceBadWords(ArrayList) | Provide a list of BadWord objects that have been ignored
 | SetIncludeUserDictionaryInSuggestions(Boolean) | Obsolete. Sets whether the user dictionary should be used in finding suggestions for misspelt words.
 | SetSeparateHyphenWords(Boolean) | Obsolete. Sets whether to treat hyphenated (-) words as separate words, default is false.
 | SetShowFinishedMessageBox(Boolean) | Obsolete. Sets whether a message box should be opened when the spell check is complete.
 | SetSuggestionsMethod(Int32) | Obsolete. Sets the suggestions method to use. Either PHONETIC_SUGGESTIONS or HASHING_SUGGESTIONS
 | SetTextComponentToCheck(TextBoxBase) | Set the TextBoxBase (eg; TextBox etc) that this GUI will spell check.
 | SetTextComponentToCheck(ISpellCheckableTextComponent) | Sets the ISpellCheckableTextComponent that this GUI will spell check.
 | SetTextComponentToCheck(ISpellCheckableTextComponent2) | Sets the ISpellCheckableTextComponent2 that this GUI will spell check.
 | SetUITexts()()()() | Applies the UI texts to the IDialogView
 | SetUserDictionary(UserDictionary) | Obsolete. Set the user dictionary object.
 | SetUserDictionaryFile(String) | Obsolete. Set the user dictionary file, if this file doesn't exist it will be created.
 | ShouldEnableAddButton()()()() | Determines if the Add button should be enabled
 | ShowContextSentence | Whether to show the query in context of it's sentence/line.
 | ShowFinishedMessageBox | Whether a message box should be opened when the spell check is complete.
 | showMessageBoxAtEnd |
 | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
 | SpellCheckFinished | Fired when checking finishes
 | SpellCheckStarted | Fired when checking starts
 | subFromPosition | To check from and to positions that are wrapped, need to do in 2 steps check from subFromPosition ( = fromPosition) -> subToPosition (= doc end) and then check from subFromPosition (= 0) -> subToPosition (= toPosition)
 | subToPosition | To check from and to positions that are wrapped, need to do in 2 steps check from subFromPosition ( = fromPosition) -> subToPosition (= doc end) and then check from subFromPosition (= 0) -> subToPosition (= toPosition)
 | SuggestionsKeyboardText | Suggestions label text when in keyboard mode
 | SuggestionsLabelText | Suggestions label text
 | SuggestionsMethod | The suggestions method to use.
 | SuggestSplitWords | Whether to look for connected words in suggestions.
 | TextBoundary | The AdvancedTextBoundary class to use to parse words.
 | TextBox | The text box instance that this is working with, the actual type depends on whether the TextBoxBaseToCheck property or ThirdPartyTextComponentToCheck property was set.
 | theBadWord |
 | theSpellChecker | The spell checker component being used
 | theTextComponent | The text component being checked
 | toPosition | Where the user wants to check to
 | ToString()()()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
 | Undo()()()() | Undoes the previous user operation.
 | UndoButtonText | Undo button text
 | Undone | Fired when an Undo occurs
 | UserDictionary | Set the user dictionary object.
 | UserDictionaryFile | Set the user dictionary file, if this file doesn't exist it will be created.
 | UserQuery | Indicates that the user is being queried on a spelling error.
 | WarnDuplicates | Whether to show duplicate words as errors (eg. "this is is an error").
 | WordAdded | Fired when word added to user dictionary
 | WordChanged | Fired when word changed
 | WordChanging | Fired before a word is changed
 | WordIgnored | Fired when word ignored
 | Wrap()()()() | Wraps the checker to start at beginning of doc
 | wrapped |
Remarks
This class contains no UI elements, instead they are held in it's DialogView property. To customize the UI layout and/or behavior, consult the user guide section "Custom RapidSpellDialog User Interface", which outlines how to use the various "Create*" events in RapidSpellDialog to return custom instances of this class or implementations of IDialogView.
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | RapidSpellGUIPresenter


RapidSpellGUIPresenter Constructor

Keyoti RapidSpell Desktop .NET API Docs
RapidSpellGUIPresenter Constructor
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► RapidSpellGUIPresenter()()()()
Keyoti RapidSpell Desktop .NET
Construct this GUI component - this will NOT open a new Form, call Check to do that.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public RapidSpellGUIPresenter()
public RapidSpellGUIPresenter()
Public Sub New
Public Sub New
public:
RapidSpellGUIPresenter()
public:
RapidSpellGUIPresenter()
new : unit -> RapidSpellGUIPresenter
new : unit -> RapidSpellGUIPresenter


ActionPerformed Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
ActionPerformed Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► ActionPerformed(Object, EventArgs)
Keyoti RapidSpell Desktop .NET
Listen to GUI events and perform actions depending on the button sending the event.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
[ObsoleteAttribute("Use DialogView_* methods instead.", true)]
protected virtual void ActionPerformed(
    Object sender,
    EventArgs e
)
[ObsoleteAttribute("Use DialogView_* methods instead.", true)]
protected virtual void ActionPerformed(
    Object sender,
    EventArgs e
)
<ObsoleteAttribute("Use DialogView_* methods instead.", true)>
Protected Overridable Sub ActionPerformed (
    sender As Object,
    e As EventArgs
)
<ObsoleteAttribute("Use DialogView_* methods instead.", true)>
Protected Overridable Sub ActionPerformed (
    sender As Object,
    e As EventArgs
)
protected:
[ObsoleteAttribute(L"Use DialogView_* methods instead.", true)]
virtual void ActionPerformed(
    Object^ sender,
    EventArgs^ e
)
protected:
[ObsoleteAttribute(L"Use DialogView_* methods instead.", true)]
virtual void ActionPerformed(
    Object^ sender,
    EventArgs^ e
)
[<ObsoleteAttribute("Use DialogView_* methods instead.", true)>]
abstract ActionPerformed :
        sender : Object *
        e : EventArgs -> unit
[<ObsoleteAttribute("Use DialogView_* methods instead.", true)>]
override ActionPerformed :
        sender : Object *
        e : EventArgs -> unit
[<ObsoleteAttribute("Use DialogView_* methods instead.", true)>]
abstract ActionPerformed :
        sender : Object *
        e : EventArgs -> unit
[<ObsoleteAttribute("Use DialogView_* methods instead.", true)>]
override ActionPerformed :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


active Field

Keyoti RapidSpell Desktop .NET API Docs
active Field
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► active
Keyoti RapidSpell Desktop .NET
The state of this GUI. It can be either active (user is using it) or inactive (user focus is elsewhere).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected bool active
protected bool active
Protected active As Boolean
Protected active As Boolean
protected:
bool active
protected:
bool active
val mutable active: bool
val mutable active: bool
Field Value
Boolean
Remarks
When this window loses focus the GUI is deactivated, because the text in theTextComponent can change whilst focus is away, and upon reactivation the new text must be loaded in. findSuggestions determines if should look up suggestions or not.


AddButtonText Property

Keyoti RapidSpell Desktop .NET API Docs
AddButtonText Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► AddButtonText
Keyoti RapidSpell Desktop .NET
Add button text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string AddButtonText { get; set; }
public string AddButtonText { get; set; }
Public Property AddButtonText As String
    Get
    Set
Public Property AddButtonText As String
    Get
    Set
public:
virtual property String^ AddButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ AddButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract AddButtonText : string with get, set
override AddButtonText : string with get, set
abstract AddButtonText : string with get, set
override AddButtonText : string with get, set
Property Value
String


AddWord Method

Keyoti RapidSpell Desktop .NET API Docs
AddWord Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► AddWord()()()()
Keyoti RapidSpell Desktop .NET
Adds the current bad word to the user dictionary.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void AddWord()
protected virtual void AddWord()
Protected Overridable Sub AddWord
Protected Overridable Sub AddWord
protected:
virtual void AddWord()
protected:
virtual void AddWord()
abstract AddWord : unit -> unit
override AddWord : unit -> unit
abstract AddWord : unit -> unit
override AddWord : unit -> unit
Return Value

void


AllOperationScope Property

Keyoti RapidSpell Desktop .NET API Docs
AllOperationScope Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► AllOperationScope
Keyoti RapidSpell Desktop .NET
The scope that ignore-all/change-all should have.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public OperationScope AllOperationScope { get; set; }
public OperationScope AllOperationScope { get; set; }
Public Property AllOperationScope As OperationScope
    Get
    Set
Public Property AllOperationScope As OperationScope
    Get
    Set
public:
virtual property OperationScope AllOperationScope {
    OperationScope get () sealed;
    void set (OperationScope value) sealed;
}
public:
virtual property OperationScope AllOperationScope {
    OperationScope get () sealed;
    void set (OperationScope value) sealed;
}
abstract AllOperationScope : OperationScope with get, set
override AllOperationScope : OperationScope with get, set
abstract AllOperationScope : OperationScope with get, set
override AllOperationScope : OperationScope with get, set
Property Value
OperationScope


CancelActionPerformed Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
CancelActionPerformed Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► CancelActionPerformed(Object, CancelEventArgs)
Keyoti RapidSpell Desktop .NET
Listen to GUI events and perform actions depending on the button sending the event.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
[ObsoleteAttribute("Use DialogView_Closing instead.", true)]
protected virtual void CancelActionPerformed(
    Object sender,
    CancelEventArgs e
)
[ObsoleteAttribute("Use DialogView_Closing instead.", true)]
protected virtual void CancelActionPerformed(
    Object sender,
    CancelEventArgs e
)
<ObsoleteAttribute("Use DialogView_Closing instead.", true)>
Protected Overridable Sub CancelActionPerformed (
    sender As Object,
    e As CancelEventArgs
)
<ObsoleteAttribute("Use DialogView_Closing instead.", true)>
Protected Overridable Sub CancelActionPerformed (
    sender As Object,
    e As CancelEventArgs
)
protected:
[ObsoleteAttribute(L"Use DialogView_Closing instead.", true)]
virtual void CancelActionPerformed(
    Object^ sender,
    CancelEventArgs^ e
)
protected:
[ObsoleteAttribute(L"Use DialogView_Closing instead.", true)]
virtual void CancelActionPerformed(
    Object^ sender,
    CancelEventArgs^ e
)
[<ObsoleteAttribute("Use DialogView_Closing instead.", true)>]
abstract CancelActionPerformed :
        sender : Object *
        e : CancelEventArgs -> unit
[<ObsoleteAttribute("Use DialogView_Closing instead.", true)>]
override CancelActionPerformed :
        sender : Object *
        e : CancelEventArgs -> unit
[<ObsoleteAttribute("Use DialogView_Closing instead.", true)>]
abstract CancelActionPerformed :
        sender : Object *
        e : CancelEventArgs -> unit
[<ObsoleteAttribute("Use DialogView_Closing instead.", true)>]
override CancelActionPerformed :
        sender : Object *
        e : CancelEventArgs -> unit
Parameters
sender (Object)
e (CancelEventArgs)


CancelButtonText Property

Keyoti RapidSpell Desktop .NET API Docs
CancelButtonText Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► CancelButtonText
Keyoti RapidSpell Desktop .NET
Cancel button text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string CancelButtonText { get; set; }
public string CancelButtonText { get; set; }
Public Property CancelButtonText As String
    Get
    Set
Public Property CancelButtonText As String
    Get
    Set
public:
virtual property String^ CancelButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ CancelButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract CancelButtonText : string with get, set
override CancelButtonText : string with get, set
abstract CancelButtonText : string with get, set
override CancelButtonText : string with get, set
Property Value
String


Cancelled Property

Keyoti RapidSpell Desktop .NET API Docs
Cancelled Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► Cancelled
Keyoti RapidSpell Desktop .NET
Whether the spell check has been cancelled.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool Cancelled { get; }
public bool Cancelled { get; }
Public ReadOnly Property Cancelled As Boolean
    Get
Public ReadOnly Property Cancelled As Boolean
    Get
public:
virtual property bool Cancelled {
    bool get () sealed;
}
public:
virtual property bool Cancelled {
    bool get () sealed;
}
abstract Cancelled : bool with get
override Cancelled : bool with get
abstract Cancelled : bool with get
override Cancelled : bool with get
Property Value
Boolean


ChangeAll Method

Keyoti RapidSpell Desktop .NET API Docs
ChangeAll Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► ChangeAll()()()()
Keyoti RapidSpell Desktop .NET
Called when user wants to change all instances of current bad word to selected word
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void ChangeAll()
protected virtual void ChangeAll()
Protected Overridable Sub ChangeAll
Protected Overridable Sub ChangeAll
protected:
virtual void ChangeAll()
protected:
virtual void ChangeAll()
abstract ChangeAll : unit -> unit
override ChangeAll : unit -> unit
abstract ChangeAll : unit -> unit
override ChangeAll : unit -> unit
Return Value

void


ChangeAllButtonText Property

Keyoti RapidSpell Desktop .NET API Docs
ChangeAllButtonText Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► ChangeAllButtonText
Keyoti RapidSpell Desktop .NET
Change All button text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string ChangeAllButtonText { get; set; }
public string ChangeAllButtonText { get; set; }
Public Property ChangeAllButtonText As String
    Get
    Set
Public Property ChangeAllButtonText As String
    Get
    Set
public:
virtual property String^ ChangeAllButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ ChangeAllButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract ChangeAllButtonText : string with get, set
override ChangeAllButtonText : string with get, set
abstract ChangeAllButtonText : string with get, set
override ChangeAllButtonText : string with get, set
Property Value
String


ChangeButtonText Property

Keyoti RapidSpell Desktop .NET API Docs
ChangeButtonText Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► ChangeButtonText
Keyoti RapidSpell Desktop .NET
Change button text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string ChangeButtonText { get; set; }
public string ChangeButtonText { get; set; }
Public Property ChangeButtonText As String
    Get
    Set
Public Property ChangeButtonText As String
    Get
    Set
public:
virtual property String^ ChangeButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ ChangeButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract ChangeButtonText : string with get, set
override ChangeButtonText : string with get, set
abstract ChangeButtonText : string with get, set
override ChangeButtonText : string with get, set
Property Value
String


ChangeWord Method

Keyoti RapidSpell Desktop .NET API Docs
ChangeWord Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► ChangeWord()()()()
Keyoti RapidSpell Desktop .NET
User wants to change current bad word to selected word
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void ChangeWord()
protected virtual void ChangeWord()
Protected Overridable Sub ChangeWord
Protected Overridable Sub ChangeWord
protected:
virtual void ChangeWord()
protected:
virtual void ChangeWord()
abstract ChangeWord : unit -> unit
override ChangeWord : unit -> unit
abstract ChangeWord : unit -> unit
override ChangeWord : unit -> unit
Return Value

void


Check Method

Keyoti RapidSpell Desktop .NET API Docs
Check Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► Check()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Check()()()() | Bring up the spell checker Form and start checking the component set by SetTextComponentToCheck.
 | Check(TextBoxBase) | Bring up the spell checker Form and start checking the TextBoxBase textComponent.
 | Check(ISpellCheckableTextComponent) | Bring up the spell checker Form and start checking the TextBoxBase textComponent.


Check Method

Keyoti RapidSpell Desktop .NET API Docs
Check Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► Check()()()()
Keyoti RapidSpell Desktop .NET
Bring up the spell checker Form and start checking the component set by SetTextComponentToCheck.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void Check()
public virtual void Check()
Public Overridable Sub Check
Public Overridable Sub Check
public:
virtual void Check()
public:
virtual void Check()
abstract Check : unit -> unit
override Check : unit -> unit
abstract Check : unit -> unit
override Check : unit -> unit
Exceptions
Exception | Condition
NoTextComponentException | if SetTextComponentToCheck hasn't be called first with a TextBoxBase object.


Check Method (textComponent)

Keyoti RapidSpell Desktop .NET API Docs
Check Method (textComponent)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► Check(ISpellCheckableTextComponent)
Keyoti RapidSpell Desktop .NET
Bring up the spell checker Form and start checking the TextBoxBase textComponent.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void Check(
    ISpellCheckableTextComponent textComponent
)
public virtual void Check(
    ISpellCheckableTextComponent textComponent
)
Public Overridable Sub Check (
    textComponent As ISpellCheckableTextComponent
)
Public Overridable Sub Check (
    textComponent As ISpellCheckableTextComponent
)
public:
virtual void Check(
    ISpellCheckableTextComponent^ textComponent
)
public:
virtual void Check(
    ISpellCheckableTextComponent^ textComponent
)
abstract Check :
        textComponent : ISpellCheckableTextComponent -> unit
override Check :
        textComponent : ISpellCheckableTextComponent -> unit
abstract Check :
        textComponent : ISpellCheckableTextComponent -> unit
override Check :
        textComponent : ISpellCheckableTextComponent -> unit
Parameters
textComponent (ISpellCheckableTextComponent)
Exceptions
Exception | Condition
ArgumentNullException | if textComponent parameter is null.


Check Method (textComponent)

Keyoti RapidSpell Desktop .NET API Docs
Check Method (textComponent)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► Check(TextBoxBase)
Keyoti RapidSpell Desktop .NET
Bring up the spell checker Form and start checking the TextBoxBase textComponent.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void Check(
    TextBoxBase textComponent
)
public virtual void Check(
    TextBoxBase textComponent
)
Public Overridable Sub Check (
    textComponent As TextBoxBase
)
Public Overridable Sub Check (
    textComponent As TextBoxBase
)
public:
virtual void Check(
    TextBoxBase^ textComponent
)
public:
virtual void Check(
    TextBoxBase^ textComponent
)
abstract Check :
        textComponent : TextBoxBase -> unit
override Check :
        textComponent : TextBoxBase -> unit
abstract Check :
        textComponent : TextBoxBase -> unit
override Check :
        textComponent : TextBoxBase -> unit
Parameters
textComponent (TextBoxBase)
Exceptions
Exception | Condition
ArgumentNullException | if textComponent parameter is null.


CheckCompletePopUpText Property

Keyoti RapidSpell Desktop .NET API Docs
CheckCompletePopUpText Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► CheckCompletePopUpText
Keyoti RapidSpell Desktop .NET
Check complete pop up text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string CheckCompletePopUpText { get; set; }
public string CheckCompletePopUpText { get; set; }
Public Property CheckCompletePopUpText As String
    Get
    Set
Public Property CheckCompletePopUpText As String
    Get
    Set
public:
virtual property String^ CheckCompletePopUpText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ CheckCompletePopUpText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract CheckCompletePopUpText : string with get, set
override CheckCompletePopUpText : string with get, set
abstract CheckCompletePopUpText : string with get, set
override CheckCompletePopUpText : string with get, set
Property Value
String


CheckCompletePopUpTitle Property

Keyoti RapidSpell Desktop .NET API Docs
CheckCompletePopUpTitle Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► CheckCompletePopUpTitle
Keyoti RapidSpell Desktop .NET
Check complete pop up title
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string CheckCompletePopUpTitle { get; set; }
public string CheckCompletePopUpTitle { get; set; }
Public Property CheckCompletePopUpTitle As String
    Get
    Set
Public Property CheckCompletePopUpTitle As String
    Get
    Set
public:
virtual property String^ CheckCompletePopUpTitle {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ CheckCompletePopUpTitle {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract CheckCompletePopUpTitle : string with get, set
override CheckCompletePopUpTitle : string with get, set
abstract CheckCompletePopUpTitle : string with get, set
override CheckCompletePopUpTitle : string with get, set
Property Value
String


CheckCompoundWords Property

Keyoti RapidSpell Desktop .NET API Docs
CheckCompoundWords Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► CheckCompoundWords
Keyoti RapidSpell Desktop .NET
Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool CheckCompoundWords { get; set; }
public bool CheckCompoundWords { get; set; }
Public Property CheckCompoundWords As Boolean
    Get
    Set
Public Property CheckCompoundWords As Boolean
    Get
    Set
public:
virtual property bool CheckCompoundWords {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool CheckCompoundWords {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract CheckCompoundWords : bool with get, set
override CheckCompoundWords : bool with get, set
abstract CheckCompoundWords : bool with get, set
override CheckCompoundWords : bool with get, set
Property Value
Boolean
Remarks
If this=false then LookUp("thesewordsarejoined") = false

If this=true then LookUp("thesewordsarejoined") = true

If this=false then LookUp("abcdef") = false

If this=true then LookUp("abcdef") = false

Setting this to true will degrade lookup performance


CheckerEngine Property

Keyoti RapidSpell Desktop .NET API Docs
CheckerEngine Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► CheckerEngine
Keyoti RapidSpell Desktop .NET
The checker engine to use, this object must implement the ICheckerEngine interface, allows customization or replacement of the spell checker.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual ICheckerEngine CheckerEngine { get; set; }
public virtual ICheckerEngine CheckerEngine { get; set; }
Public Overridable Property CheckerEngine As ICheckerEngine
    Get
    Set
Public Overridable Property CheckerEngine As ICheckerEngine
    Get
    Set
public:
virtual property ICheckerEngine^ CheckerEngine {
    ICheckerEngine^ get ();
    void set (ICheckerEngine^ value);
}
public:
virtual property ICheckerEngine^ CheckerEngine {
    ICheckerEngine^ get ();
    void set (ICheckerEngine^ value);
}
abstract CheckerEngine : ICheckerEngine with get, set
override CheckerEngine : ICheckerEngine with get, set
abstract CheckerEngine : ICheckerEngine with get, set
override CheckerEngine : ICheckerEngine with get, set
Property Value
ICheckerEngine
Remarks
Use this property to replace the object used to perform checking, it is not necessary to replace this with a spell checker, any type of word parser can be used. For example an abbreviations checker could be written to replace common words with abbreviations. Caveat: Most properties in RapidSpellGUI are mirrors of properties in ICheckerEngine, setting a CheckerEngine AFTER setting properties in RapidSpellGUI will overwrite those property values with the values of CheckerEngine.


CheckFromStartOfText Property

Keyoti RapidSpell Desktop .NET API Docs
CheckFromStartOfText Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► CheckFromStartOfText
Keyoti RapidSpell Desktop .NET
Whether to check from the start of the text (true) or whereever the cursor is (false)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool CheckFromStartOfText { get; set; }
public bool CheckFromStartOfText { get; set; }
Public Property CheckFromStartOfText As Boolean
    Get
    Set
Public Property CheckFromStartOfText As Boolean
    Get
    Set
public:
virtual property bool CheckFromStartOfText {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool CheckFromStartOfText {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract CheckFromStartOfText : bool with get, set
override CheckFromStartOfText : bool with get, set
abstract CheckFromStartOfText : bool with get, set
override CheckFromStartOfText : bool with get, set
Property Value
Boolean


checkingSelection Field

Keyoti RapidSpell Desktop .NET API Docs
checkingSelection Field
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► checkingSelection
Keyoti RapidSpell Desktop .NET
The state of this GUI. It can be either active (user is using it) or inactive (user focus is elsewhere).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected bool checkingSelection
protected bool checkingSelection
Protected checkingSelection As Boolean
Protected checkingSelection As Boolean
protected:
bool checkingSelection
protected:
bool checkingSelection
val mutable checkingSelection: bool
val mutable checkingSelection: bool
Field Value
Boolean
Remarks
When this window loses focus the GUI is deactivated, because the text in theTextComponent can change whilst focus is away, and upon reactivation the new text must be loaded in. findSuggestions determines if should look up suggestions or not.


CheckingSpellingText Property

Keyoti RapidSpell Desktop .NET API Docs
CheckingSpellingText Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► CheckingSpellingText
Keyoti RapidSpell Desktop .NET
Checking spelling text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string CheckingSpellingText { get; set; }
public string CheckingSpellingText { get; set; }
Public Property CheckingSpellingText As String
    Get
    Set
Public Property CheckingSpellingText As String
    Get
    Set
public:
virtual property String^ CheckingSpellingText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ CheckingSpellingText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract CheckingSpellingText : string with get, set
override CheckingSpellingText : string with get, set
abstract CheckingSpellingText : string with get, set
override CheckingSpellingText : string with get, set
Property Value
String


Close Method

Keyoti RapidSpell Desktop .NET API Docs
Close Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► Close()()()()
Keyoti RapidSpell Desktop .NET
Closes the form if open.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void Close()
public void Close()
Public Sub Close
Public Sub Close
public:
void Close()
public:
void Close()
member Close : unit -> unit

member Close : unit -> unit


ConsiderationRange Property

Keyoti RapidSpell Desktop .NET API Docs
ConsiderationRange Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► ConsiderationRange
Keyoti RapidSpell Desktop .NET
The factor for words to consider for suggestions, lower values are faster but consider less words for suggestions. Default is 80. If w <= 1 this method won't do anything.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int ConsiderationRange { get; set; }
public int ConsiderationRange { get; set; }
Public Property ConsiderationRange As Integer
    Get
    Set
Public Property ConsiderationRange As Integer
    Get
    Set
public:
virtual property int ConsiderationRange {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int ConsiderationRange {
    int get () sealed;
    void set (int value) sealed;
}
abstract ConsiderationRange : int with get, set
override ConsiderationRange : int with get, set
abstract ConsiderationRange : int with get, set
override ConsiderationRange : int with get, set
Property Value
Int32


CreateDialogView Event

Keyoti RapidSpell Desktop .NET API Docs
CreateDialogView Event
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► CreateDialogView
Keyoti RapidSpell Desktop .NET
Indicates that a new IDialogView has been created, also provides chance to override the default IDialogView.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event CreateDialogViewEventHandler CreateDialogView
public event CreateDialogViewEventHandler CreateDialogView
Public Event CreateDialogView As CreateDialogViewEventHandler
Public Event CreateDialogView As CreateDialogViewEventHandler
public:
virtual  event CreateDialogViewEventHandler^ CreateDialogView {
    void add (CreateDialogViewEventHandler^ value);
    void remove (CreateDialogViewEventHandler^ value);
}
public:
virtual  event CreateDialogViewEventHandler^ CreateDialogView {
    void add (CreateDialogViewEventHandler^ value);
    void remove (CreateDialogViewEventHandler^ value);
}
abstract CreateDialogView : IEvent<CreateDialogViewEventHandler,
    CreateDialogViewEventArgs>
override CreateDialogView : IEvent<CreateDialogViewEventHandler,
    CreateDialogViewEventArgs>
abstract CreateDialogView : IEvent<CreateDialogViewEventHandler,
    CreateDialogViewEventArgs>
override CreateDialogView : IEvent<CreateDialogViewEventHandler,
    CreateDialogViewEventArgs>
Value
CreateDialogViewEventHandler


CreateDialogViewOptions Event

Keyoti RapidSpell Desktop .NET API Docs
CreateDialogViewOptions Event
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► CreateDialogViewOptions
Keyoti RapidSpell Desktop .NET
Indicates that a new IDialogViewOptions is being created, also provides chance to override the default IDialogViewOptions.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event CreateDialogViewOptionsEventHandler CreateDialogViewOptions
public event CreateDialogViewOptionsEventHandler CreateDialogViewOptions
Public Event CreateDialogViewOptions As CreateDialogViewOptionsEventHandler
Public Event CreateDialogViewOptions As CreateDialogViewOptionsEventHandler
public:
virtual  event CreateDialogViewOptionsEventHandler^ CreateDialogViewOptions {
    void add (CreateDialogViewOptionsEventHandler^ value);
    void remove (CreateDialogViewOptionsEventHandler^ value);
}
public:
virtual  event CreateDialogViewOptionsEventHandler^ CreateDialogViewOptions {
    void add (CreateDialogViewOptionsEventHandler^ value);
    void remove (CreateDialogViewOptionsEventHandler^ value);
}
abstract CreateDialogViewOptions : IEvent<CreateDialogViewOptionsEventHandler,
    CreateDialogViewOptionsEventArgs>
override CreateDialogViewOptions : IEvent<CreateDialogViewOptionsEventHandler,
    CreateDialogViewOptionsEventArgs>
abstract CreateDialogViewOptions : IEvent<CreateDialogViewOptionsEventHandler,
    CreateDialogViewOptionsEventArgs>
override CreateDialogViewOptions : IEvent<CreateDialogViewOptionsEventHandler,
    CreateDialogViewOptionsEventArgs>
Value
CreateDialogViewOptionsEventHandler


CreateDialogViewUserDictionaryEdit Event

Keyoti RapidSpell Desktop .NET API Docs
CreateDialogViewUserDictionaryEdit Event
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► CreateDialogViewUserDictionaryEdit
Keyoti RapidSpell Desktop .NET
Indicates that a new IDialogViewUserDictionaryEdit is being created, also provides chance to override the default IDialogViewUserDictionaryEdit.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event CreateDialogViewUserDictionaryEditEventHandler CreateDialogViewUserDictionaryEdit
public event CreateDialogViewUserDictionaryEditEventHandler CreateDialogViewUserDictionaryEdit
Public Event CreateDialogViewUserDictionaryEdit As CreateDialogViewUserDictionaryEditEventHandler
Public Event CreateDialogViewUserDictionaryEdit As CreateDialogViewUserDictionaryEditEventHandler
public:
virtual  event CreateDialogViewUserDictionaryEditEventHandler^ CreateDialogViewUserDictionaryEdit {
    void add (CreateDialogViewUserDictionaryEditEventHandler^ value);
    void remove (CreateDialogViewUserDictionaryEditEventHandler^ value);
}
public:
virtual  event CreateDialogViewUserDictionaryEditEventHandler^ CreateDialogViewUserDictionaryEdit {
    void add (CreateDialogViewUserDictionaryEditEventHandler^ value);
    void remove (CreateDialogViewUserDictionaryEditEventHandler^ value);
}
abstract CreateDialogViewUserDictionaryEdit : IEvent<CreateDialogViewUserDictionaryEditEventHandler,
    CreateDialogViewUserDictionaryEditEventArgs>
override CreateDialogViewUserDictionaryEdit : IEvent<CreateDialogViewUserDictionaryEditEventHandler,
    CreateDialogViewUserDictionaryEditEventArgs>
abstract CreateDialogViewUserDictionaryEdit : IEvent<CreateDialogViewUserDictionaryEditEventHandler,
    CreateDialogViewUserDictionaryEditEventArgs>
override CreateDialogViewUserDictionaryEdit : IEvent<CreateDialogViewUserDictionaryEditEventHandler,
    CreateDialogViewUserDictionaryEditEventArgs>
Value
CreateDialogViewUserDictionaryEditEventHandler


CreateDialogViewUserDictionarySelect Event

Keyoti RapidSpell Desktop .NET API Docs
CreateDialogViewUserDictionarySelect Event
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► CreateDialogViewUserDictionarySelect
Keyoti RapidSpell Desktop .NET
Indicates that a new IDialogViewUserDictionarySelect is being created, also provides chance to override the default IDialogViewUserDictionarySelect.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event CreateDialogViewUserDictionarySelectEventHandler CreateDialogViewUserDictionarySelect
public event CreateDialogViewUserDictionarySelectEventHandler CreateDialogViewUserDictionarySelect
Public Event CreateDialogViewUserDictionarySelect As CreateDialogViewUserDictionarySelectEventHandler
Public Event CreateDialogViewUserDictionarySelect As CreateDialogViewUserDictionarySelectEventHandler
public:
virtual  event CreateDialogViewUserDictionarySelectEventHandler^ CreateDialogViewUserDictionarySelect {
    void add (CreateDialogViewUserDictionarySelectEventHandler^ value);
    void remove (CreateDialogViewUserDictionarySelectEventHandler^ value);
}
public:
virtual  event CreateDialogViewUserDictionarySelectEventHandler^ CreateDialogViewUserDictionarySelect {
    void add (CreateDialogViewUserDictionarySelectEventHandler^ value);
    void remove (CreateDialogViewUserDictionarySelectEventHandler^ value);
}
abstract CreateDialogViewUserDictionarySelect : IEvent<CreateDialogViewUserDictionarySelectEventHandler,
    CreateDialogViewUserDictionarySelectEventArgs>
override CreateDialogViewUserDictionarySelect : IEvent<CreateDialogViewUserDictionarySelectEventHandler,
    CreateDialogViewUserDictionarySelectEventArgs>
abstract CreateDialogViewUserDictionarySelect : IEvent<CreateDialogViewUserDictionarySelectEventHandler,
    CreateDialogViewUserDictionarySelectEventArgs>
override CreateDialogViewUserDictionarySelect : IEvent<CreateDialogViewUserDictionarySelectEventHandler,
    CreateDialogViewUserDictionarySelectEventArgs>
Value
CreateDialogViewUserDictionarySelectEventHandler


DialogTitleText Property

Keyoti RapidSpell Desktop .NET API Docs
DialogTitleText Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► DialogTitleText
Keyoti RapidSpell Desktop .NET
Dialog title text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string DialogTitleText { get; set; }
public string DialogTitleText { get; set; }
Public Property DialogTitleText As String
    Get
    Set
Public Property DialogTitleText As String
    Get
    Set
public:
virtual property String^ DialogTitleText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ DialogTitleText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract DialogTitleText : string with get, set
override DialogTitleText : string with get, set
abstract DialogTitleText : string with get, set
override DialogTitleText : string with get, set
Property Value
String


DialogView Property

Keyoti RapidSpell Desktop .NET API Docs
DialogView Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► DialogView
Keyoti RapidSpell Desktop .NET
The IDialogView instance to use for the UI.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual IDialogView DialogView { get; set; }
public virtual IDialogView DialogView { get; set; }
Public Overridable Property DialogView As IDialogView
    Get
    Set
Public Overridable Property DialogView As IDialogView
    Get
    Set
public:
virtual property IDialogView^ DialogView {
    IDialogView^ get ();
    void set (IDialogView^ value);
}
public:
virtual property IDialogView^ DialogView {
    IDialogView^ get ();
    void set (IDialogView^ value);
}
abstract DialogView : IDialogView with get, set
override DialogView : IDialogView with get, set
abstract DialogView : IDialogView with get, set
override DialogView : IDialogView with get, set
Property Value
IDialogView
Remarks
Handler CreateDialogView and set NewView to set a different instance to use.


DialogView_AddButtonClick Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
DialogView_AddButtonClick Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► DialogView_AddButtonClick(Object, EventArgs)
Keyoti RapidSpell Desktop .NET
Handles IDialogView event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void DialogView_AddButtonClick(
    Object sender,
    EventArgs e
)
public virtual void DialogView_AddButtonClick(
    Object sender,
    EventArgs e
)
Public Overridable Sub DialogView_AddButtonClick (
    sender As Object,
    e As EventArgs
)
Public Overridable Sub DialogView_AddButtonClick (
    sender As Object,
    e As EventArgs
)
public:
virtual void DialogView_AddButtonClick(
    Object^ sender,
    EventArgs^ e
)
public:
virtual void DialogView_AddButtonClick(
    Object^ sender,
    EventArgs^ e
)
abstract DialogView_AddButtonClick :
        sender : Object *
        e : EventArgs -> unit
override DialogView_AddButtonClick :
        sender : Object *
        e : EventArgs -> unit
abstract DialogView_AddButtonClick :
        sender : Object *
        e : EventArgs -> unit
override DialogView_AddButtonClick :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


DialogView_CancelButtonClick Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
DialogView_CancelButtonClick Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► DialogView_CancelButtonClick(Object, EventArgs)
Keyoti RapidSpell Desktop .NET
Handles IDialogView event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void DialogView_CancelButtonClick(
    Object sender,
    EventArgs e
)
public virtual void DialogView_CancelButtonClick(
    Object sender,
    EventArgs e
)
Public Overridable Sub DialogView_CancelButtonClick (
    sender As Object,
    e As EventArgs
)
Public Overridable Sub DialogView_CancelButtonClick (
    sender As Object,
    e As EventArgs
)
public:
virtual void DialogView_CancelButtonClick(
    Object^ sender,
    EventArgs^ e
)
public:
virtual void DialogView_CancelButtonClick(
    Object^ sender,
    EventArgs^ e
)
abstract DialogView_CancelButtonClick :
        sender : Object *
        e : EventArgs -> unit
override DialogView_CancelButtonClick :
        sender : Object *
        e : EventArgs -> unit
abstract DialogView_CancelButtonClick :
        sender : Object *
        e : EventArgs -> unit
override DialogView_CancelButtonClick :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


DialogView_ChangeAllButtonClick Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
DialogView_ChangeAllButtonClick Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► DialogView_ChangeAllButtonClick(Object, EventArgs)
Keyoti RapidSpell Desktop .NET
Handles IDialogView event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void DialogView_ChangeAllButtonClick(
    Object sender,
    EventArgs e
)
public virtual void DialogView_ChangeAllButtonClick(
    Object sender,
    EventArgs e
)
Public Overridable Sub DialogView_ChangeAllButtonClick (
    sender As Object,
    e As EventArgs
)
Public Overridable Sub DialogView_ChangeAllButtonClick (
    sender As Object,
    e As EventArgs
)
public:
virtual void DialogView_ChangeAllButtonClick(
    Object^ sender,
    EventArgs^ e
)
public:
virtual void DialogView_ChangeAllButtonClick(
    Object^ sender,
    EventArgs^ e
)
abstract DialogView_ChangeAllButtonClick :
        sender : Object *
        e : EventArgs -> unit
override DialogView_ChangeAllButtonClick :
        sender : Object *
        e : EventArgs -> unit
abstract DialogView_ChangeAllButtonClick :
        sender : Object *
        e : EventArgs -> unit
override DialogView_ChangeAllButtonClick :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


DialogView_ChangeButtonClick Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
DialogView_ChangeButtonClick Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► DialogView_ChangeButtonClick(Object, EventArgs)
Keyoti RapidSpell Desktop .NET
Handles IDialogView event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void DialogView_ChangeButtonClick(
    Object sender,
    EventArgs e
)
public virtual void DialogView_ChangeButtonClick(
    Object sender,
    EventArgs e
)
Public Overridable Sub DialogView_ChangeButtonClick (
    sender As Object,
    e As EventArgs
)
Public Overridable Sub DialogView_ChangeButtonClick (
    sender As Object,
    e As EventArgs
)
public:
virtual void DialogView_ChangeButtonClick(
    Object^ sender,
    EventArgs^ e
)
public:
virtual void DialogView_ChangeButtonClick(
    Object^ sender,
    EventArgs^ e
)
abstract DialogView_ChangeButtonClick :
        sender : Object *
        e : EventArgs -> unit
override DialogView_ChangeButtonClick :
        sender : Object *
        e : EventArgs -> unit
abstract DialogView_ChangeButtonClick :
        sender : Object *
        e : EventArgs -> unit
override DialogView_ChangeButtonClick :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


DialogView_Closing Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
DialogView_Closing Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► DialogView_Closing(Object, CancelEventArgs)
Keyoti RapidSpell Desktop .NET
Handles IDialogView event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void DialogView_Closing(
    Object sender,
    CancelEventArgs e
)
public virtual void DialogView_Closing(
    Object sender,
    CancelEventArgs e
)
Public Overridable Sub DialogView_Closing (
    sender As Object,
    e As CancelEventArgs
)
Public Overridable Sub DialogView_Closing (
    sender As Object,
    e As CancelEventArgs
)
public:
virtual void DialogView_Closing(
    Object^ sender,
    CancelEventArgs^ e
)
public:
virtual void DialogView_Closing(
    Object^ sender,
    CancelEventArgs^ e
)
abstract DialogView_Closing :
        sender : Object *
        e : CancelEventArgs -> unit
override DialogView_Closing :
        sender : Object *
        e : CancelEventArgs -> unit
abstract DialogView_Closing :
        sender : Object *
        e : CancelEventArgs -> unit
override DialogView_Closing :
        sender : Object *
        e : CancelEventArgs -> unit
Parameters
sender (Object)
e (CancelEventArgs)


DialogView_IgnoreAllButtonClick Method (s, e)

Keyoti RapidSpell Desktop .NET API Docs
DialogView_IgnoreAllButtonClick Method (s, e)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► DialogView_IgnoreAllButtonClick(Object, EventArgs)
Keyoti RapidSpell Desktop .NET
Handles IDialogView event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void DialogView_IgnoreAllButtonClick(
    Object s,
    EventArgs e
)
public virtual void DialogView_IgnoreAllButtonClick(
    Object s,
    EventArgs e
)
Public Overridable Sub DialogView_IgnoreAllButtonClick (
    s As Object,
    e As EventArgs
)
Public Overridable Sub DialogView_IgnoreAllButtonClick (
    s As Object,
    e As EventArgs
)
public:
virtual void DialogView_IgnoreAllButtonClick(
    Object^ s,
    EventArgs^ e
)
public:
virtual void DialogView_IgnoreAllButtonClick(
    Object^ s,
    EventArgs^ e
)
abstract DialogView_IgnoreAllButtonClick :
        s : Object *
        e : EventArgs -> unit
override DialogView_IgnoreAllButtonClick :
        s : Object *
        e : EventArgs -> unit
abstract DialogView_IgnoreAllButtonClick :
        s : Object *
        e : EventArgs -> unit
override DialogView_IgnoreAllButtonClick :
        s : Object *
        e : EventArgs -> unit
Parameters
s (Object)
e (EventArgs)


DialogView_IgnoreButtonClick Method (s, e)

Keyoti RapidSpell Desktop .NET API Docs
DialogView_IgnoreButtonClick Method (s, e)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► DialogView_IgnoreButtonClick(Object, EventArgs)
Keyoti RapidSpell Desktop .NET
Handles IDialogView event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void DialogView_IgnoreButtonClick(
    Object s,
    EventArgs e
)
public virtual void DialogView_IgnoreButtonClick(
    Object s,
    EventArgs e
)
Public Overridable Sub DialogView_IgnoreButtonClick (
    s As Object,
    e As EventArgs
)
Public Overridable Sub DialogView_IgnoreButtonClick (
    s As Object,
    e As EventArgs
)
public:
virtual void DialogView_IgnoreButtonClick(
    Object^ s,
    EventArgs^ e
)
public:
virtual void DialogView_IgnoreButtonClick(
    Object^ s,
    EventArgs^ e
)
abstract DialogView_IgnoreButtonClick :
        s : Object *
        e : EventArgs -> unit
override DialogView_IgnoreButtonClick :
        s : Object *
        e : EventArgs -> unit
abstract DialogView_IgnoreButtonClick :
        s : Object *
        e : EventArgs -> unit
override DialogView_IgnoreButtonClick :
        s : Object *
        e : EventArgs -> unit
Parameters
s (Object)
e (EventArgs)


DialogView_Load Method (s, e)

Keyoti RapidSpell Desktop .NET API Docs
DialogView_Load Method (s, e)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► DialogView_Load(Object, EventArgs)
Keyoti RapidSpell Desktop .NET
Handles IDialogView event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void DialogView_Load(
    Object s,
    EventArgs e
)
public virtual void DialogView_Load(
    Object s,
    EventArgs e
)
Public Overridable Sub DialogView_Load (
    s As Object,
    e As EventArgs
)
Public Overridable Sub DialogView_Load (
    s As Object,
    e As EventArgs
)
public:
virtual void DialogView_Load(
    Object^ s,
    EventArgs^ e
)
public:
virtual void DialogView_Load(
    Object^ s,
    EventArgs^ e
)
abstract DialogView_Load :
        s : Object *
        e : EventArgs -> unit
override DialogView_Load :
        s : Object *
        e : EventArgs -> unit
abstract DialogView_Load :
        s : Object *
        e : EventArgs -> unit
override DialogView_Load :
        s : Object *
        e : EventArgs -> unit
Parameters
s (Object)
e (EventArgs)


DialogView_OptionsButtonClick Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
DialogView_OptionsButtonClick Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► DialogView_OptionsButtonClick(Object, EventArgs)
Keyoti RapidSpell Desktop .NET
Handles IDialogView event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void DialogView_OptionsButtonClick(
    Object sender,
    EventArgs e
)
public virtual void DialogView_OptionsButtonClick(
    Object sender,
    EventArgs e
)
Public Overridable Sub DialogView_OptionsButtonClick (
    sender As Object,
    e As EventArgs
)
Public Overridable Sub DialogView_OptionsButtonClick (
    sender As Object,
    e As EventArgs
)
public:
virtual void DialogView_OptionsButtonClick(
    Object^ sender,
    EventArgs^ e
)
public:
virtual void DialogView_OptionsButtonClick(
    Object^ sender,
    EventArgs^ e
)
abstract DialogView_OptionsButtonClick :
        sender : Object *
        e : EventArgs -> unit
override DialogView_OptionsButtonClick :
        sender : Object *
        e : EventArgs -> unit
abstract DialogView_OptionsButtonClick :
        sender : Object *
        e : EventArgs -> unit
override DialogView_OptionsButtonClick :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


DialogView_QueryTextBoxEnter Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
DialogView_QueryTextBoxEnter Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► DialogView_QueryTextBoxEnter(Object, EventArgs)
Keyoti RapidSpell Desktop .NET
Handles IDialogView event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void DialogView_QueryTextBoxEnter(
    Object sender,
    EventArgs e
)
public virtual void DialogView_QueryTextBoxEnter(
    Object sender,
    EventArgs e
)
Public Overridable Sub DialogView_QueryTextBoxEnter (
    sender As Object,
    e As EventArgs
)
Public Overridable Sub DialogView_QueryTextBoxEnter (
    sender As Object,
    e As EventArgs
)
public:
virtual void DialogView_QueryTextBoxEnter(
    Object^ sender,
    EventArgs^ e
)
public:
virtual void DialogView_QueryTextBoxEnter(
    Object^ sender,
    EventArgs^ e
)
abstract DialogView_QueryTextBoxEnter :
        sender : Object *
        e : EventArgs -> unit
override DialogView_QueryTextBoxEnter :
        sender : Object *
        e : EventArgs -> unit
abstract DialogView_QueryTextBoxEnter :
        sender : Object *
        e : EventArgs -> unit
override DialogView_QueryTextBoxEnter :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


DialogView_QueryTextBoxTextChanged Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
DialogView_QueryTextBoxTextChanged Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► DialogView_QueryTextBoxTextChanged(Object, EventArgs)
Keyoti RapidSpell Desktop .NET
Handles IDialogView event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void DialogView_QueryTextBoxTextChanged(
    Object sender,
    EventArgs e
)
public virtual void DialogView_QueryTextBoxTextChanged(
    Object sender,
    EventArgs e
)
Public Overridable Sub DialogView_QueryTextBoxTextChanged (
    sender As Object,
    e As EventArgs
)
Public Overridable Sub DialogView_QueryTextBoxTextChanged (
    sender As Object,
    e As EventArgs
)
public:
virtual void DialogView_QueryTextBoxTextChanged(
    Object^ sender,
    EventArgs^ e
)
public:
virtual void DialogView_QueryTextBoxTextChanged(
    Object^ sender,
    EventArgs^ e
)
abstract DialogView_QueryTextBoxTextChanged :
        sender : Object *
        e : EventArgs -> unit
override DialogView_QueryTextBoxTextChanged :
        sender : Object *
        e : EventArgs -> unit
abstract DialogView_QueryTextBoxTextChanged :
        sender : Object *
        e : EventArgs -> unit
override DialogView_QueryTextBoxTextChanged :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


DialogView_SuggestionsListDoubleClick Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
DialogView_SuggestionsListDoubleClick Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► DialogView_SuggestionsListDoubleClick(Object, EventArgs)
Keyoti RapidSpell Desktop .NET
Handles IDialogView event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void DialogView_SuggestionsListDoubleClick(
    Object sender,
    EventArgs e
)
public virtual void DialogView_SuggestionsListDoubleClick(
    Object sender,
    EventArgs e
)
Public Overridable Sub DialogView_SuggestionsListDoubleClick (
    sender As Object,
    e As EventArgs
)
Public Overridable Sub DialogView_SuggestionsListDoubleClick (
    sender As Object,
    e As EventArgs
)
public:
virtual void DialogView_SuggestionsListDoubleClick(
    Object^ sender,
    EventArgs^ e
)
public:
virtual void DialogView_SuggestionsListDoubleClick(
    Object^ sender,
    EventArgs^ e
)
abstract DialogView_SuggestionsListDoubleClick :
        sender : Object *
        e : EventArgs -> unit
override DialogView_SuggestionsListDoubleClick :
        sender : Object *
        e : EventArgs -> unit
abstract DialogView_SuggestionsListDoubleClick :
        sender : Object *
        e : EventArgs -> unit
override DialogView_SuggestionsListDoubleClick :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


DialogView_UndoButtonClick Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
DialogView_UndoButtonClick Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► DialogView_UndoButtonClick(Object, EventArgs)
Keyoti RapidSpell Desktop .NET
Handles the Undo button click
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void DialogView_UndoButtonClick(
    Object sender,
    EventArgs e
)
public virtual void DialogView_UndoButtonClick(
    Object sender,
    EventArgs e
)
Public Overridable Sub DialogView_UndoButtonClick (
    sender As Object,
    e As EventArgs
)
Public Overridable Sub DialogView_UndoButtonClick (
    sender As Object,
    e As EventArgs
)
public:
virtual void DialogView_UndoButtonClick(
    Object^ sender,
    EventArgs^ e
)
public:
virtual void DialogView_UndoButtonClick(
    Object^ sender,
    EventArgs^ e
)
abstract DialogView_UndoButtonClick :
        sender : Object *
        e : EventArgs -> unit
override DialogView_UndoButtonClick :
        sender : Object *
        e : EventArgs -> unit
abstract DialogView_UndoButtonClick :
        sender : Object *
        e : EventArgs -> unit
override DialogView_UndoButtonClick :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


DialogView_UserNeedsSuggestionsChanged Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
DialogView_UserNeedsSuggestionsChanged Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► DialogView_UserNeedsSuggestionsChanged(Object, EventArgs)
Keyoti RapidSpell Desktop .NET
Handles IDialogView event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void DialogView_UserNeedsSuggestionsChanged(
    Object sender,
    EventArgs e
)
public virtual void DialogView_UserNeedsSuggestionsChanged(
    Object sender,
    EventArgs e
)
Public Overridable Sub DialogView_UserNeedsSuggestionsChanged (
    sender As Object,
    e As EventArgs
)
Public Overridable Sub DialogView_UserNeedsSuggestionsChanged (
    sender As Object,
    e As EventArgs
)
public:
virtual void DialogView_UserNeedsSuggestionsChanged(
    Object^ sender,
    EventArgs^ e
)
public:
virtual void DialogView_UserNeedsSuggestionsChanged(
    Object^ sender,
    EventArgs^ e
)
abstract DialogView_UserNeedsSuggestionsChanged :
        sender : Object *
        e : EventArgs -> unit
override DialogView_UserNeedsSuggestionsChanged :
        sender : Object *
        e : EventArgs -> unit
abstract DialogView_UserNeedsSuggestionsChanged :
        sender : Object *
        e : EventArgs -> unit
override DialogView_UserNeedsSuggestionsChanged :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


DialogViewOptionsPresenter_CreateDialogViewOptions Method (s, ev)

Keyoti RapidSpell Desktop .NET API Docs
DialogViewOptionsPresenter_CreateDialogViewOptions Method (s, ev)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► DialogViewOptionsPresenter_CreateDialogViewOptions(Object, CreateDialogViewOptionsEventArgs)
Keyoti RapidSpell Desktop .NET
Handles IDialogView event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected internal virtual void DialogViewOptionsPresenter_CreateDialogViewOptions(
    Object s,
    CreateDialogViewOptionsEventArgs ev
)
protected internal virtual void DialogViewOptionsPresenter_CreateDialogViewOptions(
    Object s,
    CreateDialogViewOptionsEventArgs ev
)
Protected Friend Overridable Sub DialogViewOptionsPresenter_CreateDialogViewOptions (
    s As Object,
    ev As CreateDialogViewOptionsEventArgs
)
Protected Friend Overridable Sub DialogViewOptionsPresenter_CreateDialogViewOptions (
    s As Object,
    ev As CreateDialogViewOptionsEventArgs
)
protected public:
virtual void DialogViewOptionsPresenter_CreateDialogViewOptions(
    Object^ s,
    CreateDialogViewOptionsEventArgs^ ev
)
protected public:
virtual void DialogViewOptionsPresenter_CreateDialogViewOptions(
    Object^ s,
    CreateDialogViewOptionsEventArgs^ ev
)
abstract DialogViewOptionsPresenter_CreateDialogViewOptions :
        s : Object *
        ev : CreateDialogViewOptionsEventArgs -> unit
override DialogViewOptionsPresenter_CreateDialogViewOptions :
        s : Object *
        ev : CreateDialogViewOptionsEventArgs -> unit
abstract DialogViewOptionsPresenter_CreateDialogViewOptions :
        s : Object *
        ev : CreateDialogViewOptionsEventArgs -> unit
override DialogViewOptionsPresenter_CreateDialogViewOptions :
        s : Object *
        ev : CreateDialogViewOptionsEventArgs -> unit
Parameters
s (Object)
ev (CreateDialogViewOptionsEventArgs)


DialogViewOptionsPresenter_CreateDialogViewUserDictionaryEdit Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
DialogViewOptionsPresenter_CreateDialogViewUserDictionaryEdit Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► DialogViewOptionsPresenter_CreateDialogViewUserDictionaryEdit(Object, CreateDialogViewUserDictionaryEditEventArgs)
Keyoti RapidSpell Desktop .NET
Handles IDialogView event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected internal virtual void DialogViewOptionsPresenter_CreateDialogViewUserDictionaryEdit(
    Object sender,
    CreateDialogViewUserDictionaryEditEventArgs e
)
protected internal virtual void DialogViewOptionsPresenter_CreateDialogViewUserDictionaryEdit(
    Object sender,
    CreateDialogViewUserDictionaryEditEventArgs e
)
Protected Friend Overridable Sub DialogViewOptionsPresenter_CreateDialogViewUserDictionaryEdit (
    sender As Object,
    e As CreateDialogViewUserDictionaryEditEventArgs
)
Protected Friend Overridable Sub DialogViewOptionsPresenter_CreateDialogViewUserDictionaryEdit (
    sender As Object,
    e As CreateDialogViewUserDictionaryEditEventArgs
)
protected public:
virtual void DialogViewOptionsPresenter_CreateDialogViewUserDictionaryEdit(
    Object^ sender,
    CreateDialogViewUserDictionaryEditEventArgs^ e
)
protected public:
virtual void DialogViewOptionsPresenter_CreateDialogViewUserDictionaryEdit(
    Object^ sender,
    CreateDialogViewUserDictionaryEditEventArgs^ e
)
abstract DialogViewOptionsPresenter_CreateDialogViewUserDictionaryEdit :
        sender : Object *
        e : CreateDialogViewUserDictionaryEditEventArgs -> unit
override DialogViewOptionsPresenter_CreateDialogViewUserDictionaryEdit :
        sender : Object *
        e : CreateDialogViewUserDictionaryEditEventArgs -> unit
abstract DialogViewOptionsPresenter_CreateDialogViewUserDictionaryEdit :
        sender : Object *
        e : CreateDialogViewUserDictionaryEditEventArgs -> unit
override DialogViewOptionsPresenter_CreateDialogViewUserDictionaryEdit :
        sender : Object *
        e : CreateDialogViewUserDictionaryEditEventArgs -> unit
Parameters
sender (Object)
e (CreateDialogViewUserDictionaryEditEventArgs)


DialogViewOptionsPresenter_CreateDialogViewUserDictionarySelect Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
DialogViewOptionsPresenter_CreateDialogViewUserDictionarySelect Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► DialogViewOptionsPresenter_CreateDialogViewUserDictionarySelect(Object, CreateDialogViewUserDictionarySelectEventArgs)
Keyoti RapidSpell Desktop .NET
Handles IDialogView event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected internal virtual void DialogViewOptionsPresenter_CreateDialogViewUserDictionarySelect(
    Object sender,
    CreateDialogViewUserDictionarySelectEventArgs e
)
protected internal virtual void DialogViewOptionsPresenter_CreateDialogViewUserDictionarySelect(
    Object sender,
    CreateDialogViewUserDictionarySelectEventArgs e
)
Protected Friend Overridable Sub DialogViewOptionsPresenter_CreateDialogViewUserDictionarySelect (
    sender As Object,
    e As CreateDialogViewUserDictionarySelectEventArgs
)
Protected Friend Overridable Sub DialogViewOptionsPresenter_CreateDialogViewUserDictionarySelect (
    sender As Object,
    e As CreateDialogViewUserDictionarySelectEventArgs
)
protected public:
virtual void DialogViewOptionsPresenter_CreateDialogViewUserDictionarySelect(
    Object^ sender,
    CreateDialogViewUserDictionarySelectEventArgs^ e
)
protected public:
virtual void DialogViewOptionsPresenter_CreateDialogViewUserDictionarySelect(
    Object^ sender,
    CreateDialogViewUserDictionarySelectEventArgs^ e
)
abstract DialogViewOptionsPresenter_CreateDialogViewUserDictionarySelect :
        sender : Object *
        e : CreateDialogViewUserDictionarySelectEventArgs -> unit
override DialogViewOptionsPresenter_CreateDialogViewUserDictionarySelect :
        sender : Object *
        e : CreateDialogViewUserDictionarySelectEventArgs -> unit
abstract DialogViewOptionsPresenter_CreateDialogViewUserDictionarySelect :
        sender : Object *
        e : CreateDialogViewUserDictionarySelectEventArgs -> unit
override DialogViewOptionsPresenter_CreateDialogViewUserDictionarySelect :
        sender : Object *
        e : CreateDialogViewUserDictionarySelectEventArgs -> unit
Parameters
sender (Object)
e (CreateDialogViewUserDictionarySelectEventArgs)


DictFilePath Property

Keyoti RapidSpell Desktop .NET API Docs
DictFilePath Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► DictFilePath
Keyoti RapidSpell Desktop .NET
Optional file path to the main dictionary .dict file to use.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string DictFilePath { get; set; }
public string DictFilePath { get; set; }
Public Property DictFilePath As String
    Get
    Set
Public Property DictFilePath As String
    Get
    Set
public:
virtual property String^ DictFilePath {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ DictFilePath {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract DictFilePath : string with get, set
override DictFilePath : string with get, set
abstract DictFilePath : string with get, set
override DictFilePath : string with get, set
Property Value
String


Dispose Method

Keyoti RapidSpell Desktop .NET API Docs
Dispose Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► Dispose()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Dispose()()()() | Disposes of resources
 | Dispose(Boolean) | Frees up resources (Overrides Component.Dispose(Boolean).)


Dispose Method

Keyoti RapidSpell Desktop .NET API Docs
Dispose Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► Dispose()()()()
Keyoti RapidSpell Desktop .NET
Disposes of resources
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void Dispose()
public void Dispose()
Public Sub Dispose
Public Sub Dispose
public:
virtual void Dispose() sealed
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit
abstract Dispose : unit -> unit
override Dispose : unit -> unit


Dispose Method (disposing)

Keyoti RapidSpell Desktop .NET API Docs
Dispose Method (disposing)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► Dispose(Boolean)
Keyoti RapidSpell Desktop .NET
Frees up resources
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
Parameters
disposing (Boolean)


DisposeAtEnd Property

Keyoti RapidSpell Desktop .NET API Docs
DisposeAtEnd Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► DisposeAtEnd
Keyoti RapidSpell Desktop .NET
Whether to dispose of this form when spell check is finished.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool DisposeAtEnd { get; set; }
public bool DisposeAtEnd { get; set; }
Public Property DisposeAtEnd As Boolean
    Get
    Set
Public Property DisposeAtEnd As Boolean
    Get
    Set
public:
virtual property bool DisposeAtEnd {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool DisposeAtEnd {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract DisposeAtEnd : bool with get, set
override DisposeAtEnd : bool with get, set
abstract DisposeAtEnd : bool with get, set
override DisposeAtEnd : bool with get, set
Property Value
Boolean


End Method

Keyoti RapidSpell Desktop .NET API Docs
End Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► End()()()()
Keyoti RapidSpell Desktop .NET
Called when finished checking document, brings up spelling check is complete message.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void End()
protected virtual void End()
Protected Overridable Sub End
Protected Overridable Sub End
protected:
virtual void End()
protected:
virtual void End()
abstract End : unit -> unit
override End : unit -> unit
abstract End : unit -> unit
override End : unit -> unit


FindCapitalizedSuggestions Property

Keyoti RapidSpell Desktop .NET API Docs
FindCapitalizedSuggestions Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► FindCapitalizedSuggestions
Keyoti RapidSpell Desktop .NET
Whether to look for capitalized suggestions, note this will slow FindSuggestions down by about 7 times.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool FindCapitalizedSuggestions { get; set; }
public bool FindCapitalizedSuggestions { get; set; }
Public Property FindCapitalizedSuggestions As Boolean
    Get
    Set
Public Property FindCapitalizedSuggestions As Boolean
    Get
    Set
public:
virtual property bool FindCapitalizedSuggestions {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool FindCapitalizedSuggestions {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract FindCapitalizedSuggestions : bool with get, set
override FindCapitalizedSuggestions : bool with get, set
abstract FindCapitalizedSuggestions : bool with get, set
override FindCapitalizedSuggestions : bool with get, set
Property Value
Boolean


FindingSuggestionsLabelText Property

Keyoti RapidSpell Desktop .NET API Docs
FindingSuggestionsLabelText Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► FindingSuggestionsLabelText
Keyoti RapidSpell Desktop .NET
Finding suggestions label text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string FindingSuggestionsLabelText { get; set; }
public string FindingSuggestionsLabelText { get; set; }
Public Property FindingSuggestionsLabelText As String
    Get
    Set
Public Property FindingSuggestionsLabelText As String
    Get
    Set
public:
virtual property String^ FindingSuggestionsLabelText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ FindingSuggestionsLabelText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract FindingSuggestionsLabelText : string with get, set
override FindingSuggestionsLabelText : string with get, set
abstract FindingSuggestionsLabelText : string with get, set
override FindingSuggestionsLabelText : string with get, set
Property Value
String


findSuggestions Field

Keyoti RapidSpell Desktop .NET API Docs
findSuggestions Field
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► findSuggestions
Keyoti RapidSpell Desktop .NET
Whether this should look up suggestions for misspelt words or not.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected bool findSuggestions
protected bool findSuggestions
Protected findSuggestions As Boolean
Protected findSuggestions As Boolean
protected:
bool findSuggestions
protected:
bool findSuggestions
val mutable findSuggestions: bool
val mutable findSuggestions: bool
Field Value
Boolean


FindSuggestionsLabelText Property

Keyoti RapidSpell Desktop .NET API Docs
FindSuggestionsLabelText Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► FindSuggestionsLabelText
Keyoti RapidSpell Desktop .NET
Find suggestions label text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string FindSuggestionsLabelText { get; set; }
public string FindSuggestionsLabelText { get; set; }
Public Property FindSuggestionsLabelText As String
    Get
    Set
Public Property FindSuggestionsLabelText As String
    Get
    Set
public:
virtual property String^ FindSuggestionsLabelText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ FindSuggestionsLabelText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract FindSuggestionsLabelText : string with get, set
override FindSuggestionsLabelText : string with get, set
abstract FindSuggestionsLabelText : string with get, set
override FindSuggestionsLabelText : string with get, set
Property Value
String


FindWordEnd Method (fromPos)

Keyoti RapidSpell Desktop .NET API Docs
FindWordEnd Method (fromPos)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► FindWordEnd(Int32)
Keyoti RapidSpell Desktop .NET
Returns the end of the word that fromPos is in.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual int FindWordEnd(
    int fromPos
)
protected virtual int FindWordEnd(
    int fromPos
)
Protected Overridable Function FindWordEnd (
    fromPos As Integer
) As Integer
Protected Overridable Function FindWordEnd (
    fromPos As Integer
) As Integer
protected:
virtual int FindWordEnd(
    int fromPos
)
protected:
virtual int FindWordEnd(
    int fromPos
)
abstract FindWordEnd :
        fromPos : int -> int
override FindWordEnd :
        fromPos : int -> int
abstract FindWordEnd :
        fromPos : int -> int
override FindWordEnd :
        fromPos : int -> int
Parameters
fromPos (Int32)
Return Value
Int32


FinishedCheckingSelectionPopUpText Property

Keyoti RapidSpell Desktop .NET API Docs
FinishedCheckingSelectionPopUpText Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► FinishedCheckingSelectionPopUpText
Keyoti RapidSpell Desktop .NET
Finished checking selection dialog text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string FinishedCheckingSelectionPopUpText { get; set; }
public string FinishedCheckingSelectionPopUpText { get; set; }
Public Property FinishedCheckingSelectionPopUpText As String
    Get
    Set
Public Property FinishedCheckingSelectionPopUpText As String
    Get
    Set
public:
virtual property String^ FinishedCheckingSelectionPopUpText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ FinishedCheckingSelectionPopUpText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract FinishedCheckingSelectionPopUpText : string with get, set
override FinishedCheckingSelectionPopUpText : string with get, set
abstract FinishedCheckingSelectionPopUpText : string with get, set
override FinishedCheckingSelectionPopUpText : string with get, set
Property Value
String


FinishedCheckingSelectionPopUpTitle Property

Keyoti RapidSpell Desktop .NET API Docs
FinishedCheckingSelectionPopUpTitle Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► FinishedCheckingSelectionPopUpTitle
Keyoti RapidSpell Desktop .NET
Finished checking selection dialog title
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string FinishedCheckingSelectionPopUpTitle { get; set; }
public string FinishedCheckingSelectionPopUpTitle { get; set; }
Public Property FinishedCheckingSelectionPopUpTitle As String
    Get
    Set
Public Property FinishedCheckingSelectionPopUpTitle As String
    Get
    Set
public:
virtual property String^ FinishedCheckingSelectionPopUpTitle {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ FinishedCheckingSelectionPopUpTitle {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract FinishedCheckingSelectionPopUpTitle : string with get, set
override FinishedCheckingSelectionPopUpTitle : string with get, set
abstract FinishedCheckingSelectionPopUpTitle : string with get, set
override FinishedCheckingSelectionPopUpTitle : string with get, set
Property Value
String


FocusGained Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
FocusGained Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► FocusGained(Object, EventArgs)
Keyoti RapidSpell Desktop .NET
Called when objects whose focus this is listening to gain focus.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void FocusGained(
    Object sender,
    EventArgs e
)
protected virtual void FocusGained(
    Object sender,
    EventArgs e
)
Protected Overridable Sub FocusGained (
    sender As Object,
    e As EventArgs
)
Protected Overridable Sub FocusGained (
    sender As Object,
    e As EventArgs
)
protected:
virtual void FocusGained(
    Object^ sender,
    EventArgs^ e
)
protected:
virtual void FocusGained(
    Object^ sender,
    EventArgs^ e
)
abstract FocusGained :
        sender : Object *
        e : EventArgs -> unit
override FocusGained :
        sender : Object *
        e : EventArgs -> unit
abstract FocusGained :
        sender : Object *
        e : EventArgs -> unit
override FocusGained :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


fromPosition Field

Keyoti RapidSpell Desktop .NET API Docs
fromPosition Field
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► fromPosition
Keyoti RapidSpell Desktop .NET
Where the user wants to check from in the document
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected int fromPosition
protected int fromPosition
Protected fromPosition As Integer
Protected fromPosition As Integer
protected:
int fromPosition
protected:
int fromPosition
val mutable fromPosition: int
val mutable fromPosition: int
Field Value
Int32


GenerateSentenceParts Method (preEnd, postStart)

Keyoti RapidSpell Desktop .NET API Docs
GenerateSentenceParts Method (preEnd, postStart)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► GenerateSentenceParts(Int32, Int32)
Keyoti RapidSpell Desktop .NET
Finds the sentence up to a point and the sentence after a point
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual string[] GenerateSentenceParts(
    int preEnd,
    int postStart
)
protected virtual string[] GenerateSentenceParts(
    int preEnd,
    int postStart
)
Protected Overridable Function GenerateSentenceParts (
    preEnd As Integer,
    postStart As Integer
) As String()
Protected Overridable Function GenerateSentenceParts (
    preEnd As Integer,
    postStart As Integer
) As String()
protected:
virtual array<String^>^ GenerateSentenceParts(
    int preEnd,
    int postStart
)
protected:
virtual array<String^>^ GenerateSentenceParts(
    int preEnd,
    int postStart
)
abstract GenerateSentenceParts :
        preEnd : int *
        postStart : int -> string[]
override GenerateSentenceParts :
        preEnd : int *
        postStart : int -> string[]
abstract GenerateSentenceParts :
        preEnd : int *
        postStart : int -> string[]
override GenerateSentenceParts :
        preEnd : int *
        postStart : int -> string[]
Parameters
preEnd (Int32)
The point at which the first part of the sentence ends
postStart (Int32)
The point at which the second part of the sentence starts
Return Value
array< String >[]()[][]
A 2 element string array holding the sentence up to preEnd in the first element and the sentence after postStart in the second element. The intention is that preEnd is the beginning of a misspelled word and postStart is the end of a misspelled word. The sentence parts are then used as context in the query dialog box.


GetConsiderationRange Method

Keyoti RapidSpell Desktop .NET API Docs
GetConsiderationRange Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► GetConsiderationRange()()()()
Keyoti RapidSpell Desktop .NET
Gets the factor for words to consider for suggestions.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
[ObsoleteAttribute("Use ConsiderationRange instead.", true)]
public int GetConsiderationRange()
[ObsoleteAttribute("Use ConsiderationRange instead.", true)]
public int GetConsiderationRange()
<ObsoleteAttribute("Use ConsiderationRange instead.", true)>
Public Function GetConsiderationRange As Integer
<ObsoleteAttribute("Use ConsiderationRange instead.", true)>
Public Function GetConsiderationRange As Integer
public:
[ObsoleteAttribute(L"Use ConsiderationRange instead.", true)]
int GetConsiderationRange()
public:
[ObsoleteAttribute(L"Use ConsiderationRange instead.", true)]
int GetConsiderationRange()
[<ObsoleteAttribute("Use ConsiderationRange instead.", true)>]
member GetConsiderationRange : unit -> int

[<ObsoleteAttribute("Use ConsiderationRange instead.", true)>]
member GetConsiderationRange : unit -> int
Return Value
Int32


GetIgnoreCapitalizedWords Method

Keyoti RapidSpell Desktop .NET API Docs
GetIgnoreCapitalizedWords Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► GetIgnoreCapitalizedWords()()()()
Keyoti RapidSpell Desktop .NET
Gets whether to ignore words with capital letters.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
[ObsoleteAttribute("Use IgnoreCapitalizedWords instead.", true)]
public bool GetIgnoreCapitalizedWords()
[ObsoleteAttribute("Use IgnoreCapitalizedWords instead.", true)]
public bool GetIgnoreCapitalizedWords()
<ObsoleteAttribute("Use IgnoreCapitalizedWords instead.", true)>
Public Function GetIgnoreCapitalizedWords As Boolean
<ObsoleteAttribute("Use IgnoreCapitalizedWords instead.", true)>
Public Function GetIgnoreCapitalizedWords As Boolean
public:
[ObsoleteAttribute(L"Use IgnoreCapitalizedWords instead.", true)]
bool GetIgnoreCapitalizedWords()
public:
[ObsoleteAttribute(L"Use IgnoreCapitalizedWords instead.", true)]
bool GetIgnoreCapitalizedWords()
[<ObsoleteAttribute("Use IgnoreCapitalizedWords instead.", true)>]
member GetIgnoreCapitalizedWords : unit -> bool

[<ObsoleteAttribute("Use IgnoreCapitalizedWords instead.", true)>]
member GetIgnoreCapitalizedWords : unit -> bool
Return Value
Boolean


GetIncludeUserDictionaryInSuggestions Method

Keyoti RapidSpell Desktop .NET API Docs
GetIncludeUserDictionaryInSuggestions Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► GetIncludeUserDictionaryInSuggestions()()()()
Keyoti RapidSpell Desktop .NET
Gets whether the user dictionary should be used in finding suggestions for misspelt words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
[ObsoleteAttribute("Use IncludeUserDictionaryInSuggestions instead.",
    true)]
public bool GetIncludeUserDictionaryInSuggestions()
[ObsoleteAttribute("Use IncludeUserDictionaryInSuggestions instead.",
    true)]
public bool GetIncludeUserDictionaryInSuggestions()
<ObsoleteAttribute("Use IncludeUserDictionaryInSuggestions instead.",
    true)>
Public Function GetIncludeUserDictionaryInSuggestions As Boolean
<ObsoleteAttribute("Use IncludeUserDictionaryInSuggestions instead.",
    true)>
Public Function GetIncludeUserDictionaryInSuggestions As Boolean
public:
[ObsoleteAttribute(L"Use IncludeUserDictionaryInSuggestions instead.",
    true)]
virtual bool GetIncludeUserDictionaryInSuggestions() sealed
public:
[ObsoleteAttribute(L"Use IncludeUserDictionaryInSuggestions instead.",
    true)]
virtual bool GetIncludeUserDictionaryInSuggestions() sealed
[<ObsoleteAttribute("Use IncludeUserDictionaryInSuggestions instead.",
    true)>]
abstract GetIncludeUserDictionaryInSuggestions : unit -> bool
[<ObsoleteAttribute("Use IncludeUserDictionaryInSuggestions instead.",
    true)>]
override GetIncludeUserDictionaryInSuggestions : unit -> bool
[<ObsoleteAttribute("Use IncludeUserDictionaryInSuggestions instead.",
    true)>]
abstract GetIncludeUserDictionaryInSuggestions : unit -> bool
[<ObsoleteAttribute("Use IncludeUserDictionaryInSuggestions instead.",
    true)>]
override GetIncludeUserDictionaryInSuggestions : unit -> bool
Return Value
Boolean


GetSeparateHyphenWords Method

Keyoti RapidSpell Desktop .NET API Docs
GetSeparateHyphenWords Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► GetSeparateHyphenWords()()()()
Keyoti RapidSpell Desktop .NET
Gets whether to treat hyphenated (-) words as separate words, default is false.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
[ObsoleteAttribute("Use SeparateHyphenWords instead.", true)]
public bool GetSeparateHyphenWords()
[ObsoleteAttribute("Use SeparateHyphenWords instead.", true)]
public bool GetSeparateHyphenWords()
<ObsoleteAttribute("Use SeparateHyphenWords instead.", true)>
Public Function GetSeparateHyphenWords As Boolean
<ObsoleteAttribute("Use SeparateHyphenWords instead.", true)>
Public Function GetSeparateHyphenWords As Boolean
public:
[ObsoleteAttribute(L"Use SeparateHyphenWords instead.", true)]
virtual bool GetSeparateHyphenWords() sealed
public:
[ObsoleteAttribute(L"Use SeparateHyphenWords instead.", true)]
virtual bool GetSeparateHyphenWords() sealed
[<ObsoleteAttribute("Use SeparateHyphenWords instead.", true)>]
abstract GetSeparateHyphenWords : unit -> bool
[<ObsoleteAttribute("Use SeparateHyphenWords instead.", true)>]
override GetSeparateHyphenWords : unit -> bool
[<ObsoleteAttribute("Use SeparateHyphenWords instead.", true)>]
abstract GetSeparateHyphenWords : unit -> bool
[<ObsoleteAttribute("Use SeparateHyphenWords instead.", true)>]
override GetSeparateHyphenWords : unit -> bool
Return Value
Boolean
Remarks
For eg. if this is true text like "cheap-deals" will be treated as two words "cheap" and "deals", otherwise this will be treated as one word "cheap-deals".


GUILanguage Property

Keyoti RapidSpell Desktop .NET API Docs
GUILanguage Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► GUILanguage
Keyoti RapidSpell Desktop .NET
The language to show the UI in.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public LanguageType GUILanguage { get; set; }
public LanguageType GUILanguage { get; set; }
Public Property GUILanguage As LanguageType
    Get
    Set
Public Property GUILanguage As LanguageType
    Get
    Set
public:
virtual property LanguageType GUILanguage {
    LanguageType get () sealed;
    void set (LanguageType value) sealed;
}
public:
virtual property LanguageType GUILanguage {
    LanguageType get () sealed;
    void set (LanguageType value) sealed;
}
abstract GUILanguage : LanguageType with get, set
override GUILanguage : LanguageType with get, set
abstract GUILanguage : LanguageType with get, set
override GUILanguage : LanguageType with get, set
Property Value
LanguageType


guiShowing Field

Keyoti RapidSpell Desktop .NET API Docs
guiShowing Field
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► guiShowing
Keyoti RapidSpell Desktop .NET
Whether the gui is currently showing
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected bool guiShowing
protected bool guiShowing
Protected guiShowing As Boolean
Protected guiShowing As Boolean
protected:
bool guiShowing
protected:
bool guiShowing
val mutable guiShowing: bool
val mutable guiShowing: bool
Field Value
Boolean


Ignore Method

Keyoti RapidSpell Desktop .NET API Docs
Ignore Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► Ignore()()()()
Keyoti RapidSpell Desktop .NET
Ignore the current bad word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void Ignore()
protected virtual void Ignore()
Protected Overridable Sub Ignore
Protected Overridable Sub Ignore
protected:
virtual void Ignore()
protected:
virtual void Ignore()
abstract Ignore : unit -> unit
override Ignore : unit -> unit
abstract Ignore : unit -> unit
override Ignore : unit -> unit
Return Value

void


IgnoreAll Method

Keyoti RapidSpell Desktop .NET API Docs
IgnoreAll Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► IgnoreAll()()()()
Keyoti RapidSpell Desktop .NET
Ignores all occurrences of this word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void IgnoreAll()
protected virtual void IgnoreAll()
Protected Overridable Sub IgnoreAll
Protected Overridable Sub IgnoreAll
protected:
virtual void IgnoreAll()
protected:
virtual void IgnoreAll()
abstract IgnoreAll : unit -> unit
override IgnoreAll : unit -> unit
abstract IgnoreAll : unit -> unit
override IgnoreAll : unit -> unit
Return Value

void


IgnoreAllButtonText Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreAllButtonText Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► IgnoreAllButtonText
Keyoti RapidSpell Desktop .NET
Ignore All button text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string IgnoreAllButtonText { get; set; }
public string IgnoreAllButtonText { get; set; }
Public Property IgnoreAllButtonText As String
    Get
    Set
Public Property IgnoreAllButtonText As String
    Get
    Set
public:
virtual property String^ IgnoreAllButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ IgnoreAllButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract IgnoreAllButtonText : string with get, set
override IgnoreAllButtonText : string with get, set
abstract IgnoreAllButtonText : string with get, set
override IgnoreAllButtonText : string with get, set
Property Value
String


IgnoreButtonText Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreButtonText Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► IgnoreButtonText
Keyoti RapidSpell Desktop .NET
Ignore button text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string IgnoreButtonText { get; set; }
public string IgnoreButtonText { get; set; }
Public Property IgnoreButtonText As String
    Get
    Set
Public Property IgnoreButtonText As String
    Get
    Set
public:
virtual property String^ IgnoreButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ IgnoreButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract IgnoreButtonText : string with get, set
override IgnoreButtonText : string with get, set
abstract IgnoreButtonText : string with get, set
override IgnoreButtonText : string with get, set
Property Value
String


IgnoreCapitalizedWords Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreCapitalizedWords Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► IgnoreCapitalizedWords
Keyoti RapidSpell Desktop .NET
Whether to ignore words with capital letters.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreCapitalizedWords { get; set; }
public bool IgnoreCapitalizedWords { get; set; }
Public Property IgnoreCapitalizedWords As Boolean
    Get
    Set
Public Property IgnoreCapitalizedWords As Boolean
    Get
    Set
public:
virtual property bool IgnoreCapitalizedWords {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool IgnoreCapitalizedWords {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IgnoreCapitalizedWords : bool with get, set
override IgnoreCapitalizedWords : bool with get, set
abstract IgnoreCapitalizedWords : bool with get, set
override IgnoreCapitalizedWords : bool with get, set
Property Value
Boolean


IgnoreIncorrectSentenceCapitalization Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreIncorrectSentenceCapitalization Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► IgnoreIncorrectSentenceCapitalization
Keyoti RapidSpell Desktop .NET
Whether to ignore incorrect sentence capitalization.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreIncorrectSentenceCapitalization { get; set; }
public bool IgnoreIncorrectSentenceCapitalization { get; set; }
Public Property IgnoreIncorrectSentenceCapitalization As Boolean
    Get
    Set
Public Property IgnoreIncorrectSentenceCapitalization As Boolean
    Get
    Set
public:
virtual property bool IgnoreIncorrectSentenceCapitalization {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool IgnoreIncorrectSentenceCapitalization {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IgnoreIncorrectSentenceCapitalization : bool with get, set
override IgnoreIncorrectSentenceCapitalization : bool with get, set
abstract IgnoreIncorrectSentenceCapitalization : bool with get, set
override IgnoreIncorrectSentenceCapitalization : bool with get, set
Property Value
Boolean


IgnoreInEnglishLowerCaseI Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreInEnglishLowerCaseI Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► IgnoreInEnglishLowerCaseI
Keyoti RapidSpell Desktop .NET
Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreInEnglishLowerCaseI { get; set; }
public bool IgnoreInEnglishLowerCaseI { get; set; }
Public Property IgnoreInEnglishLowerCaseI As Boolean
    Get
    Set
Public Property IgnoreInEnglishLowerCaseI As Boolean
    Get
    Set
public:
virtual property bool IgnoreInEnglishLowerCaseI {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool IgnoreInEnglishLowerCaseI {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IgnoreInEnglishLowerCaseI : bool with get, set
override IgnoreInEnglishLowerCaseI : bool with get, set
abstract IgnoreInEnglishLowerCaseI : bool with get, set
override IgnoreInEnglishLowerCaseI : bool with get, set
Property Value
Boolean


IgnoreWordsWithDigits Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreWordsWithDigits Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► IgnoreWordsWithDigits
Keyoti RapidSpell Desktop .NET
Whether to ignore words with numbers in them (eg. A10 or 7-11).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreWordsWithDigits { get; set; }
public bool IgnoreWordsWithDigits { get; set; }
Public Property IgnoreWordsWithDigits As Boolean
    Get
    Set
Public Property IgnoreWordsWithDigits As Boolean
    Get
    Set
public:
virtual property bool IgnoreWordsWithDigits {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool IgnoreWordsWithDigits {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IgnoreWordsWithDigits : bool with get, set
override IgnoreWordsWithDigits : bool with get, set
abstract IgnoreWordsWithDigits : bool with get, set
override IgnoreWordsWithDigits : bool with get, set
Property Value
Boolean


IgnoreXML Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreXML Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► IgnoreXML
Keyoti RapidSpell Desktop .NET
Whether to ignore XML/HTML tags, false by default.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreXML { get; set; }
public bool IgnoreXML { get; set; }
Public Property IgnoreXML As Boolean
    Get
    Set
Public Property IgnoreXML As Boolean
    Get
    Set
public:
virtual property bool IgnoreXML {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool IgnoreXML {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IgnoreXML : bool with get, set
override IgnoreXML : bool with get, set
abstract IgnoreXML : bool with get, set
override IgnoreXML : bool with get, set
Property Value
Boolean
Remarks
This identifies XML tags as anything in between < and > characters, there for it will cause undesirable effects in text such as "the sign for less than is < and the sign for greater than is >". Of course in HTML that should have been written as "the sign for less than is &lt; and the sign for greater than is &gt;" anyway, which would be fine.


IncludeUserDictionaryInSuggestions Property

Keyoti RapidSpell Desktop .NET API Docs
IncludeUserDictionaryInSuggestions Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► IncludeUserDictionaryInSuggestions
Keyoti RapidSpell Desktop .NET
Whether the user dictionary should be used in finding suggestions for misspelt words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IncludeUserDictionaryInSuggestions { get; set; }
public bool IncludeUserDictionaryInSuggestions { get; set; }
Public Property IncludeUserDictionaryInSuggestions As Boolean
    Get
    Set
Public Property IncludeUserDictionaryInSuggestions As Boolean
    Get
    Set
public:
property bool IncludeUserDictionaryInSuggestions {
    bool get ();
    void set (bool value);
}
public:
property bool IncludeUserDictionaryInSuggestions {
    bool get ();
    void set (bool value);
}
member IncludeUserDictionaryInSuggestions : bool with get, set

member IncludeUserDictionaryInSuggestions : bool with get, set
Property Value
Boolean


InDictionaryLabelText Property

Keyoti RapidSpell Desktop .NET API Docs
InDictionaryLabelText Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► InDictionaryLabelText
Keyoti RapidSpell Desktop .NET
In dictionary label text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string InDictionaryLabelText { get; set; }
public string InDictionaryLabelText { get; set; }
Public Property InDictionaryLabelText As String
    Get
    Set
Public Property InDictionaryLabelText As String
    Get
    Set
public:
virtual property String^ InDictionaryLabelText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ InDictionaryLabelText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract InDictionaryLabelText : string with get, set
override InDictionaryLabelText : string with get, set
abstract InDictionaryLabelText : string with get, set
override InDictionaryLabelText : string with get, set
Property Value
String


IsDialogViewCreated Method

Keyoti RapidSpell Desktop .NET API Docs
IsDialogViewCreated Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► IsDialogViewCreated()()()()
Keyoti RapidSpell Desktop .NET
Whether a dialog view has already been created.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IsDialogViewCreated()
public bool IsDialogViewCreated()
Public Function IsDialogViewCreated As Boolean
Public Function IsDialogViewCreated As Boolean
public:
virtual bool IsDialogViewCreated() sealed
public:
virtual bool IsDialogViewCreated() sealed
abstract IsDialogViewCreated : unit -> bool
override IsDialogViewCreated : unit -> bool
abstract IsDialogViewCreated : unit -> bool
override IsDialogViewCreated : unit -> bool
Return Value
Boolean


IsDisposed Property

Keyoti RapidSpell Desktop .NET API Docs
IsDisposed Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► IsDisposed
Keyoti RapidSpell Desktop .NET
Whether the IDialogView is disposed of
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IsDisposed { get; }
public bool IsDisposed { get; }
Public ReadOnly Property IsDisposed As Boolean
    Get
Public ReadOnly Property IsDisposed As Boolean
    Get
public:
property bool IsDisposed {
    bool get ();
}
public:
property bool IsDisposed {
    bool get ();
}
member IsDisposed : bool with get

member IsDisposed : bool with get
Property Value
Boolean


IsShowFinishedMessageBox Method

Keyoti RapidSpell Desktop .NET API Docs
IsShowFinishedMessageBox Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► IsShowFinishedMessageBox()()()()
Keyoti RapidSpell Desktop .NET
Returns whether a message box should be opened when the spell check is complete.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
[ObsoleteAttribute("Use ShowFinishedMessageBox instead.", true)]
public bool IsShowFinishedMessageBox()
[ObsoleteAttribute("Use ShowFinishedMessageBox instead.", true)]
public bool IsShowFinishedMessageBox()
<ObsoleteAttribute("Use ShowFinishedMessageBox instead.", true)>
Public Function IsShowFinishedMessageBox As Boolean
<ObsoleteAttribute("Use ShowFinishedMessageBox instead.", true)>
Public Function IsShowFinishedMessageBox As Boolean
public:
[ObsoleteAttribute(L"Use ShowFinishedMessageBox instead.", true)]
virtual bool IsShowFinishedMessageBox() sealed
public:
[ObsoleteAttribute(L"Use ShowFinishedMessageBox instead.", true)]
virtual bool IsShowFinishedMessageBox() sealed
[<ObsoleteAttribute("Use ShowFinishedMessageBox instead.", true)>]
abstract IsShowFinishedMessageBox : unit -> bool
[<ObsoleteAttribute("Use ShowFinishedMessageBox instead.", true)>]
override IsShowFinishedMessageBox : unit -> bool
[<ObsoleteAttribute("Use ShowFinishedMessageBox instead.", true)>]
abstract IsShowFinishedMessageBox : unit -> bool
[<ObsoleteAttribute("Use ShowFinishedMessageBox instead.", true)>]
override IsShowFinishedMessageBox : unit -> bool
Return Value
Boolean
true if the message box should be opened, false otherwise.


LanguageParser Property

Keyoti RapidSpell Desktop .NET API Docs
LanguageParser Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► LanguageParser
Keyoti RapidSpell Desktop .NET
The type of language parsing to use.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public LanguageType LanguageParser { get; set; }
public LanguageType LanguageParser { get; set; }
Public Property LanguageParser As LanguageType
    Get
    Set
Public Property LanguageParser As LanguageType
    Get
    Set
public:
virtual property LanguageType LanguageParser {
    LanguageType get () sealed;
    void set (LanguageType value) sealed;
}
public:
virtual property LanguageType LanguageParser {
    LanguageType get () sealed;
    void set (LanguageType value) sealed;
}
abstract LanguageParser : LanguageType with get, set
override LanguageParser : LanguageType with get, set
abstract LanguageParser : LanguageType with get, set
override LanguageParser : LanguageType with get, set
Property Value
LanguageType
Remarks
Eg. If the dictionary is set to French, you should use the French parser.


Load Event

Keyoti RapidSpell Desktop .NET API Docs
Load Event
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► Load
Keyoti RapidSpell Desktop .NET
Fired when the DialogView loads.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler Load
public event EventHandler Load
Public Event Load As EventHandler
Public Event Load As EventHandler
public:
virtual  event EventHandler^ Load {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ Load {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Load : IEvent<EventHandler,
    EventArgs>
override Load : IEvent<EventHandler,
    EventArgs>
abstract Load : IEvent<EventHandler,
    EventArgs>
override Load : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


Location Property

Keyoti RapidSpell Desktop .NET API Docs
Location Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► Location
Keyoti RapidSpell Desktop .NET
Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Point Location { get; set; }
public Point Location { get; set; }
Public Property Location As Point
    Get
    Set
Public Property Location As Point
    Get
    Set
public:
property Point Location {
    Point get ();
    void set (Point value);
}
public:
property Point Location {
    Point get ();
    void set (Point value);
}
member Location : Point with get, set

member Location : Point with get, set
Property Value
Point


LookIntoHyphenatedText Property

Keyoti RapidSpell Desktop .NET API Docs
LookIntoHyphenatedText Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► LookIntoHyphenatedText
Keyoti RapidSpell Desktop .NET
Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool LookIntoHyphenatedText { get; set; }
public bool LookIntoHyphenatedText { get; set; }
Public Property LookIntoHyphenatedText As Boolean
    Get
    Set
Public Property LookIntoHyphenatedText As Boolean
    Get
    Set
public:
virtual property bool LookIntoHyphenatedText {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool LookIntoHyphenatedText {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract LookIntoHyphenatedText : bool with get, set
override LookIntoHyphenatedText : bool with get, set
abstract LookIntoHyphenatedText : bool with get, set
override LookIntoHyphenatedText : bool with get, set
Property Value
Boolean
Remarks
Eg. "socio-economic" will be checked as "socio" and "economic".


MakeChange Method

Keyoti RapidSpell Desktop .NET API Docs
MakeChange Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► MakeChange()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | MakeChange()()()() | Changes the current bad word for one selected from the suggestions list or entered in the query pane returns the word used.
 | MakeChange(Boolean) | Changes the current bad word for one selected from the suggestions list or entered in the query pane returns the word used.
 | MakeChange(Boolean, String, Boolean) | Changes the current bad word for one selected from the suggestions list or entered in the query pane returns the word used.


MakeChange Method

Keyoti RapidSpell Desktop .NET API Docs
MakeChange Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► MakeChange()()()()
Keyoti RapidSpell Desktop .NET
Changes the current bad word for one selected from the suggestions list or entered in the query pane returns the word used.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual string MakeChange()
protected virtual string MakeChange()
Protected Overridable Function MakeChange As String
Protected Overridable Function MakeChange As String
protected:
virtual String^ MakeChange()
protected:
virtual String^ MakeChange()
abstract MakeChange : unit -> string
override MakeChange : unit -> string
abstract MakeChange : unit -> string
override MakeChange : unit -> string
Return Value
String


MakeChange Method (inChangeAllProcess)

Keyoti RapidSpell Desktop .NET API Docs
MakeChange Method (inChangeAllProcess)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► MakeChange(Boolean)
Keyoti RapidSpell Desktop .NET
Changes the current bad word for one selected from the suggestions list or entered in the query pane returns the word used.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected string MakeChange(
    bool inChangeAllProcess
)
protected string MakeChange(
    bool inChangeAllProcess
)
Protected Function MakeChange (
    inChangeAllProcess As Boolean
) As String
Protected Function MakeChange (
    inChangeAllProcess As Boolean
) As String
protected:
String^ MakeChange(
    bool inChangeAllProcess
)
protected:
String^ MakeChange(
    bool inChangeAllProcess
)
member MakeChange :
        inChangeAllProcess : bool -> string

member MakeChange :
        inChangeAllProcess : bool -> string
Parameters
inChangeAllProcess (Boolean)
Return Value
String
Remarks
inChangeAllProcess is true if this operation is part of a 'Change All'


MakeChange Method (inChangeAllProcess, newWord, removeDuplicate)

Keyoti RapidSpell Desktop .NET API Docs
MakeChange Method (inChangeAllProcess, newWord, removeDuplicate)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► MakeChange(Boolean, String, Boolean)
Keyoti RapidSpell Desktop .NET
Changes the current bad word for one selected from the suggestions list or entered in the query pane returns the word used.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual string MakeChange(
    bool inChangeAllProcess,
    string newWord,
    bool removeDuplicate
)
protected virtual string MakeChange(
    bool inChangeAllProcess,
    string newWord,
    bool removeDuplicate
)
Protected Overridable Function MakeChange (
    inChangeAllProcess As Boolean,
    newWord As String,
    removeDuplicate As Boolean
) As String
Protected Overridable Function MakeChange (
    inChangeAllProcess As Boolean,
    newWord As String,
    removeDuplicate As Boolean
) As String
protected:
virtual String^ MakeChange(
    bool inChangeAllProcess,
    String^ newWord,
    bool removeDuplicate
)
protected:
virtual String^ MakeChange(
    bool inChangeAllProcess,
    String^ newWord,
    bool removeDuplicate
)
abstract MakeChange :
        inChangeAllProcess : bool *
        newWord : string *
        removeDuplicate : bool -> string
override MakeChange :
        inChangeAllProcess : bool *
        newWord : string *
        removeDuplicate : bool -> string
abstract MakeChange :
        inChangeAllProcess : bool *
        newWord : string *
        removeDuplicate : bool -> string
override MakeChange :
        inChangeAllProcess : bool *
        newWord : string *
        removeDuplicate : bool -> string
Parameters
inChangeAllProcess (Boolean)
newWord (String)
removeDuplicate (Boolean)
Return Value
String
Remarks
inChangeAllProcess is true if this operation is part of a 'Change All'


MaximumContextualWords Property

Keyoti RapidSpell Desktop .NET API Docs
MaximumContextualWords Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► MaximumContextualWords
Keyoti RapidSpell Desktop .NET
The maximum number of words to show the user in the sentence around misspelled words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int MaximumContextualWords { get; set; }
public int MaximumContextualWords { get; set; }
Public Property MaximumContextualWords As Integer
    Get
    Set
Public Property MaximumContextualWords As Integer
    Get
    Set
public:
virtual property int MaximumContextualWords {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int MaximumContextualWords {
    int get () sealed;
    void set (int value) sealed;
}
abstract MaximumContextualWords : int with get, set
override MaximumContextualWords : int with get, set
abstract MaximumContextualWords : int with get, set
override MaximumContextualWords : int with get, set
Property Value
Int32


ModalAutoDispose Property

Keyoti RapidSpell Desktop .NET API Docs
ModalAutoDispose Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► ModalAutoDispose
Keyoti RapidSpell Desktop .NET
When running modally, determines if the dialog will be disposed of when spell check finishes.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ModalAutoDispose { get; set; }
public bool ModalAutoDispose { get; set; }
Public Property ModalAutoDispose As Boolean
    Get
    Set
Public Property ModalAutoDispose As Boolean
    Get
    Set
public:
virtual property bool ModalAutoDispose {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool ModalAutoDispose {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract ModalAutoDispose : bool with get, set
override ModalAutoDispose : bool with get, set
abstract ModalAutoDispose : bool with get, set
override ModalAutoDispose : bool with get, set
Property Value
Boolean
Remarks
If a modal form disposes of itself, there will be slight flickering on the screen, to prevent this, set this property to false and call Dispose() when finished with this control.


ModalMode Property

Keyoti RapidSpell Desktop .NET API Docs
ModalMode Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► ModalMode
Keyoti RapidSpell Desktop .NET
Whether the spell checker will run modally. (Modal operation blocks the parent form)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ModalMode { get; set; }
public bool ModalMode { get; set; }
Public Property ModalMode As Boolean
    Get
    Set
Public Property ModalMode As Boolean
    Get
    Set
public:
virtual property bool ModalMode {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool ModalMode {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract ModalMode : bool with get, set
override ModalMode : bool with get, set
abstract ModalMode : bool with get, set
override ModalMode : bool with get, set
Property Value
Boolean


ModalOwner Property

Keyoti RapidSpell Desktop .NET API Docs
ModalOwner Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► ModalOwner
Keyoti RapidSpell Desktop .NET
The modal dialog owner window.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Object ModalOwner { get; set; }
public Object ModalOwner { get; set; }
Public Property ModalOwner As Object
    Get
    Set
Public Property ModalOwner As Object
    Get
    Set
public:
virtual property Object^ ModalOwner {
    Object^ get () sealed;
    void set (Object^ value) sealed;
}
public:
virtual property Object^ ModalOwner {
    Object^ get () sealed;
    void set (Object^ value) sealed;
}
abstract ModalOwner : Object with get, set
override ModalOwner : Object with get, set
abstract ModalOwner : Object with get, set
override ModalOwner : Object with get, set
Property Value
Object


MoveCaretToWordEnd Method

Keyoti RapidSpell Desktop .NET API Docs
MoveCaretToWordEnd Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► MoveCaretToWordEnd()()()()
Keyoti RapidSpell Desktop .NET
Moves the caret to the end of the word the caret is in, or where it is if not on a word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void MoveCaretToWordEnd()
protected virtual void MoveCaretToWordEnd()
Protected Overridable Sub MoveCaretToWordEnd
Protected Overridable Sub MoveCaretToWordEnd
protected:
virtual void MoveCaretToWordEnd()
protected:
virtual void MoveCaretToWordEnd()
abstract MoveCaretToWordEnd : unit -> unit
override MoveCaretToWordEnd : unit -> unit
abstract MoveCaretToWordEnd : unit -> unit
override MoveCaretToWordEnd : unit -> unit


MoveCaretToWordStart Method

Keyoti RapidSpell Desktop .NET API Docs
MoveCaretToWordStart Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► MoveCaretToWordStart()()()()
Keyoti RapidSpell Desktop .NET
Moves the caret to the start of the word the caret is in, or where it is if not on a word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void MoveCaretToWordStart()
protected virtual void MoveCaretToWordStart()
Protected Overridable Sub MoveCaretToWordStart
Protected Overridable Sub MoveCaretToWordStart
protected:
virtual void MoveCaretToWordStart()
protected:
virtual void MoveCaretToWordStart()
abstract MoveCaretToWordStart : unit -> unit
override MoveCaretToWordStart : unit -> unit
abstract MoveCaretToWordStart : unit -> unit
override MoveCaretToWordStart : unit -> unit


NoSuggestionsText Property

Keyoti RapidSpell Desktop .NET API Docs
NoSuggestionsText Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► NoSuggestionsText
Keyoti RapidSpell Desktop .NET
No suggestions found text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string NoSuggestionsText { get; set; }
public string NoSuggestionsText { get; set; }
Public Property NoSuggestionsText As String
    Get
    Set
Public Property NoSuggestionsText As String
    Get
    Set
public:
virtual property String^ NoSuggestionsText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ NoSuggestionsText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract NoSuggestionsText : string with get, set
override NoSuggestionsText : string with get, set
abstract NoSuggestionsText : string with get, set
override NoSuggestionsText : string with get, set
Property Value
String


NotInDictionaryLabelText Property

Keyoti RapidSpell Desktop .NET API Docs
NotInDictionaryLabelText Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► NotInDictionaryLabelText
Keyoti RapidSpell Desktop .NET
Not in dictionary label text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string NotInDictionaryLabelText { get; set; }
public string NotInDictionaryLabelText { get; set; }
Public Property NotInDictionaryLabelText As String
    Get
    Set
Public Property NotInDictionaryLabelText As String
    Get
    Set
public:
virtual property String^ NotInDictionaryLabelText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ NotInDictionaryLabelText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract NotInDictionaryLabelText : string with get, set
override NotInDictionaryLabelText : string with get, set
abstract NotInDictionaryLabelText : string with get, set
override NotInDictionaryLabelText : string with get, set
Property Value
String


NumberSuggestionList Property

Keyoti RapidSpell Desktop .NET API Docs
NumberSuggestionList Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► NumberSuggestionList
Keyoti RapidSpell Desktop .NET
Whether to number the items in the suggestion list, for quick user selection.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool NumberSuggestionList { get; set; }
public bool NumberSuggestionList { get; set; }
Public Property NumberSuggestionList As Boolean
    Get
    Set
Public Property NumberSuggestionList As Boolean
    Get
    Set
public:
virtual property bool NumberSuggestionList {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool NumberSuggestionList {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract NumberSuggestionList : bool with get, set
override NumberSuggestionList : bool with get, set
abstract NumberSuggestionList : bool with get, set
override NumberSuggestionList : bool with get, set
Property Value
Boolean


OnCreateDialogView Method (e)

Keyoti RapidSpell Desktop .NET API Docs
OnCreateDialogView Method (e)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► OnCreateDialogView(CreateDialogViewEventArgs)
Keyoti RapidSpell Desktop .NET
Fires the CreateDialogView event.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void OnCreateDialogView(
    CreateDialogViewEventArgs e
)
protected virtual void OnCreateDialogView(
    CreateDialogViewEventArgs e
)
Protected Overridable Sub OnCreateDialogView (
    e As CreateDialogViewEventArgs
)
Protected Overridable Sub OnCreateDialogView (
    e As CreateDialogViewEventArgs
)
protected:
virtual void OnCreateDialogView(
    CreateDialogViewEventArgs^ e
)
protected:
virtual void OnCreateDialogView(
    CreateDialogViewEventArgs^ e
)
abstract OnCreateDialogView :
        e : CreateDialogViewEventArgs -> unit
override OnCreateDialogView :
        e : CreateDialogViewEventArgs -> unit
abstract OnCreateDialogView :
        e : CreateDialogViewEventArgs -> unit
override OnCreateDialogView :
        e : CreateDialogViewEventArgs -> unit
Parameters
e (CreateDialogViewEventArgs)


OnSuggestionsDoubleClick Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
OnSuggestionsDoubleClick Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► OnSuggestionsDoubleClick(Object, EventArgs)
Keyoti RapidSpell Desktop .NET
Called when the user double clicks on a suggestion.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected void OnSuggestionsDoubleClick(
    Object sender,
    EventArgs e
)
protected void OnSuggestionsDoubleClick(
    Object sender,
    EventArgs e
)
Protected Sub OnSuggestionsDoubleClick (
    sender As Object,
    e As EventArgs
)
Protected Sub OnSuggestionsDoubleClick (
    sender As Object,
    e As EventArgs
)
protected:
void OnSuggestionsDoubleClick(
    Object^ sender,
    EventArgs^ e
)
protected:
void OnSuggestionsDoubleClick(
    Object^ sender,
    EventArgs^ e
)
member OnSuggestionsDoubleClick :
        sender : Object *
        e : EventArgs -> unit

member OnSuggestionsDoubleClick :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


OnUndone Method (e)

Keyoti RapidSpell Desktop .NET API Docs
OnUndone Method (e)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► OnUndone(UndoEventArgs)
Keyoti RapidSpell Desktop .NET
Raises the Undone event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void OnUndone(
    UndoEventArgs e
)
protected virtual void OnUndone(
    UndoEventArgs e
)
Protected Overridable Sub OnUndone (
    e As UndoEventArgs
)
Protected Overridable Sub OnUndone (
    e As UndoEventArgs
)
protected:
virtual void OnUndone(
    UndoEventArgs^ e
)
protected:
virtual void OnUndone(
    UndoEventArgs^ e
)
abstract OnUndone :
        e : UndoEventArgs -> unit
override OnUndone :
        e : UndoEventArgs -> unit
abstract OnUndone :
        e : UndoEventArgs -> unit
override OnUndone :
        e : UndoEventArgs -> unit
Parameters
e (UndoEventArgs)


OnUserQuery Method (userQueryEventArgs)

Keyoti RapidSpell Desktop .NET API Docs
OnUserQuery Method (userQueryEventArgs)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► OnUserQuery(UserQueryEventArgs)
Keyoti RapidSpell Desktop .NET
Fires the user query event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected void OnUserQuery(
    UserQueryEventArgs userQueryEventArgs
)
protected void OnUserQuery(
    UserQueryEventArgs userQueryEventArgs
)
Protected Sub OnUserQuery (
    userQueryEventArgs As UserQueryEventArgs
)
Protected Sub OnUserQuery (
    userQueryEventArgs As UserQueryEventArgs
)
protected:
void OnUserQuery(
    UserQueryEventArgs^ userQueryEventArgs
)
protected:
void OnUserQuery(
    UserQueryEventArgs^ userQueryEventArgs
)
member OnUserQuery :
        userQueryEventArgs : UserQueryEventArgs -> unit

member OnUserQuery :
        userQueryEventArgs : UserQueryEventArgs -> unit
Parameters
userQueryEventArgs (UserQueryEventArgs)


Options Property

Keyoti RapidSpell Desktop .NET API Docs
Options Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► Options
Keyoti RapidSpell Desktop .NET
Object responsible for holding, loading and saving the user's spell check options.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual UserOptions Options { get; set; }
public virtual UserOptions Options { get; set; }
Public Overridable Property Options As UserOptions
    Get
    Set
Public Overridable Property Options As UserOptions
    Get
    Set
public:
virtual property UserOptions^ Options {
    UserOptions^ get ();
    void set (UserOptions^ value);
}
public:
virtual property UserOptions^ Options {
    UserOptions^ get ();
    void set (UserOptions^ value);
}
abstract Options : UserOptions with get, set
override Options : UserOptions with get, set
abstract Options : UserOptions with get, set
override Options : UserOptions with get, set
Property Value
UserOptions
Remarks
To customize how the user's options are saved/loaded, subclass UserOptions and set an instance in this property.


OptionsButtonText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsButtonText Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► OptionsButtonText
Keyoti RapidSpell Desktop .NET
Options button text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsButtonText { get; set; }
public string OptionsButtonText { get; set; }
Public Property OptionsButtonText As String
    Get
    Set
Public Property OptionsButtonText As String
    Get
    Set
public:
virtual property String^ OptionsButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ OptionsButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract OptionsButtonText : string with get, set
override OptionsButtonText : string with get, set
abstract OptionsButtonText : string with get, set
override OptionsButtonText : string with get, set
Property Value
String


OptionsPresenter Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsPresenter Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► OptionsPresenter
Keyoti RapidSpell Desktop .NET
Presenter for the user options form (IDialogViewOptions).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual OptionsPresenter OptionsPresenter { get; set; }
public virtual OptionsPresenter OptionsPresenter { get; set; }
Public Overridable Property OptionsPresenter As OptionsPresenter
    Get
    Set
Public Overridable Property OptionsPresenter As OptionsPresenter
    Get
    Set
public:
virtual property OptionsPresenter^ OptionsPresenter {
    OptionsPresenter^ get ();
    void set (OptionsPresenter^ value);
}
public:
virtual property OptionsPresenter^ OptionsPresenter {
    OptionsPresenter^ get ();
    void set (OptionsPresenter^ value);
}
abstract OptionsPresenter : OptionsPresenter with get, set
override OptionsPresenter : OptionsPresenter with get, set
abstract OptionsPresenter : OptionsPresenter with get, set
override OptionsPresenter : OptionsPresenter with get, set
Property Value
OptionsPresenter
Remarks
Set properties in this instance to affect the options shown to the user, or handle CreateDialogViewOptions to create your own IDialogViewOptions form instance.


ProceedFromEnd Method

Keyoti RapidSpell Desktop .NET API Docs
ProceedFromEnd Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► ProceedFromEnd()()()()
Keyoti RapidSpell Desktop .NET
Decides what to do once reached end of required text check region
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void ProceedFromEnd()
protected virtual void ProceedFromEnd()
Protected Overridable Sub ProceedFromEnd
Protected Overridable Sub ProceedFromEnd
protected:
virtual void ProceedFromEnd()
protected:
virtual void ProceedFromEnd()
abstract ProceedFromEnd : unit -> unit
override ProceedFromEnd : unit -> unit
abstract ProceedFromEnd : unit -> unit
override ProceedFromEnd : unit -> unit


QueryTextBoxMultiline Property

Keyoti RapidSpell Desktop .NET API Docs
QueryTextBoxMultiline Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► QueryTextBoxMultiline
Keyoti RapidSpell Desktop .NET
Whether 'not in dictionary' text box is multiline or single line.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool QueryTextBoxMultiline { get; set; }
public bool QueryTextBoxMultiline { get; set; }
Public Property QueryTextBoxMultiline As Boolean
    Get
    Set
Public Property QueryTextBoxMultiline As Boolean
    Get
    Set
public:
property bool QueryTextBoxMultiline {
    bool get ();
    void set (bool value);
}
public:
property bool QueryTextBoxMultiline {
    bool get ();
    void set (bool value);
}
member QueryTextBoxMultiline : bool with get, set

member QueryTextBoxMultiline : bool with get, set
Property Value
Boolean


Ready Event

Keyoti RapidSpell Desktop .NET API Docs
Ready Event
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► Ready
Keyoti RapidSpell Desktop .NET
Fired when ready to proceed with first query.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler Ready
public event EventHandler Ready
Public Event Ready As EventHandler
Public Event Ready As EventHandler
public:
virtual  event EventHandler^ Ready {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ Ready {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Ready : IEvent<EventHandler,
    EventArgs>
override Ready : IEvent<EventHandler,
    EventArgs>
abstract Ready : IEvent<EventHandler,
    EventArgs>
override Ready : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


RecheckDocumentRequest Event

Keyoti RapidSpell Desktop .NET API Docs
RecheckDocumentRequest Event
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► RecheckDocumentRequest
Keyoti RapidSpell Desktop .NET
Fired when document recheck is requested
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler RecheckDocumentRequest
public event EventHandler RecheckDocumentRequest
Public Event RecheckDocumentRequest As EventHandler
Public Event RecheckDocumentRequest As EventHandler
public:
virtual  event EventHandler^ RecheckDocumentRequest {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ RecheckDocumentRequest {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract RecheckDocumentRequest : IEvent<EventHandler,
    EventArgs>
override RecheckDocumentRequest : IEvent<EventHandler,
    EventArgs>
abstract RecheckDocumentRequest : IEvent<EventHandler,
    EventArgs>
override RecheckDocumentRequest : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


Remove Method

Keyoti RapidSpell Desktop .NET API Docs
Remove Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► Remove()()()()
Keyoti RapidSpell Desktop .NET
Safely frees up resources.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void Remove()
public void Remove()
Public Sub Remove
Public Sub Remove
public:
virtual void Remove() sealed
public:
virtual void Remove() sealed
abstract Remove : unit -> unit
override Remove : unit -> unit
abstract Remove : unit -> unit
override Remove : unit -> unit


RemoveDuplicateWordText Property

Keyoti RapidSpell Desktop .NET API Docs
RemoveDuplicateWordText Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► RemoveDuplicateWordText
Keyoti RapidSpell Desktop .NET
Remove duplicate word text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string RemoveDuplicateWordText { get; set; }
public string RemoveDuplicateWordText { get; set; }
Public Property RemoveDuplicateWordText As String
    Get
    Set
Public Property RemoveDuplicateWordText As String
    Get
    Set
public:
virtual property String^ RemoveDuplicateWordText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ RemoveDuplicateWordText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract RemoveDuplicateWordText : string with get, set
override RemoveDuplicateWordText : string with get, set
abstract RemoveDuplicateWordText : string with get, set
override RemoveDuplicateWordText : string with get, set
Property Value
String


Resume Method

Keyoti RapidSpell Desktop .NET API Docs
Resume Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► Resume()()()()
Keyoti RapidSpell Desktop .NET
Looks for next bad word
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void Resume()
protected virtual void Resume()
Protected Overridable Sub Resume
Protected Overridable Sub Resume
protected:
virtual void Resume()
protected:
virtual void Resume()
abstract Resume : unit -> unit
override Resume : unit -> unit
abstract Resume : unit -> unit
override Resume : unit -> unit
Return Value

void


ResumeButtonText Property

Keyoti RapidSpell Desktop .NET API Docs
ResumeButtonText Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► ResumeButtonText
Keyoti RapidSpell Desktop .NET
Resume button text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string ResumeButtonText { get; set; }
public string ResumeButtonText { get; set; }
Public Property ResumeButtonText As String
    Get
    Set
Public Property ResumeButtonText As String
    Get
    Set
public:
virtual property String^ ResumeButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ ResumeButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract ResumeButtonText : string with get, set
override ResumeButtonText : string with get, set
abstract ResumeButtonText : string with get, set
override ResumeButtonText : string with get, set
Property Value
String


SelectText Method (theBadWord)

Keyoti RapidSpell Desktop .NET API Docs
SelectText Method (theBadWord)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SelectText(BadWord)
Keyoti RapidSpell Desktop .NET
Selects a bad word in the text component
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void SelectText(
    BadWord theBadWord
)
protected virtual void SelectText(
    BadWord theBadWord
)
Protected Overridable Sub SelectText (
    theBadWord As BadWord
)
Protected Overridable Sub SelectText (
    theBadWord As BadWord
)
protected:
virtual void SelectText(
    BadWord^ theBadWord
)
protected:
virtual void SelectText(
    BadWord^ theBadWord
)
abstract SelectText :
        theBadWord : BadWord -> unit
override SelectText :
        theBadWord : BadWord -> unit
abstract SelectText :
        theBadWord : BadWord -> unit
override SelectText :
        theBadWord : BadWord -> unit
Parameters
theBadWord (BadWord)


SeparateHyphenWords Property

Keyoti RapidSpell Desktop .NET API Docs
SeparateHyphenWords Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SeparateHyphenWords
Keyoti RapidSpell Desktop .NET
Sets whether to treat hyphenated (-) words as separate words, default is false.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool SeparateHyphenWords { get; set; }
public bool SeparateHyphenWords { get; set; }
Public Property SeparateHyphenWords As Boolean
    Get
    Set
Public Property SeparateHyphenWords As Boolean
    Get
    Set
public:
property bool SeparateHyphenWords {
    bool get ();
    void set (bool value);
}
public:
property bool SeparateHyphenWords {
    bool get ();
    void set (bool value);
}
member SeparateHyphenWords : bool with get, set

member SeparateHyphenWords : bool with get, set
Property Value
Boolean
Remarks
For eg. if this is true text like "cheap-deals" will be treated as two words "cheap" and "deals", otherwise this will be treated as one word "cheap-deals".


SetConsiderationRange Method (w)

Keyoti RapidSpell Desktop .NET API Docs
SetConsiderationRange Method (w)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SetConsiderationRange(Int32)
Keyoti RapidSpell Desktop .NET
Sets the factor for words to consider for suggestions, lower values are faster but consider less words for suggestions. Default is 80. If w <= 1 this method won't do anything.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
[ObsoleteAttribute("Use ConsiderationRange instead.", true)]
public void SetConsiderationRange(
    int w
)
[ObsoleteAttribute("Use ConsiderationRange instead.", true)]
public void SetConsiderationRange(
    int w
)
<ObsoleteAttribute("Use ConsiderationRange instead.", true)>
Public Sub SetConsiderationRange (
    w As Integer
)
<ObsoleteAttribute("Use ConsiderationRange instead.", true)>
Public Sub SetConsiderationRange (
    w As Integer
)
public:
[ObsoleteAttribute(L"Use ConsiderationRange instead.", true)]
void SetConsiderationRange(
    int w
)
public:
[ObsoleteAttribute(L"Use ConsiderationRange instead.", true)]
void SetConsiderationRange(
    int w
)
[<ObsoleteAttribute("Use ConsiderationRange instead.", true)>]
member SetConsiderationRange :
        w : int -> unit

[<ObsoleteAttribute("Use ConsiderationRange instead.", true)>]
member SetConsiderationRange :
        w : int -> unit
Parameters
w (Int32)


SetDisposeAtEnd Method (v)

Keyoti RapidSpell Desktop .NET API Docs
SetDisposeAtEnd Method (v)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SetDisposeAtEnd(Boolean)
Keyoti RapidSpell Desktop .NET
Sets whether this will dispose of self at the end of the spell check.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected void SetDisposeAtEnd(
    bool v
)
protected void SetDisposeAtEnd(
    bool v
)
Protected Sub SetDisposeAtEnd (
    v As Boolean
)
Protected Sub SetDisposeAtEnd (
    v As Boolean
)
protected:
void SetDisposeAtEnd(
    bool v
)
protected:
void SetDisposeAtEnd(
    bool v
)
member SetDisposeAtEnd :
        v : bool -> unit

member SetDisposeAtEnd :
        v : bool -> unit
Parameters
v (Boolean)
Remarks
Use with caution.


SetFormCancelButton Method (b)

Keyoti RapidSpell Desktop .NET API Docs
SetFormCancelButton Method (b)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SetFormCancelButton(IButtonControl)
Keyoti RapidSpell Desktop .NET
Sets the Form.CancelButton property - this is for VB.NET users who are inheriting from this class.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
[ObsoleteAttribute("Use DialogView to set this property instead.", true)]
protected void SetFormCancelButton(
    IButtonControl b
)
[ObsoleteAttribute("Use DialogView to set this property instead.", true)]
protected void SetFormCancelButton(
    IButtonControl b
)
<ObsoleteAttribute("Use DialogView to set this property instead.", true)>
Protected Sub SetFormCancelButton (
    b As IButtonControl
)
<ObsoleteAttribute("Use DialogView to set this property instead.", true)>
Protected Sub SetFormCancelButton (
    b As IButtonControl
)
protected:
[ObsoleteAttribute(L"Use DialogView to set this property instead.",
    true)]
void SetFormCancelButton(
    IButtonControl^ b
)
protected:
[ObsoleteAttribute(L"Use DialogView to set this property instead.",
    true)]
void SetFormCancelButton(
    IButtonControl^ b
)
[<ObsoleteAttribute("Use DialogView to set this property instead.",
    true)>]
member SetFormCancelButton :
        b : IButtonControl -> unit

[<ObsoleteAttribute("Use DialogView to set this property instead.",
    true)>]
member SetFormCancelButton :
        b : IButtonControl -> unit
Parameters
b (IButtonControl)
Remarks
VB.NET users must use this to set Form.CancelButton, because VB.NET is case insensitive and this class has a cancelButton field.


SetIgnoreCapitalizedWords Method (v)

Keyoti RapidSpell Desktop .NET API Docs
SetIgnoreCapitalizedWords Method (v)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SetIgnoreCapitalizedWords(Boolean)
Keyoti RapidSpell Desktop .NET
Sets whether to ignore words with capital letters.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
[ObsoleteAttribute("Use IgnoreCapitalizedWords instead.", true)]
public void SetIgnoreCapitalizedWords(
    bool v
)
[ObsoleteAttribute("Use IgnoreCapitalizedWords instead.", true)]
public void SetIgnoreCapitalizedWords(
    bool v
)
<ObsoleteAttribute("Use IgnoreCapitalizedWords instead.", true)>
Public Sub SetIgnoreCapitalizedWords (
    v As Boolean
)
<ObsoleteAttribute("Use IgnoreCapitalizedWords instead.", true)>
Public Sub SetIgnoreCapitalizedWords (
    v As Boolean
)
public:
[ObsoleteAttribute(L"Use IgnoreCapitalizedWords instead.", true)]
void SetIgnoreCapitalizedWords(
    bool v
)
public:
[ObsoleteAttribute(L"Use IgnoreCapitalizedWords instead.", true)]
void SetIgnoreCapitalizedWords(
    bool v
)
[<ObsoleteAttribute("Use IgnoreCapitalizedWords instead.", true)>]
member SetIgnoreCapitalizedWords :
        v : bool -> unit

[<ObsoleteAttribute("Use IgnoreCapitalizedWords instead.", true)>]
member SetIgnoreCapitalizedWords :
        v : bool -> unit
Parameters
v (Boolean)


SetIgnoreOnceBadWords Method (ignoreOnceBadWords)

Keyoti RapidSpell Desktop .NET API Docs
SetIgnoreOnceBadWords Method (ignoreOnceBadWords)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SetIgnoreOnceBadWords(ArrayList)
Keyoti RapidSpell Desktop .NET
Provide a list of BadWord objects that have been ignored
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void SetIgnoreOnceBadWords(
    ArrayList ignoreOnceBadWords
)
public void SetIgnoreOnceBadWords(
    ArrayList ignoreOnceBadWords
)
Public Sub SetIgnoreOnceBadWords (
    ignoreOnceBadWords As ArrayList
)
Public Sub SetIgnoreOnceBadWords (
    ignoreOnceBadWords As ArrayList
)
public:
virtual void SetIgnoreOnceBadWords(
    ArrayList^ ignoreOnceBadWords
) sealed
public:
virtual void SetIgnoreOnceBadWords(
    ArrayList^ ignoreOnceBadWords
) sealed
abstract SetIgnoreOnceBadWords :
        ignoreOnceBadWords : ArrayList -> unit
override SetIgnoreOnceBadWords :
        ignoreOnceBadWords : ArrayList -> unit
abstract SetIgnoreOnceBadWords :
        ignoreOnceBadWords : ArrayList -> unit
override SetIgnoreOnceBadWords :
        ignoreOnceBadWords : ArrayList -> unit
Parameters
ignoreOnceBadWords (ArrayList)


SetIncludeUserDictionaryInSuggestions Method (v)

Keyoti RapidSpell Desktop .NET API Docs
SetIncludeUserDictionaryInSuggestions Method (v)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SetIncludeUserDictionaryInSuggestions(Boolean)
Keyoti RapidSpell Desktop .NET
Sets whether the user dictionary should be used in finding suggestions for misspelt words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
[ObsoleteAttribute("Use IncludeUserDictionaryInSuggestions instead.",
    true)]
public void SetIncludeUserDictionaryInSuggestions(
    bool v
)
[ObsoleteAttribute("Use IncludeUserDictionaryInSuggestions instead.",
    true)]
public void SetIncludeUserDictionaryInSuggestions(
    bool v
)
<ObsoleteAttribute("Use IncludeUserDictionaryInSuggestions instead.",
    true)>
Public Sub SetIncludeUserDictionaryInSuggestions (
    v As Boolean
)
<ObsoleteAttribute("Use IncludeUserDictionaryInSuggestions instead.",
    true)>
Public Sub SetIncludeUserDictionaryInSuggestions (
    v As Boolean
)
public:
[ObsoleteAttribute(L"Use IncludeUserDictionaryInSuggestions instead.",
    true)]
virtual void SetIncludeUserDictionaryInSuggestions(
    bool v
) sealed
public:
[ObsoleteAttribute(L"Use IncludeUserDictionaryInSuggestions instead.",
    true)]
virtual void SetIncludeUserDictionaryInSuggestions(
    bool v
) sealed
[<ObsoleteAttribute("Use IncludeUserDictionaryInSuggestions instead.",
    true)>]
abstract SetIncludeUserDictionaryInSuggestions :
        v : bool -> unit
[<ObsoleteAttribute("Use IncludeUserDictionaryInSuggestions instead.",
    true)>]
override SetIncludeUserDictionaryInSuggestions :
        v : bool -> unit
[<ObsoleteAttribute("Use IncludeUserDictionaryInSuggestions instead.",
    true)>]
abstract SetIncludeUserDictionaryInSuggestions :
        v : bool -> unit
[<ObsoleteAttribute("Use IncludeUserDictionaryInSuggestions instead.",
    true)>]
override SetIncludeUserDictionaryInSuggestions :
        v : bool -> unit
Parameters
v (Boolean)


SetSeparateHyphenWords Method (f)

Keyoti RapidSpell Desktop .NET API Docs
SetSeparateHyphenWords Method (f)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SetSeparateHyphenWords(Boolean)
Keyoti RapidSpell Desktop .NET
Sets whether to treat hyphenated (-) words as separate words, default is false.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
[ObsoleteAttribute("Use SeparateHyphenWords instead.", true)]
public void SetSeparateHyphenWords(
    bool f
)
[ObsoleteAttribute("Use SeparateHyphenWords instead.", true)]
public void SetSeparateHyphenWords(
    bool f
)
<ObsoleteAttribute("Use SeparateHyphenWords instead.", true)>
Public Sub SetSeparateHyphenWords (
    f As Boolean
)
<ObsoleteAttribute("Use SeparateHyphenWords instead.", true)>
Public Sub SetSeparateHyphenWords (
    f As Boolean
)
public:
[ObsoleteAttribute(L"Use SeparateHyphenWords instead.", true)]
virtual void SetSeparateHyphenWords(
    bool f
) sealed
public:
[ObsoleteAttribute(L"Use SeparateHyphenWords instead.", true)]
virtual void SetSeparateHyphenWords(
    bool f
) sealed
[<ObsoleteAttribute("Use SeparateHyphenWords instead.", true)>]
abstract SetSeparateHyphenWords :
        f : bool -> unit
[<ObsoleteAttribute("Use SeparateHyphenWords instead.", true)>]
override SetSeparateHyphenWords :
        f : bool -> unit
[<ObsoleteAttribute("Use SeparateHyphenWords instead.", true)>]
abstract SetSeparateHyphenWords :
        f : bool -> unit
[<ObsoleteAttribute("Use SeparateHyphenWords instead.", true)>]
override SetSeparateHyphenWords :
        f : bool -> unit
Parameters
f (Boolean)
Remarks
For eg. if this is true text like "cheap-deals" will be treated as two words "cheap" and "deals", otherwise this will be treated as one word "cheap-deals".


SetShowFinishedMessageBox Method (b)

Keyoti RapidSpell Desktop .NET API Docs
SetShowFinishedMessageBox Method (b)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SetShowFinishedMessageBox(Boolean)
Keyoti RapidSpell Desktop .NET
Sets whether a message box should be opened when the spell check is complete.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
[ObsoleteAttribute("Use ShowFinishedMessageBox instead.", true)]
public void SetShowFinishedMessageBox(
    bool b
)
[ObsoleteAttribute("Use ShowFinishedMessageBox instead.", true)]
public void SetShowFinishedMessageBox(
    bool b
)
<ObsoleteAttribute("Use ShowFinishedMessageBox instead.", true)>
Public Sub SetShowFinishedMessageBox (
    b As Boolean
)
<ObsoleteAttribute("Use ShowFinishedMessageBox instead.", true)>
Public Sub SetShowFinishedMessageBox (
    b As Boolean
)
public:
[ObsoleteAttribute(L"Use ShowFinishedMessageBox instead.", true)]
virtual void SetShowFinishedMessageBox(
    bool b
) sealed
public:
[ObsoleteAttribute(L"Use ShowFinishedMessageBox instead.", true)]
virtual void SetShowFinishedMessageBox(
    bool b
) sealed
[<ObsoleteAttribute("Use ShowFinishedMessageBox instead.", true)>]
abstract SetShowFinishedMessageBox :
        b : bool -> unit
[<ObsoleteAttribute("Use ShowFinishedMessageBox instead.", true)>]
override SetShowFinishedMessageBox :
        b : bool -> unit
[<ObsoleteAttribute("Use ShowFinishedMessageBox instead.", true)>]
abstract SetShowFinishedMessageBox :
        b : bool -> unit
[<ObsoleteAttribute("Use ShowFinishedMessageBox instead.", true)>]
override SetShowFinishedMessageBox :
        b : bool -> unit
Parameters
b (Boolean)
boolean indicating if the message box should be opened.


SetSuggestionsMethod Method (method)

Keyoti RapidSpell Desktop .NET API Docs
SetSuggestionsMethod Method (method)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SetSuggestionsMethod(Int32)
Keyoti RapidSpell Desktop .NET
Sets the suggestions method to use. Either PHONETIC_SUGGESTIONS or HASHING_SUGGESTIONS
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
[ObsoleteAttribute("Use SuggestionsMethod instead.", true)]
public void SetSuggestionsMethod(
    int method
)
[ObsoleteAttribute("Use SuggestionsMethod instead.", true)]
public void SetSuggestionsMethod(
    int method
)
<ObsoleteAttribute("Use SuggestionsMethod instead.", true)>
Public Sub SetSuggestionsMethod (
    method As Integer
)
<ObsoleteAttribute("Use SuggestionsMethod instead.", true)>
Public Sub SetSuggestionsMethod (
    method As Integer
)
public:
[ObsoleteAttribute(L"Use SuggestionsMethod instead.", true)]
void SetSuggestionsMethod(
    int method
)
public:
[ObsoleteAttribute(L"Use SuggestionsMethod instead.", true)]
void SetSuggestionsMethod(
    int method
)
[<ObsoleteAttribute("Use SuggestionsMethod instead.", true)>]
member SetSuggestionsMethod :
        method : int -> unit

[<ObsoleteAttribute("Use SuggestionsMethod instead.", true)>]
member SetSuggestionsMethod :
        method : int -> unit
Parameters
method (Int32)


SetTextComponentToCheck Method

Keyoti RapidSpell Desktop .NET API Docs
SetTextComponentToCheck Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SetTextComponentToCheck()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | SetTextComponentToCheck(TextBoxBase) | Set the TextBoxBase (eg; TextBox etc) that this GUI will spell check.
 | SetTextComponentToCheck(ISpellCheckableTextComponent) | Sets the ISpellCheckableTextComponent that this GUI will spell check.
 | SetTextComponentToCheck(ISpellCheckableTextComponent2) | Sets the ISpellCheckableTextComponent2 that this GUI will spell check.


SetTextComponentToCheck Method (textComponent)

Keyoti RapidSpell Desktop .NET API Docs
SetTextComponentToCheck Method (textComponent)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SetTextComponentToCheck(ISpellCheckableTextComponent)
Keyoti RapidSpell Desktop .NET
Sets the ISpellCheckableTextComponent that this GUI will spell check.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void SetTextComponentToCheck(
    ISpellCheckableTextComponent textComponent
)
public virtual void SetTextComponentToCheck(
    ISpellCheckableTextComponent textComponent
)
Public Overridable Sub SetTextComponentToCheck (
    textComponent As ISpellCheckableTextComponent
)
Public Overridable Sub SetTextComponentToCheck (
    textComponent As ISpellCheckableTextComponent
)
public:
virtual void SetTextComponentToCheck(
    ISpellCheckableTextComponent^ textComponent
)
public:
virtual void SetTextComponentToCheck(
    ISpellCheckableTextComponent^ textComponent
)
abstract SetTextComponentToCheck :
        textComponent : ISpellCheckableTextComponent -> unit
override SetTextComponentToCheck :
        textComponent : ISpellCheckableTextComponent -> unit
abstract SetTextComponentToCheck :
        textComponent : ISpellCheckableTextComponent -> unit
override SetTextComponentToCheck :
        textComponent : ISpellCheckableTextComponent -> unit
Parameters
textComponent (ISpellCheckableTextComponent)
the ISpellCheckableTextComponent that this will spell check.
Exceptions
Exception | Condition
ArgumentNullException | if textComponent parameter is null.


SetTextComponentToCheck Method (textComponent)

Keyoti RapidSpell Desktop .NET API Docs
SetTextComponentToCheck Method (textComponent)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SetTextComponentToCheck(ISpellCheckableTextComponent2)
Keyoti RapidSpell Desktop .NET
Sets the ISpellCheckableTextComponent2 that this GUI will spell check.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void SetTextComponentToCheck(
    ISpellCheckableTextComponent2 textComponent
)
public virtual void SetTextComponentToCheck(
    ISpellCheckableTextComponent2 textComponent
)
Public Overridable Sub SetTextComponentToCheck (
    textComponent As ISpellCheckableTextComponent2
)
Public Overridable Sub SetTextComponentToCheck (
    textComponent As ISpellCheckableTextComponent2
)
public:
virtual void SetTextComponentToCheck(
    ISpellCheckableTextComponent2^ textComponent
)
public:
virtual void SetTextComponentToCheck(
    ISpellCheckableTextComponent2^ textComponent
)
abstract SetTextComponentToCheck :
        textComponent : ISpellCheckableTextComponent2 -> unit
override SetTextComponentToCheck :
        textComponent : ISpellCheckableTextComponent2 -> unit
abstract SetTextComponentToCheck :
        textComponent : ISpellCheckableTextComponent2 -> unit
override SetTextComponentToCheck :
        textComponent : ISpellCheckableTextComponent2 -> unit
Parameters
textComponent (ISpellCheckableTextComponent2)
the ISpellCheckableTextComponent2 that this will spell check.
Exceptions
Exception | Condition
ArgumentNullException | if textComponent parameter is null.


SetTextComponentToCheck Method (textComponent)

Keyoti RapidSpell Desktop .NET API Docs
SetTextComponentToCheck Method (textComponent)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SetTextComponentToCheck(TextBoxBase)
Keyoti RapidSpell Desktop .NET
Set the TextBoxBase (eg; TextBox etc) that this GUI will spell check.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void SetTextComponentToCheck(
    TextBoxBase textComponent
)
public virtual void SetTextComponentToCheck(
    TextBoxBase textComponent
)
Public Overridable Sub SetTextComponentToCheck (
    textComponent As TextBoxBase
)
Public Overridable Sub SetTextComponentToCheck (
    textComponent As TextBoxBase
)
public:
virtual void SetTextComponentToCheck(
    TextBoxBase^ textComponent
)
public:
virtual void SetTextComponentToCheck(
    TextBoxBase^ textComponent
)
abstract SetTextComponentToCheck :
        textComponent : TextBoxBase -> unit
override SetTextComponentToCheck :
        textComponent : TextBoxBase -> unit
abstract SetTextComponentToCheck :
        textComponent : TextBoxBase -> unit
override SetTextComponentToCheck :
        textComponent : TextBoxBase -> unit
Parameters
textComponent (TextBoxBase)
the TextBoxBase that this will spell check.
Exceptions
Exception | Condition
ArgumentNullException | if textComponent parameter is null.


SetUITexts Method

Keyoti RapidSpell Desktop .NET API Docs
SetUITexts Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SetUITexts()()()()
Keyoti RapidSpell Desktop .NET
Applies the UI texts to the IDialogView
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void SetUITexts()
protected virtual void SetUITexts()
Protected Overridable Sub SetUITexts
Protected Overridable Sub SetUITexts
protected:
virtual void SetUITexts()
protected:
virtual void SetUITexts()
abstract SetUITexts : unit -> unit
override SetUITexts : unit -> unit
abstract SetUITexts : unit -> unit
override SetUITexts : unit -> unit


SetUserDictionary Method (userDictionary)

Keyoti RapidSpell Desktop .NET API Docs
SetUserDictionary Method (userDictionary)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SetUserDictionary(UserDictionary)
Keyoti RapidSpell Desktop .NET
Set the user dictionary object.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
[ObsoleteAttribute("Use UserDictionary instead.", true)]
public void SetUserDictionary(
    UserDictionary userDictionary
)
[ObsoleteAttribute("Use UserDictionary instead.", true)]
public void SetUserDictionary(
    UserDictionary userDictionary
)
<ObsoleteAttribute("Use UserDictionary instead.", true)>
Public Sub SetUserDictionary (
    userDictionary As UserDictionary
)
<ObsoleteAttribute("Use UserDictionary instead.", true)>
Public Sub SetUserDictionary (
    userDictionary As UserDictionary
)
public:
[ObsoleteAttribute(L"Use UserDictionary instead.", true)]
virtual void SetUserDictionary(
    UserDictionary^ userDictionary
) sealed
public:
[ObsoleteAttribute(L"Use UserDictionary instead.", true)]
virtual void SetUserDictionary(
    UserDictionary^ userDictionary
) sealed
[<ObsoleteAttribute("Use UserDictionary instead.", true)>]
abstract SetUserDictionary :
        userDictionary : UserDictionary -> unit
[<ObsoleteAttribute("Use UserDictionary instead.", true)>]
override SetUserDictionary :
        userDictionary : UserDictionary -> unit
[<ObsoleteAttribute("Use UserDictionary instead.", true)>]
abstract SetUserDictionary :
        userDictionary : UserDictionary -> unit
[<ObsoleteAttribute("Use UserDictionary instead.", true)>]
override SetUserDictionary :
        userDictionary : UserDictionary -> unit
Parameters
userDictionary (UserDictionary)
the UserDictionary to use as a user dictionary.
Remarks
Use of a user dictionary is optional.
Exceptions
Exception | Condition
ArgumentNullException | if userDictionary parameter is null.


SetUserDictionaryFile Method (userDictionaryFile)

Keyoti RapidSpell Desktop .NET API Docs
SetUserDictionaryFile Method (userDictionaryFile)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SetUserDictionaryFile(String)
Keyoti RapidSpell Desktop .NET
Set the user dictionary file, if this file doesn't exist it will be created.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
[ObsoleteAttribute("Use UserDictionaryFile instead.", true)]
public void SetUserDictionaryFile(
    string userDictionaryFile
)
[ObsoleteAttribute("Use UserDictionaryFile instead.", true)]
public void SetUserDictionaryFile(
    string userDictionaryFile
)
<ObsoleteAttribute("Use UserDictionaryFile instead.", true)>
Public Sub SetUserDictionaryFile (
    userDictionaryFile As String
)
<ObsoleteAttribute("Use UserDictionaryFile instead.", true)>
Public Sub SetUserDictionaryFile (
    userDictionaryFile As String
)
public:
[ObsoleteAttribute(L"Use UserDictionaryFile instead.", true)]
virtual void SetUserDictionaryFile(
    String^ userDictionaryFile
) sealed
public:
[ObsoleteAttribute(L"Use UserDictionaryFile instead.", true)]
virtual void SetUserDictionaryFile(
    String^ userDictionaryFile
) sealed
[<ObsoleteAttribute("Use UserDictionaryFile instead.", true)>]
abstract SetUserDictionaryFile :
        userDictionaryFile : string -> unit
[<ObsoleteAttribute("Use UserDictionaryFile instead.", true)>]
override SetUserDictionaryFile :
        userDictionaryFile : string -> unit
[<ObsoleteAttribute("Use UserDictionaryFile instead.", true)>]
abstract SetUserDictionaryFile :
        userDictionaryFile : string -> unit
[<ObsoleteAttribute("Use UserDictionaryFile instead.", true)>]
override SetUserDictionaryFile :
        userDictionaryFile : string -> unit
Parameters
userDictionaryFile (String)
the File to use as a user dictionary.
Remarks
Use of a user dictionary is optional.
Exceptions
Exception | Condition
ArgumentNullException | if userDictionaryFile parameter is null.


ShouldEnableAddButton Method

Keyoti RapidSpell Desktop .NET API Docs
ShouldEnableAddButton Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► ShouldEnableAddButton()()()()
Keyoti RapidSpell Desktop .NET
Determines if the Add button should be enabled
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual bool ShouldEnableAddButton()
protected virtual bool ShouldEnableAddButton()
Protected Overridable Function ShouldEnableAddButton As Boolean
Protected Overridable Function ShouldEnableAddButton As Boolean
protected:
virtual bool ShouldEnableAddButton()
protected:
virtual bool ShouldEnableAddButton()
abstract ShouldEnableAddButton : unit -> bool
override ShouldEnableAddButton : unit -> bool
abstract ShouldEnableAddButton : unit -> bool
override ShouldEnableAddButton : unit -> bool
Return Value
Boolean


ShowContextSentence Property

Keyoti RapidSpell Desktop .NET API Docs
ShowContextSentence Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► ShowContextSentence
Keyoti RapidSpell Desktop .NET
Whether to show the query in context of it's sentence/line.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ShowContextSentence { get; set; }
public bool ShowContextSentence { get; set; }
Public Property ShowContextSentence As Boolean
    Get
    Set
Public Property ShowContextSentence As Boolean
    Get
    Set
public:
virtual property bool ShowContextSentence {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool ShowContextSentence {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract ShowContextSentence : bool with get, set
override ShowContextSentence : bool with get, set
abstract ShowContextSentence : bool with get, set
override ShowContextSentence : bool with get, set
Property Value
Boolean


ShowFinishedMessageBox Property

Keyoti RapidSpell Desktop .NET API Docs
ShowFinishedMessageBox Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► ShowFinishedMessageBox
Keyoti RapidSpell Desktop .NET
Whether a message box should be opened when the spell check is complete.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ShowFinishedMessageBox { get; set; }
public bool ShowFinishedMessageBox { get; set; }
Public Property ShowFinishedMessageBox As Boolean
    Get
    Set
Public Property ShowFinishedMessageBox As Boolean
    Get
    Set
public:
property bool ShowFinishedMessageBox {
    bool get ();
    void set (bool value);
}
public:
property bool ShowFinishedMessageBox {
    bool get ();
    void set (bool value);
}
member ShowFinishedMessageBox : bool with get, set

member ShowFinishedMessageBox : bool with get, set
Property Value
Boolean


showMessageBoxAtEnd Field

Keyoti RapidSpell Desktop .NET API Docs
showMessageBoxAtEnd Field
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► showMessageBoxAtEnd
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected bool showMessageBoxAtEnd
protected bool showMessageBoxAtEnd
Protected showMessageBoxAtEnd As Boolean
Protected showMessageBoxAtEnd As Boolean
protected:
bool showMessageBoxAtEnd
protected:
bool showMessageBoxAtEnd
val mutable showMessageBoxAtEnd: bool
val mutable showMessageBoxAtEnd: bool
Field Value
Boolean


SpellCheckFinished Event

Keyoti RapidSpell Desktop .NET API Docs
SpellCheckFinished Event
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SpellCheckFinished
Keyoti RapidSpell Desktop .NET
Fired when checking finishes
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event RapidSpellGUIPresenter..::..SpellCheckEventHandler SpellCheckFinished
public event RapidSpellGUIPresenter..::..SpellCheckEventHandler SpellCheckFinished
Public Event SpellCheckFinished As RapidSpellGUIPresenter..::..SpellCheckEventHandler
Public Event SpellCheckFinished As RapidSpellGUIPresenter..::..SpellCheckEventHandler
public:
virtual  event RapidSpellGUIPresenter..::..SpellCheckEventHandler^ SpellCheckFinished {
    void add (RapidSpellGUIPresenter..::..SpellCheckEventHandler^ value);
    void remove (RapidSpellGUIPresenter..::..SpellCheckEventHandler^ value);
}
public:
virtual  event RapidSpellGUIPresenter..::..SpellCheckEventHandler^ SpellCheckFinished {
    void add (RapidSpellGUIPresenter..::..SpellCheckEventHandler^ value);
    void remove (RapidSpellGUIPresenter..::..SpellCheckEventHandler^ value);
}
abstract SpellCheckFinished : IEvent<RapidSpellGUIPresenter..::..SpellCheckEventHandler,
    SpellCheckEventArgs>
override SpellCheckFinished : IEvent<RapidSpellGUIPresenter..::..SpellCheckEventHandler,
    SpellCheckEventArgs>
abstract SpellCheckFinished : IEvent<RapidSpellGUIPresenter..::..SpellCheckEventHandler,
    SpellCheckEventArgs>
override SpellCheckFinished : IEvent<RapidSpellGUIPresenter..::..SpellCheckEventHandler,
    SpellCheckEventArgs>
Value
RapidSpellGUIPresenter..::..SpellCheckEventHandler


SpellCheckStarted Event

Keyoti RapidSpell Desktop .NET API Docs
SpellCheckStarted Event
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SpellCheckStarted
Keyoti RapidSpell Desktop .NET
Fired when checking starts
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event RapidSpellGUIPresenter..::..SpellCheckEventHandler SpellCheckStarted
public event RapidSpellGUIPresenter..::..SpellCheckEventHandler SpellCheckStarted
Public Event SpellCheckStarted As RapidSpellGUIPresenter..::..SpellCheckEventHandler
Public Event SpellCheckStarted As RapidSpellGUIPresenter..::..SpellCheckEventHandler
public:
virtual  event RapidSpellGUIPresenter..::..SpellCheckEventHandler^ SpellCheckStarted {
    void add (RapidSpellGUIPresenter..::..SpellCheckEventHandler^ value);
    void remove (RapidSpellGUIPresenter..::..SpellCheckEventHandler^ value);
}
public:
virtual  event RapidSpellGUIPresenter..::..SpellCheckEventHandler^ SpellCheckStarted {
    void add (RapidSpellGUIPresenter..::..SpellCheckEventHandler^ value);
    void remove (RapidSpellGUIPresenter..::..SpellCheckEventHandler^ value);
}
abstract SpellCheckStarted : IEvent<RapidSpellGUIPresenter..::..SpellCheckEventHandler,
    SpellCheckEventArgs>
override SpellCheckStarted : IEvent<RapidSpellGUIPresenter..::..SpellCheckEventHandler,
    SpellCheckEventArgs>
abstract SpellCheckStarted : IEvent<RapidSpellGUIPresenter..::..SpellCheckEventHandler,
    SpellCheckEventArgs>
override SpellCheckStarted : IEvent<RapidSpellGUIPresenter..::..SpellCheckEventHandler,
    SpellCheckEventArgs>
Value
RapidSpellGUIPresenter..::..SpellCheckEventHandler


subFromPosition Field

Keyoti RapidSpell Desktop .NET API Docs
subFromPosition Field
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► subFromPosition
Keyoti RapidSpell Desktop .NET
To check from and to positions that are wrapped, need to do in 2 steps check from subFromPosition ( = fromPosition) -> subToPosition (= doc end) and then check from subFromPosition (= 0) -> subToPosition (= toPosition)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected int subFromPosition
protected int subFromPosition
Protected subFromPosition As Integer
Protected subFromPosition As Integer
protected:
int subFromPosition
protected:
int subFromPosition
val mutable subFromPosition: int
val mutable subFromPosition: int
Field Value
Int32


subToPosition Field

Keyoti RapidSpell Desktop .NET API Docs
subToPosition Field
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► subToPosition
Keyoti RapidSpell Desktop .NET
To check from and to positions that are wrapped, need to do in 2 steps check from subFromPosition ( = fromPosition) -> subToPosition (= doc end) and then check from subFromPosition (= 0) -> subToPosition (= toPosition)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected int subToPosition
protected int subToPosition
Protected subToPosition As Integer
Protected subToPosition As Integer
protected:
int subToPosition
protected:
int subToPosition
val mutable subToPosition: int
val mutable subToPosition: int
Field Value
Int32


SuggestionsKeyboardText Property

Keyoti RapidSpell Desktop .NET API Docs
SuggestionsKeyboardText Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SuggestionsKeyboardText
Keyoti RapidSpell Desktop .NET
Suggestions label text when in keyboard mode
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string SuggestionsKeyboardText { get; set; }
public string SuggestionsKeyboardText { get; set; }
Public Property SuggestionsKeyboardText As String
    Get
    Set
Public Property SuggestionsKeyboardText As String
    Get
    Set
public:
property String^ SuggestionsKeyboardText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ SuggestionsKeyboardText {
    String^ get ();
    void set (String^ value);
}
member SuggestionsKeyboardText : string with get, set

member SuggestionsKeyboardText : string with get, set
Property Value
String


SuggestionsLabelText Property

Keyoti RapidSpell Desktop .NET API Docs
SuggestionsLabelText Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SuggestionsLabelText
Keyoti RapidSpell Desktop .NET
Suggestions label text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string SuggestionsLabelText { get; set; }
public string SuggestionsLabelText { get; set; }
Public Property SuggestionsLabelText As String
    Get
    Set
Public Property SuggestionsLabelText As String
    Get
    Set
public:
virtual property String^ SuggestionsLabelText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ SuggestionsLabelText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract SuggestionsLabelText : string with get, set
override SuggestionsLabelText : string with get, set
abstract SuggestionsLabelText : string with get, set
override SuggestionsLabelText : string with get, set
Property Value
String


SuggestionsMethod Property

Keyoti RapidSpell Desktop .NET API Docs
SuggestionsMethod Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SuggestionsMethod
Keyoti RapidSpell Desktop .NET
The suggestions method to use.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public SuggestionsMethodType SuggestionsMethod { get; set; }
public SuggestionsMethodType SuggestionsMethod { get; set; }
Public Property SuggestionsMethod As SuggestionsMethodType
    Get
    Set
Public Property SuggestionsMethod As SuggestionsMethodType
    Get
    Set
public:
virtual property SuggestionsMethodType SuggestionsMethod {
    SuggestionsMethodType get () sealed;
    void set (SuggestionsMethodType value) sealed;
}
public:
virtual property SuggestionsMethodType SuggestionsMethod {
    SuggestionsMethodType get () sealed;
    void set (SuggestionsMethodType value) sealed;
}
abstract SuggestionsMethod : SuggestionsMethodType with get, set
override SuggestionsMethod : SuggestionsMethodType with get, set
abstract SuggestionsMethod : SuggestionsMethodType with get, set
override SuggestionsMethod : SuggestionsMethodType with get, set
Property Value
SuggestionsMethodType


SuggestSplitWords Property

Keyoti RapidSpell Desktop .NET API Docs
SuggestSplitWords Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SuggestSplitWords
Keyoti RapidSpell Desktop .NET
Whether to look for connected words in suggestions.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool SuggestSplitWords { get; set; }
public bool SuggestSplitWords { get; set; }
Public Property SuggestSplitWords As Boolean
    Get
    Set
Public Property SuggestSplitWords As Boolean
    Get
    Set
public:
virtual property bool SuggestSplitWords {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool SuggestSplitWords {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract SuggestSplitWords : bool with get, set
override SuggestSplitWords : bool with get, set
abstract SuggestSplitWords : bool with get, set
override SuggestSplitWords : bool with get, set
Property Value
Boolean
Remarks
if this=true then suggestions may include joined words.

Eg; suggestions for "myhouse" will include "my house"


TextBoundary Property

Keyoti RapidSpell Desktop .NET API Docs
TextBoundary Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► TextBoundary
Keyoti RapidSpell Desktop .NET
The AdvancedTextBoundary class to use to parse words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public AdvancedTextBoundary TextBoundary { get; set; }
public AdvancedTextBoundary TextBoundary { get; set; }
Public Property TextBoundary As AdvancedTextBoundary
    Get
    Set
Public Property TextBoundary As AdvancedTextBoundary
    Get
    Set
public:
property AdvancedTextBoundary^ TextBoundary {
    AdvancedTextBoundary^ get ();
    void set (AdvancedTextBoundary^ value);
}
public:
property AdvancedTextBoundary^ TextBoundary {
    AdvancedTextBoundary^ get ();
    void set (AdvancedTextBoundary^ value);
}
member TextBoundary : AdvancedTextBoundary with get, set

member TextBoundary : AdvancedTextBoundary with get, set
Property Value
AdvancedTextBoundary


TextBox Property

Keyoti RapidSpell Desktop .NET API Docs
TextBox Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► TextBox
Keyoti RapidSpell Desktop .NET
The text box instance that this is working with, the actual type depends on whether the TextBoxBaseToCheck property or ThirdPartyTextComponentToCheck property was set.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Object TextBox { get; }
public Object TextBox { get; }
Public ReadOnly Property TextBox As Object
    Get
Public ReadOnly Property TextBox As Object
    Get
public:
property Object^ TextBox {
    Object^ get ();
}
public:
property Object^ TextBox {
    Object^ get ();
}
member TextBox : Object with get

member TextBox : Object with get
Property Value
Object


theBadWord Field

Keyoti RapidSpell Desktop .NET API Docs
theBadWord Field
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► theBadWord
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected BadWord theBadWord
protected BadWord theBadWord
Protected theBadWord As BadWord
Protected theBadWord As BadWord
protected:
BadWord^ theBadWord
protected:
BadWord^ theBadWord
val mutable theBadWord: BadWord
val mutable theBadWord: BadWord
Field Value
BadWord


theSpellChecker Field

Keyoti RapidSpell Desktop .NET API Docs
theSpellChecker Field
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► theSpellChecker
Keyoti RapidSpell Desktop .NET
The spell checker component being used
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected ICheckerEngine theSpellChecker
protected ICheckerEngine theSpellChecker
Protected theSpellChecker As ICheckerEngine
Protected theSpellChecker As ICheckerEngine
protected:
ICheckerEngine^ theSpellChecker
protected:
ICheckerEngine^ theSpellChecker
val mutable theSpellChecker: ICheckerEngine
val mutable theSpellChecker: ICheckerEngine
Field Value
ICheckerEngine


theTextComponent Field

Keyoti RapidSpell Desktop .NET API Docs
theTextComponent Field
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► theTextComponent
Keyoti RapidSpell Desktop .NET
The text component being checked
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected ISpellCheckableTextComponent2 theTextComponent
protected ISpellCheckableTextComponent2 theTextComponent
Protected theTextComponent As ISpellCheckableTextComponent2
Protected theTextComponent As ISpellCheckableTextComponent2
protected:
ISpellCheckableTextComponent2^ theTextComponent
protected:
ISpellCheckableTextComponent2^ theTextComponent
val mutable theTextComponent: ISpellCheckableTextComponent2
val mutable theTextComponent: ISpellCheckableTextComponent2
Field Value
ISpellCheckableTextComponent2


toPosition Field

Keyoti RapidSpell Desktop .NET API Docs
toPosition Field
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► toPosition
Keyoti RapidSpell Desktop .NET
Where the user wants to check to
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected int toPosition
protected int toPosition
Protected toPosition As Integer
Protected toPosition As Integer
protected:
int toPosition
protected:
int toPosition
val mutable toPosition: int
val mutable toPosition: int
Field Value
Int32


Undo Method

Keyoti RapidSpell Desktop .NET API Docs
Undo Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► Undo()()()()
Keyoti RapidSpell Desktop .NET
Undoes the previous user operation.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void Undo()
public virtual void Undo()
Public Overridable Sub Undo
Public Overridable Sub Undo
public:
virtual void Undo()
public:
virtual void Undo()
abstract Undo : unit -> unit
override Undo : unit -> unit
abstract Undo : unit -> unit
override Undo : unit -> unit


UndoButtonText Property

Keyoti RapidSpell Desktop .NET API Docs
UndoButtonText Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► UndoButtonText
Keyoti RapidSpell Desktop .NET
Undo button text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UndoButtonText { get; set; }
public string UndoButtonText { get; set; }
Public Property UndoButtonText As String
    Get
    Set
Public Property UndoButtonText As String
    Get
    Set
public:
virtual property String^ UndoButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ UndoButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract UndoButtonText : string with get, set
override UndoButtonText : string with get, set
abstract UndoButtonText : string with get, set
override UndoButtonText : string with get, set
Property Value
String


Undone Event

Keyoti RapidSpell Desktop .NET API Docs
Undone Event
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► Undone
Keyoti RapidSpell Desktop .NET
Fired when an Undo occurs
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event UndoEventHandler Undone
public event UndoEventHandler Undone
Public Event Undone As UndoEventHandler
Public Event Undone As UndoEventHandler
public:
virtual  event UndoEventHandler^ Undone {
    void add (UndoEventHandler^ value);
    void remove (UndoEventHandler^ value);
}
public:
virtual  event UndoEventHandler^ Undone {
    void add (UndoEventHandler^ value);
    void remove (UndoEventHandler^ value);
}
abstract Undone : IEvent<UndoEventHandler,
    UndoEventArgs>
override Undone : IEvent<UndoEventHandler,
    UndoEventArgs>
abstract Undone : IEvent<UndoEventHandler,
    UndoEventArgs>
override Undone : IEvent<UndoEventHandler,
    UndoEventArgs>
Value
UndoEventHandler


UserDictionary Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionary Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► UserDictionary
Keyoti RapidSpell Desktop .NET
Set the user dictionary object.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UserDictionary UserDictionary { get; set; }
public UserDictionary UserDictionary { get; set; }
Public Property UserDictionary As UserDictionary
    Get
    Set
Public Property UserDictionary As UserDictionary
    Get
    Set
public:
property UserDictionary^ UserDictionary {
    UserDictionary^ get ();
    void set (UserDictionary^ value);
}
public:
property UserDictionary^ UserDictionary {
    UserDictionary^ get ();
    void set (UserDictionary^ value);
}
member UserDictionary : UserDictionary with get, set

member UserDictionary : UserDictionary with get, set
Property Value
UserDictionary
Remarks
Use of a user dictionary is optional.


UserDictionaryFile Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionaryFile Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► UserDictionaryFile
Keyoti RapidSpell Desktop .NET
Set the user dictionary file, if this file doesn't exist it will be created.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionaryFile { set; }
public string UserDictionaryFile { set; }
Public WriteOnly Property UserDictionaryFile As String
    Set
Public WriteOnly Property UserDictionaryFile As String
    Set
public:
property String^ UserDictionaryFile {
    void set (String^ value);
}
public:
property String^ UserDictionaryFile {
    void set (String^ value);
}
member UserDictionaryFile : string with set

member UserDictionaryFile : string with set
Property Value
String
Remarks
Use of a user dictionary is optional.


UserQuery Event

Keyoti RapidSpell Desktop .NET API Docs
UserQuery Event
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► UserQuery
Keyoti RapidSpell Desktop .NET
Indicates that the user is being queried on a spelling error.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event UserQueryEventHandler UserQuery
public event UserQueryEventHandler UserQuery
Public Event UserQuery As UserQueryEventHandler
Public Event UserQuery As UserQueryEventHandler
public:
virtual  event UserQueryEventHandler^ UserQuery {
    void add (UserQueryEventHandler^ value);
    void remove (UserQueryEventHandler^ value);
}
public:
virtual  event UserQueryEventHandler^ UserQuery {
    void add (UserQueryEventHandler^ value);
    void remove (UserQueryEventHandler^ value);
}
abstract UserQuery : IEvent<UserQueryEventHandler,
    UserQueryEventArgs>
override UserQuery : IEvent<UserQueryEventHandler,
    UserQueryEventArgs>
abstract UserQuery : IEvent<UserQueryEventHandler,
    UserQueryEventArgs>
override UserQuery : IEvent<UserQueryEventHandler,
    UserQueryEventArgs>
Value
UserQueryEventHandler


WarnDuplicates Property

Keyoti RapidSpell Desktop .NET API Docs
WarnDuplicates Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► WarnDuplicates
Keyoti RapidSpell Desktop .NET
Whether to show duplicate words as errors (eg. "this is is an error").
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool WarnDuplicates { get; set; }
public bool WarnDuplicates { get; set; }
Public Property WarnDuplicates As Boolean
    Get
    Set
Public Property WarnDuplicates As Boolean
    Get
    Set
public:
virtual property bool WarnDuplicates {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool WarnDuplicates {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract WarnDuplicates : bool with get, set
override WarnDuplicates : bool with get, set
abstract WarnDuplicates : bool with get, set
override WarnDuplicates : bool with get, set
Property Value
Boolean


WordAdded Event

Keyoti RapidSpell Desktop .NET API Docs
WordAdded Event
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► WordAdded
Keyoti RapidSpell Desktop .NET
Fired when word added to user dictionary
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event WordAddedEventHandler WordAdded
public event WordAddedEventHandler WordAdded
Public Event WordAdded As WordAddedEventHandler
Public Event WordAdded As WordAddedEventHandler
public:
virtual  event WordAddedEventHandler^ WordAdded {
    void add (WordAddedEventHandler^ value);
    void remove (WordAddedEventHandler^ value);
}
public:
virtual  event WordAddedEventHandler^ WordAdded {
    void add (WordAddedEventHandler^ value);
    void remove (WordAddedEventHandler^ value);
}
abstract WordAdded : IEvent<WordAddedEventHandler,
    WordAddedEventArgs>
override WordAdded : IEvent<WordAddedEventHandler,
    WordAddedEventArgs>
abstract WordAdded : IEvent<WordAddedEventHandler,
    WordAddedEventArgs>
override WordAdded : IEvent<WordAddedEventHandler,
    WordAddedEventArgs>
Value
WordAddedEventHandler


WordChanged Event

Keyoti RapidSpell Desktop .NET API Docs
WordChanged Event
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► WordChanged
Keyoti RapidSpell Desktop .NET
Fired when word changed
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event WordChangedEventHandler WordChanged
public event WordChangedEventHandler WordChanged
Public Event WordChanged As WordChangedEventHandler
Public Event WordChanged As WordChangedEventHandler
public:
virtual  event WordChangedEventHandler^ WordChanged {
    void add (WordChangedEventHandler^ value);
    void remove (WordChangedEventHandler^ value);
}
public:
virtual  event WordChangedEventHandler^ WordChanged {
    void add (WordChangedEventHandler^ value);
    void remove (WordChangedEventHandler^ value);
}
abstract WordChanged : IEvent<WordChangedEventHandler,
    WordChangedEventArgs>
override WordChanged : IEvent<WordChangedEventHandler,
    WordChangedEventArgs>
abstract WordChanged : IEvent<WordChangedEventHandler,
    WordChangedEventArgs>
override WordChanged : IEvent<WordChangedEventHandler,
    WordChangedEventArgs>
Value
WordChangedEventHandler


WordChanging Event

Keyoti RapidSpell Desktop .NET API Docs
WordChanging Event
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► WordChanging
Keyoti RapidSpell Desktop .NET
Fired before a word is changed
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event WordChangedEventHandler WordChanging
public event WordChangedEventHandler WordChanging
Public Event WordChanging As WordChangedEventHandler
Public Event WordChanging As WordChangedEventHandler
public:
virtual  event WordChangedEventHandler^ WordChanging {
    void add (WordChangedEventHandler^ value);
    void remove (WordChangedEventHandler^ value);
}
public:
virtual  event WordChangedEventHandler^ WordChanging {
    void add (WordChangedEventHandler^ value);
    void remove (WordChangedEventHandler^ value);
}
abstract WordChanging : IEvent<WordChangedEventHandler,
    WordChangedEventArgs>
override WordChanging : IEvent<WordChangedEventHandler,
    WordChangedEventArgs>
abstract WordChanging : IEvent<WordChangedEventHandler,
    WordChangedEventArgs>
override WordChanging : IEvent<WordChangedEventHandler,
    WordChangedEventArgs>
Value
WordChangedEventHandler


WordIgnored Event

Keyoti RapidSpell Desktop .NET API Docs
WordIgnored Event
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► WordIgnored
Keyoti RapidSpell Desktop .NET
Fired when word ignored
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event WordIgnoredEventHandler WordIgnored
public event WordIgnoredEventHandler WordIgnored
Public Event WordIgnored As WordIgnoredEventHandler
Public Event WordIgnored As WordIgnoredEventHandler
public:
virtual  event WordIgnoredEventHandler^ WordIgnored {
    void add (WordIgnoredEventHandler^ value);
    void remove (WordIgnoredEventHandler^ value);
}
public:
virtual  event WordIgnoredEventHandler^ WordIgnored {
    void add (WordIgnoredEventHandler^ value);
    void remove (WordIgnoredEventHandler^ value);
}
abstract WordIgnored : IEvent<WordIgnoredEventHandler,
    WordIgnoredEventArgs>
override WordIgnored : IEvent<WordIgnoredEventHandler,
    WordIgnoredEventArgs>
abstract WordIgnored : IEvent<WordIgnoredEventHandler,
    WordIgnoredEventArgs>
override WordIgnored : IEvent<WordIgnoredEventHandler,
    WordIgnoredEventArgs>
Value
WordIgnoredEventHandler


Wrap Method

Keyoti RapidSpell Desktop .NET API Docs
Wrap Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► Wrap()()()()
Keyoti RapidSpell Desktop .NET
Wraps the checker to start at beginning of doc
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void Wrap()
protected virtual void Wrap()
Protected Overridable Sub Wrap
Protected Overridable Sub Wrap
protected:
virtual void Wrap()
protected:
virtual void Wrap()
abstract Wrap : unit -> unit
override Wrap : unit -> unit
abstract Wrap : unit -> unit
override Wrap : unit -> unit


wrapped Field

Keyoti RapidSpell Desktop .NET API Docs
wrapped Field
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► wrapped
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected bool wrapped
protected bool wrapped
Protected wrapped As Boolean
Protected wrapped As Boolean
protected:
bool wrapped
protected:
bool wrapped
val mutable wrapped: bool
val mutable wrapped: bool
Field Value
Boolean


RapidSpellGUIPresenter.SpellCheckEventHandler Delegate

Keyoti RapidSpell Desktop .NET API Docs
RapidSpellGUIPresenter..::..SpellCheckEventHandler Delegate
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► RapidSpellGUIPresenter..::..SpellCheckEventHandler
Keyoti RapidSpell Desktop .NET
Spell check event handler delegate.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void SpellCheckEventHandler(
    Object sender,
    SpellCheckEventArgs e
)
public delegate void SpellCheckEventHandler(
    Object sender,
    SpellCheckEventArgs e
)
Public Delegate Sub SpellCheckEventHandler (
    sender As Object,
    e As SpellCheckEventArgs
)
Public Delegate Sub SpellCheckEventHandler (
    sender As Object,
    e As SpellCheckEventArgs
)
public delegate void SpellCheckEventHandler(
    Object^ sender,
    SpellCheckEventArgs^ e
)
public delegate void SpellCheckEventHandler(
    Object^ sender,
    SpellCheckEventArgs^ e
)
type SpellCheckEventHandler =
    delegate of
        sender : Object *
        e : SpellCheckEventArgs -> unit
type SpellCheckEventHandler =
    delegate of
        sender : Object *
        e : SpellCheckEventArgs -> unit
Parameters
sender (Object)
e (SpellCheckEventArgs)


RegisterForm Class

Keyoti RapidSpell Desktop .NET API Docs
RegisterForm Class
API ► Keyoti.RapidSpell ► RegisterForm
Keyoti RapidSpell Desktop .NET
Internally used for registering license keys.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class RegisterForm : Form
public class RegisterForm : Form
Public Class RegisterForm
    Inherits Form
Public Class RegisterForm
    Inherits Form
public ref class RegisterForm : public Form
public ref class RegisterForm : public Form
type RegisterForm =
    class
        inherit Form
    end
type RegisterForm =
    class
        inherit Form
    end
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RegisterForm()()()() |
 | RegisterForm(Boolean) | New instance
 | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
 | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
 | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
 | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
 | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
 | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
 | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
 | Activate()()()() | Activates the form and gives it focus. (Inherited from Form.)
 | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
 | ActivateMdiChild(Form) | Activates the MDI child of a form. (Inherited from Form.)
 | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
 | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
 | AddOwnedForm(Form) | Adds an owned form to this form. (Inherited from Form.)
 | AdjustFormScrollbars(Boolean) | (Inherited from Form.)
 | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
 | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
 | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
 | ApplyAutoScaling()()()() | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
 | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
 | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
 | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
 | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
 | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
 | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
 | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
 | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
 | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
 | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
 | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
 | AutoSizeChanged | (Inherited from Form.)
 | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
 | AutoValidate | (Inherited from Form.)
 | AutoValidateChanged | (Inherited from Form.)
 | BackColor | (Inherited from Form.)
 | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
 | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
 | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
 | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
 | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
 | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
 | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
 | BindingContext | (Inherited from ContainerControl.)
 | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
 | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
 | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
 | BringToFront()()()() | Brings the control to the front of the z-order. (Inherited from Control.)
 | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
 | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
 | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
 | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
 | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
 | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
 | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
 | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
 | CenterToParent()()()() | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
 | CenterToScreen()()()() | Centers the form on the current screen. (Inherited from Form.)
 | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
 | Click | Occurs when the control is clicked. (Inherited from Control.)
 | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
 | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
 | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
 | Close()()()() | Closes the form. (Inherited from Form.)
 | Closed | Occurs when the form is closed. (Inherited from Form.)
 | Closing | Occurs when the form is closing. (Inherited from Form.)
 | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | Contains(Control) | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
 | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
 | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
 | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
 | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
 | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
 | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
 | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
 | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
 | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
 | CreateAccessibilityInstance()()()() | Creates a new accessibility object for the control. (Inherited from Control.)
 | CreateControl()()()() | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
 | CreateControlsInstance()()()() | (Inherited from Form.)
 | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
 | CreateGraphics()()()() | Creates the Graphics for the control. (Inherited from Control.)
 | CreateHandle()()()() | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateParams | (Inherited from Form.)
 | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
 | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
 | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
 | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
 | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
 | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
 | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
 | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
 | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
 | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
 | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
 | DefaultSize | (Inherited from Form.)
 | DefWndProc(Message%) | (Inherited from Form.)
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
 | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
 | DestroyHandle()()()() | Destroys the handle associated with the control. (Inherited from Control.)
 | DeviceDpi()()()() | (Inherited from Control.)
 | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
 | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Form.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
 | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
 | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
 | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
 | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
 | DoDragDrop(Object, DragDropEffects) | Begins a drag-and-drop operation. (Inherited from Control.)
 | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
 | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
 | DpiChanged()()()() | (Inherited from Form.)
 | DpiChangedAfterParent()()()() | (Inherited from Control.)
 | DpiChangedBeforeParent()()()() | (Inherited from Control.)
 | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
 | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
 | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
 | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
 | DrawToBitmap(Bitmap, Rectangle) | Supports rendering to the specified bitmap. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
 | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
 | EndInvoke(IAsyncResult) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
 | Enter | Occurs when the control is entered. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | Finalize()()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | FindForm()()()() | Retrieves the form that the control is on. (Inherited from Control.)
 | Focus()()()() | Sets input focus to the control. (Inherited from Control.)
 | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
 | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
 | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
 | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
 | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
 | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
 | FormClosed | Occurs after the form is closed. (Inherited from Form.)
 | FormClosing | Occurs before the form is closed. (Inherited from Form.)
 | GetAccessibilityObjectById(Int32) | Retrieves the specified AccessibleObject. (Inherited from Control.)
 | GetAutoSizeMode()()()() | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
 | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
 | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
 | GetContainerControl()()()() | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetNextControl(Control, Boolean) | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
 | GetPreferredSize(Size) | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
 | GetScaledBounds(Rectangle, SizeF, BoundsSpecified) | (Inherited from Form.)
 | GetScrollState(Int32) | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetStyle(ControlStyles) | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
 | GetTopLevel()()()() | Determines if the control is a top-level control. (Inherited from Control.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
 | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
 | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
 | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
 | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
 | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the control. (Inherited from Control.)
 | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
 | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
 | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
 | Hide()()()() | Conceals the control from the user. (Inherited from Control.)
 | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
 | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
 | Icon | Gets or sets the icon for the form. (Inherited from Form.)
 | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
 | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
 | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | InitLayout()()()() | Called after the control has been added to another container. (Inherited from Control.)
 | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
 | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
 | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
 | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
 | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
 | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
 | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
 | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
 | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
 | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
 | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
 | InvokeGotFocus(Control, EventArgs) | Raises the GotFocus event for the specified control. (Inherited from Control.)
 | InvokeLostFocus(Control, EventArgs) | Raises the LostFocus event for the specified control. (Inherited from Control.)
 | InvokeOnClick(Control, EventArgs) | Raises the Click event for the specified control. (Inherited from Control.)
 | InvokePaint(Control, PaintEventArgs) | Raises the Paint event for the specified control. (Inherited from Control.)
 | InvokePaintBackground(Control, PaintEventArgs) | Raises the PaintBackground event for the specified control. (Inherited from Control.)
 | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
 | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
 | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
 | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
 | IsInputChar(Char) | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
 | IsInputKey(Keys) | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
 | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
 | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
 | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
 | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
 | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
 | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
 | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
 | keyTB | TB for key
 | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
 | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
 | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
 | LayoutMdi(MdiLayout) | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
 | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
 | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
 | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
 | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
 | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
 | LogicalToDeviceUnits(Int32) | (Inherited from Control.)
 | LogicalToDeviceUnits(Size) | (Inherited from Control.)
 | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
 | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
 | Margin | (Inherited from Form.)
 | MarginChanged | (Inherited from Form.)
 | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
 | MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
 | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
 | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
 | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
 | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
 | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
 | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
 | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
 | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
 | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
 | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
 | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
 | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
 | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
 | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
 | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
 | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
 | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
 | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
 | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
 | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
 | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
 | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
 | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
 | Move | Occurs when the control is moved. (Inherited from Control.)
 | Name | Gets or sets the name of the control. (Inherited from Control.)
 | NotifyInvalidate(Rectangle) | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
 | OnActivated(EventArgs) | Raises the Activated event. (Inherited from Form.)
 | OnAutoSizeChanged(EventArgs) | Raises the AutoSizeChanged event. (Inherited from Control.)
 | OnAutoValidateChanged(EventArgs) | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
 | OnBackColorChanged(EventArgs) | Raises the BackColorChanged event. (Inherited from Control.)
 | OnBackgroundImageChanged(EventArgs) | Raises the BackgroundImageChanged event. (Inherited from Form.)
 | OnBackgroundImageLayoutChanged(EventArgs) | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
 | OnBindingContextChanged(EventArgs) | Raises the BindingContextChanged event. (Inherited from Control.)
 | OnCausesValidationChanged(EventArgs) | Raises the CausesValidationChanged event. (Inherited from Control.)
 | OnChangeUICues(UICuesEventArgs) | Raises the ChangeUICues event. (Inherited from Control.)
 | OnClick(EventArgs) | Raises the Click event. (Inherited from Control.)
 | OnClientSizeChanged(EventArgs) | Raises the ClientSizeChanged event. (Inherited from Control.)
 | OnClosed(EventArgs) | Raises the Closed event. (Inherited from Form.)
 | OnClosing(CancelEventArgs) | Raises the Closing event. (Inherited from Form.)
 | OnContextMenuChanged(EventArgs) | Raises the ContextMenuChanged event. (Inherited from Control.)
 | OnContextMenuStripChanged(EventArgs) | Raises the ContextMenuStripChanged event. (Inherited from Control.)
 | OnControlAdded(ControlEventArgs) | Raises the ControlAdded event. (Inherited from Control.)
 | OnControlRemoved(ControlEventArgs) | Raises the ControlRemoved event. (Inherited from Control.)
 | OnCreateControl()()()() | Raises the CreateControl event. (Inherited from Form.)
 | OnCursorChanged(EventArgs) | Raises the CursorChanged event. (Inherited from Control.)
 | OnDeactivate(EventArgs) | Raises the Deactivate event. (Inherited from Form.)
 | OnDockChanged(EventArgs) | Raises the DockChanged event. (Inherited from Control.)
 | OnDoubleClick(EventArgs) | Raises the DoubleClick event. (Inherited from Control.)
 | OnDpiChanged(DpiChangedEventArgs) | (Inherited from Form.)
 | OnDpiChangedAfterParent(EventArgs) | (Inherited from Control.)
 | OnDpiChangedBeforeParent(EventArgs) | (Inherited from Control.)
 | OnDragDrop(DragEventArgs) | Raises the DragDrop event. (Inherited from Control.)
 | OnDragEnter(DragEventArgs) | Raises the DragEnter event. (Inherited from Control.)
 | OnDragLeave(EventArgs) | Raises the DragLeave event. (Inherited from Control.)
 | OnDragOver(DragEventArgs) | Raises the DragOver event. (Inherited from Control.)
 | OnEnabledChanged(EventArgs) | (Inherited from Form.)
 | OnEnter(EventArgs) | Raises the Enter event. (Inherited from Form.)
 | OnFontChanged(EventArgs) | (Inherited from Form.)
 | OnForeColorChanged(EventArgs) | Raises the ForeColorChanged event. (Inherited from Control.)
 | OnFormClosed(FormClosedEventArgs) | Raises the FormClosed event. (Inherited from Form.)
 | OnFormClosing(FormClosingEventArgs) | Raises the FormClosing event. (Inherited from Form.)
 | OnGetDpiScaledSize(Int32, Int32, Size%) | (Inherited from Form.)
 | OnGiveFeedback(GiveFeedbackEventArgs) | Raises the GiveFeedback event. (Inherited from Control.)
 | OnGotFocus(EventArgs) | Raises the GotFocus event. (Inherited from Control.)
 | OnHandleCreated(EventArgs) | (Inherited from Form.)
 | OnHandleDestroyed(EventArgs) | (Inherited from Form.)
 | OnHelpButtonClicked(CancelEventArgs) | Raises the HelpButtonClicked event. (Inherited from Form.)
 | OnHelpRequested(HelpEventArgs) | Raises the HelpRequested event. (Inherited from Control.)
 | OnImeModeChanged(EventArgs) | Raises the ImeModeChanged event. (Inherited from Control.)
 | OnInputLanguageChanged(InputLanguageChangedEventArgs) | Raises the InputLanguageChanged event. (Inherited from Form.)
 | OnInputLanguageChanging(InputLanguageChangingEventArgs) | Raises the InputLanguageChanging event. (Inherited from Form.)
 | OnInvalidated(InvalidateEventArgs) | Raises the Invalidated event. (Inherited from Control.)
 | OnKeyDown(KeyEventArgs) | Raises the KeyDown event. (Inherited from Control.)
 | OnKeyPress(KeyPressEventArgs) | Raises the KeyPress event. (Inherited from Control.)
 | OnKeyUp(KeyEventArgs) | Raises the KeyUp event. (Inherited from Control.)
 | OnLayout(LayoutEventArgs) | (Inherited from Form.)
 | OnLeave(EventArgs) | Raises the Leave event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Form.)
 | OnLocationChanged(EventArgs) | Raises the LocationChanged event. (Inherited from Control.)
 | OnLostFocus(EventArgs) | Raises the LostFocus event. (Inherited from Control.)
 | OnMarginChanged(EventArgs) | Raises the MarginChanged event. (Inherited from Control.)
 | OnMaximizedBoundsChanged(EventArgs) | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
 | OnMaximumSizeChanged(EventArgs) | Raises the MaximumSizeChanged event. (Inherited from Form.)
 | OnMdiChildActivate(EventArgs) | Raises the MdiChildActivate event. (Inherited from Form.)
 | OnMenuComplete(EventArgs) | Raises the MenuComplete event. (Inherited from Form.)
 | OnMenuStart(EventArgs) | Raises the MenuStart event. (Inherited from Form.)
 | OnMinimumSizeChanged(EventArgs) | Raises the MinimumSizeChanged event. (Inherited from Form.)
 | OnMouseCaptureChanged(EventArgs) | Raises the MouseCaptureChanged event. (Inherited from Control.)
 | OnMouseClick(MouseEventArgs) | Raises the MouseClick event. (Inherited from Control.)
 | OnMouseDoubleClick(MouseEventArgs) | Raises the MouseDoubleClick event. (Inherited from Control.)
 | OnMouseDown(MouseEventArgs) | Raises the MouseDown event. (Inherited from Control.)
 | OnMouseEnter(EventArgs) | Raises the MouseEnter event. (Inherited from Control.)
 | OnMouseHover(EventArgs) | Raises the MouseHover event. (Inherited from Control.)
 | OnMouseLeave(EventArgs) | Raises the MouseLeave event. (Inherited from Control.)
 | OnMouseMove(MouseEventArgs) | Raises the MouseMove event. (Inherited from Control.)
 | OnMouseUp(MouseEventArgs) | Raises the MouseUp event. (Inherited from Control.)
 | OnMouseWheel(MouseEventArgs) | Raises the MouseWheel event. (Inherited from ScrollableControl.)
 | OnMove(EventArgs) | Raises the Move event. (Inherited from Control.)
 | OnNotifyMessage(Message) | Notifies the control of Windows messages. (Inherited from Control.)
 | OnPaddingChanged(EventArgs) | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
 | OnPaint(PaintEventArgs) | (Inherited from Form.)
 | OnPaintBackground(PaintEventArgs) | Paints the background of the control. (Inherited from ScrollableControl.)
 | OnParentBackColorChanged(EventArgs) | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
 | OnParentBackgroundImageChanged(EventArgs) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
 | OnParentBindingContextChanged(EventArgs) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
 | OnParentChanged(EventArgs) | (Inherited from ContainerControl.)
 | OnParentCursorChanged(EventArgs) | Raises the CursorChanged event. (Inherited from Control.)
 | OnParentEnabledChanged(EventArgs) | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
 | OnParentFontChanged(EventArgs) | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
 | OnParentForeColorChanged(EventArgs) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
 | OnParentRightToLeftChanged(EventArgs) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
 | OnParentVisibleChanged(EventArgs) | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
 | OnPreviewKeyDown(PreviewKeyDownEventArgs) | Raises the PreviewKeyDown event. (Inherited from Control.)
 | OnPrint(PaintEventArgs) | Raises the Paint event. (Inherited from Control.)
 | OnQueryContinueDrag(QueryContinueDragEventArgs) | Raises the QueryContinueDrag event. (Inherited from Control.)
 | OnRegionChanged(EventArgs) | Raises the RegionChanged event. (Inherited from Control.)
 | OnResize(EventArgs) | (Inherited from Form.)
 | OnResizeBegin(EventArgs) | Raises the ResizeBegin event. (Inherited from Form.)
 | OnResizeEnd(EventArgs) | Raises the ResizeEnd event. (Inherited from Form.)
 | OnRightToLeftChanged(EventArgs) | (Inherited from ScrollableControl.)
 | OnRightToLeftLayoutChanged(EventArgs) | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
 | OnScroll(ScrollEventArgs) | Raises the Scroll event. (Inherited from ScrollableControl.)
 | OnShown(EventArgs) | Raises the Shown event. (Inherited from Form.)
 | OnSizeChanged(EventArgs) | Raises the SizeChanged event. (Inherited from Control.)
 | OnStyleChanged(EventArgs) | (Inherited from Form.)
 | OnSystemColorsChanged(EventArgs) | Raises the SystemColorsChanged event. (Inherited from Control.)
 | OnTabIndexChanged(EventArgs) | Raises the TabIndexChanged event. (Inherited from Control.)
 | OnTabStopChanged(EventArgs) | Raises the TabStopChanged event. (Inherited from Control.)
 | OnTextChanged(EventArgs) | (Inherited from Form.)
 | OnValidated(EventArgs) | Raises the Validated event. (Inherited from Control.)
 | OnValidating(CancelEventArgs) | Raises the Validating event. (Inherited from Control.)
 | OnVisibleChanged(EventArgs) | Raises the VisibleChanged event. (Inherited from Form.)
 | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
 | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
 | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
 | Padding | Gets or sets padding within the control. (Inherited from Control.)
 | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
 | Paint | Occurs when the control is redrawn. (Inherited from Control.)
 | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
 | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
 | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
 | PerformAutoScale()()()() | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
 | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
 | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
 | PointToClient(Point) | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
 | PointToScreen(Point) | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
 | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
 | PreProcessControlMessage(Message%) | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
 | PreProcessMessage(Message%) | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
 | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
 | ProcessCmdKey(Message%, Keys) | Processes a command key. (Inherited from Form.)
 | ProcessDialogChar(Char) | (Inherited from Form.)
 | ProcessDialogKey(Keys) | Processes a dialog box key. (Inherited from Form.)
 | ProcessKeyEventArgs(Message%) | Processes a key message and generates the appropriate control events. (Inherited from Control.)
 | ProcessKeyMessage(Message%) | Processes a keyboard message. (Inherited from Control.)
 | ProcessKeyPreview(Message%) | (Inherited from Form.)
 | ProcessMnemonic(Char) | (Inherited from Form.)
 | ProcessTabKey(Boolean) | (Inherited from Form.)
 | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
 | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
 | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
 | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
 | RaiseDragEvent(Object, DragEventArgs) | Raises the appropriate drag event. (Inherited from Control.)
 | RaiseKeyEvent(Object, KeyEventArgs) | Raises the appropriate key event. (Inherited from Control.)
 | RaiseMouseEvent(Object, MouseEventArgs) | Raises the appropriate mouse event. (Inherited from Control.)
 | RaisePaintEvent(Object, PaintEventArgs) | Raises the appropriate paint event. (Inherited from Control.)
 | RecreateHandle()()()() | Forces the re-creation of the handle for the control. (Inherited from Control.)
 | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
 | RectangleToClient(Rectangle) | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
 | RectangleToScreen(Rectangle) | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
 | Refresh()()()() | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
 | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
 | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
 | registerClicked |
 | RemoveOwnedForm(Form) | Removes an owned form from this form. (Inherited from Form.)
 | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
 | RescaleConstantsForDpi(Int32, Int32) | (Inherited from Control.)
 | ResetBackColor()()()() | Resets the BackColor property to its default value. (Inherited from Control.)
 | ResetBindings()()()() | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
 | ResetCursor()()()() | Resets the Cursor property to its default value. (Inherited from Control.)
 | ResetFont()()()() | Resets the Font property to its default value. (Inherited from Control.)
 | ResetForeColor()()()() | Resets the ForeColor property to its default value. (Inherited from Control.)
 | ResetImeMode()()()() | Resets the ImeMode property to its default value. (Inherited from Control.)
 | ResetMouseEventArgs()()()() | Resets the control to handle the MouseLeave event. (Inherited from Control.)
 | ResetRightToLeft()()()() | Resets the RightToLeft property to its default value. (Inherited from Control.)
 | ResetText()()()() | Resets the Text property to its default value. (Inherited from Control.)
 | Resize | Occurs when the control is resized. (Inherited from Control.)
 | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
 | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
 | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
 | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
 | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
 | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
 | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
 | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
 | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
 | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
 | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
 | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateContent(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateHorizontal(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateLeftRight(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
 | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
 | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
 | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
 | ScaleBitmapLogicalToDevice(Bitmap%) | (Inherited from Control.)
 | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
 | ScaleControl(SizeF, BoundsSpecified) | (Inherited from Form.)
 | ScaleCore(Single, Single) | Performs scaling of the form. (Inherited from Form.)
 | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
 | ScrollControlIntoView(Control) | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
 | ScrollToControl(Control) | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
 | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
 | Select()()()() | Activates the control. (Inherited from Control.)
 | SelectNextControl(Control, Boolean, Boolean, Boolean, Boolean) | Activates the next control. (Inherited from Control.)
 | SendToBack()()()() | Sends the control to the back of the z-order. (Inherited from Control.)
 | SetAutoScrollMargin(Int32, Int32) | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
 | SetAutoSizeMode(AutoSizeMode) | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
 | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
 | SetBoundsCore(Int32, Int32, Int32, Int32, BoundsSpecified) | (Inherited from Form.)
 | SetClientSizeCore(Int32, Int32) | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
 | SetDesktopBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
 | SetDesktopLocation(Int32, Int32) | Sets the location of the form in desktop coordinates. (Inherited from Form.)
 | SetDisplayRectLocation(Int32, Int32) | Positions the display window to the specified value. (Inherited from ScrollableControl.)
 | SetScrollState(Int32, Boolean) | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
 | SetStyle(ControlStyles, Boolean) | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
 | SetTopLevel(Boolean) | Sets the control as the top-level control. (Inherited from Control.)
 | SetVisibleCore(Boolean) | (Inherited from Form.)
 | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
 | Show()()()() | Displays the control to the user. (Inherited from Control.)
 | ShowDialog()()()() | Shows the form as a modal dialog box. (Inherited from Form.)
 | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
 | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
 | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
 | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
 | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
 | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
 | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
 | Site | Gets or sets the site of the control. (Inherited from Control.)
 | Size | Gets or sets the size of the form. (Inherited from Form.)
 | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
 | SizeFromClientSize(Size) | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
 | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
 | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
 | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
 | SuspendLayout()()()() | Temporarily suspends the layout logic for the control. (Inherited from Control.)
 | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
 | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
 | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
 | TabStop | (Inherited from Form.)
 | TabStopChanged | (Inherited from Form.)
 | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
 | Text | (Inherited from Form.)
 | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
 | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
 | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
 | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
 | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
 | ToString()()()() | Gets a string representing the current instance of the form. (Inherited from Form.)
 | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
 | Update()()()() | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
 | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
 | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
 | UpdateDefaultButton()()()() | Updates which button is the default button. (Inherited from Form.)
 | UpdateStyles()()()() | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
 | UpdateZOrder()()()() | Updates the control in its parent's z-order. (Inherited from Control.)
 | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
 | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
 | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
 | ValidateChildren()()()() | (Inherited from Form.)
 | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
 | Validated | Occurs when the control is finished validating. (Inherited from Control.)
 | Validating | Occurs when the control is validating. (Inherited from Control.)
 | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
 | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
 | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
 | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
 | Width | Gets or sets the width of the control. (Inherited from Control.)
 | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
 | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
 | WndProc(Message%) | (Inherited from Form.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | Control
 |  |  |  | ScrollableControl
 |  |  |  |  | ContainerControl
 |  |  |  |  |  | Form
 |  |  |  |  |  |  | RegisterForm


RegisterForm Constructor

Keyoti RapidSpell Desktop .NET API Docs
RegisterForm Constructor
API ► Keyoti.RapidSpell ► RegisterForm ► RegisterForm()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | RegisterForm()()()() |
 | RegisterForm(Boolean) | New instance


RegisterForm Constructor

Keyoti RapidSpell Desktop .NET API Docs
RegisterForm Constructor
API ► Keyoti.RapidSpell ► RegisterForm ► RegisterForm()()()()
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public RegisterForm()
public RegisterForm()
Public Sub New
Public Sub New
public:
RegisterForm()
public:
RegisterForm()
new : unit -> RegisterForm
new : unit -> RegisterForm


RegisterForm Constructor (launchedFromTool)

Keyoti RapidSpell Desktop .NET API Docs
RegisterForm Constructor (launchedFromTool)
API ► Keyoti.RapidSpell ► RegisterForm ► RegisterForm(Boolean)
Keyoti RapidSpell Desktop .NET
New instance
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public RegisterForm(
    bool launchedFromTool
)
public RegisterForm(
    bool launchedFromTool
)
Public Sub New (
    launchedFromTool As Boolean
)
Public Sub New (
    launchedFromTool As Boolean
)
public:
RegisterForm(
    bool launchedFromTool
)
public:
RegisterForm(
    bool launchedFromTool
)
new :
        launchedFromTool : bool -> RegisterForm
new :
        launchedFromTool : bool -> RegisterForm
Parameters
launchedFromTool (Boolean)


Dispose Method (disposing)

Keyoti RapidSpell Desktop .NET API Docs
Dispose Method (disposing)
API ► Keyoti.RapidSpell ► RegisterForm ► Dispose(Boolean)
Keyoti RapidSpell Desktop .NET
Clean up any resources being used.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
Parameters
disposing (Boolean)


keyTB Field

Keyoti RapidSpell Desktop .NET API Docs
keyTB Field
API ► Keyoti.RapidSpell ► RegisterForm ► keyTB
Keyoti RapidSpell Desktop .NET
TB for key
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public TextBox keyTB
public TextBox keyTB
Public keyTB As TextBox
Public keyTB As TextBox
public:
TextBox^ keyTB
public:
TextBox^ keyTB
val mutable keyTB: TextBox
val mutable keyTB: TextBox
Field Value
TextBox


registerClicked Field

Keyoti RapidSpell Desktop .NET API Docs
registerClicked Field
API ► Keyoti.RapidSpell ► RegisterForm ► registerClicked
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool registerClicked
public bool registerClicked
Public registerClicked As Boolean
Public registerClicked As Boolean
public:
bool registerClicked
public:
bool registerClicked
val mutable registerClicked: bool
val mutable registerClicked: bool
Field Value
Boolean


RichTextBoxIAYTAdapter Class

Keyoti RapidSpell Desktop .NET API Docs
RichTextBoxIAYTAdapter Class
API ► Keyoti.RapidSpell ► RichTextBoxIAYTAdapter
Keyoti RapidSpell Desktop .NET
Internal wrapper for RichTextBox
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class RichTextBoxIAYTAdapter : TextBoxBaseIAYTAdapter
public class RichTextBoxIAYTAdapter : TextBoxBaseIAYTAdapter
Public Class RichTextBoxIAYTAdapter
    Inherits TextBoxBaseIAYTAdapter
Public Class RichTextBoxIAYTAdapter
    Inherits TextBoxBaseIAYTAdapter
public ref class RichTextBoxIAYTAdapter : public TextBoxBaseIAYTAdapter
public ref class RichTextBoxIAYTAdapter : public TextBoxBaseIAYTAdapter
type RichTextBoxIAYTAdapter =
    class
        inherit TextBoxBaseIAYTAdapter
    end
type RichTextBoxIAYTAdapter =
    class
        inherit TextBoxBaseIAYTAdapter
    end
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RichTextBoxIAYTAdapter(RichTextBox, Boolean) | New instance
 | AddHandlers()()()() | Adds handlers (Overrides TextBoxBaseIAYTAdapter.AddHandlers()()()().)
 | BeginInvoke(Delegate) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from TextBoxBaseIAYTAdapter.)
 | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from TextBoxBaseIAYTAdapter.)
 | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from TextBoxBaseIAYTAdapter.)
 | ContextMenu | Gets or sets the shortcut menu associated with the control (Inherited from TextBoxBaseIAYTAdapter.)
 | ContextMenuDefault | The context menu that will be shown when the right click is not on a misspelled word. (Inherited from TextBoxBaseIAYTAdapter.)
 | ContextMenuStrip | The context menu that will be shown when the right click is not on a misspelled word. (Inherited from TextBoxBaseIAYTAdapter.)
 | ContextMenuStripDefault | The context menu that will be shown when the right click is not on a misspelled word. (Inherited from TextBoxBaseIAYTAdapter.)
 | ControlBackgroundPaint | Event fired when Windows level background repaint occurs. (Inherited from TextBoxBaseIAYTAdapter.)
 | ControlPaint | Event fired when Windows level repaint occurs. (Inherited from TextBoxBaseIAYTAdapter.)
 | DefaultContextMenu | The context menu that will be shown when the right click is not on a misspelled word. (Inherited from TextBoxBaseIAYTAdapter.)
 | Disposed | Event fires when component is Disposed. (Inherited from TextBoxBaseIAYTAdapter.)
 | Disposing | See IAYTextBox (Inherited from TextBoxBaseIAYTAdapter.)
 | Enabled | Internal (Inherited from TextBoxBaseIAYTAdapter.)
 | Enter | Occurs when the control receives focus. (Inherited from TextBoxBaseIAYTAdapter.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FindForm()()()() | Internal (Inherited from TextBoxBaseIAYTAdapter.)
 | Font | Gets or sets the font of the text displayed by the control. (Inherited from TextBoxBaseIAYTAdapter.)
 | FontChanged | Internal (Inherited from TextBoxBaseIAYTAdapter.)
 | FormatChanged | Event fired when formatting changes (such as font change). (Inherited from TextBoxBaseIAYTAdapter.)
 | GetBaselineOffsetAtCharIndex(Int32) | See IAYTTextBox (Overrides TextBoxBaseIAYTAdapter.GetBaselineOffsetAtCharIndex(Int32).)
 | GetCharIndexFromPos(Point) | gets the char index from a position point. (Inherited from TextBoxBaseIAYTAdapter.)
 | GetFirstVisibleCharIndex()()()() | Gets the character index of the first visible character in the window, this is for optimization and can just return 0 if unavailable. (Inherited from TextBoxBaseIAYTAdapter.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLineFromCharIndex(Int32) | Gets the line number that char index is on (Inherited from TextBoxBaseIAYTAdapter.)
 | GetPosFromCharIndex(Int32) | Gets the position point from the char index (Inherited from TextBoxBaseIAYTAdapter.)
 | GetTBU()()()() | Interface requirement (Inherited from TextBoxBaseIAYTAdapter.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | Handle | Gets the window handle that the control is bound to. (Inherited from TextBoxBaseIAYTAdapter.)
 | Height | Gets or sets the height of the control. (Inherited from TextBoxBaseIAYTAdapter.)
 | HScrolled | Event fired when horizontal scroll changed (by anything). (Inherited from TextBoxBaseIAYTAdapter.)
 | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from TextBoxBaseIAYTAdapter.)
 | IsHandleCreated | Same as Control.IsHandleCreated (Inherited from TextBoxBaseIAYTAdapter.)
 | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from TextBoxBaseIAYTAdapter.)
 | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from TextBoxBaseIAYTAdapter.)
 | KeyUp | Occurs when a key is released while the control has focus. (Inherited from TextBoxBaseIAYTAdapter.)
 | Leave | Occurs when the control loses focus. (Inherited from TextBoxBaseIAYTAdapter.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from TextBoxBaseIAYTAdapter.)
 | MouseUp | Occurs when the mouse is released on the text box. (Inherited from TextBoxBaseIAYTAdapter.)
 | MouseWheel | Occurs when the mouse wheel is used to scroll. (Inherited from TextBoxBaseIAYTAdapter.)
 | Parent | See IAYTextBox (Inherited from TextBoxBaseIAYTAdapter.)
 | ReadOnly | Internal (Inherited from TextBoxBaseIAYTAdapter.)
 | RecreatingHandle | See IAYTextBox (Inherited from TextBoxBaseIAYTAdapter.)
 | Refresh()()()() | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from TextBoxBaseIAYTAdapter.)
 | RemoveEventHandlers()()()() | Removes event handlers (Overrides TextBoxBaseIAYTAdapter.RemoveEventHandlers()()()().)
 | Resize | Occurs when the control is resized. (Inherited from TextBoxBaseIAYTAdapter.)
 | ScrollCaret | Occurs when the text box is scrolled to the caret. (Inherited from TextBoxBaseIAYTAdapter.)
 | SelectedText | This member overrides TextBox.SelectedText. (Inherited from TextBoxBaseIAYTAdapter.)
 | SelectionChanged | Occurs when the selection of text within the control has changed. (Inherited from TextBoxBaseIAYTAdapter.)
 | SelectionLength | This member overrides TextBox.SelectionLength. (Inherited from TextBoxBaseIAYTAdapter.)
 | SelectionStart | Gets or sets the starting point of text selected in the text box. (Inherited from TextBoxBaseIAYTAdapter.)
 | ShowCutCopyPasteContextMenu | Whether to show the standard Undo/Cut/Copy/Paste/Delete/Select All context menu. (Inherited from TextBoxBaseIAYTAdapter.)
 | SuspendLayout()()()() | Internal (Inherited from TextBoxBaseIAYTAdapter.)
 | tbb | Wrapped control (Inherited from TextBoxBaseIAYTAdapter.)
 | tbu | The painter. (Inherited from TextBoxBaseIAYTAdapter.)
 | Text | This member overrides TextBox.Text. (Inherited from TextBoxBaseIAYTAdapter.)
 | TextChanged | Occurs when the Text property value changes. (Inherited from TextBoxBaseIAYTAdapter.)
 | TextLength | Gets the current text length in the text box. (Inherited from TextBoxBaseIAYTAdapter.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | UnderlineYOffset | Controls the position of the underline relative to the baseline. (Inherited from TextBoxBaseIAYTAdapter.)
 | VScrolled | Event fired when vertical scroll changed (by anything). (Inherited from TextBoxBaseIAYTAdapter.)
 | VScrollEnd | Event fired when vertical scroll ends. (Inherited from TextBoxBaseIAYTAdapter.)
 | Width | Gets or sets the width of the control. (Inherited from TextBoxBaseIAYTAdapter.)
Inheritance Hierarchy
Object
 | TextBoxBaseIAYTAdapter
 |  | RichTextBoxIAYTAdapter


RichTextBoxIAYTAdapter Constructor (tbb, createCutCopyPasteReplacement)

Keyoti RapidSpell Desktop .NET API Docs
RichTextBoxIAYTAdapter Constructor (tbb, createCutCopyPasteReplacement)
API ► Keyoti.RapidSpell ► RichTextBoxIAYTAdapter ► RichTextBoxIAYTAdapter(RichTextBox, Boolean)
Keyoti RapidSpell Desktop .NET
New instance
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected internal RichTextBoxIAYTAdapter(
    RichTextBox tbb,
    bool createCutCopyPasteReplacement
)
protected internal RichTextBoxIAYTAdapter(
    RichTextBox tbb,
    bool createCutCopyPasteReplacement
)
Protected Friend Sub New (
    tbb As RichTextBox,
    createCutCopyPasteReplacement As Boolean
)
Protected Friend Sub New (
    tbb As RichTextBox,
    createCutCopyPasteReplacement As Boolean
)
protected public:
RichTextBoxIAYTAdapter(
    RichTextBox^ tbb,
    bool createCutCopyPasteReplacement
)
protected public:
RichTextBoxIAYTAdapter(
    RichTextBox^ tbb,
    bool createCutCopyPasteReplacement
)
new :
        tbb : RichTextBox *
        createCutCopyPasteReplacement : bool -> RichTextBoxIAYTAdapter
new :
        tbb : RichTextBox *
        createCutCopyPasteReplacement : bool -> RichTextBoxIAYTAdapter
Parameters
tbb (RichTextBox)
createCutCopyPasteReplacement (Boolean)


AddHandlers Method

Keyoti RapidSpell Desktop .NET API Docs
AddHandlers Method
API ► Keyoti.RapidSpell ► RichTextBoxIAYTAdapter ► AddHandlers()()()()
Keyoti RapidSpell Desktop .NET
Adds handlers
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override void AddHandlers()
protected override void AddHandlers()
Protected Overrides Sub AddHandlers
Protected Overrides Sub AddHandlers
protected:
virtual void AddHandlers() override
protected:
virtual void AddHandlers() override
abstract AddHandlers : unit -> unit
override AddHandlers : unit -> unit
abstract AddHandlers : unit -> unit
override AddHandlers : unit -> unit


GetBaselineOffsetAtCharIndex Method (i)

Keyoti RapidSpell Desktop .NET API Docs
GetBaselineOffsetAtCharIndex Method (i)
API ► Keyoti.RapidSpell ► RichTextBoxIAYTAdapter ► GetBaselineOffsetAtCharIndex(Int32)
Keyoti RapidSpell Desktop .NET
See IAYTTextBox
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override int GetBaselineOffsetAtCharIndex(
    int i
)
public override int GetBaselineOffsetAtCharIndex(
    int i
)
Public Overrides Function GetBaselineOffsetAtCharIndex (
    i As Integer
) As Integer
Public Overrides Function GetBaselineOffsetAtCharIndex (
    i As Integer
) As Integer
public:
virtual int GetBaselineOffsetAtCharIndex(
    int i
) override
public:
virtual int GetBaselineOffsetAtCharIndex(
    int i
) override
abstract GetBaselineOffsetAtCharIndex :
        i : int -> int
override GetBaselineOffsetAtCharIndex :
        i : int -> int
abstract GetBaselineOffsetAtCharIndex :
        i : int -> int
override GetBaselineOffsetAtCharIndex :
        i : int -> int
Parameters
i (Int32)
Return Value
Int32


RemoveEventHandlers Method

Keyoti RapidSpell Desktop .NET API Docs
RemoveEventHandlers Method
API ► Keyoti.RapidSpell ► RichTextBoxIAYTAdapter ► RemoveEventHandlers()()()()
Keyoti RapidSpell Desktop .NET
Removes event handlers
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override void RemoveEventHandlers()
protected override void RemoveEventHandlers()
Protected Overrides Sub RemoveEventHandlers
Protected Overrides Sub RemoveEventHandlers
protected:
virtual void RemoveEventHandlers() override
protected:
virtual void RemoveEventHandlers() override
abstract RemoveEventHandlers : unit -> unit
override RemoveEventHandlers : unit -> unit
abstract RemoveEventHandlers : unit -> unit
override RemoveEventHandlers : unit -> unit


SpellContextMenuRequestEventHandler Delegate

Keyoti RapidSpell Desktop .NET API Docs
SpellContextMenuRequestEventHandler Delegate
API ► Keyoti.RapidSpell ► SpellContextMenuRequestEventHandler
Keyoti RapidSpell Desktop .NET
Handler delegate
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void SpellContextMenuRequestEventHandler(
    Object sender,
    SpellContextMenuEventArgs e
)
public delegate void SpellContextMenuRequestEventHandler(
    Object sender,
    SpellContextMenuEventArgs e
)
Public Delegate Sub SpellContextMenuRequestEventHandler (
    sender As Object,
    e As SpellContextMenuEventArgs
)
Public Delegate Sub SpellContextMenuRequestEventHandler (
    sender As Object,
    e As SpellContextMenuEventArgs
)
public delegate void SpellContextMenuRequestEventHandler(
    Object^ sender,
    SpellContextMenuEventArgs^ e
)
public delegate void SpellContextMenuRequestEventHandler(
    Object^ sender,
    SpellContextMenuEventArgs^ e
)
type SpellContextMenuRequestEventHandler =
    delegate of
        sender : Object *
        e : SpellContextMenuEventArgs -> unit
type SpellContextMenuRequestEventHandler =
    delegate of
        sender : Object *
        e : SpellContextMenuEventArgs -> unit
Parameters
sender (Object)
e (SpellContextMenuEventArgs)


SpellingDictionary Class

Keyoti RapidSpell Desktop .NET API Docs
SpellingDictionary Class
API ► Keyoti.RapidSpell ► SpellingDictionary
Keyoti RapidSpell Desktop .NET
Helper
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class SpellingDictionary
public class SpellingDictionary
Public Class SpellingDictionary
Public Class SpellingDictionary
public ref class SpellingDictionary
public ref class SpellingDictionary
type SpellingDictionary =  class end
type SpellingDictionary =  class end
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | LastModified | Helper
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Path | Helper
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
SpellingDictionary


LastModified Property

Keyoti RapidSpell Desktop .NET API Docs
LastModified Property
API ► Keyoti.RapidSpell ► SpellingDictionary ► LastModified
Keyoti RapidSpell Desktop .NET
Helper
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public DateTime LastModified { get; }
public DateTime LastModified { get; }
Public ReadOnly Property LastModified As DateTime
    Get
Public ReadOnly Property LastModified As DateTime
    Get
public:
property DateTime LastModified {
    DateTime get ();
}
public:
property DateTime LastModified {
    DateTime get ();
}
member LastModified : DateTime with get

member LastModified : DateTime with get
Property Value
DateTime


Path Property

Keyoti RapidSpell Desktop .NET API Docs
Path Property
API ► Keyoti.RapidSpell ► SpellingDictionary ► Path
Keyoti RapidSpell Desktop .NET
Helper
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string Path { get; }
public string Path { get; }
Public ReadOnly Property Path As String
    Get
Public ReadOnly Property Path As String
    Get
public:
property String^ Path {
    String^ get ();
}
public:
property String^ Path {
    String^ get ();
}
member Path : string with get

member Path : string with get
Property Value
String


Suggestion Class

Keyoti RapidSpell Desktop .NET API Docs
Suggestion Class
API ► Keyoti.RapidSpell ► Suggestion
Keyoti RapidSpell Desktop .NET
Represents a suggestion.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class Suggestion
public class Suggestion
Public Class Suggestion
Public Class Suggestion
public ref class Suggestion
public ref class Suggestion
type Suggestion =  class end
type Suggestion =  class end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Suggestion(String, Int32) | Creates an instance
 | Contains(ArrayList, Suggestion) | Returns true if suggestion is in list.
 | Contains(ArrayList, String) | Returns true if suggestion is in list.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Score | The score 0-1000 of how suitable suggestion is. -1 if unknown
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Word | The suggested word.
Inheritance Hierarchy
Object
Suggestion


Suggestion Constructor (word, score)

Keyoti RapidSpell Desktop .NET API Docs
Suggestion Constructor (word, score)
API ► Keyoti.RapidSpell ► Suggestion ► Suggestion(String, Int32)
Keyoti RapidSpell Desktop .NET
Creates an instance
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Suggestion(
    string word,
    int score
)
public Suggestion(
    string word,
    int score
)
Public Sub New (
    word As String,
    score As Integer
)
Public Sub New (
    word As String,
    score As Integer
)
public:
Suggestion(
    String^ word,
    int score
)
public:
Suggestion(
    String^ word,
    int score
)
new :
        word : string *
        score : int -> Suggestion
new :
        word : string *
        score : int -> Suggestion
Parameters
word (String)
The suggested word
score (Int32)
The score 0-1000 of how suitable suggestion is.


Contains Method

Keyoti RapidSpell Desktop .NET API Docs
Contains Method
API ► Keyoti.RapidSpell ► Suggestion ► Contains()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Contains(ArrayList, Suggestion) | Returns true if suggestion is in list.
 | Contains(ArrayList, String) | Returns true if suggestion is in list.


Contains Method (list, suggestion)

Keyoti RapidSpell Desktop .NET API Docs
Contains Method (list, suggestion)
API ► Keyoti.RapidSpell ► Suggestion ► Contains(ArrayList, Suggestion)
Keyoti RapidSpell Desktop .NET
Returns true if suggestion is in list.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static bool Contains(
    ArrayList list,
    Suggestion suggestion
)
public static bool Contains(
    ArrayList list,
    Suggestion suggestion
)
Public Shared Function Contains (
    list As ArrayList,
    suggestion As Suggestion
) As Boolean
Public Shared Function Contains (
    list As ArrayList,
    suggestion As Suggestion
) As Boolean
public:
static bool Contains(
    ArrayList^ list,
    Suggestion^ suggestion
)
public:
static bool Contains(
    ArrayList^ list,
    Suggestion^ suggestion
)
static member Contains :
        list : ArrayList *
        suggestion : Suggestion -> bool

static member Contains :
        list : ArrayList *
        suggestion : Suggestion -> bool
Parameters
list (ArrayList)
suggestion (Suggestion)
Return Value
Boolean


Contains Method (list, suggestion)

Keyoti RapidSpell Desktop .NET API Docs
Contains Method (list, suggestion)
API ► Keyoti.RapidSpell ► Suggestion ► Contains(ArrayList, String)
Keyoti RapidSpell Desktop .NET
Returns true if suggestion is in list.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static bool Contains(
    ArrayList list,
    string suggestion
)
public static bool Contains(
    ArrayList list,
    string suggestion
)
Public Shared Function Contains (
    list As ArrayList,
    suggestion As String
) As Boolean
Public Shared Function Contains (
    list As ArrayList,
    suggestion As String
) As Boolean
public:
static bool Contains(
    ArrayList^ list,
    String^ suggestion
)
public:
static bool Contains(
    ArrayList^ list,
    String^ suggestion
)
static member Contains :
        list : ArrayList *
        suggestion : string -> bool

static member Contains :
        list : ArrayList *
        suggestion : string -> bool
Parameters
list (ArrayList)
suggestion (String)
Return Value
Boolean


Score Property

Keyoti RapidSpell Desktop .NET API Docs
Score Property
API ► Keyoti.RapidSpell ► Suggestion ► Score
Keyoti RapidSpell Desktop .NET
The score 0-1000 of how suitable suggestion is. -1 if unknown
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual int Score { get; set; }
public virtual int Score { get; set; }
Public Overridable Property Score As Integer
    Get
    Set
Public Overridable Property Score As Integer
    Get
    Set
public:
virtual property int Score {
    int get ();
    void set (int value);
}
public:
virtual property int Score {
    int get ();
    void set (int value);
}
abstract Score : int with get, set
override Score : int with get, set
abstract Score : int with get, set
override Score : int with get, set
Property Value
Int32


Word Property

Keyoti RapidSpell Desktop .NET API Docs
Word Property
API ► Keyoti.RapidSpell ► Suggestion ► Word
Keyoti RapidSpell Desktop .NET
The suggested word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual string Word { get; set; }
public virtual string Word { get; set; }
Public Overridable Property Word As String
    Get
    Set
Public Overridable Property Word As String
    Get
    Set
public:
virtual property String^ Word {
    String^ get ();
    void set (String^ value);
}
public:
virtual property String^ Word {
    String^ get ();
    void set (String^ value);
}
abstract Word : string with get, set
override Word : string with get, set
abstract Word : string with get, set
override Word : string with get, set
Property Value
String


SuggestionsMethodType Enumeration

Keyoti RapidSpell Desktop .NET API Docs
SuggestionsMethodType Enumeration
API ► Keyoti.RapidSpell ► SuggestionsMethodType
Keyoti RapidSpell Desktop .NET
Suggestions algorithm identifiers.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public enum SuggestionsMethodType
public enum SuggestionsMethodType
Public Enumeration SuggestionsMethodType
Public Enumeration SuggestionsMethodType
public enum class SuggestionsMethodType
public enum class SuggestionsMethodType
type SuggestionsMethodType
type SuggestionsMethodType
Members
Member | Description
PhoneticSuggestions | Phonetic (sounds like) algorithm
HashingSuggestions | Hashing (closest match) algorithm


TextBoxBaseIAYTAdapter Class

Keyoti RapidSpell Desktop .NET API Docs
TextBoxBaseIAYTAdapter Class
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter
Keyoti RapidSpell Desktop .NET
Internal wrapper for TextBoxBase
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class TextBoxBaseIAYTAdapter : IAYTTextBox
public class TextBoxBaseIAYTAdapter : IAYTTextBox
Public Class TextBoxBaseIAYTAdapter
    Implements IAYTTextBox
Public Class TextBoxBaseIAYTAdapter
    Implements IAYTTextBox
public ref class TextBoxBaseIAYTAdapter : IAYTTextBox
public ref class TextBoxBaseIAYTAdapter : IAYTTextBox
type TextBoxBaseIAYTAdapter =
    class
        interface IAYTTextBox
    end
type TextBoxBaseIAYTAdapter =
    class
        interface IAYTTextBox
    end
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TextBoxBaseIAYTAdapter(TextBoxBase, Boolean) | New instance
 | AddHandlers()()()() | Adds handlers
 | BeginInvoke(Delegate) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
 | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
 | ClientSize | Gets or sets the height and width of the client area of the control.
 | ContextMenu | Gets or sets the shortcut menu associated with the control
 | ContextMenuDefault | The context menu that will be shown when the right click is not on a misspelled word.
 | ContextMenuStrip | The context menu that will be shown when the right click is not on a misspelled word.
 | ContextMenuStripDefault | The context menu that will be shown when the right click is not on a misspelled word.
 | ControlBackgroundPaint | Event fired when Windows level background repaint occurs.
 | ControlPaint | Event fired when Windows level repaint occurs.
 | Create(TextBoxBase, Boolean) | Creates a new adapter.
 | DefaultContextMenu | The context menu that will be shown when the right click is not on a misspelled word.
 | Disposed | Event fires when component is Disposed.
 | Disposing | See IAYTextBox
 | Enabled | Internal
 | Enter | Occurs when the control receives focus.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FindForm()()()() | Internal
 | Font | Gets or sets the font of the text displayed by the control.
 | FontChanged | Internal
 | FormatChanged | Event fired when formatting changes (such as font change).
 | GetBaselineOffsetAtCharIndex(Int32) | Gets the baseline offset for a character at index i
 | GetCharIndexFromPos(Point) | gets the char index from a position point.
 | GetFirstVisibleCharIndex()()()() | Gets the character index of the first visible character in the window, this is for optimization and can just return 0 if unavailable.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLineFromCharIndex(Int32) | Gets the line number that char index is on
 | GetPosFromCharIndex(Int32) | Gets the position point from the char index
 | GetTBU()()()() | Interface requirement
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | Handle | Gets the window handle that the control is bound to.
 | Height | Gets or sets the height of the control.
 | HScrolled | Event fired when horizontal scroll changed (by anything).
 | IsDisposed | Gets a value indicating whether the control has been disposed of.
 | IsHandleCreated | Same as Control.IsHandleCreated
 | KeyDown | Occurs when a key is pressed while the control has focus.
 | KeyPress | Occurs when a key is pressed while the control has focus.
 | KeyUp | Occurs when a key is released while the control has focus.
 | Leave | Occurs when the control loses focus.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed.
 | MouseUp | Occurs when the mouse is released on the text box.
 | MouseWheel | Occurs when the mouse wheel is used to scroll.
 | Parent | See IAYTextBox
 | ReadOnly | Internal
 | RecreatingHandle | See IAYTextBox
 | Refresh()()()() | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
 | RemoveEventHandlers()()()() | Removes handlers
 | Resize | Occurs when the control is resized.
 | ScrollCaret | Occurs when the text box is scrolled to the caret.
 | SelectedText | This member overrides TextBox.SelectedText.
 | SelectionChanged | Occurs when the selection of text within the control has changed.
 | SelectionLength | This member overrides TextBox.SelectionLength.
 | SelectionStart | Gets or sets the starting point of text selected in the text box.
 | ShowCutCopyPasteContextMenu | Whether to show the standard Undo/Cut/Copy/Paste/Delete/Select All context menu.
 | SuspendLayout()()()() | Internal
 | tbb | Wrapped control
 | tbu | The painter.
 | Text | This member overrides TextBox.Text.
 | TextChanged | Occurs when the Text property value changes.
 | TextLength | Gets the current text length in the text box.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | UnderlineYOffset | Controls the position of the underline relative to the baseline.
 | VScrolled | Event fired when vertical scroll changed (by anything).
 | VScrollEnd | Event fired when vertical scroll ends.
 | Width | Gets or sets the width of the control.
Inheritance Hierarchy
Object
 | TextBoxBaseIAYTAdapter
 |  | RichTextBoxIAYTAdapter


TextBoxBaseIAYTAdapter Constructor (tbb, createCutCopyPasteReplacement)

Keyoti RapidSpell Desktop .NET API Docs
TextBoxBaseIAYTAdapter Constructor (tbb, createCutCopyPasteReplacement)
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► TextBoxBaseIAYTAdapter(TextBoxBase, Boolean)
Keyoti RapidSpell Desktop .NET
New instance
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected TextBoxBaseIAYTAdapter(
    TextBoxBase tbb,
    bool createCutCopyPasteReplacement
)
protected TextBoxBaseIAYTAdapter(
    TextBoxBase tbb,
    bool createCutCopyPasteReplacement
)
Protected Sub New (
    tbb As TextBoxBase,
    createCutCopyPasteReplacement As Boolean
)
Protected Sub New (
    tbb As TextBoxBase,
    createCutCopyPasteReplacement As Boolean
)
protected:
TextBoxBaseIAYTAdapter(
    TextBoxBase^ tbb,
    bool createCutCopyPasteReplacement
)
protected:
TextBoxBaseIAYTAdapter(
    TextBoxBase^ tbb,
    bool createCutCopyPasteReplacement
)
new :
        tbb : TextBoxBase *
        createCutCopyPasteReplacement : bool -> TextBoxBaseIAYTAdapter
new :
        tbb : TextBoxBase *
        createCutCopyPasteReplacement : bool -> TextBoxBaseIAYTAdapter
Parameters
tbb (TextBoxBase)
createCutCopyPasteReplacement (Boolean)


AddHandlers Method

Keyoti RapidSpell Desktop .NET API Docs
AddHandlers Method
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► AddHandlers()()()()
Keyoti RapidSpell Desktop .NET
Adds handlers
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void AddHandlers()
protected virtual void AddHandlers()
Protected Overridable Sub AddHandlers
Protected Overridable Sub AddHandlers
protected:
virtual void AddHandlers()
protected:
virtual void AddHandlers()
abstract AddHandlers : unit -> unit
override AddHandlers : unit -> unit
abstract AddHandlers : unit -> unit
override AddHandlers : unit -> unit


BeginInvoke Method

Keyoti RapidSpell Desktop .NET API Docs
BeginInvoke Method
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► BeginInvoke()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | BeginInvoke(Delegate) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
 | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.


BeginInvoke Method (d)

Keyoti RapidSpell Desktop .NET API Docs
BeginInvoke Method (d)
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► BeginInvoke(Delegate)
Keyoti RapidSpell Desktop .NET
Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public IAsyncResult BeginInvoke(
    Delegate d
)
public IAsyncResult BeginInvoke(
    Delegate d
)
Public Function BeginInvoke (
    d As Delegate
) As IAsyncResult
Public Function BeginInvoke (
    d As Delegate
) As IAsyncResult
public:
virtual IAsyncResult^ BeginInvoke(
    Delegate^ d
) sealed
public:
virtual IAsyncResult^ BeginInvoke(
    Delegate^ d
) sealed
abstract BeginInvoke :
        d : Delegate -> IAsyncResult
override BeginInvoke :
        d : Delegate -> IAsyncResult
abstract BeginInvoke :
        d : Delegate -> IAsyncResult
override BeginInvoke :
        d : Delegate -> IAsyncResult
Parameters
d (Delegate)
Return Value
IAsyncResult


BeginInvoke Method (d, parameters)

Keyoti RapidSpell Desktop .NET API Docs
BeginInvoke Method (d, parameters)
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► BeginInvoke(Delegate, array<Object>[]()[][])
Keyoti RapidSpell Desktop .NET
Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public IAsyncResult BeginInvoke(
    Delegate d,
    Object[] parameters
)
public IAsyncResult BeginInvoke(
    Delegate d,
    Object[] parameters
)
Public Function BeginInvoke (
    d As Delegate,
    parameters As Object()
) As IAsyncResult
Public Function BeginInvoke (
    d As Delegate,
    parameters As Object()
) As IAsyncResult
public:
virtual IAsyncResult^ BeginInvoke(
    Delegate^ d,
    array<Object^>^ parameters
) sealed
public:
virtual IAsyncResult^ BeginInvoke(
    Delegate^ d,
    array<Object^>^ parameters
) sealed
abstract BeginInvoke :
        d : Delegate *
        parameters : Object[] -> IAsyncResult
override BeginInvoke :
        d : Delegate *
        parameters : Object[] -> IAsyncResult
abstract BeginInvoke :
        d : Delegate *
        parameters : Object[] -> IAsyncResult
override BeginInvoke :
        d : Delegate *
        parameters : Object[] -> IAsyncResult
Parameters
d (Delegate)
parameters (array< Object >[]()[][])
Return Value
IAsyncResult


ClientSize Property

Keyoti RapidSpell Desktop .NET API Docs
ClientSize Property
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► ClientSize
Keyoti RapidSpell Desktop .NET
Gets or sets the height and width of the client area of the control.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Size ClientSize { get; set; }
public Size ClientSize { get; set; }
Public Property ClientSize As Size
    Get
    Set
Public Property ClientSize As Size
    Get
    Set
public:
virtual property Size ClientSize {
    Size get () sealed;
    void set (Size value) sealed;
}
public:
virtual property Size ClientSize {
    Size get () sealed;
    void set (Size value) sealed;
}
abstract ClientSize : Size with get, set
override ClientSize : Size with get, set
abstract ClientSize : Size with get, set
override ClientSize : Size with get, set
Property Value
Size


ContextMenu Property

Keyoti RapidSpell Desktop .NET API Docs
ContextMenu Property
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► ContextMenu
Keyoti RapidSpell Desktop .NET
Gets or sets the shortcut menu associated with the control
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ContextMenu ContextMenu { get; set; }
public ContextMenu ContextMenu { get; set; }
Public Property ContextMenu As ContextMenu
    Get
    Set
Public Property ContextMenu As ContextMenu
    Get
    Set
public:
virtual property ContextMenu^ ContextMenu {
    ContextMenu^ get () sealed;
    void set (ContextMenu^ value) sealed;
}
public:
virtual property ContextMenu^ ContextMenu {
    ContextMenu^ get () sealed;
    void set (ContextMenu^ value) sealed;
}
abstract ContextMenu : ContextMenu with get, set
override ContextMenu : ContextMenu with get, set
abstract ContextMenu : ContextMenu with get, set
override ContextMenu : ContextMenu with get, set
Property Value
ContextMenu


ContextMenuDefault Property

Keyoti RapidSpell Desktop .NET API Docs
ContextMenuDefault Property
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► ContextMenuDefault
Keyoti RapidSpell Desktop .NET
The context menu that will be shown when the right click is not on a misspelled word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual ContextMenu ContextMenuDefault { get; set; }
public virtual ContextMenu ContextMenuDefault { get; set; }
Public Overridable Property ContextMenuDefault As ContextMenu
    Get
    Set
Public Overridable Property ContextMenuDefault As ContextMenu
    Get
    Set
public:
virtual property ContextMenu^ ContextMenuDefault {
    ContextMenu^ get ();
    void set (ContextMenu^ value);
}
public:
virtual property ContextMenu^ ContextMenuDefault {
    ContextMenu^ get ();
    void set (ContextMenu^ value);
}
abstract ContextMenuDefault : ContextMenu with get, set
override ContextMenuDefault : ContextMenu with get, set
abstract ContextMenuDefault : ContextMenu with get, set
override ContextMenuDefault : ContextMenu with get, set
Property Value
ContextMenu


ContextMenuStrip Property

Keyoti RapidSpell Desktop .NET API Docs
ContextMenuStrip Property
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► ContextMenuStrip
Keyoti RapidSpell Desktop .NET
The context menu that will be shown when the right click is not on a misspelled word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ContextMenuStrip ContextMenuStrip { get; set; }
public ContextMenuStrip ContextMenuStrip { get; set; }
Public Property ContextMenuStrip As ContextMenuStrip
    Get
    Set
Public Property ContextMenuStrip As ContextMenuStrip
    Get
    Set
public:
virtual property ContextMenuStrip^ ContextMenuStrip {
    ContextMenuStrip^ get () sealed;
    void set (ContextMenuStrip^ value) sealed;
}
public:
virtual property ContextMenuStrip^ ContextMenuStrip {
    ContextMenuStrip^ get () sealed;
    void set (ContextMenuStrip^ value) sealed;
}
abstract ContextMenuStrip : ContextMenuStrip with get, set
override ContextMenuStrip : ContextMenuStrip with get, set
abstract ContextMenuStrip : ContextMenuStrip with get, set
override ContextMenuStrip : ContextMenuStrip with get, set
Property Value
ContextMenuStrip


ContextMenuStripDefault Property

Keyoti RapidSpell Desktop .NET API Docs
ContextMenuStripDefault Property
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► ContextMenuStripDefault
Keyoti RapidSpell Desktop .NET
The context menu that will be shown when the right click is not on a misspelled word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ContextMenuStrip ContextMenuStripDefault { get; set; }
public ContextMenuStrip ContextMenuStripDefault { get; set; }
Public Property ContextMenuStripDefault As ContextMenuStrip
    Get
    Set
Public Property ContextMenuStripDefault As ContextMenuStrip
    Get
    Set
public:
virtual property ContextMenuStrip^ ContextMenuStripDefault {
    ContextMenuStrip^ get () sealed;
    void set (ContextMenuStrip^ value) sealed;
}
public:
virtual property ContextMenuStrip^ ContextMenuStripDefault {
    ContextMenuStrip^ get () sealed;
    void set (ContextMenuStrip^ value) sealed;
}
abstract ContextMenuStripDefault : ContextMenuStrip with get, set
override ContextMenuStripDefault : ContextMenuStrip with get, set
abstract ContextMenuStripDefault : ContextMenuStrip with get, set
override ContextMenuStripDefault : ContextMenuStrip with get, set
Property Value
ContextMenuStrip
Remarks
This is the context menu originally set in the ContextMenuStrip property.


ControlBackgroundPaint Event

Keyoti RapidSpell Desktop .NET API Docs
ControlBackgroundPaint Event
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► ControlBackgroundPaint
Keyoti RapidSpell Desktop .NET
Event fired when Windows level background repaint occurs.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler ControlBackgroundPaint
public event EventHandler ControlBackgroundPaint
Public Event ControlBackgroundPaint As EventHandler
Public Event ControlBackgroundPaint As EventHandler
public:
 event EventHandler^ ControlBackgroundPaint {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
 event EventHandler^ ControlBackgroundPaint {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member ControlBackgroundPaint : IEvent<EventHandler,
    EventArgs>

member ControlBackgroundPaint : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


ControlPaint Event

Keyoti RapidSpell Desktop .NET API Docs
ControlPaint Event
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► ControlPaint
Keyoti RapidSpell Desktop .NET
Event fired when Windows level repaint occurs.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler ControlPaint
public event EventHandler ControlPaint
Public Event ControlPaint As EventHandler
Public Event ControlPaint As EventHandler
public:
virtual  event EventHandler^ ControlPaint {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ ControlPaint {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ControlPaint : IEvent<EventHandler,
    EventArgs>
override ControlPaint : IEvent<EventHandler,
    EventArgs>
abstract ControlPaint : IEvent<EventHandler,
    EventArgs>
override ControlPaint : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


Create Method (value, createCutCopyPaste)

Keyoti RapidSpell Desktop .NET API Docs
Create Method (value, createCutCopyPaste)
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► Create(TextBoxBase, Boolean)
Keyoti RapidSpell Desktop .NET
Creates a new adapter.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static IAYTTextBox Create(
    TextBoxBase value,
    bool createCutCopyPaste
)
public static IAYTTextBox Create(
    TextBoxBase value,
    bool createCutCopyPaste
)
Public Shared Function Create (
    value As TextBoxBase,
    createCutCopyPaste As Boolean
) As IAYTTextBox
Public Shared Function Create (
    value As TextBoxBase,
    createCutCopyPaste As Boolean
) As IAYTTextBox
public:
static IAYTTextBox^ Create(
    TextBoxBase^ value,
    bool createCutCopyPaste
)
public:
static IAYTTextBox^ Create(
    TextBoxBase^ value,
    bool createCutCopyPaste
)
static member Create :
        value : TextBoxBase *
        createCutCopyPaste : bool -> IAYTTextBox

static member Create :
        value : TextBoxBase *
        createCutCopyPaste : bool -> IAYTTextBox
Parameters
value (TextBoxBase)
createCutCopyPaste (Boolean)
Return Value
IAYTTextBox


DefaultContextMenu Property

Keyoti RapidSpell Desktop .NET API Docs
DefaultContextMenu Property
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► DefaultContextMenu
Keyoti RapidSpell Desktop .NET
The context menu that will be shown when the right click is not on a misspelled word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual ContextMenu DefaultContextMenu { get; set; }
public virtual ContextMenu DefaultContextMenu { get; set; }
Public Overridable Property DefaultContextMenu As ContextMenu
    Get
    Set
Public Overridable Property DefaultContextMenu As ContextMenu
    Get
    Set
public:
virtual property ContextMenu^ DefaultContextMenu {
    ContextMenu^ get ();
    void set (ContextMenu^ value);
}
public:
virtual property ContextMenu^ DefaultContextMenu {
    ContextMenu^ get ();
    void set (ContextMenu^ value);
}
abstract DefaultContextMenu : ContextMenu with get, set
override DefaultContextMenu : ContextMenu with get, set
abstract DefaultContextMenu : ContextMenu with get, set
override DefaultContextMenu : ContextMenu with get, set
Property Value
ContextMenu


Disposed Event

Keyoti RapidSpell Desktop .NET API Docs
Disposed Event
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► Disposed
Keyoti RapidSpell Desktop .NET
Event fires when component is Disposed.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler Disposed
public event EventHandler Disposed
Public Event Disposed As EventHandler
Public Event Disposed As EventHandler
public:
virtual  event EventHandler^ Disposed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ Disposed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Disposed : IEvent<EventHandler,
    EventArgs>
override Disposed : IEvent<EventHandler,
    EventArgs>
abstract Disposed : IEvent<EventHandler,
    EventArgs>
override Disposed : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


Disposing Property

Keyoti RapidSpell Desktop .NET API Docs
Disposing Property
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► Disposing
Keyoti RapidSpell Desktop .NET
See IAYTextBox
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool Disposing { get; }
public bool Disposing { get; }
Public ReadOnly Property Disposing As Boolean
    Get
Public ReadOnly Property Disposing As Boolean
    Get
public:
virtual property bool Disposing {
    bool get () sealed;
}
public:
virtual property bool Disposing {
    bool get () sealed;
}
abstract Disposing : bool with get
override Disposing : bool with get
abstract Disposing : bool with get
override Disposing : bool with get
Property Value
Boolean


Enabled Property

Keyoti RapidSpell Desktop .NET API Docs
Enabled Property
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► Enabled
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool Enabled { get; }
public bool Enabled { get; }
Public ReadOnly Property Enabled As Boolean
    Get
Public ReadOnly Property Enabled As Boolean
    Get
public:
virtual property bool Enabled {
    bool get () sealed;
}
public:
virtual property bool Enabled {
    bool get () sealed;
}
abstract Enabled : bool with get
override Enabled : bool with get
abstract Enabled : bool with get
override Enabled : bool with get
Property Value
Boolean


Enter Event

Keyoti RapidSpell Desktop .NET API Docs
Enter Event
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► Enter
Keyoti RapidSpell Desktop .NET
Occurs when the control receives focus.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler Enter
public event EventHandler Enter
Public Event Enter As EventHandler
Public Event Enter As EventHandler
public:
virtual  event EventHandler^ Enter {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ Enter {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Enter : IEvent<EventHandler,
    EventArgs>
override Enter : IEvent<EventHandler,
    EventArgs>
abstract Enter : IEvent<EventHandler,
    EventArgs>
override Enter : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


FindForm Method

Keyoti RapidSpell Desktop .NET API Docs
FindForm Method
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► FindForm()()()()
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Form FindForm()
public Form FindForm()
Public Function FindForm As Form
Public Function FindForm As Form
public:
Form^ FindForm()
public:
Form^ FindForm()
member FindForm : unit -> Form

member FindForm : unit -> Form
Return Value
Form


Font Property

Keyoti RapidSpell Desktop .NET API Docs
Font Property
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► Font
Keyoti RapidSpell Desktop .NET
Gets or sets the font of the text displayed by the control.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Font Font { get; set; }
public Font Font { get; set; }
Public Property Font As Font
    Get
    Set
Public Property Font As Font
    Get
    Set
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
member Font : Font with get, set

member Font : Font with get, set
Property Value
Font


FontChanged Event

Keyoti RapidSpell Desktop .NET API Docs
FontChanged Event
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► FontChanged
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler FontChanged
public event EventHandler FontChanged
Public Event FontChanged As EventHandler
Public Event FontChanged As EventHandler
public:
 event EventHandler^ FontChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
 event EventHandler^ FontChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member FontChanged : IEvent<EventHandler,
    EventArgs>

member FontChanged : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


FormatChanged Event

Keyoti RapidSpell Desktop .NET API Docs
FormatChanged Event
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► FormatChanged
Keyoti RapidSpell Desktop .NET
Event fired when formatting changes (such as font change).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler FormatChanged
public event EventHandler FormatChanged
Public Event FormatChanged As EventHandler
Public Event FormatChanged As EventHandler
public:
virtual  event EventHandler^ FormatChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ FormatChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract FormatChanged : IEvent<EventHandler,
    EventArgs>
override FormatChanged : IEvent<EventHandler,
    EventArgs>
abstract FormatChanged : IEvent<EventHandler,
    EventArgs>
override FormatChanged : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


GetBaselineOffsetAtCharIndex Method (i)

Keyoti RapidSpell Desktop .NET API Docs
GetBaselineOffsetAtCharIndex Method (i)
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► GetBaselineOffsetAtCharIndex(Int32)
Keyoti RapidSpell Desktop .NET
Gets the baseline offset for a character at index i
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual int GetBaselineOffsetAtCharIndex(
    int i
)
public virtual int GetBaselineOffsetAtCharIndex(
    int i
)
Public Overridable Function GetBaselineOffsetAtCharIndex (
    i As Integer
) As Integer
Public Overridable Function GetBaselineOffsetAtCharIndex (
    i As Integer
) As Integer
public:
virtual int GetBaselineOffsetAtCharIndex(
    int i
)
public:
virtual int GetBaselineOffsetAtCharIndex(
    int i
)
abstract GetBaselineOffsetAtCharIndex :
        i : int -> int
override GetBaselineOffsetAtCharIndex :
        i : int -> int
abstract GetBaselineOffsetAtCharIndex :
        i : int -> int
override GetBaselineOffsetAtCharIndex :
        i : int -> int
Parameters
i (Int32)
Return Value
Int32


GetCharIndexFromPos Method (pos)

Keyoti RapidSpell Desktop .NET API Docs
GetCharIndexFromPos Method (pos)
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► GetCharIndexFromPos(Point)
Keyoti RapidSpell Desktop .NET
gets the char index from a position point.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int GetCharIndexFromPos(
    Point pos
)
public int GetCharIndexFromPos(
    Point pos
)
Public Function GetCharIndexFromPos (
    pos As Point
) As Integer
Public Function GetCharIndexFromPos (
    pos As Point
) As Integer
public:
virtual int GetCharIndexFromPos(
    Point pos
) sealed
public:
virtual int GetCharIndexFromPos(
    Point pos
) sealed
abstract GetCharIndexFromPos :
        pos : Point -> int
override GetCharIndexFromPos :
        pos : Point -> int
abstract GetCharIndexFromPos :
        pos : Point -> int
override GetCharIndexFromPos :
        pos : Point -> int
Parameters
pos (Point)
Return Value
Int32


GetFirstVisibleCharIndex Method

Keyoti RapidSpell Desktop .NET API Docs
GetFirstVisibleCharIndex Method
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► GetFirstVisibleCharIndex()()()()
Keyoti RapidSpell Desktop .NET
Gets the character index of the first visible character in the window, this is for optimization and can just return 0 if unavailable.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int GetFirstVisibleCharIndex()
public int GetFirstVisibleCharIndex()
Public Function GetFirstVisibleCharIndex As Integer
Public Function GetFirstVisibleCharIndex As Integer
public:
virtual int GetFirstVisibleCharIndex() sealed
public:
virtual int GetFirstVisibleCharIndex() sealed
abstract GetFirstVisibleCharIndex : unit -> int
override GetFirstVisibleCharIndex : unit -> int
abstract GetFirstVisibleCharIndex : unit -> int
override GetFirstVisibleCharIndex : unit -> int
Return Value
Int32


GetLineFromCharIndex Method (ind)

Keyoti RapidSpell Desktop .NET API Docs
GetLineFromCharIndex Method (ind)
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► GetLineFromCharIndex(Int32)
Keyoti RapidSpell Desktop .NET
Gets the line number that char index is on
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int GetLineFromCharIndex(
    int ind
)
public int GetLineFromCharIndex(
    int ind
)
Public Function GetLineFromCharIndex (
    ind As Integer
) As Integer
Public Function GetLineFromCharIndex (
    ind As Integer
) As Integer
public:
virtual int GetLineFromCharIndex(
    int ind
) sealed
public:
virtual int GetLineFromCharIndex(
    int ind
) sealed
abstract GetLineFromCharIndex :
        ind : int -> int
override GetLineFromCharIndex :
        ind : int -> int
abstract GetLineFromCharIndex :
        ind : int -> int
override GetLineFromCharIndex :
        ind : int -> int
Parameters
ind (Int32)
Return Value
Int32


GetPosFromCharIndex Method (ind)

Keyoti RapidSpell Desktop .NET API Docs
GetPosFromCharIndex Method (ind)
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► GetPosFromCharIndex(Int32)
Keyoti RapidSpell Desktop .NET
Gets the position point from the char index
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Point GetPosFromCharIndex(
    int ind
)
public Point GetPosFromCharIndex(
    int ind
)
Public Function GetPosFromCharIndex (
    ind As Integer
) As Point
Public Function GetPosFromCharIndex (
    ind As Integer
) As Point
public:
virtual Point GetPosFromCharIndex(
    int ind
) sealed
public:
virtual Point GetPosFromCharIndex(
    int ind
) sealed
abstract GetPosFromCharIndex :
        ind : int -> Point
override GetPosFromCharIndex :
        ind : int -> Point
abstract GetPosFromCharIndex :
        ind : int -> Point
override GetPosFromCharIndex :
        ind : int -> Point
Parameters
ind (Int32)
Return Value
Point


GetTBU Method

Keyoti RapidSpell Desktop .NET API Docs
GetTBU Method
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► GetTBU()()()()
Keyoti RapidSpell Desktop .NET
Interface requirement
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public TextBoxUtilityAdapter GetTBU()
public TextBoxUtilityAdapter GetTBU()
Public Function GetTBU As TextBoxUtilityAdapter
Public Function GetTBU As TextBoxUtilityAdapter
public:
virtual TextBoxUtilityAdapter^ GetTBU() sealed
public:
virtual TextBoxUtilityAdapter^ GetTBU() sealed
abstract GetTBU : unit -> TextBoxUtilityAdapter
override GetTBU : unit -> TextBoxUtilityAdapter
abstract GetTBU : unit -> TextBoxUtilityAdapter
override GetTBU : unit -> TextBoxUtilityAdapter
Return Value
TextBoxUtilityAdapter


Handle Property

Keyoti RapidSpell Desktop .NET API Docs
Handle Property
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► Handle
Keyoti RapidSpell Desktop .NET
Gets the window handle that the control is bound to.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public IntPtr Handle { get; }
public IntPtr Handle { get; }
Public ReadOnly Property Handle As IntPtr
    Get
Public ReadOnly Property Handle As IntPtr
    Get
public:
virtual property IntPtr Handle {
    IntPtr get () sealed;
}
public:
virtual property IntPtr Handle {
    IntPtr get () sealed;
}
abstract Handle : IntPtr with get
override Handle : IntPtr with get
abstract Handle : IntPtr with get
override Handle : IntPtr with get
Property Value
IntPtr


Height Property

Keyoti RapidSpell Desktop .NET API Docs
Height Property
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► Height
Keyoti RapidSpell Desktop .NET
Gets or sets the height of the control.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int Height { get; set; }
public int Height { get; set; }
Public Property Height As Integer
    Get
    Set
Public Property Height As Integer
    Get
    Set
public:
virtual property int Height {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int Height {
    int get () sealed;
    void set (int value) sealed;
}
abstract Height : int with get, set
override Height : int with get, set
abstract Height : int with get, set
override Height : int with get, set
Property Value
Int32


HScrolled Event

Keyoti RapidSpell Desktop .NET API Docs
HScrolled Event
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► HScrolled
Keyoti RapidSpell Desktop .NET
Event fired when horizontal scroll changed (by anything).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler HScrolled
public event EventHandler HScrolled
Public Event HScrolled As EventHandler
Public Event HScrolled As EventHandler
public:
virtual  event EventHandler^ HScrolled {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ HScrolled {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract HScrolled : IEvent<EventHandler,
    EventArgs>
override HScrolled : IEvent<EventHandler,
    EventArgs>
abstract HScrolled : IEvent<EventHandler,
    EventArgs>
override HScrolled : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


IsDisposed Property

Keyoti RapidSpell Desktop .NET API Docs
IsDisposed Property
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► IsDisposed
Keyoti RapidSpell Desktop .NET
Gets a value indicating whether the control has been disposed of.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IsDisposed { get; }
public bool IsDisposed { get; }
Public ReadOnly Property IsDisposed As Boolean
    Get
Public ReadOnly Property IsDisposed As Boolean
    Get
public:
virtual property bool IsDisposed {
    bool get () sealed;
}
public:
virtual property bool IsDisposed {
    bool get () sealed;
}
abstract IsDisposed : bool with get
override IsDisposed : bool with get
abstract IsDisposed : bool with get
override IsDisposed : bool with get
Property Value
Boolean


IsHandleCreated Property

Keyoti RapidSpell Desktop .NET API Docs
IsHandleCreated Property
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► IsHandleCreated
Keyoti RapidSpell Desktop .NET
Same as Control.IsHandleCreated
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IsHandleCreated { get; }
public bool IsHandleCreated { get; }
Public ReadOnly Property IsHandleCreated As Boolean
    Get
Public ReadOnly Property IsHandleCreated As Boolean
    Get
public:
virtual property bool IsHandleCreated {
    bool get () sealed;
}
public:
virtual property bool IsHandleCreated {
    bool get () sealed;
}
abstract IsHandleCreated : bool with get
override IsHandleCreated : bool with get
abstract IsHandleCreated : bool with get
override IsHandleCreated : bool with get
Property Value
Boolean


KeyDown Event

Keyoti RapidSpell Desktop .NET API Docs
KeyDown Event
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► KeyDown
Keyoti RapidSpell Desktop .NET
Occurs when a key is pressed while the control has focus.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event KeyEventHandler KeyDown
public event KeyEventHandler KeyDown
Public Event KeyDown As KeyEventHandler
Public Event KeyDown As KeyEventHandler
public:
virtual  event KeyEventHandler^ KeyDown {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}
public:
virtual  event KeyEventHandler^ KeyDown {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}
abstract KeyDown : IEvent<KeyEventHandler,
    KeyEventArgs>
override KeyDown : IEvent<KeyEventHandler,
    KeyEventArgs>
abstract KeyDown : IEvent<KeyEventHandler,
    KeyEventArgs>
override KeyDown : IEvent<KeyEventHandler,
    KeyEventArgs>
Value
KeyEventHandler


KeyPress Event

Keyoti RapidSpell Desktop .NET API Docs
KeyPress Event
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► KeyPress
Keyoti RapidSpell Desktop .NET
Occurs when a key is pressed while the control has focus.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event KeyPressEventHandler KeyPress
public event KeyPressEventHandler KeyPress
Public Event KeyPress As KeyPressEventHandler
Public Event KeyPress As KeyPressEventHandler
public:
virtual  event KeyPressEventHandler^ KeyPress {
    void add (KeyPressEventHandler^ value);
    void remove (KeyPressEventHandler^ value);
}
public:
virtual  event KeyPressEventHandler^ KeyPress {
    void add (KeyPressEventHandler^ value);
    void remove (KeyPressEventHandler^ value);
}
abstract KeyPress : IEvent<KeyPressEventHandler,
    KeyPressEventArgs>
override KeyPress : IEvent<KeyPressEventHandler,
    KeyPressEventArgs>
abstract KeyPress : IEvent<KeyPressEventHandler,
    KeyPressEventArgs>
override KeyPress : IEvent<KeyPressEventHandler,
    KeyPressEventArgs>
Value
KeyPressEventHandler
Remarks
Used by the auto-corrector


KeyUp Event

Keyoti RapidSpell Desktop .NET API Docs
KeyUp Event
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► KeyUp
Keyoti RapidSpell Desktop .NET
Occurs when a key is released while the control has focus.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event KeyEventHandler KeyUp
public event KeyEventHandler KeyUp
Public Event KeyUp As KeyEventHandler
Public Event KeyUp As KeyEventHandler
public:
virtual  event KeyEventHandler^ KeyUp {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}
public:
virtual  event KeyEventHandler^ KeyUp {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}
abstract KeyUp : IEvent<KeyEventHandler,
    KeyEventArgs>
override KeyUp : IEvent<KeyEventHandler,
    KeyEventArgs>
abstract KeyUp : IEvent<KeyEventHandler,
    KeyEventArgs>
override KeyUp : IEvent<KeyEventHandler,
    KeyEventArgs>
Value
KeyEventHandler


Leave Event

Keyoti RapidSpell Desktop .NET API Docs
Leave Event
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► Leave
Keyoti RapidSpell Desktop .NET
Occurs when the control loses focus.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler Leave
public event EventHandler Leave
Public Event Leave As EventHandler
Public Event Leave As EventHandler
public:
virtual  event EventHandler^ Leave {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ Leave {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Leave : IEvent<EventHandler,
    EventArgs>
override Leave : IEvent<EventHandler,
    EventArgs>
abstract Leave : IEvent<EventHandler,
    EventArgs>
override Leave : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


MouseDown Event

Keyoti RapidSpell Desktop .NET API Docs
MouseDown Event
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► MouseDown
Keyoti RapidSpell Desktop .NET
Occurs when the mouse pointer is over the control and a mouse button is pressed.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event MouseEventHandler MouseDown
public event MouseEventHandler MouseDown
Public Event MouseDown As MouseEventHandler
Public Event MouseDown As MouseEventHandler
public:
virtual  event MouseEventHandler^ MouseDown {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}
public:
virtual  event MouseEventHandler^ MouseDown {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}
abstract MouseDown : IEvent<MouseEventHandler,
    MouseEventArgs>
override MouseDown : IEvent<MouseEventHandler,
    MouseEventArgs>
abstract MouseDown : IEvent<MouseEventHandler,
    MouseEventArgs>
override MouseDown : IEvent<MouseEventHandler,
    MouseEventArgs>
Value
MouseEventHandler


MouseUp Event

Keyoti RapidSpell Desktop .NET API Docs
MouseUp Event
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► MouseUp
Keyoti RapidSpell Desktop .NET
Occurs when the mouse is released on the text box.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event MouseEventHandler MouseUp
public event MouseEventHandler MouseUp
Public Event MouseUp As MouseEventHandler
Public Event MouseUp As MouseEventHandler
public:
virtual  event MouseEventHandler^ MouseUp {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}
public:
virtual  event MouseEventHandler^ MouseUp {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}
abstract MouseUp : IEvent<MouseEventHandler,
    MouseEventArgs>
override MouseUp : IEvent<MouseEventHandler,
    MouseEventArgs>
abstract MouseUp : IEvent<MouseEventHandler,
    MouseEventArgs>
override MouseUp : IEvent<MouseEventHandler,
    MouseEventArgs>
Value
MouseEventHandler


MouseWheel Event

Keyoti RapidSpell Desktop .NET API Docs
MouseWheel Event
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► MouseWheel
Keyoti RapidSpell Desktop .NET
Occurs when the mouse wheel is used to scroll.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event MouseEventHandler MouseWheel
public event MouseEventHandler MouseWheel
Public Event MouseWheel As MouseEventHandler
Public Event MouseWheel As MouseEventHandler
public:
virtual  event MouseEventHandler^ MouseWheel {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}
public:
virtual  event MouseEventHandler^ MouseWheel {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}
abstract MouseWheel : IEvent<MouseEventHandler,
    MouseEventArgs>
override MouseWheel : IEvent<MouseEventHandler,
    MouseEventArgs>
abstract MouseWheel : IEvent<MouseEventHandler,
    MouseEventArgs>
override MouseWheel : IEvent<MouseEventHandler,
    MouseEventArgs>
Value
MouseEventHandler


Parent Property

Keyoti RapidSpell Desktop .NET API Docs
Parent Property
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► Parent
Keyoti RapidSpell Desktop .NET
See IAYTextBox
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Control Parent { get; }
public Control Parent { get; }
Public ReadOnly Property Parent As Control
    Get
Public ReadOnly Property Parent As Control
    Get
public:
virtual property Control^ Parent {
    Control^ get () sealed;
}
public:
virtual property Control^ Parent {
    Control^ get () sealed;
}
abstract Parent : Control with get
override Parent : Control with get
abstract Parent : Control with get
override Parent : Control with get
Property Value
Control


ReadOnly Property

Keyoti RapidSpell Desktop .NET API Docs
ReadOnly Property
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► ReadOnly
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ReadOnly { get; }
public bool ReadOnly { get; }
Public ReadOnly Property ReadOnly As Boolean
    Get
Public ReadOnly Property ReadOnly As Boolean
    Get
public:
virtual property bool ReadOnly {
    bool get () sealed;
}
public:
virtual property bool ReadOnly {
    bool get () sealed;
}
abstract ReadOnly : bool with get
override ReadOnly : bool with get
abstract ReadOnly : bool with get
override ReadOnly : bool with get
Property Value
Boolean


RecreatingHandle Property

Keyoti RapidSpell Desktop .NET API Docs
RecreatingHandle Property
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► RecreatingHandle
Keyoti RapidSpell Desktop .NET
See IAYTextBox
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool RecreatingHandle { get; }
public bool RecreatingHandle { get; }
Public ReadOnly Property RecreatingHandle As Boolean
    Get
Public ReadOnly Property RecreatingHandle As Boolean
    Get
public:
virtual property bool RecreatingHandle {
    bool get () sealed;
}
public:
virtual property bool RecreatingHandle {
    bool get () sealed;
}
abstract RecreatingHandle : bool with get
override RecreatingHandle : bool with get
abstract RecreatingHandle : bool with get
override RecreatingHandle : bool with get
Property Value
Boolean


Refresh Method

Keyoti RapidSpell Desktop .NET API Docs
Refresh Method
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► Refresh()()()()
Keyoti RapidSpell Desktop .NET
Forces the control to invalidate its client area and immediately redraw itself and any child controls.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void Refresh()
public void Refresh()
Public Sub Refresh
Public Sub Refresh
public:
virtual void Refresh() sealed
public:
virtual void Refresh() sealed
abstract Refresh : unit -> unit
override Refresh : unit -> unit
abstract Refresh : unit -> unit
override Refresh : unit -> unit


RemoveEventHandlers Method

Keyoti RapidSpell Desktop .NET API Docs
RemoveEventHandlers Method
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► RemoveEventHandlers()()()()
Keyoti RapidSpell Desktop .NET
Removes handlers
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void RemoveEventHandlers()
protected virtual void RemoveEventHandlers()
Protected Overridable Sub RemoveEventHandlers
Protected Overridable Sub RemoveEventHandlers
protected:
virtual void RemoveEventHandlers()
protected:
virtual void RemoveEventHandlers()
abstract RemoveEventHandlers : unit -> unit
override RemoveEventHandlers : unit -> unit
abstract RemoveEventHandlers : unit -> unit
override RemoveEventHandlers : unit -> unit


Resize Event

Keyoti RapidSpell Desktop .NET API Docs
Resize Event
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► Resize
Keyoti RapidSpell Desktop .NET
Occurs when the control is resized.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler Resize
public event EventHandler Resize
Public Event Resize As EventHandler
Public Event Resize As EventHandler
public:
virtual  event EventHandler^ Resize {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ Resize {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Resize : IEvent<EventHandler,
    EventArgs>
override Resize : IEvent<EventHandler,
    EventArgs>
abstract Resize : IEvent<EventHandler,
    EventArgs>
override Resize : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


ScrollCaret Event

Keyoti RapidSpell Desktop .NET API Docs
ScrollCaret Event
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► ScrollCaret
Keyoti RapidSpell Desktop .NET
Occurs when the text box is scrolled to the caret.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler ScrollCaret
public event EventHandler ScrollCaret
Public Event ScrollCaret As EventHandler
Public Event ScrollCaret As EventHandler
public:
virtual  event EventHandler^ ScrollCaret {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ ScrollCaret {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ScrollCaret : IEvent<EventHandler,
    EventArgs>
override ScrollCaret : IEvent<EventHandler,
    EventArgs>
abstract ScrollCaret : IEvent<EventHandler,
    EventArgs>
override ScrollCaret : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


SelectedText Property

Keyoti RapidSpell Desktop .NET API Docs
SelectedText Property
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► SelectedText
Keyoti RapidSpell Desktop .NET
This member overrides TextBox.SelectedText.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string SelectedText { get; set; }
public string SelectedText { get; set; }
Public Property SelectedText As String
    Get
    Set
Public Property SelectedText As String
    Get
    Set
public:
virtual property String^ SelectedText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ SelectedText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract SelectedText : string with get, set
override SelectedText : string with get, set
abstract SelectedText : string with get, set
override SelectedText : string with get, set
Property Value
String


SelectionChanged Event

Keyoti RapidSpell Desktop .NET API Docs
SelectionChanged Event
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► SelectionChanged
Keyoti RapidSpell Desktop .NET
Occurs when the selection of text within the control has changed.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler SelectionChanged
public event EventHandler SelectionChanged
Public Event SelectionChanged As EventHandler
Public Event SelectionChanged As EventHandler
public:
 event EventHandler^ SelectionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
 event EventHandler^ SelectionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member SelectionChanged : IEvent<EventHandler,
    EventArgs>

member SelectionChanged : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


SelectionLength Property

Keyoti RapidSpell Desktop .NET API Docs
SelectionLength Property
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► SelectionLength
Keyoti RapidSpell Desktop .NET
This member overrides TextBox.SelectionLength.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int SelectionLength { get; set; }
public int SelectionLength { get; set; }
Public Property SelectionLength As Integer
    Get
    Set
Public Property SelectionLength As Integer
    Get
    Set
public:
virtual property int SelectionLength {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int SelectionLength {
    int get () sealed;
    void set (int value) sealed;
}
abstract SelectionLength : int with get, set
override SelectionLength : int with get, set
abstract SelectionLength : int with get, set
override SelectionLength : int with get, set
Property Value
Int32


SelectionStart Property

Keyoti RapidSpell Desktop .NET API Docs
SelectionStart Property
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► SelectionStart
Keyoti RapidSpell Desktop .NET
Gets or sets the starting point of text selected in the text box.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int SelectionStart { get; set; }
public int SelectionStart { get; set; }
Public Property SelectionStart As Integer
    Get
    Set
Public Property SelectionStart As Integer
    Get
    Set
public:
virtual property int SelectionStart {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int SelectionStart {
    int get () sealed;
    void set (int value) sealed;
}
abstract SelectionStart : int with get, set
override SelectionStart : int with get, set
abstract SelectionStart : int with get, set
override SelectionStart : int with get, set
Property Value
Int32
Remarks
If no text is selected in the control, this property indicates the insertion point for new text. If you set this property to a location beyond the length of the text in the control, the selection start position will be placed after the last character. When text is selected in the text box control, changing this property might decrease the value of the SelectionLength property. If the remaining text in the control after the position indicated by the SelectionStart property is less than the value of the SelectionLength property, the value of the SelectionLength property is automatically decreased. The value of the SelectionStart property never causes an increase in the SelectionLength property. Note You can programmatically move the caret within the text box by setting the SelectionStart to the position within the text box where you want the caret to move to and set the SelectionLength property to a value of zero (0). The text box must have focus in order for the caret to be moved.


ShowCutCopyPasteContextMenu Property

Keyoti RapidSpell Desktop .NET API Docs
ShowCutCopyPasteContextMenu Property
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► ShowCutCopyPasteContextMenu
Keyoti RapidSpell Desktop .NET
Whether to show the standard Undo/Cut/Copy/Paste/Delete/Select All context menu.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ShowCutCopyPasteContextMenu { get; set; }
public bool ShowCutCopyPasteContextMenu { get; set; }
Public Property ShowCutCopyPasteContextMenu As Boolean
    Get
    Set
Public Property ShowCutCopyPasteContextMenu As Boolean
    Get
    Set
public:
property bool ShowCutCopyPasteContextMenu {
    bool get ();
    void set (bool value);
}
public:
property bool ShowCutCopyPasteContextMenu {
    bool get ();
    void set (bool value);
}
member ShowCutCopyPasteContextMenu : bool with get, set

member ShowCutCopyPasteContextMenu : bool with get, set
Property Value
Boolean


SuspendLayout Method

Keyoti RapidSpell Desktop .NET API Docs
SuspendLayout Method
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► SuspendLayout()()()()
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void SuspendLayout()
public void SuspendLayout()
Public Sub SuspendLayout
Public Sub SuspendLayout
public:
virtual void SuspendLayout() sealed
public:
virtual void SuspendLayout() sealed
abstract SuspendLayout : unit -> unit
override SuspendLayout : unit -> unit
abstract SuspendLayout : unit -> unit
override SuspendLayout : unit -> unit


tbb Field

Keyoti RapidSpell Desktop .NET API Docs
tbb Field
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► tbb
Keyoti RapidSpell Desktop .NET
Wrapped control
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected internal TextBoxBase tbb
protected internal TextBoxBase tbb
Protected Friend tbb As TextBoxBase
Protected Friend tbb As TextBoxBase
protected public:
TextBoxBase^ tbb
protected public:
TextBoxBase^ tbb
val mutable tbb: TextBoxBase
val mutable tbb: TextBoxBase
Field Value
TextBoxBase


tbu Field

Keyoti RapidSpell Desktop .NET API Docs
tbu Field
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► tbu
Keyoti RapidSpell Desktop .NET
The painter.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected TextBoxUtilityAdapter tbu
protected TextBoxUtilityAdapter tbu
Protected tbu As TextBoxUtilityAdapter
Protected tbu As TextBoxUtilityAdapter
protected:
TextBoxUtilityAdapter^ tbu
protected:
TextBoxUtilityAdapter^ tbu
val mutable tbu: TextBoxUtilityAdapter
val mutable tbu: TextBoxUtilityAdapter
Field Value
TextBoxUtilityAdapter


Text Property

Keyoti RapidSpell Desktop .NET API Docs
Text Property
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► Text
Keyoti RapidSpell Desktop .NET
This member overrides TextBox.Text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string Text { get; set; }
public string Text { get; set; }
Public Property Text As String
    Get
    Set
Public Property Text As String
    Get
    Set
public:
virtual property String^ Text {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ Text {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract Text : string with get, set
override Text : string with get, set
abstract Text : string with get, set
override Text : string with get, set
Property Value
String


TextChanged Event

Keyoti RapidSpell Desktop .NET API Docs
TextChanged Event
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► TextChanged
Keyoti RapidSpell Desktop .NET
Occurs when the Text property value changes.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler TextChanged
public event EventHandler TextChanged
Public Event TextChanged As EventHandler
Public Event TextChanged As EventHandler
public:
virtual  event EventHandler^ TextChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ TextChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract TextChanged : IEvent<EventHandler,
    EventArgs>
override TextChanged : IEvent<EventHandler,
    EventArgs>
abstract TextChanged : IEvent<EventHandler,
    EventArgs>
override TextChanged : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


TextLength Property

Keyoti RapidSpell Desktop .NET API Docs
TextLength Property
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► TextLength
Keyoti RapidSpell Desktop .NET
Gets the current text length in the text box.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int TextLength { get; }
public int TextLength { get; }
Public ReadOnly Property TextLength As Integer
    Get
Public ReadOnly Property TextLength As Integer
    Get
public:
virtual property int TextLength {
    int get () sealed;
}
public:
virtual property int TextLength {
    int get () sealed;
}
abstract TextLength : int with get
override TextLength : int with get
abstract TextLength : int with get
override TextLength : int with get
Property Value
Int32


UnderlineYOffset Property

Keyoti RapidSpell Desktop .NET API Docs
UnderlineYOffset Property
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► UnderlineYOffset
Keyoti RapidSpell Desktop .NET
Controls the position of the underline relative to the baseline.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int UnderlineYOffset { get; set; }
public int UnderlineYOffset { get; set; }
Public Property UnderlineYOffset As Integer
    Get
    Set
Public Property UnderlineYOffset As Integer
    Get
    Set
public:
property int UnderlineYOffset {
    int get ();
    void set (int value);
}
public:
property int UnderlineYOffset {
    int get ();
    void set (int value);
}
member UnderlineYOffset : int with get, set

member UnderlineYOffset : int with get, set
Property Value
Int32


VScrolled Event

Keyoti RapidSpell Desktop .NET API Docs
VScrolled Event
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► VScrolled
Keyoti RapidSpell Desktop .NET
Event fired when vertical scroll changed (by anything).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler VScrolled
public event EventHandler VScrolled
Public Event VScrolled As EventHandler
Public Event VScrolled As EventHandler
public:
virtual  event EventHandler^ VScrolled {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ VScrolled {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract VScrolled : IEvent<EventHandler,
    EventArgs>
override VScrolled : IEvent<EventHandler,
    EventArgs>
abstract VScrolled : IEvent<EventHandler,
    EventArgs>
override VScrolled : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


VScrollEnd Event

Keyoti RapidSpell Desktop .NET API Docs
VScrollEnd Event
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► VScrollEnd
Keyoti RapidSpell Desktop .NET
Event fired when vertical scroll ends.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler VScrollEnd
public event EventHandler VScrollEnd
Public Event VScrollEnd As EventHandler
Public Event VScrollEnd As EventHandler
public:
virtual  event EventHandler^ VScrollEnd {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ VScrollEnd {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract VScrollEnd : IEvent<EventHandler,
    EventArgs>
override VScrollEnd : IEvent<EventHandler,
    EventArgs>
abstract VScrollEnd : IEvent<EventHandler,
    EventArgs>
override VScrollEnd : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


Width Property

Keyoti RapidSpell Desktop .NET API Docs
Width Property
API ► Keyoti.RapidSpell ► TextBoxBaseIAYTAdapter ► Width
Keyoti RapidSpell Desktop .NET
Gets or sets the width of the control.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int Width { get; set; }
public int Width { get; set; }
Public Property Width As Integer
    Get
    Set
Public Property Width As Integer
    Get
    Set
public:
virtual property int Width {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int Width {
    int get () sealed;
    void set (int value) sealed;
}
abstract Width : int with get, set
override Width : int with get, set
abstract Width : int with get, set
override Width : int with get, set
Property Value
Int32


TextBoxUtilityAdapter Class

Keyoti RapidSpell Desktop .NET API Docs
TextBoxUtilityAdapter Class
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter
Keyoti RapidSpell Desktop .NET
Handles painting on AYTTextBox and AYTRichTextbox
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class TextBoxUtilityAdapter
public class TextBoxUtilityAdapter
Public Class TextBoxUtilityAdapter
Public Class TextBoxUtilityAdapter
public ref class TextBoxUtilityAdapter
public ref class TextBoxUtilityAdapter
type TextBoxUtilityAdapter =  class end
type TextBoxUtilityAdapter =  class end
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TextBoxUtilityAdapter()()()() | New instance
 | TextBoxUtilityAdapter(IAYTTextBox) | Construct a new utility adapter
 | TextBoxUtilityAdapter(IAYTTextBox, Boolean) | Construct a new utility adapter
 | AfterRemoveUnderline | Fired after a word is de-underlined
 | AfterUnderline | Fired after a word is underlined
 | BackgroundBMP | Used internally.
 | BeforeRemoveUnderline | Fired before a word is de-underlined
 | BeforeUnderline | Fired before a word is underlined
 | bmp | Bitmap of underlines
 | currentText | Register of text currently in the text box, updated when it changes.
 | DoUpdates(String) | Updates underlines for change in text.
 | doUpdatesMovedUnderlines | Internal
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FullPaint(Boolean) | Causes all underlines to be repainted.
 | getFirstVisibleUnderline()()()() | Calculates the first visible underline, if necessary
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | HideUnderline(Int32, Int32) | Hides an underline
 | IdentifyChange()()()() | Returns the start and end indices in the current text of the changed text.
 | IsFinished | Whether this object is no longer being used.
 | isPositionInUnderline(Int32) | Whether index is inside a visible underline
 | KeyDown | User has keyed up.
 | KeyPress | User has pressed a key.
 | KeyUp | User has keyed up.
 | Leave | Focus lost.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MenuMouseButton | The mouse button that is used to trigger the context menu.
 | MouseReleased | User has mouse released.
 | oldText | The text contained before text changed
 | OnAfterRemoveUnderline(UnderlineEventArgs) | Raises event
 | OnAfterUnderline(UnderlineEventArgs) | Raises event
 | OnBeforeRemoveUnderline(UnderlineEventArgs) | Raises event
 | OnBeforeUnderline(UnderlineEventArgs) | Raises event
 | OnKeyDown(Object, KeyEventArgs) | Called when KeyDown occurs.
 | OnKeyUp(Object, KeyEventArgs) | Called when KeyUp occurs.
 | OnLeave(Object, EventArgs) | Called when user leave the text box
 | OnMousePressed(Object, MouseEventArgs) | Mouse handler
 | OnMouseReleased(Object, MouseEventArgs) | Called when MouseReleased occurs.
 | OnTextBoxDisposed(Object, EventArgs) | Called when text box is disposed.
 | OnTextBoxInvalidated(Object, InvalidateEventArgs) | Called when text box is invalidated
 | OnTextChanged(Object, EventArgs) | Called when the text box's text is changed
 | paint()()()() | Paint onto the textbox
 | paintUnderline(Graphics, Point, Point, UnderlineStyle, Pen) | Paints an underline
 | prePaint()()()() | Prepaints the underlines onto a buffer bitmap
 | Refresh()()()() | Refreshes the display.
 | RemoveAllUnderlines()()()() | Remove all underlines.
 | RemoveUnderline(Int32, Int32, UnderlineStyle, Color) | Remove underline text, from start index to end index.
 | RepaintTimer | The number of milliseconds that must pass since the last user input before repainting. This has a resolution of 250 milliseconds.
 | RequestingContextMenu | Context menu request
 | textBox | The text box being painted.
 | textBoxCanvas | The textbox graphics context on which painting is performed
 | TextChanged | Text Changed.
 | timeSinceRepaintCall | When repaint timer is active, this is how long since the timer expired.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Underline(Int32, Int32, UnderlineStyle, Color, BadWord) | Underline text, from start index to end index.
 | underlines | The underlines being tracked.
 | underlinesArePainted | Whether underlines have been painted
 | UnhideUnderline(Int32, Int32) | Unhides an underline
Remarks
This class can be derived from for custom painting of other text boxes.
Inheritance Hierarchy
Object
TextBoxUtilityAdapter


TextBoxUtilityAdapter Constructor

Keyoti RapidSpell Desktop .NET API Docs
TextBoxUtilityAdapter Constructor
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► TextBoxUtilityAdapter()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | TextBoxUtilityAdapter()()()() | New instance
 | TextBoxUtilityAdapter(IAYTTextBox) | Construct a new utility adapter
 | TextBoxUtilityAdapter(IAYTTextBox, Boolean) | Construct a new utility adapter


TextBoxUtilityAdapter Constructor

Keyoti RapidSpell Desktop .NET API Docs
TextBoxUtilityAdapter Constructor
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► TextBoxUtilityAdapter()()()()
Keyoti RapidSpell Desktop .NET
New instance
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public TextBoxUtilityAdapter()
public TextBoxUtilityAdapter()
Public Sub New
Public Sub New
public:
TextBoxUtilityAdapter()
public:
TextBoxUtilityAdapter()
new : unit -> TextBoxUtilityAdapter
new : unit -> TextBoxUtilityAdapter


TextBoxUtilityAdapter Constructor (t)

Keyoti RapidSpell Desktop .NET API Docs
TextBoxUtilityAdapter Constructor (t)
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► TextBoxUtilityAdapter(IAYTTextBox)
Keyoti RapidSpell Desktop .NET
Construct a new utility adapter
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public TextBoxUtilityAdapter(
    IAYTTextBox t
)
public TextBoxUtilityAdapter(
    IAYTTextBox t
)
Public Sub New (
    t As IAYTTextBox
)
Public Sub New (
    t As IAYTTextBox
)
public:
TextBoxUtilityAdapter(
    IAYTTextBox^ t
)
public:
TextBoxUtilityAdapter(
    IAYTTextBox^ t
)
new :
        t : IAYTTextBox -> TextBoxUtilityAdapter
new :
        t : IAYTTextBox -> TextBoxUtilityAdapter
Parameters
t (IAYTTextBox)


TextBoxUtilityAdapter Constructor (t, needGraphics)

Keyoti RapidSpell Desktop .NET API Docs
TextBoxUtilityAdapter Constructor (t, needGraphics)
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► TextBoxUtilityAdapter(IAYTTextBox, Boolean)
Keyoti RapidSpell Desktop .NET
Construct a new utility adapter
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected TextBoxUtilityAdapter(
    IAYTTextBox t,
    bool needGraphics
)
protected TextBoxUtilityAdapter(
    IAYTTextBox t,
    bool needGraphics
)
Protected Sub New (
    t As IAYTTextBox,
    needGraphics As Boolean
)
Protected Sub New (
    t As IAYTTextBox,
    needGraphics As Boolean
)
protected:
TextBoxUtilityAdapter(
    IAYTTextBox^ t,
    bool needGraphics
)
protected:
TextBoxUtilityAdapter(
    IAYTTextBox^ t,
    bool needGraphics
)
new :
        t : IAYTTextBox *
        needGraphics : bool -> TextBoxUtilityAdapter
new :
        t : IAYTTextBox *
        needGraphics : bool -> TextBoxUtilityAdapter
Parameters
t (IAYTTextBox)
needGraphics (Boolean)


AfterRemoveUnderline Event

Keyoti RapidSpell Desktop .NET API Docs
AfterRemoveUnderline Event
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► AfterRemoveUnderline
Keyoti RapidSpell Desktop .NET
Fired after a word is de-underlined
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event UnderlineEventHandler AfterRemoveUnderline
public event UnderlineEventHandler AfterRemoveUnderline
Public Event AfterRemoveUnderline As UnderlineEventHandler
Public Event AfterRemoveUnderline As UnderlineEventHandler
public:
 event UnderlineEventHandler^ AfterRemoveUnderline {
    void add (UnderlineEventHandler^ value);
    void remove (UnderlineEventHandler^ value);
}
public:
 event UnderlineEventHandler^ AfterRemoveUnderline {
    void add (UnderlineEventHandler^ value);
    void remove (UnderlineEventHandler^ value);
}
member AfterRemoveUnderline : IEvent<UnderlineEventHandler,
    UnderlineEventArgs>

member AfterRemoveUnderline : IEvent<UnderlineEventHandler,
    UnderlineEventArgs>
Value
UnderlineEventHandler


AfterUnderline Event

Keyoti RapidSpell Desktop .NET API Docs
AfterUnderline Event
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► AfterUnderline
Keyoti RapidSpell Desktop .NET
Fired after a word is underlined
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event UnderlineEventHandler AfterUnderline
public event UnderlineEventHandler AfterUnderline
Public Event AfterUnderline As UnderlineEventHandler
Public Event AfterUnderline As UnderlineEventHandler
public:
 event UnderlineEventHandler^ AfterUnderline {
    void add (UnderlineEventHandler^ value);
    void remove (UnderlineEventHandler^ value);
}
public:
 event UnderlineEventHandler^ AfterUnderline {
    void add (UnderlineEventHandler^ value);
    void remove (UnderlineEventHandler^ value);
}
member AfterUnderline : IEvent<UnderlineEventHandler,
    UnderlineEventArgs>

member AfterUnderline : IEvent<UnderlineEventHandler,
    UnderlineEventArgs>
Value
UnderlineEventHandler


BackgroundBMP Property

Keyoti RapidSpell Desktop .NET API Docs
BackgroundBMP Property
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► BackgroundBMP
Keyoti RapidSpell Desktop .NET
Used internally.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Bitmap BackgroundBMP { get; }
public Bitmap BackgroundBMP { get; }
Public ReadOnly Property BackgroundBMP As Bitmap
    Get
Public ReadOnly Property BackgroundBMP As Bitmap
    Get
public:
property Bitmap^ BackgroundBMP {
    Bitmap^ get ();
}
public:
property Bitmap^ BackgroundBMP {
    Bitmap^ get ();
}
member BackgroundBMP : Bitmap with get

member BackgroundBMP : Bitmap with get
Property Value
Bitmap


BeforeRemoveUnderline Event

Keyoti RapidSpell Desktop .NET API Docs
BeforeRemoveUnderline Event
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► BeforeRemoveUnderline
Keyoti RapidSpell Desktop .NET
Fired before a word is de-underlined
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event UnderlineEventHandler BeforeRemoveUnderline
public event UnderlineEventHandler BeforeRemoveUnderline
Public Event BeforeRemoveUnderline As UnderlineEventHandler
Public Event BeforeRemoveUnderline As UnderlineEventHandler
public:
 event UnderlineEventHandler^ BeforeRemoveUnderline {
    void add (UnderlineEventHandler^ value);
    void remove (UnderlineEventHandler^ value);
}
public:
 event UnderlineEventHandler^ BeforeRemoveUnderline {
    void add (UnderlineEventHandler^ value);
    void remove (UnderlineEventHandler^ value);
}
member BeforeRemoveUnderline : IEvent<UnderlineEventHandler,
    UnderlineEventArgs>

member BeforeRemoveUnderline : IEvent<UnderlineEventHandler,
    UnderlineEventArgs>
Value
UnderlineEventHandler


BeforeUnderline Event

Keyoti RapidSpell Desktop .NET API Docs
BeforeUnderline Event
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► BeforeUnderline
Keyoti RapidSpell Desktop .NET
Fired before a word is underlined
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event UnderlineEventHandler BeforeUnderline
public event UnderlineEventHandler BeforeUnderline
Public Event BeforeUnderline As UnderlineEventHandler
Public Event BeforeUnderline As UnderlineEventHandler
public:
 event UnderlineEventHandler^ BeforeUnderline {
    void add (UnderlineEventHandler^ value);
    void remove (UnderlineEventHandler^ value);
}
public:
 event UnderlineEventHandler^ BeforeUnderline {
    void add (UnderlineEventHandler^ value);
    void remove (UnderlineEventHandler^ value);
}
member BeforeUnderline : IEvent<UnderlineEventHandler,
    UnderlineEventArgs>

member BeforeUnderline : IEvent<UnderlineEventHandler,
    UnderlineEventArgs>
Value
UnderlineEventHandler


bmp Field

Keyoti RapidSpell Desktop .NET API Docs
bmp Field
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► bmp
Keyoti RapidSpell Desktop .NET
Bitmap of underlines
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected internal Bitmap bmp
protected internal Bitmap bmp
Protected Friend bmp As Bitmap
Protected Friend bmp As Bitmap
protected public:
Bitmap^ bmp
protected public:
Bitmap^ bmp
val mutable bmp: Bitmap
val mutable bmp: Bitmap
Field Value
Bitmap


currentText Field

Keyoti RapidSpell Desktop .NET API Docs
currentText Field
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► currentText
Keyoti RapidSpell Desktop .NET
Register of text currently in the text box, updated when it changes.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected string currentText
protected string currentText
Protected currentText As String
Protected currentText As String
protected:
String^ currentText
protected:
String^ currentText
val mutable currentText: string
val mutable currentText: string
Field Value
String


DoUpdates Method (newText)

Keyoti RapidSpell Desktop .NET API Docs
DoUpdates Method (newText)
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► DoUpdates(String)
Keyoti RapidSpell Desktop .NET
Updates underlines for change in text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected internal virtual void DoUpdates(
    string newText
)
protected internal virtual void DoUpdates(
    string newText
)
Protected Friend Overridable Sub DoUpdates (
    newText As String
)
Protected Friend Overridable Sub DoUpdates (
    newText As String
)
protected public:
virtual void DoUpdates(
    String^ newText
)
protected public:
virtual void DoUpdates(
    String^ newText
)
abstract DoUpdates :
        newText : string -> unit
override DoUpdates :
        newText : string -> unit
abstract DoUpdates :
        newText : string -> unit
override DoUpdates :
        newText : string -> unit
Parameters
newText (String)


doUpdatesMovedUnderlines Field

Keyoti RapidSpell Desktop .NET API Docs
doUpdatesMovedUnderlines Field
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► doUpdatesMovedUnderlines
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected bool doUpdatesMovedUnderlines
protected bool doUpdatesMovedUnderlines
Protected doUpdatesMovedUnderlines As Boolean
Protected doUpdatesMovedUnderlines As Boolean
protected:
bool doUpdatesMovedUnderlines
protected:
bool doUpdatesMovedUnderlines
val mutable doUpdatesMovedUnderlines: bool
val mutable doUpdatesMovedUnderlines: bool
Field Value
Boolean


FullPaint Method (refreshTextBox)

Keyoti RapidSpell Desktop .NET API Docs
FullPaint Method (refreshTextBox)
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► FullPaint(Boolean)
Keyoti RapidSpell Desktop .NET
Causes all underlines to be repainted.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void FullPaint(
    bool refreshTextBox
)
public virtual void FullPaint(
    bool refreshTextBox
)
Public Overridable Sub FullPaint (
    refreshTextBox As Boolean
)
Public Overridable Sub FullPaint (
    refreshTextBox As Boolean
)
public:
virtual void FullPaint(
    bool refreshTextBox
)
public:
virtual void FullPaint(
    bool refreshTextBox
)
abstract FullPaint :
        refreshTextBox : bool -> unit
override FullPaint :
        refreshTextBox : bool -> unit
abstract FullPaint :
        refreshTextBox : bool -> unit
override FullPaint :
        refreshTextBox : bool -> unit
Parameters
refreshTextBox (Boolean)
Whether to force the text box to be repainted first.


getFirstVisibleUnderline Method

Keyoti RapidSpell Desktop .NET API Docs
getFirstVisibleUnderline Method
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► getFirstVisibleUnderline()()()()
Keyoti RapidSpell Desktop .NET
Calculates the first visible underline, if necessary
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected int getFirstVisibleUnderline()
protected int getFirstVisibleUnderline()
Protected Function getFirstVisibleUnderline As Integer
Protected Function getFirstVisibleUnderline As Integer
protected:
int getFirstVisibleUnderline()
protected:
int getFirstVisibleUnderline()
member getFirstVisibleUnderline : unit -> int

member getFirstVisibleUnderline : unit -> int
Return Value
Int32


HideUnderline Method (start, end)

Keyoti RapidSpell Desktop .NET API Docs
HideUnderline Method (start, end)
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► HideUnderline(Int32, Int32)
Keyoti RapidSpell Desktop .NET
Hides an underline
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void HideUnderline(
    int start,
    int end
)
public virtual void HideUnderline(
    int start,
    int end
)
Public Overridable Sub HideUnderline (
    start As Integer,
    end As Integer
)
Public Overridable Sub HideUnderline (
    start As Integer,
    end As Integer
)
public:
virtual void HideUnderline(
    int start,
    int end
)
public:
virtual void HideUnderline(
    int start,
    int end
)
abstract HideUnderline :
        start : int *
        end : int -> unit
override HideUnderline :
        start : int *
        end : int -> unit
abstract HideUnderline :
        start : int *
        end : int -> unit
override HideUnderline :
        start : int *
        end : int -> unit
Parameters
start (Int32)
end (Int32)


IdentifyChange Method

Keyoti RapidSpell Desktop .NET API Docs
IdentifyChange Method
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► IdentifyChange()()()()
Keyoti RapidSpell Desktop .NET
Returns the start and end indices in the current text of the changed text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected int[] IdentifyChange()
protected int[] IdentifyChange()
Protected Function IdentifyChange As Integer()
Protected Function IdentifyChange As Integer()
protected:
array<int>^ IdentifyChange()
protected:
array<int>^ IdentifyChange()
member IdentifyChange : unit -> int[]

member IdentifyChange : unit -> int[]
Return Value
array< Int32 >[]()[][]


IsFinished Property

Keyoti RapidSpell Desktop .NET API Docs
IsFinished Property
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► IsFinished
Keyoti RapidSpell Desktop .NET
Whether this object is no longer being used.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IsFinished { get; }
public bool IsFinished { get; }
Public ReadOnly Property IsFinished As Boolean
    Get
Public ReadOnly Property IsFinished As Boolean
    Get
public:
property bool IsFinished {
    bool get ();
}
public:
property bool IsFinished {
    bool get ();
}
member IsFinished : bool with get

member IsFinished : bool with get
Property Value
Boolean


isPositionInUnderline Method (index)

Keyoti RapidSpell Desktop .NET API Docs
isPositionInUnderline Method (index)
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► isPositionInUnderline(Int32)
Keyoti RapidSpell Desktop .NET
Whether index is inside a visible underline
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool isPositionInUnderline(
    int index
)
public bool isPositionInUnderline(
    int index
)
Public Function isPositionInUnderline (
    index As Integer
) As Boolean
Public Function isPositionInUnderline (
    index As Integer
) As Boolean
public:
bool isPositionInUnderline(
    int index
)
public:
bool isPositionInUnderline(
    int index
)
member isPositionInUnderline :
        index : int -> bool

member isPositionInUnderline :
        index : int -> bool
Parameters
index (Int32)
Return Value
Boolean


KeyDown Event

Keyoti RapidSpell Desktop .NET API Docs
KeyDown Event
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► KeyDown
Keyoti RapidSpell Desktop .NET
User has keyed up.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event KeyEventHandler KeyDown
public event KeyEventHandler KeyDown
Public Event KeyDown As KeyEventHandler
Public Event KeyDown As KeyEventHandler
public:
 event KeyEventHandler^ KeyDown {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}
public:
 event KeyEventHandler^ KeyDown {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}
member KeyDown : IEvent<KeyEventHandler,
    KeyEventArgs>

member KeyDown : IEvent<KeyEventHandler,
    KeyEventArgs>
Value
KeyEventHandler


KeyPress Event

Keyoti RapidSpell Desktop .NET API Docs
KeyPress Event
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► KeyPress
Keyoti RapidSpell Desktop .NET
User has pressed a key.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event KeyPressEventHandler KeyPress
public event KeyPressEventHandler KeyPress
Public Event KeyPress As KeyPressEventHandler
Public Event KeyPress As KeyPressEventHandler
public:
 event KeyPressEventHandler^ KeyPress {
    void add (KeyPressEventHandler^ value);
    void remove (KeyPressEventHandler^ value);
}
public:
 event KeyPressEventHandler^ KeyPress {
    void add (KeyPressEventHandler^ value);
    void remove (KeyPressEventHandler^ value);
}
member KeyPress : IEvent<KeyPressEventHandler,
    KeyPressEventArgs>

member KeyPress : IEvent<KeyPressEventHandler,
    KeyPressEventArgs>
Value
KeyPressEventHandler


KeyUp Event

Keyoti RapidSpell Desktop .NET API Docs
KeyUp Event
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► KeyUp
Keyoti RapidSpell Desktop .NET
User has keyed up.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event KeyEventHandler KeyUp
public event KeyEventHandler KeyUp
Public Event KeyUp As KeyEventHandler
Public Event KeyUp As KeyEventHandler
public:
 event KeyEventHandler^ KeyUp {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}
public:
 event KeyEventHandler^ KeyUp {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}
member KeyUp : IEvent<KeyEventHandler,
    KeyEventArgs>

member KeyUp : IEvent<KeyEventHandler,
    KeyEventArgs>
Value
KeyEventHandler


Leave Event

Keyoti RapidSpell Desktop .NET API Docs
Leave Event
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► Leave
Keyoti RapidSpell Desktop .NET
Focus lost.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler Leave
public event EventHandler Leave
Public Event Leave As EventHandler
Public Event Leave As EventHandler
public:
 event EventHandler^ Leave {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
 event EventHandler^ Leave {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member Leave : IEvent<EventHandler,
    EventArgs>

member Leave : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


MenuMouseButton Field

Keyoti RapidSpell Desktop .NET API Docs
MenuMouseButton Field
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► MenuMouseButton
Keyoti RapidSpell Desktop .NET
The mouse button that is used to trigger the context menu.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static MouseButtons MenuMouseButton
public static MouseButtons MenuMouseButton
Public Shared MenuMouseButton As MouseButtons
Public Shared MenuMouseButton As MouseButtons
public:
static MouseButtons MenuMouseButton
public:
static MouseButtons MenuMouseButton
static val mutable MenuMouseButton: MouseButtons
static val mutable MenuMouseButton: MouseButtons
Field Value
MouseButtons


MouseReleased Event

Keyoti RapidSpell Desktop .NET API Docs
MouseReleased Event
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► MouseReleased
Keyoti RapidSpell Desktop .NET
User has mouse released.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event MouseEventHandler MouseReleased
public event MouseEventHandler MouseReleased
Public Event MouseReleased As MouseEventHandler
Public Event MouseReleased As MouseEventHandler
public:
 event MouseEventHandler^ MouseReleased {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}
public:
 event MouseEventHandler^ MouseReleased {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}
member MouseReleased : IEvent<MouseEventHandler,
    MouseEventArgs>

member MouseReleased : IEvent<MouseEventHandler,
    MouseEventArgs>
Value
MouseEventHandler


oldText Field

Keyoti RapidSpell Desktop .NET API Docs
oldText Field
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► oldText
Keyoti RapidSpell Desktop .NET
The text contained before text changed
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected string oldText
protected string oldText
Protected oldText As String
Protected oldText As String
protected:
String^ oldText
protected:
String^ oldText
val mutable oldText: string
val mutable oldText: string
Field Value
String


OnAfterRemoveUnderline Method (e)

Keyoti RapidSpell Desktop .NET API Docs
OnAfterRemoveUnderline Method (e)
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► OnAfterRemoveUnderline(UnderlineEventArgs)
Keyoti RapidSpell Desktop .NET
Raises event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected void OnAfterRemoveUnderline(
    UnderlineEventArgs e
)
protected void OnAfterRemoveUnderline(
    UnderlineEventArgs e
)
Protected Sub OnAfterRemoveUnderline (
    e As UnderlineEventArgs
)
Protected Sub OnAfterRemoveUnderline (
    e As UnderlineEventArgs
)
protected:
void OnAfterRemoveUnderline(
    UnderlineEventArgs^ e
)
protected:
void OnAfterRemoveUnderline(
    UnderlineEventArgs^ e
)
member OnAfterRemoveUnderline :
        e : UnderlineEventArgs -> unit

member OnAfterRemoveUnderline :
        e : UnderlineEventArgs -> unit
Parameters
e (UnderlineEventArgs)


OnAfterUnderline Method (e)

Keyoti RapidSpell Desktop .NET API Docs
OnAfterUnderline Method (e)
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► OnAfterUnderline(UnderlineEventArgs)
Keyoti RapidSpell Desktop .NET
Raises event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected void OnAfterUnderline(
    UnderlineEventArgs e
)
protected void OnAfterUnderline(
    UnderlineEventArgs e
)
Protected Sub OnAfterUnderline (
    e As UnderlineEventArgs
)
Protected Sub OnAfterUnderline (
    e As UnderlineEventArgs
)
protected:
void OnAfterUnderline(
    UnderlineEventArgs^ e
)
protected:
void OnAfterUnderline(
    UnderlineEventArgs^ e
)
member OnAfterUnderline :
        e : UnderlineEventArgs -> unit

member OnAfterUnderline :
        e : UnderlineEventArgs -> unit
Parameters
e (UnderlineEventArgs)


OnBeforeRemoveUnderline Method (e)

Keyoti RapidSpell Desktop .NET API Docs
OnBeforeRemoveUnderline Method (e)
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► OnBeforeRemoveUnderline(UnderlineEventArgs)
Keyoti RapidSpell Desktop .NET
Raises event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected void OnBeforeRemoveUnderline(
    UnderlineEventArgs e
)
protected void OnBeforeRemoveUnderline(
    UnderlineEventArgs e
)
Protected Sub OnBeforeRemoveUnderline (
    e As UnderlineEventArgs
)
Protected Sub OnBeforeRemoveUnderline (
    e As UnderlineEventArgs
)
protected:
void OnBeforeRemoveUnderline(
    UnderlineEventArgs^ e
)
protected:
void OnBeforeRemoveUnderline(
    UnderlineEventArgs^ e
)
member OnBeforeRemoveUnderline :
        e : UnderlineEventArgs -> unit

member OnBeforeRemoveUnderline :
        e : UnderlineEventArgs -> unit
Parameters
e (UnderlineEventArgs)


OnBeforeUnderline Method (e)

Keyoti RapidSpell Desktop .NET API Docs
OnBeforeUnderline Method (e)
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► OnBeforeUnderline(UnderlineEventArgs)
Keyoti RapidSpell Desktop .NET
Raises event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected void OnBeforeUnderline(
    UnderlineEventArgs e
)
protected void OnBeforeUnderline(
    UnderlineEventArgs e
)
Protected Sub OnBeforeUnderline (
    e As UnderlineEventArgs
)
Protected Sub OnBeforeUnderline (
    e As UnderlineEventArgs
)
protected:
void OnBeforeUnderline(
    UnderlineEventArgs^ e
)
protected:
void OnBeforeUnderline(
    UnderlineEventArgs^ e
)
member OnBeforeUnderline :
        e : UnderlineEventArgs -> unit

member OnBeforeUnderline :
        e : UnderlineEventArgs -> unit
Parameters
e (UnderlineEventArgs)


OnKeyDown Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
OnKeyDown Method (sender, e)
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► OnKeyDown(Object, KeyEventArgs)
Keyoti RapidSpell Desktop .NET
Called when KeyDown occurs.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void OnKeyDown(
    Object sender,
    KeyEventArgs e
)
protected virtual void OnKeyDown(
    Object sender,
    KeyEventArgs e
)
Protected Overridable Sub OnKeyDown (
    sender As Object,
    e As KeyEventArgs
)
Protected Overridable Sub OnKeyDown (
    sender As Object,
    e As KeyEventArgs
)
protected:
virtual void OnKeyDown(
    Object^ sender,
    KeyEventArgs^ e
)
protected:
virtual void OnKeyDown(
    Object^ sender,
    KeyEventArgs^ e
)
abstract OnKeyDown :
        sender : Object *
        e : KeyEventArgs -> unit
override OnKeyDown :
        sender : Object *
        e : KeyEventArgs -> unit
abstract OnKeyDown :
        sender : Object *
        e : KeyEventArgs -> unit
override OnKeyDown :
        sender : Object *
        e : KeyEventArgs -> unit
Parameters
sender (Object)
e (KeyEventArgs)


OnKeyUp Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
OnKeyUp Method (sender, e)
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► OnKeyUp(Object, KeyEventArgs)
Keyoti RapidSpell Desktop .NET
Called when KeyUp occurs.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void OnKeyUp(
    Object sender,
    KeyEventArgs e
)
protected virtual void OnKeyUp(
    Object sender,
    KeyEventArgs e
)
Protected Overridable Sub OnKeyUp (
    sender As Object,
    e As KeyEventArgs
)
Protected Overridable Sub OnKeyUp (
    sender As Object,
    e As KeyEventArgs
)
protected:
virtual void OnKeyUp(
    Object^ sender,
    KeyEventArgs^ e
)
protected:
virtual void OnKeyUp(
    Object^ sender,
    KeyEventArgs^ e
)
abstract OnKeyUp :
        sender : Object *
        e : KeyEventArgs -> unit
override OnKeyUp :
        sender : Object *
        e : KeyEventArgs -> unit
abstract OnKeyUp :
        sender : Object *
        e : KeyEventArgs -> unit
override OnKeyUp :
        sender : Object *
        e : KeyEventArgs -> unit
Parameters
sender (Object)
e (KeyEventArgs)


OnLeave Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
OnLeave Method (sender, e)
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► OnLeave(Object, EventArgs)
Keyoti RapidSpell Desktop .NET
Called when user leave the text box
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void OnLeave(
    Object sender,
    EventArgs e
)
protected virtual void OnLeave(
    Object sender,
    EventArgs e
)
Protected Overridable Sub OnLeave (
    sender As Object,
    e As EventArgs
)
Protected Overridable Sub OnLeave (
    sender As Object,
    e As EventArgs
)
protected:
virtual void OnLeave(
    Object^ sender,
    EventArgs^ e
)
protected:
virtual void OnLeave(
    Object^ sender,
    EventArgs^ e
)
abstract OnLeave :
        sender : Object *
        e : EventArgs -> unit
override OnLeave :
        sender : Object *
        e : EventArgs -> unit
abstract OnLeave :
        sender : Object *
        e : EventArgs -> unit
override OnLeave :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


OnMousePressed Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
OnMousePressed Method (sender, e)
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► OnMousePressed(Object, MouseEventArgs)
Keyoti RapidSpell Desktop .NET
Mouse handler
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void OnMousePressed(
    Object sender,
    MouseEventArgs e
)
protected virtual void OnMousePressed(
    Object sender,
    MouseEventArgs e
)
Protected Overridable Sub OnMousePressed (
    sender As Object,
    e As MouseEventArgs
)
Protected Overridable Sub OnMousePressed (
    sender As Object,
    e As MouseEventArgs
)
protected:
virtual void OnMousePressed(
    Object^ sender,
    MouseEventArgs^ e
)
protected:
virtual void OnMousePressed(
    Object^ sender,
    MouseEventArgs^ e
)
abstract OnMousePressed :
        sender : Object *
        e : MouseEventArgs -> unit
override OnMousePressed :
        sender : Object *
        e : MouseEventArgs -> unit
abstract OnMousePressed :
        sender : Object *
        e : MouseEventArgs -> unit
override OnMousePressed :
        sender : Object *
        e : MouseEventArgs -> unit
Parameters
sender (Object)
e (MouseEventArgs)


OnMouseReleased Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
OnMouseReleased Method (sender, e)
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► OnMouseReleased(Object, MouseEventArgs)
Keyoti RapidSpell Desktop .NET
Called when MouseReleased occurs.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void OnMouseReleased(
    Object sender,
    MouseEventArgs e
)
protected virtual void OnMouseReleased(
    Object sender,
    MouseEventArgs e
)
Protected Overridable Sub OnMouseReleased (
    sender As Object,
    e As MouseEventArgs
)
Protected Overridable Sub OnMouseReleased (
    sender As Object,
    e As MouseEventArgs
)
protected:
virtual void OnMouseReleased(
    Object^ sender,
    MouseEventArgs^ e
)
protected:
virtual void OnMouseReleased(
    Object^ sender,
    MouseEventArgs^ e
)
abstract OnMouseReleased :
        sender : Object *
        e : MouseEventArgs -> unit
override OnMouseReleased :
        sender : Object *
        e : MouseEventArgs -> unit
abstract OnMouseReleased :
        sender : Object *
        e : MouseEventArgs -> unit
override OnMouseReleased :
        sender : Object *
        e : MouseEventArgs -> unit
Parameters
sender (Object)
e (MouseEventArgs)


OnTextBoxDisposed Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
OnTextBoxDisposed Method (sender, e)
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► OnTextBoxDisposed(Object, EventArgs)
Keyoti RapidSpell Desktop .NET
Called when text box is disposed.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected void OnTextBoxDisposed(
    Object sender,
    EventArgs e
)
protected void OnTextBoxDisposed(
    Object sender,
    EventArgs e
)
Protected Sub OnTextBoxDisposed (
    sender As Object,
    e As EventArgs
)
Protected Sub OnTextBoxDisposed (
    sender As Object,
    e As EventArgs
)
protected:
void OnTextBoxDisposed(
    Object^ sender,
    EventArgs^ e
)
protected:
void OnTextBoxDisposed(
    Object^ sender,
    EventArgs^ e
)
member OnTextBoxDisposed :
        sender : Object *
        e : EventArgs -> unit

member OnTextBoxDisposed :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


OnTextBoxInvalidated Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
OnTextBoxInvalidated Method (sender, e)
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► OnTextBoxInvalidated(Object, InvalidateEventArgs)
Keyoti RapidSpell Desktop .NET
Called when text box is invalidated
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected void OnTextBoxInvalidated(
    Object sender,
    InvalidateEventArgs e
)
protected void OnTextBoxInvalidated(
    Object sender,
    InvalidateEventArgs e
)
Protected Sub OnTextBoxInvalidated (
    sender As Object,
    e As InvalidateEventArgs
)
Protected Sub OnTextBoxInvalidated (
    sender As Object,
    e As InvalidateEventArgs
)
protected:
void OnTextBoxInvalidated(
    Object^ sender,
    InvalidateEventArgs^ e
)
protected:
void OnTextBoxInvalidated(
    Object^ sender,
    InvalidateEventArgs^ e
)
member OnTextBoxInvalidated :
        sender : Object *
        e : InvalidateEventArgs -> unit

member OnTextBoxInvalidated :
        sender : Object *
        e : InvalidateEventArgs -> unit
Parameters
sender (Object)
e (InvalidateEventArgs)


OnTextChanged Method (sender, evntargs)

Keyoti RapidSpell Desktop .NET API Docs
OnTextChanged Method (sender, evntargs)
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► OnTextChanged(Object, EventArgs)
Keyoti RapidSpell Desktop .NET
Called when the text box's text is changed
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected internal virtual void OnTextChanged(
    Object sender,
    EventArgs evntargs
)
protected internal virtual void OnTextChanged(
    Object sender,
    EventArgs evntargs
)
Protected Friend Overridable Sub OnTextChanged (
    sender As Object,
    evntargs As EventArgs
)
Protected Friend Overridable Sub OnTextChanged (
    sender As Object,
    evntargs As EventArgs
)
protected public:
virtual void OnTextChanged(
    Object^ sender,
    EventArgs^ evntargs
)
protected public:
virtual void OnTextChanged(
    Object^ sender,
    EventArgs^ evntargs
)
abstract OnTextChanged :
        sender : Object *
        evntargs : EventArgs -> unit
override OnTextChanged :
        sender : Object *
        evntargs : EventArgs -> unit
abstract OnTextChanged :
        sender : Object *
        evntargs : EventArgs -> unit
override OnTextChanged :
        sender : Object *
        evntargs : EventArgs -> unit
Parameters
sender (Object)
evntargs (EventArgs)


paint Method

Keyoti RapidSpell Desktop .NET API Docs
paint Method
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► paint()()()()
Keyoti RapidSpell Desktop .NET
Paint onto the textbox
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void paint()
protected virtual void paint()
Protected Overridable Sub paint
Protected Overridable Sub paint
protected:
virtual void paint()
protected:
virtual void paint()
abstract paint : unit -> unit
override paint : unit -> unit
abstract paint : unit -> unit
override paint : unit -> unit


paintUnderline Method (g, start, end, style, pen)

Keyoti RapidSpell Desktop .NET API Docs
paintUnderline Method (g, start, end, style, pen)
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► paintUnderline(Graphics, Point, Point, UnderlineStyle, Pen)
Keyoti RapidSpell Desktop .NET
Paints an underline
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static void paintUnderline(
    Graphics g,
    Point start,
    Point end,
    UnderlineStyle style,
    Pen pen
)
public static void paintUnderline(
    Graphics g,
    Point start,
    Point end,
    UnderlineStyle style,
    Pen pen
)
Public Shared Sub paintUnderline (
    g As Graphics,
    start As Point,
    end As Point,
    style As UnderlineStyle,
    pen As Pen
)
Public Shared Sub paintUnderline (
    g As Graphics,
    start As Point,
    end As Point,
    style As UnderlineStyle,
    pen As Pen
)
public:
static void paintUnderline(
    Graphics^ g,
    Point start,
    Point end,
    UnderlineStyle style,
    Pen^ pen
)
public:
static void paintUnderline(
    Graphics^ g,
    Point start,
    Point end,
    UnderlineStyle style,
    Pen^ pen
)
static member paintUnderline :
        g : Graphics *
        start : Point *
        end : Point *
        style : UnderlineStyle *
        pen : Pen -> unit

static member paintUnderline :
        g : Graphics *
        start : Point *
        end : Point *
        style : UnderlineStyle *
        pen : Pen -> unit
Parameters
g (Graphics)
start (Point)
end (Point)
style (UnderlineStyle)
pen (Pen)


prePaint Method

Keyoti RapidSpell Desktop .NET API Docs
prePaint Method
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► prePaint()()()()
Keyoti RapidSpell Desktop .NET
Prepaints the underlines onto a buffer bitmap
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void prePaint()
protected virtual void prePaint()
Protected Overridable Sub prePaint
Protected Overridable Sub prePaint
protected:
virtual void prePaint()
protected:
virtual void prePaint()
abstract prePaint : unit -> unit
override prePaint : unit -> unit
abstract prePaint : unit -> unit
override prePaint : unit -> unit


Refresh Method

Keyoti RapidSpell Desktop .NET API Docs
Refresh Method
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► Refresh()()()()
Keyoti RapidSpell Desktop .NET
Refreshes the display.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void Refresh()
public void Refresh()
Public Sub Refresh
Public Sub Refresh
public:
void Refresh()
public:
void Refresh()
member Refresh : unit -> unit

member Refresh : unit -> unit


RemoveAllUnderlines Method

Keyoti RapidSpell Desktop .NET API Docs
RemoveAllUnderlines Method
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► RemoveAllUnderlines()()()()
Keyoti RapidSpell Desktop .NET
Remove all underlines.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void RemoveAllUnderlines()
public virtual void RemoveAllUnderlines()
Public Overridable Sub RemoveAllUnderlines
Public Overridable Sub RemoveAllUnderlines
public:
virtual void RemoveAllUnderlines()
public:
virtual void RemoveAllUnderlines()
abstract RemoveAllUnderlines : unit -> unit
override RemoveAllUnderlines : unit -> unit
abstract RemoveAllUnderlines : unit -> unit
override RemoveAllUnderlines : unit -> unit


RemoveUnderline Method (start, end, u, c)

Keyoti RapidSpell Desktop .NET API Docs
RemoveUnderline Method (start, end, u, c)
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► RemoveUnderline(Int32, Int32, UnderlineStyle, Color)
Keyoti RapidSpell Desktop .NET
Remove underline text, from start index to end index.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool RemoveUnderline(
    int start,
    int end,
    UnderlineStyle u,
    Color c
)
public virtual bool RemoveUnderline(
    int start,
    int end,
    UnderlineStyle u,
    Color c
)
Public Overridable Function RemoveUnderline (
    start As Integer,
    end As Integer,
    u As UnderlineStyle,
    c As Color
) As Boolean
Public Overridable Function RemoveUnderline (
    start As Integer,
    end As Integer,
    u As UnderlineStyle,
    c As Color
) As Boolean
public:
virtual bool RemoveUnderline(
    int start,
    int end,
    UnderlineStyle u,
    Color c
)
public:
virtual bool RemoveUnderline(
    int start,
    int end,
    UnderlineStyle u,
    Color c
)
abstract RemoveUnderline :
        start : int *
        end : int *
        u : UnderlineStyle *
        c : Color -> bool
override RemoveUnderline :
        start : int *
        end : int *
        u : UnderlineStyle *
        c : Color -> bool
abstract RemoveUnderline :
        start : int *
        end : int *
        u : UnderlineStyle *
        c : Color -> bool
override RemoveUnderline :
        start : int *
        end : int *
        u : UnderlineStyle *
        c : Color -> bool
Parameters
start (Int32)
end (Int32)
u (UnderlineStyle)
c (Color)
Return Value
Boolean


RepaintTimer Property

Keyoti RapidSpell Desktop .NET API Docs
RepaintTimer Property
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► RepaintTimer
Keyoti RapidSpell Desktop .NET
The number of milliseconds that must pass since the last user input before repainting. This has a resolution of 250 milliseconds.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int RepaintTimer { get; set; }
public int RepaintTimer { get; set; }
Public Property RepaintTimer As Integer
    Get
    Set
Public Property RepaintTimer As Integer
    Get
    Set
public:
property int RepaintTimer {
    int get ();
    void set (int value);
}
public:
property int RepaintTimer {
    int get ();
    void set (int value);
}
member RepaintTimer : int with get, set

member RepaintTimer : int with get, set
Property Value
Int32


RequestingContextMenu Event

Keyoti RapidSpell Desktop .NET API Docs
RequestingContextMenu Event
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► RequestingContextMenu
Keyoti RapidSpell Desktop .NET
Context menu request
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler RequestingContextMenu
public event EventHandler RequestingContextMenu
Public Event RequestingContextMenu As EventHandler
Public Event RequestingContextMenu As EventHandler
public:
 event EventHandler^ RequestingContextMenu {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
 event EventHandler^ RequestingContextMenu {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member RequestingContextMenu : IEvent<EventHandler,
    EventArgs>

member RequestingContextMenu : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


textBox Field

Keyoti RapidSpell Desktop .NET API Docs
textBox Field
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► textBox
Keyoti RapidSpell Desktop .NET
The text box being painted.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected IAYTTextBox textBox
protected IAYTTextBox textBox
Protected textBox As IAYTTextBox
Protected textBox As IAYTTextBox
protected:
IAYTTextBox^ textBox
protected:
IAYTTextBox^ textBox
val mutable textBox: IAYTTextBox
val mutable textBox: IAYTTextBox
Field Value
IAYTTextBox


textBoxCanvas Field

Keyoti RapidSpell Desktop .NET API Docs
textBoxCanvas Field
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► textBoxCanvas
Keyoti RapidSpell Desktop .NET
The textbox graphics context on which painting is performed
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected Graphics textBoxCanvas
protected Graphics textBoxCanvas
Protected textBoxCanvas As Graphics
Protected textBoxCanvas As Graphics
protected:
Graphics^ textBoxCanvas
protected:
Graphics^ textBoxCanvas
val mutable textBoxCanvas: Graphics
val mutable textBoxCanvas: Graphics
Field Value
Graphics


TextChanged Event

Keyoti RapidSpell Desktop .NET API Docs
TextChanged Event
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► TextChanged
Keyoti RapidSpell Desktop .NET
Text Changed.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler TextChanged
public event EventHandler TextChanged
Public Event TextChanged As EventHandler
Public Event TextChanged As EventHandler
public:
 event EventHandler^ TextChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
 event EventHandler^ TextChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member TextChanged : IEvent<EventHandler,
    EventArgs>

member TextChanged : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


timeSinceRepaintCall Field

Keyoti RapidSpell Desktop .NET API Docs
timeSinceRepaintCall Field
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► timeSinceRepaintCall
Keyoti RapidSpell Desktop .NET
When repaint timer is active, this is how long since the timer expired.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected int timeSinceRepaintCall
protected int timeSinceRepaintCall
Protected timeSinceRepaintCall As Integer
Protected timeSinceRepaintCall As Integer
protected:
int timeSinceRepaintCall
protected:
int timeSinceRepaintCall
val mutable timeSinceRepaintCall: int
val mutable timeSinceRepaintCall: int
Field Value
Int32


Underline Method (start, end, u, c, originalBadWord)

Keyoti RapidSpell Desktop .NET API Docs
Underline Method (start, end, u, c, originalBadWord)
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► Underline(Int32, Int32, UnderlineStyle, Color, BadWord)
Keyoti RapidSpell Desktop .NET
Underline text, from start index to end index.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void Underline(
    int start,
    int end,
    UnderlineStyle u,
    Color c,
    BadWord originalBadWord
)
public virtual void Underline(
    int start,
    int end,
    UnderlineStyle u,
    Color c,
    BadWord originalBadWord
)
Public Overridable Sub Underline (
    start As Integer,
    end As Integer,
    u As UnderlineStyle,
    c As Color,
    originalBadWord As BadWord
)
Public Overridable Sub Underline (
    start As Integer,
    end As Integer,
    u As UnderlineStyle,
    c As Color,
    originalBadWord As BadWord
)
public:
virtual void Underline(
    int start,
    int end,
    UnderlineStyle u,
    Color c,
    BadWord^ originalBadWord
)
public:
virtual void Underline(
    int start,
    int end,
    UnderlineStyle u,
    Color c,
    BadWord^ originalBadWord
)
abstract Underline :
        start : int *
        end : int *
        u : UnderlineStyle *
        c : Color *
        originalBadWord : BadWord -> unit
override Underline :
        start : int *
        end : int *
        u : UnderlineStyle *
        c : Color *
        originalBadWord : BadWord -> unit
abstract Underline :
        start : int *
        end : int *
        u : UnderlineStyle *
        c : Color *
        originalBadWord : BadWord -> unit
override Underline :
        start : int *
        end : int *
        u : UnderlineStyle *
        c : Color *
        originalBadWord : BadWord -> unit
Parameters
start (Int32)
end (Int32)
u (UnderlineStyle)
c (Color)
originalBadWord (BadWord)


underlines Field

Keyoti RapidSpell Desktop .NET API Docs
underlines Field
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► underlines
Keyoti RapidSpell Desktop .NET
The underlines being tracked.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected ArrayList underlines
protected ArrayList underlines
Protected underlines As ArrayList
Protected underlines As ArrayList
protected:
ArrayList^ underlines
protected:
ArrayList^ underlines
val mutable underlines: ArrayList
val mutable underlines: ArrayList
Field Value
ArrayList


underlinesArePainted Field

Keyoti RapidSpell Desktop .NET API Docs
underlinesArePainted Field
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► underlinesArePainted
Keyoti RapidSpell Desktop .NET
Whether underlines have been painted
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected bool underlinesArePainted
protected bool underlinesArePainted
Protected underlinesArePainted As Boolean
Protected underlinesArePainted As Boolean
protected:
bool underlinesArePainted
protected:
bool underlinesArePainted
val mutable underlinesArePainted: bool
val mutable underlinesArePainted: bool
Field Value
Boolean


UnhideUnderline Method (start, end)

Keyoti RapidSpell Desktop .NET API Docs
UnhideUnderline Method (start, end)
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► UnhideUnderline(Int32, Int32)
Keyoti RapidSpell Desktop .NET
Unhides an underline
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void UnhideUnderline(
    int start,
    int end
)
public virtual void UnhideUnderline(
    int start,
    int end
)
Public Overridable Sub UnhideUnderline (
    start As Integer,
    end As Integer
)
Public Overridable Sub UnhideUnderline (
    start As Integer,
    end As Integer
)
public:
virtual void UnhideUnderline(
    int start,
    int end
)
public:
virtual void UnhideUnderline(
    int start,
    int end
)
abstract UnhideUnderline :
        start : int *
        end : int -> unit
override UnhideUnderline :
        start : int *
        end : int -> unit
abstract UnhideUnderline :
        start : int *
        end : int -> unit
override UnhideUnderline :
        start : int *
        end : int -> unit
Parameters
start (Int32)
end (Int32)


TextBoxUtilityAdapter.RightClickEventHandler Delegate

Keyoti RapidSpell Desktop .NET API Docs
TextBoxUtilityAdapter..::..RightClickEventHandler Delegate
API ► Keyoti.RapidSpell ► TextBoxUtilityAdapter ► TextBoxUtilityAdapter..::..RightClickEventHandler
Keyoti RapidSpell Desktop .NET
Handles right clicks.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void RightClickEventHandler(
    Object sender,
    int clickCharIndex
)
public delegate void RightClickEventHandler(
    Object sender,
    int clickCharIndex
)
Public Delegate Sub RightClickEventHandler (
    sender As Object,
    clickCharIndex As Integer
)
Public Delegate Sub RightClickEventHandler (
    sender As Object,
    clickCharIndex As Integer
)
public delegate void RightClickEventHandler(
    Object^ sender,
    int clickCharIndex
)
public delegate void RightClickEventHandler(
    Object^ sender,
    int clickCharIndex
)
type RightClickEventHandler =
    delegate of
        sender : Object *
        clickCharIndex : int -> unit
type RightClickEventHandler =
    delegate of
        sender : Object *
        clickCharIndex : int -> unit
Parameters
sender (Object)
The sender object, where the event originated from.
clickCharIndex (Int32)
The index of the character the was clicked on.


TextChangeHint Class

Keyoti RapidSpell Desktop .NET API Docs
TextChangeHint Class
API ► Keyoti.RapidSpell ► TextChangeHint
Keyoti RapidSpell Desktop .NET
Hints the change scanner as to where the change could be, if any, on user input.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class TextChangeHint
public class TextChangeHint
Public Class TextChangeHint
Public Class TextChangeHint
public ref class TextChangeHint
public ref class TextChangeHint
type TextChangeHint =  class end
type TextChangeHint =  class end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TextChangeHint()()()() |
 | ActionLocation | Where the cursor was, in the text, before the action occurred.
 | ActionUnlikelyToMeanChangeMade | True when a key such as cursor, page-up etc is pressed, which more than likely means the text hasn't changed.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
TextChangeHint


TextChangeHint Constructor

Keyoti RapidSpell Desktop .NET API Docs
TextChangeHint Constructor
API ► Keyoti.RapidSpell ► TextChangeHint ► TextChangeHint()()()()
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public TextChangeHint()
public TextChangeHint()
Public Sub New
Public Sub New
public:
TextChangeHint()
public:
TextChangeHint()
new : unit -> TextChangeHint
new : unit -> TextChangeHint


ActionLocation Property

Keyoti RapidSpell Desktop .NET API Docs
ActionLocation Property
API ► Keyoti.RapidSpell ► TextChangeHint ► ActionLocation
Keyoti RapidSpell Desktop .NET
Where the cursor was, in the text, before the action occurred.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int ActionLocation { get; set; }
public int ActionLocation { get; set; }
Public Property ActionLocation As Integer
    Get
    Set
Public Property ActionLocation As Integer
    Get
    Set
public:
property int ActionLocation {
    int get ();
    void set (int value);
}
public:
property int ActionLocation {
    int get ();
    void set (int value);
}
member ActionLocation : int with get, set

member ActionLocation : int with get, set
Property Value
Int32


ActionUnlikelyToMeanChangeMade Property

Keyoti RapidSpell Desktop .NET API Docs
ActionUnlikelyToMeanChangeMade Property
API ► Keyoti.RapidSpell ► TextChangeHint ► ActionUnlikelyToMeanChangeMade
Keyoti RapidSpell Desktop .NET
True when a key such as cursor, page-up etc is pressed, which more than likely means the text hasn't changed.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ActionUnlikelyToMeanChangeMade { get; set; }
public bool ActionUnlikelyToMeanChangeMade { get; set; }
Public Property ActionUnlikelyToMeanChangeMade As Boolean
    Get
    Set
Public Property ActionUnlikelyToMeanChangeMade As Boolean
    Get
    Set
public:
property bool ActionUnlikelyToMeanChangeMade {
    bool get ();
    void set (bool value);
}
public:
property bool ActionUnlikelyToMeanChangeMade {
    bool get ();
    void set (bool value);
}
member ActionUnlikelyToMeanChangeMade : bool with get, set

member ActionUnlikelyToMeanChangeMade : bool with get, set
Property Value
Boolean


Underline Class

Keyoti RapidSpell Desktop .NET API Docs
Underline Class
API ► Keyoti.RapidSpell ► Underline
Keyoti RapidSpell Desktop .NET
Represents an underline
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class Underline
public class Underline
Public Class Underline
Public Class Underline
public ref class Underline
public ref class Underline
type Underline =  class end
type Underline =  class end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Underline(Int32, Int32, UnderlineStyle, Color, BadWord) | New instance
 | Color | Color
 | End | End
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | Hidden | Whether the underline is hidden
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OriginalBadWord | The original bad word, note that it's offsets are not relative to the start of the text.
 | Start | Start
 | Style | Style
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
Underline


Underline Constructor (start, end, u, c, originalBadWord)

Keyoti RapidSpell Desktop .NET API Docs
Underline Constructor (start, end, u, c, originalBadWord)
API ► Keyoti.RapidSpell ► Underline ► Underline(Int32, Int32, UnderlineStyle, Color, BadWord)
Keyoti RapidSpell Desktop .NET
New instance
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Underline(
    int start,
    int end,
    UnderlineStyle u,
    Color c,
    BadWord originalBadWord
)
public Underline(
    int start,
    int end,
    UnderlineStyle u,
    Color c,
    BadWord originalBadWord
)
Public Sub New (
    start As Integer,
    end As Integer,
    u As UnderlineStyle,
    c As Color,
    originalBadWord As BadWord
)
Public Sub New (
    start As Integer,
    end As Integer,
    u As UnderlineStyle,
    c As Color,
    originalBadWord As BadWord
)
public:
Underline(
    int start,
    int end,
    UnderlineStyle u,
    Color c,
    BadWord^ originalBadWord
)
public:
Underline(
    int start,
    int end,
    UnderlineStyle u,
    Color c,
    BadWord^ originalBadWord
)
new :
        start : int *
        end : int *
        u : UnderlineStyle *
        c : Color *
        originalBadWord : BadWord -> Underline
new :
        start : int *
        end : int *
        u : UnderlineStyle *
        c : Color *
        originalBadWord : BadWord -> Underline
Parameters
start (Int32)
end (Int32)
u (UnderlineStyle)
c (Color)
originalBadWord (BadWord)


Color Property

Keyoti RapidSpell Desktop .NET API Docs
Color Property
API ► Keyoti.RapidSpell ► Underline ► Color
Keyoti RapidSpell Desktop .NET
Color
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Color Color { get; set; }
public Color Color { get; set; }
Public Property Color As Color
    Get
    Set
Public Property Color As Color
    Get
    Set
public:
property Color Color {
    Color get ();
    void set (Color value);
}
public:
property Color Color {
    Color get ();
    void set (Color value);
}
member Color : Color with get, set

member Color : Color with get, set
Property Value
Color


End Property

Keyoti RapidSpell Desktop .NET API Docs
End Property
API ► Keyoti.RapidSpell ► Underline ► End
Keyoti RapidSpell Desktop .NET
End
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int End { get; set; }
public int End { get; set; }
Public Property End As Integer
    Get
    Set
Public Property End As Integer
    Get
    Set
public:
property int End {
    int get ();
    void set (int value);
}
public:
property int End {
    int get ();
    void set (int value);
}
member End : int with get, set

member End : int with get, set
Property Value
Int32


Hidden Property

Keyoti RapidSpell Desktop .NET API Docs
Hidden Property
API ► Keyoti.RapidSpell ► Underline ► Hidden
Keyoti RapidSpell Desktop .NET
Whether the underline is hidden
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool Hidden { get; set; }
public bool Hidden { get; set; }
Public Property Hidden As Boolean
    Get
    Set
Public Property Hidden As Boolean
    Get
    Set
public:
property bool Hidden {
    bool get ();
    void set (bool value);
}
public:
property bool Hidden {
    bool get ();
    void set (bool value);
}
member Hidden : bool with get, set

member Hidden : bool with get, set
Property Value
Boolean


OriginalBadWord Property

Keyoti RapidSpell Desktop .NET API Docs
OriginalBadWord Property
API ► Keyoti.RapidSpell ► Underline ► OriginalBadWord
Keyoti RapidSpell Desktop .NET
The original bad word, note that it's offsets are not relative to the start of the text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public BadWord OriginalBadWord { get; set; }
public BadWord OriginalBadWord { get; set; }
Public Property OriginalBadWord As BadWord
    Get
    Set
Public Property OriginalBadWord As BadWord
    Get
    Set
public:
property BadWord^ OriginalBadWord {
    BadWord^ get ();
    void set (BadWord^ value);
}
public:
property BadWord^ OriginalBadWord {
    BadWord^ get ();
    void set (BadWord^ value);
}
member OriginalBadWord : BadWord with get, set

member OriginalBadWord : BadWord with get, set
Property Value
BadWord


Start Property

Keyoti RapidSpell Desktop .NET API Docs
Start Property
API ► Keyoti.RapidSpell ► Underline ► Start
Keyoti RapidSpell Desktop .NET
Start
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int Start { get; set; }
public int Start { get; set; }
Public Property Start As Integer
    Get
    Set
Public Property Start As Integer
    Get
    Set
public:
property int Start {
    int get ();
    void set (int value);
}
public:
property int Start {
    int get ();
    void set (int value);
}
member Start : int with get, set

member Start : int with get, set
Property Value
Int32


Style Property

Keyoti RapidSpell Desktop .NET API Docs
Style Property
API ► Keyoti.RapidSpell ► Underline ► Style
Keyoti RapidSpell Desktop .NET
Style
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UnderlineStyle Style { get; set; }
public UnderlineStyle Style { get; set; }
Public Property Style As UnderlineStyle
    Get
    Set
Public Property Style As UnderlineStyle
    Get
    Set
public:
property UnderlineStyle Style {
    UnderlineStyle get ();
    void set (UnderlineStyle value);
}
public:
property UnderlineStyle Style {
    UnderlineStyle get ();
    void set (UnderlineStyle value);
}
member Style : UnderlineStyle with get, set

member Style : UnderlineStyle with get, set
Property Value
UnderlineStyle


UnderlineEventArgs Class

Keyoti RapidSpell Desktop .NET API Docs
UnderlineEventArgs Class
API ► Keyoti.RapidSpell ► UnderlineEventArgs
Keyoti RapidSpell Desktop .NET
Event arguments for underline events
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class UnderlineEventArgs
public class UnderlineEventArgs
Public Class UnderlineEventArgs
Public Class UnderlineEventArgs
public ref class UnderlineEventArgs
public ref class UnderlineEventArgs
type UnderlineEventArgs =  class end
type UnderlineEventArgs =  class end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UnderlineEventArgs(Int32, Int32, UnderlineStyle, Color) | New instance.
 | Color | The color of the underline
 | End | The end index of the underline
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Start | The start index of the underline
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | UnderlineStyle | The style of the underline
Inheritance Hierarchy
Object
UnderlineEventArgs


UnderlineEventArgs Constructor (start, end, u, c)

Keyoti RapidSpell Desktop .NET API Docs
UnderlineEventArgs Constructor (start, end, u, c)
API ► Keyoti.RapidSpell ► UnderlineEventArgs ► UnderlineEventArgs(Int32, Int32, UnderlineStyle, Color)
Keyoti RapidSpell Desktop .NET
New instance.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UnderlineEventArgs(
    int start,
    int end,
    UnderlineStyle u,
    Color c
)
public UnderlineEventArgs(
    int start,
    int end,
    UnderlineStyle u,
    Color c
)
Public Sub New (
    start As Integer,
    end As Integer,
    u As UnderlineStyle,
    c As Color
)
Public Sub New (
    start As Integer,
    end As Integer,
    u As UnderlineStyle,
    c As Color
)
public:
UnderlineEventArgs(
    int start,
    int end,
    UnderlineStyle u,
    Color c
)
public:
UnderlineEventArgs(
    int start,
    int end,
    UnderlineStyle u,
    Color c
)
new :
        start : int *
        end : int *
        u : UnderlineStyle *
        c : Color -> UnderlineEventArgs
new :
        start : int *
        end : int *
        u : UnderlineStyle *
        c : Color -> UnderlineEventArgs
Parameters
start (Int32)
end (Int32)
u (UnderlineStyle)
c (Color)


Color Property

Keyoti RapidSpell Desktop .NET API Docs
Color Property
API ► Keyoti.RapidSpell ► UnderlineEventArgs ► Color
Keyoti RapidSpell Desktop .NET
The color of the underline
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Color Color { get; }
public Color Color { get; }
Public ReadOnly Property Color As Color
    Get
Public ReadOnly Property Color As Color
    Get
public:
property Color Color {
    Color get ();
}
public:
property Color Color {
    Color get ();
}
member Color : Color with get

member Color : Color with get
Property Value
Color


End Property

Keyoti RapidSpell Desktop .NET API Docs
End Property
API ► Keyoti.RapidSpell ► UnderlineEventArgs ► End
Keyoti RapidSpell Desktop .NET
The end index of the underline
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int End { get; }
public int End { get; }
Public ReadOnly Property End As Integer
    Get
Public ReadOnly Property End As Integer
    Get
public:
property int End {
    int get ();
}
public:
property int End {
    int get ();
}
member End : int with get

member End : int with get
Property Value
Int32


Start Property

Keyoti RapidSpell Desktop .NET API Docs
Start Property
API ► Keyoti.RapidSpell ► UnderlineEventArgs ► Start
Keyoti RapidSpell Desktop .NET
The start index of the underline
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int Start { get; }
public int Start { get; }
Public ReadOnly Property Start As Integer
    Get
Public ReadOnly Property Start As Integer
    Get
public:
property int Start {
    int get ();
}
public:
property int Start {
    int get ();
}
member Start : int with get

member Start : int with get
Property Value
Int32


UnderlineStyle Property

Keyoti RapidSpell Desktop .NET API Docs
UnderlineStyle Property
API ► Keyoti.RapidSpell ► UnderlineEventArgs ► UnderlineStyle
Keyoti RapidSpell Desktop .NET
The style of the underline
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UnderlineStyle UnderlineStyle { get; }
public UnderlineStyle UnderlineStyle { get; }
Public ReadOnly Property UnderlineStyle As UnderlineStyle
    Get
Public ReadOnly Property UnderlineStyle As UnderlineStyle
    Get
public:
property UnderlineStyle UnderlineStyle {
    UnderlineStyle get ();
}
public:
property UnderlineStyle UnderlineStyle {
    UnderlineStyle get ();
}
member UnderlineStyle : UnderlineStyle with get

member UnderlineStyle : UnderlineStyle with get
Property Value
UnderlineStyle


UnderlineEventHandler Delegate

Keyoti RapidSpell Desktop .NET API Docs
UnderlineEventHandler Delegate
API ► Keyoti.RapidSpell ► UnderlineEventHandler
Keyoti RapidSpell Desktop .NET
Underline event handler
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void UnderlineEventHandler(
    Object s,
    UnderlineEventArgs e
)
public delegate void UnderlineEventHandler(
    Object s,
    UnderlineEventArgs e
)
Public Delegate Sub UnderlineEventHandler (
    s As Object,
    e As UnderlineEventArgs
)
Public Delegate Sub UnderlineEventHandler (
    s As Object,
    e As UnderlineEventArgs
)
public delegate void UnderlineEventHandler(
    Object^ s,
    UnderlineEventArgs^ e
)
public delegate void UnderlineEventHandler(
    Object^ s,
    UnderlineEventArgs^ e
)
type UnderlineEventHandler =
    delegate of
        s : Object *
        e : UnderlineEventArgs -> unit
type UnderlineEventHandler =
    delegate of
        s : Object *
        e : UnderlineEventArgs -> unit
Parameters
s (Object)
e (UnderlineEventArgs)


UnderlineStyle Enumeration

Keyoti RapidSpell Desktop .NET API Docs
UnderlineStyle Enumeration
API ► Keyoti.RapidSpell ► UnderlineStyle
Keyoti RapidSpell Desktop .NET
Mis-spelling underline style for RapidSpellAYT control.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public enum UnderlineStyle
public enum UnderlineStyle
Public Enumeration UnderlineStyle
Public Enumeration UnderlineStyle
public enum class UnderlineStyle
public enum class UnderlineStyle
type UnderlineStyle
type UnderlineStyle
Members
Member | Description
Single | A single line under the word.
Dashed | Dashed underline.
Double | 2 lines under the word.
Wavy | Wavy line under the word.
ThinWavy | Thin wavy line under the word, more suitable for small font sizes.
Wavy2 | Different wavy line under the word.
Wavy3 | Different wavy line under the word.
Bar | 'Bar' under the word.
ThinBar | Thin 'Bar' under the word, more suitable for small font sizes.
HighlightRectangle | Background highlight - due to Win Forms constraints, in Win Forms this is actually painted OVER the text, so change the UnderlineColor property to be semi-transparent, otherwise the text will be invisible.


UndoableOperation Class

Keyoti RapidSpell Desktop .NET API Docs
UndoableOperation Class
API ► Keyoti.RapidSpell ► UndoableOperation
Keyoti RapidSpell Desktop .NET
An operation which can be undone
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class UndoableOperation
public class UndoableOperation
Public Class UndoableOperation
Public Class UndoableOperation
public ref class UndoableOperation
public ref class UndoableOperation
type UndoableOperation =  class end
type UndoableOperation =  class end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UndoableOperation(UndoableOperation..::..Operation, UndoableStateEventArgs) | Constructor
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperationType | The operation type
 | SourceEvent | The event which indicated the operation occurred.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
UndoableOperation


UndoableOperation Constructor (operationType, sourceEvent)

Keyoti RapidSpell Desktop .NET API Docs
UndoableOperation Constructor (operationType, sourceEvent)
API ► Keyoti.RapidSpell ► UndoableOperation ► UndoableOperation(UndoableOperation..::..Operation, UndoableStateEventArgs)
Keyoti RapidSpell Desktop .NET
Constructor
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UndoableOperation(
    UndoableOperation..::..Operation operationType,
    UndoableStateEventArgs sourceEvent
)
public UndoableOperation(
    UndoableOperation..::..Operation operationType,
    UndoableStateEventArgs sourceEvent
)
Public Sub New (
    operationType As UndoableOperation..::..Operation,
    sourceEvent As UndoableStateEventArgs
)
Public Sub New (
    operationType As UndoableOperation..::..Operation,
    sourceEvent As UndoableStateEventArgs
)
public:
UndoableOperation(
    UndoableOperation..::..Operation operationType,
    UndoableStateEventArgs^ sourceEvent
)
public:
UndoableOperation(
    UndoableOperation..::..Operation operationType,
    UndoableStateEventArgs^ sourceEvent
)
new :
        operationType : UndoableOperation..::..Operation *
        sourceEvent : UndoableStateEventArgs -> UndoableOperation
new :
        operationType : UndoableOperation..::..Operation *
        sourceEvent : UndoableStateEventArgs -> UndoableOperation
Parameters
operationType (UndoableOperation..::..Operation)
sourceEvent (UndoableStateEventArgs)


OperationType Property

Keyoti RapidSpell Desktop .NET API Docs
OperationType Property
API ► Keyoti.RapidSpell ► UndoableOperation ► OperationType
Keyoti RapidSpell Desktop .NET
The operation type
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UndoableOperation..::..Operation OperationType { get; }
public UndoableOperation..::..Operation OperationType { get; }
Public ReadOnly Property OperationType As UndoableOperation..::..Operation
    Get
Public ReadOnly Property OperationType As UndoableOperation..::..Operation
    Get
public:
property UndoableOperation..::..Operation OperationType {
    UndoableOperation..::..Operation get ();
}
public:
property UndoableOperation..::..Operation OperationType {
    UndoableOperation..::..Operation get ();
}
member OperationType : UndoableOperation..::..Operation with get

member OperationType : UndoableOperation..::..Operation with get
Property Value
UndoableOperation..::..Operation


SourceEvent Property

Keyoti RapidSpell Desktop .NET API Docs
SourceEvent Property
API ► Keyoti.RapidSpell ► UndoableOperation ► SourceEvent
Keyoti RapidSpell Desktop .NET
The event which indicated the operation occurred.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UndoableStateEventArgs SourceEvent { get; }
public UndoableStateEventArgs SourceEvent { get; }
Public ReadOnly Property SourceEvent As UndoableStateEventArgs
    Get
Public ReadOnly Property SourceEvent As UndoableStateEventArgs
    Get
public:
property UndoableStateEventArgs^ SourceEvent {
    UndoableStateEventArgs^ get ();
}
public:
property UndoableStateEventArgs^ SourceEvent {
    UndoableStateEventArgs^ get ();
}
member SourceEvent : UndoableStateEventArgs with get

member SourceEvent : UndoableStateEventArgs with get
Property Value
UndoableStateEventArgs


UndoableOperation.Operation Enumeration

Keyoti RapidSpell Desktop .NET API Docs
UndoableOperation..::..Operation Enumeration
API ► Keyoti.RapidSpell ► UndoableOperation ► UndoableOperation..::..Operation
Keyoti RapidSpell Desktop .NET
Types of operation
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public enum Operation
public enum Operation
Public Enumeration Operation
Public Enumeration Operation
public enum class Operation
public enum class Operation
type Operation
type Operation
Members
Member | Description
Ignore | Ignore
IgnoreAll | Ignore all
Change | Change
ChangeAll | Change all
Add | Add


UndoableStateEventArgs Class

Keyoti RapidSpell Desktop .NET API Docs
UndoableStateEventArgs Class
API ► Keyoti.RapidSpell ► UndoableStateEventArgs
Keyoti RapidSpell Desktop .NET
Args for the events fired when words are ignored.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class UndoableStateEventArgs : EventArgs
public class UndoableStateEventArgs : EventArgs
Public Class UndoableStateEventArgs
    Inherits EventArgs
Public Class UndoableStateEventArgs
    Inherits EventArgs
public ref class UndoableStateEventArgs : public EventArgs
public ref class UndoableStateEventArgs : public EventArgs
type UndoableStateEventArgs =
    class
        inherit EventArgs
    end
type UndoableStateEventArgs =
    class
        inherit EventArgs
    end
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UndoableStateEventArgs(RapidSpellChecker..::..State) | New
 | BadWord | The word involved.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | UndoableState | The state of RapidSpellChecker
 | word | The bad word
Inheritance Hierarchy
Object
 | EventArgs
 |  | UndoableStateEventArgs
 |  |  | WordAddedEventArgs
 |  |  | WordChangedEventArgs
 |  |  | WordIgnoredEventArgs


UndoableStateEventArgs Constructor (undoableState)

Keyoti RapidSpell Desktop .NET API Docs
UndoableStateEventArgs Constructor (undoableState)
API ► Keyoti.RapidSpell ► UndoableStateEventArgs ► UndoableStateEventArgs(RapidSpellChecker..::..State)
Keyoti RapidSpell Desktop .NET
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UndoableStateEventArgs(
    RapidSpellChecker..::..State undoableState
)
public UndoableStateEventArgs(
    RapidSpellChecker..::..State undoableState
)
Public Sub New (
    undoableState As RapidSpellChecker..::..State
)
Public Sub New (
    undoableState As RapidSpellChecker..::..State
)
public:
UndoableStateEventArgs(
    RapidSpellChecker..::..State^ undoableState
)
public:
UndoableStateEventArgs(
    RapidSpellChecker..::..State^ undoableState
)
new :
        undoableState : RapidSpellChecker..::..State -> UndoableStateEventArgs
new :
        undoableState : RapidSpellChecker..::..State -> UndoableStateEventArgs
Parameters
undoableState (RapidSpellChecker..::..State)


BadWord Property

Keyoti RapidSpell Desktop .NET API Docs
BadWord Property
API ► Keyoti.RapidSpell ► UndoableStateEventArgs ► BadWord
Keyoti RapidSpell Desktop .NET
The word involved.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public BadWord BadWord { get; }
public BadWord BadWord { get; }
Public ReadOnly Property BadWord As BadWord
    Get
Public ReadOnly Property BadWord As BadWord
    Get
public:
property BadWord^ BadWord {
    BadWord^ get ();
}
public:
property BadWord^ BadWord {
    BadWord^ get ();
}
member BadWord : BadWord with get

member BadWord : BadWord with get
Property Value
BadWord


UndoableState Property

Keyoti RapidSpell Desktop .NET API Docs
UndoableState Property
API ► Keyoti.RapidSpell ► UndoableStateEventArgs ► UndoableState
Keyoti RapidSpell Desktop .NET
The state of RapidSpellChecker
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public RapidSpellChecker..::..State UndoableState { get; set; }
public RapidSpellChecker..::..State UndoableState { get; set; }
Public Property UndoableState As RapidSpellChecker..::..State
    Get
    Set
Public Property UndoableState As RapidSpellChecker..::..State
    Get
    Set
public:
property RapidSpellChecker..::..State^ UndoableState {
    RapidSpellChecker..::..State^ get ();
    void set (RapidSpellChecker..::..State^ value);
}
public:
property RapidSpellChecker..::..State^ UndoableState {
    RapidSpellChecker..::..State^ get ();
    void set (RapidSpellChecker..::..State^ value);
}
member UndoableState : RapidSpellChecker..::..State with get, set

member UndoableState : RapidSpellChecker..::..State with get, set
Property Value
RapidSpellChecker..::..State


word Field

Keyoti RapidSpell Desktop .NET API Docs
word Field
API ► Keyoti.RapidSpell ► UndoableStateEventArgs ► word
Keyoti RapidSpell Desktop .NET
The bad word
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected BadWord word
protected BadWord word
Protected word As BadWord
Protected word As BadWord
protected:
BadWord^ word
protected:
BadWord^ word
val mutable word: BadWord
val mutable word: BadWord
Field Value
BadWord


UndoEventArgs Class

Keyoti RapidSpell Desktop .NET API Docs
UndoEventArgs Class
API ► Keyoti.RapidSpell ► UndoEventArgs
Keyoti RapidSpell Desktop .NET
Undo event args
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class UndoEventArgs : EventArgs
public class UndoEventArgs : EventArgs
Public Class UndoEventArgs
    Inherits EventArgs
Public Class UndoEventArgs
    Inherits EventArgs
public ref class UndoEventArgs : public EventArgs
public ref class UndoEventArgs : public EventArgs
type UndoEventArgs =
    class
        inherit EventArgs
    end
type UndoEventArgs =
    class
        inherit EventArgs
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UndoEventArgs(UndoableOperation) | New instance
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | UndoneOperation | The operation which is undone.
Inheritance Hierarchy
Object
 | EventArgs
 |  | UndoEventArgs


UndoEventArgs Constructor (undoneOperation)

Keyoti RapidSpell Desktop .NET API Docs
UndoEventArgs Constructor (undoneOperation)
API ► Keyoti.RapidSpell ► UndoEventArgs ► UndoEventArgs(UndoableOperation)
Keyoti RapidSpell Desktop .NET
New instance
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UndoEventArgs(
    UndoableOperation undoneOperation
)
public UndoEventArgs(
    UndoableOperation undoneOperation
)
Public Sub New (
    undoneOperation As UndoableOperation
)
Public Sub New (
    undoneOperation As UndoableOperation
)
public:
UndoEventArgs(
    UndoableOperation^ undoneOperation
)
public:
UndoEventArgs(
    UndoableOperation^ undoneOperation
)
new :
        undoneOperation : UndoableOperation -> UndoEventArgs
new :
        undoneOperation : UndoableOperation -> UndoEventArgs
Parameters
undoneOperation (UndoableOperation)
The operation which is undone.


UndoneOperation Property

Keyoti RapidSpell Desktop .NET API Docs
UndoneOperation Property
API ► Keyoti.RapidSpell ► UndoEventArgs ► UndoneOperation
Keyoti RapidSpell Desktop .NET
The operation which is undone.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UndoableOperation UndoneOperation { get; }
public UndoableOperation UndoneOperation { get; }
Public ReadOnly Property UndoneOperation As UndoableOperation
    Get
Public ReadOnly Property UndoneOperation As UndoableOperation
    Get
public:
property UndoableOperation^ UndoneOperation {
    UndoableOperation^ get ();
}
public:
property UndoableOperation^ UndoneOperation {
    UndoableOperation^ get ();
}
member UndoneOperation : UndoableOperation with get

member UndoneOperation : UndoableOperation with get
Property Value
UndoableOperation


UndoEventHandler Delegate

Keyoti RapidSpell Desktop .NET API Docs
UndoEventHandler Delegate
API ► Keyoti.RapidSpell ► UndoEventHandler
Keyoti RapidSpell Desktop .NET
Event handler delegate
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void UndoEventHandler(
    Object sender,
    UndoEventArgs e
)
public delegate void UndoEventHandler(
    Object sender,
    UndoEventArgs e
)
Public Delegate Sub UndoEventHandler (
    sender As Object,
    e As UndoEventArgs
)
Public Delegate Sub UndoEventHandler (
    sender As Object,
    e As UndoEventArgs
)
public delegate void UndoEventHandler(
    Object^ sender,
    UndoEventArgs^ e
)
public delegate void UndoEventHandler(
    Object^ sender,
    UndoEventArgs^ e
)
type UndoEventHandler =
    delegate of
        sender : Object *
        e : UndoEventArgs -> unit
type UndoEventHandler =
    delegate of
        sender : Object *
        e : UndoEventArgs -> unit
Parameters
sender (Object)
e (UndoEventArgs)


UndoManager Class

Keyoti RapidSpell Desktop .NET API Docs
UndoManager Class
API ► Keyoti.RapidSpell ► UndoManager
Keyoti RapidSpell Desktop .NET
Manages the undoable operation stack.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class UndoManager
public class UndoManager
Public Class UndoManager
Public Class UndoManager
public ref class UndoManager
public ref class UndoManager
type UndoManager =  class end
type UndoManager =  class end
Members
All Members | Constructors | Methods | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UndoManager()()()() | Constructor
 | BufferAddedTo | Indicates that an operation has been added
 | BufferEmptied | Indicates there are no more operations to undo
 | Dispose()()()() | Cleans up resources
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | g_WordAdded(Object, WordAddedEventArgs) | Handles word added events
 | g_WordChanged(Object, WordChangedEventArgs) | Handles word changed events
 | g_WordIgnored(Object, WordIgnoredEventArgs) | Handles word ignored events
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Pop()()()() | Pops off the last operation from the stack
 | Reset()()()() | Resets the stack to empty.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
UndoManager


UndoManager Constructor

Keyoti RapidSpell Desktop .NET API Docs
UndoManager Constructor
API ► Keyoti.RapidSpell ► UndoManager ► UndoManager()()()()
Keyoti RapidSpell Desktop .NET
Constructor
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UndoManager()
public UndoManager()
Public Sub New
Public Sub New
public:
UndoManager()
public:
UndoManager()
new : unit -> UndoManager
new : unit -> UndoManager


BufferAddedTo Event

Keyoti RapidSpell Desktop .NET API Docs
BufferAddedTo Event
API ► Keyoti.RapidSpell ► UndoManager ► BufferAddedTo
Keyoti RapidSpell Desktop .NET
Indicates that an operation has been added
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler BufferAddedTo
public event EventHandler BufferAddedTo
Public Event BufferAddedTo As EventHandler
Public Event BufferAddedTo As EventHandler
public:
 event EventHandler^ BufferAddedTo {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
 event EventHandler^ BufferAddedTo {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member BufferAddedTo : IEvent<EventHandler,
    EventArgs>

member BufferAddedTo : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


BufferEmptied Event

Keyoti RapidSpell Desktop .NET API Docs
BufferEmptied Event
API ► Keyoti.RapidSpell ► UndoManager ► BufferEmptied
Keyoti RapidSpell Desktop .NET
Indicates there are no more operations to undo
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler BufferEmptied
public event EventHandler BufferEmptied
Public Event BufferEmptied As EventHandler
Public Event BufferEmptied As EventHandler
public:
 event EventHandler^ BufferEmptied {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
 event EventHandler^ BufferEmptied {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member BufferEmptied : IEvent<EventHandler,
    EventArgs>

member BufferEmptied : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


Dispose Method

Keyoti RapidSpell Desktop .NET API Docs
Dispose Method
API ► Keyoti.RapidSpell ► UndoManager ► Dispose()()()()
Keyoti RapidSpell Desktop .NET
Cleans up resources
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void Dispose()
public virtual void Dispose()
Public Overridable Sub Dispose
Public Overridable Sub Dispose
public:
virtual void Dispose()
public:
virtual void Dispose()
abstract Dispose : unit -> unit
override Dispose : unit -> unit
abstract Dispose : unit -> unit
override Dispose : unit -> unit


g_WordAdded Method (s, e)

Keyoti RapidSpell Desktop .NET API Docs
g_WordAdded Method (s, e)
API ► Keyoti.RapidSpell ► UndoManager ► g_WordAdded(Object, WordAddedEventArgs)
Keyoti RapidSpell Desktop .NET
Handles word added events
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void g_WordAdded(
    Object s,
    WordAddedEventArgs e
)
public void g_WordAdded(
    Object s,
    WordAddedEventArgs e
)
Public Sub g_WordAdded (
    s As Object,
    e As WordAddedEventArgs
)
Public Sub g_WordAdded (
    s As Object,
    e As WordAddedEventArgs
)
public:
void g_WordAdded(
    Object^ s,
    WordAddedEventArgs^ e
)
public:
void g_WordAdded(
    Object^ s,
    WordAddedEventArgs^ e
)
member g_WordAdded :
        s : Object *
        e : WordAddedEventArgs -> unit

member g_WordAdded :
        s : Object *
        e : WordAddedEventArgs -> unit
Parameters
s (Object)
e (WordAddedEventArgs)


g_WordChanged Method (s, e)

Keyoti RapidSpell Desktop .NET API Docs
g_WordChanged Method (s, e)
API ► Keyoti.RapidSpell ► UndoManager ► g_WordChanged(Object, WordChangedEventArgs)
Keyoti RapidSpell Desktop .NET
Handles word changed events
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void g_WordChanged(
    Object s,
    WordChangedEventArgs e
)
public void g_WordChanged(
    Object s,
    WordChangedEventArgs e
)
Public Sub g_WordChanged (
    s As Object,
    e As WordChangedEventArgs
)
Public Sub g_WordChanged (
    s As Object,
    e As WordChangedEventArgs
)
public:
void g_WordChanged(
    Object^ s,
    WordChangedEventArgs^ e
)
public:
void g_WordChanged(
    Object^ s,
    WordChangedEventArgs^ e
)
member g_WordChanged :
        s : Object *
        e : WordChangedEventArgs -> unit

member g_WordChanged :
        s : Object *
        e : WordChangedEventArgs -> unit
Parameters
s (Object)
e (WordChangedEventArgs)


g_WordIgnored Method (s, e)

Keyoti RapidSpell Desktop .NET API Docs
g_WordIgnored Method (s, e)
API ► Keyoti.RapidSpell ► UndoManager ► g_WordIgnored(Object, WordIgnoredEventArgs)
Keyoti RapidSpell Desktop .NET
Handles word ignored events
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void g_WordIgnored(
    Object s,
    WordIgnoredEventArgs e
)
public void g_WordIgnored(
    Object s,
    WordIgnoredEventArgs e
)
Public Sub g_WordIgnored (
    s As Object,
    e As WordIgnoredEventArgs
)
Public Sub g_WordIgnored (
    s As Object,
    e As WordIgnoredEventArgs
)
public:
void g_WordIgnored(
    Object^ s,
    WordIgnoredEventArgs^ e
)
public:
void g_WordIgnored(
    Object^ s,
    WordIgnoredEventArgs^ e
)
member g_WordIgnored :
        s : Object *
        e : WordIgnoredEventArgs -> unit

member g_WordIgnored :
        s : Object *
        e : WordIgnoredEventArgs -> unit
Parameters
s (Object)
e (WordIgnoredEventArgs)


Pop Method

Keyoti RapidSpell Desktop .NET API Docs
Pop Method
API ► Keyoti.RapidSpell ► UndoManager ► Pop()()()()
Keyoti RapidSpell Desktop .NET
Pops off the last operation from the stack
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UndoableOperation Pop()
public UndoableOperation Pop()
Public Function Pop As UndoableOperation
Public Function Pop As UndoableOperation
public:
UndoableOperation^ Pop()
public:
UndoableOperation^ Pop()
member Pop : unit -> UndoableOperation

member Pop : unit -> UndoableOperation
Return Value
UndoableOperation


Reset Method

Keyoti RapidSpell Desktop .NET API Docs
Reset Method
API ► Keyoti.RapidSpell ► UndoManager ► Reset()()()()
Keyoti RapidSpell Desktop .NET
Resets the stack to empty.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void Reset()
public virtual void Reset()
Public Overridable Sub Reset
Public Overridable Sub Reset
public:
virtual void Reset()
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit
abstract Reset : unit -> unit
override Reset : unit -> unit


UserDictionary Class

Keyoti RapidSpell Desktop .NET API Docs
UserDictionary Class
API ► Keyoti.RapidSpell ► UserDictionary
Keyoti RapidSpell Desktop .NET
Represents the UserDictionary
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class UserDictionary
public class UserDictionary
Public Class UserDictionary
Public Class UserDictionary
public ref class UserDictionary
public ref class UserDictionary
type UserDictionary =  class end
type UserDictionary =  class end
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserDictionary(String) | Construct a UserDictionary based on the userDictionaryFile, which does not have to exist.
 | UserDictionary()()()() | Constructs an invalid UserDictionary
 | UserDictionary(String, Int32) | Construct a UserDictionary based on the userDictionaryFile, which does not have to exist.
 | AddWord(String) | Tries to add word to this dictionary
 | dictFile | The file containing the dictionary
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | IsValid()()()() | Returns whether the dictionary file is valid.
 | ListChanged | Notifies handlers that the word list has changed.
 | Location | Where to store the user dictionary
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnListChanged(UserDictionary..::..ListChangedEventArgs) | Raises ListChanged
 | OnListChanged(Object, UserDictionary..::..ListChangedEventArgs) | Raises ListChanged
 | ReadAll(ArrayList) | Read the dictionary word list into list.
 | ReloadDictionary()()()() | Loads the dictionary into an internal collection.
 | RemoveWord(String) | Tries to remove word from this dictionary
 | SaveList(ArrayList) | Replaces the contents of the file with newList.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | UserDictionary
 |  | MultiFileUserDictionary


UserDictionary Constructor

Keyoti RapidSpell Desktop .NET API Docs
UserDictionary Constructor
API ► Keyoti.RapidSpell ► UserDictionary ► UserDictionary()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | UserDictionary(String) | Construct a UserDictionary based on the userDictionaryFile, which does not have to exist.
 | UserDictionary()()()() | Constructs an invalid UserDictionary
 | UserDictionary(String, Int32) | Construct a UserDictionary based on the userDictionaryFile, which does not have to exist.


UserDictionary Constructor

Keyoti RapidSpell Desktop .NET API Docs
UserDictionary Constructor
API ► Keyoti.RapidSpell ► UserDictionary ► UserDictionary()()()()
Keyoti RapidSpell Desktop .NET
Constructs an invalid UserDictionary
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UserDictionary()
public UserDictionary()
Public Sub New
Public Sub New
public:
UserDictionary()
public:
UserDictionary()
new : unit -> UserDictionary
new : unit -> UserDictionary


UserDictionary Constructor (userDictionaryFile)

Keyoti RapidSpell Desktop .NET API Docs
UserDictionary Constructor (userDictionaryFile)
API ► Keyoti.RapidSpell ► UserDictionary ► UserDictionary(String)
Keyoti RapidSpell Desktop .NET
Construct a UserDictionary based on the userDictionaryFile, which does not have to exist.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UserDictionary(
    string userDictionaryFile
)
public UserDictionary(
    string userDictionaryFile
)
Public Sub New (
    userDictionaryFile As String
)
Public Sub New (
    userDictionaryFile As String
)
public:
UserDictionary(
    String^ userDictionaryFile
)
public:
UserDictionary(
    String^ userDictionaryFile
)
new :
        userDictionaryFile : string -> UserDictionary
new :
        userDictionaryFile : string -> UserDictionary
Parameters
userDictionaryFile (String)
the file used for a user dictionary.
Remarks
User dictionary is limited to 5,000 words.


UserDictionary Constructor (userDictionaryFile, wordLimit)

Keyoti RapidSpell Desktop .NET API Docs
UserDictionary Constructor (userDictionaryFile, wordLimit)
API ► Keyoti.RapidSpell ► UserDictionary ► UserDictionary(String, Int32)
Keyoti RapidSpell Desktop .NET
Construct a UserDictionary based on the userDictionaryFile, which does not have to exist.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UserDictionary(
    string userDictionaryFile,
    int wordLimit
)
public UserDictionary(
    string userDictionaryFile,
    int wordLimit
)
Public Sub New (
    userDictionaryFile As String,
    wordLimit As Integer
)
Public Sub New (
    userDictionaryFile As String,
    wordLimit As Integer
)
public:
UserDictionary(
    String^ userDictionaryFile,
    int wordLimit
)
public:
UserDictionary(
    String^ userDictionaryFile,
    int wordLimit
)
new :
        userDictionaryFile : string *
        wordLimit : int -> UserDictionary
new :
        userDictionaryFile : string *
        wordLimit : int -> UserDictionary
Parameters
userDictionaryFile (String)
the file used for a user dictionary.
wordLimit (Int32)
number of words user dictionary is limited to (150,000 max). If wordLimit is <=0 it will be set to 150,000.


AddWord Method (word)

Keyoti RapidSpell Desktop .NET API Docs
AddWord Method (word)
API ► Keyoti.RapidSpell ► UserDictionary ► AddWord(String)
Keyoti RapidSpell Desktop .NET
Tries to add word to this dictionary
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool AddWord(
    string word
)
public virtual bool AddWord(
    string word
)
Public Overridable Function AddWord (
    word As String
) As Boolean
Public Overridable Function AddWord (
    word As String
) As Boolean
public:
virtual bool AddWord(
    String^ word
)
public:
virtual bool AddWord(
    String^ word
)
abstract AddWord :
        word : string -> bool
override AddWord :
        word : string -> bool
abstract AddWord :
        word : string -> bool
override AddWord :
        word : string -> bool
Parameters
word (String)
String containing the new word
Return Value
Boolean
true if added successfully, false otherwise.


dictFile Field

Keyoti RapidSpell Desktop .NET API Docs
dictFile Field
API ► Keyoti.RapidSpell ► UserDictionary ► dictFile
Keyoti RapidSpell Desktop .NET
The file containing the dictionary
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string dictFile
public string dictFile
Public dictFile As String
Public dictFile As String
public:
String^ dictFile
public:
String^ dictFile
val mutable dictFile: string
val mutable dictFile: string
Field Value
String


IsValid Method

Keyoti RapidSpell Desktop .NET API Docs
IsValid Method
API ► Keyoti.RapidSpell ► UserDictionary ► IsValid()()()()
Keyoti RapidSpell Desktop .NET
Returns whether the dictionary file is valid.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool IsValid()
public virtual bool IsValid()
Public Overridable Function IsValid As Boolean
Public Overridable Function IsValid As Boolean
public:
virtual bool IsValid()
public:
virtual bool IsValid()
abstract IsValid : unit -> bool
override IsValid : unit -> bool
abstract IsValid : unit -> bool
override IsValid : unit -> bool
Return Value
Boolean


ListChanged Event

Keyoti RapidSpell Desktop .NET API Docs
ListChanged Event
API ► Keyoti.RapidSpell ► UserDictionary ► ListChanged
Keyoti RapidSpell Desktop .NET
Notifies handlers that the word list has changed.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event UserDictionary..::..ListChangedEventHandler ListChanged
public event UserDictionary..::..ListChangedEventHandler ListChanged
Public Event ListChanged As UserDictionary..::..ListChangedEventHandler
Public Event ListChanged As UserDictionary..::..ListChangedEventHandler
public:
 event UserDictionary..::..ListChangedEventHandler^ ListChanged {
    void add (UserDictionary..::..ListChangedEventHandler^ value);
    void remove (UserDictionary..::..ListChangedEventHandler^ value);
}
public:
 event UserDictionary..::..ListChangedEventHandler^ ListChanged {
    void add (UserDictionary..::..ListChangedEventHandler^ value);
    void remove (UserDictionary..::..ListChangedEventHandler^ value);
}
member ListChanged : IEvent<UserDictionary..::..ListChangedEventHandler,
    UserDictionary..::..ListChangedEventArgs>

member ListChanged : IEvent<UserDictionary..::..ListChangedEventHandler,
    UserDictionary..::..ListChangedEventArgs>
Value
UserDictionary..::..ListChangedEventHandler


Location Property

Keyoti RapidSpell Desktop .NET API Docs
Location Property
API ► Keyoti.RapidSpell ► UserDictionary ► Location
Keyoti RapidSpell Desktop .NET
Where to store the user dictionary
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UserDictionary..::..StorageLocation Location { get; set; }
public UserDictionary..::..StorageLocation Location { get; set; }
Public Property Location As UserDictionary..::..StorageLocation
    Get
    Set
Public Property Location As UserDictionary..::..StorageLocation
    Get
    Set
public:
property UserDictionary..::..StorageLocation Location {
    UserDictionary..::..StorageLocation get ();
    void set (UserDictionary..::..StorageLocation value);
}
public:
property UserDictionary..::..StorageLocation Location {
    UserDictionary..::..StorageLocation get ();
    void set (UserDictionary..::..StorageLocation value);
}
member Location : UserDictionary..::..StorageLocation with get, set

member Location : UserDictionary..::..StorageLocation with get, set
Property Value
UserDictionary..::..StorageLocation


OnListChanged Method

Keyoti RapidSpell Desktop .NET API Docs
OnListChanged Method
API ► Keyoti.RapidSpell ► UserDictionary ► OnListChanged()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | OnListChanged(UserDictionary..::..ListChangedEventArgs) | Raises ListChanged
 | OnListChanged(Object, UserDictionary..::..ListChangedEventArgs) | Raises ListChanged


OnListChanged Method (e)

Keyoti RapidSpell Desktop .NET API Docs
OnListChanged Method (e)
API ► Keyoti.RapidSpell ► UserDictionary ► OnListChanged(UserDictionary..::..ListChangedEventArgs)
Keyoti RapidSpell Desktop .NET
Raises ListChanged
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void OnListChanged(
    UserDictionary..::..ListChangedEventArgs e
)
protected virtual void OnListChanged(
    UserDictionary..::..ListChangedEventArgs e
)
Protected Overridable Sub OnListChanged (
    e As UserDictionary..::..ListChangedEventArgs
)
Protected Overridable Sub OnListChanged (
    e As UserDictionary..::..ListChangedEventArgs
)
protected:
virtual void OnListChanged(
    UserDictionary..::..ListChangedEventArgs^ e
)
protected:
virtual void OnListChanged(
    UserDictionary..::..ListChangedEventArgs^ e
)
abstract OnListChanged :
        e : UserDictionary..::..ListChangedEventArgs -> unit
override OnListChanged :
        e : UserDictionary..::..ListChangedEventArgs -> unit
abstract OnListChanged :
        e : UserDictionary..::..ListChangedEventArgs -> unit
override OnListChanged :
        e : UserDictionary..::..ListChangedEventArgs -> unit
Parameters
e (UserDictionary..::..ListChangedEventArgs)


OnListChanged Method (source, e)

Keyoti RapidSpell Desktop .NET API Docs
OnListChanged Method (source, e)
API ► Keyoti.RapidSpell ► UserDictionary ► OnListChanged(Object, UserDictionary..::..ListChangedEventArgs)
Keyoti RapidSpell Desktop .NET
Raises ListChanged
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected void OnListChanged(
    Object source,
    UserDictionary..::..ListChangedEventArgs e
)
protected void OnListChanged(
    Object source,
    UserDictionary..::..ListChangedEventArgs e
)
Protected Sub OnListChanged (
    source As Object,
    e As UserDictionary..::..ListChangedEventArgs
)
Protected Sub OnListChanged (
    source As Object,
    e As UserDictionary..::..ListChangedEventArgs
)
protected:
void OnListChanged(
    Object^ source,
    UserDictionary..::..ListChangedEventArgs^ e
)
protected:
void OnListChanged(
    Object^ source,
    UserDictionary..::..ListChangedEventArgs^ e
)
member OnListChanged :
        source : Object *
        e : UserDictionary..::..ListChangedEventArgs -> unit

member OnListChanged :
        source : Object *
        e : UserDictionary..::..ListChangedEventArgs -> unit
Parameters
source (Object)
e (UserDictionary..::..ListChangedEventArgs)


ReadAll Method (list)

Keyoti RapidSpell Desktop .NET API Docs
ReadAll Method (list)
API ► Keyoti.RapidSpell ► UserDictionary ► ReadAll(ArrayList)
Keyoti RapidSpell Desktop .NET
Read the dictionary word list into list.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual int ReadAll(
    ArrayList list
)
public virtual int ReadAll(
    ArrayList list
)
Public Overridable Function ReadAll (
    list As ArrayList
) As Integer
Public Overridable Function ReadAll (
    list As ArrayList
) As Integer
public:
virtual int ReadAll(
    ArrayList^ list
)
public:
virtual int ReadAll(
    ArrayList^ list
)
abstract ReadAll :
        list : ArrayList -> int
override ReadAll :
        list : ArrayList -> int
abstract ReadAll :
        list : ArrayList -> int
override ReadAll :
        list : ArrayList -> int
Parameters
list (ArrayList)
the String array that the word list will be read into.
Return Value
Int32
number of words in list.


ReloadDictionary Method

Keyoti RapidSpell Desktop .NET API Docs
ReloadDictionary Method
API ► Keyoti.RapidSpell ► UserDictionary ► ReloadDictionary()()()()
Keyoti RapidSpell Desktop .NET
Loads the dictionary into an internal collection.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool ReloadDictionary()
public virtual bool ReloadDictionary()
Public Overridable Function ReloadDictionary As Boolean
Public Overridable Function ReloadDictionary As Boolean
public:
virtual bool ReloadDictionary()
public:
virtual bool ReloadDictionary()
abstract ReloadDictionary : unit -> bool
override ReloadDictionary : unit -> bool
abstract ReloadDictionary : unit -> bool
override ReloadDictionary : unit -> bool
Return Value
Boolean
Whether the dictionary was reloaded successfully.
Remarks
The user dictionary can be changed externally (eg. by a different control), and this method is called when that happens to cause the internal collection to be updated.


RemoveWord Method (word)

Keyoti RapidSpell Desktop .NET API Docs
RemoveWord Method (word)
API ► Keyoti.RapidSpell ► UserDictionary ► RemoveWord(String)
Keyoti RapidSpell Desktop .NET
Tries to remove word from this dictionary
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool RemoveWord(
    string word
)
public virtual bool RemoveWord(
    string word
)
Public Overridable Function RemoveWord (
    word As String
) As Boolean
Public Overridable Function RemoveWord (
    word As String
) As Boolean
public:
virtual bool RemoveWord(
    String^ word
)
public:
virtual bool RemoveWord(
    String^ word
)
abstract RemoveWord :
        word : string -> bool
override RemoveWord :
        word : string -> bool
abstract RemoveWord :
        word : string -> bool
override RemoveWord :
        word : string -> bool
Parameters
word (String)
String containing the new word
Return Value
Boolean
true if added successfully, false otherwise.


SaveList Method (newList)

Keyoti RapidSpell Desktop .NET API Docs
SaveList Method (newList)
API ► Keyoti.RapidSpell ► UserDictionary ► SaveList(ArrayList)
Keyoti RapidSpell Desktop .NET
Replaces the contents of the file with newList.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void SaveList(
    ArrayList newList
)
public virtual void SaveList(
    ArrayList newList
)
Public Overridable Sub SaveList (
    newList As ArrayList
)
Public Overridable Sub SaveList (
    newList As ArrayList
)
public:
virtual void SaveList(
    ArrayList^ newList
)
public:
virtual void SaveList(
    ArrayList^ newList
)
abstract SaveList :
        newList : ArrayList -> unit
override SaveList :
        newList : ArrayList -> unit
abstract SaveList :
        newList : ArrayList -> unit
override SaveList :
        newList : ArrayList -> unit
Parameters
newList (ArrayList)


UserDictionary.ListChangedEventArgs Class

Keyoti RapidSpell Desktop .NET API Docs
UserDictionary..::..ListChangedEventArgs Class
API ► Keyoti.RapidSpell ► UserDictionary ► UserDictionary..::..ListChangedEventArgs
Keyoti RapidSpell Desktop .NET
Event args for ListChanged event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class ListChangedEventArgs : EventArgs
public class ListChangedEventArgs : EventArgs
Public Class ListChangedEventArgs
    Inherits EventArgs
Public Class ListChangedEventArgs
    Inherits EventArgs
public ref class ListChangedEventArgs : public EventArgs
public ref class ListChangedEventArgs : public EventArgs
type ListChangedEventArgs =
    class
        inherit EventArgs
    end
type ListChangedEventArgs =
    class
        inherit EventArgs
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserDictionary..::..ListChangedEventArgs(UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation, String) | New
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Operation | The type of operation
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Word | The word that was added or removed, may be null for ListSave.
Inheritance Hierarchy
Object
 | EventArgs
 |  | UserDictionary..::..ListChangedEventArgs


UserDictionary.ListChangedEventArgs Constructor (op, word)

Keyoti RapidSpell Desktop .NET API Docs
UserDictionary..::..ListChangedEventArgs Constructor (op, word)
API ► Keyoti.RapidSpell ► UserDictionary..::..ListChangedEventArgs ► UserDictionary..::..ListChangedEventArgs(UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation, String)
Keyoti RapidSpell Desktop .NET
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ListChangedEventArgs(
    UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation op,
    string word
)
public ListChangedEventArgs(
    UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation op,
    string word
)
Public Sub New (
    op As UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation,
    word As String
)
Public Sub New (
    op As UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation,
    word As String
)
public:
ListChangedEventArgs(
    UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation op,
    String^ word
)
public:
ListChangedEventArgs(
    UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation op,
    String^ word
)
new :
        op : UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation *
        word : string -> ListChangedEventArgs
new :
        op : UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation *
        word : string -> ListChangedEventArgs
Parameters
op (UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation)
word (String)


Operation Property

Keyoti RapidSpell Desktop .NET API Docs
Operation Property
API ► Keyoti.RapidSpell ► UserDictionary..::..ListChangedEventArgs ► Operation
Keyoti RapidSpell Desktop .NET
The type of operation
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation Operation { get; }
public UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation Operation { get; }
Public ReadOnly Property Operation As UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation
    Get
Public ReadOnly Property Operation As UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation
    Get
public:
property UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation Operation {
    UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation get ();
}
public:
property UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation Operation {
    UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation get ();
}
member Operation : UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation with get

member Operation : UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation with get
Property Value
UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation


Word Property

Keyoti RapidSpell Desktop .NET API Docs
Word Property
API ► Keyoti.RapidSpell ► UserDictionary..::..ListChangedEventArgs ► Word
Keyoti RapidSpell Desktop .NET
The word that was added or removed, may be null for ListSave.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string Word { get; }
public string Word { get; }
Public ReadOnly Property Word As String
    Get
Public ReadOnly Property Word As String
    Get
public:
property String^ Word {
    String^ get ();
}
public:
property String^ Word {
    String^ get ();
}
member Word : string with get

member Word : string with get
Property Value
String


UserDictionary.ListChangedEventArgs.ListChangeOperation Enumeration

Keyoti RapidSpell Desktop .NET API Docs
UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation Enumeration
API ► Keyoti.RapidSpell ► UserDictionary..::..ListChangedEventArgs ► UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation
Keyoti RapidSpell Desktop .NET
Types of operation
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public enum ListChangeOperation
public enum ListChangeOperation
Public Enumeration ListChangeOperation
Public Enumeration ListChangeOperation
public enum class ListChangeOperation
public enum class ListChangeOperation
type ListChangeOperation
type ListChangeOperation
Members
Member | Description
WordAdd | Word added.
WordRemove | Word removed
ListSave | List saved
ContentReload | The content of the dictionary was completely changed


UserDictionary.ListChangedEventHandler Delegate

Keyoti RapidSpell Desktop .NET API Docs
UserDictionary..::..ListChangedEventHandler Delegate
API ► Keyoti.RapidSpell ► UserDictionary ► UserDictionary..::..ListChangedEventHandler
Keyoti RapidSpell Desktop .NET
Event handler
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void ListChangedEventHandler(
    Object s,
    UserDictionary..::..ListChangedEventArgs e
)
public delegate void ListChangedEventHandler(
    Object s,
    UserDictionary..::..ListChangedEventArgs e
)
Public Delegate Sub ListChangedEventHandler (
    s As Object,
    e As UserDictionary..::..ListChangedEventArgs
)
Public Delegate Sub ListChangedEventHandler (
    s As Object,
    e As UserDictionary..::..ListChangedEventArgs
)
public delegate void ListChangedEventHandler(
    Object^ s,
    UserDictionary..::..ListChangedEventArgs^ e
)
public delegate void ListChangedEventHandler(
    Object^ s,
    UserDictionary..::..ListChangedEventArgs^ e
)
type ListChangedEventHandler =
    delegate of
        s : Object *
        e : UserDictionary..::..ListChangedEventArgs -> unit
type ListChangedEventHandler =
    delegate of
        s : Object *
        e : UserDictionary..::..ListChangedEventArgs -> unit
Parameters
s (Object)
e (UserDictionary..::..ListChangedEventArgs)


UserDictionary.StorageLocation Enumeration

Keyoti RapidSpell Desktop .NET API Docs
UserDictionary..::..StorageLocation Enumeration
API ► Keyoti.RapidSpell ► UserDictionary ► UserDictionary..::..StorageLocation
Keyoti RapidSpell Desktop .NET
Location options for storage
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public enum StorageLocation
public enum StorageLocation
Public Enumeration StorageLocation
Public Enumeration StorageLocation
public enum class StorageLocation
public enum class StorageLocation
type StorageLocation
type StorageLocation
Members
Member | Description
File | File based
IsolatedStorage | IsolatedStorage based.


WordAddedEventArgs Class

Keyoti RapidSpell Desktop .NET API Docs
WordAddedEventArgs Class
API ► Keyoti.RapidSpell ► WordAddedEventArgs
Keyoti RapidSpell Desktop .NET
Args for the events fired when words are added to the user dictionary.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class WordAddedEventArgs : UndoableStateEventArgs
public class WordAddedEventArgs : UndoableStateEventArgs
Public Class WordAddedEventArgs
    Inherits UndoableStateEventArgs
Public Class WordAddedEventArgs
    Inherits UndoableStateEventArgs
public ref class WordAddedEventArgs : public UndoableStateEventArgs
public ref class WordAddedEventArgs : public UndoableStateEventArgs
type WordAddedEventArgs =
    class
        inherit UndoableStateEventArgs
    end
type WordAddedEventArgs =
    class
        inherit UndoableStateEventArgs
    end
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WordAddedEventArgs(BadWord, RapidSpellChecker..::..State, Object) |
 | BadWord | The word involved. (Inherited from UndoableStateEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TextBox | The current text box, if known.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | UndoableState | The state of RapidSpellChecker (Inherited from UndoableStateEventArgs.)
 | word | The bad word (Inherited from UndoableStateEventArgs.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | UndoableStateEventArgs
 |  |  | WordAddedEventArgs


WordAddedEventArgs Constructor (word, undoableState, textBox)

Keyoti RapidSpell Desktop .NET API Docs
WordAddedEventArgs Constructor (word, undoableState, textBox)
API ► Keyoti.RapidSpell ► WordAddedEventArgs ► WordAddedEventArgs(BadWord, RapidSpellChecker..::..State, Object)
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public WordAddedEventArgs(
    BadWord word,
    RapidSpellChecker..::..State undoableState,
    Object textBox
)
public WordAddedEventArgs(
    BadWord word,
    RapidSpellChecker..::..State undoableState,
    Object textBox
)
Public Sub New (
    word As BadWord,
    undoableState As RapidSpellChecker..::..State,
    textBox As Object
)
Public Sub New (
    word As BadWord,
    undoableState As RapidSpellChecker..::..State,
    textBox As Object
)
public:
WordAddedEventArgs(
    BadWord^ word,
    RapidSpellChecker..::..State^ undoableState,
    Object^ textBox
)
public:
WordAddedEventArgs(
    BadWord^ word,
    RapidSpellChecker..::..State^ undoableState,
    Object^ textBox
)
new :
        word : BadWord *
        undoableState : RapidSpellChecker..::..State *
        textBox : Object -> WordAddedEventArgs
new :
        word : BadWord *
        undoableState : RapidSpellChecker..::..State *
        textBox : Object -> WordAddedEventArgs
Parameters
word (BadWord)
undoableState (RapidSpellChecker..::..State)
textBox (Object)


TextBox Property

Keyoti RapidSpell Desktop .NET API Docs
TextBox Property
API ► Keyoti.RapidSpell ► WordAddedEventArgs ► TextBox
Keyoti RapidSpell Desktop .NET
The current text box, if known.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Object TextBox { get; }
public Object TextBox { get; }
Public ReadOnly Property TextBox As Object
    Get
Public ReadOnly Property TextBox As Object
    Get
public:
property Object^ TextBox {
    Object^ get ();
}
public:
property Object^ TextBox {
    Object^ get ();
}
member TextBox : Object with get

member TextBox : Object with get
Property Value
Object


WordAddedEventHandler Delegate

Keyoti RapidSpell Desktop .NET API Docs
WordAddedEventHandler Delegate
API ► Keyoti.RapidSpell ► WordAddedEventHandler
Keyoti RapidSpell Desktop .NET
Handler delegate
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void WordAddedEventHandler(
    Object sender,
    WordAddedEventArgs e
)
public delegate void WordAddedEventHandler(
    Object sender,
    WordAddedEventArgs e
)
Public Delegate Sub WordAddedEventHandler (
    sender As Object,
    e As WordAddedEventArgs
)
Public Delegate Sub WordAddedEventHandler (
    sender As Object,
    e As WordAddedEventArgs
)
public delegate void WordAddedEventHandler(
    Object^ sender,
    WordAddedEventArgs^ e
)
public delegate void WordAddedEventHandler(
    Object^ sender,
    WordAddedEventArgs^ e
)
type WordAddedEventHandler =
    delegate of
        sender : Object *
        e : WordAddedEventArgs -> unit
type WordAddedEventHandler =
    delegate of
        sender : Object *
        e : WordAddedEventArgs -> unit
Parameters
sender (Object)
e (WordAddedEventArgs)


WordChangedEventArgs Class

Keyoti RapidSpell Desktop .NET API Docs
WordChangedEventArgs Class
API ► Keyoti.RapidSpell ► WordChangedEventArgs
Keyoti RapidSpell Desktop .NET
Args for the events fired when words are changed.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class WordChangedEventArgs : UndoableStateEventArgs
public class WordChangedEventArgs : UndoableStateEventArgs
Public Class WordChangedEventArgs
    Inherits UndoableStateEventArgs
Public Class WordChangedEventArgs
    Inherits UndoableStateEventArgs
public ref class WordChangedEventArgs : public UndoableStateEventArgs
public ref class WordChangedEventArgs : public UndoableStateEventArgs
type WordChangedEventArgs =
    class
        inherit UndoableStateEventArgs
    end
type WordChangedEventArgs =
    class
        inherit UndoableStateEventArgs
    end
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WordChangedEventArgs(Boolean, BadWord, String, RapidSpellChecker..::..State, ArrayList, Int32, Object) |
 | All | Whether all instances of the word were changed.
 | BadWord | The word involved. (Inherited from UndoableStateEventArgs.)
 | ChangeIndices | List of ints pointing to locations in the text where other instances of the word were changed, if there were any, null/nothing otherwise
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Replacement | The replacement word.
 | TextBox | The current text box, if known.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | UndoableState | The state of RapidSpellChecker (Inherited from UndoableStateEventArgs.)
 | word | The bad word (Inherited from UndoableStateEventArgs.)
 | WrappedChangeDelta | The change to indices caused by wrapped text changes
Inheritance Hierarchy
Object
 | EventArgs
 |  | UndoableStateEventArgs
 |  |  | WordChangedEventArgs


WordChangedEventArgs Constructor (all, badWord, replacement, undoableState, changeIndices, wrappedChangeDelta, textBox)

Keyoti RapidSpell Desktop .NET API Docs
WordChangedEventArgs Constructor (all, badWord, replacement, undoableState, changeIndices, wrappedChangeDelta, textBox)
API ► Keyoti.RapidSpell ► WordChangedEventArgs ► WordChangedEventArgs(Boolean, BadWord, String, RapidSpellChecker..::..State, ArrayList, Int32, Object)
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public WordChangedEventArgs(
    bool all,
    BadWord badWord,
    string replacement,
    RapidSpellChecker..::..State undoableState,
    ArrayList changeIndices,
    int wrappedChangeDelta,
    Object textBox
)
public WordChangedEventArgs(
    bool all,
    BadWord badWord,
    string replacement,
    RapidSpellChecker..::..State undoableState,
    ArrayList changeIndices,
    int wrappedChangeDelta,
    Object textBox
)
Public Sub New (
    all As Boolean,
    badWord As BadWord,
    replacement As String,
    undoableState As RapidSpellChecker..::..State,
    changeIndices As ArrayList,
    wrappedChangeDelta As Integer,
    textBox As Object
)
Public Sub New (
    all As Boolean,
    badWord As BadWord,
    replacement As String,
    undoableState As RapidSpellChecker..::..State,
    changeIndices As ArrayList,
    wrappedChangeDelta As Integer,
    textBox As Object
)
public:
WordChangedEventArgs(
    bool all,
    BadWord^ badWord,
    String^ replacement,
    RapidSpellChecker..::..State^ undoableState,
    ArrayList^ changeIndices,
    int wrappedChangeDelta,
    Object^ textBox
)
public:
WordChangedEventArgs(
    bool all,
    BadWord^ badWord,
    String^ replacement,
    RapidSpellChecker..::..State^ undoableState,
    ArrayList^ changeIndices,
    int wrappedChangeDelta,
    Object^ textBox
)
new :
        all : bool *
        badWord : BadWord *
        replacement : string *
        undoableState : RapidSpellChecker..::..State *
        changeIndices : ArrayList *
        wrappedChangeDelta : int *
        textBox : Object -> WordChangedEventArgs
new :
        all : bool *
        badWord : BadWord *
        replacement : string *
        undoableState : RapidSpellChecker..::..State *
        changeIndices : ArrayList *
        wrappedChangeDelta : int *
        textBox : Object -> WordChangedEventArgs
Parameters
all (Boolean)
badWord (BadWord)
replacement (String)
undoableState (RapidSpellChecker..::..State)
changeIndices (ArrayList)
wrappedChangeDelta (Int32)
textBox (Object)


All Property

Keyoti RapidSpell Desktop .NET API Docs
All Property
API ► Keyoti.RapidSpell ► WordChangedEventArgs ► All
Keyoti RapidSpell Desktop .NET
Whether all instances of the word were changed.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool All { get; }
public bool All { get; }
Public ReadOnly Property All As Boolean
    Get
Public ReadOnly Property All As Boolean
    Get
public:
property bool All {
    bool get ();
}
public:
property bool All {
    bool get ();
}
member All : bool with get

member All : bool with get
Property Value
Boolean


ChangeIndices Property

Keyoti RapidSpell Desktop .NET API Docs
ChangeIndices Property
API ► Keyoti.RapidSpell ► WordChangedEventArgs ► ChangeIndices
Keyoti RapidSpell Desktop .NET
List of ints pointing to locations in the text where other instances of the word were changed, if there were any, null/nothing otherwise
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ArrayList ChangeIndices { get; }
public ArrayList ChangeIndices { get; }
Public ReadOnly Property ChangeIndices As ArrayList
    Get
Public ReadOnly Property ChangeIndices As ArrayList
    Get
public:
property ArrayList^ ChangeIndices {
    ArrayList^ get ();
}
public:
property ArrayList^ ChangeIndices {
    ArrayList^ get ();
}
member ChangeIndices : ArrayList with get

member ChangeIndices : ArrayList with get
Property Value
ArrayList


Replacement Property

Keyoti RapidSpell Desktop .NET API Docs
Replacement Property
API ► Keyoti.RapidSpell ► WordChangedEventArgs ► Replacement
Keyoti RapidSpell Desktop .NET
The replacement word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string Replacement { get; }
public string Replacement { get; }
Public ReadOnly Property Replacement As String
    Get
Public ReadOnly Property Replacement As String
    Get
public:
property String^ Replacement {
    String^ get ();
}
public:
property String^ Replacement {
    String^ get ();
}
member Replacement : string with get

member Replacement : string with get
Property Value
String


TextBox Property

Keyoti RapidSpell Desktop .NET API Docs
TextBox Property
API ► Keyoti.RapidSpell ► WordChangedEventArgs ► TextBox
Keyoti RapidSpell Desktop .NET
The current text box, if known.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Object TextBox { get; }
public Object TextBox { get; }
Public ReadOnly Property TextBox As Object
    Get
Public ReadOnly Property TextBox As Object
    Get
public:
property Object^ TextBox {
    Object^ get ();
}
public:
property Object^ TextBox {
    Object^ get ();
}
member TextBox : Object with get

member TextBox : Object with get
Property Value
Object


WrappedChangeDelta Property

Keyoti RapidSpell Desktop .NET API Docs
WrappedChangeDelta Property
API ► Keyoti.RapidSpell ► WordChangedEventArgs ► WrappedChangeDelta
Keyoti RapidSpell Desktop .NET
The change to indices caused by wrapped text changes
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int WrappedChangeDelta { get; }
public int WrappedChangeDelta { get; }
Public ReadOnly Property WrappedChangeDelta As Integer
    Get
Public ReadOnly Property WrappedChangeDelta As Integer
    Get
public:
property int WrappedChangeDelta {
    int get ();
}
public:
property int WrappedChangeDelta {
    int get ();
}
member WrappedChangeDelta : int with get

member WrappedChangeDelta : int with get
Property Value
Int32


WordChangedEventHandler Delegate

Keyoti RapidSpell Desktop .NET API Docs
WordChangedEventHandler Delegate
API ► Keyoti.RapidSpell ► WordChangedEventHandler
Keyoti RapidSpell Desktop .NET
Handler delegate
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void WordChangedEventHandler(
    Object sender,
    WordChangedEventArgs e
)
public delegate void WordChangedEventHandler(
    Object sender,
    WordChangedEventArgs e
)
Public Delegate Sub WordChangedEventHandler (
    sender As Object,
    e As WordChangedEventArgs
)
Public Delegate Sub WordChangedEventHandler (
    sender As Object,
    e As WordChangedEventArgs
)
public delegate void WordChangedEventHandler(
    Object^ sender,
    WordChangedEventArgs^ e
)
public delegate void WordChangedEventHandler(
    Object^ sender,
    WordChangedEventArgs^ e
)
type WordChangedEventHandler =
    delegate of
        sender : Object *
        e : WordChangedEventArgs -> unit
type WordChangedEventHandler =
    delegate of
        sender : Object *
        e : WordChangedEventArgs -> unit
Parameters
sender (Object)
e (WordChangedEventArgs)


WordIgnoredEventArgs Class

Keyoti RapidSpell Desktop .NET API Docs
WordIgnoredEventArgs Class
API ► Keyoti.RapidSpell ► WordIgnoredEventArgs
Keyoti RapidSpell Desktop .NET
Args for the events fired when words are ignored.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class WordIgnoredEventArgs : UndoableStateEventArgs
public class WordIgnoredEventArgs : UndoableStateEventArgs
Public Class WordIgnoredEventArgs
    Inherits UndoableStateEventArgs
Public Class WordIgnoredEventArgs
    Inherits UndoableStateEventArgs
public ref class WordIgnoredEventArgs : public UndoableStateEventArgs
public ref class WordIgnoredEventArgs : public UndoableStateEventArgs
type WordIgnoredEventArgs =
    class
        inherit UndoableStateEventArgs
    end
type WordIgnoredEventArgs =
    class
        inherit UndoableStateEventArgs
    end
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WordIgnoredEventArgs(Boolean, BadWord, Object, RapidSpellChecker..::..State) |
 | All | Whether all instances of the word were ignored.
 | BadWord | The word involved. (Inherited from UndoableStateEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TextBox | The text box object in which the operation was performed, if known.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | UndoableState | The state of RapidSpellChecker (Inherited from UndoableStateEventArgs.)
 | word | The bad word (Inherited from UndoableStateEventArgs.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | UndoableStateEventArgs
 |  |  | WordIgnoredEventArgs


WordIgnoredEventArgs Constructor (all, badWord, textBox, undoableState)

Keyoti RapidSpell Desktop .NET API Docs
WordIgnoredEventArgs Constructor (all, badWord, textBox, undoableState)
API ► Keyoti.RapidSpell ► WordIgnoredEventArgs ► WordIgnoredEventArgs(Boolean, BadWord, Object, RapidSpellChecker..::..State)
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public WordIgnoredEventArgs(
    bool all,
    BadWord badWord,
    Object textBox,
    RapidSpellChecker..::..State undoableState
)
public WordIgnoredEventArgs(
    bool all,
    BadWord badWord,
    Object textBox,
    RapidSpellChecker..::..State undoableState
)
Public Sub New (
    all As Boolean,
    badWord As BadWord,
    textBox As Object,
    undoableState As RapidSpellChecker..::..State
)
Public Sub New (
    all As Boolean,
    badWord As BadWord,
    textBox As Object,
    undoableState As RapidSpellChecker..::..State
)
public:
WordIgnoredEventArgs(
    bool all,
    BadWord^ badWord,
    Object^ textBox,
    RapidSpellChecker..::..State^ undoableState
)
public:
WordIgnoredEventArgs(
    bool all,
    BadWord^ badWord,
    Object^ textBox,
    RapidSpellChecker..::..State^ undoableState
)
new :
        all : bool *
        badWord : BadWord *
        textBox : Object *
        undoableState : RapidSpellChecker..::..State -> WordIgnoredEventArgs
new :
        all : bool *
        badWord : BadWord *
        textBox : Object *
        undoableState : RapidSpellChecker..::..State -> WordIgnoredEventArgs
Parameters
all (Boolean)
badWord (BadWord)
textBox (Object)
undoableState (RapidSpellChecker..::..State)


All Property

Keyoti RapidSpell Desktop .NET API Docs
All Property
API ► Keyoti.RapidSpell ► WordIgnoredEventArgs ► All
Keyoti RapidSpell Desktop .NET
Whether all instances of the word were ignored.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool All { get; }
public bool All { get; }
Public ReadOnly Property All As Boolean
    Get
Public ReadOnly Property All As Boolean
    Get
public:
property bool All {
    bool get ();
}
public:
property bool All {
    bool get ();
}
member All : bool with get

member All : bool with get
Property Value
Boolean


TextBox Property

Keyoti RapidSpell Desktop .NET API Docs
TextBox Property
API ► Keyoti.RapidSpell ► WordIgnoredEventArgs ► TextBox
Keyoti RapidSpell Desktop .NET
The text box object in which the operation was performed, if known.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Object TextBox { get; }
public Object TextBox { get; }
Public ReadOnly Property TextBox As Object
    Get
Public ReadOnly Property TextBox As Object
    Get
public:
property Object^ TextBox {
    Object^ get ();
}
public:
property Object^ TextBox {
    Object^ get ();
}
member TextBox : Object with get

member TextBox : Object with get
Property Value
Object
Remarks
This is null when the event originates in RapidSpellChecker


WordIgnoredEventHandler Delegate

Keyoti RapidSpell Desktop .NET API Docs
WordIgnoredEventHandler Delegate
API ► Keyoti.RapidSpell ► WordIgnoredEventHandler
Keyoti RapidSpell Desktop .NET
Handler delegate
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void WordIgnoredEventHandler(
    Object sender,
    WordIgnoredEventArgs e
)
public delegate void WordIgnoredEventHandler(
    Object sender,
    WordIgnoredEventArgs e
)
Public Delegate Sub WordIgnoredEventHandler (
    sender As Object,
    e As WordIgnoredEventArgs
)
Public Delegate Sub WordIgnoredEventHandler (
    sender As Object,
    e As WordIgnoredEventArgs
)
public delegate void WordIgnoredEventHandler(
    Object^ sender,
    WordIgnoredEventArgs^ e
)
public delegate void WordIgnoredEventHandler(
    Object^ sender,
    WordIgnoredEventArgs^ e
)
type WordIgnoredEventHandler =
    delegate of
        sender : Object *
        e : WordIgnoredEventArgs -> unit
type WordIgnoredEventHandler =
    delegate of
        sender : Object *
        e : WordIgnoredEventArgs -> unit
Parameters
sender (Object)
e (WordIgnoredEventArgs)


WordOccurrence Class

Keyoti RapidSpell Desktop .NET API Docs
WordOccurrence Class
API ► Keyoti.RapidSpell ► WordOccurrence
Keyoti RapidSpell Desktop .NET
Represents a word in the text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class WordOccurrence
public class WordOccurrence
Public Class WordOccurrence
Public Class WordOccurrence
public ref class WordOccurrence
public ref class WordOccurrence
type WordOccurrence =  class end
type WordOccurrence =  class end
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WordOccurrence(String, Int32, Int32) | Constructs a BadWord instance.
 | caretEnd | End of word
 | caretStart | Start of word
 | EndPosition | Gets the position of the end of this word in the main text.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetEndPosition()()()() | Gets the position of the end of this word in the main text.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetStartPosition()()()() | Gets the position of the start of this word in the main text.
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GetWord()()()() | Gets the String of this bad word.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | StartPosition | Gets the position of the start of this word in the main text.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Word | Gets the string of this bad word.
Inheritance Hierarchy
Object
 | WordOccurrence
 |  | BadWord


WordOccurrence Constructor (word, caretStart, caretEnd)

Keyoti RapidSpell Desktop .NET API Docs
WordOccurrence Constructor (word, caretStart, caretEnd)
API ► Keyoti.RapidSpell ► WordOccurrence ► WordOccurrence(String, Int32, Int32)
Keyoti RapidSpell Desktop .NET
Constructs a BadWord instance.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public WordOccurrence(
    string word,
    int caretStart,
    int caretEnd
)
public WordOccurrence(
    string word,
    int caretStart,
    int caretEnd
)
Public Sub New (
    word As String,
    caretStart As Integer,
    caretEnd As Integer
)
Public Sub New (
    word As String,
    caretStart As Integer,
    caretEnd As Integer
)
public:
WordOccurrence(
    String^ word,
    int caretStart,
    int caretEnd
)
public:
WordOccurrence(
    String^ word,
    int caretStart,
    int caretEnd
)
new :
        word : string *
        caretStart : int *
        caretEnd : int -> WordOccurrence
new :
        word : string *
        caretStart : int *
        caretEnd : int -> WordOccurrence
Parameters
word (String)
the word String that is misspelt
caretStart (Int32)
the position in the original text
caretEnd (Int32)
the end position in the text


caretEnd Field

Keyoti RapidSpell Desktop .NET API Docs
caretEnd Field
API ► Keyoti.RapidSpell ► WordOccurrence ► caretEnd
Keyoti RapidSpell Desktop .NET
End of word
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected int caretEnd
protected int caretEnd
Protected caretEnd As Integer
Protected caretEnd As Integer
protected:
int caretEnd
protected:
int caretEnd
val mutable caretEnd: int
val mutable caretEnd: int
Field Value
Int32


caretStart Field

Keyoti RapidSpell Desktop .NET API Docs
caretStart Field
API ► Keyoti.RapidSpell ► WordOccurrence ► caretStart
Keyoti RapidSpell Desktop .NET
Start of word
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected int caretStart
protected int caretStart
Protected caretStart As Integer
Protected caretStart As Integer
protected:
int caretStart
protected:
int caretStart
val mutable caretStart: int
val mutable caretStart: int
Field Value
Int32


EndPosition Property

Keyoti RapidSpell Desktop .NET API Docs
EndPosition Property
API ► Keyoti.RapidSpell ► WordOccurrence ► EndPosition
Keyoti RapidSpell Desktop .NET
Gets the position of the end of this word in the main text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int EndPosition { get; set; }
public int EndPosition { get; set; }
Public Property EndPosition As Integer
    Get
    Set
Public Property EndPosition As Integer
    Get
    Set
public:
property int EndPosition {
    int get ();
    void set (int value);
}
public:
property int EndPosition {
    int get ();
    void set (int value);
}
member EndPosition : int with get, set

member EndPosition : int with get, set
Property Value
Int32


GetEndPosition Method

Keyoti RapidSpell Desktop .NET API Docs
GetEndPosition Method
API ► Keyoti.RapidSpell ► WordOccurrence ► GetEndPosition()()()()
Keyoti RapidSpell Desktop .NET
Gets the position of the end of this word in the main text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int GetEndPosition()
public int GetEndPosition()
Public Function GetEndPosition As Integer
Public Function GetEndPosition As Integer
public:
int GetEndPosition()
public:
int GetEndPosition()
member GetEndPosition : unit -> int

member GetEndPosition : unit -> int
Return Value
Int32
int position in the text where this word ends


GetStartPosition Method

Keyoti RapidSpell Desktop .NET API Docs
GetStartPosition Method
API ► Keyoti.RapidSpell ► WordOccurrence ► GetStartPosition()()()()
Keyoti RapidSpell Desktop .NET
Gets the position of the start of this word in the main text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int GetStartPosition()
public int GetStartPosition()
Public Function GetStartPosition As Integer
Public Function GetStartPosition As Integer
public:
int GetStartPosition()
public:
int GetStartPosition()
member GetStartPosition : unit -> int

member GetStartPosition : unit -> int
Return Value
Int32
int position in the text where this word starts.


GetWord Method

Keyoti RapidSpell Desktop .NET API Docs
GetWord Method
API ► Keyoti.RapidSpell ► WordOccurrence ► GetWord()()()()
Keyoti RapidSpell Desktop .NET
Gets the String of this bad word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string GetWord()
public string GetWord()
Public Function GetWord As String
Public Function GetWord As String
public:
String^ GetWord()
public:
String^ GetWord()
member GetWord : unit -> string

member GetWord : unit -> string
Return Value
String
String in this BadWord


StartPosition Property

Keyoti RapidSpell Desktop .NET API Docs
StartPosition Property
API ► Keyoti.RapidSpell ► WordOccurrence ► StartPosition
Keyoti RapidSpell Desktop .NET
Gets the position of the start of this word in the main text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int StartPosition { get; set; }
public int StartPosition { get; set; }
Public Property StartPosition As Integer
    Get
    Set
Public Property StartPosition As Integer
    Get
    Set
public:
property int StartPosition {
    int get ();
    void set (int value);
}
public:
property int StartPosition {
    int get ();
    void set (int value);
}
member StartPosition : int with get, set

member StartPosition : int with get, set
Property Value
Int32


Word Property

Keyoti RapidSpell Desktop .NET API Docs
Word Property
API ► Keyoti.RapidSpell ► WordOccurrence ► Word
Keyoti RapidSpell Desktop .NET
Gets the string of this bad word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string Word { get; set; }
public string Word { get; set; }
Public Property Word As String
    Get
    Set
Public Property Word As String
    Get
    Set
public:
property String^ Word {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Word {
    String^ get ();
    void set (String^ value);
}
member Word : string with get, set

member Word : string with get, set
Property Value
String


WordRemovedEventArgs Class

Keyoti RapidSpell Desktop .NET API Docs
WordRemovedEventArgs Class
API ► Keyoti.RapidSpell ► WordRemovedEventArgs
Keyoti RapidSpell Desktop .NET
Args for the events fired when words are removed from the user dictionary.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class WordRemovedEventArgs : EventArgs
public class WordRemovedEventArgs : EventArgs
Public Class WordRemovedEventArgs
    Inherits EventArgs
Public Class WordRemovedEventArgs
    Inherits EventArgs
public ref class WordRemovedEventArgs : public EventArgs
public ref class WordRemovedEventArgs : public EventArgs
type WordRemovedEventArgs =
    class
        inherit EventArgs
    end
type WordRemovedEventArgs =
    class
        inherit EventArgs
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WordRemovedEventArgs(String) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Word | The word that was removed
Inheritance Hierarchy
Object
 | EventArgs
 |  | WordRemovedEventArgs


WordRemovedEventArgs Constructor (word)

Keyoti RapidSpell Desktop .NET API Docs
WordRemovedEventArgs Constructor (word)
API ► Keyoti.RapidSpell ► WordRemovedEventArgs ► WordRemovedEventArgs(String)
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public WordRemovedEventArgs(
    string word
)
public WordRemovedEventArgs(
    string word
)
Public Sub New (
    word As String
)
Public Sub New (
    word As String
)
public:
WordRemovedEventArgs(
    String^ word
)
public:
WordRemovedEventArgs(
    String^ word
)
new :
        word : string -> WordRemovedEventArgs
new :
        word : string -> WordRemovedEventArgs
Parameters
word (String)


Word Property

Keyoti RapidSpell Desktop .NET API Docs
Word Property
API ► Keyoti.RapidSpell ► WordRemovedEventArgs ► Word
Keyoti RapidSpell Desktop .NET
The word that was removed
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string Word { get; }
public string Word { get; }
Public ReadOnly Property Word As String
    Get
Public ReadOnly Property Word As String
    Get
public:
property String^ Word {
    String^ get ();
}
public:
property String^ Word {
    String^ get ();
}
member Word : string with get

member Word : string with get
Property Value
String


WordRemovedEventHandler Delegate

Keyoti RapidSpell Desktop .NET API Docs
WordRemovedEventHandler Delegate
API ► Keyoti.RapidSpell ► WordRemovedEventHandler
Keyoti RapidSpell Desktop .NET
Handler delegate
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void WordRemovedEventHandler(
    Object sender,
    WordRemovedEventArgs e
)
public delegate void WordRemovedEventHandler(
    Object sender,
    WordRemovedEventArgs e
)
Public Delegate Sub WordRemovedEventHandler (
    sender As Object,
    e As WordRemovedEventArgs
)
Public Delegate Sub WordRemovedEventHandler (
    sender As Object,
    e As WordRemovedEventArgs
)
public delegate void WordRemovedEventHandler(
    Object^ sender,
    WordRemovedEventArgs^ e
)
public delegate void WordRemovedEventHandler(
    Object^ sender,
    WordRemovedEventArgs^ e
)
type WordRemovedEventHandler =
    delegate of
        sender : Object *
        e : WordRemovedEventArgs -> unit
type WordRemovedEventHandler =
    delegate of
        sender : Object *
        e : WordRemovedEventArgs -> unit
Parameters
sender (Object)
e (WordRemovedEventArgs)


Keyoti.RapidSpell.Compression Namespace

Keyoti RapidSpell Desktop .NET API Docs
Keyoti.RapidSpell.Compression Namespace
API ► Keyoti.RapidSpell.Compression
Keyoti RapidSpell Desktop .NET
Types
All Types Classes Enumerations
Icon | Type | Description
 | CompressionLevel | The compression level to be used when using a DeflateStream or ZlibStream with CompressionMode.Compress.
 | CompressionMode | An enum to specify the direction of transcoding - whether to compress or decompress.
 | CompressionStrategy | Describes options for how the compression algorithm is executed. Different strategies work better on different sorts of data. The strategy parameter can affect the compression ratio and the speed of compression but not the correctness of the compresssion.
 | CRC32 | Calculates a 32bit Cyclic Redundancy Checksum (CRC) using the same polynomial used by Zip. This type is used internally by DotNetZip; it is generally not used directly by applications wishing to create, read, or manipulate zip archive files.
 | CrcCalculatorStream | A Stream that calculates a CRC32 (a checksum) on all bytes read, or on all bytes written.
 | DeflateStream | A class for compressing and decompressing streams using the Deflate algorithm.
 | FlushType | Describes how to flush the current deflate operation.
 | GZipStream | A class for compressing and decompressing GZIP streams.
 | ZlibCodec | Encoder and Decoder for ZLIB and DEFLATE (IETF RFC1950 and RFC1951).
 | ZlibConstants | A bunch of constants used in the Zlib interface.
 | ZlibException | A general purpose exception class for exceptions in the Zlib library.
 | ZlibStream | Represents a Zlib stream for compression or decompression.


CompressionLevel Enumeration

Keyoti RapidSpell Desktop .NET API Docs
CompressionLevel Enumeration
API ► Keyoti.RapidSpell.Compression ► CompressionLevel
Keyoti RapidSpell Desktop .NET
The compression level to be used when using a DeflateStream or ZlibStream with CompressionMode.Compress.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public enum CompressionLevel
public enum CompressionLevel
Public Enumeration CompressionLevel
Public Enumeration CompressionLevel
public enum class CompressionLevel
public enum class CompressionLevel
type CompressionLevel
type CompressionLevel
Members
Member | Description
None | None means that the data will be simply stored, with no change at all. If you are producing ZIPs for use on Mac OSX, be aware that archives produced with CompressionLevel.None cannot be opened with the default zip reader. Use a different CompressionLevel.
Level0 | Same as None.
BestSpeed | The fastest but least effective compression.
Level1 | A synonym for BestSpeed.
Level2 | A little slower, but better, than level 1.
Level3 | A little slower, but better, than level 2.
Level4 | A little slower, but better, than level 3.
Level5 | A little slower than level 4, but with better compression.
Default | The default compression level, with a good balance of speed and compression efficiency.
Level6 | A synonym for Default.
Level7 | Pretty good compression!
Level8 | Better compression than Level7!
BestCompression | The "best" compression, where best means greatest reduction in size of the input data stream. This is also the slowest compression.
Level9 | A synonym for BestCompression.


CompressionMode Enumeration

Keyoti RapidSpell Desktop .NET API Docs
CompressionMode Enumeration
API ► Keyoti.RapidSpell.Compression ► CompressionMode
Keyoti RapidSpell Desktop .NET
An enum to specify the direction of transcoding - whether to compress or decompress.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public enum CompressionMode
public enum CompressionMode
Public Enumeration CompressionMode
Public Enumeration CompressionMode
public enum class CompressionMode
public enum class CompressionMode
type CompressionMode
type CompressionMode
Members
Member | Description
Compress | Used to specify that the stream should compress the data.
Decompress | Used to specify that the stream should decompress the data.


CompressionStrategy Enumeration

Keyoti RapidSpell Desktop .NET API Docs
CompressionStrategy Enumeration
API ► Keyoti.RapidSpell.Compression ► CompressionStrategy
Keyoti RapidSpell Desktop .NET
Describes options for how the compression algorithm is executed. Different strategies work better on different sorts of data. The strategy parameter can affect the compression ratio and the speed of compression but not the correctness of the compresssion.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public enum CompressionStrategy
public enum CompressionStrategy
Public Enumeration CompressionStrategy
Public Enumeration CompressionStrategy
public enum class CompressionStrategy
public enum class CompressionStrategy
type CompressionStrategy
type CompressionStrategy
Members
Member | Description
Default | The default strategy is probably the best for normal data.
Filtered | The Filtered strategy is intended to be used most effectively with data produced by a filter or predictor. By this definition, filtered data consists mostly of small values with a somewhat random distribution. In this case, the compression algorithm is tuned to compress them better. The effect of Filtered is to force more Huffman coding and less string matching; it is a half-step between Default and HuffmanOnly.
HuffmanOnly | Using HuffmanOnly will force the compressor to do Huffman encoding only, with no string matching.


CRC32 Class

Keyoti RapidSpell Desktop .NET API Docs
CRC32 Class
API ► Keyoti.RapidSpell.Compression ► CRC32
Keyoti RapidSpell Desktop .NET
Calculates a 32bit Cyclic Redundancy Checksum (CRC) using the same polynomial used by Zip. This type is used internally by DotNetZip; it is generally not used directly by applications wishing to create, read, or manipulate zip archive files.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class CRC32
public class CRC32
Public Class CRC32
Public Class CRC32
public ref class CRC32
public ref class CRC32
type CRC32 =  class end
type CRC32 =  class end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CRC32()()()() |
 | Combine(Int32, Int32) | Combines the given CRC32 value with the current running total.
 | ComputeCrc32(Int32, Byte) | Get the CRC32 for the given (word,byte) combo. This is a computation defined by PKzip.
 | Crc32Result | Indicates the current CRC for all blocks slurped in.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetCrc32(Stream) | Returns the CRC32 for the specified stream.
 | GetCrc32AndCopy(Stream, Stream) | Returns the CRC32 for the specified stream, and writes the input into the output stream.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SlurpBlock(array<Byte>[]()[][], Int32, Int32) | Update the value for the running CRC32 using the given block of bytes. This is useful when using the CRC32() class in a Stream.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | TotalBytesRead | indicates the total number of bytes read on the CRC stream. This is used when writing the ZipDirEntry when compressing files.
Inheritance Hierarchy
Object
CRC32


CRC32 Constructor

Keyoti RapidSpell Desktop .NET API Docs
CRC32 Constructor
API ► Keyoti.RapidSpell.Compression ► CRC32 ► CRC32()()()()
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public CRC32()
public CRC32()
Public Sub New
Public Sub New
public:
CRC32()
public:
CRC32()
new : unit -> CRC32
new : unit -> CRC32


Combine Method (crc, length)

Keyoti RapidSpell Desktop .NET API Docs
Combine Method (crc, length)
API ► Keyoti.RapidSpell.Compression ► CRC32 ► Combine(Int32, Int32)
Keyoti RapidSpell Desktop .NET
Combines the given CRC32 value with the current running total.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void Combine(
    int crc,
    int length
)
public void Combine(
    int crc,
    int length
)
Public Sub Combine (
    crc As Integer,
    length As Integer
)
Public Sub Combine (
    crc As Integer,
    length As Integer
)
public:
void Combine(
    int crc,
    int length
)
public:
void Combine(
    int crc,
    int length
)
member Combine :
        crc : int *
        length : int -> unit

member Combine :
        crc : int *
        length : int -> unit
Parameters
crc (Int32)
the crc value to be combined with this one
length (Int32)
the length of data the CRC value was calculated on
Remarks
This is useful when using a divide-and-conquer approach to calculating a CRC. Multiple threads can each calculate a CRC32 on a segment of the data, and then combine the individual CRC32 values at the end.


ComputeCrc32 Method (W, B)

Keyoti RapidSpell Desktop .NET API Docs
ComputeCrc32 Method (W, B)
API ► Keyoti.RapidSpell.Compression ► CRC32 ► ComputeCrc32(Int32, Byte)
Keyoti RapidSpell Desktop .NET
Get the CRC32 for the given (word,byte) combo. This is a computation defined by PKzip.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int ComputeCrc32(
    int W,
    byte B
)
public int ComputeCrc32(
    int W,
    byte B
)
Public Function ComputeCrc32 (
    W As Integer,
    B As Byte
) As Integer
Public Function ComputeCrc32 (
    W As Integer,
    B As Byte
) As Integer
public:
int ComputeCrc32(
    int W,
    unsigned char B
)
public:
int ComputeCrc32(
    int W,
    unsigned char B
)
member ComputeCrc32 :
        W : int *
        B : byte -> int

member ComputeCrc32 :
        W : int *
        B : byte -> int
Parameters
W (Int32)
The word to start with.
B (Byte)
The byte to combine it with.
Return Value
Int32
The CRC-ized result.


Crc32Result Property

Keyoti RapidSpell Desktop .NET API Docs
Crc32Result Property
API ► Keyoti.RapidSpell.Compression ► CRC32 ► Crc32Result
Keyoti RapidSpell Desktop .NET
Indicates the current CRC for all blocks slurped in.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int Crc32Result { get; }
public int Crc32Result { get; }
Public ReadOnly Property Crc32Result As Integer
    Get
Public ReadOnly Property Crc32Result As Integer
    Get
public:
property int Crc32Result {
    int get ();
}
public:
property int Crc32Result {
    int get ();
}
member Crc32Result : int with get

member Crc32Result : int with get
Property Value
Int32


GetCrc32 Method (input)

Keyoti RapidSpell Desktop .NET API Docs
GetCrc32 Method (input)
API ► Keyoti.RapidSpell.Compression ► CRC32 ► GetCrc32(Stream)
Keyoti RapidSpell Desktop .NET
Returns the CRC32 for the specified stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int GetCrc32(
    Stream input
)
public int GetCrc32(
    Stream input
)
Public Function GetCrc32 (
    input As Stream
) As Integer
Public Function GetCrc32 (
    input As Stream
) As Integer
public:
int GetCrc32(
    Stream^ input
)
public:
int GetCrc32(
    Stream^ input
)
member GetCrc32 :
        input : Stream -> int

member GetCrc32 :
        input : Stream -> int
Parameters
input (Stream)
The stream over which to calculate the CRC32
Return Value
Int32
the CRC32 calculation


GetCrc32AndCopy Method (input, output)

Keyoti RapidSpell Desktop .NET API Docs
GetCrc32AndCopy Method (input, output)
API ► Keyoti.RapidSpell.Compression ► CRC32 ► GetCrc32AndCopy(Stream, Stream)
Keyoti RapidSpell Desktop .NET
Returns the CRC32 for the specified stream, and writes the input into the output stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int GetCrc32AndCopy(
    Stream input,
    Stream output
)
public int GetCrc32AndCopy(
    Stream input,
    Stream output
)
Public Function GetCrc32AndCopy (
    input As Stream,
    output As Stream
) As Integer
Public Function GetCrc32AndCopy (
    input As Stream,
    output As Stream
) As Integer
public:
int GetCrc32AndCopy(
    Stream^ input,
    Stream^ output
)
public:
int GetCrc32AndCopy(
    Stream^ input,
    Stream^ output
)
member GetCrc32AndCopy :
        input : Stream *
        output : Stream -> int

member GetCrc32AndCopy :
        input : Stream *
        output : Stream -> int
Parameters
input (Stream)
The stream over which to calculate the CRC32
output (Stream)
The stream into which to deflate the input
Return Value
Int32
the CRC32 calculation


SlurpBlock Method (block, offset, count)

Keyoti RapidSpell Desktop .NET API Docs
SlurpBlock Method (block, offset, count)
API ► Keyoti.RapidSpell.Compression ► CRC32 ► SlurpBlock(array<Byte>[]()[][], Int32, Int32)
Keyoti RapidSpell Desktop .NET
Update the value for the running CRC32 using the given block of bytes. This is useful when using the CRC32() class in a Stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void SlurpBlock(
    byte[] block,
    int offset,
    int count
)
public void SlurpBlock(
    byte[] block,
    int offset,
    int count
)
Public Sub SlurpBlock (
    block As Byte(),
    offset As Integer,
    count As Integer
)
Public Sub SlurpBlock (
    block As Byte(),
    offset As Integer,
    count As Integer
)
public:
void SlurpBlock(
    array<unsigned char>^ block,
    int offset,
    int count
)
public:
void SlurpBlock(
    array<unsigned char>^ block,
    int offset,
    int count
)
member SlurpBlock :
        block : byte[] *
        offset : int *
        count : int -> unit

member SlurpBlock :
        block : byte[] *
        offset : int *
        count : int -> unit
Parameters
block (array< Byte >[]()[][])
block of bytes to slurp
offset (Int32)
starting point in the block
count (Int32)
how many bytes within the block to slurp


TotalBytesRead Property

Keyoti RapidSpell Desktop .NET API Docs
TotalBytesRead Property
API ► Keyoti.RapidSpell.Compression ► CRC32 ► TotalBytesRead
Keyoti RapidSpell Desktop .NET
indicates the total number of bytes read on the CRC stream. This is used when writing the ZipDirEntry when compressing files.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public long TotalBytesRead { get; }
public long TotalBytesRead { get; }
Public ReadOnly Property TotalBytesRead As Long
    Get
Public ReadOnly Property TotalBytesRead As Long
    Get
public:
property long long TotalBytesRead {
    long long get ();
}
public:
property long long TotalBytesRead {
    long long get ();
}
member TotalBytesRead : int64 with get

member TotalBytesRead : int64 with get
Property Value
Int64


CrcCalculatorStream Class

Keyoti RapidSpell Desktop .NET API Docs
CrcCalculatorStream Class
API ► Keyoti.RapidSpell.Compression ► CrcCalculatorStream
Keyoti RapidSpell Desktop .NET
A Stream that calculates a CRC32 (a checksum) on all bytes read, or on all bytes written.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class CrcCalculatorStream : Stream,
    IDisposable
public class CrcCalculatorStream : Stream,
    IDisposable
Public Class CrcCalculatorStream
    Inherits Stream
    Implements IDisposable
Public Class CrcCalculatorStream
    Inherits Stream
    Implements IDisposable
public ref class CrcCalculatorStream : public Stream,
    IDisposable
public ref class CrcCalculatorStream : public Stream,
    IDisposable
type CrcCalculatorStream =
    class
        inherit Stream
        interface IDisposable
    end
type CrcCalculatorStream =
    class
        inherit Stream
        interface IDisposable
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CrcCalculatorStream(Stream) | The default constructor.
 | CrcCalculatorStream(Stream, Boolean) | The constructor allows the caller to specify how to handle the underlying stream at close.
 | CrcCalculatorStream(Stream, Int64) | A constructor allowing the specification of the length of the stream to read.
 | CrcCalculatorStream(Stream, Int64, Boolean) | A constructor allowing the specification of the length of the stream to read, as well as whether to keep the underlying stream open upon Close().
 | BeginRead(array<Byte>[]()[][], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous read operation. (Inherited from Stream.)
 | BeginWrite(array<Byte>[]()[][], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous write operation. (Inherited from Stream.)
 | CanRead | Indicates whether the stream supports reading. (Overrides Stream.CanRead.)
 | CanSeek | Indicates whether the stream supports seeking. (Overrides Stream.CanSeek.)
 | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
 | CanWrite | Indicates whether the stream supports writing. (Overrides Stream.CanWrite.)
 | Close()()()() | Closes the stream. (Overrides Stream.Close()()()().)
 | Crc | Provides the current CRC for all blocks slurped in.
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateWaitHandle()()()() | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
 | Dispose()()()() | Releases all resources used by the Stream. (Inherited from Stream.)
 | Dispose(Boolean) | Releases the unmanaged resources used by the Stream and optionally releases the managed resources. (Inherited from Stream.)
 | EndRead(IAsyncResult) | Waits for the pending asynchronous read to complete. (Inherited from Stream.)
 | EndWrite(IAsyncResult) | Ends an asynchronous write operation. (Inherited from Stream.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | Flush()()()() | Flush the stream. (Overrides Stream.Flush()()()().)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | LeaveOpen | Indicates whether the underlying stream will be left open when the CrcCalculatorStream is Closed.
 | Length | Not implemented. (Overrides Stream.Length.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Position | Not implemented. (Overrides Stream.Position.)
 | Read(array<Byte>[]()[][], Int32, Int32) | Read from the stream (Overrides Stream.Read(array<Byte>[]()[][], Int32, Int32).)
 | ReadByte()()()() | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
 | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
 | Seek(Int64, SeekOrigin) | Not implemented. (Overrides Stream.Seek(Int64, SeekOrigin).)
 | SetLength(Int64) | Not implemented. (Overrides Stream.SetLength(Int64).)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | TotalBytesSlurped | Gets the total number of bytes run through the CRC32 calculator.
 | Write(array<Byte>[]()[][], Int32, Int32) | Write to the stream. (Overrides Stream.Write(array<Byte>[]()[][], Int32, Int32).)
 | WriteByte(Byte) | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
 | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Remarks

This class can be used to verify the CRC of a ZipEntry when reading from a stream, or to calculate a CRC when writing to a stream. The stream should be used to either read, or write, but not both. If you intermix reads and writes, the results are not defined.

This class is intended primarily for use internally by the DotNetZip library.

Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Stream
 |  |  | CrcCalculatorStream


CrcCalculatorStream Constructor

Keyoti RapidSpell Desktop .NET API Docs
CrcCalculatorStream Constructor
API ► Keyoti.RapidSpell.Compression ► CrcCalculatorStream ► CrcCalculatorStream()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | CrcCalculatorStream(Stream) | The default constructor.
 | CrcCalculatorStream(Stream, Boolean) | The constructor allows the caller to specify how to handle the underlying stream at close.
 | CrcCalculatorStream(Stream, Int64) | A constructor allowing the specification of the length of the stream to read.
 | CrcCalculatorStream(Stream, Int64, Boolean) | A constructor allowing the specification of the length of the stream to read, as well as whether to keep the underlying stream open upon Close().


CrcCalculatorStream Constructor (stream)

Keyoti RapidSpell Desktop .NET API Docs
CrcCalculatorStream Constructor (stream)
API ► Keyoti.RapidSpell.Compression ► CrcCalculatorStream ► CrcCalculatorStream(Stream)
Keyoti RapidSpell Desktop .NET
The default constructor.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public CrcCalculatorStream(
    Stream stream
)
public CrcCalculatorStream(
    Stream stream
)
Public Sub New (
    stream As Stream
)
Public Sub New (
    stream As Stream
)
public:
CrcCalculatorStream(
    Stream^ stream
)
public:
CrcCalculatorStream(
    Stream^ stream
)
new :
        stream : Stream -> CrcCalculatorStream
new :
        stream : Stream -> CrcCalculatorStream
Parameters
stream (Stream)
The underlying stream
Remarks
Instances returned from this constructor will leave the underlying stream open upon Close().


CrcCalculatorStream Constructor (stream, leaveOpen)

Keyoti RapidSpell Desktop .NET API Docs
CrcCalculatorStream Constructor (stream, leaveOpen)
API ► Keyoti.RapidSpell.Compression ► CrcCalculatorStream ► CrcCalculatorStream(Stream, Boolean)
Keyoti RapidSpell Desktop .NET
The constructor allows the caller to specify how to handle the underlying stream at close.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public CrcCalculatorStream(
    Stream stream,
    bool leaveOpen
)
public CrcCalculatorStream(
    Stream stream,
    bool leaveOpen
)
Public Sub New (
    stream As Stream,
    leaveOpen As Boolean
)
Public Sub New (
    stream As Stream,
    leaveOpen As Boolean
)
public:
CrcCalculatorStream(
    Stream^ stream,
    bool leaveOpen
)
public:
CrcCalculatorStream(
    Stream^ stream,
    bool leaveOpen
)
new :
        stream : Stream *
        leaveOpen : bool -> CrcCalculatorStream
new :
        stream : Stream *
        leaveOpen : bool -> CrcCalculatorStream
Parameters
stream (Stream)
The underlying stream
leaveOpen (Boolean)
true to leave the underlying stream open upon close of the CrcCalculatorStream.; false otherwise.


CrcCalculatorStream Constructor (stream, length)

Keyoti RapidSpell Desktop .NET API Docs
CrcCalculatorStream Constructor (stream, length)
API ► Keyoti.RapidSpell.Compression ► CrcCalculatorStream ► CrcCalculatorStream(Stream, Int64)
Keyoti RapidSpell Desktop .NET
A constructor allowing the specification of the length of the stream to read.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public CrcCalculatorStream(
    Stream stream,
    long length
)
public CrcCalculatorStream(
    Stream stream,
    long length
)
Public Sub New (
    stream As Stream,
    length As Long
)
Public Sub New (
    stream As Stream,
    length As Long
)
public:
CrcCalculatorStream(
    Stream^ stream,
    long long length
)
public:
CrcCalculatorStream(
    Stream^ stream,
    long long length
)
new :
        stream : Stream *
        length : int64 -> CrcCalculatorStream
new :
        stream : Stream *
        length : int64 -> CrcCalculatorStream
Parameters
stream (Stream)
The underlying stream
length (Int64)
The length of the stream to slurp
Remarks
Instances returned from this constructor will leave the underlying stream open upon Close().


CrcCalculatorStream Constructor (stream, length, leaveOpen)

Keyoti RapidSpell Desktop .NET API Docs
CrcCalculatorStream Constructor (stream, length, leaveOpen)
API ► Keyoti.RapidSpell.Compression ► CrcCalculatorStream ► CrcCalculatorStream(Stream, Int64, Boolean)
Keyoti RapidSpell Desktop .NET
A constructor allowing the specification of the length of the stream to read, as well as whether to keep the underlying stream open upon Close().
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public CrcCalculatorStream(
    Stream stream,
    long length,
    bool leaveOpen
)
public CrcCalculatorStream(
    Stream stream,
    long length,
    bool leaveOpen
)
Public Sub New (
    stream As Stream,
    length As Long,
    leaveOpen As Boolean
)
Public Sub New (
    stream As Stream,
    length As Long,
    leaveOpen As Boolean
)
public:
CrcCalculatorStream(
    Stream^ stream,
    long long length,
    bool leaveOpen
)
public:
CrcCalculatorStream(
    Stream^ stream,
    long long length,
    bool leaveOpen
)
new :
        stream : Stream *
        length : int64 *
        leaveOpen : bool -> CrcCalculatorStream
new :
        stream : Stream *
        length : int64 *
        leaveOpen : bool -> CrcCalculatorStream
Parameters
stream (Stream)
The underlying stream
length (Int64)
The length of the stream to slurp
leaveOpen (Boolean)
true to leave the underlying stream open upon close of the CrcCalculatorStream.; false otherwise.


CanRead Property

Keyoti RapidSpell Desktop .NET API Docs
CanRead Property
API ► Keyoti.RapidSpell.Compression ► CrcCalculatorStream ► CanRead
Keyoti RapidSpell Desktop .NET
Indicates whether the stream supports reading.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override bool CanRead { get; }
public override bool CanRead { get; }
Public Overrides ReadOnly Property CanRead As Boolean
    Get
Public Overrides ReadOnly Property CanRead As Boolean
    Get
public:
virtual property bool CanRead {
    bool get () override;
}
public:
virtual property bool CanRead {
    bool get () override;
}
abstract CanRead : bool with get
override CanRead : bool with get
abstract CanRead : bool with get
override CanRead : bool with get
Property Value
Boolean


CanSeek Property

Keyoti RapidSpell Desktop .NET API Docs
CanSeek Property
API ► Keyoti.RapidSpell.Compression ► CrcCalculatorStream ► CanSeek
Keyoti RapidSpell Desktop .NET
Indicates whether the stream supports seeking.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override bool CanSeek { get; }
public override bool CanSeek { get; }
Public Overrides ReadOnly Property CanSeek As Boolean
    Get
Public Overrides ReadOnly Property CanSeek As Boolean
    Get
public:
virtual property bool CanSeek {
    bool get () override;
}
public:
virtual property bool CanSeek {
    bool get () override;
}
abstract CanSeek : bool with get
override CanSeek : bool with get
abstract CanSeek : bool with get
override CanSeek : bool with get
Property Value
Boolean


CanWrite Property

Keyoti RapidSpell Desktop .NET API Docs
CanWrite Property
API ► Keyoti.RapidSpell.Compression ► CrcCalculatorStream ► CanWrite
Keyoti RapidSpell Desktop .NET
Indicates whether the stream supports writing.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override bool CanWrite { get; }
public override bool CanWrite { get; }
Public Overrides ReadOnly Property CanWrite As Boolean
    Get
Public Overrides ReadOnly Property CanWrite As Boolean
    Get
public:
virtual property bool CanWrite {
    bool get () override;
}
public:
virtual property bool CanWrite {
    bool get () override;
}
abstract CanWrite : bool with get
override CanWrite : bool with get
abstract CanWrite : bool with get
override CanWrite : bool with get
Property Value
Boolean


Close Method

Keyoti RapidSpell Desktop .NET API Docs
Close Method
API ► Keyoti.RapidSpell.Compression ► CrcCalculatorStream ► Close()()()()
Keyoti RapidSpell Desktop .NET
Closes the stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override void Close()
public override void Close()
Public Overrides Sub Close
Public Overrides Sub Close
public:
virtual void Close() override
public:
virtual void Close() override
abstract Close : unit -> unit
override Close : unit -> unit
abstract Close : unit -> unit
override Close : unit -> unit


Crc Property

Keyoti RapidSpell Desktop .NET API Docs
Crc Property
API ► Keyoti.RapidSpell.Compression ► CrcCalculatorStream ► Crc
Keyoti RapidSpell Desktop .NET
Provides the current CRC for all blocks slurped in.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int Crc { get; }
public int Crc { get; }
Public ReadOnly Property Crc As Integer
    Get
Public ReadOnly Property Crc As Integer
    Get
public:
property int Crc {
    int get ();
}
public:
property int Crc {
    int get ();
}
member Crc : int with get

member Crc : int with get
Property Value
Int32


Flush Method

Keyoti RapidSpell Desktop .NET API Docs
Flush Method
API ► Keyoti.RapidSpell.Compression ► CrcCalculatorStream ► Flush()()()()
Keyoti RapidSpell Desktop .NET
Flush the stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override void Flush()
public override void Flush()
Public Overrides Sub Flush
Public Overrides Sub Flush
public:
virtual void Flush() override
public:
virtual void Flush() override
abstract Flush : unit -> unit
override Flush : unit -> unit
abstract Flush : unit -> unit
override Flush : unit -> unit


LeaveOpen Property

Keyoti RapidSpell Desktop .NET API Docs
LeaveOpen Property
API ► Keyoti.RapidSpell.Compression ► CrcCalculatorStream ► LeaveOpen
Keyoti RapidSpell Desktop .NET
Indicates whether the underlying stream will be left open when the CrcCalculatorStream is Closed.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool LeaveOpen { get; set; }
public bool LeaveOpen { get; set; }
Public Property LeaveOpen As Boolean
    Get
    Set
Public Property LeaveOpen As Boolean
    Get
    Set
public:
property bool LeaveOpen {
    bool get ();
    void set (bool value);
}
public:
property bool LeaveOpen {
    bool get ();
    void set (bool value);
}
member LeaveOpen : bool with get, set

member LeaveOpen : bool with get, set
Property Value
Boolean


Length Property

Keyoti RapidSpell Desktop .NET API Docs
Length Property
API ► Keyoti.RapidSpell.Compression ► CrcCalculatorStream ► Length
Keyoti RapidSpell Desktop .NET
Not implemented.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override long Length { get; }
public override long Length { get; }
Public Overrides ReadOnly Property Length As Long
    Get
Public Overrides ReadOnly Property Length As Long
    Get
public:
virtual property long long Length {
    long long get () override;
}
public:
virtual property long long Length {
    long long get () override;
}
abstract Length : int64 with get
override Length : int64 with get
abstract Length : int64 with get
override Length : int64 with get
Property Value
Int64


Position Property

Keyoti RapidSpell Desktop .NET API Docs
Position Property
API ► Keyoti.RapidSpell.Compression ► CrcCalculatorStream ► Position
Keyoti RapidSpell Desktop .NET
Not implemented.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override long Position { get; set; }
public override long Position { get; set; }
Public Overrides Property Position As Long
    Get
    Set
Public Overrides Property Position As Long
    Get
    Set
public:
virtual property long long Position {
    long long get () override;
    void set (long long value) override;
}
public:
virtual property long long Position {
    long long get () override;
    void set (long long value) override;
}
abstract Position : int64 with get, set
override Position : int64 with get, set
abstract Position : int64 with get, set
override Position : int64 with get, set
Property Value
Int64


Read Method (buffer, offset, count)

Keyoti RapidSpell Desktop .NET API Docs
Read Method (buffer, offset, count)
API ► Keyoti.RapidSpell.Compression ► CrcCalculatorStream ► Read(array<Byte>[]()[][], Int32, Int32)
Keyoti RapidSpell Desktop .NET
Read from the stream
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Function Read (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
Public Overrides Function Read (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
abstract Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
override Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
abstract Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
override Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
Parameters
buffer (array< Byte >[]()[][])
the buffer to read
offset (Int32)
the offset at which to start
count (Int32)
the number of bytes to read
Return Value
Int32
the number of bytes actually read


Seek Method (offset, origin)

Keyoti RapidSpell Desktop .NET API Docs
Seek Method (offset, origin)
API ► Keyoti.RapidSpell.Compression ► CrcCalculatorStream ► Seek(Int64, SeekOrigin)
Keyoti RapidSpell Desktop .NET
Not implemented.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override long Seek(
    long offset,
    SeekOrigin origin
)
public override long Seek(
    long offset,
    SeekOrigin origin
)
Public Overrides Function Seek (
    offset As Long,
    origin As SeekOrigin
) As Long
Public Overrides Function Seek (
    offset As Long,
    origin As SeekOrigin
) As Long
public:
virtual long long Seek(
    long long offset,
    SeekOrigin origin
) override
public:
virtual long long Seek(
    long long offset,
    SeekOrigin origin
) override
abstract Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
override Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
abstract Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
override Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
Parameters
offset (Int64)
N/A
origin (SeekOrigin)
N/A
Return Value
Int64
N/A


SetLength Method (value)

Keyoti RapidSpell Desktop .NET API Docs
SetLength Method (value)
API ► Keyoti.RapidSpell.Compression ► CrcCalculatorStream ► SetLength(Int64)
Keyoti RapidSpell Desktop .NET
Not implemented.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override void SetLength(
    long value
)
public override void SetLength(
    long value
)
Public Overrides Sub SetLength (
    value As Long
)
Public Overrides Sub SetLength (
    value As Long
)
public:
virtual void SetLength(
    long long value
) override
public:
virtual void SetLength(
    long long value
) override
abstract SetLength :
        value : int64 -> unit
override SetLength :
        value : int64 -> unit
abstract SetLength :
        value : int64 -> unit
override SetLength :
        value : int64 -> unit
Parameters
value (Int64)
N/A


TotalBytesSlurped Property

Keyoti RapidSpell Desktop .NET API Docs
TotalBytesSlurped Property
API ► Keyoti.RapidSpell.Compression ► CrcCalculatorStream ► TotalBytesSlurped
Keyoti RapidSpell Desktop .NET
Gets the total number of bytes run through the CRC32 calculator.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public long TotalBytesSlurped { get; }
public long TotalBytesSlurped { get; }
Public ReadOnly Property TotalBytesSlurped As Long
    Get
Public ReadOnly Property TotalBytesSlurped As Long
    Get
public:
property long long TotalBytesSlurped {
    long long get ();
}
public:
property long long TotalBytesSlurped {
    long long get ();
}
member TotalBytesSlurped : int64 with get

member TotalBytesSlurped : int64 with get
Property Value
Int64
Remarks
This is either the total number of bytes read, or the total number of bytes written, depending on the direction of this stream.


Write Method (buffer, offset, count)

Keyoti RapidSpell Desktop .NET API Docs
Write Method (buffer, offset, count)
API ► Keyoti.RapidSpell.Compression ► CrcCalculatorStream ► Write(array<Byte>[]()[][], Int32, Int32)
Keyoti RapidSpell Desktop .NET
Write to the stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Sub Write (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
Public Overrides Sub Write (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
public:
virtual void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
public:
virtual void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
abstract Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
override Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
abstract Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
override Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
Parameters
buffer (array< Byte >[]()[][])
the buffer from which to write
offset (Int32)
the offset at which to start writing
count (Int32)
the number of bytes to write


DeflateStream Class

Keyoti RapidSpell Desktop .NET API Docs
DeflateStream Class
API ► Keyoti.RapidSpell.Compression ► DeflateStream
Keyoti RapidSpell Desktop .NET
A class for compressing and decompressing streams using the Deflate algorithm.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class DeflateStream : Stream
public class DeflateStream : Stream
Public Class DeflateStream
    Inherits Stream
Public Class DeflateStream
    Inherits Stream
public ref class DeflateStream : public Stream
public ref class DeflateStream : public Stream
type DeflateStream =
    class
        inherit Stream
    end
type DeflateStream =
    class
        inherit Stream
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DeflateStream(Stream, CompressionMode) | Create a DeflateStream using the specified CompressionMode.
 | DeflateStream(Stream, CompressionMode, CompressionLevel) | Create a DeflateStream using the specified CompressionMode and the specified CompressionLevel.
 | DeflateStream(Stream, CompressionMode, Boolean) | Create a DeflateStream using the specified CompressionMode, and explicitly specify whether the stream should be left open after Deflation or Inflation.
 | DeflateStream(Stream, CompressionMode, CompressionLevel, Boolean) | Create a DeflateStream using the specified CompressionMode and the specified CompressionLevel, and explicitly specify whether the stream should be left open after Deflation or Inflation.
 | BeginRead(array<Byte>[]()[][], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous read operation. (Inherited from Stream.)
 | BeginWrite(array<Byte>[]()[][], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous write operation. (Inherited from Stream.)
 | BufferSize | The size of the working buffer for the compression codec.
 | CanRead | Indicates whether the stream can be read. (Overrides Stream.CanRead.)
 | CanSeek | Indicates whether the stream supports Seek operations. (Overrides Stream.CanSeek.)
 | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
 | CanWrite | Indicates whether the stream can be written. (Overrides Stream.CanWrite.)
 | Close()()()() | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. (Inherited from Stream.)
 | CompressBuffer(array<Byte>[]()[][]) | Compress a byte array into a new byte array using DEFLATE.
 | CompressString(String) | Compress a string into a byte array using DEFLATE (RFC 1951).
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateWaitHandle()()()() | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
 | Dispose(Boolean) | Dispose the stream. (Overrides Stream.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Stream. (Inherited from Stream.)
 | EndRead(IAsyncResult) | Waits for the pending asynchronous read to complete. (Inherited from Stream.)
 | EndWrite(IAsyncResult) | Ends an asynchronous write operation. (Inherited from Stream.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | Flush()()()() | Flush the stream. (Overrides Stream.Flush()()()().)
 | FlushMode | This property sets the flush behavior on the stream.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | Length | Reading this property always throws a NotImplementedException. (Overrides Stream.Length.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Position | The position of the stream pointer. (Overrides Stream.Position.)
 | Read(array<Byte>[]()[][], Int32, Int32) | Read data from the stream. (Overrides Stream.Read(array<Byte>[]()[][], Int32, Int32).)
 | ReadByte()()()() | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
 | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
 | Seek(Int64, SeekOrigin) | Calling this method always throws a NotImplementedException. (Overrides Stream.Seek(Int64, SeekOrigin).)
 | SetLength(Int64) | Calling this method always throws a NotImplementedException. (Overrides Stream.SetLength(Int64).)
 | Strategy | The ZLIB strategy to be used during compression.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | TotalIn | Returns the total number of bytes input so far.
 | TotalOut | Returns the total number of bytes output so far.
 | UncompressBuffer(array<Byte>[]()[][]) | Uncompress a DEFLATE'd byte array into a byte array.
 | UncompressString(array<Byte>[]()[][]) | Uncompress a DEFLATE'd byte array into a single string.
 | Write(array<Byte>[]()[][], Int32, Int32) | Write data to the stream. (Overrides Stream.Write(array<Byte>[]()[][], Int32, Int32).)
 | WriteByte(Byte) | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
 | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Remarks

The DeflateStream is a Decorator on a Stream. It adds DEFLATE compression or decompression to any stream.

Using this stream, applications can compress or decompress data via stream Read and Write operations. Either compresssion or decompression can occur through either reading or writing. The compression format used is DEFLATE, which is documented in IETF RFC 1951, "DEFLATE Compressed Data Format Specification version 1.3.".

This class is similar to ZlibStream, except that ZlibStream adds the RFC 1950 - ZLIB framing bytes to a compressed stream when compressing, or expects the RFC1950 framing bytes when decompressing. The DeflateStream does not.

Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Stream
 |  |  | DeflateStream
See Also
ZlibStream
GZipStream


DeflateStream Constructor

Keyoti RapidSpell Desktop .NET API Docs
DeflateStream Constructor
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► DeflateStream()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | DeflateStream(Stream, CompressionMode) | Create a DeflateStream using the specified CompressionMode.
 | DeflateStream(Stream, CompressionMode, CompressionLevel) | Create a DeflateStream using the specified CompressionMode and the specified CompressionLevel.
 | DeflateStream(Stream, CompressionMode, Boolean) | Create a DeflateStream using the specified CompressionMode, and explicitly specify whether the stream should be left open after Deflation or Inflation.
 | DeflateStream(Stream, CompressionMode, CompressionLevel, Boolean) | Create a DeflateStream using the specified CompressionMode and the specified CompressionLevel, and explicitly specify whether the stream should be left open after Deflation or Inflation.


DeflateStream Constructor (stream, mode)

Keyoti RapidSpell Desktop .NET API Docs
DeflateStream Constructor (stream, mode)
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► DeflateStream(Stream, CompressionMode)
Keyoti RapidSpell Desktop .NET
Create a DeflateStream using the specified CompressionMode.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public DeflateStream(
    Stream stream,
    CompressionMode mode
)
public DeflateStream(
    Stream stream,
    CompressionMode mode
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode
)
public:
DeflateStream(
    Stream^ stream,
    CompressionMode mode
)
public:
DeflateStream(
    Stream^ stream,
    CompressionMode mode
)
new :
        stream : Stream *
        mode : CompressionMode -> DeflateStream
new :
        stream : Stream *
        mode : CompressionMode -> DeflateStream
Parameters
stream (Stream)
The stream which will be read or written.
mode (CompressionMode)
Indicates whether the DeflateStream will compress or decompress.
Remarks
When mode is CompressionMode.Compress, the DeflateStream will use the default compression level. The "captive" stream will be closed when the DeflateStream is closed.
Examples
This example uses a DeflateStream to compress data from a file, and writes the compressed data to another file.
Copy image Copy
using (System.IO.Stream input = System.IO.File.OpenRead(fileToCompress))
{
    using (var raw = System.IO.File.Create(fileToCompress + ".deflated"))
    {
        using (Stream compressor = new DeflateStream(raw, CompressionMode.Compress))
        {
            byte[] buffer = new byte[WORKING_BUFFER_SIZE];
            int n;
            while ((n= input.Read(buffer, 0, buffer.Length)) != 0)
            {
                compressor.Write(buffer, 0, n);
            }
        }
    }
}
Visual Basic Copy image Copy
Using input As Stream = File.OpenRead(fileToCompress)
    Using raw As FileStream = File.Create(fileToCompress & ".deflated")
        Using compressor As Stream = New DeflateStream(raw, CompressionMode.Compress)
            Dim buffer As Byte() = New Byte(4096) {}
            Dim n As Integer = -1
            Do While (n <> 0)
                If (n > 0) Then
                    compressor.Write(buffer, 0, n)
                End If
                n = input.Read(buffer, 0, buffer.Length)
            Loop
        End Using
    End Using
End Using


DeflateStream Constructor (stream, mode, level)

Keyoti RapidSpell Desktop .NET API Docs
DeflateStream Constructor (stream, mode, level)
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► DeflateStream(Stream, CompressionMode, CompressionLevel)
Keyoti RapidSpell Desktop .NET
Create a DeflateStream using the specified CompressionMode and the specified CompressionLevel.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public DeflateStream(
    Stream stream,
    CompressionMode mode,
    CompressionLevel level
)
public DeflateStream(
    Stream stream,
    CompressionMode mode,
    CompressionLevel level
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode,
    level As CompressionLevel
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode,
    level As CompressionLevel
)
public:
DeflateStream(
    Stream^ stream,
    CompressionMode mode,
    CompressionLevel level
)
public:
DeflateStream(
    Stream^ stream,
    CompressionMode mode,
    CompressionLevel level
)
new :
        stream : Stream *
        mode : CompressionMode *
        level : CompressionLevel -> DeflateStream
new :
        stream : Stream *
        mode : CompressionMode *
        level : CompressionLevel -> DeflateStream
Parameters
stream (Stream)
The stream to be read or written while deflating or inflating.
mode (CompressionMode)
Indicates whether the DeflateStream will compress or decompress.
level (CompressionLevel)
A tuning knob to trade speed for effectiveness.
Remarks

When mode is CompressionMode.Decompress, the level parameter is ignored. The "captive" stream will be closed when the DeflateStream is closed.

Examples
This example uses a DeflateStream to compress data from a file, and writes the compressed data to another file.
Copy image Copy
using (System.IO.Stream input = System.IO.File.OpenRead(fileToCompress))
{
    using (var raw = System.IO.File.Create(fileToCompress + ".deflated"))
    {
        using (Stream compressor = new DeflateStream(raw,
                                                     CompressionMode.Compress,
                                                     CompressionLevel.BestCompression))
        {
            byte[] buffer = new byte[WORKING_BUFFER_SIZE];
            int n= -1;
            while (n != 0)
            {
                if (n > 0)
                    compressor.Write(buffer, 0, n);
                n= input.Read(buffer, 0, buffer.Length);
            }
        }
    }
}
Visual Basic Copy image Copy
Using input As Stream = File.OpenRead(fileToCompress)
    Using raw As FileStream = File.Create(fileToCompress & ".deflated")
        Using compressor As Stream = New DeflateStream(raw, CompressionMode.Compress, CompressionLevel.BestCompression)
            Dim buffer As Byte() = New Byte(4096) {}
            Dim n As Integer = -1
            Do While (n <> 0)
                If (n > 0) Then
                    compressor.Write(buffer, 0, n)
                End If
                n = input.Read(buffer, 0, buffer.Length)
            Loop
        End Using
    End Using
End Using


DeflateStream Constructor (stream, mode, level, leaveOpen)

Keyoti RapidSpell Desktop .NET API Docs
DeflateStream Constructor (stream, mode, level, leaveOpen)
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► DeflateStream(Stream, CompressionMode, CompressionLevel, Boolean)
Keyoti RapidSpell Desktop .NET
Create a DeflateStream using the specified CompressionMode and the specified CompressionLevel, and explicitly specify whether the stream should be left open after Deflation or Inflation.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public DeflateStream(
    Stream stream,
    CompressionMode mode,
    CompressionLevel level,
    bool leaveOpen
)
public DeflateStream(
    Stream stream,
    CompressionMode mode,
    CompressionLevel level,
    bool leaveOpen
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode,
    level As CompressionLevel,
    leaveOpen As Boolean
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode,
    level As CompressionLevel,
    leaveOpen As Boolean
)
public:
DeflateStream(
    Stream^ stream,
    CompressionMode mode,
    CompressionLevel level,
    bool leaveOpen
)
public:
DeflateStream(
    Stream^ stream,
    CompressionMode mode,
    CompressionLevel level,
    bool leaveOpen
)
new :
        stream : Stream *
        mode : CompressionMode *
        level : CompressionLevel *
        leaveOpen : bool -> DeflateStream
new :
        stream : Stream *
        mode : CompressionMode *
        level : CompressionLevel *
        leaveOpen : bool -> DeflateStream
Parameters
stream (Stream)
The stream which will be read or written.
mode (CompressionMode)
Indicates whether the DeflateStream will compress or decompress.
level (CompressionLevel)
A tuning knob to trade speed for effectiveness.
leaveOpen (Boolean)
true if the application would like the stream to remain open after inflation/deflation.
Remarks

When mode is CompressionMode.Decompress, the level parameter is ignored.

This constructor allows the application to request that the captive stream remain open after the deflation or inflation occurs. By default, after Close() is called on the stream, the captive stream is also closed. In some cases this is not desired, for example if the stream is a MemoryStream that will be re-read after compression. Specify true for the leaveOpen parameter to leave the stream open.

Examples
This example shows how to use a DeflateStream to compress data from a file, and store the compressed data into another file.
Copy image Copy
using (var output = System.IO.File.Create(fileToCompress + ".deflated"))
{
    using (System.IO.Stream input = System.IO.File.OpenRead(fileToCompress))
    {
        using (Stream compressor = new DeflateStream(output, CompressionMode.Compress, CompressionLevel.BestCompression, true))
        {
            byte[] buffer = new byte[WORKING_BUFFER_SIZE];
            int n= -1;
            while (n != 0)
            {
                if (n > 0)
                    compressor.Write(buffer, 0, n);
                n= input.Read(buffer, 0, buffer.Length);
            }
        }
    }
    // can write additional data to the output stream here
}
Visual Basic Copy image Copy
Using output As FileStream = File.Create(fileToCompress & ".deflated")
    Using input As Stream = File.OpenRead(fileToCompress)
        Using compressor As Stream = New DeflateStream(output, CompressionMode.Compress, CompressionLevel.BestCompression, True)
            Dim buffer As Byte() = New Byte(4096) {}
            Dim n As Integer = -1
            Do While (n <> 0)
                If (n > 0) Then
                    compressor.Write(buffer, 0, n)
                End If
                n = input.Read(buffer, 0, buffer.Length)
            Loop
        End Using
    End Using
    ' can write additional data to the output stream here.
End Using


DeflateStream Constructor (stream, mode, leaveOpen)

Keyoti RapidSpell Desktop .NET API Docs
DeflateStream Constructor (stream, mode, leaveOpen)
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► DeflateStream(Stream, CompressionMode, Boolean)
Keyoti RapidSpell Desktop .NET
Create a DeflateStream using the specified CompressionMode, and explicitly specify whether the stream should be left open after Deflation or Inflation.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public DeflateStream(
    Stream stream,
    CompressionMode mode,
    bool leaveOpen
)
public DeflateStream(
    Stream stream,
    CompressionMode mode,
    bool leaveOpen
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode,
    leaveOpen As Boolean
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode,
    leaveOpen As Boolean
)
public:
DeflateStream(
    Stream^ stream,
    CompressionMode mode,
    bool leaveOpen
)
public:
DeflateStream(
    Stream^ stream,
    CompressionMode mode,
    bool leaveOpen
)
new :
        stream : Stream *
        mode : CompressionMode *
        leaveOpen : bool -> DeflateStream
new :
        stream : Stream *
        mode : CompressionMode *
        leaveOpen : bool -> DeflateStream
Parameters
stream (Stream)
The stream which will be read or written. This is called the "captive" stream in other places in this documentation.
mode (CompressionMode)
Indicates whether the DeflateStream will compress or decompress.
leaveOpen (Boolean)
true if the application would like the stream to remain open after inflation/deflation.
Remarks

This constructor allows the application to request that the captive stream remain open after the deflation or inflation occurs. By default, after Close() is called on the stream, the captive stream is also closed. In some cases this is not desired, for example if the stream is a memory stream that will be re-read after compression. Specify true for the leaveOpen parameter to leave the stream open.

The DeflateStream will use the default compression level.

See the other overloads of this constructor for example code.


BufferSize Property

Keyoti RapidSpell Desktop .NET API Docs
BufferSize Property
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► BufferSize
Keyoti RapidSpell Desktop .NET
The size of the working buffer for the compression codec.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int BufferSize { get; set; }
public int BufferSize { get; set; }
Public Property BufferSize As Integer
    Get
    Set
Public Property BufferSize As Integer
    Get
    Set
public:
property int BufferSize {
    int get ();
    void set (int value);
}
public:
property int BufferSize {
    int get ();
    void set (int value);
}
member BufferSize : int with get, set

member BufferSize : int with get, set
Property Value
Int32
Remarks

The working buffer is used for all stream operations. The default size is 1024 bytes. The minimum size is 128 bytes. You may get better performance with a larger buffer. Then again, you might not. You would have to test it.

Set this before the first call to Read() or Write() on the stream. If you try to set it afterwards, it will throw.


CanRead Property

Keyoti RapidSpell Desktop .NET API Docs
CanRead Property
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► CanRead
Keyoti RapidSpell Desktop .NET
Indicates whether the stream can be read.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override bool CanRead { get; }
public override bool CanRead { get; }
Public Overrides ReadOnly Property CanRead As Boolean
    Get
Public Overrides ReadOnly Property CanRead As Boolean
    Get
public:
virtual property bool CanRead {
    bool get () override;
}
public:
virtual property bool CanRead {
    bool get () override;
}
abstract CanRead : bool with get
override CanRead : bool with get
abstract CanRead : bool with get
override CanRead : bool with get
Property Value
Boolean
Remarks
The return value depends on whether the captive stream supports reading.


CanSeek Property

Keyoti RapidSpell Desktop .NET API Docs
CanSeek Property
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► CanSeek
Keyoti RapidSpell Desktop .NET
Indicates whether the stream supports Seek operations.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override bool CanSeek { get; }
public override bool CanSeek { get; }
Public Overrides ReadOnly Property CanSeek As Boolean
    Get
Public Overrides ReadOnly Property CanSeek As Boolean
    Get
public:
virtual property bool CanSeek {
    bool get () override;
}
public:
virtual property bool CanSeek {
    bool get () override;
}
abstract CanSeek : bool with get
override CanSeek : bool with get
abstract CanSeek : bool with get
override CanSeek : bool with get
Property Value
Boolean
Remarks
Always returns false.


CanWrite Property

Keyoti RapidSpell Desktop .NET API Docs
CanWrite Property
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► CanWrite
Keyoti RapidSpell Desktop .NET
Indicates whether the stream can be written.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override bool CanWrite { get; }
public override bool CanWrite { get; }
Public Overrides ReadOnly Property CanWrite As Boolean
    Get
Public Overrides ReadOnly Property CanWrite As Boolean
    Get
public:
virtual property bool CanWrite {
    bool get () override;
}
public:
virtual property bool CanWrite {
    bool get () override;
}
abstract CanWrite : bool with get
override CanWrite : bool with get
abstract CanWrite : bool with get
override CanWrite : bool with get
Property Value
Boolean
Remarks
The return value depends on whether the captive stream supports writing.


CompressBuffer Method (b)

Keyoti RapidSpell Desktop .NET API Docs
CompressBuffer Method (b)
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► CompressBuffer(array<Byte>[]()[][])
Keyoti RapidSpell Desktop .NET
Compress a byte array into a new byte array using DEFLATE.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static byte[] CompressBuffer(
    byte[] b
)
public static byte[] CompressBuffer(
    byte[] b
)
Public Shared Function CompressBuffer (
    b As Byte()
) As Byte()
Public Shared Function CompressBuffer (
    b As Byte()
) As Byte()
public:
static array<unsigned char>^ CompressBuffer(
    array<unsigned char>^ b
)
public:
static array<unsigned char>^ CompressBuffer(
    array<unsigned char>^ b
)
static member CompressBuffer :
        b : byte[] -> byte[]

static member CompressBuffer :
        b : byte[] -> byte[]
Parameters
b (array< Byte >[]()[][])
A buffer to compress.
Return Value
array< Byte >[]()[][]
The data in compressed form
Remarks
Uncompress it with UncompressBuffer(array<Byte>[]()[][]).
See Also
DeflateStream.CompressString(string)
DeflateStream.UncompressBuffer(byte[])
GZipStream.CompressBuffer(byte[])
ZlibStream.CompressBuffer(byte[])


CompressString Method (s)

Keyoti RapidSpell Desktop .NET API Docs
CompressString Method (s)
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► CompressString(String)
Keyoti RapidSpell Desktop .NET
Compress a string into a byte array using DEFLATE (RFC 1951).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static byte[] CompressString(
    string s
)
public static byte[] CompressString(
    string s
)
Public Shared Function CompressString (
    s As String
) As Byte()
Public Shared Function CompressString (
    s As String
) As Byte()
public:
static array<unsigned char>^ CompressString(
    String^ s
)
public:
static array<unsigned char>^ CompressString(
    String^ s
)
static member CompressString :
        s : string -> byte[]

static member CompressString :
        s : string -> byte[]
Parameters
s (String)
A string to compress. The string will first be encoded using UTF8, then compressed.
Return Value
array< Byte >[]()[][]
The string in compressed form
Remarks
Uncompress it with UncompressString(array<Byte>[]()[][]).
See Also
DeflateStream.UncompressString(byte[])
DeflateStream.CompressBuffer(byte[])
GZipStream.CompressString(string)
ZlibStream.CompressString(string)


Dispose Method (disposing)

Keyoti RapidSpell Desktop .NET API Docs
Dispose Method (disposing)
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► Dispose(Boolean)
Keyoti RapidSpell Desktop .NET
Dispose the stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
Parameters
disposing (Boolean)
Remarks
This may or may not result in a Close() call on the captive stream. See the constructors that have a leaveOpen parameter for more information.


Flush Method

Keyoti RapidSpell Desktop .NET API Docs
Flush Method
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► Flush()()()()
Keyoti RapidSpell Desktop .NET
Flush the stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override void Flush()
public override void Flush()
Public Overrides Sub Flush
Public Overrides Sub Flush
public:
virtual void Flush() override
public:
virtual void Flush() override
abstract Flush : unit -> unit
override Flush : unit -> unit
abstract Flush : unit -> unit
override Flush : unit -> unit


FlushMode Property

Keyoti RapidSpell Desktop .NET API Docs
FlushMode Property
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► FlushMode
Keyoti RapidSpell Desktop .NET
This property sets the flush behavior on the stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual FlushType FlushMode { get; set; }
public virtual FlushType FlushMode { get; set; }
Public Overridable Property FlushMode As FlushType
    Get
    Set
Public Overridable Property FlushMode As FlushType
    Get
    Set
public:
virtual property FlushType FlushMode {
    FlushType get ();
    void set (FlushType value);
}
public:
virtual property FlushType FlushMode {
    FlushType get ();
    void set (FlushType value);
}
abstract FlushMode : FlushType with get, set
override FlushMode : FlushType with get, set
abstract FlushMode : FlushType with get, set
override FlushMode : FlushType with get, set
Property Value
FlushType
Remarks
See the ZLIB documentation for the meaning of the flush behavior.


Length Property

Keyoti RapidSpell Desktop .NET API Docs
Length Property
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► Length
Keyoti RapidSpell Desktop .NET
Reading this property always throws a NotImplementedException.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override long Length { get; }
public override long Length { get; }
Public Overrides ReadOnly Property Length As Long
    Get
Public Overrides ReadOnly Property Length As Long
    Get
public:
virtual property long long Length {
    long long get () override;
}
public:
virtual property long long Length {
    long long get () override;
}
abstract Length : int64 with get
override Length : int64 with get
abstract Length : int64 with get
override Length : int64 with get
Property Value
Int64


Position Property

Keyoti RapidSpell Desktop .NET API Docs
Position Property
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► Position
Keyoti RapidSpell Desktop .NET
The position of the stream pointer.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override long Position { get; set; }
public override long Position { get; set; }
Public Overrides Property Position As Long
    Get
    Set
Public Overrides Property Position As Long
    Get
    Set
public:
virtual property long long Position {
    long long get () override;
    void set (long long value) override;
}
public:
virtual property long long Position {
    long long get () override;
    void set (long long value) override;
}
abstract Position : int64 with get, set
override Position : int64 with get, set
abstract Position : int64 with get, set
override Position : int64 with get, set
Property Value
Int64
Remarks
Setting this property always throws a NotImplementedException. Reading will return the total bytes written out, if used in writing, or the total bytes read in, if used in reading. The count may refer to compressed bytes or uncompressed bytes, depending on how you've used the stream.


Read Method (buffer, offset, count)

Keyoti RapidSpell Desktop .NET API Docs
Read Method (buffer, offset, count)
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► Read(array<Byte>[]()[][], Int32, Int32)
Keyoti RapidSpell Desktop .NET
Read data from the stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Function Read (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
Public Overrides Function Read (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
abstract Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
override Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
abstract Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
override Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
Parameters
buffer (array< Byte >[]()[][])
The buffer into which the read data should be placed.
offset (Int32)
the offset within that data array to put the first byte read.
count (Int32)
the number of bytes to read.
Return Value
Int32
the number of bytes actually read
Remarks

If you wish to use the DeflateStream to compress data while reading, you can create a DeflateStream with CompressionMode.Compress, providing an uncompressed data stream. Then call Read() on that DeflateStream, and the data read will be compressed as you read. If you wish to use the DeflateStream to decompress data while reading, you can create a DeflateStream with CompressionMode.Decompress, providing a readable compressed data stream. Then call Read() on that DeflateStream, and the data read will be decompressed as you read.

A DeflateStream can be used for Read() or Write(), but not both.


Seek Method (offset, origin)

Keyoti RapidSpell Desktop .NET API Docs
Seek Method (offset, origin)
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► Seek(Int64, SeekOrigin)
Keyoti RapidSpell Desktop .NET
Calling this method always throws a NotImplementedException.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override long Seek(
    long offset,
    SeekOrigin origin
)
public override long Seek(
    long offset,
    SeekOrigin origin
)
Public Overrides Function Seek (
    offset As Long,
    origin As SeekOrigin
) As Long
Public Overrides Function Seek (
    offset As Long,
    origin As SeekOrigin
) As Long
public:
virtual long long Seek(
    long long offset,
    SeekOrigin origin
) override
public:
virtual long long Seek(
    long long offset,
    SeekOrigin origin
) override
abstract Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
override Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
abstract Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
override Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
Parameters
offset (Int64)
this is irrelevant, since it will always throw!
origin (SeekOrigin)
this is irrelevant, since it will always throw!
Return Value
Int64
irrelevant!


SetLength Method (value)

Keyoti RapidSpell Desktop .NET API Docs
SetLength Method (value)
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► SetLength(Int64)
Keyoti RapidSpell Desktop .NET
Calling this method always throws a NotImplementedException.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override void SetLength(
    long value
)
public override void SetLength(
    long value
)
Public Overrides Sub SetLength (
    value As Long
)
Public Overrides Sub SetLength (
    value As Long
)
public:
virtual void SetLength(
    long long value
) override
public:
virtual void SetLength(
    long long value
) override
abstract SetLength :
        value : int64 -> unit
override SetLength :
        value : int64 -> unit
abstract SetLength :
        value : int64 -> unit
override SetLength :
        value : int64 -> unit
Parameters
value (Int64)
this is irrelevant, since it will always throw!


Strategy Property

Keyoti RapidSpell Desktop .NET API Docs
Strategy Property
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► Strategy
Keyoti RapidSpell Desktop .NET
The ZLIB strategy to be used during compression.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public CompressionStrategy Strategy { get; set; }
public CompressionStrategy Strategy { get; set; }
Public Property Strategy As CompressionStrategy
    Get
    Set
Public Property Strategy As CompressionStrategy
    Get
    Set
public:
property CompressionStrategy Strategy {
    CompressionStrategy get ();
    void set (CompressionStrategy value);
}
public:
property CompressionStrategy Strategy {
    CompressionStrategy get ();
    void set (CompressionStrategy value);
}
member Strategy : CompressionStrategy with get, set

member Strategy : CompressionStrategy with get, set
Property Value
CompressionStrategy
Remarks
By tweaking this parameter, you may be able to optimize the compression for data with particular characteristics.


TotalIn Property

Keyoti RapidSpell Desktop .NET API Docs
TotalIn Property
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► TotalIn
Keyoti RapidSpell Desktop .NET
Returns the total number of bytes input so far.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual long TotalIn { get; }
public virtual long TotalIn { get; }
Public Overridable ReadOnly Property TotalIn As Long
    Get
Public Overridable ReadOnly Property TotalIn As Long
    Get
public:
virtual property long long TotalIn {
    long long get ();
}
public:
virtual property long long TotalIn {
    long long get ();
}
abstract TotalIn : int64 with get
override TotalIn : int64 with get
abstract TotalIn : int64 with get
override TotalIn : int64 with get
Property Value
Int64


TotalOut Property

Keyoti RapidSpell Desktop .NET API Docs
TotalOut Property
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► TotalOut
Keyoti RapidSpell Desktop .NET
Returns the total number of bytes output so far.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual long TotalOut { get; }
public virtual long TotalOut { get; }
Public Overridable ReadOnly Property TotalOut As Long
    Get
Public Overridable ReadOnly Property TotalOut As Long
    Get
public:
virtual property long long TotalOut {
    long long get ();
}
public:
virtual property long long TotalOut {
    long long get ();
}
abstract TotalOut : int64 with get
override TotalOut : int64 with get
abstract TotalOut : int64 with get
override TotalOut : int64 with get
Property Value
Int64


UncompressBuffer Method (compressed)

Keyoti RapidSpell Desktop .NET API Docs
UncompressBuffer Method (compressed)
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► UncompressBuffer(array<Byte>[]()[][])
Keyoti RapidSpell Desktop .NET
Uncompress a DEFLATE'd byte array into a byte array.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static byte[] UncompressBuffer(
    byte[] compressed
)
public static byte[] UncompressBuffer(
    byte[] compressed
)
Public Shared Function UncompressBuffer (
    compressed As Byte()
) As Byte()
Public Shared Function UncompressBuffer (
    compressed As Byte()
) As Byte()
public:
static array<unsigned char>^ UncompressBuffer(
    array<unsigned char>^ compressed
)
public:
static array<unsigned char>^ UncompressBuffer(
    array<unsigned char>^ compressed
)
static member UncompressBuffer :
        compressed : byte[] -> byte[]

static member UncompressBuffer :
        compressed : byte[] -> byte[]
Parameters
compressed (array< Byte >[]()[][])
A buffer containing data that has been compressed with DEFLATE.
Return Value
array< Byte >[]()[][]
The data in uncompressed form
See Also
DeflateStream.CompressBuffer(byte[])
DeflateStream.UncompressString(byte[])
GZipStream.UncompressBuffer(byte[])
ZlibStream.UncompressBuffer(byte[])


UncompressString Method (compressed)

Keyoti RapidSpell Desktop .NET API Docs
UncompressString Method (compressed)
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► UncompressString(array<Byte>[]()[][])
Keyoti RapidSpell Desktop .NET
Uncompress a DEFLATE'd byte array into a single string.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static string UncompressString(
    byte[] compressed
)
public static string UncompressString(
    byte[] compressed
)
Public Shared Function UncompressString (
    compressed As Byte()
) As String
Public Shared Function UncompressString (
    compressed As Byte()
) As String
public:
static String^ UncompressString(
    array<unsigned char>^ compressed
)
public:
static String^ UncompressString(
    array<unsigned char>^ compressed
)
static member UncompressString :
        compressed : byte[] -> string

static member UncompressString :
        compressed : byte[] -> string
Parameters
compressed (array< Byte >[]()[][])
A buffer containing DEFLATE-compressed data.
Return Value
String
The uncompressed string
See Also
DeflateStream.CompressString(String)
DeflateStream.UncompressBuffer(byte[])
GZipStream.UncompressString(byte[])
ZlibStream.UncompressString(byte[])


Write Method (buffer, offset, count)

Keyoti RapidSpell Desktop .NET API Docs
Write Method (buffer, offset, count)
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► Write(array<Byte>[]()[][], Int32, Int32)
Keyoti RapidSpell Desktop .NET
Write data to the stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Sub Write (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
Public Overrides Sub Write (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
public:
virtual void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
public:
virtual void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
abstract Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
override Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
abstract Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
override Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
Parameters
buffer (array< Byte >[]()[][])
The buffer holding data to write to the stream.
offset (Int32)
the offset within that data array to find the first byte to write.
count (Int32)
the number of bytes to write.
Remarks

If you wish to use the DeflateStream to compress data while writing, you can create a DeflateStream with CompressionMode.Compress, and a writable output stream. Then call Write() on that DeflateStream, providing uncompressed data as input. The data sent to the output stream will be the compressed form of the data written. If you wish to use the DeflateStream to decompress data while writing, you can create a DeflateStream with CompressionMode.Decompress, and a writable output stream. Then call Write() on that stream, providing previously compressed data. The data sent to the output stream will be the decompressed form of the data written.

A DeflateStream can be used for Read() or Write(), but not both.


FlushType Enumeration

Keyoti RapidSpell Desktop .NET API Docs
FlushType Enumeration
API ► Keyoti.RapidSpell.Compression ► FlushType
Keyoti RapidSpell Desktop .NET
Describes how to flush the current deflate operation.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public enum FlushType
public enum FlushType
Public Enumeration FlushType
Public Enumeration FlushType
public enum class FlushType
public enum class FlushType
type FlushType
type FlushType
Members
Member | Description
None | No flush at all.
Partial | Closes the current block, but doesn't flush it to the output. Used internally only in hypothetical scenarios. This was supposed to be removed by Zlib, but it is still in use in some edge cases.
Sync | Use this during compression to specify that all pending output should be flushed to the output buffer and the output should be aligned on a byte boundary. You might use this in a streaming communication scenario, so that the decompressor can get all input data available so far. When using this with a ZlibCodec, AvailableBytesIn will be zero after the call if enough output space has been provided before the call. Flushing will degrade compression and so it should be used only when necessary.
Full | Use this during compression to specify that all output should be flushed, as with FlushType.Sync, but also, the compression state should be reset so that decompression can restart from this point if previous compressed data has been damaged or if random access is desired. Using FlushType.Full too often can significantly degrade the compression.
Finish | Signals the end of the compression/decompression stream.
Remarks
The different FlushType values are useful when using a Deflate in a streaming application.


GZipStream Class

Keyoti RapidSpell Desktop .NET API Docs
GZipStream Class
API ► Keyoti.RapidSpell.Compression ► GZipStream
Keyoti RapidSpell Desktop .NET
A class for compressing and decompressing GZIP streams.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class GZipStream : Stream
public class GZipStream : Stream
Public Class GZipStream
    Inherits Stream
Public Class GZipStream
    Inherits Stream
public ref class GZipStream : public Stream
public ref class GZipStream : public Stream
type GZipStream =
    class
        inherit Stream
    end
type GZipStream =
    class
        inherit Stream
    end
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GZipStream(Stream, CompressionMode) | Create a GZipStream using the specified CompressionMode.
 | GZipStream(Stream, CompressionMode, CompressionLevel) | Create a GZipStream using the specified CompressionMode and the specified CompressionLevel.
 | GZipStream(Stream, CompressionMode, Boolean) | Create a GZipStream using the specified CompressionMode, and explicitly specify whether the stream should be left open after Deflation or Inflation.
 | GZipStream(Stream, CompressionMode, CompressionLevel, Boolean) | Create a GZipStream using the specified CompressionMode and the specified CompressionLevel, and explicitly specify whether the stream should be left open after Deflation or Inflation.
 | BeginRead(array<Byte>[]()[][], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous read operation. (Inherited from Stream.)
 | BeginWrite(array<Byte>[]()[][], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous write operation. (Inherited from Stream.)
 | BufferSize | The size of the working buffer for the compression codec.
 | CanRead | Indicates whether the stream can be read. (Overrides Stream.CanRead.)
 | CanSeek | Indicates whether the stream supports Seek operations. (Overrides Stream.CanSeek.)
 | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
 | CanWrite | Indicates whether the stream can be written. (Overrides Stream.CanWrite.)
 | Close()()()() | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. (Inherited from Stream.)
 | Comment | The comment on the GZIP stream.
 | CompressBuffer(array<Byte>[]()[][]) | Compress a byte array into a new byte array using GZip.
 | CompressString(String) | Compress a string into a byte array using GZip.
 | Crc32 | The CRC on the GZIP stream.
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateWaitHandle()()()() | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
 | Dispose(Boolean) | Dispose the stream. (Overrides Stream.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Stream. (Inherited from Stream.)
 | EndRead(IAsyncResult) | Waits for the pending asynchronous read to complete. (Inherited from Stream.)
 | EndWrite(IAsyncResult) | Ends an asynchronous write operation. (Inherited from Stream.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FileName | The FileName for the GZIP stream.
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | Flush()()()() | Flush the stream. (Overrides Stream.Flush()()()().)
 | FlushMode | This property sets the flush behavior on the stream.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | LastModified | The last modified time for the GZIP stream.
 | Length | Reading this property always throws a NotImplementedException. (Overrides Stream.Length.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Position | The position of the stream pointer. (Overrides Stream.Position.)
 | Read(array<Byte>[]()[][], Int32, Int32) | Read and decompress data from the source stream. (Overrides Stream.Read(array<Byte>[]()[][], Int32, Int32).)
 | ReadByte()()()() | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
 | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
 | Seek(Int64, SeekOrigin) | Calling this method always throws a NotImplementedException. (Overrides Stream.Seek(Int64, SeekOrigin).)
 | SetLength(Int64) | Calling this method always throws a NotImplementedException. (Overrides Stream.SetLength(Int64).)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | TotalIn | Returns the total number of bytes input so far.
 | TotalOut | Returns the total number of bytes output so far.
 | UncompressBuffer(array<Byte>[]()[][]) | Uncompress a GZip'ed byte array into a byte array.
 | UncompressString(array<Byte>[]()[][]) | Uncompress a GZip'ed byte array into a single string.
 | Write(array<Byte>[]()[][], Int32, Int32) | Write data to the stream. (Overrides Stream.Write(array<Byte>[]()[][], Int32, Int32).)
 | WriteByte(Byte) | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
 | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Remarks

The GZipStream is a Decorator on a Stream. It adds GZIP compression or decompression to any stream.

Like the System.IO.Compression.GZipStream in the .NET Base Class Library, the Keyoti.RapidSpell.Compression.GZipStream can compress while writing, or decompress while reading, but not vice versa. The compression method used is GZIP, which is documented in IETF RFC 1952, "GZIP file format specification version 4.3".

A GZipStream can be used to decompress data (through Read()) or to compress data (through Write()), but not both.

If you wish to use the GZipStream to compress data, you must wrap it around a write-able stream. As you call Write() on the GZipStream, the data will be compressed into the GZIP format. If you want to decompress data, you must wrap the GZipStream around a readable stream that contains an IETF RFC 1952-compliant stream. The data will be decompressed as you call Read() on the GZipStream.

Though the GZIP format allows data from multiple files to be concatenated together, this stream handles only a single segment of GZIP format, typically representing a single file.

This class is similar to ZlibStream and DeflateStream. ZlibStream handles RFC1950-compliant streams. DeflateStream handles RFC1951-compliant streams. This class handles RFC1952-compliant streams.

Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Stream
 |  |  | GZipStream
See Also
DeflateStream
ZlibStream


GZipStream Constructor

Keyoti RapidSpell Desktop .NET API Docs
GZipStream Constructor
API ► Keyoti.RapidSpell.Compression ► GZipStream ► GZipStream()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | GZipStream(Stream, CompressionMode) | Create a GZipStream using the specified CompressionMode.
 | GZipStream(Stream, CompressionMode, CompressionLevel) | Create a GZipStream using the specified CompressionMode and the specified CompressionLevel.
 | GZipStream(Stream, CompressionMode, Boolean) | Create a GZipStream using the specified CompressionMode, and explicitly specify whether the stream should be left open after Deflation or Inflation.
 | GZipStream(Stream, CompressionMode, CompressionLevel, Boolean) | Create a GZipStream using the specified CompressionMode and the specified CompressionLevel, and explicitly specify whether the stream should be left open after Deflation or Inflation.


GZipStream Constructor (stream, mode)

Keyoti RapidSpell Desktop .NET API Docs
GZipStream Constructor (stream, mode)
API ► Keyoti.RapidSpell.Compression ► GZipStream ► GZipStream(Stream, CompressionMode)
Keyoti RapidSpell Desktop .NET
Create a GZipStream using the specified CompressionMode.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public GZipStream(
    Stream stream,
    CompressionMode mode
)
public GZipStream(
    Stream stream,
    CompressionMode mode
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode
)
public:
GZipStream(
    Stream^ stream,
    CompressionMode mode
)
public:
GZipStream(
    Stream^ stream,
    CompressionMode mode
)
new :
        stream : Stream *
        mode : CompressionMode -> GZipStream
new :
        stream : Stream *
        mode : CompressionMode -> GZipStream
Parameters
stream (Stream)
The stream which will be read or written.
mode (CompressionMode)
Indicates whether the GZipStream will compress or decompress.
Remarks

When mode is CompressionMode.Compress, the GZipStream will use the default compression level.

As noted in the class documentation, the CompressionMode (Compress or Decompress) also establishes the "direction" of the stream. A GZipStream with CompressionMode.Compress works only through Write(). A GZipStream with CompressionMode.Decompress works only through Read().

Examples
This example shows how to use a GZipStream to compress data.
Copy image Copy
using (System.IO.Stream input = System.IO.File.OpenRead(fileToCompress))
{
    using (var raw = System.IO.File.Create(outputFile))
    {
        using (Stream compressor = new GZipStream(raw, CompressionMode.Compress))
        {
            byte[] buffer = new byte[WORKING_BUFFER_SIZE];
            int n;
            while ((n= input.Read(buffer, 0, buffer.Length)) != 0)
            {
                compressor.Write(buffer, 0, n);
            }
        }
    }
}
Visual Basic Copy image Copy
Dim outputFile As String = (fileToCompress & ".compressed")
Using input As Stream = File.OpenRead(fileToCompress)
    Using raw As FileStream = File.Create(outputFile)
    Using compressor As Stream = New GZipStream(raw, CompressionMode.Compress)
        Dim buffer As Byte() = New Byte(4096) {}
        Dim n As Integer = -1
        Do While (n <> 0)
            If (n > 0) Then
                compressor.Write(buffer, 0, n)
            End If
            n = input.Read(buffer, 0, buffer.Length)
        Loop
    End Using
    End Using
End Using
Examples
This example shows how to use a GZipStream to uncompress a file.
Copy image Copy
private void GunZipFile(string filename)
{
    if (!filename.EndsWith(".gz))
        throw new ArgumentException("filename");
    var DecompressedFile = filename.Substring(0,filename.Length-3);
    byte[] working = new byte[WORKING_BUFFER_SIZE];
    int n= 1;
    using (System.IO.Stream input = System.IO.File.OpenRead(filename))
    {
        using (Stream decompressor= new Keyoti.RapidSpell.Compression.GZipStream(input, CompressionMode.Decompress, true))
        {
            using (var output = System.IO.File.Create(DecompressedFile))
            {
                while (n !=0)
                {
                    n= decompressor.Read(working, 0, working.Length);
                    if (n > 0)
                    {
                        output.Write(working, 0, n);
                    }
                }
            }
        }
    }
}
Visual Basic Copy image Copy
Private Sub GunZipFile(ByVal filename as String)
    If Not (filename.EndsWith(".gz)) Then
        Throw New ArgumentException("filename")
    End If
    Dim DecompressedFile as String = filename.Substring(0,filename.Length-3)
    Dim working(WORKING_BUFFER_SIZE) as Byte
    Dim n As Integer = 1
    Using input As Stream = File.OpenRead(filename)
        Using decompressor As Stream = new Keyoti.RapidSpell.Compression.GZipStream(input, CompressionMode.Decompress, True)
            Using output As Stream = File.Create(UncompressedFile)
                Do
                    n= decompressor.Read(working, 0, working.Length)
                    If n > 0 Then
                        output.Write(working, 0, n)
                    End IF
                Loop While (n  > 0)
            End Using
        End Using
    End Using
End Sub


GZipStream Constructor (stream, mode, level)

Keyoti RapidSpell Desktop .NET API Docs
GZipStream Constructor (stream, mode, level)
API ► Keyoti.RapidSpell.Compression ► GZipStream ► GZipStream(Stream, CompressionMode, CompressionLevel)
Keyoti RapidSpell Desktop .NET
Create a GZipStream using the specified CompressionMode and the specified CompressionLevel.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public GZipStream(
    Stream stream,
    CompressionMode mode,
    CompressionLevel level
)
public GZipStream(
    Stream stream,
    CompressionMode mode,
    CompressionLevel level
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode,
    level As CompressionLevel
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode,
    level As CompressionLevel
)
public:
GZipStream(
    Stream^ stream,
    CompressionMode mode,
    CompressionLevel level
)
public:
GZipStream(
    Stream^ stream,
    CompressionMode mode,
    CompressionLevel level
)
new :
        stream : Stream *
        mode : CompressionMode *
        level : CompressionLevel -> GZipStream
new :
        stream : Stream *
        mode : CompressionMode *
        level : CompressionLevel -> GZipStream
Parameters
stream (Stream)
The stream to be read or written while deflating or inflating.
mode (CompressionMode)
Indicates whether the GZipStream will compress or decompress.
level (CompressionLevel)
A tuning knob to trade speed for effectiveness.
Remarks

The CompressionMode (Compress or Decompress) also establishes the "direction" of the stream. A GZipStream with CompressionMode.Compress works only through Write(). A GZipStream with CompressionMode.Decompress works only through Read().

Examples
This example shows how to use a GZipStream to compress a file into a .gz file.
Copy image Copy
using (System.IO.Stream input = System.IO.File.OpenRead(fileToCompress))
{
    using (var raw = System.IO.File.Create(fileToCompress + ".gz"))
    {
        using (Stream compressor = new GZipStream(raw,
                                                  CompressionMode.Compress,
                                                  CompressionLevel.BestCompression))
        {
            byte[] buffer = new byte[WORKING_BUFFER_SIZE];
            int n;
            while ((n= input.Read(buffer, 0, buffer.Length)) != 0)
            {
                compressor.Write(buffer, 0, n);
            }
        }
    }
}
Visual Basic Copy image Copy
Using input As Stream = File.OpenRead(fileToCompress)
    Using raw As FileStream = File.Create(fileToCompress & ".gz")
        Using compressor As Stream = New GZipStream(raw, CompressionMode.Compress, CompressionLevel.BestCompression)
            Dim buffer As Byte() = New Byte(4096) {}
            Dim n As Integer = -1
            Do While (n <> 0)
                If (n > 0) Then
                    compressor.Write(buffer, 0, n)
                End If
                n = input.Read(buffer, 0, buffer.Length)
            Loop
        End Using
    End Using
End Using


GZipStream Constructor (stream, mode, level, leaveOpen)

Keyoti RapidSpell Desktop .NET API Docs
GZipStream Constructor (stream, mode, level, leaveOpen)
API ► Keyoti.RapidSpell.Compression ► GZipStream ► GZipStream(Stream, CompressionMode, CompressionLevel, Boolean)
Keyoti RapidSpell Desktop .NET
Create a GZipStream using the specified CompressionMode and the specified CompressionLevel, and explicitly specify whether the stream should be left open after Deflation or Inflation.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public GZipStream(
    Stream stream,
    CompressionMode mode,
    CompressionLevel level,
    bool leaveOpen
)
public GZipStream(
    Stream stream,
    CompressionMode mode,
    CompressionLevel level,
    bool leaveOpen
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode,
    level As CompressionLevel,
    leaveOpen As Boolean
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode,
    level As CompressionLevel,
    leaveOpen As Boolean
)
public:
GZipStream(
    Stream^ stream,
    CompressionMode mode,
    CompressionLevel level,
    bool leaveOpen
)
public:
GZipStream(
    Stream^ stream,
    CompressionMode mode,
    CompressionLevel level,
    bool leaveOpen
)
new :
        stream : Stream *
        mode : CompressionMode *
        level : CompressionLevel *
        leaveOpen : bool -> GZipStream
new :
        stream : Stream *
        mode : CompressionMode *
        level : CompressionLevel *
        leaveOpen : bool -> GZipStream
Parameters
stream (Stream)
The stream which will be read or written.
mode (CompressionMode)
Indicates whether the GZipStream will compress or decompress.
level (CompressionLevel)
A tuning knob to trade speed for effectiveness.
leaveOpen (Boolean)
true if the application would like the stream to remain open after inflation/deflation.
Remarks

This constructor allows the application to request that the captive stream remain open after the deflation or inflation occurs. By default, after Close() is called on the stream, the captive stream is also closed. In some cases this is not desired, for example if the stream is a memory stream that will be re-read after compressed data has been written to it. Specify true for the leaveOpen parameter to leave the stream open.

As noted in the class documentation, the CompressionMode (Compress or Decompress) also establishes the "direction" of the stream. A GZipStream with CompressionMode.Compress works only through Write(). A GZipStream with CompressionMode.Decompress works only through Read().

Examples
This example shows how to use a GZipStream to compress data.
Copy image Copy
using (System.IO.Stream input = System.IO.File.OpenRead(fileToCompress))
{
    using (var raw = System.IO.File.Create(outputFile))
    {
        using (Stream compressor = new GZipStream(raw, CompressionMode.Compress, CompressionLevel.BestCompression, true))
        {
            byte[] buffer = new byte[WORKING_BUFFER_SIZE];
            int n;
            while ((n= input.Read(buffer, 0, buffer.Length)) != 0)
            {
                compressor.Write(buffer, 0, n);
            }
        }
    }
}
Visual Basic Copy image Copy
Dim outputFile As String = (fileToCompress & ".compressed")
Using input As Stream = File.OpenRead(fileToCompress)
    Using raw As FileStream = File.Create(outputFile)
    Using compressor As Stream = New GZipStream(raw, CompressionMode.Compress, CompressionLevel.BestCompression, True)
        Dim buffer As Byte() = New Byte(4096) {}
        Dim n As Integer = -1
        Do While (n <> 0)
            If (n > 0) Then
                compressor.Write(buffer, 0, n)
            End If
            n = input.Read(buffer, 0, buffer.Length)
        Loop
    End Using
    End Using
End Using


GZipStream Constructor (stream, mode, leaveOpen)

Keyoti RapidSpell Desktop .NET API Docs
GZipStream Constructor (stream, mode, leaveOpen)
API ► Keyoti.RapidSpell.Compression ► GZipStream ► GZipStream(Stream, CompressionMode, Boolean)
Keyoti RapidSpell Desktop .NET
Create a GZipStream using the specified CompressionMode, and explicitly specify whether the stream should be left open after Deflation or Inflation.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public GZipStream(
    Stream stream,
    CompressionMode mode,
    bool leaveOpen
)
public GZipStream(
    Stream stream,
    CompressionMode mode,
    bool leaveOpen
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode,
    leaveOpen As Boolean
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode,
    leaveOpen As Boolean
)
public:
GZipStream(
    Stream^ stream,
    CompressionMode mode,
    bool leaveOpen
)
public:
GZipStream(
    Stream^ stream,
    CompressionMode mode,
    bool leaveOpen
)
new :
        stream : Stream *
        mode : CompressionMode *
        leaveOpen : bool -> GZipStream
new :
        stream : Stream *
        mode : CompressionMode *
        leaveOpen : bool -> GZipStream
Parameters
stream (Stream)
The stream which will be read or written. This is called the "captive" stream in other places in this documentation.
mode (CompressionMode)
Indicates whether the GZipStream will compress or decompress.
leaveOpen (Boolean)
true if the application would like the base stream to remain open after inflation/deflation.
Remarks

This constructor allows the application to request that the captive stream remain open after the deflation or inflation occurs. By default, after Close() is called on the stream, the captive stream is also closed. In some cases this is not desired, for example if the stream is a memory stream that will be re-read after compressed data has been written to it. Specify true for the leaveOpen parameter to leave the stream open.

The CompressionMode (Compress or Decompress) also establishes the "direction" of the stream. A GZipStream with CompressionMode.Compress works only through Write(). A GZipStream with CompressionMode.Decompress works only through Read().

The GZipStream will use the default compression level. If you want to specify the compression level, see GZipStream(Stream, CompressionMode, CompressionLevel, Boolean).

See the other overloads of this constructor for example code.


BufferSize Property

Keyoti RapidSpell Desktop .NET API Docs
BufferSize Property
API ► Keyoti.RapidSpell.Compression ► GZipStream ► BufferSize
Keyoti RapidSpell Desktop .NET
The size of the working buffer for the compression codec.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int BufferSize { get; set; }
public int BufferSize { get; set; }
Public Property BufferSize As Integer
    Get
    Set
Public Property BufferSize As Integer
    Get
    Set
public:
property int BufferSize {
    int get ();
    void set (int value);
}
public:
property int BufferSize {
    int get ();
    void set (int value);
}
member BufferSize : int with get, set

member BufferSize : int with get, set
Property Value
Int32
Remarks

The working buffer is used for all stream operations. The default size is 1024 bytes. The minimum size is 128 bytes. You may get better performance with a larger buffer. Then again, you might not. You would have to test it.

Set this before the first call to Read() or Write() on the stream. If you try to set it afterwards, it will throw.


CanRead Property

Keyoti RapidSpell Desktop .NET API Docs
CanRead Property
API ► Keyoti.RapidSpell.Compression ► GZipStream ► CanRead
Keyoti RapidSpell Desktop .NET
Indicates whether the stream can be read.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override bool CanRead { get; }
public override bool CanRead { get; }
Public Overrides ReadOnly Property CanRead As Boolean
    Get
Public Overrides ReadOnly Property CanRead As Boolean
    Get
public:
virtual property bool CanRead {
    bool get () override;
}
public:
virtual property bool CanRead {
    bool get () override;
}
abstract CanRead : bool with get
override CanRead : bool with get
abstract CanRead : bool with get
override CanRead : bool with get
Property Value
Boolean
Remarks
The return value depends on whether the captive stream supports reading.


CanSeek Property

Keyoti RapidSpell Desktop .NET API Docs
CanSeek Property
API ► Keyoti.RapidSpell.Compression ► GZipStream ► CanSeek
Keyoti RapidSpell Desktop .NET
Indicates whether the stream supports Seek operations.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override bool CanSeek { get; }
public override bool CanSeek { get; }
Public Overrides ReadOnly Property CanSeek As Boolean
    Get
Public Overrides ReadOnly Property CanSeek As Boolean
    Get
public:
virtual property bool CanSeek {
    bool get () override;
}
public:
virtual property bool CanSeek {
    bool get () override;
}
abstract CanSeek : bool with get
override CanSeek : bool with get
abstract CanSeek : bool with get
override CanSeek : bool with get
Property Value
Boolean
Remarks
Always returns false.


CanWrite Property

Keyoti RapidSpell Desktop .NET API Docs
CanWrite Property
API ► Keyoti.RapidSpell.Compression ► GZipStream ► CanWrite
Keyoti RapidSpell Desktop .NET
Indicates whether the stream can be written.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override bool CanWrite { get; }
public override bool CanWrite { get; }
Public Overrides ReadOnly Property CanWrite As Boolean
    Get
Public Overrides ReadOnly Property CanWrite As Boolean
    Get
public:
virtual property bool CanWrite {
    bool get () override;
}
public:
virtual property bool CanWrite {
    bool get () override;
}
abstract CanWrite : bool with get
override CanWrite : bool with get
abstract CanWrite : bool with get
override CanWrite : bool with get
Property Value
Boolean
Remarks
The return value depends on whether the captive stream supports writing.


Comment Property

Keyoti RapidSpell Desktop .NET API Docs
Comment Property
API ► Keyoti.RapidSpell.Compression ► GZipStream ► Comment
Keyoti RapidSpell Desktop .NET
The comment on the GZIP stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string Comment { get; set; }
public string Comment { get; set; }
Public Property Comment As String
    Get
    Set
Public Property Comment As String
    Get
    Set
public:
property String^ Comment {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Comment {
    String^ get ();
    void set (String^ value);
}
member Comment : string with get, set

member Comment : string with get, set
Property Value
String
Remarks

The GZIP format allows for each file to optionally have an associated comment stored with the file. The comment is encoded with the ISO-8859-1 code page. To include a comment in a GZIP stream you create, set this property before calling Write() for the first time on the GZipStream.

When using GZipStream to decompress, you can retrieve this property after the first call to Read(). If no comment has been set in the GZIP bytestream, the Comment property will return null (Nothing in VB).


CompressBuffer Method (b)

Keyoti RapidSpell Desktop .NET API Docs
CompressBuffer Method (b)
API ► Keyoti.RapidSpell.Compression ► GZipStream ► CompressBuffer(array<Byte>[]()[][])
Keyoti RapidSpell Desktop .NET
Compress a byte array into a new byte array using GZip.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static byte[] CompressBuffer(
    byte[] b
)
public static byte[] CompressBuffer(
    byte[] b
)
Public Shared Function CompressBuffer (
    b As Byte()
) As Byte()
Public Shared Function CompressBuffer (
    b As Byte()
) As Byte()
public:
static array<unsigned char>^ CompressBuffer(
    array<unsigned char>^ b
)
public:
static array<unsigned char>^ CompressBuffer(
    array<unsigned char>^ b
)
static member CompressBuffer :
        b : byte[] -> byte[]

static member CompressBuffer :
        b : byte[] -> byte[]
Parameters
b (array< Byte >[]()[][])
A buffer to compress.
Return Value
array< Byte >[]()[][]
The data in compressed form
Remarks
Uncompress it with UncompressBuffer(array<Byte>[]()[][]).
See Also
CompressString(String)
UncompressBuffer(array<Byte>[]()[][])


CompressString Method (s)

Keyoti RapidSpell Desktop .NET API Docs
CompressString Method (s)
API ► Keyoti.RapidSpell.Compression ► GZipStream ► CompressString(String)
Keyoti RapidSpell Desktop .NET
Compress a string into a byte array using GZip.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static byte[] CompressString(
    string s
)
public static byte[] CompressString(
    string s
)
Public Shared Function CompressString (
    s As String
) As Byte()
Public Shared Function CompressString (
    s As String
) As Byte()
public:
static array<unsigned char>^ CompressString(
    String^ s
)
public:
static array<unsigned char>^ CompressString(
    String^ s
)
static member CompressString :
        s : string -> byte[]

static member CompressString :
        s : string -> byte[]
Parameters
s (String)
A string to compress. The string will first be encoded using UTF8, then compressed.
Return Value
array< Byte >[]()[][]
The string in compressed form
Remarks
Uncompress it with UncompressString(array<Byte>[]()[][]).
See Also
UncompressString(array<Byte>[]()[][])
CompressBuffer(array<Byte>[]()[][])


Crc32 Property

Keyoti RapidSpell Desktop .NET API Docs
Crc32 Property
API ► Keyoti.RapidSpell.Compression ► GZipStream ► Crc32
Keyoti RapidSpell Desktop .NET
The CRC on the GZIP stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int Crc32 { get; }
public int Crc32 { get; }
Public ReadOnly Property Crc32 As Integer
    Get
Public ReadOnly Property Crc32 As Integer
    Get
public:
property int Crc32 {
    int get ();
}
public:
property int Crc32 {
    int get ();
}
member Crc32 : int with get

member Crc32 : int with get
Property Value
Int32
Remarks
This is used for internal error checking. You probably don't need to look at this property.


Dispose Method (disposing)

Keyoti RapidSpell Desktop .NET API Docs
Dispose Method (disposing)
API ► Keyoti.RapidSpell.Compression ► GZipStream ► Dispose(Boolean)
Keyoti RapidSpell Desktop .NET
Dispose the stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
Parameters
disposing (Boolean)
Remarks
This may or may not result in a Close() call on the captive stream. See the doc on constructors that take a leaveOpen parameter for more information.


FileName Property

Keyoti RapidSpell Desktop .NET API Docs
FileName Property
API ► Keyoti.RapidSpell.Compression ► GZipStream ► FileName
Keyoti RapidSpell Desktop .NET
The FileName for the GZIP stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string FileName { get; set; }
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
Public Property FileName As String
    Get
    Set
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
member FileName : string with get, set

member FileName : string with get, set
Property Value
String
Remarks

The GZIP format optionally allows each file to have an associated filename. When compressing data (through Write()), set this FileName before calling Write() the first time on the GZipStream. The actual filename is encoded into the GZIP bytestream with the ISO-8859-1 code page, according to RFC 1952. It is the application's responsibility to insure that the FileName can be encoded and decoded correctly with this code page.

When decompressing (through Read()), you can retrieve this value any time after the first Read(). In the case where there was no filename encoded into the GZIP bytestream, the property will return null (Nothing in VB).


Flush Method

Keyoti RapidSpell Desktop .NET API Docs
Flush Method
API ► Keyoti.RapidSpell.Compression ► GZipStream ► Flush()()()()
Keyoti RapidSpell Desktop .NET
Flush the stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override void Flush()
public override void Flush()
Public Overrides Sub Flush
Public Overrides Sub Flush
public:
virtual void Flush() override
public:
virtual void Flush() override
abstract Flush : unit -> unit
override Flush : unit -> unit
abstract Flush : unit -> unit
override Flush : unit -> unit


FlushMode Property

Keyoti RapidSpell Desktop .NET API Docs
FlushMode Property
API ► Keyoti.RapidSpell.Compression ► GZipStream ► FlushMode
Keyoti RapidSpell Desktop .NET
This property sets the flush behavior on the stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual FlushType FlushMode { get; set; }
public virtual FlushType FlushMode { get; set; }
Public Overridable Property FlushMode As FlushType
    Get
    Set
Public Overridable Property FlushMode As FlushType
    Get
    Set
public:
virtual property FlushType FlushMode {
    FlushType get ();
    void set (FlushType value);
}
public:
virtual property FlushType FlushMode {
    FlushType get ();
    void set (FlushType value);
}
abstract FlushMode : FlushType with get, set
override FlushMode : FlushType with get, set
abstract FlushMode : FlushType with get, set
override FlushMode : FlushType with get, set
Property Value
FlushType


LastModified Field

Keyoti RapidSpell Desktop .NET API Docs
LastModified Field
API ► Keyoti.RapidSpell.Compression ► GZipStream ► LastModified
Keyoti RapidSpell Desktop .NET
The last modified time for the GZIP stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public DateTime LastModified
public DateTime LastModified
Public LastModified As DateTime
Public LastModified As DateTime
public:
DateTime LastModified
public:
DateTime LastModified
val mutable LastModified: DateTime
val mutable LastModified: DateTime
Field Value
DateTime
Remarks
GZIP allows the storage of a last modified time with each GZIP entry. When compressing data, you can set this before the first call to Write(). When decompressing, you can retrieve this value any time after the first call to Read().


Length Property

Keyoti RapidSpell Desktop .NET API Docs
Length Property
API ► Keyoti.RapidSpell.Compression ► GZipStream ► Length
Keyoti RapidSpell Desktop .NET
Reading this property always throws a NotImplementedException.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override long Length { get; }
public override long Length { get; }
Public Overrides ReadOnly Property Length As Long
    Get
Public Overrides ReadOnly Property Length As Long
    Get
public:
virtual property long long Length {
    long long get () override;
}
public:
virtual property long long Length {
    long long get () override;
}
abstract Length : int64 with get
override Length : int64 with get
abstract Length : int64 with get
override Length : int64 with get
Property Value
Int64


Position Property

Keyoti RapidSpell Desktop .NET API Docs
Position Property
API ► Keyoti.RapidSpell.Compression ► GZipStream ► Position
Keyoti RapidSpell Desktop .NET
The position of the stream pointer.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override long Position { get; set; }
public override long Position { get; set; }
Public Overrides Property Position As Long
    Get
    Set
Public Overrides Property Position As Long
    Get
    Set
public:
virtual property long long Position {
    long long get () override;
    void set (long long value) override;
}
public:
virtual property long long Position {
    long long get () override;
    void set (long long value) override;
}
abstract Position : int64 with get, set
override Position : int64 with get, set
abstract Position : int64 with get, set
override Position : int64 with get, set
Property Value
Int64
Remarks
Setting this property always throws a NotImplementedException. Reading will return the total bytes written out, if used in writing, or the total bytes read in, if used in reading. The count may refer to compressed bytes or uncompressed bytes, depending on how you've used the stream.


Read Method (buffer, offset, count)

Keyoti RapidSpell Desktop .NET API Docs
Read Method (buffer, offset, count)
API ► Keyoti.RapidSpell.Compression ► GZipStream ► Read(array<Byte>[]()[][], Int32, Int32)
Keyoti RapidSpell Desktop .NET
Read and decompress data from the source stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Function Read (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
Public Overrides Function Read (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
abstract Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
override Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
abstract Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
override Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
Parameters
buffer (array< Byte >[]()[][])
The buffer into which the decompressed data should be placed.
offset (Int32)
the offset within that data array to put the first byte read.
count (Int32)
the number of bytes to read.
Return Value
Int32
the number of bytes actually read
Remarks
With a GZipStream, decompression is done through reading.
Examples
Copy image Copy
byte[] working = new byte[WORKING_BUFFER_SIZE];
using (System.IO.Stream input = System.IO.File.OpenRead(_CompressedFile))
{
    using (Stream decompressor= new Keyoti.RapidSpell.Compression.GZipStream(input, CompressionMode.Decompress, true))
    {
        using (var output = System.IO.File.Create(_DecompressedFile))
        {
            int n;
            while ((n= decompressor.Read(working, 0, working.Length)) !=0)
            {
                output.Write(working, 0, n);
            }
        }
    }
}


Seek Method (offset, origin)

Keyoti RapidSpell Desktop .NET API Docs
Seek Method (offset, origin)
API ► Keyoti.RapidSpell.Compression ► GZipStream ► Seek(Int64, SeekOrigin)
Keyoti RapidSpell Desktop .NET
Calling this method always throws a NotImplementedException.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override long Seek(
    long offset,
    SeekOrigin origin
)
public override long Seek(
    long offset,
    SeekOrigin origin
)
Public Overrides Function Seek (
    offset As Long,
    origin As SeekOrigin
) As Long
Public Overrides Function Seek (
    offset As Long,
    origin As SeekOrigin
) As Long
public:
virtual long long Seek(
    long long offset,
    SeekOrigin origin
) override
public:
virtual long long Seek(
    long long offset,
    SeekOrigin origin
) override
abstract Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
override Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
abstract Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
override Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
Parameters
offset (Int64)
irrelevant; it will always throw!
origin (SeekOrigin)
irrelevant; it will always throw!
Return Value
Int64
irrelevant!


SetLength Method (value)

Keyoti RapidSpell Desktop .NET API Docs
SetLength Method (value)
API ► Keyoti.RapidSpell.Compression ► GZipStream ► SetLength(Int64)
Keyoti RapidSpell Desktop .NET
Calling this method always throws a NotImplementedException.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override void SetLength(
    long value
)
public override void SetLength(
    long value
)
Public Overrides Sub SetLength (
    value As Long
)
Public Overrides Sub SetLength (
    value As Long
)
public:
virtual void SetLength(
    long long value
) override
public:
virtual void SetLength(
    long long value
) override
abstract SetLength :
        value : int64 -> unit
override SetLength :
        value : int64 -> unit
abstract SetLength :
        value : int64 -> unit
override SetLength :
        value : int64 -> unit
Parameters
value (Int64)
irrelevant; this method will always throw!


TotalIn Property

Keyoti RapidSpell Desktop .NET API Docs
TotalIn Property
API ► Keyoti.RapidSpell.Compression ► GZipStream ► TotalIn
Keyoti RapidSpell Desktop .NET
Returns the total number of bytes input so far.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual long TotalIn { get; }
public virtual long TotalIn { get; }
Public Overridable ReadOnly Property TotalIn As Long
    Get
Public Overridable ReadOnly Property TotalIn As Long
    Get
public:
virtual property long long TotalIn {
    long long get ();
}
public:
virtual property long long TotalIn {
    long long get ();
}
abstract TotalIn : int64 with get
override TotalIn : int64 with get
abstract TotalIn : int64 with get
override TotalIn : int64 with get
Property Value
Int64


TotalOut Property

Keyoti RapidSpell Desktop .NET API Docs
TotalOut Property
API ► Keyoti.RapidSpell.Compression ► GZipStream ► TotalOut
Keyoti RapidSpell Desktop .NET
Returns the total number of bytes output so far.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual long TotalOut { get; }
public virtual long TotalOut { get; }
Public Overridable ReadOnly Property TotalOut As Long
    Get
Public Overridable ReadOnly Property TotalOut As Long
    Get
public:
virtual property long long TotalOut {
    long long get ();
}
public:
virtual property long long TotalOut {
    long long get ();
}
abstract TotalOut : int64 with get
override TotalOut : int64 with get
abstract TotalOut : int64 with get
override TotalOut : int64 with get
Property Value
Int64


UncompressBuffer Method (compressed)

Keyoti RapidSpell Desktop .NET API Docs
UncompressBuffer Method (compressed)
API ► Keyoti.RapidSpell.Compression ► GZipStream ► UncompressBuffer(array<Byte>[]()[][])
Keyoti RapidSpell Desktop .NET
Uncompress a GZip'ed byte array into a byte array.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static byte[] UncompressBuffer(
    byte[] compressed
)
public static byte[] UncompressBuffer(
    byte[] compressed
)
Public Shared Function UncompressBuffer (
    compressed As Byte()
) As Byte()
Public Shared Function UncompressBuffer (
    compressed As Byte()
) As Byte()
public:
static array<unsigned char>^ UncompressBuffer(
    array<unsigned char>^ compressed
)
public:
static array<unsigned char>^ UncompressBuffer(
    array<unsigned char>^ compressed
)
static member UncompressBuffer :
        compressed : byte[] -> byte[]

static member UncompressBuffer :
        compressed : byte[] -> byte[]
Parameters
compressed (array< Byte >[]()[][])
A buffer containing data that has been compressed with GZip.
Return Value
array< Byte >[]()[][]
The data in uncompressed form
See Also
CompressBuffer(array<Byte>[]()[][])
UncompressString(array<Byte>[]()[][])


UncompressString Method (compressed)

Keyoti RapidSpell Desktop .NET API Docs
UncompressString Method (compressed)
API ► Keyoti.RapidSpell.Compression ► GZipStream ► UncompressString(array<Byte>[]()[][])
Keyoti RapidSpell Desktop .NET
Uncompress a GZip'ed byte array into a single string.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static string UncompressString(
    byte[] compressed
)
public static string UncompressString(
    byte[] compressed
)
Public Shared Function UncompressString (
    compressed As Byte()
) As String
Public Shared Function UncompressString (
    compressed As Byte()
) As String
public:
static String^ UncompressString(
    array<unsigned char>^ compressed
)
public:
static String^ UncompressString(
    array<unsigned char>^ compressed
)
static member UncompressString :
        compressed : byte[] -> string

static member UncompressString :
        compressed : byte[] -> string
Parameters
compressed (array< Byte >[]()[][])
A buffer containing GZIP-compressed data.
Return Value
String
The uncompressed string
See Also
CompressString(String)
UncompressBuffer(array<Byte>[]()[][])


Write Method (buffer, offset, count)

Keyoti RapidSpell Desktop .NET API Docs
Write Method (buffer, offset, count)
API ► Keyoti.RapidSpell.Compression ► GZipStream ► Write(array<Byte>[]()[][], Int32, Int32)
Keyoti RapidSpell Desktop .NET
Write data to the stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Sub Write (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
Public Overrides Sub Write (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
public:
virtual void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
public:
virtual void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
abstract Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
override Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
abstract Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
override Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
Parameters
buffer (array< Byte >[]()[][])
The buffer holding data to write to the stream.
offset (Int32)
the offset within that data array to find the first byte to write.
count (Int32)
the number of bytes to write.
Remarks

If you wish to use the GZipStream to compress data while writing, you can create a GZipStream with CompressionMode.Compress, and a writable output stream. Then call Write() on that GZipStream, providing uncompressed data as input. The data sent to the output stream will be the compressed form of the data written.

A GZipStream can be used for Read() or Write(), but not both. Writing implies compression. Reading implies decompression.


ZlibCodec Class

Keyoti RapidSpell Desktop .NET API Docs
ZlibCodec Class
API ► Keyoti.RapidSpell.Compression ► ZlibCodec
Keyoti RapidSpell Desktop .NET
Encoder and Decoder for ZLIB and DEFLATE (IETF RFC1950 and RFC1951).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public sealed class ZlibCodec
public sealed class ZlibCodec
Public NotInheritable Class ZlibCodec
Public NotInheritable Class ZlibCodec
public ref class ZlibCodec sealed
public ref class ZlibCodec sealed
[<SealedAttribute>]
type ZlibCodec =  class end
[<SealedAttribute>]
type ZlibCodec =  class end
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZlibCodec()()()() | Create a ZlibCodec.
 | ZlibCodec(CompressionMode) | Create a ZlibCodec that either compresses or decompresses.
 | Adler32 | The Adler32 checksum on the data transferred through the codec so far. You probably don't need to look at this.
 | AvailableBytesIn | The number of bytes available in the InputBuffer, starting at NextIn.
 | AvailableBytesOut | The number of bytes available in the OutputBuffer, starting at NextOut.
 | CompressLevel | The compression level to use in this codec. Useful only in compression mode.
 | Deflate(FlushType) | Deflate one batch of data.
 | EndDeflate()()()() | End a deflation session.
 | EndInflate()()()() | Ends an inflation session.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | Inflate(FlushType) | Inflate the data in the InputBuffer, placing the result in the OutputBuffer.
 | InitializeDeflate()()()() | Initialize the ZlibCodec for deflation operation.
 | InitializeDeflate(CompressionLevel) | Initialize the ZlibCodec for deflation operation, using the specified CompressionLevel.
 | InitializeDeflate(CompressionLevel, Boolean) | Initialize the ZlibCodec for deflation operation, using the specified CompressionLevel, and the explicit flag governing whether to emit an RFC1950 header byte pair.
 | InitializeDeflate(CompressionLevel, Int32) | Initialize the ZlibCodec for deflation operation, using the specified CompressionLevel, and the specified number of window bits.
 | InitializeDeflate(CompressionLevel, Int32, Boolean) | Initialize the ZlibCodec for deflation operation, using the specified CompressionLevel, the specified number of window bits, and the explicit flag governing whether to emit an RFC1950 header byte pair.
 | InitializeInflate()()()() | Initialize the inflation state.
 | InitializeInflate(Boolean) | Initialize the inflation state with an explicit flag to govern the handling of RFC1950 header bytes.
 | InitializeInflate(Int32) | Initialize the ZlibCodec for inflation, with the specified number of window bits.
 | InitializeInflate(Int32, Boolean) | Initialize the inflation state with an explicit flag to govern the handling of RFC1950 header bytes.
 | InputBuffer | The buffer from which data is taken.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | used for diagnostics, when something goes wrong!
 | NextIn | An index into the InputBuffer array, indicating where to start reading.
 | NextOut | An index into the OutputBuffer array, indicating where to start writing.
 | OutputBuffer | Buffer to store output data.
 | ResetDeflate()()()() | Reset a codec for another deflation session.
 | SetDeflateParams(CompressionLevel, CompressionStrategy) | Set the CompressionStrategy and CompressionLevel for a deflation session.
 | SetDictionary(array<Byte>[]()[][]) | Set the dictionary to be used for either Inflation or Deflation.
 | Strategy | The compression strategy to use.
 | SyncInflate()()()() | I don't know what this does!
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | TotalBytesIn | Total number of bytes read so far, through all calls to Inflate()/Deflate().
 | TotalBytesOut | Total number of bytes written to the output so far, through all calls to Inflate()/Deflate().
 | WindowBits | The number of Window Bits to use.
Remarks
This class compresses and decompresses data according to the Deflate algorithm and optionally, the ZLIB format, as documented in RFC 1950 - ZLIB and RFC 1951 - DEFLATE.
Inheritance Hierarchy
Object
ZlibCodec


ZlibCodec Constructor

Keyoti RapidSpell Desktop .NET API Docs
ZlibCodec Constructor
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► ZlibCodec()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | ZlibCodec()()()() | Create a ZlibCodec.
 | ZlibCodec(CompressionMode) | Create a ZlibCodec that either compresses or decompresses.


ZlibCodec Constructor

Keyoti RapidSpell Desktop .NET API Docs
ZlibCodec Constructor
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► ZlibCodec()()()()
Keyoti RapidSpell Desktop .NET
Create a ZlibCodec.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ZlibCodec()
public ZlibCodec()
Public Sub New
Public Sub New
public:
ZlibCodec()
public:
ZlibCodec()
new : unit -> ZlibCodec
new : unit -> ZlibCodec
Remarks
If you use this default constructor, you will later have to explicitly call InitializeInflate() or InitializeDeflate() before using the ZlibCodec to compress or decompress.


ZlibCodec Constructor (mode)

Keyoti RapidSpell Desktop .NET API Docs
ZlibCodec Constructor (mode)
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► ZlibCodec(CompressionMode)
Keyoti RapidSpell Desktop .NET
Create a ZlibCodec that either compresses or decompresses.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ZlibCodec(
    CompressionMode mode
)
public ZlibCodec(
    CompressionMode mode
)
Public Sub New (
    mode As CompressionMode
)
Public Sub New (
    mode As CompressionMode
)
public:
ZlibCodec(
    CompressionMode mode
)
public:
ZlibCodec(
    CompressionMode mode
)
new :
        mode : CompressionMode -> ZlibCodec
new :
        mode : CompressionMode -> ZlibCodec
Parameters
mode (CompressionMode)
Indicates whether the codec should compress (deflate) or decompress (inflate).


Adler32 Property

Keyoti RapidSpell Desktop .NET API Docs
Adler32 Property
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► Adler32
Keyoti RapidSpell Desktop .NET
The Adler32 checksum on the data transferred through the codec so far. You probably don't need to look at this.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int Adler32 { get; }
public int Adler32 { get; }
Public ReadOnly Property Adler32 As Integer
    Get
Public ReadOnly Property Adler32 As Integer
    Get
public:
property int Adler32 {
    int get ();
}
public:
property int Adler32 {
    int get ();
}
member Adler32 : int with get

member Adler32 : int with get
Property Value
Int32


AvailableBytesIn Field

Keyoti RapidSpell Desktop .NET API Docs
AvailableBytesIn Field
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► AvailableBytesIn
Keyoti RapidSpell Desktop .NET
The number of bytes available in the InputBuffer, starting at NextIn.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int AvailableBytesIn
public int AvailableBytesIn
Public AvailableBytesIn As Integer
Public AvailableBytesIn As Integer
public:
int AvailableBytesIn
public:
int AvailableBytesIn
val mutable AvailableBytesIn: int
val mutable AvailableBytesIn: int
Field Value
Int32
Remarks
Generally you should set this to InputBuffer.Length before the first Inflate() or Deflate() call. The class will update this number as calls to Inflate/Deflate are made.


AvailableBytesOut Field

Keyoti RapidSpell Desktop .NET API Docs
AvailableBytesOut Field
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► AvailableBytesOut
Keyoti RapidSpell Desktop .NET
The number of bytes available in the OutputBuffer, starting at NextOut.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int AvailableBytesOut
public int AvailableBytesOut
Public AvailableBytesOut As Integer
Public AvailableBytesOut As Integer
public:
int AvailableBytesOut
public:
int AvailableBytesOut
val mutable AvailableBytesOut: int
val mutable AvailableBytesOut: int
Field Value
Int32
Remarks
Generally you should set this to OutputBuffer.Length before the first Inflate() or Deflate() call. The class will update this number as calls to Inflate/Deflate are made.


CompressLevel Field

Keyoti RapidSpell Desktop .NET API Docs
CompressLevel Field
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► CompressLevel
Keyoti RapidSpell Desktop .NET
The compression level to use in this codec. Useful only in compression mode.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public CompressionLevel CompressLevel
public CompressionLevel CompressLevel
Public CompressLevel As CompressionLevel
Public CompressLevel As CompressionLevel
public:
CompressionLevel CompressLevel
public:
CompressionLevel CompressLevel
val mutable CompressLevel: CompressionLevel
val mutable CompressLevel: CompressionLevel
Field Value
CompressionLevel


Deflate Method (flush)

Keyoti RapidSpell Desktop .NET API Docs
Deflate Method (flush)
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► Deflate(FlushType)
Keyoti RapidSpell Desktop .NET
Deflate one batch of data.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int Deflate(
    FlushType flush
)
public int Deflate(
    FlushType flush
)
Public Function Deflate (
    flush As FlushType
) As Integer
Public Function Deflate (
    flush As FlushType
) As Integer
public:
int Deflate(
    FlushType flush
)
public:
int Deflate(
    FlushType flush
)
member Deflate :
        flush : FlushType -> int

member Deflate :
        flush : FlushType -> int
Parameters
flush (FlushType)
whether to flush all data as you deflate. Generally you will want to use Z_NO_FLUSH here, in a series of calls to Deflate(), and then call EndDeflate() to flush everything.
Return Value
Int32
Z_OK if all goes well.
Remarks
You must have set InputBuffer and OutputBuffer before calling this method.
Examples
Copy image Copy
private void DeflateBuffer(CompressionLevel level)
{
    int bufferSize = 1024;
    byte[] buffer = new byte[bufferSize];
    ZlibCodec compressor = new ZlibCodec();

    Console.WriteLine("\n============================================");
    Console.WriteLine("Size of Buffer to Deflate: {0} bytes.", UncompressedBytes.Length);
    MemoryStream ms = new MemoryStream();

    int rc = compressor.InitializeDeflate(level);

    compressor.InputBuffer = UncompressedBytes;
    compressor.NextIn = 0;
    compressor.AvailableBytesIn = UncompressedBytes.Length;

    compressor.OutputBuffer = buffer;

    // pass 1: deflate
    do
    {
        compressor.NextOut = 0;
        compressor.AvailableBytesOut = buffer.Length;
        rc = compressor.Deflate(FlushType.None);

        if (rc != ZlibConstants.Z_OK && rc != ZlibConstants.Z_STREAM_END)
            throw new Exception("deflating: " + compressor.Message);

        ms.Write(compressor.OutputBuffer, 0, buffer.Length - compressor.AvailableBytesOut);
    }
    while (compressor.AvailableBytesIn > 0 || compressor.AvailableBytesOut == 0);

    // pass 2: finish and flush
    do
    {
        compressor.NextOut = 0;
        compressor.AvailableBytesOut = buffer.Length;
        rc = compressor.Deflate(FlushType.Finish);

        if (rc != ZlibConstants.Z_STREAM_END && rc != ZlibConstants.Z_OK)
            throw new Exception("deflating: " + compressor.Message);

        if (buffer.Length - compressor.AvailableBytesOut > 0)
            ms.Write(buffer, 0, buffer.Length - compressor.AvailableBytesOut);
    }
    while (compressor.AvailableBytesIn > 0 || compressor.AvailableBytesOut == 0);

    compressor.EndDeflate();

    ms.Seek(0, SeekOrigin.Begin);
    CompressedBytes = new byte[compressor.TotalBytesOut];
    ms.Read(CompressedBytes, 0, CompressedBytes.Length);
}


EndDeflate Method

Keyoti RapidSpell Desktop .NET API Docs
EndDeflate Method
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► EndDeflate()()()()
Keyoti RapidSpell Desktop .NET
End a deflation session.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int EndDeflate()
public int EndDeflate()
Public Function EndDeflate As Integer
Public Function EndDeflate As Integer
public:
int EndDeflate()
public:
int EndDeflate()
member EndDeflate : unit -> int

member EndDeflate : unit -> int
Return Value
Int32
Z_OK if all goes well.
Remarks
Call this after making a series of one or more calls to Deflate(). All buffers are flushed.


EndInflate Method

Keyoti RapidSpell Desktop .NET API Docs
EndInflate Method
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► EndInflate()()()()
Keyoti RapidSpell Desktop .NET
Ends an inflation session.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int EndInflate()
public int EndInflate()
Public Function EndInflate As Integer
Public Function EndInflate As Integer
public:
int EndInflate()
public:
int EndInflate()
member EndInflate : unit -> int

member EndInflate : unit -> int
Return Value
Int32
Z_OK if everything goes well.
Remarks
Call this after successively calling Inflate(). This will cause all buffers to be flushed. After calling this you cannot call Inflate() without a intervening call to one of the InitializeInflate() overloads.


Inflate Method (flush)

Keyoti RapidSpell Desktop .NET API Docs
Inflate Method (flush)
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► Inflate(FlushType)
Keyoti RapidSpell Desktop .NET
Inflate the data in the InputBuffer, placing the result in the OutputBuffer.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int Inflate(
    FlushType flush
)
public int Inflate(
    FlushType flush
)
Public Function Inflate (
    flush As FlushType
) As Integer
Public Function Inflate (
    flush As FlushType
) As Integer
public:
int Inflate(
    FlushType flush
)
public:
int Inflate(
    FlushType flush
)
member Inflate :
        flush : FlushType -> int

member Inflate :
        flush : FlushType -> int
Parameters
flush (FlushType)
The flush to use when inflating.
Return Value
Int32
Z_OK if everything goes well.
Remarks
You must have set InputBuffer and OutputBuffer, NextIn and NextOut, and AvailableBytesIn and AvailableBytesOut before calling this method.
Examples
Copy image Copy
private void InflateBuffer()
{
    int bufferSize = 1024;
    byte[] buffer = new byte[bufferSize];
    ZlibCodec decompressor = new ZlibCodec();

    Console.WriteLine("\n============================================");
    Console.WriteLine("Size of Buffer to Inflate: {0} bytes.", CompressedBytes.Length);
    MemoryStream ms = new MemoryStream(DecompressedBytes);

    int rc = decompressor.InitializeInflate();

    decompressor.InputBuffer = CompressedBytes;
    decompressor.NextIn = 0;
    decompressor.AvailableBytesIn = CompressedBytes.Length;

    decompressor.OutputBuffer = buffer;

    // pass 1: inflate
    do
    {
        decompressor.NextOut = 0;
        decompressor.AvailableBytesOut = buffer.Length;
        rc = decompressor.Inflate(FlushType.None);

        if (rc != ZlibConstants.Z_OK && rc != ZlibConstants.Z_STREAM_END)
            throw new Exception("inflating: " + decompressor.Message);

        ms.Write(decompressor.OutputBuffer, 0, buffer.Length - decompressor.AvailableBytesOut);
    }
    while (decompressor.AvailableBytesIn > 0 || decompressor.AvailableBytesOut == 0);

    // pass 2: finish and flush
    do
    {
        decompressor.NextOut = 0;
        decompressor.AvailableBytesOut = buffer.Length;
        rc = decompressor.Inflate(FlushType.Finish);

        if (rc != ZlibConstants.Z_STREAM_END && rc != ZlibConstants.Z_OK)
            throw new Exception("inflating: " + decompressor.Message);

        if (buffer.Length - decompressor.AvailableBytesOut > 0)
            ms.Write(buffer, 0, buffer.Length - decompressor.AvailableBytesOut);
    }
    while (decompressor.AvailableBytesIn > 0 || decompressor.AvailableBytesOut == 0);

    decompressor.EndInflate();
}


InitializeDeflate Method

Keyoti RapidSpell Desktop .NET API Docs
InitializeDeflate Method
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► InitializeDeflate()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | InitializeDeflate()()()() | Initialize the ZlibCodec for deflation operation.
 | InitializeDeflate(CompressionLevel) | Initialize the ZlibCodec for deflation operation, using the specified CompressionLevel.
 | InitializeDeflate(CompressionLevel, Boolean) | Initialize the ZlibCodec for deflation operation, using the specified CompressionLevel, and the explicit flag governing whether to emit an RFC1950 header byte pair.
 | InitializeDeflate(CompressionLevel, Int32) | Initialize the ZlibCodec for deflation operation, using the specified CompressionLevel, and the specified number of window bits.
 | InitializeDeflate(CompressionLevel, Int32, Boolean) | Initialize the ZlibCodec for deflation operation, using the specified CompressionLevel, the specified number of window bits, and the explicit flag governing whether to emit an RFC1950 header byte pair.


InitializeDeflate Method

Keyoti RapidSpell Desktop .NET API Docs
InitializeDeflate Method
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► InitializeDeflate()()()()
Keyoti RapidSpell Desktop .NET
Initialize the ZlibCodec for deflation operation.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int InitializeDeflate()
public int InitializeDeflate()
Public Function InitializeDeflate As Integer
Public Function InitializeDeflate As Integer
public:
int InitializeDeflate()
public:
int InitializeDeflate()
member InitializeDeflate : unit -> int

member InitializeDeflate : unit -> int
Return Value
Int32
Z_OK if all goes well. You generally don't need to check the return code.
Remarks
The codec will use the MAX window bits and the default level of compression.
Examples
Copy image Copy
int bufferSize = 40000;
byte[] CompressedBytes = new byte[bufferSize];
byte[] DecompressedBytes = new byte[bufferSize];

ZlibCodec compressor = new ZlibCodec();

compressor.InitializeDeflate(CompressionLevel.Default);

compressor.InputBuffer = System.Text.ASCIIEncoding.ASCII.GetBytes(TextToCompress);
compressor.NextIn = 0;
compressor.AvailableBytesIn = compressor.InputBuffer.Length;

compressor.OutputBuffer = CompressedBytes;
compressor.NextOut = 0;
compressor.AvailableBytesOut = CompressedBytes.Length;

while (compressor.TotalBytesIn != TextToCompress.Length && compressor.TotalBytesOut < bufferSize)
{
  compressor.Deflate(FlushType.None);
}

while (true)
{
  int rc= compressor.Deflate(FlushType.Finish);
  if (rc == ZlibConstants.Z_STREAM_END) break;
}

compressor.EndDeflate();


InitializeDeflate Method (level)

Keyoti RapidSpell Desktop .NET API Docs
InitializeDeflate Method (level)
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► InitializeDeflate(CompressionLevel)
Keyoti RapidSpell Desktop .NET
Initialize the ZlibCodec for deflation operation, using the specified CompressionLevel.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int InitializeDeflate(
    CompressionLevel level
)
public int InitializeDeflate(
    CompressionLevel level
)
Public Function InitializeDeflate (
    level As CompressionLevel
) As Integer
Public Function InitializeDeflate (
    level As CompressionLevel
) As Integer
public:
int InitializeDeflate(
    CompressionLevel level
)
public:
int InitializeDeflate(
    CompressionLevel level
)
member InitializeDeflate :
        level : CompressionLevel -> int

member InitializeDeflate :
        level : CompressionLevel -> int
Parameters
level (CompressionLevel)
The compression level for the codec.
Return Value
Int32
Z_OK if all goes well.
Remarks
The codec will use the maximum window bits (15) and the specified CompressionLevel. It will emit a ZLIB stream as it compresses.


InitializeDeflate Method (level, wantRfc1950Header)

Keyoti RapidSpell Desktop .NET API Docs
InitializeDeflate Method (level, wantRfc1950Header)
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► InitializeDeflate(CompressionLevel, Boolean)
Keyoti RapidSpell Desktop .NET
Initialize the ZlibCodec for deflation operation, using the specified CompressionLevel, and the explicit flag governing whether to emit an RFC1950 header byte pair.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int InitializeDeflate(
    CompressionLevel level,
    bool wantRfc1950Header
)
public int InitializeDeflate(
    CompressionLevel level,
    bool wantRfc1950Header
)
Public Function InitializeDeflate (
    level As CompressionLevel,
    wantRfc1950Header As Boolean
) As Integer
Public Function InitializeDeflate (
    level As CompressionLevel,
    wantRfc1950Header As Boolean
) As Integer
public:
int InitializeDeflate(
    CompressionLevel level,
    bool wantRfc1950Header
)
public:
int InitializeDeflate(
    CompressionLevel level,
    bool wantRfc1950Header
)
member InitializeDeflate :
        level : CompressionLevel *
        wantRfc1950Header : bool -> int

member InitializeDeflate :
        level : CompressionLevel *
        wantRfc1950Header : bool -> int
Parameters
level (CompressionLevel)
The compression level for the codec.
wantRfc1950Header (Boolean)
whether to emit an initial RFC1950 byte pair in the compressed stream.
Return Value
Int32
Z_OK if all goes well.
Remarks
The codec will use the maximum window bits (15) and the specified CompressionLevel. If you want to generate a zlib stream, you should specify true for wantRfc1950Header. In this case, the library will emit a ZLIB header, as defined in RFC 1950, in the compressed stream.


InitializeDeflate Method (level, bits)

Keyoti RapidSpell Desktop .NET API Docs
InitializeDeflate Method (level, bits)
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► InitializeDeflate(CompressionLevel, Int32)
Keyoti RapidSpell Desktop .NET
Initialize the ZlibCodec for deflation operation, using the specified CompressionLevel, and the specified number of window bits.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int InitializeDeflate(
    CompressionLevel level,
    int bits
)
public int InitializeDeflate(
    CompressionLevel level,
    int bits
)
Public Function InitializeDeflate (
    level As CompressionLevel,
    bits As Integer
) As Integer
Public Function InitializeDeflate (
    level As CompressionLevel,
    bits As Integer
) As Integer
public:
int InitializeDeflate(
    CompressionLevel level,
    int bits
)
public:
int InitializeDeflate(
    CompressionLevel level,
    int bits
)
member InitializeDeflate :
        level : CompressionLevel *
        bits : int -> int

member InitializeDeflate :
        level : CompressionLevel *
        bits : int -> int
Parameters
level (CompressionLevel)
The compression level for the codec.
bits (Int32)
the number of window bits to use. If you don't know what this means, don't use this method.
Return Value
Int32
Z_OK if all goes well.
Remarks
The codec will use the specified number of window bits and the specified CompressionLevel.


InitializeDeflate Method (level, bits, wantRfc1950Header)

Keyoti RapidSpell Desktop .NET API Docs
InitializeDeflate Method (level, bits, wantRfc1950Header)
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► InitializeDeflate(CompressionLevel, Int32, Boolean)
Keyoti RapidSpell Desktop .NET
Initialize the ZlibCodec for deflation operation, using the specified CompressionLevel, the specified number of window bits, and the explicit flag governing whether to emit an RFC1950 header byte pair.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int InitializeDeflate(
    CompressionLevel level,
    int bits,
    bool wantRfc1950Header
)
public int InitializeDeflate(
    CompressionLevel level,
    int bits,
    bool wantRfc1950Header
)
Public Function InitializeDeflate (
    level As CompressionLevel,
    bits As Integer,
    wantRfc1950Header As Boolean
) As Integer
Public Function InitializeDeflate (
    level As CompressionLevel,
    bits As Integer,
    wantRfc1950Header As Boolean
) As Integer
public:
int InitializeDeflate(
    CompressionLevel level,
    int bits,
    bool wantRfc1950Header
)
public:
int InitializeDeflate(
    CompressionLevel level,
    int bits,
    bool wantRfc1950Header
)
member InitializeDeflate :
        level : CompressionLevel *
        bits : int *
        wantRfc1950Header : bool -> int

member InitializeDeflate :
        level : CompressionLevel *
        bits : int *
        wantRfc1950Header : bool -> int
Parameters
level (CompressionLevel)
The compression level for the codec.
bits (Int32)
the number of window bits to use. If you don't know what this means, don't use this method.
wantRfc1950Header (Boolean)
whether to emit an initial RFC1950 byte pair in the compressed stream.
Return Value
Int32
Z_OK if all goes well.


InitializeInflate Method

Keyoti RapidSpell Desktop .NET API Docs
InitializeInflate Method
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► InitializeInflate()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | InitializeInflate()()()() | Initialize the inflation state.
 | InitializeInflate(Boolean) | Initialize the inflation state with an explicit flag to govern the handling of RFC1950 header bytes.
 | InitializeInflate(Int32) | Initialize the ZlibCodec for inflation, with the specified number of window bits.
 | InitializeInflate(Int32, Boolean) | Initialize the inflation state with an explicit flag to govern the handling of RFC1950 header bytes.


InitializeInflate Method

Keyoti RapidSpell Desktop .NET API Docs
InitializeInflate Method
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► InitializeInflate()()()()
Keyoti RapidSpell Desktop .NET
Initialize the inflation state.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int InitializeInflate()
public int InitializeInflate()
Public Function InitializeInflate As Integer
Public Function InitializeInflate As Integer
public:
int InitializeInflate()
public:
int InitializeInflate()
member InitializeInflate : unit -> int

member InitializeInflate : unit -> int
Return Value
Int32
Z_OK if everything goes well.
Remarks
It is not necessary to call this before using the ZlibCodec to inflate data; It is implicitly called when you call the constructor.


InitializeInflate Method (expectRfc1950Header)

Keyoti RapidSpell Desktop .NET API Docs
InitializeInflate Method (expectRfc1950Header)
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► InitializeInflate(Boolean)
Keyoti RapidSpell Desktop .NET
Initialize the inflation state with an explicit flag to govern the handling of RFC1950 header bytes.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int InitializeInflate(
    bool expectRfc1950Header
)
public int InitializeInflate(
    bool expectRfc1950Header
)
Public Function InitializeInflate (
    expectRfc1950Header As Boolean
) As Integer
Public Function InitializeInflate (
    expectRfc1950Header As Boolean
) As Integer
public:
int InitializeInflate(
    bool expectRfc1950Header
)
public:
int InitializeInflate(
    bool expectRfc1950Header
)
member InitializeInflate :
        expectRfc1950Header : bool -> int

member InitializeInflate :
        expectRfc1950Header : bool -> int
Parameters
expectRfc1950Header (Boolean)
whether to expect an RFC1950 header byte pair when reading the stream of data to be inflated.
Return Value
Int32
Z_OK if everything goes well.
Remarks
By default, the ZLIB header defined in RFC 1950 is expected. If you want to read a zlib stream you should specify true for expectRfc1950Header. If you have a deflate stream, you will want to specify false. It is only necessary to invoke this initializer explicitly if you want to specify false.


InitializeInflate Method (windowBits)

Keyoti RapidSpell Desktop .NET API Docs
InitializeInflate Method (windowBits)
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► InitializeInflate(Int32)
Keyoti RapidSpell Desktop .NET
Initialize the ZlibCodec for inflation, with the specified number of window bits.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int InitializeInflate(
    int windowBits
)
public int InitializeInflate(
    int windowBits
)
Public Function InitializeInflate (
    windowBits As Integer
) As Integer
Public Function InitializeInflate (
    windowBits As Integer
) As Integer
public:
int InitializeInflate(
    int windowBits
)
public:
int InitializeInflate(
    int windowBits
)
member InitializeInflate :
        windowBits : int -> int

member InitializeInflate :
        windowBits : int -> int
Parameters
windowBits (Int32)
The number of window bits to use. If you need to ask what that is, then you shouldn't be calling this initializer.
Return Value
Int32
Z_OK if all goes well.


InitializeInflate Method (windowBits, expectRfc1950Header)

Keyoti RapidSpell Desktop .NET API Docs
InitializeInflate Method (windowBits, expectRfc1950Header)
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► InitializeInflate(Int32, Boolean)
Keyoti RapidSpell Desktop .NET
Initialize the inflation state with an explicit flag to govern the handling of RFC1950 header bytes.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int InitializeInflate(
    int windowBits,
    bool expectRfc1950Header
)
public int InitializeInflate(
    int windowBits,
    bool expectRfc1950Header
)
Public Function InitializeInflate (
    windowBits As Integer,
    expectRfc1950Header As Boolean
) As Integer
Public Function InitializeInflate (
    windowBits As Integer,
    expectRfc1950Header As Boolean
) As Integer
public:
int InitializeInflate(
    int windowBits,
    bool expectRfc1950Header
)
public:
int InitializeInflate(
    int windowBits,
    bool expectRfc1950Header
)
member InitializeInflate :
        windowBits : int *
        expectRfc1950Header : bool -> int

member InitializeInflate :
        windowBits : int *
        expectRfc1950Header : bool -> int
Parameters
windowBits (Int32)
The number of window bits to use. If you need to ask what that is, then you shouldn't be calling this initializer.
expectRfc1950Header (Boolean)
whether to expect an RFC1950 header byte pair when reading the stream of data to be inflated.
Return Value
Int32
Z_OK if everything goes well.
Remarks
If you want to read a zlib stream you should specify true for expectRfc1950Header. In this case, the library will expect to find a ZLIB header, as defined in RFC 1950, in the compressed stream. If you will be reading a DEFLATE or GZIP stream, which does not have such a header, you will want to specify false.


InputBuffer Field

Keyoti RapidSpell Desktop .NET API Docs
InputBuffer Field
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► InputBuffer
Keyoti RapidSpell Desktop .NET
The buffer from which data is taken.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public byte[] InputBuffer
public byte[] InputBuffer
Public InputBuffer As Byte()
Public InputBuffer As Byte()
public:
array<unsigned char>^ InputBuffer
public:
array<unsigned char>^ InputBuffer
val mutable InputBuffer: byte[]
val mutable InputBuffer: byte[]
Field Value
array< Byte >[]()[][]


Message Field

Keyoti RapidSpell Desktop .NET API Docs
Message Field
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► Message
Keyoti RapidSpell Desktop .NET
used for diagnostics, when something goes wrong!
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string Message
public string Message
Public Message As String
Public Message As String
public:
String^ Message
public:
String^ Message
val mutable Message: string
val mutable Message: string
Field Value
String


NextIn Field

Keyoti RapidSpell Desktop .NET API Docs
NextIn Field
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► NextIn
Keyoti RapidSpell Desktop .NET
An index into the InputBuffer array, indicating where to start reading.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int NextIn
public int NextIn
Public NextIn As Integer
Public NextIn As Integer
public:
int NextIn
public:
int NextIn
val mutable NextIn: int
val mutable NextIn: int
Field Value
Int32


NextOut Field

Keyoti RapidSpell Desktop .NET API Docs
NextOut Field
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► NextOut
Keyoti RapidSpell Desktop .NET
An index into the OutputBuffer array, indicating where to start writing.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int NextOut
public int NextOut
Public NextOut As Integer
Public NextOut As Integer
public:
int NextOut
public:
int NextOut
val mutable NextOut: int
val mutable NextOut: int
Field Value
Int32


OutputBuffer Field

Keyoti RapidSpell Desktop .NET API Docs
OutputBuffer Field
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► OutputBuffer
Keyoti RapidSpell Desktop .NET
Buffer to store output data.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public byte[] OutputBuffer
public byte[] OutputBuffer
Public OutputBuffer As Byte()
Public OutputBuffer As Byte()
public:
array<unsigned char>^ OutputBuffer
public:
array<unsigned char>^ OutputBuffer
val mutable OutputBuffer: byte[]
val mutable OutputBuffer: byte[]
Field Value
array< Byte >[]()[][]


ResetDeflate Method

Keyoti RapidSpell Desktop .NET API Docs
ResetDeflate Method
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► ResetDeflate()()()()
Keyoti RapidSpell Desktop .NET
Reset a codec for another deflation session.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void ResetDeflate()
public void ResetDeflate()
Public Sub ResetDeflate
Public Sub ResetDeflate
public:
void ResetDeflate()
public:
void ResetDeflate()
member ResetDeflate : unit -> unit

member ResetDeflate : unit -> unit
Return Value

Z_OK if all goes well.
Remarks
Call this to reset the deflation state. For example if a thread is deflating non-consecutive blocks, you can call Reset() after the Deflate(Sync) of the first block and before the next Deflate(None) of the second block.


SetDeflateParams Method (level, strategy)

Keyoti RapidSpell Desktop .NET API Docs
SetDeflateParams Method (level, strategy)
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► SetDeflateParams(CompressionLevel, CompressionStrategy)
Keyoti RapidSpell Desktop .NET
Set the CompressionStrategy and CompressionLevel for a deflation session.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int SetDeflateParams(
    CompressionLevel level,
    CompressionStrategy strategy
)
public int SetDeflateParams(
    CompressionLevel level,
    CompressionStrategy strategy
)
Public Function SetDeflateParams (
    level As CompressionLevel,
    strategy As CompressionStrategy
) As Integer
Public Function SetDeflateParams (
    level As CompressionLevel,
    strategy As CompressionStrategy
) As Integer
public:
int SetDeflateParams(
    CompressionLevel level,
    CompressionStrategy strategy
)
public:
int SetDeflateParams(
    CompressionLevel level,
    CompressionStrategy strategy
)
member SetDeflateParams :
        level : CompressionLevel *
        strategy : CompressionStrategy -> int

member SetDeflateParams :
        level : CompressionLevel *
        strategy : CompressionStrategy -> int
Parameters
level (CompressionLevel)
the level of compression to use.
strategy (CompressionStrategy)
the strategy to use for compression.
Return Value
Int32
Z_OK if all goes well.


SetDictionary Method (dictionary)

Keyoti RapidSpell Desktop .NET API Docs
SetDictionary Method (dictionary)
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► SetDictionary(array<Byte>[]()[][])
Keyoti RapidSpell Desktop .NET
Set the dictionary to be used for either Inflation or Deflation.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int SetDictionary(
    byte[] dictionary
)
public int SetDictionary(
    byte[] dictionary
)
Public Function SetDictionary (
    dictionary As Byte()
) As Integer
Public Function SetDictionary (
    dictionary As Byte()
) As Integer
public:
int SetDictionary(
    array<unsigned char>^ dictionary
)
public:
int SetDictionary(
    array<unsigned char>^ dictionary
)
member SetDictionary :
        dictionary : byte[] -> int

member SetDictionary :
        dictionary : byte[] -> int
Parameters
dictionary (array< Byte >[]()[][])
The dictionary bytes to use.
Return Value
Int32
Z_OK if all goes well.


Strategy Field

Keyoti RapidSpell Desktop .NET API Docs
Strategy Field
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► Strategy
Keyoti RapidSpell Desktop .NET
The compression strategy to use.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public CompressionStrategy Strategy
public CompressionStrategy Strategy
Public Strategy As CompressionStrategy
Public Strategy As CompressionStrategy
public:
CompressionStrategy Strategy
public:
CompressionStrategy Strategy
val mutable Strategy: CompressionStrategy
val mutable Strategy: CompressionStrategy
Field Value
CompressionStrategy
Remarks
This is only effective in compression. The theory offered by ZLIB is that different strategies could potentially produce significant differences in compression behavior for different data sets. Unfortunately I don't have any good recommendations for how to set it differently. When I tested changing the strategy I got minimally different compression performance. It's best to leave this property alone if you don't have a good feel for it. Or, you may want to produce a test harness that runs through the different strategy options and evaluates them on different file types. If you do that, let me know your results.


SyncInflate Method

Keyoti RapidSpell Desktop .NET API Docs
SyncInflate Method
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► SyncInflate()()()()
Keyoti RapidSpell Desktop .NET
I don't know what this does!
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int SyncInflate()
public int SyncInflate()
Public Function SyncInflate As Integer
Public Function SyncInflate As Integer
public:
int SyncInflate()
public:
int SyncInflate()
member SyncInflate : unit -> int

member SyncInflate : unit -> int
Return Value
Int32
Z_OK if everything goes well.


TotalBytesIn Field

Keyoti RapidSpell Desktop .NET API Docs
TotalBytesIn Field
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► TotalBytesIn
Keyoti RapidSpell Desktop .NET
Total number of bytes read so far, through all calls to Inflate()/Deflate().
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public long TotalBytesIn
public long TotalBytesIn
Public TotalBytesIn As Long
Public TotalBytesIn As Long
public:
long long TotalBytesIn
public:
long long TotalBytesIn
val mutable TotalBytesIn: int64
val mutable TotalBytesIn: int64
Field Value
Int64


TotalBytesOut Field

Keyoti RapidSpell Desktop .NET API Docs
TotalBytesOut Field
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► TotalBytesOut
Keyoti RapidSpell Desktop .NET
Total number of bytes written to the output so far, through all calls to Inflate()/Deflate().
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public long TotalBytesOut
public long TotalBytesOut
Public TotalBytesOut As Long
Public TotalBytesOut As Long
public:
long long TotalBytesOut
public:
long long TotalBytesOut
val mutable TotalBytesOut: int64
val mutable TotalBytesOut: int64
Field Value
Int64


WindowBits Field

Keyoti RapidSpell Desktop .NET API Docs
WindowBits Field
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► WindowBits
Keyoti RapidSpell Desktop .NET
The number of Window Bits to use.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int WindowBits
public int WindowBits
Public WindowBits As Integer
Public WindowBits As Integer
public:
int WindowBits
public:
int WindowBits
val mutable WindowBits: int
val mutable WindowBits: int
Field Value
Int32
Remarks
This gauges the size of the sliding window, and hence the compression effectiveness as well as memory consumption. It's best to just leave this setting alone if you don't know what it is. The maximum value is 15 bits, which implies a 32k window.


ZlibConstants Class

Keyoti RapidSpell Desktop .NET API Docs
ZlibConstants Class
API ► Keyoti.RapidSpell.Compression ► ZlibConstants
Keyoti RapidSpell Desktop .NET
A bunch of constants used in the Zlib interface.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static class ZlibConstants
public static class ZlibConstants
Public NotInheritable Class ZlibConstants
Public NotInheritable Class ZlibConstants
public ref class ZlibConstants abstract sealed
public ref class ZlibConstants abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ZlibConstants =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ZlibConstants =  class end
Members
All Members | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | WindowBitsDefault | The default number of window bits for the Deflate algorithm.
 | WindowBitsMax | The maximum number of window bits for the Deflate algorithm.
 | WorkingBufferSizeDefault | The size of the working buffer used in the ZlibCodec class. Defaults to 8192 bytes.
 | WorkingBufferSizeMin | The minimum size of the working buffer used in the ZlibCodec class. Currently it is 128 bytes.
 | Z_BUF_ERROR | There was an error with the working buffer.
 | Z_DATA_ERROR | There was an error with the data - not enough data, bad data, etc.
 | Z_NEED_DICT | The operation ended in need of a dictionary.
 | Z_OK | indicates everything is A-OK
 | Z_STREAM_END | Indicates that the last operation reached the end of the stream.
 | Z_STREAM_ERROR | There was an error with the stream - not enough data, not open and readable, etc.
Inheritance Hierarchy
Object
ZlibConstants


WindowBitsDefault Field

Keyoti RapidSpell Desktop .NET API Docs
WindowBitsDefault Field
API ► Keyoti.RapidSpell.Compression ► ZlibConstants ► WindowBitsDefault
Keyoti RapidSpell Desktop .NET
The default number of window bits for the Deflate algorithm.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public const int WindowBitsDefault
public const int WindowBitsDefault
Public Const WindowBitsDefault As Integer
Public Const WindowBitsDefault As Integer
public:
literal int WindowBitsDefault
public:
literal int WindowBitsDefault
static val mutable WindowBitsDefault: int
static val mutable WindowBitsDefault: int
Field Value
Int32


WindowBitsMax Field

Keyoti RapidSpell Desktop .NET API Docs
WindowBitsMax Field
API ► Keyoti.RapidSpell.Compression ► ZlibConstants ► WindowBitsMax
Keyoti RapidSpell Desktop .NET
The maximum number of window bits for the Deflate algorithm.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public const int WindowBitsMax
public const int WindowBitsMax
Public Const WindowBitsMax As Integer
Public Const WindowBitsMax As Integer
public:
literal int WindowBitsMax
public:
literal int WindowBitsMax
static val mutable WindowBitsMax: int
static val mutable WindowBitsMax: int
Field Value
Int32


WorkingBufferSizeDefault Field

Keyoti RapidSpell Desktop .NET API Docs
WorkingBufferSizeDefault Field
API ► Keyoti.RapidSpell.Compression ► ZlibConstants ► WorkingBufferSizeDefault
Keyoti RapidSpell Desktop .NET
The size of the working buffer used in the ZlibCodec class. Defaults to 8192 bytes.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public const int WorkingBufferSizeDefault
public const int WorkingBufferSizeDefault
Public Const WorkingBufferSizeDefault As Integer
Public Const WorkingBufferSizeDefault As Integer
public:
literal int WorkingBufferSizeDefault
public:
literal int WorkingBufferSizeDefault
static val mutable WorkingBufferSizeDefault: int
static val mutable WorkingBufferSizeDefault: int
Field Value
Int32


WorkingBufferSizeMin Field

Keyoti RapidSpell Desktop .NET API Docs
WorkingBufferSizeMin Field
API ► Keyoti.RapidSpell.Compression ► ZlibConstants ► WorkingBufferSizeMin
Keyoti RapidSpell Desktop .NET
The minimum size of the working buffer used in the ZlibCodec class. Currently it is 128 bytes.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public const int WorkingBufferSizeMin
public const int WorkingBufferSizeMin
Public Const WorkingBufferSizeMin As Integer
Public Const WorkingBufferSizeMin As Integer
public:
literal int WorkingBufferSizeMin
public:
literal int WorkingBufferSizeMin
static val mutable WorkingBufferSizeMin: int
static val mutable WorkingBufferSizeMin: int
Field Value
Int32


Z_BUF_ERROR Field

Keyoti RapidSpell Desktop .NET API Docs
Z_BUF_ERROR Field
API ► Keyoti.RapidSpell.Compression ► ZlibConstants ► Z_BUF_ERROR
Keyoti RapidSpell Desktop .NET
There was an error with the working buffer.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public const int Z_BUF_ERROR
public const int Z_BUF_ERROR
Public Const Z_BUF_ERROR As Integer
Public Const Z_BUF_ERROR As Integer
public:
literal int Z_BUF_ERROR
public:
literal int Z_BUF_ERROR
static val mutable Z_BUF_ERROR: int
static val mutable Z_BUF_ERROR: int
Field Value
Int32


Z_DATA_ERROR Field

Keyoti RapidSpell Desktop .NET API Docs
Z_DATA_ERROR Field
API ► Keyoti.RapidSpell.Compression ► ZlibConstants ► Z_DATA_ERROR
Keyoti RapidSpell Desktop .NET
There was an error with the data - not enough data, bad data, etc.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public const int Z_DATA_ERROR
public const int Z_DATA_ERROR
Public Const Z_DATA_ERROR As Integer
Public Const Z_DATA_ERROR As Integer
public:
literal int Z_DATA_ERROR
public:
literal int Z_DATA_ERROR
static val mutable Z_DATA_ERROR: int
static val mutable Z_DATA_ERROR: int
Field Value
Int32


Z_NEED_DICT Field

Keyoti RapidSpell Desktop .NET API Docs
Z_NEED_DICT Field
API ► Keyoti.RapidSpell.Compression ► ZlibConstants ► Z_NEED_DICT
Keyoti RapidSpell Desktop .NET
The operation ended in need of a dictionary.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public const int Z_NEED_DICT
public const int Z_NEED_DICT
Public Const Z_NEED_DICT As Integer
Public Const Z_NEED_DICT As Integer
public:
literal int Z_NEED_DICT
public:
literal int Z_NEED_DICT
static val mutable Z_NEED_DICT: int
static val mutable Z_NEED_DICT: int
Field Value
Int32


Z_OK Field

Keyoti RapidSpell Desktop .NET API Docs
Z_OK Field
API ► Keyoti.RapidSpell.Compression ► ZlibConstants ► Z_OK
Keyoti RapidSpell Desktop .NET
indicates everything is A-OK
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public const int Z_OK
public const int Z_OK
Public Const Z_OK As Integer
Public Const Z_OK As Integer
public:
literal int Z_OK
public:
literal int Z_OK
static val mutable Z_OK: int
static val mutable Z_OK: int
Field Value
Int32


Z_STREAM_END Field

Keyoti RapidSpell Desktop .NET API Docs
Z_STREAM_END Field
API ► Keyoti.RapidSpell.Compression ► ZlibConstants ► Z_STREAM_END
Keyoti RapidSpell Desktop .NET
Indicates that the last operation reached the end of the stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public const int Z_STREAM_END
public const int Z_STREAM_END
Public Const Z_STREAM_END As Integer
Public Const Z_STREAM_END As Integer
public:
literal int Z_STREAM_END
public:
literal int Z_STREAM_END
static val mutable Z_STREAM_END: int
static val mutable Z_STREAM_END: int
Field Value
Int32


Z_STREAM_ERROR Field

Keyoti RapidSpell Desktop .NET API Docs
Z_STREAM_ERROR Field
API ► Keyoti.RapidSpell.Compression ► ZlibConstants ► Z_STREAM_ERROR
Keyoti RapidSpell Desktop .NET
There was an error with the stream - not enough data, not open and readable, etc.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public const int Z_STREAM_ERROR
public const int Z_STREAM_ERROR
Public Const Z_STREAM_ERROR As Integer
Public Const Z_STREAM_ERROR As Integer
public:
literal int Z_STREAM_ERROR
public:
literal int Z_STREAM_ERROR
static val mutable Z_STREAM_ERROR: int
static val mutable Z_STREAM_ERROR: int
Field Value
Int32


ZlibException Class

Keyoti RapidSpell Desktop .NET API Docs
ZlibException Class
API ► Keyoti.RapidSpell.Compression ► ZlibException
Keyoti RapidSpell Desktop .NET
A general purpose exception class for exceptions in the Zlib library.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class ZlibException : Exception
public class ZlibException : Exception
Public Class ZlibException
    Inherits Exception
Public Class ZlibException
    Inherits Exception
public ref class ZlibException : public Exception
public ref class ZlibException : public Exception
type ZlibException =
    class
        inherit Exception
    end
type ZlibException =
    class
        inherit Exception
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZlibException()()()() | The ZlibException class captures exception information generated by the Zlib library.
 | ZlibException(String) | This ctor collects a message attached to the exception.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | ZlibException


ZlibException Constructor

Keyoti RapidSpell Desktop .NET API Docs
ZlibException Constructor
API ► Keyoti.RapidSpell.Compression ► ZlibException ► ZlibException()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | ZlibException()()()() | The ZlibException class captures exception information generated by the Zlib library.
 | ZlibException(String) | This ctor collects a message attached to the exception.


ZlibException Constructor

Keyoti RapidSpell Desktop .NET API Docs
ZlibException Constructor
API ► Keyoti.RapidSpell.Compression ► ZlibException ► ZlibException()()()()
Keyoti RapidSpell Desktop .NET
The ZlibException class captures exception information generated by the Zlib library.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ZlibException()
public ZlibException()
Public Sub New
Public Sub New
public:
ZlibException()
public:
ZlibException()
new : unit -> ZlibException
new : unit -> ZlibException


ZlibException Constructor (s)

Keyoti RapidSpell Desktop .NET API Docs
ZlibException Constructor (s)
API ► Keyoti.RapidSpell.Compression ► ZlibException ► ZlibException(String)
Keyoti RapidSpell Desktop .NET
This ctor collects a message attached to the exception.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ZlibException(
    string s
)
public ZlibException(
    string s
)
Public Sub New (
    s As String
)
Public Sub New (
    s As String
)
public:
ZlibException(
    String^ s
)
public:
ZlibException(
    String^ s
)
new :
        s : string -> ZlibException
new :
        s : string -> ZlibException
Parameters
s (String)


ZlibStream Class

Keyoti RapidSpell Desktop .NET API Docs
ZlibStream Class
API ► Keyoti.RapidSpell.Compression ► ZlibStream
Keyoti RapidSpell Desktop .NET
Represents a Zlib stream for compression or decompression.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class ZlibStream : Stream
public class ZlibStream : Stream
Public Class ZlibStream
    Inherits Stream
Public Class ZlibStream
    Inherits Stream
public ref class ZlibStream : public Stream
public ref class ZlibStream : public Stream
type ZlibStream =
    class
        inherit Stream
    end
type ZlibStream =
    class
        inherit Stream
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZlibStream(Stream, CompressionMode) | Create a ZlibStream using the specified CompressionMode.
 | ZlibStream(Stream, CompressionMode, CompressionLevel) | Create a ZlibStream using the specified CompressionMode and the specified CompressionLevel.
 | ZlibStream(Stream, CompressionMode, Boolean) | Create a ZlibStream using the specified CompressionMode, and explicitly specify whether the captive stream should be left open after Deflation or Inflation.
 | ZlibStream(Stream, CompressionMode, CompressionLevel, Boolean) | Create a ZlibStream using the specified CompressionMode and the specified CompressionLevel, and explicitly specify whether the stream should be left open after Deflation or Inflation.
 | BeginRead(array<Byte>[]()[][], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous read operation. (Inherited from Stream.)
 | BeginWrite(array<Byte>[]()[][], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous write operation. (Inherited from Stream.)
 | BufferSize | The size of the working buffer for the compression codec.
 | CanRead | Indicates whether the stream can be read. (Overrides Stream.CanRead.)
 | CanSeek | Indicates whether the stream supports Seek operations. (Overrides Stream.CanSeek.)
 | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
 | CanWrite | Indicates whether the stream can be written. (Overrides Stream.CanWrite.)
 | Close()()()() | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. (Inherited from Stream.)
 | CompressBuffer(array<Byte>[]()[][]) | Compress a byte array into a new byte array using ZLIB.
 | CompressString(String) | Compress a string into a byte array using ZLIB.
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateWaitHandle()()()() | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
 | Dispose(Boolean) | Dispose the stream. (Overrides Stream.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Stream. (Inherited from Stream.)
 | EndRead(IAsyncResult) | Waits for the pending asynchronous read to complete. (Inherited from Stream.)
 | EndWrite(IAsyncResult) | Ends an asynchronous write operation. (Inherited from Stream.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | Flush()()()() | Flush the stream. (Overrides Stream.Flush()()()().)
 | FlushMode | This property sets the flush behavior on the stream. Sorry, though, not sure exactly how to describe all the various settings.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | Length | Reading this property always throws a NotImplementedException. (Overrides Stream.Length.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Position | The position of the stream pointer. (Overrides Stream.Position.)
 | Read(array<Byte>[]()[][], Int32, Int32) | Read data from the stream. (Overrides Stream.Read(array<Byte>[]()[][], Int32, Int32).)
 | ReadByte()()()() | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
 | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
 | Seek(Int64, SeekOrigin) | Calling this method always throws a NotImplementedException. (Overrides Stream.Seek(Int64, SeekOrigin).)
 | SetLength(Int64) | Calling this method always throws a NotImplementedException. (Overrides Stream.SetLength(Int64).)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | TotalIn | Returns the total number of bytes input so far.
 | TotalOut | Returns the total number of bytes output so far.
 | UncompressBuffer(array<Byte>[]()[][]) | Uncompress a ZLIB-compressed byte array into a byte array.
 | UncompressString(array<Byte>[]()[][]) | Uncompress a ZLIB-compressed byte array into a single string.
 | Write(array<Byte>[]()[][], Int32, Int32) | Write data to the stream. (Overrides Stream.Write(array<Byte>[]()[][], Int32, Int32).)
 | WriteByte(Byte) | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
 | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Remarks

The ZlibStream is a Decorator on a Stream. It adds ZLIB compression or decompression to any stream.

Using this stream, applications can compress or decompress data via stream Read() and Write() operations. Either compresssion or decompression can occur through either reading or writing. The compression format used is ZLIB, which is documented in IETF RFC 1950, "ZLIB Compressed Data Format Specification version 3.3". This implementation of ZLIB always uses DEFLATE as the compression method. (see IETF RFC 1951, "DEFLATE Compressed Data Format Specification version 1.3.")

The ZLIB format allows for varying compression methods, window sizes, and dictionaries. This implementation always uses the DEFLATE compression method, a preset dictionary, and 15 window bits by default.

This class is similar to DeflateStream, except that it adds the RFC1950 header and trailer bytes to a compressed stream when compressing, or expects the RFC1950 header and trailer bytes when decompressing. It is also similar to the GZipStream.

Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Stream
 |  |  | ZlibStream
See Also
DeflateStream
GZipStream


ZlibStream Constructor

Keyoti RapidSpell Desktop .NET API Docs
ZlibStream Constructor
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► ZlibStream()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | ZlibStream(Stream, CompressionMode) | Create a ZlibStream using the specified CompressionMode.
 | ZlibStream(Stream, CompressionMode, CompressionLevel) | Create a ZlibStream using the specified CompressionMode and the specified CompressionLevel.
 | ZlibStream(Stream, CompressionMode, Boolean) | Create a ZlibStream using the specified CompressionMode, and explicitly specify whether the captive stream should be left open after Deflation or Inflation.
 | ZlibStream(Stream, CompressionMode, CompressionLevel, Boolean) | Create a ZlibStream using the specified CompressionMode and the specified CompressionLevel, and explicitly specify whether the stream should be left open after Deflation or Inflation.


ZlibStream Constructor (stream, mode)

Keyoti RapidSpell Desktop .NET API Docs
ZlibStream Constructor (stream, mode)
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► ZlibStream(Stream, CompressionMode)
Keyoti RapidSpell Desktop .NET
Create a ZlibStream using the specified CompressionMode.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ZlibStream(
    Stream stream,
    CompressionMode mode
)
public ZlibStream(
    Stream stream,
    CompressionMode mode
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode
)
public:
ZlibStream(
    Stream^ stream,
    CompressionMode mode
)
public:
ZlibStream(
    Stream^ stream,
    CompressionMode mode
)
new :
        stream : Stream *
        mode : CompressionMode -> ZlibStream
new :
        stream : Stream *
        mode : CompressionMode -> ZlibStream
Parameters
stream (Stream)
The stream which will be read or written.
mode (CompressionMode)
Indicates whether the ZlibStream will compress or decompress.
Remarks

When mode is CompressionMode.Compress, the ZlibStream will use the default compression level. The "captive" stream will be closed when the ZlibStream is closed.

Examples
This example uses a ZlibStream to compress a file, and writes the compressed data to another file.
Copy image Copy
using (System.IO.Stream input = System.IO.File.OpenRead(fileToCompress))
{
    using (var raw = System.IO.File.Create(fileToCompress + ".zlib"))
    {
        using (Stream compressor = new ZlibStream(raw, CompressionMode.Compress))
        {
            byte[] buffer = new byte[WORKING_BUFFER_SIZE];
            int n;
            while ((n= input.Read(buffer, 0, buffer.Length)) != 0)
            {
                compressor.Write(buffer, 0, n);
            }
        }
    }
}
Visual Basic Copy image Copy
Using input As Stream = File.OpenRead(fileToCompress)
    Using raw As FileStream = File.Create(fileToCompress & ".zlib")
    Using compressor As Stream = New ZlibStream(raw, CompressionMode.Compress)
        Dim buffer As Byte() = New Byte(4096) {}
        Dim n As Integer = -1
        Do While (n <> 0)
            If (n > 0) Then
                compressor.Write(buffer, 0, n)
            End If
            n = input.Read(buffer, 0, buffer.Length)
        Loop
    End Using
    End Using
End Using


ZlibStream Constructor (stream, mode, level)

Keyoti RapidSpell Desktop .NET API Docs
ZlibStream Constructor (stream, mode, level)
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► ZlibStream(Stream, CompressionMode, CompressionLevel)
Keyoti RapidSpell Desktop .NET
Create a ZlibStream using the specified CompressionMode and the specified CompressionLevel.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ZlibStream(
    Stream stream,
    CompressionMode mode,
    CompressionLevel level
)
public ZlibStream(
    Stream stream,
    CompressionMode mode,
    CompressionLevel level
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode,
    level As CompressionLevel
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode,
    level As CompressionLevel
)
public:
ZlibStream(
    Stream^ stream,
    CompressionMode mode,
    CompressionLevel level
)
public:
ZlibStream(
    Stream^ stream,
    CompressionMode mode,
    CompressionLevel level
)
new :
        stream : Stream *
        mode : CompressionMode *
        level : CompressionLevel -> ZlibStream
new :
        stream : Stream *
        mode : CompressionMode *
        level : CompressionLevel -> ZlibStream
Parameters
stream (Stream)
The stream to be read or written while deflating or inflating.
mode (CompressionMode)
Indicates whether the ZlibStream will compress or decompress.
level (CompressionLevel)
A tuning knob to trade speed for effectiveness.
Remarks

When mode is CompressionMode.Decompress, the level parameter is ignored. The "captive" stream will be closed when the ZlibStream is closed.

Examples
This example uses a ZlibStream to compress data from a file, and writes the compressed data to another file.
Copy image Copy
using (System.IO.Stream input = System.IO.File.OpenRead(fileToCompress))
{
    using (var raw = System.IO.File.Create(fileToCompress + ".zlib"))
    {
        using (Stream compressor = new ZlibStream(raw,
                                                  CompressionMode.Compress,
                                                  CompressionLevel.BestCompression))
        {
            byte[] buffer = new byte[WORKING_BUFFER_SIZE];
            int n;
            while ((n= input.Read(buffer, 0, buffer.Length)) != 0)
            {
                compressor.Write(buffer, 0, n);
            }
        }
    }
}
Visual Basic Copy image Copy
Using input As Stream = File.OpenRead(fileToCompress)
    Using raw As FileStream = File.Create(fileToCompress & ".zlib")
        Using compressor As Stream = New ZlibStream(raw, CompressionMode.Compress, CompressionLevel.BestCompression)
            Dim buffer As Byte() = New Byte(4096) {}
            Dim n As Integer = -1
            Do While (n <> 0)
                If (n > 0) Then
                    compressor.Write(buffer, 0, n)
                End If
                n = input.Read(buffer, 0, buffer.Length)
            Loop
        End Using
    End Using
End Using


ZlibStream Constructor (stream, mode, level, leaveOpen)

Keyoti RapidSpell Desktop .NET API Docs
ZlibStream Constructor (stream, mode, level, leaveOpen)
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► ZlibStream(Stream, CompressionMode, CompressionLevel, Boolean)
Keyoti RapidSpell Desktop .NET
Create a ZlibStream using the specified CompressionMode and the specified CompressionLevel, and explicitly specify whether the stream should be left open after Deflation or Inflation.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ZlibStream(
    Stream stream,
    CompressionMode mode,
    CompressionLevel level,
    bool leaveOpen
)
public ZlibStream(
    Stream stream,
    CompressionMode mode,
    CompressionLevel level,
    bool leaveOpen
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode,
    level As CompressionLevel,
    leaveOpen As Boolean
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode,
    level As CompressionLevel,
    leaveOpen As Boolean
)
public:
ZlibStream(
    Stream^ stream,
    CompressionMode mode,
    CompressionLevel level,
    bool leaveOpen
)
public:
ZlibStream(
    Stream^ stream,
    CompressionMode mode,
    CompressionLevel level,
    bool leaveOpen
)
new :
        stream : Stream *
        mode : CompressionMode *
        level : CompressionLevel *
        leaveOpen : bool -> ZlibStream
new :
        stream : Stream *
        mode : CompressionMode *
        level : CompressionLevel *
        leaveOpen : bool -> ZlibStream
Parameters
stream (Stream)
The stream which will be read or written.
mode (CompressionMode)
Indicates whether the ZlibStream will compress or decompress.
level (CompressionLevel)
A tuning knob to trade speed for effectiveness. This parameter is effective only when mode is CompressionMode.Compress.
leaveOpen (Boolean)
true if the application would like the stream to remain open after inflation/deflation.
Remarks

This constructor allows the application to request that the captive stream remain open after the deflation or inflation occurs. By default, after Close() is called on the stream, the captive stream is also closed. In some cases this is not desired, for example if the stream is a MemoryStream that will be re-read after compression. Specify true for the leaveOpen parameter to leave the stream open.

When mode is CompressionMode.Decompress, the level parameter is ignored.

Examples
This example shows how to use a ZlibStream to compress the data from a file, and store the result into another file. The filestream remains open to allow additional data to be written to it.
Copy image Copy
using (var output = System.IO.File.Create(fileToCompress + ".zlib"))
{
    using (System.IO.Stream input = System.IO.File.OpenRead(fileToCompress))
    {
        using (Stream compressor = new ZlibStream(output, CompressionMode.Compress, CompressionLevel.BestCompression, true))
        {
            byte[] buffer = new byte[WORKING_BUFFER_SIZE];
            int n;
            while ((n= input.Read(buffer, 0, buffer.Length)) != 0)
            {
                compressor.Write(buffer, 0, n);
            }
        }
    }
    // can write additional data to the output stream here
}
Visual Basic Copy image Copy
Using output As FileStream = File.Create(fileToCompress & ".zlib")
    Using input As Stream = File.OpenRead(fileToCompress)
        Using compressor As Stream = New ZlibStream(output, CompressionMode.Compress, CompressionLevel.BestCompression, True)
            Dim buffer As Byte() = New Byte(4096) {}
            Dim n As Integer = -1
            Do While (n <> 0)
                If (n > 0) Then
                    compressor.Write(buffer, 0, n)
                End If
                n = input.Read(buffer, 0, buffer.Length)
            Loop
        End Using
    End Using
    ' can write additional data to the output stream here.
End Using


ZlibStream Constructor (stream, mode, leaveOpen)

Keyoti RapidSpell Desktop .NET API Docs
ZlibStream Constructor (stream, mode, leaveOpen)
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► ZlibStream(Stream, CompressionMode, Boolean)
Keyoti RapidSpell Desktop .NET
Create a ZlibStream using the specified CompressionMode, and explicitly specify whether the captive stream should be left open after Deflation or Inflation.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ZlibStream(
    Stream stream,
    CompressionMode mode,
    bool leaveOpen
)
public ZlibStream(
    Stream stream,
    CompressionMode mode,
    bool leaveOpen
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode,
    leaveOpen As Boolean
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode,
    leaveOpen As Boolean
)
public:
ZlibStream(
    Stream^ stream,
    CompressionMode mode,
    bool leaveOpen
)
public:
ZlibStream(
    Stream^ stream,
    CompressionMode mode,
    bool leaveOpen
)
new :
        stream : Stream *
        mode : CompressionMode *
        leaveOpen : bool -> ZlibStream
new :
        stream : Stream *
        mode : CompressionMode *
        leaveOpen : bool -> ZlibStream
Parameters
stream (Stream)
The stream which will be read or written. This is called the "captive" stream in other places in this documentation.
mode (CompressionMode)
Indicates whether the ZlibStream will compress or decompress.
leaveOpen (Boolean)
true if the application would like the stream to remain open after inflation/deflation.
Remarks

When mode is CompressionMode.Compress, the ZlibStream will use the default compression level.

This constructor allows the application to request that the captive stream remain open after the deflation or inflation occurs. By default, after Close() is called on the stream, the captive stream is also closed. In some cases this is not desired, for example if the stream is a MemoryStream that will be re-read after compression. Specify true for the leaveOpen parameter to leave the stream open.

See the other overloads of this constructor for example code.


BufferSize Property

Keyoti RapidSpell Desktop .NET API Docs
BufferSize Property
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► BufferSize
Keyoti RapidSpell Desktop .NET
The size of the working buffer for the compression codec.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int BufferSize { get; set; }
public int BufferSize { get; set; }
Public Property BufferSize As Integer
    Get
    Set
Public Property BufferSize As Integer
    Get
    Set
public:
property int BufferSize {
    int get ();
    void set (int value);
}
public:
property int BufferSize {
    int get ();
    void set (int value);
}
member BufferSize : int with get, set

member BufferSize : int with get, set
Property Value
Int32
Remarks

The working buffer is used for all stream operations. The default size is 1024 bytes. The minimum size is 128 bytes. You may get better performance with a larger buffer. Then again, you might not. You would have to test it.

Set this before the first call to Read() or Write() on the stream. If you try to set it afterwards, it will throw.


CanRead Property

Keyoti RapidSpell Desktop .NET API Docs
CanRead Property
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► CanRead
Keyoti RapidSpell Desktop .NET
Indicates whether the stream can be read.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override bool CanRead { get; }
public override bool CanRead { get; }
Public Overrides ReadOnly Property CanRead As Boolean
    Get
Public Overrides ReadOnly Property CanRead As Boolean
    Get
public:
virtual property bool CanRead {
    bool get () override;
}
public:
virtual property bool CanRead {
    bool get () override;
}
abstract CanRead : bool with get
override CanRead : bool with get
abstract CanRead : bool with get
override CanRead : bool with get
Property Value
Boolean
Remarks
The return value depends on whether the captive stream supports reading.


CanSeek Property

Keyoti RapidSpell Desktop .NET API Docs
CanSeek Property
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► CanSeek
Keyoti RapidSpell Desktop .NET
Indicates whether the stream supports Seek operations.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override bool CanSeek { get; }
public override bool CanSeek { get; }
Public Overrides ReadOnly Property CanSeek As Boolean
    Get
Public Overrides ReadOnly Property CanSeek As Boolean
    Get
public:
virtual property bool CanSeek {
    bool get () override;
}
public:
virtual property bool CanSeek {
    bool get () override;
}
abstract CanSeek : bool with get
override CanSeek : bool with get
abstract CanSeek : bool with get
override CanSeek : bool with get
Property Value
Boolean
Remarks
Always returns false.


CanWrite Property

Keyoti RapidSpell Desktop .NET API Docs
CanWrite Property
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► CanWrite
Keyoti RapidSpell Desktop .NET
Indicates whether the stream can be written.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override bool CanWrite { get; }
public override bool CanWrite { get; }
Public Overrides ReadOnly Property CanWrite As Boolean
    Get
Public Overrides ReadOnly Property CanWrite As Boolean
    Get
public:
virtual property bool CanWrite {
    bool get () override;
}
public:
virtual property bool CanWrite {
    bool get () override;
}
abstract CanWrite : bool with get
override CanWrite : bool with get
abstract CanWrite : bool with get
override CanWrite : bool with get
Property Value
Boolean
Remarks
The return value depends on whether the captive stream supports writing.


CompressBuffer Method (b)

Keyoti RapidSpell Desktop .NET API Docs
CompressBuffer Method (b)
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► CompressBuffer(array<Byte>[]()[][])
Keyoti RapidSpell Desktop .NET
Compress a byte array into a new byte array using ZLIB.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static byte[] CompressBuffer(
    byte[] b
)
public static byte[] CompressBuffer(
    byte[] b
)
Public Shared Function CompressBuffer (
    b As Byte()
) As Byte()
Public Shared Function CompressBuffer (
    b As Byte()
) As Byte()
public:
static array<unsigned char>^ CompressBuffer(
    array<unsigned char>^ b
)
public:
static array<unsigned char>^ CompressBuffer(
    array<unsigned char>^ b
)
static member CompressBuffer :
        b : byte[] -> byte[]

static member CompressBuffer :
        b : byte[] -> byte[]
Parameters
b (array< Byte >[]()[][])
A buffer to compress.
Return Value
array< Byte >[]()[][]
The data in compressed form
Remarks
Uncompress it with UncompressBuffer(array<Byte>[]()[][]).
See Also
CompressString(String)
UncompressBuffer(array<Byte>[]()[][])


CompressString Method (s)

Keyoti RapidSpell Desktop .NET API Docs
CompressString Method (s)
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► CompressString(String)
Keyoti RapidSpell Desktop .NET
Compress a string into a byte array using ZLIB.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static byte[] CompressString(
    string s
)
public static byte[] CompressString(
    string s
)
Public Shared Function CompressString (
    s As String
) As Byte()
Public Shared Function CompressString (
    s As String
) As Byte()
public:
static array<unsigned char>^ CompressString(
    String^ s
)
public:
static array<unsigned char>^ CompressString(
    String^ s
)
static member CompressString :
        s : string -> byte[]

static member CompressString :
        s : string -> byte[]
Parameters
s (String)
A string to compress. The string will first be encoded using UTF8, then compressed.
Return Value
array< Byte >[]()[][]
The string in compressed form
Remarks
Uncompress it with UncompressString(array<Byte>[]()[][]).
See Also
UncompressString(array<Byte>[]()[][])
CompressBuffer(array<Byte>[]()[][])
CompressString(String)


Dispose Method (disposing)

Keyoti RapidSpell Desktop .NET API Docs
Dispose Method (disposing)
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► Dispose(Boolean)
Keyoti RapidSpell Desktop .NET
Dispose the stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
Parameters
disposing (Boolean)
Remarks
This may or may not result in a Close() call on the captive stream. See the constructors that have a leaveOpen parameter for more information.


Flush Method

Keyoti RapidSpell Desktop .NET API Docs
Flush Method
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► Flush()()()()
Keyoti RapidSpell Desktop .NET
Flush the stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override void Flush()
public override void Flush()
Public Overrides Sub Flush
Public Overrides Sub Flush
public:
virtual void Flush() override
public:
virtual void Flush() override
abstract Flush : unit -> unit
override Flush : unit -> unit
abstract Flush : unit -> unit
override Flush : unit -> unit


FlushMode Property

Keyoti RapidSpell Desktop .NET API Docs
FlushMode Property
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► FlushMode
Keyoti RapidSpell Desktop .NET
This property sets the flush behavior on the stream. Sorry, though, not sure exactly how to describe all the various settings.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual FlushType FlushMode { get; set; }
public virtual FlushType FlushMode { get; set; }
Public Overridable Property FlushMode As FlushType
    Get
    Set
Public Overridable Property FlushMode As FlushType
    Get
    Set
public:
virtual property FlushType FlushMode {
    FlushType get ();
    void set (FlushType value);
}
public:
virtual property FlushType FlushMode {
    FlushType get ();
    void set (FlushType value);
}
abstract FlushMode : FlushType with get, set
override FlushMode : FlushType with get, set
abstract FlushMode : FlushType with get, set
override FlushMode : FlushType with get, set
Property Value
FlushType


Length Property

Keyoti RapidSpell Desktop .NET API Docs
Length Property
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► Length
Keyoti RapidSpell Desktop .NET
Reading this property always throws a NotImplementedException.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override long Length { get; }
public override long Length { get; }
Public Overrides ReadOnly Property Length As Long
    Get
Public Overrides ReadOnly Property Length As Long
    Get
public:
virtual property long long Length {
    long long get () override;
}
public:
virtual property long long Length {
    long long get () override;
}
abstract Length : int64 with get
override Length : int64 with get
abstract Length : int64 with get
override Length : int64 with get
Property Value
Int64


Position Property

Keyoti RapidSpell Desktop .NET API Docs
Position Property
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► Position
Keyoti RapidSpell Desktop .NET
The position of the stream pointer.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override long Position { get; set; }
public override long Position { get; set; }
Public Overrides Property Position As Long
    Get
    Set
Public Overrides Property Position As Long
    Get
    Set
public:
virtual property long long Position {
    long long get () override;
    void set (long long value) override;
}
public:
virtual property long long Position {
    long long get () override;
    void set (long long value) override;
}
abstract Position : int64 with get, set
override Position : int64 with get, set
abstract Position : int64 with get, set
override Position : int64 with get, set
Property Value
Int64
Remarks
Setting this property always throws a NotImplementedException. Reading will return the total bytes written out, if used in writing, or the total bytes read in, if used in reading. The count may refer to compressed bytes or uncompressed bytes, depending on how you've used the stream.


Read Method (buffer, offset, count)

Keyoti RapidSpell Desktop .NET API Docs
Read Method (buffer, offset, count)
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► Read(array<Byte>[]()[][], Int32, Int32)
Keyoti RapidSpell Desktop .NET
Read data from the stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Function Read (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
Public Overrides Function Read (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
abstract Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
override Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
abstract Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
override Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
Parameters
buffer (array< Byte >[]()[][])
The buffer into which the read data should be placed.
offset (Int32)
the offset within that data array to put the first byte read.
count (Int32)
the number of bytes to read.
Return Value
Int32
Remarks

If you wish to use the ZlibStream to compress data while reading, you can create a ZlibStream with CompressionMode.Compress, providing an uncompressed data stream. Then call Read() on that ZlibStream, and the data read will be compressed. If you wish to use the ZlibStream to decompress data while reading, you can create a ZlibStream with CompressionMode.Decompress, providing a readable compressed data stream. Then call Read() on that ZlibStream, and the data will be decompressed as it is read.

A ZlibStream can be used for Read() or Write(), but not both.


Seek Method (offset, origin)

Keyoti RapidSpell Desktop .NET API Docs
Seek Method (offset, origin)
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► Seek(Int64, SeekOrigin)
Keyoti RapidSpell Desktop .NET
Calling this method always throws a NotImplementedException.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override long Seek(
    long offset,
    SeekOrigin origin
)
public override long Seek(
    long offset,
    SeekOrigin origin
)
Public Overrides Function Seek (
    offset As Long,
    origin As SeekOrigin
) As Long
Public Overrides Function Seek (
    offset As Long,
    origin As SeekOrigin
) As Long
public:
virtual long long Seek(
    long long offset,
    SeekOrigin origin
) override
public:
virtual long long Seek(
    long long offset,
    SeekOrigin origin
) override
abstract Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
override Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
abstract Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
override Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
Parameters
offset (Int64)
origin (SeekOrigin)
Return Value
Int64


SetLength Method (value)

Keyoti RapidSpell Desktop .NET API Docs
SetLength Method (value)
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► SetLength(Int64)
Keyoti RapidSpell Desktop .NET
Calling this method always throws a NotImplementedException.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override void SetLength(
    long value
)
public override void SetLength(
    long value
)
Public Overrides Sub SetLength (
    value As Long
)
Public Overrides Sub SetLength (
    value As Long
)
public:
virtual void SetLength(
    long long value
) override
public:
virtual void SetLength(
    long long value
) override
abstract SetLength :
        value : int64 -> unit
override SetLength :
        value : int64 -> unit
abstract SetLength :
        value : int64 -> unit
override SetLength :
        value : int64 -> unit
Parameters
value (Int64)


TotalIn Property

Keyoti RapidSpell Desktop .NET API Docs
TotalIn Property
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► TotalIn
Keyoti RapidSpell Desktop .NET
Returns the total number of bytes input so far.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual long TotalIn { get; }
public virtual long TotalIn { get; }
Public Overridable ReadOnly Property TotalIn As Long
    Get
Public Overridable ReadOnly Property TotalIn As Long
    Get
public:
virtual property long long TotalIn {
    long long get ();
}
public:
virtual property long long TotalIn {
    long long get ();
}
abstract TotalIn : int64 with get
override TotalIn : int64 with get
abstract TotalIn : int64 with get
override TotalIn : int64 with get
Property Value
Int64


TotalOut Property

Keyoti RapidSpell Desktop .NET API Docs
TotalOut Property
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► TotalOut
Keyoti RapidSpell Desktop .NET
Returns the total number of bytes output so far.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual long TotalOut { get; }
public virtual long TotalOut { get; }
Public Overridable ReadOnly Property TotalOut As Long
    Get
Public Overridable ReadOnly Property TotalOut As Long
    Get
public:
virtual property long long TotalOut {
    long long get ();
}
public:
virtual property long long TotalOut {
    long long get ();
}
abstract TotalOut : int64 with get
override TotalOut : int64 with get
abstract TotalOut : int64 with get
override TotalOut : int64 with get
Property Value
Int64


UncompressBuffer Method (compressed)

Keyoti RapidSpell Desktop .NET API Docs
UncompressBuffer Method (compressed)
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► UncompressBuffer(array<Byte>[]()[][])
Keyoti RapidSpell Desktop .NET
Uncompress a ZLIB-compressed byte array into a byte array.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static byte[] UncompressBuffer(
    byte[] compressed
)
public static byte[] UncompressBuffer(
    byte[] compressed
)
Public Shared Function UncompressBuffer (
    compressed As Byte()
) As Byte()
Public Shared Function UncompressBuffer (
    compressed As Byte()
) As Byte()
public:
static array<unsigned char>^ UncompressBuffer(
    array<unsigned char>^ compressed
)
public:
static array<unsigned char>^ UncompressBuffer(
    array<unsigned char>^ compressed
)
static member UncompressBuffer :
        compressed : byte[] -> byte[]

static member UncompressBuffer :
        compressed : byte[] -> byte[]
Parameters
compressed (array< Byte >[]()[][])
A buffer containing ZLIB-compressed data.
Return Value
array< Byte >[]()[][]
The data in uncompressed form
See Also
CompressBuffer(array<Byte>[]()[][])
UncompressString(array<Byte>[]()[][])


UncompressString Method (compressed)

Keyoti RapidSpell Desktop .NET API Docs
UncompressString Method (compressed)
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► UncompressString(array<Byte>[]()[][])
Keyoti RapidSpell Desktop .NET
Uncompress a ZLIB-compressed byte array into a single string.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static string UncompressString(
    byte[] compressed
)
public static string UncompressString(
    byte[] compressed
)
Public Shared Function UncompressString (
    compressed As Byte()
) As String
Public Shared Function UncompressString (
    compressed As Byte()
) As String
public:
static String^ UncompressString(
    array<unsigned char>^ compressed
)
public:
static String^ UncompressString(
    array<unsigned char>^ compressed
)
static member UncompressString :
        compressed : byte[] -> string

static member UncompressString :
        compressed : byte[] -> string
Parameters
compressed (array< Byte >[]()[][])
A buffer containing ZLIB-compressed data.
Return Value
String
The uncompressed string
See Also
CompressString(String)
UncompressBuffer(array<Byte>[]()[][])


Write Method (buffer, offset, count)

Keyoti RapidSpell Desktop .NET API Docs
Write Method (buffer, offset, count)
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► Write(array<Byte>[]()[][], Int32, Int32)
Keyoti RapidSpell Desktop .NET
Write data to the stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Sub Write (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
Public Overrides Sub Write (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
public:
virtual void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
public:
virtual void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
abstract Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
override Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
abstract Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
override Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
Parameters
buffer (array< Byte >[]()[][])
The buffer holding data to write to the stream.
offset (Int32)
the offset within that data array to find the first byte to write.
count (Int32)
the number of bytes to write.
Remarks

If you wish to use the ZlibStream to compress data while writing, you can create a ZlibStream with CompressionMode.Compress, and a writable output stream. Then call Write() on that ZlibStream, providing uncompressed data as input. The data sent to the output stream will be the compressed form of the data written. If you wish to use the ZlibStream to decompress data while writing, you can create a ZlibStream with CompressionMode.Decompress, and a writable output stream. Then call Write() on that stream, providing previously compressed data. The data sent to the output stream will be the decompressed form of the data written.

A ZlibStream can be used for Read() or Write(), but not both.


Keyoti.RapidSpell.DialogViews Namespace

Keyoti RapidSpell Desktop .NET API Docs
Keyoti.RapidSpell.DialogViews Namespace
API ► Keyoti.RapidSpell.DialogViews
Keyoti RapidSpell Desktop .NET
Dialog's view class namespace
Types
All Types Classes Interfaces
Icon | Type | Description
 | IDialogView | Describes what a view used by RapidSpellDialog/RapidSpellGUIPresenter must implement.
 | IDialogViewEventHandler | Describes a class which can handle events from an IDialogView.
 | IDialogViewOptions | Describes an option editor form
 | IDialogViewUserDictionaryEdit | Describes a user dictionary editor window
 | IDialogViewUserDictionarySelect | Describes a user dictionary editor window
 | WindowsForms | Default WindowsForms view.
 | WindowsFormsOptions | Options editor Form
 | WindowsFormsUserDictionaryEdit | Windows forms implementation of IDialogViewUserDictionaryEdit
 | WindowsFormsUserDictionarySelect | Windows forms implementation of IDialogViewUserDictionarySelect


IDialogView Interface

Keyoti RapidSpell Desktop .NET API Docs
IDialogView Interface
API ► Keyoti.RapidSpell.DialogViews ► IDialogView
Keyoti RapidSpell Desktop .NET
Describes what a view used by RapidSpellDialog/RapidSpellGUIPresenter must implement.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public interface IDialogView
public interface IDialogView
Public Interface IDialogView
Public Interface IDialogView
public interface class IDialogView
public interface class IDialogView
type IDialogView =  interface end
type IDialogView =  interface end
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddButtonEnabled | Whether the add button is enabled
 | AddButtonText | Add button text
 | AddButtonVisible | Whether the add button is visible
 | CancelButtonText | Cancel button text
 | ChangeAllButtonEnabled | Whether the change all button is enabled
 | ChangeAllButtonText | Change all button text
 | ChangeButtonEnabled | Whether the change button is enabled
 | ChangeButtonText | Change button text
 | Close()()()() | Closes the form if open.
 | Dispose()()()() | Disposes of unmanaged resources.
 | Focus()()()() | Give focus to the form.
 | GetQueryCorrection()()()() | Return the word from the query text box, as the user may have modified
 | IgnoreAllButtonEnabled | Whether the ignore all button is enabled
 | IgnoreAllButtonText | Ignore all button text
 | IgnoreButtonEnabled | Whether the ignore button is enabled
 | IgnoreButtonSelect()()()() | Select the ignore button
 | IgnoreButtonText | Ignore button text
 | IsDisposed | Gets a value indicating whether the control has been disposed of.
 | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
 | NotInDictionaryLabelText | Label text indicating whether in dictionary or not
 | OptionsButtonText | Options button text
 | QueryTextBoxMultiline | Whether 'not in dictionary' text box is multiline or single line.
 | RegisterEvents(IDialogViewEventHandler) | Hook up view events to handler
 | SetQuery(String, String, String) | Specifies the spelling query
 | Show()()()() | Show non modally
 | ShowDialog()()()() | Show modally
 | ShowDialog(Object) | Show modally
 | ShowMessageBox(String, String, MessageBoxButtons, MessageBoxIcon) | Show a message box for the user
 | ShowOptionsButton | Whether to show the options button.
 | ShowUndoButton | Whether to show the undo button.
 | SuggestionFinderCheckBoxChecked | Whether the find suggestions checkbox is checked (may not be shown)
 | SuggestionFinderCheckBoxEnabled | Whether the suggestion finder checkbox is enabled
 | SuggestionFinderCheckBoxText | Suggestion finder checkbox text
 | SuggestionsLabelEnabled | Whether the suggestions label is enabled
 | SuggestionsLabelText | Suggestion label text
 | SuggestionsListClear()()()() | Clear the suggestions list
 | SuggestionsListDeselect()()()() | Deselect all items from the suggestions list
 | SuggestionsListEnabled | Whether the suggestions list is enabled
 | SuggestionsListItems | All the suggestion items
 | SuggestionsListSelectedItem | The selected suggestion item
 | Title | Window title
 | UIThreadInvoke(Delegate) | Invoke in the UI thread the delegate d
 | UIThreadInvoke(Delegate, array<Object>[]()[][]) | Invoke in the UI thread the delegate d with parameters
 | UndoButtonEnabled | Whether the undo button is enabled
 | UndoButtonText | Undo button text
 | UnregisterEvents(IDialogViewEventHandler) | Remove view event subscriptions from handler
 | Visible | Gets or sets a value indicating whether the control is displayed.


AddButtonEnabled Property

Keyoti RapidSpell Desktop .NET API Docs
AddButtonEnabled Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► AddButtonEnabled
Keyoti RapidSpell Desktop .NET
Whether the add button is enabled
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool AddButtonEnabled { get; set; }
bool AddButtonEnabled { get; set; }
Property AddButtonEnabled As Boolean
    Get
    Set
Property AddButtonEnabled As Boolean
    Get
    Set
property bool AddButtonEnabled {
    bool get ();
    void set (bool value);
}
property bool AddButtonEnabled {
    bool get ();
    void set (bool value);
}
abstract AddButtonEnabled : bool with get, set

abstract AddButtonEnabled : bool with get, set
Property Value
Boolean


AddButtonText Property

Keyoti RapidSpell Desktop .NET API Docs
AddButtonText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► AddButtonText
Keyoti RapidSpell Desktop .NET
Add button text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string AddButtonText { get; set; }
string AddButtonText { get; set; }
Property AddButtonText As String
    Get
    Set
Property AddButtonText As String
    Get
    Set
property String^ AddButtonText {
    String^ get ();
    void set (String^ value);
}
property String^ AddButtonText {
    String^ get ();
    void set (String^ value);
}
abstract AddButtonText : string with get, set

abstract AddButtonText : string with get, set
Property Value
String


AddButtonVisible Property

Keyoti RapidSpell Desktop .NET API Docs
AddButtonVisible Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► AddButtonVisible
Keyoti RapidSpell Desktop .NET
Whether the add button is visible
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool AddButtonVisible { get; set; }
bool AddButtonVisible { get; set; }
Property AddButtonVisible As Boolean
    Get
    Set
Property AddButtonVisible As Boolean
    Get
    Set
property bool AddButtonVisible {
    bool get ();
    void set (bool value);
}
property bool AddButtonVisible {
    bool get ();
    void set (bool value);
}
abstract AddButtonVisible : bool with get, set

abstract AddButtonVisible : bool with get, set
Property Value
Boolean


CancelButtonText Property

Keyoti RapidSpell Desktop .NET API Docs
CancelButtonText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► CancelButtonText
Keyoti RapidSpell Desktop .NET
Cancel button text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string CancelButtonText { get; set; }
string CancelButtonText { get; set; }
Property CancelButtonText As String
    Get
    Set
Property CancelButtonText As String
    Get
    Set
property String^ CancelButtonText {
    String^ get ();
    void set (String^ value);
}
property String^ CancelButtonText {
    String^ get ();
    void set (String^ value);
}
abstract CancelButtonText : string with get, set

abstract CancelButtonText : string with get, set
Property Value
String


ChangeAllButtonEnabled Property

Keyoti RapidSpell Desktop .NET API Docs
ChangeAllButtonEnabled Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► ChangeAllButtonEnabled
Keyoti RapidSpell Desktop .NET
Whether the change all button is enabled
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool ChangeAllButtonEnabled { get; set; }
bool ChangeAllButtonEnabled { get; set; }
Property ChangeAllButtonEnabled As Boolean
    Get
    Set
Property ChangeAllButtonEnabled As Boolean
    Get
    Set
property bool ChangeAllButtonEnabled {
    bool get ();
    void set (bool value);
}
property bool ChangeAllButtonEnabled {
    bool get ();
    void set (bool value);
}
abstract ChangeAllButtonEnabled : bool with get, set

abstract ChangeAllButtonEnabled : bool with get, set
Property Value
Boolean


ChangeAllButtonText Property

Keyoti RapidSpell Desktop .NET API Docs
ChangeAllButtonText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► ChangeAllButtonText
Keyoti RapidSpell Desktop .NET
Change all button text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string ChangeAllButtonText { get; set; }
string ChangeAllButtonText { get; set; }
Property ChangeAllButtonText As String
    Get
    Set
Property ChangeAllButtonText As String
    Get
    Set
property String^ ChangeAllButtonText {
    String^ get ();
    void set (String^ value);
}
property String^ ChangeAllButtonText {
    String^ get ();
    void set (String^ value);
}
abstract ChangeAllButtonText : string with get, set

abstract ChangeAllButtonText : string with get, set
Property Value
String


ChangeButtonEnabled Property

Keyoti RapidSpell Desktop .NET API Docs
ChangeButtonEnabled Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► ChangeButtonEnabled
Keyoti RapidSpell Desktop .NET
Whether the change button is enabled
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool ChangeButtonEnabled { get; set; }
bool ChangeButtonEnabled { get; set; }
Property ChangeButtonEnabled As Boolean
    Get
    Set
Property ChangeButtonEnabled As Boolean
    Get
    Set
property bool ChangeButtonEnabled {
    bool get ();
    void set (bool value);
}
property bool ChangeButtonEnabled {
    bool get ();
    void set (bool value);
}
abstract ChangeButtonEnabled : bool with get, set

abstract ChangeButtonEnabled : bool with get, set
Property Value
Boolean


ChangeButtonText Property

Keyoti RapidSpell Desktop .NET API Docs
ChangeButtonText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► ChangeButtonText
Keyoti RapidSpell Desktop .NET
Change button text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string ChangeButtonText { get; set; }
string ChangeButtonText { get; set; }
Property ChangeButtonText As String
    Get
    Set
Property ChangeButtonText As String
    Get
    Set
property String^ ChangeButtonText {
    String^ get ();
    void set (String^ value);
}
property String^ ChangeButtonText {
    String^ get ();
    void set (String^ value);
}
abstract ChangeButtonText : string with get, set

abstract ChangeButtonText : string with get, set
Property Value
String


Close Method

Keyoti RapidSpell Desktop .NET API Docs
Close Method
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► Close()()()()
Keyoti RapidSpell Desktop .NET
Closes the form if open.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void Close()
void Close()
Sub Close
Sub Close
void Close()
void Close()
abstract Close : unit -> unit

abstract Close : unit -> unit


Dispose Method

Keyoti RapidSpell Desktop .NET API Docs
Dispose Method
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► Dispose()()()()
Keyoti RapidSpell Desktop .NET
Disposes of unmanaged resources.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void Dispose()
void Dispose()
Sub Dispose
Sub Dispose
void Dispose()
void Dispose()
abstract Dispose : unit -> unit

abstract Dispose : unit -> unit


Focus Method

Keyoti RapidSpell Desktop .NET API Docs
Focus Method
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► Focus()()()()
Keyoti RapidSpell Desktop .NET
Give focus to the form.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool Focus()
bool Focus()
Function Focus As Boolean
Function Focus As Boolean
bool Focus()
bool Focus()
abstract Focus : unit -> bool

abstract Focus : unit -> bool
Return Value
Boolean


GetQueryCorrection Method

Keyoti RapidSpell Desktop .NET API Docs
GetQueryCorrection Method
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► GetQueryCorrection()()()()
Keyoti RapidSpell Desktop .NET
Return the word from the query text box, as the user may have modified
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string GetQueryCorrection()
string GetQueryCorrection()
Function GetQueryCorrection As String
Function GetQueryCorrection As String
String^ GetQueryCorrection()
String^ GetQueryCorrection()
abstract GetQueryCorrection : unit -> string

abstract GetQueryCorrection : unit -> string
Return Value
String


IgnoreAllButtonEnabled Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreAllButtonEnabled Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► IgnoreAllButtonEnabled
Keyoti RapidSpell Desktop .NET
Whether the ignore all button is enabled
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool IgnoreAllButtonEnabled { get; set; }
bool IgnoreAllButtonEnabled { get; set; }
Property IgnoreAllButtonEnabled As Boolean
    Get
    Set
Property IgnoreAllButtonEnabled As Boolean
    Get
    Set
property bool IgnoreAllButtonEnabled {
    bool get ();
    void set (bool value);
}
property bool IgnoreAllButtonEnabled {
    bool get ();
    void set (bool value);
}
abstract IgnoreAllButtonEnabled : bool with get, set

abstract IgnoreAllButtonEnabled : bool with get, set
Property Value
Boolean


IgnoreAllButtonText Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreAllButtonText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► IgnoreAllButtonText
Keyoti RapidSpell Desktop .NET
Ignore all button text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string IgnoreAllButtonText { get; set; }
string IgnoreAllButtonText { get; set; }
Property IgnoreAllButtonText As String
    Get
    Set
Property IgnoreAllButtonText As String
    Get
    Set
property String^ IgnoreAllButtonText {
    String^ get ();
    void set (String^ value);
}
property String^ IgnoreAllButtonText {
    String^ get ();
    void set (String^ value);
}
abstract IgnoreAllButtonText : string with get, set

abstract IgnoreAllButtonText : string with get, set
Property Value
String


IgnoreButtonEnabled Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreButtonEnabled Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► IgnoreButtonEnabled
Keyoti RapidSpell Desktop .NET
Whether the ignore button is enabled
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool IgnoreButtonEnabled { get; set; }
bool IgnoreButtonEnabled { get; set; }
Property IgnoreButtonEnabled As Boolean
    Get
    Set
Property IgnoreButtonEnabled As Boolean
    Get
    Set
property bool IgnoreButtonEnabled {
    bool get ();
    void set (bool value);
}
property bool IgnoreButtonEnabled {
    bool get ();
    void set (bool value);
}
abstract IgnoreButtonEnabled : bool with get, set

abstract IgnoreButtonEnabled : bool with get, set
Property Value
Boolean


IgnoreButtonSelect Method

Keyoti RapidSpell Desktop .NET API Docs
IgnoreButtonSelect Method
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► IgnoreButtonSelect()()()()
Keyoti RapidSpell Desktop .NET
Select the ignore button
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void IgnoreButtonSelect()
void IgnoreButtonSelect()
Sub IgnoreButtonSelect
Sub IgnoreButtonSelect
void IgnoreButtonSelect()
void IgnoreButtonSelect()
abstract IgnoreButtonSelect : unit -> unit

abstract IgnoreButtonSelect : unit -> unit


IgnoreButtonText Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreButtonText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► IgnoreButtonText
Keyoti RapidSpell Desktop .NET
Ignore button text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string IgnoreButtonText { get; set; }
string IgnoreButtonText { get; set; }
Property IgnoreButtonText As String
    Get
    Set
Property IgnoreButtonText As String
    Get
    Set
property String^ IgnoreButtonText {
    String^ get ();
    void set (String^ value);
}
property String^ IgnoreButtonText {
    String^ get ();
    void set (String^ value);
}
abstract IgnoreButtonText : string with get, set

abstract IgnoreButtonText : string with get, set
Property Value
String


IsDisposed Property

Keyoti RapidSpell Desktop .NET API Docs
IsDisposed Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► IsDisposed
Keyoti RapidSpell Desktop .NET
Gets a value indicating whether the control has been disposed of.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool IsDisposed { get; }
bool IsDisposed { get; }
ReadOnly Property IsDisposed As Boolean
    Get
ReadOnly Property IsDisposed As Boolean
    Get
property bool IsDisposed {
    bool get ();
}
property bool IsDisposed {
    bool get ();
}
abstract IsDisposed : bool with get

abstract IsDisposed : bool with get
Property Value
Boolean


Location Property

Keyoti RapidSpell Desktop .NET API Docs
Location Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► Location
Keyoti RapidSpell Desktop .NET
Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
Point Location { get; set; }
Point Location { get; set; }
Property Location As Point
    Get
    Set
Property Location As Point
    Get
    Set
property Point Location {
    Point get ();
    void set (Point value);
}
property Point Location {
    Point get ();
    void set (Point value);
}
abstract Location : Point with get, set

abstract Location : Point with get, set
Property Value
Point


NotInDictionaryLabelText Property

Keyoti RapidSpell Desktop .NET API Docs
NotInDictionaryLabelText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► NotInDictionaryLabelText
Keyoti RapidSpell Desktop .NET
Label text indicating whether in dictionary or not
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string NotInDictionaryLabelText { get; set; }
string NotInDictionaryLabelText { get; set; }
Property NotInDictionaryLabelText As String
    Get
    Set
Property NotInDictionaryLabelText As String
    Get
    Set
property String^ NotInDictionaryLabelText {
    String^ get ();
    void set (String^ value);
}
property String^ NotInDictionaryLabelText {
    String^ get ();
    void set (String^ value);
}
abstract NotInDictionaryLabelText : string with get, set

abstract NotInDictionaryLabelText : string with get, set
Property Value
String


OptionsButtonText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsButtonText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► OptionsButtonText
Keyoti RapidSpell Desktop .NET
Options button text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string OptionsButtonText { get; set; }
string OptionsButtonText { get; set; }
Property OptionsButtonText As String
    Get
    Set
Property OptionsButtonText As String
    Get
    Set
property String^ OptionsButtonText {
    String^ get ();
    void set (String^ value);
}
property String^ OptionsButtonText {
    String^ get ();
    void set (String^ value);
}
abstract OptionsButtonText : string with get, set

abstract OptionsButtonText : string with get, set
Property Value
String


QueryTextBoxMultiline Property

Keyoti RapidSpell Desktop .NET API Docs
QueryTextBoxMultiline Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► QueryTextBoxMultiline
Keyoti RapidSpell Desktop .NET
Whether 'not in dictionary' text box is multiline or single line.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool QueryTextBoxMultiline { get; set; }
bool QueryTextBoxMultiline { get; set; }
Property QueryTextBoxMultiline As Boolean
    Get
    Set
Property QueryTextBoxMultiline As Boolean
    Get
    Set
property bool QueryTextBoxMultiline {
    bool get ();
    void set (bool value);
}
property bool QueryTextBoxMultiline {
    bool get ();
    void set (bool value);
}
abstract QueryTextBoxMultiline : bool with get, set

abstract QueryTextBoxMultiline : bool with get, set
Property Value
Boolean


RegisterEvents Method (handler)

Keyoti RapidSpell Desktop .NET API Docs
RegisterEvents Method (handler)
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► RegisterEvents(IDialogViewEventHandler)
Keyoti RapidSpell Desktop .NET
Hook up view events to handler
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void RegisterEvents(
    IDialogViewEventHandler handler
)
void RegisterEvents(
    IDialogViewEventHandler handler
)
Sub RegisterEvents (
    handler As IDialogViewEventHandler
)
Sub RegisterEvents (
    handler As IDialogViewEventHandler
)
void RegisterEvents(
    IDialogViewEventHandler^ handler
)
void RegisterEvents(
    IDialogViewEventHandler^ handler
)
abstract RegisterEvents :
        handler : IDialogViewEventHandler -> unit

abstract RegisterEvents :
        handler : IDialogViewEventHandler -> unit
Parameters
handler (IDialogViewEventHandler)


SetQuery Method (beforeSentence, word, afterSentence)

Keyoti RapidSpell Desktop .NET API Docs
SetQuery Method (beforeSentence, word, afterSentence)
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► SetQuery(String, String, String)
Keyoti RapidSpell Desktop .NET
Specifies the spelling query
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void SetQuery(
    string beforeSentence,
    string word,
    string afterSentence
)
void SetQuery(
    string beforeSentence,
    string word,
    string afterSentence
)
Sub SetQuery (
    beforeSentence As String,
    word As String,
    afterSentence As String
)
Sub SetQuery (
    beforeSentence As String,
    word As String,
    afterSentence As String
)
void SetQuery(
    String^ beforeSentence,
    String^ word,
    String^ afterSentence
)
void SetQuery(
    String^ beforeSentence,
    String^ word,
    String^ afterSentence
)
abstract SetQuery :
        beforeSentence : string *
        word : string *
        afterSentence : string -> unit

abstract SetQuery :
        beforeSentence : string *
        word : string *
        afterSentence : string -> unit
Parameters
beforeSentence (String)
The context sentence before the error
word (String)
The actual error
afterSentence (String)
The context sentence after the error


Show Method

Keyoti RapidSpell Desktop .NET API Docs
Show Method
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► Show()()()()
Keyoti RapidSpell Desktop .NET
Show non modally
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void Show()
void Show()
Sub Show
Sub Show
void Show()
void Show()
abstract Show : unit -> unit

abstract Show : unit -> unit


ShowDialog Method

Keyoti RapidSpell Desktop .NET API Docs
ShowDialog Method
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► ShowDialog()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | ShowDialog()()()() | Show modally
 | ShowDialog(Object) | Show modally


ShowDialog Method

Keyoti RapidSpell Desktop .NET API Docs
ShowDialog Method
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► ShowDialog()()()()
Keyoti RapidSpell Desktop .NET
Show modally
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
DialogResult ShowDialog()
DialogResult ShowDialog()
Function ShowDialog As DialogResult
Function ShowDialog As DialogResult
DialogResult ShowDialog()
DialogResult ShowDialog()
abstract ShowDialog : unit -> DialogResult

abstract ShowDialog : unit -> DialogResult
Return Value
DialogResult


ShowDialog Method (owner)

Keyoti RapidSpell Desktop .NET API Docs
ShowDialog Method (owner)
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► ShowDialog(Object)
Keyoti RapidSpell Desktop .NET
Show modally
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
DialogResult ShowDialog(
    Object owner
)
DialogResult ShowDialog(
    Object owner
)
Function ShowDialog (
    owner As Object
) As DialogResult
Function ShowDialog (
    owner As Object
) As DialogResult
DialogResult ShowDialog(
    Object^ owner
)
DialogResult ShowDialog(
    Object^ owner
)
abstract ShowDialog :
        owner : Object -> DialogResult

abstract ShowDialog :
        owner : Object -> DialogResult
Parameters
owner (Object)
The owner window
Return Value
DialogResult


ShowMessageBox Method (message, title, buttons, icon)

Keyoti RapidSpell Desktop .NET API Docs
ShowMessageBox Method (message, title, buttons, icon)
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► ShowMessageBox(String, String, MessageBoxButtons, MessageBoxIcon)
Keyoti RapidSpell Desktop .NET
Show a message box for the user
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
DialogResult ShowMessageBox(
    string message,
    string title,
    MessageBoxButtons buttons,
    MessageBoxIcon icon
)
DialogResult ShowMessageBox(
    string message,
    string title,
    MessageBoxButtons buttons,
    MessageBoxIcon icon
)
Function ShowMessageBox (
    message As String,
    title As String,
    buttons As MessageBoxButtons,
    icon As MessageBoxIcon
) As DialogResult
Function ShowMessageBox (
    message As String,
    title As String,
    buttons As MessageBoxButtons,
    icon As MessageBoxIcon
) As DialogResult
DialogResult ShowMessageBox(
    String^ message,
    String^ title,
    MessageBoxButtons buttons,
    MessageBoxIcon icon
)
DialogResult ShowMessageBox(
    String^ message,
    String^ title,
    MessageBoxButtons buttons,
    MessageBoxIcon icon
)
abstract ShowMessageBox :
        message : string *
        title : string *
        buttons : MessageBoxButtons *
        icon : MessageBoxIcon -> DialogResult

abstract ShowMessageBox :
        message : string *
        title : string *
        buttons : MessageBoxButtons *
        icon : MessageBoxIcon -> DialogResult
Parameters
message (String)
title (String)
buttons (MessageBoxButtons)
icon (MessageBoxIcon)
Return Value
DialogResult


ShowOptionsButton Property

Keyoti RapidSpell Desktop .NET API Docs
ShowOptionsButton Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► ShowOptionsButton
Keyoti RapidSpell Desktop .NET
Whether to show the options button.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool ShowOptionsButton { get; set; }
bool ShowOptionsButton { get; set; }
Property ShowOptionsButton As Boolean
    Get
    Set
Property ShowOptionsButton As Boolean
    Get
    Set
property bool ShowOptionsButton {
    bool get ();
    void set (bool value);
}
property bool ShowOptionsButton {
    bool get ();
    void set (bool value);
}
abstract ShowOptionsButton : bool with get, set

abstract ShowOptionsButton : bool with get, set
Property Value
Boolean


ShowUndoButton Property

Keyoti RapidSpell Desktop .NET API Docs
ShowUndoButton Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► ShowUndoButton
Keyoti RapidSpell Desktop .NET
Whether to show the undo button.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool ShowUndoButton { get; set; }
bool ShowUndoButton { get; set; }
Property ShowUndoButton As Boolean
    Get
    Set
Property ShowUndoButton As Boolean
    Get
    Set
property bool ShowUndoButton {
    bool get ();
    void set (bool value);
}
property bool ShowUndoButton {
    bool get ();
    void set (bool value);
}
abstract ShowUndoButton : bool with get, set

abstract ShowUndoButton : bool with get, set
Property Value
Boolean


SuggestionFinderCheckBoxChecked Property

Keyoti RapidSpell Desktop .NET API Docs
SuggestionFinderCheckBoxChecked Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► SuggestionFinderCheckBoxChecked
Keyoti RapidSpell Desktop .NET
Whether the find suggestions checkbox is checked (may not be shown)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool SuggestionFinderCheckBoxChecked { get; set; }
bool SuggestionFinderCheckBoxChecked { get; set; }
Property SuggestionFinderCheckBoxChecked As Boolean
    Get
    Set
Property SuggestionFinderCheckBoxChecked As Boolean
    Get
    Set
property bool SuggestionFinderCheckBoxChecked {
    bool get ();
    void set (bool value);
}
property bool SuggestionFinderCheckBoxChecked {
    bool get ();
    void set (bool value);
}
abstract SuggestionFinderCheckBoxChecked : bool with get, set

abstract SuggestionFinderCheckBoxChecked : bool with get, set
Property Value
Boolean


SuggestionFinderCheckBoxEnabled Property

Keyoti RapidSpell Desktop .NET API Docs
SuggestionFinderCheckBoxEnabled Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► SuggestionFinderCheckBoxEnabled
Keyoti RapidSpell Desktop .NET
Whether the suggestion finder checkbox is enabled
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool SuggestionFinderCheckBoxEnabled { get; set; }
bool SuggestionFinderCheckBoxEnabled { get; set; }
Property SuggestionFinderCheckBoxEnabled As Boolean
    Get
    Set
Property SuggestionFinderCheckBoxEnabled As Boolean
    Get
    Set
property bool SuggestionFinderCheckBoxEnabled {
    bool get ();
    void set (bool value);
}
property bool SuggestionFinderCheckBoxEnabled {
    bool get ();
    void set (bool value);
}
abstract SuggestionFinderCheckBoxEnabled : bool with get, set

abstract SuggestionFinderCheckBoxEnabled : bool with get, set
Property Value
Boolean


SuggestionFinderCheckBoxText Property

Keyoti RapidSpell Desktop .NET API Docs
SuggestionFinderCheckBoxText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► SuggestionFinderCheckBoxText
Keyoti RapidSpell Desktop .NET
Suggestion finder checkbox text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string SuggestionFinderCheckBoxText { get; set; }
string SuggestionFinderCheckBoxText { get; set; }
Property SuggestionFinderCheckBoxText As String
    Get
    Set
Property SuggestionFinderCheckBoxText As String
    Get
    Set
property String^ SuggestionFinderCheckBoxText {
    String^ get ();
    void set (String^ value);
}
property String^ SuggestionFinderCheckBoxText {
    String^ get ();
    void set (String^ value);
}
abstract SuggestionFinderCheckBoxText : string with get, set

abstract SuggestionFinderCheckBoxText : string with get, set
Property Value
String


SuggestionsLabelEnabled Property

Keyoti RapidSpell Desktop .NET API Docs
SuggestionsLabelEnabled Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► SuggestionsLabelEnabled
Keyoti RapidSpell Desktop .NET
Whether the suggestions label is enabled
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool SuggestionsLabelEnabled { get; set; }
bool SuggestionsLabelEnabled { get; set; }
Property SuggestionsLabelEnabled As Boolean
    Get
    Set
Property SuggestionsLabelEnabled As Boolean
    Get
    Set
property bool SuggestionsLabelEnabled {
    bool get ();
    void set (bool value);
}
property bool SuggestionsLabelEnabled {
    bool get ();
    void set (bool value);
}
abstract SuggestionsLabelEnabled : bool with get, set

abstract SuggestionsLabelEnabled : bool with get, set
Property Value
Boolean


SuggestionsLabelText Property

Keyoti RapidSpell Desktop .NET API Docs
SuggestionsLabelText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► SuggestionsLabelText
Keyoti RapidSpell Desktop .NET
Suggestion label text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string SuggestionsLabelText { get; set; }
string SuggestionsLabelText { get; set; }
Property SuggestionsLabelText As String
    Get
    Set
Property SuggestionsLabelText As String
    Get
    Set
property String^ SuggestionsLabelText {
    String^ get ();
    void set (String^ value);
}
property String^ SuggestionsLabelText {
    String^ get ();
    void set (String^ value);
}
abstract SuggestionsLabelText : string with get, set

abstract SuggestionsLabelText : string with get, set
Property Value
String


SuggestionsListClear Method

Keyoti RapidSpell Desktop .NET API Docs
SuggestionsListClear Method
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► SuggestionsListClear()()()()
Keyoti RapidSpell Desktop .NET
Clear the suggestions list
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void SuggestionsListClear()
void SuggestionsListClear()
Sub SuggestionsListClear
Sub SuggestionsListClear
void SuggestionsListClear()
void SuggestionsListClear()
abstract SuggestionsListClear : unit -> unit

abstract SuggestionsListClear : unit -> unit


SuggestionsListDeselect Method

Keyoti RapidSpell Desktop .NET API Docs
SuggestionsListDeselect Method
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► SuggestionsListDeselect()()()()
Keyoti RapidSpell Desktop .NET
Deselect all items from the suggestions list
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void SuggestionsListDeselect()
void SuggestionsListDeselect()
Sub SuggestionsListDeselect
Sub SuggestionsListDeselect
void SuggestionsListDeselect()
void SuggestionsListDeselect()
abstract SuggestionsListDeselect : unit -> unit

abstract SuggestionsListDeselect : unit -> unit


SuggestionsListEnabled Property

Keyoti RapidSpell Desktop .NET API Docs
SuggestionsListEnabled Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► SuggestionsListEnabled
Keyoti RapidSpell Desktop .NET
Whether the suggestions list is enabled
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool SuggestionsListEnabled { get; set; }
bool SuggestionsListEnabled { get; set; }
Property SuggestionsListEnabled As Boolean
    Get
    Set
Property SuggestionsListEnabled As Boolean
    Get
    Set
property bool SuggestionsListEnabled {
    bool get ();
    void set (bool value);
}
property bool SuggestionsListEnabled {
    bool get ();
    void set (bool value);
}
abstract SuggestionsListEnabled : bool with get, set

abstract SuggestionsListEnabled : bool with get, set
Property Value
Boolean


SuggestionsListItems Property

Keyoti RapidSpell Desktop .NET API Docs
SuggestionsListItems Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► SuggestionsListItems
Keyoti RapidSpell Desktop .NET
All the suggestion items
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
Object SuggestionsListItems { get; set; }
Object SuggestionsListItems { get; set; }
Property SuggestionsListItems As Object
    Get
    Set
Property SuggestionsListItems As Object
    Get
    Set
property Object^ SuggestionsListItems {
    Object^ get ();
    void set (Object^ value);
}
property Object^ SuggestionsListItems {
    Object^ get ();
    void set (Object^ value);
}
abstract SuggestionsListItems : Object with get, set

abstract SuggestionsListItems : Object with get, set
Property Value
Object


SuggestionsListSelectedItem Property

Keyoti RapidSpell Desktop .NET API Docs
SuggestionsListSelectedItem Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► SuggestionsListSelectedItem
Keyoti RapidSpell Desktop .NET
The selected suggestion item
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string SuggestionsListSelectedItem { get; }
string SuggestionsListSelectedItem { get; }
ReadOnly Property SuggestionsListSelectedItem As String
    Get
ReadOnly Property SuggestionsListSelectedItem As String
    Get
property String^ SuggestionsListSelectedItem {
    String^ get ();
}
property String^ SuggestionsListSelectedItem {
    String^ get ();
}
abstract SuggestionsListSelectedItem : string with get

abstract SuggestionsListSelectedItem : string with get
Property Value
String


Title Property

Keyoti RapidSpell Desktop .NET API Docs
Title Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► Title
Keyoti RapidSpell Desktop .NET
Window title
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string Title { get; set; }
string Title { get; set; }
Property Title As String
    Get
    Set
Property Title As String
    Get
    Set
property String^ Title {
    String^ get ();
    void set (String^ value);
}
property String^ Title {
    String^ get ();
    void set (String^ value);
}
abstract Title : string with get, set

abstract Title : string with get, set
Property Value
String


UIThreadInvoke Method

Keyoti RapidSpell Desktop .NET API Docs
UIThreadInvoke Method
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► UIThreadInvoke()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | UIThreadInvoke(Delegate) | Invoke in the UI thread the delegate d
 | UIThreadInvoke(Delegate, array<Object>[]()[][]) | Invoke in the UI thread the delegate d with parameters


UIThreadInvoke Method (d)

Keyoti RapidSpell Desktop .NET API Docs
UIThreadInvoke Method (d)
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► UIThreadInvoke(Delegate)
Keyoti RapidSpell Desktop .NET
Invoke in the UI thread the delegate d
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void UIThreadInvoke(
    Delegate d
)
void UIThreadInvoke(
    Delegate d
)
Sub UIThreadInvoke (
    d As Delegate
)
Sub UIThreadInvoke (
    d As Delegate
)
void UIThreadInvoke(
    Delegate^ d
)
void UIThreadInvoke(
    Delegate^ d
)
abstract UIThreadInvoke :
        d : Delegate -> unit

abstract UIThreadInvoke :
        d : Delegate -> unit
Parameters
d (Delegate)


UIThreadInvoke Method (d, parameters)

Keyoti RapidSpell Desktop .NET API Docs
UIThreadInvoke Method (d, parameters)
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► UIThreadInvoke(Delegate, array<Object>[]()[][])
Keyoti RapidSpell Desktop .NET
Invoke in the UI thread the delegate d with parameters
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void UIThreadInvoke(
    Delegate d,
    Object[] parameters
)
void UIThreadInvoke(
    Delegate d,
    Object[] parameters
)
Sub UIThreadInvoke (
    d As Delegate,
    parameters As Object()
)
Sub UIThreadInvoke (
    d As Delegate,
    parameters As Object()
)
void UIThreadInvoke(
    Delegate^ d,
    array<Object^>^ parameters
)
void UIThreadInvoke(
    Delegate^ d,
    array<Object^>^ parameters
)
abstract UIThreadInvoke :
        d : Delegate *
        parameters : Object[] -> unit

abstract UIThreadInvoke :
        d : Delegate *
        parameters : Object[] -> unit
Parameters
d (Delegate)
parameters (array< Object >[]()[][])


UndoButtonEnabled Property

Keyoti RapidSpell Desktop .NET API Docs
UndoButtonEnabled Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► UndoButtonEnabled
Keyoti RapidSpell Desktop .NET
Whether the undo button is enabled
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool UndoButtonEnabled { get; set; }
bool UndoButtonEnabled { get; set; }
Property UndoButtonEnabled As Boolean
    Get
    Set
Property UndoButtonEnabled As Boolean
    Get
    Set
property bool UndoButtonEnabled {
    bool get ();
    void set (bool value);
}
property bool UndoButtonEnabled {
    bool get ();
    void set (bool value);
}
abstract UndoButtonEnabled : bool with get, set

abstract UndoButtonEnabled : bool with get, set
Property Value
Boolean


UndoButtonText Property

Keyoti RapidSpell Desktop .NET API Docs
UndoButtonText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► UndoButtonText
Keyoti RapidSpell Desktop .NET
Undo button text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string UndoButtonText { get; set; }
string UndoButtonText { get; set; }
Property UndoButtonText As String
    Get
    Set
Property UndoButtonText As String
    Get
    Set
property String^ UndoButtonText {
    String^ get ();
    void set (String^ value);
}
property String^ UndoButtonText {
    String^ get ();
    void set (String^ value);
}
abstract UndoButtonText : string with get, set

abstract UndoButtonText : string with get, set
Property Value
String


UnregisterEvents Method (handler)

Keyoti RapidSpell Desktop .NET API Docs
UnregisterEvents Method (handler)
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► UnregisterEvents(IDialogViewEventHandler)
Keyoti RapidSpell Desktop .NET
Remove view event subscriptions from handler
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void UnregisterEvents(
    IDialogViewEventHandler handler
)
void UnregisterEvents(
    IDialogViewEventHandler handler
)
Sub UnregisterEvents (
    handler As IDialogViewEventHandler
)
Sub UnregisterEvents (
    handler As IDialogViewEventHandler
)
void UnregisterEvents(
    IDialogViewEventHandler^ handler
)
void UnregisterEvents(
    IDialogViewEventHandler^ handler
)
abstract UnregisterEvents :
        handler : IDialogViewEventHandler -> unit

abstract UnregisterEvents :
        handler : IDialogViewEventHandler -> unit
Parameters
handler (IDialogViewEventHandler)


Visible Property

Keyoti RapidSpell Desktop .NET API Docs
Visible Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► Visible
Keyoti RapidSpell Desktop .NET
Gets or sets a value indicating whether the control is displayed.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool Visible { get; set; }
bool Visible { get; set; }
Property Visible As Boolean
    Get
    Set
Property Visible As Boolean
    Get
    Set
property bool Visible {
    bool get ();
    void set (bool value);
}
property bool Visible {
    bool get ();
    void set (bool value);
}
abstract Visible : bool with get, set

abstract Visible : bool with get, set
Property Value
Boolean


IDialogViewEventHandler Interface

Keyoti RapidSpell Desktop .NET API Docs
IDialogViewEventHandler Interface
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewEventHandler
Keyoti RapidSpell Desktop .NET
Describes a class which can handle events from an IDialogView.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public interface IDialogViewEventHandler
public interface IDialogViewEventHandler
Public Interface IDialogViewEventHandler
Public Interface IDialogViewEventHandler
public interface class IDialogViewEventHandler
public interface class IDialogViewEventHandler
type IDialogViewEventHandler =  interface end
type IDialogViewEventHandler =  interface end
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DialogView_AddButtonClick(Object, EventArgs) | The add button was clicked
 | DialogView_CancelButtonClick(Object, EventArgs) | The cancel button was clicked
 | DialogView_ChangeAllButtonClick(Object, EventArgs) | The change-all button was clicked
 | DialogView_ChangeButtonClick(Object, EventArgs) | The change button was clicked
 | DialogView_Closing(Object, CancelEventArgs) | The view is closing
 | DialogView_IgnoreAllButtonClick(Object, EventArgs) | The ignore all button was clicked
 | DialogView_IgnoreButtonClick(Object, EventArgs) | The ignore button was clicked
 | DialogView_Load(Object, EventArgs) | The view has loaded
 | DialogView_OptionsButtonClick(Object, EventArgs) | The options button was clicked
 | DialogView_QueryTextBoxEnter(Object, EventArgs) | Query textbox has been entered
 | DialogView_QueryTextBoxTextChanged(Object, EventArgs) | The text in the query textbox changed
 | DialogView_SuggestionsListDoubleClick(Object, EventArgs) | The user double clicked on a suggested item. Not mandatory to implement.
 | DialogView_UndoButtonClick(Object, EventArgs) | The undo button was clicked
 | DialogView_UserNeedsSuggestionsChanged(Object, EventArgs) | User has checked the "Find Suggestions" checkbox (if it exists).
Remarks
Call these methods when events occur in the IDialogView GUI, or hook them up as handlers directly.


DialogView_AddButtonClick Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
DialogView_AddButtonClick Method (sender, e)
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewEventHandler ► DialogView_AddButtonClick(Object, EventArgs)
Keyoti RapidSpell Desktop .NET
The add button was clicked
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void DialogView_AddButtonClick(
    Object sender,
    EventArgs e
)
void DialogView_AddButtonClick(
    Object sender,
    EventArgs e
)
Sub DialogView_AddButtonClick (
    sender As Object,
    e As EventArgs
)
Sub DialogView_AddButtonClick (
    sender As Object,
    e As EventArgs
)
void DialogView_AddButtonClick(
    Object^ sender,
    EventArgs^ e
)
void DialogView_AddButtonClick(
    Object^ sender,
    EventArgs^ e
)
abstract DialogView_AddButtonClick :
        sender : Object *
        e : EventArgs -> unit

abstract DialogView_AddButtonClick :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


DialogView_CancelButtonClick Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
DialogView_CancelButtonClick Method (sender, e)
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewEventHandler ► DialogView_CancelButtonClick(Object, EventArgs)
Keyoti RapidSpell Desktop .NET
The cancel button was clicked
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void DialogView_CancelButtonClick(
    Object sender,
    EventArgs e
)
void DialogView_CancelButtonClick(
    Object sender,
    EventArgs e
)
Sub DialogView_CancelButtonClick (
    sender As Object,
    e As EventArgs
)
Sub DialogView_CancelButtonClick (
    sender As Object,
    e As EventArgs
)
void DialogView_CancelButtonClick(
    Object^ sender,
    EventArgs^ e
)
void DialogView_CancelButtonClick(
    Object^ sender,
    EventArgs^ e
)
abstract DialogView_CancelButtonClick :
        sender : Object *
        e : EventArgs -> unit

abstract DialogView_CancelButtonClick :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


DialogView_ChangeAllButtonClick Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
DialogView_ChangeAllButtonClick Method (sender, e)
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewEventHandler ► DialogView_ChangeAllButtonClick(Object, EventArgs)
Keyoti RapidSpell Desktop .NET
The change-all button was clicked
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void DialogView_ChangeAllButtonClick(
    Object sender,
    EventArgs e
)
void DialogView_ChangeAllButtonClick(
    Object sender,
    EventArgs e
)
Sub DialogView_ChangeAllButtonClick (
    sender As Object,
    e As EventArgs
)
Sub DialogView_ChangeAllButtonClick (
    sender As Object,
    e As EventArgs
)
void DialogView_ChangeAllButtonClick(
    Object^ sender,
    EventArgs^ e
)
void DialogView_ChangeAllButtonClick(
    Object^ sender,
    EventArgs^ e
)
abstract DialogView_ChangeAllButtonClick :
        sender : Object *
        e : EventArgs -> unit

abstract DialogView_ChangeAllButtonClick :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


DialogView_ChangeButtonClick Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
DialogView_ChangeButtonClick Method (sender, e)
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewEventHandler ► DialogView_ChangeButtonClick(Object, EventArgs)
Keyoti RapidSpell Desktop .NET
The change button was clicked
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void DialogView_ChangeButtonClick(
    Object sender,
    EventArgs e
)
void DialogView_ChangeButtonClick(
    Object sender,
    EventArgs e
)
Sub DialogView_ChangeButtonClick (
    sender As Object,
    e As EventArgs
)
Sub DialogView_ChangeButtonClick (
    sender As Object,
    e As EventArgs
)
void DialogView_ChangeButtonClick(
    Object^ sender,
    EventArgs^ e
)
void DialogView_ChangeButtonClick(
    Object^ sender,
    EventArgs^ e
)
abstract DialogView_ChangeButtonClick :
        sender : Object *
        e : EventArgs -> unit

abstract DialogView_ChangeButtonClick :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


DialogView_Closing Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
DialogView_Closing Method (sender, e)
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewEventHandler ► DialogView_Closing(Object, CancelEventArgs)
Keyoti RapidSpell Desktop .NET
The view is closing
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void DialogView_Closing(
    Object sender,
    CancelEventArgs e
)
void DialogView_Closing(
    Object sender,
    CancelEventArgs e
)
Sub DialogView_Closing (
    sender As Object,
    e As CancelEventArgs
)
Sub DialogView_Closing (
    sender As Object,
    e As CancelEventArgs
)
void DialogView_Closing(
    Object^ sender,
    CancelEventArgs^ e
)
void DialogView_Closing(
    Object^ sender,
    CancelEventArgs^ e
)
abstract DialogView_Closing :
        sender : Object *
        e : CancelEventArgs -> unit

abstract DialogView_Closing :
        sender : Object *
        e : CancelEventArgs -> unit
Parameters
sender (Object)
e (CancelEventArgs)


DialogView_IgnoreAllButtonClick Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
DialogView_IgnoreAllButtonClick Method (sender, e)
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewEventHandler ► DialogView_IgnoreAllButtonClick(Object, EventArgs)
Keyoti RapidSpell Desktop .NET
The ignore all button was clicked
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void DialogView_IgnoreAllButtonClick(
    Object sender,
    EventArgs e
)
void DialogView_IgnoreAllButtonClick(
    Object sender,
    EventArgs e
)
Sub DialogView_IgnoreAllButtonClick (
    sender As Object,
    e As EventArgs
)
Sub DialogView_IgnoreAllButtonClick (
    sender As Object,
    e As EventArgs
)
void DialogView_IgnoreAllButtonClick(
    Object^ sender,
    EventArgs^ e
)
void DialogView_IgnoreAllButtonClick(
    Object^ sender,
    EventArgs^ e
)
abstract DialogView_IgnoreAllButtonClick :
        sender : Object *
        e : EventArgs -> unit

abstract DialogView_IgnoreAllButtonClick :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


DialogView_IgnoreButtonClick Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
DialogView_IgnoreButtonClick Method (sender, e)
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewEventHandler ► DialogView_IgnoreButtonClick(Object, EventArgs)
Keyoti RapidSpell Desktop .NET
The ignore button was clicked
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void DialogView_IgnoreButtonClick(
    Object sender,
    EventArgs e
)
void DialogView_IgnoreButtonClick(
    Object sender,
    EventArgs e
)
Sub DialogView_IgnoreButtonClick (
    sender As Object,
    e As EventArgs
)
Sub DialogView_IgnoreButtonClick (
    sender As Object,
    e As EventArgs
)
void DialogView_IgnoreButtonClick(
    Object^ sender,
    EventArgs^ e
)
void DialogView_IgnoreButtonClick(
    Object^ sender,
    EventArgs^ e
)
abstract DialogView_IgnoreButtonClick :
        sender : Object *
        e : EventArgs -> unit

abstract DialogView_IgnoreButtonClick :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


DialogView_Load Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
DialogView_Load Method (sender, e)
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewEventHandler ► DialogView_Load(Object, EventArgs)
Keyoti RapidSpell Desktop .NET
The view has loaded
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void DialogView_Load(
    Object sender,
    EventArgs e
)
void DialogView_Load(
    Object sender,
    EventArgs e
)
Sub DialogView_Load (
    sender As Object,
    e As EventArgs
)
Sub DialogView_Load (
    sender As Object,
    e As EventArgs
)
void DialogView_Load(
    Object^ sender,
    EventArgs^ e
)
void DialogView_Load(
    Object^ sender,
    EventArgs^ e
)
abstract DialogView_Load :
        sender : Object *
        e : EventArgs -> unit

abstract DialogView_Load :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


DialogView_OptionsButtonClick Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
DialogView_OptionsButtonClick Method (sender, e)
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewEventHandler ► DialogView_OptionsButtonClick(Object, EventArgs)
Keyoti RapidSpell Desktop .NET
The options button was clicked
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void DialogView_OptionsButtonClick(
    Object sender,
    EventArgs e
)
void DialogView_OptionsButtonClick(
    Object sender,
    EventArgs e
)
Sub DialogView_OptionsButtonClick (
    sender As Object,
    e As EventArgs
)
Sub DialogView_OptionsButtonClick (
    sender As Object,
    e As EventArgs
)
void DialogView_OptionsButtonClick(
    Object^ sender,
    EventArgs^ e
)
void DialogView_OptionsButtonClick(
    Object^ sender,
    EventArgs^ e
)
abstract DialogView_OptionsButtonClick :
        sender : Object *
        e : EventArgs -> unit

abstract DialogView_OptionsButtonClick :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


DialogView_QueryTextBoxEnter Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
DialogView_QueryTextBoxEnter Method (sender, e)
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewEventHandler ► DialogView_QueryTextBoxEnter(Object, EventArgs)
Keyoti RapidSpell Desktop .NET
Query textbox has been entered
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void DialogView_QueryTextBoxEnter(
    Object sender,
    EventArgs e
)
void DialogView_QueryTextBoxEnter(
    Object sender,
    EventArgs e
)
Sub DialogView_QueryTextBoxEnter (
    sender As Object,
    e As EventArgs
)
Sub DialogView_QueryTextBoxEnter (
    sender As Object,
    e As EventArgs
)
void DialogView_QueryTextBoxEnter(
    Object^ sender,
    EventArgs^ e
)
void DialogView_QueryTextBoxEnter(
    Object^ sender,
    EventArgs^ e
)
abstract DialogView_QueryTextBoxEnter :
        sender : Object *
        e : EventArgs -> unit

abstract DialogView_QueryTextBoxEnter :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


DialogView_QueryTextBoxTextChanged Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
DialogView_QueryTextBoxTextChanged Method (sender, e)
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewEventHandler ► DialogView_QueryTextBoxTextChanged(Object, EventArgs)
Keyoti RapidSpell Desktop .NET
The text in the query textbox changed
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void DialogView_QueryTextBoxTextChanged(
    Object sender,
    EventArgs e
)
void DialogView_QueryTextBoxTextChanged(
    Object sender,
    EventArgs e
)
Sub DialogView_QueryTextBoxTextChanged (
    sender As Object,
    e As EventArgs
)
Sub DialogView_QueryTextBoxTextChanged (
    sender As Object,
    e As EventArgs
)
void DialogView_QueryTextBoxTextChanged(
    Object^ sender,
    EventArgs^ e
)
void DialogView_QueryTextBoxTextChanged(
    Object^ sender,
    EventArgs^ e
)
abstract DialogView_QueryTextBoxTextChanged :
        sender : Object *
        e : EventArgs -> unit

abstract DialogView_QueryTextBoxTextChanged :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


DialogView_SuggestionsListDoubleClick Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
DialogView_SuggestionsListDoubleClick Method (sender, e)
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewEventHandler ► DialogView_SuggestionsListDoubleClick(Object, EventArgs)
Keyoti RapidSpell Desktop .NET
The user double clicked on a suggested item. Not mandatory to implement.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void DialogView_SuggestionsListDoubleClick(
    Object sender,
    EventArgs e
)
void DialogView_SuggestionsListDoubleClick(
    Object sender,
    EventArgs e
)
Sub DialogView_SuggestionsListDoubleClick (
    sender As Object,
    e As EventArgs
)
Sub DialogView_SuggestionsListDoubleClick (
    sender As Object,
    e As EventArgs
)
void DialogView_SuggestionsListDoubleClick(
    Object^ sender,
    EventArgs^ e
)
void DialogView_SuggestionsListDoubleClick(
    Object^ sender,
    EventArgs^ e
)
abstract DialogView_SuggestionsListDoubleClick :
        sender : Object *
        e : EventArgs -> unit

abstract DialogView_SuggestionsListDoubleClick :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


DialogView_UndoButtonClick Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
DialogView_UndoButtonClick Method (sender, e)
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewEventHandler ► DialogView_UndoButtonClick(Object, EventArgs)
Keyoti RapidSpell Desktop .NET
The undo button was clicked
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void DialogView_UndoButtonClick(
    Object sender,
    EventArgs e
)
void DialogView_UndoButtonClick(
    Object sender,
    EventArgs e
)
Sub DialogView_UndoButtonClick (
    sender As Object,
    e As EventArgs
)
Sub DialogView_UndoButtonClick (
    sender As Object,
    e As EventArgs
)
void DialogView_UndoButtonClick(
    Object^ sender,
    EventArgs^ e
)
void DialogView_UndoButtonClick(
    Object^ sender,
    EventArgs^ e
)
abstract DialogView_UndoButtonClick :
        sender : Object *
        e : EventArgs -> unit

abstract DialogView_UndoButtonClick :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


DialogView_UserNeedsSuggestionsChanged Method (sender, e)

Keyoti RapidSpell Desktop .NET API Docs
DialogView_UserNeedsSuggestionsChanged Method (sender, e)
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewEventHandler ► DialogView_UserNeedsSuggestionsChanged(Object, EventArgs)
Keyoti RapidSpell Desktop .NET
User has checked the "Find Suggestions" checkbox (if it exists).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void DialogView_UserNeedsSuggestionsChanged(
    Object sender,
    EventArgs e
)
void DialogView_UserNeedsSuggestionsChanged(
    Object sender,
    EventArgs e
)
Sub DialogView_UserNeedsSuggestionsChanged (
    sender As Object,
    e As EventArgs
)
Sub DialogView_UserNeedsSuggestionsChanged (
    sender As Object,
    e As EventArgs
)
void DialogView_UserNeedsSuggestionsChanged(
    Object^ sender,
    EventArgs^ e
)
void DialogView_UserNeedsSuggestionsChanged(
    Object^ sender,
    EventArgs^ e
)
abstract DialogView_UserNeedsSuggestionsChanged :
        sender : Object *
        e : EventArgs -> unit

abstract DialogView_UserNeedsSuggestionsChanged :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


IDialogViewOptions Interface

Keyoti RapidSpell Desktop .NET API Docs
IDialogViewOptions Interface
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewOptions
Keyoti RapidSpell Desktop .NET
Describes an option editor form
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public interface IDialogViewOptions
public interface IDialogViewOptions
Public Interface IDialogViewOptions
Public Interface IDialogViewOptions
public interface class IDialogViewOptions
public interface class IDialogViewOptions
type IDialogViewOptions =  interface end
type IDialogViewOptions =  interface end
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Dispose()()()() | Free resources
 | Options | The options to edit
 | OptionsFormAdvancedSettingsText | UI Text
 | OptionsFormAlwaysSuggestCorrectionsText | UI Text
 | OptionsFormBasicSettingsText | UI Text
 | OptionsFormCancelText | UI Text
 | OptionsFormCheckAsYouTypeText | UI Text
 | OptionsFormIgnoreImproperCaseText | UI Text
 | OptionsFormIgnoreInternetAddressesText | UI Text
 | OptionsFormIgnoreWordsInUppercaseText | UI Text
 | OptionsFormIgnoreWordsWithNumbersText | UI Text
 | OptionsFormOKText | UI Text
 | OptionsFormRecheckTextText | UI Text
 | OptionsFormSuggestFromMainDictionaryOnlyText | UI Text
 | OptionsFormTitleText | UI Text
 | OptionsFormUserDictionaryEditText | UI Text
 | RecheckDocumentRequest | Fired when user requests document recheck
 | SelectUserDictionary | Fired when user wants to edit user dictionary
 | ShowDialog(Object, Boolean, Boolean, Boolean) | Shows the window modally


Dispose Method

Keyoti RapidSpell Desktop .NET API Docs
Dispose Method
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewOptions ► Dispose()()()()
Keyoti RapidSpell Desktop .NET
Free resources
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void Dispose()
void Dispose()
Sub Dispose
Sub Dispose
void Dispose()
void Dispose()
abstract Dispose : unit -> unit

abstract Dispose : unit -> unit


Options Property

Keyoti RapidSpell Desktop .NET API Docs
Options Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewOptions ► Options
Keyoti RapidSpell Desktop .NET
The options to edit
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
UserOptions Options { get; set; }
UserOptions Options { get; set; }
Property Options As UserOptions
    Get
    Set
Property Options As UserOptions
    Get
    Set
property UserOptions^ Options {
    UserOptions^ get ();
    void set (UserOptions^ value);
}
property UserOptions^ Options {
    UserOptions^ get ();
    void set (UserOptions^ value);
}
abstract Options : UserOptions with get, set

abstract Options : UserOptions with get, set
Property Value
UserOptions


OptionsFormAdvancedSettingsText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsFormAdvancedSettingsText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewOptions ► OptionsFormAdvancedSettingsText
Keyoti RapidSpell Desktop .NET
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string OptionsFormAdvancedSettingsText { get; set; }
string OptionsFormAdvancedSettingsText { get; set; }
Property OptionsFormAdvancedSettingsText As String
    Get
    Set
Property OptionsFormAdvancedSettingsText As String
    Get
    Set
property String^ OptionsFormAdvancedSettingsText {
    String^ get ();
    void set (String^ value);
}
property String^ OptionsFormAdvancedSettingsText {
    String^ get ();
    void set (String^ value);
}
abstract OptionsFormAdvancedSettingsText : string with get, set

abstract OptionsFormAdvancedSettingsText : string with get, set
Property Value
String


OptionsFormAlwaysSuggestCorrectionsText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsFormAlwaysSuggestCorrectionsText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewOptions ► OptionsFormAlwaysSuggestCorrectionsText
Keyoti RapidSpell Desktop .NET
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string OptionsFormAlwaysSuggestCorrectionsText { get; set; }
string OptionsFormAlwaysSuggestCorrectionsText { get; set; }
Property OptionsFormAlwaysSuggestCorrectionsText As String
    Get
    Set
Property OptionsFormAlwaysSuggestCorrectionsText As String
    Get
    Set
property String^ OptionsFormAlwaysSuggestCorrectionsText {
    String^ get ();
    void set (String^ value);
}
property String^ OptionsFormAlwaysSuggestCorrectionsText {
    String^ get ();
    void set (String^ value);
}
abstract OptionsFormAlwaysSuggestCorrectionsText : string with get, set

abstract OptionsFormAlwaysSuggestCorrectionsText : string with get, set
Property Value
String


OptionsFormBasicSettingsText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsFormBasicSettingsText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewOptions ► OptionsFormBasicSettingsText
Keyoti RapidSpell Desktop .NET
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string OptionsFormBasicSettingsText { get; set; }
string OptionsFormBasicSettingsText { get; set; }
Property OptionsFormBasicSettingsText As String
    Get
    Set
Property OptionsFormBasicSettingsText As String
    Get
    Set
property String^ OptionsFormBasicSettingsText {
    String^ get ();
    void set (String^ value);
}
property String^ OptionsFormBasicSettingsText {
    String^ get ();
    void set (String^ value);
}
abstract OptionsFormBasicSettingsText : string with get, set

abstract OptionsFormBasicSettingsText : string with get, set
Property Value
String


OptionsFormCancelText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsFormCancelText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewOptions ► OptionsFormCancelText
Keyoti RapidSpell Desktop .NET
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string OptionsFormCancelText { get; set; }
string OptionsFormCancelText { get; set; }
Property OptionsFormCancelText As String
    Get
    Set
Property OptionsFormCancelText As String
    Get
    Set
property String^ OptionsFormCancelText {
    String^ get ();
    void set (String^ value);
}
property String^ OptionsFormCancelText {
    String^ get ();
    void set (String^ value);
}
abstract OptionsFormCancelText : string with get, set

abstract OptionsFormCancelText : string with get, set
Property Value
String


OptionsFormCheckAsYouTypeText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsFormCheckAsYouTypeText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewOptions ► OptionsFormCheckAsYouTypeText
Keyoti RapidSpell Desktop .NET
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string OptionsFormCheckAsYouTypeText { get; set; }
string OptionsFormCheckAsYouTypeText { get; set; }
Property OptionsFormCheckAsYouTypeText As String
    Get
    Set
Property OptionsFormCheckAsYouTypeText As String
    Get
    Set
property String^ OptionsFormCheckAsYouTypeText {
    String^ get ();
    void set (String^ value);
}
property String^ OptionsFormCheckAsYouTypeText {
    String^ get ();
    void set (String^ value);
}
abstract OptionsFormCheckAsYouTypeText : string with get, set

abstract OptionsFormCheckAsYouTypeText : string with get, set
Property Value
String


OptionsFormIgnoreImproperCaseText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsFormIgnoreImproperCaseText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewOptions ► OptionsFormIgnoreImproperCaseText
Keyoti RapidSpell Desktop .NET
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string OptionsFormIgnoreImproperCaseText { get; set; }
string OptionsFormIgnoreImproperCaseText { get; set; }
Property OptionsFormIgnoreImproperCaseText As String
    Get
    Set
Property OptionsFormIgnoreImproperCaseText As String
    Get
    Set
property String^ OptionsFormIgnoreImproperCaseText {
    String^ get ();
    void set (String^ value);
}
property String^ OptionsFormIgnoreImproperCaseText {
    String^ get ();
    void set (String^ value);
}
abstract OptionsFormIgnoreImproperCaseText : string with get, set

abstract OptionsFormIgnoreImproperCaseText : string with get, set
Property Value
String


OptionsFormIgnoreInternetAddressesText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsFormIgnoreInternetAddressesText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewOptions ► OptionsFormIgnoreInternetAddressesText
Keyoti RapidSpell Desktop .NET
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string OptionsFormIgnoreInternetAddressesText { get; set; }
string OptionsFormIgnoreInternetAddressesText { get; set; }
Property OptionsFormIgnoreInternetAddressesText As String
    Get
    Set
Property OptionsFormIgnoreInternetAddressesText As String
    Get
    Set
property String^ OptionsFormIgnoreInternetAddressesText {
    String^ get ();
    void set (String^ value);
}
property String^ OptionsFormIgnoreInternetAddressesText {
    String^ get ();
    void set (String^ value);
}
abstract OptionsFormIgnoreInternetAddressesText : string with get, set

abstract OptionsFormIgnoreInternetAddressesText : string with get, set
Property Value
String


OptionsFormIgnoreWordsInUppercaseText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsFormIgnoreWordsInUppercaseText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewOptions ► OptionsFormIgnoreWordsInUppercaseText
Keyoti RapidSpell Desktop .NET
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string OptionsFormIgnoreWordsInUppercaseText { get; set; }
string OptionsFormIgnoreWordsInUppercaseText { get; set; }
Property OptionsFormIgnoreWordsInUppercaseText As String
    Get
    Set
Property OptionsFormIgnoreWordsInUppercaseText As String
    Get
    Set
property String^ OptionsFormIgnoreWordsInUppercaseText {
    String^ get ();
    void set (String^ value);
}
property String^ OptionsFormIgnoreWordsInUppercaseText {
    String^ get ();
    void set (String^ value);
}
abstract OptionsFormIgnoreWordsInUppercaseText : string with get, set

abstract OptionsFormIgnoreWordsInUppercaseText : string with get, set
Property Value
String


OptionsFormIgnoreWordsWithNumbersText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsFormIgnoreWordsWithNumbersText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewOptions ► OptionsFormIgnoreWordsWithNumbersText
Keyoti RapidSpell Desktop .NET
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string OptionsFormIgnoreWordsWithNumbersText { get; set; }
string OptionsFormIgnoreWordsWithNumbersText { get; set; }
Property OptionsFormIgnoreWordsWithNumbersText As String
    Get
    Set
Property OptionsFormIgnoreWordsWithNumbersText As String
    Get
    Set
property String^ OptionsFormIgnoreWordsWithNumbersText {
    String^ get ();
    void set (String^ value);
}
property String^ OptionsFormIgnoreWordsWithNumbersText {
    String^ get ();
    void set (String^ value);
}
abstract OptionsFormIgnoreWordsWithNumbersText : string with get, set

abstract OptionsFormIgnoreWordsWithNumbersText : string with get, set
Property Value
String


OptionsFormOKText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsFormOKText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewOptions ► OptionsFormOKText
Keyoti RapidSpell Desktop .NET
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string OptionsFormOKText { get; set; }
string OptionsFormOKText { get; set; }
Property OptionsFormOKText As String
    Get
    Set
Property OptionsFormOKText As String
    Get
    Set
property String^ OptionsFormOKText {
    String^ get ();
    void set (String^ value);
}
property String^ OptionsFormOKText {
    String^ get ();
    void set (String^ value);
}
abstract OptionsFormOKText : string with get, set

abstract OptionsFormOKText : string with get, set
Property Value
String


OptionsFormRecheckTextText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsFormRecheckTextText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewOptions ► OptionsFormRecheckTextText
Keyoti RapidSpell Desktop .NET
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string OptionsFormRecheckTextText { get; set; }
string OptionsFormRecheckTextText { get; set; }
Property OptionsFormRecheckTextText As String
    Get
    Set
Property OptionsFormRecheckTextText As String
    Get
    Set
property String^ OptionsFormRecheckTextText {
    String^ get ();
    void set (String^ value);
}
property String^ OptionsFormRecheckTextText {
    String^ get ();
    void set (String^ value);
}
abstract OptionsFormRecheckTextText : string with get, set

abstract OptionsFormRecheckTextText : string with get, set
Property Value
String


OptionsFormSuggestFromMainDictionaryOnlyText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsFormSuggestFromMainDictionaryOnlyText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewOptions ► OptionsFormSuggestFromMainDictionaryOnlyText
Keyoti RapidSpell Desktop .NET
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string OptionsFormSuggestFromMainDictionaryOnlyText { get; set; }
string OptionsFormSuggestFromMainDictionaryOnlyText { get; set; }
Property OptionsFormSuggestFromMainDictionaryOnlyText As String
    Get
    Set
Property OptionsFormSuggestFromMainDictionaryOnlyText As String
    Get
    Set
property String^ OptionsFormSuggestFromMainDictionaryOnlyText {
    String^ get ();
    void set (String^ value);
}
property String^ OptionsFormSuggestFromMainDictionaryOnlyText {
    String^ get ();
    void set (String^ value);
}
abstract OptionsFormSuggestFromMainDictionaryOnlyText : string with get, set

abstract OptionsFormSuggestFromMainDictionaryOnlyText : string with get, set
Property Value
String


OptionsFormTitleText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsFormTitleText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewOptions ► OptionsFormTitleText
Keyoti RapidSpell Desktop .NET
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string OptionsFormTitleText { get; set; }
string OptionsFormTitleText { get; set; }
Property OptionsFormTitleText As String
    Get
    Set
Property OptionsFormTitleText As String
    Get
    Set
property String^ OptionsFormTitleText {
    String^ get ();
    void set (String^ value);
}
property String^ OptionsFormTitleText {
    String^ get ();
    void set (String^ value);
}
abstract OptionsFormTitleText : string with get, set

abstract OptionsFormTitleText : string with get, set
Property Value
String


OptionsFormUserDictionaryEditText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsFormUserDictionaryEditText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewOptions ► OptionsFormUserDictionaryEditText
Keyoti RapidSpell Desktop .NET
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string OptionsFormUserDictionaryEditText { get; set; }
string OptionsFormUserDictionaryEditText { get; set; }
Property OptionsFormUserDictionaryEditText As String
    Get
    Set
Property OptionsFormUserDictionaryEditText As String
    Get
    Set
property String^ OptionsFormUserDictionaryEditText {
    String^ get ();
    void set (String^ value);
}
property String^ OptionsFormUserDictionaryEditText {
    String^ get ();
    void set (String^ value);
}
abstract OptionsFormUserDictionaryEditText : string with get, set

abstract OptionsFormUserDictionaryEditText : string with get, set
Property Value
String


RecheckDocumentRequest Event

Keyoti RapidSpell Desktop .NET API Docs
RecheckDocumentRequest Event
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewOptions ► RecheckDocumentRequest
Keyoti RapidSpell Desktop .NET
Fired when user requests document recheck
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event EventHandler RecheckDocumentRequest
event EventHandler RecheckDocumentRequest
Event RecheckDocumentRequest As EventHandler
Event RecheckDocumentRequest As EventHandler
 event EventHandler^ RecheckDocumentRequest {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
 event EventHandler^ RecheckDocumentRequest {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract RecheckDocumentRequest : IEvent<EventHandler,
    EventArgs>

abstract RecheckDocumentRequest : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


SelectUserDictionary Event

Keyoti RapidSpell Desktop .NET API Docs
SelectUserDictionary Event
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewOptions ► SelectUserDictionary
Keyoti RapidSpell Desktop .NET
Fired when user wants to edit user dictionary
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event EventHandler SelectUserDictionary
event EventHandler SelectUserDictionary
Event SelectUserDictionary As EventHandler
Event SelectUserDictionary As EventHandler
 event EventHandler^ SelectUserDictionary {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
 event EventHandler^ SelectUserDictionary {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract SelectUserDictionary : IEvent<EventHandler,
    EventArgs>

abstract SelectUserDictionary : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


ShowDialog Method (owner, showCheckAsYouTypeOption, showFindSuggestionsOption, showUserDictionaryButton)

Keyoti RapidSpell Desktop .NET API Docs
ShowDialog Method (owner, showCheckAsYouTypeOption, showFindSuggestionsOption, showUserDictionaryButton)
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewOptions ► ShowDialog(Object, Boolean, Boolean, Boolean)
Keyoti RapidSpell Desktop .NET
Shows the window modally
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
DialogResult ShowDialog(
    Object owner,
    bool showCheckAsYouTypeOption,
    bool showFindSuggestionsOption,
    bool showUserDictionaryButton
)
DialogResult ShowDialog(
    Object owner,
    bool showCheckAsYouTypeOption,
    bool showFindSuggestionsOption,
    bool showUserDictionaryButton
)
Function ShowDialog (
    owner As Object,
    showCheckAsYouTypeOption As Boolean,
    showFindSuggestionsOption As Boolean,
    showUserDictionaryButton As Boolean
) As DialogResult
Function ShowDialog (
    owner As Object,
    showCheckAsYouTypeOption As Boolean,
    showFindSuggestionsOption As Boolean,
    showUserDictionaryButton As Boolean
) As DialogResult
DialogResult ShowDialog(
    Object^ owner,
    bool showCheckAsYouTypeOption,
    bool showFindSuggestionsOption,
    bool showUserDictionaryButton
)
DialogResult ShowDialog(
    Object^ owner,
    bool showCheckAsYouTypeOption,
    bool showFindSuggestionsOption,
    bool showUserDictionaryButton
)
abstract ShowDialog :
        owner : Object *
        showCheckAsYouTypeOption : bool *
        showFindSuggestionsOption : bool *
        showUserDictionaryButton : bool -> DialogResult

abstract ShowDialog :
        owner : Object *
        showCheckAsYouTypeOption : bool *
        showFindSuggestionsOption : bool *
        showUserDictionaryButton : bool -> DialogResult
Parameters
owner (Object)
showCheckAsYouTypeOption (Boolean)
showFindSuggestionsOption (Boolean)
showUserDictionaryButton (Boolean)
Return Value
DialogResult


IDialogViewUserDictionaryEdit Interface

Keyoti RapidSpell Desktop .NET API Docs
IDialogViewUserDictionaryEdit Interface
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewUserDictionaryEdit
Keyoti RapidSpell Desktop .NET
Describes a user dictionary editor window
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public interface IDialogViewUserDictionaryEdit
public interface IDialogViewUserDictionaryEdit
Public Interface IDialogViewUserDictionaryEdit
Public Interface IDialogViewUserDictionaryEdit
public interface class IDialogViewUserDictionaryEdit
public interface class IDialogViewUserDictionaryEdit
type IDialogViewUserDictionaryEdit =  interface end
type IDialogViewUserDictionaryEdit =  interface end
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddWord | Word is being added
 | Dispose()()()() | Frees resources
 | RemoveWord | Word is being removed
 | ShowDialog(Object, ArrayList) | Shows the form modally
 | UserDictionaryFormAddText | UI text
 | UserDictionaryFormCancelText | UI text
 | UserDictionaryFormContentsText | UI text
 | UserDictionaryFormDeleteText | UI text
 | UserDictionaryFormDictionaryLabelText | UI text
 | UserDictionaryFormOKText | UI text
 | UserDictionaryFormTitleText | UI text
 | UserDictionaryFormWordLabelText | UI text


AddWord Event

Keyoti RapidSpell Desktop .NET API Docs
AddWord Event
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewUserDictionaryEdit ► AddWord
Keyoti RapidSpell Desktop .NET
Word is being added
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event UserDictionaryEditEventHandler AddWord
event UserDictionaryEditEventHandler AddWord
Event AddWord As UserDictionaryEditEventHandler
Event AddWord As UserDictionaryEditEventHandler
 event UserDictionaryEditEventHandler^ AddWord {
    void add (UserDictionaryEditEventHandler^ value);
    void remove (UserDictionaryEditEventHandler^ value);
}
 event UserDictionaryEditEventHandler^ AddWord {
    void add (UserDictionaryEditEventHandler^ value);
    void remove (UserDictionaryEditEventHandler^ value);
}
abstract AddWord : IEvent<UserDictionaryEditEventHandler,
    UserDictionaryEditEventArgs>

abstract AddWord : IEvent<UserDictionaryEditEventHandler,
    UserDictionaryEditEventArgs>
Value
UserDictionaryEditEventHandler


Dispose Method

Keyoti RapidSpell Desktop .NET API Docs
Dispose Method
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewUserDictionaryEdit ► Dispose()()()()
Keyoti RapidSpell Desktop .NET
Frees resources
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void Dispose()
void Dispose()
Sub Dispose
Sub Dispose
void Dispose()
void Dispose()
abstract Dispose : unit -> unit

abstract Dispose : unit -> unit


RemoveWord Event

Keyoti RapidSpell Desktop .NET API Docs
RemoveWord Event
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewUserDictionaryEdit ► RemoveWord
Keyoti RapidSpell Desktop .NET
Word is being removed
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event UserDictionaryEditEventHandler RemoveWord
event UserDictionaryEditEventHandler RemoveWord
Event RemoveWord As UserDictionaryEditEventHandler
Event RemoveWord As UserDictionaryEditEventHandler
 event UserDictionaryEditEventHandler^ RemoveWord {
    void add (UserDictionaryEditEventHandler^ value);
    void remove (UserDictionaryEditEventHandler^ value);
}
 event UserDictionaryEditEventHandler^ RemoveWord {
    void add (UserDictionaryEditEventHandler^ value);
    void remove (UserDictionaryEditEventHandler^ value);
}
abstract RemoveWord : IEvent<UserDictionaryEditEventHandler,
    UserDictionaryEditEventArgs>

abstract RemoveWord : IEvent<UserDictionaryEditEventHandler,
    UserDictionaryEditEventArgs>
Value
UserDictionaryEditEventHandler


ShowDialog Method (owner, userDictionaryContents)

Keyoti RapidSpell Desktop .NET API Docs
ShowDialog Method (owner, userDictionaryContents)
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewUserDictionaryEdit ► ShowDialog(Object, ArrayList)
Keyoti RapidSpell Desktop .NET
Shows the form modally
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
DialogResult ShowDialog(
    Object owner,
    ArrayList userDictionaryContents
)
DialogResult ShowDialog(
    Object owner,
    ArrayList userDictionaryContents
)
Function ShowDialog (
    owner As Object,
    userDictionaryContents As ArrayList
) As DialogResult
Function ShowDialog (
    owner As Object,
    userDictionaryContents As ArrayList
) As DialogResult
DialogResult ShowDialog(
    Object^ owner,
    ArrayList^ userDictionaryContents
)
DialogResult ShowDialog(
    Object^ owner,
    ArrayList^ userDictionaryContents
)
abstract ShowDialog :
        owner : Object *
        userDictionaryContents : ArrayList -> DialogResult

abstract ShowDialog :
        owner : Object *
        userDictionaryContents : ArrayList -> DialogResult
Parameters
owner (Object)
userDictionaryContents (ArrayList)
Return Value
DialogResult


UserDictionaryFormAddText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionaryFormAddText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewUserDictionaryEdit ► UserDictionaryFormAddText
Keyoti RapidSpell Desktop .NET
UI text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string UserDictionaryFormAddText { get; set; }
string UserDictionaryFormAddText { get; set; }
Property UserDictionaryFormAddText As String
    Get
    Set
Property UserDictionaryFormAddText As String
    Get
    Set
property String^ UserDictionaryFormAddText {
    String^ get ();
    void set (String^ value);
}
property String^ UserDictionaryFormAddText {
    String^ get ();
    void set (String^ value);
}
abstract UserDictionaryFormAddText : string with get, set

abstract UserDictionaryFormAddText : string with get, set
Property Value
String


UserDictionaryFormCancelText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionaryFormCancelText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewUserDictionaryEdit ► UserDictionaryFormCancelText
Keyoti RapidSpell Desktop .NET
UI text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string UserDictionaryFormCancelText { get; set; }
string UserDictionaryFormCancelText { get; set; }
Property UserDictionaryFormCancelText As String
    Get
    Set
Property UserDictionaryFormCancelText As String
    Get
    Set
property String^ UserDictionaryFormCancelText {
    String^ get ();
    void set (String^ value);
}
property String^ UserDictionaryFormCancelText {
    String^ get ();
    void set (String^ value);
}
abstract UserDictionaryFormCancelText : string with get, set

abstract UserDictionaryFormCancelText : string with get, set
Property Value
String


UserDictionaryFormContentsText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionaryFormContentsText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewUserDictionaryEdit ► UserDictionaryFormContentsText
Keyoti RapidSpell Desktop .NET
UI text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string UserDictionaryFormContentsText { get; set; }
string UserDictionaryFormContentsText { get; set; }
Property UserDictionaryFormContentsText As String
    Get
    Set
Property UserDictionaryFormContentsText As String
    Get
    Set
property String^ UserDictionaryFormContentsText {
    String^ get ();
    void set (String^ value);
}
property String^ UserDictionaryFormContentsText {
    String^ get ();
    void set (String^ value);
}
abstract UserDictionaryFormContentsText : string with get, set

abstract UserDictionaryFormContentsText : string with get, set
Property Value
String


UserDictionaryFormDeleteText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionaryFormDeleteText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewUserDictionaryEdit ► UserDictionaryFormDeleteText
Keyoti RapidSpell Desktop .NET
UI text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string UserDictionaryFormDeleteText { get; set; }
string UserDictionaryFormDeleteText { get; set; }
Property UserDictionaryFormDeleteText As String
    Get
    Set
Property UserDictionaryFormDeleteText As String
    Get
    Set
property String^ UserDictionaryFormDeleteText {
    String^ get ();
    void set (String^ value);
}
property String^ UserDictionaryFormDeleteText {
    String^ get ();
    void set (String^ value);
}
abstract UserDictionaryFormDeleteText : string with get, set

abstract UserDictionaryFormDeleteText : string with get, set
Property Value
String


UserDictionaryFormDictionaryLabelText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionaryFormDictionaryLabelText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewUserDictionaryEdit ► UserDictionaryFormDictionaryLabelText
Keyoti RapidSpell Desktop .NET
UI text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string UserDictionaryFormDictionaryLabelText { get; set; }
string UserDictionaryFormDictionaryLabelText { get; set; }
Property UserDictionaryFormDictionaryLabelText As String
    Get
    Set
Property UserDictionaryFormDictionaryLabelText As String
    Get
    Set
property String^ UserDictionaryFormDictionaryLabelText {
    String^ get ();
    void set (String^ value);
}
property String^ UserDictionaryFormDictionaryLabelText {
    String^ get ();
    void set (String^ value);
}
abstract UserDictionaryFormDictionaryLabelText : string with get, set

abstract UserDictionaryFormDictionaryLabelText : string with get, set
Property Value
String


UserDictionaryFormOKText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionaryFormOKText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewUserDictionaryEdit ► UserDictionaryFormOKText
Keyoti RapidSpell Desktop .NET
UI text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string UserDictionaryFormOKText { get; set; }
string UserDictionaryFormOKText { get; set; }
Property UserDictionaryFormOKText As String
    Get
    Set
Property UserDictionaryFormOKText As String
    Get
    Set
property String^ UserDictionaryFormOKText {
    String^ get ();
    void set (String^ value);
}
property String^ UserDictionaryFormOKText {
    String^ get ();
    void set (String^ value);
}
abstract UserDictionaryFormOKText : string with get, set

abstract UserDictionaryFormOKText : string with get, set
Property Value
String


UserDictionaryFormTitleText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionaryFormTitleText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewUserDictionaryEdit ► UserDictionaryFormTitleText
Keyoti RapidSpell Desktop .NET
UI text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string UserDictionaryFormTitleText { get; set; }
string UserDictionaryFormTitleText { get; set; }
Property UserDictionaryFormTitleText As String
    Get
    Set
Property UserDictionaryFormTitleText As String
    Get
    Set
property String^ UserDictionaryFormTitleText {
    String^ get ();
    void set (String^ value);
}
property String^ UserDictionaryFormTitleText {
    String^ get ();
    void set (String^ value);
}
abstract UserDictionaryFormTitleText : string with get, set

abstract UserDictionaryFormTitleText : string with get, set
Property Value
String


UserDictionaryFormWordLabelText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionaryFormWordLabelText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewUserDictionaryEdit ► UserDictionaryFormWordLabelText
Keyoti RapidSpell Desktop .NET
UI text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string UserDictionaryFormWordLabelText { get; set; }
string UserDictionaryFormWordLabelText { get; set; }
Property UserDictionaryFormWordLabelText As String
    Get
    Set
Property UserDictionaryFormWordLabelText As String
    Get
    Set
property String^ UserDictionaryFormWordLabelText {
    String^ get ();
    void set (String^ value);
}
property String^ UserDictionaryFormWordLabelText {
    String^ get ();
    void set (String^ value);
}
abstract UserDictionaryFormWordLabelText : string with get, set

abstract UserDictionaryFormWordLabelText : string with get, set
Property Value
String


IDialogViewUserDictionarySelect Interface

Keyoti RapidSpell Desktop .NET API Docs
IDialogViewUserDictionarySelect Interface
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewUserDictionarySelect
Keyoti RapidSpell Desktop .NET
Describes a user dictionary editor window
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public interface IDialogViewUserDictionarySelect
public interface IDialogViewUserDictionarySelect
Public Interface IDialogViewUserDictionarySelect
Public Interface IDialogViewUserDictionarySelect
public interface class IDialogViewUserDictionarySelect
public interface class IDialogViewUserDictionarySelect
type IDialogViewUserDictionarySelect =  interface end
type IDialogViewUserDictionarySelect =  interface end
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddFile | File is being added
 | DefaultUserDictionaryItem | The selected default dictionary
 | Dispose()()()() | Frees resources
 | EditFile | File is being edited
 | RemoveFile | File is being removed
 | ShowDialog(Object, List<(Of <<'(String>)>>), String) | Shows the form modally
 | UserDictionarySelectFormAddText | UI text
 | UserDictionarySelectFormCancelText | UI text
 | UserDictionarySelectFormChangeDefaultText | UI text
 | UserDictionarySelectFormEditText | UI text
 | UserDictionarySelectFormGroupBoxTitleText | UI text
 | UserDictionarySelectFormNewText | UI text
 | UserDictionarySelectFormOkText | UI text
 | UserDictionarySelectFormRemoveText | UI text
 | UserDictionarySelectFormTitleText | UI text


AddFile Event

Keyoti RapidSpell Desktop .NET API Docs
AddFile Event
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewUserDictionarySelect ► AddFile
Keyoti RapidSpell Desktop .NET
File is being added
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event UserDictionaryFormEventHandler AddFile
event UserDictionaryFormEventHandler AddFile
Event AddFile As UserDictionaryFormEventHandler
Event AddFile As UserDictionaryFormEventHandler
 event UserDictionaryFormEventHandler^ AddFile {
    void add (UserDictionaryFormEventHandler^ value);
    void remove (UserDictionaryFormEventHandler^ value);
}
 event UserDictionaryFormEventHandler^ AddFile {
    void add (UserDictionaryFormEventHandler^ value);
    void remove (UserDictionaryFormEventHandler^ value);
}
abstract AddFile : IEvent<UserDictionaryFormEventHandler,
    UserDictionaryFormEventArgs>

abstract AddFile : IEvent<UserDictionaryFormEventHandler,
    UserDictionaryFormEventArgs>
Value
UserDictionaryFormEventHandler


DefaultUserDictionaryItem Property

Keyoti RapidSpell Desktop .NET API Docs
DefaultUserDictionaryItem Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewUserDictionarySelect ► DefaultUserDictionaryItem
Keyoti RapidSpell Desktop .NET
The selected default dictionary
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string DefaultUserDictionaryItem { get; }
string DefaultUserDictionaryItem { get; }
ReadOnly Property DefaultUserDictionaryItem As String
    Get
ReadOnly Property DefaultUserDictionaryItem As String
    Get
property String^ DefaultUserDictionaryItem {
    String^ get ();
}
property String^ DefaultUserDictionaryItem {
    String^ get ();
}
abstract DefaultUserDictionaryItem : string with get

abstract DefaultUserDictionaryItem : string with get
Property Value
String


Dispose Method

Keyoti RapidSpell Desktop .NET API Docs
Dispose Method
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewUserDictionarySelect ► Dispose()()()()
Keyoti RapidSpell Desktop .NET
Frees resources
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void Dispose()
void Dispose()
Sub Dispose
Sub Dispose
void Dispose()
void Dispose()
abstract Dispose : unit -> unit

abstract Dispose : unit -> unit


EditFile Event

Keyoti RapidSpell Desktop .NET API Docs
EditFile Event
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewUserDictionarySelect ► EditFile
Keyoti RapidSpell Desktop .NET
File is being edited
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event UserDictionaryFormEventHandler EditFile
event UserDictionaryFormEventHandler EditFile
Event EditFile As UserDictionaryFormEventHandler
Event EditFile As UserDictionaryFormEventHandler
 event UserDictionaryFormEventHandler^ EditFile {
    void add (UserDictionaryFormEventHandler^ value);
    void remove (UserDictionaryFormEventHandler^ value);
}
 event UserDictionaryFormEventHandler^ EditFile {
    void add (UserDictionaryFormEventHandler^ value);
    void remove (UserDictionaryFormEventHandler^ value);
}
abstract EditFile : IEvent<UserDictionaryFormEventHandler,
    UserDictionaryFormEventArgs>

abstract EditFile : IEvent<UserDictionaryFormEventHandler,
    UserDictionaryFormEventArgs>
Value
UserDictionaryFormEventHandler


RemoveFile Event

Keyoti RapidSpell Desktop .NET API Docs
RemoveFile Event
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewUserDictionarySelect ► RemoveFile
Keyoti RapidSpell Desktop .NET
File is being removed
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event UserDictionaryFormEventHandler RemoveFile
event UserDictionaryFormEventHandler RemoveFile
Event RemoveFile As UserDictionaryFormEventHandler
Event RemoveFile As UserDictionaryFormEventHandler
 event UserDictionaryFormEventHandler^ RemoveFile {
    void add (UserDictionaryFormEventHandler^ value);
    void remove (UserDictionaryFormEventHandler^ value);
}
 event UserDictionaryFormEventHandler^ RemoveFile {
    void add (UserDictionaryFormEventHandler^ value);
    void remove (UserDictionaryFormEventHandler^ value);
}
abstract RemoveFile : IEvent<UserDictionaryFormEventHandler,
    UserDictionaryFormEventArgs>

abstract RemoveFile : IEvent<UserDictionaryFormEventHandler,
    UserDictionaryFormEventArgs>
Value
UserDictionaryFormEventHandler


ShowDialog Method (owner, userDictionaryList, defaultDictionaryItem)

Keyoti RapidSpell Desktop .NET API Docs
ShowDialog Method (owner, userDictionaryList, defaultDictionaryItem)
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewUserDictionarySelect ► ShowDialog(Object, List<(Of <<'(String>)>>), String)
Keyoti RapidSpell Desktop .NET
Shows the form modally
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
DialogResult ShowDialog(
    Object owner,
    List<string> userDictionaryList,
    string defaultDictionaryItem
)
DialogResult ShowDialog(
    Object owner,
    List<string> userDictionaryList,
    string defaultDictionaryItem
)
Function ShowDialog (
    owner As Object,
    userDictionaryList As List(Of String),
    defaultDictionaryItem As String
) As DialogResult
Function ShowDialog (
    owner As Object,
    userDictionaryList As List(Of String),
    defaultDictionaryItem As String
) As DialogResult
DialogResult ShowDialog(
    Object^ owner,
    List<String^>^ userDictionaryList,
    String^ defaultDictionaryItem
)
DialogResult ShowDialog(
    Object^ owner,
    List<String^>^ userDictionaryList,
    String^ defaultDictionaryItem
)
abstract ShowDialog :
        owner : Object *
        userDictionaryList : List<string> *
        defaultDictionaryItem : string -> DialogResult

abstract ShowDialog :
        owner : Object *
        userDictionaryList : List<string> *
        defaultDictionaryItem : string -> DialogResult
Parameters
owner (Object)
userDictionaryList (List <(Of <(<' String >)>)>)
defaultDictionaryItem (String)
Return Value
DialogResult


UserDictionarySelectFormAddText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionarySelectFormAddText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewUserDictionarySelect ► UserDictionarySelectFormAddText
Keyoti RapidSpell Desktop .NET
UI text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string UserDictionarySelectFormAddText { get; set; }
string UserDictionarySelectFormAddText { get; set; }
Property UserDictionarySelectFormAddText As String
    Get
    Set
Property UserDictionarySelectFormAddText As String
    Get
    Set
property String^ UserDictionarySelectFormAddText {
    String^ get ();
    void set (String^ value);
}
property String^ UserDictionarySelectFormAddText {
    String^ get ();
    void set (String^ value);
}
abstract UserDictionarySelectFormAddText : string with get, set

abstract UserDictionarySelectFormAddText : string with get, set
Property Value
String


UserDictionarySelectFormCancelText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionarySelectFormCancelText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewUserDictionarySelect ► UserDictionarySelectFormCancelText
Keyoti RapidSpell Desktop .NET
UI text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string UserDictionarySelectFormCancelText { get; set; }
string UserDictionarySelectFormCancelText { get; set; }
Property UserDictionarySelectFormCancelText As String
    Get
    Set
Property UserDictionarySelectFormCancelText As String
    Get
    Set
property String^ UserDictionarySelectFormCancelText {
    String^ get ();
    void set (String^ value);
}
property String^ UserDictionarySelectFormCancelText {
    String^ get ();
    void set (String^ value);
}
abstract UserDictionarySelectFormCancelText : string with get, set

abstract UserDictionarySelectFormCancelText : string with get, set
Property Value
String


UserDictionarySelectFormChangeDefaultText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionarySelectFormChangeDefaultText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewUserDictionarySelect ► UserDictionarySelectFormChangeDefaultText
Keyoti RapidSpell Desktop .NET
UI text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string UserDictionarySelectFormChangeDefaultText { get; set; }
string UserDictionarySelectFormChangeDefaultText { get; set; }
Property UserDictionarySelectFormChangeDefaultText As String
    Get
    Set
Property UserDictionarySelectFormChangeDefaultText As String
    Get
    Set
property String^ UserDictionarySelectFormChangeDefaultText {
    String^ get ();
    void set (String^ value);
}
property String^ UserDictionarySelectFormChangeDefaultText {
    String^ get ();
    void set (String^ value);
}
abstract UserDictionarySelectFormChangeDefaultText : string with get, set

abstract UserDictionarySelectFormChangeDefaultText : string with get, set
Property Value
String


UserDictionarySelectFormEditText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionarySelectFormEditText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewUserDictionarySelect ► UserDictionarySelectFormEditText
Keyoti RapidSpell Desktop .NET
UI text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string UserDictionarySelectFormEditText { get; set; }
string UserDictionarySelectFormEditText { get; set; }
Property UserDictionarySelectFormEditText As String
    Get
    Set
Property UserDictionarySelectFormEditText As String
    Get
    Set
property String^ UserDictionarySelectFormEditText {
    String^ get ();
    void set (String^ value);
}
property String^ UserDictionarySelectFormEditText {
    String^ get ();
    void set (String^ value);
}
abstract UserDictionarySelectFormEditText : string with get, set

abstract UserDictionarySelectFormEditText : string with get, set
Property Value
String


UserDictionarySelectFormGroupBoxTitleText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionarySelectFormGroupBoxTitleText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewUserDictionarySelect ► UserDictionarySelectFormGroupBoxTitleText
Keyoti RapidSpell Desktop .NET
UI text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string UserDictionarySelectFormGroupBoxTitleText { get; set; }
string UserDictionarySelectFormGroupBoxTitleText { get; set; }
Property UserDictionarySelectFormGroupBoxTitleText As String
    Get
    Set
Property UserDictionarySelectFormGroupBoxTitleText As String
    Get
    Set
property String^ UserDictionarySelectFormGroupBoxTitleText {
    String^ get ();
    void set (String^ value);
}
property String^ UserDictionarySelectFormGroupBoxTitleText {
    String^ get ();
    void set (String^ value);
}
abstract UserDictionarySelectFormGroupBoxTitleText : string with get, set

abstract UserDictionarySelectFormGroupBoxTitleText : string with get, set
Property Value
String


UserDictionarySelectFormNewText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionarySelectFormNewText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewUserDictionarySelect ► UserDictionarySelectFormNewText
Keyoti RapidSpell Desktop .NET
UI text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string UserDictionarySelectFormNewText { get; set; }
string UserDictionarySelectFormNewText { get; set; }
Property UserDictionarySelectFormNewText As String
    Get
    Set
Property UserDictionarySelectFormNewText As String
    Get
    Set
property String^ UserDictionarySelectFormNewText {
    String^ get ();
    void set (String^ value);
}
property String^ UserDictionarySelectFormNewText {
    String^ get ();
    void set (String^ value);
}
abstract UserDictionarySelectFormNewText : string with get, set

abstract UserDictionarySelectFormNewText : string with get, set
Property Value
String


UserDictionarySelectFormOkText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionarySelectFormOkText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewUserDictionarySelect ► UserDictionarySelectFormOkText
Keyoti RapidSpell Desktop .NET
UI text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string UserDictionarySelectFormOkText { get; set; }
string UserDictionarySelectFormOkText { get; set; }
Property UserDictionarySelectFormOkText As String
    Get
    Set
Property UserDictionarySelectFormOkText As String
    Get
    Set
property String^ UserDictionarySelectFormOkText {
    String^ get ();
    void set (String^ value);
}
property String^ UserDictionarySelectFormOkText {
    String^ get ();
    void set (String^ value);
}
abstract UserDictionarySelectFormOkText : string with get, set

abstract UserDictionarySelectFormOkText : string with get, set
Property Value
String


UserDictionarySelectFormRemoveText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionarySelectFormRemoveText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewUserDictionarySelect ► UserDictionarySelectFormRemoveText
Keyoti RapidSpell Desktop .NET
UI text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string UserDictionarySelectFormRemoveText { get; set; }
string UserDictionarySelectFormRemoveText { get; set; }
Property UserDictionarySelectFormRemoveText As String
    Get
    Set
Property UserDictionarySelectFormRemoveText As String
    Get
    Set
property String^ UserDictionarySelectFormRemoveText {
    String^ get ();
    void set (String^ value);
}
property String^ UserDictionarySelectFormRemoveText {
    String^ get ();
    void set (String^ value);
}
abstract UserDictionarySelectFormRemoveText : string with get, set

abstract UserDictionarySelectFormRemoveText : string with get, set
Property Value
String


UserDictionarySelectFormTitleText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionarySelectFormTitleText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewUserDictionarySelect ► UserDictionarySelectFormTitleText
Keyoti RapidSpell Desktop .NET
UI text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string UserDictionarySelectFormTitleText { get; set; }
string UserDictionarySelectFormTitleText { get; set; }
Property UserDictionarySelectFormTitleText As String
    Get
    Set
Property UserDictionarySelectFormTitleText As String
    Get
    Set
property String^ UserDictionarySelectFormTitleText {
    String^ get ();
    void set (String^ value);
}
property String^ UserDictionarySelectFormTitleText {
    String^ get ();
    void set (String^ value);
}
abstract UserDictionarySelectFormTitleText : string with get, set

abstract UserDictionarySelectFormTitleText : string with get, set
Property Value
String


WindowsForms Class

Keyoti RapidSpell Desktop .NET API Docs
WindowsForms Class
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms
Keyoti RapidSpell Desktop .NET
Default WindowsForms view.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class WindowsForms : Form,
    IDialogView
public class WindowsForms : Form,
    IDialogView
Public Class WindowsForms
    Inherits Form
    Implements IDialogView
Public Class WindowsForms
    Inherits Form
    Implements IDialogView
public ref class WindowsForms : public Form,
    IDialogView
public ref class WindowsForms : public Form,
    IDialogView
type WindowsForms =
    class
        inherit Form
        interface IDialogView
    end
type WindowsForms =
    class
        inherit Form
        interface IDialogView
    end
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WindowsForms()()()() | New instance
 | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
 | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
 | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
 | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
 | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
 | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
 | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
 | Activate()()()() | Activates the form and gives it focus. (Inherited from Form.)
 | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
 | ActivateMdiChild(Form) | Activates the MDI child of a form. (Inherited from Form.)
 | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
 | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
 | AddButtonEnabled | See interface, IDialogView for info
 | AddButtonText | See interface, IDialogView for info
 | AddButtonVisible | See interface, IDialogView for info
 | AddOwnedForm(Form) | Adds an owned form to this form. (Inherited from Form.)
 | AdjustFormScrollbars(Boolean) | (Inherited from Form.)
 | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
 | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
 | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
 | ApplyAutoScaling()()()() | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
 | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
 | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
 | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
 | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
 | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
 | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
 | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
 | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
 | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
 | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
 | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
 | AutoSizeChanged | (Inherited from Form.)
 | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
 | AutoValidate | (Inherited from Form.)
 | AutoValidateChanged | (Inherited from Form.)
 | BackColor | (Inherited from Form.)
 | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
 | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
 | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
 | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
 | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
 | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
 | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
 | BindingContext | (Inherited from ContainerControl.)
 | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
 | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
 | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
 | BringToFront()()()() | Brings the control to the front of the z-order. (Inherited from Control.)
 | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
 | CancelButtonText | See interface, IDialogView for info
 | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
 | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
 | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
 | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
 | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
 | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
 | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
 | CenterToParent()()()() | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
 | CenterToScreen()()()() | Centers the form on the current screen. (Inherited from Form.)
 | ChangeAllButtonEnabled | See interface, IDialogView for info
 | ChangeAllButtonText | See interface, IDialogView for info
 | ChangeButtonEnabled | See interface, IDialogView for info
 | ChangeButtonText | See interface, IDialogView for info
 | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
 | Click | Occurs when the control is clicked. (Inherited from Control.)
 | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
 | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
 | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
 | Close()()()() | Closes the form. (Inherited from Form.)
 | Closed | Occurs when the form is closed. (Inherited from Form.)
 | Closing | Occurs when the form is closing. (Inherited from Form.)
 | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | Contains(Control) | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
 | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
 | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
 | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
 | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
 | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
 | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
 | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
 | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
 | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
 | CreateAccessibilityInstance()()()() | Creates a new accessibility object for the control. (Inherited from Control.)
 | CreateControl()()()() | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
 | CreateControlsInstance()()()() | (Inherited from Form.)
 | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
 | CreateGraphics()()()() | Creates the Graphics for the control. (Inherited from Control.)
 | CreateHandle()()()() | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateParams | (Inherited from Form.)
 | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
 | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
 | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
 | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
 | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
 | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
 | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
 | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
 | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
 | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
 | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
 | DefaultSize | (Inherited from Form.)
 | DefWndProc(Message%) | (Inherited from Form.)
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
 | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
 | DestroyHandle()()()() | Destroys the handle associated with the control. (Inherited from Control.)
 | DeviceDpi()()()() | (Inherited from Control.)
 | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
 | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Form.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
 | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
 | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
 | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
 | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
 | DoDragDrop(Object, DragDropEffects) | Begins a drag-and-drop operation. (Inherited from Control.)
 | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
 | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
 | DpiChanged()()()() | (Inherited from Form.)
 | DpiChangedAfterParent()()()() | (Inherited from Control.)
 | DpiChangedBeforeParent()()()() | (Inherited from Control.)
 | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
 | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
 | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
 | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
 | DrawToBitmap(Bitmap, Rectangle) | Supports rendering to the specified bitmap. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
 | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
 | EndInvoke(IAsyncResult) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
 | Enter | Occurs when the control is entered. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | Finalize()()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | FindForm()()()() | Retrieves the form that the control is on. (Inherited from Control.)
 | Focus()()()() | Sets input focus to the control. (Inherited from Control.)
 | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
 | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
 | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
 | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
 | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
 | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
 | FormClosed | Occurs after the form is closed. (Inherited from Form.)
 | FormClosing | Occurs before the form is closed. (Inherited from Form.)
 | GetAccessibilityObjectById(Int32) | Retrieves the specified AccessibleObject. (Inherited from Control.)
 | GetAutoSizeMode()()()() | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
 | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
 | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
 | GetContainerControl()()()() | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetNextControl(Control, Boolean) | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
 | GetPreferredSize(Size) | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
 | GetQueryCorrection()()()() | See interface, IDialogView for info
 | GetScaledBounds(Rectangle, SizeF, BoundsSpecified) | (Inherited from Form.)
 | GetScrollState(Int32) | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetStyle(ControlStyles) | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
 | GetTopLevel()()()() | Determines if the control is a top-level control. (Inherited from Control.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
 | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
 | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
 | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
 | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
 | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the control. (Inherited from Control.)
 | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
 | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
 | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
 | Hide()()()() | Conceals the control from the user. (Inherited from Control.)
 | HighlightFontColor | The text color used to highlight the misspelled word
 | HighlightFontStyle | The style of font used to highlight the misspelled word
 | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
 | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
 | Icon | Gets or sets the icon for the form. (Inherited from Form.)
 | IgnoreAllButtonEnabled | See interface, IDialogView for info
 | IgnoreAllButtonText | See interface, IDialogView for info
 | IgnoreButtonEnabled | See interface, IDialogView for info
 | IgnoreButtonSelect()()()() | See interface, IDialogView for info
 | IgnoreButtonText | See interface, IDialogView for info
 | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
 | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
 | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | InitLayout()()()() | Called after the control has been added to another container. (Inherited from Control.)
 | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
 | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
 | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
 | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
 | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
 | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
 | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
 | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
 | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
 | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
 | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
 | InvokeGotFocus(Control, EventArgs) | Raises the GotFocus event for the specified control. (Inherited from Control.)
 | InvokeLostFocus(Control, EventArgs) | Raises the LostFocus event for the specified control. (Inherited from Control.)
 | InvokeOnClick(Control, EventArgs) | Raises the Click event for the specified control. (Inherited from Control.)
 | InvokePaint(Control, PaintEventArgs) | Raises the Paint event for the specified control. (Inherited from Control.)
 | InvokePaintBackground(Control, PaintEventArgs) | Raises the PaintBackground event for the specified control. (Inherited from Control.)
 | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
 | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
 | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
 | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
 | IsInputChar(Char) | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
 | IsInputKey(Keys) | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
 | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
 | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
 | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
 | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
 | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
 | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
 | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
 | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
 | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
 | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
 | LayoutMdi(MdiLayout) | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
 | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
 | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
 | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
 | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
 | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
 | LogicalToDeviceUnits(Int32) | (Inherited from Control.)
 | LogicalToDeviceUnits(Size) | (Inherited from Control.)
 | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
 | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
 | Margin | (Inherited from Form.)
 | MarginChanged | (Inherited from Form.)
 | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
 | MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
 | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
 | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
 | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
 | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
 | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
 | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
 | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
 | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
 | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
 | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
 | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
 | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
 | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
 | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
 | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
 | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
 | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
 | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
 | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
 | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
 | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
 | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
 | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
 | Move | Occurs when the control is moved. (Inherited from Control.)
 | Name | Gets or sets the name of the control. (Inherited from Control.)
 | NotifyInvalidate(Rectangle) | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
 | NotInDictionaryLabelText | See interface, IDialogView for info
 | OnActivated(EventArgs) | Raises the Activated event. (Inherited from Form.)
 | OnAutoSizeChanged(EventArgs) | Raises the AutoSizeChanged event. (Inherited from Control.)
 | OnAutoValidateChanged(EventArgs) | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
 | OnBackColorChanged(EventArgs) | Raises the BackColorChanged event. (Inherited from Control.)
 | OnBackgroundImageChanged(EventArgs) | Raises the BackgroundImageChanged event. (Inherited from Form.)
 | OnBackgroundImageLayoutChanged(EventArgs) | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
 | OnBindingContextChanged(EventArgs) | Raises the BindingContextChanged event. (Inherited from Control.)
 | OnCausesValidationChanged(EventArgs) | Raises the CausesValidationChanged event. (Inherited from Control.)
 | OnChangeUICues(UICuesEventArgs) | Raises the ChangeUICues event. (Inherited from Control.)
 | OnClick(EventArgs) | Raises the Click event. (Inherited from Control.)
 | OnClientSizeChanged(EventArgs) | Raises the ClientSizeChanged event. (Inherited from Control.)
 | OnClosed(EventArgs) | Raises the Closed event. (Inherited from Form.)
 | OnClosing(CancelEventArgs) | Raises the Closing event. (Inherited from Form.)
 | OnContextMenuChanged(EventArgs) | Raises the ContextMenuChanged event. (Inherited from Control.)
 | OnContextMenuStripChanged(EventArgs) | Raises the ContextMenuStripChanged event. (Inherited from Control.)
 | OnControlAdded(ControlEventArgs) | Raises the ControlAdded event. (Inherited from Control.)
 | OnControlRemoved(ControlEventArgs) | Raises the ControlRemoved event. (Inherited from Control.)
 | OnCreateControl()()()() | Raises the CreateControl event. (Inherited from Form.)
 | OnCursorChanged(EventArgs) | Raises the CursorChanged event. (Inherited from Control.)
 | OnDeactivate(EventArgs) | Raises the Deactivate event. (Inherited from Form.)
 | OnDockChanged(EventArgs) | Raises the DockChanged event. (Inherited from Control.)
 | OnDoubleClick(EventArgs) | Raises the DoubleClick event. (Inherited from Control.)
 | OnDpiChanged(DpiChangedEventArgs) | (Inherited from Form.)
 | OnDpiChangedAfterParent(EventArgs) | (Inherited from Control.)
 | OnDpiChangedBeforeParent(EventArgs) | (Inherited from Control.)
 | OnDragDrop(DragEventArgs) | Raises the DragDrop event. (Inherited from Control.)
 | OnDragEnter(DragEventArgs) | Raises the DragEnter event. (Inherited from Control.)
 | OnDragLeave(EventArgs) | Raises the DragLeave event. (Inherited from Control.)
 | OnDragOver(DragEventArgs) | Raises the DragOver event. (Inherited from Control.)
 | OnEnabledChanged(EventArgs) | (Inherited from Form.)
 | OnEnter(EventArgs) | Raises the Enter event. (Inherited from Form.)
 | OnFontChanged(EventArgs) | (Inherited from Form.)
 | OnForeColorChanged(EventArgs) | Raises the ForeColorChanged event. (Inherited from Control.)
 | OnFormClosed(FormClosedEventArgs) | Raises the FormClosed event. (Inherited from Form.)
 | OnFormClosing(FormClosingEventArgs) | Raises the FormClosing event. (Inherited from Form.)
 | OnGetDpiScaledSize(Int32, Int32, Size%) | (Inherited from Form.)
 | OnGiveFeedback(GiveFeedbackEventArgs) | Raises the GiveFeedback event. (Inherited from Control.)
 | OnGotFocus(EventArgs) | Raises the GotFocus event. (Inherited from Control.)
 | OnHandleCreated(EventArgs) | (Inherited from Form.)
 | OnHandleDestroyed(EventArgs) | (Inherited from Form.)
 | OnHelpButtonClicked(CancelEventArgs) | Raises the HelpButtonClicked event. (Inherited from Form.)
 | OnHelpRequested(HelpEventArgs) | Raises the HelpRequested event. (Inherited from Control.)
 | OnImeModeChanged(EventArgs) | Raises the ImeModeChanged event. (Inherited from Control.)
 | OnInputLanguageChanged(InputLanguageChangedEventArgs) | Raises the InputLanguageChanged event. (Inherited from Form.)
 | OnInputLanguageChanging(InputLanguageChangingEventArgs) | Raises the InputLanguageChanging event. (Inherited from Form.)
 | OnInvalidated(InvalidateEventArgs) | Raises the Invalidated event. (Inherited from Control.)
 | OnKeyDown(KeyEventArgs) | Raises the KeyDown event. (Inherited from Control.)
 | OnKeyPress(KeyPressEventArgs) | Raises the KeyPress event. (Inherited from Control.)
 | OnKeyUp(KeyEventArgs) | Raises the KeyUp event. (Inherited from Control.)
 | OnLayout(LayoutEventArgs) | (Inherited from Form.)
 | OnLeave(EventArgs) | Raises the Leave event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Form.)
 | OnLocationChanged(EventArgs) | Raises the LocationChanged event. (Inherited from Control.)
 | OnLostFocus(EventArgs) | Raises the LostFocus event. (Inherited from Control.)
 | OnMarginChanged(EventArgs) | Raises the MarginChanged event. (Inherited from Control.)
 | OnMaximizedBoundsChanged(EventArgs) | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
 | OnMaximumSizeChanged(EventArgs) | Raises the MaximumSizeChanged event. (Inherited from Form.)
 | OnMdiChildActivate(EventArgs) | Raises the MdiChildActivate event. (Inherited from Form.)
 | OnMenuComplete(EventArgs) | Raises the MenuComplete event. (Inherited from Form.)
 | OnMenuStart(EventArgs) | Raises the MenuStart event. (Inherited from Form.)
 | OnMinimumSizeChanged(EventArgs) | Raises the MinimumSizeChanged event. (Inherited from Form.)
 | OnMouseCaptureChanged(EventArgs) | Raises the MouseCaptureChanged event. (Inherited from Control.)
 | OnMouseClick(MouseEventArgs) | Raises the MouseClick event. (Inherited from Control.)
 | OnMouseDoubleClick(MouseEventArgs) | Raises the MouseDoubleClick event. (Inherited from Control.)
 | OnMouseDown(MouseEventArgs) | Raises the MouseDown event. (Inherited from Control.)
 | OnMouseEnter(EventArgs) | Raises the MouseEnter event. (Inherited from Control.)
 | OnMouseHover(EventArgs) | Raises the MouseHover event. (Inherited from Control.)
 | OnMouseLeave(EventArgs) | Raises the MouseLeave event. (Inherited from Control.)
 | OnMouseMove(MouseEventArgs) | Raises the MouseMove event. (Inherited from Control.)
 | OnMouseUp(MouseEventArgs) | Raises the MouseUp event. (Inherited from Control.)
 | OnMouseWheel(MouseEventArgs) | Raises the MouseWheel event. (Inherited from ScrollableControl.)
 | OnMove(EventArgs) | Raises the Move event. (Inherited from Control.)
 | OnNotifyMessage(Message) | Notifies the control of Windows messages. (Inherited from Control.)
 | OnPaddingChanged(EventArgs) | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
 | OnPaint(PaintEventArgs) | (Inherited from Form.)
 | OnPaintBackground(PaintEventArgs) | Paints the background of the control. (Inherited from ScrollableControl.)
 | OnParentBackColorChanged(EventArgs) | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
 | OnParentBackgroundImageChanged(EventArgs) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
 | OnParentBindingContextChanged(EventArgs) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
 | OnParentChanged(EventArgs) | (Inherited from ContainerControl.)
 | OnParentCursorChanged(EventArgs) | Raises the CursorChanged event. (Inherited from Control.)
 | OnParentEnabledChanged(EventArgs) | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
 | OnParentFontChanged(EventArgs) | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
 | OnParentForeColorChanged(EventArgs) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
 | OnParentRightToLeftChanged(EventArgs) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
 | OnParentVisibleChanged(EventArgs) | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
 | OnPreviewKeyDown(PreviewKeyDownEventArgs) | Raises the PreviewKeyDown event. (Inherited from Control.)
 | OnPrint(PaintEventArgs) | Raises the Paint event. (Inherited from Control.)
 | OnQueryContinueDrag(QueryContinueDragEventArgs) | Raises the QueryContinueDrag event. (Inherited from Control.)
 | OnRegionChanged(EventArgs) | Raises the RegionChanged event. (Inherited from Control.)
 | OnResize(EventArgs) | (Inherited from Form.)
 | OnResizeBegin(EventArgs) | Raises the ResizeBegin event. (Inherited from Form.)
 | OnResizeEnd(EventArgs) | Raises the ResizeEnd event. (Inherited from Form.)
 | OnRightToLeftChanged(EventArgs) | (Inherited from ScrollableControl.)
 | OnRightToLeftLayoutChanged(EventArgs) | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
 | OnScroll(ScrollEventArgs) | Raises the Scroll event. (Inherited from ScrollableControl.)
 | OnShown(EventArgs) | Raises the Shown event. (Inherited from Form.)
 | OnSizeChanged(EventArgs) | Raises the SizeChanged event. (Inherited from Control.)
 | OnStyleChanged(EventArgs) | (Inherited from Form.)
 | OnSystemColorsChanged(EventArgs) | Raises the SystemColorsChanged event. (Inherited from Control.)
 | OnTabIndexChanged(EventArgs) | Raises the TabIndexChanged event. (Inherited from Control.)
 | OnTabStopChanged(EventArgs) | Raises the TabStopChanged event. (Inherited from Control.)
 | OnTextChanged(EventArgs) | (Inherited from Form.)
 | OnValidated(EventArgs) | Raises the Validated event. (Inherited from Control.)
 | OnValidating(CancelEventArgs) | Raises the Validating event. (Inherited from Control.)
 | OnVisibleChanged(EventArgs) | Raises the VisibleChanged event. (Inherited from Form.)
 | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
 | OptionsButtonText | Options button text
 | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
 | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
 | Padding | Gets or sets padding within the control. (Inherited from Control.)
 | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
 | Paint | Occurs when the control is redrawn. (Inherited from Control.)
 | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
 | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
 | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
 | PerformAutoScale()()()() | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
 | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
 | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
 | PointToClient(Point) | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
 | PointToScreen(Point) | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
 | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
 | PreProcessControlMessage(Message%) | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
 | PreProcessMessage(Message%) | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
 | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
 | ProcessCmdKey(Message%, Keys) | Processes a command key. (Inherited from Form.)
 | ProcessDialogChar(Char) | (Inherited from Form.)
 | ProcessDialogKey(Keys) | Processes a dialog box key. (Inherited from Form.)
 | ProcessKeyEventArgs(Message%) | Processes a key message and generates the appropriate control events. (Inherited from Control.)
 | ProcessKeyMessage(Message%) | Processes a keyboard message. (Inherited from Control.)
 | ProcessKeyPreview(Message%) | (Inherited from Form.)
 | ProcessMnemonic(Char) | (Inherited from Form.)
 | ProcessTabKey(Boolean) | (Inherited from Form.)
 | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
 | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
 | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
 | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
 | QueryTextBoxMultiline | Whether 'not in dictionary' text box is multiline or single line.
 | RaiseDragEvent(Object, DragEventArgs) | Raises the appropriate drag event. (Inherited from Control.)
 | RaiseKeyEvent(Object, KeyEventArgs) | Raises the appropriate key event. (Inherited from Control.)
 | RaiseMouseEvent(Object, MouseEventArgs) | Raises the appropriate mouse event. (Inherited from Control.)
 | RaisePaintEvent(Object, PaintEventArgs) | Raises the appropriate paint event. (Inherited from Control.)
 | RecreateHandle()()()() | Forces the re-creation of the handle for the control. (Inherited from Control.)
 | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
 | RectangleToClient(Rectangle) | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
 | RectangleToScreen(Rectangle) | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
 | Refresh()()()() | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
 | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
 | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
 | RegisterEvents(IDialogViewEventHandler) | See interface, IDialogView for info
 | RemoveOwnedForm(Form) | Removes an owned form from this form. (Inherited from Form.)
 | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
 | RescaleConstantsForDpi(Int32, Int32) | (Inherited from Control.)
 | ResetBackColor()()()() | Resets the BackColor property to its default value. (Inherited from Control.)
 | ResetBindings()()()() | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
 | ResetCursor()()()() | Resets the Cursor property to its default value. (Inherited from Control.)
 | ResetFont()()()() | Resets the Font property to its default value. (Inherited from Control.)
 | ResetForeColor()()()() | Resets the ForeColor property to its default value. (Inherited from Control.)
 | ResetImeMode()()()() | Resets the ImeMode property to its default value. (Inherited from Control.)
 | ResetMouseEventArgs()()()() | Resets the control to handle the MouseLeave event. (Inherited from Control.)
 | ResetRightToLeft()()()() | Resets the RightToLeft property to its default value. (Inherited from Control.)
 | ResetText()()()() | Resets the Text property to its default value. (Inherited from Control.)
 | Resize | Occurs when the control is resized. (Inherited from Control.)
 | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
 | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
 | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
 | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
 | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
 | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
 | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
 | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
 | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
 | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
 | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
 | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateContent(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateHorizontal(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateLeftRight(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
 | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
 | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
 | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
 | ScaleBitmapLogicalToDevice(Bitmap%) | (Inherited from Control.)
 | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
 | ScaleControl(SizeF, BoundsSpecified) | (Inherited from Form.)
 | ScaleCore(Single, Single) | Performs scaling of the form. (Inherited from Form.)
 | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
 | ScrollControlIntoView(Control) | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
 | ScrollToControl(Control) | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
 | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
 | Select()()()() | Activates the control. (Inherited from Control.)
 | SelectNextControl(Control, Boolean, Boolean, Boolean, Boolean) | Activates the next control. (Inherited from Control.)
 | SendToBack()()()() | Sends the control to the back of the z-order. (Inherited from Control.)
 | SetAutoScrollMargin(Int32, Int32) | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
 | SetAutoSizeMode(AutoSizeMode) | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
 | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
 | SetBoundsCore(Int32, Int32, Int32, Int32, BoundsSpecified) | (Inherited from Form.)
 | SetClientSizeCore(Int32, Int32) | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
 | SetDesktopBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
 | SetDesktopLocation(Int32, Int32) | Sets the location of the form in desktop coordinates. (Inherited from Form.)
 | SetDisplayRectLocation(Int32, Int32) | Positions the display window to the specified value. (Inherited from ScrollableControl.)
 | SetQuery(String, String, String) | See interface, IDialogView for info
 | SetScrollState(Int32, Boolean) | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
 | SetStyle(ControlStyles, Boolean) | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
 | SetTopLevel(Boolean) | Sets the control as the top-level control. (Inherited from Control.)
 | SetVisibleCore(Boolean) | (Inherited from Form.)
 | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
 | Show()()()() | Displays the control to the user. (Inherited from Control.)
 | ShowDialog(Object) | See interface, IDialogView for info
 | ShowDialog()()()() | Shows the form as a modal dialog box. (Inherited from Form.)
 | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
 | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
 | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
 | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
 | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
 | ShowMessageBox(String, String, MessageBoxButtons, MessageBoxIcon) | See interface, IDialogView for info
 | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
 | ShowOptionsButton | Whether to show the options button.
 | ShowUndoButton | Whether to show the undo button.
 | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
 | Site | Gets or sets the site of the control. (Inherited from Control.)
 | Size | Gets or sets the size of the form. (Inherited from Form.)
 | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
 | SizeFromClientSize(Size) | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
 | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
 | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
 | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
 | SuggestionFinderCheckBoxChecked | See interface, IDialogView for info
 | SuggestionFinderCheckBoxEnabled | See interface, IDialogView for info
 | SuggestionFinderCheckBoxText | See interface, IDialogView for info
 | SuggestionsLabelEnabled | See interface, IDialogView for info
 | SuggestionsLabelText | See interface, IDialogView for info
 | SuggestionsListClear()()()() | See interface, IDialogView for info
 | SuggestionsListDeselect()()()() | See interface, IDialogView for info
 | SuggestionsListEnabled | See interface, IDialogView for info
 | SuggestionsListItems | See interface, IDialogView for info
 | SuggestionsListSelectedItem | See interface, IDialogView for info
 | SuspendLayout()()()() | Temporarily suspends the layout logic for the control. (Inherited from Control.)
 | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
 | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
 | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
 | TabStop | (Inherited from Form.)
 | TabStopChanged | (Inherited from Form.)
 | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
 | Text | (Inherited from Form.)
 | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
 | Title | See interface, IDialogView for info
 | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
 | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
 | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
 | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
 | ToString()()()() | Gets a string representing the current instance of the form. (Inherited from Form.)
 | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
 | UIThreadInvoke(Delegate) | See interface, IDialogView for info
 | UIThreadInvoke(Delegate, array<Object>[]()[][]) | See interface, IDialogView for info
 | UndoButtonEnabled | See interface, IDialogView for info
 | UndoButtonText | Undo button text
 | UnregisterEvents(IDialogViewEventHandler) | See interface, IDialogView for info
 | Update()()()() | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
 | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
 | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
 | UpdateDefaultButton()()()() | Updates which button is the default button. (Inherited from Form.)
 | UpdateStyles()()()() | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
 | UpdateZOrder()()()() | Updates the control in its parent's z-order. (Inherited from Control.)
 | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
 | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
 | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
 | ValidateChildren()()()() | (Inherited from Form.)
 | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
 | Validated | Occurs when the control is finished validating. (Inherited from Control.)
 | Validating | Occurs when the control is validating. (Inherited from Control.)
 | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
 | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
 | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
 | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
 | Width | Gets or sets the width of the control. (Inherited from Control.)
 | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
 | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
 | WndProc(Message%) | (Inherited from Form.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | Control
 |  |  |  | ScrollableControl
 |  |  |  |  | ContainerControl
 |  |  |  |  |  | Form
 |  |  |  |  |  |  | WindowsForms


WindowsForms Constructor

Keyoti RapidSpell Desktop .NET API Docs
WindowsForms Constructor
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► WindowsForms()()()()
Keyoti RapidSpell Desktop .NET
New instance
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public WindowsForms()
public WindowsForms()
Public Sub New
Public Sub New
public:
WindowsForms()
public:
WindowsForms()
new : unit -> WindowsForms
new : unit -> WindowsForms


AddButtonEnabled Property

Keyoti RapidSpell Desktop .NET API Docs
AddButtonEnabled Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► AddButtonEnabled
Keyoti RapidSpell Desktop .NET
See interface, IDialogView for info
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool AddButtonEnabled { get; set; }
public bool AddButtonEnabled { get; set; }
Public Property AddButtonEnabled As Boolean
    Get
    Set
Public Property AddButtonEnabled As Boolean
    Get
    Set
public:
virtual property bool AddButtonEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool AddButtonEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract AddButtonEnabled : bool with get, set
override AddButtonEnabled : bool with get, set
abstract AddButtonEnabled : bool with get, set
override AddButtonEnabled : bool with get, set
Property Value
Boolean


AddButtonText Property

Keyoti RapidSpell Desktop .NET API Docs
AddButtonText Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► AddButtonText
Keyoti RapidSpell Desktop .NET
See interface, IDialogView for info
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string AddButtonText { get; set; }
public string AddButtonText { get; set; }
Public Property AddButtonText As String
    Get
    Set
Public Property AddButtonText As String
    Get
    Set
public:
virtual property String^ AddButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ AddButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract AddButtonText : string with get, set
override AddButtonText : string with get, set
abstract AddButtonText : string with get, set
override AddButtonText : string with get, set
Property Value
String


AddButtonVisible Property

Keyoti RapidSpell Desktop .NET API Docs
AddButtonVisible Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► AddButtonVisible
Keyoti RapidSpell Desktop .NET
See interface, IDialogView for info
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool AddButtonVisible { get; set; }
public bool AddButtonVisible { get; set; }
Public Property AddButtonVisible As Boolean
    Get
    Set
Public Property AddButtonVisible As Boolean
    Get
    Set
public:
virtual property bool AddButtonVisible {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool AddButtonVisible {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract AddButtonVisible : bool with get, set
override AddButtonVisible : bool with get, set
abstract AddButtonVisible : bool with get, set
override AddButtonVisible : bool with get, set
Property Value
Boolean


CancelButtonText Property

Keyoti RapidSpell Desktop .NET API Docs
CancelButtonText Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► CancelButtonText
Keyoti RapidSpell Desktop .NET
See interface, IDialogView for info
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string CancelButtonText { get; set; }
public string CancelButtonText { get; set; }
Public Property CancelButtonText As String
    Get
    Set
Public Property CancelButtonText As String
    Get
    Set
public:
virtual property String^ CancelButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ CancelButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract CancelButtonText : string with get, set
override CancelButtonText : string with get, set
abstract CancelButtonText : string with get, set
override CancelButtonText : string with get, set
Property Value
String


ChangeAllButtonEnabled Property

Keyoti RapidSpell Desktop .NET API Docs
ChangeAllButtonEnabled Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► ChangeAllButtonEnabled
Keyoti RapidSpell Desktop .NET
See interface, IDialogView for info
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ChangeAllButtonEnabled { get; set; }
public bool ChangeAllButtonEnabled { get; set; }
Public Property ChangeAllButtonEnabled As Boolean
    Get
    Set
Public Property ChangeAllButtonEnabled As Boolean
    Get
    Set
public:
virtual property bool ChangeAllButtonEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool ChangeAllButtonEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract ChangeAllButtonEnabled : bool with get, set
override ChangeAllButtonEnabled : bool with get, set
abstract ChangeAllButtonEnabled : bool with get, set
override ChangeAllButtonEnabled : bool with get, set
Property Value
Boolean


ChangeAllButtonText Property

Keyoti RapidSpell Desktop .NET API Docs
ChangeAllButtonText Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► ChangeAllButtonText
Keyoti RapidSpell Desktop .NET
See interface, IDialogView for info
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string ChangeAllButtonText { get; set; }
public string ChangeAllButtonText { get; set; }
Public Property ChangeAllButtonText As String
    Get
    Set
Public Property ChangeAllButtonText As String
    Get
    Set
public:
virtual property String^ ChangeAllButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ ChangeAllButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract ChangeAllButtonText : string with get, set
override ChangeAllButtonText : string with get, set
abstract ChangeAllButtonText : string with get, set
override ChangeAllButtonText : string with get, set
Property Value
String


ChangeButtonEnabled Property

Keyoti RapidSpell Desktop .NET API Docs
ChangeButtonEnabled Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► ChangeButtonEnabled
Keyoti RapidSpell Desktop .NET
See interface, IDialogView for info
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ChangeButtonEnabled { get; set; }
public bool ChangeButtonEnabled { get; set; }
Public Property ChangeButtonEnabled As Boolean
    Get
    Set
Public Property ChangeButtonEnabled As Boolean
    Get
    Set
public:
virtual property bool ChangeButtonEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool ChangeButtonEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract ChangeButtonEnabled : bool with get, set
override ChangeButtonEnabled : bool with get, set
abstract ChangeButtonEnabled : bool with get, set
override ChangeButtonEnabled : bool with get, set
Property Value
Boolean


ChangeButtonText Property

Keyoti RapidSpell Desktop .NET API Docs
ChangeButtonText Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► ChangeButtonText
Keyoti RapidSpell Desktop .NET
See interface, IDialogView for info
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string ChangeButtonText { get; set; }
public string ChangeButtonText { get; set; }
Public Property ChangeButtonText As String
    Get
    Set
Public Property ChangeButtonText As String
    Get
    Set
public:
virtual property String^ ChangeButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ ChangeButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract ChangeButtonText : string with get, set
override ChangeButtonText : string with get, set
abstract ChangeButtonText : string with get, set
override ChangeButtonText : string with get, set
Property Value
String


Dispose Method (disposing)

Keyoti RapidSpell Desktop .NET API Docs
Dispose Method (disposing)
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► Dispose(Boolean)
Keyoti RapidSpell Desktop .NET
Clean up any resources being used.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
Parameters
disposing (Boolean)


GetQueryCorrection Method

Keyoti RapidSpell Desktop .NET API Docs
GetQueryCorrection Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► GetQueryCorrection()()()()
Keyoti RapidSpell Desktop .NET
See interface, IDialogView for info
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string GetQueryCorrection()
public string GetQueryCorrection()
Public Function GetQueryCorrection As String
Public Function GetQueryCorrection As String
public:
virtual String^ GetQueryCorrection() sealed
public:
virtual String^ GetQueryCorrection() sealed
abstract GetQueryCorrection : unit -> string
override GetQueryCorrection : unit -> string
abstract GetQueryCorrection : unit -> string
override GetQueryCorrection : unit -> string
Return Value
String


HighlightFontColor Property

Keyoti RapidSpell Desktop .NET API Docs
HighlightFontColor Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► HighlightFontColor
Keyoti RapidSpell Desktop .NET
The text color used to highlight the misspelled word
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Color HighlightFontColor { get; set; }
public Color HighlightFontColor { get; set; }
Public Property HighlightFontColor As Color
    Get
    Set
Public Property HighlightFontColor As Color
    Get
    Set
public:
property Color HighlightFontColor {
    Color get ();
    void set (Color value);
}
public:
property Color HighlightFontColor {
    Color get ();
    void set (Color value);
}
member HighlightFontColor : Color with get, set

member HighlightFontColor : Color with get, set
Property Value
Color


HighlightFontStyle Property

Keyoti RapidSpell Desktop .NET API Docs
HighlightFontStyle Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► HighlightFontStyle
Keyoti RapidSpell Desktop .NET
The style of font used to highlight the misspelled word
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public FontStyle HighlightFontStyle { get; set; }
public FontStyle HighlightFontStyle { get; set; }
Public Property HighlightFontStyle As FontStyle
    Get
    Set
Public Property HighlightFontStyle As FontStyle
    Get
    Set
public:
property FontStyle HighlightFontStyle {
    FontStyle get ();
    void set (FontStyle value);
}
public:
property FontStyle HighlightFontStyle {
    FontStyle get ();
    void set (FontStyle value);
}
member HighlightFontStyle : FontStyle with get, set

member HighlightFontStyle : FontStyle with get, set
Property Value
FontStyle


IgnoreAllButtonEnabled Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreAllButtonEnabled Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► IgnoreAllButtonEnabled
Keyoti RapidSpell Desktop .NET
See interface, IDialogView for info
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreAllButtonEnabled { get; set; }
public bool IgnoreAllButtonEnabled { get; set; }
Public Property IgnoreAllButtonEnabled As Boolean
    Get
    Set
Public Property IgnoreAllButtonEnabled As Boolean
    Get
    Set
public:
virtual property bool IgnoreAllButtonEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool IgnoreAllButtonEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IgnoreAllButtonEnabled : bool with get, set
override IgnoreAllButtonEnabled : bool with get, set
abstract IgnoreAllButtonEnabled : bool with get, set
override IgnoreAllButtonEnabled : bool with get, set
Property Value
Boolean


IgnoreAllButtonText Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreAllButtonText Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► IgnoreAllButtonText
Keyoti RapidSpell Desktop .NET
See interface, IDialogView for info
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string IgnoreAllButtonText { get; set; }
public string IgnoreAllButtonText { get; set; }
Public Property IgnoreAllButtonText As String
    Get
    Set
Public Property IgnoreAllButtonText As String
    Get
    Set
public:
virtual property String^ IgnoreAllButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ IgnoreAllButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract IgnoreAllButtonText : string with get, set
override IgnoreAllButtonText : string with get, set
abstract IgnoreAllButtonText : string with get, set
override IgnoreAllButtonText : string with get, set
Property Value
String


IgnoreButtonEnabled Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreButtonEnabled Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► IgnoreButtonEnabled
Keyoti RapidSpell Desktop .NET
See interface, IDialogView for info
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreButtonEnabled { get; set; }
public bool IgnoreButtonEnabled { get; set; }
Public Property IgnoreButtonEnabled As Boolean
    Get
    Set
Public Property IgnoreButtonEnabled As Boolean
    Get
    Set
public:
virtual property bool IgnoreButtonEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool IgnoreButtonEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IgnoreButtonEnabled : bool with get, set
override IgnoreButtonEnabled : bool with get, set
abstract IgnoreButtonEnabled : bool with get, set
override IgnoreButtonEnabled : bool with get, set
Property Value
Boolean


IgnoreButtonSelect Method

Keyoti RapidSpell Desktop .NET API Docs
IgnoreButtonSelect Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► IgnoreButtonSelect()()()()
Keyoti RapidSpell Desktop .NET
See interface, IDialogView for info
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void IgnoreButtonSelect()
public void IgnoreButtonSelect()
Public Sub IgnoreButtonSelect
Public Sub IgnoreButtonSelect
public:
virtual void IgnoreButtonSelect() sealed
public:
virtual void IgnoreButtonSelect() sealed
abstract IgnoreButtonSelect : unit -> unit
override IgnoreButtonSelect : unit -> unit
abstract IgnoreButtonSelect : unit -> unit
override IgnoreButtonSelect : unit -> unit


IgnoreButtonText Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreButtonText Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► IgnoreButtonText
Keyoti RapidSpell Desktop .NET
See interface, IDialogView for info
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string IgnoreButtonText { get; set; }
public string IgnoreButtonText { get; set; }
Public Property IgnoreButtonText As String
    Get
    Set
Public Property IgnoreButtonText As String
    Get
    Set
public:
virtual property String^ IgnoreButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ IgnoreButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract IgnoreButtonText : string with get, set
override IgnoreButtonText : string with get, set
abstract IgnoreButtonText : string with get, set
override IgnoreButtonText : string with get, set
Property Value
String


NotInDictionaryLabelText Property

Keyoti RapidSpell Desktop .NET API Docs
NotInDictionaryLabelText Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► NotInDictionaryLabelText
Keyoti RapidSpell Desktop .NET
See interface, IDialogView for info
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string NotInDictionaryLabelText { get; set; }
public string NotInDictionaryLabelText { get; set; }
Public Property NotInDictionaryLabelText As String
    Get
    Set
Public Property NotInDictionaryLabelText As String
    Get
    Set
public:
virtual property String^ NotInDictionaryLabelText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ NotInDictionaryLabelText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract NotInDictionaryLabelText : string with get, set
override NotInDictionaryLabelText : string with get, set
abstract NotInDictionaryLabelText : string with get, set
override NotInDictionaryLabelText : string with get, set
Property Value
String


OptionsButtonText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsButtonText Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► OptionsButtonText
Keyoti RapidSpell Desktop .NET
Options button text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsButtonText { get; set; }
public string OptionsButtonText { get; set; }
Public Property OptionsButtonText As String
    Get
    Set
Public Property OptionsButtonText As String
    Get
    Set
public:
virtual property String^ OptionsButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ OptionsButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract OptionsButtonText : string with get, set
override OptionsButtonText : string with get, set
abstract OptionsButtonText : string with get, set
override OptionsButtonText : string with get, set
Property Value
String


QueryTextBoxMultiline Property

Keyoti RapidSpell Desktop .NET API Docs
QueryTextBoxMultiline Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► QueryTextBoxMultiline
Keyoti RapidSpell Desktop .NET
Whether 'not in dictionary' text box is multiline or single line.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool QueryTextBoxMultiline { get; set; }
public bool QueryTextBoxMultiline { get; set; }
Public Property QueryTextBoxMultiline As Boolean
    Get
    Set
Public Property QueryTextBoxMultiline As Boolean
    Get
    Set
public:
virtual property bool QueryTextBoxMultiline {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool QueryTextBoxMultiline {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract QueryTextBoxMultiline : bool with get, set
override QueryTextBoxMultiline : bool with get, set
abstract QueryTextBoxMultiline : bool with get, set
override QueryTextBoxMultiline : bool with get, set
Property Value
Boolean


RegisterEvents Method (handler)

Keyoti RapidSpell Desktop .NET API Docs
RegisterEvents Method (handler)
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► RegisterEvents(IDialogViewEventHandler)
Keyoti RapidSpell Desktop .NET
See interface, IDialogView for info
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void RegisterEvents(
    IDialogViewEventHandler handler
)
public void RegisterEvents(
    IDialogViewEventHandler handler
)
Public Sub RegisterEvents (
    handler As IDialogViewEventHandler
)
Public Sub RegisterEvents (
    handler As IDialogViewEventHandler
)
public:
virtual void RegisterEvents(
    IDialogViewEventHandler^ handler
) sealed
public:
virtual void RegisterEvents(
    IDialogViewEventHandler^ handler
) sealed
abstract RegisterEvents :
        handler : IDialogViewEventHandler -> unit
override RegisterEvents :
        handler : IDialogViewEventHandler -> unit
abstract RegisterEvents :
        handler : IDialogViewEventHandler -> unit
override RegisterEvents :
        handler : IDialogViewEventHandler -> unit
Parameters
handler (IDialogViewEventHandler)


SetQuery Method (beforeSentence, word, afterSentence)

Keyoti RapidSpell Desktop .NET API Docs
SetQuery Method (beforeSentence, word, afterSentence)
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► SetQuery(String, String, String)
Keyoti RapidSpell Desktop .NET
See interface, IDialogView for info
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void SetQuery(
    string beforeSentence,
    string word,
    string afterSentence
)
public void SetQuery(
    string beforeSentence,
    string word,
    string afterSentence
)
Public Sub SetQuery (
    beforeSentence As String,
    word As String,
    afterSentence As String
)
Public Sub SetQuery (
    beforeSentence As String,
    word As String,
    afterSentence As String
)
public:
virtual void SetQuery(
    String^ beforeSentence,
    String^ word,
    String^ afterSentence
) sealed
public:
virtual void SetQuery(
    String^ beforeSentence,
    String^ word,
    String^ afterSentence
) sealed
abstract SetQuery :
        beforeSentence : string *
        word : string *
        afterSentence : string -> unit
override SetQuery :
        beforeSentence : string *
        word : string *
        afterSentence : string -> unit
abstract SetQuery :
        beforeSentence : string *
        word : string *
        afterSentence : string -> unit
override SetQuery :
        beforeSentence : string *
        word : string *
        afterSentence : string -> unit
Parameters
beforeSentence (String)
word (String)
afterSentence (String)


ShowDialog Method (owner)

Keyoti RapidSpell Desktop .NET API Docs
ShowDialog Method (owner)
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► ShowDialog(Object)
Keyoti RapidSpell Desktop .NET
See interface, IDialogView for info
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public DialogResult ShowDialog(
    Object owner
)
public DialogResult ShowDialog(
    Object owner
)
Public Function ShowDialog (
    owner As Object
) As DialogResult
Public Function ShowDialog (
    owner As Object
) As DialogResult
public:
virtual DialogResult ShowDialog(
    Object^ owner
) sealed
public:
virtual DialogResult ShowDialog(
    Object^ owner
) sealed
abstract ShowDialog :
        owner : Object -> DialogResult
override ShowDialog :
        owner : Object -> DialogResult
abstract ShowDialog :
        owner : Object -> DialogResult
override ShowDialog :
        owner : Object -> DialogResult
Parameters
owner (Object)
Return Value
DialogResult


ShowMessageBox Method (message, title, buttons, icon)

Keyoti RapidSpell Desktop .NET API Docs
ShowMessageBox Method (message, title, buttons, icon)
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► ShowMessageBox(String, String, MessageBoxButtons, MessageBoxIcon)
Keyoti RapidSpell Desktop .NET
See interface, IDialogView for info
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public DialogResult ShowMessageBox(
    string message,
    string title,
    MessageBoxButtons buttons,
    MessageBoxIcon icon
)
public DialogResult ShowMessageBox(
    string message,
    string title,
    MessageBoxButtons buttons,
    MessageBoxIcon icon
)
Public Function ShowMessageBox (
    message As String,
    title As String,
    buttons As MessageBoxButtons,
    icon As MessageBoxIcon
) As DialogResult
Public Function ShowMessageBox (
    message As String,
    title As String,
    buttons As MessageBoxButtons,
    icon As MessageBoxIcon
) As DialogResult
public:
virtual DialogResult ShowMessageBox(
    String^ message,
    String^ title,
    MessageBoxButtons buttons,
    MessageBoxIcon icon
) sealed
public:
virtual DialogResult ShowMessageBox(
    String^ message,
    String^ title,
    MessageBoxButtons buttons,
    MessageBoxIcon icon
) sealed
abstract ShowMessageBox :
        message : string *
        title : string *
        buttons : MessageBoxButtons *
        icon : MessageBoxIcon -> DialogResult
override ShowMessageBox :
        message : string *
        title : string *
        buttons : MessageBoxButtons *
        icon : MessageBoxIcon -> DialogResult
abstract ShowMessageBox :
        message : string *
        title : string *
        buttons : MessageBoxButtons *
        icon : MessageBoxIcon -> DialogResult
override ShowMessageBox :
        message : string *
        title : string *
        buttons : MessageBoxButtons *
        icon : MessageBoxIcon -> DialogResult
Parameters
message (String)
title (String)
buttons (MessageBoxButtons)
icon (MessageBoxIcon)
Return Value
DialogResult


ShowOptionsButton Property

Keyoti RapidSpell Desktop .NET API Docs
ShowOptionsButton Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► ShowOptionsButton
Keyoti RapidSpell Desktop .NET
Whether to show the options button.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ShowOptionsButton { get; set; }
public bool ShowOptionsButton { get; set; }
Public Property ShowOptionsButton As Boolean
    Get
    Set
Public Property ShowOptionsButton As Boolean
    Get
    Set
public:
virtual property bool ShowOptionsButton {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool ShowOptionsButton {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract ShowOptionsButton : bool with get, set
override ShowOptionsButton : bool with get, set
abstract ShowOptionsButton : bool with get, set
override ShowOptionsButton : bool with get, set
Property Value
Boolean


ShowUndoButton Property

Keyoti RapidSpell Desktop .NET API Docs
ShowUndoButton Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► ShowUndoButton
Keyoti RapidSpell Desktop .NET
Whether to show the undo button.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ShowUndoButton { get; set; }
public bool ShowUndoButton { get; set; }
Public Property ShowUndoButton As Boolean
    Get
    Set
Public Property ShowUndoButton As Boolean
    Get
    Set
public:
virtual property bool ShowUndoButton {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool ShowUndoButton {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract ShowUndoButton : bool with get, set
override ShowUndoButton : bool with get, set
abstract ShowUndoButton : bool with get, set
override ShowUndoButton : bool with get, set
Property Value
Boolean


SuggestionFinderCheckBoxChecked Property

Keyoti RapidSpell Desktop .NET API Docs
SuggestionFinderCheckBoxChecked Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► SuggestionFinderCheckBoxChecked
Keyoti RapidSpell Desktop .NET
See interface, IDialogView for info
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool SuggestionFinderCheckBoxChecked { get; set; }
public bool SuggestionFinderCheckBoxChecked { get; set; }
Public Property SuggestionFinderCheckBoxChecked As Boolean
    Get
    Set
Public Property SuggestionFinderCheckBoxChecked As Boolean
    Get
    Set
public:
virtual property bool SuggestionFinderCheckBoxChecked {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool SuggestionFinderCheckBoxChecked {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract SuggestionFinderCheckBoxChecked : bool with get, set
override SuggestionFinderCheckBoxChecked : bool with get, set
abstract SuggestionFinderCheckBoxChecked : bool with get, set
override SuggestionFinderCheckBoxChecked : bool with get, set
Property Value
Boolean


SuggestionFinderCheckBoxEnabled Property

Keyoti RapidSpell Desktop .NET API Docs
SuggestionFinderCheckBoxEnabled Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► SuggestionFinderCheckBoxEnabled
Keyoti RapidSpell Desktop .NET
See interface, IDialogView for info
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool SuggestionFinderCheckBoxEnabled { get; set; }
public bool SuggestionFinderCheckBoxEnabled { get; set; }
Public Property SuggestionFinderCheckBoxEnabled As Boolean
    Get
    Set
Public Property SuggestionFinderCheckBoxEnabled As Boolean
    Get
    Set
public:
virtual property bool SuggestionFinderCheckBoxEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool SuggestionFinderCheckBoxEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract SuggestionFinderCheckBoxEnabled : bool with get, set
override SuggestionFinderCheckBoxEnabled : bool with get, set
abstract SuggestionFinderCheckBoxEnabled : bool with get, set
override SuggestionFinderCheckBoxEnabled : bool with get, set
Property Value
Boolean


SuggestionFinderCheckBoxText Property

Keyoti RapidSpell Desktop .NET API Docs
SuggestionFinderCheckBoxText Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► SuggestionFinderCheckBoxText
Keyoti RapidSpell Desktop .NET
See interface, IDialogView for info
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string SuggestionFinderCheckBoxText { get; set; }
public string SuggestionFinderCheckBoxText { get; set; }
Public Property SuggestionFinderCheckBoxText As String
    Get
    Set
Public Property SuggestionFinderCheckBoxText As String
    Get
    Set
public:
virtual property String^ SuggestionFinderCheckBoxText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ SuggestionFinderCheckBoxText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract SuggestionFinderCheckBoxText : string with get, set
override SuggestionFinderCheckBoxText : string with get, set
abstract SuggestionFinderCheckBoxText : string with get, set
override SuggestionFinderCheckBoxText : string with get, set
Property Value
String


SuggestionsLabelEnabled Property

Keyoti RapidSpell Desktop .NET API Docs
SuggestionsLabelEnabled Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► SuggestionsLabelEnabled
Keyoti RapidSpell Desktop .NET
See interface, IDialogView for info
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool SuggestionsLabelEnabled { get; set; }
public bool SuggestionsLabelEnabled { get; set; }
Public Property SuggestionsLabelEnabled As Boolean
    Get
    Set
Public Property SuggestionsLabelEnabled As Boolean
    Get
    Set
public:
virtual property bool SuggestionsLabelEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool SuggestionsLabelEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract SuggestionsLabelEnabled : bool with get, set
override SuggestionsLabelEnabled : bool with get, set
abstract SuggestionsLabelEnabled : bool with get, set
override SuggestionsLabelEnabled : bool with get, set
Property Value
Boolean


SuggestionsLabelText Property

Keyoti RapidSpell Desktop .NET API Docs
SuggestionsLabelText Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► SuggestionsLabelText
Keyoti RapidSpell Desktop .NET
See interface, IDialogView for info
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string SuggestionsLabelText { get; set; }
public string SuggestionsLabelText { get; set; }
Public Property SuggestionsLabelText As String
    Get
    Set
Public Property SuggestionsLabelText As String
    Get
    Set
public:
virtual property String^ SuggestionsLabelText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ SuggestionsLabelText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract SuggestionsLabelText : string with get, set
override SuggestionsLabelText : string with get, set
abstract SuggestionsLabelText : string with get, set
override SuggestionsLabelText : string with get, set
Property Value
String


SuggestionsListClear Method

Keyoti RapidSpell Desktop .NET API Docs
SuggestionsListClear Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► SuggestionsListClear()()()()
Keyoti RapidSpell Desktop .NET
See interface, IDialogView for info
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void SuggestionsListClear()
public void SuggestionsListClear()
Public Sub SuggestionsListClear
Public Sub SuggestionsListClear
public:
virtual void SuggestionsListClear() sealed
public:
virtual void SuggestionsListClear() sealed
abstract SuggestionsListClear : unit -> unit
override SuggestionsListClear : unit -> unit
abstract SuggestionsListClear : unit -> unit
override SuggestionsListClear : unit -> unit


SuggestionsListDeselect Method

Keyoti RapidSpell Desktop .NET API Docs
SuggestionsListDeselect Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► SuggestionsListDeselect()()()()
Keyoti RapidSpell Desktop .NET
See interface, IDialogView for info
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void SuggestionsListDeselect()
public void SuggestionsListDeselect()
Public Sub SuggestionsListDeselect
Public Sub SuggestionsListDeselect
public:
virtual void SuggestionsListDeselect() sealed
public:
virtual void SuggestionsListDeselect() sealed
abstract SuggestionsListDeselect : unit -> unit
override SuggestionsListDeselect : unit -> unit
abstract SuggestionsListDeselect : unit -> unit
override SuggestionsListDeselect : unit -> unit


SuggestionsListEnabled Property

Keyoti RapidSpell Desktop .NET API Docs
SuggestionsListEnabled Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► SuggestionsListEnabled
Keyoti RapidSpell Desktop .NET
See interface, IDialogView for info
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool SuggestionsListEnabled { get; set; }
public bool SuggestionsListEnabled { get; set; }
Public Property SuggestionsListEnabled As Boolean
    Get
    Set
Public Property SuggestionsListEnabled As Boolean
    Get
    Set
public:
virtual property bool SuggestionsListEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool SuggestionsListEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract SuggestionsListEnabled : bool with get, set
override SuggestionsListEnabled : bool with get, set
abstract SuggestionsListEnabled : bool with get, set
override SuggestionsListEnabled : bool with get, set
Property Value
Boolean


SuggestionsListItems Property

Keyoti RapidSpell Desktop .NET API Docs
SuggestionsListItems Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► SuggestionsListItems
Keyoti RapidSpell Desktop .NET
See interface, IDialogView for info
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Object SuggestionsListItems { get; set; }
public Object SuggestionsListItems { get; set; }
Public Property SuggestionsListItems As Object
    Get
    Set
Public Property SuggestionsListItems As Object
    Get
    Set
public:
virtual property Object^ SuggestionsListItems {
    Object^ get () sealed;
    void set (Object^ value) sealed;
}
public:
virtual property Object^ SuggestionsListItems {
    Object^ get () sealed;
    void set (Object^ value) sealed;
}
abstract SuggestionsListItems : Object with get, set
override SuggestionsListItems : Object with get, set
abstract SuggestionsListItems : Object with get, set
override SuggestionsListItems : Object with get, set
Property Value
Object


SuggestionsListSelectedItem Property

Keyoti RapidSpell Desktop .NET API Docs
SuggestionsListSelectedItem Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► SuggestionsListSelectedItem
Keyoti RapidSpell Desktop .NET
See interface, IDialogView for info
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string SuggestionsListSelectedItem { get; }
public string SuggestionsListSelectedItem { get; }
Public ReadOnly Property SuggestionsListSelectedItem As String
    Get
Public ReadOnly Property SuggestionsListSelectedItem As String
    Get
public:
virtual property String^ SuggestionsListSelectedItem {
    String^ get () sealed;
}
public:
virtual property String^ SuggestionsListSelectedItem {
    String^ get () sealed;
}
abstract SuggestionsListSelectedItem : string with get
override SuggestionsListSelectedItem : string with get
abstract SuggestionsListSelectedItem : string with get
override SuggestionsListSelectedItem : string with get
Property Value
String


Title Property

Keyoti RapidSpell Desktop .NET API Docs
Title Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► Title
Keyoti RapidSpell Desktop .NET
See interface, IDialogView for info
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string Title { get; set; }
public string Title { get; set; }
Public Property Title As String
    Get
    Set
Public Property Title As String
    Get
    Set
public:
virtual property String^ Title {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ Title {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract Title : string with get, set
override Title : string with get, set
abstract Title : string with get, set
override Title : string with get, set
Property Value
String


UIThreadInvoke Method

Keyoti RapidSpell Desktop .NET API Docs
UIThreadInvoke Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► UIThreadInvoke()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | UIThreadInvoke(Delegate) | See interface, IDialogView for info
 | UIThreadInvoke(Delegate, array<Object>[]()[][]) | See interface, IDialogView for info


UIThreadInvoke Method (d)

Keyoti RapidSpell Desktop .NET API Docs
UIThreadInvoke Method (d)
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► UIThreadInvoke(Delegate)
Keyoti RapidSpell Desktop .NET
See interface, IDialogView for info
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void UIThreadInvoke(
    Delegate d
)
public void UIThreadInvoke(
    Delegate d
)
Public Sub UIThreadInvoke (
    d As Delegate
)
Public Sub UIThreadInvoke (
    d As Delegate
)
public:
virtual void UIThreadInvoke(
    Delegate^ d
) sealed
public:
virtual void UIThreadInvoke(
    Delegate^ d
) sealed
abstract UIThreadInvoke :
        d : Delegate -> unit
override UIThreadInvoke :
        d : Delegate -> unit
abstract UIThreadInvoke :
        d : Delegate -> unit
override UIThreadInvoke :
        d : Delegate -> unit
Parameters
d (Delegate)


UIThreadInvoke Method (d, parameters)

Keyoti RapidSpell Desktop .NET API Docs
UIThreadInvoke Method (d, parameters)
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► UIThreadInvoke(Delegate, array<Object>[]()[][])
Keyoti RapidSpell Desktop .NET
See interface, IDialogView for info
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void UIThreadInvoke(
    Delegate d,
    Object[] parameters
)
public void UIThreadInvoke(
    Delegate d,
    Object[] parameters
)
Public Sub UIThreadInvoke (
    d As Delegate,
    parameters As Object()
)
Public Sub UIThreadInvoke (
    d As Delegate,
    parameters As Object()
)
public:
virtual void UIThreadInvoke(
    Delegate^ d,
    array<Object^>^ parameters
) sealed
public:
virtual void UIThreadInvoke(
    Delegate^ d,
    array<Object^>^ parameters
) sealed
abstract UIThreadInvoke :
        d : Delegate *
        parameters : Object[] -> unit
override UIThreadInvoke :
        d : Delegate *
        parameters : Object[] -> unit
abstract UIThreadInvoke :
        d : Delegate *
        parameters : Object[] -> unit
override UIThreadInvoke :
        d : Delegate *
        parameters : Object[] -> unit
Parameters
d (Delegate)
parameters (array< Object >[]()[][])


UndoButtonEnabled Property

Keyoti RapidSpell Desktop .NET API Docs
UndoButtonEnabled Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► UndoButtonEnabled
Keyoti RapidSpell Desktop .NET
See interface, IDialogView for info
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool UndoButtonEnabled { get; set; }
public bool UndoButtonEnabled { get; set; }
Public Property UndoButtonEnabled As Boolean
    Get
    Set
Public Property UndoButtonEnabled As Boolean
    Get
    Set
public:
virtual property bool UndoButtonEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool UndoButtonEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract UndoButtonEnabled : bool with get, set
override UndoButtonEnabled : bool with get, set
abstract UndoButtonEnabled : bool with get, set
override UndoButtonEnabled : bool with get, set
Property Value
Boolean


UndoButtonText Property

Keyoti RapidSpell Desktop .NET API Docs
UndoButtonText Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► UndoButtonText
Keyoti RapidSpell Desktop .NET
Undo button text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UndoButtonText { get; set; }
public string UndoButtonText { get; set; }
Public Property UndoButtonText As String
    Get
    Set
Public Property UndoButtonText As String
    Get
    Set
public:
virtual property String^ UndoButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ UndoButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract UndoButtonText : string with get, set
override UndoButtonText : string with get, set
abstract UndoButtonText : string with get, set
override UndoButtonText : string with get, set
Property Value
String


UnregisterEvents Method (handler)

Keyoti RapidSpell Desktop .NET API Docs
UnregisterEvents Method (handler)
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► UnregisterEvents(IDialogViewEventHandler)
Keyoti RapidSpell Desktop .NET
See interface, IDialogView for info
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void UnregisterEvents(
    IDialogViewEventHandler handler
)
public void UnregisterEvents(
    IDialogViewEventHandler handler
)
Public Sub UnregisterEvents (
    handler As IDialogViewEventHandler
)
Public Sub UnregisterEvents (
    handler As IDialogViewEventHandler
)
public:
virtual void UnregisterEvents(
    IDialogViewEventHandler^ handler
) sealed
public:
virtual void UnregisterEvents(
    IDialogViewEventHandler^ handler
) sealed
abstract UnregisterEvents :
        handler : IDialogViewEventHandler -> unit
override UnregisterEvents :
        handler : IDialogViewEventHandler -> unit
abstract UnregisterEvents :
        handler : IDialogViewEventHandler -> unit
override UnregisterEvents :
        handler : IDialogViewEventHandler -> unit
Parameters
handler (IDialogViewEventHandler)


WindowsFormsOptions Class

Keyoti RapidSpell Desktop .NET API Docs
WindowsFormsOptions Class
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsOptions
Keyoti RapidSpell Desktop .NET
Options editor Form
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class WindowsFormsOptions : Form,
    IDialogViewOptions
public class WindowsFormsOptions : Form,
    IDialogViewOptions
Public Class WindowsFormsOptions
    Inherits Form
    Implements IDialogViewOptions
Public Class WindowsFormsOptions
    Inherits Form
    Implements IDialogViewOptions
public ref class WindowsFormsOptions : public Form,
    IDialogViewOptions
public ref class WindowsFormsOptions : public Form,
    IDialogViewOptions
type WindowsFormsOptions =
    class
        inherit Form
        interface IDialogViewOptions
    end
type WindowsFormsOptions =
    class
        inherit Form
        interface IDialogViewOptions
    end
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WindowsFormsOptions()()()() | New instance
 | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
 | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
 | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
 | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
 | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
 | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
 | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
 | Activate()()()() | Activates the form and gives it focus. (Inherited from Form.)
 | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
 | ActivateMdiChild(Form) | Activates the MDI child of a form. (Inherited from Form.)
 | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
 | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
 | AddOwnedForm(Form) | Adds an owned form to this form. (Inherited from Form.)
 | AdjustFormScrollbars(Boolean) | (Inherited from Form.)
 | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
 | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
 | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
 | ApplyAutoScaling()()()() | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
 | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
 | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
 | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
 | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
 | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
 | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
 | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
 | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
 | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
 | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
 | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
 | AutoSizeChanged | (Inherited from Form.)
 | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
 | AutoValidate | (Inherited from Form.)
 | AutoValidateChanged | (Inherited from Form.)
 | BackColor | (Inherited from Form.)
 | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
 | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
 | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
 | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
 | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
 | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
 | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
 | BindingContext | (Inherited from ContainerControl.)
 | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
 | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
 | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
 | BringToFront()()()() | Brings the control to the front of the z-order. (Inherited from Control.)
 | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
 | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
 | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
 | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
 | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
 | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
 | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
 | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
 | CenterToParent()()()() | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
 | CenterToScreen()()()() | Centers the form on the current screen. (Inherited from Form.)
 | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
 | Click | Occurs when the control is clicked. (Inherited from Control.)
 | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
 | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
 | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
 | Close()()()() | Closes the form. (Inherited from Form.)
 | Closed | Occurs when the form is closed. (Inherited from Form.)
 | Closing | Occurs when the form is closing. (Inherited from Form.)
 | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | Contains(Control) | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
 | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
 | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
 | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
 | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
 | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
 | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
 | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
 | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
 | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
 | CreateAccessibilityInstance()()()() | Creates a new accessibility object for the control. (Inherited from Control.)
 | CreateControl()()()() | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
 | CreateControlsInstance()()()() | (Inherited from Form.)
 | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
 | CreateGraphics()()()() | Creates the Graphics for the control. (Inherited from Control.)
 | CreateHandle()()()() | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateParams | (Inherited from Form.)
 | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
 | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
 | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
 | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
 | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
 | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
 | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
 | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
 | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
 | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
 | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
 | DefaultSize | (Inherited from Form.)
 | DefWndProc(Message%) | (Inherited from Form.)
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
 | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
 | DestroyHandle()()()() | Destroys the handle associated with the control. (Inherited from Control.)
 | DeviceDpi()()()() | (Inherited from Control.)
 | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
 | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Form.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
 | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
 | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
 | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
 | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
 | DoDragDrop(Object, DragDropEffects) | Begins a drag-and-drop operation. (Inherited from Control.)
 | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
 | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
 | DpiChanged()()()() | (Inherited from Form.)
 | DpiChangedAfterParent()()()() | (Inherited from Control.)
 | DpiChangedBeforeParent()()()() | (Inherited from Control.)
 | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
 | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
 | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
 | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
 | DrawToBitmap(Bitmap, Rectangle) | Supports rendering to the specified bitmap. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
 | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
 | EndInvoke(IAsyncResult) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
 | Enter | Occurs when the control is entered. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | Finalize()()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | FindForm()()()() | Retrieves the form that the control is on. (Inherited from Control.)
 | Focus()()()() | Sets input focus to the control. (Inherited from Control.)
 | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
 | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
 | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
 | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
 | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
 | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
 | FormClosed | Occurs after the form is closed. (Inherited from Form.)
 | FormClosing | Occurs before the form is closed. (Inherited from Form.)
 | GetAccessibilityObjectById(Int32) | Retrieves the specified AccessibleObject. (Inherited from Control.)
 | GetAutoSizeMode()()()() | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
 | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
 | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
 | GetContainerControl()()()() | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetNextControl(Control, Boolean) | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
 | GetPreferredSize(Size) | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
 | GetScaledBounds(Rectangle, SizeF, BoundsSpecified) | (Inherited from Form.)
 | GetScrollState(Int32) | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetStyle(ControlStyles) | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
 | GetTopLevel()()()() | Determines if the control is a top-level control. (Inherited from Control.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
 | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
 | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
 | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
 | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
 | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the control. (Inherited from Control.)
 | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
 | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
 | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
 | Hide()()()() | Conceals the control from the user. (Inherited from Control.)
 | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
 | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
 | Icon | Gets or sets the icon for the form. (Inherited from Form.)
 | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
 | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
 | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | InitLayout()()()() | Called after the control has been added to another container. (Inherited from Control.)
 | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
 | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
 | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
 | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
 | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
 | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
 | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
 | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
 | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
 | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
 | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
 | InvokeGotFocus(Control, EventArgs) | Raises the GotFocus event for the specified control. (Inherited from Control.)
 | InvokeLostFocus(Control, EventArgs) | Raises the LostFocus event for the specified control. (Inherited from Control.)
 | InvokeOnClick(Control, EventArgs) | Raises the Click event for the specified control. (Inherited from Control.)
 | InvokePaint(Control, PaintEventArgs) | Raises the Paint event for the specified control. (Inherited from Control.)
 | InvokePaintBackground(Control, PaintEventArgs) | Raises the PaintBackground event for the specified control. (Inherited from Control.)
 | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
 | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
 | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
 | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
 | IsInputChar(Char) | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
 | IsInputKey(Keys) | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
 | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
 | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
 | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
 | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
 | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
 | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
 | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
 | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
 | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
 | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
 | LayoutMdi(MdiLayout) | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
 | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
 | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
 | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
 | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
 | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
 | LogicalToDeviceUnits(Int32) | (Inherited from Control.)
 | LogicalToDeviceUnits(Size) | (Inherited from Control.)
 | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
 | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
 | Margin | (Inherited from Form.)
 | MarginChanged | (Inherited from Form.)
 | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
 | MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
 | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
 | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
 | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
 | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
 | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
 | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
 | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
 | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
 | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
 | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
 | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
 | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
 | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
 | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
 | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
 | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
 | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
 | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
 | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
 | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
 | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
 | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
 | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
 | Move | Occurs when the control is moved. (Inherited from Control.)
 | Name | Gets or sets the name of the control. (Inherited from Control.)
 | NotifyInvalidate(Rectangle) | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
 | OnActivated(EventArgs) | Raises the Activated event. (Inherited from Form.)
 | OnAutoSizeChanged(EventArgs) | Raises the AutoSizeChanged event. (Inherited from Control.)
 | OnAutoValidateChanged(EventArgs) | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
 | OnBackColorChanged(EventArgs) | Raises the BackColorChanged event. (Inherited from Control.)
 | OnBackgroundImageChanged(EventArgs) | Raises the BackgroundImageChanged event. (Inherited from Form.)
 | OnBackgroundImageLayoutChanged(EventArgs) | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
 | OnBindingContextChanged(EventArgs) | Raises the BindingContextChanged event. (Inherited from Control.)
 | OnCausesValidationChanged(EventArgs) | Raises the CausesValidationChanged event. (Inherited from Control.)
 | OnChangeUICues(UICuesEventArgs) | Raises the ChangeUICues event. (Inherited from Control.)
 | OnClick(EventArgs) | Raises the Click event. (Inherited from Control.)
 | OnClientSizeChanged(EventArgs) | Raises the ClientSizeChanged event. (Inherited from Control.)
 | OnClosed(EventArgs) | Raises the Closed event. (Inherited from Form.)
 | OnClosing(CancelEventArgs) | Raises the Closing event. (Inherited from Form.)
 | OnContextMenuChanged(EventArgs) | Raises the ContextMenuChanged event. (Inherited from Control.)
 | OnContextMenuStripChanged(EventArgs) | Raises the ContextMenuStripChanged event. (Inherited from Control.)
 | OnControlAdded(ControlEventArgs) | Raises the ControlAdded event. (Inherited from Control.)
 | OnControlRemoved(ControlEventArgs) | Raises the ControlRemoved event. (Inherited from Control.)
 | OnCreateControl()()()() | Raises the CreateControl event. (Inherited from Form.)
 | OnCursorChanged(EventArgs) | Raises the CursorChanged event. (Inherited from Control.)
 | OnDeactivate(EventArgs) | Raises the Deactivate event. (Inherited from Form.)
 | OnDockChanged(EventArgs) | Raises the DockChanged event. (Inherited from Control.)
 | OnDoubleClick(EventArgs) | Raises the DoubleClick event. (Inherited from Control.)
 | OnDpiChanged(DpiChangedEventArgs) | (Inherited from Form.)
 | OnDpiChangedAfterParent(EventArgs) | (Inherited from Control.)
 | OnDpiChangedBeforeParent(EventArgs) | (Inherited from Control.)
 | OnDragDrop(DragEventArgs) | Raises the DragDrop event. (Inherited from Control.)
 | OnDragEnter(DragEventArgs) | Raises the DragEnter event. (Inherited from Control.)
 | OnDragLeave(EventArgs) | Raises the DragLeave event. (Inherited from Control.)
 | OnDragOver(DragEventArgs) | Raises the DragOver event. (Inherited from Control.)
 | OnEnabledChanged(EventArgs) | (Inherited from Form.)
 | OnEnter(EventArgs) | Raises the Enter event. (Inherited from Form.)
 | OnFontChanged(EventArgs) | (Inherited from Form.)
 | OnForeColorChanged(EventArgs) | Raises the ForeColorChanged event. (Inherited from Control.)
 | OnFormClosed(FormClosedEventArgs) | Raises the FormClosed event. (Inherited from Form.)
 | OnFormClosing(FormClosingEventArgs) | Raises the FormClosing event. (Inherited from Form.)
 | OnGetDpiScaledSize(Int32, Int32, Size%) | (Inherited from Form.)
 | OnGiveFeedback(GiveFeedbackEventArgs) | Raises the GiveFeedback event. (Inherited from Control.)
 | OnGotFocus(EventArgs) | Raises the GotFocus event. (Inherited from Control.)
 | OnHandleCreated(EventArgs) | (Inherited from Form.)
 | OnHandleDestroyed(EventArgs) | (Inherited from Form.)
 | OnHelpButtonClicked(CancelEventArgs) | Raises the HelpButtonClicked event. (Inherited from Form.)
 | OnHelpRequested(HelpEventArgs) | Raises the HelpRequested event. (Inherited from Control.)
 | OnImeModeChanged(EventArgs) | Raises the ImeModeChanged event. (Inherited from Control.)
 | OnInputLanguageChanged(InputLanguageChangedEventArgs) | Raises the InputLanguageChanged event. (Inherited from Form.)
 | OnInputLanguageChanging(InputLanguageChangingEventArgs) | Raises the InputLanguageChanging event. (Inherited from Form.)
 | OnInvalidated(InvalidateEventArgs) | Raises the Invalidated event. (Inherited from Control.)
 | OnKeyDown(KeyEventArgs) | Raises the KeyDown event. (Inherited from Control.)
 | OnKeyPress(KeyPressEventArgs) | Raises the KeyPress event. (Inherited from Control.)
 | OnKeyUp(KeyEventArgs) | Raises the KeyUp event. (Inherited from Control.)
 | OnLayout(LayoutEventArgs) | (Inherited from Form.)
 | OnLeave(EventArgs) | Raises the Leave event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Form.)
 | OnLocationChanged(EventArgs) | Raises the LocationChanged event. (Inherited from Control.)
 | OnLostFocus(EventArgs) | Raises the LostFocus event. (Inherited from Control.)
 | OnMarginChanged(EventArgs) | Raises the MarginChanged event. (Inherited from Control.)
 | OnMaximizedBoundsChanged(EventArgs) | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
 | OnMaximumSizeChanged(EventArgs) | Raises the MaximumSizeChanged event. (Inherited from Form.)
 | OnMdiChildActivate(EventArgs) | Raises the MdiChildActivate event. (Inherited from Form.)
 | OnMenuComplete(EventArgs) | Raises the MenuComplete event. (Inherited from Form.)
 | OnMenuStart(EventArgs) | Raises the MenuStart event. (Inherited from Form.)
 | OnMinimumSizeChanged(EventArgs) | Raises the MinimumSizeChanged event. (Inherited from Form.)
 | OnMouseCaptureChanged(EventArgs) | Raises the MouseCaptureChanged event. (Inherited from Control.)
 | OnMouseClick(MouseEventArgs) | Raises the MouseClick event. (Inherited from Control.)
 | OnMouseDoubleClick(MouseEventArgs) | Raises the MouseDoubleClick event. (Inherited from Control.)
 | OnMouseDown(MouseEventArgs) | Raises the MouseDown event. (Inherited from Control.)
 | OnMouseEnter(EventArgs) | Raises the MouseEnter event. (Inherited from Control.)
 | OnMouseHover(EventArgs) | Raises the MouseHover event. (Inherited from Control.)
 | OnMouseLeave(EventArgs) | Raises the MouseLeave event. (Inherited from Control.)
 | OnMouseMove(MouseEventArgs) | Raises the MouseMove event. (Inherited from Control.)
 | OnMouseUp(MouseEventArgs) | Raises the MouseUp event. (Inherited from Control.)
 | OnMouseWheel(MouseEventArgs) | Raises the MouseWheel event. (Inherited from ScrollableControl.)
 | OnMove(EventArgs) | Raises the Move event. (Inherited from Control.)
 | OnNotifyMessage(Message) | Notifies the control of Windows messages. (Inherited from Control.)
 | OnPaddingChanged(EventArgs) | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
 | OnPaint(PaintEventArgs) | (Inherited from Form.)
 | OnPaintBackground(PaintEventArgs) | Paints the background of the control. (Inherited from ScrollableControl.)
 | OnParentBackColorChanged(EventArgs) | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
 | OnParentBackgroundImageChanged(EventArgs) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
 | OnParentBindingContextChanged(EventArgs) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
 | OnParentChanged(EventArgs) | (Inherited from ContainerControl.)
 | OnParentCursorChanged(EventArgs) | Raises the CursorChanged event. (Inherited from Control.)
 | OnParentEnabledChanged(EventArgs) | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
 | OnParentFontChanged(EventArgs) | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
 | OnParentForeColorChanged(EventArgs) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
 | OnParentRightToLeftChanged(EventArgs) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
 | OnParentVisibleChanged(EventArgs) | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
 | OnPreviewKeyDown(PreviewKeyDownEventArgs) | Raises the PreviewKeyDown event. (Inherited from Control.)
 | OnPrint(PaintEventArgs) | Raises the Paint event. (Inherited from Control.)
 | OnQueryContinueDrag(QueryContinueDragEventArgs) | Raises the QueryContinueDrag event. (Inherited from Control.)
 | OnRegionChanged(EventArgs) | Raises the RegionChanged event. (Inherited from Control.)
 | OnResize(EventArgs) | (Inherited from Form.)
 | OnResizeBegin(EventArgs) | Raises the ResizeBegin event. (Inherited from Form.)
 | OnResizeEnd(EventArgs) | Raises the ResizeEnd event. (Inherited from Form.)
 | OnRightToLeftChanged(EventArgs) | (Inherited from ScrollableControl.)
 | OnRightToLeftLayoutChanged(EventArgs) | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
 | OnScroll(ScrollEventArgs) | Raises the Scroll event. (Inherited from ScrollableControl.)
 | OnShown(EventArgs) | Raises the Shown event. (Inherited from Form.)
 | OnSizeChanged(EventArgs) | Raises the SizeChanged event. (Inherited from Control.)
 | OnStyleChanged(EventArgs) | (Inherited from Form.)
 | OnSystemColorsChanged(EventArgs) | Raises the SystemColorsChanged event. (Inherited from Control.)
 | OnTabIndexChanged(EventArgs) | Raises the TabIndexChanged event. (Inherited from Control.)
 | OnTabStopChanged(EventArgs) | Raises the TabStopChanged event. (Inherited from Control.)
 | OnTextChanged(EventArgs) | (Inherited from Form.)
 | OnValidated(EventArgs) | Raises the Validated event. (Inherited from Control.)
 | OnValidating(CancelEventArgs) | Raises the Validating event. (Inherited from Control.)
 | OnVisibleChanged(EventArgs) | Raises the VisibleChanged event. (Inherited from Form.)
 | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
 | Options | See interface
 | OptionsFormAdvancedSettingsText | See interface
 | OptionsFormAlwaysSuggestCorrectionsText | See interface
 | OptionsFormBasicSettingsText | See interface
 | OptionsFormCancelText | See interface
 | OptionsFormCheckAsYouTypeText | See interface
 | OptionsFormIgnoreImproperCaseText | See interface
 | OptionsFormIgnoreInternetAddressesText | See interface
 | OptionsFormIgnoreWordsInUppercaseText | See interface
 | OptionsFormIgnoreWordsWithNumbersText | See interface
 | OptionsFormOKText | See interface
 | OptionsFormRecheckTextText | See interface
 | OptionsFormSuggestFromMainDictionaryOnlyText | See interface
 | OptionsFormTitleText | See interface
 | OptionsFormUserDictionaryEditText | See interface
 | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
 | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
 | Padding | Gets or sets padding within the control. (Inherited from Control.)
 | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
 | Paint | Occurs when the control is redrawn. (Inherited from Control.)
 | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
 | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
 | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
 | PerformAutoScale()()()() | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
 | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
 | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
 | PointToClient(Point) | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
 | PointToScreen(Point) | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
 | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
 | PreProcessControlMessage(Message%) | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
 | PreProcessMessage(Message%) | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
 | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
 | ProcessCmdKey(Message%, Keys) | Processes a command key. (Inherited from Form.)
 | ProcessDialogChar(Char) | (Inherited from Form.)
 | ProcessDialogKey(Keys) | Processes a dialog box key. (Inherited from Form.)
 | ProcessKeyEventArgs(Message%) | Processes a key message and generates the appropriate control events. (Inherited from Control.)
 | ProcessKeyMessage(Message%) | Processes a keyboard message. (Inherited from Control.)
 | ProcessKeyPreview(Message%) | (Inherited from Form.)
 | ProcessMnemonic(Char) | (Inherited from Form.)
 | ProcessTabKey(Boolean) | (Inherited from Form.)
 | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
 | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
 | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
 | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
 | RaiseDragEvent(Object, DragEventArgs) | Raises the appropriate drag event. (Inherited from Control.)
 | RaiseKeyEvent(Object, KeyEventArgs) | Raises the appropriate key event. (Inherited from Control.)
 | RaiseMouseEvent(Object, MouseEventArgs) | Raises the appropriate mouse event. (Inherited from Control.)
 | RaisePaintEvent(Object, PaintEventArgs) | Raises the appropriate paint event. (Inherited from Control.)
 | RecheckDocumentRequest | See interface
 | RecreateHandle()()()() | Forces the re-creation of the handle for the control. (Inherited from Control.)
 | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
 | RectangleToClient(Rectangle) | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
 | RectangleToScreen(Rectangle) | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
 | Refresh()()()() | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
 | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
 | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
 | RemoveOwnedForm(Form) | Removes an owned form from this form. (Inherited from Form.)
 | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
 | RescaleConstantsForDpi(Int32, Int32) | (Inherited from Control.)
 | ResetBackColor()()()() | Resets the BackColor property to its default value. (Inherited from Control.)
 | ResetBindings()()()() | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
 | ResetCursor()()()() | Resets the Cursor property to its default value. (Inherited from Control.)
 | ResetFont()()()() | Resets the Font property to its default value. (Inherited from Control.)
 | ResetForeColor()()()() | Resets the ForeColor property to its default value. (Inherited from Control.)
 | ResetImeMode()()()() | Resets the ImeMode property to its default value. (Inherited from Control.)
 | ResetMouseEventArgs()()()() | Resets the control to handle the MouseLeave event. (Inherited from Control.)
 | ResetRightToLeft()()()() | Resets the RightToLeft property to its default value. (Inherited from Control.)
 | ResetText()()()() | Resets the Text property to its default value. (Inherited from Control.)
 | Resize | Occurs when the control is resized. (Inherited from Control.)
 | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
 | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
 | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
 | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
 | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
 | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
 | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
 | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
 | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
 | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
 | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
 | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateContent(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateHorizontal(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateLeftRight(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
 | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
 | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
 | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
 | ScaleBitmapLogicalToDevice(Bitmap%) | (Inherited from Control.)
 | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
 | ScaleControl(SizeF, BoundsSpecified) | (Inherited from Form.)
 | ScaleCore(Single, Single) | Performs scaling of the form. (Inherited from Form.)
 | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
 | ScrollControlIntoView(Control) | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
 | ScrollToControl(Control) | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
 | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
 | Select()()()() | Activates the control. (Inherited from Control.)
 | SelectNextControl(Control, Boolean, Boolean, Boolean, Boolean) | Activates the next control. (Inherited from Control.)
 | SelectUserDictionary | See interface
 | SendToBack()()()() | Sends the control to the back of the z-order. (Inherited from Control.)
 | SetAutoScrollMargin(Int32, Int32) | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
 | SetAutoSizeMode(AutoSizeMode) | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
 | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
 | SetBoundsCore(Int32, Int32, Int32, Int32, BoundsSpecified) | (Inherited from Form.)
 | SetClientSizeCore(Int32, Int32) | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
 | SetDesktopBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
 | SetDesktopLocation(Int32, Int32) | Sets the location of the form in desktop coordinates. (Inherited from Form.)
 | SetDisplayRectLocation(Int32, Int32) | Positions the display window to the specified value. (Inherited from ScrollableControl.)
 | SetScrollState(Int32, Boolean) | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
 | SetStyle(ControlStyles, Boolean) | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
 | SetTopLevel(Boolean) | Sets the control as the top-level control. (Inherited from Control.)
 | SetVisibleCore(Boolean) | (Inherited from Form.)
 | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
 | Show()()()() | Displays the control to the user. (Inherited from Control.)
 | ShowDialog(Object, Boolean, Boolean, Boolean) | See interface
 | ShowDialog()()()() | Shows the form as a modal dialog box. (Inherited from Form.)
 | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
 | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
 | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
 | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
 | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
 | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
 | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
 | Site | Gets or sets the site of the control. (Inherited from Control.)
 | Size | Gets or sets the size of the form. (Inherited from Form.)
 | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
 | SizeFromClientSize(Size) | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
 | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
 | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
 | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
 | SuspendLayout()()()() | Temporarily suspends the layout logic for the control. (Inherited from Control.)
 | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
 | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
 | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
 | TabStop | (Inherited from Form.)
 | TabStopChanged | (Inherited from Form.)
 | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
 | Text | (Inherited from Form.)
 | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
 | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
 | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
 | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
 | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
 | ToString()()()() | Gets a string representing the current instance of the form. (Inherited from Form.)
 | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
 | Update()()()() | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
 | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
 | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
 | UpdateDefaultButton()()()() | Updates which button is the default button. (Inherited from Form.)
 | UpdateStyles()()()() | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
 | UpdateZOrder()()()() | Updates the control in its parent's z-order. (Inherited from Control.)
 | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
 | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
 | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
 | ValidateChildren()()()() | (Inherited from Form.)
 | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
 | Validated | Occurs when the control is finished validating. (Inherited from Control.)
 | Validating | Occurs when the control is validating. (Inherited from Control.)
 | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
 | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
 | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
 | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
 | Width | Gets or sets the width of the control. (Inherited from Control.)
 | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
 | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
 | WndProc(Message%) | (Inherited from Form.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | Control
 |  |  |  | ScrollableControl
 |  |  |  |  | ContainerControl
 |  |  |  |  |  | Form
 |  |  |  |  |  |  | WindowsFormsOptions


WindowsFormsOptions Constructor

Keyoti RapidSpell Desktop .NET API Docs
WindowsFormsOptions Constructor
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsOptions ► WindowsFormsOptions()()()()
Keyoti RapidSpell Desktop .NET
New instance
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public WindowsFormsOptions()
public WindowsFormsOptions()
Public Sub New
Public Sub New
public:
WindowsFormsOptions()
public:
WindowsFormsOptions()
new : unit -> WindowsFormsOptions
new : unit -> WindowsFormsOptions


Dispose Method (disposing)

Keyoti RapidSpell Desktop .NET API Docs
Dispose Method (disposing)
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsOptions ► Dispose(Boolean)
Keyoti RapidSpell Desktop .NET
Clean up any resources being used.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
Parameters
disposing (Boolean)
true if managed resources should be disposed; otherwise, false.


Options Property

Keyoti RapidSpell Desktop .NET API Docs
Options Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsOptions ► Options
Keyoti RapidSpell Desktop .NET
See interface
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UserOptions Options { get; set; }
public UserOptions Options { get; set; }
Public Property Options As UserOptions
    Get
    Set
Public Property Options As UserOptions
    Get
    Set
public:
virtual property UserOptions^ Options {
    UserOptions^ get () sealed;
    void set (UserOptions^ value) sealed;
}
public:
virtual property UserOptions^ Options {
    UserOptions^ get () sealed;
    void set (UserOptions^ value) sealed;
}
abstract Options : UserOptions with get, set
override Options : UserOptions with get, set
abstract Options : UserOptions with get, set
override Options : UserOptions with get, set
Property Value
UserOptions


OptionsFormAdvancedSettingsText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsFormAdvancedSettingsText Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsOptions ► OptionsFormAdvancedSettingsText
Keyoti RapidSpell Desktop .NET
See interface
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsFormAdvancedSettingsText { get; set; }
public string OptionsFormAdvancedSettingsText { get; set; }
Public Property OptionsFormAdvancedSettingsText As String
    Get
    Set
Public Property OptionsFormAdvancedSettingsText As String
    Get
    Set
public:
virtual property String^ OptionsFormAdvancedSettingsText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ OptionsFormAdvancedSettingsText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract OptionsFormAdvancedSettingsText : string with get, set
override OptionsFormAdvancedSettingsText : string with get, set
abstract OptionsFormAdvancedSettingsText : string with get, set
override OptionsFormAdvancedSettingsText : string with get, set
Property Value
String


OptionsFormAlwaysSuggestCorrectionsText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsFormAlwaysSuggestCorrectionsText Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsOptions ► OptionsFormAlwaysSuggestCorrectionsText
Keyoti RapidSpell Desktop .NET
See interface
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsFormAlwaysSuggestCorrectionsText { get; set; }
public string OptionsFormAlwaysSuggestCorrectionsText { get; set; }
Public Property OptionsFormAlwaysSuggestCorrectionsText As String
    Get
    Set
Public Property OptionsFormAlwaysSuggestCorrectionsText As String
    Get
    Set
public:
virtual property String^ OptionsFormAlwaysSuggestCorrectionsText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ OptionsFormAlwaysSuggestCorrectionsText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract OptionsFormAlwaysSuggestCorrectionsText : string with get, set
override OptionsFormAlwaysSuggestCorrectionsText : string with get, set
abstract OptionsFormAlwaysSuggestCorrectionsText : string with get, set
override OptionsFormAlwaysSuggestCorrectionsText : string with get, set
Property Value
String


OptionsFormBasicSettingsText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsFormBasicSettingsText Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsOptions ► OptionsFormBasicSettingsText
Keyoti RapidSpell Desktop .NET
See interface
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsFormBasicSettingsText { get; set; }
public string OptionsFormBasicSettingsText { get; set; }
Public Property OptionsFormBasicSettingsText As String
    Get
    Set
Public Property OptionsFormBasicSettingsText As String
    Get
    Set
public:
virtual property String^ OptionsFormBasicSettingsText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ OptionsFormBasicSettingsText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract OptionsFormBasicSettingsText : string with get, set
override OptionsFormBasicSettingsText : string with get, set
abstract OptionsFormBasicSettingsText : string with get, set
override OptionsFormBasicSettingsText : string with get, set
Property Value
String


OptionsFormCancelText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsFormCancelText Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsOptions ► OptionsFormCancelText
Keyoti RapidSpell Desktop .NET
See interface
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsFormCancelText { get; set; }
public string OptionsFormCancelText { get; set; }
Public Property OptionsFormCancelText As String
    Get
    Set
Public Property OptionsFormCancelText As String
    Get
    Set
public:
virtual property String^ OptionsFormCancelText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ OptionsFormCancelText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract OptionsFormCancelText : string with get, set
override OptionsFormCancelText : string with get, set
abstract OptionsFormCancelText : string with get, set
override OptionsFormCancelText : string with get, set
Property Value
String


OptionsFormCheckAsYouTypeText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsFormCheckAsYouTypeText Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsOptions ► OptionsFormCheckAsYouTypeText
Keyoti RapidSpell Desktop .NET
See interface
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsFormCheckAsYouTypeText { get; set; }
public string OptionsFormCheckAsYouTypeText { get; set; }
Public Property OptionsFormCheckAsYouTypeText As String
    Get
    Set
Public Property OptionsFormCheckAsYouTypeText As String
    Get
    Set
public:
virtual property String^ OptionsFormCheckAsYouTypeText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ OptionsFormCheckAsYouTypeText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract OptionsFormCheckAsYouTypeText : string with get, set
override OptionsFormCheckAsYouTypeText : string with get, set
abstract OptionsFormCheckAsYouTypeText : string with get, set
override OptionsFormCheckAsYouTypeText : string with get, set
Property Value
String


OptionsFormIgnoreImproperCaseText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsFormIgnoreImproperCaseText Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsOptions ► OptionsFormIgnoreImproperCaseText
Keyoti RapidSpell Desktop .NET
See interface
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsFormIgnoreImproperCaseText { get; set; }
public string OptionsFormIgnoreImproperCaseText { get; set; }
Public Property OptionsFormIgnoreImproperCaseText As String
    Get
    Set
Public Property OptionsFormIgnoreImproperCaseText As String
    Get
    Set
public:
virtual property String^ OptionsFormIgnoreImproperCaseText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ OptionsFormIgnoreImproperCaseText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract OptionsFormIgnoreImproperCaseText : string with get, set
override OptionsFormIgnoreImproperCaseText : string with get, set
abstract OptionsFormIgnoreImproperCaseText : string with get, set
override OptionsFormIgnoreImproperCaseText : string with get, set
Property Value
String


OptionsFormIgnoreInternetAddressesText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsFormIgnoreInternetAddressesText Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsOptions ► OptionsFormIgnoreInternetAddressesText
Keyoti RapidSpell Desktop .NET
See interface
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsFormIgnoreInternetAddressesText { get; set; }
public string OptionsFormIgnoreInternetAddressesText { get; set; }
Public Property OptionsFormIgnoreInternetAddressesText As String
    Get
    Set
Public Property OptionsFormIgnoreInternetAddressesText As String
    Get
    Set
public:
virtual property String^ OptionsFormIgnoreInternetAddressesText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ OptionsFormIgnoreInternetAddressesText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract OptionsFormIgnoreInternetAddressesText : string with get, set
override OptionsFormIgnoreInternetAddressesText : string with get, set
abstract OptionsFormIgnoreInternetAddressesText : string with get, set
override OptionsFormIgnoreInternetAddressesText : string with get, set
Property Value
String


OptionsFormIgnoreWordsInUppercaseText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsFormIgnoreWordsInUppercaseText Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsOptions ► OptionsFormIgnoreWordsInUppercaseText
Keyoti RapidSpell Desktop .NET
See interface
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsFormIgnoreWordsInUppercaseText { get; set; }
public string OptionsFormIgnoreWordsInUppercaseText { get; set; }
Public Property OptionsFormIgnoreWordsInUppercaseText As String
    Get
    Set
Public Property OptionsFormIgnoreWordsInUppercaseText As String
    Get
    Set
public:
virtual property String^ OptionsFormIgnoreWordsInUppercaseText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ OptionsFormIgnoreWordsInUppercaseText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract OptionsFormIgnoreWordsInUppercaseText : string with get, set
override OptionsFormIgnoreWordsInUppercaseText : string with get, set
abstract OptionsFormIgnoreWordsInUppercaseText : string with get, set
override OptionsFormIgnoreWordsInUppercaseText : string with get, set
Property Value
String


OptionsFormIgnoreWordsWithNumbersText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsFormIgnoreWordsWithNumbersText Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsOptions ► OptionsFormIgnoreWordsWithNumbersText
Keyoti RapidSpell Desktop .NET
See interface
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsFormIgnoreWordsWithNumbersText { get; set; }
public string OptionsFormIgnoreWordsWithNumbersText { get; set; }
Public Property OptionsFormIgnoreWordsWithNumbersText As String
    Get
    Set
Public Property OptionsFormIgnoreWordsWithNumbersText As String
    Get
    Set
public:
virtual property String^ OptionsFormIgnoreWordsWithNumbersText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ OptionsFormIgnoreWordsWithNumbersText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract OptionsFormIgnoreWordsWithNumbersText : string with get, set
override OptionsFormIgnoreWordsWithNumbersText : string with get, set
abstract OptionsFormIgnoreWordsWithNumbersText : string with get, set
override OptionsFormIgnoreWordsWithNumbersText : string with get, set
Property Value
String


OptionsFormOKText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsFormOKText Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsOptions ► OptionsFormOKText
Keyoti RapidSpell Desktop .NET
See interface
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsFormOKText { get; set; }
public string OptionsFormOKText { get; set; }
Public Property OptionsFormOKText As String
    Get
    Set
Public Property OptionsFormOKText As String
    Get
    Set
public:
virtual property String^ OptionsFormOKText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ OptionsFormOKText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract OptionsFormOKText : string with get, set
override OptionsFormOKText : string with get, set
abstract OptionsFormOKText : string with get, set
override OptionsFormOKText : string with get, set
Property Value
String


OptionsFormRecheckTextText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsFormRecheckTextText Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsOptions ► OptionsFormRecheckTextText
Keyoti RapidSpell Desktop .NET
See interface
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsFormRecheckTextText { get; set; }
public string OptionsFormRecheckTextText { get; set; }
Public Property OptionsFormRecheckTextText As String
    Get
    Set
Public Property OptionsFormRecheckTextText As String
    Get
    Set
public:
virtual property String^ OptionsFormRecheckTextText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ OptionsFormRecheckTextText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract OptionsFormRecheckTextText : string with get, set
override OptionsFormRecheckTextText : string with get, set
abstract OptionsFormRecheckTextText : string with get, set
override OptionsFormRecheckTextText : string with get, set
Property Value
String


OptionsFormSuggestFromMainDictionaryOnlyText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsFormSuggestFromMainDictionaryOnlyText Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsOptions ► OptionsFormSuggestFromMainDictionaryOnlyText
Keyoti RapidSpell Desktop .NET
See interface
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsFormSuggestFromMainDictionaryOnlyText { get; set; }
public string OptionsFormSuggestFromMainDictionaryOnlyText { get; set; }
Public Property OptionsFormSuggestFromMainDictionaryOnlyText As String
    Get
    Set
Public Property OptionsFormSuggestFromMainDictionaryOnlyText As String
    Get
    Set
public:
virtual property String^ OptionsFormSuggestFromMainDictionaryOnlyText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ OptionsFormSuggestFromMainDictionaryOnlyText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract OptionsFormSuggestFromMainDictionaryOnlyText : string with get, set
override OptionsFormSuggestFromMainDictionaryOnlyText : string with get, set
abstract OptionsFormSuggestFromMainDictionaryOnlyText : string with get, set
override OptionsFormSuggestFromMainDictionaryOnlyText : string with get, set
Property Value
String


OptionsFormTitleText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsFormTitleText Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsOptions ► OptionsFormTitleText
Keyoti RapidSpell Desktop .NET
See interface
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsFormTitleText { get; set; }
public string OptionsFormTitleText { get; set; }
Public Property OptionsFormTitleText As String
    Get
    Set
Public Property OptionsFormTitleText As String
    Get
    Set
public:
virtual property String^ OptionsFormTitleText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ OptionsFormTitleText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract OptionsFormTitleText : string with get, set
override OptionsFormTitleText : string with get, set
abstract OptionsFormTitleText : string with get, set
override OptionsFormTitleText : string with get, set
Property Value
String


OptionsFormUserDictionaryEditText Property

Keyoti RapidSpell Desktop .NET API Docs
OptionsFormUserDictionaryEditText Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsOptions ► OptionsFormUserDictionaryEditText
Keyoti RapidSpell Desktop .NET
See interface
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsFormUserDictionaryEditText { get; set; }
public string OptionsFormUserDictionaryEditText { get; set; }
Public Property OptionsFormUserDictionaryEditText As String
    Get
    Set
Public Property OptionsFormUserDictionaryEditText As String
    Get
    Set
public:
virtual property String^ OptionsFormUserDictionaryEditText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ OptionsFormUserDictionaryEditText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract OptionsFormUserDictionaryEditText : string with get, set
override OptionsFormUserDictionaryEditText : string with get, set
abstract OptionsFormUserDictionaryEditText : string with get, set
override OptionsFormUserDictionaryEditText : string with get, set
Property Value
String


RecheckDocumentRequest Event

Keyoti RapidSpell Desktop .NET API Docs
RecheckDocumentRequest Event
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsOptions ► RecheckDocumentRequest
Keyoti RapidSpell Desktop .NET
See interface
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler RecheckDocumentRequest
public event EventHandler RecheckDocumentRequest
Public Event RecheckDocumentRequest As EventHandler
Public Event RecheckDocumentRequest As EventHandler
public:
virtual  event EventHandler^ RecheckDocumentRequest {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ RecheckDocumentRequest {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract RecheckDocumentRequest : IEvent<EventHandler,
    EventArgs>
override RecheckDocumentRequest : IEvent<EventHandler,
    EventArgs>
abstract RecheckDocumentRequest : IEvent<EventHandler,
    EventArgs>
override RecheckDocumentRequest : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


SelectUserDictionary Event

Keyoti RapidSpell Desktop .NET API Docs
SelectUserDictionary Event
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsOptions ► SelectUserDictionary
Keyoti RapidSpell Desktop .NET
See interface
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler SelectUserDictionary
public event EventHandler SelectUserDictionary
Public Event SelectUserDictionary As EventHandler
Public Event SelectUserDictionary As EventHandler
public:
virtual  event EventHandler^ SelectUserDictionary {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ SelectUserDictionary {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract SelectUserDictionary : IEvent<EventHandler,
    EventArgs>
override SelectUserDictionary : IEvent<EventHandler,
    EventArgs>
abstract SelectUserDictionary : IEvent<EventHandler,
    EventArgs>
override SelectUserDictionary : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


ShowDialog Method (owner, showCheckAsYouTypeOption, showFindSuggestionsOption, showUserDictionaryButton)

Keyoti RapidSpell Desktop .NET API Docs
ShowDialog Method (owner, showCheckAsYouTypeOption, showFindSuggestionsOption, showUserDictionaryButton)
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsOptions ► ShowDialog(Object, Boolean, Boolean, Boolean)
Keyoti RapidSpell Desktop .NET
See interface
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public DialogResult ShowDialog(
    Object owner,
    bool showCheckAsYouTypeOption,
    bool showFindSuggestionsOption,
    bool showUserDictionaryButton
)
public DialogResult ShowDialog(
    Object owner,
    bool showCheckAsYouTypeOption,
    bool showFindSuggestionsOption,
    bool showUserDictionaryButton
)
Public Function ShowDialog (
    owner As Object,
    showCheckAsYouTypeOption As Boolean,
    showFindSuggestionsOption As Boolean,
    showUserDictionaryButton As Boolean
) As DialogResult
Public Function ShowDialog (
    owner As Object,
    showCheckAsYouTypeOption As Boolean,
    showFindSuggestionsOption As Boolean,
    showUserDictionaryButton As Boolean
) As DialogResult
public:
virtual DialogResult ShowDialog(
    Object^ owner,
    bool showCheckAsYouTypeOption,
    bool showFindSuggestionsOption,
    bool showUserDictionaryButton
) sealed
public:
virtual DialogResult ShowDialog(
    Object^ owner,
    bool showCheckAsYouTypeOption,
    bool showFindSuggestionsOption,
    bool showUserDictionaryButton
) sealed
abstract ShowDialog :
        owner : Object *
        showCheckAsYouTypeOption : bool *
        showFindSuggestionsOption : bool *
        showUserDictionaryButton : bool -> DialogResult
override ShowDialog :
        owner : Object *
        showCheckAsYouTypeOption : bool *
        showFindSuggestionsOption : bool *
        showUserDictionaryButton : bool -> DialogResult
abstract ShowDialog :
        owner : Object *
        showCheckAsYouTypeOption : bool *
        showFindSuggestionsOption : bool *
        showUserDictionaryButton : bool -> DialogResult
override ShowDialog :
        owner : Object *
        showCheckAsYouTypeOption : bool *
        showFindSuggestionsOption : bool *
        showUserDictionaryButton : bool -> DialogResult
Parameters
owner (Object)
showCheckAsYouTypeOption (Boolean)
showFindSuggestionsOption (Boolean)
showUserDictionaryButton (Boolean)
Return Value
DialogResult


WindowsFormsUserDictionaryEdit Class

Keyoti RapidSpell Desktop .NET API Docs
WindowsFormsUserDictionaryEdit Class
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionaryEdit
Keyoti RapidSpell Desktop .NET
Windows forms implementation of IDialogViewUserDictionaryEdit
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class WindowsFormsUserDictionaryEdit : Form,
    IDialogViewUserDictionaryEdit
public class WindowsFormsUserDictionaryEdit : Form,
    IDialogViewUserDictionaryEdit
Public Class WindowsFormsUserDictionaryEdit
    Inherits Form
    Implements IDialogViewUserDictionaryEdit
Public Class WindowsFormsUserDictionaryEdit
    Inherits Form
    Implements IDialogViewUserDictionaryEdit
public ref class WindowsFormsUserDictionaryEdit : public Form,
    IDialogViewUserDictionaryEdit
public ref class WindowsFormsUserDictionaryEdit : public Form,
    IDialogViewUserDictionaryEdit
type WindowsFormsUserDictionaryEdit =
    class
        inherit Form
        interface IDialogViewUserDictionaryEdit
    end
type WindowsFormsUserDictionaryEdit =
    class
        inherit Form
        interface IDialogViewUserDictionaryEdit
    end
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WindowsFormsUserDictionaryEdit()()()() | New
 | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
 | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
 | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
 | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
 | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
 | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
 | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
 | Activate()()()() | Activates the form and gives it focus. (Inherited from Form.)
 | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
 | ActivateMdiChild(Form) | Activates the MDI child of a form. (Inherited from Form.)
 | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
 | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
 | AddOwnedForm(Form) | Adds an owned form to this form. (Inherited from Form.)
 | AddWord | Word is being added
 | AdjustFormScrollbars(Boolean) | (Inherited from Form.)
 | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
 | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
 | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
 | ApplyAutoScaling()()()() | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
 | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
 | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
 | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
 | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
 | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
 | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
 | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
 | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
 | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
 | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
 | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
 | AutoSizeChanged | (Inherited from Form.)
 | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
 | AutoValidate | (Inherited from Form.)
 | AutoValidateChanged | (Inherited from Form.)
 | BackColor | (Inherited from Form.)
 | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
 | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
 | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
 | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
 | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
 | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
 | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
 | BindingContext | (Inherited from ContainerControl.)
 | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
 | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
 | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
 | BringToFront()()()() | Brings the control to the front of the z-order. (Inherited from Control.)
 | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
 | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
 | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
 | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
 | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
 | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
 | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
 | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
 | CenterToParent()()()() | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
 | CenterToScreen()()()() | Centers the form on the current screen. (Inherited from Form.)
 | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
 | Click | Occurs when the control is clicked. (Inherited from Control.)
 | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
 | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
 | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
 | Close()()()() | Closes the form. (Inherited from Form.)
 | Closed | Occurs when the form is closed. (Inherited from Form.)
 | Closing | Occurs when the form is closing. (Inherited from Form.)
 | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | Contains(Control) | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
 | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
 | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
 | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
 | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
 | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
 | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
 | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
 | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
 | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
 | CreateAccessibilityInstance()()()() | Creates a new accessibility object for the control. (Inherited from Control.)
 | CreateControl()()()() | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
 | CreateControlsInstance()()()() | (Inherited from Form.)
 | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
 | CreateGraphics()()()() | Creates the Graphics for the control. (Inherited from Control.)
 | CreateHandle()()()() | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateParams | (Inherited from Form.)
 | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
 | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
 | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
 | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
 | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
 | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
 | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
 | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
 | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
 | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
 | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
 | DefaultSize | (Inherited from Form.)
 | DefWndProc(Message%) | (Inherited from Form.)
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
 | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
 | DestroyHandle()()()() | Destroys the handle associated with the control. (Inherited from Control.)
 | DeviceDpi()()()() | (Inherited from Control.)
 | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
 | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Form.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
 | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
 | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
 | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
 | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
 | DoDragDrop(Object, DragDropEffects) | Begins a drag-and-drop operation. (Inherited from Control.)
 | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
 | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
 | DpiChanged()()()() | (Inherited from Form.)
 | DpiChangedAfterParent()()()() | (Inherited from Control.)
 | DpiChangedBeforeParent()()()() | (Inherited from Control.)
 | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
 | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
 | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
 | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
 | DrawToBitmap(Bitmap, Rectangle) | Supports rendering to the specified bitmap. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
 | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
 | EndInvoke(IAsyncResult) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
 | Enter | Occurs when the control is entered. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | Finalize()()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | FindForm()()()() | Retrieves the form that the control is on. (Inherited from Control.)
 | Focus()()()() | Sets input focus to the control. (Inherited from Control.)
 | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
 | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
 | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
 | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
 | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
 | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
 | FormClosed | Occurs after the form is closed. (Inherited from Form.)
 | FormClosing | Occurs before the form is closed. (Inherited from Form.)
 | GetAccessibilityObjectById(Int32) | Retrieves the specified AccessibleObject. (Inherited from Control.)
 | GetAutoSizeMode()()()() | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
 | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
 | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
 | GetContainerControl()()()() | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetNextControl(Control, Boolean) | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
 | GetPreferredSize(Size) | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
 | GetScaledBounds(Rectangle, SizeF, BoundsSpecified) | (Inherited from Form.)
 | GetScrollState(Int32) | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetStyle(ControlStyles) | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
 | GetTopLevel()()()() | Determines if the control is a top-level control. (Inherited from Control.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
 | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
 | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
 | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
 | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
 | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the control. (Inherited from Control.)
 | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
 | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
 | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
 | Hide()()()() | Conceals the control from the user. (Inherited from Control.)
 | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
 | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
 | Icon | Gets or sets the icon for the form. (Inherited from Form.)
 | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
 | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
 | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | InitLayout()()()() | Called after the control has been added to another container. (Inherited from Control.)
 | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
 | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
 | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
 | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
 | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
 | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
 | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
 | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
 | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
 | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
 | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
 | InvokeGotFocus(Control, EventArgs) | Raises the GotFocus event for the specified control. (Inherited from Control.)
 | InvokeLostFocus(Control, EventArgs) | Raises the LostFocus event for the specified control. (Inherited from Control.)
 | InvokeOnClick(Control, EventArgs) | Raises the Click event for the specified control. (Inherited from Control.)
 | InvokePaint(Control, PaintEventArgs) | Raises the Paint event for the specified control. (Inherited from Control.)
 | InvokePaintBackground(Control, PaintEventArgs) | Raises the PaintBackground event for the specified control. (Inherited from Control.)
 | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
 | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
 | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
 | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
 | IsInputChar(Char) | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
 | IsInputKey(Keys) | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
 | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
 | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
 | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
 | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
 | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
 | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
 | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
 | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
 | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
 | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
 | LayoutMdi(MdiLayout) | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
 | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
 | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
 | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
 | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
 | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
 | LogicalToDeviceUnits(Int32) | (Inherited from Control.)
 | LogicalToDeviceUnits(Size) | (Inherited from Control.)
 | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
 | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
 | Margin | (Inherited from Form.)
 | MarginChanged | (Inherited from Form.)
 | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
 | MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
 | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
 | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
 | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
 | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
 | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
 | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
 | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
 | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
 | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
 | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
 | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
 | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
 | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
 | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
 | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
 | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
 | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
 | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
 | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
 | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
 | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
 | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
 | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
 | Move | Occurs when the control is moved. (Inherited from Control.)
 | Name | Gets or sets the name of the control. (Inherited from Control.)
 | NotifyInvalidate(Rectangle) | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
 | OnActivated(EventArgs) | Raises the Activated event. (Inherited from Form.)
 | OnAutoSizeChanged(EventArgs) | Raises the AutoSizeChanged event. (Inherited from Control.)
 | OnAutoValidateChanged(EventArgs) | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
 | OnBackColorChanged(EventArgs) | Raises the BackColorChanged event. (Inherited from Control.)
 | OnBackgroundImageChanged(EventArgs) | Raises the BackgroundImageChanged event. (Inherited from Form.)
 | OnBackgroundImageLayoutChanged(EventArgs) | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
 | OnBindingContextChanged(EventArgs) | Raises the BindingContextChanged event. (Inherited from Control.)
 | OnCausesValidationChanged(EventArgs) | Raises the CausesValidationChanged event. (Inherited from Control.)
 | OnChangeUICues(UICuesEventArgs) | Raises the ChangeUICues event. (Inherited from Control.)
 | OnClick(EventArgs) | Raises the Click event. (Inherited from Control.)
 | OnClientSizeChanged(EventArgs) | Raises the ClientSizeChanged event. (Inherited from Control.)
 | OnClosed(EventArgs) | Raises the Closed event. (Inherited from Form.)
 | OnClosing(CancelEventArgs) | Raises the Closing event. (Inherited from Form.)
 | OnContextMenuChanged(EventArgs) | Raises the ContextMenuChanged event. (Inherited from Control.)
 | OnContextMenuStripChanged(EventArgs) | Raises the ContextMenuStripChanged event. (Inherited from Control.)
 | OnControlAdded(ControlEventArgs) | Raises the ControlAdded event. (Inherited from Control.)
 | OnControlRemoved(ControlEventArgs) | Raises the ControlRemoved event. (Inherited from Control.)
 | OnCreateControl()()()() | Raises the CreateControl event. (Inherited from Form.)
 | OnCursorChanged(EventArgs) | Raises the CursorChanged event. (Inherited from Control.)
 | OnDeactivate(EventArgs) | Raises the Deactivate event. (Inherited from Form.)
 | OnDockChanged(EventArgs) | Raises the DockChanged event. (Inherited from Control.)
 | OnDoubleClick(EventArgs) | Raises the DoubleClick event. (Inherited from Control.)
 | OnDpiChanged(DpiChangedEventArgs) | (Inherited from Form.)
 | OnDpiChangedAfterParent(EventArgs) | (Inherited from Control.)
 | OnDpiChangedBeforeParent(EventArgs) | (Inherited from Control.)
 | OnDragDrop(DragEventArgs) | Raises the DragDrop event. (Inherited from Control.)
 | OnDragEnter(DragEventArgs) | Raises the DragEnter event. (Inherited from Control.)
 | OnDragLeave(EventArgs) | Raises the DragLeave event. (Inherited from Control.)
 | OnDragOver(DragEventArgs) | Raises the DragOver event. (Inherited from Control.)
 | OnEnabledChanged(EventArgs) | (Inherited from Form.)
 | OnEnter(EventArgs) | Raises the Enter event. (Inherited from Form.)
 | OnFontChanged(EventArgs) | (Inherited from Form.)
 | OnForeColorChanged(EventArgs) | Raises the ForeColorChanged event. (Inherited from Control.)
 | OnFormClosed(FormClosedEventArgs) | Raises the FormClosed event. (Inherited from Form.)
 | OnFormClosing(FormClosingEventArgs) | Raises the FormClosing event. (Inherited from Form.)
 | OnGetDpiScaledSize(Int32, Int32, Size%) | (Inherited from Form.)
 | OnGiveFeedback(GiveFeedbackEventArgs) | Raises the GiveFeedback event. (Inherited from Control.)
 | OnGotFocus(EventArgs) | Raises the GotFocus event. (Inherited from Control.)
 | OnHandleCreated(EventArgs) | (Inherited from Form.)
 | OnHandleDestroyed(EventArgs) | (Inherited from Form.)
 | OnHelpButtonClicked(CancelEventArgs) | Raises the HelpButtonClicked event. (Inherited from Form.)
 | OnHelpRequested(HelpEventArgs) | Raises the HelpRequested event. (Inherited from Control.)
 | OnImeModeChanged(EventArgs) | Raises the ImeModeChanged event. (Inherited from Control.)
 | OnInputLanguageChanged(InputLanguageChangedEventArgs) | Raises the InputLanguageChanged event. (Inherited from Form.)
 | OnInputLanguageChanging(InputLanguageChangingEventArgs) | Raises the InputLanguageChanging event. (Inherited from Form.)
 | OnInvalidated(InvalidateEventArgs) | Raises the Invalidated event. (Inherited from Control.)
 | OnKeyDown(KeyEventArgs) | Raises the KeyDown event. (Inherited from Control.)
 | OnKeyPress(KeyPressEventArgs) | Raises the KeyPress event. (Inherited from Control.)
 | OnKeyUp(KeyEventArgs) | Raises the KeyUp event. (Inherited from Control.)
 | OnLayout(LayoutEventArgs) | (Inherited from Form.)
 | OnLeave(EventArgs) | Raises the Leave event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Form.)
 | OnLocationChanged(EventArgs) | Raises the LocationChanged event. (Inherited from Control.)
 | OnLostFocus(EventArgs) | Raises the LostFocus event. (Inherited from Control.)
 | OnMarginChanged(EventArgs) | Raises the MarginChanged event. (Inherited from Control.)
 | OnMaximizedBoundsChanged(EventArgs) | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
 | OnMaximumSizeChanged(EventArgs) | Raises the MaximumSizeChanged event. (Inherited from Form.)
 | OnMdiChildActivate(EventArgs) | Raises the MdiChildActivate event. (Inherited from Form.)
 | OnMenuComplete(EventArgs) | Raises the MenuComplete event. (Inherited from Form.)
 | OnMenuStart(EventArgs) | Raises the MenuStart event. (Inherited from Form.)
 | OnMinimumSizeChanged(EventArgs) | Raises the MinimumSizeChanged event. (Inherited from Form.)
 | OnMouseCaptureChanged(EventArgs) | Raises the MouseCaptureChanged event. (Inherited from Control.)
 | OnMouseClick(MouseEventArgs) | Raises the MouseClick event. (Inherited from Control.)
 | OnMouseDoubleClick(MouseEventArgs) | Raises the MouseDoubleClick event. (Inherited from Control.)
 | OnMouseDown(MouseEventArgs) | Raises the MouseDown event. (Inherited from Control.)
 | OnMouseEnter(EventArgs) | Raises the MouseEnter event. (Inherited from Control.)
 | OnMouseHover(EventArgs) | Raises the MouseHover event. (Inherited from Control.)
 | OnMouseLeave(EventArgs) | Raises the MouseLeave event. (Inherited from Control.)
 | OnMouseMove(MouseEventArgs) | Raises the MouseMove event. (Inherited from Control.)
 | OnMouseUp(MouseEventArgs) | Raises the MouseUp event. (Inherited from Control.)
 | OnMouseWheel(MouseEventArgs) | Raises the MouseWheel event. (Inherited from ScrollableControl.)
 | OnMove(EventArgs) | Raises the Move event. (Inherited from Control.)
 | OnNotifyMessage(Message) | Notifies the control of Windows messages. (Inherited from Control.)
 | OnPaddingChanged(EventArgs) | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
 | OnPaint(PaintEventArgs) | (Inherited from Form.)
 | OnPaintBackground(PaintEventArgs) | Paints the background of the control. (Inherited from ScrollableControl.)
 | OnParentBackColorChanged(EventArgs) | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
 | OnParentBackgroundImageChanged(EventArgs) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
 | OnParentBindingContextChanged(EventArgs) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
 | OnParentChanged(EventArgs) | (Inherited from ContainerControl.)
 | OnParentCursorChanged(EventArgs) | Raises the CursorChanged event. (Inherited from Control.)
 | OnParentEnabledChanged(EventArgs) | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
 | OnParentFontChanged(EventArgs) | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
 | OnParentForeColorChanged(EventArgs) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
 | OnParentRightToLeftChanged(EventArgs) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
 | OnParentVisibleChanged(EventArgs) | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
 | OnPreviewKeyDown(PreviewKeyDownEventArgs) | Raises the PreviewKeyDown event. (Inherited from Control.)
 | OnPrint(PaintEventArgs) | Raises the Paint event. (Inherited from Control.)
 | OnQueryContinueDrag(QueryContinueDragEventArgs) | Raises the QueryContinueDrag event. (Inherited from Control.)
 | OnRegionChanged(EventArgs) | Raises the RegionChanged event. (Inherited from Control.)
 | OnResize(EventArgs) | (Inherited from Form.)
 | OnResizeBegin(EventArgs) | Raises the ResizeBegin event. (Inherited from Form.)
 | OnResizeEnd(EventArgs) | Raises the ResizeEnd event. (Inherited from Form.)
 | OnRightToLeftChanged(EventArgs) | (Inherited from ScrollableControl.)
 | OnRightToLeftLayoutChanged(EventArgs) | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
 | OnScroll(ScrollEventArgs) | Raises the Scroll event. (Inherited from ScrollableControl.)
 | OnShown(EventArgs) | Raises the Shown event. (Inherited from Form.)
 | OnSizeChanged(EventArgs) | Raises the SizeChanged event. (Inherited from Control.)
 | OnStyleChanged(EventArgs) | (Inherited from Form.)
 | OnSystemColorsChanged(EventArgs) | Raises the SystemColorsChanged event. (Inherited from Control.)
 | OnTabIndexChanged(EventArgs) | Raises the TabIndexChanged event. (Inherited from Control.)
 | OnTabStopChanged(EventArgs) | Raises the TabStopChanged event. (Inherited from Control.)
 | OnTextChanged(EventArgs) | (Inherited from Form.)
 | OnValidated(EventArgs) | Raises the Validated event. (Inherited from Control.)
 | OnValidating(CancelEventArgs) | Raises the Validating event. (Inherited from Control.)
 | OnVisibleChanged(EventArgs) | Raises the VisibleChanged event. (Inherited from Form.)
 | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
 | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
 | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
 | Padding | Gets or sets padding within the control. (Inherited from Control.)
 | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
 | Paint | Occurs when the control is redrawn. (Inherited from Control.)
 | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
 | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
 | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
 | PerformAutoScale()()()() | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
 | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
 | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
 | PointToClient(Point) | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
 | PointToScreen(Point) | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
 | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
 | PreProcessControlMessage(Message%) | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
 | PreProcessMessage(Message%) | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
 | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
 | ProcessCmdKey(Message%, Keys) | Processes a command key. (Inherited from Form.)
 | ProcessDialogChar(Char) | (Inherited from Form.)
 | ProcessDialogKey(Keys) | Processes a dialog box key. (Inherited from Form.)
 | ProcessKeyEventArgs(Message%) | Processes a key message and generates the appropriate control events. (Inherited from Control.)
 | ProcessKeyMessage(Message%) | Processes a keyboard message. (Inherited from Control.)
 | ProcessKeyPreview(Message%) | (Inherited from Form.)
 | ProcessMnemonic(Char) | (Inherited from Form.)
 | ProcessTabKey(Boolean) | (Inherited from Form.)
 | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
 | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
 | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
 | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
 | RaiseDragEvent(Object, DragEventArgs) | Raises the appropriate drag event. (Inherited from Control.)
 | RaiseKeyEvent(Object, KeyEventArgs) | Raises the appropriate key event. (Inherited from Control.)
 | RaiseMouseEvent(Object, MouseEventArgs) | Raises the appropriate mouse event. (Inherited from Control.)
 | RaisePaintEvent(Object, PaintEventArgs) | Raises the appropriate paint event. (Inherited from Control.)
 | RecreateHandle()()()() | Forces the re-creation of the handle for the control. (Inherited from Control.)
 | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
 | RectangleToClient(Rectangle) | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
 | RectangleToScreen(Rectangle) | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
 | Refresh()()()() | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
 | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
 | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
 | RemoveOwnedForm(Form) | Removes an owned form from this form. (Inherited from Form.)
 | RemoveWord | Word is being removed
 | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
 | RescaleConstantsForDpi(Int32, Int32) | (Inherited from Control.)
 | ResetBackColor()()()() | Resets the BackColor property to its default value. (Inherited from Control.)
 | ResetBindings()()()() | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
 | ResetCursor()()()() | Resets the Cursor property to its default value. (Inherited from Control.)
 | ResetFont()()()() | Resets the Font property to its default value. (Inherited from Control.)
 | ResetForeColor()()()() | Resets the ForeColor property to its default value. (Inherited from Control.)
 | ResetImeMode()()()() | Resets the ImeMode property to its default value. (Inherited from Control.)
 | ResetMouseEventArgs()()()() | Resets the control to handle the MouseLeave event. (Inherited from Control.)
 | ResetRightToLeft()()()() | Resets the RightToLeft property to its default value. (Inherited from Control.)
 | ResetText()()()() | Resets the Text property to its default value. (Inherited from Control.)
 | Resize | Occurs when the control is resized. (Inherited from Control.)
 | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
 | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
 | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
 | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
 | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
 | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
 | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
 | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
 | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
 | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
 | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
 | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateContent(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateHorizontal(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateLeftRight(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
 | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
 | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
 | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
 | ScaleBitmapLogicalToDevice(Bitmap%) | (Inherited from Control.)
 | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
 | ScaleControl(SizeF, BoundsSpecified) | (Inherited from Form.)
 | ScaleCore(Single, Single) | Performs scaling of the form. (Inherited from Form.)
 | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
 | ScrollControlIntoView(Control) | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
 | ScrollToControl(Control) | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
 | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
 | Select()()()() | Activates the control. (Inherited from Control.)
 | SelectNextControl(Control, Boolean, Boolean, Boolean, Boolean) | Activates the next control. (Inherited from Control.)
 | SendToBack()()()() | Sends the control to the back of the z-order. (Inherited from Control.)
 | SetAutoScrollMargin(Int32, Int32) | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
 | SetAutoSizeMode(AutoSizeMode) | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
 | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
 | SetBoundsCore(Int32, Int32, Int32, Int32, BoundsSpecified) | (Inherited from Form.)
 | SetClientSizeCore(Int32, Int32) | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
 | SetDesktopBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
 | SetDesktopLocation(Int32, Int32) | Sets the location of the form in desktop coordinates. (Inherited from Form.)
 | SetDisplayRectLocation(Int32, Int32) | Positions the display window to the specified value. (Inherited from ScrollableControl.)
 | SetScrollState(Int32, Boolean) | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
 | SetStyle(ControlStyles, Boolean) | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
 | SetTopLevel(Boolean) | Sets the control as the top-level control. (Inherited from Control.)
 | SetVisibleCore(Boolean) | (Inherited from Form.)
 | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
 | Show()()()() | Displays the control to the user. (Inherited from Control.)
 | ShowDialog(Object, ArrayList) | See IDialogViewUserDictionaryEdit
 | ShowDialog()()()() | Shows the form as a modal dialog box. (Inherited from Form.)
 | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
 | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
 | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
 | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
 | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
 | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
 | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
 | Site | Gets or sets the site of the control. (Inherited from Control.)
 | Size | Gets or sets the size of the form. (Inherited from Form.)
 | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
 | SizeFromClientSize(Size) | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
 | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
 | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
 | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
 | SuspendLayout()()()() | Temporarily suspends the layout logic for the control. (Inherited from Control.)
 | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
 | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
 | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
 | TabStop | (Inherited from Form.)
 | TabStopChanged | (Inherited from Form.)
 | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
 | Text | (Inherited from Form.)
 | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
 | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
 | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
 | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
 | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
 | ToString()()()() | Gets a string representing the current instance of the form. (Inherited from Form.)
 | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
 | Update()()()() | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
 | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
 | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
 | UpdateDefaultButton()()()() | Updates which button is the default button. (Inherited from Form.)
 | UpdateStyles()()()() | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
 | UpdateZOrder()()()() | Updates the control in its parent's z-order. (Inherited from Control.)
 | UserDictionaryFormAddText | See IDialogViewUserDictionaryEdit
 | UserDictionaryFormCancelText | See IDialogViewUserDictionaryEdit
 | UserDictionaryFormContentsText | See IDialogViewUserDictionaryEdit
 | UserDictionaryFormDeleteText | See IDialogViewUserDictionaryEdit
 | UserDictionaryFormDictionaryLabelText | See IDialogViewUserDictionaryEdit
 | UserDictionaryFormOKText | See IDialogViewUserDictionaryEdit
 | UserDictionaryFormTitleText | See IDialogViewUserDictionaryEdit
 | UserDictionaryFormWordLabelText | See IDialogViewUserDictionaryEdit
 | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
 | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
 | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
 | ValidateChildren()()()() | (Inherited from Form.)
 | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
 | Validated | Occurs when the control is finished validating. (Inherited from Control.)
 | Validating | Occurs when the control is validating. (Inherited from Control.)
 | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
 | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
 | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
 | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
 | Width | Gets or sets the width of the control. (Inherited from Control.)
 | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
 | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
 | WndProc(Message%) | (Inherited from Form.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | Control
 |  |  |  | ScrollableControl
 |  |  |  |  | ContainerControl
 |  |  |  |  |  | Form
 |  |  |  |  |  |  | WindowsFormsUserDictionaryEdit


WindowsFormsUserDictionaryEdit Constructor

Keyoti RapidSpell Desktop .NET API Docs
WindowsFormsUserDictionaryEdit Constructor
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionaryEdit ► WindowsFormsUserDictionaryEdit()()()()
Keyoti RapidSpell Desktop .NET
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public WindowsFormsUserDictionaryEdit()
public WindowsFormsUserDictionaryEdit()
Public Sub New
Public Sub New
public:
WindowsFormsUserDictionaryEdit()
public:
WindowsFormsUserDictionaryEdit()
new : unit -> WindowsFormsUserDictionaryEdit
new : unit -> WindowsFormsUserDictionaryEdit


AddWord Event

Keyoti RapidSpell Desktop .NET API Docs
AddWord Event
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionaryEdit ► AddWord
Keyoti RapidSpell Desktop .NET
Word is being added
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event UserDictionaryEditEventHandler AddWord
public event UserDictionaryEditEventHandler AddWord
Public Event AddWord As UserDictionaryEditEventHandler
Public Event AddWord As UserDictionaryEditEventHandler
public:
virtual  event UserDictionaryEditEventHandler^ AddWord {
    void add (UserDictionaryEditEventHandler^ value);
    void remove (UserDictionaryEditEventHandler^ value);
}
public:
virtual  event UserDictionaryEditEventHandler^ AddWord {
    void add (UserDictionaryEditEventHandler^ value);
    void remove (UserDictionaryEditEventHandler^ value);
}
abstract AddWord : IEvent<UserDictionaryEditEventHandler,
    UserDictionaryEditEventArgs>
override AddWord : IEvent<UserDictionaryEditEventHandler,
    UserDictionaryEditEventArgs>
abstract AddWord : IEvent<UserDictionaryEditEventHandler,
    UserDictionaryEditEventArgs>
override AddWord : IEvent<UserDictionaryEditEventHandler,
    UserDictionaryEditEventArgs>
Value
UserDictionaryEditEventHandler


Dispose Method (disposing)

Keyoti RapidSpell Desktop .NET API Docs
Dispose Method (disposing)
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionaryEdit ► Dispose(Boolean)
Keyoti RapidSpell Desktop .NET
Clean up any resources being used.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
Parameters
disposing (Boolean)
true if managed resources should be disposed; otherwise, false.


RemoveWord Event

Keyoti RapidSpell Desktop .NET API Docs
RemoveWord Event
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionaryEdit ► RemoveWord
Keyoti RapidSpell Desktop .NET
Word is being removed
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event UserDictionaryEditEventHandler RemoveWord
public event UserDictionaryEditEventHandler RemoveWord
Public Event RemoveWord As UserDictionaryEditEventHandler
Public Event RemoveWord As UserDictionaryEditEventHandler
public:
virtual  event UserDictionaryEditEventHandler^ RemoveWord {
    void add (UserDictionaryEditEventHandler^ value);
    void remove (UserDictionaryEditEventHandler^ value);
}
public:
virtual  event UserDictionaryEditEventHandler^ RemoveWord {
    void add (UserDictionaryEditEventHandler^ value);
    void remove (UserDictionaryEditEventHandler^ value);
}
abstract RemoveWord : IEvent<UserDictionaryEditEventHandler,
    UserDictionaryEditEventArgs>
override RemoveWord : IEvent<UserDictionaryEditEventHandler,
    UserDictionaryEditEventArgs>
abstract RemoveWord : IEvent<UserDictionaryEditEventHandler,
    UserDictionaryEditEventArgs>
override RemoveWord : IEvent<UserDictionaryEditEventHandler,
    UserDictionaryEditEventArgs>
Value
UserDictionaryEditEventHandler


ShowDialog Method (owner, userDictionaryContents)

Keyoti RapidSpell Desktop .NET API Docs
ShowDialog Method (owner, userDictionaryContents)
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionaryEdit ► ShowDialog(Object, ArrayList)
Keyoti RapidSpell Desktop .NET
See IDialogViewUserDictionaryEdit
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public DialogResult ShowDialog(
    Object owner,
    ArrayList userDictionaryContents
)
public DialogResult ShowDialog(
    Object owner,
    ArrayList userDictionaryContents
)
Public Function ShowDialog (
    owner As Object,
    userDictionaryContents As ArrayList
) As DialogResult
Public Function ShowDialog (
    owner As Object,
    userDictionaryContents As ArrayList
) As DialogResult
public:
virtual DialogResult ShowDialog(
    Object^ owner,
    ArrayList^ userDictionaryContents
) sealed
public:
virtual DialogResult ShowDialog(
    Object^ owner,
    ArrayList^ userDictionaryContents
) sealed
abstract ShowDialog :
        owner : Object *
        userDictionaryContents : ArrayList -> DialogResult
override ShowDialog :
        owner : Object *
        userDictionaryContents : ArrayList -> DialogResult
abstract ShowDialog :
        owner : Object *
        userDictionaryContents : ArrayList -> DialogResult
override ShowDialog :
        owner : Object *
        userDictionaryContents : ArrayList -> DialogResult
Parameters
owner (Object)
userDictionaryContents (ArrayList)
Return Value
DialogResult


UserDictionaryFormAddText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionaryFormAddText Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionaryEdit ► UserDictionaryFormAddText
Keyoti RapidSpell Desktop .NET
See IDialogViewUserDictionaryEdit
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionaryFormAddText { get; set; }
public string UserDictionaryFormAddText { get; set; }
Public Property UserDictionaryFormAddText As String
    Get
    Set
Public Property UserDictionaryFormAddText As String
    Get
    Set
public:
virtual property String^ UserDictionaryFormAddText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ UserDictionaryFormAddText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract UserDictionaryFormAddText : string with get, set
override UserDictionaryFormAddText : string with get, set
abstract UserDictionaryFormAddText : string with get, set
override UserDictionaryFormAddText : string with get, set
Property Value
String


UserDictionaryFormCancelText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionaryFormCancelText Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionaryEdit ► UserDictionaryFormCancelText
Keyoti RapidSpell Desktop .NET
See IDialogViewUserDictionaryEdit
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionaryFormCancelText { get; set; }
public string UserDictionaryFormCancelText { get; set; }
Public Property UserDictionaryFormCancelText As String
    Get
    Set
Public Property UserDictionaryFormCancelText As String
    Get
    Set
public:
virtual property String^ UserDictionaryFormCancelText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ UserDictionaryFormCancelText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract UserDictionaryFormCancelText : string with get, set
override UserDictionaryFormCancelText : string with get, set
abstract UserDictionaryFormCancelText : string with get, set
override UserDictionaryFormCancelText : string with get, set
Property Value
String


UserDictionaryFormContentsText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionaryFormContentsText Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionaryEdit ► UserDictionaryFormContentsText
Keyoti RapidSpell Desktop .NET
See IDialogViewUserDictionaryEdit
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionaryFormContentsText { get; set; }
public string UserDictionaryFormContentsText { get; set; }
Public Property UserDictionaryFormContentsText As String
    Get
    Set
Public Property UserDictionaryFormContentsText As String
    Get
    Set
public:
virtual property String^ UserDictionaryFormContentsText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ UserDictionaryFormContentsText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract UserDictionaryFormContentsText : string with get, set
override UserDictionaryFormContentsText : string with get, set
abstract UserDictionaryFormContentsText : string with get, set
override UserDictionaryFormContentsText : string with get, set
Property Value
String


UserDictionaryFormDeleteText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionaryFormDeleteText Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionaryEdit ► UserDictionaryFormDeleteText
Keyoti RapidSpell Desktop .NET
See IDialogViewUserDictionaryEdit
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionaryFormDeleteText { get; set; }
public string UserDictionaryFormDeleteText { get; set; }
Public Property UserDictionaryFormDeleteText As String
    Get
    Set
Public Property UserDictionaryFormDeleteText As String
    Get
    Set
public:
virtual property String^ UserDictionaryFormDeleteText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ UserDictionaryFormDeleteText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract UserDictionaryFormDeleteText : string with get, set
override UserDictionaryFormDeleteText : string with get, set
abstract UserDictionaryFormDeleteText : string with get, set
override UserDictionaryFormDeleteText : string with get, set
Property Value
String


UserDictionaryFormDictionaryLabelText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionaryFormDictionaryLabelText Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionaryEdit ► UserDictionaryFormDictionaryLabelText
Keyoti RapidSpell Desktop .NET
See IDialogViewUserDictionaryEdit
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionaryFormDictionaryLabelText { get; set; }
public string UserDictionaryFormDictionaryLabelText { get; set; }
Public Property UserDictionaryFormDictionaryLabelText As String
    Get
    Set
Public Property UserDictionaryFormDictionaryLabelText As String
    Get
    Set
public:
virtual property String^ UserDictionaryFormDictionaryLabelText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ UserDictionaryFormDictionaryLabelText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract UserDictionaryFormDictionaryLabelText : string with get, set
override UserDictionaryFormDictionaryLabelText : string with get, set
abstract UserDictionaryFormDictionaryLabelText : string with get, set
override UserDictionaryFormDictionaryLabelText : string with get, set
Property Value
String


UserDictionaryFormOKText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionaryFormOKText Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionaryEdit ► UserDictionaryFormOKText
Keyoti RapidSpell Desktop .NET
See IDialogViewUserDictionaryEdit
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionaryFormOKText { get; set; }
public string UserDictionaryFormOKText { get; set; }
Public Property UserDictionaryFormOKText As String
    Get
    Set
Public Property UserDictionaryFormOKText As String
    Get
    Set
public:
virtual property String^ UserDictionaryFormOKText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ UserDictionaryFormOKText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract UserDictionaryFormOKText : string with get, set
override UserDictionaryFormOKText : string with get, set
abstract UserDictionaryFormOKText : string with get, set
override UserDictionaryFormOKText : string with get, set
Property Value
String


UserDictionaryFormTitleText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionaryFormTitleText Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionaryEdit ► UserDictionaryFormTitleText
Keyoti RapidSpell Desktop .NET
See IDialogViewUserDictionaryEdit
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionaryFormTitleText { get; set; }
public string UserDictionaryFormTitleText { get; set; }
Public Property UserDictionaryFormTitleText As String
    Get
    Set
Public Property UserDictionaryFormTitleText As String
    Get
    Set
public:
virtual property String^ UserDictionaryFormTitleText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ UserDictionaryFormTitleText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract UserDictionaryFormTitleText : string with get, set
override UserDictionaryFormTitleText : string with get, set
abstract UserDictionaryFormTitleText : string with get, set
override UserDictionaryFormTitleText : string with get, set
Property Value
String


UserDictionaryFormWordLabelText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionaryFormWordLabelText Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionaryEdit ► UserDictionaryFormWordLabelText
Keyoti RapidSpell Desktop .NET
See IDialogViewUserDictionaryEdit
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionaryFormWordLabelText { get; set; }
public string UserDictionaryFormWordLabelText { get; set; }
Public Property UserDictionaryFormWordLabelText As String
    Get
    Set
Public Property UserDictionaryFormWordLabelText As String
    Get
    Set
public:
virtual property String^ UserDictionaryFormWordLabelText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ UserDictionaryFormWordLabelText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract UserDictionaryFormWordLabelText : string with get, set
override UserDictionaryFormWordLabelText : string with get, set
abstract UserDictionaryFormWordLabelText : string with get, set
override UserDictionaryFormWordLabelText : string with get, set
Property Value
String


WindowsFormsUserDictionarySelect Class

Keyoti RapidSpell Desktop .NET API Docs
WindowsFormsUserDictionarySelect Class
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionarySelect
Keyoti RapidSpell Desktop .NET
Windows forms implementation of IDialogViewUserDictionarySelect
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class WindowsFormsUserDictionarySelect : Form,
    IDialogViewUserDictionarySelect
public class WindowsFormsUserDictionarySelect : Form,
    IDialogViewUserDictionarySelect
Public Class WindowsFormsUserDictionarySelect
    Inherits Form
    Implements IDialogViewUserDictionarySelect
Public Class WindowsFormsUserDictionarySelect
    Inherits Form
    Implements IDialogViewUserDictionarySelect
public ref class WindowsFormsUserDictionarySelect : public Form,
    IDialogViewUserDictionarySelect
public ref class WindowsFormsUserDictionarySelect : public Form,
    IDialogViewUserDictionarySelect
type WindowsFormsUserDictionarySelect =
    class
        inherit Form
        interface IDialogViewUserDictionarySelect
    end
type WindowsFormsUserDictionarySelect =
    class
        inherit Form
        interface IDialogViewUserDictionarySelect
    end
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WindowsFormsUserDictionarySelect()()()() | New
 | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
 | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
 | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
 | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
 | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
 | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
 | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
 | Activate()()()() | Activates the form and gives it focus. (Inherited from Form.)
 | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
 | ActivateMdiChild(Form) | Activates the MDI child of a form. (Inherited from Form.)
 | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
 | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
 | AddFile |
 | AddOwnedForm(Form) | Adds an owned form to this form. (Inherited from Form.)
 | AdjustFormScrollbars(Boolean) | (Inherited from Form.)
 | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
 | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
 | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
 | ApplyAutoScaling()()()() | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
 | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
 | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
 | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
 | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
 | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
 | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
 | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
 | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
 | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
 | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
 | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
 | AutoSizeChanged | (Inherited from Form.)
 | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
 | AutoValidate | (Inherited from Form.)
 | AutoValidateChanged | (Inherited from Form.)
 | BackColor | (Inherited from Form.)
 | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
 | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
 | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
 | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
 | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
 | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
 | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
 | BindingContext | (Inherited from ContainerControl.)
 | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
 | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
 | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
 | BringToFront()()()() | Brings the control to the front of the z-order. (Inherited from Control.)
 | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
 | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
 | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
 | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
 | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
 | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
 | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
 | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
 | CenterToParent()()()() | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
 | CenterToScreen()()()() | Centers the form on the current screen. (Inherited from Form.)
 | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
 | Click | Occurs when the control is clicked. (Inherited from Control.)
 | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
 | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
 | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
 | Close()()()() | Closes the form. (Inherited from Form.)
 | Closed | Occurs when the form is closed. (Inherited from Form.)
 | Closing | Occurs when the form is closing. (Inherited from Form.)
 | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | Contains(Control) | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
 | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
 | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
 | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
 | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
 | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
 | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
 | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
 | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
 | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
 | CreateAccessibilityInstance()()()() | Creates a new accessibility object for the control. (Inherited from Control.)
 | CreateControl()()()() | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
 | CreateControlsInstance()()()() | (Inherited from Form.)
 | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
 | CreateGraphics()()()() | Creates the Graphics for the control. (Inherited from Control.)
 | CreateHandle()()()() | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateParams | (Inherited from Form.)
 | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
 | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
 | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
 | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
 | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
 | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
 | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
 | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
 | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
 | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
 | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
 | DefaultSize | (Inherited from Form.)
 | DefaultUserDictionaryItem |
 | DefWndProc(Message%) | (Inherited from Form.)
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
 | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
 | DestroyHandle()()()() | Destroys the handle associated with the control. (Inherited from Control.)
 | DeviceDpi()()()() | (Inherited from Control.)
 | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
 | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Form.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
 | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
 | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
 | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
 | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
 | DoDragDrop(Object, DragDropEffects) | Begins a drag-and-drop operation. (Inherited from Control.)
 | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
 | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
 | DpiChanged()()()() | (Inherited from Form.)
 | DpiChangedAfterParent()()()() | (Inherited from Control.)
 | DpiChangedBeforeParent()()()() | (Inherited from Control.)
 | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
 | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
 | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
 | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
 | DrawToBitmap(Bitmap, Rectangle) | Supports rendering to the specified bitmap. (Inherited from Control.)
 | EditFile |
 | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
 | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
 | EndInvoke(IAsyncResult) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
 | Enter | Occurs when the control is entered. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | Finalize()()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | FindForm()()()() | Retrieves the form that the control is on. (Inherited from Control.)
 | Focus()()()() | Sets input focus to the control. (Inherited from Control.)
 | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
 | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
 | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
 | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
 | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
 | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
 | FormClosed | Occurs after the form is closed. (Inherited from Form.)
 | FormClosing | Occurs before the form is closed. (Inherited from Form.)
 | GetAccessibilityObjectById(Int32) | Retrieves the specified AccessibleObject. (Inherited from Control.)
 | GetAutoSizeMode()()()() | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
 | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
 | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
 | GetContainerControl()()()() | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetNextControl(Control, Boolean) | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
 | GetPreferredSize(Size) | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
 | GetScaledBounds(Rectangle, SizeF, BoundsSpecified) | (Inherited from Form.)
 | GetScrollState(Int32) | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetStyle(ControlStyles) | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
 | GetTopLevel()()()() | Determines if the control is a top-level control. (Inherited from Control.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
 | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
 | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
 | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
 | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
 | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the control. (Inherited from Control.)
 | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
 | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
 | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
 | Hide()()()() | Conceals the control from the user. (Inherited from Control.)
 | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
 | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
 | Icon | Gets or sets the icon for the form. (Inherited from Form.)
 | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
 | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
 | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | InitLayout()()()() | Called after the control has been added to another container. (Inherited from Control.)
 | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
 | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
 | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
 | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
 | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
 | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
 | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
 | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
 | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
 | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
 | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
 | InvokeGotFocus(Control, EventArgs) | Raises the GotFocus event for the specified control. (Inherited from Control.)
 | InvokeLostFocus(Control, EventArgs) | Raises the LostFocus event for the specified control. (Inherited from Control.)
 | InvokeOnClick(Control, EventArgs) | Raises the Click event for the specified control. (Inherited from Control.)
 | InvokePaint(Control, PaintEventArgs) | Raises the Paint event for the specified control. (Inherited from Control.)
 | InvokePaintBackground(Control, PaintEventArgs) | Raises the PaintBackground event for the specified control. (Inherited from Control.)
 | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
 | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
 | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
 | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
 | IsInputChar(Char) | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
 | IsInputKey(Keys) | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
 | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
 | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
 | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
 | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
 | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
 | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
 | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
 | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
 | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
 | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
 | LayoutMdi(MdiLayout) | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
 | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
 | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
 | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
 | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
 | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
 | LogicalToDeviceUnits(Int32) | (Inherited from Control.)
 | LogicalToDeviceUnits(Size) | (Inherited from Control.)
 | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
 | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
 | Margin | (Inherited from Form.)
 | MarginChanged | (Inherited from Form.)
 | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
 | MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
 | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
 | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
 | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
 | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
 | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
 | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
 | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
 | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
 | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
 | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
 | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
 | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
 | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
 | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
 | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
 | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
 | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
 | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
 | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
 | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
 | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
 | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
 | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
 | Move | Occurs when the control is moved. (Inherited from Control.)
 | Name | Gets or sets the name of the control. (Inherited from Control.)
 | NotifyInvalidate(Rectangle) | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
 | OnActivated(EventArgs) | Raises the Activated event. (Inherited from Form.)
 | OnAutoSizeChanged(EventArgs) | Raises the AutoSizeChanged event. (Inherited from Control.)
 | OnAutoValidateChanged(EventArgs) | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
 | OnBackColorChanged(EventArgs) | Raises the BackColorChanged event. (Inherited from Control.)
 | OnBackgroundImageChanged(EventArgs) | Raises the BackgroundImageChanged event. (Inherited from Form.)
 | OnBackgroundImageLayoutChanged(EventArgs) | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
 | OnBindingContextChanged(EventArgs) | Raises the BindingContextChanged event. (Inherited from Control.)
 | OnCausesValidationChanged(EventArgs) | Raises the CausesValidationChanged event. (Inherited from Control.)
 | OnChangeUICues(UICuesEventArgs) | Raises the ChangeUICues event. (Inherited from Control.)
 | OnClick(EventArgs) | Raises the Click event. (Inherited from Control.)
 | OnClientSizeChanged(EventArgs) | Raises the ClientSizeChanged event. (Inherited from Control.)
 | OnClosed(EventArgs) | Raises the Closed event. (Inherited from Form.)
 | OnClosing(CancelEventArgs) | Raises the Closing event. (Inherited from Form.)
 | OnContextMenuChanged(EventArgs) | Raises the ContextMenuChanged event. (Inherited from Control.)
 | OnContextMenuStripChanged(EventArgs) | Raises the ContextMenuStripChanged event. (Inherited from Control.)
 | OnControlAdded(ControlEventArgs) | Raises the ControlAdded event. (Inherited from Control.)
 | OnControlRemoved(ControlEventArgs) | Raises the ControlRemoved event. (Inherited from Control.)
 | OnCreateControl()()()() | Raises the CreateControl event. (Inherited from Form.)
 | OnCursorChanged(EventArgs) | Raises the CursorChanged event. (Inherited from Control.)
 | OnDeactivate(EventArgs) | Raises the Deactivate event. (Inherited from Form.)
 | OnDockChanged(EventArgs) | Raises the DockChanged event. (Inherited from Control.)
 | OnDoubleClick(EventArgs) | Raises the DoubleClick event. (Inherited from Control.)
 | OnDpiChanged(DpiChangedEventArgs) | (Inherited from Form.)
 | OnDpiChangedAfterParent(EventArgs) | (Inherited from Control.)
 | OnDpiChangedBeforeParent(EventArgs) | (Inherited from Control.)
 | OnDragDrop(DragEventArgs) | Raises the DragDrop event. (Inherited from Control.)
 | OnDragEnter(DragEventArgs) | Raises the DragEnter event. (Inherited from Control.)
 | OnDragLeave(EventArgs) | Raises the DragLeave event. (Inherited from Control.)
 | OnDragOver(DragEventArgs) | Raises the DragOver event. (Inherited from Control.)
 | OnEnabledChanged(EventArgs) | (Inherited from Form.)
 | OnEnter(EventArgs) | Raises the Enter event. (Inherited from Form.)
 | OnFontChanged(EventArgs) | (Inherited from Form.)
 | OnForeColorChanged(EventArgs) | Raises the ForeColorChanged event. (Inherited from Control.)
 | OnFormClosed(FormClosedEventArgs) | Raises the FormClosed event. (Inherited from Form.)
 | OnFormClosing(FormClosingEventArgs) | Raises the FormClosing event. (Inherited from Form.)
 | OnGetDpiScaledSize(Int32, Int32, Size%) | (Inherited from Form.)
 | OnGiveFeedback(GiveFeedbackEventArgs) | Raises the GiveFeedback event. (Inherited from Control.)
 | OnGotFocus(EventArgs) | Raises the GotFocus event. (Inherited from Control.)
 | OnHandleCreated(EventArgs) | (Inherited from Form.)
 | OnHandleDestroyed(EventArgs) | (Inherited from Form.)
 | OnHelpButtonClicked(CancelEventArgs) | Raises the HelpButtonClicked event. (Inherited from Form.)
 | OnHelpRequested(HelpEventArgs) | Raises the HelpRequested event. (Inherited from Control.)
 | OnImeModeChanged(EventArgs) | Raises the ImeModeChanged event. (Inherited from Control.)
 | OnInputLanguageChanged(InputLanguageChangedEventArgs) | Raises the InputLanguageChanged event. (Inherited from Form.)
 | OnInputLanguageChanging(InputLanguageChangingEventArgs) | Raises the InputLanguageChanging event. (Inherited from Form.)
 | OnInvalidated(InvalidateEventArgs) | Raises the Invalidated event. (Inherited from Control.)
 | OnKeyDown(KeyEventArgs) | Raises the KeyDown event. (Inherited from Control.)
 | OnKeyPress(KeyPressEventArgs) | Raises the KeyPress event. (Inherited from Control.)
 | OnKeyUp(KeyEventArgs) | Raises the KeyUp event. (Inherited from Control.)
 | OnLayout(LayoutEventArgs) | (Inherited from Form.)
 | OnLeave(EventArgs) | Raises the Leave event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Form.)
 | OnLocationChanged(EventArgs) | Raises the LocationChanged event. (Inherited from Control.)
 | OnLostFocus(EventArgs) | Raises the LostFocus event. (Inherited from Control.)
 | OnMarginChanged(EventArgs) | Raises the MarginChanged event. (Inherited from Control.)
 | OnMaximizedBoundsChanged(EventArgs) | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
 | OnMaximumSizeChanged(EventArgs) | Raises the MaximumSizeChanged event. (Inherited from Form.)
 | OnMdiChildActivate(EventArgs) | Raises the MdiChildActivate event. (Inherited from Form.)
 | OnMenuComplete(EventArgs) | Raises the MenuComplete event. (Inherited from Form.)
 | OnMenuStart(EventArgs) | Raises the MenuStart event. (Inherited from Form.)
 | OnMinimumSizeChanged(EventArgs) | Raises the MinimumSizeChanged event. (Inherited from Form.)
 | OnMouseCaptureChanged(EventArgs) | Raises the MouseCaptureChanged event. (Inherited from Control.)
 | OnMouseClick(MouseEventArgs) | Raises the MouseClick event. (Inherited from Control.)
 | OnMouseDoubleClick(MouseEventArgs) | Raises the MouseDoubleClick event. (Inherited from Control.)
 | OnMouseDown(MouseEventArgs) | Raises the MouseDown event. (Inherited from Control.)
 | OnMouseEnter(EventArgs) | Raises the MouseEnter event. (Inherited from Control.)
 | OnMouseHover(EventArgs) | Raises the MouseHover event. (Inherited from Control.)
 | OnMouseLeave(EventArgs) | Raises the MouseLeave event. (Inherited from Control.)
 | OnMouseMove(MouseEventArgs) | Raises the MouseMove event. (Inherited from Control.)
 | OnMouseUp(MouseEventArgs) | Raises the MouseUp event. (Inherited from Control.)
 | OnMouseWheel(MouseEventArgs) | Raises the MouseWheel event. (Inherited from ScrollableControl.)
 | OnMove(EventArgs) | Raises the Move event. (Inherited from Control.)
 | OnNotifyMessage(Message) | Notifies the control of Windows messages. (Inherited from Control.)
 | OnPaddingChanged(EventArgs) | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
 | OnPaint(PaintEventArgs) | (Inherited from Form.)
 | OnPaintBackground(PaintEventArgs) | Paints the background of the control. (Inherited from ScrollableControl.)
 | OnParentBackColorChanged(EventArgs) | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
 | OnParentBackgroundImageChanged(EventArgs) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
 | OnParentBindingContextChanged(EventArgs) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
 | OnParentChanged(EventArgs) | (Inherited from ContainerControl.)
 | OnParentCursorChanged(EventArgs) | Raises the CursorChanged event. (Inherited from Control.)
 | OnParentEnabledChanged(EventArgs) | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
 | OnParentFontChanged(EventArgs) | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
 | OnParentForeColorChanged(EventArgs) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
 | OnParentRightToLeftChanged(EventArgs) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
 | OnParentVisibleChanged(EventArgs) | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
 | OnPreviewKeyDown(PreviewKeyDownEventArgs) | Raises the PreviewKeyDown event. (Inherited from Control.)
 | OnPrint(PaintEventArgs) | Raises the Paint event. (Inherited from Control.)
 | OnQueryContinueDrag(QueryContinueDragEventArgs) | Raises the QueryContinueDrag event. (Inherited from Control.)
 | OnRegionChanged(EventArgs) | Raises the RegionChanged event. (Inherited from Control.)
 | OnResize(EventArgs) | (Inherited from Form.)
 | OnResizeBegin(EventArgs) | Raises the ResizeBegin event. (Inherited from Form.)
 | OnResizeEnd(EventArgs) | Raises the ResizeEnd event. (Inherited from Form.)
 | OnRightToLeftChanged(EventArgs) | (Inherited from ScrollableControl.)
 | OnRightToLeftLayoutChanged(EventArgs) | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
 | OnScroll(ScrollEventArgs) | Raises the Scroll event. (Inherited from ScrollableControl.)
 | OnShown(EventArgs) | Raises the Shown event. (Inherited from Form.)
 | OnSizeChanged(EventArgs) | Raises the SizeChanged event. (Inherited from Control.)
 | OnStyleChanged(EventArgs) | (Inherited from Form.)
 | OnSystemColorsChanged(EventArgs) | Raises the SystemColorsChanged event. (Inherited from Control.)
 | OnTabIndexChanged(EventArgs) | Raises the TabIndexChanged event. (Inherited from Control.)
 | OnTabStopChanged(EventArgs) | Raises the TabStopChanged event. (Inherited from Control.)
 | OnTextChanged(EventArgs) | (Inherited from Form.)
 | OnValidated(EventArgs) | Raises the Validated event. (Inherited from Control.)
 | OnValidating(CancelEventArgs) | Raises the Validating event. (Inherited from Control.)
 | OnVisibleChanged(EventArgs) | Raises the VisibleChanged event. (Inherited from Form.)
 | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
 | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
 | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
 | Padding | Gets or sets padding within the control. (Inherited from Control.)
 | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
 | Paint | Occurs when the control is redrawn. (Inherited from Control.)
 | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
 | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
 | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
 | PerformAutoScale()()()() | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
 | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
 | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
 | PointToClient(Point) | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
 | PointToScreen(Point) | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
 | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
 | PreProcessControlMessage(Message%) | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
 | PreProcessMessage(Message%) | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
 | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
 | ProcessCmdKey(Message%, Keys) | Processes a command key. (Inherited from Form.)
 | ProcessDialogChar(Char) | (Inherited from Form.)
 | ProcessDialogKey(Keys) | Processes a dialog box key. (Inherited from Form.)
 | ProcessKeyEventArgs(Message%) | Processes a key message and generates the appropriate control events. (Inherited from Control.)
 | ProcessKeyMessage(Message%) | Processes a keyboard message. (Inherited from Control.)
 | ProcessKeyPreview(Message%) | (Inherited from Form.)
 | ProcessMnemonic(Char) | (Inherited from Form.)
 | ProcessTabKey(Boolean) | (Inherited from Form.)
 | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
 | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
 | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
 | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
 | RaiseDragEvent(Object, DragEventArgs) | Raises the appropriate drag event. (Inherited from Control.)
 | RaiseKeyEvent(Object, KeyEventArgs) | Raises the appropriate key event. (Inherited from Control.)
 | RaiseMouseEvent(Object, MouseEventArgs) | Raises the appropriate mouse event. (Inherited from Control.)
 | RaisePaintEvent(Object, PaintEventArgs) | Raises the appropriate paint event. (Inherited from Control.)
 | RecreateHandle()()()() | Forces the re-creation of the handle for the control. (Inherited from Control.)
 | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
 | RectangleToClient(Rectangle) | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
 | RectangleToScreen(Rectangle) | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
 | Refresh()()()() | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
 | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
 | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
 | RemoveFile |
 | RemoveOwnedForm(Form) | Removes an owned form from this form. (Inherited from Form.)
 | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
 | RescaleConstantsForDpi(Int32, Int32) | (Inherited from Control.)
 | ResetBackColor()()()() | Resets the BackColor property to its default value. (Inherited from Control.)
 | ResetBindings()()()() | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
 | ResetCursor()()()() | Resets the Cursor property to its default value. (Inherited from Control.)
 | ResetFont()()()() | Resets the Font property to its default value. (Inherited from Control.)
 | ResetForeColor()()()() | Resets the ForeColor property to its default value. (Inherited from Control.)
 | ResetImeMode()()()() | Resets the ImeMode property to its default value. (Inherited from Control.)
 | ResetMouseEventArgs()()()() | Resets the control to handle the MouseLeave event. (Inherited from Control.)
 | ResetRightToLeft()()()() | Resets the RightToLeft property to its default value. (Inherited from Control.)
 | ResetText()()()() | Resets the Text property to its default value. (Inherited from Control.)
 | Resize | Occurs when the control is resized. (Inherited from Control.)
 | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
 | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
 | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
 | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
 | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
 | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
 | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
 | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
 | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
 | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
 | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
 | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateContent(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateHorizontal(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateLeftRight(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
 | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
 | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
 | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
 | ScaleBitmapLogicalToDevice(Bitmap%) | (Inherited from Control.)
 | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
 | ScaleControl(SizeF, BoundsSpecified) | (Inherited from Form.)
 | ScaleCore(Single, Single) | Performs scaling of the form. (Inherited from Form.)
 | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
 | ScrollControlIntoView(Control) | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
 | ScrollToControl(Control) | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
 | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
 | Select()()()() | Activates the control. (Inherited from Control.)
 | SelectNextControl(Control, Boolean, Boolean, Boolean, Boolean) | Activates the next control. (Inherited from Control.)
 | SendToBack()()()() | Sends the control to the back of the z-order. (Inherited from Control.)
 | SetAutoScrollMargin(Int32, Int32) | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
 | SetAutoSizeMode(AutoSizeMode) | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
 | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
 | SetBoundsCore(Int32, Int32, Int32, Int32, BoundsSpecified) | (Inherited from Form.)
 | SetClientSizeCore(Int32, Int32) | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
 | SetDesktopBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
 | SetDesktopLocation(Int32, Int32) | Sets the location of the form in desktop coordinates. (Inherited from Form.)
 | SetDisplayRectLocation(Int32, Int32) | Positions the display window to the specified value. (Inherited from ScrollableControl.)
 | SetScrollState(Int32, Boolean) | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
 | SetStyle(ControlStyles, Boolean) | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
 | SetTopLevel(Boolean) | Sets the control as the top-level control. (Inherited from Control.)
 | SetVisibleCore(Boolean) | (Inherited from Form.)
 | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
 | Show()()()() | Displays the control to the user. (Inherited from Control.)
 | ShowDialog(Object, List<(Of <<'(String>)>>), String) | See IDialogViewUserDictionaryEdit
 | ShowDialog()()()() | Shows the form as a modal dialog box. (Inherited from Form.)
 | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
 | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
 | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
 | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
 | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
 | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
 | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
 | Site | Gets or sets the site of the control. (Inherited from Control.)
 | Size | Gets or sets the size of the form. (Inherited from Form.)
 | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
 | SizeFromClientSize(Size) | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
 | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
 | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
 | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
 | SuspendLayout()()()() | Temporarily suspends the layout logic for the control. (Inherited from Control.)
 | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
 | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
 | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
 | TabStop | (Inherited from Form.)
 | TabStopChanged | (Inherited from Form.)
 | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
 | Text | (Inherited from Form.)
 | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
 | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
 | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
 | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
 | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
 | ToString()()()() | Gets a string representing the current instance of the form. (Inherited from Form.)
 | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
 | Update()()()() | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
 | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
 | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
 | UpdateDefaultButton()()()() | Updates which button is the default button. (Inherited from Form.)
 | UpdateStyles()()()() | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
 | UpdateZOrder()()()() | Updates the control in its parent's z-order. (Inherited from Control.)
 | UserDictionaryFormSelectTitleText |
 | UserDictionarySelectFormAddText |
 | UserDictionarySelectFormCancelText |
 | UserDictionarySelectFormChangeDefaultText |
 | UserDictionarySelectFormEditText |
 | UserDictionarySelectFormGroupBoxTitleText |
 | UserDictionarySelectFormNewText |
 | UserDictionarySelectFormOkText |
 | UserDictionarySelectFormRemoveText |
 | UserDictionarySelectFormTitleText |
 | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
 | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
 | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
 | ValidateChildren()()()() | (Inherited from Form.)
 | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
 | Validated | Occurs when the control is finished validating. (Inherited from Control.)
 | Validating | Occurs when the control is validating. (Inherited from Control.)
 | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
 | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
 | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
 | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
 | Width | Gets or sets the width of the control. (Inherited from Control.)
 | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
 | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
 | WndProc(Message%) | (Inherited from Form.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | Control
 |  |  |  | ScrollableControl
 |  |  |  |  | ContainerControl
 |  |  |  |  |  | Form
 |  |  |  |  |  |  | WindowsFormsUserDictionarySelect


WindowsFormsUserDictionarySelect Constructor

Keyoti RapidSpell Desktop .NET API Docs
WindowsFormsUserDictionarySelect Constructor
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionarySelect ► WindowsFormsUserDictionarySelect()()()()
Keyoti RapidSpell Desktop .NET
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public WindowsFormsUserDictionarySelect()
public WindowsFormsUserDictionarySelect()
Public Sub New
Public Sub New
public:
WindowsFormsUserDictionarySelect()
public:
WindowsFormsUserDictionarySelect()
new : unit -> WindowsFormsUserDictionarySelect
new : unit -> WindowsFormsUserDictionarySelect


AddFile Event

Keyoti RapidSpell Desktop .NET API Docs
AddFile Event
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionarySelect ► AddFile
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event UserDictionaryFormEventHandler AddFile
public event UserDictionaryFormEventHandler AddFile
Public Event AddFile As UserDictionaryFormEventHandler
Public Event AddFile As UserDictionaryFormEventHandler
public:
virtual  event UserDictionaryFormEventHandler^ AddFile {
    void add (UserDictionaryFormEventHandler^ value);
    void remove (UserDictionaryFormEventHandler^ value);
}
public:
virtual  event UserDictionaryFormEventHandler^ AddFile {
    void add (UserDictionaryFormEventHandler^ value);
    void remove (UserDictionaryFormEventHandler^ value);
}
abstract AddFile : IEvent<UserDictionaryFormEventHandler,
    UserDictionaryFormEventArgs>
override AddFile : IEvent<UserDictionaryFormEventHandler,
    UserDictionaryFormEventArgs>
abstract AddFile : IEvent<UserDictionaryFormEventHandler,
    UserDictionaryFormEventArgs>
override AddFile : IEvent<UserDictionaryFormEventHandler,
    UserDictionaryFormEventArgs>
Value
UserDictionaryFormEventHandler


DefaultUserDictionaryItem Property

Keyoti RapidSpell Desktop .NET API Docs
DefaultUserDictionaryItem Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionarySelect ► DefaultUserDictionaryItem
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string DefaultUserDictionaryItem { get; }
public string DefaultUserDictionaryItem { get; }
Public ReadOnly Property DefaultUserDictionaryItem As String
    Get
Public ReadOnly Property DefaultUserDictionaryItem As String
    Get
public:
virtual property String^ DefaultUserDictionaryItem {
    String^ get () sealed;
}
public:
virtual property String^ DefaultUserDictionaryItem {
    String^ get () sealed;
}
abstract DefaultUserDictionaryItem : string with get
override DefaultUserDictionaryItem : string with get
abstract DefaultUserDictionaryItem : string with get
override DefaultUserDictionaryItem : string with get
Property Value
String


Dispose Method (disposing)

Keyoti RapidSpell Desktop .NET API Docs
Dispose Method (disposing)
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionarySelect ► Dispose(Boolean)
Keyoti RapidSpell Desktop .NET
Clean up any resources being used.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
Parameters
disposing (Boolean)
true if managed resources should be disposed; otherwise, false.


EditFile Event

Keyoti RapidSpell Desktop .NET API Docs
EditFile Event
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionarySelect ► EditFile
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event UserDictionaryFormEventHandler EditFile
public event UserDictionaryFormEventHandler EditFile
Public Event EditFile As UserDictionaryFormEventHandler
Public Event EditFile As UserDictionaryFormEventHandler
public:
virtual  event UserDictionaryFormEventHandler^ EditFile {
    void add (UserDictionaryFormEventHandler^ value);
    void remove (UserDictionaryFormEventHandler^ value);
}
public:
virtual  event UserDictionaryFormEventHandler^ EditFile {
    void add (UserDictionaryFormEventHandler^ value);
    void remove (UserDictionaryFormEventHandler^ value);
}
abstract EditFile : IEvent<UserDictionaryFormEventHandler,
    UserDictionaryFormEventArgs>
override EditFile : IEvent<UserDictionaryFormEventHandler,
    UserDictionaryFormEventArgs>
abstract EditFile : IEvent<UserDictionaryFormEventHandler,
    UserDictionaryFormEventArgs>
override EditFile : IEvent<UserDictionaryFormEventHandler,
    UserDictionaryFormEventArgs>
Value
UserDictionaryFormEventHandler


RemoveFile Event

Keyoti RapidSpell Desktop .NET API Docs
RemoveFile Event
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionarySelect ► RemoveFile
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event UserDictionaryFormEventHandler RemoveFile
public event UserDictionaryFormEventHandler RemoveFile
Public Event RemoveFile As UserDictionaryFormEventHandler
Public Event RemoveFile As UserDictionaryFormEventHandler
public:
virtual  event UserDictionaryFormEventHandler^ RemoveFile {
    void add (UserDictionaryFormEventHandler^ value);
    void remove (UserDictionaryFormEventHandler^ value);
}
public:
virtual  event UserDictionaryFormEventHandler^ RemoveFile {
    void add (UserDictionaryFormEventHandler^ value);
    void remove (UserDictionaryFormEventHandler^ value);
}
abstract RemoveFile : IEvent<UserDictionaryFormEventHandler,
    UserDictionaryFormEventArgs>
override RemoveFile : IEvent<UserDictionaryFormEventHandler,
    UserDictionaryFormEventArgs>
abstract RemoveFile : IEvent<UserDictionaryFormEventHandler,
    UserDictionaryFormEventArgs>
override RemoveFile : IEvent<UserDictionaryFormEventHandler,
    UserDictionaryFormEventArgs>
Value
UserDictionaryFormEventHandler


ShowDialog Method (owner, userDictionaryList, defaultUserDictionaryItem)

Keyoti RapidSpell Desktop .NET API Docs
ShowDialog Method (owner, userDictionaryList, defaultUserDictionaryItem)
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionarySelect ► ShowDialog(Object, List<(Of <<'(String>)>>), String)
Keyoti RapidSpell Desktop .NET
See IDialogViewUserDictionaryEdit
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public DialogResult ShowDialog(
    Object owner,
    List<string> userDictionaryList,
    string defaultUserDictionaryItem
)
public DialogResult ShowDialog(
    Object owner,
    List<string> userDictionaryList,
    string defaultUserDictionaryItem
)
Public Function ShowDialog (
    owner As Object,
    userDictionaryList As List(Of String),
    defaultUserDictionaryItem As String
) As DialogResult
Public Function ShowDialog (
    owner As Object,
    userDictionaryList As List(Of String),
    defaultUserDictionaryItem As String
) As DialogResult
public:
virtual DialogResult ShowDialog(
    Object^ owner,
    List<String^>^ userDictionaryList,
    String^ defaultUserDictionaryItem
) sealed
public:
virtual DialogResult ShowDialog(
    Object^ owner,
    List<String^>^ userDictionaryList,
    String^ defaultUserDictionaryItem
) sealed
abstract ShowDialog :
        owner : Object *
        userDictionaryList : List<string> *
        defaultUserDictionaryItem : string -> DialogResult
override ShowDialog :
        owner : Object *
        userDictionaryList : List<string> *
        defaultUserDictionaryItem : string -> DialogResult
abstract ShowDialog :
        owner : Object *
        userDictionaryList : List<string> *
        defaultUserDictionaryItem : string -> DialogResult
override ShowDialog :
        owner : Object *
        userDictionaryList : List<string> *
        defaultUserDictionaryItem : string -> DialogResult
Parameters
owner (Object)
userDictionaryList (List <(Of <(<' String >)>)>)
defaultUserDictionaryItem (String)
Return Value
DialogResult


UserDictionaryFormSelectTitleText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionaryFormSelectTitleText Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionarySelect ► UserDictionaryFormSelectTitleText
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionaryFormSelectTitleText { get; set; }
public string UserDictionaryFormSelectTitleText { get; set; }
Public Property UserDictionaryFormSelectTitleText As String
    Get
    Set
Public Property UserDictionaryFormSelectTitleText As String
    Get
    Set
public:
property String^ UserDictionaryFormSelectTitleText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserDictionaryFormSelectTitleText {
    String^ get ();
    void set (String^ value);
}
member UserDictionaryFormSelectTitleText : string with get, set

member UserDictionaryFormSelectTitleText : string with get, set
Property Value
String


UserDictionarySelectFormAddText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionarySelectFormAddText Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionarySelect ► UserDictionarySelectFormAddText
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionarySelectFormAddText { get; set; }
public string UserDictionarySelectFormAddText { get; set; }
Public Property UserDictionarySelectFormAddText As String
    Get
    Set
Public Property UserDictionarySelectFormAddText As String
    Get
    Set
public:
virtual property String^ UserDictionarySelectFormAddText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ UserDictionarySelectFormAddText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract UserDictionarySelectFormAddText : string with get, set
override UserDictionarySelectFormAddText : string with get, set
abstract UserDictionarySelectFormAddText : string with get, set
override UserDictionarySelectFormAddText : string with get, set
Property Value
String


UserDictionarySelectFormCancelText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionarySelectFormCancelText Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionarySelect ► UserDictionarySelectFormCancelText
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionarySelectFormCancelText { get; set; }
public string UserDictionarySelectFormCancelText { get; set; }
Public Property UserDictionarySelectFormCancelText As String
    Get
    Set
Public Property UserDictionarySelectFormCancelText As String
    Get
    Set
public:
virtual property String^ UserDictionarySelectFormCancelText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ UserDictionarySelectFormCancelText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract UserDictionarySelectFormCancelText : string with get, set
override UserDictionarySelectFormCancelText : string with get, set
abstract UserDictionarySelectFormCancelText : string with get, set
override UserDictionarySelectFormCancelText : string with get, set
Property Value
String


UserDictionarySelectFormChangeDefaultText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionarySelectFormChangeDefaultText Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionarySelect ► UserDictionarySelectFormChangeDefaultText
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionarySelectFormChangeDefaultText { get; set; }
public string UserDictionarySelectFormChangeDefaultText { get; set; }
Public Property UserDictionarySelectFormChangeDefaultText As String
    Get
    Set
Public Property UserDictionarySelectFormChangeDefaultText As String
    Get
    Set
public:
virtual property String^ UserDictionarySelectFormChangeDefaultText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ UserDictionarySelectFormChangeDefaultText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract UserDictionarySelectFormChangeDefaultText : string with get, set
override UserDictionarySelectFormChangeDefaultText : string with get, set
abstract UserDictionarySelectFormChangeDefaultText : string with get, set
override UserDictionarySelectFormChangeDefaultText : string with get, set
Property Value
String


UserDictionarySelectFormEditText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionarySelectFormEditText Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionarySelect ► UserDictionarySelectFormEditText
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionarySelectFormEditText { get; set; }
public string UserDictionarySelectFormEditText { get; set; }
Public Property UserDictionarySelectFormEditText As String
    Get
    Set
Public Property UserDictionarySelectFormEditText As String
    Get
    Set
public:
virtual property String^ UserDictionarySelectFormEditText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ UserDictionarySelectFormEditText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract UserDictionarySelectFormEditText : string with get, set
override UserDictionarySelectFormEditText : string with get, set
abstract UserDictionarySelectFormEditText : string with get, set
override UserDictionarySelectFormEditText : string with get, set
Property Value
String


UserDictionarySelectFormGroupBoxTitleText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionarySelectFormGroupBoxTitleText Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionarySelect ► UserDictionarySelectFormGroupBoxTitleText
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionarySelectFormGroupBoxTitleText { get; set; }
public string UserDictionarySelectFormGroupBoxTitleText { get; set; }
Public Property UserDictionarySelectFormGroupBoxTitleText As String
    Get
    Set
Public Property UserDictionarySelectFormGroupBoxTitleText As String
    Get
    Set
public:
virtual property String^ UserDictionarySelectFormGroupBoxTitleText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ UserDictionarySelectFormGroupBoxTitleText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract UserDictionarySelectFormGroupBoxTitleText : string with get, set
override UserDictionarySelectFormGroupBoxTitleText : string with get, set
abstract UserDictionarySelectFormGroupBoxTitleText : string with get, set
override UserDictionarySelectFormGroupBoxTitleText : string with get, set
Property Value
String


UserDictionarySelectFormNewText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionarySelectFormNewText Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionarySelect ► UserDictionarySelectFormNewText
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionarySelectFormNewText { get; set; }
public string UserDictionarySelectFormNewText { get; set; }
Public Property UserDictionarySelectFormNewText As String
    Get
    Set
Public Property UserDictionarySelectFormNewText As String
    Get
    Set
public:
virtual property String^ UserDictionarySelectFormNewText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ UserDictionarySelectFormNewText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract UserDictionarySelectFormNewText : string with get, set
override UserDictionarySelectFormNewText : string with get, set
abstract UserDictionarySelectFormNewText : string with get, set
override UserDictionarySelectFormNewText : string with get, set
Property Value
String


UserDictionarySelectFormOkText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionarySelectFormOkText Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionarySelect ► UserDictionarySelectFormOkText
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionarySelectFormOkText { get; set; }
public string UserDictionarySelectFormOkText { get; set; }
Public Property UserDictionarySelectFormOkText As String
    Get
    Set
Public Property UserDictionarySelectFormOkText As String
    Get
    Set
public:
virtual property String^ UserDictionarySelectFormOkText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ UserDictionarySelectFormOkText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract UserDictionarySelectFormOkText : string with get, set
override UserDictionarySelectFormOkText : string with get, set
abstract UserDictionarySelectFormOkText : string with get, set
override UserDictionarySelectFormOkText : string with get, set
Property Value
String


UserDictionarySelectFormRemoveText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionarySelectFormRemoveText Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionarySelect ► UserDictionarySelectFormRemoveText
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionarySelectFormRemoveText { get; set; }
public string UserDictionarySelectFormRemoveText { get; set; }
Public Property UserDictionarySelectFormRemoveText As String
    Get
    Set
Public Property UserDictionarySelectFormRemoveText As String
    Get
    Set
public:
virtual property String^ UserDictionarySelectFormRemoveText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ UserDictionarySelectFormRemoveText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract UserDictionarySelectFormRemoveText : string with get, set
override UserDictionarySelectFormRemoveText : string with get, set
abstract UserDictionarySelectFormRemoveText : string with get, set
override UserDictionarySelectFormRemoveText : string with get, set
Property Value
String


UserDictionarySelectFormTitleText Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionarySelectFormTitleText Property
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionarySelect ► UserDictionarySelectFormTitleText
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionarySelectFormTitleText { get; set; }
public string UserDictionarySelectFormTitleText { get; set; }
Public Property UserDictionarySelectFormTitleText As String
    Get
    Set
Public Property UserDictionarySelectFormTitleText As String
    Get
    Set
public:
virtual property String^ UserDictionarySelectFormTitleText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ UserDictionarySelectFormTitleText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract UserDictionarySelectFormTitleText : string with get, set
override UserDictionarySelectFormTitleText : string with get, set
abstract UserDictionarySelectFormTitleText : string with get, set
override UserDictionarySelectFormTitleText : string with get, set
Property Value
String


Keyoti.RapidSpell.Event Namespace

Keyoti RapidSpell Desktop .NET API Docs
Keyoti.RapidSpell.Event Namespace
API ► Keyoti.RapidSpell.Event
Keyoti RapidSpell Desktop .NET
The namespace for events.

Events and delegates

Types
All Types Classes Delegates
Icon | Type | Description
 | ChangeWordEventArgs | Holds data for the ChangeWord event.
 | CreateDialogViewEventArgs | Event args for create IDialogView event
 | CreateDialogViewEventHandler | EventHandler delegate
 | CreateDialogViewOptionsEventArgs | Event args for create IDialogViewOptions event
 | CreateDialogViewOptionsEventHandler | EventHandler delegate
 | CreateDialogViewUserDictionaryEditEventArgs | Event args for create IDialogViewUserDictionaryEdit event
 | CreateDialogViewUserDictionaryEditEventHandler | EventHandler delegate
 | CreateDialogViewUserDictionarySelectEventArgs | Event args for create IDialogViewOptions event
 | CreateDialogViewUserDictionarySelectEventHandler | EventHandler delegate
 | CreateUserInterfaceFormPresenterEventArgs | Event args for create presenter event
 | CreateUserInterfaceFormPresenterEventHandler | EventHandler delegate
 | FoundSpellingErrorEventArgs | Event args for found error event
 | FoundSpellingErrorEventHandler | EventHandler delegate
 | SpellCheckEventArgs | Args for the events fired when RapidSpellGUI,RapidSpellDialog or RapidSpellAYT starts or stops.
 | SpellCheckEventHandler | Spell check event handler delegate.
 | SpellContextMenuEventArgs | Args for the events fired when the spell checkers context menu is requested.
 | TextBoxSpellCheckEventArgs | Args for the events fired when spell checking multiple text boxes.
 | UserQueryEventArgs | Event args for user query event
 | UserQueryEventHandler | EventHandler delegate
 | WordsEnteredEventArgs | Args for the events fired when words are entered into the text box.
 | WordsEnteredEventHandler | Handler delegate


ChangeWordEventArgs Class

Keyoti RapidSpell Desktop .NET API Docs
ChangeWordEventArgs Class
API ► Keyoti.RapidSpell.Event ► ChangeWordEventArgs
Keyoti RapidSpell Desktop .NET
Holds data for the ChangeWord event.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class ChangeWordEventArgs : EventArgs
public class ChangeWordEventArgs : EventArgs
Public Class ChangeWordEventArgs
    Inherits EventArgs
Public Class ChangeWordEventArgs
    Inherits EventArgs
public ref class ChangeWordEventArgs : public EventArgs
public ref class ChangeWordEventArgs : public EventArgs
type ChangeWordEventArgs =
    class
        inherit EventArgs
    end
type ChangeWordEventArgs =
    class
        inherit EventArgs
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ChangeWordEventArgs(String, String, Int32) | Creates a new ChangeWordEventArgs
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | Index | The index of the word in the text
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewWord | The new word
 | OldWord | The word being replaced
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | ChangeWordEventArgs


ChangeWordEventArgs Constructor (oldWord, newWord, index)

Keyoti RapidSpell Desktop .NET API Docs
ChangeWordEventArgs Constructor (oldWord, newWord, index)
API ► Keyoti.RapidSpell.Event ► ChangeWordEventArgs ► ChangeWordEventArgs(String, String, Int32)
Keyoti RapidSpell Desktop .NET
Creates a new ChangeWordEventArgs
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ChangeWordEventArgs(
    string oldWord,
    string newWord,
    int index
)
public ChangeWordEventArgs(
    string oldWord,
    string newWord,
    int index
)
Public Sub New (
    oldWord As String,
    newWord As String,
    index As Integer
)
Public Sub New (
    oldWord As String,
    newWord As String,
    index As Integer
)
public:
ChangeWordEventArgs(
    String^ oldWord,
    String^ newWord,
    int index
)
public:
ChangeWordEventArgs(
    String^ oldWord,
    String^ newWord,
    int index
)
new :
        oldWord : string *
        newWord : string *
        index : int -> ChangeWordEventArgs
new :
        oldWord : string *
        newWord : string *
        index : int -> ChangeWordEventArgs
Parameters
oldWord (String)
newWord (String)
index (Int32)


Index Property

Keyoti RapidSpell Desktop .NET API Docs
Index Property
API ► Keyoti.RapidSpell.Event ► ChangeWordEventArgs ► Index
Keyoti RapidSpell Desktop .NET
The index of the word in the text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int Index { get; }
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get
Public ReadOnly Property Index As Integer
    Get
public:
property int Index {
    int get ();
}
public:
property int Index {
    int get ();
}
member Index : int with get

member Index : int with get
Property Value
Int32


NewWord Property

Keyoti RapidSpell Desktop .NET API Docs
NewWord Property
API ► Keyoti.RapidSpell.Event ► ChangeWordEventArgs ► NewWord
Keyoti RapidSpell Desktop .NET
The new word
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string NewWord { get; }
public string NewWord { get; }
Public ReadOnly Property NewWord As String
    Get
Public ReadOnly Property NewWord As String
    Get
public:
property String^ NewWord {
    String^ get ();
}
public:
property String^ NewWord {
    String^ get ();
}
member NewWord : string with get

member NewWord : string with get
Property Value
String


OldWord Property

Keyoti RapidSpell Desktop .NET API Docs
OldWord Property
API ► Keyoti.RapidSpell.Event ► ChangeWordEventArgs ► OldWord
Keyoti RapidSpell Desktop .NET
The word being replaced
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OldWord { get; }
public string OldWord { get; }
Public ReadOnly Property OldWord As String
    Get
Public ReadOnly Property OldWord As String
    Get
public:
property String^ OldWord {
    String^ get ();
}
public:
property String^ OldWord {
    String^ get ();
}
member OldWord : string with get

member OldWord : string with get
Property Value
String


CreateDialogViewEventArgs Class

Keyoti RapidSpell Desktop .NET API Docs
CreateDialogViewEventArgs Class
API ► Keyoti.RapidSpell.Event ► CreateDialogViewEventArgs
Keyoti RapidSpell Desktop .NET
Event args for create IDialogView event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class CreateDialogViewEventArgs : EventArgs
public class CreateDialogViewEventArgs : EventArgs
Public Class CreateDialogViewEventArgs
    Inherits EventArgs
Public Class CreateDialogViewEventArgs
    Inherits EventArgs
public ref class CreateDialogViewEventArgs : public EventArgs
public ref class CreateDialogViewEventArgs : public EventArgs
type CreateDialogViewEventArgs =
    class
        inherit EventArgs
    end
type CreateDialogViewEventArgs =
    class
        inherit EventArgs
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CreateDialogViewEventArgs(IDialogView) | New
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewView | The new view to use
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | CreateDialogViewEventArgs


CreateDialogViewEventArgs Constructor (newView)

Keyoti RapidSpell Desktop .NET API Docs
CreateDialogViewEventArgs Constructor (newView)
API ► Keyoti.RapidSpell.Event ► CreateDialogViewEventArgs ► CreateDialogViewEventArgs(IDialogView)
Keyoti RapidSpell Desktop .NET
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public CreateDialogViewEventArgs(
    IDialogView newView
)
public CreateDialogViewEventArgs(
    IDialogView newView
)
Public Sub New (
    newView As IDialogView
)
Public Sub New (
    newView As IDialogView
)
public:
CreateDialogViewEventArgs(
    IDialogView^ newView
)
public:
CreateDialogViewEventArgs(
    IDialogView^ newView
)
new :
        newView : IDialogView -> CreateDialogViewEventArgs
new :
        newView : IDialogView -> CreateDialogViewEventArgs
Parameters
newView (IDialogView)


NewView Property

Keyoti RapidSpell Desktop .NET API Docs
NewView Property
API ► Keyoti.RapidSpell.Event ► CreateDialogViewEventArgs ► NewView
Keyoti RapidSpell Desktop .NET
The new view to use
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public IDialogView NewView { get; set; }
public IDialogView NewView { get; set; }
Public Property NewView As IDialogView
    Get
    Set
Public Property NewView As IDialogView
    Get
    Set
public:
property IDialogView^ NewView {
    IDialogView^ get ();
    void set (IDialogView^ value);
}
public:
property IDialogView^ NewView {
    IDialogView^ get ();
    void set (IDialogView^ value);
}
member NewView : IDialogView with get, set

member NewView : IDialogView with get, set
Property Value
IDialogView


CreateDialogViewEventHandler Delegate

Keyoti RapidSpell Desktop .NET API Docs
CreateDialogViewEventHandler Delegate
API ► Keyoti.RapidSpell.Event ► CreateDialogViewEventHandler
Keyoti RapidSpell Desktop .NET
EventHandler delegate
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void CreateDialogViewEventHandler(
    Object sender,
    CreateDialogViewEventArgs e
)
public delegate void CreateDialogViewEventHandler(
    Object sender,
    CreateDialogViewEventArgs e
)
Public Delegate Sub CreateDialogViewEventHandler (
    sender As Object,
    e As CreateDialogViewEventArgs
)
Public Delegate Sub CreateDialogViewEventHandler (
    sender As Object,
    e As CreateDialogViewEventArgs
)
public delegate void CreateDialogViewEventHandler(
    Object^ sender,
    CreateDialogViewEventArgs^ e
)
public delegate void CreateDialogViewEventHandler(
    Object^ sender,
    CreateDialogViewEventArgs^ e
)
type CreateDialogViewEventHandler =
    delegate of
        sender : Object *
        e : CreateDialogViewEventArgs -> unit
type CreateDialogViewEventHandler =
    delegate of
        sender : Object *
        e : CreateDialogViewEventArgs -> unit
Parameters
sender (Object)
e (CreateDialogViewEventArgs)


CreateDialogViewOptionsEventArgs Class

Keyoti RapidSpell Desktop .NET API Docs
CreateDialogViewOptionsEventArgs Class
API ► Keyoti.RapidSpell.Event ► CreateDialogViewOptionsEventArgs
Keyoti RapidSpell Desktop .NET
Event args for create IDialogViewOptions event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class CreateDialogViewOptionsEventArgs : EventArgs
public class CreateDialogViewOptionsEventArgs : EventArgs
Public Class CreateDialogViewOptionsEventArgs
    Inherits EventArgs
Public Class CreateDialogViewOptionsEventArgs
    Inherits EventArgs
public ref class CreateDialogViewOptionsEventArgs : public EventArgs
public ref class CreateDialogViewOptionsEventArgs : public EventArgs
type CreateDialogViewOptionsEventArgs =
    class
        inherit EventArgs
    end
type CreateDialogViewOptionsEventArgs =
    class
        inherit EventArgs
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CreateDialogViewOptionsEventArgs(IDialogViewOptions, UserOptions) | New
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewView | The new view to use
 | Options | The UserOptions instance in use by the view
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | CreateDialogViewOptionsEventArgs


CreateDialogViewOptionsEventArgs Constructor (newView, options)

Keyoti RapidSpell Desktop .NET API Docs
CreateDialogViewOptionsEventArgs Constructor (newView, options)
API ► Keyoti.RapidSpell.Event ► CreateDialogViewOptionsEventArgs ► CreateDialogViewOptionsEventArgs(IDialogViewOptions, UserOptions)
Keyoti RapidSpell Desktop .NET
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public CreateDialogViewOptionsEventArgs(
    IDialogViewOptions newView,
    UserOptions options
)
public CreateDialogViewOptionsEventArgs(
    IDialogViewOptions newView,
    UserOptions options
)
Public Sub New (
    newView As IDialogViewOptions,
    options As UserOptions
)
Public Sub New (
    newView As IDialogViewOptions,
    options As UserOptions
)
public:
CreateDialogViewOptionsEventArgs(
    IDialogViewOptions^ newView,
    UserOptions^ options
)
public:
CreateDialogViewOptionsEventArgs(
    IDialogViewOptions^ newView,
    UserOptions^ options
)
new :
        newView : IDialogViewOptions *
        options : UserOptions -> CreateDialogViewOptionsEventArgs
new :
        newView : IDialogViewOptions *
        options : UserOptions -> CreateDialogViewOptionsEventArgs
Parameters
newView (IDialogViewOptions)
options (UserOptions)


NewView Property

Keyoti RapidSpell Desktop .NET API Docs
NewView Property
API ► Keyoti.RapidSpell.Event ► CreateDialogViewOptionsEventArgs ► NewView
Keyoti RapidSpell Desktop .NET
The new view to use
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public IDialogViewOptions NewView { get; set; }
public IDialogViewOptions NewView { get; set; }
Public Property NewView As IDialogViewOptions
    Get
    Set
Public Property NewView As IDialogViewOptions
    Get
    Set
public:
property IDialogViewOptions^ NewView {
    IDialogViewOptions^ get ();
    void set (IDialogViewOptions^ value);
}
public:
property IDialogViewOptions^ NewView {
    IDialogViewOptions^ get ();
    void set (IDialogViewOptions^ value);
}
member NewView : IDialogViewOptions with get, set

member NewView : IDialogViewOptions with get, set
Property Value
IDialogViewOptions


Options Property

Keyoti RapidSpell Desktop .NET API Docs
Options Property
API ► Keyoti.RapidSpell.Event ► CreateDialogViewOptionsEventArgs ► Options
Keyoti RapidSpell Desktop .NET
The UserOptions instance in use by the view
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UserOptions Options { get; }
public UserOptions Options { get; }
Public ReadOnly Property Options As UserOptions
    Get
Public ReadOnly Property Options As UserOptions
    Get
public:
property UserOptions^ Options {
    UserOptions^ get ();
}
public:
property UserOptions^ Options {
    UserOptions^ get ();
}
member Options : UserOptions with get

member Options : UserOptions with get
Property Value
UserOptions


CreateDialogViewOptionsEventHandler Delegate

Keyoti RapidSpell Desktop .NET API Docs
CreateDialogViewOptionsEventHandler Delegate
API ► Keyoti.RapidSpell.Event ► CreateDialogViewOptionsEventHandler
Keyoti RapidSpell Desktop .NET
EventHandler delegate
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void CreateDialogViewOptionsEventHandler(
    Object sender,
    CreateDialogViewOptionsEventArgs e
)
public delegate void CreateDialogViewOptionsEventHandler(
    Object sender,
    CreateDialogViewOptionsEventArgs e
)
Public Delegate Sub CreateDialogViewOptionsEventHandler (
    sender As Object,
    e As CreateDialogViewOptionsEventArgs
)
Public Delegate Sub CreateDialogViewOptionsEventHandler (
    sender As Object,
    e As CreateDialogViewOptionsEventArgs
)
public delegate void CreateDialogViewOptionsEventHandler(
    Object^ sender,
    CreateDialogViewOptionsEventArgs^ e
)
public delegate void CreateDialogViewOptionsEventHandler(
    Object^ sender,
    CreateDialogViewOptionsEventArgs^ e
)
type CreateDialogViewOptionsEventHandler =
    delegate of
        sender : Object *
        e : CreateDialogViewOptionsEventArgs -> unit
type CreateDialogViewOptionsEventHandler =
    delegate of
        sender : Object *
        e : CreateDialogViewOptionsEventArgs -> unit
Parameters
sender (Object)
e (CreateDialogViewOptionsEventArgs)


CreateDialogViewUserDictionaryEditEventArgs Class

Keyoti RapidSpell Desktop .NET API Docs
CreateDialogViewUserDictionaryEditEventArgs Class
API ► Keyoti.RapidSpell.Event ► CreateDialogViewUserDictionaryEditEventArgs
Keyoti RapidSpell Desktop .NET
Event args for create IDialogViewUserDictionaryEdit event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class CreateDialogViewUserDictionaryEditEventArgs : EventArgs
public class CreateDialogViewUserDictionaryEditEventArgs : EventArgs
Public Class CreateDialogViewUserDictionaryEditEventArgs
    Inherits EventArgs
Public Class CreateDialogViewUserDictionaryEditEventArgs
    Inherits EventArgs
public ref class CreateDialogViewUserDictionaryEditEventArgs : public EventArgs
public ref class CreateDialogViewUserDictionaryEditEventArgs : public EventArgs
type CreateDialogViewUserDictionaryEditEventArgs =
    class
        inherit EventArgs
    end
type CreateDialogViewUserDictionaryEditEventArgs =
    class
        inherit EventArgs
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CreateDialogViewUserDictionaryEditEventArgs(IDialogViewUserDictionaryEdit) | New
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewView | The view to use
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | CreateDialogViewUserDictionaryEditEventArgs


CreateDialogViewUserDictionaryEditEventArgs Constructor (newView)

Keyoti RapidSpell Desktop .NET API Docs
CreateDialogViewUserDictionaryEditEventArgs Constructor (newView)
API ► Keyoti.RapidSpell.Event ► CreateDialogViewUserDictionaryEditEventArgs ► CreateDialogViewUserDictionaryEditEventArgs(IDialogViewUserDictionaryEdit)
Keyoti RapidSpell Desktop .NET
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public CreateDialogViewUserDictionaryEditEventArgs(
    IDialogViewUserDictionaryEdit newView
)
public CreateDialogViewUserDictionaryEditEventArgs(
    IDialogViewUserDictionaryEdit newView
)
Public Sub New (
    newView As IDialogViewUserDictionaryEdit
)
Public Sub New (
    newView As IDialogViewUserDictionaryEdit
)
public:
CreateDialogViewUserDictionaryEditEventArgs(
    IDialogViewUserDictionaryEdit^ newView
)
public:
CreateDialogViewUserDictionaryEditEventArgs(
    IDialogViewUserDictionaryEdit^ newView
)
new :
        newView : IDialogViewUserDictionaryEdit -> CreateDialogViewUserDictionaryEditEventArgs
new :
        newView : IDialogViewUserDictionaryEdit -> CreateDialogViewUserDictionaryEditEventArgs
Parameters
newView (IDialogViewUserDictionaryEdit)


NewView Property

Keyoti RapidSpell Desktop .NET API Docs
NewView Property
API ► Keyoti.RapidSpell.Event ► CreateDialogViewUserDictionaryEditEventArgs ► NewView
Keyoti RapidSpell Desktop .NET
The view to use
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public IDialogViewUserDictionaryEdit NewView { get; set; }
public IDialogViewUserDictionaryEdit NewView { get; set; }
Public Property NewView As IDialogViewUserDictionaryEdit
    Get
    Set
Public Property NewView As IDialogViewUserDictionaryEdit
    Get
    Set
public:
property IDialogViewUserDictionaryEdit^ NewView {
    IDialogViewUserDictionaryEdit^ get ();
    void set (IDialogViewUserDictionaryEdit^ value);
}
public:
property IDialogViewUserDictionaryEdit^ NewView {
    IDialogViewUserDictionaryEdit^ get ();
    void set (IDialogViewUserDictionaryEdit^ value);
}
member NewView : IDialogViewUserDictionaryEdit with get, set

member NewView : IDialogViewUserDictionaryEdit with get, set
Property Value
IDialogViewUserDictionaryEdit


CreateDialogViewUserDictionaryEditEventHandler Delegate

Keyoti RapidSpell Desktop .NET API Docs
CreateDialogViewUserDictionaryEditEventHandler Delegate
API ► Keyoti.RapidSpell.Event ► CreateDialogViewUserDictionaryEditEventHandler
Keyoti RapidSpell Desktop .NET
EventHandler delegate
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void CreateDialogViewUserDictionaryEditEventHandler(
    Object sender,
    CreateDialogViewUserDictionaryEditEventArgs e
)
public delegate void CreateDialogViewUserDictionaryEditEventHandler(
    Object sender,
    CreateDialogViewUserDictionaryEditEventArgs e
)
Public Delegate Sub CreateDialogViewUserDictionaryEditEventHandler (
    sender As Object,
    e As CreateDialogViewUserDictionaryEditEventArgs
)
Public Delegate Sub CreateDialogViewUserDictionaryEditEventHandler (
    sender As Object,
    e As CreateDialogViewUserDictionaryEditEventArgs
)
public delegate void CreateDialogViewUserDictionaryEditEventHandler(
    Object^ sender,
    CreateDialogViewUserDictionaryEditEventArgs^ e
)
public delegate void CreateDialogViewUserDictionaryEditEventHandler(
    Object^ sender,
    CreateDialogViewUserDictionaryEditEventArgs^ e
)
type CreateDialogViewUserDictionaryEditEventHandler =
    delegate of
        sender : Object *
        e : CreateDialogViewUserDictionaryEditEventArgs -> unit
type CreateDialogViewUserDictionaryEditEventHandler =
    delegate of
        sender : Object *
        e : CreateDialogViewUserDictionaryEditEventArgs -> unit
Parameters
sender (Object)
e (CreateDialogViewUserDictionaryEditEventArgs)


CreateDialogViewUserDictionarySelectEventArgs Class

Keyoti RapidSpell Desktop .NET API Docs
CreateDialogViewUserDictionarySelectEventArgs Class
API ► Keyoti.RapidSpell.Event ► CreateDialogViewUserDictionarySelectEventArgs
Keyoti RapidSpell Desktop .NET
Event args for create IDialogViewOptions event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class CreateDialogViewUserDictionarySelectEventArgs : EventArgs
public class CreateDialogViewUserDictionarySelectEventArgs : EventArgs
Public Class CreateDialogViewUserDictionarySelectEventArgs
    Inherits EventArgs
Public Class CreateDialogViewUserDictionarySelectEventArgs
    Inherits EventArgs
public ref class CreateDialogViewUserDictionarySelectEventArgs : public EventArgs
public ref class CreateDialogViewUserDictionarySelectEventArgs : public EventArgs
type CreateDialogViewUserDictionarySelectEventArgs =
    class
        inherit EventArgs
    end
type CreateDialogViewUserDictionarySelectEventArgs =
    class
        inherit EventArgs
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CreateDialogViewUserDictionarySelectEventArgs(IDialogViewUserDictionarySelect) | New
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewView | The new view to use
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | CreateDialogViewUserDictionarySelectEventArgs


CreateDialogViewUserDictionarySelectEventArgs Constructor (newView)

Keyoti RapidSpell Desktop .NET API Docs
CreateDialogViewUserDictionarySelectEventArgs Constructor (newView)
API ► Keyoti.RapidSpell.Event ► CreateDialogViewUserDictionarySelectEventArgs ► CreateDialogViewUserDictionarySelectEventArgs(IDialogViewUserDictionarySelect)
Keyoti RapidSpell Desktop .NET
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public CreateDialogViewUserDictionarySelectEventArgs(
    IDialogViewUserDictionarySelect newView
)
public CreateDialogViewUserDictionarySelectEventArgs(
    IDialogViewUserDictionarySelect newView
)
Public Sub New (
    newView As IDialogViewUserDictionarySelect
)
Public Sub New (
    newView As IDialogViewUserDictionarySelect
)
public:
CreateDialogViewUserDictionarySelectEventArgs(
    IDialogViewUserDictionarySelect^ newView
)
public:
CreateDialogViewUserDictionarySelectEventArgs(
    IDialogViewUserDictionarySelect^ newView
)
new :
        newView : IDialogViewUserDictionarySelect -> CreateDialogViewUserDictionarySelectEventArgs
new :
        newView : IDialogViewUserDictionarySelect -> CreateDialogViewUserDictionarySelectEventArgs
Parameters
newView (IDialogViewUserDictionarySelect)


NewView Property

Keyoti RapidSpell Desktop .NET API Docs
NewView Property
API ► Keyoti.RapidSpell.Event ► CreateDialogViewUserDictionarySelectEventArgs ► NewView
Keyoti RapidSpell Desktop .NET
The new view to use
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public IDialogViewUserDictionarySelect NewView { get; set; }
public IDialogViewUserDictionarySelect NewView { get; set; }
Public Property NewView As IDialogViewUserDictionarySelect
    Get
    Set
Public Property NewView As IDialogViewUserDictionarySelect
    Get
    Set
public:
property IDialogViewUserDictionarySelect^ NewView {
    IDialogViewUserDictionarySelect^ get ();
    void set (IDialogViewUserDictionarySelect^ value);
}
public:
property IDialogViewUserDictionarySelect^ NewView {
    IDialogViewUserDictionarySelect^ get ();
    void set (IDialogViewUserDictionarySelect^ value);
}
member NewView : IDialogViewUserDictionarySelect with get, set

member NewView : IDialogViewUserDictionarySelect with get, set
Property Value
IDialogViewUserDictionarySelect


CreateDialogViewUserDictionarySelectEventHandler Delegate

Keyoti RapidSpell Desktop .NET API Docs
CreateDialogViewUserDictionarySelectEventHandler Delegate
API ► Keyoti.RapidSpell.Event ► CreateDialogViewUserDictionarySelectEventHandler
Keyoti RapidSpell Desktop .NET
EventHandler delegate
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void CreateDialogViewUserDictionarySelectEventHandler(
    Object sender,
    CreateDialogViewUserDictionarySelectEventArgs e
)
public delegate void CreateDialogViewUserDictionarySelectEventHandler(
    Object sender,
    CreateDialogViewUserDictionarySelectEventArgs e
)
Public Delegate Sub CreateDialogViewUserDictionarySelectEventHandler (
    sender As Object,
    e As CreateDialogViewUserDictionarySelectEventArgs
)
Public Delegate Sub CreateDialogViewUserDictionarySelectEventHandler (
    sender As Object,
    e As CreateDialogViewUserDictionarySelectEventArgs
)
public delegate void CreateDialogViewUserDictionarySelectEventHandler(
    Object^ sender,
    CreateDialogViewUserDictionarySelectEventArgs^ e
)
public delegate void CreateDialogViewUserDictionarySelectEventHandler(
    Object^ sender,
    CreateDialogViewUserDictionarySelectEventArgs^ e
)
type CreateDialogViewUserDictionarySelectEventHandler =
    delegate of
        sender : Object *
        e : CreateDialogViewUserDictionarySelectEventArgs -> unit
type CreateDialogViewUserDictionarySelectEventHandler =
    delegate of
        sender : Object *
        e : CreateDialogViewUserDictionarySelectEventArgs -> unit
Parameters
sender (Object)
e (CreateDialogViewUserDictionarySelectEventArgs)


CreateUserInterfaceFormPresenterEventArgs Class

Keyoti RapidSpell Desktop .NET API Docs
CreateUserInterfaceFormPresenterEventArgs Class
API ► Keyoti.RapidSpell.Event ► CreateUserInterfaceFormPresenterEventArgs
Keyoti RapidSpell Desktop .NET
Event args for create presenter event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class CreateUserInterfaceFormPresenterEventArgs : EventArgs
public class CreateUserInterfaceFormPresenterEventArgs : EventArgs
Public Class CreateUserInterfaceFormPresenterEventArgs
    Inherits EventArgs
Public Class CreateUserInterfaceFormPresenterEventArgs
    Inherits EventArgs
public ref class CreateUserInterfaceFormPresenterEventArgs : public EventArgs
public ref class CreateUserInterfaceFormPresenterEventArgs : public EventArgs
type CreateUserInterfaceFormPresenterEventArgs =
    class
        inherit EventArgs
    end
type CreateUserInterfaceFormPresenterEventArgs =
    class
        inherit EventArgs
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CreateUserInterfaceFormPresenterEventArgs(IUserInterfaceFormPresenter) | New
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewPresenter | The presenter to use
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | CreateUserInterfaceFormPresenterEventArgs


CreateUserInterfaceFormPresenterEventArgs Constructor (newPresenter)

Keyoti RapidSpell Desktop .NET API Docs
CreateUserInterfaceFormPresenterEventArgs Constructor (newPresenter)
API ► Keyoti.RapidSpell.Event ► CreateUserInterfaceFormPresenterEventArgs ► CreateUserInterfaceFormPresenterEventArgs(IUserInterfaceFormPresenter)
Keyoti RapidSpell Desktop .NET
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public CreateUserInterfaceFormPresenterEventArgs(
    IUserInterfaceFormPresenter newPresenter
)
public CreateUserInterfaceFormPresenterEventArgs(
    IUserInterfaceFormPresenter newPresenter
)
Public Sub New (
    newPresenter As IUserInterfaceFormPresenter
)
Public Sub New (
    newPresenter As IUserInterfaceFormPresenter
)
public:
CreateUserInterfaceFormPresenterEventArgs(
    IUserInterfaceFormPresenter^ newPresenter
)
public:
CreateUserInterfaceFormPresenterEventArgs(
    IUserInterfaceFormPresenter^ newPresenter
)
new :
        newPresenter : IUserInterfaceFormPresenter -> CreateUserInterfaceFormPresenterEventArgs
new :
        newPresenter : IUserInterfaceFormPresenter -> CreateUserInterfaceFormPresenterEventArgs
Parameters
newPresenter (IUserInterfaceFormPresenter)


NewPresenter Property

Keyoti RapidSpell Desktop .NET API Docs
NewPresenter Property
API ► Keyoti.RapidSpell.Event ► CreateUserInterfaceFormPresenterEventArgs ► NewPresenter
Keyoti RapidSpell Desktop .NET
The presenter to use
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public IUserInterfaceFormPresenter NewPresenter { get; set; }
public IUserInterfaceFormPresenter NewPresenter { get; set; }
Public Property NewPresenter As IUserInterfaceFormPresenter
    Get
    Set
Public Property NewPresenter As IUserInterfaceFormPresenter
    Get
    Set
public:
property IUserInterfaceFormPresenter^ NewPresenter {
    IUserInterfaceFormPresenter^ get ();
    void set (IUserInterfaceFormPresenter^ value);
}
public:
property IUserInterfaceFormPresenter^ NewPresenter {
    IUserInterfaceFormPresenter^ get ();
    void set (IUserInterfaceFormPresenter^ value);
}
member NewPresenter : IUserInterfaceFormPresenter with get, set

member NewPresenter : IUserInterfaceFormPresenter with get, set
Property Value
IUserInterfaceFormPresenter


CreateUserInterfaceFormPresenterEventHandler Delegate

Keyoti RapidSpell Desktop .NET API Docs
CreateUserInterfaceFormPresenterEventHandler Delegate
API ► Keyoti.RapidSpell.Event ► CreateUserInterfaceFormPresenterEventHandler
Keyoti RapidSpell Desktop .NET
EventHandler delegate
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void CreateUserInterfaceFormPresenterEventHandler(
    Object s,
    CreateUserInterfaceFormPresenterEventArgs e
)
public delegate void CreateUserInterfaceFormPresenterEventHandler(
    Object s,
    CreateUserInterfaceFormPresenterEventArgs e
)
Public Delegate Sub CreateUserInterfaceFormPresenterEventHandler (
    s As Object,
    e As CreateUserInterfaceFormPresenterEventArgs
)
Public Delegate Sub CreateUserInterfaceFormPresenterEventHandler (
    s As Object,
    e As CreateUserInterfaceFormPresenterEventArgs
)
public delegate void CreateUserInterfaceFormPresenterEventHandler(
    Object^ s,
    CreateUserInterfaceFormPresenterEventArgs^ e
)
public delegate void CreateUserInterfaceFormPresenterEventHandler(
    Object^ s,
    CreateUserInterfaceFormPresenterEventArgs^ e
)
type CreateUserInterfaceFormPresenterEventHandler =
    delegate of
        s : Object *
        e : CreateUserInterfaceFormPresenterEventArgs -> unit
type CreateUserInterfaceFormPresenterEventHandler =
    delegate of
        s : Object *
        e : CreateUserInterfaceFormPresenterEventArgs -> unit
Parameters
s (Object)
e (CreateUserInterfaceFormPresenterEventArgs)


FoundSpellingErrorEventArgs Class

Keyoti RapidSpell Desktop .NET API Docs
FoundSpellingErrorEventArgs Class
API ► Keyoti.RapidSpell.Event ► FoundSpellingErrorEventArgs
Keyoti RapidSpell Desktop .NET
Event args for found error event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class FoundSpellingErrorEventArgs : EventArgs
public class FoundSpellingErrorEventArgs : EventArgs
Public Class FoundSpellingErrorEventArgs
    Inherits EventArgs
Public Class FoundSpellingErrorEventArgs
    Inherits EventArgs
public ref class FoundSpellingErrorEventArgs : public EventArgs
public ref class FoundSpellingErrorEventArgs : public EventArgs
type FoundSpellingErrorEventArgs =
    class
        inherit EventArgs
    end
type FoundSpellingErrorEventArgs =
    class
        inherit EventArgs
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FoundSpellingErrorEventArgs(BadWord, IAYTTextBox) | New
 | BadWord | The misspelling
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Replacement | Any replacement to use for the misspelling, only used by RapidSpellAsYouType
 | TextBox | The textbox being checked
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | FoundSpellingErrorEventArgs


FoundSpellingErrorEventArgs Constructor (theBadWord, textBox)

Keyoti RapidSpell Desktop .NET API Docs
FoundSpellingErrorEventArgs Constructor (theBadWord, textBox)
API ► Keyoti.RapidSpell.Event ► FoundSpellingErrorEventArgs ► FoundSpellingErrorEventArgs(BadWord, IAYTTextBox)
Keyoti RapidSpell Desktop .NET
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public FoundSpellingErrorEventArgs(
    BadWord theBadWord,
    IAYTTextBox textBox
)
public FoundSpellingErrorEventArgs(
    BadWord theBadWord,
    IAYTTextBox textBox
)
Public Sub New (
    theBadWord As BadWord,
    textBox As IAYTTextBox
)
Public Sub New (
    theBadWord As BadWord,
    textBox As IAYTTextBox
)
public:
FoundSpellingErrorEventArgs(
    BadWord^ theBadWord,
    IAYTTextBox^ textBox
)
public:
FoundSpellingErrorEventArgs(
    BadWord^ theBadWord,
    IAYTTextBox^ textBox
)
new :
        theBadWord : BadWord *
        textBox : IAYTTextBox -> FoundSpellingErrorEventArgs
new :
        theBadWord : BadWord *
        textBox : IAYTTextBox -> FoundSpellingErrorEventArgs
Parameters
theBadWord (BadWord)
textBox (IAYTTextBox)


BadWord Property

Keyoti RapidSpell Desktop .NET API Docs
BadWord Property
API ► Keyoti.RapidSpell.Event ► FoundSpellingErrorEventArgs ► BadWord
Keyoti RapidSpell Desktop .NET
The misspelling
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public BadWord BadWord { get; set; }
public BadWord BadWord { get; set; }
Public Property BadWord As BadWord
    Get
    Set
Public Property BadWord As BadWord
    Get
    Set
public:
property BadWord^ BadWord {
    BadWord^ get ();
    void set (BadWord^ value);
}
public:
property BadWord^ BadWord {
    BadWord^ get ();
    void set (BadWord^ value);
}
member BadWord : BadWord with get, set

member BadWord : BadWord with get, set
Property Value
BadWord


Replacement Property

Keyoti RapidSpell Desktop .NET API Docs
Replacement Property
API ► Keyoti.RapidSpell.Event ► FoundSpellingErrorEventArgs ► Replacement
Keyoti RapidSpell Desktop .NET
Any replacement to use for the misspelling, only used by RapidSpellAsYouType
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string Replacement { get; set; }
public string Replacement { get; set; }
Public Property Replacement As String
    Get
    Set
Public Property Replacement As String
    Get
    Set
public:
property String^ Replacement {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Replacement {
    String^ get ();
    void set (String^ value);
}
member Replacement : string with get, set

member Replacement : string with get, set
Property Value
String


TextBox Property

Keyoti RapidSpell Desktop .NET API Docs
TextBox Property
API ► Keyoti.RapidSpell.Event ► FoundSpellingErrorEventArgs ► TextBox
Keyoti RapidSpell Desktop .NET
The textbox being checked
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public IAYTTextBox TextBox { get; }
public IAYTTextBox TextBox { get; }
Public ReadOnly Property TextBox As IAYTTextBox
    Get
Public ReadOnly Property TextBox As IAYTTextBox
    Get
public:
property IAYTTextBox^ TextBox {
    IAYTTextBox^ get ();
}
public:
property IAYTTextBox^ TextBox {
    IAYTTextBox^ get ();
}
member TextBox : IAYTTextBox with get

member TextBox : IAYTTextBox with get
Property Value
IAYTTextBox


FoundSpellingErrorEventHandler Delegate

Keyoti RapidSpell Desktop .NET API Docs
FoundSpellingErrorEventHandler Delegate
API ► Keyoti.RapidSpell.Event ► FoundSpellingErrorEventHandler
Keyoti RapidSpell Desktop .NET
EventHandler delegate
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void FoundSpellingErrorEventHandler(
    Object s,
    FoundSpellingErrorEventArgs e
)
public delegate void FoundSpellingErrorEventHandler(
    Object s,
    FoundSpellingErrorEventArgs e
)
Public Delegate Sub FoundSpellingErrorEventHandler (
    s As Object,
    e As FoundSpellingErrorEventArgs
)
Public Delegate Sub FoundSpellingErrorEventHandler (
    s As Object,
    e As FoundSpellingErrorEventArgs
)
public delegate void FoundSpellingErrorEventHandler(
    Object^ s,
    FoundSpellingErrorEventArgs^ e
)
public delegate void FoundSpellingErrorEventHandler(
    Object^ s,
    FoundSpellingErrorEventArgs^ e
)
type FoundSpellingErrorEventHandler =
    delegate of
        s : Object *
        e : FoundSpellingErrorEventArgs -> unit
type FoundSpellingErrorEventHandler =
    delegate of
        s : Object *
        e : FoundSpellingErrorEventArgs -> unit
Parameters
s (Object)
e (FoundSpellingErrorEventArgs)


SpellCheckEventArgs Class

Keyoti RapidSpell Desktop .NET API Docs
SpellCheckEventArgs Class
API ► Keyoti.RapidSpell.Event ► SpellCheckEventArgs
Keyoti RapidSpell Desktop .NET
Args for the events fired when RapidSpellGUI,RapidSpellDialog or RapidSpellAYT starts or stops.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class SpellCheckEventArgs : EventArgs
public class SpellCheckEventArgs : EventArgs
Public Class SpellCheckEventArgs
    Inherits EventArgs
Public Class SpellCheckEventArgs
    Inherits EventArgs
public ref class SpellCheckEventArgs : public EventArgs
public ref class SpellCheckEventArgs : public EventArgs
type SpellCheckEventArgs =
    class
        inherit EventArgs
    end
type SpellCheckEventArgs =
    class
        inherit EventArgs
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SpellCheckEventArgs()()()() |
 | SpellCheckEventArgs(Boolean) |
 | Cancelled | Whether the spell check was cancelled.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | SpellCheckEventArgs


SpellCheckEventArgs Constructor

Keyoti RapidSpell Desktop .NET API Docs
SpellCheckEventArgs Constructor
API ► Keyoti.RapidSpell.Event ► SpellCheckEventArgs ► SpellCheckEventArgs()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | SpellCheckEventArgs()()()() |
 | SpellCheckEventArgs(Boolean) |


SpellCheckEventArgs Constructor

Keyoti RapidSpell Desktop .NET API Docs
SpellCheckEventArgs Constructor
API ► Keyoti.RapidSpell.Event ► SpellCheckEventArgs ► SpellCheckEventArgs()()()()
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public SpellCheckEventArgs()
public SpellCheckEventArgs()
Public Sub New
Public Sub New
public:
SpellCheckEventArgs()
public:
SpellCheckEventArgs()
new : unit -> SpellCheckEventArgs
new : unit -> SpellCheckEventArgs


SpellCheckEventArgs Constructor (cancelled)

Keyoti RapidSpell Desktop .NET API Docs
SpellCheckEventArgs Constructor (cancelled)
API ► Keyoti.RapidSpell.Event ► SpellCheckEventArgs ► SpellCheckEventArgs(Boolean)
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public SpellCheckEventArgs(
    bool cancelled
)
public SpellCheckEventArgs(
    bool cancelled
)
Public Sub New (
    cancelled As Boolean
)
Public Sub New (
    cancelled As Boolean
)
public:
SpellCheckEventArgs(
    bool cancelled
)
public:
SpellCheckEventArgs(
    bool cancelled
)
new :
        cancelled : bool -> SpellCheckEventArgs
new :
        cancelled : bool -> SpellCheckEventArgs
Parameters
cancelled (Boolean)


Cancelled Property

Keyoti RapidSpell Desktop .NET API Docs
Cancelled Property
API ► Keyoti.RapidSpell.Event ► SpellCheckEventArgs ► Cancelled
Keyoti RapidSpell Desktop .NET
Whether the spell check was cancelled.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool Cancelled { get; }
public bool Cancelled { get; }
Public ReadOnly Property Cancelled As Boolean
    Get
Public ReadOnly Property Cancelled As Boolean
    Get
public:
property bool Cancelled {
    bool get ();
}
public:
property bool Cancelled {
    bool get ();
}
member Cancelled : bool with get

member Cancelled : bool with get
Property Value
Boolean


SpellCheckEventHandler Delegate

Keyoti RapidSpell Desktop .NET API Docs
SpellCheckEventHandler Delegate
API ► Keyoti.RapidSpell.Event ► SpellCheckEventHandler
Keyoti RapidSpell Desktop .NET
Spell check event handler delegate.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void SpellCheckEventHandler(
    Object sender,
    SpellCheckEventArgs e
)
public delegate void SpellCheckEventHandler(
    Object sender,
    SpellCheckEventArgs e
)
Public Delegate Sub SpellCheckEventHandler (
    sender As Object,
    e As SpellCheckEventArgs
)
Public Delegate Sub SpellCheckEventHandler (
    sender As Object,
    e As SpellCheckEventArgs
)
public delegate void SpellCheckEventHandler(
    Object^ sender,
    SpellCheckEventArgs^ e
)
public delegate void SpellCheckEventHandler(
    Object^ sender,
    SpellCheckEventArgs^ e
)
type SpellCheckEventHandler =
    delegate of
        sender : Object *
        e : SpellCheckEventArgs -> unit
type SpellCheckEventHandler =
    delegate of
        sender : Object *
        e : SpellCheckEventArgs -> unit
Parameters
sender (Object)
e (SpellCheckEventArgs)


SpellContextMenuEventArgs Class

Keyoti RapidSpell Desktop .NET API Docs
SpellContextMenuEventArgs Class
API ► Keyoti.RapidSpell.Event ► SpellContextMenuEventArgs
Keyoti RapidSpell Desktop .NET
Args for the events fired when the spell checkers context menu is requested.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class SpellContextMenuEventArgs : EventArgs
public class SpellContextMenuEventArgs : EventArgs
Public Class SpellContextMenuEventArgs
    Inherits EventArgs
Public Class SpellContextMenuEventArgs
    Inherits EventArgs
public ref class SpellContextMenuEventArgs : public EventArgs
public ref class SpellContextMenuEventArgs : public EventArgs
type SpellContextMenuEventArgs =
    class
        inherit EventArgs
    end
type SpellContextMenuEventArgs =
    class
        inherit EventArgs
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SpellContextMenuEventArgs(IList, Int32, Int32, Int32) | New
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MenuItems | List of menu items with suggestions, ignore and add options.
 | RightClickCharIndex | Character index where right click was made.
 | RightClickWordEnd | End index of word right clicked on.
 | RightClickWordStart | Start index of word right clicked on.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Remarks
Contains menu items so that they maybe shown in a different menu/contextmenu.
Inheritance Hierarchy
Object
 | EventArgs
 |  | SpellContextMenuEventArgs


SpellContextMenuEventArgs Constructor (menuItems, charIndex, rwordStart, rwordEnd)

Keyoti RapidSpell Desktop .NET API Docs
SpellContextMenuEventArgs Constructor (menuItems, charIndex, rwordStart, rwordEnd)
API ► Keyoti.RapidSpell.Event ► SpellContextMenuEventArgs ► SpellContextMenuEventArgs(IList, Int32, Int32, Int32)
Keyoti RapidSpell Desktop .NET
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public SpellContextMenuEventArgs(
    IList menuItems,
    int charIndex,
    int rwordStart,
    int rwordEnd
)
public SpellContextMenuEventArgs(
    IList menuItems,
    int charIndex,
    int rwordStart,
    int rwordEnd
)
Public Sub New (
    menuItems As IList,
    charIndex As Integer,
    rwordStart As Integer,
    rwordEnd As Integer
)
Public Sub New (
    menuItems As IList,
    charIndex As Integer,
    rwordStart As Integer,
    rwordEnd As Integer
)
public:
SpellContextMenuEventArgs(
    IList^ menuItems,
    int charIndex,
    int rwordStart,
    int rwordEnd
)
public:
SpellContextMenuEventArgs(
    IList^ menuItems,
    int charIndex,
    int rwordStart,
    int rwordEnd
)
new :
        menuItems : IList *
        charIndex : int *
        rwordStart : int *
        rwordEnd : int -> SpellContextMenuEventArgs
new :
        menuItems : IList *
        charIndex : int *
        rwordStart : int *
        rwordEnd : int -> SpellContextMenuEventArgs
Parameters
menuItems (IList)
charIndex (Int32)
rwordStart (Int32)
rwordEnd (Int32)


MenuItems Property

Keyoti RapidSpell Desktop .NET API Docs
MenuItems Property
API ► Keyoti.RapidSpell.Event ► SpellContextMenuEventArgs ► MenuItems
Keyoti RapidSpell Desktop .NET
List of menu items with suggestions, ignore and add options.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public IList MenuItems { get; }
public IList MenuItems { get; }
Public ReadOnly Property MenuItems As IList
    Get
Public ReadOnly Property MenuItems As IList
    Get
public:
property IList^ MenuItems {
    IList^ get ();
}
public:
property IList^ MenuItems {
    IList^ get ();
}
member MenuItems : IList with get

member MenuItems : IList with get
Property Value
IList


RightClickCharIndex Property

Keyoti RapidSpell Desktop .NET API Docs
RightClickCharIndex Property
API ► Keyoti.RapidSpell.Event ► SpellContextMenuEventArgs ► RightClickCharIndex
Keyoti RapidSpell Desktop .NET
Character index where right click was made.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int RightClickCharIndex { get; }
public int RightClickCharIndex { get; }
Public ReadOnly Property RightClickCharIndex As Integer
    Get
Public ReadOnly Property RightClickCharIndex As Integer
    Get
public:
property int RightClickCharIndex {
    int get ();
}
public:
property int RightClickCharIndex {
    int get ();
}
member RightClickCharIndex : int with get

member RightClickCharIndex : int with get
Property Value
Int32


RightClickWordEnd Property

Keyoti RapidSpell Desktop .NET API Docs
RightClickWordEnd Property
API ► Keyoti.RapidSpell.Event ► SpellContextMenuEventArgs ► RightClickWordEnd
Keyoti RapidSpell Desktop .NET
End index of word right clicked on.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int RightClickWordEnd { get; }
public int RightClickWordEnd { get; }
Public ReadOnly Property RightClickWordEnd As Integer
    Get
Public ReadOnly Property RightClickWordEnd As Integer
    Get
public:
property int RightClickWordEnd {
    int get ();
}
public:
property int RightClickWordEnd {
    int get ();
}
member RightClickWordEnd : int with get

member RightClickWordEnd : int with get
Property Value
Int32


RightClickWordStart Property

Keyoti RapidSpell Desktop .NET API Docs
RightClickWordStart Property
API ► Keyoti.RapidSpell.Event ► SpellContextMenuEventArgs ► RightClickWordStart
Keyoti RapidSpell Desktop .NET
Start index of word right clicked on.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int RightClickWordStart { get; }
public int RightClickWordStart { get; }
Public ReadOnly Property RightClickWordStart As Integer
    Get
Public ReadOnly Property RightClickWordStart As Integer
    Get
public:
property int RightClickWordStart {
    int get ();
}
public:
property int RightClickWordStart {
    int get ();
}
member RightClickWordStart : int with get

member RightClickWordStart : int with get
Property Value
Int32


TextBoxSpellCheckEventArgs Class

Keyoti RapidSpell Desktop .NET API Docs
TextBoxSpellCheckEventArgs Class
API ► Keyoti.RapidSpell.Event ► TextBoxSpellCheckEventArgs
Keyoti RapidSpell Desktop .NET
Args for the events fired when spell checking multiple text boxes.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class TextBoxSpellCheckEventArgs : EventArgs
public class TextBoxSpellCheckEventArgs : EventArgs
Public Class TextBoxSpellCheckEventArgs
    Inherits EventArgs
Public Class TextBoxSpellCheckEventArgs
    Inherits EventArgs
public ref class TextBoxSpellCheckEventArgs : public EventArgs
public ref class TextBoxSpellCheckEventArgs : public EventArgs
type TextBoxSpellCheckEventArgs =
    class
        inherit EventArgs
    end
type TextBoxSpellCheckEventArgs =
    class
        inherit EventArgs
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TextBoxSpellCheckEventArgs(Int32) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TextBoxIndex | The related text box index, this corresponds to the array of ISpellCheckableTextComponents that has been set for checking (0 for single text box checks).
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | TextBoxSpellCheckEventArgs


TextBoxSpellCheckEventArgs Constructor (textBoxIndex)

Keyoti RapidSpell Desktop .NET API Docs
TextBoxSpellCheckEventArgs Constructor (textBoxIndex)
API ► Keyoti.RapidSpell.Event ► TextBoxSpellCheckEventArgs ► TextBoxSpellCheckEventArgs(Int32)
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public TextBoxSpellCheckEventArgs(
    int textBoxIndex
)
public TextBoxSpellCheckEventArgs(
    int textBoxIndex
)
Public Sub New (
    textBoxIndex As Integer
)
Public Sub New (
    textBoxIndex As Integer
)
public:
TextBoxSpellCheckEventArgs(
    int textBoxIndex
)
public:
TextBoxSpellCheckEventArgs(
    int textBoxIndex
)
new :
        textBoxIndex : int -> TextBoxSpellCheckEventArgs
new :
        textBoxIndex : int -> TextBoxSpellCheckEventArgs
Parameters
textBoxIndex (Int32)


TextBoxIndex Property

Keyoti RapidSpell Desktop .NET API Docs
TextBoxIndex Property
API ► Keyoti.RapidSpell.Event ► TextBoxSpellCheckEventArgs ► TextBoxIndex
Keyoti RapidSpell Desktop .NET
The related text box index, this corresponds to the array of ISpellCheckableTextComponents that has been set for checking (0 for single text box checks).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int TextBoxIndex { get; }
public int TextBoxIndex { get; }
Public ReadOnly Property TextBoxIndex As Integer
    Get
Public ReadOnly Property TextBoxIndex As Integer
    Get
public:
property int TextBoxIndex {
    int get ();
}
public:
property int TextBoxIndex {
    int get ();
}
member TextBoxIndex : int with get

member TextBoxIndex : int with get
Property Value
Int32


UserQueryEventArgs Class

Keyoti RapidSpell Desktop .NET API Docs
UserQueryEventArgs Class
API ► Keyoti.RapidSpell.Event ► UserQueryEventArgs
Keyoti RapidSpell Desktop .NET
Event args for user query event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class UserQueryEventArgs : EventArgs
public class UserQueryEventArgs : EventArgs
Public Class UserQueryEventArgs
    Inherits EventArgs
Public Class UserQueryEventArgs
    Inherits EventArgs
public ref class UserQueryEventArgs : public EventArgs
public ref class UserQueryEventArgs : public EventArgs
type UserQueryEventArgs =
    class
        inherit EventArgs
    end
type UserQueryEventArgs =
    class
        inherit EventArgs
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserQueryEventArgs(BadWord, Object) | New
 | BadWord | The misspelling
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TextBox | The textbox being checked
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | UserQueryEventArgs


UserQueryEventArgs Constructor (theBadWord, textBox)

Keyoti RapidSpell Desktop .NET API Docs
UserQueryEventArgs Constructor (theBadWord, textBox)
API ► Keyoti.RapidSpell.Event ► UserQueryEventArgs ► UserQueryEventArgs(BadWord, Object)
Keyoti RapidSpell Desktop .NET
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UserQueryEventArgs(
    BadWord theBadWord,
    Object textBox
)
public UserQueryEventArgs(
    BadWord theBadWord,
    Object textBox
)
Public Sub New (
    theBadWord As BadWord,
    textBox As Object
)
Public Sub New (
    theBadWord As BadWord,
    textBox As Object
)
public:
UserQueryEventArgs(
    BadWord^ theBadWord,
    Object^ textBox
)
public:
UserQueryEventArgs(
    BadWord^ theBadWord,
    Object^ textBox
)
new :
        theBadWord : BadWord *
        textBox : Object -> UserQueryEventArgs
new :
        theBadWord : BadWord *
        textBox : Object -> UserQueryEventArgs
Parameters
theBadWord (BadWord)
textBox (Object)


BadWord Property

Keyoti RapidSpell Desktop .NET API Docs
BadWord Property
API ► Keyoti.RapidSpell.Event ► UserQueryEventArgs ► BadWord
Keyoti RapidSpell Desktop .NET
The misspelling
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public BadWord BadWord { get; set; }
public BadWord BadWord { get; set; }
Public Property BadWord As BadWord
    Get
    Set
Public Property BadWord As BadWord
    Get
    Set
public:
property BadWord^ BadWord {
    BadWord^ get ();
    void set (BadWord^ value);
}
public:
property BadWord^ BadWord {
    BadWord^ get ();
    void set (BadWord^ value);
}
member BadWord : BadWord with get, set

member BadWord : BadWord with get, set
Property Value
BadWord


TextBox Property

Keyoti RapidSpell Desktop .NET API Docs
TextBox Property
API ► Keyoti.RapidSpell.Event ► UserQueryEventArgs ► TextBox
Keyoti RapidSpell Desktop .NET
The textbox being checked
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Object TextBox { get; }
public Object TextBox { get; }
Public ReadOnly Property TextBox As Object
    Get
Public ReadOnly Property TextBox As Object
    Get
public:
property Object^ TextBox {
    Object^ get ();
}
public:
property Object^ TextBox {
    Object^ get ();
}
member TextBox : Object with get

member TextBox : Object with get
Property Value
Object


UserQueryEventHandler Delegate

Keyoti RapidSpell Desktop .NET API Docs
UserQueryEventHandler Delegate
API ► Keyoti.RapidSpell.Event ► UserQueryEventHandler
Keyoti RapidSpell Desktop .NET
EventHandler delegate
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void UserQueryEventHandler(
    Object s,
    UserQueryEventArgs e
)
public delegate void UserQueryEventHandler(
    Object s,
    UserQueryEventArgs e
)
Public Delegate Sub UserQueryEventHandler (
    s As Object,
    e As UserQueryEventArgs
)
Public Delegate Sub UserQueryEventHandler (
    s As Object,
    e As UserQueryEventArgs
)
public delegate void UserQueryEventHandler(
    Object^ s,
    UserQueryEventArgs^ e
)
public delegate void UserQueryEventHandler(
    Object^ s,
    UserQueryEventArgs^ e
)
type UserQueryEventHandler =
    delegate of
        s : Object *
        e : UserQueryEventArgs -> unit
type UserQueryEventHandler =
    delegate of
        s : Object *
        e : UserQueryEventArgs -> unit
Parameters
s (Object)
e (UserQueryEventArgs)


WordsEnteredEventArgs Class

Keyoti RapidSpell Desktop .NET API Docs
WordsEnteredEventArgs Class
API ► Keyoti.RapidSpell.Event ► WordsEnteredEventArgs
Keyoti RapidSpell Desktop .NET
Args for the events fired when words are entered into the text box.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class WordsEnteredEventArgs : EventArgs
public class WordsEnteredEventArgs : EventArgs
Public Class WordsEnteredEventArgs
    Inherits EventArgs
Public Class WordsEnteredEventArgs
    Inherits EventArgs
public ref class WordsEnteredEventArgs : public EventArgs
public ref class WordsEnteredEventArgs : public EventArgs
type WordsEnteredEventArgs =
    class
        inherit EventArgs
    end
type WordsEnteredEventArgs =
    class
        inherit EventArgs
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WordsEnteredEventArgs(IList, IAYTTextBox) | New
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SourceTextBox | The text box in which words were entered.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Words | List of WordOccurrence objects, representing the newly entered words.
Remarks
Contains IList of WordOccurrence objects.
Inheritance Hierarchy
Object
 | EventArgs
 |  | WordsEnteredEventArgs


WordsEnteredEventArgs Constructor (words, sourceTextBox)

Keyoti RapidSpell Desktop .NET API Docs
WordsEnteredEventArgs Constructor (words, sourceTextBox)
API ► Keyoti.RapidSpell.Event ► WordsEnteredEventArgs ► WordsEnteredEventArgs(IList, IAYTTextBox)
Keyoti RapidSpell Desktop .NET
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public WordsEnteredEventArgs(
    IList words,
    IAYTTextBox sourceTextBox
)
public WordsEnteredEventArgs(
    IList words,
    IAYTTextBox sourceTextBox
)
Public Sub New (
    words As IList,
    sourceTextBox As IAYTTextBox
)
Public Sub New (
    words As IList,
    sourceTextBox As IAYTTextBox
)
public:
WordsEnteredEventArgs(
    IList^ words,
    IAYTTextBox^ sourceTextBox
)
public:
WordsEnteredEventArgs(
    IList^ words,
    IAYTTextBox^ sourceTextBox
)
new :
        words : IList *
        sourceTextBox : IAYTTextBox -> WordsEnteredEventArgs
new :
        words : IList *
        sourceTextBox : IAYTTextBox -> WordsEnteredEventArgs
Parameters
words (IList)
sourceTextBox (IAYTTextBox)


SourceTextBox Property

Keyoti RapidSpell Desktop .NET API Docs
SourceTextBox Property
API ► Keyoti.RapidSpell.Event ► WordsEnteredEventArgs ► SourceTextBox
Keyoti RapidSpell Desktop .NET
The text box in which words were entered.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public IAYTTextBox SourceTextBox { get; }
public IAYTTextBox SourceTextBox { get; }
Public ReadOnly Property SourceTextBox As IAYTTextBox
    Get
Public ReadOnly Property SourceTextBox As IAYTTextBox
    Get
public:
property IAYTTextBox^ SourceTextBox {
    IAYTTextBox^ get ();
}
public:
property IAYTTextBox^ SourceTextBox {
    IAYTTextBox^ get ();
}
member SourceTextBox : IAYTTextBox with get

member SourceTextBox : IAYTTextBox with get
Property Value
IAYTTextBox


Words Property

Keyoti RapidSpell Desktop .NET API Docs
Words Property
API ► Keyoti.RapidSpell.Event ► WordsEnteredEventArgs ► Words
Keyoti RapidSpell Desktop .NET
List of WordOccurrence objects, representing the newly entered words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public IList Words { get; }
public IList Words { get; }
Public ReadOnly Property Words As IList
    Get
Public ReadOnly Property Words As IList
    Get
public:
property IList^ Words {
    IList^ get ();
}
public:
property IList^ Words {
    IList^ get ();
}
member Words : IList with get

member Words : IList with get
Property Value
IList


WordsEnteredEventHandler Delegate

Keyoti RapidSpell Desktop .NET API Docs
WordsEnteredEventHandler Delegate
API ► Keyoti.RapidSpell.Event ► WordsEnteredEventHandler
Keyoti RapidSpell Desktop .NET
Handler delegate
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void WordsEnteredEventHandler(
    Object sender,
    WordsEnteredEventArgs e
)
public delegate void WordsEnteredEventHandler(
    Object sender,
    WordsEnteredEventArgs e
)
Public Delegate Sub WordsEnteredEventHandler (
    sender As Object,
    e As WordsEnteredEventArgs
)
Public Delegate Sub WordsEnteredEventHandler (
    sender As Object,
    e As WordsEnteredEventArgs
)
public delegate void WordsEnteredEventHandler(
    Object^ sender,
    WordsEnteredEventArgs^ e
)
public delegate void WordsEnteredEventHandler(
    Object^ sender,
    WordsEnteredEventArgs^ e
)
type WordsEnteredEventHandler =
    delegate of
        sender : Object *
        e : WordsEnteredEventArgs -> unit
type WordsEnteredEventHandler =
    delegate of
        sender : Object *
        e : WordsEnteredEventArgs -> unit
Parameters
sender (Object)
e (WordsEnteredEventArgs)


Keyoti.RapidSpell.FrameWorkSpecific Namespace

Keyoti RapidSpell Desktop .NET API Docs
Keyoti.RapidSpell.FrameWorkSpecific Namespace
API ► Keyoti.RapidSpell.FrameWorkSpecific
Keyoti RapidSpell Desktop .NET
The namespace for RapidSpell Desktop .NET specific classes.

Misc

Types
All Types Classes Structures
Icon | Type | Description
 | AdvancedTextBoundary | A word parser, capable of working with XML documents.
 | CHARFORMAT2 | Internal
 | SimpleTextBoundary | A simple word parser, for plain text.


AdvancedTextBoundary Class

Keyoti RapidSpell Desktop .NET API Docs
AdvancedTextBoundary Class
API ► Keyoti.RapidSpell.FrameWorkSpecific ► AdvancedTextBoundary
Keyoti RapidSpell Desktop .NET
A word parser, capable of working with XML documents.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class AdvancedTextBoundary : SimpleTextBoundary
public class AdvancedTextBoundary : SimpleTextBoundary
Public Class AdvancedTextBoundary
    Inherits SimpleTextBoundary
Public Class AdvancedTextBoundary
    Inherits SimpleTextBoundary
public ref class AdvancedTextBoundary : public SimpleTextBoundary
public ref class AdvancedTextBoundary : public SimpleTextBoundary
type AdvancedTextBoundary =
    class
        inherit SimpleTextBoundary
    end
type AdvancedTextBoundary =
    class
        inherit SimpleTextBoundary
    end
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AdvancedTextBoundary()()()() |
 | CheckLegalOffset(Int32, String, Boolean) | Throws an ArgumentOutOfRangeException if offset is out of bounds. (Inherited from SimpleTextBoundary.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | f_languageParsing | Language rules to use when parsing. (Inherited from SimpleTextBoundary.)
 | f_separateHyphenWords | Whether to simply treat hyphens as breaking chars. (Inherited from SimpleTextBoundary.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | Following(Int32) | Returns the next breaking point in the text. (Overrides SimpleTextBoundary.Following(Int32).)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | IgnoreXML | Whether to ignore XML/HTML tags, should be set true for RichTextBox support, false by default.
 | isAtNonBreakingWhiteSpace(Int32, Boolean, Boolean) | Whether position is non-breaking white space (Overrides SimpleTextBoundary.isAtNonBreakingWhiteSpace(Int32, Boolean, Boolean).)
 | isAtNonBreakingWhiteSpace(Int32) | Whether the character at position is a nonbreaking whitespace. (Inherited from SimpleTextBoundary.)
 | isAtNonWhiteSpace(Int32) | Whether position is not whitespace. (Overrides SimpleTextBoundary.isAtNonWhiteSpace(Int32).)
 | isBetweenWordChars(Int32) | Whether the character at position is between nonbreaking white space or letters or digits. (Inherited from SimpleTextBoundary.)
 | isBetweenWordChars(Int32, Boolean, Boolean) | Whether the character at position is between nonbreaking white space or letters or digits. (Inherited from SimpleTextBoundary.)
 | IsBoundary(Int32) | Determines if character at offset is a boundary (Inherited from SimpleTextBoundary.)
 | IsBoundaryLeft(Int32) | Whether offset is a boundary to the left of text (Inherited from SimpleTextBoundary.)
 | IsBoundaryRight(Int32) | Whether offset is one place after the last character in a word. (Inherited from SimpleTextBoundary.)
 | IsStartOfSentence(Int32) | Whether the character at offset is the first letter or digit of the sentence. (Inherited from SimpleTextBoundary.)
 | LanguageParsing | The language parsing to be used. (Inherited from SimpleTextBoundary.)
 | Last()()()() | Return the last boundary. The iterator's current position is set to the last boundary. (Inherited from SimpleTextBoundary.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Preceding(Int32) | this ignores xml tags butted between text. (Overrides SimpleTextBoundary.Preceding(Int32).)
 | SeparateHyphenWords | Whether to treat hyphenated (-) words as separate words, default is false. (Inherited from SimpleTextBoundary.)
 | SetText(String) | Sets the text to be analysed. (Overrides SimpleTextBoundary.SetText(String).)
 | TextIsStartOfTextBody | If known, whether the text to be set in SetText is the start of the text body. Affects sentence determination. (Inherited from SimpleTextBoundary.)
 | theText | The text being parsed. (Inherited from SimpleTextBoundary.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | V2Parser | Whether to use parser version 2 (Inherited from SimpleTextBoundary.)
Inheritance Hierarchy
Object
 | SimpleTextBoundary
 |  | AdvancedTextBoundary


AdvancedTextBoundary Constructor

Keyoti RapidSpell Desktop .NET API Docs
AdvancedTextBoundary Constructor
API ► Keyoti.RapidSpell.FrameWorkSpecific ► AdvancedTextBoundary ► AdvancedTextBoundary()()()()
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public AdvancedTextBoundary()
public AdvancedTextBoundary()
Public Sub New
Public Sub New
public:
AdvancedTextBoundary()
public:
AdvancedTextBoundary()
new : unit -> AdvancedTextBoundary
new : unit -> AdvancedTextBoundary


Following Method (offset)

Keyoti RapidSpell Desktop .NET API Docs
Following Method (offset)
API ► Keyoti.RapidSpell.FrameWorkSpecific ► AdvancedTextBoundary ► Following(Int32)
Keyoti RapidSpell Desktop .NET
Returns the next breaking point in the text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override int Following(
    int offset
)
public override int Following(
    int offset
)
Public Overrides Function Following (
    offset As Integer
) As Integer
Public Overrides Function Following (
    offset As Integer
) As Integer
public:
virtual int Following(
    int offset
) override
public:
virtual int Following(
    int offset
) override
abstract Following :
        offset : int -> int
override Following :
        offset : int -> int
abstract Following :
        offset : int -> int
override Following :
        offset : int -> int
Parameters
offset (Int32)
Return Value
Int32


IgnoreXML Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreXML Property
API ► Keyoti.RapidSpell.FrameWorkSpecific ► AdvancedTextBoundary ► IgnoreXML
Keyoti RapidSpell Desktop .NET
Whether to ignore XML/HTML tags, should be set true for RichTextBox support, false by default.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreXML { get; set; }
public bool IgnoreXML { get; set; }
Public Property IgnoreXML As Boolean
    Get
    Set
Public Property IgnoreXML As Boolean
    Get
    Set
public:
property bool IgnoreXML {
    bool get ();
    void set (bool value);
}
public:
property bool IgnoreXML {
    bool get ();
    void set (bool value);
}
member IgnoreXML : bool with get, set

member IgnoreXML : bool with get, set
Property Value
Boolean


isAtNonBreakingWhiteSpace Method (position, previousIsIfThisIs, nextIsIfThisIs)

Keyoti RapidSpell Desktop .NET API Docs
isAtNonBreakingWhiteSpace Method (position, previousIsIfThisIs, nextIsIfThisIs)
API ► Keyoti.RapidSpell.FrameWorkSpecific ► AdvancedTextBoundary ► isAtNonBreakingWhiteSpace(Int32, Boolean, Boolean)
Keyoti RapidSpell Desktop .NET
Whether position is non-breaking white space
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override bool isAtNonBreakingWhiteSpace(
    int position,
    bool previousIsIfThisIs,
    bool nextIsIfThisIs
)
protected override bool isAtNonBreakingWhiteSpace(
    int position,
    bool previousIsIfThisIs,
    bool nextIsIfThisIs
)
Protected Overrides Function isAtNonBreakingWhiteSpace (
    position As Integer,
    previousIsIfThisIs As Boolean,
    nextIsIfThisIs As Boolean
) As Boolean
Protected Overrides Function isAtNonBreakingWhiteSpace (
    position As Integer,
    previousIsIfThisIs As Boolean,
    nextIsIfThisIs As Boolean
) As Boolean
protected:
virtual bool isAtNonBreakingWhiteSpace(
    int position,
    bool previousIsIfThisIs,
    bool nextIsIfThisIs
) override
protected:
virtual bool isAtNonBreakingWhiteSpace(
    int position,
    bool previousIsIfThisIs,
    bool nextIsIfThisIs
) override
abstract isAtNonBreakingWhiteSpace :
        position : int *
        previousIsIfThisIs : bool *
        nextIsIfThisIs : bool -> bool
override isAtNonBreakingWhiteSpace :
        position : int *
        previousIsIfThisIs : bool *
        nextIsIfThisIs : bool -> bool
abstract isAtNonBreakingWhiteSpace :
        position : int *
        previousIsIfThisIs : bool *
        nextIsIfThisIs : bool -> bool
override isAtNonBreakingWhiteSpace :
        position : int *
        previousIsIfThisIs : bool *
        nextIsIfThisIs : bool -> bool
Parameters
position (Int32)
previousIsIfThisIs (Boolean)
nextIsIfThisIs (Boolean)
Return Value
Boolean


isAtNonWhiteSpace Method (position)

Keyoti RapidSpell Desktop .NET API Docs
isAtNonWhiteSpace Method (position)
API ► Keyoti.RapidSpell.FrameWorkSpecific ► AdvancedTextBoundary ► isAtNonWhiteSpace(Int32)
Keyoti RapidSpell Desktop .NET
Whether position is not whitespace.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override bool isAtNonWhiteSpace(
    int position
)
protected override bool isAtNonWhiteSpace(
    int position
)
Protected Overrides Function isAtNonWhiteSpace (
    position As Integer
) As Boolean
Protected Overrides Function isAtNonWhiteSpace (
    position As Integer
) As Boolean
protected:
virtual bool isAtNonWhiteSpace(
    int position
) override
protected:
virtual bool isAtNonWhiteSpace(
    int position
) override
abstract isAtNonWhiteSpace :
        position : int -> bool
override isAtNonWhiteSpace :
        position : int -> bool
abstract isAtNonWhiteSpace :
        position : int -> bool
override isAtNonWhiteSpace :
        position : int -> bool
Parameters
position (Int32)
Return Value
Boolean


Preceding Method (offset)

Keyoti RapidSpell Desktop .NET API Docs
Preceding Method (offset)
API ► Keyoti.RapidSpell.FrameWorkSpecific ► AdvancedTextBoundary ► Preceding(Int32)
Keyoti RapidSpell Desktop .NET
this ignores xml tags butted between text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override int Preceding(
    int offset
)
public override int Preceding(
    int offset
)
Public Overrides Function Preceding (
    offset As Integer
) As Integer
Public Overrides Function Preceding (
    offset As Integer
) As Integer
public:
virtual int Preceding(
    int offset
) override
public:
virtual int Preceding(
    int offset
) override
abstract Preceding :
        offset : int -> int
override Preceding :
        offset : int -> int
abstract Preceding :
        offset : int -> int
override Preceding :
        offset : int -> int
Parameters
offset (Int32)
Return Value
Int32


SetText Method (t)

Keyoti RapidSpell Desktop .NET API Docs
SetText Method (t)
API ► Keyoti.RapidSpell.FrameWorkSpecific ► AdvancedTextBoundary ► SetText(String)
Keyoti RapidSpell Desktop .NET
Sets the text to be analysed.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override void SetText(
    string t
)
public override void SetText(
    string t
)
Public Overrides Sub SetText (
    t As String
)
Public Overrides Sub SetText (
    t As String
)
public:
virtual void SetText(
    String^ t
) override
public:
virtual void SetText(
    String^ t
) override
abstract SetText :
        t : string -> unit
override SetText :
        t : string -> unit
abstract SetText :
        t : string -> unit
override SetText :
        t : string -> unit
Parameters
t (String)


CHARFORMAT2 Structure

Keyoti RapidSpell Desktop .NET API Docs
CHARFORMAT2 Structure
API ► Keyoti.RapidSpell.FrameWorkSpecific ► CHARFORMAT2
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public struct CHARFORMAT2
public struct CHARFORMAT2
Public Structure CHARFORMAT2
Public Structure CHARFORMAT2
public value class CHARFORMAT2
public value class CHARFORMAT2
[<SealedAttribute>]
type CHARFORMAT2 =  struct end
[<SealedAttribute>]
type CHARFORMAT2 =  struct end
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | bAnimation | Internal
 | bCharSet | Internal
 | bPitchAndFamily | Internal
 | bReserved1 | Internal
 | bRevAuthor | Internal
 | bUnderlineType | Internal
 | cbSize | Internal
 | crBackColor | Internal
 | crTextColor | Internal
 | dwEffects | Internal
 | dwMask | Internal
 | dwReserved | Internal
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | lcid | Internal
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | sSpacing | Internal
 | sStyle | Internal
 | szFaceName | Internal
 | ToString()()()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
 | wKerning | Internal
 | wWeight | Internal
 | yHeight | Internal
 | yOffset | Internal


bAnimation Field

Keyoti RapidSpell Desktop .NET API Docs
bAnimation Field
API ► Keyoti.RapidSpell.FrameWorkSpecific ► CHARFORMAT2 ► bAnimation
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public byte bAnimation
public byte bAnimation
Public bAnimation As Byte
Public bAnimation As Byte
public:
unsigned char bAnimation
public:
unsigned char bAnimation
val mutable bAnimation: byte
val mutable bAnimation: byte
Field Value
Byte


bCharSet Field

Keyoti RapidSpell Desktop .NET API Docs
bCharSet Field
API ► Keyoti.RapidSpell.FrameWorkSpecific ► CHARFORMAT2 ► bCharSet
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public byte bCharSet
public byte bCharSet
Public bCharSet As Byte
Public bCharSet As Byte
public:
unsigned char bCharSet
public:
unsigned char bCharSet
val mutable bCharSet: byte
val mutable bCharSet: byte
Field Value
Byte


bPitchAndFamily Field

Keyoti RapidSpell Desktop .NET API Docs
bPitchAndFamily Field
API ► Keyoti.RapidSpell.FrameWorkSpecific ► CHARFORMAT2 ► bPitchAndFamily
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public byte bPitchAndFamily
public byte bPitchAndFamily
Public bPitchAndFamily As Byte
Public bPitchAndFamily As Byte
public:
unsigned char bPitchAndFamily
public:
unsigned char bPitchAndFamily
val mutable bPitchAndFamily: byte
val mutable bPitchAndFamily: byte
Field Value
Byte


bReserved1 Field

Keyoti RapidSpell Desktop .NET API Docs
bReserved1 Field
API ► Keyoti.RapidSpell.FrameWorkSpecific ► CHARFORMAT2 ► bReserved1
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public byte bReserved1
public byte bReserved1
Public bReserved1 As Byte
Public bReserved1 As Byte
public:
unsigned char bReserved1
public:
unsigned char bReserved1
val mutable bReserved1: byte
val mutable bReserved1: byte
Field Value
Byte


bRevAuthor Field

Keyoti RapidSpell Desktop .NET API Docs
bRevAuthor Field
API ► Keyoti.RapidSpell.FrameWorkSpecific ► CHARFORMAT2 ► bRevAuthor
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public byte bRevAuthor
public byte bRevAuthor
Public bRevAuthor As Byte
Public bRevAuthor As Byte
public:
unsigned char bRevAuthor
public:
unsigned char bRevAuthor
val mutable bRevAuthor: byte
val mutable bRevAuthor: byte
Field Value
Byte


bUnderlineType Field

Keyoti RapidSpell Desktop .NET API Docs
bUnderlineType Field
API ► Keyoti.RapidSpell.FrameWorkSpecific ► CHARFORMAT2 ► bUnderlineType
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public byte bUnderlineType
public byte bUnderlineType
Public bUnderlineType As Byte
Public bUnderlineType As Byte
public:
unsigned char bUnderlineType
public:
unsigned char bUnderlineType
val mutable bUnderlineType: byte
val mutable bUnderlineType: byte
Field Value
Byte


cbSize Field

Keyoti RapidSpell Desktop .NET API Docs
cbSize Field
API ► Keyoti.RapidSpell.FrameWorkSpecific ► CHARFORMAT2 ► cbSize
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int cbSize
public int cbSize
Public cbSize As Integer
Public cbSize As Integer
public:
int cbSize
public:
int cbSize
val mutable cbSize: int
val mutable cbSize: int
Field Value
Int32


crBackColor Field

Keyoti RapidSpell Desktop .NET API Docs
crBackColor Field
API ► Keyoti.RapidSpell.FrameWorkSpecific ► CHARFORMAT2 ► crBackColor
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int crBackColor
public int crBackColor
Public crBackColor As Integer
Public crBackColor As Integer
public:
int crBackColor
public:
int crBackColor
val mutable crBackColor: int
val mutable crBackColor: int
Field Value
Int32


crTextColor Field

Keyoti RapidSpell Desktop .NET API Docs
crTextColor Field
API ► Keyoti.RapidSpell.FrameWorkSpecific ► CHARFORMAT2 ► crTextColor
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int crTextColor
public int crTextColor
Public crTextColor As Integer
Public crTextColor As Integer
public:
int crTextColor
public:
int crTextColor
val mutable crTextColor: int
val mutable crTextColor: int
Field Value
Int32


dwEffects Field

Keyoti RapidSpell Desktop .NET API Docs
dwEffects Field
API ► Keyoti.RapidSpell.FrameWorkSpecific ► CHARFORMAT2 ► dwEffects
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int dwEffects
public int dwEffects
Public dwEffects As Integer
Public dwEffects As Integer
public:
int dwEffects
public:
int dwEffects
val mutable dwEffects: int
val mutable dwEffects: int
Field Value
Int32


dwMask Field

Keyoti RapidSpell Desktop .NET API Docs
dwMask Field
API ► Keyoti.RapidSpell.FrameWorkSpecific ► CHARFORMAT2 ► dwMask
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int dwMask
public int dwMask
Public dwMask As Integer
Public dwMask As Integer
public:
int dwMask
public:
int dwMask
val mutable dwMask: int
val mutable dwMask: int
Field Value
Int32


dwReserved Field

Keyoti RapidSpell Desktop .NET API Docs
dwReserved Field
API ► Keyoti.RapidSpell.FrameWorkSpecific ► CHARFORMAT2 ► dwReserved
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int dwReserved
public int dwReserved
Public dwReserved As Integer
Public dwReserved As Integer
public:
int dwReserved
public:
int dwReserved
val mutable dwReserved: int
val mutable dwReserved: int
Field Value
Int32


lcid Field

Keyoti RapidSpell Desktop .NET API Docs
lcid Field
API ► Keyoti.RapidSpell.FrameWorkSpecific ► CHARFORMAT2 ► lcid
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int lcid
public int lcid
Public lcid As Integer
Public lcid As Integer
public:
int lcid
public:
int lcid
val mutable lcid: int
val mutable lcid: int
Field Value
Int32


sSpacing Field

Keyoti RapidSpell Desktop .NET API Docs
sSpacing Field
API ► Keyoti.RapidSpell.FrameWorkSpecific ► CHARFORMAT2 ► sSpacing
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public short sSpacing
public short sSpacing
Public sSpacing As Short
Public sSpacing As Short
public:
short sSpacing
public:
short sSpacing
val mutable sSpacing: int16
val mutable sSpacing: int16
Field Value
Int16


sStyle Field

Keyoti RapidSpell Desktop .NET API Docs
sStyle Field
API ► Keyoti.RapidSpell.FrameWorkSpecific ► CHARFORMAT2 ► sStyle
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public short sStyle
public short sStyle
Public sStyle As Short
Public sStyle As Short
public:
short sStyle
public:
short sStyle
val mutable sStyle: int16
val mutable sStyle: int16
Field Value
Int16


szFaceName Field

Keyoti RapidSpell Desktop .NET API Docs
szFaceName Field
API ► Keyoti.RapidSpell.FrameWorkSpecific ► CHARFORMAT2 ► szFaceName
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string szFaceName
public string szFaceName
Public szFaceName As String
Public szFaceName As String
public:
String^ szFaceName
public:
String^ szFaceName
val mutable szFaceName: string
val mutable szFaceName: string
Field Value
String


wKerning Field

Keyoti RapidSpell Desktop .NET API Docs
wKerning Field
API ► Keyoti.RapidSpell.FrameWorkSpecific ► CHARFORMAT2 ► wKerning
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public short wKerning
public short wKerning
Public wKerning As Short
Public wKerning As Short
public:
short wKerning
public:
short wKerning
val mutable wKerning: int16
val mutable wKerning: int16
Field Value
Int16


wWeight Field

Keyoti RapidSpell Desktop .NET API Docs
wWeight Field
API ► Keyoti.RapidSpell.FrameWorkSpecific ► CHARFORMAT2 ► wWeight
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public short wWeight
public short wWeight
Public wWeight As Short
Public wWeight As Short
public:
short wWeight
public:
short wWeight
val mutable wWeight: int16
val mutable wWeight: int16
Field Value
Int16


yHeight Field

Keyoti RapidSpell Desktop .NET API Docs
yHeight Field
API ► Keyoti.RapidSpell.FrameWorkSpecific ► CHARFORMAT2 ► yHeight
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int yHeight
public int yHeight
Public yHeight As Integer
Public yHeight As Integer
public:
int yHeight
public:
int yHeight
val mutable yHeight: int
val mutable yHeight: int
Field Value
Int32


yOffset Field

Keyoti RapidSpell Desktop .NET API Docs
yOffset Field
API ► Keyoti.RapidSpell.FrameWorkSpecific ► CHARFORMAT2 ► yOffset
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int yOffset
public int yOffset
Public yOffset As Integer
Public yOffset As Integer
public:
int yOffset
public:
int yOffset
val mutable yOffset: int
val mutable yOffset: int
Field Value
Int32


SimpleTextBoundary Class

Keyoti RapidSpell Desktop .NET API Docs
SimpleTextBoundary Class
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary
Keyoti RapidSpell Desktop .NET
A simple word parser, for plain text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class SimpleTextBoundary
public class SimpleTextBoundary
Public Class SimpleTextBoundary
Public Class SimpleTextBoundary
public ref class SimpleTextBoundary
public ref class SimpleTextBoundary
type SimpleTextBoundary =  class end
type SimpleTextBoundary =  class end
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SimpleTextBoundary()()()() |
 | breakChars | Characters that aren't letters or digits and do break words apart
 | CheckLegalOffset(Int32, String, Boolean) | Throws an ArgumentOutOfRangeException if offset is out of bounds.
 | ENGLISH | English text parsing.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | f_languageParsing | Language rules to use when parsing.
 | f_separateHyphenWords | Whether to simply treat hyphens as breaking chars.
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | Following(Int32) | Return the first boundary after the specified offset
 | FRENCH | French text parsing.
 | GERMAN | French text parsing.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | isAtNonBreakingWhiteSpace(Int32) | Whether the character at position is a nonbreaking whitespace.
 | isAtNonBreakingWhiteSpace(Int32, Boolean, Boolean) | Whether the character at position is a nonbreaking whitespace.
 | isAtNonWhiteSpace(Int32) | Returns whether the character at position is whitespace, this is contextually relevant.
 | isBetweenWordChars(Int32) | Whether the character at position is between nonbreaking white space or letters or digits.
 | isBetweenWordChars(Int32, Boolean, Boolean) | Whether the character at position is between nonbreaking white space or letters or digits.
 | IsBoundary(Int32) | Determines if character at offset is a boundary
 | IsBoundaryLeft(Int32) | Whether offset is a boundary to the left of text
 | IsBoundaryRight(Int32) | Whether offset is one place after the last character in a word.
 | IsStartOfSentence(Int32) | Whether the character at offset is the first letter or digit of the sentence.
 | LanguageParsing | The language parsing to be used.
 | Last()()()() | Return the last boundary. The iterator's current position is set to the last boundary.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | noBreakButLookIntoChars | Characters that aren't letters or digits but do not break words apart, however the spell checker should consider words on either side as separate words
 | noBreakButLookIntoCharsLength | The number of chars in the noBreakButLookIntoChars field
 | noBreakChars | Characters that aren't letters or digits but do not break words apart
 | Preceding(Int32) | Return the first boundary before the specified offset
 | SeparateHyphenWords | Whether to treat hyphenated (-) words as separate words, default is false.
 | SetText(String) | Sets the text to be analysed.
 | TextIsStartOfTextBody | If known, whether the text to be set in SetText is the start of the text body. Affects sentence determination.
 | theText | The text being parsed.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | V2Parser | Whether to use parser version 2
Inheritance Hierarchy
Object
 | SimpleTextBoundary
 |  | AdvancedTextBoundary


SimpleTextBoundary Constructor

Keyoti RapidSpell Desktop .NET API Docs
SimpleTextBoundary Constructor
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► SimpleTextBoundary()()()()
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public SimpleTextBoundary()
public SimpleTextBoundary()
Public Sub New
Public Sub New
public:
SimpleTextBoundary()
public:
SimpleTextBoundary()
new : unit -> SimpleTextBoundary
new : unit -> SimpleTextBoundary


breakChars Field

Keyoti RapidSpell Desktop .NET API Docs
breakChars Field
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► breakChars
Keyoti RapidSpell Desktop .NET
Characters that aren't letters or digits and do break words apart
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public const string breakChars
public const string breakChars
Public Const breakChars As String
Public Const breakChars As String
public:
literal String^ breakChars
public:
literal String^ breakChars
static val mutable breakChars: string
static val mutable breakChars: string
Field Value
String


CheckLegalOffset Method (offset, message, allowEnd)

Keyoti RapidSpell Desktop .NET API Docs
CheckLegalOffset Method (offset, message, allowEnd)
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► CheckLegalOffset(Int32, String, Boolean)
Keyoti RapidSpell Desktop .NET
Throws an ArgumentOutOfRangeException if offset is out of bounds.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void CheckLegalOffset(
    int offset,
    string message,
    bool allowEnd
)
protected virtual void CheckLegalOffset(
    int offset,
    string message,
    bool allowEnd
)
Protected Overridable Sub CheckLegalOffset (
    offset As Integer,
    message As String,
    allowEnd As Boolean
)
Protected Overridable Sub CheckLegalOffset (
    offset As Integer,
    message As String,
    allowEnd As Boolean
)
protected:
virtual void CheckLegalOffset(
    int offset,
    String^ message,
    bool allowEnd
)
protected:
virtual void CheckLegalOffset(
    int offset,
    String^ message,
    bool allowEnd
)
abstract CheckLegalOffset :
        offset : int *
        message : string *
        allowEnd : bool -> unit
override CheckLegalOffset :
        offset : int *
        message : string *
        allowEnd : bool -> unit
abstract CheckLegalOffset :
        offset : int *
        message : string *
        allowEnd : bool -> unit
override CheckLegalOffset :
        offset : int *
        message : string *
        allowEnd : bool -> unit
Parameters
offset (Int32)
message (String)
allowEnd (Boolean)


ENGLISH Field

Keyoti RapidSpell Desktop .NET API Docs
ENGLISH Field
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► ENGLISH
Keyoti RapidSpell Desktop .NET
English text parsing.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static int ENGLISH
public static int ENGLISH
Public Shared ENGLISH As Integer
Public Shared ENGLISH As Integer
public:
static int ENGLISH
public:
static int ENGLISH
static val mutable ENGLISH: int
static val mutable ENGLISH: int
Field Value
Int32


f_languageParsing Field

Keyoti RapidSpell Desktop .NET API Docs
f_languageParsing Field
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► f_languageParsing
Keyoti RapidSpell Desktop .NET
Language rules to use when parsing.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected int f_languageParsing
protected int f_languageParsing
Protected f_languageParsing As Integer
Protected f_languageParsing As Integer
protected:
int f_languageParsing
protected:
int f_languageParsing
val mutable f_languageParsing: int
val mutable f_languageParsing: int
Field Value
Int32


f_separateHyphenWords Field

Keyoti RapidSpell Desktop .NET API Docs
f_separateHyphenWords Field
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► f_separateHyphenWords
Keyoti RapidSpell Desktop .NET
Whether to simply treat hyphens as breaking chars.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected bool f_separateHyphenWords
protected bool f_separateHyphenWords
Protected f_separateHyphenWords As Boolean
Protected f_separateHyphenWords As Boolean
protected:
bool f_separateHyphenWords
protected:
bool f_separateHyphenWords
val mutable f_separateHyphenWords: bool
val mutable f_separateHyphenWords: bool
Field Value
Boolean


Following Method (offset)

Keyoti RapidSpell Desktop .NET API Docs
Following Method (offset)
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► Following(Int32)
Keyoti RapidSpell Desktop .NET
Return the first boundary after the specified offset
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual int Following(
    int offset
)
public virtual int Following(
    int offset
)
Public Overridable Function Following (
    offset As Integer
) As Integer
Public Overridable Function Following (
    offset As Integer
) As Integer
public:
virtual int Following(
    int offset
)
public:
virtual int Following(
    int offset
)
abstract Following :
        offset : int -> int
override Following :
        offset : int -> int
abstract Following :
        offset : int -> int
override Following :
        offset : int -> int
Parameters
offset (Int32)
the offset to start
Return Value
Int32
int the first boundary after offset


FRENCH Field

Keyoti RapidSpell Desktop .NET API Docs
FRENCH Field
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► FRENCH
Keyoti RapidSpell Desktop .NET
French text parsing.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static int FRENCH
public static int FRENCH
Public Shared FRENCH As Integer
Public Shared FRENCH As Integer
public:
static int FRENCH
public:
static int FRENCH
static val mutable FRENCH: int
static val mutable FRENCH: int
Field Value
Int32


GERMAN Field

Keyoti RapidSpell Desktop .NET API Docs
GERMAN Field
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► GERMAN
Keyoti RapidSpell Desktop .NET
French text parsing.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static int GERMAN
public static int GERMAN
Public Shared GERMAN As Integer
Public Shared GERMAN As Integer
public:
static int GERMAN
public:
static int GERMAN
static val mutable GERMAN: int
static val mutable GERMAN: int
Field Value
Int32


isAtNonBreakingWhiteSpace Method

Keyoti RapidSpell Desktop .NET API Docs
isAtNonBreakingWhiteSpace Method
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► isAtNonBreakingWhiteSpace()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | isAtNonBreakingWhiteSpace(Int32) | Whether the character at position is a nonbreaking whitespace.
 | isAtNonBreakingWhiteSpace(Int32, Boolean, Boolean) | Whether the character at position is a nonbreaking whitespace.


isAtNonBreakingWhiteSpace Method (position)

Keyoti RapidSpell Desktop .NET API Docs
isAtNonBreakingWhiteSpace Method (position)
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► isAtNonBreakingWhiteSpace(Int32)
Keyoti RapidSpell Desktop .NET
Whether the character at position is a nonbreaking whitespace.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual bool isAtNonBreakingWhiteSpace(
    int position
)
protected virtual bool isAtNonBreakingWhiteSpace(
    int position
)
Protected Overridable Function isAtNonBreakingWhiteSpace (
    position As Integer
) As Boolean
Protected Overridable Function isAtNonBreakingWhiteSpace (
    position As Integer
) As Boolean
protected:
virtual bool isAtNonBreakingWhiteSpace(
    int position
)
protected:
virtual bool isAtNonBreakingWhiteSpace(
    int position
)
abstract isAtNonBreakingWhiteSpace :
        position : int -> bool
override isAtNonBreakingWhiteSpace :
        position : int -> bool
abstract isAtNonBreakingWhiteSpace :
        position : int -> bool
override isAtNonBreakingWhiteSpace :
        position : int -> bool
Parameters
position (Int32)
Return Value
Boolean


isAtNonBreakingWhiteSpace Method (position, previousIsIfThisIs, nextIsIfThisIs)

Keyoti RapidSpell Desktop .NET API Docs
isAtNonBreakingWhiteSpace Method (position, previousIsIfThisIs, nextIsIfThisIs)
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► isAtNonBreakingWhiteSpace(Int32, Boolean, Boolean)
Keyoti RapidSpell Desktop .NET
Whether the character at position is a nonbreaking whitespace.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual bool isAtNonBreakingWhiteSpace(
    int position,
    bool previousIsIfThisIs,
    bool nextIsIfThisIs
)
protected virtual bool isAtNonBreakingWhiteSpace(
    int position,
    bool previousIsIfThisIs,
    bool nextIsIfThisIs
)
Protected Overridable Function isAtNonBreakingWhiteSpace (
    position As Integer,
    previousIsIfThisIs As Boolean,
    nextIsIfThisIs As Boolean
) As Boolean
Protected Overridable Function isAtNonBreakingWhiteSpace (
    position As Integer,
    previousIsIfThisIs As Boolean,
    nextIsIfThisIs As Boolean
) As Boolean
protected:
virtual bool isAtNonBreakingWhiteSpace(
    int position,
    bool previousIsIfThisIs,
    bool nextIsIfThisIs
)
protected:
virtual bool isAtNonBreakingWhiteSpace(
    int position,
    bool previousIsIfThisIs,
    bool nextIsIfThisIs
)
abstract isAtNonBreakingWhiteSpace :
        position : int *
        previousIsIfThisIs : bool *
        nextIsIfThisIs : bool -> bool
override isAtNonBreakingWhiteSpace :
        position : int *
        previousIsIfThisIs : bool *
        nextIsIfThisIs : bool -> bool
abstract isAtNonBreakingWhiteSpace :
        position : int *
        previousIsIfThisIs : bool *
        nextIsIfThisIs : bool -> bool
override isAtNonBreakingWhiteSpace :
        position : int *
        previousIsIfThisIs : bool *
        nextIsIfThisIs : bool -> bool
Parameters
position (Int32)
previousIsIfThisIs (Boolean)
nextIsIfThisIs (Boolean)
Return Value
Boolean


isAtNonWhiteSpace Method (position)

Keyoti RapidSpell Desktop .NET API Docs
isAtNonWhiteSpace Method (position)
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► isAtNonWhiteSpace(Int32)
Keyoti RapidSpell Desktop .NET
Returns whether the character at position is whitespace, this is contextually relevant.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual bool isAtNonWhiteSpace(
    int position
)
protected virtual bool isAtNonWhiteSpace(
    int position
)
Protected Overridable Function isAtNonWhiteSpace (
    position As Integer
) As Boolean
Protected Overridable Function isAtNonWhiteSpace (
    position As Integer
) As Boolean
protected:
virtual bool isAtNonWhiteSpace(
    int position
)
protected:
virtual bool isAtNonWhiteSpace(
    int position
)
abstract isAtNonWhiteSpace :
        position : int -> bool
override isAtNonWhiteSpace :
        position : int -> bool
abstract isAtNonWhiteSpace :
        position : int -> bool
override isAtNonWhiteSpace :
        position : int -> bool
Parameters
position (Int32)
Return Value
Boolean


isBetweenWordChars Method

Keyoti RapidSpell Desktop .NET API Docs
isBetweenWordChars Method
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► isBetweenWordChars()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | isBetweenWordChars(Int32) | Whether the character at position is between nonbreaking white space or letters or digits.
 | isBetweenWordChars(Int32, Boolean, Boolean) | Whether the character at position is between nonbreaking white space or letters or digits.


isBetweenWordChars Method (position)

Keyoti RapidSpell Desktop .NET API Docs
isBetweenWordChars Method (position)
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► isBetweenWordChars(Int32)
Keyoti RapidSpell Desktop .NET
Whether the character at position is between nonbreaking white space or letters or digits.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual bool isBetweenWordChars(
    int position
)
protected virtual bool isBetweenWordChars(
    int position
)
Protected Overridable Function isBetweenWordChars (
    position As Integer
) As Boolean
Protected Overridable Function isBetweenWordChars (
    position As Integer
) As Boolean
protected:
virtual bool isBetweenWordChars(
    int position
)
protected:
virtual bool isBetweenWordChars(
    int position
)
abstract isBetweenWordChars :
        position : int -> bool
override isBetweenWordChars :
        position : int -> bool
abstract isBetweenWordChars :
        position : int -> bool
override isBetweenWordChars :
        position : int -> bool
Parameters
position (Int32)
Return Value
Boolean


isBetweenWordChars Method (position, previousIsIfThisIs, nextIsIfThisIs)

Keyoti RapidSpell Desktop .NET API Docs
isBetweenWordChars Method (position, previousIsIfThisIs, nextIsIfThisIs)
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► isBetweenWordChars(Int32, Boolean, Boolean)
Keyoti RapidSpell Desktop .NET
Whether the character at position is between nonbreaking white space or letters or digits.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual bool isBetweenWordChars(
    int position,
    bool previousIsIfThisIs,
    bool nextIsIfThisIs
)
protected virtual bool isBetweenWordChars(
    int position,
    bool previousIsIfThisIs,
    bool nextIsIfThisIs
)
Protected Overridable Function isBetweenWordChars (
    position As Integer,
    previousIsIfThisIs As Boolean,
    nextIsIfThisIs As Boolean
) As Boolean
Protected Overridable Function isBetweenWordChars (
    position As Integer,
    previousIsIfThisIs As Boolean,
    nextIsIfThisIs As Boolean
) As Boolean
protected:
virtual bool isBetweenWordChars(
    int position,
    bool previousIsIfThisIs,
    bool nextIsIfThisIs
)
protected:
virtual bool isBetweenWordChars(
    int position,
    bool previousIsIfThisIs,
    bool nextIsIfThisIs
)
abstract isBetweenWordChars :
        position : int *
        previousIsIfThisIs : bool *
        nextIsIfThisIs : bool -> bool
override isBetweenWordChars :
        position : int *
        previousIsIfThisIs : bool *
        nextIsIfThisIs : bool -> bool
abstract isBetweenWordChars :
        position : int *
        previousIsIfThisIs : bool *
        nextIsIfThisIs : bool -> bool
override isBetweenWordChars :
        position : int *
        previousIsIfThisIs : bool *
        nextIsIfThisIs : bool -> bool
Parameters
position (Int32)
previousIsIfThisIs (Boolean)
nextIsIfThisIs (Boolean)
Return Value
Boolean


IsBoundary Method (offset)

Keyoti RapidSpell Desktop .NET API Docs
IsBoundary Method (offset)
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► IsBoundary(Int32)
Keyoti RapidSpell Desktop .NET
Determines if character at offset is a boundary
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool IsBoundary(
    int offset
)
public virtual bool IsBoundary(
    int offset
)
Public Overridable Function IsBoundary (
    offset As Integer
) As Boolean
Public Overridable Function IsBoundary (
    offset As Integer
) As Boolean
public:
virtual bool IsBoundary(
    int offset
)
public:
virtual bool IsBoundary(
    int offset
)
abstract IsBoundary :
        offset : int -> bool
override IsBoundary :
        offset : int -> bool
abstract IsBoundary :
        offset : int -> bool
override IsBoundary :
        offset : int -> bool
Parameters
offset (Int32)
Return Value
Boolean


IsBoundaryLeft Method (offset)

Keyoti RapidSpell Desktop .NET API Docs
IsBoundaryLeft Method (offset)
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► IsBoundaryLeft(Int32)
Keyoti RapidSpell Desktop .NET
Whether offset is a boundary to the left of text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool IsBoundaryLeft(
    int offset
)
public virtual bool IsBoundaryLeft(
    int offset
)
Public Overridable Function IsBoundaryLeft (
    offset As Integer
) As Boolean
Public Overridable Function IsBoundaryLeft (
    offset As Integer
) As Boolean
public:
virtual bool IsBoundaryLeft(
    int offset
)
public:
virtual bool IsBoundaryLeft(
    int offset
)
abstract IsBoundaryLeft :
        offset : int -> bool
override IsBoundaryLeft :
        offset : int -> bool
abstract IsBoundaryLeft :
        offset : int -> bool
override IsBoundaryLeft :
        offset : int -> bool
Parameters
offset (Int32)
Return Value
Boolean


IsBoundaryRight Method (offset)

Keyoti RapidSpell Desktop .NET API Docs
IsBoundaryRight Method (offset)
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► IsBoundaryRight(Int32)
Keyoti RapidSpell Desktop .NET
Whether offset is one place after the last character in a word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool IsBoundaryRight(
    int offset
)
public virtual bool IsBoundaryRight(
    int offset
)
Public Overridable Function IsBoundaryRight (
    offset As Integer
) As Boolean
Public Overridable Function IsBoundaryRight (
    offset As Integer
) As Boolean
public:
virtual bool IsBoundaryRight(
    int offset
)
public:
virtual bool IsBoundaryRight(
    int offset
)
abstract IsBoundaryRight :
        offset : int -> bool
override IsBoundaryRight :
        offset : int -> bool
abstract IsBoundaryRight :
        offset : int -> bool
override IsBoundaryRight :
        offset : int -> bool
Parameters
offset (Int32)
Return Value
Boolean


IsStartOfSentence Method (offset)

Keyoti RapidSpell Desktop .NET API Docs
IsStartOfSentence Method (offset)
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► IsStartOfSentence(Int32)
Keyoti RapidSpell Desktop .NET
Whether the character at offset is the first letter or digit of the sentence.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool IsStartOfSentence(
    int offset
)
public virtual bool IsStartOfSentence(
    int offset
)
Public Overridable Function IsStartOfSentence (
    offset As Integer
) As Boolean
Public Overridable Function IsStartOfSentence (
    offset As Integer
) As Boolean
public:
virtual bool IsStartOfSentence(
    int offset
)
public:
virtual bool IsStartOfSentence(
    int offset
)
abstract IsStartOfSentence :
        offset : int -> bool
override IsStartOfSentence :
        offset : int -> bool
abstract IsStartOfSentence :
        offset : int -> bool
override IsStartOfSentence :
        offset : int -> bool
Parameters
offset (Int32)
Return Value
Boolean


LanguageParsing Property

Keyoti RapidSpell Desktop .NET API Docs
LanguageParsing Property
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► LanguageParsing
Keyoti RapidSpell Desktop .NET
The language parsing to be used.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int LanguageParsing { get; set; }
public int LanguageParsing { get; set; }
Public Property LanguageParsing As Integer
    Get
    Set
Public Property LanguageParsing As Integer
    Get
    Set
public:
property int LanguageParsing {
    int get ();
    void set (int value);
}
public:
property int LanguageParsing {
    int get ();
    void set (int value);
}
member LanguageParsing : int with get, set

member LanguageParsing : int with get, set
Property Value
Int32


Last Method

Keyoti RapidSpell Desktop .NET API Docs
Last Method
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► Last()()()()
Keyoti RapidSpell Desktop .NET
Return the last boundary. The iterator's current position is set to the last boundary.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual int Last()
public virtual int Last()
Public Overridable Function Last As Integer
Public Overridable Function Last As Integer
public:
virtual int Last()
public:
virtual int Last()
abstract Last : unit -> int
override Last : unit -> int
abstract Last : unit -> int
override Last : unit -> int
Return Value
Int32


noBreakButLookIntoChars Field

Keyoti RapidSpell Desktop .NET API Docs
noBreakButLookIntoChars Field
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► noBreakButLookIntoChars
Keyoti RapidSpell Desktop .NET
Characters that aren't letters or digits but do not break words apart, however the spell checker should consider words on either side as separate words
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public const string noBreakButLookIntoChars
public const string noBreakButLookIntoChars
Public Const noBreakButLookIntoChars As String
Public Const noBreakButLookIntoChars As String
public:
literal String^ noBreakButLookIntoChars
public:
literal String^ noBreakButLookIntoChars
static val mutable noBreakButLookIntoChars: string
static val mutable noBreakButLookIntoChars: string
Field Value
String


noBreakButLookIntoCharsLength Field

Keyoti RapidSpell Desktop .NET API Docs
noBreakButLookIntoCharsLength Field
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► noBreakButLookIntoCharsLength
Keyoti RapidSpell Desktop .NET
The number of chars in the noBreakButLookIntoChars field
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public const int noBreakButLookIntoCharsLength
public const int noBreakButLookIntoCharsLength
Public Const noBreakButLookIntoCharsLength As Integer
Public Const noBreakButLookIntoCharsLength As Integer
public:
literal int noBreakButLookIntoCharsLength
public:
literal int noBreakButLookIntoCharsLength
static val mutable noBreakButLookIntoCharsLength: int
static val mutable noBreakButLookIntoCharsLength: int
Field Value
Int32


noBreakChars Field

Keyoti RapidSpell Desktop .NET API Docs
noBreakChars Field
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► noBreakChars
Keyoti RapidSpell Desktop .NET
Characters that aren't letters or digits but do not break words apart
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static char[] noBreakChars
public static char[] noBreakChars
Public Shared noBreakChars As Char()
Public Shared noBreakChars As Char()
public:
static array<wchar_t>^ noBreakChars
public:
static array<wchar_t>^ noBreakChars
static val mutable noBreakChars: char[]
static val mutable noBreakChars: char[]
Field Value
array< Char >[]()[][]


Preceding Method (offset)

Keyoti RapidSpell Desktop .NET API Docs
Preceding Method (offset)
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► Preceding(Int32)
Keyoti RapidSpell Desktop .NET
Return the first boundary before the specified offset
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual int Preceding(
    int offset
)
public virtual int Preceding(
    int offset
)
Public Overridable Function Preceding (
    offset As Integer
) As Integer
Public Overridable Function Preceding (
    offset As Integer
) As Integer
public:
virtual int Preceding(
    int offset
)
public:
virtual int Preceding(
    int offset
)
abstract Preceding :
        offset : int -> int
override Preceding :
        offset : int -> int
abstract Preceding :
        offset : int -> int
override Preceding :
        offset : int -> int
Parameters
offset (Int32)
the offset to start
Return Value
Int32
int the first boundary after offset


SeparateHyphenWords Property

Keyoti RapidSpell Desktop .NET API Docs
SeparateHyphenWords Property
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► SeparateHyphenWords
Keyoti RapidSpell Desktop .NET
Whether to treat hyphenated (-) words as separate words, default is false.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool SeparateHyphenWords { get; set; }
public bool SeparateHyphenWords { get; set; }
Public Property SeparateHyphenWords As Boolean
    Get
    Set
Public Property SeparateHyphenWords As Boolean
    Get
    Set
public:
property bool SeparateHyphenWords {
    bool get ();
    void set (bool value);
}
public:
property bool SeparateHyphenWords {
    bool get ();
    void set (bool value);
}
member SeparateHyphenWords : bool with get, set

member SeparateHyphenWords : bool with get, set
Property Value
Boolean
Remarks
For eg. if this is true text like "cheap-deals" will be treated as two words "cheap" and "deals", otherwise this will be treated as one word "cheap-deals".


SetText Method (t)

Keyoti RapidSpell Desktop .NET API Docs
SetText Method (t)
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► SetText(String)
Keyoti RapidSpell Desktop .NET
Sets the text to be analysed.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void SetText(
    string t
)
public virtual void SetText(
    string t
)
Public Overridable Sub SetText (
    t As String
)
Public Overridable Sub SetText (
    t As String
)
public:
virtual void SetText(
    String^ t
)
public:
virtual void SetText(
    String^ t
)
abstract SetText :
        t : string -> unit
override SetText :
        t : string -> unit
abstract SetText :
        t : string -> unit
override SetText :
        t : string -> unit
Parameters
t (String)


TextIsStartOfTextBody Property

Keyoti RapidSpell Desktop .NET API Docs
TextIsStartOfTextBody Property
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► TextIsStartOfTextBody
Keyoti RapidSpell Desktop .NET
If known, whether the text to be set in SetText is the start of the text body. Affects sentence determination.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool TextIsStartOfTextBody { get; set; }
public virtual bool TextIsStartOfTextBody { get; set; }
Public Overridable Property TextIsStartOfTextBody As Boolean
    Get
    Set
Public Overridable Property TextIsStartOfTextBody As Boolean
    Get
    Set
public:
virtual property bool TextIsStartOfTextBody {
    bool get ();
    void set (bool value);
}
public:
virtual property bool TextIsStartOfTextBody {
    bool get ();
    void set (bool value);
}
abstract TextIsStartOfTextBody : bool with get, set
override TextIsStartOfTextBody : bool with get, set
abstract TextIsStartOfTextBody : bool with get, set
override TextIsStartOfTextBody : bool with get, set
Property Value
Boolean


theText Field

Keyoti RapidSpell Desktop .NET API Docs
theText Field
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► theText
Keyoti RapidSpell Desktop .NET
The text being parsed.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected string theText
protected string theText
Protected theText As String
Protected theText As String
protected:
String^ theText
protected:
String^ theText
val mutable theText: string
val mutable theText: string
Field Value
String


V2Parser Property

Keyoti RapidSpell Desktop .NET API Docs
V2Parser Property
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► V2Parser
Keyoti RapidSpell Desktop .NET
Whether to use parser version 2
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool V2Parser { get; set; }
public bool V2Parser { get; set; }
Public Property V2Parser As Boolean
    Get
    Set
Public Property V2Parser As Boolean
    Get
    Set
public:
property bool V2Parser {
    bool get ();
    void set (bool value);
}
public:
property bool V2Parser {
    bool get ();
    void set (bool value);
}
member V2Parser : bool with get, set

member V2Parser : bool with get, set
Property Value
Boolean


Keyoti.RapidSpell.Grid Namespace

Keyoti RapidSpell Desktop .NET API Docs
Keyoti.RapidSpell.Grid Namespace
API ► Keyoti.RapidSpell.Grid
Keyoti RapidSpell Desktop .NET
The namespace for grid classes.

Classes for grid support

Types
All Types Classes
Icon | Type | Description
 | AYTDataGridViewTextBoxCell | An as-you-type text box cell for the DataGridView control
 | AYTDataGridViewTextBoxColumn | An as-you-type text box column for the DataGridView control
 | AYTTextEditingControl | As you type version of DataGridVewTextBoxEditingControl
 | DataGridAYTTextBox | As-You-Type enabled TextBox.
 | DataGridAYTTextBoxColumn | Summary description for DataGridAYTTextBoxColumn.
 | DataGridView_AYT_Manager | Control used to couple a DataGridView control with RapidSpellAsYouType.
 | GridUtilities | Utility class for grid controls.
 | SpellCheckableDataGridViewCell | Wraps a DataGridViewCell so that it can be spell checked with RapidSpellDialog.


AYTDataGridViewTextBoxCell Class

Keyoti RapidSpell Desktop .NET API Docs
AYTDataGridViewTextBoxCell Class
API ► Keyoti.RapidSpell.Grid ► AYTDataGridViewTextBoxCell
Keyoti RapidSpell Desktop .NET
An as-you-type text box cell for the DataGridView control
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class AYTDataGridViewTextBoxCell : DataGridViewTextBoxCell
public class AYTDataGridViewTextBoxCell : DataGridViewTextBoxCell
Public Class AYTDataGridViewTextBoxCell
    Inherits DataGridViewTextBoxCell
Public Class AYTDataGridViewTextBoxCell
    Inherits DataGridViewTextBoxCell
public ref class AYTDataGridViewTextBoxCell : public DataGridViewTextBoxCell
public ref class AYTDataGridViewTextBoxCell : public DataGridViewTextBoxCell
type AYTDataGridViewTextBoxCell =
    class
        inherit DataGridViewTextBoxCell
    end
type AYTDataGridViewTextBoxCell =
    class
        inherit DataGridViewTextBoxCell
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AYTDataGridViewTextBoxCell()()()() | Created a new instance
 | AccessibilityObject | Gets the DataGridViewCell..::..DataGridViewCellAccessibleObject assigned to the DataGridViewCell. (Inherited from DataGridViewCell.)
 | AdjustCellBorderStyle(DataGridViewAdvancedBorderStyle, DataGridViewAdvancedBorderStyle, Boolean, Boolean, Boolean, Boolean) | Modifies the input cell border style according to the specified criteria. (Inherited from DataGridViewCell.)
 | BorderWidths(DataGridViewAdvancedBorderStyle) | Returns a Rectangle that represents the widths of all the cell margins. (Inherited from DataGridViewCell.)
 | ClickUnsharesRow(DataGridViewCellEventArgs) | Indicates whether the cell's row will be unshared when the cell is clicked. (Inherited from DataGridViewCell.)
 | Clone()()()() | Creates an exact copy of this cell. (Inherited from DataGridViewTextBoxCell.)
 | ColumnIndex | Gets the column index for this cell. (Inherited from DataGridViewCell.)
 | ContentBounds | Gets the bounding rectangle that encloses the cell's content area. (Inherited from DataGridViewCell.)
 | ContentClickUnsharesRow(DataGridViewCellEventArgs) | Indicates whether the cell's row will be unshared when the cell's content is clicked. (Inherited from DataGridViewCell.)
 | ContentDoubleClickUnsharesRow(DataGridViewCellEventArgs) | Indicates whether the cell's row will be unshared when the cell's content is double-clicked. (Inherited from DataGridViewCell.)
 | ContextMenuStrip | Gets or sets the shortcut menu associated with the cell. (Inherited from DataGridViewCell.)
 | CreateAccessibilityInstance()()()() | (Inherited from DataGridViewTextBoxCell.)
 | DataGridView | Gets the DataGridView control associated with this element. (Inherited from DataGridViewElement.)
 | DefaultNewRowValue | See DataGridViewTextBoxCell.DefaultNewRowValue (Overrides DataGridViewCell.DefaultNewRowValue.)
 | DetachEditingControl()()()() | (Inherited from DataGridViewTextBoxCell.)
 | Displayed | Gets a value that indicates whether the cell is currently displayed on-screen. (Inherited from DataGridViewCell.)
 | Dispose()()()() | Releases all resources used by the DataGridViewCell. (Inherited from DataGridViewCell.)
 | Dispose(Boolean) | Releases the unmanaged resources used by the DataGridViewCell and optionally releases the managed resources. (Inherited from DataGridViewCell.)
 | DoubleClickUnsharesRow(DataGridViewCellEventArgs) | Indicates whether the cell's row will be unshared when the cell is double-clicked. (Inherited from DataGridViewCell.)
 | EditedFormattedValue | Gets the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed. (Inherited from DataGridViewCell.)
 | EditType | See DataGridViewTextBoxCell.EditType (Overrides DataGridViewCell.EditType.)
 | EnterUnsharesRow(Int32, Boolean) | Indicates whether the parent row will be unshared when the focus moves to the cell. (Inherited from DataGridViewCell.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ErrorIconBounds | Gets the bounds of the error icon for the cell. (Inherited from DataGridViewCell.)
 | ErrorText | Gets or sets the text describing an error condition associated with the cell. (Inherited from DataGridViewCell.)
 | Finalize()()()() | Releases the unmanaged resources and performs other cleanup operations before the DataGridViewCell is reclaimed by garbage collection. (Inherited from DataGridViewCell.)
 | FormattedValue | Gets the value of the cell as formatted for display. (Inherited from DataGridViewCell.)
 | FormattedValueType | Gets the type of the formatted value associated with the cell. (Inherited from DataGridViewTextBoxCell.)
 | Frozen | Gets a value indicating whether the cell is frozen. (Inherited from DataGridViewCell.)
 | GetClipboardContent(Int32, Boolean, Boolean, Boolean, Boolean, String) | Retrieves the formatted value of the cell to copy to the Clipboard. (Inherited from DataGridViewCell.)
 | GetContentBounds(Graphics, DataGridViewCellStyle, Int32) | (Inherited from DataGridViewTextBoxCell.)
 | GetContentBounds(Int32) | Returns the bounding rectangle that encloses the cell's content area using a default Graphics and cell style currently in effect for the cell. (Inherited from DataGridViewCell.)
 | GetEditedFormattedValue(Int32, DataGridViewDataErrorContexts) | Returns the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed. (Inherited from DataGridViewCell.)
 | GetErrorIconBounds(Graphics, DataGridViewCellStyle, Int32) | (Inherited from DataGridViewTextBoxCell.)
 | GetErrorText(Int32) | Returns a string that represents the error for the cell. (Inherited from DataGridViewCell.)
 | GetFormattedValue(Object, Int32, DataGridViewCellStyle%, TypeConverter, TypeConverter, DataGridViewDataErrorContexts) | Gets the value of the cell as formatted for display. (Inherited from DataGridViewCell.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInheritedContextMenuStrip(Int32) | Gets the inherited shortcut menu for the current cell. (Inherited from DataGridViewCell.)
 | GetInheritedState(Int32) | Returns a value indicating the current state of the cell as inherited from the state of its row and column. (Inherited from DataGridViewCell.)
 | GetInheritedStyle(DataGridViewCellStyle, Int32, Boolean) | Gets the style applied to the cell. (Inherited from DataGridViewCell.)
 | GetPreferredSize(Graphics, DataGridViewCellStyle, Int32, Size) | (Inherited from DataGridViewTextBoxCell.)
 | GetSize(Int32) | Gets the size of the cell. (Inherited from DataGridViewCell.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GetValue(Int32) | Gets the value of the cell. (Inherited from DataGridViewCell.)
 | HasStyle | Gets a value indicating whether the Style property has been set. (Inherited from DataGridViewCell.)
 | InheritedState | Gets the current state of the cell as inherited from the state of its row and column. (Inherited from DataGridViewCell.)
 | InheritedStyle | Gets the style currently applied to the cell. (Inherited from DataGridViewCell.)
 | InitializeEditingControl(Int32, Object, DataGridViewCellStyle) | See DataGridViewTextBoxCell.InitializeEditingControl (Overrides DataGridViewTextBoxCell.InitializeEditingControl(Int32, Object, DataGridViewCellStyle).)
 | IsInEditMode | Gets a value indicating whether this cell is currently being edited. (Inherited from DataGridViewCell.)
 | KeyDownUnsharesRow(KeyEventArgs, Int32) | Indicates whether the parent row is unshared if the user presses a key while the focus is on the cell. (Inherited from DataGridViewCell.)
 | KeyEntersEditMode(KeyEventArgs) | Determines if edit mode should be started based on the given key. (Inherited from DataGridViewTextBoxCell.)
 | KeyPressUnsharesRow(KeyPressEventArgs, Int32) | Indicates whether a row will be unshared if a key is pressed while a cell in the row has focus. (Inherited from DataGridViewCell.)
 | KeyUpUnsharesRow(KeyEventArgs, Int32) | Indicates whether the parent row is unshared when the user releases a key while the focus is on the cell. (Inherited from DataGridViewCell.)
 | LeaveUnsharesRow(Int32, Boolean) | Indicates whether a row will be unshared when the focus leaves a cell in the row. (Inherited from DataGridViewCell.)
 | MaxInputLength | Gets or sets the maximum number of characters that can be entered into the text box. (Inherited from DataGridViewTextBoxCell.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MouseClickUnsharesRow(DataGridViewCellMouseEventArgs) | Indicates whether a row will be unshared if the user clicks a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell.)
 | MouseDoubleClickUnsharesRow(DataGridViewCellMouseEventArgs) | Indicates whether a row will be unshared if the user double-clicks a cell in the row. (Inherited from DataGridViewCell.)
 | MouseDownUnsharesRow(DataGridViewCellMouseEventArgs) | Indicates whether a row will be unshared when the user holds down a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell.)
 | MouseEnterUnsharesRow(Int32) | Indicates whether a row will be unshared when the mouse pointer moves over a cell in the row. (Inherited from DataGridViewCell.)
 | MouseLeaveUnsharesRow(Int32) | Indicates whether a row will be unshared when the mouse pointer leaves the row. (Inherited from DataGridViewCell.)
 | MouseMoveUnsharesRow(DataGridViewCellMouseEventArgs) | Indicates whether a row will be unshared when the mouse pointer moves over a cell in the row. (Inherited from DataGridViewCell.)
 | MouseUpUnsharesRow(DataGridViewCellMouseEventArgs) | Indicates whether a row will be unshared when the user releases a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell.)
 | OnClick(DataGridViewCellEventArgs) | Called when the cell is clicked. (Inherited from DataGridViewCell.)
 | OnContentClick(DataGridViewCellEventArgs) | Called when the cell's contents are clicked. (Inherited from DataGridViewCell.)
 | OnContentDoubleClick(DataGridViewCellEventArgs) | Called when the cell's contents are double-clicked. (Inherited from DataGridViewCell.)
 | OnDataGridViewChanged()()()() | Called when the DataGridView property of the cell changes. (Inherited from DataGridViewCell.)
 | OnDoubleClick(DataGridViewCellEventArgs) | Called when the cell is double-clicked. (Inherited from DataGridViewCell.)
 | OnEnter(Int32, Boolean) | Called by DataGridView when the selection cursor moves onto a cell. (Inherited from DataGridViewTextBoxCell.)
 | OnKeyDown(KeyEventArgs, Int32) | Called when a character key is pressed while the focus is on a cell. (Inherited from DataGridViewCell.)
 | OnKeyPress(KeyPressEventArgs, Int32) | Called when a key is pressed while the focus is on a cell. (Inherited from DataGridViewCell.)
 | OnKeyUp(KeyEventArgs, Int32) | Called when a character key is released while the focus is on a cell. (Inherited from DataGridViewCell.)
 | OnLeave(Int32, Boolean) | Called by the DataGridView when the mouse leaves a cell. (Inherited from DataGridViewTextBoxCell.)
 | OnMouseClick(DataGridViewCellMouseEventArgs) | Called by DataGridView when the mouse leaves a cell. (Inherited from DataGridViewTextBoxCell.)
 | OnMouseDoubleClick(DataGridViewCellMouseEventArgs) | Called when the user double-clicks a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell.)
 | OnMouseDown(DataGridViewCellMouseEventArgs) | Called when the user holds down a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell.)
 | OnMouseEnter(Int32) | Called when the mouse pointer moves over a cell. (Inherited from DataGridViewCell.)
 | OnMouseLeave(Int32) | Called when the mouse pointer leaves the cell. (Inherited from DataGridViewCell.)
 | OnMouseMove(DataGridViewCellMouseEventArgs) | Called when the mouse pointer moves within a cell. (Inherited from DataGridViewCell.)
 | OnMouseUp(DataGridViewCellMouseEventArgs) | Called when the user releases a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell.)
 | OwningColumn | Gets the column that contains this cell. (Inherited from DataGridViewCell.)
 | OwningRow | Gets the row that contains this cell. (Inherited from DataGridViewCell.)
 | Paint(Graphics, Rectangle, Rectangle, Int32, DataGridViewElementStates, Object, Object, String, DataGridViewCellStyle, DataGridViewAdvancedBorderStyle, DataGridViewPaintParts) | (Inherited from DataGridViewTextBoxCell.)
 | PaintBorder(Graphics, Rectangle, Rectangle, DataGridViewCellStyle, DataGridViewAdvancedBorderStyle) | Paints the border of the current DataGridViewCell. (Inherited from DataGridViewCell.)
 | PaintErrorIcon(Graphics, Rectangle, Rectangle, String) | Paints the error icon of the current DataGridViewCell. (Inherited from DataGridViewCell.)
 | ParseFormattedValue(Object, DataGridViewCellStyle, TypeConverter, TypeConverter) | Converts a value formatted for display to an actual cell value. (Inherited from DataGridViewCell.)
 | PositionEditingControl(Boolean, Boolean, Rectangle, Rectangle, DataGridViewCellStyle, Boolean, Boolean, Boolean, Boolean) | (Inherited from DataGridViewTextBoxCell.)
 | PositionEditingPanel(Rectangle, Rectangle, DataGridViewCellStyle, Boolean, Boolean, Boolean, Boolean) | Sets the location and size of the editing panel hosted by the cell, and returns the normal bounds of the editing control within the editing panel. (Inherited from DataGridViewCell.)
 | PreferredSize | Gets the size, in pixels, of a rectangular area into which the cell can fit. (Inherited from DataGridViewCell.)
 | RaiseCellClick(DataGridViewCellEventArgs) | Raises the CellClick event. (Inherited from DataGridViewElement.)
 | RaiseCellContentClick(DataGridViewCellEventArgs) | Raises the CellContentClick event. (Inherited from DataGridViewElement.)
 | RaiseCellContentDoubleClick(DataGridViewCellEventArgs) | Raises the CellContentDoubleClick event. (Inherited from DataGridViewElement.)
 | RaiseCellValueChanged(DataGridViewCellEventArgs) | Raises the CellValueChanged event. (Inherited from DataGridViewElement.)
 | RaiseDataError(DataGridViewDataErrorEventArgs) | Raises the DataError event. (Inherited from DataGridViewElement.)
 | RaiseMouseWheel(MouseEventArgs) | Raises the MouseWheel event. (Inherited from DataGridViewElement.)
 | ReadOnly | Gets or sets a value indicating whether the cell's data can be edited. (Inherited from DataGridViewCell.)
 | Resizable | Gets a value indicating whether the cell can be resized. (Inherited from DataGridViewCell.)
 | RowIndex | Gets the index of the cell's parent row. (Inherited from DataGridViewCell.)
 | Selected | Gets or sets a value indicating whether the cell has been selected. (Inherited from DataGridViewCell.)
 | SetValue(Int32, Object) | Sets the value of the cell. (Inherited from DataGridViewCell.)
 | Size | Gets the size of the cell. (Inherited from DataGridViewCell.)
 | State | Gets the user interface (UI) state of the element. (Inherited from DataGridViewElement.)
 | Style | Gets or sets the style for the cell. (Inherited from DataGridViewCell.)
 | Tag | Gets or sets the object that contains supplemental data about the cell. (Inherited from DataGridViewCell.)
 | ToolTipText | Gets or sets the ToolTip text associated with this cell. (Inherited from DataGridViewCell.)
 | ToString()()()() | (Inherited from DataGridViewTextBoxCell.)
 | Value | Gets or sets the value associated with this cell. (Inherited from DataGridViewCell.)
 | ValueType | See DataGridViewTextBoxCell.ValueType (Overrides DataGridViewTextBoxCell.ValueType.)
 | Visible | Gets a value indicating whether the cell is in a row or column that has been hidden. (Inherited from DataGridViewCell.)
Inheritance Hierarchy
Object
 | DataGridViewElement
 |  | DataGridViewCell
 |  |  | DataGridViewTextBoxCell
 |  |  |  | AYTDataGridViewTextBoxCell


AYTDataGridViewTextBoxCell Constructor

Keyoti RapidSpell Desktop .NET API Docs
AYTDataGridViewTextBoxCell Constructor
API ► Keyoti.RapidSpell.Grid ► AYTDataGridViewTextBoxCell ► AYTDataGridViewTextBoxCell()()()()
Keyoti RapidSpell Desktop .NET
Created a new instance
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public AYTDataGridViewTextBoxCell()
public AYTDataGridViewTextBoxCell()
Public Sub New
Public Sub New
public:
AYTDataGridViewTextBoxCell()
public:
AYTDataGridViewTextBoxCell()
new : unit -> AYTDataGridViewTextBoxCell
new : unit -> AYTDataGridViewTextBoxCell


DefaultNewRowValue Property

Keyoti RapidSpell Desktop .NET API Docs
DefaultNewRowValue Property
API ► Keyoti.RapidSpell.Grid ► AYTDataGridViewTextBoxCell ► DefaultNewRowValue
Keyoti RapidSpell Desktop .NET
See DataGridViewTextBoxCell.DefaultNewRowValue
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override Object DefaultNewRowValue { get; }
public override Object DefaultNewRowValue { get; }
Public Overrides ReadOnly Property DefaultNewRowValue As Object
    Get
Public Overrides ReadOnly Property DefaultNewRowValue As Object
    Get
public:
virtual property Object^ DefaultNewRowValue {
    Object^ get () override;
}
public:
virtual property Object^ DefaultNewRowValue {
    Object^ get () override;
}
abstract DefaultNewRowValue : Object with get
override DefaultNewRowValue : Object with get
abstract DefaultNewRowValue : Object with get
override DefaultNewRowValue : Object with get
Property Value
Object


EditType Property

Keyoti RapidSpell Desktop .NET API Docs
EditType Property
API ► Keyoti.RapidSpell.Grid ► AYTDataGridViewTextBoxCell ► EditType
Keyoti RapidSpell Desktop .NET
See DataGridViewTextBoxCell.EditType
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override Type EditType { get; }
public override Type EditType { get; }
Public Overrides ReadOnly Property EditType As Type
    Get
Public Overrides ReadOnly Property EditType As Type
    Get
public:
virtual property Type^ EditType {
    Type^ get () override;
}
public:
virtual property Type^ EditType {
    Type^ get () override;
}
abstract EditType : Type with get
override EditType : Type with get
abstract EditType : Type with get
override EditType : Type with get
Property Value
Type


InitializeEditingControl Method (rowIndex, initialFormattedValue, dataGridViewCellStyle)

Keyoti RapidSpell Desktop .NET API Docs
InitializeEditingControl Method (rowIndex, initialFormattedValue, dataGridViewCellStyle)
API ► Keyoti.RapidSpell.Grid ► AYTDataGridViewTextBoxCell ► InitializeEditingControl(Int32, Object, DataGridViewCellStyle)
Keyoti RapidSpell Desktop .NET
See DataGridViewTextBoxCell.InitializeEditingControl
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override void InitializeEditingControl(
    int rowIndex,
    Object initialFormattedValue,
    DataGridViewCellStyle dataGridViewCellStyle
)
public override void InitializeEditingControl(
    int rowIndex,
    Object initialFormattedValue,
    DataGridViewCellStyle dataGridViewCellStyle
)
Public Overrides Sub InitializeEditingControl (
    rowIndex As Integer,
    initialFormattedValue As Object,
    dataGridViewCellStyle As DataGridViewCellStyle
)
Public Overrides Sub InitializeEditingControl (
    rowIndex As Integer,
    initialFormattedValue As Object,
    dataGridViewCellStyle As DataGridViewCellStyle
)
public:
virtual void InitializeEditingControl(
    int rowIndex,
    Object^ initialFormattedValue,
    DataGridViewCellStyle^ dataGridViewCellStyle
) override
public:
virtual void InitializeEditingControl(
    int rowIndex,
    Object^ initialFormattedValue,
    DataGridViewCellStyle^ dataGridViewCellStyle
) override
abstract InitializeEditingControl :
        rowIndex : int *
        initialFormattedValue : Object *
        dataGridViewCellStyle : DataGridViewCellStyle -> unit
override InitializeEditingControl :
        rowIndex : int *
        initialFormattedValue : Object *
        dataGridViewCellStyle : DataGridViewCellStyle -> unit
abstract InitializeEditingControl :
        rowIndex : int *
        initialFormattedValue : Object *
        dataGridViewCellStyle : DataGridViewCellStyle -> unit
override InitializeEditingControl :
        rowIndex : int *
        initialFormattedValue : Object *
        dataGridViewCellStyle : DataGridViewCellStyle -> unit
Parameters
rowIndex (Int32)
initialFormattedValue (Object)
dataGridViewCellStyle (DataGridViewCellStyle)


ValueType Property

Keyoti RapidSpell Desktop .NET API Docs
ValueType Property
API ► Keyoti.RapidSpell.Grid ► AYTDataGridViewTextBoxCell ► ValueType
Keyoti RapidSpell Desktop .NET
See DataGridViewTextBoxCell.ValueType
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override Type ValueType { get; }
public override Type ValueType { get; }
Public Overrides ReadOnly Property ValueType As Type
    Get
Public Overrides ReadOnly Property ValueType As Type
    Get
public:
virtual property Type^ ValueType {
    Type^ get () override;
}
public:
virtual property Type^ ValueType {
    Type^ get () override;
}
abstract ValueType : Type with get
override ValueType : Type with get
abstract ValueType : Type with get
override ValueType : Type with get
Property Value
Type


AYTDataGridViewTextBoxColumn Class

Keyoti RapidSpell Desktop .NET API Docs
AYTDataGridViewTextBoxColumn Class
API ► Keyoti.RapidSpell.Grid ► AYTDataGridViewTextBoxColumn
Keyoti RapidSpell Desktop .NET
An as-you-type text box column for the DataGridView control
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class AYTDataGridViewTextBoxColumn : DataGridViewTextBoxColumn
public class AYTDataGridViewTextBoxColumn : DataGridViewTextBoxColumn
Public Class AYTDataGridViewTextBoxColumn
    Inherits DataGridViewTextBoxColumn
Public Class AYTDataGridViewTextBoxColumn
    Inherits DataGridViewTextBoxColumn
public ref class AYTDataGridViewTextBoxColumn : public DataGridViewTextBoxColumn
public ref class AYTDataGridViewTextBoxColumn : public DataGridViewTextBoxColumn
type AYTDataGridViewTextBoxColumn =
    class
        inherit DataGridViewTextBoxColumn
    end
type AYTDataGridViewTextBoxColumn =
    class
        inherit DataGridViewTextBoxColumn
    end
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AYTDataGridViewTextBoxColumn()()()() | Created a new instance
 | AutoSizeMode | Gets or sets the mode by which the column automatically adjusts its width. (Inherited from DataGridViewColumn.)
 | CellTemplate | See DataGridViewColumn.CellTemplate (Overrides DataGridViewTextBoxColumn.CellTemplate.)
 | CellType | Gets the run-time type of the cell template. (Inherited from DataGridViewColumn.)
 | Clone()()()() | (Inherited from DataGridViewColumn.)
 | ContextMenuStrip | Gets or sets the shortcut menu for the column. (Inherited from DataGridViewColumn.)
 | DataGridView | Gets the DataGridView control associated with this element. (Inherited from DataGridViewElement.)
 | DataPropertyName | Gets or sets the name of the data source property or database column to which the DataGridViewColumn is bound. (Inherited from DataGridViewColumn.)
 | DefaultCellStyle | Gets or sets the column's default cell style. (Inherited from DataGridViewColumn.)
 | DefaultHeaderCellType | Gets or sets the run-time type of the default header cell. (Inherited from DataGridViewBand.)
 | Displayed | Gets a value indicating whether the band is currently displayed onscreen. (Inherited from DataGridViewBand.)
 | DisplayIndex | Gets or sets the display order of the column relative to the currently displayed columns. (Inherited from DataGridViewColumn.)
 | Dispose(Boolean) | (Inherited from DataGridViewColumn.)
 | Dispose()()()() | Releases all resources used by the DataGridViewBand. (Inherited from DataGridViewBand.)
 | Disposed | Occurs when the DataGridViewColumn is disposed. (Inherited from DataGridViewColumn.)
 | DividerWidth | Gets or sets the width, in pixels, of the column divider. (Inherited from DataGridViewColumn.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FillWeight | Gets or sets a value that represents the width of the column when it is in fill mode relative to the widths of other fill-mode columns in the control. (Inherited from DataGridViewColumn.)
 | Finalize()()()() | Releases the resources associated with the band. (Inherited from DataGridViewBand.)
 | Frozen | Gets or sets a value indicating whether a column will move when a user scrolls the DataGridView control horizontally. (Inherited from DataGridViewColumn.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPreferredWidth(DataGridViewAutoSizeColumnMode, Boolean) | Calculates the ideal width of the column based on the specified criteria. (Inherited from DataGridViewColumn.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | HasDefaultCellStyle | Gets a value indicating whether the DefaultCellStyle property has been set. (Inherited from DataGridViewBand.)
 | HeaderCell | Gets or sets the DataGridViewColumnHeaderCell that represents the column header. (Inherited from DataGridViewColumn.)
 | HeaderCellCore | Gets or sets the header cell of the DataGridViewBand. (Inherited from DataGridViewBand.)
 | HeaderText | Gets or sets the caption text on the column's header cell. (Inherited from DataGridViewColumn.)
 | Index | Gets the relative position of the band within the DataGridView control. (Inherited from DataGridViewBand.)
 | InheritedAutoSizeMode | Gets the sizing mode in effect for the column. (Inherited from DataGridViewColumn.)
 | InheritedStyle | Gets the cell style currently applied to the column. (Inherited from DataGridViewColumn.)
 | IsDataBound | Gets a value indicating whether the column is bound to a data source. (Inherited from DataGridViewColumn.)
 | IsRow | Gets a value indicating whether the band represents a row. (Inherited from DataGridViewBand.)
 | MaxInputLength | Gets or sets the maximum number of characters that can be entered into the text box. (Inherited from DataGridViewTextBoxColumn.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinimumWidth | Gets or sets the minimum width, in pixels, of the column. (Inherited from DataGridViewColumn.)
 | Name | Gets or sets the name of the column. (Inherited from DataGridViewColumn.)
 | OnDataGridViewChanged()()()() | Called when the band is associated with a different DataGridView. (Inherited from DataGridViewBand.)
 | RaiseCellClick(DataGridViewCellEventArgs) | Raises the CellClick event. (Inherited from DataGridViewElement.)
 | RaiseCellContentClick(DataGridViewCellEventArgs) | Raises the CellContentClick event. (Inherited from DataGridViewElement.)
 | RaiseCellContentDoubleClick(DataGridViewCellEventArgs) | Raises the CellContentDoubleClick event. (Inherited from DataGridViewElement.)
 | RaiseCellValueChanged(DataGridViewCellEventArgs) | Raises the CellValueChanged event. (Inherited from DataGridViewElement.)
 | RaiseDataError(DataGridViewDataErrorEventArgs) | Raises the DataError event. (Inherited from DataGridViewElement.)
 | RaiseMouseWheel(MouseEventArgs) | Raises the MouseWheel event. (Inherited from DataGridViewElement.)
 | ReadOnly | Gets or sets a value indicating whether the user can edit the column's cells. (Inherited from DataGridViewColumn.)
 | Resizable | Gets or sets a value indicating whether the column is resizable. (Inherited from DataGridViewColumn.)
 | Selected | Gets or sets a value indicating whether the band is in a selected user interface (UI) state. (Inherited from DataGridViewBand.)
 | Site | Gets or sets the site of the column. (Inherited from DataGridViewColumn.)
 | SortMode | Gets or sets the sort mode for the column. (Inherited from DataGridViewTextBoxColumn.)
 | State | Gets the user interface (UI) state of the element. (Inherited from DataGridViewElement.)
 | Tag | Gets or sets the object that contains data to associate with the band. (Inherited from DataGridViewBand.)
 | ToolTipText | Gets or sets the text used for ToolTips. (Inherited from DataGridViewColumn.)
 | ToString()()()() | (Inherited from DataGridViewTextBoxColumn.)
 | ValueType | Gets or sets the data type of the values in the column's cells. (Inherited from DataGridViewColumn.)
 | Visible | Gets or sets a value indicating whether the column is visible. (Inherited from DataGridViewColumn.)
 | Width | Gets or sets the current width of the column. (Inherited from DataGridViewColumn.)
Inheritance Hierarchy
Object
 | DataGridViewElement
 |  | DataGridViewBand
 |  |  | DataGridViewColumn
 |  |  |  | DataGridViewTextBoxColumn
 |  |  |  |  | AYTDataGridViewTextBoxColumn


AYTDataGridViewTextBoxColumn Constructor

Keyoti RapidSpell Desktop .NET API Docs
AYTDataGridViewTextBoxColumn Constructor
API ► Keyoti.RapidSpell.Grid ► AYTDataGridViewTextBoxColumn ► AYTDataGridViewTextBoxColumn()()()()
Keyoti RapidSpell Desktop .NET
Created a new instance
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public AYTDataGridViewTextBoxColumn()
public AYTDataGridViewTextBoxColumn()
Public Sub New
Public Sub New
public:
AYTDataGridViewTextBoxColumn()
public:
AYTDataGridViewTextBoxColumn()
new : unit -> AYTDataGridViewTextBoxColumn
new : unit -> AYTDataGridViewTextBoxColumn


CellTemplate Property

Keyoti RapidSpell Desktop .NET API Docs
CellTemplate Property
API ► Keyoti.RapidSpell.Grid ► AYTDataGridViewTextBoxColumn ► CellTemplate
Keyoti RapidSpell Desktop .NET
See DataGridViewColumn.CellTemplate
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override DataGridViewCell CellTemplate { get; set; }
public override DataGridViewCell CellTemplate { get; set; }
Public Overrides Property CellTemplate As DataGridViewCell
    Get
    Set
Public Overrides Property CellTemplate As DataGridViewCell
    Get
    Set
public:
virtual property DataGridViewCell^ CellTemplate {
    DataGridViewCell^ get () override;
    void set (DataGridViewCell^ value) override;
}
public:
virtual property DataGridViewCell^ CellTemplate {
    DataGridViewCell^ get () override;
    void set (DataGridViewCell^ value) override;
}
abstract CellTemplate : DataGridViewCell with get, set
override CellTemplate : DataGridViewCell with get, set
abstract CellTemplate : DataGridViewCell with get, set
override CellTemplate : DataGridViewCell with get, set
Property Value
DataGridViewCell


AYTTextEditingControl Class

Keyoti RapidSpell Desktop .NET API Docs
AYTTextEditingControl Class
API ► Keyoti.RapidSpell.Grid ► AYTTextEditingControl
Keyoti RapidSpell Desktop .NET
As you type version of DataGridVewTextBoxEditingControl
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class AYTTextEditingControl : AYTTextBox,
    IDataGridViewEditingControl
public class AYTTextEditingControl : AYTTextBox,
    IDataGridViewEditingControl
Public Class AYTTextEditingControl
    Inherits AYTTextBox
    Implements IDataGridViewEditingControl
Public Class AYTTextEditingControl
    Inherits AYTTextBox
    Implements IDataGridViewEditingControl
public ref class AYTTextEditingControl : public AYTTextBox,
    IDataGridViewEditingControl
public ref class AYTTextEditingControl : public AYTTextBox,
    IDataGridViewEditingControl
type AYTTextEditingControl =
    class
        inherit AYTTextBox
        interface IDataGridViewEditingControl
    end
type AYTTextEditingControl =
    class
        inherit AYTTextBox
        interface IDataGridViewEditingControl
    end
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AYTTextEditingControl()()()() | Initializes a new instance of the DataGridViewTextBoxEditingControl class.
 | AcceptsReturn | Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form. (Inherited from TextBox.)
 | AcceptsTab | Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order. (Inherited from TextBoxBase.)
 | AcceptsTabChanged | Occurs when the value of the AcceptsTab property has changed. (Inherited from TextBoxBase.)
 | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
 | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
 | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
 | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
 | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
 | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
 | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
 | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
 | AppendText(String) | Appends text to the current text of a text box. (Inherited from TextBoxBase.)
 | ApplyCellStyleToEditingControl(DataGridViewCellStyle) | Changes the control's user interface (UI) to be consistent with the specified cell style.
 | AutoCompleteCustomSource | Gets or sets a custom StringCollection to use when the AutoCompleteSource property is set to CustomSource. (Inherited from TextBox.)
 | AutoCompleteMode | Gets or sets an option that controls how automatic completion works for the TextBox. (Inherited from TextBox.)
 | AutoCompleteSource | Gets or sets a value specifying the source of complete strings used for automatic completion. (Inherited from TextBox.)
 | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
 | AutoSize | Gets or sets a value indicating whether the height of the control automatically adjusts when the font assigned to the control is changed. (Inherited from TextBoxBase.)
 | AutoSizeChanged | This event is not relevant for this class. (Inherited from TextBoxBase.)
 | BackColor | Gets or sets the background color of the control. (Inherited from TextBoxBase.)
 | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
 | BackgroundImage | This property is not relevant for this class. (Inherited from TextBoxBase.)
 | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. This event is not relevant for this class. (Inherited from TextBoxBase.)
 | BackgroundImageLayout | This property is not relevant for this class. (Inherited from TextBoxBase.)
 | BackgroundImageLayoutChanged | Occurs when the value of the BackgroundImageLayout property changes. This event is not relevant for this class. (Inherited from TextBoxBase.)
 | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
 | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
 | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
 | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
 | BorderStyle | Gets or sets the border type of the text box control. (Inherited from TextBoxBase.)
 | BorderStyleChanged | Occurs when the value of the BorderStyle property has changed. (Inherited from TextBoxBase.)
 | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
 | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
 | BringToFront()()()() | Brings the control to the front of the z-order. (Inherited from Control.)
 | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from TextBoxBase.)
 | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
 | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
 | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
 | CanUndo | Gets a value indicating whether the user can undo the previous operation in a text box control. (Inherited from TextBoxBase.)
 | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
 | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
 | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
 | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
 | CharacterCasing | Gets or sets whether the TextBox control modifies the case of characters as they are typed. (Inherited from TextBox.)
 | Clear()()()() | Clears all text from the text box control. (Inherited from TextBoxBase.)
 | ClearUndo()()()() | Clears information about the most recent operation from the undo buffer of the text box. (Inherited from TextBoxBase.)
 | Click | Occurs when the text box is clicked. (Inherited from TextBoxBase.)
 | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
 | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
 | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
 | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | Contains(Control) | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
 | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
 | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
 | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
 | ContextMenuDefault | The context menu that will be shown when the right click is not on a misspelled word. (Inherited from AYTTextBox.)
 | ContextMenuStrip | The context menu that will be shown when the right click is not on a misspelled word. (Inherited from AYTTextBox.)
 | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
 | ContextMenuStripDefault | The context menu that will be shown when the right click is not on a misspelled word. (Inherited from AYTTextBox.)
 | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
 | ControlBackgroundPaint | Event fired when Windows level background repaint occurs. (Inherited from AYTTextBox.)
 | ControlPaint | Event fired when Windows level repaint occurs. (Inherited from AYTTextBox.)
 | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
 | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
 | Copy()()()() | Copies the current selection in the text box to the Clipboard. (Inherited from TextBoxBase.)
 | CreateAccessibilityInstance()()()() | Creates a new accessibility object for the control. (Inherited from Control.)
 | CreateControl()()()() | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
 | CreateControlsInstance()()()() | Creates a new instance of the control collection for the control. (Inherited from Control.)
 | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
 | CreateGraphics()()()() | Creates the Graphics for the control. (Inherited from Control.)
 | CreateHandle()()()() | (Inherited from TextBoxBase.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateParams | (Inherited from TextBox.)
 | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
 | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
 | Cut()()()() | Moves the current selection in the text box to the Clipboard. (Inherited from TextBoxBase.)
 | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
 | DefaultContextMenu | Obsolete. Obsolete - Use ContextMenuDefault instead. (Inherited from AYTTextBox.)
 | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from TextBoxBase.)
 | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
 | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
 | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
 | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
 | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
 | DefaultSize | (Inherited from TextBoxBase.)
 | DefWndProc(Message%) | Sends the specified message to the default window procedure. (Inherited from Control.)
 | DeselectAll()()()() | Specifies that the value of the SelectionLength property is zero so that no characters are selected in the control. (Inherited from TextBoxBase.)
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | DestroyHandle()()()() | Destroys the handle associated with the control. (Inherited from Control.)
 | DeviceDpi()()()() | (Inherited from Control.)
 | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
 | Dispose(Boolean) | Releases the unmanaged resources used by the TextBox and optionally releases the managed resources. (Inherited from TextBox.)
 | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
 | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
 | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
 | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
 | DoDragDrop(Object, DragDropEffects) | Begins a drag-and-drop operation. (Inherited from Control.)
 | DoubleBuffered | Gets or sets a value indicating whether control drawing is done in a buffer before the control is displayed. This property is not relevant for this class. (Inherited from TextBoxBase.)
 | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
 | DpiChangedAfterParent()()()() | (Inherited from Control.)
 | DpiChangedBeforeParent()()()() | (Inherited from Control.)
 | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
 | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
 | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
 | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
 | DrawToBitmap(Bitmap, Rectangle) | Supports rendering to the specified bitmap. (Inherited from Control.)
 | EditingControlDataGridView | Gets or sets the DataGridView that contains the text box control.
 | EditingControlFormattedValue | Gets or sets the formatted representation of the current value of the text box control.
 | EditingControlRowIndex | Gets or sets the index of the owning cell's parent row.
 | EditingControlValueChanged | Gets or sets a value indicating whether the current value of the text box control has changed.
 | EditingControlWantsInputKey(Keys, Boolean) | Determines whether the specified key is a regular input key that the editing control should process or a special key that the DataGridView should process.
 | EditingPanelCursor | Gets the cursor used when the mouse pointer is over the EditingPanel but not over the editing control.
 | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
 | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
 | EndInvoke(IAsyncResult) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
 | Enter | Occurs when the control is entered. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | Finalize()()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | FindForm()()()() | Retrieves the form that the control is on. (Inherited from Control.)
 | Focus()()()() | Sets input focus to the control. (Inherited from Control.)
 | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
 | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
 | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
 | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color of the control. (Inherited from TextBoxBase.)
 | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
 | FormatChanged | Event fired when formatting changes (such as font change). (Inherited from AYTTextBox.)
 | GetAccessibilityObjectById(Int32) | Retrieves the specified AccessibleObject. (Inherited from Control.)
 | GetAutoSizeMode()()()() | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
 | GetBaselineOffsetAtCharIndex(Int32) | Gets the baseline offset for a character at index i (Inherited from AYTTextBox.)
 | GetCharFromPosition(Point) | Retrieves the character that is closest to the specified location within the control. (Inherited from TextBoxBase.)
 | GetCharIndexFromPos(Point) | gets the char index from a position point. (Inherited from AYTTextBox.)
 | GetCharIndexFromPosition(Point) | Retrieves the index of the character nearest to the specified location. (Inherited from TextBoxBase.)
 | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
 | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
 | GetContainerControl()()()() | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
 | GetEditingControlFormattedValue(DataGridViewDataErrorContexts) | Retrieves the formatted value of the cell.
 | GetFirstCharIndexFromLine(Int32) | Retrieves the index of the first character of a given line. (Inherited from TextBoxBase.)
 | GetFirstCharIndexOfCurrentLine()()()() | Retrieves the index of the first character of the current line. (Inherited from TextBoxBase.)
 | GetFirstVisibleCharIndex()()()() | Gets the character index of the first visible character in the window, this is for optimization and can just return 0 if unavailable. (Inherited from AYTTextBox.)
 | GetFocusOnContextMenu | Whether to get focus when the user activates the context menu. (Inherited from AYTTextBox.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetLineFromCharIndex(Int32) | Retrieves the line number from the specified character position within the text of the control. (Inherited from TextBoxBase.)
 | GetNextControl(Control, Boolean) | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
 | GetPosFromCharIndex(Int32) | Gets the position point from the char index (Inherited from AYTTextBox.)
 | GetPositionFromCharIndex(Int32) | Retrieves the location within the control at the specified character index. (Inherited from TextBoxBase.)
 | GetPreferredSize(Size) | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
 | GetScaledBounds(Rectangle, SizeF, BoundsSpecified) | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetStyle(ControlStyles) | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
 | GetTBU()()()() | Interface requirement (Inherited from AYTTextBox.)
 | GetTopLevel()()()() | Determines if the control is a top-level control. (Inherited from Control.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
 | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
 | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
 | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
 | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
 | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the control. (Inherited from Control.)
 | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
 | Hide()()()() | Conceals the control from the user. (Inherited from Control.)
 | HideSelection | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus. (Inherited from TextBoxBase.)
 | HideSelectionChanged | Occurs when the value of the HideSelection property has changed. (Inherited from TextBoxBase.)
 | HScrolled | Event fired when horizontal scroll changed (by anything). (Inherited from AYTTextBox.)
 | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
 | ImeModeBase | (Inherited from TextBoxBase.)
 | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | InitLayout()()()() | Called after the control has been added to another container. (Inherited from Control.)
 | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
 | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
 | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
 | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
 | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
 | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
 | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
 | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
 | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
 | InvokeGotFocus(Control, EventArgs) | Raises the GotFocus event for the specified control. (Inherited from Control.)
 | InvokeLostFocus(Control, EventArgs) | Raises the LostFocus event for the specified control. (Inherited from Control.)
 | InvokeOnClick(Control, EventArgs) | Raises the Click event for the specified control. (Inherited from Control.)
 | InvokePaint(Control, PaintEventArgs) | Raises the Paint event for the specified control. (Inherited from Control.)
 | InvokePaintBackground(Control, PaintEventArgs) | Raises the PaintBackground event for the specified control. (Inherited from Control.)
 | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
 | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
 | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
 | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
 | IsInputChar(Char) | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
 | IsInputKey(Keys) | Determines whether the specified key is an input key or a special key that requires preprocessing. (Inherited from TextBox.)
 | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
 | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
 | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
 | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
 | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
 | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
 | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
 | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
 | Lines | Gets or sets the lines of text in a text box control. (Inherited from TextBoxBase.)
 | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
 | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
 | LogicalToDeviceUnits(Int32) | (Inherited from Control.)
 | LogicalToDeviceUnits(Size) | (Inherited from Control.)
 | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
 | Margin | Gets or sets the space between controls. (Inherited from Control.)
 | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
 | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
 | MaxLength | Gets or sets the maximum number of characters the user can type or paste into the text box control. (Inherited from TextBoxBase.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
 | Modified | Gets or sets a value that indicates that the text box control has been modified by the user since the control was created or its contents were last set. (Inherited from TextBoxBase.)
 | ModifiedChanged | Occurs when the value of the Modified property has changed. (Inherited from TextBoxBase.)
 | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
 | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from TextBoxBase.)
 | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
 | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
 | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
 | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
 | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
 | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
 | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
 | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
 | Move | Occurs when the control is moved. (Inherited from Control.)
 | Multiline | Gets or sets a value indicating whether this is a multiline TextBox control. (Inherited from TextBox.)
 | MultilineChanged | Occurs when the value of the Multiline property has changed. (Inherited from TextBoxBase.)
 | Name | Gets or sets the name of the control. (Inherited from Control.)
 | NotifyInvalidate(Rectangle) | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
 | OnAcceptsTabChanged(EventArgs) | Raises the AcceptsTabChanged event. (Inherited from TextBoxBase.)
 | OnAutoSizeChanged(EventArgs) | Raises the AutoSizeChanged event. (Inherited from Control.)
 | OnBackColorChanged(EventArgs) | Raises the BackColorChanged event. (Inherited from TextBox.)
 | OnBackgroundImageChanged(EventArgs) | Raises the BackgroundImageChanged event. (Inherited from Control.)
 | OnBackgroundImageLayoutChanged(EventArgs) | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
 | OnBindingContextChanged(EventArgs) | Raises the BindingContextChanged event. (Inherited from Control.)
 | OnBorderStyleChanged(EventArgs) | Raises the BorderStyleChanged event. (Inherited from TextBoxBase.)
 | OnCausesValidationChanged(EventArgs) | Raises the CausesValidationChanged event. (Inherited from Control.)
 | OnChangeUICues(UICuesEventArgs) | Raises the ChangeUICues event. (Inherited from Control.)
 | OnClick(EventArgs) | Raises the Click event. (Inherited from Control.)
 | OnClientSizeChanged(EventArgs) | Raises the ClientSizeChanged event. (Inherited from Control.)
 | OnContextMenuChanged(EventArgs) | Raises the ContextMenuChanged event. (Inherited from Control.)
 | OnContextMenuStripChanged(EventArgs) | Raises the ContextMenuStripChanged event. (Inherited from Control.)
 | OnControlAdded(ControlEventArgs) | Raises the ControlAdded event. (Inherited from Control.)
 | OnControlRemoved(ControlEventArgs) | Raises the ControlRemoved event. (Inherited from Control.)
 | OnCreateControl()()()() | Raises the CreateControl()()()() method. (Inherited from Control.)
 | OnCursorChanged(EventArgs) | Raises the CursorChanged event. (Inherited from Control.)
 | OnDockChanged(EventArgs) | Raises the DockChanged event. (Inherited from Control.)
 | OnDoubleClick(EventArgs) | Raises the DoubleClick event. (Inherited from Control.)
 | OnDpiChangedAfterParent(EventArgs) | (Inherited from Control.)
 | OnDpiChangedBeforeParent(EventArgs) | (Inherited from Control.)
 | OnDragDrop(DragEventArgs) | Raises the DragDrop event. (Inherited from Control.)
 | OnDragEnter(DragEventArgs) | Raises the DragEnter event. (Inherited from Control.)
 | OnDragLeave(EventArgs) | Raises the DragLeave event. (Inherited from Control.)
 | OnDragOver(DragEventArgs) | Raises the DragOver event. (Inherited from Control.)
 | OnEnabledChanged(EventArgs) | Raises the EnabledChanged event. (Inherited from Control.)
 | OnEnter(EventArgs) | Raises the Enter event. (Inherited from Control.)
 | OnFontChanged(EventArgs) | Raises the FontChanged event. (Inherited from TextBox.)
 | OnForeColorChanged(EventArgs) | Raises the ForeColorChanged event. (Inherited from Control.)
 | OnGiveFeedback(GiveFeedbackEventArgs) | Raises the GiveFeedback event. (Inherited from Control.)
 | OnGotFocus(EventArgs) | Raises the GotFocus event. (Inherited from TextBox.)
 | OnHandleCreated(EventArgs) | (Inherited from TextBox.)
 | OnHandleDestroyed(EventArgs) | Raises the OnHandleDestroyed(EventArgs) event. (Inherited from TextBox.)
 | OnHelpRequested(HelpEventArgs) | Raises the HelpRequested event. (Inherited from Control.)
 | OnHideSelectionChanged(EventArgs) | Raise the HideSelectionChanged event. (Inherited from TextBoxBase.)
 | OnImeModeChanged(EventArgs) | Raises the ImeModeChanged event. (Inherited from Control.)
 | OnInvalidated(InvalidateEventArgs) | Raises the Invalidated event. (Inherited from Control.)
 | OnKeyDown(KeyEventArgs) | Raises the KeyDown event. (Inherited from Control.)
 | OnKeyPress(KeyPressEventArgs) | Raises the KeyPress event. (Inherited from Control.)
 | OnKeyUp(KeyEventArgs) | Raises the KeyUp event. (Inherited from Control.)
 | OnLayout(LayoutEventArgs) | Raises the Layout event. (Inherited from Control.)
 | OnLeave(EventArgs) | Raises the Leave event. (Inherited from Control.)
 | OnLocationChanged(EventArgs) | Raises the LocationChanged event. (Inherited from Control.)
 | OnLostFocus(EventArgs) | Raises the LostFocus event. (Inherited from Control.)
 | OnMarginChanged(EventArgs) | Raises the MarginChanged event. (Inherited from Control.)
 | OnModifiedChanged(EventArgs) | Raises the ModifiedChanged event. (Inherited from TextBoxBase.)
 | OnMouseCaptureChanged(EventArgs) | Raises the MouseCaptureChanged event. (Inherited from Control.)
 | OnMouseClick(MouseEventArgs) | Raises the MouseClick event. (Inherited from Control.)
 | OnMouseDoubleClick(MouseEventArgs) | Raises the MouseDoubleClick event. (Inherited from Control.)
 | OnMouseDown(MouseEventArgs) | Raises the MouseDown event. (Inherited from Control.)
 | OnMouseEnter(EventArgs) | Raises the MouseEnter event. (Inherited from Control.)
 | OnMouseHover(EventArgs) | Raises the MouseHover event. (Inherited from Control.)
 | OnMouseLeave(EventArgs) | Raises the MouseLeave event. (Inherited from Control.)
 | OnMouseMove(MouseEventArgs) | Raises the MouseMove event. (Inherited from Control.)
 | OnMouseUp(MouseEventArgs) | (Inherited from TextBoxBase.)
 | OnMouseWheel(MouseEventArgs) | (Overrides Control.OnMouseWheel(MouseEventArgs).)
 | OnMove(EventArgs) | Raises the Move event. (Inherited from Control.)
 | OnMultilineChanged(EventArgs) | Raises the MultilineChanged event. (Inherited from TextBoxBase.)
 | OnNotifyMessage(Message) | Notifies the control of Windows messages. (Inherited from Control.)
 | OnPaddingChanged(EventArgs) | This method is not relevant for this class. (Inherited from TextBoxBase.)
 | OnPaint(PaintEventArgs) | Raises the Paint event. (Inherited from Control.)
 | OnPaintBackground(PaintEventArgs) | Paints the background of the control. (Inherited from Control.)
 | OnParentBackColorChanged(EventArgs) | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
 | OnParentBackgroundImageChanged(EventArgs) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
 | OnParentBindingContextChanged(EventArgs) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
 | OnParentChanged(EventArgs) | Raises the ParentChanged event. (Inherited from Control.)
 | OnParentCursorChanged(EventArgs) | Raises the CursorChanged event. (Inherited from Control.)
 | OnParentEnabledChanged(EventArgs) | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
 | OnParentFontChanged(EventArgs) | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
 | OnParentForeColorChanged(EventArgs) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
 | OnParentRightToLeftChanged(EventArgs) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
 | OnParentVisibleChanged(EventArgs) | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
 | OnPreviewKeyDown(PreviewKeyDownEventArgs) | Raises the PreviewKeyDown event. (Inherited from Control.)
 | OnPrint(PaintEventArgs) | Raises the Paint event. (Inherited from Control.)
 | OnQueryContinueDrag(QueryContinueDragEventArgs) | Raises the QueryContinueDrag event. (Inherited from Control.)
 | OnReadOnlyChanged(EventArgs) | Raises the ReadOnlyChanged event. (Inherited from TextBoxBase.)
 | OnRegionChanged(EventArgs) | Raises the RegionChanged event. (Inherited from Control.)
 | OnResize(EventArgs) | Raises the Resize event. (Inherited from Control.)
 | OnRightToLeftChanged(EventArgs) | Raises the RightToLeftChanged event. (Inherited from Control.)
 | OnSizeChanged(EventArgs) | Raises the SizeChanged event. (Inherited from Control.)
 | OnStyleChanged(EventArgs) | Raises the StyleChanged event. (Inherited from Control.)
 | OnSystemColorsChanged(EventArgs) | Raises the SystemColorsChanged event. (Inherited from Control.)
 | OnTabIndexChanged(EventArgs) | Raises the TabIndexChanged event. (Inherited from Control.)
 | OnTabStopChanged(EventArgs) | Raises the TabStopChanged event. (Inherited from Control.)
 | OnTextAlignChanged(EventArgs) | Raises the TextAlignChanged event. (Inherited from TextBox.)
 | OnTextChanged(EventArgs) | Internal (Overrides TextBoxBase.OnTextChanged(EventArgs).)
 | OnValidated(EventArgs) | Raises the Validated event. (Inherited from Control.)
 | OnValidating(CancelEventArgs) | Raises the Validating event. (Inherited from Control.)
 | OnVisibleChanged(EventArgs) | Raises the VisibleChanged event. (Inherited from Control.)
 | Padding | This property is not relevant for this class. (Inherited from TextBoxBase.)
 | PaddingChanged | This event is not relevant for this class. (Inherited from TextBoxBase.)
 | Paint | Occurs when the control is redrawn. This event is not relevant for this class. (Inherited from TextBoxBase.)
 | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
 | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
 | PasswordChar | Gets or sets the character used to mask characters of a password in a single-line TextBox control. (Inherited from TextBox.)
 | Paste(String) | Sets the selected text to the specified text without clearing the undo buffer. (Inherited from TextBox.)
 | Paste()()()() | Replaces the current selection in the text box with the contents of the Clipboard. (Inherited from TextBoxBase.)
 | Pasting | Occurs when text is about to be pasted. (Inherited from AYTTextBox.)
 | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
 | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
 | PointToClient(Point) | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
 | PointToScreen(Point) | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
 | PreferredHeight | Gets the preferred height for a text box. (Inherited from TextBoxBase.)
 | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
 | PrepareEditingControlForEdit(Boolean) | Prepares the currently selected cell for editing.
 | PreProcessControlMessage(Message%) | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
 | PreProcessMessage(Message%) | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
 | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
 | ProcessCmdKey(Message%, Keys) | (Inherited from TextBox.)
 | ProcessDialogChar(Char) | Processes a dialog character. (Inherited from Control.)
 | ProcessDialogKey(Keys) | (Inherited from TextBoxBase.)
 | ProcessKeyEventArgs(Message%) | Processes key events. (Overrides Control.ProcessKeyEventArgs(Message%).)
 | ProcessKeyMessage(Message%) | Processes a keyboard message. (Inherited from Control.)
 | ProcessKeyPreview(Message%) | Previews a keyboard message. (Inherited from Control.)
 | ProcessMnemonic(Char) | Processes a mnemonic character. (Inherited from Control.)
 | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
 | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
 | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
 | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
 | RaiseDragEvent(Object, DragEventArgs) | Raises the appropriate drag event. (Inherited from Control.)
 | RaiseKeyEvent(Object, KeyEventArgs) | Raises the appropriate key event. (Inherited from Control.)
 | RaiseMouseEvent(Object, MouseEventArgs) | Raises the appropriate mouse event. (Inherited from Control.)
 | RaisePaintEvent(Object, PaintEventArgs) | Raises the appropriate paint event. (Inherited from Control.)
 | ReadOnly | Gets or sets a value indicating whether text in the text box is read-only. (Inherited from TextBoxBase.)
 | ReadOnlyChanged | Occurs when the value of the ReadOnly property has changed. (Inherited from TextBoxBase.)
 | RecreateHandle()()()() | Forces the re-creation of the handle for the control. (Inherited from Control.)
 | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
 | RectangleToClient(Rectangle) | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
 | RectangleToScreen(Rectangle) | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
 | Refresh()()()() | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
 | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
 | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
 | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
 | RepositionEditingControlOnValueChange | Gets a value indicating whether the cell contents need to be repositioned whenever the value changes.
 | RescaleConstantsForDpi(Int32, Int32) | (Inherited from Control.)
 | ResetBackColor()()()() | Resets the BackColor property to its default value. (Inherited from Control.)
 | ResetBindings()()()() | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
 | ResetCursor()()()() | Resets the Cursor property to its default value. (Inherited from Control.)
 | ResetFont()()()() | Resets the Font property to its default value. (Inherited from Control.)
 | ResetForeColor()()()() | Resets the ForeColor property to its default value. (Inherited from Control.)
 | ResetImeMode()()()() | Resets the ImeMode property to its default value. (Inherited from Control.)
 | ResetMouseEventArgs()()()() | Resets the control to handle the MouseLeave event. (Inherited from Control.)
 | ResetRightToLeft()()()() | Resets the RightToLeft property to its default value. (Inherited from Control.)
 | ResetText()()()() | Resets the Text property to its default value. (Inherited from Control.)
 | Resize | Occurs when the control is resized. (Inherited from Control.)
 | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
 | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
 | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
 | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
 | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
 | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
 | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateContent(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateHorizontal(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateLeftRight(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
 | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
 | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
 | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
 | ScaleBitmapLogicalToDevice(Bitmap%) | (Inherited from Control.)
 | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
 | ScaleControl(SizeF, BoundsSpecified) | Scales a control's location, size, padding and margin. (Inherited from Control.)
 | ScaleCore(Single, Single) | This method is not relevant for this class. (Inherited from Control.)
 | ScrollBars | Gets or sets which scroll bars should appear in a multiline TextBox control. (Inherited from TextBox.)
 | ScrollCaret | Occurs when the text box is scrolled to the caret. (Inherited from AYTTextBox.)
 | ScrollToCaret()()()() | Scrolls to caret (Inherited from AYTTextBox.)
 | Select(Int32, Int32) | Selects a range of text in the text box. (Inherited from TextBoxBase.)
 | Select()()()() | Activates the control. (Inherited from Control.)
 | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
 | SelectAll()()()() | Selects all text in the text box. (Inherited from TextBoxBase.)
 | SelectedText | Gets or sets a value indicating the currently selected text in the control. (Inherited from TextBoxBase.)
 | SelectionChanged | Occurs when the selection of text within the control has changed. (Inherited from AYTTextBox.)
 | SelectionLength | This member overrides TextBox.SelectionLength. (Inherited from AYTTextBox.)
 | SelectionStart | Gets or sets the starting point of text selected in the text box. (Inherited from AYTTextBox.)
 | SelectNextControl(Control, Boolean, Boolean, Boolean, Boolean) | Activates the next control. (Inherited from Control.)
 | SendToBack()()()() | Sends the control to the back of the z-order. (Inherited from Control.)
 | SetAutoSizeMode(AutoSizeMode) | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
 | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
 | SetBoundsCore(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the TextBoxBase control. (Inherited from TextBoxBase.)
 | SetClientSizeCore(Int32, Int32) | Sets the size of the client area of the control. (Inherited from Control.)
 | SetStyle(ControlStyles, Boolean) | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
 | SetTopLevel(Boolean) | Sets the control as the top-level control. (Inherited from Control.)
 | SetVisibleCore(Boolean) | Sets the control to the specified visible state. (Inherited from Control.)
 | ShortcutsEnabled | Gets or sets a value indicating whether the defined shortcuts are enabled. (Inherited from TextBoxBase.)
 | Show()()()() | Displays the control to the user. (Inherited from Control.)
 | ShowCutCopyPasteContextMenu | Whether to show the standard Undo/Cut/Copy/Paste/Delete/Select All context menu. (Inherited from AYTTextBox.)
 | ShowCutCopyPasteContextMenuStrip | Whether to show the standard Undo/Cut/Copy/Paste/Delete/Select All context menu strip. (Inherited from AYTTextBox.)
 | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
 | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
 | Site | Gets or sets the site of the control. (Inherited from Control.)
 | Size | Gets or sets the height and width of the control. (Inherited from Control.)
 | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
 | SizeFromClientSize(Size) | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
 | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
 | SuspendLayout()()()() | Temporarily suspends the layout logic for the control. (Inherited from Control.)
 | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
 | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
 | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
 | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
 | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
 | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
 | Text | Gets or sets the current text in the TextBox. (Inherited from TextBox.)
 | TextAlign | Gets or sets how text is aligned in a TextBox control. (Inherited from TextBox.)
 | TextAlignChanged | Occurs when the value of the TextAlign property has changed. (Inherited from TextBox.)
 | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
 | TextLength | Gets the length of text in the control. (Inherited from TextBoxBase.)
 | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
 | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
 | ToString()()()() | Returns a string that represents the TextBoxBase control. (Inherited from TextBoxBase.)
 | UnderlineYOffset | Controls the position of the underline relative to the baseline. (Inherited from AYTTextBox.)
 | Undo()()()() | Undoes the last edit operation in the text box. (Inherited from TextBoxBase.)
 | Update()()()() | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
 | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
 | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
 | UpdateStyles()()()() | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
 | UpdateZOrder()()()() | Updates the control in its parent's z-order. (Inherited from Control.)
 | UseSystemPasswordChar | Gets or sets a value indicating whether the text in the TextBox control should appear as the default password character. (Inherited from TextBox.)
 | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
 | Validated | Occurs when the control is finished validating. (Inherited from Control.)
 | Validating | Occurs when the control is validating. (Inherited from Control.)
 | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
 | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
 | VScrolled | Event fired when vertical scroll changed (by anything). (Inherited from AYTTextBox.)
 | VScrollEnd | Event fired when vertical scroll ends. (Inherited from AYTTextBox.)
 | Width | Gets or sets the width of the control. (Inherited from Control.)
 | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
 | WndProc(Message%) | Handles WndProc events and dispatches new events. (Inherited from AYTTextBox.)
 | WordWrap | Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary. (Inherited from TextBoxBase.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | Control
 |  |  |  | TextBoxBase
 |  |  |  |  | TextBox
 |  |  |  |  |  | AYTTextBox
 |  |  |  |  |  |  | AYTTextEditingControl


AYTTextEditingControl Constructor

Keyoti RapidSpell Desktop .NET API Docs
AYTTextEditingControl Constructor
API ► Keyoti.RapidSpell.Grid ► AYTTextEditingControl ► AYTTextEditingControl()()()()
Keyoti RapidSpell Desktop .NET
Initializes a new instance of the DataGridViewTextBoxEditingControl class.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public AYTTextEditingControl()
public AYTTextEditingControl()
Public Sub New
Public Sub New
public:
AYTTextEditingControl()
public:
AYTTextEditingControl()
new : unit -> AYTTextEditingControl
new : unit -> AYTTextEditingControl


ApplyCellStyleToEditingControl Method (dataGridViewCellStyle)

Keyoti RapidSpell Desktop .NET API Docs
ApplyCellStyleToEditingControl Method (dataGridViewCellStyle)
API ► Keyoti.RapidSpell.Grid ► AYTTextEditingControl ► ApplyCellStyleToEditingControl(DataGridViewCellStyle)
Keyoti RapidSpell Desktop .NET
Changes the control's user interface (UI) to be consistent with the specified cell style.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void ApplyCellStyleToEditingControl(
    DataGridViewCellStyle dataGridViewCellStyle
)
public virtual void ApplyCellStyleToEditingControl(
    DataGridViewCellStyle dataGridViewCellStyle
)
Public Overridable Sub ApplyCellStyleToEditingControl (
    dataGridViewCellStyle As DataGridViewCellStyle
)
Public Overridable Sub ApplyCellStyleToEditingControl (
    dataGridViewCellStyle As DataGridViewCellStyle
)
public:
virtual void ApplyCellStyleToEditingControl(
    DataGridViewCellStyle^ dataGridViewCellStyle
)
public:
virtual void ApplyCellStyleToEditingControl(
    DataGridViewCellStyle^ dataGridViewCellStyle
)
abstract ApplyCellStyleToEditingControl :
        dataGridViewCellStyle : DataGridViewCellStyle -> unit
override ApplyCellStyleToEditingControl :
        dataGridViewCellStyle : DataGridViewCellStyle -> unit
abstract ApplyCellStyleToEditingControl :
        dataGridViewCellStyle : DataGridViewCellStyle -> unit
override ApplyCellStyleToEditingControl :
        dataGridViewCellStyle : DataGridViewCellStyle -> unit
Parameters
dataGridViewCellStyle (DataGridViewCellStyle)
The DataGridViewCellStyle to use as the model for the UI.


EditingControlDataGridView Property

Keyoti RapidSpell Desktop .NET API Docs
EditingControlDataGridView Property
API ► Keyoti.RapidSpell.Grid ► AYTTextEditingControl ► EditingControlDataGridView
Keyoti RapidSpell Desktop .NET
Gets or sets the DataGridView that contains the text box control.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual DataGridView EditingControlDataGridView { get; set; }
public virtual DataGridView EditingControlDataGridView { get; set; }
Public Overridable Property EditingControlDataGridView As DataGridView
    Get
    Set
Public Overridable Property EditingControlDataGridView As DataGridView
    Get
    Set
public:
virtual property DataGridView^ EditingControlDataGridView {
    DataGridView^ get ();
    void set (DataGridView^ value);
}
public:
virtual property DataGridView^ EditingControlDataGridView {
    DataGridView^ get ();
    void set (DataGridView^ value);
}
abstract EditingControlDataGridView : DataGridView with get, set
override EditingControlDataGridView : DataGridView with get, set
abstract EditingControlDataGridView : DataGridView with get, set
override EditingControlDataGridView : DataGridView with get, set
Return Value
DataGridView
A DataGridView that contains the DataGridViewTextBoxCell that contains this control; otherwise, null if there is no associated DataGridView.


EditingControlFormattedValue Property

Keyoti RapidSpell Desktop .NET API Docs
EditingControlFormattedValue Property
API ► Keyoti.RapidSpell.Grid ► AYTTextEditingControl ► EditingControlFormattedValue
Keyoti RapidSpell Desktop .NET
Gets or sets the formatted representation of the current value of the text box control.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual Object EditingControlFormattedValue { get; set; }
public virtual Object EditingControlFormattedValue { get; set; }
Public Overridable Property EditingControlFormattedValue As Object
    Get
    Set
Public Overridable Property EditingControlFormattedValue As Object
    Get
    Set
public:
virtual property Object^ EditingControlFormattedValue {
    Object^ get ();
    void set (Object^ value);
}
public:
virtual property Object^ EditingControlFormattedValue {
    Object^ get ();
    void set (Object^ value);
}
abstract EditingControlFormattedValue : Object with get, set
override EditingControlFormattedValue : Object with get, set
abstract EditingControlFormattedValue : Object with get, set
override EditingControlFormattedValue : Object with get, set
Return Value
Object
An object representing the current value of this control.


EditingControlRowIndex Property

Keyoti RapidSpell Desktop .NET API Docs
EditingControlRowIndex Property
API ► Keyoti.RapidSpell.Grid ► AYTTextEditingControl ► EditingControlRowIndex
Keyoti RapidSpell Desktop .NET
Gets or sets the index of the owning cell's parent row.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual int EditingControlRowIndex { get; set; }
public virtual int EditingControlRowIndex { get; set; }
Public Overridable Property EditingControlRowIndex As Integer
    Get
    Set
Public Overridable Property EditingControlRowIndex As Integer
    Get
    Set
public:
virtual property int EditingControlRowIndex {
    int get ();
    void set (int value);
}
public:
virtual property int EditingControlRowIndex {
    int get ();
    void set (int value);
}
abstract EditingControlRowIndex : int with get, set
override EditingControlRowIndex : int with get, set
abstract EditingControlRowIndex : int with get, set
override EditingControlRowIndex : int with get, set
Return Value
Int32
The index of the row that contains the owning cell; -1 if there is no owning row.


EditingControlValueChanged Property

Keyoti RapidSpell Desktop .NET API Docs
EditingControlValueChanged Property
API ► Keyoti.RapidSpell.Grid ► AYTTextEditingControl ► EditingControlValueChanged
Keyoti RapidSpell Desktop .NET
Gets or sets a value indicating whether the current value of the text box control has changed.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool EditingControlValueChanged { get; set; }
public virtual bool EditingControlValueChanged { get; set; }
Public Overridable Property EditingControlValueChanged As Boolean
    Get
    Set
Public Overridable Property EditingControlValueChanged As Boolean
    Get
    Set
public:
virtual property bool EditingControlValueChanged {
    bool get ();
    void set (bool value);
}
public:
virtual property bool EditingControlValueChanged {
    bool get ();
    void set (bool value);
}
abstract EditingControlValueChanged : bool with get, set
override EditingControlValueChanged : bool with get, set
abstract EditingControlValueChanged : bool with get, set
override EditingControlValueChanged : bool with get, set
Return Value
Boolean
true if the value of the control has changed; otherwise, false.


EditingControlWantsInputKey Method (keyData, dataGridViewWantsInputKey)

Keyoti RapidSpell Desktop .NET API Docs
EditingControlWantsInputKey Method (keyData, dataGridViewWantsInputKey)
API ► Keyoti.RapidSpell.Grid ► AYTTextEditingControl ► EditingControlWantsInputKey(Keys, Boolean)
Keyoti RapidSpell Desktop .NET
Determines whether the specified key is a regular input key that the editing control should process or a special key that the DataGridView should process.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool EditingControlWantsInputKey(
    Keys keyData,
    bool dataGridViewWantsInputKey
)
public virtual bool EditingControlWantsInputKey(
    Keys keyData,
    bool dataGridViewWantsInputKey
)
Public Overridable Function EditingControlWantsInputKey (
    keyData As Keys,
    dataGridViewWantsInputKey As Boolean
) As Boolean
Public Overridable Function EditingControlWantsInputKey (
    keyData As Keys,
    dataGridViewWantsInputKey As Boolean
) As Boolean
public:
virtual bool EditingControlWantsInputKey(
    Keys keyData,
    bool dataGridViewWantsInputKey
)
public:
virtual bool EditingControlWantsInputKey(
    Keys keyData,
    bool dataGridViewWantsInputKey
)
abstract EditingControlWantsInputKey :
        keyData : Keys *
        dataGridViewWantsInputKey : bool -> bool
override EditingControlWantsInputKey :
        keyData : Keys *
        dataGridViewWantsInputKey : bool -> bool
abstract EditingControlWantsInputKey :
        keyData : Keys *
        dataGridViewWantsInputKey : bool -> bool
override EditingControlWantsInputKey :
        keyData : Keys *
        dataGridViewWantsInputKey : bool -> bool
Parameters
keyData (Keys)
A Keys that represents the key that was pressed.
dataGridViewWantsInputKey (Boolean)
true when the DataGridView wants to process the keyData; otherwise, false.
Return Value
Boolean
true if the specified key is a regular input key that should be handled by the editing control; otherwise, false.


EditingPanelCursor Property

Keyoti RapidSpell Desktop .NET API Docs
EditingPanelCursor Property
API ► Keyoti.RapidSpell.Grid ► AYTTextEditingControl ► EditingPanelCursor
Keyoti RapidSpell Desktop .NET
Gets the cursor used when the mouse pointer is over the EditingPanel but not over the editing control.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual Cursor EditingPanelCursor { get; }
public virtual Cursor EditingPanelCursor { get; }
Public Overridable ReadOnly Property EditingPanelCursor As Cursor
    Get
Public Overridable ReadOnly Property EditingPanelCursor As Cursor
    Get
public:
virtual property Cursor^ EditingPanelCursor {
    Cursor^ get ();
}
public:
virtual property Cursor^ EditingPanelCursor {
    Cursor^ get ();
}
abstract EditingPanelCursor : Cursor with get
override EditingPanelCursor : Cursor with get
abstract EditingPanelCursor : Cursor with get
override EditingPanelCursor : Cursor with get
Return Value
Cursor
A Cursor that represents the mouse pointer used for the editing panel.


GetEditingControlFormattedValue Method (context)

Keyoti RapidSpell Desktop .NET API Docs
GetEditingControlFormattedValue Method (context)
API ► Keyoti.RapidSpell.Grid ► AYTTextEditingControl ► GetEditingControlFormattedValue(DataGridViewDataErrorContexts)
Keyoti RapidSpell Desktop .NET
Retrieves the formatted value of the cell.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual Object GetEditingControlFormattedValue(
    DataGridViewDataErrorContexts context
)
public virtual Object GetEditingControlFormattedValue(
    DataGridViewDataErrorContexts context
)
Public Overridable Function GetEditingControlFormattedValue (
    context As DataGridViewDataErrorContexts
) As Object
Public Overridable Function GetEditingControlFormattedValue (
    context As DataGridViewDataErrorContexts
) As Object
public:
virtual Object^ GetEditingControlFormattedValue(
    DataGridViewDataErrorContexts context
)
public:
virtual Object^ GetEditingControlFormattedValue(
    DataGridViewDataErrorContexts context
)
abstract GetEditingControlFormattedValue :
        context : DataGridViewDataErrorContexts -> Object
override GetEditingControlFormattedValue :
        context : DataGridViewDataErrorContexts -> Object
abstract GetEditingControlFormattedValue :
        context : DataGridViewDataErrorContexts -> Object
override GetEditingControlFormattedValue :
        context : DataGridViewDataErrorContexts -> Object
Parameters
context (DataGridViewDataErrorContexts)
One of the DataGridViewDataErrorContexts values that specifies the data error context.
Return Value
Object
An Object that represents the formatted version of the cell contents.


OnMouseWheel Method (e)

Keyoti RapidSpell Desktop .NET API Docs
OnMouseWheel Method (e)
API ► Keyoti.RapidSpell.Grid ► AYTTextEditingControl ► OnMouseWheel(MouseEventArgs)
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override void OnMouseWheel(
    MouseEventArgs e
)
protected override void OnMouseWheel(
    MouseEventArgs e
)
Protected Overrides Sub OnMouseWheel (
    e As MouseEventArgs
)
Protected Overrides Sub OnMouseWheel (
    e As MouseEventArgs
)
protected:
virtual void OnMouseWheel(
    MouseEventArgs^ e
) override
protected:
virtual void OnMouseWheel(
    MouseEventArgs^ e
) override
abstract OnMouseWheel :
        e : MouseEventArgs -> unit
override OnMouseWheel :
        e : MouseEventArgs -> unit
abstract OnMouseWheel :
        e : MouseEventArgs -> unit
override OnMouseWheel :
        e : MouseEventArgs -> unit
Parameters
e (MouseEventArgs)


OnTextChanged Method (e)

Keyoti RapidSpell Desktop .NET API Docs
OnTextChanged Method (e)
API ► Keyoti.RapidSpell.Grid ► AYTTextEditingControl ► OnTextChanged(EventArgs)
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override void OnTextChanged(
    EventArgs e
)
protected override void OnTextChanged(
    EventArgs e
)
Protected Overrides Sub OnTextChanged (
    e As EventArgs
)
Protected Overrides Sub OnTextChanged (
    e As EventArgs
)
protected:
virtual void OnTextChanged(
    EventArgs^ e
) override
protected:
virtual void OnTextChanged(
    EventArgs^ e
) override
abstract OnTextChanged :
        e : EventArgs -> unit
override OnTextChanged :
        e : EventArgs -> unit
abstract OnTextChanged :
        e : EventArgs -> unit
override OnTextChanged :
        e : EventArgs -> unit
Parameters
e (EventArgs)


PrepareEditingControlForEdit Method (selectAll)

Keyoti RapidSpell Desktop .NET API Docs
PrepareEditingControlForEdit Method (selectAll)
API ► Keyoti.RapidSpell.Grid ► AYTTextEditingControl ► PrepareEditingControlForEdit(Boolean)
Keyoti RapidSpell Desktop .NET
Prepares the currently selected cell for editing.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void PrepareEditingControlForEdit(
    bool selectAll
)
public virtual void PrepareEditingControlForEdit(
    bool selectAll
)
Public Overridable Sub PrepareEditingControlForEdit (
    selectAll As Boolean
)
Public Overridable Sub PrepareEditingControlForEdit (
    selectAll As Boolean
)
public:
virtual void PrepareEditingControlForEdit(
    bool selectAll
)
public:
virtual void PrepareEditingControlForEdit(
    bool selectAll
)
abstract PrepareEditingControlForEdit :
        selectAll : bool -> unit
override PrepareEditingControlForEdit :
        selectAll : bool -> unit
abstract PrepareEditingControlForEdit :
        selectAll : bool -> unit
override PrepareEditingControlForEdit :
        selectAll : bool -> unit
Parameters
selectAll (Boolean)
true to select the cell contents; otherwise, false.


ProcessKeyEventArgs Method (m)

Keyoti RapidSpell Desktop .NET API Docs
ProcessKeyEventArgs Method (m)
API ► Keyoti.RapidSpell.Grid ► AYTTextEditingControl ► ProcessKeyEventArgs(Message%)
Keyoti RapidSpell Desktop .NET
Processes key events.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override bool ProcessKeyEventArgs(
    ref Message m
)
protected override bool ProcessKeyEventArgs(
    ref Message m
)
Protected Overrides Function ProcessKeyEventArgs (
    ByRef m As Message
) As Boolean
Protected Overrides Function ProcessKeyEventArgs (
    ByRef m As Message
) As Boolean
protected:
virtual bool ProcessKeyEventArgs(
    Message% m
) override
protected:
virtual bool ProcessKeyEventArgs(
    Message% m
) override
abstract ProcessKeyEventArgs :
        m : Message byref -> bool
override ProcessKeyEventArgs :
        m : Message byref -> bool
abstract ProcessKeyEventArgs :
        m : Message byref -> bool
override ProcessKeyEventArgs :
        m : Message byref -> bool
Parameters
m (Message %)
A Message indicating the key that was pressed.
Return Value
Boolean
true if the key event was handled by the editing control; otherwise, false.


RepositionEditingControlOnValueChange Property

Keyoti RapidSpell Desktop .NET API Docs
RepositionEditingControlOnValueChange Property
API ► Keyoti.RapidSpell.Grid ► AYTTextEditingControl ► RepositionEditingControlOnValueChange
Keyoti RapidSpell Desktop .NET
Gets a value indicating whether the cell contents need to be repositioned whenever the value changes.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool RepositionEditingControlOnValueChange { get; }
public virtual bool RepositionEditingControlOnValueChange { get; }
Public Overridable ReadOnly Property RepositionEditingControlOnValueChange As Boolean
    Get
Public Overridable ReadOnly Property RepositionEditingControlOnValueChange As Boolean
    Get
public:
virtual property bool RepositionEditingControlOnValueChange {
    bool get ();
}
public:
virtual property bool RepositionEditingControlOnValueChange {
    bool get ();
}
abstract RepositionEditingControlOnValueChange : bool with get
override RepositionEditingControlOnValueChange : bool with get
abstract RepositionEditingControlOnValueChange : bool with get
override RepositionEditingControlOnValueChange : bool with get
Return Value
Boolean
true if the cell's WrapMode is set to true and the alignment property is not set to one of the DataGridViewContentAlignment values that aligns the content to the top; otherwise, false.


DataGridAYTTextBox Class

Keyoti RapidSpell Desktop .NET API Docs
DataGridAYTTextBox Class
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBox
Keyoti RapidSpell Desktop .NET
As-You-Type enabled TextBox.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class DataGridAYTTextBox : DataGridTextBox,
    IAYTTextBox
public class DataGridAYTTextBox : DataGridTextBox,
    IAYTTextBox
Public Class DataGridAYTTextBox
    Inherits DataGridTextBox
    Implements IAYTTextBox
Public Class DataGridAYTTextBox
    Inherits DataGridTextBox
    Implements IAYTTextBox
public ref class DataGridAYTTextBox : public DataGridTextBox,
    IAYTTextBox
public ref class DataGridAYTTextBox : public DataGridTextBox,
    IAYTTextBox
type DataGridAYTTextBox =
    class
        inherit DataGridTextBox
        interface IAYTTextBox
    end
type DataGridAYTTextBox =
    class
        inherit DataGridTextBox
        interface IAYTTextBox
    end
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataGridAYTTextBox()()()() | Creates a new TextBox with "as-you-type" facility.
 | AcceptsReturn | Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form. (Inherited from TextBox.)
 | AcceptsTab | Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order. (Inherited from TextBoxBase.)
 | AcceptsTabChanged | Occurs when the value of the AcceptsTab property has changed. (Inherited from TextBoxBase.)
 | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
 | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
 | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
 | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
 | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
 | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
 | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
 | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
 | AppendText(String) | Appends text to the current text of a text box. (Inherited from TextBoxBase.)
 | AutoCompleteCustomSource | Gets or sets a custom StringCollection to use when the AutoCompleteSource property is set to CustomSource. (Inherited from TextBox.)
 | AutoCompleteMode | Gets or sets an option that controls how automatic completion works for the TextBox. (Inherited from TextBox.)
 | AutoCompleteSource | Gets or sets a value specifying the source of complete strings used for automatic completion. (Inherited from TextBox.)
 | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
 | AutoSize | Gets or sets a value indicating whether the height of the control automatically adjusts when the font assigned to the control is changed. (Inherited from TextBoxBase.)
 | AutoSizeChanged | This event is not relevant for this class. (Inherited from TextBoxBase.)
 | BackColor | Gets or sets the background color of the control. (Inherited from TextBoxBase.)
 | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
 | BackgroundImage | This property is not relevant for this class. (Inherited from TextBoxBase.)
 | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. This event is not relevant for this class. (Inherited from TextBoxBase.)
 | BackgroundImageLayout | This property is not relevant for this class. (Inherited from TextBoxBase.)
 | BackgroundImageLayoutChanged | Occurs when the value of the BackgroundImageLayout property changes. This event is not relevant for this class. (Inherited from TextBoxBase.)
 | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
 | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
 | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
 | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
 | BorderStyle | Gets or sets the border type of the text box control. (Inherited from TextBoxBase.)
 | BorderStyleChanged | Occurs when the value of the BorderStyle property has changed. (Inherited from TextBoxBase.)
 | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
 | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
 | BringToFront()()()() | Brings the control to the front of the z-order. (Inherited from Control.)
 | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from TextBoxBase.)
 | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
 | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
 | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
 | CanUndo | Gets a value indicating whether the user can undo the previous operation in a text box control. (Inherited from TextBoxBase.)
 | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
 | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
 | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
 | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
 | CharacterCasing | Gets or sets whether the TextBox control modifies the case of characters as they are typed. (Inherited from TextBox.)
 | Clear()()()() | Clears all text from the text box control. (Inherited from TextBoxBase.)
 | ClearUndo()()()() | Clears information about the most recent operation from the undo buffer of the text box. (Inherited from TextBoxBase.)
 | Click | Occurs when the text box is clicked. (Inherited from TextBoxBase.)
 | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
 | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
 | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
 | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | Contains(Control) | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
 | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
 | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
 | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
 | ContextMenuDefault | The context menu that will be shown when the right click is not on a misspelled word.
 | ContextMenuStrip | The context menu that will be shown when the right click is not on a misspelled word. (Overrides Control.ContextMenuStrip.)
 | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
 | ContextMenuStripDefault | The context menu that will be shown when the right click is not on a misspelled word.
 | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
 | ControlBackgroundPaint | Event fired when Windows level background repaint occurs.
 | ControlPaint | Event fired when Windows level repaint occurs.
 | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
 | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
 | Copy()()()() | Copies the current selection in the text box to the Clipboard. (Inherited from TextBoxBase.)
 | CreateAccessibilityInstance()()()() | Creates a new accessibility object for the control. (Inherited from Control.)
 | CreateControl()()()() | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
 | CreateControlsInstance()()()() | Creates a new instance of the control collection for the control. (Inherited from Control.)
 | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
 | CreateGraphics()()()() | Creates the Graphics for the control. (Inherited from Control.)
 | CreateHandle()()()() | (Inherited from TextBoxBase.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateParams | (Inherited from TextBox.)
 | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
 | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
 | Cut()()()() | Moves the current selection in the text box to the Clipboard. (Inherited from TextBoxBase.)
 | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
 | DefaultContextMenu | Obsolete. Obsolete, use ContextMenuDefault instead.
 | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from TextBoxBase.)
 | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
 | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
 | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
 | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
 | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
 | DefaultSize | (Inherited from TextBoxBase.)
 | DefWndProc(Message%) | Sends the specified message to the default window procedure. (Inherited from Control.)
 | DeselectAll()()()() | Specifies that the value of the SelectionLength property is zero so that no characters are selected in the control. (Inherited from TextBoxBase.)
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | DestroyHandle()()()() | Destroys the handle associated with the control. (Inherited from Control.)
 | DeviceDpi()()()() | (Inherited from Control.)
 | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
 | Dispose(Boolean) | Releases the unmanaged resources used by the TextBox and optionally releases the managed resources. (Inherited from TextBox.)
 | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
 | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
 | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
 | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
 | DoDragDrop(Object, DragDropEffects) | Begins a drag-and-drop operation. (Inherited from Control.)
 | DoubleBuffered | Gets or sets a value indicating whether control drawing is done in a buffer before the control is displayed. This property is not relevant for this class. (Inherited from TextBoxBase.)
 | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
 | DpiChangedAfterParent()()()() | (Inherited from Control.)
 | DpiChangedBeforeParent()()()() | (Inherited from Control.)
 | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
 | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
 | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
 | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
 | DrawToBitmap(Bitmap, Rectangle) | Supports rendering to the specified bitmap. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
 | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
 | EndInvoke(IAsyncResult) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
 | Enter | Occurs when the control is entered. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | Finalize()()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | FindForm()()()() | Retrieves the form that the control is on. (Inherited from Control.)
 | Focus()()()() | Sets input focus to the control. (Inherited from Control.)
 | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
 | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
 | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
 | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color of the control. (Inherited from TextBoxBase.)
 | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
 | FormatChanged | Event fired when formatting changes (such as font change).
 | GetAccessibilityObjectById(Int32) | Retrieves the specified AccessibleObject. (Inherited from Control.)
 | GetAutoSizeMode()()()() | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
 | GetBaselineOffsetAtCharIndex(Int32) | Gets the baseline offset for a character at index i
 | GetCharFromPosition(Point) | Retrieves the character that is closest to the specified location within the control. (Inherited from TextBoxBase.)
 | GetCharIndexFromPos(Point) | gets the char index from a position point.
 | GetCharIndexFromPosition(Point) | Retrieves the index of the character nearest to the specified location. (Inherited from TextBoxBase.)
 | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
 | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
 | GetContainerControl()()()() | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
 | GetFirstCharIndexFromLine(Int32) | Retrieves the index of the first character of a given line. (Inherited from TextBoxBase.)
 | GetFirstCharIndexOfCurrentLine()()()() | Retrieves the index of the first character of the current line. (Inherited from TextBoxBase.)
 | GetFirstVisibleCharIndex()()()() | Gets the character index of the first visible character in the window, this is for optimization and can just return 0 if unavailable.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetLineFromCharIndex(Int32) | Retrieves the line number from the specified character position within the text of the control. (Inherited from TextBoxBase.)
 | GetNextControl(Control, Boolean) | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
 | GetPosFromCharIndex(Int32) | Gets the position point from the char index
 | GetPositionFromCharIndex(Int32) | Retrieves the location within the control at the specified character index. (Inherited from TextBoxBase.)
 | GetPreferredSize(Size) | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
 | GetScaledBounds(Rectangle, SizeF, BoundsSpecified) | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetStyle(ControlStyles) | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
 | GetTBU()()()() | Interface requirement
 | GetTopLevel()()()() | Determines if the control is a top-level control. (Inherited from Control.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
 | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
 | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
 | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
 | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
 | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the control. (Inherited from Control.)
 | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
 | Hide()()()() | Conceals the control from the user. (Inherited from Control.)
 | HideSelection | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus. (Inherited from TextBoxBase.)
 | HideSelectionChanged | Occurs when the value of the HideSelection property has changed. (Inherited from TextBoxBase.)
 | HScrolled | Event fired when horizontal scroll changed (by anything).
 | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
 | ImeModeBase | (Inherited from TextBoxBase.)
 | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | InitLayout()()()() | Called after the control has been added to another container. (Inherited from Control.)
 | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
 | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
 | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
 | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
 | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
 | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
 | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
 | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
 | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
 | InvokeGotFocus(Control, EventArgs) | Raises the GotFocus event for the specified control. (Inherited from Control.)
 | InvokeLostFocus(Control, EventArgs) | Raises the LostFocus event for the specified control. (Inherited from Control.)
 | InvokeOnClick(Control, EventArgs) | Raises the Click event for the specified control. (Inherited from Control.)
 | InvokePaint(Control, PaintEventArgs) | Raises the Paint event for the specified control. (Inherited from Control.)
 | InvokePaintBackground(Control, PaintEventArgs) | Raises the PaintBackground event for the specified control. (Inherited from Control.)
 | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
 | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
 | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
 | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
 | IsInEditOrNavigateMode | Gets or sets a value indicating whether the DataGridTextBox is in a mode that allows either editing or navigating. (Inherited from DataGridTextBox.)
 | IsInputChar(Char) | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
 | IsInputKey(Keys) | Determines whether the specified key is an input key or a special key that requires preprocessing. (Inherited from TextBox.)
 | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
 | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
 | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
 | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
 | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
 | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
 | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
 | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
 | Lines | Gets or sets the lines of text in a text box control. (Inherited from TextBoxBase.)
 | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
 | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
 | LogicalToDeviceUnits(Int32) | (Inherited from Control.)
 | LogicalToDeviceUnits(Size) | (Inherited from Control.)
 | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
 | Margin | Gets or sets the space between controls. (Inherited from Control.)
 | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
 | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
 | MaxLength | Gets or sets the maximum number of characters the user can type or paste into the text box control. (Inherited from TextBoxBase.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
 | Modified | Gets or sets a value that indicates that the text box control has been modified by the user since the control was created or its contents were last set. (Inherited from TextBoxBase.)
 | ModifiedChanged | Occurs when the value of the Modified property has changed. (Inherited from TextBoxBase.)
 | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
 | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from TextBoxBase.)
 | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
 | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
 | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
 | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
 | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
 | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
 | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
 | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
 | Move | Occurs when the control is moved. (Inherited from Control.)
 | Multiline | Gets or sets a value indicating whether this is a multiline TextBox control. (Inherited from TextBox.)
 | MultilineChanged | Occurs when the value of the Multiline property has changed. (Inherited from TextBoxBase.)
 | Name | Gets or sets the name of the control. (Inherited from Control.)
 | NotifyInvalidate(Rectangle) | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
 | OnAcceptsTabChanged(EventArgs) | Raises the AcceptsTabChanged event. (Inherited from TextBoxBase.)
 | OnAutoSizeChanged(EventArgs) | Raises the AutoSizeChanged event. (Inherited from Control.)
 | OnBackColorChanged(EventArgs) | Raises the BackColorChanged event. (Inherited from TextBox.)
 | OnBackgroundImageChanged(EventArgs) | Raises the BackgroundImageChanged event. (Inherited from Control.)
 | OnBackgroundImageLayoutChanged(EventArgs) | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
 | OnBindingContextChanged(EventArgs) | Raises the BindingContextChanged event. (Inherited from Control.)
 | OnBorderStyleChanged(EventArgs) | Raises the BorderStyleChanged event. (Inherited from TextBoxBase.)
 | OnCausesValidationChanged(EventArgs) | Raises the CausesValidationChanged event. (Inherited from Control.)
 | OnChangeUICues(UICuesEventArgs) | Raises the ChangeUICues event. (Inherited from Control.)
 | OnClick(EventArgs) | Raises the Click event. (Inherited from Control.)
 | OnClientSizeChanged(EventArgs) | Raises the ClientSizeChanged event. (Inherited from Control.)
 | OnContextMenuChanged(EventArgs) | Raises the ContextMenuChanged event. (Inherited from Control.)
 | OnContextMenuStripChanged(EventArgs) | Raises the ContextMenuStripChanged event. (Inherited from Control.)
 | OnControlAdded(ControlEventArgs) | Raises the ControlAdded event. (Inherited from Control.)
 | OnControlRemoved(ControlEventArgs) | Raises the ControlRemoved event. (Inherited from Control.)
 | OnCreateControl()()()() | Raises the CreateControl()()()() method. (Inherited from Control.)
 | OnCursorChanged(EventArgs) | Raises the CursorChanged event. (Inherited from Control.)
 | OnDockChanged(EventArgs) | Raises the DockChanged event. (Inherited from Control.)
 | OnDoubleClick(EventArgs) | Raises the DoubleClick event. (Inherited from Control.)
 | OnDpiChangedAfterParent(EventArgs) | (Inherited from Control.)
 | OnDpiChangedBeforeParent(EventArgs) | (Inherited from Control.)
 | OnDragDrop(DragEventArgs) | Raises the DragDrop event. (Inherited from Control.)
 | OnDragEnter(DragEventArgs) | Raises the DragEnter event. (Inherited from Control.)
 | OnDragLeave(EventArgs) | Raises the DragLeave event. (Inherited from Control.)
 | OnDragOver(DragEventArgs) | Raises the DragOver event. (Inherited from Control.)
 | OnEnabledChanged(EventArgs) | Raises the EnabledChanged event. (Inherited from Control.)
 | OnEnter(EventArgs) | Raises the Enter event. (Inherited from Control.)
 | OnFontChanged(EventArgs) | Raises the FontChanged event. (Inherited from TextBox.)
 | OnForeColorChanged(EventArgs) | Raises the ForeColorChanged event. (Inherited from Control.)
 | OnGiveFeedback(GiveFeedbackEventArgs) | Raises the GiveFeedback event. (Inherited from Control.)
 | OnGotFocus(EventArgs) | Raises the GotFocus event. (Inherited from TextBox.)
 | OnHandleCreated(EventArgs) | (Inherited from TextBox.)
 | OnHandleDestroyed(EventArgs) | Raises the OnHandleDestroyed(EventArgs) event. (Inherited from TextBox.)
 | OnHelpRequested(HelpEventArgs) | Raises the HelpRequested event. (Inherited from Control.)
 | OnHideSelectionChanged(EventArgs) | Raise the HideSelectionChanged event. (Inherited from TextBoxBase.)
 | OnImeModeChanged(EventArgs) | Raises the ImeModeChanged event. (Inherited from Control.)
 | OnInvalidated(InvalidateEventArgs) | Raises the Invalidated event. (Inherited from Control.)
 | OnKeyDown(KeyEventArgs) | Raises the KeyDown event. (Inherited from Control.)
 | OnKeyPress(KeyPressEventArgs) | Raises the KeyPress event. (Inherited from DataGridTextBox.)
 | OnKeyUp(KeyEventArgs) | Raises the KeyUp event. (Inherited from Control.)
 | OnLayout(LayoutEventArgs) | Raises the Layout event. (Inherited from Control.)
 | OnLeave(EventArgs) | Raises the Leave event. (Inherited from Control.)
 | OnLocationChanged(EventArgs) | Raises the LocationChanged event. (Inherited from Control.)
 | OnLostFocus(EventArgs) | Raises the LostFocus event. (Inherited from Control.)
 | OnMarginChanged(EventArgs) | Raises the MarginChanged event. (Inherited from Control.)
 | OnModifiedChanged(EventArgs) | Raises the ModifiedChanged event. (Inherited from TextBoxBase.)
 | OnMouseCaptureChanged(EventArgs) | Raises the MouseCaptureChanged event. (Inherited from Control.)
 | OnMouseClick(MouseEventArgs) | Raises the MouseClick event. (Inherited from Control.)
 | OnMouseDoubleClick(MouseEventArgs) | Raises the MouseDoubleClick event. (Inherited from Control.)
 | OnMouseDown(MouseEventArgs) | Raises the MouseDown event. (Inherited from Control.)
 | OnMouseEnter(EventArgs) | Raises the MouseEnter event. (Inherited from Control.)
 | OnMouseHover(EventArgs) | Raises the MouseHover event. (Inherited from Control.)
 | OnMouseLeave(EventArgs) | Raises the MouseLeave event. (Inherited from Control.)
 | OnMouseMove(MouseEventArgs) | Raises the MouseMove event. (Inherited from Control.)
 | OnMouseUp(MouseEventArgs) | (Inherited from TextBoxBase.)
 | OnMouseWheel(MouseEventArgs) | Raises the MouseWheel event. (Inherited from DataGridTextBox.)
 | OnMove(EventArgs) | Raises the Move event. (Inherited from Control.)
 | OnMultilineChanged(EventArgs) | Raises the MultilineChanged event. (Inherited from TextBoxBase.)
 | OnNotifyMessage(Message) | Notifies the control of Windows messages. (Inherited from Control.)
 | OnPaddingChanged(EventArgs) | This method is not relevant for this class. (Inherited from TextBoxBase.)
 | OnPaint(PaintEventArgs) | Raises the Paint event. (Inherited from Control.)
 | OnPaintBackground(PaintEventArgs) | Paints the background of the control. (Inherited from Control.)
 | OnParentBackColorChanged(EventArgs) | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
 | OnParentBackgroundImageChanged(EventArgs) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
 | OnParentBindingContextChanged(EventArgs) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
 | OnParentChanged(EventArgs) | Raises the ParentChanged event. (Inherited from Control.)
 | OnParentCursorChanged(EventArgs) | Raises the CursorChanged event. (Inherited from Control.)
 | OnParentEnabledChanged(EventArgs) | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
 | OnParentFontChanged(EventArgs) | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
 | OnParentForeColorChanged(EventArgs) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
 | OnParentRightToLeftChanged(EventArgs) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
 | OnParentVisibleChanged(EventArgs) | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
 | OnPreviewKeyDown(PreviewKeyDownEventArgs) | Raises the PreviewKeyDown event. (Inherited from Control.)
 | OnPrint(PaintEventArgs) | Raises the Paint event. (Inherited from Control.)
 | OnQueryContinueDrag(QueryContinueDragEventArgs) | Raises the QueryContinueDrag event. (Inherited from Control.)
 | OnReadOnlyChanged(EventArgs) | Raises the ReadOnlyChanged event. (Inherited from TextBoxBase.)
 | OnRegionChanged(EventArgs) | Raises the RegionChanged event. (Inherited from Control.)
 | OnResize(EventArgs) | Raises the Resize event. (Inherited from Control.)
 | OnRightToLeftChanged(EventArgs) | Raises the RightToLeftChanged event. (Inherited from Control.)
 | OnSizeChanged(EventArgs) | Raises the SizeChanged event. (Inherited from Control.)
 | OnStyleChanged(EventArgs) | Raises the StyleChanged event. (Inherited from Control.)
 | OnSystemColorsChanged(EventArgs) | Raises the SystemColorsChanged event. (Inherited from Control.)
 | OnTabIndexChanged(EventArgs) | Raises the TabIndexChanged event. (Inherited from Control.)
 | OnTabStopChanged(EventArgs) | Raises the TabStopChanged event. (Inherited from Control.)
 | OnTextAlignChanged(EventArgs) | Raises the TextAlignChanged event. (Inherited from TextBox.)
 | OnTextChanged(EventArgs) | (Inherited from TextBoxBase.)
 | OnValidated(EventArgs) | Raises the Validated event. (Inherited from Control.)
 | OnValidating(CancelEventArgs) | Raises the Validating event. (Inherited from Control.)
 | OnVisibleChanged(EventArgs) | Raises the VisibleChanged event. (Inherited from Control.)
 | Padding | This property is not relevant for this class. (Inherited from TextBoxBase.)
 | PaddingChanged | This event is not relevant for this class. (Inherited from TextBoxBase.)
 | Paint | Occurs when the control is redrawn. This event is not relevant for this class. (Inherited from TextBoxBase.)
 | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
 | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
 | PasswordChar | Gets or sets the character used to mask characters of a password in a single-line TextBox control. (Inherited from TextBox.)
 | Paste(String) | Sets the selected text to the specified text without clearing the undo buffer. (Inherited from TextBox.)
 | Paste()()()() | Replaces the current selection in the text box with the contents of the Clipboard. (Inherited from TextBoxBase.)
 | Pasting | Occurs when text is about to be pasted.
 | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
 | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
 | PointToClient(Point) | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
 | PointToScreen(Point) | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
 | PreferredHeight | Gets the preferred height for a text box. (Inherited from TextBoxBase.)
 | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
 | PreProcessControlMessage(Message%) | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
 | PreProcessMessage(Message%) | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
 | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
 | ProcessCmdKey(Message%, Keys) | (Inherited from TextBox.)
 | ProcessDialogChar(Char) | Processes a dialog character. (Inherited from Control.)
 | ProcessDialogKey(Keys) | (Inherited from TextBoxBase.)
 | ProcessKeyEventArgs(Message%) | Processes a key message and generates the appropriate control events. (Inherited from Control.)
 | ProcessKeyMessage(Message%) | Indicates whether the key pressed is processed further (for example, to navigate, or escape). This property is read-only. (Inherited from DataGridTextBox.)
 | ProcessKeyPreview(Message%) | Previews a keyboard message. (Inherited from Control.)
 | ProcessMnemonic(Char) | Processes a mnemonic character. (Inherited from Control.)
 | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
 | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
 | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
 | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
 | RaiseDragEvent(Object, DragEventArgs) | Raises the appropriate drag event. (Inherited from Control.)
 | RaiseKeyEvent(Object, KeyEventArgs) | Raises the appropriate key event. (Inherited from Control.)
 | RaiseMouseEvent(Object, MouseEventArgs) | Raises the appropriate mouse event. (Inherited from Control.)
 | RaisePaintEvent(Object, PaintEventArgs) | Raises the appropriate paint event. (Inherited from Control.)
 | ReadOnly | Gets or sets a value indicating whether text in the text box is read-only. (Inherited from TextBoxBase.)
 | ReadOnlyChanged | Occurs when the value of the ReadOnly property has changed. (Inherited from TextBoxBase.)
 | RecreateHandle()()()() | Forces the re-creation of the handle for the control. (Inherited from Control.)
 | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
 | RectangleToClient(Rectangle) | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
 | RectangleToScreen(Rectangle) | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
 | Refresh()()()() | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
 | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
 | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
 | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
 | RescaleConstantsForDpi(Int32, Int32) | (Inherited from Control.)
 | ResetBackColor()()()() | Resets the BackColor property to its default value. (Inherited from Control.)
 | ResetBindings()()()() | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
 | ResetCursor()()()() | Resets the Cursor property to its default value. (Inherited from Control.)
 | ResetFont()()()() | Resets the Font property to its default value. (Inherited from Control.)
 | ResetForeColor()()()() | Resets the ForeColor property to its default value. (Inherited from Control.)
 | ResetImeMode()()()() | Resets the ImeMode property to its default value. (Inherited from Control.)
 | ResetMouseEventArgs()()()() | Resets the control to handle the MouseLeave event. (Inherited from Control.)
 | ResetRightToLeft()()()() | Resets the RightToLeft property to its default value. (Inherited from Control.)
 | ResetText()()()() | Resets the Text property to its default value. (Inherited from Control.)
 | Resize | Occurs when the control is resized. (Inherited from Control.)
 | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
 | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
 | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
 | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
 | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
 | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
 | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateContent(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateHorizontal(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateLeftRight(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
 | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
 | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
 | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
 | ScaleBitmapLogicalToDevice(Bitmap%) | (Inherited from Control.)
 | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
 | ScaleControl(SizeF, BoundsSpecified) | Scales a control's location, size, padding and margin. (Inherited from Control.)
 | ScaleCore(Single, Single) | This method is not relevant for this class. (Inherited from Control.)
 | ScrollBars | Gets or sets which scroll bars should appear in a multiline TextBox control. (Inherited from TextBox.)
 | ScrollCaret | Occurs when the text box is scrolled to the caret.
 | ScrollToCaret()()()() | Scrolls the contents of the control to the current caret position. (Inherited from TextBoxBase.)
 | Select(Int32, Int32) | Selects a range of text in the text box. (Inherited from TextBoxBase.)
 | Select()()()() | Activates the control. (Inherited from Control.)
 | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
 | SelectAll()()()() | Selects all text in the text box. (Inherited from TextBoxBase.)
 | SelectedText | The selected text. (Overrides TextBoxBase.SelectedText.)
 | SelectionChanged | Occurs when the selection of text within the control has changed.
 | SelectionLength | This member overrides TextBox.SelectionLength. (Overrides TextBoxBase.SelectionLength.)
 | SelectionStart | Gets or sets the starting point of text selected in the text box.
 | SelectNextControl(Control, Boolean, Boolean, Boolean, Boolean) | Activates the next control. (Inherited from Control.)
 | SendToBack()()()() | Sends the control to the back of the z-order. (Inherited from Control.)
 | SetAutoSizeMode(AutoSizeMode) | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
 | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
 | SetBoundsCore(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the TextBoxBase control. (Inherited from TextBoxBase.)
 | SetClientSizeCore(Int32, Int32) | Sets the size of the client area of the control. (Inherited from Control.)
 | SetDataGrid(DataGrid) | Sets the DataGrid to which this TextBox control belongs. (Inherited from DataGridTextBox.)
 | SetStyle(ControlStyles, Boolean) | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
 | SetTopLevel(Boolean) | Sets the control as the top-level control. (Inherited from Control.)
 | SetVisibleCore(Boolean) | Sets the control to the specified visible state. (Inherited from Control.)
 | ShortcutsEnabled | Gets or sets a value indicating whether the defined shortcuts are enabled. (Inherited from TextBoxBase.)
 | Show()()()() | Displays the control to the user. (Inherited from Control.)
 | ShowCutCopyPasteContextMenu | Whether to show the standard Undo/Cut/Copy/Paste/Delete/Select All context menu.
 | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
 | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
 | Site | Gets or sets the site of the control. (Inherited from Control.)
 | Size | Gets or sets the height and width of the control. (Inherited from Control.)
 | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
 | SizeFromClientSize(Size) | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
 | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
 | SuspendLayout()()()() | Temporarily suspends the layout logic for the control. (Inherited from Control.)
 | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
 | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
 | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
 | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
 | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
 | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
 | Text | Gets or sets the current text in the TextBox. (Inherited from TextBox.)
 | TextAlign | Gets or sets how text is aligned in a TextBox control. (Inherited from TextBox.)
 | TextAlignChanged | Occurs when the value of the TextAlign property has changed. (Inherited from TextBox.)
 | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
 | TextLength | Gets the length of text in the control. (Inherited from TextBoxBase.)
 | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
 | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
 | ToString()()()() | Returns a string that represents the TextBoxBase control. (Inherited from TextBoxBase.)
 | UnderlineYOffset | Controls the position of the underline relative to the baseline.
 | Undo()()()() | Undoes the last edit operation in the text box. (Inherited from TextBoxBase.)
 | Update()()()() | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
 | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
 | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
 | UpdateStyles()()()() | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
 | UpdateZOrder()()()() | Updates the control in its parent's z-order. (Inherited from Control.)
 | UseSystemPasswordChar | Gets or sets a value indicating whether the text in the TextBox control should appear as the default password character. (Inherited from TextBox.)
 | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
 | Validated | Occurs when the control is finished validating. (Inherited from Control.)
 | Validating | Occurs when the control is validating. (Inherited from Control.)
 | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
 | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
 | VScrolled | Event fired when vertical scroll changed (by anything).
 | VScrollEnd | Event fired when vertical scroll ends.
 | Width | Gets or sets the width of the control. (Inherited from Control.)
 | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
 | WndProc(Message%) | Handles WndProc events and dispatches new events. (Overrides DataGridTextBox.WndProc(Message%).)
 | WordWrap | Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary. (Inherited from TextBoxBase.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | Control
 |  |  |  | TextBoxBase
 |  |  |  |  | TextBox
 |  |  |  |  |  | DataGridTextBox
 |  |  |  |  |  |  | DataGridAYTTextBox


DataGridAYTTextBox Constructor

Keyoti RapidSpell Desktop .NET API Docs
DataGridAYTTextBox Constructor
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBox ► DataGridAYTTextBox()()()()
Keyoti RapidSpell Desktop .NET
Creates a new TextBox with "as-you-type" facility.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public DataGridAYTTextBox()
public DataGridAYTTextBox()
Public Sub New
Public Sub New
public:
DataGridAYTTextBox()
public:
DataGridAYTTextBox()
new : unit -> DataGridAYTTextBox
new : unit -> DataGridAYTTextBox


ContextMenuDefault Property

Keyoti RapidSpell Desktop .NET API Docs
ContextMenuDefault Property
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBox ► ContextMenuDefault
Keyoti RapidSpell Desktop .NET
The context menu that will be shown when the right click is not on a misspelled word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual ContextMenu ContextMenuDefault { get; set; }
public virtual ContextMenu ContextMenuDefault { get; set; }
Public Overridable Property ContextMenuDefault As ContextMenu
    Get
    Set
Public Overridable Property ContextMenuDefault As ContextMenu
    Get
    Set
public:
virtual property ContextMenu^ ContextMenuDefault {
    ContextMenu^ get ();
    void set (ContextMenu^ value);
}
public:
virtual property ContextMenu^ ContextMenuDefault {
    ContextMenu^ get ();
    void set (ContextMenu^ value);
}
abstract ContextMenuDefault : ContextMenu with get, set
override ContextMenuDefault : ContextMenu with get, set
abstract ContextMenuDefault : ContextMenu with get, set
override ContextMenuDefault : ContextMenu with get, set
Property Value
ContextMenu
Remarks
This is the context menu originally set in the ContextMenu property.


ContextMenuStrip Property

Keyoti RapidSpell Desktop .NET API Docs
ContextMenuStrip Property
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBox ► ContextMenuStrip
Keyoti RapidSpell Desktop .NET
The context menu that will be shown when the right click is not on a misspelled word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override ContextMenuStrip ContextMenuStrip { get; set; }
public override ContextMenuStrip ContextMenuStrip { get; set; }
Public Overrides Property ContextMenuStrip As ContextMenuStrip
    Get
    Set
Public Overrides Property ContextMenuStrip As ContextMenuStrip
    Get
    Set
public:
virtual property ContextMenuStrip^ ContextMenuStrip {
    ContextMenuStrip^ get () override;
    void set (ContextMenuStrip^ value) override;
}
public:
virtual property ContextMenuStrip^ ContextMenuStrip {
    ContextMenuStrip^ get () override;
    void set (ContextMenuStrip^ value) override;
}
abstract ContextMenuStrip : ContextMenuStrip with get, set
override ContextMenuStrip : ContextMenuStrip with get, set
abstract ContextMenuStrip : ContextMenuStrip with get, set
override ContextMenuStrip : ContextMenuStrip with get, set
Property Value
ContextMenuStrip


ContextMenuStripDefault Property

Keyoti RapidSpell Desktop .NET API Docs
ContextMenuStripDefault Property
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBox ► ContextMenuStripDefault
Keyoti RapidSpell Desktop .NET
The context menu that will be shown when the right click is not on a misspelled word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ContextMenuStrip ContextMenuStripDefault { get; set; }
public ContextMenuStrip ContextMenuStripDefault { get; set; }
Public Property ContextMenuStripDefault As ContextMenuStrip
    Get
    Set
Public Property ContextMenuStripDefault As ContextMenuStrip
    Get
    Set
public:
virtual property ContextMenuStrip^ ContextMenuStripDefault {
    ContextMenuStrip^ get () sealed;
    void set (ContextMenuStrip^ value) sealed;
}
public:
virtual property ContextMenuStrip^ ContextMenuStripDefault {
    ContextMenuStrip^ get () sealed;
    void set (ContextMenuStrip^ value) sealed;
}
abstract ContextMenuStripDefault : ContextMenuStrip with get, set
override ContextMenuStripDefault : ContextMenuStrip with get, set
abstract ContextMenuStripDefault : ContextMenuStrip with get, set
override ContextMenuStripDefault : ContextMenuStrip with get, set
Property Value
ContextMenuStrip
Remarks
This is the context menu originally set in the ContextMenuStrip property.


ControlBackgroundPaint Event

Keyoti RapidSpell Desktop .NET API Docs
ControlBackgroundPaint Event
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBox ► ControlBackgroundPaint
Keyoti RapidSpell Desktop .NET
Event fired when Windows level background repaint occurs.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler ControlBackgroundPaint
public event EventHandler ControlBackgroundPaint
Public Event ControlBackgroundPaint As EventHandler
Public Event ControlBackgroundPaint As EventHandler
public:
 event EventHandler^ ControlBackgroundPaint {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
 event EventHandler^ ControlBackgroundPaint {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member ControlBackgroundPaint : IEvent<EventHandler,
    EventArgs>

member ControlBackgroundPaint : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


ControlPaint Event

Keyoti RapidSpell Desktop .NET API Docs
ControlPaint Event
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBox ► ControlPaint
Keyoti RapidSpell Desktop .NET
Event fired when Windows level repaint occurs.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler ControlPaint
public event EventHandler ControlPaint
Public Event ControlPaint As EventHandler
Public Event ControlPaint As EventHandler
public:
virtual  event EventHandler^ ControlPaint {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ ControlPaint {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ControlPaint : IEvent<EventHandler,
    EventArgs>
override ControlPaint : IEvent<EventHandler,
    EventArgs>
abstract ControlPaint : IEvent<EventHandler,
    EventArgs>
override ControlPaint : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


DefaultContextMenu Property

Keyoti RapidSpell Desktop .NET API Docs
DefaultContextMenu Property
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBox ► DefaultContextMenu
Keyoti RapidSpell Desktop .NET
Obsolete, use ContextMenuDefault instead.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
[ObsoleteAttribute("Use ContextMenuDefault instead.")]
public virtual ContextMenu DefaultContextMenu { get; set; }
[ObsoleteAttribute("Use ContextMenuDefault instead.")]
public virtual ContextMenu DefaultContextMenu { get; set; }
<ObsoleteAttribute("Use ContextMenuDefault instead.")>
Public Overridable Property DefaultContextMenu As ContextMenu
    Get
    Set
<ObsoleteAttribute("Use ContextMenuDefault instead.")>
Public Overridable Property DefaultContextMenu As ContextMenu
    Get
    Set
public:
[ObsoleteAttribute(L"Use ContextMenuDefault instead.")]
virtual property ContextMenu^ DefaultContextMenu {
    ContextMenu^ get ();
    void set (ContextMenu^ value);
}
public:
[ObsoleteAttribute(L"Use ContextMenuDefault instead.")]
virtual property ContextMenu^ DefaultContextMenu {
    ContextMenu^ get ();
    void set (ContextMenu^ value);
}
[<ObsoleteAttribute("Use ContextMenuDefault instead.")>]
abstract DefaultContextMenu : ContextMenu with get, set
[<ObsoleteAttribute("Use ContextMenuDefault instead.")>]
override DefaultContextMenu : ContextMenu with get, set
[<ObsoleteAttribute("Use ContextMenuDefault instead.")>]
abstract DefaultContextMenu : ContextMenu with get, set
[<ObsoleteAttribute("Use ContextMenuDefault instead.")>]
override DefaultContextMenu : ContextMenu with get, set
Property Value
ContextMenu


FormatChanged Event

Keyoti RapidSpell Desktop .NET API Docs
FormatChanged Event
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBox ► FormatChanged
Keyoti RapidSpell Desktop .NET
Event fired when formatting changes (such as font change).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler FormatChanged
public event EventHandler FormatChanged
Public Event FormatChanged As EventHandler
Public Event FormatChanged As EventHandler
public:
virtual  event EventHandler^ FormatChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ FormatChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract FormatChanged : IEvent<EventHandler,
    EventArgs>
override FormatChanged : IEvent<EventHandler,
    EventArgs>
abstract FormatChanged : IEvent<EventHandler,
    EventArgs>
override FormatChanged : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


GetBaselineOffsetAtCharIndex Method (i)

Keyoti RapidSpell Desktop .NET API Docs
GetBaselineOffsetAtCharIndex Method (i)
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBox ► GetBaselineOffsetAtCharIndex(Int32)
Keyoti RapidSpell Desktop .NET
Gets the baseline offset for a character at index i
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int GetBaselineOffsetAtCharIndex(
    int i
)
public int GetBaselineOffsetAtCharIndex(
    int i
)
Public Function GetBaselineOffsetAtCharIndex (
    i As Integer
) As Integer
Public Function GetBaselineOffsetAtCharIndex (
    i As Integer
) As Integer
public:
virtual int GetBaselineOffsetAtCharIndex(
    int i
) sealed
public:
virtual int GetBaselineOffsetAtCharIndex(
    int i
) sealed
abstract GetBaselineOffsetAtCharIndex :
        i : int -> int
override GetBaselineOffsetAtCharIndex :
        i : int -> int
abstract GetBaselineOffsetAtCharIndex :
        i : int -> int
override GetBaselineOffsetAtCharIndex :
        i : int -> int
Parameters
i (Int32)
Return Value
Int32


GetCharIndexFromPos Method (pos)

Keyoti RapidSpell Desktop .NET API Docs
GetCharIndexFromPos Method (pos)
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBox ► GetCharIndexFromPos(Point)
Keyoti RapidSpell Desktop .NET
gets the char index from a position point.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int GetCharIndexFromPos(
    Point pos
)
public int GetCharIndexFromPos(
    Point pos
)
Public Function GetCharIndexFromPos (
    pos As Point
) As Integer
Public Function GetCharIndexFromPos (
    pos As Point
) As Integer
public:
virtual int GetCharIndexFromPos(
    Point pos
) sealed
public:
virtual int GetCharIndexFromPos(
    Point pos
) sealed
abstract GetCharIndexFromPos :
        pos : Point -> int
override GetCharIndexFromPos :
        pos : Point -> int
abstract GetCharIndexFromPos :
        pos : Point -> int
override GetCharIndexFromPos :
        pos : Point -> int
Parameters
pos (Point)
Return Value
Int32


GetFirstVisibleCharIndex Method

Keyoti RapidSpell Desktop .NET API Docs
GetFirstVisibleCharIndex Method
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBox ► GetFirstVisibleCharIndex()()()()
Keyoti RapidSpell Desktop .NET
Gets the character index of the first visible character in the window, this is for optimization and can just return 0 if unavailable.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int GetFirstVisibleCharIndex()
public int GetFirstVisibleCharIndex()
Public Function GetFirstVisibleCharIndex As Integer
Public Function GetFirstVisibleCharIndex As Integer
public:
virtual int GetFirstVisibleCharIndex() sealed
public:
virtual int GetFirstVisibleCharIndex() sealed
abstract GetFirstVisibleCharIndex : unit -> int
override GetFirstVisibleCharIndex : unit -> int
abstract GetFirstVisibleCharIndex : unit -> int
override GetFirstVisibleCharIndex : unit -> int
Return Value
Int32


GetPosFromCharIndex Method (ind)

Keyoti RapidSpell Desktop .NET API Docs
GetPosFromCharIndex Method (ind)
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBox ► GetPosFromCharIndex(Int32)
Keyoti RapidSpell Desktop .NET
Gets the position point from the char index
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Point GetPosFromCharIndex(
    int ind
)
public Point GetPosFromCharIndex(
    int ind
)
Public Function GetPosFromCharIndex (
    ind As Integer
) As Point
Public Function GetPosFromCharIndex (
    ind As Integer
) As Point
public:
virtual Point GetPosFromCharIndex(
    int ind
) sealed
public:
virtual Point GetPosFromCharIndex(
    int ind
) sealed
abstract GetPosFromCharIndex :
        ind : int -> Point
override GetPosFromCharIndex :
        ind : int -> Point
abstract GetPosFromCharIndex :
        ind : int -> Point
override GetPosFromCharIndex :
        ind : int -> Point
Parameters
ind (Int32)
Return Value
Point


GetTBU Method

Keyoti RapidSpell Desktop .NET API Docs
GetTBU Method
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBox ► GetTBU()()()()
Keyoti RapidSpell Desktop .NET
Interface requirement
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public TextBoxUtilityAdapter GetTBU()
public TextBoxUtilityAdapter GetTBU()
Public Function GetTBU As TextBoxUtilityAdapter
Public Function GetTBU As TextBoxUtilityAdapter
public:
virtual TextBoxUtilityAdapter^ GetTBU() sealed
public:
virtual TextBoxUtilityAdapter^ GetTBU() sealed
abstract GetTBU : unit -> TextBoxUtilityAdapter
override GetTBU : unit -> TextBoxUtilityAdapter
abstract GetTBU : unit -> TextBoxUtilityAdapter
override GetTBU : unit -> TextBoxUtilityAdapter
Return Value
TextBoxUtilityAdapter


HScrolled Event

Keyoti RapidSpell Desktop .NET API Docs
HScrolled Event
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBox ► HScrolled
Keyoti RapidSpell Desktop .NET
Event fired when horizontal scroll changed (by anything).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler HScrolled
public event EventHandler HScrolled
Public Event HScrolled As EventHandler
Public Event HScrolled As EventHandler
public:
virtual  event EventHandler^ HScrolled {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ HScrolled {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract HScrolled : IEvent<EventHandler,
    EventArgs>
override HScrolled : IEvent<EventHandler,
    EventArgs>
abstract HScrolled : IEvent<EventHandler,
    EventArgs>
override HScrolled : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


Pasting Event

Keyoti RapidSpell Desktop .NET API Docs
Pasting Event
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBox ► Pasting
Keyoti RapidSpell Desktop .NET
Occurs when text is about to be pasted.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler Pasting
public event EventHandler Pasting
Public Event Pasting As EventHandler
Public Event Pasting As EventHandler
public:
 event EventHandler^ Pasting {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
 event EventHandler^ Pasting {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member Pasting : IEvent<EventHandler,
    EventArgs>

member Pasting : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


ScrollCaret Event

Keyoti RapidSpell Desktop .NET API Docs
ScrollCaret Event
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBox ► ScrollCaret
Keyoti RapidSpell Desktop .NET
Occurs when the text box is scrolled to the caret.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler ScrollCaret
public event EventHandler ScrollCaret
Public Event ScrollCaret As EventHandler
Public Event ScrollCaret As EventHandler
public:
virtual  event EventHandler^ ScrollCaret {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ ScrollCaret {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ScrollCaret : IEvent<EventHandler,
    EventArgs>
override ScrollCaret : IEvent<EventHandler,
    EventArgs>
abstract ScrollCaret : IEvent<EventHandler,
    EventArgs>
override ScrollCaret : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


SelectedText Property

Keyoti RapidSpell Desktop .NET API Docs
SelectedText Property
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBox ► SelectedText
Keyoti RapidSpell Desktop .NET
The selected text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override string SelectedText { get; set; }
public override string SelectedText { get; set; }
Public Overrides Property SelectedText As String
    Get
    Set
Public Overrides Property SelectedText As String
    Get
    Set
public:
virtual property String^ SelectedText {
    String^ get () override;
    void set (String^ value) override;
}
public:
virtual property String^ SelectedText {
    String^ get () override;
    void set (String^ value) override;
}
abstract SelectedText : string with get, set
override SelectedText : string with get, set
abstract SelectedText : string with get, set
override SelectedText : string with get, set
Property Value
String


SelectionChanged Event

Keyoti RapidSpell Desktop .NET API Docs
SelectionChanged Event
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBox ► SelectionChanged
Keyoti RapidSpell Desktop .NET
Occurs when the selection of text within the control has changed.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler SelectionChanged
public event EventHandler SelectionChanged
Public Event SelectionChanged As EventHandler
Public Event SelectionChanged As EventHandler
public:
 event EventHandler^ SelectionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
 event EventHandler^ SelectionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member SelectionChanged : IEvent<EventHandler,
    EventArgs>

member SelectionChanged : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


SelectionLength Property

Keyoti RapidSpell Desktop .NET API Docs
SelectionLength Property
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBox ► SelectionLength
Keyoti RapidSpell Desktop .NET
This member overrides TextBox.SelectionLength.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override int SelectionLength { get; set; }
public override int SelectionLength { get; set; }
Public Overrides Property SelectionLength As Integer
    Get
    Set
Public Overrides Property SelectionLength As Integer
    Get
    Set
public:
virtual property int SelectionLength {
    int get () override;
    void set (int value) override;
}
public:
virtual property int SelectionLength {
    int get () override;
    void set (int value) override;
}
abstract SelectionLength : int with get, set
override SelectionLength : int with get, set
abstract SelectionLength : int with get, set
override SelectionLength : int with get, set
Property Value
Int32


SelectionStart Property

Keyoti RapidSpell Desktop .NET API Docs
SelectionStart Property
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBox ► SelectionStart
Keyoti RapidSpell Desktop .NET
Gets or sets the starting point of text selected in the text box.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int SelectionStart { get; set; }
public int SelectionStart { get; set; }
Public Property SelectionStart As Integer
    Get
    Set
Public Property SelectionStart As Integer
    Get
    Set
public:
virtual property int SelectionStart {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int SelectionStart {
    int get () sealed;
    void set (int value) sealed;
}
abstract SelectionStart : int with get, set
override SelectionStart : int with get, set
abstract SelectionStart : int with get, set
override SelectionStart : int with get, set
Property Value
Int32
Remarks
If no text is selected in the control, this property indicates the insertion point for new text. If you set this property to a location beyond the length of the text in the control, the selection start position will be placed after the last character. When text is selected in the text box control, changing this property might decrease the value of the SelectionLength property. If the remaining text in the control after the position indicated by the SelectionStart property is less than the value of the SelectionLength property, the value of the SelectionLength property is automatically decreased. The value of the SelectionStart property never causes an increase in the SelectionLength property. Note You can programmatically move the caret within the text box by setting the SelectionStart to the position within the text box where you want the caret to move to and set the SelectionLength property to a value of zero (0). The text box must have focus in order for the caret to be moved.


ShowCutCopyPasteContextMenu Property

Keyoti RapidSpell Desktop .NET API Docs
ShowCutCopyPasteContextMenu Property
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBox ► ShowCutCopyPasteContextMenu
Keyoti RapidSpell Desktop .NET
Whether to show the standard Undo/Cut/Copy/Paste/Delete/Select All context menu.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool ShowCutCopyPasteContextMenu { get; set; }
public virtual bool ShowCutCopyPasteContextMenu { get; set; }
Public Overridable Property ShowCutCopyPasteContextMenu As Boolean
    Get
    Set
Public Overridable Property ShowCutCopyPasteContextMenu As Boolean
    Get
    Set
public:
virtual property bool ShowCutCopyPasteContextMenu {
    bool get ();
    void set (bool value);
}
public:
virtual property bool ShowCutCopyPasteContextMenu {
    bool get ();
    void set (bool value);
}
abstract ShowCutCopyPasteContextMenu : bool with get, set
override ShowCutCopyPasteContextMenu : bool with get, set
abstract ShowCutCopyPasteContextMenu : bool with get, set
override ShowCutCopyPasteContextMenu : bool with get, set
Property Value
Boolean


UnderlineYOffset Property

Keyoti RapidSpell Desktop .NET API Docs
UnderlineYOffset Property
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBox ► UnderlineYOffset
Keyoti RapidSpell Desktop .NET
Controls the position of the underline relative to the baseline.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int UnderlineYOffset { get; set; }
public int UnderlineYOffset { get; set; }
Public Property UnderlineYOffset As Integer
    Get
    Set
Public Property UnderlineYOffset As Integer
    Get
    Set
public:
property int UnderlineYOffset {
    int get ();
    void set (int value);
}
public:
property int UnderlineYOffset {
    int get ();
    void set (int value);
}
member UnderlineYOffset : int with get, set

member UnderlineYOffset : int with get, set
Property Value
Int32


VScrolled Event

Keyoti RapidSpell Desktop .NET API Docs
VScrolled Event
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBox ► VScrolled
Keyoti RapidSpell Desktop .NET
Event fired when vertical scroll changed (by anything).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler VScrolled
public event EventHandler VScrolled
Public Event VScrolled As EventHandler
Public Event VScrolled As EventHandler
public:
virtual  event EventHandler^ VScrolled {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ VScrolled {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract VScrolled : IEvent<EventHandler,
    EventArgs>
override VScrolled : IEvent<EventHandler,
    EventArgs>
abstract VScrolled : IEvent<EventHandler,
    EventArgs>
override VScrolled : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


VScrollEnd Event

Keyoti RapidSpell Desktop .NET API Docs
VScrollEnd Event
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBox ► VScrollEnd
Keyoti RapidSpell Desktop .NET
Event fired when vertical scroll ends.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler VScrollEnd
public event EventHandler VScrollEnd
Public Event VScrollEnd As EventHandler
Public Event VScrollEnd As EventHandler
public:
virtual  event EventHandler^ VScrollEnd {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ VScrollEnd {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract VScrollEnd : IEvent<EventHandler,
    EventArgs>
override VScrollEnd : IEvent<EventHandler,
    EventArgs>
abstract VScrollEnd : IEvent<EventHandler,
    EventArgs>
override VScrollEnd : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


WndProc Method (m)

Keyoti RapidSpell Desktop .NET API Docs
WndProc Method (m)
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBox ► WndProc(Message%)
Keyoti RapidSpell Desktop .NET
Handles WndProc events and dispatches new events.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override void WndProc(
    ref Message m
)
protected override void WndProc(
    ref Message m
)
Protected Overrides Sub WndProc (
    ByRef m As Message
)
Protected Overrides Sub WndProc (
    ByRef m As Message
)
protected:
virtual void WndProc(
    Message% m
) override
protected:
virtual void WndProc(
    Message% m
) override
abstract WndProc :
        m : Message byref -> unit
override WndProc :
        m : Message byref -> unit
abstract WndProc :
        m : Message byref -> unit
override WndProc :
        m : Message byref -> unit
Parameters
m (Message %)


DataGridAYTTextBoxColumn Class

Keyoti RapidSpell Desktop .NET API Docs
DataGridAYTTextBoxColumn Class
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBoxColumn
Keyoti RapidSpell Desktop .NET
Summary description for DataGridAYTTextBoxColumn.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class DataGridAYTTextBoxColumn : DataGridColumnStyle
public class DataGridAYTTextBoxColumn : DataGridColumnStyle
Public Class DataGridAYTTextBoxColumn
    Inherits DataGridColumnStyle
Public Class DataGridAYTTextBoxColumn
    Inherits DataGridColumnStyle
public ref class DataGridAYTTextBoxColumn : public DataGridColumnStyle
public ref class DataGridAYTTextBoxColumn : public DataGridColumnStyle
type DataGridAYTTextBoxColumn =
    class
        inherit DataGridColumnStyle
    end
type DataGridAYTTextBoxColumn =
    class
        inherit DataGridColumnStyle
    end
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataGridAYTTextBoxColumn()()()() | New
 | DataGridAYTTextBoxColumn(PropertyDescriptor) | New
 | DataGridAYTTextBoxColumn(PropertyDescriptor, Boolean) | New
 | DataGridAYTTextBoxColumn(PropertyDescriptor, String) | New
 | DataGridAYTTextBoxColumn(PropertyDescriptor, String, Boolean) | New
 | Abort(Int32) | Abort (Overrides DataGridColumnStyle.Abort(Int32).)
 | Alignment | Gets or sets the alignment of text in a column. (Inherited from DataGridColumnStyle.)
 | AlignmentChanged | Occurs when the Alignment property value changes. (Inherited from DataGridColumnStyle.)
 | BeginUpdate()()()() | Suspends the painting of the column until the EndUpdate()()()() method is called. (Inherited from DataGridColumnStyle.)
 | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
 | CheckValidDataSource(CurrencyManager) | Throws an exception if the DataGrid does not have a valid data source, or if this column is not mapped to a valid property in the data source. (Inherited from DataGridColumnStyle.)
 | ColumnStartedEditing(Control) | Informs the DataGrid that the user has begun editing the column. (Inherited from DataGridColumnStyle.)
 | Commit(CurrencyManager, Int32) | Commit (Overrides DataGridColumnStyle.Commit(CurrencyManager, Int32).)
 | ConcedeFocus()()()() | Internal (Overrides DataGridColumnStyle.ConcedeFocus()()()().)
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | CreateHeaderAccessibleObject()()()() | Gets the AccessibleObject for the column. (Inherited from DataGridColumnStyle.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | DataGridTableStyle | Gets the DataGridTableStyle for the column. (Inherited from DataGridColumnStyle.)
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
 | Edit(CurrencyManager, Int32, Rectangle, Boolean, String, Boolean) | Internal (Overrides DataGridColumnStyle.Edit(CurrencyManager, Int32, Rectangle, Boolean, String, Boolean).)
 | Edit(CurrencyManager, Int32, Rectangle, Boolean) | Prepares a cell for editing. (Inherited from DataGridColumnStyle.)
 | Edit(CurrencyManager, Int32, Rectangle, Boolean, String) | Prepares the cell for editing using the specified CurrencyManager, row number, and Rectangle parameters. (Inherited from DataGridColumnStyle.)
 | EndEdit()()()() | Internal
 | EndUpdate()()()() | Resumes the painting of columns suspended by calling the BeginUpdate()()()() method. (Inherited from DataGridColumnStyle.)
 | EnterNullValue()()()() | Internal (Overrides DataGridColumnStyle.EnterNullValue()()()().)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | Finalize()()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | FontChanged | Occurs when the column's font changes. (Inherited from DataGridColumnStyle.)
 | FontHeight | Gets the height of the column's font. (Inherited from DataGridColumnStyle.)
 | Format | Internal
 | FormatInfo | Internal
 | GetColumnValueAtRow(CurrencyManager, Int32) | Gets the value in the specified row from the specified CurrencyManager. (Inherited from DataGridColumnStyle.)
 | GetDisplayText(Object) | Internal
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetMinimumHeight()()()() | Internal (Overrides DataGridColumnStyle.GetMinimumHeight()()()().)
 | GetPreferredHeight(Graphics, Object) | Internal (Overrides DataGridColumnStyle.GetPreferredHeight(Graphics, Object).)
 | GetPreferredSize(Graphics, Object) | Internal (Overrides DataGridColumnStyle.GetPreferredSize(Graphics, Object).)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | HeaderAccessibleObject | Gets the AccessibleObject for the column. (Inherited from DataGridColumnStyle.)
 | HeaderText | Gets or sets the text of the column header. (Inherited from DataGridColumnStyle.)
 | HeaderTextChanged | Occurs when the HeaderText property value changes. (Inherited from DataGridColumnStyle.)
 | HideEditBox()()()() | Internal
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | Invalidate()()()() | Redraws the column and causes a paint message to be sent to the control. (Inherited from DataGridColumnStyle.)
 | KeyPress(Int32, Keys) | Internal
 | MappingName | Gets or sets the name of the data member to map the column style to. (Inherited from DataGridColumnStyle.)
 | MappingNameChanged | Occurs when the MappingName value changes. (Inherited from DataGridColumnStyle.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NullText | Gets or sets the text that is displayed when the column contains null. (Inherited from DataGridColumnStyle.)
 | NullTextChanged | Occurs when the NullText value changes. (Inherited from DataGridColumnStyle.)
 | Paint(Graphics, Rectangle, CurrencyManager, Int32) | Internal (Overrides DataGridColumnStyle.Paint(Graphics, Rectangle, CurrencyManager, Int32).)
 | Paint(Graphics, Rectangle, CurrencyManager, Int32, Boolean) | Internal (Overrides DataGridColumnStyle.Paint(Graphics, Rectangle, CurrencyManager, Int32, Boolean).)
 | Paint(Graphics, Rectangle, CurrencyManager, Int32, Brush, Brush, Boolean) | Internal (Overrides DataGridColumnStyle.Paint(Graphics, Rectangle, CurrencyManager, Int32, Brush, Brush, Boolean).)
 | PaintSpellingErrorGlyph(Graphics, Rectangle, Brush, Boolean) | Paints spelling error glyph onto cell (appears as a small red 'e' by default), override this method to paint a different glyph - there is no requirement to call the base/MyBase method.
 | PaintText(Graphics, Rectangle, String, Boolean) | Internal
 | PaintText(Graphics, Rectangle, String, Brush, Brush, Boolean) | Internal
 | PropertyDescriptor | Internal (Overrides DataGridColumnStyle.PropertyDescriptor.)
 | PropertyDescriptorChanged | Occurs when the PropertyDescriptor property value changes. (Inherited from DataGridColumnStyle.)
 | RapidSpellAsYouType | The control which will do the spell checking.
 | ReadOnly | Internal (Overrides DataGridColumnStyle.ReadOnly.)
 | ReadOnlyChanged | Occurs when the ReadOnly property value changes. (Inherited from DataGridColumnStyle.)
 | ReleaseHostedControl()()()() | Allows the column to free resources when the control it hosts is not needed. (Inherited from DataGridColumnStyle.)
 | ResetHeaderText()()()() | Resets the HeaderText to its default value, null. (Inherited from DataGridColumnStyle.)
 | SetColumnValueAtRow(CurrencyManager, Int32, Object) | Sets the value in a specified row with the value from a specified CurrencyManager. (Inherited from DataGridColumnStyle.)
 | SetDataGrid(DataGrid) | Sets the DataGrid control that this column belongs to. (Inherited from DataGridColumnStyle.)
 | SetDataGridInColumn(DataGrid) | Internal (Overrides DataGridColumnStyle.SetDataGridInColumn(DataGrid).)
 | ShowErrorGlyph | Whether to paint a small 'e' glyph in the corner of the cell when it's not being edited and it contains a spelling error.
 | ShowErrorUnderline | Whether to paint an underline in the cell when it's not being edited and it contains a spelling error.
 | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
 | TextBox | Internal
 | ToString()()()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
 | UpdateUI(CurrencyManager, Int32, String) | Internal (Overrides DataGridColumnStyle.UpdateUI(CurrencyManager, Int32, String).)
 | Width | Gets or sets the width of the column. (Inherited from DataGridColumnStyle.)
 | WidthChanged | Occurs when the Width property value changes. (Inherited from DataGridColumnStyle.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | DataGridColumnStyle
 |  |  |  | DataGridAYTTextBoxColumn


DataGridAYTTextBoxColumn Constructor

Keyoti RapidSpell Desktop .NET API Docs
DataGridAYTTextBoxColumn Constructor
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBoxColumn ► DataGridAYTTextBoxColumn()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | DataGridAYTTextBoxColumn()()()() | New
 | DataGridAYTTextBoxColumn(PropertyDescriptor) | New
 | DataGridAYTTextBoxColumn(PropertyDescriptor, Boolean) | New
 | DataGridAYTTextBoxColumn(PropertyDescriptor, String) | New
 | DataGridAYTTextBoxColumn(PropertyDescriptor, String, Boolean) | New


DataGridAYTTextBoxColumn Constructor

Keyoti RapidSpell Desktop .NET API Docs
DataGridAYTTextBoxColumn Constructor
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBoxColumn ► DataGridAYTTextBoxColumn()()()()
Keyoti RapidSpell Desktop .NET
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public DataGridAYTTextBoxColumn()
public DataGridAYTTextBoxColumn()
Public Sub New
Public Sub New
public:
DataGridAYTTextBoxColumn()
public:
DataGridAYTTextBoxColumn()
new : unit -> DataGridAYTTextBoxColumn
new : unit -> DataGridAYTTextBoxColumn


DataGridAYTTextBoxColumn Constructor (prop)

Keyoti RapidSpell Desktop .NET API Docs
DataGridAYTTextBoxColumn Constructor (prop)
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBoxColumn ► DataGridAYTTextBoxColumn(PropertyDescriptor)
Keyoti RapidSpell Desktop .NET
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public DataGridAYTTextBoxColumn(
    PropertyDescriptor prop
)
public DataGridAYTTextBoxColumn(
    PropertyDescriptor prop
)
Public Sub New (
    prop As PropertyDescriptor
)
Public Sub New (
    prop As PropertyDescriptor
)
public:
DataGridAYTTextBoxColumn(
    PropertyDescriptor^ prop
)
public:
DataGridAYTTextBoxColumn(
    PropertyDescriptor^ prop
)
new :
        prop : PropertyDescriptor -> DataGridAYTTextBoxColumn
new :
        prop : PropertyDescriptor -> DataGridAYTTextBoxColumn
Parameters
prop (PropertyDescriptor)


DataGridAYTTextBoxColumn Constructor (prop, isDefault)

Keyoti RapidSpell Desktop .NET API Docs
DataGridAYTTextBoxColumn Constructor (prop, isDefault)
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBoxColumn ► DataGridAYTTextBoxColumn(PropertyDescriptor, Boolean)
Keyoti RapidSpell Desktop .NET
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public DataGridAYTTextBoxColumn(
    PropertyDescriptor prop,
    bool isDefault
)
public DataGridAYTTextBoxColumn(
    PropertyDescriptor prop,
    bool isDefault
)
Public Sub New (
    prop As PropertyDescriptor,
    isDefault As Boolean
)
Public Sub New (
    prop As PropertyDescriptor,
    isDefault As Boolean
)
public:
DataGridAYTTextBoxColumn(
    PropertyDescriptor^ prop,
    bool isDefault
)
public:
DataGridAYTTextBoxColumn(
    PropertyDescriptor^ prop,
    bool isDefault
)
new :
        prop : PropertyDescriptor *
        isDefault : bool -> DataGridAYTTextBoxColumn
new :
        prop : PropertyDescriptor *
        isDefault : bool -> DataGridAYTTextBoxColumn
Parameters
prop (PropertyDescriptor)
isDefault (Boolean)


DataGridAYTTextBoxColumn Constructor (prop, format)

Keyoti RapidSpell Desktop .NET API Docs
DataGridAYTTextBoxColumn Constructor (prop, format)
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBoxColumn ► DataGridAYTTextBoxColumn(PropertyDescriptor, String)
Keyoti RapidSpell Desktop .NET
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public DataGridAYTTextBoxColumn(
    PropertyDescriptor prop,
    string format
)
public DataGridAYTTextBoxColumn(
    PropertyDescriptor prop,
    string format
)
Public Sub New (
    prop As PropertyDescriptor,
    format As String
)
Public Sub New (
    prop As PropertyDescriptor,
    format As String
)
public:
DataGridAYTTextBoxColumn(
    PropertyDescriptor^ prop,
    String^ format
)
public:
DataGridAYTTextBoxColumn(
    PropertyDescriptor^ prop,
    String^ format
)
new :
        prop : PropertyDescriptor *
        format : string -> DataGridAYTTextBoxColumn
new :
        prop : PropertyDescriptor *
        format : string -> DataGridAYTTextBoxColumn
Parameters
prop (PropertyDescriptor)
format (String)


DataGridAYTTextBoxColumn Constructor (prop, format, isDefault)

Keyoti RapidSpell Desktop .NET API Docs
DataGridAYTTextBoxColumn Constructor (prop, format, isDefault)
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBoxColumn ► DataGridAYTTextBoxColumn(PropertyDescriptor, String, Boolean)
Keyoti RapidSpell Desktop .NET
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public DataGridAYTTextBoxColumn(
    PropertyDescriptor prop,
    string format,
    bool isDefault
)
public DataGridAYTTextBoxColumn(
    PropertyDescriptor prop,
    string format,
    bool isDefault
)
Public Sub New (
    prop As PropertyDescriptor,
    format As String,
    isDefault As Boolean
)
Public Sub New (
    prop As PropertyDescriptor,
    format As String,
    isDefault As Boolean
)
public:
DataGridAYTTextBoxColumn(
    PropertyDescriptor^ prop,
    String^ format,
    bool isDefault
)
public:
DataGridAYTTextBoxColumn(
    PropertyDescriptor^ prop,
    String^ format,
    bool isDefault
)
new :
        prop : PropertyDescriptor *
        format : string *
        isDefault : bool -> DataGridAYTTextBoxColumn
new :
        prop : PropertyDescriptor *
        format : string *
        isDefault : bool -> DataGridAYTTextBoxColumn
Parameters
prop (PropertyDescriptor)
format (String)
isDefault (Boolean)


Abort Method (rowNum)

Keyoti RapidSpell Desktop .NET API Docs
Abort Method (rowNum)
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBoxColumn ► Abort(Int32)
Keyoti RapidSpell Desktop .NET
Abort
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override void Abort(
    int rowNum
)
protected override void Abort(
    int rowNum
)
Protected Overrides Sub Abort (
    rowNum As Integer
)
Protected Overrides Sub Abort (
    rowNum As Integer
)
protected:
virtual void Abort(
    int rowNum
) override
protected:
virtual void Abort(
    int rowNum
) override
abstract Abort :
        rowNum : int -> unit
override Abort :
        rowNum : int -> unit
abstract Abort :
        rowNum : int -> unit
override Abort :
        rowNum : int -> unit
Parameters
rowNum (Int32)


Commit Method (dataSource, rowNum)

Keyoti RapidSpell Desktop .NET API Docs
Commit Method (dataSource, rowNum)
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBoxColumn ► Commit(CurrencyManager, Int32)
Keyoti RapidSpell Desktop .NET
Commit
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override bool Commit(
    CurrencyManager dataSource,
    int rowNum
)
protected override bool Commit(
    CurrencyManager dataSource,
    int rowNum
)
Protected Overrides Function Commit (
    dataSource As CurrencyManager,
    rowNum As Integer
) As Boolean
Protected Overrides Function Commit (
    dataSource As CurrencyManager,
    rowNum As Integer
) As Boolean
protected:
virtual bool Commit(
    CurrencyManager^ dataSource,
    int rowNum
) override
protected:
virtual bool Commit(
    CurrencyManager^ dataSource,
    int rowNum
) override
abstract Commit :
        dataSource : CurrencyManager *
        rowNum : int -> bool
override Commit :
        dataSource : CurrencyManager *
        rowNum : int -> bool
abstract Commit :
        dataSource : CurrencyManager *
        rowNum : int -> bool
override Commit :
        dataSource : CurrencyManager *
        rowNum : int -> bool
Parameters
dataSource (CurrencyManager)
rowNum (Int32)
Return Value
Boolean


ConcedeFocus Method

Keyoti RapidSpell Desktop .NET API Docs
ConcedeFocus Method
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBoxColumn ► ConcedeFocus()()()()
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override void ConcedeFocus()
protected override void ConcedeFocus()
Protected Overrides Sub ConcedeFocus
Protected Overrides Sub ConcedeFocus
protected:
virtual void ConcedeFocus() override
protected:
virtual void ConcedeFocus() override
abstract ConcedeFocus : unit -> unit
override ConcedeFocus : unit -> unit
abstract ConcedeFocus : unit -> unit
override ConcedeFocus : unit -> unit


Edit Method (source, rowNum, bounds, readOnly, instantText, cellIsVisible)

Keyoti RapidSpell Desktop .NET API Docs
Edit Method (source, rowNum, bounds, readOnly, instantText, cellIsVisible)
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBoxColumn ► Edit(CurrencyManager, Int32, Rectangle, Boolean, String, Boolean)
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override void Edit(
    CurrencyManager source,
    int rowNum,
    Rectangle bounds,
    bool readOnly,
    string instantText,
    bool cellIsVisible
)
protected override void Edit(
    CurrencyManager source,
    int rowNum,
    Rectangle bounds,
    bool readOnly,
    string instantText,
    bool cellIsVisible
)
Protected Overrides Sub Edit (
    source As CurrencyManager,
    rowNum As Integer,
    bounds As Rectangle,
    readOnly As Boolean,
    instantText As String,
    cellIsVisible As Boolean
)
Protected Overrides Sub Edit (
    source As CurrencyManager,
    rowNum As Integer,
    bounds As Rectangle,
    readOnly As Boolean,
    instantText As String,
    cellIsVisible As Boolean
)
protected:
virtual void Edit(
    CurrencyManager^ source,
    int rowNum,
    Rectangle bounds,
    bool readOnly,
    String^ instantText,
    bool cellIsVisible
) override
protected:
virtual void Edit(
    CurrencyManager^ source,
    int rowNum,
    Rectangle bounds,
    bool readOnly,
    String^ instantText,
    bool cellIsVisible
) override
abstract Edit :
        source : CurrencyManager *
        rowNum : int *
        bounds : Rectangle *
        readOnly : bool *
        instantText : string *
        cellIsVisible : bool -> unit
override Edit :
        source : CurrencyManager *
        rowNum : int *
        bounds : Rectangle *
        readOnly : bool *
        instantText : string *
        cellIsVisible : bool -> unit
abstract Edit :
        source : CurrencyManager *
        rowNum : int *
        bounds : Rectangle *
        readOnly : bool *
        instantText : string *
        cellIsVisible : bool -> unit
override Edit :
        source : CurrencyManager *
        rowNum : int *
        bounds : Rectangle *
        readOnly : bool *
        instantText : string *
        cellIsVisible : bool -> unit
Parameters
source (CurrencyManager)
rowNum (Int32)
bounds (Rectangle)
readOnly (Boolean)
instantText (String)
cellIsVisible (Boolean)


EndEdit Method

Keyoti RapidSpell Desktop .NET API Docs
EndEdit Method
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBoxColumn ► EndEdit()()()()
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected void EndEdit()
protected void EndEdit()
Protected Sub EndEdit
Protected Sub EndEdit
protected:
void EndEdit()
protected:
void EndEdit()
member EndEdit : unit -> unit

member EndEdit : unit -> unit


EnterNullValue Method

Keyoti RapidSpell Desktop .NET API Docs
EnterNullValue Method
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBoxColumn ► EnterNullValue()()()()
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override void EnterNullValue()
protected override void EnterNullValue()
Protected Overrides Sub EnterNullValue
Protected Overrides Sub EnterNullValue
protected:
virtual void EnterNullValue() override
protected:
virtual void EnterNullValue() override
abstract EnterNullValue : unit -> unit
override EnterNullValue : unit -> unit
abstract EnterNullValue : unit -> unit
override EnterNullValue : unit -> unit


Format Property

Keyoti RapidSpell Desktop .NET API Docs
Format Property
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBoxColumn ► Format
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string Format { get; set; }
public string Format { get; set; }
Public Property Format As String
    Get
    Set
Public Property Format As String
    Get
    Set
public:
property String^ Format {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Format {
    String^ get ();
    void set (String^ value);
}
member Format : string with get, set

member Format : string with get, set
Property Value
String


FormatInfo Property

Keyoti RapidSpell Desktop .NET API Docs
FormatInfo Property
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBoxColumn ► FormatInfo
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public IFormatProvider FormatInfo { get; set; }
public IFormatProvider FormatInfo { get; set; }
Public Property FormatInfo As IFormatProvider
    Get
    Set
Public Property FormatInfo As IFormatProvider
    Get
    Set
public:
property IFormatProvider^ FormatInfo {
    IFormatProvider^ get ();
    void set (IFormatProvider^ value);
}
public:
property IFormatProvider^ FormatInfo {
    IFormatProvider^ get ();
    void set (IFormatProvider^ value);
}
member FormatInfo : IFormatProvider with get, set

member FormatInfo : IFormatProvider with get, set
Property Value
IFormatProvider


GetDisplayText Method (value)

Keyoti RapidSpell Desktop .NET API Docs
GetDisplayText Method (value)
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBoxColumn ► GetDisplayText(Object)
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected string GetDisplayText(
    Object value
)
protected string GetDisplayText(
    Object value
)
Protected Function GetDisplayText (
    value As Object
) As String
Protected Function GetDisplayText (
    value As Object
) As String
protected:
String^ GetDisplayText(
    Object^ value
)
protected:
String^ GetDisplayText(
    Object^ value
)
member GetDisplayText :
        value : Object -> string

member GetDisplayText :
        value : Object -> string
Parameters
value (Object)
Return Value
String


GetMinimumHeight Method

Keyoti RapidSpell Desktop .NET API Docs
GetMinimumHeight Method
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBoxColumn ► GetMinimumHeight()()()()
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override int GetMinimumHeight()
protected override int GetMinimumHeight()
Protected Overrides Function GetMinimumHeight As Integer
Protected Overrides Function GetMinimumHeight As Integer
protected:
virtual int GetMinimumHeight() override
protected:
virtual int GetMinimumHeight() override
abstract GetMinimumHeight : unit -> int
override GetMinimumHeight : unit -> int
abstract GetMinimumHeight : unit -> int
override GetMinimumHeight : unit -> int
Return Value
Int32


GetPreferredHeight Method (g, value)

Keyoti RapidSpell Desktop .NET API Docs
GetPreferredHeight Method (g, value)
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBoxColumn ► GetPreferredHeight(Graphics, Object)
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override int GetPreferredHeight(
    Graphics g,
    Object value
)
protected override int GetPreferredHeight(
    Graphics g,
    Object value
)
Protected Overrides Function GetPreferredHeight (
    g As Graphics,
    value As Object
) As Integer
Protected Overrides Function GetPreferredHeight (
    g As Graphics,
    value As Object
) As Integer
protected:
virtual int GetPreferredHeight(
    Graphics^ g,
    Object^ value
) override
protected:
virtual int GetPreferredHeight(
    Graphics^ g,
    Object^ value
) override
abstract GetPreferredHeight :
        g : Graphics *
        value : Object -> int
override GetPreferredHeight :
        g : Graphics *
        value : Object -> int
abstract GetPreferredHeight :
        g : Graphics *
        value : Object -> int
override GetPreferredHeight :
        g : Graphics *
        value : Object -> int
Parameters
g (Graphics)
value (Object)
Return Value
Int32


GetPreferredSize Method (g, value)

Keyoti RapidSpell Desktop .NET API Docs
GetPreferredSize Method (g, value)
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBoxColumn ► GetPreferredSize(Graphics, Object)
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override Size GetPreferredSize(
    Graphics g,
    Object value
)
protected override Size GetPreferredSize(
    Graphics g,
    Object value
)
Protected Overrides Function GetPreferredSize (
    g As Graphics,
    value As Object
) As Size
Protected Overrides Function GetPreferredSize (
    g As Graphics,
    value As Object
) As Size
protected:
virtual Size GetPreferredSize(
    Graphics^ g,
    Object^ value
) override
protected:
virtual Size GetPreferredSize(
    Graphics^ g,
    Object^ value
) override
abstract GetPreferredSize :
        g : Graphics *
        value : Object -> Size
override GetPreferredSize :
        g : Graphics *
        value : Object -> Size
abstract GetPreferredSize :
        g : Graphics *
        value : Object -> Size
override GetPreferredSize :
        g : Graphics *
        value : Object -> Size
Parameters
g (Graphics)
value (Object)
Return Value
Size


HideEditBox Method

Keyoti RapidSpell Desktop .NET API Docs
HideEditBox Method
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBoxColumn ► HideEditBox()()()()
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected void HideEditBox()
protected void HideEditBox()
Protected Sub HideEditBox
Protected Sub HideEditBox
protected:
void HideEditBox()
protected:
void HideEditBox()
member HideEditBox : unit -> unit

member HideEditBox : unit -> unit


KeyPress Method (rowNum, keyData)

Keyoti RapidSpell Desktop .NET API Docs
KeyPress Method (rowNum, keyData)
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBoxColumn ► KeyPress(Int32, Keys)
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected bool KeyPress(
    int rowNum,
    Keys keyData
)
protected bool KeyPress(
    int rowNum,
    Keys keyData
)
Protected Function KeyPress (
    rowNum As Integer,
    keyData As Keys
) As Boolean
Protected Function KeyPress (
    rowNum As Integer,
    keyData As Keys
) As Boolean
protected:
bool KeyPress(
    int rowNum,
    Keys keyData
)
protected:
bool KeyPress(
    int rowNum,
    Keys keyData
)
member KeyPress :
        rowNum : int *
        keyData : Keys -> bool

member KeyPress :
        rowNum : int *
        keyData : Keys -> bool
Parameters
rowNum (Int32)
keyData (Keys)
Return Value
Boolean


Paint Method

Keyoti RapidSpell Desktop .NET API Docs
Paint Method
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBoxColumn ► Paint()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Paint(Graphics, Rectangle, CurrencyManager, Int32) | Internal (Overrides DataGridColumnStyle.Paint(Graphics, Rectangle, CurrencyManager, Int32).)
 | Paint(Graphics, Rectangle, CurrencyManager, Int32, Boolean) | Internal (Overrides DataGridColumnStyle.Paint(Graphics, Rectangle, CurrencyManager, Int32, Boolean).)
 | Paint(Graphics, Rectangle, CurrencyManager, Int32, Brush, Brush, Boolean) | Internal (Overrides DataGridColumnStyle.Paint(Graphics, Rectangle, CurrencyManager, Int32, Brush, Brush, Boolean).)


Paint Method (g, bounds, source, rowNum)

Keyoti RapidSpell Desktop .NET API Docs
Paint Method (g, bounds, source, rowNum)
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBoxColumn ► Paint(Graphics, Rectangle, CurrencyManager, Int32)
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override void Paint(
    Graphics g,
    Rectangle bounds,
    CurrencyManager source,
    int rowNum
)
protected override void Paint(
    Graphics g,
    Rectangle bounds,
    CurrencyManager source,
    int rowNum
)
Protected Overrides Sub Paint (
    g As Graphics,
    bounds As Rectangle,
    source As CurrencyManager,
    rowNum As Integer
)
Protected Overrides Sub Paint (
    g As Graphics,
    bounds As Rectangle,
    source As CurrencyManager,
    rowNum As Integer
)
protected:
virtual void Paint(
    Graphics^ g,
    Rectangle bounds,
    CurrencyManager^ source,
    int rowNum
) override
protected:
virtual void Paint(
    Graphics^ g,
    Rectangle bounds,
    CurrencyManager^ source,
    int rowNum
) override
abstract Paint :
        g : Graphics *
        bounds : Rectangle *
        source : CurrencyManager *
        rowNum : int -> unit
override Paint :
        g : Graphics *
        bounds : Rectangle *
        source : CurrencyManager *
        rowNum : int -> unit
abstract Paint :
        g : Graphics *
        bounds : Rectangle *
        source : CurrencyManager *
        rowNum : int -> unit
override Paint :
        g : Graphics *
        bounds : Rectangle *
        source : CurrencyManager *
        rowNum : int -> unit
Parameters
g (Graphics)
bounds (Rectangle)
source (CurrencyManager)
rowNum (Int32)


Paint Method (g, bounds, source, rowNum, alignToRight)

Keyoti RapidSpell Desktop .NET API Docs
Paint Method (g, bounds, source, rowNum, alignToRight)
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBoxColumn ► Paint(Graphics, Rectangle, CurrencyManager, Int32, Boolean)
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override void Paint(
    Graphics g,
    Rectangle bounds,
    CurrencyManager source,
    int rowNum,
    bool alignToRight
)
protected override void Paint(
    Graphics g,
    Rectangle bounds,
    CurrencyManager source,
    int rowNum,
    bool alignToRight
)
Protected Overrides Sub Paint (
    g As Graphics,
    bounds As Rectangle,
    source As CurrencyManager,
    rowNum As Integer,
    alignToRight As Boolean
)
Protected Overrides Sub Paint (
    g As Graphics,
    bounds As Rectangle,
    source As CurrencyManager,
    rowNum As Integer,
    alignToRight As Boolean
)
protected:
virtual void Paint(
    Graphics^ g,
    Rectangle bounds,
    CurrencyManager^ source,
    int rowNum,
    bool alignToRight
) override
protected:
virtual void Paint(
    Graphics^ g,
    Rectangle bounds,
    CurrencyManager^ source,
    int rowNum,
    bool alignToRight
) override
abstract Paint :
        g : Graphics *
        bounds : Rectangle *
        source : CurrencyManager *
        rowNum : int *
        alignToRight : bool -> unit
override Paint :
        g : Graphics *
        bounds : Rectangle *
        source : CurrencyManager *
        rowNum : int *
        alignToRight : bool -> unit
abstract Paint :
        g : Graphics *
        bounds : Rectangle *
        source : CurrencyManager *
        rowNum : int *
        alignToRight : bool -> unit
override Paint :
        g : Graphics *
        bounds : Rectangle *
        source : CurrencyManager *
        rowNum : int *
        alignToRight : bool -> unit
Parameters
g (Graphics)
bounds (Rectangle)
source (CurrencyManager)
rowNum (Int32)
alignToRight (Boolean)


Paint Method (g, bounds, source, rowNum, backBrush, foreBrush, alignToRight)

Keyoti RapidSpell Desktop .NET API Docs
Paint Method (g, bounds, source, rowNum, backBrush, foreBrush, alignToRight)
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBoxColumn ► Paint(Graphics, Rectangle, CurrencyManager, Int32, Brush, Brush, Boolean)
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override void Paint(
    Graphics g,
    Rectangle bounds,
    CurrencyManager source,
    int rowNum,
    Brush backBrush,
    Brush foreBrush,
    bool alignToRight
)
protected override void Paint(
    Graphics g,
    Rectangle bounds,
    CurrencyManager source,
    int rowNum,
    Brush backBrush,
    Brush foreBrush,
    bool alignToRight
)
Protected Overrides Sub Paint (
    g As Graphics,
    bounds As Rectangle,
    source As CurrencyManager,
    rowNum As Integer,
    backBrush As Brush,
    foreBrush As Brush,
    alignToRight As Boolean
)
Protected Overrides Sub Paint (
    g As Graphics,
    bounds As Rectangle,
    source As CurrencyManager,
    rowNum As Integer,
    backBrush As Brush,
    foreBrush As Brush,
    alignToRight As Boolean
)
protected:
virtual void Paint(
    Graphics^ g,
    Rectangle bounds,
    CurrencyManager^ source,
    int rowNum,
    Brush^ backBrush,
    Brush^ foreBrush,
    bool alignToRight
) override
protected:
virtual void Paint(
    Graphics^ g,
    Rectangle bounds,
    CurrencyManager^ source,
    int rowNum,
    Brush^ backBrush,
    Brush^ foreBrush,
    bool alignToRight
) override
abstract Paint :
        g : Graphics *
        bounds : Rectangle *
        source : CurrencyManager *
        rowNum : int *
        backBrush : Brush *
        foreBrush : Brush *
        alignToRight : bool -> unit
override Paint :
        g : Graphics *
        bounds : Rectangle *
        source : CurrencyManager *
        rowNum : int *
        backBrush : Brush *
        foreBrush : Brush *
        alignToRight : bool -> unit
abstract Paint :
        g : Graphics *
        bounds : Rectangle *
        source : CurrencyManager *
        rowNum : int *
        backBrush : Brush *
        foreBrush : Brush *
        alignToRight : bool -> unit
override Paint :
        g : Graphics *
        bounds : Rectangle *
        source : CurrencyManager *
        rowNum : int *
        backBrush : Brush *
        foreBrush : Brush *
        alignToRight : bool -> unit
Parameters
g (Graphics)
bounds (Rectangle)
source (CurrencyManager)
rowNum (Int32)
backBrush (Brush)
foreBrush (Brush)
alignToRight (Boolean)


PaintSpellingErrorGlyph Method (g, bounds, foreBrush, alignToRight)

Keyoti RapidSpell Desktop .NET API Docs
PaintSpellingErrorGlyph Method (g, bounds, foreBrush, alignToRight)
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBoxColumn ► PaintSpellingErrorGlyph(Graphics, Rectangle, Brush, Boolean)
Keyoti RapidSpell Desktop .NET
Paints spelling error glyph onto cell (appears as a small red 'e' by default), override this method to paint a different glyph - there is no requirement to call the base/MyBase method.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected void PaintSpellingErrorGlyph(
    Graphics g,
    Rectangle bounds,
    Brush foreBrush,
    bool alignToRight
)
protected void PaintSpellingErrorGlyph(
    Graphics g,
    Rectangle bounds,
    Brush foreBrush,
    bool alignToRight
)
Protected Sub PaintSpellingErrorGlyph (
    g As Graphics,
    bounds As Rectangle,
    foreBrush As Brush,
    alignToRight As Boolean
)
Protected Sub PaintSpellingErrorGlyph (
    g As Graphics,
    bounds As Rectangle,
    foreBrush As Brush,
    alignToRight As Boolean
)
protected:
void PaintSpellingErrorGlyph(
    Graphics^ g,
    Rectangle bounds,
    Brush^ foreBrush,
    bool alignToRight
)
protected:
void PaintSpellingErrorGlyph(
    Graphics^ g,
    Rectangle bounds,
    Brush^ foreBrush,
    bool alignToRight
)
member PaintSpellingErrorGlyph :
        g : Graphics *
        bounds : Rectangle *
        foreBrush : Brush *
        alignToRight : bool -> unit

member PaintSpellingErrorGlyph :
        g : Graphics *
        bounds : Rectangle *
        foreBrush : Brush *
        alignToRight : bool -> unit
Parameters
g (Graphics)
bounds (Rectangle)
foreBrush (Brush)
alignToRight (Boolean)
Remarks
Eg. g.DrawString("e", new Font("Verdana", 7), new SolidBrush(Color.Red),bounds.Right-9,bounds.Y-5);


PaintText Method

Keyoti RapidSpell Desktop .NET API Docs
PaintText Method
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBoxColumn ► PaintText()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | PaintText(Graphics, Rectangle, String, Boolean) | Internal
 | PaintText(Graphics, Rectangle, String, Brush, Brush, Boolean) | Internal


PaintText Method (g, bounds, text, alignToRight)

Keyoti RapidSpell Desktop .NET API Docs
PaintText Method (g, bounds, text, alignToRight)
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBoxColumn ► PaintText(Graphics, Rectangle, String, Boolean)
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected void PaintText(
    Graphics g,
    Rectangle bounds,
    string text,
    bool alignToRight
)
protected void PaintText(
    Graphics g,
    Rectangle bounds,
    string text,
    bool alignToRight
)
Protected Sub PaintText (
    g As Graphics,
    bounds As Rectangle,
    text As String,
    alignToRight As Boolean
)
Protected Sub PaintText (
    g As Graphics,
    bounds As Rectangle,
    text As String,
    alignToRight As Boolean
)
protected:
void PaintText(
    Graphics^ g,
    Rectangle bounds,
    String^ text,
    bool alignToRight
)
protected:
void PaintText(
    Graphics^ g,
    Rectangle bounds,
    String^ text,
    bool alignToRight
)
member PaintText :
        g : Graphics *
        bounds : Rectangle *
        text : string *
        alignToRight : bool -> unit

member PaintText :
        g : Graphics *
        bounds : Rectangle *
        text : string *
        alignToRight : bool -> unit
Parameters
g (Graphics)
bounds (Rectangle)
text (String)
alignToRight (Boolean)


PaintText Method (g, textBounds, text, backBrush, foreBrush, alignToRight)

Keyoti RapidSpell Desktop .NET API Docs
PaintText Method (g, textBounds, text, backBrush, foreBrush, alignToRight)
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBoxColumn ► PaintText(Graphics, Rectangle, String, Brush, Brush, Boolean)
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected void PaintText(
    Graphics g,
    Rectangle textBounds,
    string text,
    Brush backBrush,
    Brush foreBrush,
    bool alignToRight
)
protected void PaintText(
    Graphics g,
    Rectangle textBounds,
    string text,
    Brush backBrush,
    Brush foreBrush,
    bool alignToRight
)
Protected Sub PaintText (
    g As Graphics,
    textBounds As Rectangle,
    text As String,
    backBrush As Brush,
    foreBrush As Brush,
    alignToRight As Boolean
)
Protected Sub PaintText (
    g As Graphics,
    textBounds As Rectangle,
    text As String,
    backBrush As Brush,
    foreBrush As Brush,
    alignToRight As Boolean
)
protected:
void PaintText(
    Graphics^ g,
    Rectangle textBounds,
    String^ text,
    Brush^ backBrush,
    Brush^ foreBrush,
    bool alignToRight
)
protected:
void PaintText(
    Graphics^ g,
    Rectangle textBounds,
    String^ text,
    Brush^ backBrush,
    Brush^ foreBrush,
    bool alignToRight
)
member PaintText :
        g : Graphics *
        textBounds : Rectangle *
        text : string *
        backBrush : Brush *
        foreBrush : Brush *
        alignToRight : bool -> unit

member PaintText :
        g : Graphics *
        textBounds : Rectangle *
        text : string *
        backBrush : Brush *
        foreBrush : Brush *
        alignToRight : bool -> unit
Parameters
g (Graphics)
textBounds (Rectangle)
text (String)
backBrush (Brush)
foreBrush (Brush)
alignToRight (Boolean)


PropertyDescriptor Property

Keyoti RapidSpell Desktop .NET API Docs
PropertyDescriptor Property
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBoxColumn ► PropertyDescriptor
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override PropertyDescriptor PropertyDescriptor { set; }
public override PropertyDescriptor PropertyDescriptor { set; }
Public Overrides WriteOnly Property PropertyDescriptor As PropertyDescriptor
    Set
Public Overrides WriteOnly Property PropertyDescriptor As PropertyDescriptor
    Set
public:
virtual property PropertyDescriptor^ PropertyDescriptor {
    void set (PropertyDescriptor^ value) override;
}
public:
virtual property PropertyDescriptor^ PropertyDescriptor {
    void set (PropertyDescriptor^ value) override;
}
abstract PropertyDescriptor : PropertyDescriptor with set
override PropertyDescriptor : PropertyDescriptor with set
abstract PropertyDescriptor : PropertyDescriptor with set
override PropertyDescriptor : PropertyDescriptor with set
Property Value
PropertyDescriptor


RapidSpellAsYouType Property

Keyoti RapidSpell Desktop .NET API Docs
RapidSpellAsYouType Property
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBoxColumn ► RapidSpellAsYouType
Keyoti RapidSpell Desktop .NET
The control which will do the spell checking.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public RapidSpellAsYouType RapidSpellAsYouType { set; }
public RapidSpellAsYouType RapidSpellAsYouType { set; }
Public WriteOnly Property RapidSpellAsYouType As RapidSpellAsYouType
    Set
Public WriteOnly Property RapidSpellAsYouType As RapidSpellAsYouType
    Set
public:
property RapidSpellAsYouType^ RapidSpellAsYouType {
    void set (RapidSpellAsYouType^ value);
}
public:
property RapidSpellAsYouType^ RapidSpellAsYouType {
    void set (RapidSpellAsYouType^ value);
}
member RapidSpellAsYouType : RapidSpellAsYouType with set

member RapidSpellAsYouType : RapidSpellAsYouType with set
Property Value
RapidSpellAsYouType


ReadOnly Property

Keyoti RapidSpell Desktop .NET API Docs
ReadOnly Property
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBoxColumn ► ReadOnly
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override bool ReadOnly { get; set; }
public override bool ReadOnly { get; set; }
Public Overrides Property ReadOnly As Boolean
    Get
    Set
Public Overrides Property ReadOnly As Boolean
    Get
    Set
public:
virtual property bool ReadOnly {
    bool get () override;
    void set (bool value) override;
}
public:
virtual property bool ReadOnly {
    bool get () override;
    void set (bool value) override;
}
abstract ReadOnly : bool with get, set
override ReadOnly : bool with get, set
abstract ReadOnly : bool with get, set
override ReadOnly : bool with get, set
Property Value
Boolean


SetDataGridInColumn Method (value)

Keyoti RapidSpell Desktop .NET API Docs
SetDataGridInColumn Method (value)
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBoxColumn ► SetDataGridInColumn(DataGrid)
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override void SetDataGridInColumn(
    DataGrid value
)
protected override void SetDataGridInColumn(
    DataGrid value
)
Protected Overrides Sub SetDataGridInColumn (
    value As DataGrid
)
Protected Overrides Sub SetDataGridInColumn (
    value As DataGrid
)
protected:
virtual void SetDataGridInColumn(
    DataGrid^ value
) override
protected:
virtual void SetDataGridInColumn(
    DataGrid^ value
) override
abstract SetDataGridInColumn :
        value : DataGrid -> unit
override SetDataGridInColumn :
        value : DataGrid -> unit
abstract SetDataGridInColumn :
        value : DataGrid -> unit
override SetDataGridInColumn :
        value : DataGrid -> unit
Parameters
value (DataGrid)


ShowErrorGlyph Property

Keyoti RapidSpell Desktop .NET API Docs
ShowErrorGlyph Property
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBoxColumn ► ShowErrorGlyph
Keyoti RapidSpell Desktop .NET
Whether to paint a small 'e' glyph in the corner of the cell when it's not being edited and it contains a spelling error.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ShowErrorGlyph { get; set; }
public bool ShowErrorGlyph { get; set; }
Public Property ShowErrorGlyph As Boolean
    Get
    Set
Public Property ShowErrorGlyph As Boolean
    Get
    Set
public:
property bool ShowErrorGlyph {
    bool get ();
    void set (bool value);
}
public:
property bool ShowErrorGlyph {
    bool get ();
    void set (bool value);
}
member ShowErrorGlyph : bool with get, set

member ShowErrorGlyph : bool with get, set
Property Value
Boolean


ShowErrorUnderline Property

Keyoti RapidSpell Desktop .NET API Docs
ShowErrorUnderline Property
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBoxColumn ► ShowErrorUnderline
Keyoti RapidSpell Desktop .NET
Whether to paint an underline in the cell when it's not being edited and it contains a spelling error.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ShowErrorUnderline { get; set; }
public bool ShowErrorUnderline { get; set; }
Public Property ShowErrorUnderline As Boolean
    Get
    Set
Public Property ShowErrorUnderline As Boolean
    Get
    Set
public:
property bool ShowErrorUnderline {
    bool get ();
    void set (bool value);
}
public:
property bool ShowErrorUnderline {
    bool get ();
    void set (bool value);
}
member ShowErrorUnderline : bool with get, set

member ShowErrorUnderline : bool with get, set
Property Value
Boolean


TextBox Property

Keyoti RapidSpell Desktop .NET API Docs
TextBox Property
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBoxColumn ► TextBox
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual TextBox TextBox { get; }
public virtual TextBox TextBox { get; }
Public Overridable ReadOnly Property TextBox As TextBox
    Get
Public Overridable ReadOnly Property TextBox As TextBox
    Get
public:
virtual property TextBox^ TextBox {
    TextBox^ get ();
}
public:
virtual property TextBox^ TextBox {
    TextBox^ get ();
}
abstract TextBox : TextBox with get
override TextBox : TextBox with get
abstract TextBox : TextBox with get
override TextBox : TextBox with get
Property Value
TextBox


UpdateUI Method (source, rowNum, instantText)

Keyoti RapidSpell Desktop .NET API Docs
UpdateUI Method (source, rowNum, instantText)
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBoxColumn ► UpdateUI(CurrencyManager, Int32, String)
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override void UpdateUI(
    CurrencyManager source,
    int rowNum,
    string instantText
)
protected override void UpdateUI(
    CurrencyManager source,
    int rowNum,
    string instantText
)
Protected Overrides Sub UpdateUI (
    source As CurrencyManager,
    rowNum As Integer,
    instantText As String
)
Protected Overrides Sub UpdateUI (
    source As CurrencyManager,
    rowNum As Integer,
    instantText As String
)
protected:
virtual void UpdateUI(
    CurrencyManager^ source,
    int rowNum,
    String^ instantText
) override
protected:
virtual void UpdateUI(
    CurrencyManager^ source,
    int rowNum,
    String^ instantText
) override
abstract UpdateUI :
        source : CurrencyManager *
        rowNum : int *
        instantText : string -> unit
override UpdateUI :
        source : CurrencyManager *
        rowNum : int *
        instantText : string -> unit
abstract UpdateUI :
        source : CurrencyManager *
        rowNum : int *
        instantText : string -> unit
override UpdateUI :
        source : CurrencyManager *
        rowNum : int *
        instantText : string -> unit
Parameters
source (CurrencyManager)
rowNum (Int32)
instantText (String)


DataGridView_AYT_Manager Class

Keyoti RapidSpell Desktop .NET API Docs
DataGridView_AYT_Manager Class
API ► Keyoti.RapidSpell.Grid ► DataGridView_AYT_Manager
Keyoti RapidSpell Desktop .NET
Control used to couple a DataGridView control with RapidSpellAsYouType.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class DataGridView_AYT_Manager : Component
public class DataGridView_AYT_Manager : Component
Public Class DataGridView_AYT_Manager
    Inherits Component
Public Class DataGridView_AYT_Manager
    Inherits Component
public ref class DataGridView_AYT_Manager : public Component
public ref class DataGridView_AYT_Manager : public Component
type DataGridView_AYT_Manager =
    class
        inherit Component
    end
type DataGridView_AYT_Manager =
    class
        inherit Component
    end
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataGridView_AYT_Manager()()()() | Internal
 | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | DataGridView | The DataGridView control instance that will hold AYTDataGridViewTextBoxColumn columns
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ErrorGlyphSize | Font size for the error 'e'
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | Finalize()()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RapidSpellAsYouType | The RapidSpellAsYouType control instance that will spell check the columns
 | ShowErrorGlyph | Whether to paint a small 'e' glyph in the corner of the cell when it's not being edited and it contains a spelling error - this is instead of the underlines and performs faster.
 | ShowErrorUnderline | Whether to paint error underlines.
 | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
 | ToString()()()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Remarks
Please see user guide section on grids for more info.
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | DataGridView_AYT_Manager


DataGridView_AYT_Manager Constructor

Keyoti RapidSpell Desktop .NET API Docs
DataGridView_AYT_Manager Constructor
API ► Keyoti.RapidSpell.Grid ► DataGridView_AYT_Manager ► DataGridView_AYT_Manager()()()()
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public DataGridView_AYT_Manager()
public DataGridView_AYT_Manager()
Public Sub New
Public Sub New
public:
DataGridView_AYT_Manager()
public:
DataGridView_AYT_Manager()
new : unit -> DataGridView_AYT_Manager
new : unit -> DataGridView_AYT_Manager


DataGridView Property

Keyoti RapidSpell Desktop .NET API Docs
DataGridView Property
API ► Keyoti.RapidSpell.Grid ► DataGridView_AYT_Manager ► DataGridView
Keyoti RapidSpell Desktop .NET
The DataGridView control instance that will hold AYTDataGridViewTextBoxColumn columns
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public DataGridView DataGridView { get; set; }
public DataGridView DataGridView { get; set; }
Public Property DataGridView As DataGridView
    Get
    Set
Public Property DataGridView As DataGridView
    Get
    Set
public:
property DataGridView^ DataGridView {
    DataGridView^ get ();
    void set (DataGridView^ value);
}
public:
property DataGridView^ DataGridView {
    DataGridView^ get ();
    void set (DataGridView^ value);
}
member DataGridView : DataGridView with get, set

member DataGridView : DataGridView with get, set
Property Value
DataGridView


ErrorGlyphSize Property

Keyoti RapidSpell Desktop .NET API Docs
ErrorGlyphSize Property
API ► Keyoti.RapidSpell.Grid ► DataGridView_AYT_Manager ► ErrorGlyphSize
Keyoti RapidSpell Desktop .NET
Font size for the error 'e'
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int ErrorGlyphSize { get; set; }
public int ErrorGlyphSize { get; set; }
Public Property ErrorGlyphSize As Integer
    Get
    Set
Public Property ErrorGlyphSize As Integer
    Get
    Set
public:
property int ErrorGlyphSize {
    int get ();
    void set (int value);
}
public:
property int ErrorGlyphSize {
    int get ();
    void set (int value);
}
member ErrorGlyphSize : int with get, set

member ErrorGlyphSize : int with get, set
Property Value
Int32


RapidSpellAsYouType Property

Keyoti RapidSpell Desktop .NET API Docs
RapidSpellAsYouType Property
API ► Keyoti.RapidSpell.Grid ► DataGridView_AYT_Manager ► RapidSpellAsYouType
Keyoti RapidSpell Desktop .NET
The RapidSpellAsYouType control instance that will spell check the columns
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public RapidSpellAsYouType RapidSpellAsYouType { get; set; }
public RapidSpellAsYouType RapidSpellAsYouType { get; set; }
Public Property RapidSpellAsYouType As RapidSpellAsYouType
    Get
    Set
Public Property RapidSpellAsYouType As RapidSpellAsYouType
    Get
    Set
public:
property RapidSpellAsYouType^ RapidSpellAsYouType {
    RapidSpellAsYouType^ get ();
    void set (RapidSpellAsYouType^ value);
}
public:
property RapidSpellAsYouType^ RapidSpellAsYouType {
    RapidSpellAsYouType^ get ();
    void set (RapidSpellAsYouType^ value);
}
member RapidSpellAsYouType : RapidSpellAsYouType with get, set

member RapidSpellAsYouType : RapidSpellAsYouType with get, set
Property Value
RapidSpellAsYouType


ShowErrorGlyph Property

Keyoti RapidSpell Desktop .NET API Docs
ShowErrorGlyph Property
API ► Keyoti.RapidSpell.Grid ► DataGridView_AYT_Manager ► ShowErrorGlyph
Keyoti RapidSpell Desktop .NET
Whether to paint a small 'e' glyph in the corner of the cell when it's not being edited and it contains a spelling error - this is instead of the underlines and performs faster.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ShowErrorGlyph { get; set; }
public bool ShowErrorGlyph { get; set; }
Public Property ShowErrorGlyph As Boolean
    Get
    Set
Public Property ShowErrorGlyph As Boolean
    Get
    Set
public:
property bool ShowErrorGlyph {
    bool get ();
    void set (bool value);
}
public:
property bool ShowErrorGlyph {
    bool get ();
    void set (bool value);
}
member ShowErrorGlyph : bool with get, set

member ShowErrorGlyph : bool with get, set
Property Value
Boolean


ShowErrorUnderline Property

Keyoti RapidSpell Desktop .NET API Docs
ShowErrorUnderline Property
API ► Keyoti.RapidSpell.Grid ► DataGridView_AYT_Manager ► ShowErrorUnderline
Keyoti RapidSpell Desktop .NET
Whether to paint error underlines.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ShowErrorUnderline { get; set; }
public bool ShowErrorUnderline { get; set; }
Public Property ShowErrorUnderline As Boolean
    Get
    Set
Public Property ShowErrorUnderline As Boolean
    Get
    Set
public:
property bool ShowErrorUnderline {
    bool get ();
    void set (bool value);
}
public:
property bool ShowErrorUnderline {
    bool get ();
    void set (bool value);
}
member ShowErrorUnderline : bool with get, set

member ShowErrorUnderline : bool with get, set
Property Value
Boolean


GridUtilities Class

Keyoti RapidSpell Desktop .NET API Docs
GridUtilities Class
API ► Keyoti.RapidSpell.Grid ► GridUtilities
Keyoti RapidSpell Desktop .NET
Utility class for grid controls.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class GridUtilities
public class GridUtilities
Public Class GridUtilities
Public Class GridUtilities
public ref class GridUtilities
public ref class GridUtilities
type GridUtilities =  class end
type GridUtilities =  class end
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GridUtilities()()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MeasureDisplayStringWidth(Graphics, String, Font, Int32, String) | Calculates the width of a string.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
GridUtilities


GridUtilities Constructor

Keyoti RapidSpell Desktop .NET API Docs
GridUtilities Constructor
API ► Keyoti.RapidSpell.Grid ► GridUtilities ► GridUtilities()()()()
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public GridUtilities()
public GridUtilities()
Public Sub New
Public Sub New
public:
GridUtilities()
public:
GridUtilities()
new : unit -> GridUtilities
new : unit -> GridUtilities


MeasureDisplayStringWidth Method (graphics, text, font, maxWidth, formatString)

Keyoti RapidSpell Desktop .NET API Docs
MeasureDisplayStringWidth Method (graphics, text, font, maxWidth, formatString)
API ► Keyoti.RapidSpell.Grid ► GridUtilities ► MeasureDisplayStringWidth(Graphics, String, Font, Int32, String)
Keyoti RapidSpell Desktop .NET
Calculates the width of a string.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static int MeasureDisplayStringWidth(
    Graphics graphics,
    string text,
    Font font,
    int maxWidth,
    string formatString
)
public static int MeasureDisplayStringWidth(
    Graphics graphics,
    string text,
    Font font,
    int maxWidth,
    string formatString
)
Public Shared Function MeasureDisplayStringWidth (
    graphics As Graphics,
    text As String,
    font As Font,
    maxWidth As Integer,
    formatString As String
) As Integer
Public Shared Function MeasureDisplayStringWidth (
    graphics As Graphics,
    text As String,
    font As Font,
    maxWidth As Integer,
    formatString As String
) As Integer
public:
static int MeasureDisplayStringWidth(
    Graphics^ graphics,
    String^ text,
    Font^ font,
    int maxWidth,
    String^ formatString
)
public:
static int MeasureDisplayStringWidth(
    Graphics^ graphics,
    String^ text,
    Font^ font,
    int maxWidth,
    String^ formatString
)
static member MeasureDisplayStringWidth :
        graphics : Graphics *
        text : string *
        font : Font *
        maxWidth : int *
        formatString : string -> int

static member MeasureDisplayStringWidth :
        graphics : Graphics *
        text : string *
        font : Font *
        maxWidth : int *
        formatString : string -> int
Parameters
graphics (Graphics)
The graphics context
text (String)
The string to measure
font (Font)
The font the string is written in
maxWidth (Int32)
The maximum point to measure to (set to 1000 if uncertain).
formatString (String)
Format string used on the text. ("" if unspecified).
Return Value
Int32


SpellCheckableDataGridViewCell Class

Keyoti RapidSpell Desktop .NET API Docs
SpellCheckableDataGridViewCell Class
API ► Keyoti.RapidSpell.Grid ► SpellCheckableDataGridViewCell
Keyoti RapidSpell Desktop .NET
Wraps a DataGridViewCell so that it can be spell checked with RapidSpellDialog.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class SpellCheckableDataGridViewCell : ISpellCheckableTextComponent
public class SpellCheckableDataGridViewCell : ISpellCheckableTextComponent
Public Class SpellCheckableDataGridViewCell
    Implements ISpellCheckableTextComponent
Public Class SpellCheckableDataGridViewCell
    Implements ISpellCheckableTextComponent
public ref class SpellCheckableDataGridViewCell : ISpellCheckableTextComponent
public ref class SpellCheckableDataGridViewCell : ISpellCheckableTextComponent
type SpellCheckableDataGridViewCell =
    class
        interface ISpellCheckableTextComponent
    end
type SpellCheckableDataGridViewCell =
    class
        interface ISpellCheckableTextComponent
    end
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SpellCheckableDataGridViewCell(DataGridViewCell) | The cell being checked.
 | DataGridViewCell | The cell.
 | Dispose()()()() | Frees up resources.
 | Disposed | Fired when disposed.
 | Enabled | Always true.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GotFocus | Interface requirement, not implemented.
 | HideSelection | Always false, interface requirement.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReadOnly | Always false, interface requirement.
 | ScrollToCaret()()()() | Interface requirement.
 | SelectedText | Any selected text.
 | SelectionLength | Selection length
 | SelectionStart | Selection start.
 | Text | The cell text.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
SpellCheckableDataGridViewCell


SpellCheckableDataGridViewCell Constructor (dataGridViewCell)

Keyoti RapidSpell Desktop .NET API Docs
SpellCheckableDataGridViewCell Constructor (dataGridViewCell)
API ► Keyoti.RapidSpell.Grid ► SpellCheckableDataGridViewCell ► SpellCheckableDataGridViewCell(DataGridViewCell)
Keyoti RapidSpell Desktop .NET
The cell being checked.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public SpellCheckableDataGridViewCell(
    DataGridViewCell dataGridViewCell
)
public SpellCheckableDataGridViewCell(
    DataGridViewCell dataGridViewCell
)
Public Sub New (
    dataGridViewCell As DataGridViewCell
)
Public Sub New (
    dataGridViewCell As DataGridViewCell
)
public:
SpellCheckableDataGridViewCell(
    DataGridViewCell^ dataGridViewCell
)
public:
SpellCheckableDataGridViewCell(
    DataGridViewCell^ dataGridViewCell
)
new :
        dataGridViewCell : DataGridViewCell -> SpellCheckableDataGridViewCell
new :
        dataGridViewCell : DataGridViewCell -> SpellCheckableDataGridViewCell
Parameters
dataGridViewCell (DataGridViewCell)


DataGridViewCell Property

Keyoti RapidSpell Desktop .NET API Docs
DataGridViewCell Property
API ► Keyoti.RapidSpell.Grid ► SpellCheckableDataGridViewCell ► DataGridViewCell
Keyoti RapidSpell Desktop .NET
The cell.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public DataGridViewCell DataGridViewCell { get; }
public DataGridViewCell DataGridViewCell { get; }
Public ReadOnly Property DataGridViewCell As DataGridViewCell
    Get
Public ReadOnly Property DataGridViewCell As DataGridViewCell
    Get
public:
property DataGridViewCell^ DataGridViewCell {
    DataGridViewCell^ get ();
}
public:
property DataGridViewCell^ DataGridViewCell {
    DataGridViewCell^ get ();
}
member DataGridViewCell : DataGridViewCell with get

member DataGridViewCell : DataGridViewCell with get
Property Value
DataGridViewCell


Dispose Method

Keyoti RapidSpell Desktop .NET API Docs
Dispose Method
API ► Keyoti.RapidSpell.Grid ► SpellCheckableDataGridViewCell ► Dispose()()()()
Keyoti RapidSpell Desktop .NET
Frees up resources.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void Dispose()
public void Dispose()
Public Sub Dispose
Public Sub Dispose
public:
virtual void Dispose() sealed
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit
abstract Dispose : unit -> unit
override Dispose : unit -> unit


Disposed Event

Keyoti RapidSpell Desktop .NET API Docs
Disposed Event
API ► Keyoti.RapidSpell.Grid ► SpellCheckableDataGridViewCell ► Disposed
Keyoti RapidSpell Desktop .NET
Fired when disposed.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler Disposed
public event EventHandler Disposed
Public Event Disposed As EventHandler
Public Event Disposed As EventHandler
public:
virtual  event EventHandler^ Disposed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ Disposed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Disposed : IEvent<EventHandler,
    EventArgs>
override Disposed : IEvent<EventHandler,
    EventArgs>
abstract Disposed : IEvent<EventHandler,
    EventArgs>
override Disposed : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


Enabled Property

Keyoti RapidSpell Desktop .NET API Docs
Enabled Property
API ► Keyoti.RapidSpell.Grid ► SpellCheckableDataGridViewCell ► Enabled
Keyoti RapidSpell Desktop .NET
Always true.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool Enabled { get; }
public bool Enabled { get; }
Public ReadOnly Property Enabled As Boolean
    Get
Public ReadOnly Property Enabled As Boolean
    Get
public:
virtual property bool Enabled {
    bool get () sealed;
}
public:
virtual property bool Enabled {
    bool get () sealed;
}
abstract Enabled : bool with get
override Enabled : bool with get
abstract Enabled : bool with get
override Enabled : bool with get
Property Value
Boolean


GotFocus Event

Keyoti RapidSpell Desktop .NET API Docs
GotFocus Event
API ► Keyoti.RapidSpell.Grid ► SpellCheckableDataGridViewCell ► GotFocus
Keyoti RapidSpell Desktop .NET
Interface requirement, not implemented.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler GotFocus
public event EventHandler GotFocus
Public Event GotFocus As EventHandler
Public Event GotFocus As EventHandler
public:
virtual  event EventHandler^ GotFocus {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ GotFocus {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract GotFocus : IEvent<EventHandler,
    EventArgs>
override GotFocus : IEvent<EventHandler,
    EventArgs>
abstract GotFocus : IEvent<EventHandler,
    EventArgs>
override GotFocus : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


HideSelection Property

Keyoti RapidSpell Desktop .NET API Docs
HideSelection Property
API ► Keyoti.RapidSpell.Grid ► SpellCheckableDataGridViewCell ► HideSelection
Keyoti RapidSpell Desktop .NET
Always false, interface requirement.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool HideSelection { get; set; }
public bool HideSelection { get; set; }
Public Property HideSelection As Boolean
    Get
    Set
Public Property HideSelection As Boolean
    Get
    Set
public:
virtual property bool HideSelection {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool HideSelection {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract HideSelection : bool with get, set
override HideSelection : bool with get, set
abstract HideSelection : bool with get, set
override HideSelection : bool with get, set
Property Value
Boolean


ReadOnly Property

Keyoti RapidSpell Desktop .NET API Docs
ReadOnly Property
API ► Keyoti.RapidSpell.Grid ► SpellCheckableDataGridViewCell ► ReadOnly
Keyoti RapidSpell Desktop .NET
Always false, interface requirement.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ReadOnly { get; }
public bool ReadOnly { get; }
Public ReadOnly Property ReadOnly As Boolean
    Get
Public ReadOnly Property ReadOnly As Boolean
    Get
public:
virtual property bool ReadOnly {
    bool get () sealed;
}
public:
virtual property bool ReadOnly {
    bool get () sealed;
}
abstract ReadOnly : bool with get
override ReadOnly : bool with get
abstract ReadOnly : bool with get
override ReadOnly : bool with get
Property Value
Boolean


ScrollToCaret Method

Keyoti RapidSpell Desktop .NET API Docs
ScrollToCaret Method
API ► Keyoti.RapidSpell.Grid ► SpellCheckableDataGridViewCell ► ScrollToCaret()()()()
Keyoti RapidSpell Desktop .NET
Interface requirement.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void ScrollToCaret()
public void ScrollToCaret()
Public Sub ScrollToCaret
Public Sub ScrollToCaret
public:
virtual void ScrollToCaret() sealed
public:
virtual void ScrollToCaret() sealed
abstract ScrollToCaret : unit -> unit
override ScrollToCaret : unit -> unit
abstract ScrollToCaret : unit -> unit
override ScrollToCaret : unit -> unit


SelectedText Property

Keyoti RapidSpell Desktop .NET API Docs
SelectedText Property
API ► Keyoti.RapidSpell.Grid ► SpellCheckableDataGridViewCell ► SelectedText
Keyoti RapidSpell Desktop .NET
Any selected text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string SelectedText { get; set; }
public string SelectedText { get; set; }
Public Property SelectedText As String
    Get
    Set
Public Property SelectedText As String
    Get
    Set
public:
virtual property String^ SelectedText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ SelectedText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract SelectedText : string with get, set
override SelectedText : string with get, set
abstract SelectedText : string with get, set
override SelectedText : string with get, set
Property Value
String


SelectionLength Property

Keyoti RapidSpell Desktop .NET API Docs
SelectionLength Property
API ► Keyoti.RapidSpell.Grid ► SpellCheckableDataGridViewCell ► SelectionLength
Keyoti RapidSpell Desktop .NET
Selection length
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int SelectionLength { get; set; }
public int SelectionLength { get; set; }
Public Property SelectionLength As Integer
    Get
    Set
Public Property SelectionLength As Integer
    Get
    Set
public:
virtual property int SelectionLength {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int SelectionLength {
    int get () sealed;
    void set (int value) sealed;
}
abstract SelectionLength : int with get, set
override SelectionLength : int with get, set
abstract SelectionLength : int with get, set
override SelectionLength : int with get, set
Property Value
Int32


SelectionStart Property

Keyoti RapidSpell Desktop .NET API Docs
SelectionStart Property
API ► Keyoti.RapidSpell.Grid ► SpellCheckableDataGridViewCell ► SelectionStart
Keyoti RapidSpell Desktop .NET
Selection start.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int SelectionStart { get; set; }
public int SelectionStart { get; set; }
Public Property SelectionStart As Integer
    Get
    Set
Public Property SelectionStart As Integer
    Get
    Set
public:
virtual property int SelectionStart {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int SelectionStart {
    int get () sealed;
    void set (int value) sealed;
}
abstract SelectionStart : int with get, set
override SelectionStart : int with get, set
abstract SelectionStart : int with get, set
override SelectionStart : int with get, set
Property Value
Int32


Text Property

Keyoti RapidSpell Desktop .NET API Docs
Text Property
API ► Keyoti.RapidSpell.Grid ► SpellCheckableDataGridViewCell ► Text
Keyoti RapidSpell Desktop .NET
The cell text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string Text { get; set; }
public string Text { get; set; }
Public Property Text As String
    Get
    Set
Public Property Text As String
    Get
    Set
public:
virtual property String^ Text {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ Text {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract Text : string with get, set
override Text : string with get, set
abstract Text : string with get, set
override Text : string with get, set
Property Value
String


Keyoti.RapidSpell.Options Namespace

Keyoti RapidSpell Desktop .NET API Docs
Keyoti.RapidSpell.Options Namespace
API ► Keyoti.RapidSpell.Options
Keyoti RapidSpell Desktop .NET
User options related classes
Types
All Types Classes Enumerations Delegates
Icon | Type | Description
 | UserDictionaryEditEventArgs..::..EditType | Types of edit operations
 | UserDictionaryFormEventArgs..::..EditType | Types of edit operations
 | NeedStreamEventArgs | Event args for NeedCustomStreamForLoading and NeedCustomStreamForSaving event.
 | UserOptions..::..NeedStreamEventHandler | Delegate for need stream events.
 | OptionsPresenter | The presenter for IDialogViewOptions
 | UserOptions..::..StorageType | The option storage location
 | UserDictionaryContentChangedEventArgs | Event args
 | UserOptions..::..UserDictionaryContentChangeEventHandler | Handler delegate
 | UserDictionaryDefaultChangeEventArgs | Event args
 | UserOptions..::..UserDictionaryDefaultChangeEventHandler | Handler delegate
 | UserDictionaryEditEventArgs | Event args for a user dictionary edit event (add word, remove)
 | UserDictionaryEditEventHandler | Event handler delegate
 | UserDictionaryFormEventArgs | Event args for a user dictionary edit event (add word, remove)
 | UserDictionaryFormEventHandler | Event handler delegate
 | UserOptions | Holds/Loads/Saves user options.


NeedStreamEventArgs Class

Keyoti RapidSpell Desktop .NET API Docs
NeedStreamEventArgs Class
API ► Keyoti.RapidSpell.Options ► NeedStreamEventArgs
Keyoti RapidSpell Desktop .NET
Event args for NeedCustomStreamForLoading and NeedCustomStreamForSaving event.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class NeedStreamEventArgs : EventArgs
public class NeedStreamEventArgs : EventArgs
Public Class NeedStreamEventArgs
    Inherits EventArgs
Public Class NeedStreamEventArgs
    Inherits EventArgs
public ref class NeedStreamEventArgs : public EventArgs
public ref class NeedStreamEventArgs : public EventArgs
type NeedStreamEventArgs =
    class
        inherit EventArgs
    end
type NeedStreamEventArgs =
    class
        inherit EventArgs
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NeedStreamEventArgs()()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RequiredStream | Set the stream in this property when handling the event.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | NeedStreamEventArgs


NeedStreamEventArgs Constructor

Keyoti RapidSpell Desktop .NET API Docs
NeedStreamEventArgs Constructor
API ► Keyoti.RapidSpell.Options ► NeedStreamEventArgs ► NeedStreamEventArgs()()()()
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public NeedStreamEventArgs()
public NeedStreamEventArgs()
Public Sub New
Public Sub New
public:
NeedStreamEventArgs()
public:
NeedStreamEventArgs()
new : unit -> NeedStreamEventArgs
new : unit -> NeedStreamEventArgs


RequiredStream Property

Keyoti RapidSpell Desktop .NET API Docs
RequiredStream Property
API ► Keyoti.RapidSpell.Options ► NeedStreamEventArgs ► RequiredStream
Keyoti RapidSpell Desktop .NET
Set the stream in this property when handling the event.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Stream RequiredStream { get; set; }
public Stream RequiredStream { get; set; }
Public Property RequiredStream As Stream
    Get
    Set
Public Property RequiredStream As Stream
    Get
    Set
public:
property Stream^ RequiredStream {
    Stream^ get ();
    void set (Stream^ value);
}
public:
property Stream^ RequiredStream {
    Stream^ get ();
    void set (Stream^ value);
}
member RequiredStream : Stream with get, set

member RequiredStream : Stream with get, set
Property Value
Stream


OptionsPresenter Class

Keyoti RapidSpell Desktop .NET API Docs
OptionsPresenter Class
API ► Keyoti.RapidSpell.Options ► OptionsPresenter
Keyoti RapidSpell Desktop .NET
The presenter for IDialogViewOptions
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class OptionsPresenter
public class OptionsPresenter
Public Class OptionsPresenter
Public Class OptionsPresenter
public ref class OptionsPresenter
public ref class OptionsPresenter
type OptionsPresenter =  class end
type OptionsPresenter =  class end
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OptionsPresenter()()()() |
 | CreateDialogViewOptions | Fired when an IDialogViewOptions is required.
 | CreateDialogViewUserDictionaryEdit | Fired when an IDialogViewUserDictionaryEdit is required.
 | CreateDialogViewUserDictionarySelect | Fired when an CreateDialogViewUserDictionarySelectForm is required.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnCreateDialogViewOptions(CreateDialogViewOptionsEventArgs) | Raises event
 | OnCreateDialogViewUserDictionaryEdit(CreateDialogViewUserDictionaryEditEventArgs) | Raises event
 | Show(Object, UserOptions) | Shows the form
 | ShowCheckAsYouTypeOption | Whether to show the "Check as you type" option
 | ShowEditUserDictionaryFile(String) |
 | ShowFindSuggestionsOption | Whether to show the "Always find suggestions" option
 | ShowOptionForMultipleUserDictionaries | Whether to show add/remove user dictionaries form.
 | ShowUserDictionaryButton | Whether to show the user dictionary button
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | WordRemoved | Fired when a word is removed from user dictionary.
Inheritance Hierarchy
Object
OptionsPresenter


OptionsPresenter Constructor

Keyoti RapidSpell Desktop .NET API Docs
OptionsPresenter Constructor
API ► Keyoti.RapidSpell.Options ► OptionsPresenter ► OptionsPresenter()()()()
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public OptionsPresenter()
public OptionsPresenter()
Public Sub New
Public Sub New
public:
OptionsPresenter()
public:
OptionsPresenter()
new : unit -> OptionsPresenter
new : unit -> OptionsPresenter


CreateDialogViewOptions Event

Keyoti RapidSpell Desktop .NET API Docs
CreateDialogViewOptions Event
API ► Keyoti.RapidSpell.Options ► OptionsPresenter ► CreateDialogViewOptions
Keyoti RapidSpell Desktop .NET
Fired when an IDialogViewOptions is required.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event CreateDialogViewOptionsEventHandler CreateDialogViewOptions
public event CreateDialogViewOptionsEventHandler CreateDialogViewOptions
Public Event CreateDialogViewOptions As CreateDialogViewOptionsEventHandler
Public Event CreateDialogViewOptions As CreateDialogViewOptionsEventHandler
public:
 event CreateDialogViewOptionsEventHandler^ CreateDialogViewOptions {
    void add (CreateDialogViewOptionsEventHandler^ value);
    void remove (CreateDialogViewOptionsEventHandler^ value);
}
public:
 event CreateDialogViewOptionsEventHandler^ CreateDialogViewOptions {
    void add (CreateDialogViewOptionsEventHandler^ value);
    void remove (CreateDialogViewOptionsEventHandler^ value);
}
member CreateDialogViewOptions : IEvent<CreateDialogViewOptionsEventHandler,
    CreateDialogViewOptionsEventArgs>

member CreateDialogViewOptions : IEvent<CreateDialogViewOptionsEventHandler,
    CreateDialogViewOptionsEventArgs>
Value
CreateDialogViewOptionsEventHandler


CreateDialogViewUserDictionaryEdit Event

Keyoti RapidSpell Desktop .NET API Docs
CreateDialogViewUserDictionaryEdit Event
API ► Keyoti.RapidSpell.Options ► OptionsPresenter ► CreateDialogViewUserDictionaryEdit
Keyoti RapidSpell Desktop .NET
Fired when an IDialogViewUserDictionaryEdit is required.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event CreateDialogViewUserDictionaryEditEventHandler CreateDialogViewUserDictionaryEdit
public event CreateDialogViewUserDictionaryEditEventHandler CreateDialogViewUserDictionaryEdit
Public Event CreateDialogViewUserDictionaryEdit As CreateDialogViewUserDictionaryEditEventHandler
Public Event CreateDialogViewUserDictionaryEdit As CreateDialogViewUserDictionaryEditEventHandler
public:
 event CreateDialogViewUserDictionaryEditEventHandler^ CreateDialogViewUserDictionaryEdit {
    void add (CreateDialogViewUserDictionaryEditEventHandler^ value);
    void remove (CreateDialogViewUserDictionaryEditEventHandler^ value);
}
public:
 event CreateDialogViewUserDictionaryEditEventHandler^ CreateDialogViewUserDictionaryEdit {
    void add (CreateDialogViewUserDictionaryEditEventHandler^ value);
    void remove (CreateDialogViewUserDictionaryEditEventHandler^ value);
}
member CreateDialogViewUserDictionaryEdit : IEvent<CreateDialogViewUserDictionaryEditEventHandler,
    CreateDialogViewUserDictionaryEditEventArgs>

member CreateDialogViewUserDictionaryEdit : IEvent<CreateDialogViewUserDictionaryEditEventHandler,
    CreateDialogViewUserDictionaryEditEventArgs>
Value
CreateDialogViewUserDictionaryEditEventHandler


CreateDialogViewUserDictionarySelect Event

Keyoti RapidSpell Desktop .NET API Docs
CreateDialogViewUserDictionarySelect Event
API ► Keyoti.RapidSpell.Options ► OptionsPresenter ► CreateDialogViewUserDictionarySelect
Keyoti RapidSpell Desktop .NET
Fired when an CreateDialogViewUserDictionarySelectForm is required.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event CreateDialogViewUserDictionarySelectEventHandler CreateDialogViewUserDictionarySelect
public event CreateDialogViewUserDictionarySelectEventHandler CreateDialogViewUserDictionarySelect
Public Event CreateDialogViewUserDictionarySelect As CreateDialogViewUserDictionarySelectEventHandler
Public Event CreateDialogViewUserDictionarySelect As CreateDialogViewUserDictionarySelectEventHandler
public:
 event CreateDialogViewUserDictionarySelectEventHandler^ CreateDialogViewUserDictionarySelect {
    void add (CreateDialogViewUserDictionarySelectEventHandler^ value);
    void remove (CreateDialogViewUserDictionarySelectEventHandler^ value);
}
public:
 event CreateDialogViewUserDictionarySelectEventHandler^ CreateDialogViewUserDictionarySelect {
    void add (CreateDialogViewUserDictionarySelectEventHandler^ value);
    void remove (CreateDialogViewUserDictionarySelectEventHandler^ value);
}
member CreateDialogViewUserDictionarySelect : IEvent<CreateDialogViewUserDictionarySelectEventHandler,
    CreateDialogViewUserDictionarySelectEventArgs>

member CreateDialogViewUserDictionarySelect : IEvent<CreateDialogViewUserDictionarySelectEventHandler,
    CreateDialogViewUserDictionarySelectEventArgs>
Value
CreateDialogViewUserDictionarySelectEventHandler


OnCreateDialogViewOptions Method (ev)

Keyoti RapidSpell Desktop .NET API Docs
OnCreateDialogViewOptions Method (ev)
API ► Keyoti.RapidSpell.Options ► OptionsPresenter ► OnCreateDialogViewOptions(CreateDialogViewOptionsEventArgs)
Keyoti RapidSpell Desktop .NET
Raises event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void OnCreateDialogViewOptions(
    CreateDialogViewOptionsEventArgs ev
)
protected virtual void OnCreateDialogViewOptions(
    CreateDialogViewOptionsEventArgs ev
)
Protected Overridable Sub OnCreateDialogViewOptions (
    ev As CreateDialogViewOptionsEventArgs
)
Protected Overridable Sub OnCreateDialogViewOptions (
    ev As CreateDialogViewOptionsEventArgs
)
protected:
virtual void OnCreateDialogViewOptions(
    CreateDialogViewOptionsEventArgs^ ev
)
protected:
virtual void OnCreateDialogViewOptions(
    CreateDialogViewOptionsEventArgs^ ev
)
abstract OnCreateDialogViewOptions :
        ev : CreateDialogViewOptionsEventArgs -> unit
override OnCreateDialogViewOptions :
        ev : CreateDialogViewOptionsEventArgs -> unit
abstract OnCreateDialogViewOptions :
        ev : CreateDialogViewOptionsEventArgs -> unit
override OnCreateDialogViewOptions :
        ev : CreateDialogViewOptionsEventArgs -> unit
Parameters
ev (CreateDialogViewOptionsEventArgs)


OnCreateDialogViewUserDictionaryEdit Method (ev)

Keyoti RapidSpell Desktop .NET API Docs
OnCreateDialogViewUserDictionaryEdit Method (ev)
API ► Keyoti.RapidSpell.Options ► OptionsPresenter ► OnCreateDialogViewUserDictionaryEdit(CreateDialogViewUserDictionaryEditEventArgs)
Keyoti RapidSpell Desktop .NET
Raises event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void OnCreateDialogViewUserDictionaryEdit(
    CreateDialogViewUserDictionaryEditEventArgs ev
)
protected virtual void OnCreateDialogViewUserDictionaryEdit(
    CreateDialogViewUserDictionaryEditEventArgs ev
)
Protected Overridable Sub OnCreateDialogViewUserDictionaryEdit (
    ev As CreateDialogViewUserDictionaryEditEventArgs
)
Protected Overridable Sub OnCreateDialogViewUserDictionaryEdit (
    ev As CreateDialogViewUserDictionaryEditEventArgs
)
protected:
virtual void OnCreateDialogViewUserDictionaryEdit(
    CreateDialogViewUserDictionaryEditEventArgs^ ev
)
protected:
virtual void OnCreateDialogViewUserDictionaryEdit(
    CreateDialogViewUserDictionaryEditEventArgs^ ev
)
abstract OnCreateDialogViewUserDictionaryEdit :
        ev : CreateDialogViewUserDictionaryEditEventArgs -> unit
override OnCreateDialogViewUserDictionaryEdit :
        ev : CreateDialogViewUserDictionaryEditEventArgs -> unit
abstract OnCreateDialogViewUserDictionaryEdit :
        ev : CreateDialogViewUserDictionaryEditEventArgs -> unit
override OnCreateDialogViewUserDictionaryEdit :
        ev : CreateDialogViewUserDictionaryEditEventArgs -> unit
Parameters
ev (CreateDialogViewUserDictionaryEditEventArgs)


Show Method (modalOwner, userOptions)

Keyoti RapidSpell Desktop .NET API Docs
Show Method (modalOwner, userOptions)
API ► Keyoti.RapidSpell.Options ► OptionsPresenter ► Show(Object, UserOptions)
Keyoti RapidSpell Desktop .NET
Shows the form
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool Show(
    Object modalOwner,
    UserOptions userOptions
)
public virtual bool Show(
    Object modalOwner,
    UserOptions userOptions
)
Public Overridable Function Show (
    modalOwner As Object,
    userOptions As UserOptions
) As Boolean
Public Overridable Function Show (
    modalOwner As Object,
    userOptions As UserOptions
) As Boolean
public:
virtual bool Show(
    Object^ modalOwner,
    UserOptions^ userOptions
)
public:
virtual bool Show(
    Object^ modalOwner,
    UserOptions^ userOptions
)
abstract Show :
        modalOwner : Object *
        userOptions : UserOptions -> bool
override Show :
        modalOwner : Object *
        userOptions : UserOptions -> bool
abstract Show :
        modalOwner : Object *
        userOptions : UserOptions -> bool
override Show :
        modalOwner : Object *
        userOptions : UserOptions -> bool
Parameters
modalOwner (Object)
userOptions (UserOptions)
Return Value
Boolean


ShowCheckAsYouTypeOption Property

Keyoti RapidSpell Desktop .NET API Docs
ShowCheckAsYouTypeOption Property
API ► Keyoti.RapidSpell.Options ► OptionsPresenter ► ShowCheckAsYouTypeOption
Keyoti RapidSpell Desktop .NET
Whether to show the "Check as you type" option
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ShowCheckAsYouTypeOption { get; set; }
public bool ShowCheckAsYouTypeOption { get; set; }
Public Property ShowCheckAsYouTypeOption As Boolean
    Get
    Set
Public Property ShowCheckAsYouTypeOption As Boolean
    Get
    Set
public:
property bool ShowCheckAsYouTypeOption {
    bool get ();
    void set (bool value);
}
public:
property bool ShowCheckAsYouTypeOption {
    bool get ();
    void set (bool value);
}
member ShowCheckAsYouTypeOption : bool with get, set

member ShowCheckAsYouTypeOption : bool with get, set
Property Value
Boolean


ShowEditUserDictionaryFile Method (file)

Keyoti RapidSpell Desktop .NET API Docs
ShowEditUserDictionaryFile Method (file)
API ► Keyoti.RapidSpell.Options ► OptionsPresenter ► ShowEditUserDictionaryFile(String)
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void ShowEditUserDictionaryFile(
    string file
)
public void ShowEditUserDictionaryFile(
    string file
)
Public Sub ShowEditUserDictionaryFile (
    file As String
)
Public Sub ShowEditUserDictionaryFile (
    file As String
)
public:
void ShowEditUserDictionaryFile(
    String^ file
)
public:
void ShowEditUserDictionaryFile(
    String^ file
)
member ShowEditUserDictionaryFile :
        file : string -> unit

member ShowEditUserDictionaryFile :
        file : string -> unit
Parameters
file (String)


ShowFindSuggestionsOption Property

Keyoti RapidSpell Desktop .NET API Docs
ShowFindSuggestionsOption Property
API ► Keyoti.RapidSpell.Options ► OptionsPresenter ► ShowFindSuggestionsOption
Keyoti RapidSpell Desktop .NET
Whether to show the "Always find suggestions" option
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ShowFindSuggestionsOption { get; set; }
public bool ShowFindSuggestionsOption { get; set; }
Public Property ShowFindSuggestionsOption As Boolean
    Get
    Set
Public Property ShowFindSuggestionsOption As Boolean
    Get
    Set
public:
property bool ShowFindSuggestionsOption {
    bool get ();
    void set (bool value);
}
public:
property bool ShowFindSuggestionsOption {
    bool get ();
    void set (bool value);
}
member ShowFindSuggestionsOption : bool with get, set

member ShowFindSuggestionsOption : bool with get, set
Property Value
Boolean


ShowOptionForMultipleUserDictionaries Property

Keyoti RapidSpell Desktop .NET API Docs
ShowOptionForMultipleUserDictionaries Property
API ► Keyoti.RapidSpell.Options ► OptionsPresenter ► ShowOptionForMultipleUserDictionaries
Keyoti RapidSpell Desktop .NET
Whether to show add/remove user dictionaries form.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ShowOptionForMultipleUserDictionaries { get; set; }
public bool ShowOptionForMultipleUserDictionaries { get; set; }
Public Property ShowOptionForMultipleUserDictionaries As Boolean
    Get
    Set
Public Property ShowOptionForMultipleUserDictionaries As Boolean
    Get
    Set
public:
property bool ShowOptionForMultipleUserDictionaries {
    bool get ();
    void set (bool value);
}
public:
property bool ShowOptionForMultipleUserDictionaries {
    bool get ();
    void set (bool value);
}
member ShowOptionForMultipleUserDictionaries : bool with get, set

member ShowOptionForMultipleUserDictionaries : bool with get, set
Property Value
Boolean


ShowUserDictionaryButton Property

Keyoti RapidSpell Desktop .NET API Docs
ShowUserDictionaryButton Property
API ► Keyoti.RapidSpell.Options ► OptionsPresenter ► ShowUserDictionaryButton
Keyoti RapidSpell Desktop .NET
Whether to show the user dictionary button
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ShowUserDictionaryButton { get; set; }
public bool ShowUserDictionaryButton { get; set; }
Public Property ShowUserDictionaryButton As Boolean
    Get
    Set
Public Property ShowUserDictionaryButton As Boolean
    Get
    Set
public:
property bool ShowUserDictionaryButton {
    bool get ();
    void set (bool value);
}
public:
property bool ShowUserDictionaryButton {
    bool get ();
    void set (bool value);
}
member ShowUserDictionaryButton : bool with get, set

member ShowUserDictionaryButton : bool with get, set
Property Value
Boolean


WordRemoved Event

Keyoti RapidSpell Desktop .NET API Docs
WordRemoved Event
API ► Keyoti.RapidSpell.Options ► OptionsPresenter ► WordRemoved
Keyoti RapidSpell Desktop .NET
Fired when a word is removed from user dictionary.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event WordRemovedEventHandler WordRemoved
public event WordRemovedEventHandler WordRemoved
Public Event WordRemoved As WordRemovedEventHandler
Public Event WordRemoved As WordRemovedEventHandler
public:
 event WordRemovedEventHandler^ WordRemoved {
    void add (WordRemovedEventHandler^ value);
    void remove (WordRemovedEventHandler^ value);
}
public:
 event WordRemovedEventHandler^ WordRemoved {
    void add (WordRemovedEventHandler^ value);
    void remove (WordRemovedEventHandler^ value);
}
member WordRemoved : IEvent<WordRemovedEventHandler,
    WordRemovedEventArgs>

member WordRemoved : IEvent<WordRemovedEventHandler,
    WordRemovedEventArgs>
Value
WordRemovedEventHandler


UserDictionaryContentChangedEventArgs Class

Keyoti RapidSpell Desktop .NET API Docs
UserDictionaryContentChangedEventArgs Class
API ► Keyoti.RapidSpell.Options ► UserDictionaryContentChangedEventArgs
Keyoti RapidSpell Desktop .NET
Event args
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class UserDictionaryContentChangedEventArgs
public class UserDictionaryContentChangedEventArgs
Public Class UserDictionaryContentChangedEventArgs
Public Class UserDictionaryContentChangedEventArgs
public ref class UserDictionaryContentChangedEventArgs
public ref class UserDictionaryContentChangedEventArgs
type UserDictionaryContentChangedEventArgs =  class end
type UserDictionaryContentChangedEventArgs =  class end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserDictionaryContentChangedEventArgs(List<(Of <<'(UserDictionary>)>>)) | New
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | UserDictionaries | List of dictionaries currently in use.
Inheritance Hierarchy
Object
UserDictionaryContentChangedEventArgs


UserDictionaryContentChangedEventArgs Constructor (dicts)

Keyoti RapidSpell Desktop .NET API Docs
UserDictionaryContentChangedEventArgs Constructor (dicts)
API ► Keyoti.RapidSpell.Options ► UserDictionaryContentChangedEventArgs ► UserDictionaryContentChangedEventArgs(List<(Of <<'(UserDictionary>)>>))
Keyoti RapidSpell Desktop .NET
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UserDictionaryContentChangedEventArgs(
    List<UserDictionary> dicts
)
public UserDictionaryContentChangedEventArgs(
    List<UserDictionary> dicts
)
Public Sub New (
    dicts As List(Of UserDictionary)
)
Public Sub New (
    dicts As List(Of UserDictionary)
)
public:
UserDictionaryContentChangedEventArgs(
    List<UserDictionary^>^ dicts
)
public:
UserDictionaryContentChangedEventArgs(
    List<UserDictionary^>^ dicts
)
new :
        dicts : List<UserDictionary> -> UserDictionaryContentChangedEventArgs
new :
        dicts : List<UserDictionary> -> UserDictionaryContentChangedEventArgs
Parameters
dicts (List <(Of <(<' UserDictionary >)>)>)


UserDictionaries Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionaries Property
API ► Keyoti.RapidSpell.Options ► UserDictionaryContentChangedEventArgs ► UserDictionaries
Keyoti RapidSpell Desktop .NET
List of dictionaries currently in use.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public List<UserDictionary> UserDictionaries { get; }
public List<UserDictionary> UserDictionaries { get; }
Public ReadOnly Property UserDictionaries As List(Of UserDictionary)
    Get
Public ReadOnly Property UserDictionaries As List(Of UserDictionary)
    Get
public:
property List<UserDictionary^>^ UserDictionaries {
    List<UserDictionary^>^ get ();
}
public:
property List<UserDictionary^>^ UserDictionaries {
    List<UserDictionary^>^ get ();
}
member UserDictionaries : List<UserDictionary> with get

member UserDictionaries : List<UserDictionary> with get
Property Value
List <(Of <(<' UserDictionary >)>)>


UserDictionaryDefaultChangeEventArgs Class

Keyoti RapidSpell Desktop .NET API Docs
UserDictionaryDefaultChangeEventArgs Class
API ► Keyoti.RapidSpell.Options ► UserDictionaryDefaultChangeEventArgs
Keyoti RapidSpell Desktop .NET
Event args
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class UserDictionaryDefaultChangeEventArgs
public class UserDictionaryDefaultChangeEventArgs
Public Class UserDictionaryDefaultChangeEventArgs
Public Class UserDictionaryDefaultChangeEventArgs
public ref class UserDictionaryDefaultChangeEventArgs
public ref class UserDictionaryDefaultChangeEventArgs
type UserDictionaryDefaultChangeEventArgs =  class end
type UserDictionaryDefaultChangeEventArgs =  class end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserDictionaryDefaultChangeEventArgs(String) | New
 | DefaultUserDictionaryItem | The default user dictionary path
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
UserDictionaryDefaultChangeEventArgs


UserDictionaryDefaultChangeEventArgs Constructor (defaultUserDictionaryItem)

Keyoti RapidSpell Desktop .NET API Docs
UserDictionaryDefaultChangeEventArgs Constructor (defaultUserDictionaryItem)
API ► Keyoti.RapidSpell.Options ► UserDictionaryDefaultChangeEventArgs ► UserDictionaryDefaultChangeEventArgs(String)
Keyoti RapidSpell Desktop .NET
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UserDictionaryDefaultChangeEventArgs(
    string defaultUserDictionaryItem
)
public UserDictionaryDefaultChangeEventArgs(
    string defaultUserDictionaryItem
)
Public Sub New (
    defaultUserDictionaryItem As String
)
Public Sub New (
    defaultUserDictionaryItem As String
)
public:
UserDictionaryDefaultChangeEventArgs(
    String^ defaultUserDictionaryItem
)
public:
UserDictionaryDefaultChangeEventArgs(
    String^ defaultUserDictionaryItem
)
new :
        defaultUserDictionaryItem : string -> UserDictionaryDefaultChangeEventArgs
new :
        defaultUserDictionaryItem : string -> UserDictionaryDefaultChangeEventArgs
Parameters
defaultUserDictionaryItem (String)
The default user dictionary path


DefaultUserDictionaryItem Property

Keyoti RapidSpell Desktop .NET API Docs
DefaultUserDictionaryItem Property
API ► Keyoti.RapidSpell.Options ► UserDictionaryDefaultChangeEventArgs ► DefaultUserDictionaryItem
Keyoti RapidSpell Desktop .NET
The default user dictionary path
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string DefaultUserDictionaryItem { get; }
public string DefaultUserDictionaryItem { get; }
Public ReadOnly Property DefaultUserDictionaryItem As String
    Get
Public ReadOnly Property DefaultUserDictionaryItem As String
    Get
public:
property String^ DefaultUserDictionaryItem {
    String^ get ();
}
public:
property String^ DefaultUserDictionaryItem {
    String^ get ();
}
member DefaultUserDictionaryItem : string with get

member DefaultUserDictionaryItem : string with get
Property Value
String


UserDictionaryEditEventArgs Class

Keyoti RapidSpell Desktop .NET API Docs
UserDictionaryEditEventArgs Class
API ► Keyoti.RapidSpell.Options ► UserDictionaryEditEventArgs
Keyoti RapidSpell Desktop .NET
Event args for a user dictionary edit event (add word, remove)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class UserDictionaryEditEventArgs
public class UserDictionaryEditEventArgs
Public Class UserDictionaryEditEventArgs
Public Class UserDictionaryEditEventArgs
public ref class UserDictionaryEditEventArgs
public ref class UserDictionaryEditEventArgs
type UserDictionaryEditEventArgs =  class end
type UserDictionaryEditEventArgs =  class end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserDictionaryEditEventArgs(UserDictionaryEditEventArgs..::..EditType, String) | New instance
 | Edit | The edit operation
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Word | The word in question
Inheritance Hierarchy
Object
UserDictionaryEditEventArgs


UserDictionaryEditEventArgs Constructor (edit, word)

Keyoti RapidSpell Desktop .NET API Docs
UserDictionaryEditEventArgs Constructor (edit, word)
API ► Keyoti.RapidSpell.Options ► UserDictionaryEditEventArgs ► UserDictionaryEditEventArgs(UserDictionaryEditEventArgs..::..EditType, String)
Keyoti RapidSpell Desktop .NET
New instance
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UserDictionaryEditEventArgs(
    UserDictionaryEditEventArgs..::..EditType edit,
    string word
)
public UserDictionaryEditEventArgs(
    UserDictionaryEditEventArgs..::..EditType edit,
    string word
)
Public Sub New (
    edit As UserDictionaryEditEventArgs..::..EditType,
    word As String
)
Public Sub New (
    edit As UserDictionaryEditEventArgs..::..EditType,
    word As String
)
public:
UserDictionaryEditEventArgs(
    UserDictionaryEditEventArgs..::..EditType edit,
    String^ word
)
public:
UserDictionaryEditEventArgs(
    UserDictionaryEditEventArgs..::..EditType edit,
    String^ word
)
new :
        edit : UserDictionaryEditEventArgs..::..EditType *
        word : string -> UserDictionaryEditEventArgs
new :
        edit : UserDictionaryEditEventArgs..::..EditType *
        word : string -> UserDictionaryEditEventArgs
Parameters
edit (UserDictionaryEditEventArgs..::..EditType)
The operation
word (String)
The word


Edit Property

Keyoti RapidSpell Desktop .NET API Docs
Edit Property
API ► Keyoti.RapidSpell.Options ► UserDictionaryEditEventArgs ► Edit
Keyoti RapidSpell Desktop .NET
The edit operation
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UserDictionaryEditEventArgs..::..EditType Edit { get; set; }
public UserDictionaryEditEventArgs..::..EditType Edit { get; set; }
Public Property Edit As UserDictionaryEditEventArgs..::..EditType
    Get
    Set
Public Property Edit As UserDictionaryEditEventArgs..::..EditType
    Get
    Set
public:
property UserDictionaryEditEventArgs..::..EditType Edit {
    UserDictionaryEditEventArgs..::..EditType get ();
    void set (UserDictionaryEditEventArgs..::..EditType value);
}
public:
property UserDictionaryEditEventArgs..::..EditType Edit {
    UserDictionaryEditEventArgs..::..EditType get ();
    void set (UserDictionaryEditEventArgs..::..EditType value);
}
member Edit : UserDictionaryEditEventArgs..::..EditType with get, set

member Edit : UserDictionaryEditEventArgs..::..EditType with get, set
Property Value
UserDictionaryEditEventArgs..::..EditType


Word Property

Keyoti RapidSpell Desktop .NET API Docs
Word Property
API ► Keyoti.RapidSpell.Options ► UserDictionaryEditEventArgs ► Word
Keyoti RapidSpell Desktop .NET
The word in question
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string Word { get; set; }
public string Word { get; set; }
Public Property Word As String
    Get
    Set
Public Property Word As String
    Get
    Set
public:
property String^ Word {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Word {
    String^ get ();
    void set (String^ value);
}
member Word : string with get, set

member Word : string with get, set
Property Value
String


UserDictionaryEditEventArgs.EditType Enumeration

Keyoti RapidSpell Desktop .NET API Docs
UserDictionaryEditEventArgs..::..EditType Enumeration
API ► Keyoti.RapidSpell.Options ► UserDictionaryEditEventArgs ► UserDictionaryEditEventArgs..::..EditType
Keyoti RapidSpell Desktop .NET
Types of edit operations
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public enum EditType
public enum EditType
Public Enumeration EditType
Public Enumeration EditType
public enum class EditType
public enum class EditType
type EditType
type EditType
Members
Member | Description
Add | Add a word
Remove | Remove a word


UserDictionaryEditEventHandler Delegate

Keyoti RapidSpell Desktop .NET API Docs
UserDictionaryEditEventHandler Delegate
API ► Keyoti.RapidSpell.Options ► UserDictionaryEditEventHandler
Keyoti RapidSpell Desktop .NET
Event handler delegate
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void UserDictionaryEditEventHandler(
    Object s,
    UserDictionaryEditEventArgs e
)
public delegate void UserDictionaryEditEventHandler(
    Object s,
    UserDictionaryEditEventArgs e
)
Public Delegate Sub UserDictionaryEditEventHandler (
    s As Object,
    e As UserDictionaryEditEventArgs
)
Public Delegate Sub UserDictionaryEditEventHandler (
    s As Object,
    e As UserDictionaryEditEventArgs
)
public delegate void UserDictionaryEditEventHandler(
    Object^ s,
    UserDictionaryEditEventArgs^ e
)
public delegate void UserDictionaryEditEventHandler(
    Object^ s,
    UserDictionaryEditEventArgs^ e
)
type UserDictionaryEditEventHandler =
    delegate of
        s : Object *
        e : UserDictionaryEditEventArgs -> unit
type UserDictionaryEditEventHandler =
    delegate of
        s : Object *
        e : UserDictionaryEditEventArgs -> unit
Parameters
s (Object)
e (UserDictionaryEditEventArgs)


UserDictionaryFormEventArgs Class

Keyoti RapidSpell Desktop .NET API Docs
UserDictionaryFormEventArgs Class
API ► Keyoti.RapidSpell.Options ► UserDictionaryFormEventArgs
Keyoti RapidSpell Desktop .NET
Event args for a user dictionary edit event (add word, remove)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class UserDictionaryFormEventArgs
public class UserDictionaryFormEventArgs
Public Class UserDictionaryFormEventArgs
Public Class UserDictionaryFormEventArgs
public ref class UserDictionaryFormEventArgs
public ref class UserDictionaryFormEventArgs
type UserDictionaryFormEventArgs =  class end
type UserDictionaryFormEventArgs =  class end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserDictionaryFormEventArgs(UserDictionaryFormEventArgs..::..EditType, String) | New instance
 | Edit | The edit operation
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | File | The word in question
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
UserDictionaryFormEventArgs


UserDictionaryFormEventArgs Constructor (edit, file)

Keyoti RapidSpell Desktop .NET API Docs
UserDictionaryFormEventArgs Constructor (edit, file)
API ► Keyoti.RapidSpell.Options ► UserDictionaryFormEventArgs ► UserDictionaryFormEventArgs(UserDictionaryFormEventArgs..::..EditType, String)
Keyoti RapidSpell Desktop .NET
New instance
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UserDictionaryFormEventArgs(
    UserDictionaryFormEventArgs..::..EditType edit,
    string file
)
public UserDictionaryFormEventArgs(
    UserDictionaryFormEventArgs..::..EditType edit,
    string file
)
Public Sub New (
    edit As UserDictionaryFormEventArgs..::..EditType,
    file As String
)
Public Sub New (
    edit As UserDictionaryFormEventArgs..::..EditType,
    file As String
)
public:
UserDictionaryFormEventArgs(
    UserDictionaryFormEventArgs..::..EditType edit,
    String^ file
)
public:
UserDictionaryFormEventArgs(
    UserDictionaryFormEventArgs..::..EditType edit,
    String^ file
)
new :
        edit : UserDictionaryFormEventArgs..::..EditType *
        file : string -> UserDictionaryFormEventArgs
new :
        edit : UserDictionaryFormEventArgs..::..EditType *
        file : string -> UserDictionaryFormEventArgs
Parameters
edit (UserDictionaryFormEventArgs..::..EditType)
The operation
file (String)


Edit Property

Keyoti RapidSpell Desktop .NET API Docs
Edit Property
API ► Keyoti.RapidSpell.Options ► UserDictionaryFormEventArgs ► Edit
Keyoti RapidSpell Desktop .NET
The edit operation
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UserDictionaryFormEventArgs..::..EditType Edit { get; set; }
public UserDictionaryFormEventArgs..::..EditType Edit { get; set; }
Public Property Edit As UserDictionaryFormEventArgs..::..EditType
    Get
    Set
Public Property Edit As UserDictionaryFormEventArgs..::..EditType
    Get
    Set
public:
property UserDictionaryFormEventArgs..::..EditType Edit {
    UserDictionaryFormEventArgs..::..EditType get ();
    void set (UserDictionaryFormEventArgs..::..EditType value);
}
public:
property UserDictionaryFormEventArgs..::..EditType Edit {
    UserDictionaryFormEventArgs..::..EditType get ();
    void set (UserDictionaryFormEventArgs..::..EditType value);
}
member Edit : UserDictionaryFormEventArgs..::..EditType with get, set

member Edit : UserDictionaryFormEventArgs..::..EditType with get, set
Property Value
UserDictionaryFormEventArgs..::..EditType


File Property

Keyoti RapidSpell Desktop .NET API Docs
File Property
API ► Keyoti.RapidSpell.Options ► UserDictionaryFormEventArgs ► File
Keyoti RapidSpell Desktop .NET
The word in question
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string File { get; set; }
public string File { get; set; }
Public Property File As String
    Get
    Set
Public Property File As String
    Get
    Set
public:
property String^ File {
    String^ get ();
    void set (String^ value);
}
public:
property String^ File {
    String^ get ();
    void set (String^ value);
}
member File : string with get, set

member File : string with get, set
Property Value
String


UserDictionaryFormEventArgs.EditType Enumeration

Keyoti RapidSpell Desktop .NET API Docs
UserDictionaryFormEventArgs..::..EditType Enumeration
API ► Keyoti.RapidSpell.Options ► UserDictionaryFormEventArgs ► UserDictionaryFormEventArgs..::..EditType
Keyoti RapidSpell Desktop .NET
Types of edit operations
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public enum EditType
public enum EditType
Public Enumeration EditType
Public Enumeration EditType
public enum class EditType
public enum class EditType
type EditType
type EditType
Members
Member | Description
Add | Add a file
Remove | Remove a file
Edit | Edit a file


UserDictionaryFormEventHandler Delegate

Keyoti RapidSpell Desktop .NET API Docs
UserDictionaryFormEventHandler Delegate
API ► Keyoti.RapidSpell.Options ► UserDictionaryFormEventHandler
Keyoti RapidSpell Desktop .NET
Event handler delegate
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void UserDictionaryFormEventHandler(
    Object s,
    UserDictionaryFormEventArgs e
)
public delegate void UserDictionaryFormEventHandler(
    Object s,
    UserDictionaryFormEventArgs e
)
Public Delegate Sub UserDictionaryFormEventHandler (
    s As Object,
    e As UserDictionaryFormEventArgs
)
Public Delegate Sub UserDictionaryFormEventHandler (
    s As Object,
    e As UserDictionaryFormEventArgs
)
public delegate void UserDictionaryFormEventHandler(
    Object^ s,
    UserDictionaryFormEventArgs^ e
)
public delegate void UserDictionaryFormEventHandler(
    Object^ s,
    UserDictionaryFormEventArgs^ e
)
type UserDictionaryFormEventHandler =
    delegate of
        s : Object *
        e : UserDictionaryFormEventArgs -> unit
type UserDictionaryFormEventHandler =
    delegate of
        s : Object *
        e : UserDictionaryFormEventArgs -> unit
Parameters
s (Object)
e (UserDictionaryFormEventArgs)


UserOptions Class

Keyoti RapidSpell Desktop .NET API Docs
UserOptions Class
API ► Keyoti.RapidSpell.Options ► UserOptions
Keyoti RapidSpell Desktop .NET
Holds/Loads/Saves user options.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class UserOptions
public class UserOptions
Public Class UserOptions
Public Class UserOptions
public ref class UserOptions
public ref class UserOptions
type UserOptions =  class end
type UserOptions =  class end
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserOptions()()()() |
 | AllowAnyCase | (User option)
 | AllowMixedCase | (User option)
 | ChangeMaintainsCheckValidity()()()() | Whether any changes have caused the current spell check progress to be invalid (requiring reset of the spell checker).
 | CheckAsYouType | (User option) Check as you type option
 | Clone()()()() | Returns a copy of this object
 | CustomStreamForLoading | The stream to use when loading options
 | CustomStreamForSaving | The stream to use when saving options
 | Delete()()()() | Delete the user's settings
 | Enabled | Whether options are enabled
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FindSuggestions | (User option)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | IgnoreCapitalizedWords | (User option)
 | IgnoreURLsAndEmailAddresses | (User option)
 | IgnoreWordsWithDigits | (User option)
 | IncludeUserDictionaryInSuggestions | (User option)
 | Load()()()() | Load the user's settings
 | Load(Stream) | Load the users settings from userOptionsStream
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NeedCustomStreamForLoading | Fired when a custom stream can be set to load the options from.
 | NeedCustomStreamForSaving | Fired when a custom stream can be set to save the options to.
 | OnRecheckDocumentRequest(EventArgs) | Raises recheck document event
 | OptionsHaveChanged()()()() | Whether this and c are set with the same options.
 | OptionsSaved | Fired when the options are saved
 | RecheckDocumentRequest | Fired when the user requests the text to be rechecked
 | Save()()()() | Save user's settings
 | Save(Stream) | Save user's settings to stream
 | SetDefaultUserDictionaryFile(String) |
 | SetUserOptions(Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | Sets new settings
 | StorageLocation | Where the user's options are stored.
 | SupplementalUserDictionaryFiles | User chosen additional user dictionary files.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | UserDictionary | The user dictionary loaded for the user
 | UserDictionaryContentChanged | Fired when the user dictionary content has changed and should be reloaded.
 | UserDictionaryDefaultChanged | Fired when the default user dictionary is changed by the user.
 | UserOptionsFileName | The file name used to store the settings (by default in IsolatedStorage).
Inheritance Hierarchy
Object
UserOptions


UserOptions Constructor

Keyoti RapidSpell Desktop .NET API Docs
UserOptions Constructor
API ► Keyoti.RapidSpell.Options ► UserOptions ► UserOptions()()()()
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UserOptions()
public UserOptions()
Public Sub New
Public Sub New
public:
UserOptions()
public:
UserOptions()
new : unit -> UserOptions
new : unit -> UserOptions


AllowAnyCase Property

Keyoti RapidSpell Desktop .NET API Docs
AllowAnyCase Property
API ► Keyoti.RapidSpell.Options ► UserOptions ► AllowAnyCase
Keyoti RapidSpell Desktop .NET
(User option)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool AllowAnyCase { get; }
public bool AllowAnyCase { get; }
Public ReadOnly Property AllowAnyCase As Boolean
    Get
Public ReadOnly Property AllowAnyCase As Boolean
    Get
public:
property bool AllowAnyCase {
    bool get ();
}
public:
property bool AllowAnyCase {
    bool get ();
}
member AllowAnyCase : bool with get

member AllowAnyCase : bool with get
Property Value
Boolean


AllowMixedCase Property

Keyoti RapidSpell Desktop .NET API Docs
AllowMixedCase Property
API ► Keyoti.RapidSpell.Options ► UserOptions ► AllowMixedCase
Keyoti RapidSpell Desktop .NET
(User option)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool AllowMixedCase { get; }
public bool AllowMixedCase { get; }
Public ReadOnly Property AllowMixedCase As Boolean
    Get
Public ReadOnly Property AllowMixedCase As Boolean
    Get
public:
property bool AllowMixedCase {
    bool get ();
}
public:
property bool AllowMixedCase {
    bool get ();
}
member AllowMixedCase : bool with get

member AllowMixedCase : bool with get
Property Value
Boolean


ChangeMaintainsCheckValidity Method

Keyoti RapidSpell Desktop .NET API Docs
ChangeMaintainsCheckValidity Method
API ► Keyoti.RapidSpell.Options ► UserOptions ► ChangeMaintainsCheckValidity()()()()
Keyoti RapidSpell Desktop .NET
Whether any changes have caused the current spell check progress to be invalid (requiring reset of the spell checker).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool ChangeMaintainsCheckValidity()
public virtual bool ChangeMaintainsCheckValidity()
Public Overridable Function ChangeMaintainsCheckValidity As Boolean
Public Overridable Function ChangeMaintainsCheckValidity As Boolean
public:
virtual bool ChangeMaintainsCheckValidity()
public:
virtual bool ChangeMaintainsCheckValidity()
abstract ChangeMaintainsCheckValidity : unit -> bool
override ChangeMaintainsCheckValidity : unit -> bool
abstract ChangeMaintainsCheckValidity : unit -> bool
override ChangeMaintainsCheckValidity : unit -> bool
Return Value
Boolean


CheckAsYouType Property

Keyoti RapidSpell Desktop .NET API Docs
CheckAsYouType Property
API ► Keyoti.RapidSpell.Options ► UserOptions ► CheckAsYouType
Keyoti RapidSpell Desktop .NET
(User option) Check as you type option
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool CheckAsYouType { get; }
public bool CheckAsYouType { get; }
Public ReadOnly Property CheckAsYouType As Boolean
    Get
Public ReadOnly Property CheckAsYouType As Boolean
    Get
public:
property bool CheckAsYouType {
    bool get ();
}
public:
property bool CheckAsYouType {
    bool get ();
}
member CheckAsYouType : bool with get

member CheckAsYouType : bool with get
Property Value
Boolean


Clone Method

Keyoti RapidSpell Desktop .NET API Docs
Clone Method
API ► Keyoti.RapidSpell.Options ► UserOptions ► Clone()()()()
Keyoti RapidSpell Desktop .NET
Returns a copy of this object
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual UserOptions Clone()
public virtual UserOptions Clone()
Public Overridable Function Clone As UserOptions
Public Overridable Function Clone As UserOptions
public:
virtual UserOptions^ Clone()
public:
virtual UserOptions^ Clone()
abstract Clone : unit -> UserOptions
override Clone : unit -> UserOptions
abstract Clone : unit -> UserOptions
override Clone : unit -> UserOptions
Return Value
UserOptions


CustomStreamForLoading Property

Keyoti RapidSpell Desktop .NET API Docs
CustomStreamForLoading Property
API ► Keyoti.RapidSpell.Options ► UserOptions ► CustomStreamForLoading
Keyoti RapidSpell Desktop .NET
The stream to use when loading options
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Stream CustomStreamForLoading { get; set; }
public Stream CustomStreamForLoading { get; set; }
Public Property CustomStreamForLoading As Stream
    Get
    Set
Public Property CustomStreamForLoading As Stream
    Get
    Set
public:
property Stream^ CustomStreamForLoading {
    Stream^ get ();
    void set (Stream^ value);
}
public:
property Stream^ CustomStreamForLoading {
    Stream^ get ();
    void set (Stream^ value);
}
member CustomStreamForLoading : Stream with get, set

member CustomStreamForLoading : Stream with get, set
Property Value
Stream


CustomStreamForSaving Property

Keyoti RapidSpell Desktop .NET API Docs
CustomStreamForSaving Property
API ► Keyoti.RapidSpell.Options ► UserOptions ► CustomStreamForSaving
Keyoti RapidSpell Desktop .NET
The stream to use when saving options
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Stream CustomStreamForSaving { get; set; }
public Stream CustomStreamForSaving { get; set; }
Public Property CustomStreamForSaving As Stream
    Get
    Set
Public Property CustomStreamForSaving As Stream
    Get
    Set
public:
property Stream^ CustomStreamForSaving {
    Stream^ get ();
    void set (Stream^ value);
}
public:
property Stream^ CustomStreamForSaving {
    Stream^ get ();
    void set (Stream^ value);
}
member CustomStreamForSaving : Stream with get, set

member CustomStreamForSaving : Stream with get, set
Property Value
Stream


Delete Method

Keyoti RapidSpell Desktop .NET API Docs
Delete Method
API ► Keyoti.RapidSpell.Options ► UserOptions ► Delete()()()()
Keyoti RapidSpell Desktop .NET
Delete the user's settings
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void Delete()
public void Delete()
Public Sub Delete
Public Sub Delete
public:
void Delete()
public:
void Delete()
member Delete : unit -> unit

member Delete : unit -> unit


Enabled Property

Keyoti RapidSpell Desktop .NET API Docs
Enabled Property
API ► Keyoti.RapidSpell.Options ► UserOptions ► Enabled
Keyoti RapidSpell Desktop .NET
Whether options are enabled
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool Enabled { get; set; }
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
member Enabled : bool with get, set

member Enabled : bool with get, set
Property Value
Boolean


FindSuggestions Property

Keyoti RapidSpell Desktop .NET API Docs
FindSuggestions Property
API ► Keyoti.RapidSpell.Options ► UserOptions ► FindSuggestions
Keyoti RapidSpell Desktop .NET
(User option)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool FindSuggestions { get; }
public bool FindSuggestions { get; }
Public ReadOnly Property FindSuggestions As Boolean
    Get
Public ReadOnly Property FindSuggestions As Boolean
    Get
public:
property bool FindSuggestions {
    bool get ();
}
public:
property bool FindSuggestions {
    bool get ();
}
member FindSuggestions : bool with get

member FindSuggestions : bool with get
Property Value
Boolean


IgnoreCapitalizedWords Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreCapitalizedWords Property
API ► Keyoti.RapidSpell.Options ► UserOptions ► IgnoreCapitalizedWords
Keyoti RapidSpell Desktop .NET
(User option)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreCapitalizedWords { get; }
public bool IgnoreCapitalizedWords { get; }
Public ReadOnly Property IgnoreCapitalizedWords As Boolean
    Get
Public ReadOnly Property IgnoreCapitalizedWords As Boolean
    Get
public:
property bool IgnoreCapitalizedWords {
    bool get ();
}
public:
property bool IgnoreCapitalizedWords {
    bool get ();
}
member IgnoreCapitalizedWords : bool with get

member IgnoreCapitalizedWords : bool with get
Property Value
Boolean


IgnoreURLsAndEmailAddresses Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreURLsAndEmailAddresses Property
API ► Keyoti.RapidSpell.Options ► UserOptions ► IgnoreURLsAndEmailAddresses
Keyoti RapidSpell Desktop .NET
(User option)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreURLsAndEmailAddresses { get; }
public bool IgnoreURLsAndEmailAddresses { get; }
Public ReadOnly Property IgnoreURLsAndEmailAddresses As Boolean
    Get
Public ReadOnly Property IgnoreURLsAndEmailAddresses As Boolean
    Get
public:
property bool IgnoreURLsAndEmailAddresses {
    bool get ();
}
public:
property bool IgnoreURLsAndEmailAddresses {
    bool get ();
}
member IgnoreURLsAndEmailAddresses : bool with get

member IgnoreURLsAndEmailAddresses : bool with get
Property Value
Boolean


IgnoreWordsWithDigits Property

Keyoti RapidSpell Desktop .NET API Docs
IgnoreWordsWithDigits Property
API ► Keyoti.RapidSpell.Options ► UserOptions ► IgnoreWordsWithDigits
Keyoti RapidSpell Desktop .NET
(User option)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreWordsWithDigits { get; }
public bool IgnoreWordsWithDigits { get; }
Public ReadOnly Property IgnoreWordsWithDigits As Boolean
    Get
Public ReadOnly Property IgnoreWordsWithDigits As Boolean
    Get
public:
property bool IgnoreWordsWithDigits {
    bool get ();
}
public:
property bool IgnoreWordsWithDigits {
    bool get ();
}
member IgnoreWordsWithDigits : bool with get

member IgnoreWordsWithDigits : bool with get
Property Value
Boolean


IncludeUserDictionaryInSuggestions Property

Keyoti RapidSpell Desktop .NET API Docs
IncludeUserDictionaryInSuggestions Property
API ► Keyoti.RapidSpell.Options ► UserOptions ► IncludeUserDictionaryInSuggestions
Keyoti RapidSpell Desktop .NET
(User option)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IncludeUserDictionaryInSuggestions { get; }
public bool IncludeUserDictionaryInSuggestions { get; }
Public ReadOnly Property IncludeUserDictionaryInSuggestions As Boolean
    Get
Public ReadOnly Property IncludeUserDictionaryInSuggestions As Boolean
    Get
public:
property bool IncludeUserDictionaryInSuggestions {
    bool get ();
}
public:
property bool IncludeUserDictionaryInSuggestions {
    bool get ();
}
member IncludeUserDictionaryInSuggestions : bool with get

member IncludeUserDictionaryInSuggestions : bool with get
Property Value
Boolean


Load Method

Keyoti RapidSpell Desktop .NET API Docs
Load Method
API ► Keyoti.RapidSpell.Options ► UserOptions ► Load()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Load()()()() | Load the user's settings
 | Load(Stream) | Load the users settings from userOptionsStream


Load Method

Keyoti RapidSpell Desktop .NET API Docs
Load Method
API ► Keyoti.RapidSpell.Options ► UserOptions ► Load()()()()
Keyoti RapidSpell Desktop .NET
Load the user's settings
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void Load()
public void Load()
Public Sub Load
Public Sub Load
public:
void Load()
public:
void Load()
member Load : unit -> unit

member Load : unit -> unit


Load Method (userOptionsStream)

Keyoti RapidSpell Desktop .NET API Docs
Load Method (userOptionsStream)
API ► Keyoti.RapidSpell.Options ► UserOptions ► Load(Stream)
Keyoti RapidSpell Desktop .NET
Load the users settings from userOptionsStream
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void Load(
    Stream userOptionsStream
)
public virtual void Load(
    Stream userOptionsStream
)
Public Overridable Sub Load (
    userOptionsStream As Stream
)
Public Overridable Sub Load (
    userOptionsStream As Stream
)
public:
virtual void Load(
    Stream^ userOptionsStream
)
public:
virtual void Load(
    Stream^ userOptionsStream
)
abstract Load :
        userOptionsStream : Stream -> unit
override Load :
        userOptionsStream : Stream -> unit
abstract Load :
        userOptionsStream : Stream -> unit
override Load :
        userOptionsStream : Stream -> unit
Parameters
userOptionsStream (Stream)
XML file stream containing options


NeedCustomStreamForLoading Event

Keyoti RapidSpell Desktop .NET API Docs
NeedCustomStreamForLoading Event
API ► Keyoti.RapidSpell.Options ► UserOptions ► NeedCustomStreamForLoading
Keyoti RapidSpell Desktop .NET
Fired when a custom stream can be set to load the options from.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event UserOptions..::..NeedStreamEventHandler NeedCustomStreamForLoading
public event UserOptions..::..NeedStreamEventHandler NeedCustomStreamForLoading
Public Event NeedCustomStreamForLoading As UserOptions..::..NeedStreamEventHandler
Public Event NeedCustomStreamForLoading As UserOptions..::..NeedStreamEventHandler
public:
 event UserOptions..::..NeedStreamEventHandler^ NeedCustomStreamForLoading {
    void add (UserOptions..::..NeedStreamEventHandler^ value);
    void remove (UserOptions..::..NeedStreamEventHandler^ value);
}
public:
 event UserOptions..::..NeedStreamEventHandler^ NeedCustomStreamForLoading {
    void add (UserOptions..::..NeedStreamEventHandler^ value);
    void remove (UserOptions..::..NeedStreamEventHandler^ value);
}
member NeedCustomStreamForLoading : IEvent<UserOptions..::..NeedStreamEventHandler,
    NeedStreamEventArgs>

member NeedCustomStreamForLoading : IEvent<UserOptions..::..NeedStreamEventHandler,
    NeedStreamEventArgs>
Value
UserOptions..::..NeedStreamEventHandler


NeedCustomStreamForSaving Event

Keyoti RapidSpell Desktop .NET API Docs
NeedCustomStreamForSaving Event
API ► Keyoti.RapidSpell.Options ► UserOptions ► NeedCustomStreamForSaving
Keyoti RapidSpell Desktop .NET
Fired when a custom stream can be set to save the options to.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event UserOptions..::..NeedStreamEventHandler NeedCustomStreamForSaving
public event UserOptions..::..NeedStreamEventHandler NeedCustomStreamForSaving
Public Event NeedCustomStreamForSaving As UserOptions..::..NeedStreamEventHandler
Public Event NeedCustomStreamForSaving As UserOptions..::..NeedStreamEventHandler
public:
 event UserOptions..::..NeedStreamEventHandler^ NeedCustomStreamForSaving {
    void add (UserOptions..::..NeedStreamEventHandler^ value);
    void remove (UserOptions..::..NeedStreamEventHandler^ value);
}
public:
 event UserOptions..::..NeedStreamEventHandler^ NeedCustomStreamForSaving {
    void add (UserOptions..::..NeedStreamEventHandler^ value);
    void remove (UserOptions..::..NeedStreamEventHandler^ value);
}
member NeedCustomStreamForSaving : IEvent<UserOptions..::..NeedStreamEventHandler,
    NeedStreamEventArgs>

member NeedCustomStreamForSaving : IEvent<UserOptions..::..NeedStreamEventHandler,
    NeedStreamEventArgs>
Value
UserOptions..::..NeedStreamEventHandler


OnRecheckDocumentRequest Method (e)

Keyoti RapidSpell Desktop .NET API Docs
OnRecheckDocumentRequest Method (e)
API ► Keyoti.RapidSpell.Options ► UserOptions ► OnRecheckDocumentRequest(EventArgs)
Keyoti RapidSpell Desktop .NET
Raises recheck document event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void OnRecheckDocumentRequest(
    EventArgs e
)
public void OnRecheckDocumentRequest(
    EventArgs e
)
Public Sub OnRecheckDocumentRequest (
    e As EventArgs
)
Public Sub OnRecheckDocumentRequest (
    e As EventArgs
)
public:
void OnRecheckDocumentRequest(
    EventArgs^ e
)
public:
void OnRecheckDocumentRequest(
    EventArgs^ e
)
member OnRecheckDocumentRequest :
        e : EventArgs -> unit

member OnRecheckDocumentRequest :
        e : EventArgs -> unit
Parameters
e (EventArgs)


OptionsHaveChanged Method

Keyoti RapidSpell Desktop .NET API Docs
OptionsHaveChanged Method
API ► Keyoti.RapidSpell.Options ► UserOptions ► OptionsHaveChanged()()()()
Keyoti RapidSpell Desktop .NET
Whether this and c are set with the same options.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool OptionsHaveChanged()
public virtual bool OptionsHaveChanged()
Public Overridable Function OptionsHaveChanged As Boolean
Public Overridable Function OptionsHaveChanged As Boolean
public:
virtual bool OptionsHaveChanged()
public:
virtual bool OptionsHaveChanged()
abstract OptionsHaveChanged : unit -> bool
override OptionsHaveChanged : unit -> bool
abstract OptionsHaveChanged : unit -> bool
override OptionsHaveChanged : unit -> bool
Return Value
Boolean


OptionsSaved Event

Keyoti RapidSpell Desktop .NET API Docs
OptionsSaved Event
API ► Keyoti.RapidSpell.Options ► UserOptions ► OptionsSaved
Keyoti RapidSpell Desktop .NET
Fired when the options are saved
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event OptionsSavedEventHandler OptionsSaved
public event OptionsSavedEventHandler OptionsSaved
Public Event OptionsSaved As OptionsSavedEventHandler
Public Event OptionsSaved As OptionsSavedEventHandler
public:
 event OptionsSavedEventHandler^ OptionsSaved {
    void add (OptionsSavedEventHandler^ value);
    void remove (OptionsSavedEventHandler^ value);
}
public:
 event OptionsSavedEventHandler^ OptionsSaved {
    void add (OptionsSavedEventHandler^ value);
    void remove (OptionsSavedEventHandler^ value);
}
member OptionsSaved : IEvent<OptionsSavedEventHandler,
    OptionsSavedEventArgs>

member OptionsSaved : IEvent<OptionsSavedEventHandler,
    OptionsSavedEventArgs>
Value
OptionsSavedEventHandler


RecheckDocumentRequest Event

Keyoti RapidSpell Desktop .NET API Docs
RecheckDocumentRequest Event
API ► Keyoti.RapidSpell.Options ► UserOptions ► RecheckDocumentRequest
Keyoti RapidSpell Desktop .NET
Fired when the user requests the text to be rechecked
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler RecheckDocumentRequest
public event EventHandler RecheckDocumentRequest
Public Event RecheckDocumentRequest As EventHandler
Public Event RecheckDocumentRequest As EventHandler
public:
 event EventHandler^ RecheckDocumentRequest {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
 event EventHandler^ RecheckDocumentRequest {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member RecheckDocumentRequest : IEvent<EventHandler,
    EventArgs>

member RecheckDocumentRequest : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


Save Method

Keyoti RapidSpell Desktop .NET API Docs
Save Method
API ► Keyoti.RapidSpell.Options ► UserOptions ► Save()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Save()()()() | Save user's settings
 | Save(Stream) | Save user's settings to stream


Save Method

Keyoti RapidSpell Desktop .NET API Docs
Save Method
API ► Keyoti.RapidSpell.Options ► UserOptions ► Save()()()()
Keyoti RapidSpell Desktop .NET
Save user's settings
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void Save()
public void Save()
Public Sub Save
Public Sub Save
public:
void Save()
public:
void Save()
member Save : unit -> unit

member Save : unit -> unit


Save Method (stream)

Keyoti RapidSpell Desktop .NET API Docs
Save Method (stream)
API ► Keyoti.RapidSpell.Options ► UserOptions ► Save(Stream)
Keyoti RapidSpell Desktop .NET
Save user's settings to stream
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void Save(
    Stream stream
)
public virtual void Save(
    Stream stream
)
Public Overridable Sub Save (
    stream As Stream
)
Public Overridable Sub Save (
    stream As Stream
)
public:
virtual void Save(
    Stream^ stream
)
public:
virtual void Save(
    Stream^ stream
)
abstract Save :
        stream : Stream -> unit
override Save :
        stream : Stream -> unit
abstract Save :
        stream : Stream -> unit
override Save :
        stream : Stream -> unit
Parameters
stream (Stream)


SetDefaultUserDictionaryFile Method (defaultUserDictionaryItem)

Keyoti RapidSpell Desktop .NET API Docs
SetDefaultUserDictionaryFile Method (defaultUserDictionaryItem)
API ► Keyoti.RapidSpell.Options ► UserOptions ► SetDefaultUserDictionaryFile(String)
Keyoti RapidSpell Desktop .NET
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void SetDefaultUserDictionaryFile(
    string defaultUserDictionaryItem
)
public void SetDefaultUserDictionaryFile(
    string defaultUserDictionaryItem
)
Public Sub SetDefaultUserDictionaryFile (
    defaultUserDictionaryItem As String
)
Public Sub SetDefaultUserDictionaryFile (
    defaultUserDictionaryItem As String
)
public:
void SetDefaultUserDictionaryFile(
    String^ defaultUserDictionaryItem
)
public:
void SetDefaultUserDictionaryFile(
    String^ defaultUserDictionaryItem
)
member SetDefaultUserDictionaryFile :
        defaultUserDictionaryItem : string -> unit

member SetDefaultUserDictionaryFile :
        defaultUserDictionaryItem : string -> unit
Parameters
defaultUserDictionaryItem (String)


SetUserOptions Method (checkAsYouType, includeUserDictionaryInSuggestions, ignoreWordsWithDigits, ignoreURLsAndEmailAddresses, ignoreCapitalizedWords, allowMixedCase, allowAnyCase, findSuggestions, isTrackPoint)

Keyoti RapidSpell Desktop .NET API Docs
SetUserOptions Method (checkAsYouType, includeUserDictionaryInSuggestions, ignoreWordsWithDigits, ignoreURLsAndEmailAddresses, ignoreCapitalizedWords, allowMixedCase, allowAnyCase, findSuggestions, isTrackPoint)
API ► Keyoti.RapidSpell.Options ► UserOptions ► SetUserOptions(Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean)
Keyoti RapidSpell Desktop .NET
Sets new settings
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void SetUserOptions(
    bool checkAsYouType,
    bool includeUserDictionaryInSuggestions,
    bool ignoreWordsWithDigits,
    bool ignoreURLsAndEmailAddresses,
    bool ignoreCapitalizedWords,
    bool allowMixedCase,
    bool allowAnyCase,
    bool findSuggestions,
    bool isTrackPoint
)
public virtual void SetUserOptions(
    bool checkAsYouType,
    bool includeUserDictionaryInSuggestions,
    bool ignoreWordsWithDigits,
    bool ignoreURLsAndEmailAddresses,
    bool ignoreCapitalizedWords,
    bool allowMixedCase,
    bool allowAnyCase,
    bool findSuggestions,
    bool isTrackPoint
)
Public Overridable Sub SetUserOptions (
    checkAsYouType As Boolean,
    includeUserDictionaryInSuggestions As Boolean,
    ignoreWordsWithDigits As Boolean,
    ignoreURLsAndEmailAddresses As Boolean,
    ignoreCapitalizedWords As Boolean,
    allowMixedCase As Boolean,
    allowAnyCase As Boolean,
    findSuggestions As Boolean,
    isTrackPoint As Boolean
)
Public Overridable Sub SetUserOptions (
    checkAsYouType As Boolean,
    includeUserDictionaryInSuggestions As Boolean,
    ignoreWordsWithDigits As Boolean,
    ignoreURLsAndEmailAddresses As Boolean,
    ignoreCapitalizedWords As Boolean,
    allowMixedCase As Boolean,
    allowAnyCase As Boolean,
    findSuggestions As Boolean,
    isTrackPoint As Boolean
)
public:
virtual void SetUserOptions(
    bool checkAsYouType,
    bool includeUserDictionaryInSuggestions,
    bool ignoreWordsWithDigits,
    bool ignoreURLsAndEmailAddresses,
    bool ignoreCapitalizedWords,
    bool allowMixedCase,
    bool allowAnyCase,
    bool findSuggestions,
    bool isTrackPoint
)
public:
virtual void SetUserOptions(
    bool checkAsYouType,
    bool includeUserDictionaryInSuggestions,
    bool ignoreWordsWithDigits,
    bool ignoreURLsAndEmailAddresses,
    bool ignoreCapitalizedWords,
    bool allowMixedCase,
    bool allowAnyCase,
    bool findSuggestions,
    bool isTrackPoint
)
abstract SetUserOptions :
        checkAsYouType : bool *
        includeUserDictionaryInSuggestions : bool *
        ignoreWordsWithDigits : bool *
        ignoreURLsAndEmailAddresses : bool *
        ignoreCapitalizedWords : bool *
        allowMixedCase : bool *
        allowAnyCase : bool *
        findSuggestions : bool *
        isTrackPoint : bool -> unit
override SetUserOptions :
        checkAsYouType : bool *
        includeUserDictionaryInSuggestions : bool *
        ignoreWordsWithDigits : bool *
        ignoreURLsAndEmailAddresses : bool *
        ignoreCapitalizedWords : bool *
        allowMixedCase : bool *
        allowAnyCase : bool *
        findSuggestions : bool *
        isTrackPoint : bool -> unit
abstract SetUserOptions :
        checkAsYouType : bool *
        includeUserDictionaryInSuggestions : bool *
        ignoreWordsWithDigits : bool *
        ignoreURLsAndEmailAddresses : bool *
        ignoreCapitalizedWords : bool *
        allowMixedCase : bool *
        allowAnyCase : bool *
        findSuggestions : bool *
        isTrackPoint : bool -> unit
override SetUserOptions :
        checkAsYouType : bool *
        includeUserDictionaryInSuggestions : bool *
        ignoreWordsWithDigits : bool *
        ignoreURLsAndEmailAddresses : bool *
        ignoreCapitalizedWords : bool *
        allowMixedCase : bool *
        allowAnyCase : bool *
        findSuggestions : bool *
        isTrackPoint : bool -> unit
Parameters
checkAsYouType (Boolean)
includeUserDictionaryInSuggestions (Boolean)
ignoreWordsWithDigits (Boolean)
ignoreURLsAndEmailAddresses (Boolean)
ignoreCapitalizedWords (Boolean)
allowMixedCase (Boolean)
allowAnyCase (Boolean)
findSuggestions (Boolean)
isTrackPoint (Boolean)
Remarks
Set isTrackPoint to true in order to monitor changes from this point until Save is called. See OptionsSavedEventArgs for indicator for change since track point. If you set the options through SetUserOptions, then passing isTrackPoint==false will mean that when Save is called, an event is fired for the property changes (causing the body text to be rechecked with the new settings). If isTrackPoint==true then it will think those settings are the original settings and no event will be fired on Save.


StorageLocation Property

Keyoti RapidSpell Desktop .NET API Docs
StorageLocation Property
API ► Keyoti.RapidSpell.Options ► UserOptions ► StorageLocation
Keyoti RapidSpell Desktop .NET
Where the user's options are stored.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UserOptions..::..StorageType StorageLocation { get; set; }
public UserOptions..::..StorageType StorageLocation { get; set; }
Public Property StorageLocation As UserOptions..::..StorageType
    Get
    Set
Public Property StorageLocation As UserOptions..::..StorageType
    Get
    Set
public:
property UserOptions..::..StorageType StorageLocation {
    UserOptions..::..StorageType get ();
    void set (UserOptions..::..StorageType value);
}
public:
property UserOptions..::..StorageType StorageLocation {
    UserOptions..::..StorageType get ();
    void set (UserOptions..::..StorageType value);
}
member StorageLocation : UserOptions..::..StorageType with get, set

member StorageLocation : UserOptions..::..StorageType with get, set
Property Value
UserOptions..::..StorageType


SupplementalUserDictionaryFiles Property

Keyoti RapidSpell Desktop .NET API Docs
SupplementalUserDictionaryFiles Property
API ► Keyoti.RapidSpell.Options ► UserOptions ► SupplementalUserDictionaryFiles
Keyoti RapidSpell Desktop .NET
User chosen additional user dictionary files.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public List<string> SupplementalUserDictionaryFiles { get; }
public List<string> SupplementalUserDictionaryFiles { get; }
Public ReadOnly Property SupplementalUserDictionaryFiles As List(Of String)
    Get
Public ReadOnly Property SupplementalUserDictionaryFiles As List(Of String)
    Get
public:
property List<String^>^ SupplementalUserDictionaryFiles {
    List<String^>^ get ();
}
public:
property List<String^>^ SupplementalUserDictionaryFiles {
    List<String^>^ get ();
}
member SupplementalUserDictionaryFiles : List<string> with get

member SupplementalUserDictionaryFiles : List<string> with get
Property Value
List <(Of <(<' String >)>)>


UserDictionary Property

Keyoti RapidSpell Desktop .NET API Docs
UserDictionary Property
API ► Keyoti.RapidSpell.Options ► UserOptions ► UserDictionary
Keyoti RapidSpell Desktop .NET
The user dictionary loaded for the user
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UserDictionary UserDictionary { get; set; }
public UserDictionary UserDictionary { get; set; }
Public Property UserDictionary As UserDictionary
    Get
    Set
Public Property UserDictionary As UserDictionary
    Get
    Set
public:
property UserDictionary^ UserDictionary {
    UserDictionary^ get ();
    void set (UserDictionary^ value);
}
public:
property UserDictionary^ UserDictionary {
    UserDictionary^ get ();
    void set (UserDictionary^ value);
}
member UserDictionary : UserDictionary with get, set

member UserDictionary : UserDictionary with get, set
Property Value
UserDictionary


UserDictionaryContentChanged Event

Keyoti RapidSpell Desktop .NET API Docs
UserDictionaryContentChanged Event
API ► Keyoti.RapidSpell.Options ► UserOptions ► UserDictionaryContentChanged
Keyoti RapidSpell Desktop .NET
Fired when the user dictionary content has changed and should be reloaded.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event UserOptions..::..UserDictionaryContentChangeEventHandler UserDictionaryContentChanged
public event UserOptions..::..UserDictionaryContentChangeEventHandler UserDictionaryContentChanged
Public Event UserDictionaryContentChanged As UserOptions..::..UserDictionaryContentChangeEventHandler
Public Event UserDictionaryContentChanged As UserOptions..::..UserDictionaryContentChangeEventHandler
public:
 event UserOptions..::..UserDictionaryContentChangeEventHandler^ UserDictionaryContentChanged {
    void add (UserOptions..::..UserDictionaryContentChangeEventHandler^ value);
    void remove (UserOptions..::..UserDictionaryContentChangeEventHandler^ value);
}
public:
 event UserOptions..::..UserDictionaryContentChangeEventHandler^ UserDictionaryContentChanged {
    void add (UserOptions..::..UserDictionaryContentChangeEventHandler^ value);
    void remove (UserOptions..::..UserDictionaryContentChangeEventHandler^ value);
}
member UserDictionaryContentChanged : IEvent<UserOptions..::..UserDictionaryContentChangeEventHandler,
    UserDictionaryContentChangedEventArgs>

member UserDictionaryContentChanged : IEvent<UserOptions..::..UserDictionaryContentChangeEventHandler,
    UserDictionaryContentChangedEventArgs>
Value
UserOptions..::..UserDictionaryContentChangeEventHandler


UserDictionaryDefaultChanged Event

Keyoti RapidSpell Desktop .NET API Docs
UserDictionaryDefaultChanged Event
API ► Keyoti.RapidSpell.Options ► UserOptions ► UserDictionaryDefaultChanged
Keyoti RapidSpell Desktop .NET
Fired when the default user dictionary is changed by the user.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event UserOptions..::..UserDictionaryDefaultChangeEventHandler UserDictionaryDefaultChanged
public event UserOptions..::..UserDictionaryDefaultChangeEventHandler UserDictionaryDefaultChanged
Public Event UserDictionaryDefaultChanged As UserOptions..::..UserDictionaryDefaultChangeEventHandler
Public Event UserDictionaryDefaultChanged As UserOptions..::..UserDictionaryDefaultChangeEventHandler
public:
 event UserOptions..::..UserDictionaryDefaultChangeEventHandler^ UserDictionaryDefaultChanged {
    void add (UserOptions..::..UserDictionaryDefaultChangeEventHandler^ value);
    void remove (UserOptions..::..UserDictionaryDefaultChangeEventHandler^ value);
}
public:
 event UserOptions..::..UserDictionaryDefaultChangeEventHandler^ UserDictionaryDefaultChanged {
    void add (UserOptions..::..UserDictionaryDefaultChangeEventHandler^ value);
    void remove (UserOptions..::..UserDictionaryDefaultChangeEventHandler^ value);
}
member UserDictionaryDefaultChanged : IEvent<UserOptions..::..UserDictionaryDefaultChangeEventHandler,
    UserDictionaryDefaultChangeEventArgs>

member UserDictionaryDefaultChanged : IEvent<UserOptions..::..UserDictionaryDefaultChangeEventHandler,
    UserDictionaryDefaultChangeEventArgs>
Value
UserOptions..::..UserDictionaryDefaultChangeEventHandler


UserOptionsFileName Property

Keyoti RapidSpell Desktop .NET API Docs
UserOptionsFileName Property
API ► Keyoti.RapidSpell.Options ► UserOptions ► UserOptionsFileName
Keyoti RapidSpell Desktop .NET
The file name used to store the settings (by default in IsolatedStorage).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserOptionsFileName { get; set; }
public string UserOptionsFileName { get; set; }
Public Property UserOptionsFileName As String
    Get
    Set
Public Property UserOptionsFileName As String
    Get
    Set
public:
property String^ UserOptionsFileName {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserOptionsFileName {
    String^ get ();
    void set (String^ value);
}
member UserOptionsFileName : string with get, set

member UserOptionsFileName : string with get, set
Property Value
String
Remarks
Changing this can ensure different applications have unique user settings.


UserOptions.NeedStreamEventHandler Delegate

Keyoti RapidSpell Desktop .NET API Docs
UserOptions..::..NeedStreamEventHandler Delegate
API ► Keyoti.RapidSpell.Options ► UserOptions ► UserOptions..::..NeedStreamEventHandler
Keyoti RapidSpell Desktop .NET
Delegate for need stream events.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void NeedStreamEventHandler(
    Object sender,
    NeedStreamEventArgs e
)
public delegate void NeedStreamEventHandler(
    Object sender,
    NeedStreamEventArgs e
)
Public Delegate Sub NeedStreamEventHandler (
    sender As Object,
    e As NeedStreamEventArgs
)
Public Delegate Sub NeedStreamEventHandler (
    sender As Object,
    e As NeedStreamEventArgs
)
public delegate void NeedStreamEventHandler(
    Object^ sender,
    NeedStreamEventArgs^ e
)
public delegate void NeedStreamEventHandler(
    Object^ sender,
    NeedStreamEventArgs^ e
)
type NeedStreamEventHandler =
    delegate of
        sender : Object *
        e : NeedStreamEventArgs -> unit
type NeedStreamEventHandler =
    delegate of
        sender : Object *
        e : NeedStreamEventArgs -> unit
Parameters
sender (Object)
e (NeedStreamEventArgs)


UserOptions.StorageType Enumeration

Keyoti RapidSpell Desktop .NET API Docs
UserOptions..::..StorageType Enumeration
API ► Keyoti.RapidSpell.Options ► UserOptions ► UserOptions..::..StorageType
Keyoti RapidSpell Desktop .NET
The option storage location
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public enum StorageType
public enum StorageType
Public Enumeration StorageType
Public Enumeration StorageType
public enum class StorageType
public enum class StorageType
type StorageType
type StorageType
Members
Member | Description
IsolatedStorage | The .NET isolated storage mechanism
FileSystem | The regular file-system
Stream | A stream provided by the API user


UserOptions.UserDictionaryContentChangeEventHandler Delegate

Keyoti RapidSpell Desktop .NET API Docs
UserOptions..::..UserDictionaryContentChangeEventHandler Delegate
API ► Keyoti.RapidSpell.Options ► UserOptions ► UserOptions..::..UserDictionaryContentChangeEventHandler
Keyoti RapidSpell Desktop .NET
Handler delegate
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void UserDictionaryContentChangeEventHandler(
    Object sender,
    UserDictionaryContentChangedEventArgs e
)
public delegate void UserDictionaryContentChangeEventHandler(
    Object sender,
    UserDictionaryContentChangedEventArgs e
)
Public Delegate Sub UserDictionaryContentChangeEventHandler (
    sender As Object,
    e As UserDictionaryContentChangedEventArgs
)
Public Delegate Sub UserDictionaryContentChangeEventHandler (
    sender As Object,
    e As UserDictionaryContentChangedEventArgs
)
public delegate void UserDictionaryContentChangeEventHandler(
    Object^ sender,
    UserDictionaryContentChangedEventArgs^ e
)
public delegate void UserDictionaryContentChangeEventHandler(
    Object^ sender,
    UserDictionaryContentChangedEventArgs^ e
)
type UserDictionaryContentChangeEventHandler =
    delegate of
        sender : Object *
        e : UserDictionaryContentChangedEventArgs -> unit
type UserDictionaryContentChangeEventHandler =
    delegate of
        sender : Object *
        e : UserDictionaryContentChangedEventArgs -> unit
Parameters
sender (Object)
e (UserDictionaryContentChangedEventArgs)


UserOptions.UserDictionaryDefaultChangeEventHandler Delegate

Keyoti RapidSpell Desktop .NET API Docs
UserOptions..::..UserDictionaryDefaultChangeEventHandler Delegate
API ► Keyoti.RapidSpell.Options ► UserOptions ► UserOptions..::..UserDictionaryDefaultChangeEventHandler
Keyoti RapidSpell Desktop .NET
Handler delegate
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void UserDictionaryDefaultChangeEventHandler(
    Object sender,
    UserDictionaryDefaultChangeEventArgs e
)
public delegate void UserDictionaryDefaultChangeEventHandler(
    Object sender,
    UserDictionaryDefaultChangeEventArgs e
)
Public Delegate Sub UserDictionaryDefaultChangeEventHandler (
    sender As Object,
    e As UserDictionaryDefaultChangeEventArgs
)
Public Delegate Sub UserDictionaryDefaultChangeEventHandler (
    sender As Object,
    e As UserDictionaryDefaultChangeEventArgs
)
public delegate void UserDictionaryDefaultChangeEventHandler(
    Object^ sender,
    UserDictionaryDefaultChangeEventArgs^ e
)
public delegate void UserDictionaryDefaultChangeEventHandler(
    Object^ sender,
    UserDictionaryDefaultChangeEventArgs^ e
)
type UserDictionaryDefaultChangeEventHandler =
    delegate of
        sender : Object *
        e : UserDictionaryDefaultChangeEventArgs -> unit
type UserDictionaryDefaultChangeEventHandler =
    delegate of
        sender : Object *
        e : UserDictionaryDefaultChangeEventArgs -> unit
Parameters
sender (Object)
e (UserDictionaryDefaultChangeEventArgs)


Keyoti.RapidSpell.ThirdParty.DevExpress6 Namespace

Keyoti RapidSpell Desktop .NET API Docs
Keyoti.RapidSpell.ThirdParty.DevExpress6 Namespace
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6
Keyoti RapidSpell Desktop .NET
3rd party support
Types
All Types Classes Interfaces
Icon | Type | Description
 | ITextBoxMaskBox | Internally used proxy interface.
 | IThirdPartyTextBoxConnector | Internally used proxy interface.
 | TextBoxConnector | As-You-Type enabled TextBox.


ITextBoxMaskBox Interface

Keyoti RapidSpell Desktop .NET API Docs
ITextBoxMaskBox Interface
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► ITextBoxMaskBox
Keyoti RapidSpell Desktop .NET
Internally used proxy interface.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public interface ITextBoxMaskBox
public interface ITextBoxMaskBox
Public Interface ITextBoxMaskBox
Public Interface ITextBoxMaskBox
public interface class ITextBoxMaskBox
public interface class ITextBoxMaskBox
type ITextBoxMaskBox =  interface end
type ITextBoxMaskBox =  interface end
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AppendText(String) | Internal
 | BeginInvoke(Delegate) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
 | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
 | CallWndProc(Message%) | Internal
 | Clear()()()() | Internal
 | ClearUndo()()()() | Internal
 | ClientSize | Internal
 | ContextMenu | Internal
 | ContextMenuStrip | Internal
 | Copy()()()() | Internal
 | Cut()()()() | Internal
 | Disposed | Internal
 | EditText | Internal
 | Enter | Occurs when the control receives focus.
 | Font | Internal
 | FontChanged | Internal
 | Handle | Internal
 | Height | Internal
 | IsDisposed | Internal
 | IsHandleCreated | Same as Control.IsHandleCreated
 | KeyDown | Occurs when a key is pressed while the control has focus.
 | KeyUp | Occurs when a key is released while the control has focus.
 | Leave | Occurs when the control loses focus.
 | MaskBoxSelectedText | Internal
 | MaskBoxSelectionLength | Internal
 | MaskBoxSelectionStart | Internal
 | MaskBoxText | Internal
 | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed.
 | MouseUp | Occurs when the mouse is released on the text box.
 | MouseWheel | Occurs when the mouse wheel is used to scroll.
 | Paste()()()() | Internal
 | Refresh()()()() | Internal
 | Resize | Internal
 | SelectAll()()()() | Internal
 | SelectedText | Internal
 | SelectionLength | Internal
 | SelectionStart | Internal
 | SuspendLayout()()()() | Internal
 | Text | Internal
 | TextChanged | Occurs when the Text property value changes.
 | TextLength | Internal
 | Undo()()()() | Internal
 | Width | Internal


AppendText Method (text)

Keyoti RapidSpell Desktop .NET API Docs
AppendText Method (text)
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► ITextBoxMaskBox ► AppendText(String)
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void AppendText(
    string text
)
void AppendText(
    string text
)
Sub AppendText (
    text As String
)
Sub AppendText (
    text As String
)
void AppendText(
    String^ text
)
void AppendText(
    String^ text
)
abstract AppendText :
        text : string -> unit

abstract AppendText :
        text : string -> unit
Parameters
text (String)


BeginInvoke Method

Keyoti RapidSpell Desktop .NET API Docs
BeginInvoke Method
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► ITextBoxMaskBox ► BeginInvoke()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | BeginInvoke(Delegate) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
 | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.


BeginInvoke Method (d)

Keyoti RapidSpell Desktop .NET API Docs
BeginInvoke Method (d)
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► ITextBoxMaskBox ► BeginInvoke(Delegate)
Keyoti RapidSpell Desktop .NET
Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
IAsyncResult BeginInvoke(
    Delegate d
)
IAsyncResult BeginInvoke(
    Delegate d
)
Function BeginInvoke (
    d As Delegate
) As IAsyncResult
Function BeginInvoke (
    d As Delegate
) As IAsyncResult
IAsyncResult^ BeginInvoke(
    Delegate^ d
)
IAsyncResult^ BeginInvoke(
    Delegate^ d
)
abstract BeginInvoke :
        d : Delegate -> IAsyncResult

abstract BeginInvoke :
        d : Delegate -> IAsyncResult
Parameters
d (Delegate)
Return Value
IAsyncResult


BeginInvoke Method (d, parameters)

Keyoti RapidSpell Desktop .NET API Docs
BeginInvoke Method (d, parameters)
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► ITextBoxMaskBox ► BeginInvoke(Delegate, array<Object>[]()[][])
Keyoti RapidSpell Desktop .NET
Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
IAsyncResult BeginInvoke(
    Delegate d,
    Object[] parameters
)
IAsyncResult BeginInvoke(
    Delegate d,
    Object[] parameters
)
Function BeginInvoke (
    d As Delegate,
    parameters As Object()
) As IAsyncResult
Function BeginInvoke (
    d As Delegate,
    parameters As Object()
) As IAsyncResult
IAsyncResult^ BeginInvoke(
    Delegate^ d,
    array<Object^>^ parameters
)
IAsyncResult^ BeginInvoke(
    Delegate^ d,
    array<Object^>^ parameters
)
abstract BeginInvoke :
        d : Delegate *
        parameters : Object[] -> IAsyncResult

abstract BeginInvoke :
        d : Delegate *
        parameters : Object[] -> IAsyncResult
Parameters
d (Delegate)
parameters (array< Object >[]()[][])
Return Value
IAsyncResult


CallWndProc Method (m)

Keyoti RapidSpell Desktop .NET API Docs
CallWndProc Method (m)
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► ITextBoxMaskBox ► CallWndProc(Message%)
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void CallWndProc(
    ref Message m
)
void CallWndProc(
    ref Message m
)
Sub CallWndProc (
    ByRef m As Message
)
Sub CallWndProc (
    ByRef m As Message
)
void CallWndProc(
    Message% m
)
void CallWndProc(
    Message% m
)
abstract CallWndProc :
        m : Message byref -> unit

abstract CallWndProc :
        m : Message byref -> unit
Parameters
m (Message %)


Clear Method

Keyoti RapidSpell Desktop .NET API Docs
Clear Method
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► ITextBoxMaskBox ► Clear()()()()
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void Clear()
void Clear()
Sub Clear
Sub Clear
void Clear()
void Clear()
abstract Clear : unit -> unit

abstract Clear : unit -> unit


ClearUndo Method

Keyoti RapidSpell Desktop .NET API Docs
ClearUndo Method
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► ITextBoxMaskBox ► ClearUndo()()()()
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void ClearUndo()
void ClearUndo()
Sub ClearUndo
Sub ClearUndo
void ClearUndo()
void ClearUndo()
abstract ClearUndo : unit -> unit

abstract ClearUndo : unit -> unit


ClientSize Property

Keyoti RapidSpell Desktop .NET API Docs
ClientSize Property
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► ITextBoxMaskBox ► ClientSize
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
Size ClientSize { get; set; }
Size ClientSize { get; set; }
Property ClientSize As Size
    Get
    Set
Property ClientSize As Size
    Get
    Set
property Size ClientSize {
    Size get ();
    void set (Size value);
}
property Size ClientSize {
    Size get ();
    void set (Size value);
}
abstract ClientSize : Size with get, set

abstract ClientSize : Size with get, set
Property Value
Size


ContextMenu Property

Keyoti RapidSpell Desktop .NET API Docs
ContextMenu Property
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► ITextBoxMaskBox ► ContextMenu
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
ContextMenu ContextMenu { get; set; }
ContextMenu ContextMenu { get; set; }
Property ContextMenu As ContextMenu
    Get
    Set
Property ContextMenu As ContextMenu
    Get
    Set
property ContextMenu^ ContextMenu {
    ContextMenu^ get ();
    void set (ContextMenu^ value);
}
property ContextMenu^ ContextMenu {
    ContextMenu^ get ();
    void set (ContextMenu^ value);
}
abstract ContextMenu : ContextMenu with get, set

abstract ContextMenu : ContextMenu with get, set
Property Value
ContextMenu


ContextMenuStrip Property

Keyoti RapidSpell Desktop .NET API Docs
ContextMenuStrip Property
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► ITextBoxMaskBox ► ContextMenuStrip
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
ContextMenuStrip ContextMenuStrip { get; set; }
ContextMenuStrip ContextMenuStrip { get; set; }
Property ContextMenuStrip As ContextMenuStrip
    Get
    Set
Property ContextMenuStrip As ContextMenuStrip
    Get
    Set
property ContextMenuStrip^ ContextMenuStrip {
    ContextMenuStrip^ get ();
    void set (ContextMenuStrip^ value);
}
property ContextMenuStrip^ ContextMenuStrip {
    ContextMenuStrip^ get ();
    void set (ContextMenuStrip^ value);
}
abstract ContextMenuStrip : ContextMenuStrip with get, set

abstract ContextMenuStrip : ContextMenuStrip with get, set
Property Value
ContextMenuStrip


Copy Method

Keyoti RapidSpell Desktop .NET API Docs
Copy Method
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► ITextBoxMaskBox ► Copy()()()()
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void Copy()
void Copy()
Sub Copy
Sub Copy
void Copy()
void Copy()
abstract Copy : unit -> unit

abstract Copy : unit -> unit


Cut Method

Keyoti RapidSpell Desktop .NET API Docs
Cut Method
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► ITextBoxMaskBox ► Cut()()()()
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void Cut()
void Cut()
Sub Cut
Sub Cut
void Cut()
void Cut()
abstract Cut : unit -> unit

abstract Cut : unit -> unit


Disposed Event

Keyoti RapidSpell Desktop .NET API Docs
Disposed Event
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► ITextBoxMaskBox ► Disposed
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event EventHandler Disposed
event EventHandler Disposed
Event Disposed As EventHandler
Event Disposed As EventHandler
 event EventHandler^ Disposed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
 event EventHandler^ Disposed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Disposed : IEvent<EventHandler,
    EventArgs>

abstract Disposed : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


EditText Property

Keyoti RapidSpell Desktop .NET API Docs
EditText Property
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► ITextBoxMaskBox ► EditText
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string EditText { get; set; }
string EditText { get; set; }
Property EditText As String
    Get
    Set
Property EditText As String
    Get
    Set
property String^ EditText {
    String^ get ();
    void set (String^ value);
}
property String^ EditText {
    String^ get ();
    void set (String^ value);
}
abstract EditText : string with get, set

abstract EditText : string with get, set
Property Value
String


Enter Event

Keyoti RapidSpell Desktop .NET API Docs
Enter Event
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► ITextBoxMaskBox ► Enter
Keyoti RapidSpell Desktop .NET
Occurs when the control receives focus.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event EventHandler Enter
event EventHandler Enter
Event Enter As EventHandler
Event Enter As EventHandler
 event EventHandler^ Enter {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
 event EventHandler^ Enter {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Enter : IEvent<EventHandler,
    EventArgs>

abstract Enter : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


Font Property

Keyoti RapidSpell Desktop .NET API Docs
Font Property
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► ITextBoxMaskBox ► Font
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
Font Font { get; set; }
Font Font { get; set; }
Property Font As Font
    Get
    Set
Property Font As Font
    Get
    Set
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
abstract Font : Font with get, set

abstract Font : Font with get, set
Property Value
Font


FontChanged Event

Keyoti RapidSpell Desktop .NET API Docs
FontChanged Event
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► ITextBoxMaskBox ► FontChanged
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event EventHandler FontChanged
event EventHandler FontChanged
Event FontChanged As EventHandler
Event FontChanged As EventHandler
 event EventHandler^ FontChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
 event EventHandler^ FontChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract FontChanged : IEvent<EventHandler,
    EventArgs>

abstract FontChanged : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


Handle Property

Keyoti RapidSpell Desktop .NET API Docs
Handle Property
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► ITextBoxMaskBox ► Handle
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
IntPtr Handle { get; }
IntPtr Handle { get; }
ReadOnly Property Handle As IntPtr
    Get
ReadOnly Property Handle As IntPtr
    Get
property IntPtr Handle {
    IntPtr get ();
}
property IntPtr Handle {
    IntPtr get ();
}
abstract Handle : IntPtr with get

abstract Handle : IntPtr with get
Property Value
IntPtr


Height Property

Keyoti RapidSpell Desktop .NET API Docs
Height Property
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► ITextBoxMaskBox ► Height
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
int Height { get; set; }
int Height { get; set; }
Property Height As Integer
    Get
    Set
Property Height As Integer
    Get
    Set
property int Height {
    int get ();
    void set (int value);
}
property int Height {
    int get ();
    void set (int value);
}
abstract Height : int with get, set

abstract Height : int with get, set
Property Value
Int32


IsDisposed Property

Keyoti RapidSpell Desktop .NET API Docs
IsDisposed Property
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► ITextBoxMaskBox ► IsDisposed
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool IsDisposed { get; }
bool IsDisposed { get; }
ReadOnly Property IsDisposed As Boolean
    Get
ReadOnly Property IsDisposed As Boolean
    Get
property bool IsDisposed {
    bool get ();
}
property bool IsDisposed {
    bool get ();
}
abstract IsDisposed : bool with get

abstract IsDisposed : bool with get
Property Value
Boolean


IsHandleCreated Property

Keyoti RapidSpell Desktop .NET API Docs
IsHandleCreated Property
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► ITextBoxMaskBox ► IsHandleCreated
Keyoti RapidSpell Desktop .NET
Same as Control.IsHandleCreated
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool IsHandleCreated { get; }
bool IsHandleCreated { get; }
ReadOnly Property IsHandleCreated As Boolean
    Get
ReadOnly Property IsHandleCreated As Boolean
    Get
property bool IsHandleCreated {
    bool get ();
}
property bool IsHandleCreated {
    bool get ();
}
abstract IsHandleCreated : bool with get

abstract IsHandleCreated : bool with get
Property Value
Boolean


KeyDown Event

Keyoti RapidSpell Desktop .NET API Docs
KeyDown Event
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► ITextBoxMaskBox ► KeyDown
Keyoti RapidSpell Desktop .NET
Occurs when a key is pressed while the control has focus.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event KeyEventHandler KeyDown
event KeyEventHandler KeyDown
Event KeyDown As KeyEventHandler
Event KeyDown As KeyEventHandler
 event KeyEventHandler^ KeyDown {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}
 event KeyEventHandler^ KeyDown {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}
abstract KeyDown : IEvent<KeyEventHandler,
    KeyEventArgs>

abstract KeyDown : IEvent<KeyEventHandler,
    KeyEventArgs>
Value
KeyEventHandler


KeyUp Event

Keyoti RapidSpell Desktop .NET API Docs
KeyUp Event
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► ITextBoxMaskBox ► KeyUp
Keyoti RapidSpell Desktop .NET
Occurs when a key is released while the control has focus.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event KeyEventHandler KeyUp
event KeyEventHandler KeyUp
Event KeyUp As KeyEventHandler
Event KeyUp As KeyEventHandler
 event KeyEventHandler^ KeyUp {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}
 event KeyEventHandler^ KeyUp {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}
abstract KeyUp : IEvent<KeyEventHandler,
    KeyEventArgs>

abstract KeyUp : IEvent<KeyEventHandler,
    KeyEventArgs>
Value
KeyEventHandler


Leave Event

Keyoti RapidSpell Desktop .NET API Docs
Leave Event
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► ITextBoxMaskBox ► Leave
Keyoti RapidSpell Desktop .NET
Occurs when the control loses focus.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event EventHandler Leave
event EventHandler Leave
Event Leave As EventHandler
Event Leave As EventHandler
 event EventHandler^ Leave {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
 event EventHandler^ Leave {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Leave : IEvent<EventHandler,
    EventArgs>

abstract Leave : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


MaskBoxSelectedText Property

Keyoti RapidSpell Desktop .NET API Docs
MaskBoxSelectedText Property
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► ITextBoxMaskBox ► MaskBoxSelectedText
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string MaskBoxSelectedText { get; set; }
string MaskBoxSelectedText { get; set; }
Property MaskBoxSelectedText As String
    Get
    Set
Property MaskBoxSelectedText As String
    Get
    Set
property String^ MaskBoxSelectedText {
    String^ get ();
    void set (String^ value);
}
property String^ MaskBoxSelectedText {
    String^ get ();
    void set (String^ value);
}
abstract MaskBoxSelectedText : string with get, set

abstract MaskBoxSelectedText : string with get, set
Property Value
String


MaskBoxSelectionLength Property

Keyoti RapidSpell Desktop .NET API Docs
MaskBoxSelectionLength Property
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► ITextBoxMaskBox ► MaskBoxSelectionLength
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
int MaskBoxSelectionLength { get; set; }
int MaskBoxSelectionLength { get; set; }
Property MaskBoxSelectionLength As Integer
    Get
    Set
Property MaskBoxSelectionLength As Integer
    Get
    Set
property int MaskBoxSelectionLength {
    int get ();
    void set (int value);
}
property int MaskBoxSelectionLength {
    int get ();
    void set (int value);
}
abstract MaskBoxSelectionLength : int with get, set

abstract MaskBoxSelectionLength : int with get, set
Property Value
Int32


MaskBoxSelectionStart Property

Keyoti RapidSpell Desktop .NET API Docs
MaskBoxSelectionStart Property
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► ITextBoxMaskBox ► MaskBoxSelectionStart
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
int MaskBoxSelectionStart { get; set; }
int MaskBoxSelectionStart { get; set; }
Property MaskBoxSelectionStart As Integer
    Get
    Set
Property MaskBoxSelectionStart As Integer
    Get
    Set
property int MaskBoxSelectionStart {
    int get ();
    void set (int value);
}
property int MaskBoxSelectionStart {
    int get ();
    void set (int value);
}
abstract MaskBoxSelectionStart : int with get, set

abstract MaskBoxSelectionStart : int with get, set
Property Value
Int32


MaskBoxText Property

Keyoti RapidSpell Desktop .NET API Docs
MaskBoxText Property
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► ITextBoxMaskBox ► MaskBoxText
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string MaskBoxText { get; }
string MaskBoxText { get; }
ReadOnly Property MaskBoxText As String
    Get
ReadOnly Property MaskBoxText As String
    Get
property String^ MaskBoxText {
    String^ get ();
}
property String^ MaskBoxText {
    String^ get ();
}
abstract MaskBoxText : string with get

abstract MaskBoxText : string with get
Property Value
String


MouseDown Event

Keyoti RapidSpell Desktop .NET API Docs
MouseDown Event
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► ITextBoxMaskBox ► MouseDown
Keyoti RapidSpell Desktop .NET
Occurs when the mouse pointer is over the control and a mouse button is pressed.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event MouseEventHandler MouseDown
event MouseEventHandler MouseDown
Event MouseDown As MouseEventHandler
Event MouseDown As MouseEventHandler
 event MouseEventHandler^ MouseDown {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}
 event MouseEventHandler^ MouseDown {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}
abstract MouseDown : IEvent<MouseEventHandler,
    MouseEventArgs>

abstract MouseDown : IEvent<MouseEventHandler,
    MouseEventArgs>
Value
MouseEventHandler


MouseUp Event

Keyoti RapidSpell Desktop .NET API Docs
MouseUp Event
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► ITextBoxMaskBox ► MouseUp
Keyoti RapidSpell Desktop .NET
Occurs when the mouse is released on the text box.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event MouseEventHandler MouseUp
event MouseEventHandler MouseUp
Event MouseUp As MouseEventHandler
Event MouseUp As MouseEventHandler
 event MouseEventHandler^ MouseUp {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}
 event MouseEventHandler^ MouseUp {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}
abstract MouseUp : IEvent<MouseEventHandler,
    MouseEventArgs>

abstract MouseUp : IEvent<MouseEventHandler,
    MouseEventArgs>
Value
MouseEventHandler


MouseWheel Event

Keyoti RapidSpell Desktop .NET API Docs
MouseWheel Event
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► ITextBoxMaskBox ► MouseWheel
Keyoti RapidSpell Desktop .NET
Occurs when the mouse wheel is used to scroll.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event MouseEventHandler MouseWheel
event MouseEventHandler MouseWheel
Event MouseWheel As MouseEventHandler
Event MouseWheel As MouseEventHandler
 event MouseEventHandler^ MouseWheel {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}
 event MouseEventHandler^ MouseWheel {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}
abstract MouseWheel : IEvent<MouseEventHandler,
    MouseEventArgs>

abstract MouseWheel : IEvent<MouseEventHandler,
    MouseEventArgs>
Value
MouseEventHandler


Paste Method

Keyoti RapidSpell Desktop .NET API Docs
Paste Method
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► ITextBoxMaskBox ► Paste()()()()
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void Paste()
void Paste()
Sub Paste
Sub Paste
void Paste()
void Paste()
abstract Paste : unit -> unit

abstract Paste : unit -> unit


Refresh Method

Keyoti RapidSpell Desktop .NET API Docs
Refresh Method
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► ITextBoxMaskBox ► Refresh()()()()
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void Refresh()
void Refresh()
Sub Refresh
Sub Refresh
void Refresh()
void Refresh()
abstract Refresh : unit -> unit

abstract Refresh : unit -> unit


Resize Event

Keyoti RapidSpell Desktop .NET API Docs
Resize Event
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► ITextBoxMaskBox ► Resize
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event EventHandler Resize
event EventHandler Resize
Event Resize As EventHandler
Event Resize As EventHandler
 event EventHandler^ Resize {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
 event EventHandler^ Resize {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Resize : IEvent<EventHandler,
    EventArgs>

abstract Resize : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


SelectAll Method

Keyoti RapidSpell Desktop .NET API Docs
SelectAll Method
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► ITextBoxMaskBox ► SelectAll()()()()
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void SelectAll()
void SelectAll()
Sub SelectAll
Sub SelectAll
void SelectAll()
void SelectAll()
abstract SelectAll : unit -> unit

abstract SelectAll : unit -> unit


SelectedText Property

Keyoti RapidSpell Desktop .NET API Docs
SelectedText Property
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► ITextBoxMaskBox ► SelectedText
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string SelectedText { get; set; }
string SelectedText { get; set; }
Property SelectedText As String
    Get
    Set
Property SelectedText As String
    Get
    Set
property String^ SelectedText {
    String^ get ();
    void set (String^ value);
}
property String^ SelectedText {
    String^ get ();
    void set (String^ value);
}
abstract SelectedText : string with get, set

abstract SelectedText : string with get, set
Property Value
String


SelectionLength Property

Keyoti RapidSpell Desktop .NET API Docs
SelectionLength Property
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► ITextBoxMaskBox ► SelectionLength
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
int SelectionLength { get; set; }
int SelectionLength { get; set; }
Property SelectionLength As Integer
    Get
    Set
Property SelectionLength As Integer
    Get
    Set
property int SelectionLength {
    int get ();
    void set (int value);
}
property int SelectionLength {
    int get ();
    void set (int value);
}
abstract SelectionLength : int with get, set

abstract SelectionLength : int with get, set
Property Value
Int32


SelectionStart Property

Keyoti RapidSpell Desktop .NET API Docs
SelectionStart Property
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► ITextBoxMaskBox ► SelectionStart
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
int SelectionStart { get; set; }
int SelectionStart { get; set; }
Property SelectionStart As Integer
    Get
    Set
Property SelectionStart As Integer
    Get
    Set
property int SelectionStart {
    int get ();
    void set (int value);
}
property int SelectionStart {
    int get ();
    void set (int value);
}
abstract SelectionStart : int with get, set

abstract SelectionStart : int with get, set
Property Value
Int32


SuspendLayout Method

Keyoti RapidSpell Desktop .NET API Docs
SuspendLayout Method
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► ITextBoxMaskBox ► SuspendLayout()()()()
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void SuspendLayout()
void SuspendLayout()
Sub SuspendLayout
Sub SuspendLayout
void SuspendLayout()
void SuspendLayout()
abstract SuspendLayout : unit -> unit

abstract SuspendLayout : unit -> unit


Text Property

Keyoti RapidSpell Desktop .NET API Docs
Text Property
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► ITextBoxMaskBox ► Text
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string Text { get; set; }
string Text { get; set; }
Property Text As String
    Get
    Set
Property Text As String
    Get
    Set
property String^ Text {
    String^ get ();
    void set (String^ value);
}
property String^ Text {
    String^ get ();
    void set (String^ value);
}
abstract Text : string with get, set

abstract Text : string with get, set
Property Value
String


TextChanged Event

Keyoti RapidSpell Desktop .NET API Docs
TextChanged Event
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► ITextBoxMaskBox ► TextChanged
Keyoti RapidSpell Desktop .NET
Occurs when the Text property value changes.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event EventHandler TextChanged
event EventHandler TextChanged
Event TextChanged As EventHandler
Event TextChanged As EventHandler
 event EventHandler^ TextChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
 event EventHandler^ TextChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract TextChanged : IEvent<EventHandler,
    EventArgs>

abstract TextChanged : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


TextLength Property

Keyoti RapidSpell Desktop .NET API Docs
TextLength Property
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► ITextBoxMaskBox ► TextLength
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
int TextLength { get; }
int TextLength { get; }
ReadOnly Property TextLength As Integer
    Get
ReadOnly Property TextLength As Integer
    Get
property int TextLength {
    int get ();
}
property int TextLength {
    int get ();
}
abstract TextLength : int with get

abstract TextLength : int with get
Property Value
Int32


Undo Method

Keyoti RapidSpell Desktop .NET API Docs
Undo Method
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► ITextBoxMaskBox ► Undo()()()()
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void Undo()
void Undo()
Sub Undo
Sub Undo
void Undo()
void Undo()
abstract Undo : unit -> unit

abstract Undo : unit -> unit


Width Property

Keyoti RapidSpell Desktop .NET API Docs
Width Property
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► ITextBoxMaskBox ► Width
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
int Width { get; set; }
int Width { get; set; }
Property Width As Integer
    Get
    Set
Property Width As Integer
    Get
    Set
property int Width {
    int get ();
    void set (int value);
}
property int Width {
    int get ();
    void set (int value);
}
abstract Width : int with get, set

abstract Width : int with get, set
Property Value
Int32


IThirdPartyTextBoxConnector Interface

Keyoti RapidSpell Desktop .NET API Docs
IThirdPartyTextBoxConnector Interface
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► IThirdPartyTextBoxConnector
Keyoti RapidSpell Desktop .NET
Internally used proxy interface.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public interface IThirdPartyTextBoxConnector
public interface IThirdPartyTextBoxConnector
Public Interface IThirdPartyTextBoxConnector
Public Interface IThirdPartyTextBoxConnector
public interface class IThirdPartyTextBoxConnector
public interface class IThirdPartyTextBoxConnector
type IThirdPartyTextBoxConnector =  interface end
type IThirdPartyTextBoxConnector =  interface end
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | WndProc(Message%) | Internal


WndProc Method (m)

Keyoti RapidSpell Desktop .NET API Docs
WndProc Method (m)
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► IThirdPartyTextBoxConnector ► WndProc(Message%)
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool WndProc(
    ref Message m
)
bool WndProc(
    ref Message m
)
Function WndProc (
    ByRef m As Message
) As Boolean
Function WndProc (
    ByRef m As Message
) As Boolean
bool WndProc(
    Message% m
)
bool WndProc(
    Message% m
)
abstract WndProc :
        m : Message byref -> bool

abstract WndProc :
        m : Message byref -> bool
Parameters
m (Message %)
Return Value
Boolean


TextBoxConnector Class

Keyoti RapidSpell Desktop .NET API Docs
TextBoxConnector Class
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector
Keyoti RapidSpell Desktop .NET
As-You-Type enabled TextBox.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class TextBoxConnector : IAYTTextBox,
    IThirdPartyTextBoxConnector
public class TextBoxConnector : IAYTTextBox,
    IThirdPartyTextBoxConnector
Public Class TextBoxConnector
    Implements IAYTTextBox, IThirdPartyTextBoxConnector
Public Class TextBoxConnector
    Implements IAYTTextBox, IThirdPartyTextBoxConnector
public ref class TextBoxConnector : IAYTTextBox,
    IThirdPartyTextBoxConnector
public ref class TextBoxConnector : IAYTTextBox,
    IThirdPartyTextBoxConnector
type TextBoxConnector =
    class
        interface IAYTTextBox
        interface IThirdPartyTextBoxConnector
    end
type TextBoxConnector =
    class
        interface IAYTTextBox
        interface IThirdPartyTextBoxConnector
    end
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TextBoxConnector()()()() | Internal
 | BeginInvoke(Delegate) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
 | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
 | ClientSize | Gets or sets the height and width of the client area of the control.
 | ContextMenu | Gets or sets the shortcut menu associated with the control
 | ContextMenuDefault | The context menu that will be shown when the right click is not on a misspelled word.
 | ContextMenuStrip | The context menu that will be shown when the right click is not on a misspelled word.
 | ContextMenuStripDefault | The context menu that will be shown when the right click is not on a misspelled word.
 | ControlBackgroundPaint | Event fired when Windows level background repaint occurs.
 | ControlPaint | Event fired when Windows level repaint occurs.
 | DefaultContextMenu | Obsolete. Internal
 | Disposed | Event fires when component is Disposed.
 | Disposing | Is disposing
 | Enabled | Internal
 | Enter | Occurs when the control receives focus.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FindForm()()()() | Internal
 | Font | Gets or sets the font of the text displayed by the control.
 | FontChanged | Internal
 | FormatChanged | Event fired when formatting changes (such as font change).
 | GetBaselineOffsetAtCharIndex(Int32) | Gets the baseline offset for a character at index i
 | GetCharIndexFromPos(Point) | gets the char index from a position point.
 | GetFirstVisibleCharIndex()()()() | Gets the character index of the first visible character in the window, this is for optimization and can just return 0 if unavailable.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLineFromCharIndex(Int32) | Gets the line number that char index is on
 | GetPosFromCharIndex(Int32) | Gets the position point from the char index
 | GetTBU()()()() | Interface requirement
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | Handle | Gets the window handle that the control is bound to.
 | Height | Gets or sets the height of the control.
 | HScrolled | Event fired when horizontal scroll changed (by anything).
 | IsDisposed | Gets a value indicating whether the control has been disposed of.
 | IsHandleCreated | Same as Control.IsHandleCreated
 | KeyDown | Occurs when a key is pressed while the control has focus.
 | KeyPress | Occurs when a key is pressed while the control has focus.
 | KeyUp | Occurs when a key is released while the control has focus.
 | Leave | Occurs when the control loses focus.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed.
 | MouseUp | Occurs when the mouse is released on the text box.
 | MouseWheel | Occurs when the mouse wheel is used to scroll.
 | Parent | Parent
 | ReadOnly | Internal
 | RecreatingHandle | Is recreating handle
 | Refresh()()()() | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
 | Resize | Occurs when the control is resized.
 | ScrollCaret | Occurs when the text box is scrolled to the caret.
 | SelectedText | This member overrides TextBox.SelectedText.
 | SelectionChanged | Occurs when the selection of text within the control has changed.
 | SelectionLength | This member overrides TextBox.SelectionLength.
 | SelectionStart | Gets or sets the starting point of text selected in the text box.
 | ShowCutCopyPasteContextMenu | Whether to show the standard Undo/Cut/Copy/Paste/Delete/Select All context menu.
 | SuspendLayout()()()() | Internal
 | Text | This member overrides TextBox.Text.
 | TextChanged | Occurs when the Text property value changes.
 | TextLength | Gets the current text length in the text box.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | UnderlineYOffset | Controls the position of the underline relative to the baseline.
 | VScrolled | Event fired when vertical scroll changed (by anything).
 | VScrollEnd | Event fired when vertical scroll ends.
 | Width | Gets or sets the width of the control.
 | WndProc(Message%) | Handles WndProc events and dispatches new events.
 | WrappedTextBox | Internal
Inheritance Hierarchy
Object
TextBoxConnector


TextBoxConnector Constructor

Keyoti RapidSpell Desktop .NET API Docs
TextBoxConnector Constructor
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► TextBoxConnector()()()()
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public TextBoxConnector()
public TextBoxConnector()
Public Sub New
Public Sub New
public:
TextBoxConnector()
public:
TextBoxConnector()
new : unit -> TextBoxConnector
new : unit -> TextBoxConnector


BeginInvoke Method

Keyoti RapidSpell Desktop .NET API Docs
BeginInvoke Method
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► BeginInvoke()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | BeginInvoke(Delegate) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
 | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.


BeginInvoke Method (d)

Keyoti RapidSpell Desktop .NET API Docs
BeginInvoke Method (d)
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► BeginInvoke(Delegate)
Keyoti RapidSpell Desktop .NET
Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public IAsyncResult BeginInvoke(
    Delegate d
)
public IAsyncResult BeginInvoke(
    Delegate d
)
Public Function BeginInvoke (
    d As Delegate
) As IAsyncResult
Public Function BeginInvoke (
    d As Delegate
) As IAsyncResult
public:
virtual IAsyncResult^ BeginInvoke(
    Delegate^ d
) sealed
public:
virtual IAsyncResult^ BeginInvoke(
    Delegate^ d
) sealed
abstract BeginInvoke :
        d : Delegate -> IAsyncResult
override BeginInvoke :
        d : Delegate -> IAsyncResult
abstract BeginInvoke :
        d : Delegate -> IAsyncResult
override BeginInvoke :
        d : Delegate -> IAsyncResult
Parameters
d (Delegate)
Return Value
IAsyncResult


BeginInvoke Method (d, parameters)

Keyoti RapidSpell Desktop .NET API Docs
BeginInvoke Method (d, parameters)
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► BeginInvoke(Delegate, array<Object>[]()[][])
Keyoti RapidSpell Desktop .NET
Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public IAsyncResult BeginInvoke(
    Delegate d,
    Object[] parameters
)
public IAsyncResult BeginInvoke(
    Delegate d,
    Object[] parameters
)
Public Function BeginInvoke (
    d As Delegate,
    parameters As Object()
) As IAsyncResult
Public Function BeginInvoke (
    d As Delegate,
    parameters As Object()
) As IAsyncResult
public:
virtual IAsyncResult^ BeginInvoke(
    Delegate^ d,
    array<Object^>^ parameters
) sealed
public:
virtual IAsyncResult^ BeginInvoke(
    Delegate^ d,
    array<Object^>^ parameters
) sealed
abstract BeginInvoke :
        d : Delegate *
        parameters : Object[] -> IAsyncResult
override BeginInvoke :
        d : Delegate *
        parameters : Object[] -> IAsyncResult
abstract BeginInvoke :
        d : Delegate *
        parameters : Object[] -> IAsyncResult
override BeginInvoke :
        d : Delegate *
        parameters : Object[] -> IAsyncResult
Parameters
d (Delegate)
parameters (array< Object >[]()[][])
Return Value
IAsyncResult


ClientSize Property

Keyoti RapidSpell Desktop .NET API Docs
ClientSize Property
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► ClientSize
Keyoti RapidSpell Desktop .NET
Gets or sets the height and width of the client area of the control.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Size ClientSize { get; set; }
public Size ClientSize { get; set; }
Public Property ClientSize As Size
    Get
    Set
Public Property ClientSize As Size
    Get
    Set
public:
virtual property Size ClientSize {
    Size get () sealed;
    void set (Size value) sealed;
}
public:
virtual property Size ClientSize {
    Size get () sealed;
    void set (Size value) sealed;
}
abstract ClientSize : Size with get, set
override ClientSize : Size with get, set
abstract ClientSize : Size with get, set
override ClientSize : Size with get, set
Property Value
Size


ContextMenu Property

Keyoti RapidSpell Desktop .NET API Docs
ContextMenu Property
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► ContextMenu
Keyoti RapidSpell Desktop .NET
Gets or sets the shortcut menu associated with the control
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ContextMenu ContextMenu { get; set; }
public ContextMenu ContextMenu { get; set; }
Public Property ContextMenu As ContextMenu
    Get
    Set
Public Property ContextMenu As ContextMenu
    Get
    Set
public:
virtual property ContextMenu^ ContextMenu {
    ContextMenu^ get () sealed;
    void set (ContextMenu^ value) sealed;
}
public:
virtual property ContextMenu^ ContextMenu {
    ContextMenu^ get () sealed;
    void set (ContextMenu^ value) sealed;
}
abstract ContextMenu : ContextMenu with get, set
override ContextMenu : ContextMenu with get, set
abstract ContextMenu : ContextMenu with get, set
override ContextMenu : ContextMenu with get, set
Property Value
ContextMenu


ContextMenuDefault Property

Keyoti RapidSpell Desktop .NET API Docs
ContextMenuDefault Property
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► ContextMenuDefault
Keyoti RapidSpell Desktop .NET
The context menu that will be shown when the right click is not on a misspelled word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual ContextMenu ContextMenuDefault { get; set; }
public virtual ContextMenu ContextMenuDefault { get; set; }
Public Overridable Property ContextMenuDefault As ContextMenu
    Get
    Set
Public Overridable Property ContextMenuDefault As ContextMenu
    Get
    Set
public:
virtual property ContextMenu^ ContextMenuDefault {
    ContextMenu^ get ();
    void set (ContextMenu^ value);
}
public:
virtual property ContextMenu^ ContextMenuDefault {
    ContextMenu^ get ();
    void set (ContextMenu^ value);
}
abstract ContextMenuDefault : ContextMenu with get, set
override ContextMenuDefault : ContextMenu with get, set
abstract ContextMenuDefault : ContextMenu with get, set
override ContextMenuDefault : ContextMenu with get, set
Property Value
ContextMenu


ContextMenuStrip Property

Keyoti RapidSpell Desktop .NET API Docs
ContextMenuStrip Property
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► ContextMenuStrip
Keyoti RapidSpell Desktop .NET
The context menu that will be shown when the right click is not on a misspelled word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ContextMenuStrip ContextMenuStrip { get; set; }
public ContextMenuStrip ContextMenuStrip { get; set; }
Public Property ContextMenuStrip As ContextMenuStrip
    Get
    Set
Public Property ContextMenuStrip As ContextMenuStrip
    Get
    Set
public:
virtual property ContextMenuStrip^ ContextMenuStrip {
    ContextMenuStrip^ get () sealed;
    void set (ContextMenuStrip^ value) sealed;
}
public:
virtual property ContextMenuStrip^ ContextMenuStrip {
    ContextMenuStrip^ get () sealed;
    void set (ContextMenuStrip^ value) sealed;
}
abstract ContextMenuStrip : ContextMenuStrip with get, set
override ContextMenuStrip : ContextMenuStrip with get, set
abstract ContextMenuStrip : ContextMenuStrip with get, set
override ContextMenuStrip : ContextMenuStrip with get, set
Property Value
ContextMenuStrip


ContextMenuStripDefault Property

Keyoti RapidSpell Desktop .NET API Docs
ContextMenuStripDefault Property
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► ContextMenuStripDefault
Keyoti RapidSpell Desktop .NET
The context menu that will be shown when the right click is not on a misspelled word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ContextMenuStrip ContextMenuStripDefault { get; set; }
public ContextMenuStrip ContextMenuStripDefault { get; set; }
Public Property ContextMenuStripDefault As ContextMenuStrip
    Get
    Set
Public Property ContextMenuStripDefault As ContextMenuStrip
    Get
    Set
public:
virtual property ContextMenuStrip^ ContextMenuStripDefault {
    ContextMenuStrip^ get () sealed;
    void set (ContextMenuStrip^ value) sealed;
}
public:
virtual property ContextMenuStrip^ ContextMenuStripDefault {
    ContextMenuStrip^ get () sealed;
    void set (ContextMenuStrip^ value) sealed;
}
abstract ContextMenuStripDefault : ContextMenuStrip with get, set
override ContextMenuStripDefault : ContextMenuStrip with get, set
abstract ContextMenuStripDefault : ContextMenuStrip with get, set
override ContextMenuStripDefault : ContextMenuStrip with get, set
Property Value
ContextMenuStrip
Remarks
This is the context menu originally set in the ContextMenuStrip property.


ControlBackgroundPaint Event

Keyoti RapidSpell Desktop .NET API Docs
ControlBackgroundPaint Event
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► ControlBackgroundPaint
Keyoti RapidSpell Desktop .NET
Event fired when Windows level background repaint occurs.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler ControlBackgroundPaint
public event EventHandler ControlBackgroundPaint
Public Event ControlBackgroundPaint As EventHandler
Public Event ControlBackgroundPaint As EventHandler
public:
 event EventHandler^ ControlBackgroundPaint {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
 event EventHandler^ ControlBackgroundPaint {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member ControlBackgroundPaint : IEvent<EventHandler,
    EventArgs>

member ControlBackgroundPaint : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


ControlPaint Event

Keyoti RapidSpell Desktop .NET API Docs
ControlPaint Event
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► ControlPaint
Keyoti RapidSpell Desktop .NET
Event fired when Windows level repaint occurs.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler ControlPaint
public event EventHandler ControlPaint
Public Event ControlPaint As EventHandler
Public Event ControlPaint As EventHandler
public:
virtual  event EventHandler^ ControlPaint {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ ControlPaint {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ControlPaint : IEvent<EventHandler,
    EventArgs>
override ControlPaint : IEvent<EventHandler,
    EventArgs>
abstract ControlPaint : IEvent<EventHandler,
    EventArgs>
override ControlPaint : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


DefaultContextMenu Property

Keyoti RapidSpell Desktop .NET API Docs
DefaultContextMenu Property
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► DefaultContextMenu
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
[ObsoleteAttribute("Use ContextMenuDefault instead.")]
public virtual ContextMenu DefaultContextMenu { get; set; }
[ObsoleteAttribute("Use ContextMenuDefault instead.")]
public virtual ContextMenu DefaultContextMenu { get; set; }
<ObsoleteAttribute("Use ContextMenuDefault instead.")>
Public Overridable Property DefaultContextMenu As ContextMenu
    Get
    Set
<ObsoleteAttribute("Use ContextMenuDefault instead.")>
Public Overridable Property DefaultContextMenu As ContextMenu
    Get
    Set
public:
[ObsoleteAttribute(L"Use ContextMenuDefault instead.")]
virtual property ContextMenu^ DefaultContextMenu {
    ContextMenu^ get ();
    void set (ContextMenu^ value);
}
public:
[ObsoleteAttribute(L"Use ContextMenuDefault instead.")]
virtual property ContextMenu^ DefaultContextMenu {
    ContextMenu^ get ();
    void set (ContextMenu^ value);
}
[<ObsoleteAttribute("Use ContextMenuDefault instead.")>]
abstract DefaultContextMenu : ContextMenu with get, set
[<ObsoleteAttribute("Use ContextMenuDefault instead.")>]
override DefaultContextMenu : ContextMenu with get, set
[<ObsoleteAttribute("Use ContextMenuDefault instead.")>]
abstract DefaultContextMenu : ContextMenu with get, set
[<ObsoleteAttribute("Use ContextMenuDefault instead.")>]
override DefaultContextMenu : ContextMenu with get, set
Property Value
ContextMenu


Disposed Event

Keyoti RapidSpell Desktop .NET API Docs
Disposed Event
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► Disposed
Keyoti RapidSpell Desktop .NET
Event fires when component is Disposed.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler Disposed
public event EventHandler Disposed
Public Event Disposed As EventHandler
Public Event Disposed As EventHandler
public:
virtual  event EventHandler^ Disposed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ Disposed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Disposed : IEvent<EventHandler,
    EventArgs>
override Disposed : IEvent<EventHandler,
    EventArgs>
abstract Disposed : IEvent<EventHandler,
    EventArgs>
override Disposed : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


Disposing Property

Keyoti RapidSpell Desktop .NET API Docs
Disposing Property
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► Disposing
Keyoti RapidSpell Desktop .NET
Is disposing
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool Disposing { get; }
public bool Disposing { get; }
Public ReadOnly Property Disposing As Boolean
    Get
Public ReadOnly Property Disposing As Boolean
    Get
public:
virtual property bool Disposing {
    bool get () sealed;
}
public:
virtual property bool Disposing {
    bool get () sealed;
}
abstract Disposing : bool with get
override Disposing : bool with get
abstract Disposing : bool with get
override Disposing : bool with get
Property Value
Boolean


Enabled Property

Keyoti RapidSpell Desktop .NET API Docs
Enabled Property
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► Enabled
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool Enabled { get; }
public bool Enabled { get; }
Public ReadOnly Property Enabled As Boolean
    Get
Public ReadOnly Property Enabled As Boolean
    Get
public:
virtual property bool Enabled {
    bool get () sealed;
}
public:
virtual property bool Enabled {
    bool get () sealed;
}
abstract Enabled : bool with get
override Enabled : bool with get
abstract Enabled : bool with get
override Enabled : bool with get
Property Value
Boolean


Enter Event

Keyoti RapidSpell Desktop .NET API Docs
Enter Event
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► Enter
Keyoti RapidSpell Desktop .NET
Occurs when the control receives focus.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler Enter
public event EventHandler Enter
Public Event Enter As EventHandler
Public Event Enter As EventHandler
public:
virtual  event EventHandler^ Enter {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ Enter {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Enter : IEvent<EventHandler,
    EventArgs>
override Enter : IEvent<EventHandler,
    EventArgs>
abstract Enter : IEvent<EventHandler,
    EventArgs>
override Enter : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


FindForm Method

Keyoti RapidSpell Desktop .NET API Docs
FindForm Method
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► FindForm()()()()
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Form FindForm()
public Form FindForm()
Public Function FindForm As Form
Public Function FindForm As Form
public:
Form^ FindForm()
public:
Form^ FindForm()
member FindForm : unit -> Form

member FindForm : unit -> Form
Return Value
Form


Font Property

Keyoti RapidSpell Desktop .NET API Docs
Font Property
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► Font
Keyoti RapidSpell Desktop .NET
Gets or sets the font of the text displayed by the control.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Font Font { get; set; }
public Font Font { get; set; }
Public Property Font As Font
    Get
    Set
Public Property Font As Font
    Get
    Set
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
member Font : Font with get, set

member Font : Font with get, set
Property Value
Font


FontChanged Event

Keyoti RapidSpell Desktop .NET API Docs
FontChanged Event
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► FontChanged
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler FontChanged
public event EventHandler FontChanged
Public Event FontChanged As EventHandler
Public Event FontChanged As EventHandler
public:
 event EventHandler^ FontChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
 event EventHandler^ FontChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member FontChanged : IEvent<EventHandler,
    EventArgs>

member FontChanged : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


FormatChanged Event

Keyoti RapidSpell Desktop .NET API Docs
FormatChanged Event
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► FormatChanged
Keyoti RapidSpell Desktop .NET
Event fired when formatting changes (such as font change).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler FormatChanged
public event EventHandler FormatChanged
Public Event FormatChanged As EventHandler
Public Event FormatChanged As EventHandler
public:
virtual  event EventHandler^ FormatChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ FormatChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract FormatChanged : IEvent<EventHandler,
    EventArgs>
override FormatChanged : IEvent<EventHandler,
    EventArgs>
abstract FormatChanged : IEvent<EventHandler,
    EventArgs>
override FormatChanged : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


GetBaselineOffsetAtCharIndex Method (i)

Keyoti RapidSpell Desktop .NET API Docs
GetBaselineOffsetAtCharIndex Method (i)
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► GetBaselineOffsetAtCharIndex(Int32)
Keyoti RapidSpell Desktop .NET
Gets the baseline offset for a character at index i
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int GetBaselineOffsetAtCharIndex(
    int i
)
public int GetBaselineOffsetAtCharIndex(
    int i
)
Public Function GetBaselineOffsetAtCharIndex (
    i As Integer
) As Integer
Public Function GetBaselineOffsetAtCharIndex (
    i As Integer
) As Integer
public:
virtual int GetBaselineOffsetAtCharIndex(
    int i
) sealed
public:
virtual int GetBaselineOffsetAtCharIndex(
    int i
) sealed
abstract GetBaselineOffsetAtCharIndex :
        i : int -> int
override GetBaselineOffsetAtCharIndex :
        i : int -> int
abstract GetBaselineOffsetAtCharIndex :
        i : int -> int
override GetBaselineOffsetAtCharIndex :
        i : int -> int
Parameters
i (Int32)
Return Value
Int32


GetCharIndexFromPos Method (pos)

Keyoti RapidSpell Desktop .NET API Docs
GetCharIndexFromPos Method (pos)
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► GetCharIndexFromPos(Point)
Keyoti RapidSpell Desktop .NET
gets the char index from a position point.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int GetCharIndexFromPos(
    Point pos
)
public int GetCharIndexFromPos(
    Point pos
)
Public Function GetCharIndexFromPos (
    pos As Point
) As Integer
Public Function GetCharIndexFromPos (
    pos As Point
) As Integer
public:
virtual int GetCharIndexFromPos(
    Point pos
) sealed
public:
virtual int GetCharIndexFromPos(
    Point pos
) sealed
abstract GetCharIndexFromPos :
        pos : Point -> int
override GetCharIndexFromPos :
        pos : Point -> int
abstract GetCharIndexFromPos :
        pos : Point -> int
override GetCharIndexFromPos :
        pos : Point -> int
Parameters
pos (Point)
Return Value
Int32


GetFirstVisibleCharIndex Method

Keyoti RapidSpell Desktop .NET API Docs
GetFirstVisibleCharIndex Method
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► GetFirstVisibleCharIndex()()()()
Keyoti RapidSpell Desktop .NET
Gets the character index of the first visible character in the window, this is for optimization and can just return 0 if unavailable.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int GetFirstVisibleCharIndex()
public int GetFirstVisibleCharIndex()
Public Function GetFirstVisibleCharIndex As Integer
Public Function GetFirstVisibleCharIndex As Integer
public:
virtual int GetFirstVisibleCharIndex() sealed
public:
virtual int GetFirstVisibleCharIndex() sealed
abstract GetFirstVisibleCharIndex : unit -> int
override GetFirstVisibleCharIndex : unit -> int
abstract GetFirstVisibleCharIndex : unit -> int
override GetFirstVisibleCharIndex : unit -> int
Return Value
Int32


GetLineFromCharIndex Method (ind)

Keyoti RapidSpell Desktop .NET API Docs
GetLineFromCharIndex Method (ind)
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► GetLineFromCharIndex(Int32)
Keyoti RapidSpell Desktop .NET
Gets the line number that char index is on
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int GetLineFromCharIndex(
    int ind
)
public int GetLineFromCharIndex(
    int ind
)
Public Function GetLineFromCharIndex (
    ind As Integer
) As Integer
Public Function GetLineFromCharIndex (
    ind As Integer
) As Integer
public:
virtual int GetLineFromCharIndex(
    int ind
) sealed
public:
virtual int GetLineFromCharIndex(
    int ind
) sealed
abstract GetLineFromCharIndex :
        ind : int -> int
override GetLineFromCharIndex :
        ind : int -> int
abstract GetLineFromCharIndex :
        ind : int -> int
override GetLineFromCharIndex :
        ind : int -> int
Parameters
ind (Int32)
Return Value
Int32


GetPosFromCharIndex Method (ind)

Keyoti RapidSpell Desktop .NET API Docs
GetPosFromCharIndex Method (ind)
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► GetPosFromCharIndex(Int32)
Keyoti RapidSpell Desktop .NET
Gets the position point from the char index
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Point GetPosFromCharIndex(
    int ind
)
public Point GetPosFromCharIndex(
    int ind
)
Public Function GetPosFromCharIndex (
    ind As Integer
) As Point
Public Function GetPosFromCharIndex (
    ind As Integer
) As Point
public:
virtual Point GetPosFromCharIndex(
    int ind
) sealed
public:
virtual Point GetPosFromCharIndex(
    int ind
) sealed
abstract GetPosFromCharIndex :
        ind : int -> Point
override GetPosFromCharIndex :
        ind : int -> Point
abstract GetPosFromCharIndex :
        ind : int -> Point
override GetPosFromCharIndex :
        ind : int -> Point
Parameters
ind (Int32)
Return Value
Point


GetTBU Method

Keyoti RapidSpell Desktop .NET API Docs
GetTBU Method
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► GetTBU()()()()
Keyoti RapidSpell Desktop .NET
Interface requirement
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public TextBoxUtilityAdapter GetTBU()
public TextBoxUtilityAdapter GetTBU()
Public Function GetTBU As TextBoxUtilityAdapter
Public Function GetTBU As TextBoxUtilityAdapter
public:
virtual TextBoxUtilityAdapter^ GetTBU() sealed
public:
virtual TextBoxUtilityAdapter^ GetTBU() sealed
abstract GetTBU : unit -> TextBoxUtilityAdapter
override GetTBU : unit -> TextBoxUtilityAdapter
abstract GetTBU : unit -> TextBoxUtilityAdapter
override GetTBU : unit -> TextBoxUtilityAdapter
Return Value
TextBoxUtilityAdapter


Handle Property

Keyoti RapidSpell Desktop .NET API Docs
Handle Property
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► Handle
Keyoti RapidSpell Desktop .NET
Gets the window handle that the control is bound to.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public IntPtr Handle { get; }
public IntPtr Handle { get; }
Public ReadOnly Property Handle As IntPtr
    Get
Public ReadOnly Property Handle As IntPtr
    Get
public:
virtual property IntPtr Handle {
    IntPtr get () sealed;
}
public:
virtual property IntPtr Handle {
    IntPtr get () sealed;
}
abstract Handle : IntPtr with get
override Handle : IntPtr with get
abstract Handle : IntPtr with get
override Handle : IntPtr with get
Property Value
IntPtr


Height Property

Keyoti RapidSpell Desktop .NET API Docs
Height Property
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► Height
Keyoti RapidSpell Desktop .NET
Gets or sets the height of the control.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int Height { get; set; }
public int Height { get; set; }
Public Property Height As Integer
    Get
    Set
Public Property Height As Integer
    Get
    Set
public:
virtual property int Height {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int Height {
    int get () sealed;
    void set (int value) sealed;
}
abstract Height : int with get, set
override Height : int with get, set
abstract Height : int with get, set
override Height : int with get, set
Property Value
Int32


HScrolled Event

Keyoti RapidSpell Desktop .NET API Docs
HScrolled Event
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► HScrolled
Keyoti RapidSpell Desktop .NET
Event fired when horizontal scroll changed (by anything).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler HScrolled
public event EventHandler HScrolled
Public Event HScrolled As EventHandler
Public Event HScrolled As EventHandler
public:
virtual  event EventHandler^ HScrolled {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ HScrolled {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract HScrolled : IEvent<EventHandler,
    EventArgs>
override HScrolled : IEvent<EventHandler,
    EventArgs>
abstract HScrolled : IEvent<EventHandler,
    EventArgs>
override HScrolled : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


IsDisposed Property

Keyoti RapidSpell Desktop .NET API Docs
IsDisposed Property
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► IsDisposed
Keyoti RapidSpell Desktop .NET
Gets a value indicating whether the control has been disposed of.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IsDisposed { get; }
public bool IsDisposed { get; }
Public ReadOnly Property IsDisposed As Boolean
    Get
Public ReadOnly Property IsDisposed As Boolean
    Get
public:
virtual property bool IsDisposed {
    bool get () sealed;
}
public:
virtual property bool IsDisposed {
    bool get () sealed;
}
abstract IsDisposed : bool with get
override IsDisposed : bool with get
abstract IsDisposed : bool with get
override IsDisposed : bool with get
Property Value
Boolean


IsHandleCreated Property

Keyoti RapidSpell Desktop .NET API Docs
IsHandleCreated Property
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► IsHandleCreated
Keyoti RapidSpell Desktop .NET
Same as Control.IsHandleCreated
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IsHandleCreated { get; }
public bool IsHandleCreated { get; }
Public ReadOnly Property IsHandleCreated As Boolean
    Get
Public ReadOnly Property IsHandleCreated As Boolean
    Get
public:
virtual property bool IsHandleCreated {
    bool get () sealed;
}
public:
virtual property bool IsHandleCreated {
    bool get () sealed;
}
abstract IsHandleCreated : bool with get
override IsHandleCreated : bool with get
abstract IsHandleCreated : bool with get
override IsHandleCreated : bool with get
Property Value
Boolean


KeyDown Event

Keyoti RapidSpell Desktop .NET API Docs
KeyDown Event
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► KeyDown
Keyoti RapidSpell Desktop .NET
Occurs when a key is pressed while the control has focus.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event KeyEventHandler KeyDown
public event KeyEventHandler KeyDown
Public Event KeyDown As KeyEventHandler
Public Event KeyDown As KeyEventHandler
public:
virtual  event KeyEventHandler^ KeyDown {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}
public:
virtual  event KeyEventHandler^ KeyDown {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}
abstract KeyDown : IEvent<KeyEventHandler,
    KeyEventArgs>
override KeyDown : IEvent<KeyEventHandler,
    KeyEventArgs>
abstract KeyDown : IEvent<KeyEventHandler,
    KeyEventArgs>
override KeyDown : IEvent<KeyEventHandler,
    KeyEventArgs>
Value
KeyEventHandler


KeyPress Event

Keyoti RapidSpell Desktop .NET API Docs
KeyPress Event
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► KeyPress
Keyoti RapidSpell Desktop .NET
Occurs when a key is pressed while the control has focus.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event KeyPressEventHandler KeyPress
public event KeyPressEventHandler KeyPress
Public Event KeyPress As KeyPressEventHandler
Public Event KeyPress As KeyPressEventHandler
public:
virtual  event KeyPressEventHandler^ KeyPress {
    void add (KeyPressEventHandler^ value);
    void remove (KeyPressEventHandler^ value);
}
public:
virtual  event KeyPressEventHandler^ KeyPress {
    void add (KeyPressEventHandler^ value);
    void remove (KeyPressEventHandler^ value);
}
abstract KeyPress : IEvent<KeyPressEventHandler,
    KeyPressEventArgs>
override KeyPress : IEvent<KeyPressEventHandler,
    KeyPressEventArgs>
abstract KeyPress : IEvent<KeyPressEventHandler,
    KeyPressEventArgs>
override KeyPress : IEvent<KeyPressEventHandler,
    KeyPressEventArgs>
Value
KeyPressEventHandler
Remarks
Used by the auto-corrector


KeyUp Event

Keyoti RapidSpell Desktop .NET API Docs
KeyUp Event
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► KeyUp
Keyoti RapidSpell Desktop .NET
Occurs when a key is released while the control has focus.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event KeyEventHandler KeyUp
public event KeyEventHandler KeyUp
Public Event KeyUp As KeyEventHandler
Public Event KeyUp As KeyEventHandler
public:
virtual  event KeyEventHandler^ KeyUp {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}
public:
virtual  event KeyEventHandler^ KeyUp {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}
abstract KeyUp : IEvent<KeyEventHandler,
    KeyEventArgs>
override KeyUp : IEvent<KeyEventHandler,
    KeyEventArgs>
abstract KeyUp : IEvent<KeyEventHandler,
    KeyEventArgs>
override KeyUp : IEvent<KeyEventHandler,
    KeyEventArgs>
Value
KeyEventHandler


Leave Event

Keyoti RapidSpell Desktop .NET API Docs
Leave Event
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► Leave
Keyoti RapidSpell Desktop .NET
Occurs when the control loses focus.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler Leave
public event EventHandler Leave
Public Event Leave As EventHandler
Public Event Leave As EventHandler
public:
virtual  event EventHandler^ Leave {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ Leave {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Leave : IEvent<EventHandler,
    EventArgs>
override Leave : IEvent<EventHandler,
    EventArgs>
abstract Leave : IEvent<EventHandler,
    EventArgs>
override Leave : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


MouseDown Event

Keyoti RapidSpell Desktop .NET API Docs
MouseDown Event
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► MouseDown
Keyoti RapidSpell Desktop .NET
Occurs when the mouse pointer is over the control and a mouse button is pressed.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event MouseEventHandler MouseDown
public event MouseEventHandler MouseDown
Public Event MouseDown As MouseEventHandler
Public Event MouseDown As MouseEventHandler
public:
virtual  event MouseEventHandler^ MouseDown {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}
public:
virtual  event MouseEventHandler^ MouseDown {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}
abstract MouseDown : IEvent<MouseEventHandler,
    MouseEventArgs>
override MouseDown : IEvent<MouseEventHandler,
    MouseEventArgs>
abstract MouseDown : IEvent<MouseEventHandler,
    MouseEventArgs>
override MouseDown : IEvent<MouseEventHandler,
    MouseEventArgs>
Value
MouseEventHandler


MouseUp Event

Keyoti RapidSpell Desktop .NET API Docs
MouseUp Event
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► MouseUp
Keyoti RapidSpell Desktop .NET
Occurs when the mouse is released on the text box.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event MouseEventHandler MouseUp
public event MouseEventHandler MouseUp
Public Event MouseUp As MouseEventHandler
Public Event MouseUp As MouseEventHandler
public:
virtual  event MouseEventHandler^ MouseUp {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}
public:
virtual  event MouseEventHandler^ MouseUp {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}
abstract MouseUp : IEvent<MouseEventHandler,
    MouseEventArgs>
override MouseUp : IEvent<MouseEventHandler,
    MouseEventArgs>
abstract MouseUp : IEvent<MouseEventHandler,
    MouseEventArgs>
override MouseUp : IEvent<MouseEventHandler,
    MouseEventArgs>
Value
MouseEventHandler


MouseWheel Event

Keyoti RapidSpell Desktop .NET API Docs
MouseWheel Event
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► MouseWheel
Keyoti RapidSpell Desktop .NET
Occurs when the mouse wheel is used to scroll.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event MouseEventHandler MouseWheel
public event MouseEventHandler MouseWheel
Public Event MouseWheel As MouseEventHandler
Public Event MouseWheel As MouseEventHandler
public:
virtual  event MouseEventHandler^ MouseWheel {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}
public:
virtual  event MouseEventHandler^ MouseWheel {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}
abstract MouseWheel : IEvent<MouseEventHandler,
    MouseEventArgs>
override MouseWheel : IEvent<MouseEventHandler,
    MouseEventArgs>
abstract MouseWheel : IEvent<MouseEventHandler,
    MouseEventArgs>
override MouseWheel : IEvent<MouseEventHandler,
    MouseEventArgs>
Value
MouseEventHandler


Parent Property

Keyoti RapidSpell Desktop .NET API Docs
Parent Property
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► Parent
Keyoti RapidSpell Desktop .NET
Parent
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Control Parent { get; }
public Control Parent { get; }
Public ReadOnly Property Parent As Control
    Get
Public ReadOnly Property Parent As Control
    Get
public:
virtual property Control^ Parent {
    Control^ get () sealed;
}
public:
virtual property Control^ Parent {
    Control^ get () sealed;
}
abstract Parent : Control with get
override Parent : Control with get
abstract Parent : Control with get
override Parent : Control with get
Property Value
Control


ReadOnly Property

Keyoti RapidSpell Desktop .NET API Docs
ReadOnly Property
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► ReadOnly
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ReadOnly { get; }
public bool ReadOnly { get; }
Public ReadOnly Property ReadOnly As Boolean
    Get
Public ReadOnly Property ReadOnly As Boolean
    Get
public:
virtual property bool ReadOnly {
    bool get () sealed;
}
public:
virtual property bool ReadOnly {
    bool get () sealed;
}
abstract ReadOnly : bool with get
override ReadOnly : bool with get
abstract ReadOnly : bool with get
override ReadOnly : bool with get
Property Value
Boolean


RecreatingHandle Property

Keyoti RapidSpell Desktop .NET API Docs
RecreatingHandle Property
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► RecreatingHandle
Keyoti RapidSpell Desktop .NET
Is recreating handle
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool RecreatingHandle { get; }
public bool RecreatingHandle { get; }
Public ReadOnly Property RecreatingHandle As Boolean
    Get
Public ReadOnly Property RecreatingHandle As Boolean
    Get
public:
virtual property bool RecreatingHandle {
    bool get () sealed;
}
public:
virtual property bool RecreatingHandle {
    bool get () sealed;
}
abstract RecreatingHandle : bool with get
override RecreatingHandle : bool with get
abstract RecreatingHandle : bool with get
override RecreatingHandle : bool with get
Property Value
Boolean


Refresh Method

Keyoti RapidSpell Desktop .NET API Docs
Refresh Method
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► Refresh()()()()
Keyoti RapidSpell Desktop .NET
Forces the control to invalidate its client area and immediately redraw itself and any child controls.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void Refresh()
public void Refresh()
Public Sub Refresh
Public Sub Refresh
public:
virtual void Refresh() sealed
public:
virtual void Refresh() sealed
abstract Refresh : unit -> unit
override Refresh : unit -> unit
abstract Refresh : unit -> unit
override Refresh : unit -> unit


Resize Event

Keyoti RapidSpell Desktop .NET API Docs
Resize Event
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► Resize
Keyoti RapidSpell Desktop .NET
Occurs when the control is resized.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler Resize
public event EventHandler Resize
Public Event Resize As EventHandler
Public Event Resize As EventHandler
public:
virtual  event EventHandler^ Resize {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ Resize {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Resize : IEvent<EventHandler,
    EventArgs>
override Resize : IEvent<EventHandler,
    EventArgs>
abstract Resize : IEvent<EventHandler,
    EventArgs>
override Resize : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


ScrollCaret Event

Keyoti RapidSpell Desktop .NET API Docs
ScrollCaret Event
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► ScrollCaret
Keyoti RapidSpell Desktop .NET
Occurs when the text box is scrolled to the caret.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler ScrollCaret
public event EventHandler ScrollCaret
Public Event ScrollCaret As EventHandler
Public Event ScrollCaret As EventHandler
public:
virtual  event EventHandler^ ScrollCaret {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ ScrollCaret {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ScrollCaret : IEvent<EventHandler,
    EventArgs>
override ScrollCaret : IEvent<EventHandler,
    EventArgs>
abstract ScrollCaret : IEvent<EventHandler,
    EventArgs>
override ScrollCaret : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


SelectedText Property

Keyoti RapidSpell Desktop .NET API Docs
SelectedText Property
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► SelectedText
Keyoti RapidSpell Desktop .NET
This member overrides TextBox.SelectedText.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string SelectedText { get; set; }
public string SelectedText { get; set; }
Public Property SelectedText As String
    Get
    Set
Public Property SelectedText As String
    Get
    Set
public:
virtual property String^ SelectedText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ SelectedText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract SelectedText : string with get, set
override SelectedText : string with get, set
abstract SelectedText : string with get, set
override SelectedText : string with get, set
Property Value
String


SelectionChanged Event

Keyoti RapidSpell Desktop .NET API Docs
SelectionChanged Event
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► SelectionChanged
Keyoti RapidSpell Desktop .NET
Occurs when the selection of text within the control has changed.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler SelectionChanged
public event EventHandler SelectionChanged
Public Event SelectionChanged As EventHandler
Public Event SelectionChanged As EventHandler
public:
 event EventHandler^ SelectionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
 event EventHandler^ SelectionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member SelectionChanged : IEvent<EventHandler,
    EventArgs>

member SelectionChanged : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


SelectionLength Property

Keyoti RapidSpell Desktop .NET API Docs
SelectionLength Property
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► SelectionLength
Keyoti RapidSpell Desktop .NET
This member overrides TextBox.SelectionLength.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int SelectionLength { get; set; }
public int SelectionLength { get; set; }
Public Property SelectionLength As Integer
    Get
    Set
Public Property SelectionLength As Integer
    Get
    Set
public:
virtual property int SelectionLength {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int SelectionLength {
    int get () sealed;
    void set (int value) sealed;
}
abstract SelectionLength : int with get, set
override SelectionLength : int with get, set
abstract SelectionLength : int with get, set
override SelectionLength : int with get, set
Property Value
Int32


SelectionStart Property

Keyoti RapidSpell Desktop .NET API Docs
SelectionStart Property
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► SelectionStart
Keyoti RapidSpell Desktop .NET
Gets or sets the starting point of text selected in the text box.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int SelectionStart { get; set; }
public int SelectionStart { get; set; }
Public Property SelectionStart As Integer
    Get
    Set
Public Property SelectionStart As Integer
    Get
    Set
public:
virtual property int SelectionStart {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int SelectionStart {
    int get () sealed;
    void set (int value) sealed;
}
abstract SelectionStart : int with get, set
override SelectionStart : int with get, set
abstract SelectionStart : int with get, set
override SelectionStart : int with get, set
Property Value
Int32
Remarks
If no text is selected in the control, this property indicates the insertion point for new text. If you set this property to a location beyond the length of the text in the control, the selection start position will be placed after the last character. When text is selected in the text box control, changing this property might decrease the value of the SelectionLength property. If the remaining text in the control after the position indicated by the SelectionStart property is less than the value of the SelectionLength property, the value of the SelectionLength property is automatically decreased. The value of the SelectionStart property never causes an increase in the SelectionLength property. Note You can programmatically move the caret within the text box by setting the SelectionStart to the position within the text box where you want the caret to move to and set the SelectionLength property to a value of zero (0). The text box must have focus in order for the caret to be moved.


ShowCutCopyPasteContextMenu Property

Keyoti RapidSpell Desktop .NET API Docs
ShowCutCopyPasteContextMenu Property
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► ShowCutCopyPasteContextMenu
Keyoti RapidSpell Desktop .NET
Whether to show the standard Undo/Cut/Copy/Paste/Delete/Select All context menu.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ShowCutCopyPasteContextMenu { get; set; }
public bool ShowCutCopyPasteContextMenu { get; set; }
Public Property ShowCutCopyPasteContextMenu As Boolean
    Get
    Set
Public Property ShowCutCopyPasteContextMenu As Boolean
    Get
    Set
public:
property bool ShowCutCopyPasteContextMenu {
    bool get ();
    void set (bool value);
}
public:
property bool ShowCutCopyPasteContextMenu {
    bool get ();
    void set (bool value);
}
member ShowCutCopyPasteContextMenu : bool with get, set

member ShowCutCopyPasteContextMenu : bool with get, set
Property Value
Boolean


SuspendLayout Method

Keyoti RapidSpell Desktop .NET API Docs
SuspendLayout Method
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► SuspendLayout()()()()
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void SuspendLayout()
public void SuspendLayout()
Public Sub SuspendLayout
Public Sub SuspendLayout
public:
virtual void SuspendLayout() sealed
public:
virtual void SuspendLayout() sealed
abstract SuspendLayout : unit -> unit
override SuspendLayout : unit -> unit
abstract SuspendLayout : unit -> unit
override SuspendLayout : unit -> unit


Text Property

Keyoti RapidSpell Desktop .NET API Docs
Text Property
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► Text
Keyoti RapidSpell Desktop .NET
This member overrides TextBox.Text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string Text { get; set; }
public string Text { get; set; }
Public Property Text As String
    Get
    Set
Public Property Text As String
    Get
    Set
public:
virtual property String^ Text {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ Text {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract Text : string with get, set
override Text : string with get, set
abstract Text : string with get, set
override Text : string with get, set
Property Value
String


TextChanged Event

Keyoti RapidSpell Desktop .NET API Docs
TextChanged Event
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► TextChanged
Keyoti RapidSpell Desktop .NET
Occurs when the Text property value changes.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler TextChanged
public event EventHandler TextChanged
Public Event TextChanged As EventHandler
Public Event TextChanged As EventHandler
public:
virtual  event EventHandler^ TextChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ TextChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract TextChanged : IEvent<EventHandler,
    EventArgs>
override TextChanged : IEvent<EventHandler,
    EventArgs>
abstract TextChanged : IEvent<EventHandler,
    EventArgs>
override TextChanged : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


TextLength Property

Keyoti RapidSpell Desktop .NET API Docs
TextLength Property
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► TextLength
Keyoti RapidSpell Desktop .NET
Gets the current text length in the text box.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int TextLength { get; }
public int TextLength { get; }
Public ReadOnly Property TextLength As Integer
    Get
Public ReadOnly Property TextLength As Integer
    Get
public:
virtual property int TextLength {
    int get () sealed;
}
public:
virtual property int TextLength {
    int get () sealed;
}
abstract TextLength : int with get
override TextLength : int with get
abstract TextLength : int with get
override TextLength : int with get
Property Value
Int32


UnderlineYOffset Property

Keyoti RapidSpell Desktop .NET API Docs
UnderlineYOffset Property
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► UnderlineYOffset
Keyoti RapidSpell Desktop .NET
Controls the position of the underline relative to the baseline.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int UnderlineYOffset { get; set; }
public int UnderlineYOffset { get; set; }
Public Property UnderlineYOffset As Integer
    Get
    Set
Public Property UnderlineYOffset As Integer
    Get
    Set
public:
property int UnderlineYOffset {
    int get ();
    void set (int value);
}
public:
property int UnderlineYOffset {
    int get ();
    void set (int value);
}
member UnderlineYOffset : int with get, set

member UnderlineYOffset : int with get, set
Property Value
Int32


VScrolled Event

Keyoti RapidSpell Desktop .NET API Docs
VScrolled Event
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► VScrolled
Keyoti RapidSpell Desktop .NET
Event fired when vertical scroll changed (by anything).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler VScrolled
public event EventHandler VScrolled
Public Event VScrolled As EventHandler
Public Event VScrolled As EventHandler
public:
virtual  event EventHandler^ VScrolled {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ VScrolled {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract VScrolled : IEvent<EventHandler,
    EventArgs>
override VScrolled : IEvent<EventHandler,
    EventArgs>
abstract VScrolled : IEvent<EventHandler,
    EventArgs>
override VScrolled : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


VScrollEnd Event

Keyoti RapidSpell Desktop .NET API Docs
VScrollEnd Event
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► VScrollEnd
Keyoti RapidSpell Desktop .NET
Event fired when vertical scroll ends.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler VScrollEnd
public event EventHandler VScrollEnd
Public Event VScrollEnd As EventHandler
Public Event VScrollEnd As EventHandler
public:
virtual  event EventHandler^ VScrollEnd {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ VScrollEnd {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract VScrollEnd : IEvent<EventHandler,
    EventArgs>
override VScrollEnd : IEvent<EventHandler,
    EventArgs>
abstract VScrollEnd : IEvent<EventHandler,
    EventArgs>
override VScrollEnd : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


Width Property

Keyoti RapidSpell Desktop .NET API Docs
Width Property
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► Width
Keyoti RapidSpell Desktop .NET
Gets or sets the width of the control.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int Width { get; set; }
public int Width { get; set; }
Public Property Width As Integer
    Get
    Set
Public Property Width As Integer
    Get
    Set
public:
virtual property int Width {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int Width {
    int get () sealed;
    void set (int value) sealed;
}
abstract Width : int with get, set
override Width : int with get, set
abstract Width : int with get, set
override Width : int with get, set
Property Value
Int32


WndProc Method (m)

Keyoti RapidSpell Desktop .NET API Docs
WndProc Method (m)
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► WndProc(Message%)
Keyoti RapidSpell Desktop .NET
Handles WndProc events and dispatches new events.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool WndProc(
    ref Message m
)
public bool WndProc(
    ref Message m
)
Public Function WndProc (
    ByRef m As Message
) As Boolean
Public Function WndProc (
    ByRef m As Message
) As Boolean
public:
virtual bool WndProc(
    Message% m
) sealed
public:
virtual bool WndProc(
    Message% m
) sealed
abstract WndProc :
        m : Message byref -> bool
override WndProc :
        m : Message byref -> bool
abstract WndProc :
        m : Message byref -> bool
override WndProc :
        m : Message byref -> bool
Parameters
m (Message %)
Return Value
Boolean


WrappedTextBox Property

Keyoti RapidSpell Desktop .NET API Docs
WrappedTextBox Property
API ► Keyoti.RapidSpell.ThirdParty.DevExpress6 ► TextBoxConnector ► WrappedTextBox
Keyoti RapidSpell Desktop .NET
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public TextBoxBase WrappedTextBox { get; set; }
public TextBoxBase WrappedTextBox { get; set; }
Public Property WrappedTextBox As TextBoxBase
    Get
    Set
Public Property WrappedTextBox As TextBoxBase
    Get
    Set
public:
property TextBoxBase^ WrappedTextBox {
    TextBoxBase^ get ();
    void set (TextBoxBase^ value);
}
public:
property TextBoxBase^ WrappedTextBox {
    TextBoxBase^ get ();
    void set (TextBoxBase^ value);
}
member WrappedTextBox : TextBoxBase with get, set

member WrappedTextBox : TextBoxBase with get, set
Property Value
TextBoxBase


MemberwiseClone Method

Keyoti RapidSpell Desktop .NET API Docs
MemberwiseClone Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► MemberwiseClone()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.


ResumeLayout Method

Keyoti RapidSpell Desktop .NET API Docs
ResumeLayout Method
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBox ► ResumeLayout()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | ResumeLayout()()()() | Resumes usual layout logic.
 | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests.


MemberwiseClone Method

Keyoti RapidSpell Desktop .NET API Docs
MemberwiseClone Method
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► MemberwiseClone()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.


Dispose Method

Keyoti RapidSpell Desktop .NET API Docs
Dispose Method
API ► Keyoti.RapidSpell ► RegisterForm ► Dispose()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Form.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component.


Find Method

Keyoti RapidSpell Desktop .NET API Docs
Find Method
API ► Keyoti.RapidSpell ► AYTRichTextBox ► Find()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Find(String) | Searches the text in a RichTextBox control for a string.
 | Find(String, RichTextBoxFinds) | Searches the text in a RichTextBox control for a string with specific options applied to the search.
 | Find(String, Int32, RichTextBoxFinds) | Searches the text in a RichTextBox control for a string at a specific location within the control and with specific options applied to the search.
 | Find(String, Int32, Int32, RichTextBoxFinds) | Searches the text in a RichTextBox control for a string within a range of text within the control and with specific options applied to the search.
 | Find(array<Char>[]()[][]) | Searches the text of a RichTextBox control for the first instance of a character from a list of characters.
 | Find(array<Char>[]()[][], Int32) | Searches the text of a RichTextBox control, at a specific starting point, for the first instance of a character from a list of characters.
 | Find(array<Char>[]()[][], Int32, Int32) | Searches a range of text in a RichTextBox control for the first instance of a character from a list of characters.


RtlTranslateAlignment Method

Keyoti RapidSpell Desktop .NET API Docs
RtlTranslateAlignment Method
API ► Keyoti.RapidSpell ► AYTTextBox ► RtlTranslateAlignment()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
 | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
 | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.


LogicalToDeviceUnits Method

Keyoti RapidSpell Desktop .NET API Docs
LogicalToDeviceUnits Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsOptions ► LogicalToDeviceUnits()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | LogicalToDeviceUnits(Int32) |
 | LogicalToDeviceUnits(Size) |


Select Method

Keyoti RapidSpell Desktop .NET API Docs
Select Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► Select()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Overrides ContainerControl.Select(Boolean, Boolean).)
 | Select()()()() | Activates the control.


BeginInvoke Method

Keyoti RapidSpell Desktop .NET API Docs
BeginInvoke Method
API ► Keyoti.RapidSpell.Grid ► AYTTextEditingControl ► BeginInvoke()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
 | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.


MemberwiseClone Method

Keyoti RapidSpell Desktop .NET API Docs
MemberwiseClone Method
API ► Keyoti.RapidSpell.Compression ► GZipStream ► MemberwiseClone()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.


Paste Method

Keyoti RapidSpell Desktop .NET API Docs
Paste Method
API ► Keyoti.RapidSpell ► AYTRichTextBox ► Paste()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Paste(DataFormats..::..Format) | Pastes the contents of the Clipboard in the specified Clipboard format.
 | Paste()()()() | Replaces the current selection in the text box with the contents of the Clipboard.


PerformLayout Method

Keyoti RapidSpell Desktop .NET API Docs
PerformLayout Method
API ► Keyoti.RapidSpell ► RegisterForm ► PerformLayout()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls.
 | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls.


Scale Method

Keyoti RapidSpell Desktop .NET API Docs
Scale Method
API ► Keyoti.RapidSpell ► AYTComboBox ► Scale()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Scale(Single) | Obsolete. Scales the control and any child controls.
 | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls.
 | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor.


Dispose Method

Keyoti RapidSpell Desktop .NET API Docs
Dispose Method
API ► Keyoti.RapidSpell.Grid ► AYTDataGridViewTextBoxColumn ► Dispose()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DataGridViewBand.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the DataGridViewBand.


Paste Method

Keyoti RapidSpell Desktop .NET API Docs
Paste Method
API ► Keyoti.RapidSpell ► AYTTextBox ► Paste()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Paste(String) | Sets the selected text to the specified text without clearing the undo buffer.
 | Paste()()()() | Replaces the current selection in the text box with the contents of the Clipboard.


ResumeLayout Method

Keyoti RapidSpell Desktop .NET API Docs
ResumeLayout Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsOptions ► ResumeLayout()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | ResumeLayout()()()() | Resumes usual layout logic.
 | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests.


ValidateChildren Method

Keyoti RapidSpell Desktop .NET API Docs
ValidateChildren Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionarySelect ► ValidateChildren()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | ValidateChildren()()()() | (Overrides ContainerControl.ValidateChildren()()()().)
 | ValidateChildren(ValidationConstraints) | (Overrides ContainerControl.ValidateChildren(ValidationConstraints).)


SetBounds Method

Keyoti RapidSpell Desktop .NET API Docs
SetBounds Method
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBox ► SetBounds()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size.
 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size.


LogicalToDeviceUnits Method

Keyoti RapidSpell Desktop .NET API Docs
LogicalToDeviceUnits Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionarySelect ► LogicalToDeviceUnits()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | LogicalToDeviceUnits(Int32) |
 | LogicalToDeviceUnits(Size) |


ValidateChildren Method

Keyoti RapidSpell Desktop .NET API Docs
ValidateChildren Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsOptions ► ValidateChildren()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | ValidateChildren()()()() | (Overrides ContainerControl.ValidateChildren()()()().)
 | ValidateChildren(ValidationConstraints) | (Overrides ContainerControl.ValidateChildren(ValidationConstraints).)


ShowDialog Method

Keyoti RapidSpell Desktop .NET API Docs
ShowDialog Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionaryEdit ► ShowDialog()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | ShowDialog(Object, ArrayList) | See IDialogViewUserDictionaryEdit
 | ShowDialog()()()() | Shows the form as a modal dialog box.
 | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner.


Scale Method

Keyoti RapidSpell Desktop .NET API Docs
Scale Method
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBox ► Scale()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Scale(Single) | Obsolete. Scales the control and any child controls.
 | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls.
 | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor.


BeginInvoke Method

Keyoti RapidSpell Desktop .NET API Docs
BeginInvoke Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionarySelect ► BeginInvoke()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
 | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.


Edit Method

Keyoti RapidSpell Desktop .NET API Docs
Edit Method
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBoxColumn ► Edit()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Edit(CurrencyManager, Int32, Rectangle, Boolean, String, Boolean) | Internal (Overrides DataGridColumnStyle.Edit(CurrencyManager, Int32, Rectangle, Boolean, String, Boolean).)
 | Edit(CurrencyManager, Int32, Rectangle, Boolean) | Prepares a cell for editing.
 | Edit(CurrencyManager, Int32, Rectangle, Boolean, String) | Prepares the cell for editing using the specified CurrencyManager, row number, and Rectangle parameters.


PerformLayout Method

Keyoti RapidSpell Desktop .NET API Docs
PerformLayout Method
API ► Keyoti.RapidSpell ► AYTComboBox ► PerformLayout()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls.
 | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls.


MemberwiseClone Method

Keyoti RapidSpell Desktop .NET API Docs
MemberwiseClone Method
API ► Keyoti.RapidSpell ► AYTRichTextBox ► MemberwiseClone()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.


SetBounds Method

Keyoti RapidSpell Desktop .NET API Docs
SetBounds Method
API ► Keyoti.RapidSpell ► RegisterForm ► SetBounds()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size.
 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size.


MemberwiseClone Method

Keyoti RapidSpell Desktop .NET API Docs
MemberwiseClone Method
API ► Keyoti.RapidSpell.Grid ► AYTTextEditingControl ► MemberwiseClone()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.


SetBounds Method

Keyoti RapidSpell Desktop .NET API Docs
SetBounds Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsOptions ► SetBounds()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size.
 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size.


SetBounds Method

Keyoti RapidSpell Desktop .NET API Docs
SetBounds Method
API ► Keyoti.RapidSpell ► AYTRichTextBox ► SetBounds()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size.
 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size.


RtlTranslateAlignment Method

Keyoti RapidSpell Desktop .NET API Docs
RtlTranslateAlignment Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionaryEdit ► RtlTranslateAlignment()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
 | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
 | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.


Dispose Method

Keyoti RapidSpell Desktop .NET API Docs
Dispose Method
API ► Keyoti.RapidSpell ► RapidSpellAYTDialogCoupler ► Dispose()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Dispose(Boolean) | Frees up resources. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component.


MemberwiseClone Method

Keyoti RapidSpell Desktop .NET API Docs
MemberwiseClone Method
API ► Keyoti.RapidSpell ► AYTTextBox ► MemberwiseClone()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.


RtlTranslateAlignment Method

Keyoti RapidSpell Desktop .NET API Docs
RtlTranslateAlignment Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsOptions ► RtlTranslateAlignment()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
 | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
 | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.


ResumeLayout Method

Keyoti RapidSpell Desktop .NET API Docs
ResumeLayout Method
API ► Keyoti.RapidSpell.Grid ► AYTTextEditingControl ► ResumeLayout()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | ResumeLayout()()()() | Resumes usual layout logic.
 | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests.


Validate Method

Keyoti RapidSpell Desktop .NET API Docs
Validate Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsOptions ► Validate()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
 | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on.


FindStringExact Method

Keyoti RapidSpell Desktop .NET API Docs
FindStringExact Method
API ► Keyoti.RapidSpell ► AYTComboBox ► FindStringExact()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | FindStringExact(String) | Finds the first item in the combo box that matches the specified string.
 | FindStringExact(String, Int32) | Finds the first item after the specified index that matches the specified string.


Invalidate Method

Keyoti RapidSpell Desktop .NET API Docs
Invalidate Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► Invalidate()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
 | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
 | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn.
 | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
 | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
 | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.


Dispose Method

Keyoti RapidSpell Desktop .NET API Docs
Dispose Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► Dispose()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Form.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component.


UpdateBounds Method

Keyoti RapidSpell Desktop .NET API Docs
UpdateBounds Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionaryEdit ► UpdateBounds()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | UpdateBounds()()()() | Updates the bounds of the control with the current size and location.
 | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location.
 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size.


SetBounds Method

Keyoti RapidSpell Desktop .NET API Docs
SetBounds Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► SetBounds()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size.
 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size.


Dispose Method

Keyoti RapidSpell Desktop .NET API Docs
Dispose Method
API ► Keyoti.RapidSpell.Compression ► GZipStream ► Dispose()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Dispose(Boolean) | Dispose the stream. (Overrides Stream.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Stream.


GetChildAtPoint Method

Keyoti RapidSpell Desktop .NET API Docs
GetChildAtPoint Method
API ► Keyoti.RapidSpell ► RegisterForm ► GetChildAtPoint()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
 | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates.


OnListChanged Method

Keyoti RapidSpell Desktop .NET API Docs
OnListChanged Method
API ► Keyoti.RapidSpell ► MultiFileUserDictionary ► OnListChanged()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | OnListChanged(UserDictionary..::..ListChangedEventArgs) | Raises ListChanged
 | OnListChanged(Object, UserDictionary..::..ListChangedEventArgs) | Raises ListChanged


MemberwiseClone Method

Keyoti RapidSpell Desktop .NET API Docs
MemberwiseClone Method
API ► Keyoti.RapidSpell.Compression ► CrcCalculatorStream ► MemberwiseClone()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.


AccessibilityNotifyClients Method

Keyoti RapidSpell Desktop .NET API Docs
AccessibilityNotifyClients Method
API ► Keyoti.RapidSpell.Grid ► AYTTextEditingControl ► AccessibilityNotifyClients()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .


Invoke Method

Keyoti RapidSpell Desktop .NET API Docs
Invoke Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► Invoke()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle.
 | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.


GetChildAtPoint Method

Keyoti RapidSpell Desktop .NET API Docs
GetChildAtPoint Method
API ► Keyoti.RapidSpell ► AYTComboBox ► GetChildAtPoint()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
 | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates.


Validate Method

Keyoti RapidSpell Desktop .NET API Docs
Validate Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► Validate()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
 | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on.


Scale Method

Keyoti RapidSpell Desktop .NET API Docs
Scale Method
API ► Keyoti.RapidSpell ► AYTTextBox ► Scale()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Scale(Single) | Obsolete. Scales the control and any child controls.
 | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls.
 | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor.


Validate Method

Keyoti RapidSpell Desktop .NET API Docs
Validate Method
API ► Keyoti.RapidSpell ► RegisterForm ► Validate()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
 | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on.


Invalidate Method

Keyoti RapidSpell Desktop .NET API Docs
Invalidate Method
API ► Keyoti.RapidSpell ► AYTTextBox ► Invalidate()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
 | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
 | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn.
 | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
 | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
 | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.


RtlTranslateAlignment Method

Keyoti RapidSpell Desktop .NET API Docs
RtlTranslateAlignment Method
API ► Keyoti.RapidSpell ► AYTRichTextBox ► RtlTranslateAlignment()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
 | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
 | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.


ResumeLayout Method

Keyoti RapidSpell Desktop .NET API Docs
ResumeLayout Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionarySelect ► ResumeLayout()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | ResumeLayout()()()() | Resumes usual layout logic.
 | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests.


Invoke Method

Keyoti RapidSpell Desktop .NET API Docs
Invoke Method
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBox ► Invoke()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle.
 | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.


BeginInvoke Method

Keyoti RapidSpell Desktop .NET API Docs
BeginInvoke Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsOptions ► BeginInvoke()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
 | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.


Dispose Method

Keyoti RapidSpell Desktop .NET API Docs
Dispose Method
API ► Keyoti.RapidSpell.Grid ► AYTDataGridViewTextBoxCell ► Dispose()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Dispose()()()() | Releases all resources used by the DataGridViewCell.
 | Dispose(Boolean) | Releases the unmanaged resources used by the DataGridViewCell and optionally releases the managed resources.


UpdateBounds Method

Keyoti RapidSpell Desktop .NET API Docs
UpdateBounds Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsOptions ► UpdateBounds()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | UpdateBounds()()()() | Updates the bounds of the control with the current size and location.
 | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location.
 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size.


Scale Method

Keyoti RapidSpell Desktop .NET API Docs
Scale Method
API ► Keyoti.RapidSpell ► RegisterForm ► Scale()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Scale(Single) | Obsolete. Scales the control and any child controls.
 | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls.
 | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor.


Select Method

Keyoti RapidSpell Desktop .NET API Docs
Select Method
API ► Keyoti.RapidSpell.Grid ► AYTTextEditingControl ► Select()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Select(Int32, Int32) | Selects a range of text in the text box.
 | Select()()()() | Activates the control.
 | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from.


Show Method

Keyoti RapidSpell Desktop .NET API Docs
Show Method
API ► Keyoti.RapidSpell ► RegisterForm ► Show()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Show(IWin32Window) | Shows the form with the specified owner to the user.
 | Show()()()() | Displays the control to the user.


MemberwiseClone Method

Keyoti RapidSpell Desktop .NET API Docs
MemberwiseClone Method
API ► Keyoti.RapidSpell ► AYTComboBox ► MemberwiseClone()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.


GetContentBounds Method

Keyoti RapidSpell Desktop .NET API Docs
GetContentBounds Method
API ► Keyoti.RapidSpell.Grid ► AYTDataGridViewTextBoxCell ► GetContentBounds()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | GetContentBounds(Graphics, DataGridViewCellStyle, Int32) | (Overrides DataGridViewCell.GetContentBounds(Graphics, DataGridViewCellStyle, Int32).)
 | GetContentBounds(Int32) | Returns the bounding rectangle that encloses the cell's content area using a default Graphics and cell style currently in effect for the cell.


Invalidate Method

Keyoti RapidSpell Desktop .NET API Docs
Invalidate Method
API ► Keyoti.RapidSpell.Grid ► AYTTextEditingControl ► Invalidate()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
 | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
 | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn.
 | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
 | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
 | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.


MemberwiseClone Method

Keyoti RapidSpell Desktop .NET API Docs
MemberwiseClone Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionarySelect ► MemberwiseClone()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.


LogicalToDeviceUnits Method

Keyoti RapidSpell Desktop .NET API Docs
LogicalToDeviceUnits Method
API ► Keyoti.RapidSpell.Grid ► AYTTextEditingControl ► LogicalToDeviceUnits()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | LogicalToDeviceUnits(Int32) |
 | LogicalToDeviceUnits(Size) |


BeginInvoke Method

Keyoti RapidSpell Desktop .NET API Docs
BeginInvoke Method
API ► Keyoti.RapidSpell ► RichTextBoxIAYTAdapter ► BeginInvoke()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | BeginInvoke(Delegate) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
 | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.


Dispose Method

Keyoti RapidSpell Desktop .NET API Docs
Dispose Method
API ► Keyoti.RapidSpell ► AYTTextBox ► Dispose()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Dispose(Boolean) | Releases the unmanaged resources used by the TextBox and optionally releases the managed resources. (Overrides Control.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component.


MemberwiseClone Method

Keyoti RapidSpell Desktop .NET API Docs
MemberwiseClone Method
API ► Keyoti.RapidSpell ► RegisterForm ► MemberwiseClone()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.


GetChildAtPoint Method

Keyoti RapidSpell Desktop .NET API Docs
GetChildAtPoint Method
API ► Keyoti.RapidSpell ► AYTRichTextBox ► GetChildAtPoint()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
 | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates.


MemberwiseClone Method

Keyoti RapidSpell Desktop .NET API Docs
MemberwiseClone Method
API ► Keyoti.RapidSpell ► RapidSpellAYTDialogCoupler ► MemberwiseClone()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.


Invoke Method

Keyoti RapidSpell Desktop .NET API Docs
Invoke Method
API ► Keyoti.RapidSpell ► AYTTextBox ► Invoke()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle.
 | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.


ShowDialog Method

Keyoti RapidSpell Desktop .NET API Docs
ShowDialog Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionarySelect ► ShowDialog()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | ShowDialog(Object, List<(Of <<'(String>)>>), String) | See IDialogViewUserDictionaryEdit
 | ShowDialog()()()() | Shows the form as a modal dialog box.
 | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner.


BeginInvoke Method

Keyoti RapidSpell Desktop .NET API Docs
BeginInvoke Method
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBox ► BeginInvoke()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
 | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.


PerformLayout Method

Keyoti RapidSpell Desktop .NET API Docs
PerformLayout Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► PerformLayout()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls.
 | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls.


Validate Method

Keyoti RapidSpell Desktop .NET API Docs
Validate Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionaryEdit ► Validate()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
 | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on.


PerformLayout Method

Keyoti RapidSpell Desktop .NET API Docs
PerformLayout Method
API ► Keyoti.RapidSpell ► AYTRichTextBox ► PerformLayout()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls.
 | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls.


Select Method

Keyoti RapidSpell Desktop .NET API Docs
Select Method
API ► Keyoti.RapidSpell ► AYTRichTextBox ► Select()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Select(Int32, Int32) | Selects a range of text in the text box.
 | Select()()()() | Activates the control.
 | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from.


ResumeLayout Method

Keyoti RapidSpell Desktop .NET API Docs
ResumeLayout Method
API ► Keyoti.RapidSpell ► AYTComboBox ► ResumeLayout()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | ResumeLayout()()()() | Resumes usual layout logic.
 | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests.


Invalidate Method

Keyoti RapidSpell Desktop .NET API Docs
Invalidate Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionaryEdit ► Invalidate()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
 | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
 | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn.
 | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
 | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
 | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.


Invoke Method

Keyoti RapidSpell Desktop .NET API Docs
Invoke Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionaryEdit ► Invoke()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle.
 | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.


Select Method

Keyoti RapidSpell Desktop .NET API Docs
Select Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionarySelect ► Select()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Overrides ContainerControl.Select(Boolean, Boolean).)
 | Select()()()() | Activates the control.


FilterItemOnProperty Method

Keyoti RapidSpell Desktop .NET API Docs
FilterItemOnProperty Method
API ► Keyoti.RapidSpell ► AYTComboBox ► FilterItemOnProperty()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | FilterItemOnProperty(Object) | Retrieves the current value of the ListControl item, if it is a property of an object, given the item.
 | FilterItemOnProperty(Object, String) | Returns the current value of the ListControl item, if it is a property of an object given the item and the property name.


UpdateBounds Method

Keyoti RapidSpell Desktop .NET API Docs
UpdateBounds Method
API ► Keyoti.RapidSpell ► RegisterForm ► UpdateBounds()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | UpdateBounds()()()() | Updates the bounds of the control with the current size and location.
 | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location.
 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size.


Select Method

Keyoti RapidSpell Desktop .NET API Docs
Select Method
API ► Keyoti.RapidSpell ► RegisterForm ► Select()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Overrides ContainerControl.Select(Boolean, Boolean).)
 | Select()()()() | Activates the control.


Dispose Method

Keyoti RapidSpell Desktop .NET API Docs
Dispose Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsOptions ► Dispose()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Form.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component.


LoadFile Method

Keyoti RapidSpell Desktop .NET API Docs
LoadFile Method
API ► Keyoti.RapidSpell ► AYTRichTextBox ► LoadFile()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | LoadFile(String) | Loads a rich text format (RTF) or standard ASCII text file into the RichTextBox control.
 | LoadFile(String, RichTextBoxStreamType) | Loads a specific type of file into the RichTextBox control.
 | LoadFile(Stream, RichTextBoxStreamType) | Loads the contents of an existing data stream into the RichTextBox control.


ResumeLayout Method

Keyoti RapidSpell Desktop .NET API Docs
ResumeLayout Method
API ► Keyoti.RapidSpell ► AYTTextBox ► ResumeLayout()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | ResumeLayout()()()() | Resumes usual layout logic.
 | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests.


Show Method

Keyoti RapidSpell Desktop .NET API Docs
Show Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionaryEdit ► Show()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Show(IWin32Window) | Shows the form with the specified owner to the user.
 | Show()()()() | Displays the control to the user.


GetChildAtPoint Method

Keyoti RapidSpell Desktop .NET API Docs
GetChildAtPoint Method
API ► Keyoti.RapidSpell ► AYTTextBox ► GetChildAtPoint()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
 | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates.


Validate Method

Keyoti RapidSpell Desktop .NET API Docs
Validate Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionarySelect ► Validate()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
 | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on.


Paste Method

Keyoti RapidSpell Desktop .NET API Docs
Paste Method
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBox ► Paste()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Paste(String) | Sets the selected text to the specified text without clearing the undo buffer.
 | Paste()()()() | Replaces the current selection in the text box with the contents of the Clipboard.


ValidateChildren Method

Keyoti RapidSpell Desktop .NET API Docs
ValidateChildren Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionaryEdit ► ValidateChildren()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | ValidateChildren()()()() | (Overrides ContainerControl.ValidateChildren()()()().)
 | ValidateChildren(ValidationConstraints) | (Overrides ContainerControl.ValidateChildren(ValidationConstraints).)


MemberwiseClone Method

Keyoti RapidSpell Desktop .NET API Docs
MemberwiseClone Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionaryEdit ► MemberwiseClone()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.


AccessibilityNotifyClients Method

Keyoti RapidSpell Desktop .NET API Docs
AccessibilityNotifyClients Method
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBox ► AccessibilityNotifyClients()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .


ShowDialog Method

Keyoti RapidSpell Desktop .NET API Docs
ShowDialog Method
API ► Keyoti.RapidSpell ► RegisterForm ► ShowDialog()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | ShowDialog()()()() | Shows the form as a modal dialog box.
 | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner.


MemberwiseClone Method

Keyoti RapidSpell Desktop .NET API Docs
MemberwiseClone Method
API ► Keyoti.RapidSpell ► RapidSpellDialog ► MemberwiseClone()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.


UpdateBounds Method

Keyoti RapidSpell Desktop .NET API Docs
UpdateBounds Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► UpdateBounds()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | UpdateBounds()()()() | Updates the bounds of the control with the current size and location.
 | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location.
 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size.


GetChildAtPoint Method

Keyoti RapidSpell Desktop .NET API Docs
GetChildAtPoint Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► GetChildAtPoint()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
 | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates.


LogicalToDeviceUnits Method

Keyoti RapidSpell Desktop .NET API Docs
LogicalToDeviceUnits Method
API ► Keyoti.RapidSpell ► AYTTextBox ► LogicalToDeviceUnits()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | LogicalToDeviceUnits(Int32) |
 | LogicalToDeviceUnits(Size) |


Invalidate Method

Keyoti RapidSpell Desktop .NET API Docs
Invalidate Method
API ► Keyoti.RapidSpell ► AYTRichTextBox ► Invalidate()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
 | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
 | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn.
 | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
 | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
 | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.


MemberwiseClone Method

Keyoti RapidSpell Desktop .NET API Docs
MemberwiseClone Method
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBoxColumn ► MemberwiseClone()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.


GetChildAtPoint Method

Keyoti RapidSpell Desktop .NET API Docs
GetChildAtPoint Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionaryEdit ► GetChildAtPoint()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
 | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates.


Select Method

Keyoti RapidSpell Desktop .NET API Docs
Select Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsOptions ► Select()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Overrides ContainerControl.Select(Boolean, Boolean).)
 | Select()()()() | Activates the control.


Scale Method

Keyoti RapidSpell Desktop .NET API Docs
Scale Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsOptions ► Scale()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Scale(Single) | Obsolete. Scales the control and any child controls.
 | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls.
 | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor.


Dispose Method

Keyoti RapidSpell Desktop .NET API Docs
Dispose Method
API ► Keyoti.RapidSpell ► AYTComboBox ► Dispose()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Dispose(Boolean) | Releases the unmanaged resources used by the ComboBox and optionally releases the managed resources. (Overrides Control.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component.


LogicalToDeviceUnits Method

Keyoti RapidSpell Desktop .NET API Docs
LogicalToDeviceUnits Method
API ► Keyoti.RapidSpell ► AYTComboBox ► LogicalToDeviceUnits()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | LogicalToDeviceUnits(Int32) |
 | LogicalToDeviceUnits(Size) |


ValidateChildren Method

Keyoti RapidSpell Desktop .NET API Docs
ValidateChildren Method
API ► Keyoti.RapidSpell ► RegisterForm ► ValidateChildren()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | ValidateChildren()()()() | (Overrides ContainerControl.ValidateChildren()()()().)
 | ValidateChildren(ValidationConstraints) | (Overrides ContainerControl.ValidateChildren(ValidationConstraints).)


ResumeLayout Method

Keyoti RapidSpell Desktop .NET API Docs
ResumeLayout Method
API ► Keyoti.RapidSpell ► AYTRichTextBox ► ResumeLayout()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | ResumeLayout()()()() | Resumes usual layout logic.
 | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests.


Dispose Method

Keyoti RapidSpell Desktop .NET API Docs
Dispose Method
API ► Keyoti.RapidSpell.Grid ► AYTTextEditingControl ► Dispose()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Dispose(Boolean) | Releases the unmanaged resources used by the TextBox and optionally releases the managed resources. (Overrides Control.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component.


LogicalToDeviceUnits Method

Keyoti RapidSpell Desktop .NET API Docs
LogicalToDeviceUnits Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionaryEdit ► LogicalToDeviceUnits()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | LogicalToDeviceUnits(Int32) |
 | LogicalToDeviceUnits(Size) |


AccessibilityNotifyClients Method

Keyoti RapidSpell Desktop .NET API Docs
AccessibilityNotifyClients Method
API ► Keyoti.RapidSpell ► AYTComboBox ► AccessibilityNotifyClients()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .


LogicalToDeviceUnits Method

Keyoti RapidSpell Desktop .NET API Docs
LogicalToDeviceUnits Method
API ► Keyoti.RapidSpell ► AYTRichTextBox ► LogicalToDeviceUnits()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | LogicalToDeviceUnits(Int32) |
 | LogicalToDeviceUnits(Size) |


AccessibilityNotifyClients Method

Keyoti RapidSpell Desktop .NET API Docs
AccessibilityNotifyClients Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionaryEdit ► AccessibilityNotifyClients()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .


Scale Method

Keyoti RapidSpell Desktop .NET API Docs
Scale Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► Scale()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Scale(Single) | Obsolete. Scales the control and any child controls.
 | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls.
 | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor.


Dispose Method

Keyoti RapidSpell Desktop .NET API Docs
Dispose Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionaryEdit ► Dispose()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Form.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component.


Dispose Method

Keyoti RapidSpell Desktop .NET API Docs
Dispose Method
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► Dispose()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Dispose()()()() | Releases all resources used by the Component.
 | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources.


ResumeLayout Method

Keyoti RapidSpell Desktop .NET API Docs
ResumeLayout Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► ResumeLayout()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | ResumeLayout()()()() | Resumes usual layout logic.
 | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests.


AccessibilityNotifyClients Method

Keyoti RapidSpell Desktop .NET API Docs
AccessibilityNotifyClients Method
API ► Keyoti.RapidSpell ► AYTTextBox ► AccessibilityNotifyClients()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .


Dispose Method

Keyoti RapidSpell Desktop .NET API Docs
Dispose Method
API ► Keyoti.RapidSpell.Compression ► CrcCalculatorStream ► Dispose()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Dispose()()()() | Releases all resources used by the Stream.
 | Dispose(Boolean) | Releases the unmanaged resources used by the Stream and optionally releases the managed resources.


BeginInvoke Method

Keyoti RapidSpell Desktop .NET API Docs
BeginInvoke Method
API ► Keyoti.RapidSpell ► AYTComboBox ► BeginInvoke()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
 | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.


BeginInvoke Method

Keyoti RapidSpell Desktop .NET API Docs
BeginInvoke Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionaryEdit ► BeginInvoke()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
 | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.


Scale Method

Keyoti RapidSpell Desktop .NET API Docs
Scale Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionaryEdit ► Scale()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Scale(Single) | Obsolete. Scales the control and any child controls.
 | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls.
 | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor.


Dispose Method

Keyoti RapidSpell Desktop .NET API Docs
Dispose Method
API ► Keyoti.RapidSpell.Grid ► DataGridView_AYT_Manager ► Dispose()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Dispose()()()() | Releases all resources used by the Component.
 | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources.


Select Method

Keyoti RapidSpell Desktop .NET API Docs
Select Method
API ► Keyoti.RapidSpell ► AYTTextBox ► Select()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Select(Int32, Int32) | Selects a range of text in the text box.
 | Select()()()() | Activates the control.
 | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from.


ShowDialog Method

Keyoti RapidSpell Desktop .NET API Docs
ShowDialog Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► ShowDialog()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | ShowDialog(Object) | See interface, IDialogView for info
 | ShowDialog()()()() | Shows the form as a modal dialog box.
 | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner.


ResumeLayout Method

Keyoti RapidSpell Desktop .NET API Docs
ResumeLayout Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionaryEdit ► ResumeLayout()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | ResumeLayout()()()() | Resumes usual layout logic.
 | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests.


BeginInvoke Method

Keyoti RapidSpell Desktop .NET API Docs
BeginInvoke Method
API ► Keyoti.RapidSpell ► AYTRichTextBox ► BeginInvoke()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
 | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.


Invalidate Method

Keyoti RapidSpell Desktop .NET API Docs
Invalidate Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsOptions ► Invalidate()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
 | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
 | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn.
 | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
 | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
 | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.


Invalidate Method

Keyoti RapidSpell Desktop .NET API Docs
Invalidate Method
API ► Keyoti.RapidSpell ► AYTComboBox ► Invalidate()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
 | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
 | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn.
 | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
 | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
 | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.


MemberwiseClone Method

Keyoti RapidSpell Desktop .NET API Docs
MemberwiseClone Method
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBox ► MemberwiseClone()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.


Invalidate Method

Keyoti RapidSpell Desktop .NET API Docs
Invalidate Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionarySelect ► Invalidate()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
 | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
 | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn.
 | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
 | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
 | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.


Select Method

Keyoti RapidSpell Desktop .NET API Docs
Select Method
API ► Keyoti.RapidSpell ► AYTComboBox ► Select()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Select(Int32, Int32) | Selects a range of text in the editable portion of the ComboBox.
 | Select()()()() | Activates the control.
 | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from.


GetChildAtPoint Method

Keyoti RapidSpell Desktop .NET API Docs
GetChildAtPoint Method
API ► Keyoti.RapidSpell.Grid ► AYTTextEditingControl ► GetChildAtPoint()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
 | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates.


Dispose Method

Keyoti RapidSpell Desktop .NET API Docs
Dispose Method
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBox ► Dispose()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Dispose(Boolean) | Releases the unmanaged resources used by the TextBox and optionally releases the managed resources. (Overrides Control.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component.


MemberwiseClone Method

Keyoti RapidSpell Desktop .NET API Docs
MemberwiseClone Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsOptions ► MemberwiseClone()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.


Dispose Method

Keyoti RapidSpell Desktop .NET API Docs
Dispose Method
API ► Keyoti.RapidSpell ► AYTRichTextBox ► Dispose()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component.


ValidateChildren Method

Keyoti RapidSpell Desktop .NET API Docs
ValidateChildren Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► ValidateChildren()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | ValidateChildren()()()() | (Overrides ContainerControl.ValidateChildren()()()().)
 | ValidateChildren(ValidationConstraints) | (Overrides ContainerControl.ValidateChildren(ValidationConstraints).)


Scale Method

Keyoti RapidSpell Desktop .NET API Docs
Scale Method
API ► Keyoti.RapidSpell ► AYTRichTextBox ► Scale()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Scale(Single) | Obsolete. Scales the control and any child controls.
 | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls.
 | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor.


RtlTranslateAlignment Method

Keyoti RapidSpell Desktop .NET API Docs
RtlTranslateAlignment Method
API ► Keyoti.RapidSpell.Grid ► AYTTextEditingControl ► RtlTranslateAlignment()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
 | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
 | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.


ResumeLayout Method

Keyoti RapidSpell Desktop .NET API Docs
ResumeLayout Method
API ► Keyoti.RapidSpell ► RegisterForm ► ResumeLayout()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | ResumeLayout()()()() | Resumes usual layout logic.
 | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests.


PerformLayout Method

Keyoti RapidSpell Desktop .NET API Docs
PerformLayout Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionarySelect ► PerformLayout()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls.
 | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls.


BeginInvoke Method

Keyoti RapidSpell Desktop .NET API Docs
BeginInvoke Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► BeginInvoke()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
 | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.


AccessibilityNotifyClients Method

Keyoti RapidSpell Desktop .NET API Docs
AccessibilityNotifyClients Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► AccessibilityNotifyClients()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .


Paste Method

Keyoti RapidSpell Desktop .NET API Docs
Paste Method
API ► Keyoti.RapidSpell.Grid ► AYTTextEditingControl ► Paste()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Paste(String) | Sets the selected text to the specified text without clearing the undo buffer.
 | Paste()()()() | Replaces the current selection in the text box with the contents of the Clipboard.


Show Method

Keyoti RapidSpell Desktop .NET API Docs
Show Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► Show()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Show(IWin32Window) | Shows the form with the specified owner to the user.
 | Show()()()() | Displays the control to the user.


Invoke Method

Keyoti RapidSpell Desktop .NET API Docs
Invoke Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsOptions ► Invoke()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle.
 | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.


Dispose Method

Keyoti RapidSpell Desktop .NET API Docs
Dispose Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionarySelect ► Dispose()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Form.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component.


UpdateBounds Method

Keyoti RapidSpell Desktop .NET API Docs
UpdateBounds Method
API ► Keyoti.RapidSpell ► AYTComboBox ► UpdateBounds()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | UpdateBounds()()()() | Updates the bounds of the control with the current size and location.
 | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location.
 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size.


Invoke Method

Keyoti RapidSpell Desktop .NET API Docs
Invoke Method
API ► Keyoti.RapidSpell.Grid ► AYTTextEditingControl ► Invoke()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle.
 | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.


SetBounds Method

Keyoti RapidSpell Desktop .NET API Docs
SetBounds Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionarySelect ► SetBounds()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size.
 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size.


Show Method

Keyoti RapidSpell Desktop .NET API Docs
Show Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsOptions ► Show()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Show(IWin32Window) | Shows the form with the specified owner to the user.
 | Show()()()() | Displays the control to the user.


LogicalToDeviceUnits Method

Keyoti RapidSpell Desktop .NET API Docs
LogicalToDeviceUnits Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► LogicalToDeviceUnits()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | LogicalToDeviceUnits(Int32) |
 | LogicalToDeviceUnits(Size) |


Dispose Method

Keyoti RapidSpell Desktop .NET API Docs
Dispose Method
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBoxColumn ► Dispose()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Dispose()()()() | Releases all resources used by the Component.
 | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources.


Dispose Method

Keyoti RapidSpell Desktop .NET API Docs
Dispose Method
API ► Keyoti.RapidSpell ► RapidSpellDialog ► Dispose()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Dispose(Boolean) | Disposes of unmanaged resources. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component.


UpdateBounds Method

Keyoti RapidSpell Desktop .NET API Docs
UpdateBounds Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionarySelect ► UpdateBounds()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | UpdateBounds()()()() | Updates the bounds of the control with the current size and location.
 | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location.
 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size.


RtlTranslateAlignment Method

Keyoti RapidSpell Desktop .NET API Docs
RtlTranslateAlignment Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsForms ► RtlTranslateAlignment()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
 | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
 | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.


PerformLayout Method

Keyoti RapidSpell Desktop .NET API Docs
PerformLayout Method
API ► Keyoti.RapidSpell.Grid ► AYTTextEditingControl ► PerformLayout()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls.
 | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls.


UpdateBounds Method

Keyoti RapidSpell Desktop .NET API Docs
UpdateBounds Method
API ► Keyoti.RapidSpell ► AYTTextBox ► UpdateBounds()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | UpdateBounds()()()() | Updates the bounds of the control with the current size and location.
 | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location.
 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size.


LogicalToDeviceUnits Method

Keyoti RapidSpell Desktop .NET API Docs
LogicalToDeviceUnits Method
API ► Keyoti.RapidSpell ► RegisterForm ► LogicalToDeviceUnits()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | LogicalToDeviceUnits(Int32) |
 | LogicalToDeviceUnits(Size) |


RtlTranslateAlignment Method

Keyoti RapidSpell Desktop .NET API Docs
RtlTranslateAlignment Method
API ► Keyoti.RapidSpell ► RegisterForm ► RtlTranslateAlignment()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
 | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
 | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.


Invoke Method

Keyoti RapidSpell Desktop .NET API Docs
Invoke Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionarySelect ► Invoke()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle.
 | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.


Select Method

Keyoti RapidSpell Desktop .NET API Docs
Select Method
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBox ► Select()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Select(Int32, Int32) | Selects a range of text in the text box.
 | Select()()()() | Activates the control.
 | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from.


UpdateBounds Method

Keyoti RapidSpell Desktop .NET API Docs
UpdateBounds Method
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBox ► UpdateBounds()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | UpdateBounds()()()() | Updates the bounds of the control with the current size and location.
 | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location.
 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size.


MemberwiseClone Method

Keyoti RapidSpell Desktop .NET API Docs
MemberwiseClone Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► MemberwiseClone()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.


GetChildAtPoint Method

Keyoti RapidSpell Desktop .NET API Docs
GetChildAtPoint Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionarySelect ► GetChildAtPoint()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
 | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates.


AccessibilityNotifyClients Method

Keyoti RapidSpell Desktop .NET API Docs
AccessibilityNotifyClients Method
API ► Keyoti.RapidSpell ► AYTRichTextBox ► AccessibilityNotifyClients()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .


Invalidate Method

Keyoti RapidSpell Desktop .NET API Docs
Invalidate Method
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBox ► Invalidate()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
 | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
 | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn.
 | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
 | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
 | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.


PerformLayout Method

Keyoti RapidSpell Desktop .NET API Docs
PerformLayout Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionaryEdit ► PerformLayout()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls.
 | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls.


RtlTranslateAlignment Method

Keyoti RapidSpell Desktop .NET API Docs
RtlTranslateAlignment Method
API ► Keyoti.RapidSpell ► AYTComboBox ► RtlTranslateAlignment()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
 | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
 | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.


PerformLayout Method

Keyoti RapidSpell Desktop .NET API Docs
PerformLayout Method
API ► Keyoti.RapidSpell ► AYTTextBox ► PerformLayout()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls.
 | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls.


Invoke Method

Keyoti RapidSpell Desktop .NET API Docs
Invoke Method
API ► Keyoti.RapidSpell ► RegisterForm ► Invoke()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle.
 | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.


Dispose Method

Keyoti RapidSpell Desktop .NET API Docs
Dispose Method
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► Dispose()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Dispose(Boolean) | Dispose the stream. (Overrides Stream.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Stream.


AccessibilityNotifyClients Method

Keyoti RapidSpell Desktop .NET API Docs
AccessibilityNotifyClients Method
API ► Keyoti.RapidSpell ► RegisterForm ► AccessibilityNotifyClients()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .


Dispose Method

Keyoti RapidSpell Desktop .NET API Docs
Dispose Method
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► Dispose()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Dispose(Boolean) | Dispose the stream. (Overrides Stream.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Stream.


MemberwiseClone Method

Keyoti RapidSpell Desktop .NET API Docs
MemberwiseClone Method
API ► Keyoti.RapidSpell.Grid ► DataGridView_AYT_Manager ► MemberwiseClone()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.


AccessibilityNotifyClients Method

Keyoti RapidSpell Desktop .NET API Docs
AccessibilityNotifyClients Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsOptions ► AccessibilityNotifyClients()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .


Invalidate Method

Keyoti RapidSpell Desktop .NET API Docs
Invalidate Method
API ► Keyoti.RapidSpell ► RegisterForm ► Invalidate()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
 | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
 | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn.
 | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
 | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
 | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.


MemberwiseClone Method

Keyoti RapidSpell Desktop .NET API Docs
MemberwiseClone Method
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► MemberwiseClone()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.


isAtNonBreakingWhiteSpace Method

Keyoti RapidSpell Desktop .NET API Docs
isAtNonBreakingWhiteSpace Method
API ► Keyoti.RapidSpell.FrameWorkSpecific ► AdvancedTextBoundary ► isAtNonBreakingWhiteSpace()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | isAtNonBreakingWhiteSpace(Int32, Boolean, Boolean) | Whether position is non-breaking white space (Overrides SimpleTextBoundary.isAtNonBreakingWhiteSpace(Int32, Boolean, Boolean).)
 | isAtNonBreakingWhiteSpace(Int32) | Whether the character at position is a nonbreaking whitespace.


SetBounds Method

Keyoti RapidSpell Desktop .NET API Docs
SetBounds Method
API ► Keyoti.RapidSpell ► AYTTextBox ► SetBounds()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size.
 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size.


UpdateBounds Method

Keyoti RapidSpell Desktop .NET API Docs
UpdateBounds Method
API ► Keyoti.RapidSpell ► AYTRichTextBox ► UpdateBounds()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | UpdateBounds()()()() | Updates the bounds of the control with the current size and location.
 | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location.
 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size.


SetBounds Method

Keyoti RapidSpell Desktop .NET API Docs
SetBounds Method
API ► Keyoti.RapidSpell.Grid ► AYTTextEditingControl ► SetBounds()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size.
 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size.


SetBounds Method

Keyoti RapidSpell Desktop .NET API Docs
SetBounds Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionaryEdit ► SetBounds()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size.
 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size.


isBetweenWordChars Method

Keyoti RapidSpell Desktop .NET API Docs
isBetweenWordChars Method
API ► Keyoti.RapidSpell.FrameWorkSpecific ► AdvancedTextBoundary ► isBetweenWordChars()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | isBetweenWordChars(Int32) | Whether the character at position is between nonbreaking white space or letters or digits.
 | isBetweenWordChars(Int32, Boolean, Boolean) | Whether the character at position is between nonbreaking white space or letters or digits.


MemberwiseClone Method

Keyoti RapidSpell Desktop .NET API Docs
MemberwiseClone Method
API ► Keyoti.RapidSpell ► RapidSpellAsYouType ► MemberwiseClone()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.


AccessibilityNotifyClients Method

Keyoti RapidSpell Desktop .NET API Docs
AccessibilityNotifyClients Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionarySelect ► AccessibilityNotifyClients()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .


Invoke Method

Keyoti RapidSpell Desktop .NET API Docs
Invoke Method
API ► Keyoti.RapidSpell ► AYTComboBox ► Invoke()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle.
 | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.


ShowDialog Method

Keyoti RapidSpell Desktop .NET API Docs
ShowDialog Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsOptions ► ShowDialog()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | ShowDialog(Object, Boolean, Boolean, Boolean) | See interface
 | ShowDialog()()()() | Shows the form as a modal dialog box.
 | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner.


UpdateBounds Method

Keyoti RapidSpell Desktop .NET API Docs
UpdateBounds Method
API ► Keyoti.RapidSpell.Grid ► AYTTextEditingControl ► UpdateBounds()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | UpdateBounds()()()() | Updates the bounds of the control with the current size and location.
 | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location.
 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size.


Scale Method

Keyoti RapidSpell Desktop .NET API Docs
Scale Method
API ► Keyoti.RapidSpell.Grid ► AYTTextEditingControl ► Scale()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Scale(Single) | Obsolete. Scales the control and any child controls.
 | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls.
 | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor.


RtlTranslateAlignment Method

Keyoti RapidSpell Desktop .NET API Docs
RtlTranslateAlignment Method
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBox ► RtlTranslateAlignment()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
 | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
 | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.


Select Method

Keyoti RapidSpell Desktop .NET API Docs
Select Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionaryEdit ► Select()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Overrides ContainerControl.Select(Boolean, Boolean).)
 | Select()()()() | Activates the control.


RtlTranslateAlignment Method

Keyoti RapidSpell Desktop .NET API Docs
RtlTranslateAlignment Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionarySelect ► RtlTranslateAlignment()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
 | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
 | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.


PerformLayout Method

Keyoti RapidSpell Desktop .NET API Docs
PerformLayout Method
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBox ► PerformLayout()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls.
 | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls.


SaveFile Method

Keyoti RapidSpell Desktop .NET API Docs
SaveFile Method
API ► Keyoti.RapidSpell ► AYTRichTextBox ► SaveFile()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | SaveFile(String) | Saves the contents of the RichTextBox to a rich text format (RTF) file.
 | SaveFile(String, RichTextBoxStreamType) | Saves the contents of the RichTextBox to a specific type of file.
 | SaveFile(Stream, RichTextBoxStreamType) | Saves the contents of a RichTextBox control to an open data stream.


GetChildAtPoint Method

Keyoti RapidSpell Desktop .NET API Docs
GetChildAtPoint Method
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBox ► GetChildAtPoint()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
 | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates.


GetChildAtPoint Method

Keyoti RapidSpell Desktop .NET API Docs
GetChildAtPoint Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsOptions ► GetChildAtPoint()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
 | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates.


BeginInvoke Method

Keyoti RapidSpell Desktop .NET API Docs
BeginInvoke Method
API ► Keyoti.RapidSpell ► AYTTextBox ► BeginInvoke()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
 | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.


PerformLayout Method

Keyoti RapidSpell Desktop .NET API Docs
PerformLayout Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsOptions ► PerformLayout()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls.
 | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls.


Show Method

Keyoti RapidSpell Desktop .NET API Docs
Show Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionarySelect ► Show()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Show(IWin32Window) | Shows the form with the specified owner to the user.
 | Show()()()() | Displays the control to the user.


LogicalToDeviceUnits Method

Keyoti RapidSpell Desktop .NET API Docs
LogicalToDeviceUnits Method
API ► Keyoti.RapidSpell.Grid ► DataGridAYTTextBox ► LogicalToDeviceUnits()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | LogicalToDeviceUnits(Int32) |
 | LogicalToDeviceUnits(Size) |


Scale Method

Keyoti RapidSpell Desktop .NET API Docs
Scale Method
API ► Keyoti.RapidSpell.DialogViews ► WindowsFormsUserDictionarySelect ► Scale()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Scale(Single) | Obsolete. Scales the control and any child controls.
 | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls.
 | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor.


SetBounds Method

Keyoti RapidSpell Desktop .NET API Docs
SetBounds Method
API ► Keyoti.RapidSpell ► AYTComboBox ► SetBounds()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size.
 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size.


BeginInvoke Method

Keyoti RapidSpell Desktop .NET API Docs
BeginInvoke Method
API ► Keyoti.RapidSpell ► RegisterForm ► BeginInvoke()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
 | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.


FindString Method

Keyoti RapidSpell Desktop .NET API Docs
FindString Method
API ► Keyoti.RapidSpell ► AYTComboBox ► FindString()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | FindString(String) | Returns the index of the first item in the ComboBox that starts with the specified string.
 | FindString(String, Int32) | Returns the index of the first item in the ComboBox beyond the specified index that contains the specified string. The search is not case sensitive.


Invoke Method

Keyoti RapidSpell Desktop .NET API Docs
Invoke Method
API ► Keyoti.RapidSpell ► AYTRichTextBox ► Invoke()()()()
Keyoti RapidSpell Desktop .NET
Members
Icon | Member | Description
 | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle.
 | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.


RapidSpell Desktop .NET Documentation: Simple Dialog & As-you-type Checking in TX Text Control

Simple Dialog & As-you-type Checking in DevExpress RichEdit control.

Please see the DevExpressRichEdit demo project, which covers as you type and dialog spell checking support. We will be documenting this based on useage so let us know if you're using it and/or need help please (support@keyoti.com).

Simple Dialog & As-you-type Checking in TX Text Control

It may help to refer to the demo projects which are included with the product.

Basic Setup
  1. Open/create a project which uses TX Text Control
  2. Open the form holding TX Text Control, and drag on RapidSpellDialog.
  3. After the InitializeComponent call in the Form's constructor call rapidSpellDialog1.AddTextComponent(textControl1).
  4. Add a button or menu item and start RapidSpellDialog in it's click handler, calling RapidSpellDialog.Check().

At this stage the spell check should work, however a few changes are needed for optimal integration.

ContextMenuStrip for version TX v19+

In v19 TX controls the context menu internally, therefore it is necessary to integrate with it, rather than control it.

  1. Set RapidSpellDialog.ShowSuggestionsContextMenu = false
  2. Add a handler for the TextControl.TextContextMenuOpening event (if a handler doesn't already exist)
  3. In the handler, integrate any spelling suggestions:
        ContextMenuStrip cm = e.TextContextMenu;

    //Get the RS items
    ToolStripItem[] suggestions = rapidSpellDialog1.GetSuggestionsToolStripItems();

    //if there are suggestions (ie if the click was on a spelling error), show them
    if (suggestions != null)
    {
      cm.Items.Add(new ToolStripSeparator());
      cm.Items.AddRange(suggestions);
    }
ContextMenuStrip for versions up to and including TX v18

RapidSpellDialog will need to control the ContextMenuStrip for the Text Control. Therefore, unset the TextControl.ContextMenuStrip property in the designer, to null/Nothing/none. Then set RapidSpellDialog's ContextMenuStripDefault property to the ContextMenuStrip to use when the user clicks away from a spelling error.

In the regular TX Text Control examples, there is a MouseDown event handler, which is used to show the regular 'text context menu'. This should be commented out, so that the context menu strip is not manually shown on the MouseDown event - RapidSpell will take care of this.

In the regular TX Text Control examples, there is a TextFrameRightClicked event handler, which shows the context menu for textframes when the user right clicks on a frame edge. Modify textControl1_TextFrameRightClicked, by adding

//C#
if (rapidSpellDialog1.GetSuggestionsToolStripItems() == null)
{
...
}

'VB.NET
If RapidSpellDialog1.GetSuggestionsToolStripItems() Is Nothing Then
...
End If
around it's contents, so that the menu logic isn't performed when there are spelling suggestions.

Resetting Ignored Words (When Creating/Opening New Documents)

To reset the words that have been ignored for a document, call

rapidSpellDialog1.ResetIgnoredWords()

For example this would normally be done in these methods from the demo project; frmMain_DragDrop, textControl1_DragDrop, FileOpen, FileNew.