RapidSpell WPF Documentation: Terms & Conditions

Terms & Conditions

If you do not agree to these terms and conditions then you may not install, use, or distribute RapidSpell WPF.
1. License and Ownership. RapidSpell WPF is a licensed software product. RapidSpell WPF, including its accompanying files and documentation, is owned and copyrighted by Keyoti Inc., © Copyright 2002-2017, all rights reserved. Keyoti Inc. grants the user in possession of an official receipt of purchase a nonexclusive license to download and use the software, for any lawful commercial or noncommercial purposes provided the terms of this agreement are met.
2. Distribution. If you purchased an Individual License Version of RapidSpell WPF, you may copy and use the RapidSpell WPF distribution file (.zip) on any systems you use but for your individual use only. Individual use is defined as one person having the ability to read or copy any of the files originally contained in the RapidSpell WPF distribution file including (but not limited to) the .dll, .cs, .vb, .html, .gif, .jpg, .bat, and .txt files. You must take appropriate safeguards to protect this product from unauthorized access by others.
If you purchased a Site License Version of RapidSpell WPF, then you may provide copies of the RapidSpell WPF distribution file (.zip) to anyone employed by your company whose primary work address is within a 100 mile (160 km) radius of your primary work address. These individuals then have license rights and responsibilities equivalent to the Individual License Version. In all cases the copies of the RapidSpell WPF distribution file (.zip) must be unaltered and complete, including this license agreement and all copyright notices. You may not reverse engineer, disassemble, decompile, or modify this software or its accompanying documentation in any way.
You may reproduce and redistribute a copy of the dll files as part of any .NET based software developed and licensed by you that itself uses RapidSpell WPF provided
a) your software has clearly distinct and added functionality,
b) you are responsible for all technical support,
c) the RapidSpell WPF application programming interfaces are not documented, exposed, or otherwise made available by your software,
d) attribution is given to Keyoti Inc. (http://www.keyoti.com) in any documentation or screen displays where other credits appear,
e) you do not allow recipients of your software to reverse engineer, disassemble, decompile, or copy portions from your software allowing them to gain separate access to RapidSpell WPF or any parts of it,
f) your software is not used by software developers as part of their application, and
g) your software is not a software component or 'Control'.
The source code samples included with this package and in the RapidSpell WPF documentation may be freely used, modified, incorporated, and distributed without restriction as part of any software that uses RapidSpell WPF itself.
3. Warranty Disclaimer and Limitation of Liability. RapidSpell WPF is licensed to the user on an "AS IS" basis. Keyoti Inc. MAKES NO WARRANTIES, EITHER EXPRESSED OR IMPLIED, WITH RESPECT TO THIS SOFTWARE AND ITS ASSOCIATED FILES AND DOCUMENTATION, INCLUDING BUT NOT LIMITED TO ANY WARRANTY OF MERCHANTABILITY OR FITNESS FOR ANY PARTICULAR PURPOSE. KEYOTI Inc. DOES NOT WARRANT THAT THE OPERATION OF THIS SOFTWARE WILL BE UNINTERRUPTED OR ERROR FREE, OR THAT DEFECTS WILL BE CORRECTED. You the user are solely responsible for determining the appropriateness of this software for your use and accept full responsibility for all risks associated with its use. Keyoti Inc. is not and will not be liable for any direct, indirect, special or incidental damages in any amount including loss of profits or interruption of business however caused, even if Keyoti Inc. has been advised of the possibility of such damages. Keyoti Inc. retains the right to, in its sole discretion, refund the purchase price of this software as a complete and final resolution to any dispute.
SPECIFIC DISCLAIMER FOR HIGH-RISK ACTIVITIES.
The SOFTWARE is not designed or intended for use in high-risk activities including, without restricting the generality of the foregoing, online control of aircraft, air traffic, aircraft navigation or aircraft communications; or in the design, construction, operation or maintenance of any nuclear facility. Keyoti Inc. and its suppliers specifically disclaim any express or implied warranty of fitness for such purposes or any other purposes.
NO LIABILITY FOR CONSEQUENTIAL DAMAGES.
To the maximum extent permitted by applicable laws, in no event shall Keyoti Inc. or its suppliers be liable for any damages whatsoever (including without limitation, damages for loss of business profits, business interruption, loss of information, or other pecuniary loss) arising out of the use of or inability to use this Keyoti Inc. product, even if Keyoti Inc. has been advised of the possibility of such damages. Because some states and jurisdictions do not allow the exclusion or limitation of liability for consequential or incidental damages, the above limitation may not apply to you.
4. Support and Source Code Licensing. Keyoti Inc. does provide formal customer support for RapidSpell WPF for a fee. We also make every effort to ensure the quality of our products, and questions, bug reports, and feature requests are encouraged, please use email. Due to resource limitations, it may not be possible to resolve all issues and no assurances can be given as to when or if problems will be addressed. Customers incorporating RapidSpell WPF into software for deployment or sale are encouraged to purchase the Source Code License Version of RapidSpell WPF which will enable self-support, debugging, and modifications or extensions to the base functionality (but not distribution of the source code itself).


RapidSpell WPF Documentation: Introduction

RapidSpell WPF v4.1.0

Thank you for purchasing RapidSpell, please keep up to date through our website keyoti.com and feel invited to post feedback. We also ask that you register your purchase so that we may offer you support and free upgrades from time to time, at https://keyoti.com/care/register

Overview

RapidSpell consists of 3 spelling components (GUI and non-GUI) which provide for rapid integration within your application. Keyoti has developed these highly granular components with simplicity of application development in mind.

The assembly holds a graphical user interface component, which can be implemented with 2 lines of code to supply complete spell checker functionality (dialog or as-you-type) to any WPF based application and a non-GUI class which provides a clean API for model (business/logic) level integration. Whilst simplicity of use has been a major guiding force in the component design, user customization has not been spared, the GUI can be easily used as a base class and extended to provide UI customization and the non-GUI component provides access to core spell checking functionality.

Common Uses

Spell checking;
  • Strings programmatically
  • WPF text editors (RichTextBox, TextBox)

Requirements

The components were built to .NET 3.0, 3.5, 4.x specification.


RapidSpell WPF Documentation: Release Notes

RapidSpell WPF Release Notes

General Upgrade Notes: As you move from one version to the next it is likely that your licenses.licx file becomes incompatible with the current version. The simplest way to fix this is to edit the licenses.licx file and on each line related to our controls, remove the text after the assembly name, eg.

Keyoti.RapidSpell.Wpf.RapidSpellChecker, Keyoti4.RapidSpell.WPF, Version=4.0.17.1110, Culture=neutral, PublicKeyToken=58d9fd2e9ec4dc0e
can be changed to
Keyoti.RapidSpell.Wpf.RapidSpellChecker, Keyoti4.RapidSpell.WPF

which will allow the licenses.licx file to be used with any version.

4.1.0

Backwards Compatibility
  • Fully compatible with 4.0
Improvements
  • Address outlier bugs.

4.0.0

Backwards Compatibility
  • Please be aware that we have added support for multiple user dictionaries. This means that the end user can click the "Options..." button and then "User Dictionaries" and proceed to add new text files to be used as user dictionaries. The user is NOT permitted to remove the user dictionary assigned via code. To prevent the user adding/removing their own dictionaries, set ShowOptionForMultipleUserDictionaries=false in RapidSpellDialog or OptionsPresenter.
  • If you have a custom Options editor form (ie you are handling the event 'rapidSpellDialog1.CreateDialogViewOptions') then you will need to update the form that implements IDialogViewOptions. Open it and add an event SelectUserDictionary:
         public event EventHandler SelectUserDictionary;
    In the "User Dictionary" button click handler (eg. void userDictionaryBT_Click(object sender, EventArgs e)) change the code to call the new SelectUserDictionary event, eg.
            void userDictionaryBT_Click(object sender, EventArgs e)
        {
            if (SelectUserDictionary != null) SelectUserDictionary(this, e);
        }
Improvements
  • Add user dictionary file manager, so the user can add/remove additional text files to be used as user dictionaries.
  • Performance improvements, for RapidSpellAsYouType with RichTextBox and TextBox controls.
  • Improve user dictionary performance
  • Fix modal window crash with multiple textboxes.
  • Update Dict Manager.
  • Added MaximumNumberOfErrorsToHighlight property to RapidSpellAsYouType, allows limit to be imposed on number of errors underlined, to preserve UI performance.

3.1.0

Improvements
  • Improved performance of RapidSpellAsYouType with RichTextBox.
  • Added RemoveAllTextComponents method to API.
Fix
  • Fix "i i" autocorrection loop.
  • Fix context menu becoming orphaned from a removed textbox.

3.0.1

Improvements
  • Added RapidSpellAsYouType.RemoveAllTextComponents.
Fix
  • Corrected parsing of symbols.

3.0.0

Backwards Compatibility
  • All loaded main dictionaries are now cached and shared between (all instances of) RapidSpellAsYouType and RapidSpellDialog. This improves performance when using the compressed .dict files (the default dictionary is compressed). The ShareDictionary property in the controls has been deprecated and now has no effect.
    The cache can be controlled through static methods
    DictionaryCache.RemoveDictionary
    DictionaryCache.RemoveAllDictionaries
  • The Keyoti.RapidSpellMDict.DLL dictionary is no longer used, by default a compressed US English dictionary is used - to use a different language you can embed the corresponding Dict File (.dict) into your project, please see the dictionaries section of the help for more info.
  • Lowercase i is no longer ignored by default (when LanguageParser==English), to preserve the old behaviour set IgnoreInEnglishLowerCaseI in the controls to true. It is also autocorrected.
  • The context menu now includes an "Ignore" option, therefore GetSuggestionsToolStripItems will also include an Ignore menu option, if you are using this method check that the extra ignore menu item will not harm your code.
New Features
  • Improved typing speed with large texts in RichTextBox.
  • Sentence capitalization correction (auto or manual).
  • Ignore Once added to 'as you type'.
  • Compressed dictionaries.
  • Many small bug fixes and improvements in behavior.

2.0.0

Separation of WPF spell checking codebase from RapidSpell Desktop .NET product v4.7.
New Features
  • As you type checking for rich and plain textboxes
  • Simplified dialog usage
  • Design time controls
  • Custom GUI demos
  • No dependency on RapidSpell Desktop or System.Windows.Forms (as was the case previously)

1.0.0

Initial release, bundled with RapidSpell Desktop .NET v4.


RapidSpell WPF Documentation: Installation

Installation

Running the MSI installer is all that is required to install the controls for development. Initially the controls will be licensed on a time-limited trial basis until a license key is registered through the evaluation splash page.

After installation, the DLLs are made available to the list of assemblies in Visual Studio, from here the controls can be added to the VS toolbar by right clicking in the Toolbox and selecting "Choose Items" and from there selecting the controls in the dialog list.

Referencing Keyoti Assemblies (DLLs)

Standard:
.NET 3, 3.5
Reference Keyoti3.RapidSpell.WPF.DLL (from the DLLs folder)

.NET 4.0
Reference Keyoti4.RapidSpell.WPF.DLL (from the DLLs folder)

Licensing

The controls, components and classes are licensed using the .NET licensing framework. Fundamental to this is the requirement that a file "licenses.licx" is compiled with the project. The licenses.licx files specifies class names and their assemblies, that need referencing. It is important that the assembly name (see below) matches the name of the assembly that the project references. Eg. if referencing Keyoti3.RapidSpell.WPF.DLL then the assembly name in the licenses.licx must be "Keyoti3.RapidSpell.WPF".

Registering The License Key

Either click "Register" in the blue licensing dialog shown when running an unlicensed application, or run the registration application (Control-Register.exe) located under the DLLs folder. Any applications using RapidSpell must subsequently be fully rebuilt (Rebuild Solution) to embed the key properly.

Visual Studio

A licenses.licx file is created (or appended to) when any licensed control is dragged onto the design surface. (The licenses.licx file must be in the project that makes the executable.) However, if the controls are used directly in code, or if the RapidSpellChecker class is used directly then Visual Studio will not create/ append the licenses.licx file. In this case create or open one in the project directory (using Notepad for example - make sure it is called "licenses.licx" and not "licenses.licx.txt"). Include the licenses.licx in the project and set its Build Action to EmbeddedResource. In the licenses.licx file add:

Keyoti.RapidSpell.Wpf.RapidSpellChecker, Keyoti3.RapidSpell.WPF

which follows the standard format

<Class name>, <Assembly name>

After modifying the licenses.licx file it is important to rebuild the solution. The licenses.licx file can contain multiple lines specifying different classes and assemblies.

Note: if a licenses.licx file is copied into the project directory, it must also be added to the VS project.

Note: the licenses.licx file must be in the project that creates the executable, if RapidSpell is used in a usercontrol, the licenses.licx file must still be added to the exe project that uses the usercontrol.

Command-line compiler

lc.exe is used to compile a text file (like licenses.licx) into a resource, from there the resource can be compiled into the final executable, please see the .NET documentation and Non Visual Studio examples for help.

lc /target:Form.exe /complist:licenses.licx /i:Keyoti3.RapidSpell.WPF.DLL

csc /res:Form1.exe.licenses /target:exe /reference:Keyoti3.RapidSpell.WPF.DLL Form1.cs

Deployment

RapidSpell WPF complies with the "XCopy deployment" standard which means that deployment is simply a matter of ensuring that the RapidSpell WPF DLLs used are deployed with the executable or installed into the GAC. The DLLs that you choose to deploy is dependent on which controls you have used, typically only Keyoti3.RapidSpell.WPF.DLL and Keyoti.RapidSpellMDict.DLL need to be deployed.

Special considerations are:

-Any ".dict" files used (eg. via the DictFilePath properties) must be deployed also.

-The .NET licensing mechanism does NOT allow the name of the executable to be changed after it has been compiled - doing so will invalidate all licenses.


Quick Start - As You Type Usage

Quick Start - AsYouType

Step 1
Step 2
Step 3
Step 4
Step 5

Step 1. Get your project ready (load or create it).

Step 2

Step 2. Add the RapidSpell Controls to your ToolBox

(if you have older versions listed, please remove them).

Step 3

Step 3. Drag the rapidSpellAsYouType Control onto your Form and add a TextBox.

Step 4

Step 4. Set the TextBox property in rapidSpellAsYouType1 to your TextBox.

a. Click on the Advanced Properties box

b. Click 'Apply Data Binding'

c. Select 'ElementName' and your TextBox

Or set the control property in XAML

TextBox="{Binding ElementName=richTextBox1}"

Step 5

Step 5. Run!

Note:

To offer an "Add" function to the user, set the UserDictionaryFile property to the file path where the dictionary should be stored (eg. "user-dictionary.txt").


Quick Start - Dialog Usage

Quick Start - Dialog mode

Step 1
Step 2
Step 3
Step 4
Step 5
Step 6

Step 1. Get your project ready (load or create it).

Next

Step 2. Add the RapidSpell Controls to your ToolBox

(if you have older versions listed, please remove them).

Next

Step 3. Drag the RapidSpellDialog Control onto your Form, name it rapidSpellDialog1, (eg. add Name="rapidSpellDialog1") and then add a TextBox.

Next

Step 4. Set the TextBox property of rapidSpellDialog1 to your TextBox.

a. Click on the Advanced Properties box

b. Click 'Apply Data Binding'

c. Select 'ElementName' and your TextBox

Or set the control property in XAML

TextBox="{Binding ElementName=richTextBox1}"

Next

Step 5. Add a button to the form and call Check() in the click event.

Next

Step 6. Run!

Note:

To offer an "Add" function to the user, set the UserDictionaryFile property to the file path where the dictionary should be stored (eg. "user-dictionary.txt").

Users can edit the word being checked using the dialog form and replace it with their own.


RapidSpell WPF Documentation: RapidSpellDialog

RapidSpellDialog

The RapidSpellDialog control conveniently wraps access to the RapidSpellGUIPresenter class providing dialog spell checking functionality for WPF with single or multiple text boxes.

This control mirrors most properties and methods available in RapidSpellGUIPresenter. Some members of note are below (please consult API docs for more info):
Properties
Options | - the users options
TextBox | - the TextBox to be checked
TextBoxBasesToCheck | - an array of TextBoxBases to be checked (also see AddTextComponent method)
ThirdPartyTextComponentToCheck | - a 3rd party component to be checked
ThirdPartyTextComponentsToCheck | - an array of 3rd party components to be checked (also see AddTextComponent method)
Modal | - whether to spell check modally
SuggestSplitWords | - whether to suggest split words (eg. thistime -> this time)
SuggestionsMethod | - the suggestions method in use (hashing or phonetic)
GUILanguage | - the text language used in the GUI
IgnoreXML | - whether to ignore XML or HTML tags
ShowFinishedBoxAtEnd | - whether to show a spell check finished box at end
IgnoreCapitalizedWords | - whether to ignore capitalized words
IncludeUserDictionaryInSuggestions | - whether to include user dictionary words in suggestions
LookIntoHyphenatedText | - whether to consider hyphenated parts as individual words
UserInterfaceFormProvider | - allows customized user interfaces to be used
Methods
Check() | - runs the spell checker dialog
AddTextComponent(...) | - adds a TextBox, RichTextBox or ISpellCheckableTextComponent to be spell checked
RemoveTextComponent(...) | - removes a TextBox, RichTextBox or ISpellCheckableTextComponent from the list to be spell checked
Events
SpellCheckStarted | - fired when checking starts
SpellCheckStartedTextBox | - fired when spell check starts on a text box (used in multiple text box checking situations)
SpellCheckFinished | - fired when checked ends
SpellCheckFinishedTextBox | - fired when spell check starts on a text box (used in multiple text box checking situations)
WordAdded | - fired when word added to user dictionary
WordChanged | - fired when word changed
WordIgnored | - fired when word ignored
CreateDialogView | - allows customization of the UI by replacing the form used in the dialog
CreateDialogViewOptions | - allows customization of the UI by replacing the form used in the dialog
CreateDialogViewUserDictionaryEdit | - allows customization of the UI by replacing the form used in the dialog
RecheckDocumentRequest | - user has requested the document be rechecked


RapidSpell WPF Documentation: RapidSpellAsYouType

RapidSpellAsYouType

The RapidSpellAsYouType control provides "as-you-type" spell checking and autocorrect functionality for System.Windows.Controls.TextBox and RichTextBox. Only one RapidSpellAsYouType control is required to check multiple text boxes per form.

Some members of note are (please consult API docs for more info):

Properties
CheckAsYouType | - whether to spell check words as the user types/modifies text.
CheckCompoundWords | - whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
ConsiderationRange | - sets the factor for words to consider for suggestions, lower values are faster but consider less words for suggestions. Default is 80. If w <= 1 this method won't do anything.
DictFilePath | - optional file path to the main dictionary .dict file to use.
GUILanguage | - the language to show the UI in.
IgnoreCapitalizedWords | - whether to ignore words with capital letters.
IncludeUserDictionaryInSuggestions | - whether the user dictionary should be used in finding suggestions for misspelt words.
LanguageParser | - the type of language parsing to use.
LookIntoHyphenatedText | - whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
Options | - the users options.
SeparateHyphenWords | - whether to treat hyphenated (-) words as separate words, default is false.
SuggestionsMethod | - the suggestions method to use.
SuggestSplitWords | - whether to look for connected words in suggestions.
TextBox | - the TextBox or RichTextBox to check as the user types/ modifies text.
UnderlineColor | - the underline color to use with mis-spelt words.
UserDictionaryFile | - the user dictionary file, if this file doesn't exist it will be created.
Methods
AddTextComponent | - adds a text component to the list being checked.
AutoCheckAllTextComponentsUnder | - adds all eligible text components found inside a control.
ForceCheckAll | - forces a check of the whole document.
RepaintUnderlines | - repaints the underlines, this should be called if any changes are made to layout, such as changes to font sizes, etc.
Events
SpellCheckFinished | - fired when checking finishes.
SpellCheckStarted | - fired when checking starts
SpellContextMenuRequest | - fired when context menu should be shown, allows customization of spelling context menu
WordAdded | - fired when word added to user dictionary
WordChanged | - fired when word changed
WordsEntered | - fired when words are entered by the user
WordIgnored | - fired when word ignored

AYTInkEdit

As you type enabled subclass of the InkEdit (from the Tablet SDK). Available in the "Tablet Ink SDK Support" sub folder - requires the Tablet SDK be installed.

Implementation

Please see the 'Examples' section of this manual.


RapidSpell WPF Documentation: RapidSpellAYTDialogCoupler

RapidSpellAYTDialogCoupler

Quickly and simply couples RapidSpellAsYouType and RapidSpellDialog to provide a cohesive end user experience (i.e. Ignore All in RapidSpellDialog will Ignore All in RapidSpellAsYouType). Design time use is easy, drop the RapidSpellAYTDialogCoupler component onto the design surface and set the RapidSpellAsYouType and RapidSpellDialog properties to the RapidSpellAsYouType and RapidSpellDialog controls already on the form.


RapidSpell WPF Documentation: Main DLLs

Main DLLs

.NET 3.x

Keyoti3.RapidSpell.WPF.DLL contains the main controls for .NET 3.x use.

.NET 4.x

Keyoti4.RapidSpell.WPF.DLL contains the main controls for .NET 4.x use.


RapidSpell WPF Documentation: Dictionaries

Dictionaries

RapidSpell can use 2 different types of dictionary at once; The "main dictionary" and a "user dictionary".

Main Dictionary

Included are AU, CA, UK and US English dictionaries, each containing ~110K words, a combined UK and US dictionary containing ~115K words. These are located in the Dictionaries folder under the install folder.

Keyoti offer a number of non-English dictionaries. Further details and evaluation versions are available at;

https://keyoti.com/products/rapidspell/dotNet/dictionaries.html

Choosing The Main Dictionary

  • RapidSpell uses it's own proprietary compressed/uncompressed dictionary format, these dictionaries are called Dict Files.
  • By default, when a Dict File is not specified, the built-in US English dictionary is used.
  • To use a Dict File set the DictFilePath property (of any spell check control) to the path of the Dict File to be used.
  • Files with '.2.dict' in their name are compressed. Due to decompression they do load slightly slower than the uncompressed versions.
As An Embedded Resource

Embedding the Dict File as a resource is the cleanest way to distribute the dictionary, the dictionary is included in your DLL or EXE, and does not have to be packaged separately. The only disadvantage is that the dictionary cannot be changed (using Dict Manager) without recompiling the application.

  1. Add the Dict File of your choice to your project.
  2. In the properties pane for the Dict File, set it as a Resource (be careful not to set as Embedded Resource)
  3. Set the DictFilePath in the spell check controls or RapidSpellChecker to the name of the Dict File (in the screen-shot that would be 'DICT-EN-UK-UKEnglish.2.dict')

Notes:

  1. If the Dict File is in a subdirectory, specify it before the file name, eg. DictFilePath="dictionaries/DICT-EN-UK-UKEnglish.2.dict"
  2. The spell checker will use the standard pack URI, i.e. "pack://application:,,,/" + DictFilePath to load the dict file from the resource manager.
  3. If the Dict File is embedded in a different assembly (than the one RapidSpell is running from), specify the DictFilePath according to this format (as outlined here):
    DictFilePath = "DictionaryLibrary1;component/dictionaries/DICT-EN-MED-Medical-EVALUATION-VERSION.dict";
    where 'DictionaryLibrary1' is the name of the assembly that the dictionary is embedded in, and 'dictionaries' is the folder in the DictionaryLibrary1 project that holds the Dict File.
As An External File

With this style of usage you deploy the Dict File with your application as a separate file. You are in total control of how and where the Dict File is deployed, and must set the DictFilePath property of the controls to point to that location, ideally this should be done before the Check method is called (with RapidSpellDialog), to prevent redundant dictionary loading.

The DictFilePath property can be set as a relative path (relative to the EXE) or an absolute file path.

Dictionary Customization

It is possible to customize the dictionaries and create new ones using the convenient Dict Manager tool included in RapidSpell WPF, please load the tool and consult the help system provided in it for more details.

The Dict Manager tool included in RapidSpell WPF

Programmatic Use Of Dict Manager
To use Dict Manager programmatically:
  • Reference DictManager.exe in your project (when you browse for the assembly, just change the file type to *.exe in the open dialog).
  • Create an instance: model = new DictManager.DictManagerModel();
  • Use any of the API calls:
CreateDict		Creates a new dict file
LoadDict		Loads an existing dict file
AddWord			Adds a word to current open dict file
MergeDictFile		Merges an existing dict file with the open dict file
MergeTextFile		Merges an existing text file with the open dict file
RemoveWord		Removes a word from the dict file
LookUp			Checks if a word is in the dict file
SaveDict		Saves the currently open dict file

Typical usages should be in the following order;

create or load

modifying operations

save.

User (Custom) Dictionaries / Add Button

To offer an "Add" function to the user, set the UserDictionaryFile property in either spell checking control to the file path where the dictionary should be stored (eg. "user-dictionary.txt"). If the file path specified is valid, the Add option will be enabled. If the file does not exist (but the path is valid) then the file will be created. The user dictionary is a simple UTF-8 text file with words listed one per line (it is not a .dict file and isn't created by 'Dict Manager'). The user dictionary is suited best to relatively short lists added to by the user. If a large list (order of thousands) of custom words needs to be added, it is suggested that they are added to the main dictionary using Dict Manager.

The Options form (via the 'Options...' button in the dialog spell check) allows the user to edit the user dictionary and also add/remove additional user dictionary files. To prevent this, set ShowOptionForMultipleUserDictionaries=false in RapidSpellDialog or OptionsPresenter.

To add multiple user dictionaries programmatically;

            var u = new Keyoti.RapidSpell.Wpf.MultiFileUserDictionary(new List());
            u.AddFile(@"test1.txt");
            u.AddFile(@"test2.txt");
            u.SetDefaultUserDictionaryFile(@"test1.txt");
            rsayt.RapidSpellChecker.SetUserDictionary(u);

It is important to call SetDefaultUserDictionaryFile, it assigns the dictionary that will be used when the user clicks Add. Without this the user dictionaries will not be used.

A Note About Main Dictionary Size

Understandably, many developers look to dictionary size as a metric for how good a spell checker is. However, the relationship is not that simple. There are many many words that can be grouped as part of the English language, especially when consideration is made for the history of English, how it has changed and been influenced by other languages (eg. French). If a spell checker dictionary is very large (ie hundreds of thousands of words) then it will include archaic and unusual spellings, scientific terms etc. which may be problematic during spell checking; a common misspelling may be accepted because it matches an unusual spelling or word. For example, consider "wonned", it is accepted by Merrium Webster as an archaic spelling for the past tense of "win". Clearly "wonned" is generally not acceptable in modern English, and it should be corrected as "won" - but a very large dictionary would accept it.


RapidSpell WPF Documentation: User Options

User Options

The options form (in RapidSpellDialog or invoked programmatically) allows the user to store their own spell check preferences and also edit their user dictionary.

By default, user options are enabled and stored under .NET's IsolatedStorage. It's important to remember that user options (if enabled) will override the properties set in the spell checker controls (eg. RapidSpellAsYouType.CheckAsYouType = true will have no effect if the user has disabled check as you type).

Ensure that any of the settings specified below are made in both RapidSpellDialog and RapidSpellAsYouType as one will override the other if used with RapidSpellAYTDialogCoupler.

Disabling User Options

Set OptionsEnabled in the RapidSpellDialog and/or RapidSpellAsYouType control.

Programmatically Setting User Options

Call SetUserOptions on the options object and pass the values that should be used. Then call Save to write the changes. In this example we use the existing values (so no changes are made).
Dim o As Options.UserOptions = rapidSpellDialog1.Options
rapidSpellDialog1.Options.SetUserOptions(o.CheckAsYouType, o.IncludeUserDictionaryInSuggestions, _
    o.IgnoreWordsWithDigits, o.IgnoreURLsAndEmailAddresses, o.IgnoreCapitalizedWords, _
    o.AllowMixedCase, o.AllowAnyCase, o.FindSuggestions, False)
rapidSpellDialog1.Options.Save()
Eg. To change the "Check as you type" option, replace o.CheckAsYouType with either true or false.

Changing Storage Location

Set OptionsStorageLocation to either IsolatedStorage (default), FileSystem or Stream see below.

Maintaining Separate Options Profiles

Set OptionsFileName in the RapidSpellDialog and/or RapidSpellAsYouType control to a unique name for each separate set of options to use.

Reseting / Deleting Options

Call UserOptions.Delete() to empty the file and allow the default options to be recreated. Eg. RapidSpellDialog.Options.Delete()

Launching Options Editor Programmatically

  1. Create an instance of Keyoti.RapidSpell.Wpf.Options.OptionsPresenter
  2. Call it's Show method with the UserOptions instance
  3. If Show returns true, then save the UserOptions object
  4. To prevent the user from adding multiple user dictionaries, set optionsPresenter.ShowOptionForMultipleUserDictionaries = false
  5. To prevent the user from editing user dictionaries at all, set optionsPresenter.ShowUserDictionaryButton = false

Eg.
            OptionsPresenter optionsPresenter = new OptionsPresenter();
            if (optionsPresenter.Show(this, rapidSpellAsYouType1.Options))
            {
                rapidSpellAsYouType1.Options.Save();
            }

How To Use A Custom Stream For Storage

Events are available which can be used to determine when to prepare a stream to read/write to.

For example, to use a custom stream to write to an XML file;

.........
       Public Sub New()
        MyBase.New
        InitializeComponent
        rapidSpellAsYouType1.OptionsStorageLocation = Keyoti.RapidSpell.Wpf.Options.UserOptions.StorageType.Stream
        rapidSpellDialog1.OptionsStorageLocation = Keyoti.RapidSpell.Wpf.Options.UserOptions.StorageType.Stream
        Dim options As Keyoti.RapidSpell.Wpf.Options.UserOptions = New Keyoti.RapidSpell.Wpf.Options.UserOptions
        options.StorageLocation = Keyoti.RapidSpell.Wpf.Options.UserOptions.StorageType.Stream
        AddHandler options.NeedCustomStreamForSaving, AddressOf Me.NeedSaveStream
        AddHandler options.NeedCustomStreamForLoading, AddressOf Me.NeedLoadStream
        AddHandler options.OptionsSaved, AddressOf Me.options_OptionsSaved
        options.Load
        rapidSpellAsYouType1.Options = options
        rapidSpellDialog1.Options = options
        rapidSpellAsYouType1.TextBox = Me.aytTextBox1
    End Sub

    Private Sub options_OptionsSaved(ByVal sender As Object, ByVal e As Keyoti.RapidSpell.Event.OptionsSavedEventArgs)
        'update the DB?
    End Sub

    Private Sub NeedSaveStream(ByVal sender As Object, ByVal e As Keyoti.RapidSpell.Wpf.Options.NeedStreamEventArgs)
        e.RequiredStream = New System.IO.FileStream("c:\useropt.xml", System.IO.FileMode.Truncate, System.IO.FileAccess.Write)
    End Sub

    Private Sub NeedLoadStream(ByVal sender As Object, ByVal e As Keyoti.RapidSpell.Wpf.Options.NeedStreamEventArgs)
        e.RequiredStream = New System.IO.FileStream("c:\useropt.xml", System.IO.FileMode.OpenOrCreate)
    End Sub
.........
NOTE:

1. RapidSpellAsYouType.TextBox must be set AFTER options.Load. This is because otherwise the options are loaded from the default location as soon as the textbox is set.

2. You can use the OptionsSaved event to write the stream's contents to a DB instead.


RapidSpell WPF Documentation: RapidSpellGUIPresenter

RapidSpellGUIPresenter

The RapidSpellGUIPresenter has a 100% customizable UI (IDialogView), provides user dictionary functionality, is multi-threaded and is extremely simple to use. The interface has a familiar layout and functionality.

RapidSpellGUIPresenter will interactively check any TextBoxBase derived class, this includes TextBox, RichTextBox and their sub-classes. When invoked in an application the component will query the user on each misspelled word allowing the following functions;

Ignore
Ignore All occurrences of misspelt word
Add to user dictionary if provided
Change misspelt word to suggestion or user amended text
Change All occurrences of misspelt word
Undo last action
Options editor with user dictionary edit
Cancel

The GUI checks selections (querying to continue when finished), wraps from current caret position back to current caret position and handles the user editing the text in your application while checking is in progress.

Please see later sections for details on customizing the UI and the API documentation for member information.


RapidSpell WPF Documentation: RapidSpellChecker

RapidSpellChecker

Provides a model (business/logic) level spell checker API which can be used in a client-server environment and any applications where a client GUI does not exist. User dictionaries can optionally be used, allowing words to be added. This component can be used in 2 different ways, in an iterative fashion or on a query by query basis. Please see the API docs for code level details.

Using RapidSpellChecker in an iterative manner provides complete textual correction of strings similar to a GUI based spell checker. A string is loaded into RapidSpellChecker and then successive calls to the NextBadWord() method move through the string allowing FindSuggestions() and ChangeBadWord(replacement) to be called to find spelling suggestions and optionally correct the misspelt words in the text, finally GetAmendedText() returns the corrected text.

Alternatively RapidSpellChecker may be used in a simple query by query basis, calls to LookUp(word) and FindSuggestions(word) methods allow bare bones spell checking functionality.

Key API Points

Methods
RapidSpellChecker() | - argumentless constructor
Check(text [, startPosition]) | - begins checking text
FindSuggestions(word) | - finds suggestions for word
LookUp(word) | - checks if word is in either main or user dictionaries
SetUserDictionary(file) | - allows you to define which file will be used as a user dictionary
IgnoreAll(word) | - ignores all future occurrences of word
AddWord(word) | - adds word to the user dictionary if it exists
NextBadWord() | - finds the next misspelt word in the text
ChangeBadWord(newWord) | - changes the misspelt word last identified by NextBadWord()
GetAmendedText() | - returns the corrected text
FindCompoundWords(text, list) | - adds compound words in text string
FindAnagrams(word, list) | - adds anagrams of word to list
Properties
DictFilePath | - the path to a .dict dictionary file.
LanguageParser | - the language parser to be used (LanguageType.ENGLISH, LanguageType.FRENCH....)
IgnoreXML | - whether to ignore XML tags
ModalMode | - whether to operate modally
SuggestSplitWords | - whether to suggest split words, eg. "myhouse" -> "my house"
CheckCompoundWords/font> | - whether to check unknown words for compound forms
LookIntoHyphenatedText | - whether to treat hyphens as word separators

Query by Query Usage Sequence Diagram

Iterative Usage Sequence Diagram

See Examples section for details.


RapidSpell WPF Documentation: Dialog Spell Checking

Dialog Spell Checking

To use the GUI dialog spell checker control (RapidSpellDialog) as an integral part of your application simply instantiate it, set the text component you wish this GUI to spell check and call Check(), which will bring up this component in a new Window allowing the user to correct their document in the TextBoxBase derived class.

Code Example

    <Menu IsMainMenu="True" Height="23" VerticalAlignment="Top">
        <MenuItem Header="_Options">
            <MenuItem Name="spellCheckingMenu" Header="Spell check..."
                        Click="spellCheckingMenu_Click" />
        </MenuItem>
    </Menu>

    <RichTextBox Height="359" Name="richTextBox1" Width="auto" Margin="0,20,0,0" />

    <my:RapidSpellDialog
    UserDictionaryFile="..\..\userdictionary.txt"
    TextBox="{Binding ElementName=richTextBox1}"
    Height="28"
    HorizontalAlignment="Right"
    Margin="0,-25,0,0"
    Name="rapidSpellDialog1"
    VerticalAlignment="Top"
    Width="86"
    xmlns:my="clr-namespace:Keyoti.RapidSpell.Wpf;assembly=Keyoti3.RapidSpell.WPF" />


RapidSpell WPF Documentation: Custom RapidSpellDialog User Interface

Custom RapidSpellDialog User Interface

Layout/Style

It is easy to customize the UI used by the RapidSpellDialog control. The example projects include full source code for the default UIs, which can be modified by hand or in the Visual Studio designer. It's also possible to implement the lightweight IDialogView interface from scratch and use any class as a UI (eg. built on 3rd party forms).

Assuming IDialogView has been implemented already (see demos), the class is used by handling the CreateDialogView event in RapidSpellDialog, and setting an instance of the class (which implements IDialogView) in the event argument's NewView property.

C#

    private void rapidSpellDialog1_CreateDialogView(object sender,
                        Keyoti.RapidSpell.Event.CreateDialogViewEventArgs e)
    {
         e.NewView = new CustomGUIView();
    }

VB.NET

    Sub rapidSpellDialog1_CreateDialogView(ByVal sender As System.Object, _
        ByVal e As Keyoti.RapidSpell.Event.CreateDialogViewEventArgs) Handles _
        rapidSpellDialog1.CreateDialogView
        e.NewView = New CustomGUIView
    End Sub

The above assumes that CustomGUIView is a class implementing IDialogView.

Options And User Dictionary Editor

Similarly, the CreateDialogViewOptions and CreateDialogViewUserDictionaryEdit events allow substitution of the default UIs for option and user dictionary editing. Please see the demo projects for full source.

Behavior

It is easy to customize the UI behavior used by the RapidSpellDialog control. This is done by subclassing "RapidSpellGUIPresenter" which is the logic behind the RapidSpellDialog user interface. RapidSpellGUIPresenter has methods which react to user input and also controls the Form, which it holds in it's "DialogView" property (this is actually the instance returned via the "CreateDialogView" event, see above).

To use a subclass of RapidSpellGUIPresenter, handle the RapidSpellDialog.CreateUserInterfaceFormPresenter event.

C#

    private void rapidSpellDialog1_CreateUserInterfaceFormPresenter(object sender,
                    Keyoti.RapidSpell.Event.CreateUserInterfaceFormPresenterEventArgs e)
    {
       e.NewPresenter = new CRapidSpellGUIPresenter();
    }

VB.NET

    Sub rapidSpellDialog1_CreateUserInterfaceFormPresenter(ByVal sender As System.Object, _
        ByVal e As Keyoti.RapidSpell.Event.CreateUserInterfaceFormPresenterEventArgs) Handles _
        rapidSpellDialog1.CreateUserInterfaceFormPresenter
        e.NewPresenter = new CRapidSpellGUIPresenter()
    End Sub

This sets the instance of the RapidSpellGUIPresenter subclass "CRapidSpellGUIPresenter" in the event property.

Consult the API docs (under namespaces) for details of the various methods which can be overridden. As an example, consider the case where the "change" buttons should be disabled when there are no suggestions. The CRapidSpellGUIPresenter class would look like this.

C#

    public class CRapidSpellGUIPresenter : RapidSpellGUIPresenter
    {

        protected override void Resume()
        {
            base.Resume();
            System.Collections.ArrayList suggs;
            suggs = CheckerEngine.FindSuggestions();

            DialogView.ChangeAllButtonEnabled = suggs.Count > 0;
            DialogView.ChangeButtonEnabled = suggs.Count > 0;

        }
    }

The Resume method is called every time a word is shown as an error to the user, and the opportunity is taken to look at how many suggestions there are (using the CheckerEngine property). When there are no suggestions the change buttons are disabled (note how they are accessed via the DialogView property, which returns the IDialogView instance in use).


RapidSpell WPF Documentation: As-You-Type Checking (RapidSpellAsYouType)

As-You-Type Checking (RapidSpellAsYouType)

To use the as-you-type checker, RapidSpellAsYouType with one or many text boxes should be fairly simple. RapidSpellAsYouType can work with any TextBoxBase derived text box (e.g. standard WPF textboxes) and any class which implements IAYTTextBox.

Example Code

Minimal requirements for as-you-type checking with RichTextBox.

    <RichTextBox Height="359" Name="richTextBox1" Width="auto" Margin="0,20,0,0" />

        <my:RapidSpellAsYouType
        TextBox="{Binding ElementName=richTextBox1}"
        Height="28"
        HorizontalAlignment="Right"
        Margin="0,-25,0,0"
        Name="rapidSpellAsYouType1"
        VerticalAlignment="Top"
        Width="86"
        xmlns:my="clr-namespace:Keyoti.RapidSpell.Wpf;assembly=Keyoti3.RapidSpell.WPF" />

Use the AddTextComponent method in code-behind to add additional textboxes to check.

Use inside TabControl

Use as usual, but add an AdornerDecorator element around the TabItem contents - otherwise (due to a bug in WPF) the underlines will disappear when switching tabs.

Eg.
    <TabItem Header="tabItem1" Name="tabItem1">
        <AdornerDecorator>
            <RichTextBox Height="108" Name="richTextBox1" VerticalScrollBarVisibility="Visible" Width="621">
                <RichTextBox.ContextMenu>
                    <ContextMenu />
                </RichTextBox.ContextMenu>
                <RichTextBox.Document>
                    <FlowDocument FontFamily="Batang" FontSize="12pt">
                        </FlowDocument>
                </RichTextBox.Document>
            </RichTextBox>
        </AdornerDecorator>
    </TabItem>


RapidSpell WPF Documentation: As You Type ContextMenu Customization

As You Type ContextMenu Customization

To use the spell checker's suggestion items in an externally provided ContextMenu

  1. Set RapidSpellAsYouType.ShowSuggestionsContextMenu = false
  2. Set RapidSpellAsYouType.ShowCutCopyPasteOnTextBoxBase = false (if working with a .NET TextBox)
  3. Add a ContextMenu to the form and assign it to the text editor and handle it's Opened event
  4. In the event handler, use GetSuggestions to obtain spelling suggestions and construct the menu.
            private void textBoxContextMenu_Opened(object sender, RoutedEventArgs e)
        {
            textBoxContextMenu.Items.Clear();
            MenuItem m = new MenuItem();
            m.Header = "A custom menu item";

            MenuItem m2 = new MenuItem();
            m2.Header = "Another custom menu item";

            textBoxContextMenu.Items.Add(m);
            textBoxContextMenu.Items.Add(m2);

            object[] spellItems = rapidSpellAsYouType1.GetSuggestions();
            if (spellItems != null)
            {
                textBoxContextMenu.Items.Add(new Separator());
                foreach (object s in spellItems)
                    textBoxContextMenu.Items.Add(s);
            }
        }


RapidSpell WPF Documentation: Autocorrect Customization And International Support

Autocorrect Customization And International Support

RapidSpellAsYouType includes an autocorrector (which can be disabled by setting RapidSpellAsYouType.AutoCorrectEnabled=false) for English.

The RapidSpellAsYouType.AutoCorrectionMap is a Hashtable linking user entries to substitutions. This can be modified as desired when the form is created.

Eg.

rapidSpellAsYouType1.AutoCorrectionMap["vb"] = "Visual Basic";
will cause the text "vb" to be changed to "Visual Basic" when the user enters it.

In this way, auto correction lists for any language can be used.


RapidSpell WPF Documentation: RapidSpellDialog + RapidSpellAsYouType

RapidSpellDialog + RapidSpellAsYouType

To provide a coherent user experience when both RapidSpellDialog and RapidSpellAsYouType check the same text box, it is necessary to use the RapidSpellAYTDialogCoupler component. This component (which can be added to the IDE tool box) is a simple way to connect the 2 types of spell checkers, ensuring that modifications made in one, are reflected in the other. For example, if the user clicks "Ignore All" in the as-you-type spell checker, then that word should also be ignored in the dialog checker.

Example XAML

<my:RapidSpellAYTDialogCoupler
            RapidSpellAsYouType="{Binding ElementName=rapidSpellAsYouType1}"
            RapidSpellDialog="{Binding ElementName=rapidSpellDialog1}"
            Height="28" Margin="241,-25,184,0"
            Name="rapidSpellAYTDialogCoupler1"
            VerticalAlignment="Top"
            xmlns:my="clr-namespace:Keyoti.RapidSpell.Wpf;assembly=Keyoti3.RapidSpell.WPF" />
Or, set the properties in codebehind:

Example codebehind

//c#
rapidSpellAYTDialogCoupler1 = new RapidSpellAYTDialogCoupler();
rapidSpellAYTDialogCoupler1.RapidSpellDialog = rapidSpellDialog1;
rapidSpellAYTDialogCoupler1.RapidSpellAsYouType = rapidSpellAsYouType1;

'VB.NET
rapidSpellAYTDialogCoupler1 = New RapidSpellAYTDialogCoupler()
rapidSpellAYTDialogCoupler1.RapidSpellDialog = rapidSpellDialog1
rapidSpellAYTDialogCoupler1.RapidSpellAsYouType = rapidSpellAsYouType1


RapidSpell WPF Documentation: Non-GUI Spell Checker

Non-GUI Spell Checker

The RapidSpellChecker component is of particular use in non-GUI scenarios. Below is a very simple excerpt of how this component can be used.

Code Example

.........
    RapidSpellChecker c = new RapidSpellChecker();
    BadWord badWord;
    ArrayList suggestions;

    //check some text.
    c.Check("This is sume text.");

    //iterate through all bad words in the text.
    while((badWord = c.NextBadWord())!=null){

        Console.WriteLine(badWord.GetWord() +
            "- is not spelt correctly. Suggestions:");

        try{
            //get suggestions for the current bad word.
            suggestions = c.FindSuggestions();

            //display all suggestions.
            for(int i=0; i<suggestions.Count; i++){
                Console.WriteLine(suggestions[i]);
            }

            //change the bad word in the text with "replacement".
            c.ChangeBadWord("replacement");
        } catch (NoCurrentBadWordException e){
            Console.WriteLine(e);
        }
    }
    Console.WriteLine(c.GetAmendedText());
.........


RapidSpell WPF Documentation: Ignore Pattern Customization

Ignore Pattern Customization & Email/URL Addresses

The IgnoreURLsAndEmailAddresses property/option can be used to make the spell checker ignore these types of strings. A built in regex does this matching, however for performance reasons it does not match every known top level domain (eg. .no), and also will not match custom domains.

The AddIgnorePattern method allows customization of the patterns that are ignored, this can be applied to most strings, not just domains.

Eg. to also ignore .no and .ro domains, call this

C#
string pattern = @"[a-zA-Z0-9]+(?:[a-zA-Z0-9\-\.]+)?\.(?:no|ro){1,2}";

(rapidSpellDialog.CheckerEngine as RapidSpellChecker).AddIgnorePattern(pattern);
rapidSpellAsYouType.RapidSpellChecker.AddIgnorePattern(pattern);
VB.NET
Dim pattern As String = "[a-zA-Z0-9]+(?:[a-zA-Z0-9\-\.]+)?\.(?:no|ro){1,2}"
CType(rapidSpellDialog.CheckerEngine,RapidSpellChecker).AddIgnorePattern(pattern)
rapidSpellAsYouType.RapidSpellChecker.AddIgnorePattern(pattern)


RapidSpell WPF Documentation: Suggestions Algorithm

Suggestions Algorithm

It is possible to choose (programmatically) the algorithm used to find suggestions for spelling errors, there are two algorithms on offer, 'hashing' (default) and 'phonetic'. Each algorithm has it's own advantages and disadvantages;

Hashing (default): Very fast, roughly 40 times faster than the phonetic algorithm, works best on typographic errors and common spelling mistakes. Similar to most spell checker suggestions.

Phonetic (Sounds like, English only): Slower, works well with genuine attempts to spell correctly, works poorly with typographic errors. Can appear to produce wild results, although results do sound like the word in question. Does not work with non English languages. Unusual.

It is recommended that you choose the suggestions algorithm in line with your target audience. The phonetic algorithm, although appearing worse overall, is more suited for people who have not spoken English for very long, e.g. non native English speakers and children.


RapidSpell WPF Documentation: Consideration Range

Consideration Range

The hashing suggestion algorithm is very fast because it accurately cuts down the list of words to look at as possible suggestions. The factory default consideration range is 80, which provides optimal speed with a loss of only a fraction of possible suggestions. It is possible to set the consideration range through the RapidSpellDialog, RapidSpellAsYouType, RapidSpellGUI and RapidSpellChecker classes. The relationship between speed, number of suggestions and consideration range is shown below.


RapidSpell WPF Documentation: Conclusion

Conclusion

Thank you for using the RapidSpell component, we hope that you experience much success with it. Keyoti is committed to improving all of it's products and truly values customer feedback of any kind. If you would like to contact us about any of our products please do so through our web site.

http://www.keyoti.com/contact.html

We thrive on suggestions for components and feature requests, if you have a component wish please don't hesitate to get in touch, it may be the next thing we develop!


Knowledge Base

Open in a new window


Support Forum

Open in a new window


API

Keyoti RapidSpell WPF API Docs
API
API
Keyoti RapidSpell WPF
RapidSpell WPF Control
Namespaces
Namespace | Description
Keyoti.RapidSpell.Compression.Wpf |
Keyoti.RapidSpell.Wpf | The core namespace for RapidSpell.
Keyoti.RapidSpell.Wpf.DialogViews |
Keyoti.RapidSpell.Wpf.Event | The namespace for events.
Keyoti.RapidSpell.Wpf.FrameWorkSpecific | The namespace for RapidSpell Desktop .NET specific classes.
Keyoti.RapidSpell.Wpf.Options |

Send comments on this topic to support@keyoti.com

2005-2014 Keyoti Inc.


Keyoti.RapidSpell.Compression.Wpf Namespace

Keyoti.RapidSpell.Compression.Wpf Namespace
API ► Keyoti.RapidSpell.Compression.Wpf
Keyoti RapidSpell WPF
Types
All Types Classes Enumerations
Icon | Type | Description
 | CompressionLevel | The compression level to be used when using a DeflateStream or ZlibStream with CompressionMode.Compress.
 | CompressionMode | An enum to specify the direction of transcoding - whether to compress or decompress.
 | CompressionStrategy | Describes options for how the compression algorithm is executed. Different strategies work better on different sorts of data. The strategy parameter can affect the compression ratio and the speed of compression but not the correctness of the compresssion.
 | CRC32 | Calculates a 32bit Cyclic Redundancy Checksum (CRC) using the same polynomial used by Zip. This type is used internally by DotNetZip; it is generally not used directly by applications wishing to create, read, or manipulate zip archive files.
 | CrcCalculatorStream | A Stream that calculates a CRC32 (a checksum) on all bytes read, or on all bytes written.
 | DeflateStream | A class for compressing and decompressing streams using the Deflate algorithm.
 | FlushType | Describes how to flush the current deflate operation.
 | GZipStream | A class for compressing and decompressing GZIP streams.
 | ZlibCodec | Encoder and Decoder for ZLIB and DEFLATE (IETF RFC1950 and RFC1951).
 | ZlibConstants | A bunch of constants used in the Zlib interface.
 | ZlibException | A general purpose exception class for exceptions in the Zlib library.
 | ZlibStream | Represents a Zlib stream for compression or decompression.


CompressionLevel Enumeration

CompressionLevel Enumeration
API ► Keyoti.RapidSpell.Compression.Wpf ► CompressionLevel
Keyoti RapidSpell WPF
The compression level to be used when using a DeflateStream or ZlibStream with CompressionMode.Compress.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public enum CompressionLevel
public enum CompressionLevel
Public Enumeration CompressionLevel
Public Enumeration CompressionLevel
public enum class CompressionLevel
public enum class CompressionLevel
type CompressionLevel
type CompressionLevel
Members
Member | Description
None | None means that the data will be simply stored, with no change at all. If you are producing ZIPs for use on Mac OSX, be aware that archives produced with CompressionLevel.None cannot be opened with the default zip reader. Use a different CompressionLevel.
Level0 | Same as None.
BestSpeed | The fastest but least effective compression.
Level1 | A synonym for BestSpeed.
Level2 | A little slower, but better, than level 1.
Level3 | A little slower, but better, than level 2.
Level4 | A little slower, but better, than level 3.
Level5 | A little slower than level 4, but with better compression.
Default | The default compression level, with a good balance of speed and compression efficiency.
Level6 | A synonym for Default.
Level7 | Pretty good compression!
Level8 | Better compression than Level7!
BestCompression | The "best" compression, where best means greatest reduction in size of the input data stream. This is also the slowest compression.
Level9 | A synonym for BestCompression.

Send comments on this topic to support@keyoti.com

2005-2014 Keyoti Inc.

Assembly: Keyoti4.RapidSpell.WPF (Module: Keyoti4.RapidSpell.WPF.dll) Version: 4.1.20.917


CompressionMode Enumeration

CompressionMode Enumeration
API ► Keyoti.RapidSpell.Compression.Wpf ► CompressionMode
Keyoti RapidSpell WPF
An enum to specify the direction of transcoding - whether to compress or decompress.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public enum CompressionMode
public enum CompressionMode
Public Enumeration CompressionMode
Public Enumeration CompressionMode
public enum class CompressionMode
public enum class CompressionMode
type CompressionMode
type CompressionMode
Members
Member | Description
Compress | Used to specify that the stream should compress the data.
Decompress | Used to specify that the stream should decompress the data.


CompressionStrategy Enumeration

CompressionStrategy Enumeration
API ► Keyoti.RapidSpell.Compression.Wpf ► CompressionStrategy
Keyoti RapidSpell WPF
Describes options for how the compression algorithm is executed. Different strategies work better on different sorts of data. The strategy parameter can affect the compression ratio and the speed of compression but not the correctness of the compresssion.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public enum CompressionStrategy
public enum CompressionStrategy
Public Enumeration CompressionStrategy
Public Enumeration CompressionStrategy
public enum class CompressionStrategy
public enum class CompressionStrategy
type CompressionStrategy
type CompressionStrategy
Members
Member | Description
Default | The default strategy is probably the best for normal data.
Filtered | The Filtered strategy is intended to be used most effectively with data produced by a filter or predictor. By this definition, filtered data consists mostly of small values with a somewhat random distribution. In this case, the compression algorithm is tuned to compress them better. The effect of Filtered is to force more Huffman coding and less string matching; it is a half-step between Default and HuffmanOnly.
HuffmanOnly | Using HuffmanOnly will force the compressor to do Huffman encoding only, with no string matching.


CRC32 Class

CRC32 Class
API ► Keyoti.RapidSpell.Compression.Wpf ► CRC32
Keyoti RapidSpell WPF
Calculates a 32bit Cyclic Redundancy Checksum (CRC) using the same polynomial used by Zip. This type is used internally by DotNetZip; it is generally not used directly by applications wishing to create, read, or manipulate zip archive files.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class CRC32
public class CRC32
Public Class CRC32
Public Class CRC32
public ref class CRC32
public ref class CRC32
type CRC32 =  class end
type CRC32 =  class end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CRC32()()()() |
 | Combine(Int32, Int32) | Combines the given CRC32 value with the current running total.
 | ComputeCrc32(Int32, Byte) | Get the CRC32 for the given (word,byte) combo. This is a computation defined by PKzip.
 | Crc32Result | Indicates the current CRC for all blocks slurped in.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetCrc32(Stream) | Returns the CRC32 for the specified stream.
 | GetCrc32AndCopy(Stream, Stream) | Returns the CRC32 for the specified stream, and writes the input into the output stream.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SlurpBlock(array<Byte>[]()[][], Int32, Int32) | Update the value for the running CRC32 using the given block of bytes. This is useful when using the CRC32() class in a Stream.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | TotalBytesRead | indicates the total number of bytes read on the CRC stream. This is used when writing the ZipDirEntry when compressing files.
Inheritance Hierarchy
Object
CRC32


CRC32 Constructor

CRC32 Constructor
API ► Keyoti.RapidSpell.Compression.Wpf ► CRC32 ► CRC32()()()()
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public CRC32()
public CRC32()
Public Sub New
Public Sub New
public:
CRC32()
public:
CRC32()
new : unit -> CRC32
new : unit -> CRC32


Combine Method (crc, length)

Combine Method (crc, length)
API ► Keyoti.RapidSpell.Compression.Wpf ► CRC32 ► Combine(Int32, Int32)
Keyoti RapidSpell WPF
Combines the given CRC32 value with the current running total.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void Combine(
    int crc,
    int length
)
public void Combine(
    int crc,
    int length
)
Public Sub Combine (
    crc As Integer,
    length As Integer
)
Public Sub Combine (
    crc As Integer,
    length As Integer
)
public:
void Combine(
    int crc,
    int length
)
public:
void Combine(
    int crc,
    int length
)
member Combine :
        crc : int *
        length : int -> unit

member Combine :
        crc : int *
        length : int -> unit
Parameters
crc (Int32)
the crc value to be combined with this one
length (Int32)
the length of data the CRC value was calculated on
Remarks
This is useful when using a divide-and-conquer approach to calculating a CRC. Multiple threads can each calculate a CRC32 on a segment of the data, and then combine the individual CRC32 values at the end.


ComputeCrc32 Method (W, B)

ComputeCrc32 Method (W, B)
API ► Keyoti.RapidSpell.Compression.Wpf ► CRC32 ► ComputeCrc32(Int32, Byte)
Keyoti RapidSpell WPF
Get the CRC32 for the given (word,byte) combo. This is a computation defined by PKzip.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int ComputeCrc32(
    int W,
    byte B
)
public int ComputeCrc32(
    int W,
    byte B
)
Public Function ComputeCrc32 (
    W As Integer,
    B As Byte
) As Integer
Public Function ComputeCrc32 (
    W As Integer,
    B As Byte
) As Integer
public:
int ComputeCrc32(
    int W,
    unsigned char B
)
public:
int ComputeCrc32(
    int W,
    unsigned char B
)
member ComputeCrc32 :
        W : int *
        B : byte -> int

member ComputeCrc32 :
        W : int *
        B : byte -> int
Parameters
W (Int32)
The word to start with.
B (Byte)
The byte to combine it with.
Return Value
Int32
The CRC-ized result.


Crc32Result Property

Crc32Result Property
API ► Keyoti.RapidSpell.Compression.Wpf ► CRC32 ► Crc32Result
Keyoti RapidSpell WPF
Indicates the current CRC for all blocks slurped in.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int Crc32Result { get; }
public int Crc32Result { get; }
Public ReadOnly Property Crc32Result As Integer
    Get
Public ReadOnly Property Crc32Result As Integer
    Get
public:
property int Crc32Result {
    int get ();
}
public:
property int Crc32Result {
    int get ();
}
member Crc32Result : int with get

member Crc32Result : int with get
Property Value
Int32


GetCrc32 Method (input)

GetCrc32 Method (input)
API ► Keyoti.RapidSpell.Compression.Wpf ► CRC32 ► GetCrc32(Stream)
Keyoti RapidSpell WPF
Returns the CRC32 for the specified stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int GetCrc32(
    Stream input
)
public int GetCrc32(
    Stream input
)
Public Function GetCrc32 (
    input As Stream
) As Integer
Public Function GetCrc32 (
    input As Stream
) As Integer
public:
int GetCrc32(
    Stream^ input
)
public:
int GetCrc32(
    Stream^ input
)
member GetCrc32 :
        input : Stream -> int

member GetCrc32 :
        input : Stream -> int
Parameters
input (Stream)
The stream over which to calculate the CRC32
Return Value
Int32
the CRC32 calculation


GetCrc32AndCopy Method (input, output)

GetCrc32AndCopy Method (input, output)
API ► Keyoti.RapidSpell.Compression.Wpf ► CRC32 ► GetCrc32AndCopy(Stream, Stream)
Keyoti RapidSpell WPF
Returns the CRC32 for the specified stream, and writes the input into the output stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int GetCrc32AndCopy(
    Stream input,
    Stream output
)
public int GetCrc32AndCopy(
    Stream input,
    Stream output
)
Public Function GetCrc32AndCopy (
    input As Stream,
    output As Stream
) As Integer
Public Function GetCrc32AndCopy (
    input As Stream,
    output As Stream
) As Integer
public:
int GetCrc32AndCopy(
    Stream^ input,
    Stream^ output
)
public:
int GetCrc32AndCopy(
    Stream^ input,
    Stream^ output
)
member GetCrc32AndCopy :
        input : Stream *
        output : Stream -> int

member GetCrc32AndCopy :
        input : Stream *
        output : Stream -> int
Parameters
input (Stream)
The stream over which to calculate the CRC32
output (Stream)
The stream into which to deflate the input
Return Value
Int32
the CRC32 calculation


SlurpBlock Method (block, offset, count)

SlurpBlock Method (block, offset, count)
API ► Keyoti.RapidSpell.Compression.Wpf ► CRC32 ► SlurpBlock(array<Byte>[]()[][], Int32, Int32)
Keyoti RapidSpell WPF
Update the value for the running CRC32 using the given block of bytes. This is useful when using the CRC32() class in a Stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void SlurpBlock(
    byte[] block,
    int offset,
    int count
)
public void SlurpBlock(
    byte[] block,
    int offset,
    int count
)
Public Sub SlurpBlock (
    block As Byte(),
    offset As Integer,
    count As Integer
)
Public Sub SlurpBlock (
    block As Byte(),
    offset As Integer,
    count As Integer
)
public:
void SlurpBlock(
    array<unsigned char>^ block,
    int offset,
    int count
)
public:
void SlurpBlock(
    array<unsigned char>^ block,
    int offset,
    int count
)
member SlurpBlock :
        block : byte[] *
        offset : int *
        count : int -> unit

member SlurpBlock :
        block : byte[] *
        offset : int *
        count : int -> unit
Parameters
block (array< Byte >[]()[][])
block of bytes to slurp
offset (Int32)
starting point in the block
count (Int32)
how many bytes within the block to slurp


TotalBytesRead Property

TotalBytesRead Property
API ► Keyoti.RapidSpell.Compression.Wpf ► CRC32 ► TotalBytesRead
Keyoti RapidSpell WPF
indicates the total number of bytes read on the CRC stream. This is used when writing the ZipDirEntry when compressing files.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public long TotalBytesRead { get; }
public long TotalBytesRead { get; }
Public ReadOnly Property TotalBytesRead As Long
    Get
Public ReadOnly Property TotalBytesRead As Long
    Get
public:
property long long TotalBytesRead {
    long long get ();
}
public:
property long long TotalBytesRead {
    long long get ();
}
member TotalBytesRead : int64 with get

member TotalBytesRead : int64 with get
Property Value
Int64


CrcCalculatorStream Class

CrcCalculatorStream Class
API ► Keyoti.RapidSpell.Compression.Wpf ► CrcCalculatorStream
Keyoti RapidSpell WPF
A Stream that calculates a CRC32 (a checksum) on all bytes read, or on all bytes written.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class CrcCalculatorStream : Stream,
    IDisposable
public class CrcCalculatorStream : Stream,
    IDisposable
Public Class CrcCalculatorStream
    Inherits Stream
    Implements IDisposable
Public Class CrcCalculatorStream
    Inherits Stream
    Implements IDisposable
public ref class CrcCalculatorStream : public Stream,
    IDisposable
public ref class CrcCalculatorStream : public Stream,
    IDisposable
type CrcCalculatorStream =
    class
        inherit Stream
        interface IDisposable
    end
type CrcCalculatorStream =
    class
        inherit Stream
        interface IDisposable
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CrcCalculatorStream(Stream) | The default constructor.
 | CrcCalculatorStream(Stream, Boolean) | The constructor allows the caller to specify how to handle the underlying stream at close.
 | CrcCalculatorStream(Stream, Int64) | A constructor allowing the specification of the length of the stream to read.
 | CrcCalculatorStream(Stream, Int64, Boolean) | A constructor allowing the specification of the length of the stream to read, as well as whether to keep the underlying stream open upon Close().
 | BeginRead(array<Byte>[]()[][], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous read operation. (Inherited from Stream.)
 | BeginWrite(array<Byte>[]()[][], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous write operation. (Inherited from Stream.)
 | CanRead | Indicates whether the stream supports reading. (Overrides Stream.CanRead.)
 | CanSeek | Indicates whether the stream supports seeking. (Overrides Stream.CanSeek.)
 | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
 | CanWrite | Indicates whether the stream supports writing. (Overrides Stream.CanWrite.)
 | Close()()()() | Closes the stream. (Overrides Stream.Close()()()().)
 | Crc | Provides the current CRC for all blocks slurped in.
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateWaitHandle()()()() | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
 | Dispose()()()() | Releases all resources used by the Stream. (Inherited from Stream.)
 | Dispose(Boolean) | Releases the unmanaged resources used by the Stream and optionally releases the managed resources. (Inherited from Stream.)
 | EndRead(IAsyncResult) | Waits for the pending asynchronous read to complete. (Inherited from Stream.)
 | EndWrite(IAsyncResult) | Ends an asynchronous write operation. (Inherited from Stream.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | Flush()()()() | Flush the stream. (Overrides Stream.Flush()()()().)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | LeaveOpen | Indicates whether the underlying stream will be left open when the CrcCalculatorStream is Closed.
 | Length | Not implemented. (Overrides Stream.Length.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Position | Not implemented. (Overrides Stream.Position.)
 | Read(array<Byte>[]()[][], Int32, Int32) | Read from the stream (Overrides Stream.Read(array<Byte>[]()[][], Int32, Int32).)
 | ReadByte()()()() | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
 | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
 | Seek(Int64, SeekOrigin) | Not implemented. (Overrides Stream.Seek(Int64, SeekOrigin).)
 | SetLength(Int64) | Not implemented. (Overrides Stream.SetLength(Int64).)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | TotalBytesSlurped | Gets the total number of bytes run through the CRC32 calculator.
 | Write(array<Byte>[]()[][], Int32, Int32) | Write to the stream. (Overrides Stream.Write(array<Byte>[]()[][], Int32, Int32).)
 | WriteByte(Byte) | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
 | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Remarks

This class can be used to verify the CRC of a ZipEntry when reading from a stream, or to calculate a CRC when writing to a stream. The stream should be used to either read, or write, but not both. If you intermix reads and writes, the results are not defined.

This class is intended primarily for use internally by the DotNetZip library.

Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Stream
 |  |  | CrcCalculatorStream


CrcCalculatorStream Constructor

CrcCalculatorStream Constructor
API ► Keyoti.RapidSpell.Compression.Wpf ► CrcCalculatorStream ► CrcCalculatorStream()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | CrcCalculatorStream(Stream) | The default constructor.
 | CrcCalculatorStream(Stream, Boolean) | The constructor allows the caller to specify how to handle the underlying stream at close.
 | CrcCalculatorStream(Stream, Int64) | A constructor allowing the specification of the length of the stream to read.
 | CrcCalculatorStream(Stream, Int64, Boolean) | A constructor allowing the specification of the length of the stream to read, as well as whether to keep the underlying stream open upon Close().


CrcCalculatorStream Constructor (stream)

CrcCalculatorStream Constructor (stream)
API ► Keyoti.RapidSpell.Compression.Wpf ► CrcCalculatorStream ► CrcCalculatorStream(Stream)
Keyoti RapidSpell WPF
The default constructor.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public CrcCalculatorStream(
    Stream stream
)
public CrcCalculatorStream(
    Stream stream
)
Public Sub New (
    stream As Stream
)
Public Sub New (
    stream As Stream
)
public:
CrcCalculatorStream(
    Stream^ stream
)
public:
CrcCalculatorStream(
    Stream^ stream
)
new :
        stream : Stream -> CrcCalculatorStream
new :
        stream : Stream -> CrcCalculatorStream
Parameters
stream (Stream)
The underlying stream
Remarks
Instances returned from this constructor will leave the underlying stream open upon Close().


CrcCalculatorStream Constructor (stream, leaveOpen)

CrcCalculatorStream Constructor (stream, leaveOpen)
API ► Keyoti.RapidSpell.Compression.Wpf ► CrcCalculatorStream ► CrcCalculatorStream(Stream, Boolean)
Keyoti RapidSpell WPF
The constructor allows the caller to specify how to handle the underlying stream at close.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public CrcCalculatorStream(
    Stream stream,
    bool leaveOpen
)
public CrcCalculatorStream(
    Stream stream,
    bool leaveOpen
)
Public Sub New (
    stream As Stream,
    leaveOpen As Boolean
)
Public Sub New (
    stream As Stream,
    leaveOpen As Boolean
)
public:
CrcCalculatorStream(
    Stream^ stream,
    bool leaveOpen
)
public:
CrcCalculatorStream(
    Stream^ stream,
    bool leaveOpen
)
new :
        stream : Stream *
        leaveOpen : bool -> CrcCalculatorStream
new :
        stream : Stream *
        leaveOpen : bool -> CrcCalculatorStream
Parameters
stream (Stream)
The underlying stream
leaveOpen (Boolean)
true to leave the underlying stream open upon close of the CrcCalculatorStream.; false otherwise.


CrcCalculatorStream Constructor (stream, length)

CrcCalculatorStream Constructor (stream, length)
API ► Keyoti.RapidSpell.Compression.Wpf ► CrcCalculatorStream ► CrcCalculatorStream(Stream, Int64)
Keyoti RapidSpell WPF
A constructor allowing the specification of the length of the stream to read.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public CrcCalculatorStream(
    Stream stream,
    long length
)
public CrcCalculatorStream(
    Stream stream,
    long length
)
Public Sub New (
    stream As Stream,
    length As Long
)
Public Sub New (
    stream As Stream,
    length As Long
)
public:
CrcCalculatorStream(
    Stream^ stream,
    long long length
)
public:
CrcCalculatorStream(
    Stream^ stream,
    long long length
)
new :
        stream : Stream *
        length : int64 -> CrcCalculatorStream
new :
        stream : Stream *
        length : int64 -> CrcCalculatorStream
Parameters
stream (Stream)
The underlying stream
length (Int64)
The length of the stream to slurp
Remarks
Instances returned from this constructor will leave the underlying stream open upon Close().


CrcCalculatorStream Constructor (stream, length, leaveOpen)

CrcCalculatorStream Constructor (stream, length, leaveOpen)
API ► Keyoti.RapidSpell.Compression.Wpf ► CrcCalculatorStream ► CrcCalculatorStream(Stream, Int64, Boolean)
Keyoti RapidSpell WPF
A constructor allowing the specification of the length of the stream to read, as well as whether to keep the underlying stream open upon Close().
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public CrcCalculatorStream(
    Stream stream,
    long length,
    bool leaveOpen
)
public CrcCalculatorStream(
    Stream stream,
    long length,
    bool leaveOpen
)
Public Sub New (
    stream As Stream,
    length As Long,
    leaveOpen As Boolean
)
Public Sub New (
    stream As Stream,
    length As Long,
    leaveOpen As Boolean
)
public:
CrcCalculatorStream(
    Stream^ stream,
    long long length,
    bool leaveOpen
)
public:
CrcCalculatorStream(
    Stream^ stream,
    long long length,
    bool leaveOpen
)
new :
        stream : Stream *
        length : int64 *
        leaveOpen : bool -> CrcCalculatorStream
new :
        stream : Stream *
        length : int64 *
        leaveOpen : bool -> CrcCalculatorStream
Parameters
stream (Stream)
The underlying stream
length (Int64)
The length of the stream to slurp
leaveOpen (Boolean)
true to leave the underlying stream open upon close of the CrcCalculatorStream.; false otherwise.


CanRead Property

CanRead Property
API ► Keyoti.RapidSpell.Compression.Wpf ► CrcCalculatorStream ► CanRead
Keyoti RapidSpell WPF
Indicates whether the stream supports reading.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override bool CanRead { get; }
public override bool CanRead { get; }
Public Overrides ReadOnly Property CanRead As Boolean
    Get
Public Overrides ReadOnly Property CanRead As Boolean
    Get
public:
virtual property bool CanRead {
    bool get () override;
}
public:
virtual property bool CanRead {
    bool get () override;
}
abstract CanRead : bool with get
override CanRead : bool with get
abstract CanRead : bool with get
override CanRead : bool with get
Property Value
Boolean


CanSeek Property

CanSeek Property
API ► Keyoti.RapidSpell.Compression.Wpf ► CrcCalculatorStream ► CanSeek
Keyoti RapidSpell WPF
Indicates whether the stream supports seeking.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override bool CanSeek { get; }
public override bool CanSeek { get; }
Public Overrides ReadOnly Property CanSeek As Boolean
    Get
Public Overrides ReadOnly Property CanSeek As Boolean
    Get
public:
virtual property bool CanSeek {
    bool get () override;
}
public:
virtual property bool CanSeek {
    bool get () override;
}
abstract CanSeek : bool with get
override CanSeek : bool with get
abstract CanSeek : bool with get
override CanSeek : bool with get
Property Value
Boolean


CanWrite Property

CanWrite Property
API ► Keyoti.RapidSpell.Compression.Wpf ► CrcCalculatorStream ► CanWrite
Keyoti RapidSpell WPF
Indicates whether the stream supports writing.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override bool CanWrite { get; }
public override bool CanWrite { get; }
Public Overrides ReadOnly Property CanWrite As Boolean
    Get
Public Overrides ReadOnly Property CanWrite As Boolean
    Get
public:
virtual property bool CanWrite {
    bool get () override;
}
public:
virtual property bool CanWrite {
    bool get () override;
}
abstract CanWrite : bool with get
override CanWrite : bool with get
abstract CanWrite : bool with get
override CanWrite : bool with get
Property Value
Boolean


Close Method

Close Method
API ► Keyoti.RapidSpell.Compression.Wpf ► CrcCalculatorStream ► Close()()()()
Keyoti RapidSpell WPF
Closes the stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override void Close()
public override void Close()
Public Overrides Sub Close
Public Overrides Sub Close
public:
virtual void Close() override
public:
virtual void Close() override
abstract Close : unit -> unit
override Close : unit -> unit
abstract Close : unit -> unit
override Close : unit -> unit


Crc Property

Crc Property
API ► Keyoti.RapidSpell.Compression.Wpf ► CrcCalculatorStream ► Crc
Keyoti RapidSpell WPF
Provides the current CRC for all blocks slurped in.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int Crc { get; }
public int Crc { get; }
Public ReadOnly Property Crc As Integer
    Get
Public ReadOnly Property Crc As Integer
    Get
public:
property int Crc {
    int get ();
}
public:
property int Crc {
    int get ();
}
member Crc : int with get

member Crc : int with get
Property Value
Int32


Flush Method

Flush Method
API ► Keyoti.RapidSpell.Compression.Wpf ► CrcCalculatorStream ► Flush()()()()
Keyoti RapidSpell WPF
Flush the stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override void Flush()
public override void Flush()
Public Overrides Sub Flush
Public Overrides Sub Flush
public:
virtual void Flush() override
public:
virtual void Flush() override
abstract Flush : unit -> unit
override Flush : unit -> unit
abstract Flush : unit -> unit
override Flush : unit -> unit


LeaveOpen Property

LeaveOpen Property
API ► Keyoti.RapidSpell.Compression.Wpf ► CrcCalculatorStream ► LeaveOpen
Keyoti RapidSpell WPF
Indicates whether the underlying stream will be left open when the CrcCalculatorStream is Closed.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool LeaveOpen { get; set; }
public bool LeaveOpen { get; set; }
Public Property LeaveOpen As Boolean
    Get
    Set
Public Property LeaveOpen As Boolean
    Get
    Set
public:
property bool LeaveOpen {
    bool get ();
    void set (bool value);
}
public:
property bool LeaveOpen {
    bool get ();
    void set (bool value);
}
member LeaveOpen : bool with get, set

member LeaveOpen : bool with get, set
Property Value
Boolean


Length Property

Length Property
API ► Keyoti.RapidSpell.Compression.Wpf ► CrcCalculatorStream ► Length
Keyoti RapidSpell WPF
Not implemented.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override long Length { get; }
public override long Length { get; }
Public Overrides ReadOnly Property Length As Long
    Get
Public Overrides ReadOnly Property Length As Long
    Get
public:
virtual property long long Length {
    long long get () override;
}
public:
virtual property long long Length {
    long long get () override;
}
abstract Length : int64 with get
override Length : int64 with get
abstract Length : int64 with get
override Length : int64 with get
Property Value
Int64


Position Property

Position Property
API ► Keyoti.RapidSpell.Compression.Wpf ► CrcCalculatorStream ► Position
Keyoti RapidSpell WPF
Not implemented.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override long Position { get; set; }
public override long Position { get; set; }
Public Overrides Property Position As Long
    Get
    Set
Public Overrides Property Position As Long
    Get
    Set
public:
virtual property long long Position {
    long long get () override;
    void set (long long value) override;
}
public:
virtual property long long Position {
    long long get () override;
    void set (long long value) override;
}
abstract Position : int64 with get, set
override Position : int64 with get, set
abstract Position : int64 with get, set
override Position : int64 with get, set
Property Value
Int64


Read Method (buffer, offset, count)

Read Method (buffer, offset, count)
API ► Keyoti.RapidSpell.Compression.Wpf ► CrcCalculatorStream ► Read(array<Byte>[]()[][], Int32, Int32)
Keyoti RapidSpell WPF
Read from the stream
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Function Read (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
Public Overrides Function Read (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
abstract Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
override Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
abstract Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
override Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
Parameters
buffer (array< Byte >[]()[][])
the buffer to read
offset (Int32)
the offset at which to start
count (Int32)
the number of bytes to read
Return Value
Int32
the number of bytes actually read


Seek Method (offset, origin)

Seek Method (offset, origin)
API ► Keyoti.RapidSpell.Compression.Wpf ► CrcCalculatorStream ► Seek(Int64, SeekOrigin)
Keyoti RapidSpell WPF
Not implemented.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override long Seek(
    long offset,
    SeekOrigin origin
)
public override long Seek(
    long offset,
    SeekOrigin origin
)
Public Overrides Function Seek (
    offset As Long,
    origin As SeekOrigin
) As Long
Public Overrides Function Seek (
    offset As Long,
    origin As SeekOrigin
) As Long
public:
virtual long long Seek(
    long long offset,
    SeekOrigin origin
) override
public:
virtual long long Seek(
    long long offset,
    SeekOrigin origin
) override
abstract Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
override Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
abstract Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
override Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
Parameters
offset (Int64)
N/A
origin (SeekOrigin)
N/A
Return Value
Int64
N/A


SetLength Method (value)

SetLength Method (value)
API ► Keyoti.RapidSpell.Compression.Wpf ► CrcCalculatorStream ► SetLength(Int64)
Keyoti RapidSpell WPF
Not implemented.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override void SetLength(
    long value
)
public override void SetLength(
    long value
)
Public Overrides Sub SetLength (
    value As Long
)
Public Overrides Sub SetLength (
    value As Long
)
public:
virtual void SetLength(
    long long value
) override
public:
virtual void SetLength(
    long long value
) override
abstract SetLength :
        value : int64 -> unit
override SetLength :
        value : int64 -> unit
abstract SetLength :
        value : int64 -> unit
override SetLength :
        value : int64 -> unit
Parameters
value (Int64)
N/A


TotalBytesSlurped Property

TotalBytesSlurped Property
API ► Keyoti.RapidSpell.Compression.Wpf ► CrcCalculatorStream ► TotalBytesSlurped
Keyoti RapidSpell WPF
Gets the total number of bytes run through the CRC32 calculator.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public long TotalBytesSlurped { get; }
public long TotalBytesSlurped { get; }
Public ReadOnly Property TotalBytesSlurped As Long
    Get
Public ReadOnly Property TotalBytesSlurped As Long
    Get
public:
property long long TotalBytesSlurped {
    long long get ();
}
public:
property long long TotalBytesSlurped {
    long long get ();
}
member TotalBytesSlurped : int64 with get

member TotalBytesSlurped : int64 with get
Property Value
Int64
Remarks
This is either the total number of bytes read, or the total number of bytes written, depending on the direction of this stream.


Write Method (buffer, offset, count)

Write Method (buffer, offset, count)
API ► Keyoti.RapidSpell.Compression.Wpf ► CrcCalculatorStream ► Write(array<Byte>[]()[][], Int32, Int32)
Keyoti RapidSpell WPF
Write to the stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Sub Write (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
Public Overrides Sub Write (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
public:
virtual void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
public:
virtual void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
abstract Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
override Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
abstract Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
override Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
Parameters
buffer (array< Byte >[]()[][])
the buffer from which to write
offset (Int32)
the offset at which to start writing
count (Int32)
the number of bytes to write


DeflateStream Class

DeflateStream Class
API ► Keyoti.RapidSpell.Compression.Wpf ► DeflateStream
Keyoti RapidSpell WPF
A class for compressing and decompressing streams using the Deflate algorithm.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class DeflateStream : Stream
public class DeflateStream : Stream
Public Class DeflateStream
    Inherits Stream
Public Class DeflateStream
    Inherits Stream
public ref class DeflateStream : public Stream
public ref class DeflateStream : public Stream
type DeflateStream =
    class
        inherit Stream
    end
type DeflateStream =
    class
        inherit Stream
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DeflateStream(Stream, CompressionMode) | Create a DeflateStream using the specified CompressionMode.
 | DeflateStream(Stream, CompressionMode, CompressionLevel) | Create a DeflateStream using the specified CompressionMode and the specified CompressionLevel.
 | DeflateStream(Stream, CompressionMode, Boolean) | Create a DeflateStream using the specified CompressionMode, and explicitly specify whether the stream should be left open after Deflation or Inflation.
 | DeflateStream(Stream, CompressionMode, CompressionLevel, Boolean) | Create a DeflateStream using the specified CompressionMode and the specified CompressionLevel, and explicitly specify whether the stream should be left open after Deflation or Inflation.
 | BeginRead(array<Byte>[]()[][], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous read operation. (Inherited from Stream.)
 | BeginWrite(array<Byte>[]()[][], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous write operation. (Inherited from Stream.)
 | BufferSize | The size of the working buffer for the compression codec.
 | CanRead | Indicates whether the stream can be read. (Overrides Stream.CanRead.)
 | CanSeek | Indicates whether the stream supports Seek operations. (Overrides Stream.CanSeek.)
 | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
 | CanWrite | Indicates whether the stream can be written. (Overrides Stream.CanWrite.)
 | Close()()()() | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. (Inherited from Stream.)
 | CompressBuffer(array<Byte>[]()[][]) | Compress a byte array into a new byte array using DEFLATE.
 | CompressString(String) | Compress a string into a byte array using DEFLATE (RFC 1951).
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateWaitHandle()()()() | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
 | Dispose(Boolean) | Dispose the stream.
 | Dispose()()()() | Releases all resources used by the Stream. (Inherited from Stream.)
 | EndRead(IAsyncResult) | Waits for the pending asynchronous read to complete. (Inherited from Stream.)
 | EndWrite(IAsyncResult) | Ends an asynchronous write operation. (Inherited from Stream.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | Flush()()()() | Flush the stream. (Overrides Stream.Flush()()()().)
 | FlushMode | This property sets the flush behavior on the stream.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | Length | Reading this property always throws a NotImplementedException. (Overrides Stream.Length.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Position | The position of the stream pointer. (Overrides Stream.Position.)
 | Read(array<Byte>[]()[][], Int32, Int32) | Read data from the stream. (Overrides Stream.Read(array<Byte>[]()[][], Int32, Int32).)
 | ReadByte()()()() | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
 | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
 | Seek(Int64, SeekOrigin) | Calling this method always throws a NotImplementedException. (Overrides Stream.Seek(Int64, SeekOrigin).)
 | SetLength(Int64) | Calling this method always throws a NotImplementedException. (Overrides Stream.SetLength(Int64).)
 | Strategy | The ZLIB strategy to be used during compression.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | TotalIn | Returns the total number of bytes input so far.
 | TotalOut | Returns the total number of bytes output so far.
 | UncompressBuffer(array<Byte>[]()[][]) | Uncompress a DEFLATE'd byte array into a byte array.
 | UncompressString(array<Byte>[]()[][]) | Uncompress a DEFLATE'd byte array into a single string.
 | Write(array<Byte>[]()[][], Int32, Int32) | Write data to the stream. (Overrides Stream.Write(array<Byte>[]()[][], Int32, Int32).)
 | WriteByte(Byte) | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
 | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Remarks

The DeflateStream is a Decorator on a Stream. It adds DEFLATE compression or decompression to any stream.

Using this stream, applications can compress or decompress data via stream Read and Write operations. Either compresssion or decompression can occur through either reading or writing. The compression format used is DEFLATE, which is documented in IETF RFC 1951, "DEFLATE Compressed Data Format Specification version 1.3.".

This class is similar to ZlibStream, except that ZlibStream adds the RFC 1950 - ZLIB framing bytes to a compressed stream when compressing, or expects the RFC1950 framing bytes when decompressing. The DeflateStream does not.

Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Stream
 |  |  | DeflateStream
See Also
ZlibStream
GZipStream


DeflateStream Constructor

DeflateStream Constructor
API ► Keyoti.RapidSpell.Compression.Wpf ► DeflateStream ► DeflateStream()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | DeflateStream(Stream, CompressionMode) | Create a DeflateStream using the specified CompressionMode.
 | DeflateStream(Stream, CompressionMode, CompressionLevel) | Create a DeflateStream using the specified CompressionMode and the specified CompressionLevel.
 | DeflateStream(Stream, CompressionMode, Boolean) | Create a DeflateStream using the specified CompressionMode, and explicitly specify whether the stream should be left open after Deflation or Inflation.
 | DeflateStream(Stream, CompressionMode, CompressionLevel, Boolean) | Create a DeflateStream using the specified CompressionMode and the specified CompressionLevel, and explicitly specify whether the stream should be left open after Deflation or Inflation.


DeflateStream Constructor (stream, mode)

DeflateStream Constructor (stream, mode)
API ► Keyoti.RapidSpell.Compression.Wpf ► DeflateStream ► DeflateStream(Stream, CompressionMode)
Keyoti RapidSpell WPF
Create a DeflateStream using the specified CompressionMode.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public DeflateStream(
    Stream stream,
    CompressionMode mode
)
public DeflateStream(
    Stream stream,
    CompressionMode mode
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode
)
public:
DeflateStream(
    Stream^ stream,
    CompressionMode mode
)
public:
DeflateStream(
    Stream^ stream,
    CompressionMode mode
)
new :
        stream : Stream *
        mode : CompressionMode -> DeflateStream
new :
        stream : Stream *
        mode : CompressionMode -> DeflateStream
Parameters
stream (Stream)
The stream which will be read or written.
mode (CompressionMode)
Indicates whether the DeflateStream will compress or decompress.
Remarks
When mode is CompressionMode.Compress, the DeflateStream will use the default compression level. The "captive" stream will be closed when the DeflateStream is closed.
Examples
This example uses a DeflateStream to compress data from a file, and writes the compressed data to another file.
Copy image Copy
using (System.IO.Stream input = System.IO.File.OpenRead(fileToCompress))
{
    using (var raw = System.IO.File.Create(fileToCompress + ".deflated"))
    {
        using (Stream compressor = new DeflateStream(raw, CompressionMode.Compress))
        {
            byte[] buffer = new byte[WORKING_BUFFER_SIZE];
            int n;
            while ((n= input.Read(buffer, 0, buffer.Length)) != 0)
            {
                compressor.Write(buffer, 0, n);
            }
        }
    }
}
Visual Basic Copy image Copy
Using input As Stream = File.OpenRead(fileToCompress)
    Using raw As FileStream = File.Create(fileToCompress & ".deflated")
        Using compressor As Stream = New DeflateStream(raw, CompressionMode.Compress)
            Dim buffer As Byte() = New Byte(4096) {}
            Dim n As Integer = -1
            Do While (n <> 0)
                If (n > 0) Then
                    compressor.Write(buffer, 0, n)
                End If
                n = input.Read(buffer, 0, buffer.Length)
            Loop
        End Using
    End Using
End Using


DeflateStream Constructor (stream, mode, level)

DeflateStream Constructor (stream, mode, level)
API ► Keyoti.RapidSpell.Compression.Wpf ► DeflateStream ► DeflateStream(Stream, CompressionMode, CompressionLevel)
Keyoti RapidSpell WPF
Create a DeflateStream using the specified CompressionMode and the specified CompressionLevel.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public DeflateStream(
    Stream stream,
    CompressionMode mode,
    CompressionLevel level
)
public DeflateStream(
    Stream stream,
    CompressionMode mode,
    CompressionLevel level
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode,
    level As CompressionLevel
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode,
    level As CompressionLevel
)
public:
DeflateStream(
    Stream^ stream,
    CompressionMode mode,
    CompressionLevel level
)
public:
DeflateStream(
    Stream^ stream,
    CompressionMode mode,
    CompressionLevel level
)
new :
        stream : Stream *
        mode : CompressionMode *
        level : CompressionLevel -> DeflateStream
new :
        stream : Stream *
        mode : CompressionMode *
        level : CompressionLevel -> DeflateStream
Parameters
stream (Stream)
The stream to be read or written while deflating or inflating.
mode (CompressionMode)
Indicates whether the DeflateStream will compress or decompress.
level (CompressionLevel)
A tuning knob to trade speed for effectiveness.
Remarks

When mode is CompressionMode.Decompress, the level parameter is ignored. The "captive" stream will be closed when the DeflateStream is closed.

Examples
This example uses a DeflateStream to compress data from a file, and writes the compressed data to another file.
Copy image Copy
using (System.IO.Stream input = System.IO.File.OpenRead(fileToCompress))
{
    using (var raw = System.IO.File.Create(fileToCompress + ".deflated"))
    {
        using (Stream compressor = new DeflateStream(raw,
                                                     CompressionMode.Compress,
                                                     CompressionLevel.BestCompression))
        {
            byte[] buffer = new byte[WORKING_BUFFER_SIZE];
            int n= -1;
            while (n != 0)
            {
                if (n > 0)
                    compressor.Write(buffer, 0, n);
                n= input.Read(buffer, 0, buffer.Length);
            }
        }
    }
}
Visual Basic Copy image Copy
Using input As Stream = File.OpenRead(fileToCompress)
    Using raw As FileStream = File.Create(fileToCompress & ".deflated")
        Using compressor As Stream = New DeflateStream(raw, CompressionMode.Compress, CompressionLevel.BestCompression)
            Dim buffer As Byte() = New Byte(4096) {}
            Dim n As Integer = -1
            Do While (n <> 0)
                If (n > 0) Then
                    compressor.Write(buffer, 0, n)
                End If
                n = input.Read(buffer, 0, buffer.Length)
            Loop
        End Using
    End Using
End Using


DeflateStream Constructor (stream, mode, level, leaveOpen)

DeflateStream Constructor (stream, mode, level, leaveOpen)
API ► Keyoti.RapidSpell.Compression.Wpf ► DeflateStream ► DeflateStream(Stream, CompressionMode, CompressionLevel, Boolean)
Keyoti RapidSpell WPF
Create a DeflateStream using the specified CompressionMode and the specified CompressionLevel, and explicitly specify whether the stream should be left open after Deflation or Inflation.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public DeflateStream(
    Stream stream,
    CompressionMode mode,
    CompressionLevel level,
    bool leaveOpen
)
public DeflateStream(
    Stream stream,
    CompressionMode mode,
    CompressionLevel level,
    bool leaveOpen
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode,
    level As CompressionLevel,
    leaveOpen As Boolean
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode,
    level As CompressionLevel,
    leaveOpen As Boolean
)
public:
DeflateStream(
    Stream^ stream,
    CompressionMode mode,
    CompressionLevel level,
    bool leaveOpen
)
public:
DeflateStream(
    Stream^ stream,
    CompressionMode mode,
    CompressionLevel level,
    bool leaveOpen
)
new :
        stream : Stream *
        mode : CompressionMode *
        level : CompressionLevel *
        leaveOpen : bool -> DeflateStream
new :
        stream : Stream *
        mode : CompressionMode *
        level : CompressionLevel *
        leaveOpen : bool -> DeflateStream
Parameters
stream (Stream)
The stream which will be read or written.
mode (CompressionMode)
Indicates whether the DeflateStream will compress or decompress.
level (CompressionLevel)
A tuning knob to trade speed for effectiveness.
leaveOpen (Boolean)
true if the application would like the stream to remain open after inflation/deflation.
Remarks

When mode is CompressionMode.Decompress, the level parameter is ignored.

This constructor allows the application to request that the captive stream remain open after the deflation or inflation occurs. By default, after Close() is called on the stream, the captive stream is also closed. In some cases this is not desired, for example if the stream is a MemoryStream that will be re-read after compression. Specify true for the leaveOpen parameter to leave the stream open.

Examples
This example shows how to use a DeflateStream to compress data from a file, and store the compressed data into another file.
Copy image Copy
using (var output = System.IO.File.Create(fileToCompress + ".deflated"))
{
    using (System.IO.Stream input = System.IO.File.OpenRead(fileToCompress))
    {
        using (Stream compressor = new DeflateStream(output, CompressionMode.Compress, CompressionLevel.BestCompression, true))
        {
            byte[] buffer = new byte[WORKING_BUFFER_SIZE];
            int n= -1;
            while (n != 0)
            {
                if (n > 0)
                    compressor.Write(buffer, 0, n);
                n= input.Read(buffer, 0, buffer.Length);
            }
        }
    }
    // can write additional data to the output stream here
}
Visual Basic Copy image Copy
Using output As FileStream = File.Create(fileToCompress & ".deflated")
    Using input As Stream = File.OpenRead(fileToCompress)
        Using compressor As Stream = New DeflateStream(output, CompressionMode.Compress, CompressionLevel.BestCompression, True)
            Dim buffer As Byte() = New Byte(4096) {}
            Dim n As Integer = -1
            Do While (n <> 0)
                If (n > 0) Then
                    compressor.Write(buffer, 0, n)
                End If
                n = input.Read(buffer, 0, buffer.Length)
            Loop
        End Using
    End Using
    ' can write additional data to the output stream here.
End Using


DeflateStream Constructor (stream, mode, leaveOpen)

DeflateStream Constructor (stream, mode, leaveOpen)
API ► Keyoti.RapidSpell.Compression.Wpf ► DeflateStream ► DeflateStream(Stream, CompressionMode, Boolean)
Keyoti RapidSpell WPF
Create a DeflateStream using the specified CompressionMode, and explicitly specify whether the stream should be left open after Deflation or Inflation.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public DeflateStream(
    Stream stream,
    CompressionMode mode,
    bool leaveOpen
)
public DeflateStream(
    Stream stream,
    CompressionMode mode,
    bool leaveOpen
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode,
    leaveOpen As Boolean
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode,
    leaveOpen As Boolean
)
public:
DeflateStream(
    Stream^ stream,
    CompressionMode mode,
    bool leaveOpen
)
public:
DeflateStream(
    Stream^ stream,
    CompressionMode mode,
    bool leaveOpen
)
new :
        stream : Stream *
        mode : CompressionMode *
        leaveOpen : bool -> DeflateStream
new :
        stream : Stream *
        mode : CompressionMode *
        leaveOpen : bool -> DeflateStream
Parameters
stream (Stream)
The stream which will be read or written. This is called the "captive" stream in other places in this documentation.
mode (CompressionMode)
Indicates whether the DeflateStream will compress or decompress.
leaveOpen (Boolean)
true if the application would like the stream to remain open after inflation/deflation.
Remarks

This constructor allows the application to request that the captive stream remain open after the deflation or inflation occurs. By default, after Close() is called on the stream, the captive stream is also closed. In some cases this is not desired, for example if the stream is a memory stream that will be re-read after compression. Specify true for the leaveOpen parameter to leave the stream open.

The DeflateStream will use the default compression level.

See the other overloads of this constructor for example code.


BufferSize Property

BufferSize Property
API ► Keyoti.RapidSpell.Compression.Wpf ► DeflateStream ► BufferSize
Keyoti RapidSpell WPF
The size of the working buffer for the compression codec.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int BufferSize { get; set; }
public int BufferSize { get; set; }
Public Property BufferSize As Integer
    Get
    Set
Public Property BufferSize As Integer
    Get
    Set
public:
property int BufferSize {
    int get ();
    void set (int value);
}
public:
property int BufferSize {
    int get ();
    void set (int value);
}
member BufferSize : int with get, set

member BufferSize : int with get, set
Property Value
Int32
Remarks

The working buffer is used for all stream operations. The default size is 1024 bytes. The minimum size is 128 bytes. You may get better performance with a larger buffer. Then again, you might not. You would have to test it.

Set this before the first call to Read() or Write() on the stream. If you try to set it afterwards, it will throw.


CanRead Property

CanRead Property
API ► Keyoti.RapidSpell.Compression.Wpf ► DeflateStream ► CanRead
Keyoti RapidSpell WPF
Indicates whether the stream can be read.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override bool CanRead { get; }
public override bool CanRead { get; }
Public Overrides ReadOnly Property CanRead As Boolean
    Get
Public Overrides ReadOnly Property CanRead As Boolean
    Get
public:
virtual property bool CanRead {
    bool get () override;
}
public:
virtual property bool CanRead {
    bool get () override;
}
abstract CanRead : bool with get
override CanRead : bool with get
abstract CanRead : bool with get
override CanRead : bool with get
Property Value
Boolean
Remarks
The return value depends on whether the captive stream supports reading.


CanSeek Property

CanSeek Property
API ► Keyoti.RapidSpell.Compression.Wpf ► DeflateStream ► CanSeek
Keyoti RapidSpell WPF
Indicates whether the stream supports Seek operations.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override bool CanSeek { get; }
public override bool CanSeek { get; }
Public Overrides ReadOnly Property CanSeek As Boolean
    Get
Public Overrides ReadOnly Property CanSeek As Boolean
    Get
public:
virtual property bool CanSeek {
    bool get () override;
}
public:
virtual property bool CanSeek {
    bool get () override;
}
abstract CanSeek : bool with get
override CanSeek : bool with get
abstract CanSeek : bool with get
override CanSeek : bool with get
Property Value
Boolean
Remarks
Always returns false.


CanWrite Property

CanWrite Property
API ► Keyoti.RapidSpell.Compression.Wpf ► DeflateStream ► CanWrite
Keyoti RapidSpell WPF
Indicates whether the stream can be written.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override bool CanWrite { get; }
public override bool CanWrite { get; }
Public Overrides ReadOnly Property CanWrite As Boolean
    Get
Public Overrides ReadOnly Property CanWrite As Boolean
    Get
public:
virtual property bool CanWrite {
    bool get () override;
}
public:
virtual property bool CanWrite {
    bool get () override;
}
abstract CanWrite : bool with get
override CanWrite : bool with get
abstract CanWrite : bool with get
override CanWrite : bool with get
Property Value
Boolean
Remarks
The return value depends on whether the captive stream supports writing.


CompressBuffer Method (b)

CompressBuffer Method (b)
API ► Keyoti.RapidSpell.Compression.Wpf ► DeflateStream ► CompressBuffer(array<Byte>[]()[][])
Keyoti RapidSpell WPF
Compress a byte array into a new byte array using DEFLATE.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static byte[] CompressBuffer(
    byte[] b
)
public static byte[] CompressBuffer(
    byte[] b
)
Public Shared Function CompressBuffer (
    b As Byte()
) As Byte()
Public Shared Function CompressBuffer (
    b As Byte()
) As Byte()
public:
static array<unsigned char>^ CompressBuffer(
    array<unsigned char>^ b
)
public:
static array<unsigned char>^ CompressBuffer(
    array<unsigned char>^ b
)
static member CompressBuffer :
        b : byte[] -> byte[]

static member CompressBuffer :
        b : byte[] -> byte[]
Parameters
b (array< Byte >[]()[][])
A buffer to compress.
Return Value
array< Byte >[]()[][]
The data in compressed form
Remarks
Uncompress it with UncompressBuffer(array<Byte>[]()[][]).
See Also
DeflateStream.CompressString(string)
DeflateStream.UncompressBuffer(byte[])
GZipStream.CompressBuffer(byte[])
ZlibStream.CompressBuffer(byte[])


CompressString Method (s)

CompressString Method (s)
API ► Keyoti.RapidSpell.Compression.Wpf ► DeflateStream ► CompressString(String)
Keyoti RapidSpell WPF
Compress a string into a byte array using DEFLATE (RFC 1951).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static byte[] CompressString(
    string s
)
public static byte[] CompressString(
    string s
)
Public Shared Function CompressString (
    s As String
) As Byte()
Public Shared Function CompressString (
    s As String
) As Byte()
public:
static array<unsigned char>^ CompressString(
    String^ s
)
public:
static array<unsigned char>^ CompressString(
    String^ s
)
static member CompressString :
        s : string -> byte[]

static member CompressString :
        s : string -> byte[]
Parameters
s (String)
A string to compress. The string will first be encoded using UTF8, then compressed.
Return Value
array< Byte >[]()[][]
The string in compressed form
Remarks
Uncompress it with UncompressString(array<Byte>[]()[][]).
See Also
DeflateStream.UncompressString(byte[])
DeflateStream.CompressBuffer(byte[])
GZipStream.CompressString(string)
ZlibStream.CompressString(string)


Dispose Method (disposing)

Dispose Method (disposing)
API ► Keyoti.RapidSpell.Compression.Wpf ► DeflateStream ► Dispose(Boolean)
Keyoti RapidSpell WPF
Dispose the stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected void Dispose(
    bool disposing
)
protected void Dispose(
    bool disposing
)
Protected Sub Dispose (
    disposing As Boolean
)
Protected Sub Dispose (
    disposing As Boolean
)
protected:
void Dispose(
    bool disposing
)
protected:
void Dispose(
    bool disposing
)
member Dispose :
        disposing : bool -> unit

member Dispose :
        disposing : bool -> unit
Parameters
disposing (Boolean)
Remarks
This may or may not result in a Close() call on the captive stream. See the constructors that have a leaveOpen parameter for more information.


Flush Method

Flush Method
API ► Keyoti.RapidSpell.Compression.Wpf ► DeflateStream ► Flush()()()()
Keyoti RapidSpell WPF
Flush the stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override void Flush()
public override void Flush()
Public Overrides Sub Flush
Public Overrides Sub Flush
public:
virtual void Flush() override
public:
virtual void Flush() override
abstract Flush : unit -> unit
override Flush : unit -> unit
abstract Flush : unit -> unit
override Flush : unit -> unit


FlushMode Property

FlushMode Property
API ► Keyoti.RapidSpell.Compression.Wpf ► DeflateStream ► FlushMode
Keyoti RapidSpell WPF
This property sets the flush behavior on the stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual FlushType FlushMode { get; set; }
public virtual FlushType FlushMode { get; set; }
Public Overridable Property FlushMode As FlushType
    Get
    Set
Public Overridable Property FlushMode As FlushType
    Get
    Set
public:
virtual property FlushType FlushMode {
    FlushType get ();
    void set (FlushType value);
}
public:
virtual property FlushType FlushMode {
    FlushType get ();
    void set (FlushType value);
}
abstract FlushMode : FlushType with get, set
override FlushMode : FlushType with get, set
abstract FlushMode : FlushType with get, set
override FlushMode : FlushType with get, set
Property Value
FlushType
Remarks
See the ZLIB documentation for the meaning of the flush behavior.


Length Property

Length Property
API ► Keyoti.RapidSpell.Compression.Wpf ► DeflateStream ► Length
Keyoti RapidSpell WPF
Reading this property always throws a NotImplementedException.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override long Length { get; }
public override long Length { get; }
Public Overrides ReadOnly Property Length As Long
    Get
Public Overrides ReadOnly Property Length As Long
    Get
public:
virtual property long long Length {
    long long get () override;
}
public:
virtual property long long Length {
    long long get () override;
}
abstract Length : int64 with get
override Length : int64 with get
abstract Length : int64 with get
override Length : int64 with get
Property Value
Int64


Position Property

Position Property
API ► Keyoti.RapidSpell.Compression.Wpf ► DeflateStream ► Position
Keyoti RapidSpell WPF
The position of the stream pointer.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override long Position { get; set; }
public override long Position { get; set; }
Public Overrides Property Position As Long
    Get
    Set
Public Overrides Property Position As Long
    Get
    Set
public:
virtual property long long Position {
    long long get () override;
    void set (long long value) override;
}
public:
virtual property long long Position {
    long long get () override;
    void set (long long value) override;
}
abstract Position : int64 with get, set
override Position : int64 with get, set
abstract Position : int64 with get, set
override Position : int64 with get, set
Property Value
Int64
Remarks
Setting this property always throws a NotImplementedException. Reading will return the total bytes written out, if used in writing, or the total bytes read in, if used in reading. The count may refer to compressed bytes or uncompressed bytes, depending on how you've used the stream.


Read Method (buffer, offset, count)

Read Method (buffer, offset, count)
API ► Keyoti.RapidSpell.Compression.Wpf ► DeflateStream ► Read(array<Byte>[]()[][], Int32, Int32)
Keyoti RapidSpell WPF
Read data from the stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Function Read (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
Public Overrides Function Read (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
abstract Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
override Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
abstract Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
override Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
Parameters
buffer (array< Byte >[]()[][])
The buffer into which the read data should be placed.
offset (Int32)
the offset within that data array to put the first byte read.
count (Int32)
the number of bytes to read.
Return Value
Int32
the number of bytes actually read
Remarks

If you wish to use the DeflateStream to compress data while reading, you can create a DeflateStream with CompressionMode.Compress, providing an uncompressed data stream. Then call Read() on that DeflateStream, and the data read will be compressed as you read. If you wish to use the DeflateStream to decompress data while reading, you can create a DeflateStream with CompressionMode.Decompress, providing a readable compressed data stream. Then call Read() on that DeflateStream, and the data read will be decompressed as you read.

A DeflateStream can be used for Read() or Write(), but not both.


Seek Method (offset, origin)

Seek Method (offset, origin)
API ► Keyoti.RapidSpell.Compression.Wpf ► DeflateStream ► Seek(Int64, SeekOrigin)
Keyoti RapidSpell WPF
Calling this method always throws a NotImplementedException.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override long Seek(
    long offset,
    SeekOrigin origin
)
public override long Seek(
    long offset,
    SeekOrigin origin
)
Public Overrides Function Seek (
    offset As Long,
    origin As SeekOrigin
) As Long
Public Overrides Function Seek (
    offset As Long,
    origin As SeekOrigin
) As Long
public:
virtual long long Seek(
    long long offset,
    SeekOrigin origin
) override
public:
virtual long long Seek(
    long long offset,
    SeekOrigin origin
) override
abstract Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
override Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
abstract Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
override Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
Parameters
offset (Int64)
this is irrelevant, since it will always throw!
origin (SeekOrigin)
this is irrelevant, since it will always throw!
Return Value
Int64
irrelevant!


SetLength Method (value)

SetLength Method (value)
API ► Keyoti.RapidSpell.Compression.Wpf ► DeflateStream ► SetLength(Int64)
Keyoti RapidSpell WPF
Calling this method always throws a NotImplementedException.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override void SetLength(
    long value
)
public override void SetLength(
    long value
)
Public Overrides Sub SetLength (
    value As Long
)
Public Overrides Sub SetLength (
    value As Long
)
public:
virtual void SetLength(
    long long value
) override
public:
virtual void SetLength(
    long long value
) override
abstract SetLength :
        value : int64 -> unit
override SetLength :
        value : int64 -> unit
abstract SetLength :
        value : int64 -> unit
override SetLength :
        value : int64 -> unit
Parameters
value (Int64)
this is irrelevant, since it will always throw!


Strategy Property

Strategy Property
API ► Keyoti.RapidSpell.Compression.Wpf ► DeflateStream ► Strategy
Keyoti RapidSpell WPF
The ZLIB strategy to be used during compression.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public CompressionStrategy Strategy { get; set; }
public CompressionStrategy Strategy { get; set; }
Public Property Strategy As CompressionStrategy
    Get
    Set
Public Property Strategy As CompressionStrategy
    Get
    Set
public:
property CompressionStrategy Strategy {
    CompressionStrategy get ();
    void set (CompressionStrategy value);
}
public:
property CompressionStrategy Strategy {
    CompressionStrategy get ();
    void set (CompressionStrategy value);
}
member Strategy : CompressionStrategy with get, set

member Strategy : CompressionStrategy with get, set
Property Value
CompressionStrategy
Remarks
By tweaking this parameter, you may be able to optimize the compression for data with particular characteristics.


TotalIn Property

TotalIn Property
API ► Keyoti.RapidSpell.Compression.Wpf ► DeflateStream ► TotalIn
Keyoti RapidSpell WPF
Returns the total number of bytes input so far.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual long TotalIn { get; }
public virtual long TotalIn { get; }
Public Overridable ReadOnly Property TotalIn As Long
    Get
Public Overridable ReadOnly Property TotalIn As Long
    Get
public:
virtual property long long TotalIn {
    long long get ();
}
public:
virtual property long long TotalIn {
    long long get ();
}
abstract TotalIn : int64 with get
override TotalIn : int64 with get
abstract TotalIn : int64 with get
override TotalIn : int64 with get
Property Value
Int64


TotalOut Property

TotalOut Property
API ► Keyoti.RapidSpell.Compression.Wpf ► DeflateStream ► TotalOut
Keyoti RapidSpell WPF
Returns the total number of bytes output so far.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual long TotalOut { get; }
public virtual long TotalOut { get; }
Public Overridable ReadOnly Property TotalOut As Long
    Get
Public Overridable ReadOnly Property TotalOut As Long
    Get
public:
virtual property long long TotalOut {
    long long get ();
}
public:
virtual property long long TotalOut {
    long long get ();
}
abstract TotalOut : int64 with get
override TotalOut : int64 with get
abstract TotalOut : int64 with get
override TotalOut : int64 with get
Property Value
Int64


UncompressBuffer Method (compressed)

UncompressBuffer Method (compressed)
API ► Keyoti.RapidSpell.Compression.Wpf ► DeflateStream ► UncompressBuffer(array<Byte>[]()[][])
Keyoti RapidSpell WPF
Uncompress a DEFLATE'd byte array into a byte array.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static byte[] UncompressBuffer(
    byte[] compressed
)
public static byte[] UncompressBuffer(
    byte[] compressed
)
Public Shared Function UncompressBuffer (
    compressed As Byte()
) As Byte()
Public Shared Function UncompressBuffer (
    compressed As Byte()
) As Byte()
public:
static array<unsigned char>^ UncompressBuffer(
    array<unsigned char>^ compressed
)
public:
static array<unsigned char>^ UncompressBuffer(
    array<unsigned char>^ compressed
)
static member UncompressBuffer :
        compressed : byte[] -> byte[]

static member UncompressBuffer :
        compressed : byte[] -> byte[]
Parameters
compressed (array< Byte >[]()[][])
A buffer containing data that has been compressed with DEFLATE.
Return Value
array< Byte >[]()[][]
The data in uncompressed form
See Also
DeflateStream.CompressBuffer(byte[])
DeflateStream.UncompressString(byte[])
GZipStream.UncompressBuffer(byte[])
ZlibStream.UncompressBuffer(byte[])


UncompressString Method (compressed)

UncompressString Method (compressed)
API ► Keyoti.RapidSpell.Compression.Wpf ► DeflateStream ► UncompressString(array<Byte>[]()[][])
Keyoti RapidSpell WPF
Uncompress a DEFLATE'd byte array into a single string.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static string UncompressString(
    byte[] compressed
)
public static string UncompressString(
    byte[] compressed
)
Public Shared Function UncompressString (
    compressed As Byte()
) As String
Public Shared Function UncompressString (
    compressed As Byte()
) As String
public:
static String^ UncompressString(
    array<unsigned char>^ compressed
)
public:
static String^ UncompressString(
    array<unsigned char>^ compressed
)
static member UncompressString :
        compressed : byte[] -> string

static member UncompressString :
        compressed : byte[] -> string
Parameters
compressed (array< Byte >[]()[][])
A buffer containing DEFLATE-compressed data.
Return Value
String
The uncompressed string
See Also
DeflateStream.CompressString(String)
DeflateStream.UncompressBuffer(byte[])
GZipStream.UncompressString(byte[])
ZlibStream.UncompressString(byte[])


Write Method (buffer, offset, count)

Write Method (buffer, offset, count)
API ► Keyoti.RapidSpell.Compression.Wpf ► DeflateStream ► Write(array<Byte>[]()[][], Int32, Int32)
Keyoti RapidSpell WPF
Write data to the stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Sub Write (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
Public Overrides Sub Write (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
public:
virtual void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
public:
virtual void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
abstract Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
override Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
abstract Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
override Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
Parameters
buffer (array< Byte >[]()[][])
The buffer holding data to write to the stream.
offset (Int32)
the offset within that data array to find the first byte to write.
count (Int32)
the number of bytes to write.
Remarks

If you wish to use the DeflateStream to compress data while writing, you can create a DeflateStream with CompressionMode.Compress, and a writable output stream. Then call Write() on that DeflateStream, providing uncompressed data as input. The data sent to the output stream will be the compressed form of the data written. If you wish to use the DeflateStream to decompress data while writing, you can create a DeflateStream with CompressionMode.Decompress, and a writable output stream. Then call Write() on that stream, providing previously compressed data. The data sent to the output stream will be the decompressed form of the data written.

A DeflateStream can be used for Read() or Write(), but not both.


FlushType Enumeration

FlushType Enumeration
API ► Keyoti.RapidSpell.Compression.Wpf ► FlushType
Keyoti RapidSpell WPF
Describes how to flush the current deflate operation.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public enum FlushType
public enum FlushType
Public Enumeration FlushType
Public Enumeration FlushType
public enum class FlushType
public enum class FlushType
type FlushType
type FlushType
Members
Member | Description
None | No flush at all.
Partial | Closes the current block, but doesn't flush it to the output. Used internally only in hypothetical scenarios. This was supposed to be removed by Zlib, but it is still in use in some edge cases.
Sync | Use this during compression to specify that all pending output should be flushed to the output buffer and the output should be aligned on a byte boundary. You might use this in a streaming communication scenario, so that the decompressor can get all input data available so far. When using this with a ZlibCodec, AvailableBytesIn will be zero after the call if enough output space has been provided before the call. Flushing will degrade compression and so it should be used only when necessary.
Full | Use this during compression to specify that all output should be flushed, as with FlushType.Sync, but also, the compression state should be reset so that decompression can restart from this point if previous compressed data has been damaged or if random access is desired. Using FlushType.Full too often can significantly degrade the compression.
Finish | Signals the end of the compression/decompression stream.
Remarks
The different FlushType values are useful when using a Deflate in a streaming application.


GZipStream Class

GZipStream Class
API ► Keyoti.RapidSpell.Compression.Wpf ► GZipStream
Keyoti RapidSpell WPF
A class for compressing and decompressing GZIP streams.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class GZipStream : Stream
public class GZipStream : Stream
Public Class GZipStream
    Inherits Stream
Public Class GZipStream
    Inherits Stream
public ref class GZipStream : public Stream
public ref class GZipStream : public Stream
type GZipStream =
    class
        inherit Stream
    end
type GZipStream =
    class
        inherit Stream
    end
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GZipStream(Stream, CompressionMode) | Create a GZipStream using the specified CompressionMode.
 | GZipStream(Stream, CompressionMode, CompressionLevel) | Create a GZipStream using the specified CompressionMode and the specified CompressionLevel.
 | GZipStream(Stream, CompressionMode, Boolean) | Create a GZipStream using the specified CompressionMode, and explicitly specify whether the stream should be left open after Deflation or Inflation.
 | GZipStream(Stream, CompressionMode, CompressionLevel, Boolean) | Create a GZipStream using the specified CompressionMode and the specified CompressionLevel, and explicitly specify whether the stream should be left open after Deflation or Inflation.
 | BeginRead(array<Byte>[]()[][], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous read operation. (Inherited from Stream.)
 | BeginWrite(array<Byte>[]()[][], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous write operation. (Inherited from Stream.)
 | BufferSize | The size of the working buffer for the compression codec.
 | CanRead | Indicates whether the stream can be read. (Overrides Stream.CanRead.)
 | CanSeek | Indicates whether the stream supports Seek operations. (Overrides Stream.CanSeek.)
 | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
 | CanWrite | Indicates whether the stream can be written. (Overrides Stream.CanWrite.)
 | Close()()()() | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. (Inherited from Stream.)
 | Comment | The comment on the GZIP stream.
 | CompressBuffer(array<Byte>[]()[][]) | Compress a byte array into a new byte array using GZip.
 | CompressString(String) | Compress a string into a byte array using GZip.
 | Crc32 | The CRC on the GZIP stream.
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateWaitHandle()()()() | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
 | Dispose(Boolean) | Dispose the stream.
 | Dispose()()()() | Releases all resources used by the Stream. (Inherited from Stream.)
 | EndRead(IAsyncResult) | Waits for the pending asynchronous read to complete. (Inherited from Stream.)
 | EndWrite(IAsyncResult) | Ends an asynchronous write operation. (Inherited from Stream.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FileName | The FileName for the GZIP stream.
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | Flush()()()() | Flush the stream. (Overrides Stream.Flush()()()().)
 | FlushMode | This property sets the flush behavior on the stream.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | LastModified | The last modified time for the GZIP stream.
 | Length | Reading this property always throws a NotImplementedException. (Overrides Stream.Length.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Position | The position of the stream pointer. (Overrides Stream.Position.)
 | Read(array<Byte>[]()[][], Int32, Int32) | Read and decompress data from the source stream. (Overrides Stream.Read(array<Byte>[]()[][], Int32, Int32).)
 | ReadByte()()()() | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
 | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
 | Seek(Int64, SeekOrigin) | Calling this method always throws a NotImplementedException. (Overrides Stream.Seek(Int64, SeekOrigin).)
 | SetLength(Int64) | Calling this method always throws a NotImplementedException. (Overrides Stream.SetLength(Int64).)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | TotalIn | Returns the total number of bytes input so far.
 | TotalOut | Returns the total number of bytes output so far.
 | UncompressBuffer(array<Byte>[]()[][]) | Uncompress a GZip'ed byte array into a byte array.
 | UncompressString(array<Byte>[]()[][]) | Uncompress a GZip'ed byte array into a single string.
 | Write(array<Byte>[]()[][], Int32, Int32) | Write data to the stream. (Overrides Stream.Write(array<Byte>[]()[][], Int32, Int32).)
 | WriteByte(Byte) | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
 | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Remarks

The GZipStream is a Decorator on a Stream. It adds GZIP compression or decompression to any stream.

Like the System.IO.Compression.GZipStream in the .NET Base Class Library, the Keyoti.RapidSpell.Compression.GZipStream can compress while writing, or decompress while reading, but not vice versa. The compression method used is GZIP, which is documented in IETF RFC 1952, "GZIP file format specification version 4.3".

A GZipStream can be used to decompress data (through Read()) or to compress data (through Write()), but not both.

If you wish to use the GZipStream to compress data, you must wrap it around a write-able stream. As you call Write() on the GZipStream, the data will be compressed into the GZIP format. If you want to decompress data, you must wrap the GZipStream around a readable stream that contains an IETF RFC 1952-compliant stream. The data will be decompressed as you call Read() on the GZipStream.

Though the GZIP format allows data from multiple files to be concatenated together, this stream handles only a single segment of GZIP format, typically representing a single file.

This class is similar to ZlibStream and DeflateStream. ZlibStream handles RFC1950-compliant streams. DeflateStream handles RFC1951-compliant streams. This class handles RFC1952-compliant streams.

Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Stream
 |  |  | GZipStream
See Also
DeflateStream
ZlibStream


GZipStream Constructor

GZipStream Constructor
API ► Keyoti.RapidSpell.Compression.Wpf ► GZipStream ► GZipStream()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | GZipStream(Stream, CompressionMode) | Create a GZipStream using the specified CompressionMode.
 | GZipStream(Stream, CompressionMode, CompressionLevel) | Create a GZipStream using the specified CompressionMode and the specified CompressionLevel.
 | GZipStream(Stream, CompressionMode, Boolean) | Create a GZipStream using the specified CompressionMode, and explicitly specify whether the stream should be left open after Deflation or Inflation.
 | GZipStream(Stream, CompressionMode, CompressionLevel, Boolean) | Create a GZipStream using the specified CompressionMode and the specified CompressionLevel, and explicitly specify whether the stream should be left open after Deflation or Inflation.


GZipStream Constructor (stream, mode)

GZipStream Constructor (stream, mode)
API ► Keyoti.RapidSpell.Compression.Wpf ► GZipStream ► GZipStream(Stream, CompressionMode)
Keyoti RapidSpell WPF
Create a GZipStream using the specified CompressionMode.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public GZipStream(
    Stream stream,
    CompressionMode mode
)
public GZipStream(
    Stream stream,
    CompressionMode mode
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode
)
public:
GZipStream(
    Stream^ stream,
    CompressionMode mode
)
public:
GZipStream(
    Stream^ stream,
    CompressionMode mode
)
new :
        stream : Stream *
        mode : CompressionMode -> GZipStream
new :
        stream : Stream *
        mode : CompressionMode -> GZipStream
Parameters
stream (Stream)
The stream which will be read or written.
mode (CompressionMode)
Indicates whether the GZipStream will compress or decompress.
Remarks

When mode is CompressionMode.Compress, the GZipStream will use the default compression level.

As noted in the class documentation, the CompressionMode (Compress or Decompress) also establishes the "direction" of the stream. A GZipStream with CompressionMode.Compress works only through Write(). A GZipStream with CompressionMode.Decompress works only through Read().

Examples
This example shows how to use a GZipStream to compress data.
Copy image Copy
using (System.IO.Stream input = System.IO.File.OpenRead(fileToCompress))
{
    using (var raw = System.IO.File.Create(outputFile))
    {
        using (Stream compressor = new GZipStream(raw, CompressionMode.Compress))
        {
            byte[] buffer = new byte[WORKING_BUFFER_SIZE];
            int n;
            while ((n= input.Read(buffer, 0, buffer.Length)) != 0)
            {
                compressor.Write(buffer, 0, n);
            }
        }
    }
}
Visual Basic Copy image Copy
Dim outputFile As String = (fileToCompress & ".compressed")
Using input As Stream = File.OpenRead(fileToCompress)
    Using raw As FileStream = File.Create(outputFile)
    Using compressor As Stream = New GZipStream(raw, CompressionMode.Compress)
        Dim buffer As Byte() = New Byte(4096) {}
        Dim n As Integer = -1
        Do While (n <> 0)
            If (n > 0) Then
                compressor.Write(buffer, 0, n)
            End If
            n = input.Read(buffer, 0, buffer.Length)
        Loop
    End Using
    End Using
End Using
Examples
This example shows how to use a GZipStream to uncompress a file.
Copy image Copy
private void GunZipFile(string filename)
{
    if (!filename.EndsWith(".gz))
        throw new ArgumentException("filename");
    var DecompressedFile = filename.Substring(0,filename.Length-3);
    byte[] working = new byte[WORKING_BUFFER_SIZE];
    int n= 1;
    using (System.IO.Stream input = System.IO.File.OpenRead(filename))
    {
        using (Stream decompressor= new Keyoti.RapidSpell.Compression.GZipStream(input, CompressionMode.Decompress, true))
        {
            using (var output = System.IO.File.Create(DecompressedFile))
            {
                while (n !=0)
                {
                    n= decompressor.Read(working, 0, working.Length);
                    if (n > 0)
                    {
                        output.Write(working, 0, n);
                    }
                }
            }
        }
    }
}
Visual Basic Copy image Copy
Private Sub GunZipFile(ByVal filename as String)
    If Not (filename.EndsWith(".gz)) Then
        Throw New ArgumentException("filename")
    End If
    Dim DecompressedFile as String = filename.Substring(0,filename.Length-3)
    Dim working(WORKING_BUFFER_SIZE) as Byte
    Dim n As Integer = 1
    Using input As Stream = File.OpenRead(filename)
        Using decompressor As Stream = new Keyoti.RapidSpell.Compression.GZipStream(input, CompressionMode.Decompress, True)
            Using output As Stream = File.Create(UncompressedFile)
                Do
                    n= decompressor.Read(working, 0, working.Length)
                    If n > 0 Then
                        output.Write(working, 0, n)
                    End IF
                Loop While (n  > 0)
            End Using
        End Using
    End Using
End Sub


GZipStream Constructor (stream, mode, level)

GZipStream Constructor (stream, mode, level)
API ► Keyoti.RapidSpell.Compression.Wpf ► GZipStream ► GZipStream(Stream, CompressionMode, CompressionLevel)
Keyoti RapidSpell WPF
Create a GZipStream using the specified CompressionMode and the specified CompressionLevel.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public GZipStream(
    Stream stream,
    CompressionMode mode,
    CompressionLevel level
)
public GZipStream(
    Stream stream,
    CompressionMode mode,
    CompressionLevel level
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode,
    level As CompressionLevel
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode,
    level As CompressionLevel
)
public:
GZipStream(
    Stream^ stream,
    CompressionMode mode,
    CompressionLevel level
)
public:
GZipStream(
    Stream^ stream,
    CompressionMode mode,
    CompressionLevel level
)
new :
        stream : Stream *
        mode : CompressionMode *
        level : CompressionLevel -> GZipStream
new :
        stream : Stream *
        mode : CompressionMode *
        level : CompressionLevel -> GZipStream
Parameters
stream (Stream)
The stream to be read or written while deflating or inflating.
mode (CompressionMode)
Indicates whether the GZipStream will compress or decompress.
level (CompressionLevel)
A tuning knob to trade speed for effectiveness.
Remarks

The CompressionMode (Compress or Decompress) also establishes the "direction" of the stream. A GZipStream with CompressionMode.Compress works only through Write(). A GZipStream with CompressionMode.Decompress works only through Read().

Examples
This example shows how to use a GZipStream to compress a file into a .gz file.
Copy image Copy
using (System.IO.Stream input = System.IO.File.OpenRead(fileToCompress))
{
    using (var raw = System.IO.File.Create(fileToCompress + ".gz"))
    {
        using (Stream compressor = new GZipStream(raw,
                                                  CompressionMode.Compress,
                                                  CompressionLevel.BestCompression))
        {
            byte[] buffer = new byte[WORKING_BUFFER_SIZE];
            int n;
            while ((n= input.Read(buffer, 0, buffer.Length)) != 0)
            {
                compressor.Write(buffer, 0, n);
            }
        }
    }
}
Visual Basic Copy image Copy
Using input As Stream = File.OpenRead(fileToCompress)
    Using raw As FileStream = File.Create(fileToCompress & ".gz")
        Using compressor As Stream = New GZipStream(raw, CompressionMode.Compress, CompressionLevel.BestCompression)
            Dim buffer As Byte() = New Byte(4096) {}
            Dim n As Integer = -1
            Do While (n <> 0)
                If (n > 0) Then
                    compressor.Write(buffer, 0, n)
                End If
                n = input.Read(buffer, 0, buffer.Length)
            Loop
        End Using
    End Using
End Using


GZipStream Constructor (stream, mode, level, leaveOpen)

GZipStream Constructor (stream, mode, level, leaveOpen)
API ► Keyoti.RapidSpell.Compression.Wpf ► GZipStream ► GZipStream(Stream, CompressionMode, CompressionLevel, Boolean)
Keyoti RapidSpell WPF
Create a GZipStream using the specified CompressionMode and the specified CompressionLevel, and explicitly specify whether the stream should be left open after Deflation or Inflation.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public GZipStream(
    Stream stream,
    CompressionMode mode,
    CompressionLevel level,
    bool leaveOpen
)
public GZipStream(
    Stream stream,
    CompressionMode mode,
    CompressionLevel level,
    bool leaveOpen
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode,
    level As CompressionLevel,
    leaveOpen As Boolean
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode,
    level As CompressionLevel,
    leaveOpen As Boolean
)
public:
GZipStream(
    Stream^ stream,
    CompressionMode mode,
    CompressionLevel level,
    bool leaveOpen
)
public:
GZipStream(
    Stream^ stream,
    CompressionMode mode,
    CompressionLevel level,
    bool leaveOpen
)
new :
        stream : Stream *
        mode : CompressionMode *
        level : CompressionLevel *
        leaveOpen : bool -> GZipStream
new :
        stream : Stream *
        mode : CompressionMode *
        level : CompressionLevel *
        leaveOpen : bool -> GZipStream
Parameters
stream (Stream)
The stream which will be read or written.
mode (CompressionMode)
Indicates whether the GZipStream will compress or decompress.
level (CompressionLevel)
A tuning knob to trade speed for effectiveness.
leaveOpen (Boolean)
true if the application would like the stream to remain open after inflation/deflation.
Remarks

This constructor allows the application to request that the captive stream remain open after the deflation or inflation occurs. By default, after Close() is called on the stream, the captive stream is also closed. In some cases this is not desired, for example if the stream is a memory stream that will be re-read after compressed data has been written to it. Specify true for the leaveOpen parameter to leave the stream open.

As noted in the class documentation, the CompressionMode (Compress or Decompress) also establishes the "direction" of the stream. A GZipStream with CompressionMode.Compress works only through Write(). A GZipStream with CompressionMode.Decompress works only through Read().

Examples
This example shows how to use a GZipStream to compress data.
Copy image Copy
using (System.IO.Stream input = System.IO.File.OpenRead(fileToCompress))
{
    using (var raw = System.IO.File.Create(outputFile))
    {
        using (Stream compressor = new GZipStream(raw, CompressionMode.Compress, CompressionLevel.BestCompression, true))
        {
            byte[] buffer = new byte[WORKING_BUFFER_SIZE];
            int n;
            while ((n= input.Read(buffer, 0, buffer.Length)) != 0)
            {
                compressor.Write(buffer, 0, n);
            }
        }
    }
}
Visual Basic Copy image Copy
Dim outputFile As String = (fileToCompress & ".compressed")
Using input As Stream = File.OpenRead(fileToCompress)
    Using raw As FileStream = File.Create(outputFile)
    Using compressor As Stream = New GZipStream(raw, CompressionMode.Compress, CompressionLevel.BestCompression, True)
        Dim buffer As Byte() = New Byte(4096) {}
        Dim n As Integer = -1
        Do While (n <> 0)
            If (n > 0) Then
                compressor.Write(buffer, 0, n)
            End If
            n = input.Read(buffer, 0, buffer.Length)
        Loop
    End Using
    End Using
End Using


GZipStream Constructor (stream, mode, leaveOpen)

GZipStream Constructor (stream, mode, leaveOpen)
API ► Keyoti.RapidSpell.Compression.Wpf ► GZipStream ► GZipStream(Stream, CompressionMode, Boolean)
Keyoti RapidSpell WPF
Create a GZipStream using the specified CompressionMode, and explicitly specify whether the stream should be left open after Deflation or Inflation.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public GZipStream(
    Stream stream,
    CompressionMode mode,
    bool leaveOpen
)
public GZipStream(
    Stream stream,
    CompressionMode mode,
    bool leaveOpen
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode,
    leaveOpen As Boolean
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode,
    leaveOpen As Boolean
)
public:
GZipStream(
    Stream^ stream,
    CompressionMode mode,
    bool leaveOpen
)
public:
GZipStream(
    Stream^ stream,
    CompressionMode mode,
    bool leaveOpen
)
new :
        stream : Stream *
        mode : CompressionMode *
        leaveOpen : bool -> GZipStream
new :
        stream : Stream *
        mode : CompressionMode *
        leaveOpen : bool -> GZipStream
Parameters
stream (Stream)
The stream which will be read or written. This is called the "captive" stream in other places in this documentation.
mode (CompressionMode)
Indicates whether the GZipStream will compress or decompress.
leaveOpen (Boolean)
true if the application would like the base stream to remain open after inflation/deflation.
Remarks

This constructor allows the application to request that the captive stream remain open after the deflation or inflation occurs. By default, after Close() is called on the stream, the captive stream is also closed. In some cases this is not desired, for example if the stream is a memory stream that will be re-read after compressed data has been written to it. Specify true for the leaveOpen parameter to leave the stream open.

The CompressionMode (Compress or Decompress) also establishes the "direction" of the stream. A GZipStream with CompressionMode.Compress works only through Write(). A GZipStream with CompressionMode.Decompress works only through Read().

The GZipStream will use the default compression level. If you want to specify the compression level, see GZipStream(Stream, CompressionMode, CompressionLevel, Boolean).

See the other overloads of this constructor for example code.


BufferSize Property

BufferSize Property
API ► Keyoti.RapidSpell.Compression.Wpf ► GZipStream ► BufferSize
Keyoti RapidSpell WPF
The size of the working buffer for the compression codec.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int BufferSize { get; set; }
public int BufferSize { get; set; }
Public Property BufferSize As Integer
    Get
    Set
Public Property BufferSize As Integer
    Get
    Set
public:
property int BufferSize {
    int get ();
    void set (int value);
}
public:
property int BufferSize {
    int get ();
    void set (int value);
}
member BufferSize : int with get, set

member BufferSize : int with get, set
Property Value
Int32
Remarks

The working buffer is used for all stream operations. The default size is 1024 bytes. The minimum size is 128 bytes. You may get better performance with a larger buffer. Then again, you might not. You would have to test it.

Set this before the first call to Read() or Write() on the stream. If you try to set it afterwards, it will throw.


CanRead Property

CanRead Property
API ► Keyoti.RapidSpell.Compression.Wpf ► GZipStream ► CanRead
Keyoti RapidSpell WPF
Indicates whether the stream can be read.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override bool CanRead { get; }
public override bool CanRead { get; }
Public Overrides ReadOnly Property CanRead As Boolean
    Get
Public Overrides ReadOnly Property CanRead As Boolean
    Get
public:
virtual property bool CanRead {
    bool get () override;
}
public:
virtual property bool CanRead {
    bool get () override;
}
abstract CanRead : bool with get
override CanRead : bool with get
abstract CanRead : bool with get
override CanRead : bool with get
Property Value
Boolean
Remarks
The return value depends on whether the captive stream supports reading.


CanSeek Property

CanSeek Property
API ► Keyoti.RapidSpell.Compression.Wpf ► GZipStream ► CanSeek
Keyoti RapidSpell WPF
Indicates whether the stream supports Seek operations.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override bool CanSeek { get; }
public override bool CanSeek { get; }
Public Overrides ReadOnly Property CanSeek As Boolean
    Get
Public Overrides ReadOnly Property CanSeek As Boolean
    Get
public:
virtual property bool CanSeek {
    bool get () override;
}
public:
virtual property bool CanSeek {
    bool get () override;
}
abstract CanSeek : bool with get
override CanSeek : bool with get
abstract CanSeek : bool with get
override CanSeek : bool with get
Property Value
Boolean
Remarks
Always returns false.


CanWrite Property

CanWrite Property
API ► Keyoti.RapidSpell.Compression.Wpf ► GZipStream ► CanWrite
Keyoti RapidSpell WPF
Indicates whether the stream can be written.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override bool CanWrite { get; }
public override bool CanWrite { get; }
Public Overrides ReadOnly Property CanWrite As Boolean
    Get
Public Overrides ReadOnly Property CanWrite As Boolean
    Get
public:
virtual property bool CanWrite {
    bool get () override;
}
public:
virtual property bool CanWrite {
    bool get () override;
}
abstract CanWrite : bool with get
override CanWrite : bool with get
abstract CanWrite : bool with get
override CanWrite : bool with get
Property Value
Boolean
Remarks
The return value depends on whether the captive stream supports writing.


Comment Property

Comment Property
API ► Keyoti.RapidSpell.Compression.Wpf ► GZipStream ► Comment
Keyoti RapidSpell WPF
The comment on the GZIP stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string Comment { get; set; }
public string Comment { get; set; }
Public Property Comment As String
    Get
    Set
Public Property Comment As String
    Get
    Set
public:
property String^ Comment {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Comment {
    String^ get ();
    void set (String^ value);
}
member Comment : string with get, set

member Comment : string with get, set
Property Value
String
Remarks

The GZIP format allows for each file to optionally have an associated comment stored with the file. The comment is encoded with the ISO-8859-1 code page. To include a comment in a GZIP stream you create, set this property before calling Write() for the first time on the GZipStream.

When using GZipStream to decompress, you can retrieve this property after the first call to Read(). If no comment has been set in the GZIP bytestream, the Comment property will return null (Nothing in VB).


CompressBuffer Method (b)

CompressBuffer Method (b)
API ► Keyoti.RapidSpell.Compression.Wpf ► GZipStream ► CompressBuffer(array<Byte>[]()[][])
Keyoti RapidSpell WPF
Compress a byte array into a new byte array using GZip.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static byte[] CompressBuffer(
    byte[] b
)
public static byte[] CompressBuffer(
    byte[] b
)
Public Shared Function CompressBuffer (
    b As Byte()
) As Byte()
Public Shared Function CompressBuffer (
    b As Byte()
) As Byte()
public:
static array<unsigned char>^ CompressBuffer(
    array<unsigned char>^ b
)
public:
static array<unsigned char>^ CompressBuffer(
    array<unsigned char>^ b
)
static member CompressBuffer :
        b : byte[] -> byte[]

static member CompressBuffer :
        b : byte[] -> byte[]
Parameters
b (array< Byte >[]()[][])
A buffer to compress.
Return Value
array< Byte >[]()[][]
The data in compressed form
Remarks
Uncompress it with UncompressBuffer(array<Byte>[]()[][]).
See Also
CompressString(String)
UncompressBuffer(array<Byte>[]()[][])


CompressString Method (s)

CompressString Method (s)
API ► Keyoti.RapidSpell.Compression.Wpf ► GZipStream ► CompressString(String)
Keyoti RapidSpell WPF
Compress a string into a byte array using GZip.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static byte[] CompressString(
    string s
)
public static byte[] CompressString(
    string s
)
Public Shared Function CompressString (
    s As String
) As Byte()
Public Shared Function CompressString (
    s As String
) As Byte()
public:
static array<unsigned char>^ CompressString(
    String^ s
)
public:
static array<unsigned char>^ CompressString(
    String^ s
)
static member CompressString :
        s : string -> byte[]

static member CompressString :
        s : string -> byte[]
Parameters
s (String)
A string to compress. The string will first be encoded using UTF8, then compressed.
Return Value
array< Byte >[]()[][]
The string in compressed form
Remarks
Uncompress it with UncompressString(array<Byte>[]()[][]).
See Also
UncompressString(array<Byte>[]()[][])
CompressBuffer(array<Byte>[]()[][])


Crc32 Property

Crc32 Property
API ► Keyoti.RapidSpell.Compression.Wpf ► GZipStream ► Crc32
Keyoti RapidSpell WPF
The CRC on the GZIP stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int Crc32 { get; }
public int Crc32 { get; }
Public ReadOnly Property Crc32 As Integer
    Get
Public ReadOnly Property Crc32 As Integer
    Get
public:
property int Crc32 {
    int get ();
}
public:
property int Crc32 {
    int get ();
}
member Crc32 : int with get

member Crc32 : int with get
Property Value
Int32
Remarks
This is used for internal error checking. You probably don't need to look at this property.


Dispose Method (disposing)

Dispose Method (disposing)
API ► Keyoti.RapidSpell.Compression.Wpf ► GZipStream ► Dispose(Boolean)
Keyoti RapidSpell WPF
Dispose the stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected void Dispose(
    bool disposing
)
protected void Dispose(
    bool disposing
)
Protected Sub Dispose (
    disposing As Boolean
)
Protected Sub Dispose (
    disposing As Boolean
)
protected:
void Dispose(
    bool disposing
)
protected:
void Dispose(
    bool disposing
)
member Dispose :
        disposing : bool -> unit

member Dispose :
        disposing : bool -> unit
Parameters
disposing (Boolean)
Remarks
This may or may not result in a Close() call on the captive stream. See the doc on constructors that take a leaveOpen parameter for more information.


FileName Property

FileName Property
API ► Keyoti.RapidSpell.Compression.Wpf ► GZipStream ► FileName
Keyoti RapidSpell WPF
The FileName for the GZIP stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string FileName { get; set; }
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
Public Property FileName As String
    Get
    Set
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
member FileName : string with get, set

member FileName : string with get, set
Property Value
String
Remarks

The GZIP format optionally allows each file to have an associated filename. When compressing data (through Write()), set this FileName before calling Write() the first time on the GZipStream. The actual filename is encoded into the GZIP bytestream with the ISO-8859-1 code page, according to RFC 1952. It is the application's responsibility to insure that the FileName can be encoded and decoded correctly with this code page.

When decompressing (through Read()), you can retrieve this value any time after the first Read(). In the case where there was no filename encoded into the GZIP bytestream, the property will return null (Nothing in VB).


Flush Method

Flush Method
API ► Keyoti.RapidSpell.Compression.Wpf ► GZipStream ► Flush()()()()
Keyoti RapidSpell WPF
Flush the stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override void Flush()
public override void Flush()
Public Overrides Sub Flush
Public Overrides Sub Flush
public:
virtual void Flush() override
public:
virtual void Flush() override
abstract Flush : unit -> unit
override Flush : unit -> unit
abstract Flush : unit -> unit
override Flush : unit -> unit


FlushMode Property

FlushMode Property
API ► Keyoti.RapidSpell.Compression.Wpf ► GZipStream ► FlushMode
Keyoti RapidSpell WPF
This property sets the flush behavior on the stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual FlushType FlushMode { get; set; }
public virtual FlushType FlushMode { get; set; }
Public Overridable Property FlushMode As FlushType
    Get
    Set
Public Overridable Property FlushMode As FlushType
    Get
    Set
public:
virtual property FlushType FlushMode {
    FlushType get ();
    void set (FlushType value);
}
public:
virtual property FlushType FlushMode {
    FlushType get ();
    void set (FlushType value);
}
abstract FlushMode : FlushType with get, set
override FlushMode : FlushType with get, set
abstract FlushMode : FlushType with get, set
override FlushMode : FlushType with get, set
Property Value
FlushType


LastModified Field

LastModified Field
API ► Keyoti.RapidSpell.Compression.Wpf ► GZipStream ► LastModified
Keyoti RapidSpell WPF
The last modified time for the GZIP stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public DateTime LastModified
public DateTime LastModified
Public LastModified As DateTime
Public LastModified As DateTime
public:
DateTime LastModified
public:
DateTime LastModified
val mutable LastModified: DateTime
val mutable LastModified: DateTime
Field Value
DateTime
Remarks
GZIP allows the storage of a last modified time with each GZIP entry. When compressing data, you can set this before the first call to Write(). When decompressing, you can retrieve this value any time after the first call to Read().


Length Property

Length Property
API ► Keyoti.RapidSpell.Compression.Wpf ► GZipStream ► Length
Keyoti RapidSpell WPF
Reading this property always throws a NotImplementedException.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override long Length { get; }
public override long Length { get; }
Public Overrides ReadOnly Property Length As Long
    Get
Public Overrides ReadOnly Property Length As Long
    Get
public:
virtual property long long Length {
    long long get () override;
}
public:
virtual property long long Length {
    long long get () override;
}
abstract Length : int64 with get
override Length : int64 with get
abstract Length : int64 with get
override Length : int64 with get
Property Value
Int64


Position Property

Position Property
API ► Keyoti.RapidSpell.Compression.Wpf ► GZipStream ► Position
Keyoti RapidSpell WPF
The position of the stream pointer.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override long Position { get; set; }
public override long Position { get; set; }
Public Overrides Property Position As Long
    Get
    Set
Public Overrides Property Position As Long
    Get
    Set
public:
virtual property long long Position {
    long long get () override;
    void set (long long value) override;
}
public:
virtual property long long Position {
    long long get () override;
    void set (long long value) override;
}
abstract Position : int64 with get, set
override Position : int64 with get, set
abstract Position : int64 with get, set
override Position : int64 with get, set
Property Value
Int64
Remarks
Setting this property always throws a NotImplementedException. Reading will return the total bytes written out, if used in writing, or the total bytes read in, if used in reading. The count may refer to compressed bytes or uncompressed bytes, depending on how you've used the stream.


Read Method (buffer, offset, count)

Read Method (buffer, offset, count)
API ► Keyoti.RapidSpell.Compression.Wpf ► GZipStream ► Read(array<Byte>[]()[][], Int32, Int32)
Keyoti RapidSpell WPF
Read and decompress data from the source stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Function Read (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
Public Overrides Function Read (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
abstract Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
override Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
abstract Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
override Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
Parameters
buffer (array< Byte >[]()[][])
The buffer into which the decompressed data should be placed.
offset (Int32)
the offset within that data array to put the first byte read.
count (Int32)
the number of bytes to read.
Return Value
Int32
the number of bytes actually read
Remarks
With a GZipStream, decompression is done through reading.
Examples
Copy image Copy
byte[] working = new byte[WORKING_BUFFER_SIZE];
using (System.IO.Stream input = System.IO.File.OpenRead(_CompressedFile))
{
    using (Stream decompressor= new Keyoti.RapidSpell.Compression.GZipStream(input, CompressionMode.Decompress, true))
    {
        using (var output = System.IO.File.Create(_DecompressedFile))
        {
            int n;
            while ((n= decompressor.Read(working, 0, working.Length)) !=0)
            {
                output.Write(working, 0, n);
            }
        }
    }
}


Seek Method (offset, origin)

Seek Method (offset, origin)
API ► Keyoti.RapidSpell.Compression.Wpf ► GZipStream ► Seek(Int64, SeekOrigin)
Keyoti RapidSpell WPF
Calling this method always throws a NotImplementedException.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override long Seek(
    long offset,
    SeekOrigin origin
)
public override long Seek(
    long offset,
    SeekOrigin origin
)
Public Overrides Function Seek (
    offset As Long,
    origin As SeekOrigin
) As Long
Public Overrides Function Seek (
    offset As Long,
    origin As SeekOrigin
) As Long
public:
virtual long long Seek(
    long long offset,
    SeekOrigin origin
) override
public:
virtual long long Seek(
    long long offset,
    SeekOrigin origin
) override
abstract Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
override Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
abstract Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
override Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
Parameters
offset (Int64)
irrelevant; it will always throw!
origin (SeekOrigin)
irrelevant; it will always throw!
Return Value
Int64
irrelevant!


SetLength Method (value)

SetLength Method (value)
API ► Keyoti.RapidSpell.Compression.Wpf ► GZipStream ► SetLength(Int64)
Keyoti RapidSpell WPF
Calling this method always throws a NotImplementedException.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override void SetLength(
    long value
)
public override void SetLength(
    long value
)
Public Overrides Sub SetLength (
    value As Long
)
Public Overrides Sub SetLength (
    value As Long
)
public:
virtual void SetLength(
    long long value
) override
public:
virtual void SetLength(
    long long value
) override
abstract SetLength :
        value : int64 -> unit
override SetLength :
        value : int64 -> unit
abstract SetLength :
        value : int64 -> unit
override SetLength :
        value : int64 -> unit
Parameters
value (Int64)
irrelevant; this method will always throw!


TotalIn Property

TotalIn Property
API ► Keyoti.RapidSpell.Compression.Wpf ► GZipStream ► TotalIn
Keyoti RapidSpell WPF
Returns the total number of bytes input so far.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual long TotalIn { get; }
public virtual long TotalIn { get; }
Public Overridable ReadOnly Property TotalIn As Long
    Get
Public Overridable ReadOnly Property TotalIn As Long
    Get
public:
virtual property long long TotalIn {
    long long get ();
}
public:
virtual property long long TotalIn {
    long long get ();
}
abstract TotalIn : int64 with get
override TotalIn : int64 with get
abstract TotalIn : int64 with get
override TotalIn : int64 with get
Property Value
Int64


TotalOut Property

TotalOut Property
API ► Keyoti.RapidSpell.Compression.Wpf ► GZipStream ► TotalOut
Keyoti RapidSpell WPF
Returns the total number of bytes output so far.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual long TotalOut { get; }
public virtual long TotalOut { get; }
Public Overridable ReadOnly Property TotalOut As Long
    Get
Public Overridable ReadOnly Property TotalOut As Long
    Get
public:
virtual property long long TotalOut {
    long long get ();
}
public:
virtual property long long TotalOut {
    long long get ();
}
abstract TotalOut : int64 with get
override TotalOut : int64 with get
abstract TotalOut : int64 with get
override TotalOut : int64 with get
Property Value
Int64


UncompressBuffer Method (compressed)

UncompressBuffer Method (compressed)
API ► Keyoti.RapidSpell.Compression.Wpf ► GZipStream ► UncompressBuffer(array<Byte>[]()[][])
Keyoti RapidSpell WPF
Uncompress a GZip'ed byte array into a byte array.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static byte[] UncompressBuffer(
    byte[] compressed
)
public static byte[] UncompressBuffer(
    byte[] compressed
)
Public Shared Function UncompressBuffer (
    compressed As Byte()
) As Byte()
Public Shared Function UncompressBuffer (
    compressed As Byte()
) As Byte()
public:
static array<unsigned char>^ UncompressBuffer(
    array<unsigned char>^ compressed
)
public:
static array<unsigned char>^ UncompressBuffer(
    array<unsigned char>^ compressed
)
static member UncompressBuffer :
        compressed : byte[] -> byte[]

static member UncompressBuffer :
        compressed : byte[] -> byte[]
Parameters
compressed (array< Byte >[]()[][])
A buffer containing data that has been compressed with GZip.
Return Value
array< Byte >[]()[][]
The data in uncompressed form
See Also
CompressBuffer(array<Byte>[]()[][])
UncompressString(array<Byte>[]()[][])


UncompressString Method (compressed)

UncompressString Method (compressed)
API ► Keyoti.RapidSpell.Compression.Wpf ► GZipStream ► UncompressString(array<Byte>[]()[][])
Keyoti RapidSpell WPF
Uncompress a GZip'ed byte array into a single string.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static string UncompressString(
    byte[] compressed
)
public static string UncompressString(
    byte[] compressed
)
Public Shared Function UncompressString (
    compressed As Byte()
) As String
Public Shared Function UncompressString (
    compressed As Byte()
) As String
public:
static String^ UncompressString(
    array<unsigned char>^ compressed
)
public:
static String^ UncompressString(
    array<unsigned char>^ compressed
)
static member UncompressString :
        compressed : byte[] -> string

static member UncompressString :
        compressed : byte[] -> string
Parameters
compressed (array< Byte >[]()[][])
A buffer containing GZIP-compressed data.
Return Value
String
The uncompressed string
See Also
CompressString(String)
UncompressBuffer(array<Byte>[]()[][])


Write Method (buffer, offset, count)

Write Method (buffer, offset, count)
API ► Keyoti.RapidSpell.Compression.Wpf ► GZipStream ► Write(array<Byte>[]()[][], Int32, Int32)
Keyoti RapidSpell WPF
Write data to the stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Sub Write (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
Public Overrides Sub Write (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
public:
virtual void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
public:
virtual void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
abstract Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
override Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
abstract Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
override Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
Parameters
buffer (array< Byte >[]()[][])
The buffer holding data to write to the stream.
offset (Int32)
the offset within that data array to find the first byte to write.
count (Int32)
the number of bytes to write.
Remarks

If you wish to use the GZipStream to compress data while writing, you can create a GZipStream with CompressionMode.Compress, and a writable output stream. Then call Write() on that GZipStream, providing uncompressed data as input. The data sent to the output stream will be the compressed form of the data written.

A GZipStream can be used for Read() or Write(), but not both. Writing implies compression. Reading implies decompression.


ZlibCodec Class

ZlibCodec Class
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibCodec
Keyoti RapidSpell WPF
Encoder and Decoder for ZLIB and DEFLATE (IETF RFC1950 and RFC1951).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public sealed class ZlibCodec
public sealed class ZlibCodec
Public NotInheritable Class ZlibCodec
Public NotInheritable Class ZlibCodec
public ref class ZlibCodec sealed
public ref class ZlibCodec sealed
[<SealedAttribute>]
type ZlibCodec =  class end
[<SealedAttribute>]
type ZlibCodec =  class end
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZlibCodec()()()() | Create a ZlibCodec.
 | ZlibCodec(CompressionMode) | Create a ZlibCodec that either compresses or decompresses.
 | Adler32 | The Adler32 checksum on the data transferred through the codec so far. You probably don't need to look at this.
 | AvailableBytesIn | The number of bytes available in the InputBuffer, starting at NextIn.
 | AvailableBytesOut | The number of bytes available in the OutputBuffer, starting at NextOut.
 | CompressLevel | The compression level to use in this codec. Useful only in compression mode.
 | Deflate(FlushType) | Deflate one batch of data.
 | EndDeflate()()()() | End a deflation session.
 | EndInflate()()()() | Ends an inflation session.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | Inflate(FlushType) | Inflate the data in the InputBuffer, placing the result in the OutputBuffer.
 | InitializeDeflate()()()() | Initialize the ZlibCodec for deflation operation.
 | InitializeDeflate(CompressionLevel) | Initialize the ZlibCodec for deflation operation, using the specified CompressionLevel.
 | InitializeDeflate(CompressionLevel, Boolean) | Initialize the ZlibCodec for deflation operation, using the specified CompressionLevel, and the explicit flag governing whether to emit an RFC1950 header byte pair.
 | InitializeDeflate(CompressionLevel, Int32) | Initialize the ZlibCodec for deflation operation, using the specified CompressionLevel, and the specified number of window bits.
 | InitializeDeflate(CompressionLevel, Int32, Boolean) | Initialize the ZlibCodec for deflation operation, using the specified CompressionLevel, the specified number of window bits, and the explicit flag governing whether to emit an RFC1950 header byte pair.
 | InitializeInflate()()()() | Initialize the inflation state.
 | InitializeInflate(Boolean) | Initialize the inflation state with an explicit flag to govern the handling of RFC1950 header bytes.
 | InitializeInflate(Int32) | Initialize the ZlibCodec for inflation, with the specified number of window bits.
 | InitializeInflate(Int32, Boolean) | Initialize the inflation state with an explicit flag to govern the handling of RFC1950 header bytes.
 | InputBuffer | The buffer from which data is taken.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | used for diagnostics, when something goes wrong!
 | NextIn | An index into the InputBuffer array, indicating where to start reading.
 | NextOut | An index into the OutputBuffer array, indicating where to start writing.
 | OutputBuffer | Buffer to store output data.
 | ResetDeflate()()()() | Reset a codec for another deflation session.
 | SetDeflateParams(CompressionLevel, CompressionStrategy) | Set the CompressionStrategy and CompressionLevel for a deflation session.
 | SetDictionary(array<Byte>[]()[][]) | Set the dictionary to be used for either Inflation or Deflation.
 | Strategy | The compression strategy to use.
 | SyncInflate()()()() | I don't know what this does!
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | TotalBytesIn | Total number of bytes read so far, through all calls to Inflate()/Deflate().
 | TotalBytesOut | Total number of bytes written to the output so far, through all calls to Inflate()/Deflate().
 | WindowBits | The number of Window Bits to use.
Remarks
This class compresses and decompresses data according to the Deflate algorithm and optionally, the ZLIB format, as documented in RFC 1950 - ZLIB and RFC 1951 - DEFLATE.
Inheritance Hierarchy
Object
ZlibCodec


ZlibCodec Constructor

ZlibCodec Constructor
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibCodec ► ZlibCodec()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | ZlibCodec()()()() | Create a ZlibCodec.
 | ZlibCodec(CompressionMode) | Create a ZlibCodec that either compresses or decompresses.


ZlibCodec Constructor

ZlibCodec Constructor
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibCodec ► ZlibCodec()()()()
Keyoti RapidSpell WPF
Create a ZlibCodec.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ZlibCodec()
public ZlibCodec()
Public Sub New
Public Sub New
public:
ZlibCodec()
public:
ZlibCodec()
new : unit -> ZlibCodec
new : unit -> ZlibCodec
Remarks
If you use this default constructor, you will later have to explicitly call InitializeInflate() or InitializeDeflate() before using the ZlibCodec to compress or decompress.


ZlibCodec Constructor (mode)

ZlibCodec Constructor (mode)
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibCodec ► ZlibCodec(CompressionMode)
Keyoti RapidSpell WPF
Create a ZlibCodec that either compresses or decompresses.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ZlibCodec(
    CompressionMode mode
)
public ZlibCodec(
    CompressionMode mode
)
Public Sub New (
    mode As CompressionMode
)
Public Sub New (
    mode As CompressionMode
)
public:
ZlibCodec(
    CompressionMode mode
)
public:
ZlibCodec(
    CompressionMode mode
)
new :
        mode : CompressionMode -> ZlibCodec
new :
        mode : CompressionMode -> ZlibCodec
Parameters
mode (CompressionMode)
Indicates whether the codec should compress (deflate) or decompress (inflate).


Adler32 Property

Adler32 Property
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibCodec ► Adler32
Keyoti RapidSpell WPF
The Adler32 checksum on the data transferred through the codec so far. You probably don't need to look at this.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int Adler32 { get; }
public int Adler32 { get; }
Public ReadOnly Property Adler32 As Integer
    Get
Public ReadOnly Property Adler32 As Integer
    Get
public:
property int Adler32 {
    int get ();
}
public:
property int Adler32 {
    int get ();
}
member Adler32 : int with get

member Adler32 : int with get
Property Value
Int32


AvailableBytesIn Field

AvailableBytesIn Field
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibCodec ► AvailableBytesIn
Keyoti RapidSpell WPF
The number of bytes available in the InputBuffer, starting at NextIn.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int AvailableBytesIn
public int AvailableBytesIn
Public AvailableBytesIn As Integer
Public AvailableBytesIn As Integer
public:
int AvailableBytesIn
public:
int AvailableBytesIn
val mutable AvailableBytesIn: int
val mutable AvailableBytesIn: int
Field Value
Int32
Remarks
Generally you should set this to InputBuffer.Length before the first Inflate() or Deflate() call. The class will update this number as calls to Inflate/Deflate are made.


AvailableBytesOut Field

AvailableBytesOut Field
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibCodec ► AvailableBytesOut
Keyoti RapidSpell WPF
The number of bytes available in the OutputBuffer, starting at NextOut.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int AvailableBytesOut
public int AvailableBytesOut
Public AvailableBytesOut As Integer
Public AvailableBytesOut As Integer
public:
int AvailableBytesOut
public:
int AvailableBytesOut
val mutable AvailableBytesOut: int
val mutable AvailableBytesOut: int
Field Value
Int32
Remarks
Generally you should set this to OutputBuffer.Length before the first Inflate() or Deflate() call. The class will update this number as calls to Inflate/Deflate are made.


CompressLevel Field

CompressLevel Field
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibCodec ► CompressLevel
Keyoti RapidSpell WPF
The compression level to use in this codec. Useful only in compression mode.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public CompressionLevel CompressLevel
public CompressionLevel CompressLevel
Public CompressLevel As CompressionLevel
Public CompressLevel As CompressionLevel
public:
CompressionLevel CompressLevel
public:
CompressionLevel CompressLevel
val mutable CompressLevel: CompressionLevel
val mutable CompressLevel: CompressionLevel
Field Value
CompressionLevel


Deflate Method (flush)

Deflate Method (flush)
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibCodec ► Deflate(FlushType)
Keyoti RapidSpell WPF
Deflate one batch of data.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int Deflate(
    FlushType flush
)
public int Deflate(
    FlushType flush
)
Public Function Deflate (
    flush As FlushType
) As Integer
Public Function Deflate (
    flush As FlushType
) As Integer
public:
int Deflate(
    FlushType flush
)
public:
int Deflate(
    FlushType flush
)
member Deflate :
        flush : FlushType -> int

member Deflate :
        flush : FlushType -> int
Parameters
flush (FlushType)
whether to flush all data as you deflate. Generally you will want to use Z_NO_FLUSH here, in a series of calls to Deflate(), and then call EndDeflate() to flush everything.
Return Value
Int32
Z_OK if all goes well.
Remarks
You must have set InputBuffer and OutputBuffer before calling this method.
Examples
Copy image Copy
private void DeflateBuffer(CompressionLevel level)
{
    int bufferSize = 1024;
    byte[] buffer = new byte[bufferSize];
    ZlibCodec compressor = new ZlibCodec();

    Console.WriteLine("\n============================================");
    Console.WriteLine("Size of Buffer to Deflate: {0} bytes.", UncompressedBytes.Length);
    MemoryStream ms = new MemoryStream();

    int rc = compressor.InitializeDeflate(level);

    compressor.InputBuffer = UncompressedBytes;
    compressor.NextIn = 0;
    compressor.AvailableBytesIn = UncompressedBytes.Length;

    compressor.OutputBuffer = buffer;

    // pass 1: deflate
    do
    {
        compressor.NextOut = 0;
        compressor.AvailableBytesOut = buffer.Length;
        rc = compressor.Deflate(FlushType.None);

        if (rc != ZlibConstants.Z_OK && rc != ZlibConstants.Z_STREAM_END)
            throw new Exception("deflating: " + compressor.Message);

        ms.Write(compressor.OutputBuffer, 0, buffer.Length - compressor.AvailableBytesOut);
    }
    while (compressor.AvailableBytesIn > 0 || compressor.AvailableBytesOut == 0);

    // pass 2: finish and flush
    do
    {
        compressor.NextOut = 0;
        compressor.AvailableBytesOut = buffer.Length;
        rc = compressor.Deflate(FlushType.Finish);

        if (rc != ZlibConstants.Z_STREAM_END && rc != ZlibConstants.Z_OK)
            throw new Exception("deflating: " + compressor.Message);

        if (buffer.Length - compressor.AvailableBytesOut > 0)
            ms.Write(buffer, 0, buffer.Length - compressor.AvailableBytesOut);
    }
    while (compressor.AvailableBytesIn > 0 || compressor.AvailableBytesOut == 0);

    compressor.EndDeflate();

    ms.Seek(0, SeekOrigin.Begin);
    CompressedBytes = new byte[compressor.TotalBytesOut];
    ms.Read(CompressedBytes, 0, CompressedBytes.Length);
}


EndDeflate Method

EndDeflate Method
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibCodec ► EndDeflate()()()()
Keyoti RapidSpell WPF
End a deflation session.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int EndDeflate()
public int EndDeflate()
Public Function EndDeflate As Integer
Public Function EndDeflate As Integer
public:
int EndDeflate()
public:
int EndDeflate()
member EndDeflate : unit -> int

member EndDeflate : unit -> int
Return Value
Int32
Z_OK if all goes well.
Remarks
Call this after making a series of one or more calls to Deflate(). All buffers are flushed.


EndInflate Method

EndInflate Method
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibCodec ► EndInflate()()()()
Keyoti RapidSpell WPF
Ends an inflation session.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int EndInflate()
public int EndInflate()
Public Function EndInflate As Integer
Public Function EndInflate As Integer
public:
int EndInflate()
public:
int EndInflate()
member EndInflate : unit -> int

member EndInflate : unit -> int
Return Value
Int32
Z_OK if everything goes well.
Remarks
Call this after successively calling Inflate(). This will cause all buffers to be flushed. After calling this you cannot call Inflate() without a intervening call to one of the InitializeInflate() overloads.


Inflate Method (flush)

Inflate Method (flush)
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibCodec ► Inflate(FlushType)
Keyoti RapidSpell WPF
Inflate the data in the InputBuffer, placing the result in the OutputBuffer.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int Inflate(
    FlushType flush
)
public int Inflate(
    FlushType flush
)
Public Function Inflate (
    flush As FlushType
) As Integer
Public Function Inflate (
    flush As FlushType
) As Integer
public:
int Inflate(
    FlushType flush
)
public:
int Inflate(
    FlushType flush
)
member Inflate :
        flush : FlushType -> int

member Inflate :
        flush : FlushType -> int
Parameters
flush (FlushType)
The flush to use when inflating.
Return Value
Int32
Z_OK if everything goes well.
Remarks
You must have set InputBuffer and OutputBuffer, NextIn and NextOut, and AvailableBytesIn and AvailableBytesOut before calling this method.
Examples
Copy image Copy
private void InflateBuffer()
{
    int bufferSize = 1024;
    byte[] buffer = new byte[bufferSize];
    ZlibCodec decompressor = new ZlibCodec();

    Console.WriteLine("\n============================================");
    Console.WriteLine("Size of Buffer to Inflate: {0} bytes.", CompressedBytes.Length);
    MemoryStream ms = new MemoryStream(DecompressedBytes);

    int rc = decompressor.InitializeInflate();

    decompressor.InputBuffer = CompressedBytes;
    decompressor.NextIn = 0;
    decompressor.AvailableBytesIn = CompressedBytes.Length;

    decompressor.OutputBuffer = buffer;

    // pass 1: inflate
    do
    {
        decompressor.NextOut = 0;
        decompressor.AvailableBytesOut = buffer.Length;
        rc = decompressor.Inflate(FlushType.None);

        if (rc != ZlibConstants.Z_OK && rc != ZlibConstants.Z_STREAM_END)
            throw new Exception("inflating: " + decompressor.Message);

        ms.Write(decompressor.OutputBuffer, 0, buffer.Length - decompressor.AvailableBytesOut);
    }
    while (decompressor.AvailableBytesIn > 0 || decompressor.AvailableBytesOut == 0);

    // pass 2: finish and flush
    do
    {
        decompressor.NextOut = 0;
        decompressor.AvailableBytesOut = buffer.Length;
        rc = decompressor.Inflate(FlushType.Finish);

        if (rc != ZlibConstants.Z_STREAM_END && rc != ZlibConstants.Z_OK)
            throw new Exception("inflating: " + decompressor.Message);

        if (buffer.Length - decompressor.AvailableBytesOut > 0)
            ms.Write(buffer, 0, buffer.Length - decompressor.AvailableBytesOut);
    }
    while (decompressor.AvailableBytesIn > 0 || decompressor.AvailableBytesOut == 0);

    decompressor.EndInflate();
}


InitializeDeflate Method

InitializeDeflate Method
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibCodec ► InitializeDeflate()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | InitializeDeflate()()()() | Initialize the ZlibCodec for deflation operation.
 | InitializeDeflate(CompressionLevel) | Initialize the ZlibCodec for deflation operation, using the specified CompressionLevel.
 | InitializeDeflate(CompressionLevel, Boolean) | Initialize the ZlibCodec for deflation operation, using the specified CompressionLevel, and the explicit flag governing whether to emit an RFC1950 header byte pair.
 | InitializeDeflate(CompressionLevel, Int32) | Initialize the ZlibCodec for deflation operation, using the specified CompressionLevel, and the specified number of window bits.
 | InitializeDeflate(CompressionLevel, Int32, Boolean) | Initialize the ZlibCodec for deflation operation, using the specified CompressionLevel, the specified number of window bits, and the explicit flag governing whether to emit an RFC1950 header byte pair.


InitializeDeflate Method

InitializeDeflate Method
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibCodec ► InitializeDeflate()()()()
Keyoti RapidSpell WPF
Initialize the ZlibCodec for deflation operation.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int InitializeDeflate()
public int InitializeDeflate()
Public Function InitializeDeflate As Integer
Public Function InitializeDeflate As Integer
public:
int InitializeDeflate()
public:
int InitializeDeflate()
member InitializeDeflate : unit -> int

member InitializeDeflate : unit -> int
Return Value
Int32
Z_OK if all goes well. You generally don't need to check the return code.
Remarks
The codec will use the MAX window bits and the default level of compression.
Examples
Copy image Copy
int bufferSize = 40000;
byte[] CompressedBytes = new byte[bufferSize];
byte[] DecompressedBytes = new byte[bufferSize];

ZlibCodec compressor = new ZlibCodec();

compressor.InitializeDeflate(CompressionLevel.Default);

compressor.InputBuffer = System.Text.ASCIIEncoding.ASCII.GetBytes(TextToCompress);
compressor.NextIn = 0;
compressor.AvailableBytesIn = compressor.InputBuffer.Length;

compressor.OutputBuffer = CompressedBytes;
compressor.NextOut = 0;
compressor.AvailableBytesOut = CompressedBytes.Length;

while (compressor.TotalBytesIn != TextToCompress.Length && compressor.TotalBytesOut < bufferSize)
{
  compressor.Deflate(FlushType.None);
}

while (true)
{
  int rc= compressor.Deflate(FlushType.Finish);
  if (rc == ZlibConstants.Z_STREAM_END) break;
}

compressor.EndDeflate();


InitializeDeflate Method (level)

InitializeDeflate Method (level)
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibCodec ► InitializeDeflate(CompressionLevel)
Keyoti RapidSpell WPF
Initialize the ZlibCodec for deflation operation, using the specified CompressionLevel.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int InitializeDeflate(
    CompressionLevel level
)
public int InitializeDeflate(
    CompressionLevel level
)
Public Function InitializeDeflate (
    level As CompressionLevel
) As Integer
Public Function InitializeDeflate (
    level As CompressionLevel
) As Integer
public:
int InitializeDeflate(
    CompressionLevel level
)
public:
int InitializeDeflate(
    CompressionLevel level
)
member InitializeDeflate :
        level : CompressionLevel -> int

member InitializeDeflate :
        level : CompressionLevel -> int
Parameters
level (CompressionLevel)
The compression level for the codec.
Return Value
Int32
Z_OK if all goes well.
Remarks
The codec will use the maximum window bits (15) and the specified CompressionLevel. It will emit a ZLIB stream as it compresses.


InitializeDeflate Method (level, wantRfc1950Header)

InitializeDeflate Method (level, wantRfc1950Header)
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibCodec ► InitializeDeflate(CompressionLevel, Boolean)
Keyoti RapidSpell WPF
Initialize the ZlibCodec for deflation operation, using the specified CompressionLevel, and the explicit flag governing whether to emit an RFC1950 header byte pair.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int InitializeDeflate(
    CompressionLevel level,
    bool wantRfc1950Header
)
public int InitializeDeflate(
    CompressionLevel level,
    bool wantRfc1950Header
)
Public Function InitializeDeflate (
    level As CompressionLevel,
    wantRfc1950Header As Boolean
) As Integer
Public Function InitializeDeflate (
    level As CompressionLevel,
    wantRfc1950Header As Boolean
) As Integer
public:
int InitializeDeflate(
    CompressionLevel level,
    bool wantRfc1950Header
)
public:
int InitializeDeflate(
    CompressionLevel level,
    bool wantRfc1950Header
)
member InitializeDeflate :
        level : CompressionLevel *
        wantRfc1950Header : bool -> int

member InitializeDeflate :
        level : CompressionLevel *
        wantRfc1950Header : bool -> int
Parameters
level (CompressionLevel)
The compression level for the codec.
wantRfc1950Header (Boolean)
whether to emit an initial RFC1950 byte pair in the compressed stream.
Return Value
Int32
Z_OK if all goes well.
Remarks
The codec will use the maximum window bits (15) and the specified CompressionLevel. If you want to generate a zlib stream, you should specify true for wantRfc1950Header. In this case, the library will emit a ZLIB header, as defined in RFC 1950, in the compressed stream.


InitializeDeflate Method (level, bits)

InitializeDeflate Method (level, bits)
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibCodec ► InitializeDeflate(CompressionLevel, Int32)
Keyoti RapidSpell WPF
Initialize the ZlibCodec for deflation operation, using the specified CompressionLevel, and the specified number of window bits.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int InitializeDeflate(
    CompressionLevel level,
    int bits
)
public int InitializeDeflate(
    CompressionLevel level,
    int bits
)
Public Function InitializeDeflate (
    level As CompressionLevel,
    bits As Integer
) As Integer
Public Function InitializeDeflate (
    level As CompressionLevel,
    bits As Integer
) As Integer
public:
int InitializeDeflate(
    CompressionLevel level,
    int bits
)
public:
int InitializeDeflate(
    CompressionLevel level,
    int bits
)
member InitializeDeflate :
        level : CompressionLevel *
        bits : int -> int

member InitializeDeflate :
        level : CompressionLevel *
        bits : int -> int
Parameters
level (CompressionLevel)
The compression level for the codec.
bits (Int32)
the number of window bits to use. If you don't know what this means, don't use this method.
Return Value
Int32
Z_OK if all goes well.
Remarks
The codec will use the specified number of window bits and the specified CompressionLevel.


InitializeDeflate Method (level, bits, wantRfc1950Header)

InitializeDeflate Method (level, bits, wantRfc1950Header)
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibCodec ► InitializeDeflate(CompressionLevel, Int32, Boolean)
Keyoti RapidSpell WPF
Initialize the ZlibCodec for deflation operation, using the specified CompressionLevel, the specified number of window bits, and the explicit flag governing whether to emit an RFC1950 header byte pair.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int InitializeDeflate(
    CompressionLevel level,
    int bits,
    bool wantRfc1950Header
)
public int InitializeDeflate(
    CompressionLevel level,
    int bits,
    bool wantRfc1950Header
)
Public Function InitializeDeflate (
    level As CompressionLevel,
    bits As Integer,
    wantRfc1950Header As Boolean
) As Integer
Public Function InitializeDeflate (
    level As CompressionLevel,
    bits As Integer,
    wantRfc1950Header As Boolean
) As Integer
public:
int InitializeDeflate(
    CompressionLevel level,
    int bits,
    bool wantRfc1950Header
)
public:
int InitializeDeflate(
    CompressionLevel level,
    int bits,
    bool wantRfc1950Header
)
member InitializeDeflate :
        level : CompressionLevel *
        bits : int *
        wantRfc1950Header : bool -> int

member InitializeDeflate :
        level : CompressionLevel *
        bits : int *
        wantRfc1950Header : bool -> int
Parameters
level (CompressionLevel)
The compression level for the codec.
bits (Int32)
the number of window bits to use. If you don't know what this means, don't use this method.
wantRfc1950Header (Boolean)
whether to emit an initial RFC1950 byte pair in the compressed stream.
Return Value
Int32
Z_OK if all goes well.


InitializeInflate Method

InitializeInflate Method
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibCodec ► InitializeInflate()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | InitializeInflate()()()() | Initialize the inflation state.
 | InitializeInflate(Boolean) | Initialize the inflation state with an explicit flag to govern the handling of RFC1950 header bytes.
 | InitializeInflate(Int32) | Initialize the ZlibCodec for inflation, with the specified number of window bits.
 | InitializeInflate(Int32, Boolean) | Initialize the inflation state with an explicit flag to govern the handling of RFC1950 header bytes.


InitializeInflate Method

InitializeInflate Method
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibCodec ► InitializeInflate()()()()
Keyoti RapidSpell WPF
Initialize the inflation state.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int InitializeInflate()
public int InitializeInflate()
Public Function InitializeInflate As Integer
Public Function InitializeInflate As Integer
public:
int InitializeInflate()
public:
int InitializeInflate()
member InitializeInflate : unit -> int

member InitializeInflate : unit -> int
Return Value
Int32
Z_OK if everything goes well.
Remarks
It is not necessary to call this before using the ZlibCodec to inflate data; It is implicitly called when you call the constructor.


InitializeInflate Method (expectRfc1950Header)

InitializeInflate Method (expectRfc1950Header)
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibCodec ► InitializeInflate(Boolean)
Keyoti RapidSpell WPF
Initialize the inflation state with an explicit flag to govern the handling of RFC1950 header bytes.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int InitializeInflate(
    bool expectRfc1950Header
)
public int InitializeInflate(
    bool expectRfc1950Header
)
Public Function InitializeInflate (
    expectRfc1950Header As Boolean
) As Integer
Public Function InitializeInflate (
    expectRfc1950Header As Boolean
) As Integer
public:
int InitializeInflate(
    bool expectRfc1950Header
)
public:
int InitializeInflate(
    bool expectRfc1950Header
)
member InitializeInflate :
        expectRfc1950Header : bool -> int

member InitializeInflate :
        expectRfc1950Header : bool -> int
Parameters
expectRfc1950Header (Boolean)
whether to expect an RFC1950 header byte pair when reading the stream of data to be inflated.
Return Value
Int32
Z_OK if everything goes well.
Remarks
By default, the ZLIB header defined in RFC 1950 is expected. If you want to read a zlib stream you should specify true for expectRfc1950Header. If you have a deflate stream, you will want to specify false. It is only necessary to invoke this initializer explicitly if you want to specify false.


InitializeInflate Method (windowBits)

InitializeInflate Method (windowBits)
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibCodec ► InitializeInflate(Int32)
Keyoti RapidSpell WPF
Initialize the ZlibCodec for inflation, with the specified number of window bits.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int InitializeInflate(
    int windowBits
)
public int InitializeInflate(
    int windowBits
)
Public Function InitializeInflate (
    windowBits As Integer
) As Integer
Public Function InitializeInflate (
    windowBits As Integer
) As Integer
public:
int InitializeInflate(
    int windowBits
)
public:
int InitializeInflate(
    int windowBits
)
member InitializeInflate :
        windowBits : int -> int

member InitializeInflate :
        windowBits : int -> int
Parameters
windowBits (Int32)
The number of window bits to use. If you need to ask what that is, then you shouldn't be calling this initializer.
Return Value
Int32
Z_OK if all goes well.


InitializeInflate Method (windowBits, expectRfc1950Header)

InitializeInflate Method (windowBits, expectRfc1950Header)
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibCodec ► InitializeInflate(Int32, Boolean)
Keyoti RapidSpell WPF
Initialize the inflation state with an explicit flag to govern the handling of RFC1950 header bytes.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int InitializeInflate(
    int windowBits,
    bool expectRfc1950Header
)
public int InitializeInflate(
    int windowBits,
    bool expectRfc1950Header
)
Public Function InitializeInflate (
    windowBits As Integer,
    expectRfc1950Header As Boolean
) As Integer
Public Function InitializeInflate (
    windowBits As Integer,
    expectRfc1950Header As Boolean
) As Integer
public:
int InitializeInflate(
    int windowBits,
    bool expectRfc1950Header
)
public:
int InitializeInflate(
    int windowBits,
    bool expectRfc1950Header
)
member InitializeInflate :
        windowBits : int *
        expectRfc1950Header : bool -> int

member InitializeInflate :
        windowBits : int *
        expectRfc1950Header : bool -> int
Parameters
windowBits (Int32)
The number of window bits to use. If you need to ask what that is, then you shouldn't be calling this initializer.
expectRfc1950Header (Boolean)
whether to expect an RFC1950 header byte pair when reading the stream of data to be inflated.
Return Value
Int32
Z_OK if everything goes well.
Remarks
If you want to read a zlib stream you should specify true for expectRfc1950Header. In this case, the library will expect to find a ZLIB header, as defined in RFC 1950, in the compressed stream. If you will be reading a DEFLATE or GZIP stream, which does not have such a header, you will want to specify false.


InputBuffer Field

InputBuffer Field
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibCodec ► InputBuffer
Keyoti RapidSpell WPF
The buffer from which data is taken.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public byte[] InputBuffer
public byte[] InputBuffer
Public InputBuffer As Byte()
Public InputBuffer As Byte()
public:
array<unsigned char>^ InputBuffer
public:
array<unsigned char>^ InputBuffer
val mutable InputBuffer: byte[]
val mutable InputBuffer: byte[]
Field Value
array< Byte >[]()[][]


Message Field

Message Field
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibCodec ► Message
Keyoti RapidSpell WPF
used for diagnostics, when something goes wrong!
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string Message
public string Message
Public Message As String
Public Message As String
public:
String^ Message
public:
String^ Message
val mutable Message: string
val mutable Message: string
Field Value
String


NextIn Field

NextIn Field
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibCodec ► NextIn
Keyoti RapidSpell WPF
An index into the InputBuffer array, indicating where to start reading.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int NextIn
public int NextIn
Public NextIn As Integer
Public NextIn As Integer
public:
int NextIn
public:
int NextIn
val mutable NextIn: int
val mutable NextIn: int
Field Value
Int32


NextOut Field

NextOut Field
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibCodec ► NextOut
Keyoti RapidSpell WPF
An index into the OutputBuffer array, indicating where to start writing.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int NextOut
public int NextOut
Public NextOut As Integer
Public NextOut As Integer
public:
int NextOut
public:
int NextOut
val mutable NextOut: int
val mutable NextOut: int
Field Value
Int32


OutputBuffer Field

OutputBuffer Field
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibCodec ► OutputBuffer
Keyoti RapidSpell WPF
Buffer to store output data.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public byte[] OutputBuffer
public byte[] OutputBuffer
Public OutputBuffer As Byte()
Public OutputBuffer As Byte()
public:
array<unsigned char>^ OutputBuffer
public:
array<unsigned char>^ OutputBuffer
val mutable OutputBuffer: byte[]
val mutable OutputBuffer: byte[]
Field Value
array< Byte >[]()[][]


ResetDeflate Method

ResetDeflate Method
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibCodec ► ResetDeflate()()()()
Keyoti RapidSpell WPF
Reset a codec for another deflation session.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void ResetDeflate()
public void ResetDeflate()
Public Sub ResetDeflate
Public Sub ResetDeflate
public:
void ResetDeflate()
public:
void ResetDeflate()
member ResetDeflate : unit -> unit

member ResetDeflate : unit -> unit
Return Value

Z_OK if all goes well.
Remarks
Call this to reset the deflation state. For example if a thread is deflating non-consecutive blocks, you can call Reset() after the Deflate(Sync) of the first block and before the next Deflate(None) of the second block.


SetDeflateParams Method (level, strategy)

SetDeflateParams Method (level, strategy)
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibCodec ► SetDeflateParams(CompressionLevel, CompressionStrategy)
Keyoti RapidSpell WPF
Set the CompressionStrategy and CompressionLevel for a deflation session.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int SetDeflateParams(
    CompressionLevel level,
    CompressionStrategy strategy
)
public int SetDeflateParams(
    CompressionLevel level,
    CompressionStrategy strategy
)
Public Function SetDeflateParams (
    level As CompressionLevel,
    strategy As CompressionStrategy
) As Integer
Public Function SetDeflateParams (
    level As CompressionLevel,
    strategy As CompressionStrategy
) As Integer
public:
int SetDeflateParams(
    CompressionLevel level,
    CompressionStrategy strategy
)
public:
int SetDeflateParams(
    CompressionLevel level,
    CompressionStrategy strategy
)
member SetDeflateParams :
        level : CompressionLevel *
        strategy : CompressionStrategy -> int

member SetDeflateParams :
        level : CompressionLevel *
        strategy : CompressionStrategy -> int
Parameters
level (CompressionLevel)
the level of compression to use.
strategy (CompressionStrategy)
the strategy to use for compression.
Return Value
Int32
Z_OK if all goes well.


SetDictionary Method (dictionary)

SetDictionary Method (dictionary)
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibCodec ► SetDictionary(array<Byte>[]()[][])
Keyoti RapidSpell WPF
Set the dictionary to be used for either Inflation or Deflation.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int SetDictionary(
    byte[] dictionary
)
public int SetDictionary(
    byte[] dictionary
)
Public Function SetDictionary (
    dictionary As Byte()
) As Integer
Public Function SetDictionary (
    dictionary As Byte()
) As Integer
public:
int SetDictionary(
    array<unsigned char>^ dictionary
)
public:
int SetDictionary(
    array<unsigned char>^ dictionary
)
member SetDictionary :
        dictionary : byte[] -> int

member SetDictionary :
        dictionary : byte[] -> int
Parameters
dictionary (array< Byte >[]()[][])
The dictionary bytes to use.
Return Value
Int32
Z_OK if all goes well.


Strategy Field

Strategy Field
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibCodec ► Strategy
Keyoti RapidSpell WPF
The compression strategy to use.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public CompressionStrategy Strategy
public CompressionStrategy Strategy
Public Strategy As CompressionStrategy
Public Strategy As CompressionStrategy
public:
CompressionStrategy Strategy
public:
CompressionStrategy Strategy
val mutable Strategy: CompressionStrategy
val mutable Strategy: CompressionStrategy
Field Value
CompressionStrategy
Remarks
This is only effective in compression. The theory offered by ZLIB is that different strategies could potentially produce significant differences in compression behavior for different data sets. Unfortunately I don't have any good recommendations for how to set it differently. When I tested changing the strategy I got minimally different compression performance. It's best to leave this property alone if you don't have a good feel for it. Or, you may want to produce a test harness that runs through the different strategy options and evaluates them on different file types. If you do that, let me know your results.


SyncInflate Method

SyncInflate Method
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibCodec ► SyncInflate()()()()
Keyoti RapidSpell WPF
I don't know what this does!
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int SyncInflate()
public int SyncInflate()
Public Function SyncInflate As Integer
Public Function SyncInflate As Integer
public:
int SyncInflate()
public:
int SyncInflate()
member SyncInflate : unit -> int

member SyncInflate : unit -> int
Return Value
Int32
Z_OK if everything goes well.


TotalBytesIn Field

TotalBytesIn Field
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibCodec ► TotalBytesIn
Keyoti RapidSpell WPF
Total number of bytes read so far, through all calls to Inflate()/Deflate().
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public long TotalBytesIn
public long TotalBytesIn
Public TotalBytesIn As Long
Public TotalBytesIn As Long
public:
long long TotalBytesIn
public:
long long TotalBytesIn
val mutable TotalBytesIn: int64
val mutable TotalBytesIn: int64
Field Value
Int64


TotalBytesOut Field

TotalBytesOut Field
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibCodec ► TotalBytesOut
Keyoti RapidSpell WPF
Total number of bytes written to the output so far, through all calls to Inflate()/Deflate().
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public long TotalBytesOut
public long TotalBytesOut
Public TotalBytesOut As Long
Public TotalBytesOut As Long
public:
long long TotalBytesOut
public:
long long TotalBytesOut
val mutable TotalBytesOut: int64
val mutable TotalBytesOut: int64
Field Value
Int64


WindowBits Field

WindowBits Field
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibCodec ► WindowBits
Keyoti RapidSpell WPF
The number of Window Bits to use.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int WindowBits
public int WindowBits
Public WindowBits As Integer
Public WindowBits As Integer
public:
int WindowBits
public:
int WindowBits
val mutable WindowBits: int
val mutable WindowBits: int
Field Value
Int32
Remarks
This gauges the size of the sliding window, and hence the compression effectiveness as well as memory consumption. It's best to just leave this setting alone if you don't know what it is. The maximum value is 15 bits, which implies a 32k window.


ZlibConstants Class

ZlibConstants Class
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibConstants
Keyoti RapidSpell WPF
A bunch of constants used in the Zlib interface.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class ZlibConstants
public class ZlibConstants
Public Class ZlibConstants
Public Class ZlibConstants
public ref class ZlibConstants
public ref class ZlibConstants
type ZlibConstants =  class end
type ZlibConstants =  class end
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZlibConstants()()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | WindowBitsDefault | The default number of window bits for the Deflate algorithm.
 | WindowBitsMax | The maximum number of window bits for the Deflate algorithm.
 | WorkingBufferSizeDefault | The size of the working buffer used in the ZlibCodec class. Defaults to 8192 bytes.
 | WorkingBufferSizeMin | The minimum size of the working buffer used in the ZlibCodec class. Currently it is 128 bytes.
 | Z_BUF_ERROR | There was an error with the working buffer.
 | Z_DATA_ERROR | There was an error with the data - not enough data, bad data, etc.
 | Z_NEED_DICT | The operation ended in need of a dictionary.
 | Z_OK | indicates everything is A-OK
 | Z_STREAM_END | Indicates that the last operation reached the end of the stream.
 | Z_STREAM_ERROR | There was an error with the stream - not enough data, not open and readable, etc.
Inheritance Hierarchy
Object
ZlibConstants


ZlibConstants Constructor

ZlibConstants Constructor
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibConstants ► ZlibConstants()()()()
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ZlibConstants()
public ZlibConstants()
Public Sub New
Public Sub New
public:
ZlibConstants()
public:
ZlibConstants()
new : unit -> ZlibConstants
new : unit -> ZlibConstants


WindowBitsDefault Field

WindowBitsDefault Field
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibConstants ► WindowBitsDefault
Keyoti RapidSpell WPF
The default number of window bits for the Deflate algorithm.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public const int WindowBitsDefault
public const int WindowBitsDefault
Public Const WindowBitsDefault As Integer
Public Const WindowBitsDefault As Integer
public:
literal int WindowBitsDefault
public:
literal int WindowBitsDefault
static val mutable WindowBitsDefault: int
static val mutable WindowBitsDefault: int
Field Value
Int32


WindowBitsMax Field

WindowBitsMax Field
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibConstants ► WindowBitsMax
Keyoti RapidSpell WPF
The maximum number of window bits for the Deflate algorithm.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public const int WindowBitsMax
public const int WindowBitsMax
Public Const WindowBitsMax As Integer
Public Const WindowBitsMax As Integer
public:
literal int WindowBitsMax
public:
literal int WindowBitsMax
static val mutable WindowBitsMax: int
static val mutable WindowBitsMax: int
Field Value
Int32


WorkingBufferSizeDefault Field

WorkingBufferSizeDefault Field
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibConstants ► WorkingBufferSizeDefault
Keyoti RapidSpell WPF
The size of the working buffer used in the ZlibCodec class. Defaults to 8192 bytes.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public const int WorkingBufferSizeDefault
public const int WorkingBufferSizeDefault
Public Const WorkingBufferSizeDefault As Integer
Public Const WorkingBufferSizeDefault As Integer
public:
literal int WorkingBufferSizeDefault
public:
literal int WorkingBufferSizeDefault
static val mutable WorkingBufferSizeDefault: int
static val mutable WorkingBufferSizeDefault: int
Field Value
Int32


WorkingBufferSizeMin Field

WorkingBufferSizeMin Field
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibConstants ► WorkingBufferSizeMin
Keyoti RapidSpell WPF
The minimum size of the working buffer used in the ZlibCodec class. Currently it is 128 bytes.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public const int WorkingBufferSizeMin
public const int WorkingBufferSizeMin
Public Const WorkingBufferSizeMin As Integer
Public Const WorkingBufferSizeMin As Integer
public:
literal int WorkingBufferSizeMin
public:
literal int WorkingBufferSizeMin
static val mutable WorkingBufferSizeMin: int
static val mutable WorkingBufferSizeMin: int
Field Value
Int32


Z_BUF_ERROR Field

Z_BUF_ERROR Field
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibConstants ► Z_BUF_ERROR
Keyoti RapidSpell WPF
There was an error with the working buffer.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public const int Z_BUF_ERROR
public const int Z_BUF_ERROR
Public Const Z_BUF_ERROR As Integer
Public Const Z_BUF_ERROR As Integer
public:
literal int Z_BUF_ERROR
public:
literal int Z_BUF_ERROR
static val mutable Z_BUF_ERROR: int
static val mutable Z_BUF_ERROR: int
Field Value
Int32


Z_DATA_ERROR Field

Z_DATA_ERROR Field
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibConstants ► Z_DATA_ERROR
Keyoti RapidSpell WPF
There was an error with the data - not enough data, bad data, etc.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public const int Z_DATA_ERROR
public const int Z_DATA_ERROR
Public Const Z_DATA_ERROR As Integer
Public Const Z_DATA_ERROR As Integer
public:
literal int Z_DATA_ERROR
public:
literal int Z_DATA_ERROR
static val mutable Z_DATA_ERROR: int
static val mutable Z_DATA_ERROR: int
Field Value
Int32


Z_NEED_DICT Field

Z_NEED_DICT Field
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibConstants ► Z_NEED_DICT
Keyoti RapidSpell WPF
The operation ended in need of a dictionary.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public const int Z_NEED_DICT
public const int Z_NEED_DICT
Public Const Z_NEED_DICT As Integer
Public Const Z_NEED_DICT As Integer
public:
literal int Z_NEED_DICT
public:
literal int Z_NEED_DICT
static val mutable Z_NEED_DICT: int
static val mutable Z_NEED_DICT: int
Field Value
Int32


Z_OK Field

Z_OK Field
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibConstants ► Z_OK
Keyoti RapidSpell WPF
indicates everything is A-OK
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public const int Z_OK
public const int Z_OK
Public Const Z_OK As Integer
Public Const Z_OK As Integer
public:
literal int Z_OK
public:
literal int Z_OK
static val mutable Z_OK: int
static val mutable Z_OK: int
Field Value
Int32


Z_STREAM_END Field

Z_STREAM_END Field
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibConstants ► Z_STREAM_END
Keyoti RapidSpell WPF
Indicates that the last operation reached the end of the stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public const int Z_STREAM_END
public const int Z_STREAM_END
Public Const Z_STREAM_END As Integer
Public Const Z_STREAM_END As Integer
public:
literal int Z_STREAM_END
public:
literal int Z_STREAM_END
static val mutable Z_STREAM_END: int
static val mutable Z_STREAM_END: int
Field Value
Int32


Z_STREAM_ERROR Field

Z_STREAM_ERROR Field
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibConstants ► Z_STREAM_ERROR
Keyoti RapidSpell WPF
There was an error with the stream - not enough data, not open and readable, etc.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public const int Z_STREAM_ERROR
public const int Z_STREAM_ERROR
Public Const Z_STREAM_ERROR As Integer
Public Const Z_STREAM_ERROR As Integer
public:
literal int Z_STREAM_ERROR
public:
literal int Z_STREAM_ERROR
static val mutable Z_STREAM_ERROR: int
static val mutable Z_STREAM_ERROR: int
Field Value
Int32


ZlibException Class

ZlibException Class
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibException
Keyoti RapidSpell WPF
A general purpose exception class for exceptions in the Zlib library.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class ZlibException : Exception
public class ZlibException : Exception
Public Class ZlibException
    Inherits Exception
Public Class ZlibException
    Inherits Exception
public ref class ZlibException : public Exception
public ref class ZlibException : public Exception
type ZlibException =
    class
        inherit Exception
    end
type ZlibException =
    class
        inherit Exception
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZlibException()()()() | The ZlibException class captures exception information generated by the Zlib library.
 | ZlibException(String) | This ctor collects a message attached to the exception.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | ZlibException


ZlibException Constructor

ZlibException Constructor
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibException ► ZlibException()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | ZlibException()()()() | The ZlibException class captures exception information generated by the Zlib library.
 | ZlibException(String) | This ctor collects a message attached to the exception.


ZlibException Constructor

ZlibException Constructor
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibException ► ZlibException()()()()
Keyoti RapidSpell WPF
The ZlibException class captures exception information generated by the Zlib library.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ZlibException()
public ZlibException()
Public Sub New
Public Sub New
public:
ZlibException()
public:
ZlibException()
new : unit -> ZlibException
new : unit -> ZlibException


ZlibException Constructor (s)

ZlibException Constructor (s)
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibException ► ZlibException(String)
Keyoti RapidSpell WPF
This ctor collects a message attached to the exception.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ZlibException(
    string s
)
public ZlibException(
    string s
)
Public Sub New (
    s As String
)
Public Sub New (
    s As String
)
public:
ZlibException(
    String^ s
)
public:
ZlibException(
    String^ s
)
new :
        s : string -> ZlibException
new :
        s : string -> ZlibException
Parameters
s (String)


ZlibStream Class

ZlibStream Class
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibStream
Keyoti RapidSpell WPF
Represents a Zlib stream for compression or decompression.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class ZlibStream : Stream
public class ZlibStream : Stream
Public Class ZlibStream
    Inherits Stream
Public Class ZlibStream
    Inherits Stream
public ref class ZlibStream : public Stream
public ref class ZlibStream : public Stream
type ZlibStream =
    class
        inherit Stream
    end
type ZlibStream =
    class
        inherit Stream
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZlibStream(Stream, CompressionMode) | Create a ZlibStream using the specified CompressionMode.
 | ZlibStream(Stream, CompressionMode, CompressionLevel) | Create a ZlibStream using the specified CompressionMode and the specified CompressionLevel.
 | ZlibStream(Stream, CompressionMode, Boolean) | Create a ZlibStream using the specified CompressionMode, and explicitly specify whether the captive stream should be left open after Deflation or Inflation.
 | ZlibStream(Stream, CompressionMode, CompressionLevel, Boolean) | Create a ZlibStream using the specified CompressionMode and the specified CompressionLevel, and explicitly specify whether the stream should be left open after Deflation or Inflation.
 | BeginRead(array<Byte>[]()[][], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous read operation. (Inherited from Stream.)
 | BeginWrite(array<Byte>[]()[][], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous write operation. (Inherited from Stream.)
 | BufferSize | The size of the working buffer for the compression codec.
 | CanRead | Indicates whether the stream can be read. (Overrides Stream.CanRead.)
 | CanSeek | Indicates whether the stream supports Seek operations. (Overrides Stream.CanSeek.)
 | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
 | CanWrite | Indicates whether the stream can be written. (Overrides Stream.CanWrite.)
 | Close()()()() | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. (Inherited from Stream.)
 | CompressBuffer(array<Byte>[]()[][]) | Compress a byte array into a new byte array using ZLIB.
 | CompressString(String) | Compress a string into a byte array using ZLIB.
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateWaitHandle()()()() | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
 | Dispose(Boolean) | Dispose the stream.
 | Dispose()()()() | Releases all resources used by the Stream. (Inherited from Stream.)
 | EndRead(IAsyncResult) | Waits for the pending asynchronous read to complete. (Inherited from Stream.)
 | EndWrite(IAsyncResult) | Ends an asynchronous write operation. (Inherited from Stream.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | Flush()()()() | Flush the stream. (Overrides Stream.Flush()()()().)
 | FlushMode | This property sets the flush behavior on the stream. Sorry, though, not sure exactly how to describe all the various settings.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | Length | Reading this property always throws a NotImplementedException. (Overrides Stream.Length.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Position | The position of the stream pointer. (Overrides Stream.Position.)
 | Read(array<Byte>[]()[][], Int32, Int32) | Read data from the stream. (Overrides Stream.Read(array<Byte>[]()[][], Int32, Int32).)
 | ReadByte()()()() | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
 | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
 | Seek(Int64, SeekOrigin) | Calling this method always throws a NotImplementedException. (Overrides Stream.Seek(Int64, SeekOrigin).)
 | SetLength(Int64) | Calling this method always throws a NotImplementedException. (Overrides Stream.SetLength(Int64).)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | TotalIn | Returns the total number of bytes input so far.
 | TotalOut | Returns the total number of bytes output so far.
 | UncompressBuffer(array<Byte>[]()[][]) | Uncompress a ZLIB-compressed byte array into a byte array.
 | UncompressString(array<Byte>[]()[][]) | Uncompress a ZLIB-compressed byte array into a single string.
 | Write(array<Byte>[]()[][], Int32, Int32) | Write data to the stream. (Overrides Stream.Write(array<Byte>[]()[][], Int32, Int32).)
 | WriteByte(Byte) | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
 | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Remarks

The ZlibStream is a Decorator on a Stream. It adds ZLIB compression or decompression to any stream.

Using this stream, applications can compress or decompress data via stream Read() and Write() operations. Either compresssion or decompression can occur through either reading or writing. The compression format used is ZLIB, which is documented in IETF RFC 1950, "ZLIB Compressed Data Format Specification version 3.3". This implementation of ZLIB always uses DEFLATE as the compression method. (see IETF RFC 1951, "DEFLATE Compressed Data Format Specification version 1.3.")

The ZLIB format allows for varying compression methods, window sizes, and dictionaries. This implementation always uses the DEFLATE compression method, a preset dictionary, and 15 window bits by default.

This class is similar to DeflateStream, except that it adds the RFC1950 header and trailer bytes to a compressed stream when compressing, or expects the RFC1950 header and trailer bytes when decompressing. It is also similar to the GZipStream.

Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Stream
 |  |  | ZlibStream
See Also
DeflateStream
GZipStream


ZlibStream Constructor

ZlibStream Constructor
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibStream ► ZlibStream()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | ZlibStream(Stream, CompressionMode) | Create a ZlibStream using the specified CompressionMode.
 | ZlibStream(Stream, CompressionMode, CompressionLevel) | Create a ZlibStream using the specified CompressionMode and the specified CompressionLevel.
 | ZlibStream(Stream, CompressionMode, Boolean) | Create a ZlibStream using the specified CompressionMode, and explicitly specify whether the captive stream should be left open after Deflation or Inflation.
 | ZlibStream(Stream, CompressionMode, CompressionLevel, Boolean) | Create a ZlibStream using the specified CompressionMode and the specified CompressionLevel, and explicitly specify whether the stream should be left open after Deflation or Inflation.


ZlibStream Constructor (stream, mode)

ZlibStream Constructor (stream, mode)
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibStream ► ZlibStream(Stream, CompressionMode)
Keyoti RapidSpell WPF
Create a ZlibStream using the specified CompressionMode.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ZlibStream(
    Stream stream,
    CompressionMode mode
)
public ZlibStream(
    Stream stream,
    CompressionMode mode
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode
)
public:
ZlibStream(
    Stream^ stream,
    CompressionMode mode
)
public:
ZlibStream(
    Stream^ stream,
    CompressionMode mode
)
new :
        stream : Stream *
        mode : CompressionMode -> ZlibStream
new :
        stream : Stream *
        mode : CompressionMode -> ZlibStream
Parameters
stream (Stream)
The stream which will be read or written.
mode (CompressionMode)
Indicates whether the ZlibStream will compress or decompress.
Remarks

When mode is CompressionMode.Compress, the ZlibStream will use the default compression level. The "captive" stream will be closed when the ZlibStream is closed.

Examples
This example uses a ZlibStream to compress a file, and writes the compressed data to another file.
Copy image Copy
using (System.IO.Stream input = System.IO.File.OpenRead(fileToCompress))
{
    using (var raw = System.IO.File.Create(fileToCompress + ".zlib"))
    {
        using (Stream compressor = new ZlibStream(raw, CompressionMode.Compress))
        {
            byte[] buffer = new byte[WORKING_BUFFER_SIZE];
            int n;
            while ((n= input.Read(buffer, 0, buffer.Length)) != 0)
            {
                compressor.Write(buffer, 0, n);
            }
        }
    }
}
Visual Basic Copy image Copy
Using input As Stream = File.OpenRead(fileToCompress)
    Using raw As FileStream = File.Create(fileToCompress & ".zlib")
    Using compressor As Stream = New ZlibStream(raw, CompressionMode.Compress)
        Dim buffer As Byte() = New Byte(4096) {}
        Dim n As Integer = -1
        Do While (n <> 0)
            If (n > 0) Then
                compressor.Write(buffer, 0, n)
            End If
            n = input.Read(buffer, 0, buffer.Length)
        Loop
    End Using
    End Using
End Using


ZlibStream Constructor (stream, mode, level)

ZlibStream Constructor (stream, mode, level)
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibStream ► ZlibStream(Stream, CompressionMode, CompressionLevel)
Keyoti RapidSpell WPF
Create a ZlibStream using the specified CompressionMode and the specified CompressionLevel.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ZlibStream(
    Stream stream,
    CompressionMode mode,
    CompressionLevel level
)
public ZlibStream(
    Stream stream,
    CompressionMode mode,
    CompressionLevel level
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode,
    level As CompressionLevel
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode,
    level As CompressionLevel
)
public:
ZlibStream(
    Stream^ stream,
    CompressionMode mode,
    CompressionLevel level
)
public:
ZlibStream(
    Stream^ stream,
    CompressionMode mode,
    CompressionLevel level
)
new :
        stream : Stream *
        mode : CompressionMode *
        level : CompressionLevel -> ZlibStream
new :
        stream : Stream *
        mode : CompressionMode *
        level : CompressionLevel -> ZlibStream
Parameters
stream (Stream)
The stream to be read or written while deflating or inflating.
mode (CompressionMode)
Indicates whether the ZlibStream will compress or decompress.
level (CompressionLevel)
A tuning knob to trade speed for effectiveness.
Remarks

When mode is CompressionMode.Decompress, the level parameter is ignored. The "captive" stream will be closed when the ZlibStream is closed.

Examples
This example uses a ZlibStream to compress data from a file, and writes the compressed data to another file.
Copy image Copy
using (System.IO.Stream input = System.IO.File.OpenRead(fileToCompress))
{
    using (var raw = System.IO.File.Create(fileToCompress + ".zlib"))
    {
        using (Stream compressor = new ZlibStream(raw,
                                                  CompressionMode.Compress,
                                                  CompressionLevel.BestCompression))
        {
            byte[] buffer = new byte[WORKING_BUFFER_SIZE];
            int n;
            while ((n= input.Read(buffer, 0, buffer.Length)) != 0)
            {
                compressor.Write(buffer, 0, n);
            }
        }
    }
}
Visual Basic Copy image Copy
Using input As Stream = File.OpenRead(fileToCompress)
    Using raw As FileStream = File.Create(fileToCompress & ".zlib")
        Using compressor As Stream = New ZlibStream(raw, CompressionMode.Compress, CompressionLevel.BestCompression)
            Dim buffer As Byte() = New Byte(4096) {}
            Dim n As Integer = -1
            Do While (n <> 0)
                If (n > 0) Then
                    compressor.Write(buffer, 0, n)
                End If
                n = input.Read(buffer, 0, buffer.Length)
            Loop
        End Using
    End Using
End Using


ZlibStream Constructor (stream, mode, level, leaveOpen)

ZlibStream Constructor (stream, mode, level, leaveOpen)
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibStream ► ZlibStream(Stream, CompressionMode, CompressionLevel, Boolean)
Keyoti RapidSpell WPF
Create a ZlibStream using the specified CompressionMode and the specified CompressionLevel, and explicitly specify whether the stream should be left open after Deflation or Inflation.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ZlibStream(
    Stream stream,
    CompressionMode mode,
    CompressionLevel level,
    bool leaveOpen
)
public ZlibStream(
    Stream stream,
    CompressionMode mode,
    CompressionLevel level,
    bool leaveOpen
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode,
    level As CompressionLevel,
    leaveOpen As Boolean
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode,
    level As CompressionLevel,
    leaveOpen As Boolean
)
public:
ZlibStream(
    Stream^ stream,
    CompressionMode mode,
    CompressionLevel level,
    bool leaveOpen
)
public:
ZlibStream(
    Stream^ stream,
    CompressionMode mode,
    CompressionLevel level,
    bool leaveOpen
)
new :
        stream : Stream *
        mode : CompressionMode *
        level : CompressionLevel *
        leaveOpen : bool -> ZlibStream
new :
        stream : Stream *
        mode : CompressionMode *
        level : CompressionLevel *
        leaveOpen : bool -> ZlibStream
Parameters
stream (Stream)
The stream which will be read or written.
mode (CompressionMode)
Indicates whether the ZlibStream will compress or decompress.
level (CompressionLevel)
A tuning knob to trade speed for effectiveness. This parameter is effective only when mode is CompressionMode.Compress.
leaveOpen (Boolean)
true if the application would like the stream to remain open after inflation/deflation.
Remarks

This constructor allows the application to request that the captive stream remain open after the deflation or inflation occurs. By default, after Close() is called on the stream, the captive stream is also closed. In some cases this is not desired, for example if the stream is a MemoryStream that will be re-read after compression. Specify true for the leaveOpen parameter to leave the stream open.

When mode is CompressionMode.Decompress, the level parameter is ignored.

Examples
This example shows how to use a ZlibStream to compress the data from a file, and store the result into another file. The filestream remains open to allow additional data to be written to it.
Copy image Copy
using (var output = System.IO.File.Create(fileToCompress + ".zlib"))
{
    using (System.IO.Stream input = System.IO.File.OpenRead(fileToCompress))
    {
        using (Stream compressor = new ZlibStream(output, CompressionMode.Compress, CompressionLevel.BestCompression, true))
        {
            byte[] buffer = new byte[WORKING_BUFFER_SIZE];
            int n;
            while ((n= input.Read(buffer, 0, buffer.Length)) != 0)
            {
                compressor.Write(buffer, 0, n);
            }
        }
    }
    // can write additional data to the output stream here
}
Visual Basic Copy image Copy
Using output As FileStream = File.Create(fileToCompress & ".zlib")
    Using input As Stream = File.OpenRead(fileToCompress)
        Using compressor As Stream = New ZlibStream(output, CompressionMode.Compress, CompressionLevel.BestCompression, True)
            Dim buffer As Byte() = New Byte(4096) {}
            Dim n As Integer = -1
            Do While (n <> 0)
                If (n > 0) Then
                    compressor.Write(buffer, 0, n)
                End If
                n = input.Read(buffer, 0, buffer.Length)
            Loop
        End Using
    End Using
    ' can write additional data to the output stream here.
End Using


ZlibStream Constructor (stream, mode, leaveOpen)

ZlibStream Constructor (stream, mode, leaveOpen)
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibStream ► ZlibStream(Stream, CompressionMode, Boolean)
Keyoti RapidSpell WPF
Create a ZlibStream using the specified CompressionMode, and explicitly specify whether the captive stream should be left open after Deflation or Inflation.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ZlibStream(
    Stream stream,
    CompressionMode mode,
    bool leaveOpen
)
public ZlibStream(
    Stream stream,
    CompressionMode mode,
    bool leaveOpen
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode,
    leaveOpen As Boolean
)
Public Sub New (
    stream As Stream,
    mode As CompressionMode,
    leaveOpen As Boolean
)
public:
ZlibStream(
    Stream^ stream,
    CompressionMode mode,
    bool leaveOpen
)
public:
ZlibStream(
    Stream^ stream,
    CompressionMode mode,
    bool leaveOpen
)
new :
        stream : Stream *
        mode : CompressionMode *
        leaveOpen : bool -> ZlibStream
new :
        stream : Stream *
        mode : CompressionMode *
        leaveOpen : bool -> ZlibStream
Parameters
stream (Stream)
The stream which will be read or written. This is called the "captive" stream in other places in this documentation.
mode (CompressionMode)
Indicates whether the ZlibStream will compress or decompress.
leaveOpen (Boolean)
true if the application would like the stream to remain open after inflation/deflation.
Remarks

When mode is CompressionMode.Compress, the ZlibStream will use the default compression level.

This constructor allows the application to request that the captive stream remain open after the deflation or inflation occurs. By default, after Close() is called on the stream, the captive stream is also closed. In some cases this is not desired, for example if the stream is a MemoryStream that will be re-read after compression. Specify true for the leaveOpen parameter to leave the stream open.

See the other overloads of this constructor for example code.


BufferSize Property

BufferSize Property
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibStream ► BufferSize
Keyoti RapidSpell WPF
The size of the working buffer for the compression codec.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int BufferSize { get; set; }
public int BufferSize { get; set; }
Public Property BufferSize As Integer
    Get
    Set
Public Property BufferSize As Integer
    Get
    Set
public:
property int BufferSize {
    int get ();
    void set (int value);
}
public:
property int BufferSize {
    int get ();
    void set (int value);
}
member BufferSize : int with get, set

member BufferSize : int with get, set
Property Value
Int32
Remarks

The working buffer is used for all stream operations. The default size is 1024 bytes. The minimum size is 128 bytes. You may get better performance with a larger buffer. Then again, you might not. You would have to test it.

Set this before the first call to Read() or Write() on the stream. If you try to set it afterwards, it will throw.


CanRead Property

CanRead Property
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibStream ► CanRead
Keyoti RapidSpell WPF
Indicates whether the stream can be read.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override bool CanRead { get; }
public override bool CanRead { get; }
Public Overrides ReadOnly Property CanRead As Boolean
    Get
Public Overrides ReadOnly Property CanRead As Boolean
    Get
public:
virtual property bool CanRead {
    bool get () override;
}
public:
virtual property bool CanRead {
    bool get () override;
}
abstract CanRead : bool with get
override CanRead : bool with get
abstract CanRead : bool with get
override CanRead : bool with get
Property Value
Boolean
Remarks
The return value depends on whether the captive stream supports reading.


CanSeek Property

CanSeek Property
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibStream ► CanSeek
Keyoti RapidSpell WPF
Indicates whether the stream supports Seek operations.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override bool CanSeek { get; }
public override bool CanSeek { get; }
Public Overrides ReadOnly Property CanSeek As Boolean
    Get
Public Overrides ReadOnly Property CanSeek As Boolean
    Get
public:
virtual property bool CanSeek {
    bool get () override;
}
public:
virtual property bool CanSeek {
    bool get () override;
}
abstract CanSeek : bool with get
override CanSeek : bool with get
abstract CanSeek : bool with get
override CanSeek : bool with get
Property Value
Boolean
Remarks
Always returns false.


CanWrite Property

CanWrite Property
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibStream ► CanWrite
Keyoti RapidSpell WPF
Indicates whether the stream can be written.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override bool CanWrite { get; }
public override bool CanWrite { get; }
Public Overrides ReadOnly Property CanWrite As Boolean
    Get
Public Overrides ReadOnly Property CanWrite As Boolean
    Get
public:
virtual property bool CanWrite {
    bool get () override;
}
public:
virtual property bool CanWrite {
    bool get () override;
}
abstract CanWrite : bool with get
override CanWrite : bool with get
abstract CanWrite : bool with get
override CanWrite : bool with get
Property Value
Boolean
Remarks
The return value depends on whether the captive stream supports writing.


CompressBuffer Method (b)

CompressBuffer Method (b)
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibStream ► CompressBuffer(array<Byte>[]()[][])
Keyoti RapidSpell WPF
Compress a byte array into a new byte array using ZLIB.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static byte[] CompressBuffer(
    byte[] b
)
public static byte[] CompressBuffer(
    byte[] b
)
Public Shared Function CompressBuffer (
    b As Byte()
) As Byte()
Public Shared Function CompressBuffer (
    b As Byte()
) As Byte()
public:
static array<unsigned char>^ CompressBuffer(
    array<unsigned char>^ b
)
public:
static array<unsigned char>^ CompressBuffer(
    array<unsigned char>^ b
)
static member CompressBuffer :
        b : byte[] -> byte[]

static member CompressBuffer :
        b : byte[] -> byte[]
Parameters
b (array< Byte >[]()[][])
A buffer to compress.
Return Value
array< Byte >[]()[][]
The data in compressed form
Remarks
Uncompress it with UncompressBuffer(array<Byte>[]()[][]).
See Also
CompressString(String)
UncompressBuffer(array<Byte>[]()[][])


CompressString Method (s)

CompressString Method (s)
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibStream ► CompressString(String)
Keyoti RapidSpell WPF
Compress a string into a byte array using ZLIB.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static byte[] CompressString(
    string s
)
public static byte[] CompressString(
    string s
)
Public Shared Function CompressString (
    s As String
) As Byte()
Public Shared Function CompressString (
    s As String
) As Byte()
public:
static array<unsigned char>^ CompressString(
    String^ s
)
public:
static array<unsigned char>^ CompressString(
    String^ s
)
static member CompressString :
        s : string -> byte[]

static member CompressString :
        s : string -> byte[]
Parameters
s (String)
A string to compress. The string will first be encoded using UTF8, then compressed.
Return Value
array< Byte >[]()[][]
The string in compressed form
Remarks
Uncompress it with UncompressString(array<Byte>[]()[][]).
See Also
UncompressString(array<Byte>[]()[][])
CompressBuffer(array<Byte>[]()[][])
CompressString(String)


Dispose Method (disposing)

Dispose Method (disposing)
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibStream ► Dispose(Boolean)
Keyoti RapidSpell WPF
Dispose the stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected void Dispose(
    bool disposing
)
protected void Dispose(
    bool disposing
)
Protected Sub Dispose (
    disposing As Boolean
)
Protected Sub Dispose (
    disposing As Boolean
)
protected:
void Dispose(
    bool disposing
)
protected:
void Dispose(
    bool disposing
)
member Dispose :
        disposing : bool -> unit

member Dispose :
        disposing : bool -> unit
Parameters
disposing (Boolean)
Remarks
This may or may not result in a Close() call on the captive stream. See the constructors that have a leaveOpen parameter for more information.


Flush Method

Flush Method
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibStream ► Flush()()()()
Keyoti RapidSpell WPF
Flush the stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override void Flush()
public override void Flush()
Public Overrides Sub Flush
Public Overrides Sub Flush
public:
virtual void Flush() override
public:
virtual void Flush() override
abstract Flush : unit -> unit
override Flush : unit -> unit
abstract Flush : unit -> unit
override Flush : unit -> unit


FlushMode Property

FlushMode Property
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibStream ► FlushMode
Keyoti RapidSpell WPF
This property sets the flush behavior on the stream. Sorry, though, not sure exactly how to describe all the various settings.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual FlushType FlushMode { get; set; }
public virtual FlushType FlushMode { get; set; }
Public Overridable Property FlushMode As FlushType
    Get
    Set
Public Overridable Property FlushMode As FlushType
    Get
    Set
public:
virtual property FlushType FlushMode {
    FlushType get ();
    void set (FlushType value);
}
public:
virtual property FlushType FlushMode {
    FlushType get ();
    void set (FlushType value);
}
abstract FlushMode : FlushType with get, set
override FlushMode : FlushType with get, set
abstract FlushMode : FlushType with get, set
override FlushMode : FlushType with get, set
Property Value
FlushType


Length Property

Length Property
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibStream ► Length
Keyoti RapidSpell WPF
Reading this property always throws a NotImplementedException.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override long Length { get; }
public override long Length { get; }
Public Overrides ReadOnly Property Length As Long
    Get
Public Overrides ReadOnly Property Length As Long
    Get
public:
virtual property long long Length {
    long long get () override;
}
public:
virtual property long long Length {
    long long get () override;
}
abstract Length : int64 with get
override Length : int64 with get
abstract Length : int64 with get
override Length : int64 with get
Property Value
Int64


Position Property

Position Property
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibStream ► Position
Keyoti RapidSpell WPF
The position of the stream pointer.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override long Position { get; set; }
public override long Position { get; set; }
Public Overrides Property Position As Long
    Get
    Set
Public Overrides Property Position As Long
    Get
    Set
public:
virtual property long long Position {
    long long get () override;
    void set (long long value) override;
}
public:
virtual property long long Position {
    long long get () override;
    void set (long long value) override;
}
abstract Position : int64 with get, set
override Position : int64 with get, set
abstract Position : int64 with get, set
override Position : int64 with get, set
Property Value
Int64
Remarks
Setting this property always throws a NotImplementedException. Reading will return the total bytes written out, if used in writing, or the total bytes read in, if used in reading. The count may refer to compressed bytes or uncompressed bytes, depending on how you've used the stream.


Read Method (buffer, offset, count)

Read Method (buffer, offset, count)
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibStream ► Read(array<Byte>[]()[][], Int32, Int32)
Keyoti RapidSpell WPF
Read data from the stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Function Read (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
Public Overrides Function Read (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
abstract Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
override Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
abstract Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
override Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
Parameters
buffer (array< Byte >[]()[][])
The buffer into which the read data should be placed.
offset (Int32)
the offset within that data array to put the first byte read.
count (Int32)
the number of bytes to read.
Return Value
Int32
Remarks

If you wish to use the ZlibStream to compress data while reading, you can create a ZlibStream with CompressionMode.Compress, providing an uncompressed data stream. Then call Read() on that ZlibStream, and the data read will be compressed. If you wish to use the ZlibStream to decompress data while reading, you can create a ZlibStream with CompressionMode.Decompress, providing a readable compressed data stream. Then call Read() on that ZlibStream, and the data will be decompressed as it is read.

A ZlibStream can be used for Read() or Write(), but not both.


Seek Method (offset, origin)

Seek Method (offset, origin)
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibStream ► Seek(Int64, SeekOrigin)
Keyoti RapidSpell WPF
Calling this method always throws a NotImplementedException.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override long Seek(
    long offset,
    SeekOrigin origin
)
public override long Seek(
    long offset,
    SeekOrigin origin
)
Public Overrides Function Seek (
    offset As Long,
    origin As SeekOrigin
) As Long
Public Overrides Function Seek (
    offset As Long,
    origin As SeekOrigin
) As Long
public:
virtual long long Seek(
    long long offset,
    SeekOrigin origin
) override
public:
virtual long long Seek(
    long long offset,
    SeekOrigin origin
) override
abstract Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
override Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
abstract Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
override Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
Parameters
offset (Int64)
origin (SeekOrigin)
Return Value
Int64


SetLength Method (value)

SetLength Method (value)
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibStream ► SetLength(Int64)
Keyoti RapidSpell WPF
Calling this method always throws a NotImplementedException.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override void SetLength(
    long value
)
public override void SetLength(
    long value
)
Public Overrides Sub SetLength (
    value As Long
)
Public Overrides Sub SetLength (
    value As Long
)
public:
virtual void SetLength(
    long long value
) override
public:
virtual void SetLength(
    long long value
) override
abstract SetLength :
        value : int64 -> unit
override SetLength :
        value : int64 -> unit
abstract SetLength :
        value : int64 -> unit
override SetLength :
        value : int64 -> unit
Parameters
value (Int64)


TotalIn Property

TotalIn Property
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibStream ► TotalIn
Keyoti RapidSpell WPF
Returns the total number of bytes input so far.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual long TotalIn { get; }
public virtual long TotalIn { get; }
Public Overridable ReadOnly Property TotalIn As Long
    Get
Public Overridable ReadOnly Property TotalIn As Long
    Get
public:
virtual property long long TotalIn {
    long long get ();
}
public:
virtual property long long TotalIn {
    long long get ();
}
abstract TotalIn : int64 with get
override TotalIn : int64 with get
abstract TotalIn : int64 with get
override TotalIn : int64 with get
Property Value
Int64


TotalOut Property

TotalOut Property
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibStream ► TotalOut
Keyoti RapidSpell WPF
Returns the total number of bytes output so far.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual long TotalOut { get; }
public virtual long TotalOut { get; }
Public Overridable ReadOnly Property TotalOut As Long
    Get
Public Overridable ReadOnly Property TotalOut As Long
    Get
public:
virtual property long long TotalOut {
    long long get ();
}
public:
virtual property long long TotalOut {
    long long get ();
}
abstract TotalOut : int64 with get
override TotalOut : int64 with get
abstract TotalOut : int64 with get
override TotalOut : int64 with get
Property Value
Int64


UncompressBuffer Method (compressed)

UncompressBuffer Method (compressed)
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibStream ► UncompressBuffer(array<Byte>[]()[][])
Keyoti RapidSpell WPF
Uncompress a ZLIB-compressed byte array into a byte array.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static byte[] UncompressBuffer(
    byte[] compressed
)
public static byte[] UncompressBuffer(
    byte[] compressed
)
Public Shared Function UncompressBuffer (
    compressed As Byte()
) As Byte()
Public Shared Function UncompressBuffer (
    compressed As Byte()
) As Byte()
public:
static array<unsigned char>^ UncompressBuffer(
    array<unsigned char>^ compressed
)
public:
static array<unsigned char>^ UncompressBuffer(
    array<unsigned char>^ compressed
)
static member UncompressBuffer :
        compressed : byte[] -> byte[]

static member UncompressBuffer :
        compressed : byte[] -> byte[]
Parameters
compressed (array< Byte >[]()[][])
A buffer containing ZLIB-compressed data.
Return Value
array< Byte >[]()[][]
The data in uncompressed form
See Also
CompressBuffer(array<Byte>[]()[][])
UncompressString(array<Byte>[]()[][])


UncompressString Method (compressed)

UncompressString Method (compressed)
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibStream ► UncompressString(array<Byte>[]()[][])
Keyoti RapidSpell WPF
Uncompress a ZLIB-compressed byte array into a single string.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static string UncompressString(
    byte[] compressed
)
public static string UncompressString(
    byte[] compressed
)
Public Shared Function UncompressString (
    compressed As Byte()
) As String
Public Shared Function UncompressString (
    compressed As Byte()
) As String
public:
static String^ UncompressString(
    array<unsigned char>^ compressed
)
public:
static String^ UncompressString(
    array<unsigned char>^ compressed
)
static member UncompressString :
        compressed : byte[] -> string

static member UncompressString :
        compressed : byte[] -> string
Parameters
compressed (array< Byte >[]()[][])
A buffer containing ZLIB-compressed data.
Return Value
String
The uncompressed string
See Also
CompressString(String)
UncompressBuffer(array<Byte>[]()[][])


Write Method (buffer, offset, count)

Write Method (buffer, offset, count)
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibStream ► Write(array<Byte>[]()[][], Int32, Int32)
Keyoti RapidSpell WPF
Write data to the stream.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Sub Write (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
Public Overrides Sub Write (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
public:
virtual void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
public:
virtual void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
abstract Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
override Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
abstract Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
override Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
Parameters
buffer (array< Byte >[]()[][])
The buffer holding data to write to the stream.
offset (Int32)
the offset within that data array to find the first byte to write.
count (Int32)
the number of bytes to write.
Remarks

If you wish to use the ZlibStream to compress data while writing, you can create a ZlibStream with CompressionMode.Compress, and a writable output stream. Then call Write() on that ZlibStream, providing uncompressed data as input. The data sent to the output stream will be the compressed form of the data written. If you wish to use the ZlibStream to decompress data while writing, you can create a ZlibStream with CompressionMode.Decompress, and a writable output stream. Then call Write() on that stream, providing previously compressed data. The data sent to the output stream will be the decompressed form of the data written.

A ZlibStream can be used for Read() or Write(), but not both.


Keyoti.RapidSpell.Wpf Namespace

Keyoti.RapidSpell.Wpf Namespace
API ► Keyoti.RapidSpell.Wpf
Keyoti RapidSpell WPF
The core namespace for RapidSpell.
Types
All Types Classes Interfaces Enumerations Delegates
Icon | Type | Description
 | BadWord | Represents a mis-spelt word in the text.
 | CheckerEngineAdapter | Abstract base implementation of ICheckerEngine, override chosen members for desired functionality.
 | ComClientInteropSupport | This class supports users who access RapidSpell controls from COM code.
 | CutCopyPasteContextMenuMaker | Creates a Cut/Copy/Paste ContextMenu
 | DesignableComponent | Base support for non-visual components.
 | DialogTexts | Contains all texts in RapidSpellDialog and user options.
 | DictionaryCache | Cache of loaded dictionaries.
 | ErrorAdorner | The highlight adorner, which renders error highlights on a plain TextBox
 | ErrorAdornerBase | Base level error underline adorner.
 | FoundSpellingErrorEventArgs | Event args for found error event
 | FoundSpellingErrorEventHandler | EventHandler delegate
 | IAdornerPaintCheat |
 | IAYTTextBox | Interface requirements for an "as-you-type" text box, if an object implements this interface then it is compatible with the RapidSpellAYT control.
 | ICheckerEngine | Defines the interface required for a class to be used as a checker engine
 | ISpellCheckableTextComponent | Defines the interface required for a text component to be spell checkable using the RapidSpellDialog control (or RapidSpellGUI class)
 | ISpellCheckableTextComponent2 | Defines the interface required for a text component to be spell checkable using the RapidSpellDialog control (or RapidSpellGUI class)
 | IUserInterfaceFormPresenter | Interface requirements for a dialog based UI form.
 | KLicenseProvider | Summary description for KLicenseProvider.
 | LanguageType | Enumeration of language types.
 | UserDictionary..::..ListChangedEventArgs | Event args for ListChanged event
 | UserDictionary..::..ListChangedEventHandler | Event handler
 | UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation | Types of operation
 | MultiFileUserDictionary | Represents multiple file based user dictionaries.
 | NoCurrentBadWordException | Thrown if NextBadWord has not been run first and found a mis-spelled word.
 | NoTextComponentException | Thrown if a valid text component hasn't been set to be checked (by the GUI for example).
 | UndoableOperation..::..Operation | Types of operation
 | OperationScope | The scope of an operation.
 | OptionsSavedEventArgs | Args for the options saved event.
 | OptionsSavedEventHandler | Handler
 | RapidSpellAsYouType | RapidSpell As-You-Type Control, spell checks text boxes as the user types.
 | RapidSpellAYTDialogCoupler | RapidSpell Desktop AYT-Dialog Coupler Control, this lightweight convenience control is used to couple RapidSpellAsYouType and RapidSpellDialog.
 | RapidSpellChecker | Spell checker engine, checks a text string for spelling errors and makes suggested corrections.
 | RapidSpellDialog | RapidSpell Desktop Dialog Control, this convenience control provides design time support for RapidSpellGUI and multiple text box support.
 | RapidSpellGUIPresenter | Controls the UI logic used for RapidSpellDialog forms.
 | RichErrorAdorner | The highlight adorner, which renders error highlights on a RichTextBox
 | SelectionAdorner | The highlight adorner, which renders error highlights on a TextBoxBase
 | RapidSpellDialog..::..SpellCheckEventHandler | Spell check event handler delegate.
 | RapidSpellGUIPresenter..::..SpellCheckEventHandler | Spell check event handler delegate.
 | SpellContextMenuRequestEventHandler | Handler delegate
 | SpellingDictionary | Helper
 | StartupRegisterForm | Helper to launch the license key registration form
 | RapidSpellChecker..::..State | State of the spell checker
 | UserDictionary..::..StorageLocation | Location options for storage
 | Suggestion | Represents a suggestion.
 | SuggestionsMethodType | Suggestions algorithm identifiers.
 | RapidSpellDialog..::..TextBoxSpellCheckEventHandler | Handler delegate
 | TextChangeHint | Hints the change scanner as to where the change could be, if any, on user input.
 | Underline | Represents an underline
 | UnderlineStyle | Mis-spelling underline style for RapidSpellAYT control.
 | UndoableOperation | An operation which can be undone
 | UndoableStateEventArgs | Args for the events fired when words are ignored.
 | UndoEventArgs | Undo event args
 | UndoEventHandler | Event handler delegate
 | UndoManager | Manages the undoable operation stack.
 | UserDictionary | Represents the UserDictionary
 | WordAddedEventArgs | Args for the events fired when words are added to the user dictionary.
 | WordAddedEventHandler | Handler delegate
 | WordChangedEventArgs | Args for the events fired when words are changed.
 | WordChangedEventHandler | Handler delegate
 | WordIgnoredEventArgs | Args for the events fired when words are ignored.
 | WordIgnoredEventHandler | Handler delegate
 | WordOccurrence | Represents a word in the text.
 | WordRemovedEventArgs | Args for the events fired when words are removed from the user dictionary.
 | WordRemovedEventHandler | Handler delegate
 | WpfBaseAdapter | Base support for internal text box wrappers.
 | WpfRichTextBoxAdapter | Used (primarily internally) to wrap the RichTextBox control with required interfaces for spell checking.
 | WpfTextBoxAdapter | Used (primarily internally) to wrap the plain TextBox control with required interfaces for spell checking.
 | WpfTextBoxBaseUtilityAdapter | Handles underlines and error adorners.


BadWord Class

BadWord Class
API ► Keyoti.RapidSpell.Wpf ► BadWord
Keyoti RapidSpell WPF
Represents a mis-spelt word in the text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class BadWord : WordOccurrence
public class BadWord : WordOccurrence
Public Class BadWord
    Inherits WordOccurrence
Public Class BadWord
    Inherits WordOccurrence
public ref class BadWord : public WordOccurrence
public ref class BadWord : public WordOccurrence
type BadWord =
    class
        inherit WordOccurrence
    end
type BadWord =
    class
        inherit WordOccurrence
    end
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BadWord(String, Int32, Int32) | Constructs a BadWord (REASON_SPELLING) instance.
 | BadWord(String, Int32, Int32, Int32) | Constructs a BadWord instance.
 | caretEnd | End of word (Inherited from WordOccurrence.)
 | caretStart | Start of word (Inherited from WordOccurrence.)
 | Clone()()()() | Clones this instance
 | EndPosition | Gets the position of the end of this word in the main text. (Inherited from WordOccurrence.)
 | Equals(Object) | See base. (Overrides Object.Equals(Object).)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetEndPosition()()()() | Gets the position of the end of this word in the main text. (Inherited from WordOccurrence.)
 | GetHashCode()()()() | See base (Overrides Object.GetHashCode()()()().)
 | GetReason()()()() | Gets the reason that this is a bad word.
 | GetStartPosition()()()() | Gets the position of the start of this word in the main text. (Inherited from WordOccurrence.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GetWord()()()() | Gets the String of this bad word. (Inherited from WordOccurrence.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Reason | Gets the reason that this is a bad word.
 | REASON_CAPITALIZATION | BadWord reason, incorrect capitalization.
 | REASON_DUPLICATE | BadWord reason, duplicate word occurrence.
 | REASON_SPELLING | BadWord reason, incorrect spelling.
 | Shift(Int32) | Moves the bad word position by delta
 | StartPosition | Gets the position of the start of this word in the main text. (Inherited from WordOccurrence.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Word | Gets the string of this bad word. (Inherited from WordOccurrence.)
Inheritance Hierarchy
Object
 | WordOccurrence
 |  | BadWord


BadWord Constructor

BadWord Constructor
API ► Keyoti.RapidSpell.Wpf ► BadWord ► BadWord()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | BadWord(String, Int32, Int32) | Constructs a BadWord (REASON_SPELLING) instance.
 | BadWord(String, Int32, Int32, Int32) | Constructs a BadWord instance.


BadWord Constructor (word, caretStart, caretEnd)

BadWord Constructor (word, caretStart, caretEnd)
API ► Keyoti.RapidSpell.Wpf ► BadWord ► BadWord(String, Int32, Int32)
Keyoti RapidSpell WPF
Constructs a BadWord (REASON_SPELLING) instance.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public BadWord(
    string word,
    int caretStart,
    int caretEnd
)
public BadWord(
    string word,
    int caretStart,
    int caretEnd
)
Public Sub New (
    word As String,
    caretStart As Integer,
    caretEnd As Integer
)
Public Sub New (
    word As String,
    caretStart As Integer,
    caretEnd As Integer
)
public:
BadWord(
    String^ word,
    int caretStart,
    int caretEnd
)
public:
BadWord(
    String^ word,
    int caretStart,
    int caretEnd
)
new :
        word : string *
        caretStart : int *
        caretEnd : int -> BadWord
new :
        word : string *
        caretStart : int *
        caretEnd : int -> BadWord
Parameters
word (String)
the word String that is misspelt
caretStart (Int32)
the position in the original text
caretEnd (Int32)
the end position in the text


BadWord Constructor (word, caretStart, caretEnd, reason)

BadWord Constructor (word, caretStart, caretEnd, reason)
API ► Keyoti.RapidSpell.Wpf ► BadWord ► BadWord(String, Int32, Int32, Int32)
Keyoti RapidSpell WPF
Constructs a BadWord instance.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public BadWord(
    string word,
    int caretStart,
    int caretEnd,
    int reason
)
public BadWord(
    string word,
    int caretStart,
    int caretEnd,
    int reason
)
Public Sub New (
    word As String,
    caretStart As Integer,
    caretEnd As Integer,
    reason As Integer
)
Public Sub New (
    word As String,
    caretStart As Integer,
    caretEnd As Integer,
    reason As Integer
)
public:
BadWord(
    String^ word,
    int caretStart,
    int caretEnd,
    int reason
)
public:
BadWord(
    String^ word,
    int caretStart,
    int caretEnd,
    int reason
)
new :
        word : string *
        caretStart : int *
        caretEnd : int *
        reason : int -> BadWord
new :
        word : string *
        caretStart : int *
        caretEnd : int *
        reason : int -> BadWord
Parameters
word (String)
the word String that is misspelt
caretStart (Int32)
the position in the original text
caretEnd (Int32)
the end position in the text
reason (Int32)
the reason this is a bad word, either REASON_DUPLICATE or REASON_SPELLING


Clone Method

Clone Method
API ► Keyoti.RapidSpell.Wpf ► BadWord ► Clone()()()()
Keyoti RapidSpell WPF
Clones this instance
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public BadWord Clone()
public BadWord Clone()
Public Function Clone As BadWord
Public Function Clone As BadWord
public:
BadWord^ Clone()
public:
BadWord^ Clone()
member Clone : unit -> BadWord

member Clone : unit -> BadWord
Return Value
BadWord


Equals Method (obj)

Equals Method (obj)
API ► Keyoti.RapidSpell.Wpf ► BadWord ► Equals(Object)
Keyoti RapidSpell WPF
See base.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
Parameters
obj (Object)
Return Value
Boolean


GetHashCode Method

GetHashCode Method
API ► Keyoti.RapidSpell.Wpf ► BadWord ► GetHashCode()()()()
Keyoti RapidSpell WPF
See base
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
Return Value
Int32


GetReason Method

GetReason Method
API ► Keyoti.RapidSpell.Wpf ► BadWord ► GetReason()()()()
Keyoti RapidSpell WPF
Gets the reason that this is a bad word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int GetReason()
public int GetReason()
Public Function GetReason As Integer
Public Function GetReason As Integer
public:
int GetReason()
public:
int GetReason()
member GetReason : unit -> int

member GetReason : unit -> int
Return Value
Int32


Reason Property

Reason Property
API ► Keyoti.RapidSpell.Wpf ► BadWord ► Reason
Keyoti RapidSpell WPF
Gets the reason that this is a bad word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int Reason { get; }
public int Reason { get; }
Public ReadOnly Property Reason As Integer
    Get
Public ReadOnly Property Reason As Integer
    Get
public:
property int Reason {
    int get ();
}
public:
property int Reason {
    int get ();
}
member Reason : int with get

member Reason : int with get
Property Value
Int32


REASON_CAPITALIZATION Field

REASON_CAPITALIZATION Field
API ► Keyoti.RapidSpell.Wpf ► BadWord ► REASON_CAPITALIZATION
Keyoti RapidSpell WPF
BadWord reason, incorrect capitalization.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static int REASON_CAPITALIZATION
public static int REASON_CAPITALIZATION
Public Shared REASON_CAPITALIZATION As Integer
Public Shared REASON_CAPITALIZATION As Integer
public:
static int REASON_CAPITALIZATION
public:
static int REASON_CAPITALIZATION
static val mutable REASON_CAPITALIZATION: int
static val mutable REASON_CAPITALIZATION: int
Field Value
Int32


REASON_DUPLICATE Field

REASON_DUPLICATE Field
API ► Keyoti.RapidSpell.Wpf ► BadWord ► REASON_DUPLICATE
Keyoti RapidSpell WPF
BadWord reason, duplicate word occurrence.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static int REASON_DUPLICATE
public static int REASON_DUPLICATE
Public Shared REASON_DUPLICATE As Integer
Public Shared REASON_DUPLICATE As Integer
public:
static int REASON_DUPLICATE
public:
static int REASON_DUPLICATE
static val mutable REASON_DUPLICATE: int
static val mutable REASON_DUPLICATE: int
Field Value
Int32


REASON_SPELLING Field

REASON_SPELLING Field
API ► Keyoti.RapidSpell.Wpf ► BadWord ► REASON_SPELLING
Keyoti RapidSpell WPF
BadWord reason, incorrect spelling.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static int REASON_SPELLING
public static int REASON_SPELLING
Public Shared REASON_SPELLING As Integer
Public Shared REASON_SPELLING As Integer
public:
static int REASON_SPELLING
public:
static int REASON_SPELLING
static val mutable REASON_SPELLING: int
static val mutable REASON_SPELLING: int
Field Value
Int32


Shift Method (delta)

Shift Method (delta)
API ► Keyoti.RapidSpell.Wpf ► BadWord ► Shift(Int32)
Keyoti RapidSpell WPF
Moves the bad word position by delta
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void Shift(
    int delta
)
public virtual void Shift(
    int delta
)
Public Overridable Sub Shift (
    delta As Integer
)
Public Overridable Sub Shift (
    delta As Integer
)
public:
virtual void Shift(
    int delta
)
public:
virtual void Shift(
    int delta
)
abstract Shift :
        delta : int -> unit
override Shift :
        delta : int -> unit
abstract Shift :
        delta : int -> unit
override Shift :
        delta : int -> unit
Parameters
delta (Int32)


CheckerEngineAdapter Class

CheckerEngineAdapter Class
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter
Keyoti RapidSpell WPF
Abstract base implementation of ICheckerEngine, override chosen members for desired functionality.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public abstract class CheckerEngineAdapter : ICheckerEngine
public abstract class CheckerEngineAdapter : ICheckerEngine
Public MustInherit Class CheckerEngineAdapter
    Implements ICheckerEngine
Public MustInherit Class CheckerEngineAdapter
    Implements ICheckerEngine
public ref class CheckerEngineAdapter abstract : ICheckerEngine
public ref class CheckerEngineAdapter abstract : ICheckerEngine
[<AbstractClassAttribute>]
type CheckerEngineAdapter =
    class
        interface ICheckerEngine
    end
[<AbstractClassAttribute>]
type CheckerEngineAdapter =
    class
        interface ICheckerEngine
    end
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CheckerEngineAdapter()()()() |
 | AddWord(String) | Adds a word to the user dictionary, if it exists.
 | AllowAnyCase | Whether to allow words spelt with any case, eg. "africa" instead of "Africa", this is more relaxed than AllowMixedCase.
 | AllowMixedCase | Whether to allow words spelt with mixed case, eg. "MIxEd"
 | ChangeBadWord(String) | Changes the current bad word to newWord in the text.
 | ChangeBadWord(BadWord, String) | Changes badWord to newWord in the text.
 | Check(String) | Checks the text for errors.
 | Check(String, Boolean) | Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.
 | CheckCompoundWords | Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
 | CurrentBadWord | Gets the current bad word (last returned by NextBadWord).
 | DictFilePath | The file to be used as the main dictionary, if this is null then the RapidSpellMDict.DLL satellite assembly is used.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FindCapitalizedSuggestions | Whether to look for capitalized suggestions, note this will slow FindSuggestions down by about 7 times.
 | FindSuggestions()()()() | Returns an ArrayList of Strings that are suitable suggestions for the current bad word (that is, the one last returned by NextBadWord()).
 | FindSuggestions(String) | Returns an ArrayList of Strings that are suitable suggestions for word.
 | GetConsiderationRange()()()() | Gets the factor for words to consider for suggestions.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIgnoreCapitalizedWords()()()() | Gets whether to ignore words that start with capital letters.
 | GetIncludeUserDictionaryInSuggestions()()()() | Gets whether the user dictionary should be used in finding suggestions for misspelt words.
 | GetSuggestionsMethod()()()() | Sets the suggestions method, where method is an integer identifier.
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GetUndoableStatePoint()()()() | Returns null as undo is not supported
 | IgnoreAll(String) | Marks word to be ignored in rest of the text.
 | IgnoreAllCaseInsensitive | Whether Ignore All operations should be considered case insensitive (default false).
 | IgnoreIncorrectSentenceCapitalization | Whether to ignore incorrect sentence capitalization.
 | IgnoreInEnglishLowerCaseI | Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
 | IgnoreList | The words to ignore, note this list is changed by IgnoreAll.
 | IgnorePatternMaximumWordLength | The maximum length of word that will be tested as a regex ignore pattern.
 | IgnoreURLsAndEmailAddresses | Whether to ignore URLs and email addresses (requires V2Parser=true)
 | IgnoreWordsWithDigits | Whether to ignore words with numbers in them (eg. A10 or 7-11).
 | IgnoreXML | Whether to ignore XML tags in the text.
 | LanguageParser | The type of language parsing to use.
 | LookIntoHyphenatedText | Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
 | LookUp(String) | Looks up word in the dictionary, returns true if it is in there.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NextBadWord()()()() | Gets the next bad word in the list that was identified by Check.
 | RevertToUndoableStatePoint(RapidSpellChecker..::..State) | Throws NotImplementedException
 | SetConsiderationRange(Int32) | Sets the breadth of the suggestions search.
 | SetDictFileStream(Stream, String, DateTime) | Passes a Dict file as a stream, to be used for the main dictionary.
 | SetIgnoreCapitalizedWords(Boolean) | Sets whether to ignore capitalized words.
 | SetIncludeUserDictionaryInSuggestions(Boolean) | Sets whether to include the user dictionary in suggestions taken from this engine.
 | SetOptionalContext(String, String) | Provides the engine with any helpful text around the text snippet which will be passed to the Check method. Implementation is not required.
 | SetPosition(Int32) | Sets the pointer position for the NextBadWord iterator.
 | SetSeparateHyphenWords(Boolean) | Sets whether to separate words with hyphens in them into separate words.
 | SetSuggestionsMethod(Int32) | Sets the suggestions method, where method is an integer identifier.
 | SetUserDictionary(UserDictionary) | Sets the UserDictionary object to be used as a user dictionary source.
 | SetUserDictionary(String) | Sets the UserDictionary file path to be used as a user dictionary source.
 | SuggestSplitWords | Whether to look for connected words in suggestions.
 | TextBoundary | The AdvancedTextBoundary class to use to parse words.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | UnloadMainDictionary()()()() | Empties the main dictionary store.
 | userDictionary | The user dictionary, this should be null (C#) or nothing (VB.NET) if no user dictionary is being used.
 | V2Parser | Whether to use parser version 2
 | WarnDuplicates | Whether to treat duplicate words as errors (eg. "this is is an error").
 | WordAdded | Fires when a word is added
Remarks
None of the members contained in this class do anything.
Inheritance Hierarchy
Object
CheckerEngineAdapter


CheckerEngineAdapter Constructor

CheckerEngineAdapter Constructor
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► CheckerEngineAdapter()()()()
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected CheckerEngineAdapter()
protected CheckerEngineAdapter()
Protected Sub New
Protected Sub New
protected:
CheckerEngineAdapter()
protected:
CheckerEngineAdapter()
new : unit -> CheckerEngineAdapter
new : unit -> CheckerEngineAdapter


AddWord Method (word)

AddWord Method (word)
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► AddWord(String)
Keyoti RapidSpell WPF
Adds a word to the user dictionary, if it exists.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool AddWord(
    string word
)
public virtual bool AddWord(
    string word
)
Public Overridable Function AddWord (
    word As String
) As Boolean
Public Overridable Function AddWord (
    word As String
) As Boolean
public:
virtual bool AddWord(
    String^ word
)
public:
virtual bool AddWord(
    String^ word
)
abstract AddWord :
        word : string -> bool
override AddWord :
        word : string -> bool
abstract AddWord :
        word : string -> bool
override AddWord :
        word : string -> bool
Parameters
word (String)
Return Value
Boolean
This implementation always returns false.
Remarks
Should return true if the word was added successfully, false otherwise.


AllowAnyCase Property

AllowAnyCase Property
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► AllowAnyCase
Keyoti RapidSpell WPF
Whether to allow words spelt with any case, eg. "africa" instead of "Africa", this is more relaxed than AllowMixedCase.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool AllowAnyCase { get; set; }
public bool AllowAnyCase { get; set; }
Public Property AllowAnyCase As Boolean
    Get
    Set
Public Property AllowAnyCase As Boolean
    Get
    Set
public:
virtual property bool AllowAnyCase {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool AllowAnyCase {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract AllowAnyCase : bool with get, set
override AllowAnyCase : bool with get, set
abstract AllowAnyCase : bool with get, set
override AllowAnyCase : bool with get, set
Property Value
Boolean


AllowMixedCase Property

AllowMixedCase Property
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► AllowMixedCase
Keyoti RapidSpell WPF
Whether to allow words spelt with mixed case, eg. "MIxEd"
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool AllowMixedCase { get; set; }
public virtual bool AllowMixedCase { get; set; }
Public Overridable Property AllowMixedCase As Boolean
    Get
    Set
Public Overridable Property AllowMixedCase As Boolean
    Get
    Set
public:
virtual property bool AllowMixedCase {
    bool get ();
    void set (bool value);
}
public:
virtual property bool AllowMixedCase {
    bool get ();
    void set (bool value);
}
abstract AllowMixedCase : bool with get, set
override AllowMixedCase : bool with get, set
abstract AllowMixedCase : bool with get, set
override AllowMixedCase : bool with get, set
Property Value
Boolean


ChangeBadWord Method

ChangeBadWord Method
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► ChangeBadWord()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | ChangeBadWord(String) | Changes the current bad word to newWord in the text.
 | ChangeBadWord(BadWord, String) | Changes badWord to newWord in the text.


ChangeBadWord Method (badWord, newWord)

ChangeBadWord Method (badWord, newWord)
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► ChangeBadWord(BadWord, String)
Keyoti RapidSpell WPF
Changes badWord to newWord in the text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void ChangeBadWord(
    BadWord badWord,
    string newWord
)
public virtual void ChangeBadWord(
    BadWord badWord,
    string newWord
)
Public Overridable Sub ChangeBadWord (
    badWord As BadWord,
    newWord As String
)
Public Overridable Sub ChangeBadWord (
    badWord As BadWord,
    newWord As String
)
public:
virtual void ChangeBadWord(
    BadWord^ badWord,
    String^ newWord
)
public:
virtual void ChangeBadWord(
    BadWord^ badWord,
    String^ newWord
)
abstract ChangeBadWord :
        badWord : BadWord *
        newWord : string -> unit
override ChangeBadWord :
        badWord : BadWord *
        newWord : string -> unit
abstract ChangeBadWord :
        badWord : BadWord *
        newWord : string -> unit
override ChangeBadWord :
        badWord : BadWord *
        newWord : string -> unit
Parameters
badWord (BadWord)
the bad word to replace
newWord (String)
replaces the current misspelt word.
Return Value

void
Exceptions
Exception | Condition
ArgumentNullException | if newWord parameter is null.


ChangeBadWord Method (newWord)

ChangeBadWord Method (newWord)
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► ChangeBadWord(String)
Keyoti RapidSpell WPF
Changes the current bad word to newWord in the text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void ChangeBadWord(
    string newWord
)
public void ChangeBadWord(
    string newWord
)
Public Sub ChangeBadWord (
    newWord As String
)
Public Sub ChangeBadWord (
    newWord As String
)
public:
virtual void ChangeBadWord(
    String^ newWord
) sealed
public:
virtual void ChangeBadWord(
    String^ newWord
) sealed
abstract ChangeBadWord :
        newWord : string -> unit
override ChangeBadWord :
        newWord : string -> unit
abstract ChangeBadWord :
        newWord : string -> unit
override ChangeBadWord :
        newWord : string -> unit
Parameters
newWord (String)
replaces the current misspelt word.
Return Value

void
Exceptions
Exception | Condition
NoCurrentBadWordException | if nextBadWord() hasn't been run first AND found an erroneous word.
ArgumentNullException | if newWord parameter is null.


Check Method

Check Method
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► Check()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | Check(String) | Checks the text for errors.
 | Check(String, Boolean) | Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.


Check Method (text)

Check Method (text)
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► Check(String)
Keyoti RapidSpell WPF
Checks the text for errors.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void Check(
    string text
)
public virtual void Check(
    string text
)
Public Overridable Sub Check (
    text As String
)
Public Overridable Sub Check (
    text As String
)
public:
virtual void Check(
    String^ text
)
public:
virtual void Check(
    String^ text
)
abstract Check :
        text : string -> unit
override Check :
        text : string -> unit
abstract Check :
        text : string -> unit
override Check :
        text : string -> unit
Parameters
text (String)
Exceptions
Exception | Condition
ArgumentNullException | if text parameter is null.


Check Method (text, isStartOfTextBody)

Check Method (text, isStartOfTextBody)
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► Check(String, Boolean)
Keyoti RapidSpell WPF
Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void Check(
    string text,
    bool isStartOfTextBody
)
public void Check(
    string text,
    bool isStartOfTextBody
)
Public Sub Check (
    text As String,
    isStartOfTextBody As Boolean
)
Public Sub Check (
    text As String,
    isStartOfTextBody As Boolean
)
public:
virtual void Check(
    String^ text,
    bool isStartOfTextBody
) sealed
public:
virtual void Check(
    String^ text,
    bool isStartOfTextBody
) sealed
abstract Check :
        text : string *
        isStartOfTextBody : bool -> unit
override Check :
        text : string *
        isStartOfTextBody : bool -> unit
abstract Check :
        text : string *
        isStartOfTextBody : bool -> unit
override Check :
        text : string *
        isStartOfTextBody : bool -> unit
Parameters
text (String)
to spell check.
isStartOfTextBody (Boolean)
whether the text being spell checked is at the start of the text body (eg. start of text box), this affects sentence capitalization determination.
Return Value

void
Exceptions
Exception | Condition
ArgumentNullException | if text parameter is null.


CheckCompoundWords Property

CheckCompoundWords Property
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► CheckCompoundWords
Keyoti RapidSpell WPF
Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool CheckCompoundWords { get; set; }
public virtual bool CheckCompoundWords { get; set; }
Public Overridable Property CheckCompoundWords As Boolean
    Get
    Set
Public Overridable Property CheckCompoundWords As Boolean
    Get
    Set
public:
virtual property bool CheckCompoundWords {
    bool get ();
    void set (bool value);
}
public:
virtual property bool CheckCompoundWords {
    bool get ();
    void set (bool value);
}
abstract CheckCompoundWords : bool with get, set
override CheckCompoundWords : bool with get, set
abstract CheckCompoundWords : bool with get, set
override CheckCompoundWords : bool with get, set
Property Value
Boolean
Remarks
If this=false then LookUp("thesewordsarejoined") = false

If this=true then LookUp("thesewordsarejoined") = true

If this=false then LookUp("abcdef") = false

If this=true then LookUp("abcdef") = false

Setting this to true will degrade lookup performance


CurrentBadWord Property

CurrentBadWord Property
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► CurrentBadWord
Keyoti RapidSpell WPF
Gets the current bad word (last returned by NextBadWord).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual BadWord CurrentBadWord { get; }
public virtual BadWord CurrentBadWord { get; }
Public Overridable ReadOnly Property CurrentBadWord As BadWord
    Get
Public Overridable ReadOnly Property CurrentBadWord As BadWord
    Get
public:
virtual property BadWord^ CurrentBadWord {
    BadWord^ get ();
}
public:
virtual property BadWord^ CurrentBadWord {
    BadWord^ get ();
}
abstract CurrentBadWord : BadWord with get
override CurrentBadWord : BadWord with get
abstract CurrentBadWord : BadWord with get
override CurrentBadWord : BadWord with get
Property Value
BadWord


DictFilePath Property

DictFilePath Property
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► DictFilePath
Keyoti RapidSpell WPF
The file to be used as the main dictionary, if this is null then the RapidSpellMDict.DLL satellite assembly is used.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual string DictFilePath { get; set; }
public virtual string DictFilePath { get; set; }
Public Overridable Property DictFilePath As String
    Get
    Set
Public Overridable Property DictFilePath As String
    Get
    Set
public:
virtual property String^ DictFilePath {
    String^ get ();
    void set (String^ value);
}
public:
virtual property String^ DictFilePath {
    String^ get ();
    void set (String^ value);
}
abstract DictFilePath : string with get, set
override DictFilePath : string with get, set
abstract DictFilePath : string with get, set
override DictFilePath : string with get, set
Return Value
String
This implementation always returns null.


FindCapitalizedSuggestions Property

FindCapitalizedSuggestions Property
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► FindCapitalizedSuggestions
Keyoti RapidSpell WPF
Whether to look for capitalized suggestions, note this will slow FindSuggestions down by about 7 times.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool FindCapitalizedSuggestions { get; set; }
public bool FindCapitalizedSuggestions { get; set; }
Public Property FindCapitalizedSuggestions As Boolean
    Get
    Set
Public Property FindCapitalizedSuggestions As Boolean
    Get
    Set
public:
virtual property bool FindCapitalizedSuggestions {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool FindCapitalizedSuggestions {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract FindCapitalizedSuggestions : bool with get, set
override FindCapitalizedSuggestions : bool with get, set
abstract FindCapitalizedSuggestions : bool with get, set
override FindCapitalizedSuggestions : bool with get, set
Property Value
Boolean


FindSuggestions Method

FindSuggestions Method
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► FindSuggestions()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | FindSuggestions()()()() | Returns an ArrayList of Strings that are suitable suggestions for the current bad word (that is, the one last returned by NextBadWord()).
 | FindSuggestions(String) | Returns an ArrayList of Strings that are suitable suggestions for word.


FindSuggestions Method

FindSuggestions Method
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► FindSuggestions()()()()
Keyoti RapidSpell WPF
Returns an ArrayList of Strings that are suitable suggestions for the current bad word (that is, the one last returned by NextBadWord()).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual ArrayList FindSuggestions()
public virtual ArrayList FindSuggestions()
Public Overridable Function FindSuggestions As ArrayList
Public Overridable Function FindSuggestions As ArrayList
public:
virtual ArrayList^ FindSuggestions()
public:
virtual ArrayList^ FindSuggestions()
abstract FindSuggestions : unit -> ArrayList
override FindSuggestions : unit -> ArrayList
abstract FindSuggestions : unit -> ArrayList
override FindSuggestions : unit -> ArrayList
Return Value
ArrayList
An empty ArrayList
Remarks
If no suggestions can be found, this should return an empty ArrayList. This method should be thread safe if operating with RapidSpell Desktop.
Exceptions
Exception | Condition
NoCurrentBadWordException | If NextBadWord() hasn't been run first AND found an erroneous word.


FindSuggestions Method (word)

FindSuggestions Method (word)
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► FindSuggestions(String)
Keyoti RapidSpell WPF
Returns an ArrayList of Strings that are suitable suggestions for word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual ArrayList FindSuggestions(
    string word
)
public virtual ArrayList FindSuggestions(
    string word
)
Public Overridable Function FindSuggestions (
    word As String
) As ArrayList
Public Overridable Function FindSuggestions (
    word As String
) As ArrayList
public:
virtual ArrayList^ FindSuggestions(
    String^ word
)
public:
virtual ArrayList^ FindSuggestions(
    String^ word
)
abstract FindSuggestions :
        word : string -> ArrayList
override FindSuggestions :
        word : string -> ArrayList
abstract FindSuggestions :
        word : string -> ArrayList
override FindSuggestions :
        word : string -> ArrayList
Parameters
word (String)
Return Value
ArrayList
An empty ArrayList
Remarks
If no suggestions can be found, this should return an empty ArrayList. This method should be thread safe if operating with RapidSpell Desktop.


GetConsiderationRange Method

GetConsiderationRange Method
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► GetConsiderationRange()()()()
Keyoti RapidSpell WPF
Gets the factor for words to consider for suggestions.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual int GetConsiderationRange()
public virtual int GetConsiderationRange()
Public Overridable Function GetConsiderationRange As Integer
Public Overridable Function GetConsiderationRange As Integer
public:
virtual int GetConsiderationRange()
public:
virtual int GetConsiderationRange()
abstract GetConsiderationRange : unit -> int
override GetConsiderationRange : unit -> int
abstract GetConsiderationRange : unit -> int
override GetConsiderationRange : unit -> int
Return Value
Int32
This implementation always returns 0.


GetIgnoreCapitalizedWords Method

GetIgnoreCapitalizedWords Method
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► GetIgnoreCapitalizedWords()()()()
Keyoti RapidSpell WPF
Gets whether to ignore words that start with capital letters.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool GetIgnoreCapitalizedWords()
public virtual bool GetIgnoreCapitalizedWords()
Public Overridable Function GetIgnoreCapitalizedWords As Boolean
Public Overridable Function GetIgnoreCapitalizedWords As Boolean
public:
virtual bool GetIgnoreCapitalizedWords()
public:
virtual bool GetIgnoreCapitalizedWords()
abstract GetIgnoreCapitalizedWords : unit -> bool
override GetIgnoreCapitalizedWords : unit -> bool
abstract GetIgnoreCapitalizedWords : unit -> bool
override GetIgnoreCapitalizedWords : unit -> bool
Return Value
Boolean
This implementation always returns false.


GetIncludeUserDictionaryInSuggestions Method

GetIncludeUserDictionaryInSuggestions Method
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► GetIncludeUserDictionaryInSuggestions()()()()
Keyoti RapidSpell WPF
Gets whether the user dictionary should be used in finding suggestions for misspelt words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool GetIncludeUserDictionaryInSuggestions()
public virtual bool GetIncludeUserDictionaryInSuggestions()
Public Overridable Function GetIncludeUserDictionaryInSuggestions As Boolean
Public Overridable Function GetIncludeUserDictionaryInSuggestions As Boolean
public:
virtual bool GetIncludeUserDictionaryInSuggestions()
public:
virtual bool GetIncludeUserDictionaryInSuggestions()
abstract GetIncludeUserDictionaryInSuggestions : unit -> bool
override GetIncludeUserDictionaryInSuggestions : unit -> bool
abstract GetIncludeUserDictionaryInSuggestions : unit -> bool
override GetIncludeUserDictionaryInSuggestions : unit -> bool
Return Value
Boolean
This implementation always returns false.


GetSuggestionsMethod Method

GetSuggestionsMethod Method
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► GetSuggestionsMethod()()()()
Keyoti RapidSpell WPF
Sets the suggestions method, where method is an integer identifier.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual int GetSuggestionsMethod()
public virtual int GetSuggestionsMethod()
Public Overridable Function GetSuggestionsMethod As Integer
Public Overridable Function GetSuggestionsMethod As Integer
public:
virtual int GetSuggestionsMethod()
public:
virtual int GetSuggestionsMethod()
abstract GetSuggestionsMethod : unit -> int
override GetSuggestionsMethod : unit -> int
abstract GetSuggestionsMethod : unit -> int
override GetSuggestionsMethod : unit -> int
Return Value
Int32


GetUndoableStatePoint Method

GetUndoableStatePoint Method
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► GetUndoableStatePoint()()()()
Keyoti RapidSpell WPF
Returns null as undo is not supported
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual RapidSpellChecker..::..State GetUndoableStatePoint()
public virtual RapidSpellChecker..::..State GetUndoableStatePoint()
Public Overridable Function GetUndoableStatePoint As RapidSpellChecker..::..State
Public Overridable Function GetUndoableStatePoint As RapidSpellChecker..::..State
public:
virtual RapidSpellChecker..::..State^ GetUndoableStatePoint()
public:
virtual RapidSpellChecker..::..State^ GetUndoableStatePoint()
abstract GetUndoableStatePoint : unit -> RapidSpellChecker..::..State
override GetUndoableStatePoint : unit -> RapidSpellChecker..::..State
abstract GetUndoableStatePoint : unit -> RapidSpellChecker..::..State
override GetUndoableStatePoint : unit -> RapidSpellChecker..::..State
Return Value
RapidSpellChecker..::..State
Returns the current state, or null if not supporting undo.


IgnoreAll Method (word)

IgnoreAll Method (word)
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► IgnoreAll(String)
Keyoti RapidSpell WPF
Marks word to be ignored in rest of the text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void IgnoreAll(
    string word
)
public virtual void IgnoreAll(
    string word
)
Public Overridable Sub IgnoreAll (
    word As String
)
Public Overridable Sub IgnoreAll (
    word As String
)
public:
virtual void IgnoreAll(
    String^ word
)
public:
virtual void IgnoreAll(
    String^ word
)
abstract IgnoreAll :
        word : string -> unit
override IgnoreAll :
        word : string -> unit
abstract IgnoreAll :
        word : string -> unit
override IgnoreAll :
        word : string -> unit
Parameters
word (String)
to ignore
Return Value

void
Exceptions
Exception | Condition
ArgumentNullException | if word parameter is null.


IgnoreAllCaseInsensitive Property

IgnoreAllCaseInsensitive Property
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► IgnoreAllCaseInsensitive
Keyoti RapidSpell WPF
Whether Ignore All operations should be considered case insensitive (default false).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreAllCaseInsensitive { get; set; }
public bool IgnoreAllCaseInsensitive { get; set; }
Public Property IgnoreAllCaseInsensitive As Boolean
    Get
    Set
Public Property IgnoreAllCaseInsensitive As Boolean
    Get
    Set
public:
virtual property bool IgnoreAllCaseInsensitive {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool IgnoreAllCaseInsensitive {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IgnoreAllCaseInsensitive : bool with get, set
override IgnoreAllCaseInsensitive : bool with get, set
abstract IgnoreAllCaseInsensitive : bool with get, set
override IgnoreAllCaseInsensitive : bool with get, set
Property Value
Boolean


IgnoreIncorrectSentenceCapitalization Property

IgnoreIncorrectSentenceCapitalization Property
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► IgnoreIncorrectSentenceCapitalization
Keyoti RapidSpell WPF
Whether to ignore incorrect sentence capitalization.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreIncorrectSentenceCapitalization { get; set; }
public bool IgnoreIncorrectSentenceCapitalization { get; set; }
Public Property IgnoreIncorrectSentenceCapitalization As Boolean
    Get
    Set
Public Property IgnoreIncorrectSentenceCapitalization As Boolean
    Get
    Set
public:
virtual property bool IgnoreIncorrectSentenceCapitalization {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool IgnoreIncorrectSentenceCapitalization {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IgnoreIncorrectSentenceCapitalization : bool with get, set
override IgnoreIncorrectSentenceCapitalization : bool with get, set
abstract IgnoreIncorrectSentenceCapitalization : bool with get, set
override IgnoreIncorrectSentenceCapitalization : bool with get, set
Property Value
Boolean


IgnoreInEnglishLowerCaseI Property

IgnoreInEnglishLowerCaseI Property
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► IgnoreInEnglishLowerCaseI
Keyoti RapidSpell WPF
Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreInEnglishLowerCaseI { get; set; }
public bool IgnoreInEnglishLowerCaseI { get; set; }
Public Property IgnoreInEnglishLowerCaseI As Boolean
    Get
    Set
Public Property IgnoreInEnglishLowerCaseI As Boolean
    Get
    Set
public:
virtual property bool IgnoreInEnglishLowerCaseI {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool IgnoreInEnglishLowerCaseI {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IgnoreInEnglishLowerCaseI : bool with get, set
override IgnoreInEnglishLowerCaseI : bool with get, set
abstract IgnoreInEnglishLowerCaseI : bool with get, set
override IgnoreInEnglishLowerCaseI : bool with get, set
Property Value
Boolean


IgnoreList Property

IgnoreList Property
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► IgnoreList
Keyoti RapidSpell WPF
The words to ignore, note this list is changed by IgnoreAll.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual ArrayList IgnoreList { get; set; }
public virtual ArrayList IgnoreList { get; set; }
Public Overridable Property IgnoreList As ArrayList
    Get
    Set
Public Overridable Property IgnoreList As ArrayList
    Get
    Set
public:
virtual property ArrayList^ IgnoreList {
    ArrayList^ get ();
    void set (ArrayList^ value);
}
public:
virtual property ArrayList^ IgnoreList {
    ArrayList^ get ();
    void set (ArrayList^ value);
}
abstract IgnoreList : ArrayList with get, set
override IgnoreList : ArrayList with get, set
abstract IgnoreList : ArrayList with get, set
override IgnoreList : ArrayList with get, set
Property Value
ArrayList


IgnorePatternMaximumWordLength Property

IgnorePatternMaximumWordLength Property
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► IgnorePatternMaximumWordLength
Keyoti RapidSpell WPF
The maximum length of word that will be tested as a regex ignore pattern.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int IgnorePatternMaximumWordLength { get; set; }
public int IgnorePatternMaximumWordLength { get; set; }
Public Property IgnorePatternMaximumWordLength As Integer
    Get
    Set
Public Property IgnorePatternMaximumWordLength As Integer
    Get
    Set
public:
virtual property int IgnorePatternMaximumWordLength {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int IgnorePatternMaximumWordLength {
    int get () sealed;
    void set (int value) sealed;
}
abstract IgnorePatternMaximumWordLength : int with get, set
override IgnorePatternMaximumWordLength : int with get, set
abstract IgnorePatternMaximumWordLength : int with get, set
override IgnorePatternMaximumWordLength : int with get, set
Property Value
Int32


IgnoreURLsAndEmailAddresses Property

IgnoreURLsAndEmailAddresses Property
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► IgnoreURLsAndEmailAddresses
Keyoti RapidSpell WPF
Whether to ignore URLs and email addresses (requires V2Parser=true)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool IgnoreURLsAndEmailAddresses { get; set; }
public virtual bool IgnoreURLsAndEmailAddresses { get; set; }
Public Overridable Property IgnoreURLsAndEmailAddresses As Boolean
    Get
    Set
Public Overridable Property IgnoreURLsAndEmailAddresses As Boolean
    Get
    Set
public:
virtual property bool IgnoreURLsAndEmailAddresses {
    bool get ();
    void set (bool value);
}
public:
virtual property bool IgnoreURLsAndEmailAddresses {
    bool get ();
    void set (bool value);
}
abstract IgnoreURLsAndEmailAddresses : bool with get, set
override IgnoreURLsAndEmailAddresses : bool with get, set
abstract IgnoreURLsAndEmailAddresses : bool with get, set
override IgnoreURLsAndEmailAddresses : bool with get, set
Property Value
Boolean
Remarks
This will cause the following strings to be accepted as non-spelling errors;
"user@domain.com", "http://www.domain.com", "domain.co.uk" etc.


IgnoreWordsWithDigits Property

IgnoreWordsWithDigits Property
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► IgnoreWordsWithDigits
Keyoti RapidSpell WPF
Whether to ignore words with numbers in them (eg. A10 or 7-11).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool IgnoreWordsWithDigits { get; set; }
public virtual bool IgnoreWordsWithDigits { get; set; }
Public Overridable Property IgnoreWordsWithDigits As Boolean
    Get
    Set
Public Overridable Property IgnoreWordsWithDigits As Boolean
    Get
    Set
public:
virtual property bool IgnoreWordsWithDigits {
    bool get ();
    void set (bool value);
}
public:
virtual property bool IgnoreWordsWithDigits {
    bool get ();
    void set (bool value);
}
abstract IgnoreWordsWithDigits : bool with get, set
override IgnoreWordsWithDigits : bool with get, set
abstract IgnoreWordsWithDigits : bool with get, set
override IgnoreWordsWithDigits : bool with get, set
Property Value
Boolean


IgnoreXML Property

IgnoreXML Property
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► IgnoreXML
Keyoti RapidSpell WPF
Whether to ignore XML tags in the text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool IgnoreXML { get; set; }
public virtual bool IgnoreXML { get; set; }
Public Overridable Property IgnoreXML As Boolean
    Get
    Set
Public Overridable Property IgnoreXML As Boolean
    Get
    Set
public:
virtual property bool IgnoreXML {
    bool get ();
    void set (bool value);
}
public:
virtual property bool IgnoreXML {
    bool get ();
    void set (bool value);
}
abstract IgnoreXML : bool with get, set
override IgnoreXML : bool with get, set
abstract IgnoreXML : bool with get, set
override IgnoreXML : bool with get, set
Return Value
Boolean
This property is always false.


LanguageParser Property

LanguageParser Property
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► LanguageParser
Keyoti RapidSpell WPF
The type of language parsing to use.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual LanguageType LanguageParser { get; set; }
public virtual LanguageType LanguageParser { get; set; }
Public Overridable Property LanguageParser As LanguageType
    Get
    Set
Public Overridable Property LanguageParser As LanguageType
    Get
    Set
public:
virtual property LanguageType LanguageParser {
    LanguageType get ();
    void set (LanguageType value);
}
public:
virtual property LanguageType LanguageParser {
    LanguageType get ();
    void set (LanguageType value);
}
abstract LanguageParser : LanguageType with get, set
override LanguageParser : LanguageType with get, set
abstract LanguageParser : LanguageType with get, set
override LanguageParser : LanguageType with get, set
Return Value
LanguageType
This implementation always returns RapidSpellChecker.LanguageParserType.ENGLISH.
Remarks
Eg. If the dictionary is set to French, you should use the French parser.


LookIntoHyphenatedText Property

LookIntoHyphenatedText Property
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► LookIntoHyphenatedText
Keyoti RapidSpell WPF
Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool LookIntoHyphenatedText { get; set; }
public virtual bool LookIntoHyphenatedText { get; set; }
Public Overridable Property LookIntoHyphenatedText As Boolean
    Get
    Set
Public Overridable Property LookIntoHyphenatedText As Boolean
    Get
    Set
public:
virtual property bool LookIntoHyphenatedText {
    bool get ();
    void set (bool value);
}
public:
virtual property bool LookIntoHyphenatedText {
    bool get ();
    void set (bool value);
}
abstract LookIntoHyphenatedText : bool with get, set
override LookIntoHyphenatedText : bool with get, set
abstract LookIntoHyphenatedText : bool with get, set
override LookIntoHyphenatedText : bool with get, set
Property Value
Boolean
Remarks
Eg. "socio-economic" will be checked as "socio" and "economic".


LookUp Method (word)

LookUp Method (word)
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► LookUp(String)
Keyoti RapidSpell WPF
Looks up word in the dictionary, returns true if it is in there.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool LookUp(
    string word
)
public virtual bool LookUp(
    string word
)
Public Overridable Function LookUp (
    word As String
) As Boolean
Public Overridable Function LookUp (
    word As String
) As Boolean
public:
virtual bool LookUp(
    String^ word
)
public:
virtual bool LookUp(
    String^ word
)
abstract LookUp :
        word : string -> bool
override LookUp :
        word : string -> bool
abstract LookUp :
        word : string -> bool
override LookUp :
        word : string -> bool
Parameters
word (String)
Return Value
Boolean


NextBadWord Method

NextBadWord Method
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► NextBadWord()()()()
Keyoti RapidSpell WPF
Gets the next bad word in the list that was identified by Check.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual BadWord NextBadWord()
public virtual BadWord NextBadWord()
Public Overridable Function NextBadWord As BadWord
Public Overridable Function NextBadWord As BadWord
public:
virtual BadWord^ NextBadWord()
public:
virtual BadWord^ NextBadWord()
abstract NextBadWord : unit -> BadWord
override NextBadWord : unit -> BadWord
abstract NextBadWord : unit -> BadWord
override NextBadWord : unit -> BadWord
Return Value
BadWord
This implementation always returns null.
Remarks
Check must be called before this method.


RevertToUndoableStatePoint Method (state)

RevertToUndoableStatePoint Method (state)
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► RevertToUndoableStatePoint(RapidSpellChecker..::..State)
Keyoti RapidSpell WPF
Throws NotImplementedException
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void RevertToUndoableStatePoint(
    RapidSpellChecker..::..State state
)
public virtual void RevertToUndoableStatePoint(
    RapidSpellChecker..::..State state
)
Public Overridable Sub RevertToUndoableStatePoint (
    state As RapidSpellChecker..::..State
)
Public Overridable Sub RevertToUndoableStatePoint (
    state As RapidSpellChecker..::..State
)
public:
virtual void RevertToUndoableStatePoint(
    RapidSpellChecker..::..State^ state
)
public:
virtual void RevertToUndoableStatePoint(
    RapidSpellChecker..::..State^ state
)
abstract RevertToUndoableStatePoint :
        state : RapidSpellChecker..::..State -> unit
override RevertToUndoableStatePoint :
        state : RapidSpellChecker..::..State -> unit
abstract RevertToUndoableStatePoint :
        state : RapidSpellChecker..::..State -> unit
override RevertToUndoableStatePoint :
        state : RapidSpellChecker..::..State -> unit
Parameters
state (RapidSpellChecker..::..State)


SetConsiderationRange Method (range)

SetConsiderationRange Method (range)
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► SetConsiderationRange(Int32)
Keyoti RapidSpell WPF
Sets the breadth of the suggestions search.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void SetConsiderationRange(
    int range
)
public virtual void SetConsiderationRange(
    int range
)
Public Overridable Sub SetConsiderationRange (
    range As Integer
)
Public Overridable Sub SetConsiderationRange (
    range As Integer
)
public:
virtual void SetConsiderationRange(
    int range
)
public:
virtual void SetConsiderationRange(
    int range
)
abstract SetConsiderationRange :
        range : int -> unit
override SetConsiderationRange :
        range : int -> unit
abstract SetConsiderationRange :
        range : int -> unit
override SetConsiderationRange :
        range : int -> unit
Parameters
range (Int32)


SetDictFileStream Method (dictFileStream, id, modifiedDate)

SetDictFileStream Method (dictFileStream, id, modifiedDate)
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► SetDictFileStream(Stream, String, DateTime)
Keyoti RapidSpell WPF
Passes a Dict file as a stream, to be used for the main dictionary.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void SetDictFileStream(
    Stream dictFileStream,
    string id,
    DateTime modifiedDate
)
public virtual void SetDictFileStream(
    Stream dictFileStream,
    string id,
    DateTime modifiedDate
)
Public Overridable Sub SetDictFileStream (
    dictFileStream As Stream,
    id As String,
    modifiedDate As DateTime
)
Public Overridable Sub SetDictFileStream (
    dictFileStream As Stream,
    id As String,
    modifiedDate As DateTime
)
public:
virtual void SetDictFileStream(
    Stream^ dictFileStream,
    String^ id,
    DateTime modifiedDate
)
public:
virtual void SetDictFileStream(
    Stream^ dictFileStream,
    String^ id,
    DateTime modifiedDate
)
abstract SetDictFileStream :
        dictFileStream : Stream *
        id : string *
        modifiedDate : DateTime -> unit
override SetDictFileStream :
        dictFileStream : Stream *
        id : string *
        modifiedDate : DateTime -> unit
abstract SetDictFileStream :
        dictFileStream : Stream *
        id : string *
        modifiedDate : DateTime -> unit
override SetDictFileStream :
        dictFileStream : Stream *
        id : string *
        modifiedDate : DateTime -> unit
Parameters
dictFileStream (Stream)
The stream containing the dictionary
id (String)
Any generated identity string which the spell checker can use to cache and identify this dictionary.
modifiedDate (DateTime)
The DateTime when this dictionary was modified, use Now to update the cache.
Remarks
Note this method must be set before Check is called, and the stream position must be at beginning of Dict file. The stream is NOT closed by this method.


SetIgnoreCapitalizedWords Method (ignore)

SetIgnoreCapitalizedWords Method (ignore)
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► SetIgnoreCapitalizedWords(Boolean)
Keyoti RapidSpell WPF
Sets whether to ignore capitalized words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void SetIgnoreCapitalizedWords(
    bool ignore
)
public virtual void SetIgnoreCapitalizedWords(
    bool ignore
)
Public Overridable Sub SetIgnoreCapitalizedWords (
    ignore As Boolean
)
Public Overridable Sub SetIgnoreCapitalizedWords (
    ignore As Boolean
)
public:
virtual void SetIgnoreCapitalizedWords(
    bool ignore
)
public:
virtual void SetIgnoreCapitalizedWords(
    bool ignore
)
abstract SetIgnoreCapitalizedWords :
        ignore : bool -> unit
override SetIgnoreCapitalizedWords :
        ignore : bool -> unit
abstract SetIgnoreCapitalizedWords :
        ignore : bool -> unit
override SetIgnoreCapitalizedWords :
        ignore : bool -> unit
Parameters
ignore (Boolean)


SetIncludeUserDictionaryInSuggestions Method (includeUserDictionaryInSuggestions)

SetIncludeUserDictionaryInSuggestions Method (includeUserDictionaryInSuggestions)
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► SetIncludeUserDictionaryInSuggestions(Boolean)
Keyoti RapidSpell WPF
Sets whether to include the user dictionary in suggestions taken from this engine.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void SetIncludeUserDictionaryInSuggestions(
    bool includeUserDictionaryInSuggestions
)
public virtual void SetIncludeUserDictionaryInSuggestions(
    bool includeUserDictionaryInSuggestions
)
Public Overridable Sub SetIncludeUserDictionaryInSuggestions (
    includeUserDictionaryInSuggestions As Boolean
)
Public Overridable Sub SetIncludeUserDictionaryInSuggestions (
    includeUserDictionaryInSuggestions As Boolean
)
public:
virtual void SetIncludeUserDictionaryInSuggestions(
    bool includeUserDictionaryInSuggestions
)
public:
virtual void SetIncludeUserDictionaryInSuggestions(
    bool includeUserDictionaryInSuggestions
)
abstract SetIncludeUserDictionaryInSuggestions :
        includeUserDictionaryInSuggestions : bool -> unit
override SetIncludeUserDictionaryInSuggestions :
        includeUserDictionaryInSuggestions : bool -> unit
abstract SetIncludeUserDictionaryInSuggestions :
        includeUserDictionaryInSuggestions : bool -> unit
override SetIncludeUserDictionaryInSuggestions :
        includeUserDictionaryInSuggestions : bool -> unit
Parameters
includeUserDictionaryInSuggestions (Boolean)


SetOptionalContext Method (beforeToCheckSnippet, afterToCheckSnippet)

SetOptionalContext Method (beforeToCheckSnippet, afterToCheckSnippet)
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► SetOptionalContext(String, String)
Keyoti RapidSpell WPF
Provides the engine with any helpful text around the text snippet which will be passed to the Check method. Implementation is not required.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void SetOptionalContext(
    string beforeToCheckSnippet,
    string afterToCheckSnippet
)
public virtual void SetOptionalContext(
    string beforeToCheckSnippet,
    string afterToCheckSnippet
)
Public Overridable Sub SetOptionalContext (
    beforeToCheckSnippet As String,
    afterToCheckSnippet As String
)
Public Overridable Sub SetOptionalContext (
    beforeToCheckSnippet As String,
    afterToCheckSnippet As String
)
public:
virtual void SetOptionalContext(
    String^ beforeToCheckSnippet,
    String^ afterToCheckSnippet
)
public:
virtual void SetOptionalContext(
    String^ beforeToCheckSnippet,
    String^ afterToCheckSnippet
)
abstract SetOptionalContext :
        beforeToCheckSnippet : string *
        afterToCheckSnippet : string -> unit
override SetOptionalContext :
        beforeToCheckSnippet : string *
        afterToCheckSnippet : string -> unit
abstract SetOptionalContext :
        beforeToCheckSnippet : string *
        afterToCheckSnippet : string -> unit
override SetOptionalContext :
        beforeToCheckSnippet : string *
        afterToCheckSnippet : string -> unit
Parameters
beforeToCheckSnippet (String)
Any text before the to check snippet
afterToCheckSnippet (String)
Any text after the snippet
Remarks
Eg. if the document contains "This is an an example piece." and Check will be called on "an example piece", then the fact that 'an' is duplicated will not be detected. Therefore, by passing "This is an " to beforeToCheckSnippet the checker will be able to detect that an is duplicated.


SetPosition Method (pos)

SetPosition Method (pos)
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► SetPosition(Int32)
Keyoti RapidSpell WPF
Sets the pointer position for the NextBadWord iterator.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void SetPosition(
    int pos
)
public virtual void SetPosition(
    int pos
)
Public Overridable Sub SetPosition (
    pos As Integer
)
Public Overridable Sub SetPosition (
    pos As Integer
)
public:
virtual void SetPosition(
    int pos
)
public:
virtual void SetPosition(
    int pos
)
abstract SetPosition :
        pos : int -> unit
override SetPosition :
        pos : int -> unit
abstract SetPosition :
        pos : int -> unit
override SetPosition :
        pos : int -> unit
Parameters
pos (Int32)
Remarks
Further calls to NextBadWord will look for the next bad word from position pos. If position > the text length it is set to the text length. If position < 0, it is set to zero.


SetSeparateHyphenWords Method (separate)

SetSeparateHyphenWords Method (separate)
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► SetSeparateHyphenWords(Boolean)
Keyoti RapidSpell WPF
Sets whether to separate words with hyphens in them into separate words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void SetSeparateHyphenWords(
    bool separate
)
public virtual void SetSeparateHyphenWords(
    bool separate
)
Public Overridable Sub SetSeparateHyphenWords (
    separate As Boolean
)
Public Overridable Sub SetSeparateHyphenWords (
    separate As Boolean
)
public:
virtual void SetSeparateHyphenWords(
    bool separate
)
public:
virtual void SetSeparateHyphenWords(
    bool separate
)
abstract SetSeparateHyphenWords :
        separate : bool -> unit
override SetSeparateHyphenWords :
        separate : bool -> unit
abstract SetSeparateHyphenWords :
        separate : bool -> unit
override SetSeparateHyphenWords :
        separate : bool -> unit
Parameters
separate (Boolean)


SetSuggestionsMethod Method (method)

SetSuggestionsMethod Method (method)
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► SetSuggestionsMethod(Int32)
Keyoti RapidSpell WPF
Sets the suggestions method, where method is an integer identifier.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void SetSuggestionsMethod(
    int method
)
public virtual void SetSuggestionsMethod(
    int method
)
Public Overridable Sub SetSuggestionsMethod (
    method As Integer
)
Public Overridable Sub SetSuggestionsMethod (
    method As Integer
)
public:
virtual void SetSuggestionsMethod(
    int method
)
public:
virtual void SetSuggestionsMethod(
    int method
)
abstract SetSuggestionsMethod :
        method : int -> unit
override SetSuggestionsMethod :
        method : int -> unit
abstract SetSuggestionsMethod :
        method : int -> unit
override SetSuggestionsMethod :
        method : int -> unit
Parameters
method (Int32)


SetUserDictionary Method

SetUserDictionary Method
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► SetUserDictionary()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | SetUserDictionary(UserDictionary) | Sets the UserDictionary object to be used as a user dictionary source.
 | SetUserDictionary(String) | Sets the UserDictionary file path to be used as a user dictionary source.


SetUserDictionary Method (userDictionary)

SetUserDictionary Method (userDictionary)
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► SetUserDictionary(UserDictionary)
Keyoti RapidSpell WPF
Sets the UserDictionary object to be used as a user dictionary source.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void SetUserDictionary(
    UserDictionary userDictionary
)
public virtual void SetUserDictionary(
    UserDictionary userDictionary
)
Public Overridable Sub SetUserDictionary (
    userDictionary As UserDictionary
)
Public Overridable Sub SetUserDictionary (
    userDictionary As UserDictionary
)
public:
virtual void SetUserDictionary(
    UserDictionary^ userDictionary
)
public:
virtual void SetUserDictionary(
    UserDictionary^ userDictionary
)
abstract SetUserDictionary :
        userDictionary : UserDictionary -> unit
override SetUserDictionary :
        userDictionary : UserDictionary -> unit
abstract SetUserDictionary :
        userDictionary : UserDictionary -> unit
override SetUserDictionary :
        userDictionary : UserDictionary -> unit
Parameters
userDictionary (UserDictionary)


SetUserDictionary Method (userDictionary)

SetUserDictionary Method (userDictionary)
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► SetUserDictionary(String)
Keyoti RapidSpell WPF
Sets the UserDictionary file path to be used as a user dictionary source.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void SetUserDictionary(
    string userDictionary
)
public virtual void SetUserDictionary(
    string userDictionary
)
Public Overridable Sub SetUserDictionary (
    userDictionary As String
)
Public Overridable Sub SetUserDictionary (
    userDictionary As String
)
public:
virtual void SetUserDictionary(
    String^ userDictionary
)
public:
virtual void SetUserDictionary(
    String^ userDictionary
)
abstract SetUserDictionary :
        userDictionary : string -> unit
override SetUserDictionary :
        userDictionary : string -> unit
abstract SetUserDictionary :
        userDictionary : string -> unit
override SetUserDictionary :
        userDictionary : string -> unit
Parameters
userDictionary (String)


SuggestSplitWords Property

SuggestSplitWords Property
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► SuggestSplitWords
Keyoti RapidSpell WPF
Whether to look for connected words in suggestions.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool SuggestSplitWords { get; set; }
public virtual bool SuggestSplitWords { get; set; }
Public Overridable Property SuggestSplitWords As Boolean
    Get
    Set
Public Overridable Property SuggestSplitWords As Boolean
    Get
    Set
public:
virtual property bool SuggestSplitWords {
    bool get ();
    void set (bool value);
}
public:
virtual property bool SuggestSplitWords {
    bool get ();
    void set (bool value);
}
abstract SuggestSplitWords : bool with get, set
override SuggestSplitWords : bool with get, set
abstract SuggestSplitWords : bool with get, set
override SuggestSplitWords : bool with get, set
Property Value
Boolean
Remarks
if this=true then suggestions may include joined words.

Eg; suggestions for "myhouse" will include "my house"


TextBoundary Property

TextBoundary Property
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► TextBoundary
Keyoti RapidSpell WPF
The AdvancedTextBoundary class to use to parse words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public AdvancedTextBoundary TextBoundary { get; set; }
public AdvancedTextBoundary TextBoundary { get; set; }
Public Property TextBoundary As AdvancedTextBoundary
    Get
    Set
Public Property TextBoundary As AdvancedTextBoundary
    Get
    Set
public:
virtual property AdvancedTextBoundary^ TextBoundary {
    AdvancedTextBoundary^ get () sealed;
    void set (AdvancedTextBoundary^ value) sealed;
}
public:
virtual property AdvancedTextBoundary^ TextBoundary {
    AdvancedTextBoundary^ get () sealed;
    void set (AdvancedTextBoundary^ value) sealed;
}
abstract TextBoundary : AdvancedTextBoundary with get, set
override TextBoundary : AdvancedTextBoundary with get, set
abstract TextBoundary : AdvancedTextBoundary with get, set
override TextBoundary : AdvancedTextBoundary with get, set
Property Value
AdvancedTextBoundary


UnloadMainDictionary Method

UnloadMainDictionary Method
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► UnloadMainDictionary()()()()
Keyoti RapidSpell WPF
Empties the main dictionary store.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void UnloadMainDictionary()
public void UnloadMainDictionary()
Public Sub UnloadMainDictionary
Public Sub UnloadMainDictionary
public:
void UnloadMainDictionary()
public:
void UnloadMainDictionary()
member UnloadMainDictionary : unit -> unit

member UnloadMainDictionary : unit -> unit


userDictionary Property

userDictionary Property
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► userDictionary
Keyoti RapidSpell WPF
The user dictionary, this should be null (C#) or nothing (VB.NET) if no user dictionary is being used.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual UserDictionary userDictionary { get; }
public virtual UserDictionary userDictionary { get; }
Public Overridable ReadOnly Property userDictionary As UserDictionary
    Get
Public Overridable ReadOnly Property userDictionary As UserDictionary
    Get
public:
virtual property UserDictionary^ userDictionary {
    UserDictionary^ get ();
}
public:
virtual property UserDictionary^ userDictionary {
    UserDictionary^ get ();
}
abstract userDictionary : UserDictionary with get
override userDictionary : UserDictionary with get
abstract userDictionary : UserDictionary with get
override userDictionary : UserDictionary with get
Return Value
UserDictionary
This implementation always returns null.


V2Parser Property

V2Parser Property
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► V2Parser
Keyoti RapidSpell WPF
Whether to use parser version 2
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool V2Parser { get; set; }
public virtual bool V2Parser { get; set; }
Public Overridable Property V2Parser As Boolean
    Get
    Set
Public Overridable Property V2Parser As Boolean
    Get
    Set
public:
virtual property bool V2Parser {
    bool get ();
    void set (bool value);
}
public:
virtual property bool V2Parser {
    bool get ();
    void set (bool value);
}
abstract V2Parser : bool with get, set
override V2Parser : bool with get, set
abstract V2Parser : bool with get, set
override V2Parser : bool with get, set
Property Value
Boolean


WarnDuplicates Property

WarnDuplicates Property
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► WarnDuplicates
Keyoti RapidSpell WPF
Whether to treat duplicate words as errors (eg. "this is is an error").
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool WarnDuplicates { get; set; }
public virtual bool WarnDuplicates { get; set; }
Public Overridable Property WarnDuplicates As Boolean
    Get
    Set
Public Overridable Property WarnDuplicates As Boolean
    Get
    Set
public:
virtual property bool WarnDuplicates {
    bool get ();
    void set (bool value);
}
public:
virtual property bool WarnDuplicates {
    bool get ();
    void set (bool value);
}
abstract WarnDuplicates : bool with get, set
override WarnDuplicates : bool with get, set
abstract WarnDuplicates : bool with get, set
override WarnDuplicates : bool with get, set
Property Value
Boolean


WordAdded Event

WordAdded Event
API ► Keyoti.RapidSpell.Wpf ► CheckerEngineAdapter ► WordAdded
Keyoti RapidSpell WPF
Fires when a word is added
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event WordAddedEventHandler WordAdded
public event WordAddedEventHandler WordAdded
Public Event WordAdded As WordAddedEventHandler
Public Event WordAdded As WordAddedEventHandler
public:
 event WordAddedEventHandler^ WordAdded {
    void add (WordAddedEventHandler^ value);
    void remove (WordAddedEventHandler^ value);
}
public:
 event WordAddedEventHandler^ WordAdded {
    void add (WordAddedEventHandler^ value);
    void remove (WordAddedEventHandler^ value);
}
member WordAdded : IEvent<WordAddedEventHandler,
    WordAddedEventArgs>

member WordAdded : IEvent<WordAddedEventHandler,
    WordAddedEventArgs>
Value
WordAddedEventHandler


ComClientInteropSupport Class

ComClientInteropSupport Class
API ► Keyoti.RapidSpell.Wpf ► ComClientInteropSupport
Keyoti RapidSpell WPF
This class supports users who access RapidSpell controls from COM code.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class ComClientInteropSupport
public class ComClientInteropSupport
Public Class ComClientInteropSupport
Public Class ComClientInteropSupport
public ref class ComClientInteropSupport
public ref class ComClientInteropSupport
type ComClientInteropSupport =  class end
type ComClientInteropSupport =  class end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ComClientInteropSupport()()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | Key | The COM support key (email support@keyoti.com for a key).
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Remarks
RapidSpell .NET, although completely written in .NET, can be used from COM, as per MS documented procedure. Please note that according to MS, not all containers are 'supported' http://support.microsoft.com/default.aspx?scid=KB;EN-US;311334
Inheritance Hierarchy
Object
ComClientInteropSupport


ComClientInteropSupport Constructor

ComClientInteropSupport Constructor
API ► Keyoti.RapidSpell.Wpf ► ComClientInteropSupport ► ComClientInteropSupport()()()()
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ComClientInteropSupport()
public ComClientInteropSupport()
Public Sub New
Public Sub New
public:
ComClientInteropSupport()
public:
ComClientInteropSupport()
new : unit -> ComClientInteropSupport
new : unit -> ComClientInteropSupport


Key Property

Key Property
API ► Keyoti.RapidSpell.Wpf ► ComClientInteropSupport ► Key
Keyoti RapidSpell WPF
The COM support key (email support@keyoti.com for a key).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string Key { set; }
public string Key { set; }
Public WriteOnly Property Key As String
    Set
Public WriteOnly Property Key As String
    Set
public:
property String^ Key {
    void set (String^ value);
}
public:
property String^ Key {
    void set (String^ value);
}
member Key : string with set

member Key : string with set
Property Value
String


CutCopyPasteContextMenuMaker Class

CutCopyPasteContextMenuMaker Class
API ► Keyoti.RapidSpell.Wpf ► CutCopyPasteContextMenuMaker
Keyoti RapidSpell WPF
Creates a Cut/Copy/Paste ContextMenu
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class CutCopyPasteContextMenuMaker
public class CutCopyPasteContextMenuMaker
Public Class CutCopyPasteContextMenuMaker
Public Class CutCopyPasteContextMenuMaker
public ref class CutCopyPasteContextMenuMaker
public ref class CutCopyPasteContextMenuMaker
type CutCopyPasteContextMenuMaker =  class end
type CutCopyPasteContextMenuMaker =  class end
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CutCopyPasteContextMenuMaker(TextBoxBase, Boolean, LanguageType) | New
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMenu()()()() | The context menu
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
CutCopyPasteContextMenuMaker


CutCopyPasteContextMenuMaker Constructor (textBox, showUndo, guiLanguage)

CutCopyPasteContextMenuMaker Constructor (textBox, showUndo, guiLanguage)
API ► Keyoti.RapidSpell.Wpf ► CutCopyPasteContextMenuMaker ► CutCopyPasteContextMenuMaker(TextBoxBase, Boolean, LanguageType)
Keyoti RapidSpell WPF
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public CutCopyPasteContextMenuMaker(
    TextBoxBase textBox,
    bool showUndo,
    LanguageType guiLanguage
)
public CutCopyPasteContextMenuMaker(
    TextBoxBase textBox,
    bool showUndo,
    LanguageType guiLanguage
)
Public Sub New (
    textBox As TextBoxBase,
    showUndo As Boolean,
    guiLanguage As LanguageType
)
Public Sub New (
    textBox As TextBoxBase,
    showUndo As Boolean,
    guiLanguage As LanguageType
)
public:
CutCopyPasteContextMenuMaker(
    TextBoxBase^ textBox,
    bool showUndo,
    LanguageType guiLanguage
)
public:
CutCopyPasteContextMenuMaker(
    TextBoxBase^ textBox,
    bool showUndo,
    LanguageType guiLanguage
)
new :
        textBox : TextBoxBase *
        showUndo : bool *
        guiLanguage : LanguageType -> CutCopyPasteContextMenuMaker
new :
        textBox : TextBoxBase *
        showUndo : bool *
        guiLanguage : LanguageType -> CutCopyPasteContextMenuMaker
Parameters
textBox (TextBoxBase)
showUndo (Boolean)
guiLanguage (LanguageType)


GetMenu Method

GetMenu Method
API ► Keyoti.RapidSpell.Wpf ► CutCopyPasteContextMenuMaker ► GetMenu()()()()
Keyoti RapidSpell WPF
The context menu
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ContextMenu GetMenu()
public ContextMenu GetMenu()
Public Function GetMenu As ContextMenu
Public Function GetMenu As ContextMenu
public:
ContextMenu^ GetMenu()
public:
ContextMenu^ GetMenu()
member GetMenu : unit -> ContextMenu

member GetMenu : unit -> ContextMenu
Return Value
ContextMenu


DesignableComponent Class

DesignableComponent Class
API ► Keyoti.RapidSpell.Wpf ► DesignableComponent
Keyoti RapidSpell WPF
Base support for non-visual components.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public abstract class DesignableComponent : FrameworkElement
public abstract class DesignableComponent : FrameworkElement
Public MustInherit Class DesignableComponent
    Inherits FrameworkElement
Public MustInherit Class DesignableComponent
    Inherits FrameworkElement
public ref class DesignableComponent abstract : public FrameworkElement
public ref class DesignableComponent abstract : public FrameworkElement
[<AbstractClassAttribute>]
type DesignableComponent =
    class
        inherit FrameworkElement
    end
[<AbstractClassAttribute>]
type DesignableComponent =
    class
        inherit FrameworkElement
    end
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DesignableComponent(String, Double, Double) | New
 | ActualHeight | (Inherited from FrameworkElement.)
 | ActualWidth | (Inherited from FrameworkElement.)
 | AddHandler(RoutedEvent, Delegate) | (Inherited from UIElement.)
 | AddHandler(RoutedEvent, Delegate, Boolean) | (Inherited from UIElement.)
 | AddLogicalChild(Object) | (Inherited from FrameworkElement.)
 | AddToEventRoute(EventRoute, RoutedEventArgs) | (Inherited from UIElement.)
 | AddVisualChild(Visual) | (Inherited from Visual.)
 | AllowDrop | (Inherited from UIElement.)
 | ApplyAnimationClock(DependencyProperty, AnimationClock) | (Inherited from UIElement.)
 | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | (Inherited from UIElement.)
 | ApplyTemplate()()()() | (Inherited from FrameworkElement.)
 | AreAnyTouchesCaptured | (Inherited from UIElement.)
 | AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
 | AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
 | AreAnyTouchesOver | (Inherited from UIElement.)
 | Arrange(Rect) | (Inherited from UIElement.)
 | ArrangeCore(Rect) | (Inherited from FrameworkElement.)
 | ArrangeOverride(Size) | (Inherited from FrameworkElement.)
 | BeginAnimation(DependencyProperty, AnimationTimeline) | (Inherited from UIElement.)
 | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | (Inherited from UIElement.)
 | BeginInit()()()() | (Inherited from FrameworkElement.)
 | BeginStoryboard(Storyboard) | (Inherited from FrameworkElement.)
 | BeginStoryboard(Storyboard, HandoffBehavior) | (Inherited from FrameworkElement.)
 | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | (Inherited from FrameworkElement.)
 | BindingGroup | (Inherited from FrameworkElement.)
 | BitmapEffect | Obsolete. (Inherited from UIElement.)
 | BitmapEffectInput | Obsolete. (Inherited from UIElement.)
 | BringIntoView()()()() | (Inherited from FrameworkElement.)
 | BringIntoView(Rect) | (Inherited from FrameworkElement.)
 | CacheMode | (Inherited from UIElement.)
 | CaptureMouse()()()() | (Inherited from UIElement.)
 | CaptureStylus()()()() | (Inherited from UIElement.)
 | CaptureTouch(TouchDevice) | (Inherited from UIElement.)
 | CheckAccess()()()() | (Inherited from DispatcherObject.)
 | ClearValue(DependencyProperty) | (Inherited from DependencyObject.)
 | ClearValue(DependencyPropertyKey) | (Inherited from DependencyObject.)
 | Clip | (Inherited from UIElement.)
 | ClipToBounds | (Inherited from UIElement.)
 | CoerceValue(DependencyProperty) | (Inherited from DependencyObject.)
 | CommandBindings | (Inherited from UIElement.)
 | ContextMenu | (Inherited from FrameworkElement.)
 | ContextMenuClosing | (Inherited from FrameworkElement.)
 | ContextMenuOpening | (Inherited from FrameworkElement.)
 | Cursor | (Inherited from FrameworkElement.)
 | DataContext | (Inherited from FrameworkElement.)
 | DataContextChanged | (Inherited from FrameworkElement.)
 | DefaultStyleKey | (Inherited from FrameworkElement.)
 | DependencyObjectType | (Inherited from DependencyObject.)
 | DesignMode | Whether control is in design mode
 | DesiredSize | (Inherited from UIElement.)
 | Dispatcher | (Inherited from DispatcherObject.)
 | DragEnter | (Inherited from UIElement.)
 | DragLeave | (Inherited from UIElement.)
 | DragOver | (Inherited from UIElement.)
 | Drop | (Inherited from UIElement.)
 | Effect | (Inherited from UIElement.)
 | EndInit()()()() | (Inherited from FrameworkElement.)
 | Equals(Object) | (Inherited from DependencyObject.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FindCommonVisualAncestor(DependencyObject) | (Inherited from Visual.)
 | FindName(String) | (Inherited from FrameworkElement.)
 | FindResource(Object) | (Inherited from FrameworkElement.)
 | FlowDirection | (Inherited from FrameworkElement.)
 | Focus()()()() | (Inherited from UIElement.)
 | Focusable | (Inherited from UIElement.)
 | FocusableChanged | (Inherited from UIElement.)
 | FocusVisualStyle | (Inherited from FrameworkElement.)
 | ForceCursor | (Inherited from FrameworkElement.)
 | GetAnimationBaseValue(DependencyProperty) | (Inherited from UIElement.)
 | GetBindingExpression(DependencyProperty) | (Inherited from FrameworkElement.)
 | GetHashCode()()()() | (Inherited from DependencyObject.)
 | GetLayoutClip(Size) | (Inherited from FrameworkElement.)
 | GetLocalValueEnumerator()()()() | (Inherited from DependencyObject.)
 | GetTemplateChild(String) | (Inherited from FrameworkElement.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GetUIParentCore()()()() | (Inherited from FrameworkElement.)
 | GetValue(DependencyProperty) | (Inherited from DependencyObject.)
 | GetVisualChild(Int32) | (Inherited from FrameworkElement.)
 | GiveFeedback | (Inherited from UIElement.)
 | GotFocus | (Inherited from UIElement.)
 | GotKeyboardFocus | (Inherited from UIElement.)
 | GotMouseCapture | (Inherited from UIElement.)
 | GotStylusCapture | (Inherited from UIElement.)
 | GotTouchCapture | (Inherited from UIElement.)
 | HasAnimatedProperties | (Inherited from UIElement.)
 | HasEffectiveKeyboardFocus | (Inherited from UIElement.)
 | Height | (Inherited from FrameworkElement.)
 | HitTestCore(PointHitTestParameters) | (Inherited from UIElement.)
 | HitTestCore(GeometryHitTestParameters) | (Inherited from UIElement.)
 | HorizontalAlignment | (Inherited from FrameworkElement.)
 | InheritanceBehavior | (Inherited from FrameworkElement.)
 | Initialized | (Inherited from FrameworkElement.)
 | InputBindings | (Inherited from UIElement.)
 | InputHitTest(Point) | (Inherited from UIElement.)
 | InputScope | (Inherited from FrameworkElement.)
 | InvalidateArrange()()()() | (Inherited from UIElement.)
 | InvalidateMeasure()()()() | (Inherited from UIElement.)
 | InvalidateProperty(DependencyProperty) | (Inherited from DependencyObject.)
 | InvalidateVisual()()()() | (Inherited from UIElement.)
 | IsAncestorOf(DependencyObject) | (Inherited from Visual.)
 | IsArrangeValid | (Inherited from UIElement.)
 | IsDescendantOf(DependencyObject) | (Inherited from Visual.)
 | IsEnabled | (Inherited from UIElement.)
 | IsEnabledChanged | (Inherited from UIElement.)
 | IsEnabledCore | (Inherited from UIElement.)
 | IsFocused | (Inherited from UIElement.)
 | IsHitTestVisible | (Inherited from UIElement.)
 | IsHitTestVisibleChanged | (Inherited from UIElement.)
 | IsInitialized | (Inherited from FrameworkElement.)
 | IsInputMethodEnabled | (Inherited from UIElement.)
 | IsKeyboardFocused | (Inherited from UIElement.)
 | IsKeyboardFocusedChanged | (Inherited from UIElement.)
 | IsKeyboardFocusWithin | (Inherited from UIElement.)
 | IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
 | IsLoaded | (Inherited from FrameworkElement.)
 | IsManipulationEnabled | (Inherited from UIElement.)
 | IsMeasureValid | (Inherited from UIElement.)
 | IsMouseCaptured | (Inherited from UIElement.)
 | IsMouseCapturedChanged | (Inherited from UIElement.)
 | IsMouseCaptureWithin | (Inherited from UIElement.)
 | IsMouseCaptureWithinChanged | (Inherited from UIElement.)
 | IsMouseDirectlyOver | (Inherited from UIElement.)
 | IsMouseDirectlyOverChanged | (Inherited from UIElement.)
 | IsMouseOver | (Inherited from UIElement.)
 | IsSealed | (Inherited from DependencyObject.)
 | IsStylusCaptured | (Inherited from UIElement.)
 | IsStylusCapturedChanged | (Inherited from UIElement.)
 | IsStylusCaptureWithin | (Inherited from UIElement.)
 | IsStylusCaptureWithinChanged | (Inherited from UIElement.)
 | IsStylusDirectlyOver | (Inherited from UIElement.)
 | IsStylusDirectlyOverChanged | (Inherited from UIElement.)
 | IsStylusOver | (Inherited from UIElement.)
 | IsVisible | (Inherited from UIElement.)
 | IsVisibleChanged | (Inherited from UIElement.)
 | KeyDown | (Inherited from UIElement.)
 | KeyUp | (Inherited from UIElement.)
 | Language | (Inherited from FrameworkElement.)
 | LayoutTransform | (Inherited from FrameworkElement.)
 | LayoutUpdated | (Inherited from UIElement.)
 | Loaded | (Inherited from FrameworkElement.)
 | LogicalChildren | (Inherited from FrameworkElement.)
 | LostFocus | (Inherited from UIElement.)
 | LostKeyboardFocus | (Inherited from UIElement.)
 | LostMouseCapture | (Inherited from UIElement.)
 | LostStylusCapture | (Inherited from UIElement.)
 | LostTouchCapture | (Inherited from UIElement.)
 | ManipulationBoundaryFeedback | (Inherited from UIElement.)
 | ManipulationCompleted | (Inherited from UIElement.)
 | ManipulationDelta | (Inherited from UIElement.)
 | ManipulationInertiaStarting | (Inherited from UIElement.)
 | ManipulationStarted | (Inherited from UIElement.)
 | ManipulationStarting | (Inherited from UIElement.)
 | Margin | (Inherited from FrameworkElement.)
 | MaxHeight | (Inherited from FrameworkElement.)
 | MaxWidth | (Inherited from FrameworkElement.)
 | Measure(Size) | (Inherited from UIElement.)
 | MeasureCore(Size) | (Inherited from FrameworkElement.)
 | MeasureOverride(Size) | (Inherited from FrameworkElement.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinHeight | (Inherited from FrameworkElement.)
 | MinWidth | (Inherited from FrameworkElement.)
 | MouseDown | (Inherited from UIElement.)
 | MouseEnter | (Inherited from UIElement.)
 | MouseLeave | (Inherited from UIElement.)
 | MouseLeftButtonDown | (Inherited from UIElement.)
 | MouseLeftButtonUp | (Inherited from UIElement.)
 | MouseMove | (Inherited from UIElement.)
 | MouseRightButtonDown | (Inherited from UIElement.)
 | MouseRightButtonUp | (Inherited from UIElement.)
 | MouseUp | (Inherited from UIElement.)
 | MouseWheel | (Inherited from UIElement.)
 | MoveFocus(TraversalRequest) | (Inherited from FrameworkElement.)
 | Name | (Inherited from FrameworkElement.)
 | OnAccessKey(AccessKeyEventArgs) | (Inherited from UIElement.)
 | OnApplyTemplate()()()() | (Inherited from FrameworkElement.)
 | OnChildDesiredSizeChanged(UIElement) | (Inherited from UIElement.)
 | OnContextMenuClosing(ContextMenuEventArgs) | (Inherited from FrameworkElement.)
 | OnContextMenuOpening(ContextMenuEventArgs) | (Inherited from FrameworkElement.)
 | OnCreateAutomationPeer()()()() | (Inherited from UIElement.)
 | OnDpiChanged(DpiScale, DpiScale) | (Inherited from Visual.)
 | OnDragEnter(DragEventArgs) | (Inherited from UIElement.)
 | OnDragLeave(DragEventArgs) | (Inherited from UIElement.)
 | OnDragOver(DragEventArgs) | (Inherited from UIElement.)
 | OnDrop(DragEventArgs) | (Inherited from UIElement.)
 | OnGiveFeedback(GiveFeedbackEventArgs) | (Inherited from UIElement.)
 | OnGotFocus(RoutedEventArgs) | (Inherited from FrameworkElement.)
 | OnGotKeyboardFocus(KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
 | OnGotMouseCapture(MouseEventArgs) | (Inherited from UIElement.)
 | OnGotStylusCapture(StylusEventArgs) | (Inherited from UIElement.)
 | OnGotTouchCapture(TouchEventArgs) | (Inherited from UIElement.)
 | OnInitialized(EventArgs) | (Inherited from FrameworkElement.)
 | OnIsKeyboardFocusedChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsKeyboardFocusWithinChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsMouseCapturedChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsMouseCaptureWithinChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsMouseDirectlyOverChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsStylusCapturedChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsStylusCaptureWithinChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsStylusDirectlyOverChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnKeyDown(KeyEventArgs) | (Inherited from UIElement.)
 | OnKeyUp(KeyEventArgs) | (Inherited from UIElement.)
 | OnLostFocus(RoutedEventArgs) | (Inherited from UIElement.)
 | OnLostKeyboardFocus(KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
 | OnLostMouseCapture(MouseEventArgs) | (Inherited from UIElement.)
 | OnLostStylusCapture(StylusEventArgs) | (Inherited from UIElement.)
 | OnLostTouchCapture(TouchEventArgs) | (Inherited from UIElement.)
 | OnManipulationBoundaryFeedback(ManipulationBoundaryFeedbackEventArgs) | (Inherited from UIElement.)
 | OnManipulationCompleted(ManipulationCompletedEventArgs) | (Inherited from UIElement.)
 | OnManipulationDelta(ManipulationDeltaEventArgs) | (Inherited from UIElement.)
 | OnManipulationInertiaStarting(ManipulationInertiaStartingEventArgs) | (Inherited from UIElement.)
 | OnManipulationStarted(ManipulationStartedEventArgs) | (Inherited from UIElement.)
 | OnManipulationStarting(ManipulationStartingEventArgs) | (Inherited from UIElement.)
 | OnMouseDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseEnter(MouseEventArgs) | (Inherited from UIElement.)
 | OnMouseLeave(MouseEventArgs) | (Inherited from UIElement.)
 | OnMouseLeftButtonDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseLeftButtonUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseMove(MouseEventArgs) | (Inherited from UIElement.)
 | OnMouseRightButtonDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseRightButtonUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseWheel(MouseWheelEventArgs) | (Inherited from UIElement.)
 | OnPreviewDragEnter(DragEventArgs) | (Inherited from UIElement.)
 | OnPreviewDragLeave(DragEventArgs) | (Inherited from UIElement.)
 | OnPreviewDragOver(DragEventArgs) | (Inherited from UIElement.)
 | OnPreviewDrop(DragEventArgs) | (Inherited from UIElement.)
 | OnPreviewGiveFeedback(GiveFeedbackEventArgs) | (Inherited from UIElement.)
 | OnPreviewGotKeyboardFocus(KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
 | OnPreviewKeyDown(KeyEventArgs) | (Inherited from UIElement.)
 | OnPreviewKeyUp(KeyEventArgs) | (Inherited from UIElement.)
 | OnPreviewLostKeyboardFocus(KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseLeftButtonDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseLeftButtonUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseMove(MouseEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseRightButtonDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseRightButtonUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseWheel(MouseWheelEventArgs) | (Inherited from UIElement.)
 | OnPreviewQueryContinueDrag(QueryContinueDragEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusButtonDown(StylusButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusButtonUp(StylusButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusDown(StylusDownEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusInAirMove(StylusEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusInRange(StylusEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusMove(StylusEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusOutOfRange(StylusEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusSystemGesture(StylusSystemGestureEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusUp(StylusEventArgs) | (Inherited from UIElement.)
 | OnPreviewTextInput(TextCompositionEventArgs) | (Inherited from UIElement.)
 | OnPreviewTouchDown(TouchEventArgs) | (Inherited from UIElement.)
 | OnPreviewTouchMove(TouchEventArgs) | (Inherited from UIElement.)
 | OnPreviewTouchUp(TouchEventArgs) | (Inherited from UIElement.)
 | OnPropertyChanged(DependencyPropertyChangedEventArgs) | (Inherited from FrameworkElement.)
 | OnQueryContinueDrag(QueryContinueDragEventArgs) | (Inherited from UIElement.)
 | OnQueryCursor(QueryCursorEventArgs) | (Inherited from UIElement.)
 | OnRender(DrawingContext) | Renders the control (Overrides UIElement.OnRender(DrawingContext).)
 | OnRenderSizeChanged(SizeChangedInfo) | (Inherited from FrameworkElement.)
 | OnStyleChanged(Style, Style) | (Inherited from FrameworkElement.)
 | OnStylusButtonDown(StylusButtonEventArgs) | (Inherited from UIElement.)
 | OnStylusButtonUp(StylusButtonEventArgs) | (Inherited from UIElement.)
 | OnStylusDown(StylusDownEventArgs) | (Inherited from UIElement.)
 | OnStylusEnter(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusInAirMove(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusInRange(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusLeave(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusMove(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusOutOfRange(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusSystemGesture(StylusSystemGestureEventArgs) | (Inherited from UIElement.)
 | OnStylusUp(StylusEventArgs) | (Inherited from UIElement.)
 | OnTextInput(TextCompositionEventArgs) | (Inherited from UIElement.)
 | OnToolTipClosing(ToolTipEventArgs) | (Inherited from FrameworkElement.)
 | OnToolTipOpening(ToolTipEventArgs) | (Inherited from FrameworkElement.)
 | OnTouchDown(TouchEventArgs) | (Inherited from UIElement.)
 | OnTouchEnter(TouchEventArgs) | (Inherited from UIElement.)
 | OnTouchLeave(TouchEventArgs) | (Inherited from UIElement.)
 | OnTouchMove(TouchEventArgs) | (Inherited from UIElement.)
 | OnTouchUp(TouchEventArgs) | (Inherited from UIElement.)
 | OnVisualChildrenChanged(DependencyObject, DependencyObject) | (Inherited from Visual.)
 | OnVisualParentChanged(DependencyObject) | (Inherited from FrameworkElement.)
 | Opacity | (Inherited from UIElement.)
 | OpacityMask | (Inherited from UIElement.)
 | OverridesDefaultStyle | (Inherited from FrameworkElement.)
 | Parent | (Inherited from FrameworkElement.)
 | ParentLayoutInvalidated(UIElement) | (Inherited from FrameworkElement.)
 | PersistId | Obsolete. (Inherited from UIElement.)
 | PointFromScreen(Point) | (Inherited from Visual.)
 | PointToScreen(Point) | (Inherited from Visual.)
 | PredictFocus(FocusNavigationDirection) | (Inherited from FrameworkElement.)
 | PreviewDragEnter | (Inherited from UIElement.)
 | PreviewDragLeave | (Inherited from UIElement.)
 | PreviewDragOver | (Inherited from UIElement.)
 | PreviewDrop | (Inherited from UIElement.)
 | PreviewGiveFeedback | (Inherited from UIElement.)
 | PreviewGotKeyboardFocus | (Inherited from UIElement.)
 | PreviewKeyDown | (Inherited from UIElement.)
 | PreviewKeyUp | (Inherited from UIElement.)
 | PreviewLostKeyboardFocus | (Inherited from UIElement.)
 | PreviewMouseDown | (Inherited from UIElement.)
 | PreviewMouseLeftButtonDown | (Inherited from UIElement.)
 | PreviewMouseLeftButtonUp | (Inherited from UIElement.)
 | PreviewMouseMove | (Inherited from UIElement.)
 | PreviewMouseRightButtonDown | (Inherited from UIElement.)
 | PreviewMouseRightButtonUp | (Inherited from UIElement.)
 | PreviewMouseUp | (Inherited from UIElement.)
 | PreviewMouseWheel | (Inherited from UIElement.)
 | PreviewQueryContinueDrag | (Inherited from UIElement.)
 | PreviewStylusButtonDown | (Inherited from UIElement.)
 | PreviewStylusButtonUp | (Inherited from UIElement.)
 | PreviewStylusDown | (Inherited from UIElement.)
 | PreviewStylusInAirMove | (Inherited from UIElement.)
 | PreviewStylusInRange | (Inherited from UIElement.)
 | PreviewStylusMove | (Inherited from UIElement.)
 | PreviewStylusOutOfRange | (Inherited from UIElement.)
 | PreviewStylusSystemGesture | (Inherited from UIElement.)
 | PreviewStylusUp | (Inherited from UIElement.)
 | PreviewTextInput | (Inherited from UIElement.)
 | PreviewTouchDown | (Inherited from UIElement.)
 | PreviewTouchMove | (Inherited from UIElement.)
 | PreviewTouchUp | (Inherited from UIElement.)
 | QueryContinueDrag | (Inherited from UIElement.)
 | QueryCursor | (Inherited from UIElement.)
 | RaiseEvent(RoutedEventArgs) | (Inherited from UIElement.)
 | ReadLocalValue(DependencyProperty) | (Inherited from DependencyObject.)
 | RegisterName(String, Object) | (Inherited from FrameworkElement.)
 | ReleaseAllTouchCaptures()()()() | (Inherited from UIElement.)
 | ReleaseMouseCapture()()()() | (Inherited from UIElement.)
 | ReleaseStylusCapture()()()() | (Inherited from UIElement.)
 | ReleaseTouchCapture(TouchDevice) | (Inherited from UIElement.)
 | RemoveHandler(RoutedEvent, Delegate) | (Inherited from UIElement.)
 | RemoveLogicalChild(Object) | (Inherited from FrameworkElement.)
 | RemoveVisualChild(Visual) | (Inherited from Visual.)
 | RenderSize | (Inherited from UIElement.)
 | RenderTransform | (Inherited from UIElement.)
 | RenderTransformOrigin | (Inherited from UIElement.)
 | RequestBringIntoView | (Inherited from FrameworkElement.)
 | Resources | (Inherited from FrameworkElement.)
 | SetBinding(DependencyProperty, BindingBase) | (Inherited from FrameworkElement.)
 | SetBinding(DependencyProperty, String) | (Inherited from FrameworkElement.)
 | SetCurrentValue(DependencyProperty, Object) | (Inherited from DependencyObject.)
 | SetResourceReference(DependencyProperty, Object) | (Inherited from FrameworkElement.)
 | SetValue(DependencyProperty, Object) | (Inherited from DependencyObject.)
 | SetValue(DependencyPropertyKey, Object) | (Inherited from DependencyObject.)
 | ShouldSerializeCommandBindings()()()() | (Inherited from UIElement.)
 | ShouldSerializeInputBindings()()()() | (Inherited from UIElement.)
 | ShouldSerializeProperty(DependencyProperty) | (Inherited from DependencyObject.)
 | ShouldSerializeResources()()()() | (Inherited from FrameworkElement.)
 | ShouldSerializeStyle()()()() | (Inherited from FrameworkElement.)
 | ShouldSerializeTriggers()()()() | (Inherited from FrameworkElement.)
 | SizeChanged | (Inherited from FrameworkElement.)
 | SnapsToDevicePixels | (Inherited from UIElement.)
 | SourceUpdated | (Inherited from FrameworkElement.)
 | Style | (Inherited from FrameworkElement.)
 | StylusButtonDown | (Inherited from UIElement.)
 | StylusButtonUp | (Inherited from UIElement.)
 | StylusDown | (Inherited from UIElement.)
 | StylusEnter | (Inherited from UIElement.)
 | StylusInAirMove | (Inherited from UIElement.)
 | StylusInRange | (Inherited from UIElement.)
 | StylusLeave | (Inherited from UIElement.)
 | StylusMove | (Inherited from UIElement.)
 | StylusOutOfRange | (Inherited from UIElement.)
 | StylusPlugIns | (Inherited from UIElement.)
 | StylusSystemGesture | (Inherited from UIElement.)
 | StylusUp | (Inherited from UIElement.)
 | Tag | (Inherited from FrameworkElement.)
 | TargetUpdated | (Inherited from FrameworkElement.)
 | TemplatedParent | (Inherited from FrameworkElement.)
 | TextInput | (Inherited from UIElement.)
 | ToolTip | (Inherited from FrameworkElement.)
 | ToolTipClosing | (Inherited from FrameworkElement.)
 | ToolTipOpening | (Inherited from FrameworkElement.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | TouchDown | (Inherited from UIElement.)
 | TouchEnter | (Inherited from UIElement.)
 | TouchesCaptured | (Inherited from UIElement.)
 | TouchesCapturedWithin | (Inherited from UIElement.)
 | TouchesDirectlyOver | (Inherited from UIElement.)
 | TouchesOver | (Inherited from UIElement.)
 | TouchLeave | (Inherited from UIElement.)
 | TouchMove | (Inherited from UIElement.)
 | TouchUp | (Inherited from UIElement.)
 | TransformToAncestor(Visual) | (Inherited from Visual.)
 | TransformToAncestor(Visual3D) | (Inherited from Visual.)
 | TransformToDescendant(Visual) | (Inherited from Visual.)
 | TransformToVisual(Visual) | (Inherited from Visual.)
 | TranslatePoint(Point, UIElement) | (Inherited from UIElement.)
 | Triggers | (Inherited from FrameworkElement.)
 | TryFindResource(Object) | (Inherited from FrameworkElement.)
 | Uid | (Inherited from UIElement.)
 | Unloaded | (Inherited from FrameworkElement.)
 | UnregisterName(String) | (Inherited from FrameworkElement.)
 | UpdateDefaultStyle()()()() | (Inherited from FrameworkElement.)
 | UpdateLayout()()()() | (Inherited from UIElement.)
 | UseLayoutRounding | (Inherited from FrameworkElement.)
 | VerifyAccess()()()() | (Inherited from DispatcherObject.)
 | VerticalAlignment | (Inherited from FrameworkElement.)
 | Visibility | (Inherited from UIElement.)
 | VisualBitmapEffect | Obsolete. (Inherited from Visual.)
 | VisualBitmapEffectInput | Obsolete. (Inherited from Visual.)
 | VisualBitmapScalingMode | (Inherited from Visual.)
 | VisualCacheMode | (Inherited from Visual.)
 | VisualChildrenCount | (Inherited from FrameworkElement.)
 | VisualClearTypeHint | (Inherited from Visual.)
 | VisualClip | (Inherited from Visual.)
 | VisualEdgeMode | (Inherited from Visual.)
 | VisualEffect | (Inherited from Visual.)
 | VisualOffset | (Inherited from Visual.)
 | VisualOpacity | (Inherited from Visual.)
 | VisualOpacityMask | (Inherited from Visual.)
 | VisualParent | (Inherited from Visual.)
 | VisualScrollableAreaClip | (Inherited from Visual.)
 | VisualTextHintingMode | (Inherited from Visual.)
 | VisualTextRenderingMode | (Inherited from Visual.)
 | VisualTransform | (Inherited from Visual.)
 | VisualXSnappingGuidelines | (Inherited from Visual.)
 | VisualYSnappingGuidelines | (Inherited from Visual.)
 | Width | (Inherited from FrameworkElement.)
Inheritance Hierarchy
Object
 | DispatcherObject
 |  | DependencyObject
 |  |  | Visual
 |  |  |  | UIElement
 |  |  |  |  | FrameworkElement
 |  |  |  |  |  | DesignableComponent
 |  |  |  |  |  |  | RapidSpellAsYouType
 |  |  |  |  |  |  | RapidSpellAYTDialogCoupler
 |  |  |  |  |  |  | RapidSpellDialog


DesignableComponent Constructor (label, width, height)

DesignableComponent Constructor (label, width, height)
API ► Keyoti.RapidSpell.Wpf ► DesignableComponent ► DesignableComponent(String, Double, Double)
Keyoti RapidSpell WPF
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public DesignableComponent(
    string label,
    double width,
    double height
)
public DesignableComponent(
    string label,
    double width,
    double height
)
Public Sub New (
    label As String,
    width As Double,
    height As Double
)
Public Sub New (
    label As String,
    width As Double,
    height As Double
)
public:
DesignableComponent(
    String^ label,
    double width,
    double height
)
public:
DesignableComponent(
    String^ label,
    double width,
    double height
)
new :
        label : string *
        width : float *
        height : float -> DesignableComponent
new :
        label : string *
        width : float *
        height : float -> DesignableComponent
Parameters
label (String)
width (Double)
height (Double)


DesignMode Property

DesignMode Property
API ► Keyoti.RapidSpell.Wpf ► DesignableComponent ► DesignMode
Keyoti RapidSpell WPF
Whether control is in design mode
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool DesignMode { get; }
public bool DesignMode { get; }
Public ReadOnly Property DesignMode As Boolean
    Get
Public ReadOnly Property DesignMode As Boolean
    Get
public:
property bool DesignMode {
    bool get ();
}
public:
property bool DesignMode {
    bool get ();
}
member DesignMode : bool with get

member DesignMode : bool with get
Property Value
Boolean


OnRender Method (drawingContext)

OnRender Method (drawingContext)
API ► Keyoti.RapidSpell.Wpf ► DesignableComponent ► OnRender(DrawingContext)
Keyoti RapidSpell WPF
Renders the control
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override void OnRender(
    DrawingContext drawingContext
)
protected override void OnRender(
    DrawingContext drawingContext
)
Protected Overrides Sub OnRender (
    drawingContext As DrawingContext
)
Protected Overrides Sub OnRender (
    drawingContext As DrawingContext
)
protected:
virtual void OnRender(
    DrawingContext^ drawingContext
) override
protected:
virtual void OnRender(
    DrawingContext^ drawingContext
) override
abstract OnRender :
        drawingContext : DrawingContext -> unit
override OnRender :
        drawingContext : DrawingContext -> unit
abstract OnRender :
        drawingContext : DrawingContext -> unit
override OnRender :
        drawingContext : DrawingContext -> unit
Parameters
drawingContext (DrawingContext)


DialogTexts Class

DialogTexts Class
API ► Keyoti.RapidSpell.Wpf ► DialogTexts
Keyoti RapidSpell WPF
Contains all texts in RapidSpellDialog and user options.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public class DialogTexts
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public class DialogTexts
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Class DialogTexts
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Class DialogTexts
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public ref class DialogTexts
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public ref class DialogTexts
[<TypeConverterAttribute(typeof(ExpandableObjectConverter))>]
type DialogTexts =  class end
[<TypeConverterAttribute(typeof(ExpandableObjectConverter))>]
type DialogTexts =  class end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DialogTexts()()()() |
 | AddButtonText | Add button text.
 | ApplyLanguage(LanguageType, LanguageType) | Applies text settings
 | ApplyTo(IUserInterfaceFormPresenter) | Applies text settings
 | ApplyTo(IDialogViewUserDictionaryEdit) | Applies text settings
 | ApplyTo(IDialogViewUserDictionarySelect) | Applies text settings
 | ApplyTo(IDialogViewOptions) | Applies text settings
 | CancelButtonText | Cancel button text.
 | ChangeAllButtonText | Change All button text.
 | ChangeButtonText | Change button text.
 | CheckCompletePopUpText | Check complete pop up text
 | CheckCompletePopUpTitle | Check complete pop up title
 | CheckingSpellingText | Checking spelling text
 | DialogTitleText | Dialog title text
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FindingSuggestionsLabelText | Finding suggestions label text.
 | FindSuggestionsLabelText | Find suggestions label text.
 | FinishedCheckingSelectionPopUpText | Finished checking selection dialog text
 | FinishedCheckingSelectionPopUpTitle | Finished checking selection dialog title
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | IgnoreAllButtonText | Ignore All button text.
 | IgnoreButtonText | Ignore button text.
 | InDictionaryLabelText | In dictionary label text
 | LoadingDictionaryText | UI Text
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NoSuggestionsText | No suggestions found text
 | NotInDictionaryLabelText | Not in dictionary label text
 | OptionsButtonText | Options button text.
 | OptionsFormAdvancedSettingsText | UI Text
 | OptionsFormAlwaysSuggestCorrectionsText | UI Text
 | OptionsFormBasicSettingsText | UI Text
 | OptionsFormCancelText | UI Text
 | OptionsFormCheckAsYouTypeText | UI Text
 | OptionsFormIgnoreImproperCaseText | UI Text
 | OptionsFormIgnoreInternetAddressesText | UI Text
 | OptionsFormIgnoreWordsInUppercaseText | UI Text
 | OptionsFormIgnoreWordsWithNumbersText | UI Text
 | OptionsFormOKText | UI Text
 | OptionsFormRecheckTextText | UI Text
 | OptionsFormSuggestFromMainDictionaryOnlyText | UI Text
 | OptionsFormTitleText | UI Text
 | OptionsFormUserDictionaryEditText | UI Text
 | RemoveDuplicateWordText | Remove duplicate word text
 | ResetText | Used at design time to reset UI text.
 | ResumeButtonText | Resume button text
 | SuggestionsLabelText | Suggestions label text
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | UndoButtonText | Undo button text.
 | UserDictionaryFormAddText | UI Text
 | UserDictionaryFormCancelText | UI Text
 | UserDictionaryFormContentsText | UI Text
 | UserDictionaryFormDeleteText | UI Text
 | UserDictionaryFormDictionaryLabelText | UI Text
 | UserDictionaryFormOKText | UI Text
 | UserDictionaryFormTitleText | UI Text
 | UserDictionaryFormWordLabelText | UI Text
 | UserDictionarySelectFormAddFileText |
 | UserDictionarySelectFormCancelText | UI Text
 | UserDictionarySelectFormChangeDefaultText |
 | UserDictionarySelectFormDeleteText | UI Text
 | UserDictionarySelectFormDictionaryLabelText | UI Text
 | UserDictionarySelectFormEditFileText |
 | UserDictionarySelectFormGroupBoxTitleText | UI Text
 | UserDictionarySelectFormNewFileText |
 | UserDictionarySelectFormOKText | UI Text
 | UserDictionarySelectFormRemoveFileText |
 | UserDictionarySelectFormTitleText | UI Text
Inheritance Hierarchy
Object
DialogTexts


DialogTexts Constructor

DialogTexts Constructor
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► DialogTexts()()()()
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public DialogTexts()
public DialogTexts()
Public Sub New
Public Sub New
public:
DialogTexts()
public:
DialogTexts()
new : unit -> DialogTexts
new : unit -> DialogTexts


AddButtonText Property

AddButtonText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► AddButtonText
Keyoti RapidSpell WPF
Add button text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string AddButtonText { get; set; }
public string AddButtonText { get; set; }
Public Property AddButtonText As String
    Get
    Set
Public Property AddButtonText As String
    Get
    Set
public:
property String^ AddButtonText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ AddButtonText {
    String^ get ();
    void set (String^ value);
}
member AddButtonText : string with get, set

member AddButtonText : string with get, set
Property Value
String


ApplyLanguage Method (newlang, oldlang)

ApplyLanguage Method (newlang, oldlang)
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► ApplyLanguage(LanguageType, LanguageType)
Keyoti RapidSpell WPF
Applies text settings
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void ApplyLanguage(
    LanguageType newlang,
    LanguageType oldlang
)
public void ApplyLanguage(
    LanguageType newlang,
    LanguageType oldlang
)
Public Sub ApplyLanguage (
    newlang As LanguageType,
    oldlang As LanguageType
)
Public Sub ApplyLanguage (
    newlang As LanguageType,
    oldlang As LanguageType
)
public:
void ApplyLanguage(
    LanguageType newlang,
    LanguageType oldlang
)
public:
void ApplyLanguage(
    LanguageType newlang,
    LanguageType oldlang
)
member ApplyLanguage :
        newlang : LanguageType *
        oldlang : LanguageType -> unit

member ApplyLanguage :
        newlang : LanguageType *
        oldlang : LanguageType -> unit
Parameters
newlang (LanguageType)
oldlang (LanguageType)


ApplyTo Method

ApplyTo Method
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► ApplyTo()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | ApplyTo(IUserInterfaceFormPresenter) | Applies text settings
 | ApplyTo(IDialogViewUserDictionaryEdit) | Applies text settings
 | ApplyTo(IDialogViewUserDictionarySelect) | Applies text settings
 | ApplyTo(IDialogViewOptions) | Applies text settings


ApplyTo Method (o)

ApplyTo Method (o)
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► ApplyTo(IDialogViewOptions)
Keyoti RapidSpell WPF
Applies text settings
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void ApplyTo(
    IDialogViewOptions o
)
public void ApplyTo(
    IDialogViewOptions o
)
Public Sub ApplyTo (
    o As IDialogViewOptions
)
Public Sub ApplyTo (
    o As IDialogViewOptions
)
public:
void ApplyTo(
    IDialogViewOptions^ o
)
public:
void ApplyTo(
    IDialogViewOptions^ o
)
member ApplyTo :
        o : IDialogViewOptions -> unit

member ApplyTo :
        o : IDialogViewOptions -> unit
Parameters
o (IDialogViewOptions)


ApplyTo Method (o)

ApplyTo Method (o)
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► ApplyTo(IDialogViewUserDictionaryEdit)
Keyoti RapidSpell WPF
Applies text settings
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void ApplyTo(
    IDialogViewUserDictionaryEdit o
)
public void ApplyTo(
    IDialogViewUserDictionaryEdit o
)
Public Sub ApplyTo (
    o As IDialogViewUserDictionaryEdit
)
Public Sub ApplyTo (
    o As IDialogViewUserDictionaryEdit
)
public:
void ApplyTo(
    IDialogViewUserDictionaryEdit^ o
)
public:
void ApplyTo(
    IDialogViewUserDictionaryEdit^ o
)
member ApplyTo :
        o : IDialogViewUserDictionaryEdit -> unit

member ApplyTo :
        o : IDialogViewUserDictionaryEdit -> unit
Parameters
o (IDialogViewUserDictionaryEdit)


ApplyTo Method (o)

ApplyTo Method (o)
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► ApplyTo(IDialogViewUserDictionarySelect)
Keyoti RapidSpell WPF
Applies text settings
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void ApplyTo(
    IDialogViewUserDictionarySelect o
)
public void ApplyTo(
    IDialogViewUserDictionarySelect o
)
Public Sub ApplyTo (
    o As IDialogViewUserDictionarySelect
)
Public Sub ApplyTo (
    o As IDialogViewUserDictionarySelect
)
public:
void ApplyTo(
    IDialogViewUserDictionarySelect^ o
)
public:
void ApplyTo(
    IDialogViewUserDictionarySelect^ o
)
member ApplyTo :
        o : IDialogViewUserDictionarySelect -> unit

member ApplyTo :
        o : IDialogViewUserDictionarySelect -> unit
Parameters
o (IDialogViewUserDictionarySelect)


ApplyTo Method (rs)

ApplyTo Method (rs)
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► ApplyTo(IUserInterfaceFormPresenter)
Keyoti RapidSpell WPF
Applies text settings
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void ApplyTo(
    IUserInterfaceFormPresenter rs
)
public void ApplyTo(
    IUserInterfaceFormPresenter rs
)
Public Sub ApplyTo (
    rs As IUserInterfaceFormPresenter
)
Public Sub ApplyTo (
    rs As IUserInterfaceFormPresenter
)
public:
void ApplyTo(
    IUserInterfaceFormPresenter^ rs
)
public:
void ApplyTo(
    IUserInterfaceFormPresenter^ rs
)
member ApplyTo :
        rs : IUserInterfaceFormPresenter -> unit

member ApplyTo :
        rs : IUserInterfaceFormPresenter -> unit
Parameters
rs (IUserInterfaceFormPresenter)


CancelButtonText Property

CancelButtonText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► CancelButtonText
Keyoti RapidSpell WPF
Cancel button text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string CancelButtonText { get; set; }
public string CancelButtonText { get; set; }
Public Property CancelButtonText As String
    Get
    Set
Public Property CancelButtonText As String
    Get
    Set
public:
property String^ CancelButtonText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ CancelButtonText {
    String^ get ();
    void set (String^ value);
}
member CancelButtonText : string with get, set

member CancelButtonText : string with get, set
Property Value
String


ChangeAllButtonText Property

ChangeAllButtonText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► ChangeAllButtonText
Keyoti RapidSpell WPF
Change All button text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string ChangeAllButtonText { get; set; }
public string ChangeAllButtonText { get; set; }
Public Property ChangeAllButtonText As String
    Get
    Set
Public Property ChangeAllButtonText As String
    Get
    Set
public:
property String^ ChangeAllButtonText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ ChangeAllButtonText {
    String^ get ();
    void set (String^ value);
}
member ChangeAllButtonText : string with get, set

member ChangeAllButtonText : string with get, set
Property Value
String


ChangeButtonText Property

ChangeButtonText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► ChangeButtonText
Keyoti RapidSpell WPF
Change button text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string ChangeButtonText { get; set; }
public string ChangeButtonText { get; set; }
Public Property ChangeButtonText As String
    Get
    Set
Public Property ChangeButtonText As String
    Get
    Set
public:
property String^ ChangeButtonText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ ChangeButtonText {
    String^ get ();
    void set (String^ value);
}
member ChangeButtonText : string with get, set

member ChangeButtonText : string with get, set
Property Value
String


CheckCompletePopUpText Property

CheckCompletePopUpText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► CheckCompletePopUpText
Keyoti RapidSpell WPF
Check complete pop up text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string CheckCompletePopUpText { get; set; }
public string CheckCompletePopUpText { get; set; }
Public Property CheckCompletePopUpText As String
    Get
    Set
Public Property CheckCompletePopUpText As String
    Get
    Set
public:
property String^ CheckCompletePopUpText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ CheckCompletePopUpText {
    String^ get ();
    void set (String^ value);
}
member CheckCompletePopUpText : string with get, set

member CheckCompletePopUpText : string with get, set
Property Value
String


CheckCompletePopUpTitle Property

CheckCompletePopUpTitle Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► CheckCompletePopUpTitle
Keyoti RapidSpell WPF
Check complete pop up title
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string CheckCompletePopUpTitle { get; set; }
public string CheckCompletePopUpTitle { get; set; }
Public Property CheckCompletePopUpTitle As String
    Get
    Set
Public Property CheckCompletePopUpTitle As String
    Get
    Set
public:
property String^ CheckCompletePopUpTitle {
    String^ get ();
    void set (String^ value);
}
public:
property String^ CheckCompletePopUpTitle {
    String^ get ();
    void set (String^ value);
}
member CheckCompletePopUpTitle : string with get, set

member CheckCompletePopUpTitle : string with get, set
Property Value
String


CheckingSpellingText Property

CheckingSpellingText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► CheckingSpellingText
Keyoti RapidSpell WPF
Checking spelling text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string CheckingSpellingText { get; set; }
public string CheckingSpellingText { get; set; }
Public Property CheckingSpellingText As String
    Get
    Set
Public Property CheckingSpellingText As String
    Get
    Set
public:
property String^ CheckingSpellingText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ CheckingSpellingText {
    String^ get ();
    void set (String^ value);
}
member CheckingSpellingText : string with get, set

member CheckingSpellingText : string with get, set
Property Value
String


DialogTitleText Property

DialogTitleText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► DialogTitleText
Keyoti RapidSpell WPF
Dialog title text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string DialogTitleText { get; set; }
public string DialogTitleText { get; set; }
Public Property DialogTitleText As String
    Get
    Set
Public Property DialogTitleText As String
    Get
    Set
public:
property String^ DialogTitleText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ DialogTitleText {
    String^ get ();
    void set (String^ value);
}
member DialogTitleText : string with get, set

member DialogTitleText : string with get, set
Property Value
String


FindingSuggestionsLabelText Property

FindingSuggestionsLabelText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► FindingSuggestionsLabelText
Keyoti RapidSpell WPF
Finding suggestions label text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string FindingSuggestionsLabelText { get; set; }
public string FindingSuggestionsLabelText { get; set; }
Public Property FindingSuggestionsLabelText As String
    Get
    Set
Public Property FindingSuggestionsLabelText As String
    Get
    Set
public:
property String^ FindingSuggestionsLabelText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ FindingSuggestionsLabelText {
    String^ get ();
    void set (String^ value);
}
member FindingSuggestionsLabelText : string with get, set

member FindingSuggestionsLabelText : string with get, set
Property Value
String


FindSuggestionsLabelText Property

FindSuggestionsLabelText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► FindSuggestionsLabelText
Keyoti RapidSpell WPF
Find suggestions label text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string FindSuggestionsLabelText { get; set; }
public string FindSuggestionsLabelText { get; set; }
Public Property FindSuggestionsLabelText As String
    Get
    Set
Public Property FindSuggestionsLabelText As String
    Get
    Set
public:
property String^ FindSuggestionsLabelText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ FindSuggestionsLabelText {
    String^ get ();
    void set (String^ value);
}
member FindSuggestionsLabelText : string with get, set

member FindSuggestionsLabelText : string with get, set
Property Value
String


FinishedCheckingSelectionPopUpText Property

FinishedCheckingSelectionPopUpText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► FinishedCheckingSelectionPopUpText
Keyoti RapidSpell WPF
Finished checking selection dialog text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string FinishedCheckingSelectionPopUpText { get; set; }
public string FinishedCheckingSelectionPopUpText { get; set; }
Public Property FinishedCheckingSelectionPopUpText As String
    Get
    Set
Public Property FinishedCheckingSelectionPopUpText As String
    Get
    Set
public:
property String^ FinishedCheckingSelectionPopUpText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ FinishedCheckingSelectionPopUpText {
    String^ get ();
    void set (String^ value);
}
member FinishedCheckingSelectionPopUpText : string with get, set

member FinishedCheckingSelectionPopUpText : string with get, set
Property Value
String


FinishedCheckingSelectionPopUpTitle Property

FinishedCheckingSelectionPopUpTitle Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► FinishedCheckingSelectionPopUpTitle
Keyoti RapidSpell WPF
Finished checking selection dialog title
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string FinishedCheckingSelectionPopUpTitle { get; set; }
public string FinishedCheckingSelectionPopUpTitle { get; set; }
Public Property FinishedCheckingSelectionPopUpTitle As String
    Get
    Set
Public Property FinishedCheckingSelectionPopUpTitle As String
    Get
    Set
public:
property String^ FinishedCheckingSelectionPopUpTitle {
    String^ get ();
    void set (String^ value);
}
public:
property String^ FinishedCheckingSelectionPopUpTitle {
    String^ get ();
    void set (String^ value);
}
member FinishedCheckingSelectionPopUpTitle : string with get, set

member FinishedCheckingSelectionPopUpTitle : string with get, set
Property Value
String


IgnoreAllButtonText Property

IgnoreAllButtonText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► IgnoreAllButtonText
Keyoti RapidSpell WPF
Ignore All button text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string IgnoreAllButtonText { get; set; }
public string IgnoreAllButtonText { get; set; }
Public Property IgnoreAllButtonText As String
    Get
    Set
Public Property IgnoreAllButtonText As String
    Get
    Set
public:
property String^ IgnoreAllButtonText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ IgnoreAllButtonText {
    String^ get ();
    void set (String^ value);
}
member IgnoreAllButtonText : string with get, set

member IgnoreAllButtonText : string with get, set
Property Value
String


IgnoreButtonText Property

IgnoreButtonText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► IgnoreButtonText
Keyoti RapidSpell WPF
Ignore button text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string IgnoreButtonText { get; set; }
public string IgnoreButtonText { get; set; }
Public Property IgnoreButtonText As String
    Get
    Set
Public Property IgnoreButtonText As String
    Get
    Set
public:
property String^ IgnoreButtonText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ IgnoreButtonText {
    String^ get ();
    void set (String^ value);
}
member IgnoreButtonText : string with get, set

member IgnoreButtonText : string with get, set
Property Value
String


InDictionaryLabelText Property

InDictionaryLabelText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► InDictionaryLabelText
Keyoti RapidSpell WPF
In dictionary label text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string InDictionaryLabelText { get; set; }
public string InDictionaryLabelText { get; set; }
Public Property InDictionaryLabelText As String
    Get
    Set
Public Property InDictionaryLabelText As String
    Get
    Set
public:
property String^ InDictionaryLabelText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ InDictionaryLabelText {
    String^ get ();
    void set (String^ value);
}
member InDictionaryLabelText : string with get, set

member InDictionaryLabelText : string with get, set
Property Value
String


LoadingDictionaryText Property

LoadingDictionaryText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► LoadingDictionaryText
Keyoti RapidSpell WPF
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string LoadingDictionaryText { get; set; }
public string LoadingDictionaryText { get; set; }
Public Property LoadingDictionaryText As String
    Get
    Set
Public Property LoadingDictionaryText As String
    Get
    Set
public:
property String^ LoadingDictionaryText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ LoadingDictionaryText {
    String^ get ();
    void set (String^ value);
}
member LoadingDictionaryText : string with get, set

member LoadingDictionaryText : string with get, set
Property Value
String


NoSuggestionsText Property

NoSuggestionsText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► NoSuggestionsText
Keyoti RapidSpell WPF
No suggestions found text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string NoSuggestionsText { get; set; }
public string NoSuggestionsText { get; set; }
Public Property NoSuggestionsText As String
    Get
    Set
Public Property NoSuggestionsText As String
    Get
    Set
public:
property String^ NoSuggestionsText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ NoSuggestionsText {
    String^ get ();
    void set (String^ value);
}
member NoSuggestionsText : string with get, set

member NoSuggestionsText : string with get, set
Property Value
String


NotInDictionaryLabelText Property

NotInDictionaryLabelText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► NotInDictionaryLabelText
Keyoti RapidSpell WPF
Not in dictionary label text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string NotInDictionaryLabelText { get; set; }
public string NotInDictionaryLabelText { get; set; }
Public Property NotInDictionaryLabelText As String
    Get
    Set
Public Property NotInDictionaryLabelText As String
    Get
    Set
public:
property String^ NotInDictionaryLabelText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ NotInDictionaryLabelText {
    String^ get ();
    void set (String^ value);
}
member NotInDictionaryLabelText : string with get, set

member NotInDictionaryLabelText : string with get, set
Property Value
String


OptionsButtonText Property

OptionsButtonText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► OptionsButtonText
Keyoti RapidSpell WPF
Options button text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsButtonText { get; set; }
public string OptionsButtonText { get; set; }
Public Property OptionsButtonText As String
    Get
    Set
Public Property OptionsButtonText As String
    Get
    Set
public:
property String^ OptionsButtonText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OptionsButtonText {
    String^ get ();
    void set (String^ value);
}
member OptionsButtonText : string with get, set

member OptionsButtonText : string with get, set
Property Value
String


OptionsFormAdvancedSettingsText Property

OptionsFormAdvancedSettingsText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► OptionsFormAdvancedSettingsText
Keyoti RapidSpell WPF
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsFormAdvancedSettingsText { get; set; }
public string OptionsFormAdvancedSettingsText { get; set; }
Public Property OptionsFormAdvancedSettingsText As String
    Get
    Set
Public Property OptionsFormAdvancedSettingsText As String
    Get
    Set
public:
property String^ OptionsFormAdvancedSettingsText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OptionsFormAdvancedSettingsText {
    String^ get ();
    void set (String^ value);
}
member OptionsFormAdvancedSettingsText : string with get, set

member OptionsFormAdvancedSettingsText : string with get, set
Property Value
String


OptionsFormAlwaysSuggestCorrectionsText Property

OptionsFormAlwaysSuggestCorrectionsText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► OptionsFormAlwaysSuggestCorrectionsText
Keyoti RapidSpell WPF
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsFormAlwaysSuggestCorrectionsText { get; set; }
public string OptionsFormAlwaysSuggestCorrectionsText { get; set; }
Public Property OptionsFormAlwaysSuggestCorrectionsText As String
    Get
    Set
Public Property OptionsFormAlwaysSuggestCorrectionsText As String
    Get
    Set
public:
property String^ OptionsFormAlwaysSuggestCorrectionsText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OptionsFormAlwaysSuggestCorrectionsText {
    String^ get ();
    void set (String^ value);
}
member OptionsFormAlwaysSuggestCorrectionsText : string with get, set

member OptionsFormAlwaysSuggestCorrectionsText : string with get, set
Property Value
String


OptionsFormBasicSettingsText Property

OptionsFormBasicSettingsText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► OptionsFormBasicSettingsText
Keyoti RapidSpell WPF
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsFormBasicSettingsText { get; set; }
public string OptionsFormBasicSettingsText { get; set; }
Public Property OptionsFormBasicSettingsText As String
    Get
    Set
Public Property OptionsFormBasicSettingsText As String
    Get
    Set
public:
property String^ OptionsFormBasicSettingsText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OptionsFormBasicSettingsText {
    String^ get ();
    void set (String^ value);
}
member OptionsFormBasicSettingsText : string with get, set

member OptionsFormBasicSettingsText : string with get, set
Property Value
String


OptionsFormCancelText Property

OptionsFormCancelText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► OptionsFormCancelText
Keyoti RapidSpell WPF
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsFormCancelText { get; set; }
public string OptionsFormCancelText { get; set; }
Public Property OptionsFormCancelText As String
    Get
    Set
Public Property OptionsFormCancelText As String
    Get
    Set
public:
property String^ OptionsFormCancelText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OptionsFormCancelText {
    String^ get ();
    void set (String^ value);
}
member OptionsFormCancelText : string with get, set

member OptionsFormCancelText : string with get, set
Property Value
String


OptionsFormCheckAsYouTypeText Property

OptionsFormCheckAsYouTypeText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► OptionsFormCheckAsYouTypeText
Keyoti RapidSpell WPF
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsFormCheckAsYouTypeText { get; set; }
public string OptionsFormCheckAsYouTypeText { get; set; }
Public Property OptionsFormCheckAsYouTypeText As String
    Get
    Set
Public Property OptionsFormCheckAsYouTypeText As String
    Get
    Set
public:
property String^ OptionsFormCheckAsYouTypeText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OptionsFormCheckAsYouTypeText {
    String^ get ();
    void set (String^ value);
}
member OptionsFormCheckAsYouTypeText : string with get, set

member OptionsFormCheckAsYouTypeText : string with get, set
Property Value
String


OptionsFormIgnoreImproperCaseText Property

OptionsFormIgnoreImproperCaseText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► OptionsFormIgnoreImproperCaseText
Keyoti RapidSpell WPF
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsFormIgnoreImproperCaseText { get; set; }
public string OptionsFormIgnoreImproperCaseText { get; set; }
Public Property OptionsFormIgnoreImproperCaseText As String
    Get
    Set
Public Property OptionsFormIgnoreImproperCaseText As String
    Get
    Set
public:
property String^ OptionsFormIgnoreImproperCaseText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OptionsFormIgnoreImproperCaseText {
    String^ get ();
    void set (String^ value);
}
member OptionsFormIgnoreImproperCaseText : string with get, set

member OptionsFormIgnoreImproperCaseText : string with get, set
Property Value
String


OptionsFormIgnoreInternetAddressesText Property

OptionsFormIgnoreInternetAddressesText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► OptionsFormIgnoreInternetAddressesText
Keyoti RapidSpell WPF
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsFormIgnoreInternetAddressesText { get; set; }
public string OptionsFormIgnoreInternetAddressesText { get; set; }
Public Property OptionsFormIgnoreInternetAddressesText As String
    Get
    Set
Public Property OptionsFormIgnoreInternetAddressesText As String
    Get
    Set
public:
property String^ OptionsFormIgnoreInternetAddressesText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OptionsFormIgnoreInternetAddressesText {
    String^ get ();
    void set (String^ value);
}
member OptionsFormIgnoreInternetAddressesText : string with get, set

member OptionsFormIgnoreInternetAddressesText : string with get, set
Property Value
String


OptionsFormIgnoreWordsInUppercaseText Property

OptionsFormIgnoreWordsInUppercaseText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► OptionsFormIgnoreWordsInUppercaseText
Keyoti RapidSpell WPF
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsFormIgnoreWordsInUppercaseText { get; set; }
public string OptionsFormIgnoreWordsInUppercaseText { get; set; }
Public Property OptionsFormIgnoreWordsInUppercaseText As String
    Get
    Set
Public Property OptionsFormIgnoreWordsInUppercaseText As String
    Get
    Set
public:
property String^ OptionsFormIgnoreWordsInUppercaseText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OptionsFormIgnoreWordsInUppercaseText {
    String^ get ();
    void set (String^ value);
}
member OptionsFormIgnoreWordsInUppercaseText : string with get, set

member OptionsFormIgnoreWordsInUppercaseText : string with get, set
Property Value
String


OptionsFormIgnoreWordsWithNumbersText Property

OptionsFormIgnoreWordsWithNumbersText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► OptionsFormIgnoreWordsWithNumbersText
Keyoti RapidSpell WPF
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsFormIgnoreWordsWithNumbersText { get; set; }
public string OptionsFormIgnoreWordsWithNumbersText { get; set; }
Public Property OptionsFormIgnoreWordsWithNumbersText As String
    Get
    Set
Public Property OptionsFormIgnoreWordsWithNumbersText As String
    Get
    Set
public:
property String^ OptionsFormIgnoreWordsWithNumbersText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OptionsFormIgnoreWordsWithNumbersText {
    String^ get ();
    void set (String^ value);
}
member OptionsFormIgnoreWordsWithNumbersText : string with get, set

member OptionsFormIgnoreWordsWithNumbersText : string with get, set
Property Value
String


OptionsFormOKText Property

OptionsFormOKText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► OptionsFormOKText
Keyoti RapidSpell WPF
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsFormOKText { get; set; }
public string OptionsFormOKText { get; set; }
Public Property OptionsFormOKText As String
    Get
    Set
Public Property OptionsFormOKText As String
    Get
    Set
public:
property String^ OptionsFormOKText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OptionsFormOKText {
    String^ get ();
    void set (String^ value);
}
member OptionsFormOKText : string with get, set

member OptionsFormOKText : string with get, set
Property Value
String


OptionsFormRecheckTextText Property

OptionsFormRecheckTextText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► OptionsFormRecheckTextText
Keyoti RapidSpell WPF
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsFormRecheckTextText { get; set; }
public string OptionsFormRecheckTextText { get; set; }
Public Property OptionsFormRecheckTextText As String
    Get
    Set
Public Property OptionsFormRecheckTextText As String
    Get
    Set
public:
property String^ OptionsFormRecheckTextText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OptionsFormRecheckTextText {
    String^ get ();
    void set (String^ value);
}
member OptionsFormRecheckTextText : string with get, set

member OptionsFormRecheckTextText : string with get, set
Property Value
String


OptionsFormSuggestFromMainDictionaryOnlyText Property

OptionsFormSuggestFromMainDictionaryOnlyText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► OptionsFormSuggestFromMainDictionaryOnlyText
Keyoti RapidSpell WPF
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsFormSuggestFromMainDictionaryOnlyText { get; set; }
public string OptionsFormSuggestFromMainDictionaryOnlyText { get; set; }
Public Property OptionsFormSuggestFromMainDictionaryOnlyText As String
    Get
    Set
Public Property OptionsFormSuggestFromMainDictionaryOnlyText As String
    Get
    Set
public:
property String^ OptionsFormSuggestFromMainDictionaryOnlyText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OptionsFormSuggestFromMainDictionaryOnlyText {
    String^ get ();
    void set (String^ value);
}
member OptionsFormSuggestFromMainDictionaryOnlyText : string with get, set

member OptionsFormSuggestFromMainDictionaryOnlyText : string with get, set
Property Value
String


OptionsFormTitleText Property

OptionsFormTitleText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► OptionsFormTitleText
Keyoti RapidSpell WPF
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsFormTitleText { get; set; }
public string OptionsFormTitleText { get; set; }
Public Property OptionsFormTitleText As String
    Get
    Set
Public Property OptionsFormTitleText As String
    Get
    Set
public:
property String^ OptionsFormTitleText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OptionsFormTitleText {
    String^ get ();
    void set (String^ value);
}
member OptionsFormTitleText : string with get, set

member OptionsFormTitleText : string with get, set
Property Value
String


OptionsFormUserDictionaryEditText Property

OptionsFormUserDictionaryEditText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► OptionsFormUserDictionaryEditText
Keyoti RapidSpell WPF
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsFormUserDictionaryEditText { get; set; }
public string OptionsFormUserDictionaryEditText { get; set; }
Public Property OptionsFormUserDictionaryEditText As String
    Get
    Set
Public Property OptionsFormUserDictionaryEditText As String
    Get
    Set
public:
property String^ OptionsFormUserDictionaryEditText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OptionsFormUserDictionaryEditText {
    String^ get ();
    void set (String^ value);
}
member OptionsFormUserDictionaryEditText : string with get, set

member OptionsFormUserDictionaryEditText : string with get, set
Property Value
String


RemoveDuplicateWordText Property

RemoveDuplicateWordText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► RemoveDuplicateWordText
Keyoti RapidSpell WPF
Remove duplicate word text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string RemoveDuplicateWordText { get; set; }
public string RemoveDuplicateWordText { get; set; }
Public Property RemoveDuplicateWordText As String
    Get
    Set
Public Property RemoveDuplicateWordText As String
    Get
    Set
public:
property String^ RemoveDuplicateWordText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ RemoveDuplicateWordText {
    String^ get ();
    void set (String^ value);
}
member RemoveDuplicateWordText : string with get, set

member RemoveDuplicateWordText : string with get, set
Property Value
String


ResetText Property

ResetText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► ResetText
Keyoti RapidSpell WPF
Used at design time to reset UI text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ResetText { get; set; }
public bool ResetText { get; set; }
Public Property ResetText As Boolean
    Get
    Set
Public Property ResetText As Boolean
    Get
    Set
public:
property bool ResetText {
    bool get ();
    void set (bool value);
}
public:
property bool ResetText {
    bool get ();
    void set (bool value);
}
member ResetText : bool with get, set

member ResetText : bool with get, set
Property Value
Boolean


ResumeButtonText Property

ResumeButtonText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► ResumeButtonText
Keyoti RapidSpell WPF
Resume button text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string ResumeButtonText { get; set; }
public string ResumeButtonText { get; set; }
Public Property ResumeButtonText As String
    Get
    Set
Public Property ResumeButtonText As String
    Get
    Set
public:
property String^ ResumeButtonText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ ResumeButtonText {
    String^ get ();
    void set (String^ value);
}
member ResumeButtonText : string with get, set

member ResumeButtonText : string with get, set
Property Value
String


SuggestionsLabelText Property

SuggestionsLabelText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► SuggestionsLabelText
Keyoti RapidSpell WPF
Suggestions label text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string SuggestionsLabelText { get; set; }
public string SuggestionsLabelText { get; set; }
Public Property SuggestionsLabelText As String
    Get
    Set
Public Property SuggestionsLabelText As String
    Get
    Set
public:
property String^ SuggestionsLabelText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ SuggestionsLabelText {
    String^ get ();
    void set (String^ value);
}
member SuggestionsLabelText : string with get, set

member SuggestionsLabelText : string with get, set
Property Value
String


UndoButtonText Property

UndoButtonText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► UndoButtonText
Keyoti RapidSpell WPF
Undo button text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UndoButtonText { get; set; }
public string UndoButtonText { get; set; }
Public Property UndoButtonText As String
    Get
    Set
Public Property UndoButtonText As String
    Get
    Set
public:
property String^ UndoButtonText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UndoButtonText {
    String^ get ();
    void set (String^ value);
}
member UndoButtonText : string with get, set

member UndoButtonText : string with get, set
Property Value
String


UserDictionaryFormAddText Property

UserDictionaryFormAddText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► UserDictionaryFormAddText
Keyoti RapidSpell WPF
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionaryFormAddText { get; set; }
public string UserDictionaryFormAddText { get; set; }
Public Property UserDictionaryFormAddText As String
    Get
    Set
Public Property UserDictionaryFormAddText As String
    Get
    Set
public:
property String^ UserDictionaryFormAddText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserDictionaryFormAddText {
    String^ get ();
    void set (String^ value);
}
member UserDictionaryFormAddText : string with get, set

member UserDictionaryFormAddText : string with get, set
Property Value
String


UserDictionaryFormCancelText Property

UserDictionaryFormCancelText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► UserDictionaryFormCancelText
Keyoti RapidSpell WPF
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionaryFormCancelText { get; set; }
public string UserDictionaryFormCancelText { get; set; }
Public Property UserDictionaryFormCancelText As String
    Get
    Set
Public Property UserDictionaryFormCancelText As String
    Get
    Set
public:
property String^ UserDictionaryFormCancelText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserDictionaryFormCancelText {
    String^ get ();
    void set (String^ value);
}
member UserDictionaryFormCancelText : string with get, set

member UserDictionaryFormCancelText : string with get, set
Property Value
String


UserDictionaryFormContentsText Property

UserDictionaryFormContentsText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► UserDictionaryFormContentsText
Keyoti RapidSpell WPF
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionaryFormContentsText { get; set; }
public string UserDictionaryFormContentsText { get; set; }
Public Property UserDictionaryFormContentsText As String
    Get
    Set
Public Property UserDictionaryFormContentsText As String
    Get
    Set
public:
property String^ UserDictionaryFormContentsText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserDictionaryFormContentsText {
    String^ get ();
    void set (String^ value);
}
member UserDictionaryFormContentsText : string with get, set

member UserDictionaryFormContentsText : string with get, set
Property Value
String


UserDictionaryFormDeleteText Property

UserDictionaryFormDeleteText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► UserDictionaryFormDeleteText
Keyoti RapidSpell WPF
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionaryFormDeleteText { get; set; }
public string UserDictionaryFormDeleteText { get; set; }
Public Property UserDictionaryFormDeleteText As String
    Get
    Set
Public Property UserDictionaryFormDeleteText As String
    Get
    Set
public:
property String^ UserDictionaryFormDeleteText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserDictionaryFormDeleteText {
    String^ get ();
    void set (String^ value);
}
member UserDictionaryFormDeleteText : string with get, set

member UserDictionaryFormDeleteText : string with get, set
Property Value
String


UserDictionaryFormDictionaryLabelText Property

UserDictionaryFormDictionaryLabelText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► UserDictionaryFormDictionaryLabelText
Keyoti RapidSpell WPF
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionaryFormDictionaryLabelText { get; set; }
public string UserDictionaryFormDictionaryLabelText { get; set; }
Public Property UserDictionaryFormDictionaryLabelText As String
    Get
    Set
Public Property UserDictionaryFormDictionaryLabelText As String
    Get
    Set
public:
property String^ UserDictionaryFormDictionaryLabelText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserDictionaryFormDictionaryLabelText {
    String^ get ();
    void set (String^ value);
}
member UserDictionaryFormDictionaryLabelText : string with get, set

member UserDictionaryFormDictionaryLabelText : string with get, set
Property Value
String


UserDictionaryFormOKText Property

UserDictionaryFormOKText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► UserDictionaryFormOKText
Keyoti RapidSpell WPF
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionaryFormOKText { get; set; }
public string UserDictionaryFormOKText { get; set; }
Public Property UserDictionaryFormOKText As String
    Get
    Set
Public Property UserDictionaryFormOKText As String
    Get
    Set
public:
property String^ UserDictionaryFormOKText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserDictionaryFormOKText {
    String^ get ();
    void set (String^ value);
}
member UserDictionaryFormOKText : string with get, set

member UserDictionaryFormOKText : string with get, set
Property Value
String


UserDictionaryFormTitleText Property

UserDictionaryFormTitleText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► UserDictionaryFormTitleText
Keyoti RapidSpell WPF
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionaryFormTitleText { get; set; }
public string UserDictionaryFormTitleText { get; set; }
Public Property UserDictionaryFormTitleText As String
    Get
    Set
Public Property UserDictionaryFormTitleText As String
    Get
    Set
public:
property String^ UserDictionaryFormTitleText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserDictionaryFormTitleText {
    String^ get ();
    void set (String^ value);
}
member UserDictionaryFormTitleText : string with get, set

member UserDictionaryFormTitleText : string with get, set
Property Value
String


UserDictionaryFormWordLabelText Property

UserDictionaryFormWordLabelText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► UserDictionaryFormWordLabelText
Keyoti RapidSpell WPF
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionaryFormWordLabelText { get; set; }
public string UserDictionaryFormWordLabelText { get; set; }
Public Property UserDictionaryFormWordLabelText As String
    Get
    Set
Public Property UserDictionaryFormWordLabelText As String
    Get
    Set
public:
property String^ UserDictionaryFormWordLabelText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserDictionaryFormWordLabelText {
    String^ get ();
    void set (String^ value);
}
member UserDictionaryFormWordLabelText : string with get, set

member UserDictionaryFormWordLabelText : string with get, set
Property Value
String


UserDictionarySelectFormAddFileText Property

UserDictionarySelectFormAddFileText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► UserDictionarySelectFormAddFileText
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionarySelectFormAddFileText { get; set; }
public string UserDictionarySelectFormAddFileText { get; set; }
Public Property UserDictionarySelectFormAddFileText As String
    Get
    Set
Public Property UserDictionarySelectFormAddFileText As String
    Get
    Set
public:
property String^ UserDictionarySelectFormAddFileText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserDictionarySelectFormAddFileText {
    String^ get ();
    void set (String^ value);
}
member UserDictionarySelectFormAddFileText : string with get, set

member UserDictionarySelectFormAddFileText : string with get, set
Property Value
String


UserDictionarySelectFormCancelText Property

UserDictionarySelectFormCancelText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► UserDictionarySelectFormCancelText
Keyoti RapidSpell WPF
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionarySelectFormCancelText { get; set; }
public string UserDictionarySelectFormCancelText { get; set; }
Public Property UserDictionarySelectFormCancelText As String
    Get
    Set
Public Property UserDictionarySelectFormCancelText As String
    Get
    Set
public:
property String^ UserDictionarySelectFormCancelText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserDictionarySelectFormCancelText {
    String^ get ();
    void set (String^ value);
}
member UserDictionarySelectFormCancelText : string with get, set

member UserDictionarySelectFormCancelText : string with get, set
Property Value
String


UserDictionarySelectFormChangeDefaultText Property

UserDictionarySelectFormChangeDefaultText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► UserDictionarySelectFormChangeDefaultText
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionarySelectFormChangeDefaultText { get; set; }
public string UserDictionarySelectFormChangeDefaultText { get; set; }
Public Property UserDictionarySelectFormChangeDefaultText As String
    Get
    Set
Public Property UserDictionarySelectFormChangeDefaultText As String
    Get
    Set
public:
property String^ UserDictionarySelectFormChangeDefaultText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserDictionarySelectFormChangeDefaultText {
    String^ get ();
    void set (String^ value);
}
member UserDictionarySelectFormChangeDefaultText : string with get, set

member UserDictionarySelectFormChangeDefaultText : string with get, set
Property Value
String


UserDictionarySelectFormDeleteText Property

UserDictionarySelectFormDeleteText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► UserDictionarySelectFormDeleteText
Keyoti RapidSpell WPF
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionarySelectFormDeleteText { get; set; }
public string UserDictionarySelectFormDeleteText { get; set; }
Public Property UserDictionarySelectFormDeleteText As String
    Get
    Set
Public Property UserDictionarySelectFormDeleteText As String
    Get
    Set
public:
property String^ UserDictionarySelectFormDeleteText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserDictionarySelectFormDeleteText {
    String^ get ();
    void set (String^ value);
}
member UserDictionarySelectFormDeleteText : string with get, set

member UserDictionarySelectFormDeleteText : string with get, set
Property Value
String


UserDictionarySelectFormDictionaryLabelText Property

UserDictionarySelectFormDictionaryLabelText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► UserDictionarySelectFormDictionaryLabelText
Keyoti RapidSpell WPF
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionarySelectFormDictionaryLabelText { get; set; }
public string UserDictionarySelectFormDictionaryLabelText { get; set; }
Public Property UserDictionarySelectFormDictionaryLabelText As String
    Get
    Set
Public Property UserDictionarySelectFormDictionaryLabelText As String
    Get
    Set
public:
property String^ UserDictionarySelectFormDictionaryLabelText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserDictionarySelectFormDictionaryLabelText {
    String^ get ();
    void set (String^ value);
}
member UserDictionarySelectFormDictionaryLabelText : string with get, set

member UserDictionarySelectFormDictionaryLabelText : string with get, set
Property Value
String


UserDictionarySelectFormEditFileText Property

UserDictionarySelectFormEditFileText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► UserDictionarySelectFormEditFileText
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionarySelectFormEditFileText { get; set; }
public string UserDictionarySelectFormEditFileText { get; set; }
Public Property UserDictionarySelectFormEditFileText As String
    Get
    Set
Public Property UserDictionarySelectFormEditFileText As String
    Get
    Set
public:
property String^ UserDictionarySelectFormEditFileText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserDictionarySelectFormEditFileText {
    String^ get ();
    void set (String^ value);
}
member UserDictionarySelectFormEditFileText : string with get, set

member UserDictionarySelectFormEditFileText : string with get, set
Property Value
String


UserDictionarySelectFormGroupBoxTitleText Property

UserDictionarySelectFormGroupBoxTitleText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► UserDictionarySelectFormGroupBoxTitleText
Keyoti RapidSpell WPF
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionarySelectFormGroupBoxTitleText { get; set; }
public string UserDictionarySelectFormGroupBoxTitleText { get; set; }
Public Property UserDictionarySelectFormGroupBoxTitleText As String
    Get
    Set
Public Property UserDictionarySelectFormGroupBoxTitleText As String
    Get
    Set
public:
property String^ UserDictionarySelectFormGroupBoxTitleText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserDictionarySelectFormGroupBoxTitleText {
    String^ get ();
    void set (String^ value);
}
member UserDictionarySelectFormGroupBoxTitleText : string with get, set

member UserDictionarySelectFormGroupBoxTitleText : string with get, set
Property Value
String


UserDictionarySelectFormNewFileText Property

UserDictionarySelectFormNewFileText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► UserDictionarySelectFormNewFileText
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionarySelectFormNewFileText { get; set; }
public string UserDictionarySelectFormNewFileText { get; set; }
Public Property UserDictionarySelectFormNewFileText As String
    Get
    Set
Public Property UserDictionarySelectFormNewFileText As String
    Get
    Set
public:
property String^ UserDictionarySelectFormNewFileText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserDictionarySelectFormNewFileText {
    String^ get ();
    void set (String^ value);
}
member UserDictionarySelectFormNewFileText : string with get, set

member UserDictionarySelectFormNewFileText : string with get, set
Property Value
String


UserDictionarySelectFormOKText Property

UserDictionarySelectFormOKText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► UserDictionarySelectFormOKText
Keyoti RapidSpell WPF
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionarySelectFormOKText { get; set; }
public string UserDictionarySelectFormOKText { get; set; }
Public Property UserDictionarySelectFormOKText As String
    Get
    Set
Public Property UserDictionarySelectFormOKText As String
    Get
    Set
public:
property String^ UserDictionarySelectFormOKText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserDictionarySelectFormOKText {
    String^ get ();
    void set (String^ value);
}
member UserDictionarySelectFormOKText : string with get, set

member UserDictionarySelectFormOKText : string with get, set
Property Value
String


UserDictionarySelectFormRemoveFileText Property

UserDictionarySelectFormRemoveFileText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► UserDictionarySelectFormRemoveFileText
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionarySelectFormRemoveFileText { get; set; }
public string UserDictionarySelectFormRemoveFileText { get; set; }
Public Property UserDictionarySelectFormRemoveFileText As String
    Get
    Set
Public Property UserDictionarySelectFormRemoveFileText As String
    Get
    Set
public:
property String^ UserDictionarySelectFormRemoveFileText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserDictionarySelectFormRemoveFileText {
    String^ get ();
    void set (String^ value);
}
member UserDictionarySelectFormRemoveFileText : string with get, set

member UserDictionarySelectFormRemoveFileText : string with get, set
Property Value
String


UserDictionarySelectFormTitleText Property

UserDictionarySelectFormTitleText Property
API ► Keyoti.RapidSpell.Wpf ► DialogTexts ► UserDictionarySelectFormTitleText
Keyoti RapidSpell WPF
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionarySelectFormTitleText { get; set; }
public string UserDictionarySelectFormTitleText { get; set; }
Public Property UserDictionarySelectFormTitleText As String
    Get
    Set
Public Property UserDictionarySelectFormTitleText As String
    Get
    Set
public:
property String^ UserDictionarySelectFormTitleText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserDictionarySelectFormTitleText {
    String^ get ();
    void set (String^ value);
}
member UserDictionarySelectFormTitleText : string with get, set

member UserDictionarySelectFormTitleText : string with get, set
Property Value
String


DictionaryCache Class

DictionaryCache Class
API ► Keyoti.RapidSpell.Wpf ► DictionaryCache
Keyoti RapidSpell WPF
Cache of loaded dictionaries.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class DictionaryCache
public class DictionaryCache
Public Class DictionaryCache
Public Class DictionaryCache
public ref class DictionaryCache
public ref class DictionaryCache
type DictionaryCache =  class end
type DictionaryCache =  class end
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DictionaryCache()()()() |
 | AddDictionary(SpellingDictionary) | Adds a dictionary to the cache.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetDictionary(String, DateTime) | Gets a dictionary from the cache.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RemoveAllDictionaries()()()() | Removes all dictionaries in the cache, they will be reloaded if needed later.
 | RemoveDictionary(String) | Removes a dictionary from the cache based on its filename.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
DictionaryCache


DictionaryCache Constructor

DictionaryCache Constructor
API ► Keyoti.RapidSpell.Wpf ► DictionaryCache ► DictionaryCache()()()()
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public DictionaryCache()
public DictionaryCache()
Public Sub New
Public Sub New
public:
DictionaryCache()
public:
DictionaryCache()
new : unit -> DictionaryCache
new : unit -> DictionaryCache


AddDictionary Method (dictionary)

AddDictionary Method (dictionary)
API ► Keyoti.RapidSpell.Wpf ► DictionaryCache ► AddDictionary(SpellingDictionary)
Keyoti RapidSpell WPF
Adds a dictionary to the cache.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static void AddDictionary(
    SpellingDictionary dictionary
)
public static void AddDictionary(
    SpellingDictionary dictionary
)
Public Shared Sub AddDictionary (
    dictionary As SpellingDictionary
)
Public Shared Sub AddDictionary (
    dictionary As SpellingDictionary
)
public:
static void AddDictionary(
    SpellingDictionary^ dictionary
)
public:
static void AddDictionary(
    SpellingDictionary^ dictionary
)
static member AddDictionary :
        dictionary : SpellingDictionary -> unit

static member AddDictionary :
        dictionary : SpellingDictionary -> unit
Parameters
dictionary (SpellingDictionary)


GetDictionary Method (path, lastModifiedDate)

GetDictionary Method (path, lastModifiedDate)
API ► Keyoti.RapidSpell.Wpf ► DictionaryCache ► GetDictionary(String, DateTime)
Keyoti RapidSpell WPF
Gets a dictionary from the cache.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static SpellingDictionary GetDictionary(
    string path,
    DateTime lastModifiedDate
)
public static SpellingDictionary GetDictionary(
    string path,
    DateTime lastModifiedDate
)
Public Shared Function GetDictionary (
    path As String,
    lastModifiedDate As DateTime
) As SpellingDictionary
Public Shared Function GetDictionary (
    path As String,
    lastModifiedDate As DateTime
) As SpellingDictionary
public:
static SpellingDictionary^ GetDictionary(
    String^ path,
    DateTime lastModifiedDate
)
public:
static SpellingDictionary^ GetDictionary(
    String^ path,
    DateTime lastModifiedDate
)
static member GetDictionary :
        path : string *
        lastModifiedDate : DateTime -> SpellingDictionary

static member GetDictionary :
        path : string *
        lastModifiedDate : DateTime -> SpellingDictionary
Parameters
path (String)
lastModifiedDate (DateTime)
Return Value
SpellingDictionary


RemoveAllDictionaries Method

RemoveAllDictionaries Method
API ► Keyoti.RapidSpell.Wpf ► DictionaryCache ► RemoveAllDictionaries()()()()
Keyoti RapidSpell WPF
Removes all dictionaries in the cache, they will be reloaded if needed later.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static void RemoveAllDictionaries()
public static void RemoveAllDictionaries()
Public Shared Sub RemoveAllDictionaries
Public Shared Sub RemoveAllDictionaries
public:
static void RemoveAllDictionaries()
public:
static void RemoveAllDictionaries()
static member RemoveAllDictionaries : unit -> unit

static member RemoveAllDictionaries : unit -> unit


RemoveDictionary Method (path)

RemoveDictionary Method (path)
API ► Keyoti.RapidSpell.Wpf ► DictionaryCache ► RemoveDictionary(String)
Keyoti RapidSpell WPF
Removes a dictionary from the cache based on its filename.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static void RemoveDictionary(
    string path
)
public static void RemoveDictionary(
    string path
)
Public Shared Sub RemoveDictionary (
    path As String
)
Public Shared Sub RemoveDictionary (
    path As String
)
public:
static void RemoveDictionary(
    String^ path
)
public:
static void RemoveDictionary(
    String^ path
)
static member RemoveDictionary :
        path : string -> unit

static member RemoveDictionary :
        path : string -> unit
Parameters
path (String)
Path to the dictionary


ErrorAdorner Class

ErrorAdorner Class
API ► Keyoti.RapidSpell.Wpf ► ErrorAdorner
Keyoti RapidSpell WPF
The highlight adorner, which renders error highlights on a plain TextBox
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class ErrorAdorner : ErrorAdornerBase
public class ErrorAdorner : ErrorAdornerBase
Public Class ErrorAdorner
    Inherits ErrorAdornerBase
Public Class ErrorAdorner
    Inherits ErrorAdornerBase
public ref class ErrorAdorner : public ErrorAdornerBase
public ref class ErrorAdorner : public ErrorAdornerBase
type ErrorAdorner =
    class
        inherit ErrorAdornerBase
    end
type ErrorAdorner =
    class
        inherit ErrorAdornerBase
    end
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ErrorAdorner(TextBox, Int32, Int32, IAYTTextBox, UnderlineStyle, Color) | New
 | Active | Whether this adorner is ever visible. It can be inactive if the word it is highlighting is ignored. (Inherited from ErrorAdornerBase.)
 | ActualHeight | (Inherited from FrameworkElement.)
 | ActualWidth | (Inherited from FrameworkElement.)
 | AddHandler(RoutedEvent, Delegate) | (Inherited from UIElement.)
 | AddHandler(RoutedEvent, Delegate, Boolean) | (Inherited from UIElement.)
 | AddLogicalChild(Object) | (Inherited from FrameworkElement.)
 | AddToEventRoute(EventRoute, RoutedEventArgs) | (Inherited from UIElement.)
 | AddVisualChild(Visual) | (Inherited from Visual.)
 | AdornedElement | (Inherited from Adorner.)
 | AllowDrop | (Inherited from UIElement.)
 | ApplyAnimationClock(DependencyProperty, AnimationClock) | (Inherited from UIElement.)
 | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | (Inherited from UIElement.)
 | ApplyTemplate()()()() | (Inherited from FrameworkElement.)
 | AreAnyTouchesCaptured | (Inherited from UIElement.)
 | AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
 | AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
 | AreAnyTouchesOver | (Inherited from UIElement.)
 | Arrange(Rect) | (Inherited from UIElement.)
 | ArrangeCore(Rect) | (Inherited from FrameworkElement.)
 | ArrangeOverride(Size) | (Inherited from FrameworkElement.)
 | BeginAnimation(DependencyProperty, AnimationTimeline) | (Inherited from UIElement.)
 | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | (Inherited from UIElement.)
 | BeginInit()()()() | (Inherited from FrameworkElement.)
 | BeginStoryboard(Storyboard) | (Inherited from FrameworkElement.)
 | BeginStoryboard(Storyboard, HandoffBehavior) | (Inherited from FrameworkElement.)
 | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | (Inherited from FrameworkElement.)
 | BindingGroup | (Inherited from FrameworkElement.)
 | BitmapEffect | Obsolete. (Inherited from UIElement.)
 | BitmapEffectInput | Obsolete. (Inherited from UIElement.)
 | BringIntoView()()()() | (Inherited from FrameworkElement.)
 | BringIntoView(Rect) | (Inherited from FrameworkElement.)
 | BumpUnderlineTo(Int32, Int32) | The underline has moved because the text has been bumped along by new or removed text before it. (Inherited from ErrorAdornerBase.)
 | CacheMode | (Inherited from UIElement.)
 | CaptureMouse()()()() | (Inherited from UIElement.)
 | CaptureStylus()()()() | (Inherited from UIElement.)
 | CaptureTouch(TouchDevice) | (Inherited from UIElement.)
 | cheat | (Inherited from ErrorAdornerBase.)
 | CheckAccess()()()() | (Inherited from DispatcherObject.)
 | ClearValue(DependencyProperty) | (Inherited from DependencyObject.)
 | ClearValue(DependencyPropertyKey) | (Inherited from DependencyObject.)
 | Clip | (Inherited from UIElement.)
 | ClipToBounds | (Inherited from UIElement.)
 | CoerceValue(DependencyProperty) | (Inherited from DependencyObject.)
 | Color | (Inherited from ErrorAdornerBase.)
 | CommandBindings | (Inherited from UIElement.)
 | ConnectAndPaint(DrawingContext, Rect, Rect) | Paints underline between two Rects (Inherited from ErrorAdornerBase.)
 | ContextMenu | (Inherited from FrameworkElement.)
 | ContextMenuClosing | (Inherited from FrameworkElement.)
 | ContextMenuOpening | (Inherited from FrameworkElement.)
 | Cursor | (Inherited from FrameworkElement.)
 | DataContext | (Inherited from FrameworkElement.)
 | DataContextChanged | (Inherited from FrameworkElement.)
 | DefaultStyleKey | (Inherited from FrameworkElement.)
 | DependencyObjectType | (Inherited from DependencyObject.)
 | DesiredSize | (Inherited from UIElement.)
 | Dispatcher | (Inherited from DispatcherObject.)
 | DragEnter | (Inherited from UIElement.)
 | DragLeave | (Inherited from UIElement.)
 | DragOver | (Inherited from UIElement.)
 | Drop | (Inherited from UIElement.)
 | Effect | (Inherited from UIElement.)
 | end | Error position. (Inherited from ErrorAdornerBase.)
 | EndInit()()()() | (Inherited from FrameworkElement.)
 | Equals(Object) | (Inherited from DependencyObject.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FindCommonVisualAncestor(DependencyObject) | (Inherited from Visual.)
 | FindName(String) | (Inherited from FrameworkElement.)
 | FindResource(Object) | (Inherited from FrameworkElement.)
 | FlowDirection | (Inherited from FrameworkElement.)
 | Focus()()()() | (Inherited from UIElement.)
 | Focusable | (Inherited from UIElement.)
 | FocusableChanged | (Inherited from UIElement.)
 | FocusVisualStyle | (Inherited from FrameworkElement.)
 | ForceCursor | (Inherited from FrameworkElement.)
 | GetAnimationBaseValue(DependencyProperty) | (Inherited from UIElement.)
 | GetBindingExpression(DependencyProperty) | (Inherited from FrameworkElement.)
 | GetDesiredTransform(GeneralTransform) | (Inherited from Adorner.)
 | GetHashCode()()()() | (Inherited from DependencyObject.)
 | GetLayoutClip(Size) | (Inherited from Adorner.)
 | GetLocalValueEnumerator()()()() | (Inherited from DependencyObject.)
 | GetTemplateChild(String) | (Inherited from FrameworkElement.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GetUIParentCore()()()() | (Inherited from FrameworkElement.)
 | GetValue(DependencyProperty) | (Inherited from DependencyObject.)
 | GetVisualChild(Int32) | (Inherited from FrameworkElement.)
 | GiveFeedback | (Inherited from UIElement.)
 | GotFocus | (Inherited from UIElement.)
 | GotKeyboardFocus | (Inherited from UIElement.)
 | GotMouseCapture | (Inherited from UIElement.)
 | GotStylusCapture | (Inherited from UIElement.)
 | GotTouchCapture | (Inherited from UIElement.)
 | HasAnimatedProperties | (Inherited from UIElement.)
 | HasEffectiveKeyboardFocus | (Inherited from UIElement.)
 | Height | (Inherited from FrameworkElement.)
 | HighlightFillBrush | The highlight brush (Inherited from ErrorAdornerBase.)
 | HighlightLinePen | The highlight pen (Inherited from ErrorAdornerBase.)
 | HitTestCore(PointHitTestParameters) | (Inherited from UIElement.)
 | HitTestCore(GeometryHitTestParameters) | (Inherited from UIElement.)
 | HorizontalAlignment | (Inherited from FrameworkElement.)
 | iayt | The IAYT interface cast of the text box wrapper (Inherited from ErrorAdornerBase.)
 | InheritanceBehavior | (Inherited from FrameworkElement.)
 | Initialized | (Inherited from FrameworkElement.)
 | InputBindings | (Inherited from UIElement.)
 | InputHitTest(Point) | (Inherited from UIElement.)
 | InputScope | (Inherited from FrameworkElement.)
 | InvalidateArrange()()()() | (Inherited from UIElement.)
 | InvalidateMeasure()()()() | (Inherited from UIElement.)
 | InvalidateProperty(DependencyProperty) | (Inherited from DependencyObject.)
 | InvalidateVisual()()()() | (Inherited from UIElement.)
 | IsAncestorOf(DependencyObject) | (Inherited from Visual.)
 | IsArrangeValid | (Inherited from UIElement.)
 | IsAt(Int32, Int32) | Whether this highlight is at start to end (Inherited from ErrorAdornerBase.)
 | IsClipEnabled | (Inherited from Adorner.)
 | IsDescendantOf(DependencyObject) | (Inherited from Visual.)
 | IsEnabled | (Inherited from UIElement.)
 | IsEnabledChanged | (Inherited from UIElement.)
 | IsEnabledCore | (Inherited from UIElement.)
 | IsFocused | (Inherited from UIElement.)
 | IsHitTestVisible | (Inherited from UIElement.)
 | IsHitTestVisibleChanged | (Inherited from UIElement.)
 | IsInitialized | (Inherited from FrameworkElement.)
 | IsInputMethodEnabled | (Inherited from UIElement.)
 | IsKeyboardFocused | (Inherited from UIElement.)
 | IsKeyboardFocusedChanged | (Inherited from UIElement.)
 | IsKeyboardFocusWithin | (Inherited from UIElement.)
 | IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
 | IsLoaded | (Inherited from FrameworkElement.)
 | IsManipulationEnabled | (Inherited from UIElement.)
 | IsMeasureValid | (Inherited from UIElement.)
 | IsMouseCaptured | (Inherited from UIElement.)
 | IsMouseCapturedChanged | (Inherited from UIElement.)
 | IsMouseCaptureWithin | (Inherited from UIElement.)
 | IsMouseCaptureWithinChanged | (Inherited from UIElement.)
 | IsMouseDirectlyOver | (Inherited from UIElement.)
 | IsMouseDirectlyOverChanged | (Inherited from UIElement.)
 | IsMouseOver | (Inherited from UIElement.)
 | IsSealed | (Inherited from DependencyObject.)
 | IsStylusCaptured | (Inherited from UIElement.)
 | IsStylusCapturedChanged | (Inherited from UIElement.)
 | IsStylusCaptureWithin | (Inherited from UIElement.)
 | IsStylusCaptureWithinChanged | (Inherited from UIElement.)
 | IsStylusDirectlyOver | (Inherited from UIElement.)
 | IsStylusDirectlyOverChanged | (Inherited from UIElement.)
 | IsStylusOver | (Inherited from UIElement.)
 | IsVisible | (Inherited from UIElement.)
 | IsVisibleChanged | (Inherited from UIElement.)
 | KeyDown | (Inherited from UIElement.)
 | KeyUp | (Inherited from UIElement.)
 | Language | (Inherited from FrameworkElement.)
 | LayoutTransform | (Inherited from FrameworkElement.)
 | LayoutUpdated | (Inherited from UIElement.)
 | Loaded | (Inherited from FrameworkElement.)
 | LogicalChildren | (Inherited from FrameworkElement.)
 | LostFocus | (Inherited from UIElement.)
 | LostKeyboardFocus | (Inherited from UIElement.)
 | LostMouseCapture | (Inherited from UIElement.)
 | LostStylusCapture | (Inherited from UIElement.)
 | LostTouchCapture | (Inherited from UIElement.)
 | ManipulationBoundaryFeedback | (Inherited from UIElement.)
 | ManipulationCompleted | (Inherited from UIElement.)
 | ManipulationDelta | (Inherited from UIElement.)
 | ManipulationInertiaStarting | (Inherited from UIElement.)
 | ManipulationStarted | (Inherited from UIElement.)
 | ManipulationStarting | (Inherited from UIElement.)
 | Margin | (Inherited from FrameworkElement.)
 | MaxHeight | (Inherited from FrameworkElement.)
 | MaxWidth | (Inherited from FrameworkElement.)
 | Measure(Size) | (Inherited from UIElement.)
 | MeasureCore(Size) | (Inherited from FrameworkElement.)
 | MeasureOverride(Size) | (Inherited from Adorner.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinHeight | (Inherited from FrameworkElement.)
 | MinWidth | (Inherited from FrameworkElement.)
 | MouseDown | (Inherited from UIElement.)
 | MouseEnter | (Inherited from UIElement.)
 | MouseLeave | (Inherited from UIElement.)
 | MouseLeftButtonDown | (Inherited from UIElement.)
 | MouseLeftButtonUp | (Inherited from UIElement.)
 | MouseMove | (Inherited from UIElement.)
 | MouseRightButtonDown | (Inherited from UIElement.)
 | MouseRightButtonUp | (Inherited from UIElement.)
 | MouseUp | (Inherited from UIElement.)
 | MouseWheel | (Inherited from UIElement.)
 | MoveFocus(TraversalRequest) | (Inherited from FrameworkElement.)
 | Name | (Inherited from FrameworkElement.)
 | numberOfFailedRenderAttempts | (Inherited from ErrorAdornerBase.)
 | OnAccessKey(AccessKeyEventArgs) | (Inherited from UIElement.)
 | OnActiveChanged(Boolean) | Active property has changed (Inherited from ErrorAdornerBase.)
 | OnApplyTemplate()()()() | (Inherited from FrameworkElement.)
 | OnChildDesiredSizeChanged(UIElement) | (Inherited from UIElement.)
 | OnContextMenuClosing(ContextMenuEventArgs) | (Inherited from FrameworkElement.)
 | OnContextMenuOpening(ContextMenuEventArgs) | (Inherited from FrameworkElement.)
 | OnCreateAutomationPeer()()()() | (Inherited from UIElement.)
 | OnDpiChanged(DpiScale, DpiScale) | (Inherited from Visual.)
 | OnDragEnter(DragEventArgs) | (Inherited from UIElement.)
 | OnDragLeave(DragEventArgs) | (Inherited from UIElement.)
 | OnDragOver(DragEventArgs) | (Inherited from UIElement.)
 | OnDrop(DragEventArgs) | (Inherited from UIElement.)
 | OnGiveFeedback(GiveFeedbackEventArgs) | (Inherited from UIElement.)
 | OnGotFocus(RoutedEventArgs) | (Inherited from FrameworkElement.)
 | OnGotKeyboardFocus(KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
 | OnGotMouseCapture(MouseEventArgs) | (Inherited from UIElement.)
 | OnGotStylusCapture(StylusEventArgs) | (Inherited from UIElement.)
 | OnGotTouchCapture(TouchEventArgs) | (Inherited from UIElement.)
 | OnInitialized(EventArgs) | (Inherited from FrameworkElement.)
 | OnIsKeyboardFocusedChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsKeyboardFocusWithinChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsMouseCapturedChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsMouseCaptureWithinChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsMouseDirectlyOverChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsStylusCapturedChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsStylusCaptureWithinChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsStylusDirectlyOverChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnKeyDown(KeyEventArgs) | (Inherited from UIElement.)
 | OnKeyUp(KeyEventArgs) | (Inherited from UIElement.)
 | OnLostFocus(RoutedEventArgs) | (Inherited from UIElement.)
 | OnLostKeyboardFocus(KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
 | OnLostMouseCapture(MouseEventArgs) | (Inherited from UIElement.)
 | OnLostStylusCapture(StylusEventArgs) | (Inherited from UIElement.)
 | OnLostTouchCapture(TouchEventArgs) | (Inherited from UIElement.)
 | OnManipulationBoundaryFeedback(ManipulationBoundaryFeedbackEventArgs) | (Inherited from UIElement.)
 | OnManipulationCompleted(ManipulationCompletedEventArgs) | (Inherited from UIElement.)
 | OnManipulationDelta(ManipulationDeltaEventArgs) | (Inherited from UIElement.)
 | OnManipulationInertiaStarting(ManipulationInertiaStartingEventArgs) | (Inherited from UIElement.)
 | OnManipulationStarted(ManipulationStartedEventArgs) | (Inherited from UIElement.)
 | OnManipulationStarting(ManipulationStartingEventArgs) | (Inherited from UIElement.)
 | OnMouseDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseEnter(MouseEventArgs) | (Inherited from UIElement.)
 | OnMouseLeave(MouseEventArgs) | (Inherited from UIElement.)
 | OnMouseLeftButtonDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseLeftButtonUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseMove(MouseEventArgs) | (Inherited from UIElement.)
 | OnMouseRightButtonDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseRightButtonUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseWheel(MouseWheelEventArgs) | (Inherited from UIElement.)
 | OnPreviewDragEnter(DragEventArgs) | (Inherited from UIElement.)
 | OnPreviewDragLeave(DragEventArgs) | (Inherited from UIElement.)
 | OnPreviewDragOver(DragEventArgs) | (Inherited from UIElement.)
 | OnPreviewDrop(DragEventArgs) | (Inherited from UIElement.)
 | OnPreviewGiveFeedback(GiveFeedbackEventArgs) | (Inherited from UIElement.)
 | OnPreviewGotKeyboardFocus(KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
 | OnPreviewKeyDown(KeyEventArgs) | (Inherited from UIElement.)
 | OnPreviewKeyUp(KeyEventArgs) | (Inherited from UIElement.)
 | OnPreviewLostKeyboardFocus(KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseLeftButtonDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseLeftButtonUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseMove(MouseEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseRightButtonDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseRightButtonUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseWheel(MouseWheelEventArgs) | (Inherited from UIElement.)
 | OnPreviewQueryContinueDrag(QueryContinueDragEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusButtonDown(StylusButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusButtonUp(StylusButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusDown(StylusDownEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusInAirMove(StylusEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusInRange(StylusEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusMove(StylusEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusOutOfRange(StylusEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusSystemGesture(StylusSystemGestureEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusUp(StylusEventArgs) | (Inherited from UIElement.)
 | OnPreviewTextInput(TextCompositionEventArgs) | (Inherited from UIElement.)
 | OnPreviewTouchDown(TouchEventArgs) | (Inherited from UIElement.)
 | OnPreviewTouchMove(TouchEventArgs) | (Inherited from UIElement.)
 | OnPreviewTouchUp(TouchEventArgs) | (Inherited from UIElement.)
 | OnPropertyChanged(DependencyPropertyChangedEventArgs) | (Inherited from FrameworkElement.)
 | OnQueryContinueDrag(QueryContinueDragEventArgs) | (Inherited from UIElement.)
 | OnQueryCursor(QueryCursorEventArgs) | (Inherited from UIElement.)
 | OnRender(DrawingContext) | Renders the underline (Overrides UIElement.OnRender(DrawingContext).)
 | OnRenderImpossible()()()() | Fires render impossible event (Inherited from ErrorAdornerBase.)
 | OnRenderSizeChanged(SizeChangedInfo) | (Inherited from FrameworkElement.)
 | OnStyleChanged(Style, Style) | (Inherited from FrameworkElement.)
 | OnStylusButtonDown(StylusButtonEventArgs) | (Inherited from UIElement.)
 | OnStylusButtonUp(StylusButtonEventArgs) | (Inherited from UIElement.)
 | OnStylusDown(StylusDownEventArgs) | (Inherited from UIElement.)
 | OnStylusEnter(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusInAirMove(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusInRange(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusLeave(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusMove(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusOutOfRange(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusSystemGesture(StylusSystemGestureEventArgs) | (Inherited from UIElement.)
 | OnStylusUp(StylusEventArgs) | (Inherited from UIElement.)
 | OnTextInput(TextCompositionEventArgs) | (Inherited from UIElement.)
 | OnToolTipClosing(ToolTipEventArgs) | (Inherited from FrameworkElement.)
 | OnToolTipOpening(ToolTipEventArgs) | (Inherited from FrameworkElement.)
 | OnTouchDown(TouchEventArgs) | (Inherited from UIElement.)
 | OnTouchEnter(TouchEventArgs) | (Inherited from UIElement.)
 | OnTouchLeave(TouchEventArgs) | (Inherited from UIElement.)
 | OnTouchMove(TouchEventArgs) | (Inherited from UIElement.)
 | OnTouchUp(TouchEventArgs) | (Inherited from UIElement.)
 | OnVisualChildrenChanged(DependencyObject, DependencyObject) | (Inherited from Visual.)
 | OnVisualParentChanged(DependencyObject) | (Inherited from FrameworkElement.)
 | Opacity | (Inherited from UIElement.)
 | OpacityMask | (Inherited from UIElement.)
 | OverridesDefaultStyle | (Inherited from FrameworkElement.)
 | Parent | (Inherited from FrameworkElement.)
 | ParentLayoutInvalidated(UIElement) | (Inherited from FrameworkElement.)
 | PersistId | Obsolete. (Inherited from UIElement.)
 | PointFromScreen(Point) | (Inherited from Visual.)
 | PointToScreen(Point) | (Inherited from Visual.)
 | PredictFocus(FocusNavigationDirection) | (Inherited from FrameworkElement.)
 | PreviewDragEnter | (Inherited from UIElement.)
 | PreviewDragLeave | (Inherited from UIElement.)
 | PreviewDragOver | (Inherited from UIElement.)
 | PreviewDrop | (Inherited from UIElement.)
 | PreviewGiveFeedback | (Inherited from UIElement.)
 | PreviewGotKeyboardFocus | (Inherited from UIElement.)
 | PreviewKeyDown | (Inherited from UIElement.)
 | PreviewKeyUp | (Inherited from UIElement.)
 | PreviewLostKeyboardFocus | (Inherited from UIElement.)
 | PreviewMouseDown | (Inherited from UIElement.)
 | PreviewMouseLeftButtonDown | (Inherited from UIElement.)
 | PreviewMouseLeftButtonUp | (Inherited from UIElement.)
 | PreviewMouseMove | (Inherited from UIElement.)
 | PreviewMouseRightButtonDown | (Inherited from UIElement.)
 | PreviewMouseRightButtonUp | (Inherited from UIElement.)
 | PreviewMouseUp | (Inherited from UIElement.)
 | PreviewMouseWheel | (Inherited from UIElement.)
 | PreviewQueryContinueDrag | (Inherited from UIElement.)
 | PreviewStylusButtonDown | (Inherited from UIElement.)
 | PreviewStylusButtonUp | (Inherited from UIElement.)
 | PreviewStylusDown | (Inherited from UIElement.)
 | PreviewStylusInAirMove | (Inherited from UIElement.)
 | PreviewStylusInRange | (Inherited from UIElement.)
 | PreviewStylusMove | (Inherited from UIElement.)
 | PreviewStylusOutOfRange | (Inherited from UIElement.)
 | PreviewStylusSystemGesture | (Inherited from UIElement.)
 | PreviewStylusUp | (Inherited from UIElement.)
 | PreviewTextInput | (Inherited from UIElement.)
 | PreviewTouchDown | (Inherited from UIElement.)
 | PreviewTouchMove | (Inherited from UIElement.)
 | PreviewTouchUp | (Inherited from UIElement.)
 | QueryContinueDrag | (Inherited from UIElement.)
 | QueryCursor | (Inherited from UIElement.)
 | RaiseEvent(RoutedEventArgs) | (Inherited from UIElement.)
 | ReadLocalValue(DependencyProperty) | (Inherited from DependencyObject.)
 | RegisterName(String, Object) | (Inherited from FrameworkElement.)
 | ReleaseAllTouchCaptures()()()() | (Inherited from UIElement.)
 | ReleaseMouseCapture()()()() | (Inherited from UIElement.)
 | ReleaseStylusCapture()()()() | (Inherited from UIElement.)
 | ReleaseTouchCapture(TouchDevice) | (Inherited from UIElement.)
 | RemoveHandler(RoutedEvent, Delegate) | (Inherited from UIElement.)
 | RemoveLogicalChild(Object) | (Inherited from FrameworkElement.)
 | RemoveVisualChild(Visual) | (Inherited from Visual.)
 | RenderSize | (Inherited from UIElement.)
 | RenderTransform | (Inherited from UIElement.)
 | RenderTransformOrigin | (Inherited from UIElement.)
 | RequestBringIntoView | (Inherited from FrameworkElement.)
 | Resources | (Inherited from FrameworkElement.)
 | scroller_ScrollChanged(Object, ScrollChangedEventArgs) | (Inherited from ErrorAdornerBase.)
 | SetBinding(DependencyProperty, BindingBase) | (Inherited from FrameworkElement.)
 | SetBinding(DependencyProperty, String) | (Inherited from FrameworkElement.)
 | SetCurrentValue(DependencyProperty, Object) | (Inherited from DependencyObject.)
 | SetResourceReference(DependencyProperty, Object) | (Inherited from FrameworkElement.)
 | SetValue(DependencyProperty, Object) | (Inherited from DependencyObject.)
 | SetValue(DependencyPropertyKey, Object) | (Inherited from DependencyObject.)
 | ShouldSerializeCommandBindings()()()() | (Inherited from UIElement.)
 | ShouldSerializeInputBindings()()()() | (Inherited from UIElement.)
 | ShouldSerializeProperty(DependencyProperty) | (Inherited from DependencyObject.)
 | ShouldSerializeResources()()()() | (Inherited from FrameworkElement.)
 | ShouldSerializeStyle()()()() | (Inherited from FrameworkElement.)
 | ShouldSerializeTriggers()()()() | (Inherited from FrameworkElement.)
 | SizeChanged | (Inherited from FrameworkElement.)
 | SnapsToDevicePixels | (Inherited from UIElement.)
 | SourceUpdated | (Inherited from FrameworkElement.)
 | start | Error position. (Inherited from ErrorAdornerBase.)
 | Style | (Inherited from FrameworkElement.)
 | StylusButtonDown | (Inherited from UIElement.)
 | StylusButtonUp | (Inherited from UIElement.)
 | StylusDown | (Inherited from UIElement.)
 | StylusEnter | (Inherited from UIElement.)
 | StylusInAirMove | (Inherited from UIElement.)
 | StylusInRange | (Inherited from UIElement.)
 | StylusLeave | (Inherited from UIElement.)
 | StylusMove | (Inherited from UIElement.)
 | StylusOutOfRange | (Inherited from UIElement.)
 | StylusPlugIns | (Inherited from UIElement.)
 | StylusSystemGesture | (Inherited from UIElement.)
 | StylusUp | (Inherited from UIElement.)
 | Tag | (Inherited from FrameworkElement.)
 | TargetUpdated | (Inherited from FrameworkElement.)
 | tb | The textbox
 | tbb | The text box (Inherited from ErrorAdornerBase.)
 | tbb_TextChanged(Object, TextChangedEventArgs) | (Inherited from ErrorAdornerBase.)
 | TemplatedParent | (Inherited from FrameworkElement.)
 | TextInput | (Inherited from UIElement.)
 | ToolTip | (Inherited from FrameworkElement.)
 | ToolTipClosing | (Inherited from FrameworkElement.)
 | ToolTipOpening | (Inherited from FrameworkElement.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | TouchDown | (Inherited from UIElement.)
 | TouchEnter | (Inherited from UIElement.)
 | TouchesCaptured | (Inherited from UIElement.)
 | TouchesCapturedWithin | (Inherited from UIElement.)
 | TouchesDirectlyOver | (Inherited from UIElement.)
 | TouchesOver | (Inherited from UIElement.)
 | TouchLeave | (Inherited from UIElement.)
 | TouchMove | (Inherited from UIElement.)
 | TouchUp | (Inherited from UIElement.)
 | TransformToAncestor(Visual) | (Inherited from Visual.)
 | TransformToAncestor(Visual3D) | (Inherited from Visual.)
 | TransformToDescendant(Visual) | (Inherited from Visual.)
 | TransformToVisual(Visual) | (Inherited from Visual.)
 | TranslatePoint(Point, UIElement) | (Inherited from UIElement.)
 | Triggers | (Inherited from FrameworkElement.)
 | TryFindResource(Object) | (Inherited from FrameworkElement.)
 | Uid | (Inherited from UIElement.)
 | Unloaded | (Inherited from FrameworkElement.)
 | Unregister()()()() | (Overrides ErrorAdornerBase.Unregister()()()().)
 | UnregisterName(String) | (Inherited from FrameworkElement.)
 | UpdateDefaultStyle()()()() | (Inherited from FrameworkElement.)
 | UpdateLayout()()()() | (Inherited from UIElement.)
 | UpdateUnderlinePosition(Int32, Int32) | We're putting the underline in a new position. (Inherited from ErrorAdornerBase.)
 | UseLayoutRounding | (Inherited from FrameworkElement.)
 | VerifyAccess()()()() | (Inherited from DispatcherObject.)
 | VerticalAlignment | (Inherited from FrameworkElement.)
 | Visibility | (Inherited from UIElement.)
 | VisualBitmapEffect | Obsolete. (Inherited from Visual.)
 | VisualBitmapEffectInput | Obsolete. (Inherited from Visual.)
 | VisualBitmapScalingMode | (Inherited from Visual.)
 | VisualCacheMode | (Inherited from Visual.)
 | VisualChildrenCount | (Inherited from FrameworkElement.)
 | VisualClearTypeHint | (Inherited from Visual.)
 | VisualClip | (Inherited from Visual.)
 | VisualEdgeMode | (Inherited from Visual.)
 | VisualEffect | (Inherited from Visual.)
 | VisualOffset | (Inherited from Visual.)
 | VisualOpacity | (Inherited from Visual.)
 | VisualOpacityMask | (Inherited from Visual.)
 | VisualParent | (Inherited from Visual.)
 | VisualScrollableAreaClip | (Inherited from Visual.)
 | VisualTextHintingMode | (Inherited from Visual.)
 | VisualTextRenderingMode | (Inherited from Visual.)
 | VisualTransform | (Inherited from Visual.)
 | VisualXSnappingGuidelines | (Inherited from Visual.)
 | VisualYSnappingGuidelines | (Inherited from Visual.)
 | Width | (Inherited from FrameworkElement.)
Inheritance Hierarchy
Object
 | DispatcherObject
 |  | DependencyObject
 |  |  | Visual
 |  |  |  | UIElement
 |  |  |  |  | FrameworkElement
 |  |  |  |  |  | Adorner
 |  |  |  |  |  |  | ErrorAdornerBase
 |  |  |  |  |  |  |  | ErrorAdorner


ErrorAdorner Constructor (adornedElement, start, end, iayt, u, c)

ErrorAdorner Constructor (adornedElement, start, end, iayt, u, c)
API ► Keyoti.RapidSpell.Wpf ► ErrorAdorner ► ErrorAdorner(TextBox, Int32, Int32, IAYTTextBox, UnderlineStyle, Color)
Keyoti RapidSpell WPF
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ErrorAdorner(
    TextBox adornedElement,
    int start,
    int end,
    IAYTTextBox iayt,
    UnderlineStyle u,
    Color c
)
public ErrorAdorner(
    TextBox adornedElement,
    int start,
    int end,
    IAYTTextBox iayt,
    UnderlineStyle u,
    Color c
)
Public Sub New (
    adornedElement As TextBox,
    start As Integer,
    end As Integer,
    iayt As IAYTTextBox,
    u As UnderlineStyle,
    c As Color
)
Public Sub New (
    adornedElement As TextBox,
    start As Integer,
    end As Integer,
    iayt As IAYTTextBox,
    u As UnderlineStyle,
    c As Color
)
public:
ErrorAdorner(
    TextBox^ adornedElement,
    int start,
    int end,
    IAYTTextBox^ iayt,
    UnderlineStyle u,
    Color c
)
public:
ErrorAdorner(
    TextBox^ adornedElement,
    int start,
    int end,
    IAYTTextBox^ iayt,
    UnderlineStyle u,
    Color c
)
new :
        adornedElement : TextBox *
        start : int *
        end : int *
        iayt : IAYTTextBox *
        u : UnderlineStyle *
        c : Color -> ErrorAdorner
new :
        adornedElement : TextBox *
        start : int *
        end : int *
        iayt : IAYTTextBox *
        u : UnderlineStyle *
        c : Color -> ErrorAdorner
Parameters
adornedElement (TextBox)
start (Int32)
end (Int32)
iayt (IAYTTextBox)
u (UnderlineStyle)
c (Color)


OnRender Method (drawingContext)

OnRender Method (drawingContext)
API ► Keyoti.RapidSpell.Wpf ► ErrorAdorner ► OnRender(DrawingContext)
Keyoti RapidSpell WPF
Renders the underline
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override void OnRender(
    DrawingContext drawingContext
)
protected override void OnRender(
    DrawingContext drawingContext
)
Protected Overrides Sub OnRender (
    drawingContext As DrawingContext
)
Protected Overrides Sub OnRender (
    drawingContext As DrawingContext
)
protected:
virtual void OnRender(
    DrawingContext^ drawingContext
) override
protected:
virtual void OnRender(
    DrawingContext^ drawingContext
) override
abstract OnRender :
        drawingContext : DrawingContext -> unit
override OnRender :
        drawingContext : DrawingContext -> unit
abstract OnRender :
        drawingContext : DrawingContext -> unit
override OnRender :
        drawingContext : DrawingContext -> unit
Parameters
drawingContext (DrawingContext)


tb Field

tb Field
API ► Keyoti.RapidSpell.Wpf ► ErrorAdorner ► tb
Keyoti RapidSpell WPF
The textbox
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected TextBox tb
protected TextBox tb
Protected tb As TextBox
Protected tb As TextBox
protected:
TextBox^ tb
protected:
TextBox^ tb
val mutable tb: TextBox
val mutable tb: TextBox
Field Value
TextBox


Unregister Method

Unregister Method
API ► Keyoti.RapidSpell.Wpf ► ErrorAdorner ► Unregister()()()()
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override void Unregister()
public override void Unregister()
Public Overrides Sub Unregister
Public Overrides Sub Unregister
public:
virtual void Unregister() override
public:
virtual void Unregister() override
abstract Unregister : unit -> unit
override Unregister : unit -> unit
abstract Unregister : unit -> unit
override Unregister : unit -> unit


ErrorAdornerBase Class

ErrorAdornerBase Class
API ► Keyoti.RapidSpell.Wpf ► ErrorAdornerBase
Keyoti RapidSpell WPF
Base level error underline adorner.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class ErrorAdornerBase : Adorner
public class ErrorAdornerBase : Adorner
Public Class ErrorAdornerBase
    Inherits Adorner
Public Class ErrorAdornerBase
    Inherits Adorner
public ref class ErrorAdornerBase : public Adorner
public ref class ErrorAdornerBase : public Adorner
type ErrorAdornerBase =
    class
        inherit Adorner
    end
type ErrorAdornerBase =
    class
        inherit Adorner
    end
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ErrorAdornerBase(TextBoxBase, UnderlineStyle, Color) | New
 | Active | Whether this adorner is ever visible. It can be inactive if the word it is highlighting is ignored.
 | ActualHeight | (Inherited from FrameworkElement.)
 | ActualWidth | (Inherited from FrameworkElement.)
 | AddHandler(RoutedEvent, Delegate) | (Inherited from UIElement.)
 | AddHandler(RoutedEvent, Delegate, Boolean) | (Inherited from UIElement.)
 | AddLogicalChild(Object) | (Inherited from FrameworkElement.)
 | AddToEventRoute(EventRoute, RoutedEventArgs) | (Inherited from UIElement.)
 | AddVisualChild(Visual) | (Inherited from Visual.)
 | AdornedElement | (Inherited from Adorner.)
 | AllowDrop | (Inherited from UIElement.)
 | ApplyAnimationClock(DependencyProperty, AnimationClock) | (Inherited from UIElement.)
 | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | (Inherited from UIElement.)
 | ApplyTemplate()()()() | (Inherited from FrameworkElement.)
 | AreAnyTouchesCaptured | (Inherited from UIElement.)
 | AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
 | AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
 | AreAnyTouchesOver | (Inherited from UIElement.)
 | Arrange(Rect) | (Inherited from UIElement.)
 | ArrangeCore(Rect) | (Inherited from FrameworkElement.)
 | ArrangeOverride(Size) | (Inherited from FrameworkElement.)
 | BeginAnimation(DependencyProperty, AnimationTimeline) | (Inherited from UIElement.)
 | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | (Inherited from UIElement.)
 | BeginInit()()()() | (Inherited from FrameworkElement.)
 | BeginStoryboard(Storyboard) | (Inherited from FrameworkElement.)
 | BeginStoryboard(Storyboard, HandoffBehavior) | (Inherited from FrameworkElement.)
 | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | (Inherited from FrameworkElement.)
 | BindingGroup | (Inherited from FrameworkElement.)
 | BitmapEffect | Obsolete. (Inherited from UIElement.)
 | BitmapEffectInput | Obsolete. (Inherited from UIElement.)
 | BringIntoView()()()() | (Inherited from FrameworkElement.)
 | BringIntoView(Rect) | (Inherited from FrameworkElement.)
 | BumpUnderlineTo(Int32, Int32) | The underline has moved because the text has been bumped along by new or removed text before it.
 | CacheMode | (Inherited from UIElement.)
 | CaptureMouse()()()() | (Inherited from UIElement.)
 | CaptureStylus()()()() | (Inherited from UIElement.)
 | CaptureTouch(TouchDevice) | (Inherited from UIElement.)
 | cheat |
 | CheckAccess()()()() | (Inherited from DispatcherObject.)
 | ClearValue(DependencyProperty) | (Inherited from DependencyObject.)
 | ClearValue(DependencyPropertyKey) | (Inherited from DependencyObject.)
 | Clip | (Inherited from UIElement.)
 | ClipToBounds | (Inherited from UIElement.)
 | CoerceValue(DependencyProperty) | (Inherited from DependencyObject.)
 | Color |
 | CommandBindings | (Inherited from UIElement.)
 | ConnectAndPaint(DrawingContext, Rect, Rect) | Paints underline between two Rects
 | ContextMenu | (Inherited from FrameworkElement.)
 | ContextMenuClosing | (Inherited from FrameworkElement.)
 | ContextMenuOpening | (Inherited from FrameworkElement.)
 | Cursor | (Inherited from FrameworkElement.)
 | DataContext | (Inherited from FrameworkElement.)
 | DataContextChanged | (Inherited from FrameworkElement.)
 | DefaultStyleKey | (Inherited from FrameworkElement.)
 | DependencyObjectType | (Inherited from DependencyObject.)
 | DesiredSize | (Inherited from UIElement.)
 | Dispatcher | (Inherited from DispatcherObject.)
 | DragEnter | (Inherited from UIElement.)
 | DragLeave | (Inherited from UIElement.)
 | DragOver | (Inherited from UIElement.)
 | Drop | (Inherited from UIElement.)
 | Effect | (Inherited from UIElement.)
 | end | Error position.
 | EndInit()()()() | (Inherited from FrameworkElement.)
 | Equals(Object) | (Inherited from DependencyObject.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FindCommonVisualAncestor(DependencyObject) | (Inherited from Visual.)
 | FindName(String) | (Inherited from FrameworkElement.)
 | FindResource(Object) | (Inherited from FrameworkElement.)
 | FlowDirection | (Inherited from FrameworkElement.)
 | Focus()()()() | (Inherited from UIElement.)
 | Focusable | (Inherited from UIElement.)
 | FocusableChanged | (Inherited from UIElement.)
 | FocusVisualStyle | (Inherited from FrameworkElement.)
 | ForceCursor | (Inherited from FrameworkElement.)
 | GetAnimationBaseValue(DependencyProperty) | (Inherited from UIElement.)
 | GetBindingExpression(DependencyProperty) | (Inherited from FrameworkElement.)
 | GetDesiredTransform(GeneralTransform) | (Inherited from Adorner.)
 | GetHashCode()()()() | (Inherited from DependencyObject.)
 | GetLayoutClip(Size) | (Inherited from Adorner.)
 | GetLocalValueEnumerator()()()() | (Inherited from DependencyObject.)
 | GetTemplateChild(String) | (Inherited from FrameworkElement.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GetUIParentCore()()()() | (Inherited from FrameworkElement.)
 | GetValue(DependencyProperty) | (Inherited from DependencyObject.)
 | GetVisualChild(Int32) | (Inherited from FrameworkElement.)
 | GiveFeedback | (Inherited from UIElement.)
 | GotFocus | (Inherited from UIElement.)
 | GotKeyboardFocus | (Inherited from UIElement.)
 | GotMouseCapture | (Inherited from UIElement.)
 | GotStylusCapture | (Inherited from UIElement.)
 | GotTouchCapture | (Inherited from UIElement.)
 | HasAnimatedProperties | (Inherited from UIElement.)
 | HasEffectiveKeyboardFocus | (Inherited from UIElement.)
 | Height | (Inherited from FrameworkElement.)
 | HighlightFillBrush | The highlight brush
 | HighlightLinePen | The highlight pen
 | HitTestCore(PointHitTestParameters) | (Inherited from UIElement.)
 | HitTestCore(GeometryHitTestParameters) | (Inherited from UIElement.)
 | HorizontalAlignment | (Inherited from FrameworkElement.)
 | iayt | The IAYT interface cast of the text box wrapper
 | InheritanceBehavior | (Inherited from FrameworkElement.)
 | Initialized | (Inherited from FrameworkElement.)
 | InputBindings | (Inherited from UIElement.)
 | InputHitTest(Point) | (Inherited from UIElement.)
 | InputScope | (Inherited from FrameworkElement.)
 | InvalidateArrange()()()() | (Inherited from UIElement.)
 | InvalidateMeasure()()()() | (Inherited from UIElement.)
 | InvalidateProperty(DependencyProperty) | (Inherited from DependencyObject.)
 | InvalidateVisual()()()() | (Inherited from UIElement.)
 | IsAncestorOf(DependencyObject) | (Inherited from Visual.)
 | IsArrangeValid | (Inherited from UIElement.)
 | IsAt(Int32, Int32) | Whether this highlight is at start to end
 | IsClipEnabled | (Inherited from Adorner.)
 | IsDescendantOf(DependencyObject) | (Inherited from Visual.)
 | IsEnabled | (Inherited from UIElement.)
 | IsEnabledChanged | (Inherited from UIElement.)
 | IsEnabledCore | (Inherited from UIElement.)
 | IsFocused | (Inherited from UIElement.)
 | IsHitTestVisible | (Inherited from UIElement.)
 | IsHitTestVisibleChanged | (Inherited from UIElement.)
 | IsInitialized | (Inherited from FrameworkElement.)
 | IsInputMethodEnabled | (Inherited from UIElement.)
 | IsKeyboardFocused | (Inherited from UIElement.)
 | IsKeyboardFocusedChanged | (Inherited from UIElement.)
 | IsKeyboardFocusWithin | (Inherited from UIElement.)
 | IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
 | IsLoaded | (Inherited from FrameworkElement.)
 | IsManipulationEnabled | (Inherited from UIElement.)
 | IsMeasureValid | (Inherited from UIElement.)
 | IsMouseCaptured | (Inherited from UIElement.)
 | IsMouseCapturedChanged | (Inherited from UIElement.)
 | IsMouseCaptureWithin | (Inherited from UIElement.)
 | IsMouseCaptureWithinChanged | (Inherited from UIElement.)
 | IsMouseDirectlyOver | (Inherited from UIElement.)
 | IsMouseDirectlyOverChanged | (Inherited from UIElement.)
 | IsMouseOver | (Inherited from UIElement.)
 | IsSealed | (Inherited from DependencyObject.)
 | IsStylusCaptured | (Inherited from UIElement.)
 | IsStylusCapturedChanged | (Inherited from UIElement.)
 | IsStylusCaptureWithin | (Inherited from UIElement.)
 | IsStylusCaptureWithinChanged | (Inherited from UIElement.)
 | IsStylusDirectlyOver | (Inherited from UIElement.)
 | IsStylusDirectlyOverChanged | (Inherited from UIElement.)
 | IsStylusOver | (Inherited from UIElement.)
 | IsVisible | (Inherited from UIElement.)
 | IsVisibleChanged | (Inherited from UIElement.)
 | KeyDown | (Inherited from UIElement.)
 | KeyUp | (Inherited from UIElement.)
 | Language | (Inherited from FrameworkElement.)
 | LayoutTransform | (Inherited from FrameworkElement.)
 | LayoutUpdated | (Inherited from UIElement.)
 | Loaded | (Inherited from FrameworkElement.)
 | LogicalChildren | (Inherited from FrameworkElement.)
 | LostFocus | (Inherited from UIElement.)
 | LostKeyboardFocus | (Inherited from UIElement.)
 | LostMouseCapture | (Inherited from UIElement.)
 | LostStylusCapture | (Inherited from UIElement.)
 | LostTouchCapture | (Inherited from UIElement.)
 | ManipulationBoundaryFeedback | (Inherited from UIElement.)
 | ManipulationCompleted | (Inherited from UIElement.)
 | ManipulationDelta | (Inherited from UIElement.)
 | ManipulationInertiaStarting | (Inherited from UIElement.)
 | ManipulationStarted | (Inherited from UIElement.)
 | ManipulationStarting | (Inherited from UIElement.)
 | Margin | (Inherited from FrameworkElement.)
 | MaxHeight | (Inherited from FrameworkElement.)
 | MaxWidth | (Inherited from FrameworkElement.)
 | Measure(Size) | (Inherited from UIElement.)
 | MeasureCore(Size) | (Inherited from FrameworkElement.)
 | MeasureOverride(Size) | (Inherited from Adorner.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinHeight | (Inherited from FrameworkElement.)
 | MinWidth | (Inherited from FrameworkElement.)
 | MouseDown | (Inherited from UIElement.)
 | MouseEnter | (Inherited from UIElement.)
 | MouseLeave | (Inherited from UIElement.)
 | MouseLeftButtonDown | (Inherited from UIElement.)
 | MouseLeftButtonUp | (Inherited from UIElement.)
 | MouseMove | (Inherited from UIElement.)
 | MouseRightButtonDown | (Inherited from UIElement.)
 | MouseRightButtonUp | (Inherited from UIElement.)
 | MouseUp | (Inherited from UIElement.)
 | MouseWheel | (Inherited from UIElement.)
 | MoveFocus(TraversalRequest) | (Inherited from FrameworkElement.)
 | Name | (Inherited from FrameworkElement.)
 | numberOfFailedRenderAttempts |
 | OnAccessKey(AccessKeyEventArgs) | (Inherited from UIElement.)
 | OnActiveChanged(Boolean) | Active property has changed
 | OnApplyTemplate()()()() | (Inherited from FrameworkElement.)
 | OnChildDesiredSizeChanged(UIElement) | (Inherited from UIElement.)
 | OnContextMenuClosing(ContextMenuEventArgs) | (Inherited from FrameworkElement.)
 | OnContextMenuOpening(ContextMenuEventArgs) | (Inherited from FrameworkElement.)
 | OnCreateAutomationPeer()()()() | (Inherited from UIElement.)
 | OnDpiChanged(DpiScale, DpiScale) | (Inherited from Visual.)
 | OnDragEnter(DragEventArgs) | (Inherited from UIElement.)
 | OnDragLeave(DragEventArgs) | (Inherited from UIElement.)
 | OnDragOver(DragEventArgs) | (Inherited from UIElement.)
 | OnDrop(DragEventArgs) | (Inherited from UIElement.)
 | OnGiveFeedback(GiveFeedbackEventArgs) | (Inherited from UIElement.)
 | OnGotFocus(RoutedEventArgs) | (Inherited from FrameworkElement.)
 | OnGotKeyboardFocus(KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
 | OnGotMouseCapture(MouseEventArgs) | (Inherited from UIElement.)
 | OnGotStylusCapture(StylusEventArgs) | (Inherited from UIElement.)
 | OnGotTouchCapture(TouchEventArgs) | (Inherited from UIElement.)
 | OnInitialized(EventArgs) | (Inherited from FrameworkElement.)
 | OnIsKeyboardFocusedChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsKeyboardFocusWithinChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsMouseCapturedChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsMouseCaptureWithinChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsMouseDirectlyOverChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsStylusCapturedChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsStylusCaptureWithinChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsStylusDirectlyOverChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnKeyDown(KeyEventArgs) | (Inherited from UIElement.)
 | OnKeyUp(KeyEventArgs) | (Inherited from UIElement.)
 | OnLostFocus(RoutedEventArgs) | (Inherited from UIElement.)
 | OnLostKeyboardFocus(KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
 | OnLostMouseCapture(MouseEventArgs) | (Inherited from UIElement.)
 | OnLostStylusCapture(StylusEventArgs) | (Inherited from UIElement.)
 | OnLostTouchCapture(TouchEventArgs) | (Inherited from UIElement.)
 | OnManipulationBoundaryFeedback(ManipulationBoundaryFeedbackEventArgs) | (Inherited from UIElement.)
 | OnManipulationCompleted(ManipulationCompletedEventArgs) | (Inherited from UIElement.)
 | OnManipulationDelta(ManipulationDeltaEventArgs) | (Inherited from UIElement.)
 | OnManipulationInertiaStarting(ManipulationInertiaStartingEventArgs) | (Inherited from UIElement.)
 | OnManipulationStarted(ManipulationStartedEventArgs) | (Inherited from UIElement.)
 | OnManipulationStarting(ManipulationStartingEventArgs) | (Inherited from UIElement.)
 | OnMouseDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseEnter(MouseEventArgs) | (Inherited from UIElement.)
 | OnMouseLeave(MouseEventArgs) | (Inherited from UIElement.)
 | OnMouseLeftButtonDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseLeftButtonUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseMove(MouseEventArgs) | (Inherited from UIElement.)
 | OnMouseRightButtonDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseRightButtonUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseWheel(MouseWheelEventArgs) | (Inherited from UIElement.)
 | OnPreviewDragEnter(DragEventArgs) | (Inherited from UIElement.)
 | OnPreviewDragLeave(DragEventArgs) | (Inherited from UIElement.)
 | OnPreviewDragOver(DragEventArgs) | (Inherited from UIElement.)
 | OnPreviewDrop(DragEventArgs) | (Inherited from UIElement.)
 | OnPreviewGiveFeedback(GiveFeedbackEventArgs) | (Inherited from UIElement.)
 | OnPreviewGotKeyboardFocus(KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
 | OnPreviewKeyDown(KeyEventArgs) | (Inherited from UIElement.)
 | OnPreviewKeyUp(KeyEventArgs) | (Inherited from UIElement.)
 | OnPreviewLostKeyboardFocus(KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseLeftButtonDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseLeftButtonUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseMove(MouseEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseRightButtonDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseRightButtonUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseWheel(MouseWheelEventArgs) | (Inherited from UIElement.)
 | OnPreviewQueryContinueDrag(QueryContinueDragEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusButtonDown(StylusButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusButtonUp(StylusButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusDown(StylusDownEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusInAirMove(StylusEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusInRange(StylusEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusMove(StylusEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusOutOfRange(StylusEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusSystemGesture(StylusSystemGestureEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusUp(StylusEventArgs) | (Inherited from UIElement.)
 | OnPreviewTextInput(TextCompositionEventArgs) | (Inherited from UIElement.)
 | OnPreviewTouchDown(TouchEventArgs) | (Inherited from UIElement.)
 | OnPreviewTouchMove(TouchEventArgs) | (Inherited from UIElement.)
 | OnPreviewTouchUp(TouchEventArgs) | (Inherited from UIElement.)
 | OnPropertyChanged(DependencyPropertyChangedEventArgs) | (Inherited from FrameworkElement.)
 | OnQueryContinueDrag(QueryContinueDragEventArgs) | (Inherited from UIElement.)
 | OnQueryCursor(QueryCursorEventArgs) | (Inherited from UIElement.)
 | OnRender(DrawingContext) | (Inherited from UIElement.)
 | OnRenderImpossible()()()() | Fires render impossible event
 | OnRenderSizeChanged(SizeChangedInfo) | (Inherited from FrameworkElement.)
 | OnStyleChanged(Style, Style) | (Inherited from FrameworkElement.)
 | OnStylusButtonDown(StylusButtonEventArgs) | (Inherited from UIElement.)
 | OnStylusButtonUp(StylusButtonEventArgs) | (Inherited from UIElement.)
 | OnStylusDown(StylusDownEventArgs) | (Inherited from UIElement.)
 | OnStylusEnter(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusInAirMove(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusInRange(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusLeave(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusMove(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusOutOfRange(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusSystemGesture(StylusSystemGestureEventArgs) | (Inherited from UIElement.)
 | OnStylusUp(StylusEventArgs) | (Inherited from UIElement.)
 | OnTextInput(TextCompositionEventArgs) | (Inherited from UIElement.)
 | OnToolTipClosing(ToolTipEventArgs) | (Inherited from FrameworkElement.)
 | OnToolTipOpening(ToolTipEventArgs) | (Inherited from FrameworkElement.)
 | OnTouchDown(TouchEventArgs) | (Inherited from UIElement.)
 | OnTouchEnter(TouchEventArgs) | (Inherited from UIElement.)
 | OnTouchLeave(TouchEventArgs) | (Inherited from UIElement.)
 | OnTouchMove(TouchEventArgs) | (Inherited from UIElement.)
 | OnTouchUp(TouchEventArgs) | (Inherited from UIElement.)
 | OnVisualChildrenChanged(DependencyObject, DependencyObject) | (Inherited from Visual.)
 | OnVisualParentChanged(DependencyObject) | (Inherited from FrameworkElement.)
 | Opacity | (Inherited from UIElement.)
 | OpacityMask | (Inherited from UIElement.)
 | OverridesDefaultStyle | (Inherited from FrameworkElement.)
 | paintUnderline(DrawingContext, Point, Point, UnderlineStyle, Pen) | Paints an underline
 | Parent | (Inherited from FrameworkElement.)
 | ParentLayoutInvalidated(UIElement) | (Inherited from FrameworkElement.)
 | PersistId | Obsolete. (Inherited from UIElement.)
 | PointFromScreen(Point) | (Inherited from Visual.)
 | PointToScreen(Point) | (Inherited from Visual.)
 | PredictFocus(FocusNavigationDirection) | (Inherited from FrameworkElement.)
 | PreviewDragEnter | (Inherited from UIElement.)
 | PreviewDragLeave | (Inherited from UIElement.)
 | PreviewDragOver | (Inherited from UIElement.)
 | PreviewDrop | (Inherited from UIElement.)
 | PreviewGiveFeedback | (Inherited from UIElement.)
 | PreviewGotKeyboardFocus | (Inherited from UIElement.)
 | PreviewKeyDown | (Inherited from UIElement.)
 | PreviewKeyUp | (Inherited from UIElement.)
 | PreviewLostKeyboardFocus | (Inherited from UIElement.)
 | PreviewMouseDown | (Inherited from UIElement.)
 | PreviewMouseLeftButtonDown | (Inherited from UIElement.)
 | PreviewMouseLeftButtonUp | (Inherited from UIElement.)
 | PreviewMouseMove | (Inherited from UIElement.)
 | PreviewMouseRightButtonDown | (Inherited from UIElement.)
 | PreviewMouseRightButtonUp | (Inherited from UIElement.)
 | PreviewMouseUp | (Inherited from UIElement.)
 | PreviewMouseWheel | (Inherited from UIElement.)
 | PreviewQueryContinueDrag | (Inherited from UIElement.)
 | PreviewStylusButtonDown | (Inherited from UIElement.)
 | PreviewStylusButtonUp | (Inherited from UIElement.)
 | PreviewStylusDown | (Inherited from UIElement.)
 | PreviewStylusInAirMove | (Inherited from UIElement.)
 | PreviewStylusInRange | (Inherited from UIElement.)
 | PreviewStylusMove | (Inherited from UIElement.)
 | PreviewStylusOutOfRange | (Inherited from UIElement.)
 | PreviewStylusSystemGesture | (Inherited from UIElement.)
 | PreviewStylusUp | (Inherited from UIElement.)
 | PreviewTextInput | (Inherited from UIElement.)
 | PreviewTouchDown | (Inherited from UIElement.)
 | PreviewTouchMove | (Inherited from UIElement.)
 | PreviewTouchUp | (Inherited from UIElement.)
 | QueryContinueDrag | (Inherited from UIElement.)
 | QueryCursor | (Inherited from UIElement.)
 | RaiseEvent(RoutedEventArgs) | (Inherited from UIElement.)
 | ReadLocalValue(DependencyProperty) | (Inherited from DependencyObject.)
 | RegisterName(String, Object) | (Inherited from FrameworkElement.)
 | ReleaseAllTouchCaptures()()()() | (Inherited from UIElement.)
 | ReleaseMouseCapture()()()() | (Inherited from UIElement.)
 | ReleaseStylusCapture()()()() | (Inherited from UIElement.)
 | ReleaseTouchCapture(TouchDevice) | (Inherited from UIElement.)
 | RemoveHandler(RoutedEvent, Delegate) | (Inherited from UIElement.)
 | RemoveLogicalChild(Object) | (Inherited from FrameworkElement.)
 | RemoveVisualChild(Visual) | (Inherited from Visual.)
 | RenderSize | (Inherited from UIElement.)
 | RenderTransform | (Inherited from UIElement.)
 | RenderTransformOrigin | (Inherited from UIElement.)
 | RequestBringIntoView | (Inherited from FrameworkElement.)
 | Resources | (Inherited from FrameworkElement.)
 | scroller_ScrollChanged(Object, ScrollChangedEventArgs) |
 | SetBinding(DependencyProperty, BindingBase) | (Inherited from FrameworkElement.)
 | SetBinding(DependencyProperty, String) | (Inherited from FrameworkElement.)
 | SetCurrentValue(DependencyProperty, Object) | (Inherited from DependencyObject.)
 | SetResourceReference(DependencyProperty, Object) | (Inherited from FrameworkElement.)
 | SetValue(DependencyProperty, Object) | (Inherited from DependencyObject.)
 | SetValue(DependencyPropertyKey, Object) | (Inherited from DependencyObject.)
 | ShouldSerializeCommandBindings()()()() | (Inherited from UIElement.)
 | ShouldSerializeInputBindings()()()() | (Inherited from UIElement.)
 | ShouldSerializeProperty(DependencyProperty) | (Inherited from DependencyObject.)
 | ShouldSerializeResources()()()() | (Inherited from FrameworkElement.)
 | ShouldSerializeStyle()()()() | (Inherited from FrameworkElement.)
 | ShouldSerializeTriggers()()()() | (Inherited from FrameworkElement.)
 | SizeChanged | (Inherited from FrameworkElement.)
 | SnapsToDevicePixels | (Inherited from UIElement.)
 | SourceUpdated | (Inherited from FrameworkElement.)
 | start | Error position.
 | Style | (Inherited from FrameworkElement.)
 | StylusButtonDown | (Inherited from UIElement.)
 | StylusButtonUp | (Inherited from UIElement.)
 | StylusDown | (Inherited from UIElement.)
 | StylusEnter | (Inherited from UIElement.)
 | StylusInAirMove | (Inherited from UIElement.)
 | StylusInRange | (Inherited from UIElement.)
 | StylusLeave | (Inherited from UIElement.)
 | StylusMove | (Inherited from UIElement.)
 | StylusOutOfRange | (Inherited from UIElement.)
 | StylusPlugIns | (Inherited from UIElement.)
 | StylusSystemGesture | (Inherited from UIElement.)
 | StylusUp | (Inherited from UIElement.)
 | Tag | (Inherited from FrameworkElement.)
 | TargetUpdated | (Inherited from FrameworkElement.)
 | tbb | The text box
 | tbb_TextChanged(Object, TextChangedEventArgs) |
 | TemplatedParent | (Inherited from FrameworkElement.)
 | TextInput | (Inherited from UIElement.)
 | ToolTip | (Inherited from FrameworkElement.)
 | ToolTipClosing | (Inherited from FrameworkElement.)
 | ToolTipOpening | (Inherited from FrameworkElement.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | TouchDown | (Inherited from UIElement.)
 | TouchEnter | (Inherited from UIElement.)
 | TouchesCaptured | (Inherited from UIElement.)
 | TouchesCapturedWithin | (Inherited from UIElement.)
 | TouchesDirectlyOver | (Inherited from UIElement.)
 | TouchesOver | (Inherited from UIElement.)
 | TouchLeave | (Inherited from UIElement.)
 | TouchMove | (Inherited from UIElement.)
 | TouchUp | (Inherited from UIElement.)
 | TransformToAncestor(Visual) | (Inherited from Visual.)
 | TransformToAncestor(Visual3D) | (Inherited from Visual.)
 | TransformToDescendant(Visual) | (Inherited from Visual.)
 | TransformToVisual(Visual) | (Inherited from Visual.)
 | TranslatePoint(Point, UIElement) | (Inherited from UIElement.)
 | Triggers | (Inherited from FrameworkElement.)
 | TryFindResource(Object) | (Inherited from FrameworkElement.)
 | Uid | (Inherited from UIElement.)
 | Unloaded | (Inherited from FrameworkElement.)
 | Unregister()()()() | Cleans up event handlers
 | UnregisterName(String) | (Inherited from FrameworkElement.)
 | UpdateDefaultStyle()()()() | (Inherited from FrameworkElement.)
 | UpdateLayout()()()() | (Inherited from UIElement.)
 | UpdateUnderlinePosition(Int32, Int32) | We're putting the underline in a new position.
 | UseLayoutRounding | (Inherited from FrameworkElement.)
 | VerifyAccess()()()() | (Inherited from DispatcherObject.)
 | VerticalAlignment | (Inherited from FrameworkElement.)
 | Visibility | (Inherited from UIElement.)
 | VisualBitmapEffect | Obsolete. (Inherited from Visual.)
 | VisualBitmapEffectInput | Obsolete. (Inherited from Visual.)
 | VisualBitmapScalingMode | (Inherited from Visual.)
 | VisualCacheMode | (Inherited from Visual.)
 | VisualChildrenCount | (Inherited from FrameworkElement.)
 | VisualClearTypeHint | (Inherited from Visual.)
 | VisualClip | (Inherited from Visual.)
 | VisualEdgeMode | (Inherited from Visual.)
 | VisualEffect | (Inherited from Visual.)
 | VisualOffset | (Inherited from Visual.)
 | VisualOpacity | (Inherited from Visual.)
 | VisualOpacityMask | (Inherited from Visual.)
 | VisualParent | (Inherited from Visual.)
 | VisualScrollableAreaClip | (Inherited from Visual.)
 | VisualTextHintingMode | (Inherited from Visual.)
 | VisualTextRenderingMode | (Inherited from Visual.)
 | VisualTransform | (Inherited from Visual.)
 | VisualXSnappingGuidelines | (Inherited from Visual.)
 | VisualYSnappingGuidelines | (Inherited from Visual.)
 | Width | (Inherited from FrameworkElement.)
Inheritance Hierarchy
Object
 | DispatcherObject
 |  | DependencyObject
 |  |  | Visual
 |  |  |  | UIElement
 |  |  |  |  | FrameworkElement
 |  |  |  |  |  | Adorner
 |  |  |  |  |  |  | ErrorAdornerBase
 |  |  |  |  |  |  |  | ErrorAdorner
 |  |  |  |  |  |  |  | RichErrorAdorner


ErrorAdornerBase Constructor (tbb, u, c)

ErrorAdornerBase Constructor (tbb, u, c)
API ► Keyoti.RapidSpell.Wpf ► ErrorAdornerBase ► ErrorAdornerBase(TextBoxBase, UnderlineStyle, Color)
Keyoti RapidSpell WPF
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ErrorAdornerBase(
    TextBoxBase tbb,
    UnderlineStyle u,
    Color c
)
public ErrorAdornerBase(
    TextBoxBase tbb,
    UnderlineStyle u,
    Color c
)
Public Sub New (
    tbb As TextBoxBase,
    u As UnderlineStyle,
    c As Color
)
Public Sub New (
    tbb As TextBoxBase,
    u As UnderlineStyle,
    c As Color
)
public:
ErrorAdornerBase(
    TextBoxBase^ tbb,
    UnderlineStyle u,
    Color c
)
public:
ErrorAdornerBase(
    TextBoxBase^ tbb,
    UnderlineStyle u,
    Color c
)
new :
        tbb : TextBoxBase *
        u : UnderlineStyle *
        c : Color -> ErrorAdornerBase
new :
        tbb : TextBoxBase *
        u : UnderlineStyle *
        c : Color -> ErrorAdornerBase
Parameters
tbb (TextBoxBase)
u (UnderlineStyle)
c (Color)


Active Property

Active Property
API ► Keyoti.RapidSpell.Wpf ► ErrorAdornerBase ► Active
Keyoti RapidSpell WPF
Whether this adorner is ever visible. It can be inactive if the word it is highlighting is ignored.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool Active { get; set; }
public bool Active { get; set; }
Public Property Active As Boolean
    Get
    Set
Public Property Active As Boolean
    Get
    Set
public:
property bool Active {
    bool get ();
    void set (bool value);
}
public:
property bool Active {
    bool get ();
    void set (bool value);
}
member Active : bool with get, set

member Active : bool with get, set
Property Value
Boolean


BumpUnderlineTo Method (start, end)

BumpUnderlineTo Method (start, end)
API ► Keyoti.RapidSpell.Wpf ► ErrorAdornerBase ► BumpUnderlineTo(Int32, Int32)
Keyoti RapidSpell WPF
The underline has moved because the text has been bumped along by new or removed text before it.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void BumpUnderlineTo(
    int start,
    int end
)
public virtual void BumpUnderlineTo(
    int start,
    int end
)
Public Overridable Sub BumpUnderlineTo (
    start As Integer,
    end As Integer
)
Public Overridable Sub BumpUnderlineTo (
    start As Integer,
    end As Integer
)
public:
virtual void BumpUnderlineTo(
    int start,
    int end
)
public:
virtual void BumpUnderlineTo(
    int start,
    int end
)
abstract BumpUnderlineTo :
        start : int *
        end : int -> unit
override BumpUnderlineTo :
        start : int *
        end : int -> unit
abstract BumpUnderlineTo :
        start : int *
        end : int -> unit
override BumpUnderlineTo :
        start : int *
        end : int -> unit
Parameters
start (Int32)
end (Int32)


cheat Field

cheat Field
API ► Keyoti.RapidSpell.Wpf ► ErrorAdornerBase ► cheat
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected IAdornerPaintCheat cheat
protected IAdornerPaintCheat cheat
Protected cheat As IAdornerPaintCheat
Protected cheat As IAdornerPaintCheat
protected:
IAdornerPaintCheat^ cheat
protected:
IAdornerPaintCheat^ cheat
val mutable cheat: IAdornerPaintCheat
val mutable cheat: IAdornerPaintCheat
Field Value
IAdornerPaintCheat


Color Property

Color Property
API ► Keyoti.RapidSpell.Wpf ► ErrorAdornerBase ► Color
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Color Color { get; }
public Color Color { get; }
Public ReadOnly Property Color As Color
    Get
Public ReadOnly Property Color As Color
    Get
public:
property Color Color {
    Color get ();
}
public:
property Color Color {
    Color get ();
}
member Color : Color with get

member Color : Color with get
Property Value
Color


ConnectAndPaint Method (drawingContext, selectionStartPos_scr, selectionEndPos_scr)

ConnectAndPaint Method (drawingContext, selectionStartPos_scr, selectionEndPos_scr)
API ► Keyoti.RapidSpell.Wpf ► ErrorAdornerBase ► ConnectAndPaint(DrawingContext, Rect, Rect)
Keyoti RapidSpell WPF
Paints underline between two Rects
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected void ConnectAndPaint(
    DrawingContext drawingContext,
    Rect selectionStartPos_scr,
    Rect selectionEndPos_scr
)
protected void ConnectAndPaint(
    DrawingContext drawingContext,
    Rect selectionStartPos_scr,
    Rect selectionEndPos_scr
)
Protected Sub ConnectAndPaint (
    drawingContext As DrawingContext,
    selectionStartPos_scr As Rect,
    selectionEndPos_scr As Rect
)
Protected Sub ConnectAndPaint (
    drawingContext As DrawingContext,
    selectionStartPos_scr As Rect,
    selectionEndPos_scr As Rect
)
protected:
void ConnectAndPaint(
    DrawingContext^ drawingContext,
    Rect selectionStartPos_scr,
    Rect selectionEndPos_scr
)
protected:
void ConnectAndPaint(
    DrawingContext^ drawingContext,
    Rect selectionStartPos_scr,
    Rect selectionEndPos_scr
)
member ConnectAndPaint :
        drawingContext : DrawingContext *
        selectionStartPos_scr : Rect *
        selectionEndPos_scr : Rect -> unit

member ConnectAndPaint :
        drawingContext : DrawingContext *
        selectionStartPos_scr : Rect *
        selectionEndPos_scr : Rect -> unit
Parameters
drawingContext (DrawingContext)
selectionStartPos_scr (Rect)
selectionEndPos_scr (Rect)


end Field

end Field
API ► Keyoti.RapidSpell.Wpf ► ErrorAdornerBase ► end
Keyoti RapidSpell WPF
Error position.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected internal int end
protected internal int end
Protected Friend end As Integer
Protected Friend end As Integer
protected public:
int end
protected public:
int end
val mutable end: int
val mutable end: int
Field Value
Int32


HighlightFillBrush Property

HighlightFillBrush Property
API ► Keyoti.RapidSpell.Wpf ► ErrorAdornerBase ► HighlightFillBrush
Keyoti RapidSpell WPF
The highlight brush
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Brush HighlightFillBrush { get; set; }
public Brush HighlightFillBrush { get; set; }
Public Property HighlightFillBrush As Brush
    Get
    Set
Public Property HighlightFillBrush As Brush
    Get
    Set
public:
property Brush^ HighlightFillBrush {
    Brush^ get ();
    void set (Brush^ value);
}
public:
property Brush^ HighlightFillBrush {
    Brush^ get ();
    void set (Brush^ value);
}
member HighlightFillBrush : Brush with get, set

member HighlightFillBrush : Brush with get, set
Property Value
Brush


HighlightLinePen Property

HighlightLinePen Property
API ► Keyoti.RapidSpell.Wpf ► ErrorAdornerBase ► HighlightLinePen
Keyoti RapidSpell WPF
The highlight pen
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Pen HighlightLinePen { get; set; }
public Pen HighlightLinePen { get; set; }
Public Property HighlightLinePen As Pen
    Get
    Set
Public Property HighlightLinePen As Pen
    Get
    Set
public:
property Pen^ HighlightLinePen {
    Pen^ get ();
    void set (Pen^ value);
}
public:
property Pen^ HighlightLinePen {
    Pen^ get ();
    void set (Pen^ value);
}
member HighlightLinePen : Pen with get, set

member HighlightLinePen : Pen with get, set
Property Value
Pen


iayt Field

iayt Field
API ► Keyoti.RapidSpell.Wpf ► ErrorAdornerBase ► iayt
Keyoti RapidSpell WPF
The IAYT interface cast of the text box wrapper
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected IAYTTextBox iayt
protected IAYTTextBox iayt
Protected iayt As IAYTTextBox
Protected iayt As IAYTTextBox
protected:
IAYTTextBox^ iayt
protected:
IAYTTextBox^ iayt
val mutable iayt: IAYTTextBox
val mutable iayt: IAYTTextBox
Field Value
IAYTTextBox


IsAt Method (start, end)

IsAt Method (start, end)
API ► Keyoti.RapidSpell.Wpf ► ErrorAdornerBase ► IsAt(Int32, Int32)
Keyoti RapidSpell WPF
Whether this highlight is at start to end
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IsAt(
    int start,
    int end
)
public bool IsAt(
    int start,
    int end
)
Public Function IsAt (
    start As Integer,
    end As Integer
) As Boolean
Public Function IsAt (
    start As Integer,
    end As Integer
) As Boolean
public:
bool IsAt(
    int start,
    int end
)
public:
bool IsAt(
    int start,
    int end
)
member IsAt :
        start : int *
        end : int -> bool

member IsAt :
        start : int *
        end : int -> bool
Parameters
start (Int32)
end (Int32)
Return Value
Boolean


numberOfFailedRenderAttempts Field

numberOfFailedRenderAttempts Field
API ► Keyoti.RapidSpell.Wpf ► ErrorAdornerBase ► numberOfFailedRenderAttempts
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected int numberOfFailedRenderAttempts
protected int numberOfFailedRenderAttempts
Protected numberOfFailedRenderAttempts As Integer
Protected numberOfFailedRenderAttempts As Integer
protected:
int numberOfFailedRenderAttempts
protected:
int numberOfFailedRenderAttempts
val mutable numberOfFailedRenderAttempts: int
val mutable numberOfFailedRenderAttempts: int
Field Value
Int32


OnActiveChanged Method (value)

OnActiveChanged Method (value)
API ► Keyoti.RapidSpell.Wpf ► ErrorAdornerBase ► OnActiveChanged(Boolean)
Keyoti RapidSpell WPF
Active property has changed
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void OnActiveChanged(
    bool value
)
protected virtual void OnActiveChanged(
    bool value
)
Protected Overridable Sub OnActiveChanged (
    value As Boolean
)
Protected Overridable Sub OnActiveChanged (
    value As Boolean
)
protected:
virtual void OnActiveChanged(
    bool value
)
protected:
virtual void OnActiveChanged(
    bool value
)
abstract OnActiveChanged :
        value : bool -> unit
override OnActiveChanged :
        value : bool -> unit
abstract OnActiveChanged :
        value : bool -> unit
override OnActiveChanged :
        value : bool -> unit
Parameters
value (Boolean)


OnRenderImpossible Method

OnRenderImpossible Method
API ► Keyoti.RapidSpell.Wpf ► ErrorAdornerBase ► OnRenderImpossible()()()()
Keyoti RapidSpell WPF
Fires render impossible event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected void OnRenderImpossible()
protected void OnRenderImpossible()
Protected Sub OnRenderImpossible
Protected Sub OnRenderImpossible
protected:
void OnRenderImpossible()
protected:
void OnRenderImpossible()
member OnRenderImpossible : unit -> unit

member OnRenderImpossible : unit -> unit


paintUnderline Method (g, start, end, style, pen)

paintUnderline Method (g, start, end, style, pen)
API ► Keyoti.RapidSpell.Wpf ► ErrorAdornerBase ► paintUnderline(DrawingContext, Point, Point, UnderlineStyle, Pen)
Keyoti RapidSpell WPF
Paints an underline
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static void paintUnderline(
    DrawingContext g,
    Point start,
    Point end,
    UnderlineStyle style,
    Pen pen
)
public static void paintUnderline(
    DrawingContext g,
    Point start,
    Point end,
    UnderlineStyle style,
    Pen pen
)
Public Shared Sub paintUnderline (
    g As DrawingContext,
    start As Point,
    end As Point,
    style As UnderlineStyle,
    pen As Pen
)
Public Shared Sub paintUnderline (
    g As DrawingContext,
    start As Point,
    end As Point,
    style As UnderlineStyle,
    pen As Pen
)
public:
static void paintUnderline(
    DrawingContext^ g,
    Point start,
    Point end,
    UnderlineStyle style,
    Pen^ pen
)
public:
static void paintUnderline(
    DrawingContext^ g,
    Point start,
    Point end,
    UnderlineStyle style,
    Pen^ pen
)
static member paintUnderline :
        g : DrawingContext *
        start : Point *
        end : Point *
        style : UnderlineStyle *
        pen : Pen -> unit

static member paintUnderline :
        g : DrawingContext *
        start : Point *
        end : Point *
        style : UnderlineStyle *
        pen : Pen -> unit
Parameters
g (DrawingContext)
start (Point)
end (Point)
style (UnderlineStyle)
pen (Pen)


scroller_ScrollChanged Method (sender, e)

scroller_ScrollChanged Method (sender, e)
API ► Keyoti.RapidSpell.Wpf ► ErrorAdornerBase ► scroller_ScrollChanged(Object, ScrollChangedEventArgs)
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void scroller_ScrollChanged(
    Object sender,
    ScrollChangedEventArgs e
)
protected virtual void scroller_ScrollChanged(
    Object sender,
    ScrollChangedEventArgs e
)
Protected Overridable Sub scroller_ScrollChanged (
    sender As Object,
    e As ScrollChangedEventArgs
)
Protected Overridable Sub scroller_ScrollChanged (
    sender As Object,
    e As ScrollChangedEventArgs
)
protected:
virtual void scroller_ScrollChanged(
    Object^ sender,
    ScrollChangedEventArgs^ e
)
protected:
virtual void scroller_ScrollChanged(
    Object^ sender,
    ScrollChangedEventArgs^ e
)
abstract scroller_ScrollChanged :
        sender : Object *
        e : ScrollChangedEventArgs -> unit
override scroller_ScrollChanged :
        sender : Object *
        e : ScrollChangedEventArgs -> unit
abstract scroller_ScrollChanged :
        sender : Object *
        e : ScrollChangedEventArgs -> unit
override scroller_ScrollChanged :
        sender : Object *
        e : ScrollChangedEventArgs -> unit
Parameters
sender (Object)
e (ScrollChangedEventArgs)


start Field

start Field
API ► Keyoti.RapidSpell.Wpf ► ErrorAdornerBase ► start
Keyoti RapidSpell WPF
Error position.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected internal int start
protected internal int start
Protected Friend start As Integer
Protected Friend start As Integer
protected public:
int start
protected public:
int start
val mutable start: int
val mutable start: int
Field Value
Int32


tbb Field

tbb Field
API ► Keyoti.RapidSpell.Wpf ► ErrorAdornerBase ► tbb
Keyoti RapidSpell WPF
The text box
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected TextBoxBase tbb
protected TextBoxBase tbb
Protected tbb As TextBoxBase
Protected tbb As TextBoxBase
protected:
TextBoxBase^ tbb
protected:
TextBoxBase^ tbb
val mutable tbb: TextBoxBase
val mutable tbb: TextBoxBase
Field Value
TextBoxBase


tbb_TextChanged Method (sender, e)

tbb_TextChanged Method (sender, e)
API ► Keyoti.RapidSpell.Wpf ► ErrorAdornerBase ► tbb_TextChanged(Object, TextChangedEventArgs)
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void tbb_TextChanged(
    Object sender,
    TextChangedEventArgs e
)
protected virtual void tbb_TextChanged(
    Object sender,
    TextChangedEventArgs e
)
Protected Overridable Sub tbb_TextChanged (
    sender As Object,
    e As TextChangedEventArgs
)
Protected Overridable Sub tbb_TextChanged (
    sender As Object,
    e As TextChangedEventArgs
)
protected:
virtual void tbb_TextChanged(
    Object^ sender,
    TextChangedEventArgs^ e
)
protected:
virtual void tbb_TextChanged(
    Object^ sender,
    TextChangedEventArgs^ e
)
abstract tbb_TextChanged :
        sender : Object *
        e : TextChangedEventArgs -> unit
override tbb_TextChanged :
        sender : Object *
        e : TextChangedEventArgs -> unit
abstract tbb_TextChanged :
        sender : Object *
        e : TextChangedEventArgs -> unit
override tbb_TextChanged :
        sender : Object *
        e : TextChangedEventArgs -> unit
Parameters
sender (Object)
e (TextChangedEventArgs)


Unregister Method

Unregister Method
API ► Keyoti.RapidSpell.Wpf ► ErrorAdornerBase ► Unregister()()()()
Keyoti RapidSpell WPF
Cleans up event handlers
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void Unregister()
public virtual void Unregister()
Public Overridable Sub Unregister
Public Overridable Sub Unregister
public:
virtual void Unregister()
public:
virtual void Unregister()
abstract Unregister : unit -> unit
override Unregister : unit -> unit
abstract Unregister : unit -> unit
override Unregister : unit -> unit


UpdateUnderlinePosition Method (start, end)

UpdateUnderlinePosition Method (start, end)
API ► Keyoti.RapidSpell.Wpf ► ErrorAdornerBase ► UpdateUnderlinePosition(Int32, Int32)
Keyoti RapidSpell WPF
We're putting the underline in a new position.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void UpdateUnderlinePosition(
    int start,
    int end
)
public virtual void UpdateUnderlinePosition(
    int start,
    int end
)
Public Overridable Sub UpdateUnderlinePosition (
    start As Integer,
    end As Integer
)
Public Overridable Sub UpdateUnderlinePosition (
    start As Integer,
    end As Integer
)
public:
virtual void UpdateUnderlinePosition(
    int start,
    int end
)
public:
virtual void UpdateUnderlinePosition(
    int start,
    int end
)
abstract UpdateUnderlinePosition :
        start : int *
        end : int -> unit
override UpdateUnderlinePosition :
        start : int *
        end : int -> unit
abstract UpdateUnderlinePosition :
        start : int *
        end : int -> unit
override UpdateUnderlinePosition :
        start : int *
        end : int -> unit
Parameters
start (Int32)
end (Int32)


FoundSpellingErrorEventArgs Class

FoundSpellingErrorEventArgs Class
API ► Keyoti.RapidSpell.Wpf ► FoundSpellingErrorEventArgs
Keyoti RapidSpell WPF
Event args for found error event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class FoundSpellingErrorEventArgs : EventArgs
public class FoundSpellingErrorEventArgs : EventArgs
Public Class FoundSpellingErrorEventArgs
    Inherits EventArgs
Public Class FoundSpellingErrorEventArgs
    Inherits EventArgs
public ref class FoundSpellingErrorEventArgs : public EventArgs
public ref class FoundSpellingErrorEventArgs : public EventArgs
type FoundSpellingErrorEventArgs =
    class
        inherit EventArgs
    end
type FoundSpellingErrorEventArgs =
    class
        inherit EventArgs
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FoundSpellingErrorEventArgs(BadWord, IAYTTextBox) | New
 | BadWord | The misspelling
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Replacement | Any replacement to use for the misspelling, only used by RapidSpellAsYouType
 | TextBox | The textbox being checked
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | FoundSpellingErrorEventArgs


FoundSpellingErrorEventArgs Constructor (theBadWord, textBox)

FoundSpellingErrorEventArgs Constructor (theBadWord, textBox)
API ► Keyoti.RapidSpell.Wpf ► FoundSpellingErrorEventArgs ► FoundSpellingErrorEventArgs(BadWord, IAYTTextBox)
Keyoti RapidSpell WPF
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public FoundSpellingErrorEventArgs(
    BadWord theBadWord,
    IAYTTextBox textBox
)
public FoundSpellingErrorEventArgs(
    BadWord theBadWord,
    IAYTTextBox textBox
)
Public Sub New (
    theBadWord As BadWord,
    textBox As IAYTTextBox
)
Public Sub New (
    theBadWord As BadWord,
    textBox As IAYTTextBox
)
public:
FoundSpellingErrorEventArgs(
    BadWord^ theBadWord,
    IAYTTextBox^ textBox
)
public:
FoundSpellingErrorEventArgs(
    BadWord^ theBadWord,
    IAYTTextBox^ textBox
)
new :
        theBadWord : BadWord *
        textBox : IAYTTextBox -> FoundSpellingErrorEventArgs
new :
        theBadWord : BadWord *
        textBox : IAYTTextBox -> FoundSpellingErrorEventArgs
Parameters
theBadWord (BadWord)
textBox (IAYTTextBox)


BadWord Property

BadWord Property
API ► Keyoti.RapidSpell.Wpf ► FoundSpellingErrorEventArgs ► BadWord
Keyoti RapidSpell WPF
The misspelling
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public BadWord BadWord { get; set; }
public BadWord BadWord { get; set; }
Public Property BadWord As BadWord
    Get
    Set
Public Property BadWord As BadWord
    Get
    Set
public:
property BadWord^ BadWord {
    BadWord^ get ();
    void set (BadWord^ value);
}
public:
property BadWord^ BadWord {
    BadWord^ get ();
    void set (BadWord^ value);
}
member BadWord : BadWord with get, set

member BadWord : BadWord with get, set
Property Value
BadWord


Replacement Property

Replacement Property
API ► Keyoti.RapidSpell.Wpf ► FoundSpellingErrorEventArgs ► Replacement
Keyoti RapidSpell WPF
Any replacement to use for the misspelling, only used by RapidSpellAsYouType
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string Replacement { get; set; }
public string Replacement { get; set; }
Public Property Replacement As String
    Get
    Set
Public Property Replacement As String
    Get
    Set
public:
property String^ Replacement {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Replacement {
    String^ get ();
    void set (String^ value);
}
member Replacement : string with get, set

member Replacement : string with get, set
Property Value
String


TextBox Property

TextBox Property
API ► Keyoti.RapidSpell.Wpf ► FoundSpellingErrorEventArgs ► TextBox
Keyoti RapidSpell WPF
The textbox being checked
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public IAYTTextBox TextBox { get; }
public IAYTTextBox TextBox { get; }
Public ReadOnly Property TextBox As IAYTTextBox
    Get
Public ReadOnly Property TextBox As IAYTTextBox
    Get
public:
property IAYTTextBox^ TextBox {
    IAYTTextBox^ get ();
}
public:
property IAYTTextBox^ TextBox {
    IAYTTextBox^ get ();
}
member TextBox : IAYTTextBox with get

member TextBox : IAYTTextBox with get
Property Value
IAYTTextBox


FoundSpellingErrorEventHandler Delegate

FoundSpellingErrorEventHandler Delegate
API ► Keyoti.RapidSpell.Wpf ► FoundSpellingErrorEventHandler
Keyoti RapidSpell WPF
EventHandler delegate
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void FoundSpellingErrorEventHandler(
    Object s,
    FoundSpellingErrorEventArgs e
)
public delegate void FoundSpellingErrorEventHandler(
    Object s,
    FoundSpellingErrorEventArgs e
)
Public Delegate Sub FoundSpellingErrorEventHandler (
    s As Object,
    e As FoundSpellingErrorEventArgs
)
Public Delegate Sub FoundSpellingErrorEventHandler (
    s As Object,
    e As FoundSpellingErrorEventArgs
)
public delegate void FoundSpellingErrorEventHandler(
    Object^ s,
    FoundSpellingErrorEventArgs^ e
)
public delegate void FoundSpellingErrorEventHandler(
    Object^ s,
    FoundSpellingErrorEventArgs^ e
)
type FoundSpellingErrorEventHandler =
    delegate of
        s : Object *
        e : FoundSpellingErrorEventArgs -> unit
type FoundSpellingErrorEventHandler =
    delegate of
        s : Object *
        e : FoundSpellingErrorEventArgs -> unit
Parameters
s (Object)
e (FoundSpellingErrorEventArgs)


IAdornerPaintCheat Interface

IAdornerPaintCheat Interface
API ► Keyoti.RapidSpell.Wpf ► IAdornerPaintCheat
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public interface IAdornerPaintCheat
public interface IAdornerPaintCheat
Public Interface IAdornerPaintCheat
Public Interface IAdornerPaintCheat
public interface class IAdornerPaintCheat
public interface class IAdornerPaintCheat
type IAdornerPaintCheat =  interface end
type IAdornerPaintCheat =  interface end
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Invalidate()()()() |
 | IsValid |
 | Refresh()()()() |


Invalidate Method

Invalidate Method
API ► Keyoti.RapidSpell.Wpf ► IAdornerPaintCheat ► Invalidate()()()()
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void Invalidate()
void Invalidate()
Sub Invalidate
Sub Invalidate
void Invalidate()
void Invalidate()
abstract Invalidate : unit -> unit

abstract Invalidate : unit -> unit


IsValid Property

IsValid Property
API ► Keyoti.RapidSpell.Wpf ► IAdornerPaintCheat ► IsValid
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool IsValid { get; }
bool IsValid { get; }
ReadOnly Property IsValid As Boolean
    Get
ReadOnly Property IsValid As Boolean
    Get
property bool IsValid {
    bool get ();
}
property bool IsValid {
    bool get ();
}
abstract IsValid : bool with get

abstract IsValid : bool with get
Property Value
Boolean


Refresh Method

Refresh Method
API ► Keyoti.RapidSpell.Wpf ► IAdornerPaintCheat ► Refresh()()()()
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void Refresh()
void Refresh()
Sub Refresh
Sub Refresh
void Refresh()
void Refresh()
abstract Refresh : unit -> unit

abstract Refresh : unit -> unit


IAYTTextBox Interface

IAYTTextBox Interface
API ► Keyoti.RapidSpell.Wpf ► IAYTTextBox
Keyoti RapidSpell WPF
Interface requirements for an "as-you-type" text box, if an object implements this interface then it is compatible with the RapidSpellAYT control.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public interface IAYTTextBox
public interface IAYTTextBox
Public Interface IAYTTextBox
Public Interface IAYTTextBox
public interface class IAYTTextBox
public interface class IAYTTextBox
type IAYTTextBox =  interface end
type IAYTTextBox =  interface end
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ContextMenu | The context menu that will be shown when the right click is on a misspelled word.
 | ContextMenuDefault | The context menu that will be shown when the right click is not on a misspelled word.
 | ContextMenuOpening | Fired when the context menu is opening
 | Dispose()()()() | Clean resources, remove references
 | Disposed | Event fires when component is Disposed.
 | Enabled | Whether the textbox is enabled
 | GetBaselineOffsetAtCharIndex(Int32) | Gets the Y offset of the baseline from the position returned by GetPosFromCharIndex for a particular character.
 | GetCharIndexFromPos(Point) | gets the char index from a position point.
 | GetPosFromCharIndex(Int32) | Gets the position point from the char index.
 | GetTBU()()()() | Returns the WpfTextBoxBaseUtilityAdapter, this is used to paint and track underlines.
 | GotFocus | Focus changed
 | Height | Gets or sets the height of the control.
 | IsAtWordBoundaryRight | Returns whether the caret is at a right hand word boundary.
 | IsEnabledChanged | IsEnabled has changed
 | IsFocused | Whether the text box is currently focused.
 | KeyDown | Occurs when a key is pressed while the control has focus.
 | KeyUp | Occurs when a key is released while the control has focus.
 | LostFocus | Focus changed
 | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed.
 | MouseUp | Occurs when the mouse is released on the text box.
 | ReadOnly | Whether the textbox is readonly
 | Refresh()()()() | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
 | SelectedText | Gets or sets a value indicating the currently selected text in the control.
 | SelectionLength | Gets or sets the number of characters selected in the text box.
 | SelectionStart | Gets or sets the starting point of text selected in the text box.
 | Text | Gets or sets the current text in the text box.
 | TextChanged | Occurs when the Text property value changes.
 | TextLength | Gets the current text length in the text box.
 | Width | Gets or sets the width of the control.


ContextMenu Property

ContextMenu Property
API ► Keyoti.RapidSpell.Wpf ► IAYTTextBox ► ContextMenu
Keyoti RapidSpell WPF
The context menu that will be shown when the right click is on a misspelled word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
ContextMenu ContextMenu { get; set; }
ContextMenu ContextMenu { get; set; }
Property ContextMenu As ContextMenu
    Get
    Set
Property ContextMenu As ContextMenu
    Get
    Set
property ContextMenu^ ContextMenu {
    ContextMenu^ get ();
    void set (ContextMenu^ value);
}
property ContextMenu^ ContextMenu {
    ContextMenu^ get ();
    void set (ContextMenu^ value);
}
abstract ContextMenu : ContextMenu with get, set

abstract ContextMenu : ContextMenu with get, set
Property Value
ContextMenu


ContextMenuDefault Property

ContextMenuDefault Property
API ► Keyoti.RapidSpell.Wpf ► IAYTTextBox ► ContextMenuDefault
Keyoti RapidSpell WPF
The context menu that will be shown when the right click is not on a misspelled word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
ContextMenu ContextMenuDefault { get; set; }
ContextMenu ContextMenuDefault { get; set; }
Property ContextMenuDefault As ContextMenu
    Get
    Set
Property ContextMenuDefault As ContextMenu
    Get
    Set
property ContextMenu^ ContextMenuDefault {
    ContextMenu^ get ();
    void set (ContextMenu^ value);
}
property ContextMenu^ ContextMenuDefault {
    ContextMenu^ get ();
    void set (ContextMenu^ value);
}
abstract ContextMenuDefault : ContextMenu with get, set

abstract ContextMenuDefault : ContextMenu with get, set
Property Value
ContextMenu


ContextMenuOpening Event

ContextMenuOpening Event
API ► Keyoti.RapidSpell.Wpf ► IAYTTextBox ► ContextMenuOpening
Keyoti RapidSpell WPF
Fired when the context menu is opening
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event ContextMenuEventHandler ContextMenuOpening
event ContextMenuEventHandler ContextMenuOpening
Event ContextMenuOpening As ContextMenuEventHandler
Event ContextMenuOpening As ContextMenuEventHandler
 event ContextMenuEventHandler^ ContextMenuOpening {
    void add (ContextMenuEventHandler^ value);
    void remove (ContextMenuEventHandler^ value);
}
 event ContextMenuEventHandler^ ContextMenuOpening {
    void add (ContextMenuEventHandler^ value);
    void remove (ContextMenuEventHandler^ value);
}
abstract ContextMenuOpening : IEvent<ContextMenuEventHandler,
    ContextMenuEventArgs>

abstract ContextMenuOpening : IEvent<ContextMenuEventHandler,
    ContextMenuEventArgs>
Value
ContextMenuEventHandler


Dispose Method

Dispose Method
API ► Keyoti.RapidSpell.Wpf ► IAYTTextBox ► Dispose()()()()
Keyoti RapidSpell WPF
Clean resources, remove references
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void Dispose()
void Dispose()
Sub Dispose
Sub Dispose
void Dispose()
void Dispose()
abstract Dispose : unit -> unit

abstract Dispose : unit -> unit


Disposed Event

Disposed Event
API ► Keyoti.RapidSpell.Wpf ► IAYTTextBox ► Disposed
Keyoti RapidSpell WPF
Event fires when component is Disposed.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event EventHandler Disposed
event EventHandler Disposed
Event Disposed As EventHandler
Event Disposed As EventHandler
 event EventHandler^ Disposed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
 event EventHandler^ Disposed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Disposed : IEvent<EventHandler,
    EventArgs>

abstract Disposed : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


Enabled Property

Enabled Property
API ► Keyoti.RapidSpell.Wpf ► IAYTTextBox ► Enabled
Keyoti RapidSpell WPF
Whether the textbox is enabled
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool Enabled { get; }
bool Enabled { get; }
ReadOnly Property Enabled As Boolean
    Get
ReadOnly Property Enabled As Boolean
    Get
property bool Enabled {
    bool get ();
}
property bool Enabled {
    bool get ();
}
abstract Enabled : bool with get

abstract Enabled : bool with get
Property Value
Boolean
Remarks
If not supported, return true.


GetBaselineOffsetAtCharIndex Method (index)

GetBaselineOffsetAtCharIndex Method (index)
API ► Keyoti.RapidSpell.Wpf ► IAYTTextBox ► GetBaselineOffsetAtCharIndex(Int32)
Keyoti RapidSpell WPF
Gets the Y offset of the baseline from the position returned by GetPosFromCharIndex for a particular character.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
int GetBaselineOffsetAtCharIndex(
    int index
)
int GetBaselineOffsetAtCharIndex(
    int index
)
Function GetBaselineOffsetAtCharIndex (
    index As Integer
) As Integer
Function GetBaselineOffsetAtCharIndex (
    index As Integer
) As Integer
int GetBaselineOffsetAtCharIndex(
    int index
)
int GetBaselineOffsetAtCharIndex(
    int index
)
abstract GetBaselineOffsetAtCharIndex :
        index : int -> int

abstract GetBaselineOffsetAtCharIndex :
        index : int -> int
Parameters
index (Int32)
Return Value
Int32
Remarks
For example, with RichTextBox Controls GetPosFromCharIndex returns the top left coord, therefore this method must return the height of the biggest font on the line.


GetCharIndexFromPos Method (pos)

GetCharIndexFromPos Method (pos)
API ► Keyoti.RapidSpell.Wpf ► IAYTTextBox ► GetCharIndexFromPos(Point)
Keyoti RapidSpell WPF
gets the char index from a position point.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
int GetCharIndexFromPos(
    Point pos
)
int GetCharIndexFromPos(
    Point pos
)
Function GetCharIndexFromPos (
    pos As Point
) As Integer
Function GetCharIndexFromPos (
    pos As Point
) As Integer
int GetCharIndexFromPos(
    Point pos
)
int GetCharIndexFromPos(
    Point pos
)
abstract GetCharIndexFromPos :
        pos : Point -> int

abstract GetCharIndexFromPos :
        pos : Point -> int
Parameters
pos (Point)
Return Value
Int32


GetPosFromCharIndex Method (index)

GetPosFromCharIndex Method (index)
API ► Keyoti.RapidSpell.Wpf ► IAYTTextBox ► GetPosFromCharIndex(Int32)
Keyoti RapidSpell WPF
Gets the position point from the char index.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
Point GetPosFromCharIndex(
    int index
)
Point GetPosFromCharIndex(
    int index
)
Function GetPosFromCharIndex (
    index As Integer
) As Point
Function GetPosFromCharIndex (
    index As Integer
) As Point
Point GetPosFromCharIndex(
    int index
)
Point GetPosFromCharIndex(
    int index
)
abstract GetPosFromCharIndex :
        index : int -> Point

abstract GetPosFromCharIndex :
        index : int -> Point
Parameters
index (Int32)
Return Value
Point


GetTBU Method

GetTBU Method
API ► Keyoti.RapidSpell.Wpf ► IAYTTextBox ► GetTBU()()()()
Keyoti RapidSpell WPF
Returns the WpfTextBoxBaseUtilityAdapter, this is used to paint and track underlines.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
WpfTextBoxBaseUtilityAdapter GetTBU()
WpfTextBoxBaseUtilityAdapter GetTBU()
Function GetTBU As WpfTextBoxBaseUtilityAdapter
Function GetTBU As WpfTextBoxBaseUtilityAdapter
WpfTextBoxBaseUtilityAdapter^ GetTBU()
WpfTextBoxBaseUtilityAdapter^ GetTBU()
abstract GetTBU : unit -> WpfTextBoxBaseUtilityAdapter

abstract GetTBU : unit -> WpfTextBoxBaseUtilityAdapter
Return Value
WpfTextBoxBaseUtilityAdapter


GotFocus Event

GotFocus Event
API ► Keyoti.RapidSpell.Wpf ► IAYTTextBox ► GotFocus
Keyoti RapidSpell WPF
Focus changed
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event RoutedEventHandler GotFocus
event RoutedEventHandler GotFocus
Event GotFocus As RoutedEventHandler
Event GotFocus As RoutedEventHandler
 event RoutedEventHandler^ GotFocus {
    void add (RoutedEventHandler^ value);
    void remove (RoutedEventHandler^ value);
}
 event RoutedEventHandler^ GotFocus {
    void add (RoutedEventHandler^ value);
    void remove (RoutedEventHandler^ value);
}
abstract GotFocus : IEvent<RoutedEventHandler,
    RoutedEventArgs>

abstract GotFocus : IEvent<RoutedEventHandler,
    RoutedEventArgs>
Value
RoutedEventHandler


Height Property

Height Property
API ► Keyoti.RapidSpell.Wpf ► IAYTTextBox ► Height
Keyoti RapidSpell WPF
Gets or sets the height of the control.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
int Height { get; set; }
int Height { get; set; }
Property Height As Integer
    Get
    Set
Property Height As Integer
    Get
    Set
property int Height {
    int get ();
    void set (int value);
}
property int Height {
    int get ();
    void set (int value);
}
abstract Height : int with get, set

abstract Height : int with get, set
Property Value
Int32


IsAtWordBoundaryRight Property

IsAtWordBoundaryRight Property
API ► Keyoti.RapidSpell.Wpf ► IAYTTextBox ► IsAtWordBoundaryRight
Keyoti RapidSpell WPF
Returns whether the caret is at a right hand word boundary.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool IsAtWordBoundaryRight { get; }
bool IsAtWordBoundaryRight { get; }
ReadOnly Property IsAtWordBoundaryRight As Boolean
    Get
ReadOnly Property IsAtWordBoundaryRight As Boolean
    Get
property bool IsAtWordBoundaryRight {
    bool get ();
}
property bool IsAtWordBoundaryRight {
    bool get ();
}
abstract IsAtWordBoundaryRight : bool with get

abstract IsAtWordBoundaryRight : bool with get
Property Value
Boolean


IsEnabledChanged Event

IsEnabledChanged Event
API ► Keyoti.RapidSpell.Wpf ► IAYTTextBox ► IsEnabledChanged
Keyoti RapidSpell WPF
IsEnabled has changed
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event EventHandler IsEnabledChanged
event EventHandler IsEnabledChanged
Event IsEnabledChanged As EventHandler
Event IsEnabledChanged As EventHandler
 event EventHandler^ IsEnabledChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
 event EventHandler^ IsEnabledChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract IsEnabledChanged : IEvent<EventHandler,
    EventArgs>

abstract IsEnabledChanged : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


IsFocused Property

IsFocused Property
API ► Keyoti.RapidSpell.Wpf ► IAYTTextBox ► IsFocused
Keyoti RapidSpell WPF
Whether the text box is currently focused.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool IsFocused { get; }
bool IsFocused { get; }
ReadOnly Property IsFocused As Boolean
    Get
ReadOnly Property IsFocused As Boolean
    Get
property bool IsFocused {
    bool get ();
}
property bool IsFocused {
    bool get ();
}
abstract IsFocused : bool with get

abstract IsFocused : bool with get
Property Value
Boolean


KeyDown Event

KeyDown Event
API ► Keyoti.RapidSpell.Wpf ► IAYTTextBox ► KeyDown
Keyoti RapidSpell WPF
Occurs when a key is pressed while the control has focus.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event KeyEventHandler KeyDown
event KeyEventHandler KeyDown
Event KeyDown As KeyEventHandler
Event KeyDown As KeyEventHandler
 event KeyEventHandler^ KeyDown {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}
 event KeyEventHandler^ KeyDown {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}
abstract KeyDown : IEvent<KeyEventHandler,
    KeyEventArgs>

abstract KeyDown : IEvent<KeyEventHandler,
    KeyEventArgs>
Value
KeyEventHandler


KeyUp Event

KeyUp Event
API ► Keyoti.RapidSpell.Wpf ► IAYTTextBox ► KeyUp
Keyoti RapidSpell WPF
Occurs when a key is released while the control has focus.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event KeyEventHandler KeyUp
event KeyEventHandler KeyUp
Event KeyUp As KeyEventHandler
Event KeyUp As KeyEventHandler
 event KeyEventHandler^ KeyUp {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}
 event KeyEventHandler^ KeyUp {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}
abstract KeyUp : IEvent<KeyEventHandler,
    KeyEventArgs>

abstract KeyUp : IEvent<KeyEventHandler,
    KeyEventArgs>
Value
KeyEventHandler


LostFocus Event

LostFocus Event
API ► Keyoti.RapidSpell.Wpf ► IAYTTextBox ► LostFocus
Keyoti RapidSpell WPF
Focus changed
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event RoutedEventHandler LostFocus
event RoutedEventHandler LostFocus
Event LostFocus As RoutedEventHandler
Event LostFocus As RoutedEventHandler
 event RoutedEventHandler^ LostFocus {
    void add (RoutedEventHandler^ value);
    void remove (RoutedEventHandler^ value);
}
 event RoutedEventHandler^ LostFocus {
    void add (RoutedEventHandler^ value);
    void remove (RoutedEventHandler^ value);
}
abstract LostFocus : IEvent<RoutedEventHandler,
    RoutedEventArgs>

abstract LostFocus : IEvent<RoutedEventHandler,
    RoutedEventArgs>
Value
RoutedEventHandler


MouseDown Event

MouseDown Event
API ► Keyoti.RapidSpell.Wpf ► IAYTTextBox ► MouseDown
Keyoti RapidSpell WPF
Occurs when the mouse pointer is over the control and a mouse button is pressed.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event MouseButtonEventHandler MouseDown
event MouseButtonEventHandler MouseDown
Event MouseDown As MouseButtonEventHandler
Event MouseDown As MouseButtonEventHandler
 event MouseButtonEventHandler^ MouseDown {
    void add (MouseButtonEventHandler^ value);
    void remove (MouseButtonEventHandler^ value);
}
 event MouseButtonEventHandler^ MouseDown {
    void add (MouseButtonEventHandler^ value);
    void remove (MouseButtonEventHandler^ value);
}
abstract MouseDown : IEvent<MouseButtonEventHandler,
    MouseButtonEventArgs>

abstract MouseDown : IEvent<MouseButtonEventHandler,
    MouseButtonEventArgs>
Value
MouseButtonEventHandler


MouseUp Event

MouseUp Event
API ► Keyoti.RapidSpell.Wpf ► IAYTTextBox ► MouseUp
Keyoti RapidSpell WPF
Occurs when the mouse is released on the text box.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event MouseButtonEventHandler MouseUp
event MouseButtonEventHandler MouseUp
Event MouseUp As MouseButtonEventHandler
Event MouseUp As MouseButtonEventHandler
 event MouseButtonEventHandler^ MouseUp {
    void add (MouseButtonEventHandler^ value);
    void remove (MouseButtonEventHandler^ value);
}
 event MouseButtonEventHandler^ MouseUp {
    void add (MouseButtonEventHandler^ value);
    void remove (MouseButtonEventHandler^ value);
}
abstract MouseUp : IEvent<MouseButtonEventHandler,
    MouseButtonEventArgs>

abstract MouseUp : IEvent<MouseButtonEventHandler,
    MouseButtonEventArgs>
Value
MouseButtonEventHandler


ReadOnly Property

ReadOnly Property
API ► Keyoti.RapidSpell.Wpf ► IAYTTextBox ► ReadOnly
Keyoti RapidSpell WPF
Whether the textbox is readonly
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool ReadOnly { get; }
bool ReadOnly { get; }
ReadOnly Property ReadOnly As Boolean
    Get
ReadOnly Property ReadOnly As Boolean
    Get
property bool ReadOnly {
    bool get ();
}
property bool ReadOnly {
    bool get ();
}
abstract ReadOnly : bool with get

abstract ReadOnly : bool with get
Property Value
Boolean
Remarks
If not supported, return false.


Refresh Method

Refresh Method
API ► Keyoti.RapidSpell.Wpf ► IAYTTextBox ► Refresh()()()()
Keyoti RapidSpell WPF
Forces the control to invalidate its client area and immediately redraw itself and any child controls.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void Refresh()
void Refresh()
Sub Refresh
Sub Refresh
void Refresh()
void Refresh()
abstract Refresh : unit -> unit

abstract Refresh : unit -> unit


SelectedText Property

SelectedText Property
API ► Keyoti.RapidSpell.Wpf ► IAYTTextBox ► SelectedText
Keyoti RapidSpell WPF
Gets or sets a value indicating the currently selected text in the control.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string SelectedText { get; set; }
string SelectedText { get; set; }
Property SelectedText As String
    Get
    Set
Property SelectedText As String
    Get
    Set
property String^ SelectedText {
    String^ get ();
    void set (String^ value);
}
property String^ SelectedText {
    String^ get ();
    void set (String^ value);
}
abstract SelectedText : string with get, set

abstract SelectedText : string with get, set
Property Value
String


SelectionLength Property

SelectionLength Property
API ► Keyoti.RapidSpell.Wpf ► IAYTTextBox ► SelectionLength
Keyoti RapidSpell WPF
Gets or sets the number of characters selected in the text box.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
int SelectionLength { get; set; }
int SelectionLength { get; set; }
Property SelectionLength As Integer
    Get
    Set
Property SelectionLength As Integer
    Get
    Set
property int SelectionLength {
    int get ();
    void set (int value);
}
property int SelectionLength {
    int get ();
    void set (int value);
}
abstract SelectionLength : int with get, set

abstract SelectionLength : int with get, set
Property Value
Int32


SelectionStart Property

SelectionStart Property
API ► Keyoti.RapidSpell.Wpf ► IAYTTextBox ► SelectionStart
Keyoti RapidSpell WPF
Gets or sets the starting point of text selected in the text box.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
int SelectionStart { get; set; }
int SelectionStart { get; set; }
Property SelectionStart As Integer
    Get
    Set
Property SelectionStart As Integer
    Get
    Set
property int SelectionStart {
    int get ();
    void set (int value);
}
property int SelectionStart {
    int get ();
    void set (int value);
}
abstract SelectionStart : int with get, set

abstract SelectionStart : int with get, set
Property Value
Int32


Text Property

Text Property
API ► Keyoti.RapidSpell.Wpf ► IAYTTextBox ► Text
Keyoti RapidSpell WPF
Gets or sets the current text in the text box.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string Text { get; }
string Text { get; }
ReadOnly Property Text As String
    Get
ReadOnly Property Text As String
    Get
property String^ Text {
    String^ get ();
}
property String^ Text {
    String^ get ();
}
abstract Text : string with get

abstract Text : string with get
Property Value
String


TextChanged Event

TextChanged Event
API ► Keyoti.RapidSpell.Wpf ► IAYTTextBox ► TextChanged
Keyoti RapidSpell WPF
Occurs when the Text property value changes.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event EventHandler TextChanged
event EventHandler TextChanged
Event TextChanged As EventHandler
Event TextChanged As EventHandler
 event EventHandler^ TextChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
 event EventHandler^ TextChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract TextChanged : IEvent<EventHandler,
    EventArgs>

abstract TextChanged : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


TextLength Property

TextLength Property
API ► Keyoti.RapidSpell.Wpf ► IAYTTextBox ► TextLength
Keyoti RapidSpell WPF
Gets the current text length in the text box.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
int TextLength { get; }
int TextLength { get; }
ReadOnly Property TextLength As Integer
    Get
ReadOnly Property TextLength As Integer
    Get
property int TextLength {
    int get ();
}
property int TextLength {
    int get ();
}
abstract TextLength : int with get

abstract TextLength : int with get
Property Value
Int32


Width Property

Width Property
API ► Keyoti.RapidSpell.Wpf ► IAYTTextBox ► Width
Keyoti RapidSpell WPF
Gets or sets the width of the control.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
int Width { get; set; }
int Width { get; set; }
Property Width As Integer
    Get
    Set
Property Width As Integer
    Get
    Set
property int Width {
    int get ();
    void set (int value);
}
property int Width {
    int get ();
    void set (int value);
}
abstract Width : int with get, set

abstract Width : int with get, set
Property Value
Int32


ICheckerEngine Interface

ICheckerEngine Interface
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine
Keyoti RapidSpell WPF
Defines the interface required for a class to be used as a checker engine
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public interface ICheckerEngine
public interface ICheckerEngine
Public Interface ICheckerEngine
Public Interface ICheckerEngine
public interface class ICheckerEngine
public interface class ICheckerEngine
type ICheckerEngine =  interface end
type ICheckerEngine =  interface end
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddWord(String) | Adds a word to the user dictionary, if it exists.
 | AllowAnyCase | Whether to allow words spelt with any case, eg. "africa" instead of "Africa", this is more relaxed than AllowMixedCase.
 | AllowMixedCase | Whether to allow words spelt with mixed case, eg. "MIxEd"
 | ChangeBadWord(String) | Changes the current bad word to newWord in the text.
 | ChangeBadWord(BadWord, String) | Changes badWord to newWord in the text.
 | Check(String) | Checks the text for errors.
 | Check(String, Boolean) | Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.
 | CheckCompoundWords | Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
 | CurrentBadWord | Gets the current bad word (last returned by NextBadWord).
 | DictFilePath | The file to be used as the main dictionary, if this is null then the RapidSpellMDict.DLL satellite assembly is used.
 | FindCapitalizedSuggestions | Whether to look for capitalized suggestions, note this will slow FindSuggestions down by about 7 times.
 | FindSuggestions()()()() | Returns an ArrayList of Strings that are suitable suggestions for the current bad word (that is, the one last returned by NextBadWord()).
 | FindSuggestions(String) | Returns an ArrayList of Strings that are suitable suggestions for word.
 | GetConsiderationRange()()()() | Gets the factor for words to consider for suggestions.
 | GetIgnoreCapitalizedWords()()()() | Gets whether to ignore words that start with capital letters.
 | GetIncludeUserDictionaryInSuggestions()()()() | Gets whether the user dictionary should be used in finding suggestions for misspelt words.
 | GetSuggestionsMethod()()()() | Gets the suggestions method, where method is an integer identifier.
 | GetUndoableStatePoint()()()() | Gets the state of the current run, which can be stored and used with RevertToUndoableStatePoint(RapidSpellChecker..::..State)
 | IgnoreAll(String) | Marks word to be ignored in rest of the text.
 | IgnoreAllCaseInsensitive | Whether Ignore All operations should be considered case insensitive (default false).
 | IgnoreIncorrectSentenceCapitalization | Whether to ignore incorrect sentence capitalization.
 | IgnoreInEnglishLowerCaseI | Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
 | IgnoreList | The words to ignore, note this list is changed by IgnoreAll.
 | IgnorePatternMaximumWordLength | The maximum length of word that will be tested as a regex ignore pattern.
 | IgnoreURLsAndEmailAddresses | Whether to ignore URLs and email addresses (requires V2Parser=true)
 | IgnoreWordsWithDigits | Whether to ignore words with numbers in them (eg. A10 or 7-11).
 | IgnoreXML | Whether to ignore XML tags in the text.
 | LanguageParser | The type of language parsing to use.
 | LookIntoHyphenatedText | Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
 | LookUp(String) | Looks up word in the dictionary, returns true if it is in there.
 | NextBadWord()()()() | Gets the next bad word in the list that was identified by Check.
 | RevertToUndoableStatePoint(RapidSpellChecker..::..State) | Reverts the state to that it was when GetUndoableStatePoint()()()() was called.
 | SetConsiderationRange(Int32) | Sets the breadth of the suggestions search.
 | SetDictFileStream(Stream, String, DateTime) | Passes a Dict file as a stream, to be used for the main dictionary.
 | SetIgnoreCapitalizedWords(Boolean) | Sets whether to ignore capitalized words.
 | SetIncludeUserDictionaryInSuggestions(Boolean) | Sets whether to include the user dictionary in suggestions taken from this engine.
 | SetOptionalContext(String, String) | Provides the engine with any helpful text around the text snippet which will be passed to the Check method. Implementation is not required.
 | SetPosition(Int32) | Sets the pointer position for the NextBadWord iterator.
 | SetSeparateHyphenWords(Boolean) | Sets whether to separate words with hyphens in them into separate words.
 | SetSuggestionsMethod(Int32) | Sets the suggestions method, where method is an integer identifier.
 | SetUserDictionary(UserDictionary) | Sets the UserDictionary object to be used as a user dictionary source.
 | SetUserDictionary(String) | Sets the UserDictionary file path to be used as a user dictionary source.
 | SuggestSplitWords | Whether to look for connected words in suggestions.
 | TextBoundary | The AdvancedTextBoundary class to use to parse words.
 | userDictionary | The user dictionary, this should be null (C#) or nothing (VB.NET) if no user dictionary is being used.
 | V2Parser | Whether to use parser version 2 (specific to RapidSpellChecker).
 | WarnDuplicates | Whether to treat duplicate words as errors (eg. "this is is an error").
Remarks
This is the interface which any checker engine must have, by implementing this interface any object can be used to parse text and identify 'bad words'. It is not necessary to functionally implement all members, for this reason an abstract empty implementation class is provided (CheckerEngineAdapter) which can be extended and overridden for desired functionality.


AddWord Method (word)

AddWord Method (word)
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► AddWord(String)
Keyoti RapidSpell WPF
Adds a word to the user dictionary, if it exists.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool AddWord(
    string word
)
bool AddWord(
    string word
)
Function AddWord (
    word As String
) As Boolean
Function AddWord (
    word As String
) As Boolean
bool AddWord(
    String^ word
)
bool AddWord(
    String^ word
)
abstract AddWord :
        word : string -> bool

abstract AddWord :
        word : string -> bool
Parameters
word (String)
Return Value
Boolean
Remarks
Should return true if the word was added successfully, false otherwise.


AllowAnyCase Property

AllowAnyCase Property
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► AllowAnyCase
Keyoti RapidSpell WPF
Whether to allow words spelt with any case, eg. "africa" instead of "Africa", this is more relaxed than AllowMixedCase.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool AllowAnyCase { get; set; }
bool AllowAnyCase { get; set; }
Property AllowAnyCase As Boolean
    Get
    Set
Property AllowAnyCase As Boolean
    Get
    Set
property bool AllowAnyCase {
    bool get ();
    void set (bool value);
}
property bool AllowAnyCase {
    bool get ();
    void set (bool value);
}
abstract AllowAnyCase : bool with get, set

abstract AllowAnyCase : bool with get, set
Property Value
Boolean


AllowMixedCase Property

AllowMixedCase Property
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► AllowMixedCase
Keyoti RapidSpell WPF
Whether to allow words spelt with mixed case, eg. "MIxEd"
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool AllowMixedCase { get; set; }
bool AllowMixedCase { get; set; }
Property AllowMixedCase As Boolean
    Get
    Set
Property AllowMixedCase As Boolean
    Get
    Set
property bool AllowMixedCase {
    bool get ();
    void set (bool value);
}
property bool AllowMixedCase {
    bool get ();
    void set (bool value);
}
abstract AllowMixedCase : bool with get, set

abstract AllowMixedCase : bool with get, set
Property Value
Boolean


ChangeBadWord Method

ChangeBadWord Method
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► ChangeBadWord()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | ChangeBadWord(String) | Changes the current bad word to newWord in the text.
 | ChangeBadWord(BadWord, String) | Changes badWord to newWord in the text.


ChangeBadWord Method (badWord, newWord)

ChangeBadWord Method (badWord, newWord)
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► ChangeBadWord(BadWord, String)
Keyoti RapidSpell WPF
Changes badWord to newWord in the text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void ChangeBadWord(
    BadWord badWord,
    string newWord
)
void ChangeBadWord(
    BadWord badWord,
    string newWord
)
Sub ChangeBadWord (
    badWord As BadWord,
    newWord As String
)
Sub ChangeBadWord (
    badWord As BadWord,
    newWord As String
)
void ChangeBadWord(
    BadWord^ badWord,
    String^ newWord
)
void ChangeBadWord(
    BadWord^ badWord,
    String^ newWord
)
abstract ChangeBadWord :
        badWord : BadWord *
        newWord : string -> unit

abstract ChangeBadWord :
        badWord : BadWord *
        newWord : string -> unit
Parameters
badWord (BadWord)
the word to reaplce
newWord (String)
replaces the current misspelt word.
Return Value

void
Exceptions
Exception | Condition
ArgumentNullException | if newWord parameter is null.


ChangeBadWord Method (newWord)

ChangeBadWord Method (newWord)
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► ChangeBadWord(String)
Keyoti RapidSpell WPF
Changes the current bad word to newWord in the text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void ChangeBadWord(
    string newWord
)
void ChangeBadWord(
    string newWord
)
Sub ChangeBadWord (
    newWord As String
)
Sub ChangeBadWord (
    newWord As String
)
void ChangeBadWord(
    String^ newWord
)
void ChangeBadWord(
    String^ newWord
)
abstract ChangeBadWord :
        newWord : string -> unit

abstract ChangeBadWord :
        newWord : string -> unit
Parameters
newWord (String)
replaces the current misspelt word.
Return Value

void
Exceptions
Exception | Condition
NoCurrentBadWordException | if nextBadWord() hasn't been run first AND found an erroneous word.
ArgumentNullException | if newWord parameter is null.


Check Method

Check Method
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► Check()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | Check(String) | Checks the text for errors.
 | Check(String, Boolean) | Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.


Check Method (text)

Check Method (text)
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► Check(String)
Keyoti RapidSpell WPF
Checks the text for errors.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void Check(
    string text
)
void Check(
    string text
)
Sub Check (
    text As String
)
Sub Check (
    text As String
)
void Check(
    String^ text
)
void Check(
    String^ text
)
abstract Check :
        text : string -> unit

abstract Check :
        text : string -> unit
Parameters
text (String)
Exceptions
Exception | Condition
ArgumentNullException | if text parameter is null.


Check Method (text, isStartOfTextBody)

Check Method (text, isStartOfTextBody)
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► Check(String, Boolean)
Keyoti RapidSpell WPF
Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void Check(
    string text,
    bool isStartOfTextBody
)
void Check(
    string text,
    bool isStartOfTextBody
)
Sub Check (
    text As String,
    isStartOfTextBody As Boolean
)
Sub Check (
    text As String,
    isStartOfTextBody As Boolean
)
void Check(
    String^ text,
    bool isStartOfTextBody
)
void Check(
    String^ text,
    bool isStartOfTextBody
)
abstract Check :
        text : string *
        isStartOfTextBody : bool -> unit

abstract Check :
        text : string *
        isStartOfTextBody : bool -> unit
Parameters
text (String)
to spell check.
isStartOfTextBody (Boolean)
whether the text being spell checked is at the start of the text body (eg. start of text box), this affects sentence capitalization determination.
Return Value

void
Exceptions
Exception | Condition
ArgumentNullException | if text parameter is null.


CheckCompoundWords Property

CheckCompoundWords Property
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► CheckCompoundWords
Keyoti RapidSpell WPF
Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool CheckCompoundWords { get; set; }
bool CheckCompoundWords { get; set; }
Property CheckCompoundWords As Boolean
    Get
    Set
Property CheckCompoundWords As Boolean
    Get
    Set
property bool CheckCompoundWords {
    bool get ();
    void set (bool value);
}
property bool CheckCompoundWords {
    bool get ();
    void set (bool value);
}
abstract CheckCompoundWords : bool with get, set

abstract CheckCompoundWords : bool with get, set
Property Value
Boolean
Remarks
If this=false then LookUp("thesewordsarejoined") = false

If this=true then LookUp("thesewordsarejoined") = true

If this=false then LookUp("abcdef") = false

If this=true then LookUp("abcdef") = false

Setting this to true will degrade lookup performance


CurrentBadWord Property

CurrentBadWord Property
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► CurrentBadWord
Keyoti RapidSpell WPF
Gets the current bad word (last returned by NextBadWord).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
BadWord CurrentBadWord { get; }
BadWord CurrentBadWord { get; }
ReadOnly Property CurrentBadWord As BadWord
    Get
ReadOnly Property CurrentBadWord As BadWord
    Get
property BadWord^ CurrentBadWord {
    BadWord^ get ();
}
property BadWord^ CurrentBadWord {
    BadWord^ get ();
}
abstract CurrentBadWord : BadWord with get

abstract CurrentBadWord : BadWord with get
Property Value
BadWord


DictFilePath Property

DictFilePath Property
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► DictFilePath
Keyoti RapidSpell WPF
The file to be used as the main dictionary, if this is null then the RapidSpellMDict.DLL satellite assembly is used.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string DictFilePath { get; set; }
string DictFilePath { get; set; }
Property DictFilePath As String
    Get
    Set
Property DictFilePath As String
    Get
    Set
property String^ DictFilePath {
    String^ get ();
    void set (String^ value);
}
property String^ DictFilePath {
    String^ get ();
    void set (String^ value);
}
abstract DictFilePath : string with get, set

abstract DictFilePath : string with get, set
Property Value
String


FindCapitalizedSuggestions Property

FindCapitalizedSuggestions Property
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► FindCapitalizedSuggestions
Keyoti RapidSpell WPF
Whether to look for capitalized suggestions, note this will slow FindSuggestions down by about 7 times.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool FindCapitalizedSuggestions { get; set; }
bool FindCapitalizedSuggestions { get; set; }
Property FindCapitalizedSuggestions As Boolean
    Get
    Set
Property FindCapitalizedSuggestions As Boolean
    Get
    Set
property bool FindCapitalizedSuggestions {
    bool get ();
    void set (bool value);
}
property bool FindCapitalizedSuggestions {
    bool get ();
    void set (bool value);
}
abstract FindCapitalizedSuggestions : bool with get, set

abstract FindCapitalizedSuggestions : bool with get, set
Property Value
Boolean


FindSuggestions Method

FindSuggestions Method
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► FindSuggestions()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | FindSuggestions()()()() | Returns an ArrayList of Strings that are suitable suggestions for the current bad word (that is, the one last returned by NextBadWord()).
 | FindSuggestions(String) | Returns an ArrayList of Strings that are suitable suggestions for word.


FindSuggestions Method

FindSuggestions Method
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► FindSuggestions()()()()
Keyoti RapidSpell WPF
Returns an ArrayList of Strings that are suitable suggestions for the current bad word (that is, the one last returned by NextBadWord()).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
ArrayList FindSuggestions()
ArrayList FindSuggestions()
Function FindSuggestions As ArrayList
Function FindSuggestions As ArrayList
ArrayList^ FindSuggestions()
ArrayList^ FindSuggestions()
abstract FindSuggestions : unit -> ArrayList

abstract FindSuggestions : unit -> ArrayList
Return Value
ArrayList
Remarks
If no suggestions can be found, this should return an empty ArrayList. This method should be thread safe if operating with RapidSpell Desktop.
Exceptions
Exception | Condition
NoCurrentBadWordException | If NextBadWord() hasn't been run first AND found an erroneous word.


FindSuggestions Method (word)

FindSuggestions Method (word)
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► FindSuggestions(String)
Keyoti RapidSpell WPF
Returns an ArrayList of Strings that are suitable suggestions for word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
ArrayList FindSuggestions(
    string word
)
ArrayList FindSuggestions(
    string word
)
Function FindSuggestions (
    word As String
) As ArrayList
Function FindSuggestions (
    word As String
) As ArrayList
ArrayList^ FindSuggestions(
    String^ word
)
ArrayList^ FindSuggestions(
    String^ word
)
abstract FindSuggestions :
        word : string -> ArrayList

abstract FindSuggestions :
        word : string -> ArrayList
Parameters
word (String)
Return Value
ArrayList
Remarks
If no suggestions can be found, this should return an empty ArrayList. This method should be thread safe if operating with RapidSpell Desktop.


GetConsiderationRange Method

GetConsiderationRange Method
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► GetConsiderationRange()()()()
Keyoti RapidSpell WPF
Gets the factor for words to consider for suggestions.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
int GetConsiderationRange()
int GetConsiderationRange()
Function GetConsiderationRange As Integer
Function GetConsiderationRange As Integer
int GetConsiderationRange()
int GetConsiderationRange()
abstract GetConsiderationRange : unit -> int

abstract GetConsiderationRange : unit -> int
Return Value
Int32


GetIgnoreCapitalizedWords Method

GetIgnoreCapitalizedWords Method
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► GetIgnoreCapitalizedWords()()()()
Keyoti RapidSpell WPF
Gets whether to ignore words that start with capital letters.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool GetIgnoreCapitalizedWords()
bool GetIgnoreCapitalizedWords()
Function GetIgnoreCapitalizedWords As Boolean
Function GetIgnoreCapitalizedWords As Boolean
bool GetIgnoreCapitalizedWords()
bool GetIgnoreCapitalizedWords()
abstract GetIgnoreCapitalizedWords : unit -> bool

abstract GetIgnoreCapitalizedWords : unit -> bool
Return Value
Boolean


GetIncludeUserDictionaryInSuggestions Method

GetIncludeUserDictionaryInSuggestions Method
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► GetIncludeUserDictionaryInSuggestions()()()()
Keyoti RapidSpell WPF
Gets whether the user dictionary should be used in finding suggestions for misspelt words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool GetIncludeUserDictionaryInSuggestions()
bool GetIncludeUserDictionaryInSuggestions()
Function GetIncludeUserDictionaryInSuggestions As Boolean
Function GetIncludeUserDictionaryInSuggestions As Boolean
bool GetIncludeUserDictionaryInSuggestions()
bool GetIncludeUserDictionaryInSuggestions()
abstract GetIncludeUserDictionaryInSuggestions : unit -> bool

abstract GetIncludeUserDictionaryInSuggestions : unit -> bool
Return Value
Boolean


GetSuggestionsMethod Method

GetSuggestionsMethod Method
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► GetSuggestionsMethod()()()()
Keyoti RapidSpell WPF
Gets the suggestions method, where method is an integer identifier.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
int GetSuggestionsMethod()
int GetSuggestionsMethod()
Function GetSuggestionsMethod As Integer
Function GetSuggestionsMethod As Integer
int GetSuggestionsMethod()
int GetSuggestionsMethod()
abstract GetSuggestionsMethod : unit -> int

abstract GetSuggestionsMethod : unit -> int
Return Value
Int32


GetUndoableStatePoint Method

GetUndoableStatePoint Method
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► GetUndoableStatePoint()()()()
Keyoti RapidSpell WPF
Gets the state of the current run, which can be stored and used with RevertToUndoableStatePoint(RapidSpellChecker..::..State)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
RapidSpellChecker..::..State GetUndoableStatePoint()
RapidSpellChecker..::..State GetUndoableStatePoint()
Function GetUndoableStatePoint As RapidSpellChecker..::..State
Function GetUndoableStatePoint As RapidSpellChecker..::..State
RapidSpellChecker..::..State^ GetUndoableStatePoint()
RapidSpellChecker..::..State^ GetUndoableStatePoint()
abstract GetUndoableStatePoint : unit -> RapidSpellChecker..::..State

abstract GetUndoableStatePoint : unit -> RapidSpellChecker..::..State
Return Value
RapidSpellChecker..::..State
Returns the current state, or null if not supporting undo.


IgnoreAll Method (word)

IgnoreAll Method (word)
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► IgnoreAll(String)
Keyoti RapidSpell WPF
Marks word to be ignored in rest of the text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void IgnoreAll(
    string word
)
void IgnoreAll(
    string word
)
Sub IgnoreAll (
    word As String
)
Sub IgnoreAll (
    word As String
)
void IgnoreAll(
    String^ word
)
void IgnoreAll(
    String^ word
)
abstract IgnoreAll :
        word : string -> unit

abstract IgnoreAll :
        word : string -> unit
Parameters
word (String)
to ignore
Return Value

void
Exceptions
Exception | Condition
ArgumentNullException | if word parameter is null.


IgnoreAllCaseInsensitive Property

IgnoreAllCaseInsensitive Property
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► IgnoreAllCaseInsensitive
Keyoti RapidSpell WPF
Whether Ignore All operations should be considered case insensitive (default false).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool IgnoreAllCaseInsensitive { get; set; }
bool IgnoreAllCaseInsensitive { get; set; }
Property IgnoreAllCaseInsensitive As Boolean
    Get
    Set
Property IgnoreAllCaseInsensitive As Boolean
    Get
    Set
property bool IgnoreAllCaseInsensitive {
    bool get ();
    void set (bool value);
}
property bool IgnoreAllCaseInsensitive {
    bool get ();
    void set (bool value);
}
abstract IgnoreAllCaseInsensitive : bool with get, set

abstract IgnoreAllCaseInsensitive : bool with get, set
Property Value
Boolean


IgnoreIncorrectSentenceCapitalization Property

IgnoreIncorrectSentenceCapitalization Property
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► IgnoreIncorrectSentenceCapitalization
Keyoti RapidSpell WPF
Whether to ignore incorrect sentence capitalization.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool IgnoreIncorrectSentenceCapitalization { get; set; }
bool IgnoreIncorrectSentenceCapitalization { get; set; }
Property IgnoreIncorrectSentenceCapitalization As Boolean
    Get
    Set
Property IgnoreIncorrectSentenceCapitalization As Boolean
    Get
    Set
property bool IgnoreIncorrectSentenceCapitalization {
    bool get ();
    void set (bool value);
}
property bool IgnoreIncorrectSentenceCapitalization {
    bool get ();
    void set (bool value);
}
abstract IgnoreIncorrectSentenceCapitalization : bool with get, set

abstract IgnoreIncorrectSentenceCapitalization : bool with get, set
Property Value
Boolean


IgnoreInEnglishLowerCaseI Property

IgnoreInEnglishLowerCaseI Property
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► IgnoreInEnglishLowerCaseI
Keyoti RapidSpell WPF
Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool IgnoreInEnglishLowerCaseI { get; set; }
bool IgnoreInEnglishLowerCaseI { get; set; }
Property IgnoreInEnglishLowerCaseI As Boolean
    Get
    Set
Property IgnoreInEnglishLowerCaseI As Boolean
    Get
    Set
property bool IgnoreInEnglishLowerCaseI {
    bool get ();
    void set (bool value);
}
property bool IgnoreInEnglishLowerCaseI {
    bool get ();
    void set (bool value);
}
abstract IgnoreInEnglishLowerCaseI : bool with get, set

abstract IgnoreInEnglishLowerCaseI : bool with get, set
Property Value
Boolean


IgnoreList Property

IgnoreList Property
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► IgnoreList
Keyoti RapidSpell WPF
The words to ignore, note this list is changed by IgnoreAll.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
ArrayList IgnoreList { get; }
ArrayList IgnoreList { get; }
ReadOnly Property IgnoreList As ArrayList
    Get
ReadOnly Property IgnoreList As ArrayList
    Get
property ArrayList^ IgnoreList {
    ArrayList^ get ();
}
property ArrayList^ IgnoreList {
    ArrayList^ get ();
}
abstract IgnoreList : ArrayList with get

abstract IgnoreList : ArrayList with get
Property Value
ArrayList


IgnorePatternMaximumWordLength Property

IgnorePatternMaximumWordLength Property
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► IgnorePatternMaximumWordLength
Keyoti RapidSpell WPF
The maximum length of word that will be tested as a regex ignore pattern.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
int IgnorePatternMaximumWordLength { get; set; }
int IgnorePatternMaximumWordLength { get; set; }
Property IgnorePatternMaximumWordLength As Integer
    Get
    Set
Property IgnorePatternMaximumWordLength As Integer
    Get
    Set
property int IgnorePatternMaximumWordLength {
    int get ();
    void set (int value);
}
property int IgnorePatternMaximumWordLength {
    int get ();
    void set (int value);
}
abstract IgnorePatternMaximumWordLength : int with get, set

abstract IgnorePatternMaximumWordLength : int with get, set
Property Value
Int32


IgnoreURLsAndEmailAddresses Property

IgnoreURLsAndEmailAddresses Property
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► IgnoreURLsAndEmailAddresses
Keyoti RapidSpell WPF
Whether to ignore URLs and email addresses (requires V2Parser=true)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool IgnoreURLsAndEmailAddresses { get; set; }
bool IgnoreURLsAndEmailAddresses { get; set; }
Property IgnoreURLsAndEmailAddresses As Boolean
    Get
    Set
Property IgnoreURLsAndEmailAddresses As Boolean
    Get
    Set
property bool IgnoreURLsAndEmailAddresses {
    bool get ();
    void set (bool value);
}
property bool IgnoreURLsAndEmailAddresses {
    bool get ();
    void set (bool value);
}
abstract IgnoreURLsAndEmailAddresses : bool with get, set

abstract IgnoreURLsAndEmailAddresses : bool with get, set
Property Value
Boolean
Remarks
This will cause the following strings to be accepted as non-spelling errors;
"user@domain.com", "http://www.domain.com", "domain.co.uk" etc.


IgnoreWordsWithDigits Property

IgnoreWordsWithDigits Property
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► IgnoreWordsWithDigits
Keyoti RapidSpell WPF
Whether to ignore words with numbers in them (eg. A10 or 7-11).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool IgnoreWordsWithDigits { get; set; }
bool IgnoreWordsWithDigits { get; set; }
Property IgnoreWordsWithDigits As Boolean
    Get
    Set
Property IgnoreWordsWithDigits As Boolean
    Get
    Set
property bool IgnoreWordsWithDigits {
    bool get ();
    void set (bool value);
}
property bool IgnoreWordsWithDigits {
    bool get ();
    void set (bool value);
}
abstract IgnoreWordsWithDigits : bool with get, set

abstract IgnoreWordsWithDigits : bool with get, set
Property Value
Boolean


IgnoreXML Property

IgnoreXML Property
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► IgnoreXML
Keyoti RapidSpell WPF
Whether to ignore XML tags in the text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool IgnoreXML { get; set; }
bool IgnoreXML { get; set; }
Property IgnoreXML As Boolean
    Get
    Set
Property IgnoreXML As Boolean
    Get
    Set
property bool IgnoreXML {
    bool get ();
    void set (bool value);
}
property bool IgnoreXML {
    bool get ();
    void set (bool value);
}
abstract IgnoreXML : bool with get, set

abstract IgnoreXML : bool with get, set
Property Value
Boolean


LanguageParser Property

LanguageParser Property
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► LanguageParser
Keyoti RapidSpell WPF
The type of language parsing to use.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
LanguageType LanguageParser { get; set; }
LanguageType LanguageParser { get; set; }
Property LanguageParser As LanguageType
    Get
    Set
Property LanguageParser As LanguageType
    Get
    Set
property LanguageType LanguageParser {
    LanguageType get ();
    void set (LanguageType value);
}
property LanguageType LanguageParser {
    LanguageType get ();
    void set (LanguageType value);
}
abstract LanguageParser : LanguageType with get, set

abstract LanguageParser : LanguageType with get, set
Return Value
LanguageType
This implementation always returns ENGLISH.
Remarks
Eg. If the dictionary is set to French, you should use the French parser.


LookIntoHyphenatedText Property

LookIntoHyphenatedText Property
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► LookIntoHyphenatedText
Keyoti RapidSpell WPF
Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool LookIntoHyphenatedText { get; set; }
bool LookIntoHyphenatedText { get; set; }
Property LookIntoHyphenatedText As Boolean
    Get
    Set
Property LookIntoHyphenatedText As Boolean
    Get
    Set
property bool LookIntoHyphenatedText {
    bool get ();
    void set (bool value);
}
property bool LookIntoHyphenatedText {
    bool get ();
    void set (bool value);
}
abstract LookIntoHyphenatedText : bool with get, set

abstract LookIntoHyphenatedText : bool with get, set
Property Value
Boolean
Remarks
Eg. "socio-economic" will be checked as "socio" and "economic".


LookUp Method (word)

LookUp Method (word)
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► LookUp(String)
Keyoti RapidSpell WPF
Looks up word in the dictionary, returns true if it is in there.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool LookUp(
    string word
)
bool LookUp(
    string word
)
Function LookUp (
    word As String
) As Boolean
Function LookUp (
    word As String
) As Boolean
bool LookUp(
    String^ word
)
bool LookUp(
    String^ word
)
abstract LookUp :
        word : string -> bool

abstract LookUp :
        word : string -> bool
Parameters
word (String)
Return Value
Boolean


NextBadWord Method

NextBadWord Method
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► NextBadWord()()()()
Keyoti RapidSpell WPF
Gets the next bad word in the list that was identified by Check.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
BadWord NextBadWord()
BadWord NextBadWord()
Function NextBadWord As BadWord
Function NextBadWord As BadWord
BadWord^ NextBadWord()
BadWord^ NextBadWord()
abstract NextBadWord : unit -> BadWord

abstract NextBadWord : unit -> BadWord
Return Value
BadWord
The next BadWord object from the text, must return null (C#) or nothing (VB.NET) when no more bad words exist.
Remarks
Check must be called before this method.


RevertToUndoableStatePoint Method (state)

RevertToUndoableStatePoint Method (state)
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► RevertToUndoableStatePoint(RapidSpellChecker..::..State)
Keyoti RapidSpell WPF
Reverts the state to that it was when GetUndoableStatePoint()()()() was called.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void RevertToUndoableStatePoint(
    RapidSpellChecker..::..State state
)
void RevertToUndoableStatePoint(
    RapidSpellChecker..::..State state
)
Sub RevertToUndoableStatePoint (
    state As RapidSpellChecker..::..State
)
Sub RevertToUndoableStatePoint (
    state As RapidSpellChecker..::..State
)
void RevertToUndoableStatePoint(
    RapidSpellChecker..::..State^ state
)
void RevertToUndoableStatePoint(
    RapidSpellChecker..::..State^ state
)
abstract RevertToUndoableStatePoint :
        state : RapidSpellChecker..::..State -> unit

abstract RevertToUndoableStatePoint :
        state : RapidSpellChecker..::..State -> unit
Parameters
state (RapidSpellChecker..::..State)


SetConsiderationRange Method (range)

SetConsiderationRange Method (range)
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► SetConsiderationRange(Int32)
Keyoti RapidSpell WPF
Sets the breadth of the suggestions search.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void SetConsiderationRange(
    int range
)
void SetConsiderationRange(
    int range
)
Sub SetConsiderationRange (
    range As Integer
)
Sub SetConsiderationRange (
    range As Integer
)
void SetConsiderationRange(
    int range
)
void SetConsiderationRange(
    int range
)
abstract SetConsiderationRange :
        range : int -> unit

abstract SetConsiderationRange :
        range : int -> unit
Parameters
range (Int32)


SetDictFileStream Method (dictFileStream, id, modifiedDate)

SetDictFileStream Method (dictFileStream, id, modifiedDate)
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► SetDictFileStream(Stream, String, DateTime)
Keyoti RapidSpell WPF
Passes a Dict file as a stream, to be used for the main dictionary.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void SetDictFileStream(
    Stream dictFileStream,
    string id,
    DateTime modifiedDate
)
void SetDictFileStream(
    Stream dictFileStream,
    string id,
    DateTime modifiedDate
)
Sub SetDictFileStream (
    dictFileStream As Stream,
    id As String,
    modifiedDate As DateTime
)
Sub SetDictFileStream (
    dictFileStream As Stream,
    id As String,
    modifiedDate As DateTime
)
void SetDictFileStream(
    Stream^ dictFileStream,
    String^ id,
    DateTime modifiedDate
)
void SetDictFileStream(
    Stream^ dictFileStream,
    String^ id,
    DateTime modifiedDate
)
abstract SetDictFileStream :
        dictFileStream : Stream *
        id : string *
        modifiedDate : DateTime -> unit

abstract SetDictFileStream :
        dictFileStream : Stream *
        id : string *
        modifiedDate : DateTime -> unit
Parameters
dictFileStream (Stream)
The stream containing the dictionary
id (String)
Any generated identity string which the spell checker can use to cache and identify this dictionary.
modifiedDate (DateTime)
When the dictionary was modified, use .Now to update the cache.
Remarks
Note this method must be set before Check is called, and the stream position must be at beginning of Dict file. The stream is NOT closed by this method.


SetIgnoreCapitalizedWords Method (ignore)

SetIgnoreCapitalizedWords Method (ignore)
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► SetIgnoreCapitalizedWords(Boolean)
Keyoti RapidSpell WPF
Sets whether to ignore capitalized words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void SetIgnoreCapitalizedWords(
    bool ignore
)
void SetIgnoreCapitalizedWords(
    bool ignore
)
Sub SetIgnoreCapitalizedWords (
    ignore As Boolean
)
Sub SetIgnoreCapitalizedWords (
    ignore As Boolean
)
void SetIgnoreCapitalizedWords(
    bool ignore
)
void SetIgnoreCapitalizedWords(
    bool ignore
)
abstract SetIgnoreCapitalizedWords :
        ignore : bool -> unit

abstract SetIgnoreCapitalizedWords :
        ignore : bool -> unit
Parameters
ignore (Boolean)


SetIncludeUserDictionaryInSuggestions Method (includeUserDictionaryInSuggestions)

SetIncludeUserDictionaryInSuggestions Method (includeUserDictionaryInSuggestions)
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► SetIncludeUserDictionaryInSuggestions(Boolean)
Keyoti RapidSpell WPF
Sets whether to include the user dictionary in suggestions taken from this engine.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void SetIncludeUserDictionaryInSuggestions(
    bool includeUserDictionaryInSuggestions
)
void SetIncludeUserDictionaryInSuggestions(
    bool includeUserDictionaryInSuggestions
)
Sub SetIncludeUserDictionaryInSuggestions (
    includeUserDictionaryInSuggestions As Boolean
)
Sub SetIncludeUserDictionaryInSuggestions (
    includeUserDictionaryInSuggestions As Boolean
)
void SetIncludeUserDictionaryInSuggestions(
    bool includeUserDictionaryInSuggestions
)
void SetIncludeUserDictionaryInSuggestions(
    bool includeUserDictionaryInSuggestions
)
abstract SetIncludeUserDictionaryInSuggestions :
        includeUserDictionaryInSuggestions : bool -> unit

abstract SetIncludeUserDictionaryInSuggestions :
        includeUserDictionaryInSuggestions : bool -> unit
Parameters
includeUserDictionaryInSuggestions (Boolean)


SetOptionalContext Method (beforeToCheckSnippet, afterToCheckSnippet)

SetOptionalContext Method (beforeToCheckSnippet, afterToCheckSnippet)
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► SetOptionalContext(String, String)
Keyoti RapidSpell WPF
Provides the engine with any helpful text around the text snippet which will be passed to the Check method. Implementation is not required.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void SetOptionalContext(
    string beforeToCheckSnippet,
    string afterToCheckSnippet
)
void SetOptionalContext(
    string beforeToCheckSnippet,
    string afterToCheckSnippet
)
Sub SetOptionalContext (
    beforeToCheckSnippet As String,
    afterToCheckSnippet As String
)
Sub SetOptionalContext (
    beforeToCheckSnippet As String,
    afterToCheckSnippet As String
)
void SetOptionalContext(
    String^ beforeToCheckSnippet,
    String^ afterToCheckSnippet
)
void SetOptionalContext(
    String^ beforeToCheckSnippet,
    String^ afterToCheckSnippet
)
abstract SetOptionalContext :
        beforeToCheckSnippet : string *
        afterToCheckSnippet : string -> unit

abstract SetOptionalContext :
        beforeToCheckSnippet : string *
        afterToCheckSnippet : string -> unit
Parameters
beforeToCheckSnippet (String)
Any text before the to check snippet
afterToCheckSnippet (String)
Any text after the snippet
Remarks
Eg. if the document contains "This is an an example piece." and Check will be called on "an example piece", then the fact that 'an' is duplicated will not be detected. Therefore, by passing "This is an " to beforeToCheckSnippet the checker will be able to detect that an is duplicated.


SetPosition Method (pos)

SetPosition Method (pos)
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► SetPosition(Int32)
Keyoti RapidSpell WPF
Sets the pointer position for the NextBadWord iterator.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void SetPosition(
    int pos
)
void SetPosition(
    int pos
)
Sub SetPosition (
    pos As Integer
)
Sub SetPosition (
    pos As Integer
)
void SetPosition(
    int pos
)
void SetPosition(
    int pos
)
abstract SetPosition :
        pos : int -> unit

abstract SetPosition :
        pos : int -> unit
Parameters
pos (Int32)
Remarks
Further calls to NextBadWord will look for the next bad word from position pos. If position > the text length it is set to the text length. If position < 0, it is set to zero.


SetSeparateHyphenWords Method (separate)

SetSeparateHyphenWords Method (separate)
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► SetSeparateHyphenWords(Boolean)
Keyoti RapidSpell WPF
Sets whether to separate words with hyphens in them into separate words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void SetSeparateHyphenWords(
    bool separate
)
void SetSeparateHyphenWords(
    bool separate
)
Sub SetSeparateHyphenWords (
    separate As Boolean
)
Sub SetSeparateHyphenWords (
    separate As Boolean
)
void SetSeparateHyphenWords(
    bool separate
)
void SetSeparateHyphenWords(
    bool separate
)
abstract SetSeparateHyphenWords :
        separate : bool -> unit

abstract SetSeparateHyphenWords :
        separate : bool -> unit
Parameters
separate (Boolean)


SetSuggestionsMethod Method (method)

SetSuggestionsMethod Method (method)
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► SetSuggestionsMethod(Int32)
Keyoti RapidSpell WPF
Sets the suggestions method, where method is an integer identifier.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void SetSuggestionsMethod(
    int method
)
void SetSuggestionsMethod(
    int method
)
Sub SetSuggestionsMethod (
    method As Integer
)
Sub SetSuggestionsMethod (
    method As Integer
)
void SetSuggestionsMethod(
    int method
)
void SetSuggestionsMethod(
    int method
)
abstract SetSuggestionsMethod :
        method : int -> unit

abstract SetSuggestionsMethod :
        method : int -> unit
Parameters
method (Int32)


SetUserDictionary Method

SetUserDictionary Method
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► SetUserDictionary()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | SetUserDictionary(UserDictionary) | Sets the UserDictionary object to be used as a user dictionary source.
 | SetUserDictionary(String) | Sets the UserDictionary file path to be used as a user dictionary source.


SetUserDictionary Method (userDictionary)

SetUserDictionary Method (userDictionary)
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► SetUserDictionary(UserDictionary)
Keyoti RapidSpell WPF
Sets the UserDictionary object to be used as a user dictionary source.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void SetUserDictionary(
    UserDictionary userDictionary
)
void SetUserDictionary(
    UserDictionary userDictionary
)
Sub SetUserDictionary (
    userDictionary As UserDictionary
)
Sub SetUserDictionary (
    userDictionary As UserDictionary
)
void SetUserDictionary(
    UserDictionary^ userDictionary
)
void SetUserDictionary(
    UserDictionary^ userDictionary
)
abstract SetUserDictionary :
        userDictionary : UserDictionary -> unit

abstract SetUserDictionary :
        userDictionary : UserDictionary -> unit
Parameters
userDictionary (UserDictionary)


SetUserDictionary Method (userDictionary)

SetUserDictionary Method (userDictionary)
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► SetUserDictionary(String)
Keyoti RapidSpell WPF
Sets the UserDictionary file path to be used as a user dictionary source.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void SetUserDictionary(
    string userDictionary
)
void SetUserDictionary(
    string userDictionary
)
Sub SetUserDictionary (
    userDictionary As String
)
Sub SetUserDictionary (
    userDictionary As String
)
void SetUserDictionary(
    String^ userDictionary
)
void SetUserDictionary(
    String^ userDictionary
)
abstract SetUserDictionary :
        userDictionary : string -> unit

abstract SetUserDictionary :
        userDictionary : string -> unit
Parameters
userDictionary (String)


SuggestSplitWords Property

SuggestSplitWords Property
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► SuggestSplitWords
Keyoti RapidSpell WPF
Whether to look for connected words in suggestions.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool SuggestSplitWords { get; set; }
bool SuggestSplitWords { get; set; }
Property SuggestSplitWords As Boolean
    Get
    Set
Property SuggestSplitWords As Boolean
    Get
    Set
property bool SuggestSplitWords {
    bool get ();
    void set (bool value);
}
property bool SuggestSplitWords {
    bool get ();
    void set (bool value);
}
abstract SuggestSplitWords : bool with get, set

abstract SuggestSplitWords : bool with get, set
Property Value
Boolean
Remarks
if this=true then suggestions may include joined words.

Eg; suggestions for "myhouse" will include "my house"


TextBoundary Property

TextBoundary Property
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► TextBoundary
Keyoti RapidSpell WPF
The AdvancedTextBoundary class to use to parse words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
AdvancedTextBoundary TextBoundary { get; set; }
AdvancedTextBoundary TextBoundary { get; set; }
Property TextBoundary As AdvancedTextBoundary
    Get
    Set
Property TextBoundary As AdvancedTextBoundary
    Get
    Set
property AdvancedTextBoundary^ TextBoundary {
    AdvancedTextBoundary^ get ();
    void set (AdvancedTextBoundary^ value);
}
property AdvancedTextBoundary^ TextBoundary {
    AdvancedTextBoundary^ get ();
    void set (AdvancedTextBoundary^ value);
}
abstract TextBoundary : AdvancedTextBoundary with get, set

abstract TextBoundary : AdvancedTextBoundary with get, set
Property Value
AdvancedTextBoundary


userDictionary Property

userDictionary Property
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► userDictionary
Keyoti RapidSpell WPF
The user dictionary, this should be null (C#) or nothing (VB.NET) if no user dictionary is being used.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
UserDictionary userDictionary { get; }
UserDictionary userDictionary { get; }
ReadOnly Property userDictionary As UserDictionary
    Get
ReadOnly Property userDictionary As UserDictionary
    Get
property UserDictionary^ userDictionary {
    UserDictionary^ get ();
}
property UserDictionary^ userDictionary {
    UserDictionary^ get ();
}
abstract userDictionary : UserDictionary with get

abstract userDictionary : UserDictionary with get
Property Value
UserDictionary


V2Parser Property

V2Parser Property
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► V2Parser
Keyoti RapidSpell WPF
Whether to use parser version 2 (specific to RapidSpellChecker).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool V2Parser { get; set; }
bool V2Parser { get; set; }
Property V2Parser As Boolean
    Get
    Set
Property V2Parser As Boolean
    Get
    Set
property bool V2Parser {
    bool get ();
    void set (bool value);
}
property bool V2Parser {
    bool get ();
    void set (bool value);
}
abstract V2Parser : bool with get, set

abstract V2Parser : bool with get, set
Property Value
Boolean


WarnDuplicates Property

WarnDuplicates Property
API ► Keyoti.RapidSpell.Wpf ► ICheckerEngine ► WarnDuplicates
Keyoti RapidSpell WPF
Whether to treat duplicate words as errors (eg. "this is is an error").
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool WarnDuplicates { get; set; }
bool WarnDuplicates { get; set; }
Property WarnDuplicates As Boolean
    Get
    Set
Property WarnDuplicates As Boolean
    Get
    Set
property bool WarnDuplicates {
    bool get ();
    void set (bool value);
}
property bool WarnDuplicates {
    bool get ();
    void set (bool value);
}
abstract WarnDuplicates : bool with get, set

abstract WarnDuplicates : bool with get, set
Property Value
Boolean


ISpellCheckableTextComponent Interface

ISpellCheckableTextComponent Interface
API ► Keyoti.RapidSpell.Wpf ► ISpellCheckableTextComponent
Keyoti RapidSpell WPF
Defines the interface required for a text component to be spell checkable using the RapidSpellDialog control (or RapidSpellGUI class)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public interface ISpellCheckableTextComponent
public interface ISpellCheckableTextComponent
Public Interface ISpellCheckableTextComponent
Public Interface ISpellCheckableTextComponent
public interface class ISpellCheckableTextComponent
public interface class ISpellCheckableTextComponent
type ISpellCheckableTextComponent =  interface end
type ISpellCheckableTextComponent =  interface end
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CaretPosition | The caret or selection start position
 | Dispose()()()() | Dispose of resources
 | Disposed | Occurs when the control is disposed of.
 | Enabled | Whether the textbox is enabled
 | GotFocus | Occurs when the control receives focus.
 | HideSelection | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus.
 | ReadOnly | Whether the textbox is readonly
 | ScrollToCaret()()()() | Scrolls the contents of the control to the current caret position.
 | Select(Int32, Int32) | Make a selection
 | SelectedText | Gets or sets a value indicating the currently selected text in the control.
 | SelectionEnd | Gets or sets the starting point of text selected in the text box.
 | SelectionLength | Gets or sets the number of characters selected in the text box.
 | SelectionStart | Gets or sets the starting point of text selected in the text box.
 | Text | Gets or sets the current text in the text box.
Remarks
This is typically used in conjunction with 3rd party text controls.


CaretPosition Property

CaretPosition Property
API ► Keyoti.RapidSpell.Wpf ► ISpellCheckableTextComponent ► CaretPosition
Keyoti RapidSpell WPF
The caret or selection start position
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
int CaretPosition { get; set; }
int CaretPosition { get; set; }
Property CaretPosition As Integer
    Get
    Set
Property CaretPosition As Integer
    Get
    Set
property int CaretPosition {
    int get ();
    void set (int value);
}
property int CaretPosition {
    int get ();
    void set (int value);
}
abstract CaretPosition : int with get, set

abstract CaretPosition : int with get, set
Property Value
Int32


Dispose Method

Dispose Method
API ► Keyoti.RapidSpell.Wpf ► ISpellCheckableTextComponent ► Dispose()()()()
Keyoti RapidSpell WPF
Dispose of resources
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void Dispose()
void Dispose()
Sub Dispose
Sub Dispose
void Dispose()
void Dispose()
abstract Dispose : unit -> unit

abstract Dispose : unit -> unit


Disposed Event

Disposed Event
API ► Keyoti.RapidSpell.Wpf ► ISpellCheckableTextComponent ► Disposed
Keyoti RapidSpell WPF
Occurs when the control is disposed of.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event EventHandler Disposed
event EventHandler Disposed
Event Disposed As EventHandler
Event Disposed As EventHandler
 event EventHandler^ Disposed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
 event EventHandler^ Disposed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Disposed : IEvent<EventHandler,
    EventArgs>

abstract Disposed : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


Enabled Property

Enabled Property
API ► Keyoti.RapidSpell.Wpf ► ISpellCheckableTextComponent ► Enabled
Keyoti RapidSpell WPF
Whether the textbox is enabled
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool Enabled { get; }
bool Enabled { get; }
ReadOnly Property Enabled As Boolean
    Get
ReadOnly Property Enabled As Boolean
    Get
property bool Enabled {
    bool get ();
}
property bool Enabled {
    bool get ();
}
abstract Enabled : bool with get

abstract Enabled : bool with get
Property Value
Boolean
Remarks
If not supported, return true.


GotFocus Event

GotFocus Event
API ► Keyoti.RapidSpell.Wpf ► ISpellCheckableTextComponent ► GotFocus
Keyoti RapidSpell WPF
Occurs when the control receives focus.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event RoutedEventHandler GotFocus
event RoutedEventHandler GotFocus
Event GotFocus As RoutedEventHandler
Event GotFocus As RoutedEventHandler
 event RoutedEventHandler^ GotFocus {
    void add (RoutedEventHandler^ value);
    void remove (RoutedEventHandler^ value);
}
 event RoutedEventHandler^ GotFocus {
    void add (RoutedEventHandler^ value);
    void remove (RoutedEventHandler^ value);
}
abstract GotFocus : IEvent<RoutedEventHandler,
    RoutedEventArgs>

abstract GotFocus : IEvent<RoutedEventHandler,
    RoutedEventArgs>
Value
RoutedEventHandler


HideSelection Property

HideSelection Property
API ► Keyoti.RapidSpell.Wpf ► ISpellCheckableTextComponent ► HideSelection
Keyoti RapidSpell WPF
Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool HideSelection { get; set; }
bool HideSelection { get; set; }
Property HideSelection As Boolean
    Get
    Set
Property HideSelection As Boolean
    Get
    Set
property bool HideSelection {
    bool get ();
    void set (bool value);
}
property bool HideSelection {
    bool get ();
    void set (bool value);
}
abstract HideSelection : bool with get, set

abstract HideSelection : bool with get, set
Property Value
Boolean


ReadOnly Property

ReadOnly Property
API ► Keyoti.RapidSpell.Wpf ► ISpellCheckableTextComponent ► ReadOnly
Keyoti RapidSpell WPF
Whether the textbox is readonly
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool ReadOnly { get; }
bool ReadOnly { get; }
ReadOnly Property ReadOnly As Boolean
    Get
ReadOnly Property ReadOnly As Boolean
    Get
property bool ReadOnly {
    bool get ();
}
property bool ReadOnly {
    bool get ();
}
abstract ReadOnly : bool with get

abstract ReadOnly : bool with get
Property Value
Boolean
Remarks
If not supported, return false.


ScrollToCaret Method

ScrollToCaret Method
API ► Keyoti.RapidSpell.Wpf ► ISpellCheckableTextComponent ► ScrollToCaret()()()()
Keyoti RapidSpell WPF
Scrolls the contents of the control to the current caret position.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void ScrollToCaret()
void ScrollToCaret()
Sub ScrollToCaret
Sub ScrollToCaret
void ScrollToCaret()
void ScrollToCaret()
abstract ScrollToCaret : unit -> unit

abstract ScrollToCaret : unit -> unit


Select Method (from, to)

Select Method (from, to)
API ► Keyoti.RapidSpell.Wpf ► ISpellCheckableTextComponent ► Select(Int32, Int32)
Keyoti RapidSpell WPF
Make a selection
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void Select(
    int from,
    int to
)
void Select(
    int from,
    int to
)
Sub Select (
    from As Integer,
    to As Integer
)
Sub Select (
    from As Integer,
    to As Integer
)
void Select(
    int from,
    int to
)
void Select(
    int from,
    int to
)
abstract Select :
        from : int *
        to : int -> unit

abstract Select :
        from : int *
        to : int -> unit
Parameters
from (Int32)
to (Int32)


SelectedText Property

SelectedText Property
API ► Keyoti.RapidSpell.Wpf ► ISpellCheckableTextComponent ► SelectedText
Keyoti RapidSpell WPF
Gets or sets a value indicating the currently selected text in the control.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string SelectedText { get; set; }
string SelectedText { get; set; }
Property SelectedText As String
    Get
    Set
Property SelectedText As String
    Get
    Set
property String^ SelectedText {
    String^ get ();
    void set (String^ value);
}
property String^ SelectedText {
    String^ get ();
    void set (String^ value);
}
abstract SelectedText : string with get, set

abstract SelectedText : string with get, set
Property Value
String


SelectionEnd Property

SelectionEnd Property
API ► Keyoti.RapidSpell.Wpf ► ISpellCheckableTextComponent ► SelectionEnd
Keyoti RapidSpell WPF
Gets or sets the starting point of text selected in the text box.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
int SelectionEnd { get; }
int SelectionEnd { get; }
ReadOnly Property SelectionEnd As Integer
    Get
ReadOnly Property SelectionEnd As Integer
    Get
property int SelectionEnd {
    int get ();
}
property int SelectionEnd {
    int get ();
}
abstract SelectionEnd : int with get

abstract SelectionEnd : int with get
Property Value
Int32


SelectionLength Property

SelectionLength Property
API ► Keyoti.RapidSpell.Wpf ► ISpellCheckableTextComponent ► SelectionLength
Keyoti RapidSpell WPF
Gets or sets the number of characters selected in the text box.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
int SelectionLength { get; set; }
int SelectionLength { get; set; }
Property SelectionLength As Integer
    Get
    Set
Property SelectionLength As Integer
    Get
    Set
property int SelectionLength {
    int get ();
    void set (int value);
}
property int SelectionLength {
    int get ();
    void set (int value);
}
abstract SelectionLength : int with get, set

abstract SelectionLength : int with get, set
Property Value
Int32


SelectionStart Property

SelectionStart Property
API ► Keyoti.RapidSpell.Wpf ► ISpellCheckableTextComponent ► SelectionStart
Keyoti RapidSpell WPF
Gets or sets the starting point of text selected in the text box.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
int SelectionStart { get; set; }
int SelectionStart { get; set; }
Property SelectionStart As Integer
    Get
    Set
Property SelectionStart As Integer
    Get
    Set
property int SelectionStart {
    int get ();
    void set (int value);
}
property int SelectionStart {
    int get ();
    void set (int value);
}
abstract SelectionStart : int with get, set

abstract SelectionStart : int with get, set
Property Value
Int32


Text Property

Text Property
API ► Keyoti.RapidSpell.Wpf ► ISpellCheckableTextComponent ► Text
Keyoti RapidSpell WPF
Gets or sets the current text in the text box.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string Text { get; set; }
string Text { get; set; }
Property Text As String
    Get
    Set
Property Text As String
    Get
    Set
property String^ Text {
    String^ get ();
    void set (String^ value);
}
property String^ Text {
    String^ get ();
    void set (String^ value);
}
abstract Text : string with get, set

abstract Text : string with get, set
Property Value
String


ISpellCheckableTextComponent2 Interface

ISpellCheckableTextComponent2 Interface
API ► Keyoti.RapidSpell.Wpf ► ISpellCheckableTextComponent2
Keyoti RapidSpell WPF
Defines the interface required for a text component to be spell checkable using the RapidSpellDialog control (or RapidSpellGUI class)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public interface ISpellCheckableTextComponent2 : ISpellCheckableTextComponent
public interface ISpellCheckableTextComponent2 : ISpellCheckableTextComponent
Public Interface ISpellCheckableTextComponent2
    Inherits ISpellCheckableTextComponent
Public Interface ISpellCheckableTextComponent2
    Inherits ISpellCheckableTextComponent
public interface class ISpellCheckableTextComponent2 : ISpellCheckableTextComponent
public interface class ISpellCheckableTextComponent2 : ISpellCheckableTextComponent
type ISpellCheckableTextComponent2 =
    interface
        interface ISpellCheckableTextComponent
    end
type ISpellCheckableTextComponent2 =
    interface
        interface ISpellCheckableTextComponent
    end
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CaretPosition | The caret or selection start position (Inherited from ISpellCheckableTextComponent.)
 | Dispose()()()() | Dispose of resources (Inherited from ISpellCheckableTextComponent.)
 | Disposed | Occurs when the control is disposed of. (Inherited from ISpellCheckableTextComponent.)
 | Enabled | Whether the textbox is enabled (Inherited from ISpellCheckableTextComponent.)
 | GotFocus | Occurs when the control receives focus. (Inherited from ISpellCheckableTextComponent.)
 | HideSelection | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus. (Inherited from ISpellCheckableTextComponent.)
 | ReadOnly | Whether the textbox is readonly (Inherited from ISpellCheckableTextComponent.)
 | ScrollToCaret()()()() | Scrolls the contents of the control to the current caret position. (Inherited from ISpellCheckableTextComponent.)
 | Select(Int32, Int32) | Make a selection (Inherited from ISpellCheckableTextComponent.)
 | SelectedText | Gets or sets a value indicating the currently selected text in the control. (Inherited from ISpellCheckableTextComponent.)
 | SelectionEnd | Gets or sets the starting point of text selected in the text box. (Inherited from ISpellCheckableTextComponent.)
 | SelectionLength | Gets or sets the number of characters selected in the text box. (Inherited from ISpellCheckableTextComponent.)
 | SelectionStart | Gets or sets the starting point of text selected in the text box. (Inherited from ISpellCheckableTextComponent.)
 | Text | Gets or sets the current text in the text box. (Inherited from ISpellCheckableTextComponent.)
Remarks
This is typically used in conjunction with 3rd party text controls.


IUserInterfaceFormPresenter Interface

IUserInterfaceFormPresenter Interface
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter
Keyoti RapidSpell WPF
Interface requirements for a dialog based UI form.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public interface IUserInterfaceFormPresenter : IDialogViewEventHandler
public interface IUserInterfaceFormPresenter : IDialogViewEventHandler
Public Interface IUserInterfaceFormPresenter
    Inherits IDialogViewEventHandler
Public Interface IUserInterfaceFormPresenter
    Inherits IDialogViewEventHandler
public interface class IUserInterfaceFormPresenter : IDialogViewEventHandler
public interface class IUserInterfaceFormPresenter : IDialogViewEventHandler
type IUserInterfaceFormPresenter =
    interface
        interface IDialogViewEventHandler
    end
type IUserInterfaceFormPresenter =
    interface
        interface IDialogViewEventHandler
    end
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddButtonText | Add button text.
 | AllOperationScope | The scope that ignore-all/change-all should have.
 | CancelButtonText | Cancel button text.
 | Cancelled | Whether the spell check has been cancelled.
 | ChangeAllButtonText | Change All button text.
 | ChangeButtonText | Change button text.
 | Check()()()() | Bring up the spell checker Form and start checking the component set by SetTextComponentToCheck.
 | Check(ISpellCheckableTextComponent) | Bring up the spell checker Form and start checking the TextBoxBase textComponent.
 | CheckCompletePopUpText | Check complete pop up text
 | CheckCompletePopUpTitle | Check complete pop up title
 | CheckCompoundWords | Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
 | CheckerEngine | The checker engine to use, this object must implement the ICheckerEngine interface, allows customization or replacement of the spell checker.
 | CheckFromStartOfText | Whether to check from the start of the text (true) or whereever the cursor is (false)
 | CheckingSpellingText | Checking spelling text
 | ConsiderationRange | The factor for words to consider for suggestions, lower values are faster but consider less words for suggestions. Default is 80. If w <= 1 this method won't do anything.
 | CreateDialogView | Indicates that a new IDialogView is being created, also provides chance to override the default IDialogView.
 | CreateDialogViewOptions | Indicates that a new IDialogViewOptions is being created, also provides chance to override the default IDialogViewOptions.
 | CreateDialogViewUserDictionaryEdit | Indicates that a new IDialogViewUserDictionaryEdit is being created, also provides chance to override the default IDialogViewUserDictionaryEdit.
 | CreateDialogViewUserDictionarySelect | Indicates that a new IDialogViewUserDictionarySelect is being created, also provides chance to override the default IDialogViewUserDictionarySelect.
 | DialogTitleText | Dialog title text
 | DialogView | The IDialogView to use
 | DialogView_AddButtonClick(Object, EventArgs) | The add button was clicked (Inherited from IDialogViewEventHandler.)
 | DialogView_CancelButtonClick(Object, EventArgs) | The cancel button was clicked (Inherited from IDialogViewEventHandler.)
 | DialogView_ChangeAllButtonClick(Object, EventArgs) | The change-all button was clicked (Inherited from IDialogViewEventHandler.)
 | DialogView_ChangeButtonClick(Object, EventArgs) | The change button was clicked (Inherited from IDialogViewEventHandler.)
 | DialogView_Closing(Object, CancelEventArgs) | The view is closing (Inherited from IDialogViewEventHandler.)
 | DialogView_IgnoreAllButtonClick(Object, EventArgs) | The ignore all button was clicked (Inherited from IDialogViewEventHandler.)
 | DialogView_IgnoreButtonClick(Object, EventArgs) | The ignore button was clicked (Inherited from IDialogViewEventHandler.)
 | DialogView_Load(Object, EventArgs) | The view has loaded (Inherited from IDialogViewEventHandler.)
 | DialogView_OptionsButtonClick(Object, EventArgs) | The options button was clicked (Inherited from IDialogViewEventHandler.)
 | DialogView_QueryTextBoxEnter(Object, EventArgs) | Query textbox has been entered (Inherited from IDialogViewEventHandler.)
 | DialogView_QueryTextBoxTextChanged(Object, EventArgs) | The text in the query textbox changed (Inherited from IDialogViewEventHandler.)
 | DialogView_SuggestionsListDoubleClick(Object, EventArgs) | The user double clicked on a suggested item. Not mandatory to implement. (Inherited from IDialogViewEventHandler.)
 | DialogView_UndoButtonClick(Object, EventArgs) | The undo button was clicked (Inherited from IDialogViewEventHandler.)
 | DialogView_UserNeedsSuggestionsChanged(Object, EventArgs) | User has checked the "Find Suggestions" checkbox (if it exists). (Inherited from IDialogViewEventHandler.)
 | DictFilePath | Optional file path to the main dictionary .dict file to use.
 | Dispose()()()() | Dispose of resources
 | DisposeAtEnd | Whether to dispose of this form when spell check is finished.
 | FindCapitalizedSuggestions | Whether to look for capitalized suggestions, note this will slow FindSuggestions down by about 7 times.
 | FindingSuggestionsLabelText | Finding suggestions label text.
 | FindSuggestionsLabelText | Find suggestions label text.
 | FinishedCheckingSelectionPopUpText | Finished checking selection dialog text
 | FinishedCheckingSelectionPopUpTitle | Finished checking selection dialog title
 | GUILanguage | The language to show the UI in.
 | IgnoreAllButtonText | Ignore All button text.
 | IgnoreButtonText | Ignore button text.
 | IgnoreCapitalizedWords | Sets whether to ignore words with capital letters.
 | IgnoreIncorrectSentenceCapitalization | Whether to ignore incorrect sentence capitalization.
 | IgnoreInEnglishLowerCaseI | Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
 | IgnoreWordsWithDigits | Whether to ignore words with numbers in them (eg. A10 or 7-11).
 | IgnoreXML | Whether to ignore XML/HTML tags, false by default.
 | IncludeUserDictionaryInSuggestions | Whether the user dictionary should be used in finding suggestions for misspelt words.
 | InDictionaryLabelText | In dictionary label text
 | IsDialogViewCreated()()()() | Whether a dialog view has already been created.
 | LanguageParser | The type of language parsing to use.
 | Load | Fired when the DialogView loads.
 | LookIntoHyphenatedText | Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
 | MaximumContextualWords | The maximum number of words to show the user in the sentence around misspelled words.
 | ModalAutoDispose | When running modally, determines if the dialog will be disposed of when spell check finishes.
 | ModalMode | Whether the spell checker will run modally. (Modal operation blocks the parent form)
 | ModalOwner | The owner window when used modally.
 | NoSuggestionsText | No suggestions found text
 | NotInDictionaryLabelText | Not in dictionary label text
 | NumberSuggestionList | Whether to number the items in the suggestion list, for quick user selection.
 | Options | Object responsible for holding, loading and saving the user's spell check options.
 | OptionsButtonText | Options button text
 | OptionsPresenter | Presenter for the user options form (IDialogViewOptions).
 | Ready | Fired when ready to proceed with first query.
 | RecheckDocumentRequest | Fired when the text should be rechecked
 | Remove()()()() | Safely frees up resources.
 | RemoveDuplicateWordText | Remove duplicate word text
 | ResumeButtonText | Resume button text
 | SeparateHyphenWords | Sets whether to treat hyphenated (-) words as separate words, default is false.
 | SetIgnoreOnceBadWords(ArrayList) | Provide a list of BadWord objects that have been ignored
 | SetTextComponentToCheck(TextBox) | Set the TextBox that this GUI will spell check.
 | SetTextComponentToCheck(RichTextBox) | Set the RichTextBox that this GUI will spell check.
 | ShowContextSentence | Whether to show the query in context of it's sentence/line.
 | ShowFinishedMessageBox | Whether a message box should be opened when the spell check is complete.
 | SpellCheckFinished | Fired when checking finishes
 | SpellCheckStarted | Fired when checking starts
 | SuggestionsLabelText | Suggestions label text
 | SuggestionsMethod | Sets the suggestions method to use. Either PHONETIC_SUGGESTIONS or HASHING_SUGGESTIONS
 | SuggestSplitWords | Whether to look for connected words in suggestions.
 | UndoButtonText | Undo button text
 | Undone | Fired when an Undo occurs
 | UserDictionary | Set the user dictionary object.
 | UserDictionaryFile | Set the user dictionary file, if this file doesn't exist it will be created.
 | UserQuery | Indicates that the user is being queried on a spelling error.
 | WarnDuplicates | Whether to show duplicate words as errors (eg. "this is is an error").
 | WordAdded | Fired when word added to user dictionary
 | WordChanged | Fired when word changed
 | WordChanging | Fired before a word is changed
 | WordIgnored | Fired when word ignored
Remarks
Implement this interface in custom UI objects that you wish to plug-in to RapidSpellDialog.

Note: Sub-classes of RapidSpellGUI implement this interface by inheritance (automatically).


AddButtonText Property

AddButtonText Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► AddButtonText
Keyoti RapidSpell WPF
Add button text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string AddButtonText { get; set; }
string AddButtonText { get; set; }
Property AddButtonText As String
    Get
    Set
Property AddButtonText As String
    Get
    Set
property String^ AddButtonText {
    String^ get ();
    void set (String^ value);
}
property String^ AddButtonText {
    String^ get ();
    void set (String^ value);
}
abstract AddButtonText : string with get, set

abstract AddButtonText : string with get, set
Property Value
String


AllOperationScope Property

AllOperationScope Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► AllOperationScope
Keyoti RapidSpell WPF
The scope that ignore-all/change-all should have.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
OperationScope AllOperationScope { get; set; }
OperationScope AllOperationScope { get; set; }
Property AllOperationScope As OperationScope
    Get
    Set
Property AllOperationScope As OperationScope
    Get
    Set
property OperationScope AllOperationScope {
    OperationScope get ();
    void set (OperationScope value);
}
property OperationScope AllOperationScope {
    OperationScope get ();
    void set (OperationScope value);
}
abstract AllOperationScope : OperationScope with get, set

abstract AllOperationScope : OperationScope with get, set
Property Value
OperationScope


CancelButtonText Property

CancelButtonText Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► CancelButtonText
Keyoti RapidSpell WPF
Cancel button text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string CancelButtonText { get; set; }
string CancelButtonText { get; set; }
Property CancelButtonText As String
    Get
    Set
Property CancelButtonText As String
    Get
    Set
property String^ CancelButtonText {
    String^ get ();
    void set (String^ value);
}
property String^ CancelButtonText {
    String^ get ();
    void set (String^ value);
}
abstract CancelButtonText : string with get, set

abstract CancelButtonText : string with get, set
Property Value
String


Cancelled Property

Cancelled Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► Cancelled
Keyoti RapidSpell WPF
Whether the spell check has been cancelled.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool Cancelled { get; }
bool Cancelled { get; }
ReadOnly Property Cancelled As Boolean
    Get
ReadOnly Property Cancelled As Boolean
    Get
property bool Cancelled {
    bool get ();
}
property bool Cancelled {
    bool get ();
}
abstract Cancelled : bool with get

abstract Cancelled : bool with get
Property Value
Boolean


ChangeAllButtonText Property

ChangeAllButtonText Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► ChangeAllButtonText
Keyoti RapidSpell WPF
Change All button text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string ChangeAllButtonText { get; set; }
string ChangeAllButtonText { get; set; }
Property ChangeAllButtonText As String
    Get
    Set
Property ChangeAllButtonText As String
    Get
    Set
property String^ ChangeAllButtonText {
    String^ get ();
    void set (String^ value);
}
property String^ ChangeAllButtonText {
    String^ get ();
    void set (String^ value);
}
abstract ChangeAllButtonText : string with get, set

abstract ChangeAllButtonText : string with get, set
Property Value
String


ChangeButtonText Property

ChangeButtonText Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► ChangeButtonText
Keyoti RapidSpell WPF
Change button text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string ChangeButtonText { get; set; }
string ChangeButtonText { get; set; }
Property ChangeButtonText As String
    Get
    Set
Property ChangeButtonText As String
    Get
    Set
property String^ ChangeButtonText {
    String^ get ();
    void set (String^ value);
}
property String^ ChangeButtonText {
    String^ get ();
    void set (String^ value);
}
abstract ChangeButtonText : string with get, set

abstract ChangeButtonText : string with get, set
Property Value
String


Check Method

Check Method
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► Check()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | Check()()()() | Bring up the spell checker Form and start checking the component set by SetTextComponentToCheck.
 | Check(ISpellCheckableTextComponent) | Bring up the spell checker Form and start checking the TextBoxBase textComponent.


Check Method

Check Method
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► Check()()()()
Keyoti RapidSpell WPF
Bring up the spell checker Form and start checking the component set by SetTextComponentToCheck.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void Check()
void Check()
Sub Check
Sub Check
void Check()
void Check()
abstract Check : unit -> unit

abstract Check : unit -> unit
Exceptions
Exception | Condition
NoTextComponentException | if SetTextComponentToCheck hasn't be called first with a TextBoxBase object.


Check Method (textComponent)

Check Method (textComponent)
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► Check(ISpellCheckableTextComponent)
Keyoti RapidSpell WPF
Bring up the spell checker Form and start checking the TextBoxBase textComponent.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void Check(
    ISpellCheckableTextComponent textComponent
)
void Check(
    ISpellCheckableTextComponent textComponent
)
Sub Check (
    textComponent As ISpellCheckableTextComponent
)
Sub Check (
    textComponent As ISpellCheckableTextComponent
)
void Check(
    ISpellCheckableTextComponent^ textComponent
)
void Check(
    ISpellCheckableTextComponent^ textComponent
)
abstract Check :
        textComponent : ISpellCheckableTextComponent -> unit

abstract Check :
        textComponent : ISpellCheckableTextComponent -> unit
Parameters
textComponent (ISpellCheckableTextComponent)
Exceptions
Exception | Condition
ArgumentNullException | if textComponent parameter is null.


CheckCompletePopUpText Property

CheckCompletePopUpText Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► CheckCompletePopUpText
Keyoti RapidSpell WPF
Check complete pop up text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string CheckCompletePopUpText { get; set; }
string CheckCompletePopUpText { get; set; }
Property CheckCompletePopUpText As String
    Get
    Set
Property CheckCompletePopUpText As String
    Get
    Set
property String^ CheckCompletePopUpText {
    String^ get ();
    void set (String^ value);
}
property String^ CheckCompletePopUpText {
    String^ get ();
    void set (String^ value);
}
abstract CheckCompletePopUpText : string with get, set

abstract CheckCompletePopUpText : string with get, set
Property Value
String


CheckCompletePopUpTitle Property

CheckCompletePopUpTitle Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► CheckCompletePopUpTitle
Keyoti RapidSpell WPF
Check complete pop up title
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string CheckCompletePopUpTitle { get; set; }
string CheckCompletePopUpTitle { get; set; }
Property CheckCompletePopUpTitle As String
    Get
    Set
Property CheckCompletePopUpTitle As String
    Get
    Set
property String^ CheckCompletePopUpTitle {
    String^ get ();
    void set (String^ value);
}
property String^ CheckCompletePopUpTitle {
    String^ get ();
    void set (String^ value);
}
abstract CheckCompletePopUpTitle : string with get, set

abstract CheckCompletePopUpTitle : string with get, set
Property Value
String


CheckCompoundWords Property

CheckCompoundWords Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► CheckCompoundWords
Keyoti RapidSpell WPF
Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool CheckCompoundWords { get; set; }
bool CheckCompoundWords { get; set; }
Property CheckCompoundWords As Boolean
    Get
    Set
Property CheckCompoundWords As Boolean
    Get
    Set
property bool CheckCompoundWords {
    bool get ();
    void set (bool value);
}
property bool CheckCompoundWords {
    bool get ();
    void set (bool value);
}
abstract CheckCompoundWords : bool with get, set

abstract CheckCompoundWords : bool with get, set
Property Value
Boolean
Remarks
If this=false then LookUp("thesewordsarejoined") = false

If this=true then LookUp("thesewordsarejoined") = true

If this=false then LookUp("abcdef") = false

If this=true then LookUp("abcdef") = false

Setting this to true will degrade lookup performance


CheckerEngine Property

CheckerEngine Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► CheckerEngine
Keyoti RapidSpell WPF
The checker engine to use, this object must implement the ICheckerEngine interface, allows customization or replacement of the spell checker.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
ICheckerEngine CheckerEngine { get; set; }
ICheckerEngine CheckerEngine { get; set; }
Property CheckerEngine As ICheckerEngine
    Get
    Set
Property CheckerEngine As ICheckerEngine
    Get
    Set
property ICheckerEngine^ CheckerEngine {
    ICheckerEngine^ get ();
    void set (ICheckerEngine^ value);
}
property ICheckerEngine^ CheckerEngine {
    ICheckerEngine^ get ();
    void set (ICheckerEngine^ value);
}
abstract CheckerEngine : ICheckerEngine with get, set

abstract CheckerEngine : ICheckerEngine with get, set
Property Value
ICheckerEngine
Remarks
Use this property to replace the object used to perform checking, it is not necessary to replace this with a spell checker, any type of word parser can be used. For example an abbreviations checker could be written to replace common words with abbreviations. Caveat: Most properties in RapidSpellGUI are mirrors of properties in ICheckerEngine, setting a CheckerEngine AFTER setting properties in RapidSpellGUI will overwrite those property values with the values of CheckerEngine.


CheckFromStartOfText Property

CheckFromStartOfText Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► CheckFromStartOfText
Keyoti RapidSpell WPF
Whether to check from the start of the text (true) or whereever the cursor is (false)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool CheckFromStartOfText { get; set; }
bool CheckFromStartOfText { get; set; }
Property CheckFromStartOfText As Boolean
    Get
    Set
Property CheckFromStartOfText As Boolean
    Get
    Set
property bool CheckFromStartOfText {
    bool get ();
    void set (bool value);
}
property bool CheckFromStartOfText {
    bool get ();
    void set (bool value);
}
abstract CheckFromStartOfText : bool with get, set

abstract CheckFromStartOfText : bool with get, set
Property Value
Boolean


CheckingSpellingText Property

CheckingSpellingText Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► CheckingSpellingText
Keyoti RapidSpell WPF
Checking spelling text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string CheckingSpellingText { get; set; }
string CheckingSpellingText { get; set; }
Property CheckingSpellingText As String
    Get
    Set
Property CheckingSpellingText As String
    Get
    Set
property String^ CheckingSpellingText {
    String^ get ();
    void set (String^ value);
}
property String^ CheckingSpellingText {
    String^ get ();
    void set (String^ value);
}
abstract CheckingSpellingText : string with get, set

abstract CheckingSpellingText : string with get, set
Property Value
String


ConsiderationRange Property

ConsiderationRange Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► ConsiderationRange
Keyoti RapidSpell WPF
The factor for words to consider for suggestions, lower values are faster but consider less words for suggestions. Default is 80. If w <= 1 this method won't do anything.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
int ConsiderationRange { get; set; }
int ConsiderationRange { get; set; }
Property ConsiderationRange As Integer
    Get
    Set
Property ConsiderationRange As Integer
    Get
    Set
property int ConsiderationRange {
    int get ();
    void set (int value);
}
property int ConsiderationRange {
    int get ();
    void set (int value);
}
abstract ConsiderationRange : int with get, set

abstract ConsiderationRange : int with get, set
Property Value
Int32


CreateDialogView Event

CreateDialogView Event
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► CreateDialogView
Keyoti RapidSpell WPF
Indicates that a new IDialogView is being created, also provides chance to override the default IDialogView.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event CreateDialogViewEventHandler CreateDialogView
event CreateDialogViewEventHandler CreateDialogView
Event CreateDialogView As CreateDialogViewEventHandler
Event CreateDialogView As CreateDialogViewEventHandler
 event CreateDialogViewEventHandler^ CreateDialogView {
    void add (CreateDialogViewEventHandler^ value);
    void remove (CreateDialogViewEventHandler^ value);
}
 event CreateDialogViewEventHandler^ CreateDialogView {
    void add (CreateDialogViewEventHandler^ value);
    void remove (CreateDialogViewEventHandler^ value);
}
abstract CreateDialogView : IEvent<CreateDialogViewEventHandler,
    CreateDialogViewEventArgs>

abstract CreateDialogView : IEvent<CreateDialogViewEventHandler,
    CreateDialogViewEventArgs>
Value
CreateDialogViewEventHandler


CreateDialogViewOptions Event

CreateDialogViewOptions Event
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► CreateDialogViewOptions
Keyoti RapidSpell WPF
Indicates that a new IDialogViewOptions is being created, also provides chance to override the default IDialogViewOptions.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event CreateDialogViewOptionsEventHandler CreateDialogViewOptions
event CreateDialogViewOptionsEventHandler CreateDialogViewOptions
Event CreateDialogViewOptions As CreateDialogViewOptionsEventHandler
Event CreateDialogViewOptions As CreateDialogViewOptionsEventHandler
 event CreateDialogViewOptionsEventHandler^ CreateDialogViewOptions {
    void add (CreateDialogViewOptionsEventHandler^ value);
    void remove (CreateDialogViewOptionsEventHandler^ value);
}
 event CreateDialogViewOptionsEventHandler^ CreateDialogViewOptions {
    void add (CreateDialogViewOptionsEventHandler^ value);
    void remove (CreateDialogViewOptionsEventHandler^ value);
}
abstract CreateDialogViewOptions : IEvent<CreateDialogViewOptionsEventHandler,
    CreateDialogViewOptionsEventArgs>

abstract CreateDialogViewOptions : IEvent<CreateDialogViewOptionsEventHandler,
    CreateDialogViewOptionsEventArgs>
Value
CreateDialogViewOptionsEventHandler


CreateDialogViewUserDictionaryEdit Event

CreateDialogViewUserDictionaryEdit Event
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► CreateDialogViewUserDictionaryEdit
Keyoti RapidSpell WPF
Indicates that a new IDialogViewUserDictionaryEdit is being created, also provides chance to override the default IDialogViewUserDictionaryEdit.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event CreateDialogViewUserDictionaryEditEventHandler CreateDialogViewUserDictionaryEdit
event CreateDialogViewUserDictionaryEditEventHandler CreateDialogViewUserDictionaryEdit
Event CreateDialogViewUserDictionaryEdit As CreateDialogViewUserDictionaryEditEventHandler
Event CreateDialogViewUserDictionaryEdit As CreateDialogViewUserDictionaryEditEventHandler
 event CreateDialogViewUserDictionaryEditEventHandler^ CreateDialogViewUserDictionaryEdit {
    void add (CreateDialogViewUserDictionaryEditEventHandler^ value);
    void remove (CreateDialogViewUserDictionaryEditEventHandler^ value);
}
 event CreateDialogViewUserDictionaryEditEventHandler^ CreateDialogViewUserDictionaryEdit {
    void add (CreateDialogViewUserDictionaryEditEventHandler^ value);
    void remove (CreateDialogViewUserDictionaryEditEventHandler^ value);
}
abstract CreateDialogViewUserDictionaryEdit : IEvent<CreateDialogViewUserDictionaryEditEventHandler,
    CreateDialogViewUserDictionaryEditEventArgs>

abstract CreateDialogViewUserDictionaryEdit : IEvent<CreateDialogViewUserDictionaryEditEventHandler,
    CreateDialogViewUserDictionaryEditEventArgs>
Value
CreateDialogViewUserDictionaryEditEventHandler


CreateDialogViewUserDictionarySelect Event

CreateDialogViewUserDictionarySelect Event
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► CreateDialogViewUserDictionarySelect
Keyoti RapidSpell WPF
Indicates that a new IDialogViewUserDictionarySelect is being created, also provides chance to override the default IDialogViewUserDictionarySelect.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event CreateDialogViewUserDictionarySelectEventHandler CreateDialogViewUserDictionarySelect
event CreateDialogViewUserDictionarySelectEventHandler CreateDialogViewUserDictionarySelect
Event CreateDialogViewUserDictionarySelect As CreateDialogViewUserDictionarySelectEventHandler
Event CreateDialogViewUserDictionarySelect As CreateDialogViewUserDictionarySelectEventHandler
 event CreateDialogViewUserDictionarySelectEventHandler^ CreateDialogViewUserDictionarySelect {
    void add (CreateDialogViewUserDictionarySelectEventHandler^ value);
    void remove (CreateDialogViewUserDictionarySelectEventHandler^ value);
}
 event CreateDialogViewUserDictionarySelectEventHandler^ CreateDialogViewUserDictionarySelect {
    void add (CreateDialogViewUserDictionarySelectEventHandler^ value);
    void remove (CreateDialogViewUserDictionarySelectEventHandler^ value);
}
abstract CreateDialogViewUserDictionarySelect : IEvent<CreateDialogViewUserDictionarySelectEventHandler,
    CreateDialogViewUserDictionarySelectEventArgs>

abstract CreateDialogViewUserDictionarySelect : IEvent<CreateDialogViewUserDictionarySelectEventHandler,
    CreateDialogViewUserDictionarySelectEventArgs>
Value
CreateDialogViewUserDictionarySelectEventHandler


DialogTitleText Property

DialogTitleText Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► DialogTitleText
Keyoti RapidSpell WPF
Dialog title text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string DialogTitleText { get; set; }
string DialogTitleText { get; set; }
Property DialogTitleText As String
    Get
    Set
Property DialogTitleText As String
    Get
    Set
property String^ DialogTitleText {
    String^ get ();
    void set (String^ value);
}
property String^ DialogTitleText {
    String^ get ();
    void set (String^ value);
}
abstract DialogTitleText : string with get, set

abstract DialogTitleText : string with get, set
Property Value
String


DialogView Property

DialogView Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► DialogView
Keyoti RapidSpell WPF
The IDialogView to use
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
IDialogView DialogView { get; set; }
IDialogView DialogView { get; set; }
Property DialogView As IDialogView
    Get
    Set
Property DialogView As IDialogView
    Get
    Set
property IDialogView^ DialogView {
    IDialogView^ get ();
    void set (IDialogView^ value);
}
property IDialogView^ DialogView {
    IDialogView^ get ();
    void set (IDialogView^ value);
}
abstract DialogView : IDialogView with get, set

abstract DialogView : IDialogView with get, set
Property Value
IDialogView


DictFilePath Property

DictFilePath Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► DictFilePath
Keyoti RapidSpell WPF
Optional file path to the main dictionary .dict file to use.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string DictFilePath { get; set; }
string DictFilePath { get; set; }
Property DictFilePath As String
    Get
    Set
Property DictFilePath As String
    Get
    Set
property String^ DictFilePath {
    String^ get ();
    void set (String^ value);
}
property String^ DictFilePath {
    String^ get ();
    void set (String^ value);
}
abstract DictFilePath : string with get, set

abstract DictFilePath : string with get, set
Property Value
String


Dispose Method

Dispose Method
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► Dispose()()()()
Keyoti RapidSpell WPF
Dispose of resources
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void Dispose()
void Dispose()
Sub Dispose
Sub Dispose
void Dispose()
void Dispose()
abstract Dispose : unit -> unit

abstract Dispose : unit -> unit


DisposeAtEnd Property

DisposeAtEnd Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► DisposeAtEnd
Keyoti RapidSpell WPF
Whether to dispose of this form when spell check is finished.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool DisposeAtEnd { get; set; }
bool DisposeAtEnd { get; set; }
Property DisposeAtEnd As Boolean
    Get
    Set
Property DisposeAtEnd As Boolean
    Get
    Set
property bool DisposeAtEnd {
    bool get ();
    void set (bool value);
}
property bool DisposeAtEnd {
    bool get ();
    void set (bool value);
}
abstract DisposeAtEnd : bool with get, set

abstract DisposeAtEnd : bool with get, set
Property Value
Boolean


FindCapitalizedSuggestions Property

FindCapitalizedSuggestions Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► FindCapitalizedSuggestions
Keyoti RapidSpell WPF
Whether to look for capitalized suggestions, note this will slow FindSuggestions down by about 7 times.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool FindCapitalizedSuggestions { get; set; }
bool FindCapitalizedSuggestions { get; set; }
Property FindCapitalizedSuggestions As Boolean
    Get
    Set
Property FindCapitalizedSuggestions As Boolean
    Get
    Set
property bool FindCapitalizedSuggestions {
    bool get ();
    void set (bool value);
}
property bool FindCapitalizedSuggestions {
    bool get ();
    void set (bool value);
}
abstract FindCapitalizedSuggestions : bool with get, set

abstract FindCapitalizedSuggestions : bool with get, set
Property Value
Boolean


FindingSuggestionsLabelText Property

FindingSuggestionsLabelText Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► FindingSuggestionsLabelText
Keyoti RapidSpell WPF
Finding suggestions label text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string FindingSuggestionsLabelText { get; set; }
string FindingSuggestionsLabelText { get; set; }
Property FindingSuggestionsLabelText As String
    Get
    Set
Property FindingSuggestionsLabelText As String
    Get
    Set
property String^ FindingSuggestionsLabelText {
    String^ get ();
    void set (String^ value);
}
property String^ FindingSuggestionsLabelText {
    String^ get ();
    void set (String^ value);
}
abstract FindingSuggestionsLabelText : string with get, set

abstract FindingSuggestionsLabelText : string with get, set
Property Value
String


FindSuggestionsLabelText Property

FindSuggestionsLabelText Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► FindSuggestionsLabelText
Keyoti RapidSpell WPF
Find suggestions label text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string FindSuggestionsLabelText { get; set; }
string FindSuggestionsLabelText { get; set; }
Property FindSuggestionsLabelText As String
    Get
    Set
Property FindSuggestionsLabelText As String
    Get
    Set
property String^ FindSuggestionsLabelText {
    String^ get ();
    void set (String^ value);
}
property String^ FindSuggestionsLabelText {
    String^ get ();
    void set (String^ value);
}
abstract FindSuggestionsLabelText : string with get, set

abstract FindSuggestionsLabelText : string with get, set
Property Value
String


FinishedCheckingSelectionPopUpText Property

FinishedCheckingSelectionPopUpText Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► FinishedCheckingSelectionPopUpText
Keyoti RapidSpell WPF
Finished checking selection dialog text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string FinishedCheckingSelectionPopUpText { get; set; }
string FinishedCheckingSelectionPopUpText { get; set; }
Property FinishedCheckingSelectionPopUpText As String
    Get
    Set
Property FinishedCheckingSelectionPopUpText As String
    Get
    Set
property String^ FinishedCheckingSelectionPopUpText {
    String^ get ();
    void set (String^ value);
}
property String^ FinishedCheckingSelectionPopUpText {
    String^ get ();
    void set (String^ value);
}
abstract FinishedCheckingSelectionPopUpText : string with get, set

abstract FinishedCheckingSelectionPopUpText : string with get, set
Property Value
String


FinishedCheckingSelectionPopUpTitle Property

FinishedCheckingSelectionPopUpTitle Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► FinishedCheckingSelectionPopUpTitle
Keyoti RapidSpell WPF
Finished checking selection dialog title
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string FinishedCheckingSelectionPopUpTitle { get; set; }
string FinishedCheckingSelectionPopUpTitle { get; set; }
Property FinishedCheckingSelectionPopUpTitle As String
    Get
    Set
Property FinishedCheckingSelectionPopUpTitle As String
    Get
    Set
property String^ FinishedCheckingSelectionPopUpTitle {
    String^ get ();
    void set (String^ value);
}
property String^ FinishedCheckingSelectionPopUpTitle {
    String^ get ();
    void set (String^ value);
}
abstract FinishedCheckingSelectionPopUpTitle : string with get, set

abstract FinishedCheckingSelectionPopUpTitle : string with get, set
Property Value
String


GUILanguage Property

GUILanguage Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► GUILanguage
Keyoti RapidSpell WPF
The language to show the UI in.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
LanguageType GUILanguage { get; set; }
LanguageType GUILanguage { get; set; }
Property GUILanguage As LanguageType
    Get
    Set
Property GUILanguage As LanguageType
    Get
    Set
property LanguageType GUILanguage {
    LanguageType get ();
    void set (LanguageType value);
}
property LanguageType GUILanguage {
    LanguageType get ();
    void set (LanguageType value);
}
abstract GUILanguage : LanguageType with get, set

abstract GUILanguage : LanguageType with get, set
Property Value
LanguageType


IgnoreAllButtonText Property

IgnoreAllButtonText Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► IgnoreAllButtonText
Keyoti RapidSpell WPF
Ignore All button text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string IgnoreAllButtonText { get; set; }
string IgnoreAllButtonText { get; set; }
Property IgnoreAllButtonText As String
    Get
    Set
Property IgnoreAllButtonText As String
    Get
    Set
property String^ IgnoreAllButtonText {
    String^ get ();
    void set (String^ value);
}
property String^ IgnoreAllButtonText {
    String^ get ();
    void set (String^ value);
}
abstract IgnoreAllButtonText : string with get, set

abstract IgnoreAllButtonText : string with get, set
Property Value
String


IgnoreButtonText Property

IgnoreButtonText Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► IgnoreButtonText
Keyoti RapidSpell WPF
Ignore button text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string IgnoreButtonText { get; set; }
string IgnoreButtonText { get; set; }
Property IgnoreButtonText As String
    Get
    Set
Property IgnoreButtonText As String
    Get
    Set
property String^ IgnoreButtonText {
    String^ get ();
    void set (String^ value);
}
property String^ IgnoreButtonText {
    String^ get ();
    void set (String^ value);
}
abstract IgnoreButtonText : string with get, set

abstract IgnoreButtonText : string with get, set
Property Value
String


IgnoreCapitalizedWords Property

IgnoreCapitalizedWords Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► IgnoreCapitalizedWords
Keyoti RapidSpell WPF
Sets whether to ignore words with capital letters.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool IgnoreCapitalizedWords { get; set; }
bool IgnoreCapitalizedWords { get; set; }
Property IgnoreCapitalizedWords As Boolean
    Get
    Set
Property IgnoreCapitalizedWords As Boolean
    Get
    Set
property bool IgnoreCapitalizedWords {
    bool get ();
    void set (bool value);
}
property bool IgnoreCapitalizedWords {
    bool get ();
    void set (bool value);
}
abstract IgnoreCapitalizedWords : bool with get, set

abstract IgnoreCapitalizedWords : bool with get, set
Property Value
Boolean


IgnoreIncorrectSentenceCapitalization Property

IgnoreIncorrectSentenceCapitalization Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► IgnoreIncorrectSentenceCapitalization
Keyoti RapidSpell WPF
Whether to ignore incorrect sentence capitalization.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool IgnoreIncorrectSentenceCapitalization { get; set; }
bool IgnoreIncorrectSentenceCapitalization { get; set; }
Property IgnoreIncorrectSentenceCapitalization As Boolean
    Get
    Set
Property IgnoreIncorrectSentenceCapitalization As Boolean
    Get
    Set
property bool IgnoreIncorrectSentenceCapitalization {
    bool get ();
    void set (bool value);
}
property bool IgnoreIncorrectSentenceCapitalization {
    bool get ();
    void set (bool value);
}
abstract IgnoreIncorrectSentenceCapitalization : bool with get, set

abstract IgnoreIncorrectSentenceCapitalization : bool with get, set
Property Value
Boolean


IgnoreInEnglishLowerCaseI Property

IgnoreInEnglishLowerCaseI Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► IgnoreInEnglishLowerCaseI
Keyoti RapidSpell WPF
Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool IgnoreInEnglishLowerCaseI { get; set; }
bool IgnoreInEnglishLowerCaseI { get; set; }
Property IgnoreInEnglishLowerCaseI As Boolean
    Get
    Set
Property IgnoreInEnglishLowerCaseI As Boolean
    Get
    Set
property bool IgnoreInEnglishLowerCaseI {
    bool get ();
    void set (bool value);
}
property bool IgnoreInEnglishLowerCaseI {
    bool get ();
    void set (bool value);
}
abstract IgnoreInEnglishLowerCaseI : bool with get, set

abstract IgnoreInEnglishLowerCaseI : bool with get, set
Property Value
Boolean


IgnoreWordsWithDigits Property

IgnoreWordsWithDigits Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► IgnoreWordsWithDigits
Keyoti RapidSpell WPF
Whether to ignore words with numbers in them (eg. A10 or 7-11).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool IgnoreWordsWithDigits { get; set; }
bool IgnoreWordsWithDigits { get; set; }
Property IgnoreWordsWithDigits As Boolean
    Get
    Set
Property IgnoreWordsWithDigits As Boolean
    Get
    Set
property bool IgnoreWordsWithDigits {
    bool get ();
    void set (bool value);
}
property bool IgnoreWordsWithDigits {
    bool get ();
    void set (bool value);
}
abstract IgnoreWordsWithDigits : bool with get, set

abstract IgnoreWordsWithDigits : bool with get, set
Property Value
Boolean


IgnoreXML Property

IgnoreXML Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► IgnoreXML
Keyoti RapidSpell WPF
Whether to ignore XML/HTML tags, false by default.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool IgnoreXML { get; set; }
bool IgnoreXML { get; set; }
Property IgnoreXML As Boolean
    Get
    Set
Property IgnoreXML As Boolean
    Get
    Set
property bool IgnoreXML {
    bool get ();
    void set (bool value);
}
property bool IgnoreXML {
    bool get ();
    void set (bool value);
}
abstract IgnoreXML : bool with get, set

abstract IgnoreXML : bool with get, set
Property Value
Boolean
Remarks
This identifies XML tags as anything in between < and > characters, there for it will cause undesirable effects in text such as "the sign for less than is < and the sign for greater than is >". Of course in HTML that should have been written as "the sign for less than is &lt; and the sign for greater than is &gt;" anyway, which would be fine.


IncludeUserDictionaryInSuggestions Property

IncludeUserDictionaryInSuggestions Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► IncludeUserDictionaryInSuggestions
Keyoti RapidSpell WPF
Whether the user dictionary should be used in finding suggestions for misspelt words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool IncludeUserDictionaryInSuggestions { get; set; }
bool IncludeUserDictionaryInSuggestions { get; set; }
Property IncludeUserDictionaryInSuggestions As Boolean
    Get
    Set
Property IncludeUserDictionaryInSuggestions As Boolean
    Get
    Set
property bool IncludeUserDictionaryInSuggestions {
    bool get ();
    void set (bool value);
}
property bool IncludeUserDictionaryInSuggestions {
    bool get ();
    void set (bool value);
}
abstract IncludeUserDictionaryInSuggestions : bool with get, set

abstract IncludeUserDictionaryInSuggestions : bool with get, set
Property Value
Boolean


InDictionaryLabelText Property

InDictionaryLabelText Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► InDictionaryLabelText
Keyoti RapidSpell WPF
In dictionary label text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string InDictionaryLabelText { get; set; }
string InDictionaryLabelText { get; set; }
Property InDictionaryLabelText As String
    Get
    Set
Property InDictionaryLabelText As String
    Get
    Set
property String^ InDictionaryLabelText {
    String^ get ();
    void set (String^ value);
}
property String^ InDictionaryLabelText {
    String^ get ();
    void set (String^ value);
}
abstract InDictionaryLabelText : string with get, set

abstract InDictionaryLabelText : string with get, set
Property Value
String


IsDialogViewCreated Method

IsDialogViewCreated Method
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► IsDialogViewCreated()()()()
Keyoti RapidSpell WPF
Whether a dialog view has already been created.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool IsDialogViewCreated()
bool IsDialogViewCreated()
Function IsDialogViewCreated As Boolean
Function IsDialogViewCreated As Boolean
bool IsDialogViewCreated()
bool IsDialogViewCreated()
abstract IsDialogViewCreated : unit -> bool

abstract IsDialogViewCreated : unit -> bool
Return Value
Boolean


LanguageParser Property

LanguageParser Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► LanguageParser
Keyoti RapidSpell WPF
The type of language parsing to use.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
LanguageType LanguageParser { get; set; }
LanguageType LanguageParser { get; set; }
Property LanguageParser As LanguageType
    Get
    Set
Property LanguageParser As LanguageType
    Get
    Set
property LanguageType LanguageParser {
    LanguageType get ();
    void set (LanguageType value);
}
property LanguageType LanguageParser {
    LanguageType get ();
    void set (LanguageType value);
}
abstract LanguageParser : LanguageType with get, set

abstract LanguageParser : LanguageType with get, set
Property Value
LanguageType
Remarks
Eg. If the dictionary is set to French, you should use the French parser.


Load Event

Load Event
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► Load
Keyoti RapidSpell WPF
Fired when the DialogView loads.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event EventHandler Load
event EventHandler Load
Event Load As EventHandler
Event Load As EventHandler
 event EventHandler^ Load {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
 event EventHandler^ Load {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Load : IEvent<EventHandler,
    EventArgs>

abstract Load : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


LookIntoHyphenatedText Property

LookIntoHyphenatedText Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► LookIntoHyphenatedText
Keyoti RapidSpell WPF
Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool LookIntoHyphenatedText { get; set; }
bool LookIntoHyphenatedText { get; set; }
Property LookIntoHyphenatedText As Boolean
    Get
    Set
Property LookIntoHyphenatedText As Boolean
    Get
    Set
property bool LookIntoHyphenatedText {
    bool get ();
    void set (bool value);
}
property bool LookIntoHyphenatedText {
    bool get ();
    void set (bool value);
}
abstract LookIntoHyphenatedText : bool with get, set

abstract LookIntoHyphenatedText : bool with get, set
Property Value
Boolean
Remarks
Eg. "socio-economic" will be checked as "socio" and "economic".


MaximumContextualWords Property

MaximumContextualWords Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► MaximumContextualWords
Keyoti RapidSpell WPF
The maximum number of words to show the user in the sentence around misspelled words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
int MaximumContextualWords { get; set; }
int MaximumContextualWords { get; set; }
Property MaximumContextualWords As Integer
    Get
    Set
Property MaximumContextualWords As Integer
    Get
    Set
property int MaximumContextualWords {
    int get ();
    void set (int value);
}
property int MaximumContextualWords {
    int get ();
    void set (int value);
}
abstract MaximumContextualWords : int with get, set

abstract MaximumContextualWords : int with get, set
Property Value
Int32


ModalAutoDispose Property

ModalAutoDispose Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► ModalAutoDispose
Keyoti RapidSpell WPF
When running modally, determines if the dialog will be disposed of when spell check finishes.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool ModalAutoDispose { get; set; }
bool ModalAutoDispose { get; set; }
Property ModalAutoDispose As Boolean
    Get
    Set
Property ModalAutoDispose As Boolean
    Get
    Set
property bool ModalAutoDispose {
    bool get ();
    void set (bool value);
}
property bool ModalAutoDispose {
    bool get ();
    void set (bool value);
}
abstract ModalAutoDispose : bool with get, set

abstract ModalAutoDispose : bool with get, set
Property Value
Boolean
Remarks
If a modal form disposes of itself, there will be slight flickering on the screen, to prevent this, set this property to false and call Dispose() when finished with this control.


ModalMode Property

ModalMode Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► ModalMode
Keyoti RapidSpell WPF
Whether the spell checker will run modally. (Modal operation blocks the parent form)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool ModalMode { get; set; }
bool ModalMode { get; set; }
Property ModalMode As Boolean
    Get
    Set
Property ModalMode As Boolean
    Get
    Set
property bool ModalMode {
    bool get ();
    void set (bool value);
}
property bool ModalMode {
    bool get ();
    void set (bool value);
}
abstract ModalMode : bool with get, set

abstract ModalMode : bool with get, set
Property Value
Boolean


ModalOwner Property

ModalOwner Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► ModalOwner
Keyoti RapidSpell WPF
The owner window when used modally.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
Object ModalOwner { get; set; }
Object ModalOwner { get; set; }
Property ModalOwner As Object
    Get
    Set
Property ModalOwner As Object
    Get
    Set
property Object^ ModalOwner {
    Object^ get ();
    void set (Object^ value);
}
property Object^ ModalOwner {
    Object^ get ();
    void set (Object^ value);
}
abstract ModalOwner : Object with get, set

abstract ModalOwner : Object with get, set
Property Value
Object


NoSuggestionsText Property

NoSuggestionsText Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► NoSuggestionsText
Keyoti RapidSpell WPF
No suggestions found text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string NoSuggestionsText { get; set; }
string NoSuggestionsText { get; set; }
Property NoSuggestionsText As String
    Get
    Set
Property NoSuggestionsText As String
    Get
    Set
property String^ NoSuggestionsText {
    String^ get ();
    void set (String^ value);
}
property String^ NoSuggestionsText {
    String^ get ();
    void set (String^ value);
}
abstract NoSuggestionsText : string with get, set

abstract NoSuggestionsText : string with get, set
Property Value
String


NotInDictionaryLabelText Property

NotInDictionaryLabelText Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► NotInDictionaryLabelText
Keyoti RapidSpell WPF
Not in dictionary label text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string NotInDictionaryLabelText { get; set; }
string NotInDictionaryLabelText { get; set; }
Property NotInDictionaryLabelText As String
    Get
    Set
Property NotInDictionaryLabelText As String
    Get
    Set
property String^ NotInDictionaryLabelText {
    String^ get ();
    void set (String^ value);
}
property String^ NotInDictionaryLabelText {
    String^ get ();
    void set (String^ value);
}
abstract NotInDictionaryLabelText : string with get, set

abstract NotInDictionaryLabelText : string with get, set
Property Value
String


NumberSuggestionList Property

NumberSuggestionList Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► NumberSuggestionList
Keyoti RapidSpell WPF
Whether to number the items in the suggestion list, for quick user selection.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool NumberSuggestionList { get; set; }
bool NumberSuggestionList { get; set; }
Property NumberSuggestionList As Boolean
    Get
    Set
Property NumberSuggestionList As Boolean
    Get
    Set
property bool NumberSuggestionList {
    bool get ();
    void set (bool value);
}
property bool NumberSuggestionList {
    bool get ();
    void set (bool value);
}
abstract NumberSuggestionList : bool with get, set

abstract NumberSuggestionList : bool with get, set
Property Value
Boolean


Options Property

Options Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► Options
Keyoti RapidSpell WPF
Object responsible for holding, loading and saving the user's spell check options.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
UserOptions Options { get; set; }
UserOptions Options { get; set; }
Property Options As UserOptions
    Get
    Set
Property Options As UserOptions
    Get
    Set
property UserOptions^ Options {
    UserOptions^ get ();
    void set (UserOptions^ value);
}
property UserOptions^ Options {
    UserOptions^ get ();
    void set (UserOptions^ value);
}
abstract Options : UserOptions with get, set

abstract Options : UserOptions with get, set
Property Value
UserOptions
Remarks
To customize how the user's options are saved/loaded, subclass UserOptions and set an instance in this property.


OptionsButtonText Property

OptionsButtonText Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► OptionsButtonText
Keyoti RapidSpell WPF
Options button text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string OptionsButtonText { get; set; }
string OptionsButtonText { get; set; }
Property OptionsButtonText As String
    Get
    Set
Property OptionsButtonText As String
    Get
    Set
property String^ OptionsButtonText {
    String^ get ();
    void set (String^ value);
}
property String^ OptionsButtonText {
    String^ get ();
    void set (String^ value);
}
abstract OptionsButtonText : string with get, set

abstract OptionsButtonText : string with get, set
Property Value
String


OptionsPresenter Property

OptionsPresenter Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► OptionsPresenter
Keyoti RapidSpell WPF
Presenter for the user options form (IDialogViewOptions).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
OptionsPresenter OptionsPresenter { get; set; }
OptionsPresenter OptionsPresenter { get; set; }
Property OptionsPresenter As OptionsPresenter
    Get
    Set
Property OptionsPresenter As OptionsPresenter
    Get
    Set
property OptionsPresenter^ OptionsPresenter {
    OptionsPresenter^ get ();
    void set (OptionsPresenter^ value);
}
property OptionsPresenter^ OptionsPresenter {
    OptionsPresenter^ get ();
    void set (OptionsPresenter^ value);
}
abstract OptionsPresenter : OptionsPresenter with get, set

abstract OptionsPresenter : OptionsPresenter with get, set
Property Value
OptionsPresenter
Remarks
Set properties in this instance to affect the options shown to the user, or handle CreateDialogViewOptions to create your own IDialogViewOptions form instance.


Ready Event

Ready Event
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► Ready
Keyoti RapidSpell WPF
Fired when ready to proceed with first query.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event EventHandler Ready
event EventHandler Ready
Event Ready As EventHandler
Event Ready As EventHandler
 event EventHandler^ Ready {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
 event EventHandler^ Ready {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Ready : IEvent<EventHandler,
    EventArgs>

abstract Ready : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


RecheckDocumentRequest Event

RecheckDocumentRequest Event
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► RecheckDocumentRequest
Keyoti RapidSpell WPF
Fired when the text should be rechecked
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event EventHandler RecheckDocumentRequest
event EventHandler RecheckDocumentRequest
Event RecheckDocumentRequest As EventHandler
Event RecheckDocumentRequest As EventHandler
 event EventHandler^ RecheckDocumentRequest {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
 event EventHandler^ RecheckDocumentRequest {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract RecheckDocumentRequest : IEvent<EventHandler,
    EventArgs>

abstract RecheckDocumentRequest : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


Remove Method

Remove Method
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► Remove()()()()
Keyoti RapidSpell WPF
Safely frees up resources.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void Remove()
void Remove()
Sub Remove
Sub Remove
void Remove()
void Remove()
abstract Remove : unit -> unit

abstract Remove : unit -> unit


RemoveDuplicateWordText Property

RemoveDuplicateWordText Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► RemoveDuplicateWordText
Keyoti RapidSpell WPF
Remove duplicate word text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string RemoveDuplicateWordText { get; set; }
string RemoveDuplicateWordText { get; set; }
Property RemoveDuplicateWordText As String
    Get
    Set
Property RemoveDuplicateWordText As String
    Get
    Set
property String^ RemoveDuplicateWordText {
    String^ get ();
    void set (String^ value);
}
property String^ RemoveDuplicateWordText {
    String^ get ();
    void set (String^ value);
}
abstract RemoveDuplicateWordText : string with get, set

abstract RemoveDuplicateWordText : string with get, set
Property Value
String


ResumeButtonText Property

ResumeButtonText Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► ResumeButtonText
Keyoti RapidSpell WPF
Resume button text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string ResumeButtonText { get; set; }
string ResumeButtonText { get; set; }
Property ResumeButtonText As String
    Get
    Set
Property ResumeButtonText As String
    Get
    Set
property String^ ResumeButtonText {
    String^ get ();
    void set (String^ value);
}
property String^ ResumeButtonText {
    String^ get ();
    void set (String^ value);
}
abstract ResumeButtonText : string with get, set

abstract ResumeButtonText : string with get, set
Property Value
String


SeparateHyphenWords Property

SeparateHyphenWords Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► SeparateHyphenWords
Keyoti RapidSpell WPF
Sets whether to treat hyphenated (-) words as separate words, default is false.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool SeparateHyphenWords { get; set; }
bool SeparateHyphenWords { get; set; }
Property SeparateHyphenWords As Boolean
    Get
    Set
Property SeparateHyphenWords As Boolean
    Get
    Set
property bool SeparateHyphenWords {
    bool get ();
    void set (bool value);
}
property bool SeparateHyphenWords {
    bool get ();
    void set (bool value);
}
abstract SeparateHyphenWords : bool with get, set

abstract SeparateHyphenWords : bool with get, set
Property Value
Boolean
Remarks
For eg. if this is true text like "cheap-deals" will be treated as two words "cheap" and "deals", otherwise this will be treated as one word "cheap-deals".


SetIgnoreOnceBadWords Method (ignoreOnceBadWords)

SetIgnoreOnceBadWords Method (ignoreOnceBadWords)
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► SetIgnoreOnceBadWords(ArrayList)
Keyoti RapidSpell WPF
Provide a list of BadWord objects that have been ignored
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void SetIgnoreOnceBadWords(
    ArrayList ignoreOnceBadWords
)
void SetIgnoreOnceBadWords(
    ArrayList ignoreOnceBadWords
)
Sub SetIgnoreOnceBadWords (
    ignoreOnceBadWords As ArrayList
)
Sub SetIgnoreOnceBadWords (
    ignoreOnceBadWords As ArrayList
)
void SetIgnoreOnceBadWords(
    ArrayList^ ignoreOnceBadWords
)
void SetIgnoreOnceBadWords(
    ArrayList^ ignoreOnceBadWords
)
abstract SetIgnoreOnceBadWords :
        ignoreOnceBadWords : ArrayList -> unit

abstract SetIgnoreOnceBadWords :
        ignoreOnceBadWords : ArrayList -> unit
Parameters
ignoreOnceBadWords (ArrayList)


SetTextComponentToCheck Method

SetTextComponentToCheck Method
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► SetTextComponentToCheck()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | SetTextComponentToCheck(TextBox) | Set the TextBox that this GUI will spell check.
 | SetTextComponentToCheck(RichTextBox) | Set the RichTextBox that this GUI will spell check.


SetTextComponentToCheck Method (textComponent)

SetTextComponentToCheck Method (textComponent)
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► SetTextComponentToCheck(RichTextBox)
Keyoti RapidSpell WPF
Set the RichTextBox that this GUI will spell check.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void SetTextComponentToCheck(
    RichTextBox textComponent
)
void SetTextComponentToCheck(
    RichTextBox textComponent
)
Sub SetTextComponentToCheck (
    textComponent As RichTextBox
)
Sub SetTextComponentToCheck (
    textComponent As RichTextBox
)
void SetTextComponentToCheck(
    RichTextBox^ textComponent
)
void SetTextComponentToCheck(
    RichTextBox^ textComponent
)
abstract SetTextComponentToCheck :
        textComponent : RichTextBox -> unit

abstract SetTextComponentToCheck :
        textComponent : RichTextBox -> unit
Parameters
textComponent (RichTextBox)
the TextBoxBase that this will spell check.
Exceptions
Exception | Condition
ArgumentNullException | if textComponent parameter is null.


SetTextComponentToCheck Method (textComponent)

SetTextComponentToCheck Method (textComponent)
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► SetTextComponentToCheck(TextBox)
Keyoti RapidSpell WPF
Set the TextBox that this GUI will spell check.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void SetTextComponentToCheck(
    TextBox textComponent
)
void SetTextComponentToCheck(
    TextBox textComponent
)
Sub SetTextComponentToCheck (
    textComponent As TextBox
)
Sub SetTextComponentToCheck (
    textComponent As TextBox
)
void SetTextComponentToCheck(
    TextBox^ textComponent
)
void SetTextComponentToCheck(
    TextBox^ textComponent
)
abstract SetTextComponentToCheck :
        textComponent : TextBox -> unit

abstract SetTextComponentToCheck :
        textComponent : TextBox -> unit
Parameters
textComponent (TextBox)
the TextBoxBase that this will spell check.
Exceptions
Exception | Condition
ArgumentNullException | if textComponent parameter is null.


ShowContextSentence Property

ShowContextSentence Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► ShowContextSentence
Keyoti RapidSpell WPF
Whether to show the query in context of it's sentence/line.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool ShowContextSentence { get; set; }
bool ShowContextSentence { get; set; }
Property ShowContextSentence As Boolean
    Get
    Set
Property ShowContextSentence As Boolean
    Get
    Set
property bool ShowContextSentence {
    bool get ();
    void set (bool value);
}
property bool ShowContextSentence {
    bool get ();
    void set (bool value);
}
abstract ShowContextSentence : bool with get, set

abstract ShowContextSentence : bool with get, set
Property Value
Boolean


ShowFinishedMessageBox Property

ShowFinishedMessageBox Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► ShowFinishedMessageBox
Keyoti RapidSpell WPF
Whether a message box should be opened when the spell check is complete.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool ShowFinishedMessageBox { get; set; }
bool ShowFinishedMessageBox { get; set; }
Property ShowFinishedMessageBox As Boolean
    Get
    Set
Property ShowFinishedMessageBox As Boolean
    Get
    Set
property bool ShowFinishedMessageBox {
    bool get ();
    void set (bool value);
}
property bool ShowFinishedMessageBox {
    bool get ();
    void set (bool value);
}
abstract ShowFinishedMessageBox : bool with get, set

abstract ShowFinishedMessageBox : bool with get, set
Property Value
Boolean


SpellCheckFinished Event

SpellCheckFinished Event
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► SpellCheckFinished
Keyoti RapidSpell WPF
Fired when checking finishes
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event RapidSpellGUIPresenter..::..SpellCheckEventHandler SpellCheckFinished
event RapidSpellGUIPresenter..::..SpellCheckEventHandler SpellCheckFinished
Event SpellCheckFinished As RapidSpellGUIPresenter..::..SpellCheckEventHandler
Event SpellCheckFinished As RapidSpellGUIPresenter..::..SpellCheckEventHandler
 event RapidSpellGUIPresenter..::..SpellCheckEventHandler^ SpellCheckFinished {
    void add (RapidSpellGUIPresenter..::..SpellCheckEventHandler^ value);
    void remove (RapidSpellGUIPresenter..::..SpellCheckEventHandler^ value);
}
 event RapidSpellGUIPresenter..::..SpellCheckEventHandler^ SpellCheckFinished {
    void add (RapidSpellGUIPresenter..::..SpellCheckEventHandler^ value);
    void remove (RapidSpellGUIPresenter..::..SpellCheckEventHandler^ value);
}
abstract SpellCheckFinished : IEvent<RapidSpellGUIPresenter..::..SpellCheckEventHandler,
    SpellCheckEventArgs>

abstract SpellCheckFinished : IEvent<RapidSpellGUIPresenter..::..SpellCheckEventHandler,
    SpellCheckEventArgs>
Value
RapidSpellGUIPresenter..::..SpellCheckEventHandler


SpellCheckStarted Event

SpellCheckStarted Event
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► SpellCheckStarted
Keyoti RapidSpell WPF
Fired when checking starts
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event RapidSpellGUIPresenter..::..SpellCheckEventHandler SpellCheckStarted
event RapidSpellGUIPresenter..::..SpellCheckEventHandler SpellCheckStarted
Event SpellCheckStarted As RapidSpellGUIPresenter..::..SpellCheckEventHandler
Event SpellCheckStarted As RapidSpellGUIPresenter..::..SpellCheckEventHandler
 event RapidSpellGUIPresenter..::..SpellCheckEventHandler^ SpellCheckStarted {
    void add (RapidSpellGUIPresenter..::..SpellCheckEventHandler^ value);
    void remove (RapidSpellGUIPresenter..::..SpellCheckEventHandler^ value);
}
 event RapidSpellGUIPresenter..::..SpellCheckEventHandler^ SpellCheckStarted {
    void add (RapidSpellGUIPresenter..::..SpellCheckEventHandler^ value);
    void remove (RapidSpellGUIPresenter..::..SpellCheckEventHandler^ value);
}
abstract SpellCheckStarted : IEvent<RapidSpellGUIPresenter..::..SpellCheckEventHandler,
    SpellCheckEventArgs>

abstract SpellCheckStarted : IEvent<RapidSpellGUIPresenter..::..SpellCheckEventHandler,
    SpellCheckEventArgs>
Value
RapidSpellGUIPresenter..::..SpellCheckEventHandler


SuggestionsLabelText Property

SuggestionsLabelText Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► SuggestionsLabelText
Keyoti RapidSpell WPF
Suggestions label text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string SuggestionsLabelText { get; set; }
string SuggestionsLabelText { get; set; }
Property SuggestionsLabelText As String
    Get
    Set
Property SuggestionsLabelText As String
    Get
    Set
property String^ SuggestionsLabelText {
    String^ get ();
    void set (String^ value);
}
property String^ SuggestionsLabelText {
    String^ get ();
    void set (String^ value);
}
abstract SuggestionsLabelText : string with get, set

abstract SuggestionsLabelText : string with get, set
Property Value
String


SuggestionsMethod Property

SuggestionsMethod Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► SuggestionsMethod
Keyoti RapidSpell WPF
Sets the suggestions method to use. Either PHONETIC_SUGGESTIONS or HASHING_SUGGESTIONS
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
SuggestionsMethodType SuggestionsMethod { get; set; }
SuggestionsMethodType SuggestionsMethod { get; set; }
Property SuggestionsMethod As SuggestionsMethodType
    Get
    Set
Property SuggestionsMethod As SuggestionsMethodType
    Get
    Set
property SuggestionsMethodType SuggestionsMethod {
    SuggestionsMethodType get ();
    void set (SuggestionsMethodType value);
}
property SuggestionsMethodType SuggestionsMethod {
    SuggestionsMethodType get ();
    void set (SuggestionsMethodType value);
}
abstract SuggestionsMethod : SuggestionsMethodType with get, set

abstract SuggestionsMethod : SuggestionsMethodType with get, set
Property Value
SuggestionsMethodType


SuggestSplitWords Property

SuggestSplitWords Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► SuggestSplitWords
Keyoti RapidSpell WPF
Whether to look for connected words in suggestions.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool SuggestSplitWords { get; set; }
bool SuggestSplitWords { get; set; }
Property SuggestSplitWords As Boolean
    Get
    Set
Property SuggestSplitWords As Boolean
    Get
    Set
property bool SuggestSplitWords {
    bool get ();
    void set (bool value);
}
property bool SuggestSplitWords {
    bool get ();
    void set (bool value);
}
abstract SuggestSplitWords : bool with get, set

abstract SuggestSplitWords : bool with get, set
Property Value
Boolean
Remarks
if this=true then suggestions may include joined words.

Eg; suggestions for "myhouse" will include "my house"


UndoButtonText Property

UndoButtonText Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► UndoButtonText
Keyoti RapidSpell WPF
Undo button text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string UndoButtonText { get; set; }
string UndoButtonText { get; set; }
Property UndoButtonText As String
    Get
    Set
Property UndoButtonText As String
    Get
    Set
property String^ UndoButtonText {
    String^ get ();
    void set (String^ value);
}
property String^ UndoButtonText {
    String^ get ();
    void set (String^ value);
}
abstract UndoButtonText : string with get, set

abstract UndoButtonText : string with get, set
Property Value
String


Undone Event

Undone Event
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► Undone
Keyoti RapidSpell WPF
Fired when an Undo occurs
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event UndoEventHandler Undone
event UndoEventHandler Undone
Event Undone As UndoEventHandler
Event Undone As UndoEventHandler
 event UndoEventHandler^ Undone {
    void add (UndoEventHandler^ value);
    void remove (UndoEventHandler^ value);
}
 event UndoEventHandler^ Undone {
    void add (UndoEventHandler^ value);
    void remove (UndoEventHandler^ value);
}
abstract Undone : IEvent<UndoEventHandler,
    UndoEventArgs>

abstract Undone : IEvent<UndoEventHandler,
    UndoEventArgs>
Value
UndoEventHandler


UserDictionary Property

UserDictionary Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► UserDictionary
Keyoti RapidSpell WPF
Set the user dictionary object.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
UserDictionary UserDictionary { get; set; }
UserDictionary UserDictionary { get; set; }
Property UserDictionary As UserDictionary
    Get
    Set
Property UserDictionary As UserDictionary
    Get
    Set
property UserDictionary^ UserDictionary {
    UserDictionary^ get ();
    void set (UserDictionary^ value);
}
property UserDictionary^ UserDictionary {
    UserDictionary^ get ();
    void set (UserDictionary^ value);
}
abstract UserDictionary : UserDictionary with get, set

abstract UserDictionary : UserDictionary with get, set
Property Value
UserDictionary
Remarks
Use of a user dictionary is optional.


UserDictionaryFile Property

UserDictionaryFile Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► UserDictionaryFile
Keyoti RapidSpell WPF
Set the user dictionary file, if this file doesn't exist it will be created.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string UserDictionaryFile { set; }
string UserDictionaryFile { set; }
WriteOnly Property UserDictionaryFile As String
    Set
WriteOnly Property UserDictionaryFile As String
    Set
property String^ UserDictionaryFile {
    void set (String^ value);
}
property String^ UserDictionaryFile {
    void set (String^ value);
}
abstract UserDictionaryFile : string with set

abstract UserDictionaryFile : string with set
Property Value
String
Remarks
Use of a user dictionary is optional.


UserQuery Event

UserQuery Event
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► UserQuery
Keyoti RapidSpell WPF
Indicates that the user is being queried on a spelling error.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event UserQueryEventHandler UserQuery
event UserQueryEventHandler UserQuery
Event UserQuery As UserQueryEventHandler
Event UserQuery As UserQueryEventHandler
 event UserQueryEventHandler^ UserQuery {
    void add (UserQueryEventHandler^ value);
    void remove (UserQueryEventHandler^ value);
}
 event UserQueryEventHandler^ UserQuery {
    void add (UserQueryEventHandler^ value);
    void remove (UserQueryEventHandler^ value);
}
abstract UserQuery : IEvent<UserQueryEventHandler,
    UserQueryEventArgs>

abstract UserQuery : IEvent<UserQueryEventHandler,
    UserQueryEventArgs>
Value
UserQueryEventHandler


WarnDuplicates Property

WarnDuplicates Property
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► WarnDuplicates
Keyoti RapidSpell WPF
Whether to show duplicate words as errors (eg. "this is is an error").
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool WarnDuplicates { get; set; }
bool WarnDuplicates { get; set; }
Property WarnDuplicates As Boolean
    Get
    Set
Property WarnDuplicates As Boolean
    Get
    Set
property bool WarnDuplicates {
    bool get ();
    void set (bool value);
}
property bool WarnDuplicates {
    bool get ();
    void set (bool value);
}
abstract WarnDuplicates : bool with get, set

abstract WarnDuplicates : bool with get, set
Property Value
Boolean


WordAdded Event

WordAdded Event
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► WordAdded
Keyoti RapidSpell WPF
Fired when word added to user dictionary
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event WordAddedEventHandler WordAdded
event WordAddedEventHandler WordAdded
Event WordAdded As WordAddedEventHandler
Event WordAdded As WordAddedEventHandler
 event WordAddedEventHandler^ WordAdded {
    void add (WordAddedEventHandler^ value);
    void remove (WordAddedEventHandler^ value);
}
 event WordAddedEventHandler^ WordAdded {
    void add (WordAddedEventHandler^ value);
    void remove (WordAddedEventHandler^ value);
}
abstract WordAdded : IEvent<WordAddedEventHandler,
    WordAddedEventArgs>

abstract WordAdded : IEvent<WordAddedEventHandler,
    WordAddedEventArgs>
Value
WordAddedEventHandler


WordChanged Event

WordChanged Event
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► WordChanged
Keyoti RapidSpell WPF
Fired when word changed
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event WordChangedEventHandler WordChanged
event WordChangedEventHandler WordChanged
Event WordChanged As WordChangedEventHandler
Event WordChanged As WordChangedEventHandler
 event WordChangedEventHandler^ WordChanged {
    void add (WordChangedEventHandler^ value);
    void remove (WordChangedEventHandler^ value);
}
 event WordChangedEventHandler^ WordChanged {
    void add (WordChangedEventHandler^ value);
    void remove (WordChangedEventHandler^ value);
}
abstract WordChanged : IEvent<WordChangedEventHandler,
    WordChangedEventArgs>

abstract WordChanged : IEvent<WordChangedEventHandler,
    WordChangedEventArgs>
Value
WordChangedEventHandler


WordChanging Event

WordChanging Event
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► WordChanging
Keyoti RapidSpell WPF
Fired before a word is changed
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event WordChangedEventHandler WordChanging
event WordChangedEventHandler WordChanging
Event WordChanging As WordChangedEventHandler
Event WordChanging As WordChangedEventHandler
 event WordChangedEventHandler^ WordChanging {
    void add (WordChangedEventHandler^ value);
    void remove (WordChangedEventHandler^ value);
}
 event WordChangedEventHandler^ WordChanging {
    void add (WordChangedEventHandler^ value);
    void remove (WordChangedEventHandler^ value);
}
abstract WordChanging : IEvent<WordChangedEventHandler,
    WordChangedEventArgs>

abstract WordChanging : IEvent<WordChangedEventHandler,
    WordChangedEventArgs>
Value
WordChangedEventHandler


WordIgnored Event

WordIgnored Event
API ► Keyoti.RapidSpell.Wpf ► IUserInterfaceFormPresenter ► WordIgnored
Keyoti RapidSpell WPF
Fired when word ignored
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event WordIgnoredEventHandler WordIgnored
event WordIgnoredEventHandler WordIgnored
Event WordIgnored As WordIgnoredEventHandler
Event WordIgnored As WordIgnoredEventHandler
 event WordIgnoredEventHandler^ WordIgnored {
    void add (WordIgnoredEventHandler^ value);
    void remove (WordIgnoredEventHandler^ value);
}
 event WordIgnoredEventHandler^ WordIgnored {
    void add (WordIgnoredEventHandler^ value);
    void remove (WordIgnoredEventHandler^ value);
}
abstract WordIgnored : IEvent<WordIgnoredEventHandler,
    WordIgnoredEventArgs>

abstract WordIgnored : IEvent<WordIgnoredEventHandler,
    WordIgnoredEventArgs>
Value
WordIgnoredEventHandler


KLicenseProvider Class

KLicenseProvider Class
API ► Keyoti.RapidSpell.Wpf ► KLicenseProvider
Keyoti RapidSpell WPF
Summary description for KLicenseProvider.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class KLicenseProvider : LicenseProvider
public class KLicenseProvider : LicenseProvider
Public Class KLicenseProvider
    Inherits LicenseProvider
Public Class KLicenseProvider
    Inherits LicenseProvider
public ref class KLicenseProvider : public LicenseProvider
public ref class KLicenseProvider : public LicenseProvider
type KLicenseProvider =
    class
        inherit LicenseProvider
    end
type KLicenseProvider =
    class
        inherit LicenseProvider
    end
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | KLicenseProvider()()()() | New
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLicense(LicenseContext, Type, Object, Boolean) | Retrieves the license. (Overrides LicenseProvider.GetLicense(LicenseContext, Type, Object, Boolean).)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetStoredKey(String) | Store key
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | LicenseProvider
 |  | KLicenseProvider


KLicenseProvider Constructor

KLicenseProvider Constructor
API ► Keyoti.RapidSpell.Wpf ► KLicenseProvider ► KLicenseProvider()()()()
Keyoti RapidSpell WPF
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public KLicenseProvider()
public KLicenseProvider()
Public Sub New
Public Sub New
public:
KLicenseProvider()
public:
KLicenseProvider()
new : unit -> KLicenseProvider
new : unit -> KLicenseProvider


GetLicense Method (context, type, instance, allowExceptions)

GetLicense Method (context, type, instance, allowExceptions)
API ► Keyoti.RapidSpell.Wpf ► KLicenseProvider ► GetLicense(LicenseContext, Type, Object, Boolean)
Keyoti RapidSpell WPF
Retrieves the license.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override License GetLicense(
    LicenseContext context,
    Type type,
    Object instance,
    bool allowExceptions
)
public override License GetLicense(
    LicenseContext context,
    Type type,
    Object instance,
    bool allowExceptions
)
Public Overrides Function GetLicense (
    context As LicenseContext,
    type As Type,
    instance As Object,
    allowExceptions As Boolean
) As License
Public Overrides Function GetLicense (
    context As LicenseContext,
    type As Type,
    instance As Object,
    allowExceptions As Boolean
) As License
public:
virtual License^ GetLicense(
    LicenseContext^ context,
    Type^ type,
    Object^ instance,
    bool allowExceptions
) override
public:
virtual License^ GetLicense(
    LicenseContext^ context,
    Type^ type,
    Object^ instance,
    bool allowExceptions
) override
abstract GetLicense :
        context : LicenseContext *
        type : Type *
        instance : Object *
        allowExceptions : bool -> License
override GetLicense :
        context : LicenseContext *
        type : Type *
        instance : Object *
        allowExceptions : bool -> License
abstract GetLicense :
        context : LicenseContext *
        type : Type *
        instance : Object *
        allowExceptions : bool -> License
override GetLicense :
        context : LicenseContext *
        type : Type *
        instance : Object *
        allowExceptions : bool -> License
Parameters
context (LicenseContext)
type (Type)
instance (Object)
allowExceptions (Boolean)
Return Value
License


SetStoredKey Method (key)

SetStoredKey Method (key)
API ► Keyoti.RapidSpell.Wpf ► KLicenseProvider ► SetStoredKey(String)
Keyoti RapidSpell WPF
Store key
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static string SetStoredKey(
    string key
)
public static string SetStoredKey(
    string key
)
Public Shared Function SetStoredKey (
    key As String
) As String
Public Shared Function SetStoredKey (
    key As String
) As String
public:
static String^ SetStoredKey(
    String^ key
)
public:
static String^ SetStoredKey(
    String^ key
)
static member SetStoredKey :
        key : string -> string

static member SetStoredKey :
        key : string -> string
Parameters
key (String)
Return Value
String


LanguageType Enumeration

LanguageType Enumeration
API ► Keyoti.RapidSpell.Wpf ► LanguageType
Keyoti RapidSpell WPF
Enumeration of language types.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public enum LanguageType
public enum LanguageType
Public Enumeration LanguageType
Public Enumeration LanguageType
public enum class LanguageType
public enum class LanguageType
type LanguageType
type LanguageType
Members
Member | Description
ENGLISH | English.
DUTCH | Dutch.
FRENCH | French.
GERMAN | German.
ITALIAN | Italian.
PORTUGUESE | Portuguese.
SPANISH | Spanish.
POLISH | Polish.
RUSSIAN | Russian.


MultiFileUserDictionary Class

MultiFileUserDictionary Class
API ► Keyoti.RapidSpell.Wpf ► MultiFileUserDictionary
Keyoti RapidSpell WPF
Represents multiple file based user dictionaries.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class MultiFileUserDictionary : UserDictionary
public class MultiFileUserDictionary : UserDictionary
Public Class MultiFileUserDictionary
    Inherits UserDictionary
Public Class MultiFileUserDictionary
    Inherits UserDictionary
public ref class MultiFileUserDictionary : public UserDictionary
public ref class MultiFileUserDictionary : public UserDictionary
type MultiFileUserDictionary =
    class
        inherit UserDictionary
    end
type MultiFileUserDictionary =
    class
        inherit UserDictionary
    end
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MultiFileUserDictionary(List<(Of <<'(UserDictionary>)>>)) | New
 | AddFile(String) | Adds a new user dictionary to the collection
 | AddWord(String) | Adds a word to the default dictionary (Overrides UserDictionary.AddWord(String).)
 | dictFile | The file containing the dictionary (Inherited from UserDictionary.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetFileNames()()()() | The file names
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GetUserDictionary(String) | Gets the UserDictionary associated with the specified path.
 | IsValid()()()() | Whether a problem has occurred. (Overrides UserDictionary.IsValid()()()().)
 | ListChanged | Notifies handlers that the word list has changed. (Inherited from UserDictionary.)
 | Location | Where to store the user dictionary (Inherited from UserDictionary.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnListChanged(UserDictionary..::..ListChangedEventArgs) | Raises ListChanged (Inherited from UserDictionary.)
 | OnListChanged(Object, UserDictionary..::..ListChangedEventArgs) | Raises ListChanged (Inherited from UserDictionary.)
 | ReadAll(ArrayList) | Reads all words from all files (Overrides UserDictionary.ReadAll(ArrayList).)
 | ReloadDictionary()()()() | Reload (Overrides UserDictionary.ReloadDictionary()()()().)
 | RemoveFile(String) | Removes a user dictionary from the collection
 | RemoveWord(String) | Removes a word from the default dictionary (Overrides UserDictionary.RemoveWord(String).)
 | SaveList(ArrayList) | Save (Overrides UserDictionary.SaveList(ArrayList).)
 | SetDefaultUserDictionaryFile(String) | Sets the default user dictionary
 | SetFiles(List<(Of <<'(String>)>>)) | Sets user dictionaries in the collection
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | UserDictionary
 |  | MultiFileUserDictionary


MultiFileUserDictionary Constructor (dictionaries)

MultiFileUserDictionary Constructor (dictionaries)
API ► Keyoti.RapidSpell.Wpf ► MultiFileUserDictionary ► MultiFileUserDictionary(List<(Of <<'(UserDictionary>)>>))
Keyoti RapidSpell WPF
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public MultiFileUserDictionary(
    List<UserDictionary> dictionaries
)
public MultiFileUserDictionary(
    List<UserDictionary> dictionaries
)
Public Sub New (
    dictionaries As List(Of UserDictionary)
)
Public Sub New (
    dictionaries As List(Of UserDictionary)
)
public:
MultiFileUserDictionary(
    List<UserDictionary^>^ dictionaries
)
public:
MultiFileUserDictionary(
    List<UserDictionary^>^ dictionaries
)
new :
        dictionaries : List<UserDictionary> -> MultiFileUserDictionary
new :
        dictionaries : List<UserDictionary> -> MultiFileUserDictionary
Parameters
dictionaries (List<(Of <(<' UserDictionary >)>)>)


AddFile Method (file)

AddFile Method (file)
API ► Keyoti.RapidSpell.Wpf ► MultiFileUserDictionary ► AddFile(String)
Keyoti RapidSpell WPF
Adds a new user dictionary to the collection
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual UserDictionary AddFile(
    string file
)
public virtual UserDictionary AddFile(
    string file
)
Public Overridable Function AddFile (
    file As String
) As UserDictionary
Public Overridable Function AddFile (
    file As String
) As UserDictionary
public:
virtual UserDictionary^ AddFile(
    String^ file
)
public:
virtual UserDictionary^ AddFile(
    String^ file
)
abstract AddFile :
        file : string -> UserDictionary
override AddFile :
        file : string -> UserDictionary
abstract AddFile :
        file : string -> UserDictionary
override AddFile :
        file : string -> UserDictionary
Parameters
file (String)
File path
Return Value
UserDictionary


AddWord Method (word)

AddWord Method (word)
API ► Keyoti.RapidSpell.Wpf ► MultiFileUserDictionary ► AddWord(String)
Keyoti RapidSpell WPF
Adds a word to the default dictionary
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override bool AddWord(
    string word
)
public override bool AddWord(
    string word
)
Public Overrides Function AddWord (
    word As String
) As Boolean
Public Overrides Function AddWord (
    word As String
) As Boolean
public:
virtual bool AddWord(
    String^ word
) override
public:
virtual bool AddWord(
    String^ word
) override
abstract AddWord :
        word : string -> bool
override AddWord :
        word : string -> bool
abstract AddWord :
        word : string -> bool
override AddWord :
        word : string -> bool
Parameters
word (String)
Return Value
Boolean


GetFileNames Method

GetFileNames Method
API ► Keyoti.RapidSpell.Wpf ► MultiFileUserDictionary ► GetFileNames()()()()
Keyoti RapidSpell WPF
The file names
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public List<string> GetFileNames()
public List<string> GetFileNames()
Public Function GetFileNames As List(Of String)
Public Function GetFileNames As List(Of String)
public:
List<String^>^ GetFileNames()
public:
List<String^>^ GetFileNames()
member GetFileNames : unit -> List<string>

member GetFileNames : unit -> List<string>
Return Value
List<(Of <(<'String>)>)>


GetUserDictionary Method (file)

GetUserDictionary Method (file)
API ► Keyoti.RapidSpell.Wpf ► MultiFileUserDictionary ► GetUserDictionary(String)
Keyoti RapidSpell WPF
Gets the UserDictionary associated with the specified path.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UserDictionary GetUserDictionary(
    string file
)
public UserDictionary GetUserDictionary(
    string file
)
Public Function GetUserDictionary (
    file As String
) As UserDictionary
Public Function GetUserDictionary (
    file As String
) As UserDictionary
public:
UserDictionary^ GetUserDictionary(
    String^ file
)
public:
UserDictionary^ GetUserDictionary(
    String^ file
)
member GetUserDictionary :
        file : string -> UserDictionary

member GetUserDictionary :
        file : string -> UserDictionary
Parameters
file (String)
Return Value
UserDictionary


IsValid Method

IsValid Method
API ► Keyoti.RapidSpell.Wpf ► MultiFileUserDictionary ► IsValid()()()()
Keyoti RapidSpell WPF
Whether a problem has occurred.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override bool IsValid()
public override bool IsValid()
Public Overrides Function IsValid As Boolean
Public Overrides Function IsValid As Boolean
public:
virtual bool IsValid() override
public:
virtual bool IsValid() override
abstract IsValid : unit -> bool
override IsValid : unit -> bool
abstract IsValid : unit -> bool
override IsValid : unit -> bool
Return Value
Boolean


ReadAll Method (list)

ReadAll Method (list)
API ► Keyoti.RapidSpell.Wpf ► MultiFileUserDictionary ► ReadAll(ArrayList)
Keyoti RapidSpell WPF
Reads all words from all files
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override int ReadAll(
    ArrayList list
)
public override int ReadAll(
    ArrayList list
)
Public Overrides Function ReadAll (
    list As ArrayList
) As Integer
Public Overrides Function ReadAll (
    list As ArrayList
) As Integer
public:
virtual int ReadAll(
    ArrayList^ list
) override
public:
virtual int ReadAll(
    ArrayList^ list
) override
abstract ReadAll :
        list : ArrayList -> int
override ReadAll :
        list : ArrayList -> int
abstract ReadAll :
        list : ArrayList -> int
override ReadAll :
        list : ArrayList -> int
Parameters
list (ArrayList)
Return Value
Int32


ReloadDictionary Method

ReloadDictionary Method
API ► Keyoti.RapidSpell.Wpf ► MultiFileUserDictionary ► ReloadDictionary()()()()
Keyoti RapidSpell WPF
Reload
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override bool ReloadDictionary()
public override bool ReloadDictionary()
Public Overrides Function ReloadDictionary As Boolean
Public Overrides Function ReloadDictionary As Boolean
public:
virtual bool ReloadDictionary() override
public:
virtual bool ReloadDictionary() override
abstract ReloadDictionary : unit -> bool
override ReloadDictionary : unit -> bool
abstract ReloadDictionary : unit -> bool
override ReloadDictionary : unit -> bool
Return Value
Boolean


RemoveFile Method (file)

RemoveFile Method (file)
API ► Keyoti.RapidSpell.Wpf ► MultiFileUserDictionary ► RemoveFile(String)
Keyoti RapidSpell WPF
Removes a user dictionary from the collection
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void RemoveFile(
    string file
)
public virtual void RemoveFile(
    string file
)
Public Overridable Sub RemoveFile (
    file As String
)
Public Overridable Sub RemoveFile (
    file As String
)
public:
virtual void RemoveFile(
    String^ file
)
public:
virtual void RemoveFile(
    String^ file
)
abstract RemoveFile :
        file : string -> unit
override RemoveFile :
        file : string -> unit
abstract RemoveFile :
        file : string -> unit
override RemoveFile :
        file : string -> unit
Parameters
file (String)
Path


RemoveWord Method (word)

RemoveWord Method (word)
API ► Keyoti.RapidSpell.Wpf ► MultiFileUserDictionary ► RemoveWord(String)
Keyoti RapidSpell WPF
Removes a word from the default dictionary
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override bool RemoveWord(
    string word
)
public override bool RemoveWord(
    string word
)
Public Overrides Function RemoveWord (
    word As String
) As Boolean
Public Overrides Function RemoveWord (
    word As String
) As Boolean
public:
virtual bool RemoveWord(
    String^ word
) override
public:
virtual bool RemoveWord(
    String^ word
) override
abstract RemoveWord :
        word : string -> bool
override RemoveWord :
        word : string -> bool
abstract RemoveWord :
        word : string -> bool
override RemoveWord :
        word : string -> bool
Parameters
word (String)
Return Value
Boolean


SaveList Method (newList)

SaveList Method (newList)
API ► Keyoti.RapidSpell.Wpf ► MultiFileUserDictionary ► SaveList(ArrayList)
Keyoti RapidSpell WPF
Save
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override void SaveList(
    ArrayList newList
)
public override void SaveList(
    ArrayList newList
)
Public Overrides Sub SaveList (
    newList As ArrayList
)
Public Overrides Sub SaveList (
    newList As ArrayList
)
public:
virtual void SaveList(
    ArrayList^ newList
) override
public:
virtual void SaveList(
    ArrayList^ newList
) override
abstract SaveList :
        newList : ArrayList -> unit
override SaveList :
        newList : ArrayList -> unit
abstract SaveList :
        newList : ArrayList -> unit
override SaveList :
        newList : ArrayList -> unit
Parameters
newList (ArrayList)


SetDefaultUserDictionaryFile Method (defaultUserDictionaryFileName)

SetDefaultUserDictionaryFile Method (defaultUserDictionaryFileName)
API ► Keyoti.RapidSpell.Wpf ► MultiFileUserDictionary ► SetDefaultUserDictionaryFile(String)
Keyoti RapidSpell WPF
Sets the default user dictionary
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void SetDefaultUserDictionaryFile(
    string defaultUserDictionaryFileName
)
public void SetDefaultUserDictionaryFile(
    string defaultUserDictionaryFileName
)
Public Sub SetDefaultUserDictionaryFile (
    defaultUserDictionaryFileName As String
)
Public Sub SetDefaultUserDictionaryFile (
    defaultUserDictionaryFileName As String
)
public:
void SetDefaultUserDictionaryFile(
    String^ defaultUserDictionaryFileName
)
public:
void SetDefaultUserDictionaryFile(
    String^ defaultUserDictionaryFileName
)
member SetDefaultUserDictionaryFile :
        defaultUserDictionaryFileName : string -> unit

member SetDefaultUserDictionaryFile :
        defaultUserDictionaryFileName : string -> unit
Parameters
defaultUserDictionaryFileName (String)


SetFiles Method (supplementalUserDictionaryFiles)

SetFiles Method (supplementalUserDictionaryFiles)
API ► Keyoti.RapidSpell.Wpf ► MultiFileUserDictionary ► SetFiles(List<(Of <<'(String>)>>))
Keyoti RapidSpell WPF
Sets user dictionaries in the collection
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void SetFiles(
    List<string> supplementalUserDictionaryFiles
)
public virtual void SetFiles(
    List<string> supplementalUserDictionaryFiles
)
Public Overridable Sub SetFiles (
    supplementalUserDictionaryFiles As List(Of String)
)
Public Overridable Sub SetFiles (
    supplementalUserDictionaryFiles As List(Of String)
)
public:
virtual void SetFiles(
    List<String^>^ supplementalUserDictionaryFiles
)
public:
virtual void SetFiles(
    List<String^>^ supplementalUserDictionaryFiles
)
abstract SetFiles :
        supplementalUserDictionaryFiles : List<string> -> unit
override SetFiles :
        supplementalUserDictionaryFiles : List<string> -> unit
abstract SetFiles :
        supplementalUserDictionaryFiles : List<string> -> unit
override SetFiles :
        supplementalUserDictionaryFiles : List<string> -> unit
Parameters
supplementalUserDictionaryFiles (List<(Of <(<'String>)>)>)


NoCurrentBadWordException Class

NoCurrentBadWordException Class
API ► Keyoti.RapidSpell.Wpf ► NoCurrentBadWordException
Keyoti RapidSpell WPF
Thrown if NextBadWord has not been run first and found a mis-spelled word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
[SerializableAttribute]
public class NoCurrentBadWordException : ApplicationException
[SerializableAttribute]
public class NoCurrentBadWordException : ApplicationException
<SerializableAttribute>
Public Class NoCurrentBadWordException
    Inherits ApplicationException
<SerializableAttribute>
Public Class NoCurrentBadWordException
    Inherits ApplicationException
[SerializableAttribute]
public ref class NoCurrentBadWordException : public ApplicationException
[SerializableAttribute]
public ref class NoCurrentBadWordException : public ApplicationException
[<SerializableAttribute>]
type NoCurrentBadWordException =
    class
        inherit ApplicationException
    end
[<SerializableAttribute>]
type NoCurrentBadWordException =
    class
        inherit ApplicationException
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NoCurrentBadWordException()()()() | Create a new instance with no message.
 | NoCurrentBadWordException(String) | Create a new instance with mesg as a message.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | ApplicationException
 |  |  | NoCurrentBadWordException


NoCurrentBadWordException Constructor

NoCurrentBadWordException Constructor
API ► Keyoti.RapidSpell.Wpf ► NoCurrentBadWordException ► NoCurrentBadWordException()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | NoCurrentBadWordException()()()() | Create a new instance with no message.
 | NoCurrentBadWordException(String) | Create a new instance with mesg as a message.


NoCurrentBadWordException Constructor

NoCurrentBadWordException Constructor
API ► Keyoti.RapidSpell.Wpf ► NoCurrentBadWordException ► NoCurrentBadWordException()()()()
Keyoti RapidSpell WPF
Create a new instance with no message.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public NoCurrentBadWordException()
public NoCurrentBadWordException()
Public Sub New
Public Sub New
public:
NoCurrentBadWordException()
public:
NoCurrentBadWordException()
new : unit -> NoCurrentBadWordException
new : unit -> NoCurrentBadWordException


NoCurrentBadWordException Constructor (mesg)

NoCurrentBadWordException Constructor (mesg)
API ► Keyoti.RapidSpell.Wpf ► NoCurrentBadWordException ► NoCurrentBadWordException(String)
Keyoti RapidSpell WPF
Create a new instance with mesg as a message.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public NoCurrentBadWordException(
    string mesg
)
public NoCurrentBadWordException(
    string mesg
)
Public Sub New (
    mesg As String
)
Public Sub New (
    mesg As String
)
public:
NoCurrentBadWordException(
    String^ mesg
)
public:
NoCurrentBadWordException(
    String^ mesg
)
new :
        mesg : string -> NoCurrentBadWordException
new :
        mesg : string -> NoCurrentBadWordException
Parameters
mesg (String)


NoTextComponentException Class

NoTextComponentException Class
API ► Keyoti.RapidSpell.Wpf ► NoTextComponentException
Keyoti RapidSpell WPF
Thrown if a valid text component hasn't been set to be checked (by the GUI for example).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class NoTextComponentException : Exception
public class NoTextComponentException : Exception
Public Class NoTextComponentException
    Inherits Exception
Public Class NoTextComponentException
    Inherits Exception
public ref class NoTextComponentException : public Exception
public ref class NoTextComponentException : public Exception
type NoTextComponentException =
    class
        inherit Exception
    end
type NoTextComponentException =
    class
        inherit Exception
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NoTextComponentException()()()() | Create a new instance with no message.
 | NoTextComponentException(String) | Create a new instance with mesg as a message.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | NoTextComponentException


NoTextComponentException Constructor

NoTextComponentException Constructor
API ► Keyoti.RapidSpell.Wpf ► NoTextComponentException ► NoTextComponentException()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | NoTextComponentException()()()() | Create a new instance with no message.
 | NoTextComponentException(String) | Create a new instance with mesg as a message.


NoTextComponentException Constructor

NoTextComponentException Constructor
API ► Keyoti.RapidSpell.Wpf ► NoTextComponentException ► NoTextComponentException()()()()
Keyoti RapidSpell WPF
Create a new instance with no message.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public NoTextComponentException()
public NoTextComponentException()
Public Sub New
Public Sub New
public:
NoTextComponentException()
public:
NoTextComponentException()
new : unit -> NoTextComponentException
new : unit -> NoTextComponentException


NoTextComponentException Constructor (mesg)

NoTextComponentException Constructor (mesg)
API ► Keyoti.RapidSpell.Wpf ► NoTextComponentException ► NoTextComponentException(String)
Keyoti RapidSpell WPF
Create a new instance with mesg as a message.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public NoTextComponentException(
    string mesg
)
public NoTextComponentException(
    string mesg
)
Public Sub New (
    mesg As String
)
Public Sub New (
    mesg As String
)
public:
NoTextComponentException(
    String^ mesg
)
public:
NoTextComponentException(
    String^ mesg
)
new :
        mesg : string -> NoTextComponentException
new :
        mesg : string -> NoTextComponentException
Parameters
mesg (String)


OperationScope Enumeration

OperationScope Enumeration
API ► Keyoti.RapidSpell.Wpf ► OperationScope
Keyoti RapidSpell WPF
The scope of an operation.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public enum OperationScope
public enum OperationScope
Public Enumeration OperationScope
Public Enumeration OperationScope
public enum class OperationScope
public enum class OperationScope
type OperationScope
type OperationScope
Members
Member | Description
AllAssignedTextBoxes | Perform operation on all assigned text boxes.
CurrentTextBox | Perform operation on current text box only.


OptionsSavedEventArgs Class

OptionsSavedEventArgs Class
API ► Keyoti.RapidSpell.Wpf ► OptionsSavedEventArgs
Keyoti RapidSpell WPF
Args for the options saved event.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class OptionsSavedEventArgs : EventArgs
public class OptionsSavedEventArgs : EventArgs
Public Class OptionsSavedEventArgs
    Inherits EventArgs
Public Class OptionsSavedEventArgs
    Inherits EventArgs
public ref class OptionsSavedEventArgs : public EventArgs
public ref class OptionsSavedEventArgs : public EventArgs
type OptionsSavedEventArgs =
    class
        inherit EventArgs
    end
type OptionsSavedEventArgs =
    class
        inherit EventArgs
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OptionsSavedEventArgs(Boolean) | New instance
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TextRecheckRequired | Whether the change in options requires the text to be rechecked.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | OptionsSavedEventArgs


OptionsSavedEventArgs Constructor (textRecheckRequired)

OptionsSavedEventArgs Constructor (textRecheckRequired)
API ► Keyoti.RapidSpell.Wpf ► OptionsSavedEventArgs ► OptionsSavedEventArgs(Boolean)
Keyoti RapidSpell WPF
New instance
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public OptionsSavedEventArgs(
    bool textRecheckRequired
)
public OptionsSavedEventArgs(
    bool textRecheckRequired
)
Public Sub New (
    textRecheckRequired As Boolean
)
Public Sub New (
    textRecheckRequired As Boolean
)
public:
OptionsSavedEventArgs(
    bool textRecheckRequired
)
public:
OptionsSavedEventArgs(
    bool textRecheckRequired
)
new :
        textRecheckRequired : bool -> OptionsSavedEventArgs
new :
        textRecheckRequired : bool -> OptionsSavedEventArgs
Parameters
textRecheckRequired (Boolean)
Whether the change in options requires the text to be rechecked.


TextRecheckRequired Property

TextRecheckRequired Property
API ► Keyoti.RapidSpell.Wpf ► OptionsSavedEventArgs ► TextRecheckRequired
Keyoti RapidSpell WPF
Whether the change in options requires the text to be rechecked.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool TextRecheckRequired { get; }
public bool TextRecheckRequired { get; }
Public ReadOnly Property TextRecheckRequired As Boolean
    Get
Public ReadOnly Property TextRecheckRequired As Boolean
    Get
public:
property bool TextRecheckRequired {
    bool get ();
}
public:
property bool TextRecheckRequired {
    bool get ();
}
member TextRecheckRequired : bool with get

member TextRecheckRequired : bool with get
Property Value
Boolean


OptionsSavedEventHandler Delegate

OptionsSavedEventHandler Delegate
API ► Keyoti.RapidSpell.Wpf ► OptionsSavedEventHandler
Keyoti RapidSpell WPF
Handler
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void OptionsSavedEventHandler(
    Object sender,
    OptionsSavedEventArgs e
)
public delegate void OptionsSavedEventHandler(
    Object sender,
    OptionsSavedEventArgs e
)
Public Delegate Sub OptionsSavedEventHandler (
    sender As Object,
    e As OptionsSavedEventArgs
)
Public Delegate Sub OptionsSavedEventHandler (
    sender As Object,
    e As OptionsSavedEventArgs
)
public delegate void OptionsSavedEventHandler(
    Object^ sender,
    OptionsSavedEventArgs^ e
)
public delegate void OptionsSavedEventHandler(
    Object^ sender,
    OptionsSavedEventArgs^ e
)
type OptionsSavedEventHandler =
    delegate of
        sender : Object *
        e : OptionsSavedEventArgs -> unit
type OptionsSavedEventHandler =
    delegate of
        sender : Object *
        e : OptionsSavedEventArgs -> unit
Parameters
sender (Object)
e (OptionsSavedEventArgs)


RapidSpellAsYouType Class

RapidSpellAsYouType Class
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType
Keyoti RapidSpell WPF
RapidSpell As-You-Type Control, spell checks text boxes as the user types.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class RapidSpellAsYouType : DesignableComponent
public class RapidSpellAsYouType : DesignableComponent
Public Class RapidSpellAsYouType
    Inherits DesignableComponent
Public Class RapidSpellAsYouType
    Inherits DesignableComponent
public ref class RapidSpellAsYouType : public DesignableComponent
public ref class RapidSpellAsYouType : public DesignableComponent
type RapidSpellAsYouType =
    class
        inherit DesignableComponent
    end
type RapidSpellAsYouType =
    class
        inherit DesignableComponent
    end
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RapidSpellAsYouType()()()() | Default constructor.
 | RapidSpellAsYouType(IContainer) | Designer constructor.
 | ActualHeight | (Inherited from FrameworkElement.)
 | ActualWidth | (Inherited from FrameworkElement.)
 | AddHandler(RoutedEvent, Delegate) | (Inherited from UIElement.)
 | AddHandler(RoutedEvent, Delegate, Boolean) | (Inherited from UIElement.)
 | AddLogicalChild(Object) | (Inherited from FrameworkElement.)
 | AddMenuText | Add button text.
 | AddTextComponent(IAYTTextBox) | Add a text component to be checked to the collection.
 | AddTextComponent(TextBox) | Add a text component to be checked to the collection.
 | AddTextComponent(RichTextBox) | Add a text component to be checked to the collection.
 | AddToEventRoute(EventRoute, RoutedEventArgs) | (Inherited from UIElement.)
 | AddVisualChild(Visual) | (Inherited from Visual.)
 | AllowAnyCase | Whether to allow words spelt with incorrect case, eg. "africa", instead of "Africa", this is more relaxed than AllowMixedCase
 | AllowDrop | (Inherited from UIElement.)
 | AllowMixedCase | Whether to allow words spelt with mixed case, eg. "MIxEd"
 | ApplyAnimationClock(DependencyProperty, AnimationClock) | (Inherited from UIElement.)
 | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | (Inherited from UIElement.)
 | ApplyTemplate()()()() | (Inherited from FrameworkElement.)
 | AreAnyTouchesCaptured | (Inherited from UIElement.)
 | AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
 | AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
 | AreAnyTouchesOver | (Inherited from UIElement.)
 | Arrange(Rect) | (Inherited from UIElement.)
 | ArrangeCore(Rect) | (Inherited from FrameworkElement.)
 | ArrangeOverride(Size) | (Inherited from FrameworkElement.)
 | AutoCorrectEnabled | Whether to auto-correct common spelling/typographical mistakes (default is English errors).
 | AutoCorrectionMap | A map of common errors and their corrections.
 | BeginAnimation(DependencyProperty, AnimationTimeline) | (Inherited from UIElement.)
 | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | (Inherited from UIElement.)
 | BeginInit()()()() | (Inherited from FrameworkElement.)
 | BeginStoryboard(Storyboard) | (Inherited from FrameworkElement.)
 | BeginStoryboard(Storyboard, HandoffBehavior) | (Inherited from FrameworkElement.)
 | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | (Inherited from FrameworkElement.)
 | BindingGroup | (Inherited from FrameworkElement.)
 | BitmapEffect | Obsolete. (Inherited from UIElement.)
 | BitmapEffectInput | Obsolete. (Inherited from UIElement.)
 | BringIntoView()()()() | (Inherited from FrameworkElement.)
 | BringIntoView(Rect) | (Inherited from FrameworkElement.)
 | CacheMode | (Inherited from UIElement.)
 | CaptureMouse()()()() | (Inherited from UIElement.)
 | CaptureStylus()()()() | (Inherited from UIElement.)
 | CaptureTouch(TouchDevice) | (Inherited from UIElement.)
 | CheckAccess()()()() | (Inherited from DispatcherObject.)
 | CheckAsYouType | Whether to spell check words as the user types/modifies text.
 | CheckCompoundWords | Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
 | CheckDisabledTextBoxes | Whether to spell check textboxes which are disabled.
 | checkFromPosition | Index of of character in text to check from.
 | CheckReadOnlyTextBoxes | Whether to spell check textboxes which are readonly.
 | ClearAllHighlights()()()() | Clears all spell check highlights (underlines) from the whole document.
 | ClearValue(DependencyProperty) | (Inherited from DependencyObject.)
 | ClearValue(DependencyPropertyKey) | (Inherited from DependencyObject.)
 | Clip | (Inherited from UIElement.)
 | ClipToBounds | (Inherited from UIElement.)
 | CoerceValue(DependencyProperty) | (Inherited from DependencyObject.)
 | CommandBindings | (Inherited from UIElement.)
 | ConsiderationRange | Sets the factor for words to consider for suggestions, lower values are faster but consider less words for suggestions. Default is 500. If w <= 1 this method won't do anything.
 | ContextMenu | (Inherited from FrameworkElement.)
 | ContextMenuClosing | (Inherited from FrameworkElement.)
 | ContextMenuOpening | (Inherited from FrameworkElement.)
 | CurrentTextBox | The text box (IAYTTextBox, TextBox or RichTextBox) that the spell checker is working on.
 | Cursor | (Inherited from FrameworkElement.)
 | DataContext | (Inherited from FrameworkElement.)
 | DataContextChanged | (Inherited from FrameworkElement.)
 | DefaultStyleKey | (Inherited from FrameworkElement.)
 | DependencyObjectType | (Inherited from DependencyObject.)
 | DesignMode | Whether control is in design mode (Inherited from DesignableComponent.)
 | DesiredSize | (Inherited from UIElement.)
 | DictFilePath | Optional file path to the main dictionary .dict file to use.
 | Dispatcher | (Inherited from DispatcherObject.)
 | DragEnter | (Inherited from UIElement.)
 | DragLeave | (Inherited from UIElement.)
 | DragOver | (Inherited from UIElement.)
 | Drop | (Inherited from UIElement.)
 | Effect | (Inherited from UIElement.)
 | EndInit()()()() | (Inherited from FrameworkElement.)
 | Equals(Object) | (Inherited from DependencyObject.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FindCapitalizedSuggestions | Whether to look for capitalized suggestions, note this will slow FindSuggestions down by about 7 times.
 | FindCommonVisualAncestor(DependencyObject) | (Inherited from Visual.)
 | FindName(String) | (Inherited from FrameworkElement.)
 | FindResource(Object) | (Inherited from FrameworkElement.)
 | FlowDirection | (Inherited from FrameworkElement.)
 | Focus()()()() | (Inherited from UIElement.)
 | Focusable | (Inherited from UIElement.)
 | FocusableChanged | (Inherited from UIElement.)
 | FocusVisualStyle | (Inherited from FrameworkElement.)
 | ForceCheckAll()()()() | Forces a check of the whole document.
 | ForceCursor | (Inherited from FrameworkElement.)
 | FoundSpellingError | Fired when a spelling error is found.
 | GetAnimationBaseValue(DependencyProperty) | (Inherited from UIElement.)
 | GetBindingExpression(DependencyProperty) | (Inherited from FrameworkElement.)
 | GetHashCode()()()() | (Inherited from DependencyObject.)
 | GetLayoutClip(Size) | (Inherited from FrameworkElement.)
 | GetLocalValueEnumerator()()()() | (Inherited from DependencyObject.)
 | GetSuggestions()()()() | Returns suggestions menu items for the last right clicked word. Null/Nothing if none.
 | GetTemplateChild(String) | (Inherited from FrameworkElement.)
 | GetTextComponents()()()() | Gets a list of text components that are being spell checked.
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GetUIParentCore()()()() | (Inherited from FrameworkElement.)
 | GetValue(DependencyProperty) | (Inherited from DependencyObject.)
 | GetVisualChild(Int32) | (Inherited from FrameworkElement.)
 | GiveFeedback | (Inherited from UIElement.)
 | GotFocus | (Inherited from UIElement.)
 | GotKeyboardFocus | (Inherited from UIElement.)
 | GotMouseCapture | (Inherited from UIElement.)
 | GotStylusCapture | (Inherited from UIElement.)
 | GotTouchCapture | (Inherited from UIElement.)
 | GUILanguage | The language to show the UI in.
 | HasAnimatedProperties | (Inherited from UIElement.)
 | HasEffectiveKeyboardFocus | (Inherited from UIElement.)
 | Height | (Inherited from FrameworkElement.)
 | HitTestCore(PointHitTestParameters) | (Inherited from UIElement.)
 | HitTestCore(GeometryHitTestParameters) | (Inherited from UIElement.)
 | HorizontalAlignment | (Inherited from FrameworkElement.)
 | IgnoreAllMenuText | Ignore All button text.
 | IgnoreCapitalizedWords | Whether to ignore words with capital letters.
 | IgnoreIncorrectSentenceCapitalization | Whether to ignore incorrect sentence capitalization.
 | IgnoreInEnglishLowerCaseI | Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
 | IgnoreMenuText | Ignore button text.
 | IgnoreOnce(BadWord, IAYTTextBox) | Ignores an instance of a bad word in the the textbox.
 | IgnoreURLsAndEmailAddresses | Whether to ignore URLs and email addresses (requires V2Parser=true)
 | IgnoreWordsWithDigits | Whether to ignore words with numbers in them (eg. A10 or 7-11).
 | IgnoreXML | Whether to ignore XML/HTML tags, false by default.
 | IncludeUserDictionaryInSuggestions | Whether the user dictionary should be used in finding suggestions for misspelt words.
 | InheritanceBehavior | (Inherited from FrameworkElement.)
 | Initialized | (Inherited from FrameworkElement.)
 | InputBindings | (Inherited from UIElement.)
 | InputHitTest(Point) | (Inherited from UIElement.)
 | InputScope | (Inherited from FrameworkElement.)
 | InvalidateArrange()()()() | (Inherited from UIElement.)
 | InvalidateMeasure()()()() | (Inherited from UIElement.)
 | InvalidateProperty(DependencyProperty) | (Inherited from DependencyObject.)
 | InvalidateVisual()()()() | (Inherited from UIElement.)
 | IsAncestorOf(DependencyObject) | (Inherited from Visual.)
 | IsArrangeValid | (Inherited from UIElement.)
 | IsDescendantOf(DependencyObject) | (Inherited from Visual.)
 | IsEnabled | (Inherited from UIElement.)
 | IsEnabledChanged | (Inherited from UIElement.)
 | IsEnabledCore | (Inherited from UIElement.)
 | IsFocused | (Inherited from UIElement.)
 | IsHitTestVisible | (Inherited from UIElement.)
 | IsHitTestVisibleChanged | (Inherited from UIElement.)
 | IsInitialized | (Inherited from FrameworkElement.)
 | IsInputMethodEnabled | (Inherited from UIElement.)
 | IsKeyboardFocused | (Inherited from UIElement.)
 | IsKeyboardFocusedChanged | (Inherited from UIElement.)
 | IsKeyboardFocusWithin | (Inherited from UIElement.)
 | IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
 | IsLoaded | (Inherited from FrameworkElement.)
 | IsManipulationEnabled | (Inherited from UIElement.)
 | IsMeasureValid | (Inherited from UIElement.)
 | IsMouseCaptured | (Inherited from UIElement.)
 | IsMouseCapturedChanged | (Inherited from UIElement.)
 | IsMouseCaptureWithin | (Inherited from UIElement.)
 | IsMouseCaptureWithinChanged | (Inherited from UIElement.)
 | IsMouseDirectlyOver | (Inherited from UIElement.)
 | IsMouseDirectlyOverChanged | (Inherited from UIElement.)
 | IsMouseOver | (Inherited from UIElement.)
 | IsSealed | (Inherited from DependencyObject.)
 | IsStylusCaptured | (Inherited from UIElement.)
 | IsStylusCapturedChanged | (Inherited from UIElement.)
 | IsStylusCaptureWithin | (Inherited from UIElement.)
 | IsStylusCaptureWithinChanged | (Inherited from UIElement.)
 | IsStylusDirectlyOver | (Inherited from UIElement.)
 | IsStylusDirectlyOverChanged | (Inherited from UIElement.)
 | IsStylusOver | (Inherited from UIElement.)
 | IsVisible | (Inherited from UIElement.)
 | IsVisibleChanged | (Inherited from UIElement.)
 | KeyDown | (Inherited from UIElement.)
 | KeyUp | (Inherited from UIElement.)
 | Language | (Inherited from FrameworkElement.)
 | LanguageParser | The type of language parsing to use.
 | LayoutTransform | (Inherited from FrameworkElement.)
 | LayoutUpdated | (Inherited from UIElement.)
 | Loaded | (Inherited from FrameworkElement.)
 | LogicalChildren | (Inherited from FrameworkElement.)
 | LookIntoHyphenatedText | Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
 | LostFocus | (Inherited from UIElement.)
 | LostKeyboardFocus | (Inherited from UIElement.)
 | LostMouseCapture | (Inherited from UIElement.)
 | LostStylusCapture | (Inherited from UIElement.)
 | LostTouchCapture | (Inherited from UIElement.)
 | ManipulationBoundaryFeedback | (Inherited from UIElement.)
 | ManipulationCompleted | (Inherited from UIElement.)
 | ManipulationDelta | (Inherited from UIElement.)
 | ManipulationInertiaStarting | (Inherited from UIElement.)
 | ManipulationStarted | (Inherited from UIElement.)
 | ManipulationStarting | (Inherited from UIElement.)
 | Margin | (Inherited from FrameworkElement.)
 | MaxHeight | (Inherited from FrameworkElement.)
 | MaximumNumberOfErrorsToHighlight | The maximum number of errors that will be highlighted, setting this can prevent the UI slowing down if too many errors are present.
 | MaxWidth | (Inherited from FrameworkElement.)
 | Measure(Size) | (Inherited from UIElement.)
 | MeasureCore(Size) | (Inherited from FrameworkElement.)
 | MeasureOverride(Size) | (Inherited from FrameworkElement.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinHeight | (Inherited from FrameworkElement.)
 | MinWidth | (Inherited from FrameworkElement.)
 | MouseDown | (Inherited from UIElement.)
 | MouseEnter | (Inherited from UIElement.)
 | MouseLeave | (Inherited from UIElement.)
 | MouseLeftButtonDown | (Inherited from UIElement.)
 | MouseLeftButtonUp | (Inherited from UIElement.)
 | MouseMove | (Inherited from UIElement.)
 | MouseRightButtonDown | (Inherited from UIElement.)
 | MouseRightButtonUp | (Inherited from UIElement.)
 | MouseUp | (Inherited from UIElement.)
 | MouseWheel | (Inherited from UIElement.)
 | MoveFocus(TraversalRequest) | (Inherited from FrameworkElement.)
 | Name | (Inherited from FrameworkElement.)
 | NumberOfSpellingErrorsInCurrentTextBox | Gets the number of spelling errors in the current textbox, or -1 if there is no current textbox.
 | OnAccessKey(AccessKeyEventArgs) | (Inherited from UIElement.)
 | OnApplyTemplate()()()() | (Inherited from FrameworkElement.)
 | OnChildDesiredSizeChanged(UIElement) | (Inherited from UIElement.)
 | OnContextMenuClosing(ContextMenuEventArgs) | (Inherited from FrameworkElement.)
 | OnContextMenuOpening(ContextMenuEventArgs) | (Inherited from FrameworkElement.)
 | OnCreateAutomationPeer()()()() | (Inherited from UIElement.)
 | OnDisposed(Object, EventArgs) | Called when the control is disposed of.
 | OnDpiChanged(DpiScale, DpiScale) | (Inherited from Visual.)
 | OnDragEnter(DragEventArgs) | (Inherited from UIElement.)
 | OnDragLeave(DragEventArgs) | (Inherited from UIElement.)
 | OnDragOver(DragEventArgs) | (Inherited from UIElement.)
 | OnDrop(DragEventArgs) | (Inherited from UIElement.)
 | OnFoundSpellingError(FoundSpellingErrorEventArgs, Boolean) | Raises the FoundSpellingError event
 | OnGiveFeedback(GiveFeedbackEventArgs) | (Inherited from UIElement.)
 | OnGotFocus(RoutedEventArgs) | (Inherited from FrameworkElement.)
 | OnGotKeyboardFocus(KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
 | OnGotMouseCapture(MouseEventArgs) | (Inherited from UIElement.)
 | OnGotStylusCapture(StylusEventArgs) | (Inherited from UIElement.)
 | OnGotTouchCapture(TouchEventArgs) | (Inherited from UIElement.)
 | OnInitialized(EventArgs) | (Inherited from FrameworkElement.)
 | OnIsKeyboardFocusedChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsKeyboardFocusWithinChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsMouseCapturedChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsMouseCaptureWithinChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsMouseDirectlyOverChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsStylusCapturedChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsStylusCaptureWithinChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsStylusDirectlyOverChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnKeyDown(KeyEventArgs) | (Inherited from UIElement.)
 | OnKeyUp(KeyEventArgs) | (Inherited from UIElement.)
 | OnLostFocus(RoutedEventArgs) | (Inherited from UIElement.)
 | OnLostKeyboardFocus(KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
 | OnLostMouseCapture(MouseEventArgs) | (Inherited from UIElement.)
 | OnLostStylusCapture(StylusEventArgs) | (Inherited from UIElement.)
 | OnLostTouchCapture(TouchEventArgs) | (Inherited from UIElement.)
 | OnManipulationBoundaryFeedback(ManipulationBoundaryFeedbackEventArgs) | (Inherited from UIElement.)
 | OnManipulationCompleted(ManipulationCompletedEventArgs) | (Inherited from UIElement.)
 | OnManipulationDelta(ManipulationDeltaEventArgs) | (Inherited from UIElement.)
 | OnManipulationInertiaStarting(ManipulationInertiaStartingEventArgs) | (Inherited from UIElement.)
 | OnManipulationStarted(ManipulationStartedEventArgs) | (Inherited from UIElement.)
 | OnManipulationStarting(ManipulationStartingEventArgs) | (Inherited from UIElement.)
 | OnMouseDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseEnter(MouseEventArgs) | (Inherited from UIElement.)
 | OnMouseLeave(MouseEventArgs) | (Inherited from UIElement.)
 | OnMouseLeftButtonDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseLeftButtonUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseMove(MouseEventArgs) | (Inherited from UIElement.)
 | OnMouseRightButtonDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseRightButtonUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseWheel(MouseWheelEventArgs) | (Inherited from UIElement.)
 | OnPreviewDragEnter(DragEventArgs) | (Inherited from UIElement.)
 | OnPreviewDragLeave(DragEventArgs) | (Inherited from UIElement.)
 | OnPreviewDragOver(DragEventArgs) | (Inherited from UIElement.)
 | OnPreviewDrop(DragEventArgs) | (Inherited from UIElement.)
 | OnPreviewGiveFeedback(GiveFeedbackEventArgs) | (Inherited from UIElement.)
 | OnPreviewGotKeyboardFocus(KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
 | OnPreviewKeyDown(KeyEventArgs) | (Inherited from UIElement.)
 | OnPreviewKeyUp(KeyEventArgs) | (Inherited from UIElement.)
 | OnPreviewLostKeyboardFocus(KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseLeftButtonDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseLeftButtonUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseMove(MouseEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseRightButtonDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseRightButtonUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseWheel(MouseWheelEventArgs) | (Inherited from UIElement.)
 | OnPreviewQueryContinueDrag(QueryContinueDragEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusButtonDown(StylusButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusButtonUp(StylusButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusDown(StylusDownEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusInAirMove(StylusEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusInRange(StylusEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusMove(StylusEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusOutOfRange(StylusEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusSystemGesture(StylusSystemGestureEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusUp(StylusEventArgs) | (Inherited from UIElement.)
 | OnPreviewTextInput(TextCompositionEventArgs) | (Inherited from UIElement.)
 | OnPreviewTouchDown(TouchEventArgs) | (Inherited from UIElement.)
 | OnPreviewTouchMove(TouchEventArgs) | (Inherited from UIElement.)
 | OnPreviewTouchUp(TouchEventArgs) | (Inherited from UIElement.)
 | OnPropertyChanged(DependencyPropertyChangedEventArgs) | (Inherited from FrameworkElement.)
 | OnQueryContinueDrag(QueryContinueDragEventArgs) | (Inherited from UIElement.)
 | OnQueryCursor(QueryCursorEventArgs) | (Inherited from UIElement.)
 | OnRender(DrawingContext) | Renders the control (Inherited from DesignableComponent.)
 | OnRenderSizeChanged(SizeChangedInfo) | (Inherited from FrameworkElement.)
 | OnSpellContextMenuRequest(SpellContextMenuEventArgs) | Fires event when a context menu is requested
 | OnStyleChanged(Style, Style) | (Inherited from FrameworkElement.)
 | OnStylusButtonDown(StylusButtonEventArgs) | (Inherited from UIElement.)
 | OnStylusButtonUp(StylusButtonEventArgs) | (Inherited from UIElement.)
 | OnStylusDown(StylusDownEventArgs) | (Inherited from UIElement.)
 | OnStylusEnter(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusInAirMove(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusInRange(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusLeave(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusMove(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusOutOfRange(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusSystemGesture(StylusSystemGestureEventArgs) | (Inherited from UIElement.)
 | OnStylusUp(StylusEventArgs) | (Inherited from UIElement.)
 | OnTextInput(TextCompositionEventArgs) | (Inherited from UIElement.)
 | OnToolTipClosing(ToolTipEventArgs) | (Inherited from FrameworkElement.)
 | OnToolTipOpening(ToolTipEventArgs) | (Inherited from FrameworkElement.)
 | OnTouchDown(TouchEventArgs) | (Inherited from UIElement.)
 | OnTouchEnter(TouchEventArgs) | (Inherited from UIElement.)
 | OnTouchLeave(TouchEventArgs) | (Inherited from UIElement.)
 | OnTouchMove(TouchEventArgs) | (Inherited from UIElement.)
 | OnTouchUp(TouchEventArgs) | (Inherited from UIElement.)
 | OnVisualChildrenChanged(DependencyObject, DependencyObject) | (Inherited from Visual.)
 | OnVisualParentChanged(DependencyObject) | (Inherited from FrameworkElement.)
 | OnWordAdded(WordAddedEventArgs) | Fires event when a word is added to the user dictionary
 | OnWordChanged(WordChangedEventArgs) | Fires event when a word is changed
 | OnWordIgnored(WordIgnoredEventArgs) | Fires event when a word is ignored
 | OnWordsEntered(WordsEnteredEventArgs) | Fires event when a word is entered into the textbox
 | Opacity | (Inherited from UIElement.)
 | OpacityMask | (Inherited from UIElement.)
 | Options | Object responsible for holding, loading and saving the user's spell check options.
 | OptionsEnabled | Whether to use user options.
 | OptionsFileName | The file name used to store the settings (by default in IsolatedStorage).
 | OptionsPresenter | Presenter for the user options form (IDialogViewOptions).
 | OptionsStorageLocation | Where the user's options are stored.
 | OverridesDefaultStyle | (Inherited from FrameworkElement.)
 | Parent | (Inherited from FrameworkElement.)
 | ParentLayoutInvalidated(UIElement) | (Inherited from FrameworkElement.)
 | PersistId | Obsolete. (Inherited from UIElement.)
 | PointFromScreen(Point) | (Inherited from Visual.)
 | PointToScreen(Point) | (Inherited from Visual.)
 | PredictFocus(FocusNavigationDirection) | (Inherited from FrameworkElement.)
 | PreviewDragEnter | (Inherited from UIElement.)
 | PreviewDragLeave | (Inherited from UIElement.)
 | PreviewDragOver | (Inherited from UIElement.)
 | PreviewDrop | (Inherited from UIElement.)
 | PreviewGiveFeedback | (Inherited from UIElement.)
 | PreviewGotKeyboardFocus | (Inherited from UIElement.)
 | PreviewKeyDown | (Inherited from UIElement.)
 | PreviewKeyUp | (Inherited from UIElement.)
 | PreviewLostKeyboardFocus | (Inherited from UIElement.)
 | PreviewMouseDown | (Inherited from UIElement.)
 | PreviewMouseLeftButtonDown | (Inherited from UIElement.)
 | PreviewMouseLeftButtonUp | (Inherited from UIElement.)
 | PreviewMouseMove | (Inherited from UIElement.)
 | PreviewMouseRightButtonDown | (Inherited from UIElement.)
 | PreviewMouseRightButtonUp | (Inherited from UIElement.)
 | PreviewMouseUp | (Inherited from UIElement.)
 | PreviewMouseWheel | (Inherited from UIElement.)
 | PreviewQueryContinueDrag | (Inherited from UIElement.)
 | PreviewStylusButtonDown | (Inherited from UIElement.)
 | PreviewStylusButtonUp | (Inherited from UIElement.)
 | PreviewStylusDown | (Inherited from UIElement.)
 | PreviewStylusInAirMove | (Inherited from UIElement.)
 | PreviewStylusInRange | (Inherited from UIElement.)
 | PreviewStylusMove | (Inherited from UIElement.)
 | PreviewStylusOutOfRange | (Inherited from UIElement.)
 | PreviewStylusSystemGesture | (Inherited from UIElement.)
 | PreviewStylusUp | (Inherited from UIElement.)
 | PreviewTextInput | (Inherited from UIElement.)
 | PreviewTouchDown | (Inherited from UIElement.)
 | PreviewTouchMove | (Inherited from UIElement.)
 | PreviewTouchUp | (Inherited from UIElement.)
 | QueryContinueDrag | (Inherited from UIElement.)
 | QueryCursor | (Inherited from UIElement.)
 | RaiseEvent(RoutedEventArgs) | (Inherited from UIElement.)
 | RapidSpellChecker | The core spell checker object
 | ReadLocalValue(DependencyProperty) | (Inherited from DependencyObject.)
 | RecheckTextOnPropertyChange | Whether to recheck the text when properties that affect the spell check change.
 | RegisterName(String, Object) | (Inherited from FrameworkElement.)
 | ReleaseAllTouchCaptures()()()() | (Inherited from UIElement.)
 | ReleaseMouseCapture()()()() | (Inherited from UIElement.)
 | ReleaseStylusCapture()()()() | (Inherited from UIElement.)
 | ReleaseTouchCapture(TouchDevice) | (Inherited from UIElement.)
 | RemoveAllTextComponents()()()() | Removes all text components to be checked from the collection.
 | RemoveDuplicateWordText | Remove duplicate word text
 | RemoveHandler(RoutedEvent, Delegate) | (Inherited from UIElement.)
 | RemoveLogicalChild(Object) | (Inherited from FrameworkElement.)
 | RemoveTextComponent(IAYTTextBox) | Remove a text component to be checked from the collection.
 | RemoveTextComponent(TextBox) | Remove a text component to be checked from the collection.
 | RemoveTextComponent(RichTextBox) | Remove a text component to be checked from the collection.
 | RemoveVisualChild(Visual) | (Inherited from Visual.)
 | RenderSize | (Inherited from UIElement.)
 | RenderTransform | (Inherited from UIElement.)
 | RenderTransformOrigin | (Inherited from UIElement.)
 | RepaintUnderlines()()()() | Repaints the underlines, this should be called if any changes are made to layout, such as changes to font sizes, etc.
 | RequestBringIntoView | (Inherited from FrameworkElement.)
 | ResetIgnoredWords()()()() | Resets all ignored words, so that the document will be rechecked.
 | Resources | (Inherited from FrameworkElement.)
 | SetBinding(DependencyProperty, BindingBase) | (Inherited from FrameworkElement.)
 | SetBinding(DependencyProperty, String) | (Inherited from FrameworkElement.)
 | SetCurrentValue(DependencyProperty, Object) | (Inherited from DependencyObject.)
 | SetResourceReference(DependencyProperty, Object) | (Inherited from FrameworkElement.)
 | SetValue(DependencyProperty, Object) | (Inherited from DependencyObject.)
 | SetValue(DependencyPropertyKey, Object) | (Inherited from DependencyObject.)
 | ShouldSerializeCommandBindings()()()() | (Inherited from UIElement.)
 | ShouldSerializeInputBindings()()()() | (Inherited from UIElement.)
 | ShouldSerializeProperty(DependencyProperty) | (Inherited from DependencyObject.)
 | ShouldSerializeResources()()()() | (Inherited from FrameworkElement.)
 | ShouldSerializeStyle()()()() | (Inherited from FrameworkElement.)
 | ShouldSerializeTriggers()()()() | (Inherited from FrameworkElement.)
 | ShowAddMenuOption | Whether to show the Add option in the context menu.
 | ShowCutCopyPasteMenuOnTextBoxBase | Whether to show a cut copy paste context menu on TextBoxBase controls being checked.
 | ShowSuggestionsContextMenu | Whether to show a context menu with suggestions when a misspelt word is right clicked, has no effect on developer set context menu.
 | ShowSuggestionsWhenTextIsSelected | Whether to show the spelling context menu regardless of whether text is currently selected.
 | ShowUnderlines | Whether to show or hide error underlines.
 | SizeChanged | (Inherited from FrameworkElement.)
 | SnapsToDevicePixels | (Inherited from UIElement.)
 | SourceUpdated | (Inherited from FrameworkElement.)
 | SpellCheckFinished | Fired when checking finishes
 | SpellCheckStarted | Fired when checking starts
 | SpellContextMenuRequest | Fired when a request is made (usually by a right click on an underlined word) for context menu
 | Style | (Inherited from FrameworkElement.)
 | StylusButtonDown | (Inherited from UIElement.)
 | StylusButtonUp | (Inherited from UIElement.)
 | StylusDown | (Inherited from UIElement.)
 | StylusEnter | (Inherited from UIElement.)
 | StylusInAirMove | (Inherited from UIElement.)
 | StylusInRange | (Inherited from UIElement.)
 | StylusLeave | (Inherited from UIElement.)
 | StylusMove | (Inherited from UIElement.)
 | StylusOutOfRange | (Inherited from UIElement.)
 | StylusPlugIns | (Inherited from UIElement.)
 | StylusSystemGesture | (Inherited from UIElement.)
 | StylusUp | (Inherited from UIElement.)
 | SuggestionsMethod | The suggestions method to use.
 | SuggestSplitWords | Whether to look for connected words in suggestions.
 | Tag | (Inherited from FrameworkElement.)
 | TargetUpdated | (Inherited from FrameworkElement.)
 | TemplatedParent | (Inherited from FrameworkElement.)
 | TextBoundary | The AdvancedTextBoundary class to use to parse words.
 | TextBox | The TextBox or RichTextBox to work with
 | TextBoxProperty | The TextBox or RichTextBox to work with.
 | TextComponent | The IAYTTextBox text box to check as the user types/modifies text.
 | TextInput | (Inherited from UIElement.)
 | ToolTip | (Inherited from FrameworkElement.)
 | ToolTipClosing | (Inherited from FrameworkElement.)
 | ToolTipOpening | (Inherited from FrameworkElement.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | TouchDown | (Inherited from UIElement.)
 | TouchEnter | (Inherited from UIElement.)
 | TouchesCaptured | (Inherited from UIElement.)
 | TouchesCapturedWithin | (Inherited from UIElement.)
 | TouchesDirectlyOver | (Inherited from UIElement.)
 | TouchesOver | (Inherited from UIElement.)
 | TouchLeave | (Inherited from UIElement.)
 | TouchMove | (Inherited from UIElement.)
 | TouchUp | (Inherited from UIElement.)
 | TransformToAncestor(Visual) | (Inherited from Visual.)
 | TransformToAncestor(Visual3D) | (Inherited from Visual.)
 | TransformToDescendant(Visual) | (Inherited from Visual.)
 | TransformToVisual(Visual) | (Inherited from Visual.)
 | TranslatePoint(Point, UIElement) | (Inherited from UIElement.)
 | Triggers | (Inherited from FrameworkElement.)
 | TryFindResource(Object) | (Inherited from FrameworkElement.)
 | Uid | (Inherited from UIElement.)
 | UnderlineColor | The underline color to use with mis-spelt words.
 | UnderlineStyle | The underline style to use with mis-spelt words.
 | UnignoreWord(BadWord, IAYTTextBox) | Unignores an instance of a bad word in the the textbox.
 | Unloaded | (Inherited from FrameworkElement.)
 | UnregisterName(String) | (Inherited from FrameworkElement.)
 | UpdateAllTextBoxes | Whether to update all text boxes when ForceCheckAll is called, usually this should be true.
 | UpdateDefaultStyle()()()() | (Inherited from FrameworkElement.)
 | UpdateLayout()()()() | (Inherited from UIElement.)
 | UseLayoutRounding | (Inherited from FrameworkElement.)
 | UserDictionaryFile | The user dictionary file, if this file doesn't exist it will be created.
 | V2Parser | Whether to use parser version 2 - Set to false for backwards (pre v3.4) compatibility.
 | VerifyAccess()()()() | (Inherited from DispatcherObject.)
 | VerticalAlignment | (Inherited from FrameworkElement.)
 | Visibility | (Inherited from UIElement.)
 | VisualBitmapEffect | Obsolete. (Inherited from Visual.)
 | VisualBitmapEffectInput | Obsolete. (Inherited from Visual.)
 | VisualBitmapScalingMode | (Inherited from Visual.)
 | VisualCacheMode | (Inherited from Visual.)
 | VisualChildrenCount | (Inherited from FrameworkElement.)
 | VisualClearTypeHint | (Inherited from Visual.)
 | VisualClip | (Inherited from Visual.)
 | VisualEdgeMode | (Inherited from Visual.)
 | VisualEffect | (Inherited from Visual.)
 | VisualOffset | (Inherited from Visual.)
 | VisualOpacity | (Inherited from Visual.)
 | VisualOpacityMask | (Inherited from Visual.)
 | VisualParent | (Inherited from Visual.)
 | VisualScrollableAreaClip | (Inherited from Visual.)
 | VisualTextHintingMode | (Inherited from Visual.)
 | VisualTextRenderingMode | (Inherited from Visual.)
 | VisualTransform | (Inherited from Visual.)
 | VisualXSnappingGuidelines | (Inherited from Visual.)
 | VisualYSnappingGuidelines | (Inherited from Visual.)
 | WarnDuplicates | Whether to show duplicate words as errors (eg. "this is is an error").
 | Width | (Inherited from FrameworkElement.)
 | WordAdded | Fired when word added to user dictionary
 | WordChanged | Fired when word changed
 | WordIgnored | Fired when word ignored
 | WordsEntered | Fired when words have been entered (typed or pasted).
Remarks
This class works with IAYTTextBox interface classes and RichTextBox and TextBox. This class not only checks as the user types, but also follows any text modifying actions, such as; Cut, paste, selection delete etc.
Inheritance Hierarchy
Object
 | DispatcherObject
 |  | DependencyObject
 |  |  | Visual
 |  |  |  | UIElement
 |  |  |  |  | FrameworkElement
 |  |  |  |  |  | DesignableComponent
 |  |  |  |  |  |  | RapidSpellAsYouType


RapidSpellAsYouType Constructor

RapidSpellAsYouType Constructor
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► RapidSpellAsYouType()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | RapidSpellAsYouType()()()() | Default constructor.
 | RapidSpellAsYouType(IContainer) | Designer constructor.


RapidSpellAsYouType Constructor

RapidSpellAsYouType Constructor
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► RapidSpellAsYouType()()()()
Keyoti RapidSpell WPF
Default constructor.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public RapidSpellAsYouType()
public RapidSpellAsYouType()
Public Sub New
Public Sub New
public:
RapidSpellAsYouType()
public:
RapidSpellAsYouType()
new : unit -> RapidSpellAsYouType
new : unit -> RapidSpellAsYouType


RapidSpellAsYouType Constructor (container)

RapidSpellAsYouType Constructor (container)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► RapidSpellAsYouType(IContainer)
Keyoti RapidSpell WPF
Designer constructor.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public RapidSpellAsYouType(
    IContainer container
)
public RapidSpellAsYouType(
    IContainer container
)
Public Sub New (
    container As IContainer
)
Public Sub New (
    container As IContainer
)
public:
RapidSpellAsYouType(
    IContainer^ container
)
public:
RapidSpellAsYouType(
    IContainer^ container
)
new :
        container : IContainer -> RapidSpellAsYouType
new :
        container : IContainer -> RapidSpellAsYouType
Parameters
container (IContainer)


AddMenuText Property

AddMenuText Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► AddMenuText
Keyoti RapidSpell WPF
Add button text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string AddMenuText { get; set; }
public string AddMenuText { get; set; }
Public Property AddMenuText As String
    Get
    Set
Public Property AddMenuText As String
    Get
    Set
public:
property String^ AddMenuText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ AddMenuText {
    String^ get ();
    void set (String^ value);
}
member AddMenuText : string with get, set

member AddMenuText : string with get, set
Property Value
String


AddTextComponent Method

AddTextComponent Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► AddTextComponent()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | AddTextComponent(IAYTTextBox) | Add a text component to be checked to the collection.
 | AddTextComponent(TextBox) | Add a text component to be checked to the collection.
 | AddTextComponent(RichTextBox) | Add a text component to be checked to the collection.


AddTextComponent Method (textComponent)

AddTextComponent Method (textComponent)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► AddTextComponent(IAYTTextBox)
Keyoti RapidSpell WPF
Add a text component to be checked to the collection.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void AddTextComponent(
    IAYTTextBox textComponent
)
public virtual void AddTextComponent(
    IAYTTextBox textComponent
)
Public Overridable Sub AddTextComponent (
    textComponent As IAYTTextBox
)
Public Overridable Sub AddTextComponent (
    textComponent As IAYTTextBox
)
public:
virtual void AddTextComponent(
    IAYTTextBox^ textComponent
)
public:
virtual void AddTextComponent(
    IAYTTextBox^ textComponent
)
abstract AddTextComponent :
        textComponent : IAYTTextBox -> unit
override AddTextComponent :
        textComponent : IAYTTextBox -> unit
abstract AddTextComponent :
        textComponent : IAYTTextBox -> unit
override AddTextComponent :
        textComponent : IAYTTextBox -> unit
Parameters
textComponent (IAYTTextBox)
The text box to be spell checked
Remarks
If textboxes are to be dynamically added/removed from the collection of textboxes to check, call this and RemoveTextComponent


AddTextComponent Method (textComponent)

AddTextComponent Method (textComponent)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► AddTextComponent(RichTextBox)
Keyoti RapidSpell WPF
Add a text component to be checked to the collection.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void AddTextComponent(
    RichTextBox textComponent
)
public virtual void AddTextComponent(
    RichTextBox textComponent
)
Public Overridable Sub AddTextComponent (
    textComponent As RichTextBox
)
Public Overridable Sub AddTextComponent (
    textComponent As RichTextBox
)
public:
virtual void AddTextComponent(
    RichTextBox^ textComponent
)
public:
virtual void AddTextComponent(
    RichTextBox^ textComponent
)
abstract AddTextComponent :
        textComponent : RichTextBox -> unit
override AddTextComponent :
        textComponent : RichTextBox -> unit
abstract AddTextComponent :
        textComponent : RichTextBox -> unit
override AddTextComponent :
        textComponent : RichTextBox -> unit
Parameters
textComponent (RichTextBox)
The text box to be spell checked
Remarks
If textboxes are to be dynamically added/removed from the collection of textboxes to check, call this and RemoveTextComponent


AddTextComponent Method (textComponent)

AddTextComponent Method (textComponent)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► AddTextComponent(TextBox)
Keyoti RapidSpell WPF
Add a text component to be checked to the collection.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void AddTextComponent(
    TextBox textComponent
)
public virtual void AddTextComponent(
    TextBox textComponent
)
Public Overridable Sub AddTextComponent (
    textComponent As TextBox
)
Public Overridable Sub AddTextComponent (
    textComponent As TextBox
)
public:
virtual void AddTextComponent(
    TextBox^ textComponent
)
public:
virtual void AddTextComponent(
    TextBox^ textComponent
)
abstract AddTextComponent :
        textComponent : TextBox -> unit
override AddTextComponent :
        textComponent : TextBox -> unit
abstract AddTextComponent :
        textComponent : TextBox -> unit
override AddTextComponent :
        textComponent : TextBox -> unit
Parameters
textComponent (TextBox)
The text box to be spell checked
Remarks
If textboxes are to be dynamically added/removed from the collection of textboxes to check, call this and RemoveTextComponent


AllowAnyCase Property

AllowAnyCase Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► AllowAnyCase
Keyoti RapidSpell WPF
Whether to allow words spelt with incorrect case, eg. "africa", instead of "Africa", this is more relaxed than AllowMixedCase
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool AllowAnyCase { get; set; }
public bool AllowAnyCase { get; set; }
Public Property AllowAnyCase As Boolean
    Get
    Set
Public Property AllowAnyCase As Boolean
    Get
    Set
public:
property bool AllowAnyCase {
    bool get ();
    void set (bool value);
}
public:
property bool AllowAnyCase {
    bool get ();
    void set (bool value);
}
member AllowAnyCase : bool with get, set

member AllowAnyCase : bool with get, set
Property Value
Boolean


AllowMixedCase Property

AllowMixedCase Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► AllowMixedCase
Keyoti RapidSpell WPF
Whether to allow words spelt with mixed case, eg. "MIxEd"
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool AllowMixedCase { get; set; }
public bool AllowMixedCase { get; set; }
Public Property AllowMixedCase As Boolean
    Get
    Set
Public Property AllowMixedCase As Boolean
    Get
    Set
public:
property bool AllowMixedCase {
    bool get ();
    void set (bool value);
}
public:
property bool AllowMixedCase {
    bool get ();
    void set (bool value);
}
member AllowMixedCase : bool with get, set

member AllowMixedCase : bool with get, set
Property Value
Boolean


AutoCorrectEnabled Property

AutoCorrectEnabled Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► AutoCorrectEnabled
Keyoti RapidSpell WPF
Whether to auto-correct common spelling/typographical mistakes (default is English errors).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool AutoCorrectEnabled { get; set; }
public bool AutoCorrectEnabled { get; set; }
Public Property AutoCorrectEnabled As Boolean
    Get
    Set
Public Property AutoCorrectEnabled As Boolean
    Get
    Set
public:
property bool AutoCorrectEnabled {
    bool get ();
    void set (bool value);
}
public:
property bool AutoCorrectEnabled {
    bool get ();
    void set (bool value);
}
member AutoCorrectEnabled : bool with get, set

member AutoCorrectEnabled : bool with get, set
Property Value
Boolean
Remarks
To set a custom list (eg. other languages see AutoCorrectionMap)


AutoCorrectionMap Property

AutoCorrectionMap Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► AutoCorrectionMap
Keyoti RapidSpell WPF
A map of common errors and their corrections.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual Hashtable AutoCorrectionMap { get; set; }
public virtual Hashtable AutoCorrectionMap { get; set; }
Public Overridable Property AutoCorrectionMap As Hashtable
    Get
    Set
Public Overridable Property AutoCorrectionMap As Hashtable
    Get
    Set
public:
virtual property Hashtable^ AutoCorrectionMap {
    Hashtable^ get ();
    void set (Hashtable^ value);
}
public:
virtual property Hashtable^ AutoCorrectionMap {
    Hashtable^ get ();
    void set (Hashtable^ value);
}
abstract AutoCorrectionMap : Hashtable with get, set
override AutoCorrectionMap : Hashtable with get, set
abstract AutoCorrectionMap : Hashtable with get, set
override AutoCorrectionMap : Hashtable with get, set
Property Value
Hashtable
Remarks
To set a custom list (eg. other languages see AutoCorrectionMap)


CheckAsYouType Property

CheckAsYouType Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► CheckAsYouType
Keyoti RapidSpell WPF
Whether to spell check words as the user types/modifies text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool CheckAsYouType { get; set; }
public bool CheckAsYouType { get; set; }
Public Property CheckAsYouType As Boolean
    Get
    Set
Public Property CheckAsYouType As Boolean
    Get
    Set
public:
property bool CheckAsYouType {
    bool get ();
    void set (bool value);
}
public:
property bool CheckAsYouType {
    bool get ();
    void set (bool value);
}
member CheckAsYouType : bool with get, set

member CheckAsYouType : bool with get, set
Property Value
Boolean
Remarks
True turns spell checking on, false turns it off. If a change of state occurs then either SpellCheckStarted or SpellCheckFinished events are fired.


CheckCompoundWords Property

CheckCompoundWords Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► CheckCompoundWords
Keyoti RapidSpell WPF
Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool CheckCompoundWords { get; set; }
public bool CheckCompoundWords { get; set; }
Public Property CheckCompoundWords As Boolean
    Get
    Set
Public Property CheckCompoundWords As Boolean
    Get
    Set
public:
property bool CheckCompoundWords {
    bool get ();
    void set (bool value);
}
public:
property bool CheckCompoundWords {
    bool get ();
    void set (bool value);
}
member CheckCompoundWords : bool with get, set

member CheckCompoundWords : bool with get, set
Property Value
Boolean
Remarks
If this=false then LookUp("thesewordsarejoined") = false

If this=true then LookUp("thesewordsarejoined") = true

If this=false then LookUp("abcdef") = false

If this=true then LookUp("abcdef") = false

Setting this to true will degrade lookup performance


CheckDisabledTextBoxes Property

CheckDisabledTextBoxes Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► CheckDisabledTextBoxes
Keyoti RapidSpell WPF
Whether to spell check textboxes which are disabled.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool CheckDisabledTextBoxes { get; set; }
public bool CheckDisabledTextBoxes { get; set; }
Public Property CheckDisabledTextBoxes As Boolean
    Get
    Set
Public Property CheckDisabledTextBoxes As Boolean
    Get
    Set
public:
property bool CheckDisabledTextBoxes {
    bool get ();
    void set (bool value);
}
public:
property bool CheckDisabledTextBoxes {
    bool get ();
    void set (bool value);
}
member CheckDisabledTextBoxes : bool with get, set

member CheckDisabledTextBoxes : bool with get, set
Property Value
Boolean


checkFromPosition Field

checkFromPosition Field
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► checkFromPosition
Keyoti RapidSpell WPF
Index of of character in text to check from.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected int checkFromPosition
protected int checkFromPosition
Protected checkFromPosition As Integer
Protected checkFromPosition As Integer
protected:
int checkFromPosition
protected:
int checkFromPosition
val mutable checkFromPosition: int
val mutable checkFromPosition: int
Field Value
Int32


CheckReadOnlyTextBoxes Property

CheckReadOnlyTextBoxes Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► CheckReadOnlyTextBoxes
Keyoti RapidSpell WPF
Whether to spell check textboxes which are readonly.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool CheckReadOnlyTextBoxes { get; set; }
public bool CheckReadOnlyTextBoxes { get; set; }
Public Property CheckReadOnlyTextBoxes As Boolean
    Get
    Set
Public Property CheckReadOnlyTextBoxes As Boolean
    Get
    Set
public:
property bool CheckReadOnlyTextBoxes {
    bool get ();
    void set (bool value);
}
public:
property bool CheckReadOnlyTextBoxes {
    bool get ();
    void set (bool value);
}
member CheckReadOnlyTextBoxes : bool with get, set

member CheckReadOnlyTextBoxes : bool with get, set
Property Value
Boolean


ClearAllHighlights Method

ClearAllHighlights Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► ClearAllHighlights()()()()
Keyoti RapidSpell WPF
Clears all spell check highlights (underlines) from the whole document.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void ClearAllHighlights()
public void ClearAllHighlights()
Public Sub ClearAllHighlights
Public Sub ClearAllHighlights
public:
void ClearAllHighlights()
public:
void ClearAllHighlights()
member ClearAllHighlights : unit -> unit

member ClearAllHighlights : unit -> unit


ConsiderationRange Property

ConsiderationRange Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► ConsiderationRange
Keyoti RapidSpell WPF
Sets the factor for words to consider for suggestions, lower values are faster but consider less words for suggestions. Default is 500. If w <= 1 this method won't do anything.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int ConsiderationRange { get; set; }
public int ConsiderationRange { get; set; }
Public Property ConsiderationRange As Integer
    Get
    Set
Public Property ConsiderationRange As Integer
    Get
    Set
public:
property int ConsiderationRange {
    int get ();
    void set (int value);
}
public:
property int ConsiderationRange {
    int get ();
    void set (int value);
}
member ConsiderationRange : int with get, set

member ConsiderationRange : int with get, set
Property Value
Int32


CurrentTextBox Property

CurrentTextBox Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► CurrentTextBox
Keyoti RapidSpell WPF
The text box (IAYTTextBox, TextBox or RichTextBox) that the spell checker is working on.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Object CurrentTextBox { get; }
public Object CurrentTextBox { get; }
Public ReadOnly Property CurrentTextBox As Object
    Get
Public ReadOnly Property CurrentTextBox As Object
    Get
public:
property Object^ CurrentTextBox {
    Object^ get ();
}
public:
property Object^ CurrentTextBox {
    Object^ get ();
}
member CurrentTextBox : Object with get

member CurrentTextBox : Object with get
Property Value
Object


DictFilePath Property

DictFilePath Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► DictFilePath
Keyoti RapidSpell WPF
Optional file path to the main dictionary .dict file to use.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string DictFilePath { get; set; }
public string DictFilePath { get; set; }
Public Property DictFilePath As String
    Get
    Set
Public Property DictFilePath As String
    Get
    Set
public:
property String^ DictFilePath {
    String^ get ();
    void set (String^ value);
}
public:
property String^ DictFilePath {
    String^ get ();
    void set (String^ value);
}
member DictFilePath : string with get, set

member DictFilePath : string with get, set
Property Value
String


FindCapitalizedSuggestions Property

FindCapitalizedSuggestions Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► FindCapitalizedSuggestions
Keyoti RapidSpell WPF
Whether to look for capitalized suggestions, note this will slow FindSuggestions down by about 7 times.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool FindCapitalizedSuggestions { get; set; }
public bool FindCapitalizedSuggestions { get; set; }
Public Property FindCapitalizedSuggestions As Boolean
    Get
    Set
Public Property FindCapitalizedSuggestions As Boolean
    Get
    Set
public:
property bool FindCapitalizedSuggestions {
    bool get ();
    void set (bool value);
}
public:
property bool FindCapitalizedSuggestions {
    bool get ();
    void set (bool value);
}
member FindCapitalizedSuggestions : bool with get, set

member FindCapitalizedSuggestions : bool with get, set
Property Value
Boolean


ForceCheckAll Method

ForceCheckAll Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► ForceCheckAll()()()()
Keyoti RapidSpell WPF
Forces a check of the whole document.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void ForceCheckAll()
public void ForceCheckAll()
Public Sub ForceCheckAll
Public Sub ForceCheckAll
public:
void ForceCheckAll()
public:
void ForceCheckAll()
member ForceCheckAll : unit -> unit

member ForceCheckAll : unit -> unit
Remarks
This method is used internally, but may be of some use.


FoundSpellingError Event

FoundSpellingError Event
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► FoundSpellingError
Keyoti RapidSpell WPF
Fired when a spelling error is found.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event FoundSpellingErrorEventHandler FoundSpellingError
public event FoundSpellingErrorEventHandler FoundSpellingError
Public Event FoundSpellingError As FoundSpellingErrorEventHandler
Public Event FoundSpellingError As FoundSpellingErrorEventHandler
public:
 event FoundSpellingErrorEventHandler^ FoundSpellingError {
    void add (FoundSpellingErrorEventHandler^ value);
    void remove (FoundSpellingErrorEventHandler^ value);
}
public:
 event FoundSpellingErrorEventHandler^ FoundSpellingError {
    void add (FoundSpellingErrorEventHandler^ value);
    void remove (FoundSpellingErrorEventHandler^ value);
}
member FoundSpellingError : IEvent<FoundSpellingErrorEventHandler,
    FoundSpellingErrorEventArgs>

member FoundSpellingError : IEvent<FoundSpellingErrorEventHandler,
    FoundSpellingErrorEventArgs>
Value
FoundSpellingErrorEventHandler


GetSuggestions Method

GetSuggestions Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► GetSuggestions()()()()
Keyoti RapidSpell WPF
Returns suggestions menu items for the last right clicked word. Null/Nothing if none.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual Object[] GetSuggestions()
public virtual Object[] GetSuggestions()
Public Overridable Function GetSuggestions As Object()
Public Overridable Function GetSuggestions As Object()
public:
virtual array<Object^>^ GetSuggestions()
public:
virtual array<Object^>^ GetSuggestions()
abstract GetSuggestions : unit -> Object[]
override GetSuggestions : unit -> Object[]
abstract GetSuggestions : unit -> Object[]
override GetSuggestions : unit -> Object[]
Return Value
array<Object>[]()[][]
Remarks

See demo projects for an example.

An example usage; retreives suggestions menu items and uses them in a 3rd Party menu control.
Copy image Copy
MenuItem[] suggs;

TD.SandBar.ToolbarItemBase[] sandBarSuggs;

private void contextMenuBarItem1_BeforePopup(object sender, TD.SandBar.MenuPopupEventArgs e)
{

    this.contextMenuBarItem1.Items.Clear();
    suggs = this.rapidSpellAsYouType1.GetSuggestions();
    if(suggs!=null)//then we have suggestions
    {
        sandBarSuggs = new TD.SandBar.ToolbarItemBase[suggs.Length];
        for(int i=0; i<suggs.Length;i++)
            sandBarSuggs[i] = new TD.SandBar.MenuButtonItem(suggs[i].Text, new EventHandler(this.OnCMClick));

        this.contextMenuBarItem1.Items.AddRange(sandBarSuggs);
    }
}

void OnCMClick(object sender, EventArgs e){
    //rapidspellasyoutype.OnPopUpClick expects the sender to be a MenuItem, so need to call
    //method with original item it produced
    for(int i=0;i<sandBarSuggs.Length; i++)    {

        if(sender == sandBarSuggs[i])
        {
            this.rapidSpellAsYouType1.OnPopUpClick(suggs[i], e);
        }
    }
}


GetTextComponents Method

GetTextComponents Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► GetTextComponents()()()()
Keyoti RapidSpell WPF
Gets a list of text components that are being spell checked.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual List<Object> GetTextComponents()
public virtual List<Object> GetTextComponents()
Public Overridable Function GetTextComponents As List(Of Object)
Public Overridable Function GetTextComponents As List(Of Object)
public:
virtual List<Object^>^ GetTextComponents()
public:
virtual List<Object^>^ GetTextComponents()
abstract GetTextComponents : unit -> List<Object>
override GetTextComponents : unit -> List<Object>
abstract GetTextComponents : unit -> List<Object>
override GetTextComponents : unit -> List<Object>
Return Value
List<(Of <(<'Object>)>)>


GUILanguage Property

GUILanguage Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► GUILanguage
Keyoti RapidSpell WPF
The language to show the UI in.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public LanguageType GUILanguage { get; set; }
public LanguageType GUILanguage { get; set; }
Public Property GUILanguage As LanguageType
    Get
    Set
Public Property GUILanguage As LanguageType
    Get
    Set
public:
property LanguageType GUILanguage {
    LanguageType get ();
    void set (LanguageType value);
}
public:
property LanguageType GUILanguage {
    LanguageType get ();
    void set (LanguageType value);
}
member GUILanguage : LanguageType with get, set

member GUILanguage : LanguageType with get, set
Property Value
LanguageType


IgnoreAllMenuText Property

IgnoreAllMenuText Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► IgnoreAllMenuText
Keyoti RapidSpell WPF
Ignore All button text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string IgnoreAllMenuText { get; set; }
public string IgnoreAllMenuText { get; set; }
Public Property IgnoreAllMenuText As String
    Get
    Set
Public Property IgnoreAllMenuText As String
    Get
    Set
public:
property String^ IgnoreAllMenuText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ IgnoreAllMenuText {
    String^ get ();
    void set (String^ value);
}
member IgnoreAllMenuText : string with get, set

member IgnoreAllMenuText : string with get, set
Property Value
String


IgnoreCapitalizedWords Property

IgnoreCapitalizedWords Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► IgnoreCapitalizedWords
Keyoti RapidSpell WPF
Whether to ignore words with capital letters.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreCapitalizedWords { get; set; }
public bool IgnoreCapitalizedWords { get; set; }
Public Property IgnoreCapitalizedWords As Boolean
    Get
    Set
Public Property IgnoreCapitalizedWords As Boolean
    Get
    Set
public:
property bool IgnoreCapitalizedWords {
    bool get ();
    void set (bool value);
}
public:
property bool IgnoreCapitalizedWords {
    bool get ();
    void set (bool value);
}
member IgnoreCapitalizedWords : bool with get, set

member IgnoreCapitalizedWords : bool with get, set
Property Value
Boolean


IgnoreIncorrectSentenceCapitalization Property

IgnoreIncorrectSentenceCapitalization Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► IgnoreIncorrectSentenceCapitalization
Keyoti RapidSpell WPF
Whether to ignore incorrect sentence capitalization.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreIncorrectSentenceCapitalization { get; set; }
public bool IgnoreIncorrectSentenceCapitalization { get; set; }
Public Property IgnoreIncorrectSentenceCapitalization As Boolean
    Get
    Set
Public Property IgnoreIncorrectSentenceCapitalization As Boolean
    Get
    Set
public:
property bool IgnoreIncorrectSentenceCapitalization {
    bool get ();
    void set (bool value);
}
public:
property bool IgnoreIncorrectSentenceCapitalization {
    bool get ();
    void set (bool value);
}
member IgnoreIncorrectSentenceCapitalization : bool with get, set

member IgnoreIncorrectSentenceCapitalization : bool with get, set
Property Value
Boolean


IgnoreInEnglishLowerCaseI Property

IgnoreInEnglishLowerCaseI Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► IgnoreInEnglishLowerCaseI
Keyoti RapidSpell WPF
Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreInEnglishLowerCaseI { get; set; }
public bool IgnoreInEnglishLowerCaseI { get; set; }
Public Property IgnoreInEnglishLowerCaseI As Boolean
    Get
    Set
Public Property IgnoreInEnglishLowerCaseI As Boolean
    Get
    Set
public:
property bool IgnoreInEnglishLowerCaseI {
    bool get ();
    void set (bool value);
}
public:
property bool IgnoreInEnglishLowerCaseI {
    bool get ();
    void set (bool value);
}
member IgnoreInEnglishLowerCaseI : bool with get, set

member IgnoreInEnglishLowerCaseI : bool with get, set
Property Value
Boolean


IgnoreMenuText Property

IgnoreMenuText Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► IgnoreMenuText
Keyoti RapidSpell WPF
Ignore button text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string IgnoreMenuText { get; set; }
public string IgnoreMenuText { get; set; }
Public Property IgnoreMenuText As String
    Get
    Set
Public Property IgnoreMenuText As String
    Get
    Set
public:
property String^ IgnoreMenuText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ IgnoreMenuText {
    String^ get ();
    void set (String^ value);
}
member IgnoreMenuText : string with get, set

member IgnoreMenuText : string with get, set
Property Value
String


IgnoreOnce Method (badWord, textBox)

IgnoreOnce Method (badWord, textBox)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► IgnoreOnce(BadWord, IAYTTextBox)
Keyoti RapidSpell WPF
Ignores an instance of a bad word in the the textbox.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void IgnoreOnce(
    BadWord badWord,
    IAYTTextBox textBox
)
public virtual void IgnoreOnce(
    BadWord badWord,
    IAYTTextBox textBox
)
Public Overridable Sub IgnoreOnce (
    badWord As BadWord,
    textBox As IAYTTextBox
)
Public Overridable Sub IgnoreOnce (
    badWord As BadWord,
    textBox As IAYTTextBox
)
public:
virtual void IgnoreOnce(
    BadWord^ badWord,
    IAYTTextBox^ textBox
)
public:
virtual void IgnoreOnce(
    BadWord^ badWord,
    IAYTTextBox^ textBox
)
abstract IgnoreOnce :
        badWord : BadWord *
        textBox : IAYTTextBox -> unit
override IgnoreOnce :
        badWord : BadWord *
        textBox : IAYTTextBox -> unit
abstract IgnoreOnce :
        badWord : BadWord *
        textBox : IAYTTextBox -> unit
override IgnoreOnce :
        badWord : BadWord *
        textBox : IAYTTextBox -> unit
Parameters
badWord (BadWord)
textBox (IAYTTextBox)


IgnoreURLsAndEmailAddresses Property

IgnoreURLsAndEmailAddresses Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► IgnoreURLsAndEmailAddresses
Keyoti RapidSpell WPF
Whether to ignore URLs and email addresses (requires V2Parser=true)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreURLsAndEmailAddresses { get; set; }
public bool IgnoreURLsAndEmailAddresses { get; set; }
Public Property IgnoreURLsAndEmailAddresses As Boolean
    Get
    Set
Public Property IgnoreURLsAndEmailAddresses As Boolean
    Get
    Set
public:
property bool IgnoreURLsAndEmailAddresses {
    bool get ();
    void set (bool value);
}
public:
property bool IgnoreURLsAndEmailAddresses {
    bool get ();
    void set (bool value);
}
member IgnoreURLsAndEmailAddresses : bool with get, set

member IgnoreURLsAndEmailAddresses : bool with get, set
Property Value
Boolean
Remarks
This will cause the following strings to be accepted as non-spelling errors;
"user@domain.com", "http://www.domain.com", "domain.co.uk" etc.


IgnoreWordsWithDigits Property

IgnoreWordsWithDigits Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► IgnoreWordsWithDigits
Keyoti RapidSpell WPF
Whether to ignore words with numbers in them (eg. A10 or 7-11).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreWordsWithDigits { get; set; }
public bool IgnoreWordsWithDigits { get; set; }
Public Property IgnoreWordsWithDigits As Boolean
    Get
    Set
Public Property IgnoreWordsWithDigits As Boolean
    Get
    Set
public:
property bool IgnoreWordsWithDigits {
    bool get ();
    void set (bool value);
}
public:
property bool IgnoreWordsWithDigits {
    bool get ();
    void set (bool value);
}
member IgnoreWordsWithDigits : bool with get, set

member IgnoreWordsWithDigits : bool with get, set
Property Value
Boolean


IgnoreXML Property

IgnoreXML Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► IgnoreXML
Keyoti RapidSpell WPF
Whether to ignore XML/HTML tags, false by default.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreXML { get; set; }
public bool IgnoreXML { get; set; }
Public Property IgnoreXML As Boolean
    Get
    Set
Public Property IgnoreXML As Boolean
    Get
    Set
public:
property bool IgnoreXML {
    bool get ();
    void set (bool value);
}
public:
property bool IgnoreXML {
    bool get ();
    void set (bool value);
}
member IgnoreXML : bool with get, set

member IgnoreXML : bool with get, set
Property Value
Boolean
Remarks
This identifies XML tags as anything in between < and > characters, there for it will cause undesirable effects in text such as "the sign for less than is < and the sign for greater than is >". Of course in HTML that should have been written as "the sign for less than is &lt; and the sign for greater than is &gt;" anyway, which would be fine.


IncludeUserDictionaryInSuggestions Property

IncludeUserDictionaryInSuggestions Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► IncludeUserDictionaryInSuggestions
Keyoti RapidSpell WPF
Whether the user dictionary should be used in finding suggestions for misspelt words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IncludeUserDictionaryInSuggestions { get; set; }
public bool IncludeUserDictionaryInSuggestions { get; set; }
Public Property IncludeUserDictionaryInSuggestions As Boolean
    Get
    Set
Public Property IncludeUserDictionaryInSuggestions As Boolean
    Get
    Set
public:
property bool IncludeUserDictionaryInSuggestions {
    bool get ();
    void set (bool value);
}
public:
property bool IncludeUserDictionaryInSuggestions {
    bool get ();
    void set (bool value);
}
member IncludeUserDictionaryInSuggestions : bool with get, set

member IncludeUserDictionaryInSuggestions : bool with get, set
Property Value
Boolean


LanguageParser Property

LanguageParser Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► LanguageParser
Keyoti RapidSpell WPF
The type of language parsing to use.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public LanguageType LanguageParser { get; set; }
public LanguageType LanguageParser { get; set; }
Public Property LanguageParser As LanguageType
    Get
    Set
Public Property LanguageParser As LanguageType
    Get
    Set
public:
property LanguageType LanguageParser {
    LanguageType get ();
    void set (LanguageType value);
}
public:
property LanguageType LanguageParser {
    LanguageType get ();
    void set (LanguageType value);
}
member LanguageParser : LanguageType with get, set

member LanguageParser : LanguageType with get, set
Property Value
LanguageType
Remarks
Eg. If the dictionary is set to French, you should use the French parser.


LookIntoHyphenatedText Property

LookIntoHyphenatedText Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► LookIntoHyphenatedText
Keyoti RapidSpell WPF
Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool LookIntoHyphenatedText { get; set; }
public bool LookIntoHyphenatedText { get; set; }
Public Property LookIntoHyphenatedText As Boolean
    Get
    Set
Public Property LookIntoHyphenatedText As Boolean
    Get
    Set
public:
property bool LookIntoHyphenatedText {
    bool get ();
    void set (bool value);
}
public:
property bool LookIntoHyphenatedText {
    bool get ();
    void set (bool value);
}
member LookIntoHyphenatedText : bool with get, set

member LookIntoHyphenatedText : bool with get, set
Property Value
Boolean
Remarks
Eg. "socio-economic" will be checked as "socio" and "economic".


MaximumNumberOfErrorsToHighlight Property

MaximumNumberOfErrorsToHighlight Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► MaximumNumberOfErrorsToHighlight
Keyoti RapidSpell WPF
The maximum number of errors that will be highlighted, setting this can prevent the UI slowing down if too many errors are present.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int MaximumNumberOfErrorsToHighlight { get; set; }
public int MaximumNumberOfErrorsToHighlight { get; set; }
Public Property MaximumNumberOfErrorsToHighlight As Integer
    Get
    Set
Public Property MaximumNumberOfErrorsToHighlight As Integer
    Get
    Set
public:
property int MaximumNumberOfErrorsToHighlight {
    int get ();
    void set (int value);
}
public:
property int MaximumNumberOfErrorsToHighlight {
    int get ();
    void set (int value);
}
member MaximumNumberOfErrorsToHighlight : int with get, set

member MaximumNumberOfErrorsToHighlight : int with get, set
Property Value
Int32


NumberOfSpellingErrorsInCurrentTextBox Property

NumberOfSpellingErrorsInCurrentTextBox Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► NumberOfSpellingErrorsInCurrentTextBox
Keyoti RapidSpell WPF
Gets the number of spelling errors in the current textbox, or -1 if there is no current textbox.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int NumberOfSpellingErrorsInCurrentTextBox { get; }
public int NumberOfSpellingErrorsInCurrentTextBox { get; }
Public ReadOnly Property NumberOfSpellingErrorsInCurrentTextBox As Integer
    Get
Public ReadOnly Property NumberOfSpellingErrorsInCurrentTextBox As Integer
    Get
public:
property int NumberOfSpellingErrorsInCurrentTextBox {
    int get ();
}
public:
property int NumberOfSpellingErrorsInCurrentTextBox {
    int get ();
}
member NumberOfSpellingErrorsInCurrentTextBox : int with get

member NumberOfSpellingErrorsInCurrentTextBox : int with get
Property Value
Int32


OnDisposed Method (s, e)

OnDisposed Method (s, e)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► OnDisposed(Object, EventArgs)
Keyoti RapidSpell WPF
Called when the control is disposed of.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void OnDisposed(
    Object s,
    EventArgs e
)
public void OnDisposed(
    Object s,
    EventArgs e
)
Public Sub OnDisposed (
    s As Object,
    e As EventArgs
)
Public Sub OnDisposed (
    s As Object,
    e As EventArgs
)
public:
void OnDisposed(
    Object^ s,
    EventArgs^ e
)
public:
void OnDisposed(
    Object^ s,
    EventArgs^ e
)
member OnDisposed :
        s : Object *
        e : EventArgs -> unit

member OnDisposed :
        s : Object *
        e : EventArgs -> unit
Parameters
s (Object)
e (EventArgs)


OnFoundSpellingError Method (e, useAutoCorrectionMap)

OnFoundSpellingError Method (e, useAutoCorrectionMap)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► OnFoundSpellingError(FoundSpellingErrorEventArgs, Boolean)
Keyoti RapidSpell WPF
Raises the FoundSpellingError event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected internal void OnFoundSpellingError(
    FoundSpellingErrorEventArgs e,
    bool useAutoCorrectionMap
)
protected internal void OnFoundSpellingError(
    FoundSpellingErrorEventArgs e,
    bool useAutoCorrectionMap
)
Protected Friend Sub OnFoundSpellingError (
    e As FoundSpellingErrorEventArgs,
    useAutoCorrectionMap As Boolean
)
Protected Friend Sub OnFoundSpellingError (
    e As FoundSpellingErrorEventArgs,
    useAutoCorrectionMap As Boolean
)
protected public:
void OnFoundSpellingError(
    FoundSpellingErrorEventArgs^ e,
    bool useAutoCorrectionMap
)
protected public:
void OnFoundSpellingError(
    FoundSpellingErrorEventArgs^ e,
    bool useAutoCorrectionMap
)
member OnFoundSpellingError :
        e : FoundSpellingErrorEventArgs *
        useAutoCorrectionMap : bool -> unit

member OnFoundSpellingError :
        e : FoundSpellingErrorEventArgs *
        useAutoCorrectionMap : bool -> unit
Parameters
e (FoundSpellingErrorEventArgs)
Event arguments
useAutoCorrectionMap (Boolean)
Whether to use the auto correct mappings


OnSpellContextMenuRequest Method (e)

OnSpellContextMenuRequest Method (e)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► OnSpellContextMenuRequest(SpellContextMenuEventArgs)
Keyoti RapidSpell WPF
Fires event when a context menu is requested
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected internal void OnSpellContextMenuRequest(
    SpellContextMenuEventArgs e
)
protected internal void OnSpellContextMenuRequest(
    SpellContextMenuEventArgs e
)
Protected Friend Sub OnSpellContextMenuRequest (
    e As SpellContextMenuEventArgs
)
Protected Friend Sub OnSpellContextMenuRequest (
    e As SpellContextMenuEventArgs
)
protected public:
void OnSpellContextMenuRequest(
    SpellContextMenuEventArgs^ e
)
protected public:
void OnSpellContextMenuRequest(
    SpellContextMenuEventArgs^ e
)
member OnSpellContextMenuRequest :
        e : SpellContextMenuEventArgs -> unit

member OnSpellContextMenuRequest :
        e : SpellContextMenuEventArgs -> unit
Parameters
e (SpellContextMenuEventArgs)


OnWordAdded Method (e)

OnWordAdded Method (e)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► OnWordAdded(WordAddedEventArgs)
Keyoti RapidSpell WPF
Fires event when a word is added to the user dictionary
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected internal void OnWordAdded(
    WordAddedEventArgs e
)
protected internal void OnWordAdded(
    WordAddedEventArgs e
)
Protected Friend Sub OnWordAdded (
    e As WordAddedEventArgs
)
Protected Friend Sub OnWordAdded (
    e As WordAddedEventArgs
)
protected public:
void OnWordAdded(
    WordAddedEventArgs^ e
)
protected public:
void OnWordAdded(
    WordAddedEventArgs^ e
)
member OnWordAdded :
        e : WordAddedEventArgs -> unit

member OnWordAdded :
        e : WordAddedEventArgs -> unit
Parameters
e (WordAddedEventArgs)


OnWordChanged Method (e)

OnWordChanged Method (e)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► OnWordChanged(WordChangedEventArgs)
Keyoti RapidSpell WPF
Fires event when a word is changed
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected internal void OnWordChanged(
    WordChangedEventArgs e
)
protected internal void OnWordChanged(
    WordChangedEventArgs e
)
Protected Friend Sub OnWordChanged (
    e As WordChangedEventArgs
)
Protected Friend Sub OnWordChanged (
    e As WordChangedEventArgs
)
protected public:
void OnWordChanged(
    WordChangedEventArgs^ e
)
protected public:
void OnWordChanged(
    WordChangedEventArgs^ e
)
member OnWordChanged :
        e : WordChangedEventArgs -> unit

member OnWordChanged :
        e : WordChangedEventArgs -> unit
Parameters
e (WordChangedEventArgs)


OnWordIgnored Method (e)

OnWordIgnored Method (e)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► OnWordIgnored(WordIgnoredEventArgs)
Keyoti RapidSpell WPF
Fires event when a word is ignored
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected internal void OnWordIgnored(
    WordIgnoredEventArgs e
)
protected internal void OnWordIgnored(
    WordIgnoredEventArgs e
)
Protected Friend Sub OnWordIgnored (
    e As WordIgnoredEventArgs
)
Protected Friend Sub OnWordIgnored (
    e As WordIgnoredEventArgs
)
protected public:
void OnWordIgnored(
    WordIgnoredEventArgs^ e
)
protected public:
void OnWordIgnored(
    WordIgnoredEventArgs^ e
)
member OnWordIgnored :
        e : WordIgnoredEventArgs -> unit

member OnWordIgnored :
        e : WordIgnoredEventArgs -> unit
Parameters
e (WordIgnoredEventArgs)


OnWordsEntered Method (e)

OnWordsEntered Method (e)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► OnWordsEntered(WordsEnteredEventArgs)
Keyoti RapidSpell WPF
Fires event when a word is entered into the textbox
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected internal void OnWordsEntered(
    WordsEnteredEventArgs e
)
protected internal void OnWordsEntered(
    WordsEnteredEventArgs e
)
Protected Friend Sub OnWordsEntered (
    e As WordsEnteredEventArgs
)
Protected Friend Sub OnWordsEntered (
    e As WordsEnteredEventArgs
)
protected public:
void OnWordsEntered(
    WordsEnteredEventArgs^ e
)
protected public:
void OnWordsEntered(
    WordsEnteredEventArgs^ e
)
member OnWordsEntered :
        e : WordsEnteredEventArgs -> unit

member OnWordsEntered :
        e : WordsEnteredEventArgs -> unit
Parameters
e (WordsEnteredEventArgs)


Options Property

Options Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► Options
Keyoti RapidSpell WPF
Object responsible for holding, loading and saving the user's spell check options.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual UserOptions Options { get; set; }
public virtual UserOptions Options { get; set; }
Public Overridable Property Options As UserOptions
    Get
    Set
Public Overridable Property Options As UserOptions
    Get
    Set
public:
virtual property UserOptions^ Options {
    UserOptions^ get ();
    void set (UserOptions^ value);
}
public:
virtual property UserOptions^ Options {
    UserOptions^ get ();
    void set (UserOptions^ value);
}
abstract Options : UserOptions with get, set
override Options : UserOptions with get, set
abstract Options : UserOptions with get, set
override Options : UserOptions with get, set
Property Value
UserOptions
Remarks
To customize how the user's options are saved/loaded, subclass UserOptions and set an instance in this property.


OptionsEnabled Property

OptionsEnabled Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► OptionsEnabled
Keyoti RapidSpell WPF
Whether to use user options.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool OptionsEnabled { get; set; }
public virtual bool OptionsEnabled { get; set; }
Public Overridable Property OptionsEnabled As Boolean
    Get
    Set
Public Overridable Property OptionsEnabled As Boolean
    Get
    Set
public:
virtual property bool OptionsEnabled {
    bool get ();
    void set (bool value);
}
public:
virtual property bool OptionsEnabled {
    bool get ();
    void set (bool value);
}
abstract OptionsEnabled : bool with get, set
override OptionsEnabled : bool with get, set
abstract OptionsEnabled : bool with get, set
override OptionsEnabled : bool with get, set
Property Value
Boolean


OptionsFileName Property

OptionsFileName Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► OptionsFileName
Keyoti RapidSpell WPF
The file name used to store the settings (by default in IsolatedStorage).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsFileName { get; set; }
public string OptionsFileName { get; set; }
Public Property OptionsFileName As String
    Get
    Set
Public Property OptionsFileName As String
    Get
    Set
public:
property String^ OptionsFileName {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OptionsFileName {
    String^ get ();
    void set (String^ value);
}
member OptionsFileName : string with get, set

member OptionsFileName : string with get, set
Property Value
String
Remarks
Changing this can ensure different applications have unique user settings.


OptionsPresenter Property

OptionsPresenter Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► OptionsPresenter
Keyoti RapidSpell WPF
Presenter for the user options form (IDialogViewOptions).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual OptionsPresenter OptionsPresenter { get; set; }
public virtual OptionsPresenter OptionsPresenter { get; set; }
Public Overridable Property OptionsPresenter As OptionsPresenter
    Get
    Set
Public Overridable Property OptionsPresenter As OptionsPresenter
    Get
    Set
public:
virtual property OptionsPresenter^ OptionsPresenter {
    OptionsPresenter^ get ();
    void set (OptionsPresenter^ value);
}
public:
virtual property OptionsPresenter^ OptionsPresenter {
    OptionsPresenter^ get ();
    void set (OptionsPresenter^ value);
}
abstract OptionsPresenter : OptionsPresenter with get, set
override OptionsPresenter : OptionsPresenter with get, set
abstract OptionsPresenter : OptionsPresenter with get, set
override OptionsPresenter : OptionsPresenter with get, set
Property Value
OptionsPresenter
Remarks
Set properties in this instance to affect the options shown to the user, or handle CreateDialogViewOptions to create your own IDialogViewOptions form instance.


OptionsStorageLocation Property

OptionsStorageLocation Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► OptionsStorageLocation
Keyoti RapidSpell WPF
Where the user's options are stored.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UserOptions..::..StorageType OptionsStorageLocation { get; set; }
public UserOptions..::..StorageType OptionsStorageLocation { get; set; }
Public Property OptionsStorageLocation As UserOptions..::..StorageType
    Get
    Set
Public Property OptionsStorageLocation As UserOptions..::..StorageType
    Get
    Set
public:
property UserOptions..::..StorageType OptionsStorageLocation {
    UserOptions..::..StorageType get ();
    void set (UserOptions..::..StorageType value);
}
public:
property UserOptions..::..StorageType OptionsStorageLocation {
    UserOptions..::..StorageType get ();
    void set (UserOptions..::..StorageType value);
}
member OptionsStorageLocation : UserOptions..::..StorageType with get, set

member OptionsStorageLocation : UserOptions..::..StorageType with get, set
Property Value
UserOptions..::..StorageType


RapidSpellChecker Property

RapidSpellChecker Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► RapidSpellChecker
Keyoti RapidSpell WPF
The core spell checker object
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public RapidSpellChecker RapidSpellChecker { get; set; }
public RapidSpellChecker RapidSpellChecker { get; set; }
Public Property RapidSpellChecker As RapidSpellChecker
    Get
    Set
Public Property RapidSpellChecker As RapidSpellChecker
    Get
    Set
public:
property RapidSpellChecker^ RapidSpellChecker {
    RapidSpellChecker^ get ();
    void set (RapidSpellChecker^ value);
}
public:
property RapidSpellChecker^ RapidSpellChecker {
    RapidSpellChecker^ get ();
    void set (RapidSpellChecker^ value);
}
member RapidSpellChecker : RapidSpellChecker with get, set

member RapidSpellChecker : RapidSpellChecker with get, set
Property Value
RapidSpellChecker


RecheckTextOnPropertyChange Property

RecheckTextOnPropertyChange Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► RecheckTextOnPropertyChange
Keyoti RapidSpell WPF
Whether to recheck the text when properties that affect the spell check change.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool RecheckTextOnPropertyChange { get; set; }
public bool RecheckTextOnPropertyChange { get; set; }
Public Property RecheckTextOnPropertyChange As Boolean
    Get
    Set
Public Property RecheckTextOnPropertyChange As Boolean
    Get
    Set
public:
property bool RecheckTextOnPropertyChange {
    bool get ();
    void set (bool value);
}
public:
property bool RecheckTextOnPropertyChange {
    bool get ();
    void set (bool value);
}
member RecheckTextOnPropertyChange : bool with get, set

member RecheckTextOnPropertyChange : bool with get, set
Property Value
Boolean
Remarks
Setting this to false before setting several properties prevents redundant rechecking of text.


RemoveAllTextComponents Method

RemoveAllTextComponents Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► RemoveAllTextComponents()()()()
Keyoti RapidSpell WPF
Removes all text components to be checked from the collection.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void RemoveAllTextComponents()
public virtual void RemoveAllTextComponents()
Public Overridable Sub RemoveAllTextComponents
Public Overridable Sub RemoveAllTextComponents
public:
virtual void RemoveAllTextComponents()
public:
virtual void RemoveAllTextComponents()
abstract RemoveAllTextComponents : unit -> unit
override RemoveAllTextComponents : unit -> unit
abstract RemoveAllTextComponents : unit -> unit
override RemoveAllTextComponents : unit -> unit


RemoveDuplicateWordText Property

RemoveDuplicateWordText Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► RemoveDuplicateWordText
Keyoti RapidSpell WPF
Remove duplicate word text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string RemoveDuplicateWordText { get; set; }
public string RemoveDuplicateWordText { get; set; }
Public Property RemoveDuplicateWordText As String
    Get
    Set
Public Property RemoveDuplicateWordText As String
    Get
    Set
public:
property String^ RemoveDuplicateWordText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ RemoveDuplicateWordText {
    String^ get ();
    void set (String^ value);
}
member RemoveDuplicateWordText : string with get, set

member RemoveDuplicateWordText : string with get, set
Property Value
String


RemoveTextComponent Method

RemoveTextComponent Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► RemoveTextComponent()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | RemoveTextComponent(IAYTTextBox) | Remove a text component to be checked from the collection.
 | RemoveTextComponent(TextBox) | Remove a text component to be checked from the collection.
 | RemoveTextComponent(RichTextBox) | Remove a text component to be checked from the collection.


RemoveTextComponent Method (textComponent)

RemoveTextComponent Method (textComponent)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► RemoveTextComponent(IAYTTextBox)
Keyoti RapidSpell WPF
Remove a text component to be checked from the collection.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void RemoveTextComponent(
    IAYTTextBox textComponent
)
public virtual void RemoveTextComponent(
    IAYTTextBox textComponent
)
Public Overridable Sub RemoveTextComponent (
    textComponent As IAYTTextBox
)
Public Overridable Sub RemoveTextComponent (
    textComponent As IAYTTextBox
)
public:
virtual void RemoveTextComponent(
    IAYTTextBox^ textComponent
)
public:
virtual void RemoveTextComponent(
    IAYTTextBox^ textComponent
)
abstract RemoveTextComponent :
        textComponent : IAYTTextBox -> unit
override RemoveTextComponent :
        textComponent : IAYTTextBox -> unit
abstract RemoveTextComponent :
        textComponent : IAYTTextBox -> unit
override RemoveTextComponent :
        textComponent : IAYTTextBox -> unit
Parameters
textComponent (IAYTTextBox)
The text box to no longer be spell checked
Remarks
If textboxes are to be dynamically added/removed from the collection of textboxes to check, call this and AddTextComponent


RemoveTextComponent Method (textComponent)

RemoveTextComponent Method (textComponent)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► RemoveTextComponent(RichTextBox)
Keyoti RapidSpell WPF
Remove a text component to be checked from the collection.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void RemoveTextComponent(
    RichTextBox textComponent
)
public virtual void RemoveTextComponent(
    RichTextBox textComponent
)
Public Overridable Sub RemoveTextComponent (
    textComponent As RichTextBox
)
Public Overridable Sub RemoveTextComponent (
    textComponent As RichTextBox
)
public:
virtual void RemoveTextComponent(
    RichTextBox^ textComponent
)
public:
virtual void RemoveTextComponent(
    RichTextBox^ textComponent
)
abstract RemoveTextComponent :
        textComponent : RichTextBox -> unit
override RemoveTextComponent :
        textComponent : RichTextBox -> unit
abstract RemoveTextComponent :
        textComponent : RichTextBox -> unit
override RemoveTextComponent :
        textComponent : RichTextBox -> unit
Parameters
textComponent (RichTextBox)
The text box to no longer be spell checked
Remarks
If textboxes are to be dynamically added/removed from the collection of textboxes to check, call this and AddTextComponent


RemoveTextComponent Method (textComponent)

RemoveTextComponent Method (textComponent)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► RemoveTextComponent(TextBox)
Keyoti RapidSpell WPF
Remove a text component to be checked from the collection.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void RemoveTextComponent(
    TextBox textComponent
)
public virtual void RemoveTextComponent(
    TextBox textComponent
)
Public Overridable Sub RemoveTextComponent (
    textComponent As TextBox
)
Public Overridable Sub RemoveTextComponent (
    textComponent As TextBox
)
public:
virtual void RemoveTextComponent(
    TextBox^ textComponent
)
public:
virtual void RemoveTextComponent(
    TextBox^ textComponent
)
abstract RemoveTextComponent :
        textComponent : TextBox -> unit
override RemoveTextComponent :
        textComponent : TextBox -> unit
abstract RemoveTextComponent :
        textComponent : TextBox -> unit
override RemoveTextComponent :
        textComponent : TextBox -> unit
Parameters
textComponent (TextBox)
The text box to no longer be spell checked
Remarks
If textboxes are to be dynamically added/removed from the collection of textboxes to check, call this and AddTextComponent


RepaintUnderlines Method

RepaintUnderlines Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► RepaintUnderlines()()()()
Keyoti RapidSpell WPF
Repaints the underlines, this should be called if any changes are made to layout, such as changes to font sizes, etc.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void RepaintUnderlines()
public void RepaintUnderlines()
Public Sub RepaintUnderlines
Public Sub RepaintUnderlines
public:
void RepaintUnderlines()
public:
void RepaintUnderlines()
member RepaintUnderlines : unit -> unit

member RepaintUnderlines : unit -> unit


ResetIgnoredWords Method

ResetIgnoredWords Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► ResetIgnoredWords()()()()
Keyoti RapidSpell WPF
Resets all ignored words, so that the document will be rechecked.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void ResetIgnoredWords()
public virtual void ResetIgnoredWords()
Public Overridable Sub ResetIgnoredWords
Public Overridable Sub ResetIgnoredWords
public:
virtual void ResetIgnoredWords()
public:
virtual void ResetIgnoredWords()
abstract ResetIgnoredWords : unit -> unit
override ResetIgnoredWords : unit -> unit
abstract ResetIgnoredWords : unit -> unit
override ResetIgnoredWords : unit -> unit


ShowAddMenuOption Property

ShowAddMenuOption Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► ShowAddMenuOption
Keyoti RapidSpell WPF
Whether to show the Add option in the context menu.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ShowAddMenuOption { get; set; }
public bool ShowAddMenuOption { get; set; }
Public Property ShowAddMenuOption As Boolean
    Get
    Set
Public Property ShowAddMenuOption As Boolean
    Get
    Set
public:
property bool ShowAddMenuOption {
    bool get ();
    void set (bool value);
}
public:
property bool ShowAddMenuOption {
    bool get ();
    void set (bool value);
}
member ShowAddMenuOption : bool with get, set

member ShowAddMenuOption : bool with get, set
Property Value
Boolean


ShowCutCopyPasteMenuOnTextBoxBase Property

ShowCutCopyPasteMenuOnTextBoxBase Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► ShowCutCopyPasteMenuOnTextBoxBase
Keyoti RapidSpell WPF
Whether to show a cut copy paste context menu on TextBoxBase controls being checked.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ShowCutCopyPasteMenuOnTextBoxBase { get; set; }
public bool ShowCutCopyPasteMenuOnTextBoxBase { get; set; }
Public Property ShowCutCopyPasteMenuOnTextBoxBase As Boolean
    Get
    Set
Public Property ShowCutCopyPasteMenuOnTextBoxBase As Boolean
    Get
    Set
public:
property bool ShowCutCopyPasteMenuOnTextBoxBase {
    bool get ();
    void set (bool value);
}
public:
property bool ShowCutCopyPasteMenuOnTextBoxBase {
    bool get ();
    void set (bool value);
}
member ShowCutCopyPasteMenuOnTextBoxBase : bool with get, set

member ShowCutCopyPasteMenuOnTextBoxBase : bool with get, set
Property Value
Boolean


ShowSuggestionsContextMenu Property

ShowSuggestionsContextMenu Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► ShowSuggestionsContextMenu
Keyoti RapidSpell WPF
Whether to show a context menu with suggestions when a misspelt word is right clicked, has no effect on developer set context menu.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ShowSuggestionsContextMenu { get; set; }
public bool ShowSuggestionsContextMenu { get; set; }
Public Property ShowSuggestionsContextMenu As Boolean
    Get
    Set
Public Property ShowSuggestionsContextMenu As Boolean
    Get
    Set
public:
property bool ShowSuggestionsContextMenu {
    bool get ();
    void set (bool value);
}
public:
property bool ShowSuggestionsContextMenu {
    bool get ();
    void set (bool value);
}
member ShowSuggestionsContextMenu : bool with get, set

member ShowSuggestionsContextMenu : bool with get, set
Property Value
Boolean
Remarks
When this property is false a context menu with suggestions is NOT shown (any existing developer set context menu is shown). When this property is true a context menu with suggestions is shown when the user's right click is on a misspelt word. A developer set context menu is always shown when a right click is off a misspelt word.


ShowSuggestionsWhenTextIsSelected Property

ShowSuggestionsWhenTextIsSelected Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► ShowSuggestionsWhenTextIsSelected
Keyoti RapidSpell WPF
Whether to show the spelling context menu regardless of whether text is currently selected.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ShowSuggestionsWhenTextIsSelected { get; set; }
public bool ShowSuggestionsWhenTextIsSelected { get; set; }
Public Property ShowSuggestionsWhenTextIsSelected As Boolean
    Get
    Set
Public Property ShowSuggestionsWhenTextIsSelected As Boolean
    Get
    Set
public:
property bool ShowSuggestionsWhenTextIsSelected {
    bool get ();
    void set (bool value);
}
public:
property bool ShowSuggestionsWhenTextIsSelected {
    bool get ();
    void set (bool value);
}
member ShowSuggestionsWhenTextIsSelected : bool with get, set

member ShowSuggestionsWhenTextIsSelected : bool with get, set
Property Value
Boolean


ShowUnderlines Property

ShowUnderlines Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► ShowUnderlines
Keyoti RapidSpell WPF
Whether to show or hide error underlines.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ShowUnderlines { get; set; }
public bool ShowUnderlines { get; set; }
Public Property ShowUnderlines As Boolean
    Get
    Set
Public Property ShowUnderlines As Boolean
    Get
    Set
public:
property bool ShowUnderlines {
    bool get ();
    void set (bool value);
}
public:
property bool ShowUnderlines {
    bool get ();
    void set (bool value);
}
member ShowUnderlines : bool with get, set

member ShowUnderlines : bool with get, set
Property Value
Boolean


SpellCheckFinished Event

SpellCheckFinished Event
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► SpellCheckFinished
Keyoti RapidSpell WPF
Fired when checking finishes
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event SpellCheckEventHandler SpellCheckFinished
public event SpellCheckEventHandler SpellCheckFinished
Public Event SpellCheckFinished As SpellCheckEventHandler
Public Event SpellCheckFinished As SpellCheckEventHandler
public:
 event SpellCheckEventHandler^ SpellCheckFinished {
    void add (SpellCheckEventHandler^ value);
    void remove (SpellCheckEventHandler^ value);
}
public:
 event SpellCheckEventHandler^ SpellCheckFinished {
    void add (SpellCheckEventHandler^ value);
    void remove (SpellCheckEventHandler^ value);
}
member SpellCheckFinished : IEvent<SpellCheckEventHandler,
    SpellCheckEventArgs>

member SpellCheckFinished : IEvent<SpellCheckEventHandler,
    SpellCheckEventArgs>
Value
SpellCheckEventHandler


SpellCheckStarted Event

SpellCheckStarted Event
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► SpellCheckStarted
Keyoti RapidSpell WPF
Fired when checking starts
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event SpellCheckEventHandler SpellCheckStarted
public event SpellCheckEventHandler SpellCheckStarted
Public Event SpellCheckStarted As SpellCheckEventHandler
Public Event SpellCheckStarted As SpellCheckEventHandler
public:
 event SpellCheckEventHandler^ SpellCheckStarted {
    void add (SpellCheckEventHandler^ value);
    void remove (SpellCheckEventHandler^ value);
}
public:
 event SpellCheckEventHandler^ SpellCheckStarted {
    void add (SpellCheckEventHandler^ value);
    void remove (SpellCheckEventHandler^ value);
}
member SpellCheckStarted : IEvent<SpellCheckEventHandler,
    SpellCheckEventArgs>

member SpellCheckStarted : IEvent<SpellCheckEventHandler,
    SpellCheckEventArgs>
Value
SpellCheckEventHandler


SpellContextMenuRequest Event

SpellContextMenuRequest Event
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► SpellContextMenuRequest
Keyoti RapidSpell WPF
Fired when a request is made (usually by a right click on an underlined word) for context menu
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event SpellContextMenuRequestEventHandler SpellContextMenuRequest
public event SpellContextMenuRequestEventHandler SpellContextMenuRequest
Public Event SpellContextMenuRequest As SpellContextMenuRequestEventHandler
Public Event SpellContextMenuRequest As SpellContextMenuRequestEventHandler
public:
 event SpellContextMenuRequestEventHandler^ SpellContextMenuRequest {
    void add (SpellContextMenuRequestEventHandler^ value);
    void remove (SpellContextMenuRequestEventHandler^ value);
}
public:
 event SpellContextMenuRequestEventHandler^ SpellContextMenuRequest {
    void add (SpellContextMenuRequestEventHandler^ value);
    void remove (SpellContextMenuRequestEventHandler^ value);
}
member SpellContextMenuRequest : IEvent<SpellContextMenuRequestEventHandler,
    SpellContextMenuEventArgs>

member SpellContextMenuRequest : IEvent<SpellContextMenuRequestEventHandler,
    SpellContextMenuEventArgs>
Value
SpellContextMenuRequestEventHandler
Remarks
This event is a good way to display the spelling context menu in a developers own context menu. Setting ShowSuggestionsContextMenu to false will deactivate the automatic context menu that appears when a user right clicks on a spelling error. Listeners to this event are notified when a context menu should be shown with spelling suggestions and options, the event args also include a collection of MenuItem objects with spelling suggestions and Ignore All & Add options; These menu item click events are already hooked into RapidSpellAsYouType and will function as expected, without further programming.
Examples
Handling the context menu in a custom fashion.
Copy image Copy
.....
private Keyoti.RapidSpell.AYTRichTextBox aytRichTextBox1;
private Keyoti.RapidSpell.RapidSpellAsYouType rapidSpellAsYouType1;
.....

private void InitializeComponent(){
    .....
    this.rapidSpellAsYouType1.SpellContextMenuRequest +=
        new RapidSpellAsYouType.SpellContextMenuRequestEventHandler(rapidSpellAsYouType1_SpellContextMenuRequest);
    .....
}

private void rapidSpellAsYouType1_SpellContextMenuRequest(object sender, Keyoti.RapidSpell.Event.SpellContextMenuEventArgs e)
{
    //The MenuItem objects in e.MenuItems can be added to any menu as desired.
    this.aytRichTextBox1.ContextMenu.MenuItems.AddRange((MenuItem[])e.MenuItems);
}
....


SuggestionsMethod Property

SuggestionsMethod Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► SuggestionsMethod
Keyoti RapidSpell WPF
The suggestions method to use.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public SuggestionsMethodType SuggestionsMethod { get; set; }
public SuggestionsMethodType SuggestionsMethod { get; set; }
Public Property SuggestionsMethod As SuggestionsMethodType
    Get
    Set
Public Property SuggestionsMethod As SuggestionsMethodType
    Get
    Set
public:
property SuggestionsMethodType SuggestionsMethod {
    SuggestionsMethodType get ();
    void set (SuggestionsMethodType value);
}
public:
property SuggestionsMethodType SuggestionsMethod {
    SuggestionsMethodType get ();
    void set (SuggestionsMethodType value);
}
member SuggestionsMethod : SuggestionsMethodType with get, set

member SuggestionsMethod : SuggestionsMethodType with get, set
Property Value
SuggestionsMethodType


SuggestSplitWords Property

SuggestSplitWords Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► SuggestSplitWords
Keyoti RapidSpell WPF
Whether to look for connected words in suggestions.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool SuggestSplitWords { get; set; }
public bool SuggestSplitWords { get; set; }
Public Property SuggestSplitWords As Boolean
    Get
    Set
Public Property SuggestSplitWords As Boolean
    Get
    Set
public:
property bool SuggestSplitWords {
    bool get ();
    void set (bool value);
}
public:
property bool SuggestSplitWords {
    bool get ();
    void set (bool value);
}
member SuggestSplitWords : bool with get, set

member SuggestSplitWords : bool with get, set
Property Value
Boolean
Remarks
if this=true then suggestions may include joined words.

Eg; suggestions for "myhouse" will include "my house"


TextBoundary Property

TextBoundary Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► TextBoundary
Keyoti RapidSpell WPF
The AdvancedTextBoundary class to use to parse words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public AdvancedTextBoundary TextBoundary { get; set; }
public AdvancedTextBoundary TextBoundary { get; set; }
Public Property TextBoundary As AdvancedTextBoundary
    Get
    Set
Public Property TextBoundary As AdvancedTextBoundary
    Get
    Set
public:
property AdvancedTextBoundary^ TextBoundary {
    AdvancedTextBoundary^ get ();
    void set (AdvancedTextBoundary^ value);
}
public:
property AdvancedTextBoundary^ TextBoundary {
    AdvancedTextBoundary^ get ();
    void set (AdvancedTextBoundary^ value);
}
member TextBoundary : AdvancedTextBoundary with get, set

member TextBoundary : AdvancedTextBoundary with get, set
Property Value
AdvancedTextBoundary
Remarks
Note, you must set this property in RapidSpellChecker with a different instance of the same class.


TextBox Property

TextBox Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► TextBox
Keyoti RapidSpell WPF
The TextBox or RichTextBox to work with
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public TextBoxBase TextBox { get; set; }
public TextBoxBase TextBox { get; set; }
Public Property TextBox As TextBoxBase
    Get
    Set
Public Property TextBox As TextBoxBase
    Get
    Set
public:
property TextBoxBase^ TextBox {
    TextBoxBase^ get ();
    void set (TextBoxBase^ value);
}
public:
property TextBoxBase^ TextBox {
    TextBoxBase^ get ();
    void set (TextBoxBase^ value);
}
member TextBox : TextBoxBase with get, set

member TextBox : TextBoxBase with get, set
Property Value
TextBoxBase


TextBoxProperty Field

TextBoxProperty Field
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► TextBoxProperty
Keyoti RapidSpell WPF
The TextBox or RichTextBox to work with.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static readonly DependencyProperty TextBoxProperty
public static readonly DependencyProperty TextBoxProperty
Public Shared ReadOnly TextBoxProperty As DependencyProperty
Public Shared ReadOnly TextBoxProperty As DependencyProperty
public:
static initonly DependencyProperty^ TextBoxProperty
public:
static initonly DependencyProperty^ TextBoxProperty
static val TextBoxProperty: DependencyProperty
static val TextBoxProperty: DependencyProperty
Field Value
DependencyProperty


TextComponent Property

TextComponent Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► TextComponent
Keyoti RapidSpell WPF
The IAYTTextBox text box to check as the user types/modifies text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public IAYTTextBox TextComponent { get; set; }
public IAYTTextBox TextComponent { get; set; }
Public Property TextComponent As IAYTTextBox
    Get
    Set
Public Property TextComponent As IAYTTextBox
    Get
    Set
public:
property IAYTTextBox^ TextComponent {
    IAYTTextBox^ get ();
    void set (IAYTTextBox^ value);
}
public:
property IAYTTextBox^ TextComponent {
    IAYTTextBox^ get ();
    void set (IAYTTextBox^ value);
}
member TextComponent : IAYTTextBox with get, set

member TextComponent : IAYTTextBox with get, set
Property Value
IAYTTextBox


UnderlineColor Property

UnderlineColor Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► UnderlineColor
Keyoti RapidSpell WPF
The underline color to use with mis-spelt words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Color UnderlineColor { get; set; }
public Color UnderlineColor { get; set; }
Public Property UnderlineColor As Color
    Get
    Set
Public Property UnderlineColor As Color
    Get
    Set
public:
property Color UnderlineColor {
    Color get ();
    void set (Color value);
}
public:
property Color UnderlineColor {
    Color get ();
    void set (Color value);
}
member UnderlineColor : Color with get, set

member UnderlineColor : Color with get, set
Property Value
Color


UnderlineStyle Property

UnderlineStyle Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► UnderlineStyle
Keyoti RapidSpell WPF
The underline style to use with mis-spelt words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UnderlineStyle UnderlineStyle { get; set; }
public UnderlineStyle UnderlineStyle { get; set; }
Public Property UnderlineStyle As UnderlineStyle
    Get
    Set
Public Property UnderlineStyle As UnderlineStyle
    Get
    Set
public:
property UnderlineStyle UnderlineStyle {
    UnderlineStyle get ();
    void set (UnderlineStyle value);
}
public:
property UnderlineStyle UnderlineStyle {
    UnderlineStyle get ();
    void set (UnderlineStyle value);
}
member UnderlineStyle : UnderlineStyle with get, set

member UnderlineStyle : UnderlineStyle with get, set
Property Value
UnderlineStyle


UnignoreWord Method (badWord, textBox)

UnignoreWord Method (badWord, textBox)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► UnignoreWord(BadWord, IAYTTextBox)
Keyoti RapidSpell WPF
Unignores an instance of a bad word in the the textbox.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void UnignoreWord(
    BadWord badWord,
    IAYTTextBox textBox
)
public virtual void UnignoreWord(
    BadWord badWord,
    IAYTTextBox textBox
)
Public Overridable Sub UnignoreWord (
    badWord As BadWord,
    textBox As IAYTTextBox
)
Public Overridable Sub UnignoreWord (
    badWord As BadWord,
    textBox As IAYTTextBox
)
public:
virtual void UnignoreWord(
    BadWord^ badWord,
    IAYTTextBox^ textBox
)
public:
virtual void UnignoreWord(
    BadWord^ badWord,
    IAYTTextBox^ textBox
)
abstract UnignoreWord :
        badWord : BadWord *
        textBox : IAYTTextBox -> unit
override UnignoreWord :
        badWord : BadWord *
        textBox : IAYTTextBox -> unit
abstract UnignoreWord :
        badWord : BadWord *
        textBox : IAYTTextBox -> unit
override UnignoreWord :
        badWord : BadWord *
        textBox : IAYTTextBox -> unit
Parameters
badWord (BadWord)
textBox (IAYTTextBox)


UpdateAllTextBoxes Property

UpdateAllTextBoxes Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► UpdateAllTextBoxes
Keyoti RapidSpell WPF
Whether to update all text boxes when ForceCheckAll is called, usually this should be true.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool UpdateAllTextBoxes { get; set; }
public bool UpdateAllTextBoxes { get; set; }
Public Property UpdateAllTextBoxes As Boolean
    Get
    Set
Public Property UpdateAllTextBoxes As Boolean
    Get
    Set
public:
property bool UpdateAllTextBoxes {
    bool get ();
    void set (bool value);
}
public:
property bool UpdateAllTextBoxes {
    bool get ();
    void set (bool value);
}
member UpdateAllTextBoxes : bool with get, set

member UpdateAllTextBoxes : bool with get, set
Property Value
Boolean


UserDictionaryFile Property

UserDictionaryFile Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► UserDictionaryFile
Keyoti RapidSpell WPF
The user dictionary file, if this file doesn't exist it will be created.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionaryFile { get; set; }
public string UserDictionaryFile { get; set; }
Public Property UserDictionaryFile As String
    Get
    Set
Public Property UserDictionaryFile As String
    Get
    Set
public:
property String^ UserDictionaryFile {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserDictionaryFile {
    String^ get ();
    void set (String^ value);
}
member UserDictionaryFile : string with get, set

member UserDictionaryFile : string with get, set
Property Value
String
Remarks
Use of a user dictionary is optional.


V2Parser Property

V2Parser Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► V2Parser
Keyoti RapidSpell WPF
Whether to use parser version 2 - Set to false for backwards (pre v3.4) compatibility.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool V2Parser { get; set; }
public bool V2Parser { get; set; }
Public Property V2Parser As Boolean
    Get
    Set
Public Property V2Parser As Boolean
    Get
    Set
public:
property bool V2Parser {
    bool get ();
    void set (bool value);
}
public:
property bool V2Parser {
    bool get ();
    void set (bool value);
}
member V2Parser : bool with get, set

member V2Parser : bool with get, set
Property Value
Boolean


WarnDuplicates Property

WarnDuplicates Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► WarnDuplicates
Keyoti RapidSpell WPF
Whether to show duplicate words as errors (eg. "this is is an error").
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool WarnDuplicates { get; set; }
public bool WarnDuplicates { get; set; }
Public Property WarnDuplicates As Boolean
    Get
    Set
Public Property WarnDuplicates As Boolean
    Get
    Set
public:
property bool WarnDuplicates {
    bool get ();
    void set (bool value);
}
public:
property bool WarnDuplicates {
    bool get ();
    void set (bool value);
}
member WarnDuplicates : bool with get, set

member WarnDuplicates : bool with get, set
Property Value
Boolean


WordAdded Event

WordAdded Event
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► WordAdded
Keyoti RapidSpell WPF
Fired when word added to user dictionary
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event WordAddedEventHandler WordAdded
public event WordAddedEventHandler WordAdded
Public Event WordAdded As WordAddedEventHandler
Public Event WordAdded As WordAddedEventHandler
public:
 event WordAddedEventHandler^ WordAdded {
    void add (WordAddedEventHandler^ value);
    void remove (WordAddedEventHandler^ value);
}
public:
 event WordAddedEventHandler^ WordAdded {
    void add (WordAddedEventHandler^ value);
    void remove (WordAddedEventHandler^ value);
}
member WordAdded : IEvent<WordAddedEventHandler,
    WordAddedEventArgs>

member WordAdded : IEvent<WordAddedEventHandler,
    WordAddedEventArgs>
Value
WordAddedEventHandler


WordChanged Event

WordChanged Event
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► WordChanged
Keyoti RapidSpell WPF
Fired when word changed
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event WordChangedEventHandler WordChanged
public event WordChangedEventHandler WordChanged
Public Event WordChanged As WordChangedEventHandler
Public Event WordChanged As WordChangedEventHandler
public:
 event WordChangedEventHandler^ WordChanged {
    void add (WordChangedEventHandler^ value);
    void remove (WordChangedEventHandler^ value);
}
public:
 event WordChangedEventHandler^ WordChanged {
    void add (WordChangedEventHandler^ value);
    void remove (WordChangedEventHandler^ value);
}
member WordChanged : IEvent<WordChangedEventHandler,
    WordChangedEventArgs>

member WordChanged : IEvent<WordChangedEventHandler,
    WordChangedEventArgs>
Value
WordChangedEventHandler


WordIgnored Event

WordIgnored Event
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► WordIgnored
Keyoti RapidSpell WPF
Fired when word ignored
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event WordIgnoredEventHandler WordIgnored
public event WordIgnoredEventHandler WordIgnored
Public Event WordIgnored As WordIgnoredEventHandler
Public Event WordIgnored As WordIgnoredEventHandler
public:
 event WordIgnoredEventHandler^ WordIgnored {
    void add (WordIgnoredEventHandler^ value);
    void remove (WordIgnoredEventHandler^ value);
}
public:
 event WordIgnoredEventHandler^ WordIgnored {
    void add (WordIgnoredEventHandler^ value);
    void remove (WordIgnoredEventHandler^ value);
}
member WordIgnored : IEvent<WordIgnoredEventHandler,
    WordIgnoredEventArgs>

member WordIgnored : IEvent<WordIgnoredEventHandler,
    WordIgnoredEventArgs>
Value
WordIgnoredEventHandler


WordsEntered Event

WordsEntered Event
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► WordsEntered
Keyoti RapidSpell WPF
Fired when words have been entered (typed or pasted).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event WordsEnteredEventHandler WordsEntered
public event WordsEnteredEventHandler WordsEntered
Public Event WordsEntered As WordsEnteredEventHandler
Public Event WordsEntered As WordsEnteredEventHandler
public:
 event WordsEnteredEventHandler^ WordsEntered {
    void add (WordsEnteredEventHandler^ value);
    void remove (WordsEnteredEventHandler^ value);
}
public:
 event WordsEnteredEventHandler^ WordsEntered {
    void add (WordsEnteredEventHandler^ value);
    void remove (WordsEnteredEventHandler^ value);
}
member WordsEntered : IEvent<WordsEnteredEventHandler,
    WordsEnteredEventArgs>

member WordsEntered : IEvent<WordsEnteredEventHandler,
    WordsEnteredEventArgs>
Value
WordsEnteredEventHandler


RapidSpellAYTDialogCoupler Class

RapidSpellAYTDialogCoupler Class
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAYTDialogCoupler
Keyoti RapidSpell WPF
RapidSpell Desktop AYT-Dialog Coupler Control, this lightweight convenience control is used to couple RapidSpellAsYouType and RapidSpellDialog.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class RapidSpellAYTDialogCoupler : DesignableComponent
public class RapidSpellAYTDialogCoupler : DesignableComponent
Public Class RapidSpellAYTDialogCoupler
    Inherits DesignableComponent
Public Class RapidSpellAYTDialogCoupler
    Inherits DesignableComponent
public ref class RapidSpellAYTDialogCoupler : public DesignableComponent
public ref class RapidSpellAYTDialogCoupler : public DesignableComponent
type RapidSpellAYTDialogCoupler =
    class
        inherit DesignableComponent
    end
type RapidSpellAYTDialogCoupler =
    class
        inherit DesignableComponent
    end
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RapidSpellAYTDialogCoupler()()()() | New
 | ActualHeight | (Inherited from FrameworkElement.)
 | ActualWidth | (Inherited from FrameworkElement.)
 | AddHandler(RoutedEvent, Delegate) | (Inherited from UIElement.)
 | AddHandler(RoutedEvent, Delegate, Boolean) | (Inherited from UIElement.)
 | AddLogicalChild(Object) | (Inherited from FrameworkElement.)
 | AddToEventRoute(EventRoute, RoutedEventArgs) | (Inherited from UIElement.)
 | AddVisualChild(Visual) | (Inherited from Visual.)
 | AllowDrop | (Inherited from UIElement.)
 | ApplyAnimationClock(DependencyProperty, AnimationClock) | (Inherited from UIElement.)
 | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | (Inherited from UIElement.)
 | ApplyTemplate()()()() | (Inherited from FrameworkElement.)
 | AreAnyTouchesCaptured | (Inherited from UIElement.)
 | AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
 | AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
 | AreAnyTouchesOver | (Inherited from UIElement.)
 | Arrange(Rect) | (Inherited from UIElement.)
 | ArrangeCore(Rect) | (Inherited from FrameworkElement.)
 | ArrangeOverride(Size) | (Inherited from FrameworkElement.)
 | BeginAnimation(DependencyProperty, AnimationTimeline) | (Inherited from UIElement.)
 | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | (Inherited from UIElement.)
 | BeginInit()()()() | (Inherited from FrameworkElement.)
 | BeginStoryboard(Storyboard) | (Inherited from FrameworkElement.)
 | BeginStoryboard(Storyboard, HandoffBehavior) | (Inherited from FrameworkElement.)
 | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | (Inherited from FrameworkElement.)
 | BindingGroup | (Inherited from FrameworkElement.)
 | BitmapEffect | Obsolete. (Inherited from UIElement.)
 | BitmapEffectInput | Obsolete. (Inherited from UIElement.)
 | BringIntoView()()()() | (Inherited from FrameworkElement.)
 | BringIntoView(Rect) | (Inherited from FrameworkElement.)
 | CacheMode | (Inherited from UIElement.)
 | CaptureMouse()()()() | (Inherited from UIElement.)
 | CaptureStylus()()()() | (Inherited from UIElement.)
 | CaptureTouch(TouchDevice) | (Inherited from UIElement.)
 | CheckAccess()()()() | (Inherited from DispatcherObject.)
 | ClearValue(DependencyProperty) | (Inherited from DependencyObject.)
 | ClearValue(DependencyPropertyKey) | (Inherited from DependencyObject.)
 | Clip | (Inherited from UIElement.)
 | ClipToBounds | (Inherited from UIElement.)
 | CoerceValue(DependencyProperty) | (Inherited from DependencyObject.)
 | CommandBindings | (Inherited from UIElement.)
 | ContextMenu | (Inherited from FrameworkElement.)
 | ContextMenuClosing | (Inherited from FrameworkElement.)
 | ContextMenuOpening | (Inherited from FrameworkElement.)
 | Cursor | (Inherited from FrameworkElement.)
 | DataContext | (Inherited from FrameworkElement.)
 | DataContextChanged | (Inherited from FrameworkElement.)
 | DefaultStyleKey | (Inherited from FrameworkElement.)
 | DependencyObjectType | (Inherited from DependencyObject.)
 | DesignMode | Whether control is in design mode (Inherited from DesignableComponent.)
 | DesiredSize | (Inherited from UIElement.)
 | Dispatcher | (Inherited from DispatcherObject.)
 | Dispose(Boolean) | Frees up resources.
 | DragEnter | (Inherited from UIElement.)
 | DragLeave | (Inherited from UIElement.)
 | DragOver | (Inherited from UIElement.)
 | Drop | (Inherited from UIElement.)
 | Effect | (Inherited from UIElement.)
 | EndInit()()()() | (Inherited from FrameworkElement.)
 | Equals(Object) | (Inherited from DependencyObject.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FindCommonVisualAncestor(DependencyObject) | (Inherited from Visual.)
 | FindName(String) | (Inherited from FrameworkElement.)
 | FindResource(Object) | (Inherited from FrameworkElement.)
 | FlowDirection | (Inherited from FrameworkElement.)
 | Focus()()()() | (Inherited from UIElement.)
 | Focusable | (Inherited from UIElement.)
 | FocusableChanged | (Inherited from UIElement.)
 | FocusVisualStyle | (Inherited from FrameworkElement.)
 | ForceCursor | (Inherited from FrameworkElement.)
 | GetAnimationBaseValue(DependencyProperty) | (Inherited from UIElement.)
 | GetBindingExpression(DependencyProperty) | (Inherited from FrameworkElement.)
 | GetHashCode()()()() | (Inherited from DependencyObject.)
 | GetLayoutClip(Size) | (Inherited from FrameworkElement.)
 | GetLocalValueEnumerator()()()() | (Inherited from DependencyObject.)
 | GetTemplateChild(String) | (Inherited from FrameworkElement.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GetUIParentCore()()()() | (Inherited from FrameworkElement.)
 | GetValue(DependencyProperty) | (Inherited from DependencyObject.)
 | GetVisualChild(Int32) | (Inherited from FrameworkElement.)
 | GiveFeedback | (Inherited from UIElement.)
 | GotFocus | (Inherited from UIElement.)
 | GotKeyboardFocus | (Inherited from UIElement.)
 | GotMouseCapture | (Inherited from UIElement.)
 | GotStylusCapture | (Inherited from UIElement.)
 | GotTouchCapture | (Inherited from UIElement.)
 | HasAnimatedProperties | (Inherited from UIElement.)
 | HasEffectiveKeyboardFocus | (Inherited from UIElement.)
 | Height | (Inherited from FrameworkElement.)
 | HitTestCore(PointHitTestParameters) | (Inherited from UIElement.)
 | HitTestCore(GeometryHitTestParameters) | (Inherited from UIElement.)
 | HorizontalAlignment | (Inherited from FrameworkElement.)
 | InheritanceBehavior | (Inherited from FrameworkElement.)
 | Initialized | (Inherited from FrameworkElement.)
 | InputBindings | (Inherited from UIElement.)
 | InputHitTest(Point) | (Inherited from UIElement.)
 | InputScope | (Inherited from FrameworkElement.)
 | InvalidateArrange()()()() | (Inherited from UIElement.)
 | InvalidateMeasure()()()() | (Inherited from UIElement.)
 | InvalidateProperty(DependencyProperty) | (Inherited from DependencyObject.)
 | InvalidateVisual()()()() | (Inherited from UIElement.)
 | IsAncestorOf(DependencyObject) | (Inherited from Visual.)
 | IsArrangeValid | (Inherited from UIElement.)
 | IsDescendantOf(DependencyObject) | (Inherited from Visual.)
 | IsEnabled | (Inherited from UIElement.)
 | IsEnabledChanged | (Inherited from UIElement.)
 | IsEnabledCore | (Inherited from UIElement.)
 | IsFocused | (Inherited from UIElement.)
 | IsHitTestVisible | (Inherited from UIElement.)
 | IsHitTestVisibleChanged | (Inherited from UIElement.)
 | IsInitialized | (Inherited from FrameworkElement.)
 | IsInputMethodEnabled | (Inherited from UIElement.)
 | IsKeyboardFocused | (Inherited from UIElement.)
 | IsKeyboardFocusedChanged | (Inherited from UIElement.)
 | IsKeyboardFocusWithin | (Inherited from UIElement.)
 | IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
 | IsLoaded | (Inherited from FrameworkElement.)
 | IsManipulationEnabled | (Inherited from UIElement.)
 | IsMeasureValid | (Inherited from UIElement.)
 | IsMouseCaptured | (Inherited from UIElement.)
 | IsMouseCapturedChanged | (Inherited from UIElement.)
 | IsMouseCaptureWithin | (Inherited from UIElement.)
 | IsMouseCaptureWithinChanged | (Inherited from UIElement.)
 | IsMouseDirectlyOver | (Inherited from UIElement.)
 | IsMouseDirectlyOverChanged | (Inherited from UIElement.)
 | IsMouseOver | (Inherited from UIElement.)
 | IsSealed | (Inherited from DependencyObject.)
 | IsStylusCaptured | (Inherited from UIElement.)
 | IsStylusCapturedChanged | (Inherited from UIElement.)
 | IsStylusCaptureWithin | (Inherited from UIElement.)
 | IsStylusCaptureWithinChanged | (Inherited from UIElement.)
 | IsStylusDirectlyOver | (Inherited from UIElement.)
 | IsStylusDirectlyOverChanged | (Inherited from UIElement.)
 | IsStylusOver | (Inherited from UIElement.)
 | IsVisible | (Inherited from UIElement.)
 | IsVisibleChanged | (Inherited from UIElement.)
 | KeyDown | (Inherited from UIElement.)
 | KeyUp | (Inherited from UIElement.)
 | Language | (Inherited from FrameworkElement.)
 | LayoutTransform | (Inherited from FrameworkElement.)
 | LayoutUpdated | (Inherited from UIElement.)
 | Loaded | (Inherited from FrameworkElement.)
 | LogicalChildren | (Inherited from FrameworkElement.)
 | LostFocus | (Inherited from UIElement.)
 | LostKeyboardFocus | (Inherited from UIElement.)
 | LostMouseCapture | (Inherited from UIElement.)
 | LostStylusCapture | (Inherited from UIElement.)
 | LostTouchCapture | (Inherited from UIElement.)
 | ManipulationBoundaryFeedback | (Inherited from UIElement.)
 | ManipulationCompleted | (Inherited from UIElement.)
 | ManipulationDelta | (Inherited from UIElement.)
 | ManipulationInertiaStarting | (Inherited from UIElement.)
 | ManipulationStarted | (Inherited from UIElement.)
 | ManipulationStarting | (Inherited from UIElement.)
 | Margin | (Inherited from FrameworkElement.)
 | MaxHeight | (Inherited from FrameworkElement.)
 | MaxWidth | (Inherited from FrameworkElement.)
 | Measure(Size) | (Inherited from UIElement.)
 | MeasureCore(Size) | (Inherited from FrameworkElement.)
 | MeasureOverride(Size) | (Inherited from FrameworkElement.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinHeight | (Inherited from FrameworkElement.)
 | MinWidth | (Inherited from FrameworkElement.)
 | MouseDown | (Inherited from UIElement.)
 | MouseEnter | (Inherited from UIElement.)
 | MouseLeave | (Inherited from UIElement.)
 | MouseLeftButtonDown | (Inherited from UIElement.)
 | MouseLeftButtonUp | (Inherited from UIElement.)
 | MouseMove | (Inherited from UIElement.)
 | MouseRightButtonDown | (Inherited from UIElement.)
 | MouseRightButtonUp | (Inherited from UIElement.)
 | MouseUp | (Inherited from UIElement.)
 | MouseWheel | (Inherited from UIElement.)
 | MoveFocus(TraversalRequest) | (Inherited from FrameworkElement.)
 | Name | (Inherited from FrameworkElement.)
 | OnAccessKey(AccessKeyEventArgs) | (Inherited from UIElement.)
 | OnApplyTemplate()()()() | (Inherited from FrameworkElement.)
 | OnChildDesiredSizeChanged(UIElement) | (Inherited from UIElement.)
 | OnContextMenuClosing(ContextMenuEventArgs) | (Inherited from FrameworkElement.)
 | OnContextMenuOpening(ContextMenuEventArgs) | (Inherited from FrameworkElement.)
 | OnCreateAutomationPeer()()()() | (Inherited from UIElement.)
 | OnDpiChanged(DpiScale, DpiScale) | (Inherited from Visual.)
 | OnDragEnter(DragEventArgs) | (Inherited from UIElement.)
 | OnDragLeave(DragEventArgs) | (Inherited from UIElement.)
 | OnDragOver(DragEventArgs) | (Inherited from UIElement.)
 | OnDrop(DragEventArgs) | (Inherited from UIElement.)
 | OnGiveFeedback(GiveFeedbackEventArgs) | (Inherited from UIElement.)
 | OnGotFocus(RoutedEventArgs) | (Inherited from FrameworkElement.)
 | OnGotKeyboardFocus(KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
 | OnGotMouseCapture(MouseEventArgs) | (Inherited from UIElement.)
 | OnGotStylusCapture(StylusEventArgs) | (Inherited from UIElement.)
 | OnGotTouchCapture(TouchEventArgs) | (Inherited from UIElement.)
 | OnInitialized(EventArgs) | (Inherited from FrameworkElement.)
 | OnIsKeyboardFocusedChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsKeyboardFocusWithinChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsMouseCapturedChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsMouseCaptureWithinChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsMouseDirectlyOverChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsStylusCapturedChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsStylusCaptureWithinChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsStylusDirectlyOverChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnKeyDown(KeyEventArgs) | (Inherited from UIElement.)
 | OnKeyUp(KeyEventArgs) | (Inherited from UIElement.)
 | OnLostFocus(RoutedEventArgs) | (Inherited from UIElement.)
 | OnLostKeyboardFocus(KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
 | OnLostMouseCapture(MouseEventArgs) | (Inherited from UIElement.)
 | OnLostStylusCapture(StylusEventArgs) | (Inherited from UIElement.)
 | OnLostTouchCapture(TouchEventArgs) | (Inherited from UIElement.)
 | OnManipulationBoundaryFeedback(ManipulationBoundaryFeedbackEventArgs) | (Inherited from UIElement.)
 | OnManipulationCompleted(ManipulationCompletedEventArgs) | (Inherited from UIElement.)
 | OnManipulationDelta(ManipulationDeltaEventArgs) | (Inherited from UIElement.)
 | OnManipulationInertiaStarting(ManipulationInertiaStartingEventArgs) | (Inherited from UIElement.)
 | OnManipulationStarted(ManipulationStartedEventArgs) | (Inherited from UIElement.)
 | OnManipulationStarting(ManipulationStartingEventArgs) | (Inherited from UIElement.)
 | OnMouseDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseEnter(MouseEventArgs) | (Inherited from UIElement.)
 | OnMouseLeave(MouseEventArgs) | (Inherited from UIElement.)
 | OnMouseLeftButtonDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseLeftButtonUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseMove(MouseEventArgs) | (Inherited from UIElement.)
 | OnMouseRightButtonDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseRightButtonUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseWheel(MouseWheelEventArgs) | (Inherited from UIElement.)
 | OnPreviewDragEnter(DragEventArgs) | (Inherited from UIElement.)
 | OnPreviewDragLeave(DragEventArgs) | (Inherited from UIElement.)
 | OnPreviewDragOver(DragEventArgs) | (Inherited from UIElement.)
 | OnPreviewDrop(DragEventArgs) | (Inherited from UIElement.)
 | OnPreviewGiveFeedback(GiveFeedbackEventArgs) | (Inherited from UIElement.)
 | OnPreviewGotKeyboardFocus(KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
 | OnPreviewKeyDown(KeyEventArgs) | (Inherited from UIElement.)
 | OnPreviewKeyUp(KeyEventArgs) | (Inherited from UIElement.)
 | OnPreviewLostKeyboardFocus(KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseLeftButtonDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseLeftButtonUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseMove(MouseEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseRightButtonDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseRightButtonUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseWheel(MouseWheelEventArgs) | (Inherited from UIElement.)
 | OnPreviewQueryContinueDrag(QueryContinueDragEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusButtonDown(StylusButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusButtonUp(StylusButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusDown(StylusDownEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusInAirMove(StylusEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusInRange(StylusEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusMove(StylusEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusOutOfRange(StylusEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusSystemGesture(StylusSystemGestureEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusUp(StylusEventArgs) | (Inherited from UIElement.)
 | OnPreviewTextInput(TextCompositionEventArgs) | (Inherited from UIElement.)
 | OnPreviewTouchDown(TouchEventArgs) | (Inherited from UIElement.)
 | OnPreviewTouchMove(TouchEventArgs) | (Inherited from UIElement.)
 | OnPreviewTouchUp(TouchEventArgs) | (Inherited from UIElement.)
 | OnPropertyChanged(DependencyPropertyChangedEventArgs) | (Inherited from FrameworkElement.)
 | OnQueryContinueDrag(QueryContinueDragEventArgs) | (Inherited from UIElement.)
 | OnQueryCursor(QueryCursorEventArgs) | (Inherited from UIElement.)
 | OnRender(DrawingContext) | Renders the control (Inherited from DesignableComponent.)
 | OnRenderSizeChanged(SizeChangedInfo) | (Inherited from FrameworkElement.)
 | OnStyleChanged(Style, Style) | (Inherited from FrameworkElement.)
 | OnStylusButtonDown(StylusButtonEventArgs) | (Inherited from UIElement.)
 | OnStylusButtonUp(StylusButtonEventArgs) | (Inherited from UIElement.)
 | OnStylusDown(StylusDownEventArgs) | (Inherited from UIElement.)
 | OnStylusEnter(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusInAirMove(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusInRange(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusLeave(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusMove(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusOutOfRange(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusSystemGesture(StylusSystemGestureEventArgs) | (Inherited from UIElement.)
 | OnStylusUp(StylusEventArgs) | (Inherited from UIElement.)
 | OnTextInput(TextCompositionEventArgs) | (Inherited from UIElement.)
 | OnToolTipClosing(ToolTipEventArgs) | (Inherited from FrameworkElement.)
 | OnToolTipOpening(ToolTipEventArgs) | (Inherited from FrameworkElement.)
 | OnTouchDown(TouchEventArgs) | (Inherited from UIElement.)
 | OnTouchEnter(TouchEventArgs) | (Inherited from UIElement.)
 | OnTouchLeave(TouchEventArgs) | (Inherited from UIElement.)
 | OnTouchMove(TouchEventArgs) | (Inherited from UIElement.)
 | OnTouchUp(TouchEventArgs) | (Inherited from UIElement.)
 | OnVisualChildrenChanged(DependencyObject, DependencyObject) | (Inherited from Visual.)
 | OnVisualParentChanged(DependencyObject) | (Inherited from FrameworkElement.)
 | Opacity | (Inherited from UIElement.)
 | OpacityMask | (Inherited from UIElement.)
 | OverridesDefaultStyle | (Inherited from FrameworkElement.)
 | Parent | (Inherited from FrameworkElement.)
 | ParentLayoutInvalidated(UIElement) | (Inherited from FrameworkElement.)
 | PersistId | Obsolete. (Inherited from UIElement.)
 | PointFromScreen(Point) | (Inherited from Visual.)
 | PointToScreen(Point) | (Inherited from Visual.)
 | PredictFocus(FocusNavigationDirection) | (Inherited from FrameworkElement.)
 | PreviewDragEnter | (Inherited from UIElement.)
 | PreviewDragLeave | (Inherited from UIElement.)
 | PreviewDragOver | (Inherited from UIElement.)
 | PreviewDrop | (Inherited from UIElement.)
 | PreviewGiveFeedback | (Inherited from UIElement.)
 | PreviewGotKeyboardFocus | (Inherited from UIElement.)
 | PreviewKeyDown | (Inherited from UIElement.)
 | PreviewKeyUp | (Inherited from UIElement.)
 | PreviewLostKeyboardFocus | (Inherited from UIElement.)
 | PreviewMouseDown | (Inherited from UIElement.)
 | PreviewMouseLeftButtonDown | (Inherited from UIElement.)
 | PreviewMouseLeftButtonUp | (Inherited from UIElement.)
 | PreviewMouseMove | (Inherited from UIElement.)
 | PreviewMouseRightButtonDown | (Inherited from UIElement.)
 | PreviewMouseRightButtonUp | (Inherited from UIElement.)
 | PreviewMouseUp | (Inherited from UIElement.)
 | PreviewMouseWheel | (Inherited from UIElement.)
 | PreviewQueryContinueDrag | (Inherited from UIElement.)
 | PreviewStylusButtonDown | (Inherited from UIElement.)
 | PreviewStylusButtonUp | (Inherited from UIElement.)
 | PreviewStylusDown | (Inherited from UIElement.)
 | PreviewStylusInAirMove | (Inherited from UIElement.)
 | PreviewStylusInRange | (Inherited from UIElement.)
 | PreviewStylusMove | (Inherited from UIElement.)
 | PreviewStylusOutOfRange | (Inherited from UIElement.)
 | PreviewStylusSystemGesture | (Inherited from UIElement.)
 | PreviewStylusUp | (Inherited from UIElement.)
 | PreviewTextInput | (Inherited from UIElement.)
 | PreviewTouchDown | (Inherited from UIElement.)
 | PreviewTouchMove | (Inherited from UIElement.)
 | PreviewTouchUp | (Inherited from UIElement.)
 | QueryContinueDrag | (Inherited from UIElement.)
 | QueryCursor | (Inherited from UIElement.)
 | RaiseEvent(RoutedEventArgs) | (Inherited from UIElement.)
 | RapidSpellAsYouType | The RapidSpellAsYouType to work with
 | RapidSpellAsYouTypeProperty | The RapidSpellAsYouType to work with.
 | RapidSpellDialog | The RapidSpellDialog to work with
 | RapidSpellDialogProperty | The RapidSpellDialog to work with.
 | ReadLocalValue(DependencyProperty) | (Inherited from DependencyObject.)
 | RegisterName(String, Object) | (Inherited from FrameworkElement.)
 | ReleaseAllTouchCaptures()()()() | (Inherited from UIElement.)
 | ReleaseMouseCapture()()()() | (Inherited from UIElement.)
 | ReleaseStylusCapture()()()() | (Inherited from UIElement.)
 | ReleaseTouchCapture(TouchDevice) | (Inherited from UIElement.)
 | RemoveHandler(RoutedEvent, Delegate) | (Inherited from UIElement.)
 | RemoveLogicalChild(Object) | (Inherited from FrameworkElement.)
 | RemoveVisualChild(Visual) | (Inherited from Visual.)
 | RenderSize | (Inherited from UIElement.)
 | RenderTransform | (Inherited from UIElement.)
 | RenderTransformOrigin | (Inherited from UIElement.)
 | RequestBringIntoView | (Inherited from FrameworkElement.)
 | Resources | (Inherited from FrameworkElement.)
 | RSAWordAdded(Object, WordAddedEventArgs) | Called when a word is added to the dictionary by the as you type.
 | RSAWordIgnored(Object, WordIgnoredEventArgs) | Called when a word is ignore by the as you type.
 | RSDFinished(Object, TextBoxSpellCheckEventArgs) | Called when the dialog finishes.
 | RSDStarted(Object, TextBoxSpellCheckEventArgs) | Called when the dialog starts.
 | RSDWordAdded(Object, WordAddedEventArgs) | Called when a word is added to the dictionary by the dialog.
 | RSDWordChanged(Object, WordChangedEventArgs) | Called when a word is changed by the dialog.
 | RSDWordIgnored(Object, WordIgnoredEventArgs) | Called when a word is ignored by the dialog.
 | SetBinding(DependencyProperty, BindingBase) | (Inherited from FrameworkElement.)
 | SetBinding(DependencyProperty, String) | (Inherited from FrameworkElement.)
 | SetCurrentValue(DependencyProperty, Object) | (Inherited from DependencyObject.)
 | SetResourceReference(DependencyProperty, Object) | (Inherited from FrameworkElement.)
 | SetValue(DependencyProperty, Object) | (Inherited from DependencyObject.)
 | SetValue(DependencyPropertyKey, Object) | (Inherited from DependencyObject.)
 | ShouldSerializeCommandBindings()()()() | (Inherited from UIElement.)
 | ShouldSerializeInputBindings()()()() | (Inherited from UIElement.)
 | ShouldSerializeProperty(DependencyProperty) | (Inherited from DependencyObject.)
 | ShouldSerializeResources()()()() | (Inherited from FrameworkElement.)
 | ShouldSerializeStyle()()()() | (Inherited from FrameworkElement.)
 | ShouldSerializeTriggers()()()() | (Inherited from FrameworkElement.)
 | SizeChanged | (Inherited from FrameworkElement.)
 | SnapsToDevicePixels | (Inherited from UIElement.)
 | SourceUpdated | (Inherited from FrameworkElement.)
 | Style | (Inherited from FrameworkElement.)
 | StylusButtonDown | (Inherited from UIElement.)
 | StylusButtonUp | (Inherited from UIElement.)
 | StylusDown | (Inherited from UIElement.)
 | StylusEnter | (Inherited from UIElement.)
 | StylusInAirMove | (Inherited from UIElement.)
 | StylusInRange | (Inherited from UIElement.)
 | StylusLeave | (Inherited from UIElement.)
 | StylusMove | (Inherited from UIElement.)
 | StylusOutOfRange | (Inherited from UIElement.)
 | StylusPlugIns | (Inherited from UIElement.)
 | StylusSystemGesture | (Inherited from UIElement.)
 | StylusUp | (Inherited from UIElement.)
 | Tag | (Inherited from FrameworkElement.)
 | TargetUpdated | (Inherited from FrameworkElement.)
 | TemplatedParent | (Inherited from FrameworkElement.)
 | TextInput | (Inherited from UIElement.)
 | ToolTip | (Inherited from FrameworkElement.)
 | ToolTipClosing | (Inherited from FrameworkElement.)
 | ToolTipOpening | (Inherited from FrameworkElement.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | TouchDown | (Inherited from UIElement.)
 | TouchEnter | (Inherited from UIElement.)
 | TouchesCaptured | (Inherited from UIElement.)
 | TouchesCapturedWithin | (Inherited from UIElement.)
 | TouchesDirectlyOver | (Inherited from UIElement.)
 | TouchesOver | (Inherited from UIElement.)
 | TouchLeave | (Inherited from UIElement.)
 | TouchMove | (Inherited from UIElement.)
 | TouchUp | (Inherited from UIElement.)
 | TransformToAncestor(Visual) | (Inherited from Visual.)
 | TransformToAncestor(Visual3D) | (Inherited from Visual.)
 | TransformToDescendant(Visual) | (Inherited from Visual.)
 | TransformToVisual(Visual) | (Inherited from Visual.)
 | TranslatePoint(Point, UIElement) | (Inherited from UIElement.)
 | Triggers | (Inherited from FrameworkElement.)
 | TryFindResource(Object) | (Inherited from FrameworkElement.)
 | Uid | (Inherited from UIElement.)
 | Unloaded | (Inherited from FrameworkElement.)
 | UnregisterName(String) | (Inherited from FrameworkElement.)
 | UpdateDefaultStyle()()()() | (Inherited from FrameworkElement.)
 | UpdateLayout()()()() | (Inherited from UIElement.)
 | UseLayoutRounding | (Inherited from FrameworkElement.)
 | VerifyAccess()()()() | (Inherited from DispatcherObject.)
 | VerticalAlignment | (Inherited from FrameworkElement.)
 | Visibility | (Inherited from UIElement.)
 | VisualBitmapEffect | Obsolete. (Inherited from Visual.)
 | VisualBitmapEffectInput | Obsolete. (Inherited from Visual.)
 | VisualBitmapScalingMode | (Inherited from Visual.)
 | VisualCacheMode | (Inherited from Visual.)
 | VisualChildrenCount | (Inherited from FrameworkElement.)
 | VisualClearTypeHint | (Inherited from Visual.)
 | VisualClip | (Inherited from Visual.)
 | VisualEdgeMode | (Inherited from Visual.)
 | VisualEffect | (Inherited from Visual.)
 | VisualOffset | (Inherited from Visual.)
 | VisualOpacity | (Inherited from Visual.)
 | VisualOpacityMask | (Inherited from Visual.)
 | VisualParent | (Inherited from Visual.)
 | VisualScrollableAreaClip | (Inherited from Visual.)
 | VisualTextHintingMode | (Inherited from Visual.)
 | VisualTextRenderingMode | (Inherited from Visual.)
 | VisualTransform | (Inherited from Visual.)
 | VisualXSnappingGuidelines | (Inherited from Visual.)
 | VisualYSnappingGuidelines | (Inherited from Visual.)
 | Width | (Inherited from FrameworkElement.)
Remarks
This control provides a coherent end-user experience; for example clicking 'Ignore All' when checking in RapidSpellDialog will also cause the underline (painted by RapidSpellAsYouType) to be removed.
Inheritance Hierarchy
Object
 | DispatcherObject
 |  | DependencyObject
 |  |  | Visual
 |  |  |  | UIElement
 |  |  |  |  | FrameworkElement
 |  |  |  |  |  | DesignableComponent
 |  |  |  |  |  |  | RapidSpellAYTDialogCoupler


RapidSpellAYTDialogCoupler Constructor

RapidSpellAYTDialogCoupler Constructor
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAYTDialogCoupler ► RapidSpellAYTDialogCoupler()()()()
Keyoti RapidSpell WPF
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public RapidSpellAYTDialogCoupler()
public RapidSpellAYTDialogCoupler()
Public Sub New
Public Sub New
public:
RapidSpellAYTDialogCoupler()
public:
RapidSpellAYTDialogCoupler()
new : unit -> RapidSpellAYTDialogCoupler
new : unit -> RapidSpellAYTDialogCoupler


Dispose Method (disposing)

Dispose Method (disposing)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAYTDialogCoupler ► Dispose(Boolean)
Keyoti RapidSpell WPF
Frees up resources.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected void Dispose(
    bool disposing
)
protected void Dispose(
    bool disposing
)
Protected Sub Dispose (
    disposing As Boolean
)
Protected Sub Dispose (
    disposing As Boolean
)
protected:
void Dispose(
    bool disposing
)
protected:
void Dispose(
    bool disposing
)
member Dispose :
        disposing : bool -> unit

member Dispose :
        disposing : bool -> unit
Parameters
disposing (Boolean)


RapidSpellAsYouType Property

RapidSpellAsYouType Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAYTDialogCoupler ► RapidSpellAsYouType
Keyoti RapidSpell WPF
The RapidSpellAsYouType to work with
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public RapidSpellAsYouType RapidSpellAsYouType { get; set; }
public RapidSpellAsYouType RapidSpellAsYouType { get; set; }
Public Property RapidSpellAsYouType As RapidSpellAsYouType
    Get
    Set
Public Property RapidSpellAsYouType As RapidSpellAsYouType
    Get
    Set
public:
property RapidSpellAsYouType^ RapidSpellAsYouType {
    RapidSpellAsYouType^ get ();
    void set (RapidSpellAsYouType^ value);
}
public:
property RapidSpellAsYouType^ RapidSpellAsYouType {
    RapidSpellAsYouType^ get ();
    void set (RapidSpellAsYouType^ value);
}
member RapidSpellAsYouType : RapidSpellAsYouType with get, set

member RapidSpellAsYouType : RapidSpellAsYouType with get, set
Property Value
RapidSpellAsYouType


RapidSpellAsYouTypeProperty Field

RapidSpellAsYouTypeProperty Field
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAYTDialogCoupler ► RapidSpellAsYouTypeProperty
Keyoti RapidSpell WPF
The RapidSpellAsYouType to work with.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static readonly DependencyProperty RapidSpellAsYouTypeProperty
public static readonly DependencyProperty RapidSpellAsYouTypeProperty
Public Shared ReadOnly RapidSpellAsYouTypeProperty As DependencyProperty
Public Shared ReadOnly RapidSpellAsYouTypeProperty As DependencyProperty
public:
static initonly DependencyProperty^ RapidSpellAsYouTypeProperty
public:
static initonly DependencyProperty^ RapidSpellAsYouTypeProperty
static val RapidSpellAsYouTypeProperty: DependencyProperty
static val RapidSpellAsYouTypeProperty: DependencyProperty
Field Value
DependencyProperty


RapidSpellDialog Property

RapidSpellDialog Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAYTDialogCoupler ► RapidSpellDialog
Keyoti RapidSpell WPF
The RapidSpellDialog to work with
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public RapidSpellDialog RapidSpellDialog { get; set; }
public RapidSpellDialog RapidSpellDialog { get; set; }
Public Property RapidSpellDialog As RapidSpellDialog
    Get
    Set
Public Property RapidSpellDialog As RapidSpellDialog
    Get
    Set
public:
property RapidSpellDialog^ RapidSpellDialog {
    RapidSpellDialog^ get ();
    void set (RapidSpellDialog^ value);
}
public:
property RapidSpellDialog^ RapidSpellDialog {
    RapidSpellDialog^ get ();
    void set (RapidSpellDialog^ value);
}
member RapidSpellDialog : RapidSpellDialog with get, set

member RapidSpellDialog : RapidSpellDialog with get, set
Property Value
RapidSpellDialog


RapidSpellDialogProperty Field

RapidSpellDialogProperty Field
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAYTDialogCoupler ► RapidSpellDialogProperty
Keyoti RapidSpell WPF
The RapidSpellDialog to work with.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static readonly DependencyProperty RapidSpellDialogProperty
public static readonly DependencyProperty RapidSpellDialogProperty
Public Shared ReadOnly RapidSpellDialogProperty As DependencyProperty
Public Shared ReadOnly RapidSpellDialogProperty As DependencyProperty
public:
static initonly DependencyProperty^ RapidSpellDialogProperty
public:
static initonly DependencyProperty^ RapidSpellDialogProperty
static val RapidSpellDialogProperty: DependencyProperty
static val RapidSpellDialogProperty: DependencyProperty
Field Value
DependencyProperty


RSAWordAdded Method (sender, e)

RSAWordAdded Method (sender, e)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAYTDialogCoupler ► RSAWordAdded(Object, WordAddedEventArgs)
Keyoti RapidSpell WPF
Called when a word is added to the dictionary by the as you type.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void RSAWordAdded(
    Object sender,
    WordAddedEventArgs e
)
protected virtual void RSAWordAdded(
    Object sender,
    WordAddedEventArgs e
)
Protected Overridable Sub RSAWordAdded (
    sender As Object,
    e As WordAddedEventArgs
)
Protected Overridable Sub RSAWordAdded (
    sender As Object,
    e As WordAddedEventArgs
)
protected:
virtual void RSAWordAdded(
    Object^ sender,
    WordAddedEventArgs^ e
)
protected:
virtual void RSAWordAdded(
    Object^ sender,
    WordAddedEventArgs^ e
)
abstract RSAWordAdded :
        sender : Object *
        e : WordAddedEventArgs -> unit
override RSAWordAdded :
        sender : Object *
        e : WordAddedEventArgs -> unit
abstract RSAWordAdded :
        sender : Object *
        e : WordAddedEventArgs -> unit
override RSAWordAdded :
        sender : Object *
        e : WordAddedEventArgs -> unit
Parameters
sender (Object)
The sender object
e (WordAddedEventArgs)
The event args


RSAWordIgnored Method (sender, e)

RSAWordIgnored Method (sender, e)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAYTDialogCoupler ► RSAWordIgnored(Object, WordIgnoredEventArgs)
Keyoti RapidSpell WPF
Called when a word is ignore by the as you type.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void RSAWordIgnored(
    Object sender,
    WordIgnoredEventArgs e
)
protected virtual void RSAWordIgnored(
    Object sender,
    WordIgnoredEventArgs e
)
Protected Overridable Sub RSAWordIgnored (
    sender As Object,
    e As WordIgnoredEventArgs
)
Protected Overridable Sub RSAWordIgnored (
    sender As Object,
    e As WordIgnoredEventArgs
)
protected:
virtual void RSAWordIgnored(
    Object^ sender,
    WordIgnoredEventArgs^ e
)
protected:
virtual void RSAWordIgnored(
    Object^ sender,
    WordIgnoredEventArgs^ e
)
abstract RSAWordIgnored :
        sender : Object *
        e : WordIgnoredEventArgs -> unit
override RSAWordIgnored :
        sender : Object *
        e : WordIgnoredEventArgs -> unit
abstract RSAWordIgnored :
        sender : Object *
        e : WordIgnoredEventArgs -> unit
override RSAWordIgnored :
        sender : Object *
        e : WordIgnoredEventArgs -> unit
Parameters
sender (Object)
The sender object
e (WordIgnoredEventArgs)
The event args


RSDFinished Method (sender, e)

RSDFinished Method (sender, e)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAYTDialogCoupler ► RSDFinished(Object, TextBoxSpellCheckEventArgs)
Keyoti RapidSpell WPF
Called when the dialog finishes.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void RSDFinished(
    Object sender,
    TextBoxSpellCheckEventArgs e
)
protected virtual void RSDFinished(
    Object sender,
    TextBoxSpellCheckEventArgs e
)
Protected Overridable Sub RSDFinished (
    sender As Object,
    e As TextBoxSpellCheckEventArgs
)
Protected Overridable Sub RSDFinished (
    sender As Object,
    e As TextBoxSpellCheckEventArgs
)
protected:
virtual void RSDFinished(
    Object^ sender,
    TextBoxSpellCheckEventArgs^ e
)
protected:
virtual void RSDFinished(
    Object^ sender,
    TextBoxSpellCheckEventArgs^ e
)
abstract RSDFinished :
        sender : Object *
        e : TextBoxSpellCheckEventArgs -> unit
override RSDFinished :
        sender : Object *
        e : TextBoxSpellCheckEventArgs -> unit
abstract RSDFinished :
        sender : Object *
        e : TextBoxSpellCheckEventArgs -> unit
override RSDFinished :
        sender : Object *
        e : TextBoxSpellCheckEventArgs -> unit
Parameters
sender (Object)
The sender object
e (TextBoxSpellCheckEventArgs)
The event args


RSDStarted Method (sender, e)

RSDStarted Method (sender, e)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAYTDialogCoupler ► RSDStarted(Object, TextBoxSpellCheckEventArgs)
Keyoti RapidSpell WPF
Called when the dialog starts.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void RSDStarted(
    Object sender,
    TextBoxSpellCheckEventArgs e
)
protected virtual void RSDStarted(
    Object sender,
    TextBoxSpellCheckEventArgs e
)
Protected Overridable Sub RSDStarted (
    sender As Object,
    e As TextBoxSpellCheckEventArgs
)
Protected Overridable Sub RSDStarted (
    sender As Object,
    e As TextBoxSpellCheckEventArgs
)
protected:
virtual void RSDStarted(
    Object^ sender,
    TextBoxSpellCheckEventArgs^ e
)
protected:
virtual void RSDStarted(
    Object^ sender,
    TextBoxSpellCheckEventArgs^ e
)
abstract RSDStarted :
        sender : Object *
        e : TextBoxSpellCheckEventArgs -> unit
override RSDStarted :
        sender : Object *
        e : TextBoxSpellCheckEventArgs -> unit
abstract RSDStarted :
        sender : Object *
        e : TextBoxSpellCheckEventArgs -> unit
override RSDStarted :
        sender : Object *
        e : TextBoxSpellCheckEventArgs -> unit
Parameters
sender (Object)
The sender object
e (TextBoxSpellCheckEventArgs)
The event args


RSDWordAdded Method (sender, e)

RSDWordAdded Method (sender, e)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAYTDialogCoupler ► RSDWordAdded(Object, WordAddedEventArgs)
Keyoti RapidSpell WPF
Called when a word is added to the dictionary by the dialog.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void RSDWordAdded(
    Object sender,
    WordAddedEventArgs e
)
protected virtual void RSDWordAdded(
    Object sender,
    WordAddedEventArgs e
)
Protected Overridable Sub RSDWordAdded (
    sender As Object,
    e As WordAddedEventArgs
)
Protected Overridable Sub RSDWordAdded (
    sender As Object,
    e As WordAddedEventArgs
)
protected:
virtual void RSDWordAdded(
    Object^ sender,
    WordAddedEventArgs^ e
)
protected:
virtual void RSDWordAdded(
    Object^ sender,
    WordAddedEventArgs^ e
)
abstract RSDWordAdded :
        sender : Object *
        e : WordAddedEventArgs -> unit
override RSDWordAdded :
        sender : Object *
        e : WordAddedEventArgs -> unit
abstract RSDWordAdded :
        sender : Object *
        e : WordAddedEventArgs -> unit
override RSDWordAdded :
        sender : Object *
        e : WordAddedEventArgs -> unit
Parameters
sender (Object)
The sender object
e (WordAddedEventArgs)
The event args


RSDWordChanged Method (sender, e)

RSDWordChanged Method (sender, e)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAYTDialogCoupler ► RSDWordChanged(Object, WordChangedEventArgs)
Keyoti RapidSpell WPF
Called when a word is changed by the dialog.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void RSDWordChanged(
    Object sender,
    WordChangedEventArgs e
)
protected virtual void RSDWordChanged(
    Object sender,
    WordChangedEventArgs e
)
Protected Overridable Sub RSDWordChanged (
    sender As Object,
    e As WordChangedEventArgs
)
Protected Overridable Sub RSDWordChanged (
    sender As Object,
    e As WordChangedEventArgs
)
protected:
virtual void RSDWordChanged(
    Object^ sender,
    WordChangedEventArgs^ e
)
protected:
virtual void RSDWordChanged(
    Object^ sender,
    WordChangedEventArgs^ e
)
abstract RSDWordChanged :
        sender : Object *
        e : WordChangedEventArgs -> unit
override RSDWordChanged :
        sender : Object *
        e : WordChangedEventArgs -> unit
abstract RSDWordChanged :
        sender : Object *
        e : WordChangedEventArgs -> unit
override RSDWordChanged :
        sender : Object *
        e : WordChangedEventArgs -> unit
Parameters
sender (Object)
The sender object
e (WordChangedEventArgs)
The event args


RSDWordIgnored Method (sender, e)

RSDWordIgnored Method (sender, e)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAYTDialogCoupler ► RSDWordIgnored(Object, WordIgnoredEventArgs)
Keyoti RapidSpell WPF
Called when a word is ignored by the dialog.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void RSDWordIgnored(
    Object sender,
    WordIgnoredEventArgs e
)
protected virtual void RSDWordIgnored(
    Object sender,
    WordIgnoredEventArgs e
)
Protected Overridable Sub RSDWordIgnored (
    sender As Object,
    e As WordIgnoredEventArgs
)
Protected Overridable Sub RSDWordIgnored (
    sender As Object,
    e As WordIgnoredEventArgs
)
protected:
virtual void RSDWordIgnored(
    Object^ sender,
    WordIgnoredEventArgs^ e
)
protected:
virtual void RSDWordIgnored(
    Object^ sender,
    WordIgnoredEventArgs^ e
)
abstract RSDWordIgnored :
        sender : Object *
        e : WordIgnoredEventArgs -> unit
override RSDWordIgnored :
        sender : Object *
        e : WordIgnoredEventArgs -> unit
abstract RSDWordIgnored :
        sender : Object *
        e : WordIgnoredEventArgs -> unit
override RSDWordIgnored :
        sender : Object *
        e : WordIgnoredEventArgs -> unit
Parameters
sender (Object)
The sender object
e (WordIgnoredEventArgs)
The event args


RapidSpellChecker Class

RapidSpellChecker Class
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker
Keyoti RapidSpell WPF
Spell checker engine, checks a text string for spelling errors and makes suggested corrections.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class RapidSpellChecker : ICheckerEngine
public class RapidSpellChecker : ICheckerEngine
Public Class RapidSpellChecker
    Implements ICheckerEngine
Public Class RapidSpellChecker
    Implements ICheckerEngine
public ref class RapidSpellChecker : ICheckerEngine
public ref class RapidSpellChecker : ICheckerEngine
type RapidSpellChecker =
    class
        interface ICheckerEngine
    end
type RapidSpellChecker =
    class
        interface ICheckerEngine
    end
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RapidSpellChecker()()()() | Creates a RapidSpellChecker, with no user dictionary.
 | AddIgnorePattern(String) | Adds a regex pattern to ignore (maximum of 20 can be added - IgnoreURLsAndEmailAddresses=true counts as 1).
 | AddWord(String) | Adds word to the user dictionary (if it has been specified).
 | AllowAnyCase | Whether to allow words spelt with incorrect case, eg. "africa", instead of "Africa", this is more relaxed than AllowMixedCase
 | AllowMixedCase | Whether to allow words spelt with mixed case, eg. "MIxEd" - also see AllowAnyCase.
 | ChangeAll(String) | Changes all instances of the current bad word to newWord in the text.
 | ChangeBadWord(String) | Changes the current bad word to newWord in the text.
 | ChangeBadWord(BadWord, String) | Changes badWord to newWord in the text.
 | Check(String) | Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.
 | Check(String, Boolean) | Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.
 | Check(String, Int32) | Checks text for spelling correctness, from startPosition in text, mis-spelt words can be accessed through NextBadWord.
 | Check(String, Int32, Boolean) | Checks text for spelling correctness, from startPosition in text, mis-spelt words can be accessed through NextBadWord.
 | CheckCompoundWords | Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
 | convertHtmlEntities(String) | Converts HTML entity codes to their Unicode characters
 | convertHtmlEntities(String, Boolean) | Converts HTML entity codes to their Unicode characters
 | CurrentBadWord | Gets the current bad word (last returned by NextBadWord).
 | DictFilePath | The file to be used as the main dictionary (either a full file path, or the name of an embedded resource), if this is null then the built-in US English dictionary is used.
 | Dispose(Boolean) | Disposes of resources.
 | Dispose()()()() | Clean up any resources being used.
 | dontSuggest | Don't suggest words in this array (swear words).
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FindAnagrams(String, IList) | Finds anagrams of word and puts them in anagrams if not already present.
 | FindCapitalizedSuggestions | Whether to look for capitalized suggestions, note this will slow FindSuggestions down by about 7 times.
 | FindCompoundWords(String, IList, Boolean) | Finds the compound words in text and puts them in subwords, set subwords to null/nothing to just find if text has compound word formation.
 | FindSuggestions()()()() | Gets an enumeration of String suggestions for spelling of current bad word.
 | FindSuggestions(String) | Gets an enumeration of String suggestions for word.
 | FindSuggestions(String, Boolean) | Gets an enumeration of String suggestions for word.
 | GetAmendedText()()()() | Returns the original text sent to check() but with any alterations made through change
 | GetConsiderationRange()()()() | Gets the factor for words to consider for suggestions.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIgnoreCapitalizedWords()()()() | Gets whether to ignore words with capital letters.
 | GetIncludeUserDictionaryInSuggestions()()()() | Gets whether the user dictionary should be used in finding suggestions for misspelt words.
 | GetNextWord()()()() | Returns the next word in the text.
 | GetSeparateHyphenWords()()()() | Gets whether to treat hyphenated (-) words as separate words, default is false.
 | GetSuggestionsMethod()()()() | Obsolete. Gets the suggestions method to use. Either PHONETIC_SUGGESTIONS or HASHING_SUGGESTIONS
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GetUndoableStatePoint()()()() | Gets the state of the current run, which can be stored and used with RevertToUndoableStatePoint(RapidSpellChecker..::..State)
 | HASHING_SUGGESTIONS | Indicator for suggestion method (Hashing is default).
 | IgnoreAll(String) | Marks word to be ignored in rest of the text.
 | IgnoreAllCaseInsensitive | Whether Ignore All operations should be considered case insensitive (default false).
 | IgnoreIncorrectSentenceCapitalization | Whether to ignore incorrect sentence capitalization.
 | IgnoreInEnglishLowerCaseI | Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
 | IgnoreList | The words to ignore, note this list is changed by IgnoreAll.
 | IgnorePatternMaximumWordLength | The maximum length of word that will be tested as a regex ignore pattern.
 | IgnoreRtfCodes | Sets whether this should ignore Rtf (or any escaped) codes in the text.
 | IgnoreURLsAndEmailAddresses | Whether to ignore URLs and email addresses (requires V2Parser=true)
 | IgnoreWordsWithDigits | Whether to ignore words with numbers in them (eg. A10 or 7-11).
 | IgnoreXML | Whether to ignore XML/HTML tags, should be set true for RichTextBox support, false by default.
 | IsAllCaps(String) | Whether all chars in s are in upper case
 | IsStartsWithCap(String) | Whether first letter is a capital and rest are lower.
 | IsWord(Int32, Int32) | Whether the word defined by the parameters is a word or whitespace.
 | LanguageParser | The type of language parsing to use.
 | LookForAnagrams | Whether to look for anagrams, if true suggestion performance is slower.
 | LookIntoHyphenatedText | Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
 | LookUp(String) | Checks if query is in the main dictionary or user.
 | LookUpMainDictionary(String) | Checks if query is in the word dictionary. Returns true if doesnt start with a letter or apostrophe
 | LookUpUserDictionary(String) | Look up the query in the user dictionary if it exists.
 | MakeCap(String) | Capitalises first letter of word
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NextBadWord()()()() | Returns the next mis-spelt word in the text, as a BadWord object.
 | PHONETIC_SUGGESTIONS | Indicator for suggestion method (Hashing is default).
 | ReloadUserDictionary()()()() | Reloads the user dictionary.
 | RemoveIgnorePattern(String) | Removes a regex pattern to ignore (maximum of 20 can be added - IgnoreURLsAndEmailAddresses=true counts as 1).
 | RevertToUndoableStatePoint(RapidSpellChecker..::..State) | Reverts the state to what it was when GetUndoableStatePoint()()()() was called.
 | SetConsiderationRange(Int32) | Sets the factor for words to consider for suggestions, lower values are faster but consider less words for suggestions. Default is 80. If w <= 1 this method won't do anything.
 | SetDictFileStream(Stream, String, DateTime) | Passes a Dict file as a stream, to be used for the main dictionary.
 | SetIgnoreCapitalizedWords(Boolean) | Sets whether to ignore words with capital letters.
 | SetIncludeUserDictionaryInSuggestions(Boolean) | Sets whether the user dictionary should be used in finding suggestions for misspelt words.
 | SetOptionalContext(String, String) | Provides the engine with any helpful text around the text snippet which will be passed to the Check method.
 | SetPosition(Int32) | Sets the pointer position for the NextBadWord iterator.
 | SetSeparateHyphenWords(Boolean) | Sets whether to treat hyphenated (-) words as separate words, default is false.
 | SetSuggestionsMethod(Int32) | Obsolete. Sets the suggestions method to use. Either PHONETIC_SUGGESTIONS or HASHING_SUGGESTIONS
 | SetUserDictionary(String) | Set the user dictionary to use.
 | SetUserDictionary(UserDictionary) | Set the user dictionary to use.
 | ShareDictionary | Obsolete. Whether to share the dictionary in memory across all instances of RapidSpellChecker (false by default).
 | SuggestionsMethod | The method used for suggestions, default is Hashing
 | SuggestSplitWords | Whether to look for connected words in suggestions.
 | TextBoundary | The AdvancedTextBoundary class to use to parse words.
 | theCurrentBadWord | The current badword
 | theText | The text being checked.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | UnloadMainDictionary()()()() | Obsolete. Empties the main dictionary store.
 | userDictionary | The UserDictionary being used, may be null if no user dictionary is being used.
 | V2Parser | Whether to use parser version 2 - Set to false for backwards compatibility.
 | WarnDuplicates | Whether to treat duplicate words as errors (eg. "this is is an error").
 | WordAdded | Fired when word added to user dictionary
 | WordChanged | Change word event, fired when a word is changed.
 | wordEnd | The end index of the current word being checked/parsed.
 | WordIgnored | Fired when word ignored
 | wordStart | The start index of the current word being checked/parsed.
Remarks
This is a non-GUI component, suitable for the business/logic layer of your application. You would use this component in web server based applications. This component can be used in 2 different ways. The most common usage, in an iterative fashion is detailed below, but it may also be used on a query by query basis. To use this component in an iterative way you must first call Check to set the text to check and then iterate through NextBadWord() to identify misspelt words. NextBadWord will return a BadWord object and internally locate the the misspelt word in the text, then you can call FindSuggestions which will return a ArrayList of suggestions as String objects. You may also call ChangeBadWord(replacement) to replace that current misspelt word in the text. NextBadWord() will return null when the text has been checked. GetAmendedText returns the current state of the text with corrections. Calling ChangeBadWord or FindSuggestions before NextBadWord has been called and returned a BadWord (i.e. not null) will result in a NoCurrentBadWordException
Remarks

The second way to use this component is simply to query words yourself using LookUp(word) to check if word is in the lexicon/dictionary and FindSuggestions(word) to find spelling suggestions for word.

Examples
Check some text, find suggestions and replace mis-spelt words with "replacement".
Copy image Copy
RapidSpellChecker c = new RapidSpellChecker();
BadWord badWord;
ArrayList suggestions;

 //check some text.
c.Check("This is sume text.");

//iterate through all bad words in the text.
while((badWord = c.NextBadWord())!=null){

    Console.WriteLine(badWord.GetWord() + "- is not spelt correctly. Suggestions:");

    try{
        //get suggestions for the current bad word.
        suggestions = c.FindSuggestions();

        //display all suggestions.
        for(int i=0; i<suggestions.Count; i++){
            Console.WriteLine(suggestions[i]);
        }

        //change the bad word in the text with "replacement".
        c.ChangeBadWord("replacement");

    } catch (NoCurrentBadWordException e){
        Console.WriteLine(e);
    }

}
Console.WriteLine(c.GetAmendedText());
Inheritance Hierarchy
Object
RapidSpellChecker


RapidSpellChecker Constructor

RapidSpellChecker Constructor
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► RapidSpellChecker()()()()
Keyoti RapidSpell WPF
Creates a RapidSpellChecker, with no user dictionary.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public RapidSpellChecker()
public RapidSpellChecker()
Public Sub New
Public Sub New
public:
RapidSpellChecker()
public:
RapidSpellChecker()
new : unit -> RapidSpellChecker
new : unit -> RapidSpellChecker
Exceptions
Exception | Condition
ApplicationException | If the dictionary cannot be read.


AddIgnorePattern Method (p)

AddIgnorePattern Method (p)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► AddIgnorePattern(String)
Keyoti RapidSpell WPF
Adds a regex pattern to ignore (maximum of 20 can be added - IgnoreURLsAndEmailAddresses=true counts as 1).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void AddIgnorePattern(
    string p
)
public virtual void AddIgnorePattern(
    string p
)
Public Overridable Sub AddIgnorePattern (
    p As String
)
Public Overridable Sub AddIgnorePattern (
    p As String
)
public:
virtual void AddIgnorePattern(
    String^ p
)
public:
virtual void AddIgnorePattern(
    String^ p
)
abstract AddIgnorePattern :
        p : string -> unit
override AddIgnorePattern :
        p : string -> unit
abstract AddIgnorePattern :
        p : string -> unit
override AddIgnorePattern :
        p : string -> unit
Parameters
p (String)
Remarks
Eg, to ignore email addresses either set IgnoreURLsAndEmailAddresses=true or AddIgnorePattern("^(?:[0-9a-zA-Z](?:[-.\w]*[0-9a-zA-Z])*@(?:[0-9a-zA-Z][-\w]*[0-9a-zA-Z]\.)+[a-zA-Z]{2,9})$").


AddWord Method (word)

AddWord Method (word)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► AddWord(String)
Keyoti RapidSpell WPF
Adds word to the user dictionary (if it has been specified).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool AddWord(
    string word
)
public virtual bool AddWord(
    string word
)
Public Overridable Function AddWord (
    word As String
) As Boolean
Public Overridable Function AddWord (
    word As String
) As Boolean
public:
virtual bool AddWord(
    String^ word
)
public:
virtual bool AddWord(
    String^ word
)
abstract AddWord :
        word : string -> bool
override AddWord :
        word : string -> bool
abstract AddWord :
        word : string -> bool
override AddWord :
        word : string -> bool
Parameters
word (String)
String to add to user dictionary, if it is being used.
Return Value
Boolean
boolean true if the word was is now in the user dictionary, false if the word could not be added to the user dictionary.
Exceptions
Exception | Condition
ArgumentNullException | If word parameter is null.


AllowAnyCase Property

AllowAnyCase Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► AllowAnyCase
Keyoti RapidSpell WPF
Whether to allow words spelt with incorrect case, eg. "africa", instead of "Africa", this is more relaxed than AllowMixedCase
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool AllowAnyCase { get; set; }
public bool AllowAnyCase { get; set; }
Public Property AllowAnyCase As Boolean
    Get
    Set
Public Property AllowAnyCase As Boolean
    Get
    Set
public:
virtual property bool AllowAnyCase {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool AllowAnyCase {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract AllowAnyCase : bool with get, set
override AllowAnyCase : bool with get, set
abstract AllowAnyCase : bool with get, set
override AllowAnyCase : bool with get, set
Property Value
Boolean


AllowMixedCase Property

AllowMixedCase Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► AllowMixedCase
Keyoti RapidSpell WPF
Whether to allow words spelt with mixed case, eg. "MIxEd" - also see AllowAnyCase.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool AllowMixedCase { get; set; }
public bool AllowMixedCase { get; set; }
Public Property AllowMixedCase As Boolean
    Get
    Set
Public Property AllowMixedCase As Boolean
    Get
    Set
public:
virtual property bool AllowMixedCase {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool AllowMixedCase {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract AllowMixedCase : bool with get, set
override AllowMixedCase : bool with get, set
abstract AllowMixedCase : bool with get, set
override AllowMixedCase : bool with get, set
Property Value
Boolean


ChangeAll Method (newWord)

ChangeAll Method (newWord)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► ChangeAll(String)
Keyoti RapidSpell WPF
Changes all instances of the current bad word to newWord in the text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void ChangeAll(
    string newWord
)
public virtual void ChangeAll(
    string newWord
)
Public Overridable Sub ChangeAll (
    newWord As String
)
Public Overridable Sub ChangeAll (
    newWord As String
)
public:
virtual void ChangeAll(
    String^ newWord
)
public:
virtual void ChangeAll(
    String^ newWord
)
abstract ChangeAll :
        newWord : string -> unit
override ChangeAll :
        newWord : string -> unit
abstract ChangeAll :
        newWord : string -> unit
override ChangeAll :
        newWord : string -> unit
Parameters
newWord (String)
Exceptions
Exception | Condition
NoCurrentBadWordException | if nextBadWord() hasn't been run first AND found an erroneous word.
ArgumentNullException | if newWord parameter is null.


ChangeBadWord Method

ChangeBadWord Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► ChangeBadWord()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | ChangeBadWord(String) | Changes the current bad word to newWord in the text.
 | ChangeBadWord(BadWord, String) | Changes badWord to newWord in the text.


ChangeBadWord Method (badWord, newWord)

ChangeBadWord Method (badWord, newWord)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► ChangeBadWord(BadWord, String)
Keyoti RapidSpell WPF
Changes badWord to newWord in the text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void ChangeBadWord(
    BadWord badWord,
    string newWord
)
public virtual void ChangeBadWord(
    BadWord badWord,
    string newWord
)
Public Overridable Sub ChangeBadWord (
    badWord As BadWord,
    newWord As String
)
Public Overridable Sub ChangeBadWord (
    badWord As BadWord,
    newWord As String
)
public:
virtual void ChangeBadWord(
    BadWord^ badWord,
    String^ newWord
)
public:
virtual void ChangeBadWord(
    BadWord^ badWord,
    String^ newWord
)
abstract ChangeBadWord :
        badWord : BadWord *
        newWord : string -> unit
override ChangeBadWord :
        badWord : BadWord *
        newWord : string -> unit
abstract ChangeBadWord :
        badWord : BadWord *
        newWord : string -> unit
override ChangeBadWord :
        badWord : BadWord *
        newWord : string -> unit
Parameters
badWord (BadWord)
word to replace
newWord (String)
replaces the current misspelt word.
Return Value

void
Exceptions
Exception | Condition
ArgumentNullException | if newWord parameter is null.


ChangeBadWord Method (newWord)

ChangeBadWord Method (newWord)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► ChangeBadWord(String)
Keyoti RapidSpell WPF
Changes the current bad word to newWord in the text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void ChangeBadWord(
    string newWord
)
public void ChangeBadWord(
    string newWord
)
Public Sub ChangeBadWord (
    newWord As String
)
Public Sub ChangeBadWord (
    newWord As String
)
public:
virtual void ChangeBadWord(
    String^ newWord
) sealed
public:
virtual void ChangeBadWord(
    String^ newWord
) sealed
abstract ChangeBadWord :
        newWord : string -> unit
override ChangeBadWord :
        newWord : string -> unit
abstract ChangeBadWord :
        newWord : string -> unit
override ChangeBadWord :
        newWord : string -> unit
Parameters
newWord (String)
Replaces the current misspelt word.
Return Value

void
Exceptions
Exception | Condition
NoCurrentBadWordException | if nextBadWord() hasn't been run first AND found an erroneous word.
ArgumentNullException | if newWord parameter is null.


Check Method

Check Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► Check()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | Check(String) | Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.
 | Check(String, Boolean) | Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.
 | Check(String, Int32) | Checks text for spelling correctness, from startPosition in text, mis-spelt words can be accessed through NextBadWord.
 | Check(String, Int32, Boolean) | Checks text for spelling correctness, from startPosition in text, mis-spelt words can be accessed through NextBadWord.


Check Method (text)

Check Method (text)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► Check(String)
Keyoti RapidSpell WPF
Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void Check(
    string text
)
public void Check(
    string text
)
Public Sub Check (
    text As String
)
Public Sub Check (
    text As String
)
public:
virtual void Check(
    String^ text
) sealed
public:
virtual void Check(
    String^ text
) sealed
abstract Check :
        text : string -> unit
override Check :
        text : string -> unit
abstract Check :
        text : string -> unit
override Check :
        text : string -> unit
Parameters
text (String)
to spell check.
Return Value

void
Exceptions
Exception | Condition
ArgumentNullException | if text parameter is null.


Check Method (text, isStartOfTextBody)

Check Method (text, isStartOfTextBody)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► Check(String, Boolean)
Keyoti RapidSpell WPF
Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void Check(
    string text,
    bool isStartOfTextBody
)
public void Check(
    string text,
    bool isStartOfTextBody
)
Public Sub Check (
    text As String,
    isStartOfTextBody As Boolean
)
Public Sub Check (
    text As String,
    isStartOfTextBody As Boolean
)
public:
virtual void Check(
    String^ text,
    bool isStartOfTextBody
) sealed
public:
virtual void Check(
    String^ text,
    bool isStartOfTextBody
) sealed
abstract Check :
        text : string *
        isStartOfTextBody : bool -> unit
override Check :
        text : string *
        isStartOfTextBody : bool -> unit
abstract Check :
        text : string *
        isStartOfTextBody : bool -> unit
override Check :
        text : string *
        isStartOfTextBody : bool -> unit
Parameters
text (String)
to spell check.
isStartOfTextBody (Boolean)
whether the text being spell checked is at the start of the text body (eg. start of text box), this affects sentence capitalization determination.
Return Value

void
Exceptions
Exception | Condition
ArgumentNullException | if text parameter is null.


Check Method (text, startPosition)

Check Method (text, startPosition)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► Check(String, Int32)
Keyoti RapidSpell WPF
Checks text for spelling correctness, from startPosition in text, mis-spelt words can be accessed through NextBadWord.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void Check(
    string text,
    int startPosition
)
public void Check(
    string text,
    int startPosition
)
Public Sub Check (
    text As String,
    startPosition As Integer
)
Public Sub Check (
    text As String,
    startPosition As Integer
)
public:
void Check(
    String^ text,
    int startPosition
)
public:
void Check(
    String^ text,
    int startPosition
)
member Check :
        text : string *
        startPosition : int -> unit

member Check :
        text : string *
        startPosition : int -> unit
Parameters
text (String)
the text to be checked
startPosition (Int32)
the position in the text to begin checking from
Return Value

void
Remarks
startPosition should be >=0 but if it is < 0 it is set = 0.
Exceptions
Exception | Condition
ArgumentNullException | if text parameter is null.


Check Method (text, startPosition, isStartOfTextBody)

Check Method (text, startPosition, isStartOfTextBody)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► Check(String, Int32, Boolean)
Keyoti RapidSpell WPF
Checks text for spelling correctness, from startPosition in text, mis-spelt words can be accessed through NextBadWord.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void Check(
    string text,
    int startPosition,
    bool isStartOfTextBody
)
public virtual void Check(
    string text,
    int startPosition,
    bool isStartOfTextBody
)
Public Overridable Sub Check (
    text As String,
    startPosition As Integer,
    isStartOfTextBody As Boolean
)
Public Overridable Sub Check (
    text As String,
    startPosition As Integer,
    isStartOfTextBody As Boolean
)
public:
virtual void Check(
    String^ text,
    int startPosition,
    bool isStartOfTextBody
)
public:
virtual void Check(
    String^ text,
    int startPosition,
    bool isStartOfTextBody
)
abstract Check :
        text : string *
        startPosition : int *
        isStartOfTextBody : bool -> unit
override Check :
        text : string *
        startPosition : int *
        isStartOfTextBody : bool -> unit
abstract Check :
        text : string *
        startPosition : int *
        isStartOfTextBody : bool -> unit
override Check :
        text : string *
        startPosition : int *
        isStartOfTextBody : bool -> unit
Parameters
text (String)
the text to be checked
startPosition (Int32)
the position in the text to begin checking from
isStartOfTextBody (Boolean)
whether the text being spell checked is at the start of the text body (eg. start of text box), this affects sentence capitalization determination.
Return Value

void
Remarks
startPosition should be >=0 but if it is < 0 it is set = 0.
Exceptions
Exception | Condition
ArgumentNullException | if text parameter is null.


CheckCompoundWords Property

CheckCompoundWords Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► CheckCompoundWords
Keyoti RapidSpell WPF
Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool CheckCompoundWords { get; set; }
public bool CheckCompoundWords { get; set; }
Public Property CheckCompoundWords As Boolean
    Get
    Set
Public Property CheckCompoundWords As Boolean
    Get
    Set
public:
virtual property bool CheckCompoundWords {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool CheckCompoundWords {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract CheckCompoundWords : bool with get, set
override CheckCompoundWords : bool with get, set
abstract CheckCompoundWords : bool with get, set
override CheckCompoundWords : bool with get, set
Property Value
Boolean
Remarks
If this=false then LookUp("thesewordsarejoined") = false

If this=true then LookUp("thesewordsarejoined") = true

If this=false then LookUp("abcdef") = false

If this=true then LookUp("abcdef") = false

Setting this to true will degrade lookup performance by a maximum of approx. 100[1-1/n] percent (where n is the number of letters in the word) for misspelt words. There is no preformance degredation for correctly spelt words. On average for texts with mostly correctly spelt words the performance degredation for the Check method is roughly 25%.


convertHtmlEntities Method

convertHtmlEntities Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► convertHtmlEntities()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | convertHtmlEntities(String) | Converts HTML entity codes to their Unicode characters
 | convertHtmlEntities(String, Boolean) | Converts HTML entity codes to their Unicode characters


convertHtmlEntities Method (text)

convertHtmlEntities Method (text)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► convertHtmlEntities(String)
Keyoti RapidSpell WPF
Converts HTML entity codes to their Unicode characters
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static string convertHtmlEntities(
    string text
)
public static string convertHtmlEntities(
    string text
)
Public Shared Function convertHtmlEntities (
    text As String
) As String
Public Shared Function convertHtmlEntities (
    text As String
) As String
public:
static String^ convertHtmlEntities(
    String^ text
)
public:
static String^ convertHtmlEntities(
    String^ text
)
static member convertHtmlEntities :
        text : string -> string

static member convertHtmlEntities :
        text : string -> string
Parameters
text (String)
Return Value
String


convertHtmlEntities Method (text, convertAMP)

convertHtmlEntities Method (text, convertAMP)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► convertHtmlEntities(String, Boolean)
Keyoti RapidSpell WPF
Converts HTML entity codes to their Unicode characters
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static string convertHtmlEntities(
    string text,
    bool convertAMP
)
public static string convertHtmlEntities(
    string text,
    bool convertAMP
)
Public Shared Function convertHtmlEntities (
    text As String,
    convertAMP As Boolean
) As String
Public Shared Function convertHtmlEntities (
    text As String,
    convertAMP As Boolean
) As String
public:
static String^ convertHtmlEntities(
    String^ text,
    bool convertAMP
)
public:
static String^ convertHtmlEntities(
    String^ text,
    bool convertAMP
)
static member convertHtmlEntities :
        text : string *
        convertAMP : bool -> string

static member convertHtmlEntities :
        text : string *
        convertAMP : bool -> string
Parameters
text (String)
The text containing the entities to convert.
convertAMP (Boolean)
Whether to convert &amp; entities to &
Return Value
String


CurrentBadWord Property

CurrentBadWord Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► CurrentBadWord
Keyoti RapidSpell WPF
Gets the current bad word (last returned by NextBadWord).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public BadWord CurrentBadWord { get; }
public BadWord CurrentBadWord { get; }
Public ReadOnly Property CurrentBadWord As BadWord
    Get
Public ReadOnly Property CurrentBadWord As BadWord
    Get
public:
virtual property BadWord^ CurrentBadWord {
    BadWord^ get () sealed;
}
public:
virtual property BadWord^ CurrentBadWord {
    BadWord^ get () sealed;
}
abstract CurrentBadWord : BadWord with get
override CurrentBadWord : BadWord with get
abstract CurrentBadWord : BadWord with get
override CurrentBadWord : BadWord with get
Property Value
BadWord


DictFilePath Property

DictFilePath Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► DictFilePath
Keyoti RapidSpell WPF
The file to be used as the main dictionary (either a full file path, or the name of an embedded resource), if this is null then the built-in US English dictionary is used.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string DictFilePath { get; set; }
public string DictFilePath { get; set; }
Public Property DictFilePath As String
    Get
    Set
Public Property DictFilePath As String
    Get
    Set
public:
virtual property String^ DictFilePath {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ DictFilePath {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract DictFilePath : string with get, set
override DictFilePath : string with get, set
abstract DictFilePath : string with get, set
override DictFilePath : string with get, set
Property Value
String


Dispose Method

Dispose Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► Dispose()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | Dispose(Boolean) | Disposes of resources.
 | Dispose()()()() | Clean up any resources being used.


Dispose Method

Dispose Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► Dispose()()()()
Keyoti RapidSpell WPF
Clean up any resources being used.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void Dispose()
public virtual void Dispose()
Public Overridable Sub Dispose
Public Overridable Sub Dispose
public:
virtual void Dispose()
public:
virtual void Dispose()
abstract Dispose : unit -> unit
override Dispose : unit -> unit
abstract Dispose : unit -> unit
override Dispose : unit -> unit


Dispose Method (disposing)

Dispose Method (disposing)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► Dispose(Boolean)
Keyoti RapidSpell WPF
Disposes of resources.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void Dispose(
    bool disposing
)
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
)
protected:
virtual void Dispose(
    bool disposing
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
Parameters
disposing (Boolean)


dontSuggest Field

dontSuggest Field
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► dontSuggest
Keyoti RapidSpell WPF
Don't suggest words in this array (swear words).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected string[] dontSuggest
protected string[] dontSuggest
Protected dontSuggest As String()
Protected dontSuggest As String()
protected:
array<String^>^ dontSuggest
protected:
array<String^>^ dontSuggest
val mutable dontSuggest: string[]
val mutable dontSuggest: string[]
Field Value
array<String>[]()[][]


FindAnagrams Method (word, anagrams)

FindAnagrams Method (word, anagrams)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► FindAnagrams(String, IList)
Keyoti RapidSpell WPF
Finds anagrams of word and puts them in anagrams if not already present.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void FindAnagrams(
    string word,
    IList anagrams
)
public virtual void FindAnagrams(
    string word,
    IList anagrams
)
Public Overridable Sub FindAnagrams (
    word As String,
    anagrams As IList
)
Public Overridable Sub FindAnagrams (
    word As String,
    anagrams As IList
)
public:
virtual void FindAnagrams(
    String^ word,
    IList^ anagrams
)
public:
virtual void FindAnagrams(
    String^ word,
    IList^ anagrams
)
abstract FindAnagrams :
        word : string *
        anagrams : IList -> unit
override FindAnagrams :
        word : string *
        anagrams : IList -> unit
abstract FindAnagrams :
        word : string *
        anagrams : IList -> unit
override FindAnagrams :
        word : string *
        anagrams : IList -> unit
Parameters
word (String)
The word to find anagrams of
anagrams (IList)
A list that anagrams will be added to.
Remarks
Exceptions
Exception | Condition
ArgumentNullException | if word is null/nothing


FindCapitalizedSuggestions Property

FindCapitalizedSuggestions Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► FindCapitalizedSuggestions
Keyoti RapidSpell WPF
Whether to look for capitalized suggestions, note this will slow FindSuggestions down by about 7 times.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool FindCapitalizedSuggestions { get; set; }
public bool FindCapitalizedSuggestions { get; set; }
Public Property FindCapitalizedSuggestions As Boolean
    Get
    Set
Public Property FindCapitalizedSuggestions As Boolean
    Get
    Set
public:
virtual property bool FindCapitalizedSuggestions {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool FindCapitalizedSuggestions {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract FindCapitalizedSuggestions : bool with get, set
override FindCapitalizedSuggestions : bool with get, set
abstract FindCapitalizedSuggestions : bool with get, set
override FindCapitalizedSuggestions : bool with get, set
Property Value
Boolean


FindCompoundWords Method (text, subwords, lengthLimit)

FindCompoundWords Method (text, subwords, lengthLimit)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► FindCompoundWords(String, IList, Boolean)
Keyoti RapidSpell WPF
Finds the compound words in text and puts them in subwords, set subwords to null/nothing to just find if text has compound word formation.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool FindCompoundWords(
    string text,
    IList subwords,
    bool lengthLimit
)
public virtual bool FindCompoundWords(
    string text,
    IList subwords,
    bool lengthLimit
)
Public Overridable Function FindCompoundWords (
    text As String,
    subwords As IList,
    lengthLimit As Boolean
) As Boolean
Public Overridable Function FindCompoundWords (
    text As String,
    subwords As IList,
    lengthLimit As Boolean
) As Boolean
public:
virtual bool FindCompoundWords(
    String^ text,
    IList^ subwords,
    bool lengthLimit
)
public:
virtual bool FindCompoundWords(
    String^ text,
    IList^ subwords,
    bool lengthLimit
)
abstract FindCompoundWords :
        text : string *
        subwords : IList *
        lengthLimit : bool -> bool
override FindCompoundWords :
        text : string *
        subwords : IList *
        lengthLimit : bool -> bool
abstract FindCompoundWords :
        text : string *
        subwords : IList *
        lengthLimit : bool -> bool
override FindCompoundWords :
        text : string *
        subwords : IList *
        lengthLimit : bool -> bool
Parameters
text (String)
The text to find compound words in
subwords (IList)
A list that formative sub-words will be added to, can be null/nothing.
lengthLimit (Boolean)
Whether to restrict lookups to words under 10 characters long. Looking up compounds for very long words can cause slow downs.
Return Value
Boolean
True if text is entirely formed from compound words, False if not.
Remarks
Only adds words to list if all are valid. In other words, this will not find all words that are part of text, but only the words that all make up text.

Eg. "catchmentarea" has words "catchment" and "area" but not "cat", "me" etc.

The order of the words in the list is the reverse of their order in text.
Exceptions
Exception | Condition
ArgumentNullException | if text is null


FindSuggestions Method

FindSuggestions Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► FindSuggestions()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | FindSuggestions()()()() | Gets an enumeration of String suggestions for spelling of current bad word.
 | FindSuggestions(String) | Gets an enumeration of String suggestions for word.
 | FindSuggestions(String, Boolean) | Gets an enumeration of String suggestions for word.


FindSuggestions Method

FindSuggestions Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► FindSuggestions()()()()
Keyoti RapidSpell WPF
Gets an enumeration of String suggestions for spelling of current bad word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual ArrayList FindSuggestions()
public virtual ArrayList FindSuggestions()
Public Overridable Function FindSuggestions As ArrayList
Public Overridable Function FindSuggestions As ArrayList
public:
virtual ArrayList^ FindSuggestions()
public:
virtual ArrayList^ FindSuggestions()
abstract FindSuggestions : unit -> ArrayList
override FindSuggestions : unit -> ArrayList
abstract FindSuggestions : unit -> ArrayList
override FindSuggestions : unit -> ArrayList
Return Value
ArrayList
ArrayList of String suggestions for current bad word.
Exceptions
Exception | Condition
NoCurrentBadWordException | If NextBadWord() hasn't been run first AND found an erroneous word.


FindSuggestions Method (word)

FindSuggestions Method (word)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► FindSuggestions(String)
Keyoti RapidSpell WPF
Gets an enumeration of String suggestions for word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual ArrayList FindSuggestions(
    string word
)
public virtual ArrayList FindSuggestions(
    string word
)
Public Overridable Function FindSuggestions (
    word As String
) As ArrayList
Public Overridable Function FindSuggestions (
    word As String
) As ArrayList
public:
virtual ArrayList^ FindSuggestions(
    String^ word
)
public:
virtual ArrayList^ FindSuggestions(
    String^ word
)
abstract FindSuggestions :
        word : string -> ArrayList
override FindSuggestions :
        word : string -> ArrayList
abstract FindSuggestions :
        word : string -> ArrayList
override FindSuggestions :
        word : string -> ArrayList
Parameters
word (String)
the word to check the spelling of.
Return Value
ArrayList
ArrayList of String suggestions for word.
Exceptions
Exception | Condition
ArgumentNullException | if word parameter is null.


FindSuggestions Method (word, searchLowerCase)

FindSuggestions Method (word, searchLowerCase)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► FindSuggestions(String, Boolean)
Keyoti RapidSpell WPF
Gets an enumeration of String suggestions for word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual ArrayList FindSuggestions(
    string word,
    bool searchLowerCase
)
protected virtual ArrayList FindSuggestions(
    string word,
    bool searchLowerCase
)
Protected Overridable Function FindSuggestions (
    word As String,
    searchLowerCase As Boolean
) As ArrayList
Protected Overridable Function FindSuggestions (
    word As String,
    searchLowerCase As Boolean
) As ArrayList
protected:
virtual ArrayList^ FindSuggestions(
    String^ word,
    bool searchLowerCase
)
protected:
virtual ArrayList^ FindSuggestions(
    String^ word,
    bool searchLowerCase
)
abstract FindSuggestions :
        word : string *
        searchLowerCase : bool -> ArrayList
override FindSuggestions :
        word : string *
        searchLowerCase : bool -> ArrayList
abstract FindSuggestions :
        word : string *
        searchLowerCase : bool -> ArrayList
override FindSuggestions :
        word : string *
        searchLowerCase : bool -> ArrayList
Parameters
word (String)
the word to check the spelling of.
searchLowerCase (Boolean)
whether to return suggestions for word in a lower case form (if it's capitalized).
Return Value
ArrayList
ArrayList of String suggestions for word.
Exceptions
Exception | Condition
ArgumentNullException | if word parameter is null.


GetAmendedText Method

GetAmendedText Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► GetAmendedText()()()()
Keyoti RapidSpell WPF
Returns the original text sent to check() but with any alterations made through change
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual string GetAmendedText()
public virtual string GetAmendedText()
Public Overridable Function GetAmendedText As String
Public Overridable Function GetAmendedText As String
public:
virtual String^ GetAmendedText()
public:
virtual String^ GetAmendedText()
abstract GetAmendedText : unit -> string
override GetAmendedText : unit -> string
abstract GetAmendedText : unit -> string
override GetAmendedText : unit -> string
Return Value
String
String the text after corrections, null if there is no text.


GetConsiderationRange Method

GetConsiderationRange Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► GetConsiderationRange()()()()
Keyoti RapidSpell WPF
Gets the factor for words to consider for suggestions.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int GetConsiderationRange()
public int GetConsiderationRange()
Public Function GetConsiderationRange As Integer
Public Function GetConsiderationRange As Integer
public:
virtual int GetConsiderationRange() sealed
public:
virtual int GetConsiderationRange() sealed
abstract GetConsiderationRange : unit -> int
override GetConsiderationRange : unit -> int
abstract GetConsiderationRange : unit -> int
override GetConsiderationRange : unit -> int
Return Value
Int32


GetIgnoreCapitalizedWords Method

GetIgnoreCapitalizedWords Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► GetIgnoreCapitalizedWords()()()()
Keyoti RapidSpell WPF
Gets whether to ignore words with capital letters.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool GetIgnoreCapitalizedWords()
public bool GetIgnoreCapitalizedWords()
Public Function GetIgnoreCapitalizedWords As Boolean
Public Function GetIgnoreCapitalizedWords As Boolean
public:
virtual bool GetIgnoreCapitalizedWords() sealed
public:
virtual bool GetIgnoreCapitalizedWords() sealed
abstract GetIgnoreCapitalizedWords : unit -> bool
override GetIgnoreCapitalizedWords : unit -> bool
abstract GetIgnoreCapitalizedWords : unit -> bool
override GetIgnoreCapitalizedWords : unit -> bool
Return Value
Boolean


GetIncludeUserDictionaryInSuggestions Method

GetIncludeUserDictionaryInSuggestions Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► GetIncludeUserDictionaryInSuggestions()()()()
Keyoti RapidSpell WPF
Gets whether the user dictionary should be used in finding suggestions for misspelt words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool GetIncludeUserDictionaryInSuggestions()
public bool GetIncludeUserDictionaryInSuggestions()
Public Function GetIncludeUserDictionaryInSuggestions As Boolean
Public Function GetIncludeUserDictionaryInSuggestions As Boolean
public:
virtual bool GetIncludeUserDictionaryInSuggestions() sealed
public:
virtual bool GetIncludeUserDictionaryInSuggestions() sealed
abstract GetIncludeUserDictionaryInSuggestions : unit -> bool
override GetIncludeUserDictionaryInSuggestions : unit -> bool
abstract GetIncludeUserDictionaryInSuggestions : unit -> bool
override GetIncludeUserDictionaryInSuggestions : unit -> bool
Return Value
Boolean


GetNextWord Method

GetNextWord Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► GetNextWord()()()()
Keyoti RapidSpell WPF
Returns the next word in the text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected internal virtual string GetNextWord()
protected internal virtual string GetNextWord()
Protected Friend Overridable Function GetNextWord As String
Protected Friend Overridable Function GetNextWord As String
protected public:
virtual String^ GetNextWord()
protected public:
virtual String^ GetNextWord()
abstract GetNextWord : unit -> string
override GetNextWord : unit -> string
abstract GetNextWord : unit -> string
override GetNextWord : unit -> string
Return Value
String
String the next word in the text


GetSeparateHyphenWords Method

GetSeparateHyphenWords Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► GetSeparateHyphenWords()()()()
Keyoti RapidSpell WPF
Gets whether to treat hyphenated (-) words as separate words, default is false.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool GetSeparateHyphenWords()
public bool GetSeparateHyphenWords()
Public Function GetSeparateHyphenWords As Boolean
Public Function GetSeparateHyphenWords As Boolean
public:
bool GetSeparateHyphenWords()
public:
bool GetSeparateHyphenWords()
member GetSeparateHyphenWords : unit -> bool

member GetSeparateHyphenWords : unit -> bool
Return Value
Boolean
Remarks
For eg. if this is true text like "cheap-deals" will be treated as two words "cheap" and "deals", otherwise this will be treated as one word "cheap-deals".


GetSuggestionsMethod Method

GetSuggestionsMethod Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► GetSuggestionsMethod()()()()
Keyoti RapidSpell WPF
Gets the suggestions method to use. Either PHONETIC_SUGGESTIONS or HASHING_SUGGESTIONS
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
[ObsoleteAttribute("Please use SuggestionsMethod property instead, it can be set with the SuggestionsMethodType enum.",
    false)]
public virtual int GetSuggestionsMethod()
[ObsoleteAttribute("Please use SuggestionsMethod property instead, it can be set with the SuggestionsMethodType enum.",
    false)]
public virtual int GetSuggestionsMethod()
<ObsoleteAttribute("Please use SuggestionsMethod property instead, it can be set with the SuggestionsMethodType enum.",
    false)>
Public Overridable Function GetSuggestionsMethod As Integer
<ObsoleteAttribute("Please use SuggestionsMethod property instead, it can be set with the SuggestionsMethodType enum.",
    false)>
Public Overridable Function GetSuggestionsMethod As Integer
public:
[ObsoleteAttribute(L"Please use SuggestionsMethod property instead, it can be set with the SuggestionsMethodType enum.",
    false)]
virtual int GetSuggestionsMethod()
public:
[ObsoleteAttribute(L"Please use SuggestionsMethod property instead, it can be set with the SuggestionsMethodType enum.",
    false)]
virtual int GetSuggestionsMethod()
[<ObsoleteAttribute("Please use SuggestionsMethod property instead, it can be set with the SuggestionsMethodType enum.",
    false)>]
abstract GetSuggestionsMethod : unit -> int
[<ObsoleteAttribute("Please use SuggestionsMethod property instead, it can be set with the SuggestionsMethodType enum.",
    false)>]
override GetSuggestionsMethod : unit -> int
[<ObsoleteAttribute("Please use SuggestionsMethod property instead, it can be set with the SuggestionsMethodType enum.",
    false)>]
abstract GetSuggestionsMethod : unit -> int
[<ObsoleteAttribute("Please use SuggestionsMethod property instead, it can be set with the SuggestionsMethodType enum.",
    false)>]
override GetSuggestionsMethod : unit -> int
Return Value
Int32


GetUndoableStatePoint Method

GetUndoableStatePoint Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► GetUndoableStatePoint()()()()
Keyoti RapidSpell WPF
Gets the state of the current run, which can be stored and used with RevertToUndoableStatePoint(RapidSpellChecker..::..State)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual RapidSpellChecker..::..State GetUndoableStatePoint()
public virtual RapidSpellChecker..::..State GetUndoableStatePoint()
Public Overridable Function GetUndoableStatePoint As RapidSpellChecker..::..State
Public Overridable Function GetUndoableStatePoint As RapidSpellChecker..::..State
public:
virtual RapidSpellChecker..::..State^ GetUndoableStatePoint()
public:
virtual RapidSpellChecker..::..State^ GetUndoableStatePoint()
abstract GetUndoableStatePoint : unit -> RapidSpellChecker..::..State
override GetUndoableStatePoint : unit -> RapidSpellChecker..::..State
abstract GetUndoableStatePoint : unit -> RapidSpellChecker..::..State
override GetUndoableStatePoint : unit -> RapidSpellChecker..::..State
Return Value
RapidSpellChecker..::..State
Returns the current state, or null if not supporting undo.


HASHING_SUGGESTIONS Field

HASHING_SUGGESTIONS Field
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► HASHING_SUGGESTIONS
Keyoti RapidSpell WPF
Indicator for suggestion method (Hashing is default).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static int HASHING_SUGGESTIONS
public static int HASHING_SUGGESTIONS
Public Shared HASHING_SUGGESTIONS As Integer
Public Shared HASHING_SUGGESTIONS As Integer
public:
static int HASHING_SUGGESTIONS
public:
static int HASHING_SUGGESTIONS
static val mutable HASHING_SUGGESTIONS: int
static val mutable HASHING_SUGGESTIONS: int
Field Value
Int32


IgnoreAll Method (word)

IgnoreAll Method (word)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► IgnoreAll(String)
Keyoti RapidSpell WPF
Marks word to be ignored in rest of the text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void IgnoreAll(
    string word
)
public virtual void IgnoreAll(
    string word
)
Public Overridable Sub IgnoreAll (
    word As String
)
Public Overridable Sub IgnoreAll (
    word As String
)
public:
virtual void IgnoreAll(
    String^ word
)
public:
virtual void IgnoreAll(
    String^ word
)
abstract IgnoreAll :
        word : string -> unit
override IgnoreAll :
        word : string -> unit
abstract IgnoreAll :
        word : string -> unit
override IgnoreAll :
        word : string -> unit
Parameters
word (String)
to ignore
Return Value

void
Exceptions
Exception | Condition
ArgumentNullException | if word parameter is null.


IgnoreAllCaseInsensitive Property

IgnoreAllCaseInsensitive Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► IgnoreAllCaseInsensitive
Keyoti RapidSpell WPF
Whether Ignore All operations should be considered case insensitive (default false).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreAllCaseInsensitive { get; set; }
public bool IgnoreAllCaseInsensitive { get; set; }
Public Property IgnoreAllCaseInsensitive As Boolean
    Get
    Set
Public Property IgnoreAllCaseInsensitive As Boolean
    Get
    Set
public:
virtual property bool IgnoreAllCaseInsensitive {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool IgnoreAllCaseInsensitive {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IgnoreAllCaseInsensitive : bool with get, set
override IgnoreAllCaseInsensitive : bool with get, set
abstract IgnoreAllCaseInsensitive : bool with get, set
override IgnoreAllCaseInsensitive : bool with get, set
Property Value
Boolean


IgnoreIncorrectSentenceCapitalization Property

IgnoreIncorrectSentenceCapitalization Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► IgnoreIncorrectSentenceCapitalization
Keyoti RapidSpell WPF
Whether to ignore incorrect sentence capitalization.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreIncorrectSentenceCapitalization { get; set; }
public bool IgnoreIncorrectSentenceCapitalization { get; set; }
Public Property IgnoreIncorrectSentenceCapitalization As Boolean
    Get
    Set
Public Property IgnoreIncorrectSentenceCapitalization As Boolean
    Get
    Set
public:
virtual property bool IgnoreIncorrectSentenceCapitalization {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool IgnoreIncorrectSentenceCapitalization {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IgnoreIncorrectSentenceCapitalization : bool with get, set
override IgnoreIncorrectSentenceCapitalization : bool with get, set
abstract IgnoreIncorrectSentenceCapitalization : bool with get, set
override IgnoreIncorrectSentenceCapitalization : bool with get, set
Property Value
Boolean


IgnoreInEnglishLowerCaseI Property

IgnoreInEnglishLowerCaseI Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► IgnoreInEnglishLowerCaseI
Keyoti RapidSpell WPF
Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreInEnglishLowerCaseI { get; set; }
public bool IgnoreInEnglishLowerCaseI { get; set; }
Public Property IgnoreInEnglishLowerCaseI As Boolean
    Get
    Set
Public Property IgnoreInEnglishLowerCaseI As Boolean
    Get
    Set
public:
virtual property bool IgnoreInEnglishLowerCaseI {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool IgnoreInEnglishLowerCaseI {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IgnoreInEnglishLowerCaseI : bool with get, set
override IgnoreInEnglishLowerCaseI : bool with get, set
abstract IgnoreInEnglishLowerCaseI : bool with get, set
override IgnoreInEnglishLowerCaseI : bool with get, set
Property Value
Boolean


IgnoreList Property

IgnoreList Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► IgnoreList
Keyoti RapidSpell WPF
The words to ignore, note this list is changed by IgnoreAll.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ArrayList IgnoreList { get; }
public ArrayList IgnoreList { get; }
Public ReadOnly Property IgnoreList As ArrayList
    Get
Public ReadOnly Property IgnoreList As ArrayList
    Get
public:
virtual property ArrayList^ IgnoreList {
    ArrayList^ get () sealed;
}
public:
virtual property ArrayList^ IgnoreList {
    ArrayList^ get () sealed;
}
abstract IgnoreList : ArrayList with get
override IgnoreList : ArrayList with get
abstract IgnoreList : ArrayList with get
override IgnoreList : ArrayList with get
Property Value
ArrayList


IgnorePatternMaximumWordLength Property

IgnorePatternMaximumWordLength Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► IgnorePatternMaximumWordLength
Keyoti RapidSpell WPF
The maximum length of word that will be tested as a regex ignore pattern.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int IgnorePatternMaximumWordLength { get; set; }
public int IgnorePatternMaximumWordLength { get; set; }
Public Property IgnorePatternMaximumWordLength As Integer
    Get
    Set
Public Property IgnorePatternMaximumWordLength As Integer
    Get
    Set
public:
virtual property int IgnorePatternMaximumWordLength {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int IgnorePatternMaximumWordLength {
    int get () sealed;
    void set (int value) sealed;
}
abstract IgnorePatternMaximumWordLength : int with get, set
override IgnorePatternMaximumWordLength : int with get, set
abstract IgnorePatternMaximumWordLength : int with get, set
override IgnorePatternMaximumWordLength : int with get, set
Property Value
Int32


IgnoreRtfCodes Property

IgnoreRtfCodes Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► IgnoreRtfCodes
Keyoti RapidSpell WPF
Sets whether this should ignore Rtf (or any escaped) codes in the text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreRtfCodes { get; set; }
public bool IgnoreRtfCodes { get; set; }
Public Property IgnoreRtfCodes As Boolean
    Get
    Set
Public Property IgnoreRtfCodes As Boolean
    Get
    Set
public:
property bool IgnoreRtfCodes {
    bool get ();
    void set (bool value);
}
public:
property bool IgnoreRtfCodes {
    bool get ();
    void set (bool value);
}
member IgnoreRtfCodes : bool with get, set

member IgnoreRtfCodes : bool with get, set
Property Value
Boolean


IgnoreURLsAndEmailAddresses Property

IgnoreURLsAndEmailAddresses Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► IgnoreURLsAndEmailAddresses
Keyoti RapidSpell WPF
Whether to ignore URLs and email addresses (requires V2Parser=true)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreURLsAndEmailAddresses { get; set; }
public bool IgnoreURLsAndEmailAddresses { get; set; }
Public Property IgnoreURLsAndEmailAddresses As Boolean
    Get
    Set
Public Property IgnoreURLsAndEmailAddresses As Boolean
    Get
    Set
public:
virtual property bool IgnoreURLsAndEmailAddresses {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool IgnoreURLsAndEmailAddresses {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IgnoreURLsAndEmailAddresses : bool with get, set
override IgnoreURLsAndEmailAddresses : bool with get, set
abstract IgnoreURLsAndEmailAddresses : bool with get, set
override IgnoreURLsAndEmailAddresses : bool with get, set
Property Value
Boolean
Remarks
This will cause the following strings to be accepted as non-spelling errors;
"user@domain.com", "http://www.domain.com", "domain.co.uk" etc.


IgnoreWordsWithDigits Property

IgnoreWordsWithDigits Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► IgnoreWordsWithDigits
Keyoti RapidSpell WPF
Whether to ignore words with numbers in them (eg. A10 or 7-11).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreWordsWithDigits { get; set; }
public bool IgnoreWordsWithDigits { get; set; }
Public Property IgnoreWordsWithDigits As Boolean
    Get
    Set
Public Property IgnoreWordsWithDigits As Boolean
    Get
    Set
public:
virtual property bool IgnoreWordsWithDigits {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool IgnoreWordsWithDigits {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IgnoreWordsWithDigits : bool with get, set
override IgnoreWordsWithDigits : bool with get, set
abstract IgnoreWordsWithDigits : bool with get, set
override IgnoreWordsWithDigits : bool with get, set
Property Value
Boolean


IgnoreXML Property

IgnoreXML Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► IgnoreXML
Keyoti RapidSpell WPF
Whether to ignore XML/HTML tags, should be set true for RichTextBox support, false by default.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreXML { get; set; }
public bool IgnoreXML { get; set; }
Public Property IgnoreXML As Boolean
    Get
    Set
Public Property IgnoreXML As Boolean
    Get
    Set
public:
virtual property bool IgnoreXML {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool IgnoreXML {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IgnoreXML : bool with get, set
override IgnoreXML : bool with get, set
abstract IgnoreXML : bool with get, set
override IgnoreXML : bool with get, set
Property Value
Boolean


IsAllCaps Method (s)

IsAllCaps Method (s)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► IsAllCaps(String)
Keyoti RapidSpell WPF
Whether all chars in s are in upper case
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static bool IsAllCaps(
    string s
)
public static bool IsAllCaps(
    string s
)
Public Shared Function IsAllCaps (
    s As String
) As Boolean
Public Shared Function IsAllCaps (
    s As String
) As Boolean
public:
static bool IsAllCaps(
    String^ s
)
public:
static bool IsAllCaps(
    String^ s
)
static member IsAllCaps :
        s : string -> bool

static member IsAllCaps :
        s : string -> bool
Parameters
s (String)
Return Value
Boolean


IsStartsWithCap Method (word)

IsStartsWithCap Method (word)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► IsStartsWithCap(String)
Keyoti RapidSpell WPF
Whether first letter is a capital and rest are lower.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static bool IsStartsWithCap(
    string word
)
public static bool IsStartsWithCap(
    string word
)
Public Shared Function IsStartsWithCap (
    word As String
) As Boolean
Public Shared Function IsStartsWithCap (
    word As String
) As Boolean
public:
static bool IsStartsWithCap(
    String^ word
)
public:
static bool IsStartsWithCap(
    String^ word
)
static member IsStartsWithCap :
        word : string -> bool

static member IsStartsWithCap :
        word : string -> bool
Parameters
word (String)
Return Value
Boolean


IsWord Method (wordStart, wordEnd)

IsWord Method (wordStart, wordEnd)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► IsWord(Int32, Int32)
Keyoti RapidSpell WPF
Whether the word defined by the parameters is a word or whitespace.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected internal virtual bool IsWord(
    int wordStart,
    int wordEnd
)
protected internal virtual bool IsWord(
    int wordStart,
    int wordEnd
)
Protected Friend Overridable Function IsWord (
    wordStart As Integer,
    wordEnd As Integer
) As Boolean
Protected Friend Overridable Function IsWord (
    wordStart As Integer,
    wordEnd As Integer
) As Boolean
protected public:
virtual bool IsWord(
    int wordStart,
    int wordEnd
)
protected public:
virtual bool IsWord(
    int wordStart,
    int wordEnd
)
abstract IsWord :
        wordStart : int *
        wordEnd : int -> bool
override IsWord :
        wordStart : int *
        wordEnd : int -> bool
abstract IsWord :
        wordStart : int *
        wordEnd : int -> bool
override IsWord :
        wordStart : int *
        wordEnd : int -> bool
Parameters
wordStart (Int32)
wordEnd (Int32)
Return Value
Boolean
True if is a word, false if whitespace.


LanguageParser Property

LanguageParser Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► LanguageParser
Keyoti RapidSpell WPF
The type of language parsing to use.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public LanguageType LanguageParser { get; set; }
public LanguageType LanguageParser { get; set; }
Public Property LanguageParser As LanguageType
    Get
    Set
Public Property LanguageParser As LanguageType
    Get
    Set
public:
virtual property LanguageType LanguageParser {
    LanguageType get () sealed;
    void set (LanguageType value) sealed;
}
public:
virtual property LanguageType LanguageParser {
    LanguageType get () sealed;
    void set (LanguageType value) sealed;
}
abstract LanguageParser : LanguageType with get, set
override LanguageParser : LanguageType with get, set
abstract LanguageParser : LanguageType with get, set
override LanguageParser : LanguageType with get, set
Property Value
LanguageType
Remarks
Eg. If the dictionary is set to French, you should use the French parser.


LookForAnagrams Property

LookForAnagrams Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► LookForAnagrams
Keyoti RapidSpell WPF
Whether to look for anagrams, if true suggestion performance is slower.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool LookForAnagrams { get; set; }
public bool LookForAnagrams { get; set; }
Public Property LookForAnagrams As Boolean
    Get
    Set
Public Property LookForAnagrams As Boolean
    Get
    Set
public:
property bool LookForAnagrams {
    bool get ();
    void set (bool value);
}
public:
property bool LookForAnagrams {
    bool get ();
    void set (bool value);
}
member LookForAnagrams : bool with get, set

member LookForAnagrams : bool with get, set
Property Value
Boolean


LookIntoHyphenatedText Property

LookIntoHyphenatedText Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► LookIntoHyphenatedText
Keyoti RapidSpell WPF
Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool LookIntoHyphenatedText { get; set; }
public bool LookIntoHyphenatedText { get; set; }
Public Property LookIntoHyphenatedText As Boolean
    Get
    Set
Public Property LookIntoHyphenatedText As Boolean
    Get
    Set
public:
virtual property bool LookIntoHyphenatedText {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool LookIntoHyphenatedText {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract LookIntoHyphenatedText : bool with get, set
override LookIntoHyphenatedText : bool with get, set
abstract LookIntoHyphenatedText : bool with get, set
override LookIntoHyphenatedText : bool with get, set
Property Value
Boolean
Remarks
Eg. "socio-economic" will be checked as "socio" and "economic".


LookUp Method (query)

LookUp Method (query)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► LookUp(String)
Keyoti RapidSpell WPF
Checks if query is in the main dictionary or user.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool LookUp(
    string query
)
public virtual bool LookUp(
    string query
)
Public Overridable Function LookUp (
    query As String
) As Boolean
Public Overridable Function LookUp (
    query As String
) As Boolean
public:
virtual bool LookUp(
    String^ query
)
public:
virtual bool LookUp(
    String^ query
)
abstract LookUp :
        query : string -> bool
override LookUp :
        query : string -> bool
abstract LookUp :
        query : string -> bool
override LookUp :
        query : string -> bool
Parameters
query (String)
the word to check spelling of
Return Value
Boolean
true if spelt correctly, false if not in dictionary
Remarks
This method is inconsiderate of the words in IgnoreList.
Exceptions
Exception | Condition
ArgumentNullException | if query parameter is null.


LookUpMainDictionary Method (query)

LookUpMainDictionary Method (query)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► LookUpMainDictionary(String)
Keyoti RapidSpell WPF
Checks if query is in the word dictionary. Returns true if doesnt start with a letter or apostrophe
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual bool LookUpMainDictionary(
    string query
)
protected virtual bool LookUpMainDictionary(
    string query
)
Protected Overridable Function LookUpMainDictionary (
    query As String
) As Boolean
Protected Overridable Function LookUpMainDictionary (
    query As String
) As Boolean
protected:
virtual bool LookUpMainDictionary(
    String^ query
)
protected:
virtual bool LookUpMainDictionary(
    String^ query
)
abstract LookUpMainDictionary :
        query : string -> bool
override LookUpMainDictionary :
        query : string -> bool
abstract LookUpMainDictionary :
        query : string -> bool
override LookUpMainDictionary :
        query : string -> bool
Parameters
query (String)
the word to check spelling of
Return Value
Boolean
boolean true if spelt correctly, false if not in dictionary


LookUpUserDictionary Method (query)

LookUpUserDictionary Method (query)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► LookUpUserDictionary(String)
Keyoti RapidSpell WPF
Look up the query in the user dictionary if it exists.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual bool LookUpUserDictionary(
    string query
)
protected virtual bool LookUpUserDictionary(
    string query
)
Protected Overridable Function LookUpUserDictionary (
    query As String
) As Boolean
Protected Overridable Function LookUpUserDictionary (
    query As String
) As Boolean
protected:
virtual bool LookUpUserDictionary(
    String^ query
)
protected:
virtual bool LookUpUserDictionary(
    String^ query
)
abstract LookUpUserDictionary :
        query : string -> bool
override LookUpUserDictionary :
        query : string -> bool
abstract LookUpUserDictionary :
        query : string -> bool
override LookUpUserDictionary :
        query : string -> bool
Parameters
query (String)
Return Value
Boolean


MakeCap Method (word)

MakeCap Method (word)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► MakeCap(String)
Keyoti RapidSpell WPF
Capitalises first letter of word
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static string MakeCap(
    string word
)
public static string MakeCap(
    string word
)
Public Shared Function MakeCap (
    word As String
) As String
Public Shared Function MakeCap (
    word As String
) As String
public:
static String^ MakeCap(
    String^ word
)
public:
static String^ MakeCap(
    String^ word
)
static member MakeCap :
        word : string -> string

static member MakeCap :
        word : string -> string
Parameters
word (String)
Return Value
String


NextBadWord Method

NextBadWord Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► NextBadWord()()()()
Keyoti RapidSpell WPF
Returns the next mis-spelt word in the text, as a BadWord object.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual BadWord NextBadWord()
public virtual BadWord NextBadWord()
Public Overridable Function NextBadWord As BadWord
Public Overridable Function NextBadWord As BadWord
public:
virtual BadWord^ NextBadWord()
public:
virtual BadWord^ NextBadWord()
abstract NextBadWord : unit -> BadWord
override NextBadWord : unit -> BadWord
abstract NextBadWord : unit -> BadWord
override NextBadWord : unit -> BadWord
Return Value
BadWord
Keyoti.RapidSpell.BadWord or null if there are no more bad words.


PHONETIC_SUGGESTIONS Field

PHONETIC_SUGGESTIONS Field
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► PHONETIC_SUGGESTIONS
Keyoti RapidSpell WPF
Indicator for suggestion method (Hashing is default).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static int PHONETIC_SUGGESTIONS
public static int PHONETIC_SUGGESTIONS
Public Shared PHONETIC_SUGGESTIONS As Integer
Public Shared PHONETIC_SUGGESTIONS As Integer
public:
static int PHONETIC_SUGGESTIONS
public:
static int PHONETIC_SUGGESTIONS
static val mutable PHONETIC_SUGGESTIONS: int
static val mutable PHONETIC_SUGGESTIONS: int
Field Value
Int32


ReloadUserDictionary Method

ReloadUserDictionary Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► ReloadUserDictionary()()()()
Keyoti RapidSpell WPF
Reloads the user dictionary.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void ReloadUserDictionary()
public virtual void ReloadUserDictionary()
Public Overridable Sub ReloadUserDictionary
Public Overridable Sub ReloadUserDictionary
public:
virtual void ReloadUserDictionary()
public:
virtual void ReloadUserDictionary()
abstract ReloadUserDictionary : unit -> unit
override ReloadUserDictionary : unit -> unit
abstract ReloadUserDictionary : unit -> unit
override ReloadUserDictionary : unit -> unit
Remarks
Call this when the user dictionary is changed externally


RemoveIgnorePattern Method (p)

RemoveIgnorePattern Method (p)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► RemoveIgnorePattern(String)
Keyoti RapidSpell WPF
Removes a regex pattern to ignore (maximum of 20 can be added - IgnoreURLsAndEmailAddresses=true counts as 1).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void RemoveIgnorePattern(
    string p
)
public virtual void RemoveIgnorePattern(
    string p
)
Public Overridable Sub RemoveIgnorePattern (
    p As String
)
Public Overridable Sub RemoveIgnorePattern (
    p As String
)
public:
virtual void RemoveIgnorePattern(
    String^ p
)
public:
virtual void RemoveIgnorePattern(
    String^ p
)
abstract RemoveIgnorePattern :
        p : string -> unit
override RemoveIgnorePattern :
        p : string -> unit
abstract RemoveIgnorePattern :
        p : string -> unit
override RemoveIgnorePattern :
        p : string -> unit
Parameters
p (String)


RevertToUndoableStatePoint Method (state)

RevertToUndoableStatePoint Method (state)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► RevertToUndoableStatePoint(RapidSpellChecker..::..State)
Keyoti RapidSpell WPF
Reverts the state to what it was when GetUndoableStatePoint()()()() was called.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void RevertToUndoableStatePoint(
    RapidSpellChecker..::..State state
)
public virtual void RevertToUndoableStatePoint(
    RapidSpellChecker..::..State state
)
Public Overridable Sub RevertToUndoableStatePoint (
    state As RapidSpellChecker..::..State
)
Public Overridable Sub RevertToUndoableStatePoint (
    state As RapidSpellChecker..::..State
)
public:
virtual void RevertToUndoableStatePoint(
    RapidSpellChecker..::..State^ state
)
public:
virtual void RevertToUndoableStatePoint(
    RapidSpellChecker..::..State^ state
)
abstract RevertToUndoableStatePoint :
        state : RapidSpellChecker..::..State -> unit
override RevertToUndoableStatePoint :
        state : RapidSpellChecker..::..State -> unit
abstract RevertToUndoableStatePoint :
        state : RapidSpellChecker..::..State -> unit
override RevertToUndoableStatePoint :
        state : RapidSpellChecker..::..State -> unit
Parameters
state (RapidSpellChecker..::..State)


SetConsiderationRange Method (w)

SetConsiderationRange Method (w)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► SetConsiderationRange(Int32)
Keyoti RapidSpell WPF
Sets the factor for words to consider for suggestions, lower values are faster but consider less words for suggestions. Default is 80. If w <= 1 this method won't do anything.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void SetConsiderationRange(
    int w
)
public void SetConsiderationRange(
    int w
)
Public Sub SetConsiderationRange (
    w As Integer
)
Public Sub SetConsiderationRange (
    w As Integer
)
public:
virtual void SetConsiderationRange(
    int w
) sealed
public:
virtual void SetConsiderationRange(
    int w
) sealed
abstract SetConsiderationRange :
        w : int -> unit
override SetConsiderationRange :
        w : int -> unit
abstract SetConsiderationRange :
        w : int -> unit
override SetConsiderationRange :
        w : int -> unit
Parameters
w (Int32)


SetDictFileStream Method (dictFileStream, dictionaryID, modifiedDate)

SetDictFileStream Method (dictFileStream, dictionaryID, modifiedDate)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► SetDictFileStream(Stream, String, DateTime)
Keyoti RapidSpell WPF
Passes a Dict file as a stream, to be used for the main dictionary.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void SetDictFileStream(
    Stream dictFileStream,
    string dictionaryID,
    DateTime modifiedDate
)
public virtual void SetDictFileStream(
    Stream dictFileStream,
    string dictionaryID,
    DateTime modifiedDate
)
Public Overridable Sub SetDictFileStream (
    dictFileStream As Stream,
    dictionaryID As String,
    modifiedDate As DateTime
)
Public Overridable Sub SetDictFileStream (
    dictFileStream As Stream,
    dictionaryID As String,
    modifiedDate As DateTime
)
public:
virtual void SetDictFileStream(
    Stream^ dictFileStream,
    String^ dictionaryID,
    DateTime modifiedDate
)
public:
virtual void SetDictFileStream(
    Stream^ dictFileStream,
    String^ dictionaryID,
    DateTime modifiedDate
)
abstract SetDictFileStream :
        dictFileStream : Stream *
        dictionaryID : string *
        modifiedDate : DateTime -> unit
override SetDictFileStream :
        dictFileStream : Stream *
        dictionaryID : string *
        modifiedDate : DateTime -> unit
abstract SetDictFileStream :
        dictFileStream : Stream *
        dictionaryID : string *
        modifiedDate : DateTime -> unit
override SetDictFileStream :
        dictFileStream : Stream *
        dictionaryID : string *
        modifiedDate : DateTime -> unit
Parameters
dictFileStream (Stream)
The stream containing the dictionary
dictionaryID (String)
Any generated identity string which the spell checker can use to cache and identify this dictionary.
modifiedDate (DateTime)
The DateTime when this dictionary was modified, use Now to update the cache.
Remarks
Note this method must be set before Check is called, and the stream position must be at beginning of Dict file. The stream is NOT closed by this method.


SetIgnoreCapitalizedWords Method (v)

SetIgnoreCapitalizedWords Method (v)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► SetIgnoreCapitalizedWords(Boolean)
Keyoti RapidSpell WPF
Sets whether to ignore words with capital letters.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void SetIgnoreCapitalizedWords(
    bool v
)
public void SetIgnoreCapitalizedWords(
    bool v
)
Public Sub SetIgnoreCapitalizedWords (
    v As Boolean
)
Public Sub SetIgnoreCapitalizedWords (
    v As Boolean
)
public:
virtual void SetIgnoreCapitalizedWords(
    bool v
) sealed
public:
virtual void SetIgnoreCapitalizedWords(
    bool v
) sealed
abstract SetIgnoreCapitalizedWords :
        v : bool -> unit
override SetIgnoreCapitalizedWords :
        v : bool -> unit
abstract SetIgnoreCapitalizedWords :
        v : bool -> unit
override SetIgnoreCapitalizedWords :
        v : bool -> unit
Parameters
v (Boolean)


SetIncludeUserDictionaryInSuggestions Method (v)

SetIncludeUserDictionaryInSuggestions Method (v)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► SetIncludeUserDictionaryInSuggestions(Boolean)
Keyoti RapidSpell WPF
Sets whether the user dictionary should be used in finding suggestions for misspelt words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void SetIncludeUserDictionaryInSuggestions(
    bool v
)
public void SetIncludeUserDictionaryInSuggestions(
    bool v
)
Public Sub SetIncludeUserDictionaryInSuggestions (
    v As Boolean
)
Public Sub SetIncludeUserDictionaryInSuggestions (
    v As Boolean
)
public:
virtual void SetIncludeUserDictionaryInSuggestions(
    bool v
) sealed
public:
virtual void SetIncludeUserDictionaryInSuggestions(
    bool v
) sealed
abstract SetIncludeUserDictionaryInSuggestions :
        v : bool -> unit
override SetIncludeUserDictionaryInSuggestions :
        v : bool -> unit
abstract SetIncludeUserDictionaryInSuggestions :
        v : bool -> unit
override SetIncludeUserDictionaryInSuggestions :
        v : bool -> unit
Parameters
v (Boolean)


SetOptionalContext Method (beforeToCheckSnippet, afterToCheckSnippet)

SetOptionalContext Method (beforeToCheckSnippet, afterToCheckSnippet)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► SetOptionalContext(String, String)
Keyoti RapidSpell WPF
Provides the engine with any helpful text around the text snippet which will be passed to the Check method.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void SetOptionalContext(
    string beforeToCheckSnippet,
    string afterToCheckSnippet
)
public virtual void SetOptionalContext(
    string beforeToCheckSnippet,
    string afterToCheckSnippet
)
Public Overridable Sub SetOptionalContext (
    beforeToCheckSnippet As String,
    afterToCheckSnippet As String
)
Public Overridable Sub SetOptionalContext (
    beforeToCheckSnippet As String,
    afterToCheckSnippet As String
)
public:
virtual void SetOptionalContext(
    String^ beforeToCheckSnippet,
    String^ afterToCheckSnippet
)
public:
virtual void SetOptionalContext(
    String^ beforeToCheckSnippet,
    String^ afterToCheckSnippet
)
abstract SetOptionalContext :
        beforeToCheckSnippet : string *
        afterToCheckSnippet : string -> unit
override SetOptionalContext :
        beforeToCheckSnippet : string *
        afterToCheckSnippet : string -> unit
abstract SetOptionalContext :
        beforeToCheckSnippet : string *
        afterToCheckSnippet : string -> unit
override SetOptionalContext :
        beforeToCheckSnippet : string *
        afterToCheckSnippet : string -> unit
Parameters
beforeToCheckSnippet (String)
Any text before the to check snippet
afterToCheckSnippet (String)
Any text after the snippet
Remarks
Eg. if the document contains "This is an an example piece." and Check will be called on "an example piece", then the fact that 'an' is duplicated will not be detected. Therefore, by passing "This is an " to beforeToCheckSnippet the checker will be able to detect that an is duplicated.


SetPosition Method (pos)

SetPosition Method (pos)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► SetPosition(Int32)
Keyoti RapidSpell WPF
Sets the pointer position for the NextBadWord iterator.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void SetPosition(
    int pos
)
public virtual void SetPosition(
    int pos
)
Public Overridable Sub SetPosition (
    pos As Integer
)
Public Overridable Sub SetPosition (
    pos As Integer
)
public:
virtual void SetPosition(
    int pos
)
public:
virtual void SetPosition(
    int pos
)
abstract SetPosition :
        pos : int -> unit
override SetPosition :
        pos : int -> unit
abstract SetPosition :
        pos : int -> unit
override SetPosition :
        pos : int -> unit
Parameters
pos (Int32)
Remarks
Further calls to NextBadWord will look for the next bad word from position pos. If position > the text length it is set to the text length. If position < 0, it is set to zero.


SetSeparateHyphenWords Method (f)

SetSeparateHyphenWords Method (f)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► SetSeparateHyphenWords(Boolean)
Keyoti RapidSpell WPF
Sets whether to treat hyphenated (-) words as separate words, default is false.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void SetSeparateHyphenWords(
    bool f
)
public void SetSeparateHyphenWords(
    bool f
)
Public Sub SetSeparateHyphenWords (
    f As Boolean
)
Public Sub SetSeparateHyphenWords (
    f As Boolean
)
public:
virtual void SetSeparateHyphenWords(
    bool f
) sealed
public:
virtual void SetSeparateHyphenWords(
    bool f
) sealed
abstract SetSeparateHyphenWords :
        f : bool -> unit
override SetSeparateHyphenWords :
        f : bool -> unit
abstract SetSeparateHyphenWords :
        f : bool -> unit
override SetSeparateHyphenWords :
        f : bool -> unit
Parameters
f (Boolean)
Remarks
For eg. if this is true text like "cheap-deals" will be treated as two words "cheap" and "deals", otherwise this will be treated as one word "cheap-deals". Also see LookIntoHyphenatedText.


SetSuggestionsMethod Method (method)

SetSuggestionsMethod Method (method)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► SetSuggestionsMethod(Int32)
Keyoti RapidSpell WPF
Sets the suggestions method to use. Either PHONETIC_SUGGESTIONS or HASHING_SUGGESTIONS
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
[ObsoleteAttribute("Please use SuggestionsMethod property instead, it can be set with the SuggestionsMethodType enum.",
    false)]
public void SetSuggestionsMethod(
    int method
)
[ObsoleteAttribute("Please use SuggestionsMethod property instead, it can be set with the SuggestionsMethodType enum.",
    false)]
public void SetSuggestionsMethod(
    int method
)
<ObsoleteAttribute("Please use SuggestionsMethod property instead, it can be set with the SuggestionsMethodType enum.",
    false)>
Public Sub SetSuggestionsMethod (
    method As Integer
)
<ObsoleteAttribute("Please use SuggestionsMethod property instead, it can be set with the SuggestionsMethodType enum.",
    false)>
Public Sub SetSuggestionsMethod (
    method As Integer
)
public:
[ObsoleteAttribute(L"Please use SuggestionsMethod property instead, it can be set with the SuggestionsMethodType enum.",
    false)]
virtual void SetSuggestionsMethod(
    int method
) sealed
public:
[ObsoleteAttribute(L"Please use SuggestionsMethod property instead, it can be set with the SuggestionsMethodType enum.",
    false)]
virtual void SetSuggestionsMethod(
    int method
) sealed
[<ObsoleteAttribute("Please use SuggestionsMethod property instead, it can be set with the SuggestionsMethodType enum.",
    false)>]
abstract SetSuggestionsMethod :
        method : int -> unit
[<ObsoleteAttribute("Please use SuggestionsMethod property instead, it can be set with the SuggestionsMethodType enum.",
    false)>]
override SetSuggestionsMethod :
        method : int -> unit
[<ObsoleteAttribute("Please use SuggestionsMethod property instead, it can be set with the SuggestionsMethodType enum.",
    false)>]
abstract SetSuggestionsMethod :
        method : int -> unit
[<ObsoleteAttribute("Please use SuggestionsMethod property instead, it can be set with the SuggestionsMethodType enum.",
    false)>]
override SetSuggestionsMethod :
        method : int -> unit
Parameters
method (Int32)


SetUserDictionary Method

SetUserDictionary Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► SetUserDictionary()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | SetUserDictionary(String) | Set the user dictionary to use.
 | SetUserDictionary(UserDictionary) | Set the user dictionary to use.


SetUserDictionary Method (userDictionary)

SetUserDictionary Method (userDictionary)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► SetUserDictionary(UserDictionary)
Keyoti RapidSpell WPF
Set the user dictionary to use.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void SetUserDictionary(
    UserDictionary userDictionary
)
public void SetUserDictionary(
    UserDictionary userDictionary
)
Public Sub SetUserDictionary (
    userDictionary As UserDictionary
)
Public Sub SetUserDictionary (
    userDictionary As UserDictionary
)
public:
virtual void SetUserDictionary(
    UserDictionary^ userDictionary
) sealed
public:
virtual void SetUserDictionary(
    UserDictionary^ userDictionary
) sealed
abstract SetUserDictionary :
        userDictionary : UserDictionary -> unit
override SetUserDictionary :
        userDictionary : UserDictionary -> unit
abstract SetUserDictionary :
        userDictionary : UserDictionary -> unit
override SetUserDictionary :
        userDictionary : UserDictionary -> unit
Parameters
userDictionary (UserDictionary)
a UserDictionary object representing a user dictionary
Remarks
If the userDictionary can not be created/read it will be ignored
Exceptions
Exception | Condition
ArgumentNullException | if userDictionary is null.


SetUserDictionary Method (userDictionaryFile)

SetUserDictionary Method (userDictionaryFile)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► SetUserDictionary(String)
Keyoti RapidSpell WPF
Set the user dictionary to use.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void SetUserDictionary(
    string userDictionaryFile
)
public void SetUserDictionary(
    string userDictionaryFile
)
Public Sub SetUserDictionary (
    userDictionaryFile As String
)
Public Sub SetUserDictionary (
    userDictionaryFile As String
)
public:
virtual void SetUserDictionary(
    String^ userDictionaryFile
) sealed
public:
virtual void SetUserDictionary(
    String^ userDictionaryFile
) sealed
abstract SetUserDictionary :
        userDictionaryFile : string -> unit
override SetUserDictionary :
        userDictionaryFile : string -> unit
abstract SetUserDictionary :
        userDictionaryFile : string -> unit
override SetUserDictionary :
        userDictionaryFile : string -> unit
Parameters
userDictionaryFile (String)
a file to be used as a user dictionary
Remarks
If the userDictionary can not be created/read it will be ignored
Exceptions
Exception | Condition
ArgumentNullException | if userDictionaryFile is null


ShareDictionary Property

ShareDictionary Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► ShareDictionary
Keyoti RapidSpell WPF
Whether to share the dictionary in memory across all instances of RapidSpellChecker (false by default).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
[ObsoleteAttribute("Unnecessary, all dictionaries are cached now in a superior manner.",
    false)]
public bool ShareDictionary { get; set; }
[ObsoleteAttribute("Unnecessary, all dictionaries are cached now in a superior manner.",
    false)]
public bool ShareDictionary { get; set; }
<ObsoleteAttribute("Unnecessary, all dictionaries are cached now in a superior manner.",
    false)>
Public Property ShareDictionary As Boolean
    Get
    Set
<ObsoleteAttribute("Unnecessary, all dictionaries are cached now in a superior manner.",
    false)>
Public Property ShareDictionary As Boolean
    Get
    Set
public:
[ObsoleteAttribute(L"Unnecessary, all dictionaries are cached now in a superior manner.",
    false)]
property bool ShareDictionary {
    bool get ();
    void set (bool value);
}
public:
[ObsoleteAttribute(L"Unnecessary, all dictionaries are cached now in a superior manner.",
    false)]
property bool ShareDictionary {
    bool get ();
    void set (bool value);
}
[<ObsoleteAttribute("Unnecessary, all dictionaries are cached now in a superior manner.",
    false)>]
member ShareDictionary : bool with get, set

[<ObsoleteAttribute("Unnecessary, all dictionaries are cached now in a superior manner.",
    false)>]
member ShareDictionary : bool with get, set
Property Value
Boolean
Remarks
Setting this to true will lower memory usage if multiple instances of RapidSpellChecker are in use at once, but will mean that only one dictionary may be used at one time. This does not affect user dictionaries.

Note that all instances with this set to true should use the same dictionary. This property must be set before any spell checking begins.


SuggestionsMethod Property

SuggestionsMethod Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► SuggestionsMethod
Keyoti RapidSpell WPF
The method used for suggestions, default is Hashing
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public SuggestionsMethodType SuggestionsMethod { get; set; }
public SuggestionsMethodType SuggestionsMethod { get; set; }
Public Property SuggestionsMethod As SuggestionsMethodType
    Get
    Set
Public Property SuggestionsMethod As SuggestionsMethodType
    Get
    Set
public:
property SuggestionsMethodType SuggestionsMethod {
    SuggestionsMethodType get ();
    void set (SuggestionsMethodType value);
}
public:
property SuggestionsMethodType SuggestionsMethod {
    SuggestionsMethodType get ();
    void set (SuggestionsMethodType value);
}
member SuggestionsMethod : SuggestionsMethodType with get, set

member SuggestionsMethod : SuggestionsMethodType with get, set
Property Value
SuggestionsMethodType


SuggestSplitWords Property

SuggestSplitWords Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► SuggestSplitWords
Keyoti RapidSpell WPF
Whether to look for connected words in suggestions.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool SuggestSplitWords { get; set; }
public bool SuggestSplitWords { get; set; }
Public Property SuggestSplitWords As Boolean
    Get
    Set
Public Property SuggestSplitWords As Boolean
    Get
    Set
public:
virtual property bool SuggestSplitWords {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool SuggestSplitWords {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract SuggestSplitWords : bool with get, set
override SuggestSplitWords : bool with get, set
abstract SuggestSplitWords : bool with get, set
override SuggestSplitWords : bool with get, set
Property Value
Boolean
Remarks
if this=true then suggestions may include joined words.

Eg; suggestions for "yourhouse" will include "yourhouse"

Setting this to true (default) has a slight performance impact.


TextBoundary Property

TextBoundary Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► TextBoundary
Keyoti RapidSpell WPF
The AdvancedTextBoundary class to use to parse words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public AdvancedTextBoundary TextBoundary { get; set; }
public AdvancedTextBoundary TextBoundary { get; set; }
Public Property TextBoundary As AdvancedTextBoundary
    Get
    Set
Public Property TextBoundary As AdvancedTextBoundary
    Get
    Set
public:
virtual property AdvancedTextBoundary^ TextBoundary {
    AdvancedTextBoundary^ get () sealed;
    void set (AdvancedTextBoundary^ value) sealed;
}
public:
virtual property AdvancedTextBoundary^ TextBoundary {
    AdvancedTextBoundary^ get () sealed;
    void set (AdvancedTextBoundary^ value) sealed;
}
abstract TextBoundary : AdvancedTextBoundary with get, set
override TextBoundary : AdvancedTextBoundary with get, set
abstract TextBoundary : AdvancedTextBoundary with get, set
override TextBoundary : AdvancedTextBoundary with get, set
Property Value
AdvancedTextBoundary


theCurrentBadWord Field

theCurrentBadWord Field
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► theCurrentBadWord
Keyoti RapidSpell WPF
The current badword
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected BadWord theCurrentBadWord
protected BadWord theCurrentBadWord
Protected theCurrentBadWord As BadWord
Protected theCurrentBadWord As BadWord
protected:
BadWord^ theCurrentBadWord
protected:
BadWord^ theCurrentBadWord
val mutable theCurrentBadWord: BadWord
val mutable theCurrentBadWord: BadWord
Field Value
BadWord


theText Field

theText Field
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► theText
Keyoti RapidSpell WPF
The text being checked.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected StringBuilder theText
protected StringBuilder theText
Protected theText As StringBuilder
Protected theText As StringBuilder
protected:
StringBuilder^ theText
protected:
StringBuilder^ theText
val mutable theText: StringBuilder
val mutable theText: StringBuilder
Field Value
StringBuilder


UnloadMainDictionary Method

UnloadMainDictionary Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► UnloadMainDictionary()()()()
Keyoti RapidSpell WPF
Empties the main dictionary store.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
[ObsoleteAttribute("No longer useful because of new dictionary caching.  See release notes.",
    true)]
public void UnloadMainDictionary()
[ObsoleteAttribute("No longer useful because of new dictionary caching.  See release notes.",
    true)]
public void UnloadMainDictionary()
<ObsoleteAttribute("No longer useful because of new dictionary caching.  See release notes.",
    true)>
Public Sub UnloadMainDictionary
<ObsoleteAttribute("No longer useful because of new dictionary caching.  See release notes.",
    true)>
Public Sub UnloadMainDictionary
public:
[ObsoleteAttribute(L"No longer useful because of new dictionary caching.  See release notes.",
    true)]
void UnloadMainDictionary()
public:
[ObsoleteAttribute(L"No longer useful because of new dictionary caching.  See release notes.",
    true)]
void UnloadMainDictionary()
[<ObsoleteAttribute("No longer useful because of new dictionary caching.  See release notes.",
    true)>]
member UnloadMainDictionary : unit -> unit

[<ObsoleteAttribute("No longer useful because of new dictionary caching.  See release notes.",
    true)>]
member UnloadMainDictionary : unit -> unit


userDictionary Property

userDictionary Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► userDictionary
Keyoti RapidSpell WPF
The UserDictionary being used, may be null if no user dictionary is being used.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UserDictionary userDictionary { get; set; }
public UserDictionary userDictionary { get; set; }
Public Property userDictionary As UserDictionary
    Get
    Set
Public Property userDictionary As UserDictionary
    Get
    Set
public:
virtual property UserDictionary^ userDictionary {
    UserDictionary^ get () sealed;
    void set (UserDictionary^ value) sealed;
}
public:
virtual property UserDictionary^ userDictionary {
    UserDictionary^ get () sealed;
    void set (UserDictionary^ value) sealed;
}
abstract userDictionary : UserDictionary with get, set
override userDictionary : UserDictionary with get, set
abstract userDictionary : UserDictionary with get, set
override userDictionary : UserDictionary with get, set
Property Value
UserDictionary


V2Parser Property

V2Parser Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► V2Parser
Keyoti RapidSpell WPF
Whether to use parser version 2 - Set to false for backwards compatibility.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool V2Parser { get; set; }
public bool V2Parser { get; set; }
Public Property V2Parser As Boolean
    Get
    Set
Public Property V2Parser As Boolean
    Get
    Set
public:
virtual property bool V2Parser {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool V2Parser {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract V2Parser : bool with get, set
override V2Parser : bool with get, set
abstract V2Parser : bool with get, set
override V2Parser : bool with get, set
Property Value
Boolean


WarnDuplicates Property

WarnDuplicates Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► WarnDuplicates
Keyoti RapidSpell WPF
Whether to treat duplicate words as errors (eg. "this is is an error").
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool WarnDuplicates { get; set; }
public bool WarnDuplicates { get; set; }
Public Property WarnDuplicates As Boolean
    Get
    Set
Public Property WarnDuplicates As Boolean
    Get
    Set
public:
virtual property bool WarnDuplicates {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool WarnDuplicates {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract WarnDuplicates : bool with get, set
override WarnDuplicates : bool with get, set
abstract WarnDuplicates : bool with get, set
override WarnDuplicates : bool with get, set
Property Value
Boolean


WordAdded Event

WordAdded Event
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► WordAdded
Keyoti RapidSpell WPF
Fired when word added to user dictionary
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event WordAddedEventHandler WordAdded
public event WordAddedEventHandler WordAdded
Public Event WordAdded As WordAddedEventHandler
Public Event WordAdded As WordAddedEventHandler
public:
 event WordAddedEventHandler^ WordAdded {
    void add (WordAddedEventHandler^ value);
    void remove (WordAddedEventHandler^ value);
}
public:
 event WordAddedEventHandler^ WordAdded {
    void add (WordAddedEventHandler^ value);
    void remove (WordAddedEventHandler^ value);
}
member WordAdded : IEvent<WordAddedEventHandler,
    WordAddedEventArgs>

member WordAdded : IEvent<WordAddedEventHandler,
    WordAddedEventArgs>
Value
WordAddedEventHandler


WordChanged Event

WordChanged Event
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► WordChanged
Keyoti RapidSpell WPF
Change word event, fired when a word is changed.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event WordChangedEventHandler WordChanged
public event WordChangedEventHandler WordChanged
Public Event WordChanged As WordChangedEventHandler
Public Event WordChanged As WordChangedEventHandler
public:
 event WordChangedEventHandler^ WordChanged {
    void add (WordChangedEventHandler^ value);
    void remove (WordChangedEventHandler^ value);
}
public:
 event WordChangedEventHandler^ WordChanged {
    void add (WordChangedEventHandler^ value);
    void remove (WordChangedEventHandler^ value);
}
member WordChanged : IEvent<WordChangedEventHandler,
    WordChangedEventArgs>

member WordChanged : IEvent<WordChangedEventHandler,
    WordChangedEventArgs>
Value
WordChangedEventHandler


wordEnd Field

wordEnd Field
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► wordEnd
Keyoti RapidSpell WPF
The end index of the current word being checked/parsed.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected int wordEnd
protected int wordEnd
Protected wordEnd As Integer
Protected wordEnd As Integer
protected:
int wordEnd
protected:
int wordEnd
val mutable wordEnd: int
val mutable wordEnd: int
Field Value
Int32


WordIgnored Event

WordIgnored Event
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► WordIgnored
Keyoti RapidSpell WPF
Fired when word ignored
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event WordIgnoredEventHandler WordIgnored
public event WordIgnoredEventHandler WordIgnored
Public Event WordIgnored As WordIgnoredEventHandler
Public Event WordIgnored As WordIgnoredEventHandler
public:
 event WordIgnoredEventHandler^ WordIgnored {
    void add (WordIgnoredEventHandler^ value);
    void remove (WordIgnoredEventHandler^ value);
}
public:
 event WordIgnoredEventHandler^ WordIgnored {
    void add (WordIgnoredEventHandler^ value);
    void remove (WordIgnoredEventHandler^ value);
}
member WordIgnored : IEvent<WordIgnoredEventHandler,
    WordIgnoredEventArgs>

member WordIgnored : IEvent<WordIgnoredEventHandler,
    WordIgnoredEventArgs>
Value
WordIgnoredEventHandler


wordStart Field

wordStart Field
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► wordStart
Keyoti RapidSpell WPF
The start index of the current word being checked/parsed.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected int wordStart
protected int wordStart
Protected wordStart As Integer
Protected wordStart As Integer
protected:
int wordStart
protected:
int wordStart
val mutable wordStart: int
val mutable wordStart: int
Field Value
Int32


RapidSpellChecker.State Class

RapidSpellChecker..::..State Class
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker ► RapidSpellChecker..::..State
Keyoti RapidSpell WPF
State of the spell checker
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class State
public class State
Public Class State
Public Class State
public ref class State
public ref class State
type State =  class end
type State =  class end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RapidSpellChecker..::..State(Int32, String, BadWord) | ublic void SetUserDiction New
 | CurrentBadWord | Current misspelling
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Position | Spell checkers position in text
 | PreviousWord | Word before current word
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
RapidSpellChecker..::..State


RapidSpellChecker.State Constructor (position, previousWord, currentBadWord)

RapidSpellChecker..::..State Constructor (position, previousWord, currentBadWord)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker..::..State ► RapidSpellChecker..::..State(Int32, String, BadWord)
Keyoti RapidSpell WPF
ublic void SetUserDiction New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public State(
    int position,
    string previousWord,
    BadWord currentBadWord
)
public State(
    int position,
    string previousWord,
    BadWord currentBadWord
)
Public Sub New (
    position As Integer,
    previousWord As String,
    currentBadWord As BadWord
)
Public Sub New (
    position As Integer,
    previousWord As String,
    currentBadWord As BadWord
)
public:
State(
    int position,
    String^ previousWord,
    BadWord^ currentBadWord
)
public:
State(
    int position,
    String^ previousWord,
    BadWord^ currentBadWord
)
new :
        position : int *
        previousWord : string *
        currentBadWord : BadWord -> State
new :
        position : int *
        previousWord : string *
        currentBadWord : BadWord -> State
Parameters
position (Int32)
previousWord (String)
currentBadWord (BadWord)


CurrentBadWord Property

CurrentBadWord Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker..::..State ► CurrentBadWord
Keyoti RapidSpell WPF
Current misspelling
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public BadWord CurrentBadWord { get; set; }
public BadWord CurrentBadWord { get; set; }
Public Property CurrentBadWord As BadWord
    Get
    Set
Public Property CurrentBadWord As BadWord
    Get
    Set
public:
property BadWord^ CurrentBadWord {
    BadWord^ get ();
    void set (BadWord^ value);
}
public:
property BadWord^ CurrentBadWord {
    BadWord^ get ();
    void set (BadWord^ value);
}
member CurrentBadWord : BadWord with get, set

member CurrentBadWord : BadWord with get, set
Property Value
BadWord


Position Property

Position Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker..::..State ► Position
Keyoti RapidSpell WPF
Spell checkers position in text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int Position { get; set; }
public int Position { get; set; }
Public Property Position As Integer
    Get
    Set
Public Property Position As Integer
    Get
    Set
public:
property int Position {
    int get ();
    void set (int value);
}
public:
property int Position {
    int get ();
    void set (int value);
}
member Position : int with get, set

member Position : int with get, set
Property Value
Int32


PreviousWord Property

PreviousWord Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellChecker..::..State ► PreviousWord
Keyoti RapidSpell WPF
Word before current word
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string PreviousWord { get; set; }
public string PreviousWord { get; set; }
Public Property PreviousWord As String
    Get
    Set
Public Property PreviousWord As String
    Get
    Set
public:
property String^ PreviousWord {
    String^ get ();
    void set (String^ value);
}
public:
property String^ PreviousWord {
    String^ get ();
    void set (String^ value);
}
member PreviousWord : string with get, set

member PreviousWord : string with get, set
Property Value
String


RapidSpellDialog Class

RapidSpellDialog Class
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog
Keyoti RapidSpell WPF
RapidSpell Desktop Dialog Control, this convenience control provides design time support for RapidSpellGUI and multiple text box support.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class RapidSpellDialog : DesignableComponent
public class RapidSpellDialog : DesignableComponent
Public Class RapidSpellDialog
    Inherits DesignableComponent
Public Class RapidSpellDialog
    Inherits DesignableComponent
public ref class RapidSpellDialog : public DesignableComponent
public ref class RapidSpellDialog : public DesignableComponent
type RapidSpellDialog =
    class
        inherit DesignableComponent
    end
type RapidSpellDialog =
    class
        inherit DesignableComponent
    end
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RapidSpellDialog()()()() | Default constructor.
 | RapidSpellDialog(IContainer) | Designer constructor.
 | ActualHeight | (Inherited from FrameworkElement.)
 | ActualWidth | (Inherited from FrameworkElement.)
 | AddHandler(RoutedEvent, Delegate) | (Inherited from UIElement.)
 | AddHandler(RoutedEvent, Delegate, Boolean) | (Inherited from UIElement.)
 | AddLogicalChild(Object) | (Inherited from FrameworkElement.)
 | AddTextComponent(TextBoxBase) | Adds a TextBoxBase (TextBox, RichTextBox and derivatives) to be checked.
 | AddTextComponent(ISpellCheckableTextComponent) | Adds an ISpellCheckableTextComponent to be checked.
 | AddToEventRoute(EventRoute, RoutedEventArgs) | (Inherited from UIElement.)
 | AddVisualChild(Visual) | (Inherited from Visual.)
 | AllOperationScope | The scope that ignore-all/change-all should have.
 | AllowAnyCase | Whether to allow words spelt with incorrect case, eg. "africa", instead of "Africa", this is more relaxed than AllowMixedCase
 | AllowDrop | (Inherited from UIElement.)
 | AllowMixedCase | Whether to allow words spelt with mixed case, eg. "MIxEd"
 | AlwaysShowDialog | Whether to show dialog even when there are no errors in the text box. If set to false causes a spell check before opening the dialog, if there are no errors a message box appears instead of the dialog.
 | ApplyAnimationClock(DependencyProperty, AnimationClock) | (Inherited from UIElement.)
 | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | (Inherited from UIElement.)
 | ApplyTemplate()()()() | (Inherited from FrameworkElement.)
 | AreAnyTouchesCaptured | (Inherited from UIElement.)
 | AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
 | AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
 | AreAnyTouchesOver | (Inherited from UIElement.)
 | Arrange(Rect) | (Inherited from UIElement.)
 | ArrangeCore(Rect) | (Inherited from FrameworkElement.)
 | ArrangeOverride(Size) | (Inherited from FrameworkElement.)
 | BeginAnimation(DependencyProperty, AnimationTimeline) | (Inherited from UIElement.)
 | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | (Inherited from UIElement.)
 | BeginInit()()()() | (Inherited from FrameworkElement.)
 | BeginStoryboard(Storyboard) | (Inherited from FrameworkElement.)
 | BeginStoryboard(Storyboard, HandoffBehavior) | (Inherited from FrameworkElement.)
 | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | (Inherited from FrameworkElement.)
 | BindingGroup | (Inherited from FrameworkElement.)
 | BitmapEffect | Obsolete. (Inherited from UIElement.)
 | BitmapEffectInput | Obsolete. (Inherited from UIElement.)
 | BringIntoView()()()() | (Inherited from FrameworkElement.)
 | BringIntoView(Rect) | (Inherited from FrameworkElement.)
 | CacheMode | (Inherited from UIElement.)
 | CaptureMouse()()()() | (Inherited from UIElement.)
 | CaptureStylus()()()() | (Inherited from UIElement.)
 | CaptureTouch(TouchDevice) | (Inherited from UIElement.)
 | Check()()()() | Bring up the spell checker dialog and start checking the component set to check.
 | CheckAccess()()()() | (Inherited from DispatcherObject.)
 | CheckCompoundWords | Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
 | CheckDisabledTextBoxes | Whether to spell check textboxes which are disabled.
 | CheckerEngine | The checker engine to use, this object must implement the ICheckerEngine interface, allows customization or replacement of the spell checker.
 | CheckFromStartOfTextOnMultiples | Whether to check each textbox from the start of the text when working with multiple textboxes.
 | CheckReadOnlyTextBoxes | Whether to spell check textboxes which are readonly.
 | ClearTextComponents()()()() | Obsolete. Removes all text components from being spell checked.
 | ClearValue(DependencyProperty) | (Inherited from DependencyObject.)
 | ClearValue(DependencyPropertyKey) | (Inherited from DependencyObject.)
 | Clip | (Inherited from UIElement.)
 | ClipToBounds | (Inherited from UIElement.)
 | Close()()()() | Close the spell checker dialog window, if open.
 | CoerceValue(DependencyProperty) | (Inherited from DependencyObject.)
 | CommandBindings | (Inherited from UIElement.)
 | ConsiderationRange | Sets the factor for words to consider for suggestions, lower values are faster but consider less words for suggestions. Default is 500. If w <= 1 this method won't do anything.
 | ContextMenu | (Inherited from FrameworkElement.)
 | ContextMenuClosing | (Inherited from FrameworkElement.)
 | ContextMenuOpening | (Inherited from FrameworkElement.)
 | ControlBox | Whether a control box is displayed in the caption bar of the form.
 | CreateDialogView | Fired when an IDialogView is being created. Allows for customization
 | CreateDialogViewOptions | Fired when an IDialogViewOptions is being created. Allows for customization
 | CreateDialogViewUserDictionaryEdit | Indicates that a new IDialogViewUserDictionaryEdit is being created, also provides chance to override the default IDialogViewUserDictionaryEdit.
 | CreateDialogViewUserDictionarySelect | Indicates that a new IDialogViewUserDictionarySelect is being created, also provides chance to override the default IDialogViewUserDictionarySelect.
 | CreateUserInterfaceFormPresenter | Fired when an IUserInterfaceFormPresenter is being created. Allows for customization
 | Cursor | (Inherited from FrameworkElement.)
 | DataContext | (Inherited from FrameworkElement.)
 | DataContextChanged | (Inherited from FrameworkElement.)
 | DefaultStyleKey | (Inherited from FrameworkElement.)
 | DependencyObjectType | (Inherited from DependencyObject.)
 | DesignMode | Whether control is in design mode (Inherited from DesignableComponent.)
 | DesiredSize | (Inherited from UIElement.)
 | DictFilePath | The file to be used as the main dictionary (either a full file path, or the name of an embedded resource), if this is null then the built-in US English dictionary is used.
 | Dispatcher | (Inherited from DispatcherObject.)
 | Dispose(Boolean) | Disposes of unmanaged resources.
 | DragEnter | (Inherited from UIElement.)
 | DragLeave | (Inherited from UIElement.)
 | DragOver | (Inherited from UIElement.)
 | Drop | (Inherited from UIElement.)
 | Effect | (Inherited from UIElement.)
 | EndInit()()()() | (Inherited from FrameworkElement.)
 | Equals(Object) | (Inherited from DependencyObject.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FindCapitalizedSuggestions | Whether to look for capitalized suggestions, note this will slow FindSuggestions down by about 7 times.
 | FindCommonVisualAncestor(DependencyObject) | (Inherited from Visual.)
 | FindName(String) | (Inherited from FrameworkElement.)
 | FindResource(Object) | (Inherited from FrameworkElement.)
 | FlowDirection | (Inherited from FrameworkElement.)
 | Focus()()()() | (Inherited from UIElement.)
 | Focusable | (Inherited from UIElement.)
 | FocusableChanged | (Inherited from UIElement.)
 | FocusVisualStyle | (Inherited from FrameworkElement.)
 | ForceCursor | (Inherited from FrameworkElement.)
 | GetAnimationBaseValue(DependencyProperty) | (Inherited from UIElement.)
 | GetBindingExpression(DependencyProperty) | (Inherited from FrameworkElement.)
 | GetHashCode()()()() | (Inherited from DependencyObject.)
 | GetLayoutClip(Size) | (Inherited from FrameworkElement.)
 | GetLocalValueEnumerator()()()() | (Inherited from DependencyObject.)
 | GetTemplateChild(String) | (Inherited from FrameworkElement.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GetUIParentCore()()()() | (Inherited from FrameworkElement.)
 | GetValue(DependencyProperty) | (Inherited from DependencyObject.)
 | GetVisualChild(Int32) | (Inherited from FrameworkElement.)
 | GiveFeedback | (Inherited from UIElement.)
 | GotFocus | (Inherited from UIElement.)
 | GotKeyboardFocus | (Inherited from UIElement.)
 | GotMouseCapture | (Inherited from UIElement.)
 | GotStylusCapture | (Inherited from UIElement.)
 | GotTouchCapture | (Inherited from UIElement.)
 | GUILanguage | The language to show the UI in.
 | HasAnimatedProperties | (Inherited from UIElement.)
 | HasEffectiveKeyboardFocus | (Inherited from UIElement.)
 | Height | (Inherited from FrameworkElement.)
 | HitTestCore(PointHitTestParameters) | (Inherited from UIElement.)
 | HitTestCore(GeometryHitTestParameters) | (Inherited from UIElement.)
 | HorizontalAlignment | (Inherited from FrameworkElement.)
 | Icon | The dialog window's icon.
 | IgnoreCapitalizedWords | Whether to ignore words with capital letters.
 | IgnoreIncorrectSentenceCapitalization | Whether to ignore incorrect sentence capitalization.
 | IgnoreInEnglishLowerCaseI | Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
 | IgnoreURLsAndEmailAddresses | Whether to ignore URLs and email addresses (requires V2Parser=true)
 | IgnoreWordsWithDigits | Whether to ignore words with numbers in them (eg. A10 or 7-11).
 | IgnoreXML | Whether to ignore XML/HTML tags, false by default.
 | IncludeUserDictionaryInSuggestions | Whether the user dictionary should be used in finding suggestions for misspelt words.
 | InheritanceBehavior | (Inherited from FrameworkElement.)
 | Initialized | (Inherited from FrameworkElement.)
 | InputBindings | (Inherited from UIElement.)
 | InputHitTest(Point) | (Inherited from UIElement.)
 | InputScope | (Inherited from FrameworkElement.)
 | InvalidateArrange()()()() | (Inherited from UIElement.)
 | InvalidateMeasure()()()() | (Inherited from UIElement.)
 | InvalidateProperty(DependencyProperty) | (Inherited from DependencyObject.)
 | InvalidateVisual()()()() | (Inherited from UIElement.)
 | IsAncestorOf(DependencyObject) | (Inherited from Visual.)
 | IsArrangeValid | (Inherited from UIElement.)
 | IsDescendantOf(DependencyObject) | (Inherited from Visual.)
 | IsEnabled | (Inherited from UIElement.)
 | IsEnabledChanged | (Inherited from UIElement.)
 | IsEnabledCore | (Inherited from UIElement.)
 | IsFocused | (Inherited from UIElement.)
 | IsHitTestVisible | (Inherited from UIElement.)
 | IsHitTestVisibleChanged | (Inherited from UIElement.)
 | IsInitialized | (Inherited from FrameworkElement.)
 | IsInputMethodEnabled | (Inherited from UIElement.)
 | IsKeyboardFocused | (Inherited from UIElement.)
 | IsKeyboardFocusedChanged | (Inherited from UIElement.)
 | IsKeyboardFocusWithin | (Inherited from UIElement.)
 | IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
 | IsLoaded | (Inherited from FrameworkElement.)
 | IsManipulationEnabled | (Inherited from UIElement.)
 | IsMeasureValid | (Inherited from UIElement.)
 | IsMouseCaptured | (Inherited from UIElement.)
 | IsMouseCapturedChanged | (Inherited from UIElement.)
 | IsMouseCaptureWithin | (Inherited from UIElement.)
 | IsMouseCaptureWithinChanged | (Inherited from UIElement.)
 | IsMouseDirectlyOver | (Inherited from UIElement.)
 | IsMouseDirectlyOverChanged | (Inherited from UIElement.)
 | IsMouseOver | (Inherited from UIElement.)
 | IsSealed | (Inherited from DependencyObject.)
 | IsStylusCaptured | (Inherited from UIElement.)
 | IsStylusCapturedChanged | (Inherited from UIElement.)
 | IsStylusCaptureWithin | (Inherited from UIElement.)
 | IsStylusCaptureWithinChanged | (Inherited from UIElement.)
 | IsStylusDirectlyOver | (Inherited from UIElement.)
 | IsStylusDirectlyOverChanged | (Inherited from UIElement.)
 | IsStylusOver | (Inherited from UIElement.)
 | IsVisible | (Inherited from UIElement.)
 | IsVisibleChanged | (Inherited from UIElement.)
 | KeyDown | (Inherited from UIElement.)
 | KeyUp | (Inherited from UIElement.)
 | Language | (Inherited from FrameworkElement.)
 | LanguageParser | The type of language parsing to use.
 | LayoutTransform | (Inherited from FrameworkElement.)
 | LayoutUpdated | (Inherited from UIElement.)
 | Loaded | (Inherited from FrameworkElement.)
 | Location | Where to position dialog the first time it is opened.
 | LogicalChildren | (Inherited from FrameworkElement.)
 | LookIntoHyphenatedText | Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
 | LostFocus | (Inherited from UIElement.)
 | LostKeyboardFocus | (Inherited from UIElement.)
 | LostMouseCapture | (Inherited from UIElement.)
 | LostStylusCapture | (Inherited from UIElement.)
 | LostTouchCapture | (Inherited from UIElement.)
 | ManipulationBoundaryFeedback | (Inherited from UIElement.)
 | ManipulationCompleted | (Inherited from UIElement.)
 | ManipulationDelta | (Inherited from UIElement.)
 | ManipulationInertiaStarting | (Inherited from UIElement.)
 | ManipulationStarted | (Inherited from UIElement.)
 | ManipulationStarting | (Inherited from UIElement.)
 | Margin | (Inherited from FrameworkElement.)
 | MaxHeight | (Inherited from FrameworkElement.)
 | MaxWidth | (Inherited from FrameworkElement.)
 | Measure(Size) | (Inherited from UIElement.)
 | MeasureCore(Size) | (Inherited from FrameworkElement.)
 | MeasureOverride(Size) | (Inherited from FrameworkElement.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinHeight | (Inherited from FrameworkElement.)
 | MinWidth | (Inherited from FrameworkElement.)
 | Modal | Whether the spell checker will run modally. (Modal operation blocks the parent form)
 | ModalOwner | The owner of the checker form, when it's viewed modally.
 | MouseDown | (Inherited from UIElement.)
 | MouseEnter | (Inherited from UIElement.)
 | MouseLeave | (Inherited from UIElement.)
 | MouseLeftButtonDown | (Inherited from UIElement.)
 | MouseLeftButtonUp | (Inherited from UIElement.)
 | MouseMove | (Inherited from UIElement.)
 | MouseRightButtonDown | (Inherited from UIElement.)
 | MouseRightButtonUp | (Inherited from UIElement.)
 | MouseUp | (Inherited from UIElement.)
 | MouseWheel | (Inherited from UIElement.)
 | MoveFocus(TraversalRequest) | (Inherited from FrameworkElement.)
 | Name | (Inherited from FrameworkElement.)
 | NumberSuggestionList | Whether to number the items in the suggestion list, for quick user selection.
 | OnAccessKey(AccessKeyEventArgs) | (Inherited from UIElement.)
 | OnApplyTemplate()()()() | (Inherited from FrameworkElement.)
 | OnChildDesiredSizeChanged(UIElement) | (Inherited from UIElement.)
 | OnContextMenuClosing(ContextMenuEventArgs) | (Inherited from FrameworkElement.)
 | OnContextMenuOpening(ContextMenuEventArgs) | (Inherited from FrameworkElement.)
 | OnCreateAutomationPeer()()()() | (Inherited from UIElement.)
 | OnCreateDialogView(CreateDialogViewEventArgs) | Raises event
 | OnCreateDialogViewOptions(CreateDialogViewOptionsEventArgs) | Raises event
 | OnCreateDialogViewUserDictionaryEdit(CreateDialogViewUserDictionaryEditEventArgs) | Fires the CreateDialogViewUserDictionaryEdit event.
 | OnCreateDialogViewUserDictionarySelect(CreateDialogViewUserDictionarySelectEventArgs) | Raises event
 | OnCreateUserInterfaceFormPresenter(CreateUserInterfaceFormPresenterEventArgs) | Raises event
 | OnDpiChanged(DpiScale, DpiScale) | (Inherited from Visual.)
 | OnDragEnter(DragEventArgs) | (Inherited from UIElement.)
 | OnDragLeave(DragEventArgs) | (Inherited from UIElement.)
 | OnDragOver(DragEventArgs) | (Inherited from UIElement.)
 | OnDrop(DragEventArgs) | (Inherited from UIElement.)
 | OnGiveFeedback(GiveFeedbackEventArgs) | (Inherited from UIElement.)
 | OnGotFocus(RoutedEventArgs) | (Inherited from FrameworkElement.)
 | OnGotKeyboardFocus(KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
 | OnGotMouseCapture(MouseEventArgs) | (Inherited from UIElement.)
 | OnGotStylusCapture(StylusEventArgs) | (Inherited from UIElement.)
 | OnGotTouchCapture(TouchEventArgs) | (Inherited from UIElement.)
 | OnInitialized(EventArgs) | (Inherited from FrameworkElement.)
 | OnIsKeyboardFocusedChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsKeyboardFocusWithinChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsMouseCapturedChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsMouseCaptureWithinChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsMouseDirectlyOverChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsStylusCapturedChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsStylusCaptureWithinChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsStylusDirectlyOverChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnKeyDown(KeyEventArgs) | (Inherited from UIElement.)
 | OnKeyUp(KeyEventArgs) | (Inherited from UIElement.)
 | OnLostFocus(RoutedEventArgs) | (Inherited from UIElement.)
 | OnLostKeyboardFocus(KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
 | OnLostMouseCapture(MouseEventArgs) | (Inherited from UIElement.)
 | OnLostStylusCapture(StylusEventArgs) | (Inherited from UIElement.)
 | OnLostTouchCapture(TouchEventArgs) | (Inherited from UIElement.)
 | OnManipulationBoundaryFeedback(ManipulationBoundaryFeedbackEventArgs) | (Inherited from UIElement.)
 | OnManipulationCompleted(ManipulationCompletedEventArgs) | (Inherited from UIElement.)
 | OnManipulationDelta(ManipulationDeltaEventArgs) | (Inherited from UIElement.)
 | OnManipulationInertiaStarting(ManipulationInertiaStartingEventArgs) | (Inherited from UIElement.)
 | OnManipulationStarted(ManipulationStartedEventArgs) | (Inherited from UIElement.)
 | OnManipulationStarting(ManipulationStartingEventArgs) | (Inherited from UIElement.)
 | OnMouseDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseEnter(MouseEventArgs) | (Inherited from UIElement.)
 | OnMouseLeave(MouseEventArgs) | (Inherited from UIElement.)
 | OnMouseLeftButtonDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseLeftButtonUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseMove(MouseEventArgs) | (Inherited from UIElement.)
 | OnMouseRightButtonDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseRightButtonUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseWheel(MouseWheelEventArgs) | (Inherited from UIElement.)
 | OnPreviewDragEnter(DragEventArgs) | (Inherited from UIElement.)
 | OnPreviewDragLeave(DragEventArgs) | (Inherited from UIElement.)
 | OnPreviewDragOver(DragEventArgs) | (Inherited from UIElement.)
 | OnPreviewDrop(DragEventArgs) | (Inherited from UIElement.)
 | OnPreviewGiveFeedback(GiveFeedbackEventArgs) | (Inherited from UIElement.)
 | OnPreviewGotKeyboardFocus(KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
 | OnPreviewKeyDown(KeyEventArgs) | (Inherited from UIElement.)
 | OnPreviewKeyUp(KeyEventArgs) | (Inherited from UIElement.)
 | OnPreviewLostKeyboardFocus(KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseLeftButtonDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseLeftButtonUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseMove(MouseEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseRightButtonDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseRightButtonUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseWheel(MouseWheelEventArgs) | (Inherited from UIElement.)
 | OnPreviewQueryContinueDrag(QueryContinueDragEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusButtonDown(StylusButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusButtonUp(StylusButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusDown(StylusDownEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusInAirMove(StylusEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusInRange(StylusEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusMove(StylusEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusOutOfRange(StylusEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusSystemGesture(StylusSystemGestureEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusUp(StylusEventArgs) | (Inherited from UIElement.)
 | OnPreviewTextInput(TextCompositionEventArgs) | (Inherited from UIElement.)
 | OnPreviewTouchDown(TouchEventArgs) | (Inherited from UIElement.)
 | OnPreviewTouchMove(TouchEventArgs) | (Inherited from UIElement.)
 | OnPreviewTouchUp(TouchEventArgs) | (Inherited from UIElement.)
 | OnPropertyChanged(DependencyPropertyChangedEventArgs) | (Inherited from FrameworkElement.)
 | OnQueryContinueDrag(QueryContinueDragEventArgs) | (Inherited from UIElement.)
 | OnQueryCursor(QueryCursorEventArgs) | (Inherited from UIElement.)
 | OnRender(DrawingContext) | Renders the control (Inherited from DesignableComponent.)
 | OnRenderSizeChanged(SizeChangedInfo) | (Inherited from FrameworkElement.)
 | OnSpellCheckFinishedTextBox(TextBoxSpellCheckEventArgs) | Raises event
 | OnSpellCheckStartedTextBox(TextBoxSpellCheckEventArgs) | Raises event
 | OnStyleChanged(Style, Style) | (Inherited from FrameworkElement.)
 | OnStylusButtonDown(StylusButtonEventArgs) | (Inherited from UIElement.)
 | OnStylusButtonUp(StylusButtonEventArgs) | (Inherited from UIElement.)
 | OnStylusDown(StylusDownEventArgs) | (Inherited from UIElement.)
 | OnStylusEnter(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusInAirMove(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusInRange(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusLeave(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusMove(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusOutOfRange(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusSystemGesture(StylusSystemGestureEventArgs) | (Inherited from UIElement.)
 | OnStylusUp(StylusEventArgs) | (Inherited from UIElement.)
 | OnTextInput(TextCompositionEventArgs) | (Inherited from UIElement.)
 | OnToolTipClosing(ToolTipEventArgs) | (Inherited from FrameworkElement.)
 | OnToolTipOpening(ToolTipEventArgs) | (Inherited from FrameworkElement.)
 | OnTouchDown(TouchEventArgs) | (Inherited from UIElement.)
 | OnTouchEnter(TouchEventArgs) | (Inherited from UIElement.)
 | OnTouchLeave(TouchEventArgs) | (Inherited from UIElement.)
 | OnTouchMove(TouchEventArgs) | (Inherited from UIElement.)
 | OnTouchUp(TouchEventArgs) | (Inherited from UIElement.)
 | OnVisualChildrenChanged(DependencyObject, DependencyObject) | (Inherited from Visual.)
 | OnVisualParentChanged(DependencyObject) | (Inherited from FrameworkElement.)
 | OnWordAdded(Object, WordAddedEventArgs) | Fires WordAdded event
 | OnWordChanged(Object, WordChangedEventArgs) | Fires WordChanged event
 | OnWordChanging(Object, WordChangedEventArgs) | Fires WordChanging event
 | OnWordIgnored(Object, WordIgnoredEventArgs) | Fires WordIgnored event
 | Opacity | (Inherited from UIElement.)
 | OpacityMask | (Inherited from UIElement.)
 | Options | Object responsible for holding, loading and saving the user's spell check options.
 | OptionsEnabled | Whether to use user options.
 | OptionsFileName | The file name used to store the settings (by default in IsolatedStorage).
 | OptionsPresenter | Presenter for the user options form (IDialogViewOptions).
 | OptionsStorageLocation | Where the user's options are stored.
 | OverridesDefaultStyle | (Inherited from FrameworkElement.)
 | Parent | (Inherited from FrameworkElement.)
 | ParentLayoutInvalidated(UIElement) | (Inherited from FrameworkElement.)
 | PersistId | Obsolete. (Inherited from UIElement.)
 | PointFromScreen(Point) | (Inherited from Visual.)
 | PointToScreen(Point) | (Inherited from Visual.)
 | PredictFocus(FocusNavigationDirection) | (Inherited from FrameworkElement.)
 | PreviewDragEnter | (Inherited from UIElement.)
 | PreviewDragLeave | (Inherited from UIElement.)
 | PreviewDragOver | (Inherited from UIElement.)
 | PreviewDrop | (Inherited from UIElement.)
 | PreviewGiveFeedback | (Inherited from UIElement.)
 | PreviewGotKeyboardFocus | (Inherited from UIElement.)
 | PreviewKeyDown | (Inherited from UIElement.)
 | PreviewKeyUp | (Inherited from UIElement.)
 | PreviewLostKeyboardFocus | (Inherited from UIElement.)
 | PreviewMouseDown | (Inherited from UIElement.)
 | PreviewMouseLeftButtonDown | (Inherited from UIElement.)
 | PreviewMouseLeftButtonUp | (Inherited from UIElement.)
 | PreviewMouseMove | (Inherited from UIElement.)
 | PreviewMouseRightButtonDown | (Inherited from UIElement.)
 | PreviewMouseRightButtonUp | (Inherited from UIElement.)
 | PreviewMouseUp | (Inherited from UIElement.)
 | PreviewMouseWheel | (Inherited from UIElement.)
 | PreviewQueryContinueDrag | (Inherited from UIElement.)
 | PreviewStylusButtonDown | (Inherited from UIElement.)
 | PreviewStylusButtonUp | (Inherited from UIElement.)
 | PreviewStylusDown | (Inherited from UIElement.)
 | PreviewStylusInAirMove | (Inherited from UIElement.)
 | PreviewStylusInRange | (Inherited from UIElement.)
 | PreviewStylusMove | (Inherited from UIElement.)
 | PreviewStylusOutOfRange | (Inherited from UIElement.)
 | PreviewStylusSystemGesture | (Inherited from UIElement.)
 | PreviewStylusUp | (Inherited from UIElement.)
 | PreviewTextInput | (Inherited from UIElement.)
 | PreviewTouchDown | (Inherited from UIElement.)
 | PreviewTouchMove | (Inherited from UIElement.)
 | PreviewTouchUp | (Inherited from UIElement.)
 | QueryContinueDrag | (Inherited from UIElement.)
 | QueryCursor | (Inherited from UIElement.)
 | QueryTextBoxMultiline | Whether 'not in dictionary' text box is multiline or single line.
 | RaiseEvent(RoutedEventArgs) | (Inherited from UIElement.)
 | ReadLocalValue(DependencyProperty) | (Inherited from DependencyObject.)
 | Ready | Fired when ready to proceed with first query.
 | RecheckDocumentRequest | Fired when the text should be rechecked
 | RegisterName(String, Object) | (Inherited from FrameworkElement.)
 | ReleaseAllTouchCaptures()()()() | (Inherited from UIElement.)
 | ReleaseMouseCapture()()()() | (Inherited from UIElement.)
 | ReleaseStylusCapture()()()() | (Inherited from UIElement.)
 | ReleaseTouchCapture(TouchDevice) | (Inherited from UIElement.)
 | RemoveAllTextComponents()()()() | Removes all text components from being spell checked.
 | RemoveHandler(RoutedEvent, Delegate) | (Inherited from UIElement.)
 | RemoveLogicalChild(Object) | (Inherited from FrameworkElement.)
 | RemoveTextComponent(TextBoxBase) | Removes a TextBoxBase (TextBox, RichTextBox and derivatives) to be checked.
 | RemoveTextComponent(ISpellCheckableTextComponent) | Removes an ISpellCheckableTextComponent to be checked.
 | RemoveVisualChild(Visual) | (Inherited from Visual.)
 | RenderSize | (Inherited from UIElement.)
 | RenderTransform | (Inherited from UIElement.)
 | RenderTransformOrigin | (Inherited from UIElement.)
 | RequestBringIntoView | (Inherited from FrameworkElement.)
 | ResetIgnoredWords()()()() | Resets all ignored words, so that the document will be rechecked.
 | Resources | (Inherited from FrameworkElement.)
 | SetBinding(DependencyProperty, BindingBase) | (Inherited from FrameworkElement.)
 | SetBinding(DependencyProperty, String) | (Inherited from FrameworkElement.)
 | SetCurrentValue(DependencyProperty, Object) | (Inherited from DependencyObject.)
 | SetResourceReference(DependencyProperty, Object) | (Inherited from FrameworkElement.)
 | SetValue(DependencyProperty, Object) | (Inherited from DependencyObject.)
 | SetValue(DependencyPropertyKey, Object) | (Inherited from DependencyObject.)
 | ShouldSerializeCommandBindings()()()() | (Inherited from UIElement.)
 | ShouldSerializeInputBindings()()()() | (Inherited from UIElement.)
 | ShouldSerializeProperty(DependencyProperty) | (Inherited from DependencyObject.)
 | ShouldSerializeResources()()()() | (Inherited from FrameworkElement.)
 | ShouldSerializeStyle()()()() | (Inherited from FrameworkElement.)
 | ShouldSerializeTriggers()()()() | (Inherited from FrameworkElement.)
 | ShowContextSentence | Whether to show the query in context of it's sentence/line.
 | ShowFinishedBoxAtEnd | Whether to show the spell check complete dialog box at the end, true by default.
 | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
 | ShowOptionForCheckAsYouType | Whether to show the 'check as you type' option check box in the options form.
 | ShowOptionForMultipleUserDictionaries | Whether to allow the user to add/remove additional user dictionaries in the options form, the user is not permitted to remove the user dictionary assigned via code.
 | ShowOptionsButton | Whether to show the options button.
 | ShowUndoButton | Whether to show the undo button.
 | SizeChanged | (Inherited from FrameworkElement.)
 | SnapsToDevicePixels | (Inherited from UIElement.)
 | SourceUpdated | (Inherited from FrameworkElement.)
 | SpellCheckFinished | Fired when checking finishes
 | SpellCheckFinishedTextBox | Fired when spell check starts on a text box (used in multiple text box checking situations)
 | SpellCheckStarted | Fired when checking starts
 | SpellCheckStartedTextBox | Fired when spell check starts on a text box (used in multiple text box checking situations)
 | Style | (Inherited from FrameworkElement.)
 | StylusButtonDown | (Inherited from UIElement.)
 | StylusButtonUp | (Inherited from UIElement.)
 | StylusDown | (Inherited from UIElement.)
 | StylusEnter | (Inherited from UIElement.)
 | StylusInAirMove | (Inherited from UIElement.)
 | StylusInRange | (Inherited from UIElement.)
 | StylusLeave | (Inherited from UIElement.)
 | StylusMove | (Inherited from UIElement.)
 | StylusOutOfRange | (Inherited from UIElement.)
 | StylusPlugIns | (Inherited from UIElement.)
 | StylusSystemGesture | (Inherited from UIElement.)
 | StylusUp | (Inherited from UIElement.)
 | SuggestionsMethod | The suggestions method to use.
 | SuggestSplitWords | Whether to look for connected words in suggestions.
 | Tag | (Inherited from FrameworkElement.)
 | TargetUpdated | (Inherited from FrameworkElement.)
 | TemplatedParent | (Inherited from FrameworkElement.)
 | TextBox | The TextBox or RichTextBox to work with
 | TextBoxBasesToCheck | Array of TextBoxBases this GUI will spell check.
 | TextBoxProperty | The RapidSpellAsYouType to work with.
 | TextInput | (Inherited from UIElement.)
 | Texts | The UI texts.
 | ThirdPartyTextComponentsToCheck | Array of ISpellCheckableTextComponent this GUI will spell check.
 | ThirdPartyTextComponentToCheck | The 3rd Party Component that this GUI will spell check.
 | ToolTip | (Inherited from FrameworkElement.)
 | ToolTipClosing | (Inherited from FrameworkElement.)
 | ToolTipOpening | (Inherited from FrameworkElement.)
 | TopMost | Whether the form is 'always on top'.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | TouchDown | (Inherited from UIElement.)
 | TouchEnter | (Inherited from UIElement.)
 | TouchesCaptured | (Inherited from UIElement.)
 | TouchesCapturedWithin | (Inherited from UIElement.)
 | TouchesDirectlyOver | (Inherited from UIElement.)
 | TouchesOver | (Inherited from UIElement.)
 | TouchLeave | (Inherited from UIElement.)
 | TouchMove | (Inherited from UIElement.)
 | TouchUp | (Inherited from UIElement.)
 | TransformToAncestor(Visual) | (Inherited from Visual.)
 | TransformToAncestor(Visual3D) | (Inherited from Visual.)
 | TransformToDescendant(Visual) | (Inherited from Visual.)
 | TransformToVisual(Visual) | (Inherited from Visual.)
 | TranslatePoint(Point, UIElement) | (Inherited from UIElement.)
 | Triggers | (Inherited from FrameworkElement.)
 | TryFindResource(Object) | (Inherited from FrameworkElement.)
 | Uid | (Inherited from UIElement.)
 | Undone | Fired when an Undo occurs
 | Unloaded | (Inherited from FrameworkElement.)
 | UnregisterName(String) | (Inherited from FrameworkElement.)
 | UpdateDefaultStyle()()()() | (Inherited from FrameworkElement.)
 | UpdateLayout()()()() | (Inherited from UIElement.)
 | UseLayoutRounding | (Inherited from FrameworkElement.)
 | UserDictionaryFile | The user dictionary file, if this file doesn't exist it will be created.
 | UserInterfaceFormPresenter | The presenter (eg. RapidSpellGUIPresenter) currently in use, may be null/Nothing if not created yet.
 | UserQuery | Indicates that the user is being queried on a spelling error.
 | V2Parser | Whether to use parser version 2 - Set to false for backwards (pre v3.4) compatibility.
 | VerifyAccess()()()() | (Inherited from DispatcherObject.)
 | VerticalAlignment | (Inherited from FrameworkElement.)
 | Visibility | (Inherited from UIElement.)
 | VisualBitmapEffect | Obsolete. (Inherited from Visual.)
 | VisualBitmapEffectInput | Obsolete. (Inherited from Visual.)
 | VisualBitmapScalingMode | (Inherited from Visual.)
 | VisualCacheMode | (Inherited from Visual.)
 | VisualChildrenCount | (Inherited from FrameworkElement.)
 | VisualClearTypeHint | (Inherited from Visual.)
 | VisualClip | (Inherited from Visual.)
 | VisualEdgeMode | (Inherited from Visual.)
 | VisualEffect | (Inherited from Visual.)
 | VisualOffset | (Inherited from Visual.)
 | VisualOpacity | (Inherited from Visual.)
 | VisualOpacityMask | (Inherited from Visual.)
 | VisualParent | (Inherited from Visual.)
 | VisualScrollableAreaClip | (Inherited from Visual.)
 | VisualTextHintingMode | (Inherited from Visual.)
 | VisualTextRenderingMode | (Inherited from Visual.)
 | VisualTransform | (Inherited from Visual.)
 | VisualXSnappingGuidelines | (Inherited from Visual.)
 | VisualYSnappingGuidelines | (Inherited from Visual.)
 | WarnDuplicates | Whether to show duplicate words as errors (eg. "this is is an error").
 | Width | (Inherited from FrameworkElement.)
 | WindowStartupLocation | The dialog window's startup location.
 | WindowStyle | The dialog window's style.
 | WordAdded | Fired when word added to user dictionary
 | WordChanged | Fired when a word is changed
 | WordChanging | Fired before a word is changed
 | WordIgnored | Fired when word ignored
 | WordRemoved | Fired when a word is removed from user dictionary.
Inheritance Hierarchy
Object
 | DispatcherObject
 |  | DependencyObject
 |  |  | Visual
 |  |  |  | UIElement
 |  |  |  |  | FrameworkElement
 |  |  |  |  |  | DesignableComponent
 |  |  |  |  |  |  | RapidSpellDialog


RapidSpellDialog Constructor

RapidSpellDialog Constructor
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► RapidSpellDialog()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | RapidSpellDialog()()()() | Default constructor.
 | RapidSpellDialog(IContainer) | Designer constructor.


RapidSpellDialog Constructor

RapidSpellDialog Constructor
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► RapidSpellDialog()()()()
Keyoti RapidSpell WPF
Default constructor.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public RapidSpellDialog()
public RapidSpellDialog()
Public Sub New
Public Sub New
public:
RapidSpellDialog()
public:
RapidSpellDialog()
new : unit -> RapidSpellDialog
new : unit -> RapidSpellDialog


RapidSpellDialog Constructor (container)

RapidSpellDialog Constructor (container)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► RapidSpellDialog(IContainer)
Keyoti RapidSpell WPF
Designer constructor.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public RapidSpellDialog(
    IContainer container
)
public RapidSpellDialog(
    IContainer container
)
Public Sub New (
    container As IContainer
)
Public Sub New (
    container As IContainer
)
public:
RapidSpellDialog(
    IContainer^ container
)
public:
RapidSpellDialog(
    IContainer^ container
)
new :
        container : IContainer -> RapidSpellDialog
new :
        container : IContainer -> RapidSpellDialog
Parameters
container (IContainer)


AddTextComponent Method

AddTextComponent Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► AddTextComponent()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | AddTextComponent(TextBoxBase) | Adds a TextBoxBase (TextBox, RichTextBox and derivatives) to be checked.
 | AddTextComponent(ISpellCheckableTextComponent) | Adds an ISpellCheckableTextComponent to be checked.


AddTextComponent Method (textComponent)

AddTextComponent Method (textComponent)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► AddTextComponent(ISpellCheckableTextComponent)
Keyoti RapidSpell WPF
Adds an ISpellCheckableTextComponent to be checked.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void AddTextComponent(
    ISpellCheckableTextComponent textComponent
)
public virtual void AddTextComponent(
    ISpellCheckableTextComponent textComponent
)
Public Overridable Sub AddTextComponent (
    textComponent As ISpellCheckableTextComponent
)
Public Overridable Sub AddTextComponent (
    textComponent As ISpellCheckableTextComponent
)
public:
virtual void AddTextComponent(
    ISpellCheckableTextComponent^ textComponent
)
public:
virtual void AddTextComponent(
    ISpellCheckableTextComponent^ textComponent
)
abstract AddTextComponent :
        textComponent : ISpellCheckableTextComponent -> unit
override AddTextComponent :
        textComponent : ISpellCheckableTextComponent -> unit
abstract AddTextComponent :
        textComponent : ISpellCheckableTextComponent -> unit
override AddTextComponent :
        textComponent : ISpellCheckableTextComponent -> unit
Parameters
textComponent (ISpellCheckableTextComponent)


AddTextComponent Method (textBoxBase)

AddTextComponent Method (textBoxBase)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► AddTextComponent(TextBoxBase)
Keyoti RapidSpell WPF
Adds a TextBoxBase (TextBox, RichTextBox and derivatives) to be checked.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void AddTextComponent(
    TextBoxBase textBoxBase
)
public virtual void AddTextComponent(
    TextBoxBase textBoxBase
)
Public Overridable Sub AddTextComponent (
    textBoxBase As TextBoxBase
)
Public Overridable Sub AddTextComponent (
    textBoxBase As TextBoxBase
)
public:
virtual void AddTextComponent(
    TextBoxBase^ textBoxBase
)
public:
virtual void AddTextComponent(
    TextBoxBase^ textBoxBase
)
abstract AddTextComponent :
        textBoxBase : TextBoxBase -> unit
override AddTextComponent :
        textBoxBase : TextBoxBase -> unit
abstract AddTextComponent :
        textBoxBase : TextBoxBase -> unit
override AddTextComponent :
        textBoxBase : TextBoxBase -> unit
Parameters
textBoxBase (TextBoxBase)


AllOperationScope Property

AllOperationScope Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► AllOperationScope
Keyoti RapidSpell WPF
The scope that ignore-all/change-all should have.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public OperationScope AllOperationScope { get; set; }
public OperationScope AllOperationScope { get; set; }
Public Property AllOperationScope As OperationScope
    Get
    Set
Public Property AllOperationScope As OperationScope
    Get
    Set
public:
property OperationScope AllOperationScope {
    OperationScope get ();
    void set (OperationScope value);
}
public:
property OperationScope AllOperationScope {
    OperationScope get ();
    void set (OperationScope value);
}
member AllOperationScope : OperationScope with get, set

member AllOperationScope : OperationScope with get, set
Property Value
OperationScope


AllowAnyCase Property

AllowAnyCase Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► AllowAnyCase
Keyoti RapidSpell WPF
Whether to allow words spelt with incorrect case, eg. "africa", instead of "Africa", this is more relaxed than AllowMixedCase
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool AllowAnyCase { get; set; }
public bool AllowAnyCase { get; set; }
Public Property AllowAnyCase As Boolean
    Get
    Set
Public Property AllowAnyCase As Boolean
    Get
    Set
public:
property bool AllowAnyCase {
    bool get ();
    void set (bool value);
}
public:
property bool AllowAnyCase {
    bool get ();
    void set (bool value);
}
member AllowAnyCase : bool with get, set

member AllowAnyCase : bool with get, set
Property Value
Boolean


AllowMixedCase Property

AllowMixedCase Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► AllowMixedCase
Keyoti RapidSpell WPF
Whether to allow words spelt with mixed case, eg. "MIxEd"
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool AllowMixedCase { get; set; }
public bool AllowMixedCase { get; set; }
Public Property AllowMixedCase As Boolean
    Get
    Set
Public Property AllowMixedCase As Boolean
    Get
    Set
public:
property bool AllowMixedCase {
    bool get ();
    void set (bool value);
}
public:
property bool AllowMixedCase {
    bool get ();
    void set (bool value);
}
member AllowMixedCase : bool with get, set

member AllowMixedCase : bool with get, set
Property Value
Boolean


AlwaysShowDialog Property

AlwaysShowDialog Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► AlwaysShowDialog
Keyoti RapidSpell WPF
Whether to show dialog even when there are no errors in the text box. If set to false causes a spell check before opening the dialog, if there are no errors a message box appears instead of the dialog.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool AlwaysShowDialog { get; set; }
public bool AlwaysShowDialog { get; set; }
Public Property AlwaysShowDialog As Boolean
    Get
    Set
Public Property AlwaysShowDialog As Boolean
    Get
    Set
public:
property bool AlwaysShowDialog {
    bool get ();
    void set (bool value);
}
public:
property bool AlwaysShowDialog {
    bool get ();
    void set (bool value);
}
member AlwaysShowDialog : bool with get, set

member AlwaysShowDialog : bool with get, set
Property Value
Boolean


Check Method

Check Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► Check()()()()
Keyoti RapidSpell WPF
Bring up the spell checker dialog and start checking the component set to check.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void Check()
public void Check()
Public Sub Check
Public Sub Check
public:
void Check()
public:
void Check()
member Check : unit -> unit

member Check : unit -> unit
Exceptions
Exception | Condition
NoTextComponentException | if text component to check hasn't been set first with a TextBoxBase or 3rd Party component.


CheckCompoundWords Property

CheckCompoundWords Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► CheckCompoundWords
Keyoti RapidSpell WPF
Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool CheckCompoundWords { get; set; }
public bool CheckCompoundWords { get; set; }
Public Property CheckCompoundWords As Boolean
    Get
    Set
Public Property CheckCompoundWords As Boolean
    Get
    Set
public:
property bool CheckCompoundWords {
    bool get ();
    void set (bool value);
}
public:
property bool CheckCompoundWords {
    bool get ();
    void set (bool value);
}
member CheckCompoundWords : bool with get, set

member CheckCompoundWords : bool with get, set
Property Value
Boolean
Remarks
If this=false then LookUp("thesewordsarejoined") = false

If this=true then LookUp("thesewordsarejoined") = true

If this=false then LookUp("abcdef") = false

If this=true then LookUp("abcdef") = false

Setting this to true will degrade lookup performance


CheckDisabledTextBoxes Property

CheckDisabledTextBoxes Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► CheckDisabledTextBoxes
Keyoti RapidSpell WPF
Whether to spell check textboxes which are disabled.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool CheckDisabledTextBoxes { get; set; }
public bool CheckDisabledTextBoxes { get; set; }
Public Property CheckDisabledTextBoxes As Boolean
    Get
    Set
Public Property CheckDisabledTextBoxes As Boolean
    Get
    Set
public:
property bool CheckDisabledTextBoxes {
    bool get ();
    void set (bool value);
}
public:
property bool CheckDisabledTextBoxes {
    bool get ();
    void set (bool value);
}
member CheckDisabledTextBoxes : bool with get, set

member CheckDisabledTextBoxes : bool with get, set
Property Value
Boolean


CheckerEngine Property

CheckerEngine Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► CheckerEngine
Keyoti RapidSpell WPF
The checker engine to use, this object must implement the ICheckerEngine interface, allows customization or replacement of the spell checker.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ICheckerEngine CheckerEngine { get; set; }
public ICheckerEngine CheckerEngine { get; set; }
Public Property CheckerEngine As ICheckerEngine
    Get
    Set
Public Property CheckerEngine As ICheckerEngine
    Get
    Set
public:
property ICheckerEngine^ CheckerEngine {
    ICheckerEngine^ get ();
    void set (ICheckerEngine^ value);
}
public:
property ICheckerEngine^ CheckerEngine {
    ICheckerEngine^ get ();
    void set (ICheckerEngine^ value);
}
member CheckerEngine : ICheckerEngine with get, set

member CheckerEngine : ICheckerEngine with get, set
Property Value
ICheckerEngine
Remarks
Use this property to replace the object used to perform checking, it is not necessary to replace this with a spell checker, any type of word parser can be used. For example an abbreviations checker could be written to replace common words with abbreviations. Caveat: Most behavior properties in RapidSpellDialog are mirrors of properties in ICheckerEngine; any values set in ICheckerEngine will be overwritten by values set in RapidSpellDialog.


CheckFromStartOfTextOnMultiples Property

CheckFromStartOfTextOnMultiples Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► CheckFromStartOfTextOnMultiples
Keyoti RapidSpell WPF
Whether to check each textbox from the start of the text when working with multiple textboxes.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool CheckFromStartOfTextOnMultiples { get; set; }
public bool CheckFromStartOfTextOnMultiples { get; set; }
Public Property CheckFromStartOfTextOnMultiples As Boolean
    Get
    Set
Public Property CheckFromStartOfTextOnMultiples As Boolean
    Get
    Set
public:
property bool CheckFromStartOfTextOnMultiples {
    bool get ();
    void set (bool value);
}
public:
property bool CheckFromStartOfTextOnMultiples {
    bool get ();
    void set (bool value);
}
member CheckFromStartOfTextOnMultiples : bool with get, set

member CheckFromStartOfTextOnMultiples : bool with get, set
Property Value
Boolean


CheckReadOnlyTextBoxes Property

CheckReadOnlyTextBoxes Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► CheckReadOnlyTextBoxes
Keyoti RapidSpell WPF
Whether to spell check textboxes which are readonly.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool CheckReadOnlyTextBoxes { get; set; }
public bool CheckReadOnlyTextBoxes { get; set; }
Public Property CheckReadOnlyTextBoxes As Boolean
    Get
    Set
Public Property CheckReadOnlyTextBoxes As Boolean
    Get
    Set
public:
property bool CheckReadOnlyTextBoxes {
    bool get ();
    void set (bool value);
}
public:
property bool CheckReadOnlyTextBoxes {
    bool get ();
    void set (bool value);
}
member CheckReadOnlyTextBoxes : bool with get, set

member CheckReadOnlyTextBoxes : bool with get, set
Property Value
Boolean


ClearTextComponents Method

ClearTextComponents Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► ClearTextComponents()()()()
Keyoti RapidSpell WPF
Removes all text components from being spell checked.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
[ObsoleteAttribute("This method has been renamed, please call RemoveAllTextComponents() instead.",
    false)]
public void ClearTextComponents()
[ObsoleteAttribute("This method has been renamed, please call RemoveAllTextComponents() instead.",
    false)]
public void ClearTextComponents()
<ObsoleteAttribute("This method has been renamed, please call RemoveAllTextComponents() instead.",
    false)>
Public Sub ClearTextComponents
<ObsoleteAttribute("This method has been renamed, please call RemoveAllTextComponents() instead.",
    false)>
Public Sub ClearTextComponents
public:
[ObsoleteAttribute(L"This method has been renamed, please call RemoveAllTextComponents() instead.",
    false)]
void ClearTextComponents()
public:
[ObsoleteAttribute(L"This method has been renamed, please call RemoveAllTextComponents() instead.",
    false)]
void ClearTextComponents()
[<ObsoleteAttribute("This method has been renamed, please call RemoveAllTextComponents() instead.",
    false)>]
member ClearTextComponents : unit -> unit

[<ObsoleteAttribute("This method has been renamed, please call RemoveAllTextComponents() instead.",
    false)>]
member ClearTextComponents : unit -> unit


Close Method

Close Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► Close()()()()
Keyoti RapidSpell WPF
Close the spell checker dialog window, if open.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void Close()
public void Close()
Public Sub Close
Public Sub Close
public:
void Close()
public:
void Close()
member Close : unit -> unit

member Close : unit -> unit


ConsiderationRange Property

ConsiderationRange Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► ConsiderationRange
Keyoti RapidSpell WPF
Sets the factor for words to consider for suggestions, lower values are faster but consider less words for suggestions. Default is 500. If w <= 1 this method won't do anything.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int ConsiderationRange { get; set; }
public int ConsiderationRange { get; set; }
Public Property ConsiderationRange As Integer
    Get
    Set
Public Property ConsiderationRange As Integer
    Get
    Set
public:
property int ConsiderationRange {
    int get ();
    void set (int value);
}
public:
property int ConsiderationRange {
    int get ();
    void set (int value);
}
member ConsiderationRange : int with get, set

member ConsiderationRange : int with get, set
Property Value
Int32


ControlBox Property

ControlBox Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► ControlBox
Keyoti RapidSpell WPF
Whether a control box is displayed in the caption bar of the form.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ControlBox { get; set; }
public bool ControlBox { get; set; }
Public Property ControlBox As Boolean
    Get
    Set
Public Property ControlBox As Boolean
    Get
    Set
public:
property bool ControlBox {
    bool get ();
    void set (bool value);
}
public:
property bool ControlBox {
    bool get ();
    void set (bool value);
}
member ControlBox : bool with get, set

member ControlBox : bool with get, set
Property Value
Boolean


CreateDialogView Event

CreateDialogView Event
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► CreateDialogView
Keyoti RapidSpell WPF
Fired when an IDialogView is being created. Allows for customization
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event CreateDialogViewEventHandler CreateDialogView
public event CreateDialogViewEventHandler CreateDialogView
Public Event CreateDialogView As CreateDialogViewEventHandler
Public Event CreateDialogView As CreateDialogViewEventHandler
public:
 event CreateDialogViewEventHandler^ CreateDialogView {
    void add (CreateDialogViewEventHandler^ value);
    void remove (CreateDialogViewEventHandler^ value);
}
public:
 event CreateDialogViewEventHandler^ CreateDialogView {
    void add (CreateDialogViewEventHandler^ value);
    void remove (CreateDialogViewEventHandler^ value);
}
member CreateDialogView : IEvent<CreateDialogViewEventHandler,
    CreateDialogViewEventArgs>

member CreateDialogView : IEvent<CreateDialogViewEventHandler,
    CreateDialogViewEventArgs>
Value
CreateDialogViewEventHandler


CreateDialogViewOptions Event

CreateDialogViewOptions Event
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► CreateDialogViewOptions
Keyoti RapidSpell WPF
Fired when an IDialogViewOptions is being created. Allows for customization
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event CreateDialogViewOptionsEventHandler CreateDialogViewOptions
public event CreateDialogViewOptionsEventHandler CreateDialogViewOptions
Public Event CreateDialogViewOptions As CreateDialogViewOptionsEventHandler
Public Event CreateDialogViewOptions As CreateDialogViewOptionsEventHandler
public:
 event CreateDialogViewOptionsEventHandler^ CreateDialogViewOptions {
    void add (CreateDialogViewOptionsEventHandler^ value);
    void remove (CreateDialogViewOptionsEventHandler^ value);
}
public:
 event CreateDialogViewOptionsEventHandler^ CreateDialogViewOptions {
    void add (CreateDialogViewOptionsEventHandler^ value);
    void remove (CreateDialogViewOptionsEventHandler^ value);
}
member CreateDialogViewOptions : IEvent<CreateDialogViewOptionsEventHandler,
    CreateDialogViewOptionsEventArgs>

member CreateDialogViewOptions : IEvent<CreateDialogViewOptionsEventHandler,
    CreateDialogViewOptionsEventArgs>
Value
CreateDialogViewOptionsEventHandler


CreateDialogViewUserDictionaryEdit Event

CreateDialogViewUserDictionaryEdit Event
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► CreateDialogViewUserDictionaryEdit
Keyoti RapidSpell WPF
Indicates that a new IDialogViewUserDictionaryEdit is being created, also provides chance to override the default IDialogViewUserDictionaryEdit.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event CreateDialogViewUserDictionaryEditEventHandler CreateDialogViewUserDictionaryEdit
public event CreateDialogViewUserDictionaryEditEventHandler CreateDialogViewUserDictionaryEdit
Public Event CreateDialogViewUserDictionaryEdit As CreateDialogViewUserDictionaryEditEventHandler
Public Event CreateDialogViewUserDictionaryEdit As CreateDialogViewUserDictionaryEditEventHandler
public:
 event CreateDialogViewUserDictionaryEditEventHandler^ CreateDialogViewUserDictionaryEdit {
    void add (CreateDialogViewUserDictionaryEditEventHandler^ value);
    void remove (CreateDialogViewUserDictionaryEditEventHandler^ value);
}
public:
 event CreateDialogViewUserDictionaryEditEventHandler^ CreateDialogViewUserDictionaryEdit {
    void add (CreateDialogViewUserDictionaryEditEventHandler^ value);
    void remove (CreateDialogViewUserDictionaryEditEventHandler^ value);
}
member CreateDialogViewUserDictionaryEdit : IEvent<CreateDialogViewUserDictionaryEditEventHandler,
    CreateDialogViewUserDictionaryEditEventArgs>

member CreateDialogViewUserDictionaryEdit : IEvent<CreateDialogViewUserDictionaryEditEventHandler,
    CreateDialogViewUserDictionaryEditEventArgs>
Value
CreateDialogViewUserDictionaryEditEventHandler


CreateDialogViewUserDictionarySelect Event

CreateDialogViewUserDictionarySelect Event
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► CreateDialogViewUserDictionarySelect
Keyoti RapidSpell WPF
Indicates that a new IDialogViewUserDictionarySelect is being created, also provides chance to override the default IDialogViewUserDictionarySelect.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event CreateDialogViewUserDictionarySelectEventHandler CreateDialogViewUserDictionarySelect
public event CreateDialogViewUserDictionarySelectEventHandler CreateDialogViewUserDictionarySelect
Public Event CreateDialogViewUserDictionarySelect As CreateDialogViewUserDictionarySelectEventHandler
Public Event CreateDialogViewUserDictionarySelect As CreateDialogViewUserDictionarySelectEventHandler
public:
 event CreateDialogViewUserDictionarySelectEventHandler^ CreateDialogViewUserDictionarySelect {
    void add (CreateDialogViewUserDictionarySelectEventHandler^ value);
    void remove (CreateDialogViewUserDictionarySelectEventHandler^ value);
}
public:
 event CreateDialogViewUserDictionarySelectEventHandler^ CreateDialogViewUserDictionarySelect {
    void add (CreateDialogViewUserDictionarySelectEventHandler^ value);
    void remove (CreateDialogViewUserDictionarySelectEventHandler^ value);
}
member CreateDialogViewUserDictionarySelect : IEvent<CreateDialogViewUserDictionarySelectEventHandler,
    CreateDialogViewUserDictionarySelectEventArgs>

member CreateDialogViewUserDictionarySelect : IEvent<CreateDialogViewUserDictionarySelectEventHandler,
    CreateDialogViewUserDictionarySelectEventArgs>
Value
CreateDialogViewUserDictionarySelectEventHandler


CreateUserInterfaceFormPresenter Event

CreateUserInterfaceFormPresenter Event
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► CreateUserInterfaceFormPresenter
Keyoti RapidSpell WPF
Fired when an IUserInterfaceFormPresenter is being created. Allows for customization
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event CreateUserInterfaceFormPresenterEventHandler CreateUserInterfaceFormPresenter
public event CreateUserInterfaceFormPresenterEventHandler CreateUserInterfaceFormPresenter
Public Event CreateUserInterfaceFormPresenter As CreateUserInterfaceFormPresenterEventHandler
Public Event CreateUserInterfaceFormPresenter As CreateUserInterfaceFormPresenterEventHandler
public:
 event CreateUserInterfaceFormPresenterEventHandler^ CreateUserInterfaceFormPresenter {
    void add (CreateUserInterfaceFormPresenterEventHandler^ value);
    void remove (CreateUserInterfaceFormPresenterEventHandler^ value);
}
public:
 event CreateUserInterfaceFormPresenterEventHandler^ CreateUserInterfaceFormPresenter {
    void add (CreateUserInterfaceFormPresenterEventHandler^ value);
    void remove (CreateUserInterfaceFormPresenterEventHandler^ value);
}
member CreateUserInterfaceFormPresenter : IEvent<CreateUserInterfaceFormPresenterEventHandler,
    CreateUserInterfaceFormPresenterEventArgs>

member CreateUserInterfaceFormPresenter : IEvent<CreateUserInterfaceFormPresenterEventHandler,
    CreateUserInterfaceFormPresenterEventArgs>
Value
CreateUserInterfaceFormPresenterEventHandler


DictFilePath Property

DictFilePath Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► DictFilePath
Keyoti RapidSpell WPF
The file to be used as the main dictionary (either a full file path, or the name of an embedded resource), if this is null then the built-in US English dictionary is used.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string DictFilePath { get; set; }
public string DictFilePath { get; set; }
Public Property DictFilePath As String
    Get
    Set
Public Property DictFilePath As String
    Get
    Set
public:
property String^ DictFilePath {
    String^ get ();
    void set (String^ value);
}
public:
property String^ DictFilePath {
    String^ get ();
    void set (String^ value);
}
member DictFilePath : string with get, set

member DictFilePath : string with get, set
Property Value
String


Dispose Method (disposing)

Dispose Method (disposing)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► Dispose(Boolean)
Keyoti RapidSpell WPF
Disposes of unmanaged resources.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected void Dispose(
    bool disposing
)
protected void Dispose(
    bool disposing
)
Protected Sub Dispose (
    disposing As Boolean
)
Protected Sub Dispose (
    disposing As Boolean
)
protected:
void Dispose(
    bool disposing
)
protected:
void Dispose(
    bool disposing
)
member Dispose :
        disposing : bool -> unit

member Dispose :
        disposing : bool -> unit
Parameters
disposing (Boolean)


FindCapitalizedSuggestions Property

FindCapitalizedSuggestions Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► FindCapitalizedSuggestions
Keyoti RapidSpell WPF
Whether to look for capitalized suggestions, note this will slow FindSuggestions down by about 7 times.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool FindCapitalizedSuggestions { get; set; }
public bool FindCapitalizedSuggestions { get; set; }
Public Property FindCapitalizedSuggestions As Boolean
    Get
    Set
Public Property FindCapitalizedSuggestions As Boolean
    Get
    Set
public:
property bool FindCapitalizedSuggestions {
    bool get ();
    void set (bool value);
}
public:
property bool FindCapitalizedSuggestions {
    bool get ();
    void set (bool value);
}
member FindCapitalizedSuggestions : bool with get, set

member FindCapitalizedSuggestions : bool with get, set
Property Value
Boolean


GUILanguage Property

GUILanguage Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► GUILanguage
Keyoti RapidSpell WPF
The language to show the UI in.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public LanguageType GUILanguage { get; set; }
public LanguageType GUILanguage { get; set; }
Public Property GUILanguage As LanguageType
    Get
    Set
Public Property GUILanguage As LanguageType
    Get
    Set
public:
property LanguageType GUILanguage {
    LanguageType get ();
    void set (LanguageType value);
}
public:
property LanguageType GUILanguage {
    LanguageType get ();
    void set (LanguageType value);
}
member GUILanguage : LanguageType with get, set

member GUILanguage : LanguageType with get, set
Property Value
LanguageType


Icon Property

Icon Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► Icon
Keyoti RapidSpell WPF
The dialog window's icon.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ImageSource Icon { get; set; }
public ImageSource Icon { get; set; }
Public Property Icon As ImageSource
    Get
    Set
Public Property Icon As ImageSource
    Get
    Set
public:
property ImageSource^ Icon {
    ImageSource^ get ();
    void set (ImageSource^ value);
}
public:
property ImageSource^ Icon {
    ImageSource^ get ();
    void set (ImageSource^ value);
}
member Icon : ImageSource with get, set

member Icon : ImageSource with get, set
Property Value
ImageSource


IgnoreCapitalizedWords Property

IgnoreCapitalizedWords Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► IgnoreCapitalizedWords
Keyoti RapidSpell WPF
Whether to ignore words with capital letters.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreCapitalizedWords { get; set; }
public bool IgnoreCapitalizedWords { get; set; }
Public Property IgnoreCapitalizedWords As Boolean
    Get
    Set
Public Property IgnoreCapitalizedWords As Boolean
    Get
    Set
public:
property bool IgnoreCapitalizedWords {
    bool get ();
    void set (bool value);
}
public:
property bool IgnoreCapitalizedWords {
    bool get ();
    void set (bool value);
}
member IgnoreCapitalizedWords : bool with get, set

member IgnoreCapitalizedWords : bool with get, set
Property Value
Boolean


IgnoreIncorrectSentenceCapitalization Property

IgnoreIncorrectSentenceCapitalization Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► IgnoreIncorrectSentenceCapitalization
Keyoti RapidSpell WPF
Whether to ignore incorrect sentence capitalization.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreIncorrectSentenceCapitalization { get; set; }
public bool IgnoreIncorrectSentenceCapitalization { get; set; }
Public Property IgnoreIncorrectSentenceCapitalization As Boolean
    Get
    Set
Public Property IgnoreIncorrectSentenceCapitalization As Boolean
    Get
    Set
public:
property bool IgnoreIncorrectSentenceCapitalization {
    bool get ();
    void set (bool value);
}
public:
property bool IgnoreIncorrectSentenceCapitalization {
    bool get ();
    void set (bool value);
}
member IgnoreIncorrectSentenceCapitalization : bool with get, set

member IgnoreIncorrectSentenceCapitalization : bool with get, set
Property Value
Boolean


IgnoreInEnglishLowerCaseI Property

IgnoreInEnglishLowerCaseI Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► IgnoreInEnglishLowerCaseI
Keyoti RapidSpell WPF
Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreInEnglishLowerCaseI { get; set; }
public bool IgnoreInEnglishLowerCaseI { get; set; }
Public Property IgnoreInEnglishLowerCaseI As Boolean
    Get
    Set
Public Property IgnoreInEnglishLowerCaseI As Boolean
    Get
    Set
public:
property bool IgnoreInEnglishLowerCaseI {
    bool get ();
    void set (bool value);
}
public:
property bool IgnoreInEnglishLowerCaseI {
    bool get ();
    void set (bool value);
}
member IgnoreInEnglishLowerCaseI : bool with get, set

member IgnoreInEnglishLowerCaseI : bool with get, set
Property Value
Boolean


IgnoreURLsAndEmailAddresses Property

IgnoreURLsAndEmailAddresses Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► IgnoreURLsAndEmailAddresses
Keyoti RapidSpell WPF
Whether to ignore URLs and email addresses (requires V2Parser=true)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreURLsAndEmailAddresses { get; set; }
public bool IgnoreURLsAndEmailAddresses { get; set; }
Public Property IgnoreURLsAndEmailAddresses As Boolean
    Get
    Set
Public Property IgnoreURLsAndEmailAddresses As Boolean
    Get
    Set
public:
property bool IgnoreURLsAndEmailAddresses {
    bool get ();
    void set (bool value);
}
public:
property bool IgnoreURLsAndEmailAddresses {
    bool get ();
    void set (bool value);
}
member IgnoreURLsAndEmailAddresses : bool with get, set

member IgnoreURLsAndEmailAddresses : bool with get, set
Property Value
Boolean
Remarks
This will cause the following strings to be accepted as non-spelling errors;
"user@domain.com", "http://www.domain.com", "domain.co.uk" etc.


IgnoreWordsWithDigits Property

IgnoreWordsWithDigits Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► IgnoreWordsWithDigits
Keyoti RapidSpell WPF
Whether to ignore words with numbers in them (eg. A10 or 7-11).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreWordsWithDigits { get; set; }
public bool IgnoreWordsWithDigits { get; set; }
Public Property IgnoreWordsWithDigits As Boolean
    Get
    Set
Public Property IgnoreWordsWithDigits As Boolean
    Get
    Set
public:
property bool IgnoreWordsWithDigits {
    bool get ();
    void set (bool value);
}
public:
property bool IgnoreWordsWithDigits {
    bool get ();
    void set (bool value);
}
member IgnoreWordsWithDigits : bool with get, set

member IgnoreWordsWithDigits : bool with get, set
Property Value
Boolean


IgnoreXML Property

IgnoreXML Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► IgnoreXML
Keyoti RapidSpell WPF
Whether to ignore XML/HTML tags, false by default.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreXML { get; set; }
public bool IgnoreXML { get; set; }
Public Property IgnoreXML As Boolean
    Get
    Set
Public Property IgnoreXML As Boolean
    Get
    Set
public:
property bool IgnoreXML {
    bool get ();
    void set (bool value);
}
public:
property bool IgnoreXML {
    bool get ();
    void set (bool value);
}
member IgnoreXML : bool with get, set

member IgnoreXML : bool with get, set
Property Value
Boolean
Remarks
This identifies XML tags as anything in between < and > characters, there for it will cause undesirable effects in text such as "the sign for less than is < and the sign for greater than is >". Of course in HTML that should have been written as "the sign for less than is &lt; and the sign for greater than is &gt;" anyway, which would be fine.


IncludeUserDictionaryInSuggestions Property

IncludeUserDictionaryInSuggestions Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► IncludeUserDictionaryInSuggestions
Keyoti RapidSpell WPF
Whether the user dictionary should be used in finding suggestions for misspelt words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IncludeUserDictionaryInSuggestions { get; set; }
public bool IncludeUserDictionaryInSuggestions { get; set; }
Public Property IncludeUserDictionaryInSuggestions As Boolean
    Get
    Set
Public Property IncludeUserDictionaryInSuggestions As Boolean
    Get
    Set
public:
property bool IncludeUserDictionaryInSuggestions {
    bool get ();
    void set (bool value);
}
public:
property bool IncludeUserDictionaryInSuggestions {
    bool get ();
    void set (bool value);
}
member IncludeUserDictionaryInSuggestions : bool with get, set

member IncludeUserDictionaryInSuggestions : bool with get, set
Property Value
Boolean


LanguageParser Property

LanguageParser Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► LanguageParser
Keyoti RapidSpell WPF
The type of language parsing to use.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public LanguageType LanguageParser { get; set; }
public LanguageType LanguageParser { get; set; }
Public Property LanguageParser As LanguageType
    Get
    Set
Public Property LanguageParser As LanguageType
    Get
    Set
public:
property LanguageType LanguageParser {
    LanguageType get ();
    void set (LanguageType value);
}
public:
property LanguageType LanguageParser {
    LanguageType get ();
    void set (LanguageType value);
}
member LanguageParser : LanguageType with get, set

member LanguageParser : LanguageType with get, set
Property Value
LanguageType
Remarks
Eg. If the dictionary is set to French, you should use the French parser.


Location Property

Location Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► Location
Keyoti RapidSpell WPF
Where to position dialog the first time it is opened.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Point Location { get; set; }
public Point Location { get; set; }
Public Property Location As Point
    Get
    Set
Public Property Location As Point
    Get
    Set
public:
property Point Location {
    Point get ();
    void set (Point value);
}
public:
property Point Location {
    Point get ();
    void set (Point value);
}
member Location : Point with get, set

member Location : Point with get, set
Property Value
Point


LookIntoHyphenatedText Property

LookIntoHyphenatedText Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► LookIntoHyphenatedText
Keyoti RapidSpell WPF
Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool LookIntoHyphenatedText { get; set; }
public bool LookIntoHyphenatedText { get; set; }
Public Property LookIntoHyphenatedText As Boolean
    Get
    Set
Public Property LookIntoHyphenatedText As Boolean
    Get
    Set
public:
property bool LookIntoHyphenatedText {
    bool get ();
    void set (bool value);
}
public:
property bool LookIntoHyphenatedText {
    bool get ();
    void set (bool value);
}
member LookIntoHyphenatedText : bool with get, set

member LookIntoHyphenatedText : bool with get, set
Property Value
Boolean
Remarks
Eg. "socio-economic" will be checked as "socio" and "economic".


Modal Property

Modal Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► Modal
Keyoti RapidSpell WPF
Whether the spell checker will run modally. (Modal operation blocks the parent form)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool Modal { get; set; }
public bool Modal { get; set; }
Public Property Modal As Boolean
    Get
    Set
Public Property Modal As Boolean
    Get
    Set
public:
property bool Modal {
    bool get ();
    void set (bool value);
}
public:
property bool Modal {
    bool get ();
    void set (bool value);
}
member Modal : bool with get, set

member Modal : bool with get, set
Property Value
Boolean


ModalOwner Property

ModalOwner Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► ModalOwner
Keyoti RapidSpell WPF
The owner of the checker form, when it's viewed modally.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Window ModalOwner { get; set; }
public Window ModalOwner { get; set; }
Public Property ModalOwner As Window
    Get
    Set
Public Property ModalOwner As Window
    Get
    Set
public:
property Window^ ModalOwner {
    Window^ get ();
    void set (Window^ value);
}
public:
property Window^ ModalOwner {
    Window^ get ();
    void set (Window^ value);
}
member ModalOwner : Window with get, set

member ModalOwner : Window with get, set
Property Value
Window
Remarks
This is equivalent to owner in ShowDialog(owner), set to null/nothing for no owner to be specified.


NumberSuggestionList Property

NumberSuggestionList Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► NumberSuggestionList
Keyoti RapidSpell WPF
Whether to number the items in the suggestion list, for quick user selection.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool NumberSuggestionList { get; set; }
public bool NumberSuggestionList { get; set; }
Public Property NumberSuggestionList As Boolean
    Get
    Set
Public Property NumberSuggestionList As Boolean
    Get
    Set
public:
property bool NumberSuggestionList {
    bool get ();
    void set (bool value);
}
public:
property bool NumberSuggestionList {
    bool get ();
    void set (bool value);
}
member NumberSuggestionList : bool with get, set

member NumberSuggestionList : bool with get, set
Property Value
Boolean


OnCreateDialogView Method (e)

OnCreateDialogView Method (e)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► OnCreateDialogView(CreateDialogViewEventArgs)
Keyoti RapidSpell WPF
Raises event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void OnCreateDialogView(
    CreateDialogViewEventArgs e
)
protected virtual void OnCreateDialogView(
    CreateDialogViewEventArgs e
)
Protected Overridable Sub OnCreateDialogView (
    e As CreateDialogViewEventArgs
)
Protected Overridable Sub OnCreateDialogView (
    e As CreateDialogViewEventArgs
)
protected:
virtual void OnCreateDialogView(
    CreateDialogViewEventArgs^ e
)
protected:
virtual void OnCreateDialogView(
    CreateDialogViewEventArgs^ e
)
abstract OnCreateDialogView :
        e : CreateDialogViewEventArgs -> unit
override OnCreateDialogView :
        e : CreateDialogViewEventArgs -> unit
abstract OnCreateDialogView :
        e : CreateDialogViewEventArgs -> unit
override OnCreateDialogView :
        e : CreateDialogViewEventArgs -> unit
Parameters
e (CreateDialogViewEventArgs)


OnCreateDialogViewOptions Method (e)

OnCreateDialogViewOptions Method (e)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► OnCreateDialogViewOptions(CreateDialogViewOptionsEventArgs)
Keyoti RapidSpell WPF
Raises event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void OnCreateDialogViewOptions(
    CreateDialogViewOptionsEventArgs e
)
protected virtual void OnCreateDialogViewOptions(
    CreateDialogViewOptionsEventArgs e
)
Protected Overridable Sub OnCreateDialogViewOptions (
    e As CreateDialogViewOptionsEventArgs
)
Protected Overridable Sub OnCreateDialogViewOptions (
    e As CreateDialogViewOptionsEventArgs
)
protected:
virtual void OnCreateDialogViewOptions(
    CreateDialogViewOptionsEventArgs^ e
)
protected:
virtual void OnCreateDialogViewOptions(
    CreateDialogViewOptionsEventArgs^ e
)
abstract OnCreateDialogViewOptions :
        e : CreateDialogViewOptionsEventArgs -> unit
override OnCreateDialogViewOptions :
        e : CreateDialogViewOptionsEventArgs -> unit
abstract OnCreateDialogViewOptions :
        e : CreateDialogViewOptionsEventArgs -> unit
override OnCreateDialogViewOptions :
        e : CreateDialogViewOptionsEventArgs -> unit
Parameters
e (CreateDialogViewOptionsEventArgs)


OnCreateDialogViewUserDictionaryEdit Method (e)

OnCreateDialogViewUserDictionaryEdit Method (e)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► OnCreateDialogViewUserDictionaryEdit(CreateDialogViewUserDictionaryEditEventArgs)
Keyoti RapidSpell WPF
Fires the CreateDialogViewUserDictionaryEdit event.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void OnCreateDialogViewUserDictionaryEdit(
    CreateDialogViewUserDictionaryEditEventArgs e
)
protected virtual void OnCreateDialogViewUserDictionaryEdit(
    CreateDialogViewUserDictionaryEditEventArgs e
)
Protected Overridable Sub OnCreateDialogViewUserDictionaryEdit (
    e As CreateDialogViewUserDictionaryEditEventArgs
)
Protected Overridable Sub OnCreateDialogViewUserDictionaryEdit (
    e As CreateDialogViewUserDictionaryEditEventArgs
)
protected:
virtual void OnCreateDialogViewUserDictionaryEdit(
    CreateDialogViewUserDictionaryEditEventArgs^ e
)
protected:
virtual void OnCreateDialogViewUserDictionaryEdit(
    CreateDialogViewUserDictionaryEditEventArgs^ e
)
abstract OnCreateDialogViewUserDictionaryEdit :
        e : CreateDialogViewUserDictionaryEditEventArgs -> unit
override OnCreateDialogViewUserDictionaryEdit :
        e : CreateDialogViewUserDictionaryEditEventArgs -> unit
abstract OnCreateDialogViewUserDictionaryEdit :
        e : CreateDialogViewUserDictionaryEditEventArgs -> unit
override OnCreateDialogViewUserDictionaryEdit :
        e : CreateDialogViewUserDictionaryEditEventArgs -> unit
Parameters
e (CreateDialogViewUserDictionaryEditEventArgs)


OnCreateDialogViewUserDictionarySelect Method (e)

OnCreateDialogViewUserDictionarySelect Method (e)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► OnCreateDialogViewUserDictionarySelect(CreateDialogViewUserDictionarySelectEventArgs)
Keyoti RapidSpell WPF
Raises event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void OnCreateDialogViewUserDictionarySelect(
    CreateDialogViewUserDictionarySelectEventArgs e
)
protected virtual void OnCreateDialogViewUserDictionarySelect(
    CreateDialogViewUserDictionarySelectEventArgs e
)
Protected Overridable Sub OnCreateDialogViewUserDictionarySelect (
    e As CreateDialogViewUserDictionarySelectEventArgs
)
Protected Overridable Sub OnCreateDialogViewUserDictionarySelect (
    e As CreateDialogViewUserDictionarySelectEventArgs
)
protected:
virtual void OnCreateDialogViewUserDictionarySelect(
    CreateDialogViewUserDictionarySelectEventArgs^ e
)
protected:
virtual void OnCreateDialogViewUserDictionarySelect(
    CreateDialogViewUserDictionarySelectEventArgs^ e
)
abstract OnCreateDialogViewUserDictionarySelect :
        e : CreateDialogViewUserDictionarySelectEventArgs -> unit
override OnCreateDialogViewUserDictionarySelect :
        e : CreateDialogViewUserDictionarySelectEventArgs -> unit
abstract OnCreateDialogViewUserDictionarySelect :
        e : CreateDialogViewUserDictionarySelectEventArgs -> unit
override OnCreateDialogViewUserDictionarySelect :
        e : CreateDialogViewUserDictionarySelectEventArgs -> unit
Parameters
e (CreateDialogViewUserDictionarySelectEventArgs)


OnCreateUserInterfaceFormPresenter Method (e)

OnCreateUserInterfaceFormPresenter Method (e)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► OnCreateUserInterfaceFormPresenter(CreateUserInterfaceFormPresenterEventArgs)
Keyoti RapidSpell WPF
Raises event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void OnCreateUserInterfaceFormPresenter(
    CreateUserInterfaceFormPresenterEventArgs e
)
protected virtual void OnCreateUserInterfaceFormPresenter(
    CreateUserInterfaceFormPresenterEventArgs e
)
Protected Overridable Sub OnCreateUserInterfaceFormPresenter (
    e As CreateUserInterfaceFormPresenterEventArgs
)
Protected Overridable Sub OnCreateUserInterfaceFormPresenter (
    e As CreateUserInterfaceFormPresenterEventArgs
)
protected:
virtual void OnCreateUserInterfaceFormPresenter(
    CreateUserInterfaceFormPresenterEventArgs^ e
)
protected:
virtual void OnCreateUserInterfaceFormPresenter(
    CreateUserInterfaceFormPresenterEventArgs^ e
)
abstract OnCreateUserInterfaceFormPresenter :
        e : CreateUserInterfaceFormPresenterEventArgs -> unit
override OnCreateUserInterfaceFormPresenter :
        e : CreateUserInterfaceFormPresenterEventArgs -> unit
abstract OnCreateUserInterfaceFormPresenter :
        e : CreateUserInterfaceFormPresenterEventArgs -> unit
override OnCreateUserInterfaceFormPresenter :
        e : CreateUserInterfaceFormPresenterEventArgs -> unit
Parameters
e (CreateUserInterfaceFormPresenterEventArgs)


OnSpellCheckFinishedTextBox Method (e)

OnSpellCheckFinishedTextBox Method (e)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► OnSpellCheckFinishedTextBox(TextBoxSpellCheckEventArgs)
Keyoti RapidSpell WPF
Raises event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void OnSpellCheckFinishedTextBox(
    TextBoxSpellCheckEventArgs e
)
protected virtual void OnSpellCheckFinishedTextBox(
    TextBoxSpellCheckEventArgs e
)
Protected Overridable Sub OnSpellCheckFinishedTextBox (
    e As TextBoxSpellCheckEventArgs
)
Protected Overridable Sub OnSpellCheckFinishedTextBox (
    e As TextBoxSpellCheckEventArgs
)
protected:
virtual void OnSpellCheckFinishedTextBox(
    TextBoxSpellCheckEventArgs^ e
)
protected:
virtual void OnSpellCheckFinishedTextBox(
    TextBoxSpellCheckEventArgs^ e
)
abstract OnSpellCheckFinishedTextBox :
        e : TextBoxSpellCheckEventArgs -> unit
override OnSpellCheckFinishedTextBox :
        e : TextBoxSpellCheckEventArgs -> unit
abstract OnSpellCheckFinishedTextBox :
        e : TextBoxSpellCheckEventArgs -> unit
override OnSpellCheckFinishedTextBox :
        e : TextBoxSpellCheckEventArgs -> unit
Parameters
e (TextBoxSpellCheckEventArgs)


OnSpellCheckStartedTextBox Method (e)

OnSpellCheckStartedTextBox Method (e)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► OnSpellCheckStartedTextBox(TextBoxSpellCheckEventArgs)
Keyoti RapidSpell WPF
Raises event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void OnSpellCheckStartedTextBox(
    TextBoxSpellCheckEventArgs e
)
protected virtual void OnSpellCheckStartedTextBox(
    TextBoxSpellCheckEventArgs e
)
Protected Overridable Sub OnSpellCheckStartedTextBox (
    e As TextBoxSpellCheckEventArgs
)
Protected Overridable Sub OnSpellCheckStartedTextBox (
    e As TextBoxSpellCheckEventArgs
)
protected:
virtual void OnSpellCheckStartedTextBox(
    TextBoxSpellCheckEventArgs^ e
)
protected:
virtual void OnSpellCheckStartedTextBox(
    TextBoxSpellCheckEventArgs^ e
)
abstract OnSpellCheckStartedTextBox :
        e : TextBoxSpellCheckEventArgs -> unit
override OnSpellCheckStartedTextBox :
        e : TextBoxSpellCheckEventArgs -> unit
abstract OnSpellCheckStartedTextBox :
        e : TextBoxSpellCheckEventArgs -> unit
override OnSpellCheckStartedTextBox :
        e : TextBoxSpellCheckEventArgs -> unit
Parameters
e (TextBoxSpellCheckEventArgs)


OnWordAdded Method (sender, e)

OnWordAdded Method (sender, e)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► OnWordAdded(Object, WordAddedEventArgs)
Keyoti RapidSpell WPF
Fires WordAdded event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected internal void OnWordAdded(
    Object sender,
    WordAddedEventArgs e
)
protected internal void OnWordAdded(
    Object sender,
    WordAddedEventArgs e
)
Protected Friend Sub OnWordAdded (
    sender As Object,
    e As WordAddedEventArgs
)
Protected Friend Sub OnWordAdded (
    sender As Object,
    e As WordAddedEventArgs
)
protected public:
void OnWordAdded(
    Object^ sender,
    WordAddedEventArgs^ e
)
protected public:
void OnWordAdded(
    Object^ sender,
    WordAddedEventArgs^ e
)
member OnWordAdded :
        sender : Object *
        e : WordAddedEventArgs -> unit

member OnWordAdded :
        sender : Object *
        e : WordAddedEventArgs -> unit
Parameters
sender (Object)
e (WordAddedEventArgs)


OnWordChanged Method (sender, e)

OnWordChanged Method (sender, e)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► OnWordChanged(Object, WordChangedEventArgs)
Keyoti RapidSpell WPF
Fires WordChanged event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected internal void OnWordChanged(
    Object sender,
    WordChangedEventArgs e
)
protected internal void OnWordChanged(
    Object sender,
    WordChangedEventArgs e
)
Protected Friend Sub OnWordChanged (
    sender As Object,
    e As WordChangedEventArgs
)
Protected Friend Sub OnWordChanged (
    sender As Object,
    e As WordChangedEventArgs
)
protected public:
void OnWordChanged(
    Object^ sender,
    WordChangedEventArgs^ e
)
protected public:
void OnWordChanged(
    Object^ sender,
    WordChangedEventArgs^ e
)
member OnWordChanged :
        sender : Object *
        e : WordChangedEventArgs -> unit

member OnWordChanged :
        sender : Object *
        e : WordChangedEventArgs -> unit
Parameters
sender (Object)
e (WordChangedEventArgs)


OnWordChanging Method (sender, e)

OnWordChanging Method (sender, e)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► OnWordChanging(Object, WordChangedEventArgs)
Keyoti RapidSpell WPF
Fires WordChanging event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected internal void OnWordChanging(
    Object sender,
    WordChangedEventArgs e
)
protected internal void OnWordChanging(
    Object sender,
    WordChangedEventArgs e
)
Protected Friend Sub OnWordChanging (
    sender As Object,
    e As WordChangedEventArgs
)
Protected Friend Sub OnWordChanging (
    sender As Object,
    e As WordChangedEventArgs
)
protected public:
void OnWordChanging(
    Object^ sender,
    WordChangedEventArgs^ e
)
protected public:
void OnWordChanging(
    Object^ sender,
    WordChangedEventArgs^ e
)
member OnWordChanging :
        sender : Object *
        e : WordChangedEventArgs -> unit

member OnWordChanging :
        sender : Object *
        e : WordChangedEventArgs -> unit
Parameters
sender (Object)
e (WordChangedEventArgs)


OnWordIgnored Method (sender, e)

OnWordIgnored Method (sender, e)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► OnWordIgnored(Object, WordIgnoredEventArgs)
Keyoti RapidSpell WPF
Fires WordIgnored event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected internal void OnWordIgnored(
    Object sender,
    WordIgnoredEventArgs e
)
protected internal void OnWordIgnored(
    Object sender,
    WordIgnoredEventArgs e
)
Protected Friend Sub OnWordIgnored (
    sender As Object,
    e As WordIgnoredEventArgs
)
Protected Friend Sub OnWordIgnored (
    sender As Object,
    e As WordIgnoredEventArgs
)
protected public:
void OnWordIgnored(
    Object^ sender,
    WordIgnoredEventArgs^ e
)
protected public:
void OnWordIgnored(
    Object^ sender,
    WordIgnoredEventArgs^ e
)
member OnWordIgnored :
        sender : Object *
        e : WordIgnoredEventArgs -> unit

member OnWordIgnored :
        sender : Object *
        e : WordIgnoredEventArgs -> unit
Parameters
sender (Object)
e (WordIgnoredEventArgs)


Options Property

Options Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► Options
Keyoti RapidSpell WPF
Object responsible for holding, loading and saving the user's spell check options.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual UserOptions Options { get; set; }
public virtual UserOptions Options { get; set; }
Public Overridable Property Options As UserOptions
    Get
    Set
Public Overridable Property Options As UserOptions
    Get
    Set
public:
virtual property UserOptions^ Options {
    UserOptions^ get ();
    void set (UserOptions^ value);
}
public:
virtual property UserOptions^ Options {
    UserOptions^ get ();
    void set (UserOptions^ value);
}
abstract Options : UserOptions with get, set
override Options : UserOptions with get, set
abstract Options : UserOptions with get, set
override Options : UserOptions with get, set
Property Value
UserOptions
Remarks
To customize how the user's options are saved/loaded, subclass UserOptions and set an instance in this property.


OptionsEnabled Property

OptionsEnabled Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► OptionsEnabled
Keyoti RapidSpell WPF
Whether to use user options.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool OptionsEnabled { get; set; }
public virtual bool OptionsEnabled { get; set; }
Public Overridable Property OptionsEnabled As Boolean
    Get
    Set
Public Overridable Property OptionsEnabled As Boolean
    Get
    Set
public:
virtual property bool OptionsEnabled {
    bool get ();
    void set (bool value);
}
public:
virtual property bool OptionsEnabled {
    bool get ();
    void set (bool value);
}
abstract OptionsEnabled : bool with get, set
override OptionsEnabled : bool with get, set
abstract OptionsEnabled : bool with get, set
override OptionsEnabled : bool with get, set
Property Value
Boolean


OptionsFileName Property

OptionsFileName Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► OptionsFileName
Keyoti RapidSpell WPF
The file name used to store the settings (by default in IsolatedStorage).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsFileName { get; set; }
public string OptionsFileName { get; set; }
Public Property OptionsFileName As String
    Get
    Set
Public Property OptionsFileName As String
    Get
    Set
public:
property String^ OptionsFileName {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OptionsFileName {
    String^ get ();
    void set (String^ value);
}
member OptionsFileName : string with get, set

member OptionsFileName : string with get, set
Property Value
String
Remarks
Changing this can ensure different applications have unique user settings.


OptionsPresenter Property

OptionsPresenter Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► OptionsPresenter
Keyoti RapidSpell WPF
Presenter for the user options form (IDialogViewOptions).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual OptionsPresenter OptionsPresenter { get; set; }
public virtual OptionsPresenter OptionsPresenter { get; set; }
Public Overridable Property OptionsPresenter As OptionsPresenter
    Get
    Set
Public Overridable Property OptionsPresenter As OptionsPresenter
    Get
    Set
public:
virtual property OptionsPresenter^ OptionsPresenter {
    OptionsPresenter^ get ();
    void set (OptionsPresenter^ value);
}
public:
virtual property OptionsPresenter^ OptionsPresenter {
    OptionsPresenter^ get ();
    void set (OptionsPresenter^ value);
}
abstract OptionsPresenter : OptionsPresenter with get, set
override OptionsPresenter : OptionsPresenter with get, set
abstract OptionsPresenter : OptionsPresenter with get, set
override OptionsPresenter : OptionsPresenter with get, set
Property Value
OptionsPresenter
Remarks
Set properties in this instance to affect the options shown to the user, or handle CreateDialogViewOptions to create your own IDialogViewOptions form instance.


OptionsStorageLocation Property

OptionsStorageLocation Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► OptionsStorageLocation
Keyoti RapidSpell WPF
Where the user's options are stored.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UserOptions..::..StorageType OptionsStorageLocation { get; set; }
public UserOptions..::..StorageType OptionsStorageLocation { get; set; }
Public Property OptionsStorageLocation As UserOptions..::..StorageType
    Get
    Set
Public Property OptionsStorageLocation As UserOptions..::..StorageType
    Get
    Set
public:
property UserOptions..::..StorageType OptionsStorageLocation {
    UserOptions..::..StorageType get ();
    void set (UserOptions..::..StorageType value);
}
public:
property UserOptions..::..StorageType OptionsStorageLocation {
    UserOptions..::..StorageType get ();
    void set (UserOptions..::..StorageType value);
}
member OptionsStorageLocation : UserOptions..::..StorageType with get, set

member OptionsStorageLocation : UserOptions..::..StorageType with get, set
Property Value
UserOptions..::..StorageType


QueryTextBoxMultiline Property

QueryTextBoxMultiline Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► QueryTextBoxMultiline
Keyoti RapidSpell WPF
Whether 'not in dictionary' text box is multiline or single line.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool QueryTextBoxMultiline { get; set; }
public bool QueryTextBoxMultiline { get; set; }
Public Property QueryTextBoxMultiline As Boolean
    Get
    Set
Public Property QueryTextBoxMultiline As Boolean
    Get
    Set
public:
property bool QueryTextBoxMultiline {
    bool get ();
    void set (bool value);
}
public:
property bool QueryTextBoxMultiline {
    bool get ();
    void set (bool value);
}
member QueryTextBoxMultiline : bool with get, set

member QueryTextBoxMultiline : bool with get, set
Property Value
Boolean


Ready Event

Ready Event
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► Ready
Keyoti RapidSpell WPF
Fired when ready to proceed with first query.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler Ready
public event EventHandler Ready
Public Event Ready As EventHandler
Public Event Ready As EventHandler
public:
 event EventHandler^ Ready {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
 event EventHandler^ Ready {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member Ready : IEvent<EventHandler,
    EventArgs>

member Ready : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


RecheckDocumentRequest Event

RecheckDocumentRequest Event
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► RecheckDocumentRequest
Keyoti RapidSpell WPF
Fired when the text should be rechecked
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler RecheckDocumentRequest
public event EventHandler RecheckDocumentRequest
Public Event RecheckDocumentRequest As EventHandler
Public Event RecheckDocumentRequest As EventHandler
public:
 event EventHandler^ RecheckDocumentRequest {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
 event EventHandler^ RecheckDocumentRequest {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member RecheckDocumentRequest : IEvent<EventHandler,
    EventArgs>

member RecheckDocumentRequest : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


RemoveAllTextComponents Method

RemoveAllTextComponents Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► RemoveAllTextComponents()()()()
Keyoti RapidSpell WPF
Removes all text components from being spell checked.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void RemoveAllTextComponents()
public void RemoveAllTextComponents()
Public Sub RemoveAllTextComponents
Public Sub RemoveAllTextComponents
public:
void RemoveAllTextComponents()
public:
void RemoveAllTextComponents()
member RemoveAllTextComponents : unit -> unit

member RemoveAllTextComponents : unit -> unit


RemoveTextComponent Method

RemoveTextComponent Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► RemoveTextComponent()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | RemoveTextComponent(TextBoxBase) | Removes a TextBoxBase (TextBox, RichTextBox and derivatives) to be checked.
 | RemoveTextComponent(ISpellCheckableTextComponent) | Removes an ISpellCheckableTextComponent to be checked.


RemoveTextComponent Method (textComponent)

RemoveTextComponent Method (textComponent)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► RemoveTextComponent(ISpellCheckableTextComponent)
Keyoti RapidSpell WPF
Removes an ISpellCheckableTextComponent to be checked.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void RemoveTextComponent(
    ISpellCheckableTextComponent textComponent
)
public virtual void RemoveTextComponent(
    ISpellCheckableTextComponent textComponent
)
Public Overridable Sub RemoveTextComponent (
    textComponent As ISpellCheckableTextComponent
)
Public Overridable Sub RemoveTextComponent (
    textComponent As ISpellCheckableTextComponent
)
public:
virtual void RemoveTextComponent(
    ISpellCheckableTextComponent^ textComponent
)
public:
virtual void RemoveTextComponent(
    ISpellCheckableTextComponent^ textComponent
)
abstract RemoveTextComponent :
        textComponent : ISpellCheckableTextComponent -> unit
override RemoveTextComponent :
        textComponent : ISpellCheckableTextComponent -> unit
abstract RemoveTextComponent :
        textComponent : ISpellCheckableTextComponent -> unit
override RemoveTextComponent :
        textComponent : ISpellCheckableTextComponent -> unit
Parameters
textComponent (ISpellCheckableTextComponent)


RemoveTextComponent Method (textBoxBase)

RemoveTextComponent Method (textBoxBase)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► RemoveTextComponent(TextBoxBase)
Keyoti RapidSpell WPF
Removes a TextBoxBase (TextBox, RichTextBox and derivatives) to be checked.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void RemoveTextComponent(
    TextBoxBase textBoxBase
)
public virtual void RemoveTextComponent(
    TextBoxBase textBoxBase
)
Public Overridable Sub RemoveTextComponent (
    textBoxBase As TextBoxBase
)
Public Overridable Sub RemoveTextComponent (
    textBoxBase As TextBoxBase
)
public:
virtual void RemoveTextComponent(
    TextBoxBase^ textBoxBase
)
public:
virtual void RemoveTextComponent(
    TextBoxBase^ textBoxBase
)
abstract RemoveTextComponent :
        textBoxBase : TextBoxBase -> unit
override RemoveTextComponent :
        textBoxBase : TextBoxBase -> unit
abstract RemoveTextComponent :
        textBoxBase : TextBoxBase -> unit
override RemoveTextComponent :
        textBoxBase : TextBoxBase -> unit
Parameters
textBoxBase (TextBoxBase)


ResetIgnoredWords Method

ResetIgnoredWords Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► ResetIgnoredWords()()()()
Keyoti RapidSpell WPF
Resets all ignored words, so that the document will be rechecked.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void ResetIgnoredWords()
public virtual void ResetIgnoredWords()
Public Overridable Sub ResetIgnoredWords
Public Overridable Sub ResetIgnoredWords
public:
virtual void ResetIgnoredWords()
public:
virtual void ResetIgnoredWords()
abstract ResetIgnoredWords : unit -> unit
override ResetIgnoredWords : unit -> unit
abstract ResetIgnoredWords : unit -> unit
override ResetIgnoredWords : unit -> unit


ShowContextSentence Property

ShowContextSentence Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► ShowContextSentence
Keyoti RapidSpell WPF
Whether to show the query in context of it's sentence/line.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ShowContextSentence { get; set; }
public bool ShowContextSentence { get; set; }
Public Property ShowContextSentence As Boolean
    Get
    Set
Public Property ShowContextSentence As Boolean
    Get
    Set
public:
property bool ShowContextSentence {
    bool get ();
    void set (bool value);
}
public:
property bool ShowContextSentence {
    bool get ();
    void set (bool value);
}
member ShowContextSentence : bool with get, set

member ShowContextSentence : bool with get, set
Property Value
Boolean


ShowFinishedBoxAtEnd Property

ShowFinishedBoxAtEnd Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► ShowFinishedBoxAtEnd
Keyoti RapidSpell WPF
Whether to show the spell check complete dialog box at the end, true by default.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ShowFinishedBoxAtEnd { get; set; }
public bool ShowFinishedBoxAtEnd { get; set; }
Public Property ShowFinishedBoxAtEnd As Boolean
    Get
    Set
Public Property ShowFinishedBoxAtEnd As Boolean
    Get
    Set
public:
property bool ShowFinishedBoxAtEnd {
    bool get ();
    void set (bool value);
}
public:
property bool ShowFinishedBoxAtEnd {
    bool get ();
    void set (bool value);
}
member ShowFinishedBoxAtEnd : bool with get, set

member ShowFinishedBoxAtEnd : bool with get, set
Property Value
Boolean


ShowInTaskbar Property

ShowInTaskbar Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► ShowInTaskbar
Keyoti RapidSpell WPF
Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ShowInTaskbar { get; set; }
public bool ShowInTaskbar { get; set; }
Public Property ShowInTaskbar As Boolean
    Get
    Set
Public Property ShowInTaskbar As Boolean
    Get
    Set
public:
property bool ShowInTaskbar {
    bool get ();
    void set (bool value);
}
public:
property bool ShowInTaskbar {
    bool get ();
    void set (bool value);
}
member ShowInTaskbar : bool with get, set

member ShowInTaskbar : bool with get, set
Property Value
Boolean


ShowOptionForCheckAsYouType Property

ShowOptionForCheckAsYouType Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► ShowOptionForCheckAsYouType
Keyoti RapidSpell WPF
Whether to show the 'check as you type' option check box in the options form.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ShowOptionForCheckAsYouType { get; set; }
public bool ShowOptionForCheckAsYouType { get; set; }
Public Property ShowOptionForCheckAsYouType As Boolean
    Get
    Set
Public Property ShowOptionForCheckAsYouType As Boolean
    Get
    Set
public:
property bool ShowOptionForCheckAsYouType {
    bool get ();
    void set (bool value);
}
public:
property bool ShowOptionForCheckAsYouType {
    bool get ();
    void set (bool value);
}
member ShowOptionForCheckAsYouType : bool with get, set

member ShowOptionForCheckAsYouType : bool with get, set
Property Value
Boolean


ShowOptionForMultipleUserDictionaries Property

ShowOptionForMultipleUserDictionaries Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► ShowOptionForMultipleUserDictionaries
Keyoti RapidSpell WPF
Whether to allow the user to add/remove additional user dictionaries in the options form, the user is not permitted to remove the user dictionary assigned via code.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ShowOptionForMultipleUserDictionaries { get; set; }
public bool ShowOptionForMultipleUserDictionaries { get; set; }
Public Property ShowOptionForMultipleUserDictionaries As Boolean
    Get
    Set
Public Property ShowOptionForMultipleUserDictionaries As Boolean
    Get
    Set
public:
property bool ShowOptionForMultipleUserDictionaries {
    bool get ();
    void set (bool value);
}
public:
property bool ShowOptionForMultipleUserDictionaries {
    bool get ();
    void set (bool value);
}
member ShowOptionForMultipleUserDictionaries : bool with get, set

member ShowOptionForMultipleUserDictionaries : bool with get, set
Property Value
Boolean


ShowOptionsButton Property

ShowOptionsButton Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► ShowOptionsButton
Keyoti RapidSpell WPF
Whether to show the options button.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ShowOptionsButton { get; set; }
public bool ShowOptionsButton { get; set; }
Public Property ShowOptionsButton As Boolean
    Get
    Set
Public Property ShowOptionsButton As Boolean
    Get
    Set
public:
property bool ShowOptionsButton {
    bool get ();
    void set (bool value);
}
public:
property bool ShowOptionsButton {
    bool get ();
    void set (bool value);
}
member ShowOptionsButton : bool with get, set

member ShowOptionsButton : bool with get, set
Property Value
Boolean


ShowUndoButton Property

ShowUndoButton Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► ShowUndoButton
Keyoti RapidSpell WPF
Whether to show the undo button.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ShowUndoButton { get; set; }
public bool ShowUndoButton { get; set; }
Public Property ShowUndoButton As Boolean
    Get
    Set
Public Property ShowUndoButton As Boolean
    Get
    Set
public:
property bool ShowUndoButton {
    bool get ();
    void set (bool value);
}
public:
property bool ShowUndoButton {
    bool get ();
    void set (bool value);
}
member ShowUndoButton : bool with get, set

member ShowUndoButton : bool with get, set
Property Value
Boolean


SpellCheckFinished Event

SpellCheckFinished Event
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► SpellCheckFinished
Keyoti RapidSpell WPF
Fired when checking finishes
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event RapidSpellDialog..::..SpellCheckEventHandler SpellCheckFinished
public event RapidSpellDialog..::..SpellCheckEventHandler SpellCheckFinished
Public Event SpellCheckFinished As RapidSpellDialog..::..SpellCheckEventHandler
Public Event SpellCheckFinished As RapidSpellDialog..::..SpellCheckEventHandler
public:
 event RapidSpellDialog..::..SpellCheckEventHandler^ SpellCheckFinished {
    void add (RapidSpellDialog..::..SpellCheckEventHandler^ value);
    void remove (RapidSpellDialog..::..SpellCheckEventHandler^ value);
}
public:
 event RapidSpellDialog..::..SpellCheckEventHandler^ SpellCheckFinished {
    void add (RapidSpellDialog..::..SpellCheckEventHandler^ value);
    void remove (RapidSpellDialog..::..SpellCheckEventHandler^ value);
}
member SpellCheckFinished : IEvent<RapidSpellDialog..::..SpellCheckEventHandler,
    SpellCheckEventArgs>

member SpellCheckFinished : IEvent<RapidSpellDialog..::..SpellCheckEventHandler,
    SpellCheckEventArgs>
Value
RapidSpellDialog..::..SpellCheckEventHandler


SpellCheckFinishedTextBox Event

SpellCheckFinishedTextBox Event
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► SpellCheckFinishedTextBox
Keyoti RapidSpell WPF
Fired when spell check starts on a text box (used in multiple text box checking situations)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event RapidSpellDialog..::..TextBoxSpellCheckEventHandler SpellCheckFinishedTextBox
public event RapidSpellDialog..::..TextBoxSpellCheckEventHandler SpellCheckFinishedTextBox
Public Event SpellCheckFinishedTextBox As RapidSpellDialog..::..TextBoxSpellCheckEventHandler
Public Event SpellCheckFinishedTextBox As RapidSpellDialog..::..TextBoxSpellCheckEventHandler
public:
 event RapidSpellDialog..::..TextBoxSpellCheckEventHandler^ SpellCheckFinishedTextBox {
    void add (RapidSpellDialog..::..TextBoxSpellCheckEventHandler^ value);
    void remove (RapidSpellDialog..::..TextBoxSpellCheckEventHandler^ value);
}
public:
 event RapidSpellDialog..::..TextBoxSpellCheckEventHandler^ SpellCheckFinishedTextBox {
    void add (RapidSpellDialog..::..TextBoxSpellCheckEventHandler^ value);
    void remove (RapidSpellDialog..::..TextBoxSpellCheckEventHandler^ value);
}
member SpellCheckFinishedTextBox : IEvent<RapidSpellDialog..::..TextBoxSpellCheckEventHandler,
    TextBoxSpellCheckEventArgs>

member SpellCheckFinishedTextBox : IEvent<RapidSpellDialog..::..TextBoxSpellCheckEventHandler,
    TextBoxSpellCheckEventArgs>
Value
RapidSpellDialog..::..TextBoxSpellCheckEventHandler


SpellCheckStarted Event

SpellCheckStarted Event
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► SpellCheckStarted
Keyoti RapidSpell WPF
Fired when checking starts
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event RapidSpellDialog..::..SpellCheckEventHandler SpellCheckStarted
public event RapidSpellDialog..::..SpellCheckEventHandler SpellCheckStarted
Public Event SpellCheckStarted As RapidSpellDialog..::..SpellCheckEventHandler
Public Event SpellCheckStarted As RapidSpellDialog..::..SpellCheckEventHandler
public:
 event RapidSpellDialog..::..SpellCheckEventHandler^ SpellCheckStarted {
    void add (RapidSpellDialog..::..SpellCheckEventHandler^ value);
    void remove (RapidSpellDialog..::..SpellCheckEventHandler^ value);
}
public:
 event RapidSpellDialog..::..SpellCheckEventHandler^ SpellCheckStarted {
    void add (RapidSpellDialog..::..SpellCheckEventHandler^ value);
    void remove (RapidSpellDialog..::..SpellCheckEventHandler^ value);
}
member SpellCheckStarted : IEvent<RapidSpellDialog..::..SpellCheckEventHandler,
    SpellCheckEventArgs>

member SpellCheckStarted : IEvent<RapidSpellDialog..::..SpellCheckEventHandler,
    SpellCheckEventArgs>
Value
RapidSpellDialog..::..SpellCheckEventHandler


SpellCheckStartedTextBox Event

SpellCheckStartedTextBox Event
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► SpellCheckStartedTextBox
Keyoti RapidSpell WPF
Fired when spell check starts on a text box (used in multiple text box checking situations)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event RapidSpellDialog..::..TextBoxSpellCheckEventHandler SpellCheckStartedTextBox
public event RapidSpellDialog..::..TextBoxSpellCheckEventHandler SpellCheckStartedTextBox
Public Event SpellCheckStartedTextBox As RapidSpellDialog..::..TextBoxSpellCheckEventHandler
Public Event SpellCheckStartedTextBox As RapidSpellDialog..::..TextBoxSpellCheckEventHandler
public:
 event RapidSpellDialog..::..TextBoxSpellCheckEventHandler^ SpellCheckStartedTextBox {
    void add (RapidSpellDialog..::..TextBoxSpellCheckEventHandler^ value);
    void remove (RapidSpellDialog..::..TextBoxSpellCheckEventHandler^ value);
}
public:
 event RapidSpellDialog..::..TextBoxSpellCheckEventHandler^ SpellCheckStartedTextBox {
    void add (RapidSpellDialog..::..TextBoxSpellCheckEventHandler^ value);
    void remove (RapidSpellDialog..::..TextBoxSpellCheckEventHandler^ value);
}
member SpellCheckStartedTextBox : IEvent<RapidSpellDialog..::..TextBoxSpellCheckEventHandler,
    TextBoxSpellCheckEventArgs>

member SpellCheckStartedTextBox : IEvent<RapidSpellDialog..::..TextBoxSpellCheckEventHandler,
    TextBoxSpellCheckEventArgs>
Value
RapidSpellDialog..::..TextBoxSpellCheckEventHandler


SuggestionsMethod Property

SuggestionsMethod Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► SuggestionsMethod
Keyoti RapidSpell WPF
The suggestions method to use.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public SuggestionsMethodType SuggestionsMethod { get; set; }
public SuggestionsMethodType SuggestionsMethod { get; set; }
Public Property SuggestionsMethod As SuggestionsMethodType
    Get
    Set
Public Property SuggestionsMethod As SuggestionsMethodType
    Get
    Set
public:
property SuggestionsMethodType SuggestionsMethod {
    SuggestionsMethodType get ();
    void set (SuggestionsMethodType value);
}
public:
property SuggestionsMethodType SuggestionsMethod {
    SuggestionsMethodType get ();
    void set (SuggestionsMethodType value);
}
member SuggestionsMethod : SuggestionsMethodType with get, set

member SuggestionsMethod : SuggestionsMethodType with get, set
Property Value
SuggestionsMethodType


SuggestSplitWords Property

SuggestSplitWords Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► SuggestSplitWords
Keyoti RapidSpell WPF
Whether to look for connected words in suggestions.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool SuggestSplitWords { get; set; }
public bool SuggestSplitWords { get; set; }
Public Property SuggestSplitWords As Boolean
    Get
    Set
Public Property SuggestSplitWords As Boolean
    Get
    Set
public:
property bool SuggestSplitWords {
    bool get ();
    void set (bool value);
}
public:
property bool SuggestSplitWords {
    bool get ();
    void set (bool value);
}
member SuggestSplitWords : bool with get, set

member SuggestSplitWords : bool with get, set
Property Value
Boolean
Remarks
if this=true then suggestions may include joined words.

Eg; suggestions for "myhouse" will include "my house"


TextBox Property

TextBox Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► TextBox
Keyoti RapidSpell WPF
The TextBox or RichTextBox to work with
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public TextBoxBase TextBox { get; set; }
public TextBoxBase TextBox { get; set; }
Public Property TextBox As TextBoxBase
    Get
    Set
Public Property TextBox As TextBoxBase
    Get
    Set
public:
property TextBoxBase^ TextBox {
    TextBoxBase^ get ();
    void set (TextBoxBase^ value);
}
public:
property TextBoxBase^ TextBox {
    TextBoxBase^ get ();
    void set (TextBoxBase^ value);
}
member TextBox : TextBoxBase with get, set

member TextBox : TextBoxBase with get, set
Property Value
TextBoxBase


TextBoxBasesToCheck Property

TextBoxBasesToCheck Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► TextBoxBasesToCheck
Keyoti RapidSpell WPF
Array of TextBoxBases this GUI will spell check.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public TextBoxBase[] TextBoxBasesToCheck { get; set; }
public TextBoxBase[] TextBoxBasesToCheck { get; set; }
Public Property TextBoxBasesToCheck As TextBoxBase()
    Get
    Set
Public Property TextBoxBasesToCheck As TextBoxBase()
    Get
    Set
public:
property array<TextBoxBase^>^ TextBoxBasesToCheck {
    array<TextBoxBase^>^ get ();
    void set (array<TextBoxBase^>^ value);
}
public:
property array<TextBoxBase^>^ TextBoxBasesToCheck {
    array<TextBoxBase^>^ get ();
    void set (array<TextBoxBase^>^ value);
}
member TextBoxBasesToCheck : TextBoxBase[] with get, set

member TextBoxBasesToCheck : TextBoxBase[] with get, set
Property Value
array<TextBoxBase>[]()[][]


TextBoxProperty Field

TextBoxProperty Field
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► TextBoxProperty
Keyoti RapidSpell WPF
The RapidSpellAsYouType to work with.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static readonly DependencyProperty TextBoxProperty
public static readonly DependencyProperty TextBoxProperty
Public Shared ReadOnly TextBoxProperty As DependencyProperty
Public Shared ReadOnly TextBoxProperty As DependencyProperty
public:
static initonly DependencyProperty^ TextBoxProperty
public:
static initonly DependencyProperty^ TextBoxProperty
static val TextBoxProperty: DependencyProperty
static val TextBoxProperty: DependencyProperty
Field Value
DependencyProperty


Texts Property

Texts Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► Texts
Keyoti RapidSpell WPF
The UI texts.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public DialogTexts Texts { get; set; }
public DialogTexts Texts { get; set; }
Public Property Texts As DialogTexts
    Get
    Set
Public Property Texts As DialogTexts
    Get
    Set
public:
property DialogTexts^ Texts {
    DialogTexts^ get ();
    void set (DialogTexts^ value);
}
public:
property DialogTexts^ Texts {
    DialogTexts^ get ();
    void set (DialogTexts^ value);
}
member Texts : DialogTexts with get, set

member Texts : DialogTexts with get, set
Property Value
DialogTexts


ThirdPartyTextComponentsToCheck Property

ThirdPartyTextComponentsToCheck Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► ThirdPartyTextComponentsToCheck
Keyoti RapidSpell WPF
Array of ISpellCheckableTextComponent this GUI will spell check.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ISpellCheckableTextComponent[] ThirdPartyTextComponentsToCheck { get; set; }
public ISpellCheckableTextComponent[] ThirdPartyTextComponentsToCheck { get; set; }
Public Property ThirdPartyTextComponentsToCheck As ISpellCheckableTextComponent()
    Get
    Set
Public Property ThirdPartyTextComponentsToCheck As ISpellCheckableTextComponent()
    Get
    Set
public:
property array<ISpellCheckableTextComponent^>^ ThirdPartyTextComponentsToCheck {
    array<ISpellCheckableTextComponent^>^ get ();
    void set (array<ISpellCheckableTextComponent^>^ value);
}
public:
property array<ISpellCheckableTextComponent^>^ ThirdPartyTextComponentsToCheck {
    array<ISpellCheckableTextComponent^>^ get ();
    void set (array<ISpellCheckableTextComponent^>^ value);
}
member ThirdPartyTextComponentsToCheck : ISpellCheckableTextComponent[] with get, set

member ThirdPartyTextComponentsToCheck : ISpellCheckableTextComponent[] with get, set
Property Value
array< ISpellCheckableTextComponent >[]()[][]


ThirdPartyTextComponentToCheck Property

ThirdPartyTextComponentToCheck Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► ThirdPartyTextComponentToCheck
Keyoti RapidSpell WPF
The 3rd Party Component that this GUI will spell check.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ISpellCheckableTextComponent ThirdPartyTextComponentToCheck { get; set; }
public ISpellCheckableTextComponent ThirdPartyTextComponentToCheck { get; set; }
Public Property ThirdPartyTextComponentToCheck As ISpellCheckableTextComponent
    Get
    Set
Public Property ThirdPartyTextComponentToCheck As ISpellCheckableTextComponent
    Get
    Set
public:
property ISpellCheckableTextComponent^ ThirdPartyTextComponentToCheck {
    ISpellCheckableTextComponent^ get ();
    void set (ISpellCheckableTextComponent^ value);
}
public:
property ISpellCheckableTextComponent^ ThirdPartyTextComponentToCheck {
    ISpellCheckableTextComponent^ get ();
    void set (ISpellCheckableTextComponent^ value);
}
member ThirdPartyTextComponentToCheck : ISpellCheckableTextComponent with get, set

member ThirdPartyTextComponentToCheck : ISpellCheckableTextComponent with get, set
Property Value
ISpellCheckableTextComponent


TopMost Property

TopMost Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► TopMost
Keyoti RapidSpell WPF
Whether the form is 'always on top'.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool TopMost { get; set; }
public bool TopMost { get; set; }
Public Property TopMost As Boolean
    Get
    Set
Public Property TopMost As Boolean
    Get
    Set
public:
property bool TopMost {
    bool get ();
    void set (bool value);
}
public:
property bool TopMost {
    bool get ();
    void set (bool value);
}
member TopMost : bool with get, set

member TopMost : bool with get, set
Property Value
Boolean


Undone Event

Undone Event
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► Undone
Keyoti RapidSpell WPF
Fired when an Undo occurs
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event UndoEventHandler Undone
public event UndoEventHandler Undone
Public Event Undone As UndoEventHandler
Public Event Undone As UndoEventHandler
public:
 event UndoEventHandler^ Undone {
    void add (UndoEventHandler^ value);
    void remove (UndoEventHandler^ value);
}
public:
 event UndoEventHandler^ Undone {
    void add (UndoEventHandler^ value);
    void remove (UndoEventHandler^ value);
}
member Undone : IEvent<UndoEventHandler,
    UndoEventArgs>

member Undone : IEvent<UndoEventHandler,
    UndoEventArgs>
Value
UndoEventHandler


UserDictionaryFile Property

UserDictionaryFile Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► UserDictionaryFile
Keyoti RapidSpell WPF
The user dictionary file, if this file doesn't exist it will be created.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionaryFile { get; set; }
public string UserDictionaryFile { get; set; }
Public Property UserDictionaryFile As String
    Get
    Set
Public Property UserDictionaryFile As String
    Get
    Set
public:
property String^ UserDictionaryFile {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserDictionaryFile {
    String^ get ();
    void set (String^ value);
}
member UserDictionaryFile : string with get, set

member UserDictionaryFile : string with get, set
Property Value
String
Remarks
Use of a user dictionary is optional.


UserInterfaceFormPresenter Property

UserInterfaceFormPresenter Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► UserInterfaceFormPresenter
Keyoti RapidSpell WPF
The presenter (eg. RapidSpellGUIPresenter) currently in use, may be null/Nothing if not created yet.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public IUserInterfaceFormPresenter UserInterfaceFormPresenter { get; }
public IUserInterfaceFormPresenter UserInterfaceFormPresenter { get; }
Public ReadOnly Property UserInterfaceFormPresenter As IUserInterfaceFormPresenter
    Get
Public ReadOnly Property UserInterfaceFormPresenter As IUserInterfaceFormPresenter
    Get
public:
property IUserInterfaceFormPresenter^ UserInterfaceFormPresenter {
    IUserInterfaceFormPresenter^ get ();
}
public:
property IUserInterfaceFormPresenter^ UserInterfaceFormPresenter {
    IUserInterfaceFormPresenter^ get ();
}
member UserInterfaceFormPresenter : IUserInterfaceFormPresenter with get

member UserInterfaceFormPresenter : IUserInterfaceFormPresenter with get
Property Value
IUserInterfaceFormPresenter


UserQuery Event

UserQuery Event
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► UserQuery
Keyoti RapidSpell WPF
Indicates that the user is being queried on a spelling error.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event UserQueryEventHandler UserQuery
public event UserQueryEventHandler UserQuery
Public Event UserQuery As UserQueryEventHandler
Public Event UserQuery As UserQueryEventHandler
public:
 event UserQueryEventHandler^ UserQuery {
    void add (UserQueryEventHandler^ value);
    void remove (UserQueryEventHandler^ value);
}
public:
 event UserQueryEventHandler^ UserQuery {
    void add (UserQueryEventHandler^ value);
    void remove (UserQueryEventHandler^ value);
}
member UserQuery : IEvent<UserQueryEventHandler,
    UserQueryEventArgs>

member UserQuery : IEvent<UserQueryEventHandler,
    UserQueryEventArgs>
Value
UserQueryEventHandler


V2Parser Property

V2Parser Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► V2Parser
Keyoti RapidSpell WPF
Whether to use parser version 2 - Set to false for backwards (pre v3.4) compatibility.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool V2Parser { get; set; }
public bool V2Parser { get; set; }
Public Property V2Parser As Boolean
    Get
    Set
Public Property V2Parser As Boolean
    Get
    Set
public:
property bool V2Parser {
    bool get ();
    void set (bool value);
}
public:
property bool V2Parser {
    bool get ();
    void set (bool value);
}
member V2Parser : bool with get, set

member V2Parser : bool with get, set
Property Value
Boolean


WarnDuplicates Property

WarnDuplicates Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► WarnDuplicates
Keyoti RapidSpell WPF
Whether to show duplicate words as errors (eg. "this is is an error").
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool WarnDuplicates { get; set; }
public bool WarnDuplicates { get; set; }
Public Property WarnDuplicates As Boolean
    Get
    Set
Public Property WarnDuplicates As Boolean
    Get
    Set
public:
property bool WarnDuplicates {
    bool get ();
    void set (bool value);
}
public:
property bool WarnDuplicates {
    bool get ();
    void set (bool value);
}
member WarnDuplicates : bool with get, set

member WarnDuplicates : bool with get, set
Property Value
Boolean


WindowStartupLocation Property

WindowStartupLocation Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► WindowStartupLocation
Keyoti RapidSpell WPF
The dialog window's startup location.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public WindowStartupLocation WindowStartupLocation { get; set; }
public WindowStartupLocation WindowStartupLocation { get; set; }
Public Property WindowStartupLocation As WindowStartupLocation
    Get
    Set
Public Property WindowStartupLocation As WindowStartupLocation
    Get
    Set
public:
property WindowStartupLocation WindowStartupLocation {
    WindowStartupLocation get ();
    void set (WindowStartupLocation value);
}
public:
property WindowStartupLocation WindowStartupLocation {
    WindowStartupLocation get ();
    void set (WindowStartupLocation value);
}
member WindowStartupLocation : WindowStartupLocation with get, set

member WindowStartupLocation : WindowStartupLocation with get, set
Property Value
WindowStartupLocation


WindowStyle Property

WindowStyle Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► WindowStyle
Keyoti RapidSpell WPF
The dialog window's style.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public WindowStyle WindowStyle { get; set; }
public WindowStyle WindowStyle { get; set; }
Public Property WindowStyle As WindowStyle
    Get
    Set
Public Property WindowStyle As WindowStyle
    Get
    Set
public:
property WindowStyle WindowStyle {
    WindowStyle get ();
    void set (WindowStyle value);
}
public:
property WindowStyle WindowStyle {
    WindowStyle get ();
    void set (WindowStyle value);
}
member WindowStyle : WindowStyle with get, set

member WindowStyle : WindowStyle with get, set
Property Value
WindowStyle


WordAdded Event

WordAdded Event
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► WordAdded
Keyoti RapidSpell WPF
Fired when word added to user dictionary
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event WordAddedEventHandler WordAdded
public event WordAddedEventHandler WordAdded
Public Event WordAdded As WordAddedEventHandler
Public Event WordAdded As WordAddedEventHandler
public:
 event WordAddedEventHandler^ WordAdded {
    void add (WordAddedEventHandler^ value);
    void remove (WordAddedEventHandler^ value);
}
public:
 event WordAddedEventHandler^ WordAdded {
    void add (WordAddedEventHandler^ value);
    void remove (WordAddedEventHandler^ value);
}
member WordAdded : IEvent<WordAddedEventHandler,
    WordAddedEventArgs>

member WordAdded : IEvent<WordAddedEventHandler,
    WordAddedEventArgs>
Value
WordAddedEventHandler


WordChanged Event

WordChanged Event
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► WordChanged
Keyoti RapidSpell WPF
Fired when a word is changed
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event WordChangedEventHandler WordChanged
public event WordChangedEventHandler WordChanged
Public Event WordChanged As WordChangedEventHandler
Public Event WordChanged As WordChangedEventHandler
public:
 event WordChangedEventHandler^ WordChanged {
    void add (WordChangedEventHandler^ value);
    void remove (WordChangedEventHandler^ value);
}
public:
 event WordChangedEventHandler^ WordChanged {
    void add (WordChangedEventHandler^ value);
    void remove (WordChangedEventHandler^ value);
}
member WordChanged : IEvent<WordChangedEventHandler,
    WordChangedEventArgs>

member WordChanged : IEvent<WordChangedEventHandler,
    WordChangedEventArgs>
Value
WordChangedEventHandler


WordChanging Event

WordChanging Event
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► WordChanging
Keyoti RapidSpell WPF
Fired before a word is changed
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event WordChangedEventHandler WordChanging
public event WordChangedEventHandler WordChanging
Public Event WordChanging As WordChangedEventHandler
Public Event WordChanging As WordChangedEventHandler
public:
 event WordChangedEventHandler^ WordChanging {
    void add (WordChangedEventHandler^ value);
    void remove (WordChangedEventHandler^ value);
}
public:
 event WordChangedEventHandler^ WordChanging {
    void add (WordChangedEventHandler^ value);
    void remove (WordChangedEventHandler^ value);
}
member WordChanging : IEvent<WordChangedEventHandler,
    WordChangedEventArgs>

member WordChanging : IEvent<WordChangedEventHandler,
    WordChangedEventArgs>
Value
WordChangedEventHandler


WordIgnored Event

WordIgnored Event
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► WordIgnored
Keyoti RapidSpell WPF
Fired when word ignored
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event WordIgnoredEventHandler WordIgnored
public event WordIgnoredEventHandler WordIgnored
Public Event WordIgnored As WordIgnoredEventHandler
Public Event WordIgnored As WordIgnoredEventHandler
public:
 event WordIgnoredEventHandler^ WordIgnored {
    void add (WordIgnoredEventHandler^ value);
    void remove (WordIgnoredEventHandler^ value);
}
public:
 event WordIgnoredEventHandler^ WordIgnored {
    void add (WordIgnoredEventHandler^ value);
    void remove (WordIgnoredEventHandler^ value);
}
member WordIgnored : IEvent<WordIgnoredEventHandler,
    WordIgnoredEventArgs>

member WordIgnored : IEvent<WordIgnoredEventHandler,
    WordIgnoredEventArgs>
Value
WordIgnoredEventHandler


WordRemoved Event

WordRemoved Event
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► WordRemoved
Keyoti RapidSpell WPF
Fired when a word is removed from user dictionary.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event WordRemovedEventHandler WordRemoved
public event WordRemovedEventHandler WordRemoved
Public Event WordRemoved As WordRemovedEventHandler
Public Event WordRemoved As WordRemovedEventHandler
public:
 event WordRemovedEventHandler^ WordRemoved {
    void add (WordRemovedEventHandler^ value);
    void remove (WordRemovedEventHandler^ value);
}
public:
 event WordRemovedEventHandler^ WordRemoved {
    void add (WordRemovedEventHandler^ value);
    void remove (WordRemovedEventHandler^ value);
}
member WordRemoved : IEvent<WordRemovedEventHandler,
    WordRemovedEventArgs>

member WordRemoved : IEvent<WordRemovedEventHandler,
    WordRemovedEventArgs>
Value
WordRemovedEventHandler


RapidSpellDialog.SpellCheckEventHandler Delegate

RapidSpellDialog..::..SpellCheckEventHandler Delegate
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► RapidSpellDialog..::..SpellCheckEventHandler
Keyoti RapidSpell WPF
Spell check event handler delegate.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void SpellCheckEventHandler(
    Object sender,
    SpellCheckEventArgs e
)
public delegate void SpellCheckEventHandler(
    Object sender,
    SpellCheckEventArgs e
)
Public Delegate Sub SpellCheckEventHandler (
    sender As Object,
    e As SpellCheckEventArgs
)
Public Delegate Sub SpellCheckEventHandler (
    sender As Object,
    e As SpellCheckEventArgs
)
public delegate void SpellCheckEventHandler(
    Object^ sender,
    SpellCheckEventArgs^ e
)
public delegate void SpellCheckEventHandler(
    Object^ sender,
    SpellCheckEventArgs^ e
)
type SpellCheckEventHandler =
    delegate of
        sender : Object *
        e : SpellCheckEventArgs -> unit
type SpellCheckEventHandler =
    delegate of
        sender : Object *
        e : SpellCheckEventArgs -> unit
Parameters
sender (Object)
e (SpellCheckEventArgs)


RapidSpellDialog.TextBoxSpellCheckEventHandler Delegate

RapidSpellDialog..::..TextBoxSpellCheckEventHandler Delegate
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► RapidSpellDialog..::..TextBoxSpellCheckEventHandler
Keyoti RapidSpell WPF
Handler delegate
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void TextBoxSpellCheckEventHandler(
    Object sender,
    TextBoxSpellCheckEventArgs e
)
public delegate void TextBoxSpellCheckEventHandler(
    Object sender,
    TextBoxSpellCheckEventArgs e
)
Public Delegate Sub TextBoxSpellCheckEventHandler (
    sender As Object,
    e As TextBoxSpellCheckEventArgs
)
Public Delegate Sub TextBoxSpellCheckEventHandler (
    sender As Object,
    e As TextBoxSpellCheckEventArgs
)
public delegate void TextBoxSpellCheckEventHandler(
    Object^ sender,
    TextBoxSpellCheckEventArgs^ e
)
public delegate void TextBoxSpellCheckEventHandler(
    Object^ sender,
    TextBoxSpellCheckEventArgs^ e
)
type TextBoxSpellCheckEventHandler =
    delegate of
        sender : Object *
        e : TextBoxSpellCheckEventArgs -> unit
type TextBoxSpellCheckEventHandler =
    delegate of
        sender : Object *
        e : TextBoxSpellCheckEventArgs -> unit
Parameters
sender (Object)
e (TextBoxSpellCheckEventArgs)


RapidSpellGUIPresenter Class

RapidSpellGUIPresenter Class
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter
Keyoti RapidSpell WPF
Controls the UI logic used for RapidSpellDialog forms.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class RapidSpellGUIPresenter : Component,
    IUserInterfaceFormPresenter, IDialogViewEventHandler
public class RapidSpellGUIPresenter : Component,
    IUserInterfaceFormPresenter, IDialogViewEventHandler
Public Class RapidSpellGUIPresenter
    Inherits Component
    Implements IUserInterfaceFormPresenter, IDialogViewEventHandler
Public Class RapidSpellGUIPresenter
    Inherits Component
    Implements IUserInterfaceFormPresenter, IDialogViewEventHandler
public ref class RapidSpellGUIPresenter : public Component,
    IUserInterfaceFormPresenter, IDialogViewEventHandler
public ref class RapidSpellGUIPresenter : public Component,
    IUserInterfaceFormPresenter, IDialogViewEventHandler
type RapidSpellGUIPresenter =
    class
        inherit Component
        interface IUserInterfaceFormPresenter
        interface IDialogViewEventHandler
    end
type RapidSpellGUIPresenter =
    class
        inherit Component
        interface IUserInterfaceFormPresenter
        interface IDialogViewEventHandler
    end
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RapidSpellGUIPresenter()()()() | Construct this GUI component - this will NOT open a new Form, call Check to do that.
 | active | The state of this GUI. It can be either active (user is using it) or inactive (user focus is elsewhere).
 | AddButtonText | Add button text.
 | AddWord()()()() | Adds the current bad word to the user dictionary.
 | AllOperationScope | The scope that ignore-all/change-all should have.
 | CancelButtonText | Cancel button text.
 | Cancelled | Whether the spell check has been cancelled.
 | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
 | ChangeAll()()()() | Called when user wants to change all instances of current bad word to selected word
 | ChangeAllButtonText | Change All button text.
 | ChangeButtonText | Change button text.
 | ChangeWord()()()() | User wants to change current bad word to selected word
 | Check()()()() | Bring up the spell checker Form and start checking the component set by SetTextComponentToCheck.
 | Check(ISpellCheckableTextComponent) | Bring up the spell checker Form and start checking the TextBoxBase textComponent.
 | CheckCompletePopUpText | Check complete pop up text
 | CheckCompletePopUpTitle | Check complete pop up title
 | CheckCompoundWords | Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
 | CheckerEngine | The checker engine to use, this object must implement the ICheckerEngine interface, allows customization or replacement of the spell checker.
 | CheckFromStartOfText | Whether to check from the start of the text (true) or whereever the cursor is (false)
 | checkingSelection | The state of this GUI. It can be either active (user is using it) or inactive (user focus is elsewhere).
 | CheckingSpellingText | Checking spelling text
 | Close()()()() | Closes the form if open.
 | ConsiderationRange | The factor for words to consider for suggestions, lower values are faster but consider less words for suggestions. Default is 80. If w <= 1 this method won't do anything.
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | CreateDialogView | Indicates that a new IDialogView has been created, also provides chance to override the default IDialogView.
 | CreateDialogViewOptions | Indicates that a new IDialogViewOptions is being created, also provides chance to override the default IDialogViewOptions.
 | CreateDialogViewUserDictionaryEdit | Indicates that a new IDialogViewUserDictionaryEdit is being created, also provides chance to override the default IDialogViewUserDictionaryEdit.
 | CreateDialogViewUserDictionarySelect | Indicates that a new IDialogViewUserDictionarySelect is being created, also provides chance to override the default IDialogViewUserDictionarySelect.
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | DialogTitleText | Dialog title text
 | DialogView | The IDialogView instance to use for the UI.
 | DialogView_AddButtonClick(Object, EventArgs) | Handles IDialogView event
 | DialogView_CancelButtonClick(Object, EventArgs) | Handles IDialogView event
 | DialogView_ChangeAllButtonClick(Object, EventArgs) | Handles IDialogView event
 | DialogView_ChangeButtonClick(Object, EventArgs) | Handles IDialogView event
 | DialogView_Closing(Object, CancelEventArgs) | Handles IDialogView event
 | DialogView_IgnoreAllButtonClick(Object, EventArgs) | Handles IDialogView event
 | DialogView_IgnoreButtonClick(Object, EventArgs) | Handles IDialogView event
 | DialogView_Load(Object, EventArgs) | Handles IDialogView event
 | DialogView_OptionsButtonClick(Object, EventArgs) | Handles IDialogView event
 | DialogView_QueryTextBoxEnter(Object, EventArgs) | Handles IDialogView event
 | DialogView_QueryTextBoxTextChanged(Object, EventArgs) | Handles IDialogView event
 | DialogView_SuggestionsListDoubleClick(Object, EventArgs) | Handles IDialogView event
 | DialogView_UndoButtonClick(Object, EventArgs) | Handles the Undo button click
 | DialogView_UserNeedsSuggestionsChanged(Object, EventArgs) | Handles IDialogView event
 | DialogViewOptionsPresenter_CreateDialogViewOptions(Object, CreateDialogViewOptionsEventArgs) | Handles IDialogView event
 | DialogViewOptionsPresenter_CreateDialogViewUserDictionaryEdit(Object, CreateDialogViewUserDictionaryEditEventArgs) | Handles IDialogView event
 | DialogViewOptionsPresenter_CreateDialogViewUserDictionarySelect(Object, CreateDialogViewUserDictionarySelectEventArgs) | Handles IDialogView event
 | DictFilePath | Optional file path to the main dictionary .dict file to use.
 | Dispose()()()() | Disposes of resources
 | Dispose(Boolean) | Frees up resources (Overrides Component.Dispose(Boolean).)
 | DisposeAtEnd | Whether to dispose of this form when spell check is finished.
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
 | End()()()() | Called when finished checking document, brings up spelling check is complete message.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | Finalize()()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | FindCapitalizedSuggestions | Whether to look for capitalized suggestions, note this will slow FindSuggestions down by about 7 times.
 | FindingSuggestionsLabelText | Finding suggestions label text.
 | findSuggestions | Whether this should look up suggestions for misspelt words or not.
 | FindSuggestionsLabelText | Find suggestions label text.
 | FindWordEnd(Int32) | Returns the end of the word that fromPos is in.
 | FinishedCheckingSelectionPopUpText | Finished checking selection dialog text
 | FinishedCheckingSelectionPopUpTitle | Finished checking selection dialog title
 | FocusGained(Object, EventArgs) | Called when objects whose focus this is listening to gain focus.
 | fromPosition | Where the user wants to check from in the document
 | GenerateSentenceParts(Int32, Int32) | Finds the sentence up to a point and the sentence after a point
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GUILanguage | The language to show the UI in.
 | guiShowing | Whether the gui is currently showing
 | Ignore()()()() | Ignore the current bad word.
 | IgnoreAll()()()() | Ignores all occurrences of this word.
 | IgnoreAllButtonText | Ignore All button text.
 | IgnoreButtonText | Ignore button text.
 | IgnoreCapitalizedWords | Whether to ignore words with capital letters.
 | IgnoreIncorrectSentenceCapitalization | Whether to ignore incorrect sentence capitalization.
 | IgnoreInEnglishLowerCaseI | Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
 | IgnoreWordsWithDigits | Whether to ignore words with numbers in them (eg. A10 or 7-11).
 | IgnoreXML | Whether to ignore XML/HTML tags, false by default.
 | IncludeUserDictionaryInSuggestions | Whether the user dictionary should be used in finding suggestions for misspelt words.
 | InDictionaryLabelText | In dictionary label text
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | IsDialogViewCreated()()()() | Whether a dialog view has already been created.
 | IsDisposed | Whether the IDialogView is disposed of
 | LanguageParser | The type of language parsing to use.
 | Load | Fired when the DialogView loads.
 | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
 | LookIntoHyphenatedText | Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
 | MakeChange()()()() | Changes the current bad word for one selected from the suggestions list or entered in the query pane returns the word used.
 | MakeChange(Boolean) | Changes the current bad word for one selected from the suggestions list or entered in the query pane returns the word used.
 | MakeChange(Boolean, String, Boolean) | Changes the current bad word for one selected from the suggestions list or entered in the query pane returns the word used.
 | MaximumContextualWords | The maximum number of words to show the user in the sentence around misspelled words.
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ModalAutoDispose | When running modally, determines if the dialog will be disposed of when spell check finishes.
 | ModalMode | Whether the spell checker will run modally. (Modal operation blocks the parent form)
 | ModalOwner | The modal dialog owner window.
 | MoveCaretToWordEnd()()()() | Moves the caret to the end of the word the caret is in, or where it is if not on a word.
 | MoveCaretToWordStart()()()() | Moves the caret to the start of the word the caret is in, or where it is if not on a word.
 | NoSuggestionsText | No suggestions found text
 | NotInDictionaryLabelText | Not in dictionary label text
 | NumberSuggestionList | Whether to number the items in the suggestion list, for quick user selection.
 | OnCreateDialogView(CreateDialogViewEventArgs) | Fires the CreateDialogView event.
 | OnSuggestionsDoubleClick(Object, EventArgs) | Called when the user double clicks on a suggestion.
 | OnUndone(UndoEventArgs) | Raises the Undone event
 | OnUserQuery(UserQueryEventArgs) | Fires the user query event
 | Options | Object responsible for holding, loading and saving the user's spell check options.
 | OptionsButtonText | Options button text
 | OptionsPresenter | Presenter for the user options form (IDialogViewOptions).
 | ProceedFromEnd()()()() | Decides what to do once reached end of required text check region
 | QueryTextBoxMultiline | Whether 'not in dictionary' text box is multiline or single line.
 | Ready | Fired when ready to proceed with first query.
 | RecheckDocumentRequest | Fired when document recheck is requested
 | Remove()()()() | Safely frees up resources.
 | RemoveDuplicateWordText | Remove duplicate word text
 | Resume()()()() | Looks for next bad word
 | ResumeButtonText | Resume button text
 | SelectText(BadWord) | Selects a bad word in the text component
 | SeparateHyphenWords | Sets whether to treat hyphenated (-) words as separate words, default is false.
 | SetDisposeAtEnd(Boolean) | Sets whether this will dispose of self at the end of the spell check.
 | SetIgnoreOnceBadWords(ArrayList) | Provide a list of BadWord objects that have been ignored
 | SetTextComponentToCheck(TextBox) | Set the TextBox (WPF) that this GUI will spell check.
 | SetTextComponentToCheck(RichTextBox) | Set the RichTextBox (WPF) that this GUI will spell check.
 | SetTextComponentToCheck(ISpellCheckableTextComponent) | Sets the ISpellCheckableTextComponent that this GUI will spell check.
 | SetTextComponentToCheck(ISpellCheckableTextComponent2) | Sets the ISpellCheckableTextComponent2 that this GUI will spell check.
 | SetUITexts()()()() | Applies the UI texts to the IDialogView
 | ShouldEnableAddButton()()()() | Determines if the Add button should be enabled
 | ShowContextSentence | Whether to show the query in context of it's sentence/line.
 | ShowFinishedMessageBox | Whether a message box should be opened when the spell check is complete.
 | showMessageBoxAtEnd |
 | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
 | SpellCheckFinished | Fired when checking finishes
 | SpellCheckStarted | Fired when checking starts
 | subFromPosition | To check from and to positions that are wrapped, need to do in 2 steps check from subFromPosition ( = fromPosition) -> subToPosition (= doc end) and then check from subFromPosition (= 0) -> subToPosition (= toPosition)
 | subToPosition | To check from and to positions that are wrapped, need to do in 2 steps check from subFromPosition ( = fromPosition) -> subToPosition (= doc end) and then check from subFromPosition (= 0) -> subToPosition (= toPosition)
 | SuggestionsKeyboardText | Suggestions label text when in keyboard mode
 | SuggestionsLabelText | Suggestions label text
 | SuggestionsMethod | The suggestions method to use.
 | SuggestSplitWords | Whether to look for connected words in suggestions.
 | TextBoundary | The AdvancedTextBoundary class to use to parse words.
 | TextBox | The text box instance that this is working with, the actual type depends on whether the TextBoxBaseToCheck property or ThirdPartyTextComponentToCheck property was set.
 | theBadWord |
 | theSpellChecker | The spell checker component being used
 | theTextComponent | The text component being checked
 | toPosition | Where the user wants to check to
 | ToString()()()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
 | Undo()()()() | Undoes the previous user operation.
 | UndoButtonText | Undo button text
 | Undone | Fired when an Undo occurs
 | UserDictionary | Set the user dictionary object.
 | UserDictionaryFile | Set the user dictionary file, if this file doesn't exist it will be created.
 | UserQuery | Indicates that the user is being queried on a spelling error.
 | WarnDuplicates | Whether to show duplicate words as errors (eg. "this is is an error").
 | WordAdded | Fired when word added to user dictionary
 | WordChanged | Fired when word changed
 | WordChanging | Fired before a word is changed
 | WordIgnored | Fired when word ignored
 | Wrap()()()() | Wraps the checker to start at beginning of doc
 | wrapped |
Remarks
This class contains no UI elements, instead they are held in it's DialogView property. To customize the UI layout and/or behavior, consult the user guide section "Custom RapidSpellDialog User Interface", which outlines how to use the various "Create*" events in RapidSpellDialog to return custom instances of this class or implementations of IDialogView.
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | RapidSpellGUIPresenter


RapidSpellGUIPresenter Constructor

RapidSpellGUIPresenter Constructor
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► RapidSpellGUIPresenter()()()()
Keyoti RapidSpell WPF
Construct this GUI component - this will NOT open a new Form, call Check to do that.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public RapidSpellGUIPresenter()
public RapidSpellGUIPresenter()
Public Sub New
Public Sub New
public:
RapidSpellGUIPresenter()
public:
RapidSpellGUIPresenter()
new : unit -> RapidSpellGUIPresenter
new : unit -> RapidSpellGUIPresenter


active Field

active Field
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► active
Keyoti RapidSpell WPF
The state of this GUI. It can be either active (user is using it) or inactive (user focus is elsewhere).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected bool active
protected bool active
Protected active As Boolean
Protected active As Boolean
protected:
bool active
protected:
bool active
val mutable active: bool
val mutable active: bool
Field Value
Boolean
Remarks
When this window loses focus the GUI is deactivated, because the text in theTextComponent can change whilst focus is away, and upon reactivation the new text must be loaded in. findSuggestions determines if should look up suggestions or not.


AddButtonText Property

AddButtonText Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► AddButtonText
Keyoti RapidSpell WPF
Add button text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string AddButtonText { get; set; }
public string AddButtonText { get; set; }
Public Property AddButtonText As String
    Get
    Set
Public Property AddButtonText As String
    Get
    Set
public:
virtual property String^ AddButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ AddButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract AddButtonText : string with get, set
override AddButtonText : string with get, set
abstract AddButtonText : string with get, set
override AddButtonText : string with get, set
Property Value
String


AddWord Method

AddWord Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► AddWord()()()()
Keyoti RapidSpell WPF
Adds the current bad word to the user dictionary.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void AddWord()
protected virtual void AddWord()
Protected Overridable Sub AddWord
Protected Overridable Sub AddWord
protected:
virtual void AddWord()
protected:
virtual void AddWord()
abstract AddWord : unit -> unit
override AddWord : unit -> unit
abstract AddWord : unit -> unit
override AddWord : unit -> unit
Return Value

void


AllOperationScope Property

AllOperationScope Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► AllOperationScope
Keyoti RapidSpell WPF
The scope that ignore-all/change-all should have.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public OperationScope AllOperationScope { get; set; }
public OperationScope AllOperationScope { get; set; }
Public Property AllOperationScope As OperationScope
    Get
    Set
Public Property AllOperationScope As OperationScope
    Get
    Set
public:
virtual property OperationScope AllOperationScope {
    OperationScope get () sealed;
    void set (OperationScope value) sealed;
}
public:
virtual property OperationScope AllOperationScope {
    OperationScope get () sealed;
    void set (OperationScope value) sealed;
}
abstract AllOperationScope : OperationScope with get, set
override AllOperationScope : OperationScope with get, set
abstract AllOperationScope : OperationScope with get, set
override AllOperationScope : OperationScope with get, set
Property Value
OperationScope


CancelButtonText Property

CancelButtonText Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► CancelButtonText
Keyoti RapidSpell WPF
Cancel button text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string CancelButtonText { get; set; }
public string CancelButtonText { get; set; }
Public Property CancelButtonText As String
    Get
    Set
Public Property CancelButtonText As String
    Get
    Set
public:
virtual property String^ CancelButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ CancelButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract CancelButtonText : string with get, set
override CancelButtonText : string with get, set
abstract CancelButtonText : string with get, set
override CancelButtonText : string with get, set
Property Value
String


Cancelled Property

Cancelled Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► Cancelled
Keyoti RapidSpell WPF
Whether the spell check has been cancelled.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool Cancelled { get; }
public bool Cancelled { get; }
Public ReadOnly Property Cancelled As Boolean
    Get
Public ReadOnly Property Cancelled As Boolean
    Get
public:
virtual property bool Cancelled {
    bool get () sealed;
}
public:
virtual property bool Cancelled {
    bool get () sealed;
}
abstract Cancelled : bool with get
override Cancelled : bool with get
abstract Cancelled : bool with get
override Cancelled : bool with get
Property Value
Boolean


ChangeAll Method

ChangeAll Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► ChangeAll()()()()
Keyoti RapidSpell WPF
Called when user wants to change all instances of current bad word to selected word
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void ChangeAll()
protected virtual void ChangeAll()
Protected Overridable Sub ChangeAll
Protected Overridable Sub ChangeAll
protected:
virtual void ChangeAll()
protected:
virtual void ChangeAll()
abstract ChangeAll : unit -> unit
override ChangeAll : unit -> unit
abstract ChangeAll : unit -> unit
override ChangeAll : unit -> unit
Return Value

void


ChangeAllButtonText Property

ChangeAllButtonText Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► ChangeAllButtonText
Keyoti RapidSpell WPF
Change All button text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string ChangeAllButtonText { get; set; }
public string ChangeAllButtonText { get; set; }
Public Property ChangeAllButtonText As String
    Get
    Set
Public Property ChangeAllButtonText As String
    Get
    Set
public:
virtual property String^ ChangeAllButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ ChangeAllButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract ChangeAllButtonText : string with get, set
override ChangeAllButtonText : string with get, set
abstract ChangeAllButtonText : string with get, set
override ChangeAllButtonText : string with get, set
Property Value
String


ChangeButtonText Property

ChangeButtonText Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► ChangeButtonText
Keyoti RapidSpell WPF
Change button text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string ChangeButtonText { get; set; }
public string ChangeButtonText { get; set; }
Public Property ChangeButtonText As String
    Get
    Set
Public Property ChangeButtonText As String
    Get
    Set
public:
virtual property String^ ChangeButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ ChangeButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract ChangeButtonText : string with get, set
override ChangeButtonText : string with get, set
abstract ChangeButtonText : string with get, set
override ChangeButtonText : string with get, set
Property Value
String


ChangeWord Method

ChangeWord Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► ChangeWord()()()()
Keyoti RapidSpell WPF
User wants to change current bad word to selected word
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void ChangeWord()
protected virtual void ChangeWord()
Protected Overridable Sub ChangeWord
Protected Overridable Sub ChangeWord
protected:
virtual void ChangeWord()
protected:
virtual void ChangeWord()
abstract ChangeWord : unit -> unit
override ChangeWord : unit -> unit
abstract ChangeWord : unit -> unit
override ChangeWord : unit -> unit
Return Value

void


Check Method

Check Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► Check()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | Check()()()() | Bring up the spell checker Form and start checking the component set by SetTextComponentToCheck.
 | Check(ISpellCheckableTextComponent) | Bring up the spell checker Form and start checking the TextBoxBase textComponent.


Check Method

Check Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► Check()()()()
Keyoti RapidSpell WPF
Bring up the spell checker Form and start checking the component set by SetTextComponentToCheck.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void Check()
public virtual void Check()
Public Overridable Sub Check
Public Overridable Sub Check
public:
virtual void Check()
public:
virtual void Check()
abstract Check : unit -> unit
override Check : unit -> unit
abstract Check : unit -> unit
override Check : unit -> unit
Exceptions
Exception | Condition
NoTextComponentException | if SetTextComponentToCheck hasn't be called first with a TextBoxBase object.


Check Method (textComponent)

Check Method (textComponent)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► Check(ISpellCheckableTextComponent)
Keyoti RapidSpell WPF
Bring up the spell checker Form and start checking the TextBoxBase textComponent.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void Check(
    ISpellCheckableTextComponent textComponent
)
public virtual void Check(
    ISpellCheckableTextComponent textComponent
)
Public Overridable Sub Check (
    textComponent As ISpellCheckableTextComponent
)
Public Overridable Sub Check (
    textComponent As ISpellCheckableTextComponent
)
public:
virtual void Check(
    ISpellCheckableTextComponent^ textComponent
)
public:
virtual void Check(
    ISpellCheckableTextComponent^ textComponent
)
abstract Check :
        textComponent : ISpellCheckableTextComponent -> unit
override Check :
        textComponent : ISpellCheckableTextComponent -> unit
abstract Check :
        textComponent : ISpellCheckableTextComponent -> unit
override Check :
        textComponent : ISpellCheckableTextComponent -> unit
Parameters
textComponent (ISpellCheckableTextComponent)
Exceptions
Exception | Condition
ArgumentNullException | if textComponent parameter is null.


CheckCompletePopUpText Property

CheckCompletePopUpText Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► CheckCompletePopUpText
Keyoti RapidSpell WPF
Check complete pop up text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string CheckCompletePopUpText { get; set; }
public string CheckCompletePopUpText { get; set; }
Public Property CheckCompletePopUpText As String
    Get
    Set
Public Property CheckCompletePopUpText As String
    Get
    Set
public:
virtual property String^ CheckCompletePopUpText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ CheckCompletePopUpText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract CheckCompletePopUpText : string with get, set
override CheckCompletePopUpText : string with get, set
abstract CheckCompletePopUpText : string with get, set
override CheckCompletePopUpText : string with get, set
Property Value
String


CheckCompletePopUpTitle Property

CheckCompletePopUpTitle Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► CheckCompletePopUpTitle
Keyoti RapidSpell WPF
Check complete pop up title
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string CheckCompletePopUpTitle { get; set; }
public string CheckCompletePopUpTitle { get; set; }
Public Property CheckCompletePopUpTitle As String
    Get
    Set
Public Property CheckCompletePopUpTitle As String
    Get
    Set
public:
virtual property String^ CheckCompletePopUpTitle {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ CheckCompletePopUpTitle {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract CheckCompletePopUpTitle : string with get, set
override CheckCompletePopUpTitle : string with get, set
abstract CheckCompletePopUpTitle : string with get, set
override CheckCompletePopUpTitle : string with get, set
Property Value
String


CheckCompoundWords Property

CheckCompoundWords Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► CheckCompoundWords
Keyoti RapidSpell WPF
Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool CheckCompoundWords { get; set; }
public bool CheckCompoundWords { get; set; }
Public Property CheckCompoundWords As Boolean
    Get
    Set
Public Property CheckCompoundWords As Boolean
    Get
    Set
public:
virtual property bool CheckCompoundWords {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool CheckCompoundWords {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract CheckCompoundWords : bool with get, set
override CheckCompoundWords : bool with get, set
abstract CheckCompoundWords : bool with get, set
override CheckCompoundWords : bool with get, set
Property Value
Boolean
Remarks
If this=false then LookUp("thesewordsarejoined") = false

If this=true then LookUp("thesewordsarejoined") = true

If this=false then LookUp("abcdef") = false

If this=true then LookUp("abcdef") = false

Setting this to true will degrade lookup performance


CheckerEngine Property

CheckerEngine Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► CheckerEngine
Keyoti RapidSpell WPF
The checker engine to use, this object must implement the ICheckerEngine interface, allows customization or replacement of the spell checker.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual ICheckerEngine CheckerEngine { get; set; }
public virtual ICheckerEngine CheckerEngine { get; set; }
Public Overridable Property CheckerEngine As ICheckerEngine
    Get
    Set
Public Overridable Property CheckerEngine As ICheckerEngine
    Get
    Set
public:
virtual property ICheckerEngine^ CheckerEngine {
    ICheckerEngine^ get ();
    void set (ICheckerEngine^ value);
}
public:
virtual property ICheckerEngine^ CheckerEngine {
    ICheckerEngine^ get ();
    void set (ICheckerEngine^ value);
}
abstract CheckerEngine : ICheckerEngine with get, set
override CheckerEngine : ICheckerEngine with get, set
abstract CheckerEngine : ICheckerEngine with get, set
override CheckerEngine : ICheckerEngine with get, set
Property Value
ICheckerEngine
Remarks
Use this property to replace the object used to perform checking, it is not necessary to replace this with a spell checker, any type of word parser can be used. For example an abbreviations checker could be written to replace common words with abbreviations. Caveat: Most properties in RapidSpellGUI are mirrors of properties in ICheckerEngine, setting a CheckerEngine AFTER setting properties in RapidSpellGUI will overwrite those property values with the values of CheckerEngine.


CheckFromStartOfText Property

CheckFromStartOfText Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► CheckFromStartOfText
Keyoti RapidSpell WPF
Whether to check from the start of the text (true) or whereever the cursor is (false)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool CheckFromStartOfText { get; set; }
public bool CheckFromStartOfText { get; set; }
Public Property CheckFromStartOfText As Boolean
    Get
    Set
Public Property CheckFromStartOfText As Boolean
    Get
    Set
public:
virtual property bool CheckFromStartOfText {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool CheckFromStartOfText {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract CheckFromStartOfText : bool with get, set
override CheckFromStartOfText : bool with get, set
abstract CheckFromStartOfText : bool with get, set
override CheckFromStartOfText : bool with get, set
Property Value
Boolean


checkingSelection Field

checkingSelection Field
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► checkingSelection
Keyoti RapidSpell WPF
The state of this GUI. It can be either active (user is using it) or inactive (user focus is elsewhere).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected bool checkingSelection
protected bool checkingSelection
Protected checkingSelection As Boolean
Protected checkingSelection As Boolean
protected:
bool checkingSelection
protected:
bool checkingSelection
val mutable checkingSelection: bool
val mutable checkingSelection: bool
Field Value
Boolean
Remarks
When this window loses focus the GUI is deactivated, because the text in theTextComponent can change whilst focus is away, and upon reactivation the new text must be loaded in. findSuggestions determines if should look up suggestions or not.


CheckingSpellingText Property

CheckingSpellingText Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► CheckingSpellingText
Keyoti RapidSpell WPF
Checking spelling text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string CheckingSpellingText { get; set; }
public string CheckingSpellingText { get; set; }
Public Property CheckingSpellingText As String
    Get
    Set
Public Property CheckingSpellingText As String
    Get
    Set
public:
virtual property String^ CheckingSpellingText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ CheckingSpellingText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract CheckingSpellingText : string with get, set
override CheckingSpellingText : string with get, set
abstract CheckingSpellingText : string with get, set
override CheckingSpellingText : string with get, set
Property Value
String


Close Method

Close Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► Close()()()()
Keyoti RapidSpell WPF
Closes the form if open.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void Close()
public void Close()
Public Sub Close
Public Sub Close
public:
void Close()
public:
void Close()
member Close : unit -> unit

member Close : unit -> unit


ConsiderationRange Property

ConsiderationRange Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► ConsiderationRange
Keyoti RapidSpell WPF
The factor for words to consider for suggestions, lower values are faster but consider less words for suggestions. Default is 80. If w <= 1 this method won't do anything.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int ConsiderationRange { get; set; }
public int ConsiderationRange { get; set; }
Public Property ConsiderationRange As Integer
    Get
    Set
Public Property ConsiderationRange As Integer
    Get
    Set
public:
virtual property int ConsiderationRange {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int ConsiderationRange {
    int get () sealed;
    void set (int value) sealed;
}
abstract ConsiderationRange : int with get, set
override ConsiderationRange : int with get, set
abstract ConsiderationRange : int with get, set
override ConsiderationRange : int with get, set
Property Value
Int32


CreateDialogView Event

CreateDialogView Event
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► CreateDialogView
Keyoti RapidSpell WPF
Indicates that a new IDialogView has been created, also provides chance to override the default IDialogView.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event CreateDialogViewEventHandler CreateDialogView
public event CreateDialogViewEventHandler CreateDialogView
Public Event CreateDialogView As CreateDialogViewEventHandler
Public Event CreateDialogView As CreateDialogViewEventHandler
public:
virtual  event CreateDialogViewEventHandler^ CreateDialogView {
    void add (CreateDialogViewEventHandler^ value);
    void remove (CreateDialogViewEventHandler^ value);
}
public:
virtual  event CreateDialogViewEventHandler^ CreateDialogView {
    void add (CreateDialogViewEventHandler^ value);
    void remove (CreateDialogViewEventHandler^ value);
}
abstract CreateDialogView : IEvent<CreateDialogViewEventHandler,
    CreateDialogViewEventArgs>
override CreateDialogView : IEvent<CreateDialogViewEventHandler,
    CreateDialogViewEventArgs>
abstract CreateDialogView : IEvent<CreateDialogViewEventHandler,
    CreateDialogViewEventArgs>
override CreateDialogView : IEvent<CreateDialogViewEventHandler,
    CreateDialogViewEventArgs>
Value
CreateDialogViewEventHandler


CreateDialogViewOptions Event

CreateDialogViewOptions Event
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► CreateDialogViewOptions
Keyoti RapidSpell WPF
Indicates that a new IDialogViewOptions is being created, also provides chance to override the default IDialogViewOptions.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event CreateDialogViewOptionsEventHandler CreateDialogViewOptions
public event CreateDialogViewOptionsEventHandler CreateDialogViewOptions
Public Event CreateDialogViewOptions As CreateDialogViewOptionsEventHandler
Public Event CreateDialogViewOptions As CreateDialogViewOptionsEventHandler
public:
virtual  event CreateDialogViewOptionsEventHandler^ CreateDialogViewOptions {
    void add (CreateDialogViewOptionsEventHandler^ value);
    void remove (CreateDialogViewOptionsEventHandler^ value);
}
public:
virtual  event CreateDialogViewOptionsEventHandler^ CreateDialogViewOptions {
    void add (CreateDialogViewOptionsEventHandler^ value);
    void remove (CreateDialogViewOptionsEventHandler^ value);
}
abstract CreateDialogViewOptions : IEvent<CreateDialogViewOptionsEventHandler,
    CreateDialogViewOptionsEventArgs>
override CreateDialogViewOptions : IEvent<CreateDialogViewOptionsEventHandler,
    CreateDialogViewOptionsEventArgs>
abstract CreateDialogViewOptions : IEvent<CreateDialogViewOptionsEventHandler,
    CreateDialogViewOptionsEventArgs>
override CreateDialogViewOptions : IEvent<CreateDialogViewOptionsEventHandler,
    CreateDialogViewOptionsEventArgs>
Value
CreateDialogViewOptionsEventHandler


CreateDialogViewUserDictionaryEdit Event

CreateDialogViewUserDictionaryEdit Event
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► CreateDialogViewUserDictionaryEdit
Keyoti RapidSpell WPF
Indicates that a new IDialogViewUserDictionaryEdit is being created, also provides chance to override the default IDialogViewUserDictionaryEdit.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event CreateDialogViewUserDictionaryEditEventHandler CreateDialogViewUserDictionaryEdit
public event CreateDialogViewUserDictionaryEditEventHandler CreateDialogViewUserDictionaryEdit
Public Event CreateDialogViewUserDictionaryEdit As CreateDialogViewUserDictionaryEditEventHandler
Public Event CreateDialogViewUserDictionaryEdit As CreateDialogViewUserDictionaryEditEventHandler
public:
virtual  event CreateDialogViewUserDictionaryEditEventHandler^ CreateDialogViewUserDictionaryEdit {
    void add (CreateDialogViewUserDictionaryEditEventHandler^ value);
    void remove (CreateDialogViewUserDictionaryEditEventHandler^ value);
}
public:
virtual  event CreateDialogViewUserDictionaryEditEventHandler^ CreateDialogViewUserDictionaryEdit {
    void add (CreateDialogViewUserDictionaryEditEventHandler^ value);
    void remove (CreateDialogViewUserDictionaryEditEventHandler^ value);
}
abstract CreateDialogViewUserDictionaryEdit : IEvent<CreateDialogViewUserDictionaryEditEventHandler,
    CreateDialogViewUserDictionaryEditEventArgs>
override CreateDialogViewUserDictionaryEdit : IEvent<CreateDialogViewUserDictionaryEditEventHandler,
    CreateDialogViewUserDictionaryEditEventArgs>
abstract CreateDialogViewUserDictionaryEdit : IEvent<CreateDialogViewUserDictionaryEditEventHandler,
    CreateDialogViewUserDictionaryEditEventArgs>
override CreateDialogViewUserDictionaryEdit : IEvent<CreateDialogViewUserDictionaryEditEventHandler,
    CreateDialogViewUserDictionaryEditEventArgs>
Value
CreateDialogViewUserDictionaryEditEventHandler


CreateDialogViewUserDictionarySelect Event

CreateDialogViewUserDictionarySelect Event
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► CreateDialogViewUserDictionarySelect
Keyoti RapidSpell WPF
Indicates that a new IDialogViewUserDictionarySelect is being created, also provides chance to override the default IDialogViewUserDictionarySelect.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event CreateDialogViewUserDictionarySelectEventHandler CreateDialogViewUserDictionarySelect
public event CreateDialogViewUserDictionarySelectEventHandler CreateDialogViewUserDictionarySelect
Public Event CreateDialogViewUserDictionarySelect As CreateDialogViewUserDictionarySelectEventHandler
Public Event CreateDialogViewUserDictionarySelect As CreateDialogViewUserDictionarySelectEventHandler
public:
virtual  event CreateDialogViewUserDictionarySelectEventHandler^ CreateDialogViewUserDictionarySelect {
    void add (CreateDialogViewUserDictionarySelectEventHandler^ value);
    void remove (CreateDialogViewUserDictionarySelectEventHandler^ value);
}
public:
virtual  event CreateDialogViewUserDictionarySelectEventHandler^ CreateDialogViewUserDictionarySelect {
    void add (CreateDialogViewUserDictionarySelectEventHandler^ value);
    void remove (CreateDialogViewUserDictionarySelectEventHandler^ value);
}
abstract CreateDialogViewUserDictionarySelect : IEvent<CreateDialogViewUserDictionarySelectEventHandler,
    CreateDialogViewUserDictionarySelectEventArgs>
override CreateDialogViewUserDictionarySelect : IEvent<CreateDialogViewUserDictionarySelectEventHandler,
    CreateDialogViewUserDictionarySelectEventArgs>
abstract CreateDialogViewUserDictionarySelect : IEvent<CreateDialogViewUserDictionarySelectEventHandler,
    CreateDialogViewUserDictionarySelectEventArgs>
override CreateDialogViewUserDictionarySelect : IEvent<CreateDialogViewUserDictionarySelectEventHandler,
    CreateDialogViewUserDictionarySelectEventArgs>
Value
CreateDialogViewUserDictionarySelectEventHandler


DialogTitleText Property

DialogTitleText Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► DialogTitleText
Keyoti RapidSpell WPF
Dialog title text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string DialogTitleText { get; set; }
public string DialogTitleText { get; set; }
Public Property DialogTitleText As String
    Get
    Set
Public Property DialogTitleText As String
    Get
    Set
public:
virtual property String^ DialogTitleText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ DialogTitleText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract DialogTitleText : string with get, set
override DialogTitleText : string with get, set
abstract DialogTitleText : string with get, set
override DialogTitleText : string with get, set
Property Value
String


DialogView Property

DialogView Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► DialogView
Keyoti RapidSpell WPF
The IDialogView instance to use for the UI.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual IDialogView DialogView { get; set; }
public virtual IDialogView DialogView { get; set; }
Public Overridable Property DialogView As IDialogView
    Get
    Set
Public Overridable Property DialogView As IDialogView
    Get
    Set
public:
virtual property IDialogView^ DialogView {
    IDialogView^ get ();
    void set (IDialogView^ value);
}
public:
virtual property IDialogView^ DialogView {
    IDialogView^ get ();
    void set (IDialogView^ value);
}
abstract DialogView : IDialogView with get, set
override DialogView : IDialogView with get, set
abstract DialogView : IDialogView with get, set
override DialogView : IDialogView with get, set
Property Value
IDialogView
Remarks
Handler CreateDialogView and set NewView to set a different instance to use.


DialogView_AddButtonClick Method (sender, e)

DialogView_AddButtonClick Method (sender, e)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► DialogView_AddButtonClick(Object, EventArgs)
Keyoti RapidSpell WPF
Handles IDialogView event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void DialogView_AddButtonClick(
    Object sender,
    EventArgs e
)
public virtual void DialogView_AddButtonClick(
    Object sender,
    EventArgs e
)
Public Overridable Sub DialogView_AddButtonClick (
    sender As Object,
    e As EventArgs
)
Public Overridable Sub DialogView_AddButtonClick (
    sender As Object,
    e As EventArgs
)
public:
virtual void DialogView_AddButtonClick(
    Object^ sender,
    EventArgs^ e
)
public:
virtual void DialogView_AddButtonClick(
    Object^ sender,
    EventArgs^ e
)
abstract DialogView_AddButtonClick :
        sender : Object *
        e : EventArgs -> unit
override DialogView_AddButtonClick :
        sender : Object *
        e : EventArgs -> unit
abstract DialogView_AddButtonClick :
        sender : Object *
        e : EventArgs -> unit
override DialogView_AddButtonClick :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


DialogView_CancelButtonClick Method (sender, e)

DialogView_CancelButtonClick Method (sender, e)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► DialogView_CancelButtonClick(Object, EventArgs)
Keyoti RapidSpell WPF
Handles IDialogView event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void DialogView_CancelButtonClick(
    Object sender,
    EventArgs e
)
public virtual void DialogView_CancelButtonClick(
    Object sender,
    EventArgs e
)
Public Overridable Sub DialogView_CancelButtonClick (
    sender As Object,
    e As EventArgs
)
Public Overridable Sub DialogView_CancelButtonClick (
    sender As Object,
    e As EventArgs
)
public:
virtual void DialogView_CancelButtonClick(
    Object^ sender,
    EventArgs^ e
)
public:
virtual void DialogView_CancelButtonClick(
    Object^ sender,
    EventArgs^ e
)
abstract DialogView_CancelButtonClick :
        sender : Object *
        e : EventArgs -> unit
override DialogView_CancelButtonClick :
        sender : Object *
        e : EventArgs -> unit
abstract DialogView_CancelButtonClick :
        sender : Object *
        e : EventArgs -> unit
override DialogView_CancelButtonClick :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


DialogView_ChangeAllButtonClick Method (sender, e)

DialogView_ChangeAllButtonClick Method (sender, e)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► DialogView_ChangeAllButtonClick(Object, EventArgs)
Keyoti RapidSpell WPF
Handles IDialogView event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void DialogView_ChangeAllButtonClick(
    Object sender,
    EventArgs e
)
public virtual void DialogView_ChangeAllButtonClick(
    Object sender,
    EventArgs e
)
Public Overridable Sub DialogView_ChangeAllButtonClick (
    sender As Object,
    e As EventArgs
)
Public Overridable Sub DialogView_ChangeAllButtonClick (
    sender As Object,
    e As EventArgs
)
public:
virtual void DialogView_ChangeAllButtonClick(
    Object^ sender,
    EventArgs^ e
)
public:
virtual void DialogView_ChangeAllButtonClick(
    Object^ sender,
    EventArgs^ e
)
abstract DialogView_ChangeAllButtonClick :
        sender : Object *
        e : EventArgs -> unit
override DialogView_ChangeAllButtonClick :
        sender : Object *
        e : EventArgs -> unit
abstract DialogView_ChangeAllButtonClick :
        sender : Object *
        e : EventArgs -> unit
override DialogView_ChangeAllButtonClick :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


DialogView_ChangeButtonClick Method (sender, e)

DialogView_ChangeButtonClick Method (sender, e)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► DialogView_ChangeButtonClick(Object, EventArgs)
Keyoti RapidSpell WPF
Handles IDialogView event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void DialogView_ChangeButtonClick(
    Object sender,
    EventArgs e
)
public virtual void DialogView_ChangeButtonClick(
    Object sender,
    EventArgs e
)
Public Overridable Sub DialogView_ChangeButtonClick (
    sender As Object,
    e As EventArgs
)
Public Overridable Sub DialogView_ChangeButtonClick (
    sender As Object,
    e As EventArgs
)
public:
virtual void DialogView_ChangeButtonClick(
    Object^ sender,
    EventArgs^ e
)
public:
virtual void DialogView_ChangeButtonClick(
    Object^ sender,
    EventArgs^ e
)
abstract DialogView_ChangeButtonClick :
        sender : Object *
        e : EventArgs -> unit
override DialogView_ChangeButtonClick :
        sender : Object *
        e : EventArgs -> unit
abstract DialogView_ChangeButtonClick :
        sender : Object *
        e : EventArgs -> unit
override DialogView_ChangeButtonClick :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


DialogView_Closing Method (sender, e)

DialogView_Closing Method (sender, e)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► DialogView_Closing(Object, CancelEventArgs)
Keyoti RapidSpell WPF
Handles IDialogView event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void DialogView_Closing(
    Object sender,
    CancelEventArgs e
)
public virtual void DialogView_Closing(
    Object sender,
    CancelEventArgs e
)
Public Overridable Sub DialogView_Closing (
    sender As Object,
    e As CancelEventArgs
)
Public Overridable Sub DialogView_Closing (
    sender As Object,
    e As CancelEventArgs
)
public:
virtual void DialogView_Closing(
    Object^ sender,
    CancelEventArgs^ e
)
public:
virtual void DialogView_Closing(
    Object^ sender,
    CancelEventArgs^ e
)
abstract DialogView_Closing :
        sender : Object *
        e : CancelEventArgs -> unit
override DialogView_Closing :
        sender : Object *
        e : CancelEventArgs -> unit
abstract DialogView_Closing :
        sender : Object *
        e : CancelEventArgs -> unit
override DialogView_Closing :
        sender : Object *
        e : CancelEventArgs -> unit
Parameters
sender (Object)
e (CancelEventArgs)


DialogView_IgnoreAllButtonClick Method (s, e)

DialogView_IgnoreAllButtonClick Method (s, e)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► DialogView_IgnoreAllButtonClick(Object, EventArgs)
Keyoti RapidSpell WPF
Handles IDialogView event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void DialogView_IgnoreAllButtonClick(
    Object s,
    EventArgs e
)
public virtual void DialogView_IgnoreAllButtonClick(
    Object s,
    EventArgs e
)
Public Overridable Sub DialogView_IgnoreAllButtonClick (
    s As Object,
    e As EventArgs
)
Public Overridable Sub DialogView_IgnoreAllButtonClick (
    s As Object,
    e As EventArgs
)
public:
virtual void DialogView_IgnoreAllButtonClick(
    Object^ s,
    EventArgs^ e
)
public:
virtual void DialogView_IgnoreAllButtonClick(
    Object^ s,
    EventArgs^ e
)
abstract DialogView_IgnoreAllButtonClick :
        s : Object *
        e : EventArgs -> unit
override DialogView_IgnoreAllButtonClick :
        s : Object *
        e : EventArgs -> unit
abstract DialogView_IgnoreAllButtonClick :
        s : Object *
        e : EventArgs -> unit
override DialogView_IgnoreAllButtonClick :
        s : Object *
        e : EventArgs -> unit
Parameters
s (Object)
e (EventArgs)


DialogView_IgnoreButtonClick Method (s, e)

DialogView_IgnoreButtonClick Method (s, e)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► DialogView_IgnoreButtonClick(Object, EventArgs)
Keyoti RapidSpell WPF
Handles IDialogView event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void DialogView_IgnoreButtonClick(
    Object s,
    EventArgs e
)
public virtual void DialogView_IgnoreButtonClick(
    Object s,
    EventArgs e
)
Public Overridable Sub DialogView_IgnoreButtonClick (
    s As Object,
    e As EventArgs
)
Public Overridable Sub DialogView_IgnoreButtonClick (
    s As Object,
    e As EventArgs
)
public:
virtual void DialogView_IgnoreButtonClick(
    Object^ s,
    EventArgs^ e
)
public:
virtual void DialogView_IgnoreButtonClick(
    Object^ s,
    EventArgs^ e
)
abstract DialogView_IgnoreButtonClick :
        s : Object *
        e : EventArgs -> unit
override DialogView_IgnoreButtonClick :
        s : Object *
        e : EventArgs -> unit
abstract DialogView_IgnoreButtonClick :
        s : Object *
        e : EventArgs -> unit
override DialogView_IgnoreButtonClick :
        s : Object *
        e : EventArgs -> unit
Parameters
s (Object)
e (EventArgs)


DialogView_Load Method (s, e)

DialogView_Load Method (s, e)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► DialogView_Load(Object, EventArgs)
Keyoti RapidSpell WPF
Handles IDialogView event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void DialogView_Load(
    Object s,
    EventArgs e
)
public virtual void DialogView_Load(
    Object s,
    EventArgs e
)
Public Overridable Sub DialogView_Load (
    s As Object,
    e As EventArgs
)
Public Overridable Sub DialogView_Load (
    s As Object,
    e As EventArgs
)
public:
virtual void DialogView_Load(
    Object^ s,
    EventArgs^ e
)
public:
virtual void DialogView_Load(
    Object^ s,
    EventArgs^ e
)
abstract DialogView_Load :
        s : Object *
        e : EventArgs -> unit
override DialogView_Load :
        s : Object *
        e : EventArgs -> unit
abstract DialogView_Load :
        s : Object *
        e : EventArgs -> unit
override DialogView_Load :
        s : Object *
        e : EventArgs -> unit
Parameters
s (Object)
e (EventArgs)


DialogView_OptionsButtonClick Method (sender, e)

DialogView_OptionsButtonClick Method (sender, e)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► DialogView_OptionsButtonClick(Object, EventArgs)
Keyoti RapidSpell WPF
Handles IDialogView event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void DialogView_OptionsButtonClick(
    Object sender,
    EventArgs e
)
public virtual void DialogView_OptionsButtonClick(
    Object sender,
    EventArgs e
)
Public Overridable Sub DialogView_OptionsButtonClick (
    sender As Object,
    e As EventArgs
)
Public Overridable Sub DialogView_OptionsButtonClick (
    sender As Object,
    e As EventArgs
)
public:
virtual void DialogView_OptionsButtonClick(
    Object^ sender,
    EventArgs^ e
)
public:
virtual void DialogView_OptionsButtonClick(
    Object^ sender,
    EventArgs^ e
)
abstract DialogView_OptionsButtonClick :
        sender : Object *
        e : EventArgs -> unit
override DialogView_OptionsButtonClick :
        sender : Object *
        e : EventArgs -> unit
abstract DialogView_OptionsButtonClick :
        sender : Object *
        e : EventArgs -> unit
override DialogView_OptionsButtonClick :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


DialogView_QueryTextBoxEnter Method (sender, e)

DialogView_QueryTextBoxEnter Method (sender, e)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► DialogView_QueryTextBoxEnter(Object, EventArgs)
Keyoti RapidSpell WPF
Handles IDialogView event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void DialogView_QueryTextBoxEnter(
    Object sender,
    EventArgs e
)
public virtual void DialogView_QueryTextBoxEnter(
    Object sender,
    EventArgs e
)
Public Overridable Sub DialogView_QueryTextBoxEnter (
    sender As Object,
    e As EventArgs
)
Public Overridable Sub DialogView_QueryTextBoxEnter (
    sender As Object,
    e As EventArgs
)
public:
virtual void DialogView_QueryTextBoxEnter(
    Object^ sender,
    EventArgs^ e
)
public:
virtual void DialogView_QueryTextBoxEnter(
    Object^ sender,
    EventArgs^ e
)
abstract DialogView_QueryTextBoxEnter :
        sender : Object *
        e : EventArgs -> unit
override DialogView_QueryTextBoxEnter :
        sender : Object *
        e : EventArgs -> unit
abstract DialogView_QueryTextBoxEnter :
        sender : Object *
        e : EventArgs -> unit
override DialogView_QueryTextBoxEnter :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


DialogView_QueryTextBoxTextChanged Method (sender, e)

DialogView_QueryTextBoxTextChanged Method (sender, e)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► DialogView_QueryTextBoxTextChanged(Object, EventArgs)
Keyoti RapidSpell WPF
Handles IDialogView event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void DialogView_QueryTextBoxTextChanged(
    Object sender,
    EventArgs e
)
public virtual void DialogView_QueryTextBoxTextChanged(
    Object sender,
    EventArgs e
)
Public Overridable Sub DialogView_QueryTextBoxTextChanged (
    sender As Object,
    e As EventArgs
)
Public Overridable Sub DialogView_QueryTextBoxTextChanged (
    sender As Object,
    e As EventArgs
)
public:
virtual void DialogView_QueryTextBoxTextChanged(
    Object^ sender,
    EventArgs^ e
)
public:
virtual void DialogView_QueryTextBoxTextChanged(
    Object^ sender,
    EventArgs^ e
)
abstract DialogView_QueryTextBoxTextChanged :
        sender : Object *
        e : EventArgs -> unit
override DialogView_QueryTextBoxTextChanged :
        sender : Object *
        e : EventArgs -> unit
abstract DialogView_QueryTextBoxTextChanged :
        sender : Object *
        e : EventArgs -> unit
override DialogView_QueryTextBoxTextChanged :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


DialogView_SuggestionsListDoubleClick Method (sender, e)

DialogView_SuggestionsListDoubleClick Method (sender, e)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► DialogView_SuggestionsListDoubleClick(Object, EventArgs)
Keyoti RapidSpell WPF
Handles IDialogView event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void DialogView_SuggestionsListDoubleClick(
    Object sender,
    EventArgs e
)
public virtual void DialogView_SuggestionsListDoubleClick(
    Object sender,
    EventArgs e
)
Public Overridable Sub DialogView_SuggestionsListDoubleClick (
    sender As Object,
    e As EventArgs
)
Public Overridable Sub DialogView_SuggestionsListDoubleClick (
    sender As Object,
    e As EventArgs
)
public:
virtual void DialogView_SuggestionsListDoubleClick(
    Object^ sender,
    EventArgs^ e
)
public:
virtual void DialogView_SuggestionsListDoubleClick(
    Object^ sender,
    EventArgs^ e
)
abstract DialogView_SuggestionsListDoubleClick :
        sender : Object *
        e : EventArgs -> unit
override DialogView_SuggestionsListDoubleClick :
        sender : Object *
        e : EventArgs -> unit
abstract DialogView_SuggestionsListDoubleClick :
        sender : Object *
        e : EventArgs -> unit
override DialogView_SuggestionsListDoubleClick :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


DialogView_UndoButtonClick Method (sender, e)

DialogView_UndoButtonClick Method (sender, e)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► DialogView_UndoButtonClick(Object, EventArgs)
Keyoti RapidSpell WPF
Handles the Undo button click
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void DialogView_UndoButtonClick(
    Object sender,
    EventArgs e
)
public virtual void DialogView_UndoButtonClick(
    Object sender,
    EventArgs e
)
Public Overridable Sub DialogView_UndoButtonClick (
    sender As Object,
    e As EventArgs
)
Public Overridable Sub DialogView_UndoButtonClick (
    sender As Object,
    e As EventArgs
)
public:
virtual void DialogView_UndoButtonClick(
    Object^ sender,
    EventArgs^ e
)
public:
virtual void DialogView_UndoButtonClick(
    Object^ sender,
    EventArgs^ e
)
abstract DialogView_UndoButtonClick :
        sender : Object *
        e : EventArgs -> unit
override DialogView_UndoButtonClick :
        sender : Object *
        e : EventArgs -> unit
abstract DialogView_UndoButtonClick :
        sender : Object *
        e : EventArgs -> unit
override DialogView_UndoButtonClick :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


DialogView_UserNeedsSuggestionsChanged Method (sender, e)

DialogView_UserNeedsSuggestionsChanged Method (sender, e)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► DialogView_UserNeedsSuggestionsChanged(Object, EventArgs)
Keyoti RapidSpell WPF
Handles IDialogView event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void DialogView_UserNeedsSuggestionsChanged(
    Object sender,
    EventArgs e
)
public virtual void DialogView_UserNeedsSuggestionsChanged(
    Object sender,
    EventArgs e
)
Public Overridable Sub DialogView_UserNeedsSuggestionsChanged (
    sender As Object,
    e As EventArgs
)
Public Overridable Sub DialogView_UserNeedsSuggestionsChanged (
    sender As Object,
    e As EventArgs
)
public:
virtual void DialogView_UserNeedsSuggestionsChanged(
    Object^ sender,
    EventArgs^ e
)
public:
virtual void DialogView_UserNeedsSuggestionsChanged(
    Object^ sender,
    EventArgs^ e
)
abstract DialogView_UserNeedsSuggestionsChanged :
        sender : Object *
        e : EventArgs -> unit
override DialogView_UserNeedsSuggestionsChanged :
        sender : Object *
        e : EventArgs -> unit
abstract DialogView_UserNeedsSuggestionsChanged :
        sender : Object *
        e : EventArgs -> unit
override DialogView_UserNeedsSuggestionsChanged :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


DialogViewOptionsPresenter_CreateDialogViewOptions Method (s, ev)

DialogViewOptionsPresenter_CreateDialogViewOptions Method (s, ev)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► DialogViewOptionsPresenter_CreateDialogViewOptions(Object, CreateDialogViewOptionsEventArgs)
Keyoti RapidSpell WPF
Handles IDialogView event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected internal virtual void DialogViewOptionsPresenter_CreateDialogViewOptions(
    Object s,
    CreateDialogViewOptionsEventArgs ev
)
protected internal virtual void DialogViewOptionsPresenter_CreateDialogViewOptions(
    Object s,
    CreateDialogViewOptionsEventArgs ev
)
Protected Friend Overridable Sub DialogViewOptionsPresenter_CreateDialogViewOptions (
    s As Object,
    ev As CreateDialogViewOptionsEventArgs
)
Protected Friend Overridable Sub DialogViewOptionsPresenter_CreateDialogViewOptions (
    s As Object,
    ev As CreateDialogViewOptionsEventArgs
)
protected public:
virtual void DialogViewOptionsPresenter_CreateDialogViewOptions(
    Object^ s,
    CreateDialogViewOptionsEventArgs^ ev
)
protected public:
virtual void DialogViewOptionsPresenter_CreateDialogViewOptions(
    Object^ s,
    CreateDialogViewOptionsEventArgs^ ev
)
abstract DialogViewOptionsPresenter_CreateDialogViewOptions :
        s : Object *
        ev : CreateDialogViewOptionsEventArgs -> unit
override DialogViewOptionsPresenter_CreateDialogViewOptions :
        s : Object *
        ev : CreateDialogViewOptionsEventArgs -> unit
abstract DialogViewOptionsPresenter_CreateDialogViewOptions :
        s : Object *
        ev : CreateDialogViewOptionsEventArgs -> unit
override DialogViewOptionsPresenter_CreateDialogViewOptions :
        s : Object *
        ev : CreateDialogViewOptionsEventArgs -> unit
Parameters
s (Object)
ev (CreateDialogViewOptionsEventArgs)


DialogViewOptionsPresenter_CreateDialogViewUserDictionaryEdit Method (sender, e)

DialogViewOptionsPresenter_CreateDialogViewUserDictionaryEdit Method (sender, e)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► DialogViewOptionsPresenter_CreateDialogViewUserDictionaryEdit(Object, CreateDialogViewUserDictionaryEditEventArgs)
Keyoti RapidSpell WPF
Handles IDialogView event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected internal virtual void DialogViewOptionsPresenter_CreateDialogViewUserDictionaryEdit(
    Object sender,
    CreateDialogViewUserDictionaryEditEventArgs e
)
protected internal virtual void DialogViewOptionsPresenter_CreateDialogViewUserDictionaryEdit(
    Object sender,
    CreateDialogViewUserDictionaryEditEventArgs e
)
Protected Friend Overridable Sub DialogViewOptionsPresenter_CreateDialogViewUserDictionaryEdit (
    sender As Object,
    e As CreateDialogViewUserDictionaryEditEventArgs
)
Protected Friend Overridable Sub DialogViewOptionsPresenter_CreateDialogViewUserDictionaryEdit (
    sender As Object,
    e As CreateDialogViewUserDictionaryEditEventArgs
)
protected public:
virtual void DialogViewOptionsPresenter_CreateDialogViewUserDictionaryEdit(
    Object^ sender,
    CreateDialogViewUserDictionaryEditEventArgs^ e
)
protected public:
virtual void DialogViewOptionsPresenter_CreateDialogViewUserDictionaryEdit(
    Object^ sender,
    CreateDialogViewUserDictionaryEditEventArgs^ e
)
abstract DialogViewOptionsPresenter_CreateDialogViewUserDictionaryEdit :
        sender : Object *
        e : CreateDialogViewUserDictionaryEditEventArgs -> unit
override DialogViewOptionsPresenter_CreateDialogViewUserDictionaryEdit :
        sender : Object *
        e : CreateDialogViewUserDictionaryEditEventArgs -> unit
abstract DialogViewOptionsPresenter_CreateDialogViewUserDictionaryEdit :
        sender : Object *
        e : CreateDialogViewUserDictionaryEditEventArgs -> unit
override DialogViewOptionsPresenter_CreateDialogViewUserDictionaryEdit :
        sender : Object *
        e : CreateDialogViewUserDictionaryEditEventArgs -> unit
Parameters
sender (Object)
e (CreateDialogViewUserDictionaryEditEventArgs)


DialogViewOptionsPresenter_CreateDialogViewUserDictionarySelect Method (sender, e)

DialogViewOptionsPresenter_CreateDialogViewUserDictionarySelect Method (sender, e)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► DialogViewOptionsPresenter_CreateDialogViewUserDictionarySelect(Object, CreateDialogViewUserDictionarySelectEventArgs)
Keyoti RapidSpell WPF
Handles IDialogView event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected internal virtual void DialogViewOptionsPresenter_CreateDialogViewUserDictionarySelect(
    Object sender,
    CreateDialogViewUserDictionarySelectEventArgs e
)
protected internal virtual void DialogViewOptionsPresenter_CreateDialogViewUserDictionarySelect(
    Object sender,
    CreateDialogViewUserDictionarySelectEventArgs e
)
Protected Friend Overridable Sub DialogViewOptionsPresenter_CreateDialogViewUserDictionarySelect (
    sender As Object,
    e As CreateDialogViewUserDictionarySelectEventArgs
)
Protected Friend Overridable Sub DialogViewOptionsPresenter_CreateDialogViewUserDictionarySelect (
    sender As Object,
    e As CreateDialogViewUserDictionarySelectEventArgs
)
protected public:
virtual void DialogViewOptionsPresenter_CreateDialogViewUserDictionarySelect(
    Object^ sender,
    CreateDialogViewUserDictionarySelectEventArgs^ e
)
protected public:
virtual void DialogViewOptionsPresenter_CreateDialogViewUserDictionarySelect(
    Object^ sender,
    CreateDialogViewUserDictionarySelectEventArgs^ e
)
abstract DialogViewOptionsPresenter_CreateDialogViewUserDictionarySelect :
        sender : Object *
        e : CreateDialogViewUserDictionarySelectEventArgs -> unit
override DialogViewOptionsPresenter_CreateDialogViewUserDictionarySelect :
        sender : Object *
        e : CreateDialogViewUserDictionarySelectEventArgs -> unit
abstract DialogViewOptionsPresenter_CreateDialogViewUserDictionarySelect :
        sender : Object *
        e : CreateDialogViewUserDictionarySelectEventArgs -> unit
override DialogViewOptionsPresenter_CreateDialogViewUserDictionarySelect :
        sender : Object *
        e : CreateDialogViewUserDictionarySelectEventArgs -> unit
Parameters
sender (Object)
e (CreateDialogViewUserDictionarySelectEventArgs)


DictFilePath Property

DictFilePath Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► DictFilePath
Keyoti RapidSpell WPF
Optional file path to the main dictionary .dict file to use.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string DictFilePath { get; set; }
public string DictFilePath { get; set; }
Public Property DictFilePath As String
    Get
    Set
Public Property DictFilePath As String
    Get
    Set
public:
virtual property String^ DictFilePath {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ DictFilePath {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract DictFilePath : string with get, set
override DictFilePath : string with get, set
abstract DictFilePath : string with get, set
override DictFilePath : string with get, set
Property Value
String


Dispose Method

Dispose Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► Dispose()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | Dispose()()()() | Disposes of resources
 | Dispose(Boolean) | Frees up resources (Overrides Component.Dispose(Boolean).)


Dispose Method

Dispose Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► Dispose()()()()
Keyoti RapidSpell WPF
Disposes of resources
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void Dispose()
public void Dispose()
Public Sub Dispose
Public Sub Dispose
public:
virtual void Dispose() sealed
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit
abstract Dispose : unit -> unit
override Dispose : unit -> unit


Dispose Method (disposing)

Dispose Method (disposing)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► Dispose(Boolean)
Keyoti RapidSpell WPF
Frees up resources
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
Parameters
disposing (Boolean)


DisposeAtEnd Property

DisposeAtEnd Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► DisposeAtEnd
Keyoti RapidSpell WPF
Whether to dispose of this form when spell check is finished.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool DisposeAtEnd { get; set; }
public bool DisposeAtEnd { get; set; }
Public Property DisposeAtEnd As Boolean
    Get
    Set
Public Property DisposeAtEnd As Boolean
    Get
    Set
public:
virtual property bool DisposeAtEnd {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool DisposeAtEnd {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract DisposeAtEnd : bool with get, set
override DisposeAtEnd : bool with get, set
abstract DisposeAtEnd : bool with get, set
override DisposeAtEnd : bool with get, set
Property Value
Boolean


End Method

End Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► End()()()()
Keyoti RapidSpell WPF
Called when finished checking document, brings up spelling check is complete message.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void End()
protected virtual void End()
Protected Overridable Sub End
Protected Overridable Sub End
protected:
virtual void End()
protected:
virtual void End()
abstract End : unit -> unit
override End : unit -> unit
abstract End : unit -> unit
override End : unit -> unit


FindCapitalizedSuggestions Property

FindCapitalizedSuggestions Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► FindCapitalizedSuggestions
Keyoti RapidSpell WPF
Whether to look for capitalized suggestions, note this will slow FindSuggestions down by about 7 times.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool FindCapitalizedSuggestions { get; set; }
public bool FindCapitalizedSuggestions { get; set; }
Public Property FindCapitalizedSuggestions As Boolean
    Get
    Set
Public Property FindCapitalizedSuggestions As Boolean
    Get
    Set
public:
virtual property bool FindCapitalizedSuggestions {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool FindCapitalizedSuggestions {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract FindCapitalizedSuggestions : bool with get, set
override FindCapitalizedSuggestions : bool with get, set
abstract FindCapitalizedSuggestions : bool with get, set
override FindCapitalizedSuggestions : bool with get, set
Property Value
Boolean


FindingSuggestionsLabelText Property

FindingSuggestionsLabelText Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► FindingSuggestionsLabelText
Keyoti RapidSpell WPF
Finding suggestions label text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string FindingSuggestionsLabelText { get; set; }
public string FindingSuggestionsLabelText { get; set; }
Public Property FindingSuggestionsLabelText As String
    Get
    Set
Public Property FindingSuggestionsLabelText As String
    Get
    Set
public:
virtual property String^ FindingSuggestionsLabelText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ FindingSuggestionsLabelText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract FindingSuggestionsLabelText : string with get, set
override FindingSuggestionsLabelText : string with get, set
abstract FindingSuggestionsLabelText : string with get, set
override FindingSuggestionsLabelText : string with get, set
Property Value
String


findSuggestions Field

findSuggestions Field
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► findSuggestions
Keyoti RapidSpell WPF
Whether this should look up suggestions for misspelt words or not.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected bool findSuggestions
protected bool findSuggestions
Protected findSuggestions As Boolean
Protected findSuggestions As Boolean
protected:
bool findSuggestions
protected:
bool findSuggestions
val mutable findSuggestions: bool
val mutable findSuggestions: bool
Field Value
Boolean


FindSuggestionsLabelText Property

FindSuggestionsLabelText Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► FindSuggestionsLabelText
Keyoti RapidSpell WPF
Find suggestions label text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string FindSuggestionsLabelText { get; set; }
public string FindSuggestionsLabelText { get; set; }
Public Property FindSuggestionsLabelText As String
    Get
    Set
Public Property FindSuggestionsLabelText As String
    Get
    Set
public:
virtual property String^ FindSuggestionsLabelText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ FindSuggestionsLabelText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract FindSuggestionsLabelText : string with get, set
override FindSuggestionsLabelText : string with get, set
abstract FindSuggestionsLabelText : string with get, set
override FindSuggestionsLabelText : string with get, set
Property Value
String


FindWordEnd Method (fromPos)

FindWordEnd Method (fromPos)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► FindWordEnd(Int32)
Keyoti RapidSpell WPF
Returns the end of the word that fromPos is in.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual int FindWordEnd(
    int fromPos
)
protected virtual int FindWordEnd(
    int fromPos
)
Protected Overridable Function FindWordEnd (
    fromPos As Integer
) As Integer
Protected Overridable Function FindWordEnd (
    fromPos As Integer
) As Integer
protected:
virtual int FindWordEnd(
    int fromPos
)
protected:
virtual int FindWordEnd(
    int fromPos
)
abstract FindWordEnd :
        fromPos : int -> int
override FindWordEnd :
        fromPos : int -> int
abstract FindWordEnd :
        fromPos : int -> int
override FindWordEnd :
        fromPos : int -> int
Parameters
fromPos (Int32)
Return Value
Int32


FinishedCheckingSelectionPopUpText Property

FinishedCheckingSelectionPopUpText Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► FinishedCheckingSelectionPopUpText
Keyoti RapidSpell WPF
Finished checking selection dialog text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string FinishedCheckingSelectionPopUpText { get; set; }
public string FinishedCheckingSelectionPopUpText { get; set; }
Public Property FinishedCheckingSelectionPopUpText As String
    Get
    Set
Public Property FinishedCheckingSelectionPopUpText As String
    Get
    Set
public:
virtual property String^ FinishedCheckingSelectionPopUpText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ FinishedCheckingSelectionPopUpText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract FinishedCheckingSelectionPopUpText : string with get, set
override FinishedCheckingSelectionPopUpText : string with get, set
abstract FinishedCheckingSelectionPopUpText : string with get, set
override FinishedCheckingSelectionPopUpText : string with get, set
Property Value
String


FinishedCheckingSelectionPopUpTitle Property

FinishedCheckingSelectionPopUpTitle Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► FinishedCheckingSelectionPopUpTitle
Keyoti RapidSpell WPF
Finished checking selection dialog title
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string FinishedCheckingSelectionPopUpTitle { get; set; }
public string FinishedCheckingSelectionPopUpTitle { get; set; }
Public Property FinishedCheckingSelectionPopUpTitle As String
    Get
    Set
Public Property FinishedCheckingSelectionPopUpTitle As String
    Get
    Set
public:
virtual property String^ FinishedCheckingSelectionPopUpTitle {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ FinishedCheckingSelectionPopUpTitle {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract FinishedCheckingSelectionPopUpTitle : string with get, set
override FinishedCheckingSelectionPopUpTitle : string with get, set
abstract FinishedCheckingSelectionPopUpTitle : string with get, set
override FinishedCheckingSelectionPopUpTitle : string with get, set
Property Value
String


FocusGained Method (sender, e)

FocusGained Method (sender, e)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► FocusGained(Object, EventArgs)
Keyoti RapidSpell WPF
Called when objects whose focus this is listening to gain focus.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void FocusGained(
    Object sender,
    EventArgs e
)
protected virtual void FocusGained(
    Object sender,
    EventArgs e
)
Protected Overridable Sub FocusGained (
    sender As Object,
    e As EventArgs
)
Protected Overridable Sub FocusGained (
    sender As Object,
    e As EventArgs
)
protected:
virtual void FocusGained(
    Object^ sender,
    EventArgs^ e
)
protected:
virtual void FocusGained(
    Object^ sender,
    EventArgs^ e
)
abstract FocusGained :
        sender : Object *
        e : EventArgs -> unit
override FocusGained :
        sender : Object *
        e : EventArgs -> unit
abstract FocusGained :
        sender : Object *
        e : EventArgs -> unit
override FocusGained :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


fromPosition Field

fromPosition Field
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► fromPosition
Keyoti RapidSpell WPF
Where the user wants to check from in the document
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected int fromPosition
protected int fromPosition
Protected fromPosition As Integer
Protected fromPosition As Integer
protected:
int fromPosition
protected:
int fromPosition
val mutable fromPosition: int
val mutable fromPosition: int
Field Value
Int32


GenerateSentenceParts Method (preEnd, postStart)

GenerateSentenceParts Method (preEnd, postStart)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► GenerateSentenceParts(Int32, Int32)
Keyoti RapidSpell WPF
Finds the sentence up to a point and the sentence after a point
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual string[] GenerateSentenceParts(
    int preEnd,
    int postStart
)
protected virtual string[] GenerateSentenceParts(
    int preEnd,
    int postStart
)
Protected Overridable Function GenerateSentenceParts (
    preEnd As Integer,
    postStart As Integer
) As String()
Protected Overridable Function GenerateSentenceParts (
    preEnd As Integer,
    postStart As Integer
) As String()
protected:
virtual array<String^>^ GenerateSentenceParts(
    int preEnd,
    int postStart
)
protected:
virtual array<String^>^ GenerateSentenceParts(
    int preEnd,
    int postStart
)
abstract GenerateSentenceParts :
        preEnd : int *
        postStart : int -> string[]
override GenerateSentenceParts :
        preEnd : int *
        postStart : int -> string[]
abstract GenerateSentenceParts :
        preEnd : int *
        postStart : int -> string[]
override GenerateSentenceParts :
        preEnd : int *
        postStart : int -> string[]
Parameters
preEnd (Int32)
The point at which the first part of the sentence ends
postStart (Int32)
The point at which the second part of the sentence starts
Return Value
array<String>[]()[][]
A 2 element string array holding the sentence up to preEnd in the first element and the sentence after postStart in the second element. The intention is that preEnd is the beginning of a misspelled word and postStart is the end of a misspelled word. The sentence parts are then used as context in the query dialog box.


GUILanguage Property

GUILanguage Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► GUILanguage
Keyoti RapidSpell WPF
The language to show the UI in.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public LanguageType GUILanguage { get; set; }
public LanguageType GUILanguage { get; set; }
Public Property GUILanguage As LanguageType
    Get
    Set
Public Property GUILanguage As LanguageType
    Get
    Set
public:
virtual property LanguageType GUILanguage {
    LanguageType get () sealed;
    void set (LanguageType value) sealed;
}
public:
virtual property LanguageType GUILanguage {
    LanguageType get () sealed;
    void set (LanguageType value) sealed;
}
abstract GUILanguage : LanguageType with get, set
override GUILanguage : LanguageType with get, set
abstract GUILanguage : LanguageType with get, set
override GUILanguage : LanguageType with get, set
Property Value
LanguageType


guiShowing Field

guiShowing Field
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► guiShowing
Keyoti RapidSpell WPF
Whether the gui is currently showing
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected bool guiShowing
protected bool guiShowing
Protected guiShowing As Boolean
Protected guiShowing As Boolean
protected:
bool guiShowing
protected:
bool guiShowing
val mutable guiShowing: bool
val mutable guiShowing: bool
Field Value
Boolean


Ignore Method

Ignore Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► Ignore()()()()
Keyoti RapidSpell WPF
Ignore the current bad word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void Ignore()
protected virtual void Ignore()
Protected Overridable Sub Ignore
Protected Overridable Sub Ignore
protected:
virtual void Ignore()
protected:
virtual void Ignore()
abstract Ignore : unit -> unit
override Ignore : unit -> unit
abstract Ignore : unit -> unit
override Ignore : unit -> unit
Return Value

void


IgnoreAll Method

IgnoreAll Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► IgnoreAll()()()()
Keyoti RapidSpell WPF
Ignores all occurrences of this word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void IgnoreAll()
protected virtual void IgnoreAll()
Protected Overridable Sub IgnoreAll
Protected Overridable Sub IgnoreAll
protected:
virtual void IgnoreAll()
protected:
virtual void IgnoreAll()
abstract IgnoreAll : unit -> unit
override IgnoreAll : unit -> unit
abstract IgnoreAll : unit -> unit
override IgnoreAll : unit -> unit
Return Value

void


IgnoreAllButtonText Property

IgnoreAllButtonText Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► IgnoreAllButtonText
Keyoti RapidSpell WPF
Ignore All button text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string IgnoreAllButtonText { get; set; }
public string IgnoreAllButtonText { get; set; }
Public Property IgnoreAllButtonText As String
    Get
    Set
Public Property IgnoreAllButtonText As String
    Get
    Set
public:
virtual property String^ IgnoreAllButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ IgnoreAllButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract IgnoreAllButtonText : string with get, set
override IgnoreAllButtonText : string with get, set
abstract IgnoreAllButtonText : string with get, set
override IgnoreAllButtonText : string with get, set
Property Value
String


IgnoreButtonText Property

IgnoreButtonText Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► IgnoreButtonText
Keyoti RapidSpell WPF
Ignore button text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string IgnoreButtonText { get; set; }
public string IgnoreButtonText { get; set; }
Public Property IgnoreButtonText As String
    Get
    Set
Public Property IgnoreButtonText As String
    Get
    Set
public:
virtual property String^ IgnoreButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ IgnoreButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract IgnoreButtonText : string with get, set
override IgnoreButtonText : string with get, set
abstract IgnoreButtonText : string with get, set
override IgnoreButtonText : string with get, set
Property Value
String


IgnoreCapitalizedWords Property

IgnoreCapitalizedWords Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► IgnoreCapitalizedWords
Keyoti RapidSpell WPF
Whether to ignore words with capital letters.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreCapitalizedWords { get; set; }
public bool IgnoreCapitalizedWords { get; set; }
Public Property IgnoreCapitalizedWords As Boolean
    Get
    Set
Public Property IgnoreCapitalizedWords As Boolean
    Get
    Set
public:
virtual property bool IgnoreCapitalizedWords {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool IgnoreCapitalizedWords {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IgnoreCapitalizedWords : bool with get, set
override IgnoreCapitalizedWords : bool with get, set
abstract IgnoreCapitalizedWords : bool with get, set
override IgnoreCapitalizedWords : bool with get, set
Property Value
Boolean


IgnoreIncorrectSentenceCapitalization Property

IgnoreIncorrectSentenceCapitalization Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► IgnoreIncorrectSentenceCapitalization
Keyoti RapidSpell WPF
Whether to ignore incorrect sentence capitalization.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreIncorrectSentenceCapitalization { get; set; }
public bool IgnoreIncorrectSentenceCapitalization { get; set; }
Public Property IgnoreIncorrectSentenceCapitalization As Boolean
    Get
    Set
Public Property IgnoreIncorrectSentenceCapitalization As Boolean
    Get
    Set
public:
virtual property bool IgnoreIncorrectSentenceCapitalization {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool IgnoreIncorrectSentenceCapitalization {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IgnoreIncorrectSentenceCapitalization : bool with get, set
override IgnoreIncorrectSentenceCapitalization : bool with get, set
abstract IgnoreIncorrectSentenceCapitalization : bool with get, set
override IgnoreIncorrectSentenceCapitalization : bool with get, set
Property Value
Boolean


IgnoreInEnglishLowerCaseI Property

IgnoreInEnglishLowerCaseI Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► IgnoreInEnglishLowerCaseI
Keyoti RapidSpell WPF
Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreInEnglishLowerCaseI { get; set; }
public bool IgnoreInEnglishLowerCaseI { get; set; }
Public Property IgnoreInEnglishLowerCaseI As Boolean
    Get
    Set
Public Property IgnoreInEnglishLowerCaseI As Boolean
    Get
    Set
public:
virtual property bool IgnoreInEnglishLowerCaseI {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool IgnoreInEnglishLowerCaseI {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IgnoreInEnglishLowerCaseI : bool with get, set
override IgnoreInEnglishLowerCaseI : bool with get, set
abstract IgnoreInEnglishLowerCaseI : bool with get, set
override IgnoreInEnglishLowerCaseI : bool with get, set
Property Value
Boolean


IgnoreWordsWithDigits Property

IgnoreWordsWithDigits Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► IgnoreWordsWithDigits
Keyoti RapidSpell WPF
Whether to ignore words with numbers in them (eg. A10 or 7-11).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreWordsWithDigits { get; set; }
public bool IgnoreWordsWithDigits { get; set; }
Public Property IgnoreWordsWithDigits As Boolean
    Get
    Set
Public Property IgnoreWordsWithDigits As Boolean
    Get
    Set
public:
virtual property bool IgnoreWordsWithDigits {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool IgnoreWordsWithDigits {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IgnoreWordsWithDigits : bool with get, set
override IgnoreWordsWithDigits : bool with get, set
abstract IgnoreWordsWithDigits : bool with get, set
override IgnoreWordsWithDigits : bool with get, set
Property Value
Boolean


IgnoreXML Property

IgnoreXML Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► IgnoreXML
Keyoti RapidSpell WPF
Whether to ignore XML/HTML tags, false by default.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreXML { get; set; }
public bool IgnoreXML { get; set; }
Public Property IgnoreXML As Boolean
    Get
    Set
Public Property IgnoreXML As Boolean
    Get
    Set
public:
virtual property bool IgnoreXML {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool IgnoreXML {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IgnoreXML : bool with get, set
override IgnoreXML : bool with get, set
abstract IgnoreXML : bool with get, set
override IgnoreXML : bool with get, set
Property Value
Boolean
Remarks
This identifies XML tags as anything in between < and > characters, there for it will cause undesirable effects in text such as "the sign for less than is < and the sign for greater than is >". Of course in HTML that should have been written as "the sign for less than is &lt; and the sign for greater than is &gt;" anyway, which would be fine.


IncludeUserDictionaryInSuggestions Property

IncludeUserDictionaryInSuggestions Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► IncludeUserDictionaryInSuggestions
Keyoti RapidSpell WPF
Whether the user dictionary should be used in finding suggestions for misspelt words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IncludeUserDictionaryInSuggestions { get; set; }
public bool IncludeUserDictionaryInSuggestions { get; set; }
Public Property IncludeUserDictionaryInSuggestions As Boolean
    Get
    Set
Public Property IncludeUserDictionaryInSuggestions As Boolean
    Get
    Set
public:
virtual property bool IncludeUserDictionaryInSuggestions {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool IncludeUserDictionaryInSuggestions {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IncludeUserDictionaryInSuggestions : bool with get, set
override IncludeUserDictionaryInSuggestions : bool with get, set
abstract IncludeUserDictionaryInSuggestions : bool with get, set
override IncludeUserDictionaryInSuggestions : bool with get, set
Property Value
Boolean


InDictionaryLabelText Property

InDictionaryLabelText Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► InDictionaryLabelText
Keyoti RapidSpell WPF
In dictionary label text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string InDictionaryLabelText { get; set; }
public string InDictionaryLabelText { get; set; }
Public Property InDictionaryLabelText As String
    Get
    Set
Public Property InDictionaryLabelText As String
    Get
    Set
public:
virtual property String^ InDictionaryLabelText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ InDictionaryLabelText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract InDictionaryLabelText : string with get, set
override InDictionaryLabelText : string with get, set
abstract InDictionaryLabelText : string with get, set
override InDictionaryLabelText : string with get, set
Property Value
String


IsDialogViewCreated Method

IsDialogViewCreated Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► IsDialogViewCreated()()()()
Keyoti RapidSpell WPF
Whether a dialog view has already been created.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IsDialogViewCreated()
public bool IsDialogViewCreated()
Public Function IsDialogViewCreated As Boolean
Public Function IsDialogViewCreated As Boolean
public:
virtual bool IsDialogViewCreated() sealed
public:
virtual bool IsDialogViewCreated() sealed
abstract IsDialogViewCreated : unit -> bool
override IsDialogViewCreated : unit -> bool
abstract IsDialogViewCreated : unit -> bool
override IsDialogViewCreated : unit -> bool
Return Value
Boolean


IsDisposed Property

IsDisposed Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► IsDisposed
Keyoti RapidSpell WPF
Whether the IDialogView is disposed of
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IsDisposed { get; }
public bool IsDisposed { get; }
Public ReadOnly Property IsDisposed As Boolean
    Get
Public ReadOnly Property IsDisposed As Boolean
    Get
public:
property bool IsDisposed {
    bool get ();
}
public:
property bool IsDisposed {
    bool get ();
}
member IsDisposed : bool with get

member IsDisposed : bool with get
Property Value
Boolean


LanguageParser Property

LanguageParser Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► LanguageParser
Keyoti RapidSpell WPF
The type of language parsing to use.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public LanguageType LanguageParser { get; set; }
public LanguageType LanguageParser { get; set; }
Public Property LanguageParser As LanguageType
    Get
    Set
Public Property LanguageParser As LanguageType
    Get
    Set
public:
virtual property LanguageType LanguageParser {
    LanguageType get () sealed;
    void set (LanguageType value) sealed;
}
public:
virtual property LanguageType LanguageParser {
    LanguageType get () sealed;
    void set (LanguageType value) sealed;
}
abstract LanguageParser : LanguageType with get, set
override LanguageParser : LanguageType with get, set
abstract LanguageParser : LanguageType with get, set
override LanguageParser : LanguageType with get, set
Property Value
LanguageType
Remarks
Eg. If the dictionary is set to French, you should use the French parser.


Load Event

Load Event
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► Load
Keyoti RapidSpell WPF
Fired when the DialogView loads.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler Load
public event EventHandler Load
Public Event Load As EventHandler
Public Event Load As EventHandler
public:
virtual  event EventHandler^ Load {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ Load {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Load : IEvent<EventHandler,
    EventArgs>
override Load : IEvent<EventHandler,
    EventArgs>
abstract Load : IEvent<EventHandler,
    EventArgs>
override Load : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


Location Property

Location Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► Location
Keyoti RapidSpell WPF
Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Point Location { get; set; }
public Point Location { get; set; }
Public Property Location As Point
    Get
    Set
Public Property Location As Point
    Get
    Set
public:
property Point Location {
    Point get ();
    void set (Point value);
}
public:
property Point Location {
    Point get ();
    void set (Point value);
}
member Location : Point with get, set

member Location : Point with get, set
Property Value
Point


LookIntoHyphenatedText Property

LookIntoHyphenatedText Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► LookIntoHyphenatedText
Keyoti RapidSpell WPF
Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool LookIntoHyphenatedText { get; set; }
public bool LookIntoHyphenatedText { get; set; }
Public Property LookIntoHyphenatedText As Boolean
    Get
    Set
Public Property LookIntoHyphenatedText As Boolean
    Get
    Set
public:
virtual property bool LookIntoHyphenatedText {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool LookIntoHyphenatedText {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract LookIntoHyphenatedText : bool with get, set
override LookIntoHyphenatedText : bool with get, set
abstract LookIntoHyphenatedText : bool with get, set
override LookIntoHyphenatedText : bool with get, set
Property Value
Boolean
Remarks
Eg. "socio-economic" will be checked as "socio" and "economic".


MakeChange Method

MakeChange Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► MakeChange()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | MakeChange()()()() | Changes the current bad word for one selected from the suggestions list or entered in the query pane returns the word used.
 | MakeChange(Boolean) | Changes the current bad word for one selected from the suggestions list or entered in the query pane returns the word used.
 | MakeChange(Boolean, String, Boolean) | Changes the current bad word for one selected from the suggestions list or entered in the query pane returns the word used.


MakeChange Method

MakeChange Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► MakeChange()()()()
Keyoti RapidSpell WPF
Changes the current bad word for one selected from the suggestions list or entered in the query pane returns the word used.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual string MakeChange()
protected virtual string MakeChange()
Protected Overridable Function MakeChange As String
Protected Overridable Function MakeChange As String
protected:
virtual String^ MakeChange()
protected:
virtual String^ MakeChange()
abstract MakeChange : unit -> string
override MakeChange : unit -> string
abstract MakeChange : unit -> string
override MakeChange : unit -> string
Return Value
String


MakeChange Method (inChangeAllProcess)

MakeChange Method (inChangeAllProcess)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► MakeChange(Boolean)
Keyoti RapidSpell WPF
Changes the current bad word for one selected from the suggestions list or entered in the query pane returns the word used.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected string MakeChange(
    bool inChangeAllProcess
)
protected string MakeChange(
    bool inChangeAllProcess
)
Protected Function MakeChange (
    inChangeAllProcess As Boolean
) As String
Protected Function MakeChange (
    inChangeAllProcess As Boolean
) As String
protected:
String^ MakeChange(
    bool inChangeAllProcess
)
protected:
String^ MakeChange(
    bool inChangeAllProcess
)
member MakeChange :
        inChangeAllProcess : bool -> string

member MakeChange :
        inChangeAllProcess : bool -> string
Parameters
inChangeAllProcess (Boolean)
Return Value
String
Remarks
inChangeAllProcess is true if this operation is part of a 'Change All'


MakeChange Method (inChangeAllProcess, newWord, removeDuplicate)

MakeChange Method (inChangeAllProcess, newWord, removeDuplicate)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► MakeChange(Boolean, String, Boolean)
Keyoti RapidSpell WPF
Changes the current bad word for one selected from the suggestions list or entered in the query pane returns the word used.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual string MakeChange(
    bool inChangeAllProcess,
    string newWord,
    bool removeDuplicate
)
protected virtual string MakeChange(
    bool inChangeAllProcess,
    string newWord,
    bool removeDuplicate
)
Protected Overridable Function MakeChange (
    inChangeAllProcess As Boolean,
    newWord As String,
    removeDuplicate As Boolean
) As String
Protected Overridable Function MakeChange (
    inChangeAllProcess As Boolean,
    newWord As String,
    removeDuplicate As Boolean
) As String
protected:
virtual String^ MakeChange(
    bool inChangeAllProcess,
    String^ newWord,
    bool removeDuplicate
)
protected:
virtual String^ MakeChange(
    bool inChangeAllProcess,
    String^ newWord,
    bool removeDuplicate
)
abstract MakeChange :
        inChangeAllProcess : bool *
        newWord : string *
        removeDuplicate : bool -> string
override MakeChange :
        inChangeAllProcess : bool *
        newWord : string *
        removeDuplicate : bool -> string
abstract MakeChange :
        inChangeAllProcess : bool *
        newWord : string *
        removeDuplicate : bool -> string
override MakeChange :
        inChangeAllProcess : bool *
        newWord : string *
        removeDuplicate : bool -> string
Parameters
inChangeAllProcess (Boolean)
newWord (String)
removeDuplicate (Boolean)
Return Value
String
Remarks
inChangeAllProcess is true if this operation is part of a 'Change All'


MaximumContextualWords Property

MaximumContextualWords Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► MaximumContextualWords
Keyoti RapidSpell WPF
The maximum number of words to show the user in the sentence around misspelled words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int MaximumContextualWords { get; set; }
public int MaximumContextualWords { get; set; }
Public Property MaximumContextualWords As Integer
    Get
    Set
Public Property MaximumContextualWords As Integer
    Get
    Set
public:
virtual property int MaximumContextualWords {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int MaximumContextualWords {
    int get () sealed;
    void set (int value) sealed;
}
abstract MaximumContextualWords : int with get, set
override MaximumContextualWords : int with get, set
abstract MaximumContextualWords : int with get, set
override MaximumContextualWords : int with get, set
Property Value
Int32


ModalAutoDispose Property

ModalAutoDispose Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► ModalAutoDispose
Keyoti RapidSpell WPF
When running modally, determines if the dialog will be disposed of when spell check finishes.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ModalAutoDispose { get; set; }
public bool ModalAutoDispose { get; set; }
Public Property ModalAutoDispose As Boolean
    Get
    Set
Public Property ModalAutoDispose As Boolean
    Get
    Set
public:
virtual property bool ModalAutoDispose {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool ModalAutoDispose {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract ModalAutoDispose : bool with get, set
override ModalAutoDispose : bool with get, set
abstract ModalAutoDispose : bool with get, set
override ModalAutoDispose : bool with get, set
Property Value
Boolean
Remarks
If a modal form disposes of itself, there will be slight flickering on the screen, to prevent this, set this property to false and call Dispose() when finished with this control.


ModalMode Property

ModalMode Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► ModalMode
Keyoti RapidSpell WPF
Whether the spell checker will run modally. (Modal operation blocks the parent form)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ModalMode { get; set; }
public bool ModalMode { get; set; }
Public Property ModalMode As Boolean
    Get
    Set
Public Property ModalMode As Boolean
    Get
    Set
public:
virtual property bool ModalMode {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool ModalMode {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract ModalMode : bool with get, set
override ModalMode : bool with get, set
abstract ModalMode : bool with get, set
override ModalMode : bool with get, set
Property Value
Boolean


ModalOwner Property

ModalOwner Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► ModalOwner
Keyoti RapidSpell WPF
The modal dialog owner window.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Object ModalOwner { get; set; }
public Object ModalOwner { get; set; }
Public Property ModalOwner As Object
    Get
    Set
Public Property ModalOwner As Object
    Get
    Set
public:
virtual property Object^ ModalOwner {
    Object^ get () sealed;
    void set (Object^ value) sealed;
}
public:
virtual property Object^ ModalOwner {
    Object^ get () sealed;
    void set (Object^ value) sealed;
}
abstract ModalOwner : Object with get, set
override ModalOwner : Object with get, set
abstract ModalOwner : Object with get, set
override ModalOwner : Object with get, set
Property Value
Object


MoveCaretToWordEnd Method

MoveCaretToWordEnd Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► MoveCaretToWordEnd()()()()
Keyoti RapidSpell WPF
Moves the caret to the end of the word the caret is in, or where it is if not on a word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void MoveCaretToWordEnd()
protected virtual void MoveCaretToWordEnd()
Protected Overridable Sub MoveCaretToWordEnd
Protected Overridable Sub MoveCaretToWordEnd
protected:
virtual void MoveCaretToWordEnd()
protected:
virtual void MoveCaretToWordEnd()
abstract MoveCaretToWordEnd : unit -> unit
override MoveCaretToWordEnd : unit -> unit
abstract MoveCaretToWordEnd : unit -> unit
override MoveCaretToWordEnd : unit -> unit


MoveCaretToWordStart Method

MoveCaretToWordStart Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► MoveCaretToWordStart()()()()
Keyoti RapidSpell WPF
Moves the caret to the start of the word the caret is in, or where it is if not on a word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void MoveCaretToWordStart()
protected virtual void MoveCaretToWordStart()
Protected Overridable Sub MoveCaretToWordStart
Protected Overridable Sub MoveCaretToWordStart
protected:
virtual void MoveCaretToWordStart()
protected:
virtual void MoveCaretToWordStart()
abstract MoveCaretToWordStart : unit -> unit
override MoveCaretToWordStart : unit -> unit
abstract MoveCaretToWordStart : unit -> unit
override MoveCaretToWordStart : unit -> unit


NoSuggestionsText Property

NoSuggestionsText Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► NoSuggestionsText
Keyoti RapidSpell WPF
No suggestions found text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string NoSuggestionsText { get; set; }
public string NoSuggestionsText { get; set; }
Public Property NoSuggestionsText As String
    Get
    Set
Public Property NoSuggestionsText As String
    Get
    Set
public:
virtual property String^ NoSuggestionsText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ NoSuggestionsText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract NoSuggestionsText : string with get, set
override NoSuggestionsText : string with get, set
abstract NoSuggestionsText : string with get, set
override NoSuggestionsText : string with get, set
Property Value
String


NotInDictionaryLabelText Property

NotInDictionaryLabelText Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► NotInDictionaryLabelText
Keyoti RapidSpell WPF
Not in dictionary label text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string NotInDictionaryLabelText { get; set; }
public string NotInDictionaryLabelText { get; set; }
Public Property NotInDictionaryLabelText As String
    Get
    Set
Public Property NotInDictionaryLabelText As String
    Get
    Set
public:
virtual property String^ NotInDictionaryLabelText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ NotInDictionaryLabelText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract NotInDictionaryLabelText : string with get, set
override NotInDictionaryLabelText : string with get, set
abstract NotInDictionaryLabelText : string with get, set
override NotInDictionaryLabelText : string with get, set
Property Value
String


NumberSuggestionList Property

NumberSuggestionList Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► NumberSuggestionList
Keyoti RapidSpell WPF
Whether to number the items in the suggestion list, for quick user selection.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool NumberSuggestionList { get; set; }
public bool NumberSuggestionList { get; set; }
Public Property NumberSuggestionList As Boolean
    Get
    Set
Public Property NumberSuggestionList As Boolean
    Get
    Set
public:
virtual property bool NumberSuggestionList {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool NumberSuggestionList {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract NumberSuggestionList : bool with get, set
override NumberSuggestionList : bool with get, set
abstract NumberSuggestionList : bool with get, set
override NumberSuggestionList : bool with get, set
Property Value
Boolean


OnCreateDialogView Method (e)

OnCreateDialogView Method (e)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► OnCreateDialogView(CreateDialogViewEventArgs)
Keyoti RapidSpell WPF
Fires the CreateDialogView event.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void OnCreateDialogView(
    CreateDialogViewEventArgs e
)
protected virtual void OnCreateDialogView(
    CreateDialogViewEventArgs e
)
Protected Overridable Sub OnCreateDialogView (
    e As CreateDialogViewEventArgs
)
Protected Overridable Sub OnCreateDialogView (
    e As CreateDialogViewEventArgs
)
protected:
virtual void OnCreateDialogView(
    CreateDialogViewEventArgs^ e
)
protected:
virtual void OnCreateDialogView(
    CreateDialogViewEventArgs^ e
)
abstract OnCreateDialogView :
        e : CreateDialogViewEventArgs -> unit
override OnCreateDialogView :
        e : CreateDialogViewEventArgs -> unit
abstract OnCreateDialogView :
        e : CreateDialogViewEventArgs -> unit
override OnCreateDialogView :
        e : CreateDialogViewEventArgs -> unit
Parameters
e (CreateDialogViewEventArgs)


OnSuggestionsDoubleClick Method (sender, e)

OnSuggestionsDoubleClick Method (sender, e)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► OnSuggestionsDoubleClick(Object, EventArgs)
Keyoti RapidSpell WPF
Called when the user double clicks on a suggestion.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected void OnSuggestionsDoubleClick(
    Object sender,
    EventArgs e
)
protected void OnSuggestionsDoubleClick(
    Object sender,
    EventArgs e
)
Protected Sub OnSuggestionsDoubleClick (
    sender As Object,
    e As EventArgs
)
Protected Sub OnSuggestionsDoubleClick (
    sender As Object,
    e As EventArgs
)
protected:
void OnSuggestionsDoubleClick(
    Object^ sender,
    EventArgs^ e
)
protected:
void OnSuggestionsDoubleClick(
    Object^ sender,
    EventArgs^ e
)
member OnSuggestionsDoubleClick :
        sender : Object *
        e : EventArgs -> unit

member OnSuggestionsDoubleClick :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


OnUndone Method (e)

OnUndone Method (e)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► OnUndone(UndoEventArgs)
Keyoti RapidSpell WPF
Raises the Undone event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void OnUndone(
    UndoEventArgs e
)
protected virtual void OnUndone(
    UndoEventArgs e
)
Protected Overridable Sub OnUndone (
    e As UndoEventArgs
)
Protected Overridable Sub OnUndone (
    e As UndoEventArgs
)
protected:
virtual void OnUndone(
    UndoEventArgs^ e
)
protected:
virtual void OnUndone(
    UndoEventArgs^ e
)
abstract OnUndone :
        e : UndoEventArgs -> unit
override OnUndone :
        e : UndoEventArgs -> unit
abstract OnUndone :
        e : UndoEventArgs -> unit
override OnUndone :
        e : UndoEventArgs -> unit
Parameters
e (UndoEventArgs)


OnUserQuery Method (userQueryEventArgs)

OnUserQuery Method (userQueryEventArgs)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► OnUserQuery(UserQueryEventArgs)
Keyoti RapidSpell WPF
Fires the user query event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected void OnUserQuery(
    UserQueryEventArgs userQueryEventArgs
)
protected void OnUserQuery(
    UserQueryEventArgs userQueryEventArgs
)
Protected Sub OnUserQuery (
    userQueryEventArgs As UserQueryEventArgs
)
Protected Sub OnUserQuery (
    userQueryEventArgs As UserQueryEventArgs
)
protected:
void OnUserQuery(
    UserQueryEventArgs^ userQueryEventArgs
)
protected:
void OnUserQuery(
    UserQueryEventArgs^ userQueryEventArgs
)
member OnUserQuery :
        userQueryEventArgs : UserQueryEventArgs -> unit

member OnUserQuery :
        userQueryEventArgs : UserQueryEventArgs -> unit
Parameters
userQueryEventArgs (UserQueryEventArgs)


Options Property

Options Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► Options
Keyoti RapidSpell WPF
Object responsible for holding, loading and saving the user's spell check options.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual UserOptions Options { get; set; }
public virtual UserOptions Options { get; set; }
Public Overridable Property Options As UserOptions
    Get
    Set
Public Overridable Property Options As UserOptions
    Get
    Set
public:
virtual property UserOptions^ Options {
    UserOptions^ get ();
    void set (UserOptions^ value);
}
public:
virtual property UserOptions^ Options {
    UserOptions^ get ();
    void set (UserOptions^ value);
}
abstract Options : UserOptions with get, set
override Options : UserOptions with get, set
abstract Options : UserOptions with get, set
override Options : UserOptions with get, set
Property Value
UserOptions
Remarks
To customize how the user's options are saved/loaded, subclass UserOptions and set an instance in this property.


OptionsButtonText Property

OptionsButtonText Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► OptionsButtonText
Keyoti RapidSpell WPF
Options button text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OptionsButtonText { get; set; }
public string OptionsButtonText { get; set; }
Public Property OptionsButtonText As String
    Get
    Set
Public Property OptionsButtonText As String
    Get
    Set
public:
virtual property String^ OptionsButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ OptionsButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract OptionsButtonText : string with get, set
override OptionsButtonText : string with get, set
abstract OptionsButtonText : string with get, set
override OptionsButtonText : string with get, set
Property Value
String


OptionsPresenter Property

OptionsPresenter Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► OptionsPresenter
Keyoti RapidSpell WPF
Presenter for the user options form (IDialogViewOptions).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual OptionsPresenter OptionsPresenter { get; set; }
public virtual OptionsPresenter OptionsPresenter { get; set; }
Public Overridable Property OptionsPresenter As OptionsPresenter
    Get
    Set
Public Overridable Property OptionsPresenter As OptionsPresenter
    Get
    Set
public:
virtual property OptionsPresenter^ OptionsPresenter {
    OptionsPresenter^ get ();
    void set (OptionsPresenter^ value);
}
public:
virtual property OptionsPresenter^ OptionsPresenter {
    OptionsPresenter^ get ();
    void set (OptionsPresenter^ value);
}
abstract OptionsPresenter : OptionsPresenter with get, set
override OptionsPresenter : OptionsPresenter with get, set
abstract OptionsPresenter : OptionsPresenter with get, set
override OptionsPresenter : OptionsPresenter with get, set
Property Value
OptionsPresenter
Remarks
Set properties in this instance to affect the options shown to the user, or handle CreateDialogViewOptions to create your own IDialogViewOptions form instance.


ProceedFromEnd Method

ProceedFromEnd Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► ProceedFromEnd()()()()
Keyoti RapidSpell WPF
Decides what to do once reached end of required text check region
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void ProceedFromEnd()
protected virtual void ProceedFromEnd()
Protected Overridable Sub ProceedFromEnd
Protected Overridable Sub ProceedFromEnd
protected:
virtual void ProceedFromEnd()
protected:
virtual void ProceedFromEnd()
abstract ProceedFromEnd : unit -> unit
override ProceedFromEnd : unit -> unit
abstract ProceedFromEnd : unit -> unit
override ProceedFromEnd : unit -> unit


QueryTextBoxMultiline Property

QueryTextBoxMultiline Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► QueryTextBoxMultiline
Keyoti RapidSpell WPF
Whether 'not in dictionary' text box is multiline or single line.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool QueryTextBoxMultiline { get; set; }
public bool QueryTextBoxMultiline { get; set; }
Public Property QueryTextBoxMultiline As Boolean
    Get
    Set
Public Property QueryTextBoxMultiline As Boolean
    Get
    Set
public:
property bool QueryTextBoxMultiline {
    bool get ();
    void set (bool value);
}
public:
property bool QueryTextBoxMultiline {
    bool get ();
    void set (bool value);
}
member QueryTextBoxMultiline : bool with get, set

member QueryTextBoxMultiline : bool with get, set
Property Value
Boolean


Ready Event

Ready Event
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► Ready
Keyoti RapidSpell WPF
Fired when ready to proceed with first query.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler Ready
public event EventHandler Ready
Public Event Ready As EventHandler
Public Event Ready As EventHandler
public:
virtual  event EventHandler^ Ready {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ Ready {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Ready : IEvent<EventHandler,
    EventArgs>
override Ready : IEvent<EventHandler,
    EventArgs>
abstract Ready : IEvent<EventHandler,
    EventArgs>
override Ready : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


RecheckDocumentRequest Event

RecheckDocumentRequest Event
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► RecheckDocumentRequest
Keyoti RapidSpell WPF
Fired when document recheck is requested
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler RecheckDocumentRequest
public event EventHandler RecheckDocumentRequest
Public Event RecheckDocumentRequest As EventHandler
Public Event RecheckDocumentRequest As EventHandler
public:
virtual  event EventHandler^ RecheckDocumentRequest {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ RecheckDocumentRequest {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract RecheckDocumentRequest : IEvent<EventHandler,
    EventArgs>
override RecheckDocumentRequest : IEvent<EventHandler,
    EventArgs>
abstract RecheckDocumentRequest : IEvent<EventHandler,
    EventArgs>
override RecheckDocumentRequest : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


Remove Method

Remove Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► Remove()()()()
Keyoti RapidSpell WPF
Safely frees up resources.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void Remove()
public void Remove()
Public Sub Remove
Public Sub Remove
public:
virtual void Remove() sealed
public:
virtual void Remove() sealed
abstract Remove : unit -> unit
override Remove : unit -> unit
abstract Remove : unit -> unit
override Remove : unit -> unit


RemoveDuplicateWordText Property

RemoveDuplicateWordText Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► RemoveDuplicateWordText
Keyoti RapidSpell WPF
Remove duplicate word text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string RemoveDuplicateWordText { get; set; }
public string RemoveDuplicateWordText { get; set; }
Public Property RemoveDuplicateWordText As String
    Get
    Set
Public Property RemoveDuplicateWordText As String
    Get
    Set
public:
virtual property String^ RemoveDuplicateWordText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ RemoveDuplicateWordText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract RemoveDuplicateWordText : string with get, set
override RemoveDuplicateWordText : string with get, set
abstract RemoveDuplicateWordText : string with get, set
override RemoveDuplicateWordText : string with get, set
Property Value
String


Resume Method

Resume Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► Resume()()()()
Keyoti RapidSpell WPF
Looks for next bad word
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void Resume()
protected virtual void Resume()
Protected Overridable Sub Resume
Protected Overridable Sub Resume
protected:
virtual void Resume()
protected:
virtual void Resume()
abstract Resume : unit -> unit
override Resume : unit -> unit
abstract Resume : unit -> unit
override Resume : unit -> unit
Return Value

void


ResumeButtonText Property

ResumeButtonText Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► ResumeButtonText
Keyoti RapidSpell WPF
Resume button text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string ResumeButtonText { get; set; }
public string ResumeButtonText { get; set; }
Public Property ResumeButtonText As String
    Get
    Set
Public Property ResumeButtonText As String
    Get
    Set
public:
virtual property String^ ResumeButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ ResumeButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract ResumeButtonText : string with get, set
override ResumeButtonText : string with get, set
abstract ResumeButtonText : string with get, set
override ResumeButtonText : string with get, set
Property Value
String


SelectText Method (theBadWord)

SelectText Method (theBadWord)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► SelectText(BadWord)
Keyoti RapidSpell WPF
Selects a bad word in the text component
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void SelectText(
    BadWord theBadWord
)
protected virtual void SelectText(
    BadWord theBadWord
)
Protected Overridable Sub SelectText (
    theBadWord As BadWord
)
Protected Overridable Sub SelectText (
    theBadWord As BadWord
)
protected:
virtual void SelectText(
    BadWord^ theBadWord
)
protected:
virtual void SelectText(
    BadWord^ theBadWord
)
abstract SelectText :
        theBadWord : BadWord -> unit
override SelectText :
        theBadWord : BadWord -> unit
abstract SelectText :
        theBadWord : BadWord -> unit
override SelectText :
        theBadWord : BadWord -> unit
Parameters
theBadWord (BadWord)


SeparateHyphenWords Property

SeparateHyphenWords Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► SeparateHyphenWords
Keyoti RapidSpell WPF
Sets whether to treat hyphenated (-) words as separate words, default is false.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool SeparateHyphenWords { get; set; }
public bool SeparateHyphenWords { get; set; }
Public Property SeparateHyphenWords As Boolean
    Get
    Set
Public Property SeparateHyphenWords As Boolean
    Get
    Set
public:
virtual property bool SeparateHyphenWords {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool SeparateHyphenWords {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract SeparateHyphenWords : bool with get, set
override SeparateHyphenWords : bool with get, set
abstract SeparateHyphenWords : bool with get, set
override SeparateHyphenWords : bool with get, set
Property Value
Boolean
Remarks
For eg. if this is true text like "cheap-deals" will be treated as two words "cheap" and "deals", otherwise this will be treated as one word "cheap-deals".


SetDisposeAtEnd Method (v)

SetDisposeAtEnd Method (v)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► SetDisposeAtEnd(Boolean)
Keyoti RapidSpell WPF
Sets whether this will dispose of self at the end of the spell check.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected void SetDisposeAtEnd(
    bool v
)
protected void SetDisposeAtEnd(
    bool v
)
Protected Sub SetDisposeAtEnd (
    v As Boolean
)
Protected Sub SetDisposeAtEnd (
    v As Boolean
)
protected:
void SetDisposeAtEnd(
    bool v
)
protected:
void SetDisposeAtEnd(
    bool v
)
member SetDisposeAtEnd :
        v : bool -> unit

member SetDisposeAtEnd :
        v : bool -> unit
Parameters
v (Boolean)
Remarks
Use with caution.


SetIgnoreOnceBadWords Method (ignoreOnceBadWords)

SetIgnoreOnceBadWords Method (ignoreOnceBadWords)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► SetIgnoreOnceBadWords(ArrayList)
Keyoti RapidSpell WPF
Provide a list of BadWord objects that have been ignored
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void SetIgnoreOnceBadWords(
    ArrayList ignoreOnceBadWords
)
public void SetIgnoreOnceBadWords(
    ArrayList ignoreOnceBadWords
)
Public Sub SetIgnoreOnceBadWords (
    ignoreOnceBadWords As ArrayList
)
Public Sub SetIgnoreOnceBadWords (
    ignoreOnceBadWords As ArrayList
)
public:
virtual void SetIgnoreOnceBadWords(
    ArrayList^ ignoreOnceBadWords
) sealed
public:
virtual void SetIgnoreOnceBadWords(
    ArrayList^ ignoreOnceBadWords
) sealed
abstract SetIgnoreOnceBadWords :
        ignoreOnceBadWords : ArrayList -> unit
override SetIgnoreOnceBadWords :
        ignoreOnceBadWords : ArrayList -> unit
abstract SetIgnoreOnceBadWords :
        ignoreOnceBadWords : ArrayList -> unit
override SetIgnoreOnceBadWords :
        ignoreOnceBadWords : ArrayList -> unit
Parameters
ignoreOnceBadWords (ArrayList)


SetTextComponentToCheck Method

SetTextComponentToCheck Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► SetTextComponentToCheck()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | SetTextComponentToCheck(TextBox) | Set the TextBox (WPF) that this GUI will spell check.
 | SetTextComponentToCheck(RichTextBox) | Set the RichTextBox (WPF) that this GUI will spell check.
 | SetTextComponentToCheck(ISpellCheckableTextComponent) | Sets the ISpellCheckableTextComponent that this GUI will spell check.
 | SetTextComponentToCheck(ISpellCheckableTextComponent2) | Sets the ISpellCheckableTextComponent2 that this GUI will spell check.


SetTextComponentToCheck Method (textComponent)

SetTextComponentToCheck Method (textComponent)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► SetTextComponentToCheck(ISpellCheckableTextComponent)
Keyoti RapidSpell WPF
Sets the ISpellCheckableTextComponent that this GUI will spell check.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void SetTextComponentToCheck(
    ISpellCheckableTextComponent textComponent
)
public virtual void SetTextComponentToCheck(
    ISpellCheckableTextComponent textComponent
)
Public Overridable Sub SetTextComponentToCheck (
    textComponent As ISpellCheckableTextComponent
)
Public Overridable Sub SetTextComponentToCheck (
    textComponent As ISpellCheckableTextComponent
)
public:
virtual void SetTextComponentToCheck(
    ISpellCheckableTextComponent^ textComponent
)
public:
virtual void SetTextComponentToCheck(
    ISpellCheckableTextComponent^ textComponent
)
abstract SetTextComponentToCheck :
        textComponent : ISpellCheckableTextComponent -> unit
override SetTextComponentToCheck :
        textComponent : ISpellCheckableTextComponent -> unit
abstract SetTextComponentToCheck :
        textComponent : ISpellCheckableTextComponent -> unit
override SetTextComponentToCheck :
        textComponent : ISpellCheckableTextComponent -> unit
Parameters
textComponent (ISpellCheckableTextComponent)
the ISpellCheckableTextComponent that this will spell check.
Exceptions
Exception | Condition
ArgumentNullException | if textComponent parameter is null.


SetTextComponentToCheck Method (textComponent)

SetTextComponentToCheck Method (textComponent)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► SetTextComponentToCheck(ISpellCheckableTextComponent2)
Keyoti RapidSpell WPF
Sets the ISpellCheckableTextComponent2 that this GUI will spell check.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void SetTextComponentToCheck(
    ISpellCheckableTextComponent2 textComponent
)
public virtual void SetTextComponentToCheck(
    ISpellCheckableTextComponent2 textComponent
)
Public Overridable Sub SetTextComponentToCheck (
    textComponent As ISpellCheckableTextComponent2
)
Public Overridable Sub SetTextComponentToCheck (
    textComponent As ISpellCheckableTextComponent2
)
public:
virtual void SetTextComponentToCheck(
    ISpellCheckableTextComponent2^ textComponent
)
public:
virtual void SetTextComponentToCheck(
    ISpellCheckableTextComponent2^ textComponent
)
abstract SetTextComponentToCheck :
        textComponent : ISpellCheckableTextComponent2 -> unit
override SetTextComponentToCheck :
        textComponent : ISpellCheckableTextComponent2 -> unit
abstract SetTextComponentToCheck :
        textComponent : ISpellCheckableTextComponent2 -> unit
override SetTextComponentToCheck :
        textComponent : ISpellCheckableTextComponent2 -> unit
Parameters
textComponent (ISpellCheckableTextComponent2)
the ISpellCheckableTextComponent2 that this will spell check.
Exceptions
Exception | Condition
ArgumentNullException | if textComponent parameter is null.


SetTextComponentToCheck Method (textComponent)

SetTextComponentToCheck Method (textComponent)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► SetTextComponentToCheck(RichTextBox)
Keyoti RapidSpell WPF
Set the RichTextBox (WPF) that this GUI will spell check.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void SetTextComponentToCheck(
    RichTextBox textComponent
)
public virtual void SetTextComponentToCheck(
    RichTextBox textComponent
)
Public Overridable Sub SetTextComponentToCheck (
    textComponent As RichTextBox
)
Public Overridable Sub SetTextComponentToCheck (
    textComponent As RichTextBox
)
public:
virtual void SetTextComponentToCheck(
    RichTextBox^ textComponent
)
public:
virtual void SetTextComponentToCheck(
    RichTextBox^ textComponent
)
abstract SetTextComponentToCheck :
        textComponent : RichTextBox -> unit
override SetTextComponentToCheck :
        textComponent : RichTextBox -> unit
abstract SetTextComponentToCheck :
        textComponent : RichTextBox -> unit
override SetTextComponentToCheck :
        textComponent : RichTextBox -> unit
Parameters
textComponent (RichTextBox)
the TextBox that this will spell check.
Exceptions
Exception | Condition
ArgumentNullException | if textComponent parameter is null.


SetTextComponentToCheck Method (textComponent)

SetTextComponentToCheck Method (textComponent)
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► SetTextComponentToCheck(TextBox)
Keyoti RapidSpell WPF
Set the TextBox (WPF) that this GUI will spell check.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void SetTextComponentToCheck(
    TextBox textComponent
)
public virtual void SetTextComponentToCheck(
    TextBox textComponent
)
Public Overridable Sub SetTextComponentToCheck (
    textComponent As TextBox
)
Public Overridable Sub SetTextComponentToCheck (
    textComponent As TextBox
)
public:
virtual void SetTextComponentToCheck(
    TextBox^ textComponent
)
public:
virtual void SetTextComponentToCheck(
    TextBox^ textComponent
)
abstract SetTextComponentToCheck :
        textComponent : TextBox -> unit
override SetTextComponentToCheck :
        textComponent : TextBox -> unit
abstract SetTextComponentToCheck :
        textComponent : TextBox -> unit
override SetTextComponentToCheck :
        textComponent : TextBox -> unit
Parameters
textComponent (TextBox)
the TextBox that this will spell check.
Exceptions
Exception | Condition
ArgumentNullException | if textComponent parameter is null.


SetUITexts Method

SetUITexts Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► SetUITexts()()()()
Keyoti RapidSpell WPF
Applies the UI texts to the IDialogView
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void SetUITexts()
protected virtual void SetUITexts()
Protected Overridable Sub SetUITexts
Protected Overridable Sub SetUITexts
protected:
virtual void SetUITexts()
protected:
virtual void SetUITexts()
abstract SetUITexts : unit -> unit
override SetUITexts : unit -> unit
abstract SetUITexts : unit -> unit
override SetUITexts : unit -> unit


ShouldEnableAddButton Method

ShouldEnableAddButton Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► ShouldEnableAddButton()()()()
Keyoti RapidSpell WPF
Determines if the Add button should be enabled
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual bool ShouldEnableAddButton()
protected virtual bool ShouldEnableAddButton()
Protected Overridable Function ShouldEnableAddButton As Boolean
Protected Overridable Function ShouldEnableAddButton As Boolean
protected:
virtual bool ShouldEnableAddButton()
protected:
virtual bool ShouldEnableAddButton()
abstract ShouldEnableAddButton : unit -> bool
override ShouldEnableAddButton : unit -> bool
abstract ShouldEnableAddButton : unit -> bool
override ShouldEnableAddButton : unit -> bool
Return Value
Boolean


ShowContextSentence Property

ShowContextSentence Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► ShowContextSentence
Keyoti RapidSpell WPF
Whether to show the query in context of it's sentence/line.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ShowContextSentence { get; set; }
public bool ShowContextSentence { get; set; }
Public Property ShowContextSentence As Boolean
    Get
    Set
Public Property ShowContextSentence As Boolean
    Get
    Set
public:
virtual property bool ShowContextSentence {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool ShowContextSentence {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract ShowContextSentence : bool with get, set
override ShowContextSentence : bool with get, set
abstract ShowContextSentence : bool with get, set
override ShowContextSentence : bool with get, set
Property Value
Boolean


ShowFinishedMessageBox Property

ShowFinishedMessageBox Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► ShowFinishedMessageBox
Keyoti RapidSpell WPF
Whether a message box should be opened when the spell check is complete.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ShowFinishedMessageBox { get; set; }
public bool ShowFinishedMessageBox { get; set; }
Public Property ShowFinishedMessageBox As Boolean
    Get
    Set
Public Property ShowFinishedMessageBox As Boolean
    Get
    Set
public:
virtual property bool ShowFinishedMessageBox {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool ShowFinishedMessageBox {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract ShowFinishedMessageBox : bool with get, set
override ShowFinishedMessageBox : bool with get, set
abstract ShowFinishedMessageBox : bool with get, set
override ShowFinishedMessageBox : bool with get, set
Property Value
Boolean


showMessageBoxAtEnd Field

showMessageBoxAtEnd Field
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► showMessageBoxAtEnd
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected bool showMessageBoxAtEnd
protected bool showMessageBoxAtEnd
Protected showMessageBoxAtEnd As Boolean
Protected showMessageBoxAtEnd As Boolean
protected:
bool showMessageBoxAtEnd
protected:
bool showMessageBoxAtEnd
val mutable showMessageBoxAtEnd: bool
val mutable showMessageBoxAtEnd: bool
Field Value
Boolean


SpellCheckFinished Event

SpellCheckFinished Event
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► SpellCheckFinished
Keyoti RapidSpell WPF
Fired when checking finishes
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event RapidSpellGUIPresenter..::..SpellCheckEventHandler SpellCheckFinished
public event RapidSpellGUIPresenter..::..SpellCheckEventHandler SpellCheckFinished
Public Event SpellCheckFinished As RapidSpellGUIPresenter..::..SpellCheckEventHandler
Public Event SpellCheckFinished As RapidSpellGUIPresenter..::..SpellCheckEventHandler
public:
virtual  event RapidSpellGUIPresenter..::..SpellCheckEventHandler^ SpellCheckFinished {
    void add (RapidSpellGUIPresenter..::..SpellCheckEventHandler^ value);
    void remove (RapidSpellGUIPresenter..::..SpellCheckEventHandler^ value);
}
public:
virtual  event RapidSpellGUIPresenter..::..SpellCheckEventHandler^ SpellCheckFinished {
    void add (RapidSpellGUIPresenter..::..SpellCheckEventHandler^ value);
    void remove (RapidSpellGUIPresenter..::..SpellCheckEventHandler^ value);
}
abstract SpellCheckFinished : IEvent<RapidSpellGUIPresenter..::..SpellCheckEventHandler,
    SpellCheckEventArgs>
override SpellCheckFinished : IEvent<RapidSpellGUIPresenter..::..SpellCheckEventHandler,
    SpellCheckEventArgs>
abstract SpellCheckFinished : IEvent<RapidSpellGUIPresenter..::..SpellCheckEventHandler,
    SpellCheckEventArgs>
override SpellCheckFinished : IEvent<RapidSpellGUIPresenter..::..SpellCheckEventHandler,
    SpellCheckEventArgs>
Value
RapidSpellGUIPresenter..::..SpellCheckEventHandler


SpellCheckStarted Event

SpellCheckStarted Event
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► SpellCheckStarted
Keyoti RapidSpell WPF
Fired when checking starts
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event RapidSpellGUIPresenter..::..SpellCheckEventHandler SpellCheckStarted
public event RapidSpellGUIPresenter..::..SpellCheckEventHandler SpellCheckStarted
Public Event SpellCheckStarted As RapidSpellGUIPresenter..::..SpellCheckEventHandler
Public Event SpellCheckStarted As RapidSpellGUIPresenter..::..SpellCheckEventHandler
public:
virtual  event RapidSpellGUIPresenter..::..SpellCheckEventHandler^ SpellCheckStarted {
    void add (RapidSpellGUIPresenter..::..SpellCheckEventHandler^ value);
    void remove (RapidSpellGUIPresenter..::..SpellCheckEventHandler^ value);
}
public:
virtual  event RapidSpellGUIPresenter..::..SpellCheckEventHandler^ SpellCheckStarted {
    void add (RapidSpellGUIPresenter..::..SpellCheckEventHandler^ value);
    void remove (RapidSpellGUIPresenter..::..SpellCheckEventHandler^ value);
}
abstract SpellCheckStarted : IEvent<RapidSpellGUIPresenter..::..SpellCheckEventHandler,
    SpellCheckEventArgs>
override SpellCheckStarted : IEvent<RapidSpellGUIPresenter..::..SpellCheckEventHandler,
    SpellCheckEventArgs>
abstract SpellCheckStarted : IEvent<RapidSpellGUIPresenter..::..SpellCheckEventHandler,
    SpellCheckEventArgs>
override SpellCheckStarted : IEvent<RapidSpellGUIPresenter..::..SpellCheckEventHandler,
    SpellCheckEventArgs>
Value
RapidSpellGUIPresenter..::..SpellCheckEventHandler


subFromPosition Field

subFromPosition Field
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► subFromPosition
Keyoti RapidSpell WPF
To check from and to positions that are wrapped, need to do in 2 steps check from subFromPosition ( = fromPosition) -> subToPosition (= doc end) and then check from subFromPosition (= 0) -> subToPosition (= toPosition)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected int subFromPosition
protected int subFromPosition
Protected subFromPosition As Integer
Protected subFromPosition As Integer
protected:
int subFromPosition
protected:
int subFromPosition
val mutable subFromPosition: int
val mutable subFromPosition: int
Field Value
Int32


subToPosition Field

subToPosition Field
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► subToPosition
Keyoti RapidSpell WPF
To check from and to positions that are wrapped, need to do in 2 steps check from subFromPosition ( = fromPosition) -> subToPosition (= doc end) and then check from subFromPosition (= 0) -> subToPosition (= toPosition)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected int subToPosition
protected int subToPosition
Protected subToPosition As Integer
Protected subToPosition As Integer
protected:
int subToPosition
protected:
int subToPosition
val mutable subToPosition: int
val mutable subToPosition: int
Field Value
Int32


SuggestionsKeyboardText Property

SuggestionsKeyboardText Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► SuggestionsKeyboardText
Keyoti RapidSpell WPF
Suggestions label text when in keyboard mode
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string SuggestionsKeyboardText { get; set; }
public string SuggestionsKeyboardText { get; set; }
Public Property SuggestionsKeyboardText As String
    Get
    Set
Public Property SuggestionsKeyboardText As String
    Get
    Set
public:
property String^ SuggestionsKeyboardText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ SuggestionsKeyboardText {
    String^ get ();
    void set (String^ value);
}
member SuggestionsKeyboardText : string with get, set

member SuggestionsKeyboardText : string with get, set
Property Value
String


SuggestionsLabelText Property

SuggestionsLabelText Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► SuggestionsLabelText
Keyoti RapidSpell WPF
Suggestions label text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string SuggestionsLabelText { get; set; }
public string SuggestionsLabelText { get; set; }
Public Property SuggestionsLabelText As String
    Get
    Set
Public Property SuggestionsLabelText As String
    Get
    Set
public:
virtual property String^ SuggestionsLabelText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ SuggestionsLabelText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract SuggestionsLabelText : string with get, set
override SuggestionsLabelText : string with get, set
abstract SuggestionsLabelText : string with get, set
override SuggestionsLabelText : string with get, set
Property Value
String


SuggestionsMethod Property

SuggestionsMethod Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► SuggestionsMethod
Keyoti RapidSpell WPF
The suggestions method to use.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public SuggestionsMethodType SuggestionsMethod { get; set; }
public SuggestionsMethodType SuggestionsMethod { get; set; }
Public Property SuggestionsMethod As SuggestionsMethodType
    Get
    Set
Public Property SuggestionsMethod As SuggestionsMethodType
    Get
    Set
public:
virtual property SuggestionsMethodType SuggestionsMethod {
    SuggestionsMethodType get () sealed;
    void set (SuggestionsMethodType value) sealed;
}
public:
virtual property SuggestionsMethodType SuggestionsMethod {
    SuggestionsMethodType get () sealed;
    void set (SuggestionsMethodType value) sealed;
}
abstract SuggestionsMethod : SuggestionsMethodType with get, set
override SuggestionsMethod : SuggestionsMethodType with get, set
abstract SuggestionsMethod : SuggestionsMethodType with get, set
override SuggestionsMethod : SuggestionsMethodType with get, set
Property Value
SuggestionsMethodType


SuggestSplitWords Property

SuggestSplitWords Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► SuggestSplitWords
Keyoti RapidSpell WPF
Whether to look for connected words in suggestions.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool SuggestSplitWords { get; set; }
public bool SuggestSplitWords { get; set; }
Public Property SuggestSplitWords As Boolean
    Get
    Set
Public Property SuggestSplitWords As Boolean
    Get
    Set
public:
virtual property bool SuggestSplitWords {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool SuggestSplitWords {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract SuggestSplitWords : bool with get, set
override SuggestSplitWords : bool with get, set
abstract SuggestSplitWords : bool with get, set
override SuggestSplitWords : bool with get, set
Property Value
Boolean
Remarks
if this=true then suggestions may include joined words.

Eg; suggestions for "myhouse" will include "my house"


TextBoundary Property

TextBoundary Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► TextBoundary
Keyoti RapidSpell WPF
The AdvancedTextBoundary class to use to parse words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public AdvancedTextBoundary TextBoundary { get; set; }
public AdvancedTextBoundary TextBoundary { get; set; }
Public Property TextBoundary As AdvancedTextBoundary
    Get
    Set
Public Property TextBoundary As AdvancedTextBoundary
    Get
    Set
public:
property AdvancedTextBoundary^ TextBoundary {
    AdvancedTextBoundary^ get ();
    void set (AdvancedTextBoundary^ value);
}
public:
property AdvancedTextBoundary^ TextBoundary {
    AdvancedTextBoundary^ get ();
    void set (AdvancedTextBoundary^ value);
}
member TextBoundary : AdvancedTextBoundary with get, set

member TextBoundary : AdvancedTextBoundary with get, set
Property Value
AdvancedTextBoundary


TextBox Property

TextBox Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► TextBox
Keyoti RapidSpell WPF
The text box instance that this is working with, the actual type depends on whether the TextBoxBaseToCheck property or ThirdPartyTextComponentToCheck property was set.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Object TextBox { get; }
public Object TextBox { get; }
Public ReadOnly Property TextBox As Object
    Get
Public ReadOnly Property TextBox As Object
    Get
public:
property Object^ TextBox {
    Object^ get ();
}
public:
property Object^ TextBox {
    Object^ get ();
}
member TextBox : Object with get

member TextBox : Object with get
Property Value
Object


theBadWord Field

theBadWord Field
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► theBadWord
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected BadWord theBadWord
protected BadWord theBadWord
Protected theBadWord As BadWord
Protected theBadWord As BadWord
protected:
BadWord^ theBadWord
protected:
BadWord^ theBadWord
val mutable theBadWord: BadWord
val mutable theBadWord: BadWord
Field Value
BadWord


theSpellChecker Field

theSpellChecker Field
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► theSpellChecker
Keyoti RapidSpell WPF
The spell checker component being used
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected ICheckerEngine theSpellChecker
protected ICheckerEngine theSpellChecker
Protected theSpellChecker As ICheckerEngine
Protected theSpellChecker As ICheckerEngine
protected:
ICheckerEngine^ theSpellChecker
protected:
ICheckerEngine^ theSpellChecker
val mutable theSpellChecker: ICheckerEngine
val mutable theSpellChecker: ICheckerEngine
Field Value
ICheckerEngine


theTextComponent Field

theTextComponent Field
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► theTextComponent
Keyoti RapidSpell WPF
The text component being checked
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected ISpellCheckableTextComponent2 theTextComponent
protected ISpellCheckableTextComponent2 theTextComponent
Protected theTextComponent As ISpellCheckableTextComponent2
Protected theTextComponent As ISpellCheckableTextComponent2
protected:
ISpellCheckableTextComponent2^ theTextComponent
protected:
ISpellCheckableTextComponent2^ theTextComponent
val mutable theTextComponent: ISpellCheckableTextComponent2
val mutable theTextComponent: ISpellCheckableTextComponent2
Field Value
ISpellCheckableTextComponent2


toPosition Field

toPosition Field
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► toPosition
Keyoti RapidSpell WPF
Where the user wants to check to
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected int toPosition
protected int toPosition
Protected toPosition As Integer
Protected toPosition As Integer
protected:
int toPosition
protected:
int toPosition
val mutable toPosition: int
val mutable toPosition: int
Field Value
Int32


Undo Method

Undo Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► Undo()()()()
Keyoti RapidSpell WPF
Undoes the previous user operation.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void Undo()
public virtual void Undo()
Public Overridable Sub Undo
Public Overridable Sub Undo
public:
virtual void Undo()
public:
virtual void Undo()
abstract Undo : unit -> unit
override Undo : unit -> unit
abstract Undo : unit -> unit
override Undo : unit -> unit


UndoButtonText Property

UndoButtonText Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► UndoButtonText
Keyoti RapidSpell WPF
Undo button text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UndoButtonText { get; set; }
public string UndoButtonText { get; set; }
Public Property UndoButtonText As String
    Get
    Set
Public Property UndoButtonText As String
    Get
    Set
public:
virtual property String^ UndoButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ UndoButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract UndoButtonText : string with get, set
override UndoButtonText : string with get, set
abstract UndoButtonText : string with get, set
override UndoButtonText : string with get, set
Property Value
String


Undone Event

Undone Event
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► Undone
Keyoti RapidSpell WPF
Fired when an Undo occurs
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event UndoEventHandler Undone
public event UndoEventHandler Undone
Public Event Undone As UndoEventHandler
Public Event Undone As UndoEventHandler
public:
virtual  event UndoEventHandler^ Undone {
    void add (UndoEventHandler^ value);
    void remove (UndoEventHandler^ value);
}
public:
virtual  event UndoEventHandler^ Undone {
    void add (UndoEventHandler^ value);
    void remove (UndoEventHandler^ value);
}
abstract Undone : IEvent<UndoEventHandler,
    UndoEventArgs>
override Undone : IEvent<UndoEventHandler,
    UndoEventArgs>
abstract Undone : IEvent<UndoEventHandler,
    UndoEventArgs>
override Undone : IEvent<UndoEventHandler,
    UndoEventArgs>
Value
UndoEventHandler


UserDictionary Property

UserDictionary Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► UserDictionary
Keyoti RapidSpell WPF
Set the user dictionary object.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UserDictionary UserDictionary { get; set; }
public UserDictionary UserDictionary { get; set; }
Public Property UserDictionary As UserDictionary
    Get
    Set
Public Property UserDictionary As UserDictionary
    Get
    Set
public:
virtual property UserDictionary^ UserDictionary {
    UserDictionary^ get () sealed;
    void set (UserDictionary^ value) sealed;
}
public:
virtual property UserDictionary^ UserDictionary {
    UserDictionary^ get () sealed;
    void set (UserDictionary^ value) sealed;
}
abstract UserDictionary : UserDictionary with get, set
override UserDictionary : UserDictionary with get, set
abstract UserDictionary : UserDictionary with get, set
override UserDictionary : UserDictionary with get, set
Property Value
UserDictionary
Remarks
Use of a user dictionary is optional.


UserDictionaryFile Property

UserDictionaryFile Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► UserDictionaryFile
Keyoti RapidSpell WPF
Set the user dictionary file, if this file doesn't exist it will be created.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionaryFile { set; }
public string UserDictionaryFile { set; }
Public WriteOnly Property UserDictionaryFile As String
    Set
Public WriteOnly Property UserDictionaryFile As String
    Set
public:
virtual property String^ UserDictionaryFile {
    void set (String^ value) sealed;
}
public:
virtual property String^ UserDictionaryFile {
    void set (String^ value) sealed;
}
abstract UserDictionaryFile : string with set
override UserDictionaryFile : string with set
abstract UserDictionaryFile : string with set
override UserDictionaryFile : string with set
Property Value
String
Remarks
Use of a user dictionary is optional.


UserQuery Event

UserQuery Event
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► UserQuery
Keyoti RapidSpell WPF
Indicates that the user is being queried on a spelling error.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event UserQueryEventHandler UserQuery
public event UserQueryEventHandler UserQuery
Public Event UserQuery As UserQueryEventHandler
Public Event UserQuery As UserQueryEventHandler
public:
virtual  event UserQueryEventHandler^ UserQuery {
    void add (UserQueryEventHandler^ value);
    void remove (UserQueryEventHandler^ value);
}
public:
virtual  event UserQueryEventHandler^ UserQuery {
    void add (UserQueryEventHandler^ value);
    void remove (UserQueryEventHandler^ value);
}
abstract UserQuery : IEvent<UserQueryEventHandler,
    UserQueryEventArgs>
override UserQuery : IEvent<UserQueryEventHandler,
    UserQueryEventArgs>
abstract UserQuery : IEvent<UserQueryEventHandler,
    UserQueryEventArgs>
override UserQuery : IEvent<UserQueryEventHandler,
    UserQueryEventArgs>
Value
UserQueryEventHandler


WarnDuplicates Property

WarnDuplicates Property
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► WarnDuplicates
Keyoti RapidSpell WPF
Whether to show duplicate words as errors (eg. "this is is an error").
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool WarnDuplicates { get; set; }
public bool WarnDuplicates { get; set; }
Public Property WarnDuplicates As Boolean
    Get
    Set
Public Property WarnDuplicates As Boolean
    Get
    Set
public:
virtual property bool WarnDuplicates {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool WarnDuplicates {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract WarnDuplicates : bool with get, set
override WarnDuplicates : bool with get, set
abstract WarnDuplicates : bool with get, set
override WarnDuplicates : bool with get, set
Property Value
Boolean


WordAdded Event

WordAdded Event
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► WordAdded
Keyoti RapidSpell WPF
Fired when word added to user dictionary
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event WordAddedEventHandler WordAdded
public event WordAddedEventHandler WordAdded
Public Event WordAdded As WordAddedEventHandler
Public Event WordAdded As WordAddedEventHandler
public:
virtual  event WordAddedEventHandler^ WordAdded {
    void add (WordAddedEventHandler^ value);
    void remove (WordAddedEventHandler^ value);
}
public:
virtual  event WordAddedEventHandler^ WordAdded {
    void add (WordAddedEventHandler^ value);
    void remove (WordAddedEventHandler^ value);
}
abstract WordAdded : IEvent<WordAddedEventHandler,
    WordAddedEventArgs>
override WordAdded : IEvent<WordAddedEventHandler,
    WordAddedEventArgs>
abstract WordAdded : IEvent<WordAddedEventHandler,
    WordAddedEventArgs>
override WordAdded : IEvent<WordAddedEventHandler,
    WordAddedEventArgs>
Value
WordAddedEventHandler


WordChanged Event

WordChanged Event
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► WordChanged
Keyoti RapidSpell WPF
Fired when word changed
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event WordChangedEventHandler WordChanged
public event WordChangedEventHandler WordChanged
Public Event WordChanged As WordChangedEventHandler
Public Event WordChanged As WordChangedEventHandler
public:
virtual  event WordChangedEventHandler^ WordChanged {
    void add (WordChangedEventHandler^ value);
    void remove (WordChangedEventHandler^ value);
}
public:
virtual  event WordChangedEventHandler^ WordChanged {
    void add (WordChangedEventHandler^ value);
    void remove (WordChangedEventHandler^ value);
}
abstract WordChanged : IEvent<WordChangedEventHandler,
    WordChangedEventArgs>
override WordChanged : IEvent<WordChangedEventHandler,
    WordChangedEventArgs>
abstract WordChanged : IEvent<WordChangedEventHandler,
    WordChangedEventArgs>
override WordChanged : IEvent<WordChangedEventHandler,
    WordChangedEventArgs>
Value
WordChangedEventHandler


WordChanging Event

WordChanging Event
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► WordChanging
Keyoti RapidSpell WPF
Fired before a word is changed
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event WordChangedEventHandler WordChanging
public event WordChangedEventHandler WordChanging
Public Event WordChanging As WordChangedEventHandler
Public Event WordChanging As WordChangedEventHandler
public:
virtual  event WordChangedEventHandler^ WordChanging {
    void add (WordChangedEventHandler^ value);
    void remove (WordChangedEventHandler^ value);
}
public:
virtual  event WordChangedEventHandler^ WordChanging {
    void add (WordChangedEventHandler^ value);
    void remove (WordChangedEventHandler^ value);
}
abstract WordChanging : IEvent<WordChangedEventHandler,
    WordChangedEventArgs>
override WordChanging : IEvent<WordChangedEventHandler,
    WordChangedEventArgs>
abstract WordChanging : IEvent<WordChangedEventHandler,
    WordChangedEventArgs>
override WordChanging : IEvent<WordChangedEventHandler,
    WordChangedEventArgs>
Value
WordChangedEventHandler


WordIgnored Event

WordIgnored Event
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► WordIgnored
Keyoti RapidSpell WPF
Fired when word ignored
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event WordIgnoredEventHandler WordIgnored
public event WordIgnoredEventHandler WordIgnored
Public Event WordIgnored As WordIgnoredEventHandler
Public Event WordIgnored As WordIgnoredEventHandler
public:
virtual  event WordIgnoredEventHandler^ WordIgnored {
    void add (WordIgnoredEventHandler^ value);
    void remove (WordIgnoredEventHandler^ value);
}
public:
virtual  event WordIgnoredEventHandler^ WordIgnored {
    void add (WordIgnoredEventHandler^ value);
    void remove (WordIgnoredEventHandler^ value);
}
abstract WordIgnored : IEvent<WordIgnoredEventHandler,
    WordIgnoredEventArgs>
override WordIgnored : IEvent<WordIgnoredEventHandler,
    WordIgnoredEventArgs>
abstract WordIgnored : IEvent<WordIgnoredEventHandler,
    WordIgnoredEventArgs>
override WordIgnored : IEvent<WordIgnoredEventHandler,
    WordIgnoredEventArgs>
Value
WordIgnoredEventHandler


Wrap Method

Wrap Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► Wrap()()()()
Keyoti RapidSpell WPF
Wraps the checker to start at beginning of doc
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void Wrap()
protected virtual void Wrap()
Protected Overridable Sub Wrap
Protected Overridable Sub Wrap
protected:
virtual void Wrap()
protected:
virtual void Wrap()
abstract Wrap : unit -> unit
override Wrap : unit -> unit
abstract Wrap : unit -> unit
override Wrap : unit -> unit


wrapped Field

wrapped Field
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► wrapped
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected bool wrapped
protected bool wrapped
Protected wrapped As Boolean
Protected wrapped As Boolean
protected:
bool wrapped
protected:
bool wrapped
val mutable wrapped: bool
val mutable wrapped: bool
Field Value
Boolean


RapidSpellGUIPresenter.SpellCheckEventHandler Delegate

RapidSpellGUIPresenter..::..SpellCheckEventHandler Delegate
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► RapidSpellGUIPresenter..::..SpellCheckEventHandler
Keyoti RapidSpell WPF
Spell check event handler delegate.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void SpellCheckEventHandler(
    Object sender,
    SpellCheckEventArgs e
)
public delegate void SpellCheckEventHandler(
    Object sender,
    SpellCheckEventArgs e
)
Public Delegate Sub SpellCheckEventHandler (
    sender As Object,
    e As SpellCheckEventArgs
)
Public Delegate Sub SpellCheckEventHandler (
    sender As Object,
    e As SpellCheckEventArgs
)
public delegate void SpellCheckEventHandler(
    Object^ sender,
    SpellCheckEventArgs^ e
)
public delegate void SpellCheckEventHandler(
    Object^ sender,
    SpellCheckEventArgs^ e
)
type SpellCheckEventHandler =
    delegate of
        sender : Object *
        e : SpellCheckEventArgs -> unit
type SpellCheckEventHandler =
    delegate of
        sender : Object *
        e : SpellCheckEventArgs -> unit
Parameters
sender (Object)
e (SpellCheckEventArgs)


RichErrorAdorner Class

RichErrorAdorner Class
API ► Keyoti.RapidSpell.Wpf ► RichErrorAdorner
Keyoti RapidSpell WPF
The highlight adorner, which renders error highlights on a RichTextBox
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class RichErrorAdorner : ErrorAdornerBase
public class RichErrorAdorner : ErrorAdornerBase
Public Class RichErrorAdorner
    Inherits ErrorAdornerBase
Public Class RichErrorAdorner
    Inherits ErrorAdornerBase
public ref class RichErrorAdorner : public ErrorAdornerBase
public ref class RichErrorAdorner : public ErrorAdornerBase
type RichErrorAdorner =
    class
        inherit ErrorAdornerBase
    end
type RichErrorAdorner =
    class
        inherit ErrorAdornerBase
    end
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RichErrorAdorner(RichTextBox, Int32, Int32, IAYTTextBox, UnderlineStyle, Color) | New
 | Active | Whether this adorner is ever visible. It can be inactive if the word it is highlighting is ignored. (Inherited from ErrorAdornerBase.)
 | ActualHeight | (Inherited from FrameworkElement.)
 | ActualWidth | (Inherited from FrameworkElement.)
 | AddHandler(RoutedEvent, Delegate) | (Inherited from UIElement.)
 | AddHandler(RoutedEvent, Delegate, Boolean) | (Inherited from UIElement.)
 | AddLogicalChild(Object) | (Inherited from FrameworkElement.)
 | AddToEventRoute(EventRoute, RoutedEventArgs) | (Inherited from UIElement.)
 | AddVisualChild(Visual) | (Inherited from Visual.)
 | AdornedElement | (Inherited from Adorner.)
 | AllowDrop | (Inherited from UIElement.)
 | ApplyAnimationClock(DependencyProperty, AnimationClock) | (Inherited from UIElement.)
 | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | (Inherited from UIElement.)
 | ApplyTemplate()()()() | (Inherited from FrameworkElement.)
 | AreAnyTouchesCaptured | (Inherited from UIElement.)
 | AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
 | AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
 | AreAnyTouchesOver | (Inherited from UIElement.)
 | Arrange(Rect) | (Inherited from UIElement.)
 | ArrangeCore(Rect) | (Inherited from FrameworkElement.)
 | ArrangeOverride(Size) | (Inherited from FrameworkElement.)
 | BeginAnimation(DependencyProperty, AnimationTimeline) | (Inherited from UIElement.)
 | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | (Inherited from UIElement.)
 | BeginInit()()()() | (Inherited from FrameworkElement.)
 | BeginStoryboard(Storyboard) | (Inherited from FrameworkElement.)
 | BeginStoryboard(Storyboard, HandoffBehavior) | (Inherited from FrameworkElement.)
 | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | (Inherited from FrameworkElement.)
 | BindingGroup | (Inherited from FrameworkElement.)
 | BitmapEffect | Obsolete. (Inherited from UIElement.)
 | BitmapEffectInput | Obsolete. (Inherited from UIElement.)
 | BringIntoView()()()() | (Inherited from FrameworkElement.)
 | BringIntoView(Rect) | (Inherited from FrameworkElement.)
 | BumpUnderlineTo(Int32, Int32) | The underline has moved because the text has been bumped along by new or removed text before it. (Inherited from ErrorAdornerBase.)
 | CacheMode | (Inherited from UIElement.)
 | CaptureMouse()()()() | (Inherited from UIElement.)
 | CaptureStylus()()()() | (Inherited from UIElement.)
 | CaptureTouch(TouchDevice) | (Inherited from UIElement.)
 | cheat | (Inherited from ErrorAdornerBase.)
 | CheckAccess()()()() | (Inherited from DispatcherObject.)
 | ClearValue(DependencyProperty) | (Inherited from DependencyObject.)
 | ClearValue(DependencyPropertyKey) | (Inherited from DependencyObject.)
 | Clip | (Inherited from UIElement.)
 | ClipToBounds | (Inherited from UIElement.)
 | CoerceValue(DependencyProperty) | (Inherited from DependencyObject.)
 | Color | (Inherited from ErrorAdornerBase.)
 | CommandBindings | (Inherited from UIElement.)
 | ConnectAndPaint(DrawingContext, Rect, Rect) | Paints underline between two Rects (Inherited from ErrorAdornerBase.)
 | ContextMenu | (Inherited from FrameworkElement.)
 | ContextMenuClosing | (Inherited from FrameworkElement.)
 | ContextMenuOpening | (Inherited from FrameworkElement.)
 | Cursor | (Inherited from FrameworkElement.)
 | DataContext | (Inherited from FrameworkElement.)
 | DataContextChanged | (Inherited from FrameworkElement.)
 | DefaultStyleKey | (Inherited from FrameworkElement.)
 | DependencyObjectType | (Inherited from DependencyObject.)
 | DesiredSize | (Inherited from UIElement.)
 | Dispatcher | (Inherited from DispatcherObject.)
 | DragEnter | (Inherited from UIElement.)
 | DragLeave | (Inherited from UIElement.)
 | DragOver | (Inherited from UIElement.)
 | Drop | (Inherited from UIElement.)
 | Effect | (Inherited from UIElement.)
 | end | Error position. (Inherited from ErrorAdornerBase.)
 | EndInit()()()() | (Inherited from FrameworkElement.)
 | endP |
 | Equals(Object) | (Inherited from DependencyObject.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FindCommonVisualAncestor(DependencyObject) | (Inherited from Visual.)
 | FindName(String) | (Inherited from FrameworkElement.)
 | FindResource(Object) | (Inherited from FrameworkElement.)
 | FlowDirection | (Inherited from FrameworkElement.)
 | Focus()()()() | (Inherited from UIElement.)
 | Focusable | (Inherited from UIElement.)
 | FocusableChanged | (Inherited from UIElement.)
 | FocusVisualStyle | (Inherited from FrameworkElement.)
 | ForceCursor | (Inherited from FrameworkElement.)
 | GetAnimationBaseValue(DependencyProperty) | (Inherited from UIElement.)
 | GetBindingExpression(DependencyProperty) | (Inherited from FrameworkElement.)
 | GetDesiredTransform(GeneralTransform) | (Inherited from Adorner.)
 | GetHashCode()()()() | (Inherited from DependencyObject.)
 | GetLayoutClip(Size) | (Inherited from Adorner.)
 | GetLocalValueEnumerator()()()() | (Inherited from DependencyObject.)
 | GetTemplateChild(String) | (Inherited from FrameworkElement.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GetUIParentCore()()()() | (Inherited from FrameworkElement.)
 | GetValue(DependencyProperty) | (Inherited from DependencyObject.)
 | GetVisualChild(Int32) | (Inherited from FrameworkElement.)
 | GiveFeedback | (Inherited from UIElement.)
 | GotFocus | (Inherited from UIElement.)
 | GotKeyboardFocus | (Inherited from UIElement.)
 | GotMouseCapture | (Inherited from UIElement.)
 | GotStylusCapture | (Inherited from UIElement.)
 | GotTouchCapture | (Inherited from UIElement.)
 | HasAnimatedProperties | (Inherited from UIElement.)
 | HasEffectiveKeyboardFocus | (Inherited from UIElement.)
 | Height | (Inherited from FrameworkElement.)
 | HighlightFillBrush | The highlight brush (Inherited from ErrorAdornerBase.)
 | HighlightLinePen | The highlight pen (Inherited from ErrorAdornerBase.)
 | HitTestCore(PointHitTestParameters) | (Inherited from UIElement.)
 | HitTestCore(GeometryHitTestParameters) | (Inherited from UIElement.)
 | HorizontalAlignment | (Inherited from FrameworkElement.)
 | iayt | The IAYT interface cast of the text box wrapper (Inherited from ErrorAdornerBase.)
 | InheritanceBehavior | (Inherited from FrameworkElement.)
 | Initialized | (Inherited from FrameworkElement.)
 | InputBindings | (Inherited from UIElement.)
 | InputHitTest(Point) | (Inherited from UIElement.)
 | InputScope | (Inherited from FrameworkElement.)
 | InvalidateArrange()()()() | (Inherited from UIElement.)
 | InvalidateMeasure()()()() | (Inherited from UIElement.)
 | InvalidateProperty(DependencyProperty) | (Inherited from DependencyObject.)
 | InvalidateVisual()()()() | (Inherited from UIElement.)
 | IsAncestorOf(DependencyObject) | (Inherited from Visual.)
 | IsArrangeValid | (Inherited from UIElement.)
 | IsAt(Int32, Int32) | Whether this highlight is at start to end (Inherited from ErrorAdornerBase.)
 | IsClipEnabled | (Inherited from Adorner.)
 | IsDescendantOf(DependencyObject) | (Inherited from Visual.)
 | IsEnabled | (Inherited from UIElement.)
 | IsEnabledChanged | (Inherited from UIElement.)
 | IsEnabledCore | (Inherited from UIElement.)
 | IsFocused | (Inherited from UIElement.)
 | IsHitTestVisible | (Inherited from UIElement.)
 | IsHitTestVisibleChanged | (Inherited from UIElement.)
 | IsInitialized | (Inherited from FrameworkElement.)
 | IsInputMethodEnabled | (Inherited from UIElement.)
 | IsKeyboardFocused | (Inherited from UIElement.)
 | IsKeyboardFocusedChanged | (Inherited from UIElement.)
 | IsKeyboardFocusWithin | (Inherited from UIElement.)
 | IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
 | IsLoaded | (Inherited from FrameworkElement.)
 | IsManipulationEnabled | (Inherited from UIElement.)
 | IsMeasureValid | (Inherited from UIElement.)
 | IsMouseCaptured | (Inherited from UIElement.)
 | IsMouseCapturedChanged | (Inherited from UIElement.)
 | IsMouseCaptureWithin | (Inherited from UIElement.)
 | IsMouseCaptureWithinChanged | (Inherited from UIElement.)
 | IsMouseDirectlyOver | (Inherited from UIElement.)
 | IsMouseDirectlyOverChanged | (Inherited from UIElement.)
 | IsMouseOver | (Inherited from UIElement.)
 | IsSealed | (Inherited from DependencyObject.)
 | IsStylusCaptured | (Inherited from UIElement.)
 | IsStylusCapturedChanged | (Inherited from UIElement.)
 | IsStylusCaptureWithin | (Inherited from UIElement.)
 | IsStylusCaptureWithinChanged | (Inherited from UIElement.)
 | IsStylusDirectlyOver | (Inherited from UIElement.)
 | IsStylusDirectlyOverChanged | (Inherited from UIElement.)
 | IsStylusOver | (Inherited from UIElement.)
 | IsVisible | (Inherited from UIElement.)
 | IsVisibleChanged | (Inherited from UIElement.)
 | KeyDown | (Inherited from UIElement.)
 | KeyUp | (Inherited from UIElement.)
 | Language | (Inherited from FrameworkElement.)
 | LayoutTransform | (Inherited from FrameworkElement.)
 | LayoutUpdated | (Inherited from UIElement.)
 | Loaded | (Inherited from FrameworkElement.)
 | LogicalChildren | (Inherited from FrameworkElement.)
 | LostFocus | (Inherited from UIElement.)
 | LostKeyboardFocus | (Inherited from UIElement.)
 | LostMouseCapture | (Inherited from UIElement.)
 | LostStylusCapture | (Inherited from UIElement.)
 | LostTouchCapture | (Inherited from UIElement.)
 | ManipulationBoundaryFeedback | (Inherited from UIElement.)
 | ManipulationCompleted | (Inherited from UIElement.)
 | ManipulationDelta | (Inherited from UIElement.)
 | ManipulationInertiaStarting | (Inherited from UIElement.)
 | ManipulationStarted | (Inherited from UIElement.)
 | ManipulationStarting | (Inherited from UIElement.)
 | Margin | (Inherited from FrameworkElement.)
 | MaxHeight | (Inherited from FrameworkElement.)
 | MaxWidth | (Inherited from FrameworkElement.)
 | Measure(Size) | (Inherited from UIElement.)
 | MeasureCore(Size) | (Inherited from FrameworkElement.)
 | MeasureOverride(Size) | (Inherited from Adorner.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinHeight | (Inherited from FrameworkElement.)
 | MinWidth | (Inherited from FrameworkElement.)
 | MouseDown | (Inherited from UIElement.)
 | MouseEnter | (Inherited from UIElement.)
 | MouseLeave | (Inherited from UIElement.)
 | MouseLeftButtonDown | (Inherited from UIElement.)
 | MouseLeftButtonUp | (Inherited from UIElement.)
 | MouseMove | (Inherited from UIElement.)
 | MouseRightButtonDown | (Inherited from UIElement.)
 | MouseRightButtonUp | (Inherited from UIElement.)
 | MouseUp | (Inherited from UIElement.)
 | MouseWheel | (Inherited from UIElement.)
 | MoveFocus(TraversalRequest) | (Inherited from FrameworkElement.)
 | Name | (Inherited from FrameworkElement.)
 | numberOfFailedRenderAttempts | (Inherited from ErrorAdornerBase.)
 | OnAccessKey(AccessKeyEventArgs) | (Inherited from UIElement.)
 | OnActiveChanged(Boolean) | (Overrides ErrorAdornerBase.OnActiveChanged(Boolean).)
 | OnApplyTemplate()()()() | (Inherited from FrameworkElement.)
 | OnChildDesiredSizeChanged(UIElement) | (Inherited from UIElement.)
 | OnContextMenuClosing(ContextMenuEventArgs) | (Inherited from FrameworkElement.)
 | OnContextMenuOpening(ContextMenuEventArgs) | (Inherited from FrameworkElement.)
 | OnCreateAutomationPeer()()()() | (Inherited from UIElement.)
 | OnDpiChanged(DpiScale, DpiScale) | (Inherited from Visual.)
 | OnDragEnter(DragEventArgs) | (Inherited from UIElement.)
 | OnDragLeave(DragEventArgs) | (Inherited from UIElement.)
 | OnDragOver(DragEventArgs) | (Inherited from UIElement.)
 | OnDrop(DragEventArgs) | (Inherited from UIElement.)
 | OnGiveFeedback(GiveFeedbackEventArgs) | (Inherited from UIElement.)
 | OnGotFocus(RoutedEventArgs) | (Inherited from FrameworkElement.)
 | OnGotKeyboardFocus(KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
 | OnGotMouseCapture(MouseEventArgs) | (Inherited from UIElement.)
 | OnGotStylusCapture(StylusEventArgs) | (Inherited from UIElement.)
 | OnGotTouchCapture(TouchEventArgs) | (Inherited from UIElement.)
 | OnInitialized(EventArgs) | (Inherited from FrameworkElement.)
 | OnIsKeyboardFocusedChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsKeyboardFocusWithinChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsMouseCapturedChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsMouseCaptureWithinChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsMouseDirectlyOverChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsStylusCapturedChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsStylusCaptureWithinChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsStylusDirectlyOverChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnKeyDown(KeyEventArgs) | (Inherited from UIElement.)
 | OnKeyUp(KeyEventArgs) | (Inherited from UIElement.)
 | OnLostFocus(RoutedEventArgs) | (Inherited from UIElement.)
 | OnLostKeyboardFocus(KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
 | OnLostMouseCapture(MouseEventArgs) | (Inherited from UIElement.)
 | OnLostStylusCapture(StylusEventArgs) | (Inherited from UIElement.)
 | OnLostTouchCapture(TouchEventArgs) | (Inherited from UIElement.)
 | OnManipulationBoundaryFeedback(ManipulationBoundaryFeedbackEventArgs) | (Inherited from UIElement.)
 | OnManipulationCompleted(ManipulationCompletedEventArgs) | (Inherited from UIElement.)
 | OnManipulationDelta(ManipulationDeltaEventArgs) | (Inherited from UIElement.)
 | OnManipulationInertiaStarting(ManipulationInertiaStartingEventArgs) | (Inherited from UIElement.)
 | OnManipulationStarted(ManipulationStartedEventArgs) | (Inherited from UIElement.)
 | OnManipulationStarting(ManipulationStartingEventArgs) | (Inherited from UIElement.)
 | OnMouseDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseEnter(MouseEventArgs) | (Inherited from UIElement.)
 | OnMouseLeave(MouseEventArgs) | (Inherited from UIElement.)
 | OnMouseLeftButtonDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseLeftButtonUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseMove(MouseEventArgs) | (Inherited from UIElement.)
 | OnMouseRightButtonDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseRightButtonUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseWheel(MouseWheelEventArgs) | (Inherited from UIElement.)
 | OnPreviewDragEnter(DragEventArgs) | (Inherited from UIElement.)
 | OnPreviewDragLeave(DragEventArgs) | (Inherited from UIElement.)
 | OnPreviewDragOver(DragEventArgs) | (Inherited from UIElement.)
 | OnPreviewDrop(DragEventArgs) | (Inherited from UIElement.)
 | OnPreviewGiveFeedback(GiveFeedbackEventArgs) | (Inherited from UIElement.)
 | OnPreviewGotKeyboardFocus(KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
 | OnPreviewKeyDown(KeyEventArgs) | (Inherited from UIElement.)
 | OnPreviewKeyUp(KeyEventArgs) | (Inherited from UIElement.)
 | OnPreviewLostKeyboardFocus(KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseLeftButtonDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseLeftButtonUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseMove(MouseEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseRightButtonDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseRightButtonUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseWheel(MouseWheelEventArgs) | (Inherited from UIElement.)
 | OnPreviewQueryContinueDrag(QueryContinueDragEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusButtonDown(StylusButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusButtonUp(StylusButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusDown(StylusDownEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusInAirMove(StylusEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusInRange(StylusEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusMove(StylusEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusOutOfRange(StylusEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusSystemGesture(StylusSystemGestureEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusUp(StylusEventArgs) | (Inherited from UIElement.)
 | OnPreviewTextInput(TextCompositionEventArgs) | (Inherited from UIElement.)
 | OnPreviewTouchDown(TouchEventArgs) | (Inherited from UIElement.)
 | OnPreviewTouchMove(TouchEventArgs) | (Inherited from UIElement.)
 | OnPreviewTouchUp(TouchEventArgs) | (Inherited from UIElement.)
 | OnPropertyChanged(DependencyPropertyChangedEventArgs) | (Inherited from FrameworkElement.)
 | OnQueryContinueDrag(QueryContinueDragEventArgs) | (Inherited from UIElement.)
 | OnQueryCursor(QueryCursorEventArgs) | (Inherited from UIElement.)
 | OnRender(DrawingContext) | Renders error (Overrides UIElement.OnRender(DrawingContext).)
 | OnRenderImpossible()()()() | Fires render impossible event (Inherited from ErrorAdornerBase.)
 | OnRenderSizeChanged(SizeChangedInfo) | (Inherited from FrameworkElement.)
 | OnStyleChanged(Style, Style) | (Inherited from FrameworkElement.)
 | OnStylusButtonDown(StylusButtonEventArgs) | (Inherited from UIElement.)
 | OnStylusButtonUp(StylusButtonEventArgs) | (Inherited from UIElement.)
 | OnStylusDown(StylusDownEventArgs) | (Inherited from UIElement.)
 | OnStylusEnter(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusInAirMove(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusInRange(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusLeave(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusMove(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusOutOfRange(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusSystemGesture(StylusSystemGestureEventArgs) | (Inherited from UIElement.)
 | OnStylusUp(StylusEventArgs) | (Inherited from UIElement.)
 | OnTextInput(TextCompositionEventArgs) | (Inherited from UIElement.)
 | OnToolTipClosing(ToolTipEventArgs) | (Inherited from FrameworkElement.)
 | OnToolTipOpening(ToolTipEventArgs) | (Inherited from FrameworkElement.)
 | OnTouchDown(TouchEventArgs) | (Inherited from UIElement.)
 | OnTouchEnter(TouchEventArgs) | (Inherited from UIElement.)
 | OnTouchLeave(TouchEventArgs) | (Inherited from UIElement.)
 | OnTouchMove(TouchEventArgs) | (Inherited from UIElement.)
 | OnTouchUp(TouchEventArgs) | (Inherited from UIElement.)
 | OnVisualChildrenChanged(DependencyObject, DependencyObject) | (Inherited from Visual.)
 | OnVisualParentChanged(DependencyObject) | (Inherited from FrameworkElement.)
 | Opacity | (Inherited from UIElement.)
 | OpacityMask | (Inherited from UIElement.)
 | OverridesDefaultStyle | (Inherited from FrameworkElement.)
 | Parent | (Inherited from FrameworkElement.)
 | ParentLayoutInvalidated(UIElement) | (Inherited from FrameworkElement.)
 | PersistId | Obsolete. (Inherited from UIElement.)
 | PointFromScreen(Point) | (Inherited from Visual.)
 | PointToScreen(Point) | (Inherited from Visual.)
 | PredictFocus(FocusNavigationDirection) | (Inherited from FrameworkElement.)
 | PreviewDragEnter | (Inherited from UIElement.)
 | PreviewDragLeave | (Inherited from UIElement.)
 | PreviewDragOver | (Inherited from UIElement.)
 | PreviewDrop | (Inherited from UIElement.)
 | PreviewGiveFeedback | (Inherited from UIElement.)
 | PreviewGotKeyboardFocus | (Inherited from UIElement.)
 | PreviewKeyDown | (Inherited from UIElement.)
 | PreviewKeyUp | (Inherited from UIElement.)
 | PreviewLostKeyboardFocus | (Inherited from UIElement.)
 | PreviewMouseDown | (Inherited from UIElement.)
 | PreviewMouseLeftButtonDown | (Inherited from UIElement.)
 | PreviewMouseLeftButtonUp | (Inherited from UIElement.)
 | PreviewMouseMove | (Inherited from UIElement.)
 | PreviewMouseRightButtonDown | (Inherited from UIElement.)
 | PreviewMouseRightButtonUp | (Inherited from UIElement.)
 | PreviewMouseUp | (Inherited from UIElement.)
 | PreviewMouseWheel | (Inherited from UIElement.)
 | PreviewQueryContinueDrag | (Inherited from UIElement.)
 | PreviewStylusButtonDown | (Inherited from UIElement.)
 | PreviewStylusButtonUp | (Inherited from UIElement.)
 | PreviewStylusDown | (Inherited from UIElement.)
 | PreviewStylusInAirMove | (Inherited from UIElement.)
 | PreviewStylusInRange | (Inherited from UIElement.)
 | PreviewStylusMove | (Inherited from UIElement.)
 | PreviewStylusOutOfRange | (Inherited from UIElement.)
 | PreviewStylusSystemGesture | (Inherited from UIElement.)
 | PreviewStylusUp | (Inherited from UIElement.)
 | PreviewTextInput | (Inherited from UIElement.)
 | PreviewTouchDown | (Inherited from UIElement.)
 | PreviewTouchMove | (Inherited from UIElement.)
 | PreviewTouchUp | (Inherited from UIElement.)
 | QueryContinueDrag | (Inherited from UIElement.)
 | QueryCursor | (Inherited from UIElement.)
 | RaiseEvent(RoutedEventArgs) | (Inherited from UIElement.)
 | ReadLocalValue(DependencyProperty) | (Inherited from DependencyObject.)
 | RegisterName(String, Object) | (Inherited from FrameworkElement.)
 | ReleaseAllTouchCaptures()()()() | (Inherited from UIElement.)
 | ReleaseMouseCapture()()()() | (Inherited from UIElement.)
 | ReleaseStylusCapture()()()() | (Inherited from UIElement.)
 | ReleaseTouchCapture(TouchDevice) | (Inherited from UIElement.)
 | RemoveHandler(RoutedEvent, Delegate) | (Inherited from UIElement.)
 | RemoveLogicalChild(Object) | (Inherited from FrameworkElement.)
 | RemoveVisualChild(Visual) | (Inherited from Visual.)
 | RenderSize | (Inherited from UIElement.)
 | RenderTransform | (Inherited from UIElement.)
 | RenderTransformOrigin | (Inherited from UIElement.)
 | RequestBringIntoView | (Inherited from FrameworkElement.)
 | Resources | (Inherited from FrameworkElement.)
 | scroller_ScrollChanged(Object, ScrollChangedEventArgs) | (Overrides ErrorAdornerBase.scroller_ScrollChanged(Object, ScrollChangedEventArgs).)
 | SetBinding(DependencyProperty, BindingBase) | (Inherited from FrameworkElement.)
 | SetBinding(DependencyProperty, String) | (Inherited from FrameworkElement.)
 | SetCurrentValue(DependencyProperty, Object) | (Inherited from DependencyObject.)
 | SetResourceReference(DependencyProperty, Object) | (Inherited from FrameworkElement.)
 | SetValue(DependencyProperty, Object) | (Inherited from DependencyObject.)
 | SetValue(DependencyPropertyKey, Object) | (Inherited from DependencyObject.)
 | ShouldSerializeCommandBindings()()()() | (Inherited from UIElement.)
 | ShouldSerializeInputBindings()()()() | (Inherited from UIElement.)
 | ShouldSerializeProperty(DependencyProperty) | (Inherited from DependencyObject.)
 | ShouldSerializeResources()()()() | (Inherited from FrameworkElement.)
 | ShouldSerializeStyle()()()() | (Inherited from FrameworkElement.)
 | ShouldSerializeTriggers()()()() | (Inherited from FrameworkElement.)
 | SizeChanged | (Inherited from FrameworkElement.)
 | SnapsToDevicePixels | (Inherited from UIElement.)
 | SourceUpdated | (Inherited from FrameworkElement.)
 | start | Error position. (Inherited from ErrorAdornerBase.)
 | startP |
 | Style | (Inherited from FrameworkElement.)
 | StylusButtonDown | (Inherited from UIElement.)
 | StylusButtonUp | (Inherited from UIElement.)
 | StylusDown | (Inherited from UIElement.)
 | StylusEnter | (Inherited from UIElement.)
 | StylusInAirMove | (Inherited from UIElement.)
 | StylusInRange | (Inherited from UIElement.)
 | StylusLeave | (Inherited from UIElement.)
 | StylusMove | (Inherited from UIElement.)
 | StylusOutOfRange | (Inherited from UIElement.)
 | StylusPlugIns | (Inherited from UIElement.)
 | StylusSystemGesture | (Inherited from UIElement.)
 | StylusUp | (Inherited from UIElement.)
 | Tag | (Inherited from FrameworkElement.)
 | TargetUpdated | (Inherited from FrameworkElement.)
 | tb |
 | tbb | The text box (Inherited from ErrorAdornerBase.)
 | tbb_TextChanged(Object, TextChangedEventArgs) | (Overrides ErrorAdornerBase.tbb_TextChanged(Object, TextChangedEventArgs).)
 | TemplatedParent | (Inherited from FrameworkElement.)
 | TextInput | (Inherited from UIElement.)
 | ToolTip | (Inherited from FrameworkElement.)
 | ToolTipClosing | (Inherited from FrameworkElement.)
 | ToolTipOpening | (Inherited from FrameworkElement.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | TouchDown | (Inherited from UIElement.)
 | TouchEnter | (Inherited from UIElement.)
 | TouchesCaptured | (Inherited from UIElement.)
 | TouchesCapturedWithin | (Inherited from UIElement.)
 | TouchesDirectlyOver | (Inherited from UIElement.)
 | TouchesOver | (Inherited from UIElement.)
 | TouchLeave | (Inherited from UIElement.)
 | TouchMove | (Inherited from UIElement.)
 | TouchUp | (Inherited from UIElement.)
 | TransformToAncestor(Visual) | (Inherited from Visual.)
 | TransformToAncestor(Visual3D) | (Inherited from Visual.)
 | TransformToDescendant(Visual) | (Inherited from Visual.)
 | TransformToVisual(Visual) | (Inherited from Visual.)
 | TranslatePoint(Point, UIElement) | (Inherited from UIElement.)
 | Triggers | (Inherited from FrameworkElement.)
 | TryFindResource(Object) | (Inherited from FrameworkElement.)
 | Uid | (Inherited from UIElement.)
 | Unloaded | (Inherited from FrameworkElement.)
 | Unregister()()()() | Cleans up event handlers (Overrides ErrorAdornerBase.Unregister()()()().)
 | UnregisterName(String) | (Inherited from FrameworkElement.)
 | UpdateDefaultStyle()()()() | (Inherited from FrameworkElement.)
 | UpdateLayout()()()() | (Inherited from UIElement.)
 | UpdateUnderlinePosition(Int32, Int32) | Updates the TextPointers (Overrides ErrorAdornerBase.UpdateUnderlinePosition(Int32, Int32).)
 | UseLayoutRounding | (Inherited from FrameworkElement.)
 | VerifyAccess()()()() | (Inherited from DispatcherObject.)
 | VerticalAlignment | (Inherited from FrameworkElement.)
 | Visibility | (Inherited from UIElement.)
 | VisualBitmapEffect | Obsolete. (Inherited from Visual.)
 | VisualBitmapEffectInput | Obsolete. (Inherited from Visual.)
 | VisualBitmapScalingMode | (Inherited from Visual.)
 | VisualCacheMode | (Inherited from Visual.)
 | VisualChildrenCount | (Inherited from FrameworkElement.)
 | VisualClearTypeHint | (Inherited from Visual.)
 | VisualClip | (Inherited from Visual.)
 | VisualEdgeMode | (Inherited from Visual.)
 | VisualEffect | (Inherited from Visual.)
 | VisualOffset | (Inherited from Visual.)
 | VisualOpacity | (Inherited from Visual.)
 | VisualOpacityMask | (Inherited from Visual.)
 | VisualParent | (Inherited from Visual.)
 | VisualScrollableAreaClip | (Inherited from Visual.)
 | VisualTextHintingMode | (Inherited from Visual.)
 | VisualTextRenderingMode | (Inherited from Visual.)
 | VisualTransform | (Inherited from Visual.)
 | VisualXSnappingGuidelines | (Inherited from Visual.)
 | VisualYSnappingGuidelines | (Inherited from Visual.)
 | Width | (Inherited from FrameworkElement.)
Inheritance Hierarchy
Object
 | DispatcherObject
 |  | DependencyObject
 |  |  | Visual
 |  |  |  | UIElement
 |  |  |  |  | FrameworkElement
 |  |  |  |  |  | Adorner
 |  |  |  |  |  |  | ErrorAdornerBase
 |  |  |  |  |  |  |  | RichErrorAdorner


RichErrorAdorner Constructor (adornedElement, start, end, iayt, u, c)

RichErrorAdorner Constructor (adornedElement, start, end, iayt, u, c)
API ► Keyoti.RapidSpell.Wpf ► RichErrorAdorner ► RichErrorAdorner(RichTextBox, Int32, Int32, IAYTTextBox, UnderlineStyle, Color)
Keyoti RapidSpell WPF
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public RichErrorAdorner(
    RichTextBox adornedElement,
    int start,
    int end,
    IAYTTextBox iayt,
    UnderlineStyle u,
    Color c
)
public RichErrorAdorner(
    RichTextBox adornedElement,
    int start,
    int end,
    IAYTTextBox iayt,
    UnderlineStyle u,
    Color c
)
Public Sub New (
    adornedElement As RichTextBox,
    start As Integer,
    end As Integer,
    iayt As IAYTTextBox,
    u As UnderlineStyle,
    c As Color
)
Public Sub New (
    adornedElement As RichTextBox,
    start As Integer,
    end As Integer,
    iayt As IAYTTextBox,
    u As UnderlineStyle,
    c As Color
)
public:
RichErrorAdorner(
    RichTextBox^ adornedElement,
    int start,
    int end,
    IAYTTextBox^ iayt,
    UnderlineStyle u,
    Color c
)
public:
RichErrorAdorner(
    RichTextBox^ adornedElement,
    int start,
    int end,
    IAYTTextBox^ iayt,
    UnderlineStyle u,
    Color c
)
new :
        adornedElement : RichTextBox *
        start : int *
        end : int *
        iayt : IAYTTextBox *
        u : UnderlineStyle *
        c : Color -> RichErrorAdorner
new :
        adornedElement : RichTextBox *
        start : int *
        end : int *
        iayt : IAYTTextBox *
        u : UnderlineStyle *
        c : Color -> RichErrorAdorner
Parameters
adornedElement (RichTextBox)
start (Int32)
end (Int32)
iayt (IAYTTextBox)
u (UnderlineStyle)
c (Color)


endP Field

endP Field
API ► Keyoti.RapidSpell.Wpf ► RichErrorAdorner ► endP
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected TextPointer endP
protected TextPointer endP
Protected endP As TextPointer
Protected endP As TextPointer
protected:
TextPointer^ endP
protected:
TextPointer^ endP
val mutable endP: TextPointer
val mutable endP: TextPointer
Field Value
TextPointer


OnActiveChanged Method (value)

OnActiveChanged Method (value)
API ► Keyoti.RapidSpell.Wpf ► RichErrorAdorner ► OnActiveChanged(Boolean)
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override void OnActiveChanged(
    bool value
)
protected override void OnActiveChanged(
    bool value
)
Protected Overrides Sub OnActiveChanged (
    value As Boolean
)
Protected Overrides Sub OnActiveChanged (
    value As Boolean
)
protected:
virtual void OnActiveChanged(
    bool value
) override
protected:
virtual void OnActiveChanged(
    bool value
) override
abstract OnActiveChanged :
        value : bool -> unit
override OnActiveChanged :
        value : bool -> unit
abstract OnActiveChanged :
        value : bool -> unit
override OnActiveChanged :
        value : bool -> unit
Parameters
value (Boolean)


OnRender Method (drawingContext)

OnRender Method (drawingContext)
API ► Keyoti.RapidSpell.Wpf ► RichErrorAdorner ► OnRender(DrawingContext)
Keyoti RapidSpell WPF
Renders error
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override void OnRender(
    DrawingContext drawingContext
)
protected override void OnRender(
    DrawingContext drawingContext
)
Protected Overrides Sub OnRender (
    drawingContext As DrawingContext
)
Protected Overrides Sub OnRender (
    drawingContext As DrawingContext
)
protected:
virtual void OnRender(
    DrawingContext^ drawingContext
) override
protected:
virtual void OnRender(
    DrawingContext^ drawingContext
) override
abstract OnRender :
        drawingContext : DrawingContext -> unit
override OnRender :
        drawingContext : DrawingContext -> unit
abstract OnRender :
        drawingContext : DrawingContext -> unit
override OnRender :
        drawingContext : DrawingContext -> unit
Parameters
drawingContext (DrawingContext)


scroller_ScrollChanged Method (sender, e)

scroller_ScrollChanged Method (sender, e)
API ► Keyoti.RapidSpell.Wpf ► RichErrorAdorner ► scroller_ScrollChanged(Object, ScrollChangedEventArgs)
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override void scroller_ScrollChanged(
    Object sender,
    ScrollChangedEventArgs e
)
protected override void scroller_ScrollChanged(
    Object sender,
    ScrollChangedEventArgs e
)
Protected Overrides Sub scroller_ScrollChanged (
    sender As Object,
    e As ScrollChangedEventArgs
)
Protected Overrides Sub scroller_ScrollChanged (
    sender As Object,
    e As ScrollChangedEventArgs
)
protected:
virtual void scroller_ScrollChanged(
    Object^ sender,
    ScrollChangedEventArgs^ e
) override
protected:
virtual void scroller_ScrollChanged(
    Object^ sender,
    ScrollChangedEventArgs^ e
) override
abstract scroller_ScrollChanged :
        sender : Object *
        e : ScrollChangedEventArgs -> unit
override scroller_ScrollChanged :
        sender : Object *
        e : ScrollChangedEventArgs -> unit
abstract scroller_ScrollChanged :
        sender : Object *
        e : ScrollChangedEventArgs -> unit
override scroller_ScrollChanged :
        sender : Object *
        e : ScrollChangedEventArgs -> unit
Parameters
sender (Object)
e (ScrollChangedEventArgs)


startP Field

startP Field
API ► Keyoti.RapidSpell.Wpf ► RichErrorAdorner ► startP
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected TextPointer startP
protected TextPointer startP
Protected startP As TextPointer
Protected startP As TextPointer
protected:
TextPointer^ startP
protected:
TextPointer^ startP
val mutable startP: TextPointer
val mutable startP: TextPointer
Field Value
TextPointer


tb Field

tb Field
API ► Keyoti.RapidSpell.Wpf ► RichErrorAdorner ► tb
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected RichTextBox tb
protected RichTextBox tb
Protected tb As RichTextBox
Protected tb As RichTextBox
protected:
RichTextBox^ tb
protected:
RichTextBox^ tb
val mutable tb: RichTextBox
val mutable tb: RichTextBox
Field Value
RichTextBox


tbb_TextChanged Method (sender, e)

tbb_TextChanged Method (sender, e)
API ► Keyoti.RapidSpell.Wpf ► RichErrorAdorner ► tbb_TextChanged(Object, TextChangedEventArgs)
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override void tbb_TextChanged(
    Object sender,
    TextChangedEventArgs e
)
protected override void tbb_TextChanged(
    Object sender,
    TextChangedEventArgs e
)
Protected Overrides Sub tbb_TextChanged (
    sender As Object,
    e As TextChangedEventArgs
)
Protected Overrides Sub tbb_TextChanged (
    sender As Object,
    e As TextChangedEventArgs
)
protected:
virtual void tbb_TextChanged(
    Object^ sender,
    TextChangedEventArgs^ e
) override
protected:
virtual void tbb_TextChanged(
    Object^ sender,
    TextChangedEventArgs^ e
) override
abstract tbb_TextChanged :
        sender : Object *
        e : TextChangedEventArgs -> unit
override tbb_TextChanged :
        sender : Object *
        e : TextChangedEventArgs -> unit
abstract tbb_TextChanged :
        sender : Object *
        e : TextChangedEventArgs -> unit
override tbb_TextChanged :
        sender : Object *
        e : TextChangedEventArgs -> unit
Parameters
sender (Object)
e (TextChangedEventArgs)


Unregister Method

Unregister Method
API ► Keyoti.RapidSpell.Wpf ► RichErrorAdorner ► Unregister()()()()
Keyoti RapidSpell WPF
Cleans up event handlers
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override void Unregister()
public override void Unregister()
Public Overrides Sub Unregister
Public Overrides Sub Unregister
public:
virtual void Unregister() override
public:
virtual void Unregister() override
abstract Unregister : unit -> unit
override Unregister : unit -> unit
abstract Unregister : unit -> unit
override Unregister : unit -> unit


UpdateUnderlinePosition Method (start, end)

UpdateUnderlinePosition Method (start, end)
API ► Keyoti.RapidSpell.Wpf ► RichErrorAdorner ► UpdateUnderlinePosition(Int32, Int32)
Keyoti RapidSpell WPF
Updates the TextPointers
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override void UpdateUnderlinePosition(
    int start,
    int end
)
public override void UpdateUnderlinePosition(
    int start,
    int end
)
Public Overrides Sub UpdateUnderlinePosition (
    start As Integer,
    end As Integer
)
Public Overrides Sub UpdateUnderlinePosition (
    start As Integer,
    end As Integer
)
public:
virtual void UpdateUnderlinePosition(
    int start,
    int end
) override
public:
virtual void UpdateUnderlinePosition(
    int start,
    int end
) override
abstract UpdateUnderlinePosition :
        start : int *
        end : int -> unit
override UpdateUnderlinePosition :
        start : int *
        end : int -> unit
abstract UpdateUnderlinePosition :
        start : int *
        end : int -> unit
override UpdateUnderlinePosition :
        start : int *
        end : int -> unit
Parameters
start (Int32)
end (Int32)


SelectionAdorner Class

SelectionAdorner Class
API ► Keyoti.RapidSpell.Wpf ► SelectionAdorner
Keyoti RapidSpell WPF
The highlight adorner, which renders error highlights on a TextBoxBase
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class SelectionAdorner : Adorner
public class SelectionAdorner : Adorner
Public Class SelectionAdorner
    Inherits Adorner
Public Class SelectionAdorner
    Inherits Adorner
public ref class SelectionAdorner : public Adorner
public ref class SelectionAdorner : public Adorner
type SelectionAdorner =
    class
        inherit Adorner
    end
type SelectionAdorner =
    class
        inherit Adorner
    end
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SelectionAdorner(UIElement) | New
 | ActualHeight | (Inherited from FrameworkElement.)
 | ActualWidth | (Inherited from FrameworkElement.)
 | AddHandler(RoutedEvent, Delegate) | (Inherited from UIElement.)
 | AddHandler(RoutedEvent, Delegate, Boolean) | (Inherited from UIElement.)
 | AddLogicalChild(Object) | (Inherited from FrameworkElement.)
 | AddToEventRoute(EventRoute, RoutedEventArgs) | (Inherited from UIElement.)
 | AddVisualChild(Visual) | (Inherited from Visual.)
 | AdornedElement | (Inherited from Adorner.)
 | AllowDrop | (Inherited from UIElement.)
 | ApplyAnimationClock(DependencyProperty, AnimationClock) | (Inherited from UIElement.)
 | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | (Inherited from UIElement.)
 | ApplyTemplate()()()() | (Inherited from FrameworkElement.)
 | AreAnyTouchesCaptured | (Inherited from UIElement.)
 | AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
 | AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
 | AreAnyTouchesOver | (Inherited from UIElement.)
 | Arrange(Rect) | (Inherited from UIElement.)
 | ArrangeCore(Rect) | (Inherited from FrameworkElement.)
 | ArrangeOverride(Size) | (Inherited from FrameworkElement.)
 | BeginAnimation(DependencyProperty, AnimationTimeline) | (Inherited from UIElement.)
 | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | (Inherited from UIElement.)
 | BeginInit()()()() | (Inherited from FrameworkElement.)
 | BeginStoryboard(Storyboard) | (Inherited from FrameworkElement.)
 | BeginStoryboard(Storyboard, HandoffBehavior) | (Inherited from FrameworkElement.)
 | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | (Inherited from FrameworkElement.)
 | BindingGroup | (Inherited from FrameworkElement.)
 | BitmapEffect | Obsolete. (Inherited from UIElement.)
 | BitmapEffectInput | Obsolete. (Inherited from UIElement.)
 | BringIntoView()()()() | (Inherited from FrameworkElement.)
 | BringIntoView(Rect) | (Inherited from FrameworkElement.)
 | CacheMode | (Inherited from UIElement.)
 | CaptureMouse()()()() | (Inherited from UIElement.)
 | CaptureStylus()()()() | (Inherited from UIElement.)
 | CaptureTouch(TouchDevice) | (Inherited from UIElement.)
 | CheckAccess()()()() | (Inherited from DispatcherObject.)
 | ClearValue(DependencyProperty) | (Inherited from DependencyObject.)
 | ClearValue(DependencyPropertyKey) | (Inherited from DependencyObject.)
 | Clip | (Inherited from UIElement.)
 | ClipToBounds | (Inherited from UIElement.)
 | CoerceValue(DependencyProperty) | (Inherited from DependencyObject.)
 | CommandBindings | (Inherited from UIElement.)
 | ContextMenu | (Inherited from FrameworkElement.)
 | ContextMenuClosing | (Inherited from FrameworkElement.)
 | ContextMenuOpening | (Inherited from FrameworkElement.)
 | Cursor | (Inherited from FrameworkElement.)
 | DataContext | (Inherited from FrameworkElement.)
 | DataContextChanged | (Inherited from FrameworkElement.)
 | DefaultStyleKey | (Inherited from FrameworkElement.)
 | DependencyObjectType | (Inherited from DependencyObject.)
 | DesiredSize | (Inherited from UIElement.)
 | Dispatcher | (Inherited from DispatcherObject.)
 | DragEnter | (Inherited from UIElement.)
 | DragLeave | (Inherited from UIElement.)
 | DragOver | (Inherited from UIElement.)
 | Drop | (Inherited from UIElement.)
 | Effect | (Inherited from UIElement.)
 | EndInit()()()() | (Inherited from FrameworkElement.)
 | Equals(Object) | (Inherited from DependencyObject.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FindCommonVisualAncestor(DependencyObject) | (Inherited from Visual.)
 | FindName(String) | (Inherited from FrameworkElement.)
 | FindResource(Object) | (Inherited from FrameworkElement.)
 | FlowDirection | (Inherited from FrameworkElement.)
 | Focus()()()() | (Inherited from UIElement.)
 | Focusable | (Inherited from UIElement.)
 | FocusableChanged | (Inherited from UIElement.)
 | FocusVisualStyle | (Inherited from FrameworkElement.)
 | ForceCursor | (Inherited from FrameworkElement.)
 | GetAnimationBaseValue(DependencyProperty) | (Inherited from UIElement.)
 | GetBindingExpression(DependencyProperty) | (Inherited from FrameworkElement.)
 | GetDesiredTransform(GeneralTransform) | (Inherited from Adorner.)
 | GetHashCode()()()() | (Inherited from DependencyObject.)
 | GetLayoutClip(Size) | (Inherited from Adorner.)
 | GetLocalValueEnumerator()()()() | (Inherited from DependencyObject.)
 | GetTemplateChild(String) | (Inherited from FrameworkElement.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GetUIParentCore()()()() | (Inherited from FrameworkElement.)
 | GetValue(DependencyProperty) | (Inherited from DependencyObject.)
 | GetVisualChild(Int32) | (Inherited from FrameworkElement.)
 | GiveFeedback | (Inherited from UIElement.)
 | GotFocus | (Inherited from UIElement.)
 | GotKeyboardFocus | (Inherited from UIElement.)
 | GotMouseCapture | (Inherited from UIElement.)
 | GotStylusCapture | (Inherited from UIElement.)
 | GotTouchCapture | (Inherited from UIElement.)
 | HasAnimatedProperties | (Inherited from UIElement.)
 | HasEffectiveKeyboardFocus | (Inherited from UIElement.)
 | Height | (Inherited from FrameworkElement.)
 | HighlightFillBrush | Error brush
 | HighlightLinePen | Error pen
 | HitTestCore(PointHitTestParameters) | (Inherited from UIElement.)
 | HitTestCore(GeometryHitTestParameters) | (Inherited from UIElement.)
 | HorizontalAlignment | (Inherited from FrameworkElement.)
 | InheritanceBehavior | (Inherited from FrameworkElement.)
 | Initialized | (Inherited from FrameworkElement.)
 | InputBindings | (Inherited from UIElement.)
 | InputHitTest(Point) | (Inherited from UIElement.)
 | InputScope | (Inherited from FrameworkElement.)
 | InvalidateArrange()()()() | (Inherited from UIElement.)
 | InvalidateMeasure()()()() | (Inherited from UIElement.)
 | InvalidateProperty(DependencyProperty) | (Inherited from DependencyObject.)
 | InvalidateVisual()()()() | (Inherited from UIElement.)
 | IsAncestorOf(DependencyObject) | (Inherited from Visual.)
 | IsArrangeValid | (Inherited from UIElement.)
 | IsClipEnabled | (Inherited from Adorner.)
 | IsDescendantOf(DependencyObject) | (Inherited from Visual.)
 | IsEnabled | (Inherited from UIElement.)
 | IsEnabledChanged | (Inherited from UIElement.)
 | IsEnabledCore | (Inherited from UIElement.)
 | IsFocused | (Inherited from UIElement.)
 | IsHitTestVisible | (Inherited from UIElement.)
 | IsHitTestVisibleChanged | (Inherited from UIElement.)
 | IsInitialized | (Inherited from FrameworkElement.)
 | IsInputMethodEnabled | (Inherited from UIElement.)
 | IsKeyboardFocused | (Inherited from UIElement.)
 | IsKeyboardFocusedChanged | (Inherited from UIElement.)
 | IsKeyboardFocusWithin | (Inherited from UIElement.)
 | IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
 | IsLoaded | (Inherited from FrameworkElement.)
 | IsManipulationEnabled | (Inherited from UIElement.)
 | IsMeasureValid | (Inherited from UIElement.)
 | IsMouseCaptured | (Inherited from UIElement.)
 | IsMouseCapturedChanged | (Inherited from UIElement.)
 | IsMouseCaptureWithin | (Inherited from UIElement.)
 | IsMouseCaptureWithinChanged | (Inherited from UIElement.)
 | IsMouseDirectlyOver | (Inherited from UIElement.)
 | IsMouseDirectlyOverChanged | (Inherited from UIElement.)
 | IsMouseOver | (Inherited from UIElement.)
 | IsSealed | (Inherited from DependencyObject.)
 | IsStylusCaptured | (Inherited from UIElement.)
 | IsStylusCapturedChanged | (Inherited from UIElement.)
 | IsStylusCaptureWithin | (Inherited from UIElement.)
 | IsStylusCaptureWithinChanged | (Inherited from UIElement.)
 | IsStylusDirectlyOver | (Inherited from UIElement.)
 | IsStylusDirectlyOverChanged | (Inherited from UIElement.)
 | IsStylusOver | (Inherited from UIElement.)
 | IsVisible | (Inherited from UIElement.)
 | IsVisibleChanged | (Inherited from UIElement.)
 | KeyDown | (Inherited from UIElement.)
 | KeyUp | (Inherited from UIElement.)
 | Language | (Inherited from FrameworkElement.)
 | LayoutTransform | (Inherited from FrameworkElement.)
 | LayoutUpdated | (Inherited from UIElement.)
 | Loaded | (Inherited from FrameworkElement.)
 | LogicalChildren | (Inherited from FrameworkElement.)
 | LostFocus | (Inherited from UIElement.)
 | LostKeyboardFocus | (Inherited from UIElement.)
 | LostMouseCapture | (Inherited from UIElement.)
 | LostStylusCapture | (Inherited from UIElement.)
 | LostTouchCapture | (Inherited from UIElement.)
 | ManipulationBoundaryFeedback | (Inherited from UIElement.)
 | ManipulationCompleted | (Inherited from UIElement.)
 | ManipulationDelta | (Inherited from UIElement.)
 | ManipulationInertiaStarting | (Inherited from UIElement.)
 | ManipulationStarted | (Inherited from UIElement.)
 | ManipulationStarting | (Inherited from UIElement.)
 | Margin | (Inherited from FrameworkElement.)
 | MaxHeight | (Inherited from FrameworkElement.)
 | MaxWidth | (Inherited from FrameworkElement.)
 | Measure(Size) | (Inherited from UIElement.)
 | MeasureCore(Size) | (Inherited from FrameworkElement.)
 | MeasureOverride(Size) | (Inherited from Adorner.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinHeight | (Inherited from FrameworkElement.)
 | MinWidth | (Inherited from FrameworkElement.)
 | MouseDown | (Inherited from UIElement.)
 | MouseEnter | (Inherited from UIElement.)
 | MouseLeave | (Inherited from UIElement.)
 | MouseLeftButtonDown | (Inherited from UIElement.)
 | MouseLeftButtonUp | (Inherited from UIElement.)
 | MouseMove | (Inherited from UIElement.)
 | MouseRightButtonDown | (Inherited from UIElement.)
 | MouseRightButtonUp | (Inherited from UIElement.)
 | MouseUp | (Inherited from UIElement.)
 | MouseWheel | (Inherited from UIElement.)
 | MoveFocus(TraversalRequest) | (Inherited from FrameworkElement.)
 | Name | (Inherited from FrameworkElement.)
 | OnAccessKey(AccessKeyEventArgs) | (Inherited from UIElement.)
 | OnApplyTemplate()()()() | (Inherited from FrameworkElement.)
 | OnChildDesiredSizeChanged(UIElement) | (Inherited from UIElement.)
 | OnContextMenuClosing(ContextMenuEventArgs) | (Inherited from FrameworkElement.)
 | OnContextMenuOpening(ContextMenuEventArgs) | (Inherited from FrameworkElement.)
 | OnCreateAutomationPeer()()()() | (Inherited from UIElement.)
 | OnDpiChanged(DpiScale, DpiScale) | (Inherited from Visual.)
 | OnDragEnter(DragEventArgs) | (Inherited from UIElement.)
 | OnDragLeave(DragEventArgs) | (Inherited from UIElement.)
 | OnDragOver(DragEventArgs) | (Inherited from UIElement.)
 | OnDrop(DragEventArgs) | (Inherited from UIElement.)
 | OnGiveFeedback(GiveFeedbackEventArgs) | (Inherited from UIElement.)
 | OnGotFocus(RoutedEventArgs) | (Inherited from FrameworkElement.)
 | OnGotKeyboardFocus(KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
 | OnGotMouseCapture(MouseEventArgs) | (Inherited from UIElement.)
 | OnGotStylusCapture(StylusEventArgs) | (Inherited from UIElement.)
 | OnGotTouchCapture(TouchEventArgs) | (Inherited from UIElement.)
 | OnInitialized(EventArgs) | (Inherited from FrameworkElement.)
 | OnIsKeyboardFocusedChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsKeyboardFocusWithinChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsMouseCapturedChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsMouseCaptureWithinChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsMouseDirectlyOverChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsStylusCapturedChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsStylusCaptureWithinChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsStylusDirectlyOverChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnKeyDown(KeyEventArgs) | (Inherited from UIElement.)
 | OnKeyUp(KeyEventArgs) | (Inherited from UIElement.)
 | OnLostFocus(RoutedEventArgs) | (Inherited from UIElement.)
 | OnLostKeyboardFocus(KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
 | OnLostMouseCapture(MouseEventArgs) | (Inherited from UIElement.)
 | OnLostStylusCapture(StylusEventArgs) | (Inherited from UIElement.)
 | OnLostTouchCapture(TouchEventArgs) | (Inherited from UIElement.)
 | OnManipulationBoundaryFeedback(ManipulationBoundaryFeedbackEventArgs) | (Inherited from UIElement.)
 | OnManipulationCompleted(ManipulationCompletedEventArgs) | (Inherited from UIElement.)
 | OnManipulationDelta(ManipulationDeltaEventArgs) | (Inherited from UIElement.)
 | OnManipulationInertiaStarting(ManipulationInertiaStartingEventArgs) | (Inherited from UIElement.)
 | OnManipulationStarted(ManipulationStartedEventArgs) | (Inherited from UIElement.)
 | OnManipulationStarting(ManipulationStartingEventArgs) | (Inherited from UIElement.)
 | OnMouseDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseEnter(MouseEventArgs) | (Inherited from UIElement.)
 | OnMouseLeave(MouseEventArgs) | (Inherited from UIElement.)
 | OnMouseLeftButtonDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseLeftButtonUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseMove(MouseEventArgs) | (Inherited from UIElement.)
 | OnMouseRightButtonDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseRightButtonUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseWheel(MouseWheelEventArgs) | (Inherited from UIElement.)
 | OnPreviewDragEnter(DragEventArgs) | (Inherited from UIElement.)
 | OnPreviewDragLeave(DragEventArgs) | (Inherited from UIElement.)
 | OnPreviewDragOver(DragEventArgs) | (Inherited from UIElement.)
 | OnPreviewDrop(DragEventArgs) | (Inherited from UIElement.)
 | OnPreviewGiveFeedback(GiveFeedbackEventArgs) | (Inherited from UIElement.)
 | OnPreviewGotKeyboardFocus(KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
 | OnPreviewKeyDown(KeyEventArgs) | (Inherited from UIElement.)
 | OnPreviewKeyUp(KeyEventArgs) | (Inherited from UIElement.)
 | OnPreviewLostKeyboardFocus(KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseLeftButtonDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseLeftButtonUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseMove(MouseEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseRightButtonDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseRightButtonUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseWheel(MouseWheelEventArgs) | (Inherited from UIElement.)
 | OnPreviewQueryContinueDrag(QueryContinueDragEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusButtonDown(StylusButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusButtonUp(StylusButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusDown(StylusDownEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusInAirMove(StylusEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusInRange(StylusEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusMove(StylusEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusOutOfRange(StylusEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusSystemGesture(StylusSystemGestureEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusUp(StylusEventArgs) | (Inherited from UIElement.)
 | OnPreviewTextInput(TextCompositionEventArgs) | (Inherited from UIElement.)
 | OnPreviewTouchDown(TouchEventArgs) | (Inherited from UIElement.)
 | OnPreviewTouchMove(TouchEventArgs) | (Inherited from UIElement.)
 | OnPreviewTouchUp(TouchEventArgs) | (Inherited from UIElement.)
 | OnPropertyChanged(DependencyPropertyChangedEventArgs) | (Inherited from FrameworkElement.)
 | OnQueryContinueDrag(QueryContinueDragEventArgs) | (Inherited from UIElement.)
 | OnQueryCursor(QueryCursorEventArgs) | (Inherited from UIElement.)
 | OnRender(DrawingContext) | Renders the highlight (Overrides UIElement.OnRender(DrawingContext).)
 | OnRenderSizeChanged(SizeChangedInfo) | (Inherited from FrameworkElement.)
 | OnStyleChanged(Style, Style) | (Inherited from FrameworkElement.)
 | OnStylusButtonDown(StylusButtonEventArgs) | (Inherited from UIElement.)
 | OnStylusButtonUp(StylusButtonEventArgs) | (Inherited from UIElement.)
 | OnStylusDown(StylusDownEventArgs) | (Inherited from UIElement.)
 | OnStylusEnter(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusInAirMove(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusInRange(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusLeave(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusMove(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusOutOfRange(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusSystemGesture(StylusSystemGestureEventArgs) | (Inherited from UIElement.)
 | OnStylusUp(StylusEventArgs) | (Inherited from UIElement.)
 | OnTextInput(TextCompositionEventArgs) | (Inherited from UIElement.)
 | OnToolTipClosing(ToolTipEventArgs) | (Inherited from FrameworkElement.)
 | OnToolTipOpening(ToolTipEventArgs) | (Inherited from FrameworkElement.)
 | OnTouchDown(TouchEventArgs) | (Inherited from UIElement.)
 | OnTouchEnter(TouchEventArgs) | (Inherited from UIElement.)
 | OnTouchLeave(TouchEventArgs) | (Inherited from UIElement.)
 | OnTouchMove(TouchEventArgs) | (Inherited from UIElement.)
 | OnTouchUp(TouchEventArgs) | (Inherited from UIElement.)
 | OnVisualChildrenChanged(DependencyObject, DependencyObject) | (Inherited from Visual.)
 | OnVisualParentChanged(DependencyObject) | (Inherited from FrameworkElement.)
 | Opacity | (Inherited from UIElement.)
 | OpacityMask | (Inherited from UIElement.)
 | OverridesDefaultStyle | (Inherited from FrameworkElement.)
 | Parent | (Inherited from FrameworkElement.)
 | ParentLayoutInvalidated(UIElement) | (Inherited from FrameworkElement.)
 | PersistId | Obsolete. (Inherited from UIElement.)
 | PointFromScreen(Point) | (Inherited from Visual.)
 | PointToScreen(Point) | (Inherited from Visual.)
 | PredictFocus(FocusNavigationDirection) | (Inherited from FrameworkElement.)
 | PreviewDragEnter | (Inherited from UIElement.)
 | PreviewDragLeave | (Inherited from UIElement.)
 | PreviewDragOver | (Inherited from UIElement.)
 | PreviewDrop | (Inherited from UIElement.)
 | PreviewGiveFeedback | (Inherited from UIElement.)
 | PreviewGotKeyboardFocus | (Inherited from UIElement.)
 | PreviewKeyDown | (Inherited from UIElement.)
 | PreviewKeyUp | (Inherited from UIElement.)
 | PreviewLostKeyboardFocus | (Inherited from UIElement.)
 | PreviewMouseDown | (Inherited from UIElement.)
 | PreviewMouseLeftButtonDown | (Inherited from UIElement.)
 | PreviewMouseLeftButtonUp | (Inherited from UIElement.)
 | PreviewMouseMove | (Inherited from UIElement.)
 | PreviewMouseRightButtonDown | (Inherited from UIElement.)
 | PreviewMouseRightButtonUp | (Inherited from UIElement.)
 | PreviewMouseUp | (Inherited from UIElement.)
 | PreviewMouseWheel | (Inherited from UIElement.)
 | PreviewQueryContinueDrag | (Inherited from UIElement.)
 | PreviewStylusButtonDown | (Inherited from UIElement.)
 | PreviewStylusButtonUp | (Inherited from UIElement.)
 | PreviewStylusDown | (Inherited from UIElement.)
 | PreviewStylusInAirMove | (Inherited from UIElement.)
 | PreviewStylusInRange | (Inherited from UIElement.)
 | PreviewStylusMove | (Inherited from UIElement.)
 | PreviewStylusOutOfRange | (Inherited from UIElement.)
 | PreviewStylusSystemGesture | (Inherited from UIElement.)
 | PreviewStylusUp | (Inherited from UIElement.)
 | PreviewTextInput | (Inherited from UIElement.)
 | PreviewTouchDown | (Inherited from UIElement.)
 | PreviewTouchMove | (Inherited from UIElement.)
 | PreviewTouchUp | (Inherited from UIElement.)
 | QueryContinueDrag | (Inherited from UIElement.)
 | QueryCursor | (Inherited from UIElement.)
 | RaiseEvent(RoutedEventArgs) | (Inherited from UIElement.)
 | ReadLocalValue(DependencyProperty) | (Inherited from DependencyObject.)
 | RegisterName(String, Object) | (Inherited from FrameworkElement.)
 | ReleaseAllTouchCaptures()()()() | (Inherited from UIElement.)
 | ReleaseMouseCapture()()()() | (Inherited from UIElement.)
 | ReleaseStylusCapture()()()() | (Inherited from UIElement.)
 | ReleaseTouchCapture(TouchDevice) | (Inherited from UIElement.)
 | RemoveHandler(RoutedEvent, Delegate) | (Inherited from UIElement.)
 | RemoveLogicalChild(Object) | (Inherited from FrameworkElement.)
 | RemoveVisualChild(Visual) | (Inherited from Visual.)
 | RenderSize | (Inherited from UIElement.)
 | RenderTransform | (Inherited from UIElement.)
 | RenderTransformOrigin | (Inherited from UIElement.)
 | RequestBringIntoView | (Inherited from FrameworkElement.)
 | Resources | (Inherited from FrameworkElement.)
 | SetBinding(DependencyProperty, BindingBase) | (Inherited from FrameworkElement.)
 | SetBinding(DependencyProperty, String) | (Inherited from FrameworkElement.)
 | SetCurrentValue(DependencyProperty, Object) | (Inherited from DependencyObject.)
 | SetResourceReference(DependencyProperty, Object) | (Inherited from FrameworkElement.)
 | SetValue(DependencyProperty, Object) | (Inherited from DependencyObject.)
 | SetValue(DependencyPropertyKey, Object) | (Inherited from DependencyObject.)
 | ShouldSerializeCommandBindings()()()() | (Inherited from UIElement.)
 | ShouldSerializeInputBindings()()()() | (Inherited from UIElement.)
 | ShouldSerializeProperty(DependencyProperty) | (Inherited from DependencyObject.)
 | ShouldSerializeResources()()()() | (Inherited from FrameworkElement.)
 | ShouldSerializeStyle()()()() | (Inherited from FrameworkElement.)
 | ShouldSerializeTriggers()()()() | (Inherited from FrameworkElement.)
 | SizeChanged | (Inherited from FrameworkElement.)
 | SnapsToDevicePixels | (Inherited from UIElement.)
 | SourceUpdated | (Inherited from FrameworkElement.)
 | Style | (Inherited from FrameworkElement.)
 | StylusButtonDown | (Inherited from UIElement.)
 | StylusButtonUp | (Inherited from UIElement.)
 | StylusDown | (Inherited from UIElement.)
 | StylusEnter | (Inherited from UIElement.)
 | StylusInAirMove | (Inherited from UIElement.)
 | StylusInRange | (Inherited from UIElement.)
 | StylusLeave | (Inherited from UIElement.)
 | StylusMove | (Inherited from UIElement.)
 | StylusOutOfRange | (Inherited from UIElement.)
 | StylusPlugIns | (Inherited from UIElement.)
 | StylusSystemGesture | (Inherited from UIElement.)
 | StylusUp | (Inherited from UIElement.)
 | Tag | (Inherited from FrameworkElement.)
 | TargetUpdated | (Inherited from FrameworkElement.)
 | TemplatedParent | (Inherited from FrameworkElement.)
 | TextInput | (Inherited from UIElement.)
 | ToolTip | (Inherited from FrameworkElement.)
 | ToolTipClosing | (Inherited from FrameworkElement.)
 | ToolTipOpening | (Inherited from FrameworkElement.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | TouchDown | (Inherited from UIElement.)
 | TouchEnter | (Inherited from UIElement.)
 | TouchesCaptured | (Inherited from UIElement.)
 | TouchesCapturedWithin | (Inherited from UIElement.)
 | TouchesDirectlyOver | (Inherited from UIElement.)
 | TouchesOver | (Inherited from UIElement.)
 | TouchLeave | (Inherited from UIElement.)
 | TouchMove | (Inherited from UIElement.)
 | TouchUp | (Inherited from UIElement.)
 | TransformToAncestor(Visual) | (Inherited from Visual.)
 | TransformToAncestor(Visual3D) | (Inherited from Visual.)
 | TransformToDescendant(Visual) | (Inherited from Visual.)
 | TransformToVisual(Visual) | (Inherited from Visual.)
 | TranslatePoint(Point, UIElement) | (Inherited from UIElement.)
 | Triggers | (Inherited from FrameworkElement.)
 | TryFindResource(Object) | (Inherited from FrameworkElement.)
 | Uid | (Inherited from UIElement.)
 | Unloaded | (Inherited from FrameworkElement.)
 | Unregister()()()() | Removes event handlers
 | UnregisterName(String) | (Inherited from FrameworkElement.)
 | UpdateDefaultStyle()()()() | (Inherited from FrameworkElement.)
 | UpdateLayout()()()() | (Inherited from UIElement.)
 | UseLayoutRounding | (Inherited from FrameworkElement.)
 | VerifyAccess()()()() | (Inherited from DispatcherObject.)
 | VerticalAlignment | (Inherited from FrameworkElement.)
 | Visibility | (Inherited from UIElement.)
 | VisualBitmapEffect | Obsolete. (Inherited from Visual.)
 | VisualBitmapEffectInput | Obsolete. (Inherited from Visual.)
 | VisualBitmapScalingMode | (Inherited from Visual.)
 | VisualCacheMode | (Inherited from Visual.)
 | VisualChildrenCount | (Inherited from FrameworkElement.)
 | VisualClearTypeHint | (Inherited from Visual.)
 | VisualClip | (Inherited from Visual.)
 | VisualEdgeMode | (Inherited from Visual.)
 | VisualEffect | (Inherited from Visual.)
 | VisualOffset | (Inherited from Visual.)
 | VisualOpacity | (Inherited from Visual.)
 | VisualOpacityMask | (Inherited from Visual.)
 | VisualParent | (Inherited from Visual.)
 | VisualScrollableAreaClip | (Inherited from Visual.)
 | VisualTextHintingMode | (Inherited from Visual.)
 | VisualTextRenderingMode | (Inherited from Visual.)
 | VisualTransform | (Inherited from Visual.)
 | VisualXSnappingGuidelines | (Inherited from Visual.)
 | VisualYSnappingGuidelines | (Inherited from Visual.)
 | Width | (Inherited from FrameworkElement.)
Inheritance Hierarchy
Object
 | DispatcherObject
 |  | DependencyObject
 |  |  | Visual
 |  |  |  | UIElement
 |  |  |  |  | FrameworkElement
 |  |  |  |  |  | Adorner
 |  |  |  |  |  |  | SelectionAdorner


SelectionAdorner Constructor (adornedElement)

SelectionAdorner Constructor (adornedElement)
API ► Keyoti.RapidSpell.Wpf ► SelectionAdorner ► SelectionAdorner(UIElement)
Keyoti RapidSpell WPF
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public SelectionAdorner(
    UIElement adornedElement
)
public SelectionAdorner(
    UIElement adornedElement
)
Public Sub New (
    adornedElement As UIElement
)
Public Sub New (
    adornedElement As UIElement
)
public:
SelectionAdorner(
    UIElement^ adornedElement
)
public:
SelectionAdorner(
    UIElement^ adornedElement
)
new :
        adornedElement : UIElement -> SelectionAdorner
new :
        adornedElement : UIElement -> SelectionAdorner
Parameters
adornedElement (UIElement)


HighlightFillBrush Property

HighlightFillBrush Property
API ► Keyoti.RapidSpell.Wpf ► SelectionAdorner ► HighlightFillBrush
Keyoti RapidSpell WPF
Error brush
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Brush HighlightFillBrush { get; set; }
public Brush HighlightFillBrush { get; set; }
Public Property HighlightFillBrush As Brush
    Get
    Set
Public Property HighlightFillBrush As Brush
    Get
    Set
public:
property Brush^ HighlightFillBrush {
    Brush^ get ();
    void set (Brush^ value);
}
public:
property Brush^ HighlightFillBrush {
    Brush^ get ();
    void set (Brush^ value);
}
member HighlightFillBrush : Brush with get, set

member HighlightFillBrush : Brush with get, set
Property Value
Brush


HighlightLinePen Property

HighlightLinePen Property
API ► Keyoti.RapidSpell.Wpf ► SelectionAdorner ► HighlightLinePen
Keyoti RapidSpell WPF
Error pen
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Pen HighlightLinePen { get; set; }
public Pen HighlightLinePen { get; set; }
Public Property HighlightLinePen As Pen
    Get
    Set
Public Property HighlightLinePen As Pen
    Get
    Set
public:
property Pen^ HighlightLinePen {
    Pen^ get ();
    void set (Pen^ value);
}
public:
property Pen^ HighlightLinePen {
    Pen^ get ();
    void set (Pen^ value);
}
member HighlightLinePen : Pen with get, set

member HighlightLinePen : Pen with get, set
Property Value
Pen


OnRender Method (drawingContext)

OnRender Method (drawingContext)
API ► Keyoti.RapidSpell.Wpf ► SelectionAdorner ► OnRender(DrawingContext)
Keyoti RapidSpell WPF
Renders the highlight
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override void OnRender(
    DrawingContext drawingContext
)
protected override void OnRender(
    DrawingContext drawingContext
)
Protected Overrides Sub OnRender (
    drawingContext As DrawingContext
)
Protected Overrides Sub OnRender (
    drawingContext As DrawingContext
)
protected:
virtual void OnRender(
    DrawingContext^ drawingContext
) override
protected:
virtual void OnRender(
    DrawingContext^ drawingContext
) override
abstract OnRender :
        drawingContext : DrawingContext -> unit
override OnRender :
        drawingContext : DrawingContext -> unit
abstract OnRender :
        drawingContext : DrawingContext -> unit
override OnRender :
        drawingContext : DrawingContext -> unit
Parameters
drawingContext (DrawingContext)


Unregister Method

Unregister Method
API ► Keyoti.RapidSpell.Wpf ► SelectionAdorner ► Unregister()()()()
Keyoti RapidSpell WPF
Removes event handlers
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void Unregister()
public void Unregister()
Public Sub Unregister
Public Sub Unregister
public:
void Unregister()
public:
void Unregister()
member Unregister : unit -> unit

member Unregister : unit -> unit


SpellContextMenuRequestEventHandler Delegate

SpellContextMenuRequestEventHandler Delegate
API ► Keyoti.RapidSpell.Wpf ► SpellContextMenuRequestEventHandler
Keyoti RapidSpell WPF
Handler delegate
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void SpellContextMenuRequestEventHandler(
    Object sender,
    SpellContextMenuEventArgs e
)
public delegate void SpellContextMenuRequestEventHandler(
    Object sender,
    SpellContextMenuEventArgs e
)
Public Delegate Sub SpellContextMenuRequestEventHandler (
    sender As Object,
    e As SpellContextMenuEventArgs
)
Public Delegate Sub SpellContextMenuRequestEventHandler (
    sender As Object,
    e As SpellContextMenuEventArgs
)
public delegate void SpellContextMenuRequestEventHandler(
    Object^ sender,
    SpellContextMenuEventArgs^ e
)
public delegate void SpellContextMenuRequestEventHandler(
    Object^ sender,
    SpellContextMenuEventArgs^ e
)
type SpellContextMenuRequestEventHandler =
    delegate of
        sender : Object *
        e : SpellContextMenuEventArgs -> unit
type SpellContextMenuRequestEventHandler =
    delegate of
        sender : Object *
        e : SpellContextMenuEventArgs -> unit
Parameters
sender (Object)
e (SpellContextMenuEventArgs)


SpellingDictionary Class

SpellingDictionary Class
API ► Keyoti.RapidSpell.Wpf ► SpellingDictionary
Keyoti RapidSpell WPF
Helper
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class SpellingDictionary
public class SpellingDictionary
Public Class SpellingDictionary
Public Class SpellingDictionary
public ref class SpellingDictionary
public ref class SpellingDictionary
type SpellingDictionary =  class end
type SpellingDictionary =  class end
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | LastModified | Helper
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Path | Helper
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
SpellingDictionary


LastModified Property

LastModified Property
API ► Keyoti.RapidSpell.Wpf ► SpellingDictionary ► LastModified
Keyoti RapidSpell WPF
Helper
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public DateTime LastModified { get; }
public DateTime LastModified { get; }
Public ReadOnly Property LastModified As DateTime
    Get
Public ReadOnly Property LastModified As DateTime
    Get
public:
property DateTime LastModified {
    DateTime get ();
}
public:
property DateTime LastModified {
    DateTime get ();
}
member LastModified : DateTime with get

member LastModified : DateTime with get
Property Value
DateTime


Path Property

Path Property
API ► Keyoti.RapidSpell.Wpf ► SpellingDictionary ► Path
Keyoti RapidSpell WPF
Helper
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string Path { get; }
public string Path { get; }
Public ReadOnly Property Path As String
    Get
Public ReadOnly Property Path As String
    Get
public:
property String^ Path {
    String^ get ();
}
public:
property String^ Path {
    String^ get ();
}
member Path : string with get

member Path : string with get
Property Value
String


StartupRegisterForm Class

StartupRegisterForm Class
API ► Keyoti.RapidSpell.Wpf ► StartupRegisterForm
Keyoti RapidSpell WPF
Helper to launch the license key registration form
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class StartupRegisterForm : Application
public class StartupRegisterForm : Application
Public Class StartupRegisterForm
    Inherits Application
Public Class StartupRegisterForm
    Inherits Application
public ref class StartupRegisterForm : public Application
public ref class StartupRegisterForm : public Application
type StartupRegisterForm =
    class
        inherit Application
    end
type StartupRegisterForm =
    class
        inherit Application
    end
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StartupRegisterForm()()()() |
 | Activated | (Inherited from Application.)
 | CheckAccess()()()() | (Inherited from DispatcherObject.)
 | Deactivated | (Inherited from Application.)
 | Dispatcher | (Inherited from DispatcherObject.)
 | DispatcherUnhandledException | (Inherited from Application.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exit | (Inherited from Application.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FindResource(Object) | (Inherited from Application.)
 | FragmentNavigation | (Inherited from Application.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | LoadCompleted | (Inherited from Application.)
 | Main(array<String>[]()[][]) | Starter
 | MainWindow | (Inherited from Application.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Navigated | (Inherited from Application.)
 | Navigating | (Inherited from Application.)
 | NavigationFailed | (Inherited from Application.)
 | NavigationProgress | (Inherited from Application.)
 | NavigationStopped | (Inherited from Application.)
 | OnActivated(EventArgs) | (Inherited from Application.)
 | OnDeactivated(EventArgs) | (Inherited from Application.)
 | OnExit(ExitEventArgs) | (Inherited from Application.)
 | OnFragmentNavigation(FragmentNavigationEventArgs) | (Inherited from Application.)
 | OnLoadCompleted(NavigationEventArgs) | (Inherited from Application.)
 | OnNavigated(NavigationEventArgs) | (Inherited from Application.)
 | OnNavigating(NavigatingCancelEventArgs) | (Inherited from Application.)
 | OnNavigationFailed(NavigationFailedEventArgs) | (Inherited from Application.)
 | OnNavigationProgress(NavigationProgressEventArgs) | (Inherited from Application.)
 | OnNavigationStopped(NavigationEventArgs) | (Inherited from Application.)
 | OnSessionEnding(SessionEndingCancelEventArgs) | (Inherited from Application.)
 | OnStartup(StartupEventArgs) | (Inherited from Application.)
 | Properties | (Inherited from Application.)
 | Resources | (Inherited from Application.)
 | Run()()()() | (Inherited from Application.)
 | Run(Window) | (Inherited from Application.)
 | SessionEnding | (Inherited from Application.)
 | Shutdown()()()() | (Inherited from Application.)
 | Shutdown(Int32) | (Inherited from Application.)
 | ShutdownMode | (Inherited from Application.)
 | Startup | (Inherited from Application.)
 | StartupUri | (Inherited from Application.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | TryFindResource(Object) | (Inherited from Application.)
 | VerifyAccess()()()() | (Inherited from DispatcherObject.)
 | Windows | (Inherited from Application.)
Inheritance Hierarchy
Object
 | DispatcherObject
 |  | Application
 |  |  | StartupRegisterForm


StartupRegisterForm Constructor

StartupRegisterForm Constructor
API ► Keyoti.RapidSpell.Wpf ► StartupRegisterForm ► StartupRegisterForm()()()()
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public StartupRegisterForm()
public StartupRegisterForm()
Public Sub New
Public Sub New
public:
StartupRegisterForm()
public:
StartupRegisterForm()
new : unit -> StartupRegisterForm
new : unit -> StartupRegisterForm


Main Method (args)

Main Method (args)
API ► Keyoti.RapidSpell.Wpf ► StartupRegisterForm ► Main(array<String>[]()[][])
Keyoti RapidSpell WPF
Starter
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static void Main(
    string[] args
)
public static void Main(
    string[] args
)
Public Shared Sub Main (
    args As String()
)
Public Shared Sub Main (
    args As String()
)
public:
static void Main(
    array<String^>^ args
)
public:
static void Main(
    array<String^>^ args
)
static member Main :
        args : string[] -> unit

static member Main :
        args : string[] -> unit
Parameters
args (array<String>[]()[][])


Suggestion Class

Suggestion Class
API ► Keyoti.RapidSpell.Wpf ► Suggestion
Keyoti RapidSpell WPF
Represents a suggestion.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class Suggestion
public class Suggestion
Public Class Suggestion
Public Class Suggestion
public ref class Suggestion
public ref class Suggestion
type Suggestion =  class end
type Suggestion =  class end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Suggestion(String, Int32) | Creates an instance
 | Contains(ArrayList, Suggestion) | Returns true if suggestion is in list.
 | Contains(ArrayList, String) | Returns true if suggestion is in list.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Score | The score 0-1000 of how suitable suggestion is. -1 if unknown
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Word | The suggested word.
Inheritance Hierarchy
Object
Suggestion


Suggestion Constructor (word, score)

Suggestion Constructor (word, score)
API ► Keyoti.RapidSpell.Wpf ► Suggestion ► Suggestion(String, Int32)
Keyoti RapidSpell WPF
Creates an instance
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Suggestion(
    string word,
    int score
)
public Suggestion(
    string word,
    int score
)
Public Sub New (
    word As String,
    score As Integer
)
Public Sub New (
    word As String,
    score As Integer
)
public:
Suggestion(
    String^ word,
    int score
)
public:
Suggestion(
    String^ word,
    int score
)
new :
        word : string *
        score : int -> Suggestion
new :
        word : string *
        score : int -> Suggestion
Parameters
word (String)
The suggested word
score (Int32)
The score 0-1000 of how suitable suggestion is.


Contains Method

Contains Method
API ► Keyoti.RapidSpell.Wpf ► Suggestion ► Contains()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | Contains(ArrayList, Suggestion) | Returns true if suggestion is in list.
 | Contains(ArrayList, String) | Returns true if suggestion is in list.


Contains Method (list, suggestion)

Contains Method (list, suggestion)
API ► Keyoti.RapidSpell.Wpf ► Suggestion ► Contains(ArrayList, Suggestion)
Keyoti RapidSpell WPF
Returns true if suggestion is in list.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static bool Contains(
    ArrayList list,
    Suggestion suggestion
)
public static bool Contains(
    ArrayList list,
    Suggestion suggestion
)
Public Shared Function Contains (
    list As ArrayList,
    suggestion As Suggestion
) As Boolean
Public Shared Function Contains (
    list As ArrayList,
    suggestion As Suggestion
) As Boolean
public:
static bool Contains(
    ArrayList^ list,
    Suggestion^ suggestion
)
public:
static bool Contains(
    ArrayList^ list,
    Suggestion^ suggestion
)
static member Contains :
        list : ArrayList *
        suggestion : Suggestion -> bool

static member Contains :
        list : ArrayList *
        suggestion : Suggestion -> bool
Parameters
list (ArrayList)
suggestion (Suggestion)
Return Value
Boolean


Contains Method (list, suggestion)

Contains Method (list, suggestion)
API ► Keyoti.RapidSpell.Wpf ► Suggestion ► Contains(ArrayList, String)
Keyoti RapidSpell WPF
Returns true if suggestion is in list.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static bool Contains(
    ArrayList list,
    string suggestion
)
public static bool Contains(
    ArrayList list,
    string suggestion
)
Public Shared Function Contains (
    list As ArrayList,
    suggestion As String
) As Boolean
Public Shared Function Contains (
    list As ArrayList,
    suggestion As String
) As Boolean
public:
static bool Contains(
    ArrayList^ list,
    String^ suggestion
)
public:
static bool Contains(
    ArrayList^ list,
    String^ suggestion
)
static member Contains :
        list : ArrayList *
        suggestion : string -> bool

static member Contains :
        list : ArrayList *
        suggestion : string -> bool
Parameters
list (ArrayList)
suggestion (String)
Return Value
Boolean


Score Property

Score Property
API ► Keyoti.RapidSpell.Wpf ► Suggestion ► Score
Keyoti RapidSpell WPF
The score 0-1000 of how suitable suggestion is. -1 if unknown
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual int Score { get; set; }
public virtual int Score { get; set; }
Public Overridable Property Score As Integer
    Get
    Set
Public Overridable Property Score As Integer
    Get
    Set
public:
virtual property int Score {
    int get ();
    void set (int value);
}
public:
virtual property int Score {
    int get ();
    void set (int value);
}
abstract Score : int with get, set
override Score : int with get, set
abstract Score : int with get, set
override Score : int with get, set
Property Value
Int32


Word Property

Word Property
API ► Keyoti.RapidSpell.Wpf ► Suggestion ► Word
Keyoti RapidSpell WPF
The suggested word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual string Word { get; set; }
public virtual string Word { get; set; }
Public Overridable Property Word As String
    Get
    Set
Public Overridable Property Word As String
    Get
    Set
public:
virtual property String^ Word {
    String^ get ();
    void set (String^ value);
}
public:
virtual property String^ Word {
    String^ get ();
    void set (String^ value);
}
abstract Word : string with get, set
override Word : string with get, set
abstract Word : string with get, set
override Word : string with get, set
Property Value
String


SuggestionsMethodType Enumeration

SuggestionsMethodType Enumeration
API ► Keyoti.RapidSpell.Wpf ► SuggestionsMethodType
Keyoti RapidSpell WPF
Suggestions algorithm identifiers.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public enum SuggestionsMethodType
public enum SuggestionsMethodType
Public Enumeration SuggestionsMethodType
Public Enumeration SuggestionsMethodType
public enum class SuggestionsMethodType
public enum class SuggestionsMethodType
type SuggestionsMethodType
type SuggestionsMethodType
Members
Member | Description
PhoneticSuggestions | Phonetic (sounds like) algorithm
HashingSuggestions | Hashing (closest match) algorithm


TextChangeHint Class

TextChangeHint Class
API ► Keyoti.RapidSpell.Wpf ► TextChangeHint
Keyoti RapidSpell WPF
Hints the change scanner as to where the change could be, if any, on user input.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class TextChangeHint
public class TextChangeHint
Public Class TextChangeHint
Public Class TextChangeHint
public ref class TextChangeHint
public ref class TextChangeHint
type TextChangeHint =  class end
type TextChangeHint =  class end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TextChangeHint()()()() |
 | ActionLocation | Where the cursor was, in the text, before the action occured.
 | ActionUnlikelyToMeanChangeMade | True when a key such as cursor, page-up etc is pressed, which more than likely means the text hasn't changed.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
TextChangeHint


TextChangeHint Constructor

TextChangeHint Constructor
API ► Keyoti.RapidSpell.Wpf ► TextChangeHint ► TextChangeHint()()()()
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public TextChangeHint()
public TextChangeHint()
Public Sub New
Public Sub New
public:
TextChangeHint()
public:
TextChangeHint()
new : unit -> TextChangeHint
new : unit -> TextChangeHint


ActionLocation Property

ActionLocation Property
API ► Keyoti.RapidSpell.Wpf ► TextChangeHint ► ActionLocation
Keyoti RapidSpell WPF
Where the cursor was, in the text, before the action occured.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int ActionLocation { get; set; }
public int ActionLocation { get; set; }
Public Property ActionLocation As Integer
    Get
    Set
Public Property ActionLocation As Integer
    Get
    Set
public:
property int ActionLocation {
    int get ();
    void set (int value);
}
public:
property int ActionLocation {
    int get ();
    void set (int value);
}
member ActionLocation : int with get, set

member ActionLocation : int with get, set
Property Value
Int32


ActionUnlikelyToMeanChangeMade Property

ActionUnlikelyToMeanChangeMade Property
API ► Keyoti.RapidSpell.Wpf ► TextChangeHint ► ActionUnlikelyToMeanChangeMade
Keyoti RapidSpell WPF
True when a key such as cursor, page-up etc is pressed, which more than likely means the text hasn't changed.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ActionUnlikelyToMeanChangeMade { get; set; }
public bool ActionUnlikelyToMeanChangeMade { get; set; }
Public Property ActionUnlikelyToMeanChangeMade As Boolean
    Get
    Set
Public Property ActionUnlikelyToMeanChangeMade As Boolean
    Get
    Set
public:
property bool ActionUnlikelyToMeanChangeMade {
    bool get ();
    void set (bool value);
}
public:
property bool ActionUnlikelyToMeanChangeMade {
    bool get ();
    void set (bool value);
}
member ActionUnlikelyToMeanChangeMade : bool with get, set

member ActionUnlikelyToMeanChangeMade : bool with get, set
Property Value
Boolean


Underline Class

Underline Class
API ► Keyoti.RapidSpell.Wpf ► Underline
Keyoti RapidSpell WPF
Represents an underline
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class Underline
public class Underline
Public Class Underline
Public Class Underline
public ref class Underline
public ref class Underline
type Underline =  class end
type Underline =  class end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Underline(Int32, Int32, UnderlineStyle, Color, BadWord, ErrorAdornerBase) | New instance
 | Color | Color
 | End | End
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | Hidden | Whether the underline is hidden
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OriginalBadWord | The original bad word, note that it's offsets are not relative to the start of the text.
 | Start | Start
 | Style | Style
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
Underline


Underline Constructor (start, end, u, c, originalBadWord, adorner)

Underline Constructor (start, end, u, c, originalBadWord, adorner)
API ► Keyoti.RapidSpell.Wpf ► Underline ► Underline(Int32, Int32, UnderlineStyle, Color, BadWord, ErrorAdornerBase)
Keyoti RapidSpell WPF
New instance
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Underline(
    int start,
    int end,
    UnderlineStyle u,
    Color c,
    BadWord originalBadWord,
    ErrorAdornerBase adorner
)
public Underline(
    int start,
    int end,
    UnderlineStyle u,
    Color c,
    BadWord originalBadWord,
    ErrorAdornerBase adorner
)
Public Sub New (
    start As Integer,
    end As Integer,
    u As UnderlineStyle,
    c As Color,
    originalBadWord As BadWord,
    adorner As ErrorAdornerBase
)
Public Sub New (
    start As Integer,
    end As Integer,
    u As UnderlineStyle,
    c As Color,
    originalBadWord As BadWord,
    adorner As ErrorAdornerBase
)
public:
Underline(
    int start,
    int end,
    UnderlineStyle u,
    Color c,
    BadWord^ originalBadWord,
    ErrorAdornerBase^ adorner
)
public:
Underline(
    int start,
    int end,
    UnderlineStyle u,
    Color c,
    BadWord^ originalBadWord,
    ErrorAdornerBase^ adorner
)
new :
        start : int *
        end : int *
        u : UnderlineStyle *
        c : Color *
        originalBadWord : BadWord *
        adorner : ErrorAdornerBase -> Underline
new :
        start : int *
        end : int *
        u : UnderlineStyle *
        c : Color *
        originalBadWord : BadWord *
        adorner : ErrorAdornerBase -> Underline
Parameters
start (Int32)
end (Int32)
u (UnderlineStyle)
c (Color)
originalBadWord (BadWord)
adorner (ErrorAdornerBase)


Color Property

Color Property
API ► Keyoti.RapidSpell.Wpf ► Underline ► Color
Keyoti RapidSpell WPF
Color
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Color Color { get; set; }
public Color Color { get; set; }
Public Property Color As Color
    Get
    Set
Public Property Color As Color
    Get
    Set
public:
property Color Color {
    Color get ();
    void set (Color value);
}
public:
property Color Color {
    Color get ();
    void set (Color value);
}
member Color : Color with get, set

member Color : Color with get, set
Property Value
Color


End Property

End Property
API ► Keyoti.RapidSpell.Wpf ► Underline ► End
Keyoti RapidSpell WPF
End
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int End { get; set; }
public int End { get; set; }
Public Property End As Integer
    Get
    Set
Public Property End As Integer
    Get
    Set
public:
property int End {
    int get ();
    void set (int value);
}
public:
property int End {
    int get ();
    void set (int value);
}
member End : int with get, set

member End : int with get, set
Property Value
Int32


Hidden Property

Hidden Property
API ► Keyoti.RapidSpell.Wpf ► Underline ► Hidden
Keyoti RapidSpell WPF
Whether the underline is hidden
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool Hidden { get; set; }
public bool Hidden { get; set; }
Public Property Hidden As Boolean
    Get
    Set
Public Property Hidden As Boolean
    Get
    Set
public:
property bool Hidden {
    bool get ();
    void set (bool value);
}
public:
property bool Hidden {
    bool get ();
    void set (bool value);
}
member Hidden : bool with get, set

member Hidden : bool with get, set
Property Value
Boolean


OriginalBadWord Property

OriginalBadWord Property
API ► Keyoti.RapidSpell.Wpf ► Underline ► OriginalBadWord
Keyoti RapidSpell WPF
The original bad word, note that it's offsets are not relative to the start of the text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public BadWord OriginalBadWord { get; set; }
public BadWord OriginalBadWord { get; set; }
Public Property OriginalBadWord As BadWord
    Get
    Set
Public Property OriginalBadWord As BadWord
    Get
    Set
public:
property BadWord^ OriginalBadWord {
    BadWord^ get ();
    void set (BadWord^ value);
}
public:
property BadWord^ OriginalBadWord {
    BadWord^ get ();
    void set (BadWord^ value);
}
member OriginalBadWord : BadWord with get, set

member OriginalBadWord : BadWord with get, set
Property Value
BadWord


Start Property

Start Property
API ► Keyoti.RapidSpell.Wpf ► Underline ► Start
Keyoti RapidSpell WPF
Start
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int Start { get; set; }
public int Start { get; set; }
Public Property Start As Integer
    Get
    Set
Public Property Start As Integer
    Get
    Set
public:
property int Start {
    int get ();
    void set (int value);
}
public:
property int Start {
    int get ();
    void set (int value);
}
member Start : int with get, set

member Start : int with get, set
Property Value
Int32


Style Property

Style Property
API ► Keyoti.RapidSpell.Wpf ► Underline ► Style
Keyoti RapidSpell WPF
Style
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UnderlineStyle Style { get; set; }
public UnderlineStyle Style { get; set; }
Public Property Style As UnderlineStyle
    Get
    Set
Public Property Style As UnderlineStyle
    Get
    Set
public:
property UnderlineStyle Style {
    UnderlineStyle get ();
    void set (UnderlineStyle value);
}
public:
property UnderlineStyle Style {
    UnderlineStyle get ();
    void set (UnderlineStyle value);
}
member Style : UnderlineStyle with get, set

member Style : UnderlineStyle with get, set
Property Value
UnderlineStyle


UnderlineStyle Enumeration

UnderlineStyle Enumeration
API ► Keyoti.RapidSpell.Wpf ► UnderlineStyle
Keyoti RapidSpell WPF
Mis-spelling underline style for RapidSpellAYT control.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public enum UnderlineStyle
public enum UnderlineStyle
Public Enumeration UnderlineStyle
Public Enumeration UnderlineStyle
public enum class UnderlineStyle
public enum class UnderlineStyle
type UnderlineStyle
type UnderlineStyle
Members
Member | Description
Single | A single line under the word.
Dashed | Dashed underline.
Double | 2 lines under the word.
Wavy | Wavy line under the word.
ThinWavy | Thin wavy line under the word, more suitable for small font sizes.
Wavy2 | Different wavy line under the word.
Wavy3 | Different wavy line under the word.
Bar | 'Bar' under the word.
ThinBar | Thin 'Bar' under the word, more suitable for small font sizes.
HighlightRectangle | Background highlight - due to Win Forms constraints, in Win Forms this is actually painted OVER the text, so change the UnderlineColor property to be semi-transparent, otherwise the text will be invisible.


UndoableOperation Class

UndoableOperation Class
API ► Keyoti.RapidSpell.Wpf ► UndoableOperation
Keyoti RapidSpell WPF
An operation which can be undone
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class UndoableOperation
public class UndoableOperation
Public Class UndoableOperation
Public Class UndoableOperation
public ref class UndoableOperation
public ref class UndoableOperation
type UndoableOperation =  class end
type UndoableOperation =  class end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UndoableOperation(UndoableOperation..::..Operation, UndoableStateEventArgs) | Constructor
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperationType | The operation type
 | SourceEvent | The event which indicated the operation occurred.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
UndoableOperation


UndoableOperation Constructor (operationType, sourceEvent)

UndoableOperation Constructor (operationType, sourceEvent)
API ► Keyoti.RapidSpell.Wpf ► UndoableOperation ► UndoableOperation(UndoableOperation..::..Operation, UndoableStateEventArgs)
Keyoti RapidSpell WPF
Constructor
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UndoableOperation(
    UndoableOperation..::..Operation operationType,
    UndoableStateEventArgs sourceEvent
)
public UndoableOperation(
    UndoableOperation..::..Operation operationType,
    UndoableStateEventArgs sourceEvent
)
Public Sub New (
    operationType As UndoableOperation..::..Operation,
    sourceEvent As UndoableStateEventArgs
)
Public Sub New (
    operationType As UndoableOperation..::..Operation,
    sourceEvent As UndoableStateEventArgs
)
public:
UndoableOperation(
    UndoableOperation..::..Operation operationType,
    UndoableStateEventArgs^ sourceEvent
)
public:
UndoableOperation(
    UndoableOperation..::..Operation operationType,
    UndoableStateEventArgs^ sourceEvent
)
new :
        operationType : UndoableOperation..::..Operation *
        sourceEvent : UndoableStateEventArgs -> UndoableOperation
new :
        operationType : UndoableOperation..::..Operation *
        sourceEvent : UndoableStateEventArgs -> UndoableOperation
Parameters
operationType (UndoableOperation..::..Operation)
sourceEvent (UndoableStateEventArgs)


OperationType Property

OperationType Property
API ► Keyoti.RapidSpell.Wpf ► UndoableOperation ► OperationType
Keyoti RapidSpell WPF
The operation type
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UndoableOperation..::..Operation OperationType { get; }
public UndoableOperation..::..Operation OperationType { get; }
Public ReadOnly Property OperationType As UndoableOperation..::..Operation
    Get
Public ReadOnly Property OperationType As UndoableOperation..::..Operation
    Get
public:
property UndoableOperation..::..Operation OperationType {
    UndoableOperation..::..Operation get ();
}
public:
property UndoableOperation..::..Operation OperationType {
    UndoableOperation..::..Operation get ();
}
member OperationType : UndoableOperation..::..Operation with get

member OperationType : UndoableOperation..::..Operation with get
Property Value
UndoableOperation..::..Operation


SourceEvent Property

SourceEvent Property
API ► Keyoti.RapidSpell.Wpf ► UndoableOperation ► SourceEvent
Keyoti RapidSpell WPF
The event which indicated the operation occurred.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UndoableStateEventArgs SourceEvent { get; }
public UndoableStateEventArgs SourceEvent { get; }
Public ReadOnly Property SourceEvent As UndoableStateEventArgs
    Get
Public ReadOnly Property SourceEvent As UndoableStateEventArgs
    Get
public:
property UndoableStateEventArgs^ SourceEvent {
    UndoableStateEventArgs^ get ();
}
public:
property UndoableStateEventArgs^ SourceEvent {
    UndoableStateEventArgs^ get ();
}
member SourceEvent : UndoableStateEventArgs with get

member SourceEvent : UndoableStateEventArgs with get
Property Value
UndoableStateEventArgs


UndoableOperation.Operation Enumeration

UndoableOperation..::..Operation Enumeration
API ► Keyoti.RapidSpell.Wpf ► UndoableOperation ► UndoableOperation..::..Operation
Keyoti RapidSpell WPF
Types of operation
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public enum Operation
public enum Operation
Public Enumeration Operation
Public Enumeration Operation
public enum class Operation
public enum class Operation
type Operation
type Operation
Members
Member | Description
Ignore | Ignore
IgnoreAll | Ignore all
Change | Change
ChangeAll | Change all
Add | Add


UndoableStateEventArgs Class

UndoableStateEventArgs Class
API ► Keyoti.RapidSpell.Wpf ► UndoableStateEventArgs
Keyoti RapidSpell WPF
Args for the events fired when words are ignored.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class UndoableStateEventArgs : EventArgs
public class UndoableStateEventArgs : EventArgs
Public Class UndoableStateEventArgs
    Inherits EventArgs
Public Class UndoableStateEventArgs
    Inherits EventArgs
public ref class UndoableStateEventArgs : public EventArgs
public ref class UndoableStateEventArgs : public EventArgs
type UndoableStateEventArgs =
    class
        inherit EventArgs
    end
type UndoableStateEventArgs =
    class
        inherit EventArgs
    end
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UndoableStateEventArgs(RapidSpellChecker..::..State) | New
 | BadWord | The word involved.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | UndoableState | The state of RapidSpellChecker
 | word | The bad word
Inheritance Hierarchy
Object
 | EventArgs
 |  | UndoableStateEventArgs
 |  |  | WordAddedEventArgs
 |  |  | WordChangedEventArgs
 |  |  | WordIgnoredEventArgs


UndoableStateEventArgs Constructor (undoableState)

UndoableStateEventArgs Constructor (undoableState)
API ► Keyoti.RapidSpell.Wpf ► UndoableStateEventArgs ► UndoableStateEventArgs(RapidSpellChecker..::..State)
Keyoti RapidSpell WPF
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UndoableStateEventArgs(
    RapidSpellChecker..::..State undoableState
)
public UndoableStateEventArgs(
    RapidSpellChecker..::..State undoableState
)
Public Sub New (
    undoableState As RapidSpellChecker..::..State
)
Public Sub New (
    undoableState As RapidSpellChecker..::..State
)
public:
UndoableStateEventArgs(
    RapidSpellChecker..::..State^ undoableState
)
public:
UndoableStateEventArgs(
    RapidSpellChecker..::..State^ undoableState
)
new :
        undoableState : RapidSpellChecker..::..State -> UndoableStateEventArgs
new :
        undoableState : RapidSpellChecker..::..State -> UndoableStateEventArgs
Parameters
undoableState (RapidSpellChecker..::..State)


BadWord Property

BadWord Property
API ► Keyoti.RapidSpell.Wpf ► UndoableStateEventArgs ► BadWord
Keyoti RapidSpell WPF
The word involved.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public BadWord BadWord { get; }
public BadWord BadWord { get; }
Public ReadOnly Property BadWord As BadWord
    Get
Public ReadOnly Property BadWord As BadWord
    Get
public:
property BadWord^ BadWord {
    BadWord^ get ();
}
public:
property BadWord^ BadWord {
    BadWord^ get ();
}
member BadWord : BadWord with get

member BadWord : BadWord with get
Property Value
BadWord


UndoableState Property

UndoableState Property
API ► Keyoti.RapidSpell.Wpf ► UndoableStateEventArgs ► UndoableState
Keyoti RapidSpell WPF
The state of RapidSpellChecker
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public RapidSpellChecker..::..State UndoableState { get; set; }
public RapidSpellChecker..::..State UndoableState { get; set; }
Public Property UndoableState As RapidSpellChecker..::..State
    Get
    Set
Public Property UndoableState As RapidSpellChecker..::..State
    Get
    Set
public:
property RapidSpellChecker..::..State^ UndoableState {
    RapidSpellChecker..::..State^ get ();
    void set (RapidSpellChecker..::..State^ value);
}
public:
property RapidSpellChecker..::..State^ UndoableState {
    RapidSpellChecker..::..State^ get ();
    void set (RapidSpellChecker..::..State^ value);
}
member UndoableState : RapidSpellChecker..::..State with get, set

member UndoableState : RapidSpellChecker..::..State with get, set
Property Value
RapidSpellChecker..::..State


word Field

word Field
API ► Keyoti.RapidSpell.Wpf ► UndoableStateEventArgs ► word
Keyoti RapidSpell WPF
The bad word
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected BadWord word
protected BadWord word
Protected word As BadWord
Protected word As BadWord
protected:
BadWord^ word
protected:
BadWord^ word
val mutable word: BadWord
val mutable word: BadWord
Field Value
BadWord


UndoEventArgs Class

UndoEventArgs Class
API ► Keyoti.RapidSpell.Wpf ► UndoEventArgs
Keyoti RapidSpell WPF
Undo event args
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class UndoEventArgs : EventArgs
public class UndoEventArgs : EventArgs
Public Class UndoEventArgs
    Inherits EventArgs
Public Class UndoEventArgs
    Inherits EventArgs
public ref class UndoEventArgs : public EventArgs
public ref class UndoEventArgs : public EventArgs
type UndoEventArgs =
    class
        inherit EventArgs
    end
type UndoEventArgs =
    class
        inherit EventArgs
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UndoEventArgs(UndoableOperation) | New instance
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | UndoneOperation | The operation which is undone.
Inheritance Hierarchy
Object
 | EventArgs
 |  | UndoEventArgs


UndoEventArgs Constructor (undoneOperation)

UndoEventArgs Constructor (undoneOperation)
API ► Keyoti.RapidSpell.Wpf ► UndoEventArgs ► UndoEventArgs(UndoableOperation)
Keyoti RapidSpell WPF
New instance
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UndoEventArgs(
    UndoableOperation undoneOperation
)
public UndoEventArgs(
    UndoableOperation undoneOperation
)
Public Sub New (
    undoneOperation As UndoableOperation
)
Public Sub New (
    undoneOperation As UndoableOperation
)
public:
UndoEventArgs(
    UndoableOperation^ undoneOperation
)
public:
UndoEventArgs(
    UndoableOperation^ undoneOperation
)
new :
        undoneOperation : UndoableOperation -> UndoEventArgs
new :
        undoneOperation : UndoableOperation -> UndoEventArgs
Parameters
undoneOperation (UndoableOperation)
The operation which is undone.


UndoneOperation Property

UndoneOperation Property
API ► Keyoti.RapidSpell.Wpf ► UndoEventArgs ► UndoneOperation
Keyoti RapidSpell WPF
The operation which is undone.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UndoableOperation UndoneOperation { get; }
public UndoableOperation UndoneOperation { get; }
Public ReadOnly Property UndoneOperation As UndoableOperation
    Get
Public ReadOnly Property UndoneOperation As UndoableOperation
    Get
public:
property UndoableOperation^ UndoneOperation {
    UndoableOperation^ get ();
}
public:
property UndoableOperation^ UndoneOperation {
    UndoableOperation^ get ();
}
member UndoneOperation : UndoableOperation with get

member UndoneOperation : UndoableOperation with get
Property Value
UndoableOperation


UndoEventHandler Delegate

UndoEventHandler Delegate
API ► Keyoti.RapidSpell.Wpf ► UndoEventHandler
Keyoti RapidSpell WPF
Event handler delegate
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void UndoEventHandler(
    Object sender,
    UndoEventArgs e
)
public delegate void UndoEventHandler(
    Object sender,
    UndoEventArgs e
)
Public Delegate Sub UndoEventHandler (
    sender As Object,
    e As UndoEventArgs
)
Public Delegate Sub UndoEventHandler (
    sender As Object,
    e As UndoEventArgs
)
public delegate void UndoEventHandler(
    Object^ sender,
    UndoEventArgs^ e
)
public delegate void UndoEventHandler(
    Object^ sender,
    UndoEventArgs^ e
)
type UndoEventHandler =
    delegate of
        sender : Object *
        e : UndoEventArgs -> unit
type UndoEventHandler =
    delegate of
        sender : Object *
        e : UndoEventArgs -> unit
Parameters
sender (Object)
e (UndoEventArgs)


UndoManager Class

UndoManager Class
API ► Keyoti.RapidSpell.Wpf ► UndoManager
Keyoti RapidSpell WPF
Manages the undoable operation stack.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class UndoManager
public class UndoManager
Public Class UndoManager
Public Class UndoManager
public ref class UndoManager
public ref class UndoManager
type UndoManager =  class end
type UndoManager =  class end
Members
All Members | Constructors | Methods | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UndoManager()()()() | Constructor
 | BufferAddedTo | Indicates that an operation has been added
 | BufferEmptied | Indicates there are no more operations to undo
 | Dispose()()()() | Cleans up resources
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | g_WordAdded(Object, WordAddedEventArgs) | Handles word added events
 | g_WordChanged(Object, WordChangedEventArgs) | Handles word changed events
 | g_WordIgnored(Object, WordIgnoredEventArgs) | Handles word ignored events
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Pop()()()() | Pops off the last operation from the stack
 | Reset()()()() | Resets the stack to empty.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
UndoManager


UndoManager Constructor

UndoManager Constructor
API ► Keyoti.RapidSpell.Wpf ► UndoManager ► UndoManager()()()()
Keyoti RapidSpell WPF
Constructor
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UndoManager()
public UndoManager()
Public Sub New
Public Sub New
public:
UndoManager()
public:
UndoManager()
new : unit -> UndoManager
new : unit -> UndoManager


BufferAddedTo Event

BufferAddedTo Event
API ► Keyoti.RapidSpell.Wpf ► UndoManager ► BufferAddedTo
Keyoti RapidSpell WPF
Indicates that an operation has been added
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler BufferAddedTo
public event EventHandler BufferAddedTo
Public Event BufferAddedTo As EventHandler
Public Event BufferAddedTo As EventHandler
public:
 event EventHandler^ BufferAddedTo {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
 event EventHandler^ BufferAddedTo {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member BufferAddedTo : IEvent<EventHandler,
    EventArgs>

member BufferAddedTo : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


BufferEmptied Event

BufferEmptied Event
API ► Keyoti.RapidSpell.Wpf ► UndoManager ► BufferEmptied
Keyoti RapidSpell WPF
Indicates there are no more operations to undo
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler BufferEmptied
public event EventHandler BufferEmptied
Public Event BufferEmptied As EventHandler
Public Event BufferEmptied As EventHandler
public:
 event EventHandler^ BufferEmptied {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
 event EventHandler^ BufferEmptied {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member BufferEmptied : IEvent<EventHandler,
    EventArgs>

member BufferEmptied : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


Dispose Method

Dispose Method
API ► Keyoti.RapidSpell.Wpf ► UndoManager ► Dispose()()()()
Keyoti RapidSpell WPF
Cleans up resources
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void Dispose()
public virtual void Dispose()
Public Overridable Sub Dispose
Public Overridable Sub Dispose
public:
virtual void Dispose()
public:
virtual void Dispose()
abstract Dispose : unit -> unit
override Dispose : unit -> unit
abstract Dispose : unit -> unit
override Dispose : unit -> unit


g_WordAdded Method (s, e)

g_WordAdded Method (s, e)
API ► Keyoti.RapidSpell.Wpf ► UndoManager ► g_WordAdded(Object, WordAddedEventArgs)
Keyoti RapidSpell WPF
Handles word added events
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void g_WordAdded(
    Object s,
    WordAddedEventArgs e
)
public void g_WordAdded(
    Object s,
    WordAddedEventArgs e
)
Public Sub g_WordAdded (
    s As Object,
    e As WordAddedEventArgs
)
Public Sub g_WordAdded (
    s As Object,
    e As WordAddedEventArgs
)
public:
void g_WordAdded(
    Object^ s,
    WordAddedEventArgs^ e
)
public:
void g_WordAdded(
    Object^ s,
    WordAddedEventArgs^ e
)
member g_WordAdded :
        s : Object *
        e : WordAddedEventArgs -> unit

member g_WordAdded :
        s : Object *
        e : WordAddedEventArgs -> unit
Parameters
s (Object)
e (WordAddedEventArgs)


g_WordChanged Method (s, e)

g_WordChanged Method (s, e)
API ► Keyoti.RapidSpell.Wpf ► UndoManager ► g_WordChanged(Object, WordChangedEventArgs)
Keyoti RapidSpell WPF
Handles word changed events
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void g_WordChanged(
    Object s,
    WordChangedEventArgs e
)
public void g_WordChanged(
    Object s,
    WordChangedEventArgs e
)
Public Sub g_WordChanged (
    s As Object,
    e As WordChangedEventArgs
)
Public Sub g_WordChanged (
    s As Object,
    e As WordChangedEventArgs
)
public:
void g_WordChanged(
    Object^ s,
    WordChangedEventArgs^ e
)
public:
void g_WordChanged(
    Object^ s,
    WordChangedEventArgs^ e
)
member g_WordChanged :
        s : Object *
        e : WordChangedEventArgs -> unit

member g_WordChanged :
        s : Object *
        e : WordChangedEventArgs -> unit
Parameters
s (Object)
e (WordChangedEventArgs)


g_WordIgnored Method (s, e)

g_WordIgnored Method (s, e)
API ► Keyoti.RapidSpell.Wpf ► UndoManager ► g_WordIgnored(Object, WordIgnoredEventArgs)
Keyoti RapidSpell WPF
Handles word ignored events
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void g_WordIgnored(
    Object s,
    WordIgnoredEventArgs e
)
public void g_WordIgnored(
    Object s,
    WordIgnoredEventArgs e
)
Public Sub g_WordIgnored (
    s As Object,
    e As WordIgnoredEventArgs
)
Public Sub g_WordIgnored (
    s As Object,
    e As WordIgnoredEventArgs
)
public:
void g_WordIgnored(
    Object^ s,
    WordIgnoredEventArgs^ e
)
public:
void g_WordIgnored(
    Object^ s,
    WordIgnoredEventArgs^ e
)
member g_WordIgnored :
        s : Object *
        e : WordIgnoredEventArgs -> unit

member g_WordIgnored :
        s : Object *
        e : WordIgnoredEventArgs -> unit
Parameters
s (Object)
e (WordIgnoredEventArgs)


Pop Method

Pop Method
API ► Keyoti.RapidSpell.Wpf ► UndoManager ► Pop()()()()
Keyoti RapidSpell WPF
Pops off the last operation from the stack
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UndoableOperation Pop()
public UndoableOperation Pop()
Public Function Pop As UndoableOperation
Public Function Pop As UndoableOperation
public:
UndoableOperation^ Pop()
public:
UndoableOperation^ Pop()
member Pop : unit -> UndoableOperation

member Pop : unit -> UndoableOperation
Return Value
UndoableOperation


Reset Method

Reset Method
API ► Keyoti.RapidSpell.Wpf ► UndoManager ► Reset()()()()
Keyoti RapidSpell WPF
Resets the stack to empty.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void Reset()
public virtual void Reset()
Public Overridable Sub Reset
Public Overridable Sub Reset
public:
virtual void Reset()
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit
abstract Reset : unit -> unit
override Reset : unit -> unit


UserDictionary Class

UserDictionary Class
API ► Keyoti.RapidSpell.Wpf ► UserDictionary
Keyoti RapidSpell WPF
Represents the UserDictionary
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class UserDictionary
public class UserDictionary
Public Class UserDictionary
Public Class UserDictionary
public ref class UserDictionary
public ref class UserDictionary
type UserDictionary =  class end
type UserDictionary =  class end
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserDictionary(String) | Construct a UserDictionary based on the userDictionaryFile, which does not have to exist.
 | UserDictionary()()()() | Constructs an invalid UserDictionary
 | UserDictionary(String, Int32) | Construct a UserDictionary based on the userDictionaryFile, which does not have to exist.
 | AddWord(String) | Tries to add word to this dictionary
 | dictFile | The file containing the dictionary
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | IsValid()()()() | Returns whether the dictionary file is valid.
 | ListChanged | Notifies handlers that the word list has changed.
 | Location | Where to store the user dictionary
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnListChanged(UserDictionary..::..ListChangedEventArgs) | Raises ListChanged
 | OnListChanged(Object, UserDictionary..::..ListChangedEventArgs) | Raises ListChanged
 | ReadAll(ArrayList) | Read the dictionary word list into list.
 | ReloadDictionary()()()() | Loads the dictionary into an internal collection.
 | RemoveWord(String) | Tries to remove word from this dictionary
 | SaveList(ArrayList) | Replaces the contents of the file with newList.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | UserDictionary
 |  | MultiFileUserDictionary


UserDictionary Constructor

UserDictionary Constructor
API ► Keyoti.RapidSpell.Wpf ► UserDictionary ► UserDictionary()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | UserDictionary(String) | Construct a UserDictionary based on the userDictionaryFile, which does not have to exist.
 | UserDictionary()()()() | Constructs an invalid UserDictionary
 | UserDictionary(String, Int32) | Construct a UserDictionary based on the userDictionaryFile, which does not have to exist.


UserDictionary Constructor

UserDictionary Constructor
API ► Keyoti.RapidSpell.Wpf ► UserDictionary ► UserDictionary()()()()
Keyoti RapidSpell WPF
Constructs an invalid UserDictionary
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UserDictionary()
public UserDictionary()
Public Sub New
Public Sub New
public:
UserDictionary()
public:
UserDictionary()
new : unit -> UserDictionary
new : unit -> UserDictionary


UserDictionary Constructor (userDictionaryFile)

UserDictionary Constructor (userDictionaryFile)
API ► Keyoti.RapidSpell.Wpf ► UserDictionary ► UserDictionary(String)
Keyoti RapidSpell WPF
Construct a UserDictionary based on the userDictionaryFile, which does not have to exist.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UserDictionary(
    string userDictionaryFile
)
public UserDictionary(
    string userDictionaryFile
)
Public Sub New (
    userDictionaryFile As String
)
Public Sub New (
    userDictionaryFile As String
)
public:
UserDictionary(
    String^ userDictionaryFile
)
public:
UserDictionary(
    String^ userDictionaryFile
)
new :
        userDictionaryFile : string -> UserDictionary
new :
        userDictionaryFile : string -> UserDictionary
Parameters
userDictionaryFile (String)
the file used for a user dictionary.
Remarks
User dictionary is limited to 5,000 words.


UserDictionary Constructor (userDictionaryFile, wordLimit)

UserDictionary Constructor (userDictionaryFile, wordLimit)
API ► Keyoti.RapidSpell.Wpf ► UserDictionary ► UserDictionary(String, Int32)
Keyoti RapidSpell WPF
Construct a UserDictionary based on the userDictionaryFile, which does not have to exist.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UserDictionary(
    string userDictionaryFile,
    int wordLimit
)
public UserDictionary(
    string userDictionaryFile,
    int wordLimit
)
Public Sub New (
    userDictionaryFile As String,
    wordLimit As Integer
)
Public Sub New (
    userDictionaryFile As String,
    wordLimit As Integer
)
public:
UserDictionary(
    String^ userDictionaryFile,
    int wordLimit
)
public:
UserDictionary(
    String^ userDictionaryFile,
    int wordLimit
)
new :
        userDictionaryFile : string *
        wordLimit : int -> UserDictionary
new :
        userDictionaryFile : string *
        wordLimit : int -> UserDictionary
Parameters
userDictionaryFile (String)
the file used for a user dictionary.
wordLimit (Int32)
number of words user dictionary is limited to (150,000 max). If wordLimit is <=0 it will be set to 150,000.


AddWord Method (word)

AddWord Method (word)
API ► Keyoti.RapidSpell.Wpf ► UserDictionary ► AddWord(String)
Keyoti RapidSpell WPF
Tries to add word to this dictionary
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool AddWord(
    string word
)
public virtual bool AddWord(
    string word
)
Public Overridable Function AddWord (
    word As String
) As Boolean
Public Overridable Function AddWord (
    word As String
) As Boolean
public:
virtual bool AddWord(
    String^ word
)
public:
virtual bool AddWord(
    String^ word
)
abstract AddWord :
        word : string -> bool
override AddWord :
        word : string -> bool
abstract AddWord :
        word : string -> bool
override AddWord :
        word : string -> bool
Parameters
word (String)
String containing the new word
Return Value
Boolean
true if added successfully, false otherwise.


dictFile Field

dictFile Field
API ► Keyoti.RapidSpell.Wpf ► UserDictionary ► dictFile
Keyoti RapidSpell WPF
The file containing the dictionary
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string dictFile
public string dictFile
Public dictFile As String
Public dictFile As String
public:
String^ dictFile
public:
String^ dictFile
val mutable dictFile: string
val mutable dictFile: string
Field Value
String


IsValid Method

IsValid Method
API ► Keyoti.RapidSpell.Wpf ► UserDictionary ► IsValid()()()()
Keyoti RapidSpell WPF
Returns whether the dictionary file is valid.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool IsValid()
public virtual bool IsValid()
Public Overridable Function IsValid As Boolean
Public Overridable Function IsValid As Boolean
public:
virtual bool IsValid()
public:
virtual bool IsValid()
abstract IsValid : unit -> bool
override IsValid : unit -> bool
abstract IsValid : unit -> bool
override IsValid : unit -> bool
Return Value
Boolean


ListChanged Event

ListChanged Event
API ► Keyoti.RapidSpell.Wpf ► UserDictionary ► ListChanged
Keyoti RapidSpell WPF
Notifies handlers that the word list has changed.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event UserDictionary..::..ListChangedEventHandler ListChanged
public event UserDictionary..::..ListChangedEventHandler ListChanged
Public Event ListChanged As UserDictionary..::..ListChangedEventHandler
Public Event ListChanged As UserDictionary..::..ListChangedEventHandler
public:
 event UserDictionary..::..ListChangedEventHandler^ ListChanged {
    void add (UserDictionary..::..ListChangedEventHandler^ value);
    void remove (UserDictionary..::..ListChangedEventHandler^ value);
}
public:
 event UserDictionary..::..ListChangedEventHandler^ ListChanged {
    void add (UserDictionary..::..ListChangedEventHandler^ value);
    void remove (UserDictionary..::..ListChangedEventHandler^ value);
}
member ListChanged : IEvent<UserDictionary..::..ListChangedEventHandler,
    UserDictionary..::..ListChangedEventArgs>

member ListChanged : IEvent<UserDictionary..::..ListChangedEventHandler,
    UserDictionary..::..ListChangedEventArgs>
Value
UserDictionary..::..ListChangedEventHandler


Location Property

Location Property
API ► Keyoti.RapidSpell.Wpf ► UserDictionary ► Location
Keyoti RapidSpell WPF
Where to store the user dictionary
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UserDictionary..::..StorageLocation Location { get; set; }
public UserDictionary..::..StorageLocation Location { get; set; }
Public Property Location As UserDictionary..::..StorageLocation
    Get
    Set
Public Property Location As UserDictionary..::..StorageLocation
    Get
    Set
public:
property UserDictionary..::..StorageLocation Location {
    UserDictionary..::..StorageLocation get ();
    void set (UserDictionary..::..StorageLocation value);
}
public:
property UserDictionary..::..StorageLocation Location {
    UserDictionary..::..StorageLocation get ();
    void set (UserDictionary..::..StorageLocation value);
}
member Location : UserDictionary..::..StorageLocation with get, set

member Location : UserDictionary..::..StorageLocation with get, set
Property Value
UserDictionary..::..StorageLocation


OnListChanged Method

OnListChanged Method
API ► Keyoti.RapidSpell.Wpf ► UserDictionary ► OnListChanged()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | OnListChanged(UserDictionary..::..ListChangedEventArgs) | Raises ListChanged
 | OnListChanged(Object, UserDictionary..::..ListChangedEventArgs) | Raises ListChanged


OnListChanged Method (e)

OnListChanged Method (e)
API ► Keyoti.RapidSpell.Wpf ► UserDictionary ► OnListChanged(UserDictionary..::..ListChangedEventArgs)
Keyoti RapidSpell WPF
Raises ListChanged
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void OnListChanged(
    UserDictionary..::..ListChangedEventArgs e
)
protected virtual void OnListChanged(
    UserDictionary..::..ListChangedEventArgs e
)
Protected Overridable Sub OnListChanged (
    e As UserDictionary..::..ListChangedEventArgs
)
Protected Overridable Sub OnListChanged (
    e As UserDictionary..::..ListChangedEventArgs
)
protected:
virtual void OnListChanged(
    UserDictionary..::..ListChangedEventArgs^ e
)
protected:
virtual void OnListChanged(
    UserDictionary..::..ListChangedEventArgs^ e
)
abstract OnListChanged :
        e : UserDictionary..::..ListChangedEventArgs -> unit
override OnListChanged :
        e : UserDictionary..::..ListChangedEventArgs -> unit
abstract OnListChanged :
        e : UserDictionary..::..ListChangedEventArgs -> unit
override OnListChanged :
        e : UserDictionary..::..ListChangedEventArgs -> unit
Parameters
e (UserDictionary..::..ListChangedEventArgs)


OnListChanged Method (source, e)

OnListChanged Method (source, e)
API ► Keyoti.RapidSpell.Wpf ► UserDictionary ► OnListChanged(Object, UserDictionary..::..ListChangedEventArgs)
Keyoti RapidSpell WPF
Raises ListChanged
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected void OnListChanged(
    Object source,
    UserDictionary..::..ListChangedEventArgs e
)
protected void OnListChanged(
    Object source,
    UserDictionary..::..ListChangedEventArgs e
)
Protected Sub OnListChanged (
    source As Object,
    e As UserDictionary..::..ListChangedEventArgs
)
Protected Sub OnListChanged (
    source As Object,
    e As UserDictionary..::..ListChangedEventArgs
)
protected:
void OnListChanged(
    Object^ source,
    UserDictionary..::..ListChangedEventArgs^ e
)
protected:
void OnListChanged(
    Object^ source,
    UserDictionary..::..ListChangedEventArgs^ e
)
member OnListChanged :
        source : Object *
        e : UserDictionary..::..ListChangedEventArgs -> unit

member OnListChanged :
        source : Object *
        e : UserDictionary..::..ListChangedEventArgs -> unit
Parameters
source (Object)
e (UserDictionary..::..ListChangedEventArgs)


ReadAll Method (list)

ReadAll Method (list)
API ► Keyoti.RapidSpell.Wpf ► UserDictionary ► ReadAll(ArrayList)
Keyoti RapidSpell WPF
Read the dictionary word list into list.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual int ReadAll(
    ArrayList list
)
public virtual int ReadAll(
    ArrayList list
)
Public Overridable Function ReadAll (
    list As ArrayList
) As Integer
Public Overridable Function ReadAll (
    list As ArrayList
) As Integer
public:
virtual int ReadAll(
    ArrayList^ list
)
public:
virtual int ReadAll(
    ArrayList^ list
)
abstract ReadAll :
        list : ArrayList -> int
override ReadAll :
        list : ArrayList -> int
abstract ReadAll :
        list : ArrayList -> int
override ReadAll :
        list : ArrayList -> int
Parameters
list (ArrayList)
the String array that the word list will be read into.
Return Value
Int32
number of words in list.


ReloadDictionary Method

ReloadDictionary Method
API ► Keyoti.RapidSpell.Wpf ► UserDictionary ► ReloadDictionary()()()()
Keyoti RapidSpell WPF
Loads the dictionary into an internal collection.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool ReloadDictionary()
public virtual bool ReloadDictionary()
Public Overridable Function ReloadDictionary As Boolean
Public Overridable Function ReloadDictionary As Boolean
public:
virtual bool ReloadDictionary()
public:
virtual bool ReloadDictionary()
abstract ReloadDictionary : unit -> bool
override ReloadDictionary : unit -> bool
abstract ReloadDictionary : unit -> bool
override ReloadDictionary : unit -> bool
Return Value
Boolean
Whether the dictionary was reloaded successfully.
Remarks
The user dictionary can be changed externally (eg. by a different control), and this method is called when that happens to cause the internal collection to be updated.


RemoveWord Method (word)

RemoveWord Method (word)
API ► Keyoti.RapidSpell.Wpf ► UserDictionary ► RemoveWord(String)
Keyoti RapidSpell WPF
Tries to remove word from this dictionary
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool RemoveWord(
    string word
)
public virtual bool RemoveWord(
    string word
)
Public Overridable Function RemoveWord (
    word As String
) As Boolean
Public Overridable Function RemoveWord (
    word As String
) As Boolean
public:
virtual bool RemoveWord(
    String^ word
)
public:
virtual bool RemoveWord(
    String^ word
)
abstract RemoveWord :
        word : string -> bool
override RemoveWord :
        word : string -> bool
abstract RemoveWord :
        word : string -> bool
override RemoveWord :
        word : string -> bool
Parameters
word (String)
String containing the new word
Return Value
Boolean
true if added successfully, false otherwise.


SaveList Method (newList)

SaveList Method (newList)
API ► Keyoti.RapidSpell.Wpf ► UserDictionary ► SaveList(ArrayList)
Keyoti RapidSpell WPF
Replaces the contents of the file with newList.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void SaveList(
    ArrayList newList
)
public virtual void SaveList(
    ArrayList newList
)
Public Overridable Sub SaveList (
    newList As ArrayList
)
Public Overridable Sub SaveList (
    newList As ArrayList
)
public:
virtual void SaveList(
    ArrayList^ newList
)
public:
virtual void SaveList(
    ArrayList^ newList
)
abstract SaveList :
        newList : ArrayList -> unit
override SaveList :
        newList : ArrayList -> unit
abstract SaveList :
        newList : ArrayList -> unit
override SaveList :
        newList : ArrayList -> unit
Parameters
newList (ArrayList)


UserDictionary.ListChangedEventArgs Class

UserDictionary..::..ListChangedEventArgs Class
API ► Keyoti.RapidSpell.Wpf ► UserDictionary ► UserDictionary..::..ListChangedEventArgs
Keyoti RapidSpell WPF
Event args for ListChanged event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class ListChangedEventArgs : EventArgs
public class ListChangedEventArgs : EventArgs
Public Class ListChangedEventArgs
    Inherits EventArgs
Public Class ListChangedEventArgs
    Inherits EventArgs
public ref class ListChangedEventArgs : public EventArgs
public ref class ListChangedEventArgs : public EventArgs
type ListChangedEventArgs =
    class
        inherit EventArgs
    end
type ListChangedEventArgs =
    class
        inherit EventArgs
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserDictionary..::..ListChangedEventArgs(UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation, String) | New
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Operation | The type of operation
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Word | The word that was added or removed, may be null for ListSave.
Inheritance Hierarchy
Object
 | EventArgs
 |  | UserDictionary..::..ListChangedEventArgs


UserDictionary.ListChangedEventArgs Constructor (op, word)

UserDictionary..::..ListChangedEventArgs Constructor (op, word)
API ► Keyoti.RapidSpell.Wpf ► UserDictionary..::..ListChangedEventArgs ► UserDictionary..::..ListChangedEventArgs(UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation, String)
Keyoti RapidSpell WPF
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ListChangedEventArgs(
    UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation op,
    string word
)
public ListChangedEventArgs(
    UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation op,
    string word
)
Public Sub New (
    op As UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation,
    word As String
)
Public Sub New (
    op As UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation,
    word As String
)
public:
ListChangedEventArgs(
    UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation op,
    String^ word
)
public:
ListChangedEventArgs(
    UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation op,
    String^ word
)
new :
        op : UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation *
        word : string -> ListChangedEventArgs
new :
        op : UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation *
        word : string -> ListChangedEventArgs
Parameters
op (UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation)
word (String)


Operation Property

Operation Property
API ► Keyoti.RapidSpell.Wpf ► UserDictionary..::..ListChangedEventArgs ► Operation
Keyoti RapidSpell WPF
The type of operation
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation Operation { get; }
public UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation Operation { get; }
Public ReadOnly Property Operation As UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation
    Get
Public ReadOnly Property Operation As UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation
    Get
public:
property UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation Operation {
    UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation get ();
}
public:
property UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation Operation {
    UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation get ();
}
member Operation : UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation with get

member Operation : UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation with get
Property Value
UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation


Word Property

Word Property
API ► Keyoti.RapidSpell.Wpf ► UserDictionary..::..ListChangedEventArgs ► Word
Keyoti RapidSpell WPF
The word that was added or removed, may be null for ListSave.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string Word { get; }
public string Word { get; }
Public ReadOnly Property Word As String
    Get
Public ReadOnly Property Word As String
    Get
public:
property String^ Word {
    String^ get ();
}
public:
property String^ Word {
    String^ get ();
}
member Word : string with get

member Word : string with get
Property Value
String


UserDictionary.ListChangedEventArgs.ListChangeOperation Enumeration

UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation Enumeration
API ► Keyoti.RapidSpell.Wpf ► UserDictionary..::..ListChangedEventArgs ► UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation
Keyoti RapidSpell WPF
Types of operation
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public enum ListChangeOperation
public enum ListChangeOperation
Public Enumeration ListChangeOperation
Public Enumeration ListChangeOperation
public enum class ListChangeOperation
public enum class ListChangeOperation
type ListChangeOperation
type ListChangeOperation
Members
Member | Description
WordAdd | Word added.
WordRemove | Word removed
ListSave | List saved
ContentReload | The content of the dictionary was completely changed


UserDictionary.ListChangedEventHandler Delegate

UserDictionary..::..ListChangedEventHandler Delegate
API ► Keyoti.RapidSpell.Wpf ► UserDictionary ► UserDictionary..::..ListChangedEventHandler
Keyoti RapidSpell WPF
Event handler
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void ListChangedEventHandler(
    Object s,
    UserDictionary..::..ListChangedEventArgs e
)
public delegate void ListChangedEventHandler(
    Object s,
    UserDictionary..::..ListChangedEventArgs e
)
Public Delegate Sub ListChangedEventHandler (
    s As Object,
    e As UserDictionary..::..ListChangedEventArgs
)
Public Delegate Sub ListChangedEventHandler (
    s As Object,
    e As UserDictionary..::..ListChangedEventArgs
)
public delegate void ListChangedEventHandler(
    Object^ s,
    UserDictionary..::..ListChangedEventArgs^ e
)
public delegate void ListChangedEventHandler(
    Object^ s,
    UserDictionary..::..ListChangedEventArgs^ e
)
type ListChangedEventHandler =
    delegate of
        s : Object *
        e : UserDictionary..::..ListChangedEventArgs -> unit
type ListChangedEventHandler =
    delegate of
        s : Object *
        e : UserDictionary..::..ListChangedEventArgs -> unit
Parameters
s (Object)
e (UserDictionary..::..ListChangedEventArgs)


UserDictionary.StorageLocation Enumeration

UserDictionary..::..StorageLocation Enumeration
API ► Keyoti.RapidSpell.Wpf ► UserDictionary ► UserDictionary..::..StorageLocation
Keyoti RapidSpell WPF
Location options for storage
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public enum StorageLocation
public enum StorageLocation
Public Enumeration StorageLocation
Public Enumeration StorageLocation
public enum class StorageLocation
public enum class StorageLocation
type StorageLocation
type StorageLocation
Members
Member | Description
File | File based
IsolatedStorage | IsolatedStorage based.


WordAddedEventArgs Class

WordAddedEventArgs Class
API ► Keyoti.RapidSpell.Wpf ► WordAddedEventArgs
Keyoti RapidSpell WPF
Args for the events fired when words are added to the user dictionary.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class WordAddedEventArgs : UndoableStateEventArgs
public class WordAddedEventArgs : UndoableStateEventArgs
Public Class WordAddedEventArgs
    Inherits UndoableStateEventArgs
Public Class WordAddedEventArgs
    Inherits UndoableStateEventArgs
public ref class WordAddedEventArgs : public UndoableStateEventArgs
public ref class WordAddedEventArgs : public UndoableStateEventArgs
type WordAddedEventArgs =
    class
        inherit UndoableStateEventArgs
    end
type WordAddedEventArgs =
    class
        inherit UndoableStateEventArgs
    end
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WordAddedEventArgs(BadWord, RapidSpellChecker..::..State, Object) |
 | BadWord | The word involved. (Inherited from UndoableStateEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TextBox | The current text box, if known.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | UndoableState | The state of RapidSpellChecker (Inherited from UndoableStateEventArgs.)
 | word | The bad word (Inherited from UndoableStateEventArgs.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | UndoableStateEventArgs
 |  |  | WordAddedEventArgs


WordAddedEventArgs Constructor (word, undoableState, textBox)

WordAddedEventArgs Constructor (word, undoableState, textBox)
API ► Keyoti.RapidSpell.Wpf ► WordAddedEventArgs ► WordAddedEventArgs(BadWord, RapidSpellChecker..::..State, Object)
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public WordAddedEventArgs(
    BadWord word,
    RapidSpellChecker..::..State undoableState,
    Object textBox
)
public WordAddedEventArgs(
    BadWord word,
    RapidSpellChecker..::..State undoableState,
    Object textBox
)
Public Sub New (
    word As BadWord,
    undoableState As RapidSpellChecker..::..State,
    textBox As Object
)
Public Sub New (
    word As BadWord,
    undoableState As RapidSpellChecker..::..State,
    textBox As Object
)
public:
WordAddedEventArgs(
    BadWord^ word,
    RapidSpellChecker..::..State^ undoableState,
    Object^ textBox
)
public:
WordAddedEventArgs(
    BadWord^ word,
    RapidSpellChecker..::..State^ undoableState,
    Object^ textBox
)
new :
        word : BadWord *
        undoableState : RapidSpellChecker..::..State *
        textBox : Object -> WordAddedEventArgs
new :
        word : BadWord *
        undoableState : RapidSpellChecker..::..State *
        textBox : Object -> WordAddedEventArgs
Parameters
word (BadWord)
undoableState (RapidSpellChecker..::..State)
textBox (Object)


TextBox Property

TextBox Property
API ► Keyoti.RapidSpell.Wpf ► WordAddedEventArgs ► TextBox
Keyoti RapidSpell WPF
The current text box, if known.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Object TextBox { get; }
public Object TextBox { get; }
Public ReadOnly Property TextBox As Object
    Get
Public ReadOnly Property TextBox As Object
    Get
public:
property Object^ TextBox {
    Object^ get ();
}
public:
property Object^ TextBox {
    Object^ get ();
}
member TextBox : Object with get

member TextBox : Object with get
Property Value
Object


WordAddedEventHandler Delegate

WordAddedEventHandler Delegate
API ► Keyoti.RapidSpell.Wpf ► WordAddedEventHandler
Keyoti RapidSpell WPF
Handler delegate
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void WordAddedEventHandler(
    Object sender,
    WordAddedEventArgs e
)
public delegate void WordAddedEventHandler(
    Object sender,
    WordAddedEventArgs e
)
Public Delegate Sub WordAddedEventHandler (
    sender As Object,
    e As WordAddedEventArgs
)
Public Delegate Sub WordAddedEventHandler (
    sender As Object,
    e As WordAddedEventArgs
)
public delegate void WordAddedEventHandler(
    Object^ sender,
    WordAddedEventArgs^ e
)
public delegate void WordAddedEventHandler(
    Object^ sender,
    WordAddedEventArgs^ e
)
type WordAddedEventHandler =
    delegate of
        sender : Object *
        e : WordAddedEventArgs -> unit
type WordAddedEventHandler =
    delegate of
        sender : Object *
        e : WordAddedEventArgs -> unit
Parameters
sender (Object)
e (WordAddedEventArgs)


WordChangedEventArgs Class

WordChangedEventArgs Class
API ► Keyoti.RapidSpell.Wpf ► WordChangedEventArgs
Keyoti RapidSpell WPF
Args for the events fired when words are changed.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class WordChangedEventArgs : UndoableStateEventArgs
public class WordChangedEventArgs : UndoableStateEventArgs
Public Class WordChangedEventArgs
    Inherits UndoableStateEventArgs
Public Class WordChangedEventArgs
    Inherits UndoableStateEventArgs
public ref class WordChangedEventArgs : public UndoableStateEventArgs
public ref class WordChangedEventArgs : public UndoableStateEventArgs
type WordChangedEventArgs =
    class
        inherit UndoableStateEventArgs
    end
type WordChangedEventArgs =
    class
        inherit UndoableStateEventArgs
    end
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WordChangedEventArgs(Boolean, BadWord, String, RapidSpellChecker..::..State, ArrayList, Int32, Object) |
 | All | Whether all instances of the word were changed.
 | BadWord | The word involved. (Inherited from UndoableStateEventArgs.)
 | ChangeIndices | List of ints pointing to locations in the text where other instances of the word were changed, if there were any, null/nothing otherwise
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Replacement | The replacement word.
 | TextBox | The current text box, if known.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | UndoableState | The state of RapidSpellChecker (Inherited from UndoableStateEventArgs.)
 | word | The bad word (Inherited from UndoableStateEventArgs.)
 | WrappedChangeDelta | The change to indices caused by wrapped text changes
Inheritance Hierarchy
Object
 | EventArgs
 |  | UndoableStateEventArgs
 |  |  | WordChangedEventArgs


WordChangedEventArgs Constructor (all, badWord, replacement, undoableState, changeIndices, wrappedChangeDelta, textBox)

WordChangedEventArgs Constructor (all, badWord, replacement, undoableState, changeIndices, wrappedChangeDelta, textBox)
API ► Keyoti.RapidSpell.Wpf ► WordChangedEventArgs ► WordChangedEventArgs(Boolean, BadWord, String, RapidSpellChecker..::..State, ArrayList, Int32, Object)
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public WordChangedEventArgs(
    bool all,
    BadWord badWord,
    string replacement,
    RapidSpellChecker..::..State undoableState,
    ArrayList changeIndices,
    int wrappedChangeDelta,
    Object textBox
)
public WordChangedEventArgs(
    bool all,
    BadWord badWord,
    string replacement,
    RapidSpellChecker..::..State undoableState,
    ArrayList changeIndices,
    int wrappedChangeDelta,
    Object textBox
)
Public Sub New (
    all As Boolean,
    badWord As BadWord,
    replacement As String,
    undoableState As RapidSpellChecker..::..State,
    changeIndices As ArrayList,
    wrappedChangeDelta As Integer,
    textBox As Object
)
Public Sub New (
    all As Boolean,
    badWord As BadWord,
    replacement As String,
    undoableState As RapidSpellChecker..::..State,
    changeIndices As ArrayList,
    wrappedChangeDelta As Integer,
    textBox As Object
)
public:
WordChangedEventArgs(
    bool all,
    BadWord^ badWord,
    String^ replacement,
    RapidSpellChecker..::..State^ undoableState,
    ArrayList^ changeIndices,
    int wrappedChangeDelta,
    Object^ textBox
)
public:
WordChangedEventArgs(
    bool all,
    BadWord^ badWord,
    String^ replacement,
    RapidSpellChecker..::..State^ undoableState,
    ArrayList^ changeIndices,
    int wrappedChangeDelta,
    Object^ textBox
)
new :
        all : bool *
        badWord : BadWord *
        replacement : string *
        undoableState : RapidSpellChecker..::..State *
        changeIndices : ArrayList *
        wrappedChangeDelta : int *
        textBox : Object -> WordChangedEventArgs
new :
        all : bool *
        badWord : BadWord *
        replacement : string *
        undoableState : RapidSpellChecker..::..State *
        changeIndices : ArrayList *
        wrappedChangeDelta : int *
        textBox : Object -> WordChangedEventArgs
Parameters
all (Boolean)
badWord (BadWord)
replacement (String)
undoableState (RapidSpellChecker..::..State)
changeIndices (ArrayList)
wrappedChangeDelta (Int32)
textBox (Object)


All Property

All Property
API ► Keyoti.RapidSpell.Wpf ► WordChangedEventArgs ► All
Keyoti RapidSpell WPF
Whether all instances of the word were changed.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool All { get; }
public bool All { get; }
Public ReadOnly Property All As Boolean
    Get
Public ReadOnly Property All As Boolean
    Get
public:
property bool All {
    bool get ();
}
public:
property bool All {
    bool get ();
}
member All : bool with get

member All : bool with get
Property Value
Boolean


ChangeIndices Property

ChangeIndices Property
API ► Keyoti.RapidSpell.Wpf ► WordChangedEventArgs ► ChangeIndices
Keyoti RapidSpell WPF
List of ints pointing to locations in the text where other instances of the word were changed, if there were any, null/nothing otherwise
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ArrayList ChangeIndices { get; }
public ArrayList ChangeIndices { get; }
Public ReadOnly Property ChangeIndices As ArrayList
    Get
Public ReadOnly Property ChangeIndices As ArrayList
    Get
public:
property ArrayList^ ChangeIndices {
    ArrayList^ get ();
}
public:
property ArrayList^ ChangeIndices {
    ArrayList^ get ();
}
member ChangeIndices : ArrayList with get

member ChangeIndices : ArrayList with get
Property Value
ArrayList


Replacement Property

Replacement Property
API ► Keyoti.RapidSpell.Wpf ► WordChangedEventArgs ► Replacement
Keyoti RapidSpell WPF
The replacement word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string Replacement { get; set; }
public string Replacement { get; set; }
Public Property Replacement As String
    Get
    Set
Public Property Replacement As String
    Get
    Set
public:
property String^ Replacement {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Replacement {
    String^ get ();
    void set (String^ value);
}
member Replacement : string with get, set

member Replacement : string with get, set
Property Value
String


TextBox Property

TextBox Property
API ► Keyoti.RapidSpell.Wpf ► WordChangedEventArgs ► TextBox
Keyoti RapidSpell WPF
The current text box, if known.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Object TextBox { get; }
public Object TextBox { get; }
Public ReadOnly Property TextBox As Object
    Get
Public ReadOnly Property TextBox As Object
    Get
public:
property Object^ TextBox {
    Object^ get ();
}
public:
property Object^ TextBox {
    Object^ get ();
}
member TextBox : Object with get

member TextBox : Object with get
Property Value
Object


WrappedChangeDelta Property

WrappedChangeDelta Property
API ► Keyoti.RapidSpell.Wpf ► WordChangedEventArgs ► WrappedChangeDelta
Keyoti RapidSpell WPF
The change to indices caused by wrapped text changes
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int WrappedChangeDelta { get; }
public int WrappedChangeDelta { get; }
Public ReadOnly Property WrappedChangeDelta As Integer
    Get
Public ReadOnly Property WrappedChangeDelta As Integer
    Get
public:
property int WrappedChangeDelta {
    int get ();
}
public:
property int WrappedChangeDelta {
    int get ();
}
member WrappedChangeDelta : int with get

member WrappedChangeDelta : int with get
Property Value
Int32


WordChangedEventHandler Delegate

WordChangedEventHandler Delegate
API ► Keyoti.RapidSpell.Wpf ► WordChangedEventHandler
Keyoti RapidSpell WPF
Handler delegate
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void WordChangedEventHandler(
    Object sender,
    WordChangedEventArgs e
)
public delegate void WordChangedEventHandler(
    Object sender,
    WordChangedEventArgs e
)
Public Delegate Sub WordChangedEventHandler (
    sender As Object,
    e As WordChangedEventArgs
)
Public Delegate Sub WordChangedEventHandler (
    sender As Object,
    e As WordChangedEventArgs
)
public delegate void WordChangedEventHandler(
    Object^ sender,
    WordChangedEventArgs^ e
)
public delegate void WordChangedEventHandler(
    Object^ sender,
    WordChangedEventArgs^ e
)
type WordChangedEventHandler =
    delegate of
        sender : Object *
        e : WordChangedEventArgs -> unit
type WordChangedEventHandler =
    delegate of
        sender : Object *
        e : WordChangedEventArgs -> unit
Parameters
sender (Object)
e (WordChangedEventArgs)


WordIgnoredEventArgs Class

WordIgnoredEventArgs Class
API ► Keyoti.RapidSpell.Wpf ► WordIgnoredEventArgs
Keyoti RapidSpell WPF
Args for the events fired when words are ignored.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class WordIgnoredEventArgs : UndoableStateEventArgs
public class WordIgnoredEventArgs : UndoableStateEventArgs
Public Class WordIgnoredEventArgs
    Inherits UndoableStateEventArgs
Public Class WordIgnoredEventArgs
    Inherits UndoableStateEventArgs
public ref class WordIgnoredEventArgs : public UndoableStateEventArgs
public ref class WordIgnoredEventArgs : public UndoableStateEventArgs
type WordIgnoredEventArgs =
    class
        inherit UndoableStateEventArgs
    end
type WordIgnoredEventArgs =
    class
        inherit UndoableStateEventArgs
    end
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WordIgnoredEventArgs(Boolean, BadWord, Object, RapidSpellChecker..::..State) |
 | All | Whether all instances of the word were ignored.
 | BadWord | The word involved. (Inherited from UndoableStateEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TextBox | The text box object in which the operation was performed, if known.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | UndoableState | The state of RapidSpellChecker (Inherited from UndoableStateEventArgs.)
 | word | The bad word (Inherited from UndoableStateEventArgs.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | UndoableStateEventArgs
 |  |  | WordIgnoredEventArgs


WordIgnoredEventArgs Constructor (all, badWord, textBox, undoableState)

WordIgnoredEventArgs Constructor (all, badWord, textBox, undoableState)
API ► Keyoti.RapidSpell.Wpf ► WordIgnoredEventArgs ► WordIgnoredEventArgs(Boolean, BadWord, Object, RapidSpellChecker..::..State)
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public WordIgnoredEventArgs(
    bool all,
    BadWord badWord,
    Object textBox,
    RapidSpellChecker..::..State undoableState
)
public WordIgnoredEventArgs(
    bool all,
    BadWord badWord,
    Object textBox,
    RapidSpellChecker..::..State undoableState
)
Public Sub New (
    all As Boolean,
    badWord As BadWord,
    textBox As Object,
    undoableState As RapidSpellChecker..::..State
)
Public Sub New (
    all As Boolean,
    badWord As BadWord,
    textBox As Object,
    undoableState As RapidSpellChecker..::..State
)
public:
WordIgnoredEventArgs(
    bool all,
    BadWord^ badWord,
    Object^ textBox,
    RapidSpellChecker..::..State^ undoableState
)
public:
WordIgnoredEventArgs(
    bool all,
    BadWord^ badWord,
    Object^ textBox,
    RapidSpellChecker..::..State^ undoableState
)
new :
        all : bool *
        badWord : BadWord *
        textBox : Object *
        undoableState : RapidSpellChecker..::..State -> WordIgnoredEventArgs
new :
        all : bool *
        badWord : BadWord *
        textBox : Object *
        undoableState : RapidSpellChecker..::..State -> WordIgnoredEventArgs
Parameters
all (Boolean)
badWord (BadWord)
textBox (Object)
undoableState (RapidSpellChecker..::..State)


All Property

All Property
API ► Keyoti.RapidSpell.Wpf ► WordIgnoredEventArgs ► All
Keyoti RapidSpell WPF
Whether all instances of the word were ignored.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool All { get; }
public bool All { get; }
Public ReadOnly Property All As Boolean
    Get
Public ReadOnly Property All As Boolean
    Get
public:
property bool All {
    bool get ();
}
public:
property bool All {
    bool get ();
}
member All : bool with get

member All : bool with get
Property Value
Boolean


TextBox Property

TextBox Property
API ► Keyoti.RapidSpell.Wpf ► WordIgnoredEventArgs ► TextBox
Keyoti RapidSpell WPF
The text box object in which the operation was performed, if known.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Object TextBox { get; }
public Object TextBox { get; }
Public ReadOnly Property TextBox As Object
    Get
Public ReadOnly Property TextBox As Object
    Get
public:
property Object^ TextBox {
    Object^ get ();
}
public:
property Object^ TextBox {
    Object^ get ();
}
member TextBox : Object with get

member TextBox : Object with get
Property Value
Object
Remarks
This is null when the event originates in RapidSpellChecker


WordIgnoredEventHandler Delegate

WordIgnoredEventHandler Delegate
API ► Keyoti.RapidSpell.Wpf ► WordIgnoredEventHandler
Keyoti RapidSpell WPF
Handler delegate
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void WordIgnoredEventHandler(
    Object sender,
    WordIgnoredEventArgs e
)
public delegate void WordIgnoredEventHandler(
    Object sender,
    WordIgnoredEventArgs e
)
Public Delegate Sub WordIgnoredEventHandler (
    sender As Object,
    e As WordIgnoredEventArgs
)
Public Delegate Sub WordIgnoredEventHandler (
    sender As Object,
    e As WordIgnoredEventArgs
)
public delegate void WordIgnoredEventHandler(
    Object^ sender,
    WordIgnoredEventArgs^ e
)
public delegate void WordIgnoredEventHandler(
    Object^ sender,
    WordIgnoredEventArgs^ e
)
type WordIgnoredEventHandler =
    delegate of
        sender : Object *
        e : WordIgnoredEventArgs -> unit
type WordIgnoredEventHandler =
    delegate of
        sender : Object *
        e : WordIgnoredEventArgs -> unit
Parameters
sender (Object)
e (WordIgnoredEventArgs)


WordOccurrence Class

WordOccurrence Class
API ► Keyoti.RapidSpell.Wpf ► WordOccurrence
Keyoti RapidSpell WPF
Represents a word in the text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class WordOccurrence
public class WordOccurrence
Public Class WordOccurrence
Public Class WordOccurrence
public ref class WordOccurrence
public ref class WordOccurrence
type WordOccurrence =  class end
type WordOccurrence =  class end
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WordOccurrence(String, Int32, Int32) | Constructs a BadWord instance.
 | caretEnd | End of word
 | caretStart | Start of word
 | EndPosition | Gets the position of the end of this word in the main text.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetEndPosition()()()() | Gets the position of the end of this word in the main text.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetStartPosition()()()() | Gets the position of the start of this word in the main text.
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GetWord()()()() | Gets the String of this bad word.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | StartPosition | Gets the position of the start of this word in the main text.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Word | Gets the string of this bad word.
Inheritance Hierarchy
Object
 | WordOccurrence
 |  | BadWord


WordOccurrence Constructor (word, caretStart, caretEnd)

WordOccurrence Constructor (word, caretStart, caretEnd)
API ► Keyoti.RapidSpell.Wpf ► WordOccurrence ► WordOccurrence(String, Int32, Int32)
Keyoti RapidSpell WPF
Constructs a BadWord instance.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public WordOccurrence(
    string word,
    int caretStart,
    int caretEnd
)
public WordOccurrence(
    string word,
    int caretStart,
    int caretEnd
)
Public Sub New (
    word As String,
    caretStart As Integer,
    caretEnd As Integer
)
Public Sub New (
    word As String,
    caretStart As Integer,
    caretEnd As Integer
)
public:
WordOccurrence(
    String^ word,
    int caretStart,
    int caretEnd
)
public:
WordOccurrence(
    String^ word,
    int caretStart,
    int caretEnd
)
new :
        word : string *
        caretStart : int *
        caretEnd : int -> WordOccurrence
new :
        word : string *
        caretStart : int *
        caretEnd : int -> WordOccurrence
Parameters
word (String)
the word String that is misspelt
caretStart (Int32)
the position in the original text
caretEnd (Int32)
the end position in the text


caretEnd Field

caretEnd Field
API ► Keyoti.RapidSpell.Wpf ► WordOccurrence ► caretEnd
Keyoti RapidSpell WPF
End of word
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected int caretEnd
protected int caretEnd
Protected caretEnd As Integer
Protected caretEnd As Integer
protected:
int caretEnd
protected:
int caretEnd
val mutable caretEnd: int
val mutable caretEnd: int
Field Value
Int32


caretStart Field

caretStart Field
API ► Keyoti.RapidSpell.Wpf ► WordOccurrence ► caretStart
Keyoti RapidSpell WPF
Start of word
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected int caretStart
protected int caretStart
Protected caretStart As Integer
Protected caretStart As Integer
protected:
int caretStart
protected:
int caretStart
val mutable caretStart: int
val mutable caretStart: int
Field Value
Int32


EndPosition Property

EndPosition Property
API ► Keyoti.RapidSpell.Wpf ► WordOccurrence ► EndPosition
Keyoti RapidSpell WPF
Gets the position of the end of this word in the main text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int EndPosition { get; set; }
public int EndPosition { get; set; }
Public Property EndPosition As Integer
    Get
    Set
Public Property EndPosition As Integer
    Get
    Set
public:
property int EndPosition {
    int get ();
    void set (int value);
}
public:
property int EndPosition {
    int get ();
    void set (int value);
}
member EndPosition : int with get, set

member EndPosition : int with get, set
Property Value
Int32


GetEndPosition Method

GetEndPosition Method
API ► Keyoti.RapidSpell.Wpf ► WordOccurrence ► GetEndPosition()()()()
Keyoti RapidSpell WPF
Gets the position of the end of this word in the main text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int GetEndPosition()
public int GetEndPosition()
Public Function GetEndPosition As Integer
Public Function GetEndPosition As Integer
public:
int GetEndPosition()
public:
int GetEndPosition()
member GetEndPosition : unit -> int

member GetEndPosition : unit -> int
Return Value
Int32
int position in the text where this word ends


GetStartPosition Method

GetStartPosition Method
API ► Keyoti.RapidSpell.Wpf ► WordOccurrence ► GetStartPosition()()()()
Keyoti RapidSpell WPF
Gets the position of the start of this word in the main text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int GetStartPosition()
public int GetStartPosition()
Public Function GetStartPosition As Integer
Public Function GetStartPosition As Integer
public:
int GetStartPosition()
public:
int GetStartPosition()
member GetStartPosition : unit -> int

member GetStartPosition : unit -> int
Return Value
Int32
int position in the text where this word starts.


GetWord Method

GetWord Method
API ► Keyoti.RapidSpell.Wpf ► WordOccurrence ► GetWord()()()()
Keyoti RapidSpell WPF
Gets the String of this bad word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string GetWord()
public string GetWord()
Public Function GetWord As String
Public Function GetWord As String
public:
String^ GetWord()
public:
String^ GetWord()
member GetWord : unit -> string

member GetWord : unit -> string
Return Value
String
String in this BadWord


StartPosition Property

StartPosition Property
API ► Keyoti.RapidSpell.Wpf ► WordOccurrence ► StartPosition
Keyoti RapidSpell WPF
Gets the position of the start of this word in the main text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int StartPosition { get; set; }
public int StartPosition { get; set; }
Public Property StartPosition As Integer
    Get
    Set
Public Property StartPosition As Integer
    Get
    Set
public:
property int StartPosition {
    int get ();
    void set (int value);
}
public:
property int StartPosition {
    int get ();
    void set (int value);
}
member StartPosition : int with get, set

member StartPosition : int with get, set
Property Value
Int32


Word Property

Word Property
API ► Keyoti.RapidSpell.Wpf ► WordOccurrence ► Word
Keyoti RapidSpell WPF
Gets the string of this bad word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string Word { get; set; }
public string Word { get; set; }
Public Property Word As String
    Get
    Set
Public Property Word As String
    Get
    Set
public:
property String^ Word {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Word {
    String^ get ();
    void set (String^ value);
}
member Word : string with get, set

member Word : string with get, set
Property Value
String


WordRemovedEventArgs Class

WordRemovedEventArgs Class
API ► Keyoti.RapidSpell.Wpf ► WordRemovedEventArgs
Keyoti RapidSpell WPF
Args for the events fired when words are removed from the user dictionary.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class WordRemovedEventArgs : EventArgs
public class WordRemovedEventArgs : EventArgs
Public Class WordRemovedEventArgs
    Inherits EventArgs
Public Class WordRemovedEventArgs
    Inherits EventArgs
public ref class WordRemovedEventArgs : public EventArgs
public ref class WordRemovedEventArgs : public EventArgs
type WordRemovedEventArgs =
    class
        inherit EventArgs
    end
type WordRemovedEventArgs =
    class
        inherit EventArgs
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WordRemovedEventArgs(String) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Word | The word that was removed
Inheritance Hierarchy
Object
 | EventArgs
 |  | WordRemovedEventArgs


WordRemovedEventArgs Constructor (word)

WordRemovedEventArgs Constructor (word)
API ► Keyoti.RapidSpell.Wpf ► WordRemovedEventArgs ► WordRemovedEventArgs(String)
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public WordRemovedEventArgs(
    string word
)
public WordRemovedEventArgs(
    string word
)
Public Sub New (
    word As String
)
Public Sub New (
    word As String
)
public:
WordRemovedEventArgs(
    String^ word
)
public:
WordRemovedEventArgs(
    String^ word
)
new :
        word : string -> WordRemovedEventArgs
new :
        word : string -> WordRemovedEventArgs
Parameters
word (String)


Word Property

Word Property
API ► Keyoti.RapidSpell.Wpf ► WordRemovedEventArgs ► Word
Keyoti RapidSpell WPF
The word that was removed
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string Word { get; }
public string Word { get; }
Public ReadOnly Property Word As String
    Get
Public ReadOnly Property Word As String
    Get
public:
property String^ Word {
    String^ get ();
}
public:
property String^ Word {
    String^ get ();
}
member Word : string with get

member Word : string with get
Property Value
String


WordRemovedEventHandler Delegate

WordRemovedEventHandler Delegate
API ► Keyoti.RapidSpell.Wpf ► WordRemovedEventHandler
Keyoti RapidSpell WPF
Handler delegate
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void WordRemovedEventHandler(
    Object sender,
    WordRemovedEventArgs e
)
public delegate void WordRemovedEventHandler(
    Object sender,
    WordRemovedEventArgs e
)
Public Delegate Sub WordRemovedEventHandler (
    sender As Object,
    e As WordRemovedEventArgs
)
Public Delegate Sub WordRemovedEventHandler (
    sender As Object,
    e As WordRemovedEventArgs
)
public delegate void WordRemovedEventHandler(
    Object^ sender,
    WordRemovedEventArgs^ e
)
public delegate void WordRemovedEventHandler(
    Object^ sender,
    WordRemovedEventArgs^ e
)
type WordRemovedEventHandler =
    delegate of
        sender : Object *
        e : WordRemovedEventArgs -> unit
type WordRemovedEventHandler =
    delegate of
        sender : Object *
        e : WordRemovedEventArgs -> unit
Parameters
sender (Object)
e (WordRemovedEventArgs)


WpfBaseAdapter Class

WpfBaseAdapter Class
API ► Keyoti.RapidSpell.Wpf ► WpfBaseAdapter
Keyoti RapidSpell WPF
Base support for internal text box wrappers.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public abstract class WpfBaseAdapter
public abstract class WpfBaseAdapter
Public MustInherit Class WpfBaseAdapter
Public MustInherit Class WpfBaseAdapter
public ref class WpfBaseAdapter abstract
public ref class WpfBaseAdapter abstract
[<AbstractClassAttribute>]
type WpfBaseAdapter =  class end
[<AbstractClassAttribute>]
type WpfBaseAdapter =  class end
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WpfBaseAdapter()()()() |
 | Create(TextBox, Boolean, LanguageType) | Creates a wrapper for the textbox
 | Create(RichTextBox, Boolean, LanguageType) | Creates a wrapper for the textbox
 | Create(TextBoxBase, Boolean, LanguageType) | Creates a wrapper for the textbox
 | CreateErrorAdorner(Int32, Int32, UnderlineStyle, Color) | Creates an adorner
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | theWrappedTextBox | The wrapped text box
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | WrappedTextBox | The wrapped text box
Inheritance Hierarchy
Object
 | WpfBaseAdapter
 |  | WpfRichTextBoxAdapter
 |  | WpfTextBoxAdapter


WpfBaseAdapter Constructor

WpfBaseAdapter Constructor
API ► Keyoti.RapidSpell.Wpf ► WpfBaseAdapter ► WpfBaseAdapter()()()()
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected WpfBaseAdapter()
protected WpfBaseAdapter()
Protected Sub New
Protected Sub New
protected:
WpfBaseAdapter()
protected:
WpfBaseAdapter()
new : unit -> WpfBaseAdapter
new : unit -> WpfBaseAdapter


Create Method

Create Method
API ► Keyoti.RapidSpell.Wpf ► WpfBaseAdapter ► Create()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | Create(TextBox, Boolean, LanguageType) | Creates a wrapper for the textbox
 | Create(RichTextBox, Boolean, LanguageType) | Creates a wrapper for the textbox
 | Create(TextBoxBase, Boolean, LanguageType) | Creates a wrapper for the textbox


Create Method (tb, showCutCopyPasteMenuOnTextBoxBase, guiLanguage)

Create Method (tb, showCutCopyPasteMenuOnTextBoxBase, guiLanguage)
API ► Keyoti.RapidSpell.Wpf ► WpfBaseAdapter ► Create(TextBoxBase, Boolean, LanguageType)
Keyoti RapidSpell WPF
Creates a wrapper for the textbox
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static WpfBaseAdapter Create(
    TextBoxBase tb,
    bool showCutCopyPasteMenuOnTextBoxBase,
    LanguageType guiLanguage
)
public static WpfBaseAdapter Create(
    TextBoxBase tb,
    bool showCutCopyPasteMenuOnTextBoxBase,
    LanguageType guiLanguage
)
Public Shared Function Create (
    tb As TextBoxBase,
    showCutCopyPasteMenuOnTextBoxBase As Boolean,
    guiLanguage As LanguageType
) As WpfBaseAdapter
Public Shared Function Create (
    tb As TextBoxBase,
    showCutCopyPasteMenuOnTextBoxBase As Boolean,
    guiLanguage As LanguageType
) As WpfBaseAdapter
public:
static WpfBaseAdapter^ Create(
    TextBoxBase^ tb,
    bool showCutCopyPasteMenuOnTextBoxBase,
    LanguageType guiLanguage
)
public:
static WpfBaseAdapter^ Create(
    TextBoxBase^ tb,
    bool showCutCopyPasteMenuOnTextBoxBase,
    LanguageType guiLanguage
)
static member Create :
        tb : TextBoxBase *
        showCutCopyPasteMenuOnTextBoxBase : bool *
        guiLanguage : LanguageType -> WpfBaseAdapter

static member Create :
        tb : TextBoxBase *
        showCutCopyPasteMenuOnTextBoxBase : bool *
        guiLanguage : LanguageType -> WpfBaseAdapter
Parameters
tb (TextBoxBase)
showCutCopyPasteMenuOnTextBoxBase (Boolean)
guiLanguage (LanguageType)
Return Value
WpfBaseAdapter


Create Method (tb, showCutCopyPasteMenuOnTextBoxBase, guiLanguage)

Create Method (tb, showCutCopyPasteMenuOnTextBoxBase, guiLanguage)
API ► Keyoti.RapidSpell.Wpf ► WpfBaseAdapter ► Create(RichTextBox, Boolean, LanguageType)
Keyoti RapidSpell WPF
Creates a wrapper for the textbox
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static WpfBaseAdapter Create(
    RichTextBox tb,
    bool showCutCopyPasteMenuOnTextBoxBase,
    LanguageType guiLanguage
)
public static WpfBaseAdapter Create(
    RichTextBox tb,
    bool showCutCopyPasteMenuOnTextBoxBase,
    LanguageType guiLanguage
)
Public Shared Function Create (
    tb As RichTextBox,
    showCutCopyPasteMenuOnTextBoxBase As Boolean,
    guiLanguage As LanguageType
) As WpfBaseAdapter
Public Shared Function Create (
    tb As RichTextBox,
    showCutCopyPasteMenuOnTextBoxBase As Boolean,
    guiLanguage As LanguageType
) As WpfBaseAdapter
public:
static WpfBaseAdapter^ Create(
    RichTextBox^ tb,
    bool showCutCopyPasteMenuOnTextBoxBase,
    LanguageType guiLanguage
)
public:
static WpfBaseAdapter^ Create(
    RichTextBox^ tb,
    bool showCutCopyPasteMenuOnTextBoxBase,
    LanguageType guiLanguage
)
static member Create :
        tb : RichTextBox *
        showCutCopyPasteMenuOnTextBoxBase : bool *
        guiLanguage : LanguageType -> WpfBaseAdapter

static member Create :
        tb : RichTextBox *
        showCutCopyPasteMenuOnTextBoxBase : bool *
        guiLanguage : LanguageType -> WpfBaseAdapter
Parameters
tb (RichTextBox)
showCutCopyPasteMenuOnTextBoxBase (Boolean)
guiLanguage (LanguageType)
Return Value
WpfBaseAdapter


Create Method (tb, showCutCopyPasteMenuOnTextBoxBase, guiLanguage)

Create Method (tb, showCutCopyPasteMenuOnTextBoxBase, guiLanguage)
API ► Keyoti.RapidSpell.Wpf ► WpfBaseAdapter ► Create(TextBox, Boolean, LanguageType)
Keyoti RapidSpell WPF
Creates a wrapper for the textbox
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static WpfBaseAdapter Create(
    TextBox tb,
    bool showCutCopyPasteMenuOnTextBoxBase,
    LanguageType guiLanguage
)
public static WpfBaseAdapter Create(
    TextBox tb,
    bool showCutCopyPasteMenuOnTextBoxBase,
    LanguageType guiLanguage
)
Public Shared Function Create (
    tb As TextBox,
    showCutCopyPasteMenuOnTextBoxBase As Boolean,
    guiLanguage As LanguageType
) As WpfBaseAdapter
Public Shared Function Create (
    tb As TextBox,
    showCutCopyPasteMenuOnTextBoxBase As Boolean,
    guiLanguage As LanguageType
) As WpfBaseAdapter
public:
static WpfBaseAdapter^ Create(
    TextBox^ tb,
    bool showCutCopyPasteMenuOnTextBoxBase,
    LanguageType guiLanguage
)
public:
static WpfBaseAdapter^ Create(
    TextBox^ tb,
    bool showCutCopyPasteMenuOnTextBoxBase,
    LanguageType guiLanguage
)
static member Create :
        tb : TextBox *
        showCutCopyPasteMenuOnTextBoxBase : bool *
        guiLanguage : LanguageType -> WpfBaseAdapter

static member Create :
        tb : TextBox *
        showCutCopyPasteMenuOnTextBoxBase : bool *
        guiLanguage : LanguageType -> WpfBaseAdapter
Parameters
tb (TextBox)
showCutCopyPasteMenuOnTextBoxBase (Boolean)
guiLanguage (LanguageType)
Return Value
WpfBaseAdapter


CreateErrorAdorner Method (start, end, u, c)

CreateErrorAdorner Method (start, end, u, c)
API ► Keyoti.RapidSpell.Wpf ► WpfBaseAdapter ► CreateErrorAdorner(Int32, Int32, UnderlineStyle, Color)
Keyoti RapidSpell WPF
Creates an adorner
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public abstract ErrorAdornerBase CreateErrorAdorner(
    int start,
    int end,
    UnderlineStyle u,
    Color c
)
public abstract ErrorAdornerBase CreateErrorAdorner(
    int start,
    int end,
    UnderlineStyle u,
    Color c
)
Public MustOverride Function CreateErrorAdorner (
    start As Integer,
    end As Integer,
    u As UnderlineStyle,
    c As Color
) As ErrorAdornerBase
Public MustOverride Function CreateErrorAdorner (
    start As Integer,
    end As Integer,
    u As UnderlineStyle,
    c As Color
) As ErrorAdornerBase
public:
virtual ErrorAdornerBase^ CreateErrorAdorner(
    int start,
    int end,
    UnderlineStyle u,
    Color c
) abstract
public:
virtual ErrorAdornerBase^ CreateErrorAdorner(
    int start,
    int end,
    UnderlineStyle u,
    Color c
) abstract
abstract CreateErrorAdorner :
        start : int *
        end : int *
        u : UnderlineStyle *
        c : Color -> ErrorAdornerBase

abstract CreateErrorAdorner :
        start : int *
        end : int *
        u : UnderlineStyle *
        c : Color -> ErrorAdornerBase
Parameters
start (Int32)
end (Int32)
u (UnderlineStyle)
c (Color)
Return Value
ErrorAdornerBase


theWrappedTextBox Field

theWrappedTextBox Field
API ► Keyoti.RapidSpell.Wpf ► WpfBaseAdapter ► theWrappedTextBox
Keyoti RapidSpell WPF
The wrapped text box
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected TextBoxBase theWrappedTextBox
protected TextBoxBase theWrappedTextBox
Protected theWrappedTextBox As TextBoxBase
Protected theWrappedTextBox As TextBoxBase
protected:
TextBoxBase^ theWrappedTextBox
protected:
TextBoxBase^ theWrappedTextBox
val mutable theWrappedTextBox: TextBoxBase
val mutable theWrappedTextBox: TextBoxBase
Field Value
TextBoxBase


WrappedTextBox Property

WrappedTextBox Property
API ► Keyoti.RapidSpell.Wpf ► WpfBaseAdapter ► WrappedTextBox
Keyoti RapidSpell WPF
The wrapped text box
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public TextBoxBase WrappedTextBox { get; }
public TextBoxBase WrappedTextBox { get; }
Public ReadOnly Property WrappedTextBox As TextBoxBase
    Get
Public ReadOnly Property WrappedTextBox As TextBoxBase
    Get
public:
property TextBoxBase^ WrappedTextBox {
    TextBoxBase^ get ();
}
public:
property TextBoxBase^ WrappedTextBox {
    TextBoxBase^ get ();
}
member WrappedTextBox : TextBoxBase with get

member WrappedTextBox : TextBoxBase with get
Property Value
TextBoxBase


WpfRichTextBoxAdapter Class

WpfRichTextBoxAdapter Class
API ► Keyoti.RapidSpell.Wpf ► WpfRichTextBoxAdapter
Keyoti RapidSpell WPF
Used (primarily internally) to wrap the RichTextBox control with required interfaces for spell checking.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
[SerializableAttribute]
public class WpfRichTextBoxAdapter : WpfBaseAdapter,
    ISpellCheckableTextComponent, IAYTTextBox
[SerializableAttribute]
public class WpfRichTextBoxAdapter : WpfBaseAdapter,
    ISpellCheckableTextComponent, IAYTTextBox
<SerializableAttribute>
Public Class WpfRichTextBoxAdapter
    Inherits WpfBaseAdapter
    Implements ISpellCheckableTextComponent, IAYTTextBox
<SerializableAttribute>
Public Class WpfRichTextBoxAdapter
    Inherits WpfBaseAdapter
    Implements ISpellCheckableTextComponent, IAYTTextBox
[SerializableAttribute]
public ref class WpfRichTextBoxAdapter : public WpfBaseAdapter,
    ISpellCheckableTextComponent, IAYTTextBox
[SerializableAttribute]
public ref class WpfRichTextBoxAdapter : public WpfBaseAdapter,
    ISpellCheckableTextComponent, IAYTTextBox
[<SerializableAttribute>]
type WpfRichTextBoxAdapter =
    class
        inherit WpfBaseAdapter
        interface ISpellCheckableTextComponent
        interface IAYTTextBox
    end
[<SerializableAttribute>]
type WpfRichTextBoxAdapter =
    class
        inherit WpfBaseAdapter
        interface ISpellCheckableTextComponent
        interface IAYTTextBox
    end
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WpfRichTextBoxAdapter(RichTextBox, Boolean, LanguageType) | Creates a new proxy with a TextBoxBase
 | CaretPosition | The caret position
 | ContextMenu | The context menu that will be shown when the right click is not on a misspelled word.
 | ContextMenuDefault | The context menu that will be shown when the right click is not on a misspelled word.
 | ContextMenuOpening | Context menu opening event
 | CreateErrorAdorner(Int32, Int32, UnderlineStyle, Color) | Creates an adorner (Overrides WpfBaseAdapter.CreateErrorAdorner(Int32, Int32, UnderlineStyle, Color).)
 | Dispose()()()() | Cleans up resources
 | Disposed | Disposed event
 | Enabled | Whether text box is enabled
 | Equals(Object) | Whether this adapter is wrapping same text box as 'obj' (Overrides Object.Equals(Object).)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaselineOffsetAtCharIndex(Int32) | Not implemented in WPF
 | GetCharIndexFromPos(Point) | Gets the character index of a Point
 | GetHashCode()()()() | Gets the hash code. (Overrides Object.GetHashCode()()()().)
 | GetPointerAtIndex(Int32, Int32) | Gets TextPointers at two close indexes.
 | GetPosFromCharIndex(Int32) | Gets the Point of a char index.
 | GetPosFromCharIndex2(Int32) | Gets a character rectangle around an char at index.
 | GetTBU()()()() | Interface requirement
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GotFocus | Textbox GotFocus
 | Height | Gets or sets the height of the control.
 | HideSelection | Not implemented
 | IsAtWordBoundaryRight | Returns whether the caret is at a right hand word boundary.
 | IsEnabledChanged | IsEnabledChanged event
 | IsFocused | Whether the textbox is focused.
 | KeyDown | KeyDown event
 | KeyUp | KeyUp event
 | LostFocus | Textbox LostFocus
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MouseDown | MouseDown event
 | MouseUp | MouseUp event
 | ReadOnly | Whether text box is readonly
 | Refresh()()()() | Refresh the underlines
 | ScrollToCaret()()()() | Scrolls the textbox to the caret
 | Select(Int32, Int32) | Selects a region of text.
 | SelectedText | The selected text.
 | SelectionAdorner | The highlighter used to highlight errors.
 | SelectionEnd | Selection end
 | SelectionLength | Selection length
 | SelectionStart | Selection start
 | Text | The text in the RichTextBox
 | TextChanged | Fired when text changes
 | TextControl | The wrapped text box.
 | TextLength | Text length
 | theWrappedTextBox | The wrapped text box (Inherited from WpfBaseAdapter.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Width | Gets or sets the width of the control.
 | WrappedTextBox | The wrapped text box (Inherited from WpfBaseAdapter.)
Inheritance Hierarchy
Object
 | WpfBaseAdapter
 |  | WpfRichTextBoxAdapter


WpfRichTextBoxAdapter Constructor (textBox, createCutCopyPasteReplacement, guiLanguage)

WpfRichTextBoxAdapter Constructor (textBox, createCutCopyPasteReplacement, guiLanguage)
API ► Keyoti.RapidSpell.Wpf ► WpfRichTextBoxAdapter ► WpfRichTextBoxAdapter(RichTextBox, Boolean, LanguageType)
Keyoti RapidSpell WPF
Creates a new proxy with a TextBoxBase
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public WpfRichTextBoxAdapter(
    RichTextBox textBox,
    bool createCutCopyPasteReplacement,
    LanguageType guiLanguage
)
public WpfRichTextBoxAdapter(
    RichTextBox textBox,
    bool createCutCopyPasteReplacement,
    LanguageType guiLanguage
)
Public Sub New (
    textBox As RichTextBox,
    createCutCopyPasteReplacement As Boolean,
    guiLanguage As LanguageType
)
Public Sub New (
    textBox As RichTextBox,
    createCutCopyPasteReplacement As Boolean,
    guiLanguage As LanguageType
)
public:
WpfRichTextBoxAdapter(
    RichTextBox^ textBox,
    bool createCutCopyPasteReplacement,
    LanguageType guiLanguage
)
public:
WpfRichTextBoxAdapter(
    RichTextBox^ textBox,
    bool createCutCopyPasteReplacement,
    LanguageType guiLanguage
)
new :
        textBox : RichTextBox *
        createCutCopyPasteReplacement : bool *
        guiLanguage : LanguageType -> WpfRichTextBoxAdapter
new :
        textBox : RichTextBox *
        createCutCopyPasteReplacement : bool *
        guiLanguage : LanguageType -> WpfRichTextBoxAdapter
Parameters
textBox (RichTextBox)
createCutCopyPasteReplacement (Boolean)
guiLanguage (LanguageType)


CaretPosition Property

CaretPosition Property
API ► Keyoti.RapidSpell.Wpf ► WpfRichTextBoxAdapter ► CaretPosition
Keyoti RapidSpell WPF
The caret position
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int CaretPosition { get; set; }
public int CaretPosition { get; set; }
Public Property CaretPosition As Integer
    Get
    Set
Public Property CaretPosition As Integer
    Get
    Set
public:
virtual property int CaretPosition {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int CaretPosition {
    int get () sealed;
    void set (int value) sealed;
}
abstract CaretPosition : int with get, set
override CaretPosition : int with get, set
abstract CaretPosition : int with get, set
override CaretPosition : int with get, set
Property Value
Int32


ContextMenu Property

ContextMenu Property
API ► Keyoti.RapidSpell.Wpf ► WpfRichTextBoxAdapter ► ContextMenu
Keyoti RapidSpell WPF
The context menu that will be shown when the right click is not on a misspelled word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ContextMenu ContextMenu { get; set; }
public ContextMenu ContextMenu { get; set; }
Public Property ContextMenu As ContextMenu
    Get
    Set
Public Property ContextMenu As ContextMenu
    Get
    Set
public:
virtual property ContextMenu^ ContextMenu {
    ContextMenu^ get () sealed;
    void set (ContextMenu^ value) sealed;
}
public:
virtual property ContextMenu^ ContextMenu {
    ContextMenu^ get () sealed;
    void set (ContextMenu^ value) sealed;
}
abstract ContextMenu : ContextMenu with get, set
override ContextMenu : ContextMenu with get, set
abstract ContextMenu : ContextMenu with get, set
override ContextMenu : ContextMenu with get, set
Property Value
ContextMenu


ContextMenuDefault Property

ContextMenuDefault Property
API ► Keyoti.RapidSpell.Wpf ► WpfRichTextBoxAdapter ► ContextMenuDefault
Keyoti RapidSpell WPF
The context menu that will be shown when the right click is not on a misspelled word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ContextMenu ContextMenuDefault { get; set; }
public ContextMenu ContextMenuDefault { get; set; }
Public Property ContextMenuDefault As ContextMenu
    Get
    Set
Public Property ContextMenuDefault As ContextMenu
    Get
    Set
public:
virtual property ContextMenu^ ContextMenuDefault {
    ContextMenu^ get () sealed;
    void set (ContextMenu^ value) sealed;
}
public:
virtual property ContextMenu^ ContextMenuDefault {
    ContextMenu^ get () sealed;
    void set (ContextMenu^ value) sealed;
}
abstract ContextMenuDefault : ContextMenu with get, set
override ContextMenuDefault : ContextMenu with get, set
abstract ContextMenuDefault : ContextMenu with get, set
override ContextMenuDefault : ContextMenu with get, set
Property Value
ContextMenu


ContextMenuOpening Event

ContextMenuOpening Event
API ► Keyoti.RapidSpell.Wpf ► WpfRichTextBoxAdapter ► ContextMenuOpening
Keyoti RapidSpell WPF
Context menu opening event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event ContextMenuEventHandler ContextMenuOpening
public event ContextMenuEventHandler ContextMenuOpening
Public Event ContextMenuOpening As ContextMenuEventHandler
Public Event ContextMenuOpening As ContextMenuEventHandler
public:
virtual  event ContextMenuEventHandler^ ContextMenuOpening {
    void add (ContextMenuEventHandler^ value);
    void remove (ContextMenuEventHandler^ value);
}
public:
virtual  event ContextMenuEventHandler^ ContextMenuOpening {
    void add (ContextMenuEventHandler^ value);
    void remove (ContextMenuEventHandler^ value);
}
abstract ContextMenuOpening : IEvent<ContextMenuEventHandler,
    ContextMenuEventArgs>
override ContextMenuOpening : IEvent<ContextMenuEventHandler,
    ContextMenuEventArgs>
abstract ContextMenuOpening : IEvent<ContextMenuEventHandler,
    ContextMenuEventArgs>
override ContextMenuOpening : IEvent<ContextMenuEventHandler,
    ContextMenuEventArgs>
Value
ContextMenuEventHandler


CreateErrorAdorner Method (start, end, u, c)

CreateErrorAdorner Method (start, end, u, c)
API ► Keyoti.RapidSpell.Wpf ► WpfRichTextBoxAdapter ► CreateErrorAdorner(Int32, Int32, UnderlineStyle, Color)
Keyoti RapidSpell WPF
Creates an adorner
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override ErrorAdornerBase CreateErrorAdorner(
    int start,
    int end,
    UnderlineStyle u,
    Color c
)
public override ErrorAdornerBase CreateErrorAdorner(
    int start,
    int end,
    UnderlineStyle u,
    Color c
)
Public Overrides Function CreateErrorAdorner (
    start As Integer,
    end As Integer,
    u As UnderlineStyle,
    c As Color
) As ErrorAdornerBase
Public Overrides Function CreateErrorAdorner (
    start As Integer,
    end As Integer,
    u As UnderlineStyle,
    c As Color
) As ErrorAdornerBase
public:
virtual ErrorAdornerBase^ CreateErrorAdorner(
    int start,
    int end,
    UnderlineStyle u,
    Color c
) override
public:
virtual ErrorAdornerBase^ CreateErrorAdorner(
    int start,
    int end,
    UnderlineStyle u,
    Color c
) override
abstract CreateErrorAdorner :
        start : int *
        end : int *
        u : UnderlineStyle *
        c : Color -> ErrorAdornerBase
override CreateErrorAdorner :
        start : int *
        end : int *
        u : UnderlineStyle *
        c : Color -> ErrorAdornerBase
abstract CreateErrorAdorner :
        start : int *
        end : int *
        u : UnderlineStyle *
        c : Color -> ErrorAdornerBase
override CreateErrorAdorner :
        start : int *
        end : int *
        u : UnderlineStyle *
        c : Color -> ErrorAdornerBase
Parameters
start (Int32)
end (Int32)
u (UnderlineStyle)
c (Color)
Return Value
ErrorAdornerBase


Dispose Method

Dispose Method
API ► Keyoti.RapidSpell.Wpf ► WpfRichTextBoxAdapter ► Dispose()()()()
Keyoti RapidSpell WPF
Cleans up resources
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void Dispose()
public void Dispose()
Public Sub Dispose
Public Sub Dispose
public:
virtual void Dispose() sealed
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit
abstract Dispose : unit -> unit
override Dispose : unit -> unit


Disposed Event

Disposed Event
API ► Keyoti.RapidSpell.Wpf ► WpfRichTextBoxAdapter ► Disposed
Keyoti RapidSpell WPF
Disposed event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler Disposed
public event EventHandler Disposed
Public Event Disposed As EventHandler
Public Event Disposed As EventHandler
public:
virtual  event EventHandler^ Disposed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ Disposed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Disposed : IEvent<EventHandler,
    EventArgs>
override Disposed : IEvent<EventHandler,
    EventArgs>
abstract Disposed : IEvent<EventHandler,
    EventArgs>
override Disposed : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


Enabled Property

Enabled Property
API ► Keyoti.RapidSpell.Wpf ► WpfRichTextBoxAdapter ► Enabled
Keyoti RapidSpell WPF
Whether text box is enabled
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool Enabled { get; }
public bool Enabled { get; }
Public ReadOnly Property Enabled As Boolean
    Get
Public ReadOnly Property Enabled As Boolean
    Get
public:
virtual property bool Enabled {
    bool get () sealed;
}
public:
virtual property bool Enabled {
    bool get () sealed;
}
abstract Enabled : bool with get
override Enabled : bool with get
abstract Enabled : bool with get
override Enabled : bool with get
Property Value
Boolean


Equals Method (obj)

Equals Method (obj)
API ► Keyoti.RapidSpell.Wpf ► WpfRichTextBoxAdapter ► Equals(Object)
Keyoti RapidSpell WPF
Whether this adapter is wrapping same text box as 'obj'
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
Parameters
obj (Object)
Return Value
Boolean


GetBaselineOffsetAtCharIndex Method (index)

GetBaselineOffsetAtCharIndex Method (index)
API ► Keyoti.RapidSpell.Wpf ► WpfRichTextBoxAdapter ► GetBaselineOffsetAtCharIndex(Int32)
Keyoti RapidSpell WPF
Not implemented in WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int GetBaselineOffsetAtCharIndex(
    int index
)
public int GetBaselineOffsetAtCharIndex(
    int index
)
Public Function GetBaselineOffsetAtCharIndex (
    index As Integer
) As Integer
Public Function GetBaselineOffsetAtCharIndex (
    index As Integer
) As Integer
public:
virtual int GetBaselineOffsetAtCharIndex(
    int index
) sealed
public:
virtual int GetBaselineOffsetAtCharIndex(
    int index
) sealed
abstract GetBaselineOffsetAtCharIndex :
        index : int -> int
override GetBaselineOffsetAtCharIndex :
        index : int -> int
abstract GetBaselineOffsetAtCharIndex :
        index : int -> int
override GetBaselineOffsetAtCharIndex :
        index : int -> int
Parameters
index (Int32)
Return Value
Int32


GetCharIndexFromPos Method (pos)

GetCharIndexFromPos Method (pos)
API ► Keyoti.RapidSpell.Wpf ► WpfRichTextBoxAdapter ► GetCharIndexFromPos(Point)
Keyoti RapidSpell WPF
Gets the character index of a Point
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int GetCharIndexFromPos(
    Point pos
)
public int GetCharIndexFromPos(
    Point pos
)
Public Function GetCharIndexFromPos (
    pos As Point
) As Integer
Public Function GetCharIndexFromPos (
    pos As Point
) As Integer
public:
virtual int GetCharIndexFromPos(
    Point pos
) sealed
public:
virtual int GetCharIndexFromPos(
    Point pos
) sealed
abstract GetCharIndexFromPos :
        pos : Point -> int
override GetCharIndexFromPos :
        pos : Point -> int
abstract GetCharIndexFromPos :
        pos : Point -> int
override GetCharIndexFromPos :
        pos : Point -> int
Parameters
pos (Point)
Return Value
Int32


GetHashCode Method

GetHashCode Method
API ► Keyoti.RapidSpell.Wpf ► WpfRichTextBoxAdapter ► GetHashCode()()()()
Keyoti RapidSpell WPF
Gets the hash code.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
Return Value
Int32


GetPointerAtIndex Method (ind1, ind2)

GetPointerAtIndex Method (ind1, ind2)
API ► Keyoti.RapidSpell.Wpf ► WpfRichTextBoxAdapter ► GetPointerAtIndex(Int32, Int32)
Keyoti RapidSpell WPF
Gets TextPointers at two close indexes.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public TextPointer[] GetPointerAtIndex(
    int ind1,
    int ind2
)
public TextPointer[] GetPointerAtIndex(
    int ind1,
    int ind2
)
Public Function GetPointerAtIndex (
    ind1 As Integer,
    ind2 As Integer
) As TextPointer()
Public Function GetPointerAtIndex (
    ind1 As Integer,
    ind2 As Integer
) As TextPointer()
public:
array<TextPointer^>^ GetPointerAtIndex(
    int ind1,
    int ind2
)
public:
array<TextPointer^>^ GetPointerAtIndex(
    int ind1,
    int ind2
)
member GetPointerAtIndex :
        ind1 : int *
        ind2 : int -> TextPointer[]

member GetPointerAtIndex :
        ind1 : int *
        ind2 : int -> TextPointer[]
Parameters
ind1 (Int32)
ind2 (Int32)
Return Value
array<TextPointer>[]()[][]


GetPosFromCharIndex Method (index)

GetPosFromCharIndex Method (index)
API ► Keyoti.RapidSpell.Wpf ► WpfRichTextBoxAdapter ► GetPosFromCharIndex(Int32)
Keyoti RapidSpell WPF
Gets the Point of a char index.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Point GetPosFromCharIndex(
    int index
)
public Point GetPosFromCharIndex(
    int index
)
Public Function GetPosFromCharIndex (
    index As Integer
) As Point
Public Function GetPosFromCharIndex (
    index As Integer
) As Point
public:
virtual Point GetPosFromCharIndex(
    int index
) sealed
public:
virtual Point GetPosFromCharIndex(
    int index
) sealed
abstract GetPosFromCharIndex :
        index : int -> Point
override GetPosFromCharIndex :
        index : int -> Point
abstract GetPosFromCharIndex :
        index : int -> Point
override GetPosFromCharIndex :
        index : int -> Point
Parameters
index (Int32)
Return Value
Point


GetPosFromCharIndex2 Method (index)

GetPosFromCharIndex2 Method (index)
API ► Keyoti.RapidSpell.Wpf ► WpfRichTextBoxAdapter ► GetPosFromCharIndex2(Int32)
Keyoti RapidSpell WPF
Gets a character rectangle around an char at index.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Rect GetPosFromCharIndex2(
    int index
)
public Rect GetPosFromCharIndex2(
    int index
)
Public Function GetPosFromCharIndex2 (
    index As Integer
) As Rect
Public Function GetPosFromCharIndex2 (
    index As Integer
) As Rect
public:
Rect GetPosFromCharIndex2(
    int index
)
public:
Rect GetPosFromCharIndex2(
    int index
)
member GetPosFromCharIndex2 :
        index : int -> Rect

member GetPosFromCharIndex2 :
        index : int -> Rect
Parameters
index (Int32)
Return Value
Rect


GetTBU Method

GetTBU Method
API ► Keyoti.RapidSpell.Wpf ► WpfRichTextBoxAdapter ► GetTBU()()()()
Keyoti RapidSpell WPF
Interface requirement
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public WpfTextBoxBaseUtilityAdapter GetTBU()
public WpfTextBoxBaseUtilityAdapter GetTBU()
Public Function GetTBU As WpfTextBoxBaseUtilityAdapter
Public Function GetTBU As WpfTextBoxBaseUtilityAdapter
public:
virtual WpfTextBoxBaseUtilityAdapter^ GetTBU() sealed
public:
virtual WpfTextBoxBaseUtilityAdapter^ GetTBU() sealed
abstract GetTBU : unit -> WpfTextBoxBaseUtilityAdapter
override GetTBU : unit -> WpfTextBoxBaseUtilityAdapter
abstract GetTBU : unit -> WpfTextBoxBaseUtilityAdapter
override GetTBU : unit -> WpfTextBoxBaseUtilityAdapter
Return Value
WpfTextBoxBaseUtilityAdapter


GotFocus Event

GotFocus Event
API ► Keyoti.RapidSpell.Wpf ► WpfRichTextBoxAdapter ► GotFocus
Keyoti RapidSpell WPF
Textbox GotFocus
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event RoutedEventHandler GotFocus
public event RoutedEventHandler GotFocus
Public Event GotFocus As RoutedEventHandler
Public Event GotFocus As RoutedEventHandler
public:
virtual  event RoutedEventHandler^ GotFocus {
    void add (RoutedEventHandler^ value);
    void remove (RoutedEventHandler^ value);
}
public:
virtual  event RoutedEventHandler^ GotFocus {
    void add (RoutedEventHandler^ value);
    void remove (RoutedEventHandler^ value);
}
abstract GotFocus : IEvent<RoutedEventHandler,
    RoutedEventArgs>
override GotFocus : IEvent<RoutedEventHandler,
    RoutedEventArgs>
abstract GotFocus : IEvent<RoutedEventHandler,
    RoutedEventArgs>
override GotFocus : IEvent<RoutedEventHandler,
    RoutedEventArgs>
Value
RoutedEventHandler


Height Property

Height Property
API ► Keyoti.RapidSpell.Wpf ► WpfRichTextBoxAdapter ► Height
Keyoti RapidSpell WPF
Gets or sets the height of the control.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int Height { get; set; }
public int Height { get; set; }
Public Property Height As Integer
    Get
    Set
Public Property Height As Integer
    Get
    Set
public:
virtual property int Height {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int Height {
    int get () sealed;
    void set (int value) sealed;
}
abstract Height : int with get, set
override Height : int with get, set
abstract Height : int with get, set
override Height : int with get, set
Property Value
Int32


HideSelection Property

HideSelection Property
API ► Keyoti.RapidSpell.Wpf ► WpfRichTextBoxAdapter ► HideSelection
Keyoti RapidSpell WPF
Not implemented
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool HideSelection { get; set; }
public bool HideSelection { get; set; }
Public Property HideSelection As Boolean
    Get
    Set
Public Property HideSelection As Boolean
    Get
    Set
public:
virtual property bool HideSelection {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool HideSelection {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract HideSelection : bool with get, set
override HideSelection : bool with get, set
abstract HideSelection : bool with get, set
override HideSelection : bool with get, set
Property Value
Boolean


IsAtWordBoundaryRight Property

IsAtWordBoundaryRight Property
API ► Keyoti.RapidSpell.Wpf ► WpfRichTextBoxAdapter ► IsAtWordBoundaryRight
Keyoti RapidSpell WPF
Returns whether the caret is at a right hand word boundary.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IsAtWordBoundaryRight { get; }
public bool IsAtWordBoundaryRight { get; }
Public ReadOnly Property IsAtWordBoundaryRight As Boolean
    Get
Public ReadOnly Property IsAtWordBoundaryRight As Boolean
    Get
public:
virtual property bool IsAtWordBoundaryRight {
    bool get () sealed;
}
public:
virtual property bool IsAtWordBoundaryRight {
    bool get () sealed;
}
abstract IsAtWordBoundaryRight : bool with get
override IsAtWordBoundaryRight : bool with get
abstract IsAtWordBoundaryRight : bool with get
override IsAtWordBoundaryRight : bool with get
Property Value
Boolean


IsEnabledChanged Event

IsEnabledChanged Event
API ► Keyoti.RapidSpell.Wpf ► WpfRichTextBoxAdapter ► IsEnabledChanged
Keyoti RapidSpell WPF
IsEnabledChanged event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler IsEnabledChanged
public event EventHandler IsEnabledChanged
Public Event IsEnabledChanged As EventHandler
Public Event IsEnabledChanged As EventHandler
public:
virtual  event EventHandler^ IsEnabledChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ IsEnabledChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract IsEnabledChanged : IEvent<EventHandler,
    EventArgs>
override IsEnabledChanged : IEvent<EventHandler,
    EventArgs>
abstract IsEnabledChanged : IEvent<EventHandler,
    EventArgs>
override IsEnabledChanged : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


IsFocused Property

IsFocused Property
API ► Keyoti.RapidSpell.Wpf ► WpfRichTextBoxAdapter ► IsFocused
Keyoti RapidSpell WPF
Whether the textbox is focused.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IsFocused { get; }
public bool IsFocused { get; }
Public ReadOnly Property IsFocused As Boolean
    Get
Public ReadOnly Property IsFocused As Boolean
    Get
public:
virtual property bool IsFocused {
    bool get () sealed;
}
public:
virtual property bool IsFocused {
    bool get () sealed;
}
abstract IsFocused : bool with get
override IsFocused : bool with get
abstract IsFocused : bool with get
override IsFocused : bool with get
Property Value
Boolean


KeyDown Event

KeyDown Event
API ► Keyoti.RapidSpell.Wpf ► WpfRichTextBoxAdapter ► KeyDown
Keyoti RapidSpell WPF
KeyDown event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event KeyEventHandler KeyDown
public event KeyEventHandler KeyDown
Public Event KeyDown As KeyEventHandler
Public Event KeyDown As KeyEventHandler
public:
virtual  event KeyEventHandler^ KeyDown {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}
public:
virtual  event KeyEventHandler^ KeyDown {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}
abstract KeyDown : IEvent<KeyEventHandler,
    KeyEventArgs>
override KeyDown : IEvent<KeyEventHandler,
    KeyEventArgs>
abstract KeyDown : IEvent<KeyEventHandler,
    KeyEventArgs>
override KeyDown : IEvent<KeyEventHandler,
    KeyEventArgs>
Value
KeyEventHandler


KeyUp Event

KeyUp Event
API ► Keyoti.RapidSpell.Wpf ► WpfRichTextBoxAdapter ► KeyUp
Keyoti RapidSpell WPF
KeyUp event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event KeyEventHandler KeyUp
public event KeyEventHandler KeyUp
Public Event KeyUp As KeyEventHandler
Public Event KeyUp As KeyEventHandler
public:
virtual  event KeyEventHandler^ KeyUp {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}
public:
virtual  event KeyEventHandler^ KeyUp {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}
abstract KeyUp : IEvent<KeyEventHandler,
    KeyEventArgs>
override KeyUp : IEvent<KeyEventHandler,
    KeyEventArgs>
abstract KeyUp : IEvent<KeyEventHandler,
    KeyEventArgs>
override KeyUp : IEvent<KeyEventHandler,
    KeyEventArgs>
Value
KeyEventHandler


LostFocus Event

LostFocus Event
API ► Keyoti.RapidSpell.Wpf ► WpfRichTextBoxAdapter ► LostFocus
Keyoti RapidSpell WPF
Textbox LostFocus
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event RoutedEventHandler LostFocus
public event RoutedEventHandler LostFocus
Public Event LostFocus As RoutedEventHandler
Public Event LostFocus As RoutedEventHandler
public:
virtual  event RoutedEventHandler^ LostFocus {
    void add (RoutedEventHandler^ value);
    void remove (RoutedEventHandler^ value);
}
public:
virtual  event RoutedEventHandler^ LostFocus {
    void add (RoutedEventHandler^ value);
    void remove (RoutedEventHandler^ value);
}
abstract LostFocus : IEvent<RoutedEventHandler,
    RoutedEventArgs>
override LostFocus : IEvent<RoutedEventHandler,
    RoutedEventArgs>
abstract LostFocus : IEvent<RoutedEventHandler,
    RoutedEventArgs>
override LostFocus : IEvent<RoutedEventHandler,
    RoutedEventArgs>
Value
RoutedEventHandler


MouseDown Event

MouseDown Event
API ► Keyoti.RapidSpell.Wpf ► WpfRichTextBoxAdapter ► MouseDown
Keyoti RapidSpell WPF
MouseDown event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event MouseButtonEventHandler MouseDown
public event MouseButtonEventHandler MouseDown
Public Event MouseDown As MouseButtonEventHandler
Public Event MouseDown As MouseButtonEventHandler
public:
virtual  event MouseButtonEventHandler^ MouseDown {
    void add (MouseButtonEventHandler^ value);
    void remove (MouseButtonEventHandler^ value);
}
public:
virtual  event MouseButtonEventHandler^ MouseDown {
    void add (MouseButtonEventHandler^ value);
    void remove (MouseButtonEventHandler^ value);
}
abstract MouseDown : IEvent<MouseButtonEventHandler,
    MouseButtonEventArgs>
override MouseDown : IEvent<MouseButtonEventHandler,
    MouseButtonEventArgs>
abstract MouseDown : IEvent<MouseButtonEventHandler,
    MouseButtonEventArgs>
override MouseDown : IEvent<MouseButtonEventHandler,
    MouseButtonEventArgs>
Value
MouseButtonEventHandler


MouseUp Event

MouseUp Event
API ► Keyoti.RapidSpell.Wpf ► WpfRichTextBoxAdapter ► MouseUp
Keyoti RapidSpell WPF
MouseUp event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event MouseButtonEventHandler MouseUp
public event MouseButtonEventHandler MouseUp
Public Event MouseUp As MouseButtonEventHandler
Public Event MouseUp As MouseButtonEventHandler
public:
virtual  event MouseButtonEventHandler^ MouseUp {
    void add (MouseButtonEventHandler^ value);
    void remove (MouseButtonEventHandler^ value);
}
public:
virtual  event MouseButtonEventHandler^ MouseUp {
    void add (MouseButtonEventHandler^ value);
    void remove (MouseButtonEventHandler^ value);
}
abstract MouseUp : IEvent<MouseButtonEventHandler,
    MouseButtonEventArgs>
override MouseUp : IEvent<MouseButtonEventHandler,
    MouseButtonEventArgs>
abstract MouseUp : IEvent<MouseButtonEventHandler,
    MouseButtonEventArgs>
override MouseUp : IEvent<MouseButtonEventHandler,
    MouseButtonEventArgs>
Value
MouseButtonEventHandler


ReadOnly Property

ReadOnly Property
API ► Keyoti.RapidSpell.Wpf ► WpfRichTextBoxAdapter ► ReadOnly
Keyoti RapidSpell WPF
Whether text box is readonly
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ReadOnly { get; }
public bool ReadOnly { get; }
Public ReadOnly Property ReadOnly As Boolean
    Get
Public ReadOnly Property ReadOnly As Boolean
    Get
public:
virtual property bool ReadOnly {
    bool get () sealed;
}
public:
virtual property bool ReadOnly {
    bool get () sealed;
}
abstract ReadOnly : bool with get
override ReadOnly : bool with get
abstract ReadOnly : bool with get
override ReadOnly : bool with get
Property Value
Boolean


Refresh Method

Refresh Method
API ► Keyoti.RapidSpell.Wpf ► WpfRichTextBoxAdapter ► Refresh()()()()
Keyoti RapidSpell WPF
Refresh the underlines
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void Refresh()
public void Refresh()
Public Sub Refresh
Public Sub Refresh
public:
virtual void Refresh() sealed
public:
virtual void Refresh() sealed
abstract Refresh : unit -> unit
override Refresh : unit -> unit
abstract Refresh : unit -> unit
override Refresh : unit -> unit


ScrollToCaret Method

ScrollToCaret Method
API ► Keyoti.RapidSpell.Wpf ► WpfRichTextBoxAdapter ► ScrollToCaret()()()()
Keyoti RapidSpell WPF
Scrolls the textbox to the caret
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void ScrollToCaret()
public void ScrollToCaret()
Public Sub ScrollToCaret
Public Sub ScrollToCaret
public:
virtual void ScrollToCaret() sealed
public:
virtual void ScrollToCaret() sealed
abstract ScrollToCaret : unit -> unit
override ScrollToCaret : unit -> unit
abstract ScrollToCaret : unit -> unit
override ScrollToCaret : unit -> unit


Select Method (from, to)

Select Method (from, to)
API ► Keyoti.RapidSpell.Wpf ► WpfRichTextBoxAdapter ► Select(Int32, Int32)
Keyoti RapidSpell WPF
Selects a region of text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void Select(
    int from,
    int to
)
public void Select(
    int from,
    int to
)
Public Sub Select (
    from As Integer,
    to As Integer
)
Public Sub Select (
    from As Integer,
    to As Integer
)
public:
virtual void Select(
    int from,
    int to
) sealed
public:
virtual void Select(
    int from,
    int to
) sealed
abstract Select :
        from : int *
        to : int -> unit
override Select :
        from : int *
        to : int -> unit
abstract Select :
        from : int *
        to : int -> unit
override Select :
        from : int *
        to : int -> unit
Parameters
from (Int32)
to (Int32)


SelectedText Property

SelectedText Property
API ► Keyoti.RapidSpell.Wpf ► WpfRichTextBoxAdapter ► SelectedText
Keyoti RapidSpell WPF
The selected text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string SelectedText { get; set; }
public string SelectedText { get; set; }
Public Property SelectedText As String
    Get
    Set
Public Property SelectedText As String
    Get
    Set
public:
virtual property String^ SelectedText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ SelectedText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract SelectedText : string with get, set
override SelectedText : string with get, set
abstract SelectedText : string with get, set
override SelectedText : string with get, set
Property Value
String


SelectionAdorner Property

SelectionAdorner Property
API ► Keyoti.RapidSpell.Wpf ► WpfRichTextBoxAdapter ► SelectionAdorner
Keyoti RapidSpell WPF
The highlighter used to highlight errors.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public SelectionAdorner SelectionAdorner { get; set; }
public SelectionAdorner SelectionAdorner { get; set; }
Public Property SelectionAdorner As SelectionAdorner
    Get
    Set
Public Property SelectionAdorner As SelectionAdorner
    Get
    Set
public:
property SelectionAdorner^ SelectionAdorner {
    SelectionAdorner^ get ();
    void set (SelectionAdorner^ value);
}
public:
property SelectionAdorner^ SelectionAdorner {
    SelectionAdorner^ get ();
    void set (SelectionAdorner^ value);
}
member SelectionAdorner : SelectionAdorner with get, set

member SelectionAdorner : SelectionAdorner with get, set
Property Value
SelectionAdorner


SelectionEnd Property

SelectionEnd Property
API ► Keyoti.RapidSpell.Wpf ► WpfRichTextBoxAdapter ► SelectionEnd
Keyoti RapidSpell WPF
Selection end
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int SelectionEnd { get; }
public int SelectionEnd { get; }
Public ReadOnly Property SelectionEnd As Integer
    Get
Public ReadOnly Property SelectionEnd As Integer
    Get
public:
virtual property int SelectionEnd {
    int get () sealed;
}
public:
virtual property int SelectionEnd {
    int get () sealed;
}
abstract SelectionEnd : int with get
override SelectionEnd : int with get
abstract SelectionEnd : int with get
override SelectionEnd : int with get
Property Value
Int32


SelectionLength Property

SelectionLength Property
API ► Keyoti.RapidSpell.Wpf ► WpfRichTextBoxAdapter ► SelectionLength
Keyoti RapidSpell WPF
Selection length
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int SelectionLength { get; set; }
public int SelectionLength { get; set; }
Public Property SelectionLength As Integer
    Get
    Set
Public Property SelectionLength As Integer
    Get
    Set
public:
virtual property int SelectionLength {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int SelectionLength {
    int get () sealed;
    void set (int value) sealed;
}
abstract SelectionLength : int with get, set
override SelectionLength : int with get, set
abstract SelectionLength : int with get, set
override SelectionLength : int with get, set
Property Value
Int32


SelectionStart Property

SelectionStart Property
API ► Keyoti.RapidSpell.Wpf ► WpfRichTextBoxAdapter ► SelectionStart
Keyoti RapidSpell WPF
Selection start
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int SelectionStart { get; set; }
public int SelectionStart { get; set; }
Public Property SelectionStart As Integer
    Get
    Set
Public Property SelectionStart As Integer
    Get
    Set
public:
virtual property int SelectionStart {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int SelectionStart {
    int get () sealed;
    void set (int value) sealed;
}
abstract SelectionStart : int with get, set
override SelectionStart : int with get, set
abstract SelectionStart : int with get, set
override SelectionStart : int with get, set
Property Value
Int32


Text Property

Text Property
API ► Keyoti.RapidSpell.Wpf ► WpfRichTextBoxAdapter ► Text
Keyoti RapidSpell WPF
The text in the RichTextBox
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string Text { get; set; }
public string Text { get; set; }
Public Property Text As String
    Get
    Set
Public Property Text As String
    Get
    Set
public:
virtual property String^ Text {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ Text {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract Text : string with get, set
override Text : string with get, set
abstract Text : string with get, set
override Text : string with get, set
Property Value
String


TextChanged Event

TextChanged Event
API ► Keyoti.RapidSpell.Wpf ► WpfRichTextBoxAdapter ► TextChanged
Keyoti RapidSpell WPF
Fired when text changes
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler TextChanged
public event EventHandler TextChanged
Public Event TextChanged As EventHandler
Public Event TextChanged As EventHandler
public:
virtual  event EventHandler^ TextChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ TextChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract TextChanged : IEvent<EventHandler,
    EventArgs>
override TextChanged : IEvent<EventHandler,
    EventArgs>
abstract TextChanged : IEvent<EventHandler,
    EventArgs>
override TextChanged : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


TextControl Property

TextControl Property
API ► Keyoti.RapidSpell.Wpf ► WpfRichTextBoxAdapter ► TextControl
Keyoti RapidSpell WPF
The wrapped text box.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public RichTextBox TextControl { get; }
public RichTextBox TextControl { get; }
Public ReadOnly Property TextControl As RichTextBox
    Get
Public ReadOnly Property TextControl As RichTextBox
    Get
public:
property RichTextBox^ TextControl {
    RichTextBox^ get ();
}
public:
property RichTextBox^ TextControl {
    RichTextBox^ get ();
}
member TextControl : RichTextBox with get

member TextControl : RichTextBox with get
Property Value
RichTextBox


TextLength Property

TextLength Property
API ► Keyoti.RapidSpell.Wpf ► WpfRichTextBoxAdapter ► TextLength
Keyoti RapidSpell WPF
Text length
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int TextLength { get; }
public int TextLength { get; }
Public ReadOnly Property TextLength As Integer
    Get
Public ReadOnly Property TextLength As Integer
    Get
public:
virtual property int TextLength {
    int get () sealed;
}
public:
virtual property int TextLength {
    int get () sealed;
}
abstract TextLength : int with get
override TextLength : int with get
abstract TextLength : int with get
override TextLength : int with get
Property Value
Int32


Width Property

Width Property
API ► Keyoti.RapidSpell.Wpf ► WpfRichTextBoxAdapter ► Width
Keyoti RapidSpell WPF
Gets or sets the width of the control.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int Width { get; set; }
public int Width { get; set; }
Public Property Width As Integer
    Get
    Set
Public Property Width As Integer
    Get
    Set
public:
virtual property int Width {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int Width {
    int get () sealed;
    void set (int value) sealed;
}
abstract Width : int with get, set
override Width : int with get, set
abstract Width : int with get, set
override Width : int with get, set
Property Value
Int32


WpfTextBoxAdapter Class

WpfTextBoxAdapter Class
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter
Keyoti RapidSpell WPF
Used (primarily internally) to wrap the plain TextBox control with required interfaces for spell checking.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class WpfTextBoxAdapter : WpfBaseAdapter,
    ISpellCheckableTextComponent, IAYTTextBox
public class WpfTextBoxAdapter : WpfBaseAdapter,
    ISpellCheckableTextComponent, IAYTTextBox
Public Class WpfTextBoxAdapter
    Inherits WpfBaseAdapter
    Implements ISpellCheckableTextComponent, IAYTTextBox
Public Class WpfTextBoxAdapter
    Inherits WpfBaseAdapter
    Implements ISpellCheckableTextComponent, IAYTTextBox
public ref class WpfTextBoxAdapter : public WpfBaseAdapter,
    ISpellCheckableTextComponent, IAYTTextBox
public ref class WpfTextBoxAdapter : public WpfBaseAdapter,
    ISpellCheckableTextComponent, IAYTTextBox
type WpfTextBoxAdapter =
    class
        inherit WpfBaseAdapter
        interface ISpellCheckableTextComponent
        interface IAYTTextBox
    end
type WpfTextBoxAdapter =
    class
        inherit WpfBaseAdapter
        interface ISpellCheckableTextComponent
        interface IAYTTextBox
    end
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WpfTextBoxAdapter(TextBox, Boolean, LanguageType) | Create a new TextBox wrapper.
 | CaretPosition | The caret position
 | ContextMenu | The context menu that will be shown when the right click is not on a misspelled word.
 | ContextMenuDefault | The context menu that will be shown when the right click is not on a misspelled word.
 | ContextMenuOpening | ContextMenuOpening event
 | CreateErrorAdorner(Int32, Int32, UnderlineStyle, Color) | Create an adorner. (Overrides WpfBaseAdapter.CreateErrorAdorner(Int32, Int32, UnderlineStyle, Color).)
 | Dispose()()()() | Cleans up resources immediately.
 | Disposed | Event fires when component is Disposed.
 | Enabled | Whether the textbox is Enabled
 | Equals(Object) | Whether this and obj are handling the same text box. (Overrides Object.Equals(Object).)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaselineOffsetAtCharIndex(Int32) | Gets the Y offset of the baseline from the position returned by GetPosFromCharIndex for a particular character.
 | GetCharIndexFromPos(Point) | gets the char index from a position point.
 | GetFirstVisibleCharIndex()()()() | Interface requirement, returns 0.
 | GetHashCode()()()() | Gets the hash code (Overrides Object.GetHashCode()()()().)
 | GetPosFromCharIndex(Int32) | Gets the position point from the char index.
 | GetTBU()()()() | Interface requirement
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GotFocus | Textbox GotFocus
 | Height | Gets or sets the height of the control.
 | HideSelection | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus.
 | IsAtWordBoundaryRight | Returns whether the caret is at a right hand word boundary.
 | IsEnabledChanged | IsEnabledChanged event
 | IsFocused | Whether the textbox is focused.
 | IsManagingSameControl(WpfTextBoxAdapter) | Whether this adapter is managing the same control as 'ad'
 | KeyDown | Occurs when a key is pressed while the control has focus.
 | KeyUp | Occurs when a key is released while the control has focus.
 | LostFocus | Textbox LostFocus
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed.
 | MouseUp | Occurs when the mouse is released on the text box.
 | OnTextChanged(Object, TextChangedEventArgs) | Fires text changed event
 | ReadOnly | Whether text box is ReadOnly
 | Refresh()()()() | Forces the control to repaint.
 | RemoveAdorner()()()() | Removes the selection highlight adorner, use this when spell checking ends.
 | ScrollToCaret()()()() | Scrolls to caret.
 | Select(Int32, Int32) | Selects a region
 | SelectedText | Gets or sets a value indicating the currently selected text in the control.
 | SelectionAdorner | The highlighter used to highlight errors.
 | SelectionEnd | Gets or sets the starting point of text selected in the text box.
 | SelectionLength |
 | SelectionStart | Gets or sets the starting point of text selected in the text box.
 | SetTBU(WpfTextBoxBaseUtilityAdapter) | Sets the TextBoxUtilityAdapter to use.
 | Text | Gets or sets the current text in the text box.
 | TextChanged | Occurs when the Text property value changes.
 | TextControl | The TextBox to be spell checked.
 | TextLength | Gets the current text length in the text box.
 | theWrappedTextBox | The wrapped text box (Inherited from WpfBaseAdapter.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | UnderlineYOffset | Controls the position of the underline relative to the baseline.
 | Width | Gets or sets the width of the control.
 | WrappedTextBox | The wrapped text box (Inherited from WpfBaseAdapter.)
Inheritance Hierarchy
Object
 | WpfBaseAdapter
 |  | WpfTextBoxAdapter


WpfTextBoxAdapter Constructor (txc, createCutCopyPasteReplacement, guiLanguage)

WpfTextBoxAdapter Constructor (txc, createCutCopyPasteReplacement, guiLanguage)
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter ► WpfTextBoxAdapter(TextBox, Boolean, LanguageType)
Keyoti RapidSpell WPF
Create a new TextBox wrapper.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public WpfTextBoxAdapter(
    TextBox txc,
    bool createCutCopyPasteReplacement,
    LanguageType guiLanguage
)
public WpfTextBoxAdapter(
    TextBox txc,
    bool createCutCopyPasteReplacement,
    LanguageType guiLanguage
)
Public Sub New (
    txc As TextBox,
    createCutCopyPasteReplacement As Boolean,
    guiLanguage As LanguageType
)
Public Sub New (
    txc As TextBox,
    createCutCopyPasteReplacement As Boolean,
    guiLanguage As LanguageType
)
public:
WpfTextBoxAdapter(
    TextBox^ txc,
    bool createCutCopyPasteReplacement,
    LanguageType guiLanguage
)
public:
WpfTextBoxAdapter(
    TextBox^ txc,
    bool createCutCopyPasteReplacement,
    LanguageType guiLanguage
)
new :
        txc : TextBox *
        createCutCopyPasteReplacement : bool *
        guiLanguage : LanguageType -> WpfTextBoxAdapter
new :
        txc : TextBox *
        createCutCopyPasteReplacement : bool *
        guiLanguage : LanguageType -> WpfTextBoxAdapter
Parameters
txc (TextBox)
createCutCopyPasteReplacement (Boolean)
guiLanguage (LanguageType)


CaretPosition Property

CaretPosition Property
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter ► CaretPosition
Keyoti RapidSpell WPF
The caret position
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int CaretPosition { get; set; }
public int CaretPosition { get; set; }
Public Property CaretPosition As Integer
    Get
    Set
Public Property CaretPosition As Integer
    Get
    Set
public:
virtual property int CaretPosition {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int CaretPosition {
    int get () sealed;
    void set (int value) sealed;
}
abstract CaretPosition : int with get, set
override CaretPosition : int with get, set
abstract CaretPosition : int with get, set
override CaretPosition : int with get, set
Property Value
Int32


ContextMenu Property

ContextMenu Property
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter ► ContextMenu
Keyoti RapidSpell WPF
The context menu that will be shown when the right click is not on a misspelled word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ContextMenu ContextMenu { get; set; }
public ContextMenu ContextMenu { get; set; }
Public Property ContextMenu As ContextMenu
    Get
    Set
Public Property ContextMenu As ContextMenu
    Get
    Set
public:
virtual property ContextMenu^ ContextMenu {
    ContextMenu^ get () sealed;
    void set (ContextMenu^ value) sealed;
}
public:
virtual property ContextMenu^ ContextMenu {
    ContextMenu^ get () sealed;
    void set (ContextMenu^ value) sealed;
}
abstract ContextMenu : ContextMenu with get, set
override ContextMenu : ContextMenu with get, set
abstract ContextMenu : ContextMenu with get, set
override ContextMenu : ContextMenu with get, set
Property Value
ContextMenu


ContextMenuDefault Property

ContextMenuDefault Property
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter ► ContextMenuDefault
Keyoti RapidSpell WPF
The context menu that will be shown when the right click is not on a misspelled word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ContextMenu ContextMenuDefault { get; set; }
public ContextMenu ContextMenuDefault { get; set; }
Public Property ContextMenuDefault As ContextMenu
    Get
    Set
Public Property ContextMenuDefault As ContextMenu
    Get
    Set
public:
virtual property ContextMenu^ ContextMenuDefault {
    ContextMenu^ get () sealed;
    void set (ContextMenu^ value) sealed;
}
public:
virtual property ContextMenu^ ContextMenuDefault {
    ContextMenu^ get () sealed;
    void set (ContextMenu^ value) sealed;
}
abstract ContextMenuDefault : ContextMenu with get, set
override ContextMenuDefault : ContextMenu with get, set
abstract ContextMenuDefault : ContextMenu with get, set
override ContextMenuDefault : ContextMenu with get, set
Property Value
ContextMenu


ContextMenuOpening Event

ContextMenuOpening Event
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter ► ContextMenuOpening
Keyoti RapidSpell WPF
ContextMenuOpening event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event ContextMenuEventHandler ContextMenuOpening
public event ContextMenuEventHandler ContextMenuOpening
Public Event ContextMenuOpening As ContextMenuEventHandler
Public Event ContextMenuOpening As ContextMenuEventHandler
public:
virtual  event ContextMenuEventHandler^ ContextMenuOpening {
    void add (ContextMenuEventHandler^ value);
    void remove (ContextMenuEventHandler^ value);
}
public:
virtual  event ContextMenuEventHandler^ ContextMenuOpening {
    void add (ContextMenuEventHandler^ value);
    void remove (ContextMenuEventHandler^ value);
}
abstract ContextMenuOpening : IEvent<ContextMenuEventHandler,
    ContextMenuEventArgs>
override ContextMenuOpening : IEvent<ContextMenuEventHandler,
    ContextMenuEventArgs>
abstract ContextMenuOpening : IEvent<ContextMenuEventHandler,
    ContextMenuEventArgs>
override ContextMenuOpening : IEvent<ContextMenuEventHandler,
    ContextMenuEventArgs>
Value
ContextMenuEventHandler


CreateErrorAdorner Method (start, end, u, c)

CreateErrorAdorner Method (start, end, u, c)
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter ► CreateErrorAdorner(Int32, Int32, UnderlineStyle, Color)
Keyoti RapidSpell WPF
Create an adorner.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override ErrorAdornerBase CreateErrorAdorner(
    int start,
    int end,
    UnderlineStyle u,
    Color c
)
public override ErrorAdornerBase CreateErrorAdorner(
    int start,
    int end,
    UnderlineStyle u,
    Color c
)
Public Overrides Function CreateErrorAdorner (
    start As Integer,
    end As Integer,
    u As UnderlineStyle,
    c As Color
) As ErrorAdornerBase
Public Overrides Function CreateErrorAdorner (
    start As Integer,
    end As Integer,
    u As UnderlineStyle,
    c As Color
) As ErrorAdornerBase
public:
virtual ErrorAdornerBase^ CreateErrorAdorner(
    int start,
    int end,
    UnderlineStyle u,
    Color c
) override
public:
virtual ErrorAdornerBase^ CreateErrorAdorner(
    int start,
    int end,
    UnderlineStyle u,
    Color c
) override
abstract CreateErrorAdorner :
        start : int *
        end : int *
        u : UnderlineStyle *
        c : Color -> ErrorAdornerBase
override CreateErrorAdorner :
        start : int *
        end : int *
        u : UnderlineStyle *
        c : Color -> ErrorAdornerBase
abstract CreateErrorAdorner :
        start : int *
        end : int *
        u : UnderlineStyle *
        c : Color -> ErrorAdornerBase
override CreateErrorAdorner :
        start : int *
        end : int *
        u : UnderlineStyle *
        c : Color -> ErrorAdornerBase
Parameters
start (Int32)
end (Int32)
u (UnderlineStyle)
c (Color)
Return Value
ErrorAdornerBase


Dispose Method

Dispose Method
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter ► Dispose()()()()
Keyoti RapidSpell WPF
Cleans up resources immediately.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void Dispose()
public void Dispose()
Public Sub Dispose
Public Sub Dispose
public:
virtual void Dispose() sealed
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit
abstract Dispose : unit -> unit
override Dispose : unit -> unit


Disposed Event

Disposed Event
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter ► Disposed
Keyoti RapidSpell WPF
Event fires when component is Disposed.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler Disposed
public event EventHandler Disposed
Public Event Disposed As EventHandler
Public Event Disposed As EventHandler
public:
virtual  event EventHandler^ Disposed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ Disposed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Disposed : IEvent<EventHandler,
    EventArgs>
override Disposed : IEvent<EventHandler,
    EventArgs>
abstract Disposed : IEvent<EventHandler,
    EventArgs>
override Disposed : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


Enabled Property

Enabled Property
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter ► Enabled
Keyoti RapidSpell WPF
Whether the textbox is Enabled
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool Enabled { get; }
public bool Enabled { get; }
Public ReadOnly Property Enabled As Boolean
    Get
Public ReadOnly Property Enabled As Boolean
    Get
public:
virtual property bool Enabled {
    bool get () sealed;
}
public:
virtual property bool Enabled {
    bool get () sealed;
}
abstract Enabled : bool with get
override Enabled : bool with get
abstract Enabled : bool with get
override Enabled : bool with get
Property Value
Boolean


Equals Method (obj)

Equals Method (obj)
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter ► Equals(Object)
Keyoti RapidSpell WPF
Whether this and obj are handling the same text box.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
Parameters
obj (Object)
Return Value
Boolean


GetBaselineOffsetAtCharIndex Method (index)

GetBaselineOffsetAtCharIndex Method (index)
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter ► GetBaselineOffsetAtCharIndex(Int32)
Keyoti RapidSpell WPF
Gets the Y offset of the baseline from the position returned by GetPosFromCharIndex for a particular character.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int GetBaselineOffsetAtCharIndex(
    int index
)
public int GetBaselineOffsetAtCharIndex(
    int index
)
Public Function GetBaselineOffsetAtCharIndex (
    index As Integer
) As Integer
Public Function GetBaselineOffsetAtCharIndex (
    index As Integer
) As Integer
public:
virtual int GetBaselineOffsetAtCharIndex(
    int index
) sealed
public:
virtual int GetBaselineOffsetAtCharIndex(
    int index
) sealed
abstract GetBaselineOffsetAtCharIndex :
        index : int -> int
override GetBaselineOffsetAtCharIndex :
        index : int -> int
abstract GetBaselineOffsetAtCharIndex :
        index : int -> int
override GetBaselineOffsetAtCharIndex :
        index : int -> int
Parameters
index (Int32)
Return Value
Int32
Remarks
For example, with RichTextBox Controls GetPosFromCharIndex returns the top left coord, therefore this method must return the height of the biggest font on the line.


GetCharIndexFromPos Method (pos)

GetCharIndexFromPos Method (pos)
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter ► GetCharIndexFromPos(Point)
Keyoti RapidSpell WPF
gets the char index from a position point.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int GetCharIndexFromPos(
    Point pos
)
public int GetCharIndexFromPos(
    Point pos
)
Public Function GetCharIndexFromPos (
    pos As Point
) As Integer
Public Function GetCharIndexFromPos (
    pos As Point
) As Integer
public:
virtual int GetCharIndexFromPos(
    Point pos
) sealed
public:
virtual int GetCharIndexFromPos(
    Point pos
) sealed
abstract GetCharIndexFromPos :
        pos : Point -> int
override GetCharIndexFromPos :
        pos : Point -> int
abstract GetCharIndexFromPos :
        pos : Point -> int
override GetCharIndexFromPos :
        pos : Point -> int
Parameters
pos (Point)
Return Value
Int32


GetFirstVisibleCharIndex Method

GetFirstVisibleCharIndex Method
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter ► GetFirstVisibleCharIndex()()()()
Keyoti RapidSpell WPF
Interface requirement, returns 0.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int GetFirstVisibleCharIndex()
public int GetFirstVisibleCharIndex()
Public Function GetFirstVisibleCharIndex As Integer
Public Function GetFirstVisibleCharIndex As Integer
public:
int GetFirstVisibleCharIndex()
public:
int GetFirstVisibleCharIndex()
member GetFirstVisibleCharIndex : unit -> int

member GetFirstVisibleCharIndex : unit -> int
Return Value
Int32


GetHashCode Method

GetHashCode Method
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter ► GetHashCode()()()()
Keyoti RapidSpell WPF
Gets the hash code
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
Return Value
Int32


GetPosFromCharIndex Method (index)

GetPosFromCharIndex Method (index)
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter ► GetPosFromCharIndex(Int32)
Keyoti RapidSpell WPF
Gets the position point from the char index.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Point GetPosFromCharIndex(
    int index
)
public Point GetPosFromCharIndex(
    int index
)
Public Function GetPosFromCharIndex (
    index As Integer
) As Point
Public Function GetPosFromCharIndex (
    index As Integer
) As Point
public:
virtual Point GetPosFromCharIndex(
    int index
) sealed
public:
virtual Point GetPosFromCharIndex(
    int index
) sealed
abstract GetPosFromCharIndex :
        index : int -> Point
override GetPosFromCharIndex :
        index : int -> Point
abstract GetPosFromCharIndex :
        index : int -> Point
override GetPosFromCharIndex :
        index : int -> Point
Parameters
index (Int32)
Return Value
Point


GetTBU Method

GetTBU Method
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter ► GetTBU()()()()
Keyoti RapidSpell WPF
Interface requirement
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public WpfTextBoxBaseUtilityAdapter GetTBU()
public WpfTextBoxBaseUtilityAdapter GetTBU()
Public Function GetTBU As WpfTextBoxBaseUtilityAdapter
Public Function GetTBU As WpfTextBoxBaseUtilityAdapter
public:
virtual WpfTextBoxBaseUtilityAdapter^ GetTBU() sealed
public:
virtual WpfTextBoxBaseUtilityAdapter^ GetTBU() sealed
abstract GetTBU : unit -> WpfTextBoxBaseUtilityAdapter
override GetTBU : unit -> WpfTextBoxBaseUtilityAdapter
abstract GetTBU : unit -> WpfTextBoxBaseUtilityAdapter
override GetTBU : unit -> WpfTextBoxBaseUtilityAdapter
Return Value
WpfTextBoxBaseUtilityAdapter


GotFocus Event

GotFocus Event
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter ► GotFocus
Keyoti RapidSpell WPF
Textbox GotFocus
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event RoutedEventHandler GotFocus
public event RoutedEventHandler GotFocus
Public Event GotFocus As RoutedEventHandler
Public Event GotFocus As RoutedEventHandler
public:
virtual  event RoutedEventHandler^ GotFocus {
    void add (RoutedEventHandler^ value);
    void remove (RoutedEventHandler^ value);
}
public:
virtual  event RoutedEventHandler^ GotFocus {
    void add (RoutedEventHandler^ value);
    void remove (RoutedEventHandler^ value);
}
abstract GotFocus : IEvent<RoutedEventHandler,
    RoutedEventArgs>
override GotFocus : IEvent<RoutedEventHandler,
    RoutedEventArgs>
abstract GotFocus : IEvent<RoutedEventHandler,
    RoutedEventArgs>
override GotFocus : IEvent<RoutedEventHandler,
    RoutedEventArgs>
Value
RoutedEventHandler


Height Property

Height Property
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter ► Height
Keyoti RapidSpell WPF
Gets or sets the height of the control.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int Height { get; set; }
public int Height { get; set; }
Public Property Height As Integer
    Get
    Set
Public Property Height As Integer
    Get
    Set
public:
virtual property int Height {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int Height {
    int get () sealed;
    void set (int value) sealed;
}
abstract Height : int with get, set
override Height : int with get, set
abstract Height : int with get, set
override Height : int with get, set
Property Value
Int32


HideSelection Property

HideSelection Property
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter ► HideSelection
Keyoti RapidSpell WPF
Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool HideSelection { get; set; }
public bool HideSelection { get; set; }
Public Property HideSelection As Boolean
    Get
    Set
Public Property HideSelection As Boolean
    Get
    Set
public:
virtual property bool HideSelection {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool HideSelection {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract HideSelection : bool with get, set
override HideSelection : bool with get, set
abstract HideSelection : bool with get, set
override HideSelection : bool with get, set
Property Value
Boolean


IsAtWordBoundaryRight Property

IsAtWordBoundaryRight Property
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter ► IsAtWordBoundaryRight
Keyoti RapidSpell WPF
Returns whether the caret is at a right hand word boundary.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IsAtWordBoundaryRight { get; }
public bool IsAtWordBoundaryRight { get; }
Public ReadOnly Property IsAtWordBoundaryRight As Boolean
    Get
Public ReadOnly Property IsAtWordBoundaryRight As Boolean
    Get
public:
virtual property bool IsAtWordBoundaryRight {
    bool get () sealed;
}
public:
virtual property bool IsAtWordBoundaryRight {
    bool get () sealed;
}
abstract IsAtWordBoundaryRight : bool with get
override IsAtWordBoundaryRight : bool with get
abstract IsAtWordBoundaryRight : bool with get
override IsAtWordBoundaryRight : bool with get
Property Value
Boolean


IsEnabledChanged Event

IsEnabledChanged Event
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter ► IsEnabledChanged
Keyoti RapidSpell WPF
IsEnabledChanged event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler IsEnabledChanged
public event EventHandler IsEnabledChanged
Public Event IsEnabledChanged As EventHandler
Public Event IsEnabledChanged As EventHandler
public:
virtual  event EventHandler^ IsEnabledChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ IsEnabledChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract IsEnabledChanged : IEvent<EventHandler,
    EventArgs>
override IsEnabledChanged : IEvent<EventHandler,
    EventArgs>
abstract IsEnabledChanged : IEvent<EventHandler,
    EventArgs>
override IsEnabledChanged : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


IsFocused Property

IsFocused Property
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter ► IsFocused
Keyoti RapidSpell WPF
Whether the textbox is focused.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IsFocused { get; }
public bool IsFocused { get; }
Public ReadOnly Property IsFocused As Boolean
    Get
Public ReadOnly Property IsFocused As Boolean
    Get
public:
virtual property bool IsFocused {
    bool get () sealed;
}
public:
virtual property bool IsFocused {
    bool get () sealed;
}
abstract IsFocused : bool with get
override IsFocused : bool with get
abstract IsFocused : bool with get
override IsFocused : bool with get
Property Value
Boolean


IsManagingSameControl Method (ad)

IsManagingSameControl Method (ad)
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter ► IsManagingSameControl(WpfTextBoxAdapter)
Keyoti RapidSpell WPF
Whether this adapter is managing the same control as 'ad'
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IsManagingSameControl(
    WpfTextBoxAdapter ad
)
public bool IsManagingSameControl(
    WpfTextBoxAdapter ad
)
Public Function IsManagingSameControl (
    ad As WpfTextBoxAdapter
) As Boolean
Public Function IsManagingSameControl (
    ad As WpfTextBoxAdapter
) As Boolean
public:
bool IsManagingSameControl(
    WpfTextBoxAdapter^ ad
)
public:
bool IsManagingSameControl(
    WpfTextBoxAdapter^ ad
)
member IsManagingSameControl :
        ad : WpfTextBoxAdapter -> bool

member IsManagingSameControl :
        ad : WpfTextBoxAdapter -> bool
Parameters
ad (WpfTextBoxAdapter)
Return Value
Boolean


KeyDown Event

KeyDown Event
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter ► KeyDown
Keyoti RapidSpell WPF
Occurs when a key is pressed while the control has focus.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event KeyEventHandler KeyDown
public event KeyEventHandler KeyDown
Public Event KeyDown As KeyEventHandler
Public Event KeyDown As KeyEventHandler
public:
virtual  event KeyEventHandler^ KeyDown {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}
public:
virtual  event KeyEventHandler^ KeyDown {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}
abstract KeyDown : IEvent<KeyEventHandler,
    KeyEventArgs>
override KeyDown : IEvent<KeyEventHandler,
    KeyEventArgs>
abstract KeyDown : IEvent<KeyEventHandler,
    KeyEventArgs>
override KeyDown : IEvent<KeyEventHandler,
    KeyEventArgs>
Value
KeyEventHandler


KeyUp Event

KeyUp Event
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter ► KeyUp
Keyoti RapidSpell WPF
Occurs when a key is released while the control has focus.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event KeyEventHandler KeyUp
public event KeyEventHandler KeyUp
Public Event KeyUp As KeyEventHandler
Public Event KeyUp As KeyEventHandler
public:
virtual  event KeyEventHandler^ KeyUp {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}
public:
virtual  event KeyEventHandler^ KeyUp {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}
abstract KeyUp : IEvent<KeyEventHandler,
    KeyEventArgs>
override KeyUp : IEvent<KeyEventHandler,
    KeyEventArgs>
abstract KeyUp : IEvent<KeyEventHandler,
    KeyEventArgs>
override KeyUp : IEvent<KeyEventHandler,
    KeyEventArgs>
Value
KeyEventHandler


LostFocus Event

LostFocus Event
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter ► LostFocus
Keyoti RapidSpell WPF
Textbox LostFocus
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event RoutedEventHandler LostFocus
public event RoutedEventHandler LostFocus
Public Event LostFocus As RoutedEventHandler
Public Event LostFocus As RoutedEventHandler
public:
virtual  event RoutedEventHandler^ LostFocus {
    void add (RoutedEventHandler^ value);
    void remove (RoutedEventHandler^ value);
}
public:
virtual  event RoutedEventHandler^ LostFocus {
    void add (RoutedEventHandler^ value);
    void remove (RoutedEventHandler^ value);
}
abstract LostFocus : IEvent<RoutedEventHandler,
    RoutedEventArgs>
override LostFocus : IEvent<RoutedEventHandler,
    RoutedEventArgs>
abstract LostFocus : IEvent<RoutedEventHandler,
    RoutedEventArgs>
override LostFocus : IEvent<RoutedEventHandler,
    RoutedEventArgs>
Value
RoutedEventHandler


MouseDown Event

MouseDown Event
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter ► MouseDown
Keyoti RapidSpell WPF
Occurs when the mouse pointer is over the control and a mouse button is pressed.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event MouseButtonEventHandler MouseDown
public event MouseButtonEventHandler MouseDown
Public Event MouseDown As MouseButtonEventHandler
Public Event MouseDown As MouseButtonEventHandler
public:
virtual  event MouseButtonEventHandler^ MouseDown {
    void add (MouseButtonEventHandler^ value);
    void remove (MouseButtonEventHandler^ value);
}
public:
virtual  event MouseButtonEventHandler^ MouseDown {
    void add (MouseButtonEventHandler^ value);
    void remove (MouseButtonEventHandler^ value);
}
abstract MouseDown : IEvent<MouseButtonEventHandler,
    MouseButtonEventArgs>
override MouseDown : IEvent<MouseButtonEventHandler,
    MouseButtonEventArgs>
abstract MouseDown : IEvent<MouseButtonEventHandler,
    MouseButtonEventArgs>
override MouseDown : IEvent<MouseButtonEventHandler,
    MouseButtonEventArgs>
Value
MouseButtonEventHandler


MouseUp Event

MouseUp Event
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter ► MouseUp
Keyoti RapidSpell WPF
Occurs when the mouse is released on the text box.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event MouseButtonEventHandler MouseUp
public event MouseButtonEventHandler MouseUp
Public Event MouseUp As MouseButtonEventHandler
Public Event MouseUp As MouseButtonEventHandler
public:
virtual  event MouseButtonEventHandler^ MouseUp {
    void add (MouseButtonEventHandler^ value);
    void remove (MouseButtonEventHandler^ value);
}
public:
virtual  event MouseButtonEventHandler^ MouseUp {
    void add (MouseButtonEventHandler^ value);
    void remove (MouseButtonEventHandler^ value);
}
abstract MouseUp : IEvent<MouseButtonEventHandler,
    MouseButtonEventArgs>
override MouseUp : IEvent<MouseButtonEventHandler,
    MouseButtonEventArgs>
abstract MouseUp : IEvent<MouseButtonEventHandler,
    MouseButtonEventArgs>
override MouseUp : IEvent<MouseButtonEventHandler,
    MouseButtonEventArgs>
Value
MouseButtonEventHandler


OnTextChanged Method (sender, e)

OnTextChanged Method (sender, e)
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter ► OnTextChanged(Object, TextChangedEventArgs)
Keyoti RapidSpell WPF
Fires text changed event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void OnTextChanged(
    Object sender,
    TextChangedEventArgs e
)
public void OnTextChanged(
    Object sender,
    TextChangedEventArgs e
)
Public Sub OnTextChanged (
    sender As Object,
    e As TextChangedEventArgs
)
Public Sub OnTextChanged (
    sender As Object,
    e As TextChangedEventArgs
)
public:
void OnTextChanged(
    Object^ sender,
    TextChangedEventArgs^ e
)
public:
void OnTextChanged(
    Object^ sender,
    TextChangedEventArgs^ e
)
member OnTextChanged :
        sender : Object *
        e : TextChangedEventArgs -> unit

member OnTextChanged :
        sender : Object *
        e : TextChangedEventArgs -> unit
Parameters
sender (Object)
e (TextChangedEventArgs)


ReadOnly Property

ReadOnly Property
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter ► ReadOnly
Keyoti RapidSpell WPF
Whether text box is ReadOnly
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ReadOnly { get; }
public bool ReadOnly { get; }
Public ReadOnly Property ReadOnly As Boolean
    Get
Public ReadOnly Property ReadOnly As Boolean
    Get
public:
virtual property bool ReadOnly {
    bool get () sealed;
}
public:
virtual property bool ReadOnly {
    bool get () sealed;
}
abstract ReadOnly : bool with get
override ReadOnly : bool with get
abstract ReadOnly : bool with get
override ReadOnly : bool with get
Property Value
Boolean


Refresh Method

Refresh Method
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter ► Refresh()()()()
Keyoti RapidSpell WPF
Forces the control to repaint.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void Refresh()
public void Refresh()
Public Sub Refresh
Public Sub Refresh
public:
virtual void Refresh() sealed
public:
virtual void Refresh() sealed
abstract Refresh : unit -> unit
override Refresh : unit -> unit
abstract Refresh : unit -> unit
override Refresh : unit -> unit


RemoveAdorner Method

RemoveAdorner Method
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter ► RemoveAdorner()()()()
Keyoti RapidSpell WPF
Removes the selection highlight adorner, use this when spell checking ends.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void RemoveAdorner()
public void RemoveAdorner()
Public Sub RemoveAdorner
Public Sub RemoveAdorner
public:
void RemoveAdorner()
public:
void RemoveAdorner()
member RemoveAdorner : unit -> unit

member RemoveAdorner : unit -> unit


ScrollToCaret Method

ScrollToCaret Method
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter ► ScrollToCaret()()()()
Keyoti RapidSpell WPF
Scrolls to caret.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void ScrollToCaret()
public void ScrollToCaret()
Public Sub ScrollToCaret
Public Sub ScrollToCaret
public:
virtual void ScrollToCaret() sealed
public:
virtual void ScrollToCaret() sealed
abstract ScrollToCaret : unit -> unit
override ScrollToCaret : unit -> unit
abstract ScrollToCaret : unit -> unit
override ScrollToCaret : unit -> unit


Select Method (from, to)

Select Method (from, to)
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter ► Select(Int32, Int32)
Keyoti RapidSpell WPF
Selects a region
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void Select(
    int from,
    int to
)
public void Select(
    int from,
    int to
)
Public Sub Select (
    from As Integer,
    to As Integer
)
Public Sub Select (
    from As Integer,
    to As Integer
)
public:
virtual void Select(
    int from,
    int to
) sealed
public:
virtual void Select(
    int from,
    int to
) sealed
abstract Select :
        from : int *
        to : int -> unit
override Select :
        from : int *
        to : int -> unit
abstract Select :
        from : int *
        to : int -> unit
override Select :
        from : int *
        to : int -> unit
Parameters
from (Int32)
to (Int32)


SelectedText Property

SelectedText Property
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter ► SelectedText
Keyoti RapidSpell WPF
Gets or sets a value indicating the currently selected text in the control.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string SelectedText { get; set; }
public string SelectedText { get; set; }
Public Property SelectedText As String
    Get
    Set
Public Property SelectedText As String
    Get
    Set
public:
virtual property String^ SelectedText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ SelectedText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract SelectedText : string with get, set
override SelectedText : string with get, set
abstract SelectedText : string with get, set
override SelectedText : string with get, set
Property Value
String


SelectionAdorner Property

SelectionAdorner Property
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter ► SelectionAdorner
Keyoti RapidSpell WPF
The highlighter used to highlight errors.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public SelectionAdorner SelectionAdorner { get; set; }
public SelectionAdorner SelectionAdorner { get; set; }
Public Property SelectionAdorner As SelectionAdorner
    Get
    Set
Public Property SelectionAdorner As SelectionAdorner
    Get
    Set
public:
property SelectionAdorner^ SelectionAdorner {
    SelectionAdorner^ get ();
    void set (SelectionAdorner^ value);
}
public:
property SelectionAdorner^ SelectionAdorner {
    SelectionAdorner^ get ();
    void set (SelectionAdorner^ value);
}
member SelectionAdorner : SelectionAdorner with get, set

member SelectionAdorner : SelectionAdorner with get, set
Property Value
SelectionAdorner


SelectionEnd Property

SelectionEnd Property
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter ► SelectionEnd
Keyoti RapidSpell WPF
Gets or sets the starting point of text selected in the text box.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int SelectionEnd { get; }
public int SelectionEnd { get; }
Public ReadOnly Property SelectionEnd As Integer
    Get
Public ReadOnly Property SelectionEnd As Integer
    Get
public:
virtual property int SelectionEnd {
    int get () sealed;
}
public:
virtual property int SelectionEnd {
    int get () sealed;
}
abstract SelectionEnd : int with get
override SelectionEnd : int with get
abstract SelectionEnd : int with get
override SelectionEnd : int with get
Property Value
Int32


SelectionLength Property

SelectionLength Property
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter ► SelectionLength
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int SelectionLength { get; set; }
public int SelectionLength { get; set; }
Public Property SelectionLength As Integer
    Get
    Set
Public Property SelectionLength As Integer
    Get
    Set
public:
virtual property int SelectionLength {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int SelectionLength {
    int get () sealed;
    void set (int value) sealed;
}
abstract SelectionLength : int with get, set
override SelectionLength : int with get, set
abstract SelectionLength : int with get, set
override SelectionLength : int with get, set
Property Value
Int32


SelectionStart Property

SelectionStart Property
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter ► SelectionStart
Keyoti RapidSpell WPF
Gets or sets the starting point of text selected in the text box.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int SelectionStart { get; set; }
public int SelectionStart { get; set; }
Public Property SelectionStart As Integer
    Get
    Set
Public Property SelectionStart As Integer
    Get
    Set
public:
virtual property int SelectionStart {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int SelectionStart {
    int get () sealed;
    void set (int value) sealed;
}
abstract SelectionStart : int with get, set
override SelectionStart : int with get, set
abstract SelectionStart : int with get, set
override SelectionStart : int with get, set
Property Value
Int32


SetTBU Method (tbu)

SetTBU Method (tbu)
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter ► SetTBU(WpfTextBoxBaseUtilityAdapter)
Keyoti RapidSpell WPF
Sets the TextBoxUtilityAdapter to use.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void SetTBU(
    WpfTextBoxBaseUtilityAdapter tbu
)
public void SetTBU(
    WpfTextBoxBaseUtilityAdapter tbu
)
Public Sub SetTBU (
    tbu As WpfTextBoxBaseUtilityAdapter
)
Public Sub SetTBU (
    tbu As WpfTextBoxBaseUtilityAdapter
)
public:
void SetTBU(
    WpfTextBoxBaseUtilityAdapter^ tbu
)
public:
void SetTBU(
    WpfTextBoxBaseUtilityAdapter^ tbu
)
member SetTBU :
        tbu : WpfTextBoxBaseUtilityAdapter -> unit

member SetTBU :
        tbu : WpfTextBoxBaseUtilityAdapter -> unit
Parameters
tbu (WpfTextBoxBaseUtilityAdapter)


Text Property

Text Property
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter ► Text
Keyoti RapidSpell WPF
Gets or sets the current text in the text box.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string Text { get; set; }
public string Text { get; set; }
Public Property Text As String
    Get
    Set
Public Property Text As String
    Get
    Set
public:
virtual property String^ Text {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ Text {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract Text : string with get, set
override Text : string with get, set
abstract Text : string with get, set
override Text : string with get, set
Property Value
String


TextChanged Event

TextChanged Event
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter ► TextChanged
Keyoti RapidSpell WPF
Occurs when the Text property value changes.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler TextChanged
public event EventHandler TextChanged
Public Event TextChanged As EventHandler
Public Event TextChanged As EventHandler
public:
virtual  event EventHandler^ TextChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
virtual  event EventHandler^ TextChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract TextChanged : IEvent<EventHandler,
    EventArgs>
override TextChanged : IEvent<EventHandler,
    EventArgs>
abstract TextChanged : IEvent<EventHandler,
    EventArgs>
override TextChanged : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


TextControl Property

TextControl Property
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter ► TextControl
Keyoti RapidSpell WPF
The TextBox to be spell checked.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public TextBox TextControl { get; set; }
public TextBox TextControl { get; set; }
Public Property TextControl As TextBox
    Get
    Set
Public Property TextControl As TextBox
    Get
    Set
public:
property TextBox^ TextControl {
    TextBox^ get ();
    void set (TextBox^ value);
}
public:
property TextBox^ TextControl {
    TextBox^ get ();
    void set (TextBox^ value);
}
member TextControl : TextBox with get, set

member TextControl : TextBox with get, set
Property Value
TextBox


TextLength Property

TextLength Property
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter ► TextLength
Keyoti RapidSpell WPF
Gets the current text length in the text box.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int TextLength { get; }
public int TextLength { get; }
Public ReadOnly Property TextLength As Integer
    Get
Public ReadOnly Property TextLength As Integer
    Get
public:
virtual property int TextLength {
    int get () sealed;
}
public:
virtual property int TextLength {
    int get () sealed;
}
abstract TextLength : int with get
override TextLength : int with get
abstract TextLength : int with get
override TextLength : int with get
Property Value
Int32


UnderlineYOffset Property

UnderlineYOffset Property
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter ► UnderlineYOffset
Keyoti RapidSpell WPF
Controls the position of the underline relative to the baseline.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int UnderlineYOffset { get; set; }
public int UnderlineYOffset { get; set; }
Public Property UnderlineYOffset As Integer
    Get
    Set
Public Property UnderlineYOffset As Integer
    Get
    Set
public:
property int UnderlineYOffset {
    int get ();
    void set (int value);
}
public:
property int UnderlineYOffset {
    int get ();
    void set (int value);
}
member UnderlineYOffset : int with get, set

member UnderlineYOffset : int with get, set
Property Value
Int32


Width Property

Width Property
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxAdapter ► Width
Keyoti RapidSpell WPF
Gets or sets the width of the control.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int Width { get; set; }
public int Width { get; set; }
Public Property Width As Integer
    Get
    Set
Public Property Width As Integer
    Get
    Set
public:
virtual property int Width {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int Width {
    int get () sealed;
    void set (int value) sealed;
}
abstract Width : int with get, set
override Width : int with get, set
abstract Width : int with get, set
override Width : int with get, set
Property Value
Int32


WpfTextBoxBaseUtilityAdapter Class

WpfTextBoxBaseUtilityAdapter Class
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxBaseUtilityAdapter
Keyoti RapidSpell WPF
Handles underlines and error adorners.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class WpfTextBoxBaseUtilityAdapter
public class WpfTextBoxBaseUtilityAdapter
Public Class WpfTextBoxBaseUtilityAdapter
Public Class WpfTextBoxBaseUtilityAdapter
public ref class WpfTextBoxBaseUtilityAdapter
public ref class WpfTextBoxBaseUtilityAdapter
type WpfTextBoxBaseUtilityAdapter =  class end
type WpfTextBoxBaseUtilityAdapter =  class end
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WpfTextBoxBaseUtilityAdapter(IAYTTextBox) | Construct a new utility adapter
 | adorner | Adorner.
 | adornersToAddOnLoad | Adorners that couldn't be added initially.
 | adornersUnRenderable | Whether any adorners in the layer couldn't be rendered during update.
 | currentText | Register of text currently in the text box, updated when it changes.
 | doUpdatesMovedUnderlines | Internal
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FullPaint(Boolean) | Not implemented in WPF version
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GetUnderlines()()()() | Returns the current underlines collection
 | HideUnderline(Int32, Int32) | Hides an existing underline
 | IdentifyChange()()()() | Returns the start and end indices in the current text of the changed text.
 | IsFinished | Whether this object is no longer being used.
 | isPositionInUnderline(Int32) | Whether index is inside a visible underline
 | KeyDown | KeyDown event from textbox
 | KeyUp | KeyUp event from textbox
 | lastRightClickChar | Where the last right click was.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MoveUnderline(Underline, Int32, Int32, Boolean) | Moves the underline due to user operations (typing)
 | myAdornerLayer | The error layer
 | oldText | The text contained before text changed
 | OnFinishUpdates()()()() | Called when underline updates are finished.
 | OnKeyDown(KeyEventArgs) | Fires KeyDown
 | OnKeyUp(KeyEventArgs) | Fires KeyUp
 | paint()()()() | Not implemented in WPF version
 | PaintUnderlines |
 | prePaint()()()() | Not implemented in WPF version
 | ProcessRightMouseUp(MouseEventArgs) | Handles right mouse up
 | RegisterAdorner(ErrorAdornerBase) | Registers the adorner
 | RemoveAllUnderlines()()()() | Remove all underlines.
 | RemoveUnderline(Int32, Int32, UnderlineStyle, Color) | Removes an existing underline
 | RemoveUnderlinesFor(String) | Removes all underlines that match instances of word.
 | textAdapter | Textbox wrapper
 | textAdapterIAYT | Textbox in IAYTTextBox interface.
 | textBox | The textbox that is being adorned.
 | TextChanged | TextChanged event from text box.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Underline(Int32, Int32, UnderlineStyle, Color, BadWord) | Underlines a word
 | underlines | The underlines being tracked.
 | UnhideUnderline(Int32, Int32) | Unhides a hidden underline
Inheritance Hierarchy
Object
WpfTextBoxBaseUtilityAdapter


WpfTextBoxBaseUtilityAdapter Constructor (t)

WpfTextBoxBaseUtilityAdapter Constructor (t)
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxBaseUtilityAdapter ► WpfTextBoxBaseUtilityAdapter(IAYTTextBox)
Keyoti RapidSpell WPF
Construct a new utility adapter
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public WpfTextBoxBaseUtilityAdapter(
    IAYTTextBox t
)
public WpfTextBoxBaseUtilityAdapter(
    IAYTTextBox t
)
Public Sub New (
    t As IAYTTextBox
)
Public Sub New (
    t As IAYTTextBox
)
public:
WpfTextBoxBaseUtilityAdapter(
    IAYTTextBox^ t
)
public:
WpfTextBoxBaseUtilityAdapter(
    IAYTTextBox^ t
)
new :
        t : IAYTTextBox -> WpfTextBoxBaseUtilityAdapter
new :
        t : IAYTTextBox -> WpfTextBoxBaseUtilityAdapter
Parameters
t (IAYTTextBox)


adorner Field

adorner Field
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxBaseUtilityAdapter ► adorner
Keyoti RapidSpell WPF
Adorner.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected ErrorAdornerBase adorner
protected ErrorAdornerBase adorner
Protected adorner As ErrorAdornerBase
Protected adorner As ErrorAdornerBase
protected:
ErrorAdornerBase^ adorner
protected:
ErrorAdornerBase^ adorner
val mutable adorner: ErrorAdornerBase
val mutable adorner: ErrorAdornerBase
Field Value
ErrorAdornerBase


adornersToAddOnLoad Field

adornersToAddOnLoad Field
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxBaseUtilityAdapter ► adornersToAddOnLoad
Keyoti RapidSpell WPF
Adorners that couldn't be added initially.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected List<Adorner> adornersToAddOnLoad
protected List<Adorner> adornersToAddOnLoad
Protected adornersToAddOnLoad As List(Of Adorner)
Protected adornersToAddOnLoad As List(Of Adorner)
protected:
List<Adorner^>^ adornersToAddOnLoad
protected:
List<Adorner^>^ adornersToAddOnLoad
val mutable adornersToAddOnLoad: List<Adorner>
val mutable adornersToAddOnLoad: List<Adorner>
Field Value
List<(Of <(<'Adorner>)>)>


adornersUnRenderable Field

adornersUnRenderable Field
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxBaseUtilityAdapter ► adornersUnRenderable
Keyoti RapidSpell WPF
Whether any adorners in the layer couldn't be rendered during update.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected bool adornersUnRenderable
protected bool adornersUnRenderable
Protected adornersUnRenderable As Boolean
Protected adornersUnRenderable As Boolean
protected:
bool adornersUnRenderable
protected:
bool adornersUnRenderable
val mutable adornersUnRenderable: bool
val mutable adornersUnRenderable: bool
Field Value
Boolean


currentText Field

currentText Field
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxBaseUtilityAdapter ► currentText
Keyoti RapidSpell WPF
Register of text currently in the text box, updated when it changes.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected string currentText
protected string currentText
Protected currentText As String
Protected currentText As String
protected:
String^ currentText
protected:
String^ currentText
val mutable currentText: string
val mutable currentText: string
Field Value
String


doUpdatesMovedUnderlines Field

doUpdatesMovedUnderlines Field
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxBaseUtilityAdapter ► doUpdatesMovedUnderlines
Keyoti RapidSpell WPF
Internal
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected bool doUpdatesMovedUnderlines
protected bool doUpdatesMovedUnderlines
Protected doUpdatesMovedUnderlines As Boolean
Protected doUpdatesMovedUnderlines As Boolean
protected:
bool doUpdatesMovedUnderlines
protected:
bool doUpdatesMovedUnderlines
val mutable doUpdatesMovedUnderlines: bool
val mutable doUpdatesMovedUnderlines: bool
Field Value
Boolean


FullPaint Method (refreshTextBox)

FullPaint Method (refreshTextBox)
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxBaseUtilityAdapter ► FullPaint(Boolean)
Keyoti RapidSpell WPF
Not implemented in WPF version
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void FullPaint(
    bool refreshTextBox
)
public void FullPaint(
    bool refreshTextBox
)
Public Sub FullPaint (
    refreshTextBox As Boolean
)
Public Sub FullPaint (
    refreshTextBox As Boolean
)
public:
void FullPaint(
    bool refreshTextBox
)
public:
void FullPaint(
    bool refreshTextBox
)
member FullPaint :
        refreshTextBox : bool -> unit

member FullPaint :
        refreshTextBox : bool -> unit
Parameters
refreshTextBox (Boolean)


GetUnderlines Method

GetUnderlines Method
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxBaseUtilityAdapter ► GetUnderlines()()()()
Keyoti RapidSpell WPF
Returns the current underlines collection
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ArrayList GetUnderlines()
public ArrayList GetUnderlines()
Public Function GetUnderlines As ArrayList
Public Function GetUnderlines As ArrayList
public:
ArrayList^ GetUnderlines()
public:
ArrayList^ GetUnderlines()
member GetUnderlines : unit -> ArrayList

member GetUnderlines : unit -> ArrayList
Return Value
ArrayList


HideUnderline Method (startPosition, endPosition)

HideUnderline Method (startPosition, endPosition)
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxBaseUtilityAdapter ► HideUnderline(Int32, Int32)
Keyoti RapidSpell WPF
Hides an existing underline
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void HideUnderline(
    int startPosition,
    int endPosition
)
public virtual void HideUnderline(
    int startPosition,
    int endPosition
)
Public Overridable Sub HideUnderline (
    startPosition As Integer,
    endPosition As Integer
)
Public Overridable Sub HideUnderline (
    startPosition As Integer,
    endPosition As Integer
)
public:
virtual void HideUnderline(
    int startPosition,
    int endPosition
)
public:
virtual void HideUnderline(
    int startPosition,
    int endPosition
)
abstract HideUnderline :
        startPosition : int *
        endPosition : int -> unit
override HideUnderline :
        startPosition : int *
        endPosition : int -> unit
abstract HideUnderline :
        startPosition : int *
        endPosition : int -> unit
override HideUnderline :
        startPosition : int *
        endPosition : int -> unit
Parameters
startPosition (Int32)
endPosition (Int32)


IdentifyChange Method

IdentifyChange Method
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxBaseUtilityAdapter ► IdentifyChange()()()()
Keyoti RapidSpell WPF
Returns the start and end indices in the current text of the changed text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected int[] IdentifyChange()
protected int[] IdentifyChange()
Protected Function IdentifyChange As Integer()
Protected Function IdentifyChange As Integer()
protected:
array<int>^ IdentifyChange()
protected:
array<int>^ IdentifyChange()
member IdentifyChange : unit -> int[]

member IdentifyChange : unit -> int[]
Return Value
array<Int32>[]()[][]


IsFinished Property

IsFinished Property
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxBaseUtilityAdapter ► IsFinished
Keyoti RapidSpell WPF
Whether this object is no longer being used.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IsFinished { get; }
public bool IsFinished { get; }
Public ReadOnly Property IsFinished As Boolean
    Get
Public ReadOnly Property IsFinished As Boolean
    Get
public:
property bool IsFinished {
    bool get ();
}
public:
property bool IsFinished {
    bool get ();
}
member IsFinished : bool with get

member IsFinished : bool with get
Property Value
Boolean


isPositionInUnderline Method (index)

isPositionInUnderline Method (index)
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxBaseUtilityAdapter ► isPositionInUnderline(Int32)
Keyoti RapidSpell WPF
Whether index is inside a visible underline
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool isPositionInUnderline(
    int index
)
public bool isPositionInUnderline(
    int index
)
Public Function isPositionInUnderline (
    index As Integer
) As Boolean
Public Function isPositionInUnderline (
    index As Integer
) As Boolean
public:
bool isPositionInUnderline(
    int index
)
public:
bool isPositionInUnderline(
    int index
)
member isPositionInUnderline :
        index : int -> bool

member isPositionInUnderline :
        index : int -> bool
Parameters
index (Int32)
Return Value
Boolean


KeyDown Event

KeyDown Event
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxBaseUtilityAdapter ► KeyDown
Keyoti RapidSpell WPF
KeyDown event from textbox
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event KeyEventHandler KeyDown
public event KeyEventHandler KeyDown
Public Event KeyDown As KeyEventHandler
Public Event KeyDown As KeyEventHandler
public:
 event KeyEventHandler^ KeyDown {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}
public:
 event KeyEventHandler^ KeyDown {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}
member KeyDown : IEvent<KeyEventHandler,
    KeyEventArgs>

member KeyDown : IEvent<KeyEventHandler,
    KeyEventArgs>
Value
KeyEventHandler


KeyUp Event

KeyUp Event
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxBaseUtilityAdapter ► KeyUp
Keyoti RapidSpell WPF
KeyUp event from textbox
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event KeyEventHandler KeyUp
public event KeyEventHandler KeyUp
Public Event KeyUp As KeyEventHandler
Public Event KeyUp As KeyEventHandler
public:
 event KeyEventHandler^ KeyUp {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}
public:
 event KeyEventHandler^ KeyUp {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}
member KeyUp : IEvent<KeyEventHandler,
    KeyEventArgs>

member KeyUp : IEvent<KeyEventHandler,
    KeyEventArgs>
Value
KeyEventHandler


lastRightClickChar Field

lastRightClickChar Field
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxBaseUtilityAdapter ► lastRightClickChar
Keyoti RapidSpell WPF
Where the last right click was.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected int lastRightClickChar
protected int lastRightClickChar
Protected lastRightClickChar As Integer
Protected lastRightClickChar As Integer
protected:
int lastRightClickChar
protected:
int lastRightClickChar
val mutable lastRightClickChar: int
val mutable lastRightClickChar: int
Field Value
Int32


MoveUnderline Method (u, start, end, bump)

MoveUnderline Method (u, start, end, bump)
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxBaseUtilityAdapter ► MoveUnderline(Underline, Int32, Int32, Boolean)
Keyoti RapidSpell WPF
Moves the underline due to user operations (typing)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void MoveUnderline(
    Underline u,
    int start,
    int end,
    bool bump
)
protected virtual void MoveUnderline(
    Underline u,
    int start,
    int end,
    bool bump
)
Protected Overridable Sub MoveUnderline (
    u As Underline,
    start As Integer,
    end As Integer,
    bump As Boolean
)
Protected Overridable Sub MoveUnderline (
    u As Underline,
    start As Integer,
    end As Integer,
    bump As Boolean
)
protected:
virtual void MoveUnderline(
    Underline^ u,
    int start,
    int end,
    bool bump
)
protected:
virtual void MoveUnderline(
    Underline^ u,
    int start,
    int end,
    bool bump
)
abstract MoveUnderline :
        u : Underline *
        start : int *
        end : int *
        bump : bool -> unit
override MoveUnderline :
        u : Underline *
        start : int *
        end : int *
        bump : bool -> unit
abstract MoveUnderline :
        u : Underline *
        start : int *
        end : int *
        bump : bool -> unit
override MoveUnderline :
        u : Underline *
        start : int *
        end : int *
        bump : bool -> unit
Parameters
u (Underline)
start (Int32)
end (Int32)
bump (Boolean)


myAdornerLayer Field

myAdornerLayer Field
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxBaseUtilityAdapter ► myAdornerLayer
Keyoti RapidSpell WPF
The error layer
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected AdornerLayer myAdornerLayer
protected AdornerLayer myAdornerLayer
Protected myAdornerLayer As AdornerLayer
Protected myAdornerLayer As AdornerLayer
protected:
AdornerLayer^ myAdornerLayer
protected:
AdornerLayer^ myAdornerLayer
val mutable myAdornerLayer: AdornerLayer
val mutable myAdornerLayer: AdornerLayer
Field Value
AdornerLayer


oldText Field

oldText Field
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxBaseUtilityAdapter ► oldText
Keyoti RapidSpell WPF
The text contained before text changed
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected string oldText
protected string oldText
Protected oldText As String
Protected oldText As String
protected:
String^ oldText
protected:
String^ oldText
val mutable oldText: string
val mutable oldText: string
Field Value
String


OnFinishUpdates Method

OnFinishUpdates Method
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxBaseUtilityAdapter ► OnFinishUpdates()()()()
Keyoti RapidSpell WPF
Called when underline updates are finished.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void OnFinishUpdates()
protected virtual void OnFinishUpdates()
Protected Overridable Sub OnFinishUpdates
Protected Overridable Sub OnFinishUpdates
protected:
virtual void OnFinishUpdates()
protected:
virtual void OnFinishUpdates()
abstract OnFinishUpdates : unit -> unit
override OnFinishUpdates : unit -> unit
abstract OnFinishUpdates : unit -> unit
override OnFinishUpdates : unit -> unit


OnKeyDown Method (e)

OnKeyDown Method (e)
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxBaseUtilityAdapter ► OnKeyDown(KeyEventArgs)
Keyoti RapidSpell WPF
Fires KeyDown
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected void OnKeyDown(
    KeyEventArgs e
)
protected void OnKeyDown(
    KeyEventArgs e
)
Protected Sub OnKeyDown (
    e As KeyEventArgs
)
Protected Sub OnKeyDown (
    e As KeyEventArgs
)
protected:
void OnKeyDown(
    KeyEventArgs^ e
)
protected:
void OnKeyDown(
    KeyEventArgs^ e
)
member OnKeyDown :
        e : KeyEventArgs -> unit

member OnKeyDown :
        e : KeyEventArgs -> unit
Parameters
e (KeyEventArgs)


OnKeyUp Method (e)

OnKeyUp Method (e)
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxBaseUtilityAdapter ► OnKeyUp(KeyEventArgs)
Keyoti RapidSpell WPF
Fires KeyUp
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected void OnKeyUp(
    KeyEventArgs e
)
protected void OnKeyUp(
    KeyEventArgs e
)
Protected Sub OnKeyUp (
    e As KeyEventArgs
)
Protected Sub OnKeyUp (
    e As KeyEventArgs
)
protected:
void OnKeyUp(
    KeyEventArgs^ e
)
protected:
void OnKeyUp(
    KeyEventArgs^ e
)
member OnKeyUp :
        e : KeyEventArgs -> unit

member OnKeyUp :
        e : KeyEventArgs -> unit
Parameters
e (KeyEventArgs)


paint Method

paint Method
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxBaseUtilityAdapter ► paint()()()()
Keyoti RapidSpell WPF
Not implemented in WPF version
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected void paint()
protected void paint()
Protected Sub paint
Protected Sub paint
protected:
void paint()
protected:
void paint()
member paint : unit -> unit

member paint : unit -> unit


PaintUnderlines Property

PaintUnderlines Property
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxBaseUtilityAdapter ► PaintUnderlines
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool PaintUnderlines { get; set; }
public bool PaintUnderlines { get; set; }
Public Property PaintUnderlines As Boolean
    Get
    Set
Public Property PaintUnderlines As Boolean
    Get
    Set
public:
property bool PaintUnderlines {
    bool get ();
    void set (bool value);
}
public:
property bool PaintUnderlines {
    bool get ();
    void set (bool value);
}
member PaintUnderlines : bool with get, set

member PaintUnderlines : bool with get, set
Property Value
Boolean


prePaint Method

prePaint Method
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxBaseUtilityAdapter ► prePaint()()()()
Keyoti RapidSpell WPF
Not implemented in WPF version
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected void prePaint()
protected void prePaint()
Protected Sub prePaint
Protected Sub prePaint
protected:
void prePaint()
protected:
void prePaint()
member prePaint : unit -> unit

member prePaint : unit -> unit


ProcessRightMouseUp Method (e)

ProcessRightMouseUp Method (e)
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxBaseUtilityAdapter ► ProcessRightMouseUp(MouseEventArgs)
Keyoti RapidSpell WPF
Handles right mouse up
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected void ProcessRightMouseUp(
    MouseEventArgs e
)
protected void ProcessRightMouseUp(
    MouseEventArgs e
)
Protected Sub ProcessRightMouseUp (
    e As MouseEventArgs
)
Protected Sub ProcessRightMouseUp (
    e As MouseEventArgs
)
protected:
void ProcessRightMouseUp(
    MouseEventArgs^ e
)
protected:
void ProcessRightMouseUp(
    MouseEventArgs^ e
)
member ProcessRightMouseUp :
        e : MouseEventArgs -> unit

member ProcessRightMouseUp :
        e : MouseEventArgs -> unit
Parameters
e (MouseEventArgs)


RegisterAdorner Method (rea)

RegisterAdorner Method (rea)
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxBaseUtilityAdapter ► RegisterAdorner(ErrorAdornerBase)
Keyoti RapidSpell WPF
Registers the adorner
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected void RegisterAdorner(
    ErrorAdornerBase rea
)
protected void RegisterAdorner(
    ErrorAdornerBase rea
)
Protected Sub RegisterAdorner (
    rea As ErrorAdornerBase
)
Protected Sub RegisterAdorner (
    rea As ErrorAdornerBase
)
protected:
void RegisterAdorner(
    ErrorAdornerBase^ rea
)
protected:
void RegisterAdorner(
    ErrorAdornerBase^ rea
)
member RegisterAdorner :
        rea : ErrorAdornerBase -> unit

member RegisterAdorner :
        rea : ErrorAdornerBase -> unit
Parameters
rea (ErrorAdornerBase)


RemoveAllUnderlines Method

RemoveAllUnderlines Method
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxBaseUtilityAdapter ► RemoveAllUnderlines()()()()
Keyoti RapidSpell WPF
Remove all underlines.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void RemoveAllUnderlines()
public virtual void RemoveAllUnderlines()
Public Overridable Sub RemoveAllUnderlines
Public Overridable Sub RemoveAllUnderlines
public:
virtual void RemoveAllUnderlines()
public:
virtual void RemoveAllUnderlines()
abstract RemoveAllUnderlines : unit -> unit
override RemoveAllUnderlines : unit -> unit
abstract RemoveAllUnderlines : unit -> unit
override RemoveAllUnderlines : unit -> unit


RemoveUnderline Method (start, end, u, c)

RemoveUnderline Method (start, end, u, c)
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxBaseUtilityAdapter ► RemoveUnderline(Int32, Int32, UnderlineStyle, Color)
Keyoti RapidSpell WPF
Removes an existing underline
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool RemoveUnderline(
    int start,
    int end,
    UnderlineStyle u,
    Color c
)
public virtual bool RemoveUnderline(
    int start,
    int end,
    UnderlineStyle u,
    Color c
)
Public Overridable Function RemoveUnderline (
    start As Integer,
    end As Integer,
    u As UnderlineStyle,
    c As Color
) As Boolean
Public Overridable Function RemoveUnderline (
    start As Integer,
    end As Integer,
    u As UnderlineStyle,
    c As Color
) As Boolean
public:
virtual bool RemoveUnderline(
    int start,
    int end,
    UnderlineStyle u,
    Color c
)
public:
virtual bool RemoveUnderline(
    int start,
    int end,
    UnderlineStyle u,
    Color c
)
abstract RemoveUnderline :
        start : int *
        end : int *
        u : UnderlineStyle *
        c : Color -> bool
override RemoveUnderline :
        start : int *
        end : int *
        u : UnderlineStyle *
        c : Color -> bool
abstract RemoveUnderline :
        start : int *
        end : int *
        u : UnderlineStyle *
        c : Color -> bool
override RemoveUnderline :
        start : int *
        end : int *
        u : UnderlineStyle *
        c : Color -> bool
Parameters
start (Int32)
end (Int32)
u (UnderlineStyle)
c (Color)
Return Value
Boolean


RemoveUnderlinesFor Method (word)

RemoveUnderlinesFor Method (word)
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxBaseUtilityAdapter ► RemoveUnderlinesFor(String)
Keyoti RapidSpell WPF
Removes all underlines that match instances of word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void RemoveUnderlinesFor(
    string word
)
public void RemoveUnderlinesFor(
    string word
)
Public Sub RemoveUnderlinesFor (
    word As String
)
Public Sub RemoveUnderlinesFor (
    word As String
)
public:
void RemoveUnderlinesFor(
    String^ word
)
public:
void RemoveUnderlinesFor(
    String^ word
)
member RemoveUnderlinesFor :
        word : string -> unit

member RemoveUnderlinesFor :
        word : string -> unit
Parameters
word (String)


textAdapter Field

textAdapter Field
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxBaseUtilityAdapter ► textAdapter
Keyoti RapidSpell WPF
Textbox wrapper
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected WpfBaseAdapter textAdapter
protected WpfBaseAdapter textAdapter
Protected textAdapter As WpfBaseAdapter
Protected textAdapter As WpfBaseAdapter
protected:
WpfBaseAdapter^ textAdapter
protected:
WpfBaseAdapter^ textAdapter
val mutable textAdapter: WpfBaseAdapter
val mutable textAdapter: WpfBaseAdapter
Field Value
WpfBaseAdapter


textAdapterIAYT Field

textAdapterIAYT Field
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxBaseUtilityAdapter ► textAdapterIAYT
Keyoti RapidSpell WPF
Textbox in IAYTTextBox interface.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected IAYTTextBox textAdapterIAYT
protected IAYTTextBox textAdapterIAYT
Protected textAdapterIAYT As IAYTTextBox
Protected textAdapterIAYT As IAYTTextBox
protected:
IAYTTextBox^ textAdapterIAYT
protected:
IAYTTextBox^ textAdapterIAYT
val mutable textAdapterIAYT: IAYTTextBox
val mutable textAdapterIAYT: IAYTTextBox
Field Value
IAYTTextBox


textBox Field

textBox Field
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxBaseUtilityAdapter ► textBox
Keyoti RapidSpell WPF
The textbox that is being adorned.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected TextBoxBase textBox
protected TextBoxBase textBox
Protected textBox As TextBoxBase
Protected textBox As TextBoxBase
protected:
TextBoxBase^ textBox
protected:
TextBoxBase^ textBox
val mutable textBox: TextBoxBase
val mutable textBox: TextBoxBase
Field Value
TextBoxBase


TextChanged Event

TextChanged Event
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxBaseUtilityAdapter ► TextChanged
Keyoti RapidSpell WPF
TextChanged event from text box.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler TextChanged
public event EventHandler TextChanged
Public Event TextChanged As EventHandler
Public Event TextChanged As EventHandler
public:
 event EventHandler^ TextChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
 event EventHandler^ TextChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member TextChanged : IEvent<EventHandler,
    EventArgs>

member TextChanged : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


Underline Method (start, end, u, c, originalBadWord)

Underline Method (start, end, u, c, originalBadWord)
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxBaseUtilityAdapter ► Underline(Int32, Int32, UnderlineStyle, Color, BadWord)
Keyoti RapidSpell WPF
Underlines a word
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void Underline(
    int start,
    int end,
    UnderlineStyle u,
    Color c,
    BadWord originalBadWord
)
public virtual void Underline(
    int start,
    int end,
    UnderlineStyle u,
    Color c,
    BadWord originalBadWord
)
Public Overridable Sub Underline (
    start As Integer,
    end As Integer,
    u As UnderlineStyle,
    c As Color,
    originalBadWord As BadWord
)
Public Overridable Sub Underline (
    start As Integer,
    end As Integer,
    u As UnderlineStyle,
    c As Color,
    originalBadWord As BadWord
)
public:
virtual void Underline(
    int start,
    int end,
    UnderlineStyle u,
    Color c,
    BadWord^ originalBadWord
)
public:
virtual void Underline(
    int start,
    int end,
    UnderlineStyle u,
    Color c,
    BadWord^ originalBadWord
)
abstract Underline :
        start : int *
        end : int *
        u : UnderlineStyle *
        c : Color *
        originalBadWord : BadWord -> unit
override Underline :
        start : int *
        end : int *
        u : UnderlineStyle *
        c : Color *
        originalBadWord : BadWord -> unit
abstract Underline :
        start : int *
        end : int *
        u : UnderlineStyle *
        c : Color *
        originalBadWord : BadWord -> unit
override Underline :
        start : int *
        end : int *
        u : UnderlineStyle *
        c : Color *
        originalBadWord : BadWord -> unit
Parameters
start (Int32)
end (Int32)
u (UnderlineStyle)
c (Color)
originalBadWord (BadWord)


underlines Field

underlines Field
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxBaseUtilityAdapter ► underlines
Keyoti RapidSpell WPF
The underlines being tracked.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected ArrayList underlines
protected ArrayList underlines
Protected underlines As ArrayList
Protected underlines As ArrayList
protected:
ArrayList^ underlines
protected:
ArrayList^ underlines
val mutable underlines: ArrayList
val mutable underlines: ArrayList
Field Value
ArrayList


UnhideUnderline Method (startPosition, endPosition)

UnhideUnderline Method (startPosition, endPosition)
API ► Keyoti.RapidSpell.Wpf ► WpfTextBoxBaseUtilityAdapter ► UnhideUnderline(Int32, Int32)
Keyoti RapidSpell WPF
Unhides a hidden underline
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void UnhideUnderline(
    int startPosition,
    int endPosition
)
public virtual void UnhideUnderline(
    int startPosition,
    int endPosition
)
Public Overridable Sub UnhideUnderline (
    startPosition As Integer,
    endPosition As Integer
)
Public Overridable Sub UnhideUnderline (
    startPosition As Integer,
    endPosition As Integer
)
public:
virtual void UnhideUnderline(
    int startPosition,
    int endPosition
)
public:
virtual void UnhideUnderline(
    int startPosition,
    int endPosition
)
abstract UnhideUnderline :
        startPosition : int *
        endPosition : int -> unit
override UnhideUnderline :
        startPosition : int *
        endPosition : int -> unit
abstract UnhideUnderline :
        startPosition : int *
        endPosition : int -> unit
override UnhideUnderline :
        startPosition : int *
        endPosition : int -> unit
Parameters
startPosition (Int32)
endPosition (Int32)


Keyoti.RapidSpell.Wpf.DialogViews Namespace

Keyoti.RapidSpell.Wpf.DialogViews Namespace
API ► Keyoti.RapidSpell.Wpf.DialogViews
Keyoti RapidSpell WPF
Types
All Types Classes Interfaces Enumerations
Icon | Type | Description
 | DialogResult | Possible results from a dialog message box.
 | IconHelper | Removes a window's icon
 | IDialogView | Describes what a view used by RapidSpellDialog/RapidSpellGUIPresenter must implement.
 | IDialogViewEventHandler | Describes a class which can handle events from an IDialogView.
 | IDialogViewOptions | Describes an option editor form
 | IDialogViewUserDictionaryEdit | Describes a user dictionary editor window
 | IDialogViewUserDictionarySelect | Describes a user dictionary editor window
 | MessageBoxButtons | Message box button combinations
 | MessageBoxIcon | Icon for a message box
 | MessageBoxWPF | WPF styled message box.
 | WPFUserDictionarySelect | Interaction logic for WpfFormsUserDictionarySelect.xaml WPFUserDictionarySelect


DialogResult Enumeration

DialogResult Enumeration
API ► Keyoti.RapidSpell.Wpf.DialogViews ► DialogResult
Keyoti RapidSpell WPF
Possible results from a dialog message box.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public enum DialogResult
public enum DialogResult
Public Enumeration DialogResult
Public Enumeration DialogResult
public enum class DialogResult
public enum class DialogResult
type DialogResult
type DialogResult
Members
Member | Description
Yes | Yes
No | No
OK | OK
Cancel | Cancel
Close | Close


IconHelper Class

IconHelper Class
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IconHelper
Keyoti RapidSpell WPF
Removes a window's icon
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static class IconHelper
public static class IconHelper
Public NotInheritable Class IconHelper
Public NotInheritable Class IconHelper
public ref class IconHelper abstract sealed
public ref class IconHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type IconHelper =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type IconHelper =  class end
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | RemoveIcon(Window) | Removes the icon in a window's titlebar
Inheritance Hierarchy
Object
IconHelper


RemoveIcon Method (window)

RemoveIcon Method (window)
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IconHelper ► RemoveIcon(Window)
Keyoti RapidSpell WPF
Removes the icon in a window's titlebar
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static void RemoveIcon(
    Window window
)
public static void RemoveIcon(
    Window window
)
Public Shared Sub RemoveIcon (
    window As Window
)
Public Shared Sub RemoveIcon (
    window As Window
)
public:
static void RemoveIcon(
    Window^ window
)
public:
static void RemoveIcon(
    Window^ window
)
static member RemoveIcon :
        window : Window -> unit

static member RemoveIcon :
        window : Window -> unit
Parameters
window (Window)


IDialogView Interface

IDialogView Interface
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView
Keyoti RapidSpell WPF
Describes what a view used by RapidSpellDialog/RapidSpellGUIPresenter must implement.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public interface IDialogView
public interface IDialogView
Public Interface IDialogView
Public Interface IDialogView
public interface class IDialogView
public interface class IDialogView
type IDialogView =  interface end
type IDialogView =  interface end
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddButtonEnabled | Whether the add button is enabled
 | AddButtonText | Add button text
 | AddButtonVisible | Whether the add button is visible
 | CancelButtonText | Cancel button text
 | ChangeAllButtonEnabled | Whether the change all button is enabled
 | ChangeAllButtonText | Change all button text
 | ChangeButtonEnabled | Whether the change button is enabled
 | ChangeButtonText | Change button text
 | Close()()()() | Closes the form if open.
 | Dispose()()()() | Disposes of unmanaged resources.
 | Focus()()()() | Give focus to the form.
 | GetQueryCorrection()()()() | Return the word from the query text box, as the user may have modified
 | IgnoreAllButtonEnabled | Whether the ignore all button is enabled
 | IgnoreAllButtonText | Ignore all button text
 | IgnoreButtonEnabled | Whether the ignore button is enabled
 | IgnoreButtonSelect()()()() | Select the ignore button
 | IgnoreButtonText | Ignore button text
 | IsDisposed | Gets a value indicating whether the control has been disposed of.
 | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
 | NotInDictionaryLabelText | Label text indicating whether in dictionary or not
 | OptionsButtonText | Options button text
 | QueryTextBoxMultiline | Whether 'not in dictionary' text box is multiline or single line.
 | RegisterEvents(IDialogViewEventHandler) | Hook up view events to handler
 | SetQuery(String, String, String) | Specifies the spelling query
 | Show()()()() | Show non modally
 | ShowDialog()()()() | Show modally
 | ShowDialog(Object) | Show modally
 | ShowMessageBox(String, String, MessageBoxButtons, MessageBoxIcon) | Show a message box for the user
 | ShowOptionsButton | Whether to show the options button.
 | ShowUndoButton | Whether to show the undo button.
 | SuggestionFinderCheckBoxChecked | Whether the find suggestions checkbox is checked (may not be shown)
 | SuggestionFinderCheckBoxEnabled | Whether the suggestion finder checkbox is enabled
 | SuggestionFinderCheckBoxText | Suggestion finder checkbox text
 | SuggestionsLabelEnabled | Whether the suggestions label is enabled
 | SuggestionsLabelText | Suggestion label text
 | SuggestionsListClear()()()() | Clear the suggestions list
 | SuggestionsListDeselect()()()() | Deselect all items from the suggestions list
 | SuggestionsListEnabled | Whether the suggestions list is enabled
 | SuggestionsListItems | All the suggestion items
 | SuggestionsListSelectedItem | The selected suggestion item
 | Title | Window title
 | UIThreadInvoke(Delegate) | Invoke in the UI thread the delegate d
 | UIThreadInvoke(Delegate, array<Object>[]()[][]) | Invoke in the UI thread the delegate d with parameters
 | UndoButtonEnabled | Whether the undo button is enabled
 | UndoButtonText | Undo button text
 | UnregisterEvents(IDialogViewEventHandler) | Remove view event subscriptions from handler
 | Visible | Gets or sets a value indicating whether the control is displayed.


AddButtonEnabled Property

AddButtonEnabled Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► AddButtonEnabled
Keyoti RapidSpell WPF
Whether the add button is enabled
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool AddButtonEnabled { get; set; }
bool AddButtonEnabled { get; set; }
Property AddButtonEnabled As Boolean
    Get
    Set
Property AddButtonEnabled As Boolean
    Get
    Set
property bool AddButtonEnabled {
    bool get ();
    void set (bool value);
}
property bool AddButtonEnabled {
    bool get ();
    void set (bool value);
}
abstract AddButtonEnabled : bool with get, set

abstract AddButtonEnabled : bool with get, set
Property Value
Boolean


AddButtonText Property

AddButtonText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► AddButtonText
Keyoti RapidSpell WPF
Add button text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string AddButtonText { get; set; }
string AddButtonText { get; set; }
Property AddButtonText As String
    Get
    Set
Property AddButtonText As String
    Get
    Set
property String^ AddButtonText {
    String^ get ();
    void set (String^ value);
}
property String^ AddButtonText {
    String^ get ();
    void set (String^ value);
}
abstract AddButtonText : string with get, set

abstract AddButtonText : string with get, set
Property Value
String


AddButtonVisible Property

AddButtonVisible Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► AddButtonVisible
Keyoti RapidSpell WPF
Whether the add button is visible
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool AddButtonVisible { get; set; }
bool AddButtonVisible { get; set; }
Property AddButtonVisible As Boolean
    Get
    Set
Property AddButtonVisible As Boolean
    Get
    Set
property bool AddButtonVisible {
    bool get ();
    void set (bool value);
}
property bool AddButtonVisible {
    bool get ();
    void set (bool value);
}
abstract AddButtonVisible : bool with get, set

abstract AddButtonVisible : bool with get, set
Property Value
Boolean


CancelButtonText Property

CancelButtonText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► CancelButtonText
Keyoti RapidSpell WPF
Cancel button text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string CancelButtonText { get; set; }
string CancelButtonText { get; set; }
Property CancelButtonText As String
    Get
    Set
Property CancelButtonText As String
    Get
    Set
property String^ CancelButtonText {
    String^ get ();
    void set (String^ value);
}
property String^ CancelButtonText {
    String^ get ();
    void set (String^ value);
}
abstract CancelButtonText : string with get, set

abstract CancelButtonText : string with get, set
Property Value
String


ChangeAllButtonEnabled Property

ChangeAllButtonEnabled Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► ChangeAllButtonEnabled
Keyoti RapidSpell WPF
Whether the change all button is enabled
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool ChangeAllButtonEnabled { get; set; }
bool ChangeAllButtonEnabled { get; set; }
Property ChangeAllButtonEnabled As Boolean
    Get
    Set
Property ChangeAllButtonEnabled As Boolean
    Get
    Set
property bool ChangeAllButtonEnabled {
    bool get ();
    void set (bool value);
}
property bool ChangeAllButtonEnabled {
    bool get ();
    void set (bool value);
}
abstract ChangeAllButtonEnabled : bool with get, set

abstract ChangeAllButtonEnabled : bool with get, set
Property Value
Boolean


ChangeAllButtonText Property

ChangeAllButtonText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► ChangeAllButtonText
Keyoti RapidSpell WPF
Change all button text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string ChangeAllButtonText { get; set; }
string ChangeAllButtonText { get; set; }
Property ChangeAllButtonText As String
    Get
    Set
Property ChangeAllButtonText As String
    Get
    Set
property String^ ChangeAllButtonText {
    String^ get ();
    void set (String^ value);
}
property String^ ChangeAllButtonText {
    String^ get ();
    void set (String^ value);
}
abstract ChangeAllButtonText : string with get, set

abstract ChangeAllButtonText : string with get, set
Property Value
String


ChangeButtonEnabled Property

ChangeButtonEnabled Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► ChangeButtonEnabled
Keyoti RapidSpell WPF
Whether the change button is enabled
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool ChangeButtonEnabled { get; set; }
bool ChangeButtonEnabled { get; set; }
Property ChangeButtonEnabled As Boolean
    Get
    Set
Property ChangeButtonEnabled As Boolean
    Get
    Set
property bool ChangeButtonEnabled {
    bool get ();
    void set (bool value);
}
property bool ChangeButtonEnabled {
    bool get ();
    void set (bool value);
}
abstract ChangeButtonEnabled : bool with get, set

abstract ChangeButtonEnabled : bool with get, set
Property Value
Boolean


ChangeButtonText Property

ChangeButtonText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► ChangeButtonText
Keyoti RapidSpell WPF
Change button text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string ChangeButtonText { get; set; }
string ChangeButtonText { get; set; }
Property ChangeButtonText As String
    Get
    Set
Property ChangeButtonText As String
    Get
    Set
property String^ ChangeButtonText {
    String^ get ();
    void set (String^ value);
}
property String^ ChangeButtonText {
    String^ get ();
    void set (String^ value);
}
abstract ChangeButtonText : string with get, set

abstract ChangeButtonText : string with get, set
Property Value
String


Close Method

Close Method
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► Close()()()()
Keyoti RapidSpell WPF
Closes the form if open.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void Close()
void Close()
Sub Close
Sub Close
void Close()
void Close()
abstract Close : unit -> unit

abstract Close : unit -> unit


Dispose Method

Dispose Method
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► Dispose()()()()
Keyoti RapidSpell WPF
Disposes of unmanaged resources.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void Dispose()
void Dispose()
Sub Dispose
Sub Dispose
void Dispose()
void Dispose()
abstract Dispose : unit -> unit

abstract Dispose : unit -> unit


Focus Method

Focus Method
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► Focus()()()()
Keyoti RapidSpell WPF
Give focus to the form.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool Focus()
bool Focus()
Function Focus As Boolean
Function Focus As Boolean
bool Focus()
bool Focus()
abstract Focus : unit -> bool

abstract Focus : unit -> bool
Return Value
Boolean


GetQueryCorrection Method

GetQueryCorrection Method
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► GetQueryCorrection()()()()
Keyoti RapidSpell WPF
Return the word from the query text box, as the user may have modified
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string GetQueryCorrection()
string GetQueryCorrection()
Function GetQueryCorrection As String
Function GetQueryCorrection As String
String^ GetQueryCorrection()
String^ GetQueryCorrection()
abstract GetQueryCorrection : unit -> string

abstract GetQueryCorrection : unit -> string
Return Value
String


IgnoreAllButtonEnabled Property

IgnoreAllButtonEnabled Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► IgnoreAllButtonEnabled
Keyoti RapidSpell WPF
Whether the ignore all button is enabled
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool IgnoreAllButtonEnabled { get; set; }
bool IgnoreAllButtonEnabled { get; set; }
Property IgnoreAllButtonEnabled As Boolean
    Get
    Set
Property IgnoreAllButtonEnabled As Boolean
    Get
    Set
property bool IgnoreAllButtonEnabled {
    bool get ();
    void set (bool value);
}
property bool IgnoreAllButtonEnabled {
    bool get ();
    void set (bool value);
}
abstract IgnoreAllButtonEnabled : bool with get, set

abstract IgnoreAllButtonEnabled : bool with get, set
Property Value
Boolean


IgnoreAllButtonText Property

IgnoreAllButtonText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► IgnoreAllButtonText
Keyoti RapidSpell WPF
Ignore all button text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string IgnoreAllButtonText { get; set; }
string IgnoreAllButtonText { get; set; }
Property IgnoreAllButtonText As String
    Get
    Set
Property IgnoreAllButtonText As String
    Get
    Set
property String^ IgnoreAllButtonText {
    String^ get ();
    void set (String^ value);
}
property String^ IgnoreAllButtonText {
    String^ get ();
    void set (String^ value);
}
abstract IgnoreAllButtonText : string with get, set

abstract IgnoreAllButtonText : string with get, set
Property Value
String


IgnoreButtonEnabled Property

IgnoreButtonEnabled Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► IgnoreButtonEnabled
Keyoti RapidSpell WPF
Whether the ignore button is enabled
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool IgnoreButtonEnabled { get; set; }
bool IgnoreButtonEnabled { get; set; }
Property IgnoreButtonEnabled As Boolean
    Get
    Set
Property IgnoreButtonEnabled As Boolean
    Get
    Set
property bool IgnoreButtonEnabled {
    bool get ();
    void set (bool value);
}
property bool IgnoreButtonEnabled {
    bool get ();
    void set (bool value);
}
abstract IgnoreButtonEnabled : bool with get, set

abstract IgnoreButtonEnabled : bool with get, set
Property Value
Boolean


IgnoreButtonSelect Method

IgnoreButtonSelect Method
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► IgnoreButtonSelect()()()()
Keyoti RapidSpell WPF
Select the ignore button
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void IgnoreButtonSelect()
void IgnoreButtonSelect()
Sub IgnoreButtonSelect
Sub IgnoreButtonSelect
void IgnoreButtonSelect()
void IgnoreButtonSelect()
abstract IgnoreButtonSelect : unit -> unit

abstract IgnoreButtonSelect : unit -> unit


IgnoreButtonText Property

IgnoreButtonText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► IgnoreButtonText
Keyoti RapidSpell WPF
Ignore button text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string IgnoreButtonText { get; set; }
string IgnoreButtonText { get; set; }
Property IgnoreButtonText As String
    Get
    Set
Property IgnoreButtonText As String
    Get
    Set
property String^ IgnoreButtonText {
    String^ get ();
    void set (String^ value);
}
property String^ IgnoreButtonText {
    String^ get ();
    void set (String^ value);
}
abstract IgnoreButtonText : string with get, set

abstract IgnoreButtonText : string with get, set
Property Value
String


IsDisposed Property

IsDisposed Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► IsDisposed
Keyoti RapidSpell WPF
Gets a value indicating whether the control has been disposed of.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool IsDisposed { get; }
bool IsDisposed { get; }
ReadOnly Property IsDisposed As Boolean
    Get
ReadOnly Property IsDisposed As Boolean
    Get
property bool IsDisposed {
    bool get ();
}
property bool IsDisposed {
    bool get ();
}
abstract IsDisposed : bool with get

abstract IsDisposed : bool with get
Property Value
Boolean


Location Property

Location Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► Location
Keyoti RapidSpell WPF
Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
Point Location { get; set; }
Point Location { get; set; }
Property Location As Point
    Get
    Set
Property Location As Point
    Get
    Set
property Point Location {
    Point get ();
    void set (Point value);
}
property Point Location {
    Point get ();
    void set (Point value);
}
abstract Location : Point with get, set

abstract Location : Point with get, set
Property Value
Point


NotInDictionaryLabelText Property

NotInDictionaryLabelText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► NotInDictionaryLabelText
Keyoti RapidSpell WPF
Label text indicating whether in dictionary or not
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string NotInDictionaryLabelText { get; set; }
string NotInDictionaryLabelText { get; set; }
Property NotInDictionaryLabelText As String
    Get
    Set
Property NotInDictionaryLabelText As String
    Get
    Set
property String^ NotInDictionaryLabelText {
    String^ get ();
    void set (String^ value);
}
property String^ NotInDictionaryLabelText {
    String^ get ();
    void set (String^ value);
}
abstract NotInDictionaryLabelText : string with get, set

abstract NotInDictionaryLabelText : string with get, set
Property Value
String


OptionsButtonText Property

OptionsButtonText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► OptionsButtonText
Keyoti RapidSpell WPF
Options button text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string OptionsButtonText { get; set; }
string OptionsButtonText { get; set; }
Property OptionsButtonText As String
    Get
    Set
Property OptionsButtonText As String
    Get
    Set
property String^ OptionsButtonText {
    String^ get ();
    void set (String^ value);
}
property String^ OptionsButtonText {
    String^ get ();
    void set (String^ value);
}
abstract OptionsButtonText : string with get, set

abstract OptionsButtonText : string with get, set
Property Value
String


QueryTextBoxMultiline Property

QueryTextBoxMultiline Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► QueryTextBoxMultiline
Keyoti RapidSpell WPF
Whether 'not in dictionary' text box is multiline or single line.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool QueryTextBoxMultiline { get; set; }
bool QueryTextBoxMultiline { get; set; }
Property QueryTextBoxMultiline As Boolean
    Get
    Set
Property QueryTextBoxMultiline As Boolean
    Get
    Set
property bool QueryTextBoxMultiline {
    bool get ();
    void set (bool value);
}
property bool QueryTextBoxMultiline {
    bool get ();
    void set (bool value);
}
abstract QueryTextBoxMultiline : bool with get, set

abstract QueryTextBoxMultiline : bool with get, set
Property Value
Boolean


RegisterEvents Method (handler)

RegisterEvents Method (handler)
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► RegisterEvents(IDialogViewEventHandler)
Keyoti RapidSpell WPF
Hook up view events to handler
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void RegisterEvents(
    IDialogViewEventHandler handler
)
void RegisterEvents(
    IDialogViewEventHandler handler
)
Sub RegisterEvents (
    handler As IDialogViewEventHandler
)
Sub RegisterEvents (
    handler As IDialogViewEventHandler
)
void RegisterEvents(
    IDialogViewEventHandler^ handler
)
void RegisterEvents(
    IDialogViewEventHandler^ handler
)
abstract RegisterEvents :
        handler : IDialogViewEventHandler -> unit

abstract RegisterEvents :
        handler : IDialogViewEventHandler -> unit
Parameters
handler (IDialogViewEventHandler)


SetQuery Method (beforeSentence, word, afterSentence)

SetQuery Method (beforeSentence, word, afterSentence)
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► SetQuery(String, String, String)
Keyoti RapidSpell WPF
Specifies the spelling query
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void SetQuery(
    string beforeSentence,
    string word,
    string afterSentence
)
void SetQuery(
    string beforeSentence,
    string word,
    string afterSentence
)
Sub SetQuery (
    beforeSentence As String,
    word As String,
    afterSentence As String
)
Sub SetQuery (
    beforeSentence As String,
    word As String,
    afterSentence As String
)
void SetQuery(
    String^ beforeSentence,
    String^ word,
    String^ afterSentence
)
void SetQuery(
    String^ beforeSentence,
    String^ word,
    String^ afterSentence
)
abstract SetQuery :
        beforeSentence : string *
        word : string *
        afterSentence : string -> unit

abstract SetQuery :
        beforeSentence : string *
        word : string *
        afterSentence : string -> unit
Parameters
beforeSentence (String)
The context sentence before the error
word (String)
The actual error
afterSentence (String)
The context sentence after the error


Show Method

Show Method
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► Show()()()()
Keyoti RapidSpell WPF
Show non modally
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void Show()
void Show()
Sub Show
Sub Show
void Show()
void Show()
abstract Show : unit -> unit

abstract Show : unit -> unit


ShowDialog Method

ShowDialog Method
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► ShowDialog()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | ShowDialog()()()() | Show modally
 | ShowDialog(Object) | Show modally


ShowDialog Method

ShowDialog Method
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► ShowDialog()()()()
Keyoti RapidSpell WPF
Show modally
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
DialogResult ShowDialog()
DialogResult ShowDialog()
Function ShowDialog As DialogResult
Function ShowDialog As DialogResult
DialogResult ShowDialog()
DialogResult ShowDialog()
abstract ShowDialog : unit -> DialogResult

abstract ShowDialog : unit -> DialogResult
Return Value
DialogResult


ShowDialog Method (owner)

ShowDialog Method (owner)
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► ShowDialog(Object)
Keyoti RapidSpell WPF
Show modally
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
DialogResult ShowDialog(
    Object owner
)
DialogResult ShowDialog(
    Object owner
)
Function ShowDialog (
    owner As Object
) As DialogResult
Function ShowDialog (
    owner As Object
) As DialogResult
DialogResult ShowDialog(
    Object^ owner
)
DialogResult ShowDialog(
    Object^ owner
)
abstract ShowDialog :
        owner : Object -> DialogResult

abstract ShowDialog :
        owner : Object -> DialogResult
Parameters
owner (Object)
The owner window
Return Value
DialogResult


ShowMessageBox Method (message, title, buttons, icon)

ShowMessageBox Method (message, title, buttons, icon)
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► ShowMessageBox(String, String, MessageBoxButtons, MessageBoxIcon)
Keyoti RapidSpell WPF
Show a message box for the user
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
DialogResult ShowMessageBox(
    string message,
    string title,
    MessageBoxButtons buttons,
    MessageBoxIcon icon
)
DialogResult ShowMessageBox(
    string message,
    string title,
    MessageBoxButtons buttons,
    MessageBoxIcon icon
)
Function ShowMessageBox (
    message As String,
    title As String,
    buttons As MessageBoxButtons,
    icon As MessageBoxIcon
) As DialogResult
Function ShowMessageBox (
    message As String,
    title As String,
    buttons As MessageBoxButtons,
    icon As MessageBoxIcon
) As DialogResult
DialogResult ShowMessageBox(
    String^ message,
    String^ title,
    MessageBoxButtons buttons,
    MessageBoxIcon icon
)
DialogResult ShowMessageBox(
    String^ message,
    String^ title,
    MessageBoxButtons buttons,
    MessageBoxIcon icon
)
abstract ShowMessageBox :
        message : string *
        title : string *
        buttons : MessageBoxButtons *
        icon : MessageBoxIcon -> DialogResult

abstract ShowMessageBox :
        message : string *
        title : string *
        buttons : MessageBoxButtons *
        icon : MessageBoxIcon -> DialogResult
Parameters
message (String)
title (String)
buttons (MessageBoxButtons)
icon (MessageBoxIcon)
Return Value
DialogResult


ShowOptionsButton Property

ShowOptionsButton Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► ShowOptionsButton
Keyoti RapidSpell WPF
Whether to show the options button.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool ShowOptionsButton { get; set; }
bool ShowOptionsButton { get; set; }
Property ShowOptionsButton As Boolean
    Get
    Set
Property ShowOptionsButton As Boolean
    Get
    Set
property bool ShowOptionsButton {
    bool get ();
    void set (bool value);
}
property bool ShowOptionsButton {
    bool get ();
    void set (bool value);
}
abstract ShowOptionsButton : bool with get, set

abstract ShowOptionsButton : bool with get, set
Property Value
Boolean


ShowUndoButton Property

ShowUndoButton Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► ShowUndoButton
Keyoti RapidSpell WPF
Whether to show the undo button.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool ShowUndoButton { get; set; }
bool ShowUndoButton { get; set; }
Property ShowUndoButton As Boolean
    Get
    Set
Property ShowUndoButton As Boolean
    Get
    Set
property bool ShowUndoButton {
    bool get ();
    void set (bool value);
}
property bool ShowUndoButton {
    bool get ();
    void set (bool value);
}
abstract ShowUndoButton : bool with get, set

abstract ShowUndoButton : bool with get, set
Property Value
Boolean


SuggestionFinderCheckBoxChecked Property

SuggestionFinderCheckBoxChecked Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► SuggestionFinderCheckBoxChecked
Keyoti RapidSpell WPF
Whether the find suggestions checkbox is checked (may not be shown)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool SuggestionFinderCheckBoxChecked { get; set; }
bool SuggestionFinderCheckBoxChecked { get; set; }
Property SuggestionFinderCheckBoxChecked As Boolean
    Get
    Set
Property SuggestionFinderCheckBoxChecked As Boolean
    Get
    Set
property bool SuggestionFinderCheckBoxChecked {
    bool get ();
    void set (bool value);
}
property bool SuggestionFinderCheckBoxChecked {
    bool get ();
    void set (bool value);
}
abstract SuggestionFinderCheckBoxChecked : bool with get, set

abstract SuggestionFinderCheckBoxChecked : bool with get, set
Property Value
Boolean


SuggestionFinderCheckBoxEnabled Property

SuggestionFinderCheckBoxEnabled Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► SuggestionFinderCheckBoxEnabled
Keyoti RapidSpell WPF
Whether the suggestion finder checkbox is enabled
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool SuggestionFinderCheckBoxEnabled { get; set; }
bool SuggestionFinderCheckBoxEnabled { get; set; }
Property SuggestionFinderCheckBoxEnabled As Boolean
    Get
    Set
Property SuggestionFinderCheckBoxEnabled As Boolean
    Get
    Set
property bool SuggestionFinderCheckBoxEnabled {
    bool get ();
    void set (bool value);
}
property bool SuggestionFinderCheckBoxEnabled {
    bool get ();
    void set (bool value);
}
abstract SuggestionFinderCheckBoxEnabled : bool with get, set

abstract SuggestionFinderCheckBoxEnabled : bool with get, set
Property Value
Boolean


SuggestionFinderCheckBoxText Property

SuggestionFinderCheckBoxText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► SuggestionFinderCheckBoxText
Keyoti RapidSpell WPF
Suggestion finder checkbox text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string SuggestionFinderCheckBoxText { get; set; }
string SuggestionFinderCheckBoxText { get; set; }
Property SuggestionFinderCheckBoxText As String
    Get
    Set
Property SuggestionFinderCheckBoxText As String
    Get
    Set
property String^ SuggestionFinderCheckBoxText {
    String^ get ();
    void set (String^ value);
}
property String^ SuggestionFinderCheckBoxText {
    String^ get ();
    void set (String^ value);
}
abstract SuggestionFinderCheckBoxText : string with get, set

abstract SuggestionFinderCheckBoxText : string with get, set
Property Value
String


SuggestionsLabelEnabled Property

SuggestionsLabelEnabled Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► SuggestionsLabelEnabled
Keyoti RapidSpell WPF
Whether the suggestions label is enabled
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool SuggestionsLabelEnabled { get; set; }
bool SuggestionsLabelEnabled { get; set; }
Property SuggestionsLabelEnabled As Boolean
    Get
    Set
Property SuggestionsLabelEnabled As Boolean
    Get
    Set
property bool SuggestionsLabelEnabled {
    bool get ();
    void set (bool value);
}
property bool SuggestionsLabelEnabled {
    bool get ();
    void set (bool value);
}
abstract SuggestionsLabelEnabled : bool with get, set

abstract SuggestionsLabelEnabled : bool with get, set
Property Value
Boolean


SuggestionsLabelText Property

SuggestionsLabelText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► SuggestionsLabelText
Keyoti RapidSpell WPF
Suggestion label text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string SuggestionsLabelText { get; set; }
string SuggestionsLabelText { get; set; }
Property SuggestionsLabelText As String
    Get
    Set
Property SuggestionsLabelText As String
    Get
    Set
property String^ SuggestionsLabelText {
    String^ get ();
    void set (String^ value);
}
property String^ SuggestionsLabelText {
    String^ get ();
    void set (String^ value);
}
abstract SuggestionsLabelText : string with get, set

abstract SuggestionsLabelText : string with get, set
Property Value
String


SuggestionsListClear Method

SuggestionsListClear Method
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► SuggestionsListClear()()()()
Keyoti RapidSpell WPF
Clear the suggestions list
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void SuggestionsListClear()
void SuggestionsListClear()
Sub SuggestionsListClear
Sub SuggestionsListClear
void SuggestionsListClear()
void SuggestionsListClear()
abstract SuggestionsListClear : unit -> unit

abstract SuggestionsListClear : unit -> unit


SuggestionsListDeselect Method

SuggestionsListDeselect Method
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► SuggestionsListDeselect()()()()
Keyoti RapidSpell WPF
Deselect all items from the suggestions list
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void SuggestionsListDeselect()
void SuggestionsListDeselect()
Sub SuggestionsListDeselect
Sub SuggestionsListDeselect
void SuggestionsListDeselect()
void SuggestionsListDeselect()
abstract SuggestionsListDeselect : unit -> unit

abstract SuggestionsListDeselect : unit -> unit


SuggestionsListEnabled Property

SuggestionsListEnabled Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► SuggestionsListEnabled
Keyoti RapidSpell WPF
Whether the suggestions list is enabled
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool SuggestionsListEnabled { get; set; }
bool SuggestionsListEnabled { get; set; }
Property SuggestionsListEnabled As Boolean
    Get
    Set
Property SuggestionsListEnabled As Boolean
    Get
    Set
property bool SuggestionsListEnabled {
    bool get ();
    void set (bool value);
}
property bool SuggestionsListEnabled {
    bool get ();
    void set (bool value);
}
abstract SuggestionsListEnabled : bool with get, set

abstract SuggestionsListEnabled : bool with get, set
Property Value
Boolean


SuggestionsListItems Property

SuggestionsListItems Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► SuggestionsListItems
Keyoti RapidSpell WPF
All the suggestion items
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
Object SuggestionsListItems { get; set; }
Object SuggestionsListItems { get; set; }
Property SuggestionsListItems As Object
    Get
    Set
Property SuggestionsListItems As Object
    Get
    Set
property Object^ SuggestionsListItems {
    Object^ get ();
    void set (Object^ value);
}
property Object^ SuggestionsListItems {
    Object^ get ();
    void set (Object^ value);
}
abstract SuggestionsListItems : Object with get, set

abstract SuggestionsListItems : Object with get, set
Property Value
Object


SuggestionsListSelectedItem Property

SuggestionsListSelectedItem Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► SuggestionsListSelectedItem
Keyoti RapidSpell WPF
The selected suggestion item
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string SuggestionsListSelectedItem { get; }
string SuggestionsListSelectedItem { get; }
ReadOnly Property SuggestionsListSelectedItem As String
    Get
ReadOnly Property SuggestionsListSelectedItem As String
    Get
property String^ SuggestionsListSelectedItem {
    String^ get ();
}
property String^ SuggestionsListSelectedItem {
    String^ get ();
}
abstract SuggestionsListSelectedItem : string with get

abstract SuggestionsListSelectedItem : string with get
Property Value
String


Title Property

Title Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► Title
Keyoti RapidSpell WPF
Window title
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string Title { get; set; }
string Title { get; set; }
Property Title As String
    Get
    Set
Property Title As String
    Get
    Set
property String^ Title {
    String^ get ();
    void set (String^ value);
}
property String^ Title {
    String^ get ();
    void set (String^ value);
}
abstract Title : string with get, set

abstract Title : string with get, set
Property Value
String


UIThreadInvoke Method

UIThreadInvoke Method
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► UIThreadInvoke()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | UIThreadInvoke(Delegate) | Invoke in the UI thread the delegate d
 | UIThreadInvoke(Delegate, array<Object>[]()[][]) | Invoke in the UI thread the delegate d with parameters


UIThreadInvoke Method (d)

UIThreadInvoke Method (d)
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► UIThreadInvoke(Delegate)
Keyoti RapidSpell WPF
Invoke in the UI thread the delegate d
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void UIThreadInvoke(
    Delegate d
)
void UIThreadInvoke(
    Delegate d
)
Sub UIThreadInvoke (
    d As Delegate
)
Sub UIThreadInvoke (
    d As Delegate
)
void UIThreadInvoke(
    Delegate^ d
)
void UIThreadInvoke(
    Delegate^ d
)
abstract UIThreadInvoke :
        d : Delegate -> unit

abstract UIThreadInvoke :
        d : Delegate -> unit
Parameters
d (Delegate)


UIThreadInvoke Method (d, parameters)

UIThreadInvoke Method (d, parameters)
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► UIThreadInvoke(Delegate, array<Object>[]()[][])
Keyoti RapidSpell WPF
Invoke in the UI thread the delegate d with parameters
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void UIThreadInvoke(
    Delegate d,
    Object[] parameters
)
void UIThreadInvoke(
    Delegate d,
    Object[] parameters
)
Sub UIThreadInvoke (
    d As Delegate,
    parameters As Object()
)
Sub UIThreadInvoke (
    d As Delegate,
    parameters As Object()
)
void UIThreadInvoke(
    Delegate^ d,
    array<Object^>^ parameters
)
void UIThreadInvoke(
    Delegate^ d,
    array<Object^>^ parameters
)
abstract UIThreadInvoke :
        d : Delegate *
        parameters : Object[] -> unit

abstract UIThreadInvoke :
        d : Delegate *
        parameters : Object[] -> unit
Parameters
d (Delegate)
parameters (array<Object>[]()[][])


UndoButtonEnabled Property

UndoButtonEnabled Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► UndoButtonEnabled
Keyoti RapidSpell WPF
Whether the undo button is enabled
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool UndoButtonEnabled { get; set; }
bool UndoButtonEnabled { get; set; }
Property UndoButtonEnabled As Boolean
    Get
    Set
Property UndoButtonEnabled As Boolean
    Get
    Set
property bool UndoButtonEnabled {
    bool get ();
    void set (bool value);
}
property bool UndoButtonEnabled {
    bool get ();
    void set (bool value);
}
abstract UndoButtonEnabled : bool with get, set

abstract UndoButtonEnabled : bool with get, set
Property Value
Boolean


UndoButtonText Property

UndoButtonText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► UndoButtonText
Keyoti RapidSpell WPF
Undo button text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string UndoButtonText { get; set; }
string UndoButtonText { get; set; }
Property UndoButtonText As String
    Get
    Set
Property UndoButtonText As String
    Get
    Set
property String^ UndoButtonText {
    String^ get ();
    void set (String^ value);
}
property String^ UndoButtonText {
    String^ get ();
    void set (String^ value);
}
abstract UndoButtonText : string with get, set

abstract UndoButtonText : string with get, set
Property Value
String


UnregisterEvents Method (handler)

UnregisterEvents Method (handler)
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► UnregisterEvents(IDialogViewEventHandler)
Keyoti RapidSpell WPF
Remove view event subscriptions from handler
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void UnregisterEvents(
    IDialogViewEventHandler handler
)
void UnregisterEvents(
    IDialogViewEventHandler handler
)
Sub UnregisterEvents (
    handler As IDialogViewEventHandler
)
Sub UnregisterEvents (
    handler As IDialogViewEventHandler
)
void UnregisterEvents(
    IDialogViewEventHandler^ handler
)
void UnregisterEvents(
    IDialogViewEventHandler^ handler
)
abstract UnregisterEvents :
        handler : IDialogViewEventHandler -> unit

abstract UnregisterEvents :
        handler : IDialogViewEventHandler -> unit
Parameters
handler (IDialogViewEventHandler)


Visible Property

Visible Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogView ► Visible
Keyoti RapidSpell WPF
Gets or sets a value indicating whether the control is displayed.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
bool Visible { get; set; }
bool Visible { get; set; }
Property Visible As Boolean
    Get
    Set
Property Visible As Boolean
    Get
    Set
property bool Visible {
    bool get ();
    void set (bool value);
}
property bool Visible {
    bool get ();
    void set (bool value);
}
abstract Visible : bool with get, set

abstract Visible : bool with get, set
Property Value
Boolean


IDialogViewEventHandler Interface

IDialogViewEventHandler Interface
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewEventHandler
Keyoti RapidSpell WPF
Describes a class which can handle events from an IDialogView.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public interface IDialogViewEventHandler
public interface IDialogViewEventHandler
Public Interface IDialogViewEventHandler
Public Interface IDialogViewEventHandler
public interface class IDialogViewEventHandler
public interface class IDialogViewEventHandler
type IDialogViewEventHandler =  interface end
type IDialogViewEventHandler =  interface end
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DialogView_AddButtonClick(Object, EventArgs) | The add button was clicked
 | DialogView_CancelButtonClick(Object, EventArgs) | The cancel button was clicked
 | DialogView_ChangeAllButtonClick(Object, EventArgs) | The change-all button was clicked
 | DialogView_ChangeButtonClick(Object, EventArgs) | The change button was clicked
 | DialogView_Closing(Object, CancelEventArgs) | The view is closing
 | DialogView_IgnoreAllButtonClick(Object, EventArgs) | The ignore all button was clicked
 | DialogView_IgnoreButtonClick(Object, EventArgs) | The ignore button was clicked
 | DialogView_Load(Object, EventArgs) | The view has loaded
 | DialogView_OptionsButtonClick(Object, EventArgs) | The options button was clicked
 | DialogView_QueryTextBoxEnter(Object, EventArgs) | Query textbox has been entered
 | DialogView_QueryTextBoxTextChanged(Object, EventArgs) | The text in the query textbox changed
 | DialogView_SuggestionsListDoubleClick(Object, EventArgs) | The user double clicked on a suggested item. Not mandatory to implement.
 | DialogView_UndoButtonClick(Object, EventArgs) | The undo button was clicked
 | DialogView_UserNeedsSuggestionsChanged(Object, EventArgs) | User has checked the "Find Suggestions" checkbox (if it exists).
Remarks
Call these methods when events occur in the IDialogView GUI, or hook them up as handlers directly.


DialogView_AddButtonClick Method (sender, e)

DialogView_AddButtonClick Method (sender, e)
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewEventHandler ► DialogView_AddButtonClick(Object, EventArgs)
Keyoti RapidSpell WPF
The add button was clicked
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void DialogView_AddButtonClick(
    Object sender,
    EventArgs e
)
void DialogView_AddButtonClick(
    Object sender,
    EventArgs e
)
Sub DialogView_AddButtonClick (
    sender As Object,
    e As EventArgs
)
Sub DialogView_AddButtonClick (
    sender As Object,
    e As EventArgs
)
void DialogView_AddButtonClick(
    Object^ sender,
    EventArgs^ e
)
void DialogView_AddButtonClick(
    Object^ sender,
    EventArgs^ e
)
abstract DialogView_AddButtonClick :
        sender : Object *
        e : EventArgs -> unit

abstract DialogView_AddButtonClick :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


DialogView_CancelButtonClick Method (sender, e)

DialogView_CancelButtonClick Method (sender, e)
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewEventHandler ► DialogView_CancelButtonClick(Object, EventArgs)
Keyoti RapidSpell WPF
The cancel button was clicked
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void DialogView_CancelButtonClick(
    Object sender,
    EventArgs e
)
void DialogView_CancelButtonClick(
    Object sender,
    EventArgs e
)
Sub DialogView_CancelButtonClick (
    sender As Object,
    e As EventArgs
)
Sub DialogView_CancelButtonClick (
    sender As Object,
    e As EventArgs
)
void DialogView_CancelButtonClick(
    Object^ sender,
    EventArgs^ e
)
void DialogView_CancelButtonClick(
    Object^ sender,
    EventArgs^ e
)
abstract DialogView_CancelButtonClick :
        sender : Object *
        e : EventArgs -> unit

abstract DialogView_CancelButtonClick :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


DialogView_ChangeAllButtonClick Method (sender, e)

DialogView_ChangeAllButtonClick Method (sender, e)
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewEventHandler ► DialogView_ChangeAllButtonClick(Object, EventArgs)
Keyoti RapidSpell WPF
The change-all button was clicked
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void DialogView_ChangeAllButtonClick(
    Object sender,
    EventArgs e
)
void DialogView_ChangeAllButtonClick(
    Object sender,
    EventArgs e
)
Sub DialogView_ChangeAllButtonClick (
    sender As Object,
    e As EventArgs
)
Sub DialogView_ChangeAllButtonClick (
    sender As Object,
    e As EventArgs
)
void DialogView_ChangeAllButtonClick(
    Object^ sender,
    EventArgs^ e
)
void DialogView_ChangeAllButtonClick(
    Object^ sender,
    EventArgs^ e
)
abstract DialogView_ChangeAllButtonClick :
        sender : Object *
        e : EventArgs -> unit

abstract DialogView_ChangeAllButtonClick :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


DialogView_ChangeButtonClick Method (sender, e)

DialogView_ChangeButtonClick Method (sender, e)
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewEventHandler ► DialogView_ChangeButtonClick(Object, EventArgs)
Keyoti RapidSpell WPF
The change button was clicked
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void DialogView_ChangeButtonClick(
    Object sender,
    EventArgs e
)
void DialogView_ChangeButtonClick(
    Object sender,
    EventArgs e
)
Sub DialogView_ChangeButtonClick (
    sender As Object,
    e As EventArgs
)
Sub DialogView_ChangeButtonClick (
    sender As Object,
    e As EventArgs
)
void DialogView_ChangeButtonClick(
    Object^ sender,
    EventArgs^ e
)
void DialogView_ChangeButtonClick(
    Object^ sender,
    EventArgs^ e
)
abstract DialogView_ChangeButtonClick :
        sender : Object *
        e : EventArgs -> unit

abstract DialogView_ChangeButtonClick :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


DialogView_Closing Method (sender, e)

DialogView_Closing Method (sender, e)
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewEventHandler ► DialogView_Closing(Object, CancelEventArgs)
Keyoti RapidSpell WPF
The view is closing
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void DialogView_Closing(
    Object sender,
    CancelEventArgs e
)
void DialogView_Closing(
    Object sender,
    CancelEventArgs e
)
Sub DialogView_Closing (
    sender As Object,
    e As CancelEventArgs
)
Sub DialogView_Closing (
    sender As Object,
    e As CancelEventArgs
)
void DialogView_Closing(
    Object^ sender,
    CancelEventArgs^ e
)
void DialogView_Closing(
    Object^ sender,
    CancelEventArgs^ e
)
abstract DialogView_Closing :
        sender : Object *
        e : CancelEventArgs -> unit

abstract DialogView_Closing :
        sender : Object *
        e : CancelEventArgs -> unit
Parameters
sender (Object)
e (CancelEventArgs)


DialogView_IgnoreAllButtonClick Method (sender, e)

DialogView_IgnoreAllButtonClick Method (sender, e)
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewEventHandler ► DialogView_IgnoreAllButtonClick(Object, EventArgs)
Keyoti RapidSpell WPF
The ignore all button was clicked
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void DialogView_IgnoreAllButtonClick(
    Object sender,
    EventArgs e
)
void DialogView_IgnoreAllButtonClick(
    Object sender,
    EventArgs e
)
Sub DialogView_IgnoreAllButtonClick (
    sender As Object,
    e As EventArgs
)
Sub DialogView_IgnoreAllButtonClick (
    sender As Object,
    e As EventArgs
)
void DialogView_IgnoreAllButtonClick(
    Object^ sender,
    EventArgs^ e
)
void DialogView_IgnoreAllButtonClick(
    Object^ sender,
    EventArgs^ e
)
abstract DialogView_IgnoreAllButtonClick :
        sender : Object *
        e : EventArgs -> unit

abstract DialogView_IgnoreAllButtonClick :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


DialogView_IgnoreButtonClick Method (sender, e)

DialogView_IgnoreButtonClick Method (sender, e)
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewEventHandler ► DialogView_IgnoreButtonClick(Object, EventArgs)
Keyoti RapidSpell WPF
The ignore button was clicked
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void DialogView_IgnoreButtonClick(
    Object sender,
    EventArgs e
)
void DialogView_IgnoreButtonClick(
    Object sender,
    EventArgs e
)
Sub DialogView_IgnoreButtonClick (
    sender As Object,
    e As EventArgs
)
Sub DialogView_IgnoreButtonClick (
    sender As Object,
    e As EventArgs
)
void DialogView_IgnoreButtonClick(
    Object^ sender,
    EventArgs^ e
)
void DialogView_IgnoreButtonClick(
    Object^ sender,
    EventArgs^ e
)
abstract DialogView_IgnoreButtonClick :
        sender : Object *
        e : EventArgs -> unit

abstract DialogView_IgnoreButtonClick :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


DialogView_Load Method (sender, e)

DialogView_Load Method (sender, e)
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewEventHandler ► DialogView_Load(Object, EventArgs)
Keyoti RapidSpell WPF
The view has loaded
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void DialogView_Load(
    Object sender,
    EventArgs e
)
void DialogView_Load(
    Object sender,
    EventArgs e
)
Sub DialogView_Load (
    sender As Object,
    e As EventArgs
)
Sub DialogView_Load (
    sender As Object,
    e As EventArgs
)
void DialogView_Load(
    Object^ sender,
    EventArgs^ e
)
void DialogView_Load(
    Object^ sender,
    EventArgs^ e
)
abstract DialogView_Load :
        sender : Object *
        e : EventArgs -> unit

abstract DialogView_Load :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


DialogView_OptionsButtonClick Method (sender, e)

DialogView_OptionsButtonClick Method (sender, e)
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewEventHandler ► DialogView_OptionsButtonClick(Object, EventArgs)
Keyoti RapidSpell WPF
The options button was clicked
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void DialogView_OptionsButtonClick(
    Object sender,
    EventArgs e
)
void DialogView_OptionsButtonClick(
    Object sender,
    EventArgs e
)
Sub DialogView_OptionsButtonClick (
    sender As Object,
    e As EventArgs
)
Sub DialogView_OptionsButtonClick (
    sender As Object,
    e As EventArgs
)
void DialogView_OptionsButtonClick(
    Object^ sender,
    EventArgs^ e
)
void DialogView_OptionsButtonClick(
    Object^ sender,
    EventArgs^ e
)
abstract DialogView_OptionsButtonClick :
        sender : Object *
        e : EventArgs -> unit

abstract DialogView_OptionsButtonClick :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


DialogView_QueryTextBoxEnter Method (sender, e)

DialogView_QueryTextBoxEnter Method (sender, e)
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewEventHandler ► DialogView_QueryTextBoxEnter(Object, EventArgs)
Keyoti RapidSpell WPF
Query textbox has been entered
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void DialogView_QueryTextBoxEnter(
    Object sender,
    EventArgs e
)
void DialogView_QueryTextBoxEnter(
    Object sender,
    EventArgs e
)
Sub DialogView_QueryTextBoxEnter (
    sender As Object,
    e As EventArgs
)
Sub DialogView_QueryTextBoxEnter (
    sender As Object,
    e As EventArgs
)
void DialogView_QueryTextBoxEnter(
    Object^ sender,
    EventArgs^ e
)
void DialogView_QueryTextBoxEnter(
    Object^ sender,
    EventArgs^ e
)
abstract DialogView_QueryTextBoxEnter :
        sender : Object *
        e : EventArgs -> unit

abstract DialogView_QueryTextBoxEnter :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


DialogView_QueryTextBoxTextChanged Method (sender, e)

DialogView_QueryTextBoxTextChanged Method (sender, e)
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewEventHandler ► DialogView_QueryTextBoxTextChanged(Object, EventArgs)
Keyoti RapidSpell WPF
The text in the query textbox changed
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void DialogView_QueryTextBoxTextChanged(
    Object sender,
    EventArgs e
)
void DialogView_QueryTextBoxTextChanged(
    Object sender,
    EventArgs e
)
Sub DialogView_QueryTextBoxTextChanged (
    sender As Object,
    e As EventArgs
)
Sub DialogView_QueryTextBoxTextChanged (
    sender As Object,
    e As EventArgs
)
void DialogView_QueryTextBoxTextChanged(
    Object^ sender,
    EventArgs^ e
)
void DialogView_QueryTextBoxTextChanged(
    Object^ sender,
    EventArgs^ e
)
abstract DialogView_QueryTextBoxTextChanged :
        sender : Object *
        e : EventArgs -> unit

abstract DialogView_QueryTextBoxTextChanged :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


DialogView_SuggestionsListDoubleClick Method (sender, e)

DialogView_SuggestionsListDoubleClick Method (sender, e)
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewEventHandler ► DialogView_SuggestionsListDoubleClick(Object, EventArgs)
Keyoti RapidSpell WPF
The user double clicked on a suggested item. Not mandatory to implement.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void DialogView_SuggestionsListDoubleClick(
    Object sender,
    EventArgs e
)
void DialogView_SuggestionsListDoubleClick(
    Object sender,
    EventArgs e
)
Sub DialogView_SuggestionsListDoubleClick (
    sender As Object,
    e As EventArgs
)
Sub DialogView_SuggestionsListDoubleClick (
    sender As Object,
    e As EventArgs
)
void DialogView_SuggestionsListDoubleClick(
    Object^ sender,
    EventArgs^ e
)
void DialogView_SuggestionsListDoubleClick(
    Object^ sender,
    EventArgs^ e
)
abstract DialogView_SuggestionsListDoubleClick :
        sender : Object *
        e : EventArgs -> unit

abstract DialogView_SuggestionsListDoubleClick :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


DialogView_UndoButtonClick Method (sender, e)

DialogView_UndoButtonClick Method (sender, e)
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewEventHandler ► DialogView_UndoButtonClick(Object, EventArgs)
Keyoti RapidSpell WPF
The undo button was clicked
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void DialogView_UndoButtonClick(
    Object sender,
    EventArgs e
)
void DialogView_UndoButtonClick(
    Object sender,
    EventArgs e
)
Sub DialogView_UndoButtonClick (
    sender As Object,
    e As EventArgs
)
Sub DialogView_UndoButtonClick (
    sender As Object,
    e As EventArgs
)
void DialogView_UndoButtonClick(
    Object^ sender,
    EventArgs^ e
)
void DialogView_UndoButtonClick(
    Object^ sender,
    EventArgs^ e
)
abstract DialogView_UndoButtonClick :
        sender : Object *
        e : EventArgs -> unit

abstract DialogView_UndoButtonClick :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


DialogView_UserNeedsSuggestionsChanged Method (sender, e)

DialogView_UserNeedsSuggestionsChanged Method (sender, e)
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewEventHandler ► DialogView_UserNeedsSuggestionsChanged(Object, EventArgs)
Keyoti RapidSpell WPF
User has checked the "Find Suggestions" checkbox (if it exists).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void DialogView_UserNeedsSuggestionsChanged(
    Object sender,
    EventArgs e
)
void DialogView_UserNeedsSuggestionsChanged(
    Object sender,
    EventArgs e
)
Sub DialogView_UserNeedsSuggestionsChanged (
    sender As Object,
    e As EventArgs
)
Sub DialogView_UserNeedsSuggestionsChanged (
    sender As Object,
    e As EventArgs
)
void DialogView_UserNeedsSuggestionsChanged(
    Object^ sender,
    EventArgs^ e
)
void DialogView_UserNeedsSuggestionsChanged(
    Object^ sender,
    EventArgs^ e
)
abstract DialogView_UserNeedsSuggestionsChanged :
        sender : Object *
        e : EventArgs -> unit

abstract DialogView_UserNeedsSuggestionsChanged :
        sender : Object *
        e : EventArgs -> unit
Parameters
sender (Object)
e (EventArgs)


IDialogViewOptions Interface

IDialogViewOptions Interface
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewOptions
Keyoti RapidSpell WPF
Describes an option editor form
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public interface IDialogViewOptions
public interface IDialogViewOptions
Public Interface IDialogViewOptions
Public Interface IDialogViewOptions
public interface class IDialogViewOptions
public interface class IDialogViewOptions
type IDialogViewOptions =  interface end
type IDialogViewOptions =  interface end
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Dispose()()()() | Free resources
 | Options | The options to edit
 | OptionsFormAdvancedSettingsText | UI Text
 | OptionsFormAlwaysSuggestCorrectionsText | UI Text
 | OptionsFormBasicSettingsText | UI Text
 | OptionsFormCancelText | UI Text
 | OptionsFormCheckAsYouTypeText | UI Text
 | OptionsFormIgnoreImproperCaseText | UI Text
 | OptionsFormIgnoreInternetAddressesText | UI Text
 | OptionsFormIgnoreWordsInUppercaseText | UI Text
 | OptionsFormIgnoreWordsWithNumbersText | UI Text
 | OptionsFormOKText | UI Text
 | OptionsFormRecheckTextText | UI Text
 | OptionsFormSuggestFromMainDictionaryOnlyText | UI Text
 | OptionsFormTitleText | UI Text
 | OptionsFormUserDictionaryEditText | UI Text
 | RecheckDocumentRequest | Fired when user requests document recheck
 | SelectUserDictionary | Fired when user wants to edit user dictionary
 | ShowDialog(Object, Boolean, Boolean, Boolean) | Shows the window modally


Dispose Method

Dispose Method
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewOptions ► Dispose()()()()
Keyoti RapidSpell WPF
Free resources
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void Dispose()
void Dispose()
Sub Dispose
Sub Dispose
void Dispose()
void Dispose()
abstract Dispose : unit -> unit

abstract Dispose : unit -> unit


Options Property

Options Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewOptions ► Options
Keyoti RapidSpell WPF
The options to edit
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
UserOptions Options { get; set; }
UserOptions Options { get; set; }
Property Options As UserOptions
    Get
    Set
Property Options As UserOptions
    Get
    Set
property UserOptions^ Options {
    UserOptions^ get ();
    void set (UserOptions^ value);
}
property UserOptions^ Options {
    UserOptions^ get ();
    void set (UserOptions^ value);
}
abstract Options : UserOptions with get, set

abstract Options : UserOptions with get, set
Property Value
UserOptions


OptionsFormAdvancedSettingsText Property

OptionsFormAdvancedSettingsText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewOptions ► OptionsFormAdvancedSettingsText
Keyoti RapidSpell WPF
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string OptionsFormAdvancedSettingsText { get; set; }
string OptionsFormAdvancedSettingsText { get; set; }
Property OptionsFormAdvancedSettingsText As String
    Get
    Set
Property OptionsFormAdvancedSettingsText As String
    Get
    Set
property String^ OptionsFormAdvancedSettingsText {
    String^ get ();
    void set (String^ value);
}
property String^ OptionsFormAdvancedSettingsText {
    String^ get ();
    void set (String^ value);
}
abstract OptionsFormAdvancedSettingsText : string with get, set

abstract OptionsFormAdvancedSettingsText : string with get, set
Property Value
String


OptionsFormAlwaysSuggestCorrectionsText Property

OptionsFormAlwaysSuggestCorrectionsText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewOptions ► OptionsFormAlwaysSuggestCorrectionsText
Keyoti RapidSpell WPF
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string OptionsFormAlwaysSuggestCorrectionsText { get; set; }
string OptionsFormAlwaysSuggestCorrectionsText { get; set; }
Property OptionsFormAlwaysSuggestCorrectionsText As String
    Get
    Set
Property OptionsFormAlwaysSuggestCorrectionsText As String
    Get
    Set
property String^ OptionsFormAlwaysSuggestCorrectionsText {
    String^ get ();
    void set (String^ value);
}
property String^ OptionsFormAlwaysSuggestCorrectionsText {
    String^ get ();
    void set (String^ value);
}
abstract OptionsFormAlwaysSuggestCorrectionsText : string with get, set

abstract OptionsFormAlwaysSuggestCorrectionsText : string with get, set
Property Value
String


OptionsFormBasicSettingsText Property

OptionsFormBasicSettingsText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewOptions ► OptionsFormBasicSettingsText
Keyoti RapidSpell WPF
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string OptionsFormBasicSettingsText { get; set; }
string OptionsFormBasicSettingsText { get; set; }
Property OptionsFormBasicSettingsText As String
    Get
    Set
Property OptionsFormBasicSettingsText As String
    Get
    Set
property String^ OptionsFormBasicSettingsText {
    String^ get ();
    void set (String^ value);
}
property String^ OptionsFormBasicSettingsText {
    String^ get ();
    void set (String^ value);
}
abstract OptionsFormBasicSettingsText : string with get, set

abstract OptionsFormBasicSettingsText : string with get, set
Property Value
String


OptionsFormCancelText Property

OptionsFormCancelText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewOptions ► OptionsFormCancelText
Keyoti RapidSpell WPF
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string OptionsFormCancelText { get; set; }
string OptionsFormCancelText { get; set; }
Property OptionsFormCancelText As String
    Get
    Set
Property OptionsFormCancelText As String
    Get
    Set
property String^ OptionsFormCancelText {
    String^ get ();
    void set (String^ value);
}
property String^ OptionsFormCancelText {
    String^ get ();
    void set (String^ value);
}
abstract OptionsFormCancelText : string with get, set

abstract OptionsFormCancelText : string with get, set
Property Value
String


OptionsFormCheckAsYouTypeText Property

OptionsFormCheckAsYouTypeText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewOptions ► OptionsFormCheckAsYouTypeText
Keyoti RapidSpell WPF
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string OptionsFormCheckAsYouTypeText { get; set; }
string OptionsFormCheckAsYouTypeText { get; set; }
Property OptionsFormCheckAsYouTypeText As String
    Get
    Set
Property OptionsFormCheckAsYouTypeText As String
    Get
    Set
property String^ OptionsFormCheckAsYouTypeText {
    String^ get ();
    void set (String^ value);
}
property String^ OptionsFormCheckAsYouTypeText {
    String^ get ();
    void set (String^ value);
}
abstract OptionsFormCheckAsYouTypeText : string with get, set

abstract OptionsFormCheckAsYouTypeText : string with get, set
Property Value
String


OptionsFormIgnoreImproperCaseText Property

OptionsFormIgnoreImproperCaseText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewOptions ► OptionsFormIgnoreImproperCaseText
Keyoti RapidSpell WPF
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string OptionsFormIgnoreImproperCaseText { get; set; }
string OptionsFormIgnoreImproperCaseText { get; set; }
Property OptionsFormIgnoreImproperCaseText As String
    Get
    Set
Property OptionsFormIgnoreImproperCaseText As String
    Get
    Set
property String^ OptionsFormIgnoreImproperCaseText {
    String^ get ();
    void set (String^ value);
}
property String^ OptionsFormIgnoreImproperCaseText {
    String^ get ();
    void set (String^ value);
}
abstract OptionsFormIgnoreImproperCaseText : string with get, set

abstract OptionsFormIgnoreImproperCaseText : string with get, set
Property Value
String


OptionsFormIgnoreInternetAddressesText Property

OptionsFormIgnoreInternetAddressesText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewOptions ► OptionsFormIgnoreInternetAddressesText
Keyoti RapidSpell WPF
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string OptionsFormIgnoreInternetAddressesText { get; set; }
string OptionsFormIgnoreInternetAddressesText { get; set; }
Property OptionsFormIgnoreInternetAddressesText As String
    Get
    Set
Property OptionsFormIgnoreInternetAddressesText As String
    Get
    Set
property String^ OptionsFormIgnoreInternetAddressesText {
    String^ get ();
    void set (String^ value);
}
property String^ OptionsFormIgnoreInternetAddressesText {
    String^ get ();
    void set (String^ value);
}
abstract OptionsFormIgnoreInternetAddressesText : string with get, set

abstract OptionsFormIgnoreInternetAddressesText : string with get, set
Property Value
String


OptionsFormIgnoreWordsInUppercaseText Property

OptionsFormIgnoreWordsInUppercaseText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewOptions ► OptionsFormIgnoreWordsInUppercaseText
Keyoti RapidSpell WPF
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string OptionsFormIgnoreWordsInUppercaseText { get; set; }
string OptionsFormIgnoreWordsInUppercaseText { get; set; }
Property OptionsFormIgnoreWordsInUppercaseText As String
    Get
    Set
Property OptionsFormIgnoreWordsInUppercaseText As String
    Get
    Set
property String^ OptionsFormIgnoreWordsInUppercaseText {
    String^ get ();
    void set (String^ value);
}
property String^ OptionsFormIgnoreWordsInUppercaseText {
    String^ get ();
    void set (String^ value);
}
abstract OptionsFormIgnoreWordsInUppercaseText : string with get, set

abstract OptionsFormIgnoreWordsInUppercaseText : string with get, set
Property Value
String


OptionsFormIgnoreWordsWithNumbersText Property

OptionsFormIgnoreWordsWithNumbersText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewOptions ► OptionsFormIgnoreWordsWithNumbersText
Keyoti RapidSpell WPF
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string OptionsFormIgnoreWordsWithNumbersText { get; set; }
string OptionsFormIgnoreWordsWithNumbersText { get; set; }
Property OptionsFormIgnoreWordsWithNumbersText As String
    Get
    Set
Property OptionsFormIgnoreWordsWithNumbersText As String
    Get
    Set
property String^ OptionsFormIgnoreWordsWithNumbersText {
    String^ get ();
    void set (String^ value);
}
property String^ OptionsFormIgnoreWordsWithNumbersText {
    String^ get ();
    void set (String^ value);
}
abstract OptionsFormIgnoreWordsWithNumbersText : string with get, set

abstract OptionsFormIgnoreWordsWithNumbersText : string with get, set
Property Value
String


OptionsFormOKText Property

OptionsFormOKText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewOptions ► OptionsFormOKText
Keyoti RapidSpell WPF
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string OptionsFormOKText { get; set; }
string OptionsFormOKText { get; set; }
Property OptionsFormOKText As String
    Get
    Set
Property OptionsFormOKText As String
    Get
    Set
property String^ OptionsFormOKText {
    String^ get ();
    void set (String^ value);
}
property String^ OptionsFormOKText {
    String^ get ();
    void set (String^ value);
}
abstract OptionsFormOKText : string with get, set

abstract OptionsFormOKText : string with get, set
Property Value
String


OptionsFormRecheckTextText Property

OptionsFormRecheckTextText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewOptions ► OptionsFormRecheckTextText
Keyoti RapidSpell WPF
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string OptionsFormRecheckTextText { get; set; }
string OptionsFormRecheckTextText { get; set; }
Property OptionsFormRecheckTextText As String
    Get
    Set
Property OptionsFormRecheckTextText As String
    Get
    Set
property String^ OptionsFormRecheckTextText {
    String^ get ();
    void set (String^ value);
}
property String^ OptionsFormRecheckTextText {
    String^ get ();
    void set (String^ value);
}
abstract OptionsFormRecheckTextText : string with get, set

abstract OptionsFormRecheckTextText : string with get, set
Property Value
String


OptionsFormSuggestFromMainDictionaryOnlyText Property

OptionsFormSuggestFromMainDictionaryOnlyText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewOptions ► OptionsFormSuggestFromMainDictionaryOnlyText
Keyoti RapidSpell WPF
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string OptionsFormSuggestFromMainDictionaryOnlyText { get; set; }
string OptionsFormSuggestFromMainDictionaryOnlyText { get; set; }
Property OptionsFormSuggestFromMainDictionaryOnlyText As String
    Get
    Set
Property OptionsFormSuggestFromMainDictionaryOnlyText As String
    Get
    Set
property String^ OptionsFormSuggestFromMainDictionaryOnlyText {
    String^ get ();
    void set (String^ value);
}
property String^ OptionsFormSuggestFromMainDictionaryOnlyText {
    String^ get ();
    void set (String^ value);
}
abstract OptionsFormSuggestFromMainDictionaryOnlyText : string with get, set

abstract OptionsFormSuggestFromMainDictionaryOnlyText : string with get, set
Property Value
String


OptionsFormTitleText Property

OptionsFormTitleText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewOptions ► OptionsFormTitleText
Keyoti RapidSpell WPF
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string OptionsFormTitleText { get; set; }
string OptionsFormTitleText { get; set; }
Property OptionsFormTitleText As String
    Get
    Set
Property OptionsFormTitleText As String
    Get
    Set
property String^ OptionsFormTitleText {
    String^ get ();
    void set (String^ value);
}
property String^ OptionsFormTitleText {
    String^ get ();
    void set (String^ value);
}
abstract OptionsFormTitleText : string with get, set

abstract OptionsFormTitleText : string with get, set
Property Value
String


OptionsFormUserDictionaryEditText Property

OptionsFormUserDictionaryEditText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewOptions ► OptionsFormUserDictionaryEditText
Keyoti RapidSpell WPF
UI Text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string OptionsFormUserDictionaryEditText { get; set; }
string OptionsFormUserDictionaryEditText { get; set; }
Property OptionsFormUserDictionaryEditText As String
    Get
    Set
Property OptionsFormUserDictionaryEditText As String
    Get
    Set
property String^ OptionsFormUserDictionaryEditText {
    String^ get ();
    void set (String^ value);
}
property String^ OptionsFormUserDictionaryEditText {
    String^ get ();
    void set (String^ value);
}
abstract OptionsFormUserDictionaryEditText : string with get, set

abstract OptionsFormUserDictionaryEditText : string with get, set
Property Value
String


RecheckDocumentRequest Event

RecheckDocumentRequest Event
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewOptions ► RecheckDocumentRequest
Keyoti RapidSpell WPF
Fired when user requests document recheck
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event EventHandler RecheckDocumentRequest
event EventHandler RecheckDocumentRequest
Event RecheckDocumentRequest As EventHandler
Event RecheckDocumentRequest As EventHandler
 event EventHandler^ RecheckDocumentRequest {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
 event EventHandler^ RecheckDocumentRequest {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract RecheckDocumentRequest : IEvent<EventHandler,
    EventArgs>

abstract RecheckDocumentRequest : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


SelectUserDictionary Event

SelectUserDictionary Event
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewOptions ► SelectUserDictionary
Keyoti RapidSpell WPF
Fired when user wants to edit user dictionary
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event EventHandler SelectUserDictionary
event EventHandler SelectUserDictionary
Event SelectUserDictionary As EventHandler
Event SelectUserDictionary As EventHandler
 event EventHandler^ SelectUserDictionary {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
 event EventHandler^ SelectUserDictionary {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract SelectUserDictionary : IEvent<EventHandler,
    EventArgs>

abstract SelectUserDictionary : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


ShowDialog Method (owner, showCheckAsYouTypeOption, showFindSuggestionsOption, showUserDictionaryButton)

ShowDialog Method (owner, showCheckAsYouTypeOption, showFindSuggestionsOption, showUserDictionaryButton)
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewOptions ► ShowDialog(Object, Boolean, Boolean, Boolean)
Keyoti RapidSpell WPF
Shows the window modally
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
DialogResult ShowDialog(
    Object owner,
    bool showCheckAsYouTypeOption,
    bool showFindSuggestionsOption,
    bool showUserDictionaryButton
)
DialogResult ShowDialog(
    Object owner,
    bool showCheckAsYouTypeOption,
    bool showFindSuggestionsOption,
    bool showUserDictionaryButton
)
Function ShowDialog (
    owner As Object,
    showCheckAsYouTypeOption As Boolean,
    showFindSuggestionsOption As Boolean,
    showUserDictionaryButton As Boolean
) As DialogResult
Function ShowDialog (
    owner As Object,
    showCheckAsYouTypeOption As Boolean,
    showFindSuggestionsOption As Boolean,
    showUserDictionaryButton As Boolean
) As DialogResult
DialogResult ShowDialog(
    Object^ owner,
    bool showCheckAsYouTypeOption,
    bool showFindSuggestionsOption,
    bool showUserDictionaryButton
)
DialogResult ShowDialog(
    Object^ owner,
    bool showCheckAsYouTypeOption,
    bool showFindSuggestionsOption,
    bool showUserDictionaryButton
)
abstract ShowDialog :
        owner : Object *
        showCheckAsYouTypeOption : bool *
        showFindSuggestionsOption : bool *
        showUserDictionaryButton : bool -> DialogResult

abstract ShowDialog :
        owner : Object *
        showCheckAsYouTypeOption : bool *
        showFindSuggestionsOption : bool *
        showUserDictionaryButton : bool -> DialogResult
Parameters
owner (Object)
showCheckAsYouTypeOption (Boolean)
showFindSuggestionsOption (Boolean)
showUserDictionaryButton (Boolean)
Return Value
DialogResult


IDialogViewUserDictionaryEdit Interface

IDialogViewUserDictionaryEdit Interface
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewUserDictionaryEdit
Keyoti RapidSpell WPF
Describes a user dictionary editor window
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public interface IDialogViewUserDictionaryEdit
public interface IDialogViewUserDictionaryEdit
Public Interface IDialogViewUserDictionaryEdit
Public Interface IDialogViewUserDictionaryEdit
public interface class IDialogViewUserDictionaryEdit
public interface class IDialogViewUserDictionaryEdit
type IDialogViewUserDictionaryEdit =  interface end
type IDialogViewUserDictionaryEdit =  interface end
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddWord | Word is being added
 | Dispose()()()() | Frees resources
 | RemoveWord | Word is being removed
 | ShowDialog(Object, ArrayList) | Shows the form modally
 | UserDictionaryFormAddText | UI text
 | UserDictionaryFormCancelText | UI text
 | UserDictionaryFormContentsText | UI text
 | UserDictionaryFormDeleteText | UI text
 | UserDictionaryFormDictionaryLabelText | UI text
 | UserDictionaryFormOKText | UI text
 | UserDictionaryFormTitleText | UI text
 | UserDictionaryFormWordLabelText | UI text


AddWord Event

AddWord Event
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewUserDictionaryEdit ► AddWord
Keyoti RapidSpell WPF
Word is being added
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event UserDictionaryEditEventHandler AddWord
event UserDictionaryEditEventHandler AddWord
Event AddWord As UserDictionaryEditEventHandler
Event AddWord As UserDictionaryEditEventHandler
 event UserDictionaryEditEventHandler^ AddWord {
    void add (UserDictionaryEditEventHandler^ value);
    void remove (UserDictionaryEditEventHandler^ value);
}
 event UserDictionaryEditEventHandler^ AddWord {
    void add (UserDictionaryEditEventHandler^ value);
    void remove (UserDictionaryEditEventHandler^ value);
}
abstract AddWord : IEvent<UserDictionaryEditEventHandler,
    UserDictionaryEditEventArgs>

abstract AddWord : IEvent<UserDictionaryEditEventHandler,
    UserDictionaryEditEventArgs>
Value
UserDictionaryEditEventHandler


Dispose Method

Dispose Method
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewUserDictionaryEdit ► Dispose()()()()
Keyoti RapidSpell WPF
Frees resources
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void Dispose()
void Dispose()
Sub Dispose
Sub Dispose
void Dispose()
void Dispose()
abstract Dispose : unit -> unit

abstract Dispose : unit -> unit


RemoveWord Event

RemoveWord Event
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewUserDictionaryEdit ► RemoveWord
Keyoti RapidSpell WPF
Word is being removed
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event UserDictionaryEditEventHandler RemoveWord
event UserDictionaryEditEventHandler RemoveWord
Event RemoveWord As UserDictionaryEditEventHandler
Event RemoveWord As UserDictionaryEditEventHandler
 event UserDictionaryEditEventHandler^ RemoveWord {
    void add (UserDictionaryEditEventHandler^ value);
    void remove (UserDictionaryEditEventHandler^ value);
}
 event UserDictionaryEditEventHandler^ RemoveWord {
    void add (UserDictionaryEditEventHandler^ value);
    void remove (UserDictionaryEditEventHandler^ value);
}
abstract RemoveWord : IEvent<UserDictionaryEditEventHandler,
    UserDictionaryEditEventArgs>

abstract RemoveWord : IEvent<UserDictionaryEditEventHandler,
    UserDictionaryEditEventArgs>
Value
UserDictionaryEditEventHandler


ShowDialog Method (owner, userDictionaryContents)

ShowDialog Method (owner, userDictionaryContents)
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewUserDictionaryEdit ► ShowDialog(Object, ArrayList)
Keyoti RapidSpell WPF
Shows the form modally
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
DialogResult ShowDialog(
    Object owner,
    ArrayList userDictionaryContents
)
DialogResult ShowDialog(
    Object owner,
    ArrayList userDictionaryContents
)
Function ShowDialog (
    owner As Object,
    userDictionaryContents As ArrayList
) As DialogResult
Function ShowDialog (
    owner As Object,
    userDictionaryContents As ArrayList
) As DialogResult
DialogResult ShowDialog(
    Object^ owner,
    ArrayList^ userDictionaryContents
)
DialogResult ShowDialog(
    Object^ owner,
    ArrayList^ userDictionaryContents
)
abstract ShowDialog :
        owner : Object *
        userDictionaryContents : ArrayList -> DialogResult

abstract ShowDialog :
        owner : Object *
        userDictionaryContents : ArrayList -> DialogResult
Parameters
owner (Object)
userDictionaryContents (ArrayList)
Return Value
DialogResult


UserDictionaryFormAddText Property

UserDictionaryFormAddText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewUserDictionaryEdit ► UserDictionaryFormAddText
Keyoti RapidSpell WPF
UI text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string UserDictionaryFormAddText { get; set; }
string UserDictionaryFormAddText { get; set; }
Property UserDictionaryFormAddText As String
    Get
    Set
Property UserDictionaryFormAddText As String
    Get
    Set
property String^ UserDictionaryFormAddText {
    String^ get ();
    void set (String^ value);
}
property String^ UserDictionaryFormAddText {
    String^ get ();
    void set (String^ value);
}
abstract UserDictionaryFormAddText : string with get, set

abstract UserDictionaryFormAddText : string with get, set
Property Value
String


UserDictionaryFormCancelText Property

UserDictionaryFormCancelText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewUserDictionaryEdit ► UserDictionaryFormCancelText
Keyoti RapidSpell WPF
UI text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string UserDictionaryFormCancelText { get; set; }
string UserDictionaryFormCancelText { get; set; }
Property UserDictionaryFormCancelText As String
    Get
    Set
Property UserDictionaryFormCancelText As String
    Get
    Set
property String^ UserDictionaryFormCancelText {
    String^ get ();
    void set (String^ value);
}
property String^ UserDictionaryFormCancelText {
    String^ get ();
    void set (String^ value);
}
abstract UserDictionaryFormCancelText : string with get, set

abstract UserDictionaryFormCancelText : string with get, set
Property Value
String


UserDictionaryFormContentsText Property

UserDictionaryFormContentsText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewUserDictionaryEdit ► UserDictionaryFormContentsText
Keyoti RapidSpell WPF
UI text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string UserDictionaryFormContentsText { get; set; }
string UserDictionaryFormContentsText { get; set; }
Property UserDictionaryFormContentsText As String
    Get
    Set
Property UserDictionaryFormContentsText As String
    Get
    Set
property String^ UserDictionaryFormContentsText {
    String^ get ();
    void set (String^ value);
}
property String^ UserDictionaryFormContentsText {
    String^ get ();
    void set (String^ value);
}
abstract UserDictionaryFormContentsText : string with get, set

abstract UserDictionaryFormContentsText : string with get, set
Property Value
String


UserDictionaryFormDeleteText Property

UserDictionaryFormDeleteText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewUserDictionaryEdit ► UserDictionaryFormDeleteText
Keyoti RapidSpell WPF
UI text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string UserDictionaryFormDeleteText { get; set; }
string UserDictionaryFormDeleteText { get; set; }
Property UserDictionaryFormDeleteText As String
    Get
    Set
Property UserDictionaryFormDeleteText As String
    Get
    Set
property String^ UserDictionaryFormDeleteText {
    String^ get ();
    void set (String^ value);
}
property String^ UserDictionaryFormDeleteText {
    String^ get ();
    void set (String^ value);
}
abstract UserDictionaryFormDeleteText : string with get, set

abstract UserDictionaryFormDeleteText : string with get, set
Property Value
String


UserDictionaryFormDictionaryLabelText Property

UserDictionaryFormDictionaryLabelText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewUserDictionaryEdit ► UserDictionaryFormDictionaryLabelText
Keyoti RapidSpell WPF
UI text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string UserDictionaryFormDictionaryLabelText { get; set; }
string UserDictionaryFormDictionaryLabelText { get; set; }
Property UserDictionaryFormDictionaryLabelText As String
    Get
    Set
Property UserDictionaryFormDictionaryLabelText As String
    Get
    Set
property String^ UserDictionaryFormDictionaryLabelText {
    String^ get ();
    void set (String^ value);
}
property String^ UserDictionaryFormDictionaryLabelText {
    String^ get ();
    void set (String^ value);
}
abstract UserDictionaryFormDictionaryLabelText : string with get, set

abstract UserDictionaryFormDictionaryLabelText : string with get, set
Property Value
String


UserDictionaryFormOKText Property

UserDictionaryFormOKText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewUserDictionaryEdit ► UserDictionaryFormOKText
Keyoti RapidSpell WPF
UI text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string UserDictionaryFormOKText { get; set; }
string UserDictionaryFormOKText { get; set; }
Property UserDictionaryFormOKText As String
    Get
    Set
Property UserDictionaryFormOKText As String
    Get
    Set
property String^ UserDictionaryFormOKText {
    String^ get ();
    void set (String^ value);
}
property String^ UserDictionaryFormOKText {
    String^ get ();
    void set (String^ value);
}
abstract UserDictionaryFormOKText : string with get, set

abstract UserDictionaryFormOKText : string with get, set
Property Value
String


UserDictionaryFormTitleText Property

UserDictionaryFormTitleText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewUserDictionaryEdit ► UserDictionaryFormTitleText
Keyoti RapidSpell WPF
UI text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string UserDictionaryFormTitleText { get; set; }
string UserDictionaryFormTitleText { get; set; }
Property UserDictionaryFormTitleText As String
    Get
    Set
Property UserDictionaryFormTitleText As String
    Get
    Set
property String^ UserDictionaryFormTitleText {
    String^ get ();
    void set (String^ value);
}
property String^ UserDictionaryFormTitleText {
    String^ get ();
    void set (String^ value);
}
abstract UserDictionaryFormTitleText : string with get, set

abstract UserDictionaryFormTitleText : string with get, set
Property Value
String


UserDictionaryFormWordLabelText Property

UserDictionaryFormWordLabelText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewUserDictionaryEdit ► UserDictionaryFormWordLabelText
Keyoti RapidSpell WPF
UI text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string UserDictionaryFormWordLabelText { get; set; }
string UserDictionaryFormWordLabelText { get; set; }
Property UserDictionaryFormWordLabelText As String
    Get
    Set
Property UserDictionaryFormWordLabelText As String
    Get
    Set
property String^ UserDictionaryFormWordLabelText {
    String^ get ();
    void set (String^ value);
}
property String^ UserDictionaryFormWordLabelText {
    String^ get ();
    void set (String^ value);
}
abstract UserDictionaryFormWordLabelText : string with get, set

abstract UserDictionaryFormWordLabelText : string with get, set
Property Value
String


IDialogViewUserDictionarySelect Interface

IDialogViewUserDictionarySelect Interface
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewUserDictionarySelect
Keyoti RapidSpell WPF
Describes a user dictionary editor window
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public interface IDialogViewUserDictionarySelect
public interface IDialogViewUserDictionarySelect
Public Interface IDialogViewUserDictionarySelect
Public Interface IDialogViewUserDictionarySelect
public interface class IDialogViewUserDictionarySelect
public interface class IDialogViewUserDictionarySelect
type IDialogViewUserDictionarySelect =  interface end
type IDialogViewUserDictionarySelect =  interface end
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddFile | File is being added
 | DefaultUserDictionaryItem | The selected default dictionary
 | Dispose()()()() | Frees resources
 | EditFile | File is being edited
 | RemoveFile | File is being removed
 | ShowDialog(Object, List<(Of <<'(String>)>>), String) | Shows the form modally
 | UserDictionarySelectFormAddText | UI text
 | UserDictionarySelectFormCancelText | UI text
 | UserDictionarySelectFormChangeDefaultText | UI text
 | UserDictionarySelectFormEditText | UI text
 | UserDictionarySelectFormGroupBoxTitleText | UI text
 | UserDictionarySelectFormNewText | UI text
 | UserDictionarySelectFormOkText | UI text
 | UserDictionarySelectFormRemoveText | UI text
 | UserDictionarySelectFormTitleText | UI text


AddFile Event

AddFile Event
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewUserDictionarySelect ► AddFile
Keyoti RapidSpell WPF
File is being added
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event UserDictionaryFormEventHandler AddFile
event UserDictionaryFormEventHandler AddFile
Event AddFile As UserDictionaryFormEventHandler
Event AddFile As UserDictionaryFormEventHandler
 event UserDictionaryFormEventHandler^ AddFile {
    void add (UserDictionaryFormEventHandler^ value);
    void remove (UserDictionaryFormEventHandler^ value);
}
 event UserDictionaryFormEventHandler^ AddFile {
    void add (UserDictionaryFormEventHandler^ value);
    void remove (UserDictionaryFormEventHandler^ value);
}
abstract AddFile : IEvent<UserDictionaryFormEventHandler,
    UserDictionaryFormEventArgs>

abstract AddFile : IEvent<UserDictionaryFormEventHandler,
    UserDictionaryFormEventArgs>
Value
UserDictionaryFormEventHandler


DefaultUserDictionaryItem Property

DefaultUserDictionaryItem Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewUserDictionarySelect ► DefaultUserDictionaryItem
Keyoti RapidSpell WPF
The selected default dictionary
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string DefaultUserDictionaryItem { get; }
string DefaultUserDictionaryItem { get; }
ReadOnly Property DefaultUserDictionaryItem As String
    Get
ReadOnly Property DefaultUserDictionaryItem As String
    Get
property String^ DefaultUserDictionaryItem {
    String^ get ();
}
property String^ DefaultUserDictionaryItem {
    String^ get ();
}
abstract DefaultUserDictionaryItem : string with get

abstract DefaultUserDictionaryItem : string with get
Property Value
String


Dispose Method

Dispose Method
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewUserDictionarySelect ► Dispose()()()()
Keyoti RapidSpell WPF
Frees resources
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
void Dispose()
void Dispose()
Sub Dispose
Sub Dispose
void Dispose()
void Dispose()
abstract Dispose : unit -> unit

abstract Dispose : unit -> unit


EditFile Event

EditFile Event
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewUserDictionarySelect ► EditFile
Keyoti RapidSpell WPF
File is being edited
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event UserDictionaryFormEventHandler EditFile
event UserDictionaryFormEventHandler EditFile
Event EditFile As UserDictionaryFormEventHandler
Event EditFile As UserDictionaryFormEventHandler
 event UserDictionaryFormEventHandler^ EditFile {
    void add (UserDictionaryFormEventHandler^ value);
    void remove (UserDictionaryFormEventHandler^ value);
}
 event UserDictionaryFormEventHandler^ EditFile {
    void add (UserDictionaryFormEventHandler^ value);
    void remove (UserDictionaryFormEventHandler^ value);
}
abstract EditFile : IEvent<UserDictionaryFormEventHandler,
    UserDictionaryFormEventArgs>

abstract EditFile : IEvent<UserDictionaryFormEventHandler,
    UserDictionaryFormEventArgs>
Value
UserDictionaryFormEventHandler


RemoveFile Event

RemoveFile Event
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewUserDictionarySelect ► RemoveFile
Keyoti RapidSpell WPF
File is being removed
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
event UserDictionaryFormEventHandler RemoveFile
event UserDictionaryFormEventHandler RemoveFile
Event RemoveFile As UserDictionaryFormEventHandler
Event RemoveFile As UserDictionaryFormEventHandler
 event UserDictionaryFormEventHandler^ RemoveFile {
    void add (UserDictionaryFormEventHandler^ value);
    void remove (UserDictionaryFormEventHandler^ value);
}
 event UserDictionaryFormEventHandler^ RemoveFile {
    void add (UserDictionaryFormEventHandler^ value);
    void remove (UserDictionaryFormEventHandler^ value);
}
abstract RemoveFile : IEvent<UserDictionaryFormEventHandler,
    UserDictionaryFormEventArgs>

abstract RemoveFile : IEvent<UserDictionaryFormEventHandler,
    UserDictionaryFormEventArgs>
Value
UserDictionaryFormEventHandler


ShowDialog Method (owner, userDictionaryList, defaultDictionaryItem)

ShowDialog Method (owner, userDictionaryList, defaultDictionaryItem)
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewUserDictionarySelect ► ShowDialog(Object, List<(Of <<'(String>)>>), String)
Keyoti RapidSpell WPF
Shows the form modally
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
DialogResult ShowDialog(
    Object owner,
    List<string> userDictionaryList,
    string defaultDictionaryItem
)
DialogResult ShowDialog(
    Object owner,
    List<string> userDictionaryList,
    string defaultDictionaryItem
)
Function ShowDialog (
    owner As Object,
    userDictionaryList As List(Of String),
    defaultDictionaryItem As String
) As DialogResult
Function ShowDialog (
    owner As Object,
    userDictionaryList As List(Of String),
    defaultDictionaryItem As String
) As DialogResult
DialogResult ShowDialog(
    Object^ owner,
    List<String^>^ userDictionaryList,
    String^ defaultDictionaryItem
)
DialogResult ShowDialog(
    Object^ owner,
    List<String^>^ userDictionaryList,
    String^ defaultDictionaryItem
)
abstract ShowDialog :
        owner : Object *
        userDictionaryList : List<string> *
        defaultDictionaryItem : string -> DialogResult

abstract ShowDialog :
        owner : Object *
        userDictionaryList : List<string> *
        defaultDictionaryItem : string -> DialogResult
Parameters
owner (Object)
userDictionaryList (List<(Of <(<'String>)>)>)
defaultDictionaryItem (String)
Return Value
DialogResult


UserDictionarySelectFormAddText Property

UserDictionarySelectFormAddText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewUserDictionarySelect ► UserDictionarySelectFormAddText
Keyoti RapidSpell WPF
UI text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string UserDictionarySelectFormAddText { get; set; }
string UserDictionarySelectFormAddText { get; set; }
Property UserDictionarySelectFormAddText As String
    Get
    Set
Property UserDictionarySelectFormAddText As String
    Get
    Set
property String^ UserDictionarySelectFormAddText {
    String^ get ();
    void set (String^ value);
}
property String^ UserDictionarySelectFormAddText {
    String^ get ();
    void set (String^ value);
}
abstract UserDictionarySelectFormAddText : string with get, set

abstract UserDictionarySelectFormAddText : string with get, set
Property Value
String


UserDictionarySelectFormCancelText Property

UserDictionarySelectFormCancelText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewUserDictionarySelect ► UserDictionarySelectFormCancelText
Keyoti RapidSpell WPF
UI text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string UserDictionarySelectFormCancelText { get; set; }
string UserDictionarySelectFormCancelText { get; set; }
Property UserDictionarySelectFormCancelText As String
    Get
    Set
Property UserDictionarySelectFormCancelText As String
    Get
    Set
property String^ UserDictionarySelectFormCancelText {
    String^ get ();
    void set (String^ value);
}
property String^ UserDictionarySelectFormCancelText {
    String^ get ();
    void set (String^ value);
}
abstract UserDictionarySelectFormCancelText : string with get, set

abstract UserDictionarySelectFormCancelText : string with get, set
Property Value
String


UserDictionarySelectFormChangeDefaultText Property

UserDictionarySelectFormChangeDefaultText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewUserDictionarySelect ► UserDictionarySelectFormChangeDefaultText
Keyoti RapidSpell WPF
UI text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string UserDictionarySelectFormChangeDefaultText { get; set; }
string UserDictionarySelectFormChangeDefaultText { get; set; }
Property UserDictionarySelectFormChangeDefaultText As String
    Get
    Set
Property UserDictionarySelectFormChangeDefaultText As String
    Get
    Set
property String^ UserDictionarySelectFormChangeDefaultText {
    String^ get ();
    void set (String^ value);
}
property String^ UserDictionarySelectFormChangeDefaultText {
    String^ get ();
    void set (String^ value);
}
abstract UserDictionarySelectFormChangeDefaultText : string with get, set

abstract UserDictionarySelectFormChangeDefaultText : string with get, set
Property Value
String


UserDictionarySelectFormEditText Property

UserDictionarySelectFormEditText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewUserDictionarySelect ► UserDictionarySelectFormEditText
Keyoti RapidSpell WPF
UI text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string UserDictionarySelectFormEditText { get; set; }
string UserDictionarySelectFormEditText { get; set; }
Property UserDictionarySelectFormEditText As String
    Get
    Set
Property UserDictionarySelectFormEditText As String
    Get
    Set
property String^ UserDictionarySelectFormEditText {
    String^ get ();
    void set (String^ value);
}
property String^ UserDictionarySelectFormEditText {
    String^ get ();
    void set (String^ value);
}
abstract UserDictionarySelectFormEditText : string with get, set

abstract UserDictionarySelectFormEditText : string with get, set
Property Value
String


UserDictionarySelectFormGroupBoxTitleText Property

UserDictionarySelectFormGroupBoxTitleText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewUserDictionarySelect ► UserDictionarySelectFormGroupBoxTitleText
Keyoti RapidSpell WPF
UI text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string UserDictionarySelectFormGroupBoxTitleText { get; set; }
string UserDictionarySelectFormGroupBoxTitleText { get; set; }
Property UserDictionarySelectFormGroupBoxTitleText As String
    Get
    Set
Property UserDictionarySelectFormGroupBoxTitleText As String
    Get
    Set
property String^ UserDictionarySelectFormGroupBoxTitleText {
    String^ get ();
    void set (String^ value);
}
property String^ UserDictionarySelectFormGroupBoxTitleText {
    String^ get ();
    void set (String^ value);
}
abstract UserDictionarySelectFormGroupBoxTitleText : string with get, set

abstract UserDictionarySelectFormGroupBoxTitleText : string with get, set
Property Value
String


UserDictionarySelectFormNewText Property

UserDictionarySelectFormNewText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewUserDictionarySelect ► UserDictionarySelectFormNewText
Keyoti RapidSpell WPF
UI text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string UserDictionarySelectFormNewText { get; set; }
string UserDictionarySelectFormNewText { get; set; }
Property UserDictionarySelectFormNewText As String
    Get
    Set
Property UserDictionarySelectFormNewText As String
    Get
    Set
property String^ UserDictionarySelectFormNewText {
    String^ get ();
    void set (String^ value);
}
property String^ UserDictionarySelectFormNewText {
    String^ get ();
    void set (String^ value);
}
abstract UserDictionarySelectFormNewText : string with get, set

abstract UserDictionarySelectFormNewText : string with get, set
Property Value
String


UserDictionarySelectFormOkText Property

UserDictionarySelectFormOkText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewUserDictionarySelect ► UserDictionarySelectFormOkText
Keyoti RapidSpell WPF
UI text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string UserDictionarySelectFormOkText { get; set; }
string UserDictionarySelectFormOkText { get; set; }
Property UserDictionarySelectFormOkText As String
    Get
    Set
Property UserDictionarySelectFormOkText As String
    Get
    Set
property String^ UserDictionarySelectFormOkText {
    String^ get ();
    void set (String^ value);
}
property String^ UserDictionarySelectFormOkText {
    String^ get ();
    void set (String^ value);
}
abstract UserDictionarySelectFormOkText : string with get, set

abstract UserDictionarySelectFormOkText : string with get, set
Property Value
String


UserDictionarySelectFormRemoveText Property

UserDictionarySelectFormRemoveText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewUserDictionarySelect ► UserDictionarySelectFormRemoveText
Keyoti RapidSpell WPF
UI text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string UserDictionarySelectFormRemoveText { get; set; }
string UserDictionarySelectFormRemoveText { get; set; }
Property UserDictionarySelectFormRemoveText As String
    Get
    Set
Property UserDictionarySelectFormRemoveText As String
    Get
    Set
property String^ UserDictionarySelectFormRemoveText {
    String^ get ();
    void set (String^ value);
}
property String^ UserDictionarySelectFormRemoveText {
    String^ get ();
    void set (String^ value);
}
abstract UserDictionarySelectFormRemoveText : string with get, set

abstract UserDictionarySelectFormRemoveText : string with get, set
Property Value
String


UserDictionarySelectFormTitleText Property

UserDictionarySelectFormTitleText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► IDialogViewUserDictionarySelect ► UserDictionarySelectFormTitleText
Keyoti RapidSpell WPF
UI text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
string UserDictionarySelectFormTitleText { get; set; }
string UserDictionarySelectFormTitleText { get; set; }
Property UserDictionarySelectFormTitleText As String
    Get
    Set
Property UserDictionarySelectFormTitleText As String
    Get
    Set
property String^ UserDictionarySelectFormTitleText {
    String^ get ();
    void set (String^ value);
}
property String^ UserDictionarySelectFormTitleText {
    String^ get ();
    void set (String^ value);
}
abstract UserDictionarySelectFormTitleText : string with get, set

abstract UserDictionarySelectFormTitleText : string with get, set
Property Value
String


MessageBoxButtons Enumeration

MessageBoxButtons Enumeration
API ► Keyoti.RapidSpell.Wpf.DialogViews ► MessageBoxButtons
Keyoti RapidSpell WPF
Message box button combinations
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public enum MessageBoxButtons
public enum MessageBoxButtons
Public Enumeration MessageBoxButtons
Public Enumeration MessageBoxButtons
public enum class MessageBoxButtons
public enum class MessageBoxButtons
type MessageBoxButtons
type MessageBoxButtons
Members
Member | Description
YesNo | Yes and no
YesNoCancel | Yes, no and cancel
OKCancel | OK and cancel
OKClose | OK and close
OK | OK
Close | Close


MessageBoxIcon Enumeration

MessageBoxIcon Enumeration
API ► Keyoti.RapidSpell.Wpf.DialogViews ► MessageBoxIcon
Keyoti RapidSpell WPF
Icon for a message box
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public enum MessageBoxIcon
public enum MessageBoxIcon
Public Enumeration MessageBoxIcon
Public Enumeration MessageBoxIcon
public enum class MessageBoxIcon
public enum class MessageBoxIcon
type MessageBoxIcon
type MessageBoxIcon
Members
Member | Description
Information | Information
Question | Question
Error | Error
OK | OK
Alert | Alert
Default | Default


MessageBoxWPF Class

MessageBoxWPF Class
API ► Keyoti.RapidSpell.Wpf.DialogViews ► MessageBoxWPF
Keyoti RapidSpell WPF
WPF styled message box.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static class MessageBoxWPF
public static class MessageBoxWPF
Public NotInheritable Class MessageBoxWPF
Public NotInheritable Class MessageBoxWPF
public ref class MessageBoxWPF abstract sealed
public ref class MessageBoxWPF abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type MessageBoxWPF =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type MessageBoxWPF =  class end
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ShowMessageBox(String, String, MessageBoxButtons, MessageBoxIcon) | Show message box
Inheritance Hierarchy
Object
MessageBoxWPF


ShowMessageBox Method (message, title, buttons, icon)

ShowMessageBox Method (message, title, buttons, icon)
API ► Keyoti.RapidSpell.Wpf.DialogViews ► MessageBoxWPF ► ShowMessageBox(String, String, MessageBoxButtons, MessageBoxIcon)
Keyoti RapidSpell WPF
Show message box
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static DialogResult ShowMessageBox(
    string message,
    string title,
    MessageBoxButtons buttons,
    MessageBoxIcon icon
)
public static DialogResult ShowMessageBox(
    string message,
    string title,
    MessageBoxButtons buttons,
    MessageBoxIcon icon
)
Public Shared Function ShowMessageBox (
    message As String,
    title As String,
    buttons As MessageBoxButtons,
    icon As MessageBoxIcon
) As DialogResult
Public Shared Function ShowMessageBox (
    message As String,
    title As String,
    buttons As MessageBoxButtons,
    icon As MessageBoxIcon
) As DialogResult
public:
static DialogResult ShowMessageBox(
    String^ message,
    String^ title,
    MessageBoxButtons buttons,
    MessageBoxIcon icon
)
public:
static DialogResult ShowMessageBox(
    String^ message,
    String^ title,
    MessageBoxButtons buttons,
    MessageBoxIcon icon
)
static member ShowMessageBox :
        message : string *
        title : string *
        buttons : MessageBoxButtons *
        icon : MessageBoxIcon -> DialogResult

static member ShowMessageBox :
        message : string *
        title : string *
        buttons : MessageBoxButtons *
        icon : MessageBoxIcon -> DialogResult
Parameters
message (String)
title (String)
buttons (MessageBoxButtons)
icon (MessageBoxIcon)
Return Value
DialogResult


WPFUserDictionarySelect Class

WPFUserDictionarySelect Class
API ► Keyoti.RapidSpell.Wpf.DialogViews ► WPFUserDictionarySelect
Keyoti RapidSpell WPF
Interaction logic for WpfFormsUserDictionarySelect.xaml
WPFUserDictionarySelect
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class WPFUserDictionarySelect : Window,
    IDialogViewUserDictionarySelect, IComponentConnector
public class WPFUserDictionarySelect : Window,
    IDialogViewUserDictionarySelect, IComponentConnector
Public Class WPFUserDictionarySelect
    Inherits Window
    Implements IDialogViewUserDictionarySelect, IComponentConnector
Public Class WPFUserDictionarySelect
    Inherits Window
    Implements IDialogViewUserDictionarySelect, IComponentConnector
public ref class WPFUserDictionarySelect : public Window,
    IDialogViewUserDictionarySelect, IComponentConnector
public ref class WPFUserDictionarySelect : public Window,
    IDialogViewUserDictionarySelect, IComponentConnector
type WPFUserDictionarySelect =
    class
        inherit Window
        interface IDialogViewUserDictionarySelect
        interface IComponentConnector
    end
type WPFUserDictionarySelect =
    class
        inherit Window
        interface IDialogViewUserDictionarySelect
        interface IComponentConnector
    end
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WPFUserDictionarySelect()()()() |
 | Activate()()()() | (Inherited from Window.)
 | Activated | (Inherited from Window.)
 | ActualHeight | (Inherited from FrameworkElement.)
 | ActualWidth | (Inherited from FrameworkElement.)
 | AddChild(Object) | (Inherited from ContentControl.)
 | AddFile |
 | AddHandler(RoutedEvent, Delegate) | (Inherited from UIElement.)
 | AddHandler(RoutedEvent, Delegate, Boolean) | (Inherited from UIElement.)
 | AddLogicalChild(Object) | (Inherited from FrameworkElement.)
 | AddText(String) | (Inherited from ContentControl.)
 | AddToEventRoute(EventRoute, RoutedEventArgs) | (Inherited from UIElement.)
 | AddVisualChild(Visual) | (Inherited from Visual.)
 | AllowDrop | (Inherited from UIElement.)
 | AllowsTransparency | (Inherited from Window.)
 | ApplyAnimationClock(DependencyProperty, AnimationClock) | (Inherited from UIElement.)
 | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | (Inherited from UIElement.)
 | ApplyTemplate()()()() | (Inherited from FrameworkElement.)
 | AreAnyTouchesCaptured | (Inherited from UIElement.)
 | AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
 | AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
 | AreAnyTouchesOver | (Inherited from UIElement.)
 | Arrange(Rect) | (Inherited from UIElement.)
 | ArrangeCore(Rect) | (Inherited from FrameworkElement.)
 | ArrangeOverride(Size) | (Inherited from Window.)
 | Background | (Inherited from Control.)
 | BeginAnimation(DependencyProperty, AnimationTimeline) | (Inherited from UIElement.)
 | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | (Inherited from UIElement.)
 | BeginInit()()()() | (Inherited from FrameworkElement.)
 | BeginStoryboard(Storyboard) | (Inherited from FrameworkElement.)
 | BeginStoryboard(Storyboard, HandoffBehavior) | (Inherited from FrameworkElement.)
 | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | (Inherited from FrameworkElement.)
 | BindingGroup | (Inherited from FrameworkElement.)
 | BitmapEffect | Obsolete. (Inherited from UIElement.)
 | BitmapEffectInput | Obsolete. (Inherited from UIElement.)
 | BorderBrush | (Inherited from Control.)
 | BorderThickness | (Inherited from Control.)
 | BringIntoView()()()() | (Inherited from FrameworkElement.)
 | BringIntoView(Rect) | (Inherited from FrameworkElement.)
 | CacheMode | (Inherited from UIElement.)
 | CaptureMouse()()()() | (Inherited from UIElement.)
 | CaptureStylus()()()() | (Inherited from UIElement.)
 | CaptureTouch(TouchDevice) | (Inherited from UIElement.)
 | CheckAccess()()()() | (Inherited from DispatcherObject.)
 | ClearValue(DependencyProperty) | (Inherited from DependencyObject.)
 | ClearValue(DependencyPropertyKey) | (Inherited from DependencyObject.)
 | Clip | (Inherited from UIElement.)
 | ClipToBounds | (Inherited from UIElement.)
 | Close()()()() | (Inherited from Window.)
 | Closed | (Inherited from Window.)
 | Closing | (Inherited from Window.)
 | CoerceValue(DependencyProperty) | (Inherited from DependencyObject.)
 | CommandBindings | (Inherited from UIElement.)
 | Content | (Inherited from ContentControl.)
 | ContentRendered | (Inherited from Window.)
 | ContentStringFormat | (Inherited from ContentControl.)
 | ContentTemplate | (Inherited from ContentControl.)
 | ContentTemplateSelector | (Inherited from ContentControl.)
 | ContextMenu | (Inherited from FrameworkElement.)
 | ContextMenuClosing | (Inherited from FrameworkElement.)
 | ContextMenuOpening | (Inherited from FrameworkElement.)
 | Cursor | (Inherited from FrameworkElement.)
 | DataContext | (Inherited from FrameworkElement.)
 | DataContextChanged | (Inherited from FrameworkElement.)
 | Deactivated | (Inherited from Window.)
 | DefaultStyleKey | (Inherited from FrameworkElement.)
 | DefaultUserDictionaryItem |
 | DependencyObjectType | (Inherited from DependencyObject.)
 | DesiredSize | (Inherited from UIElement.)
 | DialogResult | (Inherited from Window.)
 | Dispatcher | (Inherited from DispatcherObject.)
 | Dispose()()()() |
 | DpiChanged()()()() | (Inherited from Window.)
 | DragEnter | (Inherited from UIElement.)
 | DragLeave | (Inherited from UIElement.)
 | DragMove()()()() | (Inherited from Window.)
 | DragOver | (Inherited from UIElement.)
 | Drop | (Inherited from UIElement.)
 | EditFile |
 | Effect | (Inherited from UIElement.)
 | EndInit()()()() | (Inherited from FrameworkElement.)
 | Equals(Object) | (Inherited from DependencyObject.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FindCommonVisualAncestor(DependencyObject) | (Inherited from Visual.)
 | FindName(String) | (Inherited from FrameworkElement.)
 | FindResource(Object) | (Inherited from FrameworkElement.)
 | FlowDirection | (Inherited from FrameworkElement.)
 | Focus()()()() | (Inherited from UIElement.)
 | Focusable | (Inherited from UIElement.)
 | FocusableChanged | (Inherited from UIElement.)
 | FocusVisualStyle | (Inherited from FrameworkElement.)
 | FontFamily | (Inherited from Control.)
 | FontSize | (Inherited from Control.)
 | FontStretch | (Inherited from Control.)
 | FontStyle | (Inherited from Control.)
 | FontWeight | (Inherited from Control.)
 | ForceCursor | (Inherited from FrameworkElement.)
 | Foreground | (Inherited from Control.)
 | GetAnimationBaseValue(DependencyProperty) | (Inherited from UIElement.)
 | GetBindingExpression(DependencyProperty) | (Inherited from FrameworkElement.)
 | GetHashCode()()()() | (Inherited from DependencyObject.)
 | GetLayoutClip(Size) | (Inherited from FrameworkElement.)
 | GetLocalValueEnumerator()()()() | (Inherited from DependencyObject.)
 | GetTemplateChild(String) | (Inherited from FrameworkElement.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GetUIParentCore()()()() | (Inherited from FrameworkElement.)
 | GetValue(DependencyProperty) | (Inherited from DependencyObject.)
 | GetVisualChild(Int32) | (Inherited from FrameworkElement.)
 | GiveFeedback | (Inherited from UIElement.)
 | GotFocus | (Inherited from UIElement.)
 | GotKeyboardFocus | (Inherited from UIElement.)
 | GotMouseCapture | (Inherited from UIElement.)
 | GotStylusCapture | (Inherited from UIElement.)
 | GotTouchCapture | (Inherited from UIElement.)
 | HandlesScrolling | (Inherited from Control.)
 | HasAnimatedProperties | (Inherited from UIElement.)
 | HasContent | (Inherited from ContentControl.)
 | HasEffectiveKeyboardFocus | (Inherited from UIElement.)
 | Height | (Inherited from FrameworkElement.)
 | Hide()()()() | (Inherited from Window.)
 | HitTestCore(PointHitTestParameters) | (Inherited from UIElement.)
 | HitTestCore(GeometryHitTestParameters) | (Inherited from UIElement.)
 | HorizontalAlignment | (Inherited from FrameworkElement.)
 | HorizontalContentAlignment | (Inherited from Control.)
 | Icon | (Inherited from Window.)
 | InheritanceBehavior | (Inherited from FrameworkElement.)
 | InitializeComponent()()()() | InitializeComponent
 | Initialized | (Inherited from FrameworkElement.)
 | InputBindings | (Inherited from UIElement.)
 | InputHitTest(Point) | (Inherited from UIElement.)
 | InputScope | (Inherited from FrameworkElement.)
 | InvalidateArrange()()()() | (Inherited from UIElement.)
 | InvalidateMeasure()()()() | (Inherited from UIElement.)
 | InvalidateProperty(DependencyProperty) | (Inherited from DependencyObject.)
 | InvalidateVisual()()()() | (Inherited from UIElement.)
 | IsActive | (Inherited from Window.)
 | IsAncestorOf(DependencyObject) | (Inherited from Visual.)
 | IsArrangeValid | (Inherited from UIElement.)
 | IsDescendantOf(DependencyObject) | (Inherited from Visual.)
 | IsEnabled | (Inherited from UIElement.)
 | IsEnabledChanged | (Inherited from UIElement.)
 | IsEnabledCore | (Inherited from UIElement.)
 | IsFocused | (Inherited from UIElement.)
 | IsHitTestVisible | (Inherited from UIElement.)
 | IsHitTestVisibleChanged | (Inherited from UIElement.)
 | IsInitialized | (Inherited from FrameworkElement.)
 | IsInputMethodEnabled | (Inherited from UIElement.)
 | IsKeyboardFocused | (Inherited from UIElement.)
 | IsKeyboardFocusedChanged | (Inherited from UIElement.)
 | IsKeyboardFocusWithin | (Inherited from UIElement.)
 | IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
 | IsLoaded | (Inherited from FrameworkElement.)
 | IsManipulationEnabled | (Inherited from UIElement.)
 | IsMeasureValid | (Inherited from UIElement.)
 | IsMouseCaptured | (Inherited from UIElement.)
 | IsMouseCapturedChanged | (Inherited from UIElement.)
 | IsMouseCaptureWithin | (Inherited from UIElement.)
 | IsMouseCaptureWithinChanged | (Inherited from UIElement.)
 | IsMouseDirectlyOver | (Inherited from UIElement.)
 | IsMouseDirectlyOverChanged | (Inherited from UIElement.)
 | IsMouseOver | (Inherited from UIElement.)
 | IsSealed | (Inherited from DependencyObject.)
 | IsStylusCaptured | (Inherited from UIElement.)
 | IsStylusCapturedChanged | (Inherited from UIElement.)
 | IsStylusCaptureWithin | (Inherited from UIElement.)
 | IsStylusCaptureWithinChanged | (Inherited from UIElement.)
 | IsStylusDirectlyOver | (Inherited from UIElement.)
 | IsStylusDirectlyOverChanged | (Inherited from UIElement.)
 | IsStylusOver | (Inherited from UIElement.)
 | IsTabStop | (Inherited from Control.)
 | IsVisible | (Inherited from UIElement.)
 | IsVisibleChanged | (Inherited from UIElement.)
 | KeyDown | (Inherited from UIElement.)
 | KeyUp | (Inherited from UIElement.)
 | Language | (Inherited from FrameworkElement.)
 | LayoutTransform | (Inherited from FrameworkElement.)
 | LayoutUpdated | (Inherited from UIElement.)
 | Left | (Inherited from Window.)
 | Loaded | (Inherited from FrameworkElement.)
 | LocationChanged | (Inherited from Window.)
 | LogicalChildren | (Inherited from Window.)
 | LostFocus | (Inherited from UIElement.)
 | LostKeyboardFocus | (Inherited from UIElement.)
 | LostMouseCapture | (Inherited from UIElement.)
 | LostStylusCapture | (Inherited from UIElement.)
 | LostTouchCapture | (Inherited from UIElement.)
 | ManipulationBoundaryFeedback | (Inherited from UIElement.)
 | ManipulationCompleted | (Inherited from UIElement.)
 | ManipulationDelta | (Inherited from UIElement.)
 | ManipulationInertiaStarting | (Inherited from UIElement.)
 | ManipulationStarted | (Inherited from UIElement.)
 | ManipulationStarting | (Inherited from UIElement.)
 | Margin | (Inherited from FrameworkElement.)
 | MaxHeight | (Inherited from FrameworkElement.)
 | MaxWidth | (Inherited from FrameworkElement.)
 | Measure(Size) | (Inherited from UIElement.)
 | MeasureCore(Size) | (Inherited from FrameworkElement.)
 | MeasureOverride(Size) | (Inherited from Window.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinHeight | (Inherited from FrameworkElement.)
 | MinWidth | (Inherited from FrameworkElement.)
 | MouseDoubleClick | (Inherited from Control.)
 | MouseDown | (Inherited from UIElement.)
 | MouseEnter | (Inherited from UIElement.)
 | MouseLeave | (Inherited from UIElement.)
 | MouseLeftButtonDown | (Inherited from UIElement.)
 | MouseLeftButtonUp | (Inherited from UIElement.)
 | MouseMove | (Inherited from UIElement.)
 | MouseRightButtonDown | (Inherited from UIElement.)
 | MouseRightButtonUp | (Inherited from UIElement.)
 | MouseUp | (Inherited from UIElement.)
 | MouseWheel | (Inherited from UIElement.)
 | MoveFocus(TraversalRequest) | (Inherited from FrameworkElement.)
 | Name | (Inherited from FrameworkElement.)
 | OnAccessKey(AccessKeyEventArgs) | (Inherited from UIElement.)
 | OnActivated(EventArgs) | (Inherited from Window.)
 | OnApplyTemplate()()()() | (Inherited from FrameworkElement.)
 | OnChildDesiredSizeChanged(UIElement) | (Inherited from UIElement.)
 | OnClosed(EventArgs) | (Inherited from Window.)
 | OnClosing(CancelEventArgs) | (Inherited from Window.)
 | OnContentChanged(Object, Object) | (Inherited from Window.)
 | OnContentRendered(EventArgs) | (Inherited from Window.)
 | OnContentStringFormatChanged(String, String) | (Inherited from ContentControl.)
 | OnContentTemplateChanged(DataTemplate, DataTemplate) | (Inherited from ContentControl.)
 | OnContentTemplateSelectorChanged(DataTemplateSelector, DataTemplateSelector) | (Inherited from ContentControl.)
 | OnContextMenuClosing(ContextMenuEventArgs) | (Inherited from FrameworkElement.)
 | OnContextMenuOpening(ContextMenuEventArgs) | (Inherited from FrameworkElement.)
 | OnCreateAutomationPeer()()()() | (Inherited from Window.)
 | OnDeactivated(EventArgs) | (Inherited from Window.)
 | OnDpiChanged(DpiScale, DpiScale) | (Inherited from Window.)
 | OnDragEnter(DragEventArgs) | (Inherited from UIElement.)
 | OnDragLeave(DragEventArgs) | (Inherited from UIElement.)
 | OnDragOver(DragEventArgs) | (Inherited from UIElement.)
 | OnDrop(DragEventArgs) | (Inherited from UIElement.)
 | OnGiveFeedback(GiveFeedbackEventArgs) | (Inherited from UIElement.)
 | OnGotFocus(RoutedEventArgs) | (Inherited from FrameworkElement.)
 | OnGotKeyboardFocus(KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
 | OnGotMouseCapture(MouseEventArgs) | (Inherited from UIElement.)
 | OnGotStylusCapture(StylusEventArgs) | (Inherited from UIElement.)
 | OnGotTouchCapture(TouchEventArgs) | (Inherited from UIElement.)
 | OnInitialized(EventArgs) | (Inherited from FrameworkElement.)
 | OnIsKeyboardFocusedChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsKeyboardFocusWithinChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsMouseCapturedChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsMouseCaptureWithinChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsMouseDirectlyOverChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsStylusCapturedChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsStylusCaptureWithinChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnIsStylusDirectlyOverChanged(DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
 | OnKeyDown(KeyEventArgs) | (Inherited from UIElement.)
 | OnKeyUp(KeyEventArgs) | (Inherited from UIElement.)
 | OnLocationChanged(EventArgs) | (Inherited from Window.)
 | OnLostFocus(RoutedEventArgs) | (Inherited from UIElement.)
 | OnLostKeyboardFocus(KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
 | OnLostMouseCapture(MouseEventArgs) | (Inherited from UIElement.)
 | OnLostStylusCapture(StylusEventArgs) | (Inherited from UIElement.)
 | OnLostTouchCapture(TouchEventArgs) | (Inherited from UIElement.)
 | OnManipulationBoundaryFeedback(ManipulationBoundaryFeedbackEventArgs) | (Inherited from Window.)
 | OnManipulationCompleted(ManipulationCompletedEventArgs) | (Inherited from UIElement.)
 | OnManipulationDelta(ManipulationDeltaEventArgs) | (Inherited from UIElement.)
 | OnManipulationInertiaStarting(ManipulationInertiaStartingEventArgs) | (Inherited from UIElement.)
 | OnManipulationStarted(ManipulationStartedEventArgs) | (Inherited from UIElement.)
 | OnManipulationStarting(ManipulationStartingEventArgs) | (Inherited from UIElement.)
 | OnMouseDoubleClick(MouseButtonEventArgs) | (Inherited from Control.)
 | OnMouseDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseEnter(MouseEventArgs) | (Inherited from UIElement.)
 | OnMouseLeave(MouseEventArgs) | (Inherited from UIElement.)
 | OnMouseLeftButtonDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseLeftButtonUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseMove(MouseEventArgs) | (Inherited from UIElement.)
 | OnMouseRightButtonDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseRightButtonUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnMouseWheel(MouseWheelEventArgs) | (Inherited from UIElement.)
 | OnPreviewDragEnter(DragEventArgs) | (Inherited from UIElement.)
 | OnPreviewDragLeave(DragEventArgs) | (Inherited from UIElement.)
 | OnPreviewDragOver(DragEventArgs) | (Inherited from UIElement.)
 | OnPreviewDrop(DragEventArgs) | (Inherited from UIElement.)
 | OnPreviewGiveFeedback(GiveFeedbackEventArgs) | (Inherited from UIElement.)
 | OnPreviewGotKeyboardFocus(KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
 | OnPreviewKeyDown(KeyEventArgs) | (Inherited from UIElement.)
 | OnPreviewKeyUp(KeyEventArgs) | (Inherited from UIElement.)
 | OnPreviewLostKeyboardFocus(KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseDoubleClick(MouseButtonEventArgs) | (Inherited from Control.)
 | OnPreviewMouseDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseLeftButtonDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseLeftButtonUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseMove(MouseEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseRightButtonDown(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseRightButtonUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseUp(MouseButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewMouseWheel(MouseWheelEventArgs) | (Inherited from UIElement.)
 | OnPreviewQueryContinueDrag(QueryContinueDragEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusButtonDown(StylusButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusButtonUp(StylusButtonEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusDown(StylusDownEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusInAirMove(StylusEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusInRange(StylusEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusMove(StylusEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusOutOfRange(StylusEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusSystemGesture(StylusSystemGestureEventArgs) | (Inherited from UIElement.)
 | OnPreviewStylusUp(StylusEventArgs) | (Inherited from UIElement.)
 | OnPreviewTextInput(TextCompositionEventArgs) | (Inherited from UIElement.)
 | OnPreviewTouchDown(TouchEventArgs) | (Inherited from UIElement.)
 | OnPreviewTouchMove(TouchEventArgs) | (Inherited from UIElement.)
 | OnPreviewTouchUp(TouchEventArgs) | (Inherited from UIElement.)
 | OnPropertyChanged(DependencyPropertyChangedEventArgs) | (Inherited from FrameworkElement.)
 | OnQueryContinueDrag(QueryContinueDragEventArgs) | (Inherited from UIElement.)
 | OnQueryCursor(QueryCursorEventArgs) | (Inherited from UIElement.)
 | OnRender(DrawingContext) | (Inherited from UIElement.)
 | OnRenderSizeChanged(SizeChangedInfo) | (Inherited from FrameworkElement.)
 | OnSourceInitialized(EventArgs) | (Inherited from Window.)
 | OnStateChanged(EventArgs) | (Inherited from Window.)
 | OnStyleChanged(Style, Style) | (Inherited from FrameworkElement.)
 | OnStylusButtonDown(StylusButtonEventArgs) | (Inherited from UIElement.)
 | OnStylusButtonUp(StylusButtonEventArgs) | (Inherited from UIElement.)
 | OnStylusDown(StylusDownEventArgs) | (Inherited from UIElement.)
 | OnStylusEnter(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusInAirMove(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusInRange(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusLeave(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusMove(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusOutOfRange(StylusEventArgs) | (Inherited from UIElement.)
 | OnStylusSystemGesture(StylusSystemGestureEventArgs) | (Inherited from UIElement.)
 | OnStylusUp(StylusEventArgs) | (Inherited from UIElement.)
 | OnTemplateChanged(ControlTemplate, ControlTemplate) | (Inherited from Control.)
 | OnTextInput(TextCompositionEventArgs) | (Inherited from UIElement.)
 | OnToolTipClosing(ToolTipEventArgs) | (Inherited from FrameworkElement.)
 | OnToolTipOpening(ToolTipEventArgs) | (Inherited from FrameworkElement.)
 | OnTouchDown(TouchEventArgs) | (Inherited from UIElement.)
 | OnTouchEnter(TouchEventArgs) | (Inherited from UIElement.)
 | OnTouchLeave(TouchEventArgs) | (Inherited from UIElement.)
 | OnTouchMove(TouchEventArgs) | (Inherited from UIElement.)
 | OnTouchUp(TouchEventArgs) | (Inherited from UIElement.)
 | OnVisualChildrenChanged(DependencyObject, DependencyObject) | (Inherited from Window.)
 | OnVisualParentChanged(DependencyObject) | (Inherited from Window.)
 | Opacity | (Inherited from UIElement.)
 | OpacityMask | (Inherited from UIElement.)
 | OverridesDefaultStyle | (Inherited from FrameworkElement.)
 | OwnedWindows | (Inherited from Window.)
 | Owner | (Inherited from Window.)
 | Padding | (Inherited from Control.)
 | Parent | (Inherited from FrameworkElement.)
 | ParentLayoutInvalidated(UIElement) | (Inherited from FrameworkElement.)
 | PersistId | Obsolete. (Inherited from UIElement.)
 | PointFromScreen(Point) | (Inherited from Visual.)
 | PointToScreen(Point) | (Inherited from Visual.)
 | PredictFocus(FocusNavigationDirection) | (Inherited from FrameworkElement.)
 | PreviewDragEnter | (Inherited from UIElement.)
 | PreviewDragLeave | (Inherited from UIElement.)
 | PreviewDragOver | (Inherited from UIElement.)
 | PreviewDrop | (Inherited from UIElement.)
 | PreviewGiveFeedback | (Inherited from UIElement.)
 | PreviewGotKeyboardFocus | (Inherited from UIElement.)
 | PreviewKeyDown | (Inherited from UIElement.)
 | PreviewKeyUp | (Inherited from UIElement.)
 | PreviewLostKeyboardFocus | (Inherited from UIElement.)
 | PreviewMouseDoubleClick | (Inherited from Control.)
 | PreviewMouseDown | (Inherited from UIElement.)
 | PreviewMouseLeftButtonDown | (Inherited from UIElement.)
 | PreviewMouseLeftButtonUp | (Inherited from UIElement.)
 | PreviewMouseMove | (Inherited from UIElement.)
 | PreviewMouseRightButtonDown | (Inherited from UIElement.)
 | PreviewMouseRightButtonUp | (Inherited from UIElement.)
 | PreviewMouseUp | (Inherited from UIElement.)
 | PreviewMouseWheel | (Inherited from UIElement.)
 | PreviewQueryContinueDrag | (Inherited from UIElement.)
 | PreviewStylusButtonDown | (Inherited from UIElement.)
 | PreviewStylusButtonUp | (Inherited from UIElement.)
 | PreviewStylusDown | (Inherited from UIElement.)
 | PreviewStylusInAirMove | (Inherited from UIElement.)
 | PreviewStylusInRange | (Inherited from UIElement.)
 | PreviewStylusMove | (Inherited from UIElement.)
 | PreviewStylusOutOfRange | (Inherited from UIElement.)
 | PreviewStylusSystemGesture | (Inherited from UIElement.)
 | PreviewStylusUp | (Inherited from UIElement.)
 | PreviewTextInput | (Inherited from UIElement.)
 | PreviewTouchDown | (Inherited from UIElement.)
 | PreviewTouchMove | (Inherited from UIElement.)
 | PreviewTouchUp | (Inherited from UIElement.)
 | QueryContinueDrag | (Inherited from UIElement.)
 | QueryCursor | (Inherited from UIElement.)
 | RaiseEvent(RoutedEventArgs) | (Inherited from UIElement.)
 | ReadLocalValue(DependencyProperty) | (Inherited from DependencyObject.)
 | RegisterName(String, Object) | (Inherited from FrameworkElement.)
 | ReleaseAllTouchCaptures()()()() | (Inherited from UIElement.)
 | ReleaseMouseCapture()()()() | (Inherited from UIElement.)
 | ReleaseStylusCapture()()()() | (Inherited from UIElement.)
 | ReleaseTouchCapture(TouchDevice) | (Inherited from UIElement.)
 | RemoveFile |
 | RemoveHandler(RoutedEvent, Delegate) | (Inherited from UIElement.)
 | RemoveLogicalChild(Object) | (Inherited from FrameworkElement.)
 | RemoveVisualChild(Visual) | (Inherited from Visual.)
 | RenderSize | (Inherited from UIElement.)
 | RenderTransform | (Inherited from UIElement.)
 | RenderTransformOrigin | (Inherited from UIElement.)
 | RequestBringIntoView | (Inherited from FrameworkElement.)
 | ResizeMode | (Inherited from Window.)
 | Resources | (Inherited from FrameworkElement.)
 | RestoreBounds | (Inherited from Window.)
 | SetBinding(DependencyProperty, BindingBase) | (Inherited from FrameworkElement.)
 | SetBinding(DependencyProperty, String) | (Inherited from FrameworkElement.)
 | SetCurrentValue(DependencyProperty, Object) | (Inherited from DependencyObject.)
 | SetResourceReference(DependencyProperty, Object) | (Inherited from FrameworkElement.)
 | SetValue(DependencyProperty, Object) | (Inherited from DependencyObject.)
 | SetValue(DependencyPropertyKey, Object) | (Inherited from DependencyObject.)
 | ShouldSerializeCommandBindings()()()() | (Inherited from UIElement.)
 | ShouldSerializeContent()()()() | (Inherited from ContentControl.)
 | ShouldSerializeInputBindings()()()() | (Inherited from UIElement.)
 | ShouldSerializeProperty(DependencyProperty) | (Inherited from DependencyObject.)
 | ShouldSerializeResources()()()() | (Inherited from FrameworkElement.)
 | ShouldSerializeStyle()()()() | (Inherited from FrameworkElement.)
 | ShouldSerializeTriggers()()()() | (Inherited from FrameworkElement.)
 | Show()()()() | (Inherited from Window.)
 | ShowActivated | (Inherited from Window.)
 | ShowDialog(Object, List<(Of <<'(String>)>>), String) | See IDialogViewUserDictionaryEdit
 | ShowDialog()()()() | (Inherited from Window.)
 | ShowInTaskbar | (Inherited from Window.)
 | SizeChanged | (Inherited from FrameworkElement.)
 | SizeToContent | (Inherited from Window.)
 | SnapsToDevicePixels | (Inherited from UIElement.)
 | SourceInitialized | (Inherited from Window.)
 | SourceUpdated | (Inherited from FrameworkElement.)
 | StateChanged | (Inherited from Window.)
 | Style | (Inherited from FrameworkElement.)
 | StylusButtonDown | (Inherited from UIElement.)
 | StylusButtonUp | (Inherited from UIElement.)
 | StylusDown | (Inherited from UIElement.)
 | StylusEnter | (Inherited from UIElement.)
 | StylusInAirMove | (Inherited from UIElement.)
 | StylusInRange | (Inherited from UIElement.)
 | StylusLeave | (Inherited from UIElement.)
 | StylusMove | (Inherited from UIElement.)
 | StylusOutOfRange | (Inherited from UIElement.)
 | StylusPlugIns | (Inherited from UIElement.)
 | StylusSystemGesture | (Inherited from UIElement.)
 | StylusUp | (Inherited from UIElement.)
 | TabIndex | (Inherited from Control.)
 | Tag | (Inherited from FrameworkElement.)
 | TargetUpdated | (Inherited from FrameworkElement.)
 | TaskbarItemInfo | (Inherited from Window.)
 | Template | (Inherited from Control.)
 | TemplatedParent | (Inherited from FrameworkElement.)
 | TextInput | (Inherited from UIElement.)
 | Title | (Inherited from Window.)
 | ToolTip | (Inherited from FrameworkElement.)
 | ToolTipClosing | (Inherited from FrameworkElement.)
 | ToolTipOpening | (Inherited from FrameworkElement.)
 | Top | (Inherited from Window.)
 | Topmost | (Inherited from Window.)
 | ToString()()()() | (Inherited from Control.)
 | TouchDown | (Inherited from UIElement.)
 | TouchEnter | (Inherited from UIElement.)
 | TouchesCaptured | (Inherited from UIElement.)
 | TouchesCapturedWithin | (Inherited from UIElement.)
 | TouchesDirectlyOver | (Inherited from UIElement.)
 | TouchesOver | (Inherited from UIElement.)
 | TouchLeave | (Inherited from UIElement.)
 | TouchMove | (Inherited from UIElement.)
 | TouchUp | (Inherited from UIElement.)
 | TransformToAncestor(Visual) | (Inherited from Visual.)
 | TransformToAncestor(Visual3D) | (Inherited from Visual.)
 | TransformToDescendant(Visual) | (Inherited from Visual.)
 | TransformToVisual(Visual) | (Inherited from Visual.)
 | TranslatePoint(Point, UIElement) | (Inherited from UIElement.)
 | Triggers | (Inherited from FrameworkElement.)
 | TryFindResource(Object) | (Inherited from FrameworkElement.)
 | Uid | (Inherited from UIElement.)
 | Unloaded | (Inherited from FrameworkElement.)
 | UnregisterName(String) | (Inherited from FrameworkElement.)
 | UpdateDefaultStyle()()()() | (Inherited from FrameworkElement.)
 | UpdateLayout()()()() | (Inherited from UIElement.)
 | UseLayoutRounding | (Inherited from FrameworkElement.)
 | UserDictionarySelectFormAddText |
 | UserDictionarySelectFormCancelText |
 | UserDictionarySelectFormChangeDefaultText |
 | UserDictionarySelectFormEditText |
 | UserDictionarySelectFormGroupBoxTitleText |
 | UserDictionarySelectFormNewText |
 | UserDictionarySelectFormOkText |
 | UserDictionarySelectFormRemoveText |
 | UserDictionarySelectFormTitleText |
 | VerifyAccess()()()() | (Inherited from DispatcherObject.)
 | VerticalAlignment | (Inherited from FrameworkElement.)
 | VerticalContentAlignment | (Inherited from Control.)
 | Visibility | (Inherited from UIElement.)
 | VisualBitmapEffect | Obsolete. (Inherited from Visual.)
 | VisualBitmapEffectInput | Obsolete. (Inherited from Visual.)
 | VisualBitmapScalingMode | (Inherited from Visual.)
 | VisualCacheMode | (Inherited from Visual.)
 | VisualChildrenCount | (Inherited from FrameworkElement.)
 | VisualClearTypeHint | (Inherited from Visual.)
 | VisualClip | (Inherited from Visual.)
 | VisualEdgeMode | (Inherited from Visual.)
 | VisualEffect | (Inherited from Visual.)
 | VisualOffset | (Inherited from Visual.)
 | VisualOpacity | (Inherited from Visual.)
 | VisualOpacityMask | (Inherited from Visual.)
 | VisualParent | (Inherited from Visual.)
 | VisualScrollableAreaClip | (Inherited from Visual.)
 | VisualTextHintingMode | (Inherited from Visual.)
 | VisualTextRenderingMode | (Inherited from Visual.)
 | VisualTransform | (Inherited from Visual.)
 | VisualXSnappingGuidelines | (Inherited from Visual.)
 | VisualYSnappingGuidelines | (Inherited from Visual.)
 | Width | (Inherited from FrameworkElement.)
 | WindowStartupLocation | (Inherited from Window.)
 | WindowState | (Inherited from Window.)
 | WindowStyle | (Inherited from Window.)
Inheritance Hierarchy
Object
 | DispatcherObject
 |  | DependencyObject
 |  |  | Visual
 |  |  |  | UIElement
 |  |  |  |  | FrameworkElement
 |  |  |  |  |  | Control
 |  |  |  |  |  |  | ContentControl
 |  |  |  |  |  |  |  | Window
 |  |  |  |  |  |  |  |  | WPFUserDictionarySelect


WPFUserDictionarySelect Constructor

WPFUserDictionarySelect Constructor
API ► Keyoti.RapidSpell.Wpf.DialogViews ► WPFUserDictionarySelect ► WPFUserDictionarySelect()()()()
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public WPFUserDictionarySelect()
public WPFUserDictionarySelect()
Public Sub New
Public Sub New
public:
WPFUserDictionarySelect()
public:
WPFUserDictionarySelect()
new : unit -> WPFUserDictionarySelect
new : unit -> WPFUserDictionarySelect


AddFile Event

AddFile Event
API ► Keyoti.RapidSpell.Wpf.DialogViews ► WPFUserDictionarySelect ► AddFile
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event UserDictionaryFormEventHandler AddFile
public event UserDictionaryFormEventHandler AddFile
Public Event AddFile As UserDictionaryFormEventHandler
Public Event AddFile As UserDictionaryFormEventHandler
public:
virtual  event UserDictionaryFormEventHandler^ AddFile {
    void add (UserDictionaryFormEventHandler^ value);
    void remove (UserDictionaryFormEventHandler^ value);
}
public:
virtual  event UserDictionaryFormEventHandler^ AddFile {
    void add (UserDictionaryFormEventHandler^ value);
    void remove (UserDictionaryFormEventHandler^ value);
}
abstract AddFile : IEvent<UserDictionaryFormEventHandler,
    UserDictionaryFormEventArgs>
override AddFile : IEvent<UserDictionaryFormEventHandler,
    UserDictionaryFormEventArgs>
abstract AddFile : IEvent<UserDictionaryFormEventHandler,
    UserDictionaryFormEventArgs>
override AddFile : IEvent<UserDictionaryFormEventHandler,
    UserDictionaryFormEventArgs>
Value
UserDictionaryFormEventHandler


DefaultUserDictionaryItem Property

DefaultUserDictionaryItem Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► WPFUserDictionarySelect ► DefaultUserDictionaryItem
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string DefaultUserDictionaryItem { get; }
public string DefaultUserDictionaryItem { get; }
Public ReadOnly Property DefaultUserDictionaryItem As String
    Get
Public ReadOnly Property DefaultUserDictionaryItem As String
    Get
public:
virtual property String^ DefaultUserDictionaryItem {
    String^ get () sealed;
}
public:
virtual property String^ DefaultUserDictionaryItem {
    String^ get () sealed;
}
abstract DefaultUserDictionaryItem : string with get
override DefaultUserDictionaryItem : string with get
abstract DefaultUserDictionaryItem : string with get
override DefaultUserDictionaryItem : string with get
Property Value
String


Dispose Method

Dispose Method
API ► Keyoti.RapidSpell.Wpf.DialogViews ► WPFUserDictionarySelect ► Dispose()()()()
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void Dispose()
public void Dispose()
Public Sub Dispose
Public Sub Dispose
public:
virtual void Dispose() sealed
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit
abstract Dispose : unit -> unit
override Dispose : unit -> unit


EditFile Event

EditFile Event
API ► Keyoti.RapidSpell.Wpf.DialogViews ► WPFUserDictionarySelect ► EditFile
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event UserDictionaryFormEventHandler EditFile
public event UserDictionaryFormEventHandler EditFile
Public Event EditFile As UserDictionaryFormEventHandler
Public Event EditFile As UserDictionaryFormEventHandler
public:
virtual  event UserDictionaryFormEventHandler^ EditFile {
    void add (UserDictionaryFormEventHandler^ value);
    void remove (UserDictionaryFormEventHandler^ value);
}
public:
virtual  event UserDictionaryFormEventHandler^ EditFile {
    void add (UserDictionaryFormEventHandler^ value);
    void remove (UserDictionaryFormEventHandler^ value);
}
abstract EditFile : IEvent<UserDictionaryFormEventHandler,
    UserDictionaryFormEventArgs>
override EditFile : IEvent<UserDictionaryFormEventHandler,
    UserDictionaryFormEventArgs>
abstract EditFile : IEvent<UserDictionaryFormEventHandler,
    UserDictionaryFormEventArgs>
override EditFile : IEvent<UserDictionaryFormEventHandler,
    UserDictionaryFormEventArgs>
Value
UserDictionaryFormEventHandler


InitializeComponent Method

InitializeComponent Method
API ► Keyoti.RapidSpell.Wpf.DialogViews ► WPFUserDictionarySelect ► InitializeComponent()()()()
Keyoti RapidSpell WPF
InitializeComponent
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void InitializeComponent()
public void InitializeComponent()
Public Sub InitializeComponent
Public Sub InitializeComponent
public:
virtual void InitializeComponent() sealed
public:
virtual void InitializeComponent() sealed
abstract InitializeComponent : unit -> unit
override InitializeComponent : unit -> unit
abstract InitializeComponent : unit -> unit
override InitializeComponent : unit -> unit


RemoveFile Event

RemoveFile Event
API ► Keyoti.RapidSpell.Wpf.DialogViews ► WPFUserDictionarySelect ► RemoveFile
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event UserDictionaryFormEventHandler RemoveFile
public event UserDictionaryFormEventHandler RemoveFile
Public Event RemoveFile As UserDictionaryFormEventHandler
Public Event RemoveFile As UserDictionaryFormEventHandler
public:
virtual  event UserDictionaryFormEventHandler^ RemoveFile {
    void add (UserDictionaryFormEventHandler^ value);
    void remove (UserDictionaryFormEventHandler^ value);
}
public:
virtual  event UserDictionaryFormEventHandler^ RemoveFile {
    void add (UserDictionaryFormEventHandler^ value);
    void remove (UserDictionaryFormEventHandler^ value);
}
abstract RemoveFile : IEvent<UserDictionaryFormEventHandler,
    UserDictionaryFormEventArgs>
override RemoveFile : IEvent<UserDictionaryFormEventHandler,
    UserDictionaryFormEventArgs>
abstract RemoveFile : IEvent<UserDictionaryFormEventHandler,
    UserDictionaryFormEventArgs>
override RemoveFile : IEvent<UserDictionaryFormEventHandler,
    UserDictionaryFormEventArgs>
Value
UserDictionaryFormEventHandler


ShowDialog Method (owner, userDictionaryList, defaultUserDictionaryItem)

ShowDialog Method (owner, userDictionaryList, defaultUserDictionaryItem)
API ► Keyoti.RapidSpell.Wpf.DialogViews ► WPFUserDictionarySelect ► ShowDialog(Object, List<(Of <<'(String>)>>), String)
Keyoti RapidSpell WPF
See IDialogViewUserDictionaryEdit
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public DialogResult ShowDialog(
    Object owner,
    List<string> userDictionaryList,
    string defaultUserDictionaryItem
)
public DialogResult ShowDialog(
    Object owner,
    List<string> userDictionaryList,
    string defaultUserDictionaryItem
)
Public Function ShowDialog (
    owner As Object,
    userDictionaryList As List(Of String),
    defaultUserDictionaryItem As String
) As DialogResult
Public Function ShowDialog (
    owner As Object,
    userDictionaryList As List(Of String),
    defaultUserDictionaryItem As String
) As DialogResult
public:
virtual DialogResult ShowDialog(
    Object^ owner,
    List<String^>^ userDictionaryList,
    String^ defaultUserDictionaryItem
) sealed
public:
virtual DialogResult ShowDialog(
    Object^ owner,
    List<String^>^ userDictionaryList,
    String^ defaultUserDictionaryItem
) sealed
abstract ShowDialog :
        owner : Object *
        userDictionaryList : List<string> *
        defaultUserDictionaryItem : string -> DialogResult
override ShowDialog :
        owner : Object *
        userDictionaryList : List<string> *
        defaultUserDictionaryItem : string -> DialogResult
abstract ShowDialog :
        owner : Object *
        userDictionaryList : List<string> *
        defaultUserDictionaryItem : string -> DialogResult
override ShowDialog :
        owner : Object *
        userDictionaryList : List<string> *
        defaultUserDictionaryItem : string -> DialogResult
Parameters
owner (Object)
userDictionaryList (List<(Of <(<'String>)>)>)
defaultUserDictionaryItem (String)
Return Value
DialogResult


UserDictionarySelectFormAddText Property

UserDictionarySelectFormAddText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► WPFUserDictionarySelect ► UserDictionarySelectFormAddText
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionarySelectFormAddText { get; set; }
public string UserDictionarySelectFormAddText { get; set; }
Public Property UserDictionarySelectFormAddText As String
    Get
    Set
Public Property UserDictionarySelectFormAddText As String
    Get
    Set
public:
virtual property String^ UserDictionarySelectFormAddText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ UserDictionarySelectFormAddText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract UserDictionarySelectFormAddText : string with get, set
override UserDictionarySelectFormAddText : string with get, set
abstract UserDictionarySelectFormAddText : string with get, set
override UserDictionarySelectFormAddText : string with get, set
Property Value
String


UserDictionarySelectFormCancelText Property

UserDictionarySelectFormCancelText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► WPFUserDictionarySelect ► UserDictionarySelectFormCancelText
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionarySelectFormCancelText { get; set; }
public string UserDictionarySelectFormCancelText { get; set; }
Public Property UserDictionarySelectFormCancelText As String
    Get
    Set
Public Property UserDictionarySelectFormCancelText As String
    Get
    Set
public:
virtual property String^ UserDictionarySelectFormCancelText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ UserDictionarySelectFormCancelText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract UserDictionarySelectFormCancelText : string with get, set
override UserDictionarySelectFormCancelText : string with get, set
abstract UserDictionarySelectFormCancelText : string with get, set
override UserDictionarySelectFormCancelText : string with get, set
Property Value
String


UserDictionarySelectFormChangeDefaultText Property

UserDictionarySelectFormChangeDefaultText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► WPFUserDictionarySelect ► UserDictionarySelectFormChangeDefaultText
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionarySelectFormChangeDefaultText { get; set; }
public string UserDictionarySelectFormChangeDefaultText { get; set; }
Public Property UserDictionarySelectFormChangeDefaultText As String
    Get
    Set
Public Property UserDictionarySelectFormChangeDefaultText As String
    Get
    Set
public:
virtual property String^ UserDictionarySelectFormChangeDefaultText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ UserDictionarySelectFormChangeDefaultText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract UserDictionarySelectFormChangeDefaultText : string with get, set
override UserDictionarySelectFormChangeDefaultText : string with get, set
abstract UserDictionarySelectFormChangeDefaultText : string with get, set
override UserDictionarySelectFormChangeDefaultText : string with get, set
Property Value
String


UserDictionarySelectFormEditText Property

UserDictionarySelectFormEditText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► WPFUserDictionarySelect ► UserDictionarySelectFormEditText
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionarySelectFormEditText { get; set; }
public string UserDictionarySelectFormEditText { get; set; }
Public Property UserDictionarySelectFormEditText As String
    Get
    Set
Public Property UserDictionarySelectFormEditText As String
    Get
    Set
public:
virtual property String^ UserDictionarySelectFormEditText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ UserDictionarySelectFormEditText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract UserDictionarySelectFormEditText : string with get, set
override UserDictionarySelectFormEditText : string with get, set
abstract UserDictionarySelectFormEditText : string with get, set
override UserDictionarySelectFormEditText : string with get, set
Property Value
String


UserDictionarySelectFormGroupBoxTitleText Property

UserDictionarySelectFormGroupBoxTitleText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► WPFUserDictionarySelect ► UserDictionarySelectFormGroupBoxTitleText
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionarySelectFormGroupBoxTitleText { get; set; }
public string UserDictionarySelectFormGroupBoxTitleText { get; set; }
Public Property UserDictionarySelectFormGroupBoxTitleText As String
    Get
    Set
Public Property UserDictionarySelectFormGroupBoxTitleText As String
    Get
    Set
public:
virtual property String^ UserDictionarySelectFormGroupBoxTitleText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ UserDictionarySelectFormGroupBoxTitleText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract UserDictionarySelectFormGroupBoxTitleText : string with get, set
override UserDictionarySelectFormGroupBoxTitleText : string with get, set
abstract UserDictionarySelectFormGroupBoxTitleText : string with get, set
override UserDictionarySelectFormGroupBoxTitleText : string with get, set
Property Value
String


UserDictionarySelectFormNewText Property

UserDictionarySelectFormNewText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► WPFUserDictionarySelect ► UserDictionarySelectFormNewText
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionarySelectFormNewText { get; set; }
public string UserDictionarySelectFormNewText { get; set; }
Public Property UserDictionarySelectFormNewText As String
    Get
    Set
Public Property UserDictionarySelectFormNewText As String
    Get
    Set
public:
virtual property String^ UserDictionarySelectFormNewText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ UserDictionarySelectFormNewText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract UserDictionarySelectFormNewText : string with get, set
override UserDictionarySelectFormNewText : string with get, set
abstract UserDictionarySelectFormNewText : string with get, set
override UserDictionarySelectFormNewText : string with get, set
Property Value
String


UserDictionarySelectFormOkText Property

UserDictionarySelectFormOkText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► WPFUserDictionarySelect ► UserDictionarySelectFormOkText
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionarySelectFormOkText { get; set; }
public string UserDictionarySelectFormOkText { get; set; }
Public Property UserDictionarySelectFormOkText As String
    Get
    Set
Public Property UserDictionarySelectFormOkText As String
    Get
    Set
public:
virtual property String^ UserDictionarySelectFormOkText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ UserDictionarySelectFormOkText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract UserDictionarySelectFormOkText : string with get, set
override UserDictionarySelectFormOkText : string with get, set
abstract UserDictionarySelectFormOkText : string with get, set
override UserDictionarySelectFormOkText : string with get, set
Property Value
String


UserDictionarySelectFormRemoveText Property

UserDictionarySelectFormRemoveText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► WPFUserDictionarySelect ► UserDictionarySelectFormRemoveText
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionarySelectFormRemoveText { get; set; }
public string UserDictionarySelectFormRemoveText { get; set; }
Public Property UserDictionarySelectFormRemoveText As String
    Get
    Set
Public Property UserDictionarySelectFormRemoveText As String
    Get
    Set
public:
virtual property String^ UserDictionarySelectFormRemoveText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ UserDictionarySelectFormRemoveText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract UserDictionarySelectFormRemoveText : string with get, set
override UserDictionarySelectFormRemoveText : string with get, set
abstract UserDictionarySelectFormRemoveText : string with get, set
override UserDictionarySelectFormRemoveText : string with get, set
Property Value
String


UserDictionarySelectFormTitleText Property

UserDictionarySelectFormTitleText Property
API ► Keyoti.RapidSpell.Wpf.DialogViews ► WPFUserDictionarySelect ► UserDictionarySelectFormTitleText
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserDictionarySelectFormTitleText { get; set; }
public string UserDictionarySelectFormTitleText { get; set; }
Public Property UserDictionarySelectFormTitleText As String
    Get
    Set
Public Property UserDictionarySelectFormTitleText As String
    Get
    Set
public:
virtual property String^ UserDictionarySelectFormTitleText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ UserDictionarySelectFormTitleText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract UserDictionarySelectFormTitleText : string with get, set
override UserDictionarySelectFormTitleText : string with get, set
abstract UserDictionarySelectFormTitleText : string with get, set
override UserDictionarySelectFormTitleText : string with get, set
Property Value
String


Keyoti.RapidSpell.Wpf.Event Namespace

Keyoti.RapidSpell.Wpf.Event Namespace
API ► Keyoti.RapidSpell.Wpf.Event
Keyoti RapidSpell WPF
The namespace for events.
Types
All Types Classes Delegates
Icon | Type | Description
 | ChangeWordEventArgs | Holds data for the ChangeWord event.
 | CreateDialogViewEventArgs | Event args for create IDialogView event
 | CreateDialogViewEventHandler | EventHandler delegate
 | CreateDialogViewOptionsEventArgs | Event args for create IDialogViewOptions event
 | CreateDialogViewOptionsEventHandler | EventHandler delegate
 | CreateDialogViewUserDictionaryEditEventArgs | Event args for create IDialogViewUserDictionaryEdit event
 | CreateDialogViewUserDictionaryEditEventHandler | EventHandler delegate
 | CreateDialogViewUserDictionarySelectEventArgs | Event args for create IDialogViewOptions event
 | CreateDialogViewUserDictionarySelectEventHandler | EventHandler delegate
 | CreateUserInterfaceFormPresenterEventArgs | Event args for create presenter event
 | CreateUserInterfaceFormPresenterEventHandler | EventHandler delegate
 | FoundSpellingErrorEventArgs | Event args for found error event
 | FoundSpellingErrorEventHandler | EventHandler delegate
 | SpellCheckEventArgs | Args for the events fired when RapidSpellGUI,RapidSpellDialog or RapidSpellAYT starts or stops.
 | SpellCheckEventHandler | Spell check event handler delegate.
 | SpellContextMenuEventArgs | Args for the events fired when the spell checkers context menu is requested.
 | TextBoxSpellCheckEventArgs | Args for the events fired when spell checking multiple text boxes.
 | UserQueryEventArgs | Event args for user query event
 | UserQueryEventHandler | EventHandler delegate
 | WordsEnteredEventArgs | Args for the events fired when words are entered into the text box.
 | WordsEnteredEventHandler | Handler delegate


ChangeWordEventArgs Class

ChangeWordEventArgs Class
API ► Keyoti.RapidSpell.Wpf.Event ► ChangeWordEventArgs
Keyoti RapidSpell WPF
Holds data for the ChangeWord event.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class ChangeWordEventArgs : EventArgs
public class ChangeWordEventArgs : EventArgs
Public Class ChangeWordEventArgs
    Inherits EventArgs
Public Class ChangeWordEventArgs
    Inherits EventArgs
public ref class ChangeWordEventArgs : public EventArgs
public ref class ChangeWordEventArgs : public EventArgs
type ChangeWordEventArgs =
    class
        inherit EventArgs
    end
type ChangeWordEventArgs =
    class
        inherit EventArgs
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ChangeWordEventArgs(String, String, Int32) | Creates a new ChangeWordEventArgs
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | Index | The index of the word in the text
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewWord | The new word
 | OldWord | The word being replaced
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | ChangeWordEventArgs


ChangeWordEventArgs Constructor (oldWord, newWord, index)

ChangeWordEventArgs Constructor (oldWord, newWord, index)
API ► Keyoti.RapidSpell.Wpf.Event ► ChangeWordEventArgs ► ChangeWordEventArgs(String, String, Int32)
Keyoti RapidSpell WPF
Creates a new ChangeWordEventArgs
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public ChangeWordEventArgs(
    string oldWord,
    string newWord,
    int index
)
public ChangeWordEventArgs(
    string oldWord,
    string newWord,
    int index
)
Public Sub New (
    oldWord As String,
    newWord As String,
    index As Integer
)
Public Sub New (
    oldWord As String,
    newWord As String,
    index As Integer
)
public:
ChangeWordEventArgs(
    String^ oldWord,
    String^ newWord,
    int index
)
public:
ChangeWordEventArgs(
    String^ oldWord,
    String^ newWord,
    int index
)
new :
        oldWord : string *
        newWord : string *
        index : int -> ChangeWordEventArgs
new :
        oldWord : string *
        newWord : string *
        index : int -> ChangeWordEventArgs
Parameters
oldWord (String)
newWord (String)
index (Int32)


Index Property

Index Property
API ► Keyoti.RapidSpell.Wpf.Event ► ChangeWordEventArgs ► Index
Keyoti RapidSpell WPF
The index of the word in the text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int Index { get; }
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get
Public ReadOnly Property Index As Integer
    Get
public:
property int Index {
    int get ();
}
public:
property int Index {
    int get ();
}
member Index : int with get

member Index : int with get
Property Value
Int32


NewWord Property

NewWord Property
API ► Keyoti.RapidSpell.Wpf.Event ► ChangeWordEventArgs ► NewWord
Keyoti RapidSpell WPF
The new word
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string NewWord { get; }
public string NewWord { get; }
Public ReadOnly Property NewWord As String
    Get
Public ReadOnly Property NewWord As String
    Get
public:
property String^ NewWord {
    String^ get ();
}
public:
property String^ NewWord {
    String^ get ();
}
member NewWord : string with get

member NewWord : string with get
Property Value
String


OldWord Property

OldWord Property
API ► Keyoti.RapidSpell.Wpf.Event ► ChangeWordEventArgs ► OldWord
Keyoti RapidSpell WPF
The word being replaced
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string OldWord { get; }
public string OldWord { get; }
Public ReadOnly Property OldWord As String
    Get
Public ReadOnly Property OldWord As String
    Get
public:
property String^ OldWord {
    String^ get ();
}
public:
property String^ OldWord {
    String^ get ();
}
member OldWord : string with get

member OldWord : string with get
Property Value
String


CreateDialogViewEventArgs Class

CreateDialogViewEventArgs Class
API ► Keyoti.RapidSpell.Wpf.Event ► CreateDialogViewEventArgs
Keyoti RapidSpell WPF
Event args for create IDialogView event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class CreateDialogViewEventArgs : EventArgs
public class CreateDialogViewEventArgs : EventArgs
Public Class CreateDialogViewEventArgs
    Inherits EventArgs
Public Class CreateDialogViewEventArgs
    Inherits EventArgs
public ref class CreateDialogViewEventArgs : public EventArgs
public ref class CreateDialogViewEventArgs : public EventArgs
type CreateDialogViewEventArgs =
    class
        inherit EventArgs
    end
type CreateDialogViewEventArgs =
    class
        inherit EventArgs
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CreateDialogViewEventArgs(IDialogView) | New
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewView | The new view to use
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | CreateDialogViewEventArgs


CreateDialogViewEventArgs Constructor (newView)

CreateDialogViewEventArgs Constructor (newView)
API ► Keyoti.RapidSpell.Wpf.Event ► CreateDialogViewEventArgs ► CreateDialogViewEventArgs(IDialogView)
Keyoti RapidSpell WPF
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public CreateDialogViewEventArgs(
    IDialogView newView
)
public CreateDialogViewEventArgs(
    IDialogView newView
)
Public Sub New (
    newView As IDialogView
)
Public Sub New (
    newView As IDialogView
)
public:
CreateDialogViewEventArgs(
    IDialogView^ newView
)
public:
CreateDialogViewEventArgs(
    IDialogView^ newView
)
new :
        newView : IDialogView -> CreateDialogViewEventArgs
new :
        newView : IDialogView -> CreateDialogViewEventArgs
Parameters
newView (IDialogView)


NewView Property

NewView Property
API ► Keyoti.RapidSpell.Wpf.Event ► CreateDialogViewEventArgs ► NewView
Keyoti RapidSpell WPF
The new view to use
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public IDialogView NewView { get; set; }
public IDialogView NewView { get; set; }
Public Property NewView As IDialogView
    Get
    Set
Public Property NewView As IDialogView
    Get
    Set
public:
property IDialogView^ NewView {
    IDialogView^ get ();
    void set (IDialogView^ value);
}
public:
property IDialogView^ NewView {
    IDialogView^ get ();
    void set (IDialogView^ value);
}
member NewView : IDialogView with get, set

member NewView : IDialogView with get, set
Property Value
IDialogView


CreateDialogViewEventHandler Delegate

CreateDialogViewEventHandler Delegate
API ► Keyoti.RapidSpell.Wpf.Event ► CreateDialogViewEventHandler
Keyoti RapidSpell WPF
EventHandler delegate
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void CreateDialogViewEventHandler(
    Object sender,
    CreateDialogViewEventArgs e
)
public delegate void CreateDialogViewEventHandler(
    Object sender,
    CreateDialogViewEventArgs e
)
Public Delegate Sub CreateDialogViewEventHandler (
    sender As Object,
    e As CreateDialogViewEventArgs
)
Public Delegate Sub CreateDialogViewEventHandler (
    sender As Object,
    e As CreateDialogViewEventArgs
)
public delegate void CreateDialogViewEventHandler(
    Object^ sender,
    CreateDialogViewEventArgs^ e
)
public delegate void CreateDialogViewEventHandler(
    Object^ sender,
    CreateDialogViewEventArgs^ e
)
type CreateDialogViewEventHandler =
    delegate of
        sender : Object *
        e : CreateDialogViewEventArgs -> unit
type CreateDialogViewEventHandler =
    delegate of
        sender : Object *
        e : CreateDialogViewEventArgs -> unit
Parameters
sender (Object)
e (CreateDialogViewEventArgs)


CreateDialogViewOptionsEventArgs Class

CreateDialogViewOptionsEventArgs Class
API ► Keyoti.RapidSpell.Wpf.Event ► CreateDialogViewOptionsEventArgs
Keyoti RapidSpell WPF
Event args for create IDialogViewOptions event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class CreateDialogViewOptionsEventArgs : EventArgs
public class CreateDialogViewOptionsEventArgs : EventArgs
Public Class CreateDialogViewOptionsEventArgs
    Inherits EventArgs
Public Class CreateDialogViewOptionsEventArgs
    Inherits EventArgs
public ref class CreateDialogViewOptionsEventArgs : public EventArgs
public ref class CreateDialogViewOptionsEventArgs : public EventArgs
type CreateDialogViewOptionsEventArgs =
    class
        inherit EventArgs
    end
type CreateDialogViewOptionsEventArgs =
    class
        inherit EventArgs
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CreateDialogViewOptionsEventArgs(IDialogViewOptions, UserOptions) | New
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewView | The new view to use
 | Options | The UserOptions instance in use by the view
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | CreateDialogViewOptionsEventArgs


CreateDialogViewOptionsEventArgs Constructor (newView, options)

CreateDialogViewOptionsEventArgs Constructor (newView, options)
API ► Keyoti.RapidSpell.Wpf.Event ► CreateDialogViewOptionsEventArgs ► CreateDialogViewOptionsEventArgs(IDialogViewOptions, UserOptions)
Keyoti RapidSpell WPF
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public CreateDialogViewOptionsEventArgs(
    IDialogViewOptions newView,
    UserOptions options
)
public CreateDialogViewOptionsEventArgs(
    IDialogViewOptions newView,
    UserOptions options
)
Public Sub New (
    newView As IDialogViewOptions,
    options As UserOptions
)
Public Sub New (
    newView As IDialogViewOptions,
    options As UserOptions
)
public:
CreateDialogViewOptionsEventArgs(
    IDialogViewOptions^ newView,
    UserOptions^ options
)
public:
CreateDialogViewOptionsEventArgs(
    IDialogViewOptions^ newView,
    UserOptions^ options
)
new :
        newView : IDialogViewOptions *
        options : UserOptions -> CreateDialogViewOptionsEventArgs
new :
        newView : IDialogViewOptions *
        options : UserOptions -> CreateDialogViewOptionsEventArgs
Parameters
newView (IDialogViewOptions)
options (UserOptions)


NewView Property

NewView Property
API ► Keyoti.RapidSpell.Wpf.Event ► CreateDialogViewOptionsEventArgs ► NewView
Keyoti RapidSpell WPF
The new view to use
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public IDialogViewOptions NewView { get; set; }
public IDialogViewOptions NewView { get; set; }
Public Property NewView As IDialogViewOptions
    Get
    Set
Public Property NewView As IDialogViewOptions
    Get
    Set
public:
property IDialogViewOptions^ NewView {
    IDialogViewOptions^ get ();
    void set (IDialogViewOptions^ value);
}
public:
property IDialogViewOptions^ NewView {
    IDialogViewOptions^ get ();
    void set (IDialogViewOptions^ value);
}
member NewView : IDialogViewOptions with get, set

member NewView : IDialogViewOptions with get, set
Property Value
IDialogViewOptions


Options Property

Options Property
API ► Keyoti.RapidSpell.Wpf.Event ► CreateDialogViewOptionsEventArgs ► Options
Keyoti RapidSpell WPF
The UserOptions instance in use by the view
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UserOptions Options { get; }
public UserOptions Options { get; }
Public ReadOnly Property Options As UserOptions
    Get
Public ReadOnly Property Options As UserOptions
    Get
public:
property UserOptions^ Options {
    UserOptions^ get ();
}
public:
property UserOptions^ Options {
    UserOptions^ get ();
}
member Options : UserOptions with get

member Options : UserOptions with get
Property Value
UserOptions


CreateDialogViewOptionsEventHandler Delegate

CreateDialogViewOptionsEventHandler Delegate
API ► Keyoti.RapidSpell.Wpf.Event ► CreateDialogViewOptionsEventHandler
Keyoti RapidSpell WPF
EventHandler delegate
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void CreateDialogViewOptionsEventHandler(
    Object sender,
    CreateDialogViewOptionsEventArgs e
)
public delegate void CreateDialogViewOptionsEventHandler(
    Object sender,
    CreateDialogViewOptionsEventArgs e
)
Public Delegate Sub CreateDialogViewOptionsEventHandler (
    sender As Object,
    e As CreateDialogViewOptionsEventArgs
)
Public Delegate Sub CreateDialogViewOptionsEventHandler (
    sender As Object,
    e As CreateDialogViewOptionsEventArgs
)
public delegate void CreateDialogViewOptionsEventHandler(
    Object^ sender,
    CreateDialogViewOptionsEventArgs^ e
)
public delegate void CreateDialogViewOptionsEventHandler(
    Object^ sender,
    CreateDialogViewOptionsEventArgs^ e
)
type CreateDialogViewOptionsEventHandler =
    delegate of
        sender : Object *
        e : CreateDialogViewOptionsEventArgs -> unit
type CreateDialogViewOptionsEventHandler =
    delegate of
        sender : Object *
        e : CreateDialogViewOptionsEventArgs -> unit
Parameters
sender (Object)
e (CreateDialogViewOptionsEventArgs)


CreateDialogViewUserDictionaryEditEventArgs Class

CreateDialogViewUserDictionaryEditEventArgs Class
API ► Keyoti.RapidSpell.Wpf.Event ► CreateDialogViewUserDictionaryEditEventArgs
Keyoti RapidSpell WPF
Event args for create IDialogViewUserDictionaryEdit event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class CreateDialogViewUserDictionaryEditEventArgs : EventArgs
public class CreateDialogViewUserDictionaryEditEventArgs : EventArgs
Public Class CreateDialogViewUserDictionaryEditEventArgs
    Inherits EventArgs
Public Class CreateDialogViewUserDictionaryEditEventArgs
    Inherits EventArgs
public ref class CreateDialogViewUserDictionaryEditEventArgs : public EventArgs
public ref class CreateDialogViewUserDictionaryEditEventArgs : public EventArgs
type CreateDialogViewUserDictionaryEditEventArgs =
    class
        inherit EventArgs
    end
type CreateDialogViewUserDictionaryEditEventArgs =
    class
        inherit EventArgs
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CreateDialogViewUserDictionaryEditEventArgs(IDialogViewUserDictionaryEdit) | New
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewView | The view to use
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | CreateDialogViewUserDictionaryEditEventArgs


CreateDialogViewUserDictionaryEditEventArgs Constructor (newView)

CreateDialogViewUserDictionaryEditEventArgs Constructor (newView)
API ► Keyoti.RapidSpell.Wpf.Event ► CreateDialogViewUserDictionaryEditEventArgs ► CreateDialogViewUserDictionaryEditEventArgs(IDialogViewUserDictionaryEdit)
Keyoti RapidSpell WPF
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public CreateDialogViewUserDictionaryEditEventArgs(
    IDialogViewUserDictionaryEdit newView
)
public CreateDialogViewUserDictionaryEditEventArgs(
    IDialogViewUserDictionaryEdit newView
)
Public Sub New (
    newView As IDialogViewUserDictionaryEdit
)
Public Sub New (
    newView As IDialogViewUserDictionaryEdit
)
public:
CreateDialogViewUserDictionaryEditEventArgs(
    IDialogViewUserDictionaryEdit^ newView
)
public:
CreateDialogViewUserDictionaryEditEventArgs(
    IDialogViewUserDictionaryEdit^ newView
)
new :
        newView : IDialogViewUserDictionaryEdit -> CreateDialogViewUserDictionaryEditEventArgs
new :
        newView : IDialogViewUserDictionaryEdit -> CreateDialogViewUserDictionaryEditEventArgs
Parameters
newView (IDialogViewUserDictionaryEdit)


NewView Property

NewView Property
API ► Keyoti.RapidSpell.Wpf.Event ► CreateDialogViewUserDictionaryEditEventArgs ► NewView
Keyoti RapidSpell WPF
The view to use
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public IDialogViewUserDictionaryEdit NewView { get; set; }
public IDialogViewUserDictionaryEdit NewView { get; set; }
Public Property NewView As IDialogViewUserDictionaryEdit
    Get
    Set
Public Property NewView As IDialogViewUserDictionaryEdit
    Get
    Set
public:
property IDialogViewUserDictionaryEdit^ NewView {
    IDialogViewUserDictionaryEdit^ get ();
    void set (IDialogViewUserDictionaryEdit^ value);
}
public:
property IDialogViewUserDictionaryEdit^ NewView {
    IDialogViewUserDictionaryEdit^ get ();
    void set (IDialogViewUserDictionaryEdit^ value);
}
member NewView : IDialogViewUserDictionaryEdit with get, set

member NewView : IDialogViewUserDictionaryEdit with get, set
Property Value
IDialogViewUserDictionaryEdit


CreateDialogViewUserDictionaryEditEventHandler Delegate

CreateDialogViewUserDictionaryEditEventHandler Delegate
API ► Keyoti.RapidSpell.Wpf.Event ► CreateDialogViewUserDictionaryEditEventHandler
Keyoti RapidSpell WPF
EventHandler delegate
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void CreateDialogViewUserDictionaryEditEventHandler(
    Object sender,
    CreateDialogViewUserDictionaryEditEventArgs e
)
public delegate void CreateDialogViewUserDictionaryEditEventHandler(
    Object sender,
    CreateDialogViewUserDictionaryEditEventArgs e
)
Public Delegate Sub CreateDialogViewUserDictionaryEditEventHandler (
    sender As Object,
    e As CreateDialogViewUserDictionaryEditEventArgs
)
Public Delegate Sub CreateDialogViewUserDictionaryEditEventHandler (
    sender As Object,
    e As CreateDialogViewUserDictionaryEditEventArgs
)
public delegate void CreateDialogViewUserDictionaryEditEventHandler(
    Object^ sender,
    CreateDialogViewUserDictionaryEditEventArgs^ e
)
public delegate void CreateDialogViewUserDictionaryEditEventHandler(
    Object^ sender,
    CreateDialogViewUserDictionaryEditEventArgs^ e
)
type CreateDialogViewUserDictionaryEditEventHandler =
    delegate of
        sender : Object *
        e : CreateDialogViewUserDictionaryEditEventArgs -> unit
type CreateDialogViewUserDictionaryEditEventHandler =
    delegate of
        sender : Object *
        e : CreateDialogViewUserDictionaryEditEventArgs -> unit
Parameters
sender (Object)
e (CreateDialogViewUserDictionaryEditEventArgs)


CreateDialogViewUserDictionarySelectEventArgs Class

CreateDialogViewUserDictionarySelectEventArgs Class
API ► Keyoti.RapidSpell.Wpf.Event ► CreateDialogViewUserDictionarySelectEventArgs
Keyoti RapidSpell WPF
Event args for create IDialogViewOptions event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class CreateDialogViewUserDictionarySelectEventArgs : EventArgs
public class CreateDialogViewUserDictionarySelectEventArgs : EventArgs
Public Class CreateDialogViewUserDictionarySelectEventArgs
    Inherits EventArgs
Public Class CreateDialogViewUserDictionarySelectEventArgs
    Inherits EventArgs
public ref class CreateDialogViewUserDictionarySelectEventArgs : public EventArgs
public ref class CreateDialogViewUserDictionarySelectEventArgs : public EventArgs
type CreateDialogViewUserDictionarySelectEventArgs =
    class
        inherit EventArgs
    end
type CreateDialogViewUserDictionarySelectEventArgs =
    class
        inherit EventArgs
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CreateDialogViewUserDictionarySelectEventArgs(IDialogViewUserDictionarySelect) | New
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewView | The new view to use
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | CreateDialogViewUserDictionarySelectEventArgs


CreateDialogViewUserDictionarySelectEventArgs Constructor (newView)

CreateDialogViewUserDictionarySelectEventArgs Constructor (newView)
API ► Keyoti.RapidSpell.Wpf.Event ► CreateDialogViewUserDictionarySelectEventArgs ► CreateDialogViewUserDictionarySelectEventArgs(IDialogViewUserDictionarySelect)
Keyoti RapidSpell WPF
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public CreateDialogViewUserDictionarySelectEventArgs(
    IDialogViewUserDictionarySelect newView
)
public CreateDialogViewUserDictionarySelectEventArgs(
    IDialogViewUserDictionarySelect newView
)
Public Sub New (
    newView As IDialogViewUserDictionarySelect
)
Public Sub New (
    newView As IDialogViewUserDictionarySelect
)
public:
CreateDialogViewUserDictionarySelectEventArgs(
    IDialogViewUserDictionarySelect^ newView
)
public:
CreateDialogViewUserDictionarySelectEventArgs(
    IDialogViewUserDictionarySelect^ newView
)
new :
        newView : IDialogViewUserDictionarySelect -> CreateDialogViewUserDictionarySelectEventArgs
new :
        newView : IDialogViewUserDictionarySelect -> CreateDialogViewUserDictionarySelectEventArgs
Parameters
newView (IDialogViewUserDictionarySelect)


NewView Property

NewView Property
API ► Keyoti.RapidSpell.Wpf.Event ► CreateDialogViewUserDictionarySelectEventArgs ► NewView
Keyoti RapidSpell WPF
The new view to use
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public IDialogViewUserDictionarySelect NewView { get; set; }
public IDialogViewUserDictionarySelect NewView { get; set; }
Public Property NewView As IDialogViewUserDictionarySelect
    Get
    Set
Public Property NewView As IDialogViewUserDictionarySelect
    Get
    Set
public:
property IDialogViewUserDictionarySelect^ NewView {
    IDialogViewUserDictionarySelect^ get ();
    void set (IDialogViewUserDictionarySelect^ value);
}
public:
property IDialogViewUserDictionarySelect^ NewView {
    IDialogViewUserDictionarySelect^ get ();
    void set (IDialogViewUserDictionarySelect^ value);
}
member NewView : IDialogViewUserDictionarySelect with get, set

member NewView : IDialogViewUserDictionarySelect with get, set
Property Value
IDialogViewUserDictionarySelect


CreateDialogViewUserDictionarySelectEventHandler Delegate

CreateDialogViewUserDictionarySelectEventHandler Delegate
API ► Keyoti.RapidSpell.Wpf.Event ► CreateDialogViewUserDictionarySelectEventHandler
Keyoti RapidSpell WPF
EventHandler delegate
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void CreateDialogViewUserDictionarySelectEventHandler(
    Object sender,
    CreateDialogViewUserDictionarySelectEventArgs e
)
public delegate void CreateDialogViewUserDictionarySelectEventHandler(
    Object sender,
    CreateDialogViewUserDictionarySelectEventArgs e
)
Public Delegate Sub CreateDialogViewUserDictionarySelectEventHandler (
    sender As Object,
    e As CreateDialogViewUserDictionarySelectEventArgs
)
Public Delegate Sub CreateDialogViewUserDictionarySelectEventHandler (
    sender As Object,
    e As CreateDialogViewUserDictionarySelectEventArgs
)
public delegate void CreateDialogViewUserDictionarySelectEventHandler(
    Object^ sender,
    CreateDialogViewUserDictionarySelectEventArgs^ e
)
public delegate void CreateDialogViewUserDictionarySelectEventHandler(
    Object^ sender,
    CreateDialogViewUserDictionarySelectEventArgs^ e
)
type CreateDialogViewUserDictionarySelectEventHandler =
    delegate of
        sender : Object *
        e : CreateDialogViewUserDictionarySelectEventArgs -> unit
type CreateDialogViewUserDictionarySelectEventHandler =
    delegate of
        sender : Object *
        e : CreateDialogViewUserDictionarySelectEventArgs -> unit
Parameters
sender (Object)
e (CreateDialogViewUserDictionarySelectEventArgs)


CreateUserInterfaceFormPresenterEventArgs Class

CreateUserInterfaceFormPresenterEventArgs Class
API ► Keyoti.RapidSpell.Wpf.Event ► CreateUserInterfaceFormPresenterEventArgs
Keyoti RapidSpell WPF
Event args for create presenter event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class CreateUserInterfaceFormPresenterEventArgs : EventArgs
public class CreateUserInterfaceFormPresenterEventArgs : EventArgs
Public Class CreateUserInterfaceFormPresenterEventArgs
    Inherits EventArgs
Public Class CreateUserInterfaceFormPresenterEventArgs
    Inherits EventArgs
public ref class CreateUserInterfaceFormPresenterEventArgs : public EventArgs
public ref class CreateUserInterfaceFormPresenterEventArgs : public EventArgs
type CreateUserInterfaceFormPresenterEventArgs =
    class
        inherit EventArgs
    end
type CreateUserInterfaceFormPresenterEventArgs =
    class
        inherit EventArgs
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CreateUserInterfaceFormPresenterEventArgs(IUserInterfaceFormPresenter) | New
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewPresenter | The presenter to use
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | CreateUserInterfaceFormPresenterEventArgs


CreateUserInterfaceFormPresenterEventArgs Constructor (newPresenter)

CreateUserInterfaceFormPresenterEventArgs Constructor (newPresenter)
API ► Keyoti.RapidSpell.Wpf.Event ► CreateUserInterfaceFormPresenterEventArgs ► CreateUserInterfaceFormPresenterEventArgs(IUserInterfaceFormPresenter)
Keyoti RapidSpell WPF
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public CreateUserInterfaceFormPresenterEventArgs(
    IUserInterfaceFormPresenter newPresenter
)
public CreateUserInterfaceFormPresenterEventArgs(
    IUserInterfaceFormPresenter newPresenter
)
Public Sub New (
    newPresenter As IUserInterfaceFormPresenter
)
Public Sub New (
    newPresenter As IUserInterfaceFormPresenter
)
public:
CreateUserInterfaceFormPresenterEventArgs(
    IUserInterfaceFormPresenter^ newPresenter
)
public:
CreateUserInterfaceFormPresenterEventArgs(
    IUserInterfaceFormPresenter^ newPresenter
)
new :
        newPresenter : IUserInterfaceFormPresenter -> CreateUserInterfaceFormPresenterEventArgs
new :
        newPresenter : IUserInterfaceFormPresenter -> CreateUserInterfaceFormPresenterEventArgs
Parameters
newPresenter (IUserInterfaceFormPresenter)


NewPresenter Property

NewPresenter Property
API ► Keyoti.RapidSpell.Wpf.Event ► CreateUserInterfaceFormPresenterEventArgs ► NewPresenter
Keyoti RapidSpell WPF
The presenter to use
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public IUserInterfaceFormPresenter NewPresenter { get; set; }
public IUserInterfaceFormPresenter NewPresenter { get; set; }
Public Property NewPresenter As IUserInterfaceFormPresenter
    Get
    Set
Public Property NewPresenter As IUserInterfaceFormPresenter
    Get
    Set
public:
property IUserInterfaceFormPresenter^ NewPresenter {
    IUserInterfaceFormPresenter^ get ();
    void set (IUserInterfaceFormPresenter^ value);
}
public:
property IUserInterfaceFormPresenter^ NewPresenter {
    IUserInterfaceFormPresenter^ get ();
    void set (IUserInterfaceFormPresenter^ value);
}
member NewPresenter : IUserInterfaceFormPresenter with get, set

member NewPresenter : IUserInterfaceFormPresenter with get, set
Property Value
IUserInterfaceFormPresenter


CreateUserInterfaceFormPresenterEventHandler Delegate

CreateUserInterfaceFormPresenterEventHandler Delegate
API ► Keyoti.RapidSpell.Wpf.Event ► CreateUserInterfaceFormPresenterEventHandler
Keyoti RapidSpell WPF
EventHandler delegate
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void CreateUserInterfaceFormPresenterEventHandler(
    Object s,
    CreateUserInterfaceFormPresenterEventArgs e
)
public delegate void CreateUserInterfaceFormPresenterEventHandler(
    Object s,
    CreateUserInterfaceFormPresenterEventArgs e
)
Public Delegate Sub CreateUserInterfaceFormPresenterEventHandler (
    s As Object,
    e As CreateUserInterfaceFormPresenterEventArgs
)
Public Delegate Sub CreateUserInterfaceFormPresenterEventHandler (
    s As Object,
    e As CreateUserInterfaceFormPresenterEventArgs
)
public delegate void CreateUserInterfaceFormPresenterEventHandler(
    Object^ s,
    CreateUserInterfaceFormPresenterEventArgs^ e
)
public delegate void CreateUserInterfaceFormPresenterEventHandler(
    Object^ s,
    CreateUserInterfaceFormPresenterEventArgs^ e
)
type CreateUserInterfaceFormPresenterEventHandler =
    delegate of
        s : Object *
        e : CreateUserInterfaceFormPresenterEventArgs -> unit
type CreateUserInterfaceFormPresenterEventHandler =
    delegate of
        s : Object *
        e : CreateUserInterfaceFormPresenterEventArgs -> unit
Parameters
s (Object)
e (CreateUserInterfaceFormPresenterEventArgs)


FoundSpellingErrorEventArgs Class

FoundSpellingErrorEventArgs Class
API ► Keyoti.RapidSpell.Wpf.Event ► FoundSpellingErrorEventArgs
Keyoti RapidSpell WPF
Event args for found error event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class FoundSpellingErrorEventArgs : EventArgs
public class FoundSpellingErrorEventArgs : EventArgs
Public Class FoundSpellingErrorEventArgs
    Inherits EventArgs
Public Class FoundSpellingErrorEventArgs
    Inherits EventArgs
public ref class FoundSpellingErrorEventArgs : public EventArgs
public ref class FoundSpellingErrorEventArgs : public EventArgs
type FoundSpellingErrorEventArgs =
    class
        inherit EventArgs
    end
type FoundSpellingErrorEventArgs =
    class
        inherit EventArgs
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FoundSpellingErrorEventArgs(BadWord, IAYTTextBox) | New
 | BadWord | The misspelling
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Replacement | Any replacement to use for the misspelling, only used by RapidSpellAsYouType
 | TextBox | The textbox being checked
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | FoundSpellingErrorEventArgs


FoundSpellingErrorEventArgs Constructor (theBadWord, textBox)

FoundSpellingErrorEventArgs Constructor (theBadWord, textBox)
API ► Keyoti.RapidSpell.Wpf.Event ► FoundSpellingErrorEventArgs ► FoundSpellingErrorEventArgs(BadWord, IAYTTextBox)
Keyoti RapidSpell WPF
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public FoundSpellingErrorEventArgs(
    BadWord theBadWord,
    IAYTTextBox textBox
)
public FoundSpellingErrorEventArgs(
    BadWord theBadWord,
    IAYTTextBox textBox
)
Public Sub New (
    theBadWord As BadWord,
    textBox As IAYTTextBox
)
Public Sub New (
    theBadWord As BadWord,
    textBox As IAYTTextBox
)
public:
FoundSpellingErrorEventArgs(
    BadWord^ theBadWord,
    IAYTTextBox^ textBox
)
public:
FoundSpellingErrorEventArgs(
    BadWord^ theBadWord,
    IAYTTextBox^ textBox
)
new :
        theBadWord : BadWord *
        textBox : IAYTTextBox -> FoundSpellingErrorEventArgs
new :
        theBadWord : BadWord *
        textBox : IAYTTextBox -> FoundSpellingErrorEventArgs
Parameters
theBadWord (BadWord)
textBox (IAYTTextBox)


BadWord Property

BadWord Property
API ► Keyoti.RapidSpell.Wpf.Event ► FoundSpellingErrorEventArgs ► BadWord
Keyoti RapidSpell WPF
The misspelling
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public BadWord BadWord { get; set; }
public BadWord BadWord { get; set; }
Public Property BadWord As BadWord
    Get
    Set
Public Property BadWord As BadWord
    Get
    Set
public:
property BadWord^ BadWord {
    BadWord^ get ();
    void set (BadWord^ value);
}
public:
property BadWord^ BadWord {
    BadWord^ get ();
    void set (BadWord^ value);
}
member BadWord : BadWord with get, set

member BadWord : BadWord with get, set
Property Value
BadWord


Replacement Property

Replacement Property
API ► Keyoti.RapidSpell.Wpf.Event ► FoundSpellingErrorEventArgs ► Replacement
Keyoti RapidSpell WPF
Any replacement to use for the misspelling, only used by RapidSpellAsYouType
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string Replacement { get; set; }
public string Replacement { get; set; }
Public Property Replacement As String
    Get
    Set
Public Property Replacement As String
    Get
    Set
public:
property String^ Replacement {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Replacement {
    String^ get ();
    void set (String^ value);
}
member Replacement : string with get, set

member Replacement : string with get, set
Property Value
String


TextBox Property

TextBox Property
API ► Keyoti.RapidSpell.Wpf.Event ► FoundSpellingErrorEventArgs ► TextBox
Keyoti RapidSpell WPF
The textbox being checked
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public IAYTTextBox TextBox { get; }
public IAYTTextBox TextBox { get; }
Public ReadOnly Property TextBox As IAYTTextBox
    Get
Public ReadOnly Property TextBox As IAYTTextBox
    Get
public:
property IAYTTextBox^ TextBox {
    IAYTTextBox^ get ();
}
public:
property IAYTTextBox^ TextBox {
    IAYTTextBox^ get ();
}
member TextBox : IAYTTextBox with get

member TextBox : IAYTTextBox with get
Property Value
IAYTTextBox


FoundSpellingErrorEventHandler Delegate

FoundSpellingErrorEventHandler Delegate
API ► Keyoti.RapidSpell.Wpf.Event ► FoundSpellingErrorEventHandler
Keyoti RapidSpell WPF
EventHandler delegate
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void FoundSpellingErrorEventHandler(
    Object s,
    FoundSpellingErrorEventArgs e
)
public delegate void FoundSpellingErrorEventHandler(
    Object s,
    FoundSpellingErrorEventArgs e
)
Public Delegate Sub FoundSpellingErrorEventHandler (
    s As Object,
    e As FoundSpellingErrorEventArgs
)
Public Delegate Sub FoundSpellingErrorEventHandler (
    s As Object,
    e As FoundSpellingErrorEventArgs
)
public delegate void FoundSpellingErrorEventHandler(
    Object^ s,
    FoundSpellingErrorEventArgs^ e
)
public delegate void FoundSpellingErrorEventHandler(
    Object^ s,
    FoundSpellingErrorEventArgs^ e
)
type FoundSpellingErrorEventHandler =
    delegate of
        s : Object *
        e : FoundSpellingErrorEventArgs -> unit
type FoundSpellingErrorEventHandler =
    delegate of
        s : Object *
        e : FoundSpellingErrorEventArgs -> unit
Parameters
s (Object)
e (FoundSpellingErrorEventArgs)


SpellCheckEventArgs Class

SpellCheckEventArgs Class
API ► Keyoti.RapidSpell.Wpf.Event ► SpellCheckEventArgs
Keyoti RapidSpell WPF
Args for the events fired when RapidSpellGUI,RapidSpellDialog or RapidSpellAYT starts or stops.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class SpellCheckEventArgs : EventArgs
public class SpellCheckEventArgs : EventArgs
Public Class SpellCheckEventArgs
    Inherits EventArgs
Public Class SpellCheckEventArgs
    Inherits EventArgs
public ref class SpellCheckEventArgs : public EventArgs
public ref class SpellCheckEventArgs : public EventArgs
type SpellCheckEventArgs =
    class
        inherit EventArgs
    end
type SpellCheckEventArgs =
    class
        inherit EventArgs
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SpellCheckEventArgs()()()() |
 | SpellCheckEventArgs(Boolean) |
 | Cancelled | Whether the spell check was cancelled.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | SpellCheckEventArgs


SpellCheckEventArgs Constructor

SpellCheckEventArgs Constructor
API ► Keyoti.RapidSpell.Wpf.Event ► SpellCheckEventArgs ► SpellCheckEventArgs()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | SpellCheckEventArgs()()()() |
 | SpellCheckEventArgs(Boolean) |


SpellCheckEventArgs Constructor

SpellCheckEventArgs Constructor
API ► Keyoti.RapidSpell.Wpf.Event ► SpellCheckEventArgs ► SpellCheckEventArgs()()()()
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public SpellCheckEventArgs()
public SpellCheckEventArgs()
Public Sub New
Public Sub New
public:
SpellCheckEventArgs()
public:
SpellCheckEventArgs()
new : unit -> SpellCheckEventArgs
new : unit -> SpellCheckEventArgs


SpellCheckEventArgs Constructor (cancelled)

SpellCheckEventArgs Constructor (cancelled)
API ► Keyoti.RapidSpell.Wpf.Event ► SpellCheckEventArgs ► SpellCheckEventArgs(Boolean)
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public SpellCheckEventArgs(
    bool cancelled
)
public SpellCheckEventArgs(
    bool cancelled
)
Public Sub New (
    cancelled As Boolean
)
Public Sub New (
    cancelled As Boolean
)
public:
SpellCheckEventArgs(
    bool cancelled
)
public:
SpellCheckEventArgs(
    bool cancelled
)
new :
        cancelled : bool -> SpellCheckEventArgs
new :
        cancelled : bool -> SpellCheckEventArgs
Parameters
cancelled (Boolean)


Cancelled Property

Cancelled Property
API ► Keyoti.RapidSpell.Wpf.Event ► SpellCheckEventArgs ► Cancelled
Keyoti RapidSpell WPF
Whether the spell check was cancelled.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool Cancelled { get; }
public bool Cancelled { get; }
Public ReadOnly Property Cancelled As Boolean
    Get
Public ReadOnly Property Cancelled As Boolean
    Get
public:
property bool Cancelled {
    bool get ();
}
public:
property bool Cancelled {
    bool get ();
}
member Cancelled : bool with get

member Cancelled : bool with get
Property Value
Boolean


SpellCheckEventHandler Delegate

SpellCheckEventHandler Delegate
API ► Keyoti.RapidSpell.Wpf.Event ► SpellCheckEventHandler
Keyoti RapidSpell WPF
Spell check event handler delegate.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void SpellCheckEventHandler(
    Object sender,
    SpellCheckEventArgs e
)
public delegate void SpellCheckEventHandler(
    Object sender,
    SpellCheckEventArgs e
)
Public Delegate Sub SpellCheckEventHandler (
    sender As Object,
    e As SpellCheckEventArgs
)
Public Delegate Sub SpellCheckEventHandler (
    sender As Object,
    e As SpellCheckEventArgs
)
public delegate void SpellCheckEventHandler(
    Object^ sender,
    SpellCheckEventArgs^ e
)
public delegate void SpellCheckEventHandler(
    Object^ sender,
    SpellCheckEventArgs^ e
)
type SpellCheckEventHandler =
    delegate of
        sender : Object *
        e : SpellCheckEventArgs -> unit
type SpellCheckEventHandler =
    delegate of
        sender : Object *
        e : SpellCheckEventArgs -> unit
Parameters
sender (Object)
e (SpellCheckEventArgs)


SpellContextMenuEventArgs Class

SpellContextMenuEventArgs Class
API ► Keyoti.RapidSpell.Wpf.Event ► SpellContextMenuEventArgs
Keyoti RapidSpell WPF
Args for the events fired when the spell checkers context menu is requested.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class SpellContextMenuEventArgs : EventArgs
public class SpellContextMenuEventArgs : EventArgs
Public Class SpellContextMenuEventArgs
    Inherits EventArgs
Public Class SpellContextMenuEventArgs
    Inherits EventArgs
public ref class SpellContextMenuEventArgs : public EventArgs
public ref class SpellContextMenuEventArgs : public EventArgs
type SpellContextMenuEventArgs =
    class
        inherit EventArgs
    end
type SpellContextMenuEventArgs =
    class
        inherit EventArgs
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SpellContextMenuEventArgs(IList, Int32, Int32, Int32) | New
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MenuItems | List of menu items with suggestions, ignore and add options.
 | RightClickCharIndex | Character index where right click was made.
 | RightClickWordEnd | End index of word right clicked on.
 | RightClickWordStart | Start index of word right clicked on.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Remarks
Contains menu items so that they maybe shown in a different menu/contextmenu.
Inheritance Hierarchy
Object
 | EventArgs
 |  | SpellContextMenuEventArgs


SpellContextMenuEventArgs Constructor (menuItems, charIndex, rwordStart, rwordEnd)

SpellContextMenuEventArgs Constructor (menuItems, charIndex, rwordStart, rwordEnd)
API ► Keyoti.RapidSpell.Wpf.Event ► SpellContextMenuEventArgs ► SpellContextMenuEventArgs(IList, Int32, Int32, Int32)
Keyoti RapidSpell WPF
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public SpellContextMenuEventArgs(
    IList menuItems,
    int charIndex,
    int rwordStart,
    int rwordEnd
)
public SpellContextMenuEventArgs(
    IList menuItems,
    int charIndex,
    int rwordStart,
    int rwordEnd
)
Public Sub New (
    menuItems As IList,
    charIndex As Integer,
    rwordStart As Integer,
    rwordEnd As Integer
)
Public Sub New (
    menuItems As IList,
    charIndex As Integer,
    rwordStart As Integer,
    rwordEnd As Integer
)
public:
SpellContextMenuEventArgs(
    IList^ menuItems,
    int charIndex,
    int rwordStart,
    int rwordEnd
)
public:
SpellContextMenuEventArgs(
    IList^ menuItems,
    int charIndex,
    int rwordStart,
    int rwordEnd
)
new :
        menuItems : IList *
        charIndex : int *
        rwordStart : int *
        rwordEnd : int -> SpellContextMenuEventArgs
new :
        menuItems : IList *
        charIndex : int *
        rwordStart : int *
        rwordEnd : int -> SpellContextMenuEventArgs
Parameters
menuItems (IList)
charIndex (Int32)
rwordStart (Int32)
rwordEnd (Int32)


MenuItems Property

MenuItems Property
API ► Keyoti.RapidSpell.Wpf.Event ► SpellContextMenuEventArgs ► MenuItems
Keyoti RapidSpell WPF
List of menu items with suggestions, ignore and add options.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public IList MenuItems { get; }
public IList MenuItems { get; }
Public ReadOnly Property MenuItems As IList
    Get
Public ReadOnly Property MenuItems As IList
    Get
public:
property IList^ MenuItems {
    IList^ get ();
}
public:
property IList^ MenuItems {
    IList^ get ();
}
member MenuItems : IList with get

member MenuItems : IList with get
Property Value
IList


RightClickCharIndex Property

RightClickCharIndex Property
API ► Keyoti.RapidSpell.Wpf.Event ► SpellContextMenuEventArgs ► RightClickCharIndex
Keyoti RapidSpell WPF
Character index where right click was made.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int RightClickCharIndex { get; }
public int RightClickCharIndex { get; }
Public ReadOnly Property RightClickCharIndex As Integer
    Get
Public ReadOnly Property RightClickCharIndex As Integer
    Get
public:
property int RightClickCharIndex {
    int get ();
}
public:
property int RightClickCharIndex {
    int get ();
}
member RightClickCharIndex : int with get

member RightClickCharIndex : int with get
Property Value
Int32


RightClickWordEnd Property

RightClickWordEnd Property
API ► Keyoti.RapidSpell.Wpf.Event ► SpellContextMenuEventArgs ► RightClickWordEnd
Keyoti RapidSpell WPF
End index of word right clicked on.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int RightClickWordEnd { get; }
public int RightClickWordEnd { get; }
Public ReadOnly Property RightClickWordEnd As Integer
    Get
Public ReadOnly Property RightClickWordEnd As Integer
    Get
public:
property int RightClickWordEnd {
    int get ();
}
public:
property int RightClickWordEnd {
    int get ();
}
member RightClickWordEnd : int with get

member RightClickWordEnd : int with get
Property Value
Int32


RightClickWordStart Property

RightClickWordStart Property
API ► Keyoti.RapidSpell.Wpf.Event ► SpellContextMenuEventArgs ► RightClickWordStart
Keyoti RapidSpell WPF
Start index of word right clicked on.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int RightClickWordStart { get; }
public int RightClickWordStart { get; }
Public ReadOnly Property RightClickWordStart As Integer
    Get
Public ReadOnly Property RightClickWordStart As Integer
    Get
public:
property int RightClickWordStart {
    int get ();
}
public:
property int RightClickWordStart {
    int get ();
}
member RightClickWordStart : int with get

member RightClickWordStart : int with get
Property Value
Int32


TextBoxSpellCheckEventArgs Class

TextBoxSpellCheckEventArgs Class
API ► Keyoti.RapidSpell.Wpf.Event ► TextBoxSpellCheckEventArgs
Keyoti RapidSpell WPF
Args for the events fired when spell checking multiple text boxes.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class TextBoxSpellCheckEventArgs : EventArgs
public class TextBoxSpellCheckEventArgs : EventArgs
Public Class TextBoxSpellCheckEventArgs
    Inherits EventArgs
Public Class TextBoxSpellCheckEventArgs
    Inherits EventArgs
public ref class TextBoxSpellCheckEventArgs : public EventArgs
public ref class TextBoxSpellCheckEventArgs : public EventArgs
type TextBoxSpellCheckEventArgs =
    class
        inherit EventArgs
    end
type TextBoxSpellCheckEventArgs =
    class
        inherit EventArgs
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TextBoxSpellCheckEventArgs(Int32) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TextBoxIndex | The related text box index, this corresponds to the array of ISpellCheckableTextComponents that has been set for checking (0 for single text box checks).
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | TextBoxSpellCheckEventArgs


TextBoxSpellCheckEventArgs Constructor (textBoxIndex)

TextBoxSpellCheckEventArgs Constructor (textBoxIndex)
API ► Keyoti.RapidSpell.Wpf.Event ► TextBoxSpellCheckEventArgs ► TextBoxSpellCheckEventArgs(Int32)
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public TextBoxSpellCheckEventArgs(
    int textBoxIndex
)
public TextBoxSpellCheckEventArgs(
    int textBoxIndex
)
Public Sub New (
    textBoxIndex As Integer
)
Public Sub New (
    textBoxIndex As Integer
)
public:
TextBoxSpellCheckEventArgs(
    int textBoxIndex
)
public:
TextBoxSpellCheckEventArgs(
    int textBoxIndex
)
new :
        textBoxIndex : int -> TextBoxSpellCheckEventArgs
new :
        textBoxIndex : int -> TextBoxSpellCheckEventArgs
Parameters
textBoxIndex (Int32)


TextBoxIndex Property

TextBoxIndex Property
API ► Keyoti.RapidSpell.Wpf.Event ► TextBoxSpellCheckEventArgs ► TextBoxIndex
Keyoti RapidSpell WPF
The related text box index, this corresponds to the array of ISpellCheckableTextComponents that has been set for checking (0 for single text box checks).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int TextBoxIndex { get; }
public int TextBoxIndex { get; }
Public ReadOnly Property TextBoxIndex As Integer
    Get
Public ReadOnly Property TextBoxIndex As Integer
    Get
public:
property int TextBoxIndex {
    int get ();
}
public:
property int TextBoxIndex {
    int get ();
}
member TextBoxIndex : int with get

member TextBoxIndex : int with get
Property Value
Int32


UserQueryEventArgs Class

UserQueryEventArgs Class
API ► Keyoti.RapidSpell.Wpf.Event ► UserQueryEventArgs
Keyoti RapidSpell WPF
Event args for user query event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class UserQueryEventArgs : EventArgs
public class UserQueryEventArgs : EventArgs
Public Class UserQueryEventArgs
    Inherits EventArgs
Public Class UserQueryEventArgs
    Inherits EventArgs
public ref class UserQueryEventArgs : public EventArgs
public ref class UserQueryEventArgs : public EventArgs
type UserQueryEventArgs =
    class
        inherit EventArgs
    end
type UserQueryEventArgs =
    class
        inherit EventArgs
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserQueryEventArgs(BadWord, Object) | New
 | BadWord | The misspelling
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TextBox | The textbox being checked
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | UserQueryEventArgs


UserQueryEventArgs Constructor (theBadWord, textBox)

UserQueryEventArgs Constructor (theBadWord, textBox)
API ► Keyoti.RapidSpell.Wpf.Event ► UserQueryEventArgs ► UserQueryEventArgs(BadWord, Object)
Keyoti RapidSpell WPF
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UserQueryEventArgs(
    BadWord theBadWord,
    Object textBox
)
public UserQueryEventArgs(
    BadWord theBadWord,
    Object textBox
)
Public Sub New (
    theBadWord As BadWord,
    textBox As Object
)
Public Sub New (
    theBadWord As BadWord,
    textBox As Object
)
public:
UserQueryEventArgs(
    BadWord^ theBadWord,
    Object^ textBox
)
public:
UserQueryEventArgs(
    BadWord^ theBadWord,
    Object^ textBox
)
new :
        theBadWord : BadWord *
        textBox : Object -> UserQueryEventArgs
new :
        theBadWord : BadWord *
        textBox : Object -> UserQueryEventArgs
Parameters
theBadWord (BadWord)
textBox (Object)


BadWord Property

BadWord Property
API ► Keyoti.RapidSpell.Wpf.Event ► UserQueryEventArgs ► BadWord
Keyoti RapidSpell WPF
The misspelling
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public BadWord BadWord { get; set; }
public BadWord BadWord { get; set; }
Public Property BadWord As BadWord
    Get
    Set
Public Property BadWord As BadWord
    Get
    Set
public:
property BadWord^ BadWord {
    BadWord^ get ();
    void set (BadWord^ value);
}
public:
property BadWord^ BadWord {
    BadWord^ get ();
    void set (BadWord^ value);
}
member BadWord : BadWord with get, set

member BadWord : BadWord with get, set
Property Value
BadWord


TextBox Property

TextBox Property
API ► Keyoti.RapidSpell.Wpf.Event ► UserQueryEventArgs ► TextBox
Keyoti RapidSpell WPF
The textbox being checked
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Object TextBox { get; }
public Object TextBox { get; }
Public ReadOnly Property TextBox As Object
    Get
Public ReadOnly Property TextBox As Object
    Get
public:
property Object^ TextBox {
    Object^ get ();
}
public:
property Object^ TextBox {
    Object^ get ();
}
member TextBox : Object with get

member TextBox : Object with get
Property Value
Object


UserQueryEventHandler Delegate

UserQueryEventHandler Delegate
API ► Keyoti.RapidSpell.Wpf.Event ► UserQueryEventHandler
Keyoti RapidSpell WPF
EventHandler delegate
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void UserQueryEventHandler(
    Object s,
    UserQueryEventArgs e
)
public delegate void UserQueryEventHandler(
    Object s,
    UserQueryEventArgs e
)
Public Delegate Sub UserQueryEventHandler (
    s As Object,
    e As UserQueryEventArgs
)
Public Delegate Sub UserQueryEventHandler (
    s As Object,
    e As UserQueryEventArgs
)
public delegate void UserQueryEventHandler(
    Object^ s,
    UserQueryEventArgs^ e
)
public delegate void UserQueryEventHandler(
    Object^ s,
    UserQueryEventArgs^ e
)
type UserQueryEventHandler =
    delegate of
        s : Object *
        e : UserQueryEventArgs -> unit
type UserQueryEventHandler =
    delegate of
        s : Object *
        e : UserQueryEventArgs -> unit
Parameters
s (Object)
e (UserQueryEventArgs)


WordsEnteredEventArgs Class

WordsEnteredEventArgs Class
API ► Keyoti.RapidSpell.Wpf.Event ► WordsEnteredEventArgs
Keyoti RapidSpell WPF
Args for the events fired when words are entered into the text box.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class WordsEnteredEventArgs : EventArgs
public class WordsEnteredEventArgs : EventArgs
Public Class WordsEnteredEventArgs
    Inherits EventArgs
Public Class WordsEnteredEventArgs
    Inherits EventArgs
public ref class WordsEnteredEventArgs : public EventArgs
public ref class WordsEnteredEventArgs : public EventArgs
type WordsEnteredEventArgs =
    class
        inherit EventArgs
    end
type WordsEnteredEventArgs =
    class
        inherit EventArgs
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WordsEnteredEventArgs(IList, IAYTTextBox) | New
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SourceTextBox | The text box in which words were entered.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Words | List of WordOccurrence objects, representing the newly entered words.
Remarks
Contains IList of WordOccurrence objects.
Inheritance Hierarchy
Object
 | EventArgs
 |  | WordsEnteredEventArgs


WordsEnteredEventArgs Constructor (words, sourceTextBox)

WordsEnteredEventArgs Constructor (words, sourceTextBox)
API ► Keyoti.RapidSpell.Wpf.Event ► WordsEnteredEventArgs ► WordsEnteredEventArgs(IList, IAYTTextBox)
Keyoti RapidSpell WPF
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public WordsEnteredEventArgs(
    IList words,
    IAYTTextBox sourceTextBox
)
public WordsEnteredEventArgs(
    IList words,
    IAYTTextBox sourceTextBox
)
Public Sub New (
    words As IList,
    sourceTextBox As IAYTTextBox
)
Public Sub New (
    words As IList,
    sourceTextBox As IAYTTextBox
)
public:
WordsEnteredEventArgs(
    IList^ words,
    IAYTTextBox^ sourceTextBox
)
public:
WordsEnteredEventArgs(
    IList^ words,
    IAYTTextBox^ sourceTextBox
)
new :
        words : IList *
        sourceTextBox : IAYTTextBox -> WordsEnteredEventArgs
new :
        words : IList *
        sourceTextBox : IAYTTextBox -> WordsEnteredEventArgs
Parameters
words (IList)
sourceTextBox (IAYTTextBox)


SourceTextBox Property

SourceTextBox Property
API ► Keyoti.RapidSpell.Wpf.Event ► WordsEnteredEventArgs ► SourceTextBox
Keyoti RapidSpell WPF
The text box in which words were entered.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public IAYTTextBox SourceTextBox { get; }
public IAYTTextBox SourceTextBox { get; }
Public ReadOnly Property SourceTextBox As IAYTTextBox
    Get
Public ReadOnly Property SourceTextBox As IAYTTextBox
    Get
public:
property IAYTTextBox^ SourceTextBox {
    IAYTTextBox^ get ();
}
public:
property IAYTTextBox^ SourceTextBox {
    IAYTTextBox^ get ();
}
member SourceTextBox : IAYTTextBox with get

member SourceTextBox : IAYTTextBox with get
Property Value
IAYTTextBox


Words Property

Words Property
API ► Keyoti.RapidSpell.Wpf.Event ► WordsEnteredEventArgs ► Words
Keyoti RapidSpell WPF
List of WordOccurrence objects, representing the newly entered words.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public IList Words { get; }
public IList Words { get; }
Public ReadOnly Property Words As IList
    Get
Public ReadOnly Property Words As IList
    Get
public:
property IList^ Words {
    IList^ get ();
}
public:
property IList^ Words {
    IList^ get ();
}
member Words : IList with get

member Words : IList with get
Property Value
IList


WordsEnteredEventHandler Delegate

WordsEnteredEventHandler Delegate
API ► Keyoti.RapidSpell.Wpf.Event ► WordsEnteredEventHandler
Keyoti RapidSpell WPF
Handler delegate
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void WordsEnteredEventHandler(
    Object sender,
    WordsEnteredEventArgs e
)
public delegate void WordsEnteredEventHandler(
    Object sender,
    WordsEnteredEventArgs e
)
Public Delegate Sub WordsEnteredEventHandler (
    sender As Object,
    e As WordsEnteredEventArgs
)
Public Delegate Sub WordsEnteredEventHandler (
    sender As Object,
    e As WordsEnteredEventArgs
)
public delegate void WordsEnteredEventHandler(
    Object^ sender,
    WordsEnteredEventArgs^ e
)
public delegate void WordsEnteredEventHandler(
    Object^ sender,
    WordsEnteredEventArgs^ e
)
type WordsEnteredEventHandler =
    delegate of
        sender : Object *
        e : WordsEnteredEventArgs -> unit
type WordsEnteredEventHandler =
    delegate of
        sender : Object *
        e : WordsEnteredEventArgs -> unit
Parameters
sender (Object)
e (WordsEnteredEventArgs)


Keyoti.RapidSpell.Wpf.FrameWorkSpecific Namespace

Keyoti.RapidSpell.Wpf.FrameWorkSpecific Namespace
API ► Keyoti.RapidSpell.Wpf.FrameWorkSpecific
Keyoti RapidSpell WPF
The namespace for RapidSpell Desktop .NET specific classes.
Types
All Types Classes
Icon | Type | Description
 | AdvancedTextBoundary | A word parser, capable of working with XML documents.
 | SimpleTextBoundary | A simple word parser, for plain text.


AdvancedTextBoundary Class

AdvancedTextBoundary Class
API ► Keyoti.RapidSpell.Wpf.FrameWorkSpecific ► AdvancedTextBoundary
Keyoti RapidSpell WPF
A word parser, capable of working with XML documents.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class AdvancedTextBoundary : SimpleTextBoundary
public class AdvancedTextBoundary : SimpleTextBoundary
Public Class AdvancedTextBoundary
    Inherits SimpleTextBoundary
Public Class AdvancedTextBoundary
    Inherits SimpleTextBoundary
public ref class AdvancedTextBoundary : public SimpleTextBoundary
public ref class AdvancedTextBoundary : public SimpleTextBoundary
type AdvancedTextBoundary =
    class
        inherit SimpleTextBoundary
    end
type AdvancedTextBoundary =
    class
        inherit SimpleTextBoundary
    end
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AdvancedTextBoundary()()()() |
 | CheckLegalOffset(Int32, String, Boolean) | Throws an ArgumentOutOfRangeException if offset is out of bounds. (Inherited from SimpleTextBoundary.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | f_languageParsing | Language rules to use when parsing. (Inherited from SimpleTextBoundary.)
 | f_separateHyphenWords | Whether to simply treat hyphens as breaking chars. (Inherited from SimpleTextBoundary.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | Following(Int32) | Returns the next breaking point in the text. (Overrides SimpleTextBoundary.Following(Int32).)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | IgnoreXML | Whether to ignore XML/HTML tags, should be set true for RichTextBox support, false by default.
 | isAtNonBreakingWhiteSpace(Int32, Boolean, Boolean) | Whether position is non-breaking white space (Overrides SimpleTextBoundary.isAtNonBreakingWhiteSpace(Int32, Boolean, Boolean).)
 | isAtNonBreakingWhiteSpace(Int32) | Whether the character at position is a nonbreaking whitespace. (Inherited from SimpleTextBoundary.)
 | isAtNonWhiteSpace(Int32) | Whether position is not whitespace. (Overrides SimpleTextBoundary.isAtNonWhiteSpace(Int32).)
 | isBetweenWordChars(Int32) | Whether the character at position is between nonbreaking white space or letters or digits. (Inherited from SimpleTextBoundary.)
 | isBetweenWordChars(Int32, Boolean, Boolean) | Whether the character at position is between nonbreaking white space or letters or digits. (Inherited from SimpleTextBoundary.)
 | IsBoundary(Int32) | Determines if character at offset is a boundary (Inherited from SimpleTextBoundary.)
 | IsBoundaryLeft(Int32) | Whether offset is a boundary to the left of text (Inherited from SimpleTextBoundary.)
 | IsBoundaryRight(Int32) | Whether offset is one place after the last character in a word. (Inherited from SimpleTextBoundary.)
 | IsStartOfSentence(Int32) | Whether the character at offset is the first letter or digit of the sentence. (Inherited from SimpleTextBoundary.)
 | LanguageParsing | The language parsing to be used. (Inherited from SimpleTextBoundary.)
 | Last()()()() | Return the last boundary. The iterator's current position is set to the last boundary. (Inherited from SimpleTextBoundary.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Preceding(Int32) | this ignores xml tags butted between text. (Overrides SimpleTextBoundary.Preceding(Int32).)
 | SeparateHyphenWords | Whether to treat hyphenated (-) words as separate words, default is false. (Inherited from SimpleTextBoundary.)
 | SetText(String) | Sets the text to be analysed. (Overrides SimpleTextBoundary.SetText(String).)
 | TextIsStartOfTextBody | If known, whether the text to be set in SetText is the start of the text body. Affects sentence determination. (Inherited from SimpleTextBoundary.)
 | theText | The text being parsed. (Inherited from SimpleTextBoundary.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | V2Parser | Whether to use parser version 2 (Inherited from SimpleTextBoundary.)
Inheritance Hierarchy
Object
 | SimpleTextBoundary
 |  | AdvancedTextBoundary


AdvancedTextBoundary Constructor

AdvancedTextBoundary Constructor
API ► Keyoti.RapidSpell.Wpf.FrameWorkSpecific ► AdvancedTextBoundary ► AdvancedTextBoundary()()()()
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public AdvancedTextBoundary()
public AdvancedTextBoundary()
Public Sub New
Public Sub New
public:
AdvancedTextBoundary()
public:
AdvancedTextBoundary()
new : unit -> AdvancedTextBoundary
new : unit -> AdvancedTextBoundary


Following Method (offset)

Following Method (offset)
API ► Keyoti.RapidSpell.Wpf.FrameWorkSpecific ► AdvancedTextBoundary ► Following(Int32)
Keyoti RapidSpell WPF
Returns the next breaking point in the text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override int Following(
    int offset
)
public override int Following(
    int offset
)
Public Overrides Function Following (
    offset As Integer
) As Integer
Public Overrides Function Following (
    offset As Integer
) As Integer
public:
virtual int Following(
    int offset
) override
public:
virtual int Following(
    int offset
) override
abstract Following :
        offset : int -> int
override Following :
        offset : int -> int
abstract Following :
        offset : int -> int
override Following :
        offset : int -> int
Parameters
offset (Int32)
Return Value
Int32


IgnoreXML Property

IgnoreXML Property
API ► Keyoti.RapidSpell.Wpf.FrameWorkSpecific ► AdvancedTextBoundary ► IgnoreXML
Keyoti RapidSpell WPF
Whether to ignore XML/HTML tags, should be set true for RichTextBox support, false by default.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreXML { get; set; }
public bool IgnoreXML { get; set; }
Public Property IgnoreXML As Boolean
    Get
    Set
Public Property IgnoreXML As Boolean
    Get
    Set
public:
property bool IgnoreXML {
    bool get ();
    void set (bool value);
}
public:
property bool IgnoreXML {
    bool get ();
    void set (bool value);
}
member IgnoreXML : bool with get, set

member IgnoreXML : bool with get, set
Property Value
Boolean


isAtNonBreakingWhiteSpace Method (position, previousIsIfThisIs, nextIsIfThisIs)

isAtNonBreakingWhiteSpace Method (position, previousIsIfThisIs, nextIsIfThisIs)
API ► Keyoti.RapidSpell.Wpf.FrameWorkSpecific ► AdvancedTextBoundary ► isAtNonBreakingWhiteSpace(Int32, Boolean, Boolean)
Keyoti RapidSpell WPF
Whether position is non-breaking white space
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override bool isAtNonBreakingWhiteSpace(
    int position,
    bool previousIsIfThisIs,
    bool nextIsIfThisIs
)
protected override bool isAtNonBreakingWhiteSpace(
    int position,
    bool previousIsIfThisIs,
    bool nextIsIfThisIs
)
Protected Overrides Function isAtNonBreakingWhiteSpace (
    position As Integer,
    previousIsIfThisIs As Boolean,
    nextIsIfThisIs As Boolean
) As Boolean
Protected Overrides Function isAtNonBreakingWhiteSpace (
    position As Integer,
    previousIsIfThisIs As Boolean,
    nextIsIfThisIs As Boolean
) As Boolean
protected:
virtual bool isAtNonBreakingWhiteSpace(
    int position,
    bool previousIsIfThisIs,
    bool nextIsIfThisIs
) override
protected:
virtual bool isAtNonBreakingWhiteSpace(
    int position,
    bool previousIsIfThisIs,
    bool nextIsIfThisIs
) override
abstract isAtNonBreakingWhiteSpace :
        position : int *
        previousIsIfThisIs : bool *
        nextIsIfThisIs : bool -> bool
override isAtNonBreakingWhiteSpace :
        position : int *
        previousIsIfThisIs : bool *
        nextIsIfThisIs : bool -> bool
abstract isAtNonBreakingWhiteSpace :
        position : int *
        previousIsIfThisIs : bool *
        nextIsIfThisIs : bool -> bool
override isAtNonBreakingWhiteSpace :
        position : int *
        previousIsIfThisIs : bool *
        nextIsIfThisIs : bool -> bool
Parameters
position (Int32)
previousIsIfThisIs (Boolean)
nextIsIfThisIs (Boolean)
Return Value
Boolean


isAtNonWhiteSpace Method (position)

isAtNonWhiteSpace Method (position)
API ► Keyoti.RapidSpell.Wpf.FrameWorkSpecific ► AdvancedTextBoundary ► isAtNonWhiteSpace(Int32)
Keyoti RapidSpell WPF
Whether position is not whitespace.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected override bool isAtNonWhiteSpace(
    int position
)
protected override bool isAtNonWhiteSpace(
    int position
)
Protected Overrides Function isAtNonWhiteSpace (
    position As Integer
) As Boolean
Protected Overrides Function isAtNonWhiteSpace (
    position As Integer
) As Boolean
protected:
virtual bool isAtNonWhiteSpace(
    int position
) override
protected:
virtual bool isAtNonWhiteSpace(
    int position
) override
abstract isAtNonWhiteSpace :
        position : int -> bool
override isAtNonWhiteSpace :
        position : int -> bool
abstract isAtNonWhiteSpace :
        position : int -> bool
override isAtNonWhiteSpace :
        position : int -> bool
Parameters
position (Int32)
Return Value
Boolean


Preceding Method (offset)

Preceding Method (offset)
API ► Keyoti.RapidSpell.Wpf.FrameWorkSpecific ► AdvancedTextBoundary ► Preceding(Int32)
Keyoti RapidSpell WPF
this ignores xml tags butted between text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override int Preceding(
    int offset
)
public override int Preceding(
    int offset
)
Public Overrides Function Preceding (
    offset As Integer
) As Integer
Public Overrides Function Preceding (
    offset As Integer
) As Integer
public:
virtual int Preceding(
    int offset
) override
public:
virtual int Preceding(
    int offset
) override
abstract Preceding :
        offset : int -> int
override Preceding :
        offset : int -> int
abstract Preceding :
        offset : int -> int
override Preceding :
        offset : int -> int
Parameters
offset (Int32)
Return Value
Int32


SetText Method (t)

SetText Method (t)
API ► Keyoti.RapidSpell.Wpf.FrameWorkSpecific ► AdvancedTextBoundary ► SetText(String)
Keyoti RapidSpell WPF
Sets the text to be analysed.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public override void SetText(
    string t
)
public override void SetText(
    string t
)
Public Overrides Sub SetText (
    t As String
)
Public Overrides Sub SetText (
    t As String
)
public:
virtual void SetText(
    String^ t
) override
public:
virtual void SetText(
    String^ t
) override
abstract SetText :
        t : string -> unit
override SetText :
        t : string -> unit
abstract SetText :
        t : string -> unit
override SetText :
        t : string -> unit
Parameters
t (String)


SimpleTextBoundary Class

SimpleTextBoundary Class
API ► Keyoti.RapidSpell.Wpf.FrameWorkSpecific ► SimpleTextBoundary
Keyoti RapidSpell WPF
A simple word parser, for plain text.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class SimpleTextBoundary
public class SimpleTextBoundary
Public Class SimpleTextBoundary
Public Class SimpleTextBoundary
public ref class SimpleTextBoundary
public ref class SimpleTextBoundary
type SimpleTextBoundary =  class end
type SimpleTextBoundary =  class end
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SimpleTextBoundary()()()() |
 | breakChars | Characters that aren't letters or digits and do break words apart
 | CheckLegalOffset(Int32, String, Boolean) | Throws an ArgumentOutOfRangeException if offset is out of bounds.
 | ENGLISH | English text parsing.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | f_languageParsing | Language rules to use when parsing.
 | f_separateHyphenWords | Whether to simply treat hyphens as breaking chars.
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | Following(Int32) | Return the first boundary after the specified offset
 | FRENCH | French text parsing.
 | GERMAN | French text parsing.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | isAtNonBreakingWhiteSpace(Int32) | Whether the character at position is a nonbreaking whitespace.
 | isAtNonBreakingWhiteSpace(Int32, Boolean, Boolean) | Whether the character at position is a nonbreaking whitespace.
 | isAtNonWhiteSpace(Int32) | Returns whether the character at position is whitespace, this is contextually relevant.
 | isBetweenWordChars(Int32) | Whether the character at position is between nonbreaking white space or letters or digits.
 | isBetweenWordChars(Int32, Boolean, Boolean) | Whether the character at position is between nonbreaking white space or letters or digits.
 | IsBoundary(Int32) | Determines if character at offset is a boundary
 | IsBoundaryLeft(Int32) | Whether offset is a boundary to the left of text
 | IsBoundaryRight(Int32) | Whether offset is one place after the last character in a word.
 | IsStartOfSentence(Int32) | Whether the character at offset is the first letter or digit of the sentence.
 | LanguageParsing | The language parsing to be used.
 | Last()()()() | Return the last boundary. The iterator's current position is set to the last boundary.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | noBreakButLookIntoChars | Characters that aren't letters or digits but do not break words apart, however the spell checker should consider words on either side as separate words
 | noBreakButLookIntoCharsLength | The number of chars in the noBreakButLookIntoChars field
 | noBreakChars | Characters that aren't letters or digits but do not break words apart
 | Preceding(Int32) | Return the first boundary before the specified offset
 | SeparateHyphenWords | Whether to treat hyphenated (-) words as separate words, default is false.
 | SetText(String) | Sets the text to be analysed.
 | TextIsStartOfTextBody | If known, whether the text to be set in SetText is the start of the text body. Affects sentence determination.
 | theText | The text being parsed.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | V2Parser | Whether to use parser version 2
Inheritance Hierarchy
Object
 | SimpleTextBoundary
 |  | AdvancedTextBoundary


SimpleTextBoundary Constructor

SimpleTextBoundary Constructor
API ► Keyoti.RapidSpell.Wpf.FrameWorkSpecific ► SimpleTextBoundary ► SimpleTextBoundary()()()()
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public SimpleTextBoundary()
public SimpleTextBoundary()
Public Sub New
Public Sub New
public:
SimpleTextBoundary()
public:
SimpleTextBoundary()
new : unit -> SimpleTextBoundary
new : unit -> SimpleTextBoundary


breakChars Field

breakChars Field
API ► Keyoti.RapidSpell.Wpf.FrameWorkSpecific ► SimpleTextBoundary ► breakChars
Keyoti RapidSpell WPF
Characters that aren't letters or digits and do break words apart
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public const string breakChars
public const string breakChars
Public Const breakChars As String
Public Const breakChars As String
public:
literal String^ breakChars
public:
literal String^ breakChars
static val mutable breakChars: string
static val mutable breakChars: string
Field Value
String


CheckLegalOffset Method (offset, message, allowEnd)

CheckLegalOffset Method (offset, message, allowEnd)
API ► Keyoti.RapidSpell.Wpf.FrameWorkSpecific ► SimpleTextBoundary ► CheckLegalOffset(Int32, String, Boolean)
Keyoti RapidSpell WPF
Throws an ArgumentOutOfRangeException if offset is out of bounds.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void CheckLegalOffset(
    int offset,
    string message,
    bool allowEnd
)
protected virtual void CheckLegalOffset(
    int offset,
    string message,
    bool allowEnd
)
Protected Overridable Sub CheckLegalOffset (
    offset As Integer,
    message As String,
    allowEnd As Boolean
)
Protected Overridable Sub CheckLegalOffset (
    offset As Integer,
    message As String,
    allowEnd As Boolean
)
protected:
virtual void CheckLegalOffset(
    int offset,
    String^ message,
    bool allowEnd
)
protected:
virtual void CheckLegalOffset(
    int offset,
    String^ message,
    bool allowEnd
)
abstract CheckLegalOffset :
        offset : int *
        message : string *
        allowEnd : bool -> unit
override CheckLegalOffset :
        offset : int *
        message : string *
        allowEnd : bool -> unit
abstract CheckLegalOffset :
        offset : int *
        message : string *
        allowEnd : bool -> unit
override CheckLegalOffset :
        offset : int *
        message : string *
        allowEnd : bool -> unit
Parameters
offset (Int32)
message (String)
allowEnd (Boolean)


ENGLISH Field

ENGLISH Field
API ► Keyoti.RapidSpell.Wpf.FrameWorkSpecific ► SimpleTextBoundary ► ENGLISH
Keyoti RapidSpell WPF
English text parsing.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static int ENGLISH
public static int ENGLISH
Public Shared ENGLISH As Integer
Public Shared ENGLISH As Integer
public:
static int ENGLISH
public:
static int ENGLISH
static val mutable ENGLISH: int
static val mutable ENGLISH: int
Field Value
Int32


f_languageParsing Field

f_languageParsing Field
API ► Keyoti.RapidSpell.Wpf.FrameWorkSpecific ► SimpleTextBoundary ► f_languageParsing
Keyoti RapidSpell WPF
Language rules to use when parsing.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected int f_languageParsing
protected int f_languageParsing
Protected f_languageParsing As Integer
Protected f_languageParsing As Integer
protected:
int f_languageParsing
protected:
int f_languageParsing
val mutable f_languageParsing: int
val mutable f_languageParsing: int
Field Value
Int32


f_separateHyphenWords Field

f_separateHyphenWords Field
API ► Keyoti.RapidSpell.Wpf.FrameWorkSpecific ► SimpleTextBoundary ► f_separateHyphenWords
Keyoti RapidSpell WPF
Whether to simply treat hyphens as breaking chars.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected bool f_separateHyphenWords
protected bool f_separateHyphenWords
Protected f_separateHyphenWords As Boolean
Protected f_separateHyphenWords As Boolean
protected:
bool f_separateHyphenWords
protected:
bool f_separateHyphenWords
val mutable f_separateHyphenWords: bool
val mutable f_separateHyphenWords: bool
Field Value
Boolean


Following Method (offset)

Following Method (offset)
API ► Keyoti.RapidSpell.Wpf.FrameWorkSpecific ► SimpleTextBoundary ► Following(Int32)
Keyoti RapidSpell WPF
Return the first boundary after the specified offset
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual int Following(
    int offset
)
public virtual int Following(
    int offset
)
Public Overridable Function Following (
    offset As Integer
) As Integer
Public Overridable Function Following (
    offset As Integer
) As Integer
public:
virtual int Following(
    int offset
)
public:
virtual int Following(
    int offset
)
abstract Following :
        offset : int -> int
override Following :
        offset : int -> int
abstract Following :
        offset : int -> int
override Following :
        offset : int -> int
Parameters
offset (Int32)
the offset to start
Return Value
Int32
int the first boundary after offset


FRENCH Field

FRENCH Field
API ► Keyoti.RapidSpell.Wpf.FrameWorkSpecific ► SimpleTextBoundary ► FRENCH
Keyoti RapidSpell WPF
French text parsing.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static int FRENCH
public static int FRENCH
Public Shared FRENCH As Integer
Public Shared FRENCH As Integer
public:
static int FRENCH
public:
static int FRENCH
static val mutable FRENCH: int
static val mutable FRENCH: int
Field Value
Int32


GERMAN Field

GERMAN Field
API ► Keyoti.RapidSpell.Wpf.FrameWorkSpecific ► SimpleTextBoundary ► GERMAN
Keyoti RapidSpell WPF
French text parsing.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static int GERMAN
public static int GERMAN
Public Shared GERMAN As Integer
Public Shared GERMAN As Integer
public:
static int GERMAN
public:
static int GERMAN
static val mutable GERMAN: int
static val mutable GERMAN: int
Field Value
Int32


isAtNonBreakingWhiteSpace Method

isAtNonBreakingWhiteSpace Method
API ► Keyoti.RapidSpell.Wpf.FrameWorkSpecific ► SimpleTextBoundary ► isAtNonBreakingWhiteSpace()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | isAtNonBreakingWhiteSpace(Int32) | Whether the character at position is a nonbreaking whitespace.
 | isAtNonBreakingWhiteSpace(Int32, Boolean, Boolean) | Whether the character at position is a nonbreaking whitespace.


isAtNonBreakingWhiteSpace Method (position)

isAtNonBreakingWhiteSpace Method (position)
API ► Keyoti.RapidSpell.Wpf.FrameWorkSpecific ► SimpleTextBoundary ► isAtNonBreakingWhiteSpace(Int32)
Keyoti RapidSpell WPF
Whether the character at position is a nonbreaking whitespace.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual bool isAtNonBreakingWhiteSpace(
    int position
)
protected virtual bool isAtNonBreakingWhiteSpace(
    int position
)
Protected Overridable Function isAtNonBreakingWhiteSpace (
    position As Integer
) As Boolean
Protected Overridable Function isAtNonBreakingWhiteSpace (
    position As Integer
) As Boolean
protected:
virtual bool isAtNonBreakingWhiteSpace(
    int position
)
protected:
virtual bool isAtNonBreakingWhiteSpace(
    int position
)
abstract isAtNonBreakingWhiteSpace :
        position : int -> bool
override isAtNonBreakingWhiteSpace :
        position : int -> bool
abstract isAtNonBreakingWhiteSpace :
        position : int -> bool
override isAtNonBreakingWhiteSpace :
        position : int -> bool
Parameters
position (Int32)
Return Value
Boolean


isAtNonBreakingWhiteSpace Method (position, previousIsIfThisIs, nextIsIfThisIs)

isAtNonBreakingWhiteSpace Method (position, previousIsIfThisIs, nextIsIfThisIs)
API ► Keyoti.RapidSpell.Wpf.FrameWorkSpecific ► SimpleTextBoundary ► isAtNonBreakingWhiteSpace(Int32, Boolean, Boolean)
Keyoti RapidSpell WPF
Whether the character at position is a nonbreaking whitespace.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual bool isAtNonBreakingWhiteSpace(
    int position,
    bool previousIsIfThisIs,
    bool nextIsIfThisIs
)
protected virtual bool isAtNonBreakingWhiteSpace(
    int position,
    bool previousIsIfThisIs,
    bool nextIsIfThisIs
)
Protected Overridable Function isAtNonBreakingWhiteSpace (
    position As Integer,
    previousIsIfThisIs As Boolean,
    nextIsIfThisIs As Boolean
) As Boolean
Protected Overridable Function isAtNonBreakingWhiteSpace (
    position As Integer,
    previousIsIfThisIs As Boolean,
    nextIsIfThisIs As Boolean
) As Boolean
protected:
virtual bool isAtNonBreakingWhiteSpace(
    int position,
    bool previousIsIfThisIs,
    bool nextIsIfThisIs
)
protected:
virtual bool isAtNonBreakingWhiteSpace(
    int position,
    bool previousIsIfThisIs,
    bool nextIsIfThisIs
)
abstract isAtNonBreakingWhiteSpace :
        position : int *
        previousIsIfThisIs : bool *
        nextIsIfThisIs : bool -> bool
override isAtNonBreakingWhiteSpace :
        position : int *
        previousIsIfThisIs : bool *
        nextIsIfThisIs : bool -> bool
abstract isAtNonBreakingWhiteSpace :
        position : int *
        previousIsIfThisIs : bool *
        nextIsIfThisIs : bool -> bool
override isAtNonBreakingWhiteSpace :
        position : int *
        previousIsIfThisIs : bool *
        nextIsIfThisIs : bool -> bool
Parameters
position (Int32)
previousIsIfThisIs (Boolean)
nextIsIfThisIs (Boolean)
Return Value
Boolean


isAtNonWhiteSpace Method (position)

isAtNonWhiteSpace Method (position)
API ► Keyoti.RapidSpell.Wpf.FrameWorkSpecific ► SimpleTextBoundary ► isAtNonWhiteSpace(Int32)
Keyoti RapidSpell WPF
Returns whether the character at position is whitespace, this is contextually relevant.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual bool isAtNonWhiteSpace(
    int position
)
protected virtual bool isAtNonWhiteSpace(
    int position
)
Protected Overridable Function isAtNonWhiteSpace (
    position As Integer
) As Boolean
Protected Overridable Function isAtNonWhiteSpace (
    position As Integer
) As Boolean
protected:
virtual bool isAtNonWhiteSpace(
    int position
)
protected:
virtual bool isAtNonWhiteSpace(
    int position
)
abstract isAtNonWhiteSpace :
        position : int -> bool
override isAtNonWhiteSpace :
        position : int -> bool
abstract isAtNonWhiteSpace :
        position : int -> bool
override isAtNonWhiteSpace :
        position : int -> bool
Parameters
position (Int32)
Return Value
Boolean


isBetweenWordChars Method

isBetweenWordChars Method
API ► Keyoti.RapidSpell.Wpf.FrameWorkSpecific ► SimpleTextBoundary ► isBetweenWordChars()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | isBetweenWordChars(Int32) | Whether the character at position is between nonbreaking white space or letters or digits.
 | isBetweenWordChars(Int32, Boolean, Boolean) | Whether the character at position is between nonbreaking white space or letters or digits.


isBetweenWordChars Method (position)

isBetweenWordChars Method (position)
API ► Keyoti.RapidSpell.Wpf.FrameWorkSpecific ► SimpleTextBoundary ► isBetweenWordChars(Int32)
Keyoti RapidSpell WPF
Whether the character at position is between nonbreaking white space or letters or digits.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual bool isBetweenWordChars(
    int position
)
protected virtual bool isBetweenWordChars(
    int position
)
Protected Overridable Function isBetweenWordChars (
    position As Integer
) As Boolean
Protected Overridable Function isBetweenWordChars (
    position As Integer
) As Boolean
protected:
virtual bool isBetweenWordChars(
    int position
)
protected:
virtual bool isBetweenWordChars(
    int position
)
abstract isBetweenWordChars :
        position : int -> bool
override isBetweenWordChars :
        position : int -> bool
abstract isBetweenWordChars :
        position : int -> bool
override isBetweenWordChars :
        position : int -> bool
Parameters
position (Int32)
Return Value
Boolean


isBetweenWordChars Method (position, previousIsIfThisIs, nextIsIfThisIs)

isBetweenWordChars Method (position, previousIsIfThisIs, nextIsIfThisIs)
API ► Keyoti.RapidSpell.Wpf.FrameWorkSpecific ► SimpleTextBoundary ► isBetweenWordChars(Int32, Boolean, Boolean)
Keyoti RapidSpell WPF
Whether the character at position is between nonbreaking white space or letters or digits.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual bool isBetweenWordChars(
    int position,
    bool previousIsIfThisIs,
    bool nextIsIfThisIs
)
protected virtual bool isBetweenWordChars(
    int position,
    bool previousIsIfThisIs,
    bool nextIsIfThisIs
)
Protected Overridable Function isBetweenWordChars (
    position As Integer,
    previousIsIfThisIs As Boolean,
    nextIsIfThisIs As Boolean
) As Boolean
Protected Overridable Function isBetweenWordChars (
    position As Integer,
    previousIsIfThisIs As Boolean,
    nextIsIfThisIs As Boolean
) As Boolean
protected:
virtual bool isBetweenWordChars(
    int position,
    bool previousIsIfThisIs,
    bool nextIsIfThisIs
)
protected:
virtual bool isBetweenWordChars(
    int position,
    bool previousIsIfThisIs,
    bool nextIsIfThisIs
)
abstract isBetweenWordChars :
        position : int *
        previousIsIfThisIs : bool *
        nextIsIfThisIs : bool -> bool
override isBetweenWordChars :
        position : int *
        previousIsIfThisIs : bool *
        nextIsIfThisIs : bool -> bool
abstract isBetweenWordChars :
        position : int *
        previousIsIfThisIs : bool *
        nextIsIfThisIs : bool -> bool
override isBetweenWordChars :
        position : int *
        previousIsIfThisIs : bool *
        nextIsIfThisIs : bool -> bool
Parameters
position (Int32)
previousIsIfThisIs (Boolean)
nextIsIfThisIs (Boolean)
Return Value
Boolean


IsBoundary Method (offset)

IsBoundary Method (offset)
API ► Keyoti.RapidSpell.Wpf.FrameWorkSpecific ► SimpleTextBoundary ► IsBoundary(Int32)
Keyoti RapidSpell WPF
Determines if character at offset is a boundary
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool IsBoundary(
    int offset
)
public virtual bool IsBoundary(
    int offset
)
Public Overridable Function IsBoundary (
    offset As Integer
) As Boolean
Public Overridable Function IsBoundary (
    offset As Integer
) As Boolean
public:
virtual bool IsBoundary(
    int offset
)
public:
virtual bool IsBoundary(
    int offset
)
abstract IsBoundary :
        offset : int -> bool
override IsBoundary :
        offset : int -> bool
abstract IsBoundary :
        offset : int -> bool
override IsBoundary :
        offset : int -> bool
Parameters
offset (Int32)
Return Value
Boolean


IsBoundaryLeft Method (offset)

IsBoundaryLeft Method (offset)
API ► Keyoti.RapidSpell.Wpf.FrameWorkSpecific ► SimpleTextBoundary ► IsBoundaryLeft(Int32)
Keyoti RapidSpell WPF
Whether offset is a boundary to the left of text
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool IsBoundaryLeft(
    int offset
)
public virtual bool IsBoundaryLeft(
    int offset
)
Public Overridable Function IsBoundaryLeft (
    offset As Integer
) As Boolean
Public Overridable Function IsBoundaryLeft (
    offset As Integer
) As Boolean
public:
virtual bool IsBoundaryLeft(
    int offset
)
public:
virtual bool IsBoundaryLeft(
    int offset
)
abstract IsBoundaryLeft :
        offset : int -> bool
override IsBoundaryLeft :
        offset : int -> bool
abstract IsBoundaryLeft :
        offset : int -> bool
override IsBoundaryLeft :
        offset : int -> bool
Parameters
offset (Int32)
Return Value
Boolean


IsBoundaryRight Method (offset)

IsBoundaryRight Method (offset)
API ► Keyoti.RapidSpell.Wpf.FrameWorkSpecific ► SimpleTextBoundary ► IsBoundaryRight(Int32)
Keyoti RapidSpell WPF
Whether offset is one place after the last character in a word.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool IsBoundaryRight(
    int offset
)
public virtual bool IsBoundaryRight(
    int offset
)
Public Overridable Function IsBoundaryRight (
    offset As Integer
) As Boolean
Public Overridable Function IsBoundaryRight (
    offset As Integer
) As Boolean
public:
virtual bool IsBoundaryRight(
    int offset
)
public:
virtual bool IsBoundaryRight(
    int offset
)
abstract IsBoundaryRight :
        offset : int -> bool
override IsBoundaryRight :
        offset : int -> bool
abstract IsBoundaryRight :
        offset : int -> bool
override IsBoundaryRight :
        offset : int -> bool
Parameters
offset (Int32)
Return Value
Boolean


IsStartOfSentence Method (offset)

IsStartOfSentence Method (offset)
API ► Keyoti.RapidSpell.Wpf.FrameWorkSpecific ► SimpleTextBoundary ► IsStartOfSentence(Int32)
Keyoti RapidSpell WPF
Whether the character at offset is the first letter or digit of the sentence.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool IsStartOfSentence(
    int offset
)
public virtual bool IsStartOfSentence(
    int offset
)
Public Overridable Function IsStartOfSentence (
    offset As Integer
) As Boolean
Public Overridable Function IsStartOfSentence (
    offset As Integer
) As Boolean
public:
virtual bool IsStartOfSentence(
    int offset
)
public:
virtual bool IsStartOfSentence(
    int offset
)
abstract IsStartOfSentence :
        offset : int -> bool
override IsStartOfSentence :
        offset : int -> bool
abstract IsStartOfSentence :
        offset : int -> bool
override IsStartOfSentence :
        offset : int -> bool
Parameters
offset (Int32)
Return Value
Boolean


LanguageParsing Property

LanguageParsing Property
API ► Keyoti.RapidSpell.Wpf.FrameWorkSpecific ► SimpleTextBoundary ► LanguageParsing
Keyoti RapidSpell WPF
The language parsing to be used.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public int LanguageParsing { get; set; }
public int LanguageParsing { get; set; }
Public Property LanguageParsing As Integer
    Get
    Set
Public Property LanguageParsing As Integer
    Get
    Set
public:
property int LanguageParsing {
    int get ();
    void set (int value);
}
public:
property int LanguageParsing {
    int get ();
    void set (int value);
}
member LanguageParsing : int with get, set

member LanguageParsing : int with get, set
Property Value
Int32


Last Method

Last Method
API ► Keyoti.RapidSpell.Wpf.FrameWorkSpecific ► SimpleTextBoundary ► Last()()()()
Keyoti RapidSpell WPF
Return the last boundary. The iterator's current position is set to the last boundary.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual int Last()
public virtual int Last()
Public Overridable Function Last As Integer
Public Overridable Function Last As Integer
public:
virtual int Last()
public:
virtual int Last()
abstract Last : unit -> int
override Last : unit -> int
abstract Last : unit -> int
override Last : unit -> int
Return Value
Int32


noBreakButLookIntoChars Field

noBreakButLookIntoChars Field
API ► Keyoti.RapidSpell.Wpf.FrameWorkSpecific ► SimpleTextBoundary ► noBreakButLookIntoChars
Keyoti RapidSpell WPF
Characters that aren't letters or digits but do not break words apart, however the spell checker should consider words on either side as separate words
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public const string noBreakButLookIntoChars
public const string noBreakButLookIntoChars
Public Const noBreakButLookIntoChars As String
Public Const noBreakButLookIntoChars As String
public:
literal String^ noBreakButLookIntoChars
public:
literal String^ noBreakButLookIntoChars
static val mutable noBreakButLookIntoChars: string
static val mutable noBreakButLookIntoChars: string
Field Value
String


noBreakButLookIntoCharsLength Field

noBreakButLookIntoCharsLength Field
API ► Keyoti.RapidSpell.Wpf.FrameWorkSpecific ► SimpleTextBoundary ► noBreakButLookIntoCharsLength
Keyoti RapidSpell WPF
The number of chars in the noBreakButLookIntoChars field
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public const int noBreakButLookIntoCharsLength
public const int noBreakButLookIntoCharsLength
Public Const noBreakButLookIntoCharsLength As Integer
Public Const noBreakButLookIntoCharsLength As Integer
public:
literal int noBreakButLookIntoCharsLength
public:
literal int noBreakButLookIntoCharsLength
static val mutable noBreakButLookIntoCharsLength: int
static val mutable noBreakButLookIntoCharsLength: int
Field Value
Int32


noBreakChars Field

noBreakChars Field
API ► Keyoti.RapidSpell.Wpf.FrameWorkSpecific ► SimpleTextBoundary ► noBreakChars
Keyoti RapidSpell WPF
Characters that aren't letters or digits but do not break words apart
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public static char[] noBreakChars
public static char[] noBreakChars
Public Shared noBreakChars As Char()
Public Shared noBreakChars As Char()
public:
static array<wchar_t>^ noBreakChars
public:
static array<wchar_t>^ noBreakChars
static val mutable noBreakChars: char[]
static val mutable noBreakChars: char[]
Field Value
array<Char>[]()[][]


Preceding Method (offset)

Preceding Method (offset)
API ► Keyoti.RapidSpell.Wpf.FrameWorkSpecific ► SimpleTextBoundary ► Preceding(Int32)
Keyoti RapidSpell WPF
Return the first boundary before the specified offset
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual int Preceding(
    int offset
)
public virtual int Preceding(
    int offset
)
Public Overridable Function Preceding (
    offset As Integer
) As Integer
Public Overridable Function Preceding (
    offset As Integer
) As Integer
public:
virtual int Preceding(
    int offset
)
public:
virtual int Preceding(
    int offset
)
abstract Preceding :
        offset : int -> int
override Preceding :
        offset : int -> int
abstract Preceding :
        offset : int -> int
override Preceding :
        offset : int -> int
Parameters
offset (Int32)
the offset to start
Return Value
Int32
int the first boundary after offset


SeparateHyphenWords Property

SeparateHyphenWords Property
API ► Keyoti.RapidSpell.Wpf.FrameWorkSpecific ► SimpleTextBoundary ► SeparateHyphenWords
Keyoti RapidSpell WPF
Whether to treat hyphenated (-) words as separate words, default is false.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool SeparateHyphenWords { get; set; }
public bool SeparateHyphenWords { get; set; }
Public Property SeparateHyphenWords As Boolean
    Get
    Set
Public Property SeparateHyphenWords As Boolean
    Get
    Set
public:
property bool SeparateHyphenWords {
    bool get ();
    void set (bool value);
}
public:
property bool SeparateHyphenWords {
    bool get ();
    void set (bool value);
}
member SeparateHyphenWords : bool with get, set

member SeparateHyphenWords : bool with get, set
Property Value
Boolean
Remarks
For eg. if this is true text like "cheap-deals" will be treated as two words "cheap" and "deals", otherwise this will be treated as one word "cheap-deals".


SetText Method (t)

SetText Method (t)
API ► Keyoti.RapidSpell.Wpf.FrameWorkSpecific ► SimpleTextBoundary ► SetText(String)
Keyoti RapidSpell WPF
Sets the text to be analysed.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void SetText(
    string t
)
public virtual void SetText(
    string t
)
Public Overridable Sub SetText (
    t As String
)
Public Overridable Sub SetText (
    t As String
)
public:
virtual void SetText(
    String^ t
)
public:
virtual void SetText(
    String^ t
)
abstract SetText :
        t : string -> unit
override SetText :
        t : string -> unit
abstract SetText :
        t : string -> unit
override SetText :
        t : string -> unit
Parameters
t (String)


TextIsStartOfTextBody Property

TextIsStartOfTextBody Property
API ► Keyoti.RapidSpell.Wpf.FrameWorkSpecific ► SimpleTextBoundary ► TextIsStartOfTextBody
Keyoti RapidSpell WPF
If known, whether the text to be set in SetText is the start of the text body. Affects sentence determination.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool TextIsStartOfTextBody { get; set; }
public virtual bool TextIsStartOfTextBody { get; set; }
Public Overridable Property TextIsStartOfTextBody As Boolean
    Get
    Set
Public Overridable Property TextIsStartOfTextBody As Boolean
    Get
    Set
public:
virtual property bool TextIsStartOfTextBody {
    bool get ();
    void set (bool value);
}
public:
virtual property bool TextIsStartOfTextBody {
    bool get ();
    void set (bool value);
}
abstract TextIsStartOfTextBody : bool with get, set
override TextIsStartOfTextBody : bool with get, set
abstract TextIsStartOfTextBody : bool with get, set
override TextIsStartOfTextBody : bool with get, set
Property Value
Boolean


theText Field

theText Field
API ► Keyoti.RapidSpell.Wpf.FrameWorkSpecific ► SimpleTextBoundary ► theText
Keyoti RapidSpell WPF
The text being parsed.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected string theText
protected string theText
Protected theText As String
Protected theText As String
protected:
String^ theText
protected:
String^ theText
val mutable theText: string
val mutable theText: string
Field Value
String


V2Parser Property

V2Parser Property
API ► Keyoti.RapidSpell.Wpf.FrameWorkSpecific ► SimpleTextBoundary ► V2Parser
Keyoti RapidSpell WPF
Whether to use parser version 2
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool V2Parser { get; set; }
public bool V2Parser { get; set; }
Public Property V2Parser As Boolean
    Get
    Set
Public Property V2Parser As Boolean
    Get
    Set
public:
property bool V2Parser {
    bool get ();
    void set (bool value);
}
public:
property bool V2Parser {
    bool get ();
    void set (bool value);
}
member V2Parser : bool with get, set

member V2Parser : bool with get, set
Property Value
Boolean


Keyoti.RapidSpell.Wpf.Options Namespace

Keyoti.RapidSpell.Wpf.Options Namespace
API ► Keyoti.RapidSpell.Wpf.Options
Keyoti RapidSpell WPF
Types
All Types Classes Enumerations Delegates
Icon | Type | Description
 | UserDictionaryEditEventArgs..::..EditType | Types of edit operations
 | UserDictionaryFormEventArgs..::..EditType | Types of edit operations
 | NeedStreamEventArgs | Event args for NeedCustomStreamForLoading and NeedCustomStreamForSaving event.
 | UserOptions..::..NeedStreamEventHandler | Delegate for need stream events.
 | OptionsPresenter | The presenter for IDialogViewOptions
 | UserOptions..::..StorageType | The option storage location
 | UserDictionaryContentChangedEventArgs | Event args
 | UserOptions..::..UserDictionaryContentChangeEventHandler | Handler delegate
 | UserDictionaryDefaultChangeEventArgs | Event args
 | UserOptions..::..UserDictionaryDefaultChangeEventHandler | Handler delegate
 | UserDictionaryEditEventArgs | Event args for a user dictionary edit event (add word, remove)
 | UserDictionaryEditEventHandler | Event handler delegate
 | UserDictionaryFormEventArgs | Event args for a user dictionary edit event (add word, remove)
 | UserDictionaryFormEventHandler | Event handler delegate
 | UserOptions | Holds/Loads/Saves user options.


NeedStreamEventArgs Class

NeedStreamEventArgs Class
API ► Keyoti.RapidSpell.Wpf.Options ► NeedStreamEventArgs
Keyoti RapidSpell WPF
Event args for NeedCustomStreamForLoading and NeedCustomStreamForSaving event.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class NeedStreamEventArgs : EventArgs
public class NeedStreamEventArgs : EventArgs
Public Class NeedStreamEventArgs
    Inherits EventArgs
Public Class NeedStreamEventArgs
    Inherits EventArgs
public ref class NeedStreamEventArgs : public EventArgs
public ref class NeedStreamEventArgs : public EventArgs
type NeedStreamEventArgs =
    class
        inherit EventArgs
    end
type NeedStreamEventArgs =
    class
        inherit EventArgs
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NeedStreamEventArgs()()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RequiredStream | Set the stream in this property when handling the event.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | NeedStreamEventArgs


NeedStreamEventArgs Constructor

NeedStreamEventArgs Constructor
API ► Keyoti.RapidSpell.Wpf.Options ► NeedStreamEventArgs ► NeedStreamEventArgs()()()()
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public NeedStreamEventArgs()
public NeedStreamEventArgs()
Public Sub New
Public Sub New
public:
NeedStreamEventArgs()
public:
NeedStreamEventArgs()
new : unit -> NeedStreamEventArgs
new : unit -> NeedStreamEventArgs


RequiredStream Property

RequiredStream Property
API ► Keyoti.RapidSpell.Wpf.Options ► NeedStreamEventArgs ► RequiredStream
Keyoti RapidSpell WPF
Set the stream in this property when handling the event.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Stream RequiredStream { get; set; }
public Stream RequiredStream { get; set; }
Public Property RequiredStream As Stream
    Get
    Set
Public Property RequiredStream As Stream
    Get
    Set
public:
property Stream^ RequiredStream {
    Stream^ get ();
    void set (Stream^ value);
}
public:
property Stream^ RequiredStream {
    Stream^ get ();
    void set (Stream^ value);
}
member RequiredStream : Stream with get, set

member RequiredStream : Stream with get, set
Property Value
Stream


OptionsPresenter Class

OptionsPresenter Class
API ► Keyoti.RapidSpell.Wpf.Options ► OptionsPresenter
Keyoti RapidSpell WPF
The presenter for IDialogViewOptions
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class OptionsPresenter
public class OptionsPresenter
Public Class OptionsPresenter
Public Class OptionsPresenter
public ref class OptionsPresenter
public ref class OptionsPresenter
type OptionsPresenter =  class end
type OptionsPresenter =  class end
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OptionsPresenter()()()() |
 | CreateDialogViewOptions | Fired when an IDialogViewOptions is required.
 | CreateDialogViewUserDictionaryEdit | Fired when an IDialogViewUserDictionaryEdit is required.
 | CreateDialogViewUserDictionarySelect | Fired when an CreateDialogViewUserDictionarySelectForm is required.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnCreateDialogViewOptions(CreateDialogViewOptionsEventArgs) | Raises event
 | OnCreateDialogViewUserDictionaryEdit(CreateDialogViewUserDictionaryEditEventArgs) | Raises event
 | Show(Object, UserOptions) | Shows the form
 | ShowCheckAsYouTypeOption | Whether to show the "Check as you type" option
 | ShowEditUserDictionaryFile(String) |
 | ShowFindSuggestionsOption | Whether to show the "Always find suggestions" option
 | ShowOptionForMultipleUserDictionaries | Whether to show add/remove user dictionaries form.
 | ShowUserDictionaryButton | Whether to show the user dictionary button
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | WordRemoved | Fired when a word is removed from user dictionary.
Inheritance Hierarchy
Object
OptionsPresenter


OptionsPresenter Constructor

OptionsPresenter Constructor
API ► Keyoti.RapidSpell.Wpf.Options ► OptionsPresenter ► OptionsPresenter()()()()
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public OptionsPresenter()
public OptionsPresenter()
Public Sub New
Public Sub New
public:
OptionsPresenter()
public:
OptionsPresenter()
new : unit -> OptionsPresenter
new : unit -> OptionsPresenter


CreateDialogViewOptions Event

CreateDialogViewOptions Event
API ► Keyoti.RapidSpell.Wpf.Options ► OptionsPresenter ► CreateDialogViewOptions
Keyoti RapidSpell WPF
Fired when an IDialogViewOptions is required.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event CreateDialogViewOptionsEventHandler CreateDialogViewOptions
public event CreateDialogViewOptionsEventHandler CreateDialogViewOptions
Public Event CreateDialogViewOptions As CreateDialogViewOptionsEventHandler
Public Event CreateDialogViewOptions As CreateDialogViewOptionsEventHandler
public:
 event CreateDialogViewOptionsEventHandler^ CreateDialogViewOptions {
    void add (CreateDialogViewOptionsEventHandler^ value);
    void remove (CreateDialogViewOptionsEventHandler^ value);
}
public:
 event CreateDialogViewOptionsEventHandler^ CreateDialogViewOptions {
    void add (CreateDialogViewOptionsEventHandler^ value);
    void remove (CreateDialogViewOptionsEventHandler^ value);
}
member CreateDialogViewOptions : IEvent<CreateDialogViewOptionsEventHandler,
    CreateDialogViewOptionsEventArgs>

member CreateDialogViewOptions : IEvent<CreateDialogViewOptionsEventHandler,
    CreateDialogViewOptionsEventArgs>
Value
CreateDialogViewOptionsEventHandler


CreateDialogViewUserDictionaryEdit Event

CreateDialogViewUserDictionaryEdit Event
API ► Keyoti.RapidSpell.Wpf.Options ► OptionsPresenter ► CreateDialogViewUserDictionaryEdit
Keyoti RapidSpell WPF
Fired when an IDialogViewUserDictionaryEdit is required.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event CreateDialogViewUserDictionaryEditEventHandler CreateDialogViewUserDictionaryEdit
public event CreateDialogViewUserDictionaryEditEventHandler CreateDialogViewUserDictionaryEdit
Public Event CreateDialogViewUserDictionaryEdit As CreateDialogViewUserDictionaryEditEventHandler
Public Event CreateDialogViewUserDictionaryEdit As CreateDialogViewUserDictionaryEditEventHandler
public:
 event CreateDialogViewUserDictionaryEditEventHandler^ CreateDialogViewUserDictionaryEdit {
    void add (CreateDialogViewUserDictionaryEditEventHandler^ value);
    void remove (CreateDialogViewUserDictionaryEditEventHandler^ value);
}
public:
 event CreateDialogViewUserDictionaryEditEventHandler^ CreateDialogViewUserDictionaryEdit {
    void add (CreateDialogViewUserDictionaryEditEventHandler^ value);
    void remove (CreateDialogViewUserDictionaryEditEventHandler^ value);
}
member CreateDialogViewUserDictionaryEdit : IEvent<CreateDialogViewUserDictionaryEditEventHandler,
    CreateDialogViewUserDictionaryEditEventArgs>

member CreateDialogViewUserDictionaryEdit : IEvent<CreateDialogViewUserDictionaryEditEventHandler,
    CreateDialogViewUserDictionaryEditEventArgs>
Value
CreateDialogViewUserDictionaryEditEventHandler


CreateDialogViewUserDictionarySelect Event

CreateDialogViewUserDictionarySelect Event
API ► Keyoti.RapidSpell.Wpf.Options ► OptionsPresenter ► CreateDialogViewUserDictionarySelect
Keyoti RapidSpell WPF
Fired when an CreateDialogViewUserDictionarySelectForm is required.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event CreateDialogViewUserDictionarySelectEventHandler CreateDialogViewUserDictionarySelect
public event CreateDialogViewUserDictionarySelectEventHandler CreateDialogViewUserDictionarySelect
Public Event CreateDialogViewUserDictionarySelect As CreateDialogViewUserDictionarySelectEventHandler
Public Event CreateDialogViewUserDictionarySelect As CreateDialogViewUserDictionarySelectEventHandler
public:
 event CreateDialogViewUserDictionarySelectEventHandler^ CreateDialogViewUserDictionarySelect {
    void add (CreateDialogViewUserDictionarySelectEventHandler^ value);
    void remove (CreateDialogViewUserDictionarySelectEventHandler^ value);
}
public:
 event CreateDialogViewUserDictionarySelectEventHandler^ CreateDialogViewUserDictionarySelect {
    void add (CreateDialogViewUserDictionarySelectEventHandler^ value);
    void remove (CreateDialogViewUserDictionarySelectEventHandler^ value);
}
member CreateDialogViewUserDictionarySelect : IEvent<CreateDialogViewUserDictionarySelectEventHandler,
    CreateDialogViewUserDictionarySelectEventArgs>

member CreateDialogViewUserDictionarySelect : IEvent<CreateDialogViewUserDictionarySelectEventHandler,
    CreateDialogViewUserDictionarySelectEventArgs>
Value
CreateDialogViewUserDictionarySelectEventHandler


OnCreateDialogViewOptions Method (ev)

OnCreateDialogViewOptions Method (ev)
API ► Keyoti.RapidSpell.Wpf.Options ► OptionsPresenter ► OnCreateDialogViewOptions(CreateDialogViewOptionsEventArgs)
Keyoti RapidSpell WPF
Raises event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void OnCreateDialogViewOptions(
    CreateDialogViewOptionsEventArgs ev
)
protected virtual void OnCreateDialogViewOptions(
    CreateDialogViewOptionsEventArgs ev
)
Protected Overridable Sub OnCreateDialogViewOptions (
    ev As CreateDialogViewOptionsEventArgs
)
Protected Overridable Sub OnCreateDialogViewOptions (
    ev As CreateDialogViewOptionsEventArgs
)
protected:
virtual void OnCreateDialogViewOptions(
    CreateDialogViewOptionsEventArgs^ ev
)
protected:
virtual void OnCreateDialogViewOptions(
    CreateDialogViewOptionsEventArgs^ ev
)
abstract OnCreateDialogViewOptions :
        ev : CreateDialogViewOptionsEventArgs -> unit
override OnCreateDialogViewOptions :
        ev : CreateDialogViewOptionsEventArgs -> unit
abstract OnCreateDialogViewOptions :
        ev : CreateDialogViewOptionsEventArgs -> unit
override OnCreateDialogViewOptions :
        ev : CreateDialogViewOptionsEventArgs -> unit
Parameters
ev (CreateDialogViewOptionsEventArgs)


OnCreateDialogViewUserDictionaryEdit Method (ev)

OnCreateDialogViewUserDictionaryEdit Method (ev)
API ► Keyoti.RapidSpell.Wpf.Options ► OptionsPresenter ► OnCreateDialogViewUserDictionaryEdit(CreateDialogViewUserDictionaryEditEventArgs)
Keyoti RapidSpell WPF
Raises event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
protected virtual void OnCreateDialogViewUserDictionaryEdit(
    CreateDialogViewUserDictionaryEditEventArgs ev
)
protected virtual void OnCreateDialogViewUserDictionaryEdit(
    CreateDialogViewUserDictionaryEditEventArgs ev
)
Protected Overridable Sub OnCreateDialogViewUserDictionaryEdit (
    ev As CreateDialogViewUserDictionaryEditEventArgs
)
Protected Overridable Sub OnCreateDialogViewUserDictionaryEdit (
    ev As CreateDialogViewUserDictionaryEditEventArgs
)
protected:
virtual void OnCreateDialogViewUserDictionaryEdit(
    CreateDialogViewUserDictionaryEditEventArgs^ ev
)
protected:
virtual void OnCreateDialogViewUserDictionaryEdit(
    CreateDialogViewUserDictionaryEditEventArgs^ ev
)
abstract OnCreateDialogViewUserDictionaryEdit :
        ev : CreateDialogViewUserDictionaryEditEventArgs -> unit
override OnCreateDialogViewUserDictionaryEdit :
        ev : CreateDialogViewUserDictionaryEditEventArgs -> unit
abstract OnCreateDialogViewUserDictionaryEdit :
        ev : CreateDialogViewUserDictionaryEditEventArgs -> unit
override OnCreateDialogViewUserDictionaryEdit :
        ev : CreateDialogViewUserDictionaryEditEventArgs -> unit
Parameters
ev (CreateDialogViewUserDictionaryEditEventArgs)


Show Method (modalOwner, userOptions)

Show Method (modalOwner, userOptions)
API ► Keyoti.RapidSpell.Wpf.Options ► OptionsPresenter ► Show(Object, UserOptions)
Keyoti RapidSpell WPF
Shows the form
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool Show(
    Object modalOwner,
    UserOptions userOptions
)
public virtual bool Show(
    Object modalOwner,
    UserOptions userOptions
)
Public Overridable Function Show (
    modalOwner As Object,
    userOptions As UserOptions
) As Boolean
Public Overridable Function Show (
    modalOwner As Object,
    userOptions As UserOptions
) As Boolean
public:
virtual bool Show(
    Object^ modalOwner,
    UserOptions^ userOptions
)
public:
virtual bool Show(
    Object^ modalOwner,
    UserOptions^ userOptions
)
abstract Show :
        modalOwner : Object *
        userOptions : UserOptions -> bool
override Show :
        modalOwner : Object *
        userOptions : UserOptions -> bool
abstract Show :
        modalOwner : Object *
        userOptions : UserOptions -> bool
override Show :
        modalOwner : Object *
        userOptions : UserOptions -> bool
Parameters
modalOwner (Object)
userOptions (UserOptions)
Return Value
Boolean


ShowCheckAsYouTypeOption Property

ShowCheckAsYouTypeOption Property
API ► Keyoti.RapidSpell.Wpf.Options ► OptionsPresenter ► ShowCheckAsYouTypeOption
Keyoti RapidSpell WPF
Whether to show the "Check as you type" option
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ShowCheckAsYouTypeOption { get; set; }
public bool ShowCheckAsYouTypeOption { get; set; }
Public Property ShowCheckAsYouTypeOption As Boolean
    Get
    Set
Public Property ShowCheckAsYouTypeOption As Boolean
    Get
    Set
public:
property bool ShowCheckAsYouTypeOption {
    bool get ();
    void set (bool value);
}
public:
property bool ShowCheckAsYouTypeOption {
    bool get ();
    void set (bool value);
}
member ShowCheckAsYouTypeOption : bool with get, set

member ShowCheckAsYouTypeOption : bool with get, set
Property Value
Boolean


ShowEditUserDictionaryFile Method (file)

ShowEditUserDictionaryFile Method (file)
API ► Keyoti.RapidSpell.Wpf.Options ► OptionsPresenter ► ShowEditUserDictionaryFile(String)
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void ShowEditUserDictionaryFile(
    string file
)
public void ShowEditUserDictionaryFile(
    string file
)
Public Sub ShowEditUserDictionaryFile (
    file As String
)
Public Sub ShowEditUserDictionaryFile (
    file As String
)
public:
void ShowEditUserDictionaryFile(
    String^ file
)
public:
void ShowEditUserDictionaryFile(
    String^ file
)
member ShowEditUserDictionaryFile :
        file : string -> unit

member ShowEditUserDictionaryFile :
        file : string -> unit
Parameters
file (String)


ShowFindSuggestionsOption Property

ShowFindSuggestionsOption Property
API ► Keyoti.RapidSpell.Wpf.Options ► OptionsPresenter ► ShowFindSuggestionsOption
Keyoti RapidSpell WPF
Whether to show the "Always find suggestions" option
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ShowFindSuggestionsOption { get; set; }
public bool ShowFindSuggestionsOption { get; set; }
Public Property ShowFindSuggestionsOption As Boolean
    Get
    Set
Public Property ShowFindSuggestionsOption As Boolean
    Get
    Set
public:
property bool ShowFindSuggestionsOption {
    bool get ();
    void set (bool value);
}
public:
property bool ShowFindSuggestionsOption {
    bool get ();
    void set (bool value);
}
member ShowFindSuggestionsOption : bool with get, set

member ShowFindSuggestionsOption : bool with get, set
Property Value
Boolean


ShowOptionForMultipleUserDictionaries Property

ShowOptionForMultipleUserDictionaries Property
API ► Keyoti.RapidSpell.Wpf.Options ► OptionsPresenter ► ShowOptionForMultipleUserDictionaries
Keyoti RapidSpell WPF
Whether to show add/remove user dictionaries form.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ShowOptionForMultipleUserDictionaries { get; set; }
public bool ShowOptionForMultipleUserDictionaries { get; set; }
Public Property ShowOptionForMultipleUserDictionaries As Boolean
    Get
    Set
Public Property ShowOptionForMultipleUserDictionaries As Boolean
    Get
    Set
public:
property bool ShowOptionForMultipleUserDictionaries {
    bool get ();
    void set (bool value);
}
public:
property bool ShowOptionForMultipleUserDictionaries {
    bool get ();
    void set (bool value);
}
member ShowOptionForMultipleUserDictionaries : bool with get, set

member ShowOptionForMultipleUserDictionaries : bool with get, set
Property Value
Boolean


ShowUserDictionaryButton Property

ShowUserDictionaryButton Property
API ► Keyoti.RapidSpell.Wpf.Options ► OptionsPresenter ► ShowUserDictionaryButton
Keyoti RapidSpell WPF
Whether to show the user dictionary button
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool ShowUserDictionaryButton { get; set; }
public bool ShowUserDictionaryButton { get; set; }
Public Property ShowUserDictionaryButton As Boolean
    Get
    Set
Public Property ShowUserDictionaryButton As Boolean
    Get
    Set
public:
property bool ShowUserDictionaryButton {
    bool get ();
    void set (bool value);
}
public:
property bool ShowUserDictionaryButton {
    bool get ();
    void set (bool value);
}
member ShowUserDictionaryButton : bool with get, set

member ShowUserDictionaryButton : bool with get, set
Property Value
Boolean


WordRemoved Event

WordRemoved Event
API ► Keyoti.RapidSpell.Wpf.Options ► OptionsPresenter ► WordRemoved
Keyoti RapidSpell WPF
Fired when a word is removed from user dictionary.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event WordRemovedEventHandler WordRemoved
public event WordRemovedEventHandler WordRemoved
Public Event WordRemoved As WordRemovedEventHandler
Public Event WordRemoved As WordRemovedEventHandler
public:
 event WordRemovedEventHandler^ WordRemoved {
    void add (WordRemovedEventHandler^ value);
    void remove (WordRemovedEventHandler^ value);
}
public:
 event WordRemovedEventHandler^ WordRemoved {
    void add (WordRemovedEventHandler^ value);
    void remove (WordRemovedEventHandler^ value);
}
member WordRemoved : IEvent<WordRemovedEventHandler,
    WordRemovedEventArgs>

member WordRemoved : IEvent<WordRemovedEventHandler,
    WordRemovedEventArgs>
Value
WordRemovedEventHandler


UserDictionaryContentChangedEventArgs Class

UserDictionaryContentChangedEventArgs Class
API ► Keyoti.RapidSpell.Wpf.Options ► UserDictionaryContentChangedEventArgs
Keyoti RapidSpell WPF
Event args
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class UserDictionaryContentChangedEventArgs
public class UserDictionaryContentChangedEventArgs
Public Class UserDictionaryContentChangedEventArgs
Public Class UserDictionaryContentChangedEventArgs
public ref class UserDictionaryContentChangedEventArgs
public ref class UserDictionaryContentChangedEventArgs
type UserDictionaryContentChangedEventArgs =  class end
type UserDictionaryContentChangedEventArgs =  class end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserDictionaryContentChangedEventArgs(List<(Of <<'(UserDictionary>)>>)) | New
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | UserDictionaries | List of dictionaries currently in use.
Inheritance Hierarchy
Object
UserDictionaryContentChangedEventArgs


UserDictionaryContentChangedEventArgs Constructor (dicts)

UserDictionaryContentChangedEventArgs Constructor (dicts)
API ► Keyoti.RapidSpell.Wpf.Options ► UserDictionaryContentChangedEventArgs ► UserDictionaryContentChangedEventArgs(List<(Of <<'(UserDictionary>)>>))
Keyoti RapidSpell WPF
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UserDictionaryContentChangedEventArgs(
    List<UserDictionary> dicts
)
public UserDictionaryContentChangedEventArgs(
    List<UserDictionary> dicts
)
Public Sub New (
    dicts As List(Of UserDictionary)
)
Public Sub New (
    dicts As List(Of UserDictionary)
)
public:
UserDictionaryContentChangedEventArgs(
    List<UserDictionary^>^ dicts
)
public:
UserDictionaryContentChangedEventArgs(
    List<UserDictionary^>^ dicts
)
new :
        dicts : List<UserDictionary> -> UserDictionaryContentChangedEventArgs
new :
        dicts : List<UserDictionary> -> UserDictionaryContentChangedEventArgs
Parameters
dicts (List<(Of <(<' UserDictionary >)>)>)


UserDictionaries Property

UserDictionaries Property
API ► Keyoti.RapidSpell.Wpf.Options ► UserDictionaryContentChangedEventArgs ► UserDictionaries
Keyoti RapidSpell WPF
List of dictionaries currently in use.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public List<UserDictionary> UserDictionaries { get; }
public List<UserDictionary> UserDictionaries { get; }
Public ReadOnly Property UserDictionaries As List(Of UserDictionary)
    Get
Public ReadOnly Property UserDictionaries As List(Of UserDictionary)
    Get
public:
property List<UserDictionary^>^ UserDictionaries {
    List<UserDictionary^>^ get ();
}
public:
property List<UserDictionary^>^ UserDictionaries {
    List<UserDictionary^>^ get ();
}
member UserDictionaries : List<UserDictionary> with get

member UserDictionaries : List<UserDictionary> with get
Property Value
List<(Of <(<' UserDictionary >)>)>


UserDictionaryDefaultChangeEventArgs Class

UserDictionaryDefaultChangeEventArgs Class
API ► Keyoti.RapidSpell.Wpf.Options ► UserDictionaryDefaultChangeEventArgs
Keyoti RapidSpell WPF
Event args
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class UserDictionaryDefaultChangeEventArgs
public class UserDictionaryDefaultChangeEventArgs
Public Class UserDictionaryDefaultChangeEventArgs
Public Class UserDictionaryDefaultChangeEventArgs
public ref class UserDictionaryDefaultChangeEventArgs
public ref class UserDictionaryDefaultChangeEventArgs
type UserDictionaryDefaultChangeEventArgs =  class end
type UserDictionaryDefaultChangeEventArgs =  class end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserDictionaryDefaultChangeEventArgs(String) | New
 | DefaultUserDictionaryItem | The default user dictionary path
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
UserDictionaryDefaultChangeEventArgs


UserDictionaryDefaultChangeEventArgs Constructor (defaultUserDictionaryItem)

UserDictionaryDefaultChangeEventArgs Constructor (defaultUserDictionaryItem)
API ► Keyoti.RapidSpell.Wpf.Options ► UserDictionaryDefaultChangeEventArgs ► UserDictionaryDefaultChangeEventArgs(String)
Keyoti RapidSpell WPF
New
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UserDictionaryDefaultChangeEventArgs(
    string defaultUserDictionaryItem
)
public UserDictionaryDefaultChangeEventArgs(
    string defaultUserDictionaryItem
)
Public Sub New (
    defaultUserDictionaryItem As String
)
Public Sub New (
    defaultUserDictionaryItem As String
)
public:
UserDictionaryDefaultChangeEventArgs(
    String^ defaultUserDictionaryItem
)
public:
UserDictionaryDefaultChangeEventArgs(
    String^ defaultUserDictionaryItem
)
new :
        defaultUserDictionaryItem : string -> UserDictionaryDefaultChangeEventArgs
new :
        defaultUserDictionaryItem : string -> UserDictionaryDefaultChangeEventArgs
Parameters
defaultUserDictionaryItem (String)
The default user dictionary path


DefaultUserDictionaryItem Property

DefaultUserDictionaryItem Property
API ► Keyoti.RapidSpell.Wpf.Options ► UserDictionaryDefaultChangeEventArgs ► DefaultUserDictionaryItem
Keyoti RapidSpell WPF
The default user dictionary path
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string DefaultUserDictionaryItem { get; }
public string DefaultUserDictionaryItem { get; }
Public ReadOnly Property DefaultUserDictionaryItem As String
    Get
Public ReadOnly Property DefaultUserDictionaryItem As String
    Get
public:
property String^ DefaultUserDictionaryItem {
    String^ get ();
}
public:
property String^ DefaultUserDictionaryItem {
    String^ get ();
}
member DefaultUserDictionaryItem : string with get

member DefaultUserDictionaryItem : string with get
Property Value
String


UserDictionaryEditEventArgs Class

UserDictionaryEditEventArgs Class
API ► Keyoti.RapidSpell.Wpf.Options ► UserDictionaryEditEventArgs
Keyoti RapidSpell WPF
Event args for a user dictionary edit event (add word, remove)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class UserDictionaryEditEventArgs
public class UserDictionaryEditEventArgs
Public Class UserDictionaryEditEventArgs
Public Class UserDictionaryEditEventArgs
public ref class UserDictionaryEditEventArgs
public ref class UserDictionaryEditEventArgs
type UserDictionaryEditEventArgs =  class end
type UserDictionaryEditEventArgs =  class end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserDictionaryEditEventArgs(UserDictionaryEditEventArgs..::..EditType, String) | New instance
 | Edit | The edit operation
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Word | The word in question
Inheritance Hierarchy
Object
UserDictionaryEditEventArgs


UserDictionaryEditEventArgs Constructor (edit, word)

UserDictionaryEditEventArgs Constructor (edit, word)
API ► Keyoti.RapidSpell.Wpf.Options ► UserDictionaryEditEventArgs ► UserDictionaryEditEventArgs(UserDictionaryEditEventArgs..::..EditType, String)
Keyoti RapidSpell WPF
New instance
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UserDictionaryEditEventArgs(
    UserDictionaryEditEventArgs..::..EditType edit,
    string word
)
public UserDictionaryEditEventArgs(
    UserDictionaryEditEventArgs..::..EditType edit,
    string word
)
Public Sub New (
    edit As UserDictionaryEditEventArgs..::..EditType,
    word As String
)
Public Sub New (
    edit As UserDictionaryEditEventArgs..::..EditType,
    word As String
)
public:
UserDictionaryEditEventArgs(
    UserDictionaryEditEventArgs..::..EditType edit,
    String^ word
)
public:
UserDictionaryEditEventArgs(
    UserDictionaryEditEventArgs..::..EditType edit,
    String^ word
)
new :
        edit : UserDictionaryEditEventArgs..::..EditType *
        word : string -> UserDictionaryEditEventArgs
new :
        edit : UserDictionaryEditEventArgs..::..EditType *
        word : string -> UserDictionaryEditEventArgs
Parameters
edit (UserDictionaryEditEventArgs..::..EditType)
The operation
word (String)
The word


Edit Property

Edit Property
API ► Keyoti.RapidSpell.Wpf.Options ► UserDictionaryEditEventArgs ► Edit
Keyoti RapidSpell WPF
The edit operation
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UserDictionaryEditEventArgs..::..EditType Edit { get; set; }
public UserDictionaryEditEventArgs..::..EditType Edit { get; set; }
Public Property Edit As UserDictionaryEditEventArgs..::..EditType
    Get
    Set
Public Property Edit As UserDictionaryEditEventArgs..::..EditType
    Get
    Set
public:
property UserDictionaryEditEventArgs..::..EditType Edit {
    UserDictionaryEditEventArgs..::..EditType get ();
    void set (UserDictionaryEditEventArgs..::..EditType value);
}
public:
property UserDictionaryEditEventArgs..::..EditType Edit {
    UserDictionaryEditEventArgs..::..EditType get ();
    void set (UserDictionaryEditEventArgs..::..EditType value);
}
member Edit : UserDictionaryEditEventArgs..::..EditType with get, set

member Edit : UserDictionaryEditEventArgs..::..EditType with get, set
Property Value
UserDictionaryEditEventArgs..::..EditType


Word Property

Word Property
API ► Keyoti.RapidSpell.Wpf.Options ► UserDictionaryEditEventArgs ► Word
Keyoti RapidSpell WPF
The word in question
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string Word { get; set; }
public string Word { get; set; }
Public Property Word As String
    Get
    Set
Public Property Word As String
    Get
    Set
public:
property String^ Word {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Word {
    String^ get ();
    void set (String^ value);
}
member Word : string with get, set

member Word : string with get, set
Property Value
String


UserDictionaryEditEventArgs.EditType Enumeration

UserDictionaryEditEventArgs..::..EditType Enumeration
API ► Keyoti.RapidSpell.Wpf.Options ► UserDictionaryEditEventArgs ► UserDictionaryEditEventArgs..::..EditType
Keyoti RapidSpell WPF
Types of edit operations
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public enum EditType
public enum EditType
Public Enumeration EditType
Public Enumeration EditType
public enum class EditType
public enum class EditType
type EditType
type EditType
Members
Member | Description
Add | Add a word
Remove | Remove a word


UserDictionaryEditEventHandler Delegate

UserDictionaryEditEventHandler Delegate
API ► Keyoti.RapidSpell.Wpf.Options ► UserDictionaryEditEventHandler
Keyoti RapidSpell WPF
Event handler delegate
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void UserDictionaryEditEventHandler(
    Object s,
    UserDictionaryEditEventArgs e
)
public delegate void UserDictionaryEditEventHandler(
    Object s,
    UserDictionaryEditEventArgs e
)
Public Delegate Sub UserDictionaryEditEventHandler (
    s As Object,
    e As UserDictionaryEditEventArgs
)
Public Delegate Sub UserDictionaryEditEventHandler (
    s As Object,
    e As UserDictionaryEditEventArgs
)
public delegate void UserDictionaryEditEventHandler(
    Object^ s,
    UserDictionaryEditEventArgs^ e
)
public delegate void UserDictionaryEditEventHandler(
    Object^ s,
    UserDictionaryEditEventArgs^ e
)
type UserDictionaryEditEventHandler =
    delegate of
        s : Object *
        e : UserDictionaryEditEventArgs -> unit
type UserDictionaryEditEventHandler =
    delegate of
        s : Object *
        e : UserDictionaryEditEventArgs -> unit
Parameters
s (Object)
e (UserDictionaryEditEventArgs)


UserDictionaryFormEventArgs Class

UserDictionaryFormEventArgs Class
API ► Keyoti.RapidSpell.Wpf.Options ► UserDictionaryFormEventArgs
Keyoti RapidSpell WPF
Event args for a user dictionary edit event (add word, remove)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class UserDictionaryFormEventArgs
public class UserDictionaryFormEventArgs
Public Class UserDictionaryFormEventArgs
Public Class UserDictionaryFormEventArgs
public ref class UserDictionaryFormEventArgs
public ref class UserDictionaryFormEventArgs
type UserDictionaryFormEventArgs =  class end
type UserDictionaryFormEventArgs =  class end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserDictionaryFormEventArgs(UserDictionaryFormEventArgs..::..EditType, String) | New instance
 | Edit | The edit operation
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | File | The word in question
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
UserDictionaryFormEventArgs


UserDictionaryFormEventArgs Constructor (edit, file)

UserDictionaryFormEventArgs Constructor (edit, file)
API ► Keyoti.RapidSpell.Wpf.Options ► UserDictionaryFormEventArgs ► UserDictionaryFormEventArgs(UserDictionaryFormEventArgs..::..EditType, String)
Keyoti RapidSpell WPF
New instance
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UserDictionaryFormEventArgs(
    UserDictionaryFormEventArgs..::..EditType edit,
    string file
)
public UserDictionaryFormEventArgs(
    UserDictionaryFormEventArgs..::..EditType edit,
    string file
)
Public Sub New (
    edit As UserDictionaryFormEventArgs..::..EditType,
    file As String
)
Public Sub New (
    edit As UserDictionaryFormEventArgs..::..EditType,
    file As String
)
public:
UserDictionaryFormEventArgs(
    UserDictionaryFormEventArgs..::..EditType edit,
    String^ file
)
public:
UserDictionaryFormEventArgs(
    UserDictionaryFormEventArgs..::..EditType edit,
    String^ file
)
new :
        edit : UserDictionaryFormEventArgs..::..EditType *
        file : string -> UserDictionaryFormEventArgs
new :
        edit : UserDictionaryFormEventArgs..::..EditType *
        file : string -> UserDictionaryFormEventArgs
Parameters
edit (UserDictionaryFormEventArgs..::..EditType)
The operation
file (String)


Edit Property

Edit Property
API ► Keyoti.RapidSpell.Wpf.Options ► UserDictionaryFormEventArgs ► Edit
Keyoti RapidSpell WPF
The edit operation
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UserDictionaryFormEventArgs..::..EditType Edit { get; set; }
public UserDictionaryFormEventArgs..::..EditType Edit { get; set; }
Public Property Edit As UserDictionaryFormEventArgs..::..EditType
    Get
    Set
Public Property Edit As UserDictionaryFormEventArgs..::..EditType
    Get
    Set
public:
property UserDictionaryFormEventArgs..::..EditType Edit {
    UserDictionaryFormEventArgs..::..EditType get ();
    void set (UserDictionaryFormEventArgs..::..EditType value);
}
public:
property UserDictionaryFormEventArgs..::..EditType Edit {
    UserDictionaryFormEventArgs..::..EditType get ();
    void set (UserDictionaryFormEventArgs..::..EditType value);
}
member Edit : UserDictionaryFormEventArgs..::..EditType with get, set

member Edit : UserDictionaryFormEventArgs..::..EditType with get, set
Property Value
UserDictionaryFormEventArgs..::..EditType


File Property

File Property
API ► Keyoti.RapidSpell.Wpf.Options ► UserDictionaryFormEventArgs ► File
Keyoti RapidSpell WPF
The word in question
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string File { get; set; }
public string File { get; set; }
Public Property File As String
    Get
    Set
Public Property File As String
    Get
    Set
public:
property String^ File {
    String^ get ();
    void set (String^ value);
}
public:
property String^ File {
    String^ get ();
    void set (String^ value);
}
member File : string with get, set

member File : string with get, set
Property Value
String


UserDictionaryFormEventArgs.EditType Enumeration

UserDictionaryFormEventArgs..::..EditType Enumeration
API ► Keyoti.RapidSpell.Wpf.Options ► UserDictionaryFormEventArgs ► UserDictionaryFormEventArgs..::..EditType
Keyoti RapidSpell WPF
Types of edit operations
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public enum EditType
public enum EditType
Public Enumeration EditType
Public Enumeration EditType
public enum class EditType
public enum class EditType
type EditType
type EditType
Members
Member | Description
Add | Add a file
Remove | Remove a file
Edit | Edit a file


UserDictionaryFormEventHandler Delegate

UserDictionaryFormEventHandler Delegate
API ► Keyoti.RapidSpell.Wpf.Options ► UserDictionaryFormEventHandler
Keyoti RapidSpell WPF
Event handler delegate
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void UserDictionaryFormEventHandler(
    Object s,
    UserDictionaryFormEventArgs e
)
public delegate void UserDictionaryFormEventHandler(
    Object s,
    UserDictionaryFormEventArgs e
)
Public Delegate Sub UserDictionaryFormEventHandler (
    s As Object,
    e As UserDictionaryFormEventArgs
)
Public Delegate Sub UserDictionaryFormEventHandler (
    s As Object,
    e As UserDictionaryFormEventArgs
)
public delegate void UserDictionaryFormEventHandler(
    Object^ s,
    UserDictionaryFormEventArgs^ e
)
public delegate void UserDictionaryFormEventHandler(
    Object^ s,
    UserDictionaryFormEventArgs^ e
)
type UserDictionaryFormEventHandler =
    delegate of
        s : Object *
        e : UserDictionaryFormEventArgs -> unit
type UserDictionaryFormEventHandler =
    delegate of
        s : Object *
        e : UserDictionaryFormEventArgs -> unit
Parameters
s (Object)
e (UserDictionaryFormEventArgs)


UserOptions Class

UserOptions Class
API ► Keyoti.RapidSpell.Wpf.Options ► UserOptions
Keyoti RapidSpell WPF
Holds/Loads/Saves user options.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public class UserOptions
public class UserOptions
Public Class UserOptions
Public Class UserOptions
public ref class UserOptions
public ref class UserOptions
type UserOptions =  class end
type UserOptions =  class end
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserOptions()()()() |
 | AllowAnyCase | (User option)
 | AllowMixedCase | (User option)
 | ChangeMaintainsCheckValidity()()()() | Whether any changes have caused the current spell check progress to be invalid (requiring reset of the spell checker).
 | CheckAsYouType | (User option) Check as you type option
 | Clone()()()() | Returns a copy of this object
 | CustomStreamForLoading | The stream to use when loading options
 | CustomStreamForSaving | The stream to use when saving options
 | Delete()()()() | Delete the user's settings
 | Enabled | Whether options are enabled
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FindSuggestions | (User option)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | IgnoreCapitalizedWords | (User option)
 | IgnoreURLsAndEmailAddresses | (User option)
 | IgnoreWordsWithDigits | (User option)
 | IncludeUserDictionaryInSuggestions | (User option)
 | Load()()()() | Load the user's settings
 | Load(Stream) | Load the users settings from userOptionsStream
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NeedCustomStreamForLoading | Fired when a custom stream can be set to load the options from.
 | NeedCustomStreamForSaving | Fired when a custom stream can be set to save the options to.
 | OnRecheckDocumentRequest(EventArgs) | Raises recheck document event
 | OptionsHaveChanged()()()() | Whether this and c are set with the same options.
 | OptionsSaved | Fired when the options are saved
 | RecheckDocumentRequest | Fired when the user requests the text to be rechecked
 | Save()()()() | Save user's settings
 | Save(Stream) | Save user's settings to stream
 | SetDefaultUserDictionaryFile(String) |
 | SetUserOptions(Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | Sets new settings
 | StorageLocation | Where the user's options are stored.
 | SupplementalUserDictionaryFiles | User chosen additional user dictionary files.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | UserDictionary | The user dictionary loaded for the user
 | UserDictionaryContentChanged | Fired when the user dictionary content has changed and should be reloaded.
 | UserDictionaryDefaultChanged | Fired when the default user dictionary is changed by the user.
 | UserOptionsFileName | The file name used to store the settings (by default in IsolatedStorage).
Inheritance Hierarchy
Object
UserOptions


UserOptions Constructor

UserOptions Constructor
API ► Keyoti.RapidSpell.Wpf.Options ► UserOptions ► UserOptions()()()()
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UserOptions()
public UserOptions()
Public Sub New
Public Sub New
public:
UserOptions()
public:
UserOptions()
new : unit -> UserOptions
new : unit -> UserOptions


AllowAnyCase Property

AllowAnyCase Property
API ► Keyoti.RapidSpell.Wpf.Options ► UserOptions ► AllowAnyCase
Keyoti RapidSpell WPF
(User option)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool AllowAnyCase { get; }
public bool AllowAnyCase { get; }
Public ReadOnly Property AllowAnyCase As Boolean
    Get
Public ReadOnly Property AllowAnyCase As Boolean
    Get
public:
property bool AllowAnyCase {
    bool get ();
}
public:
property bool AllowAnyCase {
    bool get ();
}
member AllowAnyCase : bool with get

member AllowAnyCase : bool with get
Property Value
Boolean


AllowMixedCase Property

AllowMixedCase Property
API ► Keyoti.RapidSpell.Wpf.Options ► UserOptions ► AllowMixedCase
Keyoti RapidSpell WPF
(User option)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool AllowMixedCase { get; }
public bool AllowMixedCase { get; }
Public ReadOnly Property AllowMixedCase As Boolean
    Get
Public ReadOnly Property AllowMixedCase As Boolean
    Get
public:
property bool AllowMixedCase {
    bool get ();
}
public:
property bool AllowMixedCase {
    bool get ();
}
member AllowMixedCase : bool with get

member AllowMixedCase : bool with get
Property Value
Boolean


ChangeMaintainsCheckValidity Method

ChangeMaintainsCheckValidity Method
API ► Keyoti.RapidSpell.Wpf.Options ► UserOptions ► ChangeMaintainsCheckValidity()()()()
Keyoti RapidSpell WPF
Whether any changes have caused the current spell check progress to be invalid (requiring reset of the spell checker).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool ChangeMaintainsCheckValidity()
public virtual bool ChangeMaintainsCheckValidity()
Public Overridable Function ChangeMaintainsCheckValidity As Boolean
Public Overridable Function ChangeMaintainsCheckValidity As Boolean
public:
virtual bool ChangeMaintainsCheckValidity()
public:
virtual bool ChangeMaintainsCheckValidity()
abstract ChangeMaintainsCheckValidity : unit -> bool
override ChangeMaintainsCheckValidity : unit -> bool
abstract ChangeMaintainsCheckValidity : unit -> bool
override ChangeMaintainsCheckValidity : unit -> bool
Return Value
Boolean


CheckAsYouType Property

CheckAsYouType Property
API ► Keyoti.RapidSpell.Wpf.Options ► UserOptions ► CheckAsYouType
Keyoti RapidSpell WPF
(User option) Check as you type option
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool CheckAsYouType { get; }
public bool CheckAsYouType { get; }
Public ReadOnly Property CheckAsYouType As Boolean
    Get
Public ReadOnly Property CheckAsYouType As Boolean
    Get
public:
property bool CheckAsYouType {
    bool get ();
}
public:
property bool CheckAsYouType {
    bool get ();
}
member CheckAsYouType : bool with get

member CheckAsYouType : bool with get
Property Value
Boolean


Clone Method

Clone Method
API ► Keyoti.RapidSpell.Wpf.Options ► UserOptions ► Clone()()()()
Keyoti RapidSpell WPF
Returns a copy of this object
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual UserOptions Clone()
public virtual UserOptions Clone()
Public Overridable Function Clone As UserOptions
Public Overridable Function Clone As UserOptions
public:
virtual UserOptions^ Clone()
public:
virtual UserOptions^ Clone()
abstract Clone : unit -> UserOptions
override Clone : unit -> UserOptions
abstract Clone : unit -> UserOptions
override Clone : unit -> UserOptions
Return Value
UserOptions


CustomStreamForLoading Property

CustomStreamForLoading Property
API ► Keyoti.RapidSpell.Wpf.Options ► UserOptions ► CustomStreamForLoading
Keyoti RapidSpell WPF
The stream to use when loading options
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Stream CustomStreamForLoading { get; set; }
public Stream CustomStreamForLoading { get; set; }
Public Property CustomStreamForLoading As Stream
    Get
    Set
Public Property CustomStreamForLoading As Stream
    Get
    Set
public:
property Stream^ CustomStreamForLoading {
    Stream^ get ();
    void set (Stream^ value);
}
public:
property Stream^ CustomStreamForLoading {
    Stream^ get ();
    void set (Stream^ value);
}
member CustomStreamForLoading : Stream with get, set

member CustomStreamForLoading : Stream with get, set
Property Value
Stream


CustomStreamForSaving Property

CustomStreamForSaving Property
API ► Keyoti.RapidSpell.Wpf.Options ► UserOptions ► CustomStreamForSaving
Keyoti RapidSpell WPF
The stream to use when saving options
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public Stream CustomStreamForSaving { get; set; }
public Stream CustomStreamForSaving { get; set; }
Public Property CustomStreamForSaving As Stream
    Get
    Set
Public Property CustomStreamForSaving As Stream
    Get
    Set
public:
property Stream^ CustomStreamForSaving {
    Stream^ get ();
    void set (Stream^ value);
}
public:
property Stream^ CustomStreamForSaving {
    Stream^ get ();
    void set (Stream^ value);
}
member CustomStreamForSaving : Stream with get, set

member CustomStreamForSaving : Stream with get, set
Property Value
Stream


Delete Method

Delete Method
API ► Keyoti.RapidSpell.Wpf.Options ► UserOptions ► Delete()()()()
Keyoti RapidSpell WPF
Delete the user's settings
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void Delete()
public void Delete()
Public Sub Delete
Public Sub Delete
public:
void Delete()
public:
void Delete()
member Delete : unit -> unit

member Delete : unit -> unit


Enabled Property

Enabled Property
API ► Keyoti.RapidSpell.Wpf.Options ► UserOptions ► Enabled
Keyoti RapidSpell WPF
Whether options are enabled
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool Enabled { get; set; }
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
member Enabled : bool with get, set

member Enabled : bool with get, set
Property Value
Boolean


FindSuggestions Property

FindSuggestions Property
API ► Keyoti.RapidSpell.Wpf.Options ► UserOptions ► FindSuggestions
Keyoti RapidSpell WPF
(User option)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool FindSuggestions { get; }
public bool FindSuggestions { get; }
Public ReadOnly Property FindSuggestions As Boolean
    Get
Public ReadOnly Property FindSuggestions As Boolean
    Get
public:
property bool FindSuggestions {
    bool get ();
}
public:
property bool FindSuggestions {
    bool get ();
}
member FindSuggestions : bool with get

member FindSuggestions : bool with get
Property Value
Boolean


IgnoreCapitalizedWords Property

IgnoreCapitalizedWords Property
API ► Keyoti.RapidSpell.Wpf.Options ► UserOptions ► IgnoreCapitalizedWords
Keyoti RapidSpell WPF
(User option)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreCapitalizedWords { get; }
public bool IgnoreCapitalizedWords { get; }
Public ReadOnly Property IgnoreCapitalizedWords As Boolean
    Get
Public ReadOnly Property IgnoreCapitalizedWords As Boolean
    Get
public:
property bool IgnoreCapitalizedWords {
    bool get ();
}
public:
property bool IgnoreCapitalizedWords {
    bool get ();
}
member IgnoreCapitalizedWords : bool with get

member IgnoreCapitalizedWords : bool with get
Property Value
Boolean


IgnoreURLsAndEmailAddresses Property

IgnoreURLsAndEmailAddresses Property
API ► Keyoti.RapidSpell.Wpf.Options ► UserOptions ► IgnoreURLsAndEmailAddresses
Keyoti RapidSpell WPF
(User option)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreURLsAndEmailAddresses { get; }
public bool IgnoreURLsAndEmailAddresses { get; }
Public ReadOnly Property IgnoreURLsAndEmailAddresses As Boolean
    Get
Public ReadOnly Property IgnoreURLsAndEmailAddresses As Boolean
    Get
public:
property bool IgnoreURLsAndEmailAddresses {
    bool get ();
}
public:
property bool IgnoreURLsAndEmailAddresses {
    bool get ();
}
member IgnoreURLsAndEmailAddresses : bool with get

member IgnoreURLsAndEmailAddresses : bool with get
Property Value
Boolean


IgnoreWordsWithDigits Property

IgnoreWordsWithDigits Property
API ► Keyoti.RapidSpell.Wpf.Options ► UserOptions ► IgnoreWordsWithDigits
Keyoti RapidSpell WPF
(User option)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IgnoreWordsWithDigits { get; }
public bool IgnoreWordsWithDigits { get; }
Public ReadOnly Property IgnoreWordsWithDigits As Boolean
    Get
Public ReadOnly Property IgnoreWordsWithDigits As Boolean
    Get
public:
property bool IgnoreWordsWithDigits {
    bool get ();
}
public:
property bool IgnoreWordsWithDigits {
    bool get ();
}
member IgnoreWordsWithDigits : bool with get

member IgnoreWordsWithDigits : bool with get
Property Value
Boolean


IncludeUserDictionaryInSuggestions Property

IncludeUserDictionaryInSuggestions Property
API ► Keyoti.RapidSpell.Wpf.Options ► UserOptions ► IncludeUserDictionaryInSuggestions
Keyoti RapidSpell WPF
(User option)
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public bool IncludeUserDictionaryInSuggestions { get; }
public bool IncludeUserDictionaryInSuggestions { get; }
Public ReadOnly Property IncludeUserDictionaryInSuggestions As Boolean
    Get
Public ReadOnly Property IncludeUserDictionaryInSuggestions As Boolean
    Get
public:
property bool IncludeUserDictionaryInSuggestions {
    bool get ();
}
public:
property bool IncludeUserDictionaryInSuggestions {
    bool get ();
}
member IncludeUserDictionaryInSuggestions : bool with get

member IncludeUserDictionaryInSuggestions : bool with get
Property Value
Boolean


Load Method

Load Method
API ► Keyoti.RapidSpell.Wpf.Options ► UserOptions ► Load()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | Load()()()() | Load the user's settings
 | Load(Stream) | Load the users settings from userOptionsStream


Load Method

Load Method
API ► Keyoti.RapidSpell.Wpf.Options ► UserOptions ► Load()()()()
Keyoti RapidSpell WPF
Load the user's settings
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void Load()
public void Load()
Public Sub Load
Public Sub Load
public:
void Load()
public:
void Load()
member Load : unit -> unit

member Load : unit -> unit


Load Method (userOptionsStream)

Load Method (userOptionsStream)
API ► Keyoti.RapidSpell.Wpf.Options ► UserOptions ► Load(Stream)
Keyoti RapidSpell WPF
Load the users settings from userOptionsStream
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void Load(
    Stream userOptionsStream
)
public virtual void Load(
    Stream userOptionsStream
)
Public Overridable Sub Load (
    userOptionsStream As Stream
)
Public Overridable Sub Load (
    userOptionsStream As Stream
)
public:
virtual void Load(
    Stream^ userOptionsStream
)
public:
virtual void Load(
    Stream^ userOptionsStream
)
abstract Load :
        userOptionsStream : Stream -> unit
override Load :
        userOptionsStream : Stream -> unit
abstract Load :
        userOptionsStream : Stream -> unit
override Load :
        userOptionsStream : Stream -> unit
Parameters
userOptionsStream (Stream)
XML file stream containing options


NeedCustomStreamForLoading Event

NeedCustomStreamForLoading Event
API ► Keyoti.RapidSpell.Wpf.Options ► UserOptions ► NeedCustomStreamForLoading
Keyoti RapidSpell WPF
Fired when a custom stream can be set to load the options from.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event UserOptions..::..NeedStreamEventHandler NeedCustomStreamForLoading
public event UserOptions..::..NeedStreamEventHandler NeedCustomStreamForLoading
Public Event NeedCustomStreamForLoading As UserOptions..::..NeedStreamEventHandler
Public Event NeedCustomStreamForLoading As UserOptions..::..NeedStreamEventHandler
public:
 event UserOptions..::..NeedStreamEventHandler^ NeedCustomStreamForLoading {
    void add (UserOptions..::..NeedStreamEventHandler^ value);
    void remove (UserOptions..::..NeedStreamEventHandler^ value);
}
public:
 event UserOptions..::..NeedStreamEventHandler^ NeedCustomStreamForLoading {
    void add (UserOptions..::..NeedStreamEventHandler^ value);
    void remove (UserOptions..::..NeedStreamEventHandler^ value);
}
member NeedCustomStreamForLoading : IEvent<UserOptions..::..NeedStreamEventHandler,
    NeedStreamEventArgs>

member NeedCustomStreamForLoading : IEvent<UserOptions..::..NeedStreamEventHandler,
    NeedStreamEventArgs>
Value
UserOptions..::..NeedStreamEventHandler


NeedCustomStreamForSaving Event

NeedCustomStreamForSaving Event
API ► Keyoti.RapidSpell.Wpf.Options ► UserOptions ► NeedCustomStreamForSaving
Keyoti RapidSpell WPF
Fired when a custom stream can be set to save the options to.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event UserOptions..::..NeedStreamEventHandler NeedCustomStreamForSaving
public event UserOptions..::..NeedStreamEventHandler NeedCustomStreamForSaving
Public Event NeedCustomStreamForSaving As UserOptions..::..NeedStreamEventHandler
Public Event NeedCustomStreamForSaving As UserOptions..::..NeedStreamEventHandler
public:
 event UserOptions..::..NeedStreamEventHandler^ NeedCustomStreamForSaving {
    void add (UserOptions..::..NeedStreamEventHandler^ value);
    void remove (UserOptions..::..NeedStreamEventHandler^ value);
}
public:
 event UserOptions..::..NeedStreamEventHandler^ NeedCustomStreamForSaving {
    void add (UserOptions..::..NeedStreamEventHandler^ value);
    void remove (UserOptions..::..NeedStreamEventHandler^ value);
}
member NeedCustomStreamForSaving : IEvent<UserOptions..::..NeedStreamEventHandler,
    NeedStreamEventArgs>

member NeedCustomStreamForSaving : IEvent<UserOptions..::..NeedStreamEventHandler,
    NeedStreamEventArgs>
Value
UserOptions..::..NeedStreamEventHandler


OnRecheckDocumentRequest Method (e)

OnRecheckDocumentRequest Method (e)
API ► Keyoti.RapidSpell.Wpf.Options ► UserOptions ► OnRecheckDocumentRequest(EventArgs)
Keyoti RapidSpell WPF
Raises recheck document event
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void OnRecheckDocumentRequest(
    EventArgs e
)
public void OnRecheckDocumentRequest(
    EventArgs e
)
Public Sub OnRecheckDocumentRequest (
    e As EventArgs
)
Public Sub OnRecheckDocumentRequest (
    e As EventArgs
)
public:
void OnRecheckDocumentRequest(
    EventArgs^ e
)
public:
void OnRecheckDocumentRequest(
    EventArgs^ e
)
member OnRecheckDocumentRequest :
        e : EventArgs -> unit

member OnRecheckDocumentRequest :
        e : EventArgs -> unit
Parameters
e (EventArgs)


OptionsHaveChanged Method

OptionsHaveChanged Method
API ► Keyoti.RapidSpell.Wpf.Options ► UserOptions ► OptionsHaveChanged()()()()
Keyoti RapidSpell WPF
Whether this and c are set with the same options.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual bool OptionsHaveChanged()
public virtual bool OptionsHaveChanged()
Public Overridable Function OptionsHaveChanged As Boolean
Public Overridable Function OptionsHaveChanged As Boolean
public:
virtual bool OptionsHaveChanged()
public:
virtual bool OptionsHaveChanged()
abstract OptionsHaveChanged : unit -> bool
override OptionsHaveChanged : unit -> bool
abstract OptionsHaveChanged : unit -> bool
override OptionsHaveChanged : unit -> bool
Return Value
Boolean


OptionsSaved Event

OptionsSaved Event
API ► Keyoti.RapidSpell.Wpf.Options ► UserOptions ► OptionsSaved
Keyoti RapidSpell WPF
Fired when the options are saved
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event OptionsSavedEventHandler OptionsSaved
public event OptionsSavedEventHandler OptionsSaved
Public Event OptionsSaved As OptionsSavedEventHandler
Public Event OptionsSaved As OptionsSavedEventHandler
public:
 event OptionsSavedEventHandler^ OptionsSaved {
    void add (OptionsSavedEventHandler^ value);
    void remove (OptionsSavedEventHandler^ value);
}
public:
 event OptionsSavedEventHandler^ OptionsSaved {
    void add (OptionsSavedEventHandler^ value);
    void remove (OptionsSavedEventHandler^ value);
}
member OptionsSaved : IEvent<OptionsSavedEventHandler,
    OptionsSavedEventArgs>

member OptionsSaved : IEvent<OptionsSavedEventHandler,
    OptionsSavedEventArgs>
Value
OptionsSavedEventHandler


RecheckDocumentRequest Event

RecheckDocumentRequest Event
API ► Keyoti.RapidSpell.Wpf.Options ► UserOptions ► RecheckDocumentRequest
Keyoti RapidSpell WPF
Fired when the user requests the text to be rechecked
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event EventHandler RecheckDocumentRequest
public event EventHandler RecheckDocumentRequest
Public Event RecheckDocumentRequest As EventHandler
Public Event RecheckDocumentRequest As EventHandler
public:
 event EventHandler^ RecheckDocumentRequest {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
 event EventHandler^ RecheckDocumentRequest {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member RecheckDocumentRequest : IEvent<EventHandler,
    EventArgs>

member RecheckDocumentRequest : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


Save Method

Save Method
API ► Keyoti.RapidSpell.Wpf.Options ► UserOptions ► Save()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | Save()()()() | Save user's settings
 | Save(Stream) | Save user's settings to stream


Save Method

Save Method
API ► Keyoti.RapidSpell.Wpf.Options ► UserOptions ► Save()()()()
Keyoti RapidSpell WPF
Save user's settings
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void Save()
public void Save()
Public Sub Save
Public Sub Save
public:
void Save()
public:
void Save()
member Save : unit -> unit

member Save : unit -> unit


Save Method (stream)

Save Method (stream)
API ► Keyoti.RapidSpell.Wpf.Options ► UserOptions ► Save(Stream)
Keyoti RapidSpell WPF
Save user's settings to stream
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void Save(
    Stream stream
)
public virtual void Save(
    Stream stream
)
Public Overridable Sub Save (
    stream As Stream
)
Public Overridable Sub Save (
    stream As Stream
)
public:
virtual void Save(
    Stream^ stream
)
public:
virtual void Save(
    Stream^ stream
)
abstract Save :
        stream : Stream -> unit
override Save :
        stream : Stream -> unit
abstract Save :
        stream : Stream -> unit
override Save :
        stream : Stream -> unit
Parameters
stream (Stream)


SetDefaultUserDictionaryFile Method (defaultUserDictionaryItem)

SetDefaultUserDictionaryFile Method (defaultUserDictionaryItem)
API ► Keyoti.RapidSpell.Wpf.Options ► UserOptions ► SetDefaultUserDictionaryFile(String)
Keyoti RapidSpell WPF
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public void SetDefaultUserDictionaryFile(
    string defaultUserDictionaryItem
)
public void SetDefaultUserDictionaryFile(
    string defaultUserDictionaryItem
)
Public Sub SetDefaultUserDictionaryFile (
    defaultUserDictionaryItem As String
)
Public Sub SetDefaultUserDictionaryFile (
    defaultUserDictionaryItem As String
)
public:
void SetDefaultUserDictionaryFile(
    String^ defaultUserDictionaryItem
)
public:
void SetDefaultUserDictionaryFile(
    String^ defaultUserDictionaryItem
)
member SetDefaultUserDictionaryFile :
        defaultUserDictionaryItem : string -> unit

member SetDefaultUserDictionaryFile :
        defaultUserDictionaryItem : string -> unit
Parameters
defaultUserDictionaryItem (String)


SetUserOptions Method (checkAsYouType, includeUserDictionaryInSuggestions, ignoreWordsWithDigits, ignoreURLsAndEmailAddresses, ignoreCapitalizedWords, allowMixedCase, allowAnyCase, findSuggestions, isTrackPoint)

SetUserOptions Method (checkAsYouType, includeUserDictionaryInSuggestions, ignoreWordsWithDigits, ignoreURLsAndEmailAddresses, ignoreCapitalizedWords, allowMixedCase, allowAnyCase, findSuggestions, isTrackPoint)
API ► Keyoti.RapidSpell.Wpf.Options ► UserOptions ► SetUserOptions(Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean)
Keyoti RapidSpell WPF
Sets new settings
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public virtual void SetUserOptions(
    bool checkAsYouType,
    bool includeUserDictionaryInSuggestions,
    bool ignoreWordsWithDigits,
    bool ignoreURLsAndEmailAddresses,
    bool ignoreCapitalizedWords,
    bool allowMixedCase,
    bool allowAnyCase,
    bool findSuggestions,
    bool isTrackPoint
)
public virtual void SetUserOptions(
    bool checkAsYouType,
    bool includeUserDictionaryInSuggestions,
    bool ignoreWordsWithDigits,
    bool ignoreURLsAndEmailAddresses,
    bool ignoreCapitalizedWords,
    bool allowMixedCase,
    bool allowAnyCase,
    bool findSuggestions,
    bool isTrackPoint
)
Public Overridable Sub SetUserOptions (
    checkAsYouType As Boolean,
    includeUserDictionaryInSuggestions As Boolean,
    ignoreWordsWithDigits As Boolean,
    ignoreURLsAndEmailAddresses As Boolean,
    ignoreCapitalizedWords As Boolean,
    allowMixedCase As Boolean,
    allowAnyCase As Boolean,
    findSuggestions As Boolean,
    isTrackPoint As Boolean
)
Public Overridable Sub SetUserOptions (
    checkAsYouType As Boolean,
    includeUserDictionaryInSuggestions As Boolean,
    ignoreWordsWithDigits As Boolean,
    ignoreURLsAndEmailAddresses As Boolean,
    ignoreCapitalizedWords As Boolean,
    allowMixedCase As Boolean,
    allowAnyCase As Boolean,
    findSuggestions As Boolean,
    isTrackPoint As Boolean
)
public:
virtual void SetUserOptions(
    bool checkAsYouType,
    bool includeUserDictionaryInSuggestions,
    bool ignoreWordsWithDigits,
    bool ignoreURLsAndEmailAddresses,
    bool ignoreCapitalizedWords,
    bool allowMixedCase,
    bool allowAnyCase,
    bool findSuggestions,
    bool isTrackPoint
)
public:
virtual void SetUserOptions(
    bool checkAsYouType,
    bool includeUserDictionaryInSuggestions,
    bool ignoreWordsWithDigits,
    bool ignoreURLsAndEmailAddresses,
    bool ignoreCapitalizedWords,
    bool allowMixedCase,
    bool allowAnyCase,
    bool findSuggestions,
    bool isTrackPoint
)
abstract SetUserOptions :
        checkAsYouType : bool *
        includeUserDictionaryInSuggestions : bool *
        ignoreWordsWithDigits : bool *
        ignoreURLsAndEmailAddresses : bool *
        ignoreCapitalizedWords : bool *
        allowMixedCase : bool *
        allowAnyCase : bool *
        findSuggestions : bool *
        isTrackPoint : bool -> unit
override SetUserOptions :
        checkAsYouType : bool *
        includeUserDictionaryInSuggestions : bool *
        ignoreWordsWithDigits : bool *
        ignoreURLsAndEmailAddresses : bool *
        ignoreCapitalizedWords : bool *
        allowMixedCase : bool *
        allowAnyCase : bool *
        findSuggestions : bool *
        isTrackPoint : bool -> unit
abstract SetUserOptions :
        checkAsYouType : bool *
        includeUserDictionaryInSuggestions : bool *
        ignoreWordsWithDigits : bool *
        ignoreURLsAndEmailAddresses : bool *
        ignoreCapitalizedWords : bool *
        allowMixedCase : bool *
        allowAnyCase : bool *
        findSuggestions : bool *
        isTrackPoint : bool -> unit
override SetUserOptions :
        checkAsYouType : bool *
        includeUserDictionaryInSuggestions : bool *
        ignoreWordsWithDigits : bool *
        ignoreURLsAndEmailAddresses : bool *
        ignoreCapitalizedWords : bool *
        allowMixedCase : bool *
        allowAnyCase : bool *
        findSuggestions : bool *
        isTrackPoint : bool -> unit
Parameters
checkAsYouType (Boolean)
includeUserDictionaryInSuggestions (Boolean)
ignoreWordsWithDigits (Boolean)
ignoreURLsAndEmailAddresses (Boolean)
ignoreCapitalizedWords (Boolean)
allowMixedCase (Boolean)
allowAnyCase (Boolean)
findSuggestions (Boolean)
isTrackPoint (Boolean)
Remarks
Set isTrackPoint to true in order to monitor changes from this point until Save is called. See OptionsSavedEventArgs for indicator for change since track point. If you set the options through SetUserOptions, then passing isTrackPoint==false will mean that when Save is called, an event is fired for the property changes (causing the body text to be rechecked with the new settings). If isTrackPoint==true then it will think those settings are the original settings and no event will be fired on Save.


StorageLocation Property

StorageLocation Property
API ► Keyoti.RapidSpell.Wpf.Options ► UserOptions ► StorageLocation
Keyoti RapidSpell WPF
Where the user's options are stored.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UserOptions..::..StorageType StorageLocation { get; set; }
public UserOptions..::..StorageType StorageLocation { get; set; }
Public Property StorageLocation As UserOptions..::..StorageType
    Get
    Set
Public Property StorageLocation As UserOptions..::..StorageType
    Get
    Set
public:
property UserOptions..::..StorageType StorageLocation {
    UserOptions..::..StorageType get ();
    void set (UserOptions..::..StorageType value);
}
public:
property UserOptions..::..StorageType StorageLocation {
    UserOptions..::..StorageType get ();
    void set (UserOptions..::..StorageType value);
}
member StorageLocation : UserOptions..::..StorageType with get, set

member StorageLocation : UserOptions..::..StorageType with get, set
Property Value
UserOptions..::..StorageType


SupplementalUserDictionaryFiles Property

SupplementalUserDictionaryFiles Property
API ► Keyoti.RapidSpell.Wpf.Options ► UserOptions ► SupplementalUserDictionaryFiles
Keyoti RapidSpell WPF
User chosen additional user dictionary files.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public List<string> SupplementalUserDictionaryFiles { get; }
public List<string> SupplementalUserDictionaryFiles { get; }
Public ReadOnly Property SupplementalUserDictionaryFiles As List(Of String)
    Get
Public ReadOnly Property SupplementalUserDictionaryFiles As List(Of String)
    Get
public:
property List<String^>^ SupplementalUserDictionaryFiles {
    List<String^>^ get ();
}
public:
property List<String^>^ SupplementalUserDictionaryFiles {
    List<String^>^ get ();
}
member SupplementalUserDictionaryFiles : List<string> with get

member SupplementalUserDictionaryFiles : List<string> with get
Property Value
List<(Of <(<'String>)>)>


UserDictionary Property

UserDictionary Property
API ► Keyoti.RapidSpell.Wpf.Options ► UserOptions ► UserDictionary
Keyoti RapidSpell WPF
The user dictionary loaded for the user
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public UserDictionary UserDictionary { get; set; }
public UserDictionary UserDictionary { get; set; }
Public Property UserDictionary As UserDictionary
    Get
    Set
Public Property UserDictionary As UserDictionary
    Get
    Set
public:
property UserDictionary^ UserDictionary {
    UserDictionary^ get ();
    void set (UserDictionary^ value);
}
public:
property UserDictionary^ UserDictionary {
    UserDictionary^ get ();
    void set (UserDictionary^ value);
}
member UserDictionary : UserDictionary with get, set

member UserDictionary : UserDictionary with get, set
Property Value
UserDictionary


UserDictionaryContentChanged Event

UserDictionaryContentChanged Event
API ► Keyoti.RapidSpell.Wpf.Options ► UserOptions ► UserDictionaryContentChanged
Keyoti RapidSpell WPF
Fired when the user dictionary content has changed and should be reloaded.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event UserOptions..::..UserDictionaryContentChangeEventHandler UserDictionaryContentChanged
public event UserOptions..::..UserDictionaryContentChangeEventHandler UserDictionaryContentChanged
Public Event UserDictionaryContentChanged As UserOptions..::..UserDictionaryContentChangeEventHandler
Public Event UserDictionaryContentChanged As UserOptions..::..UserDictionaryContentChangeEventHandler
public:
 event UserOptions..::..UserDictionaryContentChangeEventHandler^ UserDictionaryContentChanged {
    void add (UserOptions..::..UserDictionaryContentChangeEventHandler^ value);
    void remove (UserOptions..::..UserDictionaryContentChangeEventHandler^ value);
}
public:
 event UserOptions..::..UserDictionaryContentChangeEventHandler^ UserDictionaryContentChanged {
    void add (UserOptions..::..UserDictionaryContentChangeEventHandler^ value);
    void remove (UserOptions..::..UserDictionaryContentChangeEventHandler^ value);
}
member UserDictionaryContentChanged : IEvent<UserOptions..::..UserDictionaryContentChangeEventHandler,
    UserDictionaryContentChangedEventArgs>

member UserDictionaryContentChanged : IEvent<UserOptions..::..UserDictionaryContentChangeEventHandler,
    UserDictionaryContentChangedEventArgs>
Value
UserOptions..::..UserDictionaryContentChangeEventHandler


UserDictionaryDefaultChanged Event

UserDictionaryDefaultChanged Event
API ► Keyoti.RapidSpell.Wpf.Options ► UserOptions ► UserDictionaryDefaultChanged
Keyoti RapidSpell WPF
Fired when the default user dictionary is changed by the user.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public event UserOptions..::..UserDictionaryDefaultChangeEventHandler UserDictionaryDefaultChanged
public event UserOptions..::..UserDictionaryDefaultChangeEventHandler UserDictionaryDefaultChanged
Public Event UserDictionaryDefaultChanged As UserOptions..::..UserDictionaryDefaultChangeEventHandler
Public Event UserDictionaryDefaultChanged As UserOptions..::..UserDictionaryDefaultChangeEventHandler
public:
 event UserOptions..::..UserDictionaryDefaultChangeEventHandler^ UserDictionaryDefaultChanged {
    void add (UserOptions..::..UserDictionaryDefaultChangeEventHandler^ value);
    void remove (UserOptions..::..UserDictionaryDefaultChangeEventHandler^ value);
}
public:
 event UserOptions..::..UserDictionaryDefaultChangeEventHandler^ UserDictionaryDefaultChanged {
    void add (UserOptions..::..UserDictionaryDefaultChangeEventHandler^ value);
    void remove (UserOptions..::..UserDictionaryDefaultChangeEventHandler^ value);
}
member UserDictionaryDefaultChanged : IEvent<UserOptions..::..UserDictionaryDefaultChangeEventHandler,
    UserDictionaryDefaultChangeEventArgs>

member UserDictionaryDefaultChanged : IEvent<UserOptions..::..UserDictionaryDefaultChangeEventHandler,
    UserDictionaryDefaultChangeEventArgs>
Value
UserOptions..::..UserDictionaryDefaultChangeEventHandler


UserOptionsFileName Property

UserOptionsFileName Property
API ► Keyoti.RapidSpell.Wpf.Options ► UserOptions ► UserOptionsFileName
Keyoti RapidSpell WPF
The file name used to store the settings (by default in IsolatedStorage).
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public string UserOptionsFileName { get; set; }
public string UserOptionsFileName { get; set; }
Public Property UserOptionsFileName As String
    Get
    Set
Public Property UserOptionsFileName As String
    Get
    Set
public:
property String^ UserOptionsFileName {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserOptionsFileName {
    String^ get ();
    void set (String^ value);
}
member UserOptionsFileName : string with get, set

member UserOptionsFileName : string with get, set
Property Value
String
Remarks
Changing this can ensure different applications have unique user settings.


UserOptions.NeedStreamEventHandler Delegate

UserOptions..::..NeedStreamEventHandler Delegate
API ► Keyoti.RapidSpell.Wpf.Options ► UserOptions ► UserOptions..::..NeedStreamEventHandler
Keyoti RapidSpell WPF
Delegate for need stream events.
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void NeedStreamEventHandler(
    Object sender,
    NeedStreamEventArgs e
)
public delegate void NeedStreamEventHandler(
    Object sender,
    NeedStreamEventArgs e
)
Public Delegate Sub NeedStreamEventHandler (
    sender As Object,
    e As NeedStreamEventArgs
)
Public Delegate Sub NeedStreamEventHandler (
    sender As Object,
    e As NeedStreamEventArgs
)
public delegate void NeedStreamEventHandler(
    Object^ sender,
    NeedStreamEventArgs^ e
)
public delegate void NeedStreamEventHandler(
    Object^ sender,
    NeedStreamEventArgs^ e
)
type NeedStreamEventHandler =
    delegate of
        sender : Object *
        e : NeedStreamEventArgs -> unit
type NeedStreamEventHandler =
    delegate of
        sender : Object *
        e : NeedStreamEventArgs -> unit
Parameters
sender (Object)
e (NeedStreamEventArgs)


UserOptions.StorageType Enumeration

UserOptions..::..StorageType Enumeration
API ► Keyoti.RapidSpell.Wpf.Options ► UserOptions ► UserOptions..::..StorageType
Keyoti RapidSpell WPF
The option storage location
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public enum StorageType
public enum StorageType
Public Enumeration StorageType
Public Enumeration StorageType
public enum class StorageType
public enum class StorageType
type StorageType
type StorageType
Members
Member | Description
IsolatedStorage | The .NET isolated storage mechanism
FileSystem | The regular file-system
Stream | A stream provided by the API user


UserOptions.UserDictionaryContentChangeEventHandler Delegate

UserOptions..::..UserDictionaryContentChangeEventHandler Delegate
API ► Keyoti.RapidSpell.Wpf.Options ► UserOptions ► UserOptions..::..UserDictionaryContentChangeEventHandler
Keyoti RapidSpell WPF
Handler delegate
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void UserDictionaryContentChangeEventHandler(
    Object sender,
    UserDictionaryContentChangedEventArgs e
)
public delegate void UserDictionaryContentChangeEventHandler(
    Object sender,
    UserDictionaryContentChangedEventArgs e
)
Public Delegate Sub UserDictionaryContentChangeEventHandler (
    sender As Object,
    e As UserDictionaryContentChangedEventArgs
)
Public Delegate Sub UserDictionaryContentChangeEventHandler (
    sender As Object,
    e As UserDictionaryContentChangedEventArgs
)
public delegate void UserDictionaryContentChangeEventHandler(
    Object^ sender,
    UserDictionaryContentChangedEventArgs^ e
)
public delegate void UserDictionaryContentChangeEventHandler(
    Object^ sender,
    UserDictionaryContentChangedEventArgs^ e
)
type UserDictionaryContentChangeEventHandler =
    delegate of
        sender : Object *
        e : UserDictionaryContentChangedEventArgs -> unit
type UserDictionaryContentChangeEventHandler =
    delegate of
        sender : Object *
        e : UserDictionaryContentChangedEventArgs -> unit
Parameters
sender (Object)
e (UserDictionaryContentChangedEventArgs)


UserOptions.UserDictionaryDefaultChangeEventHandler Delegate

UserOptions..::..UserDictionaryDefaultChangeEventHandler Delegate
API ► Keyoti.RapidSpell.Wpf.Options ► UserOptions ► UserOptions..::..UserDictionaryDefaultChangeEventHandler
Keyoti RapidSpell WPF
Handler delegate
Declaration Syntax
C# C# Visual Basic Visual Basic Visual C++ Visual C++ F# F#
public delegate void UserDictionaryDefaultChangeEventHandler(
    Object sender,
    UserDictionaryDefaultChangeEventArgs e
)
public delegate void UserDictionaryDefaultChangeEventHandler(
    Object sender,
    UserDictionaryDefaultChangeEventArgs e
)
Public Delegate Sub UserDictionaryDefaultChangeEventHandler (
    sender As Object,
    e As UserDictionaryDefaultChangeEventArgs
)
Public Delegate Sub UserDictionaryDefaultChangeEventHandler (
    sender As Object,
    e As UserDictionaryDefaultChangeEventArgs
)
public delegate void UserDictionaryDefaultChangeEventHandler(
    Object^ sender,
    UserDictionaryDefaultChangeEventArgs^ e
)
public delegate void UserDictionaryDefaultChangeEventHandler(
    Object^ sender,
    UserDictionaryDefaultChangeEventArgs^ e
)
type UserDictionaryDefaultChangeEventHandler =
    delegate of
        sender : Object *
        e : UserDictionaryDefaultChangeEventArgs -> unit
type UserDictionaryDefaultChangeEventHandler =
    delegate of
        sender : Object *
        e : UserDictionaryDefaultChangeEventArgs -> unit
Parameters
sender (Object)
e (UserDictionaryDefaultChangeEventArgs)


HitTestCore Method

HitTestCore Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► HitTestCore()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | HitTestCore(PointHitTestParameters) | (Overrides Visual.HitTestCore(PointHitTestParameters).)
 | HitTestCore(GeometryHitTestParameters) | (Overrides Visual.HitTestCore(GeometryHitTestParameters).)


HitTestCore Method

HitTestCore Method
API ► Keyoti.RapidSpell.Wpf ► DesignableComponent ► HitTestCore()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | HitTestCore(PointHitTestParameters) | (Overrides Visual.HitTestCore(PointHitTestParameters).)
 | HitTestCore(GeometryHitTestParameters) | (Overrides Visual.HitTestCore(GeometryHitTestParameters).)


ClearValue Method

ClearValue Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAYTDialogCoupler ► ClearValue()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | ClearValue(DependencyProperty) |
 | ClearValue(DependencyPropertyKey) |


SetBinding Method

SetBinding Method
API ► Keyoti.RapidSpell.Wpf ► DesignableComponent ► SetBinding()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | SetBinding(DependencyProperty, BindingBase) |
 | SetBinding(DependencyProperty, String) |


TransformToAncestor Method

TransformToAncestor Method
API ► Keyoti.RapidSpell.Wpf ► ErrorAdorner ► TransformToAncestor()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | TransformToAncestor(Visual) |
 | TransformToAncestor(Visual3D) |


SetValue Method

SetValue Method
API ► Keyoti.RapidSpell.Wpf ► RichErrorAdorner ► SetValue()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | SetValue(DependencyProperty, Object) |
 | SetValue(DependencyPropertyKey, Object) |


BeginStoryboard Method

BeginStoryboard Method
API ► Keyoti.RapidSpell.Wpf ► DesignableComponent ► BeginStoryboard()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | BeginStoryboard(Storyboard) |
 | BeginStoryboard(Storyboard, HandoffBehavior) |
 | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) |


MemberwiseClone Method

MemberwiseClone Method
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibStream ► MemberwiseClone()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.


ApplyAnimationClock Method

ApplyAnimationClock Method
API ► Keyoti.RapidSpell.Wpf ► DesignableComponent ► ApplyAnimationClock()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | ApplyAnimationClock(DependencyProperty, AnimationClock) |
 | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) |


MemberwiseClone Method

MemberwiseClone Method
API ► Keyoti.RapidSpell.Compression.Wpf ► GZipStream ► MemberwiseClone()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.


ClearValue Method

ClearValue Method
API ► Keyoti.RapidSpell.Wpf ► ErrorAdornerBase ► ClearValue()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | ClearValue(DependencyProperty) |
 | ClearValue(DependencyPropertyKey) |


HitTestCore Method

HitTestCore Method
API ► Keyoti.RapidSpell.Wpf ► RichErrorAdorner ► HitTestCore()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | HitTestCore(PointHitTestParameters) | (Overrides Visual.HitTestCore(PointHitTestParameters).)
 | HitTestCore(GeometryHitTestParameters) | (Overrides Visual.HitTestCore(GeometryHitTestParameters).)


SetBinding Method

SetBinding Method
API ► Keyoti.RapidSpell.Wpf ► RichErrorAdorner ► SetBinding()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | SetBinding(DependencyProperty, BindingBase) |
 | SetBinding(DependencyProperty, String) |


BeginAnimation Method

BeginAnimation Method
API ► Keyoti.RapidSpell.Wpf ► ErrorAdornerBase ► BeginAnimation()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | BeginAnimation(DependencyProperty, AnimationTimeline) |
 | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) |


SetBinding Method

SetBinding Method
API ► Keyoti.RapidSpell.Wpf ► SelectionAdorner ► SetBinding()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | SetBinding(DependencyProperty, BindingBase) |
 | SetBinding(DependencyProperty, String) |


BeginStoryboard Method

BeginStoryboard Method
API ► Keyoti.RapidSpell.Wpf ► SelectionAdorner ► BeginStoryboard()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | BeginStoryboard(Storyboard) |
 | BeginStoryboard(Storyboard, HandoffBehavior) |
 | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) |


TransformToAncestor Method

TransformToAncestor Method
API ► Keyoti.RapidSpell.Wpf.DialogViews ► WPFUserDictionarySelect ► TransformToAncestor()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | TransformToAncestor(Visual) |
 | TransformToAncestor(Visual3D) |


AddHandler Method

AddHandler Method
API ► Keyoti.RapidSpell.Wpf ► ErrorAdorner ► AddHandler()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | AddHandler(RoutedEvent, Delegate) |
 | AddHandler(RoutedEvent, Delegate, Boolean) |


HitTestCore Method

HitTestCore Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► HitTestCore()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | HitTestCore(PointHitTestParameters) | (Overrides Visual.HitTestCore(PointHitTestParameters).)
 | HitTestCore(GeometryHitTestParameters) | (Overrides Visual.HitTestCore(GeometryHitTestParameters).)


Dispose Method

Dispose Method
API ► Keyoti.RapidSpell.Compression.Wpf ► CrcCalculatorStream ► Dispose()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | Dispose()()()() | Releases all resources used by the Stream.
 | Dispose(Boolean) | Releases the unmanaged resources used by the Stream and optionally releases the managed resources.


HitTestCore Method

HitTestCore Method
API ► Keyoti.RapidSpell.Wpf ► SelectionAdorner ► HitTestCore()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | HitTestCore(PointHitTestParameters) | (Overrides Visual.HitTestCore(PointHitTestParameters).)
 | HitTestCore(GeometryHitTestParameters) | (Overrides Visual.HitTestCore(GeometryHitTestParameters).)


BeginStoryboard Method

BeginStoryboard Method
API ► Keyoti.RapidSpell.Wpf ► ErrorAdorner ► BeginStoryboard()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | BeginStoryboard(Storyboard) |
 | BeginStoryboard(Storyboard, HandoffBehavior) |
 | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) |


ApplyAnimationClock Method

ApplyAnimationClock Method
API ► Keyoti.RapidSpell.Wpf ► ErrorAdornerBase ► ApplyAnimationClock()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | ApplyAnimationClock(DependencyProperty, AnimationClock) |
 | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) |


BringIntoView Method

BringIntoView Method
API ► Keyoti.RapidSpell.Wpf ► SelectionAdorner ► BringIntoView()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | BringIntoView()()()() |
 | BringIntoView(Rect) |


SetBinding Method

SetBinding Method
API ► Keyoti.RapidSpell.Wpf ► ErrorAdorner ► SetBinding()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | SetBinding(DependencyProperty, BindingBase) |
 | SetBinding(DependencyProperty, String) |


BeginStoryboard Method

BeginStoryboard Method
API ► Keyoti.RapidSpell.Wpf ► ErrorAdornerBase ► BeginStoryboard()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | BeginStoryboard(Storyboard) |
 | BeginStoryboard(Storyboard, HandoffBehavior) |
 | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) |


MemberwiseClone Method

MemberwiseClone Method
API ► Keyoti.RapidSpell.Compression.Wpf ► DeflateStream ► MemberwiseClone()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.


AddHandler Method

AddHandler Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAYTDialogCoupler ► AddHandler()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | AddHandler(RoutedEvent, Delegate) |
 | AddHandler(RoutedEvent, Delegate, Boolean) |


AddHandler Method

AddHandler Method
API ► Keyoti.RapidSpell.Wpf ► ErrorAdornerBase ► AddHandler()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | AddHandler(RoutedEvent, Delegate) |
 | AddHandler(RoutedEvent, Delegate, Boolean) |


AddHandler Method

AddHandler Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► AddHandler()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | AddHandler(RoutedEvent, Delegate) |
 | AddHandler(RoutedEvent, Delegate, Boolean) |


SetValue Method

SetValue Method
API ► Keyoti.RapidSpell.Wpf ► ErrorAdornerBase ► SetValue()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | SetValue(DependencyProperty, Object) |
 | SetValue(DependencyPropertyKey, Object) |


ApplyAnimationClock Method

ApplyAnimationClock Method
API ► Keyoti.RapidSpell.Wpf ► RichErrorAdorner ► ApplyAnimationClock()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | ApplyAnimationClock(DependencyProperty, AnimationClock) |
 | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) |


ClearValue Method

ClearValue Method
API ► Keyoti.RapidSpell.Wpf ► DesignableComponent ► ClearValue()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | ClearValue(DependencyProperty) |
 | ClearValue(DependencyPropertyKey) |


SetBinding Method

SetBinding Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAYTDialogCoupler ► SetBinding()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | SetBinding(DependencyProperty, BindingBase) |
 | SetBinding(DependencyProperty, String) |


TransformToAncestor Method

TransformToAncestor Method
API ► Keyoti.RapidSpell.Wpf ► DesignableComponent ► TransformToAncestor()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | TransformToAncestor(Visual) |
 | TransformToAncestor(Visual3D) |


BeginAnimation Method

BeginAnimation Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAYTDialogCoupler ► BeginAnimation()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | BeginAnimation(DependencyProperty, AnimationTimeline) |
 | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) |


SetValue Method

SetValue Method
API ► Keyoti.RapidSpell.Wpf ► SelectionAdorner ► SetValue()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | SetValue(DependencyProperty, Object) |
 | SetValue(DependencyPropertyKey, Object) |


AddHandler Method

AddHandler Method
API ► Keyoti.RapidSpell.Wpf ► RichErrorAdorner ► AddHandler()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | AddHandler(RoutedEvent, Delegate) |
 | AddHandler(RoutedEvent, Delegate, Boolean) |


BeginStoryboard Method

BeginStoryboard Method
API ► Keyoti.RapidSpell.Wpf ► RichErrorAdorner ► BeginStoryboard()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | BeginStoryboard(Storyboard) |
 | BeginStoryboard(Storyboard, HandoffBehavior) |
 | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) |


ClearValue Method

ClearValue Method
API ► Keyoti.RapidSpell.Wpf ► SelectionAdorner ► ClearValue()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | ClearValue(DependencyProperty) |
 | ClearValue(DependencyPropertyKey) |


TransformToAncestor Method

TransformToAncestor Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► TransformToAncestor()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | TransformToAncestor(Visual) |
 | TransformToAncestor(Visual3D) |


SetValue Method

SetValue Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAYTDialogCoupler ► SetValue()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | SetValue(DependencyProperty, Object) |
 | SetValue(DependencyPropertyKey, Object) |


Dispose Method

Dispose Method
API ► Keyoti.RapidSpell.Compression.Wpf ► GZipStream ► Dispose()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | Dispose(Boolean) | Dispose the stream.
 | Dispose()()()() | Releases all resources used by the Stream.


BringIntoView Method

BringIntoView Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAYTDialogCoupler ► BringIntoView()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | BringIntoView()()()() |
 | BringIntoView(Rect) |


Shutdown Method

Shutdown Method
API ► Keyoti.RapidSpell.Wpf ► StartupRegisterForm ► Shutdown()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | Shutdown()()()() |
 | Shutdown(Int32) |


ApplyAnimationClock Method

ApplyAnimationClock Method
API ► Keyoti.RapidSpell.Wpf.DialogViews ► WPFUserDictionarySelect ► ApplyAnimationClock()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | ApplyAnimationClock(DependencyProperty, AnimationClock) |
 | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) |


TransformToAncestor Method

TransformToAncestor Method
API ► Keyoti.RapidSpell.Wpf ► ErrorAdornerBase ► TransformToAncestor()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | TransformToAncestor(Visual) |
 | TransformToAncestor(Visual3D) |


isAtNonBreakingWhiteSpace Method

isAtNonBreakingWhiteSpace Method
API ► Keyoti.RapidSpell.Wpf.FrameWorkSpecific ► AdvancedTextBoundary ► isAtNonBreakingWhiteSpace()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | isAtNonBreakingWhiteSpace(Int32, Boolean, Boolean) | Whether position is non-breaking white space (Overrides SimpleTextBoundary.isAtNonBreakingWhiteSpace(Int32, Boolean, Boolean).)
 | isAtNonBreakingWhiteSpace(Int32) | Whether the character at position is a nonbreaking whitespace.


BringIntoView Method

BringIntoView Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► BringIntoView()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | BringIntoView()()()() |
 | BringIntoView(Rect) |


Dispose Method

Dispose Method
API ► Keyoti.RapidSpell.Compression.Wpf ► DeflateStream ► Dispose()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | Dispose(Boolean) | Dispose the stream.
 | Dispose()()()() | Releases all resources used by the Stream.


MemberwiseClone Method

MemberwiseClone Method
API ► Keyoti.RapidSpell.Compression.Wpf ► CrcCalculatorStream ► MemberwiseClone()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.


BeginAnimation Method

BeginAnimation Method
API ► Keyoti.RapidSpell.Wpf.DialogViews ► WPFUserDictionarySelect ► BeginAnimation()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | BeginAnimation(DependencyProperty, AnimationTimeline) |
 | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) |


SetBinding Method

SetBinding Method
API ► Keyoti.RapidSpell.Wpf ► ErrorAdornerBase ► SetBinding()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | SetBinding(DependencyProperty, BindingBase) |
 | SetBinding(DependencyProperty, String) |


SetValue Method

SetValue Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► SetValue()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | SetValue(DependencyProperty, Object) |
 | SetValue(DependencyPropertyKey, Object) |


OnListChanged Method

OnListChanged Method
API ► Keyoti.RapidSpell.Wpf ► MultiFileUserDictionary ► OnListChanged()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | OnListChanged(UserDictionary..::..ListChangedEventArgs) | Raises ListChanged
 | OnListChanged(Object, UserDictionary..::..ListChangedEventArgs) | Raises ListChanged


ClearValue Method

ClearValue Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► ClearValue()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | ClearValue(DependencyProperty) |
 | ClearValue(DependencyPropertyKey) |


TransformToAncestor Method

TransformToAncestor Method
API ► Keyoti.RapidSpell.Wpf ► SelectionAdorner ► TransformToAncestor()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | TransformToAncestor(Visual) |
 | TransformToAncestor(Visual3D) |


SetBinding Method

SetBinding Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► SetBinding()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | SetBinding(DependencyProperty, BindingBase) |
 | SetBinding(DependencyProperty, String) |


ApplyAnimationClock Method

ApplyAnimationClock Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► ApplyAnimationClock()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | ApplyAnimationClock(DependencyProperty, AnimationClock) |
 | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) |


SetBinding Method

SetBinding Method
API ► Keyoti.RapidSpell.Wpf.DialogViews ► WPFUserDictionarySelect ► SetBinding()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | SetBinding(DependencyProperty, BindingBase) |
 | SetBinding(DependencyProperty, String) |


ClearValue Method

ClearValue Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► ClearValue()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | ClearValue(DependencyProperty) |
 | ClearValue(DependencyPropertyKey) |


BringIntoView Method

BringIntoView Method
API ► Keyoti.RapidSpell.Wpf ► DesignableComponent ► BringIntoView()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | BringIntoView()()()() |
 | BringIntoView(Rect) |


HitTestCore Method

HitTestCore Method
API ► Keyoti.RapidSpell.Wpf ► ErrorAdornerBase ► HitTestCore()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | HitTestCore(PointHitTestParameters) | (Overrides Visual.HitTestCore(PointHitTestParameters).)
 | HitTestCore(GeometryHitTestParameters) | (Overrides Visual.HitTestCore(GeometryHitTestParameters).)


ClearValue Method

ClearValue Method
API ► Keyoti.RapidSpell.Wpf.DialogViews ► WPFUserDictionarySelect ► ClearValue()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | ClearValue(DependencyProperty) |
 | ClearValue(DependencyPropertyKey) |


SetValue Method

SetValue Method
API ► Keyoti.RapidSpell.Wpf.DialogViews ► WPFUserDictionarySelect ► SetValue()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | SetValue(DependencyProperty, Object) |
 | SetValue(DependencyPropertyKey, Object) |


TransformToAncestor Method

TransformToAncestor Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAYTDialogCoupler ► TransformToAncestor()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | TransformToAncestor(Visual) |
 | TransformToAncestor(Visual3D) |


AddHandler Method

AddHandler Method
API ► Keyoti.RapidSpell.Wpf ► DesignableComponent ► AddHandler()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | AddHandler(RoutedEvent, Delegate) |
 | AddHandler(RoutedEvent, Delegate, Boolean) |


Dispose Method

Dispose Method
API ► Keyoti.RapidSpell.Compression.Wpf ► ZlibStream ► Dispose()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | Dispose(Boolean) | Dispose the stream.
 | Dispose()()()() | Releases all resources used by the Stream.


HitTestCore Method

HitTestCore Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAYTDialogCoupler ► HitTestCore()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | HitTestCore(PointHitTestParameters) | (Overrides Visual.HitTestCore(PointHitTestParameters).)
 | HitTestCore(GeometryHitTestParameters) | (Overrides Visual.HitTestCore(GeometryHitTestParameters).)


MemberwiseClone Method

MemberwiseClone Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellGUIPresenter ► MemberwiseClone()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.


BeginStoryboard Method

BeginStoryboard Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAYTDialogCoupler ► BeginStoryboard()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | BeginStoryboard(Storyboard) |
 | BeginStoryboard(Storyboard, HandoffBehavior) |
 | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) |


BringIntoView Method

BringIntoView Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► BringIntoView()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | BringIntoView()()()() |
 | BringIntoView(Rect) |


AddHandler Method

AddHandler Method
API ► Keyoti.RapidSpell.Wpf ► SelectionAdorner ► AddHandler()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | AddHandler(RoutedEvent, Delegate) |
 | AddHandler(RoutedEvent, Delegate, Boolean) |


SetValue Method

SetValue Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► SetValue()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | SetValue(DependencyProperty, Object) |
 | SetValue(DependencyPropertyKey, Object) |


BringIntoView Method

BringIntoView Method
API ► Keyoti.RapidSpell.Wpf ► RichErrorAdorner ► BringIntoView()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | BringIntoView()()()() |
 | BringIntoView(Rect) |


ApplyAnimationClock Method

ApplyAnimationClock Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAYTDialogCoupler ► ApplyAnimationClock()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | ApplyAnimationClock(DependencyProperty, AnimationClock) |
 | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) |


HitTestCore Method

HitTestCore Method
API ► Keyoti.RapidSpell.Wpf.DialogViews ► WPFUserDictionarySelect ► HitTestCore()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | HitTestCore(PointHitTestParameters) | (Overrides Visual.HitTestCore(PointHitTestParameters).)
 | HitTestCore(GeometryHitTestParameters) | (Overrides Visual.HitTestCore(GeometryHitTestParameters).)


isBetweenWordChars Method

isBetweenWordChars Method
API ► Keyoti.RapidSpell.Wpf.FrameWorkSpecific ► AdvancedTextBoundary ► isBetweenWordChars()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | isBetweenWordChars(Int32) | Whether the character at position is between nonbreaking white space or letters or digits.
 | isBetweenWordChars(Int32, Boolean, Boolean) | Whether the character at position is between nonbreaking white space or letters or digits.


BeginStoryboard Method

BeginStoryboard Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► BeginStoryboard()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | BeginStoryboard(Storyboard) |
 | BeginStoryboard(Storyboard, HandoffBehavior) |
 | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) |


BringIntoView Method

BringIntoView Method
API ► Keyoti.RapidSpell.Wpf ► ErrorAdornerBase ► BringIntoView()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | BringIntoView()()()() |
 | BringIntoView(Rect) |


TransformToAncestor Method

TransformToAncestor Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► TransformToAncestor()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | TransformToAncestor(Visual) |
 | TransformToAncestor(Visual3D) |


SetValue Method

SetValue Method
API ► Keyoti.RapidSpell.Wpf ► ErrorAdorner ► SetValue()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | SetValue(DependencyProperty, Object) |
 | SetValue(DependencyPropertyKey, Object) |


BeginAnimation Method

BeginAnimation Method
API ► Keyoti.RapidSpell.Wpf ► RichErrorAdorner ► BeginAnimation()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | BeginAnimation(DependencyProperty, AnimationTimeline) |
 | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) |


BeginStoryboard Method

BeginStoryboard Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► BeginStoryboard()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | BeginStoryboard(Storyboard) |
 | BeginStoryboard(Storyboard, HandoffBehavior) |
 | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) |


BeginStoryboard Method

BeginStoryboard Method
API ► Keyoti.RapidSpell.Wpf.DialogViews ► WPFUserDictionarySelect ► BeginStoryboard()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | BeginStoryboard(Storyboard) |
 | BeginStoryboard(Storyboard, HandoffBehavior) |
 | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) |


SetBinding Method

SetBinding Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► SetBinding()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | SetBinding(DependencyProperty, BindingBase) |
 | SetBinding(DependencyProperty, String) |


BringIntoView Method

BringIntoView Method
API ► Keyoti.RapidSpell.Wpf.DialogViews ► WPFUserDictionarySelect ► BringIntoView()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | BringIntoView()()()() |
 | BringIntoView(Rect) |


Run Method

Run Method
API ► Keyoti.RapidSpell.Wpf ► StartupRegisterForm ► Run()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | Run()()()() |
 | Run(Window) |


BringIntoView Method

BringIntoView Method
API ► Keyoti.RapidSpell.Wpf ► ErrorAdorner ► BringIntoView()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | BringIntoView()()()() |
 | BringIntoView(Rect) |


ShowDialog Method

ShowDialog Method
API ► Keyoti.RapidSpell.Wpf.DialogViews ► WPFUserDictionarySelect ► ShowDialog()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | ShowDialog(Object, List<(Of <<'(String>)>>), String) | See IDialogViewUserDictionaryEdit
 | ShowDialog()()()() |


HitTestCore Method

HitTestCore Method
API ► Keyoti.RapidSpell.Wpf ► ErrorAdorner ► HitTestCore()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | HitTestCore(PointHitTestParameters) | (Overrides Visual.HitTestCore(PointHitTestParameters).)
 | HitTestCore(GeometryHitTestParameters) | (Overrides Visual.HitTestCore(GeometryHitTestParameters).)


ApplyAnimationClock Method

ApplyAnimationClock Method
API ► Keyoti.RapidSpell.Wpf ► SelectionAdorner ► ApplyAnimationClock()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | ApplyAnimationClock(DependencyProperty, AnimationClock) |
 | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) |


AddHandler Method

AddHandler Method
API ► Keyoti.RapidSpell.Wpf.DialogViews ► WPFUserDictionarySelect ► AddHandler()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | AddHandler(RoutedEvent, Delegate) |
 | AddHandler(RoutedEvent, Delegate, Boolean) |


BeginAnimation Method

BeginAnimation Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► BeginAnimation()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | BeginAnimation(DependencyProperty, AnimationTimeline) |
 | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) |


TransformToAncestor Method

TransformToAncestor Method
API ► Keyoti.RapidSpell.Wpf ► RichErrorAdorner ► TransformToAncestor()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | TransformToAncestor(Visual) |
 | TransformToAncestor(Visual3D) |


BeginAnimation Method

BeginAnimation Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellAsYouType ► BeginAnimation()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | BeginAnimation(DependencyProperty, AnimationTimeline) |
 | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) |


ApplyAnimationClock Method

ApplyAnimationClock Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► ApplyAnimationClock()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | ApplyAnimationClock(DependencyProperty, AnimationClock) |
 | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) |


ApplyAnimationClock Method

ApplyAnimationClock Method
API ► Keyoti.RapidSpell.Wpf ► ErrorAdorner ► ApplyAnimationClock()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | ApplyAnimationClock(DependencyProperty, AnimationClock) |
 | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) |


SetValue Method

SetValue Method
API ► Keyoti.RapidSpell.Wpf ► DesignableComponent ► SetValue()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | SetValue(DependencyProperty, Object) |
 | SetValue(DependencyPropertyKey, Object) |


ClearValue Method

ClearValue Method
API ► Keyoti.RapidSpell.Wpf ► RichErrorAdorner ► ClearValue()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | ClearValue(DependencyProperty) |
 | ClearValue(DependencyPropertyKey) |


ClearValue Method

ClearValue Method
API ► Keyoti.RapidSpell.Wpf ► ErrorAdorner ► ClearValue()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | ClearValue(DependencyProperty) |
 | ClearValue(DependencyPropertyKey) |


BeginAnimation Method

BeginAnimation Method
API ► Keyoti.RapidSpell.Wpf ► ErrorAdorner ► BeginAnimation()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | BeginAnimation(DependencyProperty, AnimationTimeline) |
 | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) |


BeginAnimation Method

BeginAnimation Method
API ► Keyoti.RapidSpell.Wpf ► SelectionAdorner ► BeginAnimation()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | BeginAnimation(DependencyProperty, AnimationTimeline) |
 | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) |


AddHandler Method

AddHandler Method
API ► Keyoti.RapidSpell.Wpf ► RapidSpellDialog ► AddHandler()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | AddHandler(RoutedEvent, Delegate) |
 | AddHandler(RoutedEvent, Delegate, Boolean) |


BeginAnimation Method

BeginAnimation Method
API ► Keyoti.RapidSpell.Wpf ► DesignableComponent ► BeginAnimation()()()()
Keyoti RapidSpell WPF
Members
Icon | Member | Description
 | BeginAnimation(DependencyProperty, AnimationTimeline) |
 | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) |