はじめに

Knowlbo(R)/COMシリーズ e-ハンコ Version2をお求めいただき誠にありがとうございます。

e-ハンコは、ハンコの印影を簡単に作成できる電子捺印コンポーネントです。

このヘルプ情報は、e-ハンコのソフトウェア使用許諾権、サポート情報、使用方法などの各種ドキュメント、およびサンプルコードなどから構成されています。また、最新の製品情報や修正版、FAQなどについては、弊社ホームページにて公開されます。

登録商標など

Knowlbo(R)はナルボの登録商標です。

Microsoft、WindowsNT、Windows95、Windows98、Windows2000、Windows Me、Visual Basic、Visual C++は米国Microsoft Corporationの米国およびその他の国における登録商標です。

Delphi、C++Builderは米国Borland Corporationの米国およびその他の国における登録商標です。

その他記載されている会社名、製品名は各社の登録商標、または商標です。

なお、本マニュアルの記述については、特に記載がない限り、Visual Basic言語を対象としています。他の言語環境でご利用される場合は、お手数ですが対応の言語に置き換えてご利用下さい。


ソフトウェア使用許諾権について

ソフトウェア使用許諾契約

お客様がディスクのケースを開封するかまたはディスクのシールをはがした場合に、お客様はこの契約に同意してご利用いただけるものといたします。この契約に同意できない場合には、ご利用することはできません。

このソフトウエア使用許諾契約とディスクは、お客様が適法に使用許諾を受けたことの証しとなりますので、どちらも大切に保管してください。

適用

以下の条項は、お客様がこの契約書とともに入手された株式会社ナルボ（以下「弊社」といいます）のソフトウエア製品（コンピュータプログラムとマニュアルその他の関連資料を含み、以下「本製品」といいます）に適用します。

使用の許諾

（１）お客様は「ユーザ登録」に記載された担当者の管理下においてのみ本製品を使用できます。

（２）お客様は本製品をコンピュータネットワーク上で複数の使用者により使用することはできません。ただし、マニュアルその他にネットワーク対応製品である旨が記載されている製品はこの限りではありません。

（３）お客様はいかなる事由によろうとも本製品を譲渡、販売、転貸することはできません。

（４）本製品のパッケージに同一の機能を有し、形態の異なるディスクが複数入っていた場合、お客様はそのうちの一種類のディスクのみをご使用いただけます。お客様が残りのディスクを他のコンピュータで使用したり、他者に譲渡、販売、転貸することはできません。また、お客様のご要望に応じて弊社が本製品と同一の機能を有し、形態の異なるディスクをお客様に提供した場合も同様とします。

（５）本製品のマニュアルその他にロイヤルティフリーの言語関連製品である旨が記載されている場合に限り、お客様が販売する製品に本製品のランタイムモジュールを組み込むことができます。ただし、この場合においても本製品の使用法やその他一切を公開することはできません。また、販売する製品には本製品の有効な著作権表示を明記しなければなりません。

保証の範囲

（１）弊社は本製品の仕様を予告なしに変更することがあります。

（２）本製品の品質および性能に関して発生する問題は、お客様の費用負担をもって処理することとします。

（３）弊社は、いかなる場合にも、お客様が本製品を使用または運用した結果に関して一切責任を負いません。

（４）本製品にお客様が目的を遂げることができないような重大な欠陥（磁気の消滅、破損など）があった場合、欠陥のない製品と交換するかまたはその製品代金相当額をもって弊社の保証限度とします。ただし、この保証は、お客様が本製品をご購入されてから30日以内に限らせていただきます。

テクニカルサポートサービス

弊社は、ユーザー登録によりご登録をいただいたお客様に対してのみ、テクニカルサポートサービスをご提供するものとします。但し、本製品（バージョン）の販売が終了して、１年以上が経過した場合にはその限りではありません。

契約期間

（１）本契約はお客様に製品を納入した日より発効します。また、納入日は証票により確認するものとします。

（２）お客様が本契約の条項のいずれかに違反した場合、本契約は解除されます。またこの場合を含め、製品の代金は返還いたしません。


ユーザ登録について

弊社では、よりよい製品とサービスをお届けするために、お客様の情報を登録させていただきたく存じます。お手数ではございますが、弊社ホームページまたは「ユーザ登録FAX用紙」を印刷のうえ、必要事項をご記入のうえファックスにてお送りください。

ご登録いただきましたお客様には、製品やサービスについてのインフォメーションをお届けいたします。ご住所や電話番号など、ご登録内容に変更が生じた場合は弊社カスタマ･コミュニケーションズまでお知らせください。

ご登録のない場合、バージョンアップサービスやテクニカルサポートサービスをご提供できないことがございます。

カスタマ・コミュニケーションズのご案内

製品内容やユーザ登録についてのお問い合わせは、下記にて承ります。

カスタマ・コミュニケーションズ
電話番号 | 03-3361-7755 | 11:00～12:00 13:00～19:00 （月～金）
FAX番号 | 03-3361-7735 | 24時間受け付け
電子メールアドレス | knocx@knowlbo.co.jp |


ユーザ登録FAX用紙

ユーザ登録は、オンラインでWebページから行う方法と、当FAX用紙を印刷していただき、内容を明記の上、FAXにてお送りいただく方法があります。

FAX. 03-3361-7735 （株）ナルボ　カスタマコミュニケーションズ行

ユーザ登録項目 | 内容
製品名 | Knowlbo/COM e-ハンコ Version2
シリアル№ |
登録キー |
登録形態 | □法人 □個人
法人名* |
所属部署名* |
役職名* |
ユーザ名 |
住所 | 〒
電話番号 | （ ） －
FAX番号 | （ ） －
電子メールアドレス |

※｢登録キー｣はバージョン情報ダイアログの Registration Key を記入してください。
※｢登録形態｣が法人の場合は、｢法人名*｣、｢所属部署名*｣、および｢役職名*｣も記入してください。

本製品購入のきっかけとなった媒体は何ですか

□雑誌記事　□雑誌広告　□DM　□展示会　□店頭　□知人の紹介
□ホームページ　□電子メール　□その他

e-ハンコをご利用の形態は何ですか

□Active X コントロール（Visual Basic 6.0、Internet Explorer 5.0など）
□サーバーコンポーネント（Internet Information Serverなど）

本製品ご購入の理由、ご意見、ご要望を教えてください


インストール／アンインストールについて

e-ハンコ Version2は、次の環境でご使用いただけます。

基本ソフトウェア

Windows 98 （日本語版）
Windows Me （日本語版）
Windows NT4.0 （日本語版）
Windows 2000 （日本語版）

コントロールコンテナ

Visual Basic 6.0 （日本語版）

Internet Explorer 5.0 （日本語版）

コンポーネントWebサーバー

Internet Information Server 4.0（日本語版）

Internet Information Service 5.0（日本語版）

Personal Web Server4.0（日本語版）

e-ハンコのインストールは、製品ディスクに含まれているセットアッププログラム（SETUP.EXE）により可能です。セットアッププログラムは、次の様な構成でシステムディレクトリあるいは、ユーザ指定のディレクトリ下の"e-HANKOV2"ディレクトリにファイルをインストールします。

\<Windows Directory>\System

OLEAUT32.DLL

AutomationサポートDLL

\<User Directory>\e-HANKOV2

Readme.WRI | e-ハンコ 情報ドキュメントファイル
KnHANKO.DLL | e-ハンコ DLLファイル
KnHANKO.LIC | e-ハンコ ライセンスファイル
e-HANKO.CHM | e-ハンコ ヘルプファイル
REGSVR32.EXE | コントロール登録（レジストリ）実行モジュール
Uninst.isu | アンインストール情報ファイル

\<User Directory>\e-HANKOV2\Samples for VB

e-ハンコ Visual Basic用サンプルプログラム

\<User Directory>\e-HANKOV2\Samples for IE

e-ハンコ InternetExplorer用サンプルプログラム

\<User Directory>\e-HANKOV2\Samples for ASP

e-ハンコ ASP用サンプルプログラム

補足

製品インストール時に、WindowsディレクトリSystem配下にコピーするファイルは、ActiveXコントロールを使用する上で必要なOLEサポートDLLです。これらのファイルは、最新のファイルが既に存在する場合は、コピーされません。

インストールの手順

インストールは次の手順で行います。

旧バージョンのアンインストール

システムに旧バージョンのe-ハンコがインストールされている場合、旧バージョンをアンインストールする。

旧バージョンのアンインストールは、旧バージョンの製品ディスク内にあるSETUP.EXEで行います。アンインストールの手順につきましては、旧バージョンのディレクトリ内にある「SETUP.TXT」に記述されていますので、そちらをご参照ください。

e-ハンコ Version2のインストール

(１)e-ハンコ Version2のCD-ROMをドライブにセットします。

(２)e-ハンコ Version2のセットアップメニューが自動的に起動しますので、そこで「SETUP」をクリックすると、セットアップが開始されます。始まらない場合は、以下の手順を行ってください。

・コントロールパネルの【アプリケーションの登録と削除】を起動します。

・「アプリケーションの登録と削除のプロパティ」画面で【セットアップ】／【インストール】ボタンをクリックします。

・「フロッピーディスクまたはＣＤ－ＲＯＭからのセットアップ」の画面で、【次へ】ボタンをクリックします。

・セットアッププログラムの実行」画面のテキストボックスに D:\setup.exe（ＣＤ－ＲＯＭドライブがD:の場合）と表示されるので、【完了】ボタンをクリックします。ここまでの操作により、セットアッププログラムが起動されます。

(３)起動されたセットアッププログラムの「ようこそ」の画面で、【次へ】をクリックします。

(４)製品ライセンス契約の同意確認の画面になるので、【はい】をクリックします。

(５)インストール／アンインストールの選択画面になるので、【Install】ボタンをクリックした上で、【次へ】のボタンをクリックします。

(６)インストール先フォルダの選択画面が表示されるので、インストール先を選択し、【次へ】をクリックします。

(７)セットアップの方法を選択し、【次へ】をクリックします。

セットアップの方法は、３通りあります。

標準 | もっとも一般的なインストールをします。 コンポーネントファイル、ライセンスファイル、ヘルプファイル、サンプルプログラム、ＯＬＥサポートＤＬＬ群をインストールします。
コンパクト | 必要最小限のオプションでインストールを行います。 コンポーネントファイル、ライセンスファイル、ヘルプファイルのみインストールします。
カスタム | ヘルプファイル、サンプルプログラム、ＯＬＥサポートＤＬＬ群のインストールを選択できます。

(８)プログラムフォルダ名を入力し、【次へ】をクリックします。(コンパクトを選択した場合、この手順は省略されます。)

(９)インストール情報の確認画面が表示されるので、【はい】／【次へ】をクリックします。

(１０)自動的にファイルがコピーされます。「インストール完了」ダイアログが表示されれば、インストールは完了です。Readmeファイルをすぐに読みたい場合は、【はい（Y）】ボタンをクリック、あとで読む場合は【いいえ(N)】ボタンをクリックして終了して下さい。

アンインストールの手順

アンインストールの手順につきましては、旧バージョンのディレクトリ内にある「SETUP.TXT」に記述されていますので、そちらをご参照ください。


バージョン２の新機能

バージョン２の新機能などについて

バージョン１をご利用のお客様のために、バージョン２の新機能などについて概略します。

ヘルプのMicrosoft HTMLヘルプ化

バージョン１のヘルプはWinHelp形式でしたが、バージョン２ではMicrosoft HTMLヘルプ形式（当ヘルプ）とし、より操作性を向上させました。

キャプションテキスト、名前テキストにそれぞれ３つの文字フォント指定

バージョン１のキャプションテキスト、名前テキストの文字フォントは、それぞれ１つのみ指定できましたが、バージョン２ではそれぞれ３つの文字フォントの利用を可能としました。

各行における英字コロン（｢:｣）をフォント切替えの区切り文字と解釈します。

背景に透かしテキストの埋め込み指定（Version1.1）

メタファイル形式でイメージファイルを作成する場合、印影の背景に透かしテキストを埋め込み可能としました。

背景にピクチャの配置指定（Version1.1）

印影の背景に、任意のピクチャを配置可能としました。

印影の四隅にピクチャの配置指定

印影の四隅にそれぞれ、任意のピクチャを配置可能としました。


定数一覧

定数項目 | 説明 | 備考
KnHankoType | ハンコのタイプ |
KnHankoFrame | ハンコの枠形状 |
KnHankoData | イメージデータの形式 |
KnHankoPictureMode | バックグランドピクチャの表示サイズモード |


KnHankoData

イメージデータの形式

定数名 | 説明 | 備考
0 - hanDataBmp | ビットマップ |
1 - hanDataPng | ＰＮＧ（圧縮） |
2 - hanDataWmf | Windowsメタファイル |


KnHankoFrame

ハンコの枠形状

定数名 | 説明 | 備考
0 - hanFrameNull | 枠なし |
1 - hanFrameRound | 丸型 |
2 - hanFrameRoundRect | 角丸矩形 |
3 - hanFrameRect | 矩形 |


KnHankoPictureMode

バックグランドピクチャの表示サイズモード

定数名 | 説明 | 備考
0 - hanPictureClip | クリップ（ピクチャサイズ不変） |
1 - hanPictureZoom | ズーム（縦横比不変） |
2 - hanPictureStretch | ストレッチ |
3 - hanPictureZoomIn | ズームイン（縦横比不変拡大） |
4 - hanPictureZoomOut | ズームアウト（縦横比不変縮小） |


KnHankoType

ハンコのタイプ

定数名 | 説明 | 備考
0 - hanTypeNull | 空 |
1 - hanTypeCaption | キャプションのみ |
2 - hanTypeDate | 日付のみ |
3 - hanTypeName | 名前のみ |
4 - hanTypeCaptionDate | キャプション｜日付 |
5 - hanTypeCaptionName | キャプション｜名前 |
6 - hanTypeDateName | 日付｜名前 |
7 - hanTypeCaptionDateName | キャプション｜日付｜名前 |


プロパティ一覧

アルファベット昇順プロパティ一覧

プロパティ | 説明 | 備考
BackColor | 印影の背景カラー（イメージデータ作成時有効） |
BackgroundPicture | バックグランドピクチャ |
BackgroundPictureMode | バックグランドピクチャモード |
Caption | = StampCaption |
DataText | データテキスト |
Font | StampCaptionの文字フォント |
ForeColor | 印影のカラー |
FrameCornerRoundRate | ハンコの角丸矩形枠の丸み率（対ハンコサイズ） |
FrameShape | ハンコの枠形状 |
FrameWidth | ハンコの枠の幅 |
LeftBottomCornerPicture | 左下角ピクチャ |
LeftTopCornerPicture | 左上角ピクチャ |
RightBottomCornerPicture | 右下角ピクチャ |
RightTopCornerPicture | 右上角ピクチャ |
StampCaption | Caption文字列 |
StampCaptionFont2 | StampCaptionのセカンド文字フォント |
StampCaptionFont3 | StampCaptionのサード文字フォント |
StampCaptionFontAutoScale | StampCaption文字フォントの自動スケール指定 |
StampDate | Date文字列 |
StampDateFont | StampDate の文字フォント |
StampDateFontAutoScale | StampDate 文字フォントの自動スケール指定 |
StampHeight | ハンコの縦サイズ |
StampName | Name文字列 |
StampNameFont | StampNameの文字フォント |
StampNameFont2 | StampNameのセカンド文字フォント |
StampNameFont3 | StampNameののサード文字フォント |
StampNameFontAutoScale | StampName 文字フォントの自動スケール指定 |
StampType | ハンコのタイプ |
StampWidth | ハンコの横サイズ |
Watermark | すかし文字の指定 |
WatermarkApplication | すかし文字のアプリケーション名 |
WatermarkColor | すかし文字のカラー |
WatermarkFont | すかし文字のフォント |
WatermarkText | すかし文字のテキスト |
WatermarkTitle | すかし文字のタイトル名 |


BackColorプロパティ

BackColor、ForeColorプロパティ

ハンコの背景カラー、および印影カラーを設定、または取得します。

構文

object.BackColor [ = color ]

object.ForeColor [ = color ]

指定項目 | 内容 | 備考
object | オブジェクトを指すオブジェクト式です。 |
color | ハンコの背景カラー、および印影カラーのカラー値を指定します。 |

解説

ハンコの背景カラー、および印影カラーです。

背景カラーは、印影イメージの取得、および印影イメージファイルの作成においてのみ有効です。（一般の表示においては無効です。）

例

サンプルコード

KnHankoCtl1.BackColor = RGB(&HC0,&HC0,&HFF)

KnHankoCtl1.BackColor = &HFFC0C0

KnHankoCtl1.ForeColor = RGB(&H80,&H80,&HFF)

KnHankoCtl1.ForeColor = &HFF8080


BackgroundPictureプロパティ

BackgroundPicture、BackgroundPictureModeプロパティ

バックグランドピクチャとその表示サイズモードを設定、または取得します。

構文

object.BackgroundPicture [ = picture ]

object.BackgroundPictureMode [ = number ]

指定項目 | 内容 | 備考
object | オブジェクトを指すオブジェクト式です。 |
picture | Pictureオブジェクトを指定します。 |
number | バックグランドピクチャの表示サイズモードを定数値KnHankoPictureModeで指定します。 |

解説

バックグランドピクチャとその表示サイズモードです。

例

サンプルコード

KnHankoCtl1.BackgroundPicture = LoadPicture("Test.bmp")

KnHankoCtl1.BackgroundPictureModer = hanPictureZoom


DataTextプロパティ

データテキスト文字列を設定、または取得します。

構文

object.DataText [ = string ]

指定項目 | 内容 | 備考
object | オブジェクトを指すオブジェクト式です。 |
string | データテキストを示す文字列式を指定します。 |

解説

データテキスト文字列です。

例

サンプルコード

KnHankoCtl1.DataText = "技術部,男"


Fontプロパティ

Font、StampCaptionFont2、StampCaptionFont3、StampDateFont、StampNameFont、StampNameFont2、StampNameFont3プロパティ

Caption文字列、Date文字列、およびName文字列のフォントを設定、または取得します。

構文

object.Font[ = font ]

object.StampCaptionFont2[ = font ]

object.StampCaptionFont3[ = font ]

object.StampDateFont[ = font ]

object.StampNameFont[ = font ]

object.StampNameFont2[ = font ]

object.StampNameFont3[ = font ]

指定項目 | 内容 | 備考
object | オブジェクトを指すオブジェクト式です。 |
font | Caption文字列、Date文字列、およびName文字列のFontオブジェクトを指定します。 |

解説

Caption文字列、Date文字列、およびName文字列のフォントです。

Caption文字列、および Name文字列についてはそれぞれ３つの文字フォントの利用が可能です。３つの文字フォントは各行の中で英字のコロン（「:」）を区切り文字として順に割り付けられます。（英字のコロン（「:」）は、表示されません。）

例

サンプルコード

KnHankoCtl1.Font.Name ="ＭＳＰゴシック"

KnHankoCtl1.Font.Bold =False

KnHankoCtl1.Font.Italic =True

KnHankoCtl1.Font.Underline =False

KnHankoCtl1.Font.StrikeThrough =True

KnHankoCtl1.Font.Size =20 '20ポイント

Print "Font Weight ="KnHankoCtl1.Font.Weight

KnHankoCtl1.StampDateFont.Name ="Arial"

KnHankoCtl1.StampDateFont.Size =16 '16ポイント

Print CaptionsDateFont Weight = KnHankoCtl1.CaptionsFont.Weight

KnHankoCtl1.StampNameFont.Name ="ＭＳＰゴシック"

KnHankoCtl1.StampNameFont.Size = 20 '20ポイント

Print CaptionsNameFont.Weight = KnHankoCtl1.StampNameFont.Weight


FrameCornerRoundRateプロパティ

FrameCornerRoundRate、FrameShape、FrameWidthプロパティ

ハンコの角丸矩形枠の丸み率（対ハンコサイズ）、枠形状、および枠幅を設定、または取得します。

構文

object.FrameCornerRoundRate [ = value ]

object.FrameShape [ = number ]

object.FrameWidth [ = value2 ]

指定項目 | 内容 | 備考
object | オブジェクトを指すオブジェクト式です。 |
value | ハンコの角丸矩形枠の丸み率（対ハンコサイズ）を示す数値式を指定します。 |
number | ハンコの枠形状を定数値 KnHankoFrame で指定します。 |
value2 | ハンコの枠幅を示す数値式を指定します。 |

解説

ハンコの角丸矩形枠の丸み率（対ハンコサイズ）、枠形状、および枠幅です。

ハンコの角丸矩形枠の丸み率は、ハンコの枠形状が角丸矩形の場合のみ有効です。ボタンの縦、横サイズの小さい方に対する割合（％）であり、そのサイズは角丸の直径となります。

ハンコの枠幅のスケールはコンテナにおける設定に依存します（Visual Basic ではフォームのScaleModeプロパティにより、既定値はTwip）。

例

サンプルコード

KnHankoCtl1.FrameCornerRoundRate = 25

KnHankoCtl1.FrameShape = hanFrameRoundRect

KnHankoCtl1.FrameWidth = 100


LeftBottomCornerPictureプロパティ

LeftBottomCornerPicture、LeftTopCornerPicture、RightBottomCornerPicture、RightTopCornerPictureプロパティ

ハンコの左下角ピクチャ、左上下角ピクチャ、右下角ピクチャ、および右上角ピクチャを設定、または取得します。

構文

object.LeftBottomCornerPicture [ = picture ]

object.LeftTopCornerPicture [ = picture ]

object.RightBottomCornerPicture [ = picture ]

object.RightTopCornerPicture [ = picture ]

指定項目 | 内容 | 備考
object | オブジェクトを指すオブジェクト式です。 |
picture | Pictureオブジェクトを指定します。 |

解説

ハンコの左下角ピクチャ、左上下角ピクチャ、右下角ピクチャ、および右上角ピクチャです。

例

サンプルコード

KnHankoCtl1.LeftBottomCornerPicture = LoadPicture("Test.bmp")

KnHankoCtl1.LeftTopCornerPicture = KnHankoCtl1.LeftBottomCornerPicture

KnHankoCtl1.RightBottomCornerPicture = KnHankoCtl1.LeftBottomCornerPicture

KnHankoCtl1.RightTopCornerPicture = KnHankoCtl1.LeftBottomCornerPicture


StampCaptionFontAutoScaleプロパティ

StampCaptionFontAutoScale、StampDateFontAutoScale、StampNameFontAutoScaleプロパティ

Caption文字フォント、Date文字フォント、およびName文字フォントの自動スケール指定を示すブール値を設定、または取得します。

構文

object.StampCaptionFontAutoScale[ = boolean ]

object.StampDateFontAutoScale[ = boolean ]

object.StampNameFontAutoScale[ = boolean ]

指定項目 | 内容 | 備考
object | オブジェクトを指すオブジェクト式です。 |
boolean | Caption文字フォント、Date文字フォント、およびName文字フォントの自動スケール指定を示すブール式を指定します。 | Trueで有効。

解説

Caption文字フォント、Date文字フォント、およびName文字フォントの自動スケール指定を示すブール値です。

自動スケール指定は、対応文字列が、ハンコの対応フレームに収まらないサイズの場合に、はみ出した部分をクリッピングするのでなく、対応フレームに収まるよう自動サイズ変更させる指定です（デフォルト）。

例

サンプルコード

KnHankoCtl1.StampCaptionFontAutoScale = True

KnHankoCtl1.StampDateFontAutoScale = True

KnHankoCtl1.StampNameFontAutoScale = True


StampCaptionプロパティ

StampCaption、StampDate、StampNameプロパティ

Caption文字列、Date文字列、およびName文字列を設定、または取得します。

構文

object.StampCaption[ = string ]

object.StampDate[ = string ]

object.StampName[ = string ]

指定項目 | 内容 | 備考
object | オブジェクトを指すオブジェクト式です。 |
string | Caption、Date、およびNameとして表示されるテキストを示す文字列式を指定します。 |

解説

Caption文字列、Date文字列、およびName文字列です。

例

サンプルコード

KnHankoCtl1.StampCaption = "Knowlbo/COM"

KnHankoCtl1.StampDate = Date

KnHankoCtl1.StampName = "e-ハンコ"


StampHeightプロパティ

StampHeight、StampWidthプロパティ

ハンコの縦サイズ、およびハンコの横サイズを設定、または取得します。

構文

object.StampHeight[ = value ]

object.StampWidth[ = value ]

指定項目 | 内容 | 備考
object | オブジェクトを指すオブジェクト式です。 |
value | ハンコの縦サイズ、およびハンコの横サイズを示す数値式を指定します。 |

解説

ハンコの縦サイズ、およびハンコの横サイズ値です。

スケールはコンテナにおける設定に依存します（Visual Basic ではフォームのScaleModeプロパティにより、既定値はTwip）。

例

サンプルコード

KnHankoCtl1.StampHeight = 4000

KnHankoCtl1.StampWidth = 4000


StampTypeプロパティ

ハンコのタイプを設定、または取得します。

構文

object.StampType[ = number ]

指定項目 | 内容 | 備考
object | オブジェクトを指すオブジェクト式です。 |
number | ハンコのタイプを定数値 KnHankoTypeで指定します。 |

解説

ハンコのタイプです。

例

サンプルコード

KnHankoCtl1.StampType = hanTypeCaptionDateName


Watermarkプロパティ

Watermark、WatermarkApplication、WatermarkColor、WatermarkFont、WatermarkText、WatermarkTitleプロパティ

ハンコのすかし文字の指定、アプリケーション名、カラー、文字フォント、テキスト、およびタイトル名を設定、または取得します。

構文

object.Watermark [ = boolean ]

object.WatermarkApplication [ = string ]

object.WatermarkColor [ = color ]

object.WatermarkFont [ = font ]

object.WatermarkText [ = string2 ]

object.WatermarkTitle [ = string3 ]

指定項目 | 内容 | 備考
object | オブジェクトを指すオブジェクト式です。 |
boolean | すかし文字の指定を示すブール式を指定します。 | Trueで有効。
string | すかし文字のアプリケーション名を示す文字列式を指定します。 | 利用法は任意です。
color | すかし文字のカラーのカラー値を指定します。 |
font | すかし文字のFontオブジェクトを指定します。 |
string2 | すかし文字のテキストを示す文字列式を指定します。 | 利用法は任意です。
string3 | すかし文字のタイトル名を示す文字列式を指定します。 | 利用法は任意です。

解説

ハンコのすかし文字の指定、アプリケーション名、カラー、文字フォント、テキスト、およびタイトル名です。

例

サンプルコード

KnHankoCtl1.Watermark = True

KnHankoCtl1.WatermarkApplication = "e-ハンコドライバ"

KnHankoCtl1.WatermarkTitle = "ハンコ№123"

KnHankoCtl1.WatermarkText = "xxxxxxxx"


メソッド一覧

アルファベット昇順メソッド一覧

メソッド | 説明 | 備考
CreateStampData | 印影イメージの取得 |
CreateStampDataFile | 印影イメージファイルの作成 |


CreateStampDataメソッド

ハンコの印影イメージを取得します。

構文

pvStampData = object.GetStampData ( nStampDataFormat )

指定項目 | 内容 | 備考
pvStampData | イメージデータ（Byte配列）を格納する変数名を指定します。 |
object | オブジェクトを指すオブジェクト式です。 |
nStampDataFormat | 作成するイメージデータの形式を定数値 KnHankoData で指定します。 |

解説

ハンコの印影イメージを指定のイメージデータ形式で取得します。

例

サンプルコード

pvStampData = KnHankoCtl1.GetStampData( hanDataPng )


CreateStampDataFileメソッド

ハンコの印影イメージファイルを作成します。

構文

object.CreateStampDataFile nStampDataFormat, strFilePath

指定項目 | 内容 | 備考
object | オブジェクトを指すオブジェクト式です。 |
nStampDataFormat | 作成するイメージデータの形式を定数値 KnHankoData で指定します。 |
strFilePath | 作成するファイルパス名です。 |

解説

ハンコの印影イメージファイルを指定のイメージデータ形式で作成します。

例

サンプルコード

KnHankoCtl1.CreateStampDataFile hanDataBmp, "@KnHANKO.bmp"


イベント一覧

アルファベット昇順イベント一覧

イベント | 説明 | 備考
Click | ハンコのクリック通知 |
MouseDown | マウスボタンの押下通知 |
MouseUp | マウスボタンの解放通知 |
MouseMove | マウスポインタの移動通知 |


Clickイベント

ハンコのクリックを通知します。

構文

Private Sub Object_Click ()

指定項目 | 内容 | 備考
object | オブジェクトを指すオブジェクト式です。 |

解説

ハンコクリックを通知します。

例

サンプルコード

Private Sub KnHankoCtl1_Click()

Debug.Print "e-HANKO /Click"

Debug.Print KnHankoCtl1.StampCaption;"=";KnHankoCtl1.DataText

End Sub


MouseDownイベント

MouseDown、MouseMove、MouseUpイベント

マウスボタンの押下、移動、および解放を通知します。

構文

Private Sub Object__MouseDownEx(ByVal nButton As Integer, ByVal nShift As Integer, ByVal x As Single, ByVal y As Single)

Private Sub Object__MouseMoveEx(ByVal nButton As Integer, ByVal nShift As Integer, ByVal x As Single, ByVal y As Single)

Private Sub Object__MouseUpEx(ByVal nButtonAs Integer, ByVal nShift As Integer, ByVal x As Single, ByVal y As Single)

指定項目 | 内容 | 備考
object | オブジェクトを指すオブジェクト式です。 |
Button | 押された、または離されたボタンを示す整数値を定数値 VisualBasic定数値で指定します。 |
Shift | 引数Button が示すマウスボタンが押された、または離されたときのShift キー、Ctrl キーおよびAlt キーの状態を示す整数値を定数値 VisualBasic定数値 で指定します。 |
x, y | マウスポインタの現在位置を表す数値です。 |

解説

ボタンの押下、解放、およびマウスポインタの移動に対し、その操作マウスボタン、シフトキーの押下状態、およびマウスポインタの位置を通知します。

注意事項

ハンコが押されると、最後の MouseUp イベントも含めてすべてのマウスイベントは、そのハンコに対して発生します。したがって、マウス イベントによって返されるマウス ポインタの x、y 座標値が、常にイベントが発生したハンコの領域内にあるとは限りません。

例

サンプルコード

Private Sub KnHankoCtl1_MouseDown(ByVal nButton As Integer,ByVal nShift As Integer,ByVal x As Single,ByVal y As Single)

Debug.Print "e-HANKO /MouseDown";"(";nButton;",";nShift;",";x;",";y;")"

End Sub

Private Sub KnHankoCtl1_MouseMove(ByVal nButton As Integer,ByVal nShift As Integer,ByVal x As Single,ByVal y As Single)

Debug.Print "e-HANKO /MouseMove";"(";nButton;",";nShift;",";x;",";y;")"

End Sub

Private Sub KnHankoCtl1_MouseUp(ByVal nButton As Integer,ByVal nShift As Integer,ByVal x As Single,ByVal y As Single)

Debug.Print "e-HANKO /MouseUp";"(";nButton;",";nShift;",";x;",";y;")"

End Sub


概要

e-ハンコ（KnHANKOコンポーネント）は、ハンコの印影を簡単に作成できる電子捺印コンポーネントです。

（KnHANKOコンポーネントは、サーバーコンポーネントとして印影イメージファイル、および印影イメージByte配列を生成できます。また、電子捺印ActiveXコントロールとして、コンテナにおいて利用することも可能です。

特に印影イメージデータの取得は特長的で、サーバーサイドのASP（Active Server Pages）等で利用し、Ｗｅｂページ（htmlファイル）からそのASPを参照することで、ActiveXコントロールとしてではなく、画像として印影イメージを利用できます。

サンプルイメージ

次は、KnHANKOコンポーネントのイメージとサンプルアプリケーションのイメージです。

関連ファイル

KnHANKOコンポーネントは、次の関連ファイル、およびプログラムIDを持ちます。

ファイル/プログラムID | 内容
KnHANKO.dll | KnHANKOコンポーネントです。
KnHANKO.lic | KnHANKOコンポーネントのライセンスファイルです。 正しく対応するライセンスファイルが無い場合は、トライアル版と見なされ、ご利用が制限されます。
e-HANKO.chm | KnHANKOコンポーネントのヘルプファイルです。
KnHANKO.KnHankoCtl | KnHANKOコンポーネントのプログラムID（ProgID）です。

ランタイムライセンス（サーバー関連）

KnHANKOコンポーネントをサーバーコンポーネントとして、すなわち、サーバーにおいて画像化した印影を利用する場合は、各クラインアトにライセンスは必要ありません。

KnHANKOコンポーネントをActiveXコントロールとして利用する場合は、各クラインアトへダウンロード（セットアップ）されるため、そのクライアント数分のランタイムライセンスが必要です。

機能概要

以下に、KnHANKOコンポーネントの主な機能を概略します。

ハンコの要素とタイプ

ハンコの要素には、キャプション、日付、および名前があり、その組み合わせによるタイプの指定が可能です。タイプには、各要素単独、２要素の組み合わせ、および３要素による構成があります。

キャプション、日付、および名前文字列

ハンコの要素（キャプション、日付、および名前）文字列それぞれに対し、文字フォント、サイズ等の指定が可能です。文字列が、ハンコのフレームに収まらないサイズの場合は、はみ出した部分をクリッピングする指定の他、フレームに収まるサイズへの自動調整機能の指定も個別に指定可能です（デフォルト）。

キャプション、および名前文字列は複数行の指定も可能であり、これにより縦書き表示を実現できます。

また、日付の初期文字列は、作成年月日の?<西暦>/<月>/<日>?形式文字列とします。

ハンコのフレーム形状

ハンコのフレーム形状として、枠なし、丸型、角丸矩形、矩形の指定が可能です。また、角丸矩形についてはその角の丸みの度合いも指定できます。

また、フレームの太さもHIMETRIC(1/100mm)単位で指定できます。

ハンコのカラー

ハンコはフォアグランド（ハンコ文字列、およびフレーム）のカラーとバックグランド（背景）のカラーの指定が可能です。

バックグランド（背景）のカラーは、印影イメージの取得、および印影イメージファイルの作成において有効です。（一般の表示においては無効です。）

データテキスト

KnHANKOコンポーネントはその情報レジスタとしてDataTextプロパティを持ちます。形態は文字列で、任意の用途に利用可能です。

印影イメージの取得

印影イメージデータをByte配列として取得できます。（ビットマップ、およびＰＮＧ形式。）

例えば、この機能をサーバーサイドのASP（Active Server Pages）等で利用し、Ｗｅｂページ（htmlファイル）からＰＮＧ形式により参照すれば、ActiveXコントロールとしてではなく、Ｗｅｂページにおけるピクチャ参照として印影イメージを表現できます。（特にIEに限定されないＷｅｂページの作成に有効です。）

印影イメージファイルの作成

印影イメージデータのピクチャファイルを作成できます。（ビットマップ、およびＰＮＧ形式。）

基本事項

キャプション（Caption）、日付（Date）、および名前（Name）は上下に並び、その順序は固定です。（入れ替えはできません。）

KnHANKOコンポーネントは、セキュリティ機能は持ちません。（セキュリティ機能については、システム全体の中で設計・実装するスタイルを想定しています。）

注意事項

ヘルプファイルにおける言語インタフェースの記述は、Visual Basicを対象としています。他の言語環境でご利用される場合は、お手数ですが対応の言語に置き換えてご利用ください。

トライアル版

KnTilingButtonコントロールのトライアル版における機能制限は次の通りです。

実行ファイルの実行不可

実行ファイル（exe）はその作成時にトライアル版としてマーキングされます。このため、その実行については拒否されます。

ハンコ（印影）のカラー固定

ハンコ（印影）のカラーは、その指定に係わらず、常に青色となります。


プロパティページ

KnHANKOコンポーネントは、次のプロパティページを持ちます。

プロパティページ | 内容 | 備考
General | 基本的なプロパティを指定します。 |
フォント | テキストのフォントプロパティを指定します。 |
色 | カラープロパティを指定します。 |
ピクチャ | 使用するピクチャプロパティを指定します。 |

General

【General】プロパティページは、基本的なプロパティを指定します。

次は、【General】プロパティページのサンプルイメージです。

フォント

【ﾌｫﾝﾄ】プロパティページは、テキストのフォントプロパティを指定します。

次は、【ﾌｫﾝﾄ】プロパティページのサンプルイメージです。

色

【色】プロパティページは、カラープロパティを指定します。

次は、【色】プロパティページのサンプルイメージです。

ピクチャ

【ﾋﾟｸﾁｬ】プロパティページは、使用するピクチャプロパティを指定します。

次は、【ﾋﾟｸﾁｬ】プロパティページのサンプルイメージです。


ハンコの要素とタイプ

ハンコの要素には、キャプション、日付、および名前があり、その組み合わせによるタイプの指定が可能です。タイプには、各要素単独、２要素の組み合わせ、および３要素による構成があります。

StampTypeプロパティ

0 - hanTypeNull | 1- hanTypeCaption | 2 - hanTypeDate | 3 - hanTypeName
4 - hanTypeCaptionDate | 5 - hanTypeCaptionName | 6 - hanTypeDateName | 7 - hanTypeCaptionDateName

StampCaptionプロパティ：　株式会社;:ナルボ

StampDateプロパティ：　28-Jun-01

StampNameプロパティ：　Knowlbo/COM;:e-ハンコ


キャプション、日付、および名前テキスト

ハンコの要素（キャプション、日付、および名前）テキストそれぞれに対し、文字フォント等の指定が可能です。

フォントの自動サイズ調整

テキストの表示が、ハンコのフレームに収まらない場合は、はみ出した部分をクリッピングするモードと、フレームに収まるサイズへの自動調整モード（デフォルト）の指定が可能です。

キャプションと名前のテキスト

キャプションと名前のテキストは、複数行の入力が可能です。改行を入力するには、テキストフィールドにおいて改行コード（「Enter」キー）を入力するか、英字のセミコロン（「;」）を入力します。

また、文字フォントについてはそれぞれ３つの文字フォントの利用が可能です。３つの文字フォントは各行の中で英字のコロン（「:」）を区切り文字として順に割り付けられます。（英字のコロン（「:」）は、表示されません。）

Captionプロパティ | 株式会社 :ナルボ
Dateプロパティ | 平成13年8月22日
Nameプロパティ | 課長 :小泉
印影イメージ |

キャプションと名前のテキストを合わせると６つのフォントを利用することができるため、多彩な印影に対応することができます。

Captionプロパティ | 〒169-0073 東京都新宿区百人町 1-22-27 太陽ビル４Ｆ :株式会社 : ナルボ
Dateプロパティ | <なし>
Nameプロパティ | 代表取締役 : 奈留歩 太郎 ::TEL. 03 - 3361 - 7601 ::FAX. 03 - 3361 - 7735 ::http://www.knowlbo.co.jp
印影イメージ |

複数行を縦書き表現に利用することもできます。

Captionプロパティ | 株式会社 :ナルボ
Dateプロパティ | 2001/08/22
Nameプロパティ | 尚 斎 :部 大 藤 :長
印影イメージ |

英字のセミコロン（「;」）、および英字のコロン（「:」）は改行文字、およびフォントの区切り文字として解釈されるため、表示文字として利用することはできません。ただし、各行の３つ目以降のコロンは区切り文字としては無意味なため、通常の文字として認識されます。

日付のテキスト

日付のテキストは１行です。また、任意の文字フォント、文字サイズの利用が可能です。

日付の初期テキストは、作成年月日の「<西暦>/<月>/<日>」の形式となります。


ハンコの形状とカラー

ハンコのサイズ

ハンコのサイズは、StampWidthプロパティと Stampheightプロパティにより指定します。

ハンコの形状

ハンコの形状は、FrameShapeプロパティにより指定します。｢枠なし｣、｢丸型｣、｢角丸矩形｣、および、｢矩形｣が指定でき、角丸矩形についてはその角の丸みの度合いも指定できます。

FrameShapeプロパティ

0 - hanFrameNull | 1- hanFrameRound | 2 - hanFrameRoundRect | 3 - hanFrameRect

フレームの太さは、FrameWidthプロパティにより指定できます。

FrameWidthプロパティ

1mm | 5mm | 10mm

ハンコのカラー

ハンコのカラーは、ハンコ文字列、およびフレームに対して、ForeColorプロパティにより指定できます。

また、印影イメージの取得、および印影イメージファイルの作成においては、ただし、バックグランド（背景）のカラーもBackColorプロパティにより指定できます。（一般の表示においては無効です。）

ForeColorプロパティ

赤 | 黒 | 青


ハンコのピクチャ

スタンプの背景としてピクチャ（ビットマップ、メタファイル）を取り込むことができます。取り込むピクチャは、BackgroundPictureプロパティにより指定します。

署名（サイン）のピクチャをそのままスタンプイメージとして利用することもできます。


データテキスト

KnHANKOコンポーネントは任意の情報を保持可能な DataTextプロパティ（文字列）を持ちます。


印影イメージの取得

印影イメージデータをByte配列として取得できます。（ビットマップ、およびＰＮＧ形式。）

例えば、この機能をサーバーサイドのASP（Active Server Pages）等で利用し、Ｗｅｂページ（htmlファイル）からＰＮＧ形式により参照すれば、ActiveXコントロールとしてではなく、Ｗｅｂページにおけるピクチャ参照として印影イメージを表現できます。（特にIEに限定されないＷｅｂページの作成に有効です。）

これは、GetStampDataメソッドにより実現します。

次は、このGetStampDataメソッドをASP（Active Server Pages）で利用した例です。

GetStampData.htm

<HTML>

<HEAD>

<META NAME="GENERATOR" Content="Microsoft Visual Studio 6.0">

<TITLE></TITLE>

</HEAD>

<BODY>

<P>GetStampDataPNG.asp→<IMGsrc="http://futagoyama/KnHanko/GetStampData/GetStampDataPNG.asp">&nbsp;

</BODY>

</HTML>

GetStampDataPNG.asp

<%@ LANGUAGE=?VBSCRIPT? %>

<%

Response.Expires = 0

Response.Buffer = True

Response.Clear

Response.ContentType = "image/png"

'--------

Set KnHanko = Server.CreateObject("KnHANKO.KnHankoCtl.1")

KnHanko.StampWidth = 3000 ?横サイズ

KnHanko.StampHeight = 3000 ?縦サイズ

KnHanko.FrameShape = 1 ?フレーム形状：丸形

KnHanko.FrameWidth = 50 ?フレーム幅

KnHanko.ForeColor = RGB(255, 0, 0) ?印影カラー：赤

KnHanko.StampType = 7 ?ハンコタイプ：キャプション｜日付｜名前

KnHanko.StampCaption = StampCaption ?キャプション

KnHanko.StampDate = StampDate ?日付

KnHanko.StampName = StampName ?名前

'--------------------------------

Response.BinaryWrite KnHanko.GetStampData(1) 'ＰＮＧ

'--------------------------------

Response.End Set KnHanko = Nothing

%>

上記の例では、印影イメージデータをＰＮＧ形式で取得しています。

KnHANKOコンポーネントのインスタンスはServerオブジェクトのCreateObject（ProgID："KnHANKO.KnHankoCtl.1"）により生成しています。

注意事項

htm、およびaspファイルによるサンプルプログラムを動作確認する場合は、それらファイルのディレクトリをＷｅｂサーバの仮想ディレクトリに設定し、ブラウザから参照してください。

→http://<サーバー>/<仮想ディレクトリ>/GetStampData/GetStampData.htm


印影イメージファイルの作成

印影イメージデータのピクチャファイルを作成できます。（ビットマップ、およびＰＮＧ形式。）

これは、CreateStampDataFileメソッドにより実現します。

次は、このCreateStampDataFileメソッドを利用したＶＢによる例です。

Dim KnHanko As Object

'-------- Load

Private Sub Form_Load()

Set KnHanko = New KNHANKOLib.KnHankoCtl

KnHanko.StampWidth = 4000 ?横サイズ

KnHanko.StampHeight = 4000 ?縦サイズ

KnHanko.FrameShape = hanFrameRound ?フレーム形状：丸形

KnHanko.FrameWidth = 50 ?フレーム幅

KnHanko.ForeColor = RGB(255, 0, 0) ?印影カラー：赤

KnHanko.StampType = hanTypeCaptionDateName ?ハンコタイプ：キャプション｜日付｜名前

End Sub

'-------- Unload

Private Sub Form_Unload(Cancel As Integer)

Set KnHanko = Nothing

End Sub

'-------- Click

Private Sub Command1_Click()

KnHanko.StampCaption = StampCaption ?キャプション

KnHanko.StampDate = StampDate ?日付

KnHanko.StampName = StampName ?名前

'--------------------------------

KnHanko.CreateStampDataFile hanDataBmp, "@KnHANKO.BMP"

'--------------------------------

Image1.Picture = LoadPicture("@KnHANKO.BMP")

End Sub

上記の例では、印影イメージデータのビットマップファイル（@KnHANKO.BMP）を作成しています。

KnHANKOコンポーネントのインスタンスはNew（コクラス名：KNHANKOLib.KnHankoCtl）により生成しています。このため、「ﾌﾟﾛｼﾞｪｸﾄ」メニューの「参照設定」において、「Knowlbo/COM e-HANKO 2.0」をチェックし、参照設定しておく必要があります。


テクニカルサポートについて

Knowlbo(R)製品のご使用中に、このオンラインヘルプやインストールディレクトリ下にある「README.WRI」 に記載されている内容で解決できない問題が発生した場合には、弊社カスタマ・コミュニケーションズまでお問い合わせください。お問い合わせの際には、下記事項を確認の上、電子メールにてお送りくださるようお願い申し上げます。また、弊社ホームページにオンラインサポートページも設けております。（電話、ファックスなどによるテクニカルなお問い合わせは、お受けしていません。）

なお、お問い合わせいただいた内容により、回答に数日かかることがございます。あらかじめご了承ください。

また、寄せられたご質問については、他のお客様の参考とするため、断りなく雑誌やその他メディア、弊社ホームページなどで公開させていただくことがあります。

お送りいただいたリストやファイルなどで公開できないものについては、その旨を明示しておいてください。

また、お送りいただいたリスト，ファイルについては原則として返却いたしません。ご了承ください。

コントロールコンテナの使用方法やプログラミングに関するご質問などにつきましては、ご容赦いただいております。あらかじめご了承ください。

お問い合わせの場合に必要な情報

お問い合わせの場合、お手数ですが下記事項を電子メールに明記してお問い合わせください。

（法人の場合）法人名、部署名
ユーザ名
連絡先住所
電話番号
FAX番号
電子メールアドレス
製品名（バージョン）

エクスプローラで製品を選択し、右クリックをして表示されるメニューからプロパティを選択すると製品のプロパティダイアログが表示されます。そこに記載されているファイルバージョンをご明記ください。

シリアルNO
コンテナ製品名（バージョン）
OS名（バージョン）
使用PC機種名
お問い合わせ内容


プロジェクトへの組み込みと削除について

Visual Basicの場合

Visual Basicのプロジェクトへの組み込み

e-ハンコのプロジェクトへの組み込みは、以下の手順で行います。

（１）Visual Basicの【プロジェクト(P)】メニューから【コンポーネント(O)】を選択します。

（２）【コントロール】タグ内リストボックスから｢e-ハンコ｣コントロールを選択します。｢e-ハンコ｣コントロールの名称は以下のように表示されます。

表示される名称 | Knowlbo/COM e-HANKO 2.0
コントロール | KnHANKO.dll

（３）｢e-ハンコ｣コントロールのチェックボックスをチェックし【OK】ボタンをクリックします。

（４）ツールボックスに｢e-ハンコ｣コントロールのアイコンが表示されれば、プロジェクトへの組み込みは完了です。

Visual Basicのプロジェクトからの削除

e-ハンコのプロジェクトからの削除は、以下の手順で行います。

（１）フォーム上からコントロールを削除します。

（２）Visual Basicの【プロジェクト(P)】メニューから【コンポーネント(C)】を選択します。

（３）【コントロール】タグ内リストボックスから｢e-ハンコ｣コントロールを選択します。

（４）｢e-ハンコ｣コントロールのチェックボックスを未チェック状態にして【OK】ボタンをクリックします。

（５）ツールボックスから｢e-ハンコ｣コントロールのアイコンが削除されれば、プロジェクトからの削除は完了です。

ASPでご利用の場合

e-ハンコをサーバーコンポーネントとしてASP等で利用する場合、ASPファイルが動作するサーバーへのセットアップだけで利用可能です。各クライアントへのインストールは必要ありません。

サーバーへのセットアップは以下の手順で行います。

（１）e-ハンコのインストーラーを用いてe-ハンコをサーバーの任意のフォルダにインストールします。

（２）ご利用のASPファイルが入っているフォルダをインターネットサービスマネージャー等で、仮想ディレクトリとして登録します。（登録の方法はインターネットサービスマネージャーのヘルプなどをご参照ください。）

（３）以上の手順を行ってから、e-ハンコを使用しているASPファイルをWebブラウザで参照することで、ご利用できます。


ファイルの配布について

ランタイム時のファイルの配布について

e-ハンコ Version2は、その開発用インストールＰＣ１台につき１ライセンスを必要とします。

また、本製品を組み込んだアプリケーションを配布する場合、ランタイムライセンスが必要となります。ランタイムライセンスは、アプリケーション配布PC台数分が必要です。お客様がご購入された本製品には、開発ライセンス（１ライセンス）の他、ランタイムライセンスを１０ライセンス含んでおります。追加の開発もしくはランタイムライセンスが必要な場合は、弊社ホームページのライセンスオプションをご覧いただくか、あるいは、カスタマ・コミュニケーションズまでご連絡ください。

COMコントロールを使用したアプリケーションをその他のシステムで実行させるためには、その実行に先立ち、使用しているCOMコントロールのシステム登録を必要とします。通常、アプリケーションのセットアッププログラムを作成し、これに対応します。

Visual Basic付属のディストリビューションウィザードなどのインストーラ作成ツールを利用することで、COMコンポーネントの登録を含むセットアッププログラムを作成することが可能です。

また、COMコントロールのシステム登録ツール"REGSVR32.EXE"により、手動で登録することも可能です。コマンドプロンプトもしくは「ファイル名を指定して実行」ダイアログより、以下のようにコマンドを実行してください。

REGSRV32 "<パス名>\e-HANKOV2\KnHANKO.dll"

ご注意

本製品のご使用にあたり、上記事項以外は、お客様と弊社との契約事項は特にありません。ただし、「ソフトウェア使用許諾契約」に記載している制限事項は、厳守してください。

Visual Basicのディストリビューションウィザード（セットアップウィザード）使用後の注意

Visual Basicセットアップウィザード（ディストリビューションウィザード）を利用して作成したセットアッププログラムを編集用インストールPCで実行すると、その後、再編集の操作が正常に動作しないことがあります。

これは、セットアッププログラムがCOMコンポーネントをWindowsのシステムディレクトリにコピーし、システム環境に登録（レジストリへの登録）を行うためです。

セットアッププログラム実行後、編集が必要な場合は、システム環境にe-HANKOをインストールしたディレクトリ下のファイルで再登録してください。

登録は、コマンドプロンプトもしくは、「ファイル名を指定して実行」ダイアログで以下のコマンドを実行してください。

登録は方法は、上記と同様になります。


Knowlbo/COM 製品のバージョンについて

Knowlbo(R)/COM製品のバージョンについて

Knowlbo(R)/COM製品のバージョンについて

Knowlbo(R)/COM製品は、プロダクト・バージョンとデベロップ・バージョンを持ちます。

Version <Mojor>.<Minor> R<Revision>

<Mojor>：プロダクトバージョンです。

<Minor>：同一プロダクトにおけるマイナーバージョン（改善版）です。

<Revision>：障害を含むリリースバージョン（対応版）です。

プロダクトバージョン

プロダクトバージョンは、その製品を通して普遍的なバージョンであり、各種マテリアル、製品カタログ、および製品広告に表示されます。

例：Version 2

デベロップバージョン

デベロップバージョンは開発バージョンであり、製品のアップデートバージョンとして製品におけるマイナーバージョン（改善版）、およびリリースバージョン（対応版）を識別します。

例：Version 2.0 R3

コンポーネント・バージョン

コンポーネントバージョンは複数のコンポーネントを含む製品において、各コンポーネント別のデベロップバージョンであり、（製品）デベロップバージョンとは独立して管理されます。各コンポーネントのバージョン情報ダイアログに表示されます。（製品が単一コンポーネントである場合は、デベロップバージョンと同一になります。）

マイナーバージョンアップのご案内

当製品のマイナーバージョンは、お客様からのご要望が多く、またご要望の強いもののなかから、比較的小規模なものを選び改善したバージョンです。

改善内容とアップデートはアップデータダウンロードページに掲載いたします。

マイナーバージョンのアップデートは無料です。必要に応じてホームページからダウンロードしてご利用ください。


最新製品情報について

ナルボ製品の最新情報は、弊社ホームページの製品情報をご覧ください。


最初のトピック

プロジェクト 'Knowlbo/COM e-ハンコ Version2' の最初のトピック


Pictureオブジェクト

Pictureオブジェクト | 内容 | 備考
なし | ピクチャはありません。 |
ビットマップ、アイコン、メタファイル | デザイン時にプロパティウィンドウでビットマップ、アイコン、メタファイルを指定して値を設定することができます。また、実行時にはLoadPicture 関数を使うことによって、値をロード（設定）することができます。 |


VisualBasic定数値

VisualBasic定数値 | 内容 | 備考
1 -(vbLeftButton) | 左ボタンが押されました。 |
2 -(vbRightButton) | 右ボタンが押されました。 |
4 -(vbMiddleButton) | 中央ボタンが押されました。 |
VisualBasic定数値 | 内容 | 備考
1 -(VbShiftMask) | Shift キーが押されました。 |
2 -(VbCtrlMask) | Ctrl キーが押されました。 |
4 -(vbAltMask) | Alt キーが押されました。 |


カラー値

カラー値 | 内容 | 備考
通常のRGBカラー | カラーパレット、またはコード内でRGB 関数等により指定する色です。 |
システムカラー | システムカラー定数を使って指定する色です。Windows のコントロールパネルの設定に基づいて変換されます。 |