xp

( V2.1R0 )

Microsoft Office 2000 / XP 対応　簡単電子捺印ツール！

はじめに

Knowlbo/Office e-スタンプ xpをお求めいただき誠にありがとうございます。

e-スタンプは、Microsoft Office 2000 / XP 対応の簡単電子捺印ツールです。

このヘルプ情報は、e-スタンプのソフトウェア仕様許諾権、サポート情報、使用方法などの各種ドキュメント、およびサンプルコードなどから構成されています。また、最新の製品情報や修正版、FAQなどについては、弊社ホームページにて公開されます。

登録商標など

Knowlbo(R)はナルボの登録商標です。

Microsoft、WindowsNT、Windows95、Windows98、Windows2000、Windows Me、Visual Basic、Visual C++、Office 2000、Office XPは米国Microsoft Corporationの米国およびその他の国における登録商標です。

その他記載されている会社名、製品名は各社の登録商標、または商標です。


ソフトウェア使用許諾権について

ソフトウェア使用許諾契約

お客様がディスクのケースを開封するかまたはディスクのシールをはがした場合に、お客様はこの契約に同意してご利用いただけるものといたします。この契約に同意できない場合には、ご利用することはできません。

このソフトウエア使用許諾契約とディスクは、お客様が適法に使用許諾を受けたことの証しとなりますので、どちらも大切に保管してください。

適用

以下の条項は、お客様がこの契約書とともに入手された株式会社ナルボ（以下「弊社」といいます）のソフトウエア製品（コンピュータプログラムとマニュアルその他の関連資料を含み、以下「本製品」といいます）に適用します。

使用の許諾

（１）お客様は「ユーザー登録」に記載された担当者の管理下においてのみ本製品を使用できます。

（２）お客様は本製品をコンピュータネットワーク上で複数の使用者により使用することはできません。ただし、マニュアルその他にネットワーク対応製品である旨が記載されている製品はこの限りではありません。

（３）お客様はいかなる事由によろうとも本製品を譲渡、販売、転貸することはできません。

（４）本製品のパッケージに同一の機能を有し、形態の異なるディスクが複数入っていた場合、お客様はそのうちの一種類のディスクのみをご使用いただけます。お客様が残りのディスクを他のコンピュータで使用したり、他者に譲渡、販売、転貸することはできません。また、お客様のご要望に応じて弊社が本製品と同一の機能を有し、形態の異なるディスクをお客様に提供した場合も同様とします。

（５）本製品のマニュアルその他にロイヤルティフリーの言語関連製品である旨が記載されている場合に限り、お客様が販売する製品に本製品のランタイムモジュールを組み込むことができます。ただし、この場合においても本製品の使用法やその他一切を公開することはできません。また、販売する製品には本製品の有効な著作権表示を明記しなければなりません。

保証の範囲

（１）弊社は本製品の仕様を予告なしに変更することがあります。

（２）本製品の品質および性能に関して発生する問題は、お客様の費用負担をもって処理することとします。

（３）弊社は、いかなる場合にも、お客様が本製品を使用または運用した結果に関して一切責任を負いません。

（４）本製品にお客様が目的を遂げることができないような重大な欠陥（磁気の消滅、破損など）があった場合、欠陥のない製品と交換するかまたはその製品代金相当額をもって弊社の保証限度とします。ただし、この保証は、お客様が本製品をご購入されてから30日以内に限らせていただきます。

テクニカルサポートサービス

弊社は、ユーザー登録によりご登録をいただいたお客様に対してのみ、テクニカルサポートサービスをご提供するものとします。但し、本製品（バージョン）の販売が終了して、１年以上が経過した場合にはその限りではありません。

契約期間

（１）本契約はお客様に製品を納入した日より発効します。また、納入日は証票により確認するものとします。

（２）お客様が本契約の条項のいずれかに違反した場合、本契約は解除されます。またこの場合を含め、製品の代金は返還いたしません。


ユーザ登録について

弊社では、よりよい製品とサービスをお届けするために、お客様の情報を登録させていただきたく存じます。お手数ではございますが、弊社ホームページまたは「ユーザ登録FAX用紙」を印刷のうえ、必要事項をご記入のうえファックスにてお送りください。

ご登録いただきましたお客様には、製品やサービスについてのインフォメーションをお届けいたします。ご住所や電話番号など、ご登録内容に変更が生じた場合は弊社カスタマ･コミュニケーションズまでお知らせください。

ご登録のない場合、バージョンアップサービスやテクニカルサポートサービスをご提供できないことがございます。

カスタマ・コミュニケーションズのご案内

製品内容やユーザ登録についてのお問い合わせは、下記にて承ります。

カスタマ・コミュニケーションズ
電話番号 | 03-3361-7755 | 11:00～12:00 13:00～19:00 （月～金）
FAX番号 | 03-3361-7735 | 24時間受け付け
電子メールアドレス | knocx@knowlbo.co.jp |


ユーザ登録FAX用紙

ユーザ登録は、オンラインでWebページから行う方法と、当FAX用紙を印刷していただき、内容を明記の上、FAXにてお送りいただく方法があります。

FAX. 03-3361-7735 （株）ナルボ　カスタマコミュニケーションズ行

ユーザ登録項目 | 内容
製品名 | Knowlbo/Office e-スタンプ Version2
シリアル№ |
登録キー |
登録形態 | □法人 □個人
法人名* |
所属部署名* |
役職名* |
ユーザ名 |
住所 | 〒
電話番号 | （ ） －
FAX番号 | （ ） －
電子メールアドレス |

※｢登録キー｣はバージョン情報ダイアログのレジストレーションキーを記入してください。
※｢登録形態｣が法人の場合は、｢法人名*｣、｢所属部署名*｣、および｢役職名*｣も記入してください。

本製品購入のきっかけとなった媒体は何ですか

□雑誌記事　□雑誌広告　□DM　□展示会　□店頭　□知人の紹介
□ホームページ　□電子メール　□その他

e-スタンプをご利用のOfficeアプリケーションは何ですか

□Word　□Excel　□PowerPoint

本製品ご購入の理由、ご意見、ご要望を教えてください


インストール／アンインストールについて

e-スタンプVersion2は、次の環境でご使用いただけます。

基本ソフトウェア

Windows 98 （日本語版）
Windows Me （日本語版）
Windows NT4.0 （日本語版）
Windows 2000 （日本語版）

Officeアプリケーション

Word 2000 / XP （日本語版）
Excel 2000 / XP （日本語版）
PowerPoint 2000 / XP （日本語版）

インストールの手順

インストールは次の手順で行います。

(１)e-スタンプのCD-ROMをドライブにセットします。

(２)e-スタンプのセットアップメニューが自動的に起動しますので、そこで【SETUP】をクリックすると、セットアップが開始されます。始まらない場合は、以下の手順を行ってください。

コントロールパネルの【アプリケーションの登録と削除】を起動します。

「アプリケーションの登録と削除のプロパティ」画面で【セットアップ】／【インストール】ボタンをクリックします。

「フロッピーディスクまたはＣＤ－ＲＯＭからのセットアップ」の画面で、【次へ】ボタンをクリックします。

セットアッププログラムの実行」画面のテキストボックスに D:\setup.exe（ＣＤ－ＲＯＭドライブがD:の場合）と表示されるので、【完了】ボタンをクリックします。ここまでの操作により、セットアッププログラムが起動されます。

(２)起動されたセットアッププログラムの「ようこそ」の画面で、【次へ】をクリックします。

(３)製品ライセンス契約の同意確認の画面になるので、【はい】をクリックします。

(４)インストール／アンインストールの選択画面になるので、【Install】ボタンをクリックしたうえで、【次へ】のボタンをクリックします。

(５)インストール先フォルダの選択画面が表示されるので、インストール先を選択し、【次へ】をクリックします。

(６)セットアップの方法は標準のまま【次へ】をクリックします。

(７)プログラムフォルダ名を入力し、【次へ】をクリックします。(コンパクトを選択した場合、この手順は省略されます。)

(８)インストール情報の確認画面が表示されるので、【はい】／【次へ】をクリックします。

(９)自動的にファイルがコピーされます。「インストール完了」ダイアログが表示されれば、インストールは完了です。Readmeファイルをすぐに読みたい場合は、【はい（Y）】ボタンをクリック、あとで読む場合は【いいえ(N)】ボタンをクリックして終了して下さい。

アンインストールの手順

（１）e-スタンプのアンインストールに先立ちOffice製品からe-スタンプの登録を削除します。COMアドインの登録と削除を参照してください。

（２）コントロールパネルの【アプリケーションの登録と削除】を起動します。

（３）e-スタンプ"を選択し、【追加と削除】を押します。

（４）アンインストールの確認画面が表示されるので、【ＯＫ】をクリックします。

（５）自動的にファイル等が削除され、完了すると、完了メッセージが表示されます。正常終了のメッセージが表示されれば、アンインストールは完了です。


xp

Microsoft Office 2000 / XP 対応　簡単電子捺印ツール！

e-スタンプの概要

Knowlbo/Office e-スタンプは、Microsoft Office 2000 / XP の機能を拡張し、Word や Excel などのドキュメントにシームレスな操作で電子捺印を実現するツールです。

印影（スタンプ）にはそれぞれ名前を付けて、複数のスタンプを管理することができます。

スタンプのデザインはとても簡単で、設定画面でいくつかの項目を変更するだけです。ユーザ認証として、ログオンしたユーザ名などを自由な位置に引用することもできます。

任意の画像データ（ビットマップ、メタファイル）を取り込むこともでき、印影の背景に画像データを重ねたり、署名（サイン）の画像データとして利用することもできます。

スタンプは、画像データで挿入されます。このため、e-スタンプのない環境においても問題なく表示できます。画像形式にはメタファイルやビットマップなどが選択できますが、メタファイル形式では印影の背景に付加情報（アタッチノートと呼びます）を埋め込んだりすることも可能です。

捺印するときに、Officeの持つ文書の保護機能や改版機能を実行させることができます。これらの機能を利用し、捺印した文書を改ざんから保護することも可能です。

スタンプの履歴情報をログファイルとして残すこともできます。

e-スタンプは、次の Office 2000 / XP アプリケーションに対応しています。

Word 2000 / XP
Excel 2000 / XP
PowerPoint 2000 / XP

Microsoft Office 2000 / XP に共通した組み込み機能として動作するため、各Office製品において同様の操作で利用可能です。

Office XP のWord、およびExcel については、｢スマートタグ｣にも対応しています。例えば、「印」というテキストの認識により、登録されているスタンプの一覧がポップアップメニュー表示され、ここで、任意のスタンプを選択することで、「印」の位置に捺印することができます。

また、Visual Basic for Application(VBA) などから e-スタンプを制御できるように、プロパティやメソッドを公開しています。これにより、プログラミング知識のある高度な Officeユーザーであれば、Officeをフロントエンドとしたワークフロー型アプリケーションなどの構築も可能です。

サンプル画面

関連ファイル

e-スタンプ xp は、次のファイルにより提供します。

ファイル | 内容
KnStampXP.dll | e-スタンプ xp （コンポーネント）です。 （COMアドインのスタイルを持つDLLファイルです。）
KnStampXP.lic | e-スタンプ xp のライセンスファイルです。 正しいライセンスファイルが無い場合は、トライアル版と見なされ、ご利用が制限されます。
e-StampXP.chm | e-スタンプ xp のヘルプファイルです。 （このファイルです。）
KnHANKO.dll | e-スタンプの内部コンポーネントです。 （ActiveX コンポーネントのスタイルを持つDLLファイルです。）

トライアル版

e-スタンプ xp のトライアル版では、最初のご利用から３０日間だけご利用することができます。（機能的な制限はありません。）

有効期限が過ぎてスタンプしようとした場合は、次のメッセージが表示され、スタンプをキャンセルします。


基本的な機能と操作

e-スタンプは、ホストアプリケーション（Word、Excel など）に組み込まれたメニューとツールバーにより操作します。

メニュー

次は、Wordにおけるメニューのイメージです。

メニュー | 説明
スタンプ | 選択スタンプの印影（画像）をホストアプリケーションに挿入します。
スタンプ プロパティ | スタンプ プロパティ・ダイアログが表示されます。 スタンプの各種プロパティ情報を設定（参照）できます。
ユーザ プロパティ | ユーザ プロパティ・ダイアログが表示されます。 ユーザの各種プロパティ情報を設定（参照）できます。
スタンプ保護の解除 | 選択スタンプの保護情報を用いて保護を解除します。 一時的にスタンプの保護を解除することができます。
スタンプ保護 | 選択スタンプの保護情報を用いて保護を実行します。 スタンプ保護の解除により解除された保護を再び保護することができます。
ヘルプ | 当ヘルプファイルを表示します。 機能、および操作について確認できます。
バージョン情報 | e-スタンプのバージョン情報を表示します。 バージョン情報について確認できます。

次は、バージョン情報ダイアログのイメージです。

ツールバー

次は、ツールバーのイメージです。

メニューバー内のイメージ

フロート状態のイメージ

それぞれのアイコンは、左から、メニューの【スタンプ】、スタンプ名コンボボックス、【スタンプ プロパティ】、【ユーザ プロパティ】、【スタンプ保護の解除】、【スタンプ保護】、および【ヘルプ】に対応します。

スタンプ名コンボボックスにより利用するスタンプを選択します。

スタンプ名コンボボックスは、インストール直後の状態では「*」（基本スタンプ）のみ存在しています。


スタンプの管理

e-スタンプは複数の印影（スタンプ）を管理することができます。それぞれのスタンプには任意の名前を付けて管理します。

スタンプの管理は、スタンプ プロパティ・ダイアログの左下にあるフレームにおいて、選択しているスタンプを確認しながら操作します。

スタンプの選択

作成済みのスタンプはツールバーのスタンプ名コンボボックスにより選択できます。選択されたスタンプ内容は、スタンプ プロパティ・ダイアログに反映されます。選択されたスタンプは、【コピー】、【削除】、および【名前の変更】の対象となります。また、【 [image] 】ボタンによりスタンプすることもできます。

スタンプの選択は、上記のスタンプ プロパティ・ダイアログの他、ツールバーにおいても可能です。

スタンプの新規作成

スタンプは、【新規】ボタンにより作成することができます。

【新規】ボタンにより表示される｢スタンプの新規作成｣ダイアログで、新しいスタンプ名を入力します。

スタンプ名の文字には、カンマ文字（,）を除いてすべて利用可能です。カンマ文字の利用に対してはメッセージボックスが表示されます。（そのスタンプ名は認められません。）

また、入力したスタンプ名が既に存在する場合もメッセージボックスが表示されます。（そのスタンプ名は認められません。）

スタンプのコピー

選択スタンプと同じ内容のスタンプを、【コピー】ボタンにより作成することができます。

【コピー】ボタンにより表示される｢スタンプのコピー｣ダイアログで、新しいスタンプ名を入力（変更）します。

許可されるスタンプ名などについては、｢スタンプの新規作成｣と同様です。

スタンプの削除

選択スタンプを、【削除】ボタンにより削除することができます。

スタンプの削除に当たっては、操作ミスを抑制するために削除確認メッセージボックスが表示されます。

スタンプの削除後は基本スタンプ（「*」）が選択されます。

基本スタンプ（「*」）を削除することはできません。。基本スタンプ（*）の削除に対してはメッセージボックスが表示され、削除は拒否されます。

スタンプの名前の変更

選択スタンプの名前は、【名前の変更】ボタンにより変更することができます。

【名前の変更】ボタンにより表示される｢スタンプの名前の変更｣ダイアログで、スタンプ名を変更します。

許可されるスタンプ名などについては、｢スタンプの新規作成｣と同様です。

また、基本スタンプの名前（「*」）は変更できません。。基本スタンプの名前（「*」）の変更に対してはメッセージボックスが表示され、名前の変更は拒否されます。


スタンプのデザイン

e-スタンプは、必要な印影を簡単にデザインすることができます。

スタンプのデザインは、｢スタンプ プロパティ｣ダイアログの【デザイン】ページの右上にあるプレビュー表示を確認しながら進めます。

スタンプのタイプ

スタンプのテキストは、キャプション、日付、および名前から構成され、これら３つのテキストを任意に有効／無効とすることでスタンプのタイプを指定します。

キャプション | × | ○ | × | ×
日付 | × | × | ○ | ×
名前 | × | × | × | ○
印影イメージ |  |  |  |
キャプション | ○ | ○ | × | ○
日付 | ○ | × | ○ | ○
名前 | × | ○ | ○ | ○
印影イメージ |  |  |  |

キャプション、日付、および名前は上下に並び、その順序の入れ替えはできません。

キャプションと名前のテキスト

キャプションと名前のテキストは、複数行の入力が可能です。また、文字フォントについてはそれぞれ３つの文字フォントの利用が可能です。

改行を入力するには、テキストフィールドにおいて改行コード（「Enter」キー）を入力するか、英字のセミコロン（「;」）を入力します。また、３つの文字フォントは各行において、英字のコロン（「:」）を区切り文字として順に割り付けられます。（英字のコロン（「:」）は、表示されません。）

キャプションと名前のテキストを合わせると６つのフォントを利用することができるため、多彩な印影に対応することができます。

複数行を縦書き表現に利用することもできます。

英字のセミコロン（「;」）、および英字のコロン（「:」）は改行文字、およびフォントの区切り文字として解釈されるため、表示文字として利用することはできません。ただし、各行の３つ目以降のコロンは区切り文字としては無意味なため、通常の文字として認識されます。

フォントの自動サイズ調整

テキストのフォントサイズは任意に設定することもできますが、【自動サイズ】チェックボックスが有効（初期値）な場合は、テキスト表示がスタンプのフレームに収まるサイズへ自動調整（縮小）します。

自動サイズ調整で表示サイズおよび表示位置などが、期待したものでない場合には、【自動サイズ】チェックボックスを無効としてフォントサイズの指定で調整してください。

システムデータの引用

キャプションと名前のテキストにはログオンしたユーザ名、日付などのシステムデータを次の書式により引用することができます。

引用書式 | 引用内容 | 備考
#user | ログオンしたユーザ名を引用します。 | 引用により、ユーザ認証アイコン（ [image] ／ [image] ）を付加します。
#name | ログオンしたユーザのフルネームを引用します。 | 引用により、ユーザ認証アイコン（ [image] ／ [image] ）を付加します。 Windows NT / 2000 においてのみ有効です。
#pc | コンピュータ名を引用します。 |
#domain | ドメインネームを引用します。 | Windows NT / 2000 においてのみ有効です。
#now(<日時書式>) | スタンプの日時を引用します。 <日時書式>にはスタンプ日時の表示書式を指定します。 |

引用書式は、直接入力する方法の他、【システムデータの引用】フレームのインタフェースを用いて、引用内容を確認しながらテキストフィールドへ挿入（【⇒キャプション】、【⇒名前】）することも可能です。

「#user」、および「#name」については、システムデータからの引用であることを示すユーザ認証アイコンを印影イメージに付加することができます。

ユーザ認証アイコンは、【ユーザ認証アイコン表示】チェックボックスにより、表示を抑制することも可能です。

ユーザ認証アイコン | 説明 | 備考
 | ローカルなコンピュータにログオンしている場合に付加されるアイコンです。 |
 | グローバルなサーバへログオンしている場合に付加されるアイコンです。 | Windows NT / 2000 においてのみ有効です。

スタンプ日時の引用により、キャプションや名前フィールドに日時を配置することも可能です。

日付のテキスト

日付のテキストは１行です。また、任意の文字フォント、文字サイズの利用が可能です。フォントの自動サイズ調整については、キャプション、および名前のテキストと同様です。

任意の文字を入力できる他に、スタンプ日時の表示書式も利用可能です。

また、バージョン１との互換のため、次の表示書式も利用可能です。

表示書式 | 表示内容 | 備考
* | <西暦>/<月>/<日> | 「*」のみで有効
+ | <時>:<分>:<秒> | 「+」のみで有効

スタンプのサイズと形状

スタンプのサイズは最大 60mm×50mm（横×縦）で、1mm単位で指定できます。【デザイン】ページの右上にあるプレビュー表示スライダで設定します。

スタンプのフレーム形状には、｢枠なし｣、｢丸型｣、｢角丸矩形｣、および、｢矩形｣が指定でき、【フレーム形状】コンボボックスで選択します。

枠なし | 丸型 | 角丸 | 矩形

フレームの幅（太さ）は、1/10mm単位で指定できます。【フレーム幅】スライダで設定します。

1（0.1mm） | 5（0.5mm） | 10（1.0mm）

スタンプのカラー

スタンプのカラーは、任意のカラー値を指定できます。【スタンプカラー】コンボボックス設定します。

スタンプのピクチャ

ピクチャ（ビットマップ、メタファイル）をスタンプの背景として取り込むことができます。取り込むピクチャは、【スタンプピクチャ】コンボボックスで指定し、【スタンプピクチャ】チェックボックスによりその表示を制御します。

署名（サイン）のピクチャをそのままスタンプイメージとして利用することもできます。


スタンプのセキュリティ

e-スタンプは、セキュリティ機能として、スタンプ時にドキュメント（データ）の保護、および改版が可能です。

これらのセキュリティ機能は、ホストアプリケーション（Word、Excelなど）における保護機能、および改版機能を利用します。

セキュリティ機能は、｢スタンプ プロパティ｣ダイアログの【セキュリティ】ページで指定します。

各ホストアプリケーションにおける保護と改版

スタンプのセキュリティ機能は、対応するホストアプリケーションに依存します。

次にそれぞれのホストアプリケーションにおける対応内容をまとめます。

ホストアプリケーション | 保護 | 改版 | 備考
Word | 文書の保護機能を有効とします。 フォームフィールドを保護対象外として、文書を保護します。 | 有効です。 | 保護の解除のWord操作は、【ツール】－【文書保護の解除】です。
Excel | シートの保護機能を有効とします。 データ、オブジェクト、およびシナリオを保護対象として、シートを保護します。 | 無効です。 | 保護の解除のExcel操作は、【ツール】－【保護】－【シート保護の解除】です。
Power Point | 無効です。 | 無効です。 |

セキュリティ状態に対応したスタンプアイコン

スタンプのセキュリティ状態は、スタンプアイコンにも反映されます。

スタンプアイコン | 保護 | 改版 | 改版保護
 | × | × | ×
 | ○ | × | ×
 | × | ○ | ×
 | ○ | ○ | ×
 | × | ○ | ○
 | ○ | ○ | ○

スタンプによる保護

スタンプ時にホストアプリケーションの保護機能を実行させることができます。【保護】チェックボックスにより指定します。

保護されたドキュメント（データ）は、保護を解除しない限り、改ざんできなくなります。必要に応じて保護のパスワードを設定してください。

保護オプションのパスワードは、主にグループ共通のパスワードとしての利用が有効です。

スタンプによる改版と改版保護

スタンプ時に、ホストアプリケーションの改版機能を実行させることができます。【改版】チェックボックスにより指定します。

改版されたドキュメント（データ）は、ひとつの版として同一ファイル内に管理されます。また、それぞれ任意のコメントを設定することもできます。コメントに｢*｣を指定すると自動的にツ次の形式のコメントとなります。

<キャプション>, <日付>, <名前>

次はWordにおける版の管理ダイアログのサンプルイメージです。

【改版】チェックボックスの指定に、更に【改版保護】チェックボックスを指定することで、改版ドキュメント（データ）に対して保護をかけることができます。必要に応じて改版保護のパスワードを設定してください。

改版保護のパスワードは、主に各個人のパスワードとしての利用が有効です。

パスワードの設定と変更における注意

保護、および改版保護のパスワードを用いて保護したドキュメントは、パスワードを忘れた場合にはその保護は解除できなくなりますので十分にご注意ください。

保護、および改版保護のパスワードを変更すると、それまでに保護されたドキュメントの保護の解除は、ホストアプリケーションの操作により対応してください。


スタンプのオプション

スタンプに対するオプションは、｢スタンプ プロパティ｣ダイアログの【スタンプ オプション】ページで指定します。

スタンプ画像の形式

スタンプ画像の形式には、｢メタファル形式｣、｢ビットマップ形式｣、および、｢PNG形式｣が指定できます。【スタンプ画像形式】コンボボックスで選択します。

アタッチノート

印影の背景には、付加情報（アタッチノートと呼びます）を埋め込むことができます。アタッチノートは、スタンプ画像に添付したい詳細情報や関連情報を埋め込み利用します。初期値は水色（透かし文字のイメージ）です。

アタッチノートは、グループ名、パーソナル名、およびメモから構成されます。

アタッチノートは、スタンプ画像の形式がメタファイルの場合のみ有効です。

次はアタッチノートに小さな文字で多くの情報を付加してスタンプした、サンプルイメージとその拡大イメージです。

スタンプカラーをベースカラーと合わせることで（例えば白色）、表示や印刷から見えなくすることもできます。


ユーザのオプション

ユーザに対するオプションは、｢ユーザ プロパティ｣ダイアログの【ユーザ オプション】ページで指定します。

セキュリティ指定確認ダイアログ

e-スタンプのセキュリティとして、スタンプ時の保護、改版、および改版保護の指定が可能ですが、これらのセキュリティをともなうスタンプに対して、その指定の確認ダイアログの表示を指定できます。【保護指定確認】、【改版指定確認】、および【改版保護指定確認】チェックボックスで指定します。

｢セキュリティ指定確認｣ダイアログでは、スタンプのキャンセルや、一時的にセキュリティ指定を変更することもできます。

スタンプの位置

Excel へのスタンプは、カレントセルにオーバーラップした画像挿入となり、そのセルに対するスタンプの位置を【横位置】、および【縦位置】コンボボックスで選択することができます。

 | 左揃え | 中央揃え | 右揃え
上揃え |  |  |
中央揃え |  |  |
下揃え |  |  |

スタンプログ

スタンプの履歴をログファイルに残すことができます。

【スタンプログ】チェックボックスで有効／無効を指定し、【ログフォルダ】、および【ログファイル名】でログファイルを指定します。

ログの出力形式は次の通りです。

<日時>, <ユーザ名>, <スタンプ名(スタンプテキスト)>, <対象ドキュメント>

ログファイル名の日付形式により、年単位、月単位、および日単位のログファイルとして利用可能です。


e-スタンプのスマートタグ対応

e-スタンプのスマートタグへの対応

e-スタンプは、ホストアプリケーション（Word、Excel）の｢スマートタグ｣機能にも対応しています。

スマートタグは、Office アプリケーションで扱われるデータの中で認識可能なデータに付加されるタグであり、その認識データに対する実行可能なアクションリストを提示するものです。また、データの認識は、スマートタグをサポートする Office アプリケーションに共通したものとなります。

スマートタグは、Office XP のWord、およびExcel でのみ有効な機能です。その他のアプリケーション、および Office 2000 のアプリケーションにおいては機能しません。

次は、Excelにおけるe-スタンプのスマートタグ・アクションリストの表示イメージです。テキストの｢印｣を認識し、スタンプ名の一覧をスタンプアクションとして提示しています。

e-スタンプのサポートするスマートタグ対応の認識とアクションは、次の通りです。

スマートタグ | 認識テキスト | アクション | 備考
e-スタンプ | 印 スタンプ stamp <スタンプ名> | 【<スタンプ名>】 ⇒ 認識テキスト位置へスタンプ | <スタンプ名>は、今回のホストアプリケーション起動前に登録されているすべてのスタンプ名が対象となります。
ナルボ | ナルボ knowlbo | 【（株）ナルボ】 ⇒ （株）ナルボのWebページへリンク 【ナルボ製品 】⇒ ナルボ製品案内のWebページへリンク |

英字の大文字、小文字は区別しません。

スマートタグのプロパティ

スマートタグのプロパティは、｢ユーザ プロパティ｣ダイアログの【スマートタグ】ページで指定します。

現在、設定プロパティをもつアクションは、スタンプ アクションのみになります。

スタンプ アクションのプロパティ

プロパティ | 説明 | 指定
適用範囲クリア | スタンプに対して、その認識テキスト（範囲）のクリアを指定することができます。 | 【適用範囲クリア】チェックボックス
プロパティ指定確認ダイアログ | スタンプに対して、そのプロパティの確認ダイアログの表示を指定することができます。 プロパティ指定の確認ダイアログでは、スタンプのキャンセルや、一時的にプロパティ指定を変更することもできます。 現在対象となるプロパティは、｢適用範囲クリア｣のみです。 | 【プロパティ指定確認ダイアログ／スタンプ】チェックボックス


e-スタンプのオートメーション制御

e-スタンプは、オートメーション制御が可能です。

オートメーション制御方法

e-スタンプを制御する手順は次の通りです。

①Applicationオブジェクトの COMAddInsプロパティと e-スタンプのプログラムIDから、対応するCOMAddinオブジェクト参照を取得します。

e-スタンプのプログラムIDは次の通りです（ホストアプリケーション別）。

ホストアプリケーション | e-スタンプのプログラムID （ProgID）
Word | "KnStamp.dsrWord"
Excel | "KnStamp.dsrExcel"
PowerPoint | "KnStamp.dsrPowerPoint"

②取得したCOMAddinオブジェクトのObjectのKnStampプロパティから、オートメーション・オブジェクト参照を取得します。

③取得したオートメーション・オブジェクト（KnStamp）のメソッド、およびプロパティを利用します。

オートメーション制御サンプル

次の例では、Visual Basic から Word のアドインとして機能している e-スタンプを制御しています。

変数の宣言

Dim objWordApp As Object
'----
Dim objWordDsr As Object '-- ①
Dim objWordKnStamp As Object '-- ②
'----
Dim docTarget As Document
Private m_strMyPath As String
Private Const c_strMyDOC = "StampControl.doc"

e-スタンプ（Operationプロパティ）の取得とWordのロード

Set appWord = CreateObject("Word.Application")
'----
m_strMyPath = App.Path & "\"
Set docTarget = appWord.Documents.Open(m_strMyPath & c_strMyDOC)
appWord.Visible = True

'----
Set objWordDsr = appWord.COMAddIns.Item("KnStamp.dsrWord") '-- ①
Set objWordKnStamp = objWordDsr.Object.KnStamp '-- ②

スタンプの実行 -- ③

objWordKnStamp.SelectStamp ("*") '-- "*"（基本スタンプ）を選択！

objWordKnStamp.StampCaption = objWordKnStamp.StampCaption & vbCrLf & "Automation"

'---- スタンプ！
objWordKnStamp.Stamp

サポートするプロパティ

e-スタンプのサポートするプロパティは、プロパティ一覧、およびそれぞれのプロパティの説明を参照してください。

サポートするメソッド

e-スタンプのサポートするメソッドは、メソッド一覧、およびそれぞれのメソッドの説明を参照してください。


FrameShape

スタンプ枠の形状

定数値 | 説明 | 備考
0 | 枠なし |
1 | 丸型 |
2 | 角丸矩形 |
3 | 矩形 |


StampHorzPosition

スタンプ（オーバーラップ）の配置－横位置

定数値 | 説明 | 備考
0 | 左揃え |
1 | 中央揃え |
2 | 右揃え |

StampVertPosition

スタンプ（オーバーラップ）の配置－縦位置

定数値 | 説明 | 備考
0 | 上揃え |
1 | 中央揃え |
2 | 下揃え |


StampImageFormat

スタンプの画像形式

定数値 | 説明 | 備考
0 | ビットマップ形式 |
1 | ＰＮＧ形式 |
2 | メタファイル形式 |


StampType

スタンプのタイプ

定数値 | 説明 | 備考
0 | 空 |
1 | キャプションのみ |
2 | 日付のみ |
3 | 名前のみ |
4 | キャプション｜日付 |
5 | キャプション｜名前 |
6 | 日付｜名前 |
7 | キャプション｜日付｜名前 |


プロパティ一覧

アルファベット昇順プロパティ一覧

プロパティ | 説明 | 備考
AttachNote | アタッチノートの指定 |
AttachNoteColor | アタッチノートのカラー |
AttachNoteFont | アタッチノートの文字列フォント |
AttachNoteGroupName | アタッチノートのグループ名 |
AttachNoteMemo | アタッチノートのメモ（テキスト） |
AttachNotePersonalName | アタッチノートのパーソナル名 |
FrameShape | スタンプ枠の形状 |
FrameWidth | スタンプ枠の幅 |
StampActionTargetClear | スマートタグのスタンプ アクションにおける適用範囲のクリアの指定 |
StampActionPropertyConfirm | スマートタグのスタンプ アクションにおけるプロパティ指定確認ダイアログの表示の指定 |
StampCaptionFontAutoSize | スタンプのキャプションのフォントに対する自動サイズの指定 |
StampCaptionFonts | スタンプのキャプションのフォント |
StampCaptionText | スタンプのキャプション・テキスト |
StampCaptionView | スタンプのキャプションの表示テキスト |
StampColor | スタンプのカラー |
StampDateFont | スタンプの日付のフォント |
StampDateFontAutoSize | スタンプの日付のフォントに対する自動サイズの指定 |
StampDateText | スタンプの日付テキスト |
StampDateView | スタンプの日付の表示テキスト |
StampHeight | スタンプの縦サイズ |
StampHorzPosition | スタンプ（オーバーラップ）の配置の横位置 |
StampImageFormat | スタンプの画像形式 |
StampLog | スタンプログの指定 |
StampLogFileDateFormat | スタンプログの日付フォーマット |
StampLogFileExt | スタンプログのファイルの拡張子 |
StampLogFilePrefix | スタンプログのファイルのプリフィックス |
StampLogFolderPath | スタンプログのフォルダパス |
StampNameFontAutoSize | スタンプの名前のフォントに対する自動サイズの指定 |
StampNameFonts | スタンプの名前のフォント |
StampNames | 登録（作成）済みスタンプ名 |
StampNamesCount | 登録（作成）済みのスタンプ数 |
StampNameText | スタンプの名前テキスト |
StampNameView | スタンプの名前の表示テキスト |
StampPicture | スタンプピクチャの指定 |
StampPictureFile | スタンプピクチャ・ファイル名（パス） |
StampProtect | スタンプによるドキュメントの保護指定 |
StampProtectConfirm | 保護指定によるセキュリティ指定確認ダイアログの表示の指定 |
StampProtectPassword | ドキュメントの保護のパスワード |
StampType | スタンプのタイプ |
StampVersionUp | スタンプによるドキュメントの改版指定 |
StampVersionUpComment | ドキュメントの改版のコメント |
StampVersionUpConfirm | 改版指定によるセキュリティ指定確認ダイアログの表示の指定 |
StampVersionUpProtect | 改版ドキュメントの保護指定 |
StampVersionUpProtectConfirm | 改版保護指定によるセキュリティ指定確認ダイアログの表示の指定 |
StampVersionUpProtectPassword | 改版ドキュメントの保護のパスワード |
StampVertPosition | スタンプ（オーバーラップ）の配置の縦位置 |
StampWidth | スタンプの横サイズ |
UserCertifyIcon | スタンプのユーザ認証アイコン表示の指定 |


AttachNoteプロパティ

AttachNoteプロパティ、AttachNoteGroupNameプロパティ、AttachNotePersonalNameプロパティ、AttachNoteMemoプロパティ

アタッチノートの指定、グループ名、パーソナル名、およびメモ（テキスト）を設定、または取得します。

構文

object.AttachNoteNote [ = boolean ]

object.AttachNoteGroupName [ = string ]

object.AttachNotePersonalName [ = string ]

object.AttachNoteMemo [ = string ]

指定項目 | 内容 | 備考
object | オブジェクトを指すオブジェクト式です。 |
boolean | アタッチノートの指定を示すブール式を指定します。 | Trueで有効。
string | アタッチノートのグループ名、パーソナル名、およびメモ（テキスト）を示す文字列式を指定します。 |

解説

アタッチノートの指定、グループ名、パーソナル名、およびメモ（テキスト）です。

AttachNoteGroupNameプロパティ（グループ名）は、グループ共通の認証情報として利用できます。

AttachNotePersonalNameプロパティ（パーソナル名）は、各個人の認証情報として利用できます。

例

サンプルコード

objKnStamp.AttachNoteNote = True

objKnStamp.AttachNoteGroupName = "カスタマコミュニケーションズ"

objKnStamp.AttachNotePersonalName = "斎藤みなみ"

objKnStamp.AttachNoteMemo = "Knowlbo/COM e-スタンプ"


AttachNoteColorプロパティ

アタッチノートのテキストカラーを設定、または取得します。

構文

object.AttachNoteColor [ = color ]

指定項目 | 内容 | 備考
object | オブジェクトを指すオブジェクト式です。 |
color | アタッチノートのテキストカラー値を指定します。 |

解説

アタッチノートのテキストカラーです。

例

サンプルコード

objKnStamp.AttachNoteColor = RGB(&H00,&H00,&HFF)

objKnStamp.AttachNoteColor = &HFF0000


AttachNoteFontプロパティ

アタッチノートのフォントを設定、または取得します。

構文

object.AttachNoteFont [ = font ]

指定項目 | 内容 | 備考
object | オブジェクトを指すオブジェクト式です。 |
font | アタッチノートのテキストフォントのFontオブジェクトを指定します。 |

解説

アタッチノートのフォントです。

例

サンプルコード

objKnStamp.AttachNoteFont.Name = "Arial"

objKnStamp.AttachNoteFont.Bold = True

objKnStamp.AttachNoteFont.Italic = False

objKnStamp.AttachNoteFont.Underline = True

objKnStamp.AttachNoteFont.StrikeThrough = False

objKnStamp.AttachNoteFont.Size = 16 '-- 16ポイント

Print "AttachNoteFont Weight =" objKnStamp.AttachNoteFont.Weight


FrameShapeプロパティ

スタンプ枠の形状を設定、または取得します。

構文

object.FrameShape [ = number ]

指定項目 | 内容 | 備考
object | オブジェクトを指すオブジェクト式です。 |
number | スタンプ枠の形状を定数値で指定します。 |

解説

スタンプ枠の形状です。

例

サンプルコード

opeStamp.FrameShape = 2


FrameWidthプロパティ

スタンプ枠の幅を設定、または取得します。

構文

object.FrameWidth [ = value ]

指定項目 | 内容 | 備考
object | オブジェクトを指すオブジェクト式です。 |
value | スタンプ枠の幅を指定します。 | 1/100mmの単位で指定します

解説

スタンプ枠の幅です。

例

サンプルコード

objKnStamp.FrameWidth = 50


StampActionTargetClearプロパティ

StampActionTargetClearプロパティ、StampActionPropertyConfirmプロパティ

スマートタグのスタンプ アクションにおける適用範囲のクリアの指定、およびプロパティ指定確認ダイアログの表示の指定を設定、または取得します。

構文

object.StampActionTargetClear [ = boolean ]

object.StampActionPropertyConfirm [ = boolean ]

指定項目 | 内容 | 備考
object | オブジェクトを指すオブジェクト式です。 |
boolean | スマートタグのスタンプ アクションにおける適用範囲のクリアの指定、およびプロパティ指定確認ダイアログの表示の指定を示すブール式を指定します。 | Trueで有効。

解説

スマートタグのスタンプアクションにおける適用範囲のクリアの指定、およびプロパティ指定確認ダイアログの表示の指定です。

例

サンプルコード

objKnStamp.StampActionTargetClear = True

objKnStamp.StampActionPropertyConfirm = True


StampCaptionFontAutoSizeメソッド

StampCaptionFontAutoSizeプロパティ、StampDateFontAutoSizeプロパティ、StampNameFontAutoSizeプロパティ

スタンプのキャプション、日付、および名前のフォントに対する自動サイズの指定を設定、または取得します。

構文

object.StampCaptionFontAutoSize [ = boolean ]

object.StampDateFontAutoSize [ = boolean ]

object.StampNameFontAutoSize [ = boolean ]

指定項目 | 内容 | 備考
object | オブジェクトを指すオブジェクト式です。 |
boolean | スタンプのキャプション、日付、および名前のフォントに対する自動サイズの指定を示すブール式を指定します。 | Trueで有効。

解説

スタンプのキャプション、日付、および名前のフォントに対する自動サイズの指定です。

例

サンプルコード

objKnStamp.StampCaptionFontAutoSize = True

objKnStamp.StampDateFontAutoSize = True

objKnStamp.StampNameFontAutoSize = True


StampCaptionFontsプロパティ

StampCaptionFontsプロパティ、StampDateFontプロパティ、StampNameFontsプロパティ

スタンプのキャプション、日付、および名前のフォントを設定、または取得します。

構文

object.StampCaptionFonts(nIndex) [ = font ]

object.StampDateFont [ = font ]

object.StampNameFonts(nIndex) [ = font ]

指定項目 | 内容 | 備考
object | オブジェクトを指すオブジェクト式です。 |
nIndex | フォントインデックスです。 | 0～3。
font | スタンプのキャプション、日付、および名前のフォントのFontオブジェクトを指定します。 |

解説

スタンプのキャプション、日付、および名前のフォントです。

例

サンプルコード

objKnStamp.StampCaptionFonts(nIndex).Name = "Arial"

objKnStamp.StampDateFont.Bold = True

objKnStamp.StampNameFonts(nIndex).Italic = True


StampCaptionTextプロパティ

StampCaptionTextプロパティ、StampDateTextプロパティ、StampNameTextプロパティ

スタンプのキャプション、日付、および名前のテキストを設定、または取得します。

構文

object.StampCaptionText [ = string ]

object.StampDateText [ = string ]

object.StampNameText [ = string ]

指定項目 | 内容 | 備考
object | オブジェクトを指すオブジェクト式です。 |
string | スタンプのキャプション、日付、および名前を示す文字列式を指定します。 |

解説

スタンプのキャプション、日付、および名前のテキストです。

例

サンプルコード

objKnStamp.StampCaptionText = "ナルボ"

objKnStamp.StampDateText = "*

objKnStamp.StampNameText = "斎藤 尚大"


StampCaptionViewプロパティ

StampCaptionViewプロパティ、StampDateViewプロパティ、StampNameViewプロパティ

スタンプのキャプション、日付、および名前の表示テキストを取得します。

構文

object.StampCaptionView

object.StampDateView

object.StampNameView

指定項目 | 内容 | 備考
object | オブジェクトを指すオブジェクト式です。 |

解説

スタンプのキャプション、日付、および名前の表示テキストです。

例

サンプルコード

strStampCaptionView = objKnStamp.StampCaptionView

strStampDateView = objKnStamp.StampDateView

strStampNameView = objKnStamp.StampNameView


StampColorプロパティ

スタンプカラーを設定、または取得します。

構文

object.StampColor [ = color ]

指定項目 | 内容 | 備考
object | オブジェクトを指すオブジェクト式です。 |
color | スタンプカラーのカラー値を指定します。 |

解説

スタンプカラーです。

例

サンプルコード

objKnStamp.StampColor = RGB(&HFF,&H00,&H00)

objKnStamp.StampColor = &H0000FF


StampHeightプロパティ

StampHeightプロパティ、StampWidthプロパティ

スタンプの縦サイズ、および横サイズを設定、または取得します。

構文

object.StampHeight [ = value ]

object.StampWidth [ = value ]

指定項目 | 内容 | 備考
object | オブジェクトを指すオブジェクト式です。 |
value | スタンプの縦サイズ、および横サイズを指定します。 | 1/100mmの単位で指定します

解説

スタンプの縦サイズ、および横サイズです。

例

サンプルコード

objKnStamp.StampHeight = 3000

objKnStamp.StampWidth = 3000


StampHorzPositionプロパティ

StampHorzPositionプロパティ、StampVertPositionプロパティ

スタンプ（オーバーラップ）の配置の横位置、および縦位置を設定、または取得します。

構文

object.StampHorzPosition[ = number ]

object.StampVertPosition[ = number ]

指定項目 | 内容 | 備考
object | オブジェクトを指すオブジェクト式です。 |
number | スタンプ（オーバーラップ）の配置を定数値で指定します。 |

解説

スタンプ（オーバーラップ）の配置の横位置、および縦位置です。

例

サンプルコード

objKnStamp.StampHorzPosition = 1

objKnStamp.StampVertPosition = 1


StampImageFormatプロパティ

スタンプの画像形式を設定、または取得します。

構文

object.StampImageFormat[ = number ]

指定項目 | 内容 | 備考
object | オブジェクトを指すオブジェクト式です。 |
number | スタンプのタイプを定数値で指定します。 |

解説

スタンプの画像形式です。

例

サンプルコード

objKnStamp.StampImageFormat = 2


StampLogプロパティ

StampLogプロパティ、StampLogFolderPathプロパティ、StampLogFilePrefixプロパティ、StampLogFileDateFormatプロパティ、StampLogFileExtプロパティ

スタンプログの指定、およびスタンプログのフォルダパス、ファイルのプリフィックス、日付フォーマット、拡張子を設定、または取得します。

構文

object.StampLog [ = boolean ]

object..StampLogFolderPath [ = string ]

object..StampLogFilePrefix [ = string ]

object..StampLogFileDateFormat [ = string ]

object..StampLogFileExt [ = string ]

指定項目 | 内容 | 備考
object | オブジェクトを指すオブジェクト式です。 |
boolean | スタンプログの指定を示すブール式を指定します。 | Trueで有効。
string | スタンプログのフォルダパス、ファイルのプリフィックス、日付フォーマット、拡張子を示す文字列式を指定します。 |

解説

スタンプピクチャの指定、およびスタンプピクチャ・ファイルのパス名です。

例

サンプルコード

objKnStamp.StampLog = True

objKnStamp.StampLogFolderPath = "C:\...\"

objKnStamp.StampLogFilePrefix = "#KnStamp.Log"

objKnStamp.StampLogFileDateFormat = "yyyy.mm"

objKnStamp.StampLogFileExt = "txt"


StampNamesプロパティ

StampNamesプロパティ、StampNamesCountプロパティ

登録（作成）済みスタンプ名、およびスタンプ数を取得します。

構文

object.StampNames(nIndex)

object.StampNamesCount

指定項目 | 内容 | 備考
object | オブジェクトを指すオブジェクト式です。 |
nIndex | スタンプのインデックスです。 | 0～。

解説

スタンプピクチャの指定、およびスタンプピクチャ・ファイル名（パス）です。

例

サンプルコード

strStampName = objKnStamp.StampNames(nIndex)

nStampNamesCount = objKnStamp.StampNamesCount


StampPictureプロパティ

StampPictureプロパティ、StampPictureFilePathプロパティ

スタンプピクチャの指定、およびスタンプピクチャ・ファイル名（パス）を設定、または取得します。

構文

object.StampPicture [ = boolean ]

object.StampPictureFilePath [ = string ]

指定項目 | 内容 | 備考
object | オブジェクトを指すオブジェクト式です。 |
boolean | スタンプピクチャの指定を示すブール式を指定します。 | Trueで有効。
string | スタンプピクチャ・ファイル名（パス）のを示す文字列式を指定します。 |

解説

スタンプピクチャの指定、およびスタンプピクチャ・ファイル名（パス）です。

例

サンプルコード

objKnStamp.StampPicture = True

objKnStamp.StampPictureFilePath = "C:\...\WorldMap.bmp"


StampProtectプロパティ

StampProtectプロパティ、StampProtectPasswordプロパティ

スタンプによるドキュメントの保護指定、およびドキュメントの保護のパスワードを設定、または取得します。

構文

object.StampProtect [ = boolean ]

object.StampProtectPassword [ = string ]

指定項目 | 内容 | 備考
object | オブジェクトを指すオブジェクト式です。 |
boolean | スタンプによるドキュメントの保護指定を示すブール式を指定します。 | Trueで有効。
string | スタンプによるドキュメントの保護指定のパスワードを示す文字列式を指定します。 |

解説

スタンプによるドキュメントの保護指定、およびドキュメントの保護のパスワードです。

StampProtectPasswordプロパティは、グループ共通のパスワードとしての利用が有効です。

例

サンプルコード

objKnStamp.StampProtect = True

objKnStamp.StampProtectPassword = "KNOWLBO"


StampProtectConfirmプロパティ

StampProtectConfirmプロパティ、StampVersionUpConfirmプロパティ、StampVersionUpProtectConfirmプロパティ

保護指定、改版指定、および改版保護指定によるセキュリティ指定確認ダイアログの表示の指定を設定、または取得します。

構文

object.StampProtectConfirm[ = boolean ]

object.StampVersionUpConfirm[ = boolean ]

object.StampVersionUpProtectConfirm[ = boolean ]

指定項目 | 内容 | 備考
object | オブジェクトを指すオブジェクト式です。 |
boolean | 保護指定、改版指定、および改版保護指定によるセキュリティ指定確認ダイアログの表示の指定を示すブール式を指定します。 | Trueで有効。

解説

保護指定、改版指定、および改版保護指定によるセキュリティ指定確認ダイアログの表示の指定です。

例

サンプルコード

objKnStamp.StampProtectConfirm = True

objKnStamp.StampVersionUpConfirm = True

objKnStamp.StampVersionUpProtectConfirm = True


StampTypeプロパティ

スタンプのタイプを設定、または取得します。

構文

object.StampType [ = number ]

指定項目 | 内容 | 備考
object | オブジェクトを指すオブジェクト式です。 |
number | スタンプのタイプを定数値で指定します。 |

解説

スタンプのタイプです。

例

サンプルコード

objKnStamp.StampType = 7


StampVersionUpプロパティ

StampVersionUpプロパティ、StampVersionUpCommentプロパティ、StampVersionUpProtectプロパティ、StampVersionUpProtectPasswordプロパティ

スタンプによる改版指定、改版コメント、改版ドキュメントの保護指定、および改版ドキュメントの保護のパスワードを設定、または取得します。

構文

object.StampVersionUp [ = boolean ]

object.StampVersionUpComment [ = string ]

object.StampVersionUpProtect [ = boolean ]

object.StampVersionUpProtectPassword [ = string ]

指定項目 | 内容 | 備考
object | オブジェクトを指すオブジェクト式です。 |
boolean | スタンプによる改版指定、および改版ドキュメントの保護指定を示すブール式を指定します。 | Trueで有効。
string | 改版コメント、および改版ドキュメントの保護のパスワードを示す文字列式を指定します。 |

解説

スタンプによる改版指定、改版コメント、改版ドキュメントの保護指定、および改版ドキュメントの保護のパスワードです。

StampVersionUpProtectPasswordプロパティは、各個人のパスワードとしての利用が有効です。

例

サンプルコード

objKnStamp.StampVersionUp = True

objKnStamp.StampVersionUpComment = "Version3.3"

objKnStamp.StampVersionUpProtect = True

objKnStamp.StampVersionUpProtectPassword = "knocx"


UserCertifyIconプロパティ

スタンプのユーザ認証アイコン表示の指定を設定、または取得します。

構文

object.UserCertifyIcon[ = boolean ]

指定項目 | 内容 | 備考
object | オブジェクトを指すオブジェクト式です。 |
boolean | スタンプのユーザ認証アイコン表示の指定を示すブール式を指定します。 | Trueで有効。

解説

スタンプのユーザ認証アイコン表示の指定です。

例

サンプルコード

objKnStamp.UserCertifyIcon= True


メソッド一覧

アルファベット昇順メソッド一覧

メソッド | 説明 | 備考
CopyStamp | 選択されているスタンプのコピースタンプの作成 |
NewStamp | 新しいスタンプの作成 |
Protect | 選択されているスタンプの保護パスワードによる保護 |
RemoveStamp | 指定のスタンプの削除 |
RenameStamp | 選択されているスタンプの名前の変更 |
SelectStamp | 登録（作成）済みのスタンプからスタンプの選択 |
ShowAbout | e-スタンプのバージョン情報ダイアログの表示 |
ShowHelp | e-スタンプのヘルプの表示 |
ShowStampProp | スタンプ プロパティ・ダイアログの表示 |
ShowUserProp | ユーザ プロパティ・ダイアログの表示 |
Stamp | ホストアプリケーションの指定位置にスタンプの挿入 |
Unprotect | 選択されているスタンプの保護パスワードによる保護の解除 |


CopyStampメソッド

選択されているスタンプのコピースタンプを作成します。

構文

object.CopyStamp strCopyStamp

指定項目 | 内容 | 備考
object | オブジェクトを指すオブジェクト式です。 |
strCopyStamp | コピー（作成）するスタンプのスタンプ名を示す文字列式を指定します。 |

解説

選択されているスタンプのコピースタンプを作成します。

例

サンプルコード

Call objKnStamp.CopyStamp "スタンプ１"


NewStampメソッド

新しいスタンプを作成します。

構文

object.NewStamp strNewStamp

指定項目 | 内容 | 備考
object | オブジェクトを指すオブジェクト式です。 |
strNewStamp | 新しく作成するスタンプのスタンプ名を示す文字列式を指定します。 |

解説

新しいスタンプを作成します。

例

サンプルコード

Call objKnStamp.NewStamp "スタンプ１"


Protectメソッド

Protectメソッド、Unprotectメソッド

選択されているスタンプの保護パスワードによる保護、および保護の解除を実行します。

構文

object.Protect

object.Unprotect

指定項目 | 内容 | 備考
object | オブジェクトを指すオブジェクト式です。 |

解説

選択されているスタンプの保護パスワードによる保護、および保護の解除を実行します。

例

サンプルコード

Call objKnStamp.Protect

Call objKnStamp.Unprotect


RemoveStampメソッド

指定のスタンプを削除します。

構文

object.RemoveStamp strRemoveStamp

指定項目 | 内容 | 備考
object | オブジェクトを指すオブジェクト式です。 |
strRemoveStamp | 削除するスタンプのスタンプ名を示す文字列式を指定します。 |

解説

指定のスタンプを削除します。

例

サンプルコード

Call objKnStamp.RemoveStamp "スタンプ１"


RenameStampメソッド

選択されているスタンプの名前を変更します。

構文

object.RenameStamp strRenameStamp

指定項目 | 内容 | 備考
object | オブジェクトを指すオブジェクト式です。 |
strRenameStamp | 変更するスタンプ名を示す文字列式を指定します。 |

解説

選択されているスタンプの名前を変更します。

例

サンプルコード

Call objKnStamp.RenameStamp "スタンプ１"


SelectStampメソッド

登録（作成）済みのスタンプからスタンプを選択します。

構文

object.SelectStamp strSelectStamp

指定項目 | 内容 | 備考
object | オブジェクトを指すオブジェクト式です。 |
strSelectStamp | 選択するスタンプ名を示す文字列式を指定します。 |

解説

登録（作成）済みのスタンプからスタンプを選択します。

例

サンプルコード

Call objKnStamp.SelectStamp "スタンプ１"


ShowAboutメソッド

e-スタンプのバージョン情報ダイアログを表示します。

構文

object.ShowAbout

指定項目 | 内容 | 備考
object | オブジェクトを指すオブジェクト式です。 |

解説

e-スタンプのバージョン情報ダイアログを表示します。

例

サンプルコード

Call objKnStamp.ShowAbout


ShowHelpメソッド

e-スタンプのヘルプを表示します。

構文

object.ShowHelp

指定項目 | 内容 | 備考
object | オブジェクトを指すオブジェクト式です。 |

解説

e-スタンプのヘルプを表示します。

例

サンプルコード

Call objKnStamp.ShowHelp


ShowStampPropメソッド

ShowStampPropメソッド、ShowUserPropメソッド

スタンプ プロパティ・ダイアログ、およびユーザ プロパティ・ダイアログを表示します。

構文

object.ShowStampProp

object.ShowUserProp

指定項目 | 内容 | 備考
object | オブジェクトを指すオブジェクト式です。 |

解説

スタンプ プロパティ・ダイアログ、およびユーザ プロパティ・ダイアログを表示します。

例

サンプルコード

Call objKnStamp.ShowStampProp

Call objKnStamp.ShowUserProp


Stampメソッド

ホストアプリケーションの指定位置にスタンプを挿入します。

構文

object.Stamp

指定項目 | 内容 | 備考
object | オブジェクトを指すオブジェクト式です。 |

解説

ホストアプリケーションの指定位置にスタンプを挿入します。

例

サンプルコード

Call objKnStamp.Stamp


テクニカルサポートについて

ナルボ製品のご使用中に、このオンラインヘルプやインストールディレクトリ下にある「README.WRI」 に記載されている内容で解決できない問題が発生した場合には、弊社カスタマ・コミュニケーションズまでお問い合わせください。お問い合わせの際には、下記事項を確認の上、ご連絡くださるようお願い申し上げます。また、弊社ホームページにオンラインサポートページも設けております。

なお、お問い合わせいただいた内容により、回答に数日かかることがございます。あらかじめご了承ください。

また、寄せられたご質問については、他のお客様の参考とするため、断りなく雑誌やその他メディア、弊社ホームページなどで公開させていただくことがあります。

お送りいただいたリストやファイルなどで公開できないものについては、その旨を明示しておいてください。

また、お送りいただいたリスト，ファイルについては原則として返却いたしません。ご了承ください。

Windows、およびOffice一般の使用方法などに関するご質問などにつきましては、ご容赦いただいております。あらかじめご了承ください。

お問い合わせの場合に必要な情報

お問い合わせの場合、お手数ですが下記事項を確認の上お問い合わせください。

（法人の場合）法人名、部署名
ユーザ名
連絡先住所
電話番号
FAX番号
電子メールアドレス
製品名および製品のバージョン

エクスプローラで製品を選択し、右クリックをして表示されるメニューからプロパティを選択すると製品のプロパティダイアログが表示されます。そこに記載されているファイルバージョンをご明記ください。

シリアルNO
Officeアプリケーション名、バージョン
OS名、バージョン
使用PC機種名
お問い合わせ内容


COMアドインの登録と削除について

COMアドインの登録

e-スタンプのインストール時に自動で登録されます。後から手動で登録する場合は以下の手順で行います。

(１)Office製品のメニューから【ツール】-【ユーザー設定】を選択します。

(２)ユーザー設定ダイアログの【コマンド】タグを選択し、分類【ツール】のコマンド【COMアドイン】をツールバーまでドラッグします。これで、ツールバーに【COMアドイン】が配置されます。

(３)ツールバーの【COMアドイン】を押します。

(４)表示されたCOMアドインダイアログから使用できるアドインの一覧のe-スタンプをチェックしOKを押します。

(５)にe-スタンプツールバー（スタンプアイコン、プロパティアイコン）が配置され登録が完了します。

COMアドインの削除

(１)COMアドインダイアログを表示します。登録の(1)～(3)の手順を参照してください。

(２)使用できるアドインの一覧のe-スタンプのチェックをはずしてOKを押します。

(３)ツールバーからe-スタンプがなくなり削除が完了します。


最新製品情報について

ナルボ製品の最新情報は、弊社ホームページの製品情報をご覧ください。


カラー値

カラー値 | 内容 | 備考
通常のRGBカラー | カラーパレット、またはコード内でRGB 関数等により指定する色です。 |
システムカラー | システムカラー定数を使って指定する色です。Windows のコントロールパネルの設定に基づいて変換されます。 |


スタンプ日時の表示書式

表示書式 | 表示内容 | 備考
c | ddddd および ttttt の書式で表した日付と時刻を、日付、時刻の順序で返します。指定された値に小数部がない場合は日付のみ、整数部がない場合は時刻のみを表す文字列を返します。 |
d | 日付を返します。1 桁の場合、先頭に 0 が付きません (1 ～ 31)。 |
dd | 日付を返します。1 桁の場合、先頭に 0 が付きます (01 ～ 31)。 |
ddd | 曜日を英語 (省略形) で返します (Sun ～ Sat)。 |
aaa | 曜日を日本語 (省略形) で返します (日～土)。 |
dddd | 曜日を英語で返します (Sunday ～ Saturday)。 |
aaaa | 曜日を日本語で返します (日曜日～土曜日)。 |
ddddd | 年、月、日を含む短い形式 (コントロール パネルで設定) で表した日付を返します。既定の短い日付形式は、m/d/yy です。 |
dddddd | 年、月、日を含む長い形式 (コントロール パネルで設定) で表した日付を返します。既定の長い日付形式は mmmm dd, yyyy です。 |
w | 曜日を表す数値を返します (日曜日が 1、土曜日が 7 となります)。 |
ww | その日が一年のうちで何週目に当たるかを表す数値を返します (1 ～ 54)。 |
m | 月を表す数値を返します。1 桁の場合、先頭に 0 が付きません (1 ～ 12)。ただし、h や hh の直後に m を指定した場合、月ではなく分と解釈されます。 |
mm | 月を表す数値を返します。1 桁の場合、先頭に 0 が付きます (01 ～ 12)。ただし、h や hh の直後に mm を指定した場合、月ではなく分と解釈されます。 |
mmm | 月の名前を英語 (省略形) の文字列に変換して返します (Jan ～ Dec)。 |
mmmm | 月の名前を英語で返します (January ～ December)。 |
q | 1年のうちで何番目の四半期に当たるかを表す数値を返します (1 ～ 4)。 |
g | 年号の頭文字を返します (M、T、S、H)。 |
gg | 年号の先頭の 1 文字を漢字で返します (明、大、昭、平)。 |
ggg | 年号を返します (明治、大正、昭和、平成)。 |
e | 年号に基づく和暦の年を返します。1 桁の場合、先頭に 0 が付きません。 |
ee | 年号に基づく和暦の年を 2 桁の数値を使って返します。1 桁の場合、先頭に 0 が付きます。 |
y | 1年のうちで何日目に当たるかを数値で返します (1 ～ 366)。 |
yy | 西暦の年を下 2 桁の数値で返します (00 ～ 99)。 |
yyyy | 西暦の年を 4 桁の数値で返します (100 ～ 9999)。 |
h | 時間を返します。1 桁の場合、先頭に 0 が付きません (0 ～ 23)。 |
hh | 時間を返します。1 桁の場合、先頭に 0 が付きます (00 ～ 23)。 |
n | 分を返します。1 桁の場合、先頭に 0 が付きません (0 ～ 59)。 |
nn | 分を返します。1 桁の場合、先頭に 0 が付きます (00 ～ 59)。 |
s | 秒を返します。1 桁の場合、先頭に 0 が付きません (0 ～ 59)。 |
ss | 秒を返します。1 桁の場合、先頭に 0 が付きます (00 ～ 59)。 |
ttttt | コントロール パネルで設定されている形式で時刻を返します。先頭に 0 を付けるオプションが選択されていて、時刻が午前または午後 10 時以前の場合、先頭に 0 が付きます。既定の形式は、h:mm:ss です。 |
AM/PM | 時刻が正午以前の場合は大文字で AM を返し、正午～午後 11 時 59 分の間は大文字で PM を返します。 |
am/pm | 時刻が正午以前の場合は小文字で am を返し、正午～午後 11 時 59 分の間は小文字で pm を返します。 |
A/P | 時刻が正午以前の場合は大文字で A を返し、正午～午後 11 時 59 分の間は大文字で P を返します。 |
a/p | 時刻が正午以前の場合は小文字で a を返し、正午～午後 11 時 59 分の間は小文字で p を返します。 |
AMPM | "12 時間制" が選択されていて、時刻が正午以前の場合は午前を表すリテラル文字列を、正午～午後 11 時 59 分の間は午後を表すリテラル文字列を返します。これらの文字列の設定および "12 時間制" の選択は、コントロール パネルで行います。AMPM は大文字、小文字のどちらでも指定できます。既定の形式は、AM/PM です。 |