はじめに

Knowlbo(R)/OCXシリーズ タイム ビュー Version3をお求めいただき誠にありがとうございます。

タイム ビューは、実用的な機能と豊富な表現力でさまざまな時間スケジュール情報をガント チャート形式で表示します。

このヘルプ情報は、タイム ビューのソフトウェア使用許諾権、サポート情報、使用方法などの各種ドキュメント、およびサンプルコードなどから構成されています。また、最新の製品情報や修正版、FAQなどについては、弊社ホームページにて公開されます。

登録商標など

Knowlbo(R)はナルボの登録商標です。

Microsoft、ActiveX、Windows、Windows NT、Visual Basic、Visual Studioは、米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

その他記載されている会社名、製品名は各社の登録商標、または商標です。

なお、本マニュアルの記述については、特に記載がない限り、Visual Basic言語を対象としています。他の言語環境でご利用される場合は、お手数ですが対応の言語に置き換えてご利用下さい。


バージョン3の新機能

バージョン3の新機能などについて

バージョン２をご利用のお客様のために、バージョン３の新機能などについて概略します。

Visual Studio.NET への対応

Visual Studio.NET をコンテナとして利用可能になりました。また、サンプルも提供しています。

関係線の設定

ピースを結ぶ関係線を設定することが可能になりました。プロジェクト管理アプリケーションで、タスク間の関係(先行タスクなど）を表現できます。

イナズマ線の設定

ピース間を結ぶイナズマ線を設定することが可能になりました。

セルのレベル設定

セルにレベルを設定することが可能になりました。プロジェクト管理アプリケーションで、タスクの親子関係の表現（サマリタスク表示）できます。

ピースの分割・結合のドラッグ＆ドロップ対応

ピースの分割・結合がドラッグ＆ドロップ操作で可能になりました。

セルの行移動

特定のセルおよびそのセルに対応するアイテム、ピースを行移動することが可能になりました。

吹き出しの設定

コントロール上に吹き出しを設定することが可能になりました。

画像出力

タイム ビューの表示画面を画像出力することが可能になりました。

テンプレート機能の強化

ピースなどのテンプレート機能をより簡単に扱えるようになりました 。


ソフトウェア使用許諾権について

ソフトウェア使用許諾契約

お客様がディスクのケースを開封するかまたはディスクのシールをはがした場合に、お客様はこの契約に同意してご利用いただけるものといたします。この契約に同意できない場合には、ご利用することはできません。

このソフトウエア使用許諾契約とディスクは、お客様が適法に使用許諾を受けたことの証しとなりますので、どちらも大切に保管してください。

適用

以下の条項は、お客様がこの契約書とともに入手された株式会社ナルボ（以下「弊社」といいます）のソフトウエア製品（コンピュータプログラムとマニュアルその他の関連資料を含み、以下「本製品」といいます）に適用します。

使用の許諾

（１）お客様は「ユーザ登録」に記載された担当者の管理下においてのみ本製品を使用できます。

（２）お客様は本製品をコンピュータネットワーク上で複数の使用者により使用することはできません。ただし、マニュアルその他にネットワーク対応製品である旨が記載されている製品はこの限りではありません。

（３）お客様はいかなる事由によろうとも本製品を譲渡、販売、転貸することはできません。

（４）本製品のパッケージに同一の機能を有し、形態の異なるディスクが複数入っていた場合、お客様はそのうちの一種類のディスクのみをご使用いただけます。お客様が残りのディスクを他のコンピュータで使用したり、他者に譲渡、販売、転貸することはできません。また、お客様のご要望に応じて弊社が本製品と同一の機能を有し、形態の異なるディスクをお客様に提供した場合も同様とします。

（５）本製品のマニュアルその他にロイヤルティフリーの言語関連製品である旨が記載されている場合に限り、お客様が販売する製品に本製品のランタイムモジュールを組み込むことができます。ただし、この場合においても本製品の使用法やその他一切を公開することはできません。また、販売する製品には本製品の有効な著作権表示を明記しなければなりません。

保証の範囲

（１）弊社は本製品の仕様を予告なしに変更することがあります。

（２）本製品の品質および性能に関して発生する問題は、お客様の費用負担をもって処理することとします。

（３）弊社は、いかなる場合にも、お客様が本製品を使用または運用した結果に関して一切責任を負いません。

（４）本製品にお客様が目的を遂げることができないような重大な欠陥（磁気の消滅、破損など）があった場合、欠陥のない製品と交換するかまたはその製品代金相当額をもって弊社の保証限度とします。ただし、この保証は、お客様が本製品をご購入されてから30日以内に限らせていただきます。

テクニカルサポートサービス

弊社は、ユーザ登録によりご登録をいただいたお客様に対してのみ、テクニカルサポートサービスをご提供するものとします。但し、本製品（バージョン）の販売が終了して、１年以上が経過した場合にはその限りではありません。

契約期間

（１）本契約はお客様に製品を納入した日より発効します。また、納入日は証票により確認するものとします。

（２）お客様が本契約の条項のいずれかに違反した場合、本契約は解除されます。またこの場合を含め、製品の代金は返還いたしません。


ユーザ登録について

弊社では、よりよい製品とサービスをお届けするために、お客様の情報を登録させていただきたく存じます。お手数ではございますが、弊社ホームページまたは「ユーザ登録FAX用紙」を印刷のうえ、必要事項をご記入のうえファックスにてお送りください。

ご登録いただきましたお客様には、製品やサービスについてのインフォメーションをお届けいたします。ご住所や電話番号など、ご登録内容に変更が生じた場合は弊社カスタマ･コミュニケーションズまでお知らせください。

ご登録のない場合、バージョンアップサービスやテクニカルサポートサービスをご提供できないことがございます。

カスタマ・コミュニケーションズのご案内

製品内容やユーザ登録についてのお問い合わせは、下記にて承ります。

カスタマ・コミュニケーションズ
電話番号 | 03-3361-7755 | 11:00～12:00 13:00～19:00 （月～金）
FAX番号 | 03-3361-7735 | 24時間受け付け
電子メールアドレス | knocx@knowlbo.co.jp |


ユーザ登録FAX用紙

ユーザ登録は、オンラインでWebページから行う方法と、当FAX用紙を印刷していただき、内容を明記の上、FAXにてお送りいただく方法があります。

FAX. 03-3361-7735 （株）ナルボ　カスタマコミュニケーションズ行

ユーザ登録項目 | 内容
製品名 | Knowlbo(R)/OCX タイム ビュー Version3
シリアル№ |
登録キー |
登録形態 | □法人 □個人
法人名* |
所属部署名* |
役職名* |
ユーザ名 |
住所 | 〒
電話番号 | （ ） －
FAX番号 | （ ） －
電子メールアドレス |

※｢登録キー｣はバージョン情報ダイアログの Registration Key を記入してください。
※｢登録形態｣が法人の場合は、｢法人名*｣、｢所属部署名*｣、および｢役職名*｣も記入してください。

本製品購入のきっかけとなった媒体は何ですか

□雑誌記事　□雑誌広告　□DM　□展示会　□店頭　□知人の紹介
□ホームページ　□電子メール　□その他

本製品ご利用のコントロールコンテナは何ですか

□Visual Basic 6.0　□Visual Studio.NET 2002　□Visual Studio.NET 2003

□Internet Explorer 5　□Internet Explorer 6　□Access 2002

本製品ご購入の理由、ご意見、ご要望を教えてください


インストール／アンインストールについて

タイム ビュー Version3は、次の環境でご使用いただけます。

基本ソフトウェア

Windows 98 （日本語版）
Windows Me （日本語版）
Windows NT 4.0 （日本語版）
Windows 2000 （日本語版）
Windows XP （日本語版）
Windows 2003 （日本語版）

コントロールコンテナ

Visual Basic 6.0 （日本語版）
Visual Studio.NET 2002/2003 （日本語版）

Internet Explorer 5/6 （日本語版）

Access 2002 （日本語版）

タイム ビューのインストールは、製品ディスクに含まれているセットアッププログラム（SETUP.EXE）により可能です。セットアッププログラムは、次の様な構成でシステムディレクトリあるいは、ユーザ指定のディレクトリ下の"TimeViewV3"ディレクトリにファイルをインストールします。

\<Windows Directory>\System

MFC42.DLL | MFCコアコードDLL(MBCS版)
MSVCRT.DLL | Cランタイム共有DLL
OLEPRO32.DLL | Microsoft OLEプロパティサポートDLL
OLEAUT32.DLL | ActiveXサポートDLL
MSVCP60.DLL | Microsoft Visual C++ ランタイムDLL

\<User Directory>\TimeViewV3

Readme.WRI | タイム ビュー 情報ドキュメントファイル
KnTiew.OCX | タイム ビュー OCXファイル
KnTVPrt.dll | タイム ビュー 印刷用拡張DLLファイル
KnTView.LIC | タイム ビュー ライセンスファイル
KnTView.CHM | タイム ビュー ヘルプファイル
KnTView.DEP | タイム ビュー 依存ファイル
REGSVR32.EXE | コントロール登録（レジストリ）実行モジュール
Uninst.isu | アンインストール情報ファイル

\<User Directory>\TimeViewV3\CABS

タイム ビュー キャビネットファイル

\<User Directory>\TimeViewV3\Samples for VB

タイム ビュー　Visual Basic用サンプルプログラム

\<User Directory>\TimeViewV3\Samples for dotNET C#

タイム ビュー　dotNET C#用サンプルプログラム

\<User Directory>\TimeViewV3\Samples for IE

タイム ビュー　IE用サンプルプログラム

補足

製品インストール時に、WindowsディレクトリSystem配下にコピーするファイルは、ActiveXコントロールを使用する上で必要なOLEサポートDLLです。これらのファイルは、最新のファイルが既に存在する場合は、コピーされません。

インストールの手順

インストールは次の手順で行います。

旧バージョンのアンインストール

システムに旧バージョンのタイムビューがインストールされている場合、旧バージョンをアンインストールします。

旧バージョンのアンインストールは、旧バージョンの製品ディスク内にあるSETUP.EXEで行います。アンインストールの手順につきましては、旧バージョンのディレクトリ内にある「Readme.WRI」に記述されていますので、そちらをご参照ください。

タイム ビュー Version3のインストール

(１)タイム ビュー Version3のCD-ROMをドライブにセットします。

(２)タイム ビュー Version3のセットアップメニューが自動的に起動しますので、そこで「SETUP」をクリックすると、セットアップが開始されます。始まらない場合は、以下の手順を行ってください。

・コントロールパネルの「アプリケーションの登録と削除」を起動します。

・「アプリケーションの登録と削除のプロパティ」画面で「セットアップ」／「インストール」ボタンをクリックします。

・「フロッピーディスクまたはＣＤ－ＲＯＭからのセットアップ」の画面で、「次へ」ボタンをクリックします。

・セットアッププログラムの実行」画面のテキストボックスに D:\setup.exe（ＣＤ－ＲＯＭドライブがD:の場合）と表示されるので、「完了」ボタンをクリックします。ここまでの操作により、セットアッププログラムが起動されます。

(３)起動されたセットアッププログラムの「ようこそ」の画面で、「次へ」をクリックします。

(４)製品ライセンス契約の同意確認の画面になるので、「はい」をクリックします。

(５)インストール／アンインストールの選択画面になるので、[Install]ボタンをクリックした上で、「次へ」のボタンをクリックします。

(６)インストール先フォルダの選択画面が表示されるので、インストール先を選択し、「次へ」をクリックします。

(７)セットアップの方法を選択し、「次へ」をクリックします。

セットアップの方法は、３通りあります。

標準 | もっとも一般的なインストールをします。 OCXファイル、ライセンスファイル、ヘルプファイル、サンプルプログラム、、CABファイルＯＬＥサポートＤＬＬ群をインストールします。
コンパクト | 必要最小限のオプションでインストールを行います。 OCXファイル、ライセンスファイル、ヘルプファイルのみインストールします。
カスタム | ヘルプファイル、サンプルプログラム、CABファイル、ＯＬＥサポートＤＬＬ群のインストールを選択できます。

(８)プログラムフォルダ名を入力し、「次へ」をクリックします。(コンパクトを選択した場合、この手順は省略されます。)

(９)インストール情報の確認画面が表示されるので、「はい」／「次へ」をクリックします。

(１０)自動的にファイルがコピーされます。「インストール完了」ダイアログが表示されれば、インストールは完了です。Readmeファイルをすぐに読みたい場合は、「はい（Y）」ボタンをクリック、あとで読む場合は「いいえ(N)」ボタンをクリックして終了して下さい。

アンインストールの手順

（１）コントロールパネルの「アプリケーションの登録と削除」を起動します。

（２）" タイム ビュー V3"をダブルクリックします｡

（３）アンインストールの確認画面が表示されるので、「ＯＫ」をクリックします。

（４）自動的にファイル等が削除され、完了すると、完了メッセージが表示されます。正常終了のメッセージが表示されれば、アンインストールは完了です。


タイム ビュー (KnTView) コントロール

関連項目 使用例

タイム ビュー コントロールは、さまざまな時間スケジュール情報をガント チャート形式で表示します。

ファイル名

KnTView.ocx

クラス名

KnTView

概要

タイム ビュー コントロールは、時間を基準に計画された情報の入力や効果的な表示に用いることができます。タイム ビュー コントロールでは、仕事や予定などをピースという単位で表します。ピースの入力や移動は、マウスを使って直接画面上で行うことが可能です。横軸にタイム スケールという時間の目盛りを持ち、目盛りの単位は分単位から年単位まで指定が可能です。専用の印刷メソッドを使用して、タイム ビュー コントロールのみを複数ページに印刷することができます。

プロパティ | 内容
AllowColumnWidthChange | ユーザー操作で列幅を変更できるかどうかを示します。
AllowItemHeightChange | ユーザー操作で行高を変更できるかどうかを示します。
AllowPieceAdd | ユーザー操作でピースを追加できるかどうかを示します。
AllowPieceMove | ユーザー操作でピースの時間を移動できるかどうかを示します。
AllowPieceTimeChange | ユーザー操作でピースの時間を変更できるかどうかを示します。
AllowWidthPerScaleChange | ユーザー操作で目盛り幅を変更できるかどうかを示します。
Appearance | タイム ビュー コントロールの境界を３Dにするかどうかを示します。
BorderStyle | タイム ビュー コントロールの境界線を描画するかどうかを示します。
CellEdit | ユーザー操作でセルの値を編集できるかどうかを示します。
CellPaneWidth | セルを表示する領域の幅を示します。
CellValueWordWrap | セル内のテキストを折り返すかどうかを示します。
CellSelectMode | セルの選択方法を示します。
ClipDragToScale | ピースドラッグ操作をタイムスケールの目盛範囲に制約するかどうかを示します。
ColumnHeaders | 列見出しコレクションを示します。
ColumnIndex | アクティブ セルの列位置を示します。
CurrentTime | 現在日時線を示します。
DisableNoVerScroll | 垂直スクロールバーが不要なときに表示するかどうかを示します。
DisableNoHorScroll | 水平スクロールバーが不要なときに表示するかどうかを示します。
DragTip | ドラッグ ヒントを示します。
Enabled | ユーザー操作で発生したイベントを認識させるかどうかを示します。
FixedColumns | 1列目から何列分を非スクロール列とするかを示します。
Font | 列見出しの文字列の表示に使用するフォントを示します。
HideCellSelection | フォーカス消失中のセル選択の強調表示をどうするかを示します。
HidePieceSelection | フォーカス消失中のピース選択の強調表示をどうするかを示します。
HSBarWindowsFit | 水平スクロールバーをコントロールの幅に合わせて表示するかどうかを示します。
ImageLists | 画像を格納する ImageLists コレクションへの参照を示します。
ItemHeight | 行高を示します。
ItemHeightMode | 行高を自動的に調整するかどうかを示します。
ItemIndex | アクティブ セルの行位置を示します。
Items | アイテム コレクションを示します。
Misc | タイム ビュー コントロールの機能調節の値を示します。
LockedPieceSelectionColor | ドラッグ不可状態にあるピース選択ハンドルの色を示します。
OLEDragMode | OLE ドラッグ アンド ドロップ操作の処理をコンポーネントが行うかどうかを示します。
OLEDropMode | ドロップ操作を処理する方法を示します。
PieceBottomHeight | ピース下部キャプション領域の高さを示します。
PieceBottomMarginBottom | ピース下部キャプションの下余白を示します。
PieceBottomMarginTop | ピース下部キャプションの上余白を示します。
PieceCaptionAdjustInView | ピース バー内キャプションの表示をピースペイン内に留めるようにします。
PieceCaptionMaxWidth | ピース バー外キャプション文字列の折り返し幅を示します。
PieceCaptionWordWrap | ピース バー外キャプション文字列を折り返すかどうかを示します。
PieceCenterHeight | ピース バー領域の高さを示します。
PieceCenterMarginBottom | ピース中央キャプションの下余白を示します。
PieceCenterMarginTop | ピース中央キャプションの上余白を示します。
PieceFont | ピース キャプションの表示に使用するフォントを示します。
PieceLayout | 同一アイテムにあるピースどうしの時間が重複した場合の表示方法を示します。
PiecePane | ピース ペインを示します。
PiecePanePaddingBottom | ピース（ピース キャプションを含む）下部とアイテム ピース ペイン間の余白を示します。
PiecePanePaddingCenter | ピース並列表示時におけるピース（ピース キャプションを含む）間の垂直余白を示します。
PiecePanePaddingTop | ピース（ピース キャプションを含む）上部とアイテム ピース ペイン間の余白を示します。
PiecePointHorScale | ピース端点図形の幅の拡大・縮小率を示します。
PiecePointVerScale | ピース端点図形の高さの拡大・縮小率を示します。
PieceSelectionColor | ドラッグ可能なピースの選択ハンドルの色を示します。
PieceSelectMode | ピースの選択方法を示します。
PieceTimeNotify | ピースの開始日時又は終了日時を知らせるイベントを出力するかどうかを示します。
PieceTopHeight | ピース上部キャプション領域の高さを示します。
PieceTopMarginBottom | ピース上部キャプションの下余白を示します。
PieceTopMarginTop | ピース上部キャプションの上余白を示します。
ScaleFitting | ピースのドラッグ時にタイム スケールの目盛りに合わせるかどうかを示します。
SelectedPieces | 選択中のピースのコレクションを示します。
SpecialTimeSets | 特別時間帯コレクションを示します。
TimeScale | タイム スケールを示します。
ViewTopItem | 先頭に表示するアイテムのインデックスを示します。
ViewTopTime | 左端に表示する日時を示します。

メソッド | 内容
CalcDragItemInterval | OLE ドラッグ アンド ドロップ操作におけるドラッグの移動量から行数を計算します。
CalcDragMinuteInterval | OLE ドラッグ アンド ドロップ操作におけるドラッグの移動量から分数を計算します。
Cell | 行、列で指定されたセルを取得します。
CreateOutputInfo | OutputInfo オブジェクトを作成します。
CreatePrintInfo | PrintInfo オブジェクトを作成します。
DoScroll | 水平方向又は垂直方向にスクロールを実行します。
FormatDateTime | 日付/時刻書式に従って日時の文字列を作成します。
GetCellRect | 行、列で指定されたセルの表示領域の座標を取得します。
GetFontProperty | Font オブジェクトのプロパティ値の取得を支援します。
GetPieceFontProperty | PieceFont オブジェクトのプロパティ値の取得を支援します。
HitTest | 指定の座標に対応するタイム ビュー コントロールの要素を調べます。
OLEDrag | OLE ドラッグ アンド ドロップ操作を手動で開始します。
PrintStart | 印刷ダイアログを表示して印刷を開始します。
PrintDirect | 印刷ダイアログを表示せずに現在のプリンタ設定で印刷を開始します。
PrintPreview | 印刷プレビュー ダイアログを表示します。
Refresh | 無効領域、または全体を強制的に再描画します。
SaveFile | タイム ビュー コントロールのイメージをファイルに出力します。
SetFontProperty | Font オブジェクトのプロパティ値の設定を支援します。
SetPieceFontProperty | PieceFont オブジェクトのプロパティ値の設定を支援します。
Sort | アイテム コレクション内のアイテムの順序を並べ替えます。
StartCellEdit | セルの値の編集操作を手動で開始します。

イベント | 内容
AfterCellEdit | ユーザーがセルの編集操作を完了した直後に発生します。
AfterCellSelect | ユーザーがセルの選択状態の変更操作を完了した直後に発生します。
AfterHorScroll | ユーザーの水平スクロールの操作に対してスクロールが実施された直後に発生します。
AfterPieceAdd | ユーザーがピースの追加操作を完了した直後に発生します。
AfterPieceMove | ユーザーがピースの移動操作を完了した直後に発生します。
AfterPieceSelect | ユーザーがピースの選択状態の変更操作を完了した直後に発生します。
AfterPieceTimeChange | ユーザーがピースの時間変更操作を完了した直後に発生します。
AfterVerScroll | ユーザーの水平スクロールの操作に対してスクロールが実施された直後に発生します。
BeforeCellEdit | ユーザーがセルの編集を開始しようとしたときに発生します。
BeforeHorScroll | ユーザーが水平スクロールをしようとしたときに発生します。
BeforePieceAdd | ユーザーがピースを移動しようとしたときに発生します。
BeforePieceMove | ユーザーがピースを移動しようとしたときに発生します。
BeforePieceTimeChange | ユーザーがピースの時間を変更しようとしたときに発生します。
BeforeVerScroll | ユーザーが垂直スクロールをしようとしたときに発生します。
Cliｃk | ユーザーがタイム ビュー コントロール上でマウス ボタンを押して離したときに発生します。
Compare | Sort メソッドの実行中にアイテムの比較を行う度に発生します。
DblClick | ユーザーがタイム ビュー コントロール上でマウス ボタンを押して離す操作を2回続けて行ったときに発生します。
DragTipFormat | ドラッグ ヒントに表示する文字列を更新しようとするときに発生します。
EndPrint | 印刷メソッドの実行結果を通知します。
FooterPrint | タイム ビュー コントロールの印刷メソッドの実行で各ページを描画する度に発生します。
HeaderPrint | タイム ビュー コントロールの印刷メソッドの実行で各ページを描画する度に発生します。
KeyDown | ユーザーがキーボードのキーを押したときに発生します。
KeyPress | ユーザーがANSI 文字キーを押して離したときに発生します。
KeyUp | ユーザーがキーボードのキーを離したときに発生します。
MouseDown | ユーザーがマウス ボタンを押したときに発生します。
MouseMove | ユーザーがマウスを移動したときに発生します。
MouseUp | ユーザーがマウス ボタンを離したときに発生します。
OLECompleteDrag | ソース コンポーネントがターゲット コンポーネントにドロップされたときに発生し、ドラッグ操作の実行または取り消しをソース コンポーネントに通知します。
OLEDragDrop | ソース コンポーネントをターゲット コンポーネントにドロップし、ソース コンポーネントでドロップ可能と判断されたときに発生します。
OLEDragOver | コンポーネントが自身又は他のコンポーネント上にドラッグされたときに発生します。
OLEGiveFeedback | 各 OLEDragOver イベントの後に発生します。
OLESetData | ターゲット コンポーネントがソースの DataObject オブジェクトに GetData メソッドを実行したが、指定した形式のデータがロードされる前に、ソース コンポーネントで発生します。
OLEStartDrag | タイム ビュー コントロールのOLE ドラッグ アンド ドロップを開始した直後に発生します。
PieceFinish | 現在日時がピースの終了日時になったときに発生します。
PieceStart | 現在日時がピースの開始日時になったときに発生します。
RequestTipText | ツール チップ ウィンドウに表示する文字列の更新が必要なときに発生します。


オブジェクト階層図

オブジェクト モデル

図中のオブジェクト名をクリックすると、各オブジェクトの解説ページの先頭にジャンプします。

オブジェクト名 | 説明
ArrowShape | 矢印の形状オブジェクト。矢印の表示方法に関する情報を持ちます。
BarShape | バー形状オブジェクト。ピース バーの表示方法に関する情報を持ちます。
Balloon | 吹き出しオブジェクト。吹き出しを表します。
Balloons | 吹き出しオブジェクトのコレクション。吹き出しの追加や削除ができます。
BalloonShape | 吹き出し形状オブジェクト。吹き出しの表示方法に関する情報を持ちます。
Cell | セル オブジェクト。行と列からなるグリッドの各マスをセルと呼びます。セルは任意のバリアント値を持ち、表示することができます。
Cells | セル オブジェクトのコレクション。各行は１行分のセルのコレクションを持っています。
ColumnHeader | 列見出しオブジェクト。各列の先頭に列見出しがあり、任意の文字列を表示することができます。
ColumnHeaders | 列見出しオブジェクトのコレクション。列の追加や削除ができます。
CurrentTime | 現在日時オブジェクト。タイム ビュー コントロール内の現在日時を表す情報を持ちます。
DataObject | データ オブジェクト。OLE ドラッグ アンド ドロップで転送するデータのコンテナ。
DragTip | ドラッグ ヒント。ドラッグ操作中に表示されるポップ アップ ウィンドウの表示属性を持ちます。
FillFormat | フィル フォーマット オブジェクト。セルやピース表示領域、ピース バーなど、さまざまの領域の塗りつぶし方法に関する情報を持ちます。
HitTestResult | ヒット結果オブジェクト。ヒット テストの結果を格納するオブジェクトです。
Image | イメージオブジェクト。一画像を指すオブジェクトです。
ImageList | イメージリストオブジェクト。サイズとマスク カラーを共通とする一組の画像集合を表します。
ImageLists | イメージリストオブジェクトのコレクション。画像集合を指すイメージリストをコレクションしています。
Images | イメージオブジェクトのコレクション。ImageListオブジェクトに格納された画像集合を管理します。
Item | アイテム オブジェクト。行に相当し、１行分のセルやピースのコレクションを持っています。
ItemPiecePane | アイテム ピース ペイン オブジェクト。各行のピース表示領域について、背景の塗りつぶしパターンや特別時間帯に関する情報を持ちます。
Items | アイテム オブジェクトのコレクション。行の追加や削除ができます。
JoinRelatedLines | 接続されている関係線のコレクション。
KnTView | タイム ビュー コントロール。
LetterScale | 文字スケール オブジェクト。タイム スケールの大区分目盛りと中区分目盛りの表示方法に関する情報を持ちます。
LineFormat | ライン フォーマット オブジェクト。セル間の境界線や目盛り線などの描画に関する情報を持ちます。
LineScale | 線スケール オブジェクト。タイム スケールの小区分目盛りの表示方法に関する情報を持ちます。
MarkShape | マーク形状オブジェクト。マークの表示方法に関する情報を持ちます。
OutputInfo | 出力情報オブジェクト。出力についての情報を提供するのに用います。
Piece | ピース オブジェクト。タイム ビュー コントロールでは、１つのスケジュールをピースという単位で表します。行毎に複数のピースを追加できます。
PieceCaption | ピース キャプション オブジェクト。ピース バーの中や周りに、ピースに関する情報を表示したい時に使用します。
PieceCaptions | ピース キャプション オブジェクトのコレクション。ピースに対するキャプションの追加などに使用します。
PiecePane | ピース ペイン オブジェクト。ピース表示領域全体について、目盛り線や特別時間帯に関する情報を持ちます。
Pieces | ピース オブジェクトのコレクション。各行毎に１行分のピースのコレクションを持っています。行に対するピースの追加などに使用します。
Point | 地点オブジェクト。地点に関する情報を持ちます。
PointShape | 端点形状オブジェクト。ピース バーの端点の表示方法に関する情報を持ちます。
PrintInfo | 印刷情報オブジェクト。印刷又は印刷プレビューの実行を要求する時に、印刷方法についての情報を提供するのに用います。
Progress | 達成率オブジェクト。作業の達成の割合を百分率で表します。
Progresses | 達成率オブジェクトのコレクション。ピースに対して達成率を設定するときなどに使用します。
ProgressLine | 稲妻線オブジェクト。稲妻線を表します。
ProgressLines | 稲妻線オブジェクトのコレクション。稲妻線の追加や削除ができます。
ProgressPoint | 稲妻線の達成率ポイントオブジェクト。稲妻線の達成率ポイントを表します。
ProgressPoints | 稲妻線の達成率ポイントオブジェクトのコレクション。稲妻線の達成率ポイントの追加や削除ができます。
RelatedLine | 関係線オブジェクト。ピースの終了とピースの開始を結ぶ関係線を表します。
RelatedLines | 関係線オブジェクトのコレクション。関係線の追加や削除ができます。
SelectedPieces | 選択ピース オブジェクトのコレクション。選択状態にあるピース オブジェクトへの参照をコレクションしています。
SpecialTime | 特別時間帯オブジェクト。ピース表示領域の一部の時間帯を任意パターンで塗りつぶすのに使用します。
SpecialTimes | 特別時間帯オブジェクトのコレクション。
SpecialTimeSet | 特別時間帯セット オブジェクト。特別時間帯オブジェクトのコレクションを持っているだけの単純なオブジェクトです。ピース表示領域全体や行毎のピース表示領域に対して特別時間帯を設定する時は、このオブジェクトの参照を設定します。
SpecialTimeSets | 特別時間帯セット オブジェクトのコレクション。
TimeScale | タイム スケール オブジェクト。横軸の目盛りの表示方法に関する情報を持ちます。
TrackerHandle | トラッカハンドルオブジェクト。トラッカハンドルを表します。
TrackerHandles | トラッカハンドルオブジェクトのコレクション。トラッカハンドルの追加や削除ができます。


コントロールのイメージ

以下は、タイム ビュー コントロールの実行イメージです。


プロパティ ページのイメージ

タイム ビュー コントロールのプロパティ ページのイメージです。

Version2では、プロパティページが強化され、デザイン時に指定できるプロパティが飛躍的に増え、

開発時の生産性が向上しました。

「General」 プロパティ ページのイメージ

タイム ビュー コントロール全体の表示、および動作に影響するプロパティを設定します。

「ColumnHeaders」 プロパティ ページのイメージ

列見出しの追加や削除、各列見出しの表示や動作に関するプロパティを設定します。また、列見出し全体に関係するプロパティを設定します。

「Cell」 プロパティ ページのイメージ

セルを表示する領域（セル ペイン）の幅や、固定列、およびセル選択に関する設定、セル編集モードなどを設定します。

「SpecialTimeSets」 プロパティ ページのイメージ

特別時間帯セット コレクションの編集、特別時間帯セットへの特別時間帯の追加、削除、および各特別時間帯のプロパティを設定します。「TimeScale」 プロパティ ページや「PiecePane」 プロパティ ページなどで、「SpecialTimeSet」欄に特別時間帯のキーを指定する場合は、ここで特別時間帯セットを作成したあとで行う必要があります。

「TimeScale」 プロパティ ページのイメージ

タイム スケールにおける各区分（大区分、中区分、小区分）の、目盛りの単位や書式の設定、目盛り幅に関する設定、表示デザインなどを設定します。

「Item」 プロパティ ページのイメージ

アイテムの高さの決定方法、マウス操作によるアイテムの高さ変更操作の許可などを設定します。

「ItemTemplates」 プロパティ ページのイメージ

アイテムを追加する際に適用するアイテム テンプレートを追加、削除、および各アイテムの表示属性プロパティなどを設定します。アイテム テンプレートを使ってアイテムを追加するには、Items コレクションの AddFromTemplate メソッドを使用します。

「PiecePane」 プロパティ ページのイメージ

ピース ペインに表示する、タイムスケールの目盛りに対応した目盛り線の表示属性プロパティを設定します。また、ピース ペイン全体に適用する特別時間帯セットを指定します。

「Piece」 プロパティ ページのイメージ

ピースの選択モード、選択ハンドルのフォーム喪失における表示有無、選択ハンドルの色、ピース重複表示時の配置方式の選択、システム時間がピースの時間を通過するときのイベント発進の有無、マウス操作によるピース編集操作の制御、ピース キャプション表示場所の大きさなどを設定します。

「PieceTemplates」 プロパティ ページのイメージ

ピースを追加する際に適用するピース テンプレートを追加、削除、および各ピースの表示属性プロパティなどを設定します。ピース テンプレートを使ってピースを追加するには、Pieces コレクションの AddFromTemplate メソッドを使用します。

「Piece Etc」 プロパティ ページのイメージ

ピースの表示位置やサイズについて、微調整プロパティを設定します。

「Misc」 プロパティ ページのイメージ

タイムビュー コントロールのMisc プロパティを設定します。Misc プロパティは、下位互換を維持するために設けられたプロパティです。各項目について、チェックをしない場合は以前仕様で動作し、チェックをした場合、最新の仕様で動作します。

「Font」 プロパティ ページのイメージ

列見出し、およびピース キャプションの表示に使用するフォントのプロパティを設定します。


ピース

１つのスケジュールをピースという単位で入力します。
ピースには開始日時と終了日時を設定しますが、設定した日時のうち秒を除いた年月日時分を解釈します。
行毎に複数のピースを追加できます。

ピースの表示形状は、開始日時と終了日時を結ぶバーの部分とバーの両端それぞれについて
豊富なパターンを提供しており、スケジュールの種類の違いなどを視覚的に表現することが可能です。
また、ピース バーの中や周辺に任意のマルチ ライン文字列や開始日時、終了日時、達成率などを表示することができます。
さらに、１アイテム内にピースの並列して表示したり、ピースを非表示にしたり、特定のピースや時間帯の上のピース配置の禁止、
ピースとアイテムとの上下マージンを設定できたりなど、より実戦的な表現方法をサポートしています。
また、ピースキャプションに入りきらない情報もツールチップを使用して簡単に表示することも可能です。

注記： 設定できるピース数は、使用するマシンのメモリ量やパワーなどで増減します。ピース キャプションの表示に使用されるフォントは、すべてのピース キャプションで共通です。

１アイテム内にピースを並列表示し、マウスポインタがピース上に移動した場合、ツールチップを出す例


達成率

ピースに対して達成率を百分率で設定できます。達成率はピース バーと同様の豊富な形状パターンのいずれかを使用して表示することができます。
１つのピースに対して複数の達成率を設定することができ、達成率の指定は終了パーセントだけでなく開始パーセントも指定することが可能です。

① 達成率の終了パーセントに60%を設定。ピース キャプションを使って終了パーセントを表示。

② 達成率の開始パーセントに30%、終了パーセントに70%を設定。ピース キャプションを使って開始-終了パーセントを表示。

③ 達成率を２つ設定した例。中央の青い線がピース バー、上の赤い線が１つ目の達成率、下の赤い線が２つ目の達成率です。達成率バーにもピース バーと同様の表示属性を設定可能です。


分単位から年単位まで表現可能なタイム スケール

大区分、中区分、小区分の３段の目盛り表示が行えます。
大区分と中区分は文字で、小区分は線で目盛りを表示します。
大区分と小区分の目盛りは非表示にすることも可能です。
各区分毎に、「分単位で10分おき」のように目盛りの単位と間隔を設定することができます。

大区分： 年単位1年間隔、 中区分: 月単位３ヶ月間隔、 小区分: 月単位３ヶ月間隔、 補助目盛り: 月単位１ヶ月間隔

大区分： 月単位1月間隔、 中区分: 週単位1週間隔、 小区分: 日単位7日間隔、 補助目盛り: 日単位1日間隔

大区分： 週単位1週間隔、 中区分: 日単位1日間隔、 小区分: 非表示

大区分： 日単位1日間隔、 中区分: 時間単位12時間間隔、 小区分: 非表示

大区分： 非表示、 中区分: 分単位15分間隔、 小区分: 分単位15分間隔、 補助目盛り: 分単位1分間隔

上図のように、大区分の１目盛り分を１画面に圧縮して表示することもできます。

大区分：週単位1週間隔（表記は年の頭から第ｘ週）、 中区分: 日単位１日間隔（表記は曜日）、 小区分: 非表示

上記のように曜日色の指定や区分ごとに特別時間帯を設定することも可能です。

注記： 各目盛りの単位は、上位の段と同じか、より小さい単位のみ設定できます。


特別時間帯

特別時間帯を使えば、ピース表示領域の一部の時間帯を任意の塗りつぶしパターンやカラーで描画することができます。
例えば、毎日の昼休みの時間帯や、勤務日でない毎週日曜日の終日を特別に区別して表示したい時に有効です。
特別時間帯の設定は、全行のピース表示領域に設定することも、特定の行のピース表示領域のみに設定することも可能です。
さらにタイムスケール全体およびその各区分ごとにも特別時間帯の設定も可能にです。
また、プロパティの設定により指定の特別時間帯上へのピースの配置を禁止することもできます。

特別時間帯の設定例

・全ピース表示領域に対して、毎週水曜日の終日をピンク色の網掛けで表示するように設定。

・正社員の行のピース表示領域に対して、毎日午前９時から午後６時までを水色で表示するように設定。

・アルバイトの行のピース表示領域に対して、毎日午後6時から午後11時までをうす緑で表示するように設定。

特別時間帯へのピースを配置を禁止にした例（上記各アイテムの網掛け部分が特別時間帯）


複数列をサポート

列を複数作成して表示することができます。各行は列数と同数のセルを持つので、列の追加によってより多くの情報を表示させることが可能になります。
列幅は列毎に設定できます。また、列を非表示することも可能です。
さらに、セルペインの左側に列を固定表示することもできます。この場合、残りの列はスクロールして表示されます。
これにより、ピースペインの表示範囲を犠牲にすることなく、多数の列を表示できます。

セルには任意のバリアント値を設定できますが、文字列以外の場合は文字列に変換して表示します。
セル データの表示書式及び入力書式はサポートしていません。

デフォルトで複数の列を表示させた例

左から２列を固定表示にした例

・固定されていない列は、スクロールして表示される。

・セルペインの表示幅も指定可能


ユーザー インターフェース

ピースの選択、ピースの追加、ピースの開始及び終了日時の変更、ピースの同一行内での移動、セル編集、列幅の変更、列幅の自動調整、
行高の変更、行高の自動調整、タイム スケールの目盛り幅の変更、カレント セルの移動、行のスクロール、タイム スケールのスクロール
といった操作を画面上で直接行うことができます。

ピースの追加 ピースの選択

ピース終了日時の変更 ピース移動（同一行でのみ可能）

セル編集 ピースのラバー バンド選択

タイム スケールの目盛り幅の変更 行高の変更、行高の自動調整（ダブルクリックで自動調整）


ヒット テスト

今、マウス ポインタがどのピース上にいるのか、どのセル上にいるのか、ヒット テストを使えばすぐに分かります。
マウスの右ボタンが押された時に表示するポップ アップ メニューの種類を決めたり、ピース上でのダブル クリックを認識してダイアログを表示するコードの開発を支援します。

ヒット テスト メソッドを使って、マウス ポインタ下の次のオブジェクトを特定することができます。


OLE ドラッグ アンド ドロップ

選択中の複数のピースを一度に他の時間や行へ、さらに他のコントロールまでドラッグすることができます。
ドラッグ操作の開始を手動で行ったり、ドラッグ データに独自の情報を設定したりできます。ドラッグ中の自動スクロールも可能です。

タイム ビュー コントロールは、自動 OLE ドラッグをサポートしますが、ドロップについては手動のみサポートします。
従って OLE ドロップされたデータを受け取るには、データの転送元が自分自身でも、他のタイム ビュー コントロールの場合でも、
又は他の種類のコントロールやアプリケーションからの場合でもコーディングが必要です。

他の時間や行へドラッグした状態

他のタイム ビュー コントロールへドラッグした状態 他の種類のコントロールへドラッグした状態


行ソート

ソートしたい行の範囲とキー列の範囲、及び文字コード順又は数値順を指定して簡単に行ソートすることができます。また、ソート中の比較及び交換操作をプログラマ側で処理するモードもあります。

ソート前の状態

１列目をキーに文字コード順で昇順ソート １列目をキーに数値順で昇順ソート

２列目をキーに５０音順で昇順ソート ピースの開始日時で昇順ソート

（コーディングによるカスタム ソート） （コーディングによるカスタム ソート）


セル結合

上下に隣り合うセルの内容が同じ場合に、まとめて１つのセルとして表示することができます。
セル結合するかどうかを、列毎に設定することが可能です。

３列ともセル結合しない例（デフォルト状態） 　　　　　　　左列の結合状態の制約を受けて結合する例

各列が自由に結合する例 １列目は結合せず、２列目は自由に結合し、３列目は２列目の結合状態の制約を受けて結合する例


豊富なアピアランス属性

それぞれの業務に適した画面の作成を可能にするため、又はディベロッパのアーティスティックなセンスを活かすために、アピアランスに関する属性を豊富に備えました。
グラデーションなどを含む１９種類のフィル パターンや５種類のライン パターンを、各セル、各ピース、各行のピース表示領域、各列見出しのそれぞれについて設定することが可能です。
設定方法も数多くのプロパティページやテンプレート機能を用いて、より少ないコーディング量で、さまざまな表現を行うことができます。

アピアランスに関するプロパティの設定を行っていない状態

用途や好みあわせて、さまざまなアピアランス属性を設定した例

アピアランス属性の設定例２


イメージ

列見出し、セル、ピース端点に文字列やデフォルトで定義されているパターン以外にユーザ定義のイメージを表示することができます。

これにより、よりユーザフレンドリーなインターフェースをもつアプリケーションを作成することが可能です。


印刷

専用の印刷及び印刷プレビュー機能を使用して、タイム ビュー コントロールのみを複数ページに印刷することができます。
印刷する行範囲及び時間範囲の指定や、余白、倍率、用紙方向、ヘッダ及びフッタ領域の高さの指定が可能です。
また、強制改ページの指定や印刷対象日時範囲をタイムスケールの時間区切りに適合させることもできます。
ヘッダ及びフッタ領域は、WindowsAPIを使って自由に描画することができます。

ヘッダ領域を指定しない場合の印刷（印刷プレビュー ウィンドウでの確認）

ヘッダ領域の印刷例（印刷プレビュー ウィンドウでの確認）
ヘッダ領域の高さを1.5センチ メートルに設定し、ヘッダ印刷を要求するイベント プロシージャ内でWindowAPIを用いて、ヘッダ領域に２０ポイントのフォントで文字列「地球を守るボランティア」を描画

印刷方向を横、用紙サイズをB5に設定したの印刷例（印刷プレビュー ウィンドウでの確認）

印刷する列を１列目、３行目で強制改行（印刷プレビュー ウィンドウでの確認）

制限事項： OSやプリンタ(ドライバドライバ)の種類によっては、印刷、印刷プレビューが画面上のTimeViewの表示通りにならない場合があります。


その他の機能

セル矩形領域の座標取得

セル描画に使用するフォントを列毎に設定可能

ピースのラバー バンド選択

ピース選択モードの設定（選択不可／択一選択／複数選択／行毎に択一選択）

フォーカス消失時のカレント セル表示／非表示の設定

フォーカス消失時のピース選択ハンドル表示／非表示の設定

各セル、各列見出しの縦罫線及び横罫線表示の有無

各セル、各列見出しの縦方向及び横方向の文字揃えの設定

現在日時がピースの開始又は終了日時と一致した時にイベント出力

現在日時線の表示／非表示、及び現在日時更新モードの設定

週の開始曜日の設定

大区分の指定目盛り数分の時間範囲を１画面に圧縮表示

目盛りに合わせたピース ドラッグのサポート

目盛り文字の描画に使用するフォントを大区分、中区分それぞれに設定可能

プログラムから参照するためのデータの保管場所としてTag、Valueプロパティを実装


バージョン3で追加されたサンプルについて

バージョン3で追加された機能別に下記のサンプルがあります。

セルのインデントの変更操作

セルをツリー表示するために追加されたインデント機能を利用したサンプルです。

アイテム移動操作

セルをツリー表示した場合に、子項目を非表示 (ディスパンド) するするために追加された機能を利用したサンプルです。

セルのツリー表現

セルをツリー表示するために追加された各機能を利用した、セルのツリー表示を実装したサンプルです。

ピースの分割操作

ピースを分割、結合した表現をサポートするための機能を利用したサンプルです。

分割したピースの達成率操作

ピースを分割したように扱った場合の達成率の操作機能を利用したサンプルです。

既定のピーステンプレート

プログラムをコーディングせずにピースの追加操作においてピーステンプレートを利用する機能を利用したサンプルです。

関係線

ピースとピースを結ぶ関係線の機能を利用したサンプルです。

関係線の接続操作

関係線のマウス操作による接続機能を利用したサンプルです。

吹き出し

ピースに対するコメントを吹き出しの形式で表示する機能を利用したサンプルです。

吹き出しのマウス操作

吹き出しのマウス操作機能を利用したサンプルです。

タイムスケールの罫線

タイムスケールに罫線を表示できるようにした機能を利用したサンプルです。

稲妻線

稲妻線を表示するための機能を利用したサンプルです。

特別時間帯に関する新機能

バージョン3で特別時間帯機能に追加した機能を利用したサンプルです。

プロジェクト管理

プロジェクト管理用の表示機能を利用したサンプルです。


プロパティ一覧

プロパティ | 内容
AllColumnsAtFirstPage | 印刷する時間範囲の先頭時間を含むページにすべての列を印刷するかどうかを示します。
AllowColumnWidthChange | ユーザー操作で列幅を変更できるかどうかを示します。
AllowItemHeightChange | ユーザー操作で行高を変更できるかどうかを示します。
AllowPieceAdd | ユーザー操作でピースを追加できるかどうかを示します。
AllowPieceMove | ユーザー操作でピースの時間を移動できるかどうかを示します。
AllowPieceTimeChange | ユーザー操作でピースの時間を変更できるかどうかを示します。
AllowWidthPerScaleChange | ユーザー操作で目盛り幅を変更できるかどうかを示します。
AnchorPoint | アンカーの位置を表すオブジェクトを示します。
AnchorRelPoint | アンカーからの相対位置を表すオブジェクトを示します。
Angle | 矢印の角度を示します。
Appearance | タイム ビュー コントロールの境界を３Dにするかどうかを示します。
BackColor | 塗りつぶし領域の背景色を示します。
BalloonIndex | ヒットした吹き出しのインデックスを示します。
Balloons | 吹き出しコレクションを示します。
BalloonShape | 吹き出しの形状を表すオブジェクトを示します。
BarShape | ピースバーの形状を示します。
BeakBase | 吹き出しの接続線の底辺の長さを示します。
BeakBaseStyle | 吹き出しの接続線の底辺の指定スタイルを示します。
BkMode | 塗りつぶし領域を透過させるかどうかを示します。
BodyBorder | ボディを囲む線の描画属性を示します。
BorderStyle | タイム ビュー コントロールの境界線を描画するかどうかを示します。
BottomBorder | 下辺境界線の描画属性を示します。
Caption | キャプションを表すオブジェクトを示します。
Captions | ピースキャプションコレクションを示します。
CellEdit | ユーザー操作でセルの値を編集できるかどうかを示します。
CellPaneWidth | セルを表示する領域の幅を示します。
Cells | アイテムが持つセルコレクションを示します。
CellSelectMode | セルの選択方法を示します。
CellValueWordWrap | セルを表示する領域の幅を示します。
ChartBorder | 印刷時のチャート部分の描画を囲む線の描画属性を示します。
ClipDragToScale | ピースドラッグ操作をタイムスケールの目盛範囲に制約するかどうかを示します。
Color | 対象のテキストの色を示します。
Color (LineFormat) | 線の色を表します。
ColumnHeaders | 列見出しコレクションを示します。
ColumnIndex | アクティブ セルの列位置を示します。
ColumnWidthMode | 列見出しの幅を自動的に調整するかどうかを示します。
ConnectionHitTestWidth | 吹き出しの接続線のヒットテストの有効幅を示します。
ConnectionShape | 吹き出しの接続線の形状を示します。
CornerDiameter | 吹き出しの角丸の直径を示します。
CornerDiameterStyle | 吹き出しの角丸の直径の指定スタイルを示します。
Count | コレクションの持つオブジェクトの数を示します。
CurrentTime | 現在日時線を示します。
DateSwitchHour | 日付が変わる時間を示します。
DeltaX | DragPiece プロパティから参照するピースの左端座標からドラッグ開始時のマウス ポインタの X座標までの距離を示します。
DisableNoVerScroll | 垂直スクロールバーが不要なときに表示するかどうかを示します。
DisableNoHorScroll | 水平スクロールバーが不要なときに表示するかどうかを示します。
DragPiece | OLE ドラッグ アンド ドロップ操作で、ドラッグ開始時に直接マウスでポイントしたピースを示します。
DragTip | ドラッグ ヒントを示します。
Enabled | ユーザー操作で発生したイベントを認識させるかどうかを示します。
Fill | 塗りつぶしの描画属性を示します。
Finish (Piece) | ピースの終了日時を示します。
Finish (SpecialTime) | 特別時間帯の終了時分を示します。
FinishColumn | 出力する列範囲の終了列のインデックスを示します。
FinishIndex | 出力する行範囲の終了行のインデックスを示します。
FinishRelPoint | 終端アンカーからの相対位置を表すオブジェクトを示します。
FinishShape (Piece) | ピース バーの終点の形状や描画属性を表すオブジェクトを示します。
FinishShape (RelatedLine) | 終端の矢印の形状を表すオブジェクトをを示します。
FinishTime | 出力する時間範囲の終了日時を示します。
FirstDayOfWeek | 目盛りの単位が週の場合の開始曜日を示します。
FixedColumns | 1列目から何列分を非スクロール列とするかを示します。
Font | 列見出しの文字列の表示に使用するフォントを示します。
FooterHeight | フッタ領域の高さをセンチメートル単位で示します。
ForeColor | 塗りつぶし領域の前景色を示します。
Format | 文字列の書式を示します。
HeaderHeight | ヘッダ領域の高さをセンチメートル単位で示します。
Height (BalloonShape) | 吹き出しの高さを示します。
Height (LineScale) | タイムスケール小区分の目盛りの高さを示します。
Hidden | 対象を非表示にするかどうかを示します。
HideCellSelection | フォーカス消失中のセル選択の強調表示をどうするかを示します。
HidePieceSelection | フォーカス消失中のピース選択の強調表示をどうするかを示します。
HitTestTarget | ヒットテストの対象にするかどうかを示します。
HitTestWidth | ヒットテストの有効幅を示します。
HorAlign | 文字列の水平方向の配置を示します。
HSBarWindowFit | 水平スクロールバーをコントロールの幅に合わせて表示するかどうかを示します。
ImageLists | 画像を格納するイメージリストコレクションへを示します。
ImagePosition | テキストに対するイメージの位置を示します。
Images | ImageList オブジェクトに格納した画像集合をオブジェクト化した Images コレクションを示します。
Index | コレクション内のオブジェクトを識別する、1から始まる番号 (インデックス番号) を示します。
Interval | 目盛りの間隔を示します。
ItemHeight | 行高を示します。
ItemHeightMode | 行高を自動的に調整するかどうかを示します。
ItemIndex | アクティブ セルの行位置を示します。
Items | アイテム コレクションを示します。
JoinRelatedLines | 接続されている関係線コレクションを示します。
JustClippingToScale | 時間目盛を改ページ時、および右端ページでどのようにクリッピングするかを示します。
Key | コレクション内で自身を識別する文字列を示します。
Keys | Images コレクション内にある、すべてのImage オブジェクトのキーが格納された1次元配列を示します。
Large | 大区分目盛りを示します。
LargeLine | 大区分の目盛りに対応する位置に描画する縦線の描画属性を表すオブジェクトを示します。
Length | 矢印の傘の長さを示します。
LenToBreak | 矢印の形状の折れる位置までの長さを示します。
Line | 線の描画属性を示します。
Line (CurrentTime) | 現在日時線の描画属性を示します。
Line (LineScale) | 目盛り線の描画属性を示します。
LockedPieceSelectionColor | ドラッグ不可状態にあるピース選択ハンドルの色を示します。
Magnification | 印刷出力の拡大率、または縮小率を示します。
MarginBottom (Caption) | 下のマージンを示します。
MarginBottom (PrintInfo) | 用紙の下側の余白をセンチメートル単位で示します。
MarginLeft (Caption) | 左のマージンを示します。
MarginLeft (PrintInfo) | 用紙の左側の余白をセンチメートル単位で示します。
MarginRight (Caption) | 右のマージンを示します。
MarginRight (PrintInfo) | 用紙の右側の余白をセンチメートル単位で示します。
MarginTop (Caption) | 上のマージンを示します。
MarginTop (PrintInfo) | 用紙の上側の余白をセンチメートル単位で示します。
Medium | 中区分目盛りを示します。
MediumLine | 中区分の目盛りに対応する位置に描画する縦線の描画属性を表すオブジェクトを示します。
MergeMode | 列見出しに対応する列に含まれるセルどうしの結合方法を示します。
MiniHeightToPiece | ピースまでの最小高さを示します。
MiniWidthToPiece | ピースまでの最小幅を示します。
Misc | タイム ビュー コントロールの機能調節の値を示します。
MonochromeText | 印刷する文字の色を白、または黒に変換して出力するかどうかを示します。
ObjectType | ヒットしたオブジェクトの種類を示します。
OLEDragMode | OLE ドラッグ アンド ドロップ操作の処理をコンポーネントが行うかどうかを示します。
OLEDropMode | ドロップ操作を処理する方法を示します。
Orientation | 用紙の方向を示します。
Origin | タイム スケールの目盛りの日時を決めるときの基準日を示します。
PageBreak | アイテムを次ページの先頭に印刷するかどうかを示します。
PaperSize | 用紙サイズを示します。
Parent | 親オブジェクトを示します。
Pattern (FillFormat) | 塗りつぶし領域の塗りつぶしパターンを示します。
Pattern (SpecialTime) | 特別時間帯の適用パターンを示します。
PercentFrom | 達成率の開始パーセントを百分率で示します。
PercentTo | 達成率の終了パーセントを百分率で示します。
PieceBottomHeight | ピース下部キャプション領域の高さを示します。
PieceBottomMarginBottom | ピース下部キャプションの下余白を示します。
PieceBottomMarginTop | ピース下部キャプションの上余白を示します。
PieceCaptionAdjustInView | ピース バー内キャプションの表示をピースペイン内に留めるようにします。
PieceCaptionMaxWidth | ピース バー外キャプション文字列の折り返し幅を示します。
PieceCaptionWordWrap | ピース バー外キャプション文字列を折り返すかどうかを示します。
PieceCenterHeight | ピース バー領域の高さを示します。
PieceCenterMarginBottom | ピース中央キャプションの下余白を示します。
PieceCenterMarginTop | ピース中央キャプションの上余白を示します。
PieceFont | ピース キャプションの表示に使用するフォントを示します。
PieceIndex | ヒットしたピースのピース コレクション内での位置を表すインデックスを示します。
PieceLayout | 同一アイテムにあるピースどうしの時間が重複した場合の表示方法を示します。
PiecePane | ピース ペインを示します。
PiecePanePaddingBottom | ピース（ピース キャプションを含む）下部とアイテム ピース ペイン間の余白を示します。
PiecePanePaddingCenter | ピース並列表示時におけるピース（ピース キャプションを含む）間の垂直余白を示します。
PiecePanePaddingTop | ピース（ピース キャプションを含む）上部とアイテム ピース ペイン間の余白を示します。
PiecePointHorScale | ピース端点図形の幅の拡大・縮小率を示します。
PiecePointVerScale | ピース端点図形の高さの拡大・縮小率を示します。
Pieces | アイテムが持つピース コレクションを示します。
PieceSelectionColor | ドラッグ可能なピースの選択ハンドルの色を示します。
PieceSelectMode | ピースの選択方法を示します。
PieceTimeNotify | ピースの開始日時又は終了日時を知らせるイベントを出力するかどうかを示します。
PieceTopHeight | ピース上部キャプション領域の高さを示します。
PieceTopMarginBottom | ピース上部キャプションの下余白を示します。
PieceTopMarginTop | ピース上部キャプションの上余白を示します。
PosBaseTime | 吹き出しの位置のスタイルによる相対位置の基準日時を示します。
Position (PieceCaption) | ピース キャプションの位置を示します。
Position (PointShape) | ピースの端点とピースの時間の位置関係を示します。
PosRelPoint | 吹き出しの位置のスタイルによる相対位置を表すオブジェクトを示します。
PosStyle | 吹き出しの位置のスタイルを示します。
Progresses | ピースの達成率コレクションを示します。
Prohibited | ピースが重なるのを禁止するかどうかを示します。
RelatedLineIndex | ヒットした関係線のインデックスを示します。
RelatedLines | 関係線コレクションを示します。
Relation | 接続先 Piece オブジェクトを示します。
RightBorder | 右辺の描画属性を示します。
SaveFile | タイム ビュー コントロールのイメージをファイルに出力します。
ScaleFitting | ピースのドラッグ時にタイム スケールの目盛りに合わせるかどうかを示します。
Selected (Piece) | ピースの選択状態を示します。
Selected (Pieces) | ピース コレクション内の全てのピースを対象に選択状態を設定します。
SelectedPieces | 選択中のピースのコレクションを示します。
SelectMode | ピース コレクション内のピースの選択方法を示します。
Shape (ArrowShape) | 矢印の形状を示します。
Shape (BallonShape) | 吹き出しの形状を示します。
Shape (BarShape) | ピース バーの形状を示します。
Shape (PointShape) | ピース バーの始点、または終点の形状を示します。
SizeStyle | サイズの指定スタイルを示します。
SlidingLetter | 次の目盛りに押し出されるまで左端に目盛りを表示し続けるかどうかを示します。
Small | 小区分目盛りを示します。
SmallLine | 小区分の補助目盛りに対応する位置に描画する縦線の描画属性を表すオブジェクトを示します。
SpecialTimes | 特別時間帯のコレクションを示します。
SpecialTimeSet | 特別時間帯オブジェクトを示します。
SpecialTimeSets | 特別時間帯コレクションを示します。
Start (Piece) | ピースの開始日時を示します。
Start (SpecialTime) | 特別時間帯の開始時分を示します。
StartColumn | 出力する行範囲の開始列のインデックスを示します。
StartIndex | 出力する行範囲の開始行のインデックスを示します。
StartRelPoint | 先端アンカーからの相対位置を表すオブジェクトを示します。
StartShape (Piece) | ピース バーの始点の形状や描画属性を表すオブジェクトを示します。
StartShape (RelatedLine) | 先端の矢印の形状を表すオブジェクトを示します。
StartTime | 出力する時間範囲の開始日時を示します。
Style (LineFormat) | 線種を示します。
Style (RelatedLine) | 関係線のスタイルを示します。
SubInterval | 補助目盛りの表示間隔を示します。
SubLine | 小区分の補助目盛りに対応する位置に描画する縦線の描画属性を表すオブジェクトを示します。
SubLine (LineScale) | 補助目盛り線の描画属性を示します。
SubUnit | 補助目盛りの単位を示します。
Tag | プログラムから参照する任意データを示します。
Target | 特別時間帯を適用する日付や曜日を示します。
Text | 表示する文字列を示します。
Text (PieceCaption) | ピース キャプションに表示する任意の文字列を示します。
Time (CurrentTime) | 現在日時線を表示する位置を日時を示します。
Time (HitTestResult) | ヒットした日時を示します。
TimeScale | タイム スケールを示します。
Title | 印刷プレビュー ウィンドウや印刷中ダイアログのウィンドウ タイトルに表示する名前を示します。
Type | ピース キャプションに表示する情報の種類を示します。
Unit | 目盛りの単位を示します。
UpdateMode | 現在日時線を表示する位置を更新する方法を示します。
Value | バリアント型の任意データを格納します。
Value (Cell) | セルに設定及び表示する値を示します。
VerAlign | 文字列の垂直方向の配置を示します。
ViewTopItem | 先頭に表示するアイテムのインデックスを示します。
ViewTopTime | 左端に表示する日時を示します。
Width (BalloonShape) | 吹き出しの幅を示します。
Width (ColumnHeader) | 列見出しの幅を示します。
WidthPerScale | 中区分目盛りにおける 1目盛りの幅を示します。
WindowFit | 1画面に目盛りを合わせるかどうかを示します
WindowFitNumScales | １画面に目盛りを合わせる場合の目盛り数を示します。
WordWrap | 単語による行の分割をおこなうかを示します。
X | X 座標を示します。
Y | Y 座標を示します。
ZoomType | 拡大・縮小における方式を示します。
ZOrder | 特別時間帯の描画時における重ね順を示します。


AllColumnsAtFirstPage プロパティ

AllColumnAtFirstPage プロパティ

関連項目

印刷する時間範囲の先頭時間を含むページにすべての列を印刷するかどうかを設定します。値の取得も可能です。

構文

object.AllColumnAtFirstPage [= boolean]

AllColumnAtFirstPage プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | PrintInfo オブジェクトへの参照を表すオブジェクト式です。
boolean | 左端ページにすべての列を印刷するかどうかををブール式で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 boolean の設定値は次のとおりです。

定数名 | 内容
True | 印刷する時間範囲の先頭時間を含むページにすべての列を印刷し、その他のページは StartColumn プロパティ、FinishColumn プロパティの示す列範囲を印刷します。
False (既定値) | すべてのページにおいて、StartColumn プロパティ、FinishColumn プロパティの示す列範囲を印刷します。

解説

印刷が複数ページになるとき、列の印刷について、印刷する時間範囲の先頭時間を含むページにすべての列を印刷し、他のページはStartColumn プロパティ、FinishColumn プロパティの示す列範囲のみを印刷するかどうかを設定します。AllColumnsAtFirstPage プロパティの値に 真 (True) を指定した場合、複数ページにわたる印刷は下図のようになります。

1ページ目

Col1 | Col2 | Col3 | Col4 | 1時 2時
1,1 | 1,2 | 1,3 | 1,4 | □
2,1 | 2,2 | 2,3 | 2,4 | □
3,1 | 3,2 | 3,3 | 3,4 | □

2ページ目

Col2 | Col3 | 3時 4時 5時 6時 7時
1,2 | 1,3 | □
2,2 | 2,3 | □
3,2 | 3,3 | □

3ページ目

Col1 | Col2 | Col3 | Col4 | 1時 2時
4,1 | 4,2 | 4,3 | 4,4 | □
5,1 | 5,2 | 5,3 | 5,4 | □
6,1 | 6,2 | 6,3 | 6,4 | □

4ページ目

Col2 | Col3 | 3時 4時 5時 6時 7時
4,2 | 4,3 | □
5,2 | 5,3 | □
6,2 | 6,3 | □


AllowAnchorRelMouseChange プロパティ

関連項目 使用例

マウス操作で吹き出しのアンカーからの相対位置を移動できるかどうかを設定します。値の取得も可能です。

構文

object.AllowMouseMove [= boolean]

AllowMouseMove プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | Balloon オブジェクトへの参照を表すオブジェクト式です。
boolean | マウス操作で吹き出しのアンカーからの相対位置を移動できるかどうかをブール式で指定します。設定する値については、次の「設定値」を参照してください。

設定値

boolean の設定値は次のとおりです。

設定値 | 内容
True(既定値) | マウス操作で吹き出しのアンカーからの相対位置を移動できます。
False | マウス操作で吹き出しのアンカーからの相対位置を移動できません。

解説

このプロパティに 真 (True) が設定されている場合、下図の「アンカー相対位置変更ハンドル」をドラッグして、アンカーからの相対位置を表す AnchorRelPoint プロパティの内容を変更することができます。この時、アンカーの位置を表す AnchorPoint プロパティの内容は変更されません。

「アンカー相対位置変更ハンドル」の表示方法は、TrackerHandles プロパティが保持する TrackerHandles コレクションの 9 番目 (tivBalloonTHAnchorRel) の TrackerHandle オブジェクトで変更することができます。


AllowColumnWidthChange プロパティ

関連項目

マウス操作で列見出しの幅を変更できるかどうかを設定します。値の取得も可能です。

構文

object.AllowColumnWidthChange [= boolean]

AllowColumnWidthChange プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。
boolean | マウス操作で列見出しの幅を変更できるかどうかをブール式で指定します。設定する値については、次の「設定値」を参照してください。

設定値

boolean の設定値は次のとおりです。

設定値 | 内容
True(既定値) | マウス操作で列見出しの幅を変更できます。
False | マウス操作で列見出しの幅を変更できません。


AllowItemHeightChange プロパティ

関連項目

マウス操作でアイテムの高さを変更できるかどうかを設定します。値の取得も可能です。

構文

object.AllowItemHeightChange [= boolean]

AllowItemHeightChange プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。
boolean | マウス操作でアイテムの高さを変更できるかどうかをブール式で指定します。設定する値については、次の「設定値」を参照してください。

設定値

boolean の設定値は次のとおりです。

設定値 | 内容
True(既定値) | マウス操作でアイテムの高さを変更できます。
False | マウス操作でアイテムの高さを変更できません。

解説

AllowItemHeightChange プロパティが真 (True) のとき、上下に隣り合うアイテムの間の境界線付近にマウスカーソルを移動すると、マウスカーソルの形状が変わります。この状態からドラッグ操作をしてアイテムの高さを変更することができます。

アイテムの高さは、常にすべてのアイテムで同じです。したがって、いずれかのアイテムの高さをマウス操作で変更した場合、すべてのアイテムの高さが同一に変更されます。

タイム ビュー コントロールの ItemHeightMode プロパティが 1 (自動) のときは、マウス操作でアイテムの高さを変更することはできません。


AllowSizeMouseChange プロパティ

関連項目 使用例

マウス操作で対象のオブジェクトのサイズを変更できるかどうかを設定します。値の取得も可能です。

構文

object.AllowSizeMouseChange [= boolean]

AllowSizeMouseChange プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | 必ず指定します。 「対象」一覧内のいずれかのオブジェクトを指すオブジェクト式です。
boolean | マウス操作で対象のオブジェクトのサイズを変更できるかどうかをブール式で指定します。設定する値については、次の「設定値」を参照してください。

設定値

boolean の設定値は次のとおりです。

設定値 | 内容
True(既定値) | マウス操作で対象のオブジェクトのサイズを変更できます。
False | マウス操作で対象のオブジェクトのサイズを変更できません。


AllowMouseMove プロパティ

関連項目 使用例

マウス操作で対象のオブジェクトを移動できるかどうかを設定します。値の取得も可能です。

構文

object.AllowMouseMove [= boolean]

AllowMouseMove プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | 必ず指定します。 「対象」一覧内のいずれかのオブジェクトを指すオブジェクト式です。
boolean | マウス操作で対象のオブジェクトを移動できるかどうかをブール式で指定します。設定する値については、次の「設定値」を参照してください。

設定値

boolean の設定値は次のとおりです。

設定値 | 内容
True(既定値) | マウス操作で対象のオブジェクトを移動できます。
False | マウス操作で対象のオブジェクトを移動できません。


AllowPieceAdd プロパティ

関連項目

マウス操作でピースを追加できるかどうかを設定します。値の取得も可能です。

構文

object.AllowPieceAdd [= boolean]

AllowPieceAdd プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。
boolean | マウス操作でピースを追加できるかどうかをブール式で指定します。設定する値については、次の「設定値」を参照してください。

設定値

boolean の設定値は次のとおりです。

設定値 | 内容
True(既定値) | マウス操作でピースを追加できます。
False | マウス操作でピースを追加できません。

解説

AllowPieceAdd プロパティの値を偽 (False) にすると、ピースのラバーバンド選択ができるようになります。


AllowPieceMove プロパティ

関連項目

マウスを使って、ピースを同一アイテム内で移動できるかどうかを設定します。値の取得も可能です。

構文

object.AllowPieceAdd [= boolean]

AllowPieceAdd プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。
boolean | マウスを使って、ピースを同一アイテム内で移動できるかどうかをブール式で指定します。設定する値については、次の「設定値」を参照してください。

設定値

boolean の設定値は次のとおりです。

設定値 | 内容
True(既定値) | マウスを使って、ピースを同一アイテム内で移動できます。
False | マウスを使って、ピースを同一アイテム内で移動できません。


AllowPieceTimeChange プロパティ

関連項目

マウス操作でピースの開始日時又は終了日時を変更できるかどうかを設定します。値の取得も可能です。

構文

object.AllowPieceTimeChange [= boolean]

AllowPieceTimeChange プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。
boolean | ピースの開始日時又は終了日時を、マウス操作で変更できるかどうかをブール式で指定します。設定する値については、次の「設定値」を参照してください。

設定値

boolean の設定値は次のとおりです。

設定値 | 内容
True(既定値) | マウス操作でピースの開始日時又は終了日時を変更できます。
False | マウス操作でピースの開始日時又は終了日時を変更できません。


AllowWidthPerScaleChange プロパティ

関連項目

マウス操作で中区分の１目盛りの幅を変更できるかどうかを設定します。値の取得も可能です。

構文

object.AllowWidthPerScaleChange [= boolean]

AllowWidthPerScaleChange プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。
boolean | マウス操作で中区分の１目盛りの幅を変更できるかどうかをブール式で指定します。設定する値については、次の「設定値」を参照してください。

設定値

boolean の設定値は次のとおりです。

設定値 | 内容
True(既定値) | マウス操作で中区分の１目盛りの幅を変更できます。
False | マウス操作で中区分の１目盛りの幅を変更できません。

解説

AllowWidthPerScaleChange プロパティが真 (True) のとき、中区分の目盛りの文字付近にマウスカーソルを移動すると、マウスカーソルの形状が変わります。この状態からドラッグ操作を行って中区分の1目盛りの幅を変更することができます。

WindowFit プロパティに１ （大区分）を設定した場合、AllowWidthPerScaleChange プロパティは使用されません。目盛り幅は常にウィンドウ幅から計算された幅になります。


AnchorPoint プロパティ

関連項目 使用例

アンカーの位置を表す Point オブジェクトへの参照を返します。実行時のみ使用が可能です。

構文

object.AnchorPoint

AnchorPoint プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | Balloon オブジェクトへの参照を表すオブジェクト式です。

解説

アンカーの位置は、 AnchorPoint プロパティから参照する Point オブジェクトのプロパティを操作して指定することができます。

アンカーの位置は、対象ピース等の矩形の左上からの割合で指定します。

アンカーの位置からの相対位置を、 AnchorRelPoint プロパティで指定することもできます。

AncherPoint プロパティの内容 | イメージ
X ： 0 Y ： 50 |
X ： 50 Y ： 50 |
X ： 100 Y ： 100 |

※赤点が基準の位置です。


AnchorRelPoint プロパティ

関連項目 使用例

アンカーからの相対位置を表す Point オブジェクトへの参照を返します。実行時のみ使用が可能です。

構文

object.AnchorRelPoint

AnchorRelPoint プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | Balloon オブジェクトへの参照を表すオブジェクト式です。

解説

アンカーからの相対位置の変更は、 AnchorRelPoint プロパティから参照する Point オブジェクトのプロパティを操作して行うことができます。

アンカーからの相対位置を変更すると、下図のように接続線の先端を任意の位置に設定することができます。

AncherRelPoint プロパティの内容 | イメージ
X ： 0 Y ： 0 |
X ： 10 Y ： 0 |
X ： 10 Y ： -15 |

※赤点がアンカーです。


Angle プロパティ

関連項目 使用例

矢印の角度を設定します。値の取得も可能です。

構文

object.Angle [= value]

Angle プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | ArrowShape オブジェクトへの参照を表すオブジェクト式です。
value | 矢印の角度を示す値を整数で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 value の設定値は次のとおりです。

定数名 | 内容
0 ～ 180 | 指定した角度の矢印で表示されます。
30(既定値) | 30 度の矢印で表示されます。
上記以外 | 360 % 180 の結果の角度で表示されます。

解説

91 以上 180 未満の値を設定すると、逆向きの矢印で表示されます。


Appearance プロパティ

関連項目

タイム ビュー コントロールの境界線の描画スタイルを設定します。値の取得も可能です。実行時は値の取得のみ可能です。

構文

object.Appearance [= appearance]

Appearance プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。
appearance | タイム ビュー コントロールの境界線の描画スタイルを整数で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 appearance の設定値は次のとおりです。

定数名 | 内容
0 - tivAppearanceFlat(既定値) | タイム ビュー コントロールの境界線を3Dにしません。
1 - tivAppearance3D | タイム ビュー コントロールの境界線を3Dにします。


BackColor プロパティ

関連項目

塗りつぶし領域の背景色を設定します。値の取得も可能です。

構文

object.BackColor [= color]

BackColor プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | FillFormat オブジェクトへの参照を表すオブジェクト式です。
color | 色を示す数式を指定します。

解説

FillFormat オブジェクトの Pattern プロパティに 3D (tivPattern3D) を指定している場合、 塗りつぶし領域の左辺と上辺は、 BackColor プロパティの示すカラーより５０％明るい色で描画され、右辺と下辺は、５０％暗い色で描画されます。


BalloonIndex プロパティ

関連項目 使用例

Balloons コレクション内の Balloon オブジェクトを識別する、固有のインデックスを設定します。値の取得も可能です。

構文

object.BalloonIndex [= index]

BalloonIndex プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | HitTestResult オブジェクトへの参照を表すオブジェクト式です。
index | Balloons コレクション内の Balloon オブジェクトを識別する、固有のインデックス。

解説

タイム ビュー コントロールの HitTest メソッドが、吹き出しへのヒットを検出したとき、 BalloonIndex プロパティに、ヒットした吹き出しに対応する Balloon オブジェクトを識別するインデックスを設定します。


Balloons プロパティ

関連項目 使用例

Balloons コレクションへの参照を返します。実行時のみ使用できます。

構文

object.Balloons

Balloons プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | Piece オブジェクトへの参照を表すオブジェクト式です。

解説

Balloons コレクションは、吹き出しを表す Balloon オブジェクトのコレクションです。

ピースに対する吹き出しを表示する場合は、 Piece オブジェクトの Balloons プロパティから参照する Balloons コレクションに Balloon オブジェクトを追加します。


BalloonShape プロパティ

関連項目 使用例

吹き出しの形状を表す BalloonShape オブジェクトへの参照を返します。実行時のみ使用が可能です。

構文

object.BalloonShape

BalloonShape プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | Balloon オブジェクトへの参照を表すオブジェクト式です。

解説

吹き出しの形状やカラーの変更は、 BalloonShape プロパティから参照する BalloonShape オブジェクトのプロパティを操作して行うことができます。


BarShape プロパティ

関連項目 使用例

BarShape オブジェクトへの参照を返します。実行時のみ使用が可能です。

構文

object.BarShape

指定項目 | 内容
object | Piece オブジェクトへの参照を表すオブジェクト式です。

解説

ピース バーの形状やカラーの変更は、 BarShape プロパティから参照する BarShape オブジェクトのプロパティを操作して行うことができます。


BeakBaseプロパティ

関連項目 使用例

吹き出しの接続線の底辺の長さを設定します。値の取得も可能です。

構文

object.BeakBase [= value]

BeakBase プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | BalloonShape オブジェクトへの参照を表すオブジェクト式です。
value | 吹き出しの接続線の底辺の長さを BeakBaseStyle プロパティに設定されている方法で指定します。設定する値については、次の「設定値」を参照してください。

設定値

BeakBaseStyle プロパティに、パーセントで長さを指定 (0 - tivBalShapeBeakBaseStylePercent) が設定されている場合の引数 value の設定値は次のとおりです。

定数名 | 内容
1 ～ 100 | 指定した底辺の長さで接続線が表示されます。
30(既定値) | 30% の底辺の長さで接続線が表示されます。
0 以下 | 1% の底辺の長さで接続線が表示されます。
101 以上 | 100% の底辺の長さで接続線が表示されます。

BeakBaseStyle プロパティに、コンテナ単位で長さを指定 (1 - tivBalShapeBeakBaseStyleContainer) が設定されている場合の引数 value の設定値は次のとおりです。

定数名 | 内容
1 ～接続線が接続している辺 /2 | 指定した底辺の長さで接続線が表示されます。
接続線が接続している辺 /2 | 接続線が接続している辺の半分の長さで接続線が表示されます。

解説

BeakBase プロパティは、 ConnectionShpae プロパティがくちばし (2 - tivBalloonShapeBeak) の場合のみ有効で、設定されている長さの底辺で、接続線が表示されます。

接続線の底辺は、接続線が接続している辺の半分の長さが最大値となります。

BeakBaseStyle プロパティに、パーセントで長さを指定 (0 - tivBalShapeBeakBaseStylePercent) が設定されている場合は、接続線が接続している辺の半分の長さに対する割合になります。

下図は、上から 100% 、 50% 、 30% を指定した場合の接続線の形状です。

BeakBase プロパティの内容 | イメージ
100 |
50 |
30 |


BeakBaseStyle プロパティ

関連項目 使用例

吹き出しの接続線の底辺の長さの指定スタイルを設定します。値の取得も可能です。

構文

object.BeakBaseStyle [= value]

BeakBaseStyle プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | BalloonShape オブジェクトへの参照を表すオブジェクト式です。
value | 吹き出しの接続線の底辺の長さの指定スタイルを示す値を整数で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 value の設定値は次のとおりです。

定数名 | 内容
0 - tivBalShapeBeakBaseStylePercent(既定値) | パーセントで長さを指定。
1 - tivBalShapeBeakBaseStyleContiner | コンテナ単位で長さを指定。

解説

BeakBaseStyle プロパティを使うと、 BeakBase プロパティの指定方法を変更することができます。

BeakBaseStyle プロパティを変更すると、自動的に BeakBase プロパティの値が変換されます。


BkMode プロパティ

関連項目

塗りつぶし領域のバックグラウンド モードを設定します。値の取得も可能です。

構文

object.BkMode [= mode]

BkMode プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | FillFormat オブジェクトへの参照を表すオブジェクト式です。
mode | 塗りつぶし領域のバックグラウンド モードを整数で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 mode の設定値は次のとおりです。

定数名 | 内容
0 - tivTransparent | 透過。 Pattern プロパティで指定した値がシステム ハッチ パターンのとき、 ForeColor プロパティに指定した色を使ってパターンのみ描画します。
1 - tivOpaque(既定値) | 不透過。塗りつぶし領域全体を BackColor プロパティに指定した色を使って塗りつぶし、その上に ForeColor プロパティに指定した色でパターンを描画します。

解説

BkMode プロパティへの 0 (透過) の指定は、塗りつぶし対象の領域の下に、他の塗りつぶし領域がある時のみ可能です。したがって、 BarShape オブジェクトから参照する FillFormat オブジェクトの BkMode プロパティに、 0 (透過) を指定できますが、 ItemPiecePane オブジェクトから参照する FillFormat オブジェクトの BkMode プロパティへは設定することができません。


BodyBorder プロパティ

関連項目

出力におけるボディを囲む線の描画属性をもつ LineFormat オブジェクトへの参照を返します。

構文

object.BodyBorder

指定項目 | 内容
object | 「対象」一覧内のいずれかのオブジェクトを指すオブジェクト式です。

解説

ボディを囲む線の描画属性を示す LineFormat オブジェクトへの参照を返します。デフォルトでは、黒の実線で描画します。LineFormat オブジェクトのプロパティを変更して、線の描画をなくしたり、線種や色を変更することができます。

対象がPrintInfo オブジェクトの場合、ボディは用紙端からの余白、およびヘッダ、フッタを除いた、チャートを描画する領域を指します。

対象がOutputInfo オブジェクトの場合、ボディはタイム ビュー コントロールのイメージ全体を指します。


BorderStyle プロパティ

関連項目

タイム ビュー コントロールの境界線のスタイルを設定します。値の取得も可能です。

構文

object.BorderStyle [= style]

BorderStyle プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。
style | タイム ビュー コントロールの境界線の描画スタイルを整数で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 style の設定値は次のとおりです。

設定値 | 内容
0 | 境界線を表示しません。
1 (既定値) | 境界線を実線で描画します。


BottomBorder プロパティ

関連項目

「対象」一覧内のいずれかのオブジェクトの領域における、下辺境界線の描画属性を示す LineFormat オブジェクトへの参照を返します。実行時のみ使用できます。

構文

object.BottomBorder

指定項目 | 内容
object | 「対象」一覧内のいずれかのオブジェクトを指すオブジェクト式です。

解説

対象オブジェクトの下辺境界線について、表示の有無や線種、及び色を設定する時に使用します。


Caption プロパティ

関連項目 使用例

キャプションを表す Caption オブジェクトへの参照を返します。実行時のみ使用が可能です。

構文

object.Caption

Caption プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | Balloon オブジェクトへの参照を表すオブジェクト式です。

解説

キャプションの内容や配置、カラーの変更は、 Caption プロパティから参照する Caption オブジェクトのプロパティを操作して行うことができます。


Captions プロパティ

関連項目

PieceCaptions コレクションへの参照を返します。実行時のみ使用できます。

構文

object.Captions

指定項目 | 内容
object | Piece オブジェクトへの参照を表すオブジェクト式です。

解説

PieceCaptions コレクションは、ピース周辺に表示する文字列とその表示属性を表す PieceCaption オブジェクトのコレクションです。ピース周辺に、ピースに関する情報又は任意の文字列を表示する場合は、 Piece オブジェクトの Captions プロパティから参照する PieceCaptions コレクションを使って行います。


CellEdit プロパティ

関連項目

ユーザー操作でアイテムの文字列を編集できるようにするかどうかを設定します。値の取得も可能です。

構文

object.CellEdit [= mode]

CellEdit プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。
mode | ユーザー操作でアイテムの文字列を編集できるようにするかどうかを整数で指定します。設定する値については、次の「設定値」を参照してください。

設定値

mode の設定値は次のとおりです。

定数名 | 内容
0 - tivManual | StartCellEdit メソッドが呼び出された場合にのみ BeforeCellEdit イベントが発生します。
1 - tivAutomatic(既定値) | 自動。ユーザーが選択アイテムでクリックしたり、エンターキーを押すと BeforeCellEdit イベントが発生します。

解説

カレント セルが編集対象のセルとなります。

CellEdit プロパティと StartCellEdit メソッドを組み合わせて使用すると、いつ、どのセルを編集できるようにするかをコードで制御できます。 CellEdit プロパティを 1 (自動) に設定すると、 StartCellEdit メソッドを呼び出さない限りセルを編集できません。


CellPaneWidth プロパティ

関連項目

セルを表示する領域(セルペイン)の幅を設定します。値の取得も可能です。

構文

object.CellPaneWidth [= width]

CellPaneWidth プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。
width | セルペインの幅をピクセル単位の数式で指定します。デフォルトは 0 です。

解説

セルペインの幅とは、固定化した列を含むすべてのセル、および列見出しを表示する領域の幅を示します。セルペインの幅よりも列全体の幅が大きいとき、非固定の列は横スクロールによって表示させることができます。セルペインとピースペインの間には、セルペインの幅をマウス操作にて変更するための垂直分割バーが表示されますが、FixedColumns プロパティの値が -1 (すべて固定) の場合、セルペインの幅は強制的に列全体の幅となり、また垂直分割バーは表示されません。セルペインの表示をなくし、全体をピースペインにするには、CellPaneWidth プロパティの値を 0 、FixedColumns プロパティに 0 以上の値を指定します。


Cells プロパティ

関連項目

Cells コレクションへの参照を返します。実行時のみ使用できます。

構文

object.Cells

指定項目 | 内容
object | Item オブジェクトへの参照を表すオブジェクト式です。

解説

Item オブジェクトは、 Cells プロパティから参照する Cells コレクションに、 1行分の Cell オブジェクトを保持しています。 Item オブジェクトの持つ Cells コレクション内の Cell オブジェクトの数は、常にタイム ビュー コントロールの ColumnHeaders コレクション内の ColumnHeader オブジェクトの数(即ち列数)と一致します。従って、 ColumnHeaders コレクションの Add メソッド、 Remove メソッド、 Clear メソッドを使用して列見出しの数を変更すると、全てのItem オブジェクトの Cells コレクション内の Cell オブジェクトも自動的に追加又は削除されます。

タイム ビュー コントロールのColumnHeaders コレクションには、実行直後の状態で ColumnHeader オブジェクトが１つ追加されています。


CellSelectMode プロパティ

関連項目

ユーザー操作でセルを選択できるかどうかを設定します。値の取得も可能です。

構文

object.CellSelectMode [= mode]

CellSelectMode プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。
mode | ユーザー操作でセルを選択できるかどうかを整数で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 mode の設定値は次のとおりです。

定数名 | 内容
0 - tivCellSelectNone | 選択不可。
1 - tivCellSelectSingle(既定値) | 択一選択。任意のセルを選択することができます。

解説

CellSelectMode プロパティに tivCellSelectNone (選択不可) を指定すると、カレント セル枠は表示されなくなります。


CellValueWordWrap プロパティ

関連項目 使用例

セル内のテキストの長さがセルの幅を超える場合に、テキストを折り返すかどうかを設定します。値の取得も可能です。

構文

object.CellValueWordWrap [= boolean]

CellValueWordWrap プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。
boolean | セル内のテキストを折り返すかどうかをブール式で指定します。設定する値については、次の「設定値」を参照してください。

設定値

boolean の設定値は次のとおりです。

設定値 | 内容
True | セル内のテキストを、折り返して表示します。
False(既定値) | セル内のテキストを、折り返して表示しません。

解説

CellValueWordWrap プロパティが真 (True) の場合でも、セルの編集操作中はテキストを折り返しません。

テキストの折り返しは、半角英数の場合は単語単位で、全角の場合は文字単位で行われます。

キャリッジ リターンとラインフィードの組み合わせは、常にテキストを折り返します。


ChartBorder プロパティ

関連項目

印刷におけるチャート部分の描画を囲む線についての属性をもつ LineFormat オブジェクトへの参照を返します。

構文

object.ChartBorder

指定項目 | 内容
object | PrintInfo オブジェクトへの参照を表すオブジェクト式です。

解説

印刷では、ヘッダ、およびフッタ、印刷要素が少ないために余った右端、および下端を除いた実際のチャート部分を囲む線が描画されます。デフォルトでは、Style プロパティの値 (線種) が 0 (線なし) のため描画はありませんが、必要に合わせて線種や色を設定して描画を行わせることができます。


ClipDragToScale プロパティ

関連項目

マウス操作によるピース編集時に、ドラッグをタイムスケールの目盛範囲に制約するかどうかを指定します。値の取得も可能です。

構文

object.ClipDragToScale [= boolean]

ClipDragToScale プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。
boolean | ドラッグをタイムスケールの目盛範囲に制約するかどうかをを示す、ブール式を指定します。

設定値

boolean の設定値は次のとおりです。

設定値 | 内容
True | ドラッグをタイムスケールの目盛範囲に制約します。
False (既定値) | ドラッグをタイムスケールの目盛範囲に制約しません。

解説

TimeScale オブジェクトの SetRange メソッドや、WindowFit プロパティによって設定された目盛全体の範囲に、ピースのドラッグ移動の範囲を限定するかどうかを指定します。

下位互換を維持するために初期値を 偽 (False) としています。しかしながら、通常タイムスケールの目盛全体は、アプリケーションがサポートする時間の範囲をあらわしており、これを超えたピースの配置を禁止する場面が多いと考えられるため、多くのアプリケーションでは 真 (True) に変更すると考えられます。


Color プロパティ

関連項目

オブジェクトに格納されているテキストの表示色を指定します。

構文

object.Color [= color]

Color プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | 「対象」一覧内のいずれかのオブジェクトを指すオブジェクト式です。
color | 色を示す数式を指定します。


Color プロパティ (LineFormat オブジェクト)

関連項目

線の色を設定します。値の取得も可能です。

構文

object.Color [= color]

Color プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | LineFormat オブジェクトへの参照を表すオブジェクト式です。
mode | 色を示す数式を指定します。


ColumnHeaders プロパティ

関連項目

ColumnHeaders コレクションへの参照を返します。実行のみ使用できます。

構文

object.ColumnHeaders

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。

解説

タイム ビュー コントロールの列見出しの数を操作することができます。タイム ビュー コントロールの ColumnHeaders プロパティから参照する ColumnHeaders コレクションには、実行直後の状態で ColumnHeader オブジェクトが１つ追加されていますが、必要がなければ削除することも出来ます。


ColumnIndex プロパティ

関連項目

ColumnHeaders コレクション内の ColumnHeader オブジェクトを識別する、固有のインデックスを設定します。値の取得も可能です。

構文

object.ColumnIndex [= index]

ColumnIndex プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | 「対象」一覧内のいずれかのオブジェクトを指すオブジェクト式です。
index | ColumnHeaders コレクション内の ColumnHeader オブジェクトを識別する、固有のインデックス。

解説

対象がタイム ビュー コントロールの場合、カレント セルの列位置を表します。値を設定して、カレント セルの位置を変えることができます。

対象が HitTestResult オブジェクトの場合、タイム ビュー コントロールの HitTest メソッドが、列見出し又はセルへのヒットを検出したとき、ヒットした列見出しに対応する ColumnHeader オブジェクトを識別するインデックスを返します。


ColumnWidthMode プロパティ

関連項目

列見出しの幅をタイムビューコントロールが自動的に決めるかどうかを指定します。値の取得も可能です。

構文

object.ColumnWidthMode [= mode]

ColumnWidthMode プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | ColumnHeader オブジェクトへの参照を表すオブジェクト式です。
mode | 列見出しの幅をタイム ビュー コントロールが自動的に決めるかどうかを示す値を整数で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 mode の設定値は次のとおりです。

定数名 | 内容
0 - tivManual (既定値) | Width プロパティが示す高さで表示します。
1 - tivAutomatic | タイム ビュー コントロールが計算したカラムの幅で表示します。

解説

ColumnWidthMode プロパティに 1 (自動) を指定した場合、列見出しの幅は PieceFont プロパティから参照する Font オブジェクトの Size プロパティの値から計算した幅で常に表示します。


ConnectionHitTestWidth プロパティ

関連項目 使用例

吹き出しの接続線のヒットテストの有効幅を設定します。値の取得も可能です。

構文

object.ConnectionHitTestWidth [= value]

ConnectionHitTestWidth プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | BalloonShape オブジェクトへの参照を表すオブジェクト式です。
value | 吹き出しの接続線のヒットテストの有効幅をコンテナ単位で指定します。既定値は 3 ピクセルです。

設定値

ConnectionHitTestWidth プロパティを使うと、吹き出しの接続線のヒットテストの有効範囲を変更することができます。

ConnectionHitTestWidth プロパティは、 ConnectionShpae プロパティが線 (1 - tivBalloonShapeLine) の場合のみ有効です。

下図においてヒットテストの有効範囲は、吹き出しの接続線の周りの点線です。 ConnectionHitTestWidth プロパティには、吹き出しの接続線から、その有効範囲の矩形までの長さを指定します。

※ピースと重なり合っている部分は、吹き出しの接続線の方が優先されます。


ConnectionShape プロパティ

ConnectionShpae プロパティ

関連項目 使用例

吹き出しの接続線の形状を設定します。値の取得も可能です。

構文

object.ConnectionShape [= value]

ConnectionShape プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | BalloonShape オブジェクトへの参照を表すオブジェクト式です。
value | 吹き出しの接続線の形状を示す値を整数で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 value の設定値は次のとおりです。

定数名 | 内容 | イメージ
0 - tivBalShapeConShapeNull | なし。 |
1 - tivBalShapeConShapeLine | 線。 |
2 - tivBalShapeConShapeBeak(既定値) | くちばし。 |

解説

ConnectionShpae プロパティを使うと、吹き出しの接続線の形状を変更することができます。


CornerDiameter プロパティ

関連項目 使用例

吹き出しの角丸の直径を設定します。値の取得も可能です。

構文

object.CornerDiameter [= value]

CornerDiameter プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | BalloonShape オブジェクトへの参照を表すオブジェクト式です。
value | 吹き出しの角丸の直径を CornerDiameterStyle プロパティに設定されている方法で指定します。設定する値については、次の「設定値」を参照してください。

設定値

CornerDiameterStyle プロパティに、パーセントで長さを指定 (0 - tivBalShapeCorDiaStylePercent) が設定されている場合の引数valueの設定値は次のとおりです。

定数名 | 内容
0 ～ 100 | 指定した直径の弧で角が丸く表示されます。
30(既定値) | 30% の直径の弧で角が丸く表示されます。
101 以上 | 100% の直径の弧で角が丸く表示されます。

CornerDiameterStyle プロパティに、コンテナ単位で長さを指定 (1 - tivBalShapeCorDiaStyleContainer) が設定されている場合の引数 value の設定値は次のとおりです。

定数名 | 内容
0 ～吹き出しの幅か高さ | 指定した直径の弧で角が丸く表示されます。
吹き出しの幅か高さ以上 | 吹き出しの幅か高さの直径の弧で角が丸く表示されます。

解説

CornerDiameter プロパティは、 Shpae プロパティが角丸矩形 (1 - tivBalloonShapeRoundRect) の場合のみ有効で、設定されている直径の弧で、吹き出しの角が丸く表示されます。

吹き出しの角丸の直径は、吹き出しの矩形の幅と高さ、どちらか短い方が最大値となります。

CornerDiameterStyle プロパティに、パーセントで長さを指定 (0 - tivBalShapeCorDiaStylePercent) が設定されている場合は、吹き出しの矩形の幅と高さ、どちらか短い方に対する割合になります。

下図は、上から 100% 、 50% 、 30% を指定した場合の角丸矩形の形状です。

CornerDiameter プロパティの内容 | イメージ
100 |
50 |
30 |


CornerDiameterStyle プロパティ

関連項目 使用例

吹き出しの角丸の直径の指定スタイルを設定します。値の取得も可能です。

構文

object.CornerDiameterStyle [= value]

CornerDiameterStyle プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | BalloonShape オブジェクトへの参照を表すオブジェクト式です。
value | 吹き出しの角丸の直径の指定スタイルを示す値を整数で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 value の設定値は次のとおりです。

定数名 | 内容
0 - tivBalShapeCorDiaStylePercent(既定値) | パーセントで直径を指定。
1 - tivBalShapeCorDiaStyleContiner | コンテナ単位で直径を指定。

解説

CornerDiameterStyle プロパティを使うと、 CornerDiameter プロパティの指定方法を変更することができます。

CornerDiameterStyle プロパティを変更すると、自動的に CornerDiameter プロパティの値が変換されます。


Count プロパティ

関連項目

コレクション内のオブジェクトの数を返します。

構文

object.Count

指定項目 | 内容
object | 「対象」一覧内のいずれかのオブジェクトを指すオブジェクト式です。


CurrentTime プロパティ

関連項目

CurrentTime オブジェクトへの参照を返します。実行時のみ使用できます。

構文

object.CurrentTime

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。

解説

タイム ビュー コントロールの現在日時線の表示の有無やカラーなどを操作するには、CurrentTime プロパティから参照する CurrentTime オブジェクトを使用して行います。


DateSwitchHour プロパティ

関連項目

日付が変わる時間を指定します。値の取得も可能です。

構文

object.DateSwitchHour [= hour]

DateSwitchHour プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | TimeScale オブジェクトへの参照を表すオブジェクト式です。
hour | 日付が変わる時間を0～23の整数で指定します。デフォルトは0です。

解説

24時以降の時間の表示を24, 25, 26としたい場合に、DateSwitchHour プロパティを用います。実際に24, 25, 26と表示するには、時間の表示書式として、HX書式を指定する必要が有ります。


DeltaX プロパティ

関連項目

SelectedPieces コレクションの DragPiece プロパティから参照するピースの左端座標からドラッグ開始時のマウス ポインタの X座標までの距離を取得します。

構文

object.DeltaX

指定項目 | 内容
object | SelectedPieces コレクションへの参照を表すオブジェクト式です。

解説

DeltaX プロパティは、主にタイム ビュー コントロールの CalcDragMinuteInterval メソッドの引数に渡す値として使用します。


DefaultPieceTemplateKey プロパティ

関連項目

マウス操作でピースを追加したときに利用するピーステンプレートのキーを設定します。値の取得も可能です。

構文

object.DefaultPieceTempalteKey [= string]

DefaultPueceTemplateKey プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | 「対象」一覧内のいずれかのオブジェクトを指すオブジェクト式です。
string | マウス操作でピースを追加したときに利用するピーステンプレートのキーを表す文字列を指定します。

解説

このプロパティを設定しておくと、マウス操作でピースを追加した際に、自動的に指定したピーステンプレートを利用してピースが追加されるので、それ用のプログラムコードを記述する必要がありません。

ピーステンプレートは、プロパティページの「PieceTemplates」ページで追加することができます。


DisableNoVerScroll プロパティ、 DisableNoHorScroll プロパティ

関連項目

スクロールバーが不要なときに表示するかどうかを設定します。値の取得も可能です。

構文

object.DisableNoVerScroll [= boolean]

object.DisableNoHorScroll [= boolean]

DisableNoVerScroll プロパティ、 DisableNoHorScroll プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。
boolean | スクロールバーが不要なときに表示するかどうかをブール式で指定します。設定する値については、次の「設定値」を参照してください。

設定値

boolean の設定値は次のとおりです。

設定値 | 内容
True (既定値) | スクロールバーが不要なときでも、ユーザー操作を受け付けない状態で表示します。
False | スクロールバーが不要なときは表示しません。

解説

垂直方向にスクロールしなくてもすべてのアイテムがウィンドウ内に見えている場合や、水平方向にスクロールしなくてもすべての時間範囲が見えているとき、垂直、又は水平スクロールバーの表示をどうするかを設定します。スクロールバーが必要なとき、つまりスクロールしないとすべてのアイテムや時間範囲が表示できない場合は、設定値をFalseにしていてもスクロールバーは表示されます。


DragPiece プロパティ

関連項目

OLE ドラッグ アンド ドロップ操作で、ドラッグ開始時に直接マウスでポイントしたピースへの参照を返します。

構文

object.DragPiece

指定項目 | 内容
object | SelectedPieces コレクションへの参照を表すオブジェクト式です。

解説

DragPiece プロパティは、主にタイム ビュー コントロールの CalcDragItemInterval メソッドの引数に渡す値として使用します。


DragTip プロパティ

関連項目

DragTip オブジェクトへの参照を返します。実行時のみ使用できます。

構文

object.DragTip

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。

解説

マウスでのドラッグ操作中に表示される、ドラッグ ヒントの非表示やアピアランスなどを操作するには、DragTip プロパティから参照する DragTip オブジェクトを使用して行います。


EditMode プロパティ

関連項目 使用例

吹き出しの編集を、マウス操作で自動的に行うかどうかを設定します。値の取得も可能です。

構文

object.EditMode [= mode]

EditMode プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | Balloon オブジェクトへの参照を表すオブジェクト式です。
mode | 吹き出しの編集を、マウス操作で自動的に行うかどうかを示す値を整数で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 mode の設定値は次のとおりです。

定数名 | 内容
0 - tivManual | 手動。 マウスのダブルクリックしても編集状態（エディットボックスのアクティブ化）になりません。
1 - tivAutomatic (既定値) | 自動。 マウスのダブルクリックで編集状態（エディットボックスのアクティブ化）にすることができます。

解説

EditMode プロパティの値が 1 (自動) の場合、吹き出しをダブルクリックすると、エディットボックスがアクティブ化され、Caption プロパティが保持している　Caption オブジェクトの Text プロパティの値を直接編集することができます。

EditMode プロパティの値が 0 (手動) の場合、吹き出しをダブルクリックしても何も起きません。StartEdit メソッドを利用すると,すると、プログラムコードで編集を開始することができます。


Enabled プロパティ

関連項目

タイム ビュー コントロールに、ユーザーの操作で発生したイベントを認識させるかどうかを設定します。値の取得も可能です。

構文

object.Enabled [= boolean]

Enabled プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。
boolean | タイム ビュー コントロールがユーザーの操作で発生するイベントを認識するかどうかを示す、ブール式を指定します。

設定値

boolean の設定値は次のとおりです。

設定値 | 内容
True(既定値) | イベントを認識します。
False | イベントを認識しません。


Fill プロパティ

関連項目

FillFormat オブジェクトへの参照を返します。

構文

object.Fill

指定項目 | 内容
object | 「対象」一覧内のいずれかのオブジェクトを指すオブジェクト式です。

解説

Fill プロパティを持つオブジェクトの表示領域の塗りつぶし属性の設定は、 Fill プロパティから参照する FillFormat オブジェクトを使って行うことができます。

対象が AllowShape オブジェクトの場合、矢印（三角と丸のみ）の表示領域の塗りつぶし属性を表します。

対象が BalloonShape オブジェクトの場合、吹き出しの表示領域の塗りつぶし属性を表します。


FirstDayOfWeek プロパティ

関連項目

タイム スケールの目盛りの単位に週単位を設定した場合の、週の開始曜日を指定します。値の取得も可能です。

構文

object.FirstDayOfWeek [= dayofweek]

FirstDayOfWeek プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | TimeScale オブジェクトへの参照を表すオブジェクト式です。
dayofweek | 週の開始曜日を整数で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 dayofweek の設定値は次のとおりです。

定数名 | 内容
0 - tivSunday | 日曜日
1 - tivMonday | 月曜日
2 - tivTuesday | 火曜日
3 - tivWednesday | 水曜日
4 - tivThursday | 木曜日
5 - tivFriday | 金曜日
6 - tivSaturday | 土曜日


FixedColumns プロパティ

関連項目

スクロールせずに固定表示する列を、1列目からの列数で設定します。値の取得も可能です。

構文

object.FixedColumns [= number]

FixedColumns プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。
number | スクロールせずに固定表示する列について、1列目からの列数を整数で指定します。デフォルトは、-1 (全固定) です。

解説

列見出しのうち、1列から指定列数分を、横スクロールの対象外として固定表示することができます。0 (固定列なし) を指定した場合、すべての列が横スクロールの対象となります。また、-1 (全固定) を指定した場合、すべての列を固定表示するため、セルペインの幅は強制的に列全体の幅となり、また垂直分割バーは表示されません。


Font プロパティ

関連項目

Font オブジェクトへの参照を返します。

構文

object.Font

指定項目 | 内容
object | 「対象」一覧内のいずれかのオブジェクトを指すオブジェクト式です。

解説

対象が タイム ビュー コントロール の場合、タイム ビュー コントロールの Font プロパティから参照する Font オブジェクトは、列見出しに表示する文字列の描画に使用します。

対象が ColumnHeader オブジェクト の場合、ColumnHeader オブジェクトの Font プロパティから参照する Font オブジェクトは、列見出しに対応するセルの文字列の描画に使用します。

対象が LetterScale オブジェクト の場合、LetterScale オブジェクトの Font プロパティから参照する Font オブジェクトは、タイム スケールの大区分又は中区分の目盛り文字の描画に使用します。

対象が DragTip オブジェクト の場合、DragTip オブジェクトの Font プロパティから参照する Font オブジェクトは、ドラッグ ヒント文字列の描画に使用します。

対象が Caption オブジェクトの場合、キャプション文字列の描画に使用します。


FooterHeight プロパティ, HeaderHeight プロパティ

関連項目

タイム ビュー コントロールの PrintPreview メソッド及び PrintStart メソッド、 PrintDirect メソッドで印刷を行うときの、ヘッダ領域又はフッタ領域の高さを設定します。値の取得も可能です。

構文

object.FooterHeight [= height]

object.HeaderHeight [= height]

FooterHeight プロパティ、 HeaderHeight プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | PrintInfo オブジェクトへの参照を表すオブジェクト式です。
height | ヘッダ領域又はフッタ領域の高さをセンチメートルを単位とした実数で指定します。デフォルトはヘッダ領域、フッタ領域共に 0 です。

解説

FooterHeight プロパティ、 HeaderHeight プロパティに 0 より大きい値を指定すると、１ページを印刷するたびに FooterPrint イベント又は HeaderPrint イベント又はその両方を発進し、ユーザー側でヘッダ及びフッタ領域を描画する機会を与えます。


ForeColor プロパティ

関連項目

塗りつぶし領域の前景色を設定します。値の取得も可能です。

構文

object.ForeColor [= color]

ForeColor プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | FillFormat オブジェクトへの参照を表すオブジェクト式です。
color | 色を示す数式を指定します。

解説

ForeColor プロパティは、 FillFormat オブジェクトの Pattern プロパティがハッチ パターンを示す値の場合はパターンの描画色として使用され、グラデーションを示す値の場合は、グラデーションの混合色として使用されます。


Format プロパティ

関連項目

文字列の表示書式を設定します。値の取得も可能です。

構文

object.Format [= format]

Format プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | 「対象」一覧内のいずれかのオブジェクトを指すオブジェクト式です。
format | 文字列の表示に使用する日付/時刻表示書式を指定します。

解説

タイム スケールの目盛文字や、ピース キャプションで開始日時、又は終了日時を表示する時に使用する表示書式を設定します。

対象が LetterScale オブジェクトの場合、タイム スケールの大区分の目盛文字の表示書式を設定するには、 TimeScale オブジェクトの Large プロパティから参照する LetterScale オブジェクトの Format プロパティを使用します。同様に、中区分の目盛り文字の場合は、 TimeScale オブジェクトの Medium プロパティから参照する LetterScale オブジェクト Format プロパティを使用します。

対象が Pieces コレクションの場合、ピース キャプションを使ってピースの開始又は終了日時を表示する時に使用する表示書式を設定するには、対象ピースをコレクションしている Pieces コレクションの Format プロパティを使用します。ピース キャプションの表示属性の設定は、Piece オブジェクト毎にはできず、 Pieces コレクション毎 (即ち行毎) に設定することができます。


Height プロパティ

関連項目

小区分目盛り領域の高さを設定します。値の取得も可能です。

構文

object.Height [= height]

Height プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | LineScale オブジェクトへの参照を表すオブジェクト式です。
height | 小区分目盛り領域の高さをコンテナ単位の値で指定します。


Hidden プロパティ

関連項目

対象オブジェクトを表示するかどうかを設定します。値の取得も可能です。

構文

object.Hidden [= boolean]

Hidden プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | 「対象」一覧内のいずれかのオブジェクトを指すオブジェクト式です。
boolean | 対象オブジェクトを表示するかどうかを示す、ブール式を指定します。

設定値

boolean の設定値は次のとおりです。

設定値 | 内容
True | 表示しません。
False(既定値) | 表示します。

解説

対象が CurrentTime オブジェクトの場合、現在日時線を表示するかどうかを表します。

対象が LetterScale オブジェクトの場合、タイム スケールの大区分を表示するかどうかを表します。中区分を非表示にすることはできません。

対象が LineFormat オブジェクトの場合、タイム スケールの小区分を表示するかどうかを表します。

対象が DragTip オブジェクトの場合、ドラッグ操作中にドラッグ ヒントを表示するかどうかを表します。

対象が Balloon オブジェクトの場合、吹き出しを表示するかどうかを表します。真 (True) が設定されているにもかかわらず、 Parent プロパティから参照する親オブジェクトが表示されていない等の理由で吹き出しが表示されていない場合でも、値は真 (True) のままです。

実際に表示されているかをチェックするには、 IsVisible メソッドを使います。

対象が RelatedLine オブジェクトの場合、関係線を表示するかどうかを表します。真 (True) が設定されているにもかかわらず、接続先のピースが表示されていない等の理由で関係線が表示されていない場合でも、値は真 (True) のままです。

実際に表示されているかをチェックするには、 IsVisible メソッドを使います。


HideCellSelection プロパティ

関連項目

タイム ビュー コントロールがフォーカスを失ったときに、カレント セルの表示をどうするかを指定します。値の取得も可能です。

構文

object.HideCellSelection [= boolean]

HideCellSelection プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。
boolean | タイム ビュー コントロールがフォーカスを失ったときに、カレント セルの表示をどうするかをブール式で指定します。設定する値については、次の「設定値」を参照してください。

設定値

boolean の設定値は次のとおりです。

設定値 | 内容
True(既定値) | コントロールがフォーカスを失うと、カレント セルの表示は行われません。
False | コントロールがフォーカスを失っても、カレント セルは表示したままです。


HidePieceSelection プロパティ

関連項目

タイム ビュー コントロールがフォーカスを失ったときに、ピース選択の表示をどうするかを指定します。値の取得も可能です。

構文

object.HidePieceSelection [= boolean]

HidePieceSelection プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。
boolean | タイム ビュー コントロールがフォーカスを失ったときに、ピース選択の表示をどうするかをブール式で指定します。設定する値については、次の「設定値」を参照してください。

設定値

boolean の設定値は次のとおりです。

設定値 | 内容
True(既定値) | コントロールがフォーカスを失うと、ピース選択の表示は行われません。
False | コントロールがフォーカスを失っても、ピース選択は表示したままです。


HitTestTarget プロパティ

関連項目 使用例

対象オブジェクトをヒットテストの対象にするかどうかを設定します。値の取得も可能です。

構文

object.HitTestTarget [= boolean]

HitTestTarget プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | 「対象」一覧内のいずれかのオブジェクトを指すオブジェクト式です。
boolean | 対象オブジェクトをヒットテストの対象にするかどうかを示す、ブール式を指定します。

設定値

boolean の設定値は次のとおりです。

設定値 | 内容
True(既定値) | ヒットテストの対象にします。
False | ヒットテストの対象にしません。

解説

対象が Balloon オブジェクトの場合、吹き出しをヒットテストの対象にするかどうかを表します。

対象が RelatedLine オブジェクトの場合、関係線をヒットテストの対象にするかどうかを表します。


HitTestWidth プロパティ

関連項目 使用例

ヒットテストの有効幅を設定します。値の取得も可能です。

構文

object.HitTestWidth [= value]

HitTestWidth プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | RelatedLine オブジェクトへの参照を表すオブジェクト式です。
value | ヒットテストの有効幅をコンテナ単位で指定します。既定値は 3 ピクセルです。

解説

HitTestWidth プロパティを使うと、ヒットテストの有効範囲を変更することができます。

下図においてヒットテストの有効範囲は、関係線の周りの点線です。 HitTestWidth プロパティには、関係線から、その有効範囲の矩形までの長さを指定します。

下図は、いくつかのパターンです。

※ピースと重なり合っている部分は、関係線の方が優先されます。


HorAlign プロパティ

関連項目

オブジェクトの表示領域内におけるテキストの横方向の配置を設定します。値の取得も可能です。

構文

object.HorAlign [= align]

HorAlign プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | 「対象」一覧内のいずれかのオブジェクトを指すオブジェクト式です。
align | テキストの横方向の配置を示す値を整数で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 align の設定値は次のとおりです。

定数名 | 内容
0 - tivTextHorAlignLeft | 左詰め
1 - tivTextHorAlignCenter | 中央揃え
2 - tivTextHorAlignRight | 右詰め

解説

対象オブジェクトが PieceCaption オブジェクトで、 Position プロパティの値が 3 (ピース バーの左側) 又は 4 (ピース バーの右側) の場合、 HorAlign プロパティは使用されません。


HSBarWindowFit プロパティ

関連項目 使用例

水平スクロールバーをコントロールの幅に合わせて表示するかどうかを設定します。値の取得も可能です。

構文

object.HSBarWindowFit [= boolean]

HSBarWindowFit プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。
boolean | 水平スクロールバーをコントロールの幅に合わせて表示するかどうかをブール式で指定します。設定する値については、次の「設定値」を参照してください。

設定値

boolean の設定値は次のとおりです。

設定値 | 内容
True | 水平スクロールバーをコントロールの幅に合わせて表示します。
False(既定値) | 水平スクロールバーをコントロールの幅に合わせて表示しません。

解説

HSBarWindowFit プロパティに真 (True) を設定すると、セルペインの下の領域まで水平スクロールバーの幅を拡張して表示します。

HSBarWindowFitプロパティが偽 (False) の場合

HSBarWindowFitプロパティが真 (True) の場合

FixedColumns プロパティに -1 (全固定) 以上の値が設定されている場合は、セルペインの水平スクロールバーの幅を、固定列の下の領域まで拡張して表示します。

HSBarWindowFitプロパティが偽 (False) の場合

HSBarWindowFitプロパティが真 (True) の場合


ImageLists プロパティ

関連項目

セルやピース端点に設定する一つ以上の画像を格納する ImageLists コレクションへの参照を返します。実行時のみ使用できます。

構文

object.ImageLists

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。

解説

画像は、ImageLists コレクションと ImageList オブジェクトがもつ Images コレクションの２層で管理しています。上位コレクション (ImageLists コレクション) と 下位コレクション (Images コレクション)の使い分けは自由です。単純な利用では、ImageLists コレクションに一つだけ ImageList オブジェクトを追加し、この ImageList オブジェクトがもつ Images コレクションに複数の画像をロードして使用します。画像に分類がある場合（予定の種類を表す画像群と緊急度を表す画像群）などは、分類の数だけ ImageList オブジェクトを追加して、それぞれの Images コレクションに画像をロードして使用します。


ImagePosition プロパティ

関連項目

テキストに対するイメージの位置を設定します。値の取得も可能です。

構文

object.ImagePosition [= position]

ImagePosition プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | 「対象」一覧内のいずれかのオブジェクトを表すオブジェクト式です。
position | テキストに対するイメージの位置を整数で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 position の設定値は次のとおりです。

定数名 | 内容
0 - tivImagePositionLeft | 文字列の左側に配置します。
1 - tivImagePositionRight | 文字列の右側に配置します。

解説

テキストとイメージの位置関係を設定します。イメージは Image メソッドで指定した画像です。

HorAlign プロパティ、および VerAlign プロパティは、テキストとイメージをひとまとまりとした内容に適用します。

テキストのイメージへの回り込みはサポートしていません。


Images プロパティ

関連項目

Images コレクションへの参照を返します。

構文

object.Images

指定項目 | 内容
object | ImageList オブジェクトへの参照を表すオブジェクト式です。

解説

ImageList オブジェクトは、Images プロパティから参照する Images コレクションに画像を格納しています。Images コレクションに画像を追加するには、ImageLists コレクションの Add メソッド、または Images コレクションの Add メソッドを使用します。


Index プロパティ

関連項目

コレクション内のオブジェクトを識別する、1から始まる番号 (インデックス番号) を設定します。値の取得も可能です。

構文

object.Index [= index]

Index プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | 「対象」一覧内のいずれかのオブジェクトを指すオブジェクト式です。
index | コレクション内のオブジェクトを識別する、1から始まる番号 (インデックス番号) を整数で指定します。


Interval プロパティ

関連項目

タイム スケールの目盛りの間隔を指定します。値の取得も可能です。

構文

object.Interval [= interval]

Interval プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | 「対象」一覧内のいずれかのオブジェクトを指すオブジェクト式です。
interval | 目盛りの間隔を整数で指定します。デフォルトは 1 です。 0 を指定した場合、目盛りを表示しません。

解説

大区分又は中区分、小区分の目盛の表示間隔を表します。目盛りは、 LetterScale オブジェクト又は LineScale オブジェクトの Unit プロパティで指定した単位で、 Interval プロパティに指定した間隔毎に表示されます。 Unit プロパティの値が 3 (時間単位)で Interval プロパティの値が 6 の場合は、 6 時間毎に目盛りが表示されます。


ItemHeight プロパティ

関連項目

アイテムの高さの設定します。値の取得も可能です。

構文

object.ItemHeight [= height]

ItemHeight プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。
height | アイテムの高さをコンテナ単位で指定します。

解説

アイテムの高さは、全てのアイテムで一律です。アイテム毎に高さを設定することはできません。

ItemHeight プロパティは、 ItemHeightMode プロパティの値が 1 (自動) のときは使用されません。

マウス操作でアイテムの高さを変更すると、 ItemHeight プロパティの値も更新されます。


ItemHeightMode プロパティ

関連項目

アイテムの高さをタイム ビュー コントロールが自動的に決めるかどうかを指定します。値の取得も可能です。

構文

object.ItemHeightMode [= mode]

ItemHeightMode プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。
mode | アイテムの高さをタイム ビュー コントロールが自動的に決めるかどうかを示す値を整数で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 mode の設定値は次のとおりです。

定数名 | 内容
0 - tivManual | ItemHeight プロパティが示す高さで表示します。
1 - tivAutomatic (既定値) | タイム ビュー コントロールが計算したアイテムの高さで表示します。

解説

ItemHeightMode プロパティに 1 (自動) を指定した場合、アイテムの高さは PieceFont プロパティから参照する Font オブジェクトの Size プロパティの値や、すべてのピースのピース キャプション の表示状態などから計算した高さで常に表示します。

注意事項

ItemHeightMode プロパティに 1 (自動) を指定したときの自動調整は、ピース キャプションに表示される文字列の改行数については考慮しません。


ItemIndex プロパティ

関連項目

Items コレクション内の Item オブジェクト を識別する、固有のインデックスを設定します。値の取得も可能です。

構文

object.ItemIndex [= index]

ItemIndex プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | 「対象」一覧内のいずれかのオブジェクトを指すオブジェクト式です。
index | Items コレクション内の Item オブジェクトを識別する、固有のインデックス。

解説

対象が タイム ビュー コントロールの場合、カレント セルの行位置を表します。値を設定して、カレント セルの位置を変えることができます。

対象が HitTestResult オブジェクトの場合、タイム ビュー コントロールの HitTest メソッドが、ヒットしたアイテムに対応するItem オブジェクトを識別するインデックスを返します。

対象が Cell オブジェクトの場合、セルを含むアイテムのアイテム コレクション内でのインデックスを示します。

対象が Piece オブジェクトの場合、ピースを含むアイテムのアイテム コレクション内でのインデックスを示します。


Items プロパティ

関連項目

Items コレクションへの参照を返します。実行時のみ使用できます。

構文

object.Items

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。

解説

タイム ビュー コントロールのアイテム (即ち行) の集合を表す、Items コレクションへの参照を返します。アイテムの追加や削除は、 Items プロパティから参照する Items コレクションのメソッドを使って行うことができます。


JoinRelatedLines プロパティ

関連項目 使用例

JoinRelatedLines コレクションへの参照を返します。実行時のみ使用できます。

構文

object.JoinRelatedLines

JoinRelatedLines プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | Piece オブジェクトへの参照を表すオブジェクト式です。

解説

JoinRelatedLines コレクションは、接続されている関係線を表す RelatedLine オブジェクトのコレクションです。

JoinRelatedLines コレクションは、 RelatedLine オブジェクトの追加、削除を行うメソッドはありません。


JustClippingToScale プロパティ

関連項目

中区分目盛の途中での改ページ、および印刷対象外の目盛の出力を抑制するかどうかを設定します。値の取得も可能です。

構文

object.JustClippingToScale [= boolean]

JustClippingToScale プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | PrintInfo オブジェクトへの参照を表すオブジェクト式です。
boolean | 印刷における中区分目盛の途中での改ページ、および印刷対象外の目盛の出力を抑制するかどうかをブール式で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 boolean の設定値は次のとおりです。

定数名 | 内容
True | 印刷する時間範囲が1ページを超えるために改ページするとき、中区分の目盛に合わせてクリッピングします。この場合、次ページ左端には前ページの目盛の次の目盛から出力します。 また、印刷する時間範囲の最後が、ページの右端より手前で終わっても、余分な目盛を出力せずに空欄とします。
False (既定値) | 印刷する時間範囲が1ページを超えるために改ページするとき、単純にページの右端でクリッピングします。もしクリッピングした位置が中区分の目盛の途中だった場合、次ページ左端の時間は、前ページで中途半端になった目盛から出力します。 また、印刷する時間範囲の最後が、ページの右端より手前で終わるとき、時間範囲の最終時間を延長してページの右端まで印刷します。

解説

PrintInfo オブジェクトの StartTime プロパティ、FinishTime プロパティにて指定した時間範囲を印刷する際に、改ページにおける目盛のクリッピング、および特定ページに出力する目盛全体の幅がページの幅より少ないときの余白調整の有無を指定します。
JustClippingToScale プロパティに真 (True) を設定した場合、ChartBorder プロパティを設定してチャート境界線を印刷するようにすると、境界線に右端がきれいに仕上がります。


Key プロパティ

関連項目

コレクション内の固有のメンバを識別する文字列を設定します。値の取得も可能です。

構文

object.Key [= string]

Key プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | 「対象」一覧内のいずれかのオブジェクトを指すオブジェクト式です。
string | コレクション内のメンバを識別する固有の文字列を指定します。

解説

Key プロパティに指定する文字列は、コレクション内で一意でなければいけません。

Add メソッドを使用してオブジェクトをコレクションに追加する場合、Key プロパティを設定できます。

Index プロパティの動的な変更が予想される場合、Key プロパティを使用してコレクション内のオブジェクトを参照してください。


Keys プロパティ

関連項目

Images コレクションに含まれるすべての Image オブジェクト の Key プロパティを一括設定します。値の取得も可能です。

構文

object.Keys [= keys]

Keys プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | Images コレクションを指すオブジェクト式です。
keys | Images コレクションに含まれるすべての Image オブジェクト の Key プロパティの値を格納した1次元配列が格納されたバリアント型の値。

解説

ImageLists コレクションの Add メソッド を使って、複数の画像にスライスされる画像ファイルをロードした場合に、スライスされた画像群を格納した Images コレクション中の各Image オブジェクトの Key プロパティの値を一度に設定することができます。


Large プロパティ

関連項目

LetterScale オブジェクトへの参照を返します。

構文

object.Large

指定項目 | 内容
object | TimeScale オブジェクトへの参照を表すオブジェクト式です。

解説

Large プロパティは、大区分の目盛りの単位や間隔、表示スタイルを設定する時に使用します。


LargeLine プロパティ, MediumLine プロパティ, SmallLine プロパティ, SubLine プロパティ

関連項目

LineFormat オブジェクトへの参照を返します。

構文

object.LageLine

object.MediumLine

object.SmallLine

object.SubLine

指定項目 | 内容
object | PiecePane オブジェクトへの参照を表すオブジェクト式です。

解説

ピース ペインには、タイム スケールの各区分の目盛りに対した位置に目盛り線を表示することができます。これらのプロパティを使用して、各区分に対応する目盛り線の描画属性を設定することができます。

LargeLine プロパティは、大区分の目盛りに対応する位置に表示する目盛り線の描画属性を表します。

MediumLine プロパティは、中区分の目盛りに対応する位置に表示する目盛り線の描画属性を表します。

SmallLine プロパティは、小区分の目盛りに対応する位置に表示する目盛り線の描画属性を表します。

SubLine プロパティは、小区分の補助目盛りに対応する位置に表示する目盛り線の描画属性を表します。


Length プロパティ

関連項目 使用例

矢印の傘の長さを設定します。値の取得も可能です。

構文

object.Length [= value]

Length プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | ArrowShape オブジェクトへの参照を表すオブジェクト式です。
value | 矢印の傘の長さをコンテナ単位で指定します。設定する値については、次の「設定値」を参照してください。既定値は、ピースフォントの高さの 1/2 の長さです。

解説

「矢印の傘の長さ」とは、下図の部分の長さです。


LenToBreak プロパティ

関連項目 使用例

矢印の形状の折れる位置までの長さを設定します。値の取得も可能です。

構文

object.LenToBeak [= value]

LenToBeak プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | ArrowShape オブジェクトへの参照を表すオブジェクト式です。
value | 矢印の形状の折れる位置までの長さの割合 (%) を整数で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 value の設定値は次のとおりです。

定数名 | 内容
0 ～ 99 | 三角形の底辺が食い込んだ形で表示されます。
100(規定値) | 三角形で表示されます。
200 | 菱形で表示されます。

解説

LenToBreak プロパティは、Shpae プロパティが三角 (2 - tivArrowShapeTriangle) の場合のみ有効です。

下図は、左から 100 、 80 、 200 を指定した場合の矢印の形状です。

LenToBeak プロパティの内容 | イメージ
100 |
80 |
200 |


Line プロパティ

関連項目

LineFormat オブジェクトへの参照を返します。

構文

object.Line

指定項目 | 内容
object | 「対象」一覧内のいずれかのオブジェクトを指すオブジェクト式です。

解説

矩形領域又は任意形状の描画において、境界線の描画属性を表します。

対象が BarShape オブジェクトの場合、ピース バー領域の境界線の有無、又は線種や色を表します。

対象が PointShape オブジェクトの場合、ピース端点の形状に対する境界線の有無、又は線種や色を表します。

対象が Progress オブジェクトの場合、達成率バー領域の境界線の有無、又は線種や色を表します。

対象が DragTip オブジェクトの場合、ドラッグ ヒント ウィンドウの境界線の有無、又は線種や色を表します。

対象が AllowShape オブジェクトの場合、矢印の線種や色を表します。

対象が RelatedLine オブジェクトの場合、関係線の線種や色を表します。

対象が BalloonShape オブジェクトの場合、吹き出しの境界線の有無、又は線種や色を表します。


Line プロパティ (CurrentTime オブジェクト)

関連項目

LineFormat オブジェクトへの参照を返します。

構文

object.Line

指定項目 | 内容
object | CurrentTime オブジェクトを指すオブジェクト式です。

解説

CurrentTime オブジェクトの Line プロパティを使って、現在日時線の線種や色を設定することができます。


Line プロパティ, SubLine プロパティ (LineScale オブジェクト)

Line プロパティ, SubLine プロパティ

関連項目

LineFormat オブジェクトへの参照を返します。

構文

object.Line

object.SubLine

指定項目 | 内容
object | LineScale オブジェクトへの参照を表すオブジェクト式です。

解説

タイム スケールの小区分に表示する、目盛り線又は補助目盛り線の描画属性を表す LineFormat オブジェクトへの参照を返します。小区分目盛りの線種や色を設定することができます。


LockedPieceSelectionColor プロパティ

関連項目

ドラッグ不可状態にあるピースの選択ハンドルの色を設定します。値の取得も可能です。

構文

object.LockedPieceSelectionColor [= color]

LockedPieceSelectionColor プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。
color | ドラッグ不可状態にあるピース選択ハンドルの色を指定します。デフォルトは RGB(255, 0, 0) (赤) です。

解説

ピース選択ハンドルとは、ピースをマウス クリックなどで選択状態にした場合に、ピース端点上に小さな矩形として表示されるものを示します。重複が禁止されたピースや特別時間帯 (Prohibited プロパティ参照) と重なっているなどの理由でドラッグが不可能になっているピースを選択状態にした場合、このプロパティに設定した色でハンドルを表示します。ドラッグ可能なピースの選択ハンドルの色は、PieceSelectionColor プロパティに設定します。


Magnification プロパティ

関連項目

タイム ビュー コントロールの PrintPreview メソッド又はPrintStart メソッド、 PrintDirect メソッドで印刷する場合の拡大・縮小率を設定します。値の取得も可能です。

構文

object.Magnification [= magnification]

Magnification プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | PrintInfo オブジェクトへの参照を表すオブジェクト式です。
magnification | タイム ビュー コントロールの PrintPreview メソッド又はPrintStart メソッド、 PrintDirect メソッドで印刷する場合の拡大・縮小率を示すパーセント値を整数で指定します。10～400の範囲で設定可能です。デフォルトは 100 (%)です。

解説

印刷の出力を拡大、または縮小する率を設定します。拡大・縮小は、タイムビュー全体の描画、およびヘッダ、フッタの描画に適用されます。


MarginLeft プロパティ、 MarginTop プロパティ、 MarginRight プロパティ、 MarginBottom プロパティ (Caption オブジェクト)

MarginLeft プロパティ、 MarginTop プロパティ、 MarginRight プロパティ、 MarginBottom プロパティ

関連項目 使用例

吹き出しなどに表示するキャプションの、テキストの端に確保する余白のサイズを設定します。値の取得も可能です。

構文

object.MarginLeft [= value]

object.MarginTop [= value]

object.MarginRight [= value]

object.MarginBottom [= value]

MarginLeft プロパティ、 MarginTop プロパティ、 MarginRight プロパティ、 MarginBottom プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | Caption オブジェクトを指すオブジェクト式です。
value | テキストの端に確保する余白のサイズを示す値をコンテナ単位で指定します。デフォルトの値はフォントサイズの 1/5 です。

解説

各プロパティには、マイナス値を指定することもできます。マイナス値を指定すると、対象の矩形はテキストの内側になります。

AncherRelPoint プロパティの内容 | イメージ
MarginLeft ： 10 MarginTop ： 10 MarginRight ： 10 MarginBottom ： 10 |
MarginLeft ： 0 MarginTop ： 0 MarginRight ： 0 MarginBottom ： 0 |
MarginLeft ： -10 MarginTop ： -10 MarginRight ： -10 MarginBottom ： -10 |

※赤枠はテキストの描画範囲です。


MarginLeft プロパティ、 MarginTop プロパティ、 MarginRight プロパティ、 MarginBottom プロパティ (PrintInfo オブジェクト)

MarginLeft プロパティ、 MarginTop プロパティ、 MarginRight プロパティ、 MarginBottom プロパティ

関連項目

タイム ビュー コントロールの PrintPreview メソッド又はPrintStart メソッド、 PrintDirect メソッドで印刷する場合の、用紙端に確保する余白のサイズを設定します。値の取得も可能です。

構文

object.MarginLeft [= cm]

object.MarginTop [= cm]

object.MarginRight [= cm]

object.MarginBottom [= cm]

MarginLeft プロパティ、 MarginTop プロパティ、 MarginRight プロパティ、 MarginBottom プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | PrintInfo オブジェクトへの参照を表すオブジェクト式です。
cm | 用紙端に確保する余白のサイズを示す値をセンチメートル単位の実数で 0 以上の値を指定します。デフォルトの値は 1.2cm です。


Medium プロパティ

関連項目

LetterScale オブジェクトへの参照を返します。

構文

object.Medium

指定項目 | 内容
object | TimeScale オブジェクトへの参照を表すオブジェクト式です。

解説

Medium プロパティは、中区分の目盛りの単位や間隔、表示スタイルの設定に使用します。


MergeMode プロパティ

関連項目

列見出しに対応する列に含まれるセルどうしの結合方法を設定します。値の取得も可能です。

構文

object.MergeMode [= mode]

MergeMode プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | ColumnHeader オブジェクトへの参照を表すオブジェクト式です。
mode | 上下に隣り合うセル同士を結合する方法を整数で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 mode の設定値は次のとおりです。

定数名 | 内容
0 - tivMergeNone (既定値) | 結合なし。セルの結合を行いません。
1 - tivMergeRestrict | 制約付きで結合。左の列の MergeMode プロパティが 1 (制約付きで結合)、又は 2 (自由に結合) のとき、左の列で結合されている枠の範囲内で結合を行います。
2 - tivMergeFree | 自由に結合。左の列の結合状態に影響を受けません。

解説

上下に隣り合うセルの内容が同じ場合に、まとめて１つのセルとして表示することができます。

以下にいくつかの結合パターンを示します。


MiniWidthToPiece プロパティ、 MiniHeightToPiece プロパティ

関連項目 使用例

ピースまでの最小幅、最小高さを設定します。値の取得も可能です。

構文

object.MiniWidthToPiece [= value]
object.MiniHeightToPiece [= value]

MiniWidthToPiece プロパティ、 MiniHeightToPiece プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | RelatedLine オブジェクトへの参照を表すオブジェクト式です。
value | ピースまでの最小幅、最小高さをコンテナ単位で指定します。最小幅の既定値は、ピースフォントの高さです。最小高さの既定値は、 PiecePanePaddingTop プロパティの値です。

解説

MiniWidthToPiece プロパティ、 MiniHeightToPiece プロパティを使うと、接続線からピースまでの最小幅、最小高さを変更することができます。

下図では、赤が MiniWidthToPiece プロパティで指定する最小幅、青が MiniHeightToPiece プロパティで指定する最小高さです。


Misc プロパティ

関連項目

タイム ビュー コントロールの機能を調節する値を指定します。値の取得も可能です。

構文

object.Misc [= misc]

Misc プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。
misc | タイム ビュー コントロールの機能を調節する値を指定します。設定する値については、次の「設定値」を参照してください。複数の設定値を指定する場合は、論理 OR によって設定します。

設定値

引数 misc の設定値は次のとおりです。

定数名 | 内容
1 - tivMiscHitTestPrecise | ピースに対するヒットテストをピース バーの形状を考慮して行います。この値を指定しない場合、同一アイテム内で、且つ同じ時間帯に重なるピース同士の検出が正確にできない反面、ヒットテストが大まかになるので、マウスでの選択が容易になります。
2 - tivMiscHitTestBackOrder | ヒットテストにおいて、同一アイテム内にあるピースのテスト順を、Index プロパティの値が大きいほうから行います。この値を指定しない場合、 Index プロパティの値が小さいほうからテストします。
4 - tivMiscHitTestTime | ヒットテストにおいて、ピース、およびピースの始点／終点にヒットした場合にも、 HitTestResult オブジェクトの Time プロパティに、マウスポインタの位置に対応する日時を返すようにします。この値を指定しない場合、 Time プロパティの値は常に 0 です。
8 - tivMiscSpecialTimeNewMode | 必ずすべての特別時間帯設定を描画するようになります。特別時間帯 (SpecialTimes) コレクションに含まれる複数の特別時間帯で異なるパターンを設定していても、もれなくすべて描画します。また、V1.5 R.00 より追加された、SpcialTime オブジェクトの ZOrder プロパティが利用可能になります。
16 - tivMiscDontPrintFocus | セルカーソルや、ピース選択マークを印刷しないようにします。
32 - tivMiscFinePieceDraw | ピースのバー、および端点図形の描画高を、状況によって 1 ピクセル多くして描画品質が向上するように調整します。1 ピクセル増やすかどうかは、PieceFont プロパティから参照する Font オブジェクトを使用した実際の文字の描画高に依存します。

解説

タイム ビュー コントロールのバージョン アップの一部には、基本仕様の見直しなどで、既存のプロパティやメソッドの動作の変更を伴うものもあります。 Misc プロパティは、タイム ビュー コントロールの動作について、下位互換を維持するために設けられたプロパティです。各設定値について、設定がなければバージョンアップ前の仕様で動作し、設定をするとバージョンアップ後の新しい仕様で動作します。

タイム ビュー V1.2 R.00 以降のバージョンから新規利用の場合、設定値 tivMiscHitTestPrecise と tivMiscHitTestBackOrder は、はじめから設定されています。

V1.3 R.00 以降のバージョンから新規利用の場合は、 V1.2 R.00 の分に加えて、 tivMiscHitTestTime もはじめから設定されています。

V1.5 R.00 以降のバージョンから新規利用の場合は、 V1.3 R.00　までの分に加えて、 tivMiscSpecialTimeNewMode もはじめから設定されています。

V1.6 R.00 以降のバージョンから新規利用の場合は、 V1.5 R.00　までの分に加えて、 tivMiscDontPrintFocus もはじめから設定されています。

V2.0 R.00 以降のバージョンから新規利用の場合は、 V1.6 R.00　までの分に加えて、 tivMiscFinePieceDraw もはじめから設定されています。


MonochromeText プロパティ

関連項目

印刷する文字の色を白、または黒に変換して出力するかどうかを設定します。値の取得も可能です。

構文

object.MonochromeText [= boolean]

MonochromeText プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | PrintInfo オブジェクトへの参照を表すオブジェクト式です。
boolean | 印刷する文字の色を白、または黒に変換して出力するかどうかをブール式で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 boolean の設定値は次のとおりです。

定数名 | 内容
True | ディスプレイに対する描画色が白(RGB(0, 0, 0))の文字は白で印刷し、その他の色の文字をすべて黒で印刷します。
False (既定値) | ディスプレイに対する描画と同じ色を使って印刷します。

解説

モノクロ プリンタを使った印刷において、文字がはっきり印刷されるように、文字の印刷色を自動的に白、または黒に変換するかどうかを設定します。このプロパティの設定は、画面の描画、および文字色を示す各プロパティの値に影響を与えることはありません。印刷の出力に対してのみ適用されます。

モノクロやカラーなどのプリンタの性能に関係なく使用できます。


ObjectType プロパティ

関連項目

タイム ビュー コントロールの HitTest メソッドを使って分かった、ヒットしたオブジェクトの種類を表します。

構文

object.ObjectType [= type]

ObjectType プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | HitTestResult オブジェクトへの参照を表すオブジェクト式です。
type | ヒットテストによりヒットしたオブジェクトの種類を示す値を整数で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 type の設定値は次のとおりです。

定数名 | 内容
0 - tivObjectNothing | ヒットしたオブジェクトなし。
1 - tivCell | セル。
2 - tivColumnHeader | 列見出し。
3 - tivPiece | ピース。
4 - tivPieceStart | ピース開始日時。
5 - tivPieceFinish | ピース終了日時。
6 - tivPiecePane | ピース ペイン。
7 - tivTimeScale | タイム スケール。
8 - tivColumnWidthUIPoint | 列幅変更UIポイント。
9 - tivItemHeightUIPoint | 行高変更UIポイント。
10 - tivWidthPerScaleUIPoint | 目盛り幅変更UIポイント。


OLEDragMode プロパティ

関連項目

OLE ドラッグ アンド ドロップ操作の処理をタイム ビュー コントロールが行うか、またはプログラマが行うかを設定します。値の取得も可能です。

構文

object.OLEDragMode [= mode]

OLEDragMode プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。
mode | タイム ビュー コントロールが OLE ドラッグ アンド ドロップ操作を処理する方法を整数で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 mode の設定値は次のとおりです。

定数名 | 内容
0 - tivOLEDragManual(既定値) | 手動。プログラマがすべての OLE ドラッグ アンド ドロップ操作を処理します。
1 - tivOLEDragAutomatic | 自動。タイム ビュー コントロールですべての OLE ドラッグ アンド ドロップ操作を処理します。

解説

OLEDragMode プロパティを 0 (手動) に設定した場合、ドラッグを開始するには OLEDrag メソッドを呼び出す必要があります。OLEDrag メソッドは、OLEStartDrag イベントを発生させます。

OLEDragMode プロパティを 1 (自動) に設定した場合、ユーザーがコントロールの外側にドラッグするとき、OLEStartDrag イベント (および OLESetData イベントなど、ほかのソースレベルの OLE ドラッグ アンド ドロップ イベント) が発生する前に、ソース コンポーネントはそのデータを DataObject オブジェクトに格納し、引数 effects を設定します。これにより、ユーザーはドラッグ アンド ドロップ操作を制御できるようになり、Clear メソッドまたは SetData メソッドを使ってほかの形式を追加したり、データと形式の自動設定を無効にできます。

ソースの OLEDragMode プロパティが 1 (自動) に設定され、OLEStartDrag イベントにデータがロードされないか、または引数 aftereffects が 0 に設定された場合は、OLE ドラッグ アンド ドロップ操作は実行されません。


OLEDropMode プロパティ

関連項目

ターゲット コンポーネントがドロップ操作を処理する方法を設定します。値の取得も可能です。

構文

object.OLEDropMode [= mode]

OLEDropMode プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。
mode | タイム ビュー コントロールが OLE ドラッグ アンド ドロップ操作を処理する方法を整数で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 mode の設定値は次のとおりです。

定数名 | 内容
0 - tivOLEDropNone (既定値) | なし。ターゲット コンポーネントは OLE ドロップを受け付けず、ドロップできないカーソルを表示します。
1 - tivOLEDropManual | 手動。ターゲット コンポーネントは OLE ドロップ イベントを発生させます。プログラマは、プログラム内ですべての OLE ドロップ操作を処理できます。


Orientation プロパティ

関連項目

タイム ビュー コントロールの PrintPreview メソッド又はPrintStart メソッド、 PrintDirect メソッドで印刷する場合の用紙方向を設定します。値の取得も可能です。

構文

object.Orientation [= orientation]

Orientation プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。
orientation | タイム ビュー コントロールの PrintPreview メソッド又はPrintStart メソッド、 PrintDirect メソッドで印刷する場合の用紙方向を示す値を整数で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 orientaion の設定値は次のとおりです。

定数名 | 内容
0 - tivDefaultOrientation (既定値) | 現在のプリンタの設定に従います。
1 - tivPrintPortrait | 縦方向に印刷します。
2 - tivPrintLandscape | 横方向に印刷します。


Origin プロパティ

関連項目

タイム スケールの目盛りの日時を決めるときの、基準日を設定します。値の取得も可能です。

構文

object.Origin [= date]

Origin プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | TimeScale オブジェクトへの参照を表すオブジェクト式です。
date | タイム スケールの目盛りの日時を決めるときの、基準日を示す日付式で指定します。デフォルト値は、実行時のシステムの時間が示す年の1月1日です。

解説

Orgin プロパティの目的を説明する例として、例えば、小区分の目盛りの単位が時単位で、目盛りの間隔が 5の場合、中区分の目盛りは 5時間間隔で表示されますが、具体的には、ある基準となる日付の 0時 0分から、0時、5時、10時、15時、20時、1時、6時、11時という風に表示していきます。この基準となる日付が Origin プロパティの示す日付です。


PageBreak プロパティ

関連項目

このアイテムを次ページの先頭に印刷するかどうかを設定します。値の取得も可能です。

構文

object.PageBreak [= boolean]

PageBreak プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | Item オブジェクトへの参照を表すオブジェクト式です。
boolean | このアイテムを次ページの先頭に印刷するかどうかをブール式で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 boolean の設定値は次のとおりです。

定数名 | 内容
True | このアイテムの直前で強制的に改ページしたのち、新しいページの先頭に印刷します。
False (既定値) | このアイテムの直前で強制的に改ページしません。

解説

印刷時に、明示的に改ページしたいアイテム位置を設定します。

通常アイテム方向の改ページ位置は、アイテムが1ページに収まらなくなった時点で改ページをします。


PaperSize プロパティ

関連項目

タイム ビュー コントロールの PrintPreview メソッド又はPrintStart メソッド、 PrintDirect メソッドで印刷する場合の用紙サイズを設定します。値の取得も可能です。

構文

object.PaperSize [= papersize]

PaperSize プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | PrintInfo オブジェクトへの参照を表すオブジェクト式です。
papersize | タイム ビュー コントロールの PrintPreview メソッド又はPrintStart メソッド、 PrintDirect メソッドで印刷する場合の用紙サイズを示す値を整数で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 papersize の設定値は次のとおりです。

定数名 | 内容
0 - tivDefaultPaperSize (既定値) | 現在のプリンタの設定に従います。
1 - tivPaperA4 | A4 シート、210 × 297 mm。
2 - tivPaperA3 | A3 シート、297 × 420 mm。
3 - tivPaperA5 | A5 シート、148 × 210 mm。
4 - tivPaperB4 | B4 シート、250 × 354 mm。
5 - tivPaperB5 | B5 シート、182 × 257 mm。


Parent プロパティ

関連項目 使用例

親オブジェクトへの参照を取得します。実行時のみ使用が可能です。

構文

object.Parent

Parent プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | 「対象」一覧内のいずれかのオブジェクトへの参照を表すオブジェクト式です。

解説

Parent プロパティを使って、保持されている親オブジェクトの参照を取得することができます。コレクションに保持されている場合は、そのコレクションを保持しているオブジェクトが親オブジェクトになります。


Pattern プロパティ (FillFormat オブジェクト)

関連項目

塗りつぶし領域の塗りつぶしパターンを設定します。値の取得も可能です。

構文

object.Pattern [= pattern]

Pattern プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | FillFormat オブジェクトへの参照を表すオブジェクト式です。
pattern | 塗りつぶし領域の塗りつぶしパターンを示す値を整数で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 pattern の設定値は次のとおりです。

定数名 | 内容
0 - tivPatternNull | パターンなし。
1 - tivPatternHorizontal | 横縞。システム ハッチ ブラシ。
2 - tivPatternVertical | 縦縞。システム ハッチ ブラシ。
3 - tivPatternBackwardDiagonal | 右下がりの斜め線。システム ハッチ ブラシ。
4 - tivPatternForwardDiagonal | 右上がりの斜め線。システム ハッチ ブラシ。
5 - tivPatternCross | 縦横の格子。システム ハッチ ブラシ。
6 - tivPatternDiagonalCross | 斜めの格子。システム ハッチ ブラシ。
7 - tivPattern5Percent | 5%。カスタム パターン ブラシ。
8 - tivPattern10Percent | 10%。カスタム パターン ブラシ。
9 - tivPattern20Percent | 20%。カスタム パターン ブラシ。
10 - tivPattern25Percent | 25%。カスタム パターン ブラシ。
11 - tivPattern30Percent | 30%。カスタム パターン ブラシ。
12 - tivPattern40Percent | 40%。カスタム パターン ブラシ。
13- tivPattern50Percent | 50%。カスタム パターン ブラシ。
14 - tivPatternFineBackwardDiagonal | 右下がりの斜め線(細かい)。カスタム パターン ブラシ。
15 - tivPatternFineForwardDiagonal | 右上がりの斜め線(細かい)。カスタム パターン ブラシ。
16 - tivPatternFineDiagonalCross | 斜めの格子(細かい)。カスタム パターン ブラシ。
17 - tivPatternVerticalGradation | 縦のグラデーション。
18 - tivPatternHorizontalGradation | 横のグラデーション。
19 - tivPattern3D | 3D。

解説

システム ハッチ ブラシのパターンを指定した場合に、 BkMode プロパティに 0 (透過) が設定されていると、 ForeColor プロパティが示す色でパターンのみ描画し、 BackColor プロパティが示す色を使った背景塗りつぶしは行いません。システム ハッチ ブラシ以外のパターンの場合は、 BkMode プロパティの値に関係なく 背景を塗りつぶします。

もし Fill プロパティを持つオブジェクトが Line プロパティも持っていて、且つ Pattern プロパティに対して 3D を指定した場合、オブジェクトの表示領域の境界線は、BackColor プロパティが示す色から計算した反射色と影色を使って描画するので、Line プロパティが示す属性を使った線の描画は省略されます。

ItemPiecePane オブジェクト、 SpecialTime オブジェクトの Fill プロパティから参照する FillFormat オブジェクトの Pattern プロパティにグラデーションの塗りつぶしパターンを指定した場合、スクロールした場合に描画が乱れますので使用することができません。


Pattern プロパティ (SpecialTime オブジェクト)

関連項目

特別時間帯の適用パターンを設定します。値の取得も可能です。

構文

object.Pattern [= pattern]

Pattern プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | SpecialTime オブジェクトへの参照を表すオブジェクト式です。
pattern | 特別時間帯の適用パターンを示す値を整数で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 pattern の設定値は次のとおりです。

定数名 | 内容
0 - tivSpecialTimeDaily | Start プロパティから Finish プロパティまでの時間帯を、毎日に対して適用します。 Start プロパティと Finish プロパティの示す日時のうち、時分のみを使用します。
1 - tivSpecialTimeWeekly | Start プロパティから Finish プロパティまでの時間帯を、毎週の Target プロパティが示す曜日に対して適用します。 Start プロパティと Finish プロパティの示す日時のうち、時分のみを使用します。
2 - tivSpecialTimeDate | Start プロパティから Finish プロパティまでの時間帯を、 Target プロパティが示す日付のみに対して適用します。 Start プロパティと Finish プロパティの示す日時のうち、時分のみを使用します。
3 - tivSpecialTimeDirect | Start プロパティから Finish プロパティ プロパティの示す日時までを特別時間帯とします。ほかのパターンと異なり、日付部分も解釈します。つまり、Piece オブジェクトの Start プロパティ、およびFinish プロパティと同様の解釈をします。3 (tivSpecialTimeDirect) を使用するには、タイム ビュー コントロール の Misc プロパティ に 8 (tivMiscSpecialTimeNewMode) を設定しておく必要があります。


PercentFrom プロパティ, PercentTo プロパティ

関連項目

達成率の開始パーセント及び終了パーセントを設定します。値の取得も可能です。

構文

object.PercentFrom [= percent]

object.PercentTo [= percent]

PercentFrom プロパティ、 PercentTo プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | Progress オブジェクトへの参照を表すオブジェクト式です。
percent | 達成率の開始パーセント又は終了パーセントを示す百分率の値、又は任意の日時を表わす日付式を指定します。0.1は10%を表し、1.0は100%を表します。1999/8/5 10:00はひづけを表わします。

解説

終了パーセントは、開始パーセントより大きい値を指定してください。

ピースの開始日時又は終了日時を変更した場合、PercentFrom プロパティ、又はPercentTo プロパティが百分率を示す値の場合は達成率バーの表示位置も自動的に移動しますが、日付を示す値の場合は自動的な移動操作は行われません。必要に応じてプログラムコードで調節してください。


PieceBottomHeight プロパティ

関連項目

ピース下部キャプション領域の高さを設定します。値の取得も可能です。

構文

object.PieceBottomHeight [= height]

PieceBottomHeight プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。
height | ピース下部キャプション領域の高さを、文字列の行数を表す単位で 1 以上の整数を指定します。


PieceCaptionAdjustInView プロパティ

関連項目

ピース バーの中に配置したキャプションの表示を、できるだけピースペイン内に表示するかどうかを指定します。値の取得も可能です。

構文

object.PieceCaptionAdjustInView [= boolean]

PieceCaptionAdjustInView プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。
boolean | ピース バーの中に配置したキャプションの表示を、できるだけピースペイン内に表示するかどうかをブール式で指定します。設定する値については、次の「設定値」を参照してください。

設定値

boolean の設定値は次のとおりです。

設定値 | 内容
True | キャプションの文字列が見えるように、表示位置を所定の位置からピースペイン内に調節します。
False(既定値) | ピースペイン内に見えているかどうかに関係なく、所定の位置に表示します。

解説

PieceCaption オブジェクトの Position プロパティの値に 0 (ピースのバーの中) を指定しているピース　キャプションの表示について、できるだけピースペイン内に表示するかどうかを制御します。ピースの開始日時と終了日時が離れているために、ピースペイン内にピース　バーの一部しか見えず、そのためキャプションの表示位置もピースペインの外側となって見えなくなるときに、このプロパティの値を 真 (True) に設定すると、表示位置を所定の位置からピースペイン内に調節して、キャプションの文字列が見えるようにします。

真 (True) に設定した場合、横スクロール時はピースペイン全体を再描画するため、多少ちらつくことがあります。


PieceCaptionMaxWidth プロパティ

関連項目

ピース バーの外側に配置したキャプション文字列について、表示幅を指定します。値の取得も可能です。

構文

object.PieceCaptionMaxWidth [= width]

PieceCaptionMaxWidth プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。
width | ピース バーの外側に配置したキャプション文字列の表示幅を、ピクセル単位の数式で指定します。既定値は、400 ピクセルです。

解説

ピース バーの外側に配置したキャプション文字列を表示幅で折り返すかどうかは、PieceCaptionWordwrap プロパティで指定することができます。

ピース バーの外側とは、PieceCaption オブジェクトの Position プロパティに、0 (ピースのバーの中) 以外を指定した場合の配置です。

このプロパティの値は、ピース キャプションの描画速度に影響を与えます。2000 ピクセルにすると、既定値の 400 ピクセルのときより、約2倍以上描画に時間がかかります。反対に、既定値より小さくしても、速度の行動は、顕著には現れません。


PieceCaptionWordWrap プロパティ

関連項目 使用例

ピース バーの外側に配置したキャプション文字列の長さが表示幅を超える場合に、文字列を折り返すかどうかを設定します。値の取得も可能です。

構文

object.PieceCaptionWordWrap [= boolean]

PieceCaptionWordWrap プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。
boolean | ピース バーの外側に配置したキャプション文字列を折り返すかどうかをブール式で指定します。設定する値については、次の「設定値」を参照してください。

設定値

boolean の設定値は次のとおりです。

設定値 | 内容
True | ピース バーの外側に配置したキャプション文字列を、折り返して表示します。
False(既定値) | ピース バーの外側に配置したキャプション文字列を、折り返して表示しません。

解説

表示幅は、PieceCaptionMaxWidth プロパティで取得、設定することができます。

ピース バーの外側とは、PieceCaption オブジェクトの Position プロパティに、0 (ピースのバーの中) 以外を指定した場合の配置です。

キャプション文字列の折り返しは、半角英数の場合は単語単位で、全角の場合は文字単位で行われます。

キャリッジ リターンとラインフィードの組み合わせは、常にキャプション文字列を折り返します。


PieceCenterHeight プロパティ

関連項目

ピース バー領域の高さを設定します。値の取得も可能です。

構文

object.PieceCenterHeight [= height]

PieceCenterHeight プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。
height | ピース バー領域の高さを、文字列の行数を表す単位で 1 以上の整数を指定します。デフォルトの値は 1 です。


PieceFont プロパティ

関連項目

Font オブジェクトへの参照を返します。

構文

object.Font

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。

解説

すべてのピース周辺に表示するピース キャプション文字列の描画に使用する、 Font オブジェクトへの参照を返します。


PieceIndex プロパティ

関連項目

Pieces コレクション内の Piece オブジェクト を識別する、固有のインデックスを設定します。値の取得も可能です。

構文

object.PieceIndex [= index]

PieceIndex プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | HitTestResult オブジェクトへの参照を表すオブジェクト式です。
index | Pieces コレクション内の Piece オブジェクト を識別する、固有のインデックス。

解説

タイム ビュー コントロール の HitTest メソッドが、ピースへのヒットを検出したとき、 PieceIndex プロパティに、ヒットしたピースに対応する Piece オブジェクトを識別するインデックスを設定します。


PieceLayout プロパティ

関連項目

同一アイテムにあるピースどうしの時間が重複した場合の表示方法を設定します。値の取得も可能です。

構文

object.PieceLayout [= layout]

PieceLayout プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。
layout | 同一アイテムにあるピースどうしの時間が重複した場合の表示方法を整数で指定します。設定する値については、次の「設定値」を参照してください。

設定値

layout の設定値は次のとおりです。

定数名 | 内容
0 - tivPieceLayoutPlain (既定値) | ピースどうしの時間が重複している場合、そのまま重複した状態で表示します。重なり順は、Piece オブジェクトの Index プロパティの値が大きいピースが前面になります。
1 - tivPieceLayoutParallel | 並列表示します。ピースどうしの時間が重複している場合、ピースの表示が重ならないように、アイテムの高さを拡張して垂直方向にずらして表示します。

解説

同一アイテムにあるピースどうしの時間が重複したときに、表示が重ならないに並列表示するかどうかを設定します。並列表示におけるアイテム高の拡張は、拡張が必要なアイテムのみ行われます。


PiecePane プロパティ

関連項目

PiecePane オブジェクト、又は ItemPiecePane オブジェクトへの参照を返します。

構文

object.PiecePane

指定項目 | 内容
object | 「対象」一覧内のいずれかのオブジェクトを指すオブジェクト式です。

解説

対象が タイム ビュー コントロールの場合、PiecePane オブジェクトへの参照を返します。 PiecePane オブジェクト使って、ピース ペイン領域全体に表示する目盛り線の表示パターンを設定することができます。

対象が Item オブジェクトの場合、ItemPiecePane オブジェクトへの参照を返します。 ItemPiecePane オブジェクトを使って、アイテム毎のピース ペイン領域の背景の描画パターンや、特別時間帯の設定を行うことができます。


PiecePanePaddingTop プロパティ、PiecePanePaddingCenter プロパティ、PiecePanePaddingBottom プロパティ

関連項目

ピースとアイテム ピース ペインの間の垂直余白、またはピース並列表示時の垂直余白を設定します。値の取得も可能です。

構文

object.PiecePanePaddingTop [= pixel]

object.PiecePanePaddingCenter [= pixel]

object.PiecePanePaddingBottom [= pixel]

PiecePanePaddingTop プロパティ、PiecePanePaddingCenter プロパティ、PiecePanePaddingBottom プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。
pixel | ピースとアイテム ピース ペインの間の垂直余白、またはピース並列表示時の垂直余白を、ピクセル単位の数式で指定します。

解説

ピースとアイテム ピース ペイン、またはピース並列表示時におけるピース間の垂直方向の余白を設定します。アイテム ピース ペインとピースの間の隙間を大きくしたい、または小さくしたいときに活用できます。

PiecePanePaddingTop プロパティ、PiecePanePaddingCenter プロパティ、PiecePanePaddingBottom プロパティが適用される場所を下図に示します。

上下のピース キャプションがないとき

上部ピース キャプションがある時

下部ピース キャプションがあるとき

上下にピースキャプションがある時

ピースを並列表示しているとき


PiecePointHorScale プロパティ、PiecePointVerScale プロパティ

関連項目

ピース端点図形の拡大・縮小率を設定します。値の取得も可能です。

構文

object.PiecePointHorScale [= percent]

object.PiecePointVerScale [= percent]

PiecePointHorScale プロパティ、PiecePointVerScale プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。
percent | ピース端点図形の拡大・縮小率を示すパーセント値を整数で指定します。5～1000の範囲で設定可能です。デフォルトは共に 100 (%)です。

解説

StartShape プロパティ、および FinishShape プロパティが示すピース端点の図形について、高さ、または幅の拡大・縮小率をパーセントで指定します。デフォルトの100%の状態におけるピース端点の高さと幅は、PieceCenterHeight プロパティの値が示す文字の高さと、PieceCenterMarginTop プロパティ、および PieceCenterMarginBottom プロパティの値が示す余白を合計した値から求めています。

PiecePointHorScale プロパティ、および PiecePointVerScale プロパティの値は、タイムビュー コントロール全体のピースの前後の端点すべてに適用します。


Pieces プロパティ

関連項目

Piece コレクションへの参照を返します。

構文

object.Pieces

指定項目 | 内容
object | Item オブジェクトへの参照を表すオブジェクト式です。

解説

アイテムに対してピースの追加や削除を行うには、 Pieces プロパティから参照する Piece コレクションのメソッドを使って行います。


PieceSelectionColor プロパティ

関連項目

ピース選択ハンドルの色を設定します。値の取得も可能です。

構文

object.PieceSelectionColor [= color]

PieceSelectionColor プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。
color | ピース選択ハンドルの色を指定します。デフォルトは RGB(255, 255, 255) (白) です。

解説

ピース選択ハンドルとは、ピースをマウス クリックなどで選択状態にした場合に、ピース端点上に小さな矩形として表示されるものを示します。重複が禁止されたピースや特別時間帯 (Prohibited プロパティ参照) と重なっているピースにおける選択ハンドルの色は、LockedPieceSelectionColor プロパティにて設定します。


PieceSelectMode プロパティ

関連項目

マウス操作でピースを選択することができるかどうかを設定します。値の取得も可能です。

構文

object.PieceSelectMode [= mode]

PieceSelectMode プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。
mode | マウス操作でピースを選択することができるかどうかを示す値を整数で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 mode の設定値は次のとおりです。

定数名 | 内容
0 - tivSelectNone | 選択不可。マウス操作でピースを選択することはできません。
1 - tivSelectSingle | 択一選択。タイム ビュー コントロール内のピースのうち、１つだけ選択することができます。すでに選択中のピースがある状態で別のピースを選択すると、既存の選択は解除され、新しく選択されたピースが選択状態になります。
2 - tivSelectMultiple (既定値) | 複数選択。タイム ビュー コントロール内のピースのうち、複数のピースを同時に選択することができます。

解説

PieceSelectMode プロパティに 2 (複数選択) を設定し、すべての Pieces コレクションの SelectMode プロパティに 1 (択一選択) を設定すると、各行毎に択一選択が可能な状態にすることができます。


PieceTimeNotify プロパティ

関連項目

ピースの開始日時又は終了日時を知らせるイベントを出力するかどうかを設定します。値の取得も可能です。

構文

object.PieceTimeNotify [= boolean]

PieceTimeNotify プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。
boolean | ピースの開始日時又は終了日時を知らせるイベントを出力するかどうかをブール式で指定します。設定する値については、次の「設定値」を参照してください。

設定値

boolean の設定値は次のとおりです。

設定値 | 内容
True(既定値) | ピースの開始日時又は終了日時を知らせるイベントを出力します。
False | ピースの開始日時又は終了日時を知らせるイベントを出力しません。

解説

PieceTimeNotify プロパティの値が真 (True) のとき、 CurrentTime オブジェクトの Time プロパティが示す日時が、いずれかの Piece オブジェクトの Start プロパティ、又は Finish プロパティが示す日時を同じになった時に、 PieceStart イベント、又は PieceFinish イベントが出力されます。


PieceTopHeight プロパティ

関連項目

ピース上部キャプション領域の高さを設定します。値の取得も可能です。

構文

object.PieceTopHeight [= height]

PieceTopHeight プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。
height | ピース上部キャプション領域の高さを、文字列の行数を表す単位で 1 以上の整数を指定します。


PieceTopMarginTop プロパティ、PieceTopMarginBottom プロパティ、PieceCenterMarginTop プロパティ、PieceCenterMarginBottom プロパティ、PieceBottomMarginTop プロパティ、PieceBottomMarginBottom プロパティ

PieceTopMarginTop プロパティ、PieceTopMarginBottom プロパティ、

PieceCenterMarginTop プロパティ、PieceCenterMarginBottom プロパティ、

PieceBottomMarginTop プロパティ、PieceBottomMarginBottom プロパティ

関連項目

ピースとピース キャプション間の垂直余白を設定します。値の取得も可能です。

構文

object.PieceTopMarginTop [= pixel]

object.PieceTopMarginBottom [= pixel]

object.PieceCenterMarginTop [= pixel]

object.PieceCenterMarginBottom [= pixel]

object.PieceBottomMarginTop [= pixel]

object.PieceBottomMarginBottom [= pixel]

PieceTopMarginTop プロパティ、PieceTopMarginBottom プロパティ、PieceCenterMarginTop プロパティ、PieceCenterMarginBottom プロパティ、PieceBottomMarginTop プロパティ、PieceBottomMarginBottom プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。
pixel | ピースとピース キャプション間の垂直余白を、ピクセル単位の数式で指定します。

解説

PieceTopMarginTop プロパティ、PieceTopMarginBottom プロパティ、PieceCenterMarginTop プロパティ、PieceCenterMarginBottom プロパティ、PieceBottomMarginTop プロパティ、PieceBottomMarginBottom プロパティの適用場所を下図に示します。

上下のピース キャプションがないとき

上部ピース キャプションがある時

下部ピース キャプションがあるとき

上下にピースキャプションがある時

ピースを並列表示しているとき


PosBaseTime プロパティ

関連項目 使用例

吹き出しの位置のスタイルによる相対位置の基準日時を設定します。値の取得も可能です。

構文

object.PosBaseTime [= date]

PosBaseTime プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | Balloon オブジェクトへの参照を表すオブジェクト式です。
date | 吹き出しの位置のスタイルによる相対位置の基準日時を示す値を日付式で指定します。既定値値は、親ピースの開始日時です。

解説

PosStyle プロパティが、アイテムを基準にする (0 - tivBalloonPosStyleFromItem) の場合に、アイテムからの相対位置の基準点の X 座標は、 PosBaseTime プロパティで指定します (下図の赤線) 。

PosStyle プロパティが、ピースを基準にする (0 - tivBalloonPosStyleFromItem) で、 PosBaseTime プロパティが Null だった場合は、吹き出しは表示されません。


Position プロパティ (PieceCaption オブジェクト)

関連項目

ピース キャプションの表示位置を設定します。値の取得も可能です。

構文

object.Position [= position]

Position プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | PieceCaption オブジェクトへの参照を表すオブジェクト式です。
position | ピース キャプションの表示位置を示す値を整数で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 position の設定値は次のとおりです。

定数名 | 内容
0 - tivPieceCenter | ピースのバーの中 (既定値)
1 - tivPieceTop | ピースのバーの上
2 - tivPieceBottom | ピースのバーの下
3 - tivPieceLeft | ピースのバーの左
4 - tivPieceRight | ピースのバーの右

解説

PieceCaption オブジェクトには、ピース キャプションの位置を更に詳細に指定するプロパティとして、 HorAlign プロパティと VerAlign プロパティがあります。


Position プロパティ (PointShape オブジェクト)

関連項目

ピース端点と時間の位置関係を設定します。値の取得も可能です。

構文

object.Position [= position]

Position プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | PointShape オブジェクトへの参照を表すオブジェクト式です。
position | ピース端点と時間の位置関係を示す値を整数で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 position の設定値は次のとおりです。

定数名 | 内容
0 - tivPointPositionCenter | 形状の中心が時間と合う位置に表示します。 (既定値)
1 - tivPointPositionInset | 形状が時間の内側に接する位置に表示します。

解説

Position プロパティの値を 1 (形状が時間の内側に接する位置に表示) に設定する主な場面は、Shape プロパティの値を 9 (＜)、または 10 (＞) にして 三角の水平方向の頂点をピースの時間と合わせたいときです。


PosRelPoint プロパティ

関連項目 使用例

吹き出しの位置のスタイルによる相対位置を表す Point オブジェクトへの参照を返します。実行時のみ使用が可能です。

構文

object.PosRelPoint

PosRelPoint プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | Balloon オブジェクトへの参照を表すオブジェクト式です。

解説

アンカーからの相対位置の変更は、 PosRelPoint プロパティから参照する Point オブジェクトのプロパティを操作して行うことができます。

Point オブジェクトの X プロパティの初期値は 0 です。

Point オブジェクトの Y プロパティの初期値は「 - ( ピースの高さ + PiecePanePaddingTop プロパティ * 2 ) 」です。

アイテムからの相対位置の基準点は、 X 座標が PosBaseTime プロパティに指定されている基準日時、 Y 座標がアイテムの上の境界線です（下図の 0）。

ピースからの相対位置の基準点は、ピースの左上になります（下図の1）。

接続線と吹き出しの接続部は、接続線の先端の位置で決まります。

下図のように、接続線の先端のエリアが接している吹き出しの辺の中心部が、接続線と吹き出しの接続部となります。

下図において接続線の先端「 1 」は、エリア「 h 」にあるので、エリアが接している吹き出しの辺 (赤線の部分)の中心部が、接続線と吹き出しの接続部となっています。


PosStyle プロパティ

関連項目 使用例

吹き出しの位置のスタイルを設定します。値の取得も可能です。

構文

object.PosStyle [= value]

PosStyle プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | Balloon オブジェクトへの参照を表すオブジェクト式です。
value | 吹き出しの位置のスタイルを示す値を整数で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 value の設定値は次のとおりです。

定数名 | 内容
0 - tivBalloonPosStyleFromItem | アイテムを基準にする。
1 - tivBalloonPosStyleFromPiece(規定値) | ピースを基準にする。

解説

吹き出しの位置のスタイルは、吹き出しのボックス部の位置を決めるスタイルです。

アイテムを基準にする (0 - tivBalloonPosStyleFromItem） を指定すると、アイテムからの相対位置で配置されます。

相対位置の基準点は、 X 座標が PosBaseTime プロパティに指定されている基準日時、 Y 座標がアイテムの上の境界線です (下図の 0) 。

ピースを基準にする (1 - tivBalloonPosStyleFromPiece) を指定すると、ピースからの相対位置で配置されます。

相対位置の基準点は、ピースの左上になります（下図の1）。

相対位置は、 PosRelPoint プロパティで指定します。

アイテムを基準にした場合、ピースを移動しても吹き出しは移動しません。

ピースを基準にした場合、ピースを移動すると一緒に吹き出しも移動します。

どちらのスタイルも、スクロールした場合は一緒にスクロールされます。


Progresses プロパティ

関連項目

Progresses コレクションへの参照を返します。

構文

object.Progresses

指定項目 | 内容
object | Piece オブジェクトへの参照を表すオブジェクト式です。

解説

ピースの達成率の表す Progress オブジェクトのコレクションへの参照を返します。ピースに対して達成率を設定するには、始めに Progresses コレクションの Add メソッドを使って、 Progress オブジェクトを追加します。


Prohibited プロパティ

関連項目

対象のオブジェクトが位置する時間帯への他ピースの配置を禁止するかどうかを指定します。値の取得も可能です。

構文

object.Prohibited [= boolean]

Prohibited プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | 「対象」一覧内のいずれかのオブジェクトを指すオブジェクト式です。
boolean | 他ピースの配置を禁止するかどうかを示す値をブール式で指定します。設定する値については、次の「設定値」を参照してください。

設定値

boolean の設定値は次のとおりです。

設定値 | 内容
True | 他ピースの配置を禁止します。
False (既定値) | 他ピースの配置を禁止しません。

解説

他ピースの配置を禁止した場合、下記のマウス操作によるピース編集操作が制約されます。

  • マウス ポインタが禁止時間帯に位置する場合、ピース追加ドラッグ操作を禁止します。

  • 禁止時間帯と重なっているピースの移動、および時間変更操作を禁止します。

  • ピースの時間変更ドラッグが禁止時間帯を跨ぐのを禁止し、禁止時間帯の直前までに制約します。

  • ピース移動ドラッグについて、禁止時間帯と重なる位置へのドロップを禁止します。

すべてのピースについて時間の重複を禁止する場合、すべてのピースの Prohibited プロパティ の値を 真 (True) に設定します。

Prohibited プロパティによる制約はマウス操作に対してのみ有効です。コードにて直接 Piece オブジェクトの Start プロパティ、Finish プロパティ を設定した場合は適用されません。


RelatedLineIndex プロパティ

関連項目 使用例

RelatedLines コレクション内の RelatedLine オブジェクトを識別する、固有のインデックスを設定します。値の取得も可能です。

構文

object.RelatedLineIndex [= index]

RelatedLineIndex プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | HitTestResult オブジェクトへの参照を表すオブジェクト式です。
index | RelatedLines コレクション内の RelatedLine オブジェクトを識別する、固有のインデックス。

解説

タイム ビュー コントロールの HitTest メソッドが、関係線へのヒットを検出したとき、 RelatedLineIndex プロパティに、ヒットした関係線に対応する RelatedLine オブジェクトを識別するインデックスを設定します。


RelatedLines プロパティ

関連項目 使用例

RelatedLines コレクションへの参照を返します。実行時のみ使用できます。

構文

object.RelatedLines

RelatedLines プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | Piece オブジェクトへの参照を表すオブジェクト式です。

解説

RelatedLines コレクションは、関係線を表す RelatedLine オブジェクトのコレクションです。

ピースとピースの関係線を表示する場合は、 Piece オブジェクトの RelatedLines プロパティから参照する RelatedLines コレクションに RelatedLine オブジェクトを追加します。


Relation プロパティ

関連項目 使用例

接続先 Piece オブジェクトへの参照を取得します。実行時のみ使用が可能です。

構文

object.Relation

Relation プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | RelatedLine オブジェクトへの参照を表すオブジェクト式です。

解説

RelatedLine オブジェクトがピースと接続している場合は、 Relation プロパティで接続先 Piece オブジェクトへの参照を取得することができます。接続しているかは、 IsConnected メソッドでチェックすることができます。

ピースとの接続、接続解除は、 Connect メソッド、 Disconnect メソッドで行うことができます。

関係線は、ピースと接続している場合のみ表示されます。


RightBorder プロパティ

関連項目

「対象」一覧内のいずれかのオブジェクトの領域における、右辺境界線の描画属性を示す LineFormat オブジェクトを返します。

構文

object.RightBorder

指定項目 | 内容
object | 「対象」一覧内のいずれかのオブジェクトを指すオブジェクト式です。

解説

対象オブジェクトの右辺境界線について、表示の有無や線種、及び色を設定する時に使用します。


ScaleFitting プロパティ

関連項目

ピースのドラッグ時に、タイム スケールのいずれかの目盛りに自動的に合わせるかどうかを設定します。値の取得も可能です。

構文

object.ScaleFitting [= fitting]

ScaleFitting プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。
fitting | ピースのドラッグ時に、タイム スケールのいずれかの目盛りに自動的に合わせるかどうかを示す値を整数で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 mode の設定値は次のとおりです。

定数名 | 内容
0 - tivNotFit(既定値) | 合わせない。
1 - tivFitToMedium | 中区分の目盛りに合わせる。
2 - tivFitToSmall | 小区分の目盛りに合わせる。
3 - tivFitToSub | 補助目盛りに合わせる。

解説

ScaleFitting プロパティに 0 (合わせない) 以外を指定した場合でも、Alt キーを押している間は、目盛りへの吸着は行われず、自由にドラッグすることができます。

ScaleFitting プロパティの指定は、ピースの追加、ピースの移動、ピースの時間変更、ピースのラバー バンド選択、OLE ドラッグ アンド ドロップ操作といった、ピースに関する全てのドラッグ操作に適用されます。


Selected プロパティ (Piece オブジェクト)

関連項目

ピースの選択状態を設定します。値の取得も可能です。

構文

object.Selected [= boolean]

Selected プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | Piece オブジェクトへの参照を表すオブジェクト式です。
boolean | ピースの選択状態を示す値をブール式で指定します。設定する値については、次の「設定値」を参照してください。

設定値

boolean の設定値は次のとおりです。

設定値 | 内容
True | ピースを選択します。
False(既定値) | ピースの選択を解除します。

解説

Selected プロパティに真 (True) を設定した Piece オブジェクトは、タイム ビュー コントロールの SelectedPieces プロパティから参照する、 SelectedPieces コレクションに参照が追加されます。逆に Selected プロパティに偽 (False) を設定した Piece オブジェクトは、 SelectedPieces コレクションから参照が削除されます。


Shape プロパティ (ArrowShape オブジェクト)

Shpae プロパティ

関連項目 使用例

矢印の形状を設定します。値の取得も可能です。

構文

object.Shape [= value]

Shape プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | ArrowShape オブジェクトへの参照を表すオブジェクト式です。
value | 矢印の形状を示す値を整数で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 value の設定値は次のとおりです。

定数名 | 内容 | イメージ
0 - tivArrowShapeNull | なし。 |
1 - tivArrowShapeNormal(規定値) | 普通。 |
2 - tivArrowShapeTriangle | 三角形。 |
3 - tivArrowShapeCircle | 丸。 |

解説

Shpae プロパティを使うと、矢印の形状を変更することができます。

線の到達点に対する各矢印の形状の描画は、下図のように行われます。

形状 | イメージ
なし |
普通 |
三角形 |
丸 |

※赤点が到達点です。


Shape プロパティ (BalloonShape オブジェクト)

Shpae プロパティ

関連項目 使用例

吹き出しの形状を設定します。値の取得も可能です。

構文

object.Shape [= value]

Shape プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | BalloonShape オブジェクトへの参照を表すオブジェクト式です。
value | 吹き出し矢印の形状を示す値を整数で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 value の設定値は次のとおりです。

定数名 | 内容 | イメージ
0 - tivBalloonShapeNull | なし。 |
1 - tivBalloonShapeRect | 矩形。 |
2 - tivBalloonShapeRoundRect(既定値) | 角丸矩形。 |

解説

Shpae プロパティを使うと、吹き出しの形状を変更することができます。


SizeStyle プロパティ

関連項目 使用例

サイズの指定スタイルを設定します。値の取得も可能です。

構文

object.SizeStyle [= value]

SizeStyle プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | BalloonShape オブジェクトへの参照を表すオブジェクト式です。
value | サイズの指定スタイルを示す値を整数で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 value の設定値は次のとおりです。

定数名 | 内容
0 - tivBalShapeSizeStyleChar(規定値) | 文字数でサイズを指定。
1 - tivBalShapeSizeStyleContiner | コンテナ単位でサイズを指定。

解説

SizeStyle プロパティを使うと、 Width プロパティ、 Height プロパティの指定方法を変更することができます。

SizeStyle プロパティを変更すると、自動的に Width プロパティ、 Height プロパティの値が変換されます。


Selected プロパティ (Pieces コレクション)

関連項目

ピース コレクション内の全てのピースを対象に選択状態を設定します。

構文

object.Selected = boolean

Selected プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | Pieces コレクションへの参照を表すオブジェクト式です。
boolean | ピース コレクション内の全てのピースを対象にした選択状態を示す値をブール式で指定します。設定する値については、次の「設定値」を参照してください。

設定値

boolean の設定値は次のとおりです。

設定値 | 内容
True | ピース コレクション内の全てのピースを選択状態にします。
False | ピース コレクション内の全てのピースの選択状態を解除します。

解説

Selected プロパティに真 (True) を設定した Piece オブジェクトは、タイム ビュー コントロールの SelectedPieces プロパティから参照する、 SelectedPieces コレクションに参照が追加されます。逆に Selected プロパティに偽 (False) を設定した Piece オブジェクトは、 SelectedPieces コレクションから参照が削除されます。


SelectedPieces プロパティ

関連項目

SelectedPieces コレクションへの参照を返します。実行時のみ使用できます。

構文

object.SelectedPieces

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。

解説

SelectedPieces プロパティから参照する SelectedPieces コレクションには、現在選択状態の Piece オブジェクトへの参照がコレクションされています。


SelectMode プロパティ

関連項目

マウス操作でピースを選択することができるかどうかを設定します。値の取得も可能です。

構文

object.SelectMode [= mode]

SelectMode プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | Pieces コレクションへの参照を表すオブジェクト式です。
mode | マウス操作でピースを選択することができるかどうかを示す値を整数で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 mode の設定値は次のとおりです。

定数名 | 内容
0 - tivSelectNone | 選択不可。マウス操作でピースを選択することはできません。
1 - tivSelectSingle | 択一選択。 Pieces コレクション内のピースのうち、１つだけ選択することができます。 Pieces コレクション内に、すでに選択中のピースがある状態で別のピースを選択すると、既存の選択は解除され、新しく選択されたピースが選択状態になります。
2 - tivSelectMultiple(既定値) | 複数選択。 Pieces コレクション内のピースのうち、複数のピースを同時に選択することができます。

解説

Pieces コレクション毎のピースの選択モードを指定します。タイム ビュー コントロール全体のピースを対象に選択モードを設定する場合は、タイム ビュー コントロールの PieceSelectMode プロパティを操作して行います。


Shape プロパティ

関連項目

ピース バーの形状を設定します。値の取得も可能です。

構文

object.Shape [= shape]

Shape プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | BarShape オブジェクトへの参照を表すオブジェクト式です。
shape | ピース バーの形状を示す値を整数で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 shape の設定値は次のとおりです。

定数名 | 内容
0 - tivBarShapeLine | 線(中央)
1 - tivBarShapeRectangle(既定値) | 矩形
2 - tivBarShapeUpperLine | 線(上部)
3 - tivBarShapeLowerLine | 線(下部)
4 - tivBarShapeUpperRectangle | 矩形(上部)
5 - tivBarShapeCenterRectangle | 矩形(中央)
6 - tivBarShapeLowerRectangle | 矩形(下部)

解説

Piece オブジェクトの Finish プロパティの値が、設定されていないか Start プロパティと同じ値の場合、ピース バーは表示されません。


Shape プロパティ (PointShape オブジェクト)

関連項目

ピースの開始日時又は終了日時の形状を設定します。値の取得も可能です。

構文

object.Shape [= shape]

Shape プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | PointShape オブジェクトへの参照を表すオブジェクト式です。
shape | ピースの開始日時又は終了日時の形状を示す値を整数で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 shape の設定値は次のとおりです。

定数名 | 内容
0 - tivPointShapeNull | なし
1 - tivPointShapeCircle | ○
2 - tivPointShapeRectangle | □
3 - tivPointShapeDiamond | ◇
4 - tivPointShapeHomeBase | ホームペース型(下頂点)
5 - tivPointShapeHomeBaseReverse | ホームペース型(上頂点)
6 - tivPointShapeTriangleUp | △
7 - tivPointShapeTriangleDown | ▽
8 - tivPointShapeStar | ☆
9 - tivPointShapeTriangleLeft | ＜
10 - tivPointShapeTriangleRight | ＞
11 - tivPointShapeImage | Image メソッドにて指定した画像。

解説

Piece オブジェクトの Finish プロパティの値が、設定されていないか Start プロパティと同じ値の場合、終了日時の形状は表示されません。


SizeChangeMode プロパティ

関連項目 使用例

サイズの変更モードを設定します。値の取得も可能です。

構文

object.SizeChangeMode [= value]

SizeChangeMode プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | Balloon オブジェクトへの参照を表すオブジェクト式です。
value | サイズの変更モードを示す値を整数で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 value の設定値は次のとおりです。

定数名 | 内容 | イメージ
0 - tivSizeTracker | トラッカーハンドルを表示します。 |
1 - tivSizeEdge(規定値) | トラッカーハンドルは表示せず、吹き出しの縁でサイズ変更を行います。 |

解説

このプロパティに 0 (tivSizeTracker) が設定されている場合、トラッカハンドルが表示されます。

トラッカハンドルの表示方法は、TrackerHandles プロパティが保持する TrackerHandles コレクション,、TrackerHandle オブジェクトで変更することができます。

このプロパティに 1 (tivSizeEdge) が設定されている場合の「サイズ変更UI領域」の幅は、PiecePane オブジェクトの BalloonSizeUIWidth プロパティで変更することができます。


SlidingLetter プロパティ

関連項目

次の目盛りに押し出されるまで左端に目盛りを表示し続けるかどうかを指定します。値の取得も可能です。

構文

object.SlidingLetter [= boolean]

SlidingLetter プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | LetterScale オブジェクトへの参照を表すオブジェクト式です。
boolean | 次の目盛りに押し出されるまで左端に目盛りを表示し続けるかどうかをブール式で指定します。設定する値については、次の「設定値」を参照してください。

設定値

boolean の設定値は次のとおりです。

設定値 | 内容
True(既定値) | 次の目盛りに押し出されるまで左端に目盛りを表示し続けるようにします。
False | 次の目盛りに押し出されるまで左端に目盛りを表示し続けないようにします。


Small プロパティ

関連項目

LineScale オブジェクトへの参照を返します。

構文

object.Small

指定項目 | 内容
object | TimeScale オブジェクトへの参照を表すオブジェクト式です。

解説

Small プロパティは、小区分と補助目盛りの単位や間隔、表示スタイルを設定する時に使用します。


SpecialTimes プロパティ

関連項目

特別時間帯コレクションへの参照を返します。

構文

object.SpecialTimes

指定項目 | 内容
object | SpecialTimeSet オブジェクトへの参照を表すオブジェクト式です。

解説

特別時間帯の設定を行うには、まず SpecialTimeSet オブジェクトの SpecialTimes プロパティから参照する SpecialTimes コレクションの Add メソッドを使って、 新規に SpecialTime オブジェクトを追加します。この SpecialTime オブジェクトのプロパティに対して特別時間帯の設定を行います。 SpecialTimeSet オブジェクトは、 タイム ビュー コントロールの SpecialTimeSets プロパティから参照する SpecialTimeSets コレクションの Add メソッドを使って作成します。


SpecialTimeSet プロパティ

関連項目 使用例

特別時間帯セット オブジェクトへの参照を指定します。値の取得も可能です。

構文

object.SpecialTimeSet [= specialtimeset]

SpecialTimeSet プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | 「対象」一覧内のいずれかのオブジェクトを指すオブジェクト式です。
specialtimeset | SpecialTimeSet オブジェクトへの参照を設定します。デフォルトでは、何も設定されていません。

解説

対象が PiecePane オブジェクトの場合、ピース ペイン全体に対して使用する、特別時間帯セット オブジェクトへの参照を表します。ピース ペイン全体に対して特別時間帯を設定する場合は、 PiecePane オブジェクトの SpecialTimeSet プロパティに対して設定します。

対象が ItemPiecePane オブジェクトの場合、アイテムのピース ペインに対して使用する、特別時間帯セット オブジェクトへの参照を表します。特定のアイテムのピース ペインに対してのみ特別時間帯を設定する場合は、 ItemPiecePane オブジェクトの SpecialTimeSet プロパティに対して設定します。

アイテム ピース ペインの特別時間帯の表示と、ピース ペイン全体の特別時間帯の表示が重なる場合は、アイテム ピース ペインの表示の方が上書きします。


SpecialTimeSets プロパティ

関連項目

特別時間帯セット コレクションへの参照を返します。実行時の使用できます。

構文

object.SpecialTimeSets

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。

解説

ピース ペイン、又はアイテム ピース ペインに対して特別時間帯を設定するには、始めにタイム ビュー コントロールの SpecialTimeSets プロパティから参照する SpecialTimeSets コレクションの Add メソッドを使って、 SpecialTimeSet オブジェクトを生成します。今度は生成した SpecialTimeSet オブジェクトの SpecialTimes プロパティから参照する SpecialTimes コレクションの Add メソッドを使って SpecialTime オブジェクトを生成します。そして生成した SpecialTime オブジェクトのプロパティを使って１つの特別時間帯の設定をします。最後に SpecialTimeSet オブジェクトへの参照を、タイム ビュー コントロールの PiecePane プロパティから参照する PiecePane オブジェクトの SpecialTimeSet プロパティ、又は Item オブジェクトの PiecePane プロパティから参照する ItemPiecePane オブジェクトの SpecialTimeSet プロパティに設定します。


Start プロパティ, Finish プロパティ (Piece オブジェクト)

関連項目

ピースの開始日時、又は終了日時を設定します。値の取得も可能です。

構文

object.Start [= date]

object.Finish [= date]

Start プロパティ、 Finish プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | Piece オブジェクトへの参照を表すオブジェクト式です。
date | ピースの開始日時又は終了日時を示す値を日付式で指定します。デフォルト値は Null です。

解説

Finish プロパティの値は、 Start プロパティの値以上でなければいけません。

開始日時から終了日時までの期間ではなく、開始日時のみの場合は、Start プロパティのみ設定します。 Finish プロパティは値を設定しないか、又は Null を設定します。開始日時のみの場合、ピース バーは表示されません。


Start プロパティ, Finish プロパティ (SpecialTime オブジェクト)

関連項目

特別時間帯の開始時分、又は終了時分を設定します。値の取得も可能です。

構文

object.Start [= date]

object.Finish [= date]

Start プロパティ、 Finish プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | SpecialTime オブジェクトへの参照を表すオブジェクト式です。
date | 特別時間帯の開始時分、又は終了時分を示す値を日付式で指定します。

解説

特別時間帯とする時間の範囲を指定します。例えば、12:00から13:00までの昼休み時間を表すならば、Start プロパティに "12:30" を指定し、Finish プロパティに "13:00" を指定します。

タイム ビュー コントロールの Misc プロパティに、8 (tivMiscSpecialTimeNewMode) の設定がある場合とない場合で、 Finish プロパティの解釈が変わります。

8 (tivMiscSpecialTimeNewMode) の設定がある場合　：

Finish プロパティの値が、 Start プロパティの値と同じか過去の場合、 Finish プロパティに 24 時間足した時間を実際の Finish プロパティの示す時間と解釈します。（例　Startが20:00、Finishが2:00の場合、夜の８時から次の日の午前２時までの６時間と解釈します）

8 (tivMiscSpecialTimeNewMode) の設定がない場合　：

Start プロパティの値は、 Finish プロパティの値以上でなければいけません。ただし、Finish プロパティに 0時 0分を指定すると、24時の指定と解釈します。（例　Startが20:00、Finishが0:00の場合、夜の８時から次の日の午前０時までの４時間と解釈します）


StartEdit メソッド

関連項目 使用例

吹き出しの編集を開始します。値の取得も可能です。

構文

object.StartCellEdit

指定項目 | 内容
object | Balloon オブジェクトへの参照を表すオブジェクト式です。

解説

このメソッドをコールすると、吹き出しのエディットボックスがアクティブ化され、Caption プロパティが保持している Caption オブジェクトの Text プロパティの値を直接編集することができるようになります。

EditMode プロパティに 1 (自動) が設定されている場合は、吹き出しをダブルクリックすることでへ週を自動的に開始することができます。


StartColumn プロパティ、 FinishColumn プロパティ

関連項目

出力する列の開始インデックスと終了インデックスを設定します。値の取得も可能です。

構文

object.StartColumn [= index]

object.FinishColumn [= index]

StartColumn プロパティ、FinishColumn プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | 「対象」一覧内のいずれかのオブジェクトを指すオブジェクト式です。
index | ColumnHeaders コレクション内の ColumnHeader オブジェクトを識別する、固有のインデックス。デフォルトの値は StartColumn プロパティ、 FinishColumn プロパティともに -1 です。StartColumn プロパティが -1 の場合、先頭列から出力します。FinishColumn プロパティが -1 の場合、最終列まで出力します。

解説

列の出力をしない場合は、StartColumn プロパティの値に 0 を設定します。

FinishColumn プロパティには、StartColumn プロパティの値以上の値を指定してください。


StartIndex プロパティ、 FinishIndex プロパティ

関連項目

出力する行の開始インデックスと終了インデックスを設定します。値の取得も可能です。

構文

object.StartIndex [= index]

object.FinishIndex [= index]

StartIndex プロパティ、FinishIndex プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | 「対象」一覧内のいずれかのオブジェクトを指すオブジェクト式です。
index | Items コレクション内の Item オブジェクト を識別する、固有のインデックス。デフォルトの値は 0 です。

解説

開始インデックスの値が 0 の場合は、先頭行から印刷します。

終了インデックスの値が 0 の場合は、最終行まで印刷します。

終了インデックスは開始インデックス以上の値を指定してください。


StartRelPoint プロパティ、 FinishRelPoint プロパティ

関連項目 使用例

先端、終端アンカーからの相対位置を表す Point オブジェクトへの参照を返します。実行時のみ使用が可能です。

構文

object.StartRelPoint

object.FinishRelPoint

Shape プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | RelatedLine オブジェクトへの参照を表すオブジェクト式です。

解説

先端、終端アンカーからの相対位置の変更は、 StartRelPoint プロパティ、 FinishRelPoint プロパティから参照する Point オブジェクトのプロパティを操作して行うことができます。

Point オブジェクトの X プロパティ、 Y プロパティの初期値はどちらも 0 です。

先端、終端アンカーからの相対位置を変更すると、下図のようにピースと関係線を離すことができます。

StartRelPoint プロパティの内容 | イメージ
X：0 Y：0 |
X：10 Y：0 |
X：10 Y：20 |
X：-10 Y：20 |

※赤点が先端アンカー、青点が終端アンカーです。


StartShape プロパティ、 FinishShape プロパティ (RelatedLine オブジェクト)

StartShape プロパティ、 FinishShape プロパティ

関連項目 使用例

先端、終端の矢印の形状を表す ArrowShape オブジェクトへの参照を返します。実行時のみ使用が可能です。

構文

object.Shape [= value]

Shape プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | RelatedLine オブジェクトへの参照を表すオブジェクト式です。

解説

先端、終端の矢印の形状やカラーの変更は、 StartShape プロパティ、 FinishShape プロパティから参照する ArrowShape オブジェクトのプロパティを操作して行うことができます。

FinishShape プロパティから参照する ArrowShape オブジェクトの Shape プロパティの初期値は、普通 (1 - tivArrowShapeNormal) ではなく、なし (0 - tivArrowShapeNull) です。


StartShape プロパティ、 FinishShape プロパティ (Piece オブジェクト)

StartShape プロパティ、 FinishShape プロパティ

関連項目

PointShape オブジェクトへの参照を返します。

構文

object.StartShape

object.FinishShape

指定項目 | 内容
object | Piece オブジェクトへの参照を表すオブジェクト式です。

解説

ピースの開始日時又は終了日時の形状を表すオブジェクトへの参照を返します。ピースの端点の形状や色などを指定する時に使用します。


StartTime プロパティ、 FinishTime プロパティ

StartTime プロパティ, FinishTime プロパティ

関連項目

出力する時間範囲の開始日時と終了日時を設定します。値の取得も可能です。

構文

object.StartTime [= date]

object.FinishTime [= date]

StartTime プロパティ、 FinishTime プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | 「対象」一覧内のいずれかのオブジェクトを指すオブジェクト式です。
date | 出力する時間範囲の開始日時又は終了日時を日付式で指定します。デフォルトの値は Empty 。

解説

開始日時の値が Empty の場合は、開始日時の一番古いピースの Start プロパティの示す日時から出力します。タイム ビューに１つもピースが設定されていない場合は、現在の画面に表示している左端の日時から出力します。

終了日時の値が Empty の場合は、終了日時の一番新しいピースの Finish プロパティの示す日時まで出力します。タイム ビューに１つもピースが設定されていない場合は、現在の画面に表示している右端の日時まで出力します。


Style プロパティ (LineFormat オブジェクト)

Style プロパティ

関連項目

線のスタイルを設定します。値の取得も可能です。

構文

object.Style [= style]

Style プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | LineFormat オブジェクトへの参照を表すオブジェクト式です。
style | 線のスタイルを示す値を整数で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 style の設定値は次のとおりです。

定数名 | 内容
0 - tivLineNull | 線なし
1 - tivLineSolid | 実線
2 - tivLineDot | 短い破線
3 - tivLineDash | 長い破線
4 - tivLineDashDot | 1点鎖線
5 - tivLineDashDotDot | 2点鎖線


Style プロパティ (RelatedLine オブジェクト)

Style プロパティ

関連項目 使用例

関係線のスタイルを設定します。値の取得も可能です。

構文

object.Style [= value]

Style プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | RelatedLine オブジェクトへの参照を表すオブジェクト式です。
value | 関係線のスタイルを示す値を整数で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 value の設定値は次のとおりです。

定数名 | 内容 | イメージ
0 - tivRelLineStyleBreakFirst(既定値) | 先に折れる。 |
1 - tivRelLineStyleBreakLater | 後で折れる。 |
2 - tivRelLineStyleDiagonal | 斜め。 |

解説

関係線の各スタイルの基本パターンは、下表のとおりです。

「先に折れる」の基本パターン

 | 前ピースの位置が上 | ピースの位置が同じ高さ | 前ピースの位置が下
通常 |  |  |
開始点と終了点が同じ |  |  |
開始点が終了点より前 |  |  |

「後で折れる」の基本パターン

 | 前ピースの位置が上 | ピースの位置が同じ高さ | 前ピースの位置が下
通常 |  |  |
開始点と終了点が同じ |  |  |
開始点が終了点より前 |  |  |

「斜め」の基本パターン

 | 前ピースの位置が上 | ピースの位置が同じ高さ | 前ピースの位置が下
通常 |  |  |
開始点と終了点が同じ |  |  |
開始点が終了点より前 |  |  |


SubInterval プロパティ

関連項目

補助目盛りの間隔を設定します。値の取得も可能です。

構文

object.SubInterval [= interval]

SubInterval プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | LineScale オブジェクトへの参照を表すオブジェクト式です。
interval | 補助目盛りの間隔を示す値を整数で指定します。設定する値については、次の「設定値」を参照してください。

解説

補助目盛りは、小区分の領域に表示される短い目盛り線です。 SubInterval プロパティは、この補助目盛りの間隔を表します。補助目盛りは、 LineScale オブジェクトの SubUnit プロパティで指定した単位で、 SubInterval プロパティに指定した間隔毎に表示されます。 SubUnit プロパティの値が 4 (分単位)で SubInterval プロパティの値が 20 の場合は、 20 分おきに目盛りが表示されます。


SubUnit プロパティ

関連項目

補助目盛りの単位を設定します。値の取得も可能です。

構文

object.SubUnit [= unit]

SubUnit プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | LineScale オブジェクトへの参照を表すオブジェクト式です。
unit | 補助目盛りの単位を示す値を整数で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 unit の設定値は次のとおりです。

定数名 | 内容
0 - tivScaleUnitYear | 年単位。
1 - tivScaleUnitMonth | 月単位。
2 - tivScaleUnitDay | 日単位。
3 - tivScaleUnitHour | 時単位。
4 - tivScaleUnitMinute | 分単位。
5 - tivScaleUnitWeek | 週単位。

解説

補助目盛りは、小区分の領域に表示される短い目盛り線です。 SubUnit プロパティは、この補助目盛りの単位を表します。 SubInterval プロパティと組み合わせて使用します。


Tag プロパティ

関連項目

プログラムから参照するためのデータを格納する文字列式を指定します。値の取得も可能です。ほかのプロパティと異なり、特定の用途によっては Tag プロパティの値は タイムビュー コントロール によって使われることはありません。Tag プロパティは、オブジェクトの識別子として利用できます。

構文

object.Tag [= expression]

Tag プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | 「対象」一覧内のいずれかのオブジェクトを表すオブジェクト式です。
expression | オブジェクトを識別する文字列式を指定します。既定値は、長さ 0 の文字列 ("") です。

解説

Tag プロパティを使うと、ほかのプロパティや動作には影響を与えず、オブジェクトを判別するための文字列を割り当てることができます。


Target プロパティ

関連項目

特別時間帯の適用する日付や曜日を設定します。値の取得も可能です。

構文

object.Target [= target]

Target プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | SpecialTime オブジェクトへの参照を表すオブジェクト式です。
target | 特別時間帯の適用する日付や曜日を設定します。日付を設定する場合は、日付型か文字列型で設定してください。曜日を設定する場合は、次の「設定値」を参照してください。

設定値

引数 target の設定値は次のとおりです。

定数名 | 内容
0 - tivSunday | 日曜日
1 - tivMonday | 月曜日
2 - tivTuesday | 火曜日
3 - tivWednesday | 水曜日
4 - tivThursday | 木曜日
5 - tivFriday | 金曜日
6 - tivSaturday | 土曜日

解説

Target プロパティは、 Pattern プロパティと組み合わせて使用します。以下に Pattern プロパティと Target プロパティの関係を示します。

Patternプロパティの値 | Targetプロパティの値
0 - (毎日) | Target プロパティの設定は不要です。
1 - (毎週) | Target プロパティに対して、特別時間帯を適用する曜日を設定します。
2 - (指定日) | Target プロパティに対して、特別時間帯を適用する日付を設定します。


Text プロパティ

関連項目

表示する文字列を設定します。値の取得も可能です。

構文

object.Text [= string]

Text プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | 「対象」一覧内のいずれかのオブジェクトを指すオブジェクト式です。
string | 表示する文字列を文字列式で指定します。改行コードを埋め込む場合は、CR と LF の両方を指定します。


Text プロパティ (PieceCaption オブジェクト)

関連項目

ピース キャプションに表示する文字列を設定します。値の取得も可能です。

構文

object.Text [= string]

Text プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | PieceCaption オブジェクトを指すオブジェクト式です。
string | ピース キャプションに表示する文字列を文字列式で指定します。

解説

ピース キャプションに任意の文字列を表示したい時に使用します。

ピース キャプションに Text プロパティの値を表示するには、 PieceCaption オブジェクトの Type プロパティに 0 (Text プロパティの値) を指定してください。


Time プロパティ (CurrentTime オブジェクト)

関連項目

現在日時線を表示する位置を示す日時を設定します。値の取得も可能です。

構文

object.Time [= date]

Time プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | CurrentTime オブジェクトへの参照を表すオブジェクト式です。
date | 現在日時線を表示する位置を示す日時を日付式で指定します。

解説

Time プロパティへの値の設定は、 CurrentTime オブジェクトの UpdateMode プロパティの値が 1 (手動) のときに行います。 UpdateMode プロパティの値が 0 (自動) の場合、 Time プロパティの値はシステム時間の進行に合わせて定期的に更新され、又同時に表示位置も更新されます。

タイム ビュー コントロールの PieceTimeNotify プロパティの値が真 (True) のとき、 Time プロパティが示す日時が、いずれかの Piece オブジェクトの Start プロパティ、又は Finish プロパティが示す日時を同じになった時に、 PieceStart イベント、又は PieceFinish イベントが出力されます。


Time プロパティ (HitTestResult オブジェクト)

関連項目

ヒットした日時を表します。

構文

object.Time

指定項目 | 内容
object | HitTestResult オブジェクトへの参照を表すオブジェクト式です。

解説

タイム ビュー コントロールの HitTest メソッドが、タイム スケール又はピース ペイン、ピースへのヒットを検出したとき、 Time プロパティにヒットした日時を返します。


TimeScale プロパティ

関連項目

TimeScale オブジェクトへの参照を返します。

構文

object.TimeScale

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。

解説

タイム ビュー コントロール内の上部に表示するタイム スケールを表す TimeScale オブジェクトへの参照を返します。 TimeScale オブジェクトのプロパティを使って、タイム スケールに関するさまざまな設定を行うことができます。


Title プロパティ

関連項目

印刷プレビュー ウィンドウのタイトル、および印刷中ダイアログのタイトルに表示する文字列を設定します。値の取得も可能です

構文

object.Title

指定項目 | 内容
object | PrintInfo オブジェクトへの参照を表すオブジェクト式です。

解説

既定値は「ﾀｲﾑ ﾋﾞｭｰ ｺﾝﾄﾛｰﾙ」です。Title プロパティに「チャート１」という文字列を設定した場合、各ウィンドウのタイトルは次のように表示されます。

ウィンドウ | ウィンドウ タイトル
印刷プレビュー ウィンドウ | チャート１ 印刷ﾌﾟﾚﾋﾞｭｰ
印刷中ダイアログ | チャート１ 印刷中


TrackerHandles プロパティ (Balloonオブジェクト)

関連項目 使用例

TrackerHandles コレクションへの参照を返します。実行時のみ使用できます。

構文

object.TrackerHandles

TrackerHandles プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | Balloon オブジェクトへの参照を表すオブジェクト式です。

解説

TrackerHandles コレクションは、トラッカハンドルを表す TrackerHandle オブジェクトのコレクションです。

吹き出しのトラッカは、下図の 9 つです。

コレクションの要素のインデックスには、下表の定数を利用できます。

定数名 | 内容
0 - tivBalloonTHTopLeft | 左上サイズ変更トラッカハンドル。
1 - tivBalloonTHTop | 上サイズ変更トラッカハンドル。
2 - tivBalloonTHTopRight | 右上サイズ変更トラッカハンドル。
3 - tivBalloonTHRight | 右サイズ変更トラッカハンドル。
4 - tivBalloonTHBottomRight | 右下サイズ変更トラッカハンドル。
5 - tivBalloonTHBottom | 下サイズ変更トラッカハンドル。
6 - tivBalloonTHBottomLeft | 左下サイズ変更トラッカハンドル。
7 - tivBalloonTHLeft | 左サイズ変更トラッカハンドル。
8 - tivBalloonTHAnchorRel | アンカー相対位置変更トラッカハンドル。


Type プロパティ (PieceCaption オブジェクト)

Type プロパティ

関連項目

ピース キャプションに表示する情報の種類を設定します。値の取得も可能です。

構文

object.Type [= type]

Type プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | PieceCaption オブジェクトへの参照を表すオブジェクト式です。
type | ピース キャプションに表示する情報の種類を示す値を整数で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 type の設定値は次のとおりです。

定数名 | 内容
0 - tivPieceCaptionText | PieceCaption オブジェクトの Text プロパティ の値
1 - tivPieceCaptionStart | Piece オブジェクトの Start プロパティの値
2 - tivPieceCaptionFinish | Piece オブジェクトの Finish プロパティの値
3 - tivPieceCaptionProgress1From | Progresses コレクションのインデックス番号が１で識別される Progress オブジェクトの PercentFrom プロパティの値
4 - tivPieceCaptionProgress1To | Progresses コレクションのインデックス番号が１で識別される Progress オブジェクトの PercentTo プロパティの値
5 - tivPieceCaptionProgress1FromTo | Progresses コレクションのインデックス番号が１で識別される Progress オブジェクトの PercentFrom プロパティと PercentTo プロパティの値 （例： 10%-50%）
6 - tivPieceCaptionProgress2From | Progresses コレクションのインデックス番号が2で識別される Progress オブジェクトの PercentFrom プロパティの値
7 - tivPieceCaptionProgress2To | Progresses コレクションのインデックス番号が2で識別される Progress オブジェクトの PercentTo プロパティの値
8 - tivPieceCaptionProgress2FromTo | Progresses コレクションのインデックス番号が2で識別される Progress オブジェクトの PercentFrom プロパティと PercentTo プロパティの値 （例： 10%-50%）
9 - tivPieceCaptionProgress3From | Progresses コレクションのインデックス番号が3で識別される Progress オブジェクトの PercentFrom プロパティの値
10 - tivPieceCaptionProgress3To | Progresses コレクションのインデックス番号が3で識別される Progress オブジェクトの PercentTo プロパティの値
11 - tivPieceCaptionProgress3FromTo | Progresses コレクションのインデックス番号が3で識別される Progress オブジェクトの PercentFrom プロパティと PercentTo プロパティの値 （例： 10%-50%）
12- tivPieceCaptionKey | Piece オブジェクトの Key プロパティの値

解説

Pieces コレクションの Format プロパティを使って、Piece オブジェクトの Start プロパティ、又は Finish プロパティの表示に使用する表示書式を指定することができます。


Unit プロパティ

関連項目

大区分、中区分、小区分の目盛りの単位を設定します。値の取得も可能です。

構文

object.Unit [= unit]

Unit プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | 「対象」一覧内のいずれかのオブジェクトを表すオブジェクト式です。
unit | 大区分又は中区分の目盛りの単位を示す値を整数で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 unit の設定値は次のとおりです。

定数名 | 内容
0 - tivScaleUnitYear | 年単位。
1 - tivScaleUnitMonth | 月単位。
2 - tivScaleUnitDay | 日単位。
3 - tivScaleUnitHour | 時単位。
4 - tivScaleUnitMinute | 分単位。
5 - tivScaleUnitWeek | 週単位。

解説

LetterScale オブジェクトの場合、大区分、又は中区分の目盛りの単位を表します。

LineScale オブジェクトの場合、小区分の目盛りの単位を表します。

指定する単位は、上位の区分に指定する単位と同じか、より小さい単位にする必要があります。

Unit プロパティは、 Interval プロパティと組み合わせて使用します。


UpdateMode プロパティ

関連項目

CurrentTime オブジェクトの Time プロパティの値を自動的に更新するかどうかを設定します。値の取得も可能です。

構文

object.UpdateMode [= mode]

UpdateMode プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | CurrentTime オブジェクトへの参照を表すオブジェクト式です。
mode | CurrentTime オブジェクトの Time プロパティの値を自動的に更新するかどうかを示す値を整数で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 mode の設定値は次のとおりです。

定数名 | 内容
0 - tivManual | 手動。 Time プロパティの変更を自動で行いません。 現在日時線の表示位置は、プログラマが Time プロパティに値を直接設定して操作します。
1 - tivAutomatic (既定値) | 自動。 Time プロパティの変更をシステムの時刻を定期的に調べて自動で行います。

解説

CurrentTime オブジェクトの Hidden プロパティの値が真 (True) の場合、 UpdateMode プロパティの値が 1 (自動) で CurrentTime オブジェクトの Time プロパティが更新されても、現在日時線は常に非表示です。


Value プロパティ

関連項目

任意のバリアント値を設定します。値の取得も可能です。

構文

object.Value [= value]

Value プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | 「対象」一覧内のいずれかのオブジェクトを表すオブジェクト式です。
value | 任意のバリアント値を指定します。

解説

プログラムから参照するための任意のバリアント型 (Variant) データを格納します。ほかのプロパティと異なり、 タイムビュー コントロール によって使われることはありません。Value プロパティは、プログラムの任意の情報を格納する場所として利用できます。


Value プロパティ (Cell オブジェクト)

Value プロパティ

関連項目

セルに表示する任意のバリアント値を設定します。値の取得も可能です。

構文

object.Value [= value]

Value プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | Cell オブジェクトを指すオブジェクト式です。
value | セルに表示する任意のバリアント値を指定します。改行コードを含む文字列を設定する場合、改行コードは CR と LF の組み合わせで指定します。

解説

セルには任意のバリアント値を設定できますが、文字列以外の場合は文字列に変換して表示します。セル データの表示書式及び入力書式はサポートしていません。


VerAlign プロパティ

関連項目

オブジェクトの表示領域内におけるテキストの縦方向の配置を設定します。値の取得も可能です。

構文

object.VerAlign [= align]

VerAlign プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | 「対象」一覧内のいずれかのオブジェクトを指すオブジェクト式です。
align | テキストの縦方向の配置を示す値を整数で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 align の設定値は次のとおりです。

定数名 | 内容
0 - tivTextVerAlignTop | 上詰め
1 - tivTextVerAlignCenter | 中央揃え
2 - tivTextVerAlignBottom | 下詰め


ViewTopItem プロパティ

関連項目

表示上の先頭行を設定します。値の取得も可能です。

構文

object.ViewTopItem [= itemindex]

ViewTopItem プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。
itemindex | 表示上の先頭行を示す値を 1 から始まる整数で指定します。

解説

指定の行が先頭になるように表示をスクロールします。


ViewTopTime プロパティ

関連項目

画面に見える左端の日時を設定します。値の取得も可能です。

構文

object.ViewTopTime [= date]

ViewTopTime プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールへの参照を表すオブジェクト式です。
date | 画面に見える左端の日時を日付式で指定します。

解説

ViewTopTime プロパティに設定した値は、 中区分の目盛りのうち、一番近いの目盛りの示す日時に補正されます。


Width プロパティ (ColumnHeader オブジェクト)

関連項目

列見出しの幅を設定します。値の取得も可能です。

構文

object.Width [= width]

Width プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | ColumnHeader オブジェクトへの参照を表すオブジェクト式です。
width | 列見出しの幅をコンテナ単位で指定します。

解説

列見出しの幅はカラムヘッダー毎に設定できます。Width プロパティは、ColumnWidthMode プロパティの値が１(自動)の時は使用されません。

タイム ビュー コントロールの AllowColumnWidthChange プロパティが真(True)のときは、マウス操作で列見出しの幅を変更することができます。


Width プロパティ、Height プロパティ (BalloonShape オブジェクト)

Width プロパティ、 Height プロパティ

関連項目 使用例

吹き出しの幅、高さを設定します。値の取得も可能です。

構文

object.Width [= value]

object.Height [= value]

Width プロパティ、 Height プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | BalloonShape オブジェクトへの参照を表すオブジェクト式です。
value | 吹き出しの幅、高さを SizeStyle プロパティに設定されている方法で指定します。設定する値については、次の「設定値」を参照してください。吹き出しの幅の既定値は、 4 文字です。吹き出しの高さの既定値、 8 文字です。

解説

「吹き出しの幅、高さ」は、 SizeStyle プロパティの内容により指定する範囲が下表のように異なります。

プロパティの内容 | イメージ
SizeStyle ： 文字数でサイズを指定 Shape ： 矩形、なし マージンは含みません。 |
SizeStyle ： 文字数でサイズを指定 Shape ： 角丸矩形 マージンと描画有効範囲は含みません。 |
SizeStyle ： コンテナ単位でサイズを指定 Shape ： 矩形、なし 常に外周が対象になります。 |
SizeStyle ： コンテナ単位でサイズを指定 Shape ： 角丸矩形 常に外周が対象になります。 |


WidthPerScale プロパティ

関連項目

タイム スケールの中区分の1目盛りの幅を設定します。値の取得も可能です。

構文

object.WidthPerScale [= width]

WidthPerScale プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | TimeScale オブジェクトへの参照を表すオブジェクト式です。
width | タイム スケールの中区分の1目盛りの幅をコンテナ単位で指定します。

解説

WidthPerScale プロパティは、中区分の1目盛りの幅を表します。大区分、小区分の目盛りは、中区分の目盛り幅に合わせて表示されます。

WidthPerScale プロパティは、 WindowFit プロパティの値が 0 (ウィンドウ合せなし) の時にのみ使用します。

WindowFit プロパティの値が 0 (ウィンドウ合せなし) で、且つタイム ビュー コントロールの AllowWidthPerScaleChange プロパティが真(True)のとき、マウスを使ってタイム スケールの 1目盛りの幅を変更することができます。


WindowFit プロパティ

関連項目

特定の時間範囲全体を 1画面に見えるようにするかどうかを設定します。値の取得も可能です。

構文

object.WindowFit [= windowfit]

WindowFit プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | TimeScale オブジェクトへの参照を表すオブジェクト式です。
windowfit | 特定の時間範囲全体を 1画面に見えるようにするかどうかを整数で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 windowfit の設定値は次のとおりです。

定数名 | 内容
0 - tivWindowFitNone (既定値) | ウィンドウ合せなし。タイム ビュー コントロールの ViewTopTime プロパティの示す日時を画面の左端に配置して、 TimeScale オブジェクトの WidthPerScale プロパティの示す値分の表示間隔毎に目盛りを表示します。横スクロールできます。
1 - tivWindowFitLargeScale | 大区分の目盛りに合わせます。大区分の目盛りのうち、タイム ビュー コントロールの ViewTopTime プロパティの示す日時に一番近い目盛りの示す日時を画面の左端に配置し、 WindowFitNumScales プロパティが示す数分の目盛りを１画面に表示します。横スクロールできません。


WindowFitNumScales プロパティ

関連項目

１画面に目盛りを合わせる場合の目盛り数を設定します。値の取得も可能です。

構文

object.WindowFitNumScales [= numscales]

WindowFitNumScales プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | TimeScale オブジェクトへの参照を表すオブジェクト式です。
numscales | １画面に目盛りを合わせる場合の目盛り数として、1以上の整数を指定します。

解説

WindowFitNumScales プロパティは、 WindowFit プロパティの値が 0 (ウィンドウ合せなし) 以外の時に使用します。


WordWrap プロパティ

関連項目 使用例

単語による行の分割をおこなうかを設定します。値の取得も可能です。

構文

object.WordWrap [= balloon]

WordWrap プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | Caption オブジェクトを指すオブジェクト式です。
balloon | 対象オブジェクトを表示するかどうかを示す、ブール式を指定します。

設定値

引数 value の設定値は次のとおりです。

定数名 | 内容
True(既定値) | 単語による行の分割をおこないます。
False | 単語による行の分割をおこないません。

解説

Text プロパティの内容が、表示する矩形の端を越えてしまったとき、 WordWrap プロパティに真 (True) が設定されていると、自動的に単語と単語の間で行が分割されます。キャリッジ リターンとラインフィードの組み合わせも行を分割します。

下表にいくつかのパターンを示します。

キャプションの内容 | イメージ
タイム■ビューのキャプション |
タイム■ビュー■のキャプション |
Caption■of■Time■View |
Caption-of-Time-View |
タイム■ビューのキャプション |

※■が半角スペース、■がキャリッジ リターンとラインフィードの組み合わせです。


X プロパティ、Y プロパティ

関連項目 使用例

X 座標、 Y 座標を設定します。値の取得も可能です。

構文

object.X [= value]

object.Y [= value]

X プロパティ、Y プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | Pointオブジェクトへの参照を表すオブジェクト式です。
string | X 座標、 Y 座標を指定します。既定値は X プロパティ、 Y プロパティ共に 0 です。指定する単位は、 Point オブジェクトを保持している親オブジェクトにより決められます。

解説

相対位置を指定する場合は、アンカーなどの対象の座標を (0, 0) とした座標になります。


ZoomType プロパティ

関連項目 使用例

タイム ビュー コントロールの PrintPreview メソッド又はPrintStart メソッド、 PrintDirect メソッドで印刷する場合の拡大・縮小方式を設定します。値の取得も可能です。

構文

object.ZoomType [= zoomtype]

ZoomType プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | PrintInfo オブジェクトへの参照を表すオブジェクト式です。
zoomtype | タイム ビュー コントロールの PrintPreview メソッド又はPrintStart メソッド、 PrintDirect メソッドで印刷する場合の拡大・縮小方式を示す値を整数で指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 zoomtype の設定値は次のとおりです。

定数名 | 内容
0 - tivPrintZoomMagnification (既定値) | Magnification プロパティの値にしたがった、倍率による拡大縮小を行います。

解説

現在 ZoomType プロパティの取りうる値は一つしかないため、このプロパティを操作する必要はありません。将来、異なる拡大・縮小方式を提供する可能性を考慮して追加したプロパティです。


ZOrder プロパティ

関連項目

特別時間帯の描画における重ね順を設定します。値の取得も可能です。

構文

object.ZOrder [= zorder]

ZOrder プロパティの構文の指定項目は次のとおりです。

指定項目 | 内容
object | SpecialTime オブジェクトへの参照を表すオブジェクト式です。
zorder | 特別時間帯の描画における重ね順を示す値を整数で指定します。規定値は 0 です。ほかの特別時間帯よりも上に描画させるには、大きい値を指定します。

解説

ZOrder プロパティは、一つの特別時間帯 (SpecialTimes) コレクションに複数の特別時間帯 (SpecialTime) の設定がある状態で、互いの時間帯が一部でも重なり合う場合に、他の特別時間帯に上書きされないように描画順（＝重ね順）を明示的に指定する際に利用します。

ピース ペイン全体の特別時間帯（タイム ビュー コントロールの PiecePane プロパティから参照する PiecePane オブジェクトの SpecialTimeSet プロパティに設定した特別時間帯コレクションに含まれる特別時間帯）は、アイテムごとの特別時間帯（各アイテム(Item)の PiecePane プロパティから参照する PiecePane オブジェクトの SpecialTimeSet プロパティに設定した特別時間帯コレクションに含まれる特別時間帯）よりも、常に下に描画されます。

ZOrder プロパティを利用するには、タイム ビュー コントロール の Misc プロパティ に 8 (tivMiscSpecialTimeNewMode) を設定しておく必要があります。


メソッド一覧

メソッド | 内容
Add | コレクションに オブジェクトを追加します。
Add (ImageLists) | ImageLists コレクションに ImageList オブジェクトを追加します。
Add (Images) | Images コレクションに Image オブジェクトを追加します。
AddFromTemplate | アイテム コレクションに、プロパティ ページにて作成したアイテム テンプレートを使ってアイテム オブジェクトを追加します。
CalcDragItemInterval | OLE ドラッグ アンド ドロップ操作におけるドラッグの移動量から行数を計算します。
CalcDragMinuteInterval | OLE ドラッグ アンド ドロップ操作におけるドラッグの移動量から分数を計算します。
Cell | 行、列で指定されたセルを取得します。
Clear | コレクション内の全てのオブジェクトを削除します。
Clear (DataObject) | DataObject オブジェクトの内容を削除します。
Connect | Piece オブジェクトと接続します。
CreateOutputInfo | OutputInfo オブジェクトを作成します。
CreatePrintInfo | PrintInfo オブジェクトを作成します。
DayOfWeekColor | 目盛を日単位で表示した場合の各曜日色を指定します。
Disconnect | Piece オブジェクトと接続解除します。
DoScroll | 水平方向又は垂直方向にスクロールを実行します。
DrawImage | 指定の領域にピース バーを描画します。
FormatDateTime | 日付/時刻書式に従って日時の文字列を作成します。
GetCellRect | 行、列で指定されたセルの表示領域の座標を取得します。
GetData | DataObject オブジェクトのデータをバリアント型で返します。
GetFontProperty | Font オブジェクトのプロパティ値の取得を支援します。
GetPieceFontProperty | PieceFont オブジェクトのプロパティ値の取得を支援します。
GetFormat | 指定した形式と一致するアイテムが DataObject オブジェクトにあるかどうかを示す値を返します。
HitTest | 指定の座標に対応するタイム ビュー コントロールの要素を調べます。
Image | 表示する画像を設定します。
IsConnected | Piece オブジェクトと接続しているかチェックします。
IsVisible | 関係線が実際に表示されているかをチェックします。
Item | コレクションから指定のオブジェクトを取得します。
OLEDrag | OLE ドラッグ アンド ドロップ操作を手動で開始します。
PrintDirect | 印刷ダイアログを表示せずに現在のプリンタ設定で印刷を開始します。
PrintPreview | 印刷プレビュー ダイアログを表示します。
PrintStart | 印刷ダイアログを表示して印刷を開始します。
Refresh | 無効領域、または全体を強制的に再描画します。
Remove | コレクションから指定のオブジェクトを削除します。
SaveFile | タイム ビュー コントロールのイメージをファイルに出力します。
SetData | 指定したデータ形式を使って DataObject オブジェクトにデータを挿入します。
SetFontProperty | Font オブジェクトのプロパティ値の設定を支援します。
SetPieceFontProperty | PieceFont オブジェクトのプロパティ値の設定を支援します。
SetRange | タイム スケール全体の時間範囲を指定します。
Sort | アイテム コレクション内のアイテムの順序を並べ替えます。
StartCellEdit | セルの値の編集操作を手動で開始します。


Add メソッド

関連項目

コレクションにオブジェクトを追加します。

構文

item = object.Add (index, key)

Add メソッドの構文の指定項目は次のとおりです。

指定項目 | 内容
item | 省略可能です。追加したコレクションのオブジェクトを指すオブジェクト式です。
object | 必ず指定します。「対象」一覧内のいずれかのオブジェクトを指すオブジェクト式です。
index | 省略可能です。新しいオブジェクトを挿入する位置を整数で指定します。インデックスの指定が省略されると、新しいオブジェクトはコレクションの末尾に追加されます。
key | 省略可能です。コレクションの各メンバの処理をするときに、位置を表す数値の代わりに使用できる重複しない文字列を文字列式で指定します。

解説

追加するメンバの名前付き引数 key に、コレクションの既存のメンバの key と重複する値を指定した場合もエラーが発生します。


Add メソッド (ImageLists コレクション)

関連項目 使用例

ImageLists コレクションに ImageList オブジェクトを追加します。

構文

item = object.Add (index, key, url, maskcolor, imagewidth, imageheight)

Add メソッドの構文の指定項目は次のとおりです。

指定項目 | 内容
item | 省略可能です。追加したコレクションのオブジェクトを指すオブジェクト式です。
object | 必ず指定します。 ImageLists コレクションを指すオブジェクト式です。
index | 省略可能です。新しいオブジェクトを挿入する位置を整数で指定します。インデックスの指定が省略されると、新しいオブジェクトはコレクションの末尾に追加されます。
key | オブジェクトを識別する固有の文字列を指定します。省略可能ですが、省略した場合はあとで Key プロパティに代入を行ってください。セルなどに画像を組み込む Image メソッドは、ImageLists コレクション内の ImageList オブジェクトを特定する キー値、および Images コレクション内の Image オブジェクトを特定するキー値を要求します。
url | 省略可能です。ImageList オブジェクトの生成と同時に画像を組み込む場合に指定します。画像ファイルの場所を、パス(c:\\image.gif)、またはURL（http://yourcorp.co.jp/image.gif）の文字列で指定します。組み込んだ画像を識別する Key プロパティの値は、ImageList オブジェクトの Images プロパティから参照する Images コレクションの Keys プロパティを使って設定することができます。ファイルには、ビットマップ ファイル (.BMP)、アイコン ファイル (.ICO)、カーソル ファイル (.CUR)、GIF ファイル (.GIF)、JPEG ファイル (.JPG) などが指定できます。
maskcolor | 省略可能です。引数 url に指定した画像に対するマスク カラーを、色を示す数式で指定します。画像描画において、マスク カラーに指定したのと同じ色の画素を描画しないことで透過効果を出します。
imagewidth | 省略可能です。引数 url に指定した画像を垂直にスライスする場合の幅をピクセル単位で指定します。たとえば 24×16ピクセルの画像を横に１０個、縦に３個連結したような、幅240×高さ48ピクセルの画像を30個の画像として組み込む場合、引数 imagewidth に 16 を指定します。省略した場合は、画像全体の幅を、一つの画像の幅として解釈します。
imageheight | 省略可能です。引数 url に指定した画像を水平にスライスする場合の高さをピクセル単位で指定します。たとえば 24×16ピクセルの画像を横に１０個、縦に３個連結したような、幅240×高さ48ピクセルの画像を30個の画像として組み込む場合、引数 imageheight に 24を指定します。省略した場合は、画像全体の高さを、一つの画像の高さとして解釈します。

解説

セルやピース端点などに使用する、ビットマップ、またはGIF ファイルを ImageList オブジェクトにロードします。引数 url の指定を省略した場合は、追加された ImageList オブジェクトの Images コレクションの Add メソッドを使って画像をロードしてください。ロードされた画像は、ImageList オブジェクトの Images コレクションに格納されます。引数 imagewidth、 imageheight を指定して画像をスライスした場合、Images コレクションに複数の Image オブジェクトが作成されます。

セルやピース端点などで画像を使用するには、これらのオブジェクトの Image メソッドに、使用したい画像が格納された Image オブジェクトの Key プロパティと Image オブジェクトを含む ImageList オブジェクトの Key プロパティを指定します。したがって、Image オブジェクト、および ImageList オブジェクトの Key プロパティの設定は必須です。

基本的な使い方は、次のようになります。

set il =KnTView1.ImageLists.Add _

(,"Airlines", "/Picture/Airlines.gif", RGB(0,255,255), 16, 16)

il.Images.Keys Array("AA", "JAL")

il.Images.Add ,"JAS", "/Picture/Jas.gif", RGB(255, 255, 0)

pce.Captions(1).Image "Airlines" , "JAL"

pce.Captions(1).ImagePosition = tivImageLeft

制限事項： 赤、黒など、マスク処理が正常に行われない色がいくつか存在することが確認されています。また、正常にマスク処理が行われる色として、白、青、緑、黄、シアン、マゼンタが確認されています。


Add メソッド (Images コレクション)

関連項目 使用例

Images コレクションに Image オブジェクトを追加します。

構文

item = object.Add (index, key, url, maskcolor)

Add メソッドの構文の指定項目は次のとおりです。

指定項目 | 内容
item | 省略可能です。追加したコレクションのオブジェクトを指すオブジェクト式です。
object | 必ず指定します。Images コレクションを指すオブジェクト式です。
index | 省略可能です。新しいオブジェクトを挿入する位置を整数で指定します。インデックスの指定が省略されると、新しいオブジェクトはコレクションの末尾に追加されます。
key | オブジェクトを識別する固有の文字列を指定します。省略可能ですが、省略した場合はあとで Key プロパティに代入を行ってください。セルなどに画像を組み込む Image メソッドは、ImageLists コレクション内の ImageList オブジェクトを特定する キー値、および ImageList オブジェクト内の Image オブジェクトを特定するキー値を要求します。
url | 必ず指定します。画像ファイルの場所を、パス(c:\\image.gif)、またはURL（http://yourcorp.co.jp/image.gif）の文字列で指定します。ファイルには、ビットマップ ファイル (.BMP)、アイコン ファイル (.ICO)、カーソル ファイル (.CUR)、GIF ファイル (.GIF)、JPEG ファイル (.JPG) などが指定できます。
maskcolor | 省略可能です。引数 url に指定した画像に対するマスク カラーを、色を示す数式で指定します。画像描画において、マスク カラーに指定したのと同じ色の画素を描画しないことで透過効果を出します。

解説

セルやピース端点などに使用する、ビットマップ、またはGIF ファイルをロードして Image オブジェクトを Images コレクションに追加します。Images コレクションの Add メソッドは画像のスライスをサポートしてなく、一つの画像としてロードし、一つ Image オブジェクトを作成します。 ImageLists コレクションの Add メソッドを使うと、画像をスライスして、一度に複数 Image オブジェクトを追加することができます。

セルやピース端点などで画像を使用するには、これらのオブジェクトの Image メソッドに、使用したい画像が格納された Image オブジェクトの Key プロパティと Image オブジェクトを含む ImageList オブジェクトの Key プロパティを指定します。したがって、Image オブジェクト、および ImageList オブジェクトの Key プロパティの設定は必須です。

基本的な使い方は、次のようになります。

set il =KnTView1.ImageLists.Add (, "Airlines")

il.Images.Add ,"JAS", "/Picture/Jas.gif", RGB(255, 255, 0)

pce.Captions(1).Image "Airlines" , "JAS"

pce.Captions(1).ImagePosition = tivImagePositionLeft

制限事項： 赤、黒など、マスク処理が正常に行われない色がいくつか存在することが確認されています。また、正常にマスク処理が行われる色として、白、青、緑、黄、シアン、マゼンタが確認されています。


AddFromTemplate メソッド

関連項目

コレクションに指定のテンプレートを使ってオブジェクトを追加します。

構文

item = object.AddFromTemplate (templateindex, index, key)

AddFromTemplate メソッドの構文の指定項目は次のとおりです。

指定項目 | 内容
item | 省略可能です。追加したコレクションのオブジェクトを指すオブジェクト式です。
object | 必ず指定します。「対象」一覧内のいずれかのオブジェクトを指すオブジェクト式です。
templateindex | 必ず指定します。対象のテンプレート コレクションのメンバの位置を式で指定します。数式を使って Index 値を指定するか、または文字列式を使って Key 値を指定してください。テンプレート コレクションの Index 値、および Key 値は、各対象のプロパティ ページにて設定した値を使用します。
index | 省略可能です。新しいオブジェクトを挿入する位置を整数で指定します。インデックスの指定が省略されると、新しいオブジェクトはコレクションの末尾に追加されます。
key | 省略可能です。コレクションの各メンバの処理をするときに、位置を表す数値の代わりに使用できる重複しない文字列を文字列式で指定します。

解説

タイムビュー コントロールのプロパティ ページ ダイアログを使って、Item オブジェクト、および Piece オブジェクトのテンプレート（雛形）を作成することができます。AddFromTemplate メソッドでは、プロパティ ページにて作成したテンプレートを使って、コレクションに新しいオブジェクトを追加します。

Pieces コレクションについて、AddFromTemplate メソッドでピースを作成した場合、はじめから Progresses コレクションに Progress オブジェクトが一つ追加されますが、Add メソッドで作成した場合、Progresses コレクションにProgress オブジェクトが追加されない点に注意してください。どちらの場合も、達成率オブジェクトの追加は、Progresses コレクションの Add メソッドを使って、後で追加することができます。

制限事項： テンプレートの適用は、AddFromTemplate メソッドの実行よって追加されるオブジェクトのみに適用されます。たとえば、Items コレクションの AddFromTemplate メソッドを呼び出してアイテムを追加した時点では アイテム テンプレートにて作成しておいた列分のセル テンプレートが適用されますが、あとで、ColumnHeaders コレクションの Add メソッドの呼び出しに伴う各アイテムへのセルの追加では、セルのテンプレートは適用されません。

また同様の仕様により、直接 PieceCaptions コレクションや Progresses コレクションの Add メソッドを呼び出した場合もテンプレートは適用されません。


CalcDragItemInterval メソッド

関連項目

OLE ドラッグ アンド ドロップ操作におけるドラッグの移動量からアイテム数を計算します。

構文

lngValue = object.CalcDragItemInterval (X, Y, DragPiece)

CalcDragItemInterval メソッドの構文の指定項目は次のとおりです。

指定項目 | 内容
lngValue | ドラッグ操作による移動量を示します。
object | タイム ビュー コントロールを指すオブジェクト式です。
X, Y | 必ず指定します。マウス ポインタの現在位置を示す値をコンテナ単位で設定します。
DragPiece | SelectedPieces コレクションの DragPiece プロパティの値を設定します。

解説

OLE ドラッグ アンド ドロップ操作によって SelectedPieces コレクションがドラッグされてきた時に、ドラッグ操作による移動量が何アイテム分 (つまり何行分) かを調べるのに使用します。

CalcDragItemInterval メソッドは、 OLEDragDrop イベント又は OLEDragOver イベントから呼び出すことができます。


CalcDragMinuteInterval メソッド

関連項目

OLE ドラッグ アンド ドロップ操作におけるドラッグの移動量から分数を計算します。

構文

lngValue = object.CalcDragMinuteInterval (X, Y, DragPiece, DeltaX)

CalcDragMinuteInterval メソッドの構文の指定項目は次のとおりです。

指定項目 | 内容
lngValue | ドラッグ操作による移動量を示します。
object | タイム ビュー コントロールを指すオブジェクト式です。
X, Y | 必ず指定します。マウス ポインタの現在位置を示す値をコンテナ単位で設定します。
DragPiece | SelectedPieces コレクションの DragPiece プロパティの値を設定します。
DeltaX | SelectedPieces コレクションの DeltaX プロパティの値を設定します。

解説

OLE ドラッグ アンド ドロップ操作によって SelectedPieces コレクションがドラッグされてきた時に、ドラッグ操作による移動量が分数にして何分かを調べるのに使用します。

CalcDragMinuteInterval メソッドは、 OLEDragDrop イベント又は OLEDragOver イベントから呼び出すことができます。


Cell メソッド

関連項目

指定した位置に対応する特定の Cell オブジェクトへの参照を返します。

構文

Cellobj = object.Cell (ItemIndex, ColumnIndex)

Cell メソッドの構文の指定項目は次のとおりです。

指定項目 | 内容
Cellobj | 指定した位置に対応する Cell オブジェクトを指すオブジェクト式です。見つからない場合は、 Nothing を返します。
object | タイム ビュー コントロールを指すオブジェクト式です。
ItemIndex | セルに対応するアイテムのインデックスを指定します。
ColumnIndex | セルに対応する列見出しのインデックスを指定します。

解説

指定した位置に対応する Cell オブジェクトが見つからない場合は、 Nothing を返します。

引数をすべて省略すると、カレント セルに対応する Cell オブジェクトへの参照を返しますが、カレント セルに対応する Cell オブジェクトが無い場合は、 Nothing を返します。


Clear メソッド

関連項目

コレクション内のすべてのオブジェクトを消去します。

構文

object.Clear

指定項目 | 内容
object | 「対象」一覧内のいずれかのオブジェクトを指すオブジェクト式です。

解説

コレクションから 1 つのオブジェクトを削除する場合、Remove メソッドを使用します。


Clear メソッド (DataObject オブジェクト)

関連項目 使用例

DataObject オブジェクトの内容を削除します。

構文

object.Clear

指定項目 | 内容
object | DataObject オブジェクトを指すオブジェクト式です。

解説

このメソッドは、コンポーネント ドラッグ ソースでだけ利用できます。コンポーネント ドロップ ターゲットから Clear メソッドが呼び出された場合は、エラーが発生します。


Connect メソッド、 Disconnect メソッド

関連項目 使用例

Piece オブジェクトと接続、接続解除します。

構文

object.Connect (piece)

object.Disconnect

Connect メソッド、 Disconnect メソッドの構文の指定項目は次のとおりです。

指定項目 | 内容
object | 必ず指定します。 RelatedLine オブジェクトへの参照を表すオブジェクト式です。
piece | 必ず指定します。接続する Piece オブジェクトを指定します。

解説

関係線を表示するためには、ピースと接続する必要があります。

ピースとの接続、接続解除は、 Connect メソッド、 Disconnect メソッドを使います。

接続しているかは、 IsConnected メソッドでチェックすることができます。

接続している Piece オブジェクトは、 Relation プロパティで参照することができます。

Piece オブジェクトの JoinRelatedLines プロパティで接続されている関係線 (RelatedLine オブジェクト) を参照することもできます。

関係線は、ピースと接続している場合のみ表示されます。また、接続しているピースが非表示、削除されたりした場合は、関係線は描画されません。

接続先のピースが削除された場合は、自動的に接続解除されます。


CreateOutputInfo メソッド

関連項目 使用例

OutputInfo オブジェクトを作成し、 OutputInfo オブジェクトへの参照を返します。

構文

obj = object.CreatePrintInfo

CreatePrintInfo メソッドの構文の指定項目は次のとおりです。

指定項目 | 内容
obj | 作成された OutputInfo オブジェクトを指すオブジェクト式です。
object | タイム ビュー コントロールを指すオブジェクト式です。

解説

このメソッドで作成した OutputInfo オブジェクトも、タイム ビュー コントロールの SaveFile メソッドの引数に指定することができます。


CreatePrintInfo メソッド

関連項目 使用例

PrintInfo オブジェクトを作成し、PrintInfo オブジェクトへの参照を返します。

構文

PrintInfoobj = object.CreatePrintInfo

CreatePrintInfo メソッドの構文の指定項目は次のとおりです。

指定項目 | 内容
PrintInfoobj | 作成されたPrintInfo オブジェクトを指すオブジェクト式です。
object | タイム ビュー コントロールを指すオブジェクト式です。

解説

このメソッドで作成した PrintInfo オブジェクトも、タイム ビュー コントロールの印刷メソッド（PrintStart メソッド、PrintPreview メソッド、PrintDirect メソッド）の引数に指定することができます。


DayOfWeekColor メソッド

関連項目

タイム スケールの目盛線、および目盛文字の曜日色を指定します。

構文

object.DayOfWeekColor (DayOfWeek, Color)

DayOfWeekColor メソッドの構文の指定項目は次のとおりです。

指定項目 | 内容
object | TimeScale オブジェクトへの参照を表すオブジェクト式です。
DayOfWeek | 色を指定する曜日を整数で指定します。設定する値については、次の「設定値」を参照してください。
Color | 色を示す数式を指定します。

設定値

引数 DayOfWeek の設定値は次のとおりです。

定数名 | 内容
0 - tivSunday | 日曜日
1 - tivMonday | 月曜日
2 - tivTuesday | 火曜日
3 - tivWednesday | 水曜日
4 - tivThursday | 木曜日
5 - tivFriday | 金曜日
6 - tivSaturday | 土曜日

解説

タイムスケールの各区分のうち、単位が日単位の区分における目盛文字、または目盛線を、指定の曜日色で表示します。


DoScroll メソッド

関連項目

水平方向および垂直方向へスクロールします。

構文

object.DoScroll (VerScroll, HorScroll)

DoScroll メソッドの構文の指定項目は次のとおりです。

指定項目 | 内容
object | 必ず指定します。 タイム ビュー コントロールを指すオブジェクト式です。
VerScroll | 必ず指定します。垂直方向へのスクロール要求を示す定数または値を指定します。設定する値については、次の「設定値」を参照してください。
HorScroll | 必ず指定します。水平方向へのスクロール要求を示す定数または値を指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 VerScroll, HorScroll の設定値は次のとおりです。

定数名 | 内容
0 - tivScrollNone | スクロールを要求しません。
1 - tivScrollLineUp | 1アイテム上又は中区分の1目盛り左へスクロールします。
2 - tivScrollLineDown | 1アイテム下又は中区分の1目盛り右へスクロールします。
3 - tivScrollPageUp | 1画面分上又は左へスクロールします。
4 - tivScrollPageDown | 1画面分下又は右へスクロールします。
5 - tivScrollTop | 先頭アイテムへスクロールします。対応する水平スクロールはありません。
6 - tivScrollBottom | 最終アイテムへスクロールします。対応する水平スクロールはありません。


DrawImage メソッド

関連項目 使用例

ピースのバーと開始日時及び終了日時の点のイメージを、指定のデバイス コンテキストに描画します。

構文

object.DrawImage (hdc, Left, Top, Right, Bottom)

DrawImage メソッドの構文の指定項目は次のとおりです。

指定項目 | 内容
object | 必ず指定します。 Piece オブジェクトを指すオブジェクト式です。
hdc | 必ず指定します。出力先となるデバイス コンテキストを指定します。
Left, Top, Right, Bottom | 必ず指定します。イメージ描画位置を表す、デバイス コンテキスト中の座標を指定します。


FormatDateTime メソッド

関連項目

日付/時刻書式に従って日時の文字列を作成します。

構文

String = object.FormatDateTime (DateTime, Format)

FormatDateTime メソッドの構文の指定項目は次のとおりです。

指定項目 | 内容
String | 日付/時刻書式に従って作成された文字列です。
object | 必ず指定します。 タイム ビュー コントロールを指すオブジェクト式です。
DataTime | 必ず指定します。書式で変換する日付式を指定します。引数 DateTime に指定したデータは、引数 Format の書式に従って変換されます。
Format | 必ず指定します。適用する日付/時刻表示書式を文字列で指定します。

解説

FormatDateTime メソッドは、日時を示す値を、簡単に文字列化するヘルパー メソッドです。 変換操作には、 TimeScale オブジェクトの DateSwitchHour プロパティの値が適用されるため、 引数 Format で "HHX時" などを指定すると、深夜帯の時刻文字列 ("25時"など) を取得することができます。


GetCellRect メソッド

関連項目

指定した位置に対応する特定の Cell オブジェクトの表示領域の座標を取得します。

構文

boolean = object.GetCellRect (ItemIndex, ColumnIndex, Left, Top, Right, Bottom)

GetCellRect メソッドの構文の指定項目は次のとおりです。

指定項目 | 内容
boolean | 指定した位置に対応する Cell オブジェクト情報取得の成功/失敗を示します。
object | 必ず指定します。 タイム ビュー コントロールを指すオブジェクト式です。
ItemIndex | セルに対応するアイテムのインデックスを指定します。
ColumnIndex | セルに対応する列見出しのインデックスを指定します。
Left, Top, Right, Bottom | セルの表示領域の座標をコンテナ単位で返します。

解説

指定した位置に対応する Cell オブジェクトが見つからない場合は、偽 (False) を返します。


GetData メソッド

関連項目

DataObject オブジェクトのデータをバリアント型で返します。

構文

object.GetData (format)

GetData メソッドの構文の指定項目は次のとおりです。

指定項目 | 内容
object | 必ず指定します。 DataObject オブジェクトを指すオブジェクト式です。
format | 必ず指定します。データ形式を指定する定数または値を、かっこで囲んで指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 format の設定値は次のとおりです。

定数名 | 内容
1 - tivCFText | テキスト
2 - tivCFBitmap | ビットマップ
3 - tivCFMetafile | メタファイル
8 - tivCFDIB | デバイスに依存しないビットマップ
9 - tivCFPalette | カラー パレット
14 - tivCFEMetafile | 拡張メタファイル
5050 - tivCFSelectedPieces |


GetFontPropery メソッド、GetPieceFontPropery メソッド

GetFontProperty メソッド、GetPieceFontProperty メソッド

関連項目

フォント オブジェクトのプロパティ値の取得を支援します。

構文

Result　=　object.GetFontProperty (Prop)

Result　=　object.GetPieceFontProperty (Prop)

GetFontProperty メソッドおよび GetPieceFontProperty メソッドの構文の指定項目は次のとおりです。

指定項目 | 内容
Result | 取得したいフォント属性の値を格納する変数を指定します。
object | 必ず指定します。 「対象」一覧内のいずれかのオブジェクトを指すオブジェクト式です。
Prop | 必ず指定します。取得したいフォント属性を示す値を指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 Prop の設定値は次のとおりです。

定数名 | 内容
0 - tivFontBold | 太字
1 - tivFontItalic | 斜体
2 - tivFontName | フォント名
3 - tivFontSize | サイズ
4 - tivFontStrikeThrough | 取り消し線
5 - tivFontUnderline | 下線付き
6 - tivFontWeight | 太さ

解説

引数 Prop に指定したプロパティの値を取得します。

このメソッドを使いますと、フォント オブジェクトのプロパティを簡単に取得することができます。


GetFormat メソッド

関連項目

指定した形式と一致するアイテムが DataObject オブジェクトにあるかどうかを示すブール型 (Boolean) の値を返します。

構文

boolean = object.GetFormat (format)

GetFormat メソッドの構文の指定項目は次のとおりです。

指定項目 | 内容
boolean | 指定した形式と一致するアイテムが DataObject オブジェクトにあるかどうかを示すブール型 (Boolean) の値です。
object | 必ず指定します。 DataObject オブジェクトを指すオブジェクト式です。
format | 必ず指定します。データ形式を指定する定数または値を、かっこで囲んで指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 format の設定値は次のとおりです。

定数名 | 内容
1 - tivCFText | テキスト
2 - tivCFBitmap | ビットマップ
3 - tivCFMetafile | メタファイル
8 - tivCFDIB | デバイスに依存しないビットマップ
9 - tivCFPalette | カラー パレット
14 - tivCFEMetafile | 拡張メタファイル
5050 - tivCFSelectedPieces | SelectedPieces コレクション

解説

GetFormat メソッドは、指定した形式と一致するアイテムが DataObject オブジェクト内にあるときは真 (True) を返します。その他の場合は偽 (False) を返します。


HitTest メソッド

関連項目

X および X で指定した座標に位置するオブジェクトを調べます。

構文

HitTestResultobj = object.HitTest (X, Y)

HitTest メソッドの構文の指定項目は次のとおりです。

指定項目 | 内容
HitTestResultobj | ヒット テストの結果を格納した HitTestResult オブジェクトを指すオブジェクト式です。
object | 必ず指定します。 タイム ビュー コントロールを指すオブジェクト式です。
X, Y | 必ず指定します。オブジェクトがあるかどうかを調べる位置の座標を指定します。

解説

HitTest メソッドを使って次の場所を認識することができます。

ヒット テストの結果を HitTestResult オブジェクトに格納して返します。ヒットしたオブジェクトによって HitTestResult オブジェクトのどのプロパティに有効な値が格納されているかが異なります。

次の表に、ヒットしたオブジェクトと HitTestResult オブジェクトの各プロパティの関係を示します。（丸のついている個所に対応するプロパティに有効な値が格納されています）

タイム　ビュー　コントロールの Misc プロパティに tivMiscHitTestTime フラグの指定が無い場合、ピース、ピース始点／終点にヒットしても、 HitTestResult オブジェクトの Time プロパティの値は 0 です。


Image メソッド

関連項目

対象のオブジェクトに画像を設定します。

構文

object.Image (imagelistkey, imagekey)

Image メソッドの構文の指定項目は次のとおりです。

指定項目 | 内容
object | 必ず指定します。 「対象」一覧内のいずれかのオブジェクトを指すオブジェクト式です。
imagelistkey | 必ず指定します。タイムビュー コントロールの ImageLists プロパティから参照する ImageLists コレクションに含まれる特定の ImageList オブジェクトの Key プロパティの値を指定します。
imagekey | 必ず指定します。引数 imagelistkey が特定する ImageList オブジェクトの Images プロパティから参照する Images コレクションに含まれる特定の Image オブジェクトの Key プロパティの値を指定します。

解説

対象のオブジェクトに、タイムビュー コントロールの ImageLists コレクションにロードしておいた画像のうち、引数 imagelistkey、 imagekey が特定する画像を設定します。

画像の設定を解除するときは、引数 imagelistkey、 imagekey の両方に "" (空の文字列) を指定して呼び出します。
画像の配置については、対象オブジェクトの ImagePosition プロパティを使って設定します。


IsConnected メソッド

関連項目 使用例

Piece オブジェクトと接続しているかチェックします。

構文

object.IsConnected

IsConnected メソッドの構文の指定項目は次のとおりです。

指定項目 | 内容
object | 必ず指定します。 RelatedLine オブジェクトへの参照を表すオブジェクト式です。

解説

IsConnected メソッドは、ピースと接続している場合は真 (True) を、接続解除している場合は偽 (False) を返します。

接続先のピースが削除された場合は、自動的に接続解除されます。


IsVisible メソッド

関連項目 使用例

対象のオブジェクトが実際に表示されているかをチェックします。

構文

object.IsVisiblee

IsVisible メソッドの構文の指定項目は次のとおりです。

指定項目 | 内容
object | 必ず指定します。 「対象」一覧内のいずれかのオブジェクトを指すオブジェクト式です。

解説

IsVisible メソッドは、対象のオブジェクトが表示されている場合は真 (True) を、表示されていない場合は偽 (False) を返します。

対象のオブジェクトの表示、非表示の制御は、 Hidden プロパティを使います。


Item メソッド

関連項目

指定した位置、または文字列に対応するコレクション内のオブジェクトを返します。

構文

item = object.Item (index)

Item メソッドの構文の指定項目は次のとおりです。

指定項目 | 内容
item | 取得したコレクションのオブジェクトを指すオブジェクト式です。
object | 必ず指定します。 「対象」一覧内のいずれかのオブジェクトを指すオブジェクト式です。
index | 必ず指定します。コレクションのメンバの位置を式で指定します。数式を使って指定する場合、引数 index には 1 からコレクションの Count プロパティの値までの範囲の整数を指定する必要があります。文字列式を使って指定する場合、引数 index には、参照先のメンバをコレクションに追加したときに指定した名前付き引数 key に一致する文字列を指定しなければなりません。

解説

引数 index の値がコレクション オブジェクトの既存のメンバと一致しない場合、エラーが発生します。

Item プロパティは、コレクション オブジェクトの既定のプロパティです。


OLEDrag メソッド

関連項目

コンポーネントに OLE ドラッグ アンド ドロップ操作を開始させます。

構文

object.OLEDrag

指定項目 | 内容
object | 必ず指定します。 タイム ビュー コントロールを指すオブジェクト式です。

解説

OLEDrag メソッドを呼び出すと、タイム ビュー コントロールの OLEStartDrag イベントが発生し、ターゲット コンポーネントにデータを提供できます。


PrintPreview メソッド

関連項目

タイム ビュー コントロールの印刷プレビュー ダイアログをモーダルに表示します。

構文

object.PrintPreview (PrintInfo)

PrintPreview メソッドの構文の指定項目は次のとおりです。

指定項目 | 内容
object | 必ず指定します。 タイム ビュー コントロールを指すオブジェクト式です。
PrintInfo | 必ず指定します。印刷に出力する時間の範囲や行の範囲、余白などを指定します。省略した場合、時間の範囲は、一番開始日時の古いピースの開始日時付近から一番終了日時の新しいピースの終了日時付近までを対象とします。つまりすべてのピースが含まれる一番短い時間の範囲を対象にします。ピースが１つも設定されていない場合は、現在画面に表示されている時間の範囲を対象にします。また同様に省略時における出力する行の範囲はすべての行を対象にします。行が１つも設定されていない場合、印刷は行われません。

解説

PrintPreview メソッドは、印刷プレビューのウィンドウを持つモーダル ダイアログを表示します。この印刷プレビュー ダイアログの「印刷...」ボタンを押して、続けて印刷を実行することができます。

注意事項

時間の印刷範囲は、基本的には StartTime／FinishTime プロパティの設定値となりますが、時間の指定範囲を用紙幅にあてはめた場合に余白が発生する場合、 FinishTime プロパティを用紙幅にあわせて拡張します。


PrintStart メソッド

PrintStart、 PrintDirect メソッド

関連項目

タイム ビュー コントロールを印刷します。

構文

object.PrintStart (PrintInfo)

object.PrintDirect (PrintInfo)

PrintStart メソッド、 PrintDirect メソッドの構文の指定項目は次のとおりです。

指定項目 | 内容
object | 必ず指定します。 タイム ビュー コントロールを指すオブジェクト式です。
PrintInfo | 必ず指定します。印刷に出力する時間の範囲や行の範囲、余白などを指定します。省略した場合、時間の範囲は、一番開始日時の古いピースの開始日時付近から一番終了日時の新しいピースの終了日時付近までを対象とします。つまりすべてのピースが含まれる一番短い時間の範囲を対象にします。ピースが１つも設定されていない場合は、現在画面に表示されている時間の範囲を対象にします。また同様に省略時における出力する行の範囲はすべての行を対象にします。行が１つも設定されていない場合、印刷は行われません。

解説

PrintStart メソッドは、印刷ダイアログを表示します。印刷ダイアログの「印刷」ボタンを押して印刷を開始します。

PrintDirect メソッドは、印刷ダイアログを表示しません。現在のプリンタ設定ですぐに印刷を実行します。

注意事項

時間の印刷範囲は、基本的にはStartTime／FinishTimeプロパティの設定値となりますが、時間の指定範囲を用紙幅にあてはめた場合に余白が発生する場合、FinishTimeを用紙幅にあわせて拡張します。


Refresh メソッド

関連項目 使用例

無効領域、または全体を強制的に再描画します。

構文

object.Refresh (Type)

Refresh メソッドの構文の指定項目は次のとおりです。

指定項目 | 内容
object | 必ず指定します。 タイム ビュー コントロールを指すオブジェクト式です。
Type | 必ず指定します。再描画の範囲を指定する定数または値を指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 Type の設定値は次のとおりです。

定数名 | 内容
0 - tivRefreshInvalid | 無効領域のみを再描画します。無効領域とは、プロパティやメソッドの呼び出しの結果が画面に反映されていない部分を表します。
1 - tivRefreshAll | 強制的にタイムビュー全体を再描画します。

解説

通常、タイムビュー コントロールの再描画は、プロパティやメソッドの呼び出しに応じて、再描画の必要な部分のみを無効化し、イベントが発生していないタイミングで自動的に更新します。引数 Type に 0 (無効領域) を指定した呼び出しは、ループ処理などでアイテムを連続追加する最中に行うと、すぐに追加結果を表示に反映することができます。

注意事項

タイムビュー コントロールの未解決の障害などによって、再描画が十分に行われない場合、引数 Type に 1(全体) を指定して呼び出すと、回避できる場合があります。


Remove メソッド

関連項目

コレクションから項目を削除します。

構文

object.Remove (index)

Remove メソッドの構文の指定項目は次のとおりです。

指定項目 | 内容
object | 「対象」一覧内のいずれかのオブジェクトを指すオブジェクト式です。
index | 必ず指定します。 コレクション中のオブジェクトを識別するための ID として使う整数又は文字列を指定します。 引数 index には 1 からコレクションの Count プロパティの値までの範囲の整数を指定する必要があります。文字列式を使って指定する場合、引数 index には、参照先のメンバをコレクションに追加したときに指定した名前付き引数 key に一致する文字列を指定しなければなりません。

解説

コレクションのすべてのメンバを削除するには、Clear メソッドを使用します。


SaveFile メソッド

関連項目 使用例

タイム ビュー コントロールのイメージをファイルに出力します。

構文

object.SaveFile (filename, fileformat, outputinfo)

SaveFile メソッドの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールを指すオブジェクト式です。
filename | 出力するファイル名を文字列式で指定します。
fileformat | 出力するファイルのフォーマットを指定します。設定する値については、次の「設定値」を参照してください。
outputinfo | 出力する時間の範囲や行の範囲などを設定した、 OutputInfo オブジェクトを指定します。

設定値

引数 fileformat の設定値は次のとおりです。

定数名 | 内容
0 - tivSaveFileFmtMetaFile | メタファイル。
1 - tivSaveFileFmtBitmap | ビットマップ。

解説

SaveFile メソッドを使うと、タイム ビュー コントロールのイメージをファイルに出力することができます。出力に関する情報は、 OutputInfo オブジェクトに設定しパラメータで指定します。

OutputInfo オブジェクトには、出力する列、行の範囲、開始日時、終了日時を指定することができます。


SetData メソッド

関連項目

指定したデータ形式を使って DataObject オブジェクトにデータを挿入します。

構文

object.SetData (data, format)

SetData メソッドの構文の指定項目は次のとおりです。

指定項目 | 内容
object | 必ず指定します。 DataObject オブジェクトを指すオブジェクト式です。
data | 省略可能です。DataObject オブジェクトに渡すデータをバリアント型で指定します。
format | 必ず指定します。DataObject オブジェクトに渡すデータの形式を示す定数または値を指定します。設定する値については、次の「設定値」を参照してください。

設定値

引数 format の設定値は次のとおりです。

定数名 | 内容
1 - tivCFText | テキスト
2 - tivCFBitmap | ビットマップ
3 - tivCFMetafile | メタファイル
8 - tivCFDIB | デバイスに依存しないビットマップ
9 - tivCFPalette | カラー パレット
14 - tivCFEMetafile | 拡張メタファイル
5050 - tivCFSelectedPieces | SelectedPieces コレクション

解説

引数 data は省略可能です。形式ごとにデータをロードせずに、ソース コンポーネントでサポートできる複数の異なる形式を設定できます。複数の形式を設定するには、1 回ごとに異なる形式を使い、SetData メソッドを複数回呼び出します。設定を始めからやり直す場合は、Clear メソッドを使って DataObject オブジェクトのすべてのデータと形式をクリアします。


SetFontPropery メソッド、SetPieceFontPropery メソッド

SetFontProperty メソッド、SetPieceFontProperty メソッド

関連項目

フォント オブジェクトのプロパティ値の設定を支援します。

構文

object.SetFontProperty (Prop, NewValue)

object.SetPieceFontProperty (Prop, NewValue)

SetFontProperty メソッドおよび SetPieceFontProperty メソッドの構文の指定項目は次のとおりです。

指定項目 | 内容
object | 必ず指定します。 「対象」一覧内のいずれかのオブジェクトを指すオブジェクト式です。
Prop | 必ず指定します。プロパティを特定する値を指定します。設定する値については、次の「設定値」を参照してください。
NewValue | 必ず指定します。プロパティに設定する値を指定します。

設定値

引数 Prop の設定値は次のとおりです。

定数名 | 内容
0 - tivFontBold | 太字。引数 NewValue に、太字にするかどうかを示す、ブール式を指定します。
1 - tivFontItalic | 斜体。引数 NewValue に、斜体にするかどうかを示す、ブール式を指定します。
2 - tivFontName | フォント名。引数 NewValue に、フォント名を文字列で指定します。
3 - tivFontSize | サイズ。引数 NewValue に、フォント サイズをポイントで示す数式を指定します。
4 - tivFontStrikeThrough | 取り消し線。引数 NewValue に、取り消し線をつけるかどうかを示す、ブール式を指定します。
5 - tivFontUnderline | 下線付き。引数 NewValue に、下線をつけるかどうかを示す、ブール式を指定します。
6 - tivFontWeight | 太さ。引数 NewValue に、フォントのウェイトを表す数式を指定します。

解説

引数 Prop で指定したプロパティに、引数 NewValue の値を設定します。

このメソッドを使いますと、フォント オブジェクトのプロパティを簡単に設定することができます。


SetRange メソッド

関連項目

タイム スケール全体の時間範囲を指定します。

構文

object.SetRange (start, finish)

SetRange メソッドの構文の指定項目は次のとおりです。

指定項目 | 内容
object | 必ず指定します。 TimeScale オブジェクトを指すオブジェクト式です。
start | 必ず指定します。必ず指定します。タイム スケール全体の先頭日時を日付式で指定します。
finish | 必ず指定します。必ず指定します。タイム スケール全体の末尾日時を日付式で指定します。

解説

タイム スケール全体の時間範囲とは、水平スクロールバー操作で移動できる最小および最大の時間を示します。初期状態での時間範囲は1900年1月1日0時0分から2100年1月1日0時0分までです。


Sort メソッド

関連項目

アイテム コレクション内のアイテムの順序を並べ替えます。

構文

object.Sort [StartItemIndex], [FinishItemIndex], [StartColumnIndex], [FinishColumnIndex], [Order], [Custom]

Sort メソッドの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールを指すオブジェクト式です。
StartItemIndex | 省略可能です。並べ替えの対象とする行範囲の、インデックス値の小さいほうを指定します。
FinishItemIndex | 省略可能です。並べ替えの対象とする行範囲の、インデックス値の大きいほうを指定します。
StartColumnIndex | 省略可能です。キーとする列範囲の、インデックス値の小さいほうを指定します。
FinishColumnIndex | 省略可能です。キーとする列範囲の、インデックス値の大きいほうを指定します。
Order | 省略可能です。並べ替えの順序を示す値を整数で指定します。設定する値については、次の「設定値」を参照してください。JISコード順又は数値順で昇順或いは降順に並べ替えることが出来ます。
Custom | 省略可能です。真 (True) を指定した場合、 Compare イベントが発生します。またこの場合、タイム ビュー コントロール自身では並べ替えのための比較作業を行わないので、 Compare イベント内で任意の条件で比較作業を行ってください。

注意事項

このメソッドは、名前付き引数をサポートしていません。したがって途中の引数のみを省略することはできません。最後の引数から順に省略するのみ可能です。

設定値

引数 Order の設定値は次のとおりです。

定数名 | 内容
0 - tivSortTextAscending | JISコードの昇順
1 - tivSortTextDescending | JISコードの降順
2 - tivSortNumAscending | 数値の昇順
3 - tivSortNumDescending | 数値の降順

解説

タイム ビュー コントロールの Items プロパティが指す Items オブジェクトを対象にした行ソートを実行することができます。


StartCellEdit メソッド

関連項目

ユーザーによるセル編集を開始します。

構文

object.StartCellEdit

指定項目 | 内容
object | タイム ビュー コントロールを指すオブジェクト式です。

解説

CellEdit プロパティが 0 (手動) に設定されている場合は、セル編集操作を開始するには、StartCellEdit メソッドを使わなければなりません。

オブジェクト上で StartCellEdit メソッドを呼び出すと、BeforeCellEdit イベントが発生します。


イベント一覧

イベント | 内容
AfterCellEdit | ユーザーがセルの編集操作を完了した直後に発生します。
AfterCellSelect | ユーザーがセルの選択状態の変更操作を完了した直後に発生します。
AfterHorScroll | ユーザーの水平スクロールの操作に対してスクロールが実施された直後に発生します。
AfterPieceAdd | ユーザーがピースの追加操作を完了した直後に発生します。
AfterPieceMove | ユーザーがピースの移動操作を完了した直後に発生します。
AfterPieceSelect | ユーザーがピースの選択状態の変更操作を完了した直後に発生します。
AfterPieceTimeChange | ユーザーがピースの時間変更操作を完了した直後に発生します。
AfterVerScroll | ユーザーの水平スクロールの操作に対してスクロールが実施された直後に発生します。
BeforeCellEdit | ユーザーがセルの編集を開始しようとしたときに発生します。
BeforeHorScroll | ユーザーが水平スクロールをしようとしたときに発生します。
BeforePieceAdd | ユーザーがピースを移動しようとしたときに発生します。
BeforePieceMove | ユーザーがピースを移動しようとしたときに発生します。
BeforePieceTimeChange | ユーザーがピースの時間を変更しようとしたときに発生します。
BeforeVerScroll | ユーザーが垂直スクロールをしようとしたときに発生します。
Cliｃk | ユーザーがタイム ビュー コントロール上でマウス ボタンを押して離したときに発生します。
Compare | Sort メソッドの実行中にアイテムの比較を行う度に発生します。
DblClick | ユーザーがタイム ビュー コントロール上でマウス ボタンを押して離す操作を2回続けて行ったときに発生します。
DragTipFormat | ドラッグ ヒントに表示する文字列を更新しようとするときに発生します。
EndPrint | 印刷メソッドの実行結果を通知します。
FooterPrint | タイム ビュー コントロールの印刷メソッドの実行で各ページを描画する度に発生します。
HeaderPrint | タイム ビュー コントロールの印刷メソッドの実行で各ページを描画する度に発生します。
KeyDown | ユーザーがキーボードのキーを押したときに発生します。
KeyPress | ユーザーがANSI 文字キーを押して離したときに発生します。
KeyUp | ユーザーがキーボードのキーを離したときに発生します。
MouseDown | ユーザーがマウス ボタンを押したときに発生します。
MouseMove | ユーザーがマウスを移動したときに発生します。
MouseUp | ユーザーがマウス ボタンを離したときに発生します。
OLECompleteDrag | ソース コンポーネントがターゲット コンポーネントにドロップされたときに発生し、ドラッグ操作の実行または取り消しをソース コンポーネントに通知します。
OLEDragDrop | ソース コンポーネントをターゲット コンポーネントにドロップし、ソース コンポーネントでドロップ可能と判断されたときに発生します。
OLEDragOver | コンポーネントが自身又は他のコンポーネント上にドラッグされたときに発生します。
OLEGiveFeedback | 各 OLEDragOver イベントの後に発生します。
OLESetData | ターゲット コンポーネントがソースの DataObject オブジェクトに GetData メソッドを実行したが、指定した形式のデータがロードされる前に、ソース コンポーネントで発生します。
OLEStartDrag | タイム ビュー コントロールのOLE ドラッグ アンド ドロップを開始した直後に発生します。
PieceFinish | 現在日時がピースの終了日時になったときに発生します。
PieceStart | 現在日時がピースの開始日時になったときに発生します。
RequestTipText | ツール チップ ウィンドウに表示する文字列の更新が必要なときに発生します。


AfterCellEdit イベント

関連項目

カレント セルの値をユーザー操作で編集した後に発生します。

構文

Private Sub object_AfterCellEdit (Cancel As ReturnBoolean, NewValue As ReturnVariant)

AfterCellEdit イベントの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールを指すオブジェクト式です。
Cancel | 操作を取り消すかどうかを指定する整数を指定します。0 以外の値を指定すると操作は取り消されます。ブール値を指定することもできます。
NewValue | ユーザーが入力した文字列を元のデータ タイプに変換した値が渡されます。

解説

AfterCellEdit イベントは、ユーザーがセル編集操作を終了した後、他のアイテムをクリックするか Enter キーを押すかしたときに発生します。編集操作を取り消すには、引数 Cancel に 0 以外の値または真 (True) を設定します。編集操作を取り消すと、編集前の既存の値が復元されます。


AfterCellSelect イベント

関連項目

ユーザー操作でカレント セルを変更した直後に発生します。

構文

Private Sub object_AfterCellSelect

指定項目 | 内容
object | タイム ビュー コントロールを指すオブジェクト式です。


AfterHorScroll イベント

関連項目

ユーザーのピースペインの水平スクロールの操作に対してスクロールが実施された直後に発生します。

構文

Private Sub object_AfterHorScroll (HorScroll As Integer)

AfterHorScroll イベントの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールを指すオブジェクト式です。
HorScroll | 実施されたスクロール操作を表す値が渡されます。値については、次の「設定値」を参照してください。

設定値

引数 HorScroll の取りうる値は次のとおりです。

定数名 | 内容
1 - tivScrollLineUp | 中区分の1目盛り分左へスクロールしました。
2 - tivScrollLineDown | 中区分の1目盛り分右へスクロールしました。
3 - tivScrollPageUp | 1画面分左へスクロールしました。
4 - tivScrollPageDown | 1画面分右へスクロールしました。
8 - tivScrollThumbTrack | スクロール ボックスをドラッグしてスクロールしました。


AfterPieceAdd イベント

関連項目

ユーザー操作によるピースの追加操作が完了した後に発生します。

構文

Private Sub object_AfterPieceAdd (Cancel As ReturnBoolean, Start As ReturnDate, Finish As ReturnDate, Item As Item)

AfterPieceAdd イベントの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールを指すオブジェクト式です。
Cancel | 操作を取り消すかどうかを指定する整数を指定します。0 以外の値を指定すると操作は取り消されます。ブール値を指定することもできます。
Start | ユーザー操作から得られた開始日時が渡されます。
Finish | ユーザー操作から得られた終了日時が渡されます。
Item | ピースが追加される Item オブジェクトが渡されます。

解説

ユーザーがピース ペインでマウスの左ボタンを押して、そのまま離さずにマウス カーソルを移動すると、ラバー バンド表示が行われます。任意の時間を表す位置でマウスの左ボタンを離すと、ラバー バンド表示で囲まれた時間でピースを追加します。 AfterPieceAdd イベントは、この一連の操作の最後、つまりマウスの左ボタンを離した時点で発生します。ピースの追加操作を取り消すには、引数 Cancel に 0 以外の値または真 (True) を設定します。


AfterPieceMove イベント

関連項目

ユーザーがピースの移動操作を完了した直後に発生します。

構文

Private Sub object_AfterPieceMove (Cancel As ReturnBoolean, Minutes As Long)

AfterPieceMove イベントの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールを指すオブジェクト式です。
Cancel | 操作を取り消すかどうかを指定する整数を指定します。0 以外の値を指定すると操作は取り消されます。ブール値を指定することもできます。
Minutes | 移動量を分単位にした値が渡されます。


AfterPieceSelect イベント

関連項目

ユーザーが、マウスでピースをポイントした直後に発生します。

構文

Private Sub object_AfterPieceSelect ()

指定項目 | 内容
object | タイム ビュー コントロールを指すオブジェクト式です。


AfterPieceTimeChange イベント

関連項目

ユーザー操作によるピースの時間変更操作が完了した後に発生します。

構文

Private Sub object_AfterPieceTimeChange (Cancel As ReturnBoolean, Which As Integer, Time As ReturnDate)

AfterPieceTimeChange イベントの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールを指すオブジェクト式です。
Cancel | 操作を取り消すかどうかを指定する整数を指定します。0 以外の値を指定すると操作は取り消されます。ブール値を指定することもできます。
Which | 変更操作の行われた日時を表す値が渡されます。設定可能な値については、次の「設定値」を参照してください。
Time | ユーザー操作から得られた新しい日時が渡されます。

設定値

引数 Which の設定値は次のとおりです。

定数名 | 内容
0 - tivStart | 開始日時。
1 - tivFinish | 終了日時。


AfterVerScroll イベント

関連項目

ユーザーの垂直スクロールの操作に対してスクロールが実施された直後に発生します。

構文

Private Sub object_AfterVerScroll (VerScroll As Integer)

AfterVerScroll イベントの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールを指すオブジェクト式です。
VerScroll | 実施されたスクロール操作を表す値が渡されます。値については、次の「設定値」を参照してください。

設定値

引数 VerScroll の取りうる値は次のとおりです。

定数名 | 内容
1 - tivScrollLineUp | 1アイテム分上へスクロールしました。
2 - tivScrollLineDown | 1アイテム分下へスクロールしました。
3 - tivScrollPageUp | 1画面分上へスクロールしました。
4 - tivScrollPageDown | 1画面分下へスクロールしました。
5 - tivScrollTop | 先頭アイテムまでスクロールしました。
6 - tivScrollBottom | 最終アイテムまでスクロールしました。
8 - tivScrollThumbTrack | スクロール ボックスをドラッグしてスクロールしました。


BeforeCellEdit イベント

関連項目 使用例

ユーザーがセルの編集を開始しようとしたときに発生します。

構文

Private Sub object_BeforeCellEdit (Cancel As ReturnBoolean)

BeforeCellEdit イベントの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールを指すオブジェクト式です。
Cancel | 操作を取り消すかどうかを指定する整数を指定します。0 以外の値を指定すると操作は取り消されます。ブール値を指定することもできます。

解説

タイム ビュー コントロールの CellEdit プロパティの値が 0 (手動) の場合、ユーザー操作でアイテムの文字列操作は開始されません。


BeforeHorScroll イベント

関連項目

ユーザーがピースペインのを水平スクロールをしようとしたときに発生します。

構文

Private Sub object_BeforeHorScroll (Cancel As ReturnBoolean, HorScroll As Integer, NewViewTopTime As ReturnDate)

BeforeHorScroll イベントの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールを指すオブジェクト式です。
Cancel | 操作を取り消すかどうかを指定する整数を指定します。0 以外の値を指定すると操作は取り消されます。ブール値を指定することもできます。
HorScroll | ユーザーが行ったスクロール操作を表す値が渡されます。値については、次の「設定値」を参照してください。
NewViewTopTime | スクロールの結果新しく ViewTopTime プロパティに設定される値を渡します。

設定値

引数 HorScroll の取りうる値は次のとおりです。

定数名 | 内容
1 - tivScrollLineUp | 中区分の1目盛り分左へのスクロールを要求しました。
2 - tivScrollLineDown | 中区分の1目盛り分右へのスクロールを要求しました。
3 - tivScrollPageUp | 1画面分左へのスクロールを要求しました。
4 - tivScrollPageDown | 1画面分右へのスクロールを要求しました。
8 - tivScrollThumbTrack | スクロール ボックスをドラッグ操作しました。


BeforePieceAdd イベント

関連項目

ユーザー操作によるピースの追加操作を開始しようとしたときに発生します。

構文

Private Sub object_BeforePieceAdd (Cancel As ReturnBoolean, Time As Date, Item As Item)

BeforePieceAdd イベントの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールを指すオブジェクト式です。
Cancel | 操作を取り消すかどうかを指定する整数を指定します。0 以外の値を指定すると操作は取り消されます。ブール値を指定することもできます。
Time | ユーザーがマウスでポイントした座標に対応する日時が渡されます。
Item | ピースが追加される Item オブジェクトが渡されます。

解説

ユーザーがピース ペインでマウスの左ボタンを押すと、ピースの追加操作が開始されます。ピースの追加操作を取り消すには、引数 Cancel に 0 以外の値または真 (True) を設定します。操作を取り消した場合、 AfterPieceAdd イベントは発生しません。

AllowPieceAdd プロパティの値が 偽 (False) のときは、ピースの追加操作は開始されません。


BeforePieceMove イベント

関連項目

ユーザー操作でピースを移動しようとしたときに発生します。

構文

Private Sub object_BeforePieceMove (Cancel As ReturnBoolean)

BeforePieceMove イベントの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールを指すオブジェクト式です。
Cancel | 操作を取り消すかどうかを指定する整数を指定します。0 以外の値を指定すると操作は取り消されます。ブール値を指定することもできます。

解説

操作を取り消すには、引数 Cancel に 0 以外の値または真 (True) を設定します。操作を取り消すには、引数 Cancel に 0 以外の値または真 (True) を設定します。操作を取り消した場合、 AfterPieceMove イベントは発生しません。

タイム ビュー コントロールの AllowPieceMove プロパティの値が偽 (False) の場合、ピースの移動操作は開始されません。


BeforePieceTimeChange イベント

関連項目

ユーザー操作によるピースの時間変更操作が開始されようとしたときに発生します。

構文

Private Sub object_BeforePieceTimeChange (Cancel As ReturnBoolean, Which As Integer)

BeforePieceTimeChange イベントの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールを指すオブジェクト式です。
Cancel | 操作を取り消すかどうかを指定する整数を指定します。0 以外の値を指定すると操作は取り消されます。ブール値を指定することもできます。
Which | 変更操作の行われた日時を表す値が渡されます。設定可能な値については、次の「設定値」を参照してください。

設定値

引数 Which の設定値は次のとおりです。

定数名 | 内容
0 - tivStart | 開始日時。
1 - tivFinish | 終了日時。

解説

AllowPieceTimeChange プロパティの値が 偽 (False) のときは、ピースの時間変更操作は開始されません。


BeforeVerScroll イベント

関連項目

ユーザーが垂直スクロールをしようとしたときに発生します。

構文

Private Sub object_BeforeVerScroll (Cancel As ReturnBoolean, VerScroll As Integer, NewViewTopItem As ReturnLong)

BeforeVerScroll イベントの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールを指すオブジェクト式です。
Cancel | 操作を取り消すかどうかを指定する整数を指定します。0 以外の値を指定すると操作は取り消されます。ブール値を指定することもできます。
VerScroll | ユーザーが行ったスクロール操作を表す値が渡されます。値については、次の「設定値」を参照してください。
NewViewTopItem | スクロールの結果新しく ViewTopItem プロパティに設定される値を渡します。

設定値

引数 VerScroll の取りうる値は次のとおりです。

定数名 | 内容
1 - tivScrollLineUp | 1アイテム分上へのスクロールを要求しました。
2 - tivScrollLineDown | 1アイテム分下へのスクロールを要求しました。
3 - tivScrollPageUp | 1画面分上へのスクロールを要求しました。
4 - tivScrollPageDown | 1画面分下へのスクロールを要求しました。
8 - tivScrollThumbTrack | スクロール ボックスをドラッグ操作しました。


Click イベント

関連項目

ユーザーが、マウスでタイム ビュー コントロールをポイントした後、マウス ボタンを押して離したときに発生します。

構文

Private Sub object_Click ()

指定項目 | 内容
object | タイム ビュー コントロールを指すオブジェクト式です。


Compare イベント

関連項目

タイム ビュー コントロールの Sort メソッドの引数 Customize に 0 以外の値または真 (True) を指定したときに、このイベントが発生します。

構文

Private Sub object_Compare (Swap As ReturnBoolean, LeftItem As Item, RightItem As Item)

Compare イベントの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールを指すオブジェクト式です。
Swap | 引数 LeftItem と引数 RightItem の指す Item オブジェクトの、 Items コレクション内での位置を交換するかどうかを指定する整数を指定します。0 以外の値を指定すると交換されます。ブール値を指定することもできます。
LeftItem | 比較対象の Item オブジェクトが渡されます。
RightItem | 比較相手のItem オブジェクトが渡されます。

解説

ユーザーはこのイベントを通してソートの比較条件をカスタマイズすることが出来ます。引数 Swap に 0 以外の値または真 (True) を指定すると、引数 LeftItem と引数 RightItem の指す Item オブジェクトの Items コレクション内での位置が交換されます。 Compare イベントは、並べ替えが完了するまで、さまざまな Item オブジェクトの組み合わせで何度も発生します。


DblClick イベント

関連項目

ユーザーがタイム ビュー コントロール上でマウス ボタンを押して離す操作を 2 回続けて行ったとき (ダブルクリックしたとき) に発生します。

構文

Private Sub object_DblClick ()

指定項目 | 内容
object | タイム ビュー コントロールを指すオブジェクト式です。


DragTipFormat イベント

関連項目

ドラッグ ヒントに表示する文字列を更新しようとするときに呼び出されます。

構文

Private Sub object_DragTipFormat (DragPattern As KnTViewLib.TivDragPattern, StartTime As Date, FinishTime As Date, StartIndex As Long, FinishIndex As Long, Tip As KnTViewLib.ReturnString)

DragTipFormat イベントの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールを指すオブジェクト式です。
DragPattern | ドラッグ操作によって行おうとしているアクションを表わす値が渡されます。値については、次の「設定値」を参照してください。
StartTime, FinishTime | ドラッグ矩形の開始日時、及び終了日時を表わす値が渡されます。
StartIndex, FinishIndex | ドラッグ矩形の開始アイテム インデックス、及び終了アイテム インデックスを表わす値が渡されます。この引数に適切な値が渡されるのは、引数DragPattern が、5 (ラバーバンド選択)のときのみです。
Tip | ドラッグ ヒントに新しく表示するデフォルトの文字列が渡されます。独自の内容を表示したい場合は、この内容を書き換えてください。

設定値

引数 DragPattern の取りうる値は次のとおりです。

定数名 | 内容
0 - tivDragPatternNull | ドラッグ操作なし。
1 - tivDragPatternPieceAdd | ピース追加操作。
2 - tivDragPatternPieceMove | 同一アイテム内ピース移動操作。
3 - tivDragPatternPieceStartTimeChange | ピース開始日時の変更操作。
4 - tivDragPatternPieceFinishTimeChange | ピース終了日時の変更操作。
5 - tivDragPatternRubberBand | ピースのラバーバンド選択操作。
6 - tivDragPatternOLEDragDrop | OLE ドラッグ アンド ドロップ操作。

解説

このイベントを処理して、ドラッグ ヒントに表示される文字列を任意に設定することができます。


EndPrint イベント

関連項目

タイム ビュー コントロールの印刷メソッドによる印刷が終了したときに呼び出されます。

構文

Private Sub object_EndPrint (PrintMethod As KnTViewLib.TivPrintMethod, PrintResult As KnTViewLib.TivPrintResult, PrintDetail As KnTViewLib.TivPrintDetail)

EndPrint イベントの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールを指すオブジェクト式です。
PrintMethod | どのメソッドを使用して印刷を実行したかを表わす値が渡されます。値については、次の「設定値」を参照してください。
PrintResult | 印刷がどのように終了したかを表わす値が渡されます。値については、次の「設定値」を参照してください。
PrintDetail | 印刷がエラー終了した場合に、エラー情報を示す値が渡されます。値については、次の「設定値」を参照してください。

設定値

引数 PrintMethod の取りうる値は次のとおりです。

定数名 | 内容
0 - tivPrintStart | PrintStart メソッドを呼び出して印刷しました。
1 - tivPrintPreview | PrintPreview メソッドを呼び出して印刷しました。
2 - tivPrintDirect | PrintDirect メソッドを呼び出して印刷しました。

引数 PrintResult の取りうる値は次のとおりです。

定数名 | 内容
0 - tivPrintDone | 印刷をすべて完了して終了しました。
1 - tivPrintCancel | ユーザーが、印刷ダイアログや印刷中ダイアログで「取消」を選択したり、印刷プレビュー ウィンドウで「閉じる」を選択して、印刷をキャンセルしました。
2 - tivPrintAbort | 印刷中に何らかのエラーが発生したために、印刷を強制的に終了しました。エラーの詳細については、引数 PrintDetail の値から知ることができます。

引数 PrintDetail の取りうる値は次のとおりです。

定数名 | 内容
0 - tivPrintNoDetail | エラーなし。この値は、引数 PrintResult の値が tivPrintAbort 以外のときのみに渡されます。
1 - ｔivPrintUnknownError | 印刷中にエラーが発生しましたが、原因を特定できませんでした。
2 - tivPrintFailToStartPrint | 印刷を開始できませんでした。
3 - tivPrintCantOpenPreview | 印刷プレビュー ウィンドウを表示することができませんでした。
4 - tivPrintApplicationAbort | アプリケーションのアボート関数が 0 を返したために、印刷ジョブを終了しました。
5 - tivPrintUserAbort | ユーザーが、プリント マネージャを使ってジョブを終了させました。
6 - tivPrintOutOfDisk | 現在、スプールに必要なディスク領域が十分でなく、領域が回復される見込みがないことを示します。
7 - tivPrintOutOfMemory | スプールに必要なメモリが十分にありません。

解説

印刷が、実際に行われたか、ユーザーが途中でキャンセルしたか、またはエラーが発生したために強制的に途中で終了したかを判別することができます。どの印刷メソッド(PrintStart 、PrintPreview、PrintDirect)を使用した印刷かを引数 PrintMethod から知ることができます。また、エラーによる強制終了の場合、そのエラーの詳細を示す値が引数 PrintDetail に渡されます。

このイベントは、印刷メソッドから復帰する直前に呼び出されます。


FooterPrint イベント

関連項目

PrintPreview メソッド又は PrintStart メソッドの引数に渡された PrintInfo オブジェクトの FooterHeight プロパティの値が 0 より大きいとき、１ページ分を印刷する毎に呼び出されます。

構文

Private Sub object_FooterPrint (hdc As Long, Left As Long, Top As Long, Right As Long, Bottom As Long, CurPage As Long, NumPages As Long)

FooterPrint イベントの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールを指すオブジェクト式です。
hdc | 印刷に使用するデバイスコンテキスト(DC) です。マッピングモードは常にMM_TEXT (ピクセル単位)です。
Left, Top, Right, Bottom | フッター領域の位置を表す値が渡されます。 単位は常にピクセルです。
CurPage | 現在のページ番号を表す値が渡されます。
NumPages | ページ数を表す値が渡されます。

解説

フッタ領域に任意のイメージを描画することができます。

描画には WindowsAPI を用いる必要が有ります。


HeaderPrint イベント

関連項目

PrintPreview メソッド又は PrintStart メソッドの引数に渡された PrintInfo オブジェクトの HeaderHeight プロパティの値が 0 より大きいとき、１ページ分を印刷する毎に呼び出されます。

構文

Private Sub object_HeaderPrint (hdc As Long, Left As Long, Top As Long, Right As Long, Bottom As Long, CurPage As Long, NumPages As Long)

HeaderPrint イベントの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールを指すオブジェクト式です。
hdc | 印刷に使用するデバイスコンテキスト(DC) です。マッピングモードは常にMM_TEXT (ピクセル単位)です。
Left, Top, Right, Bottom | ヘッダー領域の位置を表す値が渡されます。 単位は常にピクセルです。
CurPage | 現在のページ番号を表す値が渡されます。
NumPages | ページ数を表す値が渡されます。

解説

ヘッダ領域に任意のイメージを描画することができます。

描画には WindowsAPI を用いる必要が有ります。


KeyDown イベント

関連項目

ユーザーがキーボードのキーを押したときに発生します。

構文

Private Sub object_KeyDown (KeyCode As ReturnInteger, Shift As Integer)

KeyDown イベントの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールを指すオブジェクト式です。
KeyCode | F1 キーのときは vbKeyF1、Home キーのときは vbKeyHome など、キー コードを示す定数が設定されます。
Shift | イベント発生時の Shift キー、Ctrl キーおよび Alt キーの状態を示す整数値です。引数 shift はビット フィールドで、ビット 0 が Shift キー、ビット 1 が Ctrl キー、ビット 2 が Alt キーの状態を表します。3 つのビットのいずれか 1 つがオン (1) のときの shift の値はそれぞれ 1、2、4 になります。Shift キー、Ctrl キーおよび Alt キーは、任意の組み合わせで同時に押すことができ、これらのキーの状態に応じて、3 つのビットのオン、オフが設定されます。たとえば、Ctrl キーおよび Alt キーが同時に押された場合、shift の値は 6 になります。

解説

KeyDown イベントは、そのときフォーカスが設定されているオブジェクトに対して発生します。操作されたキーのANSI 文字コードを調べる場合は、KeyPress イベントを使用してください。


KeyPress イベント

関連項目

ユーザーが、ANSI 文字キーを押して離したときに発生します。

構文

Private Sub object_KeyPress (KeyAscii As ReturnInteger)

KeyPress イベントの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールを指すオブジェクト式です。
KeyAscii | 標準の ANSI 文字コードを表す整数値です。引数 keyascii は参照によって渡されるので、この値を変更することによって、実際に入力された文字と異なる文字をオブジェクトに渡すことができます。keyascii を 0 に設定すると、キー操作が取り消され、オブジェクトは文字を受け取りません。


KeyUp イベント

関連項目

ユーザーがキーボードのキーを離したときに発生します。

構文

Private Sub object_KeyUp (KeyCode As ReturnInteger, Shift As Integer)

KeyUp イベントの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールを指すオブジェクト式です。
KeyCode | F1 キーのときは vbKeyF1、Home キーのときは vbKeyHome など、キー コードを示す定数が設定されます。
Shift | イベント発生時の Shift キー、Ctrl キーおよび Alt キーの状態を示す整数値です。引数 shift はビット フィールドで、ビット 0 が Shift キー、ビット 1 が Ctrl キー、ビット 2 が Alt キーの状態を表します。3 つのビットのいずれか 1 つがオン (1) のときの shift の値はそれぞれ 1、2、4 になります。Shift キー、Ctrl キーおよび Alt キーは、任意の組み合わせで同時に押すことができ、これらのキーの状態に応じて、3 つのビットのオン、オフが設定されます。たとえば、Ctrl キーおよび Alt キーが同時に押された場合、shift の値は 6 になります。

解説

KeyUp イベントは、そのときフォーカスが設定されているオブジェクトに対して発生します。操作されたキーのANSI 文字コードを調べる場合は、KeyPress イベントを使用してください。


MouseDown イベント, MouseUp イベント

関連項目

ユーザーがマウス ボタンを押したとき (MouseDown イベント) または離したとき (MouseUp イベント) に発生します。

構文

Private Sub object_MouseDown (Button As Integer, Shift As Integer, X As Single, Y As Single)

MouseDown イベントの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールを指すオブジェクト式です。
Button | 押された (MouseDown イベント) または離された (MouseUp イベント) ボタンを示す整数値です。引数 button はビット フィールドで、ビット 0 がマウスの左ボタン、ビット 1 が右ボタン、ビット 2 が中央ボタンに対応します。3 つのビットのいずれか 1 つがオン (1) のときの button の値はそれぞれ 1、2、4 になります。これらのビットのうち同時にオンに設定されるのは、イベント発生の原因となったいずれかのマウス ボタンを示す 1 つのビットだけです。
Shift | 引数 button が示すマウス ボタンが押されたまたは離されたときの、Shift キー、Ctrl キーおよび Alt キーの状態を示す整数値です。ビットは、キーが押されている場合にオン (1) になります。引数 shift はビット フィールドで、ビット 0 が Shift キー、ビット 1 が Ctrl キー、ビット 2 が Alt キーの状態を表します。3 つのビットのいずれか 1 つがオン (1) のときの shift の値はそれぞれ 1、2、4 になります。Shift キー、Ctrl キーおよび Alt キーは、任意の組み合わせで同時に押すことができ、これらのキーの状態に応じて、3 つのビットのオン、オフが設定されます。たとえば、Ctrl キーおよび Alt キーが同時に押された場合、shift の値は 6 になります。
X, Y | マウス ポインタの現在位置を表す数値です。

解説

引数 X, Y の座標を HitTest メソッドに渡して、マウス カーソルがタイム ビュー コントロール内のどのオブジェクトの上にいるかを詳細に調べることができます。


MouseMove イベント

関連項目

ユーザーがマウスを移動したときに発生します。

構文

Private Sub object_MouseMove (Button As Integer, Shift As Integer, X As Single, Y As Single)

MouseMove イベントの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールを指すオブジェクト式です。
Button | 押された (MouseDown イベント) または離された (MouseUp イベント) ボタンを示す整数値です。引数 button はビット フィールドで、ビット 0 がマウスの左ボタン、ビット 1 が右ボタン、ビット 2 が中央ボタンに対応します。3 つのビットのいずれか 1 つがオン (1) のときの button の値はそれぞれ 1、2、4 になります。これらのビットのうち同時にオンに設定されるのは、イベント発生の原因となったいずれかのマウス ボタンを示す 1 つのビットだけです。
Shift | 引数 button が示すマウス ボタンが押されたまたは離されたときの、Shift キー、Ctrl キーおよび Alt キーの状態を示す整数値です。ビットは、キーが押されている場合にオン (1) になります。引数 shift はビット フィールドで、ビット 0 が Shift キー、ビット 1 が Ctrl キー、ビット 2 が Alt キーの状態を表します。3 つのビットのいずれか 1 つがオン (1) のときの shift の値はそれぞれ 1、2、4 になります。Shift キー、Ctrl キーおよび Alt キーは、任意の組み合わせで同時に押すことができ、これらのキーの状態に応じて、3 つのビットのオン、オフが設定されます。たとえば、Ctrl キーおよび Alt キーが同時に押された場合、shift の値は 6 になります。
X, Y | マウス ポインタの現在位置を表す数値です。

解説

引数 X, Y の座標を HitTest メソッドに渡して、マウス カーソルがタイム ビュー コントロール内のどのオブジェクトの上にいるかを詳細に調べることができます。


OLECompleteDrag イベント

関連項目

ソース コンポーネントがターゲット コンポーネントにドロップされたときに発生し、ドラッグ操作の実行または取り消しをソース コンポーネントに通知します。

構文

Private Sub object_OLECompleteDrag (Effect As ReturnLong)

OLECompleteDrag イベントの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールを指すオブジェクト式です。
Effect | 実行されたアクションを表す値が、ソース オブジェクトによって長整数型 (long) で設定されます。コンポーネントが移動された場合、ソースはこの値を使って適切な処理を実行できます。たとえば、データがコンポーネント間で移動された場合、ソースではそのデータを削除します。設定可能な値については、次の「設定値」を参照してください。

設定値

引数 Effect の設定値は次のとおりです。

定数名 | 内容
0 - vbDropEffectNone | ドロップ ターゲットはデータを受け付けることができません。または、ドロップ操作が取り消されました。
1 - vbDropEffectCopy | ドロップ操作によって、ソースからターゲットにデータがコピーされます。元のデータはドロップ操作では変更されません。
2 - vbDropEffectMove | ドロップ操作によって、ドラッグ ソースからドロップ ターゲットにデータが移動します。データが移動した後、ドラッグ ソースからデータが削除されます。

解説

OLECompleteDrag イベントは、OLE ドラッグ アンド ドロップ操作で呼び出される最後のイベントです。このイベントでは、オブジェクトがターゲット コンポーネントにドロップされたときに実行されたアクションをソース コンポーネントに通知します。ターゲットでは、OLEDragDrop イベントの引数 effect を使ってこの値を設定します。この値に基づき、ソースでは必要なアクションを決定できます。たとえば、オブジェクトがターゲットに移動された場合 (vbDropEffectMove)、オブジェクトの移動後にソースからオブジェクトを削除する必要があります。


OLEDragDrop イベント

関連項目

ソース コンポーネントをターゲット コンポーネントにドロップし、ソース コンポーネントでドロップ可能と判断されたときに発生します。

注意事項

このイベントは、OLEDropMode プロパティが 1 (手動) に設定されている場合にだけ発生します。

構文

Private Sub object_OLEDragDrop (Data As DataObject, Effect As ReturnLong, Button As Integer, Shift As Integer, X As Single, Y As Single, LocalDragDrop As Boolean)

OLEDragDrop イベントの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールを指すオブジェクト式です。
Date | ソースが提供する形式が入った DataObject オブジェクトが渡されます。また、オブジェクトには、これらの形式のデータが入っている場合もあります。DataObject オブジェクトにデータが入っていない場合は、コントロールが GetData メソッドを呼び出したときにデータが渡されます。ここでは、SetData メソッドおよび Clear メソッドは使用できません。
Effect | 実行されたアクションを表す値が、ターゲット オブジェクトによって長整数型 (long) で設定されます (アクションが存在する場合)。コンポーネントが移動された場合、ソースはこの値を使って適切な処理を実行できます。たとえば、ソースは移動されたデータを削除します。設定可能な値については、次の「設定値」を参照してください。
Button | ビット フィールドとして機能する整数の値が渡されます。イベント発生時のマウス ボタンの状態を示します。左ボタンはビット 0、右ボタンはビット 1、中央ボタンはビット 2 に対応しています。各ボタンを示す値は、それぞれ 1、2、4 になります。各ビットは重複して設定でき、値は押されたボタンを表します。
Shift | ビット フィールドとして機能する整数の値が渡されます。イベント発生時の Shift、Ctrl、Alt の各キーの状態を示します。Shift キーはビット 0、Ctrl キーはビット 1、Alt キーはビット 2 に対応しています。各キーを示す値はそれぞれ 1、2、4 になります。引数 shift はこれらのキーの状態を示します。各ビットは重複して設定でき、イベント発生時に押されていたキーの値を合計した値が渡されます。たとえば、Ctrl キー (2) と Alt キー (4) が押されている場合、2 + 4 で shift の値は 6 になります。
X, Y | マウス ポインタの現在の位置を示す数値が渡されます。
LocalDragDrop | ターゲットがドラッグを開始したタイム ビュー コントロールと同じ場合、真 (True) が渡されます。

設定値

引数 Effect の設定値は次のとおりです。

定数名 | 内容
0 - vbDropEffectNone | ドロップ ターゲットはデータを受け付けることができません。
1 - vbDropEffectCopy | ドロップ操作によって、ソースからターゲットにデータがコピーされます。元のデータはドロップ操作では変更されません。
2 - vbDropEffectMove | ドロップ操作によって、ドラッグ ソースからドロップ ターゲットにデータが移動されます。ドラッグ ソースでは、移動後にデータを削除する必要があります。

解説

ソース ActiveX コンポーネントでは、ActiveX コンポーネントの将来のインプリメンテーションと互換性を保つため、引数 effect の値を常にマスクしてください。現在、引数 effect では 32 ビットのうち 3 ビットしか使われていません。しかし、将来のバージョンでは、ほかのビットも使われる可能性があります。したがって、将来問題にならないように、ドラッグ ソースとドロップ ターゲットでは、比較の前に値を適切にマスクしてください。


OLEDragOver イベント

関連項目

コンポーネントがほかのコンポーネント上にドラッグされたときに発生します。

構文

Private Sub object_OLEDragOver (Data As DataObject, Effect As ReturnLong, Button As Integer, Shift As Integer, X As Single, Y As Single, State As Integer, LocalDragDrop As Boolean)

OLEDragOver イベントの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールを指すオブジェクト式です。
Date | ソースが提供する形式が入った DataObject オブジェクトが渡されます。また、オブジェクトには、これらの形式のデータが入っている場合もあります。DataObject オブジェクトにデータが入っていない場合は、コントロールが GetData メソッドを呼び出したときにデータが渡されます。ここでは、SetData メソッドおよび Clear メソッドは使用できません。
Effect | 最初に、ソース オブジェクトがサポートするすべての処理を示す値が、ソース オブジェクトによって長整数 (long) で設定されます。引数 effect は、このイベント中にターゲット コンポーネントによって正しく設定されなければなりません。引数 effect の値は、アクティブなすべての処理 (「設定値」を参照) の論理 OR によって設定されます。ターゲット コンポーネントでは、これらの処理とほかの引数をチェックして適切なアクションを決定します。次に、ソースによって指定された利用可能な処理の 1 つにこの引数を設定し、ユーザーが選択したオブジェクトをコンポーネントにドロップしたときに実行するアクションを指定します。設定可能な値については、次の「設定値」を参照してください。
Button | ビット フィールドとして機能する整数の値が渡されます。イベント発生時のマウス ボタンの状態を示します。左ボタンはビット 0、右ボタンはビット 1、中央ボタンはビット 2 に対応しています。各ボタンを示す値は、それぞれ 1、2、4 になります。各ビットは重複して設定でき、値は押されたボタンを表します。
Shift | ビット フィールドとして機能する整数の値が渡されます。イベント発生時の Shift、Ctrl、Alt の各キーの状態を示します。Shift キーはビット 0、Ctrl キーはビット 1、Alt キーはビット 2 に対応しています。各キーを示す値はそれぞれ 1、2、4 になります。引数 shift はこれらのキーの状態を示します。各ビットは重複して設定でき、イベント発生時に押されていたキーの値を合計した値が渡されます。たとえば、Ctrl キー (2) と Alt キー (4) が押されている場合、2 + 4 で shift の値は 6 になります。
X, Y | マウス ポインタの現在の水平位置 (X) および垂直位置 (Y) が渡されます。
State | ソースのコントロール (マウス ポインタ) とターゲットのフォームまたはコントロールの位置関係を示す整数の値が渡されます。設定可能な値については、次の「設定値」を参照してください。
LocalDragDrop | ターゲットがドラッグを開始したタイム ビュー コントロールと同じ場合、真 (True) が渡されます。

設定値

引数 State の設定値は次のとおりです。

定数名 | 内容
0 - vbEnter | ソース コンポーネントはターゲットの範囲内へ入ったところです。
1 - vbLeave | ソース コンポーネントはターゲットの範囲の外へ出たところです。
2 - vbOver | ソース コンポーネントはターゲット上を移動しています。

解説

メモ 引数 State が vbLeave である場合 (マウス ポインタがターゲットの範囲外に出た場合)、引数 X と Y には 0 が入ります。

ソース ActiveX コンポーネントでは、ActiveX コンポーネントの将来のインプリメンテーションと互換性を保つため、引数 effect の値を常にマスクしてください。現在、引数 effect では 32 ビットのうち 3 ビットしか使われていません。しかし、将来のバージョンでは、ほかのビットも使われる可能性があります。したがって、将来問題にならないように、ドラッグ ソースとドロップ ターゲットでは、比較の前に値を適切にマスクしてください。


OLEGiveFeedback イベント

関連項目

各 OLEDragOver イベントの後に発生します。OLEGiveFeedback イベントによって、ソース コンポーネントではユーザーに視覚的なフィードバックを行うことができます。たとえば、ユーザーがオブジェクトをドロップしたときにマウス カーソルを変更して次の処理を伝えたり、ソース コンポーネントで選択されたオブジェクトを視覚的に変更して次の処理を伝えることができます。

構文

Private Sub object_OLEGiveFeedback (Effect As ReturnLong, DefaultCursors As ReturnBoolean)

OLEGiveFeedback イベントの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールを指すオブジェクト式です。
Effect | ターゲット コンポーネントによって OLEDragOver イベントで長整数型 (long) の値が設定されます。ユーザーが選択したオブジェクトをターゲット コンポーネントにドラッグしたときに実行するアクションを指定します。ソースはこの値を使って適切なアクションを取ることができます (視覚的フィードバックなど)。設定可能な値については、次の「設定値」を参照してください。
DefaultCursors | コンポーネントが提供する既定のマウス カーソルを使うか、またはユーザー定義のマウス カーソルを使うかを示すブール値が渡されます。 真 (True) (既定値) = 既定のマウス カーソルを使います。 偽 (False) = 既定のマウス カーソルを使いません。Screen オブジェクトの MousePointer プロパティを使ってマウス カーソルを設定する必要があります。

設定値

引数 Effect の設定値は次のとおりです。

定数名 | 内容
0 - vbDropEffectNone | ドロップ ターゲットはデータを受け付けることができません。
1 - vbDropEffectCopy | ドロップ操作によって、ソースからターゲットにデータがコピーされます。元のデータはドロップ操作では変更されません。
2 - vbDropEffectMove | ドロップ操作によって、ドラッグ ソースからドロップ ターゲットにデータが移動されます。ドラッグ ソースでは、移動後にデータを削除する必要があります。
22147483648 - vbDropEffectScroll | ターゲット コンポーネントで現在スクロールしているか、これからスクロールしようとしています。この値は、ほかの値と共に使います。ターゲット コンポーネントでユーザー自身がスクロールしている場合にだけ使います。

解説

OLEGiveFeedback イベントにコードが設定されていないか、または引数 DefaultCursors が真 (True) に設定されている場合、マウス カーソルは、コンポーネントによって提供された既定のカーソルに自動設定されます。

ソース ActiveX コンポーネントでは、ActiveX コンポーネントの将来のインプリメンテーションと互換性を保つため、引数 effect の値を常にマスクしてください。現在、引数 effect では 32 ビットのうち 3 ビットしか使われていません。しかし、将来のバージョンでは、ほかのビットも使われる可能性があります。したがって、将来問題にならないように、ドラッグ ソースとドロップ ターゲットでは、比較の前に値を適切にマスクしてください。


OLESetData イベント

関連項目

ターゲット コンポーネントがソースの DataObject オブジェクトに GetData メソッドを実行したが、指定した形式のデータがロードされる前に、ソース コンポーネントで発生します。

構文

Private Sub object_OLESetData (Data As DataObject, DataFormat As Integer)

OLESetData イベントの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールを指すオブジェクト式です。
Data | 要求されたデータを入れる DataObject オブジェクトが渡されます。コンポーネントは SetData メソッドを呼び出し、要求された形式をロードします。
DataFormat | ターゲット コンポーネントが要求しているデータの形式を指定する整数の値が渡されます。ソース コンポーネントではこの値を使って DataObject オブジェクトにロードする形式を決定します。

解説

時間を節約するため、ソース コンポーネントの DataObject オブジェクトにデータをロードするのを遅らせた方がいい場合があります。たとえば、ソース コンポーネントが多数の形式をサポートしている場合などです。OLESetData イベントによって、ソースはデータ形式ごとに 1 つの要求にしか応答しないようにできます。OLESetData イベントが呼び出されたとき、ソースでは引数 format を調べてロードが必要な形式を決定します。次に、DataObject オブジェクトに SetData メソッドを実行してデータをロードします。このデータは、ターゲット コンポーネントに渡されます。


OLEStartDrag イベント

関連項目

コンポーネントの OLEDrag メソッドが実行されたときに発生します。また、OLEDragMode プロパティが 1 (自動) に設定されている場合にコンポーネントが OLE ドラッグ アンド ドロップ操作を開始したときにも発生します。

構文

Private Sub object_OLEStartDrag (Data As DataObject, AllowedEffects As ReturnLong)

OLEStartDrag イベントの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールを指すオブジェクト式です。
Data | ソースが提供する形式が入った DataObject オブジェクトが渡されます。また、オブジェクトには、これらの形式のデータが入っている場合もあります。DataObject オブジェクトにデータが入っていない場合は、コントロールが GetData メソッドを呼び出したときにデータが渡されます。引数 Data の値を指定する必要があります。ここでは、SetData メソッドおよび Clear メソッドは使用できません。
AllowedEffects | ソース コンポーネントがサポートする処理を示す長整数型 (long) の値が渡されます。設定可能な値については、次の「設定値」を参照してください。

設定値

引数 AllowedEffects の設定値は次のとおりです。

定数名 | 内容
0 - vbDropEffectNone | ドロップ ターゲットはデータを受け付けることができません。
1 - vbDropEffectCopy | ドロップ操作によって、ソースからターゲットにデータがコピーされます。元のデータはドロップ操作では変更されません。
2 - vbDropEffectMove | ドロップ操作によって、ドラッグ ソースからドロップ ターゲットにデータが移動されます。ドラッグ ソースでは、移動後にデータを削除する必要があります。

解説

ソース コンポーネントでは、サポートしている値を論理 OR し、その結果を引数 AllowedEffects に入れてください。ターゲット コンポーネントでは、この値を使って適切なアクションおよびユーザーへの適切なフィードバックを決定できます。

OLEDragMode プロパティが 1 (自動) に設定されている場合もOLEStartDrag イベントが発生します。コンポーネントが DataObject オブジェクトに形式とデータを追加した後、ユーザーも形式とデータを追加することができます。また、DataObject オブジェクトをクリアし (Clear メソッドを使用)、データと形式を追加することでコンポーネントの既定の動作を無効にすることもできます。

ターゲット コンポーネントが DataObject オブジェクトを要求するまで、DataObject オブジェクトにデータを入れないこともできます。このようにすると、ソース コンポーネントは複数のデータ形式をロードしないため、時間を節約できます。ターゲット コンポーネントが DataObject オブジェクトに GetData メソッドを実行したとき、DataObject オブジェクトに要求されたデータが入っていない場合はソースの OLESetData イベントが発生します。この時点で、DataObject オブジェクトにデータをロードできます。このデータはターゲットに提供されます。

注意事項

Delphiで、 OLEStartDrag イベントは使用できません。


PieceFinish イベント

関連項目

CurrentTime オブジェクトの Time プロパティの示す日時が、引数 Piece の指す Piece オブジェクトの終了日時になったときに発生します。

構文

Private Sub object_PieceFinish (Piece As Piece)

PieceFinish イベントの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールを指すオブジェクト式です。
Piece | 終了日時が、 CurrentTime オブジェクトの Time プロパティの示す日時になった Piece オブジェクトが渡されます。

解説

CurrentTime オブジェクトの Time プロパティの示す日時とピースの終了日時の比較は、秒を除いた年、月、日、時、分を対象に行われます。

タイム ビュー コントロールの PieceTimeNotify プロパティの値が偽 (False) のときは、 PieceStart イベント、及び PieceFinish イベントは出力されません。


PieceStart イベント

関連項目

CurrentTime オブジェクトの Time プロパティの示す日時が、引数 Piece の指す Piece オブジェクトの開始日時になったときに発生します。

構文

Private Sub object_PieceStart (Piece As Piece)

PieceStart イベントの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールを指すオブジェクト式です。
Piece | 開始日時が、 CurrentTime オブジェクトの Time プロパティの示す日時になった Piece オブジェクトが渡されます。

解説

CurrentTime オブジェクトの Time プロパティの示す日時とピースの開始日時の比較は、秒を除いた年、月、日、時、分を対象に行われます。

タイム ビュー コントロールの PieceTimeNotify プロパティの値が偽 (False) のときは、 PieceStart イベント、及び PieceFinish イベントは出力されません。


RequestTipText イベント

関連項目

マウス ポインタが区別可能な表示要素間を移動したとき、マウス ポインタ下の表示要素に対応するツール チップ テキストを求めて発生します。

構文

Private Sub object_RequestTipText (Result As HitTestResult, TipText As Variant)

RequestTipText イベントの構文の指定項目は次のとおりです。

指定項目 | 内容
object | タイム ビュー コントロールを指すオブジェクト式です。
Request | マウス ポインタの下にあるオブジェクトを識別する HitTestResult オブジェクトが渡されます。
TipText | 空の文字列が渡されます。ツール チップ テキストで表示したい内容がある場合、文字列式で指定します。文字列の途中で改行する場合は、文字列の途中にCR+LFを挿入してください。

解説

RequestTipText イベントを使って、マウス ポインタの移動がしばらく行われないときに現れるツール チップ ウィンドウに表示する文字列を指定することができます。RequestTipText イベントは、HitTest メソッドによって区別可能なオブジェクト間をマウス ポインタが移動したタイミングで発生します。引数 TipText に文字列与えない場合、ツール チップ ウィンドウの表示は行われません。


オブジェクト一覧

オブジェクト名 | 説明
ArrowShape | 矢印の形状オブジェクト。矢印の表示方法に関する情報を持ちます。
Balloon | 吹き出しオブジェクト。吹き出しを表します。
BalloonShape | 吹き出し形状オブジェクト。吹き出しの表示方法に関する情報を持ちます。
BarShape | バー形状オブジェクト。ピース バーの表示方法に関する情報を持ちます。
Cell | セル オブジェクト。行と列からなるグリッドの各マスをセルと呼びます。セルは任意のバリアント値を持ち、表示することができます。
ColumnHeader | 列見出しオブジェクト。各列の先頭に列見出しがあり、任意の文字列を表示することができます。
CurrentTime | 現在日時オブジェクト。タイム ビュー コントロール内の現在日時を表す情報を持ちます。
DataObject | データ オブジェクト。OLE ドラッグ アンド ドロップで転送するデータのコンテナ。
DragTip | ドラッグ ヒント。ドラッグ操作中に表示されるポップ アップ ウィンドウの表示属性を持ちます。
FillFormat | フィル フォーマット オブジェクト。セルやピース表示領域、ピース バーなど、さまざまの領域の塗りつぶし方法に関する情報を持ちます。
HitTestResult | ヒット結果オブジェクト。ヒット テストの結果を格納するオブジェクトです。
Image | イメージオブジェクト。一画像を指すオブジェクトです。
ImageList | イメージリストオブジェクト。サイズとマスク カラーを共通とする一組の画像集合を表します。
Item | アイテム オブジェクト。行に相当し、１行分のセルやピースのコレクションを持っています。
ItemPiecePane | アイテム ピース ペイン オブジェクト。各行のピース表示領域について、背景の塗りつぶしパターンや特別時間帯に関する情報を持ちます。
KnTView | タイム ビュー コントロール。
LetterScale | 文字スケール オブジェクト。タイム スケールの大区分目盛りと中区分目盛りの表示方法に関する情報を持ちます。
LineFormat | ライン フォーマット オブジェクト。セル間の境界線や目盛り線などの描画に関する情報を持ちます。
LineScale | 線スケール オブジェクト。タイム スケールの小区分目盛りの表示方法に関する情報を持ちます。
OutputInfo | 出力情報オブジェクト。出力についての情報を提供するのに用います。
Piece | ピース オブジェクト。タイム ビュー コントロールでは、１つのスケジュールをピースという単位で表します。行毎に複数のピースを追加できます。
PieceCaption | ピース キャプション オブジェクト。ピース バーの中や周りに、ピースに関する情報を表示したい時に使用します。
PiecePane | ピース ペイン オブジェクト。ピース表示領域全体について、目盛り線や特別時間帯に関する情報を持ちます。
Point | 地点オブジェクト。地点に関する情報を持ちます。
PointShape | 端点形状オブジェクト。ピース バーの端点の表示方法に関する情報を持ちます。
PrintInfo | 印刷情報オブジェクト。印刷又は印刷プレビューの実行を要求する時に、印刷方法についての情報を提供するのに用います。
Progress | 達成率オブジェクト。作業の達成の割合を百分率で表します。
RelatedLine | 関係線オブジェクト。ピースの終了とピースの開始を結ぶ関係線を表します。
SpecialTime | 特別時間帯オブジェクト。ピース表示領域の一部の時間帯を任意パターンで塗りつぶすのに使用します。
SpecialTimeSet | 特別時間帯セット オブジェクト。特別時間帯オブジェクトのコレクションを持っているだけの単純なオブジェクトです。ピース表示領域全体や行毎のピース表示領域に対して特別時間帯を設定する時は、このオブジェクトの参照を設定します。
TimeScale | タイム スケール オブジェクト。横軸の目盛りの表示方法に関する情報を持ちます。


ArrowShape オブジェクト

関連項目 使用例 メソッド イベント

矢印の表示方法を表します。

解説

ArrowShape オブジェクトは、矢印の表示方法に関する情報を持ちます。

プロパティ一覧

プロパティ | 内容
Angle | 矢印の角度を示します。
Fill | 矢印の領域を塗りつぶすときの属性を示します。
Length | 矢印の傘の長さを示します。
LenToBreak | 矢印の形状の折れる位置までの長さを示します。
Line | 矢印の線、輪郭線の描画属性を示します。
Shpae | 矢印の形状を示します。


Balloon オブジェクト

関連項目 使用例 イベント

吹き出しを表します。

解説

Balloon オブジェクトは、吹き出しを表します。

Balloon オブジェクトを使って、吹き出しの表示や表示方法等を制御することができます。

各部名称

吹き出しの各部名称は、下図のとおりです。

プロパティ一覧

プロパティ | 内容
AnchorPoint | アンカーの位置を表すオブジェクトを示します。
AnchorRelPoint | アンカーからの相対位置を表すオブジェクトを示します。
BalloonShape | 吹き出しの形状を表すオブジェクトを示します。
Caption | キャプションを表すオブジェクトを示します。
Hidden | 吹き出しの表示を隠すかどうかを示します。
HitTestTarget | ヒットテストの対象にするかどうかを示します。
Index | コレクション内での位置を表すインデックスを示します。
Key | コレクション内で自身を識別する文字列を示します。
Parent | 親オブジェクトを示します。
PosBaseTime | 吹き出しの位置のスタイルによる相対位置の基準日時を示します。
PosRelPoint | 吹き出しの位置のスタイルによる相対位置を表すオブジェクトを示します。
PosStyle | 吹き出しの位置のスタイルを示します。
Tag | プログラムから参照する任意データを示します。

メソッド一覧

メソッド | 内容
IsVisible | 吹き出しが実際に表示されているかをチェックします。


BalloonShape オブジェクト

関連項目 使用例 メソッド イベント

吹き出しの表示方法を表します。

解説

BalloonShape オブジェクトは、吹き出しの表示方法に関する情報を持ちます。

プロパティ一覧

プロパティ | 内容
BeakBase | 吹き出しの接続線の底辺の長さを示します。
BeakBaseStyle | 吹き出しの接続線の底辺の指定スタイルを示します。
ConnectionHitTestWidth | 吹き出しの接続線のヒットテストの有効幅を示します。
ConnectionShape | 吹き出しの接続線の形状を示します。
CornerDiameter | 吹き出しの角丸の直径を示します。
CornerDiameterStyle | 吹き出しの角丸の直径の指定スタイルを示します。
Fill | 吹き出し矢印の領域を塗りつぶすときの属性を示します。
Height | 吹き出しの高さを示します。
Line | 吹き出し矢印の線、輪郭線の描画属性を示します。
Shape | 吹き出しの形状を示します。
SizeStyle | サイズの指定スタイルを示します。
Width | 吹き出しの幅を示します。


BarShape オブジェクト

関連項目 使用例 メソッド イベント

ピース バーの表示方法を表します。

解説

BarShape オブジェクトは、ピース バーの表示方法に関する情報を持ちます。ピース バーとは、 Piece オブジェクトの Start プロパティが示す時間から Finish プロパティが示す時間の間を結ぶ、棒状の表示を示します。

Piece オブジェクトの Start プロパティと Finish プロパティの値が同じ場合や、 Finish プロパティの値が空(Null)の場合、 ピース バーは描画されません。

プロパティ一覧

プロパティ | 内容
Fill | ピース バーの領域を塗りつぶすときの描画属性を示します。
Line | ピース バーの境界線の描画属性を示します。
Shape | ピース バーの形状を示します。


Caption オブジェクト

関連項目 使用例 イベント

キャプションの表示方法を表します。

解説

Caption オブジェクトは、吹き出しなどに表示するキャプションに関する情報を持ちます。

プロパティ一覧

プロパティ | 内容
Color | 表示色を示します。
Font | フォントを示します。
HorAlign | 水平方向の配置を示します。
MarginBottom | 下のマージンを示します。
MarginLeft | 左のマージンを示します。
MarginRight | 右のマージンを示します。
MarginTop | 上のマージンを示します。
Text | 表示する文字列を示します。
VerAlign | 垂直方向の配置を示します。
WordWrap | 単語による行の分割をおこなうかを示します。

メソッド一覧

メソッド | 内容
GetFontProperty | Font オブジェクトのプロパティ値の取得を支援します。
SetFontProperty | Font オブジェクトのプロパティ値の設定を支援します。


Cell オブジェクト

関連項目 使用例 イベント

アイテム行と列見出しからなるグリッド上の各マス（セル）を表します。

解説

Value プロパティに対して、任意のバリアント値を格納できます。 Value プロパティのデータ タイプが文字列以外の場合、文字列に変換して表示します。セル毎に背景や罫線の表示パターンを設定することができます。

セルの値は、ユーザー操作で直接編集することが出来ます。表示書式及び入力書式はサポートしていません。

プロパティ一覧

プロパティ | 内容
BottomBorder | セルの下辺の描画属性を示します。
Color | セルに表示する文字列の色を示します。
Fill | セルの領域を塗りつぶすときの描画属性を示します。
HorAlign | セルに表示する文字列の水平方向の配置を示します。
ImagePosition | セルに表示するテキストとイメージの位置関係を示します。
Index | セル コレクション内での位置を表すインデックスを示します。
ItemIndex | セルを含むアイテムのアイテム コレクション内でのインデックスを示します。
Key | セル コレクション内で自身を識別する文字列を示します。
RightBorder | セルの右辺の描画属性を示します。
Tag | プログラムから参照する任意データを示します。
Value | セルに設定及び表示する値を示します。
VerAlign | セルに表示する文字列の垂直方向の配置を示します。

メソッド一覧

プロパティ | 内容
Image | セルに表示する画像を設定します。


ColumnHeader オブジェクト

関連項目 使用例 イベント

各列の先頭にある見出し部分を表します。

解説

ColumnHeader オブジェクトは、各列の先頭にある見出し部分を表す列見出しオブジェクトです。 Text プロパティに設定した文字列が、列見出しに表示されます。 MergeMode プロパティを使って、列に対応する上下に隣り合うセルどうしの結合表示を制御することができます。

プロパティ一覧

プロパティ | 内容
BottomBorder | 列見出しの下辺の描画属性を示します。
Color | 列見出しに表示する文字列の色を示します。
ColumnWidthMode | 列見出しの幅を自動的に調整するかどうかを示します。
Fill | 列見出しの領域を塗りつぶすときの描画属性を示します。
Font | 列見出しに対応する列に含まれるセルの値の描画に使用するフォントを示します。
HorAlign | 列見出しに表示する文字列の水平方向の配置を示します。
ImagePosition | 列見出しに表示するテキストとイメージの位置関係を示します。
Index | 列見出しコレクション内での位置を表すインデックスを示します。
Key | 列見出しコレクション内で自身を識別する文字列を示します。
MergeMode | 列見出しに対応する列に含まれるセルどうしの結合方法を示します。
RightBorder | 列見出しの右辺の描画属性を示します。
Tag | プログラムから参照する任意データを示します。
Text | 列見出しに表示する文字列を示します。
VerAlign | 列見出しに表示する文字列の垂直方向の配置を示します。
Width | 列見出しの幅を示します。

メソッド一覧

メソッド | 内容
GetFontProperty | Font オブジェクトのプロパティ値の取得を支援します。
Image | 列見出しに表示する画像を設定します。
SetFontProperty | Font オブジェクトのプロパティ値の設定を支援します。


CurrentTime オブジェクト

関連項目 使用例 メソッド イベント

タイム ビュー コントロール内の現在日時とその表示方法に関する情報を表します。

解説

Time プロパティが示す日時の位置に、現在日時線を表示します。

タイム ビュー コントロールの PieceTimeNotify プロパティが真 (True) に設定されている場合に Time プロパティの値を変更すると、いずれかのピースの開始日時又は終了日時が Time プロパティの示す日時と同じかどうかを調べます。同じ日時のピースが見つかった場合、タイム ビュー コントロールから PieceStart イベント又は PieceFinish イベントを出力します。

Hidden プロパティを使って、現在日時線の表示の有無を制御できます。 Hidden プロパティに真 (True) が設定されている場合でも、 Time プロパティの値を変更したときのピースの日時との照合は行われます。

Time プロパティの値を変更によって、システム時間が変更されることはありません。

プロパティ一覧

プロパティ | 内容
Hidden | 現在日時線を表示するかどうかを示します。
Line | 現在日時線の描画属性を示します。
Time | 現在日時線を表示する位置を日時を示します。
UpdateMode | 現在日時線を表示する位置を更新する方法を示します。


DataObject オブジェクト

関連項目 使用例 プロパティ イベント

OLE ドラッグ アンド ドロップ操作で転送するデータのコンテナです。

解説

タイム ビュー コントロールの OLE ドラッグ アンド ドロップは、転送可能なデータの種類に制限がある以外では、標準的な OLE ドラッグ アンド ドロップ操作に準じた使い方ができます。

メソッド一覧

メソッド | 内容
Clear | DataObject オブジェクトの内容を削除します。
GetData | DataObject オブジェクトのデータをバリアント型で返します。
GetFormat | 指定した形式と一致するアイテムが DataObject オブジェクトにあるかどうかを示す値を返します。
SetData | 指定したデータ形式を使って DataObject オブジェクトにデータを挿入します。


DragTip オブジェクト

関連項目 使用例 イベント

ピースのドラッグ操作中に表示されるドラッグ ヒント ウィンドウの表示属性を表わします。

解説

ドラッグ ヒントは、ピースをマウスボタンで押下したときや、ピース ペインでのドラッグ操作で新規にピースを追加しようとしたとき、及びOLE ドラッグ アンド ドロップ操作中にポップ アップ ウィンドウで表示されます。 DragTip オブジェクトのプロパティを使用してドラッグ ヒントの表示を行わないようにしたり、表示時のフォントやカラーの設定を行うことができます。

プロパティ一覧

プロパティ | 内容
Color | ドラッグ ヒント文字列の表示色を示します。
Fill | ドラッグ ヒント ウィンドウ領域の塗りつぶし属性を示します。
Font | ドラッグ ヒント文字列のフォントを示します。
Hidden | ドラッグ ヒントを表示するかどうかを示します。
Line | ドラッグ ヒント ウィンドウ境界線の描画属性を示します。

メソッド一覧

メソッド | 内容
GetFontProperty | Font オブジェクトのプロパティ値の取得を支援します。
SetFontProperty | Font オブジェクトのプロパティ値の設定を支援します。


FillFormat オブジェクト

関連項目 使用例 メソッド イベント

領域の塗りつぶしの書式を表します。

解説

均一な色、グラデーション、パターン、３Dの塗りつぶしのいずれかを設定できます。

プロパティ一覧

プロパティ | 内容
BackColor | 塗りつぶし領域の背景色を示します。
BkMode | 塗りつぶし領域のバックグラウンド モードを示します。
ForeColor | 塗りつぶし領域の前景色を示します。
Pattern | 塗りつぶし領域の塗りつぶしパターンを示します。


HitTestResult オブジェクト

関連項目 使用例 メソッド イベント

タイム ビュー コントロールの HitTest メソッドが返す、ヒット テストの結果を表します。

プロパティ一覧

プロパティ | 内容
BalloonIndex | ヒットした吹き出しのインデックスを示します。
ColumnIndex | ヒットした列インデックスを示します。
ItemIndex | ヒットした行インデックスを示します。
ObjectType | ヒットしたオブジェクトの種類を示します。
PieceIndex | ヒットしたピースのピース コレクション内での位置を表すインデックスを示します。
RelatedLineIndex | ヒットした関係線のインデックスを示します。
Time | ヒットした日時を示します。


Image オブジェクト

関連項目 使用例 メソッド イベント

一つの画像を表します。

解説

Image オブジェクトは、 ImageList オブジェクトが Images コレクションを用いて管理する同一サイズ、同一マスク カラーである一つ以上の画像のうちの一つを表します。

プロパティ一覧

プロパティ | 内容
Index | Images コレクション内で自身の位置を指すインデックスを示します。
Key | Images コレクション内で自身を識別する文字列を示します。


ImageList オブジェクト

関連項目 使用例 メソッド イベント

サイズとマスク カラーを共通とする一組の画像集合を表します。

解説

ImageList オブジェクトは、画像の高さと幅が同じで、且つマスク カラー(透過色として使われる色)が同じ一つ以上の画像をコレクションで保有することができます。 ImageLists コレクションの Add メソッドの引数に画像ファイルの場所をあらわすファイル パス、 または URL を指定して呼び出した場合、ImageLists コレクションに ImageList オブジェクトを追加した後、追加された ImageList オブジェクトの Images プロパティから参照する Images コレクションに読み込んだ画像を格納します。

プロパティ一覧

プロパティ | 内容
Index | ImageLists コレクション内で自身の位置を指すインデックスを示します。
Key | ImageLists コレクション内で自身を識別する文字列を示します。
Images | ImageList オブジェクトに格納した画像集合をオブジェクト化した ImageLists コレクションを示します。


Item オブジェクト

関連項目 使用例 メソッド イベント

タイム ビュー コントロールの行を表します。

解説

Item オブジェクトは、タイム ビュー コントロールの1行分の情報を持ちます。1行分の情報とは、1行に含まれるセルのコレクション、1行に含まれるピースのコレクション、アイテム ピース ペインです。

プロパティ一覧

プロパティ | 内容
Cells | アイテムが持つセル コレクションを示します。
Index | アイテム コレクション内での位置を表すインデックスを示します。
Key | アイテム コレクション内で自身を識別する文字列を示します。
PageBreak | アイテムを次ページの先頭に印刷するかどうかを示します。
PiecePane | アイテム ピース ペインを示します。
Pieces | アイテムが持つピース コレクションを示します。
Tag | プログラムから参照する任意データを示します。
Value | バリアント型の任意データを格納します。


ItemPiecePane オブジェクト

関連項目 使用例 メソッド イベント

１行分のピース表示領域 (アイテム ピース ペイン) に関する情報を表します。

解説

タイム ビュー コントロールの各行のピース表示領域をアイテム ピース ペインと呼びます。 ItemPiecePane オブジェクトは、 Item オブジェクトから利用することができます。任意の Item オブジェクトから参照する ItemPiecePane オブジェクトのプロパティを使用して、行毎に塗りつぶしパターンや特別時間帯を設定することができます。

プロパティ一覧

プロパティ | 内容
BottomBorder | アイテム ピース ペインの下辺の描画属性を示します。
Fill | アイテム ピース ペインの領域を塗りつぶすときの描画属性を示します。
SpecialTimeSet | アイテム ピース ペインに使用する特別時間帯オブジェクトを示します。


LetterScale オブジェクト

関連項目 使用例 イベント

タイム スケールの大区分及び中区分の目盛りを表します。

解説

タイム スケールの目盛りは、大区分、中区分、小区分の 3段で構成されています。 LetterScale オブジェクトは、目盛りを文字で表現する、大区分又は中区分の目盛りを表すオブジェクトです。

プロパティ一覧

プロパティ | 内容
Color | 目盛りの文字列の表示色を示します。
Fill | 目盛りの領域を塗りつぶすときの描画属性を示します。
Font | 目盛りの文字列の描画に使用するフォントを示します。
Format | 目盛りの文字列の書式を示します。
Hidden | 目盛りの表示を隠すかどうかを示します。
Interval | 目盛りの間隔を示します。
SlidingLetter | 次の目盛りに押し出されるまで左端に目盛りを表示し続けるかどうかを示します。
Unit | 目盛りの単位を示します。

メソッド一覧

メソッド | 内容
GetFontProperty | Font オブジェクトのプロパティ値の取得を支援します。
SetFontProperty | Font オブジェクトのプロパティ値の設定を支援します。


LineFormat オブジェクト

関連項目 使用例 メソッド イベント

線の描画に関する属性を表します。

解説

LineFormat オブジェクトの持つプロパティは、直線の描画や矩形の枠線の描画に用いられます。

プロパティ一覧

プロパティ | 内容
Color | 線の表示色を示します。
Style | 線種を示します。


LineScale オブジェクト

関連項目 使用例 メソッド イベント

タイム スケールの小区分の目盛りを表します。

解説

タイム スケールの目盛りは、大区分、中区分、小区分の 3段で構成されています。 LineScale オブジェクトは、目盛りを線で表現する、小区分の目盛りを表すオブジェクトです。

プロパティ一覧

プロパティ | 内容
Fill | 目盛りの領域を塗りつぶすときの描画属性を示します。
Height | 目盛りの高さを示します。
Hidden | 目盛りの表示を隠すかどうかを示します。
Interval | 目盛りの間隔を示します。
Line | 目盛り線の描画属性を示します。
SubInterval | 補助目盛りの表示間隔を示します。
SubLine | 補助目盛り線の描画属性を示します。
SubUnit | 補助目盛りの単位を示します。
Unit | 目盛りの単位を示します。


MarkShape オブジェクト

関連項目 使用例 イベント

マークの表示方法を表します。

解説

稲妻線の達成率ポイントや、トラッカハンドルのマークの表示方法に関する情報を持ちます。

プロパティ一覧

プロパティ | 内容
Fill | マークの領域を塗りつぶすときの属性を示します。
Line | マークの輪郭線の描画属性を示します。
Shape | マークの形状を示します。

メソッド一覧

プロパティ | 内容
Image | マークに表示する画像を設定します。


OutputInfo オブジェクト

関連項目 使用例 メソッド イベント

タイム ビュー コントロールの SaveFile メソッドの引数に指定する出力情報を表します。

解説

タイム ビュー コントロールの SaveFile メソッドを使うと、タイム ビュー コントロールのイメージをファイルに出力することができます。 OutputInfo オブジェクトはこの出力における、時間の範囲や行の範囲、拡大・縮小率の指定をするのに用います。

プロパティ一覧

プロパティ | 内容
BodyBorder | ボディを囲む線の描画属性を示します。
FinishColumn | 出力する列範囲の終了列のインデックスを示します。
FinishIndex | 出力する行範囲の終了行のインデックスを示します。
FinishTime | 出力する時間範囲の終了日時を示します。
StartColumn | 出力する行範囲の開始列のインデックスを示します。
StartIndex | 出力する行範囲の開始行のインデックスを示します。
StartTime | 出力する時間範囲の開始日時を示します。


Piece オブジェクト

関連項目 使用例 イベント

仕事や予定など、特定の日時や期間に起こる事柄を表現する、基本的な単位を表します。

解説

Piece オブジェクトを使って、仕事や予定など、特定の日時や期間に起こる事柄を入力することができます。

Progresses プロパティを使うと、仕事の達成率などを百分率で指定することができ、画面にも表示されます。

Captions プロパティを使うと、ピース バーの内側や周辺に、開始および終了日時や達成率、又は任意の文字列を表示することができます。

RelatedLines プロパティを使うと、ピースとピースの関係線を表示することができます。

Balloons プロパティを使うと、ピースに対する吹き出しを表示することができます。

プロパティ一覧

プロパティ | 内容
Balloons | 吹き出しコレクションを示します。
BarShape | ピース バーの形状や描画属性を表すオブジェクトを示します。
Captions | ピース キャプション コレクションを示します。
Finish | ピースの終了日時を示します。
FinishShape | ピース バーの終点の形状や描画属性を表すオブジェクトを示します。
Index | ピース コレクション内での位置を表すインデックスを示します。
ItemIndex | ピースを含むアイテムのアイテム コレクション内でのインデックスを示します。
JoinRelatedLines | 接続されている関係線コレクションを示します。
Key | ピース コレクション内で自身を識別する文字列を示します。
Progresses | ピースの達成率コレクションを示します。
Prohibited | 他ピースが重なるのを禁止するかどうかを示します。
RelatedLines | 関係線コレクションを示します。
Selected | ピースの選択状態を示します。
Start | ピースの開始日時を示します。
StartShape | ピース バーの始点の形状や描画属性を表すオブジェクトを示します。
Tag | プログラムから参照する任意データを示します。
Value | バリアント型の任意データを格納します。

メソッド一覧

メソッド | 内容
DrawImage | 指定の領域にピース バーを描画します。


PieceCaption オブジェクト

関連項目 使用例 イベント

ピースの内側や周辺に表示する文字列とその表示属性を表します。

解説

PieceCaption オブジェクトは、ピース バーの内側や周辺に表示する情報の種類と表示位置および表示属性に関する情報を持ちます。表示できるデータとしては、開始日時、終了日時、任意文字列、達成率があります。

プロパティ一覧

プロパティ | 内容
Color | ピース キャプションの表示色を示します。
HorAlign | ピース キャプションの水平方向の配置を示します。
ImagePosition | ピース キャプションに表示するテキストとイメージの位置関係を示します。
Index | ピース キャプション コレクション内での位置を表すインデックスを示します。
Key | ピース キャプション コレクション内で自身を識別する文字列を示します。
Position | ピース キャプションの位置を示します。
Text | ピース キャプションに表示する任意の文字列を示します。
Type | ピース キャプションに表示する情報の種類を示します。
VerAlign | ピース キャプションの垂直方向の配置を示します。

メソッド一覧

プロパティ | 内容
Image | ピース キャプションに表示する画像を設定します。


PiecePane オブジェクト

関連項目 使用例 メソッド イベント

ピース ペインに関する情報を表します。

解説

タイム スケール下部のピースを表示する領域全体をピース ペインと呼びます。 PiecePane オブジェクトは、ピース ペインの表示に関する属性情報を持ち、ピース ペイン内の目盛り線の描画パターンや特別時間帯の設定を行えます。 PiecePane オブジェクトは、タイム ビュー コントロールの PiecePane プロパティから参照して利用することができます。行毎の塗りつぶしパターンや特別時間帯の設定を行うには、 Item オブジェクトが持つ PiecePane プロパティから参照する ItemPiecePane オブジェクトを利用します。

プロパティ一覧

プロパティ | 内容
LargeLine | 大区分の目盛りに対応する位置に描画する縦線の描画属性を表すオブジェクトを示します。
MediumLine | 中区分の目盛りに対応する位置に描画する縦線の描画属性を表すオブジェクトを示します。
SmallLine | 小区分の目盛りに対応する位置に描画する縦線の描画属性を表すオブジェクトを示します。
SubLine | 小区分の補助目盛りに対応する位置に描画する縦線の描画属性を表すオブジェクトを示します。
SpecialTimeSet | ピース ペインに使用する特別時間帯オブジェクトを示します。


Point オブジェクト

関連項目 使用例 メソッド イベント

地点を表します。

解説

Point オブジェクトは、地点に関する情報を持ちます。

プロパティ一覧

プロパティ | 内容
X | X 座標を示します。
Y | Y 座標を示します。


PointShape オブジェクト

関連項目 使用例 イベント

ピース ポイントの表示方法を表します。

解説

ピースの開始日時又は終了日時に対応する位置に表示する図形をピース ポイントと呼びます。ピース ポイントの設定は、Piece オブジェクトの StartShape プロパティ又は FinishShape プロパティから参照する PointShape オブジェクトを使用して行います。

プロパティ一覧

プロパティ | 内容
Fill | ピース バーの始点、または終点の領域を塗りつぶすときの属性を示します。
Line | ピース バーの始点、または終点の輪郭線の描画属性を示します。
Position | ピース ポイントとピースの時間の位置関係を示します。
Shape | ピース バーの始点、または終点の形状を示します。

メソッド一覧

プロパティ | 内容
Image | ピース バーの始点、または終点に表示する画像を設定します。


PrintInfo オブジェクト

関連項目 使用例 メソッド イベント

タイム ビュー コントロールの PrintPreview メソッド及び PrintStart メソッド、 PrintDirect メソッドの引数に指定する印刷情報を表します。

解説

タイム ビュー コントロールの PrintPreview メソッド及び PrintStart メソッド、 PrintDirect メソッドを使うと、用紙全体にタイム ビュー コントロールのみを複数ページに渡って印刷することができます。 PrintInfo オブジェクトはこの印刷における、印刷する時間の範囲や行の範囲、余白のサイズ、ヘッダー及びフッター領域のサイズ、用紙方向、拡大・縮小率の指定をするのに用います。

プロパティ一覧

プロパティ | 内容
AllColumnsAtFirstPage | 印刷する時間範囲の先頭時間を含むページにすべての列を印刷するかどうかを示します。
BodyBorder | ボディを囲む線の描画属性を示します。
ChartBorder | チャート部分の描画を囲む線の描画属性を示します。
FinishColumn | 印刷に出力する列範囲の終了列のインデックスを示します。
FinishIndex | 印刷に出力する行範囲の終了行のインデックスを示します。
FinishTime | 印刷に出力する時間範囲の終了日時を示します。
FooterHeight | フッタ領域の高さをセンチメートル単位で示します。
HeaderHeight | ヘッダ領域の高さをセンチメートル単位で示します。
JustClippingToScale | 時間目盛を改ページ時、および右端ページでどのようにクリッピングするかを示します。
Magnification | 印刷の出力を拡大、または縮小する率を設定します。
MarginBottom | 用紙の下側の余白をセンチメートル単位で示します。
MarginLeft | 用紙の左側の余白をセンチメートル単位で示します。
MarginRight | 用紙の右側の余白をセンチメートル単位で示します。
MarginTop | 用紙の上側の余白をセンチメートル単位で示します。
MonochromeText | 印刷する文字の色を白、または黒に変換して出力するかどうかを示します。
Orientation | 用紙の方向を示します。
PaperSize | 用紙サイズを示します。
StartColumn | 印刷に出力する行範囲の開始列のインデックスを示します。
StartIndex | 印刷に出力する行範囲の開始行のインデックスを示します。
StartTime | 印刷に出力する時間範囲の開始日時を示します。
Title | 印刷プレビュー ウィンドウや印刷中ダイアログのウィンドウ タイトルに表示する名前を示します。
ZoomType | 拡大・縮小における方式を示します。


Progress オブジェクト

関連項目 使用例 メソッド イベント

ピースを使って設定した仕事や予定の達成率を表します。

解説

仕事の達成率などを百分率で指定することができ、画面にも表示されます。

達成率は、「何 % まで」を表す PercentTo プロパティのほかに、「何 % から」を表す PercentFrom プロパティを使って設定することが出来ます。

達成率バーの形状は、ピース バーの形状と同等のバリエーションから選択することが出来ます。

プロパティ一覧

プロパティ | 内容
Fill | 達成率バーの領域を塗りつぶす時の描画属性を示します。
Index | 達成率コレクション内での位置を表すインデックスを示します。
Key | 達成率コレクション内で自身を識別する文字列を示します。
Line | 達成率バーの境界線の描画属性を示します。
PercentFrom | 達成率の開始パーセントを百分率で示します。
PercentTo | 達成率の終了パーセントを百分率で示します。
Shape | 達成率バーの形状を示します。


ProgressLine オブジェクト

関連項目 使用例 プロパティ メソッド イベント

プロジェクト管理の機能である、各タスク (ピース) の達成率を結ぶ稲妻線を表します。

解説

ProgressLine オブジェクトは、稲妻線を表します。

ProgressLine オブジェクトを使って、稲妻線の表示や表示方法等を制御することができます。


ProgressPoint オブジェクト

関連項目 使用例 プロパティ メソッド イベント

稲妻線の達成率ポイントを表します。

解説

ProgressPoint オブジェクトは、稲妻線の達成率ポイントを表します。

ProgressPoint オブジェクトを使って、稲妻線の達成率ポイントの表示や表示方法等を制御することができます。


RelatedLine オブジェクト

関連項目 使用例 イベント

ピースとピースの関係線を表します。

解説

RelatedLine オブジェクトは、ピースの終了とピースの開始を結ぶ関係線を表します。

RelatedLine オブジェクトを使って、関係線の表示や表示方法等を制御することができます。

プロパティ一覧

プロパティ | 内容
FinishRelPoint | 終端アンカーからの相対位置を表すオブジェクトを示します。
FinishShape | 終端の矢印の形状を表すオブジェクトをを示します。
Hidden | 関係線の表示を隠すかどうかを示します。
HitTestTarget | ヒットテストの対象にするかどうかを示します。
HitTestWidth | ヒットテストの有効幅を示します。
Index | コレクション内での位置を表すインデックスを示します。
Key | コレクション内で自身を識別する文字列を示します。
Line | 関係線の描画属性を示します。
MiniHeightToPiece | ピースまでの最小高さを示します。
MiniWidthToPiece | ピースまでの最小幅を示します。
Parent | 親オブジェクトを示します。
Relation | 接続先 Piece オブジェクトを示します。
StartRelPoint | 先端アンカーからの相対位置を表すオブジェクトを示します。
StartShape | 先端の矢印の形状を表すオブジェクトを示します。
Style | 関係線のスタイルを示します。
Tag | プログラムから参照する任意データを示します。

メソッド一覧

メソッド | 内容
Connect | Piece オブジェクトと接続します。
Disconnect | Piece オブジェクトと接続解除します。
IsConnected | Piece オブジェクトと接続しているかチェックします。
IsVisible | 関係線が実際に表示されているかをチェックします。


SpecialTime オブジェクト

関連項目 使用例 メソッド イベント

１つの特別時間帯情報を表します。

解説

特別時間帯は、開始時分と終了時分の指定を、毎日/指定曜日/指定日のいずれかを対象に設定します。開始時分と終了時分の両方に 0:00 を設定すると終日の指定になります。

プロパティ一覧

プロパティ | 内容
Fill | 指定の時間帯を塗りつぶすときの描画属性を示します。
Finish | 特別時間帯の終了時分を示します。
Index | 特別時間帯 コレクション内での位置を表すインデックスを示します。
Key | 特別時間帯 コレクション内で自身を識別する文字列を示します。
Pattern | 特別時間帯の適用パターンを示します。
Prohibited | ピースが重なるのを禁止するかどうかを示します。
Start | 特別時間帯の開始時分を示します。
Target | 特別時間帯を適用する日付や曜日を示します。
ZOrder | 特別時間帯の描画時における重ね順を示します。


SpecialTimeSet オブジェクト

関連項目 使用例 メソッド イベント

一組の特別時間帯情報を表します。

解説

SpecialTimeSet オブジェクトは、特別時間帯のコレクションを持っています。

ピース ペイン、又はアイテム ピース ペインに対して特別時間帯を設定するには、始めにタイム ビュー コントロールの SpecialTimeSets プロパティから参照する SpecialTimeSets オブジェクトの Add メソッドを使って、 SpecialTimeSet オブジェクトを生成します。今度は生成した SpecialTimeSet オブジェクトの SpecialTimes プロパティから参照する SpecialTimes オブジェクトの Add メソッドを使って SpecialTime オブジェクトを生成します。そして生成した SpecialTime オブジェクトのプロパティを使って１つの特別時間帯の設定をします。最後に SpecialTimeSets オブジェクトへの参照を、タイム ビュー コントロールの PiecePane プロパティから参照する PiecePane オブジェクトの SpecialTimeSet プロパティ、又は Item オブジェクトの PiecePane プロパティから参照する ItemPiecePane オブジェクトの SpecialTimeSet プロパティに設定して使用します。

プロパティ一覧

プロパティ | 内容
Index | 特別時間帯セット コレクション内での位置を表すインデックスを示します。
Key | 特別時間帯セット コレクション内で自身を識別する文字列を示します。
SpecialTimes | 特別時間帯のコレクションを示します。


TimeScale オブジェクト

関連項目 使用例 イベント

タイム ビュー コントロールの上部に表示する、タイム スケールを表します。

解説

タイム スケールの目盛りは、大区分、中区分、小区分の 3段で構成されています。小区分は、一番細かい目盛りを表示する補助目盛りを持っています。各区分の目盛りの単位は、年、月、週、日、時、分のいずれかを指定できますが、下位の区分は上位の区分の単位と同じかそれより小さい単位を設定する必要があります。

プロパティ一覧

プロパティ | 内容
BottomBorder | タイム スケールの下辺の描画属性を示します。
DateSwitchHour | 日付が変わる時間を示します。
FirstDayOfWeek | 目盛りの単位が週の場合の開始曜日を示します。
Large | 大区分目盛りを示します。
Medium | 中区分目盛りを示します。
Small | 小区分目盛りを示します。
Origin | タイム スケールの目盛りの日時を決めるときの基準日を示します。
WidthPerScale | 中区分目盛りにおける 1目盛りの幅を示します。
WindowFit | 1画面に目盛りを合わせるかどうかを示します。
WindowFitNumScales | １画面に目盛りを合わせる場合の目盛り数を示します。

メソッド一覧

メソッド | 内容
DayOfWeekColor | 目盛を日単位で表示した場合の各曜日色を指定します。
SetRange | タイム スケール全体の時間範囲を指定します。


TrackerHandle オブジェクト

関連項目 使用例 プロパティ メソッド イベント

トラッカハンドルを表します。

解説

TrackerHandle オブジェクトは、トラッカハンドルを表します。

TrackerHandle オブジェクトを使って、トラッカハンドルの表示や表示方法等を制御することができます。


コレクション一覧

オブジェクト名 | 説明
Balloons | 吹き出しオブジェクトのコレクション。吹き出しの追加や削除ができます。
Cells | セル オブジェクトのコレクション。各行は１行分のセルのコレクションを持っています。
ColumnHeaders | 列見出しオブジェクトのコレクション。列の追加や削除ができます。
ImageLists | イメージリストオブジェクトのコレクション。画像集合を指すイメージリストをコレクションしています。
Images | イメージオブジェクトのコレクション。ImageListオブジェクトに格納された画像集合を管理します。
Items | アイテム オブジェクトのコレクション。行の追加や削除ができます。
JoinRelatedLines | 接続されている関係線のコレクション。
PieceCaptions | ピース キャプション オブジェクトのコレクション。ピースに対するキャプションの追加などに使用します。
Pieces | ピース オブジェクトのコレクション。各行毎に１行分のピースのコレクションを持っています。行に対するピースの追加などに使用します。
Progresses | 達成率オブジェクトのコレクション。ピースに対して達成率を設定するときなどに使用します。
RelatedLines | 関係線オブジェクトのコレクション。関係線の追加や削除ができます。
SelectedPieces | 選択ピース オブジェクトのコレクション。選択状態にあるピース オブジェクトへの参照をコレクションしています。
SpecialTimes | 特別時間帯オブジェクトのコレクション。
SpecialTimeSets | 特別時間帯セット オブジェクトのコレクション。


Balloons コレクション

関連項目 使用例 イベント

吹き出しを表す Balloon オブジェクトのコレクションです。

解説

吹き出しを表示するには、 Piece オブジェクトの Balloons プロパティから参照する Balloons コレクションの Add メソッドを用いて、 Balloon オブジェクトを追加します。 1 つのピースに対して、幾つも吹き出しを設定することができます。

プロパティ一覧

プロパティ | 内容
Count | 吹き出しコレクション内の連結線の数を示します。

メソッド一覧

メソッド | 内容
Add | 吹き出しコレクションに吹き出しを追加します。
Clear | 吹き出しコレクション内の全ての吹き出しを削除します。
Item | 指定の吹き出しを取得します。
Remove | 指定の吹き出しを削除します。


Cells コレクション

関連項目 使用例 イベント

Cell オブジェクトのコレクションです。

解説

各 Item オブジェクトは、１行分のセルを Cells コレクションで保持しています。タイム ビュー コントロール内の各 Item オブジェクトが持つことのできる Cell オブジェクトの個数は、ColumnHeader オブジェクトの個数で決まります。 ColumnHeader オブジェクトを削除すると、その列に関連するすべての Cell オブジェクトも削除されます。

プロパティ一覧

プロパティ | 内容
Count | Cell オブジェクトの数を示します。

メソッド一覧

メソッド | 内容
Item | Cell オブジェクトを取得します。


ColumnHeaders コレクション

関連項目 使用例 イベント

列見出しを表す ColumnHeader オブジェクトのコレクションです。

解説

ColumnHeaders コレクションには、実行直後の状態で ColumnHeader オブジェクトが１つ追加されていますが、必要がなければ削除することも出来ます。

Item オブジェクトの持つ Cells コレクション内の Cell オブジェクトの数は、常に ColumnHeaders コレクション内の ColumnHeader オブジェクトの数(即ち列数)と一致します。従って、 ColumnHeaders コレクションの Add メソッド、 Remove メソッド、 Clear メソッドを使用して列見出しの数を変更すると、全ての Item オブジェクトの Cells コレクション内の Cell オブジェクトも自動的に追加又は削除されます。

プロパティ一覧

プロパティ | 内容
Count | 列見出し(列)の数を示します。

メソッド一覧

メソッド | 内容
Add | 列見出し(列)を追加します。
Clear | 全ての列見出し(列)の削除します。
Item | 指定の列見出し(列)を取得します。
Remove | 指定の列見出し(列)を削除します。


ImageLists コレクション

関連項目 使用例 イベント

サイズとマスク カラーを共通とする一組の画像集合を表す ImageList オブジェクトのコレクションです。

解説

画像は、セル、列見出し、ピース端点、ピース キャプションに設定することができます。画像を使用するには、はじめにタイムビュー コントロールの ImageLists プロパティから参照する ImageLists コレクションの Add メソッドに対して使いたい画像へのファイルパス、またはURLを指定して呼び出します。セルなどのオブジェクトに画像を設定するには、オブジェクトの Image メソッドを呼び出します。 Image メソッドは、引数として ImageLists コレクション中の一意の ImageList オブジェクトを特定する Key プロパティの値、および ImageList オブジェクトが持つ Images コレクション中の一意の Image オブジェクトを特定する Key プロパティの値を要求します。各 Key プロパティへの値の設定は、ImageList オブジェクトの Key プロパティ、または Image オブジェクトの Key プロパティへの代入によって可能ですが、Add メソッドに指定した画像ファイルの内容が複数の画像を連結したものである場合、Images コレクションの Keys プロパティを使った一括設定もできます。

プロパティ一覧

プロパティ | 内容
Count | ImageLists コレクションに格納されている ImageList オブジェクトの総数を示します。

メソッド一覧

メソッド | 内容
Add | ImageLists コレクションに ImageList オブジェクトを追加します。
Clear | ImageLists コレクションから ImageList オブジェクトをすべて削除します。
Item | ImageLists コレクションから指定の ImageList オブジェクトを取得します。
Remove | ImageLists コレクションから特定の ImageList オブジェクトを削除します。


Images コレクション

関連項目 使用例 イベント

ImageList オブジェクトに格納された画像集合を表すコレクション オブジェクトです。

解説

ImageList オブジェクトは Images コレクションをもっており、この Images コレクションを利用して画像を管理しています。Images コレクションがもつ 各 Image オブジェクトが一つの画像に対応します。

画像は、ImageLists コレクションの Add メソッドに対して画像ファイルを指定して ImageList オブジェクトの生成と同時に格納する方法と、ImageList オブジェクトの Images プロパティから参照する Images コレクションの Add メソッドを使って格納する方法があります。

プロパティ一覧

プロパティ | 内容
Count | Images コレクション内の Image オブジェクトの数を示します。
Keys | Images コレクション内にある、すべてのImage オブジェクトのキーが格納された1次元配列を示します。

メソッド一覧

メソッド | 内容
Add | Images コレクションに Image オブジェクトを追加します。
Clear | Images コレクションから Image オブジェクトをすべて削除します。
Item | Images コレクションから特定の Image オブジェクトを取得します。
Remove | Images コレクションから特定の Image オブジェクトを削除します。


Items コレクション

関連項目 使用例 イベント

1行分の情報を持つ Item オブジェクトのコレクションです。

解説

タイム ビュー コントロールに行を追加するには、タイム ビュー コントロールの Items プロパティから参照する Items コレクションの Add メソッドを使用して Item オブジェクトを追加します。

プロパティ一覧

プロパティ | 内容
Count | アイテム コレクション内のアイテム オブジェクトの数を示します。

メソッド一覧

メソッド | 内容
Add | アイテム コレクションにアイテム オブジェクトを追加します。
AddFromTemplate | アイテム コレクションに、プロパティ ページにて作成したアイテム テンプレートを使ってアイテム オブジェクトを追加します。
Clear | アイテム コレクション内の全てのアイテム オブジェクトを削除します。
Item | アイテム コレクションから指定のアイテム オブジェクトを取得します。
Remove | アイテム コレクションから指定のアイテム オブジェクトを削除します。


JoinRelatedLinesコレクション

関連項目 使用例 イベント

ピースとピースの関係線において、接続されている RelatedLine オブジェクトのコレクションです。

解説

RelatedLine オブジェクトの Connect メソッドで関係線を接続すると、接続されたピースの JoinRelatedLines プロパティで参照できる JoinRelatedLines コレクションに、その RelatedLine オブジェクトが追加されます。

RelatedLine オブジェクトの Disconnect メソッドで関係線を接続解除すると、接続されたピースの JoinRelatedLines プロパティで参照できる JoinRelatedLines コレクションから、その RelatedLine オブジェクトが削除されます。

プロパティ一覧

プロパティ | 内容
Count | 関係線コレクション内の関係線の数を示します。

メソッド一覧

メソッド | 内容
Item | 指定の関係線を取得します。


PieceCaptions コレクション

関連項目 使用例 イベント

ピースの内側や周辺に表示する文字列とその表示属性を表す PieceCaption オブジェクトのコレクションです。

解説

ピースの内側や周辺にピースに関する情報を表示するには、 Piece オブジェクトの Captions プロパティから参照する PieceCaptions コレクションの Add メソッドを用いて、 PieceCaption オブジェクトを追加します。１つのピースに対して、幾つもピース キャプションを設定することができます。

プロパティ一覧

プロパティ | 内容
Count | ピース キャプション コレクション内のピース キャプションの数を示します。

メソッド一覧

メソッド | 内容
Add | ピース キャプション コレクションにピース キャプションを追加します。
Clear | ピース キャプション コレクション内の全てのピース キャプションを削除します。
Item | 指定のピース キャプションを取得します。
Remove | 指定のピース キャプションを削除します。


Pieces コレクション

関連項目 使用例 イベント

仕事や予定など、特定の日時や期間に起こる事柄を表現する、 Piece オブジェクトのコレクションです。

解説

指定の行にピースを追加するには、 Item オブジェクトの Pieces プロパティから参照する Pieces コレクションの Add メソッドを用いて、 Piece オブジェクトの追加を行います。

プロパティ一覧

プロパティ | 内容
Count | ピース コレクション内のピースの数を示します。
Format | ピース コレクション内のピースのピース キャプションに開始日時又は終了日時を表示する場合に使用する日付書式を示します。
Selected | ピース コレクション内の全てのピースを対象に選択状態を設定します。
SelectMode | ピース コレクション内のピースの選択方法を示します。

メソッド一覧

メソッド | 内容
Add | ピース コレクションにピースを追加します。
AddFromTemplate | ピース コレクションに、プロパティ ページにて作成したピース テンプレートを使って、ピースを追加します。
Clear | ピース コレクション内の全てのピースを削除します。
Item | 指定のピースを取得します。
Remove | 指定のピースを削除します。


Progresses コレクション

関連項目 使用例 イベント

仕事や予定の達成率を表す Progress オブジェクトのコレクションです。

解説

ピースに達成率を設定するには、 Piece オブジェクトの Progresses プロパティから参照する Progresses コレクションの Add メソッドを用いて、 Progress オブジェクトを追加します。１つのピースに複数の達成率を設定できます。

プロパティ一覧

プロパティ | 内容
Count | 達成率コレクション内の達成率オブジェクトの数を示します。

メソッド一覧

メソッド | 内容
Add | 達成率コレクションに達成率オブジェクトを追加します。
Clear | 達成率コレクション内の全ての達成率オブジェクトを削除します。
Item | 達成率コレクションから指定の達成率オブジェクトを取得します。
Remove | 達成率コレクションから指定の達成率オブジェクトを削除します。


Balloons コレクション

関連項目 使用例 イベント

吹き出しを表す Balloon オブジェクトのコレクションです。

解説

吹き出しを表示するには、 Piece オブジェクトの Balloons プロパティから参照する Balloons コレクションの Add メソッドを用いて、 Balloon オブジェクトを追加します。 1 つのピースに対して、幾つも吹き出しを設定することができます。

プロパティ一覧

プロパティ | 内容
Count | 吹き出しコレクション内の連結線の数を示します。

メソッド一覧

メソッド | 内容
Add | 吹き出しコレクションに吹き出しを追加します。
Clear | 吹き出しコレクション内の全ての吹き出しを削除します。
Item | 指定の吹き出しを取得します。
Remove | 指定の吹き出しを削除します。
ProgressLines コレクション

ここにトピック テキストを入力します。


RelatedPoints コレクション

ProgressLines コレクション

関連項目 使用例 イベント

稲妻線の達成率ポイント表す ProgressPoint オブジェクトのコレクションです。

解説

稲妻線の達成率ポイントを表示するには、 ProgressLine オブジェクトの ProgressPoints プロパティから参照する ProgressPoints コレクションの Add メソッドを用いて、 ProgressPoint オブジェクトを追加します。

プロパティ一覧

プロパティ | 内容
Count | 関係線コレクション内の関係線の数を示します。

メソッド一覧

メソッド | 内容
Add | 関係線コレクションに関係線を追加します。
Clear | 関係線コレクション内の全ての関係線を削除します。
Item | 指定の関係線を取得します。
Remove | 指定の関係線を削除します。


RelatedLines コレクション

ProgressLines コレクション

関連項目 使用例 イベント

稲妻線を表す ProgressLine オブジェクトのコレクションです。

解説

稲妻線を表示するには、 タイム ビュー コントロールの ProgressLines プロパティから参照する ProgressLines コレクションの Add メソッドを用いて、 ProgressLine オブジェクトを追加します。 複数の稲妻線を設定することができます。

プロパティ一覧

プロパティ | 内容
Count | 関係線コレクション内の関係線の数を示します。

メソッド一覧

メソッド | 内容
Add | 関係線コレクションに関係線を追加します。
Clear | 関係線コレクション内の全ての関係線を削除します。
Item | 指定の関係線を取得します。
Remove | 指定の関係線を削除します。


SelectedPieces コレクション

関連項目 使用例 イベント

選択中の Piece オブジェクトのコレクションです。

解説

Piece オブジェクトの Selected プロパティを真 (True) に設定すると、 SelectedPieces コレクションに追加され、偽 (False) を設定すると、取り除かれます。 SelectedPieces コレクションは、タイム ビュー コントロールの SelectedPieces プロパティから参照して利用することができます。

選択中のピースを OLE ドラッグ アンド ドロップ操作したときは、 SelectedPieces コレクションの持つデータのコピーが転送されます。

プロパティ一覧

プロパティ | 内容
Count | 選択ピース コレクション内のピースの数を示します。
DeltaX | DragPiece プロパティから参照するピースの左端座標からドラッグ開始時のマウス ポインタの X座標までの距離を取得します。
DragPiece | OLE ドラッグ アンド ドロップ操作で、ドラッグ開始時に直接マウスでポイントしたピースを示します。

メソッド一覧

メソッド | 内容
Item | 選択ピース コレクションから指定のピースを取得します。


SpecialTimes コレクション

関連項目 使用例 イベント

１つの特別時間帯情報を表す SpecialTime オブジェクトのコレクションです。

解説

新たに特別時間帯情報を作成するには、SpecialTimeSet オブジェクトの SpecialTimes プロパティから参照する SpecialTimes コレクションの Add メソッドを使用して行います。

プロパティ一覧

プロパティ | 内容
Count | 特別時間帯 コレクション内の特別時間帯 オブジェクトの数を示します。

メソッド一覧

メソッド | 内容
Add | 特別時間帯 コレクションに特別時間帯 オブジェクトを追加します。
Clear | 特別時間帯 コレクション内の全ての特別時間帯 オブジェクトを削除します。
Item | 特別時間帯 コレクションから指定の特別時間帯 オブジェクトを取得します。
Remove | 特別時間帯 コレクションから指定の特別時間帯 オブジェクトを削除します。


SpecialTimeSets コレクション

関連項目 使用例 イベント

一組の特別時間帯情報を表す SpecialTimeSet オブジェクトのコレクションです。

解説

ピース ペイン又は各行のアイテム ピース ペインに対して特別時間帯を設定する時は、 一組の特別時間帯情報を表す SpecialTimeSet オブジェクトへの参照を設定します。

新たに一組の特別時間帯情報を作成するには、タイム ビュー コントロールの SpecialTimeSets プロパティから参照する SpecialTimeSets コレクションの Add メソッドを使用して行います。

プロパティ一覧

プロパティ | 内容
Count | 特別時間帯セット コレクション内の特別時間帯セット オブジェクトの数を示します。

メソッド一覧

メソッド | 内容
Add | 特別時間帯セット コレクションに特別時間帯セット オブジェクトを追加します。
Clear | 特別時間帯セット コレクション内の全ての特別時間帯セット オブジェクトを削除します。
Item | 特別時間帯セット コレクションから指定の特別時間帯セット オブジェクトを取得します。
Remove | 特別時間帯セット コレクションから指定の特別時間帯セット オブジェクトを削除します。


TrackerHandles コレクション

関連項目 使用例 イベント

トラッカハンドル表す TrackerHandle オブジェクトのコレクションです。

解説

対象のオブジェクトが保持するトラッカハンドルは、対象オブジェクトが保持する TrackerHandles コレクションに追加されています。このコレクションにアイテムである TrackerHandle オブジェクトを追加することはできません。

プロパティ一覧

プロパティ | 内容
Count | 関係線コレクション内の関係線の数を示します。

メソッド一覧

メソッド | 内容
Item | 指定の関係線を取得します。


マウス ポインタの形

形 | 表示位置 | マウス操作
 | セル | クリックしてセル選択、ダブル クリックしてセル編集
 | ピース | クリックしてピース選択
 | ピース ペイン | ドラッグしてピースのラバー バンド選択
 | ピース ペイン | ドラッグしてピース追加
 | ピース バー | ドラッグしてピース移動
 | ピース ポイント | ドラッグして開始日時、又は終了日時の変更
 | 列幅変更ポイント | ドラッグして列幅変更
 | 目盛り幅変更ポイント | ドラッグして目盛り幅変更
 | 行高変更ポイント | ドラッグして行高変更
 | コントロール全体 | 移動ドラッグ
 | コントロール全体 | コピードラッグ
 | コントロール全体 | ドロップ拒否


タイム スケールのスクロール

キーボードでの操作

いずれも Alt キーとの組み合わせで操作します。

キー操作 | 動作
Alt + ← | 中区分の目盛りで１目盛り分左にスクロールします。
Alt + → | 中区分の目盛りで１目盛り分右にスクロールします。
Alt + PageUp | １画面分左にスクロールします。
Alt + PageDown | １画面分右にスクロールします。

マウスでの操作

水平スクロール バーを操作します。

マウス操作 | 動作
左の矢印ボタン | 中区分の目盛りで１目盛り分左にスクロールします。
右の矢印ボタン | 中区分の目盛りで１目盛り分右にスクロールします。
スクロール バー シャフト | １画面分横スクロールします。左の矢印ボタンとスクロール バーのつまみの間をクリックすると、１画面分左にスクロールし、右の矢印ボタンとスクロール バーのつまみの間をクリックすると、１画面分右にスクロールします。押しつづけると、連続で横に画面スクロールします。
スクロール バーのつまみ | 左方向にドラッグすると連動して左にスクロールします。右方向にドラッグすると連動して右にスクロールします。


アイテムのスクロール

キーボードでの操作

アイテムのスクロールを直接の目的としたキー操作はありません。キー操作でのカレント セルの移動において、カレント セルが画面の外に移動して見えなくなる場合に、カレント セルが見えるように自動的にアイテムをスクロールします。カレント セルの移動方法については、「カレント セルの移動」を参照してください。

マウスでの操作

垂直スクロール バーを操作します。

マウス操作 | 動作
上の矢印ボタン | １アイテム分上にスクロールします。
下の矢印ボタン | １アイテム分下にスクロールします。
スクロール バー シャフト | １画面分縦スクロールします。上の矢印ボタンとスクロール バーのつまみの間をクリックすると、１画面分上にスクロールし、下の矢印ボタンとスクロール バーのつまみの間をクリックすると、１画面分下にスクロールします。押しつづけると、連続で縦に画面スクロールします。
スクロール バーのつまみ | 上方向にドラッグすると連動して上にスクロールします。下方向にドラッグすると連動して下にスクロールします。


カレント セルの移動

キーボードでの操作

フォーカスを取得中で、いずれかのセルが選択されている時に操作できます。

キー操作 | 動作
← | １つ左のセルに移動します。
→ | １つ右のセルに移動します。
↑ | １つ上のセルに移動します。
↓ | １つ下のセルに移動します。
PageUp | １画面分上のセルに移動します。
PageDown | １画面分下のセルに移動します。
Ctrl + ↑ | 列は変えずに先頭のアイテムに移動します。
Ctrl + ↓ | 列は変えずに末尾のアイテムに移動します。

マウスでの操作

マウスでの操作はありません。


セル編集

セル編集の開始

キーボードでの操作

フォーカスを取得中で、いずれかのセルが選択されている時に次の操作が有効です。

キー操作 | 動作
Enter | セルの上にセル編集ウィンドウを表示し、セル編集を開始します。
マウスでの操作
マウス操作 | 動作
ダブル クリック | ダブル クリックしたセルの上にセル編集ウィンドウを表示し、セル編集を開始します。

セル編集ウィンドウでの操作

キーボードでの操作

標準的なテキスト ボックスと異なる操作について説明します。

キー操作 | 動作
Enter | セル編集ウィンドウを閉じ、編集内容をセルに設定してセル編集を終了します。
Cancel | セル編集ウィンドウを閉じ、編集内容を破棄してセル編集を終了します。
Ctrl + Enter | 改行を入力します。

マウスでの操作
マウス操作 | 動作
クリック | 画面上でセル編集ウィンドウ以外の場所をクリックすると、セル編集ウィンドウを閉じ、編集内容をセルに設定してセル編集を終了します。


ピースの追加

キーボードでの操作

キーボードでの操作はありません。

マウスでの操作

ピースの追加操作は、ピース ペイン上にマウス ポインタを移動した際に、マウス ポインタの形状が＋印になっているときに行うことができます。

1.ピースを追加したいアイテムのピース ペイン上の、開始日時（又は終了日時）にしたい時間にマウス ポインタを合わせます。

2.マウスの左ボタンを押して、終了日時（又は開始日時）にしたい時間まで水平方向にドラッグします。希望の時間が画面に表示されていない場合は、ピース ペインの左端か右端付近にマウス ポインタをドラッグしたまま近づけると発生する自動スクロールを利用して、希望の時間までドラッグを続けます。

3.マウスの左ボタンを離すと、ピースの追加が完了します。

ドラッグ中にドラッグ操作を取り消したい場合は、 Cancel キーを押すか、又はマウスの右ボタンを押します。


ピースの選択

キーボードでの操作

キーボードでの操作はありません。

マウスでの操作

選択したいピース上にマウス ポインタを移動してクリックします。

すでにピースを１つ1以上選択している状態で、他のピースの選択したり選択を解除するには、Shift キーを押しながらピースをクリックします。

希望の時間が画面に表示されていない場合は、ピース ペインの左端か右端付近にマウス ポインタをドラッグしたまま近づけると発生する自動スクロールを利用して、希望の時間までドラッグを続けます。


ピースのラバー バンド選択

キーボードでの操作

キーボードでの操作はありません。

マウスでの操作

ピースのラバー バンド選択は、ピース ペイン上にマウス ポインタを移動した際に、マウス ポインタの形状が標準の矢印カーソルになっているときに行うことができます。

選択したいピース全体をドラッグで囲みます。ドラッグ枠（ラバー バンド）の中に一部が触れているピースが選択されます。選択したい全てのピースが画面に表示されていない場合は、ピース ペインの左端か右端付近にマウス ポインタをドラッグしたまま近づけると発生する、自動スクロールを利用して選択したいピースが現れるまでドラッグを続けます。

ドラッグ中にドラッグ操作を取り消したい場合は、 Cancel キーを押すか、又はマウスの右ボタンを押します。


ピースの移動

キーボードでの操作

キーボードでの操作はありません。

マウスでの操作

1.移動したいピースにマウス ポインタを合わせます。

2.マウスの左ボタンを押して、希望の時間まで水平方向にドラッグします。希望の時間が画面に表示されていない場合は、ピース ペインの左端か右端付近にマウス ポインタをドラッグしたまま近づけると発生する、自動スクロールを利用して希望の時間までドラッグを続けます。

3.マウスの左ボタンを離すと、ピースの移動が完了します。

ドラッグ中にドラッグ操作を取り消したい場合は、 Cancel キーを押すか、又はマウスの右ボタンを押します。


ピースの時間変更

キーボードでの操作

キーボードでの操作はありません。

マウスでの操作

1.時間を変更したいピースの開始ポイント(又は終了ポイント)にマウス ポインタを合わせます。

2.マウスの左ボタンを押して、希望の時間まで水平方向にドラッグします。希望の時間が画面に表示されていない場合は、ピース ペインの左端か右端付近にマウス ポインタをドラッグしたまま近づけると発生する、自動的スクロールを利用して、希望の時間までドラッグを続けます。

3.マウスの左ボタンを離すと、ピースの開始日時(又は終了日時)の変更が完了します。

ドラッグ中にドラッグ操作を取り消したい場合は、 Cancel キーを押すか、又はマウスの右ボタンを押します。


OLE ドラッグ アンド ドロップ

キーボードでの操作

キーボードでの操作はありません。

マウスでの操作

1.OLE ドラッグ アンド ドロップ操作をしたいピースにマウス ポインタを合わせます。

2.マウスの左ボタンを押して、ドロップしたい場所までドラッグします。希望の場所が画面に表示されていない場合は、自動スクロールを利用して希望の場所までドラッグを続けます。水平方向の自動スクロールは、ピース ペインの左端か右端付近にマウス ポインタを移動すると発生し、垂直方向の自動スクロールは、ピース ペインの上端、又は水平スクロール バーの上に移動すると発生します。

3.マウスの左ボタンを離すと、 OLE ドラッグ アンド ドロップ操作が完了します。

ドラッグ中にドラッグ操作を取り消したい場合は、 Cancel キーを押すか、又はマウスの右ボタンを押します。

他のコントロールやアプリケーションにドロップするには、ドラッグしたままタイム ビュー コントロールの外までマウス ポインタを移動して、目的のコントロールやアプリケーションの上で、マウスの左ボタンを離します。


行高の変更

キーボードでの操作

キーボードでの操作はありません。

マウスでの操作

行高変更ポイントにマウス ポインタを合わせてマウスの左ボタンを押して垂直方向にドラッグ操作を行い、希望の高さを示す場所で左ボタンを離すとドラッグ操作が完了し、行高が変更されます。

行高変更ポイントにマウス ポインタを合わせて、マウスの左ボタンをダブル クリックすると、すべてのピースの中で、ピース キャプションも含めて一番表示の高さが高いピースの全体が表示される高さに自動調整します。

ドラッグ中にドラッグ操作を取り消したい場合は、 Cancel キーを押すか、又はマウスの右ボタンを押します。


列幅の変更

キーボードでの操作

キーボードでの操作はありません。

マウスでの操作

列幅変更ポイントにマウス ポインタを合わせてマウスの左ボタンを押して水平方向にドラッグ操作を行い、希望の幅を示す場所で左ボタンを離すとドラッグ操作が完了し、列幅が変更されます。

列幅変更ポイントにマウス ポインタを合わせて、マウスの左ボタンをダブル クリックすると、セルの内容で１番長い内容がすべて見えるように、列幅を自動調整します。

ドラッグ中にドラッグ操作を取り消したい場合は、 Cancel キーを押すか、又はマウスの右ボタンを押します。


目盛り幅の変更

キーボードでの操作

キーボードでの操作はありません。

マウスでの操作

目盛り幅変更ポイントにマウス ポインタを合わせてマウスの左ボタンを押して水平方向にドラッグ操作を行い、希望の幅を示す場所で左ボタンを離すとドラッグ操作が完了し、目盛り幅が変更されます。

ドラッグ中にドラッグ操作を取り消したい場合は、 Cancel キーを押すか、又はマウスの右ボタンを押します。


最新製品情報について

ナルボ製品の最新情報は、弊社ホームページの製品情報をご覧ください。


Knowlbo OCX製品のバージョンについて

Knowlbo(R)/OCX製品のバージョンについて

Knowlbo(R)/OCX製品のバージョンについて

Knowlbo(R)/OCX製品は、プロダクト・バージョンとデベロップ・バージョンを持ちます。

Version <Mojor>.<Minor> R<Revision>

<Mojor>：プロダクトバージョンです。

<Minor>：同一プロダクトにおけるマイナーバージョン（改善版）です。

<Revision>：障害を含むリリースバージョン（対応版）です。

プロダクトバージョン

プロダクトバージョンは、その製品を通して普遍的なバージョンであり、各種マテリアル、製品カタログ、および製品広告に表示されます。

例：Version 2

デベロップバージョン

デベロップバージョンは開発バージョンであり、製品のアップデートバージョンとして製品におけるマイナーバージョン（改善版）、およびリリースバージョン（対応版）を識別します。

例：Version 2.0 R3

コンポーネント・バージョン

コンポーネントバージョンは複数のコンポーネントを含む製品において、各コンポーネント別のデベロップバージョンであり、（製品）デベロップバージョンとは独立して管理されます。各コンポーネントのバージョン情報ダイアログに表示されます。（製品が単一コンポーネントである場合は、デベロップバージョンと同一になります。）

マイナーバージョンアップのご案内

当製品のマイナーバージョンは、お客様からのご要望が多く、またご要望の強いもののなかから、比較的小規模なものを選び改善したバージョンです。

改善内容とアップデートはアップデータダウンロードページに掲載いたします。

マイナーバージョンのアップデートは無料です。必要に応じてホームページからダウンロードしてご利用ください。


プロジェクトへの組み込みと削除について

Visual Basicの場合

Visual Basicのプロジェクトへの組み込み

タイム ビューのプロジェクトへの組み込みは、以下の手順で行います。

(１)Visual Basicの「プロジェクト(P)」メニューから「コンポーネント(C)」を選択します。

(２)「コントロール」タグ内リストボックスからタイム ビュー コントロールを選択します。タイム ビュー コントロールの名称は以下のように表示されます。

表示される名称 | Knowlbo/OCX Time View 3.0
コントロール | KnTView.OCX

(３)タイム ビュー コントロールのチェックボックスをチェックし「ＯＫ」ボタンをクリックします。

(４)ツールボックスにタイム ビュー コントロールのアイコンが表示されれば、プロジェクトへの組み込みは完了です。

Visual Basicのプロジェクトからの削除

タイム ビューのプロジェクトからの削除は、以下の手順で行います。

(１)フォーム上からコントロールを削除します。

(２)Visual Basicの「プロジェクト(P)」メニューから「コンポーネント(C)」を選択します。

(３)「コントロール」タグ内リストボックスからタイム ビュー コントロールを選択します。

(４)タイム ビュー コントロールのチェックボックスを未チェック状態にして「ＯＫ」ボタンをクリックします。

(５)ツールボックスからタイム ビュー コントロールのアイコンが削除されれば、プロジェクトからの削除は完了です。

Visual .NETの場合

Visual .NETのプロジェクトへの組み込み

タイム ビューのプロジェクトへの組み込みは、以下の手順で行います。

(１)Visual .NETの「プロジェクト(P)」メニューから「参照の追加(R)」を選択します。

(２)「COM」タグ内リストボックスからタイム ビュー コントロールを選択し、「選択(E)」ボタンをクリックします。タイム ビュー コントロールの名称は以下のように表示されます。

コンポーネント名 | Knowlbo/OCX Time View 3.0
TypeLibバージョン | 3.0

(３)選択されたコンポーネント(S)リスト部にタイム ビュー コントロールが追加されていることを確認し、「OK」ボタンをクリックします。ソリューション エクスプローラーの参照設定にタイム ビュー コントロール（KnTViewLib）が追加表示されれば、プロジェクトへの組み込みは完了です。

Visual .NETのプロジェクトからの削除

タイム ビューのプロジェクトからの削除は、以下の手順で行います。

(１)Visual .NETのソリューション エクスプローラーの参照設定に表示されているタイム ビュー コントロール（KnTViewLib）を選択し、「編集(E)」メニューから「削除」を選択します。

(２)ソリューション エクスプローラーの参照設定にタイム ビュー コントロール（KnTViewLib）の表示が削除されれば、プロジェクトからの削除は完了です。


ファイルの配布について

ランタイム時のファイルの配布について

タイム ビュー Version3は、その開発用インストールＰＣ１台につき１ライセンスを必要とします。

また、本製品を組み込んだアプリケーションを配布する場合、ランタイムライセンスが必要となります。ランタイムライセンスは、アプリケーション配布PC台数分が必要です。お客様がご購入された本製品には、開発ライセンス（１ライセンス）の他、ランタイムライセンスを１０ライセンス含んでおります。追加の開発もしくはランタイムライセンスが必要な場合は、弊社ホームページのライセンスオプションをご覧いただくか、あるいは、カスタマ・コミュニケーションズまでご連絡ください。

ActiveXコントロールを使用したアプリケーションをその他のシステムで実行させるためには、その実行に先立ち、使用しているActiveXコントロールのシステム登録を必要とします。通常、アプリケーションのセットアッププログラムを作成し、これに対応します。

Visual Basic付属のディストリビューションウィザードなどのインストーラ作成ツールを利用することで、ActiveXコントロールの登録を含むセットアッププログラムを作成することが可能です。

また、ActiveXコントロールのシステム登録ツール"REGSVR32.EXE"により、手動で登録することも可能です。コマンドプロンプトもしくは「ファイル名を指定して実行」ダイアログより、以下のようにコマンドを実行してください。

REGSRV32 "<パス名>\TimeViewV3\KnTView.OCX"

ご注意

本製品のご使用にあたり、上記事項以外は、お客様と弊社との契約事項は特にありません。ただし、「ソフトウェア使用許諾契約」に記載している制限事項は、厳守してください。

Visual Basicのディストリビューションウィザード（セットアップウィザード）使用後の注意

ディストリビューションウィザードなどを利用して作成したセットアッププログラムを、開発用PCで実行し、インストールを行うと、その後、ご利用の開発環境でタイムビュー が正常に動作しないことがあります。

これは、セットアッププログラムがActiveXコントロールをWindowsのシステムディレクトリにコピーし、システム環境に登録（レジストリへの登録）を行うためです。

この場合には、タイム ビュー をインストールしたディレクトリ下のActiveXコントロールで再登録してください。

登録は方法は、上記と同様になります。


テクニカルサポートについて

Knowlbo(R)/OCX製品のご使用中に、このオンラインヘルプやインストールディレクトリ下にある「README.WRI」 に記載されている内容で解決できない問題が発生した場合には、弊社カスタマ・コミュニケーションズまでお問い合わせください。お問い合わせの際には、下記事項を確認の上、電子メールにてお送りくださるようお願い申し上げます。また、弊社ホームページにオンラインサポートページも設けております。（電話、ファックスなどによるテクニカルなお問い合わせは、お受けしていません。）

なお、お問い合わせいただいた内容により、回答に数日かかることがございます。あらかじめご了承ください。

また、寄せられたご質問については、他のお客様の参考とするため、断りなく雑誌やその他メディア、弊社ホームページなどで公開させていただくことがあります。

お送りいただいたリストやファイルなどで公開できないものについては、その旨を明示しておいてください。

また、お送りいただいたリスト，ファイルについては原則として返却いたしません。ご了承ください。

コントロールコンテナの使用方法やプログラミングに関するご質問などにつきましては、ご容赦いただいております。あらかじめご了承ください。

お問い合わせの場合に必要な情報

お問い合わせの場合、お手数ですが下記事項を電子メールに明記してお問い合わせください。

（法人の場合）法人名、部署名
ユーザ名
連絡先住所
電話番号
FAX番号
電子メールアドレス
Knowlbo(R)/OCX製品名および製品のバージョン

エクスプローラで製品を選択し、右クリックをして表示されるメニューからプロパティを選択すると製品のプロパティダイアログが表示されます。そこに記載されているファイルバージョンをご明記ください。

シリアルNO
コントロール・コンテナ製品名、バージョン
OS名、バージョン
使用PC機種名
お問い合わせ内容


PiecePaneTrackingEnd イベント

ここにトピック テキストを入力します。


BeforeVerScroll イベント の例

１アイテム分下にスクロールしようと場合、１画面分したにスクロールするサンプルです。

Private Sub KnTView1_BeforeVerScroll(ByVal Cancel As KnTViewLib.ReturnBoolean, ByVal VerScroll As Integer, ByVal NewViewTopItem As KnTViewLib.ReturnLong)

If VerScroll = tivScrollLineDown Then

Cancel.Value = True

KnTView1.DoScroll tivScrollPageDown, tivScrollNone

End If

End Sub


AfterCellEdit イベント の例

編集後のセルの値が数値以外の場合、編集した内容を元に戻すサンプルです。

Private Sub KnTView1_AfterCellEdit(ByVal Cancel As KnTViewLib.ReturnBoolean, ByVal NewValue As KnTViewLib.ReturnVariant)

If IsNumeric(NewValue) = False Then

Cancel.Value = True

End If

End Sub


AfterCellSelect イベント の例

フォーカスのあるセルの背景色を緑色にするサンプルです。

Private clCurCell As Cell

Private Sub Form_Load()

Set clCurCell = KnTView1.Cell

     clCurCell.Fill.BackColor = vbGreen

End Sub

Private Sub KnTView1_AfterCellSelect()

clCurCell.Fill.BackColor = vbWhite

KnTView1.Cell.Fill.BackColor = vbGreen

Set clCurCell = KnTView1.Cell

End Sub


AfterHorScroll イベント の例

スクロール後ViewTopTimeをメッセージボックスで表示するサンプルです。

Private Sub KnTView1_AfterHorScroll(ByVal HorScroll As Integer)

MsgBox KnTView1.ViewTopTime

End Sub


AfterPieceAdd イベント の例

デフォルトのピースの追加処理を取り消して、ユーザ定義のスタイルのピースをするサンプルです。

Private Sub KnTView1_AfterPieceAdd(ByVal Cancel As KnTViewLib.ReturnBoolean, ByVal Start As KnTViewLib.ReturnDate, ByVal Finish As KnTViewLib.ReturnDate, ByVal Item As KnTViewLib.Item)

'デフォルトのピースの追加処理を取り消します

Cancel.Value = True

'下記でユーザ定義のスタイルのピースを追加します

    Dim pce As Piece

Set pce = Item.Pieces.Add

pce.Start = Start

pce.Finish = Finish

pce.BarShape.Shape = tivBarShapeLine

pce.StartShape.Shape = tivPointShapeTriangleUp

pce.FinishShape.Shape = tivPointShapeTriangleUp

End Sub

参考サンプル

・Appearance、Progress、SpecialTime、DragDrop、HitTest


AfterPieceMove イベント の例

変更確認メッセージボックスを表示して、「いいえ」を選択した場合、移動したピースを元に戻すサンプルです。

Private Sub KnTView1_AfterPieceMove(ByVal Cancel As KnTViewLib.ReturnBoolean, ByVal Minutes As Long)

Dim nRetVal As Integer

nRetVal = MsgBox("変更しますか？", vbYesNo, "変更確認")

If nRetVal = vbNo Then

Cancel.Value = True

End If

End Sub


AfterPieceSelect イベント の例

選択したピースの開始時間をメッセージボックスで表示をするサンプルです。

Private Sub KnTView1_AfterPieceSelect()

Dim strStartTime As String

KnTView1.PieceSelectMode = tivSelectSingle

strStartTime = KnTView1.SelectedPieces(1).Start

MsgBox "開始時間:" & strStartTime

End Sub


AfterPieceTimeChange イベント の例

マウス操作でピースの開始または終了時間を変更した際にメッセージボックスで何時から何時に変更されたかを表示するサンプルです。

Private Sub KnTView1_AfterPieceSelect()

With KnTView1.SelectedPieces(1)

.Value = .Start & "," & .Finish

End With

End Sub

Private Sub KnTView1_AfterPieceTimeChange(ByVal Cancel As KnTViewLib.ReturnBoolean, ByVal Which As Integer, ByVal Time As KnTViewLib.ReturnDate)

Dim strTemp As String

Dim strValue As String

strValue = KnTView1.SelectedPieces(1).Value

If Which = tivStart Then

strTemp = Left(strValue, InStr(strValue, ",") - 1)

MsgBox "開始時間：" & strTemp & "→" & Time.Value

Else

strTemp = Mid(strValue, InStr(strValue, ",") + 1)

MsgBox "終了時間：" & strTemp & "→" & Time.Value

End If

End Sub


AfterVerScroll イベント の例

スクロール後ViewTopItemをメッセージボックスで表示するサンプルです。

Private Sub KnTView1_AfterVerScroll(ByVal VerScroll As Integer)

MsgBox KnTView1.ViewTopItem

End Sub


BeforeCellEdit イベント の例


BeforeHorScroll イベント の例

ポジションのドラッグによるスクロールを禁止するサンプルです。

Private Sub KnTView1_BeforeHorScroll(ByVal Cancel As KnTViewLib.ReturnBoolean, ByVal VerScroll As Integer, ByVal NewViewTopItem As KnTViewLib.ReturnLong)

If VerScroll = tivScrollThumbTrack Then

Cancel.Value = True

End If

End Sub


BeforePieceAdd イベント の例

１行目で、追加するピースの開始時間が2001/3/18 22:00以降の場合、追加処理を取り消すサンプルです。

Private Sub KnTView1_BeforePieceAdd(ByVal Cancel As KnTViewLib.ReturnBoolean, ByVal Time As Date, ByVal Item As KnTViewLib.Item)

If Item.Index = 1 And Time > CDate("2001/3/18 22:00") Then

Cancel.Value = True

End If

End Sub


BeforePieceMove イベント の例

ユーザ操作で移動しようとするピースのPieceオブジェクトのValue値が９９の場合、移動処理を取り消すサンプルです。

Private Sub KnTView1_BeforePieceMove(ByVal Cancel As KnTViewLib.ReturnBoolean)

With KnTView1.SelectedPieces(1)

If .Value = 99 Then

Cancel.Value = True

End If

End With

End Sub


BeforePieceTimeChange イベント の例

開始時間をマウスで変更しようした場合、メッセージボックスを出して、変更を取り消すをするサンプルです。

Private Sub KnTView1_BeforePieceTimeChange(ByVal Cancel As KnTViewLib.ReturnBoolean, ByVal Which As Integer)

If Which = tivStart Then

MsgBox "開始時間の変更はできません"

Cancel.Value = True

End If

End Sub


Click イベント の例

タイムビューコントロールをクリックするとバージョン情報ダイアログを表示させるサンプルです。

Private Sub KnTView1_Click()

KnTView1.AboutBox

End Sub


Compare イベント の例

以下は、タイムビューが用意しているソートの条件をユーザが定義するサンプルです。

'Compareイベント内でソートの条件を定義してソートを行います

KnTView1.Sort 1, 10, 1, 3, 5, 0,True

Private Sub KnTView1_Compare(ByVal Swap As ReturnBoolean, ByVal LeftItem As KnTViewLib.Item, ByVal RightItem As KnTViewLib.Item)

'ピースの開始日時が早い順にソート

If LeftItem.Pieces(1).Start < RightItem.Pieces(1).Start Then

Swap = True

Else

Swap = False

End If

End Sub

参考サンプル

・Sort


DblClick イベント の例

ダブルクリックしたピースの背景色を黒色にするサンプルです。

'タイム ビュー コントロール内のピースを１つだけ選択可能にします

KnTView1.PieceSelectMode = tivSelectSingle

Private Sub KnTView1_DblClick()

'ダブルクリックの際にピースは選択状態になるので、SelectedPiecesコレクションでダブルクリックされたピースを判別します

If KnTView1.SelectedPieces.Count > 0 Then

KnTView1.SelectedPieces(1).BarShape.Fill.BackColor = vbBlack

End If

End Sub

参考サンプル

・DragDrop


DragTipFormat イベント の例

以下は、ピースのラバーバンド選択操作を行う場合、その範囲の開始日時、終了日時、開始行、終了行をDragTipとして表示するサンプルです。

Private Sub KnTView1_DragTipFormat(ByVal DragPattern As KnTViewLib.TivDragPattern, ByVal StartTime As Date, ByVal FinishTime As Date, ByVal StartIndex As Long, ByVal FinishIndex As Long, ByVal Tip As KnTViewLib.ReturnString)

'ピースのラバーバンド選択操作を行う場合、その範囲の開始日時、終了日時、開始行、終了行をDragTipとして表示します

If DragPattern = tivDragPatternRubberBand Then

Tip = "行№:" & Format(StartIndex, "###") _

& "開始日時:" & Format(StartTime, "yyyy/mm/dd HH:nn") _

& vbCrLf _

& "行№:" & Format(FinishIndex, "###") _

& "終了日時:" & Format(FinishTime, "yyyy/mm/dd HH:nn")

End If

End Sub

参考サンプル

・DragDrop


EndPrint イベントの例

印刷結果をメッセージボックスで表示するサンプルです。

Private Sub KnTView1_EndPrint(ByVal PrintMethod As KnTViewLib.TivPrintMethod, ByVal PrintResult As KnTViewLib.TivPrintResult, ByVal PrintDetail As KnTViewLib.TivPrintDetail)

Dim strMsg As String

Select Case (PrintResult)

Case tivPrintDone:

strMsg = "印刷は正常に終了しました"

Case tivPrintCancel:

strMsg = "ユーザによるキャンセルが行われました"

Case tivPrintAbort:

strMsg = "エラーが発生しました"

End Select

MsgBox strMsg

End Sub


HeaderPrintイベントの例

HeaderPrint イベント、FooterPrint イベント の例

Introductionサンプルの該当箇所を参照ください。


KeyDown イベント の例

Ctrl+Aでタイムビュー上のすべてのピースを選択状態にするサンプルです。

Private Sub KnTView1_KeyDown(KeyCode As KnTViewLib.ReturnInteger, Shift As Integer)

Dim itm As Item

If KeyCode = vbKeyA And (Shift And 2) Then

For Each itm In KnTView1.Items

itm.Pieces.Selected = True

Next

End If

End Sub

参考サンプル

・Introduction,Merge


KeyPress イベント の例

タイムビュー上で入力された小文字の英字（a～z）を大文字（A～Z）に変換するサンプルです。

Private Sub KnTView1_KeyPress(KeyAscii As KnTViewLib.ReturnInteger)

If KeyAscii >= Asc("a") And KeyAscii <= Asc("z") Then

KeyAscii = KeyAscii - 32

End If

End Sub


KeyUp イベント の例

F1キーを押したときにときにカレントセルの背景色を赤にする（キーを離すと元に戻る）サンプルです。

Public vtCurColor As Variant

Private Sub KnTView1_KeyDown(KeyCode As KnTViewLib.ReturnInteger, Shift As Integer)

If KeyCode = vbKeyF1 Then

vtCurColor = KnTView1.cell.Fill.BackColor

KnTView1.cell.Fill.BackColor = vbRed

End If

End Sub

Private Sub KnTView1_KeyUp(KeyCode As KnTViewLib.ReturnInteger, Shift As Integer)

If KeyCode = vbKeyF1 Then

KnTView1.cell.Fill.BackColor = vtCurColor

End If

End Sub


MouseDown イベント の例

カラムヘッダ上で右クリックするとポップアップメニューを表示するサンプルです。

Private Sub KnTView1_MouseDown(Button As Integer, Shift As Integer, X As Single, Y As Single)

Dim cntrX As Single

Dim cntrY As Single

cntrX = ScaleX(X, vbTwips, Me.ScaleMode)

cntrY = ScaleY(Y, vbTwips, Me.ScaleMode)

Set htrSav = KnTView1.HitTest(cntrX, cntrY)

Select Case htrSav.ObjectType

Case tivColumnHeader

If Button = vbRightButton Then

PopupMenu mnuColumnHeader, _

vbPopupMenuCenterAlign Or vbPopupMenuRightButton

End If

End Select

End Sub

参考サンプル

・Merge、Sort


MouseMove イベント の例

タイムスケール上でマウスを移動させた場合、マウスカーソル上の時間をステータスバーに表示するサンプルです。

Private Sub KnTView1_MouseMove(Button As Integer, Shift As Integer, X As Single, Y As Single)

Dim cntrX As Single

Dim cntrY As Single

cntrX = ScaleX(X, vbTwips, Me.ScaleMode)

cntrY = ScaleY(Y, vbTwips, Me.ScaleMode)

Dim htr As HitTestResult

Set htr = KnTView1.HitTest(cntrX, cntrY)

Dim strTrace As String

If htr.ObjectType = tivTimeScaleThen

strTrace = "ﾀｲﾑｽｹｰﾙ。時間は、" & CStr(htr.Time) & "。"

End If

'デフォルトのピースの追加処理を取り消します

StatusBar1.Panels(1).Text = strTrace

End Sub

参考サンプル

・HitTest、Merge


OLECompleteDrag イベント の例

OLEDragDropイベントで行われたドロップ操作に結果をユーザにメッセージボックスで通知するサンプルです。

Private Sub KnTView1_OLECompleteDrag(ByVal Effect As KnTViewLib.ReturnLong)

Dim strResult As String

Select Case (Effect)

Case vbDropEffectNone:

strResult = "ドロップ中止"

Case vbDropEffectCopy:

strResult = "データはコピーされました"

Case vbDropEffectMove:

strResult = "データは移動されました"

End Select

MsgBox strResult

End Sub


OLEDragOverイベントの例

OLEDragOver イベント、OLEGiveFeedBackイベント の例

ドラッグ中のマウスカーソルをドラッグ可能な場所は矢印、不可の場所は禁止マークで表示し、

偶数のインデックスをもつアイテムのピースペイン上ではドロップを禁止するサンプルです。

Private Sub KnTView1_OLEDragOver(Data As KnTViewLib.DataObject, ByVal Effect As KnTViewLib.ReturnLong, Button As Integer, Shift As Integer, x As Single, y As Single, ByVal State As KnTViewLib.ReturnInteger, ByVal LocalDragDrop As Boolean)

Dim htr As HitTestResult

Set htr = KnTView1.HitTest(x, y)

If htr.ObjectType = tivPiecePane Then

If (htr.ItemIndex Mod 2) = 0 Then

Effect.Value = vbDropEffectNone

Exit Sub

End If

End If

If Shift And 2 Then

Effect.Value = vbDropEffectCopy

Else

Effect.Value = vbDropEffectMove

End If

End Sub

Private Sub KnTView1_OLEGiveFeedback(ByVal Effect As KnTViewLib.ReturnLong, ByVal DefaultCursors As KnTViewLib.ReturnBoolean)

DefaultCursors = False

If Effect = vbDropEffectNone Then

Screen.MousePointer = vbNoDrop

Else

Screen.MousePointer = vbUpArrow

End If

End Sub


OLESetData イベント の例

GetDataメソッドが呼ばれるまでDataObjectオブジェクトへの実データの設定を遅らせるサンプルです。

'OLEDragDropイベント等でGetDataメソッドが呼ばれた際にはじめてデータの実体をDataObjectに設定

'ドラッグ開始時に実データの設定を行うと、データ量が多い場合はドラッグ開始が遅れて

'表示等で都合が悪い場合、実際にドロップしてデータが要求さるときまで実データの設定を遅らせるように対応

Private Sub KnTView1_OLESetData(Data As KnTViewLib.DataObject, DataFormat As Integer)

Dim strData As String

Dim pce As Piece

strData = "Tasks"

For Each pce In KnTView1.SelectedPieces

strData = strData & "," & KnTView1.Cell(pce.ItemIndex, 2).Value & _

"," & CStr(pce.Start) & "," & CStr(pce.Finish)

Next

Data.SetData strData, DataFormat

End Sub

'ドラッグ開始時はデータ形式のみDataObjectオブジェクトに設定

Private Sub KnTView1_OLEStartDrag(Data As KnTViewLib.DataObject, ByVal AllowedEffects As KnTViewLib.ReturnLong)

Data.SetData , vbCFText

End Sub


PieceFinishイベントの例

PieceStart イベント の例

現在日時がピースの終了時間になった場合、そのピースを自動的に削除するサンプルです。

Private Sub KnTView1_PieceFinish(ByVal Piece As KnTViewLib.Piece)

Dim nIndex As Integer

Dim nItemIndex As Integer

nIndex = Piece.Index

nItemIndex = Piece.ItemIndex

KnTView1.Items(nItemIndex).Pieces.Remove nIndex

End Sub


PieceStart イベント の例

現在日時がピースの開始時間になった場合、ビープ音を鳴らして、メッセージボックスを表示させるサンプルです。

Private Sub KnTView1_PieceStart(ByVal Piece As KnTViewLib.Piece)

Beep

MsgBox "予約時間だよ"

End Sub


RequestTipText イベント の例

ツールチップを表示するサンプルです。

Private Sub KnTView1_RequestTipText(ByVal Result As KnTViewLib.HitTestResult, TipText As Variant)

'チェックボックスチェックがされていない場合は､ツールチップを表示しません

If Check1.Value = False Then

Exit Sub

End If

'ツールチップを表示します

Dim strTrace As String

Select Case Result.ObjectType

Case tivColumnHeader

strTrace = "列見出し"

Case tivCell

strTrace = "セル"

Case tivColumnWidthUIPoint

strTrace = "列幅変更ポイント"

Case tivItemHeightUIPoint

strTrace = "行高変更ポイント"

Case tivObjectNothing

strTrace = "オブジェクトなし"

Case tivPiece

strTrace = "ピース"

Case tivPieceFinish

strTrace = "ピースの終点"

Case tivPieceStart

strTrace = "ピースの始点"

Case tivPiecePane

strTrace = "ピースペイン"

Case tivTimeScale

strTrace = "タイムスケール"

Case tivWidthPerScaleUIPoint

strTrace = "目盛り幅変更ポイント"

Case Else

strTrace = ""

End Select

'表示する文字列をTipTextに代入します

TipText = strTrace

End Sub

参考サンプル

・HitTest


AllowColumnWidthChange プロパティ の例

マウス操作で列見出しの幅の変更を禁止するサンプルです。

KnTView1.AllowColumnWidthChange = False

参考サンプル

・Image


AllowItemheightChange プロパティ の例

マウス操作でアイテムの高さの変更を禁止するサンプルです。

KnTView1.AllowItemHeightChange = False


AllowPieceAddプロパティの例

AllowPieceAdd、AllowPieceMove、AllowTimeChange プロパティ の例

マウス操作でのピースの追加および移動、開始終了時間の変更を禁止して読み取り専用のタイムビュー画面を作成するサンプルです。

KnTView1.AllowPieceAdd = False

KnTView1.AllowPieceMove = False

KnTView1.AllowPieceTimeChange = False

参考サンプル

・DragDrop


AllowWidthPerScaleChange プロパティ の例

マウス操作による中区分の１目盛りの幅の変更を禁止するサンプルです。

KnTView1.AllowWidthPerScaleChange = False


Appearance プロパティ の例

タイム ビュー コントロールの境界線をフラット、実線で描画するサンプルです。

KnTView1.Appearance = tivAppearanceFlat

KnTView1.BorderStyle = 1


BottomBorder プロパティ の例

タイムスケールの下辺境界線を赤色の二点鎖線に設定するサンプルです。

Dim tscale As TimeScale

Set tscale = KnTView1.TimeScale

tscale.BottomBorder.Color = vbRed

tscale.BottomBorder.Style = tivLineDashDotDot

参考サンプル

・Appearance、Introduction


Captions プロパティ の例

ピースにキャプションを追加するサンプルです。

'ピース設定

Dim pce As Piece

Dim prgs As KnTViewLib.Progress

Dim pcap As PieceCaption

'１つ目 達成率をパーセントで指定

Set pce = KnTView1.Items(1).Pieces.Add

pce.Start = "2000/8/1"

pce.Finish = "2000/8/4"

Set prgs = pce.Progresses.Add

prgs.PercentTo = 0.6

Set pcap = pce.Captions.Add

pcap.Position = tivPieceRight

pcap.Type = tivPieceCaptionProgress1To

参考サンプル

・HitTest、Piece、Intorduction、Appearance、Progress、DragDrop、Image


CellPaneWidth プロパティ の例

セルペイン幅を220に設定するサンプルです。

KnTView1.CellPaneWidth = 220

参考サンプル

・Introduction、MultiColumn


Cells プロパティ の例

セルに値を設定するサンプルです。

For i = 1 To 20

Set itm = KnTView1.Items.Add

itm.Cells(1).Value = "ﾀｽｸ " & Chr(64 + i)

itm.Cells(2).Value = "ﾘｿｰｽ " & CStr(i)

Next


CellSelectMode プロパティ の例

セルの選択を禁止するサンプルです。

KnTView1.CellSelectMode = tivCellSelectNone


Color（LineFormatオブジェクト）プロパティの例

Color（LineFormatオブジェクト） プロパティ、Lineプロパティ の例

小区分のおよび補助目盛りのラインの設定を行うサンプルです。

KnTView1.TimeScale.Small.Line.Color = vbBlue '小区分の線色を青色に設定

KnTView1.TimeScale.Small.Line.Style = tivLineSolid '小区分の線種に実線に設定

KnTView1.TimeScale.Small.SubLine.Color = vbRed '小区分の補助目盛りの線色を赤色に設定

KnTView1.TimeScale.Small.SubLine.Style = tivLineDot '小区分の補助目盛りの線種を短い破線に設定


ColumnHeadersプロパティの例

ColumnHeaders プロパティ、Fill プロパティ、Pattern プロパティ、 Color プロパティ、RightBorder プロパティ

ForeColor プロパティ、BackColor プロパティ、HorAlign プロパティ、 VerAlign プロパティ、Style プロパティ

Textプロパティ（ColumnHeaderオブジェクト）の例

カラムヘッダに各種設定を行うサンプルです。

    '１列目のカラムヘッダオブジェクトを取得します

    Set ch = KnTView1.ColumnHeaders(1)

ch.Text = "地域"

ch.MergeMode = tivMergeRestrict

ch.Width = ScaleX(75, vbPixels, Me.ScaleMode)

ch.Fill.Pattern = tivPatternHorizontalGradation

ch.Fill.ForeColor = vbGreen

ch.Fill.BackColor = vbBlue

ch.Color = RGB(255, 255, 255)

ch.HorAlign = tivTextHorAlignCenter

    ch.VerAlign = tivTextVerAlignTop

ch.RightBorder.Style = tivLineNull

参考サンプル

・


Width、ColumnWidthModeプロパティの例

Width (ColumnHeader オブジェクト)、ColumnWIdthMode プロパティ の例

ボタンを押しすことに１列目のカラムの幅を自動と手動（行高 400）で切り替えるサンプルです。

Private Sub Command1_Click()

With KnTView1.ColumnHeaders(1)

If .ColumnWidthMode = tivAoutomatic Then

.ColumnWidthMode = tivManual

. Width = 400

Else

.ColumnWIdthMode = tivAoutomatic

End if

End With

End Sub

参考サンプル

・Appearance


CｌipDragToScaleプロパティの例

ClipDragToScale プロパティ の例

マウス操作によるピース編集時に、ドラッグをタイムスケールの目盛範囲に限定するサンプルです。

KnTView1.ClipDragToScale = True


CurrentTimeプロパティの例

CurrentTime プロパティ、Timeプロパティ（CurrentTimeオブジェクト）、Lineプロパティ（CurrentTimeオブジェクト）

UpdateModeプロパティの例

現在日時に関する設定を行うサンプルです。

'現在日時線の更新を手動モードに設定します

KnTView1.CurrentTime.UpdateMode = tivManual

'現在日時線を表示する位置を示す日時を設定

KnTView1.CurrentTime.Time = "2001/8/28 15:00"

'現在日時線の線色を青に設定

KnTView1.CurrentTime.Line.Color = vbBlue

参考サンプル

・Introduction


DisableNoVerScrollプロパティの例

DisableNoVerScroll プロパティ、 DisableNoHorScroll プロパティ の例

スクロールバーが不要なときに表示を行わないサンプルです。

KnTView1.DisableNoVerScroll = False

KnTView1.DisableNoHorScroll = False


DragTip プロパティ の例

ドラッグチップのテキストの表示色を白、背景色を黒、塗りつぶし領域の塗りつぶしパターンを3Dにするサンプルです。

KnTView1.DragTip.Color = vbWhite

KnTView1.DragTip.Fill.BackColor = vbBlack

KnTView1.DragTip.Fill.Pattern = tivPattern3D


Enabled プロパティ の例

タイム ビュー コントロールに、ユーザーの操作で発生したイベントを通知しないようにするサンプルです。

KnTView1.Enabled = False


FirstDayOfWeekプロパティの例

FirstDayOfWeek プロパティ、SlidingLetter プロパティ、WidthPerScale プロパティ の例

マウス操作で列見出しの幅の変更を禁止するサンプルです。

'週の開始曜日を設定

KnTView2.TimeScale.FirstDayOfWeek = tivSaturday

    '中区分の目盛り間の幅を設定

KnTView2.TimeScale.WidthPerScale = ScaleX(80, vbPixels, Me.ScaleMode)

KnTView2.TimeScale.Large.Unit = tivScaleUnitWeek

KnTView2.TimeScale.Large.Interval = 1

KnTView2.TimeScale.Large.Format = "m/d"

'目盛り文字のスライドを行う

KnTView2.TimeScale.Large.SlidingLetter = True

KnTView2.TimeScale.Medium.Unit = tivScaleUnitDay

KnTView2.TimeScale.Medium.Interval = 1

KnTView2.TimeScale.Medium.Format = "d(ddd)"

KnTView2.TimeScale.Small.Unit = tivScaleUnitHour

KnTView2.TimeScale.Small.Interval = 12

KnTView2.TimeScale.Small.SubUnit = tivScaleUnitHour

KnTView2.TimeScale.Small.SubInterval = 0

参考サンプル

・TimeScale、


FixedColumns プロパティ の例

左から２列を固定表示するサンプルです。

KnTView1.FixedColumns = 2

参考サンプル

・Introduction、MultiColumn


Font プロパティ の例

フォントに関する設定を行うサンプルです。

'タイムスケールの大区分のフォントを太字にします

KnTView1.TimeScale.Large.Font.Bold = True

'列見出しのフォントのサイズを１５ポイントにします

KnTView1.ColumnHeaders(1).Font.Size = 15

参考サンプル

・Image、Introduction、TimeScale


HeaderHeightプロパティの例

HeaderHeight プロパティ、FooterHeightプロパティ、MarginLeftプロパティ、Orientationプロパティ、PaperSizeプロパティ

ChartBorderプロパティ、PageBreakプロパティ、 MonochromeTextプロパティ、JustClippingToScaleプロパティ

StartColumnプロパティ、StartIndexプロパティ、StartTimeプロパティ、Magnificationプロパティ、AllColumnAtFirstPage

BodyBorderプロパティの例

タイムビューの印刷の設定を行うサンプルです。

Dim pi As New PrintInfo

pi.HeaderHeight = 10 'ヘッダー高を10cmに設定

pi.FooterHeight = 10 'フッター高を10cmに設定

pi.MarginLeft = 2 '用紙の左マージンを2cmに設定

    pi.Orientation = tivPrintPortrait '用紙方向を縦方向に設定

pi.PaperSize = tivPaperA4 '用紙サイズをA4に設定

pi.ChartBorder.Style = tivLineSolid タイムビューの外枠の線種を実線に設定

pi.StartColumn = 1 '印刷対象の列指定(開始列)

pi.FinishColumn = 3　　　　　　　　　　　　　　　　　　　　　'印刷対象の列指定(終了列)

pi.StartIndex = 1 　'印刷対象の行指定(開始行)

pi.FinishIndex = 10　　　　　　　　　　　　　　　　　　　　　　'印刷対象の行指定(終了行)

    pi.StartTime = "2001/1/1" '印刷対象の時間範囲指定(開始時間)

pi.FinishTime = "2001/1/31"　　　　　　　　　　　　　　'印刷対象の時間範囲指定(終了時間)

    KnTView1.Items(10).PageBreak = True '10行で強制改頁

pi.MonochromeText = True '印刷文字列の色を白か黒にするように設定

pi.Magnification = dlgPrint.Magnification '倍率９０％で印刷

pi.JustClippingToScale = True '中区分目盛の途中での改ページ、および印刷対象外の目盛の出力を抑制するように設定

pi.AllColumnAtFirstPage = True '印刷する時間範囲の先頭時間を含むページにすべての列を印刷するように設定

   pi.BodyBorder.Style = tivLineDashDotDot　　　 　　 '印刷におけるボディを囲む線種を2点鎖線に設定

pi.BodyBorder.Color = vbYellow　　　　　　　　　　　　　'印刷におけるボディを囲む線色を黄色に設定

参考サンプル

・Introduction


Heightプロパティの例

Height プロパティ 、Width プロパティ の例

Formのサイズが変更された際、タイムビューのサイズも自動的に変更するサンプルです。

Private Sub Form_Resize()

KnTView1.Height = Me.ScaleHeight

KnTView1.Width = Me.ScaleWidth

End Sub


Hidden プロパティ の例

タイムスケールの大区分、小区分の表示、非表示を切り替えるサンプルです。

KnTView1.TimeScale.Large.Hidden = Not(KnTView1.TimeScale.Large.Hidden)

KnTView1.TimeScale.Small.Hidden = Not(KnTView1.TimeScale.Small.Hidden)

参考サンプル

・TimeScale、Piece


HideCellSelectionプロパティの例

HideCellSelectionプロパティ、HidePieceSelection プロパティ の例

タイムビューがフォーカスを失った際にセルやピースのカレント枠や選択状態の表示を行ったままにするサンプルです。

KnTView1.HideCellSelection = False

KnTView1.HidePieceSelection = False


ImagePosition プロパティ の例

セルにイメージと文字列を設定（文字列の右側にイメージ）するサンプルです。

Dim imgList As ImageList

Set imgList = KnTView1.ImageLists.Add(, "ImageList", App.Path & "\Image.bmp", RGB(255, 0, 255), 16, 16)

imgList.Images.Keys = Array("Calendar", "Trush", "Tree", "Smile")

KnTView1.Cell(1, 2).Value = "資源ごみ" & vbCrLf & "収集"

KnTView1.Cell(1, 2).Image "ImageList", "Trush"

KnTView1.Cell(1, 2).ImagePosition = tivImagePositionRight

参考サンプル

・Image、Intoroduction


Indexプロパティの例

Index プロパティ、Itemsプロパティ の例

各行のセルに値を設定するサンプルです。

For Each itm In KnTView1.Items

itm.Cells(3).Value = itm.Cells(1).Value

itm.Cells(2).Value = CStr(itm.Index)

itm.Cells(4).Value = CStr(itm.Index)

Next


ItemHeightプロパティの例

ItemHeight、ItemHeightMode プロパティ の例

ボタンを押しすことに各行の高さの指定を自動と手動（行高 200）で切り替えるサンプルです。

Private Sub Command1_Click()

If KnTView1.ItemHeightMode = tivAutomatic Then

KnTView1.ItemHeightMode = tivManual

KnTView1.ItemHeight = 200

Else

KnTView1.ItemHeightMode = tivAutomatic

End If

End Sub

参考サンプル

・Appearance,Introduction,Merge,Piece,HitTest


Key プロパティ の例

マウスでピースを追加する際にKeyプロパティを指定して、ピースを一意に認識できるように設定するサンプルです。

Private nID As Integer

Private Sub KnTView1_AfterPieceAdd(ByVal Cancel As KnTViewlib.ReturnBoolean, ByVal Start As KnTViewlib.ReturnDate, ByVal Finish As KnTViewlib.ReturnDate, ByVal Item As KnTViewlib.Item)

Cancel.Value = True

With Item.Pieces.Add

.Start = Start

.Finish = Finish

.Key = nID

End With

nID = nID + 1

End Sub


LargeLine プロパティ の例

ピースペインのタイム スケールの各区分の目盛りに対した位置に目盛り線を表示するサンプルです。

With KnTView1.PiecePane

.LargeLine.Color = RGB(163, 168, 238)

.MediumLine.Color = RGB(253, 219, 188)

.SmallLine.Color = vbRed

.SubLine.Style = tivLineDot

End With

参考サンプル

・Image、Introduction、TimeScale、Appearance、


MergeMode プロパティ の例

２列目を左列の制約つきで結合するサンプルです。

KnTView1.ColumnHeaders(2).MergeMode = tivMergeRestrict

参考サンプル

・Image、Intorduction、Merge


Misc プロパティ の例

タイム ビュー コントロールの機能を調節するプロパティ値を設定するサンプルです。

たいていの場合、デフォルトで設定されており、設定する場合もデザイン時プロパティページで行うことがほとんどなので、

コーディングで設定することは少ないと思われます。

'以下のMisc値を設定します

KnTView1.Misc = KnTView1.Misc Or tivMiscDontPrintFocus Or tivMiscHitTestBackOrder Or tivMiscHitTestBackOrder


OLEDropMode プロパティ の例

OLEドロップを禁止するサンプルです。

KnTView1.OLEDropMode = tivOLEDropNone

参考サンプル

・DragDrop


Origin プロパティ の例

タイムスケールのの目盛りの日時を決めるときの、基準日を"2000/7/31"に設定し、

基準日から第ｘ週表記で大区分を表示するサンプルです。

    Dim strViewTopTime

strViewTopTime = "2000/7/31"

'表示左端日時の設定

KnTView1.ViewTopTime = strViewTopTime

KnTView1.TimeScale.Origin = "2000/7/31"

'タイム スケールの設定

'KnTView3 - L=週1, M=日1, S=Hidden

KnTView1.TimeScale.Large.Unit = tivScaleUnitWeek

KnTView1.TimeScale.Large.Interval = 1

KnTView1.TimeScale.Large.Format = "yyyy年wwo週"

'この結果、大区分の表記は、2000/7/31を含む週が「2000年１週」となります。


PieceCaptionAdjustInView プロパティ の例

ピース バーの中に配置したキャプションの表示を、できるだけピースペイン内に表示するようにするサンプルです。

    '表示左端日時の設定

KnTView1.ViewTopTime = "2000/8/4"

'タイム スケールの設定

'KnTView3 - L=週1, M=日1, S=Hidden

KnTView1.TimeScale.Large.Unit = tivScaleUnitWeek

KnTView1.TimeScale.Large.Interval = 1

KnTView1.TimeScale.Large.Format = "yyyy年m月d日"

KnTView1.TimeScale.Medium.Unit = tivScaleUnitDay

KnTView1.TimeScale.Medium.Interval = 1

KnTView1.TimeScale.Medium.Format = "d"

KnTView1.TimeScale.Small.Unit = tivScaleUnitDay

KnTView1.TimeScale.Small.Interval = 1

KnTView1.TimeScale.Small.SubUnit = tivScaleUnitHour

KnTView1.TimeScale.Small.SubInterval = 12

    'アイテム、ピースの追加

    KnTView1.Items.Add

Set pce = KnTView1.Items(1).Pieces.Add

pce.Start = "2000/8/3"

pce.Finish = "2000/8/14"

Set pcap = pce.Captions.Add

pcap.Position = tivPieceCenter

pcap.Type = tivPieceCaptionText

pcap.Text = "TestTest"

'下記プロパティをFalseに設定すると、ViewTopTimeが"2000/8/4"でPieceのStartが"2000/8/3"なので、

'キャプションが切れて表示されます。

    KnTView1.PieceCaptionAdjustInView = True


PieceFont プロパティ の例

タイムビュー全体のピースのキャプションのフォントの設定を行うサンプルです。

With KnTView1.PieceFont

.Italic = True　　　　　　　　　'イタリックに設定します

.Bold = True　　　　　　　　　'ボールド設定します

.Name = "MS明朝"　　　　　'フォントをMS明朝に設定します

.Size = 9　　　　　　　　　　　　'フォントのサイズを９ポイントに設定します

End With


PieceLayout プロパティ の例

ボタンを押すたびにピースのレイアウトモードを切り替えるサンプルです。

Private Sub Command1_Click()

With KnTView1

If .PieceLayout = tivPieceLayoutPlain Then

.PieceLayout = tivPieceLayoutParallel

Else

.PieceLayout = tivPieceLayoutPlain

End If

End With

End Sub


PiecePane プロパティ の例

ピースペイン全体やアイテムピースペインへの各種設定を行うサンプルです。

Dim pcepane As PiecePane

Dim itm As Item

Dim pce As Piece

Dim pcap As PieceCaption

Dim prgrs As Progress

'ピースペイン全体への設定

    Set pcepane = KnTView1.PiecePane

pcepane.MediumLine.Style = tivLineSolid

pcepane.MediumLine.Color = RGB(49, 49, 156)

pcepane.SpecialTimeSet.SpecialTimes(1).Fill.Pattern = tivPatternForwardDiagonal

pcepane.SpecialTimeSet.SpecialTimes(1).Fill.ForeColor = RGB(32, 32, 32)

    'アイテムピースペイン全体への設定

For Each itm In KnTView1.Items

If itm.Index Mod 5 = 0 Then

itm.PiecePane.Fill.BackColor = RGB(0, 0, 64)

Else

itm.PiecePane.Fill.BackColor = vbBlack

End If

itm.PiecePane.BottomBorder.Color = RGB(49, 49, 156)

Next

参考サンプル

・Appearance、Image、Introduction、SpecialTime、TimeScale


PiecePointHorScale プロパティ の例

ピース端点図形の拡大・縮小率を設定するサンプルです。

KnTView1.PiecePointVerScale = 90 'ピース端点図形の縦９０％の倍率で表示します

KnTView1.PiecePointHorScale = 120 'ピース端点図形の横１２０％の倍率で表示します

参考サンプル

・Piece


PieceSelectionColorプロパティの例

PieceSelectionColor プロパティ、LockedPieceSelectionColor プロパティ の例

ピース選択ハンドルの色を赤、ドラッグ不可状態にあるピースの選択ハンドルを黄色に設定するサンプルです。

KnTView1.PieceSelectionColor = vbRed

KnTView1.LockedPieceSelectionColor = vbYellow


PieceSelectModeプロパティの例

PieceSelectMode プロパティ、 SelectMode プロパティの例

各行ごとに択一選択ができるように設定するサンプルです。

KnTView1.PieceSelectMode = tivSelectMultiple

Dim item As KnTViewLib.item

For Each item In KnTView1.Items

item.Pieces.SelectMode = tivSelectSingle

Next

参考サンプル


PieceTimeNotify プロパティ の例

PieceStart イベント、又は PieceFinish イベントの出力を禁止するサンプルです。

KnTView1.PieceTimeNotify = False


PieceTopHeightプロパティの例

PieceTopHeight プロパティ、PieceBottomHeight プロパティ、PieceCenterHeightプロパティ、PieceTopMarginTopプロパティ、

PiecePanePaddingTopプロパティ、PieceCaptionMaxWidthプロパティの例

タイムビューのピース全般に関する様様な設定を行います。

With KnTView1

.PieceTopHeight = 5　　　 　　　 'ピース上部キャプション領域の高さ（５文字分）

.PieceBottomHeight = 5　　　 　　　'ピース下部キャプション領域の高さ（５文字分）

.PieceCenterHeight = 1 'ピース バー領域の高さを設定（１文字分）

.PieceTopMarginTop = 2 'ピースペインの上部とピースキャプションの上部とのマージンを設定（２ピクセル）

.PiecePanePaddingTop = 20 'ピースキャプション（上部）の上部とアイテム ピース ペインの上の線との間の垂直余白を設定（２０ピクセル）

.PiecePanePaddingBottom = 5 'ピースキャプション（下部）の下部とアイテム ピース ペインの下の線との間の垂直余白を設定（５ピクセル）

.PieceCaptionMaxWidth = 200 'ピース バーの外側に配置したキャプション文字列の折り返し幅を設定（２００ピクセル）

End With

参考サンプル

・


Positionプロパティ（PointShapeオブジェクト）の例

Position（PointShapeオブジェクト） プロパティ、Piecesプロパティ の例

チェックボックスをチェックをON/Offにすることに、ピース端点と時間の位置関係を切り替えるサンプルです。

Private Sub Check1_Click()

Dim pce As KnTViewLib.piece

For Each pce In KnTView1.Items(3).Pieces

If Check1.Value Then

pce.StartShape.Position = tivPointPositionInset

Else

pce.StartShape.Position = tivPointPositionCenter

End If

Next

End Sub

参考サンプル

・Piece


Progressesプロパティの例

Progresses プロパティ、PercentForm プロパティ 、Line プロパティ、Shape プロパティの例

ピースに達成度を表示するサンプルです。

Set pce = KnTView1.Items(1).Pieces.Add

pce.Start = "2000/8/11"

pce.Finish = "2000/8/15"

pce.BarShape.Shape = tivBarShapeLine

pce.BarShape.Line.Style = tivLineNull

pce.BarShape.Fill.Pattern = tivPattern3D

pce.BarShape.Fill.BackColor = vbBlue

Set prgs = pce.Progresses.Add

prgs.PercentTo = 0.8

prgs.Shape = tivBarShapeUpperLine

prgs.Line.Style = tivLineNull

prgs.Fill.Pattern = tivPattern3D

prgs.Fill.BackColor = vbRed

  Set prgs = pce.Progresses.Add

prgs.PercentTo = 0.5

prgs.Shape = tivBarShapeLowerLine

prgs.Line.Style = tivLineNull

prgs.Fill.Pattern = tivPattern3D

prgs.Fill.BackColor = vbRed

Set pcap = pce.Captions.Add

pcap.Position = tivPieceLeft

pcap.Type = tivPieceCaptionStart

Set pcap = pce.Captions.Add

pcap.Position = tivPieceRight

pcap.Type = tivPieceCaptionFinish

Set pcap = pce.Captions.Add

pcap.Position = tivPieceTop

pcap.Type = tivPieceCaptionProgress1To

Set pcap = pce.Captions.Add

pcap.Position = tivPieceBottom

pcap.Type = tivPieceCaptionProgress2To

参考サンプル（Progresses プロパティ、PercentForm プロパティ）

・Progress、Introduction、DragDrop、Appearance


ScaleFitting プロパティ の例

ピースをタイム スケールの小区分の目盛り単位でドラッグするように設定するにサンプルです。

KnTView1.ScaleFitting = tivFitToSmall

参考サンプル

・SpecialTime


Selectedプロパティの例

Selected プロパティ（Pieceオブジェクト）、Selected プロパティ（Piecesコレクション） の例

３行目のインデックス１のピースを除いたすべてのピースを選択状態に設定するサンプルです。。

KnTView1.Items(3).Pieces.Selected = True

KnTView1.Items(3).Pieces(1).Selected = False

参考サンプル

・Piece


SelectPiecesプロパティの例

SelectedPieces プロパティ の例

ボタンクリックで選択状態のピースの背景色を赤に設定するサンプルです。

Private Sub Command_Click()

Dim pce As KnTViewLib.Piece

For Each pce In KnTView1.SelectedPieces

pce.BarShape.Fill.BackColor = vbRed

Next

End Sub

参考サンプル

・DragDrop


SlidingLetter プロパティ の例

タイムスケールの大区分を次の目盛りに押し出されるまで左端に表示し続けるように設定するサンプルです。

KnTView2.TimeScale.Large.SlidingLetter = True

参考サンプル

・Image、TimeScale


SpecialTimesプロパティの例

SpecialTimes プロパティ、SpecialTimeSets プロパティ、BkModeプロパティ 、Prohibitedプロパティ

Startプロパティ（SpecialTimeオブジェクト）の例

特別時間帯を設定するサンプルです。

Dim spt As SpecialTime

Dim sptsHoliday As SpecialTimeSet

Set sptsHoliday = KnTView1.SpecialTimeSets.Add

Set spt = sptsHoliday.SpecialTimes.Add

spt.Fill.BkMode = tivTransparent

spt.Fill.Pattern = tivPatternDiagonalCross

spt.Fill.ForeColor = RGB(204, 204, 204)

spt.Pattern = tivSpecialTimeDaily

spt.Start = "20:00"

spt.Finish = "6:00"

spt.Prohibited = True

参考サンプル（SpecialTimes、SpecialTimeSets）

・Progress、Image、Intorduction、SpecialTime、HitTest、Appearance、Piece

参考サンプル（BkMode）

・SpecialTime、Appearance

参考サンプル（Prohibited）

・SpecialTime


Tag プロパティ の例

ピース追加時に表示されるダイアログで入力された情報をTagに設定して、

ピースクリックで上記情報をメッセージボックスで表示するサンプル。

Private Sub KnTView1_AfterPieceAdd(ByVal Cancel As KnTViewLib.ReturnBoolean, ByVal Start As KnTViewLib.ReturnDate, ByVal Finish As KnTViewLib.ReturnDate, ByVal Item As KnTViewLib.Item)

Cancel.Value = True

'選択リストつきダイアログ表示

Dialog.Show 1

'nIndexおよびstrUserは、上記ダイアログのリストボックスで選択したデータを代入

With Item.Pieces.Add

.Start = Start

.Finish = Finish

.Tag = CStr(nIndex) & ":" & strUser

End With

End Sub

Private Sub KnTView1_Click()

If KnTView1.SelectedPieces.Count > 0 Then

MsgBox KnTView1.SelectedPieces(1).Tag

End If

End Sub


Targetプロパティの例

Pattern、Target プロパティ の例

毎週日曜日に特別時間帯を設定するサンプルです。

Dim spts As SpecialTimeSet

Set spts = KnTView7.SpecialTimeSets.Add

With spts.SpecialTimes.Add

.Pattern = tivSpecialTimeWeekly

.Target = tivSunday

  .Start = "0:00"

  .Finish = "0:00"

  .Fill.BackColor = RGB(241, 91, 233)

End With

2010/1/1に特別時間帯を設定するサンプルです。

Dim spts As SpecialTimeSet

Set spts = KnTView7.SpecialTimeSets.Add

With spts.SpecialTimes.Add

  .Pattern = tivSpecialTimeDate

.Target = "2010/1/1"

  .Start = "0:00"

  .Finish = "0:00"

  .Fill.BackColor = RGB(241, 91, 233)

End With

参考サンプル

・Image、Introduction、SpecialTime、TimeScale


TimeScaleプロパティの例

TimeScale プロパティ、Largeプロパティ、Mediumプロパティ、Smallプロパティ

Unitプロパティ、Intervalプロパティ、Formatプロパティ、SubUnitプロパティ、SubIntervalプロパティ の例

タイムスケールの基本的な設定を行うサンプルです。

KnTView2.ColumnHeaders.Clear

KnTView2.TimeScale.Large.Unit = tivScaleUnitMonth

KnTView2.TimeScale.Large.Interval = 1

KnTView2.TimeScale.Large.Format = "yyyy年m月"

KnTView2.TimeScale.Medium.Unit = tivScaleUnitWeek

KnTView2.TimeScale.Medium.Interval = 1

KnTView2.TimeScale.Medium.Format = "d日"

KnTView2.TimeScale.Small.Unit = tivScaleUnitWeek

KnTView2.TimeScale.Small.Interval = 1

KnTView2.TimeScale.Small.SubUnit = tivScaleUnitDay

KnTView2.TimeScale.Small.SubInterval = 1

KnTView2.TimeScale.WidthPerScale = ScaleX(40, vbPixels, Me.ScaleMode)

KnTView2.Items.Add

KnTView2.Items.Add

参考サンプル

・すべて


Title プロパティ の例

印刷プレビューダイアログのタイトルを設定するサンプルです。

Dim pi As New PrintInfo

pi.Title = "テスト印刷"

KnTView1.PrintPreview pi


Typeプロパティの例

Type プロパティ 、Text プロパティ (PieceCaption オブジェクト)、Shape プロパティ (PointShape オブジェクト)

Start プロパティ(Piece オブジェクト)、StartShape プロパティ、Position プロパティ (PieceCaption オブジェクト)の例

ピース、ピースキャプションの様様な設定を行うサンプルです。

Set pce = KnTView1.Items(1).Pieces.Add

pce.Start = "2001/8/1"

pce.Finish = "2001/8/3"

pce.BarShape.Shape = tivBarShapeUpperRectangle

pce.StartShape.Shape = tivPointShapeHomeBase

pce.FinishShape.Shape = tivPointShapeHomeBase

Set pcap = pce.Captions.Add

pcap.Position = tivPieceTop

pcap.Type = tivPieceCaptionText

pcap.Text = "ピース バー、開始日時、終了日時の形状の組み合わせは自由です。"


Value プロパティ の例

マウス操作でピースを追加する際に、ユーザにピースの移動や時間の変更を

するか問い合わせて、ピースにロックをかけるサンプルです。

Private Sub KnTView1_AfterPieceAdd(ByVal Cancel As KnTViewLib.ReturnBoolean, ByVal Start As KnTViewLib.ReturnDate, ByVal Finish As KnTViewLib.ReturnDate, ByVal Item As KnTViewLib.Item)

Cancel.Value = True

With Item.Pieces.Add

.Start = Start

.Finish = Finish

If MsgBox("ロックしますか？", vbYesNo) = vbYes Then

.Value = 99

Else

.Value = Null

End If

End With

End Sub

Private Sub KnTView1_BeforePieceMove(ByVal Cancel As KnTViewLib.ReturnBoolean)

With KnTView1.SelectedPieces(1)

If .Value = 99 Then

Cancel.Value = True

End If

End With

End Sub

Private Sub KnTView1_BeforePieceTimeChange(ByVal Cancel As KnTViewLib.ReturnBoolean, ByVal Which As Integer)

With KnTView1.SelectedPieces(1)

If .Value = 99 Then

Cancel.Value = True

End If

End With

End Sub


ViewTopItem プロパティ の例

フォームがロードされた際にタイムビューの2行目が先頭行として表示されるサンプルです。

Private Sub Form_Load()

KnTView1.ViewTopTime = "2010/3/3"

KnTView1.ViewTopItem = 2

'行の追加

For i = 1 To 5

KnTView1.Items.Add

Next

'2行目が表示先頭行となるように表示します
'設定値に対応するインデックスをもつアイテムが存在しない状態で、（たとえば上記ViewTopItem プロパティの次の行で）
'ViewTopItemを設定しても無効です

KnTView1.ViewTopItem = 2

End Sub


ViewTopTime プロパティ の例

画面に見える左端の日時を設定するサンプルです。

'画面に見える左端の日時を2010年3月3日 12:00に設定します

KnTView1.ViewTopTime = "2010/3/3　12:00"

参考サンプル

・Appearance、Progress、Image、Introduction、Merge、MultiColumn、Piece、Sort、SpecialTime、DragDrop、HitTest


WidthPerScale プロパティ の例

タイム スケールの中区分の1目盛りの幅を設定するサンプルです。

With KnTView2.TimeScale

.Large.Unit = tivScaleUnitMonth

.Large.Interval = 1

.Large.Format = "yyyy年m月"

.Medium.Unit = tivScaleUnitWeek

.Medium.Interval = 1

.Medium.Format = "d日"

.Small.Unit = tivScaleUnitWeek

.Small.Interval = 1

.Small.SubUnit = tivScaleUnitDay

.Small.SubInterval = 1

'中区分の1目盛りの幅を50に設定します

.WidthPerScale = ScaleX(50, vbPixels, Me.ScaleMode)

End With

参考サンプル

・TimeScale


WindowsFitプロパティの例

WindowFit、WindowFitNumScale プロパティ の例

大区分の２目盛り分を 1画面に見えるように自動調整して表示するサンプルです。

With KnTView2.TimeScale

.Large.Unit = tivScaleUnitMonth

.Large.Interval = 1

.Large.Format = "yyyy年m月"

.Medium.Unit = tivScaleUnitWeek

.Medium.Interval = 1

.Medium.Format = "d日"

.Small.Unit = tivScaleUnitWeek

.Small.Interval = 1

.Small.SubUnit = tivScaleUnitDay

.Small.SubInterval = 1

'大区分の目盛りにあわせて１画面に表示されるように設定します

.WindowFit = tivWindowFitLargeScale

'WindowsFitで指定した区分（この場合は大区分）の何目盛り分を１画面に表示するかを設定します

.WindowFitNumScales = 2

End With

参考サンプル

・TimeScale


ZOrder プロパティ の例

特別時間帯の表示の優先順位を指定して表示するサンプルです。

下記の例で、Zorderプロパティの指定がない場合、SpecialTimeSetオブジェクトのインデックス順（つまり追加された順）に

上書きして表示されるために、

・８：００～１４：００　---　　vbCyan

・１４：００～１６：００　---　vbYellow

となります。Zorderプロパティを指定すると、その値の大きい順に優先して表示されるので、

・８：００～１１：００　---　　vbCyan

・１１：００～１３：００　---　vbCyan

・１３：００～１６：００　---　vbGreen

となります。

Dim sptset As SpecialTimeSet

Dim sptime As SpecialTime

Set sptset = KnTView1.SpecialTimeSets.Add

'特別時間帯A

Set sptime = sptset.SpecialTimes.Add

sptime.Start = "12:00"

sptime.Finish = "16:00"

sptime.Fill.BkMode = tivTransparent

sptime.Fill.BackColor = vbYellow

sptime.ZOrder = 1

'特別時間帯B

Set sptime = sptset.SpecialTimes.Add

sptime.Start = "11:00"

sptime.Finish = "13:00"

sptime.Fill.BkMode = tivTransparent

sptime.Fill.BackColor = vbGreen

sptime.ZOrder = 2

'特別時間帯C

Set sptime = sptset.SpecialTimes.Ad

sptime.Start = "8:00"

sptime.Finish = "14:00"

sptime.Fill.BkMode = tivTransparent

sptime.Fill.BackColor = vbCyan

参考サンプル

・SpecialTime


SetRect メソッド

関連項目 使用例

オブジェクトの矩形を設定します。

構文

object.SetRect (TopLeft, Width, Height)

SetRect メソッドの構文の指定項目は次のとおりです。

指定項目 | 内容
object | 必ず指定します。 「対象」一覧内のいずれかのオブジェクトを指すオブジェクト式です。
TopLeft | 設定する矩形の左上の位置を Point オブジェクトで指定します。
Width | 設定する矩形の幅をコンテナ単位で指定します。
Height | 設定する矩形の高さをコンテナ単位で指定します。

解説

このメソッドを利用すると、オブジェクトの矩形を直接指定することができます。

このメソッドは、PiecePaneTrackingEnd イベントで利用すると、イベントの引数をそのままメソッドに渡すことができます。


Addメソッドの例

Addメソッド、Clearメソッド、Removeメソッド、Itemメソッド、Countプロパティ の例

各種コレクションオブジェクトに対する操作を行うサンプルです。

'行を１つ追加します

KnTView1.Items.Add

'列見出しをなくします。（表示しないのではなく、オブジェクトをクリア）

KnTView1.ColumnHeaders.Clear

'1行目のインデックス１のピースを削除します

KnTView1.Items(1).Pieces.Remove 1

'２行目、３列目のセルに文字列を設定します

KnTView1.Items.Item(1).Cells.Item(1).Value = "aaa"

'上記は以下のようにも記述できます

KnTView1.Items(1).Cells(1).Value = "aaa"

'タイムビュー全体で選択状態にあるピースの数を取得します

Dim nCount As Integer

nCount = KnTView1.SelectedPieces.Count


AddFromTemplete メソッド の例

プロパティページで定義したテンプレートを用いて行を追加するサンプルです。

For i = 1 To 20

'テンプレートによるItemの追加

Set itm = KnTView2.Items.AddFromTemplate(1)

itm.Cells(1).Value = "ﾀｽｸ " & Chr(64 + i)

itm.Cells(2).Value = "ﾘｿｰｽ " & CStr(i)

Next


CalcDragItemIntervalメソッドの例

CalcDragItemIntervalメソッド、CalcDragMinuteIntervalメソッドメソッド、 GetDataメソッド、GetFoｒmatメソッド、OLEDragDropイベント

DeltaXプロパティの例

ドラッグ＆ドロップでドロップ時に渡されたきた情報を用いて、ドロップターゲットのタイムビューにピースを描画するサンプルです。

Private Sub KnTView1_OLEDragDrop(Data As KnTViewLib.DataObject, ByVal Effect As KnTViewLib.ReturnLong, Button As Integer, Shift As Integer,
x As Single, y As Single, ByVal LocalDragDrop As Boolean)

If Data.GetFormat(tivCFSelectedPieces) Then

'ﾋﾟｰｽｺﾚｸｼｮﾝを取得

Dim selPcs As SelectedPieces

Set selPcs = Data.GetData(tivCFSelectedPieces)

'ﾄﾞﾗｯｸﾞの移動量を行数及び分数で求める

Dim ItemInterval As Long

Dim MinuteInterval As Long
ItemInterval = KnTView1.CalcDragItemInterval(x, y, selPcs.DragPiece)

MinuteInterval = KnTView1.CalcDragMinuteInterval(x, y, selPcs.DragPiece, selPcs.DeltaX)

'現在の行数を取得

Dim NumItems As Long

NumItems = KnTView1.Items.Count

'既存の行にﾄﾞﾛｯﾌﾟされたﾋﾟｰｽ情報のみを取り込む

Dim NewItemIndex As Long

Dim itms As Items

Dim itm As Item

Dim pcSrc As Piece, pcNew As Piece

Set itms = KnTView1.Items

For Each pcSrc In selPcs

NewItemIndex = pcSrc.ItemIndex + ItemInterval

If 1 <= NewItemIndex And NewItemIndex <= NumItems Then

Set itm = itms(NewItemIndex)

'ﾋﾟｰｽ新規追加

Set pcNew = itm.Pieces.Add

'時間設定

pcNew.Start = DateAdd("n", MinuteInterval, pcSrc.Start)

pcNew.Finish = DateAdd("n", MinuteInterval, pcSrc.Finish)

With pcNew.BarShape

.Shape = pcSrc.BarShape.Shape

.Fill.Pattern = pcSrc.BarShape.Fill.Pattern

.Fill.BackColor = pcSrc.BarShape.Fill.BackColor

End With

'達成率

Dim prgs As Progress

Set prgs = pcNew.Progresses.Add

With prgs

.PercentFrom = pcSrc.Progresses(1).PercentFrom

.PercentTo = pcSrc.Progresses(1).PercentTo

.Shape = pcSrc.Progresses(1).Shape

.Fill.Pattern = pcSrc.Progresses(1).Fill.Pattern

.Fill.BackColor = pcSrc.Progresses(1).Fill.BackColor

End With

'キャプション文字列

Dim pcap As PieceCaption

Set pcap = pcNew.Captions.Add

With pcap

.Text = pcSrc.Captions.Item(1).Text

.Position = pcSrc.Captions.Item(1).Position

.Type = pcSrc.Captions.Item(1).Type

.HorAlign = pcSrc.Captions.Item(1).HorAlign

.VerAlign = pcSrc.Captions.Item(1).VerAlign

.Color = pcSrc.Captions.Item(1).Color

End With

End If

Next pcSrc

If Shift And 2 Then

Effect.Value = vbDropEffectCopy

Else

Effect.Value = vbDropEffectMove

End If

End If

End Sub

参考サンプル

・DragDrop


Cellメソッドの例

Cell メソッド、Valueプロパティ の例

各セルの値を設定するサンプルです。

実行結果は、MultiColumnサンプルを参照してください。

KnTView1.Cell(1, 1).Value = "海"

KnTView1.Cell(1, 2).Value = CDate(Now)

KnTView1.Cell(1, 3).Value = CLng(0)

KnTView1.Cell(1, 4).Value = CSng(1#)

KnTView1.Cell(1, 5).Value = CCur(100)

KnTView1.Cell(2, 1).Value = "うみ"

KnTView1.Cell(2, 2).Value = CDate("1969/7/20")

KnTView1.Cell(2, 3).Value = CLng(1)

KnTView1.Cell(2, 4).Value = CSng(0.1)

KnTView1.Cell(2, 5).Value = CCur(0.1)

KnTView1.Cell(3, 1).Value = "ウミ"

KnTView1.Cell(3, 2).Value = CDate("10:20:30")

KnTView1.Cell(3, 3).Value = CLng(-1)

KnTView1.Cell(3, 4).Value = CSng(-0.1)

KnTView1.Cell(3, 5).Value = CCur(-0.1)

KnTView1.Cell(4, 1).Value = "ｳﾐ"

KnTView1.Cell(4, 2).Value = CDate("1999/12/31 23:59")

KnTView1.Cell(4, 3).Value = CLng(1234567890)

KnTView1.Cell(4, 4).Value = CSng(1.23456789)

KnTView1.Cell(4, 5).Value = CCur(123.45)

KnTView1.Cell(5, 1).Value = "Sea"

KnTView1.Cell(5, 2).Value = CDate("2000/1/1 0:0")

KnTView1.Cell(5, 3).Value = CLng(-1234567890)

KnTView1.Cell(5, 4).Value = CSng(-1.23456789)

KnTView1.Cell(5, 5).Value = CCur(-123.45)


DayOfWeekColor メソッド の例

毎週日曜日の、タイム スケールの目盛線、および目盛文字を黄色に表示するサンプルです。

KnTView1.TimeScale.DayOfWeekColor tivSunday, vbYellow

参考サンプル

・Image、Introduction、TimeScale


DoScroll メソッド の例

さまざまな垂直または水平方向へのスクロールを行うサンプルです。

'垂直方向は、最終アイテムへスクロール。水平報告は、１画面分右へスクロール

KnTView1.DoScroll tivScrollBottom, tivScrollPageDow

'垂直方向は、スクロールしない。水平報告は、中区分の1目盛り左へスクロール

KnTView1.DoScroll tivScrollNone, tivScrollLineUp


FormatDateTimeメソッドの例

FormatDateTime メソッド、DateSwitchHourプロパティ の例

現在の日時を午前１時までは深夜時間表記で（24時、25時）指定したフォーマットの文字列に変換するサンプルです。

'日付が変わる時間を午前２時に設定します

KnTView1.TimeScale.DateSwitchHour = 2

'現在日時を指定したフォーマットの文字列に変換します。

KnTView1.FormatDateTime(Now, "yyyy/mm/dd HHX:nn:ss")


GetCellRect メソッド の例

選択したセル上にコンボボックスを位置づけるサンプルです。

Private Sub KnTView1_AfterCellSelect()

Dim sngLeft As Single, sngTop As Single

Dim sngRight As Single, sngBottom As Single

With KnTView1

.GetCellRect .ItemIndex, .ColumnIndex, _

sngLeft, sngTop, sngRight, sngBottom

End With

Combo1.Left = KnTView1.Left + sngLeft

Combo1.Top = KnTView1.Top + sngTop

End Sub


HitTestメソッドの例

HitTest メソッド 、ColumnIndex　プロパティ、ItemInteｘ　プロパティ、Time　プロパティ

ObjectType　プロパティの例

マウスでクリックした箇所を判別して、取得できる情報をテキストボックスに表示するサンプルです。

Private Sub KnTView1_MouseMove(Button As Integer, Shift As Integer, X As Single, Y As Single)

Dim cntrX As Single

'HitTestメソッドに渡す引数をコンテナの座標系の値に変換する

cntrX = ScaleX(X, vbTwips, Me.ScaleMode)

cntrY = ScaleY(Y, vbTwips, Me.ScaleMode)

Dim htr As HitTestResult

Set htr = KnTView1.HitTest(cntrX, cntrY)

'HitTestResultオブジェクトに設定されたオブジェクトタイプを判断する

Dim strTrace As String

Select Case htr.ObjectType

Case tivColumnHeader

strTrace = "列見出し " & CStr(htr.ColumnIndex)

Case tivCell

        strTrace = "ｾﾙ(" & CStr(htr.ItemIndex) & "," & CStr(htr.ColumnIndex) & ")"

Case tivColumnWidthUIPoint

strTrace = CStr(htr.ColumnIndex) & "列目 列幅変更ﾎﾟｲﾝﾄ"

Case tivItemHeightUIPoint

strTrace = CStr(htr.ItemIndex) & "行目にある行高変更ﾎﾟｲﾝﾄ"

Case tivObjectNothing

strTrace = "ｵﾌﾞｼﾞｪｸﾄなし"

Case tivPiece

strTrace = "ﾋﾟｰｽ(" & CStr(htr.ItemIndex) & "," & CStr(htr.PieceIndex) & ")"

Case tivPieceFinish

strTrace = "ﾋﾟｰｽ(" & CStr(htr.ItemIndex) & "," & CStr(htr.PieceIndex) & ")の終点"

Case tivPieceStart

strTrace = "ﾋﾟｰｽ(" & CStr(htr.ItemIndex) & "," & CStr(htr.PieceIndex) & ")の始点"

Case tivPiecePane

strTrace = CStr(htr.ItemIndex) & "行目のﾋﾟｰｽﾍﾟｲﾝ。時間は、" & CStr(htr.Time) & "。"

Case tivTimeScale

strTrace = "ﾀｲﾑｽｹｰﾙ。時間は、" & CStr(htr.Time) & "。"

Case tivWidthPerScaleUIPoint

strTrace = "目盛り幅変更ﾎﾟｲﾝﾄ"

Case Else

strTrace = ""

End Select

'テキストボックスに表示

Text1.Text = strTrace

End Sub


Imageメソッドの例

Image メソッド、Imagesプロパティ、ImageListsプロパティ、Keysプロパティ の例

1行目のピースインデックスが１のピースの開始点をイメージに変更するサンプルです。

Dim imgList As ImageList

Set imgList = KnTView1.ImageLists.Add(, "ImageList", App.Path & "\Image.bmp", RGB(255, 0, 255), 16, 16)

imgList.Images.Keys = Array("Calendar", "Trush", "Tree", "Smile")

Dim pce As Piece

Set pce = KnTView1.Items(1).Pieces(1)

pce.StartShape.Shape = tivPointShapeImage

pce.StartShape.Image "ImageList", "Trush"

参考サンプル

・Image、Introduction


OLEDragメソッドの例

OLEDrag メソッド、OLEDragMode プロパティ の例

ピース上で右クリックでドラッグを開始するサンプルです。

'ドラッグの開始を手動に設定します

Private Sub Form_Load()

KnTView1.OLEDragMode = tivOLEDragManual

End Sub

Private Sub KnTView1_MouseDown(Button As Integer, Shift As Integer, X As Single, Y As Single)

Dim ctlX As Integer

Dim ctlY As Integer

ctlX = ScaleX(X, vbTwips, Me.ScaleMode)

ctlY = ScaleY(Y, vbTwips, Me.ScaleMode)

Dim htr As HitTestResult

Set htr = KnTView1.HitTest(ctlX, ctlY)

If htr.ObjectType = tivPiece Then

If Button = vbRightButton Then

KnTView1.OLEDrag

End If

End If

End Sub


PrintPreview メソッド の例

タイム ビュー コントロールの印刷プレビュー ダイアログを表示するサンプルです。

Dim pi As New PrintInfo

KnTView1.PrintPreview pi

参考サンプル

・Appearance、Introduction、Merge


PrintStartメソッドの例

PrintStart、PrintDirect メソッド の例

タイム ビュー コントロールを印刷するサンプルです。

'印刷ダイアログを出して印刷を行います。

Dim pi As New PrintInfo

KnTView1.PrintStart pi

'印刷ダイアログを出さずに印刷を行います。

Dim pi As New PrintInfo

KnTView1.PrintDirect pi


SetDataメソッドの例

SetDataメソッド、OLEStartDragイベントの例

ドラッグ＆ドロップでドラッグ開始時に、ドロップターゲットに渡すDataObjectに情報を設定するサンプルです。

Private Sub KnTView1_OLEStartDrag(Data As KnTViewLib.DataObject, ByVal AllowedEffects As KnTViewLib.ReturnLong)

Dim strData As String

Dim pce As Piece

strData = "Tasks"

'選択されている各ピースの開始時間、終了時間、ピースが存在する行の２列目のセルのValueをカンマ区切りで変数にセット

For Each pce In KnTView1.SelectedPieces

strData = strData & "," & KnTView1.Cell(pce.ItemIndex, 2).Value & _

"," & CStr(pce.Start) & "," & CStr(pce.Finish)

Next

'ドロップターゲットに渡すDataObjectに情報を設定

    Data.SetData strData, vbCFText

End Sub

参考サンプル

・DragDrop


SetFontPropertyメソッドの例

SetFontProperty メソッド、SetPieceFontProperty メソッド 、GetFontProperty メソッド、G etPieceFontProperty メソッドの例

ピース フォントについて、フォント名をTime Roman、太字に設定するサンプルです。

また、ピース フォントのサイズが１２ポイント以下ならサイズを１２ポイントに設定します。

With KnTView1

.SetPieceFontProperty tivFontName, "Times Roman"

If .GetPieceFontProperty(tivFontSize) < 12 Then

.SetPieceFontProperty tivFontSize, 12

End If

.SetPieceFontProperty tivFontBold, True

End With


SetRange メソッド の例

タイムスケール全体の表示幅を2001/3/18～2001/3/19の範囲に設定するサンプルです。

KnTView1.TimeScale.SetRange "2001/3/18", "2001/3/19"


Sort メソッド の例

以下は、タイムビューが用意しているソートの条件を用いたサンプルです。

'１行目～１０行目を対象に、１列目～３列目のセルの値をキーに、JISコードの昇順にソートします。

KnTView1.Sort 1, 10, 1, 3, 5, tivSortTextAscending,False

以下は、タイムビューが用意しているソートの条件をユーザが定義するサンプルです。

'Compareイベント内でソートの条件を定義してソートを行います

KnTView1.Sort 1, 10, 1, 3, 5, 0,True

Private Sub KnTView1_Compare(ByVal Swap As ReturnBoolean, ByVal LeftItem As KnTViewLib.Item, ByVal RightItem As KnTViewLib.Item)

'五十音順で昇順にソート

Dim strLeft As String

Dim strRight As String

strLeft = LeftItem.Cells(htrSav.ColumnIndex).Value

strRight = RightItem.Cells(htrSav.ColumnIndex).Value

Dim ret

ret = StrComp(strLeft, strRight, vbTextCompare)

If ret < 0 Then

Swap = True

Else

Swap = False

End If

End Sub


StartCellEditメソッドの例

StartCellEdit メソッド、CellEditプロパティ の例

ボタンを押したときのみカレントセルの編集をできるようにするサンプルです。

'セルの編集をStartCellEditメソッドが呼ばれたときのみ開始するようにします

KnTView1.CellEdit = tivManual

Private Sub Command1_Click()

'セルの編集を開始します

KnTView1.StartCellEdit

End Sub


日付式

日付として解釈可能な式。日付式には、日付リテラル、日付と解釈できる数値、日付と解釈できる文字列、関数によって返される日付が含まれます。日付式で表すことのできる日付の範囲は、西暦 100 年 1 月 1 日 ～ 西暦 9999 年 12 月 31 日です。

日付は、実数の一部として格納されます。整数部の値は日付を表し、小数部の値は時刻を表します。負の整数を指定すると、1899 年 12 月 30 日より前の日付を表します。


日付/時刻表示書式指定文字

使用例

次の表は、日付/時刻表示書式指定文字とその内容を示します。

文字 | 内容
y | 1 年のうちで何日目に当たるかを数値で返します (1 ～ 366)。
o | Origin プロパティの示す日付から何日目に当たるかを数値で返します (1 ～)。
yy | 西暦の年を下 2 桁の数値で返します (00 ～ 99)。
yyyy | 西暦の年を 4 桁の数値で返します (100 ～ 9999)。
g | 年号の頭文字を返します (M、T、S、H)。
gg | 年号の先頭の 1 文字を漢字で返します (明、大、昭、平)。
ggg | 年号を返します (明治、大正、昭和、平成)。
e | 年号に基づく和暦の年を返します。1 桁の場合、先頭に 0 が付きません。
ee | 年号に基づく和暦の年を 2 桁の数値を使って返します。1 桁の場合、先頭に 0 が付きます。
m | 月を表す数値を返します。1 桁の場合、先頭に 0 が付きません (1 ～ 12)。ただし、h や hh の直後に m を指定した場合、月ではなく分と解釈されます。
mm | 月を表す数値を返します。1 桁の場合、先頭に 0 が付きます (01 ～ 12)。ただし、h や hh の直後に mm を指定した場合、月ではなく分と解釈されます。
mmm | 月の名前を英語 (省略形) の文字列に変換して返します (Jan ～ Dec)。
mmmm | 月の名前を英語で返します (January ～ December)。
ww | その日が一年のうちで何週目に当たるかを表す数値を返します (1 ～ 54)。
wwo | Origin プロパティの示す日付から何週目に当たるかを表す数値を返します (1 ～ )。
d | 日付を返します。1 桁の場合、先頭に 0 が付きません (1 ～ 31)。
dd | 日付を返します。1 桁の場合、先頭に 0 が付きます (01 ～ 31)。
ddd | 曜日を英語 (省略形) で返します (Sun ～ Sat)。
aaa | 曜日を日本語 (省略形) で返します (日～土)。
dddd | 曜日を英語で返します (Sunday ～ Saturday)。
aaaa | 曜日を日本語で返します (日曜日～土曜日)。
h | 12 時間制の時間を返します。1 桁の場合、先頭に 0 が付きません (1 ～ 12)。
hh | 12 時間制の時間を返します。1 桁の場合、先頭に 0 が付きます (01 ～ 12)。
H | 24 時間制の時間を返します。1 桁の場合、先頭に 0 が付きません (0 ～ 23)。
HH | 24 時間制の時間を返します。1 桁の場合、先頭に 0 が付きます (00 ～ 23)。
HX | 24 時間制の時間を返します。DateSwitchHour プロパティの値が 0 以外のとき、24時以降を24, 25, 26と表示します。1 桁の場合、先頭に 0 が付きません (0 ～ 47)。
HHX | 24 時間制の時間を返します。DateSwitchHour プロパティの値が 0 以外のとき、24時以降を24, 25, 26と表示します。1 桁の場合、先頭に 0 が付きます (00 ～ 47)。
n | 分を返します。1 桁の場合、先頭に 0 が付きません (0 ～ 59)。
nn | 分を返します。1 桁の場合、先頭に 0 が付きます (00 ～ 59)。
s | 秒を返します。1 桁の場合、先頭に 0 が付きません (0 ～ 59)。
ss | 秒を返します。1 桁の場合、先頭に 0 が付きます (00 ～ 59)。
AM/PM | 時刻が正午以前の場合は大文字で AM を返し、正午～午後 11 時 59 分の間は大文字で PM を返します。
am/pm | 時刻が正午以前の場合は小文字で am を返し、正午～午後 11 時 59 分の間は小文字で pm を返します。
A/P | 時刻が正午以前の場合は大文字で A を返し、正午～午後 11 時 59 分の間は大文字で P を返します。
a/p | 時刻が正午以前の場合は小文字で a を返し、正午～午後 11 時 59 分の間は小文字で p を返します。
AMPM | 時刻が正午以前の場合は午前を表すリテラル文字列を、正午～午後 11 時 59 分の間は午後を表すリテラル文字列を返します。これらの文字列の設定は、コントロール パネルで行います。


定義済み日付/時刻書式

次の表は、定義済み日付/時刻書式の名前とその内容を示します。

文字 | 内容
General Date | 日付または時刻、あるいはその両方を返します。整数部と小数部の両方を含む数値を指定すると、日付と時刻の両方を表す文字列 (たとえば 96/4/3 5:34) に変換します。小数部がない場合には日付のみ (たとえば 96/4/3)、整数部がない場合には時刻のみ (たとえば 5:34) を表す文字列に変換します。日付と時刻の表示形式はコントロール パネルの設定により決まります。
Long Date | 日付の長い形式 (コントロール パネルの設定) で表した日付を返します。
Medium Date | 簡略形式で表した日付を返します。
Short Date | 日付の短い形式 (コントロール パネルの設定) で表した日付を返します。
Long Time | 時刻、分、秒を含む形式で表した時刻を返します。
Medium Time | 時間と分を 12 時間制で表した時刻を返します。同時に午前 (AM)、午後 (PM) も追加します。
Short Time | 時間と分を 24 時間制で表した時刻 (たとえば 17:45) を返します。