Lassalle.WPF.Flow Namespace

AddFlow for WPF 2016
Lassalle.WPF.Flow Namespace
AddFlow for WPF is a general purpose Flowcharting/Diagramming WPF control.

Each time you need to graphically display interactive diagrams, you should consider using AddFlow, a royalty-free control that offers unique support to create diagrams interactively or programmatically: workflow diagrams, database diagrams, communication networks, organizational charts, process flows, state transitions diagrams, CTI applications, CRM (Customer Relationship Management), expert systems, graph theory, quality control diagrams, ...

AddFlow for WPF lets you quickly build flowchart-enabled WPF applications. Features such as distinct colors, fonts, shapes, styles, pictures, text, and so on for each object of the diagram (node or link) are available. Nodes stay connected when moved. Metafiles support, serialization, printing, undo/redo, zooming, Bezier curves, reflexive links, multiselection, scrolling, user data association, navigation in the graph. Runtime distribution is royalty free.

AddFlow for WPF provides two ways to build diagrams:

1. interactive way. AddFlow lets you create a diagram interactively without programming any line of code. Moreover, AddFlow provides support for saving, loading, cutting, pasting and printing diagrams. And it provides also a very powerful multi-level undo/redo feature.

2. programmatic way. Its object model is powerful and very easy to use.

Classes
 | Class | Description
Public class | AddFlow | The AddFlow control
Public class | AddFlowException | AddFlow exception class
Public class | AddFlowLicenseProvider |
Public class | AfterEditEventArgs | Event parameters used for the AfterEdit event
Public class | BeforeAddLinkEventArgs | Event parameters used for the BeforeAddLink event
Public class | BeforeEditEventArgs | Event parameters used for the BeforeEdit event
Public class | CancelEditEventArgs | Event parameters used for the CancelEdit event
Public class | Caption | Represents a caption (also called label or note) in the diagram. A caption is a ContentItem object that can be owned by an Item
Public class | CaptionCreatedEventArgs | Event parameters used for the CaptionCreated event
Public class | CaptionCreatingEventArgs | Event parameters used for the CaptionCreating event
Public class | CaptionDeletedEventArgs | Event parameters used for the CaptionDeleted event
Public class | CaptionDeletingEventArgs | Event parameters used for the CaptionDeleting event
Public class | ContentItem | Represents an Item object that has a content which may be a string or/and an image. Nodes and captions are ContentItem objects.
Public class | DstChangedEventArgs | Event parameters used for the DstChanged event
Public class | DstChangingEventArgs | Event parameters used for the DstChanging event
Public class | ErrorEventArgs | Event parameters used for the Error event
Public class | Item | Represents an object in the diagram. This is an abstract class.
Public class | Link | Represents a link (also called edge, relation or arc) in the diagram.
Public class | LinkCreatedEventArgs | Event parameters used for the LinkCreated event
Public class | LinkCreatingEventArgs | Event parameters used for the LinkCreating event
Public class | LinkDeletedEventArgs | Event parameters used for the LinkDeleted event
Public class | LinkDeletingEventArgs | Event parameters used for the LinkDeleting event
Public class | Node | Represents a node (also called vertice or entity) in the diagram.
Public class | NodeCreatedEventArgs | Event parameters used for the NodeCreated event
Public class | NodeCreatingEventArgs | Event parameters used for the NodeCreating event
Public class | NodeDeletedEventArgs | Event parameters used for the NodeDeleted event
Public class | NodeDeletingEventArgs | Event parameters used for the NodeDeleting event
Public class | OrgChangedEventArgs | Event parameters used for the OrgChanged event
Public class | OrgChangingEventArgs | Event parameters used for the OrgChanging event
Public class | Pin | A Pin object is the connector displayed in the node, that allows creating a link.
Public class | SelectedItemsLayoutingEventArgs | Event parameters used for the SelectedItemsLayouting event
Public class | SelectedItemsRotatingEventArgs | Event parameters used for the SelectedItemsRotatingEventArgs event
Public class | SelectedLinkStretchingEventArgs | Event parameters used for the SelectedLinkStretching event
Public class | SelectionChangedEventArgs | Event parameters used for the SelectionChanged event
Public class | Task | Represents an action that can be undone and redone.
Public class | TaskManager | The class managing the list of tasks and allowing undo/redo.
Interfaces
 | Interface | Description
Public interface | IMoveable | Common interface for items (nodes, captions) that can be moved
Public interface | IRotatable | Common interface for items that can be rotated (nodes, captions)
Public interface | ISelectable | Common interface for items (nodes, links, captions) that can be selected.
Public interface | ISizeable | Common interface for items (nodes, captions) that can be resized
Delegates
 | Delegate | Description
Public delegate | AddFlowAfterEditEventHandler | Represents the method that will handle the AfterEdit event.
Public delegate | AddFlowBeforeEditEventHandler | Represents the method that will handle the BeforeEdit event.
Public delegate | AddFlowCancelEditEventHandler | Represents the method that will handle the CancelEdit event.
Public delegate | AddFlowCaptionCreatedEventHandler | Represents the method that will handle the CaptionCreated event.
Public delegate | AddFlowCaptionCreatingEventHandler | Represents the method that will handle the CaptionCreating event.
Public delegate | AddFlowCaptionDeletedEventHandler | Represents the method that will handle the CaptionDeleted event.
Public delegate | AddFlowCaptionDeletingEventHandler | Represents the method that will handle the CaptionDeleting event.
Public delegate | AddFlowDstChangedEventHandler | Represents the method that will handle the DstChanged event.
Public delegate | AddFlowDstChangingEventHandler | Represents the method that will handle the DstChanging event.
Public delegate | AddFlowErrorEventHandler | Represents the method that will handle the Error event.
Public delegate | AddFlowExtentChangedEventHandler | Represents the method that will handle the ExtentChange event.
Public delegate | AddFlowLinkCreatedEventHandler | Represents the method that will handle the LinkCreated event.
Public delegate | AddFlowLinkCreatingEventHandler | Represents the method that will handle the LinkCreating event.
Public delegate | AddFlowLinkDeletedEventHandler | Represents the method that will handle the LinkDeleted event.
Public delegate | AddFlowLinkDeletingEventHandler | Represents the method that will handle the LinkDeleting event.
Public delegate | AddFlowNodeCreatedEventHandler | Represents the method that will handle the NodeCreated event.
Public delegate | AddFlowNodeCreatingEventHandler | Represents the method that will handle the NodeCreating event.
Public delegate | AddFlowNodeDeletedEventHandler | Represents the method that will handle the NodeDeleted event.
Public delegate | AddFlowNodeDeletingEventHandler | Represents the method that will handle the NodeDeleting event.
Public delegate | AddFlowOrgChangedEventHandler | Represents the method that will handle the OrgChanged event.
Public delegate | AddFlowOrgChangingEventHandler | Represents the method that will handle the OrgChanging event.
Public delegate | AddFlowSelectedItemsLayoutingEventHandler | Represents the method that will handle the SelectedItemsLayouting event.
Public delegate | AddFlowSelectedItemsRotatingEventHandler | Represents the method that will handle the SelectedItemsRotating event.
Public delegate | AddFlowSelectedLinkStretchingEventHandler | Represents the method that will handle the SelectedLinkStretching event.
Public delegate | AddFlowSelectionChangedEventHandler | Represents the method that will handle the SelectionChanged event.
Public delegate | ToolTipContentProviderDelegate | Returns the content of a Tooltip
Enumerations
 | Enumeration | Description
Public enumeration | Action | Used to specify an action that can be undone
Public enumeration | BackMode | Used to specify whether the background will remain untouched or not for the text in a node.
Public enumeration | ConnectionMode | Used to specify how a link is connected to a node
Public enumeration | DockStyle | Used to specify the caption dock style.
Public enumeration | ErrorEventType | Used to specify the type of the Error event
Public enumeration | GridStyle | Used to specify the drawing style of the grid.
Public enumeration | ImagePosition | Used to specify the position of the image in the node.
Public enumeration | ItemSet | Used to specify a set of items (nodes and links)
Public enumeration | LineStyle | Used to specify the style used to draw a link.
Public enumeration | MouseSelection | Used to specify the selection rectangle action with the mouse.
Public enumeration | PinShape | Used to specify the pin shape
Public enumeration | ShadowStyle | Used to specify the node shadow style.
Public enumeration | TextPlacementMode | Used to specify the position of the link text near the link.
Public enumeration | TextPosition | Used to specify the position of the text in the ContentItem object.

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


Action Enumeration

Action Enumeration
Used to specify an action that can be undone

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public enum Action
Public Enumeration Action
public enum class Action
type Action
Members
Member name | Value | Description
DeleteSel | -1 | The selected items are deleted
Dst | -2 | The destination node of a link is changed
ItemLayout | -3 | A node or a caption is moved or resized
CaptionAdd | -4 | A caption is created
CaptionRemove | -5 | A caption is deleted
InPlaceTextEdition | -6 | The text of a node has been changed directly in the node
LineStyle | -7 | The LineStyle property of a link is changed
LinkAdd | -8 | A link is created
LinkRemove | -9 | A link is deleted
LinkStretch | -10 | A link is stretched
NodeAdd | -11 | A node is created
NodeRemove | -12 | A node is deleted
NodeRotate | -13 | A node is rotated
None | -14 | No action
Org | -15 | The origin node of a link is changed
Owner | -16 | The owner of a caption is changed
PinDstIndex | -17 | The index of the destination pin is changed
PinOrgIndex | -18 | The index of the origin pin is changed
Points | -19 | The points collection of a link is changed
Reverse | -20 | A link is rotated
ZOrder | -21 | The ZOrder of an item is changed
See Also

Reference

Lassalle.WPF.Flow Namespace


AddFlow Class

AddFlow Class
The AddFlow control
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsPanel
System.Windows.ControlsCanvas
Lassalle.WPF.FlowAddFlow

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public class AddFlow : Canvas, IScrollInfo
Public Class AddFlow
    Inherits Canvas
    Implements IScrollInfo
public ref class AddFlow : public Canvas,
    IScrollInfo
type AddFlow =
    class
        inherit Canvas
        interface IScrollInfo
    end

The AddFlow type exposes the following members.

Constructors
 | Name | Description
Public method | AddFlow | AddFlow constructor
Top
Methods
 | Name | Description
Public method | AddCaption | Add a caption object to the AddFlow control.
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | AddLink | Add a link to the diagram
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddNode | Add a node to the diagram
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Arranges the content of a Canvas element. (Inherited from Canvas.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BeginUpdate | Disables any redrawing of the AddFlow control.
Public method | BringForward | Bring the selected items forward
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringToFront | Bring the selected items at the front of the zorder list
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Clear | Clears all the content the AddFlow diagram
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | Delete | Deletes the current selection of the AddFlow diagram
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | EndUpdate | Enables the redrawing of the AddFlow control.
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetDiagramBounds | Calculate and returns the smallest rectangle that contains all the items of the diagram.
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetItemAt(Point) | Retrieves the selectable item at the specified location.
Public method | GetItemAt(Point, ItemSet) | Retrieves the item at the specified location.
Protected method | GetLayoutClip | Returns a clipping geometry that indicates the area that will be clipped if the ClipToBounds property is set to true. (Inherited from Canvas.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides Visual.GetVisualChild, and returns a child at the specified index from a collection of child elements. (Overrides PanelGetVisualChild(Int32).)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | LineDown | Scroll down one small scroll increment.
Public method | LineLeft | Scroll left by one small scroll increment.
Public method | LineRight | Scroll right by one small scroll increment
Public method | LineUp | Scroll up by one small scroll increment
Public method | MakeVisible | Make the given visual at the given bounds visible.
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Overrides CanvasMeasureOverride(Size).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseWheelDown | Scroll down by one mouse wheel increment.
Public method | MouseWheelLeft | Scroll left by one mouse wheel increment.
Public method | MouseWheelRight | Scroll right by one mouse wheel increment.
Public method | MouseWheelUp | Scroll up by one mouse wheel increment.
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnAfterEdit | Raises the AfterEdit event
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnBeforeEdit | Raises the BeforeEdit event
Protected method | OnCancelEdit | Raises the CancelEdit event
Protected method | OnCaptionCreated | Raises the CaptionCreated event
Protected method | OnCaptionCreating | Raises the CaptionCreating event
Protected method | OnCaptionDeleted | Raises the CaptionDeleted event
Protected method | OnCaptionDeleting | Raises the CaptionDeleting event
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDstChanged | Raises the DstChanged event
Protected method | OnDstChanging | Raises the DstChanging event. Cancelling the action aborts the destination change.
Protected method | OnError | Raises the Error event
Protected method | OnExtentChanged | Raises the ExtentChanged event
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLinkCreated | Raises the LinkCreated event
Protected method | OnLinkCreating | Raises the LinkCreating event
Protected method | OnLinkDeleted | Raises the LinkDeleted event
Protected method | OnLinkDeleting | Raises the LinkDeleting event
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | (Overrides UIElementOnLostMouseCapture(MouseEventArgs).)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture . (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled Mouse.MouseEnter attached event is raised on this element. (Inherited from UIElement) (Overrides UIElementOnMouseLeave(MouseEventArgs).)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. (Inherited from UIElement) (Overrides UIElementOnMouseLeftButtonDown(MouseButtonEventArgs).)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event is raised on this element. (Inherited from UIElement) (Overrides UIElementOnMouseLeftButtonUp(MouseButtonEventArgs).)
Protected method | OnMouseMove | Invoked when an unhandled Mouse.MouseMove attached event reaches an element in its route that is derived from this class. (Inherited from UIElement) (Overrides UIElementOnMouseMove(MouseEventArgs).)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnNodeCreated | Raises the NodeCreated event
Protected method | OnNodeCreating | Raises the NodeCreating event
Protected method | OnNodeDeleted | Raises the NodeDeleted event
Protected method | OnNodeDeleting | Raises the NodeDeleting event
Protected method | OnOrgChanged | Raises the OrgChanged event
Protected method | OnOrgChanging | Raises the OrgChanging event. Cancelling the action aborts the origin change.
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.) (Overrides PanelOnRender(DrawingContext).)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSelectedItemsLayouting | Raises the SelectedNodesLayouting event. Cancelling the action aborts the resizing or moving action.
Protected method | OnSelectedItemsRotating | Raises the SelectedItemsRotating event. Cancelling the action aborts the rotating action.
Protected method | OnSelectedLinkStretching | Raises the SelectedLinkStretching event. Cancelling the action aborts the stretching action.
Protected method | OnSelectionChanged | Raises the SelectionChanged event
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Invoked when the VisualCollection of a visual object is modified. (Inherited from Panel.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Public method | PageDown | Page down by one view port height amount.
Public method | PageLeft | Page left by one view port width amount.
Public method | PageRight | Page right by one view port width amount.
Public method | PageUp | Page up by one view port height amount.
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveCaption | Remove the specified caption from the AddFlow control
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | RemoveLink | Remove a link from the canvas
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Public method | RemoveNode | Remove a node from the canvas
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ResetChangedFlag | Allow setting a flag indicating that the diagram is not still changed. Typically, you should call this method just after having saved the diagram.
Public method | SelectAll | Selects all the items of the diagram
Public method | SendBackward | Send the selected items backward
Public method | SendToBack | Send the selected items at the back of the zorder list
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetHorizontalOffset | Scroll to the given absolute horizontal scroll position.
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | SetVerticalOffset | Scroll to the given absolute vertical scroll position.
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UnselectAll | Command that unselects all the items of the diagram
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ZoomRectangle | Zoom a rectangular portion of the diagram.
Top
Fields
Name | Description
GridColorProperty | Identifies the GridColor dependency property.
GridDrawProperty | Identifies the GridDraw dependency property.
GridSizeProperty | Identifies the GridSize dependency property.
GridSnapProperty | Identifies the GridSnap dependency property.
GridStyleProperty | Identifies the GridStyle dependency property.
IsCreatingCaptionProperty | Identifies the IsCreatingCaption dependency property.
IsCreatingLinkProperty | Identifies the IsCreatingLink dependency property.
IsCreatingNodeProperty | Identifies the IsCreatingNode dependency property.
IsInPlaceEditingProperty | Identifies the IsInPlaceEditing dependency property
IsMouseOverPinProperty | Identifies the IsMouseOverPinProperty dependency property
IsMovingProperty | Identifies the IsMoving dependency property.
IsPanningProperty | Identifies the IsPanning dependency property
IsResizingProperty | Identifies the IsResizing dependency property.
IsRotatingProperty | Identifies the IsRotating dependency property.
IsSelectingProperty | Identifies the IsSelecting dependency property
IsStretchingProperty | Identifies the IsStretching dependency property.
IsZoomingProperty | Identifies the IsZooming dependency property
ItemProperty | Attached property used internally to store a reference to the Item object associated to a visual object in the canvas.
PinFillProperty | Identifies the PinFill dependency property.
PinShapeProperty | Identifies the PinShape dependency property.
PinSizeProperty | Identifies the PinSize dependency property
PinStrokeProperty | Identifies the PinStroke dependency property.
ResizeHandleStyleProperty | Identifies the ResizeHandleStyle dependency property
RotateHandleStyleProperty | Identifies the RotateHandleStyle dependency property
SelectionBoxStyleProperty | Identifies the SelectionBoxStyle dependency property
StretchHandleStyleProperty | Identifies the StretchHandleStyle dependency property
ZoomingBoxStyleProperty | Identifies the ZoomingBoxStyle dependency property
ZoomProperty | Identifies the Zoom dependency property.
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CanChangeDst | Determines whether the user can interactively change the destination of a link.
Public property | CanChangeOrg | Determines whether the user can interactively change the origin of a link.
Public property | CanDragScroll | Determines whether drag scrolling is allowed or not.
Public property | CanDrawCaption | Determines whether interactive creation of captions is allowed or not.
Public property | CanDrawLink | Determines whether interactive creation of links is allowed or not.
Public property | CanDrawNode | Determines whether interactive creation of nodes is allowed or not.
Public property | CanEditContentItem | Determines whether the user can edit the text of ContentItem objects.
Public property | CanFireError | Determines if the error event is fired or not.
Public property | CanHorizontallyScroll | Return whether we are allowed to scroll horizontally.
Public property | CanMoveItems | Determines whether interactive dragging of items is allowed or not.
Public property | CanMultiLink | Determines whether you can create several links between two nodes or not.
Public property | CanMultiSelect | Determines whether multiselection mode of nodes and links is allowed or not.
Public property | CanReflexLink | Determines whether you can create reflexive links. A link is reflexive if its destination and origin nodes are the same.
Public property | CanRotateNode | Determines whether interactive dragging of nodes is allowed or not
Public property | CanSelectOnMouseMove | Indicates whether the selection of items with the mouse is made only when the MouseUp event is fired or at each MouseMove event.
Public property | CanSendSelectionChangedEvent | Determines whether the SelectionChanged event is fired or not.
Public property | CanShowJumps | Determines whether jumps are displayed at the intersection of links. The default value is false.
Public property | CanSizeItems | Determines whether you can resize items interactively or not.
Public property | CanStretchLink | Determines whether you can "stretch" links (i.e add or remove segments) interactively or not.
Public property | CanVerticallyScroll | Return whether we are allowed to scroll vertically.
Public property | CaptionModel | Returns a caption object that contains the default property values for captions. When a caption is created, it receives these property values.
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Inherited from UIElement.)
Public property | Extent | Returns the diagram size.
Public property | ExtentHeight | The height of the canvas to be scrolled.
Public property | ExtentWidth | The width of the canvas to be scrolled.
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | GridColor | Returns/sets the grid color.
Public property | GridDraw | Determines whether the grid is displayed or not.
Public property | GridSize | Returns/sets the horizontal and vertical grid size.
Public property | GridSnap | Determines whether nodes are aligned on the grid.
Public property | GridStyle | Returns/sets the grid style.
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HitItem | Returns the item pointed by the mouse.
Public property | HitPin | Returns the pin pointed by the mouse.
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalOffset | Get the current horizontal scroll position.
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsChanged | Indicates if the AddFlow diagram has changed.
Public property | IsCreatingCaption | Indicates if the user is currently creating a caption
Public property | IsCreatingLink | Indicates if the user is currently creating a link
Public property | IsCreatingNode | Indicates if the user is currently creating a node
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInPlaceEditing | Indicates if the user is currently editing the text of a ContentItem object
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsInteractiveEventsOnly | Determines whether events can occur only with interactive actions.
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Inherited from UIElement.)
Public property | IsMouseOverPin | Indicates if the mouse is over a pin.
Public property | IsMoving | Indicates if the user is currently moving nodes
Public property | IsPanning | Indicates if the user is currently panning the diagram
Public property | IsResizing | Indicates if the user is currently moving nodes
Public property | IsRotating | Indicates if the user is currently rotating items
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelecting | Indicates if the user is currently selecting items with the mouse
Public property | IsStretching | Indicates if the user is currently stretching a link
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Inherited from UIElement.)
Public property | IsUnselectableItemHitable | Determines whether unselectable items are ignored in hit testing
Public property | IsVirtualizing | Determines whether virtualization mode is set or not
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Inherited from UIElement.)
Public property | IsZooming | Indicates if the user is currently zooming the diagram
Public property | Items | Returns the list of items
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
 | LicenseKey |
Public property | LinkModel | Returns a link object that contains the default property values for links. When a link is created, it receives these property values.
Public property | LinkSelectionAreaWidth | Returns/sets a value that determines the width of the area where the user has to click to select a link.
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MouseSelection | Returns/sets the selection rectangle action (select items, zoom,...).
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | NodeModel | Returns a node object that contains the default property values for nodes. When a node is created, it receives these property values.
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Inherited from UIElement.)
Public property | Origin | Returns the diagram top left point.
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | PinFill | Returns/sets the brush used to fill the pins
Public property | PinShape | Returns/sets the shape used to draw the pins
Public property | PinSize | Gets or sets the size fo the pins.
Public property | PinStroke | Returns/sets the brush used to draw the pins
Public property | RemovePointDistance | Returns/sets a value that determines if the user can remove a link point by dragging the handle to a position where it has a very obtuse angle to its surrounding link points.
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Inherited from UIElement.)
Public property | ResizeHandleStyle | Gets or sets the Style used for the node resizing thumbs.
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RotateHandleStyle | Gets or sets the Style used for the node rotating thumb.
Public property | ScrollIncrement | Set the scroll amount for the scroll bar arrows.
Public property | ScrollOwner | Return the ScrollViewer that contains this object.
Public property | SelectedItems | Returns the list of selected items
Public property | SelectionBoxStyle | Gets or sets the style used for the selection box.
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Inherited from UIElement.)
Public property | StretchHandleStyle | Gets or sets the Style used for the link stretching thumbs.
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TaskManager | Returns the object managing the list of tasks and allowing undo/redo.
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the Uid for this element. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalOffset | Return the current vertical scroll position.
Public property | ViewportHeight | Return the height of the current viewport that is visible in the ScrollViewer.
Public property | ViewportWidth | Return the width of the current viewport that is visible in the ScrollViewer.
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. (Inherited from UIElement.)
Public property | Visual | Returns the visual used to draw the diagram.
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement) (Overrides PanelVisualChildrenCount.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Zoom | Returns/sets the zooming factor.
Public property | ZoomingBoxStyle | Gets or sets the style used for the zooming box.
Top
Events
 | Name | Description
Public event | AfterEdit | Occurs after a user edits the text of the selected node.
Public event | BeforeEdit | Occurs when a user attempts to edit the text of the selected node. Cancelling the action aborts the inline edit.
Public event | CancelEdit | Occurs after a user cancels the text edition of the selected node.
Public event | CaptionCreated | Occurs after a user creates a caption.
Public event | CaptionCreating | Occurs when a user attempts to create a caption. Cancelling the action aborts the caption creation.
Public event | CaptionDeleted | Occurs after a user removes a caption.
Public event | CaptionDeleting | Occurs when a user attempts to create a caption. Cancelling the action aborts the caption creation.
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DstChanged | Occurs after a user has changed the destination node of a link.
Public event | DstChanging | Occurs when a user attempts to change the destination node of a link.
Public event | Error | This event is fired when the user tries to make some actions that are not allowed: - creating a reflexive link if the CanReflexLink property is false - creating a second link between 2 nodes if the CanMultiLink property is false The CanFireError property must be set.
Public event | ExtentChanged | This event is fired each time the size of the diagram is changed.
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | LinkCreated | Occurs after a user creates a link.
Public event | LinkCreating | Occurs when a user attempts to create a link. Cancelling the action aborts the link creation.
Public event | LinkDeleted | Occurs after a user removes a link.
Public event | LinkDeleting | Occurs when a user attempts to create a link. Cancelling the action aborts the link creation.
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | NodeCreated | Occurs after a user creates a node.
Public event | NodeCreating | Occurs when a user attempts to create a node. Cancelling the action aborts the node creation.
Public event | NodeDeleted | Occurs after a user removes a node.
Public event | NodeDeleting | Occurs when a user attempts to create a node. Cancelling the action aborts the node creation.
Public event | OrgChanged | Occurs after a user has changed the origin node of a link.
Public event | OrgChanging | Occurs when a user attempts to change the origin node of a link.
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SelectedItemsLayouting | Occurs when a user is currently moving or resizing a node
Public event | SelectedItemsRotating | Occurs when a user is currently rotating an item
Public event | SelectedLinkStretching | Occurs when a user is currently stretching a link.
Public event | SelectionChanged | Occurs when the selection status of an item is changed
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


AddFlow Constructor

AddFlow Constructor
AddFlow constructor

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public AddFlow()
Public Sub New
public:
AddFlow()
new : unit -> AddFlow
See Also

Reference

AddFlow Class


AddFlow Fields

AddFlow Fields

The AddFlow type exposes the following members.

Fields
Name | Description
GridColorProperty | Identifies the GridColor dependency property.
GridDrawProperty | Identifies the GridDraw dependency property.
GridSizeProperty | Identifies the GridSize dependency property.
GridSnapProperty | Identifies the GridSnap dependency property.
GridStyleProperty | Identifies the GridStyle dependency property.
IsCreatingCaptionProperty | Identifies the IsCreatingCaption dependency property.
IsCreatingLinkProperty | Identifies the IsCreatingLink dependency property.
IsCreatingNodeProperty | Identifies the IsCreatingNode dependency property.
IsInPlaceEditingProperty | Identifies the IsInPlaceEditing dependency property
IsMouseOverPinProperty | Identifies the IsMouseOverPinProperty dependency property
IsMovingProperty | Identifies the IsMoving dependency property.
IsPanningProperty | Identifies the IsPanning dependency property
IsResizingProperty | Identifies the IsResizing dependency property.
IsRotatingProperty | Identifies the IsRotating dependency property.
IsSelectingProperty | Identifies the IsSelecting dependency property
IsStretchingProperty | Identifies the IsStretching dependency property.
IsZoomingProperty | Identifies the IsZooming dependency property
ItemProperty | Attached property used internally to store a reference to the Item object associated to a visual object in the canvas.
PinFillProperty | Identifies the PinFill dependency property.
PinShapeProperty | Identifies the PinShape dependency property.
PinSizeProperty | Identifies the PinSize dependency property
PinStrokeProperty | Identifies the PinStroke dependency property.
ResizeHandleStyleProperty | Identifies the ResizeHandleStyle dependency property
RotateHandleStyleProperty | Identifies the RotateHandleStyle dependency property
SelectionBoxStyleProperty | Identifies the SelectionBoxStyle dependency property
StretchHandleStyleProperty | Identifies the StretchHandleStyle dependency property
ZoomingBoxStyleProperty | Identifies the ZoomingBoxStyle dependency property
ZoomProperty | Identifies the Zoom dependency property.
Top
See Also

Reference

AddFlow Class


AddFlow.GridColorProperty Field

AddFlowGridColorProperty Field
Identifies the GridColor dependency property.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty GridColorProperty
Public Shared ReadOnly GridColorProperty As DependencyProperty
public:
static initonly DependencyProperty^ GridColorProperty
static val GridColorProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

AddFlow Class


AddFlow.GridDrawProperty Field

AddFlowGridDrawProperty Field
Identifies the GridDraw dependency property.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty GridDrawProperty
Public Shared ReadOnly GridDrawProperty As DependencyProperty
public:
static initonly DependencyProperty^ GridDrawProperty
static val GridDrawProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

AddFlow Class


AddFlow.GridSizeProperty Field

AddFlowGridSizeProperty Field
Identifies the GridSize dependency property.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty GridSizeProperty
Public Shared ReadOnly GridSizeProperty As DependencyProperty
public:
static initonly DependencyProperty^ GridSizeProperty
static val GridSizeProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

AddFlow Class


AddFlow.GridSnapProperty Field

AddFlowGridSnapProperty Field
Identifies the GridSnap dependency property.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty GridSnapProperty
Public Shared ReadOnly GridSnapProperty As DependencyProperty
public:
static initonly DependencyProperty^ GridSnapProperty
static val GridSnapProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

AddFlow Class


AddFlow.GridStyleProperty Field

AddFlowGridStyleProperty Field
Identifies the GridStyle dependency property.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty GridStyleProperty
Public Shared ReadOnly GridStyleProperty As DependencyProperty
public:
static initonly DependencyProperty^ GridStyleProperty
static val GridStyleProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

AddFlow Class


AddFlow.IsCreatingCaptionProperty Field

AddFlowIsCreatingCaptionProperty Field
Identifies the IsCreatingCaption dependency property.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty IsCreatingCaptionProperty
Public Shared ReadOnly IsCreatingCaptionProperty As DependencyProperty
public:
static initonly DependencyProperty^ IsCreatingCaptionProperty
static val IsCreatingCaptionProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

AddFlow Class


AddFlow.IsCreatingLinkProperty Field

AddFlowIsCreatingLinkProperty Field
Identifies the IsCreatingLink dependency property.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty IsCreatingLinkProperty
Public Shared ReadOnly IsCreatingLinkProperty As DependencyProperty
public:
static initonly DependencyProperty^ IsCreatingLinkProperty
static val IsCreatingLinkProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

AddFlow Class


AddFlow.IsCreatingNodeProperty Field

AddFlowIsCreatingNodeProperty Field
Identifies the IsCreatingNode dependency property.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty IsCreatingNodeProperty
Public Shared ReadOnly IsCreatingNodeProperty As DependencyProperty
public:
static initonly DependencyProperty^ IsCreatingNodeProperty
static val IsCreatingNodeProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

AddFlow Class


AddFlow.IsInPlaceEditingProperty Field

AddFlowIsInPlaceEditingProperty Field
Identifies the IsInPlaceEditing dependency property

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty IsInPlaceEditingProperty
Public Shared ReadOnly IsInPlaceEditingProperty As DependencyProperty
public:
static initonly DependencyProperty^ IsInPlaceEditingProperty
static val IsInPlaceEditingProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

AddFlow Class


AddFlow.IsMouseOverPinProperty Field

AddFlowIsMouseOverPinProperty Field
Identifies the IsMouseOverPinProperty dependency property

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty IsMouseOverPinProperty
Public Shared ReadOnly IsMouseOverPinProperty As DependencyProperty
public:
static initonly DependencyProperty^ IsMouseOverPinProperty
static val IsMouseOverPinProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

AddFlow Class


AddFlow.IsMovingProperty Field

AddFlowIsMovingProperty Field
Identifies the IsMoving dependency property.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty IsMovingProperty
Public Shared ReadOnly IsMovingProperty As DependencyProperty
public:
static initonly DependencyProperty^ IsMovingProperty
static val IsMovingProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

AddFlow Class


AddFlow.IsPanningProperty Field

AddFlowIsPanningProperty Field
Identifies the IsPanning dependency property

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty IsPanningProperty
Public Shared ReadOnly IsPanningProperty As DependencyProperty
public:
static initonly DependencyProperty^ IsPanningProperty
static val IsPanningProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

AddFlow Class


AddFlow.IsResizingProperty Field

AddFlowIsResizingProperty Field
Identifies the IsResizing dependency property.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty IsResizingProperty
Public Shared ReadOnly IsResizingProperty As DependencyProperty
public:
static initonly DependencyProperty^ IsResizingProperty
static val IsResizingProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

AddFlow Class


AddFlow.IsRotatingProperty Field

AddFlowIsRotatingProperty Field
Identifies the IsRotating dependency property.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty IsRotatingProperty
Public Shared ReadOnly IsRotatingProperty As DependencyProperty
public:
static initonly DependencyProperty^ IsRotatingProperty
static val IsRotatingProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

AddFlow Class


AddFlow.IsSelectingProperty Field

AddFlowIsSelectingProperty Field
Identifies the IsSelecting dependency property

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty IsSelectingProperty
Public Shared ReadOnly IsSelectingProperty As DependencyProperty
public:
static initonly DependencyProperty^ IsSelectingProperty
static val IsSelectingProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

AddFlow Class


AddFlow.IsStretchingProperty Field

AddFlowIsStretchingProperty Field
Identifies the IsStretching dependency property.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty IsStretchingProperty
Public Shared ReadOnly IsStretchingProperty As DependencyProperty
public:
static initonly DependencyProperty^ IsStretchingProperty
static val IsStretchingProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

AddFlow Class


AddFlow.IsZoomingProperty Field

AddFlowIsZoomingProperty Field
Identifies the IsZooming dependency property

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty IsZoomingProperty
Public Shared ReadOnly IsZoomingProperty As DependencyProperty
public:
static initonly DependencyProperty^ IsZoomingProperty
static val IsZoomingProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

AddFlow Class


AddFlow.ItemProperty Field

AddFlowItemProperty Field
Attached property used internally to store a reference to the Item object associated to a visual object in the canvas.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public static DependencyProperty ItemProperty
Public Shared ItemProperty As DependencyProperty
public:
static DependencyProperty^ ItemProperty
static val mutable ItemProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

AddFlow Class


AddFlow.PinFillProperty Field

AddFlowPinFillProperty Field
Identifies the PinFill dependency property.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty PinFillProperty
Public Shared ReadOnly PinFillProperty As DependencyProperty
public:
static initonly DependencyProperty^ PinFillProperty
static val PinFillProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

AddFlow Class


AddFlow.PinShapeProperty Field

AddFlowPinShapeProperty Field
Identifies the PinShape dependency property.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty PinShapeProperty
Public Shared ReadOnly PinShapeProperty As DependencyProperty
public:
static initonly DependencyProperty^ PinShapeProperty
static val PinShapeProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

AddFlow Class


AddFlow.PinSizeProperty Field

AddFlowPinSizeProperty Field
Identifies the PinSize dependency property

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty PinSizeProperty
Public Shared ReadOnly PinSizeProperty As DependencyProperty
public:
static initonly DependencyProperty^ PinSizeProperty
static val PinSizeProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

AddFlow Class


AddFlow.PinStrokeProperty Field

AddFlowPinStrokeProperty Field
Identifies the PinStroke dependency property.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty PinStrokeProperty
Public Shared ReadOnly PinStrokeProperty As DependencyProperty
public:
static initonly DependencyProperty^ PinStrokeProperty
static val PinStrokeProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

AddFlow Class


AddFlow.ResizeHandleStyleProperty Field

AddFlowResizeHandleStyleProperty Field
Identifies the ResizeHandleStyle dependency property

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty ResizeHandleStyleProperty
Public Shared ReadOnly ResizeHandleStyleProperty As DependencyProperty
public:
static initonly DependencyProperty^ ResizeHandleStyleProperty
static val ResizeHandleStyleProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

AddFlow Class


AddFlow.RotateHandleStyleProperty Field

AddFlowRotateHandleStyleProperty Field
Identifies the RotateHandleStyle dependency property

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty RotateHandleStyleProperty
Public Shared ReadOnly RotateHandleStyleProperty As DependencyProperty
public:
static initonly DependencyProperty^ RotateHandleStyleProperty
static val RotateHandleStyleProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

AddFlow Class


AddFlow.SelectionBoxStyleProperty Field

AddFlowSelectionBoxStyleProperty Field
Identifies the SelectionBoxStyle dependency property

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty SelectionBoxStyleProperty
Public Shared ReadOnly SelectionBoxStyleProperty As DependencyProperty
public:
static initonly DependencyProperty^ SelectionBoxStyleProperty
static val SelectionBoxStyleProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

AddFlow Class


AddFlow.StretchHandleStyleProperty Field

AddFlowStretchHandleStyleProperty Field
Identifies the StretchHandleStyle dependency property

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty StretchHandleStyleProperty
Public Shared ReadOnly StretchHandleStyleProperty As DependencyProperty
public:
static initonly DependencyProperty^ StretchHandleStyleProperty
static val StretchHandleStyleProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

AddFlow Class


AddFlow.ZoomingBoxStyleProperty Field

AddFlowZoomingBoxStyleProperty Field
Identifies the ZoomingBoxStyle dependency property

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty ZoomingBoxStyleProperty
Public Shared ReadOnly ZoomingBoxStyleProperty As DependencyProperty
public:
static initonly DependencyProperty^ ZoomingBoxStyleProperty
static val ZoomingBoxStyleProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

AddFlow Class


AddFlow.ZoomProperty Field

AddFlowZoomProperty Field
Identifies the Zoom dependency property.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty ZoomProperty
Public Shared ReadOnly ZoomProperty As DependencyProperty
public:
static initonly DependencyProperty^ ZoomProperty
static val ZoomProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

AddFlow Class


AddFlow Methods

AddFlow Methods

The AddFlow type exposes the following members.

Methods
 | Name | Description
Public method | AddCaption | Add a caption object to the AddFlow control.
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | AddLink | Add a link to the diagram
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddNode | Add a node to the diagram
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Arranges the content of a Canvas element. (Inherited from Canvas.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BeginUpdate | Disables any redrawing of the AddFlow control.
Public method | BringForward | Bring the selected items forward
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringToFront | Bring the selected items at the front of the zorder list
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Clear | Clears all the content the AddFlow diagram
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | Delete | Deletes the current selection of the AddFlow diagram
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | EndUpdate | Enables the redrawing of the AddFlow control.
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetDiagramBounds | Calculate and returns the smallest rectangle that contains all the items of the diagram.
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetItemAt(Point) | Retrieves the selectable item at the specified location.
Public method | GetItemAt(Point, ItemSet) | Retrieves the item at the specified location.
Protected method | GetLayoutClip | Returns a clipping geometry that indicates the area that will be clipped if the ClipToBounds property is set to true. (Inherited from Canvas.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides Visual.GetVisualChild, and returns a child at the specified index from a collection of child elements. (Overrides PanelGetVisualChild(Int32).)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | LineDown | Scroll down one small scroll increment.
Public method | LineLeft | Scroll left by one small scroll increment.
Public method | LineRight | Scroll right by one small scroll increment
Public method | LineUp | Scroll up by one small scroll increment
Public method | MakeVisible | Make the given visual at the given bounds visible.
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Overrides CanvasMeasureOverride(Size).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseWheelDown | Scroll down by one mouse wheel increment.
Public method | MouseWheelLeft | Scroll left by one mouse wheel increment.
Public method | MouseWheelRight | Scroll right by one mouse wheel increment.
Public method | MouseWheelUp | Scroll up by one mouse wheel increment.
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnAfterEdit | Raises the AfterEdit event
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnBeforeEdit | Raises the BeforeEdit event
Protected method | OnCancelEdit | Raises the CancelEdit event
Protected method | OnCaptionCreated | Raises the CaptionCreated event
Protected method | OnCaptionCreating | Raises the CaptionCreating event
Protected method | OnCaptionDeleted | Raises the CaptionDeleted event
Protected method | OnCaptionDeleting | Raises the CaptionDeleting event
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDstChanged | Raises the DstChanged event
Protected method | OnDstChanging | Raises the DstChanging event. Cancelling the action aborts the destination change.
Protected method | OnError | Raises the Error event
Protected method | OnExtentChanged | Raises the ExtentChanged event
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLinkCreated | Raises the LinkCreated event
Protected method | OnLinkCreating | Raises the LinkCreating event
Protected method | OnLinkDeleted | Raises the LinkDeleted event
Protected method | OnLinkDeleting | Raises the LinkDeleting event
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | (Overrides UIElementOnLostMouseCapture(MouseEventArgs).)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture . (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled Mouse.MouseEnter attached event is raised on this element. (Inherited from UIElement) (Overrides UIElementOnMouseLeave(MouseEventArgs).)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. (Inherited from UIElement) (Overrides UIElementOnMouseLeftButtonDown(MouseButtonEventArgs).)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event is raised on this element. (Inherited from UIElement) (Overrides UIElementOnMouseLeftButtonUp(MouseButtonEventArgs).)
Protected method | OnMouseMove | Invoked when an unhandled Mouse.MouseMove attached event reaches an element in its route that is derived from this class. (Inherited from UIElement) (Overrides UIElementOnMouseMove(MouseEventArgs).)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnNodeCreated | Raises the NodeCreated event
Protected method | OnNodeCreating | Raises the NodeCreating event
Protected method | OnNodeDeleted | Raises the NodeDeleted event
Protected method | OnNodeDeleting | Raises the NodeDeleting event
Protected method | OnOrgChanged | Raises the OrgChanged event
Protected method | OnOrgChanging | Raises the OrgChanging event. Cancelling the action aborts the origin change.
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.) (Overrides PanelOnRender(DrawingContext).)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSelectedItemsLayouting | Raises the SelectedNodesLayouting event. Cancelling the action aborts the resizing or moving action.
Protected method | OnSelectedItemsRotating | Raises the SelectedItemsRotating event. Cancelling the action aborts the rotating action.
Protected method | OnSelectedLinkStretching | Raises the SelectedLinkStretching event. Cancelling the action aborts the stretching action.
Protected method | OnSelectionChanged | Raises the SelectionChanged event
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Invoked when the VisualCollection of a visual object is modified. (Inherited from Panel.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Public method | PageDown | Page down by one view port height amount.
Public method | PageLeft | Page left by one view port width amount.
Public method | PageRight | Page right by one view port width amount.
Public method | PageUp | Page up by one view port height amount.
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveCaption | Remove the specified caption from the AddFlow control
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | RemoveLink | Remove a link from the canvas
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Public method | RemoveNode | Remove a node from the canvas
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ResetChangedFlag | Allow setting a flag indicating that the diagram is not still changed. Typically, you should call this method just after having saved the diagram.
Public method | SelectAll | Selects all the items of the diagram
Public method | SendBackward | Send the selected items backward
Public method | SendToBack | Send the selected items at the back of the zorder list
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetHorizontalOffset | Scroll to the given absolute horizontal scroll position.
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | SetVerticalOffset | Scroll to the given absolute vertical scroll position.
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UnselectAll | Command that unselects all the items of the diagram
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ZoomRectangle | Zoom a rectangular portion of the diagram.
Top
See Also

Reference

AddFlow Class


AddFlow.AddCaption Method

AddFlowAddCaption Method
Add a caption object to the AddFlow control.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void AddCaption(
    Caption caption
)
Public Sub AddCaption (
    caption As Caption
)
public:
void AddCaption(
    Caption^ caption
)
member AddCaption :
        caption : Caption -> unit

Parameters

caption
Type: Lassalle.WPF.FlowCaption
A reference to the caption object to add
Exceptions
Exception | Condition
AddFlowException | Thrown if the caption object is already owned by an AddFlow control
Remarks
A Caption object can only be assigned to one AddFlow control at a time. To add the caption to a new AddFlow control, you must remove it from the other AddFlow first, or clone it.
See Also

Reference

AddFlow Class


AddFlow.AddLink Method

AddFlowAddLink Method
Add a link to the diagram

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void AddLink(
    Link link
)
Public Sub AddLink (
    link As Link
)
public:
void AddLink(
    Link^ link
)
member AddLink :
        link : Link -> unit

Parameters

link
Type: Lassalle.WPF.FlowLink
A reference to the link to add to the diagram
See Also

Reference

AddFlow Class


AddFlow.AddNode Method

AddFlowAddNode Method
Add a node to the diagram

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void AddNode(
    Node node
)
Public Sub AddNode (
    node As Node
)
public:
void AddNode(
    Node^ node
)
member AddNode :
        node : Node -> unit

Parameters

node
Type: Lassalle.WPF.FlowNode
the node to add to the diagram
See Also

Reference

AddFlow Class


AddFlow.BeginUpdate Method

AddFlowBeginUpdate Method
Disables any redrawing of the AddFlow control.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void BeginUpdate()
Public Sub BeginUpdate
public:
void BeginUpdate()
member BeginUpdate : unit -> unit
Remarks
To maintain performance while items are added to the AddFlow control, call the BeginUpdate method. The BeginUpdate method prevents the control from painting until the EndUpdate method is called. Also, between the calls to BeginUpdate and EndUpdate, the size of the diagram is not updated. It is updated only when the EndUpdate method is called.
See Also

Reference

AddFlow Class


AddFlow.BringForward Method

AddFlowBringForward Method
Bring the selected items forward

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void BringForward()
Public Sub BringForward
public:
void BringForward()
member BringForward : unit -> unit
See Also

Reference

AddFlow Class


AddFlow.BringToFront Method

AddFlowBringToFront Method
Bring the selected items at the front of the zorder list

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void BringToFront()
Public Sub BringToFront
public:
void BringToFront()
member BringToFront : unit -> unit
See Also

Reference

AddFlow Class


AddFlow.Clear Method

AddFlowClear Method
Clears all the content the AddFlow diagram

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

AddFlow Class


AddFlow.Delete Method

AddFlowDelete Method
Deletes the current selection of the AddFlow diagram

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void Delete()
Public Sub Delete
public:
void Delete()
member Delete : unit -> unit
See Also

Reference

AddFlow Class


AddFlow.EndUpdate Method

AddFlowEndUpdate Method
Enables the redrawing of the AddFlow control.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void EndUpdate()
Public Sub EndUpdate
public:
void EndUpdate()
member EndUpdate : unit -> unit
Remarks
To maintain performance while items are added to the AddFlow control, call the BeginUpdate method. The BeginUpdate method prevents the control from painting until the EndUpdate method is called. Also, between the calls to BeginUpdate and EndUpdate, the size of the diagram is not updated. It is updated only when the EndUpdate method is called.
See Also

Reference

AddFlow Class


AddFlow.GetDiagramBounds Method

AddFlowGetDiagramBounds Method
Calculate and returns the smallest rectangle that contains all the items of the diagram.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Rect GetDiagramBounds()
Public Function GetDiagramBounds As Rect
public:
Rect GetDiagramBounds()
member GetDiagramBounds : unit -> Rect

Return Value

Type: Rect
The bounding recatngle.
Remarks
Generally, this method returns the same information as the Extent and Origin properties. However it recalculates the size of the rectangle just before returning it, which is not the case of the Extent property. This method can be useful in some cases where the Extent and Origin properties have not been updated, for instance between the calls to the BeginUpdate and EndUpdate methods.
See Also

Reference

AddFlow Class


AddFlow.GetItemAt Method

AddFlowGetItemAt Method
Overload List
 | Name | Description
Public method | GetItemAt(Point) | Retrieves the selectable item at the specified location.
Public method | GetItemAt(Point, ItemSet) | Retrieves the item at the specified location.
Top
See Also

Reference

AddFlow Class


AddFlow.GetItemAt Method (Point)

AddFlowGetItemAt Method (Point)
Retrieves the selectable item at the specified location.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Item GetItemAt(
    Point pt
)
Public Function GetItemAt (
    pt As Point
) As Item
public:
Item^ GetItemAt(
    Point pt
)
member GetItemAt :
        pt : Point -> Item

Parameters

pt
Type: System.WindowsPoint
The Point to evaluate and retrieve the item from

Return Value

Type: Item
The selectable item at the specified point
Remarks
The point is given in AddFlow coordinates.
See Also

Reference

AddFlow Class
GetItemAt Overload


AddFlow.GetItemAt Method (Point, ItemSet)

AddFlowGetItemAt Method (Point, ItemSet)
Retrieves the item at the specified location.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Item GetItemAt(
    Point pt,
    ItemSet itemSet
)
Public Function GetItemAt (
    pt As Point,
    itemSet As ItemSet
) As Item
public:
Item^ GetItemAt(
    Point pt,
    ItemSet itemSet
)
member GetItemAt :
        pt : Point *
        itemSet : ItemSet -> Item

Parameters

pt
Type: System.WindowsPoint
The Point to evaluate and retrieve the item from
itemSet
Type: Lassalle.WPF.FlowItemSet
The set of items to take into account

Return Value

Type: Item
The item at the specified point
Remarks
The point is given in AddFlow coordinates.
See Also

Reference

AddFlow Class
GetItemAt Overload


AddFlow.GetVisualChild Method

AddFlowGetVisualChild Method
Overrides Visual.GetVisualChild, and returns a child at the specified index from a collection of child elements.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
protected override Visual GetVisualChild(
    int index
)
Protected Overrides Function GetVisualChild (
    index As Integer
) As Visual
protected:
virtual Visual^ GetVisualChild(
    int index
) override
abstract GetVisualChild :
        index : int -> Visual
override GetVisualChild :
        index : int -> Visual

Parameters

index
Type: SystemInt32
The zero-based index of the requested child element in the collection.

Return Value

Type: Visual
The requested child element. This should not return null
See Also

Reference

AddFlow Class


AddFlow.LineDown Method

AddFlowLineDown Method
Scroll down one small scroll increment.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void LineDown()
Public Sub LineDown
public:
virtual void LineDown() sealed
abstract LineDown : unit -> unit
override LineDown : unit -> unit

Implements

IScrollInfoLineDown
See Also

Reference

AddFlow Class


AddFlow.LineLeft Method

AddFlowLineLeft Method
Scroll left by one small scroll increment.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void LineLeft()
Public Sub LineLeft
public:
virtual void LineLeft() sealed
abstract LineLeft : unit -> unit
override LineLeft : unit -> unit

Implements

IScrollInfoLineLeft
See Also

Reference

AddFlow Class


AddFlow.LineRight Method

AddFlowLineRight Method
Scroll right by one small scroll increment

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void LineRight()
Public Sub LineRight
public:
virtual void LineRight() sealed
abstract LineRight : unit -> unit
override LineRight : unit -> unit

Implements

IScrollInfoLineRight
See Also

Reference

AddFlow Class


AddFlow.LineUp Method

AddFlowLineUp Method
Scroll up by one small scroll increment

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void LineUp()
Public Sub LineUp
public:
virtual void LineUp() sealed
abstract LineUp : unit -> unit
override LineUp : unit -> unit

Implements

IScrollInfoLineUp
See Also

Reference

AddFlow Class


AddFlow.MakeVisible Method

AddFlowMakeVisible Method
Make the given visual at the given bounds visible.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Rect MakeVisible(
    Visual visual,
    Rect rect
)
Public Function MakeVisible (
    visual As Visual,
    rect As Rect
) As Rect
public:
virtual Rect MakeVisible(
    Visual^ visual,
    Rect rect
) sealed
abstract MakeVisible :
        visual : Visual *
        rect : Rect -> Rect
override MakeVisible :
        visual : Visual *
        rect : Rect -> Rect

Parameters

visual
Type: System.Windows.MediaVisual
The visual that will become visible
rect
Type: System.WindowsRect
The bounds of that visual

Return Value

Type: Rect
The bounds that is actually visible.

Implements

IScrollInfoMakeVisible(Visual, Rect)
See Also

Reference

AddFlow Class


AddFlow.MeasureOverride Method

AddFlowMeasureOverride Method
Called to remeasure a control.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
protected override Size MeasureOverride(
    Size availableSize
)
Protected Overrides Function MeasureOverride (
    availableSize As Size
) As Size
protected:
virtual Size MeasureOverride(
    Size availableSize
) override
abstract MeasureOverride :
        availableSize : Size -> Size
override MeasureOverride :
        availableSize : Size -> Size

Parameters

availableSize
Type: System.WindowsSize
The maximum size that the method can return.

Return Value

Type: Size
The size of the control, up to the maximum specified by availableSize.
See Also

Reference

AddFlow Class


AddFlow.MouseWheelDown Method

AddFlowMouseWheelDown Method
Scroll down by one mouse wheel increment.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void MouseWheelDown()
Public Sub MouseWheelDown
public:
virtual void MouseWheelDown() sealed
abstract MouseWheelDown : unit -> unit
override MouseWheelDown : unit -> unit

Implements

IScrollInfoMouseWheelDown
See Also

Reference

AddFlow Class


AddFlow.MouseWheelLeft Method

AddFlowMouseWheelLeft Method
Scroll left by one mouse wheel increment.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void MouseWheelLeft()
Public Sub MouseWheelLeft
public:
virtual void MouseWheelLeft() sealed
abstract MouseWheelLeft : unit -> unit
override MouseWheelLeft : unit -> unit

Implements

IScrollInfoMouseWheelLeft
See Also

Reference

AddFlow Class


AddFlow.MouseWheelRight Method

AddFlowMouseWheelRight Method
Scroll right by one mouse wheel increment.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void MouseWheelRight()
Public Sub MouseWheelRight
public:
virtual void MouseWheelRight() sealed
abstract MouseWheelRight : unit -> unit
override MouseWheelRight : unit -> unit

Implements

IScrollInfoMouseWheelRight
See Also

Reference

AddFlow Class


AddFlow.MouseWheelUp Method

AddFlowMouseWheelUp Method
Scroll up by one mouse wheel increment.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void MouseWheelUp()
Public Sub MouseWheelUp
public:
virtual void MouseWheelUp() sealed
abstract MouseWheelUp : unit -> unit
override MouseWheelUp : unit -> unit

Implements

IScrollInfoMouseWheelUp
See Also

Reference

AddFlow Class


AddFlow.OnAfterEdit Method

AddFlowOnAfterEdit Method
Raises the AfterEdit event

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnAfterEdit(
    AfterEditEventArgs e
)
Protected Overridable Sub OnAfterEdit (
    e As AfterEditEventArgs
)
protected:
virtual void OnAfterEdit(
    AfterEditEventArgs^ e
)
abstract OnAfterEdit :
        e : AfterEditEventArgs -> unit
override OnAfterEdit :
        e : AfterEditEventArgs -> unit

Parameters

e
Type: Lassalle.WPF.FlowAfterEditEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.WPF.Flow.AddFlow.OnAfterEdit(Lassalle.WPF.Flow.AfterEditEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnBeforeEdit Method

AddFlowOnBeforeEdit Method
Raises the BeforeEdit event

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnBeforeEdit(
    BeforeEditEventArgs e
)
Protected Overridable Sub OnBeforeEdit (
    e As BeforeEditEventArgs
)
protected:
virtual void OnBeforeEdit(
    BeforeEditEventArgs^ e
)
abstract OnBeforeEdit :
        e : BeforeEditEventArgs -> unit
override OnBeforeEdit :
        e : BeforeEditEventArgs -> unit

Parameters

e
Type: Lassalle.WPF.FlowBeforeEditEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.WPF.Flow.AddFlow.OnBeforeEdit(Lassalle.WPF.Flow.BeforeEditEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnCancelEdit Method

AddFlowOnCancelEdit Method
Raises the CancelEdit event

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnCancelEdit(
    CancelEditEventArgs e
)
Protected Overridable Sub OnCancelEdit (
    e As CancelEditEventArgs
)
protected:
virtual void OnCancelEdit(
    CancelEditEventArgs^ e
)
abstract OnCancelEdit :
        e : CancelEditEventArgs -> unit
override OnCancelEdit :
        e : CancelEditEventArgs -> unit

Parameters

e
Type: Lassalle.WPF.FlowCancelEditEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.WPF.Flow.AddFlow.OnCancelEdit(Lassalle.WPF.Flow.CancelEditEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnCaptionCreated Method

AddFlowOnCaptionCreated Method
Raises the CaptionCreated event

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnCaptionCreated(
    CaptionCreatedEventArgs e
)
Protected Overridable Sub OnCaptionCreated (
    e As CaptionCreatedEventArgs
)
protected:
virtual void OnCaptionCreated(
    CaptionCreatedEventArgs^ e
)
abstract OnCaptionCreated :
        e : CaptionCreatedEventArgs -> unit
override OnCaptionCreated :
        e : CaptionCreatedEventArgs -> unit

Parameters

e
Type: Lassalle.WPF.FlowCaptionCreatedEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.WPF.Flow.AddFlow.OnCaptionCreated(Lassalle.WPF.Flow.CaptionCreatedEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnCaptionCreating Method

AddFlowOnCaptionCreating Method
Raises the CaptionCreating event

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnCaptionCreating(
    CaptionCreatingEventArgs e
)
Protected Overridable Sub OnCaptionCreating (
    e As CaptionCreatingEventArgs
)
protected:
virtual void OnCaptionCreating(
    CaptionCreatingEventArgs^ e
)
abstract OnCaptionCreating :
        e : CaptionCreatingEventArgs -> unit
override OnCaptionCreating :
        e : CaptionCreatingEventArgs -> unit

Parameters

e
Type: Lassalle.WPF.FlowCaptionCreatingEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.WPF.Flow.AddFlow.OnCaptionCreating(Lassalle.WPF.Flow.CaptionCreatingEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnCaptionDeleted Method

AddFlowOnCaptionDeleted Method
Raises the CaptionDeleted event

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnCaptionDeleted(
    CaptionDeletedEventArgs e
)
Protected Overridable Sub OnCaptionDeleted (
    e As CaptionDeletedEventArgs
)
protected:
virtual void OnCaptionDeleted(
    CaptionDeletedEventArgs^ e
)
abstract OnCaptionDeleted :
        e : CaptionDeletedEventArgs -> unit
override OnCaptionDeleted :
        e : CaptionDeletedEventArgs -> unit

Parameters

e
Type: Lassalle.WPF.FlowCaptionDeletedEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.WPF.Flow.AddFlow.OnCaptionDeleted(Lassalle.WPF.Flow.CaptionDeletedEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnCaptionDeleting Method

AddFlowOnCaptionDeleting Method
Raises the CaptionDeleting event

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnCaptionDeleting(
    CaptionDeletingEventArgs e
)
Protected Overridable Sub OnCaptionDeleting (
    e As CaptionDeletingEventArgs
)
protected:
virtual void OnCaptionDeleting(
    CaptionDeletingEventArgs^ e
)
abstract OnCaptionDeleting :
        e : CaptionDeletingEventArgs -> unit
override OnCaptionDeleting :
        e : CaptionDeletingEventArgs -> unit

Parameters

e
Type: Lassalle.WPF.FlowCaptionDeletingEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.WPF.Flow.AddFlow.OnCaptionDeleting(Lassalle.WPF.Flow.CaptionDeletingEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnDstChanged Method

AddFlowOnDstChanged Method
Raises the DstChanged event

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnDstChanged(
    DstChangedEventArgs e
)
Protected Overridable Sub OnDstChanged (
    e As DstChangedEventArgs
)
protected:
virtual void OnDstChanged(
    DstChangedEventArgs^ e
)
abstract OnDstChanged :
        e : DstChangedEventArgs -> unit
override OnDstChanged :
        e : DstChangedEventArgs -> unit

Parameters

e
Type: Lassalle.WPF.FlowDstChangedEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.WPF.Flow.AddFlow.OnDstChanged(Lassalle.WPF.Flow.DstChangedEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnDstChanging Method

AddFlowOnDstChanging Method
Raises the DstChanging event. Cancelling the action aborts the destination change.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnDstChanging(
    DstChangingEventArgs e
)
Protected Overridable Sub OnDstChanging (
    e As DstChangingEventArgs
)
protected:
virtual void OnDstChanging(
    DstChangingEventArgs^ e
)
abstract OnDstChanging :
        e : DstChangingEventArgs -> unit
override OnDstChanging :
        e : DstChangingEventArgs -> unit

Parameters

e
Type: Lassalle.WPF.FlowDstChangingEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.WPF.Flow.AddFlow.OnDstChanging(Lassalle.WPF.Flow.DstChangingEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnError Method

AddFlowOnError Method
Raises the Error event

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnError(
    ErrorEventArgs e
)
Protected Overridable Sub OnError (
    e As ErrorEventArgs
)
protected:
virtual void OnError(
    ErrorEventArgs^ e
)
abstract OnError :
        e : ErrorEventArgs -> unit
override OnError :
        e : ErrorEventArgs -> unit

Parameters

e
Type: Lassalle.WPF.FlowErrorEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.WPF.Flow.AddFlow.OnError(Lassalle.WPF.Flow.ErrorEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnExtentChanged Method

AddFlowOnExtentChanged Method
Raises the ExtentChanged event

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnExtentChanged(
    EventArgs e
)
Protected Overridable Sub OnExtentChanged (
    e As EventArgs
)
protected:
virtual void OnExtentChanged(
    EventArgs^ e
)
abstract OnExtentChanged :
        e : EventArgs -> unit
override OnExtentChanged :
        e : EventArgs -> unit

Parameters

e
Type: SystemEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.WPF.Flow.AddFlow.OnExtentChanged(System.EventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnLinkCreated Method

AddFlowOnLinkCreated Method
Raises the LinkCreated event

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnLinkCreated(
    LinkCreatedEventArgs e
)
Protected Overridable Sub OnLinkCreated (
    e As LinkCreatedEventArgs
)
protected:
virtual void OnLinkCreated(
    LinkCreatedEventArgs^ e
)
abstract OnLinkCreated :
        e : LinkCreatedEventArgs -> unit
override OnLinkCreated :
        e : LinkCreatedEventArgs -> unit

Parameters

e
Type: Lassalle.WPF.FlowLinkCreatedEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.WPF.Flow.AddFlow.OnLinkCreated(Lassalle.WPF.Flow.LinkCreatedEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnLinkCreating Method

AddFlowOnLinkCreating Method
Raises the LinkCreating event

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnLinkCreating(
    LinkCreatingEventArgs e
)
Protected Overridable Sub OnLinkCreating (
    e As LinkCreatingEventArgs
)
protected:
virtual void OnLinkCreating(
    LinkCreatingEventArgs^ e
)
abstract OnLinkCreating :
        e : LinkCreatingEventArgs -> unit
override OnLinkCreating :
        e : LinkCreatingEventArgs -> unit

Parameters

e
Type: Lassalle.WPF.FlowLinkCreatingEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.WPF.Flow.AddFlow.OnLinkCreating(Lassalle.WPF.Flow.LinkCreatingEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnLinkDeleted Method

AddFlowOnLinkDeleted Method
Raises the LinkDeleted event

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnLinkDeleted(
    LinkDeletedEventArgs e
)
Protected Overridable Sub OnLinkDeleted (
    e As LinkDeletedEventArgs
)
protected:
virtual void OnLinkDeleted(
    LinkDeletedEventArgs^ e
)
abstract OnLinkDeleted :
        e : LinkDeletedEventArgs -> unit
override OnLinkDeleted :
        e : LinkDeletedEventArgs -> unit

Parameters

e
Type: Lassalle.WPF.FlowLinkDeletedEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.WPF.Flow.AddFlow.OnLinkDeleted(Lassalle.WPF.Flow.LinkDeletedEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnLinkDeleting Method

AddFlowOnLinkDeleting Method
Raises the LinkDeleting event

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnLinkDeleting(
    LinkDeletingEventArgs e
)
Protected Overridable Sub OnLinkDeleting (
    e As LinkDeletingEventArgs
)
protected:
virtual void OnLinkDeleting(
    LinkDeletingEventArgs^ e
)
abstract OnLinkDeleting :
        e : LinkDeletingEventArgs -> unit
override OnLinkDeleting :
        e : LinkDeletingEventArgs -> unit

Parameters

e
Type: Lassalle.WPF.FlowLinkDeletingEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.WPF.Flow.AddFlow.OnLinkDeleting(Lassalle.WPF.Flow.LinkDeletingEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnLostMouseCapture Method

AddFlowOnLostMouseCapture Method

[Missing <summary> documentation for "M:Lassalle.WPF.Flow.AddFlow.OnLostMouseCapture(System.Windows.Input.MouseEventArgs)"]

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
protected override void OnLostMouseCapture(
    MouseEventArgs e
)
Protected Overrides Sub OnLostMouseCapture (
    e As MouseEventArgs
)
protected:
virtual void OnLostMouseCapture(
    MouseEventArgs^ e
) override
abstract OnLostMouseCapture :
        e : MouseEventArgs -> unit
override OnLostMouseCapture :
        e : MouseEventArgs -> unit

Parameters

e
Type: System.Windows.InputMouseEventArgs
The MouseEventArgs that contains the event data.
See Also

Reference

AddFlow Class


AddFlow.OnMouseLeave Method

AddFlowOnMouseLeave Method
Invoked when an unhandled Mouse.MouseEnter attached event is raised on this element. (Inherited from UIElement)

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
protected override void OnMouseLeave(
    MouseEventArgs e
)
Protected Overrides Sub OnMouseLeave (
    e As MouseEventArgs
)
protected:
virtual void OnMouseLeave(
    MouseEventArgs^ e
) override
abstract OnMouseLeave :
        e : MouseEventArgs -> unit
override OnMouseLeave :
        e : MouseEventArgs -> unit

Parameters

e
Type: System.Windows.InputMouseEventArgs
A EventArgs that contains the event data.
See Also

Reference

AddFlow Class


AddFlow.OnMouseLeftButtonDown Method

AddFlowOnMouseLeftButtonDown Method
Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. (Inherited from UIElement)

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
protected override void OnMouseLeftButtonDown(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnMouseLeftButtonDown (
    e As MouseButtonEventArgs
)
protected:
virtual void OnMouseLeftButtonDown(
    MouseButtonEventArgs^ e
) override
abstract OnMouseLeftButtonDown :
        e : MouseButtonEventArgs -> unit
override OnMouseLeftButtonDown :
        e : MouseButtonEventArgs -> unit

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
The MouseButtonEventArgs that contains the event data.
See Also

Reference

AddFlow Class


AddFlow.OnMouseLeftButtonUp Method

AddFlowOnMouseLeftButtonUp Method
Invoked when an unhandled MouseLeftButtonUp routed event is raised on this element. (Inherited from UIElement)

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
protected override void OnMouseLeftButtonUp(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnMouseLeftButtonUp (
    e As MouseButtonEventArgs
)
protected:
virtual void OnMouseLeftButtonUp(
    MouseButtonEventArgs^ e
) override
abstract OnMouseLeftButtonUp :
        e : MouseButtonEventArgs -> unit
override OnMouseLeftButtonUp :
        e : MouseButtonEventArgs -> unit

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
The MouseButtonEventArgs that contains the event data.
See Also

Reference

AddFlow Class


AddFlow.OnMouseMove Method

AddFlowOnMouseMove Method
Invoked when an unhandled Mouse.MouseMove attached event reaches an element in its route that is derived from this class. (Inherited from UIElement)

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
protected override void OnMouseMove(
    MouseEventArgs e
)
Protected Overrides Sub OnMouseMove (
    e As MouseEventArgs
)
protected:
virtual void OnMouseMove(
    MouseEventArgs^ e
) override
abstract OnMouseMove :
        e : MouseEventArgs -> unit
override OnMouseMove :
        e : MouseEventArgs -> unit

Parameters

e
Type: System.Windows.InputMouseEventArgs
The MouseEventArgs that contains the event data.
See Also

Reference

AddFlow Class


AddFlow.OnNodeCreated Method

AddFlowOnNodeCreated Method
Raises the NodeCreated event

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnNodeCreated(
    NodeCreatedEventArgs e
)
Protected Overridable Sub OnNodeCreated (
    e As NodeCreatedEventArgs
)
protected:
virtual void OnNodeCreated(
    NodeCreatedEventArgs^ e
)
abstract OnNodeCreated :
        e : NodeCreatedEventArgs -> unit
override OnNodeCreated :
        e : NodeCreatedEventArgs -> unit

Parameters

e
Type: Lassalle.WPF.FlowNodeCreatedEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.WPF.Flow.AddFlow.OnNodeCreated(Lassalle.WPF.Flow.NodeCreatedEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnNodeCreating Method

AddFlowOnNodeCreating Method
Raises the NodeCreating event

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnNodeCreating(
    NodeCreatingEventArgs e
)
Protected Overridable Sub OnNodeCreating (
    e As NodeCreatingEventArgs
)
protected:
virtual void OnNodeCreating(
    NodeCreatingEventArgs^ e
)
abstract OnNodeCreating :
        e : NodeCreatingEventArgs -> unit
override OnNodeCreating :
        e : NodeCreatingEventArgs -> unit

Parameters

e
Type: Lassalle.WPF.FlowNodeCreatingEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.WPF.Flow.AddFlow.OnNodeCreating(Lassalle.WPF.Flow.NodeCreatingEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnNodeDeleted Method

AddFlowOnNodeDeleted Method
Raises the NodeDeleted event

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnNodeDeleted(
    NodeDeletedEventArgs e
)
Protected Overridable Sub OnNodeDeleted (
    e As NodeDeletedEventArgs
)
protected:
virtual void OnNodeDeleted(
    NodeDeletedEventArgs^ e
)
abstract OnNodeDeleted :
        e : NodeDeletedEventArgs -> unit
override OnNodeDeleted :
        e : NodeDeletedEventArgs -> unit

Parameters

e
Type: Lassalle.WPF.FlowNodeDeletedEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.WPF.Flow.AddFlow.OnNodeDeleted(Lassalle.WPF.Flow.NodeDeletedEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnNodeDeleting Method

AddFlowOnNodeDeleting Method
Raises the NodeDeleting event

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnNodeDeleting(
    NodeDeletingEventArgs e
)
Protected Overridable Sub OnNodeDeleting (
    e As NodeDeletingEventArgs
)
protected:
virtual void OnNodeDeleting(
    NodeDeletingEventArgs^ e
)
abstract OnNodeDeleting :
        e : NodeDeletingEventArgs -> unit
override OnNodeDeleting :
        e : NodeDeletingEventArgs -> unit

Parameters

e
Type: Lassalle.WPF.FlowNodeDeletingEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.WPF.Flow.AddFlow.OnNodeDeleting(Lassalle.WPF.Flow.NodeDeletingEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnOrgChanged Method

AddFlowOnOrgChanged Method
Raises the OrgChanged event

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnOrgChanged(
    OrgChangedEventArgs e
)
Protected Overridable Sub OnOrgChanged (
    e As OrgChangedEventArgs
)
protected:
virtual void OnOrgChanged(
    OrgChangedEventArgs^ e
)
abstract OnOrgChanged :
        e : OrgChangedEventArgs -> unit
override OnOrgChanged :
        e : OrgChangedEventArgs -> unit

Parameters

e
Type: Lassalle.WPF.FlowOrgChangedEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.WPF.Flow.AddFlow.OnOrgChanged(Lassalle.WPF.Flow.OrgChangedEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnOrgChanging Method

AddFlowOnOrgChanging Method
Raises the OrgChanging event. Cancelling the action aborts the origin change.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnOrgChanging(
    OrgChangingEventArgs e
)
Protected Overridable Sub OnOrgChanging (
    e As OrgChangingEventArgs
)
protected:
virtual void OnOrgChanging(
    OrgChangingEventArgs^ e
)
abstract OnOrgChanging :
        e : OrgChangingEventArgs -> unit
override OnOrgChanging :
        e : OrgChangingEventArgs -> unit

Parameters

e
Type: Lassalle.WPF.FlowOrgChangingEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.WPF.Flow.AddFlow.OnOrgChanging(Lassalle.WPF.Flow.OrgChangingEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnRender Method

AddFlowOnRender Method
When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
protected override void OnRender(
    DrawingContext dc
)
Protected Overrides Sub OnRender (
    dc As DrawingContext
)
protected:
virtual void OnRender(
    DrawingContext^ dc
) override
abstract OnRender :
        dc : DrawingContext -> unit
override OnRender :
        dc : DrawingContext -> unit

Parameters

dc
Type: System.Windows.MediaDrawingContext
The drawing instructions for a specific element. This context is provided to the layout system.
See Also

Reference

AddFlow Class


AddFlow.OnSelectedItemsLayouting Method

AddFlowOnSelectedItemsLayouting Method
Raises the SelectedNodesLayouting event. Cancelling the action aborts the resizing or moving action.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnSelectedItemsLayouting(
    SelectedItemsLayoutingEventArgs e
)
Protected Overridable Sub OnSelectedItemsLayouting (
    e As SelectedItemsLayoutingEventArgs
)
protected:
virtual void OnSelectedItemsLayouting(
    SelectedItemsLayoutingEventArgs^ e
)
abstract OnSelectedItemsLayouting :
        e : SelectedItemsLayoutingEventArgs -> unit
override OnSelectedItemsLayouting :
        e : SelectedItemsLayoutingEventArgs -> unit

Parameters

e
Type: Lassalle.WPF.FlowSelectedItemsLayoutingEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.WPF.Flow.AddFlow.OnSelectedItemsLayouting(Lassalle.WPF.Flow.SelectedItemsLayoutingEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnSelectedItemsRotating Method

AddFlowOnSelectedItemsRotating Method
Raises the SelectedItemsRotating event. Cancelling the action aborts the rotating action.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnSelectedItemsRotating(
    SelectedItemsRotatingEventArgs e
)
Protected Overridable Sub OnSelectedItemsRotating (
    e As SelectedItemsRotatingEventArgs
)
protected:
virtual void OnSelectedItemsRotating(
    SelectedItemsRotatingEventArgs^ e
)
abstract OnSelectedItemsRotating :
        e : SelectedItemsRotatingEventArgs -> unit
override OnSelectedItemsRotating :
        e : SelectedItemsRotatingEventArgs -> unit

Parameters

e
Type: Lassalle.WPF.FlowSelectedItemsRotatingEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.WPF.Flow.AddFlow.OnSelectedItemsRotating(Lassalle.WPF.Flow.SelectedItemsRotatingEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnSelectedLinkStretching Method

AddFlowOnSelectedLinkStretching Method
Raises the SelectedLinkStretching event. Cancelling the action aborts the stretching action.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnSelectedLinkStretching(
    SelectedLinkStretchingEventArgs e
)
Protected Overridable Sub OnSelectedLinkStretching (
    e As SelectedLinkStretchingEventArgs
)
protected:
virtual void OnSelectedLinkStretching(
    SelectedLinkStretchingEventArgs^ e
)
abstract OnSelectedLinkStretching :
        e : SelectedLinkStretchingEventArgs -> unit
override OnSelectedLinkStretching :
        e : SelectedLinkStretchingEventArgs -> unit

Parameters

e
Type: Lassalle.WPF.FlowSelectedLinkStretchingEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.WPF.Flow.AddFlow.OnSelectedLinkStretching(Lassalle.WPF.Flow.SelectedLinkStretchingEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.OnSelectionChanged Method

AddFlowOnSelectionChanged Method
Raises the SelectionChanged event

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnSelectionChanged(
    SelectionChangedEventArgs e
)
Protected Overridable Sub OnSelectionChanged (
    e As SelectionChangedEventArgs
)
protected:
virtual void OnSelectionChanged(
    SelectionChangedEventArgs^ e
)
abstract OnSelectionChanged :
        e : SelectionChangedEventArgs -> unit
override OnSelectionChanged :
        e : SelectionChangedEventArgs -> unit

Parameters

e
Type: Lassalle.WPF.FlowSelectionChangedEventArgs

[Missing <param name="e"/> documentation for "M:Lassalle.WPF.Flow.AddFlow.OnSelectionChanged(Lassalle.WPF.Flow.SelectionChangedEventArgs)"]

See Also

Reference

AddFlow Class


AddFlow.PageDown Method

AddFlowPageDown Method
Page down by one view port height amount.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void PageDown()
Public Sub PageDown
public:
virtual void PageDown() sealed
abstract PageDown : unit -> unit
override PageDown : unit -> unit

Implements

IScrollInfoPageDown
See Also

Reference

AddFlow Class


AddFlow.PageLeft Method

AddFlowPageLeft Method
Page left by one view port width amount.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void PageLeft()
Public Sub PageLeft
public:
virtual void PageLeft() sealed
abstract PageLeft : unit -> unit
override PageLeft : unit -> unit

Implements

IScrollInfoPageLeft
See Also

Reference

AddFlow Class


AddFlow.PageRight Method

AddFlowPageRight Method
Page right by one view port width amount.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void PageRight()
Public Sub PageRight
public:
virtual void PageRight() sealed
abstract PageRight : unit -> unit
override PageRight : unit -> unit

Implements

IScrollInfoPageRight
See Also

Reference

AddFlow Class


AddFlow.PageUp Method

AddFlowPageUp Method
Page up by one view port height amount.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void PageUp()
Public Sub PageUp
public:
virtual void PageUp() sealed
abstract PageUp : unit -> unit
override PageUp : unit -> unit

Implements

IScrollInfoPageUp
See Also

Reference

AddFlow Class


AddFlow.RemoveCaption Method

AddFlowRemoveCaption Method
Remove the specified caption from the AddFlow control

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void RemoveCaption(
    Caption caption
)
Public Sub RemoveCaption (
    caption As Caption
)
public:
void RemoveCaption(
    Caption^ caption
)
member RemoveCaption :
        caption : Caption -> unit

Parameters

caption
Type: Lassalle.WPF.FlowCaption
The caption to be removed
See Also

Reference

AddFlow Class


AddFlow.RemoveLink Method

AddFlowRemoveLink Method
Remove a link from the canvas

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void RemoveLink(
    Link link
)
Public Sub RemoveLink (
    link As Link
)
public:
void RemoveLink(
    Link^ link
)
member RemoveLink :
        link : Link -> unit

Parameters

link
Type: Lassalle.WPF.FlowLink
A reference to the link to remove
See Also

Reference

AddFlow Class


AddFlow.RemoveNode Method

AddFlowRemoveNode Method
Remove a node from the canvas

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void RemoveNode(
    Node node
)
Public Sub RemoveNode (
    node As Node
)
public:
void RemoveNode(
    Node^ node
)
member RemoveNode :
        node : Node -> unit

Parameters

node
Type: Lassalle.WPF.FlowNode
A reference to the node to remove
See Also

Reference

AddFlow Class


AddFlow.ResetChangedFlag Method

AddFlowResetChangedFlag Method
Allow setting a flag indicating that the diagram is not still changed. Typically, you should call this method just after having saved the diagram.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void ResetChangedFlag()
Public Sub ResetChangedFlag
public:
void ResetChangedFlag()
member ResetChangedFlag : unit -> unit
See Also

Reference

AddFlow Class


AddFlow.SelectAll Method

AddFlowSelectAll Method
Selects all the items of the diagram

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void SelectAll()
Public Sub SelectAll
public:
void SelectAll()
member SelectAll : unit -> unit
See Also

Reference

AddFlow Class


AddFlow.SendBackward Method

AddFlowSendBackward Method
Send the selected items backward

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void SendBackward()
Public Sub SendBackward
public:
void SendBackward()
member SendBackward : unit -> unit
See Also

Reference

AddFlow Class


AddFlow.SendToBack Method

AddFlowSendToBack Method
Send the selected items at the back of the zorder list

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void SendToBack()
Public Sub SendToBack
public:
void SendToBack()
member SendToBack : unit -> unit
See Also

Reference

AddFlow Class


AddFlow.SetHorizontalOffset Method

AddFlowSetHorizontalOffset Method
Scroll to the given absolute horizontal scroll position.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void SetHorizontalOffset(
    double offset
)
Public Sub SetHorizontalOffset (
    offset As Double
)
public:
virtual void SetHorizontalOffset(
    double offset
) sealed
abstract SetHorizontalOffset :
        offset : float -> unit
override SetHorizontalOffset :
        offset : float -> unit

Parameters

offset
Type: SystemDouble
The horizontal position to scroll to

Implements

IScrollInfoSetHorizontalOffset(Double)
See Also

Reference

AddFlow Class


AddFlow.SetVerticalOffset Method

AddFlowSetVerticalOffset Method
Scroll to the given absolute vertical scroll position.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void SetVerticalOffset(
    double offset
)
Public Sub SetVerticalOffset (
    offset As Double
)
public:
virtual void SetVerticalOffset(
    double offset
) sealed
abstract SetVerticalOffset :
        offset : float -> unit
override SetVerticalOffset :
        offset : float -> unit

Parameters

offset
Type: SystemDouble
The vertical position to scroll to

Implements

IScrollInfoSetVerticalOffset(Double)
See Also

Reference

AddFlow Class


AddFlow.UnselectAll Method

AddFlowUnselectAll Method
Command that unselects all the items of the diagram

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void UnselectAll()
Public Sub UnselectAll
public:
void UnselectAll()
member UnselectAll : unit -> unit
See Also

Reference

AddFlow Class


AddFlow.ZoomRectangle Method

AddFlowZoomRectangle Method
Zoom a rectangular portion of the diagram.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void ZoomRectangle(
    Rect zoomRectangle
)
Public Sub ZoomRectangle (
    zoomRectangle As Rect
)
public:
void ZoomRectangle(
    Rect zoomRectangle
)
member ZoomRectangle :
        zoomRectangle : Rect -> unit

Parameters

zoomRectangle
Type: System.WindowsRect
A rectangular portion of the diagram.
See Also

Reference

AddFlow Class


AddFlow Properties

AddFlow Properties

The AddFlow type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CanChangeDst | Determines whether the user can interactively change the destination of a link.
Public property | CanChangeOrg | Determines whether the user can interactively change the origin of a link.
Public property | CanDragScroll | Determines whether drag scrolling is allowed or not.
Public property | CanDrawCaption | Determines whether interactive creation of captions is allowed or not.
Public property | CanDrawLink | Determines whether interactive creation of links is allowed or not.
Public property | CanDrawNode | Determines whether interactive creation of nodes is allowed or not.
Public property | CanEditContentItem | Determines whether the user can edit the text of ContentItem objects.
Public property | CanFireError | Determines if the error event is fired or not.
Public property | CanHorizontallyScroll | Return whether we are allowed to scroll horizontally.
Public property | CanMoveItems | Determines whether interactive dragging of items is allowed or not.
Public property | CanMultiLink | Determines whether you can create several links between two nodes or not.
Public property | CanMultiSelect | Determines whether multiselection mode of nodes and links is allowed or not.
Public property | CanReflexLink | Determines whether you can create reflexive links. A link is reflexive if its destination and origin nodes are the same.
Public property | CanRotateNode | Determines whether interactive dragging of nodes is allowed or not
Public property | CanSelectOnMouseMove | Indicates whether the selection of items with the mouse is made only when the MouseUp event is fired or at each MouseMove event.
Public property | CanSendSelectionChangedEvent | Determines whether the SelectionChanged event is fired or not.
Public property | CanShowJumps | Determines whether jumps are displayed at the intersection of links. The default value is false.
Public property | CanSizeItems | Determines whether you can resize items interactively or not.
Public property | CanStretchLink | Determines whether you can "stretch" links (i.e add or remove segments) interactively or not.
Public property | CanVerticallyScroll | Return whether we are allowed to scroll vertically.
Public property | CaptionModel | Returns a caption object that contains the default property values for captions. When a caption is created, it receives these property values.
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Inherited from UIElement.)
Public property | Extent | Returns the diagram size.
Public property | ExtentHeight | The height of the canvas to be scrolled.
Public property | ExtentWidth | The width of the canvas to be scrolled.
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | GridColor | Returns/sets the grid color.
Public property | GridDraw | Determines whether the grid is displayed or not.
Public property | GridSize | Returns/sets the horizontal and vertical grid size.
Public property | GridSnap | Determines whether nodes are aligned on the grid.
Public property | GridStyle | Returns/sets the grid style.
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HitItem | Returns the item pointed by the mouse.
Public property | HitPin | Returns the pin pointed by the mouse.
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalOffset | Get the current horizontal scroll position.
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsChanged | Indicates if the AddFlow diagram has changed.
Public property | IsCreatingCaption | Indicates if the user is currently creating a caption
Public property | IsCreatingLink | Indicates if the user is currently creating a link
Public property | IsCreatingNode | Indicates if the user is currently creating a node
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInPlaceEditing | Indicates if the user is currently editing the text of a ContentItem object
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsInteractiveEventsOnly | Determines whether events can occur only with interactive actions.
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Inherited from UIElement.)
Public property | IsMouseOverPin | Indicates if the mouse is over a pin.
Public property | IsMoving | Indicates if the user is currently moving nodes
Public property | IsPanning | Indicates if the user is currently panning the diagram
Public property | IsResizing | Indicates if the user is currently moving nodes
Public property | IsRotating | Indicates if the user is currently rotating items
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelecting | Indicates if the user is currently selecting items with the mouse
Public property | IsStretching | Indicates if the user is currently stretching a link
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Inherited from UIElement.)
Public property | IsUnselectableItemHitable | Determines whether unselectable items are ignored in hit testing
Public property | IsVirtualizing | Determines whether virtualization mode is set or not
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Inherited from UIElement.)
Public property | IsZooming | Indicates if the user is currently zooming the diagram
Public property | Items | Returns the list of items
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
 | LicenseKey |
Public property | LinkModel | Returns a link object that contains the default property values for links. When a link is created, it receives these property values.
Public property | LinkSelectionAreaWidth | Returns/sets a value that determines the width of the area where the user has to click to select a link.
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MouseSelection | Returns/sets the selection rectangle action (select items, zoom,...).
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | NodeModel | Returns a node object that contains the default property values for nodes. When a node is created, it receives these property values.
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Inherited from UIElement.)
Public property | Origin | Returns the diagram top left point.
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | PinFill | Returns/sets the brush used to fill the pins
Public property | PinShape | Returns/sets the shape used to draw the pins
Public property | PinSize | Gets or sets the size fo the pins.
Public property | PinStroke | Returns/sets the brush used to draw the pins
Public property | RemovePointDistance | Returns/sets a value that determines if the user can remove a link point by dragging the handle to a position where it has a very obtuse angle to its surrounding link points.
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Inherited from UIElement.)
Public property | ResizeHandleStyle | Gets or sets the Style used for the node resizing thumbs.
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RotateHandleStyle | Gets or sets the Style used for the node rotating thumb.
Public property | ScrollIncrement | Set the scroll amount for the scroll bar arrows.
Public property | ScrollOwner | Return the ScrollViewer that contains this object.
Public property | SelectedItems | Returns the list of selected items
Public property | SelectionBoxStyle | Gets or sets the style used for the selection box.
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Inherited from UIElement.)
Public property | StretchHandleStyle | Gets or sets the Style used for the link stretching thumbs.
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TaskManager | Returns the object managing the list of tasks and allowing undo/redo.
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the Uid for this element. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalOffset | Return the current vertical scroll position.
Public property | ViewportHeight | Return the height of the current viewport that is visible in the ScrollViewer.
Public property | ViewportWidth | Return the width of the current viewport that is visible in the ScrollViewer.
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. (Inherited from UIElement.)
Public property | Visual | Returns the visual used to draw the diagram.
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement) (Overrides PanelVisualChildrenCount.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Zoom | Returns/sets the zooming factor.
Public property | ZoomingBoxStyle | Gets or sets the style used for the zooming box.
Top
See Also

Reference

AddFlow Class


AddFlow.CanChangeDst Property

AddFlowCanChangeDst Property
Determines whether the user can interactively change the destination of a link.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool CanChangeDst { get; set; }
Public Property CanChangeDst As Boolean
    Get
    Set
public:
property bool CanChangeDst {
    bool get ();
    void set (bool value);
}
member CanChangeDst : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.CanChangeOrg Property

AddFlowCanChangeOrg Property
Determines whether the user can interactively change the origin of a link.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool CanChangeOrg { get; set; }
Public Property CanChangeOrg As Boolean
    Get
    Set
public:
property bool CanChangeOrg {
    bool get ();
    void set (bool value);
}
member CanChangeOrg : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.CanDragScroll Property

AddFlowCanDragScroll Property
Determines whether drag scrolling is allowed or not.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool CanDragScroll { get; set; }
Public Property CanDragScroll As Boolean
    Get
    Set
public:
property bool CanDragScroll {
    bool get ();
    void set (bool value);
}
member CanDragScroll : bool with get, set

Property Value

Type: Boolean
Remarks
Drag scrolling means for instance that when the user moves a node out of the visible part of the control, the control scrolls automatically so that the node stays visible.
See Also

Reference

AddFlow Class


AddFlow.CanDrawCaption Property

AddFlowCanDrawCaption Property
Determines whether interactive creation of captions is allowed or not.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool CanDrawCaption { get; set; }
Public Property CanDrawCaption As Boolean
    Get
    Set
public:
property bool CanDrawCaption {
    bool get ();
    void set (bool value);
}
member CanDrawCaption : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.CanDrawLink Property

AddFlowCanDrawLink Property
Determines whether interactive creation of links is allowed or not.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool CanDrawLink { get; set; }
Public Property CanDrawLink As Boolean
    Get
    Set
public:
property bool CanDrawLink {
    bool get ();
    void set (bool value);
}
member CanDrawLink : bool with get, set

Property Value

Type: Boolean
Remarks
If the value of this property is False, then the handle at the middle of the node is not displayed.
See Also

Reference

AddFlow Class


AddFlow.CanDrawNode Property

AddFlowCanDrawNode Property
Determines whether interactive creation of nodes is allowed or not.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool CanDrawNode { get; set; }
Public Property CanDrawNode As Boolean
    Get
    Set
public:
property bool CanDrawNode {
    bool get ();
    void set (bool value);
}
member CanDrawNode : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.CanEditContentItem Property

AddFlowCanEditContentItem Property
Determines whether the user can edit the text of ContentItem objects.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool CanEditContentItem { get; set; }
Public Property CanEditContentItem As Boolean
    Get
    Set
public:
property bool CanEditContentItem {
    bool get ();
    void set (bool value);
}
member CanEditContentItem : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.CanFireError Property

AddFlowCanFireError Property
Determines if the error event is fired or not.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool CanFireError { get; set; }
Public Property CanFireError As Boolean
    Get
    Set
public:
property bool CanFireError {
    bool get ();
    void set (bool value);
}
member CanFireError : bool with get, set

Property Value

Type: Boolean
Remarks
For instance, suppose that your diagram has two nodes A and B and a link from A to B. Suppose also that the CanMultiLink property is false. If the user draws a new link from A to B, the link will not be created because CanMultiLink is false. If CanFireError is true, an Error event is fired and by default, this causes an error message box to be displayed (this default behavior can be modified). If CanFireError is false, no event is fired. The user just sees that the link is not created.
See Also

Reference

AddFlow Class


AddFlow.CanHorizontallyScroll Property

AddFlowCanHorizontallyScroll Property
Return whether we are allowed to scroll horizontally.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool CanHorizontallyScroll { get; set; }
Public Property CanHorizontallyScroll As Boolean
    Get
    Set
public:
virtual property bool CanHorizontallyScroll {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract CanHorizontallyScroll : bool with get, set
override CanHorizontallyScroll : bool with get, set

Property Value

Type: Boolean

Implements

IScrollInfoCanHorizontallyScroll
See Also

Reference

AddFlow Class


AddFlow.CanMoveItems Property

AddFlowCanMoveItems Property
Determines whether interactive dragging of items is allowed or not.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool CanMoveItems { get; set; }
Public Property CanMoveItems As Boolean
    Get
    Set
public:
property bool CanMoveItems {
    bool get ();
    void set (bool value);
}
member CanMoveItems : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.CanMultiLink Property

AddFlowCanMultiLink Property
Determines whether you can create several links between two nodes or not.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool CanMultiLink { get; set; }
Public Property CanMultiLink As Boolean
    Get
    Set
public:
property bool CanMultiLink {
    bool get ();
    void set (bool value);
}
member CanMultiLink : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.CanMultiSelect Property

AddFlowCanMultiSelect Property
Determines whether multiselection mode of nodes and links is allowed or not.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool CanMultiSelect { get; set; }
Public Property CanMultiSelect As Boolean
    Get
    Set
public:
property bool CanMultiSelect {
    bool get ();
    void set (bool value);
}
member CanMultiSelect : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.CanReflexLink Property

AddFlowCanReflexLink Property
Determines whether you can create reflexive links. A link is reflexive if its destination and origin nodes are the same.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool CanReflexLink { get; set; }
Public Property CanReflexLink As Boolean
    Get
    Set
public:
property bool CanReflexLink {
    bool get ();
    void set (bool value);
}
member CanReflexLink : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.CanRotateNode Property

AddFlowCanRotateNode Property
Determines whether interactive dragging of nodes is allowed or not

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool CanRotateNode { get; set; }
Public Property CanRotateNode As Boolean
    Get
    Set
public:
property bool CanRotateNode {
    bool get ();
    void set (bool value);
}
member CanRotateNode : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.CanSelectOnMouseMove Property

AddFlowCanSelectOnMouseMove Property
Indicates whether the selection of items with the mouse is made only when the MouseUp event is fired or at each MouseMove event.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool CanSelectOnMouseMove { get; set; }
Public Property CanSelectOnMouseMove As Boolean
    Get
    Set
public:
property bool CanSelectOnMouseMove {
    bool get ();
    void set (bool value);
}
member CanSelectOnMouseMove : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.CanSendSelectionChangedEvent Property

AddFlowCanSendSelectionChangedEvent Property
Determines whether the SelectionChanged event is fired or not.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool CanSendSelectionChangedEvent { get; set; }
Public Property CanSendSelectionChangedEvent As Boolean
    Get
    Set
public:
property bool CanSendSelectionChangedEvent {
    bool get ();
    void set (bool value);
}
member CanSendSelectionChangedEvent : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.CanShowJumps Property

AddFlowCanShowJumps Property
Determines whether jumps are displayed at the intersection of links. The default value is false.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool CanShowJumps { get; set; }
Public Property CanShowJumps As Boolean
    Get
    Set
public:
property bool CanShowJumps {
    bool get ();
    void set (bool value);
}
member CanShowJumps : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.CanSizeItems Property

AddFlowCanSizeItems Property
Determines whether you can resize items interactively or not.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool CanSizeItems { get; set; }
Public Property CanSizeItems As Boolean
    Get
    Set
public:
property bool CanSizeItems {
    bool get ();
    void set (bool value);
}
member CanSizeItems : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.CanStretchLink Property

AddFlowCanStretchLink Property
Determines whether you can "stretch" links (i.e add or remove segments) interactively or not.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool CanStretchLink { get; set; }
Public Property CanStretchLink As Boolean
    Get
    Set
public:
property bool CanStretchLink {
    bool get ();
    void set (bool value);
}
member CanStretchLink : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.CanVerticallyScroll Property

AddFlowCanVerticallyScroll Property
Return whether we are allowed to scroll vertically.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool CanVerticallyScroll { get; set; }
Public Property CanVerticallyScroll As Boolean
    Get
    Set
public:
virtual property bool CanVerticallyScroll {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract CanVerticallyScroll : bool with get, set
override CanVerticallyScroll : bool with get, set

Property Value

Type: Boolean

Implements

IScrollInfoCanVerticallyScroll
See Also

Reference

AddFlow Class


AddFlow.CaptionModel Property

AddFlowCaptionModel Property
Returns a caption object that contains the default property values for captions. When a caption is created, it receives these property values.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Caption CaptionModel { get; set; }
Public Property CaptionModel As Caption
    Get
    Set
public:
property Caption^ CaptionModel {
    Caption^ get ();
    void set (Caption^ value);
}
member CaptionModel : Caption with get, set

Property Value

Type: Caption
See Also

Reference

AddFlow Class


AddFlow.Extent Property

AddFlowExtent Property
Returns the diagram size.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Size Extent { get; }
Public ReadOnly Property Extent As Size
    Get
public:
property Size Extent {
    Size get ();
}
member Extent : Size with get

Property Value

Type: Size
See Also

Reference

AddFlow Class


AddFlow.ExtentHeight Property

AddFlowExtentHeight Property
The height of the canvas to be scrolled.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public double ExtentHeight { get; }
Public ReadOnly Property ExtentHeight As Double
    Get
public:
virtual property double ExtentHeight {
    double get () sealed;
}
abstract ExtentHeight : float with get
override ExtentHeight : float with get

Property Value

Type: Double

Implements

IScrollInfoExtentHeight
See Also

Reference

AddFlow Class


AddFlow.ExtentWidth Property

AddFlowExtentWidth Property
The width of the canvas to be scrolled.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public double ExtentWidth { get; }
Public ReadOnly Property ExtentWidth As Double
    Get
public:
virtual property double ExtentWidth {
    double get () sealed;
}
abstract ExtentWidth : float with get
override ExtentWidth : float with get

Property Value

Type: Double

Implements

IScrollInfoExtentWidth
See Also

Reference

AddFlow Class


AddFlow.GridColor Property

AddFlowGridColor Property
Returns/sets the grid color.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Color GridColor { get; set; }
Public Property GridColor As Color
    Get
    Set
public:
property Color GridColor {
    Color get ();
    void set (Color value);
}
member GridColor : Color with get, set

Property Value

Type: Color
See Also

Reference

AddFlow Class


AddFlow.GridDraw Property

AddFlowGridDraw Property
Determines whether the grid is displayed or not.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool GridDraw { get; set; }
Public Property GridDraw As Boolean
    Get
    Set
public:
property bool GridDraw {
    bool get ();
    void set (bool value);
}
member GridDraw : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.GridSize Property

AddFlowGridSize Property
Returns/sets the horizontal and vertical grid size.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Size GridSize { get; set; }
Public Property GridSize As Size
    Get
    Set
public:
property Size GridSize {
    Size get ();
    void set (Size value);
}
member GridSize : Size with get, set

Property Value

Type: Size
See Also

Reference

AddFlow Class


AddFlow.GridSnap Property

AddFlowGridSnap Property
Determines whether nodes are aligned on the grid.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool GridSnap { get; set; }
Public Property GridSnap As Boolean
    Get
    Set
public:
property bool GridSnap {
    bool get ();
    void set (bool value);
}
member GridSnap : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.GridStyle Property

AddFlowGridStyle Property
Returns/sets the grid style.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public GridStyle GridStyle { get; set; }
Public Property GridStyle As GridStyle
    Get
    Set
public:
property GridStyle GridStyle {
    GridStyle get ();
    void set (GridStyle value);
}
member GridStyle : GridStyle with get, set

Property Value

Type: GridStyle
See Also

Reference

AddFlow Class


AddFlow.HitItem Property

AddFlowHitItem Property
Returns the item pointed by the mouse.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Item HitItem { get; }
Public ReadOnly Property HitItem As Item
    Get
public:
property Item^ HitItem {
    Item^ get ();
}
member HitItem : Item with get

Property Value

Type: Item
See Also

Reference

AddFlow Class


AddFlow.HitPin Property

AddFlowHitPin Property
Returns the pin pointed by the mouse.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Pin HitPin { get; }
Public ReadOnly Property HitPin As Pin
    Get
public:
property Pin^ HitPin {
    Pin^ get ();
}
member HitPin : Pin with get

Property Value

Type: Pin
See Also

Reference

AddFlow Class


AddFlow.HorizontalOffset Property

AddFlowHorizontalOffset Property
Get the current horizontal scroll position.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public double HorizontalOffset { get; }
Public ReadOnly Property HorizontalOffset As Double
    Get
public:
virtual property double HorizontalOffset {
    double get () sealed;
}
abstract HorizontalOffset : float with get
override HorizontalOffset : float with get

Property Value

Type: Double

Implements

IScrollInfoHorizontalOffset
See Also

Reference

AddFlow Class


AddFlow.IsChanged Property

AddFlowIsChanged Property
Indicates if the AddFlow diagram has changed.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool IsChanged { get; }
Public ReadOnly Property IsChanged As Boolean
    Get
public:
property bool IsChanged {
    bool get ();
}
member IsChanged : bool with get

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.IsCreatingCaption Property

AddFlowIsCreatingCaption Property
Indicates if the user is currently creating a caption

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool IsCreatingCaption { get; set; }
Public Property IsCreatingCaption As Boolean
    Get
    Set
public:
property bool IsCreatingCaption {
    bool get ();
    void set (bool value);
}
member IsCreatingCaption : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.IsCreatingLink Property

AddFlowIsCreatingLink Property
Indicates if the user is currently creating a link

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool IsCreatingLink { get; set; }
Public Property IsCreatingLink As Boolean
    Get
    Set
public:
property bool IsCreatingLink {
    bool get ();
    void set (bool value);
}
member IsCreatingLink : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.IsCreatingNode Property

AddFlowIsCreatingNode Property
Indicates if the user is currently creating a node

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool IsCreatingNode { get; set; }
Public Property IsCreatingNode As Boolean
    Get
    Set
public:
property bool IsCreatingNode {
    bool get ();
    void set (bool value);
}
member IsCreatingNode : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.IsInPlaceEditing Property

AddFlowIsInPlaceEditing Property
Indicates if the user is currently editing the text of a ContentItem object

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool IsInPlaceEditing { get; set; }
Public Property IsInPlaceEditing As Boolean
    Get
    Set
public:
property bool IsInPlaceEditing {
    bool get ();
    void set (bool value);
}
member IsInPlaceEditing : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.IsInteractiveEventsOnly Property

AddFlowIsInteractiveEventsOnly Property
Determines whether events can occur only with interactive actions.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool IsInteractiveEventsOnly { get; set; }
Public Property IsInteractiveEventsOnly As Boolean
    Get
    Set
public:
property bool IsInteractiveEventsOnly {
    bool get ();
    void set (bool value);
}
member IsInteractiveEventsOnly : bool with get, set

Property Value

Type: Boolean
Remarks
If this property is true, events occured only with interactive events (Mouse events, keybord events, node or link creation with the mouse, etc...). If this property is false, then events can occur also with programmatic actions: for instance, if a node is added programmaticaly, the NodeCreating and the NodeCreated events will be fired.
See Also

Reference

AddFlow Class


AddFlow.IsMouseOverPin Property

AddFlowIsMouseOverPin Property
Indicates if the mouse is over a pin.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool IsMouseOverPin { get; set; }
Public Property IsMouseOverPin As Boolean
    Get
    Set
public:
property bool IsMouseOverPin {
    bool get ();
    void set (bool value);
}
member IsMouseOverPin : bool with get, set

Property Value

Type: Boolean
Remarks
You may determines this pin with the HitPin property.
See Also

Reference

AddFlow Class


AddFlow.IsMoving Property

AddFlowIsMoving Property
Indicates if the user is currently moving nodes

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool IsMoving { get; set; }
Public Property IsMoving As Boolean
    Get
    Set
public:
property bool IsMoving {
    bool get ();
    void set (bool value);
}
member IsMoving : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.IsPanning Property

AddFlowIsPanning Property
Indicates if the user is currently panning the diagram

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool IsPanning { get; set; }
Public Property IsPanning As Boolean
    Get
    Set
public:
property bool IsPanning {
    bool get ();
    void set (bool value);
}
member IsPanning : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.IsResizing Property

AddFlowIsResizing Property
Indicates if the user is currently moving nodes

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool IsResizing { get; set; }
Public Property IsResizing As Boolean
    Get
    Set
public:
property bool IsResizing {
    bool get ();
    void set (bool value);
}
member IsResizing : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.IsRotating Property

AddFlowIsRotating Property
Indicates if the user is currently rotating items

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool IsRotating { get; set; }
Public Property IsRotating As Boolean
    Get
    Set
public:
property bool IsRotating {
    bool get ();
    void set (bool value);
}
member IsRotating : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.IsSelecting Property

AddFlowIsSelecting Property
Indicates if the user is currently selecting items with the mouse

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool IsSelecting { get; set; }
Public Property IsSelecting As Boolean
    Get
    Set
public:
property bool IsSelecting {
    bool get ();
    void set (bool value);
}
member IsSelecting : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.IsStretching Property

AddFlowIsStretching Property
Indicates if the user is currently stretching a link

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool IsStretching { get; set; }
Public Property IsStretching As Boolean
    Get
    Set
public:
property bool IsStretching {
    bool get ();
    void set (bool value);
}
member IsStretching : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.IsUnselectableItemHitable Property

AddFlowIsUnselectableItemHitable Property
Determines whether unselectable items are ignored in hit testing

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool IsUnselectableItemHitable { get; set; }
Public Property IsUnselectableItemHitable As Boolean
    Get
    Set
public:
property bool IsUnselectableItemHitable {
    bool get ();
    void set (bool value);
}
member IsUnselectableItemHitable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.IsVirtualizing Property

AddFlowIsVirtualizing Property
Determines whether virtualization mode is set or not

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool IsVirtualizing { get; set; }
Public Property IsVirtualizing As Boolean
    Get
    Set
public:
property bool IsVirtualizing {
    bool get ();
    void set (bool value);
}
member IsVirtualizing : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.IsZooming Property

AddFlowIsZooming Property
Indicates if the user is currently zooming the diagram

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool IsZooming { get; set; }
Public Property IsZooming As Boolean
    Get
    Set
public:
property bool IsZooming {
    bool get ();
    void set (bool value);
}
member IsZooming : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AddFlow Class


AddFlow.Items Property

AddFlowItems Property
Returns the list of items

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public List<Item> Items { get; }
Public ReadOnly Property Items As List(Of Item)
    Get
public:
property List<Item^>^ Items {
    List<Item^>^ get ();
}
member Items : List<Item> with get

Property Value

Type: List Item
See Also

Reference

AddFlow Class


AddFlow.LicenseKey Property

AddFlowLicenseKey Property

[Missing <summary> documentation for "P:Lassalle.WPF.Flow.AddFlow.LicenseKey"]

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public static string LicenseKey { set; }
Public Shared WriteOnly Property LicenseKey As String
    Set
public:
static property String^ LicenseKey {
    void set (String^ value);
}
static member LicenseKey : string with set

Property Value

Type: String
See Also

Reference

AddFlow Class


AddFlow.LinkModel Property

AddFlowLinkModel Property
Returns a link object that contains the default property values for links. When a link is created, it receives these property values.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Link LinkModel { get; set; }
Public Property LinkModel As Link
    Get
    Set
public:
property Link^ LinkModel {
    Link^ get ();
    void set (Link^ value);
}
member LinkModel : Link with get, set

Property Value

Type: Link
See Also

Reference

AddFlow Class


AddFlow.LinkSelectionAreaWidth Property

AddFlowLinkSelectionAreaWidth Property
Returns/sets a value that determines the width of the area where the user has to click to select a link.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public double LinkSelectionAreaWidth { get; set; }
Public Property LinkSelectionAreaWidth As Double
    Get
    Set
public:
property double LinkSelectionAreaWidth {
    double get ();
    void set (double value);
}
member LinkSelectionAreaWidth : float with get, set

Property Value

Type: Double
See Also

Reference

AddFlow Class


AddFlow.MouseSelection Property

AddFlowMouseSelection Property
Returns/sets the selection rectangle action (select items, zoom,...).

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public MouseSelection MouseSelection { get; set; }
Public Property MouseSelection As MouseSelection
    Get
    Set
public:
property MouseSelection MouseSelection {
    MouseSelection get ();
    void set (MouseSelection value);
}
member MouseSelection : MouseSelection with get, set

Property Value

Type: MouseSelection
See Also

Reference

AddFlow Class


AddFlow.NodeModel Property

AddFlowNodeModel Property
Returns a node object that contains the default property values for nodes. When a node is created, it receives these property values.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Node NodeModel { get; set; }
Public Property NodeModel As Node
    Get
    Set
public:
property Node^ NodeModel {
    Node^ get ();
    void set (Node^ value);
}
member NodeModel : Node with get, set

Property Value

Type: Node
See Also

Reference

AddFlow Class


AddFlow.Origin Property

AddFlowOrigin Property
Returns the diagram top left point.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Point Origin { get; }
Public ReadOnly Property Origin As Point
    Get
public:
property Point Origin {
    Point get ();
}
member Origin : Point with get

Property Value

Type: Point
See Also

Reference

AddFlow Class


AddFlow.PinFill Property

AddFlowPinFill Property
Returns/sets the brush used to fill the pins

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Brush PinFill { get; set; }
Public Property PinFill As Brush
    Get
    Set
public:
property Brush^ PinFill {
    Brush^ get ();
    void set (Brush^ value);
}
member PinFill : Brush with get, set

Property Value

Type: Brush
See Also

Reference

AddFlow Class


AddFlow.PinShape Property

AddFlowPinShape Property
Returns/sets the shape used to draw the pins

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public PinShape PinShape { get; set; }
Public Property PinShape As PinShape
    Get
    Set
public:
property PinShape PinShape {
    PinShape get ();
    void set (PinShape value);
}
member PinShape : PinShape with get, set

Property Value

Type: PinShape
See Also

Reference

AddFlow Class


AddFlow.PinSize Property

AddFlowPinSize Property
Gets or sets the size fo the pins.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public double PinSize { get; set; }
Public Property PinSize As Double
    Get
    Set
public:
property double PinSize {
    double get ();
    void set (double value);
}
member PinSize : float with get, set

Property Value

Type: Double
See Also

Reference

AddFlow Class


AddFlow.PinStroke Property

AddFlowPinStroke Property
Returns/sets the brush used to draw the pins

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Brush PinStroke { get; set; }
Public Property PinStroke As Brush
    Get
    Set
public:
property Brush^ PinStroke {
    Brush^ get ();
    void set (Brush^ value);
}
member PinStroke : Brush with get, set

Property Value

Type: Brush
See Also

Reference

AddFlow Class


AddFlow.RemovePointDistance Property

AddFlowRemovePointDistance Property
Returns/sets a value that determines if the user can remove a link point by dragging the handle to a position where it has a very obtuse angle to its surrounding link points.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public double RemovePointDistance { get; set; }
Public Property RemovePointDistance As Double
    Get
    Set
public:
property double RemovePointDistance {
    double get ();
    void set (double value);
}
member RemovePointDistance : float with get, set

Property Value

Type: Double
See Also

Reference

AddFlow Class


AddFlow.ResizeHandleStyle Property

AddFlowResizeHandleStyle Property
Gets or sets the Style used for the node resizing thumbs.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Style ResizeHandleStyle { get; set; }
Public Property ResizeHandleStyle As Style
    Get
    Set
public:
property Style^ ResizeHandleStyle {
    Style^ get ();
    void set (Style^ value);
}
member ResizeHandleStyle : Style with get, set

Property Value

Type: Style
See Also

Reference

AddFlow Class


AddFlow.RotateHandleStyle Property

AddFlowRotateHandleStyle Property
Gets or sets the Style used for the node rotating thumb.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Style RotateHandleStyle { get; set; }
Public Property RotateHandleStyle As Style
    Get
    Set
public:
property Style^ RotateHandleStyle {
    Style^ get ();
    void set (Style^ value);
}
member RotateHandleStyle : Style with get, set

Property Value

Type: Style
See Also

Reference

AddFlow Class


AddFlow.ScrollIncrement Property

AddFlowScrollIncrement Property
Set the scroll amount for the scroll bar arrows.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Size ScrollIncrement { get; set; }
Public Property ScrollIncrement As Size
    Get
    Set
public:
property Size ScrollIncrement {
    Size get ();
    void set (Size value);
}
member ScrollIncrement : Size with get, set

Property Value

Type: Size
See Also

Reference

AddFlow Class


AddFlow.ScrollOwner Property

AddFlowScrollOwner Property
Return the ScrollViewer that contains this object.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public ScrollViewer ScrollOwner { get; set; }
Public Property ScrollOwner As ScrollViewer
    Get
    Set
public:
virtual property ScrollViewer^ ScrollOwner {
    ScrollViewer^ get () sealed;
    void set (ScrollViewer^ value) sealed;
}
abstract ScrollOwner : ScrollViewer with get, set
override ScrollOwner : ScrollViewer with get, set

Property Value

Type: ScrollViewer

Implements

IScrollInfoScrollOwner
See Also

Reference

AddFlow Class


AddFlow.SelectedItems Property

AddFlowSelectedItems Property
Returns the list of selected items

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public List<Item> SelectedItems { get; }
Public ReadOnly Property SelectedItems As List(Of Item)
    Get
public:
property List<Item^>^ SelectedItems {
    List<Item^>^ get ();
}
member SelectedItems : List<Item> with get

Property Value

Type: List Item
See Also

Reference

AddFlow Class


AddFlow.SelectionBoxStyle Property

AddFlowSelectionBoxStyle Property
Gets or sets the style used for the selection box.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Style SelectionBoxStyle { get; set; }
Public Property SelectionBoxStyle As Style
    Get
    Set
public:
property Style^ SelectionBoxStyle {
    Style^ get ();
    void set (Style^ value);
}
member SelectionBoxStyle : Style with get, set

Property Value

Type: Style
See Also

Reference

AddFlow Class


AddFlow.StretchHandleStyle Property

AddFlowStretchHandleStyle Property
Gets or sets the Style used for the link stretching thumbs.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Style StretchHandleStyle { get; set; }
Public Property StretchHandleStyle As Style
    Get
    Set
public:
property Style^ StretchHandleStyle {
    Style^ get ();
    void set (Style^ value);
}
member StretchHandleStyle : Style with get, set

Property Value

Type: Style
See Also

Reference

AddFlow Class


AddFlow.TaskManager Property

AddFlowTaskManager Property
Returns the object managing the list of tasks and allowing undo/redo.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public TaskManager TaskManager { get; }
Public ReadOnly Property TaskManager As TaskManager
    Get
public:
property TaskManager^ TaskManager {
    TaskManager^ get ();
}
member TaskManager : TaskManager with get

Property Value

Type: TaskManager
See Also

Reference

AddFlow Class


AddFlow.VerticalOffset Property

AddFlowVerticalOffset Property
Return the current vertical scroll position.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public double VerticalOffset { get; }
Public ReadOnly Property VerticalOffset As Double
    Get
public:
virtual property double VerticalOffset {
    double get () sealed;
}
abstract VerticalOffset : float with get
override VerticalOffset : float with get

Property Value

Type: Double

Implements

IScrollInfoVerticalOffset
See Also

Reference

AddFlow Class


AddFlow.ViewportHeight Property

AddFlowViewportHeight Property
Return the height of the current viewport that is visible in the ScrollViewer.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public double ViewportHeight { get; }
Public ReadOnly Property ViewportHeight As Double
    Get
public:
virtual property double ViewportHeight {
    double get () sealed;
}
abstract ViewportHeight : float with get
override ViewportHeight : float with get

Property Value

Type: Double

Implements

IScrollInfoViewportHeight
See Also

Reference

AddFlow Class


AddFlow.ViewportWidth Property

AddFlowViewportWidth Property
Return the width of the current viewport that is visible in the ScrollViewer.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public double ViewportWidth { get; }
Public ReadOnly Property ViewportWidth As Double
    Get
public:
virtual property double ViewportWidth {
    double get () sealed;
}
abstract ViewportWidth : float with get
override ViewportWidth : float with get

Property Value

Type: Double

Implements

IScrollInfoViewportWidth
See Also

Reference

AddFlow Class


AddFlow.Visual Property

AddFlowVisual Property
Returns the visual used to draw the diagram.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public DrawingVisual Visual { get; }
Public ReadOnly Property Visual As DrawingVisual
    Get
public:
property DrawingVisual^ Visual {
    DrawingVisual^ get ();
}
member Visual : DrawingVisual with get

Property Value

Type: DrawingVisual
See Also

Reference

AddFlow Class


AddFlow.VisualChildrenCount Property

AddFlowVisualChildrenCount Property
Gets the number of visual child elements within this element. (Inherited from FrameworkElement)

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
protected override int VisualChildrenCount { get; }
Protected Overrides ReadOnly Property VisualChildrenCount As Integer
    Get
protected:
virtual property int VisualChildrenCount {
    int get () override;
}
abstract VisualChildrenCount : int with get
override VisualChildrenCount : int with get

Property Value

Type: Int32
See Also

Reference

AddFlow Class


AddFlow.Zoom Property

AddFlowZoom Property
Returns/sets the zooming factor.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public double Zoom { get; set; }
Public Property Zoom As Double
    Get
    Set
public:
property double Zoom {
    double get ();
    void set (double value);
}
member Zoom : float with get, set

Property Value

Type: Double
See Also

Reference

AddFlow Class


AddFlow.ZoomingBoxStyle Property

AddFlowZoomingBoxStyle Property
Gets or sets the style used for the zooming box.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Style ZoomingBoxStyle { get; set; }
Public Property ZoomingBoxStyle As Style
    Get
    Set
public:
property Style^ ZoomingBoxStyle {
    Style^ get ();
    void set (Style^ value);
}
member ZoomingBoxStyle : Style with get, set

Property Value

Type: Style
See Also

Reference

AddFlow Class


AddFlow Events

AddFlow Events

The AddFlow type exposes the following members.

Events
 | Name | Description
Public event | AfterEdit | Occurs after a user edits the text of the selected node.
Public event | BeforeEdit | Occurs when a user attempts to edit the text of the selected node. Cancelling the action aborts the inline edit.
Public event | CancelEdit | Occurs after a user cancels the text edition of the selected node.
Public event | CaptionCreated | Occurs after a user creates a caption.
Public event | CaptionCreating | Occurs when a user attempts to create a caption. Cancelling the action aborts the caption creation.
Public event | CaptionDeleted | Occurs after a user removes a caption.
Public event | CaptionDeleting | Occurs when a user attempts to create a caption. Cancelling the action aborts the caption creation.
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DstChanged | Occurs after a user has changed the destination node of a link.
Public event | DstChanging | Occurs when a user attempts to change the destination node of a link.
Public event | Error | This event is fired when the user tries to make some actions that are not allowed: - creating a reflexive link if the CanReflexLink property is false - creating a second link between 2 nodes if the CanMultiLink property is false The CanFireError property must be set.
Public event | ExtentChanged | This event is fired each time the size of the diagram is changed.
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | LinkCreated | Occurs after a user creates a link.
Public event | LinkCreating | Occurs when a user attempts to create a link. Cancelling the action aborts the link creation.
Public event | LinkDeleted | Occurs after a user removes a link.
Public event | LinkDeleting | Occurs when a user attempts to create a link. Cancelling the action aborts the link creation.
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | NodeCreated | Occurs after a user creates a node.
Public event | NodeCreating | Occurs when a user attempts to create a node. Cancelling the action aborts the node creation.
Public event | NodeDeleted | Occurs after a user removes a node.
Public event | NodeDeleting | Occurs when a user attempts to create a node. Cancelling the action aborts the node creation.
Public event | OrgChanged | Occurs after a user has changed the origin node of a link.
Public event | OrgChanging | Occurs when a user attempts to change the origin node of a link.
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SelectedItemsLayouting | Occurs when a user is currently moving or resizing a node
Public event | SelectedItemsRotating | Occurs when a user is currently rotating an item
Public event | SelectedLinkStretching | Occurs when a user is currently stretching a link.
Public event | SelectionChanged | Occurs when the selection status of an item is changed
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

AddFlow Class


AddFlow.AfterEdit Event

AddFlowAfterEdit Event
Occurs after a user edits the text of the selected node.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowAfterEditEventHandler AfterEdit
Public Event AfterEdit As AddFlowAfterEditEventHandler
public:
 event AddFlowAfterEditEventHandler^ AfterEdit {
    void add (AddFlowAfterEditEventHandler^ value);
    void remove (AddFlowAfterEditEventHandler^ value);
}
member AfterEdit : IEvent<AddFlowAfterEditEventHandler,
    AfterEditEventArgs>

Value

Type: Lassalle.WPF.FlowAddFlowAfterEditEventHandler
See Also

Reference

AddFlow Class


AddFlow.BeforeEdit Event

AddFlowBeforeEdit Event
Occurs when a user attempts to edit the text of the selected node. Cancelling the action aborts the inline edit.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowBeforeEditEventHandler BeforeEdit
Public Event BeforeEdit As AddFlowBeforeEditEventHandler
public:
 event AddFlowBeforeEditEventHandler^ BeforeEdit {
    void add (AddFlowBeforeEditEventHandler^ value);
    void remove (AddFlowBeforeEditEventHandler^ value);
}
member BeforeEdit : IEvent<AddFlowBeforeEditEventHandler,
    BeforeEditEventArgs>

Value

Type: Lassalle.WPF.FlowAddFlowBeforeEditEventHandler
See Also

Reference

AddFlow Class


AddFlow.CancelEdit Event

AddFlowCancelEdit Event
Occurs after a user cancels the text edition of the selected node.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowCancelEditEventHandler CancelEdit
Public Event CancelEdit As AddFlowCancelEditEventHandler
public:
 event AddFlowCancelEditEventHandler^ CancelEdit {
    void add (AddFlowCancelEditEventHandler^ value);
    void remove (AddFlowCancelEditEventHandler^ value);
}
member CancelEdit : IEvent<AddFlowCancelEditEventHandler,
    CancelEditEventArgs>

Value

Type: Lassalle.WPF.FlowAddFlowCancelEditEventHandler
See Also

Reference

AddFlow Class


AddFlow.CaptionCreated Event

AddFlowCaptionCreated Event
Occurs after a user creates a caption.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowCaptionCreatedEventHandler CaptionCreated
Public Event CaptionCreated As AddFlowCaptionCreatedEventHandler
public:
 event AddFlowCaptionCreatedEventHandler^ CaptionCreated {
    void add (AddFlowCaptionCreatedEventHandler^ value);
    void remove (AddFlowCaptionCreatedEventHandler^ value);
}
member CaptionCreated : IEvent<AddFlowCaptionCreatedEventHandler,
    CaptionCreatedEventArgs>

Value

Type: Lassalle.WPF.FlowAddFlowCaptionCreatedEventHandler
See Also

Reference

AddFlow Class


AddFlow.CaptionCreating Event

AddFlowCaptionCreating Event
Occurs when a user attempts to create a caption. Cancelling the action aborts the caption creation.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowCaptionCreatingEventHandler CaptionCreating
Public Event CaptionCreating As AddFlowCaptionCreatingEventHandler
public:
 event AddFlowCaptionCreatingEventHandler^ CaptionCreating {
    void add (AddFlowCaptionCreatingEventHandler^ value);
    void remove (AddFlowCaptionCreatingEventHandler^ value);
}
member CaptionCreating : IEvent<AddFlowCaptionCreatingEventHandler,
    CaptionCreatingEventArgs>

Value

Type: Lassalle.WPF.FlowAddFlowCaptionCreatingEventHandler
See Also

Reference

AddFlow Class


AddFlow.CaptionDeleted Event

AddFlowCaptionDeleted Event
Occurs after a user removes a caption.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowCaptionDeletedEventHandler CaptionDeleted
Public Event CaptionDeleted As AddFlowCaptionDeletedEventHandler
public:
 event AddFlowCaptionDeletedEventHandler^ CaptionDeleted {
    void add (AddFlowCaptionDeletedEventHandler^ value);
    void remove (AddFlowCaptionDeletedEventHandler^ value);
}
member CaptionDeleted : IEvent<AddFlowCaptionDeletedEventHandler,
    CaptionDeletedEventArgs>

Value

Type: Lassalle.WPF.FlowAddFlowCaptionDeletedEventHandler
See Also

Reference

AddFlow Class


AddFlow.CaptionDeleting Event

AddFlowCaptionDeleting Event
Occurs when a user attempts to create a caption. Cancelling the action aborts the caption creation.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowCaptionDeletingEventHandler CaptionDeleting
Public Event CaptionDeleting As AddFlowCaptionDeletingEventHandler
public:
 event AddFlowCaptionDeletingEventHandler^ CaptionDeleting {
    void add (AddFlowCaptionDeletingEventHandler^ value);
    void remove (AddFlowCaptionDeletingEventHandler^ value);
}
member CaptionDeleting : IEvent<AddFlowCaptionDeletingEventHandler,
    CaptionDeletingEventArgs>

Value

Type: Lassalle.WPF.FlowAddFlowCaptionDeletingEventHandler
See Also

Reference

AddFlow Class


AddFlow.DstChanged Event

AddFlowDstChanged Event
Occurs after a user has changed the destination node of a link.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowDstChangedEventHandler DstChanged
Public Event DstChanged As AddFlowDstChangedEventHandler
public:
 event AddFlowDstChangedEventHandler^ DstChanged {
    void add (AddFlowDstChangedEventHandler^ value);
    void remove (AddFlowDstChangedEventHandler^ value);
}
member DstChanged : IEvent<AddFlowDstChangedEventHandler,
    EventArgs>

Value

Type: Lassalle.WPF.FlowAddFlowDstChangedEventHandler
See Also

Reference

AddFlow Class


AddFlow.DstChanging Event

AddFlowDstChanging Event
Occurs when a user attempts to change the destination node of a link.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowDstChangingEventHandler DstChanging
Public Event DstChanging As AddFlowDstChangingEventHandler
public:
 event AddFlowDstChangingEventHandler^ DstChanging {
    void add (AddFlowDstChangingEventHandler^ value);
    void remove (AddFlowDstChangingEventHandler^ value);
}
member DstChanging : IEvent<AddFlowDstChangingEventHandler,
    EventArgs>

Value

Type: Lassalle.WPF.FlowAddFlowDstChangingEventHandler
See Also

Reference

AddFlow Class


AddFlow.Error Event

AddFlowError Event
This event is fired when the user tries to make some actions that are not allowed: - creating a reflexive link if the CanReflexLink property is false - creating a second link between 2 nodes if the CanMultiLink property is false The CanFireError property must be set.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowErrorEventHandler Error
Public Event Error As AddFlowErrorEventHandler
public:
 event AddFlowErrorEventHandler^ Error {
    void add (AddFlowErrorEventHandler^ value);
    void remove (AddFlowErrorEventHandler^ value);
}
member Error : IEvent<AddFlowErrorEventHandler,
    ErrorEventArgs>

Value

Type: Lassalle.WPF.FlowAddFlowErrorEventHandler
See Also

Reference

AddFlow Class


AddFlow.ExtentChanged Event

AddFlowExtentChanged Event
This event is fired each time the size of the diagram is changed.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowExtentChangedEventHandler ExtentChanged
Public Event ExtentChanged As AddFlowExtentChangedEventHandler
public:
 event AddFlowExtentChangedEventHandler^ ExtentChanged {
    void add (AddFlowExtentChangedEventHandler^ value);
    void remove (AddFlowExtentChangedEventHandler^ value);
}
member ExtentChanged : IEvent<AddFlowExtentChangedEventHandler,
    EventArgs>

Value

Type: Lassalle.WPF.FlowAddFlowExtentChangedEventHandler
Remarks
This event is not fired if the redrawing is disabled (see the BeginUpdate and EndUpdate methods).
See Also

Reference

AddFlow Class


AddFlow.LinkCreated Event

AddFlowLinkCreated Event
Occurs after a user creates a link.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowLinkCreatedEventHandler LinkCreated
Public Event LinkCreated As AddFlowLinkCreatedEventHandler
public:
 event AddFlowLinkCreatedEventHandler^ LinkCreated {
    void add (AddFlowLinkCreatedEventHandler^ value);
    void remove (AddFlowLinkCreatedEventHandler^ value);
}
member LinkCreated : IEvent<AddFlowLinkCreatedEventHandler,
    LinkCreatedEventArgs>

Value

Type: Lassalle.WPF.FlowAddFlowLinkCreatedEventHandler
See Also

Reference

AddFlow Class


AddFlow.LinkCreating Event

AddFlowLinkCreating Event
Occurs when a user attempts to create a link. Cancelling the action aborts the link creation.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowLinkCreatingEventHandler LinkCreating
Public Event LinkCreating As AddFlowLinkCreatingEventHandler
public:
 event AddFlowLinkCreatingEventHandler^ LinkCreating {
    void add (AddFlowLinkCreatingEventHandler^ value);
    void remove (AddFlowLinkCreatingEventHandler^ value);
}
member LinkCreating : IEvent<AddFlowLinkCreatingEventHandler,
    LinkCreatingEventArgs>

Value

Type: Lassalle.WPF.FlowAddFlowLinkCreatingEventHandler
See Also

Reference

AddFlow Class


AddFlow.LinkDeleted Event

AddFlowLinkDeleted Event
Occurs after a user removes a link.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowLinkDeletedEventHandler LinkDeleted
Public Event LinkDeleted As AddFlowLinkDeletedEventHandler
public:
 event AddFlowLinkDeletedEventHandler^ LinkDeleted {
    void add (AddFlowLinkDeletedEventHandler^ value);
    void remove (AddFlowLinkDeletedEventHandler^ value);
}
member LinkDeleted : IEvent<AddFlowLinkDeletedEventHandler,
    LinkDeletedEventArgs>

Value

Type: Lassalle.WPF.FlowAddFlowLinkDeletedEventHandler
See Also

Reference

AddFlow Class


AddFlow.LinkDeleting Event

AddFlowLinkDeleting Event
Occurs when a user attempts to create a link. Cancelling the action aborts the link creation.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowLinkDeletingEventHandler LinkDeleting
Public Event LinkDeleting As AddFlowLinkDeletingEventHandler
public:
 event AddFlowLinkDeletingEventHandler^ LinkDeleting {
    void add (AddFlowLinkDeletingEventHandler^ value);
    void remove (AddFlowLinkDeletingEventHandler^ value);
}
member LinkDeleting : IEvent<AddFlowLinkDeletingEventHandler,
    LinkDeletingEventArgs>

Value

Type: Lassalle.WPF.FlowAddFlowLinkDeletingEventHandler
See Also

Reference

AddFlow Class


AddFlow.NodeCreated Event

AddFlowNodeCreated Event
Occurs after a user creates a node.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowNodeCreatedEventHandler NodeCreated
Public Event NodeCreated As AddFlowNodeCreatedEventHandler
public:
 event AddFlowNodeCreatedEventHandler^ NodeCreated {
    void add (AddFlowNodeCreatedEventHandler^ value);
    void remove (AddFlowNodeCreatedEventHandler^ value);
}
member NodeCreated : IEvent<AddFlowNodeCreatedEventHandler,
    NodeCreatedEventArgs>

Value

Type: Lassalle.WPF.FlowAddFlowNodeCreatedEventHandler
See Also

Reference

AddFlow Class


AddFlow.NodeCreating Event

AddFlowNodeCreating Event
Occurs when a user attempts to create a node. Cancelling the action aborts the node creation.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowNodeCreatingEventHandler NodeCreating
Public Event NodeCreating As AddFlowNodeCreatingEventHandler
public:
 event AddFlowNodeCreatingEventHandler^ NodeCreating {
    void add (AddFlowNodeCreatingEventHandler^ value);
    void remove (AddFlowNodeCreatingEventHandler^ value);
}
member NodeCreating : IEvent<AddFlowNodeCreatingEventHandler,
    NodeCreatingEventArgs>

Value

Type: Lassalle.WPF.FlowAddFlowNodeCreatingEventHandler
See Also

Reference

AddFlow Class


AddFlow.NodeDeleted Event

AddFlowNodeDeleted Event
Occurs after a user removes a node.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowNodeDeletedEventHandler NodeDeleted
Public Event NodeDeleted As AddFlowNodeDeletedEventHandler
public:
 event AddFlowNodeDeletedEventHandler^ NodeDeleted {
    void add (AddFlowNodeDeletedEventHandler^ value);
    void remove (AddFlowNodeDeletedEventHandler^ value);
}
member NodeDeleted : IEvent<AddFlowNodeDeletedEventHandler,
    NodeDeletedEventArgs>

Value

Type: Lassalle.WPF.FlowAddFlowNodeDeletedEventHandler
See Also

Reference

AddFlow Class


AddFlow.NodeDeleting Event

AddFlowNodeDeleting Event
Occurs when a user attempts to create a node. Cancelling the action aborts the node creation.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowNodeDeletingEventHandler NodeDeleting
Public Event NodeDeleting As AddFlowNodeDeletingEventHandler
public:
 event AddFlowNodeDeletingEventHandler^ NodeDeleting {
    void add (AddFlowNodeDeletingEventHandler^ value);
    void remove (AddFlowNodeDeletingEventHandler^ value);
}
member NodeDeleting : IEvent<AddFlowNodeDeletingEventHandler,
    NodeDeletingEventArgs>

Value

Type: Lassalle.WPF.FlowAddFlowNodeDeletingEventHandler
See Also

Reference

AddFlow Class


AddFlow.OrgChanged Event

AddFlowOrgChanged Event
Occurs after a user has changed the origin node of a link.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowOrgChangedEventHandler OrgChanged
Public Event OrgChanged As AddFlowOrgChangedEventHandler
public:
 event AddFlowOrgChangedEventHandler^ OrgChanged {
    void add (AddFlowOrgChangedEventHandler^ value);
    void remove (AddFlowOrgChangedEventHandler^ value);
}
member OrgChanged : IEvent<AddFlowOrgChangedEventHandler,
    EventArgs>

Value

Type: Lassalle.WPF.FlowAddFlowOrgChangedEventHandler
See Also

Reference

AddFlow Class


AddFlow.OrgChanging Event

AddFlowOrgChanging Event
Occurs when a user attempts to change the origin node of a link.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowOrgChangingEventHandler OrgChanging
Public Event OrgChanging As AddFlowOrgChangingEventHandler
public:
 event AddFlowOrgChangingEventHandler^ OrgChanging {
    void add (AddFlowOrgChangingEventHandler^ value);
    void remove (AddFlowOrgChangingEventHandler^ value);
}
member OrgChanging : IEvent<AddFlowOrgChangingEventHandler,
    EventArgs>

Value

Type: Lassalle.WPF.FlowAddFlowOrgChangingEventHandler
See Also

Reference

AddFlow Class


AddFlow.SelectedItemsLayouting Event

AddFlowSelectedItemsLayouting Event
Occurs when a user is currently moving or resizing a node

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowSelectedItemsLayoutingEventHandler SelectedItemsLayouting
Public Event SelectedItemsLayouting As AddFlowSelectedItemsLayoutingEventHandler
public:
 event AddFlowSelectedItemsLayoutingEventHandler^ SelectedItemsLayouting {
    void add (AddFlowSelectedItemsLayoutingEventHandler^ value);
    void remove (AddFlowSelectedItemsLayoutingEventHandler^ value);
}
member SelectedItemsLayouting : IEvent<AddFlowSelectedItemsLayoutingEventHandler,
    SelectedItemsLayoutingEventArgs>

Value

Type: Lassalle.WPF.FlowAddFlowSelectedItemsLayoutingEventHandler
See Also

Reference

AddFlow Class


AddFlow.SelectedItemsRotating Event

AddFlowSelectedItemsRotating Event
Occurs when a user is currently rotating an item

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowSelectedItemsRotatingEventHandler SelectedItemsRotating
Public Event SelectedItemsRotating As AddFlowSelectedItemsRotatingEventHandler
public:
 event AddFlowSelectedItemsRotatingEventHandler^ SelectedItemsRotating {
    void add (AddFlowSelectedItemsRotatingEventHandler^ value);
    void remove (AddFlowSelectedItemsRotatingEventHandler^ value);
}
member SelectedItemsRotating : IEvent<AddFlowSelectedItemsRotatingEventHandler,
    SelectedItemsRotatingEventArgs>

Value

Type: Lassalle.WPF.FlowAddFlowSelectedItemsRotatingEventHandler
See Also

Reference

AddFlow Class


AddFlow.SelectedLinkStretching Event

AddFlowSelectedLinkStretching Event
Occurs when a user is currently stretching a link.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowSelectedLinkStretchingEventHandler SelectedLinkStretching
Public Event SelectedLinkStretching As AddFlowSelectedLinkStretchingEventHandler
public:
 event AddFlowSelectedLinkStretchingEventHandler^ SelectedLinkStretching {
    void add (AddFlowSelectedLinkStretchingEventHandler^ value);
    void remove (AddFlowSelectedLinkStretchingEventHandler^ value);
}
member SelectedLinkStretching : IEvent<AddFlowSelectedLinkStretchingEventHandler,
    SelectedLinkStretchingEventArgs>

Value

Type: Lassalle.WPF.FlowAddFlowSelectedLinkStretchingEventHandler
See Also

Reference

AddFlow Class


AddFlow.SelectionChanged Event

AddFlowSelectionChanged Event
Occurs when the selection status of an item is changed

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public event AddFlowSelectionChangedEventHandler SelectionChanged
Public Event SelectionChanged As AddFlowSelectionChangedEventHandler
public:
 event AddFlowSelectionChangedEventHandler^ SelectionChanged {
    void add (AddFlowSelectionChangedEventHandler^ value);
    void remove (AddFlowSelectionChangedEventHandler^ value);
}
member SelectionChanged : IEvent<AddFlowSelectionChangedEventHandler,
    SelectionChangedEventArgs>

Value

Type: Lassalle.WPF.FlowAddFlowSelectionChangedEventHandler
See Also

Reference

AddFlow Class


AddFlow.AfterEditEventHandler Delegate

AddFlowAfterEditEventHandler Delegate
Represents the method that will handle the AfterEdit event.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public delegate void AfterEditEventHandler(
    Object sender,
    AfterEditEventArgs e
)
Public Delegate Sub AfterEditEventHandler (
    sender As Object,
    e As AfterEditEventArgs
)
public delegate void AfterEditEventHandler(
    Object^ sender,
    AfterEditEventArgs^ e
)
type AfterEditEventHandler =
    delegate of
        sender : Object *
        e : AfterEditEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Lassalle.WPF.FlowAfterEditEventArgs
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


AddFlow.BeforeEditEventHandler Delegate

AddFlowBeforeEditEventHandler Delegate
Represents the method that will handle the BeforeEdit event.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public delegate void BeforeEditEventHandler(
    Object sender,
    BeforeEditEventArgs e
)
Public Delegate Sub BeforeEditEventHandler (
    sender As Object,
    e As BeforeEditEventArgs
)
public delegate void BeforeEditEventHandler(
    Object^ sender,
    BeforeEditEventArgs^ e
)
type BeforeEditEventHandler =
    delegate of
        sender : Object *
        e : BeforeEditEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Lassalle.WPF.FlowBeforeEditEventArgs
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


AddFlow.CancelEditEventHandler Delegate

AddFlowCancelEditEventHandler Delegate
Represents the method that will handle the CancelEdit event.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public delegate void CancelEditEventHandler(
    Object sender,
    CancelEditEventArgs e
)
Public Delegate Sub CancelEditEventHandler (
    sender As Object,
    e As CancelEditEventArgs
)
public delegate void CancelEditEventHandler(
    Object^ sender,
    CancelEditEventArgs^ e
)
type CancelEditEventHandler =
    delegate of
        sender : Object *
        e : CancelEditEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Lassalle.WPF.FlowCancelEditEventArgs
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


AddFlow.CaptionCreatedEventHandler Delegate

AddFlowCaptionCreatedEventHandler Delegate
Represents the method that will handle the CaptionCreated event.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public delegate void CaptionCreatedEventHandler(
    Object sender,
    CaptionCreatedEventArgs e
)
Public Delegate Sub CaptionCreatedEventHandler (
    sender As Object,
    e As CaptionCreatedEventArgs
)
public delegate void CaptionCreatedEventHandler(
    Object^ sender,
    CaptionCreatedEventArgs^ e
)
type CaptionCreatedEventHandler =
    delegate of
        sender : Object *
        e : CaptionCreatedEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Lassalle.WPF.FlowCaptionCreatedEventArgs
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


AddFlow.CaptionCreatingEventHandler Delegate

AddFlowCaptionCreatingEventHandler Delegate
Represents the method that will handle the CaptionCreating event.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public delegate void CaptionCreatingEventHandler(
    Object sender,
    CaptionCreatingEventArgs e
)
Public Delegate Sub CaptionCreatingEventHandler (
    sender As Object,
    e As CaptionCreatingEventArgs
)
public delegate void CaptionCreatingEventHandler(
    Object^ sender,
    CaptionCreatingEventArgs^ e
)
type CaptionCreatingEventHandler =
    delegate of
        sender : Object *
        e : CaptionCreatingEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Lassalle.WPF.FlowCaptionCreatingEventArgs
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


AddFlow.CaptionDeletedEventHandler Delegate

AddFlowCaptionDeletedEventHandler Delegate
Represents the method that will handle the CaptionDeleted event.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public delegate void CaptionDeletedEventHandler(
    Object sender,
    CaptionDeletedEventArgs e
)
Public Delegate Sub CaptionDeletedEventHandler (
    sender As Object,
    e As CaptionDeletedEventArgs
)
public delegate void CaptionDeletedEventHandler(
    Object^ sender,
    CaptionDeletedEventArgs^ e
)
type CaptionDeletedEventHandler =
    delegate of
        sender : Object *
        e : CaptionDeletedEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Lassalle.WPF.FlowCaptionDeletedEventArgs
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


AddFlow.CaptionDeletingEventHandler Delegate

AddFlowCaptionDeletingEventHandler Delegate
Represents the method that will handle the CaptionDeleting event.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public delegate void CaptionDeletingEventHandler(
    Object sender,
    CaptionDeletingEventArgs e
)
Public Delegate Sub CaptionDeletingEventHandler (
    sender As Object,
    e As CaptionDeletingEventArgs
)
public delegate void CaptionDeletingEventHandler(
    Object^ sender,
    CaptionDeletingEventArgs^ e
)
type CaptionDeletingEventHandler =
    delegate of
        sender : Object *
        e : CaptionDeletingEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Lassalle.WPF.FlowCaptionDeletingEventArgs
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


AddFlow.DstChangedEventHandler Delegate

AddFlowDstChangedEventHandler Delegate
Represents the method that will handle the DstChanged event.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public delegate void DstChangedEventHandler(
    Object sender,
    EventArgs e
)
Public Delegate Sub DstChangedEventHandler (
    sender As Object,
    e As EventArgs
)
public delegate void DstChangedEventHandler(
    Object^ sender,
    EventArgs^ e
)
type DstChangedEventHandler =
    delegate of
        sender : Object *
        e : EventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: SystemEventArgs
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


AddFlow.DstChangingEventHandler Delegate

AddFlowDstChangingEventHandler Delegate
Represents the method that will handle the DstChanging event.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public delegate void DstChangingEventHandler(
    Object sender,
    EventArgs e
)
Public Delegate Sub DstChangingEventHandler (
    sender As Object,
    e As EventArgs
)
public delegate void DstChangingEventHandler(
    Object^ sender,
    EventArgs^ e
)
type DstChangingEventHandler =
    delegate of
        sender : Object *
        e : EventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: SystemEventArgs
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


AddFlow.ErrorEventHandler Delegate

AddFlowErrorEventHandler Delegate
Represents the method that will handle the Error event.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public delegate void ErrorEventHandler(
    Object sender,
    ErrorEventArgs e
)
Public Delegate Sub ErrorEventHandler (
    sender As Object,
    e As ErrorEventArgs
)
public delegate void ErrorEventHandler(
    Object^ sender,
    ErrorEventArgs^ e
)
type ErrorEventHandler =
    delegate of
        sender : Object *
        e : ErrorEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Lassalle.WPF.FlowErrorEventArgs
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


AddFlow.ExtentChangedEventHandler Delegate

AddFlowExtentChangedEventHandler Delegate
Represents the method that will handle the ExtentChange event.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public delegate void ExtentChangedEventHandler(
    Object sender,
    EventArgs e
)
Public Delegate Sub ExtentChangedEventHandler (
    sender As Object,
    e As EventArgs
)
public delegate void ExtentChangedEventHandler(
    Object^ sender,
    EventArgs^ e
)
type ExtentChangedEventHandler =
    delegate of
        sender : Object *
        e : EventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: SystemEventArgs
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


AddFlow.LinkCreatedEventHandler Delegate

AddFlowLinkCreatedEventHandler Delegate
Represents the method that will handle the LinkCreated event.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public delegate void LinkCreatedEventHandler(
    Object sender,
    LinkCreatedEventArgs e
)
Public Delegate Sub LinkCreatedEventHandler (
    sender As Object,
    e As LinkCreatedEventArgs
)
public delegate void LinkCreatedEventHandler(
    Object^ sender,
    LinkCreatedEventArgs^ e
)
type LinkCreatedEventHandler =
    delegate of
        sender : Object *
        e : LinkCreatedEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Lassalle.WPF.FlowLinkCreatedEventArgs
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


AddFlow.LinkCreatingEventHandler Delegate

AddFlowLinkCreatingEventHandler Delegate
Represents the method that will handle the LinkCreating event.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public delegate void LinkCreatingEventHandler(
    Object sender,
    LinkCreatingEventArgs e
)
Public Delegate Sub LinkCreatingEventHandler (
    sender As Object,
    e As LinkCreatingEventArgs
)
public delegate void LinkCreatingEventHandler(
    Object^ sender,
    LinkCreatingEventArgs^ e
)
type LinkCreatingEventHandler =
    delegate of
        sender : Object *
        e : LinkCreatingEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Lassalle.WPF.FlowLinkCreatingEventArgs
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


AddFlow.LinkDeletedEventHandler Delegate

AddFlowLinkDeletedEventHandler Delegate
Represents the method that will handle the LinkDeleted event.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public delegate void LinkDeletedEventHandler(
    Object sender,
    LinkDeletedEventArgs e
)
Public Delegate Sub LinkDeletedEventHandler (
    sender As Object,
    e As LinkDeletedEventArgs
)
public delegate void LinkDeletedEventHandler(
    Object^ sender,
    LinkDeletedEventArgs^ e
)
type LinkDeletedEventHandler =
    delegate of
        sender : Object *
        e : LinkDeletedEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Lassalle.WPF.FlowLinkDeletedEventArgs
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


AddFlow.LinkDeletingEventHandler Delegate

AddFlowLinkDeletingEventHandler Delegate
Represents the method that will handle the LinkDeleting event.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public delegate void LinkDeletingEventHandler(
    Object sender,
    LinkDeletingEventArgs e
)
Public Delegate Sub LinkDeletingEventHandler (
    sender As Object,
    e As LinkDeletingEventArgs
)
public delegate void LinkDeletingEventHandler(
    Object^ sender,
    LinkDeletingEventArgs^ e
)
type LinkDeletingEventHandler =
    delegate of
        sender : Object *
        e : LinkDeletingEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Lassalle.WPF.FlowLinkDeletingEventArgs
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


AddFlow.NodeCreatedEventHandler Delegate

AddFlowNodeCreatedEventHandler Delegate
Represents the method that will handle the NodeCreated event.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public delegate void NodeCreatedEventHandler(
    Object sender,
    NodeCreatedEventArgs e
)
Public Delegate Sub NodeCreatedEventHandler (
    sender As Object,
    e As NodeCreatedEventArgs
)
public delegate void NodeCreatedEventHandler(
    Object^ sender,
    NodeCreatedEventArgs^ e
)
type NodeCreatedEventHandler =
    delegate of
        sender : Object *
        e : NodeCreatedEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Lassalle.WPF.FlowNodeCreatedEventArgs
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


AddFlow.NodeCreatingEventHandler Delegate

AddFlowNodeCreatingEventHandler Delegate
Represents the method that will handle the NodeCreating event.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public delegate void NodeCreatingEventHandler(
    Object sender,
    NodeCreatingEventArgs e
)
Public Delegate Sub NodeCreatingEventHandler (
    sender As Object,
    e As NodeCreatingEventArgs
)
public delegate void NodeCreatingEventHandler(
    Object^ sender,
    NodeCreatingEventArgs^ e
)
type NodeCreatingEventHandler =
    delegate of
        sender : Object *
        e : NodeCreatingEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Lassalle.WPF.FlowNodeCreatingEventArgs
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


AddFlow.NodeDeletedEventHandler Delegate

AddFlowNodeDeletedEventHandler Delegate
Represents the method that will handle the NodeDeleted event.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public delegate void NodeDeletedEventHandler(
    Object sender,
    NodeDeletedEventArgs e
)
Public Delegate Sub NodeDeletedEventHandler (
    sender As Object,
    e As NodeDeletedEventArgs
)
public delegate void NodeDeletedEventHandler(
    Object^ sender,
    NodeDeletedEventArgs^ e
)
type NodeDeletedEventHandler =
    delegate of
        sender : Object *
        e : NodeDeletedEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Lassalle.WPF.FlowNodeDeletedEventArgs
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


AddFlow.NodeDeletingEventHandler Delegate

AddFlowNodeDeletingEventHandler Delegate
Represents the method that will handle the NodeDeleting event.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public delegate void NodeDeletingEventHandler(
    Object sender,
    NodeDeletingEventArgs e
)
Public Delegate Sub NodeDeletingEventHandler (
    sender As Object,
    e As NodeDeletingEventArgs
)
public delegate void NodeDeletingEventHandler(
    Object^ sender,
    NodeDeletingEventArgs^ e
)
type NodeDeletingEventHandler =
    delegate of
        sender : Object *
        e : NodeDeletingEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Lassalle.WPF.FlowNodeDeletingEventArgs
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


AddFlow.OrgChangedEventHandler Delegate

AddFlowOrgChangedEventHandler Delegate
Represents the method that will handle the OrgChanged event.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public delegate void OrgChangedEventHandler(
    Object sender,
    EventArgs e
)
Public Delegate Sub OrgChangedEventHandler (
    sender As Object,
    e As EventArgs
)
public delegate void OrgChangedEventHandler(
    Object^ sender,
    EventArgs^ e
)
type OrgChangedEventHandler =
    delegate of
        sender : Object *
        e : EventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: SystemEventArgs
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


AddFlow.OrgChangingEventHandler Delegate

AddFlowOrgChangingEventHandler Delegate
Represents the method that will handle the OrgChanging event.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public delegate void OrgChangingEventHandler(
    Object sender,
    EventArgs e
)
Public Delegate Sub OrgChangingEventHandler (
    sender As Object,
    e As EventArgs
)
public delegate void OrgChangingEventHandler(
    Object^ sender,
    EventArgs^ e
)
type OrgChangingEventHandler =
    delegate of
        sender : Object *
        e : EventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: SystemEventArgs
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


AddFlow.SelectedItemsLayoutingEventHandler Delegate

AddFlowSelectedItemsLayoutingEventHandler Delegate
Represents the method that will handle the SelectedItemsLayouting event.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public delegate void SelectedItemsLayoutingEventHandler(
    Object sender,
    SelectedItemsLayoutingEventArgs e
)
Public Delegate Sub SelectedItemsLayoutingEventHandler (
    sender As Object,
    e As SelectedItemsLayoutingEventArgs
)
public delegate void SelectedItemsLayoutingEventHandler(
    Object^ sender,
    SelectedItemsLayoutingEventArgs^ e
)
type SelectedItemsLayoutingEventHandler =
    delegate of
        sender : Object *
        e : SelectedItemsLayoutingEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Lassalle.WPF.FlowSelectedItemsLayoutingEventArgs
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


AddFlow.SelectedItemsRotatingEventHandler Delegate

AddFlowSelectedItemsRotatingEventHandler Delegate
Represents the method that will handle the SelectedItemsRotating event.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public delegate void SelectedItemsRotatingEventHandler(
    Object sender,
    SelectedItemsRotatingEventArgs e
)
Public Delegate Sub SelectedItemsRotatingEventHandler (
    sender As Object,
    e As SelectedItemsRotatingEventArgs
)
public delegate void SelectedItemsRotatingEventHandler(
    Object^ sender,
    SelectedItemsRotatingEventArgs^ e
)
type SelectedItemsRotatingEventHandler =
    delegate of
        sender : Object *
        e : SelectedItemsRotatingEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Lassalle.WPF.FlowSelectedItemsRotatingEventArgs
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


AddFlow.SelectedLinkStretchingEventHandler Delegate

AddFlowSelectedLinkStretchingEventHandler Delegate
Represents the method that will handle the SelectedLinkStretching event.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public delegate void SelectedLinkStretchingEventHandler(
    Object sender,
    SelectedLinkStretchingEventArgs e
)
Public Delegate Sub SelectedLinkStretchingEventHandler (
    sender As Object,
    e As SelectedLinkStretchingEventArgs
)
public delegate void SelectedLinkStretchingEventHandler(
    Object^ sender,
    SelectedLinkStretchingEventArgs^ e
)
type SelectedLinkStretchingEventHandler =
    delegate of
        sender : Object *
        e : SelectedLinkStretchingEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Lassalle.WPF.FlowSelectedLinkStretchingEventArgs
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


AddFlow.SelectionChangedEventHandler Delegate

AddFlowSelectionChangedEventHandler Delegate
Represents the method that will handle the SelectionChanged event.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public delegate void SelectionChangedEventHandler(
    Object sender,
    SelectionChangedEventArgs e
)
Public Delegate Sub SelectionChangedEventHandler (
    sender As Object,
    e As SelectionChangedEventArgs
)
public delegate void SelectionChangedEventHandler(
    Object^ sender,
    SelectionChangedEventArgs^ e
)
type SelectionChangedEventHandler =
    delegate of
        sender : Object *
        e : SelectionChangedEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Lassalle.WPF.FlowSelectionChangedEventArgs
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


AddFlowException Class

AddFlowException Class
AddFlow exception class
Inheritance Hierarchy
SystemObject
SystemException
SystemApplicationException
Lassalle.WPF.FlowAddFlowException

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public class AddFlowException : ApplicationException
Public Class AddFlowException
    Inherits ApplicationException
public ref class AddFlowException : public ApplicationException
type AddFlowException =
    class
        inherit ApplicationException
    end

The AddFlowException type exposes the following members.

Constructors
 | Name | Description
Public method | AddFlowException | AddFlow exception class constructor with 1 parameter: the message text.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


AddFlowException Constructor

AddFlowException Constructor
AddFlow exception class constructor with 1 parameter: the message text.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public AddFlowException(
    string message
)
Public Sub New (
    message As String
)
public:
AddFlowException(
    String^ message
)
new :
        message : string -> AddFlowException

Parameters

message
Type: SystemString
The message that describes the error.
See Also

Reference

AddFlowException Class


AddFlowException Methods

AddFlowException Methods

The AddFlowException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

AddFlowException Class


AddFlowException Properties

AddFlowException Properties

The AddFlowException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

AddFlowException Class


AddFlowException Events

AddFlowException Events

The AddFlowException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

AddFlowException Class


AddFlowLicenseProvider Class

AddFlowLicenseProvider Class

[Missing <summary> documentation for "T:Lassalle.WPF.Flow.AddFlowLicenseProvider"]

Inheritance Hierarchy
SystemObject
System.ComponentModelLicenseProvider
System.ComponentModelLicFileLicenseProvider
Lassalle.WPF.FlowAddFlowLicenseProvider

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public class AddFlowLicenseProvider : LicFileLicenseProvider
Public Class AddFlowLicenseProvider
    Inherits LicFileLicenseProvider
public ref class AddFlowLicenseProvider : public LicFileLicenseProvider
type AddFlowLicenseProvider =
    class
        inherit LicFileLicenseProvider
    end

The AddFlowLicenseProvider type exposes the following members.

Constructors
 | Name | Description
Public method | AddFlowLicenseProvider | Initializes a new instance of the AddFlowLicenseProvider class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetKey | (Overrides LicFileLicenseProviderGetKey(Type).)
Public method | GetLicense | Returns a license for the instance of the component, if one is available. (Inherited from LicFileLicenseProvider.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | IsKeyValid | (Overrides LicFileLicenseProviderIsKeyValid(String, Type).)
 | IsLicensePro | Indicates if it is a professional license
 | IsLicenseStd | Indicates if it is a standard license
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


AddFlowLicenseProvider Constructor

AddFlowLicenseProvider Constructor
Initializes a new instance of the AddFlowLicenseProvider class

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public AddFlowLicenseProvider()
Public Sub New
public:
AddFlowLicenseProvider()
new : unit -> AddFlowLicenseProvider
See Also

Reference

AddFlowLicenseProvider Class


AddFlowLicenseProvider Methods

AddFlowLicenseProvider Methods

The AddFlowLicenseProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetKey | (Overrides LicFileLicenseProviderGetKey(Type).)
Public method | GetLicense | Returns a license for the instance of the component, if one is available. (Inherited from LicFileLicenseProvider.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | IsKeyValid | (Overrides LicFileLicenseProviderIsKeyValid(String, Type).)
 | IsLicensePro | Indicates if it is a professional license
 | IsLicenseStd | Indicates if it is a standard license
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
See Also

Reference

AddFlowLicenseProvider Class


AddFlowLicenseProvider.GetKey Method

AddFlowLicenseProviderGetKey Method

[Missing <summary> documentation for "M:Lassalle.WPF.Flow.AddFlowLicenseProvider.GetKey(System.Type)"]

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
protected override string GetKey(
    Type type
)
Protected Overrides Function GetKey (
    type As Type
) As String
protected:
virtual String^ GetKey(
    Type^ type
) override
abstract GetKey :
        type : Type -> string
override GetKey :
        type : Type -> string

Parameters

type
Type: SystemType

[Missing <param name="type"/> documentation for "M:Lassalle.WPF.Flow.AddFlowLicenseProvider.GetKey(System.Type)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Lassalle.WPF.Flow.AddFlowLicenseProvider.GetKey(System.Type)"]

See Also

Reference

AddFlowLicenseProvider Class


AddFlowLicenseProvider.IsKeyValid Method

AddFlowLicenseProviderIsKeyValid Method

[Missing <summary> documentation for "M:Lassalle.WPF.Flow.AddFlowLicenseProvider.IsKeyValid(System.String,System.Type)"]

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
protected override bool IsKeyValid(
    string key,
    Type type
)
Protected Overrides Function IsKeyValid (
    key As String,
    type As Type
) As Boolean
protected:
virtual bool IsKeyValid(
    String^ key,
    Type^ type
) override
abstract IsKeyValid :
        key : string *
        type : Type -> bool
override IsKeyValid :
        key : string *
        type : Type -> bool

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Lassalle.WPF.Flow.AddFlowLicenseProvider.IsKeyValid(System.String,System.Type)"]

type
Type: SystemType

[Missing <param name="type"/> documentation for "M:Lassalle.WPF.Flow.AddFlowLicenseProvider.IsKeyValid(System.String,System.Type)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Lassalle.WPF.Flow.AddFlowLicenseProvider.IsKeyValid(System.String,System.Type)"]

See Also

Reference

AddFlowLicenseProvider Class


AddFlowLicenseProvider.IsLicensePro Method

AddFlowLicenseProviderIsLicensePro Method
Indicates if it is a professional license

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public static bool IsLicensePro()
Public Shared Function IsLicensePro As Boolean
public:
static bool IsLicensePro()
static member IsLicensePro : unit -> bool

Return Value

Type: Boolean
true if it is a professional license
See Also

Reference

AddFlowLicenseProvider Class


AddFlowLicenseProvider.IsLicenseStd Method

AddFlowLicenseProviderIsLicenseStd Method
Indicates if it is a standard license

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public static bool IsLicenseStd()
Public Shared Function IsLicenseStd As Boolean
public:
static bool IsLicenseStd()
static member IsLicenseStd : unit -> bool

Return Value

Type: Boolean
true if it is a standard license
See Also

Reference

AddFlowLicenseProvider Class


AfterEditEventArgs Class

AfterEditEventArgs Class
Event parameters used for the AfterEdit event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.WPF.FlowAfterEditEventArgs

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public class AfterEditEventArgs : EventArgs
Public Class AfterEditEventArgs
    Inherits EventArgs
public ref class AfterEditEventArgs : public EventArgs
type AfterEditEventArgs =
    class
        inherit EventArgs
    end

The AfterEditEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | AfterEditEventArgs | Constructor. Creates a new AfterEditEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the edition should be canceled.
Public property | ContentItem | The ContentItem that has just been edited (read-only)
Public property | Text | Gets/sets the text of the ContentItem being edited.
Top
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


AfterEditEventArgs Constructor

AfterEditEventArgs Constructor
Constructor. Creates a new AfterEditEventArgs instance.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public AfterEditEventArgs(
    string text,
    ContentItem contentItem
)
Public Sub New (
    text As String,
    contentItem As ContentItem
)
public:
AfterEditEventArgs(
    String^ text,
    ContentItem^ contentItem
)
new :
        text : string *
        contentItem : ContentItem -> AfterEditEventArgs

Parameters

text
Type: SystemString
Text of the node being edited.
contentItem
Type: Lassalle.WPF.FlowContentItem
A reference to the ContentItem that has just been edited.
See Also

Reference

AfterEditEventArgs Class


AfterEditEventArgs Methods

AfterEditEventArgs Methods

The AfterEditEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
See Also

Reference

AfterEditEventArgs Class


AfterEditEventArgs Properties

AfterEditEventArgs Properties

The AfterEditEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the edition should be canceled.
Public property | ContentItem | The ContentItem that has just been edited (read-only)
Public property | Text | Gets/sets the text of the ContentItem being edited.
Top
See Also

Reference

AfterEditEventArgs Class


AfterEditEventArgs.Cancel Property

AfterEditEventArgsCancel Property
Gets/sets a value indicating whether the edition should be canceled.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public CancelEventArgs Cancel { get; set; }
Public Property Cancel As CancelEventArgs
    Get
    Set
public:
property CancelEventArgs^ Cancel {
    CancelEventArgs^ get ();
    void set (CancelEventArgs^ value);
}
member Cancel : CancelEventArgs with get, set

Property Value

Type: CancelEventArgs
See Also

Reference

AfterEditEventArgs Class


AfterEditEventArgs.ContentItem Property

AfterEditEventArgsContentItem Property
The ContentItem that has just been edited (read-only)

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public ContentItem ContentItem { get; }
Public ReadOnly Property ContentItem As ContentItem
    Get
public:
property ContentItem^ ContentItem {
    ContentItem^ get ();
}
member ContentItem : ContentItem with get

Property Value

Type: ContentItem
See Also

Reference

AfterEditEventArgs Class


AfterEditEventArgs.Text Property

AfterEditEventArgsText Property
Gets/sets the text of the ContentItem being edited.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
member Text : string with get, set

Property Value

Type: String
See Also

Reference

AfterEditEventArgs Class


BackMode Enumeration

BackMode Enumeration
Used to specify whether the background will remain untouched or not for the text in a node.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public enum BackMode
Public Enumeration BackMode
public enum class BackMode
type BackMode
Members
Member name | Value | Description
Transparent | 0 | The background remains untouched
Opaque | 1 | The background is filled with the background color before the text (default).
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


BeforeAddLinkEventArgs Class

BeforeAddLinkEventArgs Class
Event parameters used for the BeforeAddLink event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.WPF.FlowBeforeAddLinkEventArgs

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public class BeforeAddLinkEventArgs : EventArgs
Public Class BeforeAddLinkEventArgs
    Inherits EventArgs
public ref class BeforeAddLinkEventArgs : public EventArgs
type BeforeAddLinkEventArgs =
    class
        inherit EventArgs
    end

The BeforeAddLinkEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | BeforeAddLinkEventArgs | Constructor. Creates a new BeforeAddLinkEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the link creation should be canceled.
Public property | Dst | The destination node of the link to create (read-only)
Public property | Org | The origin node of the link to create (read-only)
Top
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


BeforeAddLinkEventArgs Constructor

BeforeAddLinkEventArgs Constructor
Constructor. Creates a new BeforeAddLinkEventArgs instance.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public BeforeAddLinkEventArgs(
    Node org,
    Node dst
)
Public Sub New (
    org As Node,
    dst As Node
)
public:
BeforeAddLinkEventArgs(
    Node^ org,
    Node^ dst
)
new :
        org : Node *
        dst : Node -> BeforeAddLinkEventArgs

Parameters

org
Type: Lassalle.WPF.FlowNode
The origin node of the link that is going to be created
dst
Type: Lassalle.WPF.FlowNode
The destination node of the link that is going to be created
See Also

Reference

BeforeAddLinkEventArgs Class


BeforeAddLinkEventArgs Methods

BeforeAddLinkEventArgs Methods

The BeforeAddLinkEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
See Also

Reference

BeforeAddLinkEventArgs Class


BeforeAddLinkEventArgs Properties

BeforeAddLinkEventArgs Properties

The BeforeAddLinkEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the link creation should be canceled.
Public property | Dst | The destination node of the link to create (read-only)
Public property | Org | The origin node of the link to create (read-only)
Top
See Also

Reference

BeforeAddLinkEventArgs Class


BeforeAddLinkEventArgs.Cancel Property

BeforeAddLinkEventArgsCancel Property
Gets/sets a value indicating whether the link creation should be canceled.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public CancelEventArgs Cancel { get; set; }
Public Property Cancel As CancelEventArgs
    Get
    Set
public:
property CancelEventArgs^ Cancel {
    CancelEventArgs^ get ();
    void set (CancelEventArgs^ value);
}
member Cancel : CancelEventArgs with get, set

Property Value

Type: CancelEventArgs
See Also

Reference

BeforeAddLinkEventArgs Class


BeforeAddLinkEventArgs.Dst Property

BeforeAddLinkEventArgsDst Property
The destination node of the link to create (read-only)

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Node Dst { get; }
Public ReadOnly Property Dst As Node
    Get
public:
property Node^ Dst {
    Node^ get ();
}
member Dst : Node with get

Property Value

Type: Node
See Also

Reference

BeforeAddLinkEventArgs Class


BeforeAddLinkEventArgs.Org Property

BeforeAddLinkEventArgsOrg Property
The origin node of the link to create (read-only)

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Node Org { get; }
Public ReadOnly Property Org As Node
    Get
public:
property Node^ Org {
    Node^ get ();
}
member Org : Node with get

Property Value

Type: Node
See Also

Reference

BeforeAddLinkEventArgs Class


BeforeEditEventArgs Class

BeforeEditEventArgs Class
Event parameters used for the BeforeEdit event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.WPF.FlowBeforeEditEventArgs

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public class BeforeEditEventArgs : EventArgs
Public Class BeforeEditEventArgs
    Inherits EventArgs
public ref class BeforeEditEventArgs : public EventArgs
type BeforeEditEventArgs =
    class
        inherit EventArgs
    end

The BeforeEditEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | BeforeEditEventArgs | Default constructor
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the edition should be canceled.
Public property | ContentItem | The ContentItem that is going to be edited (read-only)
Top
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


BeforeEditEventArgs Constructor

BeforeEditEventArgs Constructor
Default constructor

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public BeforeEditEventArgs(
    ContentItem contentItem
)
Public Sub New (
    contentItem As ContentItem
)
public:
BeforeEditEventArgs(
    ContentItem^ contentItem
)
new :
        contentItem : ContentItem -> BeforeEditEventArgs

Parameters

contentItem
Type: Lassalle.WPF.FlowContentItem
A reference to the ContentItem that is going to be edited.
See Also

Reference

BeforeEditEventArgs Class


BeforeEditEventArgs Methods

BeforeEditEventArgs Methods

The BeforeEditEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
See Also

Reference

BeforeEditEventArgs Class


BeforeEditEventArgs Properties

BeforeEditEventArgs Properties

The BeforeEditEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the edition should be canceled.
Public property | ContentItem | The ContentItem that is going to be edited (read-only)
Top
See Also

Reference

BeforeEditEventArgs Class


BeforeEditEventArgs.Cancel Property

BeforeEditEventArgsCancel Property
Gets/sets a value indicating whether the edition should be canceled.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public CancelEventArgs Cancel { get; set; }
Public Property Cancel As CancelEventArgs
    Get
    Set
public:
property CancelEventArgs^ Cancel {
    CancelEventArgs^ get ();
    void set (CancelEventArgs^ value);
}
member Cancel : CancelEventArgs with get, set

Property Value

Type: CancelEventArgs
See Also

Reference

BeforeEditEventArgs Class


BeforeEditEventArgs.ContentItem Property

BeforeEditEventArgsContentItem Property
The ContentItem that is going to be edited (read-only)

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public ContentItem ContentItem { get; }
Public ReadOnly Property ContentItem As ContentItem
    Get
public:
property ContentItem^ ContentItem {
    ContentItem^ get ();
}
member ContentItem : ContentItem with get

Property Value

Type: ContentItem
See Also

Reference

BeforeEditEventArgs Class


CancelEditEventArgs Class

CancelEditEventArgs Class
Event parameters used for the CancelEdit event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.WPF.FlowCancelEditEventArgs

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public class CancelEditEventArgs : EventArgs
Public Class CancelEditEventArgs
    Inherits EventArgs
public ref class CancelEditEventArgs : public EventArgs
type CancelEditEventArgs =
    class
        inherit EventArgs
    end

The CancelEditEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | CancelEditEventArgs | Constructor. Creates a new CancelEditEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ContentItem | The ContentItem that has just been edited (read-only)
Public property | Text | Gets/sets the text of the node being edited.
Top
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


CancelEditEventArgs Constructor

CancelEditEventArgs Constructor
Constructor. Creates a new CancelEditEventArgs instance.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public CancelEditEventArgs(
    string text,
    ContentItem contentItem
)
Public Sub New (
    text As String,
    contentItem As ContentItem
)
public:
CancelEditEventArgs(
    String^ text,
    ContentItem^ contentItem
)
new :
        text : string *
        contentItem : ContentItem -> CancelEditEventArgs

Parameters

text
Type: SystemString
Text of the node being edited.
contentItem
Type: Lassalle.WPF.FlowContentItem
A reference to the ContentItem that has just been edited.
See Also

Reference

CancelEditEventArgs Class


CancelEditEventArgs Methods

CancelEditEventArgs Methods

The CancelEditEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
See Also

Reference

CancelEditEventArgs Class


CancelEditEventArgs Properties

CancelEditEventArgs Properties

The CancelEditEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ContentItem | The ContentItem that has just been edited (read-only)
Public property | Text | Gets/sets the text of the node being edited.
Top
See Also

Reference

CancelEditEventArgs Class


CancelEditEventArgs.ContentItem Property

CancelEditEventArgsContentItem Property
The ContentItem that has just been edited (read-only)

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public ContentItem ContentItem { get; }
Public ReadOnly Property ContentItem As ContentItem
    Get
public:
property ContentItem^ ContentItem {
    ContentItem^ get ();
}
member ContentItem : ContentItem with get

Property Value

Type: ContentItem
See Also

Reference

CancelEditEventArgs Class


CancelEditEventArgs.Text Property

CancelEditEventArgsText Property
Gets/sets the text of the node being edited.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
member Text : string with get, set

Property Value

Type: String
See Also

Reference

CancelEditEventArgs Class


Caption Class

Caption Class
Represents a caption (also called label or note) in the diagram. A caption is a ContentItem object that can be owned by an Item
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
Lassalle.WPF.FlowItem
Lassalle.WPF.FlowContentItem
Lassalle.WPF.FlowCaption

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public class Caption : ContentItem
Public Class Caption
    Inherits ContentItem
public ref class Caption : public ContentItem
type Caption =
    class
        inherit ContentItem
    end

The Caption type exposes the following members.

Constructors
 | Name | Description
Public method | Caption | Caption constructor
Public method | Caption(Double, Double, Double, Double, String, Item, AddFlow) | Initializes a new instance of the Caption class with an initial position and size, an initial text.
Public method | Caption(Double, Double, Double, Double, String, Item, Caption) | Initializes a new instance of the Caption class with an initial position and size, an initial text and with the default property values given by a Caption object
Top
Methods
 | Name | Description
Public method | BeginEdit | Initiates the editing of the node label. (Inherited from ContentItem.)
Public method | BringIntoView | Ensures that the item is in the viewable area of the control. If the item is not viewable, scrolls the control as necessary to bring the item into view. (Inherited from Item.)
Public method | CancelEdit | Cancels the editing of the ContentItem text. (Inherited from ContentItem.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndEdit | Ends the editing of the node label. (Inherited from ContentItem.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this DependencyObject has been updated. The specific dependency property that changed is reported in the event data. (Inherited from DependencyObject.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Refresh | Forces a repaint of the item. (Inherited from Item.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeImageMargin | Returns true if ImageMargin should be serialized. (Inherited from ContentItem.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeTextMargin | Returns true if TextMargin should be serialized. (Inherited from ContentItem.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Properties
 | Name | Description
Public property | AddFlow | The addflow canvas containing this item (Inherited from Item.)
Public property | AnchorPositionOnLink | Returns/sets a value which defines the position of the caption near the link.
Public property | BackMode | Determines whether the background remains untouched or if the background is filled with the current background color before the text of the item. (Inherited from Item.)
Public property | Bounds | Returns the item bounding rectangle (Inherited from Item.)
Public property | Captions | Returns the collection of the captions attached to this item. (Inherited from Item.)
Public property | DashStyle | Returns/sets the DashStyle of the pen used to draw the item. (Inherited from Item.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Dock | Returns/sets the DockStyle of the caption.
Public property | Fill | Returns/sets the brush used to fill the item. (Inherited from Item.)
Public property | FontFamily | Gets or sets the font family to use with the item (Inherited from Item.)
Public property | FontSize | Gets or sets the font size to use with the item (Inherited from Item.)
Public property | FontStretch | Gets or sets a FontStretch property that selects a normal, condensed, or expanded font from a FontFamily (Inherited from Item.)
Public property | FontStrikethrough | Indicates whether this Font has a strikethrough TextDecoration (Inherited from Item.)
Public property | FontStyle | Gets or sets the font style to use with the item (Inherited from Item.)
Public property | FontUnderline | Indicates whether this Font is underlined (Inherited from Item.)
Public property | FontWeight | Gets or sets the font weight to use with the item (Inherited from Item.)
Public property | Foreground | Gets or sets the Brush to apply to the text of the item (Inherited from Item.)
Public property | Geometry | Returns/sets the geometry of the ContentItem object (Inherited from ContentItem.)
Public property | Image | Returns/sets the image displayed in the ContentItem object. (Inherited from ContentItem.)
Public property | ImageMargin | Returns/sets the size of the margins for the image of the node. (Inherited from ContentItem.)
Public property | ImagePosition | Returns/sets the picture position in the node. (Inherited from ContentItem.)
Public property | IsClipContent | Determines whether the content of the contentItem object is clipped or not. (Inherited from ContentItem.)
Public property | IsEditable | Determines whether the text of contentItem object can be edited or not (Inherited from ContentItem.)
Public property | IsEditing | Returns/sets a value indicating whether the text of the ContentItem object is currently edited (Inherited from ContentItem.)
Public property | IsHitTestVisible | Determines whether the item can be hit tested. (Inherited from Item.)
Public property | IsImageSizeFitContentArea | Determines whether the image of the contentItem object is adjusted to its size. (Inherited from ContentItem.)
Public property | IsRotatable | Determines whether the contentItem object can be rotated or not. (Inherited from ContentItem.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelectable | Determines whether the item is selectable by clicking on it with the mouse or unselectable (readonly or inactive). (Inherited from Item.)
Public property | IsSelected | Returns/sets a flag indicating if the item is selected or not. (Inherited from Item.)
Public property | IsXMoveable | Determines whether the contentItem object can be horizontally moved or not. (Inherited from ContentItem.)
Public property | IsXSizeable | Determines whether the contentItem object can be horizontally resized or not. (Inherited from ContentItem.)
Public property | IsYMoveable | Determines whether the contentItem object can be vertically moved or not. (Inherited from ContentItem.)
Public property | IsYSizeable | Determines whether the contentItem object can be vertically resized or not. (Inherited from ContentItem.)
Public property | Location | Returns/sets the position of a node. (Overrides ContentItemLocation.)
Public property | Owner | Returns/sets the reference of the owner item of this caption
Public property | RotationAngle | Returns/sets the rotation angle (in degrees) of a caption. (Overrides ContentItemRotationAngle.)
Public property | Size | Returns/sets the size of a node. (Overrides ContentItemSize.)
Public property | Stroke | Returns/sets the brush used to draw the item. (Inherited from Item.)
Public property | StrokeThickness | Returns/sets the pen width used to draw the item. (Inherited from Item.)
Public property | Text | Returns/sets the text associated with the item. In the case of a node, the text is displayed inside the node. It is a multiline display. The text is wrapped automatically inside the node. Linefeed and carriage return characters are allowed. (Inherited from Item.)
Public property | TextMargin | Returns/sets the size of the margins for the text of the node. (Inherited from ContentItem.)
Public property | TextPosition | Returns/sets the position style of the text of the node. (Inherited from ContentItem.)
Public property | TextTrimming | Returns/sets the string trimming of the text in the node. (Inherited from ContentItem.)
Public property | Tooltip | Returns/sets the tooltip associated with the item. (Inherited from Item.)
Public property | Visual | The DrawingVisualobject used to display the item (Inherited from Item.)
Top
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


Caption Constructor

Caption Constructor
Overload List
 | Name | Description
Public method | Caption | Caption constructor
Public method | Caption(Double, Double, Double, Double, String, Item, AddFlow) | Initializes a new instance of the Caption class with an initial position and size, an initial text.
Public method | Caption(Double, Double, Double, Double, String, Item, Caption) | Initializes a new instance of the Caption class with an initial position and size, an initial text and with the default property values given by a Caption object
Top
See Also

Reference

Caption Class


Caption Constructor

Caption Constructor
Caption constructor

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Caption()
Public Sub New
public:
Caption()
new : unit -> Caption
See Also

Reference

Caption Class
Caption Overload


Caption Constructor (Double, Double, Double, Double, String, Item, AddFlow)

Caption Constructor (Double, Double, Double, Double, String, Item, AddFlow)
Initializes a new instance of the Caption class with an initial position and size, an initial text.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Caption(
    double left,
    double top,
    double width,
    double height,
    string text,
    Item owner,
    AddFlow addflow
)
Public Sub New (
    left As Double,
    top As Double,
    width As Double,
    height As Double,
    text As String,
    owner As Item,
    addflow As AddFlow
)
public:
Caption(
    double left,
    double top,
    double width,
    double height,
    String^ text,
    Item^ owner,
    AddFlow^ addflow
)
new :
        left : float *
        top : float *
        width : float *
        height : float *
        text : string *
        owner : Item *
        addflow : AddFlow -> Caption

Parameters

left
Type: SystemDouble
The x-coordinate of the caption position
top
Type: SystemDouble
The y-coordinate of the caption position
width
Type: SystemDouble
The horizontal size of the caption
height
Type: SystemDouble
The vertical size of the caption
text
Type: SystemString
The text displayed in the caption
owner
Type: Lassalle.WPF.FlowItem
The item that will own this caption
addflow
Type: Lassalle.WPF.FlowAddFlow
The AddFlow control that will supply default property values for the caption
See Also

Reference

Caption Class
Caption Overload


Caption Constructor (Double, Double, Double, Double, String, Item, Caption)

Caption Constructor (Double, Double, Double, Double, String, Item, Caption)
Initializes a new instance of the Caption class with an initial position and size, an initial text and with the default property values given by a Caption object

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Caption(
    double left,
    double top,
    double width,
    double height,
    string text,
    Item owner,
    Caption caption
)
Public Sub New (
    left As Double,
    top As Double,
    width As Double,
    height As Double,
    text As String,
    owner As Item,
    caption As Caption
)
public:
Caption(
    double left,
    double top,
    double width,
    double height,
    String^ text,
    Item^ owner,
    Caption^ caption
)
new :
        left : float *
        top : float *
        width : float *
        height : float *
        text : string *
        owner : Item *
        caption : Caption -> Caption

Parameters

left
Type: SystemDouble
The x-coordinate of the caption position
top
Type: SystemDouble
The y-coordinate of the caption position
width
Type: SystemDouble
The horizontal size of the caption
height
Type: SystemDouble
The vertical size of the caption
text
Type: SystemString
The text of the caption
owner
Type: Lassalle.WPF.FlowItem
The item that will own this caption
caption
Type: Lassalle.WPF.FlowCaption
An object containing the default property values of captions.
See Also

Reference

Caption Class
Caption Overload


Caption Methods

Caption Methods

The Caption type exposes the following members.

Methods
 | Name | Description
Public method | BeginEdit | Initiates the editing of the node label. (Inherited from ContentItem.)
Public method | BringIntoView | Ensures that the item is in the viewable area of the control. If the item is not viewable, scrolls the control as necessary to bring the item into view. (Inherited from Item.)
Public method | CancelEdit | Cancels the editing of the ContentItem text. (Inherited from ContentItem.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndEdit | Ends the editing of the node label. (Inherited from ContentItem.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this DependencyObject has been updated. The specific dependency property that changed is reported in the event data. (Inherited from DependencyObject.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Refresh | Forces a repaint of the item. (Inherited from Item.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeImageMargin | Returns true if ImageMargin should be serialized. (Inherited from ContentItem.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeTextMargin | Returns true if TextMargin should be serialized. (Inherited from ContentItem.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

Caption Class


Caption Properties

Caption Properties

The Caption type exposes the following members.

Properties
 | Name | Description
Public property | AddFlow | The addflow canvas containing this item (Inherited from Item.)
Public property | AnchorPositionOnLink | Returns/sets a value which defines the position of the caption near the link.
Public property | BackMode | Determines whether the background remains untouched or if the background is filled with the current background color before the text of the item. (Inherited from Item.)
Public property | Bounds | Returns the item bounding rectangle (Inherited from Item.)
Public property | Captions | Returns the collection of the captions attached to this item. (Inherited from Item.)
Public property | DashStyle | Returns/sets the DashStyle of the pen used to draw the item. (Inherited from Item.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Dock | Returns/sets the DockStyle of the caption.
Public property | Fill | Returns/sets the brush used to fill the item. (Inherited from Item.)
Public property | FontFamily | Gets or sets the font family to use with the item (Inherited from Item.)
Public property | FontSize | Gets or sets the font size to use with the item (Inherited from Item.)
Public property | FontStretch | Gets or sets a FontStretch property that selects a normal, condensed, or expanded font from a FontFamily (Inherited from Item.)
Public property | FontStrikethrough | Indicates whether this Font has a strikethrough TextDecoration (Inherited from Item.)
Public property | FontStyle | Gets or sets the font style to use with the item (Inherited from Item.)
Public property | FontUnderline | Indicates whether this Font is underlined (Inherited from Item.)
Public property | FontWeight | Gets or sets the font weight to use with the item (Inherited from Item.)
Public property | Foreground | Gets or sets the Brush to apply to the text of the item (Inherited from Item.)
Public property | Geometry | Returns/sets the geometry of the ContentItem object (Inherited from ContentItem.)
Public property | Image | Returns/sets the image displayed in the ContentItem object. (Inherited from ContentItem.)
Public property | ImageMargin | Returns/sets the size of the margins for the image of the node. (Inherited from ContentItem.)
Public property | ImagePosition | Returns/sets the picture position in the node. (Inherited from ContentItem.)
Public property | IsClipContent | Determines whether the content of the contentItem object is clipped or not. (Inherited from ContentItem.)
Public property | IsEditable | Determines whether the text of contentItem object can be edited or not (Inherited from ContentItem.)
Public property | IsEditing | Returns/sets a value indicating whether the text of the ContentItem object is currently edited (Inherited from ContentItem.)
Public property | IsHitTestVisible | Determines whether the item can be hit tested. (Inherited from Item.)
Public property | IsImageSizeFitContentArea | Determines whether the image of the contentItem object is adjusted to its size. (Inherited from ContentItem.)
Public property | IsRotatable | Determines whether the contentItem object can be rotated or not. (Inherited from ContentItem.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelectable | Determines whether the item is selectable by clicking on it with the mouse or unselectable (readonly or inactive). (Inherited from Item.)
Public property | IsSelected | Returns/sets a flag indicating if the item is selected or not. (Inherited from Item.)
Public property | IsXMoveable | Determines whether the contentItem object can be horizontally moved or not. (Inherited from ContentItem.)
Public property | IsXSizeable | Determines whether the contentItem object can be horizontally resized or not. (Inherited from ContentItem.)
Public property | IsYMoveable | Determines whether the contentItem object can be vertically moved or not. (Inherited from ContentItem.)
Public property | IsYSizeable | Determines whether the contentItem object can be vertically resized or not. (Inherited from ContentItem.)
Public property | Location | Returns/sets the position of a node. (Overrides ContentItemLocation.)
Public property | Owner | Returns/sets the reference of the owner item of this caption
Public property | RotationAngle | Returns/sets the rotation angle (in degrees) of a caption. (Overrides ContentItemRotationAngle.)
Public property | Size | Returns/sets the size of a node. (Overrides ContentItemSize.)
Public property | Stroke | Returns/sets the brush used to draw the item. (Inherited from Item.)
Public property | StrokeThickness | Returns/sets the pen width used to draw the item. (Inherited from Item.)
Public property | Text | Returns/sets the text associated with the item. In the case of a node, the text is displayed inside the node. It is a multiline display. The text is wrapped automatically inside the node. Linefeed and carriage return characters are allowed. (Inherited from Item.)
Public property | TextMargin | Returns/sets the size of the margins for the text of the node. (Inherited from ContentItem.)
Public property | TextPosition | Returns/sets the position style of the text of the node. (Inherited from ContentItem.)
Public property | TextTrimming | Returns/sets the string trimming of the text in the node. (Inherited from ContentItem.)
Public property | Tooltip | Returns/sets the tooltip associated with the item. (Inherited from Item.)
Public property | Visual | The DrawingVisualobject used to display the item (Inherited from Item.)
Top
See Also

Reference

Caption Class


Caption.AnchorPositionOnLink Property

CaptionAnchorPositionOnLink Property
Returns/sets a value which defines the position of the caption near the link.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public double AnchorPositionOnLink { get; set; }
Public Property AnchorPositionOnLink As Double
    Get
    Set
public:
property double AnchorPositionOnLink {
    double get ();
    void set (double value);
}
member AnchorPositionOnLink : float with get, set

Property Value

Type: Double
Remarks
It is a value betwwen 0 and 1. If it is 0, then the caption is placed near the origin node of the link. If it is 1, then the caption is placed near the destination node of the link. If it is for instance 0.5, then the caption is placed near the middle of the link.
See Also

Reference

Caption Class


Caption.Dock Property

CaptionDock Property
Returns/sets the DockStyle of the caption.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public DockStyle Dock { get; set; }
Public Property Dock As DockStyle
    Get
    Set
public:
property DockStyle Dock {
    DockStyle get ();
    void set (DockStyle value);
}
member Dock : DockStyle with get, set

Property Value

Type: DockStyle
Remarks
This property is relevant only if the caption is attached to a ContentItem object
See Also

Reference

Caption Class


Caption.Location Property

CaptionLocation Property
Returns/sets the position of a node.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public override Point Location { get; set; }
Public Overrides Property Location As Point
    Get
    Set
public:
virtual property Point Location {
    Point get () override;
    void set (Point value) override;
}
abstract Location : Point with get, set
override Location : Point with get, set

Property Value

Type: Point
See Also

Reference

Caption Class


Caption.Owner Property

CaptionOwner Property
Returns/sets the reference of the owner item of this caption

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Item Owner { get; set; }
Public Property Owner As Item
    Get
    Set
public:
property Item^ Owner {
    Item^ get ();
    void set (Item^ value);
}
member Owner : Item with get, set

Property Value

Type: Item
See Also

Reference

Caption Class


Caption.RotationAngle Property

CaptionRotationAngle Property
Returns/sets the rotation angle (in degrees) of a caption.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public override double RotationAngle { get; set; }
Public Overrides Property RotationAngle As Double
    Get
    Set
public:
virtual property double RotationAngle {
    double get () override;
    void set (double value) override;
}
abstract RotationAngle : float with get, set
override RotationAngle : float with get, set

Property Value

Type: Double

Implements

IRotatableRotationAngle
See Also

Reference

Caption Class


Caption.Size Property

CaptionSize Property
Returns/sets the size of a node.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public override Size Size { get; set; }
Public Overrides Property Size As Size
    Get
    Set
public:
virtual property Size Size {
    Size get () override;
    void set (Size value) override;
}
abstract Size : Size with get, set
override Size : Size with get, set

Property Value

Type: Size
See Also

Reference

Caption Class


CaptionCreatedEventArgs Class

CaptionCreatedEventArgs Class
Event parameters used for the CaptionCreated event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.WPF.FlowCaptionCreatedEventArgs

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public class CaptionCreatedEventArgs : EventArgs
Public Class CaptionCreatedEventArgs
    Inherits EventArgs
public ref class CaptionCreatedEventArgs : public EventArgs
type CaptionCreatedEventArgs =
    class
        inherit EventArgs
    end

The CaptionCreatedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | CaptionCreatedEventArgs | Constructor. Creates a new CaptionCreatedEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Caption | The caption that has just been created (read-only)
Top
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


CaptionCreatedEventArgs Constructor

CaptionCreatedEventArgs Constructor
Constructor. Creates a new CaptionCreatedEventArgs instance.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public CaptionCreatedEventArgs(
    Caption caption
)
Public Sub New (
    caption As Caption
)
public:
CaptionCreatedEventArgs(
    Caption^ caption
)
new :
        caption : Caption -> CaptionCreatedEventArgs

Parameters

caption
Type: Lassalle.WPF.FlowCaption
The created caption
See Also

Reference

CaptionCreatedEventArgs Class


CaptionCreatedEventArgs Methods

CaptionCreatedEventArgs Methods

The CaptionCreatedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
See Also

Reference

CaptionCreatedEventArgs Class


CaptionCreatedEventArgs Properties

CaptionCreatedEventArgs Properties

The CaptionCreatedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Caption | The caption that has just been created (read-only)
Top
See Also

Reference

CaptionCreatedEventArgs Class


CaptionCreatedEventArgs.Caption Property

CaptionCreatedEventArgsCaption Property
The caption that has just been created (read-only)

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Caption Caption { get; }
Public ReadOnly Property Caption As Caption
    Get
public:
property Caption^ Caption {
    Caption^ get ();
}
member Caption : Caption with get

Property Value

Type: Caption
See Also

Reference

CaptionCreatedEventArgs Class


CaptionCreatingEventArgs Class

CaptionCreatingEventArgs Class
Event parameters used for the CaptionCreating event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.WPF.FlowCaptionCreatingEventArgs

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public class CaptionCreatingEventArgs : EventArgs
Public Class CaptionCreatingEventArgs
    Inherits EventArgs
public ref class CaptionCreatingEventArgs : public EventArgs
type CaptionCreatingEventArgs =
    class
        inherit EventArgs
    end

The CaptionCreatingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | CaptionCreatingEventArgs | Constructor. Creates a new CaptionCreatingEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the caption creation should be canceled.
Public property | Rect | Returns/sets the rectangle of the caption to create
Top
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


CaptionCreatingEventArgs Constructor

CaptionCreatingEventArgs Constructor
Constructor. Creates a new CaptionCreatingEventArgs instance.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public CaptionCreatingEventArgs(
    Rect rect
)
Public Sub New (
    rect As Rect
)
public:
CaptionCreatingEventArgs(
    Rect rect
)
new :
        rect : Rect -> CaptionCreatingEventArgs

Parameters

rect
Type: System.WindowsRect
The bounding rectangle of the caption that is going to be created.
See Also

Reference

CaptionCreatingEventArgs Class


CaptionCreatingEventArgs Methods

CaptionCreatingEventArgs Methods

The CaptionCreatingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
See Also

Reference

CaptionCreatingEventArgs Class


CaptionCreatingEventArgs Properties

CaptionCreatingEventArgs Properties

The CaptionCreatingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the caption creation should be canceled.
Public property | Rect | Returns/sets the rectangle of the caption to create
Top
See Also

Reference

CaptionCreatingEventArgs Class


CaptionCreatingEventArgs.Cancel Property

CaptionCreatingEventArgsCancel Property
Gets/sets a value indicating whether the caption creation should be canceled.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public CancelEventArgs Cancel { get; set; }
Public Property Cancel As CancelEventArgs
    Get
    Set
public:
property CancelEventArgs^ Cancel {
    CancelEventArgs^ get ();
    void set (CancelEventArgs^ value);
}
member Cancel : CancelEventArgs with get, set

Property Value

Type: CancelEventArgs
See Also

Reference

CaptionCreatingEventArgs Class


CaptionCreatingEventArgs.Rect Property

CaptionCreatingEventArgsRect Property
Returns/sets the rectangle of the caption to create

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Rect Rect { get; set; }
Public Property Rect As Rect
    Get
    Set
public:
property Rect Rect {
    Rect get ();
    void set (Rect value);
}
member Rect : Rect with get, set

Property Value

Type: Rect
See Also

Reference

CaptionCreatingEventArgs Class


CaptionDeletedEventArgs Class

CaptionDeletedEventArgs Class
Event parameters used for the CaptionDeleted event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.WPF.FlowCaptionDeletedEventArgs

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public class CaptionDeletedEventArgs : EventArgs
Public Class CaptionDeletedEventArgs
    Inherits EventArgs
public ref class CaptionDeletedEventArgs : public EventArgs
type CaptionDeletedEventArgs =
    class
        inherit EventArgs
    end

The CaptionDeletedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | CaptionDeletedEventArgs | Constructor. Creates a new CaptionDeletedEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Caption | The caption that has just been removed (read-only)
Top
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


CaptionDeletedEventArgs Constructor

CaptionDeletedEventArgs Constructor
Constructor. Creates a new CaptionDeletedEventArgs instance.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public CaptionDeletedEventArgs(
    Caption caption
)
Public Sub New (
    caption As Caption
)
public:
CaptionDeletedEventArgs(
    Caption^ caption
)
new :
        caption : Caption -> CaptionDeletedEventArgs

Parameters

caption
Type: Lassalle.WPF.FlowCaption
The removed caption
See Also

Reference

CaptionDeletedEventArgs Class


CaptionDeletedEventArgs Methods

CaptionDeletedEventArgs Methods

The CaptionDeletedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
See Also

Reference

CaptionDeletedEventArgs Class


CaptionDeletedEventArgs Properties

CaptionDeletedEventArgs Properties

The CaptionDeletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Caption | The caption that has just been removed (read-only)
Top
See Also

Reference

CaptionDeletedEventArgs Class


CaptionDeletedEventArgs.Caption Property

CaptionDeletedEventArgsCaption Property
The caption that has just been removed (read-only)

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Caption Caption { get; }
Public ReadOnly Property Caption As Caption
    Get
public:
property Caption^ Caption {
    Caption^ get ();
}
member Caption : Caption with get

Property Value

Type: Caption
See Also

Reference

CaptionDeletedEventArgs Class


CaptionDeletingEventArgs Class

CaptionDeletingEventArgs Class
Event parameters used for the CaptionDeleting event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.WPF.FlowCaptionDeletingEventArgs

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public class CaptionDeletingEventArgs : EventArgs
Public Class CaptionDeletingEventArgs
    Inherits EventArgs
public ref class CaptionDeletingEventArgs : public EventArgs
type CaptionDeletingEventArgs =
    class
        inherit EventArgs
    end

The CaptionDeletingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | CaptionDeletingEventArgs | Constructor. Creates a new CaptionDeletingEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the caption removing should be canceled.
Public property | Caption | The caption to be removed (read-only)
Top
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


CaptionDeletingEventArgs Constructor

CaptionDeletingEventArgs Constructor
Constructor. Creates a new CaptionDeletingEventArgs instance.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public CaptionDeletingEventArgs(
    Caption caption
)
Public Sub New (
    caption As Caption
)
public:
CaptionDeletingEventArgs(
    Caption^ caption
)
new :
        caption : Caption -> CaptionDeletingEventArgs

Parameters

caption
Type: Lassalle.WPF.FlowCaption
The caption to be removed
See Also

Reference

CaptionDeletingEventArgs Class


CaptionDeletingEventArgs Methods

CaptionDeletingEventArgs Methods

The CaptionDeletingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
See Also

Reference

CaptionDeletingEventArgs Class


CaptionDeletingEventArgs Properties

CaptionDeletingEventArgs Properties

The CaptionDeletingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the caption removing should be canceled.
Public property | Caption | The caption to be removed (read-only)
Top
See Also

Reference

CaptionDeletingEventArgs Class


CaptionDeletingEventArgs.Cancel Property

CaptionDeletingEventArgsCancel Property
Gets/sets a value indicating whether the caption removing should be canceled.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public CancelEventArgs Cancel { get; set; }
Public Property Cancel As CancelEventArgs
    Get
    Set
public:
property CancelEventArgs^ Cancel {
    CancelEventArgs^ get ();
    void set (CancelEventArgs^ value);
}
member Cancel : CancelEventArgs with get, set

Property Value

Type: CancelEventArgs
See Also

Reference

CaptionDeletingEventArgs Class


CaptionDeletingEventArgs.Caption Property

CaptionDeletingEventArgsCaption Property
The caption to be removed (read-only)

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Caption Caption { get; }
Public ReadOnly Property Caption As Caption
    Get
public:
property Caption^ Caption {
    Caption^ get ();
}
member Caption : Caption with get

Property Value

Type: Caption
See Also

Reference

CaptionDeletingEventArgs Class


ConnectionMode Enumeration

ConnectionMode Enumeration
Used to specify how a link is connected to a node

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public enum ConnectionMode
Public Enumeration ConnectionMode
public enum class ConnectionMode
type ConnectionMode
Members
Member name | Value | Description
Center | 0 | The link is directed towards the centre of the node
Anywhere | 1 | The link last (or first) point can be placed anywhere
Pin | 2 | A pin a must be use to connect a link to the node
LinkDecision | 3 | It is the links that decide how there are connected to the node, via their IsDstAdjusted and IsOrgAdjusted properties
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


ContentItem Class

ContentItem Class
Represents an Item object that has a content which may be a string or/and an image. Nodes and captions are ContentItem objects.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
Lassalle.WPF.FlowItem
Lassalle.WPF.FlowContentItem
Lassalle.WPF.FlowCaption
Lassalle.WPF.FlowNode

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public abstract class ContentItem : Item,
    IMoveable, ISizeable, IRotatable
Public MustInherit Class ContentItem
    Inherits Item
    Implements IMoveable, ISizeable, IRotatable
public ref class ContentItem abstract : public Item,
    IMoveable, ISizeable, IRotatable
[<AbstractClassAttribute>]
type ContentItem =
    class
        inherit Item
        interface IMoveable
        interface ISizeable
        interface IRotatable
    end

The ContentItem type exposes the following members.

Constructors
 | Name | Description
Protected method | ContentItem | Initializes a new instance of the ContentItem class
Top
Methods
 | Name | Description
Public method | BeginEdit | Initiates the editing of the node label.
Public method | BringIntoView | Ensures that the item is in the viewable area of the control. If the item is not viewable, scrolls the control as necessary to bring the item into view. (Inherited from Item.)
Public method | CancelEdit | Cancels the editing of the ContentItem text.
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndEdit | Ends the editing of the node label.
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this DependencyObject has been updated. The specific dependency property that changed is reported in the event data. (Inherited from DependencyObject.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Refresh | Forces a repaint of the item. (Inherited from Item.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeImageMargin | Returns true if ImageMargin should be serialized.
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeTextMargin | Returns true if TextMargin should be serialized.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Properties
 | Name | Description
Public property | AddFlow | The addflow canvas containing this item (Inherited from Item.)
Public property | BackMode | Determines whether the background remains untouched or if the background is filled with the current background color before the text of the item. (Inherited from Item.)
Public property | Bounds | Returns the item bounding rectangle (Inherited from Item.)
Public property | Captions | Returns the collection of the captions attached to this item. (Inherited from Item.)
Public property | DashStyle | Returns/sets the DashStyle of the pen used to draw the item. (Inherited from Item.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Fill | Returns/sets the brush used to fill the item. (Inherited from Item.)
Public property | FontFamily | Gets or sets the font family to use with the item (Inherited from Item.)
Public property | FontSize | Gets or sets the font size to use with the item (Inherited from Item.)
Public property | FontStretch | Gets or sets a FontStretch property that selects a normal, condensed, or expanded font from a FontFamily (Inherited from Item.)
Public property | FontStrikethrough | Indicates whether this Font has a strikethrough TextDecoration (Inherited from Item.)
Public property | FontStyle | Gets or sets the font style to use with the item (Inherited from Item.)
Public property | FontUnderline | Indicates whether this Font is underlined (Inherited from Item.)
Public property | FontWeight | Gets or sets the font weight to use with the item (Inherited from Item.)
Public property | Foreground | Gets or sets the Brush to apply to the text of the item (Inherited from Item.)
Public property | Geometry | Returns/sets the geometry of the ContentItem object
Public property | Image | Returns/sets the image displayed in the ContentItem object.
Public property | ImageMargin | Returns/sets the size of the margins for the image of the node.
Public property | ImagePosition | Returns/sets the picture position in the node.
Public property | IsClipContent | Determines whether the content of the contentItem object is clipped or not.
Public property | IsEditable | Determines whether the text of contentItem object can be edited or not
Public property | IsEditing | Returns/sets a value indicating whether the text of the ContentItem object is currently edited
Public property | IsHitTestVisible | Determines whether the item can be hit tested. (Inherited from Item.)
Public property | IsImageSizeFitContentArea | Determines whether the image of the contentItem object is adjusted to its size.
Public property | IsRotatable | Determines whether the contentItem object can be rotated or not.
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelectable | Determines whether the item is selectable by clicking on it with the mouse or unselectable (readonly or inactive). (Inherited from Item.)
Public property | IsSelected | Returns/sets a flag indicating if the item is selected or not. (Inherited from Item.)
Public property | IsXMoveable | Determines whether the contentItem object can be horizontally moved or not.
Public property | IsXSizeable | Determines whether the contentItem object can be horizontally resized or not.
Public property | IsYMoveable | Determines whether the contentItem object can be vertically moved or not.
Public property | IsYSizeable | Determines whether the contentItem object can be vertically resized or not.
Public property | Location | Sets or returns the location of the item.
Public property | RotationAngle | Sets or returns the rotation angle of the item.
Public property | Size | Sets or returns the size of the item.
Public property | Stroke | Returns/sets the brush used to draw the item. (Inherited from Item.)
Public property | StrokeThickness | Returns/sets the pen width used to draw the item. (Inherited from Item.)
Public property | Text | Returns/sets the text associated with the item. In the case of a node, the text is displayed inside the node. It is a multiline display. The text is wrapped automatically inside the node. Linefeed and carriage return characters are allowed. (Inherited from Item.)
Public property | TextMargin | Returns/sets the size of the margins for the text of the node.
Public property | TextPosition | Returns/sets the position style of the text of the node.
Public property | TextTrimming | Returns/sets the string trimming of the text in the node.
Public property | Tooltip | Returns/sets the tooltip associated with the item. (Inherited from Item.)
Public property | Visual | The DrawingVisualobject used to display the item (Inherited from Item.)
Top
Remarks
The main purpose is to provide common methods and properties for nodes and captions. Note that it is an abstract class. You cannot use it directly but instead use objects that derive from Node or Caption classes.
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


ContentItem Constructor

ContentItem Constructor
Initializes a new instance of the ContentItem class

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
protected ContentItem()
Protected Sub New
protected:
ContentItem()
new : unit -> ContentItem
See Also

Reference

ContentItem Class


ContentItem Methods

ContentItem Methods

The ContentItem type exposes the following members.

Methods
 | Name | Description
Public method | BeginEdit | Initiates the editing of the node label.
Public method | BringIntoView | Ensures that the item is in the viewable area of the control. If the item is not viewable, scrolls the control as necessary to bring the item into view. (Inherited from Item.)
Public method | CancelEdit | Cancels the editing of the ContentItem text.
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndEdit | Ends the editing of the node label.
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this DependencyObject has been updated. The specific dependency property that changed is reported in the event data. (Inherited from DependencyObject.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Refresh | Forces a repaint of the item. (Inherited from Item.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeImageMargin | Returns true if ImageMargin should be serialized.
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeTextMargin | Returns true if TextMargin should be serialized.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ContentItem Class


ContentItem.BeginEdit Method

ContentItemBeginEdit Method
Initiates the editing of the node label.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void BeginEdit()
Public Sub BeginEdit
public:
void BeginEdit()
member BeginEdit : unit -> unit
See Also

Reference

ContentItem Class


ContentItem.CancelEdit Method

ContentItemCancelEdit Method
Cancels the editing of the ContentItem text.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void CancelEdit()
Public Sub CancelEdit
public:
void CancelEdit()
member CancelEdit : unit -> unit
See Also

Reference

ContentItem Class


ContentItem.EndEdit Method

ContentItemEndEdit Method
Ends the editing of the node label.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void EndEdit()
Public Sub EndEdit
public:
void EndEdit()
member EndEdit : unit -> unit
See Also

Reference

ContentItem Class


ContentItem.ShouldSerializeImageMargin Method

ContentItemShouldSerializeImageMargin Method
Returns true if ImageMargin should be serialized.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeImageMargin()
Public Function ShouldSerializeImageMargin As Boolean
public:
bool ShouldSerializeImageMargin()
member ShouldSerializeImageMargin : unit -> bool

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Lassalle.WPF.Flow.ContentItem.ShouldSerializeImageMargin"]

See Also

Reference

ContentItem Class


ContentItem.ShouldSerializeTextMargin Method

ContentItemShouldSerializeTextMargin Method
Returns true if TextMargin should be serialized.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeTextMargin()
Public Function ShouldSerializeTextMargin As Boolean
public:
bool ShouldSerializeTextMargin()
member ShouldSerializeTextMargin : unit -> bool

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Lassalle.WPF.Flow.ContentItem.ShouldSerializeTextMargin"]

See Also

Reference

ContentItem Class


ContentItem Properties

ContentItem Properties

The ContentItem type exposes the following members.

Properties
 | Name | Description
Public property | AddFlow | The addflow canvas containing this item (Inherited from Item.)
Public property | BackMode | Determines whether the background remains untouched or if the background is filled with the current background color before the text of the item. (Inherited from Item.)
Public property | Bounds | Returns the item bounding rectangle (Inherited from Item.)
Public property | Captions | Returns the collection of the captions attached to this item. (Inherited from Item.)
Public property | DashStyle | Returns/sets the DashStyle of the pen used to draw the item. (Inherited from Item.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Fill | Returns/sets the brush used to fill the item. (Inherited from Item.)
Public property | FontFamily | Gets or sets the font family to use with the item (Inherited from Item.)
Public property | FontSize | Gets or sets the font size to use with the item (Inherited from Item.)
Public property | FontStretch | Gets or sets a FontStretch property that selects a normal, condensed, or expanded font from a FontFamily (Inherited from Item.)
Public property | FontStrikethrough | Indicates whether this Font has a strikethrough TextDecoration (Inherited from Item.)
Public property | FontStyle | Gets or sets the font style to use with the item (Inherited from Item.)
Public property | FontUnderline | Indicates whether this Font is underlined (Inherited from Item.)
Public property | FontWeight | Gets or sets the font weight to use with the item (Inherited from Item.)
Public property | Foreground | Gets or sets the Brush to apply to the text of the item (Inherited from Item.)
Public property | Geometry | Returns/sets the geometry of the ContentItem object
Public property | Image | Returns/sets the image displayed in the ContentItem object.
Public property | ImageMargin | Returns/sets the size of the margins for the image of the node.
Public property | ImagePosition | Returns/sets the picture position in the node.
Public property | IsClipContent | Determines whether the content of the contentItem object is clipped or not.
Public property | IsEditable | Determines whether the text of contentItem object can be edited or not
Public property | IsEditing | Returns/sets a value indicating whether the text of the ContentItem object is currently edited
Public property | IsHitTestVisible | Determines whether the item can be hit tested. (Inherited from Item.)
Public property | IsImageSizeFitContentArea | Determines whether the image of the contentItem object is adjusted to its size.
Public property | IsRotatable | Determines whether the contentItem object can be rotated or not.
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelectable | Determines whether the item is selectable by clicking on it with the mouse or unselectable (readonly or inactive). (Inherited from Item.)
Public property | IsSelected | Returns/sets a flag indicating if the item is selected or not. (Inherited from Item.)
Public property | IsXMoveable | Determines whether the contentItem object can be horizontally moved or not.
Public property | IsXSizeable | Determines whether the contentItem object can be horizontally resized or not.
Public property | IsYMoveable | Determines whether the contentItem object can be vertically moved or not.
Public property | IsYSizeable | Determines whether the contentItem object can be vertically resized or not.
Public property | Location | Sets or returns the location of the item.
Public property | RotationAngle | Sets or returns the rotation angle of the item.
Public property | Size | Sets or returns the size of the item.
Public property | Stroke | Returns/sets the brush used to draw the item. (Inherited from Item.)
Public property | StrokeThickness | Returns/sets the pen width used to draw the item. (Inherited from Item.)
Public property | Text | Returns/sets the text associated with the item. In the case of a node, the text is displayed inside the node. It is a multiline display. The text is wrapped automatically inside the node. Linefeed and carriage return characters are allowed. (Inherited from Item.)
Public property | TextMargin | Returns/sets the size of the margins for the text of the node.
Public property | TextPosition | Returns/sets the position style of the text of the node.
Public property | TextTrimming | Returns/sets the string trimming of the text in the node.
Public property | Tooltip | Returns/sets the tooltip associated with the item. (Inherited from Item.)
Public property | Visual | The DrawingVisualobject used to display the item (Inherited from Item.)
Top
See Also

Reference

ContentItem Class


ContentItem.Geometry Property

ContentItemGeometry Property
Returns/sets the geometry of the ContentItem object

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Geometry Geometry { get; set; }
Public Property Geometry As Geometry
    Get
    Set
public:
property Geometry^ Geometry {
    Geometry^ get ();
    void set (Geometry^ value);
}
member Geometry : Geometry with get, set

Property Value

Type: Geometry
See Also

Reference

ContentItem Class


ContentItem.Image Property

ContentItemImage Property
Returns/sets the image displayed in the ContentItem object.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public ImageSource Image { get; set; }
Public Property Image As ImageSource
    Get
    Set
public:
property ImageSource^ Image {
    ImageSource^ get ();
    void set (ImageSource^ value);
}
member Image : ImageSource with get, set

Property Value

Type: ImageSource
See Also

Reference

ContentItem Class


ContentItem.ImageMargin Property

ContentItemImageMargin Property
Returns/sets the size of the margins for the image of the node.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Thickness ImageMargin { get; set; }
Public Property ImageMargin As Thickness
    Get
    Set
public:
property Thickness ImageMargin {
    Thickness get ();
    void set (Thickness value);
}
member ImageMargin : Thickness with get, set

Property Value

Type: Thickness
See Also

Reference

ContentItem Class


ContentItem.ImagePosition Property

ContentItemImagePosition Property
Returns/sets the picture position in the node.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public ImagePosition ImagePosition { get; set; }
Public Property ImagePosition As ImagePosition
    Get
    Set
public:
property ImagePosition ImagePosition {
    ImagePosition get ();
    void set (ImagePosition value);
}
member ImagePosition : ImagePosition with get, set

Property Value

Type: ImagePosition
See Also

Reference

ContentItem Class


ContentItem.IsClipContent Property

ContentItemIsClipContent Property
Determines whether the content of the contentItem object is clipped or not.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool IsClipContent { get; set; }
Public Property IsClipContent As Boolean
    Get
    Set
public:
property bool IsClipContent {
    bool get ();
    void set (bool value);
}
member IsClipContent : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ContentItem Class


ContentItem.IsEditable Property

ContentItemIsEditable Property
Determines whether the text of contentItem object can be edited or not

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool IsEditable { get; set; }
Public Property IsEditable As Boolean
    Get
    Set
public:
property bool IsEditable {
    bool get ();
    void set (bool value);
}
member IsEditable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ContentItem Class


ContentItem.IsEditing Property

ContentItemIsEditing Property
Returns/sets a value indicating whether the text of the ContentItem object is currently edited

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool IsEditing { get; set; }
Public Property IsEditing As Boolean
    Get
    Set
public:
property bool IsEditing {
    bool get ();
    void set (bool value);
}
member IsEditing : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ContentItem Class


ContentItem.IsImageSizeFitContentArea Property

ContentItemIsImageSizeFitContentArea Property
Determines whether the image of the contentItem object is adjusted to its size.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool IsImageSizeFitContentArea { get; set; }
Public Property IsImageSizeFitContentArea As Boolean
    Get
    Set
public:
property bool IsImageSizeFitContentArea {
    bool get ();
    void set (bool value);
}
member IsImageSizeFitContentArea : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ContentItem Class


ContentItem.IsRotatable Property

ContentItemIsRotatable Property
Determines whether the contentItem object can be rotated or not.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool IsRotatable { get; set; }
Public Property IsRotatable As Boolean
    Get
    Set
public:
virtual property bool IsRotatable {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IsRotatable : bool with get, set
override IsRotatable : bool with get, set

Property Value

Type: Boolean

Implements

IRotatableIsRotatable
See Also

Reference

ContentItem Class


ContentItem.IsXMoveable Property

ContentItemIsXMoveable Property
Determines whether the contentItem object can be horizontally moved or not.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool IsXMoveable { get; set; }
Public Property IsXMoveable As Boolean
    Get
    Set
public:
virtual property bool IsXMoveable {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IsXMoveable : bool with get, set
override IsXMoveable : bool with get, set

Property Value

Type: Boolean

Implements

IMoveableIsXMoveable
See Also

Reference

ContentItem Class


ContentItem.IsXSizeable Property

ContentItemIsXSizeable Property
Determines whether the contentItem object can be horizontally resized or not.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool IsXSizeable { get; set; }
Public Property IsXSizeable As Boolean
    Get
    Set
public:
virtual property bool IsXSizeable {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IsXSizeable : bool with get, set
override IsXSizeable : bool with get, set

Property Value

Type: Boolean

Implements

ISizeableIsXSizeable
See Also

Reference

ContentItem Class


ContentItem.IsYMoveable Property

ContentItemIsYMoveable Property
Determines whether the contentItem object can be vertically moved or not.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool IsYMoveable { get; set; }
Public Property IsYMoveable As Boolean
    Get
    Set
public:
virtual property bool IsYMoveable {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IsYMoveable : bool with get, set
override IsYMoveable : bool with get, set

Property Value

Type: Boolean

Implements

IMoveableIsYMoveable
See Also

Reference

ContentItem Class


ContentItem.IsYSizeable Property

ContentItemIsYSizeable Property
Determines whether the contentItem object can be vertically resized or not.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool IsYSizeable { get; set; }
Public Property IsYSizeable As Boolean
    Get
    Set
public:
virtual property bool IsYSizeable {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IsYSizeable : bool with get, set
override IsYSizeable : bool with get, set

Property Value

Type: Boolean

Implements

ISizeableIsYSizeable
See Also

Reference

ContentItem Class


ContentItem.Location Property

ContentItemLocation Property
Sets or returns the location of the item.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public abstract Point Location { get; set; }
Public MustOverride Property Location As Point
    Get
    Set
public:
virtual property Point Location {
    Point get () abstract;
    void set (Point value) abstract;
}
abstract Location : Point with get, set

Property Value

Type: Point
See Also

Reference

ContentItem Class


ContentItem.RotationAngle Property

ContentItemRotationAngle Property
Sets or returns the rotation angle of the item.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public abstract double RotationAngle { get; set; }
Public MustOverride Property RotationAngle As Double
    Get
    Set
public:
virtual property double RotationAngle {
    double get () abstract;
    void set (double value) abstract;
}
abstract RotationAngle : float with get, set

Property Value

Type: Double

Implements

IRotatableRotationAngle
See Also

Reference

ContentItem Class


ContentItem.Size Property

ContentItemSize Property
Sets or returns the size of the item.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public abstract Size Size { get; set; }
Public MustOverride Property Size As Size
    Get
    Set
public:
virtual property Size Size {
    Size get () abstract;
    void set (Size value) abstract;
}
abstract Size : Size with get, set

Property Value

Type: Size
See Also

Reference

ContentItem Class


ContentItem.TextMargin Property

ContentItemTextMargin Property
Returns/sets the size of the margins for the text of the node.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Thickness TextMargin { get; set; }
Public Property TextMargin As Thickness
    Get
    Set
public:
property Thickness TextMargin {
    Thickness get ();
    void set (Thickness value);
}
member TextMargin : Thickness with get, set

Property Value

Type: Thickness
See Also

Reference

ContentItem Class


ContentItem.TextPosition Property

ContentItemTextPosition Property
Returns/sets the position style of the text of the node.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public TextPosition TextPosition { get; set; }
Public Property TextPosition As TextPosition
    Get
    Set
public:
property TextPosition TextPosition {
    TextPosition get ();
    void set (TextPosition value);
}
member TextPosition : TextPosition with get, set

Property Value

Type: TextPosition
See Also

Reference

ContentItem Class


ContentItem.TextTrimming Property

ContentItemTextTrimming Property
Returns/sets the string trimming of the text in the node.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public TextTrimming TextTrimming { get; set; }
Public Property TextTrimming As TextTrimming
    Get
    Set
public:
property TextTrimming TextTrimming {
    TextTrimming get ();
    void set (TextTrimming value);
}
member TextTrimming : TextTrimming with get, set

Property Value

Type: TextTrimming
See Also

Reference

ContentItem Class


DockStyle Enumeration

DockStyle Enumeration
Used to specify the caption dock style.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public enum DockStyle
Public Enumeration DockStyle
public enum class DockStyle
type DockStyle
Members
Member name | Value | Description
None | 0 | The caption is not docked
Top | 1 | The caption's top edge is docked to the top of its containing item.
Bottom | 2 | The caption's bottom edge is docked to the bottom of its containing item.
Left | 3 | The caption's left edge is docked to the left of its containing item.
Right | 4 | The caption's right edge is docked to the right of its containing item.
Fill | 5 | All the caption's edges are docked to the all edges of its containing item and sized appropriately
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


DstChangedEventArgs Class

DstChangedEventArgs Class
Event parameters used for the DstChanged event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.WPF.FlowDstChangedEventArgs

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public class DstChangedEventArgs : EventArgs
Public Class DstChangedEventArgs
    Inherits EventArgs
public ref class DstChangedEventArgs : public EventArgs
type DstChangedEventArgs =
    class
        inherit EventArgs
    end

The DstChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | DstChangedEventArgs | Constructor. Creates a new DstChangedEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the change of the destination node of the link should be canceled.
Public property | Link | The link whose destination node is changed (read-only)
Public property | OldDst | The old destination node (read-only)
Top
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


DstChangedEventArgs Constructor

DstChangedEventArgs Constructor
Constructor. Creates a new DstChangedEventArgs instance.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public DstChangedEventArgs(
    Link link,
    Node oldDst
)
Public Sub New (
    link As Link,
    oldDst As Node
)
public:
DstChangedEventArgs(
    Link^ link,
    Node^ oldDst
)
new :
        link : Link *
        oldDst : Node -> DstChangedEventArgs

Parameters

link
Type: Lassalle.WPF.FlowLink
The created link
oldDst
Type: Lassalle.WPF.FlowNode
The old destination node
See Also

Reference

DstChangedEventArgs Class


DstChangedEventArgs Methods

DstChangedEventArgs Methods

The DstChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
See Also

Reference

DstChangedEventArgs Class


DstChangedEventArgs Properties

DstChangedEventArgs Properties

The DstChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the change of the destination node of the link should be canceled.
Public property | Link | The link whose destination node is changed (read-only)
Public property | OldDst | The old destination node (read-only)
Top
See Also

Reference

DstChangedEventArgs Class


DstChangedEventArgs.Cancel Property

DstChangedEventArgsCancel Property
Gets/sets a value indicating whether the change of the destination node of the link should be canceled.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public CancelEventArgs Cancel { get; set; }
Public Property Cancel As CancelEventArgs
    Get
    Set
public:
property CancelEventArgs^ Cancel {
    CancelEventArgs^ get ();
    void set (CancelEventArgs^ value);
}
member Cancel : CancelEventArgs with get, set

Property Value

Type: CancelEventArgs
See Also

Reference

DstChangedEventArgs Class


DstChangedEventArgs.Link Property

DstChangedEventArgsLink Property
The link whose destination node is changed (read-only)

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Link Link { get; }
Public ReadOnly Property Link As Link
    Get
public:
property Link^ Link {
    Link^ get ();
}
member Link : Link with get

Property Value

Type: Link
See Also

Reference

DstChangedEventArgs Class


DstChangedEventArgs.OldDst Property

DstChangedEventArgsOldDst Property
The old destination node (read-only)

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Node OldDst { get; }
Public ReadOnly Property OldDst As Node
    Get
public:
property Node^ OldDst {
    Node^ get ();
}
member OldDst : Node with get

Property Value

Type: Node
See Also

Reference

DstChangedEventArgs Class


DstChangingEventArgs Class

DstChangingEventArgs Class
Event parameters used for the DstChanging event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.WPF.FlowDstChangingEventArgs

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public class DstChangingEventArgs : EventArgs
Public Class DstChangingEventArgs
    Inherits EventArgs
public ref class DstChangingEventArgs : public EventArgs
type DstChangingEventArgs =
    class
        inherit EventArgs
    end

The DstChangingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | DstChangingEventArgs | Constructor. Creates a new DstChangingEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the change of the destination node of the link should be canceled.
Public property | Dst | The new destination node (read-only)
Public property | Link | The link whose destination node is changed (read-only)
Top
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


DstChangingEventArgs Constructor

DstChangingEventArgs Constructor
Constructor. Creates a new DstChangingEventArgs instance.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public DstChangingEventArgs(
    Link link,
    Node dst
)
Public Sub New (
    link As Link,
    dst As Node
)
public:
DstChangingEventArgs(
    Link^ link,
    Node^ dst
)
new :
        link : Link *
        dst : Node -> DstChangingEventArgs

Parameters

link
Type: Lassalle.WPF.FlowLink
The created link
dst
Type: Lassalle.WPF.FlowNode
The new destination node
See Also

Reference

DstChangingEventArgs Class


DstChangingEventArgs Methods

DstChangingEventArgs Methods

The DstChangingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
See Also

Reference

DstChangingEventArgs Class


DstChangingEventArgs Properties

DstChangingEventArgs Properties

The DstChangingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the change of the destination node of the link should be canceled.
Public property | Dst | The new destination node (read-only)
Public property | Link | The link whose destination node is changed (read-only)
Top
See Also

Reference

DstChangingEventArgs Class


DstChangingEventArgs.Cancel Property

DstChangingEventArgsCancel Property
Gets/sets a value indicating whether the change of the destination node of the link should be canceled.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public CancelEventArgs Cancel { get; set; }
Public Property Cancel As CancelEventArgs
    Get
    Set
public:
property CancelEventArgs^ Cancel {
    CancelEventArgs^ get ();
    void set (CancelEventArgs^ value);
}
member Cancel : CancelEventArgs with get, set

Property Value

Type: CancelEventArgs
See Also

Reference

DstChangingEventArgs Class


DstChangingEventArgs.Dst Property

DstChangingEventArgsDst Property
The new destination node (read-only)

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Node Dst { get; }
Public ReadOnly Property Dst As Node
    Get
public:
property Node^ Dst {
    Node^ get ();
}
member Dst : Node with get

Property Value

Type: Node
See Also

Reference

DstChangingEventArgs Class


DstChangingEventArgs.Link Property

DstChangingEventArgsLink Property
The link whose destination node is changed (read-only)

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Link Link { get; }
Public ReadOnly Property Link As Link
    Get
public:
property Link^ Link {
    Link^ get ();
}
member Link : Link with get

Property Value

Type: Link
See Also

Reference

DstChangingEventArgs Class


ErrorEventArgs Class

ErrorEventArgs Class
Event parameters used for the Error event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.WPF.FlowErrorEventArgs

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public class ErrorEventArgs : EventArgs
Public Class ErrorEventArgs
    Inherits EventArgs
public ref class ErrorEventArgs : public EventArgs
type ErrorEventArgs =
    class
        inherit EventArgs
    end

The ErrorEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ErrorEventArgs | Constructor. Creates a new ErrorEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ErrorEventType | The type of the error event (read-only)
Top
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


ErrorEventArgs Constructor

ErrorEventArgs Constructor
Constructor. Creates a new ErrorEventArgs instance.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public ErrorEventArgs(
    ErrorEventType errorEventType
)
Public Sub New (
    errorEventType As ErrorEventType
)
public:
ErrorEventArgs(
    ErrorEventType errorEventType
)
new :
        errorEventType : ErrorEventType -> ErrorEventArgs

Parameters

errorEventType
Type: Lassalle.WPF.FlowErrorEventType
The type of the error event
See Also

Reference

ErrorEventArgs Class


ErrorEventArgs Methods

ErrorEventArgs Methods

The ErrorEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
See Also

Reference

ErrorEventArgs Class


ErrorEventArgs Properties

ErrorEventArgs Properties

The ErrorEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ErrorEventType | The type of the error event (read-only)
Top
See Also

Reference

ErrorEventArgs Class


ErrorEventArgs.ErrorEventType Property

ErrorEventArgsErrorEventType Property
The type of the error event (read-only)

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public ErrorEventType ErrorEventType { get; }
Public ReadOnly Property ErrorEventType As ErrorEventType
    Get
public:
property ErrorEventType ErrorEventType {
    ErrorEventType get ();
}
member ErrorEventType : ErrorEventType with get

Property Value

Type: ErrorEventType
See Also

Reference

ErrorEventArgs Class


ErrorEventType Enumeration

ErrorEventType Enumeration
Used to specify the type of the Error event

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public enum ErrorEventType
Public Enumeration ErrorEventType
public enum class ErrorEventType
type ErrorEventType
Members
Member name | Value | Description
MultilinkError | 0 | Multiple links between 2 nodes are not accepted.
ReflexiveError | 1 | Reflexive links are not accepted.
IncomingLinkError | 2 | This node does not accept incoming links.
OutgoingLinkError | 3 | This node does not accept outgoing links.
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


GridStyle Enumeration

GridStyle Enumeration
Used to specify the drawing style of the grid.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public enum GridStyle
Public Enumeration GridStyle
public enum class GridStyle
type GridStyle
Members
Member name | Value | Description
Pixels | 0 | Draws a grid of one-pixel dots
Lines | 1 | Draws a grid of lines
DottedLines | 2 | Draws a grid of dotted lines
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


ImagePosition Enumeration

ImagePosition Enumeration
Used to specify the position of the image in the node.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public enum ImagePosition
Public Enumeration ImagePosition
public enum class ImagePosition
type ImagePosition
Members
Member name | Value | Description
LeftTop | 0 | Picture at the left top position of the node
LeftMiddle | 1 | Picture at the left middle position of the node
LeftBottom | 2 | Picture at the left bottom position of the node
RightTop | 3 | Picture at the right top position of the node
RightMiddle | 4 | Picture at the right middle position of the node
RightBottom | 5 | Picture at the right bottom position of the node
CenterTop | 6 | Picture at the center top position of the node
CenterMiddle | 7 | Picture at the center middle position of the node
CenterBottom | 8 | Picture at the center bottom position of the node
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


IMoveable Interface

IMoveable Interface
Common interface for items (nodes, captions) that can be moved

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public interface IMoveable
Public Interface IMoveable
public interface class IMoveable
type IMoveable =  interface end

The IMoveable type exposes the following members.

Properties
 | Name | Description
Public property | IsXMoveable | Determines whether the item can be horizontally moved or not.
Public property | IsYMoveable | Determines whether the item can be vertically moved or not.
Top
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


IMoveable Properties

IMoveable Properties

The IMoveable type exposes the following members.

Properties
 | Name | Description
Public property | IsXMoveable | Determines whether the item can be horizontally moved or not.
Public property | IsYMoveable | Determines whether the item can be vertically moved or not.
Top
See Also

Reference

IMoveable Interface


IMoveable.IsXMoveable Property

IMoveableIsXMoveable Property
Determines whether the item can be horizontally moved or not.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
bool IsXMoveable { get; set; }
Property IsXMoveable As Boolean
    Get
    Set
property bool IsXMoveable {
    bool get ();
    void set (bool value);
}
abstract IsXMoveable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMoveable Interface


IMoveable.IsYMoveable Property

IMoveableIsYMoveable Property
Determines whether the item can be vertically moved or not.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
bool IsYMoveable { get; set; }
Property IsYMoveable As Boolean
    Get
    Set
property bool IsYMoveable {
    bool get ();
    void set (bool value);
}
abstract IsYMoveable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMoveable Interface


IRotatable Interface

IRotatable Interface
Common interface for items that can be rotated (nodes, captions)

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public interface IRotatable
Public Interface IRotatable
public interface class IRotatable
type IRotatable =  interface end

The IRotatable type exposes the following members.

Properties
 | Name | Description
Public property | IsRotatable | Determines whether the item can be rotated or not.
Public property | RotationAngle | Returns/sets the rotation angle of the item.
Top
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


IRotatable Properties

IRotatable Properties

The IRotatable type exposes the following members.

Properties
 | Name | Description
Public property | IsRotatable | Determines whether the item can be rotated or not.
Public property | RotationAngle | Returns/sets the rotation angle of the item.
Top
See Also

Reference

IRotatable Interface


IRotatable.IsRotatable Property

IRotatableIsRotatable Property
Determines whether the item can be rotated or not.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
bool IsRotatable { get; set; }
Property IsRotatable As Boolean
    Get
    Set
property bool IsRotatable {
    bool get ();
    void set (bool value);
}
abstract IsRotatable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IRotatable Interface


IRotatable.RotationAngle Property

IRotatableRotationAngle Property
Returns/sets the rotation angle of the item.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
double RotationAngle { get; set; }
Property RotationAngle As Double
    Get
    Set
property double RotationAngle {
    double get ();
    void set (double value);
}
abstract RotationAngle : float with get, set

Property Value

Type: Double
See Also

Reference

IRotatable Interface


ISelectable Interface

ISelectable Interface
Common interface for items (nodes, links, captions) that can be selected.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public interface ISelectable
Public Interface ISelectable
public interface class ISelectable
type ISelectable =  interface end

The ISelectable type exposes the following members.

Properties
 | Name | Description
Public property | IsSelectable | Determines if an item is selectable or not.
Public property | IsSelected | Determines if an item is selected or not.
Top
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


ISelectable Properties

ISelectable Properties

The ISelectable type exposes the following members.

Properties
 | Name | Description
Public property | IsSelectable | Determines if an item is selectable or not.
Public property | IsSelected | Determines if an item is selected or not.
Top
See Also

Reference

ISelectable Interface


ISelectable.IsSelectable Property

ISelectableIsSelectable Property
Determines if an item is selectable or not.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
bool IsSelectable { get; set; }
Property IsSelectable As Boolean
    Get
    Set
property bool IsSelectable {
    bool get ();
    void set (bool value);
}
abstract IsSelectable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ISelectable Interface


ISelectable.IsSelected Property

ISelectableIsSelected Property
Determines if an item is selected or not.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
bool IsSelected { get; set; }
Property IsSelected As Boolean
    Get
    Set
property bool IsSelected {
    bool get ();
    void set (bool value);
}
abstract IsSelected : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ISelectable Interface


ISizeable Interface

ISizeable Interface
Common interface for items (nodes, captions) that can be resized

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public interface ISizeable
Public Interface ISizeable
public interface class ISizeable
type ISizeable =  interface end

The ISizeable type exposes the following members.

Properties
 | Name | Description
Public property | IsXSizeable | Determines whether the item can be horizontally resized or not.
Public property | IsYSizeable | Determines whether the item can be vertically resized or not.
Top
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


ISizeable Properties

ISizeable Properties

The ISizeable type exposes the following members.

Properties
 | Name | Description
Public property | IsXSizeable | Determines whether the item can be horizontally resized or not.
Public property | IsYSizeable | Determines whether the item can be vertically resized or not.
Top
See Also

Reference

ISizeable Interface


ISizeable.IsXSizeable Property

ISizeableIsXSizeable Property
Determines whether the item can be horizontally resized or not.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
bool IsXSizeable { get; set; }
Property IsXSizeable As Boolean
    Get
    Set
property bool IsXSizeable {
    bool get ();
    void set (bool value);
}
abstract IsXSizeable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ISizeable Interface


ISizeable.IsYSizeable Property

ISizeableIsYSizeable Property
Determines whether the item can be vertically resized or not.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
bool IsYSizeable { get; set; }
Property IsYSizeable As Boolean
    Get
    Set
property bool IsYSizeable {
    bool get ();
    void set (bool value);
}
abstract IsYSizeable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ISizeable Interface


Item Class

Item Class
Represents an object in the diagram. This is an abstract class.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
Lassalle.WPF.FlowItem
Lassalle.WPF.FlowContentItem
Lassalle.WPF.FlowLink

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public abstract class Item : DependencyObject,
    ISelectable
Public MustInherit Class Item
    Inherits DependencyObject
    Implements ISelectable
public ref class Item abstract : public DependencyObject,
    ISelectable
[<AbstractClassAttribute>]
type Item =
    class
        inherit DependencyObject
        interface ISelectable
    end

The Item type exposes the following members.

Methods
 | Name | Description
Public method | BringIntoView | Ensures that the item is in the viewable area of the control. If the item is not viewable, scrolls the control as necessary to bring the item into view.
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this DependencyObject has been updated. The specific dependency property that changed is reported in the event data. (Inherited from DependencyObject.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Refresh | Forces a repaint of the item.
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
FontFamilyProperty | Identifies the FontFamily dependency property.
FontSizeProperty | Identifies the FontSize dependency property.
FontStretchProperty | Identifies the FontStretch dependency property.
FontStrikethroughProperty | Identifies the FontStrikethrough dependency property.
FontStyleProperty | Identifies the FontStyle dependency property.
FontUnderlineProperty | Identifies the FontUnderline dependency property.
FontWeightProperty | Identifies the FontWeight dependency property.
ForegroundProperty | Identifies the Foreground dependency property.
Top
Properties
 | Name | Description
Public property | AddFlow | The addflow canvas containing this item
Public property | BackMode | Determines whether the background remains untouched or if the background is filled with the current background color before the text of the item.
Public property | Bounds | Returns the item bounding rectangle
Public property | Captions | Returns the collection of the captions attached to this item.
Public property | DashStyle | Returns/sets the DashStyle of the pen used to draw the item.
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Fill | Returns/sets the brush used to fill the item.
Public property | FontFamily | Gets or sets the font family to use with the item
Public property | FontSize | Gets or sets the font size to use with the item
Public property | FontStretch | Gets or sets a FontStretch property that selects a normal, condensed, or expanded font from a FontFamily
Public property | FontStrikethrough | Indicates whether this Font has a strikethrough TextDecoration
Public property | FontStyle | Gets or sets the font style to use with the item
Public property | FontUnderline | Indicates whether this Font is underlined
Public property | FontWeight | Gets or sets the font weight to use with the item
Public property | Foreground | Gets or sets the Brush to apply to the text of the item
Public property | IsHitTestVisible | Determines whether the item can be hit tested.
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelectable | Determines whether the item is selectable by clicking on it with the mouse or unselectable (readonly or inactive).
Public property | IsSelected | Returns/sets a flag indicating if the item is selected or not.
Public property | Stroke | Returns/sets the brush used to draw the item.
Public property | StrokeThickness | Returns/sets the pen width used to draw the item.
Public property | Text | Returns/sets the text associated with the item. In the case of a node, the text is displayed inside the node. It is a multiline display. The text is wrapped automatically inside the node. Linefeed and carriage return characters are allowed.
Public property | Tooltip | Returns/sets the tooltip associated with the item.
Public property | Visual | The DrawingVisualobject used to display the item
Top
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


Item Fields

Item Fields

The Item type exposes the following members.

Fields
Name | Description
FontFamilyProperty | Identifies the FontFamily dependency property.
FontSizeProperty | Identifies the FontSize dependency property.
FontStretchProperty | Identifies the FontStretch dependency property.
FontStrikethroughProperty | Identifies the FontStrikethrough dependency property.
FontStyleProperty | Identifies the FontStyle dependency property.
FontUnderlineProperty | Identifies the FontUnderline dependency property.
FontWeightProperty | Identifies the FontWeight dependency property.
ForegroundProperty | Identifies the Foreground dependency property.
Top
See Also

Reference

Item Class


Item.FontFamilyProperty Field

ItemFontFamilyProperty Field
Identifies the FontFamily dependency property.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty FontFamilyProperty
Public Shared ReadOnly FontFamilyProperty As DependencyProperty
public:
static initonly DependencyProperty^ FontFamilyProperty
static val FontFamilyProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

Item Class


Item.FontSizeProperty Field

ItemFontSizeProperty Field
Identifies the FontSize dependency property.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty FontSizeProperty
Public Shared ReadOnly FontSizeProperty As DependencyProperty
public:
static initonly DependencyProperty^ FontSizeProperty
static val FontSizeProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

Item Class


Item.FontStretchProperty Field

ItemFontStretchProperty Field
Identifies the FontStretch dependency property.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty FontStretchProperty
Public Shared ReadOnly FontStretchProperty As DependencyProperty
public:
static initonly DependencyProperty^ FontStretchProperty
static val FontStretchProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

Item Class


Item.FontStrikethroughProperty Field

ItemFontStrikethroughProperty Field
Identifies the FontStrikethrough dependency property.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty FontStrikethroughProperty
Public Shared ReadOnly FontStrikethroughProperty As DependencyProperty
public:
static initonly DependencyProperty^ FontStrikethroughProperty
static val FontStrikethroughProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

Item Class


Item.FontStyleProperty Field

ItemFontStyleProperty Field
Identifies the FontStyle dependency property.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty FontStyleProperty
Public Shared ReadOnly FontStyleProperty As DependencyProperty
public:
static initonly DependencyProperty^ FontStyleProperty
static val FontStyleProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

Item Class


Item.FontUnderlineProperty Field

ItemFontUnderlineProperty Field
Identifies the FontUnderline dependency property.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty FontUnderlineProperty
Public Shared ReadOnly FontUnderlineProperty As DependencyProperty
public:
static initonly DependencyProperty^ FontUnderlineProperty
static val FontUnderlineProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

Item Class


Item.FontWeightProperty Field

ItemFontWeightProperty Field
Identifies the FontWeight dependency property.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty FontWeightProperty
Public Shared ReadOnly FontWeightProperty As DependencyProperty
public:
static initonly DependencyProperty^ FontWeightProperty
static val FontWeightProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

Item Class


Item.ForegroundProperty Field

ItemForegroundProperty Field
Identifies the Foreground dependency property.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty ForegroundProperty
Public Shared ReadOnly ForegroundProperty As DependencyProperty
public:
static initonly DependencyProperty^ ForegroundProperty
static val ForegroundProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

Item Class


Item Methods

Item Methods

The Item type exposes the following members.

Methods
 | Name | Description
Public method | BringIntoView | Ensures that the item is in the viewable area of the control. If the item is not viewable, scrolls the control as necessary to bring the item into view.
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this DependencyObject has been updated. The specific dependency property that changed is reported in the event data. (Inherited from DependencyObject.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Refresh | Forces a repaint of the item.
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

Item Class


Item.BringIntoView Method

ItemBringIntoView Method
Ensures that the item is in the viewable area of the control. If the item is not viewable, scrolls the control as necessary to bring the item into view.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void BringIntoView()
Public Sub BringIntoView
public:
void BringIntoView()
member BringIntoView : unit -> unit
Remarks
This method will work the same way if the item is hidden.
See Also

Reference

Item Class


Item.Refresh Method

ItemRefresh Method
Forces a repaint of the item.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void Refresh()
Public Sub Refresh
public:
void Refresh()
member Refresh : unit -> unit
See Also

Reference

Item Class


Item Properties

Item Properties

The Item type exposes the following members.

Properties
 | Name | Description
Public property | AddFlow | The addflow canvas containing this item
Public property | BackMode | Determines whether the background remains untouched or if the background is filled with the current background color before the text of the item.
Public property | Bounds | Returns the item bounding rectangle
Public property | Captions | Returns the collection of the captions attached to this item.
Public property | DashStyle | Returns/sets the DashStyle of the pen used to draw the item.
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Fill | Returns/sets the brush used to fill the item.
Public property | FontFamily | Gets or sets the font family to use with the item
Public property | FontSize | Gets or sets the font size to use with the item
Public property | FontStretch | Gets or sets a FontStretch property that selects a normal, condensed, or expanded font from a FontFamily
Public property | FontStrikethrough | Indicates whether this Font has a strikethrough TextDecoration
Public property | FontStyle | Gets or sets the font style to use with the item
Public property | FontUnderline | Indicates whether this Font is underlined
Public property | FontWeight | Gets or sets the font weight to use with the item
Public property | Foreground | Gets or sets the Brush to apply to the text of the item
Public property | IsHitTestVisible | Determines whether the item can be hit tested.
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelectable | Determines whether the item is selectable by clicking on it with the mouse or unselectable (readonly or inactive).
Public property | IsSelected | Returns/sets a flag indicating if the item is selected or not.
Public property | Stroke | Returns/sets the brush used to draw the item.
Public property | StrokeThickness | Returns/sets the pen width used to draw the item.
Public property | Text | Returns/sets the text associated with the item. In the case of a node, the text is displayed inside the node. It is a multiline display. The text is wrapped automatically inside the node. Linefeed and carriage return characters are allowed.
Public property | Tooltip | Returns/sets the tooltip associated with the item.
Public property | Visual | The DrawingVisualobject used to display the item
Top
See Also

Reference

Item Class


Item.AddFlow Property

ItemAddFlow Property
The addflow canvas containing this item

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public AddFlow AddFlow { get; }
Public ReadOnly Property AddFlow As AddFlow
    Get
public:
property AddFlow^ AddFlow {
    AddFlow^ get ();
}
member AddFlow : AddFlow with get

Property Value

Type: AddFlow
See Also

Reference

Item Class


Item.BackMode Property

ItemBackMode Property
Determines whether the background remains untouched or if the background is filled with the current background color before the text of the item.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public BackMode BackMode { get; set; }
Public Property BackMode As BackMode
    Get
    Set
public:
property BackMode BackMode {
    BackMode get ();
    void set (BackMode value);
}
member BackMode : BackMode with get, set

Property Value

Type: BackMode
See Also

Reference

Item Class


Item.Bounds Property

ItemBounds Property
Returns the item bounding rectangle

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Rect Bounds { get; }
Public ReadOnly Property Bounds As Rect
    Get
public:
property Rect Bounds {
    Rect get ();
}
member Bounds : Rect with get

Property Value

Type: Rect
See Also

Reference

Item Class


Item.Captions Property

ItemCaptions Property
Returns the collection of the captions attached to this item.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public List<Caption> Captions { get; }
Public ReadOnly Property Captions As List(Of Caption)
    Get
public:
property List<Caption^>^ Captions {
    List<Caption^>^ get ();
}
member Captions : List<Caption> with get

Property Value

Type: List Caption
Remarks
Don't use this property which is only provided for the AddFlow infrastructure. To manipulate the collection of captions of an AddFlow item, you should use the Owner property of captions. You may however use this property for enumeration purposes.
See Also

Reference

Item Class


Item.DashStyle Property

ItemDashStyle Property
Returns/sets the DashStyle of the pen used to draw the item.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public DashStyle DashStyle { get; set; }
Public Property DashStyle As DashStyle
    Get
    Set
public:
property DashStyle^ DashStyle {
    DashStyle^ get ();
    void set (DashStyle^ value);
}
member DashStyle : DashStyle with get, set

Property Value

Type: DashStyle
See Also

Reference

Item Class


Item.Fill Property

ItemFill Property
Returns/sets the brush used to fill the item.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Brush Fill { get; set; }
Public Property Fill As Brush
    Get
    Set
public:
property Brush^ Fill {
    Brush^ get ();
    void set (Brush^ value);
}
member Fill : Brush with get, set

Property Value

Type: Brush
See Also

Reference

Item Class


Item.FontFamily Property

ItemFontFamily Property
Gets or sets the font family to use with the item

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public FontFamily FontFamily { get; set; }
Public Property FontFamily As FontFamily
    Get
    Set
public:
property FontFamily^ FontFamily {
    FontFamily^ get ();
    void set (FontFamily^ value);
}
member FontFamily : FontFamily with get, set

Property Value

Type: FontFamily
See Also

Reference

Item Class


Item.FontSize Property

ItemFontSize Property
Gets or sets the font size to use with the item

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public double FontSize { get; set; }
Public Property FontSize As Double
    Get
    Set
public:
property double FontSize {
    double get ();
    void set (double value);
}
member FontSize : float with get, set

Property Value

Type: Double
See Also

Reference

Item Class


Item.FontStretch Property

ItemFontStretch Property
Gets or sets a FontStretch property that selects a normal, condensed, or expanded font from a FontFamily

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public FontStretch FontStretch { get; set; }
Public Property FontStretch As FontStretch
    Get
    Set
public:
property FontStretch FontStretch {
    FontStretch get ();
    void set (FontStretch value);
}
member FontStretch : FontStretch with get, set

Property Value

Type: FontStretch
See Also

Reference

Item Class


Item.FontStrikethrough Property

ItemFontStrikethrough Property
Indicates whether this Font has a strikethrough TextDecoration

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool FontStrikethrough { get; set; }
Public Property FontStrikethrough As Boolean
    Get
    Set
public:
property bool FontStrikethrough {
    bool get ();
    void set (bool value);
}
member FontStrikethrough : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Item Class


Item.FontStyle Property

ItemFontStyle Property
Gets or sets the font style to use with the item

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public FontStyle FontStyle { get; set; }
Public Property FontStyle As FontStyle
    Get
    Set
public:
property FontStyle FontStyle {
    FontStyle get ();
    void set (FontStyle value);
}
member FontStyle : FontStyle with get, set

Property Value

Type: FontStyle
See Also

Reference

Item Class


Item.FontUnderline Property

ItemFontUnderline Property
Indicates whether this Font is underlined

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool FontUnderline { get; set; }
Public Property FontUnderline As Boolean
    Get
    Set
public:
property bool FontUnderline {
    bool get ();
    void set (bool value);
}
member FontUnderline : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Item Class


Item.FontWeight Property

ItemFontWeight Property
Gets or sets the font weight to use with the item

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public FontWeight FontWeight { get; set; }
Public Property FontWeight As FontWeight
    Get
    Set
public:
property FontWeight FontWeight {
    FontWeight get ();
    void set (FontWeight value);
}
member FontWeight : FontWeight with get, set

Property Value

Type: FontWeight
See Also

Reference

Item Class


Item.Foreground Property

ItemForeground Property
Gets or sets the Brush to apply to the text of the item

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Brush Foreground { get; set; }
Public Property Foreground As Brush
    Get
    Set
public:
property Brush^ Foreground {
    Brush^ get ();
    void set (Brush^ value);
}
member Foreground : Brush with get, set

Property Value

Type: Brush
See Also

Reference

Item Class


Item.IsHitTestVisible Property

ItemIsHitTestVisible Property
Determines whether the item can be hit tested.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool IsHitTestVisible { get; set; }
Public Property IsHitTestVisible As Boolean
    Get
    Set
public:
property bool IsHitTestVisible {
    bool get ();
    void set (bool value);
}
member IsHitTestVisible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Item Class


Item.IsSelectable Property

ItemIsSelectable Property
Determines whether the item is selectable by clicking on it with the mouse or unselectable (readonly or inactive).

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool IsSelectable { get; set; }
Public Property IsSelectable As Boolean
    Get
    Set
public:
virtual property bool IsSelectable {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IsSelectable : bool with get, set
override IsSelectable : bool with get, set

Property Value

Type: Boolean

Implements

ISelectableIsSelectable
See Also

Reference

Item Class


Item.IsSelected Property

ItemIsSelected Property
Returns/sets a flag indicating if the item is selected or not.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool IsSelected { get; set; }
Public Property IsSelected As Boolean
    Get
    Set
public:
virtual property bool IsSelected {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IsSelected : bool with get, set
override IsSelected : bool with get, set

Property Value

Type: Boolean

Implements

ISelectableIsSelected
See Also

Reference

Item Class


Item.Stroke Property

ItemStroke Property
Returns/sets the brush used to draw the item.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Brush Stroke { get; set; }
Public Property Stroke As Brush
    Get
    Set
public:
property Brush^ Stroke {
    Brush^ get ();
    void set (Brush^ value);
}
member Stroke : Brush with get, set

Property Value

Type: Brush
See Also

Reference

Item Class


Item.StrokeThickness Property

ItemStrokeThickness Property
Returns/sets the pen width used to draw the item.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public double StrokeThickness { get; set; }
Public Property StrokeThickness As Double
    Get
    Set
public:
property double StrokeThickness {
    double get ();
    void set (double value);
}
member StrokeThickness : float with get, set

Property Value

Type: Double
See Also

Reference

Item Class


Item.Text Property

ItemText Property
Returns/sets the text associated with the item. In the case of a node, the text is displayed inside the node. It is a multiline display. The text is wrapped automatically inside the node. Linefeed and carriage return characters are allowed.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
member Text : string with get, set

Property Value

Type: String
See Also

Reference

Item Class


Item.Tooltip Property

ItemTooltip Property
Returns/sets the tooltip associated with the item.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public string Tooltip { get; set; }
Public Property Tooltip As String
    Get
    Set
public:
property String^ Tooltip {
    String^ get ();
    void set (String^ value);
}
member Tooltip : string with get, set

Property Value

Type: String
See Also

Reference

Item Class


Item.Visual Property

ItemVisual Property
The DrawingVisualobject used to display the item

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public DrawingVisual Visual { get; }
Public ReadOnly Property Visual As DrawingVisual
    Get
public:
property DrawingVisual^ Visual {
    DrawingVisual^ get ();
}
member Visual : DrawingVisual with get

Property Value

Type: DrawingVisual
See Also

Reference

Item Class


ItemSet Enumeration

ItemSet Enumeration
Used to specify a set of items (nodes and links)

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public enum ItemSet
Public Enumeration ItemSet
public enum class ItemSet
type ItemSet
Members
Member name | Value | Description
Items | 0 | We take all items
Nodes | 1 | We take all nodes
Links | 2 | We take all links
Captions | 3 | We take all captions
SelectableItems | 4 | We take all selectable items
SelectableNodes | 5 | We take all selectable nodes
SelectableLinks | 6 | We take all selectable links
SelectableCaptions | 7 | We take all selectable Captions
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


LineStyle Enumeration

LineStyle Enumeration
Used to specify the style used to draw a link.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public enum LineStyle
Public Enumeration LineStyle
public enum class LineStyle
type LineStyle
Members
Member name | Value | Description
Polyline | 0 | A series of connected lines
Bezier | 1 | A Bezier curve
Spline | 2 | A Cubic spline curve
Database | 3 | Database style
Orthogonal | 4 | Orthogonal style
VH | 5 | 2 segments: vertical horizontal
HV | 6 | 2 segments: horizontal vertical
VHV | 7 | 3 segments: vertical horizontal vertical
HVH | 8 | 3 segments: horizontal vertical horizontal
VHVH | 9 | 4 segments: vert horz vert horz
HVHV | 10 | 4 segments: horz vert horz vert
VHVHV | 11 | 5 segments: vert horz vert horz vert
HVHVH | 12 | 5 segments: horz vert horz vert horz
VHVHVH | 13 | 6 segments: vert horz vert horz vert horz
HVHVHV | 14 | 6 segments: horz vert horz vert horz vert
VHVHVHV | 15 | 7 segments: vert horz vert horz vert horz vert
HVHVHVH | 16 | 7 segments: horz vert horz vert horz vert horz
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


Link Class

Link Class
Represents a link (also called edge, relation or arc) in the diagram.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
Lassalle.WPF.FlowItem
Lassalle.WPF.FlowLink

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public class Link : Item
Public Class Link
    Inherits Item
public ref class Link : public Item
type Link =
    class
        inherit Item
    end

The Link type exposes the following members.

Constructors
 | Name | Description
Public method | Link | Initializes a new instance of the Link class.
Public method | Link(Node, Node, String, AddFlow) | Initializes a new instance of the Link class with an origin node, a destination node, a text and a reference to an AddFlow control.
Public method | Link(Node, Node, String, Link) | Initializes a new instance of the Link class with an origin, a destination node and a text.
Public method | Link(Node, Node, Int32, Int32, String, AddFlow) | Initializes a new instance of the Link class with an origin node, a destination node, an origin pin index, a destination pin index, a text and a reference to an AddFlow control
Public method | Link(Node, Node, Int32, Int32, String, Link) | Initializes a new instance of the Link class with an origin node, a destination node, an origin pin index, a destination pin index and a text.
Top
Methods
 | Name | Description
Public method | AddPoint | Add a point to the collection of points of a link.
Public method | BringIntoView | Ensures that the item is in the viewable area of the control. If the item is not viewable, scrolls the control as necessary to bring the item into view. (Inherited from Item.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearPoints | Clears the collection of points of the link, removing all points except the first and the last since a link points collection is never empty and contains at least 2 points.
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CountPoints | Gets the total number of points in the collection of points of a link.
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDstPin | Gets the destination pin of the link or null if there is no destination pin
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetOrgPin | Gets the origin pin of the link or null if there is no origin pin
Public method | GetPoint | Returns a point at the specified index.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this DependencyObject has been updated. The specific dependency property that changed is reported in the event data. (Inherited from DependencyObject.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Refresh | Forces a repaint of the item. (Inherited from Item.)
Public method | RemovePoint | Removes the point at the specified index from the collection of points of the link.
Public method | Reverse | Reverse the origin and destination nodes of the link. After a Reverse action, a link from node A to B becomes a link from node B to node A.
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetPoint | Sets a point at the specified index.
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Properties
 | Name | Description
Public property | AddFlow | The addflow canvas containing this item (Inherited from Item.)
Public property | ArrowGeometryDst | Returns/sets the geometry of the link destination arrow head.
Public property | ArrowGeometryMid | Returns/sets the geometry of the arrow placed at the middle of each segment of the link.
Public property | ArrowGeometryOrg | Returns/sets the geometry of the link origin arrow head.
Public property | BackMode | Determines whether the background remains untouched or if the background is filled with the current background color before the text of the item. (Inherited from Item.)
Public property | Bounds | Returns the item bounding rectangle (Inherited from Item.)
Public property | Captions | Returns the collection of the captions attached to this item. (Inherited from Item.)
Public property | DashStyle | Returns/sets the DashStyle of the pen used to draw the item. (Inherited from Item.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Dst | Returns/sets the reference of the destination node of the link.
Public property | Fill | Returns/sets the brush used to fill the item. (Inherited from Item.)
Public property | FontFamily | Gets or sets the font family to use with the item (Inherited from Item.)
Public property | FontSize | Gets or sets the font size to use with the item (Inherited from Item.)
Public property | FontStretch | Gets or sets a FontStretch property that selects a normal, condensed, or expanded font from a FontFamily (Inherited from Item.)
Public property | FontStrikethrough | Indicates whether this Font has a strikethrough TextDecoration (Inherited from Item.)
Public property | FontStyle | Gets or sets the font style to use with the item (Inherited from Item.)
Public property | FontUnderline | Indicates whether this Font is underlined (Inherited from Item.)
Public property | FontWeight | Gets or sets the font weight to use with the item (Inherited from Item.)
Public property | Foreground | Gets or sets the Brush to apply to the text of the item (Inherited from Item.)
Public property | IsAdjustDst | Determines whether it is possible to adjust the position of the last point of the link. This property has an effect only if the InConnectionMode property of the destination node is set to LinkDecision
Public property | IsAdjustOrg | Determines whether it is possible to adjust the position of the first point of the link. This property has an effect only if the OutConnectionMode property of the origin node is set to LinkDecision
Public property | IsHitTestVisible | Determines whether the item can be hit tested. (Inherited from Item.)
Public property | IsOrientedText | Determines whether the link text can be drawn in the same direction as the link itself.
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelectable | Determines whether the item is selectable by clicking on it with the mouse or unselectable (readonly or inactive). (Inherited from Item.)
Public property | IsSelected | Returns/sets a flag indicating if the item is selected or not. (Inherited from Item.)
Public property | IsStretchable | Determines whether the link is stretchable or not. When a link is not stretchable, the user cannot interactively stretch it with the mouse.
Public property | JumpSize | Returns/sets the size of the jumps at the intersection of links.
Public property | LineStyle | Returns/sets the style of the link.
Public property | Org | Returns/sets the reference of the origin node of the link.
Public property | PinDstIndex | Returns/sets the index of the destination pin
Public property | PinOrgIndex | Returns/sets the index of the origin pin
Public property | Points | The collection of link points
Public property | RoundedCornerSize | Determines the size of the rounded corner at the intersection point of 2 segments. It is 0 by default
Public property | Stroke | Returns/sets the brush used to draw the item. (Inherited from Item.)
Public property | StrokeThickness | Returns/sets the pen width used to draw the item. (Inherited from Item.)
Public property | Text | Returns/sets the text associated with the item. In the case of a node, the text is displayed inside the node. It is a multiline display. The text is wrapped automatically inside the node. Linefeed and carriage return characters are allowed. (Inherited from Item.)
Public property | TextPlacementMode | Returns/sets the TextPlacementMode style of the text of the link.
Public property | Tooltip | Returns/sets the tooltip associated with the item. (Inherited from Item.)
Public property | Visual | The DrawingVisualobject used to display the item (Inherited from Item.)
Top
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


Link Constructor

Link Constructor
Overload List
 | Name | Description
Public method | Link | Initializes a new instance of the Link class.
Public method | Link(Node, Node, String, AddFlow) | Initializes a new instance of the Link class with an origin node, a destination node, a text and a reference to an AddFlow control.
Public method | Link(Node, Node, String, Link) | Initializes a new instance of the Link class with an origin, a destination node and a text.
Public method | Link(Node, Node, Int32, Int32, String, AddFlow) | Initializes a new instance of the Link class with an origin node, a destination node, an origin pin index, a destination pin index, a text and a reference to an AddFlow control
Public method | Link(Node, Node, Int32, Int32, String, Link) | Initializes a new instance of the Link class with an origin node, a destination node, an origin pin index, a destination pin index and a text.
Top
See Also

Reference

Link Class


Link Constructor

Link Constructor
Initializes a new instance of the Link class.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Link()
Public Sub New
public:
Link()
new : unit -> Link
See Also

Reference

Link Class
Link Overload


Link Constructor (Node, Node, String, AddFlow)

Link Constructor (Node, Node, String, AddFlow)
Initializes a new instance of the Link class with an origin node, a destination node, a text and a reference to an AddFlow control.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Link(
    Node org,
    Node dst,
    string text,
    AddFlow addflow
)
Public Sub New (
    org As Node,
    dst As Node,
    text As String,
    addflow As AddFlow
)
public:
Link(
    Node^ org,
    Node^ dst,
    String^ text,
    AddFlow^ addflow
)
new :
        org : Node *
        dst : Node *
        text : string *
        addflow : AddFlow -> Link

Parameters

org
Type: Lassalle.WPF.FlowNode
A reference to the origin node
dst
Type: Lassalle.WPF.FlowNode
A reference to the destination node
text
Type: SystemString
The text displayed with the link
addflow
Type: Lassalle.WPF.FlowAddFlow
The AddFlow control that will supply default values for the node
See Also

Reference

Link Class
Link Overload


Link Constructor (Node, Node, String, Link)

Link Constructor (Node, Node, String, Link)
Initializes a new instance of the Link class with an origin, a destination node and a text.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Link(
    Node org,
    Node dst,
    string text,
    Link link
)
Public Sub New (
    org As Node,
    dst As Node,
    text As String,
    link As Link
)
public:
Link(
    Node^ org,
    Node^ dst,
    String^ text,
    Link^ link
)
new :
        org : Node *
        dst : Node *
        text : string *
        link : Link -> Link

Parameters

org
Type: Lassalle.WPF.FlowNode
A reference to the origin node
dst
Type: Lassalle.WPF.FlowNode
A reference to the destination node
text
Type: SystemString
The text displayed with the link
link
Type: Lassalle.WPF.FlowLink
An object containing the default property values of link.
See Also

Reference

Link Class
Link Overload


Link Constructor (Node, Node, Int32, Int32, String, AddFlow)

Link Constructor (Node, Node, Int32, Int32, String, AddFlow)
Initializes a new instance of the Link class with an origin node, a destination node, an origin pin index, a destination pin index, a text and a reference to an AddFlow control

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Link(
    Node org,
    Node dst,
    int pinOrgIndex,
    int pinDstIndex,
    string text,
    AddFlow addflow
)
Public Sub New (
    org As Node,
    dst As Node,
    pinOrgIndex As Integer,
    pinDstIndex As Integer,
    text As String,
    addflow As AddFlow
)
public:
Link(
    Node^ org,
    Node^ dst,
    int pinOrgIndex,
    int pinDstIndex,
    String^ text,
    AddFlow^ addflow
)
new :
        org : Node *
        dst : Node *
        pinOrgIndex : int *
        pinDstIndex : int *
        text : string *
        addflow : AddFlow -> Link

Parameters

org
Type: Lassalle.WPF.FlowNode
A reference to the origin node
dst
Type: Lassalle.WPF.FlowNode
A reference to the destination node
pinOrgIndex
Type: SystemInt32
Origin pin index
pinDstIndex
Type: SystemInt32
Destination pin index
text
Type: SystemString
The text displayed with the link
addflow
Type: Lassalle.WPF.FlowAddFlow
The AddFlow control that will supply default values for the node
See Also

Reference

Link Class
Link Overload


Link Constructor (Node, Node, Int32, Int32, String, Link)

Link Constructor (Node, Node, Int32, Int32, String, Link)
Initializes a new instance of the Link class with an origin node, a destination node, an origin pin index, a destination pin index and a text.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Link(
    Node org,
    Node dst,
    int pinOrgIndex,
    int pinDstIndex,
    string text,
    Link link
)
Public Sub New (
    org As Node,
    dst As Node,
    pinOrgIndex As Integer,
    pinDstIndex As Integer,
    text As String,
    link As Link
)
public:
Link(
    Node^ org,
    Node^ dst,
    int pinOrgIndex,
    int pinDstIndex,
    String^ text,
    Link^ link
)
new :
        org : Node *
        dst : Node *
        pinOrgIndex : int *
        pinDstIndex : int *
        text : string *
        link : Link -> Link

Parameters

org
Type: Lassalle.WPF.FlowNode
A reference to the origin node
dst
Type: Lassalle.WPF.FlowNode
A reference to the destination node
pinOrgIndex
Type: SystemInt32
Origin pin index
pinDstIndex
Type: SystemInt32
Destination pin index
text
Type: SystemString
The text displayed with the link
link
Type: Lassalle.WPF.FlowLink
An object containing the default property values of link.
See Also

Reference

Link Class
Link Overload


Link Methods

Link Methods

The Link type exposes the following members.

Methods
 | Name | Description
Public method | AddPoint | Add a point to the collection of points of a link.
Public method | BringIntoView | Ensures that the item is in the viewable area of the control. If the item is not viewable, scrolls the control as necessary to bring the item into view. (Inherited from Item.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearPoints | Clears the collection of points of the link, removing all points except the first and the last since a link points collection is never empty and contains at least 2 points.
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CountPoints | Gets the total number of points in the collection of points of a link.
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDstPin | Gets the destination pin of the link or null if there is no destination pin
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetOrgPin | Gets the origin pin of the link or null if there is no origin pin
Public method | GetPoint | Returns a point at the specified index.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this DependencyObject has been updated. The specific dependency property that changed is reported in the event data. (Inherited from DependencyObject.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Refresh | Forces a repaint of the item. (Inherited from Item.)
Public method | RemovePoint | Removes the point at the specified index from the collection of points of the link.
Public method | Reverse | Reverse the origin and destination nodes of the link. After a Reverse action, a link from node A to B becomes a link from node B to node A.
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetPoint | Sets a point at the specified index.
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

Link Class


Link.AddPoint Method

LinkAddPoint Method
Add a point to the collection of points of a link.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void AddPoint(
    Point pt
)
Public Sub AddPoint (
    pt As Point
)
public:
void AddPoint(
    Point pt
)
member AddPoint :
        pt : Point -> unit

Parameters

pt
Type: System.WindowsPoint
The point to add
Remarks
This method will work only if the link style is Polyline or Spline. However, in other cases, no exception is thrown.
See Also

Reference

Link Class


Link.ClearPoints Method

LinkClearPoints Method
Clears the collection of points of the link, removing all points except the first and the last since a link points collection is never empty and contains at least 2 points.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void ClearPoints()
Public Sub ClearPoints
public:
void ClearPoints()
member ClearPoints : unit -> unit
Remarks
This method will work only if the link style is Polyline or Spline. However, in other cases, no exception is thrown.
See Also

Reference

Link Class


Link.CountPoints Method

LinkCountPoints Method
Gets the total number of points in the collection of points of a link.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public int CountPoints()
Public Function CountPoints As Integer
public:
int CountPoints()
member CountPoints : unit -> int

Return Value

Type: Int32

[Missing <returns> documentation for "M:Lassalle.WPF.Flow.Link.CountPoints"]

See Also

Reference

Link Class


Link.GetDstPin Method

LinkGetDstPin Method
Gets the destination pin of the link or null if there is no destination pin

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Pin GetDstPin()
Public Function GetDstPin As Pin
public:
Pin^ GetDstPin()
member GetDstPin : unit -> Pin

Return Value

Type: Pin
A reference to the destination pin
See Also

Reference

Link Class


Link.GetOrgPin Method

LinkGetOrgPin Method
Gets the origin pin of the link or null if there is no origin pin

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Pin GetOrgPin()
Public Function GetOrgPin As Pin
public:
Pin^ GetOrgPin()
member GetOrgPin : unit -> Pin

Return Value

Type: Pin
A reference to the origin pin
See Also

Reference

Link Class


Link.GetPoint Method

LinkGetPoint Method
Returns a point at the specified index.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Point GetPoint(
    int index
)
Public Function GetPoint (
    index As Integer
) As Point
public:
Point GetPoint(
    int index
)
member GetPoint :
        index : int -> Point

Parameters

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Lassalle.WPF.Flow.Link.GetPoint(System.Int32)"]

Return Value

Type: Point

[Missing <returns> documentation for "M:Lassalle.WPF.Flow.Link.GetPoint(System.Int32)"]

See Also

Reference

Link Class


Link.RemovePoint Method

LinkRemovePoint Method
Removes the point at the specified index from the collection of points of the link.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void RemovePoint(
    int index
)
Public Sub RemovePoint (
    index As Integer
)
public:
void RemovePoint(
    int index
)
member RemovePoint :
        index : int -> unit

Parameters

index
Type: SystemInt32
The index of the point to be removed from the collection.
Remarks
This method will work only if the link style is Polyline or Spline. However, in other cases, no exception is thrown.
See Also

Reference

Link Class


Link.Reverse Method

LinkReverse Method
Reverse the origin and destination nodes of the link. After a Reverse action, a link from node A to B becomes a link from node B to node A.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void Reverse()
Public Sub Reverse
public:
void Reverse()
member Reverse : unit -> unit
See Also

Reference

Link Class


Link.SetPoint Method

LinkSetPoint Method
Sets a point at the specified index.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void SetPoint(
    Point pt,
    int index
)
Public Sub SetPoint (
    pt As Point,
    index As Integer
)
public:
void SetPoint(
    Point pt,
    int index
)
member SetPoint :
        pt : Point *
        index : int -> unit

Parameters

pt
Type: System.WindowsPoint

[Missing <param name="pt"/> documentation for "M:Lassalle.WPF.Flow.Link.SetPoint(System.Windows.Point,System.Int32)"]

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Lassalle.WPF.Flow.Link.SetPoint(System.Windows.Point,System.Int32)"]

See Also

Reference

Link Class


Link Properties

Link Properties

The Link type exposes the following members.

Properties
 | Name | Description
Public property | AddFlow | The addflow canvas containing this item (Inherited from Item.)
Public property | ArrowGeometryDst | Returns/sets the geometry of the link destination arrow head.
Public property | ArrowGeometryMid | Returns/sets the geometry of the arrow placed at the middle of each segment of the link.
Public property | ArrowGeometryOrg | Returns/sets the geometry of the link origin arrow head.
Public property | BackMode | Determines whether the background remains untouched or if the background is filled with the current background color before the text of the item. (Inherited from Item.)
Public property | Bounds | Returns the item bounding rectangle (Inherited from Item.)
Public property | Captions | Returns the collection of the captions attached to this item. (Inherited from Item.)
Public property | DashStyle | Returns/sets the DashStyle of the pen used to draw the item. (Inherited from Item.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Dst | Returns/sets the reference of the destination node of the link.
Public property | Fill | Returns/sets the brush used to fill the item. (Inherited from Item.)
Public property | FontFamily | Gets or sets the font family to use with the item (Inherited from Item.)
Public property | FontSize | Gets or sets the font size to use with the item (Inherited from Item.)
Public property | FontStretch | Gets or sets a FontStretch property that selects a normal, condensed, or expanded font from a FontFamily (Inherited from Item.)
Public property | FontStrikethrough | Indicates whether this Font has a strikethrough TextDecoration (Inherited from Item.)
Public property | FontStyle | Gets or sets the font style to use with the item (Inherited from Item.)
Public property | FontUnderline | Indicates whether this Font is underlined (Inherited from Item.)
Public property | FontWeight | Gets or sets the font weight to use with the item (Inherited from Item.)
Public property | Foreground | Gets or sets the Brush to apply to the text of the item (Inherited from Item.)
Public property | IsAdjustDst | Determines whether it is possible to adjust the position of the last point of the link. This property has an effect only if the InConnectionMode property of the destination node is set to LinkDecision
Public property | IsAdjustOrg | Determines whether it is possible to adjust the position of the first point of the link. This property has an effect only if the OutConnectionMode property of the origin node is set to LinkDecision
Public property | IsHitTestVisible | Determines whether the item can be hit tested. (Inherited from Item.)
Public property | IsOrientedText | Determines whether the link text can be drawn in the same direction as the link itself.
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelectable | Determines whether the item is selectable by clicking on it with the mouse or unselectable (readonly or inactive). (Inherited from Item.)
Public property | IsSelected | Returns/sets a flag indicating if the item is selected or not. (Inherited from Item.)
Public property | IsStretchable | Determines whether the link is stretchable or not. When a link is not stretchable, the user cannot interactively stretch it with the mouse.
Public property | JumpSize | Returns/sets the size of the jumps at the intersection of links.
Public property | LineStyle | Returns/sets the style of the link.
Public property | Org | Returns/sets the reference of the origin node of the link.
Public property | PinDstIndex | Returns/sets the index of the destination pin
Public property | PinOrgIndex | Returns/sets the index of the origin pin
Public property | Points | The collection of link points
Public property | RoundedCornerSize | Determines the size of the rounded corner at the intersection point of 2 segments. It is 0 by default
Public property | Stroke | Returns/sets the brush used to draw the item. (Inherited from Item.)
Public property | StrokeThickness | Returns/sets the pen width used to draw the item. (Inherited from Item.)
Public property | Text | Returns/sets the text associated with the item. In the case of a node, the text is displayed inside the node. It is a multiline display. The text is wrapped automatically inside the node. Linefeed and carriage return characters are allowed. (Inherited from Item.)
Public property | TextPlacementMode | Returns/sets the TextPlacementMode style of the text of the link.
Public property | Tooltip | Returns/sets the tooltip associated with the item. (Inherited from Item.)
Public property | Visual | The DrawingVisualobject used to display the item (Inherited from Item.)
Top
See Also

Reference

Link Class


Link.ArrowGeometryDst Property

LinkArrowGeometryDst Property
Returns/sets the geometry of the link destination arrow head.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Geometry ArrowGeometryDst { get; set; }
Public Property ArrowGeometryDst As Geometry
    Get
    Set
public:
property Geometry^ ArrowGeometryDst {
    Geometry^ get ();
    void set (Geometry^ value);
}
member ArrowGeometryDst : Geometry with get, set

Property Value

Type: Geometry
See Also

Reference

Link Class


Link.ArrowGeometryMid Property

LinkArrowGeometryMid Property
Returns/sets the geometry of the arrow placed at the middle of each segment of the link.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Geometry ArrowGeometryMid { get; set; }
Public Property ArrowGeometryMid As Geometry
    Get
    Set
public:
property Geometry^ ArrowGeometryMid {
    Geometry^ get ();
    void set (Geometry^ value);
}
member ArrowGeometryMid : Geometry with get, set

Property Value

Type: Geometry
See Also

Reference

Link Class


Link.ArrowGeometryOrg Property

LinkArrowGeometryOrg Property
Returns/sets the geometry of the link origin arrow head.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Geometry ArrowGeometryOrg { get; set; }
Public Property ArrowGeometryOrg As Geometry
    Get
    Set
public:
property Geometry^ ArrowGeometryOrg {
    Geometry^ get ();
    void set (Geometry^ value);
}
member ArrowGeometryOrg : Geometry with get, set

Property Value

Type: Geometry
See Also

Reference

Link Class


Link.Dst Property

LinkDst Property
Returns/sets the reference of the destination node of the link.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Node Dst { get; set; }
Public Property Dst As Node
    Get
    Set
public:
property Node^ Dst {
    Node^ get ();
    void set (Node^ value);
}
member Dst : Node with get, set

Property Value

Type: Node
See Also

Reference

Link Class


Link.IsAdjustDst Property

LinkIsAdjustDst Property
Determines whether it is possible to adjust the position of the last point of the link. This property has an effect only if the InConnectionMode property of the destination node is set to LinkDecision

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool IsAdjustDst { get; set; }
Public Property IsAdjustDst As Boolean
    Get
    Set
public:
property bool IsAdjustDst {
    bool get ();
    void set (bool value);
}
member IsAdjustDst : bool with get, set

Property Value

Type: Boolean
Remarks
This property is provided to facilitate the conversion of code written for AddFlow for Winforms
See Also

Reference

Link Class


Link.IsAdjustOrg Property

LinkIsAdjustOrg Property
Determines whether it is possible to adjust the position of the first point of the link. This property has an effect only if the OutConnectionMode property of the origin node is set to LinkDecision

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool IsAdjustOrg { get; set; }
Public Property IsAdjustOrg As Boolean
    Get
    Set
public:
property bool IsAdjustOrg {
    bool get ();
    void set (bool value);
}
member IsAdjustOrg : bool with get, set

Property Value

Type: Boolean
Remarks
This property is provided to facilitate the conversion of code written for AddFlow for Winforms
See Also

Reference

Link Class


Link.IsOrientedText Property

LinkIsOrientedText Property
Determines whether the link text can be drawn in the same direction as the link itself.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool IsOrientedText { get; set; }
Public Property IsOrientedText As Boolean
    Get
    Set
public:
property bool IsOrientedText {
    bool get ();
    void set (bool value);
}
member IsOrientedText : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Link Class


Link.IsStretchable Property

LinkIsStretchable Property
Determines whether the link is stretchable or not. When a link is not stretchable, the user cannot interactively stretch it with the mouse.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool IsStretchable { get; set; }
Public Property IsStretchable As Boolean
    Get
    Set
public:
property bool IsStretchable {
    bool get ();
    void set (bool value);
}
member IsStretchable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Link Class


Link.JumpSize Property

LinkJumpSize Property
Returns/sets the size of the jumps at the intersection of links.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public double JumpSize { get; set; }
Public Property JumpSize As Double
    Get
    Set
public:
property double JumpSize {
    double get ();
    void set (double value);
}
member JumpSize : float with get, set

Property Value

Type: Double
See Also

Reference

Link Class


Link.LineStyle Property

LinkLineStyle Property
Returns/sets the style of the link.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public LineStyle LineStyle { get; set; }
Public Property LineStyle As LineStyle
    Get
    Set
public:
property LineStyle LineStyle {
    LineStyle get ();
    void set (LineStyle value);
}
member LineStyle : LineStyle with get, set

Property Value

Type: LineStyle
Remarks
  1. A reflexive link cannot have a LineStyle other than Polyline, Bezier or Spline.
  2. The Bezier link has 4 points.
  3. If LineStyle is not Polyline, Bezier or Spline, the link is not stretchable. You cannot increase its segments number.
See Also

Reference

Link Class


Link.Org Property

LinkOrg Property
Returns/sets the reference of the origin node of the link.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Node Org { get; set; }
Public Property Org As Node
    Get
    Set
public:
property Node^ Org {
    Node^ get ();
    void set (Node^ value);
}
member Org : Node with get, set

Property Value

Type: Node
See Also

Reference

Link Class


Link.PinDstIndex Property

LinkPinDstIndex Property
Returns/sets the index of the destination pin

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public int PinDstIndex { get; set; }
Public Property PinDstIndex As Integer
    Get
    Set
public:
property int PinDstIndex {
    int get ();
    void set (int value);
}
member PinDstIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

Link Class


Link.PinOrgIndex Property

LinkPinOrgIndex Property
Returns/sets the index of the origin pin

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public int PinOrgIndex { get; set; }
Public Property PinOrgIndex As Integer
    Get
    Set
public:
property int PinOrgIndex {
    int get ();
    void set (int value);
}
member PinOrgIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

Link Class


Link.Points Property

LinkPoints Property
The collection of link points

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public PointCollection Points { get; set; }
Public Property Points As PointCollection
    Get
    Set
public:
property PointCollection^ Points {
    PointCollection^ get ();
    void set (PointCollection^ value);
}
member Points : PointCollection with get, set

Property Value

Type: PointCollection
Remarks
Don't use this property which is only provided for the AddFlow infrastructure. To manipulate the collection of link points, you should use instead the methods AddPoint, RemovePoints, ClearPoints, CountPoints, GetPoint and SetPoint.
See Also

Reference

Link Class


Link.RoundedCornerSize Property

LinkRoundedCornerSize Property
Determines the size of the rounded corner at the intersection point of 2 segments. It is 0 by default

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public double RoundedCornerSize { get; set; }
Public Property RoundedCornerSize As Double
    Get
    Set
public:
property double RoundedCornerSize {
    double get ();
    void set (double value);
}
member RoundedCornerSize : float with get, set

Property Value

Type: Double
Remarks
This property will have not any effect if the style property of the link is Bezier or Spline.
See Also

Reference

Link Class


Link.TextPlacementMode Property

LinkTextPlacementMode Property
Returns/sets the TextPlacementMode style of the text of the link.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public TextPlacementMode TextPlacementMode { get; set; }
Public Property TextPlacementMode As TextPlacementMode
    Get
    Set
public:
property TextPlacementMode TextPlacementMode {
    TextPlacementMode get ();
    void set (TextPlacementMode value);
}
member TextPlacementMode : TextPlacementMode with get, set

Property Value

Type: TextPlacementMode
See Also

Reference

Link Class


LinkCreatedEventArgs Class

LinkCreatedEventArgs Class
Event parameters used for the LinkCreated event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.WPF.FlowLinkCreatedEventArgs

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public class LinkCreatedEventArgs : EventArgs
Public Class LinkCreatedEventArgs
    Inherits EventArgs
public ref class LinkCreatedEventArgs : public EventArgs
type LinkCreatedEventArgs =
    class
        inherit EventArgs
    end

The LinkCreatedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | LinkCreatedEventArgs | Constructor. Creates a new LinkCreatedEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Link | The link that has just been created (read-only)
Top
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


LinkCreatedEventArgs Constructor

LinkCreatedEventArgs Constructor
Constructor. Creates a new LinkCreatedEventArgs instance.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public LinkCreatedEventArgs(
    Link link
)
Public Sub New (
    link As Link
)
public:
LinkCreatedEventArgs(
    Link^ link
)
new :
        link : Link -> LinkCreatedEventArgs

Parameters

link
Type: Lassalle.WPF.FlowLink
The created link
See Also

Reference

LinkCreatedEventArgs Class


LinkCreatedEventArgs Methods

LinkCreatedEventArgs Methods

The LinkCreatedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
See Also

Reference

LinkCreatedEventArgs Class


LinkCreatedEventArgs Properties

LinkCreatedEventArgs Properties

The LinkCreatedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Link | The link that has just been created (read-only)
Top
See Also

Reference

LinkCreatedEventArgs Class


LinkCreatedEventArgs.Link Property

LinkCreatedEventArgsLink Property
The link that has just been created (read-only)

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Link Link { get; }
Public ReadOnly Property Link As Link
    Get
public:
property Link^ Link {
    Link^ get ();
}
member Link : Link with get

Property Value

Type: Link
See Also

Reference

LinkCreatedEventArgs Class


LinkCreatingEventArgs Class

LinkCreatingEventArgs Class
Event parameters used for the LinkCreating event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.WPF.FlowLinkCreatingEventArgs

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public class LinkCreatingEventArgs : EventArgs
Public Class LinkCreatingEventArgs
    Inherits EventArgs
public ref class LinkCreatingEventArgs : public EventArgs
type LinkCreatingEventArgs =
    class
        inherit EventArgs
    end

The LinkCreatingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | LinkCreatingEventArgs | Constructor. Creates a new LinkCreatingEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the link creation should be canceled.
Public property | Dst | The destination node of the link to create (read-only)
Public property | Org | The origin node of the link to create (read-only)
Top
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


LinkCreatingEventArgs Constructor

LinkCreatingEventArgs Constructor
Constructor. Creates a new LinkCreatingEventArgs instance.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public LinkCreatingEventArgs(
    Node org,
    Node dst
)
Public Sub New (
    org As Node,
    dst As Node
)
public:
LinkCreatingEventArgs(
    Node^ org,
    Node^ dst
)
new :
        org : Node *
        dst : Node -> LinkCreatingEventArgs

Parameters

org
Type: Lassalle.WPF.FlowNode
The origin node of the link that is going to be created
dst
Type: Lassalle.WPF.FlowNode
The destination node of the link that is going to be created
See Also

Reference

LinkCreatingEventArgs Class


LinkCreatingEventArgs Methods

LinkCreatingEventArgs Methods

The LinkCreatingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
See Also

Reference

LinkCreatingEventArgs Class


LinkCreatingEventArgs Properties

LinkCreatingEventArgs Properties

The LinkCreatingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the link creation should be canceled.
Public property | Dst | The destination node of the link to create (read-only)
Public property | Org | The origin node of the link to create (read-only)
Top
See Also

Reference

LinkCreatingEventArgs Class


LinkCreatingEventArgs.Cancel Property

LinkCreatingEventArgsCancel Property
Gets/sets a value indicating whether the link creation should be canceled.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public CancelEventArgs Cancel { get; set; }
Public Property Cancel As CancelEventArgs
    Get
    Set
public:
property CancelEventArgs^ Cancel {
    CancelEventArgs^ get ();
    void set (CancelEventArgs^ value);
}
member Cancel : CancelEventArgs with get, set

Property Value

Type: CancelEventArgs
See Also

Reference

LinkCreatingEventArgs Class


LinkCreatingEventArgs.Dst Property

LinkCreatingEventArgsDst Property
The destination node of the link to create (read-only)

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Node Dst { get; }
Public ReadOnly Property Dst As Node
    Get
public:
property Node^ Dst {
    Node^ get ();
}
member Dst : Node with get

Property Value

Type: Node
See Also

Reference

LinkCreatingEventArgs Class


LinkCreatingEventArgs.Org Property

LinkCreatingEventArgsOrg Property
The origin node of the link to create (read-only)

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Node Org { get; }
Public ReadOnly Property Org As Node
    Get
public:
property Node^ Org {
    Node^ get ();
}
member Org : Node with get

Property Value

Type: Node
See Also

Reference

LinkCreatingEventArgs Class


LinkDeletedEventArgs Class

LinkDeletedEventArgs Class
Event parameters used for the LinkDeleted event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.WPF.FlowLinkDeletedEventArgs

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public class LinkDeletedEventArgs : EventArgs
Public Class LinkDeletedEventArgs
    Inherits EventArgs
public ref class LinkDeletedEventArgs : public EventArgs
type LinkDeletedEventArgs =
    class
        inherit EventArgs
    end

The LinkDeletedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | LinkDeletedEventArgs | Constructor. Creates a new LinkDeletedEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Link | The link that has just been removed (read-only)
Top
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


LinkDeletedEventArgs Constructor

LinkDeletedEventArgs Constructor
Constructor. Creates a new LinkDeletedEventArgs instance.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public LinkDeletedEventArgs(
    Link link
)
Public Sub New (
    link As Link
)
public:
LinkDeletedEventArgs(
    Link^ link
)
new :
        link : Link -> LinkDeletedEventArgs

Parameters

link
Type: Lassalle.WPF.FlowLink
The removed link
See Also

Reference

LinkDeletedEventArgs Class


LinkDeletedEventArgs Methods

LinkDeletedEventArgs Methods

The LinkDeletedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
See Also

Reference

LinkDeletedEventArgs Class


LinkDeletedEventArgs Properties

LinkDeletedEventArgs Properties

The LinkDeletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Link | The link that has just been removed (read-only)
Top
See Also

Reference

LinkDeletedEventArgs Class


LinkDeletedEventArgs.Link Property

LinkDeletedEventArgsLink Property
The link that has just been removed (read-only)

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Link Link { get; }
Public ReadOnly Property Link As Link
    Get
public:
property Link^ Link {
    Link^ get ();
}
member Link : Link with get

Property Value

Type: Link
See Also

Reference

LinkDeletedEventArgs Class


LinkDeletingEventArgs Class

LinkDeletingEventArgs Class
Event parameters used for the LinkDeleting event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.WPF.FlowLinkDeletingEventArgs

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public class LinkDeletingEventArgs : EventArgs
Public Class LinkDeletingEventArgs
    Inherits EventArgs
public ref class LinkDeletingEventArgs : public EventArgs
type LinkDeletingEventArgs =
    class
        inherit EventArgs
    end

The LinkDeletingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | LinkDeletingEventArgs | Constructor. Creates a new LinkDeletingEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the link removing should be canceled.
Public property | Link | The link to be removed (read-only)
Top
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


LinkDeletingEventArgs Constructor

LinkDeletingEventArgs Constructor
Constructor. Creates a new LinkDeletingEventArgs instance.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public LinkDeletingEventArgs(
    Link link
)
Public Sub New (
    link As Link
)
public:
LinkDeletingEventArgs(
    Link^ link
)
new :
        link : Link -> LinkDeletingEventArgs

Parameters

link
Type: Lassalle.WPF.FlowLink
The link to be removed
See Also

Reference

LinkDeletingEventArgs Class


LinkDeletingEventArgs Methods

LinkDeletingEventArgs Methods

The LinkDeletingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
See Also

Reference

LinkDeletingEventArgs Class


LinkDeletingEventArgs Properties

LinkDeletingEventArgs Properties

The LinkDeletingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the link removing should be canceled.
Public property | Link | The link to be removed (read-only)
Top
See Also

Reference

LinkDeletingEventArgs Class


LinkDeletingEventArgs.Cancel Property

LinkDeletingEventArgsCancel Property
Gets/sets a value indicating whether the link removing should be canceled.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public CancelEventArgs Cancel { get; set; }
Public Property Cancel As CancelEventArgs
    Get
    Set
public:
property CancelEventArgs^ Cancel {
    CancelEventArgs^ get ();
    void set (CancelEventArgs^ value);
}
member Cancel : CancelEventArgs with get, set

Property Value

Type: CancelEventArgs
See Also

Reference

LinkDeletingEventArgs Class


LinkDeletingEventArgs.Link Property

LinkDeletingEventArgsLink Property
The link to be removed (read-only)

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Link Link { get; }
Public ReadOnly Property Link As Link
    Get
public:
property Link^ Link {
    Link^ get ();
}
member Link : Link with get

Property Value

Type: Link
See Also

Reference

LinkDeletingEventArgs Class


MouseSelection Enumeration

MouseSelection Enumeration
Used to specify the selection rectangle action with the mouse.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public enum MouseSelection
Public Enumeration MouseSelection
public enum class MouseSelection
type MouseSelection
Members
Member name | Value | Description
Node | 0 | Nodes creation mode
Caption | 1 | Captions creation mode
Selection | 2 | Select the items partially inside the rectangle
Selection2 | 3 | Select the items completely inside the rectangle
Pan | 4 | Panning mode. Scroll the diagram with the mouse.
Zoom | 5 | Zoom the rectangle while ensuring a 1:1 aspect ratio
DrawRectangle | 6 | Just draw a rectangle without any action
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


Node Class

Node Class
Represents a node (also called vertice or entity) in the diagram.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
Lassalle.WPF.FlowItem
Lassalle.WPF.FlowContentItem
Lassalle.WPF.FlowNode

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public class Node : ContentItem
Public Class Node
    Inherits ContentItem
public ref class Node : public ContentItem
type Node =
    class
        inherit ContentItem
    end

The Node type exposes the following members.

Constructors
 | Name | Description
Public method | Node | Initializes a new instance of the Node class.
Public method | Node(Double, Double, Double, Double, String, AddFlow) | Initializes a new instance of the Node class with an initial position and size, an initial text and default values supplied by the addflow control.
Public method | Node(Double, Double, Double, Double, String, Node) | Initializes a new instance of the Node class with an initial position and size, an initial text and with the default property values given by a Node object
Top
Methods
 | Name | Description
Public method | BeginEdit | Initiates the editing of the node label. (Inherited from ContentItem.)
Public method | BringIntoView | Ensures that the item is in the viewable area of the control. If the item is not viewable, scrolls the control as necessary to bring the item into view. (Inherited from Item.)
Public method | CancelEdit | Cancels the editing of the ContentItem text. (Inherited from ContentItem.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndEdit | Ends the editing of the node label. (Inherited from ContentItem.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLinkedNode | Returns the node connected via a given link.
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this DependencyObject has been updated. The specific dependency property that changed is reported in the event data. (Inherited from DependencyObject.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Refresh | Forces a repaint of the item. (Inherited from Item.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeImageMargin | Returns true if ImageMargin should be serialized. (Inherited from ContentItem.)
Public method | ShouldSerializePinsLayout | Returns true if the PinsLayout property need to be serialized
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeTextMargin | Returns true if TextMargin should be serialized. (Inherited from ContentItem.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Properties
 | Name | Description
Public property | AddFlow | The addflow canvas containing this item (Inherited from Item.)
Public property | BackMode | Determines whether the background remains untouched or if the background is filled with the current background color before the text of the item. (Inherited from Item.)
Public property | Bounds | Returns the item bounding rectangle (Inherited from Item.)
Public property | Captions | Returns the collection of the captions attached to this item. (Inherited from Item.)
Public property | DashStyle | Returns/sets the DashStyle of the pen used to draw the item. (Inherited from Item.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Fill | Returns/sets the brush used to fill the item. (Inherited from Item.)
Public property | FontFamily | Gets or sets the font family to use with the item (Inherited from Item.)
Public property | FontSize | Gets or sets the font size to use with the item (Inherited from Item.)
Public property | FontStretch | Gets or sets a FontStretch property that selects a normal, condensed, or expanded font from a FontFamily (Inherited from Item.)
Public property | FontStrikethrough | Indicates whether this Font has a strikethrough TextDecoration (Inherited from Item.)
Public property | FontStyle | Gets or sets the font style to use with the item (Inherited from Item.)
Public property | FontUnderline | Indicates whether this Font is underlined (Inherited from Item.)
Public property | FontWeight | Gets or sets the font weight to use with the item (Inherited from Item.)
Public property | Foreground | Gets or sets the Brush to apply to the text of the item (Inherited from Item.)
Public property | Geometry | Returns/sets the geometry of the ContentItem object (Inherited from ContentItem.)
Public property | Image | Returns/sets the image displayed in the ContentItem object. (Inherited from ContentItem.)
Public property | ImageMargin | Returns/sets the size of the margins for the image of the node. (Inherited from ContentItem.)
Public property | ImagePosition | Returns/sets the picture position in the node. (Inherited from ContentItem.)
Public property | InConnectionMode | Indicates how a coming link is connected to the destination node
Public property | IsClipContent | Determines whether the content of the contentItem object is clipped or not. (Inherited from ContentItem.)
Public property | IsEditable | Determines whether the text of contentItem object can be edited or not (Inherited from ContentItem.)
Public property | IsEditing | Returns/sets a value indicating whether the text of the ContentItem object is currently edited (Inherited from ContentItem.)
Public property | IsHitTestVisible | Determines whether the item can be hit tested. (Inherited from Item.)
Public property | IsImageSizeFitContentArea | Determines whether the image of the contentItem object is adjusted to its size. (Inherited from ContentItem.)
Public property | IsInLinkable | Determines whether the node accept incoming links.
Public property | IsLinkingOver | If True, this property indicates that, during the creation of a link, the mouse is over this node which therefore may be the destination of that link.
Public property | IsOutLinkable | Determines whether the node accept outgoing links.
Public property | IsRotatable | Determines whether the contentItem object can be rotated or not. (Inherited from ContentItem.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelectable | Determines whether the item is selectable by clicking on it with the mouse or unselectable (readonly or inactive). (Inherited from Item.)
Public property | IsSelected | Returns/sets a flag indicating if the item is selected or not. (Inherited from Item.)
Public property | IsXMoveable | Determines whether the contentItem object can be horizontally moved or not. (Inherited from ContentItem.)
Public property | IsXSizeable | Determines whether the contentItem object can be horizontally resized or not. (Inherited from ContentItem.)
Public property | IsYMoveable | Determines whether the contentItem object can be vertically moved or not. (Inherited from ContentItem.)
Public property | IsYSizeable | Determines whether the contentItem object can be vertically resized or not. (Inherited from ContentItem.)
Public property | Links | Returns the collection of links that come to the node or that leave it.
Public property | Location | Returns/sets the position of a node. (Overrides ContentItemLocation.)
Public property | OutConnectionMode | Indicates how a leaving link is connected to the origin node
Public property | Pins | Returns the collection of the pins attached to this node.
Public property | PinsLayout | Sets or gets the list of node pins
Public property | RotationAngle | Returns/sets the rotation angle (in degrees) of a node. (Overrides ContentItemRotationAngle.)
Public property | Size | Returns/sets the size of a node. (Overrides ContentItemSize.)
Public property | Stroke | Returns/sets the brush used to draw the item. (Inherited from Item.)
Public property | StrokeThickness | Returns/sets the pen width used to draw the item. (Inherited from Item.)
Public property | Text | Returns/sets the text associated with the item. In the case of a node, the text is displayed inside the node. It is a multiline display. The text is wrapped automatically inside the node. Linefeed and carriage return characters are allowed. (Inherited from Item.)
Public property | TextMargin | Returns/sets the size of the margins for the text of the node. (Inherited from ContentItem.)
Public property | TextPosition | Returns/sets the position style of the text of the node. (Inherited from ContentItem.)
Public property | TextTrimming | Returns/sets the string trimming of the text in the node. (Inherited from ContentItem.)
Public property | Tooltip | Returns/sets the tooltip associated with the item. (Inherited from Item.)
Public property | Visual | The DrawingVisualobject used to display the item (Inherited from Item.)
Top
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


Node Constructor

Node Constructor
Overload List
 | Name | Description
Public method | Node | Initializes a new instance of the Node class.
Public method | Node(Double, Double, Double, Double, String, AddFlow) | Initializes a new instance of the Node class with an initial position and size, an initial text and default values supplied by the addflow control.
Public method | Node(Double, Double, Double, Double, String, Node) | Initializes a new instance of the Node class with an initial position and size, an initial text and with the default property values given by a Node object
Top
See Also

Reference

Node Class


Node Constructor

Node Constructor
Initializes a new instance of the Node class.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Node()
Public Sub New
public:
Node()
new : unit -> Node
See Also

Reference

Node Class
Node Overload


Node Constructor (Double, Double, Double, Double, String, AddFlow)

Node Constructor (Double, Double, Double, Double, String, AddFlow)
Initializes a new instance of the Node class with an initial position and size, an initial text and default values supplied by the addflow control.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Node(
    double left,
    double top,
    double width,
    double height,
    string text,
    AddFlow addflow
)
Public Sub New (
    left As Double,
    top As Double,
    width As Double,
    height As Double,
    text As String,
    addflow As AddFlow
)
public:
Node(
    double left,
    double top,
    double width,
    double height,
    String^ text,
    AddFlow^ addflow
)
new :
        left : float *
        top : float *
        width : float *
        height : float *
        text : string *
        addflow : AddFlow -> Node

Parameters

left
Type: SystemDouble
The x-coordinate of the node position
top
Type: SystemDouble
The y-coordinate of the node position
width
Type: SystemDouble
The horizontal size of the node
height
Type: SystemDouble
The vertical size of the node
text
Type: SystemString
The text displayed in the node
addflow
Type: Lassalle.WPF.FlowAddFlow
The AddFlow control that will supply default property values for the node
See Also

Reference

Node Class
Node Overload


Node Constructor (Double, Double, Double, Double, String, Node)

Node Constructor (Double, Double, Double, Double, String, Node)
Initializes a new instance of the Node class with an initial position and size, an initial text and with the default property values given by a Node object

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Node(
    double left,
    double top,
    double width,
    double height,
    string text,
    Node node
)
Public Sub New (
    left As Double,
    top As Double,
    width As Double,
    height As Double,
    text As String,
    node As Node
)
public:
Node(
    double left,
    double top,
    double width,
    double height,
    String^ text,
    Node^ node
)
new :
        left : float *
        top : float *
        width : float *
        height : float *
        text : string *
        node : Node -> Node

Parameters

left
Type: SystemDouble
The x-coordinate of the node position
top
Type: SystemDouble
The y-coordinate of the node position
width
Type: SystemDouble
The horizontal size of the node
height
Type: SystemDouble
The vertical size of the node
text
Type: SystemString
The text displayed in the node
node
Type: Lassalle.WPF.FlowNode
A node containing the default property values of nodes.
See Also

Reference

Node Class
Node Overload


Node Methods

Node Methods

The Node type exposes the following members.

Methods
 | Name | Description
Public method | BeginEdit | Initiates the editing of the node label. (Inherited from ContentItem.)
Public method | BringIntoView | Ensures that the item is in the viewable area of the control. If the item is not viewable, scrolls the control as necessary to bring the item into view. (Inherited from Item.)
Public method | CancelEdit | Cancels the editing of the ContentItem text. (Inherited from ContentItem.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndEdit | Ends the editing of the node label. (Inherited from ContentItem.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLinkedNode | Returns the node connected via a given link.
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this DependencyObject has been updated. The specific dependency property that changed is reported in the event data. (Inherited from DependencyObject.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Refresh | Forces a repaint of the item. (Inherited from Item.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeImageMargin | Returns true if ImageMargin should be serialized. (Inherited from ContentItem.)
Public method | ShouldSerializePinsLayout | Returns true if the PinsLayout property need to be serialized
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeTextMargin | Returns true if TextMargin should be serialized. (Inherited from ContentItem.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

Node Class


Node.GetLinkedNode Method

NodeGetLinkedNode Method
Returns the node connected via a given link.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Node GetLinkedNode(
    Link link
)
Public Function GetLinkedNode (
    link As Link
) As Node
public:
Node^ GetLinkedNode(
    Link^ link
)
member GetLinkedNode :
        link : Link -> Node

Parameters

link
Type: Lassalle.WPF.FlowLink
A reference to a link object attached to the node

Return Value

Type: Node
A reference to the connected node
Remarks
This method has been added to manage undirected graphs. In some situations, it may be useful to get the node B linked to the node A via a given link, without having to wonder if node A is the origin or the destination.
See Also

Reference

Node Class


Node.ShouldSerializePinsLayout Method

NodeShouldSerializePinsLayout Method
Returns true if the PinsLayout property need to be serialized

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializePinsLayout()
Public Function ShouldSerializePinsLayout As Boolean
public:
bool ShouldSerializePinsLayout()
member ShouldSerializePinsLayout : unit -> bool

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Lassalle.WPF.Flow.Node.ShouldSerializePinsLayout"]

See Also

Reference

Node Class


Node Properties

Node Properties

The Node type exposes the following members.

Properties
 | Name | Description
Public property | AddFlow | The addflow canvas containing this item (Inherited from Item.)
Public property | BackMode | Determines whether the background remains untouched or if the background is filled with the current background color before the text of the item. (Inherited from Item.)
Public property | Bounds | Returns the item bounding rectangle (Inherited from Item.)
Public property | Captions | Returns the collection of the captions attached to this item. (Inherited from Item.)
Public property | DashStyle | Returns/sets the DashStyle of the pen used to draw the item. (Inherited from Item.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Fill | Returns/sets the brush used to fill the item. (Inherited from Item.)
Public property | FontFamily | Gets or sets the font family to use with the item (Inherited from Item.)
Public property | FontSize | Gets or sets the font size to use with the item (Inherited from Item.)
Public property | FontStretch | Gets or sets a FontStretch property that selects a normal, condensed, or expanded font from a FontFamily (Inherited from Item.)
Public property | FontStrikethrough | Indicates whether this Font has a strikethrough TextDecoration (Inherited from Item.)
Public property | FontStyle | Gets or sets the font style to use with the item (Inherited from Item.)
Public property | FontUnderline | Indicates whether this Font is underlined (Inherited from Item.)
Public property | FontWeight | Gets or sets the font weight to use with the item (Inherited from Item.)
Public property | Foreground | Gets or sets the Brush to apply to the text of the item (Inherited from Item.)
Public property | Geometry | Returns/sets the geometry of the ContentItem object (Inherited from ContentItem.)
Public property | Image | Returns/sets the image displayed in the ContentItem object. (Inherited from ContentItem.)
Public property | ImageMargin | Returns/sets the size of the margins for the image of the node. (Inherited from ContentItem.)
Public property | ImagePosition | Returns/sets the picture position in the node. (Inherited from ContentItem.)
Public property | InConnectionMode | Indicates how a coming link is connected to the destination node
Public property | IsClipContent | Determines whether the content of the contentItem object is clipped or not. (Inherited from ContentItem.)
Public property | IsEditable | Determines whether the text of contentItem object can be edited or not (Inherited from ContentItem.)
Public property | IsEditing | Returns/sets a value indicating whether the text of the ContentItem object is currently edited (Inherited from ContentItem.)
Public property | IsHitTestVisible | Determines whether the item can be hit tested. (Inherited from Item.)
Public property | IsImageSizeFitContentArea | Determines whether the image of the contentItem object is adjusted to its size. (Inherited from ContentItem.)
Public property | IsInLinkable | Determines whether the node accept incoming links.
Public property | IsLinkingOver | If True, this property indicates that, during the creation of a link, the mouse is over this node which therefore may be the destination of that link.
Public property | IsOutLinkable | Determines whether the node accept outgoing links.
Public property | IsRotatable | Determines whether the contentItem object can be rotated or not. (Inherited from ContentItem.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelectable | Determines whether the item is selectable by clicking on it with the mouse or unselectable (readonly or inactive). (Inherited from Item.)
Public property | IsSelected | Returns/sets a flag indicating if the item is selected or not. (Inherited from Item.)
Public property | IsXMoveable | Determines whether the contentItem object can be horizontally moved or not. (Inherited from ContentItem.)
Public property | IsXSizeable | Determines whether the contentItem object can be horizontally resized or not. (Inherited from ContentItem.)
Public property | IsYMoveable | Determines whether the contentItem object can be vertically moved or not. (Inherited from ContentItem.)
Public property | IsYSizeable | Determines whether the contentItem object can be vertically resized or not. (Inherited from ContentItem.)
Public property | Links | Returns the collection of links that come to the node or that leave it.
Public property | Location | Returns/sets the position of a node. (Overrides ContentItemLocation.)
Public property | OutConnectionMode | Indicates how a leaving link is connected to the origin node
Public property | Pins | Returns the collection of the pins attached to this node.
Public property | PinsLayout | Sets or gets the list of node pins
Public property | RotationAngle | Returns/sets the rotation angle (in degrees) of a node. (Overrides ContentItemRotationAngle.)
Public property | Size | Returns/sets the size of a node. (Overrides ContentItemSize.)
Public property | Stroke | Returns/sets the brush used to draw the item. (Inherited from Item.)
Public property | StrokeThickness | Returns/sets the pen width used to draw the item. (Inherited from Item.)
Public property | Text | Returns/sets the text associated with the item. In the case of a node, the text is displayed inside the node. It is a multiline display. The text is wrapped automatically inside the node. Linefeed and carriage return characters are allowed. (Inherited from Item.)
Public property | TextMargin | Returns/sets the size of the margins for the text of the node. (Inherited from ContentItem.)
Public property | TextPosition | Returns/sets the position style of the text of the node. (Inherited from ContentItem.)
Public property | TextTrimming | Returns/sets the string trimming of the text in the node. (Inherited from ContentItem.)
Public property | Tooltip | Returns/sets the tooltip associated with the item. (Inherited from Item.)
Public property | Visual | The DrawingVisualobject used to display the item (Inherited from Item.)
Top
See Also

Reference

Node Class


Node.InConnectionMode Property

NodeInConnectionMode Property
Indicates how a coming link is connected to the destination node

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public ConnectionMode InConnectionMode { get; set; }
Public Property InConnectionMode As ConnectionMode
    Get
    Set
public:
property ConnectionMode InConnectionMode {
    ConnectionMode get ();
    void set (ConnectionMode value);
}
member InConnectionMode : ConnectionMode with get, set

Property Value

Type: ConnectionMode
See Also

Reference

Node Class


Node.IsInLinkable Property

NodeIsInLinkable Property
Determines whether the node accept incoming links.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool IsInLinkable { get; set; }
Public Property IsInLinkable As Boolean
    Get
    Set
public:
property bool IsInLinkable {
    bool get ();
    void set (bool value);
}
member IsInLinkable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Node Class


Node.IsLinkingOver Property

NodeIsLinkingOver Property
If True, this property indicates that, during the creation of a link, the mouse is over this node which therefore may be the destination of that link.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool IsLinkingOver { get; }
Public ReadOnly Property IsLinkingOver As Boolean
    Get
public:
property bool IsLinkingOver {
    bool get ();
}
member IsLinkingOver : bool with get

Property Value

Type: Boolean
See Also

Reference

Node Class


Node.IsOutLinkable Property

NodeIsOutLinkable Property
Determines whether the node accept outgoing links.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool IsOutLinkable { get; set; }
Public Property IsOutLinkable As Boolean
    Get
    Set
public:
property bool IsOutLinkable {
    bool get ();
    void set (bool value);
}
member IsOutLinkable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Node Class


Node.Links Property

NodeLinks Property
Returns the collection of links that come to the node or that leave it.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public List<Link> Links { get; }
Public ReadOnly Property Links As List(Of Link)
    Get
public:
property List<Link^>^ Links {
    List<Link^>^ get ();
}
member Links : List<Link> with get

Property Value

Type: List Link
Remarks
Don't use this property which is only provided for the AddFlow infrastructure. You may however use this property for enumeration purposes.
See Also

Reference

Node Class


Node.Location Property

NodeLocation Property
Returns/sets the position of a node.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public override Point Location { get; set; }
Public Overrides Property Location As Point
    Get
    Set
public:
virtual property Point Location {
    Point get () override;
    void set (Point value) override;
}
abstract Location : Point with get, set
override Location : Point with get, set

Property Value

Type: Point
See Also

Reference

Node Class


Node.OutConnectionMode Property

NodeOutConnectionMode Property
Indicates how a leaving link is connected to the origin node

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public ConnectionMode OutConnectionMode { get; set; }
Public Property OutConnectionMode As ConnectionMode
    Get
    Set
public:
property ConnectionMode OutConnectionMode {
    ConnectionMode get ();
    void set (ConnectionMode value);
}
member OutConnectionMode : ConnectionMode with get, set

Property Value

Type: ConnectionMode
See Also

Reference

Node Class


Node.Pins Property

NodePins Property
Returns the collection of the pins attached to this node.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public List<Pin> Pins { get; }
Public ReadOnly Property Pins As List(Of Pin)
    Get
public:
property List<Pin^>^ Pins {
    List<Pin^>^ get ();
}
member Pins : List<Pin> with get

Property Value

Type: List Pin
See Also

Reference

Node Class


Node.PinsLayout Property

NodePinsLayout Property
Sets or gets the list of node pins

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public PointCollection PinsLayout { get; set; }
Public Property PinsLayout As PointCollection
    Get
    Set
public:
property PointCollection^ PinsLayout {
    PointCollection^ get ();
    void set (PointCollection^ value);
}
member PinsLayout : PointCollection with get, set

Property Value

Type: PointCollection
See Also

Reference

Node Class


Node.RotationAngle Property

NodeRotationAngle Property
Returns/sets the rotation angle (in degrees) of a node.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public override double RotationAngle { get; set; }
Public Overrides Property RotationAngle As Double
    Get
    Set
public:
virtual property double RotationAngle {
    double get () override;
    void set (double value) override;
}
abstract RotationAngle : float with get, set
override RotationAngle : float with get, set

Property Value

Type: Double

Implements

IRotatableRotationAngle
See Also

Reference

Node Class


Node.Size Property

NodeSize Property
Returns/sets the size of a node.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public override Size Size { get; set; }
Public Overrides Property Size As Size
    Get
    Set
public:
virtual property Size Size {
    Size get () override;
    void set (Size value) override;
}
abstract Size : Size with get, set
override Size : Size with get, set

Property Value

Type: Size
See Also

Reference

Node Class


NodeCreatedEventArgs Class

NodeCreatedEventArgs Class
Event parameters used for the NodeCreated event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.WPF.FlowNodeCreatedEventArgs

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public class NodeCreatedEventArgs : EventArgs
Public Class NodeCreatedEventArgs
    Inherits EventArgs
public ref class NodeCreatedEventArgs : public EventArgs
type NodeCreatedEventArgs =
    class
        inherit EventArgs
    end

The NodeCreatedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | NodeCreatedEventArgs | Constructor. Creates a new NodeCreatedEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Node | The node that has just been created (read-only
Top
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


NodeCreatedEventArgs Constructor

NodeCreatedEventArgs Constructor
Constructor. Creates a new NodeCreatedEventArgs instance.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public NodeCreatedEventArgs(
    Node node
)
Public Sub New (
    node As Node
)
public:
NodeCreatedEventArgs(
    Node^ node
)
new :
        node : Node -> NodeCreatedEventArgs

Parameters

node
Type: Lassalle.WPF.FlowNode
The created node
See Also

Reference

NodeCreatedEventArgs Class


NodeCreatedEventArgs Methods

NodeCreatedEventArgs Methods

The NodeCreatedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
See Also

Reference

NodeCreatedEventArgs Class


NodeCreatedEventArgs Properties

NodeCreatedEventArgs Properties

The NodeCreatedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Node | The node that has just been created (read-only
Top
See Also

Reference

NodeCreatedEventArgs Class


NodeCreatedEventArgs.Node Property

NodeCreatedEventArgsNode Property
The node that has just been created (read-only

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Node Node { get; }
Public ReadOnly Property Node As Node
    Get
public:
property Node^ Node {
    Node^ get ();
}
member Node : Node with get

Property Value

Type: Node
See Also

Reference

NodeCreatedEventArgs Class


NodeCreatingEventArgs Class

NodeCreatingEventArgs Class
Event parameters used for the NodeCreating event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.WPF.FlowNodeCreatingEventArgs

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public class NodeCreatingEventArgs : EventArgs
Public Class NodeCreatingEventArgs
    Inherits EventArgs
public ref class NodeCreatingEventArgs : public EventArgs
type NodeCreatingEventArgs =
    class
        inherit EventArgs
    end

The NodeCreatingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | NodeCreatingEventArgs | Constructor. Creates a new NodeCreatingEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the node creation should be canceled.
Public property | Rect | Returns rectangle of the node to create
Top
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


NodeCreatingEventArgs Constructor

NodeCreatingEventArgs Constructor
Constructor. Creates a new NodeCreatingEventArgs instance.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public NodeCreatingEventArgs(
    Rect rect
)
Public Sub New (
    rect As Rect
)
public:
NodeCreatingEventArgs(
    Rect rect
)
new :
        rect : Rect -> NodeCreatingEventArgs

Parameters

rect
Type: System.WindowsRect
The bounding rectangle of the node that is going to be created.
See Also

Reference

NodeCreatingEventArgs Class


NodeCreatingEventArgs Methods

NodeCreatingEventArgs Methods

The NodeCreatingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
See Also

Reference

NodeCreatingEventArgs Class


NodeCreatingEventArgs Properties

NodeCreatingEventArgs Properties

The NodeCreatingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the node creation should be canceled.
Public property | Rect | Returns rectangle of the node to create
Top
See Also

Reference

NodeCreatingEventArgs Class


NodeCreatingEventArgs.Cancel Property

NodeCreatingEventArgsCancel Property
Gets/sets a value indicating whether the node creation should be canceled.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public CancelEventArgs Cancel { get; set; }
Public Property Cancel As CancelEventArgs
    Get
    Set
public:
property CancelEventArgs^ Cancel {
    CancelEventArgs^ get ();
    void set (CancelEventArgs^ value);
}
member Cancel : CancelEventArgs with get, set

Property Value

Type: CancelEventArgs
See Also

Reference

NodeCreatingEventArgs Class


NodeCreatingEventArgs.Rect Property

NodeCreatingEventArgsRect Property
Returns rectangle of the node to create

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Rect Rect { get; set; }
Public Property Rect As Rect
    Get
    Set
public:
property Rect Rect {
    Rect get ();
    void set (Rect value);
}
member Rect : Rect with get, set

Property Value

Type: Rect
See Also

Reference

NodeCreatingEventArgs Class


NodeDeletedEventArgs Class

NodeDeletedEventArgs Class
Event parameters used for the NodeDeleted event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.WPF.FlowNodeDeletedEventArgs

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public class NodeDeletedEventArgs : EventArgs
Public Class NodeDeletedEventArgs
    Inherits EventArgs
public ref class NodeDeletedEventArgs : public EventArgs
type NodeDeletedEventArgs =
    class
        inherit EventArgs
    end

The NodeDeletedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | NodeDeletedEventArgs | Constructor. Creates a new NodeDeletedEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Node | The node that has just been removed (read-only)
Top
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


NodeDeletedEventArgs Constructor

NodeDeletedEventArgs Constructor
Constructor. Creates a new NodeDeletedEventArgs instance.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public NodeDeletedEventArgs(
    Node node
)
Public Sub New (
    node As Node
)
public:
NodeDeletedEventArgs(
    Node^ node
)
new :
        node : Node -> NodeDeletedEventArgs

Parameters

node
Type: Lassalle.WPF.FlowNode
The removed node
See Also

Reference

NodeDeletedEventArgs Class


NodeDeletedEventArgs Methods

NodeDeletedEventArgs Methods

The NodeDeletedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
See Also

Reference

NodeDeletedEventArgs Class


NodeDeletedEventArgs Properties

NodeDeletedEventArgs Properties

The NodeDeletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Node | The node that has just been removed (read-only)
Top
See Also

Reference

NodeDeletedEventArgs Class


NodeDeletedEventArgs.Node Property

NodeDeletedEventArgsNode Property
The node that has just been removed (read-only)

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Node Node { get; }
Public ReadOnly Property Node As Node
    Get
public:
property Node^ Node {
    Node^ get ();
}
member Node : Node with get

Property Value

Type: Node
See Also

Reference

NodeDeletedEventArgs Class


NodeDeletingEventArgs Class

NodeDeletingEventArgs Class
Event parameters used for the NodeDeleting event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.WPF.FlowNodeDeletingEventArgs

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public class NodeDeletingEventArgs : EventArgs
Public Class NodeDeletingEventArgs
    Inherits EventArgs
public ref class NodeDeletingEventArgs : public EventArgs
type NodeDeletingEventArgs =
    class
        inherit EventArgs
    end

The NodeDeletingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | NodeDeletingEventArgs | Constructor. Creates a new NodeDeletingEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the node removing should be canceled.
Public property | Node | The node to be removed (read-only)
Top
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


NodeDeletingEventArgs Constructor

NodeDeletingEventArgs Constructor
Constructor. Creates a new NodeDeletingEventArgs instance.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public NodeDeletingEventArgs(
    Node node
)
Public Sub New (
    node As Node
)
public:
NodeDeletingEventArgs(
    Node^ node
)
new :
        node : Node -> NodeDeletingEventArgs

Parameters

node
Type: Lassalle.WPF.FlowNode
The node to be removed
See Also

Reference

NodeDeletingEventArgs Class


NodeDeletingEventArgs Methods

NodeDeletingEventArgs Methods

The NodeDeletingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
See Also

Reference

NodeDeletingEventArgs Class


NodeDeletingEventArgs Properties

NodeDeletingEventArgs Properties

The NodeDeletingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the node removing should be canceled.
Public property | Node | The node to be removed (read-only)
Top
See Also

Reference

NodeDeletingEventArgs Class


NodeDeletingEventArgs.Cancel Property

NodeDeletingEventArgsCancel Property
Gets/sets a value indicating whether the node removing should be canceled.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public CancelEventArgs Cancel { get; set; }
Public Property Cancel As CancelEventArgs
    Get
    Set
public:
property CancelEventArgs^ Cancel {
    CancelEventArgs^ get ();
    void set (CancelEventArgs^ value);
}
member Cancel : CancelEventArgs with get, set

Property Value

Type: CancelEventArgs
See Also

Reference

NodeDeletingEventArgs Class


NodeDeletingEventArgs.Node Property

NodeDeletingEventArgsNode Property
The node to be removed (read-only)

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Node Node { get; }
Public ReadOnly Property Node As Node
    Get
public:
property Node^ Node {
    Node^ get ();
}
member Node : Node with get

Property Value

Type: Node
See Also

Reference

NodeDeletingEventArgs Class


OrgChangedEventArgs Class

OrgChangedEventArgs Class
Event parameters used for the OrgChanged event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.WPF.FlowOrgChangedEventArgs

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public class OrgChangedEventArgs : EventArgs
Public Class OrgChangedEventArgs
    Inherits EventArgs
public ref class OrgChangedEventArgs : public EventArgs
type OrgChangedEventArgs =
    class
        inherit EventArgs
    end

The OrgChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | OrgChangedEventArgs | Constructor. Creates a new OrgChangedEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the change of the origin node of the link should be canceled.
Public property | Link | The link whose origin node is changed (read-only)
Public property | OldOrg | The old origin node (read-only)
Top
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


OrgChangedEventArgs Constructor

OrgChangedEventArgs Constructor
Constructor. Creates a new OrgChangedEventArgs instance.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public OrgChangedEventArgs(
    Link link,
    Node oldOrg
)
Public Sub New (
    link As Link,
    oldOrg As Node
)
public:
OrgChangedEventArgs(
    Link^ link,
    Node^ oldOrg
)
new :
        link : Link *
        oldOrg : Node -> OrgChangedEventArgs

Parameters

link
Type: Lassalle.WPF.FlowLink
The created link
oldOrg
Type: Lassalle.WPF.FlowNode
The old origin node
See Also

Reference

OrgChangedEventArgs Class


OrgChangedEventArgs Methods

OrgChangedEventArgs Methods

The OrgChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
See Also

Reference

OrgChangedEventArgs Class


OrgChangedEventArgs Properties

OrgChangedEventArgs Properties

The OrgChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the change of the origin node of the link should be canceled.
Public property | Link | The link whose origin node is changed (read-only)
Public property | OldOrg | The old origin node (read-only)
Top
See Also

Reference

OrgChangedEventArgs Class


OrgChangedEventArgs.Cancel Property

OrgChangedEventArgsCancel Property
Gets/sets a value indicating whether the change of the origin node of the link should be canceled.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public CancelEventArgs Cancel { get; set; }
Public Property Cancel As CancelEventArgs
    Get
    Set
public:
property CancelEventArgs^ Cancel {
    CancelEventArgs^ get ();
    void set (CancelEventArgs^ value);
}
member Cancel : CancelEventArgs with get, set

Property Value

Type: CancelEventArgs
See Also

Reference

OrgChangedEventArgs Class


OrgChangedEventArgs.Link Property

OrgChangedEventArgsLink Property
The link whose origin node is changed (read-only)

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Link Link { get; }
Public ReadOnly Property Link As Link
    Get
public:
property Link^ Link {
    Link^ get ();
}
member Link : Link with get

Property Value

Type: Link
See Also

Reference

OrgChangedEventArgs Class


OrgChangedEventArgs.OldOrg Property

OrgChangedEventArgsOldOrg Property
The old origin node (read-only)

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Node OldOrg { get; }
Public ReadOnly Property OldOrg As Node
    Get
public:
property Node^ OldOrg {
    Node^ get ();
}
member OldOrg : Node with get

Property Value

Type: Node
See Also

Reference

OrgChangedEventArgs Class


OrgChangingEventArgs Class

OrgChangingEventArgs Class
Event parameters used for the OrgChanging event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.WPF.FlowOrgChangingEventArgs

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public class OrgChangingEventArgs : EventArgs
Public Class OrgChangingEventArgs
    Inherits EventArgs
public ref class OrgChangingEventArgs : public EventArgs
type OrgChangingEventArgs =
    class
        inherit EventArgs
    end

The OrgChangingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | OrgChangingEventArgs | Constructor. Creates a new OrgChangingEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the change of the origin node of the link should be canceled.
Public property | Link | The link whose origin node is changed (read-only)
Public property | Org | The new origin node (read-only)
Top
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


OrgChangingEventArgs Constructor

OrgChangingEventArgs Constructor
Constructor. Creates a new OrgChangingEventArgs instance.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public OrgChangingEventArgs(
    Link link,
    Node org
)
Public Sub New (
    link As Link,
    org As Node
)
public:
OrgChangingEventArgs(
    Link^ link,
    Node^ org
)
new :
        link : Link *
        org : Node -> OrgChangingEventArgs

Parameters

link
Type: Lassalle.WPF.FlowLink
The created link
org
Type: Lassalle.WPF.FlowNode
The new origin node
See Also

Reference

OrgChangingEventArgs Class


OrgChangingEventArgs Methods

OrgChangingEventArgs Methods

The OrgChangingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
See Also

Reference

OrgChangingEventArgs Class


OrgChangingEventArgs Properties

OrgChangingEventArgs Properties

The OrgChangingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the change of the origin node of the link should be canceled.
Public property | Link | The link whose origin node is changed (read-only)
Public property | Org | The new origin node (read-only)
Top
See Also

Reference

OrgChangingEventArgs Class


OrgChangingEventArgs.Cancel Property

OrgChangingEventArgsCancel Property
Gets/sets a value indicating whether the change of the origin node of the link should be canceled.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public CancelEventArgs Cancel { get; set; }
Public Property Cancel As CancelEventArgs
    Get
    Set
public:
property CancelEventArgs^ Cancel {
    CancelEventArgs^ get ();
    void set (CancelEventArgs^ value);
}
member Cancel : CancelEventArgs with get, set

Property Value

Type: CancelEventArgs
See Also

Reference

OrgChangingEventArgs Class


OrgChangingEventArgs.Link Property

OrgChangingEventArgsLink Property
The link whose origin node is changed (read-only)

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Link Link { get; }
Public ReadOnly Property Link As Link
    Get
public:
property Link^ Link {
    Link^ get ();
}
member Link : Link with get

Property Value

Type: Link
See Also

Reference

OrgChangingEventArgs Class


OrgChangingEventArgs.Org Property

OrgChangingEventArgsOrg Property
The new origin node (read-only)

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Node Org { get; }
Public ReadOnly Property Org As Node
    Get
public:
property Node^ Org {
    Node^ get ();
}
member Org : Node with get

Property Value

Type: Node
See Also

Reference

OrgChangingEventArgs Class


Pin Class

Pin Class
A Pin object is the connector displayed in the node, that allows creating a link.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
Lassalle.WPF.FlowPin

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public class Pin : ContentControl
Public Class Pin
    Inherits ContentControl
public ref class Pin : public ContentControl
type Pin =
    class
        inherit ContentControl
    end

The Pin type exposes the following members.

Constructors
 | Name | Description
Public method | Pin | Pin constructor
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture . (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Raises the MouseEnter event (Overrides UIElementOnMouseEnter(MouseEventArgs).)
Protected method | OnMouseLeave | Raises the Mouseleave event (Overrides UIElementOnMouseLeave(MouseEventArgs).)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Raises the MouseMove event. (Overrides UIElementOnMouseMove(MouseEventArgs).)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | In | Determines if the pin accepts "in" links
Public property | Index | Returns the pin index.
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Node | Returns the Node owning this pin.
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Inherited from UIElement.)
Public property | Out | Determines if the pin accepts "out" links
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | Position | Returns the pin position.
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the Uid for this element. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


Pin Constructor

Pin Constructor
Pin constructor

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Pin(
    Node node
)
Public Sub New (
    node As Node
)
public:
Pin(
    Node^ node
)
new :
        node : Node -> Pin

Parameters

node
Type: Lassalle.WPF.FlowNode

[Missing <param name="node"/> documentation for "M:Lassalle.WPF.Flow.Pin.#ctor(Lassalle.WPF.Flow.Node)"]

See Also

Reference

Pin Class


Pin Methods

Pin Methods

The Pin type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture . (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Raises the MouseEnter event (Overrides UIElementOnMouseEnter(MouseEventArgs).)
Protected method | OnMouseLeave | Raises the Mouseleave event (Overrides UIElementOnMouseLeave(MouseEventArgs).)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Raises the MouseMove event. (Overrides UIElementOnMouseMove(MouseEventArgs).)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

Pin Class


Pin.OnMouseEnter Method

PinOnMouseEnter Method
Raises the MouseEnter event

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
protected override void OnMouseEnter(
    MouseEventArgs e
)
Protected Overrides Sub OnMouseEnter (
    e As MouseEventArgs
)
protected:
virtual void OnMouseEnter(
    MouseEventArgs^ e
) override
abstract OnMouseEnter :
        e : MouseEventArgs -> unit
override OnMouseEnter :
        e : MouseEventArgs -> unit

Parameters

e
Type: System.Windows.InputMouseEventArgs
A MouseEventArgs that contains the event data.
See Also

Reference

Pin Class


Pin.OnMouseLeave Method

PinOnMouseLeave Method
Raises the Mouseleave event

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
protected override void OnMouseLeave(
    MouseEventArgs e
)
Protected Overrides Sub OnMouseLeave (
    e As MouseEventArgs
)
protected:
virtual void OnMouseLeave(
    MouseEventArgs^ e
) override
abstract OnMouseLeave :
        e : MouseEventArgs -> unit
override OnMouseLeave :
        e : MouseEventArgs -> unit

Parameters

e
Type: System.Windows.InputMouseEventArgs
A MouseEventArgs that contains the event data.
See Also

Reference

Pin Class


Pin.OnMouseMove Method

PinOnMouseMove Method
Raises the MouseMove event.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
protected override void OnMouseMove(
    MouseEventArgs e
)
Protected Overrides Sub OnMouseMove (
    e As MouseEventArgs
)
protected:
virtual void OnMouseMove(
    MouseEventArgs^ e
) override
abstract OnMouseMove :
        e : MouseEventArgs -> unit
override OnMouseMove :
        e : MouseEventArgs -> unit

Parameters

e
Type: System.Windows.InputMouseEventArgs
A MouseEventArgs that contains the event data.
See Also

Reference

Pin Class


Pin Properties

Pin Properties

The Pin type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | In | Determines if the pin accepts "in" links
Public property | Index | Returns the pin index.
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Node | Returns the Node owning this pin.
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Inherited from UIElement.)
Public property | Out | Determines if the pin accepts "out" links
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | Position | Returns the pin position.
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the Uid for this element. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Top
See Also

Reference

Pin Class


Pin.In Property

PinIn Property
Determines if the pin accepts "in" links

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool In { get; set; }
Public Property In As Boolean
    Get
    Set
public:
property bool In {
    bool get ();
    void set (bool value);
}
member In : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pin Class


Pin.Index Property

PinIndex Property
Returns the pin index.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get
public:
property int Index {
    int get ();
}
member Index : int with get

Property Value

Type: Int32
See Also

Reference

Pin Class


Pin.Node Property

PinNode Property
Returns the Node owning this pin.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Node Node { get; }
Public ReadOnly Property Node As Node
    Get
public:
property Node^ Node {
    Node^ get ();
}
member Node : Node with get

Property Value

Type: Node
See Also

Reference

Pin Class


Pin.Out Property

PinOut Property
Determines if the pin accepts "out" links

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool Out { get; set; }
Public Property Out As Boolean
    Get
    Set
public:
property bool Out {
    bool get ();
    void set (bool value);
}
member Out : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Pin Class


Pin.Position Property

PinPosition Property
Returns the pin position.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Point Position { get; }
Public ReadOnly Property Position As Point
    Get
public:
property Point Position {
    Point get ();
}
member Position : Point with get

Property Value

Type: Point
See Also

Reference

Pin Class


Pin Events

Pin Events

The Pin type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

Pin Class


PinShape Enumeration

PinShape Enumeration
Used to specify the pin shape

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public enum PinShape
Public Enumeration PinShape
public enum class PinShape
type PinShape
Members
Member name | Value | Description
Circle | 0 |
Square | 1 |
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


SelectedItemsLayoutingEventArgs Class

SelectedItemsLayoutingEventArgs Class
Event parameters used for the SelectedItemsLayouting event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.WPF.FlowSelectedItemsLayoutingEventArgs

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public class SelectedItemsLayoutingEventArgs : EventArgs
Public Class SelectedItemsLayoutingEventArgs
    Inherits EventArgs
public ref class SelectedItemsLayoutingEventArgs : public EventArgs
type SelectedItemsLayoutingEventArgs =
    class
        inherit EventArgs
    end

The SelectedItemsLayoutingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | SelectedItemsLayoutingEventArgs | Constructor. Creates a new SelectedNodesLayoutingEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the moving or resizing action should be canceled.
Top
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


SelectedItemsLayoutingEventArgs Constructor

SelectedItemsLayoutingEventArgs Constructor
Constructor. Creates a new SelectedNodesLayoutingEventArgs instance.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public SelectedItemsLayoutingEventArgs()
Public Sub New
public:
SelectedItemsLayoutingEventArgs()
new : unit -> SelectedItemsLayoutingEventArgs
See Also

Reference

SelectedItemsLayoutingEventArgs Class


SelectedItemsLayoutingEventArgs Methods

SelectedItemsLayoutingEventArgs Methods

The SelectedItemsLayoutingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
See Also

Reference

SelectedItemsLayoutingEventArgs Class


SelectedItemsLayoutingEventArgs Properties

SelectedItemsLayoutingEventArgs Properties

The SelectedItemsLayoutingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the moving or resizing action should be canceled.
Top
See Also

Reference

SelectedItemsLayoutingEventArgs Class


SelectedItemsLayoutingEventArgs.Cancel Property

SelectedItemsLayoutingEventArgsCancel Property
Gets/sets a value indicating whether the moving or resizing action should be canceled.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public CancelEventArgs Cancel { get; set; }
Public Property Cancel As CancelEventArgs
    Get
    Set
public:
property CancelEventArgs^ Cancel {
    CancelEventArgs^ get ();
    void set (CancelEventArgs^ value);
}
member Cancel : CancelEventArgs with get, set

Property Value

Type: CancelEventArgs
See Also

Reference

SelectedItemsLayoutingEventArgs Class


SelectedItemsRotatingEventArgs Class

SelectedItemsRotatingEventArgs Class
Event parameters used for the SelectedItemsRotatingEventArgs event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.WPF.FlowSelectedItemsRotatingEventArgs

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public class SelectedItemsRotatingEventArgs : EventArgs
Public Class SelectedItemsRotatingEventArgs
    Inherits EventArgs
public ref class SelectedItemsRotatingEventArgs : public EventArgs
type SelectedItemsRotatingEventArgs =
    class
        inherit EventArgs
    end

The SelectedItemsRotatingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | SelectedItemsRotatingEventArgs | Constructor. Creates a new SelectedItemsRotatingEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the moving or resizing action should be canceled.
Top
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


SelectedItemsRotatingEventArgs Constructor

SelectedItemsRotatingEventArgs Constructor
Constructor. Creates a new SelectedItemsRotatingEventArgs instance.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public SelectedItemsRotatingEventArgs()
Public Sub New
public:
SelectedItemsRotatingEventArgs()
new : unit -> SelectedItemsRotatingEventArgs
See Also

Reference

SelectedItemsRotatingEventArgs Class


SelectedItemsRotatingEventArgs Methods

SelectedItemsRotatingEventArgs Methods

The SelectedItemsRotatingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
See Also

Reference

SelectedItemsRotatingEventArgs Class


SelectedItemsRotatingEventArgs Properties

SelectedItemsRotatingEventArgs Properties

The SelectedItemsRotatingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the moving or resizing action should be canceled.
Top
See Also

Reference

SelectedItemsRotatingEventArgs Class


SelectedItemsRotatingEventArgs.Cancel Property

SelectedItemsRotatingEventArgsCancel Property
Gets/sets a value indicating whether the moving or resizing action should be canceled.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public CancelEventArgs Cancel { get; set; }
Public Property Cancel As CancelEventArgs
    Get
    Set
public:
property CancelEventArgs^ Cancel {
    CancelEventArgs^ get ();
    void set (CancelEventArgs^ value);
}
member Cancel : CancelEventArgs with get, set

Property Value

Type: CancelEventArgs
See Also

Reference

SelectedItemsRotatingEventArgs Class


SelectedLinkStretchingEventArgs Class

SelectedLinkStretchingEventArgs Class
Event parameters used for the SelectedLinkStretching event
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
Lassalle.WPF.FlowSelectedLinkStretchingEventArgs

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public class SelectedLinkStretchingEventArgs : RoutedEventArgs
Public Class SelectedLinkStretchingEventArgs
    Inherits RoutedEventArgs
public ref class SelectedLinkStretchingEventArgs : public RoutedEventArgs
type SelectedLinkStretchingEventArgs =
    class
        inherit RoutedEventArgs
    end

The SelectedLinkStretchingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | SelectedLinkStretchingEventArgs | Constructor. Creates a new SelectedLinkStretchingEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InvokeEventHandler | When overridden in a derived class, provides a way to invoke event handlers in a type-specific way, which can increase efficiency over the base implementation. (Inherited from RoutedEventArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnSetSource | When overridden in a derived class, provides a notification callback entry point whenever the value of the Source property of an instance changes. (Inherited from RoutedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the stretching action should be canceled.
Public property | Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from RoutedEventArgs.)
Public property | Link | The link being stretched (read-only)
Public property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class. (Inherited from RoutedEventArgs.)
Public property | RoutedEvent | Gets or sets the RoutedEvent associated with this RoutedEventArgs instance. (Inherited from RoutedEventArgs.)
Public property | Source | Gets or sets a reference to the object that raised the event. (Inherited from RoutedEventArgs.)
Top
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


SelectedLinkStretchingEventArgs Constructor

SelectedLinkStretchingEventArgs Constructor
Constructor. Creates a new SelectedLinkStretchingEventArgs instance.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public SelectedLinkStretchingEventArgs(
    Link link
)
Public Sub New (
    link As Link
)
public:
SelectedLinkStretchingEventArgs(
    Link^ link
)
new :
        link : Link -> SelectedLinkStretchingEventArgs

Parameters

link
Type: Lassalle.WPF.FlowLink
The link being stretched
See Also

Reference

SelectedLinkStretchingEventArgs Class


SelectedLinkStretchingEventArgs Methods

SelectedLinkStretchingEventArgs Methods

The SelectedLinkStretchingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InvokeEventHandler | When overridden in a derived class, provides a way to invoke event handlers in a type-specific way, which can increase efficiency over the base implementation. (Inherited from RoutedEventArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnSetSource | When overridden in a derived class, provides a notification callback entry point whenever the value of the Source property of an instance changes. (Inherited from RoutedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
See Also

Reference

SelectedLinkStretchingEventArgs Class


SelectedLinkStretchingEventArgs Properties

SelectedLinkStretchingEventArgs Properties

The SelectedLinkStretchingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the stretching action should be canceled.
Public property | Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from RoutedEventArgs.)
Public property | Link | The link being stretched (read-only)
Public property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class. (Inherited from RoutedEventArgs.)
Public property | RoutedEvent | Gets or sets the RoutedEvent associated with this RoutedEventArgs instance. (Inherited from RoutedEventArgs.)
Public property | Source | Gets or sets a reference to the object that raised the event. (Inherited from RoutedEventArgs.)
Top
See Also

Reference

SelectedLinkStretchingEventArgs Class


SelectedLinkStretchingEventArgs.Cancel Property

SelectedLinkStretchingEventArgsCancel Property
Gets/sets a value indicating whether the stretching action should be canceled.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public CancelEventArgs Cancel { get; set; }
Public Property Cancel As CancelEventArgs
    Get
    Set
public:
property CancelEventArgs^ Cancel {
    CancelEventArgs^ get ();
    void set (CancelEventArgs^ value);
}
member Cancel : CancelEventArgs with get, set

Property Value

Type: CancelEventArgs
See Also

Reference

SelectedLinkStretchingEventArgs Class


SelectedLinkStretchingEventArgs.Link Property

SelectedLinkStretchingEventArgsLink Property
The link being stretched (read-only)

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Link Link { get; }
Public ReadOnly Property Link As Link
    Get
public:
property Link^ Link {
    Link^ get ();
}
member Link : Link with get

Property Value

Type: Link
See Also

Reference

SelectedLinkStretchingEventArgs Class


SelectionChangedEventArgs Class

SelectionChangedEventArgs Class
Event parameters used for the SelectionChanged event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.WPF.FlowSelectionChangedEventArgs

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public class SelectionChangedEventArgs : EventArgs
Public Class SelectionChangedEventArgs
    Inherits EventArgs
public ref class SelectionChangedEventArgs : public EventArgs
type SelectionChangedEventArgs =
    class
        inherit EventArgs
    end

The SelectionChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | SelectionChangedEventArgs | Constructor. Creates a new SelectionChangedEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Item | The item whose selection status has changed (read-only)
Top
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


SelectionChangedEventArgs Constructor

SelectionChangedEventArgs Constructor
Constructor. Creates a new SelectionChangedEventArgs instance.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public SelectionChangedEventArgs(
    Item item
)
Public Sub New (
    item As Item
)
public:
SelectionChangedEventArgs(
    Item^ item
)
new :
        item : Item -> SelectionChangedEventArgs

Parameters

item
Type: Lassalle.WPF.FlowItem
The item whose selection status has changed
See Also

Reference

SelectionChangedEventArgs Class


SelectionChangedEventArgs Methods

SelectionChangedEventArgs Methods

The SelectionChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
See Also

Reference

SelectionChangedEventArgs Class


SelectionChangedEventArgs Properties

SelectionChangedEventArgs Properties

The SelectionChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Item | The item whose selection status has changed (read-only)
Top
See Also

Reference

SelectionChangedEventArgs Class


SelectionChangedEventArgs.Item Property

SelectionChangedEventArgsItem Property
The item whose selection status has changed (read-only)

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Item Item { get; }
Public ReadOnly Property Item As Item
    Get
public:
property Item^ Item {
    Item^ get ();
}
member Item : Item with get

Property Value

Type: Item
See Also

Reference

SelectionChangedEventArgs Class


ShadowStyle Enumeration

ShadowStyle Enumeration
Used to specify the node shadow style.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public enum ShadowStyle
Public Enumeration ShadowStyle
public enum class ShadowStyle
type ShadowStyle
Members
Member name | Value | Description
None | 0 | No Shadow (default)
RightBottom | 1 | Right Bottom Shadow
RightTop | 2 | Right Top Shadow
LeftTop | 3 | Left Top Shadow
LeftBottom | 4 | Left Bottom Shadow
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


Task Class

Task Class
Represents an action that can be undone and redone.
Inheritance Hierarchy
SystemObject
Lassalle.WPF.FlowTask

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public abstract class Task
Public MustInherit Class Task
public ref class Task abstract
[<AbstractClassAttribute>]
type Task =  class end

The Task type exposes the following members.

Constructors
 | Name | Description
Public method | Task | Constructor
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Redo | Allows redoing the action
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Undo | Allows undoing the action
Top
Properties
 | Name | Description
Public property | Code | A Code allowing identifying an action
Top
Remarks
This class is an abstract class which defines the interface expected by the AddFlow undo manager for undoing or redoing actions. The Undo and Redo methods are abstract and must be implemented by derived classes.
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


Task Constructor

Task Constructor
Constructor

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Task()
Public Sub New
public:
Task()
new : unit -> Task
See Also

Reference

Task Class


Task Methods

Task Methods

The Task type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Redo | Allows redoing the action
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Undo | Allows undoing the action
Top
See Also

Reference

Task Class


Task.Redo Method

TaskRedo Method
Allows redoing the action

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public virtual void Redo()
Public Overridable Sub Redo
public:
virtual void Redo()
abstract Redo : unit -> unit
override Redo : unit -> unit
See Also

Reference

Task Class


Task.Undo Method

TaskUndo Method
Allows undoing the action

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public virtual void Undo()
Public Overridable Sub Undo
public:
virtual void Undo()
abstract Undo : unit -> unit
override Undo : unit -> unit
See Also

Reference

Task Class


Task Properties

Task Properties

The Task type exposes the following members.

Properties
 | Name | Description
Public property | Code | A Code allowing identifying an action
Top
See Also

Reference

Task Class


Task.Code Property

TaskCode Property
A Code allowing identifying an action

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Action Code { get; set; }
Public Property Code As Action
    Get
    Set
public:
property Action Code {
    Action get ();
    void set (Action value);
}
member Code : Action with get, set

Property Value

Type: Action
See Also

Reference

Task Class


TaskManager Class

TaskManager Class
The class managing the list of tasks and allowing undo/redo.
Inheritance Hierarchy
SystemObject
Lassalle.WPF.FlowTaskManager

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public class TaskManager
Public Class TaskManager
public ref class TaskManager
type TaskManager =  class end

The TaskManager type exposes the following members.

Methods
 | Name | Description
Public method | AddToLastAction | Add the following actions in the last group of actions. This "add" mode will terminate when calling EndAction.
 | BeginAction | Start a group of actions that can be undone in one time.
Public method | Clear | Clears the undo/redo buffer.
Public method | EndAction | Terminate a group of actions that can be undone in one time.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Redo | Redo, if possible, the last action.
Public method | RemoveLastTask | Remove the last task that has been added in the undo/redo buffer.
Public method | SubmitTask | Submit a task (or action) that can be undone and redone.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Undo | Undo the last action performed in the diagram.
Top
Properties
 | Name | Description
Public property | CanRedo | Indicates if there is an action that can be redone.
Public property | CanUndo | Indicates if there is an action that can be undone.
Public property | CanUndoRedo | Determines whether undo/redo is allowed.
Public property | RedoCode | Returns the code of the next redoable action.
Public property | RedoItem | Returns the item involved in the next redoable action.
Public property | SkipUndo | Determines whether the next actions are recorded in the task manager.
Public property | UndoCode | Returns the code of the next undoable action.
Public property | UndoItem | Returns the item involved in the next undoable action.
Public property | UndoLimit | Returns/sets the number of undo commands that can be performed.
Top
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


TaskManager Methods

TaskManager Methods

The TaskManager type exposes the following members.

Methods
 | Name | Description
Public method | AddToLastAction | Add the following actions in the last group of actions. This "add" mode will terminate when calling EndAction.
 | BeginAction | Start a group of actions that can be undone in one time.
Public method | Clear | Clears the undo/redo buffer.
Public method | EndAction | Terminate a group of actions that can be undone in one time.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Redo | Redo, if possible, the last action.
Public method | RemoveLastTask | Remove the last task that has been added in the undo/redo buffer.
Public method | SubmitTask | Submit a task (or action) that can be undone and redone.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Undo | Undo the last action performed in the diagram.
Top
See Also

Reference

TaskManager Class


TaskManager.AddToLastAction Method

TaskManagerAddToLastAction Method
Add the following actions in the last group of actions. This "add" mode will terminate when calling EndAction.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void AddToLastAction()
Public Sub AddToLastAction
public:
void AddToLastAction()
member AddToLastAction : unit -> unit
See Also

Reference

TaskManager Class


TaskManager.BeginAction Method

TaskManagerBeginAction Method
Start a group of actions that can be undone in one time.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void BeginAction(
    int code
)
Public Sub BeginAction (
    code As Integer
)
public:
void BeginAction(
    int code
)
member BeginAction :
        code : int -> unit

Parameters

code
Type: SystemInt32
A positive integer. This code allows to identify a group of action. This code is returned by the UndoCode and RedoCode properties.
Examples
For instance, if, in your application, the user can open a dialog box allowing to change the image of the node, its color and its Text property, you will probably allow that user to undo these 3 basic actions in one time. To do that, add a call to BeginAction before invoking the dialog box and a call to EndAction just after the dialog box termination.
See Also

Reference

TaskManager Class


TaskManager.Clear Method

TaskManagerClear Method
Clears the undo/redo buffer.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

TaskManager Class


TaskManager.EndAction Method

TaskManagerEndAction Method
Terminate a group of actions that can be undone in one time.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void EndAction()
Public Sub EndAction
public:
void EndAction()
member EndAction : unit -> unit
See Also

Reference

TaskManager Class


TaskManager.Redo Method

TaskManagerRedo Method
Redo, if possible, the last action.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void Redo()
Public Sub Redo
public:
void Redo()
member Redo : unit -> unit
See Also

Reference

TaskManager Class


TaskManager.RemoveLastTask Method

TaskManagerRemoveLastTask Method
Remove the last task that has been added in the undo/redo buffer.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void RemoveLastTask()
Public Sub RemoveLastTask
public:
void RemoveLastTask()
member RemoveLastTask : unit -> unit
See Also

Reference

TaskManager Class


TaskManager.SubmitTask Method

TaskManagerSubmitTask Method
Submit a task (or action) that can be undone and redone.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void SubmitTask(
    Task task
)
Public Sub SubmitTask (
    task As Task
)
public:
void SubmitTask(
    Task^ task
)
member SubmitTask :
        task : Task -> unit

Parameters

task
Type: Lassalle.WPF.FlowTask
A task to include in the undo list
See Also

Reference

TaskManager Class


TaskManager.Undo Method

TaskManagerUndo Method
Undo the last action performed in the diagram.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public void Undo()
Public Sub Undo
public:
void Undo()
member Undo : unit -> unit
See Also

Reference

TaskManager Class


TaskManager Properties

TaskManager Properties

The TaskManager type exposes the following members.

Properties
 | Name | Description
Public property | CanRedo | Indicates if there is an action that can be redone.
Public property | CanUndo | Indicates if there is an action that can be undone.
Public property | CanUndoRedo | Determines whether undo/redo is allowed.
Public property | RedoCode | Returns the code of the next redoable action.
Public property | RedoItem | Returns the item involved in the next redoable action.
Public property | SkipUndo | Determines whether the next actions are recorded in the task manager.
Public property | UndoCode | Returns the code of the next undoable action.
Public property | UndoItem | Returns the item involved in the next undoable action.
Public property | UndoLimit | Returns/sets the number of undo commands that can be performed.
Top
See Also

Reference

TaskManager Class


TaskManager.CanRedo Property

TaskManagerCanRedo Property
Indicates if there is an action that can be redone.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool CanRedo { get; }
Public ReadOnly Property CanRedo As Boolean
    Get
public:
property bool CanRedo {
    bool get ();
}
member CanRedo : bool with get

Property Value

Type: Boolean
Remarks
Typically, this method allows to enable or disable the "Redo" menu item of your application.
See Also

Reference

TaskManager Class


TaskManager.CanUndo Property

TaskManagerCanUndo Property
Indicates if there is an action that can be undone.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool CanUndo { get; }
Public ReadOnly Property CanUndo As Boolean
    Get
public:
property bool CanUndo {
    bool get ();
}
member CanUndo : bool with get

Property Value

Type: Boolean
Remarks
Typically, this method allows to enable or disable the "Undo" menu item of your application.
See Also

Reference

TaskManager Class


TaskManager.CanUndoRedo Property

TaskManagerCanUndoRedo Property
Determines whether undo/redo is allowed.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool CanUndoRedo { get; set; }
Public Property CanUndoRedo As Boolean
    Get
    Set
public:
property bool CanUndoRedo {
    bool get ();
    void set (bool value);
}
member CanUndoRedo : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TaskManager Class


TaskManager.RedoCode Property

TaskManagerRedoCode Property
Returns the code of the next redoable action.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Action RedoCode { get; }
Public ReadOnly Property RedoCode As Action
    Get
public:
property Action RedoCode {
    Action get ();
}
member RedoCode : Action with get

Property Value

Type: Action
See Also

Reference

TaskManager Class


TaskManager.RedoItem Property

TaskManagerRedoItem Property
Returns the item involved in the next redoable action.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Item RedoItem { get; }
Public ReadOnly Property RedoItem As Item
    Get
public:
property Item^ RedoItem {
    Item^ get ();
}
member RedoItem : Item with get

Property Value

Type: Item
See Also

Reference

TaskManager Class


TaskManager.SkipUndo Property

TaskManagerSkipUndo Property
Determines whether the next actions are recorded in the task manager.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public bool SkipUndo { get; set; }
Public Property SkipUndo As Boolean
    Get
    Set
public:
property bool SkipUndo {
    bool get ();
    void set (bool value);
}
member SkipUndo : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TaskManager Class


TaskManager.UndoCode Property

TaskManagerUndoCode Property
Returns the code of the next undoable action.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Action UndoCode { get; }
Public ReadOnly Property UndoCode As Action
    Get
public:
property Action UndoCode {
    Action get ();
}
member UndoCode : Action with get

Property Value

Type: Action
See Also

Reference

TaskManager Class


TaskManager.UndoItem Property

TaskManagerUndoItem Property
Returns the item involved in the next undoable action.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public Item UndoItem { get; }
Public ReadOnly Property UndoItem As Item
    Get
public:
property Item^ UndoItem {
    Item^ get ();
}
member UndoItem : Item with get

Property Value

Type: Item
See Also

Reference

TaskManager Class


TaskManager.UndoLimit Property

TaskManagerUndoLimit Property
Returns/sets the number of undo commands that can be performed.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public int UndoLimit { get; set; }
Public Property UndoLimit As Integer
    Get
    Set
public:
property int UndoLimit {
    int get ();
    void set (int value);
}
member UndoLimit : int with get, set

Property Value

Type: Int32
Remarks
  1. UndoLimit limits the size of the Undo buffer. Therefore, you can use this property to save memory.
  2. Setting UndoLimit to zero means that the size of the Undo buffer is unlimited.
See Also

Reference

TaskManager Class


TextPlacementMode Enumeration

TextPlacementMode Enumeration
Used to specify the position of the link text near the link.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public enum TextPlacementMode
Public Enumeration TextPlacementMode
public enum class TextPlacementMode
type TextPlacementMode
Members
Member name | Value | Description
MiddleSegment | 0 | The text is placed at the middle of the medium segment of the link
MiddleLine | 1 | The text is placed at the middle of the link line
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


TextPosition Enumeration

TextPosition Enumeration
Used to specify the position of the text in the ContentItem object.

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public enum TextPosition
Public Enumeration TextPosition
public enum class TextPosition
type TextPosition
Members
Member name | Value | Description
LeftTop | 0 | Text at the left top position of the node
LeftMiddle | 1 | Text at the left middle position of the node
LeftBottom | 2 | Text at the left bottom position of the node
RightTop | 3 | Text at the right top position of the node
RightMiddle | 4 | Text at the right middle position of the node
RightBottom | 5 | Text at the right bottom position of the node
CenterTop | 6 | Text at the center top position of the node
CenterMiddle | 7 | Text at the center middle position of the node
CenterBottom | 8 | Text at the center bottom position of the node
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


ToolTipContentProviderDelegate Delegate

ToolTipContentProviderDelegate Delegate
Returns the content of a Tooltip

Namespace: Lassalle.WPF.Flow
Assembly: Lassalle.WPF.Flow (in Lassalle.WPF.Flow.dll) Version: 2.1.0.2 (2.1.0.2)
Syntax
C#
VB
C++
F#
Copy
public delegate void ToolTipContentProviderDelegate(
    Object tag
)
Public Delegate Sub ToolTipContentProviderDelegate (
    tag As Object
)
public delegate void ToolTipContentProviderDelegate(
    Object^ tag
)
type ToolTipContentProviderDelegate =
    delegate of
        tag : Object -> unit

Parameters

tag
Type: SystemObject
See Also

Reference

Lassalle.WPF.Flow Namespace

Copyright (c) 2008-2016 Lassalle Technologies. All Rights

Send comments on this topic to plassalle@lassalle.com


Lassalle.WPF.Flow.Layout Namespace

Lassalle.WPF.Flow.Layout Namespace

LayoutFlow is a component that performs layouts on a graph. Performing a layout automatically positions its vertices (also called nodes) and edges (also called links).

As LayoutFlow applies to AddFlow diagrams, it can be viewed as an extension of AddFlow for WPF, a control dedicated to the creation and the use of flowchart diagrams or graphs. Note that it is necessary to use AddFlow for WPF to be able to use LayoutFlow

Classes
 | Class | Description
Public class | AboutDialogBox | AboutDialogBox
Public class | LayoutFlow | LayoutFlow is a class that performs some graph layout algorithms.
Public class | StepEventArgs | Event parameters used for the Step event
Enumerations
 | Enumeration | Description
Public enumeration | Orientation | Used to specify the general direction in which the automatic layout algorithm will position vertices.
Public enumeration | SPDrawingStyle | Used to specify the Series Parallel drawing style
Public enumeration | TreeDrawingStyle | Used to specify the tree drawing style


AboutDialogBox Class

AboutDialogBox Class
AboutDialogBox
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.WindowsWindow
Lassalle.WPF.Flow.LayoutAboutDialogBox

Namespace: Lassalle.WPF.Flow.Layout
Assembly: Lassalle.WPF.Flow.Layout (in Lassalle.WPF.Flow.Layout.dll) Version: 2.0.0.1 (2.0.0.1)
Syntax
C#
VB
C++
F#
Copy
public class AboutDialogBox : Window,
    IComponentConnector
Public Class AboutDialogBox
    Inherits Window
    Implements IComponentConnector
public ref class AboutDialogBox : public Window,
    IComponentConnector
type AboutDialogBox =
    class
        inherit Window
        interface IComponentConnector
    end

The AboutDialogBox type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Attempts to bring the window to the foreground and activates it. (Inherited from Window.)
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Override this method to arrange and size a window and its child elements. (Inherited from Window.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Close | Manually closes a Window. (Inherited from Window.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | DragMove | Allows a window to be dragged by a mouse with its left button down over an exposed area of the window's client area. (Inherited from Window.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Public method | Hide | Makes a window invisible. (Inherited from Window.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Override this method to measure the size of a window. (Inherited from Window.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Window.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Window.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Window.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from Window.)
Protected method | OnContentRendered | Raises the ContentRendered event. (Inherited from Window.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns a WindowAutomationPeer object for this Window. (Inherited from Window.)
Protected method | OnDeactivated | Raises the Deactivated event. (Inherited from Window.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Window.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture . (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from Window.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSourceInitialized | Raises the SourceInitialized event. (Inherited from Window.)
Protected method | OnStateChanged | Raises the StateChanged event. (Inherited from Window.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the window is changed. (Inherited from Window.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | Show | Opens a window and returns without waiting for the newly opened window to close. (Inherited from Window.)
Public method | ShowDialog | Opens a window and returns only when the newly opened window is closed. (Inherited from Window.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Inherited from UIElement.)
Public property | AllowsTransparency | Gets or sets a value that indicates whether a window's client area supports transparency. (Inherited from Window.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DialogResult | Gets or sets the dialog result value, which is the value that is returned from the ShowDialog method. (Inherited from Window.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets or sets a window's icon. (Inherited from Window.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsActive | Gets a value that indicates whether the window is active. (Inherited from Window.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | Left | Gets or sets the position of the window's left edge, in relation to the desktop. (Inherited from Window.)
Protected property | LogicalChildren | Gets an enumerator for a window's logical child elements. (Inherited from Window.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | OwnedWindows | Gets a collection of windows for which this window is the owner. (Inherited from Window.)
Public property | Owner | Gets or sets the Window that owns this Window. (Inherited from Window.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Inherited from UIElement.)
Public property | ResizeMode | Gets or sets the resize mode. (Inherited from Window.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RestoreBounds | Gets the size and location of a window before being either minimized or maximized. (Inherited from Window.)
Public property | ShowActivated | Gets or sets a value that indicates whether a window is activated when first shown. (Inherited from Window.)
Public property | ShowInTaskbar | Gets or sets a value that indicates whether the window has a task bar button. (Inherited from Window.)
Public property | SizeToContent | Gets or sets a value that indicates whether a window will automatically size itself to fit the size of its content. (Inherited from Window.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TaskbarItemInfo | Gets or sets the Windows 7 taskbar thumbnail for the Window. (Inherited from Window.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Title | Gets or sets a window's title. (Inherited from Window.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | Top | Gets or sets the position of the window's top edge, in relation to the desktop. (Inherited from Window.)
Public property | Topmost | Gets or sets a value that indicates whether a window appears in the topmost z-order. (Inherited from Window.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the Uid for this element. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | WindowStartupLocation | Gets or sets the position of the window when first shown. (Inherited from Window.)
Public property | WindowState | Gets or sets a value that indicates whether a window is restored, minimized, or maximized. (Inherited from Window.)
Public property | WindowStyle | Gets or sets a window's border style. (Inherited from Window.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when a window becomes the foreground window. (Inherited from Window.)
Public event | Closed | Occurs when the window is about to close. (Inherited from Window.)
Public event | Closing | Occurs directly after Close is called, and can be handled to cancel window closure. (Inherited from Window.)
Public event | ContentRendered | Occurs after a window's content has been rendered. (Inherited from Window.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | Deactivated | Occurs when a window becomes a background window. (Inherited from Window.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LocationChanged | Occurs when the window's location changes. (Inherited from Window.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceInitialized | This event is raised to support interoperation with Win32. See HwndSource. (Inherited from Window.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StateChanged | Occurs when the window's WindowState property changes. (Inherited from Window.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

Lassalle.WPF.Flow.Layout Namespace


AboutDialogBox Methods

AboutDialogBox Methods

The AboutDialogBox type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Attempts to bring the window to the foreground and activates it. (Inherited from Window.)
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Override this method to arrange and size a window and its child elements. (Inherited from Window.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Close | Manually closes a Window. (Inherited from Window.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | DragMove | Allows a window to be dragged by a mouse with its left button down over an exposed area of the window's client area. (Inherited from Window.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Public method | Hide | Makes a window invisible. (Inherited from Window.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Override this method to measure the size of a window. (Inherited from Window.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Window.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Window.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Window.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from Window.)
Protected method | OnContentRendered | Raises the ContentRendered event. (Inherited from Window.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns a WindowAutomationPeer object for this Window. (Inherited from Window.)
Protected method | OnDeactivated | Raises the Deactivated event. (Inherited from Window.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Window.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture . (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from Window.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSourceInitialized | Raises the SourceInitialized event. (Inherited from Window.)
Protected method | OnStateChanged | Raises the StateChanged event. (Inherited from Window.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the window is changed. (Inherited from Window.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | Show | Opens a window and returns without waiting for the newly opened window to close. (Inherited from Window.)
Public method | ShowDialog | Opens a window and returns only when the newly opened window is closed. (Inherited from Window.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

AboutDialogBox Class
Lassalle.WPF.Flow.Layout Namespace


AboutDialogBox.InitializeComponent Method

AboutDialogBoxInitializeComponent Method
InitializeComponent

Namespace: Lassalle.WPF.Flow.Layout
Assembly: Lassalle.WPF.Flow.Layout (in Lassalle.WPF.Flow.Layout.dll) Version: 2.0.0.1 (2.0.0.1)
Syntax
C#
VB
C++
F#
Copy
public void InitializeComponent()
Public Sub InitializeComponent
public:
virtual void InitializeComponent() sealed
abstract InitializeComponent : unit -> unit
override InitializeComponent : unit -> unit

Implements

IComponentConnectorInitializeComponent
See Also

Reference

AboutDialogBox Class
Lassalle.WPF.Flow.Layout Namespace


AboutDialogBox Properties

AboutDialogBox Properties

The AboutDialogBox type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Inherited from UIElement.)
Public property | AllowsTransparency | Gets or sets a value that indicates whether a window's client area supports transparency. (Inherited from Window.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DialogResult | Gets or sets the dialog result value, which is the value that is returned from the ShowDialog method. (Inherited from Window.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets or sets a window's icon. (Inherited from Window.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsActive | Gets a value that indicates whether the window is active. (Inherited from Window.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | Left | Gets or sets the position of the window's left edge, in relation to the desktop. (Inherited from Window.)
Protected property | LogicalChildren | Gets an enumerator for a window's logical child elements. (Inherited from Window.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | OwnedWindows | Gets a collection of windows for which this window is the owner. (Inherited from Window.)
Public property | Owner | Gets or sets the Window that owns this Window. (Inherited from Window.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Inherited from UIElement.)
Public property | ResizeMode | Gets or sets the resize mode. (Inherited from Window.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RestoreBounds | Gets the size and location of a window before being either minimized or maximized. (Inherited from Window.)
Public property | ShowActivated | Gets or sets a value that indicates whether a window is activated when first shown. (Inherited from Window.)
Public property | ShowInTaskbar | Gets or sets a value that indicates whether the window has a task bar button. (Inherited from Window.)
Public property | SizeToContent | Gets or sets a value that indicates whether a window will automatically size itself to fit the size of its content. (Inherited from Window.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TaskbarItemInfo | Gets or sets the Windows 7 taskbar thumbnail for the Window. (Inherited from Window.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Title | Gets or sets a window's title. (Inherited from Window.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | Top | Gets or sets the position of the window's top edge, in relation to the desktop. (Inherited from Window.)
Public property | Topmost | Gets or sets a value that indicates whether a window appears in the topmost z-order. (Inherited from Window.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the Uid for this element. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | WindowStartupLocation | Gets or sets the position of the window when first shown. (Inherited from Window.)
Public property | WindowState | Gets or sets a value that indicates whether a window is restored, minimized, or maximized. (Inherited from Window.)
Public property | WindowStyle | Gets or sets a window's border style. (Inherited from Window.)
Top
See Also

Reference

AboutDialogBox Class
Lassalle.WPF.Flow.Layout Namespace


AboutDialogBox Events

AboutDialogBox Events

The AboutDialogBox type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when a window becomes the foreground window. (Inherited from Window.)
Public event | Closed | Occurs when the window is about to close. (Inherited from Window.)
Public event | Closing | Occurs directly after Close is called, and can be handled to cancel window closure. (Inherited from Window.)
Public event | ContentRendered | Occurs after a window's content has been rendered. (Inherited from Window.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | Deactivated | Occurs when a window becomes a background window. (Inherited from Window.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LocationChanged | Occurs when the window's location changes. (Inherited from Window.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceInitialized | This event is raised to support interoperation with Win32. See HwndSource. (Inherited from Window.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StateChanged | Occurs when the window's WindowState property changes. (Inherited from Window.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

AboutDialogBox Class
Lassalle.WPF.Flow.Layout Namespace


LayoutFlow Class

LayoutFlow Class
LayoutFlow is a class that performs some graph layout algorithms.
Inheritance Hierarchy
SystemObject
Lassalle.WPF.Flow.LayoutLayoutFlow

Namespace: Lassalle.WPF.Flow.Layout
Assembly: Lassalle.WPF.Flow.Layout (in Lassalle.WPF.Flow.Layout.dll) Version: 2.0.0.1 (2.0.0.1)
Syntax
C#
VB
C++
F#
Copy
public static class LayoutFlow
Public NotInheritable Class LayoutFlow
public ref class LayoutFlow abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type LayoutFlow =  class end

The LayoutFlow type exposes the following members.

Methods
Name | Description
GetIsLogical | Gets the value of the IsLogical attached property to a specified element.
HierarchicLayout(AddFlow) | Performs the hierarchical layout
HierarchicLayout(AddFlow, Double, Double, Orientation, Size, Int32) | Performs the hierarchical layout
OrthogonalGridLayout(AddFlow) | Performs the orthogonal grid layout
OrthogonalGridLayout(AddFlow, Orientation, Size, Int32, Size) | Performs the orthogonal grid layout
SeriesParallelLayout(AddFlow) | Performs the Series parallel layout.
SeriesParallelLayout(AddFlow, SPDrawingStyle, Orientation, Double, Double, Size, Size) | Performs the Series parallel layout.
SetIsLogical | Sets the value of the IsLogical attached property to a specified element.
SymmetricLayout(AddFlow) | Performs the symmetic layout.
SymmetricLayout(AddFlow, Double, Size) | Performs the symmetic layout.
SymmetricLayout(AddFlow, Double, Size, Boolean, Boolean, Boolean) | Performs the symmetic layout.
TreeLayout(AddFlow) | Performs the tree layout.
TreeLayout(AddFlow, Double, Double) | Performs the tree layout
TreeLayout(AddFlow, Double, Double, TreeDrawingStyle, Orientation, Size) | Performs the tree layout
Top
Fields
Name | Description
IsLogicalProperty | Identifies the IsLogical attached property.
Top
Attached Properties
 | Name | Description
Public attached property | IsLogical |
Top
See Also

Reference

Lassalle.WPF.Flow.Layout Namespace


LayoutFlow Fields

LayoutFlow Fields

The LayoutFlow type exposes the following members.

Fields
Name | Description
IsLogicalProperty | Identifies the IsLogical attached property.
Top
See Also

Reference

LayoutFlow Class
Lassalle.WPF.Flow.Layout Namespace


LayoutFlow.IsLogicalProperty Field

LayoutFlowIsLogicalProperty Field
Identifies the IsLogical attached property.

Namespace: Lassalle.WPF.Flow.Layout
Assembly: Lassalle.WPF.Flow.Layout (in Lassalle.WPF.Flow.Layout.dll) Version: 2.0.0.1 (2.0.0.1)
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty IsLogicalProperty
Public Shared ReadOnly IsLogicalProperty As DependencyProperty
public:
static initonly DependencyProperty^ IsLogicalProperty
static val IsLogicalProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

LayoutFlow Class
Lassalle.WPF.Flow.Layout Namespace


LayoutFlow Methods

LayoutFlow Methods

The LayoutFlow type exposes the following members.

Methods
Name | Description
GetIsLogical | Gets the value of the IsLogical attached property to a specified element.
HierarchicLayout(AddFlow) | Performs the hierarchical layout
HierarchicLayout(AddFlow, Double, Double, Orientation, Size, Int32) | Performs the hierarchical layout
OrthogonalGridLayout(AddFlow) | Performs the orthogonal grid layout
OrthogonalGridLayout(AddFlow, Orientation, Size, Int32, Size) | Performs the orthogonal grid layout
SeriesParallelLayout(AddFlow) | Performs the Series parallel layout.
SeriesParallelLayout(AddFlow, SPDrawingStyle, Orientation, Double, Double, Size, Size) | Performs the Series parallel layout.
SetIsLogical | Sets the value of the IsLogical attached property to a specified element.
SymmetricLayout(AddFlow) | Performs the symmetic layout.
SymmetricLayout(AddFlow, Double, Size) | Performs the symmetic layout.
SymmetricLayout(AddFlow, Double, Size, Boolean, Boolean, Boolean) | Performs the symmetic layout.
TreeLayout(AddFlow) | Performs the tree layout.
TreeLayout(AddFlow, Double, Double) | Performs the tree layout
TreeLayout(AddFlow, Double, Double, TreeDrawingStyle, Orientation, Size) | Performs the tree layout
Top
See Also

Reference

LayoutFlow Class
Lassalle.WPF.Flow.Layout Namespace


LayoutFlow.GetIsLogical Method

LayoutFlowGetIsLogical Method
Gets the value of the IsLogical attached property to a specified element.

Namespace: Lassalle.WPF.Flow.Layout
Assembly: Lassalle.WPF.Flow.Layout (in Lassalle.WPF.Flow.Layout.dll) Version: 2.0.0.1 (2.0.0.1)
Syntax
C#
VB
C++
F#
Copy
public static bool GetIsLogical(
    DependencyObject item
)
Public Shared Function GetIsLogical (
    item As DependencyObject
) As Boolean
public:
static bool GetIsLogical(
    DependencyObject^ item
)
static member GetIsLogical :
        item : DependencyObject -> bool

Parameters

item
Type: System.WindowsDependencyObject
The item to which the attached property is read

Return Value

Type: Boolean
The IsLogical property value for the item.
See Also

Reference

LayoutFlow Class
Lassalle.WPF.Flow.Layout Namespace


LayoutFlow.HierarchicLayout Method

LayoutFlowHierarchicLayout Method
Overload List
Name | Description
HierarchicLayout(AddFlow) | Performs the hierarchical layout
HierarchicLayout(AddFlow, Double, Double, Orientation, Size, Int32) | Performs the hierarchical layout
Top
See Also

Reference

LayoutFlow Class
Lassalle.WPF.Flow.Layout Namespace


LayoutFlow.HierarchicLayout Method (AddFlow)

LayoutFlowHierarchicLayout Method (AddFlow)
Performs the hierarchical layout

Namespace: Lassalle.WPF.Flow.Layout
Assembly: Lassalle.WPF.Flow.Layout (in Lassalle.WPF.Flow.Layout.dll) Version: 2.0.0.1 (2.0.0.1)
Syntax
C#
VB
C++
F#
Copy
public static void HierarchicLayout(
    AddFlow addflow
)
Public Shared Sub HierarchicLayout (
    addflow As AddFlow
)
public:
static void HierarchicLayout(
    AddFlow^ addflow
)
static member HierarchicLayout :
        addflow : AddFlow -> unit

Parameters

addflow
Type: Lassalle.WPF.FlowAddFlow
The AddFlow control
See Also

Reference

LayoutFlow Class
HierarchicLayout Overload
Lassalle.WPF.Flow.Layout Namespace


LayoutFlow.HierarchicLayout Method (AddFlow, Double, Double, Orientation, Size, Int32)

LayoutFlowHierarchicLayout Method (AddFlow, Double, Double, Orientation, Size, Int32)
Performs the hierarchical layout

Namespace: Lassalle.WPF.Flow.Layout
Assembly: Lassalle.WPF.Flow.Layout (in Lassalle.WPF.Flow.Layout.dll) Version: 2.0.0.1 (2.0.0.1)
Syntax
C#
VB
C++
F#
Copy
public static void HierarchicLayout(
    AddFlow addflow,
    double layerDistance,
    double vertexDistance,
    Orientation orientation,
    Size marginSize,
    int layerWidth
)
Public Shared Sub HierarchicLayout (
    addflow As AddFlow,
    layerDistance As Double,
    vertexDistance As Double,
    orientation As Orientation,
    marginSize As Size,
    layerWidth As Integer
)
public:
static void HierarchicLayout(
    AddFlow^ addflow,
    double layerDistance,
    double vertexDistance,
    Orientation orientation,
    Size marginSize,
    int layerWidth
)
static member HierarchicLayout :
        addflow : AddFlow *
        layerDistance : float *
        vertexDistance : float *
        orientation : Orientation *
        marginSize : Size *
        layerWidth : int -> unit

Parameters

addflow
Type: Lassalle.WPF.FlowAddFlow
The AddFlow control
layerDistance
Type: SystemDouble
The distance between two adjacent layers.
vertexDistance
Type: SystemDouble
The distance between two adjacent vertices
orientation
Type: Lassalle.WPF.Flow.LayoutOrientation
The general direction in which the automatic layout algorithm will position vertices.
marginSize
Type: System.WindowsSize
The horizontal and vertical margin size.
layerWidth
Type: SystemInt32
The maximum number of vertices in a layer. If it is 0, then there is no maximum number of vertices.
See Also

Reference

LayoutFlow Class
HierarchicLayout Overload
Lassalle.WPF.Flow.Layout Namespace


LayoutFlow.OrthogonalGridLayout Method

LayoutFlowOrthogonalGridLayout Method
Overload List
Name | Description
OrthogonalGridLayout(AddFlow) | Performs the orthogonal grid layout
OrthogonalGridLayout(AddFlow, Orientation, Size, Int32, Size) | Performs the orthogonal grid layout
Top
See Also

Reference

LayoutFlow Class
Lassalle.WPF.Flow.Layout Namespace


LayoutFlow.OrthogonalGridLayout Method (AddFlow)

LayoutFlowOrthogonalGridLayout Method (AddFlow)
Performs the orthogonal grid layout

Namespace: Lassalle.WPF.Flow.Layout
Assembly: Lassalle.WPF.Flow.Layout (in Lassalle.WPF.Flow.Layout.dll) Version: 2.0.0.1 (2.0.0.1)
Syntax
C#
VB
C++
F#
Copy
public static void OrthogonalGridLayout(
    AddFlow addflow
)
Public Shared Sub OrthogonalGridLayout (
    addflow As AddFlow
)
public:
static void OrthogonalGridLayout(
    AddFlow^ addflow
)
static member OrthogonalGridLayout :
        addflow : AddFlow -> unit

Parameters

addflow
Type: Lassalle.WPF.FlowAddFlow
The AddFlow control
See Also

Reference

LayoutFlow Class
OrthogonalGridLayout Overload
Lassalle.WPF.Flow.Layout Namespace


LayoutFlow.OrthogonalGridLayout Method (AddFlow, Orientation, Size, Int32, Size)

LayoutFlowOrthogonalGridLayout Method (AddFlow, Orientation, Size, Int32, Size)
Performs the orthogonal grid layout

Namespace: Lassalle.WPF.Flow.Layout
Assembly: Lassalle.WPF.Flow.Layout (in Lassalle.WPF.Flow.Layout.dll) Version: 2.0.0.1 (2.0.0.1)
Syntax
C#
VB
C++
F#
Copy
public static void OrthogonalGridLayout(
    AddFlow addflow,
    Orientation orientation,
    Size gridSize,
    int nodeSizeRatio,
    Size marginSize
)
Public Shared Sub OrthogonalGridLayout (
    addflow As AddFlow,
    orientation As Orientation,
    gridSize As Size,
    nodeSizeRatio As Integer,
    marginSize As Size
)
public:
static void OrthogonalGridLayout(
    AddFlow^ addflow,
    Orientation orientation,
    Size gridSize,
    int nodeSizeRatio,
    Size marginSize
)
static member OrthogonalGridLayout :
        addflow : AddFlow *
        orientation : Orientation *
        gridSize : Size *
        nodeSizeRatio : int *
        marginSize : Size -> unit

Parameters

addflow
Type: Lassalle.WPF.FlowAddFlow
The AddFlow control
orientation
Type: Lassalle.WPF.Flow.LayoutOrientation
Layout orientation
gridSize
Type: System.WindowsSize
The horizontal and vertical grid size
nodeSizeRatio
Type: SystemInt32
The node size expressed in percentage of the grid size
marginSize
Type: System.WindowsSize
The horizontal and vertical margin size
See Also

Reference

LayoutFlow Class
OrthogonalGridLayout Overload
Lassalle.WPF.Flow.Layout Namespace


LayoutFlow.SeriesParallelLayout Method

LayoutFlowSeriesParallelLayout Method
Overload List
Name | Description
SeriesParallelLayout(AddFlow) | Performs the Series parallel layout.
SeriesParallelLayout(AddFlow, SPDrawingStyle, Orientation, Double, Double, Size, Size) | Performs the Series parallel layout.
Top
See Also

Reference

LayoutFlow Class
Lassalle.WPF.Flow.Layout Namespace


LayoutFlow.SeriesParallelLayout Method (AddFlow)

LayoutFlowSeriesParallelLayout Method (AddFlow)
Performs the Series parallel layout.

Namespace: Lassalle.WPF.Flow.Layout
Assembly: Lassalle.WPF.Flow.Layout (in Lassalle.WPF.Flow.Layout.dll) Version: 2.0.0.1 (2.0.0.1)
Syntax
C#
VB
C++
F#
Copy
public static void SeriesParallelLayout(
    AddFlow addflow
)
Public Shared Sub SeriesParallelLayout (
    addflow As AddFlow
)
public:
static void SeriesParallelLayout(
    AddFlow^ addflow
)
static member SeriesParallelLayout :
        addflow : AddFlow -> unit

Parameters

addflow
Type: Lassalle.WPF.FlowAddFlow
The AddFlow control
See Also

Reference

LayoutFlow Class
SeriesParallelLayout Overload
Lassalle.WPF.Flow.Layout Namespace


LayoutFlow.SeriesParallelLayout Method (AddFlow, SPDrawingStyle, Orientation, Double, Double, Size, Size)

LayoutFlowSeriesParallelLayout Method (AddFlow, SPDrawingStyle, Orientation, Double, Double, Size, Size)
Performs the Series parallel layout.

Namespace: Lassalle.WPF.Flow.Layout
Assembly: Lassalle.WPF.Flow.Layout (in Lassalle.WPF.Flow.Layout.dll) Version: 2.0.0.1 (2.0.0.1)
Syntax
C#
VB
C++
F#
Copy
public static void SeriesParallelLayout(
    AddFlow addflow,
    SPDrawingStyle drawingStyle,
    Orientation orientation,
    double layerDistance,
    double vertexDistance,
    Size vertexSize,
    Size marginSize
)
Public Shared Sub SeriesParallelLayout (
    addflow As AddFlow,
    drawingStyle As SPDrawingStyle,
    orientation As Orientation,
    layerDistance As Double,
    vertexDistance As Double,
    vertexSize As Size,
    marginSize As Size
)
public:
static void SeriesParallelLayout(
    AddFlow^ addflow,
    SPDrawingStyle drawingStyle,
    Orientation orientation,
    double layerDistance,
    double vertexDistance,
    Size vertexSize,
    Size marginSize
)
static member SeriesParallelLayout :
        addflow : AddFlow *
        drawingStyle : SPDrawingStyle *
        orientation : Orientation *
        layerDistance : float *
        vertexDistance : float *
        vertexSize : Size *
        marginSize : Size -> unit

Parameters

addflow
Type: Lassalle.WPF.FlowAddFlow
The AddFlow control
drawingStyle
Type: Lassalle.WPF.Flow.LayoutSPDrawingStyle
the Series Parallel drawing style
orientation
Type: Lassalle.WPF.Flow.LayoutOrientation
the general direction in which the automatic layout algorithm will position vertices
layerDistance
Type: SystemDouble
the distance between two adjacent layers
vertexDistance
Type: SystemDouble
the distance between two adjacent vertices
vertexSize
Type: System.WindowsSize
the horizontal and vertical vertex size
marginSize
Type: System.WindowsSize
the horizontal and vertical margin size
See Also

Reference

LayoutFlow Class
SeriesParallelLayout Overload
Lassalle.WPF.Flow.Layout Namespace


LayoutFlow.SetIsLogical Method

LayoutFlowSetIsLogical Method
Sets the value of the IsLogical attached property to a specified element.

Namespace: Lassalle.WPF.Flow.Layout
Assembly: Lassalle.WPF.Flow.Layout (in Lassalle.WPF.Flow.Layout.dll) Version: 2.0.0.1 (2.0.0.1)
Syntax
C#
VB
C++
F#
Copy
public static void SetIsLogical(
    DependencyObject item,
    bool value
)
Public Shared Sub SetIsLogical (
    item As DependencyObject,
    value As Boolean
)
public:
static void SetIsLogical(
    DependencyObject^ item,
    bool value
)
static member SetIsLogical :
        item : DependencyObject *
        value : bool -> unit

Parameters

item
Type: System.WindowsDependencyObject
The item to which the attached property is written
value
Type: SystemBoolean
The needed boolean value
See Also

Reference

LayoutFlow Class
Lassalle.WPF.Flow.Layout Namespace


LayoutFlow.SymmetricLayout Method

LayoutFlowSymmetricLayout Method
Overload List
Name | Description
SymmetricLayout(AddFlow) | Performs the symmetic layout.
SymmetricLayout(AddFlow, Double, Size) | Performs the symmetic layout.
SymmetricLayout(AddFlow, Double, Size, Boolean, Boolean, Boolean) | Performs the symmetic layout.
Top
See Also

Reference

LayoutFlow Class
Lassalle.WPF.Flow.Layout Namespace


LayoutFlow.SymmetricLayout Method (AddFlow)

LayoutFlowSymmetricLayout Method (AddFlow)
Performs the symmetic layout.

Namespace: Lassalle.WPF.Flow.Layout
Assembly: Lassalle.WPF.Flow.Layout (in Lassalle.WPF.Flow.Layout.dll) Version: 2.0.0.1 (2.0.0.1)
Syntax
C#
VB
C++
F#
Copy
public static void SymmetricLayout(
    AddFlow addflow
)
Public Shared Sub SymmetricLayout (
    addflow As AddFlow
)
public:
static void SymmetricLayout(
    AddFlow^ addflow
)
static member SymmetricLayout :
        addflow : AddFlow -> unit

Parameters

addflow
Type: Lassalle.WPF.FlowAddFlow
The AddFlow control
See Also

Reference

LayoutFlow Class
SymmetricLayout Overload
Lassalle.WPF.Flow.Layout Namespace


LayoutFlow.SymmetricLayout Method (AddFlow, Double, Size)

LayoutFlowSymmetricLayout Method (AddFlow, Double, Size)
Performs the symmetic layout.

Namespace: Lassalle.WPF.Flow.Layout
Assembly: Lassalle.WPF.Flow.Layout (in Lassalle.WPF.Flow.Layout.dll) Version: 2.0.0.1 (2.0.0.1)
Syntax
C#
VB
C++
F#
Copy
public static void SymmetricLayout(
    AddFlow addflow,
    double distance,
    Size marginSize
)
Public Shared Sub SymmetricLayout (
    addflow As AddFlow,
    distance As Double,
    marginSize As Size
)
public:
static void SymmetricLayout(
    AddFlow^ addflow,
    double distance,
    Size marginSize
)
static member SymmetricLayout :
        addflow : AddFlow *
        distance : float *
        marginSize : Size -> unit

Parameters

addflow
Type: Lassalle.WPF.FlowAddFlow
The AddFlow control
distance
Type: SystemDouble
The distance between two vertices
marginSize
Type: System.WindowsSize
The horizontal and vertical margin size
See Also

Reference

LayoutFlow Class
SymmetricLayout Overload
Lassalle.WPF.Flow.Layout Namespace


LayoutFlow.SymmetricLayout Method (AddFlow, Double, Size, Boolean, Boolean, Boolean)

LayoutFlowSymmetricLayout Method (AddFlow, Double, Size, Boolean, Boolean, Boolean)
Performs the symmetic layout.

Namespace: Lassalle.WPF.Flow.Layout
Assembly: Lassalle.WPF.Flow.Layout (in Lassalle.WPF.Flow.Layout.dll) Version: 2.0.0.1 (2.0.0.1)
Syntax
C#
VB
C++
F#
Copy
public static void SymmetricLayout(
    AddFlow addflow,
    double distance,
    Size marginSize,
    bool unmoveableNodesAccepted,
    bool randomStart,
    bool sendStepEvent
)
Public Shared Sub SymmetricLayout (
    addflow As AddFlow,
    distance As Double,
    marginSize As Size,
    unmoveableNodesAccepted As Boolean,
    randomStart As Boolean,
    sendStepEvent As Boolean
)
public:
static void SymmetricLayout(
    AddFlow^ addflow,
    double distance,
    Size marginSize,
    bool unmoveableNodesAccepted,
    bool randomStart,
    bool sendStepEvent
)
static member SymmetricLayout :
        addflow : AddFlow *
        distance : float *
        marginSize : Size *
        unmoveableNodesAccepted : bool *
        randomStart : bool *
        sendStepEvent : bool -> unit

Parameters

addflow
Type: Lassalle.WPF.FlowAddFlow
The AddFlow control
distance
Type: SystemDouble
The distance between two vertices
marginSize
Type: System.WindowsSize
The horizontal and vertical margin size
unmoveableNodesAccepted
Type: SystemBoolean
Determines whether the layout takes account of the IsXMoveable and IsYMoveable properties of the nodes.
randomStart
Type: SystemBoolean
Determines whether the nodes are placed randomly at the beginning of the layout. Normally, SFlow starts by placing the nodes randomly on the control, except if randomStart is False.
sendStepEvent
Type: SystemBoolean
Determines whether the Step event is fired at each iteration of the layout algorithm. This property could be used for instance to terminate the algorithm.
Remarks
If the IsXMoveable property of a node is false and if UnmoveableNodesAccepted is true, then the SFlow layout will move it only vertically. If the IsYMoveable property of a node is false and if unmoveableNodesAccepted is true, then the SFlow layout will move it only horizontally. If both the IsXMoveable and IsYMoveable properties are false (and if unmoveableNodesAccepted is true), not move neither vertically neither horizontally.
See Also

Reference

LayoutFlow Class
SymmetricLayout Overload
Lassalle.WPF.Flow.Layout Namespace


LayoutFlow.TreeLayout Method

LayoutFlowTreeLayout Method
Overload List
Name | Description
TreeLayout(AddFlow) | Performs the tree layout.
TreeLayout(AddFlow, Double, Double) | Performs the tree layout
TreeLayout(AddFlow, Double, Double, TreeDrawingStyle, Orientation, Size) | Performs the tree layout
Top
See Also

Reference

LayoutFlow Class
Lassalle.WPF.Flow.Layout Namespace


LayoutFlow.TreeLayout Method (AddFlow)

LayoutFlowTreeLayout Method (AddFlow)
Performs the tree layout.

Namespace: Lassalle.WPF.Flow.Layout
Assembly: Lassalle.WPF.Flow.Layout (in Lassalle.WPF.Flow.Layout.dll) Version: 2.0.0.1 (2.0.0.1)
Syntax
C#
VB
C++
F#
Copy
public static void TreeLayout(
    AddFlow addflow
)
Public Shared Sub TreeLayout (
    addflow As AddFlow
)
public:
static void TreeLayout(
    AddFlow^ addflow
)
static member TreeLayout :
        addflow : AddFlow -> unit

Parameters

addflow
Type: Lassalle.WPF.FlowAddFlow
The AddFlow control
See Also

Reference

LayoutFlow Class
TreeLayout Overload
Lassalle.WPF.Flow.Layout Namespace


LayoutFlow.TreeLayout Method (AddFlow, Double, Double)

LayoutFlowTreeLayout Method (AddFlow, Double, Double)
Performs the tree layout

Namespace: Lassalle.WPF.Flow.Layout
Assembly: Lassalle.WPF.Flow.Layout (in Lassalle.WPF.Flow.Layout.dll) Version: 2.0.0.1 (2.0.0.1)
Syntax
C#
VB
C++
F#
Copy
public static void TreeLayout(
    AddFlow addflow,
    double layerDistance,
    double vertexDistance
)
Public Shared Sub TreeLayout (
    addflow As AddFlow,
    layerDistance As Double,
    vertexDistance As Double
)
public:
static void TreeLayout(
    AddFlow^ addflow,
    double layerDistance,
    double vertexDistance
)
static member TreeLayout :
        addflow : AddFlow *
        layerDistance : float *
        vertexDistance : float -> unit

Parameters

addflow
Type: Lassalle.WPF.FlowAddFlow
The AddFlow control
layerDistance
Type: SystemDouble
Distance between two adjacent layers.
vertexDistance
Type: SystemDouble
Distance between two adjacent vertices
See Also

Reference

LayoutFlow Class
TreeLayout Overload
Lassalle.WPF.Flow.Layout Namespace


LayoutFlow.TreeLayout Method (AddFlow, Double, Double, TreeDrawingStyle, Orientation, Size)

LayoutFlowTreeLayout Method (AddFlow, Double, Double, TreeDrawingStyle, Orientation, Size)
Performs the tree layout

Namespace: Lassalle.WPF.Flow.Layout
Assembly: Lassalle.WPF.Flow.Layout (in Lassalle.WPF.Flow.Layout.dll) Version: 2.0.0.1 (2.0.0.1)
Syntax
C#
VB
C++
F#
Copy
public static void TreeLayout(
    AddFlow addflow,
    double layerDistance,
    double vertexDistance,
    TreeDrawingStyle drawingStyle,
    Orientation orientation,
    Size marginSize
)
Public Shared Sub TreeLayout (
    addflow As AddFlow,
    layerDistance As Double,
    vertexDistance As Double,
    drawingStyle As TreeDrawingStyle,
    orientation As Orientation,
    marginSize As Size
)
public:
static void TreeLayout(
    AddFlow^ addflow,
    double layerDistance,
    double vertexDistance,
    TreeDrawingStyle drawingStyle,
    Orientation orientation,
    Size marginSize
)
static member TreeLayout :
        addflow : AddFlow *
        layerDistance : float *
        vertexDistance : float *
        drawingStyle : TreeDrawingStyle *
        orientation : Orientation *
        marginSize : Size -> unit

Parameters

addflow
Type: Lassalle.WPF.FlowAddFlow
The AddFlow control
layerDistance
Type: SystemDouble
Distance between two adjacent layers.
vertexDistance
Type: SystemDouble
Distance between two adjacent vertices
drawingStyle
Type: Lassalle.WPF.Flow.LayoutTreeDrawingStyle
tree drawing style
orientation
Type: Lassalle.WPF.Flow.LayoutOrientation
Layout orientation
marginSize
Type: System.WindowsSize
Horizontal and vertical margin size.
See Also

Reference

LayoutFlow Class
TreeLayout Overload
Lassalle.WPF.Flow.Layout Namespace


LayoutFlow Attached Properties

LayoutFlow Attached Properties

The LayoutFlow type exposes the following members.

Attached Properties
 | Name | Description
Public attached property | IsLogical |
Top
See Also

Reference

LayoutFlow Class
Lassalle.WPF.Flow.Layout Namespace


LayoutFlow.IsLogical Attached Property

LayoutFlowIsLogical Attached Property

[Missing <summary> documentation for "P:Lassalle.WPF.Flow.Layout.LayoutFlow.IsLogical"]

Namespace: Lassalle.WPF.Flow.Layout
Assembly: Lassalle.WPF.Flow.Layout (in Lassalle.WPF.Flow.Layout.dll) Version: 2.0.0.1 (2.0.0.1)
Syntax
C#
VB
C++
F#
Copy
See GetIsLogical, SetIsLogical
See GetIsLogical, SetIsLogical
See GetIsLogical, SetIsLogical
See GetIsLogical, SetIsLogical

Property Value

Type: Boolean
See Also

Reference

LayoutFlow Class
Lassalle.WPF.Flow.Layout Namespace


Orientation Enumeration

Orientation Enumeration
Used to specify the general direction in which the automatic layout algorithm will position vertices.

Namespace: Lassalle.WPF.Flow.Layout
Assembly: Lassalle.WPF.Flow.Layout (in Lassalle.WPF.Flow.Layout.dll) Version: 2.0.0.1 (2.0.0.1)
Syntax
C#
VB
C++
F#
Copy
public enum Orientation
Public Enumeration Orientation
public enum class Orientation
type Orientation
Members
Member name | Value | Description
North | 0 | Start at the top and proceed downwards
East | 1 | Start at the right side and proceed toward the left
South | 2 | Start at the bottom and proceed upwards
West | 3 | Start on the left side and proceed toward the right
See Also

Reference

Lassalle.WPF.Flow.Layout Namespace


SPDrawingStyle Enumeration

SPDrawingStyle Enumeration
Used to specify the Series Parallel drawing style

Namespace: Lassalle.WPF.Flow.Layout
Assembly: Lassalle.WPF.Flow.Layout (in Lassalle.WPF.Flow.Layout.dll) Version: 2.0.0.1 (2.0.0.1)
Syntax
C#
VB
C++
F#
Copy
public enum SPDrawingStyle
Public Enumeration SPDrawingStyle
public enum class SPDrawingStyle
type SPDrawingStyle
Members
Member name | Value | Description
BusOrthogonalDrawing | 0 | The has a bus above. The sink has a bus below. All other vertices have exactly one bus above and one bus below.
StraightLine | 1 | Each edge is a straight line.
VisibilityDrawing | 2 | Each vertex is mapped as a horizontal lne segment and each edge to a vertical line segment
See Also

Reference

Lassalle.WPF.Flow.Layout Namespace


StepEventArgs Class

StepEventArgs Class
Event parameters used for the Step event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Lassalle.WPF.Flow.LayoutStepEventArgs

Namespace: Lassalle.WPF.Flow.Layout
Assembly: Lassalle.WPF.Flow.Layout (in Lassalle.WPF.Flow.Layout.dll) Version: 2.0.0.1 (2.0.0.1)
Syntax
C#
VB
C++
F#
Copy
public class StepEventArgs : EventArgs
Public Class StepEventArgs
    Inherits EventArgs
public ref class StepEventArgs : public EventArgs
type StepEventArgs =
    class
        inherit EventArgs
    end

The StepEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | StepEventArgs | Constructor. Creates a new StepEventArgs instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the layout should be canceled.
Public property | Iteration | Gets the current iteration of the layout algorithm.
Top
See Also

Reference

Lassalle.WPF.Flow.Layout Namespace


StepEventArgs Constructor

StepEventArgs Constructor
Constructor. Creates a new StepEventArgs instance.

Namespace: Lassalle.WPF.Flow.Layout
Assembly: Lassalle.WPF.Flow.Layout (in Lassalle.WPF.Flow.Layout.dll) Version: 2.0.0.1 (2.0.0.1)
Syntax
C#
VB
C++
F#
Copy
public StepEventArgs(
    int iteration
)
Public Sub New (
    iteration As Integer
)
public:
StepEventArgs(
    int iteration
)
new :
        iteration : int -> StepEventArgs

Parameters

iteration
Type: SystemInt32
Current iteration of the layout algorithm
See Also

Reference

StepEventArgs Class
Lassalle.WPF.Flow.Layout Namespace


StepEventArgs Methods

StepEventArgs Methods

The StepEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Top
See Also

Reference

StepEventArgs Class
Lassalle.WPF.Flow.Layout Namespace


StepEventArgs Properties

StepEventArgs Properties

The StepEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets/sets a value indicating whether the layout should be canceled.
Public property | Iteration | Gets the current iteration of the layout algorithm.
Top
See Also

Reference

StepEventArgs Class
Lassalle.WPF.Flow.Layout Namespace


StepEventArgs.Cancel Property

StepEventArgsCancel Property
Gets/sets a value indicating whether the layout should be canceled.

Namespace: Lassalle.WPF.Flow.Layout
Assembly: Lassalle.WPF.Flow.Layout (in Lassalle.WPF.Flow.Layout.dll) Version: 2.0.0.1 (2.0.0.1)
Syntax
C#
VB
C++
F#
Copy
public CancelEventArgs Cancel { get; set; }
Public Property Cancel As CancelEventArgs
    Get
    Set
public:
property CancelEventArgs^ Cancel {
    CancelEventArgs^ get ();
    void set (CancelEventArgs^ value);
}
member Cancel : CancelEventArgs with get, set

Property Value

Type: CancelEventArgs
See Also

Reference

StepEventArgs Class
Lassalle.WPF.Flow.Layout Namespace


StepEventArgs.Iteration Property

StepEventArgsIteration Property
Gets the current iteration of the layout algorithm.

Namespace: Lassalle.WPF.Flow.Layout
Assembly: Lassalle.WPF.Flow.Layout (in Lassalle.WPF.Flow.Layout.dll) Version: 2.0.0.1 (2.0.0.1)
Syntax
C#
VB
C++
F#
Copy
public int Iteration { get; }
Public ReadOnly Property Iteration As Integer
    Get
public:
property int Iteration {
    int get ();
}
member Iteration : int with get

Property Value

Type: Int32
See Also

Reference

StepEventArgs Class
Lassalle.WPF.Flow.Layout Namespace


TreeDrawingStyle Enumeration

TreeDrawingStyle Enumeration
Used to specify the tree drawing style

Namespace: Lassalle.WPF.Flow.Layout
Assembly: Lassalle.WPF.Flow.Layout (in Lassalle.WPF.Flow.Layout.dll) Version: 2.0.0.1 (2.0.0.1)
Syntax
C#
VB
C++
F#
Copy
public enum TreeDrawingStyle
Public Enumeration TreeDrawingStyle
public enum class TreeDrawingStyle
type TreeDrawingStyle
Members
Member name | Value | Description
Layered | 0 | Layered tree drawing: vertices are arranged in horizontal (or vertical, depending of the choosen orientation) layers
Radial | 1 | Radial tree drawing: the root is placed origin and the layers are concentric circles centered at the origin
See Also

Reference

Lassalle.WPF.Flow.Layout Namespace