%%ItemTitle%%

Lassalle.Silverlight.Flow
Lassalle.Silverlight.Flow Assembly
Namespaces
Namespace | Description
Lassalle.Silverlight.Flow |
Send Feedback


Lassalle.Silverlight.Flow Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | AddFlow | The panel used to display the diagram
Class | AfterEditEventArgs | Event parameters used for the AfterEdit event
Class | BeforeEditEventArgs | Event parameters used for the BeforeEdit event
Class | BirdView | The class managing the control used for a bird view.
Class | CancelEditEventArgs | Event parameters used for the CancelEdit event
Class | Connector | Represents the set of pins (connectors) of a node.
Class | ContextHandle | Represents a rotating handle of a node.
Class | ContextHandleClickedEventArgs | Event parameters used for the ContextHandleClicked event
Class | DoubleConverter |
Class | DstChangedEventArgs | Event parameters used for the DstChanged event
Class | DstChangingEventArgs | Event parameters used for the DstChanging event
Class | ErrorEventArgs | Event parameters used for the Error event
Class | License | License management
Class | Link | Represents a link (also called edge, relation or arc) in the diagram.
Class | LinkCreatedEventArgs | Event parameters used for the LinkCreated event
Class | LinkDeletedEventArgs | Event parameters used for the LinkDeleted event
Class | Node | Represents a node (also called vertice or entity) in the this.Diagram.
Class | NodeCreatedEventArgs | Event parameters used for the NodeCreated event
Class | NodeDeletedEventArgs | Event parameters used for the NodeDeleted event
Class | OrgChangedEventArgs | Event parameters used for the OrgChanged event
Class | OrgChangingEventArgs | Event parameters used for the OrgChanging event
Class | Pin | Represents a pin of a node. A link may be attached to this node via this pin.
Class | ResizeHandle | Represents a resizing handle of a node.
Class | RotateHandle | Represents a rotating handle of a node.
Class | SelectedLinkStretchingEventArgs | Event parameters used for the SelectedLinkStretching event
Class | SelectedNodesLayoutingEventArgs | Event parameters used for the SelectedNodesLayouting event
Class | SelectedNodesRotatingEventArgs | Event parameters used for the SelectedNodesRotatingEventArgs event
Class | SelectionBox | The rectangle used when selecting items with the mouse.
Class | SelectionChangedEventArgs | Event parameters used for the SelectionChanged event
Class | StretchHandle | Represents a stretching handle of a link.
Class | Task | Represents an action that can be undone and redone.
Class | TaskManager | The class managing the list of tasks and allowing undo/redo.
Class | ZoomedEventArgs | Event parameters used for the ZoomedEventArgs event
Class | ZoomingBox | The rectangle used when making a zoom with the mouse.
Interfaces
 | Interface | Description
Interface | IHasContext | Common interface for items that can have a context button: nodes, busbars, links
Interface | IMoveable | Common interface for items that can be moved
Interface | ISelectable | Common interface for items that can be selected: nodes and links
Delegates
 | Delegate | Description
Delegate | AddFlow.AfterEditEventHandler | Represents the method that will handle the AfterEdit event.
Delegate | AddFlow.BeforeEditEventHandler | Represents the method that will handle the BeforeEdit event.
Delegate | AddFlow.CancelEditEventHandler | Represents the method that will handle the CancelEdit event.
Delegate | AddFlow.ContextHandleClickedEventHandler | Represents the method that will handle the MouseOverPin event.
Delegate | AddFlow.DstChangedEventHandler | Represents the method that will handle the DstChanged event.
Delegate | AddFlow.DstChangingEventHandler | Represents the method that will handle the DstChanging event.
Delegate | AddFlow.ErrorEventHandler | Represents the method that will handle the Error event.
Delegate | AddFlow.LinkCreatedEventHandler | Represents the method that will handle the LinkCreated event.
Delegate | AddFlow.LinkDeletedEventHandler | Represents the method that will handle the LinkDeleted event.
Delegate | AddFlow.NodeCreatedEventHandler | Represents the method that will handle the NodeCreated event.
Delegate | AddFlow.NodeDeletedEventHandler | Represents the method that will handle the NodeDeleted event.
Delegate | AddFlow.OrgChangedEventHandler | Represents the method that will handle the OrgChanged event.
Delegate | AddFlow.OrgChangingEventHandler | Represents the method that will handle the OrgChanging event.
Delegate | AddFlow.SelectedLinkStretchingEventHandler | Represents the method that will handle the SelectedLinkStretching event.
Delegate | AddFlow.SelectedNodesLayoutingEventHandler | Represents the method that will handle the SelectedNodesLayouting event.
Delegate | AddFlow.SelectedNodesRotatingEventHandler | Represents the method that will handle the SelectedNodesRotating event.
Delegate | AddFlow.SelectionChangedEventHandler | Represents the method that will handle the SelectionChanged event.
Delegate | AddFlow.ZoomedEventHandler | Represents the method that will handle the Zoomed event.
Enumerations
 | Enumeration | Description
Enumeration | Action | Used to specify an action that changes the diagram.
Enumeration | ConnectionMode | Used to specify how a link is connected to a node
Enumeration | ErrorEventType | Used to specify the type of the Error event
Enumeration | LineStyle | Used to specify the style used to draw a link.
Enumeration | MouseSelection | Used to specify the action with the mouse.
Enumeration | ResizeHandle.HandleType | Type of node handle (Left, Up etc)
Enumeration | TextAngleMode | Used to specify if the link text is displayed with an angle
Enumeration | TextPlacementMode | Used to specify the position of the link text near the link.
See Also

Reference

Lassalle.Silverlight.Flow Assembly


%%PageItemTitle%%

AddFlow Class
Members

Lassalle.Silverlight.Flow Namespace : AddFlow Class
The panel used to display the diagram
Object Model
AddFlow ClassBirdView ClassTaskManager Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DesignTimeVisibleAttribute()>
Public Class AddFlow
   Inherits System.Windows.Controls.Canvas
'Usage

Dim instance As AddFlow
[DesignTimeVisibleAttribute()]
public class AddFlow : System.Windows.Controls.Canvas
[DesignTimeVisibleAttribute()]
public __gc class AddFlow : public System.Windows.Controls.Canvas
[DesignTimeVisibleAttribute()]
public ref class AddFlow : public System.Windows.Controls.Canvas
Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Panel
System.Windows.Controls.Canvas
Lassalle.Silverlight.Flow.AddFlow

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Members$$

AddFlow Class Members
Fields Properties Methods Events

Lassalle.Silverlight.Flow Namespace : AddFlow Class

The following tables list the members exposed by AddFlow.

Public Constructors
 | Name | Description
Public Constructor | AddFlow Constructor | Diagram constructor
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | CanChangeDstProperty | Identifies the CanChangeDst dependency property
static (Shared in Visual Basic) | CanChangeOrgProperty | Identifies the CanChangeOrg dependency property
static (Shared in Visual Basic) | CanDragScrollProperty | Identifies the CanDragScroll dependency property
static (Shared in Visual Basic) | CanDrawLinkProperty | Identifies the CanDrawLink dependency property
static (Shared in Visual Basic) | CanDrawNodeProperty | Identifies the CanDrawNode dependency property
static (Shared in Visual Basic) | CanEditNodeProperty | Identifies the CanEditNode dependency property.
static (Shared in Visual Basic) | CanMoveNodeProperty | Identifies the CanMoveNode dependency property
static (Shared in Visual Basic) | CanMultiLinkProperty | Identifies the CanMultiLink dependency property
static (Shared in Visual Basic) | CanReflexLinkProperty | Identifies the CanReflexLink dependency property
static (Shared in Visual Basic) | CanRotateNodeProperty | Identifies the CanRotateNode dependency property
static (Shared in Visual Basic) | CanSelectOnMouseMoveProperty | Identifies the CanSelectOnMouseMove dependency property
static (Shared in Visual Basic) | CanSendSelectionChangedEventProperty | Identifies the CanSendSelectionChangedEvent dependency property.
static (Shared in Visual Basic) | CanShowContextHandlesProperty | Identifies the CanShowContextHandles dependency property
static (Shared in Visual Basic) | CanShowJumpsProperty | Identifies the CanShowJumps dependency property
static (Shared in Visual Basic) | CanSizeNodeProperty | Identifies the CanSizeNode dependency property
static (Shared in Visual Basic) | CanStretchLinkProperty | Identifies the CanStretchLink dependency property
static (Shared in Visual Basic) | ConnectorStyleProperty | Identifies the ConnectorStyle dependency property
static (Shared in Visual Basic) | ContextHandleStyleProperty | Identifies the ContextHandleStyle dependency property
static (Shared in Visual Basic) | GridColorProperty | Identifies the GridColor dependency property.
static (Shared in Visual Basic) | GridDrawProperty | Identifies the GridDraw dependency property.
static (Shared in Visual Basic) | GridSizeProperty | Identifies the GridSize dependency property.
static (Shared in Visual Basic) | GridSnapProperty | Identifies the GridSnap dependency property.
static (Shared in Visual Basic) | IsCreatingLinkProperty | Identifies the IsCreatingLink dependency property
static (Shared in Visual Basic) | IsCreatingNodeProperty | Identifies the IsCreatingNode dependency property
static (Shared in Visual Basic) | IsFixedSizeProperty | Identifies the IsFixedSize dependency property
static (Shared in Visual Basic) | IsMovingNodeProperty | Identifies the IsMovingNode dependency property
static (Shared in Visual Basic) | IsPanningProperty | Identifies the IsPanning dependency property
static (Shared in Visual Basic) | IsResizingNodeProperty | Identifies the IsResizingNode dependency property
static (Shared in Visual Basic) | IsRotatingNodeProperty | Identifies the IsRotatingNode dependency property
static (Shared in Visual Basic) | IsSelectingProperty | Identifies the IsSelecting dependency property
static (Shared in Visual Basic) | IsStretchingLinkProperty | Identifies the IsStretchingLink dependency property
static (Shared in Visual Basic) | IsVirtualizingProperty | Identifies the IsVirtualizing dependency property
static (Shared in Visual Basic) | IsZoomingProperty | Identifies the IsZooming dependency property
static (Shared in Visual Basic) | LinkSelectionAreaWidthProperty | Identifies the LinkSelectionAreaWidth dependency property
static (Shared in Visual Basic) | LinkStyleProperty | Identifies the LinkStyle dependency property
static (Shared in Visual Basic) | MouseSelectionProperty | Identifies the MouseSelection dependency property
static (Shared in Visual Basic) | NodeStyleProperty | Identifies the NodeStyle dependency property
static (Shared in Visual Basic) | PinStyleProperty | Identifies the PinStyle dependency property
static (Shared in Visual Basic) | RemovePointDistanceProperty | Identifies the RemovePointDistance dependency property.
static (Shared in Visual Basic) | ResizeHandleStyleProperty | Identifies the ResizeHandleStyle dependency property
static (Shared in Visual Basic) | RotateHandleStyleProperty | Identifies the RotateHandleStyle dependency property
static (Shared in Visual Basic) | SelectionBoxStyleProperty | Identifies the SelectionBoxStyle dependency property
static (Shared in Visual Basic) | StretchHandleStyleProperty | Identifies the StretchHandleStyle dependency property
static (Shared in Visual Basic) | ZoomingBoxStyleProperty | Identifies the ZoomingBoxStyle dependency property
static (Shared in Visual Basic) | ZoomProperty | Identifies the Zoom dependency property
Top
Public Properties
 | Name | Description
Public Property | ActualHeight | Gets the rendered height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | Gets the rendered width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | AllowDrop | Gets or sets a value that determines whether this System.Windows.UIElement can be a drop target for purposes of Silverlight drag-and-drop operations. (Inherited from System.Windows.UIElement)
Public Property | Background | Gets or sets a System.Windows.Media.Brush that is used to fill the panel. (Inherited from System.Windows.Controls.Panel)
Public Property | BirdView | Returns the object managing the bird view popup
Public Property | CacheMode | Gets or sets a value that indicates that rendered content should be cached when possible. (Inherited from System.Windows.UIElement)
Public Property | CanChangeDst | Determines whether the user can interactively change the destination of a link. The default value is true.
Public Property | CanChangeOrg | Determines whether the user can interactively change the origin of a link. The default value is true.
Public Property | CanDragScroll | Determines whether drag scrolling is allowed or not. The default value is true.
Public Property | CanDrawLink | Determines whether interactive creation of links is allowed. The default value is true.
Public Property | CanDrawNode | Determines whether interactive creation of nodes is allowed. The default value is true.
Public Property | CanEditNode | Determines whether the user can edit the text of nodes. The default value is true.
Public Property | CanMoveNode | Determines whether you can drag nodes interactively. The default value is true.
Public Property | CanMultiLink | Determines whether you can create several links between two nodes or not. The default value is true.
Public Property | CanReflexLink | Determines whether you can create reflexive links. A link is reflexive if its destination and origin nodes are the same. The default value is true.
Public Property | CanRotateNode | Determines whether interactive rotation of nodes is allowed. The default value is true.
Public Property | CanSelectOnMouseMove | Indicates whether the selection of items with the mouse is made only when the MouseUp event is fired or at each MouseMove event.
Public Property | CanSendSelectionChangedEvent | Determines whether the SelectionChanged event is fired or not.
Public Property | CanShowContextHandles | Indicates whether a context handle is displayed when a node or a link is selected.
Public Property | CanShowJumps | Determines whether jumps are displayed at the intersection of links. The default value is false.
Public Property | CanSizeNode | Determines whether you can resize nodes interactively. The default value is true.
Public Property | CanStretchLink | Determines whether you can "stretch" links (i.e add or remove segments) interactively. The default value is true.
Public Property | Children | Gets the collection of child elements of the panel. (Inherited from System.Windows.Controls.Panel)
Public Property | Clip | Gets or sets the System.Windows.Media.Geometry used to define the outline of the contents of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | ConnectorStyle | Gets or sets the style used for the set of node pins.
Public Property | ContextHandleStyle | Gets or sets the Style used for the context handles.
Public Property | Cursor | Gets or sets the cursor image that displays while the mouse pointer is over a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | Gets or sets the data context for a System.Windows.FrameworkElement when it participates in data binding. (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | Gets the size that this System.Windows.UIElement computed during the measure pass of the layout process. (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | Gets the System.Windows.Threading.Dispatcher this object is associated with. (Inherited from System.Windows.DependencyObject)
Public Property | Effect | Gets or sets the pixel shader effect to use for rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | Extent | Return the size of the diagram.
Public Property | FlowDirection | Gets or sets the direction that text and other user interface elements flow within any parent element that controls their layout. (Inherited from System.Windows.FrameworkElement)
Public Property | GridColor | Returns/sets the grid color.
Public Property | GridDraw | Determines whether the grid is displayed or not.
Public Property | GridSize | Returns/sets the horizontal and vertical grid size.
Public Property | GridSnap | Determines whether nodes are aligned on the grid.
Public Property | Height | Gets or sets the suggested height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | IsChanged | Indicates if the AddFlow diagram has changed.
Public Property | IsCreatingLink | Indicates if the user is currently creating a link
Public Property | IsCreatingNode | Indicates if the user is currently creating a node
Public Property | IsFixedSize | Determines whether the size of the diagram panel is fixed or if it depends on the size of the diagram. The default value is false.
Public Property | IsHitTestVisible | Gets or sets whether the contained area of this System.Windows.UIElement can return true values for hit testing. (Inherited from System.Windows.UIElement)
Public Property | IsItemsHost | Gets a value that indicates whether this System.Windows.Controls.Panel is a container for UI items that are generated by an System.Windows.Controls.ItemsControl. (Inherited from System.Windows.Controls.Panel)
Public Property | IsMovingNode | Indicates if the user is currently moving nodes
Public Property | IsPanning | Indicates if the user is currently panning the diagram
Public Property | IsResizingNode | Indicates if the user is currently resising nodes
Public Property | IsRotatingNode | Indicates if the user is currently rotating nodes
Public Property | IsSelecting | Indicates if the user is currently selecting items with the mouse
Public Property | IsStretchingLink | Indicates if the user is currently stretching a link
Public Property | IsVirtualizing | Determines whether virtualizing mode is allowed. This is a UI virtualization, which collapses all items outside the viewable area, thus enhancing the performance while manipulating the items. The default value is false.
Public Property | IsZooming | Indicates if the user is currently zooming the diagram
Public Property | Language | Gets or sets localization/globalization language information that applies to a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | LinkSelectionAreaWidth | Returns/sets the width of the area where the user has to click to select a link.
Public Property | LinkStyle | Gets or sets the Style used for links.
Public Property | Margin | Gets or sets the outer margin of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | Gets or sets the maximum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | Gets or sets the maximum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | Gets or sets the minimum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | Gets or sets the minimum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MouseSelection | Returns/sets the selection rectangle action.
Public Property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from System.Windows.FrameworkElement)
Public Property | NodeStyle | Gets or sets the Style used for nodes.
Public Property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | Gets or sets the brush used to alter the opacity of regions of this object. (Inherited from System.Windows.UIElement)
Public Property | Origin | Return the origin of the diagram
Public Property | Parent | Gets the parent object of this System.Windows.FrameworkElement in the object tree. (Inherited from System.Windows.FrameworkElement)
Public Property | PinStyle | Gets or sets the style used for the node pins.
Public Property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RemovePointDistance | Returns/sets a value that determines if the user can remove a link point by dragging the handle to a position where it has a very obtuse angle to its surrounding link points.
Public Property | RenderSize | Gets the final render size of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | Gets or sets transform information that affects the rendering position of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by System.Windows.UIElement.RenderTransform, relative to the bounds of the System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | ResizeHandleStyle | Gets or sets the style used for the node resizing handles.
Public Property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from System.Windows.FrameworkElement)
Public Property | RotateHandleStyle | Gets or sets the style used for the node rotating handles.
Public Property | ScrollViewer | Returns the ScrollViewer used to scroll the diagram
Public Property | SelectedItems | Returns the list of selected items
Public Property | SelectionBoxStyle | Gets or sets the style used for the selection box.
Public Property | StretchHandleStyle | Gets or sets the style used for the link stretching handles.
Public Property | Style | Gets or sets an instance System.Windows.Style that is applied for this object during rendering. (Inherited from System.Windows.FrameworkElement)
Public Property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from System.Windows.FrameworkElement)
Public Property | TaskManager | Returns the object managing the list of tasks and allowing undo/redo.
Public Property | Triggers | Gets the collection of triggers for animations that are defined for a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from System.Windows.UIElement)
Public Property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | Visibility | Gets or sets the visibility of a System.Windows.UIElement. A System.Windows.UIElement that is not visible does not render and does not communicate its desired size to layout. (Inherited from System.Windows.UIElement)
Public Property | Width | Gets or sets the width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | XamlNodeContent | A xaml string defining the default content of nodes
Public Property | Zoom | Returns/sets the zooming factor.
Public Property | ZoomingBoxStyle | Gets or sets the style used for the zooming box.
Top
Public Methods
 | Name | Description
Public Method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from System.Windows.UIElement)
Public Method | AddLink | Overloaded. Add a link to the diagram
Public Method | AddNode | Overloaded. Add a node to the diagram
Public Method | Arrange | Positions child objects and determines a size for a System.Windows.UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | BeginUpdate | The BeginUpdate method prevents the control to calculate the size of the diagram until the EndUpdate method is called. This allows better performance.
Public Method | BringForward | Bring the selected items forward
Public Method | BringToFront | Bring the selected items at the front of the zorder list
Public Method | CaptureMouse | Sets mouse capture to a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | Clear | Clears all the content the AddFlow diagram
Public Method | ClearValue | Clears the local value of a dependency property. (Inherited from System.Windows.DependencyObject)
Public Method | Delete | Deletes the current selection of the AddFlow diagram
Public Method | EndUpdate | The BeginUpdate method prevents the control to calculate the size of the diagram until the EndUpdate method is called. This allows better performance.
Public Method | FindName | Retrieves an object that has the specified identifier name. (Inherited from System.Windows.FrameworkElement)
Public Method | GetAnimationBaseValue | Returns any base value established for a Silverlight dependency property, which would apply in cases where an animation is not active. (Inherited from System.Windows.DependencyObject)
Public Method | GetBindingExpression | Retrieves the System.Windows.Data.BindingExpression for a dependency property where a binding is established. (Inherited from System.Windows.FrameworkElement)
Public Method | GetDiagramSize | Calculate and returns the size of the diagram, i.e the size of the smallest rectangle that contains all the nodes and links of the diagram.
Public Method | GetValue | Returns the current effective value of a dependency property from a System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateArrange | Invalidates the arrange state (layout) for a System.Windows.UIElement. After the invalidation, the System.Windows.UIElement will have its layout updated, which will occur asynchronously. (Inherited from System.Windows.UIElement)
Public Method | InvalidateMeasure | Invalidates the measurement state (layout) for a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | Measure | Updates the System.Windows.UIElement.DesiredSize of a System.Windows.UIElement. Typically, objects that implement custom layout for their layout children call this method from their own System.Windows.FrameworkElement.MeasureOverride(System.Windows.Size) implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | MoveSelectedItems | Translate the selected items by dx along the x axis and dy along the y axis
Public Method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call System.Windows.Controls.Control.ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in an application. For more information, see Remarks. (Inherited from System.Windows.FrameworkElement)
Public Method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from System.Windows.DependencyObject)
Public Method | ReleaseMouseCapture | Removes mouse capture from a System.Windows.UIElement. After this call, typically no object holds mouse capture. (Inherited from System.Windows.UIElement)
Public Method | RemoveHandler | Removes the specified routed event handler from this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | RemoveLink | Remove a link from the panel
Public Method | RemoveNode | Remove a node from the panel
Public Method | ResetChangedFlag | Allow setting a flag indicating that the diagram is not still changed. Typically, you should call this method just after having saved the diagram.
Public Method | SelectAll | Selects all the items of the diagram
Public Method | SendBackward | Send the selected items backward
Public Method | SendToBack | Send the selected items at the back of the zorder list
Public Method | SetBinding | Attaches a binding to a System.Windows.FrameworkElement, using the provided binding object, and returns a System.Windows.Data.BindingExpressionBase for possible later use. (Inherited from System.Windows.FrameworkElement)
Public Method | SetValue | (Inherited from System.Windows.DependencyObject)
Public Method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the System.Windows.UIElement to the specified object. (Inherited from System.Windows.UIElement)
Public Method | UnselectAll | Command that unselects all the items of the diagram
Public Method | UpdateLayout | Ensures that all positions of child objects of a System.Windows.UIElement are properly updated for layout. (Inherited from System.Windows.UIElement)
Public Method | ZoomRectangle | Zoom and scroll a view to fit a specified rectangular portion of the diagram.
Top
Protected Methods
 | Name | Description
Protected Method | ArrangeOverride | Provides the behavior for the "arrange" pass of Silverlight layout. (Inherited from System.Windows.Controls.Canvas)
Protected Method | MeasureOverride | Provides the behavior for the "measure" pass of Silverlight layout. (Inherited from System.Windows.Controls.Canvas)
Protected Method | OnAfterEdit | Raises the AfterEdit event
Protected Method | OnBeforeEdit | Raises the BeforeEdit event
Protected Method | OnCancelEdit | Raises the CancelEdit event
Protected Method | OnContextHandleClicked | Raises the ContextHandleClicked event
Protected Method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific System.Windows.Automation.Peers.AutomationPeer implementations for the Silverlight automation infrastructure. (Inherited from System.Windows.UIElement)
Protected Method | OnDstChanged | Raises the DstChanged event
Protected Method | OnDstChanging | Raises the DstChanging event. Cancelling the action aborts the destination change.
Protected Method | OnError | Raises the Error event
Protected Method | OnLinkCreated | Raises the LinkCreated event
Protected Method | OnLinkDeleted | Raises the LinkDeleted event
Protected Method | OnNodeCreated | Raises the NodeCreated event
Protected Method | OnNodeDeleted | Raises the NodeDeleted event
Protected Method | OnOrgChanged | Raises the OrgChanged event
Protected Method | OnOrgChanging | Raises the OrgChanging event. Cancelling the action aborts the origin change.
Protected Method | OnSelectedLinkStretching | Raises the SelectedLinkStretching event. Cancelling the action aborts the stretching action.
Protected Method | OnSelectedNodesLayouting | Raises the SelectedNodesLayouting event. Cancelling the action aborts the resizing or moving action.
Protected Method | OnSelectedNodesRotating | Raises the SelectedNodesLayouting event. Cancelling the action aborts the resizing or moving action.
Protected Method | OnSelectionChanged | Raises the SelectionChanged event
Protected Method | OnZoomed | Raises the Zoomed event
Top
Public Events
Name | Description
Public Event | AfterEdit | Occurs after a user edits the text of the selected node.
Public Event | BeforeEdit | Occurs when a user attempts to edit the text of the selected node. Cancelling the action aborts the inline edit.
Public Event | BindingValidationError | Occurs when a data validation error is reported by a binding source. (Inherited from System.Windows.FrameworkElement)
Public Event | CancelEdit | Occurs after a user cancels the text edition of the selected node.
Public Event | ContextHandleClicked | Occurs when a Context handle is clicked.
Public Event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from System.Windows.FrameworkElement)
Public Event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from System.Windows.UIElement)
Public Event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from System.Windows.UIElement)
Public Event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from System.Windows.UIElement)
Public Event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from System.Windows.UIElement)
Public Event | DstChanged | Occurs after a user has changed the destination node of a link.
Public Event | DstChanging | Occurs when a user attempts to change the destination node of a link.
Public Event Error This event is fired when the user tries to make some actions that are not allowed:
  • - creating a reflexive link if the CanReflexLink property is false
  • - creating a second link between 2 nodes if the CanMultiLink property is false
  • - creating a link to a node that does not accept coming (int) links
  • - creating a link from a node that does not accept leaving (out) links
Public Event | GotFocus | Occurs when a System.Windows.UIElement receives focus. (Inherited from System.Windows.UIElement)
Public Event | KeyDown | Occurs when a keyboard key is pressed while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | KeyUp | Occurs when a keyboard key is released while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | Occurs when the layout of the Silverlight visual tree changes. (Inherited from System.Windows.FrameworkElement)
Public Event | LinkCreated | Occurs after a user creates a link.
Public Event | LinkDeleted | Occurs after a user removes a link.
Public Event | Loaded | Occurs when a System.Windows.FrameworkElement has been constructed and added to the object tree. (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | Occurs when a System.Windows.UIElement loses focus. (Inherited from System.Windows.UIElement)
Public Event | LostMouseCapture | Occurs when the System.Windows.UIElement loses mouse capture. (Inherited from System.Windows.UIElement)
Public Event | MediaCommand | Occurs when a button is pressed on a remote control. (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | Occurs when the mouse (or a stylus) enters the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | Occurs when the mouse (or the stylus) leaves the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | Occurs when the left mouse button is pressed (or when the tip of the stylus touches the tablet) while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | Occurs when the left mouse button is released (or the tip of the stylus is removed from the tablet) while the mouse (or the stylus) is over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseMove | Occurs when the coordinate position of the mouse (or stylus) changes while over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over a System.Windows.UIElement. However, this event will only be raised if a caller marks the preceding System.Windows.UIElement.MouseRightButtonDown event as handled; see Remarks. (Inherited from System.Windows.UIElement)
Public Event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over a System.Windows.UIElement, or the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | NodeCreated | Occurs after a user creates a node.
Public Event | NodeDeleted | Occurs after a user removes a node.
Public Event | OrgChanged | Occurs after a user has changed the origin node of a link.
Public Event | OrgChanging | Occurs when a user attempts to change the origin node of a link.
Public Event | SelectedLinkStretching | Occurs when a user is currently stretching a link.
Public Event | SelectedNodesLayouting | Occurs when a user is currently moving or resizing a node
Public Event | SelectedNodesRotating | Occurs when a user is currently rotating a node
Public Event | SelectionChanged | Occurs when the selection status of an item is changed
Public Event | SizeChanged | Occurs when either the System.Windows.FrameworkElement.ActualHeight or the System.Windows.FrameworkElement.ActualWidth properties change value on a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Event | TextInput | Occurs when a UI element gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputStart | Occurs when a UI element initially gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputUpdate | Occurs when text continues to be composed via an input method editor (IME). (Inherited from System.Windows.UIElement)
Public Event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from System.Windows.FrameworkElement)
Public Event | Zoomed | Occurs when the zoom factor is changed
Top
See Also

Reference

AddFlow Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

AddFlow Constructor

Lassalle.Silverlight.Flow Namespace > AddFlow Class : AddFlow Constructor
Diagram constructor
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New AddFlow()
public AddFlow()
public: AddFlow();
public:
AddFlow();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


%%PageItemTitle%% $$Methods$$

AddFlow Class Methods

Lassalle.Silverlight.Flow Namespace : AddFlow Class

For a list of all members of this type, see AddFlow members.

Public Methods
 | Name | Description
Public Method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from System.Windows.UIElement)
Public Method | AddLink | Overloaded. Add a link to the diagram
Public Method | AddNode | Overloaded. Add a node to the diagram
Public Method | Arrange | Positions child objects and determines a size for a System.Windows.UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | BeginUpdate | The BeginUpdate method prevents the control to calculate the size of the diagram until the EndUpdate method is called. This allows better performance.
Public Method | BringForward | Bring the selected items forward
Public Method | BringToFront | Bring the selected items at the front of the zorder list
Public Method | CaptureMouse | Sets mouse capture to a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | Clear | Clears all the content the AddFlow diagram
Public Method | ClearValue | Clears the local value of a dependency property. (Inherited from System.Windows.DependencyObject)
Public Method | Delete | Deletes the current selection of the AddFlow diagram
Public Method | EndUpdate | The BeginUpdate method prevents the control to calculate the size of the diagram until the EndUpdate method is called. This allows better performance.
Public Method | FindName | Retrieves an object that has the specified identifier name. (Inherited from System.Windows.FrameworkElement)
Public Method | GetAnimationBaseValue | Returns any base value established for a Silverlight dependency property, which would apply in cases where an animation is not active. (Inherited from System.Windows.DependencyObject)
Public Method | GetBindingExpression | Retrieves the System.Windows.Data.BindingExpression for a dependency property where a binding is established. (Inherited from System.Windows.FrameworkElement)
Public Method | GetDiagramSize | Calculate and returns the size of the diagram, i.e the size of the smallest rectangle that contains all the nodes and links of the diagram.
Public Method | GetValue | Returns the current effective value of a dependency property from a System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateArrange | Invalidates the arrange state (layout) for a System.Windows.UIElement. After the invalidation, the System.Windows.UIElement will have its layout updated, which will occur asynchronously. (Inherited from System.Windows.UIElement)
Public Method | InvalidateMeasure | Invalidates the measurement state (layout) for a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | Measure | Updates the System.Windows.UIElement.DesiredSize of a System.Windows.UIElement. Typically, objects that implement custom layout for their layout children call this method from their own System.Windows.FrameworkElement.MeasureOverride(System.Windows.Size) implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | MoveSelectedItems | Translate the selected items by dx along the x axis and dy along the y axis
Public Method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call System.Windows.Controls.Control.ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in an application. For more information, see Remarks. (Inherited from System.Windows.FrameworkElement)
Public Method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from System.Windows.DependencyObject)
Public Method | ReleaseMouseCapture | Removes mouse capture from a System.Windows.UIElement. After this call, typically no object holds mouse capture. (Inherited from System.Windows.UIElement)
Public Method | RemoveHandler | Removes the specified routed event handler from this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | RemoveLink | Remove a link from the panel
Public Method | RemoveNode | Remove a node from the panel
Public Method | ResetChangedFlag | Allow setting a flag indicating that the diagram is not still changed. Typically, you should call this method just after having saved the diagram.
Public Method | SelectAll | Selects all the items of the diagram
Public Method | SendBackward | Send the selected items backward
Public Method | SendToBack | Send the selected items at the back of the zorder list
Public Method | SetBinding | Attaches a binding to a System.Windows.FrameworkElement, using the provided binding object, and returns a System.Windows.Data.BindingExpressionBase for possible later use. (Inherited from System.Windows.FrameworkElement)
Public Method | SetValue | (Inherited from System.Windows.DependencyObject)
Public Method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the System.Windows.UIElement to the specified object. (Inherited from System.Windows.UIElement)
Public Method | UnselectAll | Command that unselects all the items of the diagram
Public Method | UpdateLayout | Ensures that all positions of child objects of a System.Windows.UIElement are properly updated for layout. (Inherited from System.Windows.UIElement)
Public Method | ZoomRectangle | Zoom and scroll a view to fit a specified rectangular portion of the diagram.
Top
Protected Methods
 | Name | Description
Protected Method | ArrangeOverride | Provides the behavior for the "arrange" pass of Silverlight layout. (Inherited from System.Windows.Controls.Canvas)
Protected Method | MeasureOverride | Provides the behavior for the "measure" pass of Silverlight layout. (Inherited from System.Windows.Controls.Canvas)
Protected Method | OnAfterEdit | Raises the AfterEdit event
Protected Method | OnBeforeEdit | Raises the BeforeEdit event
Protected Method | OnCancelEdit | Raises the CancelEdit event
Protected Method | OnContextHandleClicked | Raises the ContextHandleClicked event
Protected Method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific System.Windows.Automation.Peers.AutomationPeer implementations for the Silverlight automation infrastructure. (Inherited from System.Windows.UIElement)
Protected Method | OnDstChanged | Raises the DstChanged event
Protected Method | OnDstChanging | Raises the DstChanging event. Cancelling the action aborts the destination change.
Protected Method | OnError | Raises the Error event
Protected Method | OnLinkCreated | Raises the LinkCreated event
Protected Method | OnLinkDeleted | Raises the LinkDeleted event
Protected Method | OnNodeCreated | Raises the NodeCreated event
Protected Method | OnNodeDeleted | Raises the NodeDeleted event
Protected Method | OnOrgChanged | Raises the OrgChanged event
Protected Method | OnOrgChanging | Raises the OrgChanging event. Cancelling the action aborts the origin change.
Protected Method | OnSelectedLinkStretching | Raises the SelectedLinkStretching event. Cancelling the action aborts the stretching action.
Protected Method | OnSelectedNodesLayouting | Raises the SelectedNodesLayouting event. Cancelling the action aborts the resizing or moving action.
Protected Method | OnSelectedNodesRotating | Raises the SelectedNodesLayouting event. Cancelling the action aborts the resizing or moving action.
Protected Method | OnSelectionChanged | Raises the SelectionChanged event
Protected Method | OnZoomed | Raises the Zoomed event
Top
See Also

Reference

AddFlow Class
Lassalle.Silverlight.Flow Namespace


AddLink Method

Lassalle.Silverlight.Flow Namespace > AddFlow Class : AddLink Method
Add a link to the diagram
Overload List
Overload | Description
AddLink(Link) | Add a link to the diagram
AddLink(Node,Node) | Create a link between two nodes and add it to the canvas.
AddLink(Node,Node,String) | Create a link between two nodes and add it to the panel.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


AddLink(Link) Method

Lassalle.Silverlight.Flow Namespace > AddFlow Class > AddLink Method : AddLink(Link) Method
A reference to the link to add to the diagram
Add a link to the diagram
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub AddLink( _
   ByVal link As Link _
)
'Usage

Dim instance As AddFlow
Dim link As Link

instance.AddLink(link)
public void AddLink(
   Link link
)
public: void AddLink(
   Link* link
)
public:
void AddLink(
   Link^ link
)

Parameters

link
A reference to the link to add to the diagram
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members
Overload List


AddLink(Node,Node) Method

Lassalle.Silverlight.Flow Namespace > AddFlow Class > AddLink Method : AddLink(Node,Node) Method
A reference to the origin node of the link
A reference to the destination node of the link
Create a link between two nodes and add it to the canvas.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function AddLink( _
   ByVal org As Node, _
   ByVal dst As Node _
) As Link
'Usage

Dim instance As AddFlow
Dim org As Node
Dim dst As Node
Dim value As Link

value = instance.AddLink(org, dst)
public Link AddLink(
   Node org,
   Node dst
)
public: Link* AddLink(
   Node* org,
   Node* dst
)
public:
Link^ AddLink(
   Node^ org,
   Node^ dst
)

Parameters

org
A reference to the origin node of the link
dst
A reference to the destination node of the link

Return Value

A reference to the created link
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members
Overload List


AddLink(Node,Node,String) Method

Lassalle.Silverlight.Flow Namespace > AddFlow Class > AddLink Method : AddLink(Node,Node,String) Method
A reference to the origin node of the link
A reference to the destination node of the link
The text displayed near the link
Create a link between two nodes and add it to the panel.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function AddLink( _
   ByVal org As Node, _
   ByVal dst As Node, _
   ByVal text As String _
) As Link
'Usage

Dim instance As AddFlow
Dim org As Node
Dim dst As Node
Dim text As String
Dim value As Link

value = instance.AddLink(org, dst, text)
public Link AddLink(
   Node org,
   Node dst,
   string text
)
public: Link* AddLink(
   Node* org,
   Node* dst,
   string* text
)
public:
Link^ AddLink(
   Node^ org,
   Node^ dst,
   String^ text
)

Parameters

org
A reference to the origin node of the link
dst
A reference to the destination node of the link
text
The text displayed near the link

Return Value

A reference to the created link
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members
Overload List


AddNode Method

Lassalle.Silverlight.Flow Namespace > AddFlow Class : AddNode Method
Add a node to the diagram
Overload List
Overload | Description
AddNode(Node) | Add a node to the diagram
AddNode(Double,Double,Double,Double,String,Object) | Create a node with a position, a size, a text and a content and add it to the canvas.
AddNode(Double,Double,Double,Double,String) | Create a node with a position, a size and a text and add it to the canvas.
AddNode(Double,Double,Double,Double) | Create a node with a position and a size and add it to the canvas.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


AddNode(Node) Method

Lassalle.Silverlight.Flow Namespace > AddFlow Class > AddNode Method : AddNode(Node) Method
the node to add to the diagram
Add a node to the diagram
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub AddNode( _
   ByVal node As Node _
)
'Usage

Dim instance As AddFlow
Dim node As Node

instance.AddNode(node)
public void AddNode(
   Node node
)
public: void AddNode(
   Node* node
)
public:
void AddNode(
   Node^ node
)

Parameters

node
the node to add to the diagram
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members
Overload List


AddNode(Double,Double,Double,Double,String,Object) Method

Lassalle.Silverlight.Flow Namespace > AddFlow Class > AddNode Method : AddNode(Double,Double,Double,Double,String,Object) Method
The x-coordinate of the node position
The y-coordinate of the node position
The horizontal size of the node
The vertical size of the node
The text displayed inside the node
The node content
Create a node with a position, a size, a text and a content and add it to the canvas.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function AddNode( _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal text As String, _
   ByVal content As Object _
) As Node
'Usage

Dim instance As AddFlow
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim text As String
Dim content As Object
Dim value As Node

value = instance.AddNode(left, top, width, height, text, content)
public Node AddNode(
   double left,
   double top,
   double width,
   double height,
   string text,
   object content
)
public: Node* AddNode(
   double left,
   double top,
   double width,
   double height,
   string* text,
   Object* content
)
public:
Node^ AddNode(
   double left,
   double top,
   double width,
   double height,
   String^ text,
   Object^ content
)

Parameters

left
The x-coordinate of the node position
top
The y-coordinate of the node position
width
The horizontal size of the node
height
The vertical size of the node
text
The text displayed inside the node
content
The node content

Return Value

A reference to the created node
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members
Overload List


AddNode(Double,Double,Double,Double,String) Method

Lassalle.Silverlight.Flow Namespace > AddFlow Class > AddNode Method : AddNode(Double,Double,Double,Double,String) Method
The x-coordinate of the node position
The y-coordinate of the node position
The horizontal size of the node
The vertical size of the node
The text displayed inside the node
Create a node with a position, a size and a text and add it to the canvas.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function AddNode( _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal text As String _
) As Node
'Usage

Dim instance As AddFlow
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim text As String
Dim value As Node

value = instance.AddNode(left, top, width, height, text)
public Node AddNode(
   double left,
   double top,
   double width,
   double height,
   string text
)
public: Node* AddNode(
   double left,
   double top,
   double width,
   double height,
   string* text
)
public:
Node^ AddNode(
   double left,
   double top,
   double width,
   double height,
   String^ text
)

Parameters

left
The x-coordinate of the node position
top
The y-coordinate of the node position
width
The horizontal size of the node
height
The vertical size of the node
text
The text displayed inside the node

Return Value

A reference to the created node
Remarks
The content of the node is defined by the XamlNode content property of AddFlow.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members
Overload List


AddNode(Double,Double,Double,Double) Method

Lassalle.Silverlight.Flow Namespace > AddFlow Class > AddNode Method : AddNode(Double,Double,Double,Double) Method
The x-coordinate of the node position
The y-coordinate of the node position
The horizontal size of the node
The vertical size of the node
Create a node with a position and a size and add it to the canvas.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function AddNode( _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double _
) As Node
'Usage

Dim instance As AddFlow
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim value As Node

value = instance.AddNode(left, top, width, height)
public Node AddNode(
   double left,
   double top,
   double width,
   double height
)
public: Node* AddNode(
   double left,
   double top,
   double width,
   double height
)
public:
Node^ AddNode(
   double left,
   double top,
   double width,
   double height
)

Parameters

left
The x-coordinate of the node position
top
The y-coordinate of the node position
width
The horizontal size of the node
height
The vertical size of the node

Return Value

A reference to the created node
Remarks
The content of the node is defined by the XamlNode content property of AddFlow.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members
Overload List


BeginUpdate Method

Lassalle.Silverlight.Flow Namespace > AddFlow Class : BeginUpdate Method
The BeginUpdate method prevents the control to calculate the size of the diagram until the EndUpdate method is called. This allows better performance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub BeginUpdate()
'Usage

Dim instance As AddFlow

instance.BeginUpdate()
public void BeginUpdate()
public: void BeginUpdate();
public:
void BeginUpdate();
Remarks
If you need the size of the diagram before the call to endUpdate, you can use the GetDiagramSize method.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


BringForward Method

Lassalle.Silverlight.Flow Namespace > AddFlow Class : BringForward Method
Bring the selected items forward
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub BringForward()
'Usage

Dim instance As AddFlow

instance.BringForward()
public void BringForward()
public: void BringForward();
public:
void BringForward();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


BringToFront Method

Lassalle.Silverlight.Flow Namespace > AddFlow Class : BringToFront Method
Bring the selected items at the front of the zorder list
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub BringToFront()
'Usage

Dim instance As AddFlow

instance.BringToFront()
public void BringToFront()
public: void BringToFront();
public:
void BringToFront();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


Clear Method (AddFlow)

Lassalle.Silverlight.Flow Namespace > AddFlow Class : Clear Method
Clears all the content the AddFlow diagram
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Clear()
'Usage

Dim instance As AddFlow

instance.Clear()
public void Clear()
public: void Clear();
public:
void Clear();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


Delete Method

Lassalle.Silverlight.Flow Namespace > AddFlow Class : Delete Method
Deletes the current selection of the AddFlow diagram
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Delete()
'Usage

Dim instance As AddFlow

instance.Delete()
public void Delete()
public: void Delete();
public:
void Delete();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


EndUpdate Method

Lassalle.Silverlight.Flow Namespace > AddFlow Class : EndUpdate Method
The BeginUpdate method prevents the control to calculate the size of the diagram until the EndUpdate method is called. This allows better performance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub EndUpdate()
'Usage

Dim instance As AddFlow

instance.EndUpdate()
public void EndUpdate()
public: void EndUpdate();
public:
void EndUpdate();
Remarks
If you need the size of the diagram before the call to endUpdate, you can use the GetDiagramSize method.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


GetDiagramSize Method

Lassalle.Silverlight.Flow Namespace > AddFlow Class : GetDiagramSize Method
Calculate and returns the size of the diagram, i.e the size of the smallest rectangle that contains all the nodes and links of the diagram.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetDiagramSize() As Size
'Usage

Dim instance As AddFlow
Dim value As Size

value = instance.GetDiagramSize()
public Size GetDiagramSize()
public: Size GetDiagramSize();
public:
Size GetDiagramSize();

Return Value

The size of the diagram.
Remarks
Generally, this method returns the same information as the Extent property. However it recalculates the size of the rectangle just before returning it, which is not the case of the Extent property. This method can be useful in some cases where the diagram size has not been updated, for instance between the calls to the BeginUpdate and EndUpdate methods.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


MoveSelectedItems Method

Lassalle.Silverlight.Flow Namespace > AddFlow Class : MoveSelectedItems Method
the distance to move the items along the x axis
the distance to move the items along the y axis
Translate the selected items by dx along the x axis and dy along the y axis
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub MoveSelectedItems( _
   ByVal dx As Double, _
   ByVal dy As Double _
)
'Usage

Dim instance As AddFlow
Dim dx As Double
Dim dy As Double

instance.MoveSelectedItems(dx, dy)
public void MoveSelectedItems(
   double dx,
   double dy
)
public: void MoveSelectedItems(
   double dx,
   double dy
)
public:
void MoveSelectedItems(
   double dx,
   double dy
)

Parameters

dx
the distance to move the items along the x axis
dy
the distance to move the items along the y axis
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


OnAfterEdit Method

Lassalle.Silverlight.Flow Namespace > AddFlow Class : OnAfterEdit Method
Raises the AfterEdit event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Sub OnAfterEdit( _
   ByVal e As AfterEditEventArgs _
)
'Usage

Dim instance As AddFlow
Dim e As AfterEditEventArgs

instance.OnAfterEdit(e)
protected virtual void OnAfterEdit(
   AfterEditEventArgs e
)
protected: virtual void OnAfterEdit(
   AfterEditEventArgs* e
)
protected:
virtual void OnAfterEdit(
   AfterEditEventArgs^ e
)

Parameters

e
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


OnBeforeEdit Method

Lassalle.Silverlight.Flow Namespace > AddFlow Class : OnBeforeEdit Method
Raises the BeforeEdit event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Sub OnBeforeEdit( _
   ByVal e As BeforeEditEventArgs _
)
'Usage

Dim instance As AddFlow
Dim e As BeforeEditEventArgs

instance.OnBeforeEdit(e)
protected virtual void OnBeforeEdit(
   BeforeEditEventArgs e
)
protected: virtual void OnBeforeEdit(
   BeforeEditEventArgs* e
)
protected:
virtual void OnBeforeEdit(
   BeforeEditEventArgs^ e
)

Parameters

e
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


OnCancelEdit Method

Lassalle.Silverlight.Flow Namespace > AddFlow Class : OnCancelEdit Method
Raises the CancelEdit event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Sub OnCancelEdit( _
   ByVal e As CancelEditEventArgs _
)
'Usage

Dim instance As AddFlow
Dim e As CancelEditEventArgs

instance.OnCancelEdit(e)
protected virtual void OnCancelEdit(
   CancelEditEventArgs e
)
protected: virtual void OnCancelEdit(
   CancelEditEventArgs* e
)
protected:
virtual void OnCancelEdit(
   CancelEditEventArgs^ e
)

Parameters

e
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


OnContextHandleClicked Method

Lassalle.Silverlight.Flow Namespace > AddFlow Class : OnContextHandleClicked Method
Raises the ContextHandleClicked event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Sub OnContextHandleClicked( _
   ByVal e As ContextHandleClickedEventArgs _
)
'Usage

Dim instance As AddFlow
Dim e As ContextHandleClickedEventArgs

instance.OnContextHandleClicked(e)
protected virtual void OnContextHandleClicked(
   ContextHandleClickedEventArgs e
)
protected: virtual void OnContextHandleClicked(
   ContextHandleClickedEventArgs* e
)
protected:
virtual void OnContextHandleClicked(
   ContextHandleClickedEventArgs^ e
)

Parameters

e
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


OnDstChanged Method

Lassalle.Silverlight.Flow Namespace > AddFlow Class : OnDstChanged Method
Raises the DstChanged event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Sub OnDstChanged( _
   ByVal e As DstChangedEventArgs _
)
'Usage

Dim instance As AddFlow
Dim e As DstChangedEventArgs

instance.OnDstChanged(e)
protected virtual void OnDstChanged(
   DstChangedEventArgs e
)
protected: virtual void OnDstChanged(
   DstChangedEventArgs* e
)
protected:
virtual void OnDstChanged(
   DstChangedEventArgs^ e
)

Parameters

e
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


OnDstChanging Method

Lassalle.Silverlight.Flow Namespace > AddFlow Class : OnDstChanging Method
Raises the DstChanging event. Cancelling the action aborts the destination change.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Sub OnDstChanging( _
   ByVal e As DstChangingEventArgs _
)
'Usage

Dim instance As AddFlow
Dim e As DstChangingEventArgs

instance.OnDstChanging(e)
protected virtual void OnDstChanging(
   DstChangingEventArgs e
)
protected: virtual void OnDstChanging(
   DstChangingEventArgs* e
)
protected:
virtual void OnDstChanging(
   DstChangingEventArgs^ e
)

Parameters

e
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


OnError Method

Lassalle.Silverlight.Flow Namespace > AddFlow Class : OnError Method
Raises the Error event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Sub OnError( _
   ByVal e As ErrorEventArgs _
)
'Usage

Dim instance As AddFlow
Dim e As ErrorEventArgs

instance.OnError(e)
protected virtual void OnError(
   ErrorEventArgs e
)
protected: virtual void OnError(
   ErrorEventArgs* e
)
protected:
virtual void OnError(
   ErrorEventArgs^ e
)

Parameters

e
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


OnLinkCreated Method

Lassalle.Silverlight.Flow Namespace > AddFlow Class : OnLinkCreated Method
Raises the LinkCreated event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Sub OnLinkCreated( _
   ByVal e As LinkCreatedEventArgs _
)
'Usage

Dim instance As AddFlow
Dim e As LinkCreatedEventArgs

instance.OnLinkCreated(e)
protected virtual void OnLinkCreated(
   LinkCreatedEventArgs e
)
protected: virtual void OnLinkCreated(
   LinkCreatedEventArgs* e
)
protected:
virtual void OnLinkCreated(
   LinkCreatedEventArgs^ e
)

Parameters

e
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


OnLinkDeleted Method

Lassalle.Silverlight.Flow Namespace > AddFlow Class : OnLinkDeleted Method
Raises the LinkDeleted event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Sub OnLinkDeleted( _
   ByVal e As LinkDeletedEventArgs _
)
'Usage

Dim instance As AddFlow
Dim e As LinkDeletedEventArgs

instance.OnLinkDeleted(e)
protected virtual void OnLinkDeleted(
   LinkDeletedEventArgs e
)
protected: virtual void OnLinkDeleted(
   LinkDeletedEventArgs* e
)
protected:
virtual void OnLinkDeleted(
   LinkDeletedEventArgs^ e
)

Parameters

e
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


OnNodeCreated Method

Lassalle.Silverlight.Flow Namespace > AddFlow Class : OnNodeCreated Method
Raises the NodeCreated event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Sub OnNodeCreated( _
   ByVal e As NodeCreatedEventArgs _
)
'Usage

Dim instance As AddFlow
Dim e As NodeCreatedEventArgs

instance.OnNodeCreated(e)
protected virtual void OnNodeCreated(
   NodeCreatedEventArgs e
)
protected: virtual void OnNodeCreated(
   NodeCreatedEventArgs* e
)
protected:
virtual void OnNodeCreated(
   NodeCreatedEventArgs^ e
)

Parameters

e
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


OnNodeDeleted Method

Lassalle.Silverlight.Flow Namespace > AddFlow Class : OnNodeDeleted Method
Raises the NodeDeleted event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Sub OnNodeDeleted( _
   ByVal e As NodeDeletedEventArgs _
)
'Usage

Dim instance As AddFlow
Dim e As NodeDeletedEventArgs

instance.OnNodeDeleted(e)
protected virtual void OnNodeDeleted(
   NodeDeletedEventArgs e
)
protected: virtual void OnNodeDeleted(
   NodeDeletedEventArgs* e
)
protected:
virtual void OnNodeDeleted(
   NodeDeletedEventArgs^ e
)

Parameters

e
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


OnOrgChanged Method

Lassalle.Silverlight.Flow Namespace > AddFlow Class : OnOrgChanged Method
Raises the OrgChanged event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Sub OnOrgChanged( _
   ByVal e As OrgChangedEventArgs _
)
'Usage

Dim instance As AddFlow
Dim e As OrgChangedEventArgs

instance.OnOrgChanged(e)
protected virtual void OnOrgChanged(
   OrgChangedEventArgs e
)
protected: virtual void OnOrgChanged(
   OrgChangedEventArgs* e
)
protected:
virtual void OnOrgChanged(
   OrgChangedEventArgs^ e
)

Parameters

e
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


OnOrgChanging Method

Lassalle.Silverlight.Flow Namespace > AddFlow Class : OnOrgChanging Method
Raises the OrgChanging event. Cancelling the action aborts the origin change.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Sub OnOrgChanging( _
   ByVal e As OrgChangingEventArgs _
)
'Usage

Dim instance As AddFlow
Dim e As OrgChangingEventArgs

instance.OnOrgChanging(e)
protected virtual void OnOrgChanging(
   OrgChangingEventArgs e
)
protected: virtual void OnOrgChanging(
   OrgChangingEventArgs* e
)
protected:
virtual void OnOrgChanging(
   OrgChangingEventArgs^ e
)

Parameters

e
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


OnSelectedLinkStretching Method

Lassalle.Silverlight.Flow Namespace > AddFlow Class : OnSelectedLinkStretching Method
Raises the SelectedLinkStretching event. Cancelling the action aborts the stretching action.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Sub OnSelectedLinkStretching( _
   ByVal e As SelectedLinkStretchingEventArgs _
)
'Usage

Dim instance As AddFlow
Dim e As SelectedLinkStretchingEventArgs

instance.OnSelectedLinkStretching(e)
protected virtual void OnSelectedLinkStretching(
   SelectedLinkStretchingEventArgs e
)
protected: virtual void OnSelectedLinkStretching(
   SelectedLinkStretchingEventArgs* e
)
protected:
virtual void OnSelectedLinkStretching(
   SelectedLinkStretchingEventArgs^ e
)

Parameters

e
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


OnSelectedNodesLayouting Method

Lassalle.Silverlight.Flow Namespace > AddFlow Class : OnSelectedNodesLayouting Method
Raises the SelectedNodesLayouting event. Cancelling the action aborts the resizing or moving action.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Sub OnSelectedNodesLayouting( _
   ByVal e As SelectedNodesLayoutingEventArgs _
)
'Usage

Dim instance As AddFlow
Dim e As SelectedNodesLayoutingEventArgs

instance.OnSelectedNodesLayouting(e)
protected virtual void OnSelectedNodesLayouting(
   SelectedNodesLayoutingEventArgs e
)
protected: virtual void OnSelectedNodesLayouting(
   SelectedNodesLayoutingEventArgs* e
)
protected:
virtual void OnSelectedNodesLayouting(
   SelectedNodesLayoutingEventArgs^ e
)

Parameters

e
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


OnSelectedNodesRotating Method

Lassalle.Silverlight.Flow Namespace > AddFlow Class : OnSelectedNodesRotating Method
Raises the SelectedNodesLayouting event. Cancelling the action aborts the resizing or moving action.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Sub OnSelectedNodesRotating( _
   ByVal e As SelectedNodesRotatingEventArgs _
)
'Usage

Dim instance As AddFlow
Dim e As SelectedNodesRotatingEventArgs

instance.OnSelectedNodesRotating(e)
protected virtual void OnSelectedNodesRotating(
   SelectedNodesRotatingEventArgs e
)
protected: virtual void OnSelectedNodesRotating(
   SelectedNodesRotatingEventArgs* e
)
protected:
virtual void OnSelectedNodesRotating(
   SelectedNodesRotatingEventArgs^ e
)

Parameters

e
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


OnSelectionChanged Method

Lassalle.Silverlight.Flow Namespace > AddFlow Class : OnSelectionChanged Method
Raises the SelectionChanged event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Sub OnSelectionChanged( _
   ByVal e As SelectionChangedEventArgs _
)
'Usage

Dim instance As AddFlow
Dim e As SelectionChangedEventArgs

instance.OnSelectionChanged(e)
protected virtual void OnSelectionChanged(
   SelectionChangedEventArgs e
)
protected: virtual void OnSelectionChanged(
   SelectionChangedEventArgs* e
)
protected:
virtual void OnSelectionChanged(
   SelectionChangedEventArgs^ e
)

Parameters

e
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


OnZoomed Method

Lassalle.Silverlight.Flow Namespace > AddFlow Class : OnZoomed Method
Raises the Zoomed event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Sub OnZoomed( _
   ByVal e As ZoomedEventArgs _
)
'Usage

Dim instance As AddFlow
Dim e As ZoomedEventArgs

instance.OnZoomed(e)
protected virtual void OnZoomed(
   ZoomedEventArgs e
)
protected: virtual void OnZoomed(
   ZoomedEventArgs* e
)
protected:
virtual void OnZoomed(
   ZoomedEventArgs^ e
)

Parameters

e
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


RemoveLink Method

Lassalle.Silverlight.Flow Namespace > AddFlow Class : RemoveLink Method
A reference to the link to remove
Remove a link from the panel
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RemoveLink( _
   ByVal link As Link _
)
'Usage

Dim instance As AddFlow
Dim link As Link

instance.RemoveLink(link)
public void RemoveLink(
   Link link
)
public: void RemoveLink(
   Link* link
)
public:
void RemoveLink(
   Link^ link
)

Parameters

link
A reference to the link to remove
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


RemoveNode Method

Lassalle.Silverlight.Flow Namespace > AddFlow Class : RemoveNode Method
A reference to the node to remove
Remove a node from the panel
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RemoveNode( _
   ByVal node As Node _
)
'Usage

Dim instance As AddFlow
Dim node As Node

instance.RemoveNode(node)
public void RemoveNode(
   Node node
)
public: void RemoveNode(
   Node* node
)
public:
void RemoveNode(
   Node^ node
)

Parameters

node
A reference to the node to remove
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


ResetChangedFlag Method

Lassalle.Silverlight.Flow Namespace > AddFlow Class : ResetChangedFlag Method
Allow setting a flag indicating that the diagram is not still changed. Typically, you should call this method just after having saved the diagram.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ResetChangedFlag()
'Usage

Dim instance As AddFlow

instance.ResetChangedFlag()
public void ResetChangedFlag()
public: void ResetChangedFlag();
public:
void ResetChangedFlag();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


SelectAll Method

Lassalle.Silverlight.Flow Namespace > AddFlow Class : SelectAll Method
Selects all the items of the diagram
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SelectAll()
'Usage

Dim instance As AddFlow

instance.SelectAll()
public void SelectAll()
public: void SelectAll();
public:
void SelectAll();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


SendBackward Method

Lassalle.Silverlight.Flow Namespace > AddFlow Class : SendBackward Method
Send the selected items backward
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SendBackward()
'Usage

Dim instance As AddFlow

instance.SendBackward()
public void SendBackward()
public: void SendBackward();
public:
void SendBackward();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


SendToBack Method

Lassalle.Silverlight.Flow Namespace > AddFlow Class : SendToBack Method
Send the selected items at the back of the zorder list
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SendToBack()
'Usage

Dim instance As AddFlow

instance.SendToBack()
public void SendToBack()
public: void SendToBack();
public:
void SendToBack();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


UnselectAll Method

Lassalle.Silverlight.Flow Namespace > AddFlow Class : UnselectAll Method
Command that unselects all the items of the diagram
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub UnselectAll()
'Usage

Dim instance As AddFlow

instance.UnselectAll()
public void UnselectAll()
public: void UnselectAll();
public:
void UnselectAll();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


ZoomRectangle Method

Lassalle.Silverlight.Flow Namespace > AddFlow Class : ZoomRectangle Method
A rectangular portion of the diagram.
Zoom and scroll a view to fit a specified rectangular portion of the diagram.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ZoomRectangle( _
   ByVal zoomRectangle As Rect _
)
'Usage

Dim instance As AddFlow
Dim zoomRectangle As Rect

instance.ZoomRectangle(zoomRectangle)
public void ZoomRectangle(
   Rect zoomRectangle
)
public: void ZoomRectangle(
   Rect zoomRectangle
)
public:
void ZoomRectangle(
   Rect zoomRectangle
)

Parameters

zoomRectangle
A rectangular portion of the diagram.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


%%PageItemTitle%% $$Properties$$

AddFlow Class Properties

Lassalle.Silverlight.Flow Namespace : AddFlow Class

For a list of all members of this type, see AddFlow members.

Public Properties
 | Name | Description
Public Property | ActualHeight | Gets the rendered height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | Gets the rendered width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | AllowDrop | Gets or sets a value that determines whether this System.Windows.UIElement can be a drop target for purposes of Silverlight drag-and-drop operations. (Inherited from System.Windows.UIElement)
Public Property | Background | Gets or sets a System.Windows.Media.Brush that is used to fill the panel. (Inherited from System.Windows.Controls.Panel)
Public Property | BirdView | Returns the object managing the bird view popup
Public Property | CacheMode | Gets or sets a value that indicates that rendered content should be cached when possible. (Inherited from System.Windows.UIElement)
Public Property | CanChangeDst | Determines whether the user can interactively change the destination of a link. The default value is true.
Public Property | CanChangeOrg | Determines whether the user can interactively change the origin of a link. The default value is true.
Public Property | CanDragScroll | Determines whether drag scrolling is allowed or not. The default value is true.
Public Property | CanDrawLink | Determines whether interactive creation of links is allowed. The default value is true.
Public Property | CanDrawNode | Determines whether interactive creation of nodes is allowed. The default value is true.
Public Property | CanEditNode | Determines whether the user can edit the text of nodes. The default value is true.
Public Property | CanMoveNode | Determines whether you can drag nodes interactively. The default value is true.
Public Property | CanMultiLink | Determines whether you can create several links between two nodes or not. The default value is true.
Public Property | CanReflexLink | Determines whether you can create reflexive links. A link is reflexive if its destination and origin nodes are the same. The default value is true.
Public Property | CanRotateNode | Determines whether interactive rotation of nodes is allowed. The default value is true.
Public Property | CanSelectOnMouseMove | Indicates whether the selection of items with the mouse is made only when the MouseUp event is fired or at each MouseMove event.
Public Property | CanSendSelectionChangedEvent | Determines whether the SelectionChanged event is fired or not.
Public Property | CanShowContextHandles | Indicates whether a context handle is displayed when a node or a link is selected.
Public Property | CanShowJumps | Determines whether jumps are displayed at the intersection of links. The default value is false.
Public Property | CanSizeNode | Determines whether you can resize nodes interactively. The default value is true.
Public Property | CanStretchLink | Determines whether you can "stretch" links (i.e add or remove segments) interactively. The default value is true.
Public Property | Children | Gets the collection of child elements of the panel. (Inherited from System.Windows.Controls.Panel)
Public Property | Clip | Gets or sets the System.Windows.Media.Geometry used to define the outline of the contents of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | ConnectorStyle | Gets or sets the style used for the set of node pins.
Public Property | ContextHandleStyle | Gets or sets the Style used for the context handles.
Public Property | Cursor | Gets or sets the cursor image that displays while the mouse pointer is over a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | Gets or sets the data context for a System.Windows.FrameworkElement when it participates in data binding. (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | Gets the size that this System.Windows.UIElement computed during the measure pass of the layout process. (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | Gets the System.Windows.Threading.Dispatcher this object is associated with. (Inherited from System.Windows.DependencyObject)
Public Property | Effect | Gets or sets the pixel shader effect to use for rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | Extent | Return the size of the diagram.
Public Property | FlowDirection | Gets or sets the direction that text and other user interface elements flow within any parent element that controls their layout. (Inherited from System.Windows.FrameworkElement)
Public Property | GridColor | Returns/sets the grid color.
Public Property | GridDraw | Determines whether the grid is displayed or not.
Public Property | GridSize | Returns/sets the horizontal and vertical grid size.
Public Property | GridSnap | Determines whether nodes are aligned on the grid.
Public Property | Height | Gets or sets the suggested height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | IsChanged | Indicates if the AddFlow diagram has changed.
Public Property | IsCreatingLink | Indicates if the user is currently creating a link
Public Property | IsCreatingNode | Indicates if the user is currently creating a node
Public Property | IsFixedSize | Determines whether the size of the diagram panel is fixed or if it depends on the size of the diagram. The default value is false.
Public Property | IsHitTestVisible | Gets or sets whether the contained area of this System.Windows.UIElement can return true values for hit testing. (Inherited from System.Windows.UIElement)
Public Property | IsItemsHost | Gets a value that indicates whether this System.Windows.Controls.Panel is a container for UI items that are generated by an System.Windows.Controls.ItemsControl. (Inherited from System.Windows.Controls.Panel)
Public Property | IsMovingNode | Indicates if the user is currently moving nodes
Public Property | IsPanning | Indicates if the user is currently panning the diagram
Public Property | IsResizingNode | Indicates if the user is currently resising nodes
Public Property | IsRotatingNode | Indicates if the user is currently rotating nodes
Public Property | IsSelecting | Indicates if the user is currently selecting items with the mouse
Public Property | IsStretchingLink | Indicates if the user is currently stretching a link
Public Property | IsVirtualizing | Determines whether virtualizing mode is allowed. This is a UI virtualization, which collapses all items outside the viewable area, thus enhancing the performance while manipulating the items. The default value is false.
Public Property | IsZooming | Indicates if the user is currently zooming the diagram
Public Property | Language | Gets or sets localization/globalization language information that applies to a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | LinkSelectionAreaWidth | Returns/sets the width of the area where the user has to click to select a link.
Public Property | LinkStyle | Gets or sets the Style used for links.
Public Property | Margin | Gets or sets the outer margin of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | Gets or sets the maximum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | Gets or sets the maximum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | Gets or sets the minimum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | Gets or sets the minimum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MouseSelection | Returns/sets the selection rectangle action.
Public Property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from System.Windows.FrameworkElement)
Public Property | NodeStyle | Gets or sets the Style used for nodes.
Public Property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | Gets or sets the brush used to alter the opacity of regions of this object. (Inherited from System.Windows.UIElement)
Public Property | Origin | Return the origin of the diagram
Public Property | Parent | Gets the parent object of this System.Windows.FrameworkElement in the object tree. (Inherited from System.Windows.FrameworkElement)
Public Property | PinStyle | Gets or sets the style used for the node pins.
Public Property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RemovePointDistance | Returns/sets a value that determines if the user can remove a link point by dragging the handle to a position where it has a very obtuse angle to its surrounding link points.
Public Property | RenderSize | Gets the final render size of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | Gets or sets transform information that affects the rendering position of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by System.Windows.UIElement.RenderTransform, relative to the bounds of the System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | ResizeHandleStyle | Gets or sets the style used for the node resizing handles.
Public Property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from System.Windows.FrameworkElement)
Public Property | RotateHandleStyle | Gets or sets the style used for the node rotating handles.
Public Property | ScrollViewer | Returns the ScrollViewer used to scroll the diagram
Public Property | SelectedItems | Returns the list of selected items
Public Property | SelectionBoxStyle | Gets or sets the style used for the selection box.
Public Property | StretchHandleStyle | Gets or sets the style used for the link stretching handles.
Public Property | Style | Gets or sets an instance System.Windows.Style that is applied for this object during rendering. (Inherited from System.Windows.FrameworkElement)
Public Property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from System.Windows.FrameworkElement)
Public Property | TaskManager | Returns the object managing the list of tasks and allowing undo/redo.
Public Property | Triggers | Gets the collection of triggers for animations that are defined for a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from System.Windows.UIElement)
Public Property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | Visibility | Gets or sets the visibility of a System.Windows.UIElement. A System.Windows.UIElement that is not visible does not render and does not communicate its desired size to layout. (Inherited from System.Windows.UIElement)
Public Property | Width | Gets or sets the width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | XamlNodeContent | A xaml string defining the default content of nodes
Public Property | Zoom | Returns/sets the zooming factor.
Public Property | ZoomingBoxStyle | Gets or sets the style used for the zooming box.
Top
See Also

Reference

AddFlow Class
Lassalle.Silverlight.Flow Namespace


BirdView Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : BirdView Property
Returns the object managing the bird view popup
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property BirdView As BirdView
'Usage

Dim instance As AddFlow
Dim value As BirdView

value = instance.BirdView
public BirdView BirdView {get;}
public: __property BirdView* get_BirdView();
public:
property BirdView^ BirdView {
   BirdView^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


CanChangeDst Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : CanChangeDst Property
Determines whether the user can interactively change the destination of a link. The default value is true.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CanChangeDst As Boolean
'Usage

Dim instance As AddFlow
Dim value As Boolean

instance.CanChangeDst = value

value = instance.CanChangeDst
public bool CanChangeDst {get; set;}
public: __property bool get_CanChangeDst();
public: __property void set_CanChangeDst(
   bool value
);
public:
property bool CanChangeDst {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


CanChangeOrg Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : CanChangeOrg Property
Determines whether the user can interactively change the origin of a link. The default value is true.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CanChangeOrg As Boolean
'Usage

Dim instance As AddFlow
Dim value As Boolean

instance.CanChangeOrg = value

value = instance.CanChangeOrg
public bool CanChangeOrg {get; set;}
public: __property bool get_CanChangeOrg();
public: __property void set_CanChangeOrg(
   bool value
);
public:
property bool CanChangeOrg {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


CanDragScroll Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : CanDragScroll Property
Determines whether drag scrolling is allowed or not. The default value is true.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CanDragScroll As Boolean
'Usage

Dim instance As AddFlow
Dim value As Boolean

instance.CanDragScroll = value

value = instance.CanDragScroll
public bool CanDragScroll {get; set;}
public: __property bool get_CanDragScroll();
public: __property void set_CanDragScroll(
   bool value
);
public:
property bool CanDragScroll {
   bool get();
   void set (    bool value);
}
Remarks
Auto scrolling means for instance that when the user moves a node outside the visible part of the control, the control scrolls automatically so that the node stays visible.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


CanDrawLink Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : CanDrawLink Property
Determines whether interactive creation of links is allowed. The default value is true.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CanDrawLink As Boolean
'Usage

Dim instance As AddFlow
Dim value As Boolean

instance.CanDrawLink = value

value = instance.CanDrawLink
public bool CanDrawLink {get; set;}
public: __property bool get_CanDrawLink();
public: __property void set_CanDrawLink(
   bool value
);
public:
property bool CanDrawLink {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


CanDrawNode Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : CanDrawNode Property
Determines whether interactive creation of nodes is allowed. The default value is true.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CanDrawNode As Boolean
'Usage

Dim instance As AddFlow
Dim value As Boolean

instance.CanDrawNode = value

value = instance.CanDrawNode
public bool CanDrawNode {get; set;}
public: __property bool get_CanDrawNode();
public: __property void set_CanDrawNode(
   bool value
);
public:
property bool CanDrawNode {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


CanEditNode Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : CanEditNode Property
Determines whether the user can edit the text of nodes. The default value is true.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CanEditNode As Boolean
'Usage

Dim instance As AddFlow
Dim value As Boolean

instance.CanEditNode = value

value = instance.CanEditNode
public bool CanEditNode {get; set;}
public: __property bool get_CanEditNode();
public: __property void set_CanEditNode(
   bool value
);
public:
property bool CanEditNode {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


CanMoveNode Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : CanMoveNode Property
Determines whether you can drag nodes interactively. The default value is true.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CanMoveNode As Boolean
'Usage

Dim instance As AddFlow
Dim value As Boolean

instance.CanMoveNode = value

value = instance.CanMoveNode
public bool CanMoveNode {get; set;}
public: __property bool get_CanMoveNode();
public: __property void set_CanMoveNode(
   bool value
);
public:
property bool CanMoveNode {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


CanMultiLink Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : CanMultiLink Property
Determines whether you can create several links between two nodes or not. The default value is true.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CanMultiLink As Boolean
'Usage

Dim instance As AddFlow
Dim value As Boolean

instance.CanMultiLink = value

value = instance.CanMultiLink
public bool CanMultiLink {get; set;}
public: __property bool get_CanMultiLink();
public: __property void set_CanMultiLink(
   bool value
);
public:
property bool CanMultiLink {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


CanReflexLink Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : CanReflexLink Property
Determines whether you can create reflexive links. A link is reflexive if its destination and origin nodes are the same. The default value is true.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CanReflexLink As Boolean
'Usage

Dim instance As AddFlow
Dim value As Boolean

instance.CanReflexLink = value

value = instance.CanReflexLink
public bool CanReflexLink {get; set;}
public: __property bool get_CanReflexLink();
public: __property void set_CanReflexLink(
   bool value
);
public:
property bool CanReflexLink {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


CanRotateNode Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : CanRotateNode Property
Determines whether interactive rotation of nodes is allowed. The default value is true.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CanRotateNode As Boolean
'Usage

Dim instance As AddFlow
Dim value As Boolean

instance.CanRotateNode = value

value = instance.CanRotateNode
public bool CanRotateNode {get; set;}
public: __property bool get_CanRotateNode();
public: __property void set_CanRotateNode(
   bool value
);
public:
property bool CanRotateNode {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


CanSelectOnMouseMove Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : CanSelectOnMouseMove Property
Indicates whether the selection of items with the mouse is made only when the MouseUp event is fired or at each MouseMove event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CanSelectOnMouseMove As Boolean
'Usage

Dim instance As AddFlow
Dim value As Boolean

instance.CanSelectOnMouseMove = value

value = instance.CanSelectOnMouseMove
public bool CanSelectOnMouseMove {get; set;}
public: __property bool get_CanSelectOnMouseMove();
public: __property void set_CanSelectOnMouseMove(
   bool value
);
public:
property bool CanSelectOnMouseMove {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


CanSendSelectionChangedEvent Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : CanSendSelectionChangedEvent Property
Determines whether the SelectionChanged event is fired or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CanSendSelectionChangedEvent As Boolean
'Usage

Dim instance As AddFlow
Dim value As Boolean

instance.CanSendSelectionChangedEvent = value

value = instance.CanSendSelectionChangedEvent
public bool CanSendSelectionChangedEvent {get; set;}
public: __property bool get_CanSendSelectionChangedEvent();
public: __property void set_CanSendSelectionChangedEvent(
   bool value
);
public:
property bool CanSendSelectionChangedEvent {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


CanShowContextHandles Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : CanShowContextHandles Property
Indicates whether a context handle is displayed when a node or a link is selected.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CanShowContextHandles As Boolean
'Usage

Dim instance As AddFlow
Dim value As Boolean

instance.CanShowContextHandles = value

value = instance.CanShowContextHandles
public bool CanShowContextHandles {get; set;}
public: __property bool get_CanShowContextHandles();
public: __property void set_CanShowContextHandles(
   bool value
);
public:
property bool CanShowContextHandles {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


CanShowJumps Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : CanShowJumps Property
Determines whether jumps are displayed at the intersection of links. The default value is false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CanShowJumps As Boolean
'Usage

Dim instance As AddFlow
Dim value As Boolean

instance.CanShowJumps = value

value = instance.CanShowJumps
public bool CanShowJumps {get; set;}
public: __property bool get_CanShowJumps();
public: __property void set_CanShowJumps(
   bool value
);
public:
property bool CanShowJumps {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


CanSizeNode Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : CanSizeNode Property
Determines whether you can resize nodes interactively. The default value is true.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CanSizeNode As Boolean
'Usage

Dim instance As AddFlow
Dim value As Boolean

instance.CanSizeNode = value

value = instance.CanSizeNode
public bool CanSizeNode {get; set;}
public: __property bool get_CanSizeNode();
public: __property void set_CanSizeNode(
   bool value
);
public:
property bool CanSizeNode {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


CanStretchLink Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : CanStretchLink Property
Determines whether you can "stretch" links (i.e add or remove segments) interactively. The default value is true.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CanStretchLink As Boolean
'Usage

Dim instance As AddFlow
Dim value As Boolean

instance.CanStretchLink = value

value = instance.CanStretchLink
public bool CanStretchLink {get; set;}
public: __property bool get_CanStretchLink();
public: __property void set_CanStretchLink(
   bool value
);
public:
property bool CanStretchLink {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


ConnectorStyle Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : ConnectorStyle Property
Gets or sets the style used for the set of node pins.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ConnectorStyle As Style
'Usage

Dim instance As AddFlow
Dim value As Style

instance.ConnectorStyle = value

value = instance.ConnectorStyle
public Style ConnectorStyle {get; set;}
public: __property Style* get_ConnectorStyle();
public: __property void set_ConnectorStyle(
   Style* value
);
public:
property Style^ ConnectorStyle {
   Style^ get();
   void set (    Style^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


ContextHandleStyle Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : ContextHandleStyle Property
Gets or sets the Style used for the context handles.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ContextHandleStyle As Style
'Usage

Dim instance As AddFlow
Dim value As Style

instance.ContextHandleStyle = value

value = instance.ContextHandleStyle
public Style ContextHandleStyle {get; set;}
public: __property Style* get_ContextHandleStyle();
public: __property void set_ContextHandleStyle(
   Style* value
);
public:
property Style^ ContextHandleStyle {
   Style^ get();
   void set (    Style^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


Extent Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : Extent Property
Return the size of the diagram.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Extent As Size
'Usage

Dim instance As AddFlow
Dim value As Size

value = instance.Extent
public Size Extent {get;}
public: __property Size get_Extent();
public:
property Size Extent {
   Size get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


GridColor Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : GridColor Property
Returns/sets the grid color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GridColor As Color
'Usage

Dim instance As AddFlow
Dim value As Color

instance.GridColor = value

value = instance.GridColor
public Color GridColor {get; set;}
public: __property Color get_GridColor();
public: __property void set_GridColor(
   Color value
);
public:
property Color GridColor {
   Color get();
   void set (    Color value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


GridDraw Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : GridDraw Property
Determines whether the grid is displayed or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GridDraw As Boolean
'Usage

Dim instance As AddFlow
Dim value As Boolean

instance.GridDraw = value

value = instance.GridDraw
public bool GridDraw {get; set;}
public: __property bool get_GridDraw();
public: __property void set_GridDraw(
   bool value
);
public:
property bool GridDraw {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


GridSize Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : GridSize Property
Returns/sets the horizontal and vertical grid size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GridSize As Size
'Usage

Dim instance As AddFlow
Dim value As Size

instance.GridSize = value

value = instance.GridSize
public Size GridSize {get; set;}
public: __property Size get_GridSize();
public: __property void set_GridSize(
   Size value
);
public:
property Size GridSize {
   Size get();
   void set (    Size value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


GridSnap Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : GridSnap Property
Determines whether nodes are aligned on the grid.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GridSnap As Boolean
'Usage

Dim instance As AddFlow
Dim value As Boolean

instance.GridSnap = value

value = instance.GridSnap
public bool GridSnap {get; set;}
public: __property bool get_GridSnap();
public: __property void set_GridSnap(
   bool value
);
public:
property bool GridSnap {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


IsChanged Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : IsChanged Property
Indicates if the AddFlow diagram has changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property IsChanged As Boolean
'Usage

Dim instance As AddFlow
Dim value As Boolean

value = instance.IsChanged
public bool IsChanged {get;}
public: __property bool get_IsChanged();
public:
property bool IsChanged {
   bool get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


IsCreatingLink Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : IsCreatingLink Property
Indicates if the user is currently creating a link
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsCreatingLink As Boolean
'Usage

Dim instance As AddFlow
Dim value As Boolean

instance.IsCreatingLink = value

value = instance.IsCreatingLink
public bool IsCreatingLink {get; set;}
public: __property bool get_IsCreatingLink();
public: __property void set_IsCreatingLink(
   bool value
);
public:
property bool IsCreatingLink {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


IsCreatingNode Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : IsCreatingNode Property
Indicates if the user is currently creating a node
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsCreatingNode As Boolean
'Usage

Dim instance As AddFlow
Dim value As Boolean

instance.IsCreatingNode = value

value = instance.IsCreatingNode
public bool IsCreatingNode {get; set;}
public: __property bool get_IsCreatingNode();
public: __property void set_IsCreatingNode(
   bool value
);
public:
property bool IsCreatingNode {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


IsFixedSize Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : IsFixedSize Property
Determines whether the size of the diagram panel is fixed or if it depends on the size of the diagram. The default value is false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsFixedSize As Boolean
'Usage

Dim instance As AddFlow
Dim value As Boolean

instance.IsFixedSize = value

value = instance.IsFixedSize
public bool IsFixedSize {get; set;}
public: __property bool get_IsFixedSize();
public: __property void set_IsFixedSize(
   bool value
);
public:
property bool IsFixedSize {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


IsMovingNode Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : IsMovingNode Property
Indicates if the user is currently moving nodes
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsMovingNode As Boolean
'Usage

Dim instance As AddFlow
Dim value As Boolean

instance.IsMovingNode = value

value = instance.IsMovingNode
public bool IsMovingNode {get; set;}
public: __property bool get_IsMovingNode();
public: __property void set_IsMovingNode(
   bool value
);
public:
property bool IsMovingNode {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


IsPanning Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : IsPanning Property
Indicates if the user is currently panning the diagram
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsPanning As Boolean
'Usage

Dim instance As AddFlow
Dim value As Boolean

instance.IsPanning = value

value = instance.IsPanning
public bool IsPanning {get; set;}
public: __property bool get_IsPanning();
public: __property void set_IsPanning(
   bool value
);
public:
property bool IsPanning {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


IsResizingNode Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : IsResizingNode Property
Indicates if the user is currently resising nodes
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsResizingNode As Boolean
'Usage

Dim instance As AddFlow
Dim value As Boolean

instance.IsResizingNode = value

value = instance.IsResizingNode
public bool IsResizingNode {get; set;}
public: __property bool get_IsResizingNode();
public: __property void set_IsResizingNode(
   bool value
);
public:
property bool IsResizingNode {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


IsRotatingNode Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : IsRotatingNode Property
Indicates if the user is currently rotating nodes
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsRotatingNode As Boolean
'Usage

Dim instance As AddFlow
Dim value As Boolean

instance.IsRotatingNode = value

value = instance.IsRotatingNode
public bool IsRotatingNode {get; set;}
public: __property bool get_IsRotatingNode();
public: __property void set_IsRotatingNode(
   bool value
);
public:
property bool IsRotatingNode {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


IsSelecting Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : IsSelecting Property
Indicates if the user is currently selecting items with the mouse
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsSelecting As Boolean
'Usage

Dim instance As AddFlow
Dim value As Boolean

instance.IsSelecting = value

value = instance.IsSelecting
public bool IsSelecting {get; set;}
public: __property bool get_IsSelecting();
public: __property void set_IsSelecting(
   bool value
);
public:
property bool IsSelecting {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


IsStretchingLink Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : IsStretchingLink Property
Indicates if the user is currently stretching a link
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsStretchingLink As Boolean
'Usage

Dim instance As AddFlow
Dim value As Boolean

instance.IsStretchingLink = value

value = instance.IsStretchingLink
public bool IsStretchingLink {get; set;}
public: __property bool get_IsStretchingLink();
public: __property void set_IsStretchingLink(
   bool value
);
public:
property bool IsStretchingLink {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


IsVirtualizing Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : IsVirtualizing Property
Determines whether virtualizing mode is allowed. This is a UI virtualization, which collapses all items outside the viewable area, thus enhancing the performance while manipulating the items. The default value is false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsVirtualizing As Boolean
'Usage

Dim instance As AddFlow
Dim value As Boolean

instance.IsVirtualizing = value

value = instance.IsVirtualizing
public bool IsVirtualizing {get; set;}
public: __property bool get_IsVirtualizing();
public: __property void set_IsVirtualizing(
   bool value
);
public:
property bool IsVirtualizing {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


IsZooming Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : IsZooming Property
Indicates if the user is currently zooming the diagram
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsZooming As Boolean
'Usage

Dim instance As AddFlow
Dim value As Boolean

instance.IsZooming = value

value = instance.IsZooming
public bool IsZooming {get; set;}
public: __property bool get_IsZooming();
public: __property void set_IsZooming(
   bool value
);
public:
property bool IsZooming {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


LinkSelectionAreaWidth Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : LinkSelectionAreaWidth Property
Returns/sets the width of the area where the user has to click to select a link.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LinkSelectionAreaWidth As Integer
'Usage

Dim instance As AddFlow
Dim value As Integer

instance.LinkSelectionAreaWidth = value

value = instance.LinkSelectionAreaWidth
public int LinkSelectionAreaWidth {get; set;}
public: __property int get_LinkSelectionAreaWidth();
public: __property void set_LinkSelectionAreaWidth(
   int value
);
public:
property int LinkSelectionAreaWidth {
   int get();
   void set (    int value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


LinkStyle Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : LinkStyle Property
Gets or sets the Style used for links.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LinkStyle As Style
'Usage

Dim instance As AddFlow
Dim value As Style

instance.LinkStyle = value

value = instance.LinkStyle
public Style LinkStyle {get; set;}
public: __property Style* get_LinkStyle();
public: __property void set_LinkStyle(
   Style* value
);
public:
property Style^ LinkStyle {
   Style^ get();
   void set (    Style^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


MouseSelection Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : MouseSelection Property
Returns/sets the selection rectangle action.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MouseSelection As MouseSelection
'Usage

Dim instance As AddFlow
Dim value As MouseSelection

instance.MouseSelection = value

value = instance.MouseSelection
public MouseSelection MouseSelection {get; set;}
public: __property MouseSelection get_MouseSelection();
public: __property void set_MouseSelection(
   MouseSelection value
);
public:
property MouseSelection MouseSelection {
   MouseSelection get();
   void set (    MouseSelection value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


NodeStyle Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : NodeStyle Property
Gets or sets the Style used for nodes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property NodeStyle As Style
'Usage

Dim instance As AddFlow
Dim value As Style

instance.NodeStyle = value

value = instance.NodeStyle
public Style NodeStyle {get; set;}
public: __property Style* get_NodeStyle();
public: __property void set_NodeStyle(
   Style* value
);
public:
property Style^ NodeStyle {
   Style^ get();
   void set (    Style^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


Origin Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : Origin Property
Return the origin of the diagram
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Origin As Point
'Usage

Dim instance As AddFlow
Dim value As Point

value = instance.Origin
public Point Origin {get;}
public: __property Point get_Origin();
public:
property Point Origin {
   Point get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


PinStyle Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : PinStyle Property
Gets or sets the style used for the node pins.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PinStyle As Style
'Usage

Dim instance As AddFlow
Dim value As Style

instance.PinStyle = value

value = instance.PinStyle
public Style PinStyle {get; set;}
public: __property Style* get_PinStyle();
public: __property void set_PinStyle(
   Style* value
);
public:
property Style^ PinStyle {
   Style^ get();
   void set (    Style^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


RemovePointDistance Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : RemovePointDistance Property
Returns/sets a value that determines if the user can remove a link point by dragging the handle to a position where it has a very obtuse angle to its surrounding link points.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RemovePointDistance As Double
'Usage

Dim instance As AddFlow
Dim value As Double

instance.RemovePointDistance = value

value = instance.RemovePointDistance
public double RemovePointDistance {get; set;}
public: __property double get_RemovePointDistance();
public: __property void set_RemovePointDistance(
   double value
);
public:
property double RemovePointDistance {
   double get();
   void set (    double value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


ResizeHandleStyle Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : ResizeHandleStyle Property
Gets or sets the style used for the node resizing handles.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ResizeHandleStyle As Style
'Usage

Dim instance As AddFlow
Dim value As Style

instance.ResizeHandleStyle = value

value = instance.ResizeHandleStyle
public Style ResizeHandleStyle {get; set;}
public: __property Style* get_ResizeHandleStyle();
public: __property void set_ResizeHandleStyle(
   Style* value
);
public:
property Style^ ResizeHandleStyle {
   Style^ get();
   void set (    Style^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


RotateHandleStyle Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : RotateHandleStyle Property
Gets or sets the style used for the node rotating handles.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RotateHandleStyle As Style
'Usage

Dim instance As AddFlow
Dim value As Style

instance.RotateHandleStyle = value

value = instance.RotateHandleStyle
public Style RotateHandleStyle {get; set;}
public: __property Style* get_RotateHandleStyle();
public: __property void set_RotateHandleStyle(
   Style* value
);
public:
property Style^ RotateHandleStyle {
   Style^ get();
   void set (    Style^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


ScrollViewer Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : ScrollViewer Property
Returns the ScrollViewer used to scroll the diagram
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ScrollViewer As ScrollViewer
'Usage

Dim instance As AddFlow
Dim value As ScrollViewer

value = instance.ScrollViewer
public ScrollViewer ScrollViewer {get;}
public: __property ScrollViewer* get_ScrollViewer();
public:
property ScrollViewer^ ScrollViewer {
   ScrollViewer^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


SelectedItems Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : SelectedItems Property
Returns the list of selected items
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SelectedItems As List(Of ISelectable)
'Usage

Dim instance As AddFlow
Dim value As List(Of ISelectable)

value = instance.SelectedItems
public List<ISelectable> SelectedItems {get;}
public: __property List<ISelectable*>* get_SelectedItems();
public:
property List<ISelectable^>^ SelectedItems {
   List<ISelectable^>^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


SelectionBoxStyle Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : SelectionBoxStyle Property
Gets or sets the style used for the selection box.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SelectionBoxStyle As Style
'Usage

Dim instance As AddFlow
Dim value As Style

instance.SelectionBoxStyle = value

value = instance.SelectionBoxStyle
public Style SelectionBoxStyle {get; set;}
public: __property Style* get_SelectionBoxStyle();
public: __property void set_SelectionBoxStyle(
   Style* value
);
public:
property Style^ SelectionBoxStyle {
   Style^ get();
   void set (    Style^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


StretchHandleStyle Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : StretchHandleStyle Property
Gets or sets the style used for the link stretching handles.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property StretchHandleStyle As Style
'Usage

Dim instance As AddFlow
Dim value As Style

instance.StretchHandleStyle = value

value = instance.StretchHandleStyle
public Style StretchHandleStyle {get; set;}
public: __property Style* get_StretchHandleStyle();
public: __property void set_StretchHandleStyle(
   Style* value
);
public:
property Style^ StretchHandleStyle {
   Style^ get();
   void set (    Style^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


TaskManager Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : TaskManager Property
Returns the object managing the list of tasks and allowing undo/redo.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property TaskManager As TaskManager
'Usage

Dim instance As AddFlow
Dim value As TaskManager

value = instance.TaskManager
public TaskManager TaskManager {get;}
public: __property TaskManager* get_TaskManager();
public:
property TaskManager^ TaskManager {
   TaskManager^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


XamlNodeContent Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : XamlNodeContent Property
A xaml string defining the default content of nodes
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property XamlNodeContent As String
'Usage

Dim instance As AddFlow
Dim value As String

instance.XamlNodeContent = value

value = instance.XamlNodeContent
public string XamlNodeContent {get; set;}
public: __property string* get_XamlNodeContent();
public: __property void set_XamlNodeContent(
   string* value
);
public:
property String^ XamlNodeContent {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


Zoom Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : Zoom Property
Returns/sets the zooming factor.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Zoom As Double
'Usage

Dim instance As AddFlow
Dim value As Double

instance.Zoom = value

value = instance.Zoom
public double Zoom {get; set;}
public: __property double get_Zoom();
public: __property void set_Zoom(
   double value
);
public:
property double Zoom {
   double get();
   void set (    double value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


ZoomingBoxStyle Property

Lassalle.Silverlight.Flow Namespace > AddFlow Class : ZoomingBoxStyle Property
Gets or sets the style used for the zooming box.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ZoomingBoxStyle As Style
'Usage

Dim instance As AddFlow
Dim value As Style

instance.ZoomingBoxStyle = value

value = instance.ZoomingBoxStyle
public Style ZoomingBoxStyle {get; set;}
public: __property Style* get_ZoomingBoxStyle();
public: __property void set_ZoomingBoxStyle(
   Style* value
);
public:
property Style^ ZoomingBoxStyle {
   Style^ get();
   void set (    Style^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


%%PageItemTitle%% $$Fields$$

AddFlow Class Fields

Lassalle.Silverlight.Flow Namespace : AddFlow Class

For a list of all members of this type, see AddFlow members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | CanChangeDstProperty | Identifies the CanChangeDst dependency property
static (Shared in Visual Basic) | CanChangeOrgProperty | Identifies the CanChangeOrg dependency property
static (Shared in Visual Basic) | CanDragScrollProperty | Identifies the CanDragScroll dependency property
static (Shared in Visual Basic) | CanDrawLinkProperty | Identifies the CanDrawLink dependency property
static (Shared in Visual Basic) | CanDrawNodeProperty | Identifies the CanDrawNode dependency property
static (Shared in Visual Basic) | CanEditNodeProperty | Identifies the CanEditNode dependency property.
static (Shared in Visual Basic) | CanMoveNodeProperty | Identifies the CanMoveNode dependency property
static (Shared in Visual Basic) | CanMultiLinkProperty | Identifies the CanMultiLink dependency property
static (Shared in Visual Basic) | CanReflexLinkProperty | Identifies the CanReflexLink dependency property
static (Shared in Visual Basic) | CanRotateNodeProperty | Identifies the CanRotateNode dependency property
static (Shared in Visual Basic) | CanSelectOnMouseMoveProperty | Identifies the CanSelectOnMouseMove dependency property
static (Shared in Visual Basic) | CanSendSelectionChangedEventProperty | Identifies the CanSendSelectionChangedEvent dependency property.
static (Shared in Visual Basic) | CanShowContextHandlesProperty | Identifies the CanShowContextHandles dependency property
static (Shared in Visual Basic) | CanShowJumpsProperty | Identifies the CanShowJumps dependency property
static (Shared in Visual Basic) | CanSizeNodeProperty | Identifies the CanSizeNode dependency property
static (Shared in Visual Basic) | CanStretchLinkProperty | Identifies the CanStretchLink dependency property
static (Shared in Visual Basic) | ConnectorStyleProperty | Identifies the ConnectorStyle dependency property
static (Shared in Visual Basic) | ContextHandleStyleProperty | Identifies the ContextHandleStyle dependency property
static (Shared in Visual Basic) | GridColorProperty | Identifies the GridColor dependency property.
static (Shared in Visual Basic) | GridDrawProperty | Identifies the GridDraw dependency property.
static (Shared in Visual Basic) | GridSizeProperty | Identifies the GridSize dependency property.
static (Shared in Visual Basic) | GridSnapProperty | Identifies the GridSnap dependency property.
static (Shared in Visual Basic) | IsCreatingLinkProperty | Identifies the IsCreatingLink dependency property
static (Shared in Visual Basic) | IsCreatingNodeProperty | Identifies the IsCreatingNode dependency property
static (Shared in Visual Basic) | IsFixedSizeProperty | Identifies the IsFixedSize dependency property
static (Shared in Visual Basic) | IsMovingNodeProperty | Identifies the IsMovingNode dependency property
static (Shared in Visual Basic) | IsPanningProperty | Identifies the IsPanning dependency property
static (Shared in Visual Basic) | IsResizingNodeProperty | Identifies the IsResizingNode dependency property
static (Shared in Visual Basic) | IsRotatingNodeProperty | Identifies the IsRotatingNode dependency property
static (Shared in Visual Basic) | IsSelectingProperty | Identifies the IsSelecting dependency property
static (Shared in Visual Basic) | IsStretchingLinkProperty | Identifies the IsStretchingLink dependency property
static (Shared in Visual Basic) | IsVirtualizingProperty | Identifies the IsVirtualizing dependency property
static (Shared in Visual Basic) | IsZoomingProperty | Identifies the IsZooming dependency property
static (Shared in Visual Basic) | LinkSelectionAreaWidthProperty | Identifies the LinkSelectionAreaWidth dependency property
static (Shared in Visual Basic) | LinkStyleProperty | Identifies the LinkStyle dependency property
static (Shared in Visual Basic) | MouseSelectionProperty | Identifies the MouseSelection dependency property
static (Shared in Visual Basic) | NodeStyleProperty | Identifies the NodeStyle dependency property
static (Shared in Visual Basic) | PinStyleProperty | Identifies the PinStyle dependency property
static (Shared in Visual Basic) | RemovePointDistanceProperty | Identifies the RemovePointDistance dependency property.
static (Shared in Visual Basic) | ResizeHandleStyleProperty | Identifies the ResizeHandleStyle dependency property
static (Shared in Visual Basic) | RotateHandleStyleProperty | Identifies the RotateHandleStyle dependency property
static (Shared in Visual Basic) | SelectionBoxStyleProperty | Identifies the SelectionBoxStyle dependency property
static (Shared in Visual Basic) | StretchHandleStyleProperty | Identifies the StretchHandleStyle dependency property
static (Shared in Visual Basic) | ZoomingBoxStyleProperty | Identifies the ZoomingBoxStyle dependency property
static (Shared in Visual Basic) | ZoomProperty | Identifies the Zoom dependency property
Top
See Also

Reference

AddFlow Class
Lassalle.Silverlight.Flow Namespace


CanChangeDstProperty Field

Lassalle.Silverlight.Flow Namespace > AddFlow Class : CanChangeDstProperty Field
Identifies the CanChangeDst dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly CanChangeDstProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = AddFlow.CanChangeDstProperty
public static readonly DependencyProperty CanChangeDstProperty
public: static readonly DependencyProperty* CanChangeDstProperty
public:
static readonly DependencyProperty^ CanChangeDstProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


CanChangeOrgProperty Field

Lassalle.Silverlight.Flow Namespace > AddFlow Class : CanChangeOrgProperty Field
Identifies the CanChangeOrg dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly CanChangeOrgProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = AddFlow.CanChangeOrgProperty
public static readonly DependencyProperty CanChangeOrgProperty
public: static readonly DependencyProperty* CanChangeOrgProperty
public:
static readonly DependencyProperty^ CanChangeOrgProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


CanDragScrollProperty Field

Lassalle.Silverlight.Flow Namespace > AddFlow Class : CanDragScrollProperty Field
Identifies the CanDragScroll dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly CanDragScrollProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = AddFlow.CanDragScrollProperty
public static readonly DependencyProperty CanDragScrollProperty
public: static readonly DependencyProperty* CanDragScrollProperty
public:
static readonly DependencyProperty^ CanDragScrollProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


CanDrawLinkProperty Field

Lassalle.Silverlight.Flow Namespace > AddFlow Class : CanDrawLinkProperty Field
Identifies the CanDrawLink dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly CanDrawLinkProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = AddFlow.CanDrawLinkProperty
public static readonly DependencyProperty CanDrawLinkProperty
public: static readonly DependencyProperty* CanDrawLinkProperty
public:
static readonly DependencyProperty^ CanDrawLinkProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


CanDrawNodeProperty Field

Lassalle.Silverlight.Flow Namespace > AddFlow Class : CanDrawNodeProperty Field
Identifies the CanDrawNode dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly CanDrawNodeProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = AddFlow.CanDrawNodeProperty
public static readonly DependencyProperty CanDrawNodeProperty
public: static readonly DependencyProperty* CanDrawNodeProperty
public:
static readonly DependencyProperty^ CanDrawNodeProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


CanEditNodeProperty Field

Lassalle.Silverlight.Flow Namespace > AddFlow Class : CanEditNodeProperty Field
Identifies the CanEditNode dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly CanEditNodeProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = AddFlow.CanEditNodeProperty
public static readonly DependencyProperty CanEditNodeProperty
public: static readonly DependencyProperty* CanEditNodeProperty
public:
static readonly DependencyProperty^ CanEditNodeProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


CanMoveNodeProperty Field

Lassalle.Silverlight.Flow Namespace > AddFlow Class : CanMoveNodeProperty Field
Identifies the CanMoveNode dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly CanMoveNodeProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = AddFlow.CanMoveNodeProperty
public static readonly DependencyProperty CanMoveNodeProperty
public: static readonly DependencyProperty* CanMoveNodeProperty
public:
static readonly DependencyProperty^ CanMoveNodeProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


CanMultiLinkProperty Field

Lassalle.Silverlight.Flow Namespace > AddFlow Class : CanMultiLinkProperty Field
Identifies the CanMultiLink dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly CanMultiLinkProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = AddFlow.CanMultiLinkProperty
public static readonly DependencyProperty CanMultiLinkProperty
public: static readonly DependencyProperty* CanMultiLinkProperty
public:
static readonly DependencyProperty^ CanMultiLinkProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


CanReflexLinkProperty Field

Lassalle.Silverlight.Flow Namespace > AddFlow Class : CanReflexLinkProperty Field
Identifies the CanReflexLink dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly CanReflexLinkProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = AddFlow.CanReflexLinkProperty
public static readonly DependencyProperty CanReflexLinkProperty
public: static readonly DependencyProperty* CanReflexLinkProperty
public:
static readonly DependencyProperty^ CanReflexLinkProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


CanRotateNodeProperty Field

Lassalle.Silverlight.Flow Namespace > AddFlow Class : CanRotateNodeProperty Field
Identifies the CanRotateNode dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly CanRotateNodeProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = AddFlow.CanRotateNodeProperty
public static readonly DependencyProperty CanRotateNodeProperty
public: static readonly DependencyProperty* CanRotateNodeProperty
public:
static readonly DependencyProperty^ CanRotateNodeProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


CanSelectOnMouseMoveProperty Field

Lassalle.Silverlight.Flow Namespace > AddFlow Class : CanSelectOnMouseMoveProperty Field
Identifies the CanSelectOnMouseMove dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly CanSelectOnMouseMoveProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = AddFlow.CanSelectOnMouseMoveProperty
public static readonly DependencyProperty CanSelectOnMouseMoveProperty
public: static readonly DependencyProperty* CanSelectOnMouseMoveProperty
public:
static readonly DependencyProperty^ CanSelectOnMouseMoveProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


CanSendSelectionChangedEventProperty Field

Lassalle.Silverlight.Flow Namespace > AddFlow Class : CanSendSelectionChangedEventProperty Field
Identifies the CanSendSelectionChangedEvent dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly CanSendSelectionChangedEventProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = AddFlow.CanSendSelectionChangedEventProperty
public static readonly DependencyProperty CanSendSelectionChangedEventProperty
public: static readonly DependencyProperty* CanSendSelectionChangedEventProperty
public:
static readonly DependencyProperty^ CanSendSelectionChangedEventProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


CanShowContextHandlesProperty Field

Lassalle.Silverlight.Flow Namespace > AddFlow Class : CanShowContextHandlesProperty Field
Identifies the CanShowContextHandles dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly CanShowContextHandlesProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = AddFlow.CanShowContextHandlesProperty
public static readonly DependencyProperty CanShowContextHandlesProperty
public: static readonly DependencyProperty* CanShowContextHandlesProperty
public:
static readonly DependencyProperty^ CanShowContextHandlesProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


CanShowJumpsProperty Field

Lassalle.Silverlight.Flow Namespace > AddFlow Class : CanShowJumpsProperty Field
Identifies the CanShowJumps dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly CanShowJumpsProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = AddFlow.CanShowJumpsProperty
public static readonly DependencyProperty CanShowJumpsProperty
public: static readonly DependencyProperty* CanShowJumpsProperty
public:
static readonly DependencyProperty^ CanShowJumpsProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


CanSizeNodeProperty Field

Lassalle.Silverlight.Flow Namespace > AddFlow Class : CanSizeNodeProperty Field
Identifies the CanSizeNode dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly CanSizeNodeProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = AddFlow.CanSizeNodeProperty
public static readonly DependencyProperty CanSizeNodeProperty
public: static readonly DependencyProperty* CanSizeNodeProperty
public:
static readonly DependencyProperty^ CanSizeNodeProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


CanStretchLinkProperty Field

Lassalle.Silverlight.Flow Namespace > AddFlow Class : CanStretchLinkProperty Field
Identifies the CanStretchLink dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly CanStretchLinkProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = AddFlow.CanStretchLinkProperty
public static readonly DependencyProperty CanStretchLinkProperty
public: static readonly DependencyProperty* CanStretchLinkProperty
public:
static readonly DependencyProperty^ CanStretchLinkProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


ConnectorStyleProperty Field

Lassalle.Silverlight.Flow Namespace > AddFlow Class : ConnectorStyleProperty Field
Identifies the ConnectorStyle dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ConnectorStyleProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = AddFlow.ConnectorStyleProperty
public static readonly DependencyProperty ConnectorStyleProperty
public: static readonly DependencyProperty* ConnectorStyleProperty
public:
static readonly DependencyProperty^ ConnectorStyleProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


ContextHandleStyleProperty Field

Lassalle.Silverlight.Flow Namespace > AddFlow Class : ContextHandleStyleProperty Field
Identifies the ContextHandleStyle dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ContextHandleStyleProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = AddFlow.ContextHandleStyleProperty
public static readonly DependencyProperty ContextHandleStyleProperty
public: static readonly DependencyProperty* ContextHandleStyleProperty
public:
static readonly DependencyProperty^ ContextHandleStyleProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


GridColorProperty Field

Lassalle.Silverlight.Flow Namespace > AddFlow Class : GridColorProperty Field
Identifies the GridColor dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly GridColorProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = AddFlow.GridColorProperty
public static readonly DependencyProperty GridColorProperty
public: static readonly DependencyProperty* GridColorProperty
public:
static readonly DependencyProperty^ GridColorProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


GridDrawProperty Field

Lassalle.Silverlight.Flow Namespace > AddFlow Class : GridDrawProperty Field
Identifies the GridDraw dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly GridDrawProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = AddFlow.GridDrawProperty
public static readonly DependencyProperty GridDrawProperty
public: static readonly DependencyProperty* GridDrawProperty
public:
static readonly DependencyProperty^ GridDrawProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


GridSizeProperty Field

Lassalle.Silverlight.Flow Namespace > AddFlow Class : GridSizeProperty Field
Identifies the GridSize dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly GridSizeProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = AddFlow.GridSizeProperty
public static readonly DependencyProperty GridSizeProperty
public: static readonly DependencyProperty* GridSizeProperty
public:
static readonly DependencyProperty^ GridSizeProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


GridSnapProperty Field

Lassalle.Silverlight.Flow Namespace > AddFlow Class : GridSnapProperty Field
Identifies the GridSnap dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly GridSnapProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = AddFlow.GridSnapProperty
public static readonly DependencyProperty GridSnapProperty
public: static readonly DependencyProperty* GridSnapProperty
public:
static readonly DependencyProperty^ GridSnapProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


IsCreatingLinkProperty Field

Lassalle.Silverlight.Flow Namespace > AddFlow Class : IsCreatingLinkProperty Field
Identifies the IsCreatingLink dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly IsCreatingLinkProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = AddFlow.IsCreatingLinkProperty
public static readonly DependencyProperty IsCreatingLinkProperty
public: static readonly DependencyProperty* IsCreatingLinkProperty
public:
static readonly DependencyProperty^ IsCreatingLinkProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


IsCreatingNodeProperty Field

Lassalle.Silverlight.Flow Namespace > AddFlow Class : IsCreatingNodeProperty Field
Identifies the IsCreatingNode dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly IsCreatingNodeProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = AddFlow.IsCreatingNodeProperty
public static readonly DependencyProperty IsCreatingNodeProperty
public: static readonly DependencyProperty* IsCreatingNodeProperty
public:
static readonly DependencyProperty^ IsCreatingNodeProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


IsFixedSizeProperty Field

Lassalle.Silverlight.Flow Namespace > AddFlow Class : IsFixedSizeProperty Field
Identifies the IsFixedSize dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly IsFixedSizeProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = AddFlow.IsFixedSizeProperty
public static readonly DependencyProperty IsFixedSizeProperty
public: static readonly DependencyProperty* IsFixedSizeProperty
public:
static readonly DependencyProperty^ IsFixedSizeProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


IsMovingNodeProperty Field

Lassalle.Silverlight.Flow Namespace > AddFlow Class : IsMovingNodeProperty Field
Identifies the IsMovingNode dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly IsMovingNodeProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = AddFlow.IsMovingNodeProperty
public static readonly DependencyProperty IsMovingNodeProperty
public: static readonly DependencyProperty* IsMovingNodeProperty
public:
static readonly DependencyProperty^ IsMovingNodeProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


IsPanningProperty Field

Lassalle.Silverlight.Flow Namespace > AddFlow Class : IsPanningProperty Field
Identifies the IsPanning dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly IsPanningProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = AddFlow.IsPanningProperty
public static readonly DependencyProperty IsPanningProperty
public: static readonly DependencyProperty* IsPanningProperty
public:
static readonly DependencyProperty^ IsPanningProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


IsResizingNodeProperty Field

Lassalle.Silverlight.Flow Namespace > AddFlow Class : IsResizingNodeProperty Field
Identifies the IsResizingNode dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly IsResizingNodeProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = AddFlow.IsResizingNodeProperty
public static readonly DependencyProperty IsResizingNodeProperty
public: static readonly DependencyProperty* IsResizingNodeProperty
public:
static readonly DependencyProperty^ IsResizingNodeProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


IsRotatingNodeProperty Field

Lassalle.Silverlight.Flow Namespace > AddFlow Class : IsRotatingNodeProperty Field
Identifies the IsRotatingNode dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly IsRotatingNodeProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = AddFlow.IsRotatingNodeProperty
public static readonly DependencyProperty IsRotatingNodeProperty
public: static readonly DependencyProperty* IsRotatingNodeProperty
public:
static readonly DependencyProperty^ IsRotatingNodeProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


IsSelectingProperty Field

Lassalle.Silverlight.Flow Namespace > AddFlow Class : IsSelectingProperty Field
Identifies the IsSelecting dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly IsSelectingProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = AddFlow.IsSelectingProperty
public static readonly DependencyProperty IsSelectingProperty
public: static readonly DependencyProperty* IsSelectingProperty
public:
static readonly DependencyProperty^ IsSelectingProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


IsStretchingLinkProperty Field

Lassalle.Silverlight.Flow Namespace > AddFlow Class : IsStretchingLinkProperty Field
Identifies the IsStretchingLink dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly IsStretchingLinkProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = AddFlow.IsStretchingLinkProperty
public static readonly DependencyProperty IsStretchingLinkProperty
public: static readonly DependencyProperty* IsStretchingLinkProperty
public:
static readonly DependencyProperty^ IsStretchingLinkProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


IsVirtualizingProperty Field

Lassalle.Silverlight.Flow Namespace > AddFlow Class : IsVirtualizingProperty Field
Identifies the IsVirtualizing dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly IsVirtualizingProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = AddFlow.IsVirtualizingProperty
public static readonly DependencyProperty IsVirtualizingProperty
public: static readonly DependencyProperty* IsVirtualizingProperty
public:
static readonly DependencyProperty^ IsVirtualizingProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


IsZoomingProperty Field

Lassalle.Silverlight.Flow Namespace > AddFlow Class : IsZoomingProperty Field
Identifies the IsZooming dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly IsZoomingProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = AddFlow.IsZoomingProperty
public static readonly DependencyProperty IsZoomingProperty
public: static readonly DependencyProperty* IsZoomingProperty
public:
static readonly DependencyProperty^ IsZoomingProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


LinkSelectionAreaWidthProperty Field

Lassalle.Silverlight.Flow Namespace > AddFlow Class : LinkSelectionAreaWidthProperty Field
Identifies the LinkSelectionAreaWidth dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly LinkSelectionAreaWidthProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = AddFlow.LinkSelectionAreaWidthProperty
public static readonly DependencyProperty LinkSelectionAreaWidthProperty
public: static readonly DependencyProperty* LinkSelectionAreaWidthProperty
public:
static readonly DependencyProperty^ LinkSelectionAreaWidthProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


LinkStyleProperty Field

Lassalle.Silverlight.Flow Namespace > AddFlow Class : LinkStyleProperty Field
Identifies the LinkStyle dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly LinkStyleProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = AddFlow.LinkStyleProperty
public static readonly DependencyProperty LinkStyleProperty
public: static readonly DependencyProperty* LinkStyleProperty
public:
static readonly DependencyProperty^ LinkStyleProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


MouseSelectionProperty Field

Lassalle.Silverlight.Flow Namespace > AddFlow Class : MouseSelectionProperty Field
Identifies the MouseSelection dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly MouseSelectionProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = AddFlow.MouseSelectionProperty
public static readonly DependencyProperty MouseSelectionProperty
public: static readonly DependencyProperty* MouseSelectionProperty
public:
static readonly DependencyProperty^ MouseSelectionProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


NodeStyleProperty Field

Lassalle.Silverlight.Flow Namespace > AddFlow Class : NodeStyleProperty Field
Identifies the NodeStyle dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly NodeStyleProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = AddFlow.NodeStyleProperty
public static readonly DependencyProperty NodeStyleProperty
public: static readonly DependencyProperty* NodeStyleProperty
public:
static readonly DependencyProperty^ NodeStyleProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


PinStyleProperty Field

Lassalle.Silverlight.Flow Namespace > AddFlow Class : PinStyleProperty Field
Identifies the PinStyle dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly PinStyleProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = AddFlow.PinStyleProperty
public static readonly DependencyProperty PinStyleProperty
public: static readonly DependencyProperty* PinStyleProperty
public:
static readonly DependencyProperty^ PinStyleProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


RemovePointDistanceProperty Field

Lassalle.Silverlight.Flow Namespace > AddFlow Class : RemovePointDistanceProperty Field
Identifies the RemovePointDistance dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly RemovePointDistanceProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = AddFlow.RemovePointDistanceProperty
public static readonly DependencyProperty RemovePointDistanceProperty
public: static readonly DependencyProperty* RemovePointDistanceProperty
public:
static readonly DependencyProperty^ RemovePointDistanceProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


ResizeHandleStyleProperty Field

Lassalle.Silverlight.Flow Namespace > AddFlow Class : ResizeHandleStyleProperty Field
Identifies the ResizeHandleStyle dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ResizeHandleStyleProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = AddFlow.ResizeHandleStyleProperty
public static readonly DependencyProperty ResizeHandleStyleProperty
public: static readonly DependencyProperty* ResizeHandleStyleProperty
public:
static readonly DependencyProperty^ ResizeHandleStyleProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


RotateHandleStyleProperty Field

Lassalle.Silverlight.Flow Namespace > AddFlow Class : RotateHandleStyleProperty Field
Identifies the RotateHandleStyle dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly RotateHandleStyleProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = AddFlow.RotateHandleStyleProperty
public static readonly DependencyProperty RotateHandleStyleProperty
public: static readonly DependencyProperty* RotateHandleStyleProperty
public:
static readonly DependencyProperty^ RotateHandleStyleProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


SelectionBoxStyleProperty Field

Lassalle.Silverlight.Flow Namespace > AddFlow Class : SelectionBoxStyleProperty Field
Identifies the SelectionBoxStyle dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly SelectionBoxStyleProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = AddFlow.SelectionBoxStyleProperty
public static readonly DependencyProperty SelectionBoxStyleProperty
public: static readonly DependencyProperty* SelectionBoxStyleProperty
public:
static readonly DependencyProperty^ SelectionBoxStyleProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


StretchHandleStyleProperty Field

Lassalle.Silverlight.Flow Namespace > AddFlow Class : StretchHandleStyleProperty Field
Identifies the StretchHandleStyle dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly StretchHandleStyleProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = AddFlow.StretchHandleStyleProperty
public static readonly DependencyProperty StretchHandleStyleProperty
public: static readonly DependencyProperty* StretchHandleStyleProperty
public:
static readonly DependencyProperty^ StretchHandleStyleProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


ZoomingBoxStyleProperty Field

Lassalle.Silverlight.Flow Namespace > AddFlow Class : ZoomingBoxStyleProperty Field
Identifies the ZoomingBoxStyle dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ZoomingBoxStyleProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = AddFlow.ZoomingBoxStyleProperty
public static readonly DependencyProperty ZoomingBoxStyleProperty
public: static readonly DependencyProperty* ZoomingBoxStyleProperty
public:
static readonly DependencyProperty^ ZoomingBoxStyleProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


ZoomProperty Field

Lassalle.Silverlight.Flow Namespace > AddFlow Class : ZoomProperty Field
Identifies the Zoom dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ZoomProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = AddFlow.ZoomProperty
public static readonly DependencyProperty ZoomProperty
public: static readonly DependencyProperty* ZoomProperty
public:
static readonly DependencyProperty^ ZoomProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


%%PageItemTitle%% $$Events$$

AddFlow Class Events

Lassalle.Silverlight.Flow Namespace : AddFlow Class

For a list of all members of this type, see AddFlow members.

Public Events
Name | Description
Public Event | AfterEdit | Occurs after a user edits the text of the selected node.
Public Event | BeforeEdit | Occurs when a user attempts to edit the text of the selected node. Cancelling the action aborts the inline edit.
Public Event | BindingValidationError | Occurs when a data validation error is reported by a binding source. (Inherited from System.Windows.FrameworkElement)
Public Event | CancelEdit | Occurs after a user cancels the text edition of the selected node.
Public Event | ContextHandleClicked | Occurs when a Context handle is clicked.
Public Event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from System.Windows.FrameworkElement)
Public Event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from System.Windows.UIElement)
Public Event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from System.Windows.UIElement)
Public Event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from System.Windows.UIElement)
Public Event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from System.Windows.UIElement)
Public Event | DstChanged | Occurs after a user has changed the destination node of a link.
Public Event | DstChanging | Occurs when a user attempts to change the destination node of a link.
Public Event Error This event is fired when the user tries to make some actions that are not allowed:
  • - creating a reflexive link if the CanReflexLink property is false
  • - creating a second link between 2 nodes if the CanMultiLink property is false
  • - creating a link to a node that does not accept coming (int) links
  • - creating a link from a node that does not accept leaving (out) links
Public Event | GotFocus | Occurs when a System.Windows.UIElement receives focus. (Inherited from System.Windows.UIElement)
Public Event | KeyDown | Occurs when a keyboard key is pressed while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | KeyUp | Occurs when a keyboard key is released while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | Occurs when the layout of the Silverlight visual tree changes. (Inherited from System.Windows.FrameworkElement)
Public Event | LinkCreated | Occurs after a user creates a link.
Public Event | LinkDeleted | Occurs after a user removes a link.
Public Event | Loaded | Occurs when a System.Windows.FrameworkElement has been constructed and added to the object tree. (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | Occurs when a System.Windows.UIElement loses focus. (Inherited from System.Windows.UIElement)
Public Event | LostMouseCapture | Occurs when the System.Windows.UIElement loses mouse capture. (Inherited from System.Windows.UIElement)
Public Event | MediaCommand | Occurs when a button is pressed on a remote control. (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | Occurs when the mouse (or a stylus) enters the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | Occurs when the mouse (or the stylus) leaves the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | Occurs when the left mouse button is pressed (or when the tip of the stylus touches the tablet) while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | Occurs when the left mouse button is released (or the tip of the stylus is removed from the tablet) while the mouse (or the stylus) is over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseMove | Occurs when the coordinate position of the mouse (or stylus) changes while over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over a System.Windows.UIElement. However, this event will only be raised if a caller marks the preceding System.Windows.UIElement.MouseRightButtonDown event as handled; see Remarks. (Inherited from System.Windows.UIElement)
Public Event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over a System.Windows.UIElement, or the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | NodeCreated | Occurs after a user creates a node.
Public Event | NodeDeleted | Occurs after a user removes a node.
Public Event | OrgChanged | Occurs after a user has changed the origin node of a link.
Public Event | OrgChanging | Occurs when a user attempts to change the origin node of a link.
Public Event | SelectedLinkStretching | Occurs when a user is currently stretching a link.
Public Event | SelectedNodesLayouting | Occurs when a user is currently moving or resizing a node
Public Event | SelectedNodesRotating | Occurs when a user is currently rotating a node
Public Event | SelectionChanged | Occurs when the selection status of an item is changed
Public Event | SizeChanged | Occurs when either the System.Windows.FrameworkElement.ActualHeight or the System.Windows.FrameworkElement.ActualWidth properties change value on a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Event | TextInput | Occurs when a UI element gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputStart | Occurs when a UI element initially gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputUpdate | Occurs when text continues to be composed via an input method editor (IME). (Inherited from System.Windows.UIElement)
Public Event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from System.Windows.FrameworkElement)
Public Event | Zoomed | Occurs when the zoom factor is changed
Top
See Also

Reference

AddFlow Class
Lassalle.Silverlight.Flow Namespace


AfterEdit Event

Lassalle.Silverlight.Flow Namespace > AddFlow Class : AfterEdit Event
Occurs after a user edits the text of the selected node.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event AfterEdit As AddFlow.AfterEditEventHandler
'Usage

Dim instance As AddFlow
Dim handler As AddFlow.AfterEditEventHandler

AddHandler instance.AfterEdit, handler
public event AddFlow.AfterEditEventHandler AfterEdit
public: __event AddFlow.AfterEditEventHandler* AfterEdit
public:
event AddFlow.AfterEditEventHandler^ AfterEdit
Event Data

The event handler receives an argument of type AfterEditEventArgs containing data related to this event. The following AfterEditEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets/sets a value indicating whether the edition should be canceled.
Node | The node that has just been edited (read-only)
OriginalSource (Inherited from System.Windows.RoutedEventArgs) | Gets a reference to the object that raised the event.
Text | Gets/sets the text of the node being edited.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


BeforeEdit Event

Lassalle.Silverlight.Flow Namespace > AddFlow Class : BeforeEdit Event
Occurs when a user attempts to edit the text of the selected node. Cancelling the action aborts the inline edit.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event BeforeEdit As AddFlow.BeforeEditEventHandler
'Usage

Dim instance As AddFlow
Dim handler As AddFlow.BeforeEditEventHandler

AddHandler instance.BeforeEdit, handler
public event AddFlow.BeforeEditEventHandler BeforeEdit
public: __event AddFlow.BeforeEditEventHandler* BeforeEdit
public:
event AddFlow.BeforeEditEventHandler^ BeforeEdit
Event Data

The event handler receives an argument of type BeforeEditEventArgs containing data related to this event. The following BeforeEditEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets/sets a value indicating whether the edition should be canceled.
Node | The node that is going to be edited (read-only)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


CancelEdit Event

Lassalle.Silverlight.Flow Namespace > AddFlow Class : CancelEdit Event
Occurs after a user cancels the text edition of the selected node.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event CancelEdit As AddFlow.CancelEditEventHandler
'Usage

Dim instance As AddFlow
Dim handler As AddFlow.CancelEditEventHandler

AddHandler instance.CancelEdit, handler
public event AddFlow.CancelEditEventHandler CancelEdit
public: __event AddFlow.CancelEditEventHandler* CancelEdit
public:
event AddFlow.CancelEditEventHandler^ CancelEdit
Event Data

The event handler receives an argument of type CancelEditEventArgs containing data related to this event. The following CancelEditEventArgs properties provide information specific to this event.

Property | Description
Node | The node that has just been edited (read-only)
OriginalSource (Inherited from System.Windows.RoutedEventArgs) | Gets a reference to the object that raised the event.
Text | Gets/sets the text of the node being edited.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


ContextHandleClicked Event

Lassalle.Silverlight.Flow Namespace > AddFlow Class : ContextHandleClicked Event
Occurs when a Context handle is clicked.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event ContextHandleClicked As AddFlow.ContextHandleClickedEventHandler
'Usage

Dim instance As AddFlow
Dim handler As AddFlow.ContextHandleClickedEventHandler

AddHandler instance.ContextHandleClicked, handler
public event AddFlow.ContextHandleClickedEventHandler ContextHandleClicked
public: __event AddFlow.ContextHandleClickedEventHandler* ContextHandleClicked
public:
event AddFlow.ContextHandleClickedEventHandler^ ContextHandleClicked
Event Data

The event handler receives an argument of type ContextHandleClickedEventArgs containing data related to this event. The following ContextHandleClickedEventArgs properties provide information specific to this event.

Property | Description
Item | The item owning the ContextHandle (read-only)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


DstChanged Event

Lassalle.Silverlight.Flow Namespace > AddFlow Class : DstChanged Event
Occurs after a user has changed the destination node of a link.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event DstChanged As AddFlow.DstChangedEventHandler
'Usage

Dim instance As AddFlow
Dim handler As AddFlow.DstChangedEventHandler

AddHandler instance.DstChanged, handler
public event AddFlow.DstChangedEventHandler DstChanged
public: __event AddFlow.DstChangedEventHandler* DstChanged
public:
event AddFlow.DstChangedEventHandler^ DstChanged
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


DstChanging Event

Lassalle.Silverlight.Flow Namespace > AddFlow Class : DstChanging Event
Occurs when a user attempts to change the destination node of a link.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event DstChanging As AddFlow.DstChangingEventHandler
'Usage

Dim instance As AddFlow
Dim handler As AddFlow.DstChangingEventHandler

AddHandler instance.DstChanging, handler
public event AddFlow.DstChangingEventHandler DstChanging
public: __event AddFlow.DstChangingEventHandler* DstChanging
public:
event AddFlow.DstChangingEventHandler^ DstChanging
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


Error Event

Lassalle.Silverlight.Flow Namespace > AddFlow Class : Error Event
This event is fired when the user tries to make some actions that are not allowed:
  • - creating a reflexive link if the CanReflexLink property is false
  • - creating a second link between 2 nodes if the CanMultiLink property is false
  • - creating a link to a node that does not accept coming (int) links
  • - creating a link from a node that does not accept leaving (out) links
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event Error As AddFlow.ErrorEventHandler
'Usage

Dim instance As AddFlow
Dim handler As AddFlow.ErrorEventHandler

AddHandler instance.Error, handler
public event AddFlow.ErrorEventHandler Error
public: __event AddFlow.ErrorEventHandler* Error
public:
event AddFlow.ErrorEventHandler^ Error
Event Data

The event handler receives an argument of type ErrorEventArgs containing data related to this event. The following ErrorEventArgs properties provide information specific to this event.

Property | Description
ErrorEventType | The type of the error event (read-only)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


LinkCreated Event

Lassalle.Silverlight.Flow Namespace > AddFlow Class : LinkCreated Event
Occurs after a user creates a link.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event LinkCreated As AddFlow.LinkCreatedEventHandler
'Usage

Dim instance As AddFlow
Dim handler As AddFlow.LinkCreatedEventHandler

AddHandler instance.LinkCreated, handler
public event AddFlow.LinkCreatedEventHandler LinkCreated
public: __event AddFlow.LinkCreatedEventHandler* LinkCreated
public:
event AddFlow.LinkCreatedEventHandler^ LinkCreated
Event Data

The event handler receives an argument of type LinkCreatedEventArgs containing data related to this event. The following LinkCreatedEventArgs properties provide information specific to this event.

Property | Description
Link | The link that has just been created (read-only)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


LinkDeleted Event

Lassalle.Silverlight.Flow Namespace > AddFlow Class : LinkDeleted Event
Occurs after a user removes a link.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event LinkDeleted As AddFlow.LinkDeletedEventHandler
'Usage

Dim instance As AddFlow
Dim handler As AddFlow.LinkDeletedEventHandler

AddHandler instance.LinkDeleted, handler
public event AddFlow.LinkDeletedEventHandler LinkDeleted
public: __event AddFlow.LinkDeletedEventHandler* LinkDeleted
public:
event AddFlow.LinkDeletedEventHandler^ LinkDeleted
Event Data

The event handler receives an argument of type LinkDeletedEventArgs containing data related to this event. The following LinkDeletedEventArgs properties provide information specific to this event.

Property | Description
Link | The link that has just been removed (read-only)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


NodeCreated Event

Lassalle.Silverlight.Flow Namespace > AddFlow Class : NodeCreated Event
Occurs after a user creates a node.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event NodeCreated As AddFlow.NodeCreatedEventHandler
'Usage

Dim instance As AddFlow
Dim handler As AddFlow.NodeCreatedEventHandler

AddHandler instance.NodeCreated, handler
public event AddFlow.NodeCreatedEventHandler NodeCreated
public: __event AddFlow.NodeCreatedEventHandler* NodeCreated
public:
event AddFlow.NodeCreatedEventHandler^ NodeCreated
Event Data

The event handler receives an argument of type NodeCreatedEventArgs containing data related to this event. The following NodeCreatedEventArgs properties provide information specific to this event.

Property | Description
Node | The node that has just been created (read-only)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


NodeDeleted Event

Lassalle.Silverlight.Flow Namespace > AddFlow Class : NodeDeleted Event
Occurs after a user removes a node.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event NodeDeleted As AddFlow.NodeDeletedEventHandler
'Usage

Dim instance As AddFlow
Dim handler As AddFlow.NodeDeletedEventHandler

AddHandler instance.NodeDeleted, handler
public event AddFlow.NodeDeletedEventHandler NodeDeleted
public: __event AddFlow.NodeDeletedEventHandler* NodeDeleted
public:
event AddFlow.NodeDeletedEventHandler^ NodeDeleted
Event Data

The event handler receives an argument of type NodeDeletedEventArgs containing data related to this event. The following NodeDeletedEventArgs properties provide information specific to this event.

Property | Description
Node | The node that has just been removed (read-only)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


OrgChanged Event

Lassalle.Silverlight.Flow Namespace > AddFlow Class : OrgChanged Event
Occurs after a user has changed the origin node of a link.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event OrgChanged As AddFlow.OrgChangedEventHandler
'Usage

Dim instance As AddFlow
Dim handler As AddFlow.OrgChangedEventHandler

AddHandler instance.OrgChanged, handler
public event AddFlow.OrgChangedEventHandler OrgChanged
public: __event AddFlow.OrgChangedEventHandler* OrgChanged
public:
event AddFlow.OrgChangedEventHandler^ OrgChanged
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


OrgChanging Event

Lassalle.Silverlight.Flow Namespace > AddFlow Class : OrgChanging Event
Occurs when a user attempts to change the origin node of a link.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event OrgChanging As AddFlow.OrgChangingEventHandler
'Usage

Dim instance As AddFlow
Dim handler As AddFlow.OrgChangingEventHandler

AddHandler instance.OrgChanging, handler
public event AddFlow.OrgChangingEventHandler OrgChanging
public: __event AddFlow.OrgChangingEventHandler* OrgChanging
public:
event AddFlow.OrgChangingEventHandler^ OrgChanging
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


SelectedLinkStretching Event

Lassalle.Silverlight.Flow Namespace > AddFlow Class : SelectedLinkStretching Event
Occurs when a user is currently stretching a link.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event SelectedLinkStretching As AddFlow.SelectedLinkStretchingEventHandler
'Usage

Dim instance As AddFlow
Dim handler As AddFlow.SelectedLinkStretchingEventHandler

AddHandler instance.SelectedLinkStretching, handler
public event AddFlow.SelectedLinkStretchingEventHandler SelectedLinkStretching
public: __event AddFlow.SelectedLinkStretchingEventHandler* SelectedLinkStretching
public:
event AddFlow.SelectedLinkStretchingEventHandler^ SelectedLinkStretching
Event Data

The event handler receives an argument of type SelectedLinkStretchingEventArgs containing data related to this event. The following SelectedLinkStretchingEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets/sets a value indicating whether the stretching action should be canceled.
Link | The link being stretched (read-only)
MousePosition | A Point specifying the mouse cursor position (read-only)
OriginalSource (Inherited from System.Windows.RoutedEventArgs) | Gets a reference to the object that raised the event.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


SelectedNodesLayouting Event

Lassalle.Silverlight.Flow Namespace > AddFlow Class : SelectedNodesLayouting Event
Occurs when a user is currently moving or resizing a node
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event SelectedNodesLayouting As AddFlow.SelectedNodesLayoutingEventHandler
'Usage

Dim instance As AddFlow
Dim handler As AddFlow.SelectedNodesLayoutingEventHandler

AddHandler instance.SelectedNodesLayouting, handler
public event AddFlow.SelectedNodesLayoutingEventHandler SelectedNodesLayouting
public: __event AddFlow.SelectedNodesLayoutingEventHandler* SelectedNodesLayouting
public:
event AddFlow.SelectedNodesLayoutingEventHandler^ SelectedNodesLayouting
Event Data

The event handler receives an argument of type SelectedNodesLayoutingEventArgs containing data related to this event. The following SelectedNodesLayoutingEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets/sets a value indicating whether the moving or resizing action should be canceled.
MousePosition | A Point specifying the mouse cursor position (read-only)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


SelectedNodesRotating Event

Lassalle.Silverlight.Flow Namespace > AddFlow Class : SelectedNodesRotating Event
Occurs when a user is currently rotating a node
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event SelectedNodesRotating As AddFlow.SelectedNodesRotatingEventHandler
'Usage

Dim instance As AddFlow
Dim handler As AddFlow.SelectedNodesRotatingEventHandler

AddHandler instance.SelectedNodesRotating, handler
public event AddFlow.SelectedNodesRotatingEventHandler SelectedNodesRotating
public: __event AddFlow.SelectedNodesRotatingEventHandler* SelectedNodesRotating
public:
event AddFlow.SelectedNodesRotatingEventHandler^ SelectedNodesRotating
Event Data

The event handler receives an argument of type SelectedNodesRotatingEventArgs containing data related to this event. The following SelectedNodesRotatingEventArgs properties provide information specific to this event.

Property | Description
Angle | A double specifying the rotation angle value (read-only)
Cancel | Gets/sets a value indicating whether the moving or resizing action should be canceled.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


SelectionChanged Event

Lassalle.Silverlight.Flow Namespace > AddFlow Class : SelectionChanged Event
Occurs when the selection status of an item is changed
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event SelectionChanged As AddFlow.SelectionChangedEventHandler
'Usage

Dim instance As AddFlow
Dim handler As AddFlow.SelectionChangedEventHandler

AddHandler instance.SelectionChanged, handler
public event AddFlow.SelectionChangedEventHandler SelectionChanged
public: __event AddFlow.SelectionChangedEventHandler* SelectionChanged
public:
event AddFlow.SelectionChangedEventHandler^ SelectionChanged
Event Data

The event handler receives an argument of type SelectionChangedEventArgs containing data related to this event. The following SelectionChangedEventArgs properties provide information specific to this event.

Property | Description
Item | The item whose selection status has changed (read-only)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


Zoomed Event

Lassalle.Silverlight.Flow Namespace > AddFlow Class : Zoomed Event
Occurs when the zoom factor is changed
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event Zoomed As AddFlow.ZoomedEventHandler
'Usage

Dim instance As AddFlow
Dim handler As AddFlow.ZoomedEventHandler

AddHandler instance.Zoomed, handler
public event AddFlow.ZoomedEventHandler Zoomed
public: __event AddFlow.ZoomedEventHandler* Zoomed
public:
event AddFlow.ZoomedEventHandler^ Zoomed
Event Data

The event handler receives an argument of type ZoomedEventArgs containing data related to this event. The following ZoomedEventArgs properties provide information specific to this event.

Property | Description
newZoom | The new zoom value (read-only)
OldZoom | The old zoom value (read-only)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow Class
AddFlow Members


%%PageItemTitle%%

AfterEditEventArgs Class
Members

Lassalle.Silverlight.Flow Namespace : AfterEditEventArgs Class
Event parameters used for the AfterEdit event
Object Model
AfterEditEventArgs ClassNode Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class AfterEditEventArgs
   Inherits System.Windows.RoutedEventArgs
'Usage

Dim instance As AfterEditEventArgs
public class AfterEditEventArgs : System.Windows.RoutedEventArgs
public __gc class AfterEditEventArgs : public System.Windows.RoutedEventArgs
public ref class AfterEditEventArgs : public System.Windows.RoutedEventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
System.Windows.RoutedEventArgs
Lassalle.Silverlight.Flow.AfterEditEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AfterEditEventArgs Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Members$$

AfterEditEventArgs Class Members
Properties

Lassalle.Silverlight.Flow Namespace : AfterEditEventArgs Class

The following tables list the members exposed by AfterEditEventArgs.

Public Constructors
 | Name | Description
Public Constructor | AfterEditEventArgs Constructor | Constructor. Creates a new AfterEditEventArgs instance.
Top
Public Properties
 | Name | Description
Public Property | Cancel | Gets/sets a value indicating whether the edition should be canceled.
Public Property | Node | The node that has just been edited (read-only)
Public Property | OriginalSource | Gets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
Public Property | Text | Gets/sets the text of the node being edited.
Top
See Also

Reference

AfterEditEventArgs Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

AfterEditEventArgs Constructor

Lassalle.Silverlight.Flow Namespace > AfterEditEventArgs Class : AfterEditEventArgs Constructor
Text of the node being edited.
A reference to the node that has just been edited.
Constructor. Creates a new AfterEditEventArgs instance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal text As String, _
   ByVal node As Node _
)
'Usage

Dim text As String
Dim node As Node

Dim instance As New AfterEditEventArgs(text, node)
public AfterEditEventArgs(
   string text,
   Node node
)
public: AfterEditEventArgs(
   string* text,
   Node* node
)
public:
AfterEditEventArgs(
   String^ text,
   Node^ node
)

Parameters

text
Text of the node being edited.
node
A reference to the node that has just been edited.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AfterEditEventArgs Class
AfterEditEventArgs Members


%%PageItemTitle%% $$Properties$$

AfterEditEventArgs Class Properties

Lassalle.Silverlight.Flow Namespace : AfterEditEventArgs Class

For a list of all members of this type, see AfterEditEventArgs members.

Public Properties
 | Name | Description
Public Property | Cancel | Gets/sets a value indicating whether the edition should be canceled.
Public Property | Node | The node that has just been edited (read-only)
Public Property | OriginalSource | Gets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
Public Property | Text | Gets/sets the text of the node being edited.
Top
See Also

Reference

AfterEditEventArgs Class
Lassalle.Silverlight.Flow Namespace


Cancel Property (AfterEditEventArgs)

Lassalle.Silverlight.Flow Namespace > AfterEditEventArgs Class : Cancel Property
Gets/sets a value indicating whether the edition should be canceled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Cancel As CancelEventArgs
'Usage

Dim instance As AfterEditEventArgs
Dim value As CancelEventArgs

instance.Cancel = value

value = instance.Cancel
public CancelEventArgs Cancel {get; set;}
public: __property CancelEventArgs* get_Cancel();
public: __property void set_Cancel(
   CancelEventArgs* value
);
public:
property CancelEventArgs^ Cancel {
   CancelEventArgs^ get();
   void set (    CancelEventArgs^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AfterEditEventArgs Class
AfterEditEventArgs Members


Node Property (AfterEditEventArgs)

Lassalle.Silverlight.Flow Namespace > AfterEditEventArgs Class : Node Property
The node that has just been edited (read-only)
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Node As Node
'Usage

Dim instance As AfterEditEventArgs
Dim value As Node

value = instance.Node
public Node Node {get;}
public: __property Node* get_Node();
public:
property Node^ Node {
   Node^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AfterEditEventArgs Class
AfterEditEventArgs Members


Text Property (AfterEditEventArgs)

Lassalle.Silverlight.Flow Namespace > AfterEditEventArgs Class : Text Property
Gets/sets the text of the node being edited.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Text As String
'Usage

Dim instance As AfterEditEventArgs
Dim value As String

instance.Text = value

value = instance.Text
public string Text {get; set;}
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
public:
property String^ Text {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AfterEditEventArgs Class
AfterEditEventArgs Members


%%PageItemTitle%%

BeforeEditEventArgs Class
Members

Lassalle.Silverlight.Flow Namespace : BeforeEditEventArgs Class
Event parameters used for the BeforeEdit event
Object Model
BeforeEditEventArgs ClassNode Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class BeforeEditEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As BeforeEditEventArgs
public class BeforeEditEventArgs : System.EventArgs
public __gc class BeforeEditEventArgs : public System.EventArgs
public ref class BeforeEditEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Lassalle.Silverlight.Flow.BeforeEditEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BeforeEditEventArgs Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Members$$

BeforeEditEventArgs Class Members
Properties

Lassalle.Silverlight.Flow Namespace : BeforeEditEventArgs Class

The following tables list the members exposed by BeforeEditEventArgs.

Public Constructors
 | Name | Description
Public Constructor | BeforeEditEventArgs Constructor | Default constructor
Top
Public Properties
 | Name | Description
Public Property | Cancel | Gets/sets a value indicating whether the edition should be canceled.
Public Property | Node | The node that is going to be edited (read-only)
Top
See Also

Reference

BeforeEditEventArgs Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

BeforeEditEventArgs Constructor

Lassalle.Silverlight.Flow Namespace > BeforeEditEventArgs Class : BeforeEditEventArgs Constructor
A reference to the node that is going to be edited.
Default constructor
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal node As Node _
)
'Usage

Dim node As Node

Dim instance As New BeforeEditEventArgs(node)
public BeforeEditEventArgs(
   Node node
)
public: BeforeEditEventArgs(
   Node* node
)
public:
BeforeEditEventArgs(
   Node^ node
)

Parameters

node
A reference to the node that is going to be edited.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BeforeEditEventArgs Class
BeforeEditEventArgs Members


%%PageItemTitle%% $$Properties$$

BeforeEditEventArgs Class Properties

Lassalle.Silverlight.Flow Namespace : BeforeEditEventArgs Class

For a list of all members of this type, see BeforeEditEventArgs members.

Public Properties
 | Name | Description
Public Property | Cancel | Gets/sets a value indicating whether the edition should be canceled.
Public Property | Node | The node that is going to be edited (read-only)
Top
See Also

Reference

BeforeEditEventArgs Class
Lassalle.Silverlight.Flow Namespace


Cancel Property (BeforeEditEventArgs)

Lassalle.Silverlight.Flow Namespace > BeforeEditEventArgs Class : Cancel Property
Gets/sets a value indicating whether the edition should be canceled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Cancel As CancelEventArgs
'Usage

Dim instance As BeforeEditEventArgs
Dim value As CancelEventArgs

instance.Cancel = value

value = instance.Cancel
public CancelEventArgs Cancel {get; set;}
public: __property CancelEventArgs* get_Cancel();
public: __property void set_Cancel(
   CancelEventArgs* value
);
public:
property CancelEventArgs^ Cancel {
   CancelEventArgs^ get();
   void set (    CancelEventArgs^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BeforeEditEventArgs Class
BeforeEditEventArgs Members


Node Property (BeforeEditEventArgs)

Lassalle.Silverlight.Flow Namespace > BeforeEditEventArgs Class : Node Property
The node that is going to be edited (read-only)
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Node As Node
'Usage

Dim instance As BeforeEditEventArgs
Dim value As Node

value = instance.Node
public Node Node {get;}
public: __property Node* get_Node();
public:
property Node^ Node {
   Node^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BeforeEditEventArgs Class
BeforeEditEventArgs Members


%%PageItemTitle%%

BirdView Class
Members

Lassalle.Silverlight.Flow Namespace : BirdView Class
The class managing the control used for a bird view.
Object Model
BirdView ClassAddFlow Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class BirdView
   Inherits System.Windows.Controls.Control
'Usage

Dim instance As BirdView
public class BirdView : System.Windows.Controls.Control
public __gc class BirdView : public System.Windows.Controls.Control
public ref class BirdView : public System.Windows.Controls.Control
Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
Lassalle.Silverlight.Flow.BirdView

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BirdView Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Members$$

BirdView Class Members
Fields Properties Methods Events

Lassalle.Silverlight.Flow Namespace : BirdView Class

The following tables list the members exposed by BirdView.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | AddFlowProperty | Identifies the AddFlow dependency property
static (Shared in Visual Basic) | BorderLineProperty | Identifies the BorderLine dependency property
static (Shared in Visual Basic) | BorderProperty | Identifies the Border dependency property
static (Shared in Visual Basic) | CanvasProperty | Identifies the Canvas dependency property
static (Shared in Visual Basic) | ImageProperty | Identifies the Image dependency property
static (Shared in Visual Basic) | SliderProperty | Identifies the Slider dependency property
static (Shared in Visual Basic) | ThumbProperty | Identifies the Thumb dependency property
Top
Public Properties
 | Name | Description
Public Property | ActualHeight | Gets the rendered height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | Gets the rendered width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | AddFlow | Returns/sets the AddFlow panel to view
Public Property | AllowDrop | Gets or sets a value that determines whether this System.Windows.UIElement can be a drop target for purposes of Silverlight drag-and-drop operations. (Inherited from System.Windows.UIElement)
Public Property | Background | Gets or sets a brush that provides the background of the control. (Inherited from System.Windows.Controls.Control)
Public Property | Border | Returns/sets the Border element containing the zoom box
Public Property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from System.Windows.Controls.Control)
Public Property | BorderLine | Returns/sets the Border element used inside the zoom box
Public Property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from System.Windows.Controls.Control)
Public Property | CacheMode | Gets or sets a value that indicates that rendered content should be cached when possible. (Inherited from System.Windows.UIElement)
Public Property | Canvas | Returns/sets the Canvas control used by the zoom box
Public Property | CharacterSpacing | Gets or sets the distance between characters of text in the control measured in 1000ths of the font size. (Inherited from System.Windows.Controls.Control)
Public Property | Clip | Gets or sets the System.Windows.Media.Geometry used to define the outline of the contents of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | Cursor | Gets or sets the cursor image that displays while the mouse pointer is over a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | Gets or sets the data context for a System.Windows.FrameworkElement when it participates in data binding. (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | Gets the size that this System.Windows.UIElement computed during the measure pass of the layout process. (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | Gets the System.Windows.Threading.Dispatcher this object is associated with. (Inherited from System.Windows.DependencyObject)
Public Property | Effect | Gets or sets the pixel shader effect to use for rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | FlowDirection | Gets or sets the direction that text and other user interface elements flow within any parent element that controls their layout. (Inherited from System.Windows.FrameworkElement)
Public Property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | Gets or sets the size of the text in this control. (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from System.Windows.Controls.Control)
Public Property | Height | Gets or sets the suggested height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | Image | Returns/sets the Image control used by the Zoombox
Public Property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | Gets or sets whether the contained area of this System.Windows.UIElement can return true values for hit testing. (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from System.Windows.Controls.Control)
Public Property | Language | Gets or sets localization/globalization language information that applies to a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | Gets or sets the outer margin of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | Gets or sets the maximum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | Gets or sets the maximum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | Gets or sets the minimum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | Gets or sets the minimum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | Gets or sets the brush used to alter the opacity of regions of this object. (Inherited from System.Windows.UIElement)
Public Property | Padding | Gets or sets the padding inside a control. (Inherited from System.Windows.Controls.Control)
Public Property | Parent | Gets the parent object of this System.Windows.FrameworkElement in the object tree. (Inherited from System.Windows.FrameworkElement)
Public Property | Popup | Returns the Popup used to display this bird view
Public Property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderSize | Gets the final render size of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | Gets or sets transform information that affects the rendering position of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by System.Windows.UIElement.RenderTransform, relative to the bounds of the System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from System.Windows.FrameworkElement)
Public Property | Slider | Returns/sets the Slider control used by the zoom box
Public Property | Style | Gets or sets an instance System.Windows.Style that is applied for this object during rendering. (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | Gets or sets a value that modifies how tabbing and System.Windows.Controls.Control.TabIndex work for this control. (Inherited from System.Windows.Controls.Control)
Public Property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from System.Windows.FrameworkElement)
Public Property | Template | Gets or sets a control template. (Inherited from System.Windows.Controls.Control)
Public Property | Thumb | Returns/sets the Thumb control used by the zoom box
Public Property | Triggers | Gets the collection of triggers for animations that are defined for a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from System.Windows.UIElement)
Public Property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | Gets or sets the visibility of a System.Windows.UIElement. A System.Windows.UIElement that is not visible does not render and does not communicate its desired size to layout. (Inherited from System.Windows.UIElement)
Public Property | Width | Gets or sets the width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Top
Protected Properties
 | Name | Description
Protected Property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from System.Windows.Controls.Control)
Top
Public Methods
 | Name | Description
Public Method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from System.Windows.UIElement)
Public Method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from System.Windows.Controls.Control)
Public Method | Arrange | Positions child objects and determines a size for a System.Windows.UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | CaptureMouse | Sets mouse capture to a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | ClearValue | Clears the local value of a dependency property. (Inherited from System.Windows.DependencyObject)
Public Method | FindName | Retrieves an object that has the specified identifier name. (Inherited from System.Windows.FrameworkElement)
Public Method | Focus | Attempts to set the focus on the control. (Inherited from System.Windows.Controls.Control)
Public Method | GetAnimationBaseValue | Returns any base value established for a Silverlight dependency property, which would apply in cases where an animation is not active. (Inherited from System.Windows.DependencyObject)
Public Method | GetBindingExpression | Retrieves the System.Windows.Data.BindingExpression for a dependency property where a binding is established. (Inherited from System.Windows.FrameworkElement)
Public Method | GetValue | Returns the current effective value of a dependency property from a System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | Hide | Hide the the bird view window
Public Method | InvalidateArrange | Invalidates the arrange state (layout) for a System.Windows.UIElement. After the invalidation, the System.Windows.UIElement will have its layout updated, which will occur asynchronously. (Inherited from System.Windows.UIElement)
Public Method | InvalidateMeasure | Invalidates the measurement state (layout) for a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | Measure | Updates the System.Windows.UIElement.DesiredSize of a System.Windows.UIElement. Typically, objects that implement custom layout for their layout children call this method from their own System.Windows.FrameworkElement.MeasureOverride(System.Windows.Size) implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | OnApplyTemplate | Overridden. Loads the node template so that its parts can be referenced.
Public Method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from System.Windows.DependencyObject)
Public Method | ReleaseMouseCapture | Removes mouse capture from a System.Windows.UIElement. After this call, typically no object holds mouse capture. (Inherited from System.Windows.UIElement)
Public Method | RemoveHandler | Removes the specified routed event handler from this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | SetBinding | Attaches a binding to a System.Windows.FrameworkElement, using the provided binding object, and returns a System.Windows.Data.BindingExpressionBase for possible later use. (Inherited from System.Windows.FrameworkElement)
Public Method | SetValue | (Inherited from System.Windows.DependencyObject)
Public Method | Show | Show the the bird view window
Public Method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the System.Windows.UIElement to the specified object. (Inherited from System.Windows.UIElement)
Public Method | UpdateLayout | Ensures that all positions of child objects of a System.Windows.UIElement are properly updated for layout. (Inherited from System.Windows.UIElement)
Top
Protected Methods
 | Name | Description
Protected Method | ArrangeOverride | (Inherited from System.Windows.FrameworkElement)
Protected Method | GetTemplateChild | Retrieves the named element in the instantiated System.Windows.Controls.ControlTemplate visual tree. (Inherited from System.Windows.Controls.Control)
Protected Method | MeasureOverride | (Inherited from System.Windows.FrameworkElement)
Protected Method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific System.Windows.Automation.Peers.AutomationPeer implementations for the Silverlight automation infrastructure. (Inherited from System.Windows.UIElement)
Protected Method | OnDragEnter | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDragLeave | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDragOver | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDrop | (Inherited from System.Windows.Controls.Control)
Protected Method | OnGotFocus | (Inherited from System.Windows.Controls.Control)
Protected Method | OnKeyDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnKeyUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnLostFocus | (Inherited from System.Windows.Controls.Control)
Protected Method | OnLostMouseCapture | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseEnter | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeave | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeftButtonDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeftButtonUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseMove | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseRightButtonDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseRightButtonUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseWheel | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInput | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInputStart | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInputUpdate | (Inherited from System.Windows.Controls.Control)
Top
Public Events
 | Name | Description
Public Event | BindingValidationError | Occurs when a data validation error is reported by a binding source. (Inherited from System.Windows.FrameworkElement)
Public Event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from System.Windows.FrameworkElement)
Public Event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from System.Windows.UIElement)
Public Event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from System.Windows.UIElement)
Public Event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from System.Windows.UIElement)
Public Event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from System.Windows.UIElement)
Public Event | GotFocus | Occurs when a System.Windows.UIElement receives focus. (Inherited from System.Windows.UIElement)
Public Event | IsEnabledChanged | Occurs when the System.Windows.Controls.Control.IsEnabled property changes. (Inherited from System.Windows.Controls.Control)
Public Event | KeyDown | Occurs when a keyboard key is pressed while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | KeyUp | Occurs when a keyboard key is released while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | Occurs when the layout of the Silverlight visual tree changes. (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | Occurs when a System.Windows.FrameworkElement has been constructed and added to the object tree. (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | Occurs when a System.Windows.UIElement loses focus. (Inherited from System.Windows.UIElement)
Public Event | LostMouseCapture | Occurs when the System.Windows.UIElement loses mouse capture. (Inherited from System.Windows.UIElement)
Public Event | MediaCommand | Occurs when a button is pressed on a remote control. (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | Occurs when the mouse (or a stylus) enters the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | Occurs when the mouse (or the stylus) leaves the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | Occurs when the left mouse button is pressed (or when the tip of the stylus touches the tablet) while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | Occurs when the left mouse button is released (or the tip of the stylus is removed from the tablet) while the mouse (or the stylus) is over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseMove | Occurs when the coordinate position of the mouse (or stylus) changes while over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over a System.Windows.UIElement. However, this event will only be raised if a caller marks the preceding System.Windows.UIElement.MouseRightButtonDown event as handled; see Remarks. (Inherited from System.Windows.UIElement)
Public Event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over a System.Windows.UIElement, or the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | Occurs when either the System.Windows.FrameworkElement.ActualHeight or the System.Windows.FrameworkElement.ActualWidth properties change value on a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Event | TextInput | Occurs when a UI element gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputStart | Occurs when a UI element initially gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputUpdate | Occurs when text continues to be composed via an input method editor (IME). (Inherited from System.Windows.UIElement)
Public Event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from System.Windows.FrameworkElement)
Top
See Also

Reference

BirdView Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Methods$$

BirdView Class Methods

Lassalle.Silverlight.Flow Namespace : BirdView Class

For a list of all members of this type, see BirdView members.

Public Methods
 | Name | Description
Public Method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from System.Windows.UIElement)
Public Method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from System.Windows.Controls.Control)
Public Method | Arrange | Positions child objects and determines a size for a System.Windows.UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | CaptureMouse | Sets mouse capture to a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | ClearValue | Clears the local value of a dependency property. (Inherited from System.Windows.DependencyObject)
Public Method | FindName | Retrieves an object that has the specified identifier name. (Inherited from System.Windows.FrameworkElement)
Public Method | Focus | Attempts to set the focus on the control. (Inherited from System.Windows.Controls.Control)
Public Method | GetAnimationBaseValue | Returns any base value established for a Silverlight dependency property, which would apply in cases where an animation is not active. (Inherited from System.Windows.DependencyObject)
Public Method | GetBindingExpression | Retrieves the System.Windows.Data.BindingExpression for a dependency property where a binding is established. (Inherited from System.Windows.FrameworkElement)
Public Method | GetValue | Returns the current effective value of a dependency property from a System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | Hide | Hide the the bird view window
Public Method | InvalidateArrange | Invalidates the arrange state (layout) for a System.Windows.UIElement. After the invalidation, the System.Windows.UIElement will have its layout updated, which will occur asynchronously. (Inherited from System.Windows.UIElement)
Public Method | InvalidateMeasure | Invalidates the measurement state (layout) for a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | Measure | Updates the System.Windows.UIElement.DesiredSize of a System.Windows.UIElement. Typically, objects that implement custom layout for their layout children call this method from their own System.Windows.FrameworkElement.MeasureOverride(System.Windows.Size) implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | OnApplyTemplate | Overridden. Loads the node template so that its parts can be referenced.
Public Method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from System.Windows.DependencyObject)
Public Method | ReleaseMouseCapture | Removes mouse capture from a System.Windows.UIElement. After this call, typically no object holds mouse capture. (Inherited from System.Windows.UIElement)
Public Method | RemoveHandler | Removes the specified routed event handler from this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | SetBinding | Attaches a binding to a System.Windows.FrameworkElement, using the provided binding object, and returns a System.Windows.Data.BindingExpressionBase for possible later use. (Inherited from System.Windows.FrameworkElement)
Public Method | SetValue | (Inherited from System.Windows.DependencyObject)
Public Method | Show | Show the the bird view window
Public Method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the System.Windows.UIElement to the specified object. (Inherited from System.Windows.UIElement)
Public Method | UpdateLayout | Ensures that all positions of child objects of a System.Windows.UIElement are properly updated for layout. (Inherited from System.Windows.UIElement)
Top
Protected Methods
 | Name | Description
Protected Method | ArrangeOverride | (Inherited from System.Windows.FrameworkElement)
Protected Method | GetTemplateChild | Retrieves the named element in the instantiated System.Windows.Controls.ControlTemplate visual tree. (Inherited from System.Windows.Controls.Control)
Protected Method | MeasureOverride | (Inherited from System.Windows.FrameworkElement)
Protected Method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific System.Windows.Automation.Peers.AutomationPeer implementations for the Silverlight automation infrastructure. (Inherited from System.Windows.UIElement)
Protected Method | OnDragEnter | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDragLeave | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDragOver | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDrop | (Inherited from System.Windows.Controls.Control)
Protected Method | OnGotFocus | (Inherited from System.Windows.Controls.Control)
Protected Method | OnKeyDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnKeyUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnLostFocus | (Inherited from System.Windows.Controls.Control)
Protected Method | OnLostMouseCapture | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseEnter | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeave | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeftButtonDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeftButtonUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseMove | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseRightButtonDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseRightButtonUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseWheel | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInput | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInputStart | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInputUpdate | (Inherited from System.Windows.Controls.Control)
Top
See Also

Reference

BirdView Class
Lassalle.Silverlight.Flow Namespace


Hide Method

Lassalle.Silverlight.Flow Namespace > BirdView Class : Hide Method
Hide the the bird view window
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Hide()
'Usage

Dim instance As BirdView

instance.Hide()
public void Hide()
public: void Hide();
public:
void Hide();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BirdView Class
BirdView Members


OnApplyTemplate Method (BirdView)

Lassalle.Silverlight.Flow Namespace > BirdView Class : OnApplyTemplate Method
Loads the node template so that its parts can be referenced.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub OnApplyTemplate()
'Usage

Dim instance As BirdView

instance.OnApplyTemplate()
public override void OnApplyTemplate()
public: void OnApplyTemplate(); override
public:
void OnApplyTemplate(); override
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BirdView Class
BirdView Members


Show Method

Lassalle.Silverlight.Flow Namespace > BirdView Class : Show Method
Show the the bird view window
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Show( _
   ByVal x As Double, _
   ByVal y As Double _
)
'Usage

Dim instance As BirdView
Dim x As Double
Dim y As Double

instance.Show(x, y)
public void Show(
   double x,
   double y
)
public: void Show(
   double x,
   double y
)
public:
void Show(
   double x,
   double y
)

Parameters

x
y
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BirdView Class
BirdView Members


%%PageItemTitle%% $$Properties$$

BirdView Class Properties

Lassalle.Silverlight.Flow Namespace : BirdView Class

For a list of all members of this type, see BirdView members.

Public Properties
 | Name | Description
Public Property | ActualHeight | Gets the rendered height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | Gets the rendered width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | AddFlow | Returns/sets the AddFlow panel to view
Public Property | AllowDrop | Gets or sets a value that determines whether this System.Windows.UIElement can be a drop target for purposes of Silverlight drag-and-drop operations. (Inherited from System.Windows.UIElement)
Public Property | Background | Gets or sets a brush that provides the background of the control. (Inherited from System.Windows.Controls.Control)
Public Property | Border | Returns/sets the Border element containing the zoom box
Public Property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from System.Windows.Controls.Control)
Public Property | BorderLine | Returns/sets the Border element used inside the zoom box
Public Property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from System.Windows.Controls.Control)
Public Property | CacheMode | Gets or sets a value that indicates that rendered content should be cached when possible. (Inherited from System.Windows.UIElement)
Public Property | Canvas | Returns/sets the Canvas control used by the zoom box
Public Property | CharacterSpacing | Gets or sets the distance between characters of text in the control measured in 1000ths of the font size. (Inherited from System.Windows.Controls.Control)
Public Property | Clip | Gets or sets the System.Windows.Media.Geometry used to define the outline of the contents of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | Cursor | Gets or sets the cursor image that displays while the mouse pointer is over a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | Gets or sets the data context for a System.Windows.FrameworkElement when it participates in data binding. (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | Gets the size that this System.Windows.UIElement computed during the measure pass of the layout process. (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | Gets the System.Windows.Threading.Dispatcher this object is associated with. (Inherited from System.Windows.DependencyObject)
Public Property | Effect | Gets or sets the pixel shader effect to use for rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | FlowDirection | Gets or sets the direction that text and other user interface elements flow within any parent element that controls their layout. (Inherited from System.Windows.FrameworkElement)
Public Property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | Gets or sets the size of the text in this control. (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from System.Windows.Controls.Control)
Public Property | Height | Gets or sets the suggested height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | Image | Returns/sets the Image control used by the Zoombox
Public Property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | Gets or sets whether the contained area of this System.Windows.UIElement can return true values for hit testing. (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from System.Windows.Controls.Control)
Public Property | Language | Gets or sets localization/globalization language information that applies to a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | Gets or sets the outer margin of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | Gets or sets the maximum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | Gets or sets the maximum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | Gets or sets the minimum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | Gets or sets the minimum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | Gets or sets the brush used to alter the opacity of regions of this object. (Inherited from System.Windows.UIElement)
Public Property | Padding | Gets or sets the padding inside a control. (Inherited from System.Windows.Controls.Control)
Public Property | Parent | Gets the parent object of this System.Windows.FrameworkElement in the object tree. (Inherited from System.Windows.FrameworkElement)
Public Property | Popup | Returns the Popup used to display this bird view
Public Property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderSize | Gets the final render size of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | Gets or sets transform information that affects the rendering position of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by System.Windows.UIElement.RenderTransform, relative to the bounds of the System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from System.Windows.FrameworkElement)
Public Property | Slider | Returns/sets the Slider control used by the zoom box
Public Property | Style | Gets or sets an instance System.Windows.Style that is applied for this object during rendering. (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | Gets or sets a value that modifies how tabbing and System.Windows.Controls.Control.TabIndex work for this control. (Inherited from System.Windows.Controls.Control)
Public Property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from System.Windows.FrameworkElement)
Public Property | Template | Gets or sets a control template. (Inherited from System.Windows.Controls.Control)
Public Property | Thumb | Returns/sets the Thumb control used by the zoom box
Public Property | Triggers | Gets the collection of triggers for animations that are defined for a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from System.Windows.UIElement)
Public Property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | Gets or sets the visibility of a System.Windows.UIElement. A System.Windows.UIElement that is not visible does not render and does not communicate its desired size to layout. (Inherited from System.Windows.UIElement)
Public Property | Width | Gets or sets the width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Top
Protected Properties
 | Name | Description
Protected Property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from System.Windows.Controls.Control)
Top
See Also

Reference

BirdView Class
Lassalle.Silverlight.Flow Namespace


AddFlow Property (BirdView)

Lassalle.Silverlight.Flow Namespace > BirdView Class : AddFlow Property
Returns/sets the AddFlow panel to view
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AddFlow As AddFlow
'Usage

Dim instance As BirdView
Dim value As AddFlow

instance.AddFlow = value

value = instance.AddFlow
public AddFlow AddFlow {get; set;}
public: __property AddFlow* get_AddFlow();
public: __property void set_AddFlow(
   AddFlow* value
);
public:
property AddFlow^ AddFlow {
   AddFlow^ get();
   void set (    AddFlow^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BirdView Class
BirdView Members


Border Property

Lassalle.Silverlight.Flow Namespace > BirdView Class : Border Property
Returns/sets the Border element containing the zoom box
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Border As Border
'Usage

Dim instance As BirdView
Dim value As Border

instance.Border = value

value = instance.Border
public Border Border {get; set;}
public: __property Border* get_Border();
public: __property void set_Border(
   Border* value
);
public:
property Border^ Border {
   Border^ get();
   void set (    Border^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BirdView Class
BirdView Members


BorderLine Property

Lassalle.Silverlight.Flow Namespace > BirdView Class : BorderLine Property
Returns/sets the Border element used inside the zoom box
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BorderLine As Border
'Usage

Dim instance As BirdView
Dim value As Border

instance.BorderLine = value

value = instance.BorderLine
public Border BorderLine {get; set;}
public: __property Border* get_BorderLine();
public: __property void set_BorderLine(
   Border* value
);
public:
property Border^ BorderLine {
   Border^ get();
   void set (    Border^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BirdView Class
BirdView Members


Canvas Property

Lassalle.Silverlight.Flow Namespace > BirdView Class : Canvas Property
Returns/sets the Canvas control used by the zoom box
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Canvas As Canvas
'Usage

Dim instance As BirdView
Dim value As Canvas

instance.Canvas = value

value = instance.Canvas
public Canvas Canvas {get; set;}
public: __property Canvas* get_Canvas();
public: __property void set_Canvas(
   Canvas* value
);
public:
property Canvas^ Canvas {
   Canvas^ get();
   void set (    Canvas^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BirdView Class
BirdView Members


Image Property (BirdView)

Lassalle.Silverlight.Flow Namespace > BirdView Class : Image Property
Returns/sets the Image control used by the Zoombox
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Image As Image
'Usage

Dim instance As BirdView
Dim value As Image

instance.Image = value

value = instance.Image
public Image Image {get; set;}
public: __property Image* get_Image();
public: __property void set_Image(
   Image* value
);
public:
property Image^ Image {
   Image^ get();
   void set (    Image^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BirdView Class
BirdView Members


Popup Property

Lassalle.Silverlight.Flow Namespace > BirdView Class : Popup Property
Returns the Popup used to display this bird view
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Popup As Popup
'Usage

Dim instance As BirdView
Dim value As Popup

value = instance.Popup
public Popup Popup {get;}
public: __property Popup* get_Popup();
public:
property Popup^ Popup {
   Popup^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BirdView Class
BirdView Members


Slider Property

Lassalle.Silverlight.Flow Namespace > BirdView Class : Slider Property
Returns/sets the Slider control used by the zoom box
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Slider As Slider
'Usage

Dim instance As BirdView
Dim value As Slider

instance.Slider = value

value = instance.Slider
public Slider Slider {get; set;}
public: __property Slider* get_Slider();
public: __property void set_Slider(
   Slider* value
);
public:
property Slider^ Slider {
   Slider^ get();
   void set (    Slider^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BirdView Class
BirdView Members


Thumb Property

Lassalle.Silverlight.Flow Namespace > BirdView Class : Thumb Property
Returns/sets the Thumb control used by the zoom box
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Thumb As Thumb
'Usage

Dim instance As BirdView
Dim value As Thumb

instance.Thumb = value

value = instance.Thumb
public Thumb Thumb {get; set;}
public: __property Thumb* get_Thumb();
public: __property void set_Thumb(
   Thumb* value
);
public:
property Thumb^ Thumb {
   Thumb^ get();
   void set (    Thumb^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BirdView Class
BirdView Members


%%PageItemTitle%% $$Fields$$

BirdView Class Fields

Lassalle.Silverlight.Flow Namespace : BirdView Class

For a list of all members of this type, see BirdView members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | AddFlowProperty | Identifies the AddFlow dependency property
static (Shared in Visual Basic) | BorderLineProperty | Identifies the BorderLine dependency property
static (Shared in Visual Basic) | BorderProperty | Identifies the Border dependency property
static (Shared in Visual Basic) | CanvasProperty | Identifies the Canvas dependency property
static (Shared in Visual Basic) | ImageProperty | Identifies the Image dependency property
static (Shared in Visual Basic) | SliderProperty | Identifies the Slider dependency property
static (Shared in Visual Basic) | ThumbProperty | Identifies the Thumb dependency property
Top
See Also

Reference

BirdView Class
Lassalle.Silverlight.Flow Namespace


AddFlowProperty Field

Lassalle.Silverlight.Flow Namespace > BirdView Class : AddFlowProperty Field
Identifies the AddFlow dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly AddFlowProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = BirdView.AddFlowProperty
public static readonly DependencyProperty AddFlowProperty
public: static readonly DependencyProperty* AddFlowProperty
public:
static readonly DependencyProperty^ AddFlowProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BirdView Class
BirdView Members


BorderLineProperty Field

Lassalle.Silverlight.Flow Namespace > BirdView Class : BorderLineProperty Field
Identifies the BorderLine dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly BorderLineProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = BirdView.BorderLineProperty
public static readonly DependencyProperty BorderLineProperty
public: static readonly DependencyProperty* BorderLineProperty
public:
static readonly DependencyProperty^ BorderLineProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BirdView Class
BirdView Members


BorderProperty Field

Lassalle.Silverlight.Flow Namespace > BirdView Class : BorderProperty Field
Identifies the Border dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly BorderProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = BirdView.BorderProperty
public static readonly DependencyProperty BorderProperty
public: static readonly DependencyProperty* BorderProperty
public:
static readonly DependencyProperty^ BorderProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BirdView Class
BirdView Members


CanvasProperty Field

Lassalle.Silverlight.Flow Namespace > BirdView Class : CanvasProperty Field
Identifies the Canvas dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly CanvasProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = BirdView.CanvasProperty
public static readonly DependencyProperty CanvasProperty
public: static readonly DependencyProperty* CanvasProperty
public:
static readonly DependencyProperty^ CanvasProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BirdView Class
BirdView Members


ImageProperty Field

Lassalle.Silverlight.Flow Namespace > BirdView Class : ImageProperty Field
Identifies the Image dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ImageProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = BirdView.ImageProperty
public static readonly DependencyProperty ImageProperty
public: static readonly DependencyProperty* ImageProperty
public:
static readonly DependencyProperty^ ImageProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BirdView Class
BirdView Members


SliderProperty Field

Lassalle.Silverlight.Flow Namespace > BirdView Class : SliderProperty Field
Identifies the Slider dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly SliderProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = BirdView.SliderProperty
public static readonly DependencyProperty SliderProperty
public: static readonly DependencyProperty* SliderProperty
public:
static readonly DependencyProperty^ SliderProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BirdView Class
BirdView Members


ThumbProperty Field

Lassalle.Silverlight.Flow Namespace > BirdView Class : ThumbProperty Field
Identifies the Thumb dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ThumbProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = BirdView.ThumbProperty
public static readonly DependencyProperty ThumbProperty
public: static readonly DependencyProperty* ThumbProperty
public:
static readonly DependencyProperty^ ThumbProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BirdView Class
BirdView Members


%%PageItemTitle%%

CancelEditEventArgs Class
Members

Lassalle.Silverlight.Flow Namespace : CancelEditEventArgs Class
Event parameters used for the CancelEdit event
Object Model
CancelEditEventArgs ClassNode Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class CancelEditEventArgs
   Inherits System.Windows.RoutedEventArgs
'Usage

Dim instance As CancelEditEventArgs
public class CancelEditEventArgs : System.Windows.RoutedEventArgs
public __gc class CancelEditEventArgs : public System.Windows.RoutedEventArgs
public ref class CancelEditEventArgs : public System.Windows.RoutedEventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
System.Windows.RoutedEventArgs
Lassalle.Silverlight.Flow.CancelEditEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CancelEditEventArgs Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Members$$

CancelEditEventArgs Class Members
Properties

Lassalle.Silverlight.Flow Namespace : CancelEditEventArgs Class

The following tables list the members exposed by CancelEditEventArgs.

Public Constructors
 | Name | Description
Public Constructor | CancelEditEventArgs Constructor | Constructor. Creates a new AfterEditEventArgs instance.
Top
Public Properties
 | Name | Description
Public Property | Node | The node that has just been edited (read-only)
Public Property | OriginalSource | Gets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
Public Property | Text | Gets/sets the text of the node being edited.
Top
See Also

Reference

CancelEditEventArgs Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

CancelEditEventArgs Constructor

Lassalle.Silverlight.Flow Namespace > CancelEditEventArgs Class : CancelEditEventArgs Constructor
Text of the node being edited.
A reference to the node that has just been edited.
Constructor. Creates a new AfterEditEventArgs instance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal text As String, _
   ByVal node As Node _
)
'Usage

Dim text As String
Dim node As Node

Dim instance As New CancelEditEventArgs(text, node)
public CancelEditEventArgs(
   string text,
   Node node
)
public: CancelEditEventArgs(
   string* text,
   Node* node
)
public:
CancelEditEventArgs(
   String^ text,
   Node^ node
)

Parameters

text
Text of the node being edited.
node
A reference to the node that has just been edited.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CancelEditEventArgs Class
CancelEditEventArgs Members


%%PageItemTitle%% $$Properties$$

CancelEditEventArgs Class Properties

Lassalle.Silverlight.Flow Namespace : CancelEditEventArgs Class

For a list of all members of this type, see CancelEditEventArgs members.

Public Properties
 | Name | Description
Public Property | Node | The node that has just been edited (read-only)
Public Property | OriginalSource | Gets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
Public Property | Text | Gets/sets the text of the node being edited.
Top
See Also

Reference

CancelEditEventArgs Class
Lassalle.Silverlight.Flow Namespace


Node Property (CancelEditEventArgs)

Lassalle.Silverlight.Flow Namespace > CancelEditEventArgs Class : Node Property
The node that has just been edited (read-only)
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Node As Node
'Usage

Dim instance As CancelEditEventArgs
Dim value As Node

value = instance.Node
public Node Node {get;}
public: __property Node* get_Node();
public:
property Node^ Node {
   Node^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CancelEditEventArgs Class
CancelEditEventArgs Members


Text Property (CancelEditEventArgs)

Lassalle.Silverlight.Flow Namespace > CancelEditEventArgs Class : Text Property
Gets/sets the text of the node being edited.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Text As String
'Usage

Dim instance As CancelEditEventArgs
Dim value As String

instance.Text = value

value = instance.Text
public string Text {get; set;}
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
public:
property String^ Text {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CancelEditEventArgs Class
CancelEditEventArgs Members


%%PageItemTitle%%

Connector Class
Members

Lassalle.Silverlight.Flow Namespace : Connector Class
Represents the set of pins (connectors) of a node.
Object Model
Connector Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DesignTimeVisibleAttribute()>
Public Class Connector
   Inherits System.Windows.Controls.Control
'Usage

Dim instance As Connector
[DesignTimeVisibleAttribute()]
public class Connector : System.Windows.Controls.Control
[DesignTimeVisibleAttribute()]
public __gc class Connector : public System.Windows.Controls.Control
[DesignTimeVisibleAttribute()]
public ref class Connector : public System.Windows.Controls.Control
Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
Lassalle.Silverlight.Flow.Connector

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Connector Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Members$$

Connector Class Members
Properties Methods Events

Lassalle.Silverlight.Flow Namespace : Connector Class

The following tables list the members exposed by Connector.

Public Constructors
 | Name | Description
Public Constructor | Connector Constructor | Connector constructor
Top
Public Properties
 | Name | Description
Public Property | ActualHeight | Gets the rendered height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | Gets the rendered width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | AllowDrop | Gets or sets a value that determines whether this System.Windows.UIElement can be a drop target for purposes of Silverlight drag-and-drop operations. (Inherited from System.Windows.UIElement)
Public Property | Background | Gets or sets a brush that provides the background of the control. (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from System.Windows.Controls.Control)
Public Property | CacheMode | Gets or sets a value that indicates that rendered content should be cached when possible. (Inherited from System.Windows.UIElement)
Public Property | CharacterSpacing | Gets or sets the distance between characters of text in the control measured in 1000ths of the font size. (Inherited from System.Windows.Controls.Control)
Public Property | Clip | Gets or sets the System.Windows.Media.Geometry used to define the outline of the contents of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | Cursor | Gets or sets the cursor image that displays while the mouse pointer is over a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | Gets or sets the data context for a System.Windows.FrameworkElement when it participates in data binding. (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | Gets the size that this System.Windows.UIElement computed during the measure pass of the layout process. (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | Gets the System.Windows.Threading.Dispatcher this object is associated with. (Inherited from System.Windows.DependencyObject)
Public Property | Effect | Gets or sets the pixel shader effect to use for rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | FlowDirection | Gets or sets the direction that text and other user interface elements flow within any parent element that controls their layout. (Inherited from System.Windows.FrameworkElement)
Public Property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | Gets or sets the size of the text in this control. (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from System.Windows.Controls.Control)
Public Property | Height | Gets or sets the suggested height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | Gets or sets whether the contained area of this System.Windows.UIElement can return true values for hit testing. (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from System.Windows.Controls.Control)
Public Property | Language | Gets or sets localization/globalization language information that applies to a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | Gets or sets the outer margin of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | Gets or sets the maximum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | Gets or sets the maximum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | Gets or sets the minimum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | Gets or sets the minimum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | Gets or sets the brush used to alter the opacity of regions of this object. (Inherited from System.Windows.UIElement)
Public Property | Padding | Gets or sets the padding inside a control. (Inherited from System.Windows.Controls.Control)
Public Property | Parent | Gets the parent object of this System.Windows.FrameworkElement in the object tree. (Inherited from System.Windows.FrameworkElement)
Public Property | Pins | Returns the collection of the pins attached to this Connector object.
Public Property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderSize | Gets the final render size of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | Gets or sets transform information that affects the rendering position of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by System.Windows.UIElement.RenderTransform, relative to the bounds of the System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from System.Windows.FrameworkElement)
Public Property | Style | Gets or sets an instance System.Windows.Style that is applied for this object during rendering. (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | Gets or sets a value that modifies how tabbing and System.Windows.Controls.Control.TabIndex work for this control. (Inherited from System.Windows.Controls.Control)
Public Property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from System.Windows.FrameworkElement)
Public Property | Template | Gets or sets a control template. (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | Gets the collection of triggers for animations that are defined for a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from System.Windows.UIElement)
Public Property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | Gets or sets the visibility of a System.Windows.UIElement. A System.Windows.UIElement that is not visible does not render and does not communicate its desired size to layout. (Inherited from System.Windows.UIElement)
Public Property | Width | Gets or sets the width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Top
Protected Properties
 | Name | Description
Protected Property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from System.Windows.Controls.Control)
Top
Public Methods
 | Name | Description
Public Method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from System.Windows.UIElement)
Public Method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from System.Windows.Controls.Control)
Public Method | Arrange | Positions child objects and determines a size for a System.Windows.UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | CaptureMouse | Sets mouse capture to a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | ClearValue | Clears the local value of a dependency property. (Inherited from System.Windows.DependencyObject)
Public Method | FindName | Retrieves an object that has the specified identifier name. (Inherited from System.Windows.FrameworkElement)
Public Method | Focus | Attempts to set the focus on the control. (Inherited from System.Windows.Controls.Control)
Public Method | GetAnimationBaseValue | Returns any base value established for a Silverlight dependency property, which would apply in cases where an animation is not active. (Inherited from System.Windows.DependencyObject)
Public Method | GetBindingExpression | Retrieves the System.Windows.Data.BindingExpression for a dependency property where a binding is established. (Inherited from System.Windows.FrameworkElement)
Public Method | GetValue | Returns the current effective value of a dependency property from a System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateArrange | Invalidates the arrange state (layout) for a System.Windows.UIElement. After the invalidation, the System.Windows.UIElement will have its layout updated, which will occur asynchronously. (Inherited from System.Windows.UIElement)
Public Method | InvalidateMeasure | Invalidates the measurement state (layout) for a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | Measure | Updates the System.Windows.UIElement.DesiredSize of a System.Windows.UIElement. Typically, objects that implement custom layout for their layout children call this method from their own System.Windows.FrameworkElement.MeasureOverride(System.Windows.Size) implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | OnApplyTemplate | Overridden. Loads the connector template so that its parts can be referenced.
Public Method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from System.Windows.DependencyObject)
Public Method | ReleaseMouseCapture | Removes mouse capture from a System.Windows.UIElement. After this call, typically no object holds mouse capture. (Inherited from System.Windows.UIElement)
Public Method | RemoveHandler | Removes the specified routed event handler from this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | SetBinding | Attaches a binding to a System.Windows.FrameworkElement, using the provided binding object, and returns a System.Windows.Data.BindingExpressionBase for possible later use. (Inherited from System.Windows.FrameworkElement)
Public Method | SetValue | (Inherited from System.Windows.DependencyObject)
Public Method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the System.Windows.UIElement to the specified object. (Inherited from System.Windows.UIElement)
Public Method | UpdateLayout | Ensures that all positions of child objects of a System.Windows.UIElement are properly updated for layout. (Inherited from System.Windows.UIElement)
Top
Protected Methods
 | Name | Description
Protected Method | ArrangeOverride | (Inherited from System.Windows.FrameworkElement)
Protected Method | GetTemplateChild | Retrieves the named element in the instantiated System.Windows.Controls.ControlTemplate visual tree. (Inherited from System.Windows.Controls.Control)
Protected Method | MeasureOverride | (Inherited from System.Windows.FrameworkElement)
Protected Method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific System.Windows.Automation.Peers.AutomationPeer implementations for the Silverlight automation infrastructure. (Inherited from System.Windows.UIElement)
Protected Method | OnDragEnter | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDragLeave | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDragOver | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDrop | (Inherited from System.Windows.Controls.Control)
Protected Method | OnGotFocus | (Inherited from System.Windows.Controls.Control)
Protected Method | OnKeyDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnKeyUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnLostFocus | (Inherited from System.Windows.Controls.Control)
Protected Method | OnLostMouseCapture | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseEnter | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeave | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeftButtonDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeftButtonUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseMove | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseRightButtonDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseRightButtonUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseWheel | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInput | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInputStart | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInputUpdate | (Inherited from System.Windows.Controls.Control)
Top
Public Events
 | Name | Description
Public Event | BindingValidationError | Occurs when a data validation error is reported by a binding source. (Inherited from System.Windows.FrameworkElement)
Public Event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from System.Windows.FrameworkElement)
Public Event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from System.Windows.UIElement)
Public Event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from System.Windows.UIElement)
Public Event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from System.Windows.UIElement)
Public Event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from System.Windows.UIElement)
Public Event | GotFocus | Occurs when a System.Windows.UIElement receives focus. (Inherited from System.Windows.UIElement)
Public Event | IsEnabledChanged | Occurs when the System.Windows.Controls.Control.IsEnabled property changes. (Inherited from System.Windows.Controls.Control)
Public Event | KeyDown | Occurs when a keyboard key is pressed while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | KeyUp | Occurs when a keyboard key is released while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | Occurs when the layout of the Silverlight visual tree changes. (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | Occurs when a System.Windows.FrameworkElement has been constructed and added to the object tree. (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | Occurs when a System.Windows.UIElement loses focus. (Inherited from System.Windows.UIElement)
Public Event | LostMouseCapture | Occurs when the System.Windows.UIElement loses mouse capture. (Inherited from System.Windows.UIElement)
Public Event | MediaCommand | Occurs when a button is pressed on a remote control. (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | Occurs when the mouse (or a stylus) enters the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | Occurs when the mouse (or the stylus) leaves the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | Occurs when the left mouse button is pressed (or when the tip of the stylus touches the tablet) while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | Occurs when the left mouse button is released (or the tip of the stylus is removed from the tablet) while the mouse (or the stylus) is over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseMove | Occurs when the coordinate position of the mouse (or stylus) changes while over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over a System.Windows.UIElement. However, this event will only be raised if a caller marks the preceding System.Windows.UIElement.MouseRightButtonDown event as handled; see Remarks. (Inherited from System.Windows.UIElement)
Public Event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over a System.Windows.UIElement, or the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | Occurs when either the System.Windows.FrameworkElement.ActualHeight or the System.Windows.FrameworkElement.ActualWidth properties change value on a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Event | TextInput | Occurs when a UI element gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputStart | Occurs when a UI element initially gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputUpdate | Occurs when text continues to be composed via an input method editor (IME). (Inherited from System.Windows.UIElement)
Public Event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from System.Windows.FrameworkElement)
Top
See Also

Reference

Connector Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

Connector Constructor

Lassalle.Silverlight.Flow Namespace > Connector Class : Connector Constructor
Connector constructor
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New Connector()
public Connector()
public: Connector();
public:
Connector();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Connector Class
Connector Members


%%PageItemTitle%% $$Methods$$

Connector Class Methods

Lassalle.Silverlight.Flow Namespace : Connector Class

For a list of all members of this type, see Connector members.

Public Methods
 | Name | Description
Public Method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from System.Windows.UIElement)
Public Method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from System.Windows.Controls.Control)
Public Method | Arrange | Positions child objects and determines a size for a System.Windows.UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | CaptureMouse | Sets mouse capture to a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | ClearValue | Clears the local value of a dependency property. (Inherited from System.Windows.DependencyObject)
Public Method | FindName | Retrieves an object that has the specified identifier name. (Inherited from System.Windows.FrameworkElement)
Public Method | Focus | Attempts to set the focus on the control. (Inherited from System.Windows.Controls.Control)
Public Method | GetAnimationBaseValue | Returns any base value established for a Silverlight dependency property, which would apply in cases where an animation is not active. (Inherited from System.Windows.DependencyObject)
Public Method | GetBindingExpression | Retrieves the System.Windows.Data.BindingExpression for a dependency property where a binding is established. (Inherited from System.Windows.FrameworkElement)
Public Method | GetValue | Returns the current effective value of a dependency property from a System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateArrange | Invalidates the arrange state (layout) for a System.Windows.UIElement. After the invalidation, the System.Windows.UIElement will have its layout updated, which will occur asynchronously. (Inherited from System.Windows.UIElement)
Public Method | InvalidateMeasure | Invalidates the measurement state (layout) for a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | Measure | Updates the System.Windows.UIElement.DesiredSize of a System.Windows.UIElement. Typically, objects that implement custom layout for their layout children call this method from their own System.Windows.FrameworkElement.MeasureOverride(System.Windows.Size) implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | OnApplyTemplate | Overridden. Loads the connector template so that its parts can be referenced.
Public Method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from System.Windows.DependencyObject)
Public Method | ReleaseMouseCapture | Removes mouse capture from a System.Windows.UIElement. After this call, typically no object holds mouse capture. (Inherited from System.Windows.UIElement)
Public Method | RemoveHandler | Removes the specified routed event handler from this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | SetBinding | Attaches a binding to a System.Windows.FrameworkElement, using the provided binding object, and returns a System.Windows.Data.BindingExpressionBase for possible later use. (Inherited from System.Windows.FrameworkElement)
Public Method | SetValue | (Inherited from System.Windows.DependencyObject)
Public Method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the System.Windows.UIElement to the specified object. (Inherited from System.Windows.UIElement)
Public Method | UpdateLayout | Ensures that all positions of child objects of a System.Windows.UIElement are properly updated for layout. (Inherited from System.Windows.UIElement)
Top
Protected Methods
 | Name | Description
Protected Method | ArrangeOverride | (Inherited from System.Windows.FrameworkElement)
Protected Method | GetTemplateChild | Retrieves the named element in the instantiated System.Windows.Controls.ControlTemplate visual tree. (Inherited from System.Windows.Controls.Control)
Protected Method | MeasureOverride | (Inherited from System.Windows.FrameworkElement)
Protected Method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific System.Windows.Automation.Peers.AutomationPeer implementations for the Silverlight automation infrastructure. (Inherited from System.Windows.UIElement)
Protected Method | OnDragEnter | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDragLeave | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDragOver | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDrop | (Inherited from System.Windows.Controls.Control)
Protected Method | OnGotFocus | (Inherited from System.Windows.Controls.Control)
Protected Method | OnKeyDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnKeyUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnLostFocus | (Inherited from System.Windows.Controls.Control)
Protected Method | OnLostMouseCapture | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseEnter | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeave | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeftButtonDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeftButtonUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseMove | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseRightButtonDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseRightButtonUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseWheel | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInput | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInputStart | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInputUpdate | (Inherited from System.Windows.Controls.Control)
Top
See Also

Reference

Connector Class
Lassalle.Silverlight.Flow Namespace


OnApplyTemplate Method (Connector)

Lassalle.Silverlight.Flow Namespace > Connector Class : OnApplyTemplate Method
Loads the connector template so that its parts can be referenced.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub OnApplyTemplate()
'Usage

Dim instance As Connector

instance.OnApplyTemplate()
public override void OnApplyTemplate()
public: void OnApplyTemplate(); override
public:
void OnApplyTemplate(); override
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Connector Class
Connector Members


%%PageItemTitle%% $$Properties$$

Connector Class Properties

Lassalle.Silverlight.Flow Namespace : Connector Class

For a list of all members of this type, see Connector members.

Public Properties
 | Name | Description
Public Property | ActualHeight | Gets the rendered height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | Gets the rendered width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | AllowDrop | Gets or sets a value that determines whether this System.Windows.UIElement can be a drop target for purposes of Silverlight drag-and-drop operations. (Inherited from System.Windows.UIElement)
Public Property | Background | Gets or sets a brush that provides the background of the control. (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from System.Windows.Controls.Control)
Public Property | CacheMode | Gets or sets a value that indicates that rendered content should be cached when possible. (Inherited from System.Windows.UIElement)
Public Property | CharacterSpacing | Gets or sets the distance between characters of text in the control measured in 1000ths of the font size. (Inherited from System.Windows.Controls.Control)
Public Property | Clip | Gets or sets the System.Windows.Media.Geometry used to define the outline of the contents of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | Cursor | Gets or sets the cursor image that displays while the mouse pointer is over a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | Gets or sets the data context for a System.Windows.FrameworkElement when it participates in data binding. (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | Gets the size that this System.Windows.UIElement computed during the measure pass of the layout process. (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | Gets the System.Windows.Threading.Dispatcher this object is associated with. (Inherited from System.Windows.DependencyObject)
Public Property | Effect | Gets or sets the pixel shader effect to use for rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | FlowDirection | Gets or sets the direction that text and other user interface elements flow within any parent element that controls their layout. (Inherited from System.Windows.FrameworkElement)
Public Property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | Gets or sets the size of the text in this control. (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from System.Windows.Controls.Control)
Public Property | Height | Gets or sets the suggested height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | Gets or sets whether the contained area of this System.Windows.UIElement can return true values for hit testing. (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from System.Windows.Controls.Control)
Public Property | Language | Gets or sets localization/globalization language information that applies to a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | Gets or sets the outer margin of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | Gets or sets the maximum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | Gets or sets the maximum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | Gets or sets the minimum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | Gets or sets the minimum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | Gets or sets the brush used to alter the opacity of regions of this object. (Inherited from System.Windows.UIElement)
Public Property | Padding | Gets or sets the padding inside a control. (Inherited from System.Windows.Controls.Control)
Public Property | Parent | Gets the parent object of this System.Windows.FrameworkElement in the object tree. (Inherited from System.Windows.FrameworkElement)
Public Property | Pins | Returns the collection of the pins attached to this Connector object.
Public Property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderSize | Gets the final render size of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | Gets or sets transform information that affects the rendering position of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by System.Windows.UIElement.RenderTransform, relative to the bounds of the System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from System.Windows.FrameworkElement)
Public Property | Style | Gets or sets an instance System.Windows.Style that is applied for this object during rendering. (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | Gets or sets a value that modifies how tabbing and System.Windows.Controls.Control.TabIndex work for this control. (Inherited from System.Windows.Controls.Control)
Public Property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from System.Windows.FrameworkElement)
Public Property | Template | Gets or sets a control template. (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | Gets the collection of triggers for animations that are defined for a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from System.Windows.UIElement)
Public Property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | Gets or sets the visibility of a System.Windows.UIElement. A System.Windows.UIElement that is not visible does not render and does not communicate its desired size to layout. (Inherited from System.Windows.UIElement)
Public Property | Width | Gets or sets the width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Top
Protected Properties
 | Name | Description
Protected Property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from System.Windows.Controls.Control)
Top
See Also

Reference

Connector Class
Lassalle.Silverlight.Flow Namespace


Pins Property

Lassalle.Silverlight.Flow Namespace > Connector Class : Pins Property
Returns the collection of the pins attached to this Connector object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Pins As List(Of Pin)
'Usage

Dim instance As Connector
Dim value As List(Of Pin)

value = instance.Pins
public List<Pin> Pins {get;}
public: __property List<Pin*>* get_Pins();
public:
property List<Pin^>^ Pins {
   List<Pin^>^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Connector Class
Connector Members


%%PageItemTitle%%

ContextHandle Class
Members

Lassalle.Silverlight.Flow Namespace : ContextHandle Class
Represents a rotating handle of a node.
Object Model
ContextHandle ClassAddFlow ClassIHasContext Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<TemplateVisualStateAttribute(Name="MouseOver", GroupName="CommonStates")>
<TemplateVisualStateAttribute(Name="Normal", GroupName="CommonStates")>
Public Class ContextHandle
   Inherits System.Windows.Controls.Control
'Usage

Dim instance As ContextHandle
[TemplateVisualStateAttribute(Name="MouseOver", GroupName="CommonStates")]
[TemplateVisualStateAttribute(Name="Normal", GroupName="CommonStates")]
public class ContextHandle : System.Windows.Controls.Control
[TemplateVisualStateAttribute(Name="MouseOver", GroupName="CommonStates")]
[TemplateVisualStateAttribute(Name="Normal", GroupName="CommonStates")]
public __gc class ContextHandle : public System.Windows.Controls.Control
[TemplateVisualStateAttribute(Name="MouseOver", GroupName="CommonStates")]
[TemplateVisualStateAttribute(Name="Normal", GroupName="CommonStates")]
public ref class ContextHandle : public System.Windows.Controls.Control
Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
Lassalle.Silverlight.Flow.ContextHandle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ContextHandle Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Members$$

ContextHandle Class Members
Properties Methods Events

Lassalle.Silverlight.Flow Namespace : ContextHandle Class

The following tables list the members exposed by ContextHandle.

Public Constructors
 | Name | Description
Public Constructor | ContextHandle Constructor | ContextHandle constructor
Top
Public Properties
 | Name | Description
Public Property | ActualHeight | Gets the rendered height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | Gets the rendered width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | AddFlow | The addflow canvas containing this node
Public Property | AllowDrop | Gets or sets a value that determines whether this System.Windows.UIElement can be a drop target for purposes of Silverlight drag-and-drop operations. (Inherited from System.Windows.UIElement)
Public Property | Background | Gets or sets a brush that provides the background of the control. (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from System.Windows.Controls.Control)
Public Property | CacheMode | Gets or sets a value that indicates that rendered content should be cached when possible. (Inherited from System.Windows.UIElement)
Public Property | CharacterSpacing | Gets or sets the distance between characters of text in the control measured in 1000ths of the font size. (Inherited from System.Windows.Controls.Control)
Public Property | Clip | Gets or sets the System.Windows.Media.Geometry used to define the outline of the contents of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | Cursor | Gets or sets the cursor image that displays while the mouse pointer is over a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | Gets or sets the data context for a System.Windows.FrameworkElement when it participates in data binding. (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | Gets the size that this System.Windows.UIElement computed during the measure pass of the layout process. (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | Gets the System.Windows.Threading.Dispatcher this object is associated with. (Inherited from System.Windows.DependencyObject)
Public Property | Effect | Gets or sets the pixel shader effect to use for rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | FlowDirection | Gets or sets the direction that text and other user interface elements flow within any parent element that controls their layout. (Inherited from System.Windows.FrameworkElement)
Public Property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | Gets or sets the size of the text in this control. (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from System.Windows.Controls.Control)
Public Property | Height | Gets or sets the suggested height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | Gets or sets whether the contained area of this System.Windows.UIElement can return true values for hit testing. (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from System.Windows.Controls.Control)
Public Property | Item | Returns the item using this contextButton
Public Property | Language | Gets or sets localization/globalization language information that applies to a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | Gets or sets the outer margin of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | Gets or sets the maximum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | Gets or sets the maximum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | Gets or sets the minimum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | Gets or sets the minimum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | Gets or sets the brush used to alter the opacity of regions of this object. (Inherited from System.Windows.UIElement)
Public Property | Padding | Gets or sets the padding inside a control. (Inherited from System.Windows.Controls.Control)
Public Property | Parent | Gets the parent object of this System.Windows.FrameworkElement in the object tree. (Inherited from System.Windows.FrameworkElement)
Public Property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderSize | Gets the final render size of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | Gets or sets transform information that affects the rendering position of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by System.Windows.UIElement.RenderTransform, relative to the bounds of the System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from System.Windows.FrameworkElement)
Public Property | Style | Gets or sets an instance System.Windows.Style that is applied for this object during rendering. (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | Gets or sets a value that modifies how tabbing and System.Windows.Controls.Control.TabIndex work for this control. (Inherited from System.Windows.Controls.Control)
Public Property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from System.Windows.FrameworkElement)
Public Property | Template | Gets or sets a control template. (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | Gets the collection of triggers for animations that are defined for a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from System.Windows.UIElement)
Public Property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | Gets or sets the visibility of a System.Windows.UIElement. A System.Windows.UIElement that is not visible does not render and does not communicate its desired size to layout. (Inherited from System.Windows.UIElement)
Public Property | Width | Gets or sets the width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Top
Protected Properties
 | Name | Description
Protected Property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from System.Windows.Controls.Control)
Top
Public Methods
 | Name | Description
Public Method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from System.Windows.UIElement)
Public Method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from System.Windows.Controls.Control)
Public Method | Arrange | Positions child objects and determines a size for a System.Windows.UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | CaptureMouse | Sets mouse capture to a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | ClearValue | Clears the local value of a dependency property. (Inherited from System.Windows.DependencyObject)
Public Method | FindName | Retrieves an object that has the specified identifier name. (Inherited from System.Windows.FrameworkElement)
Public Method | Focus | Attempts to set the focus on the control. (Inherited from System.Windows.Controls.Control)
Public Method | GetAnimationBaseValue | Returns any base value established for a Silverlight dependency property, which would apply in cases where an animation is not active. (Inherited from System.Windows.DependencyObject)
Public Method | GetBindingExpression | Retrieves the System.Windows.Data.BindingExpression for a dependency property where a binding is established. (Inherited from System.Windows.FrameworkElement)
Public Method | GetValue | Returns the current effective value of a dependency property from a System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateArrange | Invalidates the arrange state (layout) for a System.Windows.UIElement. After the invalidation, the System.Windows.UIElement will have its layout updated, which will occur asynchronously. (Inherited from System.Windows.UIElement)
Public Method | InvalidateMeasure | Invalidates the measurement state (layout) for a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | Measure | Updates the System.Windows.UIElement.DesiredSize of a System.Windows.UIElement. Typically, objects that implement custom layout for their layout children call this method from their own System.Windows.FrameworkElement.MeasureOverride(System.Windows.Size) implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call System.Windows.Controls.Control.ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in an application. For more information, see Remarks. (Inherited from System.Windows.FrameworkElement)
Public Method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from System.Windows.DependencyObject)
Public Method | ReleaseMouseCapture | Removes mouse capture from a System.Windows.UIElement. After this call, typically no object holds mouse capture. (Inherited from System.Windows.UIElement)
Public Method | RemoveHandler | Removes the specified routed event handler from this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | SetBinding | Attaches a binding to a System.Windows.FrameworkElement, using the provided binding object, and returns a System.Windows.Data.BindingExpressionBase for possible later use. (Inherited from System.Windows.FrameworkElement)
Public Method | SetValue | (Inherited from System.Windows.DependencyObject)
Public Method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the System.Windows.UIElement to the specified object. (Inherited from System.Windows.UIElement)
Public Method | UpdateLayout | Ensures that all positions of child objects of a System.Windows.UIElement are properly updated for layout. (Inherited from System.Windows.UIElement)
Top
Protected Methods
 | Name | Description
Protected Method | ArrangeOverride | (Inherited from System.Windows.FrameworkElement)
Protected Method | GetTemplateChild | Retrieves the named element in the instantiated System.Windows.Controls.ControlTemplate visual tree. (Inherited from System.Windows.Controls.Control)
Protected Method | MeasureOverride | (Inherited from System.Windows.FrameworkElement)
Protected Method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific System.Windows.Automation.Peers.AutomationPeer implementations for the Silverlight automation infrastructure. (Inherited from System.Windows.UIElement)
Protected Method | OnDragEnter | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDragLeave | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDragOver | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDrop | (Inherited from System.Windows.Controls.Control)
Protected Method | OnGotFocus | (Inherited from System.Windows.Controls.Control)
Protected Method | OnKeyDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnKeyUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnLostFocus | (Inherited from System.Windows.Controls.Control)
Protected Method | OnLostMouseCapture | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseEnter | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeave | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeftButtonDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeftButtonUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseMove | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseRightButtonDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseRightButtonUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseWheel | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInput | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInputStart | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInputUpdate | (Inherited from System.Windows.Controls.Control)
Top
Public Events
 | Name | Description
Public Event | BindingValidationError | Occurs when a data validation error is reported by a binding source. (Inherited from System.Windows.FrameworkElement)
Public Event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from System.Windows.FrameworkElement)
Public Event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from System.Windows.UIElement)
Public Event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from System.Windows.UIElement)
Public Event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from System.Windows.UIElement)
Public Event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from System.Windows.UIElement)
Public Event | GotFocus | Occurs when a System.Windows.UIElement receives focus. (Inherited from System.Windows.UIElement)
Public Event | IsEnabledChanged | Occurs when the System.Windows.Controls.Control.IsEnabled property changes. (Inherited from System.Windows.Controls.Control)
Public Event | KeyDown | Occurs when a keyboard key is pressed while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | KeyUp | Occurs when a keyboard key is released while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | Occurs when the layout of the Silverlight visual tree changes. (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | Occurs when a System.Windows.FrameworkElement has been constructed and added to the object tree. (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | Occurs when a System.Windows.UIElement loses focus. (Inherited from System.Windows.UIElement)
Public Event | LostMouseCapture | Occurs when the System.Windows.UIElement loses mouse capture. (Inherited from System.Windows.UIElement)
Public Event | MediaCommand | Occurs when a button is pressed on a remote control. (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | Occurs when the mouse (or a stylus) enters the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | Occurs when the mouse (or the stylus) leaves the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | Occurs when the left mouse button is pressed (or when the tip of the stylus touches the tablet) while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | Occurs when the left mouse button is released (or the tip of the stylus is removed from the tablet) while the mouse (or the stylus) is over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseMove | Occurs when the coordinate position of the mouse (or stylus) changes while over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over a System.Windows.UIElement. However, this event will only be raised if a caller marks the preceding System.Windows.UIElement.MouseRightButtonDown event as handled; see Remarks. (Inherited from System.Windows.UIElement)
Public Event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over a System.Windows.UIElement, or the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | Occurs when either the System.Windows.FrameworkElement.ActualHeight or the System.Windows.FrameworkElement.ActualWidth properties change value on a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Event | TextInput | Occurs when a UI element gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputStart | Occurs when a UI element initially gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputUpdate | Occurs when text continues to be composed via an input method editor (IME). (Inherited from System.Windows.UIElement)
Public Event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from System.Windows.FrameworkElement)
Top
See Also

Reference

ContextHandle Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

ContextHandle Constructor

Lassalle.Silverlight.Flow Namespace > ContextHandle Class : ContextHandle Constructor
ContextHandle constructor
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ContextHandle()
public ContextHandle()
public: ContextHandle();
public:
ContextHandle();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ContextHandle Class
ContextHandle Members


%%PageItemTitle%% $$Properties$$

ContextHandle Class Properties

Lassalle.Silverlight.Flow Namespace : ContextHandle Class

For a list of all members of this type, see ContextHandle members.

Public Properties
 | Name | Description
Public Property | ActualHeight | Gets the rendered height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | Gets the rendered width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | AddFlow | The addflow canvas containing this node
Public Property | AllowDrop | Gets or sets a value that determines whether this System.Windows.UIElement can be a drop target for purposes of Silverlight drag-and-drop operations. (Inherited from System.Windows.UIElement)
Public Property | Background | Gets or sets a brush that provides the background of the control. (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from System.Windows.Controls.Control)
Public Property | CacheMode | Gets or sets a value that indicates that rendered content should be cached when possible. (Inherited from System.Windows.UIElement)
Public Property | CharacterSpacing | Gets or sets the distance between characters of text in the control measured in 1000ths of the font size. (Inherited from System.Windows.Controls.Control)
Public Property | Clip | Gets or sets the System.Windows.Media.Geometry used to define the outline of the contents of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | Cursor | Gets or sets the cursor image that displays while the mouse pointer is over a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | Gets or sets the data context for a System.Windows.FrameworkElement when it participates in data binding. (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | Gets the size that this System.Windows.UIElement computed during the measure pass of the layout process. (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | Gets the System.Windows.Threading.Dispatcher this object is associated with. (Inherited from System.Windows.DependencyObject)
Public Property | Effect | Gets or sets the pixel shader effect to use for rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | FlowDirection | Gets or sets the direction that text and other user interface elements flow within any parent element that controls their layout. (Inherited from System.Windows.FrameworkElement)
Public Property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | Gets or sets the size of the text in this control. (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from System.Windows.Controls.Control)
Public Property | Height | Gets or sets the suggested height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | Gets or sets whether the contained area of this System.Windows.UIElement can return true values for hit testing. (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from System.Windows.Controls.Control)
Public Property | Item | Returns the item using this contextButton
Public Property | Language | Gets or sets localization/globalization language information that applies to a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | Gets or sets the outer margin of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | Gets or sets the maximum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | Gets or sets the maximum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | Gets or sets the minimum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | Gets or sets the minimum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | Gets or sets the brush used to alter the opacity of regions of this object. (Inherited from System.Windows.UIElement)
Public Property | Padding | Gets or sets the padding inside a control. (Inherited from System.Windows.Controls.Control)
Public Property | Parent | Gets the parent object of this System.Windows.FrameworkElement in the object tree. (Inherited from System.Windows.FrameworkElement)
Public Property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderSize | Gets the final render size of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | Gets or sets transform information that affects the rendering position of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by System.Windows.UIElement.RenderTransform, relative to the bounds of the System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from System.Windows.FrameworkElement)
Public Property | Style | Gets or sets an instance System.Windows.Style that is applied for this object during rendering. (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | Gets or sets a value that modifies how tabbing and System.Windows.Controls.Control.TabIndex work for this control. (Inherited from System.Windows.Controls.Control)
Public Property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from System.Windows.FrameworkElement)
Public Property | Template | Gets or sets a control template. (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | Gets the collection of triggers for animations that are defined for a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from System.Windows.UIElement)
Public Property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | Gets or sets the visibility of a System.Windows.UIElement. A System.Windows.UIElement that is not visible does not render and does not communicate its desired size to layout. (Inherited from System.Windows.UIElement)
Public Property | Width | Gets or sets the width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Top
Protected Properties
 | Name | Description
Protected Property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from System.Windows.Controls.Control)
Top
See Also

Reference

ContextHandle Class
Lassalle.Silverlight.Flow Namespace


AddFlow Property (ContextHandle)

Lassalle.Silverlight.Flow Namespace > ContextHandle Class : AddFlow Property
The addflow canvas containing this node
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property AddFlow As AddFlow
'Usage

Dim instance As ContextHandle
Dim value As AddFlow

value = instance.AddFlow
public AddFlow AddFlow {get;}
public: __property AddFlow* get_AddFlow();
public:
property AddFlow^ AddFlow {
   AddFlow^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ContextHandle Class
ContextHandle Members


Item Property (ContextHandle)

Lassalle.Silverlight.Flow Namespace > ContextHandle Class : Item Property
Returns the item using this contextButton
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Item As IHasContext
'Usage

Dim instance As ContextHandle
Dim value As IHasContext

value = instance.Item
public IHasContext Item {get;}
public: __property IHasContext* get_Item();
public:
property IHasContext^ Item {
   IHasContext^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ContextHandle Class
ContextHandle Members


%%PageItemTitle%%

ContextHandleClickedEventArgs Class
Members

Lassalle.Silverlight.Flow Namespace : ContextHandleClickedEventArgs Class
Event parameters used for the ContextHandleClicked event
Object Model
ContextHandleClickedEventArgs ClassIHasContext Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ContextHandleClickedEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ContextHandleClickedEventArgs
public class ContextHandleClickedEventArgs : System.EventArgs
public __gc class ContextHandleClickedEventArgs : public System.EventArgs
public ref class ContextHandleClickedEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Lassalle.Silverlight.Flow.ContextHandleClickedEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ContextHandleClickedEventArgs Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Members$$

ContextHandleClickedEventArgs Class Members
Properties

Lassalle.Silverlight.Flow Namespace : ContextHandleClickedEventArgs Class

The following tables list the members exposed by ContextHandleClickedEventArgs.

Public Constructors
 | Name | Description
Public Constructor | ContextHandleClickedEventArgs Constructor | Constructor. Creates a new ContextHandleClickedEventArgs instance.
Top
Public Properties
 | Name | Description
Public Property | Item | The item owning the ContextHandle (read-only)
Top
See Also

Reference

ContextHandleClickedEventArgs Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

ContextHandleClickedEventArgs Constructor

Lassalle.Silverlight.Flow Namespace > ContextHandleClickedEventArgs Class : ContextHandleClickedEventArgs Constructor
The item owning the ContextHandle
Constructor. Creates a new ContextHandleClickedEventArgs instance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal item As IHasContext _
)
'Usage

Dim item As IHasContext

Dim instance As New ContextHandleClickedEventArgs(item)
public ContextHandleClickedEventArgs(
   IHasContext item
)
public: ContextHandleClickedEventArgs(
   IHasContext* item
)
public:
ContextHandleClickedEventArgs(
   IHasContext^ item
)

Parameters

item
The item owning the ContextHandle
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ContextHandleClickedEventArgs Class
ContextHandleClickedEventArgs Members


%%PageItemTitle%% $$Properties$$

ContextHandleClickedEventArgs Class Properties

Lassalle.Silverlight.Flow Namespace : ContextHandleClickedEventArgs Class

For a list of all members of this type, see ContextHandleClickedEventArgs members.

Public Properties
 | Name | Description
Public Property | Item | The item owning the ContextHandle (read-only)
Top
See Also

Reference

ContextHandleClickedEventArgs Class
Lassalle.Silverlight.Flow Namespace


Item Property (ContextHandleClickedEventArgs)

Lassalle.Silverlight.Flow Namespace > ContextHandleClickedEventArgs Class : Item Property
The item owning the ContextHandle (read-only)
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Item As IHasContext
'Usage

Dim instance As ContextHandleClickedEventArgs
Dim value As IHasContext

value = instance.Item
public IHasContext Item {get;}
public: __property IHasContext* get_Item();
public:
property IHasContext^ Item {
   IHasContext^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ContextHandleClickedEventArgs Class
ContextHandleClickedEventArgs Members


%%PageItemTitle%%

DoubleConverter Class
Members

Lassalle.Silverlight.Flow Namespace : DoubleConverter Class
Object Model
DoubleConverter Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class DoubleConverter
'Usage

Dim instance As DoubleConverter
public class DoubleConverter
public __gc class DoubleConverter
public ref class DoubleConverter
Inheritance Hierarchy

System.Object
Lassalle.Silverlight.Flow.DoubleConverter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Members$$

DoubleConverter Class Members
Methods

Lassalle.Silverlight.Flow Namespace : DoubleConverter Class

The following tables list the members exposed by DoubleConverter.

Public Constructors
 | Name | Description
Public Constructor | DoubleConverter Constructor |
Top
Public Methods
 | Name | Description
Public Method | Convert |
Public Method | ConvertBack |
Top
See Also

Reference

DoubleConverter Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

DoubleConverter Constructor

Lassalle.Silverlight.Flow Namespace > DoubleConverter Class : DoubleConverter Constructor
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New DoubleConverter()
public DoubleConverter()
public: DoubleConverter();
public:
DoubleConverter();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members


%%PageItemTitle%% $$Methods$$

DoubleConverter Class Methods

Lassalle.Silverlight.Flow Namespace : DoubleConverter Class

For a list of all members of this type, see DoubleConverter members.

Public Methods
 | Name | Description
Public Method | Convert |
Public Method | ConvertBack |
Top
See Also

Reference

DoubleConverter Class
Lassalle.Silverlight.Flow Namespace


Convert Method

Lassalle.Silverlight.Flow Namespace > DoubleConverter Class : Convert Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Convert( _
   ByVal value As Object, _
   ByVal targetType As Type, _
   ByVal parameter As Object, _
   ByVal culture As CultureInfo _
) As Object
'Usage

Dim instance As DoubleConverter
Dim value As Object
Dim targetType As Type
Dim parameter As Object
Dim culture As CultureInfo
Dim value As Object

value = instance.Convert(value, targetType, parameter, culture)
public object Convert(
   object value,
   Type targetType,
   object parameter,
   CultureInfo culture
)
public: Object* Convert(
   Object* value,
   Type* targetType,
   Object* parameter,
   CultureInfo* culture
)
public:
Object^ Convert(
   Object^ value,
   Type^ targetType,
   Object^ parameter,
   CultureInfo^ culture
)

Parameters

value
targetType
parameter
culture
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members


ConvertBack Method

Lassalle.Silverlight.Flow Namespace > DoubleConverter Class : ConvertBack Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ConvertBack( _
   ByVal value As Object, _
   ByVal targetType As Type, _
   ByVal parameter As Object, _
   ByVal culture As CultureInfo _
) As Object
'Usage

Dim instance As DoubleConverter
Dim value As Object
Dim targetType As Type
Dim parameter As Object
Dim culture As CultureInfo
Dim value As Object

value = instance.ConvertBack(value, targetType, parameter, culture)
public object ConvertBack(
   object value,
   Type targetType,
   object parameter,
   CultureInfo culture
)
public: Object* ConvertBack(
   Object* value,
   Type* targetType,
   Object* parameter,
   CultureInfo* culture
)
public:
Object^ ConvertBack(
   Object^ value,
   Type^ targetType,
   Object^ parameter,
   CultureInfo^ culture
)

Parameters

value
targetType
parameter
culture
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleConverter Class
DoubleConverter Members


%%PageItemTitle%%

DstChangedEventArgs Class
Members

Lassalle.Silverlight.Flow Namespace : DstChangedEventArgs Class
Event parameters used for the DstChanged event
Object Model
DstChangedEventArgs ClassLink ClassNode Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class DstChangedEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As DstChangedEventArgs
public class DstChangedEventArgs : System.EventArgs
public __gc class DstChangedEventArgs : public System.EventArgs
public ref class DstChangedEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Lassalle.Silverlight.Flow.DstChangedEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DstChangedEventArgs Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Members$$

DstChangedEventArgs Class Members
Properties

Lassalle.Silverlight.Flow Namespace : DstChangedEventArgs Class

The following tables list the members exposed by DstChangedEventArgs.

Public Constructors
 | Name | Description
Public Constructor | DstChangedEventArgs Constructor | Constructor. Creates a new DstChangedEventArgs instance.
Top
Public Properties
 | Name | Description
Public Property | Cancel | Gets/sets a value indicating whether the change of the destination node of the link should be canceled.
Public Property | Link | The link whose destination node is changed (read-only)
Public Property | OldDst | The old destination node (read-only)
Top
See Also

Reference

DstChangedEventArgs Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

DstChangedEventArgs Constructor

Lassalle.Silverlight.Flow Namespace > DstChangedEventArgs Class : DstChangedEventArgs Constructor
The created link
The old destination node
Constructor. Creates a new DstChangedEventArgs instance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal link As Link, _
   ByVal oldDst As Node _
)
'Usage

Dim link As Link
Dim oldDst As Node

Dim instance As New DstChangedEventArgs(link, oldDst)
public DstChangedEventArgs(
   Link link,
   Node oldDst
)
public: DstChangedEventArgs(
   Link* link,
   Node* oldDst
)
public:
DstChangedEventArgs(
   Link^ link,
   Node^ oldDst
)

Parameters

link
The created link
oldDst
The old destination node
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DstChangedEventArgs Class
DstChangedEventArgs Members


%%PageItemTitle%% $$Properties$$

DstChangedEventArgs Class Properties

Lassalle.Silverlight.Flow Namespace : DstChangedEventArgs Class

For a list of all members of this type, see DstChangedEventArgs members.

Public Properties
 | Name | Description
Public Property | Cancel | Gets/sets a value indicating whether the change of the destination node of the link should be canceled.
Public Property | Link | The link whose destination node is changed (read-only)
Public Property | OldDst | The old destination node (read-only)
Top
See Also

Reference

DstChangedEventArgs Class
Lassalle.Silverlight.Flow Namespace


Cancel Property (DstChangedEventArgs)

Lassalle.Silverlight.Flow Namespace > DstChangedEventArgs Class : Cancel Property
Gets/sets a value indicating whether the change of the destination node of the link should be canceled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Cancel As CancelEventArgs
'Usage

Dim instance As DstChangedEventArgs
Dim value As CancelEventArgs

instance.Cancel = value

value = instance.Cancel
public CancelEventArgs Cancel {get; set;}
public: __property CancelEventArgs* get_Cancel();
public: __property void set_Cancel(
   CancelEventArgs* value
);
public:
property CancelEventArgs^ Cancel {
   CancelEventArgs^ get();
   void set (    CancelEventArgs^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DstChangedEventArgs Class
DstChangedEventArgs Members


Link Property (DstChangedEventArgs)

Lassalle.Silverlight.Flow Namespace > DstChangedEventArgs Class : Link Property
The link whose destination node is changed (read-only)
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Link As Link
'Usage

Dim instance As DstChangedEventArgs
Dim value As Link

value = instance.Link
public Link Link {get;}
public: __property Link* get_Link();
public:
property Link^ Link {
   Link^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DstChangedEventArgs Class
DstChangedEventArgs Members


OldDst Property

Lassalle.Silverlight.Flow Namespace > DstChangedEventArgs Class : OldDst Property
The old destination node (read-only)
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property OldDst As Node
'Usage

Dim instance As DstChangedEventArgs
Dim value As Node

value = instance.OldDst
public Node OldDst {get;}
public: __property Node* get_OldDst();
public:
property Node^ OldDst {
   Node^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DstChangedEventArgs Class
DstChangedEventArgs Members


%%PageItemTitle%%

DstChangingEventArgs Class
Members

Lassalle.Silverlight.Flow Namespace : DstChangingEventArgs Class
Event parameters used for the DstChanging event
Object Model
DstChangingEventArgs ClassNode ClassLink Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class DstChangingEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As DstChangingEventArgs
public class DstChangingEventArgs : System.EventArgs
public __gc class DstChangingEventArgs : public System.EventArgs
public ref class DstChangingEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Lassalle.Silverlight.Flow.DstChangingEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DstChangingEventArgs Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Members$$

DstChangingEventArgs Class Members
Properties

Lassalle.Silverlight.Flow Namespace : DstChangingEventArgs Class

The following tables list the members exposed by DstChangingEventArgs.

Public Constructors
 | Name | Description
Public Constructor | DstChangingEventArgs Constructor | Constructor. Creates a new DstChangingEventArgs instance.
Top
Public Properties
 | Name | Description
Public Property | Cancel | Gets/sets a value indicating whether the change of the destination node of the link should be canceled.
Public Property | Dst | The new destination node (read-only)
Public Property | Link | The link whose destination node is changed (read-only)
Top
See Also

Reference

DstChangingEventArgs Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

DstChangingEventArgs Constructor

Lassalle.Silverlight.Flow Namespace > DstChangingEventArgs Class : DstChangingEventArgs Constructor
The created link
The new destination node
Constructor. Creates a new DstChangingEventArgs instance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal link As Link, _
   ByVal dst As Node _
)
'Usage

Dim link As Link
Dim dst As Node

Dim instance As New DstChangingEventArgs(link, dst)
public DstChangingEventArgs(
   Link link,
   Node dst
)
public: DstChangingEventArgs(
   Link* link,
   Node* dst
)
public:
DstChangingEventArgs(
   Link^ link,
   Node^ dst
)

Parameters

link
The created link
dst
The new destination node
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DstChangingEventArgs Class
DstChangingEventArgs Members


%%PageItemTitle%% $$Properties$$

DstChangingEventArgs Class Properties

Lassalle.Silverlight.Flow Namespace : DstChangingEventArgs Class

For a list of all members of this type, see DstChangingEventArgs members.

Public Properties
 | Name | Description
Public Property | Cancel | Gets/sets a value indicating whether the change of the destination node of the link should be canceled.
Public Property | Dst | The new destination node (read-only)
Public Property | Link | The link whose destination node is changed (read-only)
Top
See Also

Reference

DstChangingEventArgs Class
Lassalle.Silverlight.Flow Namespace


Cancel Property (DstChangingEventArgs)

Lassalle.Silverlight.Flow Namespace > DstChangingEventArgs Class : Cancel Property
Gets/sets a value indicating whether the change of the destination node of the link should be canceled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Cancel As CancelEventArgs
'Usage

Dim instance As DstChangingEventArgs
Dim value As CancelEventArgs

instance.Cancel = value

value = instance.Cancel
public CancelEventArgs Cancel {get; set;}
public: __property CancelEventArgs* get_Cancel();
public: __property void set_Cancel(
   CancelEventArgs* value
);
public:
property CancelEventArgs^ Cancel {
   CancelEventArgs^ get();
   void set (    CancelEventArgs^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DstChangingEventArgs Class
DstChangingEventArgs Members


Dst Property (DstChangingEventArgs)

Lassalle.Silverlight.Flow Namespace > DstChangingEventArgs Class : Dst Property
The new destination node (read-only)
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Dst As Node
'Usage

Dim instance As DstChangingEventArgs
Dim value As Node

value = instance.Dst
public Node Dst {get;}
public: __property Node* get_Dst();
public:
property Node^ Dst {
   Node^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DstChangingEventArgs Class
DstChangingEventArgs Members


Link Property (DstChangingEventArgs)

Lassalle.Silverlight.Flow Namespace > DstChangingEventArgs Class : Link Property
The link whose destination node is changed (read-only)
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Link As Link
'Usage

Dim instance As DstChangingEventArgs
Dim value As Link

value = instance.Link
public Link Link {get;}
public: __property Link* get_Link();
public:
property Link^ Link {
   Link^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DstChangingEventArgs Class
DstChangingEventArgs Members


%%PageItemTitle%%

ErrorEventArgs Class
Members

Lassalle.Silverlight.Flow Namespace : ErrorEventArgs Class
Event parameters used for the Error event
Object Model
ErrorEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ErrorEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ErrorEventArgs
public class ErrorEventArgs : System.EventArgs
public __gc class ErrorEventArgs : public System.EventArgs
public ref class ErrorEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Lassalle.Silverlight.Flow.ErrorEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ErrorEventArgs Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Members$$

ErrorEventArgs Class Members
Properties

Lassalle.Silverlight.Flow Namespace : ErrorEventArgs Class

The following tables list the members exposed by ErrorEventArgs.

Public Constructors
 | Name | Description
Public Constructor | ErrorEventArgs Constructor | Constructor. Creates a new ErrorEventArgs instance.
Top
Public Properties
 | Name | Description
Public Property | ErrorEventType | The type of the error event (read-only)
Top
See Also

Reference

ErrorEventArgs Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

ErrorEventArgs Constructor

Lassalle.Silverlight.Flow Namespace > ErrorEventArgs Class : ErrorEventArgs Constructor
The type of the error event
Constructor. Creates a new ErrorEventArgs instance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal errorEventType As ErrorEventType _
)
'Usage

Dim errorEventType As ErrorEventType

Dim instance As New ErrorEventArgs(errorEventType)
public ErrorEventArgs(
   ErrorEventType errorEventType
)
public: ErrorEventArgs(
   ErrorEventType errorEventType
)
public:
ErrorEventArgs(
   ErrorEventType errorEventType
)

Parameters

errorEventType
The type of the error event
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ErrorEventArgs Class
ErrorEventArgs Members


%%PageItemTitle%% $$Properties$$

ErrorEventArgs Class Properties

Lassalle.Silverlight.Flow Namespace : ErrorEventArgs Class

For a list of all members of this type, see ErrorEventArgs members.

Public Properties
 | Name | Description
Public Property | ErrorEventType | The type of the error event (read-only)
Top
See Also

Reference

ErrorEventArgs Class
Lassalle.Silverlight.Flow Namespace


ErrorEventType Property

Lassalle.Silverlight.Flow Namespace > ErrorEventArgs Class : ErrorEventType Property
The type of the error event (read-only)
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ErrorEventType As ErrorEventType
'Usage

Dim instance As ErrorEventArgs
Dim value As ErrorEventType

value = instance.ErrorEventType
public ErrorEventType ErrorEventType {get;}
public: __property ErrorEventType get_ErrorEventType();
public:
property ErrorEventType ErrorEventType {
   ErrorEventType get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ErrorEventArgs Class
ErrorEventArgs Members


%%PageItemTitle%%

License Class
Members

Lassalle.Silverlight.Flow Namespace : License Class
License management
Object Model
License Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit NotInheritable Class License
'Usage

Dim instance As License
public static class License
public __gc abstract __sealed class License
public ref class License abstract sealed
Inheritance Hierarchy

System.Object
Lassalle.Silverlight.Flow.License

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

License Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Members$$

License Class Members
Properties Methods

Lassalle.Silverlight.Flow Namespace : License Class

The following tables list the members exposed by License.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | IsLicensed | Indicates whether the product is licensed
static (Shared in Visual Basic) | LicenseHead |
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | Activate | Activate the product with a license key
Top
See Also

Reference

License Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Methods$$

License Class Methods

Lassalle.Silverlight.Flow Namespace : License Class

For a list of all members of this type, see License members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | Activate | Activate the product with a license key
Top
See Also

Reference

License Class
Lassalle.Silverlight.Flow Namespace


Activate Method

Lassalle.Silverlight.Flow Namespace > License Class : Activate Method
The license key to use.
Activate the product with a license key
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub Activate( _
   ByVal licenseKey As String _
)
'Usage

Dim licenseKey As String

License.Activate(licenseKey)
public static void Activate(
   string licenseKey
)
public: static void Activate(
   string* licenseKey
)
public:
static void Activate(
   String^ licenseKey
)

Parameters

licenseKey
The license key to use.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

License Class
License Members


%%PageItemTitle%% $$Properties$$

License Class Properties

Lassalle.Silverlight.Flow Namespace : License Class

For a list of all members of this type, see License members.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | IsLicensed | Indicates whether the product is licensed
static (Shared in Visual Basic) | LicenseHead |
Top
See Also

Reference

License Class
Lassalle.Silverlight.Flow Namespace


IsLicensed Property

Lassalle.Silverlight.Flow Namespace > License Class : IsLicensed Property
Indicates whether the product is licensed
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property IsLicensed As Boolean
'Usage

Dim value As Boolean

value = License.IsLicensed
public static bool IsLicensed {get;}
public: __property static bool get_IsLicensed();
public:
static property bool IsLicensed {
   bool get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

License Class
License Members


LicenseHead Property

Lassalle.Silverlight.Flow Namespace > License Class : LicenseHead Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property LicenseHead As String
'Usage

Dim value As String

value = License.LicenseHead
public static string LicenseHead {get;}
public: __property static string* get_LicenseHead();
public:
static property String^ LicenseHead {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

License Class
License Members


%%PageItemTitle%%

Link Class
Members

Lassalle.Silverlight.Flow Namespace : Link Class
Represents a link (also called edge, relation or arc) in the diagram.
Object Model
Link ClassAddFlow ClassNode ClassNode ClassPin ClassPin Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<TemplatePartAttribute(Name="LinkHitPath", Type=System.Windows.Shapes.Path)>
<DesignTimeVisibleAttribute()>
<TemplatePartAttribute(Name="TextBlockBorder", Type=System.Windows.Controls.Border)>
<TemplateVisualStateAttribute(Name="Normal", GroupName="CommonStates")>
<TemplateVisualStateAttribute(Name="MouseOver", GroupName="CommonStates")>
<TemplatePartAttribute(Name="Root", Type=System.Windows.FrameworkElement)>
<TemplatePartAttribute(Name="LinkPath", Type=System.Windows.Shapes.Path)>
<TemplatePartAttribute(Name="ArrowDstContent", Type=System.Windows.FrameworkElement)>
<TemplatePartAttribute(Name="ArrowOrgContent", Type=System.Windows.FrameworkElement)>
<TemplatePartAttribute(Name="TextBlock", Type=System.Windows.Controls.TextBlock)>
Public Class Link
   Inherits System.Windows.Controls.Control
   Implements IHasContext, ISelectable
'Usage

Dim instance As Link
[TemplatePartAttribute(Name="LinkHitPath", Type=System.Windows.Shapes.Path)]
[DesignTimeVisibleAttribute()]
[TemplatePartAttribute(Name="TextBlockBorder", Type=System.Windows.Controls.Border)]
[TemplateVisualStateAttribute(Name="Normal", GroupName="CommonStates")]
[TemplateVisualStateAttribute(Name="MouseOver", GroupName="CommonStates")]
[TemplatePartAttribute(Name="Root", Type=System.Windows.FrameworkElement)]
[TemplatePartAttribute(Name="LinkPath", Type=System.Windows.Shapes.Path)]
[TemplatePartAttribute(Name="ArrowDstContent", Type=System.Windows.FrameworkElement)]
[TemplatePartAttribute(Name="ArrowOrgContent", Type=System.Windows.FrameworkElement)]
[TemplatePartAttribute(Name="TextBlock", Type=System.Windows.Controls.TextBlock)]
public class Link : System.Windows.Controls.Control, IHasContext, ISelectable
[TemplatePartAttribute(Name="LinkHitPath", Type=System.Windows.Shapes.Path)]
[DesignTimeVisibleAttribute()]
[TemplatePartAttribute(Name="TextBlockBorder", Type=System.Windows.Controls.Border)]
[TemplateVisualStateAttribute(Name="Normal", GroupName="CommonStates")]
[TemplateVisualStateAttribute(Name="MouseOver", GroupName="CommonStates")]
[TemplatePartAttribute(Name="Root", Type=System.Windows.FrameworkElement)]
[TemplatePartAttribute(Name="LinkPath", Type=System.Windows.Shapes.Path)]
[TemplatePartAttribute(Name="ArrowDstContent", Type=System.Windows.FrameworkElement)]
[TemplatePartAttribute(Name="ArrowOrgContent", Type=System.Windows.FrameworkElement)]
[TemplatePartAttribute(Name="TextBlock", Type=System.Windows.Controls.TextBlock)]
public __gc class Link : public System.Windows.Controls.Control, IHasContext, ISelectable
[TemplatePartAttribute(Name="LinkHitPath", Type=System.Windows.Shapes.Path)]
[DesignTimeVisibleAttribute()]
[TemplatePartAttribute(Name="TextBlockBorder", Type=System.Windows.Controls.Border)]
[TemplateVisualStateAttribute(Name="Normal", GroupName="CommonStates")]
[TemplateVisualStateAttribute(Name="MouseOver", GroupName="CommonStates")]
[TemplatePartAttribute(Name="Root", Type=System.Windows.FrameworkElement)]
[TemplatePartAttribute(Name="LinkPath", Type=System.Windows.Shapes.Path)]
[TemplatePartAttribute(Name="ArrowDstContent", Type=System.Windows.FrameworkElement)]
[TemplatePartAttribute(Name="ArrowOrgContent", Type=System.Windows.FrameworkElement)]
[TemplatePartAttribute(Name="TextBlock", Type=System.Windows.Controls.TextBlock)]
public ref class Link : public System.Windows.Controls.Control, IHasContext, ISelectable
Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
Lassalle.Silverlight.Flow.Link

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Members$$

Link Class Members
Fields Properties Methods Events

Lassalle.Silverlight.Flow Namespace : Link Class

The following tables list the members exposed by Link.

Public Constructors
 | Name | Description
Public Constructor | Link Constructor | Overloaded.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | ArrowDstAngleProperty | Identifies the ArrowDstAngle dependency property
static (Shared in Visual Basic) | ArrowDstFillProperty | Identifies the ArrowDstFill dependency property.
static (Shared in Visual Basic) | ArrowDstGeometryProperty | Identifies the ArrowDstGeometry dependency property.
static (Shared in Visual Basic) | ArrowDstHeightProperty | Identifies the ArrowDstHeight dependency property
static (Shared in Visual Basic) | ArrowDstWidthProperty | Identifies the ArrowDstWidth dependency property
static (Shared in Visual Basic) | ArrowDstXProperty | Identifies the ArrowDstX dependency property
static (Shared in Visual Basic) | ArrowDstYProperty | Identifies the ArrowDstY dependency property
static (Shared in Visual Basic) | ArrowOrgAngleProperty | Identifies the ArrowOrgAngle dependency property
static (Shared in Visual Basic) | ArrowOrgFillProperty | Identifies the ArrowOrgFill dependency property.
static (Shared in Visual Basic) | ArrowOrgGeometryProperty | Identifies the ArrowOrgGeometry dependency property.
static (Shared in Visual Basic) | ArrowOrgHeightProperty | Identifies the ArrowOrgHeight dependency property
static (Shared in Visual Basic) | ArrowOrgWidthProperty | Identifies the ArrowOrgWidth dependency property
static (Shared in Visual Basic) | ArrowOrgXProperty | Identifies the ArrowOrgX dependency property
static (Shared in Visual Basic) | ArrowOrgYProperty | Identifies the ArrowOrgY dependency property
static (Shared in Visual Basic) | DstProperty | Identifies the Dst dependency property
static (Shared in Visual Basic) | HitPathGeometryProperty | Identifies the HitPathGeometry dependency property.
static (Shared in Visual Basic) | IsContextHandleProperty | Identifies the IsContextHandle dependency property
static (Shared in Visual Basic) | IsSelectableProperty | Identifies the IsSelectable dependency property.
static (Shared in Visual Basic) | IsSelectedProperty | Identifies the IsSelected dependency property.
static (Shared in Visual Basic) | IsStretchableProperty | Identifies the IsStretchable dependency property.
static (Shared in Visual Basic) | JumpSizeProperty | Identifies the JumpSize dependency property.
static (Shared in Visual Basic) | LineStyleProperty | Identifies the LineStyle dependency property.
static (Shared in Visual Basic) | OrgProperty | Identifies the Org dependency property
static (Shared in Visual Basic) | PathGeometryProperty | Identifies the PathGeometry dependency property.
static (Shared in Visual Basic) | PinDstProperty | Identifies the PinDst dependency property
static (Shared in Visual Basic) | PinOrgProperty | Identifies the PinOrg dependency property
static (Shared in Visual Basic) | PointsProperty | Identifies the Points dependency property.
static (Shared in Visual Basic) | RoundedCornerSizeProperty | Identifies the RoundedCornerSize dependency property.
static (Shared in Visual Basic) | StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property.
static (Shared in Visual Basic) | StrokeProperty | Identifies the Stroke dependency property.
static (Shared in Visual Basic) | StrokeThicknessProperty | Identifies the StrokeThickness dependency property.
static (Shared in Visual Basic) | TextAngleModeProperty | Identifies the TextAngleMode dependency property
static (Shared in Visual Basic) | TextPlacementModeProperty | Identifies the TextPlacementMode dependency property.
static (Shared in Visual Basic) | TextProperty | Identifies the Text dependency property.
static (Shared in Visual Basic) | TextXOffsetProperty | Identifies the TextXOffset dependency property.
static (Shared in Visual Basic) | TextXPositionProperty | Identifies the TextXPosition dependency property.
static (Shared in Visual Basic) | TextYOffsetProperty | Identifies the TextYOffset dependency property.
static (Shared in Visual Basic) | TextYPositionProperty | Identifies the TextYPosition dependency property.
Top
Public Properties
 | Name | Description
Public Property | ActualHeight | Gets the rendered height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | Gets the rendered width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | AddFlow | The addflow canvas containing this link
Public Property | AllowDrop | Gets or sets a value that determines whether this System.Windows.UIElement can be a drop target for purposes of Silverlight drag-and-drop operations. (Inherited from System.Windows.UIElement)
Public Property | ArrowDstAngle | Returns/sets the angle used to display the arrow placed at destination of the link
Public Property | ArrowDstFill | Returns/sets the brush used to draw the destination arrow of the link.
Public Property | ArrowDstGeometry | Returns/sets the brush used to draw the destination arrow of the link.
Public Property | ArrowDstHeight | Returns/sets the heigth of the arrow placed at destination of the link
Public Property | ArrowDstWidth | Returns/sets the width of the arrow placed at destination of the link
Public Property | ArrowDstX | Returns/sets the X position used to display the arrow placed at destination of the link
Public Property | ArrowDstY | Returns/sets the X position used to display the arrow placed at destination of the link
Public Property | ArrowOrgAngle | Returns/sets the angle used to display the arrow placed at origin of the link
Public Property | ArrowOrgFill | Returns/sets the brush used to draw the origin arrow of the link.
Public Property | ArrowOrgGeometry | Returns/sets the brush used to draw the origin arrow of the link.
Public Property | ArrowOrgHeight | Returns/sets the heigth of the arrow placed at origin of the link
Public Property | ArrowOrgWidth | Returns/sets the width of the arrow placed at origin of the link
Public Property | ArrowOrgX | Returns/sets the X position used to display the arrow placed at origin of the link
Public Property | ArrowOrgY | Returns/sets the X position used to display the arrow placed at origin of the link
Public Property | Background | Gets or sets a brush that provides the background of the control. (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from System.Windows.Controls.Control)
Public Property | CacheMode | Gets or sets a value that indicates that rendered content should be cached when possible. (Inherited from System.Windows.UIElement)
Public Property | CharacterSpacing | Gets or sets the distance between characters of text in the control measured in 1000ths of the font size. (Inherited from System.Windows.Controls.Control)
Public Property | Clip | Gets or sets the System.Windows.Media.Geometry used to define the outline of the contents of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | Cursor | Gets or sets the cursor image that displays while the mouse pointer is over a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | Gets or sets the data context for a System.Windows.FrameworkElement when it participates in data binding. (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | Gets the size that this System.Windows.UIElement computed during the measure pass of the layout process. (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | Gets the System.Windows.Threading.Dispatcher this object is associated with. (Inherited from System.Windows.DependencyObject)
Public Property | Dst | Returns/sets the destination node of the link.
Public Property | Effect | Gets or sets the pixel shader effect to use for rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | FlowDirection | Gets or sets the direction that text and other user interface elements flow within any parent element that controls their layout. (Inherited from System.Windows.FrameworkElement)
Public Property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | Gets or sets the size of the text in this control. (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from System.Windows.Controls.Control)
Public Property | Height | Gets or sets the suggested height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | HitPathGeometry | Returns/sets the HitPathGeometry object used to hit the link
Public Property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | IsContextHandle | Determines whether the link has a context handle.
Public Property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | Gets or sets whether the contained area of this System.Windows.UIElement can return true values for hit testing. (Inherited from System.Windows.UIElement)
Public Property | IsSelectable | Determines whether the link is selectable by clicking on it with the mouse or unselectable (readonly or inactive).
Public Property | IsSelected | Determines if link is selected or not.
Public Property | IsStretchable | Determines whether the link is stretchable or not. When a link is not stretchable, the user cannot interactively stretch it with the mouse.
Public Property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from System.Windows.Controls.Control)
Public Property | JumpSize | Returns/sets the size of the jumps at the intersection of this link with other links.
Public Property | Language | Gets or sets localization/globalization language information that applies to a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | LineStyle | Returns/sets the style of the line of the link.
Public Property | Margin | Gets or sets the outer margin of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | Gets or sets the maximum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | Gets or sets the maximum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | Gets or sets the minimum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | Gets or sets the minimum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | Gets or sets the brush used to alter the opacity of regions of this object. (Inherited from System.Windows.UIElement)
Public Property | Org | Returns/sets the origin node of the link.
Public Property | Padding | Gets or sets the padding inside a control. (Inherited from System.Windows.Controls.Control)
Public Property | Parent | Gets the parent object of this System.Windows.FrameworkElement in the object tree. (Inherited from System.Windows.FrameworkElement)
Public Property | PathGeometry | Returns/sets the PathGeometry object used to draw the link
Public Property | PinDst | Returns/sets the destination pin shape of the link
Public Property | PinOrg | Returns/sets the destination pin shape of the link
Public Property | Points | The collection of link points
Public Property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderSize | Gets the final render size of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | Gets or sets transform information that affects the rendering position of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by System.Windows.UIElement.RenderTransform, relative to the bounds of the System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from System.Windows.FrameworkElement)
Public Property | RoundedCornerSize | Determines the size of the rounded corner at the intersection point of 2 segments. It is 0 by default
Public Property | Stroke | Returns/sets the brush used to draw the item.
Public Property | StrokeDashArray | Returns/sets the collection of Double values that indicate the pattern of dashes and gaps that is used to draw the link.
Public Property | StrokeThickness | Returns/sets the thickness used to draw the link.
Public Property | Style | Gets or sets an instance System.Windows.Style that is applied for this object during rendering. (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | Gets or sets a value that modifies how tabbing and System.Windows.Controls.Control.TabIndex work for this control. (Inherited from System.Windows.Controls.Control)
Public Property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from System.Windows.FrameworkElement)
Public Property | Template | Gets or sets a control template. (Inherited from System.Windows.Controls.Control)
Public Property | Text | Sets or returns the text label associated with the link.
Public Property | TextAngleMode | Sets or returns the TextAngleMode style of the label on the link
Public Property | TextBlock | Returns the TextBlock associated with the link and used to display the link label
Public Property | TextBlockBorder | Returns the Border containing the link TextBlock
Public Property | TextPlacementMode | Returns/sets the TextPlacementMode style of the text of the link.
Public Property | TextXOffset | Returns/sets the x value of the offset of the link text.
Public Property | TextXPosition | Returns/sets the x coordinate of the position of the link text.
Public Property | TextYOffset | Returns/sets the y value of the offset of the link text.
Public Property | TextYPosition | Returns/sets the y coordinate of the position of the link text.
Public Property | Triggers | Gets the collection of triggers for animations that are defined for a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from System.Windows.UIElement)
Public Property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | Gets or sets the visibility of a System.Windows.UIElement. A System.Windows.UIElement that is not visible does not render and does not communicate its desired size to layout. (Inherited from System.Windows.UIElement)
Public Property | Width | Gets or sets the width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Top
Protected Properties
 | Name | Description
Protected Property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from System.Windows.Controls.Control)
Top
Public Methods
 | Name | Description
Public Method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from System.Windows.UIElement)
Public Method | AddPoint | Add a point to the collection of points of a link.
Public Method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from System.Windows.Controls.Control)
Public Method | Arrange | Positions child objects and determines a size for a System.Windows.UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | CaptureMouse | Sets mouse capture to a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | ClearPoints | Clears the collection of points of the link, removing all points except the first and the last since a link points collection is never empty and contains at least 2 points.
Public Method | ClearValue | Clears the local value of a dependency property. (Inherited from System.Windows.DependencyObject)
Public Method | CountPoints | Gets the total number of points in the collection of points of a link.
Public Method | FindName | Retrieves an object that has the specified identifier name. (Inherited from System.Windows.FrameworkElement)
Public Method | Focus | Attempts to set the focus on the control. (Inherited from System.Windows.Controls.Control)
Public Method | GetAnimationBaseValue | Returns any base value established for a Silverlight dependency property, which would apply in cases where an animation is not active. (Inherited from System.Windows.DependencyObject)
Public Method | GetBindingExpression | Retrieves the System.Windows.Data.BindingExpression for a dependency property where a binding is established. (Inherited from System.Windows.FrameworkElement)
Public Method | GetPoint | Returns a point at the specified index.
Public Method | GetValue | Returns the current effective value of a dependency property from a System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateArrange | Invalidates the arrange state (layout) for a System.Windows.UIElement. After the invalidation, the System.Windows.UIElement will have its layout updated, which will occur asynchronously. (Inherited from System.Windows.UIElement)
Public Method | InvalidateMeasure | Invalidates the measurement state (layout) for a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | Measure | Updates the System.Windows.UIElement.DesiredSize of a System.Windows.UIElement. Typically, objects that implement custom layout for their layout children call this method from their own System.Windows.FrameworkElement.MeasureOverride(System.Windows.Size) implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | OnApplyTemplate | Overridden. Loads the link template so that its parts can be referenced.
Public Method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from System.Windows.DependencyObject)
Public Method | ReleaseMouseCapture | Removes mouse capture from a System.Windows.UIElement. After this call, typically no object holds mouse capture. (Inherited from System.Windows.UIElement)
Public Method | RemoveHandler | Removes the specified routed event handler from this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | RemovePoint | Removes the point at the specified index from the collection of points of the link.
Public Method | SetBinding | Attaches a binding to a System.Windows.FrameworkElement, using the provided binding object, and returns a System.Windows.Data.BindingExpressionBase for possible later use. (Inherited from System.Windows.FrameworkElement)
Public Method | SetPoint | Sets a point at the specified index.
Public Method | SetValue | (Inherited from System.Windows.DependencyObject)
Public Method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the System.Windows.UIElement to the specified object. (Inherited from System.Windows.UIElement)
Public Method | UpdateLayout | Ensures that all positions of child objects of a System.Windows.UIElement are properly updated for layout. (Inherited from System.Windows.UIElement)
Top
Protected Methods
 | Name | Description
Protected Method | ArrangeOverride | (Inherited from System.Windows.FrameworkElement)
Protected Method | GetTemplateChild | Retrieves the named element in the instantiated System.Windows.Controls.ControlTemplate visual tree. (Inherited from System.Windows.Controls.Control)
Protected Method | MeasureOverride | (Inherited from System.Windows.FrameworkElement)
Protected Method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific System.Windows.Automation.Peers.AutomationPeer implementations for the Silverlight automation infrastructure. (Inherited from System.Windows.UIElement)
Protected Method | OnDragEnter | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDragLeave | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDragOver | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDrop | (Inherited from System.Windows.Controls.Control)
Protected Method | OnGotFocus | (Inherited from System.Windows.Controls.Control)
Protected Method | OnKeyDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnKeyUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnLostFocus | (Inherited from System.Windows.Controls.Control)
Protected Method | OnLostMouseCapture | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseEnter | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeave | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeftButtonDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeftButtonUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseMove | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseRightButtonDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseRightButtonUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseWheel | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInput | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInputStart | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInputUpdate | (Inherited from System.Windows.Controls.Control)
Top
Public Events
 | Name | Description
Public Event | BindingValidationError | Occurs when a data validation error is reported by a binding source. (Inherited from System.Windows.FrameworkElement)
Public Event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from System.Windows.FrameworkElement)
Public Event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from System.Windows.UIElement)
Public Event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from System.Windows.UIElement)
Public Event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from System.Windows.UIElement)
Public Event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from System.Windows.UIElement)
Public Event | GotFocus | Occurs when a System.Windows.UIElement receives focus. (Inherited from System.Windows.UIElement)
Public Event | IsEnabledChanged | Occurs when the System.Windows.Controls.Control.IsEnabled property changes. (Inherited from System.Windows.Controls.Control)
Public Event | KeyDown | Occurs when a keyboard key is pressed while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | KeyUp | Occurs when a keyboard key is released while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | Occurs when the layout of the Silverlight visual tree changes. (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | Occurs when a System.Windows.FrameworkElement has been constructed and added to the object tree. (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | Occurs when a System.Windows.UIElement loses focus. (Inherited from System.Windows.UIElement)
Public Event | LostMouseCapture | Occurs when the System.Windows.UIElement loses mouse capture. (Inherited from System.Windows.UIElement)
Public Event | MediaCommand | Occurs when a button is pressed on a remote control. (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | Occurs when the mouse (or a stylus) enters the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | Occurs when the mouse (or the stylus) leaves the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | Occurs when the left mouse button is pressed (or when the tip of the stylus touches the tablet) while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | Occurs when the left mouse button is released (or the tip of the stylus is removed from the tablet) while the mouse (or the stylus) is over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseMove | Occurs when the coordinate position of the mouse (or stylus) changes while over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over a System.Windows.UIElement. However, this event will only be raised if a caller marks the preceding System.Windows.UIElement.MouseRightButtonDown event as handled; see Remarks. (Inherited from System.Windows.UIElement)
Public Event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over a System.Windows.UIElement, or the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | Occurs when either the System.Windows.FrameworkElement.ActualHeight or the System.Windows.FrameworkElement.ActualWidth properties change value on a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Event | TextInput | Occurs when a UI element gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputStart | Occurs when a UI element initially gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputUpdate | Occurs when text continues to be composed via an input method editor (IME). (Inherited from System.Windows.UIElement)
Public Event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from System.Windows.FrameworkElement)
Top
See Also

Reference

Link Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

Link Constructor

Lassalle.Silverlight.Flow Namespace > Link Class : Link Constructor
Overload List
Overload | Description
Link Constructor() | Link constructor
Link Constructor(Node,Node) | Initializes a new instance of the Link class with a text.
Link Constructor(Node,Node,String) | Initializes a new instance of the Link class with a text.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


%%PageItemTitle%%

Link Constructor()

Lassalle.Silverlight.Flow Namespace > Link Class > Link Constructor : Link Constructor()
Link constructor
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New Link()
public Link()
public: Link();
public:
Link();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members
Overload List


%%PageItemTitle%%

Link Constructor(Node,Node)

Lassalle.Silverlight.Flow Namespace > Link Class > Link Constructor : Link Constructor(Node,Node)
A reference to the origin node of the link
A reference to the destination node of the link
Initializes a new instance of the Link class with a text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal org As Node, _
   ByVal dst As Node _
)
'Usage

Dim org As Node
Dim dst As Node

Dim instance As New Link(org, dst)
public Link(
   Node org,
   Node dst
)
public: Link(
   Node* org,
   Node* dst
)
public:
Link(
   Node^ org,
   Node^ dst
)

Parameters

org
A reference to the origin node of the link
dst
A reference to the destination node of the link
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members
Overload List


%%PageItemTitle%%

Link Constructor(Node,Node,String)

Lassalle.Silverlight.Flow Namespace > Link Class > Link Constructor : Link Constructor(Node,Node,String)
A reference to the origin node of the link
A reference to the destination node of the link
The text displayed with the link
Initializes a new instance of the Link class with a text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal org As Node, _
   ByVal dst As Node, _
   ByVal text As String _
)
'Usage

Dim org As Node
Dim dst As Node
Dim text As String

Dim instance As New Link(org, dst, text)
public Link(
   Node org,
   Node dst,
   string text
)
public: Link(
   Node* org,
   Node* dst,
   string* text
)
public:
Link(
   Node^ org,
   Node^ dst,
   String^ text
)

Parameters

org
A reference to the origin node of the link
dst
A reference to the destination node of the link
text
The text displayed with the link
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members
Overload List


%%PageItemTitle%% $$Methods$$

Link Class Methods

Lassalle.Silverlight.Flow Namespace : Link Class

For a list of all members of this type, see Link members.

Public Methods
 | Name | Description
Public Method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from System.Windows.UIElement)
Public Method | AddPoint | Add a point to the collection of points of a link.
Public Method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from System.Windows.Controls.Control)
Public Method | Arrange | Positions child objects and determines a size for a System.Windows.UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | CaptureMouse | Sets mouse capture to a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | ClearPoints | Clears the collection of points of the link, removing all points except the first and the last since a link points collection is never empty and contains at least 2 points.
Public Method | ClearValue | Clears the local value of a dependency property. (Inherited from System.Windows.DependencyObject)
Public Method | CountPoints | Gets the total number of points in the collection of points of a link.
Public Method | FindName | Retrieves an object that has the specified identifier name. (Inherited from System.Windows.FrameworkElement)
Public Method | Focus | Attempts to set the focus on the control. (Inherited from System.Windows.Controls.Control)
Public Method | GetAnimationBaseValue | Returns any base value established for a Silverlight dependency property, which would apply in cases where an animation is not active. (Inherited from System.Windows.DependencyObject)
Public Method | GetBindingExpression | Retrieves the System.Windows.Data.BindingExpression for a dependency property where a binding is established. (Inherited from System.Windows.FrameworkElement)
Public Method | GetPoint | Returns a point at the specified index.
Public Method | GetValue | Returns the current effective value of a dependency property from a System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateArrange | Invalidates the arrange state (layout) for a System.Windows.UIElement. After the invalidation, the System.Windows.UIElement will have its layout updated, which will occur asynchronously. (Inherited from System.Windows.UIElement)
Public Method | InvalidateMeasure | Invalidates the measurement state (layout) for a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | Measure | Updates the System.Windows.UIElement.DesiredSize of a System.Windows.UIElement. Typically, objects that implement custom layout for their layout children call this method from their own System.Windows.FrameworkElement.MeasureOverride(System.Windows.Size) implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | OnApplyTemplate | Overridden. Loads the link template so that its parts can be referenced.
Public Method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from System.Windows.DependencyObject)
Public Method | ReleaseMouseCapture | Removes mouse capture from a System.Windows.UIElement. After this call, typically no object holds mouse capture. (Inherited from System.Windows.UIElement)
Public Method | RemoveHandler | Removes the specified routed event handler from this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | RemovePoint | Removes the point at the specified index from the collection of points of the link.
Public Method | SetBinding | Attaches a binding to a System.Windows.FrameworkElement, using the provided binding object, and returns a System.Windows.Data.BindingExpressionBase for possible later use. (Inherited from System.Windows.FrameworkElement)
Public Method | SetPoint | Sets a point at the specified index.
Public Method | SetValue | (Inherited from System.Windows.DependencyObject)
Public Method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the System.Windows.UIElement to the specified object. (Inherited from System.Windows.UIElement)
Public Method | UpdateLayout | Ensures that all positions of child objects of a System.Windows.UIElement are properly updated for layout. (Inherited from System.Windows.UIElement)
Top
Protected Methods
 | Name | Description
Protected Method | ArrangeOverride | (Inherited from System.Windows.FrameworkElement)
Protected Method | GetTemplateChild | Retrieves the named element in the instantiated System.Windows.Controls.ControlTemplate visual tree. (Inherited from System.Windows.Controls.Control)
Protected Method | MeasureOverride | (Inherited from System.Windows.FrameworkElement)
Protected Method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific System.Windows.Automation.Peers.AutomationPeer implementations for the Silverlight automation infrastructure. (Inherited from System.Windows.UIElement)
Protected Method | OnDragEnter | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDragLeave | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDragOver | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDrop | (Inherited from System.Windows.Controls.Control)
Protected Method | OnGotFocus | (Inherited from System.Windows.Controls.Control)
Protected Method | OnKeyDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnKeyUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnLostFocus | (Inherited from System.Windows.Controls.Control)
Protected Method | OnLostMouseCapture | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseEnter | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeave | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeftButtonDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeftButtonUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseMove | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseRightButtonDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseRightButtonUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseWheel | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInput | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInputStart | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInputUpdate | (Inherited from System.Windows.Controls.Control)
Top
See Also

Reference

Link Class
Lassalle.Silverlight.Flow Namespace


AddPoint Method

Lassalle.Silverlight.Flow Namespace > Link Class : AddPoint Method
The point to add
Add a point to the collection of points of a link.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AddPoint( _
   ByVal point As Point _
)
'Usage

Dim instance As Link
Dim point As Point

instance.AddPoint(point)
public void AddPoint(
   Point point
)
public: void AddPoint(
   Point point
)
public:
void AddPoint(
   Point point
)

Parameters

point
The point to add
Remarks
This method will work only if the link style is IsPolyline or Spline. However, in other cases, no exception is thrown.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


ClearPoints Method

Lassalle.Silverlight.Flow Namespace > Link Class : ClearPoints Method
Clears the collection of points of the link, removing all points except the first and the last since a link points collection is never empty and contains at least 2 points.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ClearPoints()
'Usage

Dim instance As Link

instance.ClearPoints()
public void ClearPoints()
public: void ClearPoints();
public:
void ClearPoints();
Remarks
This method will work only if the link style is IsPolyline or Spline. However, in other cases, no exception is thrown.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


CountPoints Method

Lassalle.Silverlight.Flow Namespace > Link Class : CountPoints Method
Gets the total number of points in the collection of points of a link.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CountPoints() As Integer
'Usage

Dim instance As Link
Dim value As Integer

value = instance.CountPoints()
public int CountPoints()
public: int CountPoints();
public:
int CountPoints();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


GetPoint Method

Lassalle.Silverlight.Flow Namespace > Link Class : GetPoint Method
Returns a point at the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetPoint( _
   ByVal index As Integer _
) As Point
'Usage

Dim instance As Link
Dim index As Integer
Dim value As Point

value = instance.GetPoint(index)
public Point GetPoint(
   int index
)
public: Point GetPoint(
   int index
)
public:
Point GetPoint(
   int index
)

Parameters

index
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


OnApplyTemplate Method (Link)

Lassalle.Silverlight.Flow Namespace > Link Class : OnApplyTemplate Method
Loads the link template so that its parts can be referenced.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub OnApplyTemplate()
'Usage

Dim instance As Link

instance.OnApplyTemplate()
public override void OnApplyTemplate()
public: void OnApplyTemplate(); override
public:
void OnApplyTemplate(); override
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


RemovePoint Method

Lassalle.Silverlight.Flow Namespace > Link Class : RemovePoint Method
The index of the point to be removed from the collection.
Removes the point at the specified index from the collection of points of the link.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RemovePoint( _
   ByVal index As Integer _
)
'Usage

Dim instance As Link
Dim index As Integer

instance.RemovePoint(index)
public void RemovePoint(
   int index
)
public: void RemovePoint(
   int index
)
public:
void RemovePoint(
   int index
)

Parameters

index
The index of the point to be removed from the collection.
Remarks
This method will work only if the link style is IsPolyline or Spline. However, in other cases, no exception is thrown.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


SetPoint Method

Lassalle.Silverlight.Flow Namespace > Link Class : SetPoint Method
Sets a point at the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetPoint( _
   ByVal point As Point, _
   ByVal index As Integer _
)
'Usage

Dim instance As Link
Dim point As Point
Dim index As Integer

instance.SetPoint(point, index)
public void SetPoint(
   Point point,
   int index
)
public: void SetPoint(
   Point point,
   int index
)
public:
void SetPoint(
   Point point,
   int index
)

Parameters

point
index
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


%%PageItemTitle%% $$Properties$$

Link Class Properties

Lassalle.Silverlight.Flow Namespace : Link Class

For a list of all members of this type, see Link members.

Public Properties
 | Name | Description
Public Property | ActualHeight | Gets the rendered height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | Gets the rendered width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | AddFlow | The addflow canvas containing this link
Public Property | AllowDrop | Gets or sets a value that determines whether this System.Windows.UIElement can be a drop target for purposes of Silverlight drag-and-drop operations. (Inherited from System.Windows.UIElement)
Public Property | ArrowDstAngle | Returns/sets the angle used to display the arrow placed at destination of the link
Public Property | ArrowDstFill | Returns/sets the brush used to draw the destination arrow of the link.
Public Property | ArrowDstGeometry | Returns/sets the brush used to draw the destination arrow of the link.
Public Property | ArrowDstHeight | Returns/sets the heigth of the arrow placed at destination of the link
Public Property | ArrowDstWidth | Returns/sets the width of the arrow placed at destination of the link
Public Property | ArrowDstX | Returns/sets the X position used to display the arrow placed at destination of the link
Public Property | ArrowDstY | Returns/sets the X position used to display the arrow placed at destination of the link
Public Property | ArrowOrgAngle | Returns/sets the angle used to display the arrow placed at origin of the link
Public Property | ArrowOrgFill | Returns/sets the brush used to draw the origin arrow of the link.
Public Property | ArrowOrgGeometry | Returns/sets the brush used to draw the origin arrow of the link.
Public Property | ArrowOrgHeight | Returns/sets the heigth of the arrow placed at origin of the link
Public Property | ArrowOrgWidth | Returns/sets the width of the arrow placed at origin of the link
Public Property | ArrowOrgX | Returns/sets the X position used to display the arrow placed at origin of the link
Public Property | ArrowOrgY | Returns/sets the X position used to display the arrow placed at origin of the link
Public Property | Background | Gets or sets a brush that provides the background of the control. (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from System.Windows.Controls.Control)
Public Property | CacheMode | Gets or sets a value that indicates that rendered content should be cached when possible. (Inherited from System.Windows.UIElement)
Public Property | CharacterSpacing | Gets or sets the distance between characters of text in the control measured in 1000ths of the font size. (Inherited from System.Windows.Controls.Control)
Public Property | Clip | Gets or sets the System.Windows.Media.Geometry used to define the outline of the contents of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | Cursor | Gets or sets the cursor image that displays while the mouse pointer is over a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | Gets or sets the data context for a System.Windows.FrameworkElement when it participates in data binding. (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | Gets the size that this System.Windows.UIElement computed during the measure pass of the layout process. (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | Gets the System.Windows.Threading.Dispatcher this object is associated with. (Inherited from System.Windows.DependencyObject)
Public Property | Dst | Returns/sets the destination node of the link.
Public Property | Effect | Gets or sets the pixel shader effect to use for rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | FlowDirection | Gets or sets the direction that text and other user interface elements flow within any parent element that controls their layout. (Inherited from System.Windows.FrameworkElement)
Public Property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | Gets or sets the size of the text in this control. (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from System.Windows.Controls.Control)
Public Property | Height | Gets or sets the suggested height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | HitPathGeometry | Returns/sets the HitPathGeometry object used to hit the link
Public Property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | IsContextHandle | Determines whether the link has a context handle.
Public Property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | Gets or sets whether the contained area of this System.Windows.UIElement can return true values for hit testing. (Inherited from System.Windows.UIElement)
Public Property | IsSelectable | Determines whether the link is selectable by clicking on it with the mouse or unselectable (readonly or inactive).
Public Property | IsSelected | Determines if link is selected or not.
Public Property | IsStretchable | Determines whether the link is stretchable or not. When a link is not stretchable, the user cannot interactively stretch it with the mouse.
Public Property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from System.Windows.Controls.Control)
Public Property | JumpSize | Returns/sets the size of the jumps at the intersection of this link with other links.
Public Property | Language | Gets or sets localization/globalization language information that applies to a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | LineStyle | Returns/sets the style of the line of the link.
Public Property | Margin | Gets or sets the outer margin of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | Gets or sets the maximum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | Gets or sets the maximum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | Gets or sets the minimum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | Gets or sets the minimum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | Gets or sets the brush used to alter the opacity of regions of this object. (Inherited from System.Windows.UIElement)
Public Property | Org | Returns/sets the origin node of the link.
Public Property | Padding | Gets or sets the padding inside a control. (Inherited from System.Windows.Controls.Control)
Public Property | Parent | Gets the parent object of this System.Windows.FrameworkElement in the object tree. (Inherited from System.Windows.FrameworkElement)
Public Property | PathGeometry | Returns/sets the PathGeometry object used to draw the link
Public Property | PinDst | Returns/sets the destination pin shape of the link
Public Property | PinOrg | Returns/sets the destination pin shape of the link
Public Property | Points | The collection of link points
Public Property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderSize | Gets the final render size of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | Gets or sets transform information that affects the rendering position of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by System.Windows.UIElement.RenderTransform, relative to the bounds of the System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from System.Windows.FrameworkElement)
Public Property | RoundedCornerSize | Determines the size of the rounded corner at the intersection point of 2 segments. It is 0 by default
Public Property | Stroke | Returns/sets the brush used to draw the item.
Public Property | StrokeDashArray | Returns/sets the collection of Double values that indicate the pattern of dashes and gaps that is used to draw the link.
Public Property | StrokeThickness | Returns/sets the thickness used to draw the link.
Public Property | Style | Gets or sets an instance System.Windows.Style that is applied for this object during rendering. (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | Gets or sets a value that modifies how tabbing and System.Windows.Controls.Control.TabIndex work for this control. (Inherited from System.Windows.Controls.Control)
Public Property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from System.Windows.FrameworkElement)
Public Property | Template | Gets or sets a control template. (Inherited from System.Windows.Controls.Control)
Public Property | Text | Sets or returns the text label associated with the link.
Public Property | TextAngleMode | Sets or returns the TextAngleMode style of the label on the link
Public Property | TextBlock | Returns the TextBlock associated with the link and used to display the link label
Public Property | TextBlockBorder | Returns the Border containing the link TextBlock
Public Property | TextPlacementMode | Returns/sets the TextPlacementMode style of the text of the link.
Public Property | TextXOffset | Returns/sets the x value of the offset of the link text.
Public Property | TextXPosition | Returns/sets the x coordinate of the position of the link text.
Public Property | TextYOffset | Returns/sets the y value of the offset of the link text.
Public Property | TextYPosition | Returns/sets the y coordinate of the position of the link text.
Public Property | Triggers | Gets the collection of triggers for animations that are defined for a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from System.Windows.UIElement)
Public Property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | Gets or sets the visibility of a System.Windows.UIElement. A System.Windows.UIElement that is not visible does not render and does not communicate its desired size to layout. (Inherited from System.Windows.UIElement)
Public Property | Width | Gets or sets the width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Top
Protected Properties
 | Name | Description
Protected Property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from System.Windows.Controls.Control)
Top
See Also

Reference

Link Class
Lassalle.Silverlight.Flow Namespace


AddFlow Property (Link)

Lassalle.Silverlight.Flow Namespace > Link Class : AddFlow Property
The addflow canvas containing this link
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property AddFlow As AddFlow
'Usage

Dim instance As Link
Dim value As AddFlow

value = instance.AddFlow
public AddFlow AddFlow {get;}
public: __property AddFlow* get_AddFlow();
public:
property AddFlow^ AddFlow {
   AddFlow^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


ArrowDstAngle Property

Lassalle.Silverlight.Flow Namespace > Link Class : ArrowDstAngle Property
Returns/sets the angle used to display the arrow placed at destination of the link
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ArrowDstAngle As Double
'Usage

Dim instance As Link
Dim value As Double

instance.ArrowDstAngle = value

value = instance.ArrowDstAngle
public double ArrowDstAngle {get; set;}
public: __property double get_ArrowDstAngle();
public: __property void set_ArrowDstAngle(
   double value
);
public:
property double ArrowDstAngle {
   double get();
   void set (    double value);
}
Remarks
Don't use this property which is only provided for the AddFlow infrastructure
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


ArrowDstFill Property

Lassalle.Silverlight.Flow Namespace > Link Class : ArrowDstFill Property
Returns/sets the brush used to draw the destination arrow of the link.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ArrowDstFill As Brush
'Usage

Dim instance As Link
Dim value As Brush

instance.ArrowDstFill = value

value = instance.ArrowDstFill
public Brush ArrowDstFill {get; set;}
public: __property Brush* get_ArrowDstFill();
public: __property void set_ArrowDstFill(
   Brush* value
);
public:
property Brush^ ArrowDstFill {
   Brush^ get();
   void set (    Brush^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


ArrowDstGeometry Property

Lassalle.Silverlight.Flow Namespace > Link Class : ArrowDstGeometry Property
Returns/sets the brush used to draw the destination arrow of the link.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ArrowDstGeometry As Geometry
'Usage

Dim instance As Link
Dim value As Geometry

instance.ArrowDstGeometry = value

value = instance.ArrowDstGeometry
public Geometry ArrowDstGeometry {get; set;}
public: __property Geometry* get_ArrowDstGeometry();
public: __property void set_ArrowDstGeometry(
   Geometry* value
);
public:
property Geometry^ ArrowDstGeometry {
   Geometry^ get();
   void set (    Geometry^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


ArrowDstHeight Property

Lassalle.Silverlight.Flow Namespace > Link Class : ArrowDstHeight Property
Returns/sets the heigth of the arrow placed at destination of the link
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ArrowDstHeight As Double
'Usage

Dim instance As Link
Dim value As Double

instance.ArrowDstHeight = value

value = instance.ArrowDstHeight
public double ArrowDstHeight {get; set;}
public: __property double get_ArrowDstHeight();
public: __property void set_ArrowDstHeight(
   double value
);
public:
property double ArrowDstHeight {
   double get();
   void set (    double value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


ArrowDstWidth Property

Lassalle.Silverlight.Flow Namespace > Link Class : ArrowDstWidth Property
Returns/sets the width of the arrow placed at destination of the link
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ArrowDstWidth As Double
'Usage

Dim instance As Link
Dim value As Double

instance.ArrowDstWidth = value

value = instance.ArrowDstWidth
public double ArrowDstWidth {get; set;}
public: __property double get_ArrowDstWidth();
public: __property void set_ArrowDstWidth(
   double value
);
public:
property double ArrowDstWidth {
   double get();
   void set (    double value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


ArrowDstX Property

Lassalle.Silverlight.Flow Namespace > Link Class : ArrowDstX Property
Returns/sets the X position used to display the arrow placed at destination of the link
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ArrowDstX As Double
'Usage

Dim instance As Link
Dim value As Double

instance.ArrowDstX = value

value = instance.ArrowDstX
public double ArrowDstX {get; set;}
public: __property double get_ArrowDstX();
public: __property void set_ArrowDstX(
   double value
);
public:
property double ArrowDstX {
   double get();
   void set (    double value);
}
Remarks
Don't use this property which is only provided for the AddFlow infrastructure
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


ArrowDstY Property

Lassalle.Silverlight.Flow Namespace > Link Class : ArrowDstY Property
Returns/sets the X position used to display the arrow placed at destination of the link
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ArrowDstY As Double
'Usage

Dim instance As Link
Dim value As Double

instance.ArrowDstY = value

value = instance.ArrowDstY
public double ArrowDstY {get; set;}
public: __property double get_ArrowDstY();
public: __property void set_ArrowDstY(
   double value
);
public:
property double ArrowDstY {
   double get();
   void set (    double value);
}
Remarks
Don't use this property which is only provided for the AddFlow infrastructure
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


ArrowOrgAngle Property

Lassalle.Silverlight.Flow Namespace > Link Class : ArrowOrgAngle Property
Returns/sets the angle used to display the arrow placed at origin of the link
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ArrowOrgAngle As Double
'Usage

Dim instance As Link
Dim value As Double

instance.ArrowOrgAngle = value

value = instance.ArrowOrgAngle
public double ArrowOrgAngle {get; set;}
public: __property double get_ArrowOrgAngle();
public: __property void set_ArrowOrgAngle(
   double value
);
public:
property double ArrowOrgAngle {
   double get();
   void set (    double value);
}
Remarks
Don't use this property which is only provided for the AddFlow infrastructure
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


ArrowOrgFill Property

Lassalle.Silverlight.Flow Namespace > Link Class : ArrowOrgFill Property
Returns/sets the brush used to draw the origin arrow of the link.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ArrowOrgFill As Brush
'Usage

Dim instance As Link
Dim value As Brush

instance.ArrowOrgFill = value

value = instance.ArrowOrgFill
public Brush ArrowOrgFill {get; set;}
public: __property Brush* get_ArrowOrgFill();
public: __property void set_ArrowOrgFill(
   Brush* value
);
public:
property Brush^ ArrowOrgFill {
   Brush^ get();
   void set (    Brush^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


ArrowOrgGeometry Property

Lassalle.Silverlight.Flow Namespace > Link Class : ArrowOrgGeometry Property
Returns/sets the brush used to draw the origin arrow of the link.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ArrowOrgGeometry As Geometry
'Usage

Dim instance As Link
Dim value As Geometry

instance.ArrowOrgGeometry = value

value = instance.ArrowOrgGeometry
public Geometry ArrowOrgGeometry {get; set;}
public: __property Geometry* get_ArrowOrgGeometry();
public: __property void set_ArrowOrgGeometry(
   Geometry* value
);
public:
property Geometry^ ArrowOrgGeometry {
   Geometry^ get();
   void set (    Geometry^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


ArrowOrgHeight Property

Lassalle.Silverlight.Flow Namespace > Link Class : ArrowOrgHeight Property
Returns/sets the heigth of the arrow placed at origin of the link
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ArrowOrgHeight As Double
'Usage

Dim instance As Link
Dim value As Double

instance.ArrowOrgHeight = value

value = instance.ArrowOrgHeight
public double ArrowOrgHeight {get; set;}
public: __property double get_ArrowOrgHeight();
public: __property void set_ArrowOrgHeight(
   double value
);
public:
property double ArrowOrgHeight {
   double get();
   void set (    double value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


ArrowOrgWidth Property

Lassalle.Silverlight.Flow Namespace > Link Class : ArrowOrgWidth Property
Returns/sets the width of the arrow placed at origin of the link
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ArrowOrgWidth As Double
'Usage

Dim instance As Link
Dim value As Double

instance.ArrowOrgWidth = value

value = instance.ArrowOrgWidth
public double ArrowOrgWidth {get; set;}
public: __property double get_ArrowOrgWidth();
public: __property void set_ArrowOrgWidth(
   double value
);
public:
property double ArrowOrgWidth {
   double get();
   void set (    double value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


ArrowOrgX Property

Lassalle.Silverlight.Flow Namespace > Link Class : ArrowOrgX Property
Returns/sets the X position used to display the arrow placed at origin of the link
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ArrowOrgX As Double
'Usage

Dim instance As Link
Dim value As Double

instance.ArrowOrgX = value

value = instance.ArrowOrgX
public double ArrowOrgX {get; set;}
public: __property double get_ArrowOrgX();
public: __property void set_ArrowOrgX(
   double value
);
public:
property double ArrowOrgX {
   double get();
   void set (    double value);
}
Remarks
Don't use this property which is only provided for the AddFlow infrastructure
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


ArrowOrgY Property

Lassalle.Silverlight.Flow Namespace > Link Class : ArrowOrgY Property
Returns/sets the X position used to display the arrow placed at origin of the link
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ArrowOrgY As Double
'Usage

Dim instance As Link
Dim value As Double

instance.ArrowOrgY = value

value = instance.ArrowOrgY
public double ArrowOrgY {get; set;}
public: __property double get_ArrowOrgY();
public: __property void set_ArrowOrgY(
   double value
);
public:
property double ArrowOrgY {
   double get();
   void set (    double value);
}
Remarks
Don't use this property which is only provided for the AddFlow infrastructure
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


Dst Property (Link)

Lassalle.Silverlight.Flow Namespace > Link Class : Dst Property
Returns/sets the destination node of the link.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Dst As Node
'Usage

Dim instance As Link
Dim value As Node

instance.Dst = value

value = instance.Dst
public Node Dst {get; set;}
public: __property Node* get_Dst();
public: __property void set_Dst(
   Node* value
);
public:
property Node^ Dst {
   Node^ get();
   void set (    Node^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


HitPathGeometry Property

Lassalle.Silverlight.Flow Namespace > Link Class : HitPathGeometry Property
Returns/sets the HitPathGeometry object used to hit the link
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HitPathGeometry As PathGeometry
'Usage

Dim instance As Link
Dim value As PathGeometry

instance.HitPathGeometry = value

value = instance.HitPathGeometry
public PathGeometry HitPathGeometry {get; set;}
public: __property PathGeometry* get_HitPathGeometry();
public: __property void set_HitPathGeometry(
   PathGeometry* value
);
public:
property PathGeometry^ HitPathGeometry {
   PathGeometry^ get();
   void set (    PathGeometry^ value);
}
Remarks
Don't use this property which is only provided for the AddFlow infrastructure
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


IsContextHandle Property (Link)

Lassalle.Silverlight.Flow Namespace > Link Class : IsContextHandle Property
Determines whether the link has a context handle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsContextHandle As Boolean
'Usage

Dim instance As Link
Dim value As Boolean

instance.IsContextHandle = value

value = instance.IsContextHandle
public bool IsContextHandle {get; set;}
public: __property bool get_IsContextHandle();
public: __property void set_IsContextHandle(
   bool value
);
public:
property bool IsContextHandle {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


IsSelectable Property (Link)

Lassalle.Silverlight.Flow Namespace > Link Class : IsSelectable Property
Determines whether the link is selectable by clicking on it with the mouse or unselectable (readonly or inactive).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsSelectable As Boolean
'Usage

Dim instance As Link
Dim value As Boolean

instance.IsSelectable = value

value = instance.IsSelectable
public bool IsSelectable {get; set;}
public: __property bool get_IsSelectable();
public: __property void set_IsSelectable(
   bool value
);
public:
property bool IsSelectable {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


IsSelected Property (Link)

Lassalle.Silverlight.Flow Namespace > Link Class : IsSelected Property
Determines if link is selected or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsSelected As Boolean
'Usage

Dim instance As Link
Dim value As Boolean

instance.IsSelected = value

value = instance.IsSelected
public bool IsSelected {get; set;}
public: __property bool get_IsSelected();
public: __property void set_IsSelected(
   bool value
);
public:
property bool IsSelected {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


IsStretchable Property

Lassalle.Silverlight.Flow Namespace > Link Class : IsStretchable Property
Determines whether the link is stretchable or not. When a link is not stretchable, the user cannot interactively stretch it with the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsStretchable As Boolean
'Usage

Dim instance As Link
Dim value As Boolean

instance.IsStretchable = value

value = instance.IsStretchable
public bool IsStretchable {get; set;}
public: __property bool get_IsStretchable();
public: __property void set_IsStretchable(
   bool value
);
public:
property bool IsStretchable {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


JumpSize Property

Lassalle.Silverlight.Flow Namespace > Link Class : JumpSize Property
Returns/sets the size of the jumps at the intersection of this link with other links.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property JumpSize As Double
'Usage

Dim instance As Link
Dim value As Double

instance.JumpSize = value

value = instance.JumpSize
public double JumpSize {get; set;}
public: __property double get_JumpSize();
public: __property void set_JumpSize(
   double value
);
public:
property double JumpSize {
   double get();
   void set (    double value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


LineStyle Property

Lassalle.Silverlight.Flow Namespace > Link Class : LineStyle Property
Returns/sets the style of the line of the link.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LineStyle As LineStyle
'Usage

Dim instance As Link
Dim value As LineStyle

instance.LineStyle = value

value = instance.LineStyle
public LineStyle LineStyle {get; set;}
public: __property LineStyle get_LineStyle();
public: __property void set_LineStyle(
   LineStyle value
);
public:
property LineStyle LineStyle {
   LineStyle get();
   void set (    LineStyle value);
}
Remarks
  1. A reflexive link cannot have a LineStyle other than IsPolyline, Bezier or Spline.
  2. The Bezier link has 4 points.
  3. If LineStyle is not IsPolyline, Bezier or Spline, the link is not stretchable. You cannot increase its segments number.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


Org Property (Link)

Lassalle.Silverlight.Flow Namespace > Link Class : Org Property
Returns/sets the origin node of the link.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Org As Node
'Usage

Dim instance As Link
Dim value As Node

instance.Org = value

value = instance.Org
public Node Org {get; set;}
public: __property Node* get_Org();
public: __property void set_Org(
   Node* value
);
public:
property Node^ Org {
   Node^ get();
   void set (    Node^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


PathGeometry Property

Lassalle.Silverlight.Flow Namespace > Link Class : PathGeometry Property
Returns/sets the PathGeometry object used to draw the link
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PathGeometry As PathGeometry
'Usage

Dim instance As Link
Dim value As PathGeometry

instance.PathGeometry = value

value = instance.PathGeometry
public PathGeometry PathGeometry {get; set;}
public: __property PathGeometry* get_PathGeometry();
public: __property void set_PathGeometry(
   PathGeometry* value
);
public:
property PathGeometry^ PathGeometry {
   PathGeometry^ get();
   void set (    PathGeometry^ value);
}
Remarks
Don't use this property which is only provided for the AddFlow infrastructure
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


PinDst Property

Lassalle.Silverlight.Flow Namespace > Link Class : PinDst Property
Returns/sets the destination pin shape of the link
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PinDst As Pin
'Usage

Dim instance As Link
Dim value As Pin

instance.PinDst = value

value = instance.PinDst
public Pin PinDst {get; set;}
public: __property Pin* get_PinDst();
public: __property void set_PinDst(
   Pin* value
);
public:
property Pin^ PinDst {
   Pin^ get();
   void set (    Pin^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


PinOrg Property

Lassalle.Silverlight.Flow Namespace > Link Class : PinOrg Property
Returns/sets the destination pin shape of the link
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PinOrg As Pin
'Usage

Dim instance As Link
Dim value As Pin

instance.PinOrg = value

value = instance.PinOrg
public Pin PinOrg {get; set;}
public: __property Pin* get_PinOrg();
public: __property void set_PinOrg(
   Pin* value
);
public:
property Pin^ PinOrg {
   Pin^ get();
   void set (    Pin^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


Points Property

Lassalle.Silverlight.Flow Namespace > Link Class : Points Property
The collection of link points
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Points As PointCollection
'Usage

Dim instance As Link
Dim value As PointCollection

instance.Points = value

value = instance.Points
public PointCollection Points {get; set;}
public: __property PointCollection* get_Points();
public: __property void set_Points(
   PointCollection* value
);
public:
property PointCollection^ Points {
   PointCollection^ get();
   void set (    PointCollection^ value);
}
Remarks
Don't use this property which is only provided for the AddFlow infrastructure. To manipulate the collection of link points, you should use instead the methods AddPoint, RemovePoints, ClearPoints, CountPoints, GetPoint and SetPoint.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


RoundedCornerSize Property

Lassalle.Silverlight.Flow Namespace > Link Class : RoundedCornerSize Property
Determines the size of the rounded corner at the intersection point of 2 segments. It is 0 by default
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RoundedCornerSize As Double
'Usage

Dim instance As Link
Dim value As Double

instance.RoundedCornerSize = value

value = instance.RoundedCornerSize
public double RoundedCornerSize {get; set;}
public: __property double get_RoundedCornerSize();
public: __property void set_RoundedCornerSize(
   double value
);
public:
property double RoundedCornerSize {
   double get();
   void set (    double value);
}
Remarks
This property will have not any effect if the style property of the link is Bezier or Spline.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


Stroke Property

Lassalle.Silverlight.Flow Namespace > Link Class : Stroke Property
Returns/sets the brush used to draw the item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Stroke As Brush
'Usage

Dim instance As Link
Dim value As Brush

instance.Stroke = value

value = instance.Stroke
public Brush Stroke {get; set;}
public: __property Brush* get_Stroke();
public: __property void set_Stroke(
   Brush* value
);
public:
property Brush^ Stroke {
   Brush^ get();
   void set (    Brush^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


StrokeDashArray Property

Lassalle.Silverlight.Flow Namespace > Link Class : StrokeDashArray Property
Returns/sets the collection of Double values that indicate the pattern of dashes and gaps that is used to draw the link.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property StrokeDashArray As DoubleCollection
'Usage

Dim instance As Link
Dim value As DoubleCollection

instance.StrokeDashArray = value

value = instance.StrokeDashArray
public DoubleCollection StrokeDashArray {get; set;}
public: __property DoubleCollection* get_StrokeDashArray();
public: __property void set_StrokeDashArray(
   DoubleCollection* value
);
public:
property DoubleCollection^ StrokeDashArray {
   DoubleCollection^ get();
   void set (    DoubleCollection^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


StrokeThickness Property

Lassalle.Silverlight.Flow Namespace > Link Class : StrokeThickness Property
Returns/sets the thickness used to draw the link.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property StrokeThickness As Double
'Usage

Dim instance As Link
Dim value As Double

instance.StrokeThickness = value

value = instance.StrokeThickness
public double StrokeThickness {get; set;}
public: __property double get_StrokeThickness();
public: __property void set_StrokeThickness(
   double value
);
public:
property double StrokeThickness {
   double get();
   void set (    double value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


Text Property (Link)

Lassalle.Silverlight.Flow Namespace > Link Class : Text Property
Sets or returns the text label associated with the link.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Text As String
'Usage

Dim instance As Link
Dim value As String

instance.Text = value

value = instance.Text
public string Text {get; set;}
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
public:
property String^ Text {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


TextAngleMode Property

Lassalle.Silverlight.Flow Namespace > Link Class : TextAngleMode Property
Sets or returns the TextAngleMode style of the label on the link
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TextAngleMode As TextAngleMode
'Usage

Dim instance As Link
Dim value As TextAngleMode

instance.TextAngleMode = value

value = instance.TextAngleMode
public TextAngleMode TextAngleMode {get; set;}
public: __property TextAngleMode get_TextAngleMode();
public: __property void set_TextAngleMode(
   TextAngleMode value
);
public:
property TextAngleMode TextAngleMode {
   TextAngleMode get();
   void set (    TextAngleMode value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


TextBlock Property (Link)

Lassalle.Silverlight.Flow Namespace > Link Class : TextBlock Property
Returns the TextBlock associated with the link and used to display the link label
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property TextBlock As TextBlock
'Usage

Dim instance As Link
Dim value As TextBlock

value = instance.TextBlock
public TextBlock TextBlock {get;}
public: __property TextBlock* get_TextBlock();
public:
property TextBlock^ TextBlock {
   TextBlock^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


TextBlockBorder Property

Lassalle.Silverlight.Flow Namespace > Link Class : TextBlockBorder Property
Returns the Border containing the link TextBlock
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TextBlockBorder As Border
'Usage

Dim instance As Link
Dim value As Border

instance.TextBlockBorder = value

value = instance.TextBlockBorder
public Border TextBlockBorder {get; set;}
public: __property Border* get_TextBlockBorder();
public: __property void set_TextBlockBorder(
   Border* value
);
public:
property Border^ TextBlockBorder {
   Border^ get();
   void set (    Border^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


TextPlacementMode Property

Lassalle.Silverlight.Flow Namespace > Link Class : TextPlacementMode Property
Returns/sets the TextPlacementMode style of the text of the link.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TextPlacementMode As TextPlacementMode
'Usage

Dim instance As Link
Dim value As TextPlacementMode

instance.TextPlacementMode = value

value = instance.TextPlacementMode
public TextPlacementMode TextPlacementMode {get; set;}
public: __property TextPlacementMode get_TextPlacementMode();
public: __property void set_TextPlacementMode(
   TextPlacementMode value
);
public:
property TextPlacementMode TextPlacementMode {
   TextPlacementMode get();
   void set (    TextPlacementMode value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


TextXOffset Property

Lassalle.Silverlight.Flow Namespace > Link Class : TextXOffset Property
Returns/sets the x value of the offset of the link text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TextXOffset As Double
'Usage

Dim instance As Link
Dim value As Double

instance.TextXOffset = value

value = instance.TextXOffset
public double TextXOffset {get; set;}
public: __property double get_TextXOffset();
public: __property void set_TextXOffset(
   double value
);
public:
property double TextXOffset {
   double get();
   void set (    double value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


TextXPosition Property

Lassalle.Silverlight.Flow Namespace > Link Class : TextXPosition Property
Returns/sets the x coordinate of the position of the link text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TextXPosition As Double
'Usage

Dim instance As Link
Dim value As Double

instance.TextXPosition = value

value = instance.TextXPosition
public double TextXPosition {get; set;}
public: __property double get_TextXPosition();
public: __property void set_TextXPosition(
   double value
);
public:
property double TextXPosition {
   double get();
   void set (    double value);
}
Remarks
Don't use this property which is only provided for the AddFlow infrastructure
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


TextYOffset Property

Lassalle.Silverlight.Flow Namespace > Link Class : TextYOffset Property
Returns/sets the y value of the offset of the link text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TextYOffset As Double
'Usage

Dim instance As Link
Dim value As Double

instance.TextYOffset = value

value = instance.TextYOffset
public double TextYOffset {get; set;}
public: __property double get_TextYOffset();
public: __property void set_TextYOffset(
   double value
);
public:
property double TextYOffset {
   double get();
   void set (    double value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


TextYPosition Property

Lassalle.Silverlight.Flow Namespace > Link Class : TextYPosition Property
Returns/sets the y coordinate of the position of the link text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TextYPosition As Double
'Usage

Dim instance As Link
Dim value As Double

instance.TextYPosition = value

value = instance.TextYPosition
public double TextYPosition {get; set;}
public: __property double get_TextYPosition();
public: __property void set_TextYPosition(
   double value
);
public:
property double TextYPosition {
   double get();
   void set (    double value);
}
Remarks
Don't use this property which is only provided for the AddFlow infrastructure
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


%%PageItemTitle%% $$Fields$$

Link Class Fields

Lassalle.Silverlight.Flow Namespace : Link Class

For a list of all members of this type, see Link members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | ArrowDstAngleProperty | Identifies the ArrowDstAngle dependency property
static (Shared in Visual Basic) | ArrowDstFillProperty | Identifies the ArrowDstFill dependency property.
static (Shared in Visual Basic) | ArrowDstGeometryProperty | Identifies the ArrowDstGeometry dependency property.
static (Shared in Visual Basic) | ArrowDstHeightProperty | Identifies the ArrowDstHeight dependency property
static (Shared in Visual Basic) | ArrowDstWidthProperty | Identifies the ArrowDstWidth dependency property
static (Shared in Visual Basic) | ArrowDstXProperty | Identifies the ArrowDstX dependency property
static (Shared in Visual Basic) | ArrowDstYProperty | Identifies the ArrowDstY dependency property
static (Shared in Visual Basic) | ArrowOrgAngleProperty | Identifies the ArrowOrgAngle dependency property
static (Shared in Visual Basic) | ArrowOrgFillProperty | Identifies the ArrowOrgFill dependency property.
static (Shared in Visual Basic) | ArrowOrgGeometryProperty | Identifies the ArrowOrgGeometry dependency property.
static (Shared in Visual Basic) | ArrowOrgHeightProperty | Identifies the ArrowOrgHeight dependency property
static (Shared in Visual Basic) | ArrowOrgWidthProperty | Identifies the ArrowOrgWidth dependency property
static (Shared in Visual Basic) | ArrowOrgXProperty | Identifies the ArrowOrgX dependency property
static (Shared in Visual Basic) | ArrowOrgYProperty | Identifies the ArrowOrgY dependency property
static (Shared in Visual Basic) | DstProperty | Identifies the Dst dependency property
static (Shared in Visual Basic) | HitPathGeometryProperty | Identifies the HitPathGeometry dependency property.
static (Shared in Visual Basic) | IsContextHandleProperty | Identifies the IsContextHandle dependency property
static (Shared in Visual Basic) | IsSelectableProperty | Identifies the IsSelectable dependency property.
static (Shared in Visual Basic) | IsSelectedProperty | Identifies the IsSelected dependency property.
static (Shared in Visual Basic) | IsStretchableProperty | Identifies the IsStretchable dependency property.
static (Shared in Visual Basic) | JumpSizeProperty | Identifies the JumpSize dependency property.
static (Shared in Visual Basic) | LineStyleProperty | Identifies the LineStyle dependency property.
static (Shared in Visual Basic) | OrgProperty | Identifies the Org dependency property
static (Shared in Visual Basic) | PathGeometryProperty | Identifies the PathGeometry dependency property.
static (Shared in Visual Basic) | PinDstProperty | Identifies the PinDst dependency property
static (Shared in Visual Basic) | PinOrgProperty | Identifies the PinOrg dependency property
static (Shared in Visual Basic) | PointsProperty | Identifies the Points dependency property.
static (Shared in Visual Basic) | RoundedCornerSizeProperty | Identifies the RoundedCornerSize dependency property.
static (Shared in Visual Basic) | StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property.
static (Shared in Visual Basic) | StrokeProperty | Identifies the Stroke dependency property.
static (Shared in Visual Basic) | StrokeThicknessProperty | Identifies the StrokeThickness dependency property.
static (Shared in Visual Basic) | TextAngleModeProperty | Identifies the TextAngleMode dependency property
static (Shared in Visual Basic) | TextPlacementModeProperty | Identifies the TextPlacementMode dependency property.
static (Shared in Visual Basic) | TextProperty | Identifies the Text dependency property.
static (Shared in Visual Basic) | TextXOffsetProperty | Identifies the TextXOffset dependency property.
static (Shared in Visual Basic) | TextXPositionProperty | Identifies the TextXPosition dependency property.
static (Shared in Visual Basic) | TextYOffsetProperty | Identifies the TextYOffset dependency property.
static (Shared in Visual Basic) | TextYPositionProperty | Identifies the TextYPosition dependency property.
Top
See Also

Reference

Link Class
Lassalle.Silverlight.Flow Namespace


ArrowDstAngleProperty Field

Lassalle.Silverlight.Flow Namespace > Link Class : ArrowDstAngleProperty Field
Identifies the ArrowDstAngle dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ArrowDstAngleProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Link.ArrowDstAngleProperty
public static readonly DependencyProperty ArrowDstAngleProperty
public: static readonly DependencyProperty* ArrowDstAngleProperty
public:
static readonly DependencyProperty^ ArrowDstAngleProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


ArrowDstFillProperty Field

Lassalle.Silverlight.Flow Namespace > Link Class : ArrowDstFillProperty Field
Identifies the ArrowDstFill dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ArrowDstFillProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Link.ArrowDstFillProperty
public static readonly DependencyProperty ArrowDstFillProperty
public: static readonly DependencyProperty* ArrowDstFillProperty
public:
static readonly DependencyProperty^ ArrowDstFillProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


ArrowDstGeometryProperty Field

Lassalle.Silverlight.Flow Namespace > Link Class : ArrowDstGeometryProperty Field
Identifies the ArrowDstGeometry dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ArrowDstGeometryProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Link.ArrowDstGeometryProperty
public static readonly DependencyProperty ArrowDstGeometryProperty
public: static readonly DependencyProperty* ArrowDstGeometryProperty
public:
static readonly DependencyProperty^ ArrowDstGeometryProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


ArrowDstHeightProperty Field

Lassalle.Silverlight.Flow Namespace > Link Class : ArrowDstHeightProperty Field
Identifies the ArrowDstHeight dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ArrowDstHeightProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Link.ArrowDstHeightProperty
public static readonly DependencyProperty ArrowDstHeightProperty
public: static readonly DependencyProperty* ArrowDstHeightProperty
public:
static readonly DependencyProperty^ ArrowDstHeightProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


ArrowDstWidthProperty Field

Lassalle.Silverlight.Flow Namespace > Link Class : ArrowDstWidthProperty Field
Identifies the ArrowDstWidth dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ArrowDstWidthProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Link.ArrowDstWidthProperty
public static readonly DependencyProperty ArrowDstWidthProperty
public: static readonly DependencyProperty* ArrowDstWidthProperty
public:
static readonly DependencyProperty^ ArrowDstWidthProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


ArrowDstXProperty Field

Lassalle.Silverlight.Flow Namespace > Link Class : ArrowDstXProperty Field
Identifies the ArrowDstX dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ArrowDstXProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Link.ArrowDstXProperty
public static readonly DependencyProperty ArrowDstXProperty
public: static readonly DependencyProperty* ArrowDstXProperty
public:
static readonly DependencyProperty^ ArrowDstXProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


ArrowDstYProperty Field

Lassalle.Silverlight.Flow Namespace > Link Class : ArrowDstYProperty Field
Identifies the ArrowDstY dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ArrowDstYProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Link.ArrowDstYProperty
public static readonly DependencyProperty ArrowDstYProperty
public: static readonly DependencyProperty* ArrowDstYProperty
public:
static readonly DependencyProperty^ ArrowDstYProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


ArrowOrgAngleProperty Field

Lassalle.Silverlight.Flow Namespace > Link Class : ArrowOrgAngleProperty Field
Identifies the ArrowOrgAngle dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ArrowOrgAngleProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Link.ArrowOrgAngleProperty
public static readonly DependencyProperty ArrowOrgAngleProperty
public: static readonly DependencyProperty* ArrowOrgAngleProperty
public:
static readonly DependencyProperty^ ArrowOrgAngleProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


ArrowOrgFillProperty Field

Lassalle.Silverlight.Flow Namespace > Link Class : ArrowOrgFillProperty Field
Identifies the ArrowOrgFill dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ArrowOrgFillProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Link.ArrowOrgFillProperty
public static readonly DependencyProperty ArrowOrgFillProperty
public: static readonly DependencyProperty* ArrowOrgFillProperty
public:
static readonly DependencyProperty^ ArrowOrgFillProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


ArrowOrgGeometryProperty Field

Lassalle.Silverlight.Flow Namespace > Link Class : ArrowOrgGeometryProperty Field
Identifies the ArrowOrgGeometry dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ArrowOrgGeometryProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Link.ArrowOrgGeometryProperty
public static readonly DependencyProperty ArrowOrgGeometryProperty
public: static readonly DependencyProperty* ArrowOrgGeometryProperty
public:
static readonly DependencyProperty^ ArrowOrgGeometryProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


ArrowOrgHeightProperty Field

Lassalle.Silverlight.Flow Namespace > Link Class : ArrowOrgHeightProperty Field
Identifies the ArrowOrgHeight dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ArrowOrgHeightProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Link.ArrowOrgHeightProperty
public static readonly DependencyProperty ArrowOrgHeightProperty
public: static readonly DependencyProperty* ArrowOrgHeightProperty
public:
static readonly DependencyProperty^ ArrowOrgHeightProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


ArrowOrgWidthProperty Field

Lassalle.Silverlight.Flow Namespace > Link Class : ArrowOrgWidthProperty Field
Identifies the ArrowOrgWidth dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ArrowOrgWidthProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Link.ArrowOrgWidthProperty
public static readonly DependencyProperty ArrowOrgWidthProperty
public: static readonly DependencyProperty* ArrowOrgWidthProperty
public:
static readonly DependencyProperty^ ArrowOrgWidthProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


ArrowOrgXProperty Field

Lassalle.Silverlight.Flow Namespace > Link Class : ArrowOrgXProperty Field
Identifies the ArrowOrgX dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ArrowOrgXProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Link.ArrowOrgXProperty
public static readonly DependencyProperty ArrowOrgXProperty
public: static readonly DependencyProperty* ArrowOrgXProperty
public:
static readonly DependencyProperty^ ArrowOrgXProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


ArrowOrgYProperty Field

Lassalle.Silverlight.Flow Namespace > Link Class : ArrowOrgYProperty Field
Identifies the ArrowOrgY dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ArrowOrgYProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Link.ArrowOrgYProperty
public static readonly DependencyProperty ArrowOrgYProperty
public: static readonly DependencyProperty* ArrowOrgYProperty
public:
static readonly DependencyProperty^ ArrowOrgYProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


DstProperty Field

Lassalle.Silverlight.Flow Namespace > Link Class : DstProperty Field
Identifies the Dst dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly DstProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Link.DstProperty
public static readonly DependencyProperty DstProperty
public: static readonly DependencyProperty* DstProperty
public:
static readonly DependencyProperty^ DstProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


HitPathGeometryProperty Field

Lassalle.Silverlight.Flow Namespace > Link Class : HitPathGeometryProperty Field
Identifies the HitPathGeometry dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly HitPathGeometryProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Link.HitPathGeometryProperty
public static readonly DependencyProperty HitPathGeometryProperty
public: static readonly DependencyProperty* HitPathGeometryProperty
public:
static readonly DependencyProperty^ HitPathGeometryProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


IsContextHandleProperty Field (Link)

Lassalle.Silverlight.Flow Namespace > Link Class : IsContextHandleProperty Field
Identifies the IsContextHandle dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly IsContextHandleProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Link.IsContextHandleProperty
public static readonly DependencyProperty IsContextHandleProperty
public: static readonly DependencyProperty* IsContextHandleProperty
public:
static readonly DependencyProperty^ IsContextHandleProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


IsSelectableProperty Field (Link)

Lassalle.Silverlight.Flow Namespace > Link Class : IsSelectableProperty Field
Identifies the IsSelectable dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly IsSelectableProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Link.IsSelectableProperty
public static readonly DependencyProperty IsSelectableProperty
public: static readonly DependencyProperty* IsSelectableProperty
public:
static readonly DependencyProperty^ IsSelectableProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


IsSelectedProperty Field (Link)

Lassalle.Silverlight.Flow Namespace > Link Class : IsSelectedProperty Field
Identifies the IsSelected dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly IsSelectedProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Link.IsSelectedProperty
public static readonly DependencyProperty IsSelectedProperty
public: static readonly DependencyProperty* IsSelectedProperty
public:
static readonly DependencyProperty^ IsSelectedProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


IsStretchableProperty Field

Lassalle.Silverlight.Flow Namespace > Link Class : IsStretchableProperty Field
Identifies the IsStretchable dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly IsStretchableProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Link.IsStretchableProperty
public static readonly DependencyProperty IsStretchableProperty
public: static readonly DependencyProperty* IsStretchableProperty
public:
static readonly DependencyProperty^ IsStretchableProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


JumpSizeProperty Field

Lassalle.Silverlight.Flow Namespace > Link Class : JumpSizeProperty Field
Identifies the JumpSize dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly JumpSizeProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Link.JumpSizeProperty
public static readonly DependencyProperty JumpSizeProperty
public: static readonly DependencyProperty* JumpSizeProperty
public:
static readonly DependencyProperty^ JumpSizeProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


LineStyleProperty Field

Lassalle.Silverlight.Flow Namespace > Link Class : LineStyleProperty Field
Identifies the LineStyle dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly LineStyleProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Link.LineStyleProperty
public static readonly DependencyProperty LineStyleProperty
public: static readonly DependencyProperty* LineStyleProperty
public:
static readonly DependencyProperty^ LineStyleProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


OrgProperty Field

Lassalle.Silverlight.Flow Namespace > Link Class : OrgProperty Field
Identifies the Org dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly OrgProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Link.OrgProperty
public static readonly DependencyProperty OrgProperty
public: static readonly DependencyProperty* OrgProperty
public:
static readonly DependencyProperty^ OrgProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


PathGeometryProperty Field

Lassalle.Silverlight.Flow Namespace > Link Class : PathGeometryProperty Field
Identifies the PathGeometry dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly PathGeometryProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Link.PathGeometryProperty
public static readonly DependencyProperty PathGeometryProperty
public: static readonly DependencyProperty* PathGeometryProperty
public:
static readonly DependencyProperty^ PathGeometryProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


PinDstProperty Field

Lassalle.Silverlight.Flow Namespace > Link Class : PinDstProperty Field
Identifies the PinDst dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly PinDstProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Link.PinDstProperty
public static readonly DependencyProperty PinDstProperty
public: static readonly DependencyProperty* PinDstProperty
public:
static readonly DependencyProperty^ PinDstProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


PinOrgProperty Field

Lassalle.Silverlight.Flow Namespace > Link Class : PinOrgProperty Field
Identifies the PinOrg dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly PinOrgProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Link.PinOrgProperty
public static readonly DependencyProperty PinOrgProperty
public: static readonly DependencyProperty* PinOrgProperty
public:
static readonly DependencyProperty^ PinOrgProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


PointsProperty Field

Lassalle.Silverlight.Flow Namespace > Link Class : PointsProperty Field
Identifies the Points dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly PointsProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Link.PointsProperty
public static readonly DependencyProperty PointsProperty
public: static readonly DependencyProperty* PointsProperty
public:
static readonly DependencyProperty^ PointsProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


RoundedCornerSizeProperty Field

Lassalle.Silverlight.Flow Namespace > Link Class : RoundedCornerSizeProperty Field
Identifies the RoundedCornerSize dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly RoundedCornerSizeProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Link.RoundedCornerSizeProperty
public static readonly DependencyProperty RoundedCornerSizeProperty
public: static readonly DependencyProperty* RoundedCornerSizeProperty
public:
static readonly DependencyProperty^ RoundedCornerSizeProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


StrokeDashArrayProperty Field

Lassalle.Silverlight.Flow Namespace > Link Class : StrokeDashArrayProperty Field
Identifies the StrokeDashArray dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly StrokeDashArrayProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Link.StrokeDashArrayProperty
public static readonly DependencyProperty StrokeDashArrayProperty
public: static readonly DependencyProperty* StrokeDashArrayProperty
public:
static readonly DependencyProperty^ StrokeDashArrayProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


StrokeProperty Field

Lassalle.Silverlight.Flow Namespace > Link Class : StrokeProperty Field
Identifies the Stroke dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly StrokeProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Link.StrokeProperty
public static readonly DependencyProperty StrokeProperty
public: static readonly DependencyProperty* StrokeProperty
public:
static readonly DependencyProperty^ StrokeProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


StrokeThicknessProperty Field

Lassalle.Silverlight.Flow Namespace > Link Class : StrokeThicknessProperty Field
Identifies the StrokeThickness dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly StrokeThicknessProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Link.StrokeThicknessProperty
public static readonly DependencyProperty StrokeThicknessProperty
public: static readonly DependencyProperty* StrokeThicknessProperty
public:
static readonly DependencyProperty^ StrokeThicknessProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


TextAngleModeProperty Field

Lassalle.Silverlight.Flow Namespace > Link Class : TextAngleModeProperty Field
Identifies the TextAngleMode dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly TextAngleModeProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Link.TextAngleModeProperty
public static readonly DependencyProperty TextAngleModeProperty
public: static readonly DependencyProperty* TextAngleModeProperty
public:
static readonly DependencyProperty^ TextAngleModeProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


TextPlacementModeProperty Field

Lassalle.Silverlight.Flow Namespace > Link Class : TextPlacementModeProperty Field
Identifies the TextPlacementMode dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly TextPlacementModeProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Link.TextPlacementModeProperty
public static readonly DependencyProperty TextPlacementModeProperty
public: static readonly DependencyProperty* TextPlacementModeProperty
public:
static readonly DependencyProperty^ TextPlacementModeProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


TextProperty Field (Link)

Lassalle.Silverlight.Flow Namespace > Link Class : TextProperty Field
Identifies the Text dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly TextProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Link.TextProperty
public static readonly DependencyProperty TextProperty
public: static readonly DependencyProperty* TextProperty
public:
static readonly DependencyProperty^ TextProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


TextXOffsetProperty Field

Lassalle.Silverlight.Flow Namespace > Link Class : TextXOffsetProperty Field
Identifies the TextXOffset dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly TextXOffsetProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Link.TextXOffsetProperty
public static readonly DependencyProperty TextXOffsetProperty
public: static readonly DependencyProperty* TextXOffsetProperty
public:
static readonly DependencyProperty^ TextXOffsetProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


TextXPositionProperty Field

Lassalle.Silverlight.Flow Namespace > Link Class : TextXPositionProperty Field
Identifies the TextXPosition dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly TextXPositionProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Link.TextXPositionProperty
public static readonly DependencyProperty TextXPositionProperty
public: static readonly DependencyProperty* TextXPositionProperty
public:
static readonly DependencyProperty^ TextXPositionProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


TextYOffsetProperty Field

Lassalle.Silverlight.Flow Namespace > Link Class : TextYOffsetProperty Field
Identifies the TextYOffset dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly TextYOffsetProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Link.TextYOffsetProperty
public static readonly DependencyProperty TextYOffsetProperty
public: static readonly DependencyProperty* TextYOffsetProperty
public:
static readonly DependencyProperty^ TextYOffsetProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


TextYPositionProperty Field

Lassalle.Silverlight.Flow Namespace > Link Class : TextYPositionProperty Field
Identifies the TextYPosition dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly TextYPositionProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Link.TextYPositionProperty
public static readonly DependencyProperty TextYPositionProperty
public: static readonly DependencyProperty* TextYPositionProperty
public:
static readonly DependencyProperty^ TextYPositionProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Link Class
Link Members


%%PageItemTitle%%

LinkCreatedEventArgs Class
Members

Lassalle.Silverlight.Flow Namespace : LinkCreatedEventArgs Class
Event parameters used for the LinkCreated event
Object Model
LinkCreatedEventArgs ClassLink Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class LinkCreatedEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As LinkCreatedEventArgs
public class LinkCreatedEventArgs : System.EventArgs
public __gc class LinkCreatedEventArgs : public System.EventArgs
public ref class LinkCreatedEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Lassalle.Silverlight.Flow.LinkCreatedEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LinkCreatedEventArgs Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Members$$

LinkCreatedEventArgs Class Members
Properties

Lassalle.Silverlight.Flow Namespace : LinkCreatedEventArgs Class

The following tables list the members exposed by LinkCreatedEventArgs.

Public Constructors
 | Name | Description
Public Constructor | LinkCreatedEventArgs Constructor | Constructor. Creates a new LinkCreatedEventArgs instance.
Top
Public Properties
 | Name | Description
Public Property | Link | The link that has just been created (read-only)
Top
See Also

Reference

LinkCreatedEventArgs Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

LinkCreatedEventArgs Constructor

Lassalle.Silverlight.Flow Namespace > LinkCreatedEventArgs Class : LinkCreatedEventArgs Constructor
The created link
Constructor. Creates a new LinkCreatedEventArgs instance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal link As Link _
)
'Usage

Dim link As Link

Dim instance As New LinkCreatedEventArgs(link)
public LinkCreatedEventArgs(
   Link link
)
public: LinkCreatedEventArgs(
   Link* link
)
public:
LinkCreatedEventArgs(
   Link^ link
)

Parameters

link
The created link
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LinkCreatedEventArgs Class
LinkCreatedEventArgs Members


%%PageItemTitle%% $$Properties$$

LinkCreatedEventArgs Class Properties

Lassalle.Silverlight.Flow Namespace : LinkCreatedEventArgs Class

For a list of all members of this type, see LinkCreatedEventArgs members.

Public Properties
 | Name | Description
Public Property | Link | The link that has just been created (read-only)
Top
See Also

Reference

LinkCreatedEventArgs Class
Lassalle.Silverlight.Flow Namespace


Link Property (LinkCreatedEventArgs)

Lassalle.Silverlight.Flow Namespace > LinkCreatedEventArgs Class : Link Property
The link that has just been created (read-only)
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Link As Link
'Usage

Dim instance As LinkCreatedEventArgs
Dim value As Link

value = instance.Link
public Link Link {get;}
public: __property Link* get_Link();
public:
property Link^ Link {
   Link^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LinkCreatedEventArgs Class
LinkCreatedEventArgs Members


%%PageItemTitle%%

LinkDeletedEventArgs Class
Members

Lassalle.Silverlight.Flow Namespace : LinkDeletedEventArgs Class
Event parameters used for the LinkDeleted event
Object Model
LinkDeletedEventArgs ClassLink Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class LinkDeletedEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As LinkDeletedEventArgs
public class LinkDeletedEventArgs : System.EventArgs
public __gc class LinkDeletedEventArgs : public System.EventArgs
public ref class LinkDeletedEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Lassalle.Silverlight.Flow.LinkDeletedEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LinkDeletedEventArgs Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Members$$

LinkDeletedEventArgs Class Members
Properties

Lassalle.Silverlight.Flow Namespace : LinkDeletedEventArgs Class

The following tables list the members exposed by LinkDeletedEventArgs.

Public Constructors
 | Name | Description
Public Constructor | LinkDeletedEventArgs Constructor | Constructor. Creates a new LinkDeletedEventArgs instance.
Top
Public Properties
 | Name | Description
Public Property | Link | The link that has just been removed (read-only)
Top
See Also

Reference

LinkDeletedEventArgs Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

LinkDeletedEventArgs Constructor

Lassalle.Silverlight.Flow Namespace > LinkDeletedEventArgs Class : LinkDeletedEventArgs Constructor
The removed link
Constructor. Creates a new LinkDeletedEventArgs instance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal link As Link _
)
'Usage

Dim link As Link

Dim instance As New LinkDeletedEventArgs(link)
public LinkDeletedEventArgs(
   Link link
)
public: LinkDeletedEventArgs(
   Link* link
)
public:
LinkDeletedEventArgs(
   Link^ link
)

Parameters

link
The removed link
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LinkDeletedEventArgs Class
LinkDeletedEventArgs Members


%%PageItemTitle%% $$Properties$$

LinkDeletedEventArgs Class Properties

Lassalle.Silverlight.Flow Namespace : LinkDeletedEventArgs Class

For a list of all members of this type, see LinkDeletedEventArgs members.

Public Properties
 | Name | Description
Public Property | Link | The link that has just been removed (read-only)
Top
See Also

Reference

LinkDeletedEventArgs Class
Lassalle.Silverlight.Flow Namespace


Link Property (LinkDeletedEventArgs)

Lassalle.Silverlight.Flow Namespace > LinkDeletedEventArgs Class : Link Property
The link that has just been removed (read-only)
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Link As Link
'Usage

Dim instance As LinkDeletedEventArgs
Dim value As Link

value = instance.Link
public Link Link {get;}
public: __property Link* get_Link();
public:
property Link^ Link {
   Link^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LinkDeletedEventArgs Class
LinkDeletedEventArgs Members


%%PageItemTitle%%

Node Class
Members

Lassalle.Silverlight.Flow Namespace : Node Class
Represents a node (also called vertice or entity) in the this.Diagram.
Object Model
Node ClassAddFlow ClassConnector Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<TemplateVisualStateAttribute(Name="Pressed", GroupName="CommonStates")>
<TemplatePartAttribute(Name="Image", Type=System.Windows.Controls.Image)>
<TemplatePartAttribute(Name="Connector", Type=System.Windows.Controls.ContentControl)>
<TemplatePartAttribute(Name="Text", Type=System.Windows.Controls.TextBlock)>
<DesignTimeVisibleAttribute()>
<TemplatePartAttribute(Name="InPlaceTextBox", Type=System.Windows.Controls.TextBox)>
<TemplateVisualStateAttribute(Name="Normal", GroupName="CommonStates")>
<TemplateVisualStateAttribute(Name="MouseOver", GroupName="CommonStates")>
<TemplateVisualStateAttribute(Name="MouseOverUnlinkableNode", GroupName="CommonStates")>
<TemplateVisualStateAttribute(Name="PressedUnlinkableNode", GroupName="CommonStates")>
<TemplatePartAttribute(Name="Root", Type=System.Windows.FrameworkElement)>
<TemplatePartAttribute(Name="Content", Type=System.Windows.Controls.ContentControl)>
Public Class Node
   Inherits System.Windows.Controls.ContentControl
   Implements IHasContext, IMoveable, ISelectable
'Usage

Dim instance As Node
[TemplateVisualStateAttribute(Name="Pressed", GroupName="CommonStates")]
[TemplatePartAttribute(Name="Image", Type=System.Windows.Controls.Image)]
[TemplatePartAttribute(Name="Connector", Type=System.Windows.Controls.ContentControl)]
[TemplatePartAttribute(Name="Text", Type=System.Windows.Controls.TextBlock)]
[DesignTimeVisibleAttribute()]
[TemplatePartAttribute(Name="InPlaceTextBox", Type=System.Windows.Controls.TextBox)]
[TemplateVisualStateAttribute(Name="Normal", GroupName="CommonStates")]
[TemplateVisualStateAttribute(Name="MouseOver", GroupName="CommonStates")]
[TemplateVisualStateAttribute(Name="MouseOverUnlinkableNode", GroupName="CommonStates")]
[TemplateVisualStateAttribute(Name="PressedUnlinkableNode", GroupName="CommonStates")]
[TemplatePartAttribute(Name="Root", Type=System.Windows.FrameworkElement)]
[TemplatePartAttribute(Name="Content", Type=System.Windows.Controls.ContentControl)]
public class Node : System.Windows.Controls.ContentControl, IHasContext, IMoveable, ISelectable
[TemplateVisualStateAttribute(Name="Pressed", GroupName="CommonStates")]
[TemplatePartAttribute(Name="Image", Type=System.Windows.Controls.Image)]
[TemplatePartAttribute(Name="Connector", Type=System.Windows.Controls.ContentControl)]
[TemplatePartAttribute(Name="Text", Type=System.Windows.Controls.TextBlock)]
[DesignTimeVisibleAttribute()]
[TemplatePartAttribute(Name="InPlaceTextBox", Type=System.Windows.Controls.TextBox)]
[TemplateVisualStateAttribute(Name="Normal", GroupName="CommonStates")]
[TemplateVisualStateAttribute(Name="MouseOver", GroupName="CommonStates")]
[TemplateVisualStateAttribute(Name="MouseOverUnlinkableNode", GroupName="CommonStates")]
[TemplateVisualStateAttribute(Name="PressedUnlinkableNode", GroupName="CommonStates")]
[TemplatePartAttribute(Name="Root", Type=System.Windows.FrameworkElement)]
[TemplatePartAttribute(Name="Content", Type=System.Windows.Controls.ContentControl)]
public __gc class Node : public System.Windows.Controls.ContentControl, IHasContext, IMoveable, ISelectable
[TemplateVisualStateAttribute(Name="Pressed", GroupName="CommonStates")]
[TemplatePartAttribute(Name="Image", Type=System.Windows.Controls.Image)]
[TemplatePartAttribute(Name="Connector", Type=System.Windows.Controls.ContentControl)]
[TemplatePartAttribute(Name="Text", Type=System.Windows.Controls.TextBlock)]
[DesignTimeVisibleAttribute()]
[TemplatePartAttribute(Name="InPlaceTextBox", Type=System.Windows.Controls.TextBox)]
[TemplateVisualStateAttribute(Name="Normal", GroupName="CommonStates")]
[TemplateVisualStateAttribute(Name="MouseOver", GroupName="CommonStates")]
[TemplateVisualStateAttribute(Name="MouseOverUnlinkableNode", GroupName="CommonStates")]
[TemplateVisualStateAttribute(Name="PressedUnlinkableNode", GroupName="CommonStates")]
[TemplatePartAttribute(Name="Root", Type=System.Windows.FrameworkElement)]
[TemplatePartAttribute(Name="Content", Type=System.Windows.Controls.ContentControl)]
public ref class Node : public System.Windows.Controls.ContentControl, IHasContext, IMoveable, ISelectable
Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
Lassalle.Silverlight.Flow.Node

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Members$$

Node Class Members
Fields Properties Methods Events

Lassalle.Silverlight.Flow Namespace : Node Class

The following tables list the members exposed by Node.

Public Constructors
 | Name | Description
Public Constructor | Node Constructor | Overloaded.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | ImageHorizontalAlignmentProperty | Identifies the ImageHorizontalAlignment dependency property
static (Shared in Visual Basic) | ImageUriProperty | Identifies the ImageUri dependency property
static (Shared in Visual Basic) | ImageVerticalAlignmentProperty | Identifies the ImageVerticalAlignment dependency property
static (Shared in Visual Basic) | InConnectionModeProperty | Identifies the InConnectionMode dependency property
static (Shared in Visual Basic) | IsContextHandleProperty | Identifies the IsContextHandle dependency property
static (Shared in Visual Basic) | IsEditableProperty | Identifies the IsEditable dependency property.
static (Shared in Visual Basic) | IsInEditModeProperty | Identifies the IsInEditMode dependency property
static (Shared in Visual Basic) | IsInLinkableProperty | Identifies the IsInLinkable dependency property
static (Shared in Visual Basic) | IsLinkingOverProperty | Identifies the IsLinkingOver dependency property
static (Shared in Visual Basic) | IsOutLinkableProperty | Identifies the IsOutLinkable dependency property
static (Shared in Visual Basic) | IsRotatableProperty | Identifies the IsRotatable dependency property
static (Shared in Visual Basic) | IsSelectableProperty | Identifies the IsSelectable dependency property
static (Shared in Visual Basic) | IsSelectedProperty | Identifies the IsSelected dependency property
static (Shared in Visual Basic) | IsXMoveableProperty | Identifies the IsXMoveable dependency property
static (Shared in Visual Basic) | IsXSizeableProperty | Identifies the IsXSizeable dependency property
static (Shared in Visual Basic) | IsYMoveableProperty | Identifies the IsYMoveable dependency property
static (Shared in Visual Basic) | IsYSizeableProperty | Identifies the IsYSizeable dependency property
static (Shared in Visual Basic) | OutConnectionModeProperty | Identifies the OutConnectionMode dependency property
static (Shared in Visual Basic) | TextHorizontalAlignmentProperty | Identifies the TextHorizontalAlignment dependency property
static (Shared in Visual Basic) | TextProperty | Identifies the Text dependency property
static (Shared in Visual Basic) | TextVerticalAlignmentProperty | Identifies the TextVerticalAlignment dependency property
Top
Public Properties
 | Name | Description
Public Property | ActualHeight | Gets the rendered height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | Gets the rendered width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | AddFlow | The addflow canvas containing this link
Public Property | AllowDrop | Gets or sets a value that determines whether this System.Windows.UIElement can be a drop target for purposes of Silverlight drag-and-drop operations. (Inherited from System.Windows.UIElement)
Public Property | Background | Gets or sets a brush that provides the background of the control. (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from System.Windows.Controls.Control)
Public Property | CacheMode | Gets or sets a value that indicates that rendered content should be cached when possible. (Inherited from System.Windows.UIElement)
Public Property | CharacterSpacing | Gets or sets the distance between characters of text in the control measured in 1000ths of the font size. (Inherited from System.Windows.Controls.Control)
Public Property | Clip | Gets or sets the System.Windows.Media.Geometry used to define the outline of the contents of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | Connector | Returns the Connector of the node.
Public Property | Content | Gets or sets the value of the System.Windows.Controls.ContentControl dependency property. (Inherited from System.Windows.Controls.ContentControl)
Public Property | ContentTemplate | Gets or sets the data template that is used to display the content of the System.Windows.Controls.ContentControl. (Inherited from System.Windows.Controls.ContentControl)
Public Property | Cursor | Gets or sets the cursor image that displays while the mouse pointer is over a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | Gets or sets the data context for a System.Windows.FrameworkElement when it participates in data binding. (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | Gets the size that this System.Windows.UIElement computed during the measure pass of the layout process. (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | Gets the System.Windows.Threading.Dispatcher this object is associated with. (Inherited from System.Windows.DependencyObject)
Public Property | Effect | Gets or sets the pixel shader effect to use for rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | FlowDirection | Gets or sets the direction that text and other user interface elements flow within any parent element that controls their layout. (Inherited from System.Windows.FrameworkElement)
Public Property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | Gets or sets the size of the text in this control. (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from System.Windows.Controls.Control)
Public Property | Height | Gets or sets the suggested height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | Image | Returns the Image of the node.
Public Property | ImageHorizontalAlignment | Sets or returns the horizontal alignment of the image associated with the node.
Public Property | ImageUri | Sets or returns the uri of the image associated with the node.
Public Property | ImageVerticalAlignment | Sets or returns the vertical alignment of the image associated with the node.
Public Property | InConnectionMode | Indicates how a coming link is connected to the destination node
Public Property | IsContextHandle | Determines whether the node has a context handle.
Public Property | IsEditable | Gets or sets a value indicating whether the label text of the node can be edited.
Public Property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | Gets or sets whether the contained area of this System.Windows.UIElement can return true values for hit testing. (Inherited from System.Windows.UIElement)
Public Property | IsInEditMode | Determines if the node is in edition mode
Public Property | IsInLinkable | Determines whether the node accept incoming links.
Public Property | IsLinkingOver | If True, this property indicates that, during the creation of a link, the mouse is over this node which therefore may be the destination of that link.
Public Property | IsOutLinkable | Determines whether the node accept outgoing links.
Public Property | IsRotatable | Determines whether the node can be rotated.
Public Property | IsSelectable | Determines whether the node is selectable by clicking on it with the mouse or unselectable (readonly or inactive).
Public Property | IsSelected | Determines if the node is selected or not.
Public Property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from System.Windows.Controls.Control)
Public Property | IsXMoveable | Determines whether the node can be horizontally moved or not.
Public Property | IsXSizeable | Determines whether the node can be horizontally resized or not.
Public Property | IsYMoveable | Determines whether the node can be vertically moved or not.
Public Property | IsYSizeable | Determines whether the node can be vertically resized or not.
Public Property | Language | Gets or sets localization/globalization language information that applies to a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | Links | Returns the collection of the links attached to this node.
Public Property | Location | Returns/sets the position of a node.
Public Property | Margin | Gets or sets the outer margin of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | Gets or sets the maximum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | Gets or sets the maximum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | Gets or sets the minimum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | Gets or sets the minimum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | Gets or sets the brush used to alter the opacity of regions of this object. (Inherited from System.Windows.UIElement)
Public Property | OutConnectionMode | Indicates how a leaving link is connected to the origin node
Public Property | Padding | Gets or sets the padding inside a control. (Inherited from System.Windows.Controls.Control)
Public Property | Parent | Gets the parent object of this System.Windows.FrameworkElement in the object tree. (Inherited from System.Windows.FrameworkElement)
Public Property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderSize | Gets the final render size of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | Gets or sets transform information that affects the rendering position of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by System.Windows.UIElement.RenderTransform, relative to the bounds of the System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from System.Windows.FrameworkElement)
Public Property | RotationAngle | Returns/sets the rotation angle of a node.
Public Property | Size | Returns/sets the size of a node.
Public Property | Style | Gets or sets an instance System.Windows.Style that is applied for this object during rendering. (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | Gets or sets a value that modifies how tabbing and System.Windows.Controls.Control.TabIndex work for this control. (Inherited from System.Windows.Controls.Control)
Public Property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from System.Windows.FrameworkElement)
Public Property | Template | Gets or sets a control template. (Inherited from System.Windows.Controls.Control)
Public Property | Text | Sets or returns the text associated with the node.
Public Property | TextBlock | Sets or returns the TextBlock associated with the node and used to display the node label
Public Property | TextHorizontalAlignment | Sets or returns the horizontal alignment of the text associated with the node.
Public Property | TextVerticalAlignment | Sets or returns the vertical alignment of the text associated with the node.
Public Property | Triggers | Gets the collection of triggers for animations that are defined for a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from System.Windows.UIElement)
Public Property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | Gets or sets the visibility of a System.Windows.UIElement. A System.Windows.UIElement that is not visible does not render and does not communicate its desired size to layout. (Inherited from System.Windows.UIElement)
Public Property | Width | Gets or sets the width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Top
Protected Properties
 | Name | Description
Protected Property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from System.Windows.Controls.Control)
Top
Public Methods
 | Name | Description
Public Method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from System.Windows.UIElement)
Public Method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from System.Windows.Controls.Control)
Public Method | Arrange | Positions child objects and determines a size for a System.Windows.UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | BeginEdit | Initiates the editing of the node label.
Public Method | CancelEdit | Cancels the editing of the node label.
Public Method | CaptureMouse | Sets mouse capture to a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | ClearValue | Clears the local value of a dependency property. (Inherited from System.Windows.DependencyObject)
Public Method | EndEdit | Ends the editing of the node label.
Public Method | FindName | Retrieves an object that has the specified identifier name. (Inherited from System.Windows.FrameworkElement)
Public Method | Focus | Attempts to set the focus on the control. (Inherited from System.Windows.Controls.Control)
Public Method | GetAnimationBaseValue | Returns any base value established for a Silverlight dependency property, which would apply in cases where an animation is not active. (Inherited from System.Windows.DependencyObject)
Public Method | GetBindingExpression | Retrieves the System.Windows.Data.BindingExpression for a dependency property where a binding is established. (Inherited from System.Windows.FrameworkElement)
Public Method | GetValue | Returns the current effective value of a dependency property from a System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateArrange | Invalidates the arrange state (layout) for a System.Windows.UIElement. After the invalidation, the System.Windows.UIElement will have its layout updated, which will occur asynchronously. (Inherited from System.Windows.UIElement)
Public Method | InvalidateMeasure | Invalidates the measurement state (layout) for a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | Measure | Updates the System.Windows.UIElement.DesiredSize of a System.Windows.UIElement. Typically, objects that implement custom layout for their layout children call this method from their own System.Windows.FrameworkElement.MeasureOverride(System.Windows.Size) implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | OnApplyTemplate | Overridden. Loads the node template so that its parts can be referenced.
Public Method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from System.Windows.DependencyObject)
Public Method | ReleaseMouseCapture | Removes mouse capture from a System.Windows.UIElement. After this call, typically no object holds mouse capture. (Inherited from System.Windows.UIElement)
Public Method | RemoveHandler | Removes the specified routed event handler from this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | SetBinding | Attaches a binding to a System.Windows.FrameworkElement, using the provided binding object, and returns a System.Windows.Data.BindingExpressionBase for possible later use. (Inherited from System.Windows.FrameworkElement)
Public Method | SetValue | (Inherited from System.Windows.DependencyObject)
Public Method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the System.Windows.UIElement to the specified object. (Inherited from System.Windows.UIElement)
Public Method | UpdateLayout | Ensures that all positions of child objects of a System.Windows.UIElement are properly updated for layout. (Inherited from System.Windows.UIElement)
Top
Protected Methods
 | Name | Description
Protected Method | ArrangeOverride | (Inherited from System.Windows.FrameworkElement)
Protected Method | GetTemplateChild | Retrieves the named element in the instantiated System.Windows.Controls.ControlTemplate visual tree. (Inherited from System.Windows.Controls.Control)
Protected Method | MeasureOverride | (Inherited from System.Windows.FrameworkElement)
Protected Method | OnContentChanged | (Inherited from System.Windows.Controls.ContentControl)
Protected Method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific System.Windows.Automation.Peers.AutomationPeer implementations for the Silverlight automation infrastructure. (Inherited from System.Windows.UIElement)
Protected Method | OnDragEnter | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDragLeave | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDragOver | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDrop | (Inherited from System.Windows.Controls.Control)
Protected Method | OnGotFocus | (Inherited from System.Windows.Controls.Control)
Protected Method | OnKeyDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnKeyUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnLostFocus | (Inherited from System.Windows.Controls.Control)
Protected Method | OnLostMouseCapture | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseEnter | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeave | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeftButtonDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeftButtonUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseMove | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseRightButtonDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseRightButtonUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseWheel | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInput | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInputStart | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInputUpdate | (Inherited from System.Windows.Controls.Control)
Top
Public Events
 | Name | Description
Public Event | BindingValidationError | Occurs when a data validation error is reported by a binding source. (Inherited from System.Windows.FrameworkElement)
Public Event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from System.Windows.FrameworkElement)
Public Event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from System.Windows.UIElement)
Public Event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from System.Windows.UIElement)
Public Event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from System.Windows.UIElement)
Public Event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from System.Windows.UIElement)
Public Event | GotFocus | Occurs when a System.Windows.UIElement receives focus. (Inherited from System.Windows.UIElement)
Public Event | IsEnabledChanged | Occurs when the System.Windows.Controls.Control.IsEnabled property changes. (Inherited from System.Windows.Controls.Control)
Public Event | KeyDown | Occurs when a keyboard key is pressed while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | KeyUp | Occurs when a keyboard key is released while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | Occurs when the layout of the Silverlight visual tree changes. (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | Occurs when a System.Windows.FrameworkElement has been constructed and added to the object tree. (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | Occurs when a System.Windows.UIElement loses focus. (Inherited from System.Windows.UIElement)
Public Event | LostMouseCapture | Occurs when the System.Windows.UIElement loses mouse capture. (Inherited from System.Windows.UIElement)
Public Event | MediaCommand | Occurs when a button is pressed on a remote control. (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | Occurs when the mouse (or a stylus) enters the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | Occurs when the mouse (or the stylus) leaves the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | Occurs when the left mouse button is pressed (or when the tip of the stylus touches the tablet) while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | Occurs when the left mouse button is released (or the tip of the stylus is removed from the tablet) while the mouse (or the stylus) is over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseMove | Occurs when the coordinate position of the mouse (or stylus) changes while over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over a System.Windows.UIElement. However, this event will only be raised if a caller marks the preceding System.Windows.UIElement.MouseRightButtonDown event as handled; see Remarks. (Inherited from System.Windows.UIElement)
Public Event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over a System.Windows.UIElement, or the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | Occurs when either the System.Windows.FrameworkElement.ActualHeight or the System.Windows.FrameworkElement.ActualWidth properties change value on a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Event | TextInput | Occurs when a UI element gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputStart | Occurs when a UI element initially gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputUpdate | Occurs when text continues to be composed via an input method editor (IME). (Inherited from System.Windows.UIElement)
Public Event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from System.Windows.FrameworkElement)
Top
See Also

Reference

Node Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

Node Constructor

Lassalle.Silverlight.Flow Namespace > Node Class : Node Constructor
Overload List
Overload | Description
Node Constructor() | Node constructor
Node Constructor(Double,Double,Double,Double) | Initializes a new instance of the Node class with an initial position and size.
Node Constructor(Double,Double,Double,Double,String) | Initializes a new instance of the Node class with an initial position and size, an initial text.
Node Constructor(Double,Double,Double,Double,String,Object) | Initializes a new instance of the Node class with an initial position and size, an initial text.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


%%PageItemTitle%%

Node Constructor()

Lassalle.Silverlight.Flow Namespace > Node Class > Node Constructor : Node Constructor()
Node constructor
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New Node()
public Node()
public: Node();
public:
Node();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members
Overload List


%%PageItemTitle%%

Node Constructor(Double,Double,Double,Double)

Lassalle.Silverlight.Flow Namespace > Node Class > Node Constructor : Node Constructor(Double,Double,Double,Double)
The x-coordinate of the node position
The y-coordinate of the node position
The horizontal size of the node
The vertical size of the node
Initializes a new instance of the Node class with an initial position and size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
'Usage

Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double

Dim instance As New Node(left, top, width, height)
public Node(
   double left,
   double top,
   double width,
   double height
)
public: Node(
   double left,
   double top,
   double width,
   double height
)
public:
Node(
   double left,
   double top,
   double width,
   double height
)

Parameters

left
The x-coordinate of the node position
top
The y-coordinate of the node position
width
The horizontal size of the node
height
The vertical size of the node
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members
Overload List


%%PageItemTitle%%

Node Constructor(Double,Double,Double,Double,String)

Lassalle.Silverlight.Flow Namespace > Node Class > Node Constructor : Node Constructor(Double,Double,Double,Double,String)
The x-coordinate of the node position
The y-coordinate of the node position
The horizontal size of the node
The vertical size of the node
The text displayed in the node
Initializes a new instance of the Node class with an initial position and size, an initial text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal text As String _
)
'Usage

Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim text As String

Dim instance As New Node(left, top, width, height, text)
public Node(
   double left,
   double top,
   double width,
   double height,
   string text
)
public: Node(
   double left,
   double top,
   double width,
   double height,
   string* text
)
public:
Node(
   double left,
   double top,
   double width,
   double height,
   String^ text
)

Parameters

left
The x-coordinate of the node position
top
The y-coordinate of the node position
width
The horizontal size of the node
height
The vertical size of the node
text
The text displayed in the node
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members
Overload List


%%PageItemTitle%%

Node Constructor(Double,Double,Double,Double,String,Object)

Lassalle.Silverlight.Flow Namespace > Node Class > Node Constructor : Node Constructor(Double,Double,Double,Double,String,Object)
The x-coordinate of the node position
The y-coordinate of the node position
The horizontal size of the node
The vertical size of the node
The text displayed in the node
The node content
Initializes a new instance of the Node class with an initial position and size, an initial text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal text As String, _
   ByVal content As Object _
)
'Usage

Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim text As String
Dim content As Object

Dim instance As New Node(left, top, width, height, text, content)
public Node(
   double left,
   double top,
   double width,
   double height,
   string text,
   object content
)
public: Node(
   double left,
   double top,
   double width,
   double height,
   string* text,
   Object* content
)
public:
Node(
   double left,
   double top,
   double width,
   double height,
   String^ text,
   Object^ content
)

Parameters

left
The x-coordinate of the node position
top
The y-coordinate of the node position
width
The horizontal size of the node
height
The vertical size of the node
text
The text displayed in the node
content
The node content
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members
Overload List


%%PageItemTitle%% $$Methods$$

Node Class Methods

Lassalle.Silverlight.Flow Namespace : Node Class

For a list of all members of this type, see Node members.

Public Methods
 | Name | Description
Public Method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from System.Windows.UIElement)
Public Method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from System.Windows.Controls.Control)
Public Method | Arrange | Positions child objects and determines a size for a System.Windows.UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | BeginEdit | Initiates the editing of the node label.
Public Method | CancelEdit | Cancels the editing of the node label.
Public Method | CaptureMouse | Sets mouse capture to a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | ClearValue | Clears the local value of a dependency property. (Inherited from System.Windows.DependencyObject)
Public Method | EndEdit | Ends the editing of the node label.
Public Method | FindName | Retrieves an object that has the specified identifier name. (Inherited from System.Windows.FrameworkElement)
Public Method | Focus | Attempts to set the focus on the control. (Inherited from System.Windows.Controls.Control)
Public Method | GetAnimationBaseValue | Returns any base value established for a Silverlight dependency property, which would apply in cases where an animation is not active. (Inherited from System.Windows.DependencyObject)
Public Method | GetBindingExpression | Retrieves the System.Windows.Data.BindingExpression for a dependency property where a binding is established. (Inherited from System.Windows.FrameworkElement)
Public Method | GetValue | Returns the current effective value of a dependency property from a System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateArrange | Invalidates the arrange state (layout) for a System.Windows.UIElement. After the invalidation, the System.Windows.UIElement will have its layout updated, which will occur asynchronously. (Inherited from System.Windows.UIElement)
Public Method | InvalidateMeasure | Invalidates the measurement state (layout) for a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | Measure | Updates the System.Windows.UIElement.DesiredSize of a System.Windows.UIElement. Typically, objects that implement custom layout for their layout children call this method from their own System.Windows.FrameworkElement.MeasureOverride(System.Windows.Size) implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | OnApplyTemplate | Overridden. Loads the node template so that its parts can be referenced.
Public Method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from System.Windows.DependencyObject)
Public Method | ReleaseMouseCapture | Removes mouse capture from a System.Windows.UIElement. After this call, typically no object holds mouse capture. (Inherited from System.Windows.UIElement)
Public Method | RemoveHandler | Removes the specified routed event handler from this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | SetBinding | Attaches a binding to a System.Windows.FrameworkElement, using the provided binding object, and returns a System.Windows.Data.BindingExpressionBase for possible later use. (Inherited from System.Windows.FrameworkElement)
Public Method | SetValue | (Inherited from System.Windows.DependencyObject)
Public Method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the System.Windows.UIElement to the specified object. (Inherited from System.Windows.UIElement)
Public Method | UpdateLayout | Ensures that all positions of child objects of a System.Windows.UIElement are properly updated for layout. (Inherited from System.Windows.UIElement)
Top
Protected Methods
 | Name | Description
Protected Method | ArrangeOverride | (Inherited from System.Windows.FrameworkElement)
Protected Method | GetTemplateChild | Retrieves the named element in the instantiated System.Windows.Controls.ControlTemplate visual tree. (Inherited from System.Windows.Controls.Control)
Protected Method | MeasureOverride | (Inherited from System.Windows.FrameworkElement)
Protected Method | OnContentChanged | (Inherited from System.Windows.Controls.ContentControl)
Protected Method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific System.Windows.Automation.Peers.AutomationPeer implementations for the Silverlight automation infrastructure. (Inherited from System.Windows.UIElement)
Protected Method | OnDragEnter | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDragLeave | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDragOver | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDrop | (Inherited from System.Windows.Controls.Control)
Protected Method | OnGotFocus | (Inherited from System.Windows.Controls.Control)
Protected Method | OnKeyDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnKeyUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnLostFocus | (Inherited from System.Windows.Controls.Control)
Protected Method | OnLostMouseCapture | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseEnter | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeave | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeftButtonDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeftButtonUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseMove | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseRightButtonDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseRightButtonUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseWheel | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInput | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInputStart | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInputUpdate | (Inherited from System.Windows.Controls.Control)
Top
See Also

Reference

Node Class
Lassalle.Silverlight.Flow Namespace


BeginEdit Method

Lassalle.Silverlight.Flow Namespace > Node Class : BeginEdit Method
Initiates the editing of the node label.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub BeginEdit()
'Usage

Dim instance As Node

instance.BeginEdit()
public void BeginEdit()
public: void BeginEdit();
public:
void BeginEdit();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


CancelEdit Method

Lassalle.Silverlight.Flow Namespace > Node Class : CancelEdit Method
Cancels the editing of the node label.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub CancelEdit()
'Usage

Dim instance As Node

instance.CancelEdit()
public void CancelEdit()
public: void CancelEdit();
public:
void CancelEdit();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


EndEdit Method

Lassalle.Silverlight.Flow Namespace > Node Class : EndEdit Method
Ends the editing of the node label.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub EndEdit()
'Usage

Dim instance As Node

instance.EndEdit()
public void EndEdit()
public: void EndEdit();
public:
void EndEdit();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


OnApplyTemplate Method (Node)

Lassalle.Silverlight.Flow Namespace > Node Class : OnApplyTemplate Method
Loads the node template so that its parts can be referenced.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub OnApplyTemplate()
'Usage

Dim instance As Node

instance.OnApplyTemplate()
public override void OnApplyTemplate()
public: void OnApplyTemplate(); override
public:
void OnApplyTemplate(); override
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


%%PageItemTitle%% $$Properties$$

Node Class Properties

Lassalle.Silverlight.Flow Namespace : Node Class

For a list of all members of this type, see Node members.

Public Properties
 | Name | Description
Public Property | ActualHeight | Gets the rendered height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | Gets the rendered width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | AddFlow | The addflow canvas containing this link
Public Property | AllowDrop | Gets or sets a value that determines whether this System.Windows.UIElement can be a drop target for purposes of Silverlight drag-and-drop operations. (Inherited from System.Windows.UIElement)
Public Property | Background | Gets or sets a brush that provides the background of the control. (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from System.Windows.Controls.Control)
Public Property | CacheMode | Gets or sets a value that indicates that rendered content should be cached when possible. (Inherited from System.Windows.UIElement)
Public Property | CharacterSpacing | Gets or sets the distance between characters of text in the control measured in 1000ths of the font size. (Inherited from System.Windows.Controls.Control)
Public Property | Clip | Gets or sets the System.Windows.Media.Geometry used to define the outline of the contents of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | Connector | Returns the Connector of the node.
Public Property | Content | Gets or sets the value of the System.Windows.Controls.ContentControl dependency property. (Inherited from System.Windows.Controls.ContentControl)
Public Property | ContentTemplate | Gets or sets the data template that is used to display the content of the System.Windows.Controls.ContentControl. (Inherited from System.Windows.Controls.ContentControl)
Public Property | Cursor | Gets or sets the cursor image that displays while the mouse pointer is over a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | Gets or sets the data context for a System.Windows.FrameworkElement when it participates in data binding. (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | Gets the size that this System.Windows.UIElement computed during the measure pass of the layout process. (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | Gets the System.Windows.Threading.Dispatcher this object is associated with. (Inherited from System.Windows.DependencyObject)
Public Property | Effect | Gets or sets the pixel shader effect to use for rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | FlowDirection | Gets or sets the direction that text and other user interface elements flow within any parent element that controls their layout. (Inherited from System.Windows.FrameworkElement)
Public Property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | Gets or sets the size of the text in this control. (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from System.Windows.Controls.Control)
Public Property | Height | Gets or sets the suggested height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | Image | Returns the Image of the node.
Public Property | ImageHorizontalAlignment | Sets or returns the horizontal alignment of the image associated with the node.
Public Property | ImageUri | Sets or returns the uri of the image associated with the node.
Public Property | ImageVerticalAlignment | Sets or returns the vertical alignment of the image associated with the node.
Public Property | InConnectionMode | Indicates how a coming link is connected to the destination node
Public Property | IsContextHandle | Determines whether the node has a context handle.
Public Property | IsEditable | Gets or sets a value indicating whether the label text of the node can be edited.
Public Property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | Gets or sets whether the contained area of this System.Windows.UIElement can return true values for hit testing. (Inherited from System.Windows.UIElement)
Public Property | IsInEditMode | Determines if the node is in edition mode
Public Property | IsInLinkable | Determines whether the node accept incoming links.
Public Property | IsLinkingOver | If True, this property indicates that, during the creation of a link, the mouse is over this node which therefore may be the destination of that link.
Public Property | IsOutLinkable | Determines whether the node accept outgoing links.
Public Property | IsRotatable | Determines whether the node can be rotated.
Public Property | IsSelectable | Determines whether the node is selectable by clicking on it with the mouse or unselectable (readonly or inactive).
Public Property | IsSelected | Determines if the node is selected or not.
Public Property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from System.Windows.Controls.Control)
Public Property | IsXMoveable | Determines whether the node can be horizontally moved or not.
Public Property | IsXSizeable | Determines whether the node can be horizontally resized or not.
Public Property | IsYMoveable | Determines whether the node can be vertically moved or not.
Public Property | IsYSizeable | Determines whether the node can be vertically resized or not.
Public Property | Language | Gets or sets localization/globalization language information that applies to a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | Links | Returns the collection of the links attached to this node.
Public Property | Location | Returns/sets the position of a node.
Public Property | Margin | Gets or sets the outer margin of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | Gets or sets the maximum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | Gets or sets the maximum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | Gets or sets the minimum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | Gets or sets the minimum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | Gets or sets the brush used to alter the opacity of regions of this object. (Inherited from System.Windows.UIElement)
Public Property | OutConnectionMode | Indicates how a leaving link is connected to the origin node
Public Property | Padding | Gets or sets the padding inside a control. (Inherited from System.Windows.Controls.Control)
Public Property | Parent | Gets the parent object of this System.Windows.FrameworkElement in the object tree. (Inherited from System.Windows.FrameworkElement)
Public Property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderSize | Gets the final render size of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | Gets or sets transform information that affects the rendering position of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by System.Windows.UIElement.RenderTransform, relative to the bounds of the System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from System.Windows.FrameworkElement)
Public Property | RotationAngle | Returns/sets the rotation angle of a node.
Public Property | Size | Returns/sets the size of a node.
Public Property | Style | Gets or sets an instance System.Windows.Style that is applied for this object during rendering. (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | Gets or sets a value that modifies how tabbing and System.Windows.Controls.Control.TabIndex work for this control. (Inherited from System.Windows.Controls.Control)
Public Property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from System.Windows.FrameworkElement)
Public Property | Template | Gets or sets a control template. (Inherited from System.Windows.Controls.Control)
Public Property | Text | Sets or returns the text associated with the node.
Public Property | TextBlock | Sets or returns the TextBlock associated with the node and used to display the node label
Public Property | TextHorizontalAlignment | Sets or returns the horizontal alignment of the text associated with the node.
Public Property | TextVerticalAlignment | Sets or returns the vertical alignment of the text associated with the node.
Public Property | Triggers | Gets the collection of triggers for animations that are defined for a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from System.Windows.UIElement)
Public Property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | Gets or sets the visibility of a System.Windows.UIElement. A System.Windows.UIElement that is not visible does not render and does not communicate its desired size to layout. (Inherited from System.Windows.UIElement)
Public Property | Width | Gets or sets the width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Top
Protected Properties
 | Name | Description
Protected Property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from System.Windows.Controls.Control)
Top
See Also

Reference

Node Class
Lassalle.Silverlight.Flow Namespace


AddFlow Property (Node)

Lassalle.Silverlight.Flow Namespace > Node Class : AddFlow Property
The addflow canvas containing this link
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property AddFlow As AddFlow
'Usage

Dim instance As Node
Dim value As AddFlow

value = instance.AddFlow
public AddFlow AddFlow {get;}
public: __property AddFlow* get_AddFlow();
public:
property AddFlow^ AddFlow {
   AddFlow^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


Connector Property

Lassalle.Silverlight.Flow Namespace > Node Class : Connector Property
Returns the Connector of the node.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Connector As Connector
'Usage

Dim instance As Node
Dim value As Connector

value = instance.Connector
public Connector Connector {get;}
public: __property Connector* get_Connector();
public:
property Connector^ Connector {
   Connector^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


Image Property (Node)

Lassalle.Silverlight.Flow Namespace > Node Class : Image Property
Returns the Image of the node.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Image As Image
'Usage

Dim instance As Node
Dim value As Image

value = instance.Image
public Image Image {get;}
public: __property Image* get_Image();
public:
property Image^ Image {
   Image^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


ImageHorizontalAlignment Property

Lassalle.Silverlight.Flow Namespace > Node Class : ImageHorizontalAlignment Property
Sets or returns the horizontal alignment of the image associated with the node.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ImageHorizontalAlignment As HorizontalAlignment
'Usage

Dim instance As Node
Dim value As HorizontalAlignment

instance.ImageHorizontalAlignment = value

value = instance.ImageHorizontalAlignment
public HorizontalAlignment ImageHorizontalAlignment {get; set;}
public: __property HorizontalAlignment get_ImageHorizontalAlignment();
public: __property void set_ImageHorizontalAlignment(
   HorizontalAlignment value
);
public:
property HorizontalAlignment ImageHorizontalAlignment {
   HorizontalAlignment get();
   void set (    HorizontalAlignment value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


ImageUri Property

Lassalle.Silverlight.Flow Namespace > Node Class : ImageUri Property
Sets or returns the uri of the image associated with the node.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ImageUri As Uri
'Usage

Dim instance As Node
Dim value As Uri

instance.ImageUri = value

value = instance.ImageUri
public Uri ImageUri {get; set;}
public: __property Uri* get_ImageUri();
public: __property void set_ImageUri(
   Uri* value
);
public:
property Uri^ ImageUri {
   Uri^ get();
   void set (    Uri^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


ImageVerticalAlignment Property

Lassalle.Silverlight.Flow Namespace > Node Class : ImageVerticalAlignment Property
Sets or returns the vertical alignment of the image associated with the node.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ImageVerticalAlignment As VerticalAlignment
'Usage

Dim instance As Node
Dim value As VerticalAlignment

instance.ImageVerticalAlignment = value

value = instance.ImageVerticalAlignment
public VerticalAlignment ImageVerticalAlignment {get; set;}
public: __property VerticalAlignment get_ImageVerticalAlignment();
public: __property void set_ImageVerticalAlignment(
   VerticalAlignment value
);
public:
property VerticalAlignment ImageVerticalAlignment {
   VerticalAlignment get();
   void set (    VerticalAlignment value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


InConnectionMode Property

Lassalle.Silverlight.Flow Namespace > Node Class : InConnectionMode Property
Indicates how a coming link is connected to the destination node
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property InConnectionMode As ConnectionMode
'Usage

Dim instance As Node
Dim value As ConnectionMode

instance.InConnectionMode = value

value = instance.InConnectionMode
public ConnectionMode InConnectionMode {get; set;}
public: __property ConnectionMode get_InConnectionMode();
public: __property void set_InConnectionMode(
   ConnectionMode value
);
public:
property ConnectionMode InConnectionMode {
   ConnectionMode get();
   void set (    ConnectionMode value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


IsContextHandle Property (Node)

Lassalle.Silverlight.Flow Namespace > Node Class : IsContextHandle Property
Determines whether the node has a context handle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsContextHandle As Boolean
'Usage

Dim instance As Node
Dim value As Boolean

instance.IsContextHandle = value

value = instance.IsContextHandle
public bool IsContextHandle {get; set;}
public: __property bool get_IsContextHandle();
public: __property void set_IsContextHandle(
   bool value
);
public:
property bool IsContextHandle {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


IsEditable Property

Lassalle.Silverlight.Flow Namespace > Node Class : IsEditable Property
Gets or sets a value indicating whether the label text of the node can be edited.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsEditable As Boolean
'Usage

Dim instance As Node
Dim value As Boolean

instance.IsEditable = value

value = instance.IsEditable
public bool IsEditable {get; set;}
public: __property bool get_IsEditable();
public: __property void set_IsEditable(
   bool value
);
public:
property bool IsEditable {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


IsInEditMode Property

Lassalle.Silverlight.Flow Namespace > Node Class : IsInEditMode Property
Determines if the node is in edition mode
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsInEditMode As Boolean
'Usage

Dim instance As Node
Dim value As Boolean

instance.IsInEditMode = value

value = instance.IsInEditMode
public bool IsInEditMode {get; set;}
public: __property bool get_IsInEditMode();
public: __property void set_IsInEditMode(
   bool value
);
public:
property bool IsInEditMode {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


IsInLinkable Property

Lassalle.Silverlight.Flow Namespace > Node Class : IsInLinkable Property
Determines whether the node accept incoming links.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsInLinkable As Boolean
'Usage

Dim instance As Node
Dim value As Boolean

instance.IsInLinkable = value

value = instance.IsInLinkable
public bool IsInLinkable {get; set;}
public: __property bool get_IsInLinkable();
public: __property void set_IsInLinkable(
   bool value
);
public:
property bool IsInLinkable {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


IsLinkingOver Property

Lassalle.Silverlight.Flow Namespace > Node Class : IsLinkingOver Property
If True, this property indicates that, during the creation of a link, the mouse is over this node which therefore may be the destination of that link.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsLinkingOver As Boolean
'Usage

Dim instance As Node
Dim value As Boolean

instance.IsLinkingOver = value

value = instance.IsLinkingOver
public bool IsLinkingOver {get; set;}
public: __property bool get_IsLinkingOver();
public: __property void set_IsLinkingOver(
   bool value
);
public:
property bool IsLinkingOver {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


IsOutLinkable Property

Lassalle.Silverlight.Flow Namespace > Node Class : IsOutLinkable Property
Determines whether the node accept outgoing links.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsOutLinkable As Boolean
'Usage

Dim instance As Node
Dim value As Boolean

instance.IsOutLinkable = value

value = instance.IsOutLinkable
public bool IsOutLinkable {get; set;}
public: __property bool get_IsOutLinkable();
public: __property void set_IsOutLinkable(
   bool value
);
public:
property bool IsOutLinkable {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


IsRotatable Property

Lassalle.Silverlight.Flow Namespace > Node Class : IsRotatable Property
Determines whether the node can be rotated.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsRotatable As Boolean
'Usage

Dim instance As Node
Dim value As Boolean

instance.IsRotatable = value

value = instance.IsRotatable
public bool IsRotatable {get; set;}
public: __property bool get_IsRotatable();
public: __property void set_IsRotatable(
   bool value
);
public:
property bool IsRotatable {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


IsSelectable Property (Node)

Lassalle.Silverlight.Flow Namespace > Node Class : IsSelectable Property
Determines whether the node is selectable by clicking on it with the mouse or unselectable (readonly or inactive).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsSelectable As Boolean
'Usage

Dim instance As Node
Dim value As Boolean

instance.IsSelectable = value

value = instance.IsSelectable
public bool IsSelectable {get; set;}
public: __property bool get_IsSelectable();
public: __property void set_IsSelectable(
   bool value
);
public:
property bool IsSelectable {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


IsSelected Property (Node)

Lassalle.Silverlight.Flow Namespace > Node Class : IsSelected Property
Determines if the node is selected or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsSelected As Boolean
'Usage

Dim instance As Node
Dim value As Boolean

instance.IsSelected = value

value = instance.IsSelected
public bool IsSelected {get; set;}
public: __property bool get_IsSelected();
public: __property void set_IsSelected(
   bool value
);
public:
property bool IsSelected {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


IsXMoveable Property (Node)

Lassalle.Silverlight.Flow Namespace > Node Class : IsXMoveable Property
Determines whether the node can be horizontally moved or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsXMoveable As Boolean
'Usage

Dim instance As Node
Dim value As Boolean

instance.IsXMoveable = value

value = instance.IsXMoveable
public bool IsXMoveable {get; set;}
public: __property bool get_IsXMoveable();
public: __property void set_IsXMoveable(
   bool value
);
public:
property bool IsXMoveable {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


IsXSizeable Property

Lassalle.Silverlight.Flow Namespace > Node Class : IsXSizeable Property
Determines whether the node can be horizontally resized or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsXSizeable As Boolean
'Usage

Dim instance As Node
Dim value As Boolean

instance.IsXSizeable = value

value = instance.IsXSizeable
public bool IsXSizeable {get; set;}
public: __property bool get_IsXSizeable();
public: __property void set_IsXSizeable(
   bool value
);
public:
property bool IsXSizeable {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


IsYMoveable Property (Node)

Lassalle.Silverlight.Flow Namespace > Node Class : IsYMoveable Property
Determines whether the node can be vertically moved or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsYMoveable As Boolean
'Usage

Dim instance As Node
Dim value As Boolean

instance.IsYMoveable = value

value = instance.IsYMoveable
public bool IsYMoveable {get; set;}
public: __property bool get_IsYMoveable();
public: __property void set_IsYMoveable(
   bool value
);
public:
property bool IsYMoveable {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


IsYSizeable Property

Lassalle.Silverlight.Flow Namespace > Node Class : IsYSizeable Property
Determines whether the node can be vertically resized or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsYSizeable As Boolean
'Usage

Dim instance As Node
Dim value As Boolean

instance.IsYSizeable = value

value = instance.IsYSizeable
public bool IsYSizeable {get; set;}
public: __property bool get_IsYSizeable();
public: __property void set_IsYSizeable(
   bool value
);
public:
property bool IsYSizeable {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


Links Property

Lassalle.Silverlight.Flow Namespace > Node Class : Links Property
Returns the collection of the links attached to this node.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Links As List(Of Link)
'Usage

Dim instance As Node
Dim value As List(Of Link)

value = instance.Links
public List<Link> Links {get;}
public: __property List<Link*>* get_Links();
public:
property List<Link^>^ Links {
   List<Link^>^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


Location Property

Lassalle.Silverlight.Flow Namespace > Node Class : Location Property
Returns/sets the position of a node.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Location As Point
'Usage

Dim instance As Node
Dim value As Point

instance.Location = value

value = instance.Location
public Point Location {get; set;}
public: __property Point get_Location();
public: __property void set_Location(
   Point value
);
public:
property Point Location {
   Point get();
   void set (    Point value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


OutConnectionMode Property

Lassalle.Silverlight.Flow Namespace > Node Class : OutConnectionMode Property
Indicates how a leaving link is connected to the origin node
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property OutConnectionMode As ConnectionMode
'Usage

Dim instance As Node
Dim value As ConnectionMode

instance.OutConnectionMode = value

value = instance.OutConnectionMode
public ConnectionMode OutConnectionMode {get; set;}
public: __property ConnectionMode get_OutConnectionMode();
public: __property void set_OutConnectionMode(
   ConnectionMode value
);
public:
property ConnectionMode OutConnectionMode {
   ConnectionMode get();
   void set (    ConnectionMode value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


RotationAngle Property

Lassalle.Silverlight.Flow Namespace > Node Class : RotationAngle Property
Returns/sets the rotation angle of a node.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RotationAngle As Double
'Usage

Dim instance As Node
Dim value As Double

instance.RotationAngle = value

value = instance.RotationAngle
public double RotationAngle {get; set;}
public: __property double get_RotationAngle();
public: __property void set_RotationAngle(
   double value
);
public:
property double RotationAngle {
   double get();
   void set (    double value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


Size Property

Lassalle.Silverlight.Flow Namespace > Node Class : Size Property
Returns/sets the size of a node.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Size As Size
'Usage

Dim instance As Node
Dim value As Size

instance.Size = value

value = instance.Size
public Size Size {get; set;}
public: __property Size get_Size();
public: __property void set_Size(
   Size value
);
public:
property Size Size {
   Size get();
   void set (    Size value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


Text Property (Node)

Lassalle.Silverlight.Flow Namespace > Node Class : Text Property
Sets or returns the text associated with the node.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Text As String
'Usage

Dim instance As Node
Dim value As String

instance.Text = value

value = instance.Text
public string Text {get; set;}
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
public:
property String^ Text {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


TextBlock Property (Node)

Lassalle.Silverlight.Flow Namespace > Node Class : TextBlock Property
Sets or returns the TextBlock associated with the node and used to display the node label
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property TextBlock As TextBlock
'Usage

Dim instance As Node
Dim value As TextBlock

value = instance.TextBlock
public TextBlock TextBlock {get;}
public: __property TextBlock* get_TextBlock();
public:
property TextBlock^ TextBlock {
   TextBlock^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


TextHorizontalAlignment Property

Lassalle.Silverlight.Flow Namespace > Node Class : TextHorizontalAlignment Property
Sets or returns the horizontal alignment of the text associated with the node.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TextHorizontalAlignment As HorizontalAlignment
'Usage

Dim instance As Node
Dim value As HorizontalAlignment

instance.TextHorizontalAlignment = value

value = instance.TextHorizontalAlignment
public HorizontalAlignment TextHorizontalAlignment {get; set;}
public: __property HorizontalAlignment get_TextHorizontalAlignment();
public: __property void set_TextHorizontalAlignment(
   HorizontalAlignment value
);
public:
property HorizontalAlignment TextHorizontalAlignment {
   HorizontalAlignment get();
   void set (    HorizontalAlignment value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


TextVerticalAlignment Property

Lassalle.Silverlight.Flow Namespace > Node Class : TextVerticalAlignment Property
Sets or returns the vertical alignment of the text associated with the node.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TextVerticalAlignment As VerticalAlignment
'Usage

Dim instance As Node
Dim value As VerticalAlignment

instance.TextVerticalAlignment = value

value = instance.TextVerticalAlignment
public VerticalAlignment TextVerticalAlignment {get; set;}
public: __property VerticalAlignment get_TextVerticalAlignment();
public: __property void set_TextVerticalAlignment(
   VerticalAlignment value
);
public:
property VerticalAlignment TextVerticalAlignment {
   VerticalAlignment get();
   void set (    VerticalAlignment value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


%%PageItemTitle%% $$Fields$$

Node Class Fields

Lassalle.Silverlight.Flow Namespace : Node Class

For a list of all members of this type, see Node members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | ImageHorizontalAlignmentProperty | Identifies the ImageHorizontalAlignment dependency property
static (Shared in Visual Basic) | ImageUriProperty | Identifies the ImageUri dependency property
static (Shared in Visual Basic) | ImageVerticalAlignmentProperty | Identifies the ImageVerticalAlignment dependency property
static (Shared in Visual Basic) | InConnectionModeProperty | Identifies the InConnectionMode dependency property
static (Shared in Visual Basic) | IsContextHandleProperty | Identifies the IsContextHandle dependency property
static (Shared in Visual Basic) | IsEditableProperty | Identifies the IsEditable dependency property.
static (Shared in Visual Basic) | IsInEditModeProperty | Identifies the IsInEditMode dependency property
static (Shared in Visual Basic) | IsInLinkableProperty | Identifies the IsInLinkable dependency property
static (Shared in Visual Basic) | IsLinkingOverProperty | Identifies the IsLinkingOver dependency property
static (Shared in Visual Basic) | IsOutLinkableProperty | Identifies the IsOutLinkable dependency property
static (Shared in Visual Basic) | IsRotatableProperty | Identifies the IsRotatable dependency property
static (Shared in Visual Basic) | IsSelectableProperty | Identifies the IsSelectable dependency property
static (Shared in Visual Basic) | IsSelectedProperty | Identifies the IsSelected dependency property
static (Shared in Visual Basic) | IsXMoveableProperty | Identifies the IsXMoveable dependency property
static (Shared in Visual Basic) | IsXSizeableProperty | Identifies the IsXSizeable dependency property
static (Shared in Visual Basic) | IsYMoveableProperty | Identifies the IsYMoveable dependency property
static (Shared in Visual Basic) | IsYSizeableProperty | Identifies the IsYSizeable dependency property
static (Shared in Visual Basic) | OutConnectionModeProperty | Identifies the OutConnectionMode dependency property
static (Shared in Visual Basic) | TextHorizontalAlignmentProperty | Identifies the TextHorizontalAlignment dependency property
static (Shared in Visual Basic) | TextProperty | Identifies the Text dependency property
static (Shared in Visual Basic) | TextVerticalAlignmentProperty | Identifies the TextVerticalAlignment dependency property
Top
See Also

Reference

Node Class
Lassalle.Silverlight.Flow Namespace


ImageHorizontalAlignmentProperty Field

Lassalle.Silverlight.Flow Namespace > Node Class : ImageHorizontalAlignmentProperty Field
Identifies the ImageHorizontalAlignment dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ImageHorizontalAlignmentProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Node.ImageHorizontalAlignmentProperty
public static readonly DependencyProperty ImageHorizontalAlignmentProperty
public: static readonly DependencyProperty* ImageHorizontalAlignmentProperty
public:
static readonly DependencyProperty^ ImageHorizontalAlignmentProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


ImageUriProperty Field

Lassalle.Silverlight.Flow Namespace > Node Class : ImageUriProperty Field
Identifies the ImageUri dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ImageUriProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Node.ImageUriProperty
public static readonly DependencyProperty ImageUriProperty
public: static readonly DependencyProperty* ImageUriProperty
public:
static readonly DependencyProperty^ ImageUriProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


ImageVerticalAlignmentProperty Field

Lassalle.Silverlight.Flow Namespace > Node Class : ImageVerticalAlignmentProperty Field
Identifies the ImageVerticalAlignment dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly ImageVerticalAlignmentProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Node.ImageVerticalAlignmentProperty
public static readonly DependencyProperty ImageVerticalAlignmentProperty
public: static readonly DependencyProperty* ImageVerticalAlignmentProperty
public:
static readonly DependencyProperty^ ImageVerticalAlignmentProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


InConnectionModeProperty Field

Lassalle.Silverlight.Flow Namespace > Node Class : InConnectionModeProperty Field
Identifies the InConnectionMode dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly InConnectionModeProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Node.InConnectionModeProperty
public static readonly DependencyProperty InConnectionModeProperty
public: static readonly DependencyProperty* InConnectionModeProperty
public:
static readonly DependencyProperty^ InConnectionModeProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


IsContextHandleProperty Field (Node)

Lassalle.Silverlight.Flow Namespace > Node Class : IsContextHandleProperty Field
Identifies the IsContextHandle dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly IsContextHandleProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Node.IsContextHandleProperty
public static readonly DependencyProperty IsContextHandleProperty
public: static readonly DependencyProperty* IsContextHandleProperty
public:
static readonly DependencyProperty^ IsContextHandleProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


IsEditableProperty Field

Lassalle.Silverlight.Flow Namespace > Node Class : IsEditableProperty Field
Identifies the IsEditable dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly IsEditableProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Node.IsEditableProperty
public static readonly DependencyProperty IsEditableProperty
public: static readonly DependencyProperty* IsEditableProperty
public:
static readonly DependencyProperty^ IsEditableProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


IsInEditModeProperty Field

Lassalle.Silverlight.Flow Namespace > Node Class : IsInEditModeProperty Field
Identifies the IsInEditMode dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly IsInEditModeProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Node.IsInEditModeProperty
public static readonly DependencyProperty IsInEditModeProperty
public: static readonly DependencyProperty* IsInEditModeProperty
public:
static readonly DependencyProperty^ IsInEditModeProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


IsInLinkableProperty Field

Lassalle.Silverlight.Flow Namespace > Node Class : IsInLinkableProperty Field
Identifies the IsInLinkable dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly IsInLinkableProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Node.IsInLinkableProperty
public static readonly DependencyProperty IsInLinkableProperty
public: static readonly DependencyProperty* IsInLinkableProperty
public:
static readonly DependencyProperty^ IsInLinkableProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


IsLinkingOverProperty Field

Lassalle.Silverlight.Flow Namespace > Node Class : IsLinkingOverProperty Field
Identifies the IsLinkingOver dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly IsLinkingOverProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Node.IsLinkingOverProperty
public static readonly DependencyProperty IsLinkingOverProperty
public: static readonly DependencyProperty* IsLinkingOverProperty
public:
static readonly DependencyProperty^ IsLinkingOverProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


IsOutLinkableProperty Field

Lassalle.Silverlight.Flow Namespace > Node Class : IsOutLinkableProperty Field
Identifies the IsOutLinkable dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly IsOutLinkableProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Node.IsOutLinkableProperty
public static readonly DependencyProperty IsOutLinkableProperty
public: static readonly DependencyProperty* IsOutLinkableProperty
public:
static readonly DependencyProperty^ IsOutLinkableProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


IsRotatableProperty Field

Lassalle.Silverlight.Flow Namespace > Node Class : IsRotatableProperty Field
Identifies the IsRotatable dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly IsRotatableProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Node.IsRotatableProperty
public static readonly DependencyProperty IsRotatableProperty
public: static readonly DependencyProperty* IsRotatableProperty
public:
static readonly DependencyProperty^ IsRotatableProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


IsSelectableProperty Field (Node)

Lassalle.Silverlight.Flow Namespace > Node Class : IsSelectableProperty Field
Identifies the IsSelectable dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly IsSelectableProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Node.IsSelectableProperty
public static readonly DependencyProperty IsSelectableProperty
public: static readonly DependencyProperty* IsSelectableProperty
public:
static readonly DependencyProperty^ IsSelectableProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


IsSelectedProperty Field (Node)

Lassalle.Silverlight.Flow Namespace > Node Class : IsSelectedProperty Field
Identifies the IsSelected dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly IsSelectedProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Node.IsSelectedProperty
public static readonly DependencyProperty IsSelectedProperty
public: static readonly DependencyProperty* IsSelectedProperty
public:
static readonly DependencyProperty^ IsSelectedProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


IsXMoveableProperty Field

Lassalle.Silverlight.Flow Namespace > Node Class : IsXMoveableProperty Field
Identifies the IsXMoveable dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly IsXMoveableProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Node.IsXMoveableProperty
public static readonly DependencyProperty IsXMoveableProperty
public: static readonly DependencyProperty* IsXMoveableProperty
public:
static readonly DependencyProperty^ IsXMoveableProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


IsXSizeableProperty Field

Lassalle.Silverlight.Flow Namespace > Node Class : IsXSizeableProperty Field
Identifies the IsXSizeable dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly IsXSizeableProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Node.IsXSizeableProperty
public static readonly DependencyProperty IsXSizeableProperty
public: static readonly DependencyProperty* IsXSizeableProperty
public:
static readonly DependencyProperty^ IsXSizeableProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


IsYMoveableProperty Field

Lassalle.Silverlight.Flow Namespace > Node Class : IsYMoveableProperty Field
Identifies the IsYMoveable dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly IsYMoveableProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Node.IsYMoveableProperty
public static readonly DependencyProperty IsYMoveableProperty
public: static readonly DependencyProperty* IsYMoveableProperty
public:
static readonly DependencyProperty^ IsYMoveableProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


IsYSizeableProperty Field

Lassalle.Silverlight.Flow Namespace > Node Class : IsYSizeableProperty Field
Identifies the IsYSizeable dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly IsYSizeableProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Node.IsYSizeableProperty
public static readonly DependencyProperty IsYSizeableProperty
public: static readonly DependencyProperty* IsYSizeableProperty
public:
static readonly DependencyProperty^ IsYSizeableProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


OutConnectionModeProperty Field

Lassalle.Silverlight.Flow Namespace > Node Class : OutConnectionModeProperty Field
Identifies the OutConnectionMode dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly OutConnectionModeProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Node.OutConnectionModeProperty
public static readonly DependencyProperty OutConnectionModeProperty
public: static readonly DependencyProperty* OutConnectionModeProperty
public:
static readonly DependencyProperty^ OutConnectionModeProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


TextHorizontalAlignmentProperty Field

Lassalle.Silverlight.Flow Namespace > Node Class : TextHorizontalAlignmentProperty Field
Identifies the TextHorizontalAlignment dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly TextHorizontalAlignmentProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Node.TextHorizontalAlignmentProperty
public static readonly DependencyProperty TextHorizontalAlignmentProperty
public: static readonly DependencyProperty* TextHorizontalAlignmentProperty
public:
static readonly DependencyProperty^ TextHorizontalAlignmentProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


TextProperty Field (Node)

Lassalle.Silverlight.Flow Namespace > Node Class : TextProperty Field
Identifies the Text dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly TextProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Node.TextProperty
public static readonly DependencyProperty TextProperty
public: static readonly DependencyProperty* TextProperty
public:
static readonly DependencyProperty^ TextProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


TextVerticalAlignmentProperty Field

Lassalle.Silverlight.Flow Namespace > Node Class : TextVerticalAlignmentProperty Field
Identifies the TextVerticalAlignment dependency property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly TextVerticalAlignmentProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Node.TextVerticalAlignmentProperty
public static readonly DependencyProperty TextVerticalAlignmentProperty
public: static readonly DependencyProperty* TextVerticalAlignmentProperty
public:
static readonly DependencyProperty^ TextVerticalAlignmentProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Node Class
Node Members


%%PageItemTitle%%

NodeCreatedEventArgs Class
Members

Lassalle.Silverlight.Flow Namespace : NodeCreatedEventArgs Class
Event parameters used for the NodeCreated event
Object Model
NodeCreatedEventArgs ClassNode Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class NodeCreatedEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As NodeCreatedEventArgs
public class NodeCreatedEventArgs : System.EventArgs
public __gc class NodeCreatedEventArgs : public System.EventArgs
public ref class NodeCreatedEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Lassalle.Silverlight.Flow.NodeCreatedEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NodeCreatedEventArgs Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Members$$

NodeCreatedEventArgs Class Members
Properties

Lassalle.Silverlight.Flow Namespace : NodeCreatedEventArgs Class

The following tables list the members exposed by NodeCreatedEventArgs.

Public Constructors
 | Name | Description
Public Constructor | NodeCreatedEventArgs Constructor | Constructor. Creates a new NodeCreatedEventArgs instance.
Top
Public Properties
 | Name | Description
Public Property | Node | The node that has just been created (read-only)
Top
See Also

Reference

NodeCreatedEventArgs Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

NodeCreatedEventArgs Constructor

Lassalle.Silverlight.Flow Namespace > NodeCreatedEventArgs Class : NodeCreatedEventArgs Constructor
The created node
Constructor. Creates a new NodeCreatedEventArgs instance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal node As Node _
)
'Usage

Dim node As Node

Dim instance As New NodeCreatedEventArgs(node)
public NodeCreatedEventArgs(
   Node node
)
public: NodeCreatedEventArgs(
   Node* node
)
public:
NodeCreatedEventArgs(
   Node^ node
)

Parameters

node
The created node
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NodeCreatedEventArgs Class
NodeCreatedEventArgs Members


%%PageItemTitle%% $$Properties$$

NodeCreatedEventArgs Class Properties

Lassalle.Silverlight.Flow Namespace : NodeCreatedEventArgs Class

For a list of all members of this type, see NodeCreatedEventArgs members.

Public Properties
 | Name | Description
Public Property | Node | The node that has just been created (read-only)
Top
See Also

Reference

NodeCreatedEventArgs Class
Lassalle.Silverlight.Flow Namespace


Node Property (NodeCreatedEventArgs)

Lassalle.Silverlight.Flow Namespace > NodeCreatedEventArgs Class : Node Property
The node that has just been created (read-only)
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Node As Node
'Usage

Dim instance As NodeCreatedEventArgs
Dim value As Node

value = instance.Node
public Node Node {get;}
public: __property Node* get_Node();
public:
property Node^ Node {
   Node^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NodeCreatedEventArgs Class
NodeCreatedEventArgs Members


%%PageItemTitle%%

NodeDeletedEventArgs Class
Members

Lassalle.Silverlight.Flow Namespace : NodeDeletedEventArgs Class
Event parameters used for the NodeDeleted event
Object Model
NodeDeletedEventArgs ClassNode Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class NodeDeletedEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As NodeDeletedEventArgs
public class NodeDeletedEventArgs : System.EventArgs
public __gc class NodeDeletedEventArgs : public System.EventArgs
public ref class NodeDeletedEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Lassalle.Silverlight.Flow.NodeDeletedEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NodeDeletedEventArgs Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Members$$

NodeDeletedEventArgs Class Members
Properties

Lassalle.Silverlight.Flow Namespace : NodeDeletedEventArgs Class

The following tables list the members exposed by NodeDeletedEventArgs.

Public Constructors
 | Name | Description
Public Constructor | NodeDeletedEventArgs Constructor | Constructor. Creates a new NodeDeletedEventArgs instance.
Top
Public Properties
 | Name | Description
Public Property | Node | The node that has just been removed (read-only)
Top
See Also

Reference

NodeDeletedEventArgs Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

NodeDeletedEventArgs Constructor

Lassalle.Silverlight.Flow Namespace > NodeDeletedEventArgs Class : NodeDeletedEventArgs Constructor
The removed node
Constructor. Creates a new NodeDeletedEventArgs instance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal node As Node _
)
'Usage

Dim node As Node

Dim instance As New NodeDeletedEventArgs(node)
public NodeDeletedEventArgs(
   Node node
)
public: NodeDeletedEventArgs(
   Node* node
)
public:
NodeDeletedEventArgs(
   Node^ node
)

Parameters

node
The removed node
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NodeDeletedEventArgs Class
NodeDeletedEventArgs Members


%%PageItemTitle%% $$Properties$$

NodeDeletedEventArgs Class Properties

Lassalle.Silverlight.Flow Namespace : NodeDeletedEventArgs Class

For a list of all members of this type, see NodeDeletedEventArgs members.

Public Properties
 | Name | Description
Public Property | Node | The node that has just been removed (read-only)
Top
See Also

Reference

NodeDeletedEventArgs Class
Lassalle.Silverlight.Flow Namespace


Node Property (NodeDeletedEventArgs)

Lassalle.Silverlight.Flow Namespace > NodeDeletedEventArgs Class : Node Property
The node that has just been removed (read-only)
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Node As Node
'Usage

Dim instance As NodeDeletedEventArgs
Dim value As Node

value = instance.Node
public Node Node {get;}
public: __property Node* get_Node();
public:
property Node^ Node {
   Node^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NodeDeletedEventArgs Class
NodeDeletedEventArgs Members


%%PageItemTitle%%

OrgChangedEventArgs Class
Members

Lassalle.Silverlight.Flow Namespace : OrgChangedEventArgs Class
Event parameters used for the OrgChanged event
Object Model
OrgChangedEventArgs ClassLink ClassNode Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class OrgChangedEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As OrgChangedEventArgs
public class OrgChangedEventArgs : System.EventArgs
public __gc class OrgChangedEventArgs : public System.EventArgs
public ref class OrgChangedEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Lassalle.Silverlight.Flow.OrgChangedEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OrgChangedEventArgs Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Members$$

OrgChangedEventArgs Class Members
Properties

Lassalle.Silverlight.Flow Namespace : OrgChangedEventArgs Class

The following tables list the members exposed by OrgChangedEventArgs.

Public Constructors
 | Name | Description
Public Constructor | OrgChangedEventArgs Constructor | Constructor. Creates a new OrgChangedEventArgs instance.
Top
Public Properties
 | Name | Description
Public Property | Cancel | Gets/sets a value indicating whether the change of the origin node of the link should be canceled.
Public Property | Link | The link whose origin node is changed (read-only)
Public Property | OldOrg | The old origin node (read-only)
Top
See Also

Reference

OrgChangedEventArgs Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

OrgChangedEventArgs Constructor

Lassalle.Silverlight.Flow Namespace > OrgChangedEventArgs Class : OrgChangedEventArgs Constructor
The created link
The old origin node
Constructor. Creates a new OrgChangedEventArgs instance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal link As Link, _
   ByVal oldOrg As Node _
)
'Usage

Dim link As Link
Dim oldOrg As Node

Dim instance As New OrgChangedEventArgs(link, oldOrg)
public OrgChangedEventArgs(
   Link link,
   Node oldOrg
)
public: OrgChangedEventArgs(
   Link* link,
   Node* oldOrg
)
public:
OrgChangedEventArgs(
   Link^ link,
   Node^ oldOrg
)

Parameters

link
The created link
oldOrg
The old origin node
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OrgChangedEventArgs Class
OrgChangedEventArgs Members


%%PageItemTitle%% $$Properties$$

OrgChangedEventArgs Class Properties

Lassalle.Silverlight.Flow Namespace : OrgChangedEventArgs Class

For a list of all members of this type, see OrgChangedEventArgs members.

Public Properties
 | Name | Description
Public Property | Cancel | Gets/sets a value indicating whether the change of the origin node of the link should be canceled.
Public Property | Link | The link whose origin node is changed (read-only)
Public Property | OldOrg | The old origin node (read-only)
Top
See Also

Reference

OrgChangedEventArgs Class
Lassalle.Silverlight.Flow Namespace


Cancel Property (OrgChangedEventArgs)

Lassalle.Silverlight.Flow Namespace > OrgChangedEventArgs Class : Cancel Property
Gets/sets a value indicating whether the change of the origin node of the link should be canceled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Cancel As CancelEventArgs
'Usage

Dim instance As OrgChangedEventArgs
Dim value As CancelEventArgs

instance.Cancel = value

value = instance.Cancel
public CancelEventArgs Cancel {get; set;}
public: __property CancelEventArgs* get_Cancel();
public: __property void set_Cancel(
   CancelEventArgs* value
);
public:
property CancelEventArgs^ Cancel {
   CancelEventArgs^ get();
   void set (    CancelEventArgs^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OrgChangedEventArgs Class
OrgChangedEventArgs Members


Link Property (OrgChangedEventArgs)

Lassalle.Silverlight.Flow Namespace > OrgChangedEventArgs Class : Link Property
The link whose origin node is changed (read-only)
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Link As Link
'Usage

Dim instance As OrgChangedEventArgs
Dim value As Link

value = instance.Link
public Link Link {get;}
public: __property Link* get_Link();
public:
property Link^ Link {
   Link^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OrgChangedEventArgs Class
OrgChangedEventArgs Members


OldOrg Property

Lassalle.Silverlight.Flow Namespace > OrgChangedEventArgs Class : OldOrg Property
The old origin node (read-only)
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property OldOrg As Node
'Usage

Dim instance As OrgChangedEventArgs
Dim value As Node

value = instance.OldOrg
public Node OldOrg {get;}
public: __property Node* get_OldOrg();
public:
property Node^ OldOrg {
   Node^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OrgChangedEventArgs Class
OrgChangedEventArgs Members


%%PageItemTitle%%

OrgChangingEventArgs Class
Members

Lassalle.Silverlight.Flow Namespace : OrgChangingEventArgs Class
Event parameters used for the OrgChanging event
Object Model
OrgChangingEventArgs ClassLink ClassNode Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class OrgChangingEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As OrgChangingEventArgs
public class OrgChangingEventArgs : System.EventArgs
public __gc class OrgChangingEventArgs : public System.EventArgs
public ref class OrgChangingEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Lassalle.Silverlight.Flow.OrgChangingEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OrgChangingEventArgs Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Members$$

OrgChangingEventArgs Class Members
Properties

Lassalle.Silverlight.Flow Namespace : OrgChangingEventArgs Class

The following tables list the members exposed by OrgChangingEventArgs.

Public Constructors
 | Name | Description
Public Constructor | OrgChangingEventArgs Constructor | Constructor. Creates a new OrgChangingEventArgs instance.
Top
Public Properties
 | Name | Description
Public Property | Cancel | Gets/sets a value indicating whether the change of the origin node of the link should be canceled.
Public Property | Link | The link whose origin node is changed (read-only)
Public Property | Org | The new origin node (read-only)
Top
See Also

Reference

OrgChangingEventArgs Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

OrgChangingEventArgs Constructor

Lassalle.Silverlight.Flow Namespace > OrgChangingEventArgs Class : OrgChangingEventArgs Constructor
The created link
The new origin node
Constructor. Creates a new OrgChangingEventArgs instance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal link As Link, _
   ByVal org As Node _
)
'Usage

Dim link As Link
Dim org As Node

Dim instance As New OrgChangingEventArgs(link, org)
public OrgChangingEventArgs(
   Link link,
   Node org
)
public: OrgChangingEventArgs(
   Link* link,
   Node* org
)
public:
OrgChangingEventArgs(
   Link^ link,
   Node^ org
)

Parameters

link
The created link
org
The new origin node
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OrgChangingEventArgs Class
OrgChangingEventArgs Members


%%PageItemTitle%% $$Properties$$

OrgChangingEventArgs Class Properties

Lassalle.Silverlight.Flow Namespace : OrgChangingEventArgs Class

For a list of all members of this type, see OrgChangingEventArgs members.

Public Properties
 | Name | Description
Public Property | Cancel | Gets/sets a value indicating whether the change of the origin node of the link should be canceled.
Public Property | Link | The link whose origin node is changed (read-only)
Public Property | Org | The new origin node (read-only)
Top
See Also

Reference

OrgChangingEventArgs Class
Lassalle.Silverlight.Flow Namespace


Cancel Property (OrgChangingEventArgs)

Lassalle.Silverlight.Flow Namespace > OrgChangingEventArgs Class : Cancel Property
Gets/sets a value indicating whether the change of the origin node of the link should be canceled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Cancel As CancelEventArgs
'Usage

Dim instance As OrgChangingEventArgs
Dim value As CancelEventArgs

instance.Cancel = value

value = instance.Cancel
public CancelEventArgs Cancel {get; set;}
public: __property CancelEventArgs* get_Cancel();
public: __property void set_Cancel(
   CancelEventArgs* value
);
public:
property CancelEventArgs^ Cancel {
   CancelEventArgs^ get();
   void set (    CancelEventArgs^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OrgChangingEventArgs Class
OrgChangingEventArgs Members


Link Property (OrgChangingEventArgs)

Lassalle.Silverlight.Flow Namespace > OrgChangingEventArgs Class : Link Property
The link whose origin node is changed (read-only)
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Link As Link
'Usage

Dim instance As OrgChangingEventArgs
Dim value As Link

value = instance.Link
public Link Link {get;}
public: __property Link* get_Link();
public:
property Link^ Link {
   Link^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OrgChangingEventArgs Class
OrgChangingEventArgs Members


Org Property (OrgChangingEventArgs)

Lassalle.Silverlight.Flow Namespace > OrgChangingEventArgs Class : Org Property
The new origin node (read-only)
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Org As Node
'Usage

Dim instance As OrgChangingEventArgs
Dim value As Node

value = instance.Org
public Node Org {get;}
public: __property Node* get_Org();
public:
property Node^ Org {
   Node^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OrgChangingEventArgs Class
OrgChangingEventArgs Members


%%PageItemTitle%%

Pin Class
Members

Lassalle.Silverlight.Flow Namespace : Pin Class
Represents a pin of a node. A link may be attached to this node via this pin.
Object Model
Pin Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DesignTimeVisibleAttribute()>
Public Class Pin
   Inherits System.Windows.Controls.Control
'Usage

Dim instance As Pin
[DesignTimeVisibleAttribute()]
public class Pin : System.Windows.Controls.Control
[DesignTimeVisibleAttribute()]
public __gc class Pin : public System.Windows.Controls.Control
[DesignTimeVisibleAttribute()]
public ref class Pin : public System.Windows.Controls.Control
Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
Lassalle.Silverlight.Flow.Pin

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Pin Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Members$$

Pin Class Members
Fields Properties Methods Events

Lassalle.Silverlight.Flow Namespace : Pin Class

The following tables list the members exposed by Pin.

Public Constructors
 | Name | Description
Public Constructor | Pin Constructor | Pin constructor
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | InProperty | Identifies the In dependency property.
static (Shared in Visual Basic) | OutProperty | Identifies the Out dependency property.
static (Shared in Visual Basic) | PositionProperty | Identifies the Position dependency property.
Top
Public Properties
 | Name | Description
Public Property | ActualHeight | Gets the rendered height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | Gets the rendered width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | AllowDrop | Gets or sets a value that determines whether this System.Windows.UIElement can be a drop target for purposes of Silverlight drag-and-drop operations. (Inherited from System.Windows.UIElement)
Public Property | Background | Gets or sets a brush that provides the background of the control. (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from System.Windows.Controls.Control)
Public Property | CacheMode | Gets or sets a value that indicates that rendered content should be cached when possible. (Inherited from System.Windows.UIElement)
Public Property | CharacterSpacing | Gets or sets the distance between characters of text in the control measured in 1000ths of the font size. (Inherited from System.Windows.Controls.Control)
Public Property | Clip | Gets or sets the System.Windows.Media.Geometry used to define the outline of the contents of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | Cursor | Gets or sets the cursor image that displays while the mouse pointer is over a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | Gets or sets the data context for a System.Windows.FrameworkElement when it participates in data binding. (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | Gets the size that this System.Windows.UIElement computed during the measure pass of the layout process. (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | Gets the System.Windows.Threading.Dispatcher this object is associated with. (Inherited from System.Windows.DependencyObject)
Public Property | Effect | Gets or sets the pixel shader effect to use for rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | FlowDirection | Gets or sets the direction that text and other user interface elements flow within any parent element that controls their layout. (Inherited from System.Windows.FrameworkElement)
Public Property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | Gets or sets the size of the text in this control. (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from System.Windows.Controls.Control)
Public Property | Height | Gets or sets the suggested height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | In | Determines if the pin accepts "in" links
Public Property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | Gets or sets whether the contained area of this System.Windows.UIElement can return true values for hit testing. (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from System.Windows.Controls.Control)
Public Property | Language | Gets or sets localization/globalization language information that applies to a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | Gets or sets the outer margin of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | Gets or sets the maximum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | Gets or sets the maximum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | Gets or sets the minimum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | Gets or sets the minimum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | Gets or sets the brush used to alter the opacity of regions of this object. (Inherited from System.Windows.UIElement)
Public Property | Out | Determines if the pin accepts "out" links
Public Property | Padding | Gets or sets the padding inside a control. (Inherited from System.Windows.Controls.Control)
Public Property | Parent | Gets the parent object of this System.Windows.FrameworkElement in the object tree. (Inherited from System.Windows.FrameworkElement)
Public Property | Position | Returns/sets the position of the pin
Public Property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderSize | Gets the final render size of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | Gets or sets transform information that affects the rendering position of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by System.Windows.UIElement.RenderTransform, relative to the bounds of the System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from System.Windows.FrameworkElement)
Public Property | Style | Gets or sets an instance System.Windows.Style that is applied for this object during rendering. (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | Gets or sets a value that modifies how tabbing and System.Windows.Controls.Control.TabIndex work for this control. (Inherited from System.Windows.Controls.Control)
Public Property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from System.Windows.FrameworkElement)
Public Property | Template | Gets or sets a control template. (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | Gets the collection of triggers for animations that are defined for a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from System.Windows.UIElement)
Public Property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | Gets or sets the visibility of a System.Windows.UIElement. A System.Windows.UIElement that is not visible does not render and does not communicate its desired size to layout. (Inherited from System.Windows.UIElement)
Public Property | Width | Gets or sets the width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Top
Protected Properties
 | Name | Description
Protected Property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from System.Windows.Controls.Control)
Top
Public Methods
 | Name | Description
Public Method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from System.Windows.UIElement)
Public Method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from System.Windows.Controls.Control)
Public Method | Arrange | Positions child objects and determines a size for a System.Windows.UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | CaptureMouse | Sets mouse capture to a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | ClearValue | Clears the local value of a dependency property. (Inherited from System.Windows.DependencyObject)
Public Method | FindName | Retrieves an object that has the specified identifier name. (Inherited from System.Windows.FrameworkElement)
Public Method | Focus | Attempts to set the focus on the control. (Inherited from System.Windows.Controls.Control)
Public Method | GetAnimationBaseValue | Returns any base value established for a Silverlight dependency property, which would apply in cases where an animation is not active. (Inherited from System.Windows.DependencyObject)
Public Method | GetBindingExpression | Retrieves the System.Windows.Data.BindingExpression for a dependency property where a binding is established. (Inherited from System.Windows.FrameworkElement)
Public Method | GetValue | Returns the current effective value of a dependency property from a System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateArrange | Invalidates the arrange state (layout) for a System.Windows.UIElement. After the invalidation, the System.Windows.UIElement will have its layout updated, which will occur asynchronously. (Inherited from System.Windows.UIElement)
Public Method | InvalidateMeasure | Invalidates the measurement state (layout) for a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | Measure | Updates the System.Windows.UIElement.DesiredSize of a System.Windows.UIElement. Typically, objects that implement custom layout for their layout children call this method from their own System.Windows.FrameworkElement.MeasureOverride(System.Windows.Size) implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call System.Windows.Controls.Control.ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in an application. For more information, see Remarks. (Inherited from System.Windows.FrameworkElement)
Public Method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from System.Windows.DependencyObject)
Public Method | ReleaseMouseCapture | Removes mouse capture from a System.Windows.UIElement. After this call, typically no object holds mouse capture. (Inherited from System.Windows.UIElement)
Public Method | RemoveHandler | Removes the specified routed event handler from this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | SetBinding | Attaches a binding to a System.Windows.FrameworkElement, using the provided binding object, and returns a System.Windows.Data.BindingExpressionBase for possible later use. (Inherited from System.Windows.FrameworkElement)
Public Method | SetValue | (Inherited from System.Windows.DependencyObject)
Public Method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the System.Windows.UIElement to the specified object. (Inherited from System.Windows.UIElement)
Public Method | UpdateLayout | Ensures that all positions of child objects of a System.Windows.UIElement are properly updated for layout. (Inherited from System.Windows.UIElement)
Top
Protected Methods
 | Name | Description
Protected Method | ArrangeOverride | (Inherited from System.Windows.FrameworkElement)
Protected Method | GetTemplateChild | Retrieves the named element in the instantiated System.Windows.Controls.ControlTemplate visual tree. (Inherited from System.Windows.Controls.Control)
Protected Method | MeasureOverride | (Inherited from System.Windows.FrameworkElement)
Protected Method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific System.Windows.Automation.Peers.AutomationPeer implementations for the Silverlight automation infrastructure. (Inherited from System.Windows.UIElement)
Protected Method | OnDragEnter | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDragLeave | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDragOver | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDrop | (Inherited from System.Windows.Controls.Control)
Protected Method | OnGotFocus | (Inherited from System.Windows.Controls.Control)
Protected Method | OnKeyDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnKeyUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnLostFocus | (Inherited from System.Windows.Controls.Control)
Protected Method | OnLostMouseCapture | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseEnter | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeave | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeftButtonDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeftButtonUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseMove | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseRightButtonDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseRightButtonUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseWheel | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInput | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInputStart | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInputUpdate | (Inherited from System.Windows.Controls.Control)
Top
Public Events
 | Name | Description
Public Event | BindingValidationError | Occurs when a data validation error is reported by a binding source. (Inherited from System.Windows.FrameworkElement)
Public Event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from System.Windows.FrameworkElement)
Public Event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from System.Windows.UIElement)
Public Event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from System.Windows.UIElement)
Public Event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from System.Windows.UIElement)
Public Event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from System.Windows.UIElement)
Public Event | GotFocus | Occurs when a System.Windows.UIElement receives focus. (Inherited from System.Windows.UIElement)
Public Event | IsEnabledChanged | Occurs when the System.Windows.Controls.Control.IsEnabled property changes. (Inherited from System.Windows.Controls.Control)
Public Event | KeyDown | Occurs when a keyboard key is pressed while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | KeyUp | Occurs when a keyboard key is released while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | Occurs when the layout of the Silverlight visual tree changes. (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | Occurs when a System.Windows.FrameworkElement has been constructed and added to the object tree. (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | Occurs when a System.Windows.UIElement loses focus. (Inherited from System.Windows.UIElement)
Public Event | LostMouseCapture | Occurs when the System.Windows.UIElement loses mouse capture. (Inherited from System.Windows.UIElement)
Public Event | MediaCommand | Occurs when a button is pressed on a remote control. (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | Occurs when the mouse (or a stylus) enters the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | Occurs when the mouse (or the stylus) leaves the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | Occurs when the left mouse button is pressed (or when the tip of the stylus touches the tablet) while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | Occurs when the left mouse button is released (or the tip of the stylus is removed from the tablet) while the mouse (or the stylus) is over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseMove | Occurs when the coordinate position of the mouse (or stylus) changes while over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over a System.Windows.UIElement. However, this event will only be raised if a caller marks the preceding System.Windows.UIElement.MouseRightButtonDown event as handled; see Remarks. (Inherited from System.Windows.UIElement)
Public Event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over a System.Windows.UIElement, or the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | Occurs when either the System.Windows.FrameworkElement.ActualHeight or the System.Windows.FrameworkElement.ActualWidth properties change value on a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Event | TextInput | Occurs when a UI element gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputStart | Occurs when a UI element initially gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputUpdate | Occurs when text continues to be composed via an input method editor (IME). (Inherited from System.Windows.UIElement)
Public Event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from System.Windows.FrameworkElement)
Top
See Also

Reference

Pin Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

Pin Constructor

Lassalle.Silverlight.Flow Namespace > Pin Class : Pin Constructor
Pin constructor
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New Pin()
public Pin()
public: Pin();
public:
Pin();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Pin Class
Pin Members


%%PageItemTitle%% $$Properties$$

Pin Class Properties

Lassalle.Silverlight.Flow Namespace : Pin Class

For a list of all members of this type, see Pin members.

Public Properties
 | Name | Description
Public Property | ActualHeight | Gets the rendered height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | Gets the rendered width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | AllowDrop | Gets or sets a value that determines whether this System.Windows.UIElement can be a drop target for purposes of Silverlight drag-and-drop operations. (Inherited from System.Windows.UIElement)
Public Property | Background | Gets or sets a brush that provides the background of the control. (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from System.Windows.Controls.Control)
Public Property | CacheMode | Gets or sets a value that indicates that rendered content should be cached when possible. (Inherited from System.Windows.UIElement)
Public Property | CharacterSpacing | Gets or sets the distance between characters of text in the control measured in 1000ths of the font size. (Inherited from System.Windows.Controls.Control)
Public Property | Clip | Gets or sets the System.Windows.Media.Geometry used to define the outline of the contents of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | Cursor | Gets or sets the cursor image that displays while the mouse pointer is over a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | Gets or sets the data context for a System.Windows.FrameworkElement when it participates in data binding. (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | Gets the size that this System.Windows.UIElement computed during the measure pass of the layout process. (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | Gets the System.Windows.Threading.Dispatcher this object is associated with. (Inherited from System.Windows.DependencyObject)
Public Property | Effect | Gets or sets the pixel shader effect to use for rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | FlowDirection | Gets or sets the direction that text and other user interface elements flow within any parent element that controls their layout. (Inherited from System.Windows.FrameworkElement)
Public Property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | Gets or sets the size of the text in this control. (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from System.Windows.Controls.Control)
Public Property | Height | Gets or sets the suggested height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | In | Determines if the pin accepts "in" links
Public Property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | Gets or sets whether the contained area of this System.Windows.UIElement can return true values for hit testing. (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from System.Windows.Controls.Control)
Public Property | Language | Gets or sets localization/globalization language information that applies to a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | Gets or sets the outer margin of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | Gets or sets the maximum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | Gets or sets the maximum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | Gets or sets the minimum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | Gets or sets the minimum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | Gets or sets the brush used to alter the opacity of regions of this object. (Inherited from System.Windows.UIElement)
Public Property | Out | Determines if the pin accepts "out" links
Public Property | Padding | Gets or sets the padding inside a control. (Inherited from System.Windows.Controls.Control)
Public Property | Parent | Gets the parent object of this System.Windows.FrameworkElement in the object tree. (Inherited from System.Windows.FrameworkElement)
Public Property | Position | Returns/sets the position of the pin
Public Property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderSize | Gets the final render size of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | Gets or sets transform information that affects the rendering position of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by System.Windows.UIElement.RenderTransform, relative to the bounds of the System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from System.Windows.FrameworkElement)
Public Property | Style | Gets or sets an instance System.Windows.Style that is applied for this object during rendering. (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | Gets or sets a value that modifies how tabbing and System.Windows.Controls.Control.TabIndex work for this control. (Inherited from System.Windows.Controls.Control)
Public Property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from System.Windows.FrameworkElement)
Public Property | Template | Gets or sets a control template. (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | Gets the collection of triggers for animations that are defined for a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from System.Windows.UIElement)
Public Property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | Gets or sets the visibility of a System.Windows.UIElement. A System.Windows.UIElement that is not visible does not render and does not communicate its desired size to layout. (Inherited from System.Windows.UIElement)
Public Property | Width | Gets or sets the width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Top
Protected Properties
 | Name | Description
Protected Property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from System.Windows.Controls.Control)
Top
See Also

Reference

Pin Class
Lassalle.Silverlight.Flow Namespace


In Property

Lassalle.Silverlight.Flow Namespace > Pin Class : In Property
Determines if the pin accepts "in" links
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property In As Boolean
'Usage

Dim instance As Pin
Dim value As Boolean

instance.In = value

value = instance.In
public bool In {get; set;}
public: __property bool get_In();
public: __property void set_In(
   bool value
);
public:
property bool In {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Pin Class
Pin Members


Out Property

Lassalle.Silverlight.Flow Namespace > Pin Class : Out Property
Determines if the pin accepts "out" links
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Out As Boolean
'Usage

Dim instance As Pin
Dim value As Boolean

instance.Out = value

value = instance.Out
public bool Out {get; set;}
public: __property bool get_Out();
public: __property void set_Out(
   bool value
);
public:
property bool Out {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Pin Class
Pin Members


Position Property

Lassalle.Silverlight.Flow Namespace > Pin Class : Position Property
Returns/sets the position of the pin
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Position As Point
'Usage

Dim instance As Pin
Dim value As Point

instance.Position = value

value = instance.Position
public Point Position {get; set;}
public: __property Point get_Position();
public: __property void set_Position(
   Point value
);
public:
property Point Position {
   Point get();
   void set (    Point value);
}
Remarks
Don't use this property which is only provided for the AddFlow infrastructure
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Pin Class
Pin Members


%%PageItemTitle%% $$Fields$$

Pin Class Fields

Lassalle.Silverlight.Flow Namespace : Pin Class

For a list of all members of this type, see Pin members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | InProperty | Identifies the In dependency property.
static (Shared in Visual Basic) | OutProperty | Identifies the Out dependency property.
static (Shared in Visual Basic) | PositionProperty | Identifies the Position dependency property.
Top
See Also

Reference

Pin Class
Lassalle.Silverlight.Flow Namespace


InProperty Field

Lassalle.Silverlight.Flow Namespace > Pin Class : InProperty Field
Identifies the In dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly InProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Pin.InProperty
public static readonly DependencyProperty InProperty
public: static readonly DependencyProperty* InProperty
public:
static readonly DependencyProperty^ InProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Pin Class
Pin Members


OutProperty Field

Lassalle.Silverlight.Flow Namespace > Pin Class : OutProperty Field
Identifies the Out dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly OutProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Pin.OutProperty
public static readonly DependencyProperty OutProperty
public: static readonly DependencyProperty* OutProperty
public:
static readonly DependencyProperty^ OutProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Pin Class
Pin Members


PositionProperty Field

Lassalle.Silverlight.Flow Namespace > Pin Class : PositionProperty Field
Identifies the Position dependency property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly PositionProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = Pin.PositionProperty
public static readonly DependencyProperty PositionProperty
public: static readonly DependencyProperty* PositionProperty
public:
static readonly DependencyProperty^ PositionProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Pin Class
Pin Members


%%PageItemTitle%%

ResizeHandle Class
Members

Lassalle.Silverlight.Flow Namespace : ResizeHandle Class
Represents a resizing handle of a node.
Object Model
ResizeHandle ClassAddFlow ClassNode Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<TemplateVisualStateAttribute(Name="Normal", GroupName="CommonStates")>
<TemplateVisualStateAttribute(Name="MouseOver", GroupName="CommonStates")>
<DesignTimeVisibleAttribute()>
Public Class ResizeHandle
   Inherits System.Windows.Controls.Control
'Usage

Dim instance As ResizeHandle
[TemplateVisualStateAttribute(Name="Normal", GroupName="CommonStates")]
[TemplateVisualStateAttribute(Name="MouseOver", GroupName="CommonStates")]
[DesignTimeVisibleAttribute()]
public class ResizeHandle : System.Windows.Controls.Control
[TemplateVisualStateAttribute(Name="Normal", GroupName="CommonStates")]
[TemplateVisualStateAttribute(Name="MouseOver", GroupName="CommonStates")]
[DesignTimeVisibleAttribute()]
public __gc class ResizeHandle : public System.Windows.Controls.Control
[TemplateVisualStateAttribute(Name="Normal", GroupName="CommonStates")]
[TemplateVisualStateAttribute(Name="MouseOver", GroupName="CommonStates")]
[DesignTimeVisibleAttribute()]
public ref class ResizeHandle : public System.Windows.Controls.Control
Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
Lassalle.Silverlight.Flow.ResizeHandle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ResizeHandle Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Members$$

ResizeHandle Class Members
Properties Methods Events

Lassalle.Silverlight.Flow Namespace : ResizeHandle Class

The following tables list the members exposed by ResizeHandle.

Public Constructors
 | Name | Description
Public Constructor | ResizeHandle Constructor | ResizeHandle constructor
Top
Public Properties
 | Name | Description
Public Property | ActualHeight | Gets the rendered height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | Gets the rendered width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | AddFlow | The addflow canvas containing this node
Public Property | AllowDrop | Gets or sets a value that determines whether this System.Windows.UIElement can be a drop target for purposes of Silverlight drag-and-drop operations. (Inherited from System.Windows.UIElement)
Public Property | Background | Gets or sets a brush that provides the background of the control. (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from System.Windows.Controls.Control)
Public Property | CacheMode | Gets or sets a value that indicates that rendered content should be cached when possible. (Inherited from System.Windows.UIElement)
Public Property | CharacterSpacing | Gets or sets the distance between characters of text in the control measured in 1000ths of the font size. (Inherited from System.Windows.Controls.Control)
Public Property | Clip | Gets or sets the System.Windows.Media.Geometry used to define the outline of the contents of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | Cursor | Gets or sets the cursor image that displays while the mouse pointer is over a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | Gets or sets the data context for a System.Windows.FrameworkElement when it participates in data binding. (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | Gets the size that this System.Windows.UIElement computed during the measure pass of the layout process. (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | Gets the System.Windows.Threading.Dispatcher this object is associated with. (Inherited from System.Windows.DependencyObject)
Public Property | Effect | Gets or sets the pixel shader effect to use for rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | FlowDirection | Gets or sets the direction that text and other user interface elements flow within any parent element that controls their layout. (Inherited from System.Windows.FrameworkElement)
Public Property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | Gets or sets the size of the text in this control. (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from System.Windows.Controls.Control)
Public Property | Height | Gets or sets the suggested height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | Gets or sets whether the contained area of this System.Windows.UIElement can return true values for hit testing. (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from System.Windows.Controls.Control)
Public Property | Language | Gets or sets localization/globalization language information that applies to a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | Gets or sets the outer margin of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | Gets or sets the maximum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | Gets or sets the maximum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | Gets or sets the minimum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | Gets or sets the minimum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from System.Windows.FrameworkElement)
Public Property | Node | Returns the node using this handle
Public Property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | Gets or sets the brush used to alter the opacity of regions of this object. (Inherited from System.Windows.UIElement)
Public Property | Padding | Gets or sets the padding inside a control. (Inherited from System.Windows.Controls.Control)
Public Property | Parent | Gets the parent object of this System.Windows.FrameworkElement in the object tree. (Inherited from System.Windows.FrameworkElement)
Public Property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderSize | Gets the final render size of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | Gets or sets transform information that affects the rendering position of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by System.Windows.UIElement.RenderTransform, relative to the bounds of the System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from System.Windows.FrameworkElement)
Public Property | Style | Gets or sets an instance System.Windows.Style that is applied for this object during rendering. (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | Gets or sets a value that modifies how tabbing and System.Windows.Controls.Control.TabIndex work for this control. (Inherited from System.Windows.Controls.Control)
Public Property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from System.Windows.FrameworkElement)
Public Property | Template | Gets or sets a control template. (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | Gets the collection of triggers for animations that are defined for a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | Type | Returns the type of the handle (Left, Up, etc)
Public Property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from System.Windows.UIElement)
Public Property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | Gets or sets the visibility of a System.Windows.UIElement. A System.Windows.UIElement that is not visible does not render and does not communicate its desired size to layout. (Inherited from System.Windows.UIElement)
Public Property | Width | Gets or sets the width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Top
Protected Properties
 | Name | Description
Protected Property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from System.Windows.Controls.Control)
Top
Public Methods
 | Name | Description
Public Method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from System.Windows.UIElement)
Public Method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from System.Windows.Controls.Control)
Public Method | Arrange | Positions child objects and determines a size for a System.Windows.UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | CaptureMouse | Sets mouse capture to a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | ClearValue | Clears the local value of a dependency property. (Inherited from System.Windows.DependencyObject)
Public Method | FindName | Retrieves an object that has the specified identifier name. (Inherited from System.Windows.FrameworkElement)
Public Method | Focus | Attempts to set the focus on the control. (Inherited from System.Windows.Controls.Control)
Public Method | GetAnimationBaseValue | Returns any base value established for a Silverlight dependency property, which would apply in cases where an animation is not active. (Inherited from System.Windows.DependencyObject)
Public Method | GetBindingExpression | Retrieves the System.Windows.Data.BindingExpression for a dependency property where a binding is established. (Inherited from System.Windows.FrameworkElement)
Public Method | GetValue | Returns the current effective value of a dependency property from a System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateArrange | Invalidates the arrange state (layout) for a System.Windows.UIElement. After the invalidation, the System.Windows.UIElement will have its layout updated, which will occur asynchronously. (Inherited from System.Windows.UIElement)
Public Method | InvalidateMeasure | Invalidates the measurement state (layout) for a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | Measure | Updates the System.Windows.UIElement.DesiredSize of a System.Windows.UIElement. Typically, objects that implement custom layout for their layout children call this method from their own System.Windows.FrameworkElement.MeasureOverride(System.Windows.Size) implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call System.Windows.Controls.Control.ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in an application. For more information, see Remarks. (Inherited from System.Windows.FrameworkElement)
Public Method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from System.Windows.DependencyObject)
Public Method | ReleaseMouseCapture | Removes mouse capture from a System.Windows.UIElement. After this call, typically no object holds mouse capture. (Inherited from System.Windows.UIElement)
Public Method | RemoveHandler | Removes the specified routed event handler from this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | SetBinding | Attaches a binding to a System.Windows.FrameworkElement, using the provided binding object, and returns a System.Windows.Data.BindingExpressionBase for possible later use. (Inherited from System.Windows.FrameworkElement)
Public Method | SetValue | (Inherited from System.Windows.DependencyObject)
Public Method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the System.Windows.UIElement to the specified object. (Inherited from System.Windows.UIElement)
Public Method | UpdateLayout | Ensures that all positions of child objects of a System.Windows.UIElement are properly updated for layout. (Inherited from System.Windows.UIElement)
Top
Protected Methods
 | Name | Description
Protected Method | ArrangeOverride | (Inherited from System.Windows.FrameworkElement)
Protected Method | GetTemplateChild | Retrieves the named element in the instantiated System.Windows.Controls.ControlTemplate visual tree. (Inherited from System.Windows.Controls.Control)
Protected Method | MeasureOverride | (Inherited from System.Windows.FrameworkElement)
Protected Method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific System.Windows.Automation.Peers.AutomationPeer implementations for the Silverlight automation infrastructure. (Inherited from System.Windows.UIElement)
Protected Method | OnDragEnter | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDragLeave | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDragOver | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDrop | (Inherited from System.Windows.Controls.Control)
Protected Method | OnGotFocus | (Inherited from System.Windows.Controls.Control)
Protected Method | OnKeyDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnKeyUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnLostFocus | (Inherited from System.Windows.Controls.Control)
Protected Method | OnLostMouseCapture | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseEnter | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeave | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeftButtonDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeftButtonUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseMove | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseRightButtonDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseRightButtonUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseWheel | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInput | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInputStart | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInputUpdate | (Inherited from System.Windows.Controls.Control)
Top
Public Events
 | Name | Description
Public Event | BindingValidationError | Occurs when a data validation error is reported by a binding source. (Inherited from System.Windows.FrameworkElement)
Public Event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from System.Windows.FrameworkElement)
Public Event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from System.Windows.UIElement)
Public Event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from System.Windows.UIElement)
Public Event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from System.Windows.UIElement)
Public Event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from System.Windows.UIElement)
Public Event | GotFocus | Occurs when a System.Windows.UIElement receives focus. (Inherited from System.Windows.UIElement)
Public Event | IsEnabledChanged | Occurs when the System.Windows.Controls.Control.IsEnabled property changes. (Inherited from System.Windows.Controls.Control)
Public Event | KeyDown | Occurs when a keyboard key is pressed while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | KeyUp | Occurs when a keyboard key is released while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | Occurs when the layout of the Silverlight visual tree changes. (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | Occurs when a System.Windows.FrameworkElement has been constructed and added to the object tree. (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | Occurs when a System.Windows.UIElement loses focus. (Inherited from System.Windows.UIElement)
Public Event | LostMouseCapture | Occurs when the System.Windows.UIElement loses mouse capture. (Inherited from System.Windows.UIElement)
Public Event | MediaCommand | Occurs when a button is pressed on a remote control. (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | Occurs when the mouse (or a stylus) enters the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | Occurs when the mouse (or the stylus) leaves the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | Occurs when the left mouse button is pressed (or when the tip of the stylus touches the tablet) while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | Occurs when the left mouse button is released (or the tip of the stylus is removed from the tablet) while the mouse (or the stylus) is over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseMove | Occurs when the coordinate position of the mouse (or stylus) changes while over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over a System.Windows.UIElement. However, this event will only be raised if a caller marks the preceding System.Windows.UIElement.MouseRightButtonDown event as handled; see Remarks. (Inherited from System.Windows.UIElement)
Public Event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over a System.Windows.UIElement, or the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | Occurs when either the System.Windows.FrameworkElement.ActualHeight or the System.Windows.FrameworkElement.ActualWidth properties change value on a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Event | TextInput | Occurs when a UI element gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputStart | Occurs when a UI element initially gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputUpdate | Occurs when text continues to be composed via an input method editor (IME). (Inherited from System.Windows.UIElement)
Public Event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from System.Windows.FrameworkElement)
Top
See Also

Reference

ResizeHandle Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

ResizeHandle Constructor

Lassalle.Silverlight.Flow Namespace > ResizeHandle Class : ResizeHandle Constructor
ResizeHandle constructor
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ResizeHandle()
public ResizeHandle()
public: ResizeHandle();
public:
ResizeHandle();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ResizeHandle Class
ResizeHandle Members


%%PageItemTitle%% $$Properties$$

ResizeHandle Class Properties

Lassalle.Silverlight.Flow Namespace : ResizeHandle Class

For a list of all members of this type, see ResizeHandle members.

Public Properties
 | Name | Description
Public Property | ActualHeight | Gets the rendered height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | Gets the rendered width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | AddFlow | The addflow canvas containing this node
Public Property | AllowDrop | Gets or sets a value that determines whether this System.Windows.UIElement can be a drop target for purposes of Silverlight drag-and-drop operations. (Inherited from System.Windows.UIElement)
Public Property | Background | Gets or sets a brush that provides the background of the control. (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from System.Windows.Controls.Control)
Public Property | CacheMode | Gets or sets a value that indicates that rendered content should be cached when possible. (Inherited from System.Windows.UIElement)
Public Property | CharacterSpacing | Gets or sets the distance between characters of text in the control measured in 1000ths of the font size. (Inherited from System.Windows.Controls.Control)
Public Property | Clip | Gets or sets the System.Windows.Media.Geometry used to define the outline of the contents of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | Cursor | Gets or sets the cursor image that displays while the mouse pointer is over a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | Gets or sets the data context for a System.Windows.FrameworkElement when it participates in data binding. (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | Gets the size that this System.Windows.UIElement computed during the measure pass of the layout process. (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | Gets the System.Windows.Threading.Dispatcher this object is associated with. (Inherited from System.Windows.DependencyObject)
Public Property | Effect | Gets or sets the pixel shader effect to use for rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | FlowDirection | Gets or sets the direction that text and other user interface elements flow within any parent element that controls their layout. (Inherited from System.Windows.FrameworkElement)
Public Property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | Gets or sets the size of the text in this control. (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from System.Windows.Controls.Control)
Public Property | Height | Gets or sets the suggested height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | Gets or sets whether the contained area of this System.Windows.UIElement can return true values for hit testing. (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from System.Windows.Controls.Control)
Public Property | Language | Gets or sets localization/globalization language information that applies to a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | Gets or sets the outer margin of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | Gets or sets the maximum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | Gets or sets the maximum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | Gets or sets the minimum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | Gets or sets the minimum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from System.Windows.FrameworkElement)
Public Property | Node | Returns the node using this handle
Public Property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | Gets or sets the brush used to alter the opacity of regions of this object. (Inherited from System.Windows.UIElement)
Public Property | Padding | Gets or sets the padding inside a control. (Inherited from System.Windows.Controls.Control)
Public Property | Parent | Gets the parent object of this System.Windows.FrameworkElement in the object tree. (Inherited from System.Windows.FrameworkElement)
Public Property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderSize | Gets the final render size of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | Gets or sets transform information that affects the rendering position of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by System.Windows.UIElement.RenderTransform, relative to the bounds of the System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from System.Windows.FrameworkElement)
Public Property | Style | Gets or sets an instance System.Windows.Style that is applied for this object during rendering. (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | Gets or sets a value that modifies how tabbing and System.Windows.Controls.Control.TabIndex work for this control. (Inherited from System.Windows.Controls.Control)
Public Property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from System.Windows.FrameworkElement)
Public Property | Template | Gets or sets a control template. (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | Gets the collection of triggers for animations that are defined for a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | Type | Returns the type of the handle (Left, Up, etc)
Public Property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from System.Windows.UIElement)
Public Property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | Gets or sets the visibility of a System.Windows.UIElement. A System.Windows.UIElement that is not visible does not render and does not communicate its desired size to layout. (Inherited from System.Windows.UIElement)
Public Property | Width | Gets or sets the width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Top
Protected Properties
 | Name | Description
Protected Property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from System.Windows.Controls.Control)
Top
See Also

Reference

ResizeHandle Class
Lassalle.Silverlight.Flow Namespace


AddFlow Property (ResizeHandle)

Lassalle.Silverlight.Flow Namespace > ResizeHandle Class : AddFlow Property
The addflow canvas containing this node
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property AddFlow As AddFlow
'Usage

Dim instance As ResizeHandle
Dim value As AddFlow

value = instance.AddFlow
public AddFlow AddFlow {get;}
public: __property AddFlow* get_AddFlow();
public:
property AddFlow^ AddFlow {
   AddFlow^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ResizeHandle Class
ResizeHandle Members


Node Property (ResizeHandle)

Lassalle.Silverlight.Flow Namespace > ResizeHandle Class : Node Property
Returns the node using this handle
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Node As Node
'Usage

Dim instance As ResizeHandle
Dim value As Node

value = instance.Node
public Node Node {get;}
public: __property Node* get_Node();
public:
property Node^ Node {
   Node^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ResizeHandle Class
ResizeHandle Members


Type Property

Lassalle.Silverlight.Flow Namespace > ResizeHandle Class : Type Property
Returns the type of the handle (Left, Up, etc)
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Type As ResizeHandle.HandleType
'Usage

Dim instance As ResizeHandle
Dim value As ResizeHandle.HandleType

instance.Type = value

value = instance.Type
public ResizeHandle.HandleType Type {get; set;}
public: __property ResizeHandle.HandleType get_Type();
public: __property void set_Type(
   ResizeHandle.HandleType value
);
public:
property ResizeHandle.HandleType Type {
   ResizeHandle.HandleType get();
   void set (    ResizeHandle.HandleType value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ResizeHandle Class
ResizeHandle Members


%%PageItemTitle%%

RotateHandle Class
Members

Lassalle.Silverlight.Flow Namespace : RotateHandle Class
Represents a rotating handle of a node.
Object Model
RotateHandle ClassAddFlow ClassNode Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<TemplateVisualStateAttribute(Name="Normal", GroupName="CommonStates")>
<TemplateVisualStateAttribute(Name="MouseOver", GroupName="CommonStates")>
Public Class RotateHandle
   Inherits System.Windows.Controls.Control
'Usage

Dim instance As RotateHandle
[TemplateVisualStateAttribute(Name="Normal", GroupName="CommonStates")]
[TemplateVisualStateAttribute(Name="MouseOver", GroupName="CommonStates")]
public class RotateHandle : System.Windows.Controls.Control
[TemplateVisualStateAttribute(Name="Normal", GroupName="CommonStates")]
[TemplateVisualStateAttribute(Name="MouseOver", GroupName="CommonStates")]
public __gc class RotateHandle : public System.Windows.Controls.Control
[TemplateVisualStateAttribute(Name="Normal", GroupName="CommonStates")]
[TemplateVisualStateAttribute(Name="MouseOver", GroupName="CommonStates")]
public ref class RotateHandle : public System.Windows.Controls.Control
Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
Lassalle.Silverlight.Flow.RotateHandle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RotateHandle Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Members$$

RotateHandle Class Members
Properties Methods Events

Lassalle.Silverlight.Flow Namespace : RotateHandle Class

The following tables list the members exposed by RotateHandle.

Public Constructors
 | Name | Description
Public Constructor | RotateHandle Constructor | RotateHandle constructor
Top
Public Properties
 | Name | Description
Public Property | ActualHeight | Gets the rendered height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | Gets the rendered width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | AddFlow | The addflow canvas containing this node
Public Property | AllowDrop | Gets or sets a value that determines whether this System.Windows.UIElement can be a drop target for purposes of Silverlight drag-and-drop operations. (Inherited from System.Windows.UIElement)
Public Property | Background | Gets or sets a brush that provides the background of the control. (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from System.Windows.Controls.Control)
Public Property | CacheMode | Gets or sets a value that indicates that rendered content should be cached when possible. (Inherited from System.Windows.UIElement)
Public Property | CharacterSpacing | Gets or sets the distance between characters of text in the control measured in 1000ths of the font size. (Inherited from System.Windows.Controls.Control)
Public Property | Clip | Gets or sets the System.Windows.Media.Geometry used to define the outline of the contents of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | Cursor | Gets or sets the cursor image that displays while the mouse pointer is over a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | Gets or sets the data context for a System.Windows.FrameworkElement when it participates in data binding. (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | Gets the size that this System.Windows.UIElement computed during the measure pass of the layout process. (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | Gets the System.Windows.Threading.Dispatcher this object is associated with. (Inherited from System.Windows.DependencyObject)
Public Property | Effect | Gets or sets the pixel shader effect to use for rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | FlowDirection | Gets or sets the direction that text and other user interface elements flow within any parent element that controls their layout. (Inherited from System.Windows.FrameworkElement)
Public Property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | Gets or sets the size of the text in this control. (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from System.Windows.Controls.Control)
Public Property | Height | Gets or sets the suggested height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | Gets or sets whether the contained area of this System.Windows.UIElement can return true values for hit testing. (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from System.Windows.Controls.Control)
Public Property | Language | Gets or sets localization/globalization language information that applies to a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | Gets or sets the outer margin of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | Gets or sets the maximum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | Gets or sets the maximum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | Gets or sets the minimum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | Gets or sets the minimum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from System.Windows.FrameworkElement)
Public Property | Node | Returns the item using this handle
Public Property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | Gets or sets the brush used to alter the opacity of regions of this object. (Inherited from System.Windows.UIElement)
Public Property | Padding | Gets or sets the padding inside a control. (Inherited from System.Windows.Controls.Control)
Public Property | Parent | Gets the parent object of this System.Windows.FrameworkElement in the object tree. (Inherited from System.Windows.FrameworkElement)
Public Property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderSize | Gets the final render size of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | Gets or sets transform information that affects the rendering position of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by System.Windows.UIElement.RenderTransform, relative to the bounds of the System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from System.Windows.FrameworkElement)
Public Property | Style | Gets or sets an instance System.Windows.Style that is applied for this object during rendering. (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | Gets or sets a value that modifies how tabbing and System.Windows.Controls.Control.TabIndex work for this control. (Inherited from System.Windows.Controls.Control)
Public Property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from System.Windows.FrameworkElement)
Public Property | Template | Gets or sets a control template. (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | Gets the collection of triggers for animations that are defined for a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from System.Windows.UIElement)
Public Property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | Gets or sets the visibility of a System.Windows.UIElement. A System.Windows.UIElement that is not visible does not render and does not communicate its desired size to layout. (Inherited from System.Windows.UIElement)
Public Property | Width | Gets or sets the width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Top
Protected Properties
 | Name | Description
Protected Property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from System.Windows.Controls.Control)
Top
Public Methods
 | Name | Description
Public Method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from System.Windows.UIElement)
Public Method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from System.Windows.Controls.Control)
Public Method | Arrange | Positions child objects and determines a size for a System.Windows.UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | CaptureMouse | Sets mouse capture to a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | ClearValue | Clears the local value of a dependency property. (Inherited from System.Windows.DependencyObject)
Public Method | FindName | Retrieves an object that has the specified identifier name. (Inherited from System.Windows.FrameworkElement)
Public Method | Focus | Attempts to set the focus on the control. (Inherited from System.Windows.Controls.Control)
Public Method | GetAnimationBaseValue | Returns any base value established for a Silverlight dependency property, which would apply in cases where an animation is not active. (Inherited from System.Windows.DependencyObject)
Public Method | GetBindingExpression | Retrieves the System.Windows.Data.BindingExpression for a dependency property where a binding is established. (Inherited from System.Windows.FrameworkElement)
Public Method | GetValue | Returns the current effective value of a dependency property from a System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateArrange | Invalidates the arrange state (layout) for a System.Windows.UIElement. After the invalidation, the System.Windows.UIElement will have its layout updated, which will occur asynchronously. (Inherited from System.Windows.UIElement)
Public Method | InvalidateMeasure | Invalidates the measurement state (layout) for a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | Measure | Updates the System.Windows.UIElement.DesiredSize of a System.Windows.UIElement. Typically, objects that implement custom layout for their layout children call this method from their own System.Windows.FrameworkElement.MeasureOverride(System.Windows.Size) implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call System.Windows.Controls.Control.ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in an application. For more information, see Remarks. (Inherited from System.Windows.FrameworkElement)
Public Method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from System.Windows.DependencyObject)
Public Method | ReleaseMouseCapture | Removes mouse capture from a System.Windows.UIElement. After this call, typically no object holds mouse capture. (Inherited from System.Windows.UIElement)
Public Method | RemoveHandler | Removes the specified routed event handler from this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | SetBinding | Attaches a binding to a System.Windows.FrameworkElement, using the provided binding object, and returns a System.Windows.Data.BindingExpressionBase for possible later use. (Inherited from System.Windows.FrameworkElement)
Public Method | SetValue | (Inherited from System.Windows.DependencyObject)
Public Method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the System.Windows.UIElement to the specified object. (Inherited from System.Windows.UIElement)
Public Method | UpdateLayout | Ensures that all positions of child objects of a System.Windows.UIElement are properly updated for layout. (Inherited from System.Windows.UIElement)
Top
Protected Methods
 | Name | Description
Protected Method | ArrangeOverride | (Inherited from System.Windows.FrameworkElement)
Protected Method | GetTemplateChild | Retrieves the named element in the instantiated System.Windows.Controls.ControlTemplate visual tree. (Inherited from System.Windows.Controls.Control)
Protected Method | MeasureOverride | (Inherited from System.Windows.FrameworkElement)
Protected Method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific System.Windows.Automation.Peers.AutomationPeer implementations for the Silverlight automation infrastructure. (Inherited from System.Windows.UIElement)
Protected Method | OnDragEnter | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDragLeave | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDragOver | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDrop | (Inherited from System.Windows.Controls.Control)
Protected Method | OnGotFocus | (Inherited from System.Windows.Controls.Control)
Protected Method | OnKeyDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnKeyUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnLostFocus | (Inherited from System.Windows.Controls.Control)
Protected Method | OnLostMouseCapture | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseEnter | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeave | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeftButtonDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeftButtonUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseMove | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseRightButtonDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseRightButtonUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseWheel | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInput | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInputStart | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInputUpdate | (Inherited from System.Windows.Controls.Control)
Top
Public Events
 | Name | Description
Public Event | BindingValidationError | Occurs when a data validation error is reported by a binding source. (Inherited from System.Windows.FrameworkElement)
Public Event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from System.Windows.FrameworkElement)
Public Event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from System.Windows.UIElement)
Public Event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from System.Windows.UIElement)
Public Event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from System.Windows.UIElement)
Public Event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from System.Windows.UIElement)
Public Event | GotFocus | Occurs when a System.Windows.UIElement receives focus. (Inherited from System.Windows.UIElement)
Public Event | IsEnabledChanged | Occurs when the System.Windows.Controls.Control.IsEnabled property changes. (Inherited from System.Windows.Controls.Control)
Public Event | KeyDown | Occurs when a keyboard key is pressed while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | KeyUp | Occurs when a keyboard key is released while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | Occurs when the layout of the Silverlight visual tree changes. (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | Occurs when a System.Windows.FrameworkElement has been constructed and added to the object tree. (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | Occurs when a System.Windows.UIElement loses focus. (Inherited from System.Windows.UIElement)
Public Event | LostMouseCapture | Occurs when the System.Windows.UIElement loses mouse capture. (Inherited from System.Windows.UIElement)
Public Event | MediaCommand | Occurs when a button is pressed on a remote control. (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | Occurs when the mouse (or a stylus) enters the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | Occurs when the mouse (or the stylus) leaves the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | Occurs when the left mouse button is pressed (or when the tip of the stylus touches the tablet) while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | Occurs when the left mouse button is released (or the tip of the stylus is removed from the tablet) while the mouse (or the stylus) is over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseMove | Occurs when the coordinate position of the mouse (or stylus) changes while over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over a System.Windows.UIElement. However, this event will only be raised if a caller marks the preceding System.Windows.UIElement.MouseRightButtonDown event as handled; see Remarks. (Inherited from System.Windows.UIElement)
Public Event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over a System.Windows.UIElement, or the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | Occurs when either the System.Windows.FrameworkElement.ActualHeight or the System.Windows.FrameworkElement.ActualWidth properties change value on a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Event | TextInput | Occurs when a UI element gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputStart | Occurs when a UI element initially gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputUpdate | Occurs when text continues to be composed via an input method editor (IME). (Inherited from System.Windows.UIElement)
Public Event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from System.Windows.FrameworkElement)
Top
See Also

Reference

RotateHandle Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

RotateHandle Constructor

Lassalle.Silverlight.Flow Namespace > RotateHandle Class : RotateHandle Constructor
RotateHandle constructor
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New RotateHandle()
public RotateHandle()
public: RotateHandle();
public:
RotateHandle();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RotateHandle Class
RotateHandle Members


%%PageItemTitle%% $$Properties$$

RotateHandle Class Properties

Lassalle.Silverlight.Flow Namespace : RotateHandle Class

For a list of all members of this type, see RotateHandle members.

Public Properties
 | Name | Description
Public Property | ActualHeight | Gets the rendered height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | Gets the rendered width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | AddFlow | The addflow canvas containing this node
Public Property | AllowDrop | Gets or sets a value that determines whether this System.Windows.UIElement can be a drop target for purposes of Silverlight drag-and-drop operations. (Inherited from System.Windows.UIElement)
Public Property | Background | Gets or sets a brush that provides the background of the control. (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from System.Windows.Controls.Control)
Public Property | CacheMode | Gets or sets a value that indicates that rendered content should be cached when possible. (Inherited from System.Windows.UIElement)
Public Property | CharacterSpacing | Gets or sets the distance between characters of text in the control measured in 1000ths of the font size. (Inherited from System.Windows.Controls.Control)
Public Property | Clip | Gets or sets the System.Windows.Media.Geometry used to define the outline of the contents of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | Cursor | Gets or sets the cursor image that displays while the mouse pointer is over a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | Gets or sets the data context for a System.Windows.FrameworkElement when it participates in data binding. (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | Gets the size that this System.Windows.UIElement computed during the measure pass of the layout process. (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | Gets the System.Windows.Threading.Dispatcher this object is associated with. (Inherited from System.Windows.DependencyObject)
Public Property | Effect | Gets or sets the pixel shader effect to use for rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | FlowDirection | Gets or sets the direction that text and other user interface elements flow within any parent element that controls their layout. (Inherited from System.Windows.FrameworkElement)
Public Property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | Gets or sets the size of the text in this control. (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from System.Windows.Controls.Control)
Public Property | Height | Gets or sets the suggested height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | Gets or sets whether the contained area of this System.Windows.UIElement can return true values for hit testing. (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from System.Windows.Controls.Control)
Public Property | Language | Gets or sets localization/globalization language information that applies to a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | Gets or sets the outer margin of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | Gets or sets the maximum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | Gets or sets the maximum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | Gets or sets the minimum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | Gets or sets the minimum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from System.Windows.FrameworkElement)
Public Property | Node | Returns the item using this handle
Public Property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | Gets or sets the brush used to alter the opacity of regions of this object. (Inherited from System.Windows.UIElement)
Public Property | Padding | Gets or sets the padding inside a control. (Inherited from System.Windows.Controls.Control)
Public Property | Parent | Gets the parent object of this System.Windows.FrameworkElement in the object tree. (Inherited from System.Windows.FrameworkElement)
Public Property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderSize | Gets the final render size of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | Gets or sets transform information that affects the rendering position of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by System.Windows.UIElement.RenderTransform, relative to the bounds of the System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from System.Windows.FrameworkElement)
Public Property | Style | Gets or sets an instance System.Windows.Style that is applied for this object during rendering. (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | Gets or sets a value that modifies how tabbing and System.Windows.Controls.Control.TabIndex work for this control. (Inherited from System.Windows.Controls.Control)
Public Property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from System.Windows.FrameworkElement)
Public Property | Template | Gets or sets a control template. (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | Gets the collection of triggers for animations that are defined for a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from System.Windows.UIElement)
Public Property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | Gets or sets the visibility of a System.Windows.UIElement. A System.Windows.UIElement that is not visible does not render and does not communicate its desired size to layout. (Inherited from System.Windows.UIElement)
Public Property | Width | Gets or sets the width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Top
Protected Properties
 | Name | Description
Protected Property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from System.Windows.Controls.Control)
Top
See Also

Reference

RotateHandle Class
Lassalle.Silverlight.Flow Namespace


AddFlow Property (RotateHandle)

Lassalle.Silverlight.Flow Namespace > RotateHandle Class : AddFlow Property
The addflow canvas containing this node
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property AddFlow As AddFlow
'Usage

Dim instance As RotateHandle
Dim value As AddFlow

value = instance.AddFlow
public AddFlow AddFlow {get;}
public: __property AddFlow* get_AddFlow();
public:
property AddFlow^ AddFlow {
   AddFlow^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RotateHandle Class
RotateHandle Members


Node Property (RotateHandle)

Lassalle.Silverlight.Flow Namespace > RotateHandle Class : Node Property
Returns the item using this handle
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Node As Node
'Usage

Dim instance As RotateHandle
Dim value As Node

value = instance.Node
public Node Node {get;}
public: __property Node* get_Node();
public:
property Node^ Node {
   Node^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RotateHandle Class
RotateHandle Members


%%PageItemTitle%%

SelectedLinkStretchingEventArgs Class
Members

Lassalle.Silverlight.Flow Namespace : SelectedLinkStretchingEventArgs Class
Event parameters used for the SelectedLinkStretching event
Object Model
SelectedLinkStretchingEventArgs ClassLink Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class SelectedLinkStretchingEventArgs
   Inherits System.Windows.RoutedEventArgs
'Usage

Dim instance As SelectedLinkStretchingEventArgs
public class SelectedLinkStretchingEventArgs : System.Windows.RoutedEventArgs
public __gc class SelectedLinkStretchingEventArgs : public System.Windows.RoutedEventArgs
public ref class SelectedLinkStretchingEventArgs : public System.Windows.RoutedEventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
System.Windows.RoutedEventArgs
Lassalle.Silverlight.Flow.SelectedLinkStretchingEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelectedLinkStretchingEventArgs Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Members$$

SelectedLinkStretchingEventArgs Class Members
Properties

Lassalle.Silverlight.Flow Namespace : SelectedLinkStretchingEventArgs Class

The following tables list the members exposed by SelectedLinkStretchingEventArgs.

Public Constructors
 | Name | Description
Public Constructor | SelectedLinkStretchingEventArgs Constructor | Constructor. Creates a new SelectedLinkStretchingEventArgs instance.
Top
Public Properties
 | Name | Description
Public Property | Cancel | Gets/sets a value indicating whether the stretching action should be canceled.
Public Property | Link | The link being stretched (read-only)
Public Property | MousePosition | A Point specifying the mouse cursor position (read-only)
Public Property | OriginalSource | Gets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
Top
See Also

Reference

SelectedLinkStretchingEventArgs Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

SelectedLinkStretchingEventArgs Constructor

Lassalle.Silverlight.Flow Namespace > SelectedLinkStretchingEventArgs Class : SelectedLinkStretchingEventArgs Constructor
The link being stretched
A Point specifying the mouse cursor position
Constructor. Creates a new SelectedLinkStretchingEventArgs instance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal link As Link, _
   ByVal mousePosition As Point _
)
'Usage

Dim link As Link
Dim mousePosition As Point

Dim instance As New SelectedLinkStretchingEventArgs(link, mousePosition)
public SelectedLinkStretchingEventArgs(
   Link link,
   Point mousePosition
)
public: SelectedLinkStretchingEventArgs(
   Link* link,
   Point mousePosition
)
public:
SelectedLinkStretchingEventArgs(
   Link^ link,
   Point mousePosition
)

Parameters

link
The link being stretched
mousePosition
A Point specifying the mouse cursor position
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelectedLinkStretchingEventArgs Class
SelectedLinkStretchingEventArgs Members


%%PageItemTitle%% $$Properties$$

SelectedLinkStretchingEventArgs Class Properties

Lassalle.Silverlight.Flow Namespace : SelectedLinkStretchingEventArgs Class

For a list of all members of this type, see SelectedLinkStretchingEventArgs members.

Public Properties
 | Name | Description
Public Property | Cancel | Gets/sets a value indicating whether the stretching action should be canceled.
Public Property | Link | The link being stretched (read-only)
Public Property | MousePosition | A Point specifying the mouse cursor position (read-only)
Public Property | OriginalSource | Gets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
Top
See Also

Reference

SelectedLinkStretchingEventArgs Class
Lassalle.Silverlight.Flow Namespace


Cancel Property (SelectedLinkStretchingEventArgs)

Lassalle.Silverlight.Flow Namespace > SelectedLinkStretchingEventArgs Class : Cancel Property
Gets/sets a value indicating whether the stretching action should be canceled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Cancel As CancelEventArgs
'Usage

Dim instance As SelectedLinkStretchingEventArgs
Dim value As CancelEventArgs

instance.Cancel = value

value = instance.Cancel
public CancelEventArgs Cancel {get; set;}
public: __property CancelEventArgs* get_Cancel();
public: __property void set_Cancel(
   CancelEventArgs* value
);
public:
property CancelEventArgs^ Cancel {
   CancelEventArgs^ get();
   void set (    CancelEventArgs^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelectedLinkStretchingEventArgs Class
SelectedLinkStretchingEventArgs Members


Link Property (SelectedLinkStretchingEventArgs)

Lassalle.Silverlight.Flow Namespace > SelectedLinkStretchingEventArgs Class : Link Property
The link being stretched (read-only)
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Link As Link
'Usage

Dim instance As SelectedLinkStretchingEventArgs
Dim value As Link

value = instance.Link
public Link Link {get;}
public: __property Link* get_Link();
public:
property Link^ Link {
   Link^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelectedLinkStretchingEventArgs Class
SelectedLinkStretchingEventArgs Members


MousePosition Property (SelectedLinkStretchingEventArgs)

Lassalle.Silverlight.Flow Namespace > SelectedLinkStretchingEventArgs Class : MousePosition Property
A Point specifying the mouse cursor position (read-only)
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property MousePosition As Point
'Usage

Dim instance As SelectedLinkStretchingEventArgs
Dim value As Point

value = instance.MousePosition
public Point MousePosition {get;}
public: __property Point get_MousePosition();
public:
property Point MousePosition {
   Point get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelectedLinkStretchingEventArgs Class
SelectedLinkStretchingEventArgs Members


%%PageItemTitle%%

SelectedNodesLayoutingEventArgs Class
Members

Lassalle.Silverlight.Flow Namespace : SelectedNodesLayoutingEventArgs Class
Event parameters used for the SelectedNodesLayouting event
Object Model
SelectedNodesLayoutingEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class SelectedNodesLayoutingEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As SelectedNodesLayoutingEventArgs
public class SelectedNodesLayoutingEventArgs : System.EventArgs
public __gc class SelectedNodesLayoutingEventArgs : public System.EventArgs
public ref class SelectedNodesLayoutingEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Lassalle.Silverlight.Flow.SelectedNodesLayoutingEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelectedNodesLayoutingEventArgs Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Members$$

SelectedNodesLayoutingEventArgs Class Members
Properties

Lassalle.Silverlight.Flow Namespace : SelectedNodesLayoutingEventArgs Class

The following tables list the members exposed by SelectedNodesLayoutingEventArgs.

Public Constructors
 | Name | Description
Public Constructor | SelectedNodesLayoutingEventArgs Constructor | Constructor. Creates a new SelectedNodesLayoutingEventArgs instance.
Top
Public Properties
 | Name | Description
Public Property | Cancel | Gets/sets a value indicating whether the moving or resizing action should be canceled.
Public Property | MousePosition | A Point specifying the mouse cursor position (read-only)
Top
See Also

Reference

SelectedNodesLayoutingEventArgs Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

SelectedNodesLayoutingEventArgs Constructor

Lassalle.Silverlight.Flow Namespace > SelectedNodesLayoutingEventArgs Class : SelectedNodesLayoutingEventArgs Constructor
A Point specifying the mouse cursor position
Constructor. Creates a new SelectedNodesLayoutingEventArgs instance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal mousePosition As Point _
)
'Usage

Dim mousePosition As Point

Dim instance As New SelectedNodesLayoutingEventArgs(mousePosition)
public SelectedNodesLayoutingEventArgs(
   Point mousePosition
)
public: SelectedNodesLayoutingEventArgs(
   Point mousePosition
)
public:
SelectedNodesLayoutingEventArgs(
   Point mousePosition
)

Parameters

mousePosition
A Point specifying the mouse cursor position
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelectedNodesLayoutingEventArgs Class
SelectedNodesLayoutingEventArgs Members


%%PageItemTitle%% $$Properties$$

SelectedNodesLayoutingEventArgs Class Properties

Lassalle.Silverlight.Flow Namespace : SelectedNodesLayoutingEventArgs Class

For a list of all members of this type, see SelectedNodesLayoutingEventArgs members.

Public Properties
 | Name | Description
Public Property | Cancel | Gets/sets a value indicating whether the moving or resizing action should be canceled.
Public Property | MousePosition | A Point specifying the mouse cursor position (read-only)
Top
See Also

Reference

SelectedNodesLayoutingEventArgs Class
Lassalle.Silverlight.Flow Namespace


Cancel Property (SelectedNodesLayoutingEventArgs)

Lassalle.Silverlight.Flow Namespace > SelectedNodesLayoutingEventArgs Class : Cancel Property
Gets/sets a value indicating whether the moving or resizing action should be canceled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Cancel As CancelEventArgs
'Usage

Dim instance As SelectedNodesLayoutingEventArgs
Dim value As CancelEventArgs

instance.Cancel = value

value = instance.Cancel
public CancelEventArgs Cancel {get; set;}
public: __property CancelEventArgs* get_Cancel();
public: __property void set_Cancel(
   CancelEventArgs* value
);
public:
property CancelEventArgs^ Cancel {
   CancelEventArgs^ get();
   void set (    CancelEventArgs^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelectedNodesLayoutingEventArgs Class
SelectedNodesLayoutingEventArgs Members


MousePosition Property (SelectedNodesLayoutingEventArgs)

Lassalle.Silverlight.Flow Namespace > SelectedNodesLayoutingEventArgs Class : MousePosition Property
A Point specifying the mouse cursor position (read-only)
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property MousePosition As Point
'Usage

Dim instance As SelectedNodesLayoutingEventArgs
Dim value As Point

value = instance.MousePosition
public Point MousePosition {get;}
public: __property Point get_MousePosition();
public:
property Point MousePosition {
   Point get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelectedNodesLayoutingEventArgs Class
SelectedNodesLayoutingEventArgs Members


%%PageItemTitle%%

SelectedNodesRotatingEventArgs Class
Members

Lassalle.Silverlight.Flow Namespace : SelectedNodesRotatingEventArgs Class
Event parameters used for the SelectedNodesRotatingEventArgs event
Object Model
SelectedNodesRotatingEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class SelectedNodesRotatingEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As SelectedNodesRotatingEventArgs
public class SelectedNodesRotatingEventArgs : System.EventArgs
public __gc class SelectedNodesRotatingEventArgs : public System.EventArgs
public ref class SelectedNodesRotatingEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Lassalle.Silverlight.Flow.SelectedNodesRotatingEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelectedNodesRotatingEventArgs Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Members$$

SelectedNodesRotatingEventArgs Class Members
Properties

Lassalle.Silverlight.Flow Namespace : SelectedNodesRotatingEventArgs Class

The following tables list the members exposed by SelectedNodesRotatingEventArgs.

Public Constructors
 | Name | Description
Public Constructor | SelectedNodesRotatingEventArgs Constructor | Constructor. Creates a new SelectedNodesRotatingEventArgs instance.
Top
Public Properties
 | Name | Description
Public Property | Angle | A double specifying the rotation angle value (read-only)
Public Property | Cancel | Gets/sets a value indicating whether the moving or resizing action should be canceled.
Top
See Also

Reference

SelectedNodesRotatingEventArgs Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

SelectedNodesRotatingEventArgs Constructor

Lassalle.Silverlight.Flow Namespace > SelectedNodesRotatingEventArgs Class : SelectedNodesRotatingEventArgs Constructor
A double specifying the rotation angle value
Constructor. Creates a new SelectedNodesRotatingEventArgs instance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal angle As Double _
)
'Usage

Dim angle As Double

Dim instance As New SelectedNodesRotatingEventArgs(angle)
public SelectedNodesRotatingEventArgs(
   double angle
)
public: SelectedNodesRotatingEventArgs(
   double angle
)
public:
SelectedNodesRotatingEventArgs(
   double angle
)

Parameters

angle
A double specifying the rotation angle value
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelectedNodesRotatingEventArgs Class
SelectedNodesRotatingEventArgs Members


%%PageItemTitle%% $$Properties$$

SelectedNodesRotatingEventArgs Class Properties

Lassalle.Silverlight.Flow Namespace : SelectedNodesRotatingEventArgs Class

For a list of all members of this type, see SelectedNodesRotatingEventArgs members.

Public Properties
 | Name | Description
Public Property | Angle | A double specifying the rotation angle value (read-only)
Public Property | Cancel | Gets/sets a value indicating whether the moving or resizing action should be canceled.
Top
See Also

Reference

SelectedNodesRotatingEventArgs Class
Lassalle.Silverlight.Flow Namespace


Angle Property

Lassalle.Silverlight.Flow Namespace > SelectedNodesRotatingEventArgs Class : Angle Property
A double specifying the rotation angle value (read-only)
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Angle As Double
'Usage

Dim instance As SelectedNodesRotatingEventArgs
Dim value As Double

value = instance.Angle
public double Angle {get;}
public: __property double get_Angle();
public:
property double Angle {
   double get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelectedNodesRotatingEventArgs Class
SelectedNodesRotatingEventArgs Members


Cancel Property (SelectedNodesRotatingEventArgs)

Lassalle.Silverlight.Flow Namespace > SelectedNodesRotatingEventArgs Class : Cancel Property
Gets/sets a value indicating whether the moving or resizing action should be canceled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Cancel As CancelEventArgs
'Usage

Dim instance As SelectedNodesRotatingEventArgs
Dim value As CancelEventArgs

instance.Cancel = value

value = instance.Cancel
public CancelEventArgs Cancel {get; set;}
public: __property CancelEventArgs* get_Cancel();
public: __property void set_Cancel(
   CancelEventArgs* value
);
public:
property CancelEventArgs^ Cancel {
   CancelEventArgs^ get();
   void set (    CancelEventArgs^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelectedNodesRotatingEventArgs Class
SelectedNodesRotatingEventArgs Members


%%PageItemTitle%%

SelectionBox Class
Members

Lassalle.Silverlight.Flow Namespace : SelectionBox Class
The rectangle used when selecting items with the mouse.
Object Model
SelectionBox Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DesignTimeVisibleAttribute()>
Public Class SelectionBox
   Inherits System.Windows.Controls.Control
'Usage

Dim instance As SelectionBox
[DesignTimeVisibleAttribute()]
public class SelectionBox : System.Windows.Controls.Control
[DesignTimeVisibleAttribute()]
public __gc class SelectionBox : public System.Windows.Controls.Control
[DesignTimeVisibleAttribute()]
public ref class SelectionBox : public System.Windows.Controls.Control
Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
Lassalle.Silverlight.Flow.SelectionBox

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelectionBox Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Members$$

SelectionBox Class Members
Properties Methods Events

Lassalle.Silverlight.Flow Namespace : SelectionBox Class

The following tables list the members exposed by SelectionBox.

Public Constructors
 | Name | Description
Public Constructor | SelectionBox Constructor | SelectionBox constructor
Top
Public Properties
 | Name | Description
Public Property | ActualHeight | Gets the rendered height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | Gets the rendered width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | AllowDrop | Gets or sets a value that determines whether this System.Windows.UIElement can be a drop target for purposes of Silverlight drag-and-drop operations. (Inherited from System.Windows.UIElement)
Public Property | Background | Gets or sets a brush that provides the background of the control. (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from System.Windows.Controls.Control)
Public Property | CacheMode | Gets or sets a value that indicates that rendered content should be cached when possible. (Inherited from System.Windows.UIElement)
Public Property | CharacterSpacing | Gets or sets the distance between characters of text in the control measured in 1000ths of the font size. (Inherited from System.Windows.Controls.Control)
Public Property | Clip | Gets or sets the System.Windows.Media.Geometry used to define the outline of the contents of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | Cursor | Gets or sets the cursor image that displays while the mouse pointer is over a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | Gets or sets the data context for a System.Windows.FrameworkElement when it participates in data binding. (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | Gets the size that this System.Windows.UIElement computed during the measure pass of the layout process. (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | Gets the System.Windows.Threading.Dispatcher this object is associated with. (Inherited from System.Windows.DependencyObject)
Public Property | Effect | Gets or sets the pixel shader effect to use for rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | FlowDirection | Gets or sets the direction that text and other user interface elements flow within any parent element that controls their layout. (Inherited from System.Windows.FrameworkElement)
Public Property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | Gets or sets the size of the text in this control. (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from System.Windows.Controls.Control)
Public Property | Height | Gets or sets the suggested height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | Gets or sets whether the contained area of this System.Windows.UIElement can return true values for hit testing. (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from System.Windows.Controls.Control)
Public Property | Language | Gets or sets localization/globalization language information that applies to a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | Gets or sets the outer margin of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | Gets or sets the maximum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | Gets or sets the maximum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | Gets or sets the minimum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | Gets or sets the minimum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | Gets or sets the brush used to alter the opacity of regions of this object. (Inherited from System.Windows.UIElement)
Public Property | Padding | Gets or sets the padding inside a control. (Inherited from System.Windows.Controls.Control)
Public Property | Parent | Gets the parent object of this System.Windows.FrameworkElement in the object tree. (Inherited from System.Windows.FrameworkElement)
Public Property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderSize | Gets the final render size of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | Gets or sets transform information that affects the rendering position of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by System.Windows.UIElement.RenderTransform, relative to the bounds of the System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from System.Windows.FrameworkElement)
Public Property | Style | Gets or sets an instance System.Windows.Style that is applied for this object during rendering. (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | Gets or sets a value that modifies how tabbing and System.Windows.Controls.Control.TabIndex work for this control. (Inherited from System.Windows.Controls.Control)
Public Property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from System.Windows.FrameworkElement)
Public Property | Template | Gets or sets a control template. (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | Gets the collection of triggers for animations that are defined for a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from System.Windows.UIElement)
Public Property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | Gets or sets the visibility of a System.Windows.UIElement. A System.Windows.UIElement that is not visible does not render and does not communicate its desired size to layout. (Inherited from System.Windows.UIElement)
Public Property | Width | Gets or sets the width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Top
Protected Properties
 | Name | Description
Protected Property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from System.Windows.Controls.Control)
Top
Public Methods
 | Name | Description
Public Method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from System.Windows.UIElement)
Public Method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from System.Windows.Controls.Control)
Public Method | Arrange | Positions child objects and determines a size for a System.Windows.UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | CaptureMouse | Sets mouse capture to a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | ClearValue | Clears the local value of a dependency property. (Inherited from System.Windows.DependencyObject)
Public Method | FindName | Retrieves an object that has the specified identifier name. (Inherited from System.Windows.FrameworkElement)
Public Method | Focus | Attempts to set the focus on the control. (Inherited from System.Windows.Controls.Control)
Public Method | GetAnimationBaseValue | Returns any base value established for a Silverlight dependency property, which would apply in cases where an animation is not active. (Inherited from System.Windows.DependencyObject)
Public Method | GetBindingExpression | Retrieves the System.Windows.Data.BindingExpression for a dependency property where a binding is established. (Inherited from System.Windows.FrameworkElement)
Public Method | GetValue | Returns the current effective value of a dependency property from a System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateArrange | Invalidates the arrange state (layout) for a System.Windows.UIElement. After the invalidation, the System.Windows.UIElement will have its layout updated, which will occur asynchronously. (Inherited from System.Windows.UIElement)
Public Method | InvalidateMeasure | Invalidates the measurement state (layout) for a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | Measure | Updates the System.Windows.UIElement.DesiredSize of a System.Windows.UIElement. Typically, objects that implement custom layout for their layout children call this method from their own System.Windows.FrameworkElement.MeasureOverride(System.Windows.Size) implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call System.Windows.Controls.Control.ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in an application. For more information, see Remarks. (Inherited from System.Windows.FrameworkElement)
Public Method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from System.Windows.DependencyObject)
Public Method | ReleaseMouseCapture | Removes mouse capture from a System.Windows.UIElement. After this call, typically no object holds mouse capture. (Inherited from System.Windows.UIElement)
Public Method | RemoveHandler | Removes the specified routed event handler from this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | SetBinding | Attaches a binding to a System.Windows.FrameworkElement, using the provided binding object, and returns a System.Windows.Data.BindingExpressionBase for possible later use. (Inherited from System.Windows.FrameworkElement)
Public Method | SetValue | (Inherited from System.Windows.DependencyObject)
Public Method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the System.Windows.UIElement to the specified object. (Inherited from System.Windows.UIElement)
Public Method | UpdateLayout | Ensures that all positions of child objects of a System.Windows.UIElement are properly updated for layout. (Inherited from System.Windows.UIElement)
Top
Protected Methods
 | Name | Description
Protected Method | ArrangeOverride | (Inherited from System.Windows.FrameworkElement)
Protected Method | GetTemplateChild | Retrieves the named element in the instantiated System.Windows.Controls.ControlTemplate visual tree. (Inherited from System.Windows.Controls.Control)
Protected Method | MeasureOverride | (Inherited from System.Windows.FrameworkElement)
Protected Method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific System.Windows.Automation.Peers.AutomationPeer implementations for the Silverlight automation infrastructure. (Inherited from System.Windows.UIElement)
Protected Method | OnDragEnter | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDragLeave | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDragOver | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDrop | (Inherited from System.Windows.Controls.Control)
Protected Method | OnGotFocus | (Inherited from System.Windows.Controls.Control)
Protected Method | OnKeyDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnKeyUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnLostFocus | (Inherited from System.Windows.Controls.Control)
Protected Method | OnLostMouseCapture | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseEnter | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeave | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeftButtonDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeftButtonUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseMove | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseRightButtonDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseRightButtonUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseWheel | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInput | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInputStart | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInputUpdate | (Inherited from System.Windows.Controls.Control)
Top
Public Events
 | Name | Description
Public Event | BindingValidationError | Occurs when a data validation error is reported by a binding source. (Inherited from System.Windows.FrameworkElement)
Public Event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from System.Windows.FrameworkElement)
Public Event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from System.Windows.UIElement)
Public Event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from System.Windows.UIElement)
Public Event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from System.Windows.UIElement)
Public Event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from System.Windows.UIElement)
Public Event | GotFocus | Occurs when a System.Windows.UIElement receives focus. (Inherited from System.Windows.UIElement)
Public Event | IsEnabledChanged | Occurs when the System.Windows.Controls.Control.IsEnabled property changes. (Inherited from System.Windows.Controls.Control)
Public Event | KeyDown | Occurs when a keyboard key is pressed while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | KeyUp | Occurs when a keyboard key is released while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | Occurs when the layout of the Silverlight visual tree changes. (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | Occurs when a System.Windows.FrameworkElement has been constructed and added to the object tree. (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | Occurs when a System.Windows.UIElement loses focus. (Inherited from System.Windows.UIElement)
Public Event | LostMouseCapture | Occurs when the System.Windows.UIElement loses mouse capture. (Inherited from System.Windows.UIElement)
Public Event | MediaCommand | Occurs when a button is pressed on a remote control. (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | Occurs when the mouse (or a stylus) enters the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | Occurs when the mouse (or the stylus) leaves the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | Occurs when the left mouse button is pressed (or when the tip of the stylus touches the tablet) while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | Occurs when the left mouse button is released (or the tip of the stylus is removed from the tablet) while the mouse (or the stylus) is over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseMove | Occurs when the coordinate position of the mouse (or stylus) changes while over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over a System.Windows.UIElement. However, this event will only be raised if a caller marks the preceding System.Windows.UIElement.MouseRightButtonDown event as handled; see Remarks. (Inherited from System.Windows.UIElement)
Public Event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over a System.Windows.UIElement, or the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | Occurs when either the System.Windows.FrameworkElement.ActualHeight or the System.Windows.FrameworkElement.ActualWidth properties change value on a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Event | TextInput | Occurs when a UI element gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputStart | Occurs when a UI element initially gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputUpdate | Occurs when text continues to be composed via an input method editor (IME). (Inherited from System.Windows.UIElement)
Public Event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from System.Windows.FrameworkElement)
Top
See Also

Reference

SelectionBox Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

SelectionBox Constructor

Lassalle.Silverlight.Flow Namespace > SelectionBox Class : SelectionBox Constructor
SelectionBox constructor
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New SelectionBox()
public SelectionBox()
public: SelectionBox();
public:
SelectionBox();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelectionBox Class
SelectionBox Members


%%PageItemTitle%%

SelectionChangedEventArgs Class
Members

Lassalle.Silverlight.Flow Namespace : SelectionChangedEventArgs Class
Event parameters used for the SelectionChanged event
Object Model
SelectionChangedEventArgs ClassISelectable Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class SelectionChangedEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As SelectionChangedEventArgs
public class SelectionChangedEventArgs : System.EventArgs
public __gc class SelectionChangedEventArgs : public System.EventArgs
public ref class SelectionChangedEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Lassalle.Silverlight.Flow.SelectionChangedEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelectionChangedEventArgs Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Members$$

SelectionChangedEventArgs Class Members
Properties

Lassalle.Silverlight.Flow Namespace : SelectionChangedEventArgs Class

The following tables list the members exposed by SelectionChangedEventArgs.

Public Constructors
 | Name | Description
Public Constructor | SelectionChangedEventArgs Constructor | Constructor. Creates a new SelectionChangedEventArgs instance.
Top
Public Properties
 | Name | Description
Public Property | Item | The item whose selection status has changed (read-only)
Top
See Also

Reference

SelectionChangedEventArgs Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

SelectionChangedEventArgs Constructor

Lassalle.Silverlight.Flow Namespace > SelectionChangedEventArgs Class : SelectionChangedEventArgs Constructor
The item whose selection status has changed
Constructor. Creates a new SelectionChangedEventArgs instance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal item As ISelectable _
)
'Usage

Dim item As ISelectable

Dim instance As New SelectionChangedEventArgs(item)
public SelectionChangedEventArgs(
   ISelectable item
)
public: SelectionChangedEventArgs(
   ISelectable* item
)
public:
SelectionChangedEventArgs(
   ISelectable^ item
)

Parameters

item
The item whose selection status has changed
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelectionChangedEventArgs Class
SelectionChangedEventArgs Members


%%PageItemTitle%% $$Properties$$

SelectionChangedEventArgs Class Properties

Lassalle.Silverlight.Flow Namespace : SelectionChangedEventArgs Class

For a list of all members of this type, see SelectionChangedEventArgs members.

Public Properties
 | Name | Description
Public Property | Item | The item whose selection status has changed (read-only)
Top
See Also

Reference

SelectionChangedEventArgs Class
Lassalle.Silverlight.Flow Namespace


Item Property (SelectionChangedEventArgs)

Lassalle.Silverlight.Flow Namespace > SelectionChangedEventArgs Class : Item Property
The item whose selection status has changed (read-only)
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Item As ISelectable
'Usage

Dim instance As SelectionChangedEventArgs
Dim value As ISelectable

value = instance.Item
public ISelectable Item {get;}
public: __property ISelectable* get_Item();
public:
property ISelectable^ Item {
   ISelectable^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelectionChangedEventArgs Class
SelectionChangedEventArgs Members


%%PageItemTitle%%

StretchHandle Class
Members

Lassalle.Silverlight.Flow Namespace : StretchHandle Class
Represents a stretching handle of a link.
Object Model
StretchHandle ClassAddFlow ClassLink Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DesignTimeVisibleAttribute()>
<TemplateVisualStateAttribute(Name="MouseOver", GroupName="CommonStates")>
<TemplateVisualStateAttribute(Name="Normal", GroupName="CommonStates")>
Public Class StretchHandle
   Inherits System.Windows.Controls.Control
'Usage

Dim instance As StretchHandle
[DesignTimeVisibleAttribute()]
[TemplateVisualStateAttribute(Name="MouseOver", GroupName="CommonStates")]
[TemplateVisualStateAttribute(Name="Normal", GroupName="CommonStates")]
public class StretchHandle : System.Windows.Controls.Control
[DesignTimeVisibleAttribute()]
[TemplateVisualStateAttribute(Name="MouseOver", GroupName="CommonStates")]
[TemplateVisualStateAttribute(Name="Normal", GroupName="CommonStates")]
public __gc class StretchHandle : public System.Windows.Controls.Control
[DesignTimeVisibleAttribute()]
[TemplateVisualStateAttribute(Name="MouseOver", GroupName="CommonStates")]
[TemplateVisualStateAttribute(Name="Normal", GroupName="CommonStates")]
public ref class StretchHandle : public System.Windows.Controls.Control
Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
Lassalle.Silverlight.Flow.StretchHandle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StretchHandle Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Members$$

StretchHandle Class Members
Properties Methods Events

Lassalle.Silverlight.Flow Namespace : StretchHandle Class

The following tables list the members exposed by StretchHandle.

Public Constructors
 | Name | Description
Public Constructor | StretchHandle Constructor | StretchHandle constructor
Top
Public Properties
 | Name | Description
Public Property | ActualHeight | Gets the rendered height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | Gets the rendered width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | AddFlow | The addflow canvas containing this node
Public Property | AllowDrop | Gets or sets a value that determines whether this System.Windows.UIElement can be a drop target for purposes of Silverlight drag-and-drop operations. (Inherited from System.Windows.UIElement)
Public Property | Background | Gets or sets a brush that provides the background of the control. (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from System.Windows.Controls.Control)
Public Property | CacheMode | Gets or sets a value that indicates that rendered content should be cached when possible. (Inherited from System.Windows.UIElement)
Public Property | CharacterSpacing | Gets or sets the distance between characters of text in the control measured in 1000ths of the font size. (Inherited from System.Windows.Controls.Control)
Public Property | Clip | Gets or sets the System.Windows.Media.Geometry used to define the outline of the contents of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | Cursor | Gets or sets the cursor image that displays while the mouse pointer is over a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | Gets or sets the data context for a System.Windows.FrameworkElement when it participates in data binding. (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | Gets the size that this System.Windows.UIElement computed during the measure pass of the layout process. (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | Gets the System.Windows.Threading.Dispatcher this object is associated with. (Inherited from System.Windows.DependencyObject)
Public Property | Effect | Gets or sets the pixel shader effect to use for rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | FlowDirection | Gets or sets the direction that text and other user interface elements flow within any parent element that controls their layout. (Inherited from System.Windows.FrameworkElement)
Public Property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | Gets or sets the size of the text in this control. (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from System.Windows.Controls.Control)
Public Property | Height | Gets or sets the suggested height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | Gets or sets whether the contained area of this System.Windows.UIElement can return true values for hit testing. (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from System.Windows.Controls.Control)
Public Property | Language | Gets or sets localization/globalization language information that applies to a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | Link | Returns the link using this handle
Public Property | Margin | Gets or sets the outer margin of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | Gets or sets the maximum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | Gets or sets the maximum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | Gets or sets the minimum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | Gets or sets the minimum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | Gets or sets the brush used to alter the opacity of regions of this object. (Inherited from System.Windows.UIElement)
Public Property | Padding | Gets or sets the padding inside a control. (Inherited from System.Windows.Controls.Control)
Public Property | Parent | Gets the parent object of this System.Windows.FrameworkElement in the object tree. (Inherited from System.Windows.FrameworkElement)
Public Property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderSize | Gets the final render size of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | Gets or sets transform information that affects the rendering position of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by System.Windows.UIElement.RenderTransform, relative to the bounds of the System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from System.Windows.FrameworkElement)
Public Property | Style | Gets or sets an instance System.Windows.Style that is applied for this object during rendering. (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | Gets or sets a value that modifies how tabbing and System.Windows.Controls.Control.TabIndex work for this control. (Inherited from System.Windows.Controls.Control)
Public Property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from System.Windows.FrameworkElement)
Public Property | Template | Gets or sets a control template. (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | Gets the collection of triggers for animations that are defined for a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from System.Windows.UIElement)
Public Property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | Gets or sets the visibility of a System.Windows.UIElement. A System.Windows.UIElement that is not visible does not render and does not communicate its desired size to layout. (Inherited from System.Windows.UIElement)
Public Property | Width | Gets or sets the width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Top
Protected Properties
 | Name | Description
Protected Property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from System.Windows.Controls.Control)
Top
Public Methods
 | Name | Description
Public Method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from System.Windows.UIElement)
Public Method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from System.Windows.Controls.Control)
Public Method | Arrange | Positions child objects and determines a size for a System.Windows.UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | CaptureMouse | Sets mouse capture to a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | ClearValue | Clears the local value of a dependency property. (Inherited from System.Windows.DependencyObject)
Public Method | FindName | Retrieves an object that has the specified identifier name. (Inherited from System.Windows.FrameworkElement)
Public Method | Focus | Attempts to set the focus on the control. (Inherited from System.Windows.Controls.Control)
Public Method | GetAnimationBaseValue | Returns any base value established for a Silverlight dependency property, which would apply in cases where an animation is not active. (Inherited from System.Windows.DependencyObject)
Public Method | GetBindingExpression | Retrieves the System.Windows.Data.BindingExpression for a dependency property where a binding is established. (Inherited from System.Windows.FrameworkElement)
Public Method | GetValue | Returns the current effective value of a dependency property from a System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateArrange | Invalidates the arrange state (layout) for a System.Windows.UIElement. After the invalidation, the System.Windows.UIElement will have its layout updated, which will occur asynchronously. (Inherited from System.Windows.UIElement)
Public Method | InvalidateMeasure | Invalidates the measurement state (layout) for a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | Measure | Updates the System.Windows.UIElement.DesiredSize of a System.Windows.UIElement. Typically, objects that implement custom layout for their layout children call this method from their own System.Windows.FrameworkElement.MeasureOverride(System.Windows.Size) implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call System.Windows.Controls.Control.ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in an application. For more information, see Remarks. (Inherited from System.Windows.FrameworkElement)
Public Method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from System.Windows.DependencyObject)
Public Method | ReleaseMouseCapture | Removes mouse capture from a System.Windows.UIElement. After this call, typically no object holds mouse capture. (Inherited from System.Windows.UIElement)
Public Method | RemoveHandler | Removes the specified routed event handler from this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | SetBinding | Attaches a binding to a System.Windows.FrameworkElement, using the provided binding object, and returns a System.Windows.Data.BindingExpressionBase for possible later use. (Inherited from System.Windows.FrameworkElement)
Public Method | SetValue | (Inherited from System.Windows.DependencyObject)
Public Method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the System.Windows.UIElement to the specified object. (Inherited from System.Windows.UIElement)
Public Method | UpdateLayout | Ensures that all positions of child objects of a System.Windows.UIElement are properly updated for layout. (Inherited from System.Windows.UIElement)
Top
Protected Methods
 | Name | Description
Protected Method | ArrangeOverride | (Inherited from System.Windows.FrameworkElement)
Protected Method | GetTemplateChild | Retrieves the named element in the instantiated System.Windows.Controls.ControlTemplate visual tree. (Inherited from System.Windows.Controls.Control)
Protected Method | MeasureOverride | (Inherited from System.Windows.FrameworkElement)
Protected Method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific System.Windows.Automation.Peers.AutomationPeer implementations for the Silverlight automation infrastructure. (Inherited from System.Windows.UIElement)
Protected Method | OnDragEnter | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDragLeave | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDragOver | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDrop | (Inherited from System.Windows.Controls.Control)
Protected Method | OnGotFocus | (Inherited from System.Windows.Controls.Control)
Protected Method | OnKeyDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnKeyUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnLostFocus | (Inherited from System.Windows.Controls.Control)
Protected Method | OnLostMouseCapture | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseEnter | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeave | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeftButtonDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeftButtonUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseMove | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseRightButtonDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseRightButtonUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseWheel | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInput | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInputStart | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInputUpdate | (Inherited from System.Windows.Controls.Control)
Top
Public Events
 | Name | Description
Public Event | BindingValidationError | Occurs when a data validation error is reported by a binding source. (Inherited from System.Windows.FrameworkElement)
Public Event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from System.Windows.FrameworkElement)
Public Event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from System.Windows.UIElement)
Public Event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from System.Windows.UIElement)
Public Event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from System.Windows.UIElement)
Public Event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from System.Windows.UIElement)
Public Event | GotFocus | Occurs when a System.Windows.UIElement receives focus. (Inherited from System.Windows.UIElement)
Public Event | IsEnabledChanged | Occurs when the System.Windows.Controls.Control.IsEnabled property changes. (Inherited from System.Windows.Controls.Control)
Public Event | KeyDown | Occurs when a keyboard key is pressed while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | KeyUp | Occurs when a keyboard key is released while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | Occurs when the layout of the Silverlight visual tree changes. (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | Occurs when a System.Windows.FrameworkElement has been constructed and added to the object tree. (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | Occurs when a System.Windows.UIElement loses focus. (Inherited from System.Windows.UIElement)
Public Event | LostMouseCapture | Occurs when the System.Windows.UIElement loses mouse capture. (Inherited from System.Windows.UIElement)
Public Event | MediaCommand | Occurs when a button is pressed on a remote control. (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | Occurs when the mouse (or a stylus) enters the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | Occurs when the mouse (or the stylus) leaves the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | Occurs when the left mouse button is pressed (or when the tip of the stylus touches the tablet) while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | Occurs when the left mouse button is released (or the tip of the stylus is removed from the tablet) while the mouse (or the stylus) is over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseMove | Occurs when the coordinate position of the mouse (or stylus) changes while over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over a System.Windows.UIElement. However, this event will only be raised if a caller marks the preceding System.Windows.UIElement.MouseRightButtonDown event as handled; see Remarks. (Inherited from System.Windows.UIElement)
Public Event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over a System.Windows.UIElement, or the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | Occurs when either the System.Windows.FrameworkElement.ActualHeight or the System.Windows.FrameworkElement.ActualWidth properties change value on a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Event | TextInput | Occurs when a UI element gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputStart | Occurs when a UI element initially gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputUpdate | Occurs when text continues to be composed via an input method editor (IME). (Inherited from System.Windows.UIElement)
Public Event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from System.Windows.FrameworkElement)
Top
See Also

Reference

StretchHandle Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

StretchHandle Constructor

Lassalle.Silverlight.Flow Namespace > StretchHandle Class : StretchHandle Constructor
StretchHandle constructor
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New StretchHandle()
public StretchHandle()
public: StretchHandle();
public:
StretchHandle();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StretchHandle Class
StretchHandle Members


%%PageItemTitle%% $$Properties$$

StretchHandle Class Properties

Lassalle.Silverlight.Flow Namespace : StretchHandle Class

For a list of all members of this type, see StretchHandle members.

Public Properties
 | Name | Description
Public Property | ActualHeight | Gets the rendered height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | Gets the rendered width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | AddFlow | The addflow canvas containing this node
Public Property | AllowDrop | Gets or sets a value that determines whether this System.Windows.UIElement can be a drop target for purposes of Silverlight drag-and-drop operations. (Inherited from System.Windows.UIElement)
Public Property | Background | Gets or sets a brush that provides the background of the control. (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from System.Windows.Controls.Control)
Public Property | CacheMode | Gets or sets a value that indicates that rendered content should be cached when possible. (Inherited from System.Windows.UIElement)
Public Property | CharacterSpacing | Gets or sets the distance between characters of text in the control measured in 1000ths of the font size. (Inherited from System.Windows.Controls.Control)
Public Property | Clip | Gets or sets the System.Windows.Media.Geometry used to define the outline of the contents of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | Cursor | Gets or sets the cursor image that displays while the mouse pointer is over a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | Gets or sets the data context for a System.Windows.FrameworkElement when it participates in data binding. (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | Gets the size that this System.Windows.UIElement computed during the measure pass of the layout process. (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | Gets the System.Windows.Threading.Dispatcher this object is associated with. (Inherited from System.Windows.DependencyObject)
Public Property | Effect | Gets or sets the pixel shader effect to use for rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | FlowDirection | Gets or sets the direction that text and other user interface elements flow within any parent element that controls their layout. (Inherited from System.Windows.FrameworkElement)
Public Property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | Gets or sets the size of the text in this control. (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from System.Windows.Controls.Control)
Public Property | Height | Gets or sets the suggested height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | Gets or sets whether the contained area of this System.Windows.UIElement can return true values for hit testing. (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from System.Windows.Controls.Control)
Public Property | Language | Gets or sets localization/globalization language information that applies to a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | Link | Returns the link using this handle
Public Property | Margin | Gets or sets the outer margin of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | Gets or sets the maximum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | Gets or sets the maximum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | Gets or sets the minimum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | Gets or sets the minimum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | Gets or sets the brush used to alter the opacity of regions of this object. (Inherited from System.Windows.UIElement)
Public Property | Padding | Gets or sets the padding inside a control. (Inherited from System.Windows.Controls.Control)
Public Property | Parent | Gets the parent object of this System.Windows.FrameworkElement in the object tree. (Inherited from System.Windows.FrameworkElement)
Public Property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderSize | Gets the final render size of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | Gets or sets transform information that affects the rendering position of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by System.Windows.UIElement.RenderTransform, relative to the bounds of the System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from System.Windows.FrameworkElement)
Public Property | Style | Gets or sets an instance System.Windows.Style that is applied for this object during rendering. (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | Gets or sets a value that modifies how tabbing and System.Windows.Controls.Control.TabIndex work for this control. (Inherited from System.Windows.Controls.Control)
Public Property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from System.Windows.FrameworkElement)
Public Property | Template | Gets or sets a control template. (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | Gets the collection of triggers for animations that are defined for a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from System.Windows.UIElement)
Public Property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | Gets or sets the visibility of a System.Windows.UIElement. A System.Windows.UIElement that is not visible does not render and does not communicate its desired size to layout. (Inherited from System.Windows.UIElement)
Public Property | Width | Gets or sets the width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Top
Protected Properties
 | Name | Description
Protected Property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from System.Windows.Controls.Control)
Top
See Also

Reference

StretchHandle Class
Lassalle.Silverlight.Flow Namespace


AddFlow Property (StretchHandle)

Lassalle.Silverlight.Flow Namespace > StretchHandle Class : AddFlow Property
The addflow canvas containing this node
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property AddFlow As AddFlow
'Usage

Dim instance As StretchHandle
Dim value As AddFlow

value = instance.AddFlow
public AddFlow AddFlow {get;}
public: __property AddFlow* get_AddFlow();
public:
property AddFlow^ AddFlow {
   AddFlow^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StretchHandle Class
StretchHandle Members


Link Property (StretchHandle)

Lassalle.Silverlight.Flow Namespace > StretchHandle Class : Link Property
Returns the link using this handle
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Link As Link
'Usage

Dim instance As StretchHandle
Dim value As Link

value = instance.Link
public Link Link {get;}
public: __property Link* get_Link();
public:
property Link^ Link {
   Link^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StretchHandle Class
StretchHandle Members


%%PageItemTitle%%

Task Class
Members

Lassalle.Silverlight.Flow Namespace : Task Class
Represents an action that can be undone and redone.
Object Model
Task Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class Task
'Usage

Dim instance As Task
public abstract class Task
public __gc abstract class Task
public ref class Task abstract
Remarks
This class is an abstract class which defines the interface expected by the AddFlow undo manager for undoing or redoing actions. The Undo and Redo methods are abstract and must be implemented by derived classes.
Inheritance Hierarchy

System.Object
Lassalle.Silverlight.Flow.Task

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Task Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Members$$

Task Class Members
Properties Methods

Lassalle.Silverlight.Flow Namespace : Task Class

The following tables list the members exposed by Task.

Public Properties
 | Name | Description
Public Property | Code | A Code allowing identifying an action
Top
Public Methods
 | Name | Description
Public Method | Redo | Allows redoing the action
Public Method | Undo | Allows undoing the action
Top
See Also

Reference

Task Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Methods$$

Task Class Methods

Lassalle.Silverlight.Flow Namespace : Task Class

For a list of all members of this type, see Task members.

Public Methods
 | Name | Description
Public Method | Redo | Allows redoing the action
Public Method | Undo | Allows undoing the action
Top
See Also

Reference

Task Class
Lassalle.Silverlight.Flow Namespace


Redo Method (Task)

Lassalle.Silverlight.Flow Namespace > Task Class : Redo Method
Allows redoing the action
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub Redo()
'Usage

Dim instance As Task

instance.Redo()
public virtual void Redo()
public: virtual void Redo();
public:
virtual void Redo();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Task Class
Task Members


Undo Method (Task)

Lassalle.Silverlight.Flow Namespace > Task Class : Undo Method
Allows undoing the action
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub Undo()
'Usage

Dim instance As Task

instance.Undo()
public virtual void Undo()
public: virtual void Undo();
public:
virtual void Undo();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Task Class
Task Members


%%PageItemTitle%% $$Properties$$

Task Class Properties

Lassalle.Silverlight.Flow Namespace : Task Class

For a list of all members of this type, see Task members.

Public Properties
 | Name | Description
Public Property | Code | A Code allowing identifying an action
Top
See Also

Reference

Task Class
Lassalle.Silverlight.Flow Namespace


Code Property

Lassalle.Silverlight.Flow Namespace > Task Class : Code Property
A Code allowing identifying an action
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Code As Action
'Usage

Dim instance As Task
Dim value As Action

instance.Code = value

value = instance.Code
public Action Code {get; set;}
public: __property Action get_Code();
public: __property void set_Code(
   Action value
);
public:
property Action Code {
   Action get();
   void set (    Action value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Task Class
Task Members


%%PageItemTitle%%

TaskManager Class
Members

Lassalle.Silverlight.Flow Namespace : TaskManager Class
The class managing the list of tasks and allowing undo/redo.
Object Model
TaskManager Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class TaskManager
'Usage

Dim instance As TaskManager
public class TaskManager
public __gc class TaskManager
public ref class TaskManager
Inheritance Hierarchy

System.Object
Lassalle.Silverlight.Flow.TaskManager

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TaskManager Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Members$$

TaskManager Class Members
Properties Methods

Lassalle.Silverlight.Flow Namespace : TaskManager Class

The following tables list the members exposed by TaskManager.

Public Constructors
 | Name | Description
Public Constructor | TaskManager Constructor | TaskManager constructor
Top
Public Properties
 | Name | Description
Public Property | CanRedo | Indicates if there is an action that can be redone.
Public Property | CanUndo | Indicates if there is an action that can be undone.
Public Property | CanUndoRedo | Determines whether undo/redo is allowed.
Public Property | RedoCode | Returns the code of the next redoable action.
Public Property | RedoItem | Returns the item involved in the next redoable action.
Public Property | SkipUndo | Determines whether the next actions are recorded in the task manager.
Public Property | UndoCode | Returns the code of the next undoable action.
Public Property | UndoItem | Returns the item involved in the next undoable action.
Public Property | UndoLimit | Returns/sets the number of undo commands that can be performed.
Top
Public Methods
 | Name | Description
Public Method | AddToLastAction | Add the following actions in the last group of actions. This "add" mode will terminate when calling EndAction.
Public Method | BeginAction | Start a group of actions that can be undone in one time.
Public Method | Clear | Clears the undo/redo buffer.
Public Method | EndAction | Terminate a group of actions that can be undone in one time.
Public Method | Redo | Redo, if possible, the last action.
Public Method | RemoveLastTask | Remove the last task that has been added in the undo/redo buffer.
Public Method | SubmitTask | Submit a task (or action) that can be undone and redone.
Public Method | Undo | Undo the last action performed in AddFlow.
Top
See Also

Reference

TaskManager Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

TaskManager Constructor

Lassalle.Silverlight.Flow Namespace > TaskManager Class : TaskManager Constructor
TaskManager constructor
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New TaskManager()
public TaskManager()
public: TaskManager();
public:
TaskManager();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TaskManager Class
TaskManager Members


%%PageItemTitle%% $$Methods$$

TaskManager Class Methods

Lassalle.Silverlight.Flow Namespace : TaskManager Class

For a list of all members of this type, see TaskManager members.

Public Methods
 | Name | Description
Public Method | AddToLastAction | Add the following actions in the last group of actions. This "add" mode will terminate when calling EndAction.
Public Method | BeginAction | Start a group of actions that can be undone in one time.
Public Method | Clear | Clears the undo/redo buffer.
Public Method | EndAction | Terminate a group of actions that can be undone in one time.
Public Method | Redo | Redo, if possible, the last action.
Public Method | RemoveLastTask | Remove the last task that has been added in the undo/redo buffer.
Public Method | SubmitTask | Submit a task (or action) that can be undone and redone.
Public Method | Undo | Undo the last action performed in AddFlow.
Top
See Also

Reference

TaskManager Class
Lassalle.Silverlight.Flow Namespace


AddToLastAction Method

Lassalle.Silverlight.Flow Namespace > TaskManager Class : AddToLastAction Method
Add the following actions in the last group of actions. This "add" mode will terminate when calling EndAction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AddToLastAction()
'Usage

Dim instance As TaskManager

instance.AddToLastAction()
public void AddToLastAction()
public: void AddToLastAction();
public:
void AddToLastAction();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TaskManager Class
TaskManager Members


BeginAction Method

Lassalle.Silverlight.Flow Namespace > TaskManager Class : BeginAction Method
An integer that must be > 1000. This code allows to identify a group of action. This code is returned by the UndoCode and RedoCode properties.
Start a group of actions that can be undone in one time.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub BeginAction( _
   ByVal code As Integer _
)
'Usage

Dim instance As TaskManager
Dim code As Integer

instance.BeginAction(code)
public void BeginAction(
   int code
)
public: void BeginAction(
   int code
)
public:
void BeginAction(
   int code
)

Parameters

code
An integer that must be > 1000. This code allows to identify a group of action. This code is returned by the UndoCode and RedoCode properties.
Example
For instance, if, in your application, the user can open a dialog box allowing to change the image of the node, its color and its Text property, you will probably allow that user to undo these 3 basic actions in one time. To do that, add a call to BeginAction before invoking the dialog box and a call to EndAction just after the dialog box termination.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TaskManager Class
TaskManager Members


Clear Method (TaskManager)

Lassalle.Silverlight.Flow Namespace > TaskManager Class : Clear Method
Clears the undo/redo buffer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Clear()
'Usage

Dim instance As TaskManager

instance.Clear()
public void Clear()
public: void Clear();
public:
void Clear();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TaskManager Class
TaskManager Members


EndAction Method

Lassalle.Silverlight.Flow Namespace > TaskManager Class : EndAction Method
Terminate a group of actions that can be undone in one time.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub EndAction()
'Usage

Dim instance As TaskManager

instance.EndAction()
public void EndAction()
public: void EndAction();
public:
void EndAction();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TaskManager Class
TaskManager Members


Redo Method (TaskManager)

Lassalle.Silverlight.Flow Namespace > TaskManager Class : Redo Method
Redo, if possible, the last action.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Redo()
'Usage

Dim instance As TaskManager

instance.Redo()
public void Redo()
public: void Redo();
public:
void Redo();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TaskManager Class
TaskManager Members


RemoveLastTask Method

Lassalle.Silverlight.Flow Namespace > TaskManager Class : RemoveLastTask Method
Remove the last task that has been added in the undo/redo buffer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RemoveLastTask()
'Usage

Dim instance As TaskManager

instance.RemoveLastTask()
public void RemoveLastTask()
public: void RemoveLastTask();
public:
void RemoveLastTask();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TaskManager Class
TaskManager Members


SubmitTask Method

Lassalle.Silverlight.Flow Namespace > TaskManager Class : SubmitTask Method
A task to include in the undo list
Submit a task (or action) that can be undone and redone.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SubmitTask( _
   ByVal task As Task _
)
'Usage

Dim instance As TaskManager
Dim task As Task

instance.SubmitTask(task)
public void SubmitTask(
   Task task
)
public: void SubmitTask(
   Task* task
)
public:
void SubmitTask(
   Task^ task
)

Parameters

task
A task to include in the undo list
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TaskManager Class
TaskManager Members


Undo Method (TaskManager)

Lassalle.Silverlight.Flow Namespace > TaskManager Class : Undo Method
Undo the last action performed in AddFlow.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Undo()
'Usage

Dim instance As TaskManager

instance.Undo()
public void Undo()
public: void Undo();
public:
void Undo();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TaskManager Class
TaskManager Members


%%PageItemTitle%% $$Properties$$

TaskManager Class Properties

Lassalle.Silverlight.Flow Namespace : TaskManager Class

For a list of all members of this type, see TaskManager members.

Public Properties
 | Name | Description
Public Property | CanRedo | Indicates if there is an action that can be redone.
Public Property | CanUndo | Indicates if there is an action that can be undone.
Public Property | CanUndoRedo | Determines whether undo/redo is allowed.
Public Property | RedoCode | Returns the code of the next redoable action.
Public Property | RedoItem | Returns the item involved in the next redoable action.
Public Property | SkipUndo | Determines whether the next actions are recorded in the task manager.
Public Property | UndoCode | Returns the code of the next undoable action.
Public Property | UndoItem | Returns the item involved in the next undoable action.
Public Property | UndoLimit | Returns/sets the number of undo commands that can be performed.
Top
See Also

Reference

TaskManager Class
Lassalle.Silverlight.Flow Namespace


CanRedo Property

Lassalle.Silverlight.Flow Namespace > TaskManager Class : CanRedo Property
Indicates if there is an action that can be redone.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property CanRedo As Boolean
'Usage

Dim instance As TaskManager
Dim value As Boolean

value = instance.CanRedo
public bool CanRedo {get;}
public: __property bool get_CanRedo();
public:
property bool CanRedo {
   bool get();
}
Remarks
Typically, this method allows to enable or disable the "Redo" menu item of your application.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TaskManager Class
TaskManager Members


CanUndo Property

Lassalle.Silverlight.Flow Namespace > TaskManager Class : CanUndo Property
Indicates if there is an action that can be undone.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property CanUndo As Boolean
'Usage

Dim instance As TaskManager
Dim value As Boolean

value = instance.CanUndo
public bool CanUndo {get;}
public: __property bool get_CanUndo();
public:
property bool CanUndo {
   bool get();
}
Remarks
Typically, this method allows to enable or disable the "Undo" menu item of your application.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TaskManager Class
TaskManager Members


CanUndoRedo Property

Lassalle.Silverlight.Flow Namespace > TaskManager Class : CanUndoRedo Property
Determines whether undo/redo is allowed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CanUndoRedo As Boolean
'Usage

Dim instance As TaskManager
Dim value As Boolean

instance.CanUndoRedo = value

value = instance.CanUndoRedo
public bool CanUndoRedo {get; set;}
public: __property bool get_CanUndoRedo();
public: __property void set_CanUndoRedo(
   bool value
);
public:
property bool CanUndoRedo {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TaskManager Class
TaskManager Members


RedoCode Property

Lassalle.Silverlight.Flow Namespace > TaskManager Class : RedoCode Property
Returns the code of the next redoable action.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property RedoCode As Action
'Usage

Dim instance As TaskManager
Dim value As Action

value = instance.RedoCode
public Action RedoCode {get;}
public: __property Action get_RedoCode();
public:
property Action RedoCode {
   Action get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TaskManager Class
TaskManager Members


RedoItem Property

Lassalle.Silverlight.Flow Namespace > TaskManager Class : RedoItem Property
Returns the item involved in the next redoable action.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property RedoItem As UIElement
'Usage

Dim instance As TaskManager
Dim value As UIElement

value = instance.RedoItem
public UIElement RedoItem {get;}
public: __property UIElement* get_RedoItem();
public:
property UIElement^ RedoItem {
   UIElement^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TaskManager Class
TaskManager Members


SkipUndo Property

Lassalle.Silverlight.Flow Namespace > TaskManager Class : SkipUndo Property
Determines whether the next actions are recorded in the task manager.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SkipUndo As Boolean
'Usage

Dim instance As TaskManager
Dim value As Boolean

instance.SkipUndo = value

value = instance.SkipUndo
public bool SkipUndo {get; set;}
public: __property bool get_SkipUndo();
public: __property void set_SkipUndo(
   bool value
);
public:
property bool SkipUndo {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TaskManager Class
TaskManager Members


UndoCode Property

Lassalle.Silverlight.Flow Namespace > TaskManager Class : UndoCode Property
Returns the code of the next undoable action.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property UndoCode As Action
'Usage

Dim instance As TaskManager
Dim value As Action

value = instance.UndoCode
public Action UndoCode {get;}
public: __property Action get_UndoCode();
public:
property Action UndoCode {
   Action get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TaskManager Class
TaskManager Members


UndoItem Property

Lassalle.Silverlight.Flow Namespace > TaskManager Class : UndoItem Property
Returns the item involved in the next undoable action.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property UndoItem As UIElement
'Usage

Dim instance As TaskManager
Dim value As UIElement

value = instance.UndoItem
public UIElement UndoItem {get;}
public: __property UIElement* get_UndoItem();
public:
property UIElement^ UndoItem {
   UIElement^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TaskManager Class
TaskManager Members


UndoLimit Property

Lassalle.Silverlight.Flow Namespace > TaskManager Class : UndoLimit Property
Returns/sets the number of undo commands that can be performed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UndoLimit As Integer
'Usage

Dim instance As TaskManager
Dim value As Integer

instance.UndoLimit = value

value = instance.UndoLimit
public int UndoLimit {get; set;}
public: __property int get_UndoLimit();
public: __property void set_UndoLimit(
   int value
);
public:
property int UndoLimit {
   int get();
   void set (    int value);
}
Remarks
  1. UndoLimit limits the size of the Undo buffer. Therefore, you can use this property to save memory.
  2. Setting UndoLimit to zero means that the size of the Undo buffer is unlimited.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TaskManager Class
TaskManager Members


%%PageItemTitle%%

ZoomedEventArgs Class
Members

Lassalle.Silverlight.Flow Namespace : ZoomedEventArgs Class
Event parameters used for the ZoomedEventArgs event
Object Model
ZoomedEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ZoomedEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ZoomedEventArgs
public class ZoomedEventArgs : System.EventArgs
public __gc class ZoomedEventArgs : public System.EventArgs
public ref class ZoomedEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Lassalle.Silverlight.Flow.ZoomedEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ZoomedEventArgs Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Members$$

ZoomedEventArgs Class Members
Properties

Lassalle.Silverlight.Flow Namespace : ZoomedEventArgs Class

The following tables list the members exposed by ZoomedEventArgs.

Public Constructors
 | Name | Description
Public Constructor | ZoomedEventArgs Constructor | Constructor. Creates a new ZoomedEventArgs instance.
Top
Public Properties
 | Name | Description
Public Property | newZoom | The new zoom value (read-only)
Public Property | OldZoom | The old zoom value (read-only)
Top
See Also

Reference

ZoomedEventArgs Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

ZoomedEventArgs Constructor

Lassalle.Silverlight.Flow Namespace > ZoomedEventArgs Class : ZoomedEventArgs Constructor
The old zoom value
The new zoom value
Constructor. Creates a new ZoomedEventArgs instance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal oldZoom As Double, _
   ByVal newZoom As Double _
)
'Usage

Dim oldZoom As Double
Dim newZoom As Double

Dim instance As New ZoomedEventArgs(oldZoom, newZoom)
public ZoomedEventArgs(
   double oldZoom,
   double newZoom
)
public: ZoomedEventArgs(
   double oldZoom,
   double newZoom
)
public:
ZoomedEventArgs(
   double oldZoom,
   double newZoom
)

Parameters

oldZoom
The old zoom value
newZoom
The new zoom value
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ZoomedEventArgs Class
ZoomedEventArgs Members


%%PageItemTitle%% $$Properties$$

ZoomedEventArgs Class Properties

Lassalle.Silverlight.Flow Namespace : ZoomedEventArgs Class

For a list of all members of this type, see ZoomedEventArgs members.

Public Properties
 | Name | Description
Public Property | newZoom | The new zoom value (read-only)
Public Property | OldZoom | The old zoom value (read-only)
Top
See Also

Reference

ZoomedEventArgs Class
Lassalle.Silverlight.Flow Namespace


newZoom Property

Lassalle.Silverlight.Flow Namespace > ZoomedEventArgs Class : newZoom Property
The new zoom value (read-only)
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property newZoom As Double
'Usage

Dim instance As ZoomedEventArgs
Dim value As Double

value = instance.newZoom
public double newZoom {get;}
public: __property double get_newZoom();
public:
property double newZoom {
   double get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ZoomedEventArgs Class
ZoomedEventArgs Members


OldZoom Property

Lassalle.Silverlight.Flow Namespace > ZoomedEventArgs Class : OldZoom Property
The old zoom value (read-only)
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property OldZoom As Double
'Usage

Dim instance As ZoomedEventArgs
Dim value As Double

value = instance.OldZoom
public double OldZoom {get;}
public: __property double get_OldZoom();
public:
property double OldZoom {
   double get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ZoomedEventArgs Class
ZoomedEventArgs Members


%%PageItemTitle%%

ZoomingBox Class
Members

Lassalle.Silverlight.Flow Namespace : ZoomingBox Class
The rectangle used when making a zoom with the mouse.
Object Model
ZoomingBox Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DesignTimeVisibleAttribute()>
Public Class ZoomingBox
   Inherits System.Windows.Controls.Control
'Usage

Dim instance As ZoomingBox
[DesignTimeVisibleAttribute()]
public class ZoomingBox : System.Windows.Controls.Control
[DesignTimeVisibleAttribute()]
public __gc class ZoomingBox : public System.Windows.Controls.Control
[DesignTimeVisibleAttribute()]
public ref class ZoomingBox : public System.Windows.Controls.Control
Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
Lassalle.Silverlight.Flow.ZoomingBox

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ZoomingBox Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Members$$

ZoomingBox Class Members
Properties Methods Events

Lassalle.Silverlight.Flow Namespace : ZoomingBox Class

The following tables list the members exposed by ZoomingBox.

Public Constructors
 | Name | Description
Public Constructor | ZoomingBox Constructor | ZoomingBox constructor
Top
Public Properties
 | Name | Description
Public Property | ActualHeight | Gets the rendered height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | Gets the rendered width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | AllowDrop | Gets or sets a value that determines whether this System.Windows.UIElement can be a drop target for purposes of Silverlight drag-and-drop operations. (Inherited from System.Windows.UIElement)
Public Property | Background | Gets or sets a brush that provides the background of the control. (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from System.Windows.Controls.Control)
Public Property | CacheMode | Gets or sets a value that indicates that rendered content should be cached when possible. (Inherited from System.Windows.UIElement)
Public Property | CharacterSpacing | Gets or sets the distance between characters of text in the control measured in 1000ths of the font size. (Inherited from System.Windows.Controls.Control)
Public Property | Clip | Gets or sets the System.Windows.Media.Geometry used to define the outline of the contents of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | Cursor | Gets or sets the cursor image that displays while the mouse pointer is over a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | Gets or sets the data context for a System.Windows.FrameworkElement when it participates in data binding. (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | Gets the size that this System.Windows.UIElement computed during the measure pass of the layout process. (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | Gets the System.Windows.Threading.Dispatcher this object is associated with. (Inherited from System.Windows.DependencyObject)
Public Property | Effect | Gets or sets the pixel shader effect to use for rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | FlowDirection | Gets or sets the direction that text and other user interface elements flow within any parent element that controls their layout. (Inherited from System.Windows.FrameworkElement)
Public Property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | Gets or sets the size of the text in this control. (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from System.Windows.Controls.Control)
Public Property | Height | Gets or sets the suggested height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | Gets or sets whether the contained area of this System.Windows.UIElement can return true values for hit testing. (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from System.Windows.Controls.Control)
Public Property | Language | Gets or sets localization/globalization language information that applies to a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | Gets or sets the outer margin of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | Gets or sets the maximum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | Gets or sets the maximum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | Gets or sets the minimum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | Gets or sets the minimum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | Gets or sets the brush used to alter the opacity of regions of this object. (Inherited from System.Windows.UIElement)
Public Property | Padding | Gets or sets the padding inside a control. (Inherited from System.Windows.Controls.Control)
Public Property | Parent | Gets the parent object of this System.Windows.FrameworkElement in the object tree. (Inherited from System.Windows.FrameworkElement)
Public Property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderSize | Gets the final render size of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | Gets or sets transform information that affects the rendering position of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by System.Windows.UIElement.RenderTransform, relative to the bounds of the System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from System.Windows.FrameworkElement)
Public Property | Style | Gets or sets an instance System.Windows.Style that is applied for this object during rendering. (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | Gets or sets a value that modifies how tabbing and System.Windows.Controls.Control.TabIndex work for this control. (Inherited from System.Windows.Controls.Control)
Public Property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from System.Windows.FrameworkElement)
Public Property | Template | Gets or sets a control template. (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | Gets the collection of triggers for animations that are defined for a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from System.Windows.UIElement)
Public Property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | Gets or sets the visibility of a System.Windows.UIElement. A System.Windows.UIElement that is not visible does not render and does not communicate its desired size to layout. (Inherited from System.Windows.UIElement)
Public Property | Width | Gets or sets the width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Top
Protected Properties
 | Name | Description
Protected Property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from System.Windows.Controls.Control)
Top
Public Methods
 | Name | Description
Public Method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from System.Windows.UIElement)
Public Method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from System.Windows.Controls.Control)
Public Method | Arrange | Positions child objects and determines a size for a System.Windows.UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | CaptureMouse | Sets mouse capture to a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | ClearValue | Clears the local value of a dependency property. (Inherited from System.Windows.DependencyObject)
Public Method | FindName | Retrieves an object that has the specified identifier name. (Inherited from System.Windows.FrameworkElement)
Public Method | Focus | Attempts to set the focus on the control. (Inherited from System.Windows.Controls.Control)
Public Method | GetAnimationBaseValue | Returns any base value established for a Silverlight dependency property, which would apply in cases where an animation is not active. (Inherited from System.Windows.DependencyObject)
Public Method | GetBindingExpression | Retrieves the System.Windows.Data.BindingExpression for a dependency property where a binding is established. (Inherited from System.Windows.FrameworkElement)
Public Method | GetValue | Returns the current effective value of a dependency property from a System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateArrange | Invalidates the arrange state (layout) for a System.Windows.UIElement. After the invalidation, the System.Windows.UIElement will have its layout updated, which will occur asynchronously. (Inherited from System.Windows.UIElement)
Public Method | InvalidateMeasure | Invalidates the measurement state (layout) for a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | Measure | Updates the System.Windows.UIElement.DesiredSize of a System.Windows.UIElement. Typically, objects that implement custom layout for their layout children call this method from their own System.Windows.FrameworkElement.MeasureOverride(System.Windows.Size) implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call System.Windows.Controls.Control.ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in an application. For more information, see Remarks. (Inherited from System.Windows.FrameworkElement)
Public Method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from System.Windows.DependencyObject)
Public Method | ReleaseMouseCapture | Removes mouse capture from a System.Windows.UIElement. After this call, typically no object holds mouse capture. (Inherited from System.Windows.UIElement)
Public Method | RemoveHandler | Removes the specified routed event handler from this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | SetBinding | Attaches a binding to a System.Windows.FrameworkElement, using the provided binding object, and returns a System.Windows.Data.BindingExpressionBase for possible later use. (Inherited from System.Windows.FrameworkElement)
Public Method | SetValue | (Inherited from System.Windows.DependencyObject)
Public Method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the System.Windows.UIElement to the specified object. (Inherited from System.Windows.UIElement)
Public Method | UpdateLayout | Ensures that all positions of child objects of a System.Windows.UIElement are properly updated for layout. (Inherited from System.Windows.UIElement)
Top
Protected Methods
 | Name | Description
Protected Method | ArrangeOverride | (Inherited from System.Windows.FrameworkElement)
Protected Method | GetTemplateChild | Retrieves the named element in the instantiated System.Windows.Controls.ControlTemplate visual tree. (Inherited from System.Windows.Controls.Control)
Protected Method | MeasureOverride | (Inherited from System.Windows.FrameworkElement)
Protected Method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific System.Windows.Automation.Peers.AutomationPeer implementations for the Silverlight automation infrastructure. (Inherited from System.Windows.UIElement)
Protected Method | OnDragEnter | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDragLeave | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDragOver | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDrop | (Inherited from System.Windows.Controls.Control)
Protected Method | OnGotFocus | (Inherited from System.Windows.Controls.Control)
Protected Method | OnKeyDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnKeyUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnLostFocus | (Inherited from System.Windows.Controls.Control)
Protected Method | OnLostMouseCapture | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseEnter | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeave | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeftButtonDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeftButtonUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseMove | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseRightButtonDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseRightButtonUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseWheel | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInput | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInputStart | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInputUpdate | (Inherited from System.Windows.Controls.Control)
Top
Public Events
 | Name | Description
Public Event | BindingValidationError | Occurs when a data validation error is reported by a binding source. (Inherited from System.Windows.FrameworkElement)
Public Event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from System.Windows.FrameworkElement)
Public Event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from System.Windows.UIElement)
Public Event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from System.Windows.UIElement)
Public Event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from System.Windows.UIElement)
Public Event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from System.Windows.UIElement)
Public Event | GotFocus | Occurs when a System.Windows.UIElement receives focus. (Inherited from System.Windows.UIElement)
Public Event | IsEnabledChanged | Occurs when the System.Windows.Controls.Control.IsEnabled property changes. (Inherited from System.Windows.Controls.Control)
Public Event | KeyDown | Occurs when a keyboard key is pressed while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | KeyUp | Occurs when a keyboard key is released while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | Occurs when the layout of the Silverlight visual tree changes. (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | Occurs when a System.Windows.FrameworkElement has been constructed and added to the object tree. (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | Occurs when a System.Windows.UIElement loses focus. (Inherited from System.Windows.UIElement)
Public Event | LostMouseCapture | Occurs when the System.Windows.UIElement loses mouse capture. (Inherited from System.Windows.UIElement)
Public Event | MediaCommand | Occurs when a button is pressed on a remote control. (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | Occurs when the mouse (or a stylus) enters the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | Occurs when the mouse (or the stylus) leaves the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | Occurs when the left mouse button is pressed (or when the tip of the stylus touches the tablet) while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | Occurs when the left mouse button is released (or the tip of the stylus is removed from the tablet) while the mouse (or the stylus) is over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseMove | Occurs when the coordinate position of the mouse (or stylus) changes while over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over a System.Windows.UIElement. However, this event will only be raised if a caller marks the preceding System.Windows.UIElement.MouseRightButtonDown event as handled; see Remarks. (Inherited from System.Windows.UIElement)
Public Event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over a System.Windows.UIElement, or the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | Occurs when either the System.Windows.FrameworkElement.ActualHeight or the System.Windows.FrameworkElement.ActualWidth properties change value on a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Event | TextInput | Occurs when a UI element gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputStart | Occurs when a UI element initially gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputUpdate | Occurs when text continues to be composed via an input method editor (IME). (Inherited from System.Windows.UIElement)
Public Event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from System.Windows.FrameworkElement)
Top
See Also

Reference

ZoomingBox Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

ZoomingBox Constructor

Lassalle.Silverlight.Flow Namespace > ZoomingBox Class : ZoomingBox Constructor
ZoomingBox constructor
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ZoomingBox()
public ZoomingBox()
public: ZoomingBox();
public:
ZoomingBox();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ZoomingBox Class
ZoomingBox Members


%%PageItemTitle%%

Action Enumeration
Members

Lassalle.Silverlight.Flow Namespace : Action Enumeration
Used to specify an action that changes the diagram.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum Action
   Inherits System.Enum
'Usage

Dim instance As Action
public enum Action : System.Enum
__value public enum Action : public System.Enum
public enum class Action : public System.Enum
Members
Member | Description
ArrowDst | The ArrowDst property of a link is changed
ArrowOrg | The ArrowOrg property of a link is changed
Delete | The selected items are deleted
Dst | The destination node of a link is changed
InPlaceTextEdition | The text of a node has been changed directly in the node
LineStyle | The line style property of a link is changed
LinkAdd | A link is created
LinkRemove | A link is deleted
LinkStretch | A link is stretched
MoveSelectedNodes | The selected nodes are moved
NodeAdd | A node is created
NodeMoveAndSize | A node is moved or resized
NodeRemove | A node is deleted
NodeResize | A node is resized
NodeRotate | A node is rotated
None | No action
Org | The origin node of a link is changed
PinDst | The destination pin of a link is changed
PinOrg | The origin pin of a link is changed
Points | The points collection of a link is changed
ResizeSelectedNodes | The selected nodes are resized
RotateSelectedNodes | The selected nodes are rotated
ZOrder | The ZOrder of an item is changed
Remarks
Selection actions are omitted because they do not change the document
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Lassalle.Silverlight.Flow.Action

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

ConnectionMode Enumeration
Members

Lassalle.Silverlight.Flow Namespace : ConnectionMode Enumeration
Used to specify how a link is connected to a node
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ConnectionMode
   Inherits System.Enum
'Usage

Dim instance As ConnectionMode
public enum ConnectionMode : System.Enum
__value public enum ConnectionMode : public System.Enum
public enum class ConnectionMode : public System.Enum
Members
Member | Description
Anywhere | The link last (or first) point can be placed anywhere
Center | The link is directed towards the centre of the node
Pin | A pin a must be use to connect a link to the node
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Lassalle.Silverlight.Flow.ConnectionMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

ErrorEventType Enumeration
Members

Lassalle.Silverlight.Flow Namespace : ErrorEventType Enumeration
Used to specify the type of the Error event
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ErrorEventType
   Inherits System.Enum
'Usage

Dim instance As ErrorEventType
public enum ErrorEventType : System.Enum
__value public enum ErrorEventType : public System.Enum
public enum class ErrorEventType : public System.Enum
Members
Member | Description
IncomingLinkError | This node does not accept incoming links.
MultilinkError | Multiple links between 2 nodes are not accepted.
OutgoingLinkError | This node does not accept outgoing links.
ReflexiveError | Reflexive links are not accepted.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Lassalle.Silverlight.Flow.ErrorEventType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

LineStyle Enumeration
Members

Lassalle.Silverlight.Flow Namespace : LineStyle Enumeration
Used to specify the style used to draw a link.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum LineStyle
   Inherits System.Enum
'Usage

Dim instance As LineStyle
public enum LineStyle : System.Enum
__value public enum LineStyle : public System.Enum
public enum class LineStyle : public System.Enum
Members
Member | Description
Bezier | A Bezier curve
Database | Database style
HV | 2 segments: horizontal vertical
HVH | 3 segments: horizontal vertical horizontal
HVHV | 4 segments: horz vert horz vert
HVHVH | 5 segments: horz vert horz vert horz
HVHVHV | 6 segments: horz vert horz vert horz vert
HVHVHVH | 7 segments: horz vert horz vert horz vert horz
Polyline | A series of connected lines
Spline | A Cubic spline curve
VH | 2 segments: vertical horizontal
VHV | 3 segments: vertical horizontal vertical
VHVH | 4 segments: vert horz vert horz
VHVHV | 5 segments: vert horz vert horz vert
VHVHVH | 6 segments: vert horz vert horz vert horz
VHVHVHV | 7 segments: vert horz vert horz vert horz vert
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Lassalle.Silverlight.Flow.LineStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

MouseSelection Enumeration
Members

Lassalle.Silverlight.Flow Namespace : MouseSelection Enumeration
Used to specify the action with the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum MouseSelection
   Inherits System.Enum
'Usage

Dim instance As MouseSelection
public enum MouseSelection : System.Enum
__value public enum MouseSelection : public System.Enum
public enum class MouseSelection : public System.Enum
Members
Member | Description
None | Default mode. It means that the user can create nodes with the mouse
Pan | Panning mode. Scroll the diagram with the mouse.
Selection | Selection mode. Select the items partially inside the rectangle
Zoom | Zoom the rectangle while ensuring a 1:1 aspect ratio
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Lassalle.Silverlight.Flow.MouseSelection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

ResizeHandle.HandleType Enumeration
Members

Lassalle.Silverlight.Flow Namespace : ResizeHandle.HandleType Enumeration
Type of node handle (Left, Up etc)
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ResizeHandle.HandleType
   Inherits System.Enum
'Usage

Dim instance As ResizeHandle.HandleType
public enum ResizeHandle.HandleType : System.Enum
__value public enum ResizeHandle.HandleType : public System.Enum
public enum class ResizeHandle.HandleType : public System.Enum
Members
Member | Description
Down |
Left |
LeftDown |
LeftUp |
Right |
RightDown |
RightUp |
Up |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Lassalle.Silverlight.Flow.ResizeHandle.HandleType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

TextAngleMode Enumeration
Members

Lassalle.Silverlight.Flow Namespace : TextAngleMode Enumeration
Used to specify if the link text is displayed with an angle
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum TextAngleMode
   Inherits System.Enum
'Usage

Dim instance As TextAngleMode
public enum TextAngleMode : System.Enum
__value public enum TextAngleMode : public System.Enum
public enum class TextAngleMode : public System.Enum
Members
Member | Description
Horizontal | The text is displayed horizontally, whatever the angle of the link may be.
LineAngle | The text is rotated to follow the link angle
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Lassalle.Silverlight.Flow.TextAngleMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

TextPlacementMode Enumeration
Members

Lassalle.Silverlight.Flow Namespace : TextPlacementMode Enumeration
Used to specify the position of the link text near the link.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum TextPlacementMode
   Inherits System.Enum
'Usage

Dim instance As TextPlacementMode
public enum TextPlacementMode : System.Enum
__value public enum TextPlacementMode : public System.Enum
public enum class TextPlacementMode : public System.Enum
Members
Member | Description
MiddleLine | The text is placed at the middle of the link line
MiddleSegment | The text is placed at the middle of the medium segment of the link
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Lassalle.Silverlight.Flow.TextPlacementMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

IHasContext Interface
Members

Lassalle.Silverlight.Flow Namespace : IHasContext Interface
Common interface for items that can have a context button: nodes, busbars, links
Object Model
IHasContext Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IHasContext
'Usage

Dim instance As IHasContext
public interface IHasContext
public __gc __interface IHasContext
public interface class IHasContext
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IHasContext Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Members$$

IHasContext Interface Members
Properties

Lassalle.Silverlight.Flow Namespace : IHasContext Interface

The following tables list the members exposed by IHasContext.

Public Properties
 | Name | Description
Property | IsContextHandle | Determines whether the item has a context handle.
Top
See Also

Reference

IHasContext Interface
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Properties$$

IHasContext Interface Properties

Lassalle.Silverlight.Flow Namespace : IHasContext Interface

For a list of all members of this type, see IHasContext members.

Public Properties
 | Name | Description
Property | IsContextHandle | Determines whether the item has a context handle.
Top
See Also

Reference

IHasContext Interface
Lassalle.Silverlight.Flow Namespace


IsContextHandle Property (IHasContext)

Lassalle.Silverlight.Flow Namespace > IHasContext Interface : IsContextHandle Property
Determines whether the item has a context handle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property IsContextHandle As Boolean
'Usage

Dim instance As IHasContext
Dim value As Boolean

instance.IsContextHandle = value

value = instance.IsContextHandle
bool IsContextHandle {get; set;}
__property bool get_IsContextHandle();
__property void set_IsContextHandle(
   bool value
);
property bool IsContextHandle {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IHasContext Interface
IHasContext Members


%%PageItemTitle%%

IMoveable Interface
Members

Lassalle.Silverlight.Flow Namespace : IMoveable Interface
Common interface for items that can be moved
Object Model
IMoveable Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IMoveable
'Usage

Dim instance As IMoveable
public interface IMoveable
public __gc __interface IMoveable
public interface class IMoveable
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMoveable Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Members$$

IMoveable Interface Members
Properties

Lassalle.Silverlight.Flow Namespace : IMoveable Interface

The following tables list the members exposed by IMoveable.

Public Properties
 | Name | Description
Property | IsXMoveable | Determines whether the item can be horizontally moved or not.
Property | IsYMoveable | Determines whether the item can be vertically moved or not.
Top
See Also

Reference

IMoveable Interface
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Properties$$

IMoveable Interface Properties

Lassalle.Silverlight.Flow Namespace : IMoveable Interface

For a list of all members of this type, see IMoveable members.

Public Properties
 | Name | Description
Property | IsXMoveable | Determines whether the item can be horizontally moved or not.
Property | IsYMoveable | Determines whether the item can be vertically moved or not.
Top
See Also

Reference

IMoveable Interface
Lassalle.Silverlight.Flow Namespace


IsXMoveable Property (IMoveable)

Lassalle.Silverlight.Flow Namespace > IMoveable Interface : IsXMoveable Property
Determines whether the item can be horizontally moved or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property IsXMoveable As Boolean
'Usage

Dim instance As IMoveable
Dim value As Boolean

instance.IsXMoveable = value

value = instance.IsXMoveable
bool IsXMoveable {get; set;}
__property bool get_IsXMoveable();
__property void set_IsXMoveable(
   bool value
);
property bool IsXMoveable {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMoveable Interface
IMoveable Members


IsYMoveable Property (IMoveable)

Lassalle.Silverlight.Flow Namespace > IMoveable Interface : IsYMoveable Property
Determines whether the item can be vertically moved or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property IsYMoveable As Boolean
'Usage

Dim instance As IMoveable
Dim value As Boolean

instance.IsYMoveable = value

value = instance.IsYMoveable
bool IsYMoveable {get; set;}
__property bool get_IsYMoveable();
__property void set_IsYMoveable(
   bool value
);
property bool IsYMoveable {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMoveable Interface
IMoveable Members


%%PageItemTitle%%

ISelectable Interface
Members

Lassalle.Silverlight.Flow Namespace : ISelectable Interface
Common interface for items that can be selected: nodes and links
Object Model
ISelectable Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface ISelectable
'Usage

Dim instance As ISelectable
public interface ISelectable
public __gc __interface ISelectable
public interface class ISelectable
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISelectable Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Members$$

ISelectable Interface Members
Properties

Lassalle.Silverlight.Flow Namespace : ISelectable Interface

The following tables list the members exposed by ISelectable.

Public Properties
 | Name | Description
Property | IsSelectable | Determines if an item is selectable or not.
Property | IsSelected | Determines if an item is selected or not.
Top
See Also

Reference

ISelectable Interface
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Properties$$

ISelectable Interface Properties

Lassalle.Silverlight.Flow Namespace : ISelectable Interface

For a list of all members of this type, see ISelectable members.

Public Properties
 | Name | Description
Property | IsSelectable | Determines if an item is selectable or not.
Property | IsSelected | Determines if an item is selected or not.
Top
See Also

Reference

ISelectable Interface
Lassalle.Silverlight.Flow Namespace


IsSelectable Property (ISelectable)

Lassalle.Silverlight.Flow Namespace > ISelectable Interface : IsSelectable Property
Determines if an item is selectable or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property IsSelectable As Boolean
'Usage

Dim instance As ISelectable
Dim value As Boolean

instance.IsSelectable = value

value = instance.IsSelectable
bool IsSelectable {get; set;}
__property bool get_IsSelectable();
__property void set_IsSelectable(
   bool value
);
property bool IsSelectable {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISelectable Interface
ISelectable Members


IsSelected Property (ISelectable)

Lassalle.Silverlight.Flow Namespace > ISelectable Interface : IsSelected Property
Determines if an item is selected or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Property IsSelected As Boolean
'Usage

Dim instance As ISelectable
Dim value As Boolean

instance.IsSelected = value

value = instance.IsSelected
bool IsSelected {get; set;}
__property bool get_IsSelected();
__property void set_IsSelected(
   bool value
);
property bool IsSelected {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISelectable Interface
ISelectable Members


%%PageItemTitle%%

AddFlow.AfterEditEventHandler Delegate

Lassalle.Silverlight.Flow Namespace : AddFlow.AfterEditEventHandler Delegate
Represents the method that will handle the AfterEdit event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub AddFlow.AfterEditEventHandler( _
   ByVal sender As Object, _
   ByVal e As AfterEditEventArgs _
)
'Usage

Dim instance As New AddFlow.AfterEditEventHandler(AddressOf HandlerMethod)
public delegate void AddFlow.AfterEditEventHandler(
   object sender,
   AfterEditEventArgs e
)
public: __gc __delegate void AddFlow.AfterEditEventHandler(
   Object* sender,
   AfterEditEventArgs* e
)
public delegate void AddFlow.AfterEditEventHandler(
   Object^ sender,
   AfterEditEventArgs^ e
)

Parameters

sender
e
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow.AfterEditEventHandler Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

AddFlow.BeforeEditEventHandler Delegate

Lassalle.Silverlight.Flow Namespace : AddFlow.BeforeEditEventHandler Delegate
Represents the method that will handle the BeforeEdit event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub AddFlow.BeforeEditEventHandler( _
   ByVal sender As Object, _
   ByVal e As BeforeEditEventArgs _
)
'Usage

Dim instance As New AddFlow.BeforeEditEventHandler(AddressOf HandlerMethod)
public delegate void AddFlow.BeforeEditEventHandler(
   object sender,
   BeforeEditEventArgs e
)
public: __gc __delegate void AddFlow.BeforeEditEventHandler(
   Object* sender,
   BeforeEditEventArgs* e
)
public delegate void AddFlow.BeforeEditEventHandler(
   Object^ sender,
   BeforeEditEventArgs^ e
)

Parameters

sender
e
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow.BeforeEditEventHandler Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

AddFlow.CancelEditEventHandler Delegate

Lassalle.Silverlight.Flow Namespace : AddFlow.CancelEditEventHandler Delegate
Represents the method that will handle the CancelEdit event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub AddFlow.CancelEditEventHandler( _
   ByVal sender As Object, _
   ByVal e As CancelEditEventArgs _
)
'Usage

Dim instance As New AddFlow.CancelEditEventHandler(AddressOf HandlerMethod)
public delegate void AddFlow.CancelEditEventHandler(
   object sender,
   CancelEditEventArgs e
)
public: __gc __delegate void AddFlow.CancelEditEventHandler(
   Object* sender,
   CancelEditEventArgs* e
)
public delegate void AddFlow.CancelEditEventHandler(
   Object^ sender,
   CancelEditEventArgs^ e
)

Parameters

sender
e
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow.CancelEditEventHandler Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

AddFlow.ContextHandleClickedEventHandler Delegate

Lassalle.Silverlight.Flow Namespace : AddFlow.ContextHandleClickedEventHandler Delegate
Represents the method that will handle the MouseOverPin event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub AddFlow.ContextHandleClickedEventHandler( _
   ByVal sender As Object, _
   ByVal e As ContextHandleClickedEventArgs _
)
'Usage

Dim instance As New AddFlow.ContextHandleClickedEventHandler(AddressOf HandlerMethod)
public delegate void AddFlow.ContextHandleClickedEventHandler(
   object sender,
   ContextHandleClickedEventArgs e
)
public: __gc __delegate void AddFlow.ContextHandleClickedEventHandler(
   Object* sender,
   ContextHandleClickedEventArgs* e
)
public delegate void AddFlow.ContextHandleClickedEventHandler(
   Object^ sender,
   ContextHandleClickedEventArgs^ e
)

Parameters

sender
e
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow.ContextHandleClickedEventHandler Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

AddFlow.DstChangedEventHandler Delegate

Lassalle.Silverlight.Flow Namespace : AddFlow.DstChangedEventHandler Delegate
Represents the method that will handle the DstChanged event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub AddFlow.DstChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
'Usage

Dim instance As New AddFlow.DstChangedEventHandler(AddressOf HandlerMethod)
public delegate void AddFlow.DstChangedEventHandler(
   object sender,
   EventArgs e
)
public: __gc __delegate void AddFlow.DstChangedEventHandler(
   Object* sender,
   EventArgs* e
)
public delegate void AddFlow.DstChangedEventHandler(
   Object^ sender,
   EventArgs^ e
)

Parameters

sender
e
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow.DstChangedEventHandler Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

AddFlow.DstChangingEventHandler Delegate

Lassalle.Silverlight.Flow Namespace : AddFlow.DstChangingEventHandler Delegate
Represents the method that will handle the DstChanging event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub AddFlow.DstChangingEventHandler( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
'Usage

Dim instance As New AddFlow.DstChangingEventHandler(AddressOf HandlerMethod)
public delegate void AddFlow.DstChangingEventHandler(
   object sender,
   EventArgs e
)
public: __gc __delegate void AddFlow.DstChangingEventHandler(
   Object* sender,
   EventArgs* e
)
public delegate void AddFlow.DstChangingEventHandler(
   Object^ sender,
   EventArgs^ e
)

Parameters

sender
e
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow.DstChangingEventHandler Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

AddFlow.ErrorEventHandler Delegate

Lassalle.Silverlight.Flow Namespace : AddFlow.ErrorEventHandler Delegate
Represents the method that will handle the Error event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub AddFlow.ErrorEventHandler( _
   ByVal sender As Object, _
   ByVal e As ErrorEventArgs _
)
'Usage

Dim instance As New AddFlow.ErrorEventHandler(AddressOf HandlerMethod)
public delegate void AddFlow.ErrorEventHandler(
   object sender,
   ErrorEventArgs e
)
public: __gc __delegate void AddFlow.ErrorEventHandler(
   Object* sender,
   ErrorEventArgs* e
)
public delegate void AddFlow.ErrorEventHandler(
   Object^ sender,
   ErrorEventArgs^ e
)

Parameters

sender
e
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow.ErrorEventHandler Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

AddFlow.LinkCreatedEventHandler Delegate

Lassalle.Silverlight.Flow Namespace : AddFlow.LinkCreatedEventHandler Delegate
Represents the method that will handle the LinkCreated event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub AddFlow.LinkCreatedEventHandler( _
   ByVal sender As Object, _
   ByVal e As LinkCreatedEventArgs _
)
'Usage

Dim instance As New AddFlow.LinkCreatedEventHandler(AddressOf HandlerMethod)
public delegate void AddFlow.LinkCreatedEventHandler(
   object sender,
   LinkCreatedEventArgs e
)
public: __gc __delegate void AddFlow.LinkCreatedEventHandler(
   Object* sender,
   LinkCreatedEventArgs* e
)
public delegate void AddFlow.LinkCreatedEventHandler(
   Object^ sender,
   LinkCreatedEventArgs^ e
)

Parameters

sender
e
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow.LinkCreatedEventHandler Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

AddFlow.LinkDeletedEventHandler Delegate

Lassalle.Silverlight.Flow Namespace : AddFlow.LinkDeletedEventHandler Delegate
Represents the method that will handle the LinkDeleted event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub AddFlow.LinkDeletedEventHandler( _
   ByVal sender As Object, _
   ByVal e As LinkDeletedEventArgs _
)
'Usage

Dim instance As New AddFlow.LinkDeletedEventHandler(AddressOf HandlerMethod)
public delegate void AddFlow.LinkDeletedEventHandler(
   object sender,
   LinkDeletedEventArgs e
)
public: __gc __delegate void AddFlow.LinkDeletedEventHandler(
   Object* sender,
   LinkDeletedEventArgs* e
)
public delegate void AddFlow.LinkDeletedEventHandler(
   Object^ sender,
   LinkDeletedEventArgs^ e
)

Parameters

sender
e
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow.LinkDeletedEventHandler Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

AddFlow.NodeCreatedEventHandler Delegate

Lassalle.Silverlight.Flow Namespace : AddFlow.NodeCreatedEventHandler Delegate
Represents the method that will handle the NodeCreated event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub AddFlow.NodeCreatedEventHandler( _
   ByVal sender As Object, _
   ByVal e As NodeCreatedEventArgs _
)
'Usage

Dim instance As New AddFlow.NodeCreatedEventHandler(AddressOf HandlerMethod)
public delegate void AddFlow.NodeCreatedEventHandler(
   object sender,
   NodeCreatedEventArgs e
)
public: __gc __delegate void AddFlow.NodeCreatedEventHandler(
   Object* sender,
   NodeCreatedEventArgs* e
)
public delegate void AddFlow.NodeCreatedEventHandler(
   Object^ sender,
   NodeCreatedEventArgs^ e
)

Parameters

sender
e
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow.NodeCreatedEventHandler Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

AddFlow.NodeDeletedEventHandler Delegate

Lassalle.Silverlight.Flow Namespace : AddFlow.NodeDeletedEventHandler Delegate
Represents the method that will handle the NodeDeleted event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub AddFlow.NodeDeletedEventHandler( _
   ByVal sender As Object, _
   ByVal e As NodeDeletedEventArgs _
)
'Usage

Dim instance As New AddFlow.NodeDeletedEventHandler(AddressOf HandlerMethod)
public delegate void AddFlow.NodeDeletedEventHandler(
   object sender,
   NodeDeletedEventArgs e
)
public: __gc __delegate void AddFlow.NodeDeletedEventHandler(
   Object* sender,
   NodeDeletedEventArgs* e
)
public delegate void AddFlow.NodeDeletedEventHandler(
   Object^ sender,
   NodeDeletedEventArgs^ e
)

Parameters

sender
e
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow.NodeDeletedEventHandler Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

AddFlow.OrgChangedEventHandler Delegate

Lassalle.Silverlight.Flow Namespace : AddFlow.OrgChangedEventHandler Delegate
Represents the method that will handle the OrgChanged event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub AddFlow.OrgChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
'Usage

Dim instance As New AddFlow.OrgChangedEventHandler(AddressOf HandlerMethod)
public delegate void AddFlow.OrgChangedEventHandler(
   object sender,
   EventArgs e
)
public: __gc __delegate void AddFlow.OrgChangedEventHandler(
   Object* sender,
   EventArgs* e
)
public delegate void AddFlow.OrgChangedEventHandler(
   Object^ sender,
   EventArgs^ e
)

Parameters

sender
e
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow.OrgChangedEventHandler Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

AddFlow.OrgChangingEventHandler Delegate

Lassalle.Silverlight.Flow Namespace : AddFlow.OrgChangingEventHandler Delegate
Represents the method that will handle the OrgChanging event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub AddFlow.OrgChangingEventHandler( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
'Usage

Dim instance As New AddFlow.OrgChangingEventHandler(AddressOf HandlerMethod)
public delegate void AddFlow.OrgChangingEventHandler(
   object sender,
   EventArgs e
)
public: __gc __delegate void AddFlow.OrgChangingEventHandler(
   Object* sender,
   EventArgs* e
)
public delegate void AddFlow.OrgChangingEventHandler(
   Object^ sender,
   EventArgs^ e
)

Parameters

sender
e
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow.OrgChangingEventHandler Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

AddFlow.SelectedLinkStretchingEventHandler Delegate

Lassalle.Silverlight.Flow Namespace : AddFlow.SelectedLinkStretchingEventHandler Delegate
Represents the method that will handle the SelectedLinkStretching event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub AddFlow.SelectedLinkStretchingEventHandler( _
   ByVal sender As Object, _
   ByVal e As SelectedLinkStretchingEventArgs _
)
'Usage

Dim instance As New AddFlow.SelectedLinkStretchingEventHandler(AddressOf HandlerMethod)
public delegate void AddFlow.SelectedLinkStretchingEventHandler(
   object sender,
   SelectedLinkStretchingEventArgs e
)
public: __gc __delegate void AddFlow.SelectedLinkStretchingEventHandler(
   Object* sender,
   SelectedLinkStretchingEventArgs* e
)
public delegate void AddFlow.SelectedLinkStretchingEventHandler(
   Object^ sender,
   SelectedLinkStretchingEventArgs^ e
)

Parameters

sender
e
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow.SelectedLinkStretchingEventHandler Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

AddFlow.SelectedNodesLayoutingEventHandler Delegate

Lassalle.Silverlight.Flow Namespace : AddFlow.SelectedNodesLayoutingEventHandler Delegate
Represents the method that will handle the SelectedNodesLayouting event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub AddFlow.SelectedNodesLayoutingEventHandler( _
   ByVal sender As Object, _
   ByVal e As SelectedNodesLayoutingEventArgs _
)
'Usage

Dim instance As New AddFlow.SelectedNodesLayoutingEventHandler(AddressOf HandlerMethod)
public delegate void AddFlow.SelectedNodesLayoutingEventHandler(
   object sender,
   SelectedNodesLayoutingEventArgs e
)
public: __gc __delegate void AddFlow.SelectedNodesLayoutingEventHandler(
   Object* sender,
   SelectedNodesLayoutingEventArgs* e
)
public delegate void AddFlow.SelectedNodesLayoutingEventHandler(
   Object^ sender,
   SelectedNodesLayoutingEventArgs^ e
)

Parameters

sender
e
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow.SelectedNodesLayoutingEventHandler Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

AddFlow.SelectedNodesRotatingEventHandler Delegate

Lassalle.Silverlight.Flow Namespace : AddFlow.SelectedNodesRotatingEventHandler Delegate
Represents the method that will handle the SelectedNodesRotating event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub AddFlow.SelectedNodesRotatingEventHandler( _
   ByVal sender As Object, _
   ByVal e As SelectedNodesRotatingEventArgs _
)
'Usage

Dim instance As New AddFlow.SelectedNodesRotatingEventHandler(AddressOf HandlerMethod)
public delegate void AddFlow.SelectedNodesRotatingEventHandler(
   object sender,
   SelectedNodesRotatingEventArgs e
)
public: __gc __delegate void AddFlow.SelectedNodesRotatingEventHandler(
   Object* sender,
   SelectedNodesRotatingEventArgs* e
)
public delegate void AddFlow.SelectedNodesRotatingEventHandler(
   Object^ sender,
   SelectedNodesRotatingEventArgs^ e
)

Parameters

sender
e
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow.SelectedNodesRotatingEventHandler Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

AddFlow.SelectionChangedEventHandler Delegate

Lassalle.Silverlight.Flow Namespace : AddFlow.SelectionChangedEventHandler Delegate
Represents the method that will handle the SelectionChanged event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub AddFlow.SelectionChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As SelectionChangedEventArgs _
)
'Usage

Dim instance As New AddFlow.SelectionChangedEventHandler(AddressOf HandlerMethod)
public delegate void AddFlow.SelectionChangedEventHandler(
   object sender,
   SelectionChangedEventArgs e
)
public: __gc __delegate void AddFlow.SelectionChangedEventHandler(
   Object* sender,
   SelectionChangedEventArgs* e
)
public delegate void AddFlow.SelectionChangedEventHandler(
   Object^ sender,
   SelectionChangedEventArgs^ e
)

Parameters

sender
e
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow.SelectionChangedEventHandler Members
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%%

AddFlow.ZoomedEventHandler Delegate

Lassalle.Silverlight.Flow Namespace : AddFlow.ZoomedEventHandler Delegate
Represents the method that will handle the Zoomed event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub AddFlow.ZoomedEventHandler( _
   ByVal sender As Object, _
   ByVal e As ZoomedEventArgs _
)
'Usage

Dim instance As New AddFlow.ZoomedEventHandler(AddressOf HandlerMethod)
public delegate void AddFlow.ZoomedEventHandler(
   object sender,
   ZoomedEventArgs e
)
public: __gc __delegate void AddFlow.ZoomedEventHandler(
   Object* sender,
   ZoomedEventArgs* e
)
public delegate void AddFlow.ZoomedEventHandler(
   Object^ sender,
   ZoomedEventArgs^ e
)

Parameters

sender
e
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddFlow.ZoomedEventHandler Members
Lassalle.Silverlight.Flow Namespace


Lassalle.Silverlight.Flow.Layout
Lassalle.Silverlight.Flow.Layout Assembly
Namespaces
Namespace | Description
Lassalle.Silverlight.Flow.Layout |


Lassalle.Silverlight.Flow.Layout
Lassalle.Silverlight.Flow.Layout Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | LayoutFlow | LayoutFlow is a class that performs some graph layout algorithms.
Class | StepEventArgs | Event parameters used for the Step event
Enumerations
 | Enumeration | Description
Enumeration | Orientation | Used to specify the general direction in which the automatic layout algorithm will position vertices.
Enumeration | SPDrawingStyle | Used to specify the Series Parallel drawing style
Enumeration | TreeDrawingStyle | Used to specify the tree drawing style
See Also

Reference

Lassalle.Silverlight.Flow.Layout Assembly


%%PageItemTitle%%

Lassalle.Silverlight.Flow.Layout
LayoutFlow Class
Members

Lassalle.Silverlight.Flow.Layout Namespace : LayoutFlow Class
LayoutFlow is a class that performs some graph layout algorithms.
Object Model
LayoutFlow Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit NotInheritable Class LayoutFlow
'Usage

Dim instance As LayoutFlow
public static class LayoutFlow
public __gc abstract __sealed class LayoutFlow
public ref class LayoutFlow abstract sealed
Inheritance Hierarchy

System.Object
Lassalle.Silverlight.Flow.Layout.LayoutFlow

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutFlow Members
Lassalle.Silverlight.Flow.Layout Namespace


%%PageItemTitle%% $$Members$$

Lassalle.Silverlight.Flow.Layout
LayoutFlow Class Members
Fields Methods

Lassalle.Silverlight.Flow.Layout Namespace : LayoutFlow Class

The following tables list the members exposed by LayoutFlow.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | IsLogicalProperty | Identifies the IsLogical attached property.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | GetIsLogical | Gets the value of the IsLogical attached property to a specified element.
static (Shared in Visual Basic) | HierarchicLayout | Overloaded. Performs the hierarchical layout
static (Shared in Visual Basic) | OrthogonalGridLayout | Overloaded. Performs the orthogonal grid layout
static (Shared in Visual Basic) | SeriesParallelLayout | Overloaded. Performs the Series parallel layout.
static (Shared in Visual Basic) | SetIsLogical | Sets the value of the IsLogical attached property to a specified element.
static (Shared in Visual Basic) | SymmetricLayout | Overloaded. Performs the symmetic layout.
static (Shared in Visual Basic) | TreeLayout | Overloaded. Performs the tree layout.
Top
See Also

Reference

LayoutFlow Class
Lassalle.Silverlight.Flow.Layout Namespace


%%PageItemTitle%% $$Methods$$

Lassalle.Silverlight.Flow.Layout
LayoutFlow Class Methods

Lassalle.Silverlight.Flow.Layout Namespace : LayoutFlow Class

For a list of all members of this type, see LayoutFlow members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | GetIsLogical | Gets the value of the IsLogical attached property to a specified element.
static (Shared in Visual Basic) | HierarchicLayout | Overloaded. Performs the hierarchical layout
static (Shared in Visual Basic) | OrthogonalGridLayout | Overloaded. Performs the orthogonal grid layout
static (Shared in Visual Basic) | SeriesParallelLayout | Overloaded. Performs the Series parallel layout.
static (Shared in Visual Basic) | SetIsLogical | Sets the value of the IsLogical attached property to a specified element.
static (Shared in Visual Basic) | SymmetricLayout | Overloaded. Performs the symmetic layout.
static (Shared in Visual Basic) | TreeLayout | Overloaded. Performs the tree layout.
Top
See Also

Reference

LayoutFlow Class
Lassalle.Silverlight.Flow.Layout Namespace


Lassalle.Silverlight.Flow.Layout
GetIsLogical Method

Lassalle.Silverlight.Flow.Layout Namespace > LayoutFlow Class : GetIsLogical Method
The item to which the attached property is read
Gets the value of the IsLogical attached property to a specified element.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function GetIsLogical( _
   ByVal item As DependencyObject _
) As Boolean
'Usage

Dim item As DependencyObject
Dim value As Boolean

value = LayoutFlow.GetIsLogical(item)
public static bool GetIsLogical(
   DependencyObject item
)
public: static bool GetIsLogical(
   DependencyObject* item
)
public:
static bool GetIsLogical(
   DependencyObject^ item
)

Parameters

item
The item to which the attached property is read

Return Value

The IsLogical property value for the item.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutFlow Class
LayoutFlow Members


Lassalle.Silverlight.Flow.Layout
HierarchicLayout Method

Lassalle.Silverlight.Flow.Layout Namespace > LayoutFlow Class : HierarchicLayout Method
Performs the hierarchical layout
Overload List
Overload | Description
HierarchicLayout(AddFlow) | Performs the hierarchical layout
HierarchicLayout(AddFlow,Double,Double,Orientation,Size,Int32) | Performs the hierarchical layout
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutFlow Class
LayoutFlow Members


Lassalle.Silverlight.Flow.Layout
HierarchicLayout(AddFlow) Method

Lassalle.Silverlight.Flow.Layout Namespace > LayoutFlow Class > HierarchicLayout Method : HierarchicLayout(AddFlow) Method
The AddFlow control
Performs the hierarchical layout
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub HierarchicLayout( _
   ByVal addflow As AddFlow _
)
'Usage

Dim addflow As AddFlow

LayoutFlow.HierarchicLayout(addflow)
public static void HierarchicLayout(
   AddFlow addflow
)
public: static void HierarchicLayout(
   AddFlow* addflow
)
public:
static void HierarchicLayout(
   AddFlow^ addflow
)

Parameters

addflow
The AddFlow control
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutFlow Class
LayoutFlow Members
Overload List


Lassalle.Silverlight.Flow.Layout
HierarchicLayout(AddFlow,Double,Double,Orientation,Size,Int32) Method

Lassalle.Silverlight.Flow.Layout Namespace > LayoutFlow Class > HierarchicLayout Method : HierarchicLayout(AddFlow,Double,Double,Orientation,Size,Int32) Method
The AddFlow control
The distance between two adjacent layers.
The distance between two adjacent vertices
The general direction in which the automatic layout algorithm will position vertices.
The horizontal and vertical margin size.
The maximum number of vertices in a layer. If it is 0, then there is no maximum number of vertices.
Performs the hierarchical layout
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub HierarchicLayout( _
   ByVal addflow As AddFlow, _
   ByVal layerDistance As Double, _
   ByVal vertexDistance As Double, _
   ByVal orientation As Orientation, _
   ByVal marginSize As Size, _
   ByVal layerWidth As Integer _
)
'Usage

Dim addflow As AddFlow
Dim layerDistance As Double
Dim vertexDistance As Double
Dim orientation As Orientation
Dim marginSize As Size
Dim layerWidth As Integer

LayoutFlow.HierarchicLayout(addflow, layerDistance, vertexDistance, orientation, marginSize, layerWidth)
public static void HierarchicLayout(
   AddFlow addflow,
   double layerDistance,
   double vertexDistance,
   Orientation orientation,
   Size marginSize,
   int layerWidth
)
public: static void HierarchicLayout(
   AddFlow* addflow,
   double layerDistance,
   double vertexDistance,
   Orientation orientation,
   Size marginSize,
   int layerWidth
)
public:
static void HierarchicLayout(
   AddFlow^ addflow,
   double layerDistance,
   double vertexDistance,
   Orientation orientation,
   Size marginSize,
   int layerWidth
)

Parameters

addflow
The AddFlow control
layerDistance
The distance between two adjacent layers.
vertexDistance
The distance between two adjacent vertices
orientation
The general direction in which the automatic layout algorithm will position vertices.
marginSize
The horizontal and vertical margin size.
layerWidth
The maximum number of vertices in a layer. If it is 0, then there is no maximum number of vertices.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutFlow Class
LayoutFlow Members
Overload List


Lassalle.Silverlight.Flow.Layout
OrthogonalGridLayout Method

Lassalle.Silverlight.Flow.Layout Namespace > LayoutFlow Class : OrthogonalGridLayout Method
Performs the orthogonal grid layout
Overload List
Overload | Description
OrthogonalGridLayout(AddFlow) | Performs the orthogonal grid layout
OrthogonalGridLayout(AddFlow,Orientation,Size,Int32,Size) | Performs the orthogonal grid layout
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutFlow Class
LayoutFlow Members


Lassalle.Silverlight.Flow.Layout
OrthogonalGridLayout(AddFlow) Method

Lassalle.Silverlight.Flow.Layout Namespace > LayoutFlow Class > OrthogonalGridLayout Method : OrthogonalGridLayout(AddFlow) Method
The AddFlow control
Performs the orthogonal grid layout
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub OrthogonalGridLayout( _
   ByVal addflow As AddFlow _
)
'Usage

Dim addflow As AddFlow

LayoutFlow.OrthogonalGridLayout(addflow)
public static void OrthogonalGridLayout(
   AddFlow addflow
)
public: static void OrthogonalGridLayout(
   AddFlow* addflow
)
public:
static void OrthogonalGridLayout(
   AddFlow^ addflow
)

Parameters

addflow
The AddFlow control
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutFlow Class
LayoutFlow Members
Overload List


Lassalle.Silverlight.Flow.Layout
OrthogonalGridLayout(AddFlow,Orientation,Size,Int32,Size) Method

Lassalle.Silverlight.Flow.Layout Namespace > LayoutFlow Class > OrthogonalGridLayout Method : OrthogonalGridLayout(AddFlow,Orientation,Size,Int32,Size) Method
The AddFlow control
Layout orientation
The horizontal and vertical grid size
The node size expressed in percentage of the grid size
The horizontal and vertical margin size
Performs the orthogonal grid layout
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub OrthogonalGridLayout( _
   ByVal addflow As AddFlow, _
   ByVal orientation As Orientation, _
   ByVal gridSize As Size, _
   ByVal nodeSizeRatio As Integer, _
   ByVal marginSize As Size _
)
'Usage

Dim addflow As AddFlow
Dim orientation As Orientation
Dim gridSize As Size
Dim nodeSizeRatio As Integer
Dim marginSize As Size

LayoutFlow.OrthogonalGridLayout(addflow, orientation, gridSize, nodeSizeRatio, marginSize)
public static void OrthogonalGridLayout(
   AddFlow addflow,
   Orientation orientation,
   Size gridSize,
   int nodeSizeRatio,
   Size marginSize
)
public: static void OrthogonalGridLayout(
   AddFlow* addflow,
   Orientation orientation,
   Size gridSize,
   int nodeSizeRatio,
   Size marginSize
)
public:
static void OrthogonalGridLayout(
   AddFlow^ addflow,
   Orientation orientation,
   Size gridSize,
   int nodeSizeRatio,
   Size marginSize
)

Parameters

addflow
The AddFlow control
orientation
Layout orientation
gridSize
The horizontal and vertical grid size
nodeSizeRatio
The node size expressed in percentage of the grid size
marginSize
The horizontal and vertical margin size
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutFlow Class
LayoutFlow Members
Overload List


Lassalle.Silverlight.Flow.Layout
SeriesParallelLayout Method

Lassalle.Silverlight.Flow.Layout Namespace > LayoutFlow Class : SeriesParallelLayout Method
Performs the Series parallel layout.
Overload List
Overload | Description
SeriesParallelLayout(AddFlow) | Performs the Series parallel layout.
SeriesParallelLayout(AddFlow,SPDrawingStyle,Orientation,Double,Double,Size,Size) | Performs the Series parallel layout.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutFlow Class
LayoutFlow Members


Lassalle.Silverlight.Flow.Layout
SeriesParallelLayout(AddFlow) Method

Lassalle.Silverlight.Flow.Layout Namespace > LayoutFlow Class > SeriesParallelLayout Method : SeriesParallelLayout(AddFlow) Method
The AddFlow control
Performs the Series parallel layout.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub SeriesParallelLayout( _
   ByVal addflow As AddFlow _
)
'Usage

Dim addflow As AddFlow

LayoutFlow.SeriesParallelLayout(addflow)
public static void SeriesParallelLayout(
   AddFlow addflow
)
public: static void SeriesParallelLayout(
   AddFlow* addflow
)
public:
static void SeriesParallelLayout(
   AddFlow^ addflow
)

Parameters

addflow
The AddFlow control
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutFlow Class
LayoutFlow Members
Overload List


Lassalle.Silverlight.Flow.Layout
SeriesParallelLayout(AddFlow,SPDrawingStyle,Orientation,Double,Double,Size,Size) Method

Lassalle.Silverlight.Flow.Layout Namespace > LayoutFlow Class > SeriesParallelLayout Method : SeriesParallelLayout(AddFlow,SPDrawingStyle,Orientation,Double,Double,Size,Size) Method
The AddFlow control
the Series Parallel drawing style
the general direction in which the automatic layout algorithm will position vertices
the distance between two adjacent layers
the distance between two adjacent vertices
the horizontal and vertical vertex size
the horizontal and vertical margin size
Performs the Series parallel layout.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub SeriesParallelLayout( _
   ByVal addflow As AddFlow, _
   ByVal drawingStyle As SPDrawingStyle, _
   ByVal orientation As Orientation, _
   ByVal layerDistance As Double, _
   ByVal vertexDistance As Double, _
   ByVal vertexSize As Size, _
   ByVal marginSize As Size _
)
'Usage

Dim addflow As AddFlow
Dim drawingStyle As SPDrawingStyle
Dim orientation As Orientation
Dim layerDistance As Double
Dim vertexDistance As Double
Dim vertexSize As Size
Dim marginSize As Size

LayoutFlow.SeriesParallelLayout(addflow, drawingStyle, orientation, layerDistance, vertexDistance, vertexSize, marginSize)
public static void SeriesParallelLayout(
   AddFlow addflow,
   SPDrawingStyle drawingStyle,
   Orientation orientation,
   double layerDistance,
   double vertexDistance,
   Size vertexSize,
   Size marginSize
)
public: static void SeriesParallelLayout(
   AddFlow* addflow,
   SPDrawingStyle drawingStyle,
   Orientation orientation,
   double layerDistance,
   double vertexDistance,
   Size vertexSize,
   Size marginSize
)
public:
static void SeriesParallelLayout(
   AddFlow^ addflow,
   SPDrawingStyle drawingStyle,
   Orientation orientation,
   double layerDistance,
   double vertexDistance,
   Size vertexSize,
   Size marginSize
)

Parameters

addflow
The AddFlow control
drawingStyle
the Series Parallel drawing style
orientation
the general direction in which the automatic layout algorithm will position vertices
layerDistance
the distance between two adjacent layers
vertexDistance
the distance between two adjacent vertices
vertexSize
the horizontal and vertical vertex size
marginSize
the horizontal and vertical margin size
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutFlow Class
LayoutFlow Members
Overload List


Lassalle.Silverlight.Flow.Layout
SetIsLogical Method

Lassalle.Silverlight.Flow.Layout Namespace > LayoutFlow Class : SetIsLogical Method
The item to which the attached property is written
The needed boolean value
Sets the value of the IsLogical attached property to a specified element.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub SetIsLogical( _
   ByVal item As DependencyObject, _
   ByVal value As Boolean _
)
'Usage

Dim item As DependencyObject
Dim value As Boolean

LayoutFlow.SetIsLogical(item, value)
public static void SetIsLogical(
   DependencyObject item,
   bool value
)
public: static void SetIsLogical(
   DependencyObject* item,
   bool value
)
public:
static void SetIsLogical(
   DependencyObject^ item,
   bool value
)

Parameters

item
The item to which the attached property is written
value
The needed boolean value
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutFlow Class
LayoutFlow Members


Lassalle.Silverlight.Flow.Layout
SymmetricLayout Method

Lassalle.Silverlight.Flow.Layout Namespace > LayoutFlow Class : SymmetricLayout Method
Performs the symmetic layout.
Overload List
Overload | Description
SymmetricLayout(AddFlow) | Performs the symmetic layout.
SymmetricLayout(AddFlow,Double,Size) | Performs the symmetic layout.
SymmetricLayout(AddFlow,Double,Size,Boolean,Boolean,Boolean) | Performs the symmetic layout.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutFlow Class
LayoutFlow Members


Lassalle.Silverlight.Flow.Layout
SymmetricLayout(AddFlow) Method

Lassalle.Silverlight.Flow.Layout Namespace > LayoutFlow Class > SymmetricLayout Method : SymmetricLayout(AddFlow) Method
The AddFlow control
Performs the symmetic layout.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub SymmetricLayout( _
   ByVal addflow As AddFlow _
)
'Usage

Dim addflow As AddFlow

LayoutFlow.SymmetricLayout(addflow)
public static void SymmetricLayout(
   AddFlow addflow
)
public: static void SymmetricLayout(
   AddFlow* addflow
)
public:
static void SymmetricLayout(
   AddFlow^ addflow
)

Parameters

addflow
The AddFlow control
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutFlow Class
LayoutFlow Members
Overload List


Lassalle.Silverlight.Flow.Layout
SymmetricLayout(AddFlow,Double,Size) Method

Lassalle.Silverlight.Flow.Layout Namespace > LayoutFlow Class > SymmetricLayout Method : SymmetricLayout(AddFlow,Double,Size) Method
The AddFlow control
The distance between two vertices
The horizontal and vertical margin size
Performs the symmetic layout.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub SymmetricLayout( _
   ByVal addflow As AddFlow, _
   ByVal distance As Double, _
   ByVal marginSize As Size _
)
'Usage

Dim addflow As AddFlow
Dim distance As Double
Dim marginSize As Size

LayoutFlow.SymmetricLayout(addflow, distance, marginSize)
public static void SymmetricLayout(
   AddFlow addflow,
   double distance,
   Size marginSize
)
public: static void SymmetricLayout(
   AddFlow* addflow,
   double distance,
   Size marginSize
)
public:
static void SymmetricLayout(
   AddFlow^ addflow,
   double distance,
   Size marginSize
)

Parameters

addflow
The AddFlow control
distance
The distance between two vertices
marginSize
The horizontal and vertical margin size
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutFlow Class
LayoutFlow Members
Overload List


Lassalle.Silverlight.Flow.Layout
SymmetricLayout(AddFlow,Double,Size,Boolean,Boolean,Boolean) Method

Lassalle.Silverlight.Flow.Layout Namespace > LayoutFlow Class > SymmetricLayout Method : SymmetricLayout(AddFlow,Double,Size,Boolean,Boolean,Boolean) Method
The AddFlow control
The distance between two vertices
The horizontal and vertical margin size
Determines whether the layout takes account of the IsXMoveable and IsYMoveable properties of the nodes.
Determines whether the nodes are placed randomly at the beginning of the layout. Normally, SFlow starts by placing the nodes randomly on the control, except if randomStart is False.
Determines whether the Step event is fired at each iteration of the layout algorithm. This property could be used for instance to terminate the algorithm.
Performs the symmetic layout.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub SymmetricLayout( _
   ByVal addflow As AddFlow, _
   ByVal distance As Double, _
   ByVal marginSize As Size, _
   ByVal unmoveableNodesAccepted As Boolean, _
   ByVal randomStart As Boolean, _
   ByVal sendStepEvent As Boolean _
)
'Usage

Dim addflow As AddFlow
Dim distance As Double
Dim marginSize As Size
Dim unmoveableNodesAccepted As Boolean
Dim randomStart As Boolean
Dim sendStepEvent As Boolean

LayoutFlow.SymmetricLayout(addflow, distance, marginSize, unmoveableNodesAccepted, randomStart, sendStepEvent)
public static void SymmetricLayout(
   AddFlow addflow,
   double distance,
   Size marginSize,
   bool unmoveableNodesAccepted,
   bool randomStart,
   bool sendStepEvent
)
public: static void SymmetricLayout(
   AddFlow* addflow,
   double distance,
   Size marginSize,
   bool unmoveableNodesAccepted,
   bool randomStart,
   bool sendStepEvent
)
public:
static void SymmetricLayout(
   AddFlow^ addflow,
   double distance,
   Size marginSize,
   bool unmoveableNodesAccepted,
   bool randomStart,
   bool sendStepEvent
)

Parameters

addflow
The AddFlow control
distance
The distance between two vertices
marginSize
The horizontal and vertical margin size
unmoveableNodesAccepted
Determines whether the layout takes account of the IsXMoveable and IsYMoveable properties of the nodes.
randomStart
Determines whether the nodes are placed randomly at the beginning of the layout. Normally, SFlow starts by placing the nodes randomly on the control, except if randomStart is False.
sendStepEvent
Determines whether the Step event is fired at each iteration of the layout algorithm. This property could be used for instance to terminate the algorithm.
Remarks
If the IsXMoveable property of a node is false and if UnmoveableNodesAccepted is true, then the SFlow layout will move it only vertically. If the IsYMoveable property of a node is false and if UnmoveableNodesAccepted is true, then the SFlow layout will move it only horizontally. If both the IsXMoveable and IsYMoveable properties are false (and if UnmoveableNodesAccepted is true), the node will not move neither vertically neither horizontally.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutFlow Class
LayoutFlow Members
Overload List


Lassalle.Silverlight.Flow.Layout
TreeLayout Method

Lassalle.Silverlight.Flow.Layout Namespace > LayoutFlow Class : TreeLayout Method
Performs the tree layout.
Overload List
Overload | Description
TreeLayout(AddFlow) | Performs the tree layout.
TreeLayout(AddFlow,Double,Double) | Performs the tree layout
TreeLayout(AddFlow,Double,Double,TreeDrawingStyle,Orientation,Size) | Performs the tree layout
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutFlow Class
LayoutFlow Members


Lassalle.Silverlight.Flow.Layout
TreeLayout(AddFlow) Method

Lassalle.Silverlight.Flow.Layout Namespace > LayoutFlow Class > TreeLayout Method : TreeLayout(AddFlow) Method
The AddFlow control
Performs the tree layout.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub TreeLayout( _
   ByVal addflow As AddFlow _
)
'Usage

Dim addflow As AddFlow

LayoutFlow.TreeLayout(addflow)
public static void TreeLayout(
   AddFlow addflow
)
public: static void TreeLayout(
   AddFlow* addflow
)
public:
static void TreeLayout(
   AddFlow^ addflow
)

Parameters

addflow
The AddFlow control
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutFlow Class
LayoutFlow Members
Overload List


Lassalle.Silverlight.Flow.Layout
TreeLayout(AddFlow,Double,Double) Method

Lassalle.Silverlight.Flow.Layout Namespace > LayoutFlow Class > TreeLayout Method : TreeLayout(AddFlow,Double,Double) Method
The AddFlow control
Distance between two adjacent layers.
Distance between two adjacent vertices
Performs the tree layout
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub TreeLayout( _
   ByVal addflow As AddFlow, _
   ByVal layerDistance As Double, _
   ByVal vertexDistance As Double _
)
'Usage

Dim addflow As AddFlow
Dim layerDistance As Double
Dim vertexDistance As Double

LayoutFlow.TreeLayout(addflow, layerDistance, vertexDistance)
public static void TreeLayout(
   AddFlow addflow,
   double layerDistance,
   double vertexDistance
)
public: static void TreeLayout(
   AddFlow* addflow,
   double layerDistance,
   double vertexDistance
)
public:
static void TreeLayout(
   AddFlow^ addflow,
   double layerDistance,
   double vertexDistance
)

Parameters

addflow
The AddFlow control
layerDistance
Distance between two adjacent layers.
vertexDistance
Distance between two adjacent vertices
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutFlow Class
LayoutFlow Members
Overload List


Lassalle.Silverlight.Flow.Layout
TreeLayout(AddFlow,Double,Double,TreeDrawingStyle,Orientation,Size) Method

Lassalle.Silverlight.Flow.Layout Namespace > LayoutFlow Class > TreeLayout Method : TreeLayout(AddFlow,Double,Double,TreeDrawingStyle,Orientation,Size) Method
The AddFlow control
Distance between two adjacent layers.
Distance between two adjacent vertices
tree drawing style
Layout orientation
Horizontal and vertical margin size.
Performs the tree layout
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub TreeLayout( _
   ByVal addflow As AddFlow, _
   ByVal layerDistance As Double, _
   ByVal vertexDistance As Double, _
   ByVal drawingStyle As TreeDrawingStyle, _
   ByVal orientation As Orientation, _
   ByVal marginSize As Size _
)
'Usage

Dim addflow As AddFlow
Dim layerDistance As Double
Dim vertexDistance As Double
Dim drawingStyle As TreeDrawingStyle
Dim orientation As Orientation
Dim marginSize As Size

LayoutFlow.TreeLayout(addflow, layerDistance, vertexDistance, drawingStyle, orientation, marginSize)
public static void TreeLayout(
   AddFlow addflow,
   double layerDistance,
   double vertexDistance,
   TreeDrawingStyle drawingStyle,
   Orientation orientation,
   Size marginSize
)
public: static void TreeLayout(
   AddFlow* addflow,
   double layerDistance,
   double vertexDistance,
   TreeDrawingStyle drawingStyle,
   Orientation orientation,
   Size marginSize
)
public:
static void TreeLayout(
   AddFlow^ addflow,
   double layerDistance,
   double vertexDistance,
   TreeDrawingStyle drawingStyle,
   Orientation orientation,
   Size marginSize
)

Parameters

addflow
The AddFlow control
layerDistance
Distance between two adjacent layers.
vertexDistance
Distance between two adjacent vertices
drawingStyle
tree drawing style
orientation
Layout orientation
marginSize
Horizontal and vertical margin size.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutFlow Class
LayoutFlow Members
Overload List


%%PageItemTitle%% $$Fields$$

Lassalle.Silverlight.Flow.Layout
LayoutFlow Class Fields

Lassalle.Silverlight.Flow.Layout Namespace : LayoutFlow Class

For a list of all members of this type, see LayoutFlow members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | IsLogicalProperty | Identifies the IsLogical attached property.
Top
See Also

Reference

LayoutFlow Class
Lassalle.Silverlight.Flow.Layout Namespace


Lassalle.Silverlight.Flow.Layout
IsLogicalProperty Field

Lassalle.Silverlight.Flow.Layout Namespace > LayoutFlow Class : IsLogicalProperty Field
Identifies the IsLogical attached property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly IsLogicalProperty As DependencyProperty
'Usage

Dim value As DependencyProperty

value = LayoutFlow.IsLogicalProperty
public static readonly DependencyProperty IsLogicalProperty
public: static readonly DependencyProperty* IsLogicalProperty
public:
static readonly DependencyProperty^ IsLogicalProperty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutFlow Class
LayoutFlow Members


%%PageItemTitle%%

Lassalle.Silverlight.Flow.Layout
StepEventArgs Class
Members

Lassalle.Silverlight.Flow.Layout Namespace : StepEventArgs Class
Event parameters used for the Step event
Object Model
StepEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class StepEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As StepEventArgs
public class StepEventArgs : System.EventArgs
public __gc class StepEventArgs : public System.EventArgs
public ref class StepEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Lassalle.Silverlight.Flow.Layout.StepEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StepEventArgs Members
Lassalle.Silverlight.Flow.Layout Namespace


%%PageItemTitle%% $$Members$$

Lassalle.Silverlight.Flow.Layout
StepEventArgs Class Members
Properties

Lassalle.Silverlight.Flow.Layout Namespace : StepEventArgs Class

The following tables list the members exposed by StepEventArgs.

Public Constructors
 | Name | Description
Public Constructor | StepEventArgs Constructor | Constructor. Creates a new StepEventArgs instance.
Top
Public Properties
 | Name | Description
Public Property | Cancel | Gets/sets a value indicating whether the layout should be canceled.
Public Property | Iteration | Gets the current iteration of the layout algorithm.
Top
See Also

Reference

StepEventArgs Class
Lassalle.Silverlight.Flow.Layout Namespace


%%PageItemTitle%%

Lassalle.Silverlight.Flow.Layout
StepEventArgs Constructor

Lassalle.Silverlight.Flow.Layout Namespace > StepEventArgs Class : StepEventArgs Constructor
Current iteration of the layout algorithm
Constructor. Creates a new StepEventArgs instance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal iteration As Integer _
)
'Usage

Dim iteration As Integer

Dim instance As New StepEventArgs(iteration)
public StepEventArgs(
   int iteration
)
public: StepEventArgs(
   int iteration
)
public:
StepEventArgs(
   int iteration
)

Parameters

iteration
Current iteration of the layout algorithm
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StepEventArgs Class
StepEventArgs Members


%%PageItemTitle%% $$Properties$$

Lassalle.Silverlight.Flow.Layout
StepEventArgs Class Properties

Lassalle.Silverlight.Flow.Layout Namespace : StepEventArgs Class

For a list of all members of this type, see StepEventArgs members.

Public Properties
 | Name | Description
Public Property | Cancel | Gets/sets a value indicating whether the layout should be canceled.
Public Property | Iteration | Gets the current iteration of the layout algorithm.
Top
See Also

Reference

StepEventArgs Class
Lassalle.Silverlight.Flow.Layout Namespace


Lassalle.Silverlight.Flow.Layout
Cancel Property (StepEventArgs)

Lassalle.Silverlight.Flow.Layout Namespace > StepEventArgs Class : Cancel Property
Gets/sets a value indicating whether the layout should be canceled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Cancel As Boolean
'Usage

Dim instance As StepEventArgs
Dim value As Boolean

instance.Cancel = value

value = instance.Cancel
public bool Cancel {get; set;}
public: __property bool get_Cancel();
public: __property void set_Cancel(
   bool value
);
public:
property bool Cancel {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StepEventArgs Class
StepEventArgs Members


Lassalle.Silverlight.Flow.Layout
Iteration Property

Lassalle.Silverlight.Flow.Layout Namespace > StepEventArgs Class : Iteration Property
Gets the current iteration of the layout algorithm.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Iteration As Integer
'Usage

Dim instance As StepEventArgs
Dim value As Integer

value = instance.Iteration
public int Iteration {get;}
public: __property int get_Iteration();
public:
property int Iteration {
   int get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StepEventArgs Class
StepEventArgs Members


%%PageItemTitle%%

Lassalle.Silverlight.Flow.Layout
Orientation Enumeration
Members

Lassalle.Silverlight.Flow.Layout Namespace : Orientation Enumeration
Used to specify the general direction in which the automatic layout algorithm will position vertices.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum Orientation
   Inherits System.Enum
'Usage

Dim instance As Orientation
public enum Orientation : System.Enum
__value public enum Orientation : public System.Enum
public enum class Orientation : public System.Enum
Members
Member | Description
East | Start at the right side and proceed toward the left
North | Start at the top and proceed downwards
South | Start at the bottom and proceed upwards
West | Start on the left side and proceed toward the right
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Lassalle.Silverlight.Flow.Layout.Orientation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Lassalle.Silverlight.Flow.Layout Namespace


%%PageItemTitle%%

Lassalle.Silverlight.Flow.Layout
SPDrawingStyle Enumeration
Members

Lassalle.Silverlight.Flow.Layout Namespace : SPDrawingStyle Enumeration
Used to specify the Series Parallel drawing style
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum SPDrawingStyle
   Inherits System.Enum
'Usage

Dim instance As SPDrawingStyle
public enum SPDrawingStyle : System.Enum
__value public enum SPDrawingStyle : public System.Enum
public enum class SPDrawingStyle : public System.Enum
Members
Member | Description
BusOrthogonalDrawing | The has a bus above. The sink has a bus below. All other vertices have exactly one bus above and one bus below.
StraightLine | Each edge is a straight line.
VisibilityDrawing | Each vertex is mapped as a horizontal lne segment and each edge to a vertical line segment
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Lassalle.Silverlight.Flow.Layout.SPDrawingStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Lassalle.Silverlight.Flow.Layout Namespace


%%PageItemTitle%%

Lassalle.Silverlight.Flow.Layout
TreeDrawingStyle Enumeration
Members

Lassalle.Silverlight.Flow.Layout Namespace : TreeDrawingStyle Enumeration
Used to specify the tree drawing style
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum TreeDrawingStyle
   Inherits System.Enum
'Usage

Dim instance As TreeDrawingStyle
public enum TreeDrawingStyle : System.Enum
__value public enum TreeDrawingStyle : public System.Enum
public enum class TreeDrawingStyle : public System.Enum
Members
Member | Description
Layered | Layered tree drawing: vertices are arranged in horizontal (or vertical, depending of the choosen orientation) layers
Radial | Radial tree drawing: the root is placed origin and the layers are concentric circles centered at the origin
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Lassalle.Silverlight.Flow.Layout.TreeDrawingStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Lassalle.Silverlight.Flow.Layout Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Lassalle.Silverlight.Flow.Layout
Lassalle.Silverlight.Flow.Layout Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
Lassalle.Silverlight.Flow.Layout.LayoutFlow
System.EventArgs
Lassalle.Silverlight.Flow.Layout.StepEventArgs
See Also

Reference

Lassalle.Silverlight.Flow.Layout Assembly


%%PageItemTitle%% $$Events$$

BirdView Class Events

Lassalle.Silverlight.Flow Namespace : BirdView Class

For a list of all members of this type, see BirdView members.

Public Events
 | Name | Description
Public Event | BindingValidationError | Occurs when a data validation error is reported by a binding source. (Inherited from System.Windows.FrameworkElement)
Public Event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from System.Windows.FrameworkElement)
Public Event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from System.Windows.UIElement)
Public Event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from System.Windows.UIElement)
Public Event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from System.Windows.UIElement)
Public Event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from System.Windows.UIElement)
Public Event | GotFocus | Occurs when a System.Windows.UIElement receives focus. (Inherited from System.Windows.UIElement)
Public Event | IsEnabledChanged | Occurs when the System.Windows.Controls.Control.IsEnabled property changes. (Inherited from System.Windows.Controls.Control)
Public Event | KeyDown | Occurs when a keyboard key is pressed while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | KeyUp | Occurs when a keyboard key is released while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | Occurs when the layout of the Silverlight visual tree changes. (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | Occurs when a System.Windows.FrameworkElement has been constructed and added to the object tree. (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | Occurs when a System.Windows.UIElement loses focus. (Inherited from System.Windows.UIElement)
Public Event | LostMouseCapture | Occurs when the System.Windows.UIElement loses mouse capture. (Inherited from System.Windows.UIElement)
Public Event | MediaCommand | Occurs when a button is pressed on a remote control. (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | Occurs when the mouse (or a stylus) enters the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | Occurs when the mouse (or the stylus) leaves the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | Occurs when the left mouse button is pressed (or when the tip of the stylus touches the tablet) while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | Occurs when the left mouse button is released (or the tip of the stylus is removed from the tablet) while the mouse (or the stylus) is over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseMove | Occurs when the coordinate position of the mouse (or stylus) changes while over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over a System.Windows.UIElement. However, this event will only be raised if a caller marks the preceding System.Windows.UIElement.MouseRightButtonDown event as handled; see Remarks. (Inherited from System.Windows.UIElement)
Public Event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over a System.Windows.UIElement, or the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | Occurs when either the System.Windows.FrameworkElement.ActualHeight or the System.Windows.FrameworkElement.ActualWidth properties change value on a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Event | TextInput | Occurs when a UI element gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputStart | Occurs when a UI element initially gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputUpdate | Occurs when text continues to be composed via an input method editor (IME). (Inherited from System.Windows.UIElement)
Public Event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from System.Windows.FrameworkElement)
Top
See Also

Reference

BirdView Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Events$$

Connector Class Events

Lassalle.Silverlight.Flow Namespace : Connector Class

For a list of all members of this type, see Connector members.

Public Events
 | Name | Description
Public Event | BindingValidationError | Occurs when a data validation error is reported by a binding source. (Inherited from System.Windows.FrameworkElement)
Public Event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from System.Windows.FrameworkElement)
Public Event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from System.Windows.UIElement)
Public Event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from System.Windows.UIElement)
Public Event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from System.Windows.UIElement)
Public Event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from System.Windows.UIElement)
Public Event | GotFocus | Occurs when a System.Windows.UIElement receives focus. (Inherited from System.Windows.UIElement)
Public Event | IsEnabledChanged | Occurs when the System.Windows.Controls.Control.IsEnabled property changes. (Inherited from System.Windows.Controls.Control)
Public Event | KeyDown | Occurs when a keyboard key is pressed while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | KeyUp | Occurs when a keyboard key is released while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | Occurs when the layout of the Silverlight visual tree changes. (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | Occurs when a System.Windows.FrameworkElement has been constructed and added to the object tree. (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | Occurs when a System.Windows.UIElement loses focus. (Inherited from System.Windows.UIElement)
Public Event | LostMouseCapture | Occurs when the System.Windows.UIElement loses mouse capture. (Inherited from System.Windows.UIElement)
Public Event | MediaCommand | Occurs when a button is pressed on a remote control. (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | Occurs when the mouse (or a stylus) enters the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | Occurs when the mouse (or the stylus) leaves the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | Occurs when the left mouse button is pressed (or when the tip of the stylus touches the tablet) while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | Occurs when the left mouse button is released (or the tip of the stylus is removed from the tablet) while the mouse (or the stylus) is over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseMove | Occurs when the coordinate position of the mouse (or stylus) changes while over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over a System.Windows.UIElement. However, this event will only be raised if a caller marks the preceding System.Windows.UIElement.MouseRightButtonDown event as handled; see Remarks. (Inherited from System.Windows.UIElement)
Public Event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over a System.Windows.UIElement, or the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | Occurs when either the System.Windows.FrameworkElement.ActualHeight or the System.Windows.FrameworkElement.ActualWidth properties change value on a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Event | TextInput | Occurs when a UI element gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputStart | Occurs when a UI element initially gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputUpdate | Occurs when text continues to be composed via an input method editor (IME). (Inherited from System.Windows.UIElement)
Public Event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from System.Windows.FrameworkElement)
Top
See Also

Reference

Connector Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Events$$

ContextHandle Class Events

Lassalle.Silverlight.Flow Namespace : ContextHandle Class

For a list of all members of this type, see ContextHandle members.

Public Events
 | Name | Description
Public Event | BindingValidationError | Occurs when a data validation error is reported by a binding source. (Inherited from System.Windows.FrameworkElement)
Public Event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from System.Windows.FrameworkElement)
Public Event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from System.Windows.UIElement)
Public Event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from System.Windows.UIElement)
Public Event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from System.Windows.UIElement)
Public Event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from System.Windows.UIElement)
Public Event | GotFocus | Occurs when a System.Windows.UIElement receives focus. (Inherited from System.Windows.UIElement)
Public Event | IsEnabledChanged | Occurs when the System.Windows.Controls.Control.IsEnabled property changes. (Inherited from System.Windows.Controls.Control)
Public Event | KeyDown | Occurs when a keyboard key is pressed while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | KeyUp | Occurs when a keyboard key is released while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | Occurs when the layout of the Silverlight visual tree changes. (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | Occurs when a System.Windows.FrameworkElement has been constructed and added to the object tree. (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | Occurs when a System.Windows.UIElement loses focus. (Inherited from System.Windows.UIElement)
Public Event | LostMouseCapture | Occurs when the System.Windows.UIElement loses mouse capture. (Inherited from System.Windows.UIElement)
Public Event | MediaCommand | Occurs when a button is pressed on a remote control. (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | Occurs when the mouse (or a stylus) enters the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | Occurs when the mouse (or the stylus) leaves the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | Occurs when the left mouse button is pressed (or when the tip of the stylus touches the tablet) while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | Occurs when the left mouse button is released (or the tip of the stylus is removed from the tablet) while the mouse (or the stylus) is over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseMove | Occurs when the coordinate position of the mouse (or stylus) changes while over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over a System.Windows.UIElement. However, this event will only be raised if a caller marks the preceding System.Windows.UIElement.MouseRightButtonDown event as handled; see Remarks. (Inherited from System.Windows.UIElement)
Public Event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over a System.Windows.UIElement, or the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | Occurs when either the System.Windows.FrameworkElement.ActualHeight or the System.Windows.FrameworkElement.ActualWidth properties change value on a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Event | TextInput | Occurs when a UI element gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputStart | Occurs when a UI element initially gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputUpdate | Occurs when text continues to be composed via an input method editor (IME). (Inherited from System.Windows.UIElement)
Public Event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from System.Windows.FrameworkElement)
Top
See Also

Reference

ContextHandle Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Methods$$

ContextHandle Class Methods

Lassalle.Silverlight.Flow Namespace : ContextHandle Class

For a list of all members of this type, see ContextHandle members.

Public Methods
 | Name | Description
Public Method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from System.Windows.UIElement)
Public Method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from System.Windows.Controls.Control)
Public Method | Arrange | Positions child objects and determines a size for a System.Windows.UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | CaptureMouse | Sets mouse capture to a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | ClearValue | Clears the local value of a dependency property. (Inherited from System.Windows.DependencyObject)
Public Method | FindName | Retrieves an object that has the specified identifier name. (Inherited from System.Windows.FrameworkElement)
Public Method | Focus | Attempts to set the focus on the control. (Inherited from System.Windows.Controls.Control)
Public Method | GetAnimationBaseValue | Returns any base value established for a Silverlight dependency property, which would apply in cases where an animation is not active. (Inherited from System.Windows.DependencyObject)
Public Method | GetBindingExpression | Retrieves the System.Windows.Data.BindingExpression for a dependency property where a binding is established. (Inherited from System.Windows.FrameworkElement)
Public Method | GetValue | Returns the current effective value of a dependency property from a System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateArrange | Invalidates the arrange state (layout) for a System.Windows.UIElement. After the invalidation, the System.Windows.UIElement will have its layout updated, which will occur asynchronously. (Inherited from System.Windows.UIElement)
Public Method | InvalidateMeasure | Invalidates the measurement state (layout) for a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | Measure | Updates the System.Windows.UIElement.DesiredSize of a System.Windows.UIElement. Typically, objects that implement custom layout for their layout children call this method from their own System.Windows.FrameworkElement.MeasureOverride(System.Windows.Size) implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call System.Windows.Controls.Control.ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in an application. For more information, see Remarks. (Inherited from System.Windows.FrameworkElement)
Public Method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from System.Windows.DependencyObject)
Public Method | ReleaseMouseCapture | Removes mouse capture from a System.Windows.UIElement. After this call, typically no object holds mouse capture. (Inherited from System.Windows.UIElement)
Public Method | RemoveHandler | Removes the specified routed event handler from this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | SetBinding | Attaches a binding to a System.Windows.FrameworkElement, using the provided binding object, and returns a System.Windows.Data.BindingExpressionBase for possible later use. (Inherited from System.Windows.FrameworkElement)
Public Method | SetValue | (Inherited from System.Windows.DependencyObject)
Public Method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the System.Windows.UIElement to the specified object. (Inherited from System.Windows.UIElement)
Public Method | UpdateLayout | Ensures that all positions of child objects of a System.Windows.UIElement are properly updated for layout. (Inherited from System.Windows.UIElement)
Top
Protected Methods
 | Name | Description
Protected Method | ArrangeOverride | (Inherited from System.Windows.FrameworkElement)
Protected Method | GetTemplateChild | Retrieves the named element in the instantiated System.Windows.Controls.ControlTemplate visual tree. (Inherited from System.Windows.Controls.Control)
Protected Method | MeasureOverride | (Inherited from System.Windows.FrameworkElement)
Protected Method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific System.Windows.Automation.Peers.AutomationPeer implementations for the Silverlight automation infrastructure. (Inherited from System.Windows.UIElement)
Protected Method | OnDragEnter | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDragLeave | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDragOver | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDrop | (Inherited from System.Windows.Controls.Control)
Protected Method | OnGotFocus | (Inherited from System.Windows.Controls.Control)
Protected Method | OnKeyDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnKeyUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnLostFocus | (Inherited from System.Windows.Controls.Control)
Protected Method | OnLostMouseCapture | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseEnter | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeave | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeftButtonDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeftButtonUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseMove | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseRightButtonDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseRightButtonUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseWheel | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInput | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInputStart | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInputUpdate | (Inherited from System.Windows.Controls.Control)
Top
See Also

Reference

ContextHandle Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Events$$

Link Class Events

Lassalle.Silverlight.Flow Namespace : Link Class

For a list of all members of this type, see Link members.

Public Events
 | Name | Description
Public Event | BindingValidationError | Occurs when a data validation error is reported by a binding source. (Inherited from System.Windows.FrameworkElement)
Public Event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from System.Windows.FrameworkElement)
Public Event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from System.Windows.UIElement)
Public Event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from System.Windows.UIElement)
Public Event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from System.Windows.UIElement)
Public Event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from System.Windows.UIElement)
Public Event | GotFocus | Occurs when a System.Windows.UIElement receives focus. (Inherited from System.Windows.UIElement)
Public Event | IsEnabledChanged | Occurs when the System.Windows.Controls.Control.IsEnabled property changes. (Inherited from System.Windows.Controls.Control)
Public Event | KeyDown | Occurs when a keyboard key is pressed while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | KeyUp | Occurs when a keyboard key is released while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | Occurs when the layout of the Silverlight visual tree changes. (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | Occurs when a System.Windows.FrameworkElement has been constructed and added to the object tree. (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | Occurs when a System.Windows.UIElement loses focus. (Inherited from System.Windows.UIElement)
Public Event | LostMouseCapture | Occurs when the System.Windows.UIElement loses mouse capture. (Inherited from System.Windows.UIElement)
Public Event | MediaCommand | Occurs when a button is pressed on a remote control. (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | Occurs when the mouse (or a stylus) enters the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | Occurs when the mouse (or the stylus) leaves the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | Occurs when the left mouse button is pressed (or when the tip of the stylus touches the tablet) while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | Occurs when the left mouse button is released (or the tip of the stylus is removed from the tablet) while the mouse (or the stylus) is over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseMove | Occurs when the coordinate position of the mouse (or stylus) changes while over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over a System.Windows.UIElement. However, this event will only be raised if a caller marks the preceding System.Windows.UIElement.MouseRightButtonDown event as handled; see Remarks. (Inherited from System.Windows.UIElement)
Public Event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over a System.Windows.UIElement, or the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | Occurs when either the System.Windows.FrameworkElement.ActualHeight or the System.Windows.FrameworkElement.ActualWidth properties change value on a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Event | TextInput | Occurs when a UI element gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputStart | Occurs when a UI element initially gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputUpdate | Occurs when text continues to be composed via an input method editor (IME). (Inherited from System.Windows.UIElement)
Public Event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from System.Windows.FrameworkElement)
Top
See Also

Reference

Link Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Events$$

Node Class Events

Lassalle.Silverlight.Flow Namespace : Node Class

For a list of all members of this type, see Node members.

Public Events
 | Name | Description
Public Event | BindingValidationError | Occurs when a data validation error is reported by a binding source. (Inherited from System.Windows.FrameworkElement)
Public Event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from System.Windows.FrameworkElement)
Public Event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from System.Windows.UIElement)
Public Event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from System.Windows.UIElement)
Public Event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from System.Windows.UIElement)
Public Event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from System.Windows.UIElement)
Public Event | GotFocus | Occurs when a System.Windows.UIElement receives focus. (Inherited from System.Windows.UIElement)
Public Event | IsEnabledChanged | Occurs when the System.Windows.Controls.Control.IsEnabled property changes. (Inherited from System.Windows.Controls.Control)
Public Event | KeyDown | Occurs when a keyboard key is pressed while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | KeyUp | Occurs when a keyboard key is released while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | Occurs when the layout of the Silverlight visual tree changes. (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | Occurs when a System.Windows.FrameworkElement has been constructed and added to the object tree. (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | Occurs when a System.Windows.UIElement loses focus. (Inherited from System.Windows.UIElement)
Public Event | LostMouseCapture | Occurs when the System.Windows.UIElement loses mouse capture. (Inherited from System.Windows.UIElement)
Public Event | MediaCommand | Occurs when a button is pressed on a remote control. (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | Occurs when the mouse (or a stylus) enters the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | Occurs when the mouse (or the stylus) leaves the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | Occurs when the left mouse button is pressed (or when the tip of the stylus touches the tablet) while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | Occurs when the left mouse button is released (or the tip of the stylus is removed from the tablet) while the mouse (or the stylus) is over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseMove | Occurs when the coordinate position of the mouse (or stylus) changes while over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over a System.Windows.UIElement. However, this event will only be raised if a caller marks the preceding System.Windows.UIElement.MouseRightButtonDown event as handled; see Remarks. (Inherited from System.Windows.UIElement)
Public Event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over a System.Windows.UIElement, or the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | Occurs when either the System.Windows.FrameworkElement.ActualHeight or the System.Windows.FrameworkElement.ActualWidth properties change value on a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Event | TextInput | Occurs when a UI element gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputStart | Occurs when a UI element initially gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputUpdate | Occurs when text continues to be composed via an input method editor (IME). (Inherited from System.Windows.UIElement)
Public Event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from System.Windows.FrameworkElement)
Top
See Also

Reference

Node Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Events$$

Pin Class Events

Lassalle.Silverlight.Flow Namespace : Pin Class

For a list of all members of this type, see Pin members.

Public Events
 | Name | Description
Public Event | BindingValidationError | Occurs when a data validation error is reported by a binding source. (Inherited from System.Windows.FrameworkElement)
Public Event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from System.Windows.FrameworkElement)
Public Event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from System.Windows.UIElement)
Public Event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from System.Windows.UIElement)
Public Event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from System.Windows.UIElement)
Public Event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from System.Windows.UIElement)
Public Event | GotFocus | Occurs when a System.Windows.UIElement receives focus. (Inherited from System.Windows.UIElement)
Public Event | IsEnabledChanged | Occurs when the System.Windows.Controls.Control.IsEnabled property changes. (Inherited from System.Windows.Controls.Control)
Public Event | KeyDown | Occurs when a keyboard key is pressed while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | KeyUp | Occurs when a keyboard key is released while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | Occurs when the layout of the Silverlight visual tree changes. (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | Occurs when a System.Windows.FrameworkElement has been constructed and added to the object tree. (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | Occurs when a System.Windows.UIElement loses focus. (Inherited from System.Windows.UIElement)
Public Event | LostMouseCapture | Occurs when the System.Windows.UIElement loses mouse capture. (Inherited from System.Windows.UIElement)
Public Event | MediaCommand | Occurs when a button is pressed on a remote control. (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | Occurs when the mouse (or a stylus) enters the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | Occurs when the mouse (or the stylus) leaves the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | Occurs when the left mouse button is pressed (or when the tip of the stylus touches the tablet) while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | Occurs when the left mouse button is released (or the tip of the stylus is removed from the tablet) while the mouse (or the stylus) is over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseMove | Occurs when the coordinate position of the mouse (or stylus) changes while over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over a System.Windows.UIElement. However, this event will only be raised if a caller marks the preceding System.Windows.UIElement.MouseRightButtonDown event as handled; see Remarks. (Inherited from System.Windows.UIElement)
Public Event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over a System.Windows.UIElement, or the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | Occurs when either the System.Windows.FrameworkElement.ActualHeight or the System.Windows.FrameworkElement.ActualWidth properties change value on a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Event | TextInput | Occurs when a UI element gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputStart | Occurs when a UI element initially gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputUpdate | Occurs when text continues to be composed via an input method editor (IME). (Inherited from System.Windows.UIElement)
Public Event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from System.Windows.FrameworkElement)
Top
See Also

Reference

Pin Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Methods$$

Pin Class Methods

Lassalle.Silverlight.Flow Namespace : Pin Class

For a list of all members of this type, see Pin members.

Public Methods
 | Name | Description
Public Method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from System.Windows.UIElement)
Public Method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from System.Windows.Controls.Control)
Public Method | Arrange | Positions child objects and determines a size for a System.Windows.UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | CaptureMouse | Sets mouse capture to a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | ClearValue | Clears the local value of a dependency property. (Inherited from System.Windows.DependencyObject)
Public Method | FindName | Retrieves an object that has the specified identifier name. (Inherited from System.Windows.FrameworkElement)
Public Method | Focus | Attempts to set the focus on the control. (Inherited from System.Windows.Controls.Control)
Public Method | GetAnimationBaseValue | Returns any base value established for a Silverlight dependency property, which would apply in cases where an animation is not active. (Inherited from System.Windows.DependencyObject)
Public Method | GetBindingExpression | Retrieves the System.Windows.Data.BindingExpression for a dependency property where a binding is established. (Inherited from System.Windows.FrameworkElement)
Public Method | GetValue | Returns the current effective value of a dependency property from a System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateArrange | Invalidates the arrange state (layout) for a System.Windows.UIElement. After the invalidation, the System.Windows.UIElement will have its layout updated, which will occur asynchronously. (Inherited from System.Windows.UIElement)
Public Method | InvalidateMeasure | Invalidates the measurement state (layout) for a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | Measure | Updates the System.Windows.UIElement.DesiredSize of a System.Windows.UIElement. Typically, objects that implement custom layout for their layout children call this method from their own System.Windows.FrameworkElement.MeasureOverride(System.Windows.Size) implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call System.Windows.Controls.Control.ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in an application. For more information, see Remarks. (Inherited from System.Windows.FrameworkElement)
Public Method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from System.Windows.DependencyObject)
Public Method | ReleaseMouseCapture | Removes mouse capture from a System.Windows.UIElement. After this call, typically no object holds mouse capture. (Inherited from System.Windows.UIElement)
Public Method | RemoveHandler | Removes the specified routed event handler from this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | SetBinding | Attaches a binding to a System.Windows.FrameworkElement, using the provided binding object, and returns a System.Windows.Data.BindingExpressionBase for possible later use. (Inherited from System.Windows.FrameworkElement)
Public Method | SetValue | (Inherited from System.Windows.DependencyObject)
Public Method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the System.Windows.UIElement to the specified object. (Inherited from System.Windows.UIElement)
Public Method | UpdateLayout | Ensures that all positions of child objects of a System.Windows.UIElement are properly updated for layout. (Inherited from System.Windows.UIElement)
Top
Protected Methods
 | Name | Description
Protected Method | ArrangeOverride | (Inherited from System.Windows.FrameworkElement)
Protected Method | GetTemplateChild | Retrieves the named element in the instantiated System.Windows.Controls.ControlTemplate visual tree. (Inherited from System.Windows.Controls.Control)
Protected Method | MeasureOverride | (Inherited from System.Windows.FrameworkElement)
Protected Method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific System.Windows.Automation.Peers.AutomationPeer implementations for the Silverlight automation infrastructure. (Inherited from System.Windows.UIElement)
Protected Method | OnDragEnter | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDragLeave | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDragOver | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDrop | (Inherited from System.Windows.Controls.Control)
Protected Method | OnGotFocus | (Inherited from System.Windows.Controls.Control)
Protected Method | OnKeyDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnKeyUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnLostFocus | (Inherited from System.Windows.Controls.Control)
Protected Method | OnLostMouseCapture | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseEnter | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeave | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeftButtonDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeftButtonUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseMove | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseRightButtonDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseRightButtonUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseWheel | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInput | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInputStart | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInputUpdate | (Inherited from System.Windows.Controls.Control)
Top
See Also

Reference

Pin Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Events$$

ResizeHandle Class Events

Lassalle.Silverlight.Flow Namespace : ResizeHandle Class

For a list of all members of this type, see ResizeHandle members.

Public Events
 | Name | Description
Public Event | BindingValidationError | Occurs when a data validation error is reported by a binding source. (Inherited from System.Windows.FrameworkElement)
Public Event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from System.Windows.FrameworkElement)
Public Event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from System.Windows.UIElement)
Public Event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from System.Windows.UIElement)
Public Event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from System.Windows.UIElement)
Public Event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from System.Windows.UIElement)
Public Event | GotFocus | Occurs when a System.Windows.UIElement receives focus. (Inherited from System.Windows.UIElement)
Public Event | IsEnabledChanged | Occurs when the System.Windows.Controls.Control.IsEnabled property changes. (Inherited from System.Windows.Controls.Control)
Public Event | KeyDown | Occurs when a keyboard key is pressed while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | KeyUp | Occurs when a keyboard key is released while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | Occurs when the layout of the Silverlight visual tree changes. (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | Occurs when a System.Windows.FrameworkElement has been constructed and added to the object tree. (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | Occurs when a System.Windows.UIElement loses focus. (Inherited from System.Windows.UIElement)
Public Event | LostMouseCapture | Occurs when the System.Windows.UIElement loses mouse capture. (Inherited from System.Windows.UIElement)
Public Event | MediaCommand | Occurs when a button is pressed on a remote control. (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | Occurs when the mouse (or a stylus) enters the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | Occurs when the mouse (or the stylus) leaves the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | Occurs when the left mouse button is pressed (or when the tip of the stylus touches the tablet) while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | Occurs when the left mouse button is released (or the tip of the stylus is removed from the tablet) while the mouse (or the stylus) is over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseMove | Occurs when the coordinate position of the mouse (or stylus) changes while over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over a System.Windows.UIElement. However, this event will only be raised if a caller marks the preceding System.Windows.UIElement.MouseRightButtonDown event as handled; see Remarks. (Inherited from System.Windows.UIElement)
Public Event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over a System.Windows.UIElement, or the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | Occurs when either the System.Windows.FrameworkElement.ActualHeight or the System.Windows.FrameworkElement.ActualWidth properties change value on a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Event | TextInput | Occurs when a UI element gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputStart | Occurs when a UI element initially gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputUpdate | Occurs when text continues to be composed via an input method editor (IME). (Inherited from System.Windows.UIElement)
Public Event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from System.Windows.FrameworkElement)
Top
See Also

Reference

ResizeHandle Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Methods$$

ResizeHandle Class Methods

Lassalle.Silverlight.Flow Namespace : ResizeHandle Class

For a list of all members of this type, see ResizeHandle members.

Public Methods
 | Name | Description
Public Method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from System.Windows.UIElement)
Public Method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from System.Windows.Controls.Control)
Public Method | Arrange | Positions child objects and determines a size for a System.Windows.UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | CaptureMouse | Sets mouse capture to a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | ClearValue | Clears the local value of a dependency property. (Inherited from System.Windows.DependencyObject)
Public Method | FindName | Retrieves an object that has the specified identifier name. (Inherited from System.Windows.FrameworkElement)
Public Method | Focus | Attempts to set the focus on the control. (Inherited from System.Windows.Controls.Control)
Public Method | GetAnimationBaseValue | Returns any base value established for a Silverlight dependency property, which would apply in cases where an animation is not active. (Inherited from System.Windows.DependencyObject)
Public Method | GetBindingExpression | Retrieves the System.Windows.Data.BindingExpression for a dependency property where a binding is established. (Inherited from System.Windows.FrameworkElement)
Public Method | GetValue | Returns the current effective value of a dependency property from a System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateArrange | Invalidates the arrange state (layout) for a System.Windows.UIElement. After the invalidation, the System.Windows.UIElement will have its layout updated, which will occur asynchronously. (Inherited from System.Windows.UIElement)
Public Method | InvalidateMeasure | Invalidates the measurement state (layout) for a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | Measure | Updates the System.Windows.UIElement.DesiredSize of a System.Windows.UIElement. Typically, objects that implement custom layout for their layout children call this method from their own System.Windows.FrameworkElement.MeasureOverride(System.Windows.Size) implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call System.Windows.Controls.Control.ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in an application. For more information, see Remarks. (Inherited from System.Windows.FrameworkElement)
Public Method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from System.Windows.DependencyObject)
Public Method | ReleaseMouseCapture | Removes mouse capture from a System.Windows.UIElement. After this call, typically no object holds mouse capture. (Inherited from System.Windows.UIElement)
Public Method | RemoveHandler | Removes the specified routed event handler from this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | SetBinding | Attaches a binding to a System.Windows.FrameworkElement, using the provided binding object, and returns a System.Windows.Data.BindingExpressionBase for possible later use. (Inherited from System.Windows.FrameworkElement)
Public Method | SetValue | (Inherited from System.Windows.DependencyObject)
Public Method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the System.Windows.UIElement to the specified object. (Inherited from System.Windows.UIElement)
Public Method | UpdateLayout | Ensures that all positions of child objects of a System.Windows.UIElement are properly updated for layout. (Inherited from System.Windows.UIElement)
Top
Protected Methods
 | Name | Description
Protected Method | ArrangeOverride | (Inherited from System.Windows.FrameworkElement)
Protected Method | GetTemplateChild | Retrieves the named element in the instantiated System.Windows.Controls.ControlTemplate visual tree. (Inherited from System.Windows.Controls.Control)
Protected Method | MeasureOverride | (Inherited from System.Windows.FrameworkElement)
Protected Method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific System.Windows.Automation.Peers.AutomationPeer implementations for the Silverlight automation infrastructure. (Inherited from System.Windows.UIElement)
Protected Method | OnDragEnter | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDragLeave | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDragOver | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDrop | (Inherited from System.Windows.Controls.Control)
Protected Method | OnGotFocus | (Inherited from System.Windows.Controls.Control)
Protected Method | OnKeyDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnKeyUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnLostFocus | (Inherited from System.Windows.Controls.Control)
Protected Method | OnLostMouseCapture | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseEnter | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeave | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeftButtonDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeftButtonUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseMove | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseRightButtonDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseRightButtonUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseWheel | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInput | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInputStart | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInputUpdate | (Inherited from System.Windows.Controls.Control)
Top
See Also

Reference

ResizeHandle Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Events$$

RotateHandle Class Events

Lassalle.Silverlight.Flow Namespace : RotateHandle Class

For a list of all members of this type, see RotateHandle members.

Public Events
 | Name | Description
Public Event | BindingValidationError | Occurs when a data validation error is reported by a binding source. (Inherited from System.Windows.FrameworkElement)
Public Event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from System.Windows.FrameworkElement)
Public Event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from System.Windows.UIElement)
Public Event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from System.Windows.UIElement)
Public Event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from System.Windows.UIElement)
Public Event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from System.Windows.UIElement)
Public Event | GotFocus | Occurs when a System.Windows.UIElement receives focus. (Inherited from System.Windows.UIElement)
Public Event | IsEnabledChanged | Occurs when the System.Windows.Controls.Control.IsEnabled property changes. (Inherited from System.Windows.Controls.Control)
Public Event | KeyDown | Occurs when a keyboard key is pressed while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | KeyUp | Occurs when a keyboard key is released while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | Occurs when the layout of the Silverlight visual tree changes. (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | Occurs when a System.Windows.FrameworkElement has been constructed and added to the object tree. (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | Occurs when a System.Windows.UIElement loses focus. (Inherited from System.Windows.UIElement)
Public Event | LostMouseCapture | Occurs when the System.Windows.UIElement loses mouse capture. (Inherited from System.Windows.UIElement)
Public Event | MediaCommand | Occurs when a button is pressed on a remote control. (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | Occurs when the mouse (or a stylus) enters the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | Occurs when the mouse (or the stylus) leaves the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | Occurs when the left mouse button is pressed (or when the tip of the stylus touches the tablet) while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | Occurs when the left mouse button is released (or the tip of the stylus is removed from the tablet) while the mouse (or the stylus) is over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseMove | Occurs when the coordinate position of the mouse (or stylus) changes while over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over a System.Windows.UIElement. However, this event will only be raised if a caller marks the preceding System.Windows.UIElement.MouseRightButtonDown event as handled; see Remarks. (Inherited from System.Windows.UIElement)
Public Event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over a System.Windows.UIElement, or the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | Occurs when either the System.Windows.FrameworkElement.ActualHeight or the System.Windows.FrameworkElement.ActualWidth properties change value on a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Event | TextInput | Occurs when a UI element gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputStart | Occurs when a UI element initially gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputUpdate | Occurs when text continues to be composed via an input method editor (IME). (Inherited from System.Windows.UIElement)
Public Event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from System.Windows.FrameworkElement)
Top
See Also

Reference

RotateHandle Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Methods$$

RotateHandle Class Methods

Lassalle.Silverlight.Flow Namespace : RotateHandle Class

For a list of all members of this type, see RotateHandle members.

Public Methods
 | Name | Description
Public Method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from System.Windows.UIElement)
Public Method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from System.Windows.Controls.Control)
Public Method | Arrange | Positions child objects and determines a size for a System.Windows.UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | CaptureMouse | Sets mouse capture to a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | ClearValue | Clears the local value of a dependency property. (Inherited from System.Windows.DependencyObject)
Public Method | FindName | Retrieves an object that has the specified identifier name. (Inherited from System.Windows.FrameworkElement)
Public Method | Focus | Attempts to set the focus on the control. (Inherited from System.Windows.Controls.Control)
Public Method | GetAnimationBaseValue | Returns any base value established for a Silverlight dependency property, which would apply in cases where an animation is not active. (Inherited from System.Windows.DependencyObject)
Public Method | GetBindingExpression | Retrieves the System.Windows.Data.BindingExpression for a dependency property where a binding is established. (Inherited from System.Windows.FrameworkElement)
Public Method | GetValue | Returns the current effective value of a dependency property from a System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateArrange | Invalidates the arrange state (layout) for a System.Windows.UIElement. After the invalidation, the System.Windows.UIElement will have its layout updated, which will occur asynchronously. (Inherited from System.Windows.UIElement)
Public Method | InvalidateMeasure | Invalidates the measurement state (layout) for a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | Measure | Updates the System.Windows.UIElement.DesiredSize of a System.Windows.UIElement. Typically, objects that implement custom layout for their layout children call this method from their own System.Windows.FrameworkElement.MeasureOverride(System.Windows.Size) implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call System.Windows.Controls.Control.ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in an application. For more information, see Remarks. (Inherited from System.Windows.FrameworkElement)
Public Method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from System.Windows.DependencyObject)
Public Method | ReleaseMouseCapture | Removes mouse capture from a System.Windows.UIElement. After this call, typically no object holds mouse capture. (Inherited from System.Windows.UIElement)
Public Method | RemoveHandler | Removes the specified routed event handler from this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | SetBinding | Attaches a binding to a System.Windows.FrameworkElement, using the provided binding object, and returns a System.Windows.Data.BindingExpressionBase for possible later use. (Inherited from System.Windows.FrameworkElement)
Public Method | SetValue | (Inherited from System.Windows.DependencyObject)
Public Method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the System.Windows.UIElement to the specified object. (Inherited from System.Windows.UIElement)
Public Method | UpdateLayout | Ensures that all positions of child objects of a System.Windows.UIElement are properly updated for layout. (Inherited from System.Windows.UIElement)
Top
Protected Methods
 | Name | Description
Protected Method | ArrangeOverride | (Inherited from System.Windows.FrameworkElement)
Protected Method | GetTemplateChild | Retrieves the named element in the instantiated System.Windows.Controls.ControlTemplate visual tree. (Inherited from System.Windows.Controls.Control)
Protected Method | MeasureOverride | (Inherited from System.Windows.FrameworkElement)
Protected Method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific System.Windows.Automation.Peers.AutomationPeer implementations for the Silverlight automation infrastructure. (Inherited from System.Windows.UIElement)
Protected Method | OnDragEnter | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDragLeave | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDragOver | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDrop | (Inherited from System.Windows.Controls.Control)
Protected Method | OnGotFocus | (Inherited from System.Windows.Controls.Control)
Protected Method | OnKeyDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnKeyUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnLostFocus | (Inherited from System.Windows.Controls.Control)
Protected Method | OnLostMouseCapture | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseEnter | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeave | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeftButtonDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeftButtonUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseMove | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseRightButtonDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseRightButtonUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseWheel | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInput | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInputStart | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInputUpdate | (Inherited from System.Windows.Controls.Control)
Top
See Also

Reference

RotateHandle Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Events$$

SelectionBox Class Events

Lassalle.Silverlight.Flow Namespace : SelectionBox Class

For a list of all members of this type, see SelectionBox members.

Public Events
 | Name | Description
Public Event | BindingValidationError | Occurs when a data validation error is reported by a binding source. (Inherited from System.Windows.FrameworkElement)
Public Event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from System.Windows.FrameworkElement)
Public Event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from System.Windows.UIElement)
Public Event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from System.Windows.UIElement)
Public Event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from System.Windows.UIElement)
Public Event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from System.Windows.UIElement)
Public Event | GotFocus | Occurs when a System.Windows.UIElement receives focus. (Inherited from System.Windows.UIElement)
Public Event | IsEnabledChanged | Occurs when the System.Windows.Controls.Control.IsEnabled property changes. (Inherited from System.Windows.Controls.Control)
Public Event | KeyDown | Occurs when a keyboard key is pressed while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | KeyUp | Occurs when a keyboard key is released while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | Occurs when the layout of the Silverlight visual tree changes. (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | Occurs when a System.Windows.FrameworkElement has been constructed and added to the object tree. (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | Occurs when a System.Windows.UIElement loses focus. (Inherited from System.Windows.UIElement)
Public Event | LostMouseCapture | Occurs when the System.Windows.UIElement loses mouse capture. (Inherited from System.Windows.UIElement)
Public Event | MediaCommand | Occurs when a button is pressed on a remote control. (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | Occurs when the mouse (or a stylus) enters the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | Occurs when the mouse (or the stylus) leaves the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | Occurs when the left mouse button is pressed (or when the tip of the stylus touches the tablet) while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | Occurs when the left mouse button is released (or the tip of the stylus is removed from the tablet) while the mouse (or the stylus) is over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseMove | Occurs when the coordinate position of the mouse (or stylus) changes while over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over a System.Windows.UIElement. However, this event will only be raised if a caller marks the preceding System.Windows.UIElement.MouseRightButtonDown event as handled; see Remarks. (Inherited from System.Windows.UIElement)
Public Event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over a System.Windows.UIElement, or the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | Occurs when either the System.Windows.FrameworkElement.ActualHeight or the System.Windows.FrameworkElement.ActualWidth properties change value on a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Event | TextInput | Occurs when a UI element gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputStart | Occurs when a UI element initially gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputUpdate | Occurs when text continues to be composed via an input method editor (IME). (Inherited from System.Windows.UIElement)
Public Event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from System.Windows.FrameworkElement)
Top
See Also

Reference

SelectionBox Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Methods$$

SelectionBox Class Methods

Lassalle.Silverlight.Flow Namespace : SelectionBox Class

For a list of all members of this type, see SelectionBox members.

Public Methods
 | Name | Description
Public Method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from System.Windows.UIElement)
Public Method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from System.Windows.Controls.Control)
Public Method | Arrange | Positions child objects and determines a size for a System.Windows.UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | CaptureMouse | Sets mouse capture to a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | ClearValue | Clears the local value of a dependency property. (Inherited from System.Windows.DependencyObject)
Public Method | FindName | Retrieves an object that has the specified identifier name. (Inherited from System.Windows.FrameworkElement)
Public Method | Focus | Attempts to set the focus on the control. (Inherited from System.Windows.Controls.Control)
Public Method | GetAnimationBaseValue | Returns any base value established for a Silverlight dependency property, which would apply in cases where an animation is not active. (Inherited from System.Windows.DependencyObject)
Public Method | GetBindingExpression | Retrieves the System.Windows.Data.BindingExpression for a dependency property where a binding is established. (Inherited from System.Windows.FrameworkElement)
Public Method | GetValue | Returns the current effective value of a dependency property from a System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateArrange | Invalidates the arrange state (layout) for a System.Windows.UIElement. After the invalidation, the System.Windows.UIElement will have its layout updated, which will occur asynchronously. (Inherited from System.Windows.UIElement)
Public Method | InvalidateMeasure | Invalidates the measurement state (layout) for a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | Measure | Updates the System.Windows.UIElement.DesiredSize of a System.Windows.UIElement. Typically, objects that implement custom layout for their layout children call this method from their own System.Windows.FrameworkElement.MeasureOverride(System.Windows.Size) implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call System.Windows.Controls.Control.ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in an application. For more information, see Remarks. (Inherited from System.Windows.FrameworkElement)
Public Method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from System.Windows.DependencyObject)
Public Method | ReleaseMouseCapture | Removes mouse capture from a System.Windows.UIElement. After this call, typically no object holds mouse capture. (Inherited from System.Windows.UIElement)
Public Method | RemoveHandler | Removes the specified routed event handler from this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | SetBinding | Attaches a binding to a System.Windows.FrameworkElement, using the provided binding object, and returns a System.Windows.Data.BindingExpressionBase for possible later use. (Inherited from System.Windows.FrameworkElement)
Public Method | SetValue | (Inherited from System.Windows.DependencyObject)
Public Method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the System.Windows.UIElement to the specified object. (Inherited from System.Windows.UIElement)
Public Method | UpdateLayout | Ensures that all positions of child objects of a System.Windows.UIElement are properly updated for layout. (Inherited from System.Windows.UIElement)
Top
Protected Methods
 | Name | Description
Protected Method | ArrangeOverride | (Inherited from System.Windows.FrameworkElement)
Protected Method | GetTemplateChild | Retrieves the named element in the instantiated System.Windows.Controls.ControlTemplate visual tree. (Inherited from System.Windows.Controls.Control)
Protected Method | MeasureOverride | (Inherited from System.Windows.FrameworkElement)
Protected Method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific System.Windows.Automation.Peers.AutomationPeer implementations for the Silverlight automation infrastructure. (Inherited from System.Windows.UIElement)
Protected Method | OnDragEnter | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDragLeave | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDragOver | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDrop | (Inherited from System.Windows.Controls.Control)
Protected Method | OnGotFocus | (Inherited from System.Windows.Controls.Control)
Protected Method | OnKeyDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnKeyUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnLostFocus | (Inherited from System.Windows.Controls.Control)
Protected Method | OnLostMouseCapture | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseEnter | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeave | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeftButtonDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeftButtonUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseMove | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseRightButtonDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseRightButtonUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseWheel | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInput | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInputStart | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInputUpdate | (Inherited from System.Windows.Controls.Control)
Top
See Also

Reference

SelectionBox Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Properties$$

SelectionBox Class Properties

Lassalle.Silverlight.Flow Namespace : SelectionBox Class

For a list of all members of this type, see SelectionBox members.

Public Properties
 | Name | Description
Public Property | ActualHeight | Gets the rendered height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | Gets the rendered width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | AllowDrop | Gets or sets a value that determines whether this System.Windows.UIElement can be a drop target for purposes of Silverlight drag-and-drop operations. (Inherited from System.Windows.UIElement)
Public Property | Background | Gets or sets a brush that provides the background of the control. (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from System.Windows.Controls.Control)
Public Property | CacheMode | Gets or sets a value that indicates that rendered content should be cached when possible. (Inherited from System.Windows.UIElement)
Public Property | CharacterSpacing | Gets or sets the distance between characters of text in the control measured in 1000ths of the font size. (Inherited from System.Windows.Controls.Control)
Public Property | Clip | Gets or sets the System.Windows.Media.Geometry used to define the outline of the contents of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | Cursor | Gets or sets the cursor image that displays while the mouse pointer is over a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | Gets or sets the data context for a System.Windows.FrameworkElement when it participates in data binding. (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | Gets the size that this System.Windows.UIElement computed during the measure pass of the layout process. (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | Gets the System.Windows.Threading.Dispatcher this object is associated with. (Inherited from System.Windows.DependencyObject)
Public Property | Effect | Gets or sets the pixel shader effect to use for rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | FlowDirection | Gets or sets the direction that text and other user interface elements flow within any parent element that controls their layout. (Inherited from System.Windows.FrameworkElement)
Public Property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | Gets or sets the size of the text in this control. (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from System.Windows.Controls.Control)
Public Property | Height | Gets or sets the suggested height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | Gets or sets whether the contained area of this System.Windows.UIElement can return true values for hit testing. (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from System.Windows.Controls.Control)
Public Property | Language | Gets or sets localization/globalization language information that applies to a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | Gets or sets the outer margin of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | Gets or sets the maximum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | Gets or sets the maximum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | Gets or sets the minimum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | Gets or sets the minimum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | Gets or sets the brush used to alter the opacity of regions of this object. (Inherited from System.Windows.UIElement)
Public Property | Padding | Gets or sets the padding inside a control. (Inherited from System.Windows.Controls.Control)
Public Property | Parent | Gets the parent object of this System.Windows.FrameworkElement in the object tree. (Inherited from System.Windows.FrameworkElement)
Public Property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderSize | Gets the final render size of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | Gets or sets transform information that affects the rendering position of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by System.Windows.UIElement.RenderTransform, relative to the bounds of the System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from System.Windows.FrameworkElement)
Public Property | Style | Gets or sets an instance System.Windows.Style that is applied for this object during rendering. (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | Gets or sets a value that modifies how tabbing and System.Windows.Controls.Control.TabIndex work for this control. (Inherited from System.Windows.Controls.Control)
Public Property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from System.Windows.FrameworkElement)
Public Property | Template | Gets or sets a control template. (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | Gets the collection of triggers for animations that are defined for a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from System.Windows.UIElement)
Public Property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | Gets or sets the visibility of a System.Windows.UIElement. A System.Windows.UIElement that is not visible does not render and does not communicate its desired size to layout. (Inherited from System.Windows.UIElement)
Public Property | Width | Gets or sets the width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Top
Protected Properties
 | Name | Description
Protected Property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from System.Windows.Controls.Control)
Top
See Also

Reference

SelectionBox Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Events$$

StretchHandle Class Events

Lassalle.Silverlight.Flow Namespace : StretchHandle Class

For a list of all members of this type, see StretchHandle members.

Public Events
 | Name | Description
Public Event | BindingValidationError | Occurs when a data validation error is reported by a binding source. (Inherited from System.Windows.FrameworkElement)
Public Event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from System.Windows.FrameworkElement)
Public Event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from System.Windows.UIElement)
Public Event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from System.Windows.UIElement)
Public Event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from System.Windows.UIElement)
Public Event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from System.Windows.UIElement)
Public Event | GotFocus | Occurs when a System.Windows.UIElement receives focus. (Inherited from System.Windows.UIElement)
Public Event | IsEnabledChanged | Occurs when the System.Windows.Controls.Control.IsEnabled property changes. (Inherited from System.Windows.Controls.Control)
Public Event | KeyDown | Occurs when a keyboard key is pressed while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | KeyUp | Occurs when a keyboard key is released while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | Occurs when the layout of the Silverlight visual tree changes. (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | Occurs when a System.Windows.FrameworkElement has been constructed and added to the object tree. (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | Occurs when a System.Windows.UIElement loses focus. (Inherited from System.Windows.UIElement)
Public Event | LostMouseCapture | Occurs when the System.Windows.UIElement loses mouse capture. (Inherited from System.Windows.UIElement)
Public Event | MediaCommand | Occurs when a button is pressed on a remote control. (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | Occurs when the mouse (or a stylus) enters the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | Occurs when the mouse (or the stylus) leaves the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | Occurs when the left mouse button is pressed (or when the tip of the stylus touches the tablet) while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | Occurs when the left mouse button is released (or the tip of the stylus is removed from the tablet) while the mouse (or the stylus) is over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseMove | Occurs when the coordinate position of the mouse (or stylus) changes while over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over a System.Windows.UIElement. However, this event will only be raised if a caller marks the preceding System.Windows.UIElement.MouseRightButtonDown event as handled; see Remarks. (Inherited from System.Windows.UIElement)
Public Event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over a System.Windows.UIElement, or the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | Occurs when either the System.Windows.FrameworkElement.ActualHeight or the System.Windows.FrameworkElement.ActualWidth properties change value on a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Event | TextInput | Occurs when a UI element gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputStart | Occurs when a UI element initially gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputUpdate | Occurs when text continues to be composed via an input method editor (IME). (Inherited from System.Windows.UIElement)
Public Event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from System.Windows.FrameworkElement)
Top
See Also

Reference

StretchHandle Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Methods$$

StretchHandle Class Methods

Lassalle.Silverlight.Flow Namespace : StretchHandle Class

For a list of all members of this type, see StretchHandle members.

Public Methods
 | Name | Description
Public Method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from System.Windows.UIElement)
Public Method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from System.Windows.Controls.Control)
Public Method | Arrange | Positions child objects and determines a size for a System.Windows.UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | CaptureMouse | Sets mouse capture to a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | ClearValue | Clears the local value of a dependency property. (Inherited from System.Windows.DependencyObject)
Public Method | FindName | Retrieves an object that has the specified identifier name. (Inherited from System.Windows.FrameworkElement)
Public Method | Focus | Attempts to set the focus on the control. (Inherited from System.Windows.Controls.Control)
Public Method | GetAnimationBaseValue | Returns any base value established for a Silverlight dependency property, which would apply in cases where an animation is not active. (Inherited from System.Windows.DependencyObject)
Public Method | GetBindingExpression | Retrieves the System.Windows.Data.BindingExpression for a dependency property where a binding is established. (Inherited from System.Windows.FrameworkElement)
Public Method | GetValue | Returns the current effective value of a dependency property from a System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateArrange | Invalidates the arrange state (layout) for a System.Windows.UIElement. After the invalidation, the System.Windows.UIElement will have its layout updated, which will occur asynchronously. (Inherited from System.Windows.UIElement)
Public Method | InvalidateMeasure | Invalidates the measurement state (layout) for a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | Measure | Updates the System.Windows.UIElement.DesiredSize of a System.Windows.UIElement. Typically, objects that implement custom layout for their layout children call this method from their own System.Windows.FrameworkElement.MeasureOverride(System.Windows.Size) implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call System.Windows.Controls.Control.ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in an application. For more information, see Remarks. (Inherited from System.Windows.FrameworkElement)
Public Method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from System.Windows.DependencyObject)
Public Method | ReleaseMouseCapture | Removes mouse capture from a System.Windows.UIElement. After this call, typically no object holds mouse capture. (Inherited from System.Windows.UIElement)
Public Method | RemoveHandler | Removes the specified routed event handler from this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | SetBinding | Attaches a binding to a System.Windows.FrameworkElement, using the provided binding object, and returns a System.Windows.Data.BindingExpressionBase for possible later use. (Inherited from System.Windows.FrameworkElement)
Public Method | SetValue | (Inherited from System.Windows.DependencyObject)
Public Method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the System.Windows.UIElement to the specified object. (Inherited from System.Windows.UIElement)
Public Method | UpdateLayout | Ensures that all positions of child objects of a System.Windows.UIElement are properly updated for layout. (Inherited from System.Windows.UIElement)
Top
Protected Methods
 | Name | Description
Protected Method | ArrangeOverride | (Inherited from System.Windows.FrameworkElement)
Protected Method | GetTemplateChild | Retrieves the named element in the instantiated System.Windows.Controls.ControlTemplate visual tree. (Inherited from System.Windows.Controls.Control)
Protected Method | MeasureOverride | (Inherited from System.Windows.FrameworkElement)
Protected Method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific System.Windows.Automation.Peers.AutomationPeer implementations for the Silverlight automation infrastructure. (Inherited from System.Windows.UIElement)
Protected Method | OnDragEnter | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDragLeave | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDragOver | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDrop | (Inherited from System.Windows.Controls.Control)
Protected Method | OnGotFocus | (Inherited from System.Windows.Controls.Control)
Protected Method | OnKeyDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnKeyUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnLostFocus | (Inherited from System.Windows.Controls.Control)
Protected Method | OnLostMouseCapture | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseEnter | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeave | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeftButtonDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeftButtonUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseMove | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseRightButtonDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseRightButtonUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseWheel | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInput | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInputStart | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInputUpdate | (Inherited from System.Windows.Controls.Control)
Top
See Also

Reference

StretchHandle Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Events$$

ZoomingBox Class Events

Lassalle.Silverlight.Flow Namespace : ZoomingBox Class

For a list of all members of this type, see ZoomingBox members.

Public Events
 | Name | Description
Public Event | BindingValidationError | Occurs when a data validation error is reported by a binding source. (Inherited from System.Windows.FrameworkElement)
Public Event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from System.Windows.FrameworkElement)
Public Event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from System.Windows.UIElement)
Public Event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from System.Windows.UIElement)
Public Event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from System.Windows.UIElement)
Public Event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from System.Windows.UIElement)
Public Event | GotFocus | Occurs when a System.Windows.UIElement receives focus. (Inherited from System.Windows.UIElement)
Public Event | IsEnabledChanged | Occurs when the System.Windows.Controls.Control.IsEnabled property changes. (Inherited from System.Windows.Controls.Control)
Public Event | KeyDown | Occurs when a keyboard key is pressed while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | KeyUp | Occurs when a keyboard key is released while the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | Occurs when the layout of the Silverlight visual tree changes. (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | Occurs when a System.Windows.FrameworkElement has been constructed and added to the object tree. (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | Occurs when a System.Windows.UIElement loses focus. (Inherited from System.Windows.UIElement)
Public Event | LostMouseCapture | Occurs when the System.Windows.UIElement loses mouse capture. (Inherited from System.Windows.UIElement)
Public Event | MediaCommand | Occurs when a button is pressed on a remote control. (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | Occurs when the mouse (or a stylus) enters the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | Occurs when the mouse (or the stylus) leaves the bounding area of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | Occurs when the left mouse button is pressed (or when the tip of the stylus touches the tablet) while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | Occurs when the left mouse button is released (or the tip of the stylus is removed from the tablet) while the mouse (or the stylus) is over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseMove | Occurs when the coordinate position of the mouse (or stylus) changes while over a System.Windows.UIElement (or while a System.Windows.UIElement holds mouse capture). (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over a System.Windows.UIElement. However, this event will only be raised if a caller marks the preceding System.Windows.UIElement.MouseRightButtonDown event as handled; see Remarks. (Inherited from System.Windows.UIElement)
Public Event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over a System.Windows.UIElement, or the System.Windows.UIElement has focus. (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | Occurs when either the System.Windows.FrameworkElement.ActualHeight or the System.Windows.FrameworkElement.ActualWidth properties change value on a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Event | TextInput | Occurs when a UI element gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputStart | Occurs when a UI element initially gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | TextInputUpdate | Occurs when text continues to be composed via an input method editor (IME). (Inherited from System.Windows.UIElement)
Public Event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from System.Windows.FrameworkElement)
Top
See Also

Reference

ZoomingBox Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Methods$$

ZoomingBox Class Methods

Lassalle.Silverlight.Flow Namespace : ZoomingBox Class

For a list of all members of this type, see ZoomingBox members.

Public Methods
 | Name | Description
Public Method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from System.Windows.UIElement)
Public Method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from System.Windows.Controls.Control)
Public Method | Arrange | Positions child objects and determines a size for a System.Windows.UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | CaptureMouse | Sets mouse capture to a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | ClearValue | Clears the local value of a dependency property. (Inherited from System.Windows.DependencyObject)
Public Method | FindName | Retrieves an object that has the specified identifier name. (Inherited from System.Windows.FrameworkElement)
Public Method | Focus | Attempts to set the focus on the control. (Inherited from System.Windows.Controls.Control)
Public Method | GetAnimationBaseValue | Returns any base value established for a Silverlight dependency property, which would apply in cases where an animation is not active. (Inherited from System.Windows.DependencyObject)
Public Method | GetBindingExpression | Retrieves the System.Windows.Data.BindingExpression for a dependency property where a binding is established. (Inherited from System.Windows.FrameworkElement)
Public Method | GetValue | Returns the current effective value of a dependency property from a System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateArrange | Invalidates the arrange state (layout) for a System.Windows.UIElement. After the invalidation, the System.Windows.UIElement will have its layout updated, which will occur asynchronously. (Inherited from System.Windows.UIElement)
Public Method | InvalidateMeasure | Invalidates the measurement state (layout) for a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | Measure | Updates the System.Windows.UIElement.DesiredSize of a System.Windows.UIElement. Typically, objects that implement custom layout for their layout children call this method from their own System.Windows.FrameworkElement.MeasureOverride(System.Windows.Size) implementations to form a recursive layout update. (Inherited from System.Windows.UIElement)
Public Method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call System.Windows.Controls.Control.ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in an application. For more information, see Remarks. (Inherited from System.Windows.FrameworkElement)
Public Method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from System.Windows.DependencyObject)
Public Method | ReleaseMouseCapture | Removes mouse capture from a System.Windows.UIElement. After this call, typically no object holds mouse capture. (Inherited from System.Windows.UIElement)
Public Method | RemoveHandler | Removes the specified routed event handler from this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Method | SetBinding | Attaches a binding to a System.Windows.FrameworkElement, using the provided binding object, and returns a System.Windows.Data.BindingExpressionBase for possible later use. (Inherited from System.Windows.FrameworkElement)
Public Method | SetValue | (Inherited from System.Windows.DependencyObject)
Public Method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the System.Windows.UIElement to the specified object. (Inherited from System.Windows.UIElement)
Public Method | UpdateLayout | Ensures that all positions of child objects of a System.Windows.UIElement are properly updated for layout. (Inherited from System.Windows.UIElement)
Top
Protected Methods
 | Name | Description
Protected Method | ArrangeOverride | (Inherited from System.Windows.FrameworkElement)
Protected Method | GetTemplateChild | Retrieves the named element in the instantiated System.Windows.Controls.ControlTemplate visual tree. (Inherited from System.Windows.Controls.Control)
Protected Method | MeasureOverride | (Inherited from System.Windows.FrameworkElement)
Protected Method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific System.Windows.Automation.Peers.AutomationPeer implementations for the Silverlight automation infrastructure. (Inherited from System.Windows.UIElement)
Protected Method | OnDragEnter | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDragLeave | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDragOver | (Inherited from System.Windows.Controls.Control)
Protected Method | OnDrop | (Inherited from System.Windows.Controls.Control)
Protected Method | OnGotFocus | (Inherited from System.Windows.Controls.Control)
Protected Method | OnKeyDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnKeyUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnLostFocus | (Inherited from System.Windows.Controls.Control)
Protected Method | OnLostMouseCapture | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseEnter | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeave | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeftButtonDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseLeftButtonUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseMove | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseRightButtonDown | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseRightButtonUp | (Inherited from System.Windows.Controls.Control)
Protected Method | OnMouseWheel | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInput | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInputStart | (Inherited from System.Windows.Controls.Control)
Protected Method | OnTextInputUpdate | (Inherited from System.Windows.Controls.Control)
Top
See Also

Reference

ZoomingBox Class
Lassalle.Silverlight.Flow Namespace


%%PageItemTitle%% $$Properties$$

ZoomingBox Class Properties

Lassalle.Silverlight.Flow Namespace : ZoomingBox Class

For a list of all members of this type, see ZoomingBox members.

Public Properties
 | Name | Description
Public Property | ActualHeight | Gets the rendered height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | Gets the rendered width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | AllowDrop | Gets or sets a value that determines whether this System.Windows.UIElement can be a drop target for purposes of Silverlight drag-and-drop operations. (Inherited from System.Windows.UIElement)
Public Property | Background | Gets or sets a brush that provides the background of the control. (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from System.Windows.Controls.Control)
Public Property | CacheMode | Gets or sets a value that indicates that rendered content should be cached when possible. (Inherited from System.Windows.UIElement)
Public Property | CharacterSpacing | Gets or sets the distance between characters of text in the control measured in 1000ths of the font size. (Inherited from System.Windows.Controls.Control)
Public Property | Clip | Gets or sets the System.Windows.Media.Geometry used to define the outline of the contents of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | Cursor | Gets or sets the cursor image that displays while the mouse pointer is over a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | Gets or sets the data context for a System.Windows.FrameworkElement when it participates in data binding. (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | Gets the size that this System.Windows.UIElement computed during the measure pass of the layout process. (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | Gets the System.Windows.Threading.Dispatcher this object is associated with. (Inherited from System.Windows.DependencyObject)
Public Property | Effect | Gets or sets the pixel shader effect to use for rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | FlowDirection | Gets or sets the direction that text and other user interface elements flow within any parent element that controls their layout. (Inherited from System.Windows.FrameworkElement)
Public Property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | Gets or sets the size of the text in this control. (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from System.Windows.Controls.Control)
Public Property | Height | Gets or sets the suggested height of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | Gets or sets whether the contained area of this System.Windows.UIElement can return true values for hit testing. (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from System.Windows.Controls.Control)
Public Property | Language | Gets or sets localization/globalization language information that applies to a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | Gets or sets the outer margin of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | Gets or sets the maximum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | Gets or sets the maximum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | Gets or sets the minimum height constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | Gets or sets the minimum width constraint of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | Gets or sets the brush used to alter the opacity of regions of this object. (Inherited from System.Windows.UIElement)
Public Property | Padding | Gets or sets the padding inside a control. (Inherited from System.Windows.Controls.Control)
Public Property | Parent | Gets the parent object of this System.Windows.FrameworkElement in the object tree. (Inherited from System.Windows.FrameworkElement)
Public Property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderSize | Gets the final render size of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | Gets or sets transform information that affects the rendering position of a System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by System.Windows.UIElement.RenderTransform, relative to the bounds of the System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from System.Windows.FrameworkElement)
Public Property | Style | Gets or sets an instance System.Windows.Style that is applied for this object during rendering. (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | Gets or sets a value that modifies how tabbing and System.Windows.Controls.Control.TabIndex work for this control. (Inherited from System.Windows.Controls.Control)
Public Property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from System.Windows.FrameworkElement)
Public Property | Template | Gets or sets a control template. (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | Gets the collection of triggers for animations that are defined for a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from System.Windows.UIElement)
Public Property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a System.Windows.FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | Gets or sets the visibility of a System.Windows.UIElement. A System.Windows.UIElement that is not visible does not render and does not communicate its desired size to layout. (Inherited from System.Windows.UIElement)
Public Property | Width | Gets or sets the width of a System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Top
Protected Properties
 | Name | Description
Protected Property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from System.Windows.Controls.Control)
Top
See Also

Reference

ZoomingBox Class
Lassalle.Silverlight.Flow Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Lassalle.Silverlight.Flow Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
Lassalle.Silverlight.Flow.DoubleConverter
Lassalle.Silverlight.Flow.License
Lassalle.Silverlight.Flow.Task
Lassalle.Silverlight.Flow.AddLinkTask
Lassalle.Silverlight.Flow.AddNodeTask
Lassalle.Silverlight.Flow.InPlaceTextEditionTask
Lassalle.Silverlight.Flow.LineStyleTask
Lassalle.Silverlight.Flow.NodeLayoutTask
Lassalle.Silverlight.Flow.NodeRotateTask
Lassalle.Silverlight.Flow.RemoveLinkTask
Lassalle.Silverlight.Flow.RemoveNodeTask
Lassalle.Silverlight.Flow.SetLinkDstTask
Lassalle.Silverlight.Flow.SetLinkOrgTask
Lassalle.Silverlight.Flow.SetLinkPinDstTask
Lassalle.Silverlight.Flow.SetLinkPinOrgTask
Lassalle.Silverlight.Flow.StretchLinkTask
Lassalle.Silverlight.Flow.ZOrderTask
Lassalle.Silverlight.Flow.TaskManager
System.EventArgs
Lassalle.Silverlight.Flow.BeforeEditEventArgs
Lassalle.Silverlight.Flow.ContextHandleClickedEventArgs
Lassalle.Silverlight.Flow.DstChangedEventArgs
Lassalle.Silverlight.Flow.DstChangingEventArgs
Lassalle.Silverlight.Flow.ErrorEventArgs
Lassalle.Silverlight.Flow.LinkCreatedEventArgs
Lassalle.Silverlight.Flow.LinkDeletedEventArgs
Lassalle.Silverlight.Flow.NodeCreatedEventArgs
Lassalle.Silverlight.Flow.NodeDeletedEventArgs
Lassalle.Silverlight.Flow.OrgChangedEventArgs
Lassalle.Silverlight.Flow.OrgChangingEventArgs
Lassalle.Silverlight.Flow.SelectedNodesLayoutingEventArgs
Lassalle.Silverlight.Flow.SelectedNodesRotatingEventArgs
Lassalle.Silverlight.Flow.SelectionChangedEventArgs
Lassalle.Silverlight.Flow.ZoomedEventArgs
System.Windows.RoutedEventArgs
Lassalle.Silverlight.Flow.AfterEditEventArgs
Lassalle.Silverlight.Flow.CancelEditEventArgs
Lassalle.Silverlight.Flow.SelectedLinkStretchingEventArgs
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
Lassalle.Silverlight.Flow.BirdView
Lassalle.Silverlight.Flow.Connector
Lassalle.Silverlight.Flow.ContextHandle
Lassalle.Silverlight.Flow.Link
Lassalle.Silverlight.Flow.Pin
Lassalle.Silverlight.Flow.ResizeHandle
Lassalle.Silverlight.Flow.RotateHandle
Lassalle.Silverlight.Flow.SelectionBox
Lassalle.Silverlight.Flow.StretchHandle
Lassalle.Silverlight.Flow.ZoomingBox
System.Windows.Controls.ContentControl
Lassalle.Silverlight.Flow.Node
System.Windows.Controls.Panel
System.Windows.Controls.Canvas
Lassalle.Silverlight.Flow.AddFlow
See Also

Reference

Lassalle.Silverlight.Flow Assembly